序列化表格 (Java 2 Platform SE 6)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架

序列化表格

软件包 java.applet

类 java.applet.Applet 继承 Panel 实现 Serializable

serialVersionUID: -5836846270535785031L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
从对象输入流读取 applet。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless()
序列化字段

accessibleContext

AccessibleContext accessibleContext

类 java.applet.Applet.AccessibleApplet 继承 Panel.AccessibleAWTPanel 实现 Serializable

serialVersionUID: 8127374778187708896L

软件包 java.awt

类 java.awt.AWTError 继承 Error 实现 Serializable

serialVersionUID: -1819846354050686206L

类 java.awt.AWTEvent 继承 EventObject 实现 Serializable

serialVersionUID: -1825314779160409405L

序列化字段

bdata

byte[] bdata

id

int id
事件的 id。

另请参见：
AWTEvent.getID(), AWTEvent.AWTEvent(java.lang.Object, int)

consumed

boolean consumed
在源处理了事件之后，控制是否将事件发送回同位体，false 表示将事件发送给同位体；true 则不发送。语义事件始终具有 'true' 值，因为它们由响应低级别事件的同位体生成。

另请参见：
AWTEvent.consume(), AWTEvent.isConsumed()

类 java.awt.AWTException 继承 Exception 实现 Serializable

serialVersionUID: -1900414231151323879L

类 java.awt.AWTKeyStroke 继承 Object 实现 Serializable

serialVersionUID: -6430539691155161871L

序列化方法

readResolve

protected Object readResolve()
                      throws ObjectStreamException
返回 AWTKeyStroke 的一个缓存实例（或 AWTKeyStroke 的子类），它与此实例相等。

抛出：
ObjectStreamException
序列化字段

keyChar

char keyChar

keyCode

int keyCode

modifiers

int modifiers

onKeyRelease

boolean onKeyRelease

类 java.awt.AWTPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 8890392402588814465L

类 java.awt.BorderLayout 继承 Object 实现 Serializable

serialVersionUID: -8658291919501921765L

序列化字段

hgap

int hgap
Constructs a border layout with the horizontal gaps between components. The horizontal gap is specified by hgap.

另请参见：
BorderLayout.getHgap(), BorderLayout.setHgap(int)

vgap

int vgap
Constructs a border layout with the vertical gaps between components. The vertical gap is specified by vgap.

另请参见：
BorderLayout.getVgap(), BorderLayout.setVgap(int)

north

Component north
Constant to specify components location to be the north portion of the border layout.

另请参见：
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

west

Component west
Constant to specify components location to be the west portion of the border layout.

另请参见：
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

east

Component east
Constant to specify components location to be the east portion of the border layout.

另请参见：
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

south

Component south
Constant to specify components location to be the south portion of the border layout.

另请参见：
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

center

Component center
Constant to specify components location to be the center portion of the border layout.

另请参见：
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

firstLine

Component firstLine
A relative positioning constant, that can be used instead of north, south, east, west or center. mixing the two types of constants can lead to unpredicable results. If you use both types, the relative constants will take precedence. For example, if you add components using both the NORTH and BEFORE_FIRST_LINE constants in a container whose orientation is LEFT_TO_RIGHT, only the BEFORE_FIRST_LINE will be layed out. This will be the same for lastLine, firstItem, lastItem.

lastLine

Component lastLine
A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

firstItem

Component firstItem
A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

lastItem

Component lastItem
A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

类 java.awt.Button 继承 Component 实现 Serializable

serialVersionUID: -8774683716313001058L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收按钮激发的动作事件。未识别的键或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
Button.removeActionListener(ActionListener),
Button.addActionListener(ActionListener),
GraphicsEnvironment.isHeadless(),
Button.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流。写入可序列化 ActionListeners 的一个列表作为可选数据。检测不可序列化的 ActionListeners，不会试图对它们进行序列化。

序列数据：
以 null 终止的 0 或多对序列：该对由一个 String 和一个 Object 组成；String 指示对象的类型，它是以下类型之一：指示 ActionListener 对象的 actionListenerK
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.actionListenerK, Button.readObject(ObjectInputStream)
序列化字段

label

String label
The button's label. This value may be null.

另请参见：
Button.getLabel(), Button.setLabel(String)

actionCommand

String actionCommand
The action to be performed once a button has been pressed. This value may be null.

另请参见：
Button.getActionCommand(), Button.setActionCommand(String)

buttonSerializedDataVersion

int buttonSerializedDataVersion

类 java.awt.Button.AccessibleAWTButton 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: -5932203980244017102L

类 java.awt.Canvas 继承 Component 实现 Serializable

serialVersionUID: -2284879212465893870L

类 java.awt.Canvas.AccessibleAWTCanvas 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: -6325592262103146699L

类 java.awt.CardLayout 继承 Object 实现 Serializable

serialVersionUID: -4328196481005934313L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从流中读取可序列化的字段。

抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
向流中写入可序列化的字段。

抛出：
IOException
序列化字段

currentCard

int currentCard

hgap

int hgap

tab

Hashtable<K,V> tab
已过时，仅用于向前兼容

vector

Vector<E> vector

vgap

int vgap

类 java.awt.Checkbox 继承 Component 实现 Serializable

serialVersionUID: 7270714317450821763L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收 Checkbox 触发的项事件。忽略未被识别的键或值。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
Checkbox.removeItemListener(ItemListener),
Checkbox.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
Checkbox.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入流中。写入可序列化 ItemListeners 的一个列表作为可选数据。检测不可序列化的 ItemListeners，不要尝试对它们进行序列化。

序列数据：
null 表示终止 0 或多个对的序列；这种对是由 String 和 Object 组成的；String 指示对象类型，它为以下类型之一：itemListenerK 指示一个 ItemListener 对象
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Checkbox.readObject(ObjectInputStream)
序列化字段

label

String label
The label of the Checkbox. This field can be null.

另请参见：
Checkbox.getLabel(), Checkbox.setLabel(String)

state

boolean state
The state of the Checkbox.

另请参见：
Checkbox.getState(), Checkbox.setState(boolean)

group

CheckboxGroup group
The check box group. This field can be null indicating that the checkbox is not a group checkbox.

另请参见：
Checkbox.getCheckboxGroup(), Checkbox.setCheckboxGroup(CheckboxGroup)

checkboxSerializedDataVersion

int checkboxSerializedDataVersion

类 java.awt.Checkbox.AccessibleAWTCheckbox 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 7881579233144754107L

类 java.awt.CheckboxGroup 继承 Object 实现 Serializable

serialVersionUID: 3729780091441768983L

序列化字段

selectedCheckbox

Checkbox selectedCheckbox
The current choice.

另请参见：
CheckboxGroup.getCurrent(), CheckboxGroup.setCurrent(Checkbox)

类 java.awt.CheckboxMenuItem 继承 MenuItem 实现 Serializable

serialVersionUID: 6190621106981774043L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流。写入可序列化 ItemListeners 的一个列表作为可选数据。检测不可序列化的 ItemListeners，不要尝试对它们进行序列化。

序列数据：
以 null 终止的 0 或多对序列；该对由一个 String 和一个 Object 组成；String 指示对象的类型，它是以下类型之一：指示 ItemListener 对象的 itemListenerK
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, CheckboxMenuItem.readObject(ObjectInputStream)
序列化字段

state

boolean state
The state of a checkbox menu item

另请参见：
CheckboxMenuItem.getState(), CheckboxMenuItem.setState(boolean)

checkboxMenuItemSerializedDataVersion

int checkboxMenuItemSerializedDataVersion

类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 继承 MenuItem.AccessibleAWTMenuItem 实现 Serializable

serialVersionUID: -1122642964303476L

类 java.awt.Choice 继承 Component 实现 Serializable

serialVersionUID: -4075310674757313071L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收 Choice 项触发的项事件。忽略未被识别的键或值。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
Choice.removeItemListener(ItemListener),
Choice.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
Choice.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入流中。写入可序列化 ItemListeners 的一个列表作为可选数据。检测不可序列化的 ItemListeners，不要尝试对它们进行序列化。

序列数据：
null 表示终止 0 或多个对的序列；这种对是由 String 和 Object 组成的；String 指示对象类型，它为以下类型之一：itemListenerK 指示一个 ItemListener 对象
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Choice.readObject(ObjectInputStream)
序列化字段

pItems

Vector<E> pItems
The items for the Choice. This can be a null value.

另请参见：
Choice.add(String),
Choice.addItem(String),
Choice.getItem(int),
Choice.getItemCount(),
Choice.insert(String, int),
Choice.remove(String)

selectedIndex

int selectedIndex
The index of the current choice for this Choice or -1 if nothing is selected.

另请参见：
Choice.getSelectedItem(), Choice.select(int)

choiceSerializedDataVersion

int choiceSerializedDataVersion

类 java.awt.Choice.AccessibleAWTChoice 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 7175603582428509322L

类 java.awt.Color 继承 Object 实现 Serializable

serialVersionUID: 118526816881161077L

序列化字段

value

int value
The color value.

另请参见：
Color.getRGB()

frgbvalue

float[] frgbvalue
默认 sRGB ColorSpace 中的颜色值可看作是 float 分量（不带 alpha 值）。如果在构造对象之后颜色值为 null，则此颜色必须是用 8 位精度构造的一种 sRGB 颜色，因此要从 int 颜色值开始计算。

另请参见：
Color.getRGBColorComponents(float[]), Color.getRGBComponents(float[])

fvalue

float[] fvalue
本机 sRGB ColorSpace 中的颜色值可看作是 float 分量（不带 alpha 值）。如果在构造对象之后颜色值为 null，则此颜色必须是用 8 位精度构造的一种 sRGB 颜色，因此要从 int 颜色值开始计算。

另请参见：
Color.getRGBColorComponents(float[]), Color.getRGBComponents(float[])

falpha

float falpha
alpha 值可看作是一个 float 分量。如果 frgbvalue 为 null，那么这是一个无效数据，因此要从 int 颜色值开始计算。

另请参见：
Color.getRGBComponents(float[]), Color.getComponents(float[])

cs

ColorSpace cs
ColorSpace。如果 ColorSpace 为 null，那么其默认值为 sRGB。

另请参见：
Color.getColor(java.lang.String),
Color.getColorSpace(),
Color.getColorComponents(float[])

类 java.awt.Component 继承 Object 实现 Serializable

serialVersionUID: -7644114512714619750L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
读取 ObjectInputStream 并且如果它不为 null，则添加一个侦听器，以便接收由组件所激发的各种事件。忽略未识别的键或值。

抛出：
ClassNotFoundException
IOException
另请参见：
Component.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。将各种可序列化侦听器作为可选数据写入。检测不可序列化的侦听器并且不尝试对其进行序列化。

序列数据：
以 null 终止的 0 或多对序列；该对由一个 String 和一个 Object 组成；String 表示对象的类型并为下列类型之一（1.4 中）：componentListenerK 表示 ComponentListener 对象；focusListenerK 表示 FocusListener 对象；keyListenerK 表示 KeyListener 对象；mouseListenerK 表示 MouseListener 对象；mouseMotionListenerK 表示 MouseMotionListener 对象；InputMethodListener 表示 InputMethodListener 对象；hierarchyListenerK 表示 HierarchyListener 对象；hierarchyBoundsListenerK 表示 HierarchyBoundsListener 对象；mouseWheelListenerK 表示 MouseWheelListener 对象, 一个可选的 ComponentOrientation（在 1.2 中位于 inputMethodListener 之后）
抛出：
IOException
另请参见：
AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.componentListenerK, Component.focusListenerK, Component.keyListenerK, Component.mouseListenerK, Component.mouseMotionListenerK, Component.inputMethodListenerK, Component.hierarchyListenerK, Component.hierarchyBoundsListenerK, Component.mouseWheelListenerK, Component.readObject(ObjectInputStream)
序列化字段

x

int x
The x position of the component in the parent's coordinate system.

另请参见：
Component.getLocation()

y

int y
The y position of the component in the parent's coordinate system.

另请参见：
Component.getLocation()

width

int width
The width of the component.

另请参见：
Component.getSize()

height

int height
The height of the component.

另请参见：
Component.getSize()

foreground

Color foreground
The foreground color for this component. foreground can be null.

另请参见：
Component.getForeground(), Component.setForeground(java.awt.Color)

background

Color background
The background color for this component. background can be null.

另请参见：
Component.getBackground(), Component.setBackground(java.awt.Color)

font

Font font
The font used by this component. The font can be null.

另请参见：
Component.getFont(), Component.setFont(java.awt.Font)

peerFont

Font peerFont
The font which the peer is currently using. (null if no peer exists.)

cursor

Cursor cursor
The cursor displayed when pointer is over this component. This value can be null.

另请参见：
Component.getCursor(), Component.setCursor(java.awt.Cursor)

locale

Locale locale
The locale for the component.

另请参见：
Component.getLocale(), Component.setLocale(java.util.Locale)

ignoreRepaint

boolean ignoreRepaint
True when the object should ignore all repaint events.

从以下版本开始：
1.4
另请参见：
Component.setIgnoreRepaint(boolean), Component.getIgnoreRepaint()

visible

boolean visible
True when the object is visible. An object that is not visible is not drawn on the screen.

另请参见：
Component.isVisible(), Component.setVisible(boolean)

enabled

boolean enabled
True when the object is enabled. An object that is not enabled does not interact with the user.

另请参见：
Component.isEnabled(), Component.setEnabled(boolean)

valid

boolean valid
True when the object is valid. An invalid object needs to be layed out. This flag is set to false when the object size is changed.

另请参见：
Component.isValid(),
Component.validate(),
Component.invalidate()

dropTarget

DropTarget dropTarget
The DropTarget associated with this component.

从以下版本开始：
1.2
另请参见：
Component.setDropTarget(java.awt.dnd.DropTarget), Component.getDropTarget()

popups

Vector<E> popups
另请参见：
Component.add(java.awt.PopupMenu)

name

String name
组件名称。该字段可以为 null。

另请参见：
Component.getName(), Component.setName(String)

nameExplicitlySet

boolean nameExplicitlySet
确定是否已显示地设置了名称的布尔值。如果尚未设置名称，则 nameExplicitlySet 为 false；否则为 true。

另请参见：
Component.getName(), Component.setName(String)

focusable

boolean focusable
表示此 Component 是否可以获得焦点。

从以下版本开始：
1.4
另请参见：
Component.setFocusable(boolean), Component.isFocusable()

isFocusTraversableOverridden

int isFocusTraversableOverridden
跟踪此 Component 是否依赖于默认的焦点可遍历性。

从以下版本开始：
1.4

focusTraversalKeys

Set<E>[] focusTraversalKeys
The focus traversal keys. These keys will generate focus traversal behavior for Components for which focus traversal keys are enabled. If a value of null is specified for a traversal key, this Component inherits that traversal key from its parent. If all ancestors of this Component have null specified for that traversal key, then the current KeyboardFocusManager's default traversal key is used.

从以下版本开始：
1.4
另请参见：
Component.setFocusTraversalKeys(int, java.util.Set), Component.getFocusTraversalKeys(int)

focusTraversalKeysEnabled

boolean focusTraversalKeysEnabled
表示是否为此 Component 启用了焦点遍历键。其焦点遍历键已禁用的 Component 接收这些焦点遍历键的按键事件。其焦点遍历键已启用的 Component 不会看到这些事件；相反，会将该事件自动转换为遍历操作。

从以下版本开始：
1.4
另请参见：
Component.setFocusTraversalKeysEnabled(boolean), Component.getFocusTraversalKeysEnabled()

minSize

Dimension minSize
Minimum size. (This field perhaps should have been transient).

minSizeSet

boolean minSizeSet
Whether or not setMinimumSize has been invoked with a non-null value.

prefSize

Dimension prefSize
Preferred size. (This field perhaps should have been transient).

prefSizeSet

boolean prefSizeSet
Whether or not setPreferredSize has been invoked with a non-null value.

maxSize

Dimension maxSize
Maximum size

maxSizeSet

boolean maxSizeSet
Whether or not setMaximumSize has been invoked with a non-null value.

newEventsOnly

boolean newEventsOnly
newEventsOnly will be true if the event is one of the event types enabled for the component. It will then allow for normal processing to continue. If it is false the event is passed to the component's parent and up the ancestor tree until the event has been consumed.

另请参见：
Component.dispatchEvent(java.awt.AWTEvent)

eventMask

long eventMask
The eventMask is ONLY set by subclasses via enableEvents. The mask should NOT be set when listeners are registered so that we can distinguish the difference between when listeners request events and subclasses request them. One bit is used to indicate whether input methods are enabled; this bit is set by enableInputMethods and is on by default.

另请参见：
Component.enableInputMethods(boolean), AWTEvent

changeSupport

PropertyChangeSupport changeSupport
如果已注册了任意 PropertyChangeListener，则 changeSupport 字段负责描述它们。

从以下版本开始：
1.2
另请参见：
Component.addPropertyChangeListener(java.beans.PropertyChangeListener),
Component.removePropertyChangeListener(java.beans.PropertyChangeListener),
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

isPacked

boolean isPacked

boundsOp

int boundsOp
直接用于几何学 API（setLocation、setBounds、setSize）的伪参数，通知 setBounds 发生了什么改变。应该在 TreeLock 下使用。需要它的唯一原因是无法改变公共和否决方法的交叉调用顺序。

componentSerializedDataVersion

int componentSerializedDataVersion
序列化的 Component 数据版本。

accessibleContext

AccessibleContext accessibleContext

类 java.awt.Component.AccessibleAWTComponent 继承 AccessibleContext 实现 Serializable

serialVersionUID: 642321655757800191L

序列化字段

accessibleAWTComponentHandler

ComponentListener accessibleAWTComponentHandler

accessibleAWTFocusHandler

FocusListener accessibleAWTFocusHandler

类 java.awt.ComponentOrientation 继承 Object 实现 Serializable

serialVersionUID: -4113291392143563828L

序列化字段

orientation

int orientation

类 java.awt.Container 继承 Component 实现 Serializable

serialVersionUID: 4613797578919906343L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化来自指定 ObjectInputStream 的 Container。
  • 从流中读取默认可序列化字段。
  • 读取可序列化 ContainerListener(s) 的一个列表作为可选数据。如果列表为 null，则不安装任何 Listener。
  • 读取此 Container 的 FocusTraversalPolicy 作为可选数据，它可以为 null。

抛出：
ClassNotFoundException
IOException
另请参见：
Container.addContainerListener(java.awt.event.ContainerListener), Container.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此 Container 序列化到指定的 ObjectOutputStream 中。
  • 将默认可序列化字段写入流中。
  • 写入可序列化 ContainerListener(s) 的一个列表作为可选数据。检测不可序列化的 ContainerListner(s)，不要试图对它们进行序列化。
  • 当且仅当此 Container 的 FocusTraversalPolicy 是可序列化的时候，才写入它；否则写入 null。

序列数据：
null 表示终止 0 或多个对的序列；这种对是由 String 和 Object 组成的；String 指示了对象类型，它为以下类型之一：指示 ContainerListener 对象的 containerListenerK、Container 的 FocusTraversalPolicy 或 null
抛出：
IOException
另请参见：
AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.containerListenerK, Container.readObject(ObjectInputStream)
序列化字段

component

Component[] component
容器中的组件。

containerSerializedDataVersion

int containerSerializedDataVersion
Container Serial Data Version。

dispatcher

java.awt.LightweightDispatcher dispatcher
轻量级组件的事件路由器。如果容器是本机的，则此调度程序会小心转发这些事件，将它们的目标重新指向所包含的轻量级组件（如果有）。

focusCycleRoot

boolean focusCycleRoot
指示此 Component 是否是某个焦点遍历循环的根。一旦焦点进入某个遍历循环，它通常无法通过焦点遍历离开，除非按下向上键或向下键之一。普通遍历被限定于此 Container，该 Container 的所有子代并不是下级焦点循环根的子代。

focusTraversalPolicyProvider

boolean focusTraversalPolicyProvider
存储 focusTraversalPolicyProvider 属性的值。

layoutMgr

LayoutManager layoutMgr
此容器的布局管理器。

maxSize

Dimension maxSize
此 Container 的最大大小。

ncomponents

int ncomponents
容器中组件的数量。该值可以为 null。

类 java.awt.Container.AccessibleAWTContainer 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 5081320404842566097L

序列化字段

accessibleContainerHandler

ContainerListener accessibleContainerHandler

类 java.awt.ContainerOrderFocusTraversalPolicy 继承 FocusTraversalPolicy 实现 Serializable

serialVersionUID: 486933713763926351L

序列化字段

implicitDownCycleTraversal

boolean implicitDownCycleTraversal

类 java.awt.Cursor 继承 Object 实现 Serializable

serialVersionUID: 8028237497568985504L

序列化字段

type

int type
The chosen cursor type initially set to the DEFAULT_CURSOR.

另请参见：
Cursor.getType()

name

String name
光标的用户可视名称。

另请参见：
Cursor.getName()

类 java.awt.DefaultFocusTraversalPolicy 继承 ContainerOrderFocusTraversalPolicy 实现 Serializable

serialVersionUID: 8876966522510157497L

类 java.awt.Dialog 继承 Window 实现 Serializable

serialVersionUID: 5920926903803293709L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
抛出：
ClassNotFoundException
IOException
HeadlessException
序列化字段

resizable

boolean resizable
A dialog's resizable property. Will be true if the Dialog is to be resizable, otherwise it will be false.

另请参见：
Dialog.setResizable(boolean)

undecorated

boolean undecorated
This field indicates whether the dialog is undecorated. This property can only be changed while the dialog is not displayable. undecorated will be true if the dialog is undecorated, otherwise it will be false.

从以下版本开始：
1.4
另请参见：
Dialog.setUndecorated(boolean),
Dialog.isUndecorated(),
Component.isDisplayable()

modal

boolean modal
True if this dialog is modal, false is the dialog is modeless. A modal dialog blocks user input to some application top-level windows. This field is kept only for backwards compatibility. Use the ModalityType enum instead.

另请参见：
Dialog.isModal(), Dialog.setModal(boolean), Dialog.getModalityType(), Dialog.setModalityType(java.awt.Dialog.ModalityType), Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE

modalityType

Dialog.ModalityType modalityType
Modality type of this dialog. If the dialog's modality type is not ModalityType.MODELESS, it blocks all user input to some application top-level windows.

从以下版本开始：
1.6
另请参见：
Dialog.ModalityType, Dialog.getModalityType(), Dialog.setModalityType(java.awt.Dialog.ModalityType)

title

String title
Specifies the title of the Dialog. This field can be null.

另请参见：
Dialog.getTitle(), Dialog.setTitle(String)

类 java.awt.Dialog.AccessibleAWTDialog 继承 Window.AccessibleAWTWindow 实现 Serializable

serialVersionUID: 4837230331833941201L

类 java.awt.Dimension 继承 Dimension2D 实现 Serializable

serialVersionUID: 4723952579491349524L

序列化字段

width

int width
dimension 的宽度，可以使用负值。

从以下版本开始：
1.0
另请参见：
Dimension.getSize(), Dimension.setSize(double, double)

height

int height
dimension 的高度，可以使用负值。

从以下版本开始：
1.0
另请参见：
Dimension.getSize(), Dimension.setSize(double, double)

类 java.awt.Event 继承 Object 实现 Serializable

serialVersionUID: 5488922509400504703L

序列化字段

target

Object target
目标组件。这指示事件针对该组件发生，或事件与该组件关联。此对象已经由 AWTEvent.getSource() 取代。

另请参见：
EventObject.getSource()

when

long when
时间戳。由 InputEvent.getWhen() 取代。

另请参见：
InputEvent.getWhen()

id

int id
指示事件是什么类型的事件，其他哪个 Event 变量与该事件有关。它已经由 AWTEvent.getID() 取代。

另请参见：
AWTEvent.getID()

x

int x
事件的 x 坐标。由 MouseEvent.getX() 取代。

另请参见：
MouseEvent.getX()

y

int y
事件的 y 坐标。由 MouseEvent.getY() 取代。

另请参见：
MouseEvent.getY()

key

int key
在键盘事件中被按下的键的键代码。这已经由 KeyEvent.getKeyCode() 取代。

另请参见：
KeyEvent.getKeyCode()

modifiers

int modifiers
修饰符键的状态。这已经由 InputEvent.getModifiers() 取代。在 java 1.1 中，MouseEvent 和 KeyEvent 是 InputEvent 的子类。

另请参见：
InputEvent.getModifiers()

clickCount

int clickCount
对于 MOUSE_DOWN 事件来说，此字段指示连续点击的次数。对于其他事件，其值为 0。此字段由 MouseEvent.getClickCount() 取代。

另请参见：
MouseEvent.getClickCount().

arg

Object arg
事件的任意参数。此字段的值取决于事件的类型。arg 已经由事件指定的属性取代。

evt

Event evt
下一事件。将事件放入到链接列表时设置此字段。这已经由 EventQueue 取代。

另请参见：
EventQueue

consumed

boolean consumed
此字段控制当目标处理完事件时，该事件是否发送回同位体——如果为 false，则发送回同位体，如果为 true，则不发送。

另请参见：
Event.isConsumed()

类 java.awt.FileDialog 继承 Dialog 实现 Serializable

serialVersionUID: 5035145889651310422L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
读取 ObjectInputStream，并执行向后兼容检查，将 dir 或等于空字符串的 file 转换为 null。

抛出：
ClassNotFoundException
IOException
序列化字段

mode

int mode

dir

String dir

file

String file

filter

FilenameFilter filter

类 java.awt.FlowLayout 继承 Object 实现 Serializable

serialVersionUID: -7262534875583282631L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
从序列化流读取此对象，处理由类的较旧版本写入的对象，该版本不包含我们现在使用的所有字段。

抛出：
IOException
ClassNotFoundException
序列化字段

align

int align
align is the property that determines how each row distributes empty space. It can be one of the following values:
    LEFT RIGHT CENTER LEADING TRAILING

另请参见：
FlowLayout.getAlignment(), FlowLayout.setAlignment(int)

newAlign

int newAlign
newAlign is the property that determines how each row distributes empty space for the Java 2 platform, v1.2 and greater. It can be one of the following three values:
    LEFT RIGHT CENTER LEADING TRAILING

从以下版本开始：
1.2
另请参见：
FlowLayout.getAlignment(), FlowLayout.setAlignment(int)

hgap

int hgap
The flow layout manager allows a seperation of components with gaps. The horizontal gap will specify the space between components and between the components and the borders of the Container.

另请参见：
FlowLayout.getHgap(), FlowLayout.setHgap(int)

vgap

int vgap
The flow layout manager allows a seperation of components with gaps. The vertical gap will specify the space between rows and between the the rows and the borders of the Container.

另请参见：
FlowLayout.getHgap(), FlowLayout.setHgap(int)

alignOnBaseline

boolean alignOnBaseline
如果组件将沿着其基线对齐，则返回 true。

serialVersionOnStream

int serialVersionOnStream
表示正被使用的 currentSerialVersion。它将是以下两个值之一：0，Java 2 平台 v1.2 之前的版本1，Java 2 平台 v1.2 之后的版本

从以下版本开始：
1.2

类 java.awt.Font 继承 Object 实现 Serializable

serialVersionUID: -4206021311591459213L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
读取 ObjectInputStream。未识别的密钥或值将被忽略。

抛出：
ClassNotFoundException
IOException
另请参见：
Font.writeObject(java.io.ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
将默认的可序列化字段写入流中。

抛出：
ClassNotFoundException
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Font.readObject(java.io.ObjectInputStream)
序列化字段

fRequestedAttributes

Hashtable<K,V> fRequestedAttributes
此方法现在只在序列化期间使用。它通常为 null。

另请参见：
Font.getAttributes()

name

String name
Font 的逻辑名称，它被传递到构造方法中。

从以下版本开始：
JDK1.0
另请参见：
Font.getName()

style

int style
Font 的样式，它被传递到构造方法中。此样式可以为 PLAIN、BOLD、ITALIC 或 BOLD+ITALIC。

从以下版本开始：
JDK1.0
另请参见：
Font.getStyle()

size

int size
Font 的磅值大小，舍入为整数。

从以下版本开始：
JDK1.0
另请参见：
Font.getSize()

pointSize

float pointSize
以 float 形式表示的 Font 的磅值大小。

另请参见：
Font.getSize(), Font.getSize2D()

fontSerializedDataVersion

int fontSerializedDataVersion
Font 的可序列化数据形式。

类 java.awt.FontFormatException 继承 Exception 实现 Serializable

serialVersionUID: -4481290147811361272L

类 java.awt.FontMetrics 继承 Object 实现 Serializable

serialVersionUID: 1681126225205050147L

序列化字段

font

Font font
实际的 Font，字体规格是由此创建的。它不能为 null。

另请参见：
FontMetrics.getFont()

类 java.awt.Frame 继承 Window 实现 Serializable

serialVersionUID: 2673458971256075116L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream。尝试读取一个 Image 图标，它是从 1.4 版本开始可用的可选数据。如果有一个 Image 图标不可用，但是已经检测了除 EOF 之外的所有数据，则抛出 OptionalDataException。未识别的键或值将被忽略。

抛出：
OptionalDataException - 如果某个 Image 图标不可用，但是已经检测了除 EOF 之外的所有数据
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless(),
Image,
Frame.getIconImage(),
Frame.setIconImage(Image),
Frame.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。写入可选的序列化 Image 图标，从 1.4 版本开始，该图标是可用的。

序列数据：
可选的 Image 图标
抛出：
IOException
另请参见：
Image,
Frame.getIconImage(),
Frame.setIconImage(Image),
Frame.readObject(ObjectInputStream)
序列化字段

maximizedBounds

Rectangle maximizedBounds
Maximized bounds for this frame.

从以下版本开始：
1.4
另请参见：
Frame.setMaximizedBounds(Rectangle), Frame.getMaximizedBounds()

title

String title
This is the title of the frame. It can be changed at any time. title can be null and if this is the case the title = "".

另请参见：
Frame.getTitle(), Frame.setTitle(String)

menuBar

MenuBar menuBar
The frames menubar. If menuBar = null the frame will not have a menubar.

另请参见：
Frame.getMenuBar(), Frame.setMenuBar(MenuBar)

resizable

boolean resizable
This field indicates whether the frame is resizable. This property can be changed at any time. resizable will be true if the frame is resizable, otherwise it will be false.

另请参见：
Frame.isResizable()

undecorated

boolean undecorated
This field indicates whether the frame is undecorated. This property can only be changed while the frame is not displayable. undecorated will be true if the frame is undecorated, otherwise it will be false.

从以下版本开始：
1.4
另请参见：
Frame.setUndecorated(boolean),
Frame.isUndecorated(),
Component.isDisplayable()

mbManagement

boolean mbManagement
mbManagement is only used by the Motif implementation.

state

int state

ownedWindows

Vector<E> ownedWindows

frameSerializedDataVersion

int frameSerializedDataVersion
Frame 的序列化数据版本。

类 java.awt.Frame.AccessibleAWTFrame 继承 Window.AccessibleAWTWindow 实现 Serializable

serialVersionUID: -6172960752956030250L

类 java.awt.GraphicsConfigTemplate 继承 Object 实现 Serializable

serialVersionUID: -8061369279557787079L

类 java.awt.GridBagConstraints 继承 Object 实现 Serializable

serialVersionUID: -1000070633030801713L

序列化字段

gridx

int gridx
指定包含组件的显示区域开始边的单元格，其中行的第一个单元格为 gridx=0。组件显示区域的开始边指的是水平的、从左到右的容器的左边缘，以及水平的、从右到左的容器的右边缘。值 RELATIVE 指定将组件放置在添加此组件之前刚刚添加到容器中的组件的后面。

默认值为 RELATIVE。gridx 应为非负值。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.gridy, ComponentOrientation

gridy

int gridy
指定位于组件显示区域的顶部的单元格，其中最上边的单元格为 gridy=0。值 RELATIVE 指定将组件放置在添加此组件之前刚刚添加到容器中的组件的下面。

默认值为 RELATIVE。gridy 应为非负值。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.gridx

gridwidth

int gridwidth
指定组件显示区域的某一行中的单元格数。

使用 REMAINDER 指定组件的显示区域，该区域的范围是从 gridx 到该行的最后一个单元格。使用 RELATIVE 指定组件的显示区域，该区域的范围是从 gridx 到它所在行的倒数第二个单元格。

gridwidth 应为非负，默认值为 1。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.gridheight

gridheight

int gridheight
指定在组件显示区域的一列中的单元格数。

使用 REMAINDER 指定组件的显示区域，该区域的范围是从 gridy 到该列的最后一个单元格。使用 RELATIVE 指定组件的显示区域，该区域的范围是从 gridy 到它所在列的倒数第二个单元格。

gridheight 应为非负，默认值为 1。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.gridwidth

weightx

double weightx
指定如何分布额外的水平空间。

网格包布局管理器计算出列的权重将是列的所有组件中最大的 weightx。如果得到的布局在水平方向上比需要填充的区域小，那么系统会将额外的空间按照其权重比例分布到每一列。权重为零的列不会得到额外的空间。

如果所有的权重都为零，则所有的额外空间都将出现在单元格的网格之间和左右边缘之间。

此字段的默认值为 0。weightx 应为非负值。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.weighty

weighty

double weighty
指定如何分布额外的垂直空间。

网格包布局管理器计算出行的权重将是行的所有组件中最大的 weighty。如果得到的布局在垂直方向上比需要填充的区域小，则系统会将额外的空间按照其权重比例分布到每一行。权重为零的行不会得到额外的空间。

如果所有的权重都为零，则所有的额外空间都将出现在单元格的网格之间和上下边缘之间。

此字段的默认值为 0。weighty 应为非负值。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.weightx

anchor

int anchor
当组件小于其显示区域时使用此字段。它可以确定在显示区域中放置组件的位置。

可能的值有三种：相对于方向的值、相对于基线的值和绝对值。相对于方向的值是相对于容器的组件方向属性进行解释的，相对于基线值是相对于基线进行解释的，绝对值则不然。绝对值有：CENTER、NORTH、NORTHEAST、EAST、SOUTHEAST、SOUTH、SOUTHWEST、WEST 和 NORTHWEST。方向相对值有：PAGE_START、PAGE_END、LINE_START、LINE_END、FIRST_LINE_START、FIRST_LINE_END、LAST_LINE_START 和 LAST_LINE_END。相对于基线的值有：BASELINE、BASELINE_LEADING、BASELINE_TRAILING、ABOVE_BASELINE、ABOVE_BASELINE_LEADING、ABOVE_BASELINE_TRAILING、BELOW_BASELINE、BELOW_BASELINE_LEADING 和 BELOW_BASELINE_TRAILING。默认值为 CENTER。

另请参见：
GridBagConstraints.clone(), ComponentOrientation

fill

int fill
当组件的显示区域大于它所请求的显示区域的大小时使用此字段。它可以确定是否调整组件大小，以及在需要的时候如何进行调整。

以下值适用于 fill：

  • NONE：不调整组件大小。
  • HORIZONTAL：加宽组件，使它在水平方向上填满其显示区域，但是不改变高度。
  • VERTICAL：加高组件，使它在垂直方向上填满其显示区域，但是不改变宽度。
  • BOTH：使组件完全填满其显示区域。

默认值为 NONE。

另请参见：
GridBagConstraints.clone()

insets

Insets insets
此字段指定组件的外部填充，即组件与其显示区域边缘之间间距的最小量。

默认值为 new Insets(0, 0, 0, 0)。

另请参见：
GridBagConstraints.clone()

ipadx

int ipadx
此字段指定组件的内部填充，即给组件的最小宽度添加多大的空间。组件的宽度至少为其最小宽度加上 ipadx 像素。

默认值为 0。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.ipady

ipady

int ipady
此字段指定内部填充，即给组件的最小高度添加多大的空间。组件的高度至少为其最小高度加上 ipady 像素。

默认值为 0。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.ipadx

tempX

int tempX
Temporary place holder for the x coordinate.

tempY

int tempY
Temporary place holder for the y coordinate.

tempWidth

int tempWidth
Temporary place holder for the Width of the component.

tempHeight

int tempHeight
Temporary place holder for the Height of the component.

minWidth

int minWidth
The minimum width of the component. It is used to calculate ipady, where the default will be 0.

另请参见：
GridBagConstraints.ipady

minHeight

int minHeight
The minimum height of the component. It is used to calculate ipadx, where the default will be 0.

另请参见：
GridBagConstraints.ipadx

类 java.awt.GridBagLayout 继承 Object 实现 Serializable

serialVersionUID: 8838754796412211005L

序列化字段

comptable

Hashtable<K,V> comptable
此哈希表维持组件与其网格包约束之间的关联。comptable 中的键是组件，值是 GridBagConstraints 的实例。

另请参见：
GridBagConstraints

defaultConstraints

GridBagConstraints defaultConstraints
此字段保持包含默认值的网格包约束实例，因此如果某个组件没有与其相关联的网格包约束，则会分配给该组件一个 defaultConstraints 的副本。

另请参见：
GridBagLayout.getConstraints(Component),
GridBagLayout.setConstraints(Component, GridBagConstraints),
GridBagLayout.lookupConstraints(Component)

layoutInfo

GridBagLayoutInfo layoutInfo
此字段保持网格包的布局信息。此字段中的信息基于最近验证的网格包。如果 layoutInfo 为 null，这指示网格包中不存在组件，或者即使存在，也是尚未经过验证的组件。

另请参见：
GridBagLayout.getLayoutInfo(Container, int)

columnWidths

int[] columnWidths
此字段保持对列最小宽度的重写。如果此字段为非 null，则在计算全部最小列宽度之后将这些值应用到网格包。如果 columnWidths 的元素数多于列数，则在网格包中添加列以匹配 columnWidth 中的元素数。

另请参见：
GridBagLayout.getLayoutDimensions()

rowHeights

int[] rowHeights
此字段保持对行最小高度的重写。如果此字段为非 null，则在计算全部最小行高度之后将这些值应用到网格包。如果 rowHeights 的元素数多于行数，则在网格包中添加行以匹配 rowHeights 中的元素数。

另请参见：
GridBagLayout.getLayoutDimensions()

columnWeights

double[] columnWeights
此字段保持对列权重的重写。如果此字段为非 null，则在计算全部列权重之后将这些值应用到网格包。如果 columnWeights[i] 大于列 i 的权重，则将 columnWeights[i] 中的权重分配给列 i。如果 columnWeights 的元素数多于列数，则多余的元素将被忽略——而不会相应地创建更多列。

rowWeights

double[] rowWeights
此字段保持对行权重的重写。如果此字段为非 null，则在计算全部行权重之后将这些值应用到网格包。如果 rowWeights[i] 大于行 i 的权重，则将 rowWeights[i] 中的权重分配给行 i。如果 rowWeights 的元素多于行数，则多余的元素将被忽略——它们不会导致更多行的创建。

componentAdjusting

Component componentAdjusting
正放置的组件。这是在调用 adjustForGravity 之前设置的。

类 java.awt.GridBagLayoutInfo 继承 Object 实现 Serializable

serialVersionUID: -4899416460737170217L

序列化字段

width

int width

height

int height

startx

int startx

starty

int starty

minWidth

int[] minWidth

minHeight

int[] minHeight

weightX

double[] weightX

weightY

double[] weightY

hasBaseline

boolean hasBaseline

baselineType

short[] baselineType

maxAscent

int[] maxAscent

maxDescent

int[] maxDescent

类 java.awt.GridLayout 继承 Object 实现 Serializable

serialVersionUID: -7411804673224730901L

序列化字段

hgap

int hgap
This is the horizontal gap (in pixels) which specifies the space between columns. They can be changed at any time. This should be a non-negative integer.

另请参见：
GridLayout.getHgap(), GridLayout.setHgap(int)

vgap

int vgap
This is the vertical gap (in pixels) which specifies the space between rows. They can be changed at any time. This should be a non negative integer.

另请参见：
GridLayout.getVgap(), GridLayout.setVgap(int)

rows

int rows
This is the number of rows specified for the grid. The number of rows can be changed at any time. This should be a non negative integer, where '0' means 'any number' meaning that the number of Rows in that dimension depends on the other dimension.

另请参见：
GridLayout.getRows(), GridLayout.setRows(int)

cols

int cols
This is the number of columns specified for the grid. The number of columns can be changed at any time. This should be a non negative integer, where '0' means 'any number' meaning that the number of Columns in that dimension depends on the other dimension.

另请参见：
GridLayout.getColumns(), GridLayout.setColumns(int)

类 java.awt.HeadlessException 继承 UnsupportedOperationException 实现 Serializable

serialVersionUID: 167183644944358563L

类 java.awt.IllegalComponentStateException 继承 IllegalStateException 实现 Serializable

serialVersionUID: -1889339587208144238L

类 java.awt.Insets 继承 Object 实现 Serializable

serialVersionUID: -2272572637695466749L

序列化字段

top

int top
顶部的 inset。将此值添加到长方形的 Top，以产生一个新的 Top 位置。

另请参见：
Insets.clone()

left

int left
左边的 inset。将此值添加到长方形的 Left，以产生一个新的 Left 边缘位置。

另请参见：
Insets.clone()

bottom

int bottom
底部的 inset。从长方形的 Bottom 减去此值，以产生一个新的 Bottom 位置。

另请参见：
Insets.clone()

right

int right
右边的 inset。从长方形的 Right 减去此值，以产生一个新的 Right 边缘位置。

另请参见：
Insets.clone()

类 java.awt.Label 继承 Component 实现 Serializable

serialVersionUID: 3094126758329070636L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
从对象输入流读取标签。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless()
序列化字段

text

String text
The text of this label. This text can be modified by the program but never by the user.

另请参见：
Label.getText(), Label.setText(String)

alignment

int alignment
The label's alignment. The default alignment is set to be left justified.

另请参见：
Label.getAlignment(), Label.setAlignment(int)

类 java.awt.Label.AccessibleAWTLabel 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: -3568967560160480438L

类 java.awt.List 继承 Component 实现 Serializable

serialVersionUID: -3304312411574666869L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加侦听器以接收由 List 激活的项事件和动作事件（由存储在流中的键指定）。未识别的键或值将被忽略。

抛出：
HeadlessException - 如果为 GraphicsEnvironment.isHeadless，则返回 true
ClassNotFoundException
IOException
另请参见：
List.removeItemListener(ItemListener),
List.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
List.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。写入可序列化的 ItemListeners 和 ActionListeners 的列表作为可选数据。检测不可序列化的侦听器并且不尝试对其进行序列化。

序列数据：
null 终止 0 或更多对的序列；这些对由一个 String 和一个 Object 组成；String 指示对象类型，为以下任意一种：itemListenerK 指示一个 ItemListener 对象；actionListenerK 指示一个 ActionListener 对象。
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Component.actionListenerK, List.readObject(ObjectInputStream)
序列化字段

items

Vector<E> items
A vector created to contain items which will become part of the List Component.

另请参见：
List.addItem(String), List.getItem(int)

rows

int rows
This field will represent the number of visible rows in the List Component. It is specified only once, and that is when the list component is actually created. It will never change.

另请参见：
List.getRows()

multipleMode

boolean multipleMode
multipleMode is a variable that will be set to true if a list component is to be set to multiple selection mode, that is where the user can select more than one item in a list at one time. multipleMode will be set to false if the list component is set to single selection, that is where the user can only select one item on the list at any one time.

另请参见：
List.isMultipleMode(), List.setMultipleMode(boolean)

selected

int[] selected
selected is an array that will contain the indices of items that have been selected.

另请参见：
List.getSelectedIndexes(), List.getSelectedIndex()

visibleIndex

int visibleIndex
This variable contains the value that will be used when trying to make a particular list item visible.

另请参见：
List.makeVisible(int)

listSerializedDataVersion

int listSerializedDataVersion
List 组件的序列化数据版本 (Serialized Data Version)。

类 java.awt.List.AccessibleAWTList 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 7924617370136012829L

类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 4412022926028300317L

序列化字段

parent

List parent

indexInParent

int indexInParent

类 java.awt.MediaTracker 继承 Object 实现 Serializable

serialVersionUID: -483174189758638095L

序列化字段

target

Component target
A given Component that will be tracked by a media tracker where the image will eventually be drawn.

另请参见：
MediaTracker.MediaTracker(Component)

head

java.awt.MediaEntry head
The head of the list of Images that is being tracked by the MediaTracker.

另请参见：
MediaTracker.addImage(Image, int), MediaTracker.removeImage(Image)

类 java.awt.Menu 继承 MenuItem 实现 Serializable

serialVersionUID: -8809584163345499784L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException,
                        HeadlessException
读取 ObjectInputStream。未识别的密钥或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
IOException
ClassNotFoundException
另请参见：
GraphicsEnvironment.isHeadless(), Menu.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入流中。

抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Menu.readObject(ObjectInputStream)
序列化字段

items

Vector<E> items
A vector of the items that will be part of the Menu.

另请参见：
Menu.countItems()

tearOff

boolean tearOff
This field indicates whether the menu has the tear of property or not. It will be set to true if the menu has the tear off property and it will be set to false if it does not. A torn off menu can be deleted by a user when it is no longer needed.

另请参见：
Menu.isTearOff()

isHelpMenu

boolean isHelpMenu
This field will be set to true if the Menu in question is actually a help menu. Otherwise it will be set to false.

menuSerializedDataVersion

int menuSerializedDataVersion
菜单序列化的数据版本。

类 java.awt.Menu.AccessibleAWTMenu 继承 MenuItem.AccessibleAWTMenuItem 实现 Serializable

serialVersionUID: 5228160894980069094L

类 java.awt.MenuBar 继承 MenuComponent 实现 Serializable

serialVersionUID: -4930327919388951260L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream。未识别的键或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless(), MenuBar.writeObject(java.io.ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
将默认的可序列化字段写入流中。

抛出：
ClassNotFoundException
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), MenuBar.readObject(java.io.ObjectInputStream)
序列化字段

menus

Vector<E> menus
This field represents a vector of the actual menus that will be part of the MenuBar.

另请参见：
MenuBar.countMenus()

helpMenu

Menu helpMenu
This menu is a special menu dedicated to help. The one thing to note about this menu is that on some platforms it appears at the right edge of the menubar.

另请参见：
MenuBar.getHelpMenu(), MenuBar.setHelpMenu(Menu)

menuBarSerializedDataVersion

int menuBarSerializedDataVersion
MenuBar 的序列化数据版本。

类 java.awt.MenuBar.AccessibleAWTMenuBar 继承 MenuComponent.AccessibleAWTMenuComponent 实现 Serializable

serialVersionUID: -8577604491830083815L

类 java.awt.MenuComponent 继承 Object 实现 Serializable

serialVersionUID: -4536902356223894379L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
从对象输入流读取该菜单组件。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless()
序列化字段

font

Font font
The menu component's font. This value can be null at which point a default will be used. This defaults to null.

另请参见：
MenuComponent.setFont(Font), MenuComponent.getFont()

name

String name
该菜单组件的名称，默认为 null。

另请参见：
MenuComponent.getName(), MenuComponent.setName(String)

nameExplicitlySet

boolean nameExplicitlySet
指示是否显式设置名称的变量。如果为 true，将以显式方式设置该名称。此变量默认为 false。

另请参见：
MenuComponent.setName(String)

newEventsOnly

boolean newEventsOnly
Defaults to false.

另请参见：
MenuComponent.dispatchEvent(AWTEvent)

accessibleContext

AccessibleContext accessibleContext

类 java.awt.MenuComponent.AccessibleAWTMenuComponent 继承 AccessibleContext 实现 Serializable

serialVersionUID: -4269533416223798698L

类 java.awt.MenuItem 继承 MenuComponent 实现 Serializable

serialVersionUID: -21757335363267194L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收由 Menu 项引发的动作事件。未识别的键或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
MenuItem.removeActionListener(ActionListener),
MenuItem.addActionListener(ActionListener),
MenuItem.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。将一个可序列化的 ActionListeners 列表作为可选数据写入。检测不可序列化的侦听器并且不尝试对其进行序列化。

序列数据：
null 表示终止 0 或更多对的序列；这种对是由 String 和 Object 组成的；String 指示对象类型，它为以下类型之一：指示 ActionListener 对象的 actionListenerK
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), MenuItem.readObject(ObjectInputStream)
序列化字段

enabled

boolean enabled
A value to indicate whether a menu item is enabled or not. If it is enabled, enabled will be set to true. Else enabled will be set to false.

另请参见：
MenuItem.isEnabled(), MenuItem.setEnabled(boolean)

label

String label
label is the label of a menu item. It can be any string.

另请参见：
MenuItem.getLabel(), MenuItem.setLabel(String)

actionCommand

String actionCommand
This field indicates the command tha has been issued by a particular menu item. By default the actionCommand is the label of the menu item, unless it has been set using setActionCommand.

另请参见：
MenuItem.setActionCommand(String), MenuItem.getActionCommand()

eventMask

long eventMask
The eventMask is ONLY set by subclasses via enableEvents. The mask should NOT be set when listeners are registered so that we can distinguish the difference between when listeners request events and subclasses request them.

shortcut

MenuShortcut shortcut
与菜单项关联的关键字序列。注意，在 1.1.2 中，必须使用菜单项上的 setActionCommand()，才可以以快捷方式工作。

另请参见：
MenuItem.getShortcut(),
MenuItem.setShortcut(MenuShortcut),
MenuItem.deleteShortcut()

menuItemSerializedDataVersion

int menuItemSerializedDataVersion
菜单项的序列化数据版本。

类 java.awt.MenuItem.AccessibleAWTMenuItem 继承 MenuComponent.AccessibleAWTMenuComponent 实现 Serializable

serialVersionUID: -217847831945965825L

类 java.awt.MenuShortcut 继承 Object 实现 Serializable

serialVersionUID: 143448358473180225L

序列化字段

key

int key
The virtual keycode for the menu shortcut. This is the keycode with which the menu shortcut will be created. Note that it is a virtual keycode, not a character, e.g. KeyEvent.VK_A, not 'a'. Note: in 1.1.x you must use setActionCommand() on a menu item in order for its shortcut to work, otherwise it will fire a null action command.

从以下版本开始：
JDK1.1
另请参见：
MenuShortcut.getKey(), MenuShortcut.usesShiftModifier(), KeyEvent

usesShift

boolean usesShift
Indicates whether the shft key was pressed. If true, the shift key was pressed. If false, the shift key was not pressed

从以下版本开始：
JDK1.1
另请参见：
MenuShortcut.usesShiftModifier()

类 java.awt.Panel 继承 Container 实现 Serializable

serialVersionUID: -2728009084054400034L

类 java.awt.Panel.AccessibleAWTPanel 继承 Container.AccessibleAWTContainer 实现 Serializable

serialVersionUID: -6409552226660031050L

类 java.awt.Point 继承 Point2D 实现 Serializable

serialVersionUID: -5276940640259749850L

序列化字段

x

int x
此 Point 的 X 坐标。如果未设置 X 坐标，则默认为 0。

从以下版本开始：
1.0
另请参见：
Point.getLocation(), Point.move(int, int)

y

int y
此 Point 的 Y 坐标。如果未设置 Y 坐标，则默认为 0。

从以下版本开始：
1.0
另请参见：
Point.getLocation(), Point.move(int, int)

类 java.awt.Polygon 继承 Object 实现 Serializable

serialVersionUID: -6460061437900069969L

序列化字段

npoints

int npoints
点的总数。npoints 的值表示在此 Polygon 中有效的点的数量，该值可以小于 xpoints 或 ypoints 中元素的个数。此值可以为 NULL。

从以下版本开始：
1.0
另请参见：
Polygon.addPoint(int, int)

xpoints

int[] xpoints
X 坐标的数组。此数组中元素的个数可以大于此 Polygon 中 X 坐标的个数。额外的元素允许新的点添加到此 Polygon 中，而无需重新创建此数组。npoints 的值等于此 Polygon 中有效点的个数。

从以下版本开始：
1.0
另请参见：
Polygon.addPoint(int, int)

ypoints

int[] ypoints
Y 坐标的数组。此数组中元素的个数可以大于此 Polygon 中 Y 坐标的个数。额外的元素允许新的点添加到 Polygon 中，而无需重新创建此数组。npoints 的值等于此 Polygon 中有效点的个数。

从以下版本开始：
1.0
另请参见：
Polygon.addPoint(int, int)

bounds

Rectangle bounds
此 Polygon 的边界。此值可以为 null。

从以下版本开始：
1.0
另请参见：
Polygon.getBoundingBox(), Polygon.getBounds()

类 java.awt.PopupMenu 继承 Menu 实现 Serializable

serialVersionUID: -4620452533522760060L

类 java.awt.PopupMenu.AccessibleAWTPopupMenu 继承 Menu.AccessibleAWTMenu 实现 Serializable

serialVersionUID: -4282044795947239955L

类 java.awt.Rectangle 继承 Rectangle2D 实现 Serializable

serialVersionUID: -4345857070255674764L

序列化字段

x

int x
Rectangle 左上角的 X 坐标。

从以下版本开始：
1.0
另请参见：
Rectangle.setLocation(int, int), Rectangle.getLocation()

y

int y
Rectangle 左上角的 Y 坐标。

从以下版本开始：
1.0
另请参见：
Rectangle.setLocation(int, int), Rectangle.getLocation()

width

int width
Rectangle 的宽度。

从以下版本开始：
1.0
另请参见：
Rectangle.setSize(int, int), Rectangle.getSize()

height

int height
Rectangle 的高度。

从以下版本开始：
1.0
另请参见：
Rectangle.setSize(int, int), Rectangle.getSize()

类 java.awt.Scrollbar 继承 Component 实现 Serializable

serialVersionUID: 8451667562882310543L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收 Scrollbar 触发的调整事件。忽略未被识别的键或值。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless(), Scrollbar.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入流中。写入可序列化 AdjustmentListeners 的一个列表作为可选数据。检测不可序列化的侦听器并且不尝试对其进行序列化。

序列数据：
null 表示终止 0 或更多对的序列；这种对是由 String 和 Object 组成的；String 指示对象类型，它为以下类型之一：指示 AdjustmentListener 对象的 adjustmentListenerK
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.adjustmentListenerK, Scrollbar.readObject(ObjectInputStream)
序列化字段

value

int value
The value of the Scrollbar. This property must be greater than or equal to minimum and less than or equal to maximum - visibleAmount

另请参见：
Scrollbar.getValue(), Scrollbar.setValue(int)

maximum

int maximum
The maximum value of the Scrollbar. This value must be greater than the minimum value.

另请参见：
Scrollbar.getMaximum(), Scrollbar.setMaximum(int)

minimum

int minimum
The minimum value of the Scrollbar. This value must be less than the maximum value.

另请参见：
Scrollbar.getMinimum(), Scrollbar.setMinimum(int)

visibleAmount

int visibleAmount
The size of the Scrollbar's bubble. When a scroll bar is used to select a range of values, the visibleAmount represents the size of this range. This is visually indicated by the size of the bubble.

另请参见：
Scrollbar.getVisibleAmount(), Scrollbar.setVisibleAmount(int)

orientation

int orientation
The Scrollbar's orientation--being either horizontal or vertical. This value should be specified when the scrollbar is created.
orientation can be either : VERTICAL or HORIZONTAL only.

另请参见：
Scrollbar.getOrientation(), Scrollbar.setOrientation(int)

lineIncrement

int lineIncrement
The amount by which the scrollbar value will change when going up or down by a line. This value must be greater than zero.

另请参见：
Scrollbar.getLineIncrement(), Scrollbar.setLineIncrement(int)

pageIncrement

int pageIncrement
The amount by which the scrollbar value will change when going up or down by a page. This value must be greater than zero.

另请参见：
Scrollbar.getPageIncrement(), Scrollbar.setPageIncrement(int)

scrollbarSerializedDataVersion

int scrollbarSerializedDataVersion
滚动条的序列化 Data Version。

类 java.awt.Scrollbar.AccessibleAWTScrollBar 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: -344337268523697807L

类 java.awt.ScrollPane 继承 Container 实现 Serializable

serialVersionUID: 7956609840827222915L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
将默认可序列化字段读入流中。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入流中。

抛出：
IOException
序列化字段

scrollbarDisplayPolicy

int scrollbarDisplayPolicy
有三种显示滚动条的方法。此整数将显示三种显示方法之一——（SCROLLBARS_ALWAYS、SCROLLBARS_AS_NEEDED 和 SCROLLBARS_NEVER）

另请参见：
ScrollPane.getScrollbarDisplayPolicy()

vAdjustable

ScrollPaneAdjustable vAdjustable
一个可调整的垂直滚动条。注意到不必 调用三种 Adjustable 方法非常重要，这三种方法是：setMinimum()、setMaximum() 和 setVisibleAmount()。

另请参见：
ScrollPane.getVAdjustable()

hAdjustable

ScrollPaneAdjustable hAdjustable
一个可调整的水平滚动条。注意到不必 调用三种 Adjustable 方法非常重要，这三种方法是：setMinimum()、setMaximum() 和 setVisibleAmount()。

另请参见：
ScrollPane.getHAdjustable()

wheelScrollingEnabled

boolean wheelScrollingEnabled
指示是否应该在接收 MouseWheelEvent 时进行滚动。

从以下版本开始：
1.4

类 java.awt.ScrollPane.AccessibleAWTScrollPane 继承 Container.AccessibleAWTContainer 实现 Serializable

serialVersionUID: 6100703663886637L

类 java.awt.ScrollPaneAdjustable 继承 Object 实现 Serializable

serialVersionUID: -3359745691033257079L

序列化字段

sp

ScrollPane sp
此对象是其滚动条的 ScrollPane。

orientation

int orientation
此滚动条的方向。

另请参见：
ScrollPaneAdjustable.getOrientation(), Adjustable.HORIZONTAL, Adjustable.VERTICAL

value

int value
此滚动条的值。value 应该大于 minimum 且小于 maximum

另请参见：
ScrollPaneAdjustable.getValue(), ScrollPaneAdjustable.setValue(int)

minimum

int minimum
此滚动条的最小值。只能通过 ScrollPane 设置此值。

ATTN： 在当前实现中，minimum 总是为 0。只能通过 setSpan 方法更改此字段，并且 ScrollPane 总是调用 minimum 为 0 的此方法。getMinimum 方法总是返回 0 而不检查此字段。

另请参见：
ScrollPaneAdjustable.getMinimum(), ScrollPaneAdjustable.setSpan(int, int, int)

maximum

int maximum
此滚动条的最大值。只能通过 ScrollPane 设置此值。

另请参见：
ScrollPaneAdjustable.getMaximum(), ScrollPaneAdjustable.setSpan(int, int, int)

visibleAmount

int visibleAmount
此滚动条可视部分的大小。只能通过 ScrollPane 设置此值。

另请参见：
ScrollPaneAdjustable.getVisibleAmount(), ScrollPaneAdjustable.setSpan(int, int, int)

unitIncrement

int unitIncrement
当滚动条向上或向下移动一行时，滚动条值更改的量。该值应该是一个非负整数。

另请参见：
ScrollPaneAdjustable.getUnitIncrement(), ScrollPaneAdjustable.setUnitIncrement(int)

blockIncrement

int blockIncrement
当滚动条向上或向下移动一页时，滚动条值更改的量。该值应该是一个非负整数。

另请参见：
ScrollPaneAdjustable.getBlockIncrement(), ScrollPaneAdjustable.setBlockIncrement(int)

adjustmentListener

AdjustmentListener adjustmentListener

类 java.awt.SystemColor 继承 Color 实现 Serializable

serialVersionUID: 4503142729533789064L

类 java.awt.TextArea 继承 TextComponent 实现 Serializable

serialVersionUID: 3692302836626095722L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless()
序列化字段

rows

int rows
The number of rows in the TextArea. This parameter will determine the text area's height. Guaranteed to be non-negative.

另请参见：
TextArea.getRows(), TextArea.setRows(int)

columns

int columns
The number of columns in the TextArea. A column is an approximate average character width that is platform-dependent. This parameter will determine the text area's width. Guaranteed to be non-negative.

另请参见：
TextArea.setColumns(int), TextArea.getColumns()

scrollbarVisibility

int scrollbarVisibility
确定为文本区创建哪种滚动条。它可以是以下四个值之一：SCROLLBARS_BOTH = 两种滚动条都创建。
SCROLLBARS_HORIZONTAL_ONLY = 只创建水平滚动条。
SCROLLBARS_VERTICAL_ONLY = 只创建垂直滚动条。
SCROLLBARS_NONE = 不创建滚动条。

另请参见：
TextArea.getScrollbarVisibility()

textAreaSerializedDataVersion

int textAreaSerializedDataVersion
The textArea Serialized Data Version.

类 java.awt.TextArea.AccessibleAWTTextArea 继承 TextComponent.AccessibleAWTTextComponent 实现 Serializable

serialVersionUID: 3472827823632144419L

类 java.awt.TextComponent 继承 Component 实现 Serializable

serialVersionUID: -2214773872412987419L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收 TextComponent 触发的文本事件。未识别的密钥或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
另请参见：
TextComponent.removeTextListener(java.awt.event.TextListener),
TextComponent.addTextListener(java.awt.event.TextListener),
GraphicsEnvironment.isHeadless()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。写入可序列化 TextListener 的一个列表作为可选数据。检测不可序列化的 TextListener，并且不尝试对其进行序列化。

序列数据：
以 null 终止的 0 或多对序列。由 String 和 Object 组成的一对序列。String 指示对象类型，它是以下之一： textListenerK 指示 TextListener 对象。
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.textListenerK
序列化字段

text

String text
The value of the text. A null value is the same as "".

另请参见：
TextComponent.setText(String), TextComponent.getText()

editable

boolean editable
A boolean indicating whether or not this TextComponent is editable. It will be true if the text component is editable and false if not.

另请参见：
TextComponent.isEditable()

selectionStart

int selectionStart
The selection refers to the selected text, and the selectionStart is the start position of the selected text.

另请参见：
TextComponent.getSelectionStart(), TextComponent.setSelectionStart(int)

selectionEnd

int selectionEnd
The selection refers to the selected text, and the selectionEnd is the end position of the selected text.

另请参见：
TextComponent.getSelectionEnd(), TextComponent.setSelectionEnd(int)

backgroundSetByClientCode

boolean backgroundSetByClientCode

textComponentSerializedDataVersion

int textComponentSerializedDataVersion
textComponent 的 SerializedDataVersion。

checkForEnableIM

boolean checkForEnableIM

类 java.awt.TextComponent.AccessibleAWTTextComponent 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 3631432373506317811L

类 java.awt.TextField 继承 TextComponent 实现 Serializable

serialVersionUID: -2966288784432217853L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收 TextField 触发的操作事件。未识别的密钥或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
另请参见：
TextField.removeActionListener(ActionListener),
TextField.addActionListener(ActionListener),
GraphicsEnvironment.isHeadless()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。写入可序列化 ActionListener 的一个列表作为可选数据。检测不可序列化的 ActionListener，并且不尝试对其进行序列化。

序列数据：
以 null 终止的 0 或多对序列。由 String 和 Object 组成的一对序列。String 指示对象类型，它是以下类型之一：指示 ActionListener 对象的 ActionListenerK。
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.actionListenerK
序列化字段

columns

int columns
The number of columns in the text field. A column is an approximate average character width that is platform-dependent. Guaranteed to be non-negative.

另请参见：
TextField.setColumns(int), TextField.getColumns()

echoChar

char echoChar
The echo character, which is used when the user wishes to disguise the characters typed into the text field. The disguises are removed if echoChar = 0.

另请参见：
TextField.getEchoChar(),
TextField.setEchoChar(char),
TextField.echoCharIsSet()

textFieldSerializedDataVersion

int textFieldSerializedDataVersion
textField 的 Serialized Data Version。

类 java.awt.TextField.AccessibleAWTTextField 继承 TextComponent.AccessibleAWTTextComponent 实现 Serializable

serialVersionUID: 6219164359235943158L

类 java.awt.Window 继承 Container 实现 Serializable

serialVersionUID: 4497834738069338734L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream 和侦听器的可选列表，以接收由该组件引发的各种事件；并且读取子窗口（可能为 null）的列表。未识别的键或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless(), Window.writeObject(java.io.ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。将可序列化的 WindowListener 和 WindowFocusListener 的列表作为可选数据写入。将子窗口的列表作为可选数据写入。将图标图像的列表作为可选数据写入。

序列数据：
null 表示终止 0 或更多对的序列；这种对是由 String 和 Object 组成的；String 指示对象类型，它为以下类型之一：windowListenerK 指示 WindowListener 对象；windowFocusWindowK 指示 WindowFocusListener 对象；ownedWindowK 指示 Window 子对象
抛出：
IOException
另请参见：
AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.windowListenerK, Component.windowFocusListenerK, Component.ownedWindowK, Window.readObject(ObjectInputStream)
序列化字段

warningString

String warningString
This represents the warning message that is to be displayed in a non secure window. ie : a window that has a security manager installed for which calling SecurityManager.checkTopLevelWindow() is false. This message can be displayed anywhere in the window.

另请参见：
Window.getWarningString()

syncLWRequests

boolean syncLWRequests

state

int state
An Integer value representing the Window State.

从以下版本开始：
1.2
另请参见：
Window.show()

alwaysOnTop

boolean alwaysOnTop
表示窗口 always-on-top 状态的布尔值

从以下版本开始：
1.5
另请参见：
Window.setAlwaysOnTop(boolean), Window.isAlwaysOnTop()

modalExclusionType

Dialog.ModalExclusionType modalExclusionType
从以下版本开始：
1.6
另请参见：
Dialog.ModalExclusionType, Window.getModalExclusionType(), Window.setModalExclusionType(java.awt.Dialog.ModalExclusionType)

focusMgr

java.awt.FocusManager focusMgr
未使用。为序列化向后兼容性而维护。

从以下版本开始：
1.2

focusableWindowState

boolean focusableWindowState
指示此窗口是否可以成为聚焦窗口。

从以下版本开始：
1.4
另请参见：
Window.getFocusableWindowState(), Window.setFocusableWindowState(boolean)

windowSerializedDataVersion

int windowSerializedDataVersion
窗口序列化的数据版本。

locationByPlatform

boolean locationByPlatform

类 java.awt.Window.AccessibleAWTWindow 继承 Container.AccessibleAWTContainer 实现 Serializable

serialVersionUID: 4215068635060671780L

软件包 java.awt.color

类 java.awt.color.CMMException 继承 RuntimeException 实现 Serializable

类 java.awt.color.ColorSpace 继承 Object 实现 Serializable

serialVersionUID: -409452704308689724L

序列化字段

type

int type

numComponents

int numComponents

类 java.awt.color.ICC_ColorSpace 继承 ColorSpace 实现 Serializable

serialVersionUID: 3455889114070431483L

序列化字段

thisProfile

ICC_Profile thisProfile

minVal

float[] minVal

maxVal

float[] maxVal

diffMinMax

float[] diffMinMax

invDiffMinMax

float[] invDiffMinMax

needScaleInit

boolean needScaleInit

类 java.awt.color.ICC_Profile 继承 Object 实现 Serializable

serialVersionUID: -3938515861990936766L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中读取默认的可序列化字段。从流中读取 string 和 byte 数组作为额外的数据。

序列数据：
如果 profile 对象是预定义颜色空间（如 "CS_sRGB"）的某个配置文件，则 String 是 ColorSpace 类中所定义的 CS_* 常量之一。否则 string 为 null。

byte[] 数组是该配置文件的配置文件数据。对于预定义的配置文件而言，它通常为 null。

如果将该 string 识别为预定义颜色空间的常量名，则将对象解析为使用 getInstance(int cspace) 所获得的配置文件，并且忽略配置文件数据。否则将对象解析为使用 getInstance(byte[] data) 所获得的配置文件。

抛出：
IOException - 由 ObjectInputStream 抛出。
ClassNotFoundException - 由 ObjectInputStream 抛出。
另请参见：
ICC_Profile.readResolve(),
ICC_Profile.getInstance(int),
ICC_Profile.getInstance(byte[])

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流。向流中写入 string 和 byte 数组作为额外的数据。

序列数据：
如果 profile 对象是预定义颜色空间（如 "CS_sRGB"）的某个配置文件，则 String 是 ColorSpace 类中所定义的 CS_* 常量之一。否则 string 为 null。

byte[] 数组是该配置文件的配置文件数据。对于预定义的颜色空间，写入的是 null 而不是配置文件数据。如果在以后的 Java API 版本中添加了新的预定义颜色空间，则此类的以后版本中可能会选择这条道：不但写入新预定义颜色空间的颜色空间名称，而且还要写入配置文件数据，以使旧版本仍能反序列化对象。

抛出：
IOException - 由 ObjectInputStream 抛出。

readResolve

protected Object readResolve()
                      throws ObjectStreamException
解析将被反序列化为用 CMM 注册的实例的实例。

抛出：
ObjectStreamException - 不会抛出，但是要受序列化规范的限制。
从以下版本开始：
1.3
序列化字段

iccProfileSerializedDataVersion

int iccProfileSerializedDataVersion
流中其他序列化数据的格式版本。版本 1 对应于 Java 2 平台，1.3 版

从以下版本开始：
1.3

类 java.awt.color.ICC_ProfileGray 继承 ICC_Profile 实现 Serializable

类 java.awt.color.ICC_ProfileRGB 继承 ICC_Profile 实现 Serializable

类 java.awt.color.ProfileDataException 继承 RuntimeException 实现 Serializable

软件包 java.awt.datatransfer

类 java.awt.datatransfer.DataFlavor 继承 Object 实现 Serializable

serialVersionUID: 8367026044764648243L

序列化方法

readExternal

public void readExternal(ObjectInput is)
                  throws IOException,
                         ClassNotFoundException
根据 Serialized 状态还原此 DataFlavor。

抛出：
IOException - 如果发生 I/O 错误
ClassNotFoundException - 如果无法找到需要恢复的某个对象的类。

writeExternal

public void writeExternal(ObjectOutput os)
                   throws IOException
序列化此 DataFlavor。

抛出：
IOException - 包含可能发生的所有 I/O 异常

类 java.awt.datatransfer.FlavorEvent 继承 EventObject 实现 Serializable

类 java.awt.datatransfer.UnsupportedFlavorException 继承 Exception 实现 Serializable

serialVersionUID: 5383814944251665601L

软件包 java.awt.dnd

类 java.awt.dnd.DragGestureEvent 继承 EventObject 实现 Serializable

serialVersionUID: 9080172649166731306L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化此 DragGestureEvent。此方法首先为所有的非 transient 字段执行默认的反序列化。然后还要尝试反序列化此对象动作事件的 List。通过反序列化字段 events 来进行首次尝试，因为在发布版本 1.4 之前，此名称的非 transient 字段存储动作事件的 List。如果此尝试失败，则使用流中的下一个对象。如果结果 List 为 null，则设置此对象的动作事件 List 为空 List。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列化此 DragGestureEvent。当且仅当可以序列化此对象的动作事件 List 时才执行默认的序列化，然后写出该 List。如果无法序列化，则写出 null。在这种情况下，从得到的反序列化流中创建的 DragGestureEvent 将包含一个空的动作事件 List。

序列数据：
按字母顺序排列的默认可序列化字段，后跟 List 实例或 null。
抛出：
IOException
从以下版本开始：
1.4
序列化字段

dragSource

DragSource dragSource
与此 DragGestureEvent 关联的 DragSource。

component

Component component
与此 DragGestureEvent 关联的 Component。

origin

Point origin
拖动的原点。

action

int action
用户的首选操作。

类 java.awt.dnd.DragGestureRecognizer 继承 Object 实现 Serializable

serialVersionUID: 8996673345831063337L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化此 DragGestureRecognizer。此方法首先为所有的非 transient 字段执行默认的反序列化。然后通过使用流中的下一个对象，还要反序列化此对象的 DragGestureListener。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列化此 DragGestureRecognizer。此方法首先执行默认的序列化。然后当且仅当可以序列化此对象的 DragGestureListener 时将其写出。如果无法序列化，则写出 null。

序列数据：
按字母顺序排列的默认可序列化字段，后跟 DragGestureListener 或 null。
抛出：
IOException
从以下版本开始：
1.4
序列化字段

dragSource

DragSource dragSource
与此 DragGestureRecognizer 关联的 DragSource。

component

Component component
与此 DragGestureRecognizer 关联的 Component。

sourceActions

int sourceActions
此 Drag 和 Drop 操作中所用动作类型的 int 表示形式。

events

ArrayList<E> events
DragGestureRecognizer“识别”为触发拖动的“动作”事件列表（按顺序）。

类 java.awt.dnd.DragSource 继承 Object 实现 Serializable

serialVersionUID: 6236096958971414066L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化此 DragSource。此方法首先执行默认的反序列化。然后使用流中的下一个对象反序列化此对象的 FlavorMap。如果得到的 FlavorMap 为 null，则将此对象的 FlavorMap 设置为此线程的 ClassLoader 的默认 FlavorMap。然后反序列化此对象的侦听器，方法是从流中读取以 null 终止的 0 序列或者更多的键/值对：
  • 如果键对象是等于 dragSourceListenerK 的 String，则使用相应的值对象反序列化一个 DragSourceListener 并添加到此 DragSource 中。
  • 如果键对象是等于 dragSourceMotionListenerK 的 String，则使用相应的值对象反序列化一个 DragSourceMotionListener 并添加到此 DragSource 中。
  • 否则跳过该键/值对。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.4
另请参见：
SystemFlavorMap.getDefaultFlavorMap()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列化此 DragSource。此方法首先执行默认的序列化。然后当且仅当可以序列化此对象的 FlavorMap 时写出该 FlavorMap。如果无法序列化，则写出 null。然后写出向此对象注册的 Serializable 侦听器。使用以 null 终止的 0 序列或更多数据对的形式写出这些侦听器。该数据对由 String 和 Object 组成；String 指示该 Object 的类型，为以下某个值：
  • dragSourceListenerK 表示 DragSourceListener 对象；
  • dragSourceMotionListenerK 表示 DragSourceMotionListener 对象。

序列数据：
FlavorMap 实例或 null，后跟以 null 终止的 0 序列或更多数据对；该数据对由 String 和 Object 组成；String 指示该 Object 的类型，为以下某个值：
  • dragSourceListenerK 表示 DragSourceListener 对象；
  • dragSourceMotionListenerK 表示 DragSourceMotionListener 对象。
抛出：
IOException
从以下版本开始：
1.4

类 java.awt.dnd.DragSourceContext 继承 Object 实现 Serializable

serialVersionUID: -115407898692194719L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化此 DragSourceContext 此方法首先为所有的非 transient 字段执行默认的反序列化。然后通过使用流中的下两个对象，还要反序列化此对象的 Transferable 和 DragSourceListener 如果得到的 Transferable 为 null，则将此对象的 Transferable 设置为支持无 DataFlavor 的虚拟 Transferable。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列化此 DragSourceContext 此方法首先执行默认的序列化。然后当且仅当可以序列化此对象的 Transferable 时将其写出。如果无法序列化，则写出 null 在这种情况下，从得到的反序列化流中创建的 DragSourceContext 将包含一个支持无 DataFlavor 的虚拟 Transferable。最后，当且仅当可以序列化此对象的 DragSourceListener 时将其写出。如果无法序列化，则写出 null。

序列数据：
按字母顺序排列的默认可序列化字段，后跟 Transferable 实例或 null，然后是 DragSourceListener 实例或 null。
抛出：
IOException
从以下版本开始：
1.4
序列化字段

trigger

DragGestureEvent trigger
触发拖动开始的事件。

cursor

Cursor cursor
当前的拖动光标。

useCustomCursor

boolean useCustomCursor
如果使用了自定义的拖动光标，而不是默认的拖动光标，则为 true。

sourceActions

int sourceActions
DnDConstants 的位掩码，表示拖动源针对与此 DragSourceContext 关联的拖动操作所支持的放置动作集合。

类 java.awt.dnd.DragSourceDragEvent 继承 DragSourceEvent 实现 Serializable

serialVersionUID: 481346297933902471L

序列化字段

targetActions

int targetActions
目标放置动作。

dropAction

int dropAction
用户放置动作。

gestureModifiers

int gestureModifiers
与用户动作关联的输入设备修饰符状态。

invalidModifiers

boolean invalidModifiers
指示 gestureModifiers 是否无效。

类 java.awt.dnd.DragSourceDropEvent 继承 DragSourceEvent 实现 Serializable

serialVersionUID: -5571321229470821891L

序列化字段

dropSuccess

boolean dropSuccess
如果放置成功，则为 true。

dropAction

int dropAction
放置操作。

类 java.awt.dnd.DragSourceEvent 继承 EventObject 实现 Serializable

serialVersionUID: -763287114604032641L

序列化字段

locationSpecified

boolean locationSpecified
指示是否为此事件指定了光标位置的 boolean 值。

x

int x
如果为此事件指定了光标位置，则为事件发生时该光标位置的水平坐标；否则为零。

y

int y
如果为此事件指定了光标位置，则为事件发生时该光标位置的垂直坐标；否则为零。

类 java.awt.dnd.DropTarget 继承 Object 实现 Serializable

serialVersionUID: -6283860791671019047L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化此 DropTarget 此方法首先为所有的非 transient 字段执行默认的反序列化。然后还要尝试反序列化此对象的 DropTargetListener 通过反序列化字段 dtListener 来进行首次尝试，因为在发布版本 1.4 之前，此名称的非 transient 字段存储 DropTargetListener 如果此尝试失败，则使用流中的下一个对象。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列化此 DropTarget 当且仅当可以执行序列化时才执行默认的序列化，然后写出此对象的 DropTargetListener 如果无法序列化，则写出 null。

序列数据：
按字母顺序排列的默认可序列化字段，后跟 DropTargetListener 实例或 null。
抛出：
IOException
从以下版本开始：
1.4
序列化字段

dropTargetContext

DropTargetContext dropTargetContext
与此 DropTarget 关联的 DropTargetContext。

component

Component component
与此 DropTarget 关联的 Component。

actions

int actions
Default permissible actions supported by this DropTarget.

另请参见：
DropTarget.setDefaultActions(int), DropTarget.getDefaultActions()

active

boolean active
true if the DropTarget is accepting Drag & Drop operations.

类 java.awt.dnd.DropTargetContext 继承 Object 实现 Serializable

serialVersionUID: -634158968993743371L

序列化字段

dropTarget

DropTarget dropTarget
与此 DropTargetContext 相关的 DropTarget。

类 java.awt.dnd.DropTargetDragEvent 继承 DropTargetEvent 实现 Serializable

serialVersionUID: -8422265619058953682L

序列化字段

location

Point location
Component 坐标中 drag 光标的热点位置。

actions

int actions
源 drop 操作。

dropAction

int dropAction
用户 drop 操作。

类 java.awt.dnd.DropTargetDropEvent 继承 DropTargetEvent 实现 Serializable

serialVersionUID: -1721911170440459322L

序列化字段

location

Point location
Component 坐标中 drag 光标的热点位置。

actions

int actions
源 drop 操作。

dropAction

int dropAction
用户 drop 操作。

isLocalTx

boolean isLocalTx
如果源对象与目标对象处于相同的 JVM 中，则为 true。

类 java.awt.dnd.DropTargetEvent 继承 EventObject 实现 Serializable

serialVersionUID: 2821229066521922993L

序列化字段

context

DropTargetContext context
与此 DropTargetEvent 相关的 DropTargetContext。

类 java.awt.dnd.InvalidDnDOperationException 继承 IllegalStateException 实现 Serializable

类 java.awt.dnd.MouseDragGestureRecognizer 继承 DragGestureRecognizer 实现 Serializable

serialVersionUID: 6220099344182281120L

软件包 java.awt.event

类 java.awt.event.ActionEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: -7671078796273832149L

序列化字段

actionCommand

String actionCommand
The nonlocalized string that gives more details of what actually caused the event. This information is very specific to the component that fired it.

另请参见：
ActionEvent.getActionCommand()

when

long when
Timestamp of when this event occurred. Because an ActionEvent is a high- level, semantic event, the timestamp is typically the same as an underlying InputEvent.

另请参见：
ActionEvent.getWhen()

modifiers

int modifiers
This represents the key modifier that was selected, and is used to determine the state of the selected key. If no modifier has been selected it will default to zero.

另请参见：
ActionEvent.getModifiers()

类 java.awt.event.AdjustmentEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: 5700290645205279921L

序列化字段

adjustable

Adjustable adjustable
The adjustable object that fired the event.

另请参见：
AdjustmentEvent.getAdjustable()

value

int value
value will contain the new value of the adjustable object. This value will always be in a range associated adjustable object.

另请参见：
AdjustmentEvent.getValue()

adjustmentType

int adjustmentType
The adjustmentType describes how the adjustable object value has changed. This value can be increased/decreased by a block or unit amount where the block is associated with page increments/decrements, and a unit is associated with line increments/decrements.

另请参见：
AdjustmentEvent.getAdjustmentType()

isAdjusting

boolean isAdjusting
The isAdjusting is true if the event is one of the series of multiple adjustment events.

从以下版本开始：
1.4
另请参见：
AdjustmentEvent.getValueIsAdjusting()

类 java.awt.event.ComponentEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: 8101406823902992965L

类 java.awt.event.ContainerEvent 继承 ComponentEvent 实现 Serializable

serialVersionUID: -4114942250539772041L

序列化字段

child

Component child
The non-null component that is being added or removed from the Container.

另请参见：
ContainerEvent.getChild()

类 java.awt.event.FocusEvent 继承 ComponentEvent 实现 Serializable

serialVersionUID: 523753786457416396L

序列化字段

temporary

boolean temporary
A focus event can have two different levels, permanent and temporary. It will be set to true if some operation takes away the focus temporarily and intends on getting it back once the event is completed. Otherwise it will be set to false.

另请参见：
FocusEvent.isTemporary()

类 java.awt.event.HierarchyEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: -5337576970038043990L

序列化字段

changed

Component changed

changedParent

Container changedParent

changeFlags

long changeFlags

类 java.awt.event.InputEvent 继承 ComponentEvent 实现 Serializable

serialVersionUID: -2482525981698309786L

序列化字段

when

long when
The input event's Time stamp in UTC format. The time stamp indicates when the input event was created.

另请参见：
InputEvent.getWhen()

modifiers

int modifiers
The state of the modifier mask at the time the input event was fired.

另请参见：
InputEvent.getModifiers(), InputEvent.getModifiersEx(), KeyEvent, MouseEvent

类 java.awt.event.InputMethodEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: 4727190874778922661L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
如果 when 字段未出现在对象输入流中，则初始化它。在这种情况下，将通过调用 EventQueue.getMostRecentEventTime() 来初始化该字段。

抛出：
ClassNotFoundException
IOException
序列化字段

when

long when
The time stamp that indicates when the event was created.

从以下版本开始：
1.4
另请参见：
InputMethodEvent.getWhen()

类 java.awt.event.InvocationEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: 436056344909459450L

序列化字段

runnable

Runnable runnable
调用其 run() 方法的 Runnable。

notifier

Object notifier
在 Runnable.run() 方法返回之后立即调用其 notifyAll() 方法的对象（可能为 null）。

catchExceptions

boolean catchExceptions
如果 dispatch() 捕获了 Throwable 并将其存储在异常实例变量中，则设置为 true。如果设置为 false，则会将 Throwable 传播到 EventDispatchThread 的调度循环中。

exception

Exception exception
在执行 Runnable.run() 方法期间抛出的 Exception（可能为 null）。如果特定实例没有捕获异常，则此变量也为 null。

throwable

Throwable throwable
在执行 Runnable.run() 方法期间抛出的 Throwable（可能为 null）。如果特定实例没有捕获异常，则此变量也为 null。

when

long when
此事件发生时的时间戳。

另请参见：
InvocationEvent.getWhen()

类 java.awt.event.ItemEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: -608708132447206933L

序列化字段

item

Object item
The item whose selection state has changed.

另请参见：
ItemEvent.getItem()

stateChange

int stateChange
stateChange indicates whether the item was selected or deselected.

另请参见：
ItemEvent.getStateChange()

类 java.awt.event.KeyEvent 继承 InputEvent 实现 Serializable

serialVersionUID: -2352130953028126954L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
根据旧的修饰符来设置新的修饰符。键修饰符可重写与鼠标修饰符重合的部分。

抛出：
IOException
ClassNotFoundException
序列化字段

isProxyActive

boolean isProxyActive
存储本机事件调度系统的状态。如果创建事件时事件代理机制是活动的，则为 true；如果是非活动的，则为 false。该状态用于 Component.dispatchEventImpl 中，以在代理是活动的情况下正确地调度事件。

keyCode

int keyCode
The unique value assigned to each of the keys on the keyboard. There is a common set of key codes that can be fired by most keyboards. The symbolic name for a key code should be used rather than the code value itself.

另请参见：
KeyEvent.getKeyCode(), KeyEvent.setKeyCode(int)

keyChar

char keyChar
keyChar is a valid unicode character that is fired by a key or a key combination on a keyboard.

另请参见：
KeyEvent.getKeyChar(), KeyEvent.setKeyChar(char)

keyLocation

int keyLocation
The location of the key on the keyboard. Some keys occur more than once on a keyboard, e.g. the left and right shift keys. Additionally, some keys occur on the numeric keypad. This variable is used to distinguish such keys. The only legal values are KEY_LOCATION_UNKNOWN, KEY_LOCATION_STANDARD, KEY_LOCATION_LEFT, KEY_LOCATION_RIGHT, and KEY_LOCATION_NUMPAD.

另请参见：
KeyEvent.getKeyLocation()

类 java.awt.event.MouseEvent 继承 InputEvent 实现 Serializable

serialVersionUID: -991214153494842848L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
根据旧的修饰符来设置新的修饰符。

抛出：
IOException
ClassNotFoundException
序列化字段

x

int x
The mouse event's x coordinate. The x value is relative to the component that fired the event.

另请参见：
MouseEvent.getX()

y

int y
The mouse event's y coordinate. The y value is relative to the component that fired the event.

另请参见：
MouseEvent.getY()

xAbs

int xAbs
鼠标事件的 x 绝对坐标。在虚拟设备多屏幕环境中，桌面区域可以跨越多个物理屏幕设备，此坐标相对于虚拟坐标系。否则，此坐标相对于与 Component 的 GraphicsConfiguration 关联的坐标系。

yAbs

int yAbs
鼠标事件的 y 绝对坐标。在虚拟设备多屏幕环境中，桌面区域可以跨越多个物理屏幕设备，此坐标相对于虚拟坐标系。否则，此坐标相对于与 Component 的 GraphicsConfiguration 关联的坐标系。

clickCount

int clickCount
Indicates the number of quick consecutive clicks of a mouse button. clickCount will be valid for only three mouse events :
MOUSE_CLICKED, MOUSE_PRESSED and MOUSE_RELEASED. For the above, the clickCount will be at least 1. For all other events the count will be 0.

另请参见：
MouseEvent.getClickCount().

button

int button
Indicates which, if any, of the mouse buttons has changed state. The only legal values are the following constants: NOBUTTON, BUTTON1, BUTTON2 or BUTTON3.

另请参见：
MouseEvent.getButton().

popupTrigger

boolean popupTrigger
A property used to indicate whether a Popup Menu should appear with a certain gestures. If popupTrigger = false, no popup menu should appear. If it is true then a popup menu should appear.

另请参见：
PopupMenu, MouseEvent.isPopupTrigger()

类 java.awt.event.MouseWheelEvent 继承 MouseEvent 实现 Serializable

serialVersionUID: 6459879390515399677L

序列化字段

scrollType

int scrollType
Indicates what sort of scrolling should take place in response to this event, based on platform settings. Legal values are:
  • WHEEL_UNIT_SCROLL
  • WHEEL_BLOCK_SCROLL

另请参见：
MouseWheelEvent.getScrollType()

scrollAmount

int scrollAmount
Only valid for scrollType WHEEL_UNIT_SCROLL. Indicates number of units that should be scrolled per click of mouse wheel rotation, based on platform settings.

另请参见：
MouseWheelEvent.getScrollAmount(), MouseWheelEvent.getScrollType()

wheelRotation

int wheelRotation
Indicates how far the mouse wheel was rotated.

另请参见：
MouseWheelEvent.getWheelRotation()

类 java.awt.event.PaintEvent 继承 ComponentEvent 实现 Serializable

serialVersionUID: 1267492026433337593L

序列化字段

updateRect

Rectangle updateRect
This is the rectangle that represents the area on the source component that requires a repaint. This rectangle should be non null.

另请参见：
Rectangle, PaintEvent.setUpdateRect(Rectangle), PaintEvent.getUpdateRect()

类 java.awt.event.TextEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: 6269902291250941179L

类 java.awt.event.WindowEvent 继承 ComponentEvent 实现 Serializable

serialVersionUID: -1567959133147912127L

序列化字段

oldState

int oldState
TBS

newState

int newState
软件包 java.awt.font

类 java.awt.font.NumericShaper 继承 Object 实现 Serializable

序列化字段

key

int key
针对上下文成形的上下文索引，值的范围是 0 到 18

mask

int mask
此标志指示是否以上下文方式成形（高位），以及要成形哪些数字范围（0-18 位）

类 java.awt.font.TextAttribute 继承 AttributedCharacterIterator.Attribute 实现 Serializable

serialVersionUID: 7744112784117861702L

序列化方法

readResolve

protected Object readResolve()
                      throws InvalidObjectException
将反序列化的实例解析为预定义常量。

抛出：
InvalidObjectException

类 java.awt.font.TransformAttribute 继承 Object 实现 Serializable

serialVersionUID: 3356247357827709530L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
抛出：
ClassNotFoundException
IOException

readResolve

private Object readResolve()
                    throws ObjectStreamException
抛出：
ObjectStreamException
序列化字段

transform

AffineTransform transform
此 TransformAttribute 的 AffineTransform；如果 AffineTransform 为恒等变换，则为 null。

软件包 java.awt.geom

类 java.awt.geom.AffineTransform 继承 Object 实现 Serializable

serialVersionUID: 1330973210523860834L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
抛出：
ClassNotFoundException
IOException
序列化字段

m00

double m00
The X coordinate scaling element of the 3x3 affine transformation matrix.

m10

double m10
The Y coordinate shearing element of the 3x3 affine transformation matrix.

m01

double m01
The X coordinate shearing element of the 3x3 affine transformation matrix.

m11

double m11
The Y coordinate scaling element of the 3x3 affine transformation matrix.

m02

double m02
The X coordinate of the translation element of the 3x3 affine transformation matrix.

m12

double m12
The Y coordinate of the translation element of the 3x3 affine transformation matrix.

类 java.awt.geom.Arc2D.Double 继承 Arc2D 实现 Serializable

serialVersionUID: 728264085846882001L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从后跟一个指示此 Arc2D 实例类型的 byte 值的 ObjectInputStream 中读取默认可序列化字段。

序列数据：
  1. 默认可序列化字段。
  2. 后跟一个指示类型 Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE 的 byte。
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入后跟一个指示此 Arc2D 实例类型的 byte 值的 ObjectOutputStream 中。

序列数据：
  1. 默认的可序列化字段。
  2. 后跟一个指示类型 Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE 的 byte。
抛出：
IOException
序列化字段

x

double x
弧的窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

double y
弧的窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

double width
完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

height

double height
完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

start

double start
弧的起始角度（以度数表示）。

从以下版本开始：
1.2

extent

double extent
弧的角跨越（以度数表示）。

从以下版本开始：
1.2

类 java.awt.geom.Arc2D.Float 继承 Arc2D 实现 Serializable

serialVersionUID: 9130893014586380278L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从后跟一个指示此 Arc2D 实例类型的 byte 值的 ObjectInputStream 中读取默认可序列化字段。

序列数据：
  1. 默认可序列化字段。
  2. 后跟一个指示类型 Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE 的 byte。
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入后跟一个指示此 Arc2D 实例类型的 byte 值的 ObjectOutputStream 中。

序列数据：
  1. 默认可序列化字段。
  2. 后跟一个指示类型 Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE 的 byte。
抛出：
IOException
序列化字段

x

float x
弧的窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

float y
弧的窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

float width
完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

height

float height
完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

start

float start
弧的起始角度（以度数表示）。

从以下版本开始：
1.2

extent

float extent
弧的角跨越（以度数表示）。

从以下版本开始：
1.2

类 java.awt.geom.CubicCurve2D.Double 继承 CubicCurve2D 实现 Serializable

serialVersionUID: -4202960122839707295L

序列化字段

x1

double x1
三次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

double y1
三次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx1

double ctrlx1
三次曲线段第一个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly1

double ctrly1
三次曲线段第一个控制点的 Y 坐标。

从以下版本开始：
1.2

ctrlx2

double ctrlx2
三次曲线段第二个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly2

double ctrly2
三次曲线段第二个控制点的 Y 坐标。

从以下版本开始：
1.2

x2

double x2
三次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

double y2
三次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.CubicCurve2D.Float 继承 CubicCurve2D 实现 Serializable

serialVersionUID: -1272015596714244385L

序列化字段

x1

float x1
三次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

float y1
三次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx1

float ctrlx1
三次曲线段第一个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly1

float ctrly1
三次曲线段第一个控制点的 Y 坐标。

从以下版本开始：
1.2

ctrlx2

float ctrlx2
三次曲线段第二个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly2

float ctrly2
三次曲线段第二个控制点的 Y 坐标。

从以下版本开始：
1.2

x2

float x2
三次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

float y2
三次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.Ellipse2D.Double 继承 Ellipse2D 实现 Serializable

serialVersionUID: 5555464816372320683L

序列化字段

x

double x
此 Ellipse2D 的窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

double y
此 Ellipse2D 的窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

double width
此 Ellipse2D 的总宽度。

从以下版本开始：
1.2

height

double height
此 Ellipse2D 的总高度。

从以下版本开始：
1.2

类 java.awt.geom.Ellipse2D.Float 继承 Ellipse2D 实现 Serializable

serialVersionUID: -6633761252372475977L

序列化字段

x

float x
此 Ellipse2D 窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

float y
此 Ellipse2D 窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

float width
此 Ellipse2D 的总宽度。

从以下版本开始：
1.2

height

float height
此 Ellipse2D 的总高度。

从以下版本开始：
1.2

类 java.awt.geom.GeneralPath 继承 Path2D.Float 实现 Serializable

serialVersionUID: -8327096662768731142L

类 java.awt.geom.IllegalPathStateException 继承 RuntimeException 实现 Serializable

类 java.awt.geom.Line2D.Double 继承 Line2D 实现 Serializable

serialVersionUID: 7979627399746467499L

序列化字段

x1

double x1
线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

double y1
线段起始点的 Y 坐标。

从以下版本开始：
1.2

x2

double x2
线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

double y2
线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.Line2D.Float 继承 Line2D 实现 Serializable

serialVersionUID: 6161772511649436349L

序列化字段

x1

float x1
线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

float y1
线段起始点的 Y 坐标。

从以下版本开始：
1.2

x2

float x2
线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

float y2
线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.NoninvertibleTransformException 继承 Exception 实现 Serializable

类 java.awt.geom.Path2D.Double 继承 Path2D 实现 Serializable

serialVersionUID: 1826762518450014216L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从 ObjectInputStream 中读取默认的可序列化字段，然后显式序列化此路径中存储的路径段。

从 1.6 开始，没有默认的可序列化字段。

此对象的序列数据是用 writeObject 方法描述的。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.6

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入 ObjectOutputStream，然后显式序列化此路径中存储的路径段。

序列数据：
  1. 默认的可序列化字段。从 1.6 开始，没有默认的可序列化字段。
  2. 后跟一个字节，指示将初始对象的存储类型作为提示 (SERIAL_STORAGE_DBL_ARRAY)。
  3. 接着是一个整数，指示应该遵循的路径段数量 (NP)，或者为 -1 ，指示遵循未知数量的路径段。
  4. 接着又是一个整数，指示应该遵循的坐标总数 (NC)，或者为 -1，指示遵循未知的坐标数（NC 应该始终是偶数，因为坐标始终以成对的 x,y 形式出现）。
  5. 再接着是一个指示旋绕规则（WIND_EVEN_ODD 或 WIND_NON_ZERO）的字节。
  6. 再接着是由指示路径段类型的单个字节组成的值的 NP 集合（如果 NP < 0，则值是无限的），后跟表示路径段坐标的一对或多对 float 或 double 值。
  7. 最后是指示路径结尾的字节 (SERIAL_PATH_END) 。

以下字节值常量用于 Path2D 对象的序列化形式中：

常量名 | 字节值 | 后跟 | 描述
SERIAL_STORAGE_FLT_ARRAY | 0x30 | 一个提示，原始 Path2D 对象以 Java 的 float 数组形式存储于坐标中。
SERIAL_STORAGE_DBL_ARRAY | 0x31 | 一个提示，原始 Path2D 对象以 Java 的 double 数组形式存储于坐标中。
SERIAL_SEG_FLT_MOVETO | 0x40 | 2 浮点型 | 后跟一个 moveTo 路径段。
SERIAL_SEG_FLT_LINETO | 0x41 | 2 浮点型 | 后跟一个 lineTo 路径段。
SERIAL_SEG_FLT_QUADTO | 0x42 | 4 浮点型 | 后跟一个 quadTo 路径段。
SERIAL_SEG_FLT_CUBICTO | 0x43 | 6 浮点型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_DBL_MOVETO | 0x50 | 2 双精度型 | 后跟一个 moveTo 路径段。
SERIAL_SEG_DBL_LINETO | 0x51 | 2 双精度型 | 后跟一个 lineTo 路径段。
SERIAL_SEG_DBL_QUADTO | 0x52 | 4 双精度型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_DBL_CUBICTO | 0x53 | 6 双精度型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_CLOSE | 0x60 | 一个 closePath 路径段。
SERIAL_PATH_END | 0x61 | 不再有路径段跟在后面。
抛出：
IOException
从以下版本开始：
1.6

类 java.awt.geom.Path2D.Float 继承 Path2D 实现 Serializable

serialVersionUID: 6990832515060788886L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从 ObjectInputStream 中读取默认的可序列化字段，然后显式序列化此路径中存储的路径段。

从 1.6 开始，没有默认的可序列化字段。

此对象的序列数据是用 writeObject 方法描述的。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.6

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入 ObjectOutputStream，然后显式序列化此路径中存储的路径段。

序列数据：
  1. 默认的可序列化字段。从 1.6 开始，没有默认的可序列化字段。
  2. 后跟一个字节，指示将初始对象的存储类型作为提示 (SERIAL_STORAGE_FLT_ARRAY)。
  3. 接着是一个整数，指示应该遵循的路径段数量 (NP)，或者为 -1 ，指示遵循未知数量的路径段。
  4. 接着又是一个整数，指示应该遵循的坐标总数 (NC)，或者为 -1，指示遵循未知的坐标数（NC 应该始终是偶数，因为坐标始终以成对的 x,y 形式出现）。
  5. 再接着是一个指示旋绕规则（WIND_EVEN_ODD 或 WIND_NON_ZERO）的字节。
  6. 再接着是由指示路径段类型的单个字节组成的值的 NP 集合（如果 NP < 0，则值是无限的），后跟表示路径段坐标的一对或多对 float 或 double 值。
  7. 最后是指示路径结尾的字节 (SERIAL_PATH_END) 。

以下字节值常量用于 Path2D 对象的序列化形式中：

常量名 | 字节值 | 后跟 | 描述
SERIAL_STORAGE_FLT_ARRAY | 0x30 | 一个提示，原始 Path2D 对象以 Java 的 float 数组形式存储于坐标中。
SERIAL_STORAGE_DBL_ARRAY | 0x31 | 一个提示，原始 Path2D 对象以 Java 的 double 数组形式存储于坐标中。
SERIAL_SEG_FLT_MOVETO | 0x40 | 2 浮点型 | 后跟一个 moveTo 路径段。
SERIAL_SEG_FLT_LINETO | 0x41 | 2 浮点型 | 后跟一个 lineTo 路径段。
SERIAL_SEG_FLT_QUADTO | 0x42 | 4 浮点型 | 后跟一个 quadTo 路径段。
SERIAL_SEG_FLT_CUBICTO | 0x43 | 6 浮点型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_DBL_MOVETO | 0x50 | 2 双精度型 | 后跟一个 moveTo 路径段。
SERIAL_SEG_DBL_LINETO | 0x51 | 2 双精度型 | 后跟一个 lineTo 路径段。
SERIAL_SEG_DBL_QUADTO | 0x52 | 4 双精度型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_DBL_CUBICTO | 0x53 | 6 双精度型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_CLOSE | 0x60 | 一个 closePath 路径段。
SERIAL_PATH_END | 0x61 | 不再有路径段跟在后面。
抛出：
IOException
从以下版本开始：
1.6

类 java.awt.geom.Point2D.Double 继承 Point2D 实现 Serializable

serialVersionUID: 6150783262733311327L

序列化字段

x

double x
此 Point2D 的 X 坐标。

从以下版本开始：
1.2

y

double y
此 Point2D 的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.Point2D.Float 继承 Point2D 实现 Serializable

serialVersionUID: -2870572449815403710L

序列化字段

x

float x
此 Point2D 的 X 坐标。

从以下版本开始：
1.2

y

float y
此 Point2D 的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.QuadCurve2D.Double 继承 QuadCurve2D 实现 Serializable

serialVersionUID: 4217149928428559721L

序列化字段

x1

double x1
二次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

double y1
二次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx

double ctrlx
二次曲线段控制点的 X 坐标。

从以下版本开始：
1.2

ctrly

double ctrly
二次曲线段控制点的 Y 坐标。

从以下版本开始：
1.2

x2

double x2
二次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

double y2
二次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.QuadCurve2D.Float 继承 QuadCurve2D 实现 Serializable

serialVersionUID: -8511188402130719609L

序列化字段

x1

float x1
二次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

float y1
二次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx

float ctrlx
二次曲线段控制点的 X 坐标。

从以下版本开始：
1.2

ctrly

float ctrly
二次曲线段控制点的 Y 坐标。

从以下版本开始：
1.2

x2

float x2
二次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

float y2
二次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.Rectangle2D.Double 继承 Rectangle2D 实现 Serializable

serialVersionUID: 7771313791441850493L

序列化字段

x

double x
此 Rectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

double y
此 Rectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

double width
此 Rectangle2D 的宽度。

从以下版本开始：
1.2

height

double height
此 Rectangle2D 的高度。

从以下版本开始：
1.2

类 java.awt.geom.Rectangle2D.Float 继承 Rectangle2D 实现 Serializable

serialVersionUID: 3798716824173675777L

序列化字段

x

float x
此 Rectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

float y
此 Rectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

float width
此 Rectangle2D 的宽度。

从以下版本开始：
1.2

height

float height
此 Rectangle2D 的高度。

从以下版本开始：
1.2

类 java.awt.geom.RoundRectangle2D.Double 继承 RoundRectangle2D 实现 Serializable

serialVersionUID: 1048939333485206117L

序列化字段

x

double x
此 RoundRectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

double y
此 RoundRectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

double width
此 RoundRectangle2D 的宽度。

从以下版本开始：
1.2

height

double height
此 RoundRectangle2D 的高度。

从以下版本开始：
1.2

arcwidth

double arcwidth
圆角弧的宽度。

从以下版本开始：
1.2

archeight

double archeight
圆角弧的高度。

从以下版本开始：
1.2

类 java.awt.geom.RoundRectangle2D.Float 继承 RoundRectangle2D 实现 Serializable

serialVersionUID: -3423150618393866922L

序列化字段

x

float x
此 RoundRectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

float y
此 RoundRectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

float width
此 RoundRectangle2D 的宽度。

从以下版本开始：
1.2

height

float height
此 RoundRectangle2D 的高度。

从以下版本开始：
1.2

arcwidth

float arcwidth
圆角弧的宽度。

从以下版本开始：
1.2

archeight

float archeight
圆角弧的高度。

从以下版本开始：
1.2
软件包 java.awt.image

类 java.awt.image.ImagingOpException 继承 RuntimeException 实现 Serializable

类 java.awt.image.RasterFormatException 继承 RuntimeException 实现 Serializable

软件包 java.awt.image.renderable

类 java.awt.image.renderable.ParameterBlock 继承 Object 实现 Serializable

序列化字段

sources

Vector<E> sources
源的 Vector，存储为任意 Objects。

parameters

Vector<E> parameters
一个非源参数的 Vector，存储为任意 Object。

软件包 java.awt.print

类 java.awt.print.PrinterAbortException 继承 PrinterException 实现 Serializable

类 java.awt.print.PrinterException 继承 Exception 实现 Serializable

类 java.awt.print.PrinterIOException 继承 PrinterException 实现 Serializable

serialVersionUID: 5850870712125932846L

序列化字段

mException

IOException mException
终止打印作业的 IO 错误。

软件包 java.beans

类 java.beans.IndexedPropertyChangeEvent 继承 PropertyChangeEvent 实现 Serializable

序列化字段

index

int index

类 java.beans.IntrospectionException 继承 Exception 实现 Serializable

类 java.beans.PropertyChangeEvent 继承 EventObject 实现 Serializable

序列化字段

propertyName

String propertyName
已更改属性的名称。如果该名称未知，则为 null。

newValue

Object newValue
属性的新值。如果该值未知，则为 null。

oldValue

Object oldValue
属性以前的值。如果该值未知，则为 null。

propagationId

Object propagationId
传播 ID。可能为 null。

另请参见：
#getPropagationId.

类 java.beans.PropertyChangeSupport 继承 Object 实现 Serializable

serialVersionUID: 6401253773779951803L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列数据：
Null terminated list of PropertyChangeListeners。

在进行序列化时，跳过不可序列化的侦听器，只序列化可序列化的侦听器。

抛出：
IOException
序列化字段

children

Hashtable<K,V> children
管理特定属性的侦听器的哈希表。将属性名称映射到 PropertyChangeSupport 对象。

从以下版本开始：
1.2

source

Object source
将作为所有已生成事件的“源”提供的对象。

propertyChangeSupportSerializedDataVersion

int propertyChangeSupportSerializedDataVersion
内部版本号

从以下版本开始：

类 java.beans.PropertyVetoException 继承 Exception 实现 Serializable

序列化字段

evt

PropertyChangeEvent evt
描述所禁止的更改的 PropertyChangeEvent。

类 java.beans.VetoableChangeSupport 继承 Object 实现 Serializable

serialVersionUID: -5090210921595982017L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列数据：
Null terminated list of VetoableChangeListeners.

在进行序列化时，跳过不可序列化的侦听器，只序列化可序列化的侦听器。

抛出：
IOException
序列化字段

children

Hashtable<K,V> children
管理特定属性的侦听器的哈希表。将属性名称映射到 VetoableChangeSupport 对象。

从以下版本开始：
1.2

source

Object source
将作为所有已生成事件的“源”而提供的对象。

vetoableChangeSupportSerializedDataVersion

int vetoableChangeSupportSerializedDataVersion
内部版本号

软件包 java.beans.beancontext

类 java.beans.beancontext.BeanContextChildSupport 继承 Object 实现 Serializable

serialVersionUID: 6328947014421475877L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
恢复一个持久对象，必须等待后续 setBeanContext() 完全恢复从新的嵌套 BeanContext 中获得的所有资源

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
写入对象的持久状态。

抛出：
IOException
序列化字段

beanContextChildPeer

BeanContextChild beanContextChildPeer
在其中嵌套此 BeanContextChild 的 BeanContext。

pcSupport

PropertyChangeSupport pcSupport
与此 BeanContextChildSupport 相关联的 PropertyChangeSupport。

vcSupport

VetoableChangeSupport vcSupport
与此 BeanContextChildSupport 相关联的 VetoableChangeSupport。

类 java.beans.beancontext.BeanContextEvent 继承 EventObject 实现 Serializable

序列化字段

propagatedFrom

BeanContext propagatedFrom
作为此事件传播源的 BeanContext

类 java.beans.beancontext.BeanContextMembershipEvent 继承 BeanContextEvent 实现 Serializable

序列化字段

children

Collection<E> children
受此事件通知影响的子级的列表。

类 java.beans.beancontext.BeanContextServiceAvailableEvent 继承 BeanContextEvent 实现 Serializable

序列化字段

serviceClass

Class<T> serviceClass
新近可用服务的 Class 引用

类 java.beans.beancontext.BeanContextServiceRevokedEvent 继承 BeanContextEvent 实现 Serializable

序列化字段

serviceClass

Class<T> serviceClass
将被取消服务的 Class 引用。

invalidateRefs

boolean invalidateRefs

类 java.beans.beancontext.BeanContextServicesSupport 继承 BeanContextSupport 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
反序列化实例。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
序列化实例。

抛出：
IOException

类 java.beans.beancontext.BeanContextServicesSupport.BCSSChild 继承 BeanContextSupport.BCSChild 实现 Serializable

serialVersionUID: -3263851306889194873L

类 java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider 继承 Object 实现 Serializable

序列化字段

serviceProvider

BeanContextServiceProvider serviceProvider

类 java.beans.beancontext.BeanContextSupport 继承 BeanContextChildSupport 实现 Serializable

serialVersionUID: -4879613978649577204L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
反序列化内容。如果此实例有截然不同的同位体，则子级在这里“不”被序列化，同位体的 readObject() 必须在反序列化此实例之后调用 readChildren()。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException,
                         ClassNotFoundException
序列化 BeanContextSupport，如果此实例有一个截然不同的同位体（即此对象正充当另一个对象的代理），则此实例的子级在这里不被序列化，因为在序列化此实例的同时反序列化其子级会产生“先有鸡还是先有蛋”的问题。 所以，在具有此实例的截然不同同位体的情况下，应该总是在调用 writeObject() 之后调用 writeChildren()，并在调用 readObject() 之后调用 readChildren()。

抛出：
IOException
ClassNotFoundException
序列化字段

serializable

int serializable

locale

Locale locale
此 BeanContext 的当前语言环境。

okToUseGui

boolean okToUseGui
指示此实例现在能否呈现 GUI 的 boolean 值。

designTime

boolean designTime
指示此对象目前是否处于设计时间模式下的 boolean 值。

类 java.beans.beancontext.BeanContextSupport.BCSChild 继承 Object 实现 Serializable

serialVersionUID: -5815286101609939109L

序列化字段

child

Object child

proxyPeer

Object proxyPeer
软件包 java.io

类 java.io.CharConversionException 继承 IOException 实现 Serializable

类 java.io.EOFException 继承 IOException 实现 Serializable

类 java.io.File 继承 Object 实现 Serializable

serialVersionUID: 301077366599181567L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject 来恢复此文件名。读取原有的分隔符字符。如果它于此系统上的分隔符字符不同，则使用本地分隔符替换原有的分隔符。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
调用 WriteObject 保存此文件名。还要保存分隔符字符，以便用不同主机类型重构该路径时可以对它进行替换。

序列数据：
Default fields followed by separator character.
抛出：
IOException
序列化字段

path

String path
此抽象路径名的规范化路径名字符串。规范化路径名字符串使用默认名称分隔符，并且不包含任何重复或多余的分隔符。

类 java.io.FileNotFoundException 继承 IOException 实现 Serializable

类 java.io.FilePermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: 2202956749081564585L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
"permissions" field (a Vector containing the FilePermissions).
抛出：
IOException
序列化字段

permissions

Vector<E> permissions
A list of FilePermission objects.

类 java.io.InterruptedIOException 继承 IOException 实现 Serializable

序列化字段

bytesTransferred

int bytesTransferred
报告 I/O 操作中断之前传输了其中多少字节。

类 java.io.InvalidClassException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: -4333316296251054416L

序列化字段

classname

String classname
无效类的名称。

无效类的名称。

类 java.io.InvalidObjectException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: 3233174318281839583L

类 java.io.IOError 继承 Error 实现 Serializable

serialVersionUID: 67100927991680413L

类 java.io.IOException 继承 Exception 实现 Serializable

serialVersionUID: 7818375828146090155L

类 java.io.NotActiveException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: -3893467273049808895L

类 java.io.NotSerializableException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: 2906642554793891381L

类 java.io.ObjectStreamClass 继承 Object 实现 Serializable

serialVersionUID: -6120832682080437368L

序列化字段

类 java.io.ObjectStreamException 继承 IOException 实现 Serializable

serialVersionUID: 7260898174833392607L

类 java.io.OptionalDataException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: -8011121865681257820L

序列化字段

length

int length
当前缓冲区中可读取的基本数据的字节数。

eof

boolean eof
如果流的缓冲部分不再有数据，则为 True。

类 java.io.SerializablePermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 8537212141160296410L

序列化字段

actions

String actions

类 java.io.StreamCorruptedException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: 8983558202217591746L

类 java.io.SyncFailedException 继承 IOException 实现 Serializable

类 java.io.UnsupportedEncodingException 继承 IOException 实现 Serializable

类 java.io.UTFDataFormatException 继承 IOException 实现 Serializable

类 java.io.WriteAbortedException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: -3326426625597282442L

序列化字段

detail

Exception detail
在写入 ObjectStream 时捕获的异常。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获得此信息的首选方法。

软件包 java.lang

类 java.lang.AbstractMethodError 继承 IncompatibleClassChangeError 实现 Serializable

类 java.lang.ArithmeticException 继承 RuntimeException 实现 Serializable

类 java.lang.ArrayIndexOutOfBoundsException 继承 IndexOutOfBoundsException 实现 Serializable

类 java.lang.ArrayStoreException 继承 RuntimeException 实现 Serializable

类 java.lang.AssertionError 继承 Error 实现 Serializable

类 java.lang.Boolean 继承 Object 实现 Serializable

serialVersionUID: -3665804199014368530L

序列化字段

value

boolean value
布尔值。

类 java.lang.Byte 继承 Number 实现 Serializable

serialVersionUID: -7183698231559129828L

序列化字段

value

byte value
Byte 的值。

类 java.lang.Character 继承 Object 实现 Serializable

serialVersionUID: 3786198910865385080L

序列化字段

value

char value
Character 的值。

类 java.lang.Class 继承 Object 实现 Serializable

serialVersionUID: 3206093459760846163L

序列化概述
Class 类是 Serialization Stream Protocol 中的一个特例。 Class 实例最初是以下列格式写入 ObjectOutputStream 的：
      TC_CLASS ClassDescriptor
      ClassDescriptor 是 java.io.ObjectStreamClass 实例的一个特殊序列化。
类描述符写入该流的初始时刻会生成一个新的句柄。未来对该类描述符的引用写作对此初始类描述符实例的引用。

另请参见：
ObjectStreamClass
序列化字段

类 java.lang.ClassCastException 继承 RuntimeException 实现 Serializable

类 java.lang.ClassCircularityError 继承 LinkageError 实现 Serializable

类 java.lang.ClassFormatError 继承 LinkageError 实现 Serializable

类 java.lang.ClassNotFoundException 继承 Exception 实现 Serializable

serialVersionUID: 9176873029745254542L

序列化字段

ex

Throwable ex
如果使用 ClassNotFoundException(String s, Throwable ex) 构造方法来实例化对象，则此字段保持异常 ex。

从以下版本开始：
1.2

类 java.lang.CloneNotSupportedException 继承 Exception 实现 Serializable

类 java.lang.Double 继承 Number 实现 Serializable

serialVersionUID: -9172774392245257468L

序列化字段

value

double value
Double 的值。

类 java.lang.Enum 继承 Object 实现 Serializable

序列化字段

name

String name
此枚举常量的名称，在枚举声明中声明。大多数程序员应该使用 Enum.toString() 方法，而不是访问此字段。

ordinal

int ordinal
此枚举常量的序数（它在枚举声明中的位置，其中初始常量序数为零）。 大多数程序员不会使用此字段。它被设计用于复杂的基于枚举的数据结构，比如 EnumSet 和 EnumMap。

类 java.lang.EnumConstantNotPresentException 继承 RuntimeException 实现 Serializable

序列化字段

enumType

Class<T> enumType
缺少的枚举常量的类型。

constantName

String constantName
缺少的枚举常量的名称。

类 java.lang.Error 继承 Throwable 实现 Serializable

serialVersionUID: 4980196508277280342L

类 java.lang.Exception 继承 Throwable 实现 Serializable

serialVersionUID: -3387516993124229948L

类 java.lang.ExceptionInInitializerError 继承 LinkageError 实现 Serializable

serialVersionUID: 1521711792217232256L

序列化字段

exception

Throwable exception
如果使用 ExceptionInInitializerError(Throwable thrown) 构造方法来实例化此对象，则该字段将保持异常

类 java.lang.Float 继承 Number 实现 Serializable

serialVersionUID: -2671257302660747028L

序列化字段

value

float value
Float 的值。

类 java.lang.IllegalAccessError 继承 IncompatibleClassChangeError 实现 Serializable

类 java.lang.IllegalAccessException 继承 Exception 实现 Serializable

类 java.lang.IllegalArgumentException 继承 RuntimeException 实现 Serializable

serialVersionUID: -5365630128856068164L

类 java.lang.IllegalMonitorStateException 继承 RuntimeException 实现 Serializable

类 java.lang.IllegalStateException 继承 RuntimeException 实现 Serializable

serialVersionUID: -1848914673093119416L

类 java.lang.IllegalThreadStateException 继承 IllegalArgumentException 实现 Serializable

类 java.lang.IncompatibleClassChangeError 继承 LinkageError 实现 Serializable

类 java.lang.IndexOutOfBoundsException 继承 RuntimeException 实现 Serializable

类 java.lang.InstantiationError 继承 IncompatibleClassChangeError 实现 Serializable

类 java.lang.InstantiationException 继承 Exception 实现 Serializable

类 java.lang.Integer 继承 Number 实现 Serializable

serialVersionUID: 1360826667806852920L

序列化字段

value

int value
Integer 的值。

类 java.lang.InternalError 继承 VirtualMachineError 实现 Serializable

类 java.lang.InterruptedException 继承 Exception 实现 Serializable

类 java.lang.LinkageError 继承 Error 实现 Serializable

类 java.lang.Long 继承 Number 实现 Serializable

serialVersionUID: 4290774380558885855L

序列化字段

value

long value
Long 的值。

类 java.lang.NegativeArraySizeException 继承 RuntimeException 实现 Serializable

类 java.lang.NoClassDefFoundError 继承 LinkageError 实现 Serializable

类 java.lang.NoSuchFieldError 继承 IncompatibleClassChangeError 实现 Serializable

类 java.lang.NoSuchFieldException 继承 Exception 实现 Serializable

类 java.lang.NoSuchMethodError 继承 IncompatibleClassChangeError 实现 Serializable

类 java.lang.NoSuchMethodException 继承 Exception 实现 Serializable

类 java.lang.NullPointerException 继承 RuntimeException 实现 Serializable

类 java.lang.Number 继承 Object 实现 Serializable

serialVersionUID: -8742448824652078965L

类 java.lang.NumberFormatException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: -2848938806368998894L

类 java.lang.OutOfMemoryError 继承 VirtualMachineError 实现 Serializable

类 java.lang.RuntimeException 继承 Exception 实现 Serializable

serialVersionUID: -7034897190745766939L

类 java.lang.RuntimePermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 7399184964622342223L

类 java.lang.SecurityException 继承 RuntimeException 实现 Serializable

serialVersionUID: 6878364983674394167L

类 java.lang.Short 继承 Number 实现 Serializable

serialVersionUID: 7515723908773894738L

序列化字段

value

short value
Short 值。

类 java.lang.StackOverflowError 继承 VirtualMachineError 实现 Serializable

类 java.lang.StackTraceElement 继承 Object 实现 Serializable

serialVersionUID: 6992337162326171013L

序列化字段

declaringClass

String declaringClass

methodName

String methodName

fileName

String fileName

lineNumber

int lineNumber

类 java.lang.String 继承 Object 实现 Serializable

serialVersionUID: -6849794470754667710L

序列化概述
String 类被专门放入 Serialization Stream Protocol。 String 实例最初以如下格式被写入 ObjectOutputStream：
      TC_STRING (utf String)
该 String 由方法 DataOutput.writeUTF 写入。生成一个新句柄以访问流中对此字符串实例的所有将来引用。

序列化字段

类 java.lang.StringBuffer 继承 java.lang.AbstractStringBuilder 实现 Serializable

serialVersionUID: 3388685877147921107L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject，从流中恢复 StringBuffer 的状态。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
调用 readObject，从流中恢复 StringBuffer 的状态。

抛出：
IOException
序列化概述
StringBuffer 的可序列化字段。

序列化字段

count

int count
该 StringBuffer 中的字符数。

shared

boolean shared
指示是否共享底层数组的标志。在反序列化时忽略该值。

value

char[] value
该 StringBuffer 的底层字符数组。

类 java.lang.StringBuilder 继承 java.lang.AbstractStringBuilder 实现 Serializable

serialVersionUID: 4383685877147921099L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject，从流中恢复 StringBuffer 的状态。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 StringBuilder 实例的状态保存到流中（也就是将其序列化）。

序列数据：
当前存储在字符串生成器中的字符数（int），后跟字符串生成器中的字符（char[]）。char 数组的长度可能大于当前存储在字符串生成器中的字符数，在这种情况下，将忽略多出的字符。
抛出：
IOException

类 java.lang.StringIndexOutOfBoundsException 继承 IndexOutOfBoundsException 实现 Serializable

类 java.lang.ThreadDeath 继承 Error 实现 Serializable

类 java.lang.Throwable 继承 Object 实现 Serializable

serialVersionUID: -3042686055658047285L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException
序列化字段

detailMessage

String detailMessage
有关 Throwable 的详细信息。例如，对于 FileNotFoundException，这包含了无法找到的文件名称。

cause

Throwable cause
由此 throwable 引起的 throwable 被抛出，如果 throwable 未由其他 throwable 引起，或作为 cause 的 throwable 未知，则为空。如果此字段等于该 throwable 本身，它表示该 throwable 的 cause 尚未初始化。

从以下版本开始：
1.4

stackTrace

StackTraceElement[] stackTrace
堆栈跟踪，由 Throwable.getStackTrace() 返回。

从以下版本开始：
1.4

类 java.lang.TypeNotPresentException 继承 RuntimeException 实现 Serializable

序列化字段

typeName

String typeName

类 java.lang.UnknownError 继承 VirtualMachineError 实现 Serializable

类 java.lang.UnsatisfiedLinkError 继承 LinkageError 实现 Serializable

类 java.lang.UnsupportedClassVersionError 继承 ClassFormatError 实现 Serializable

类 java.lang.UnsupportedOperationException 继承 RuntimeException 实现 Serializable

serialVersionUID: -1242599979055084673L

类 java.lang.VerifyError 继承 LinkageError 实现 Serializable

类 java.lang.VirtualMachineError 继承 Error 实现 Serializable

软件包 java.lang.annotation

类 java.lang.annotation.AnnotationFormatError 继承 Error 实现 Serializable

类 java.lang.annotation.AnnotationTypeMismatchException 继承 RuntimeException 实现 Serializable

序列化字段

element

Method element
注释元素的 Method 对象。

foundType

String foundType
在注释中找到的数据（错误）类型。该字符串可以，但不一定包含该值。字符串的确切格式没有指定。

类 java.lang.annotation.IncompleteAnnotationException 继承 RuntimeException 实现 Serializable

序列化字段

annotationType

Class<T> annotationType

elementName

String elementName
软件包 java.lang.instrument

类 java.lang.instrument.IllegalClassFormatException 继承 Exception 实现 Serializable

类 java.lang.instrument.UnmodifiableClassException 继承 Exception 实现 Serializable

软件包 java.lang.management

类 java.lang.management.ManagementPermission 继承 BasicPermission 实现 Serializable

软件包 java.lang.reflect

类 java.lang.reflect.GenericSignatureFormatError 继承 ClassFormatError 实现 Serializable

类 java.lang.reflect.InvocationTargetException 继承 Exception 实现 Serializable

serialVersionUID: 4085088731926701167L

序列化字段

target

Throwable target
如果使用 InvocationTargetException(Throwable target) 构造方法来实例化该对象，则此字段将保持目标

类 java.lang.reflect.MalformedParameterizedTypeException 继承 RuntimeException 实现 Serializable

类 java.lang.reflect.Proxy 继承 Object 实现 Serializable

serialVersionUID: -2222568056686623797L

序列化字段

h

InvocationHandler h
此代理实例的调用处理程序。

类 java.lang.reflect.ReflectPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 7412737110241507485L

类 java.lang.reflect.UndeclaredThrowableException 继承 RuntimeException 实现 Serializable

serialVersionUID: 330127114055056639L

序列化字段

undeclaredThrowable

Throwable undeclaredThrowable
抛出的经过检查的未声明异常

软件包 java.math

类 java.math.BigDecimal 继承 Number 实现 Serializable

serialVersionUID: 6108874887143696463L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 BigDecimal 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此 BigDecimal 序列化到请求的流

抛出：
IOException
序列化字段

intVal

BigInteger intVal
此 BigDecimal 的非标度值，由 BigDecimal.unscaledValue() 返回。

另请参见：
BigDecimal.unscaledValue()

scale

int scale
此 BigDecimal 的标度，由 BigDecimal.scale 返回。

另请参见：
BigDecimal.scale

类 java.math.BigInteger 继承 Number 实现 Serializable

serialVersionUID: -8287574255936472291L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构 BigInteger 实例（也就是将其反序列化）。由于历史原因，该大小作为一个 byte 数组读入，但它被转换为一个 int 数组，并丢弃 byte 数组。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 BigInteger 实例保存到流。由于历史原因，BigInteger 的大小被序列化为一个 byte 数组。

序列数据：
将写入两个必需字段和一些过时字段，以便与较旧版本兼容。
抛出：
IOException
序列化概述
BigInteger 的可序列化字段。

序列化字段

bitCount

int bitCount
此 BigInteger 中的位数

bitLength

int bitLength
此 BigInteger 最小的二进制补码表示形式的位数

lowestSetBit

int lowestSetBit
二进制补码表示形式的最低设置位

magnitude

int[] magnitude
此 BigInteger 的大小数组。

signum

int signum
此 BigInteger 的正负号。

类 java.math.MathContext 继承 Object 实现 Serializable

serialVersionUID: 5579720004786848255L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 MathContext 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException
序列化字段

precision

int precision
某个操作使用的数位。值为 0 指示将使用无限精度（需要多少位就用多少位）。注意，前导零（在某个数的系数中）不是有效数字。

precision 始终为非负数。

roundingMode

RoundingMode roundingMode
某个操作使用的舍入算法。

另请参见：
RoundingMode
软件包 java.net

类 java.net.BindException 继承 SocketException 实现 Serializable

类 java.net.ConnectException 继承 SocketException 实现 Serializable

类 java.net.HttpRetryException 继承 IOException 实现 Serializable

序列化字段

responseCode

int responseCode

location

String location

类 java.net.Inet4Address 继承 InetAddress 实现 Serializable

serialVersionUID: 3286316764910316507L

序列化方法

writeReplace

private Object writeReplace()
                     throws ObjectStreamException
用 InetAddress 对象取代要序列化的对象。

抛出：
ObjectStreamException - 如果无法创建取代此对象的新对象

类 java.net.Inet6Address 继承 InetAddress 实现 Serializable

serialVersionUID: 6880410070516793377L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
仅当范围接口名称在此系统上有效时，从包括范围信息的流还原此对象的状态。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
重写默认行为以便以 String 的形式，而不是以不可序列化的 NetworkInterface 的形式写入 scope_ifname 字段。

抛出：
IOException
序列化字段

ipaddress

byte[] ipaddress
Holds a 128-bit (16 bytes) IPv6 address.

scope_id

int scope_id
scope_id。创建对象时指定的范围。如果对象是使用接口名称创建的，则到需要时才确定 scope_id。

scope_id_set

boolean scope_id_set
当 scope_id 字段包含有效的整数 scope_id 时，将其设置为 true。

scope_ifname_set

boolean scope_ifname_set
在使用范围接口而不是数字范围 id 构造对象时设置。

ifname

String ifname
仅在序列化/反序列化期间才使用后跟字段

类 java.net.InetAddress 继承 Object 实现 Serializable

serialVersionUID: 3286316764910316507L

序列化方法

readResolve

private Object readResolve()
                    throws ObjectStreamException
用 Inet4Address 对象取代反序列化对象。

抛出：
ObjectStreamException - 如果无法创建取代此对象的新对象
序列化字段

hostName

String hostName

address

int address
Holds a 32-bit IPv4 address.

family

int family
Specifies the address family type, for instance, '1' for IPv4 addresses, and '2' for IPv6 addresses.

类 java.net.InetSocketAddress 继承 SocketAddress 实现 Serializable

serialVersionUID: 5076001401234631237L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException
序列化字段

hostname

String hostname

addr

InetAddress addr

port

int port

类 java.net.MalformedURLException 继承 IOException 实现 Serializable

类 java.net.NetPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: -8343910153355041693L

类 java.net.NoRouteToHostException 继承 SocketException 实现 Serializable

类 java.net.PortUnreachableException 继承 SocketException 实现 Serializable

类 java.net.ProtocolException 继承 IOException 实现 Serializable

类 java.net.SocketAddress 继承 Object 实现 Serializable

类 java.net.SocketException 继承 IOException 实现 Serializable

类 java.net.SocketPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: 2787186408602843674L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
"permissions" field (a Vector containing the SocketPermissions).
抛出：
IOException
序列化字段

permissions

Vector<E> permissions
A list of the SocketPermissions for this set.

类 java.net.SocketTimeoutException 继承 InterruptedIOException 实现 Serializable

类 java.net.UnknownHostException 继承 IOException 实现 Serializable

类 java.net.UnknownServiceException 继承 IOException 实现 Serializable

类 java.net.URI 继承 Object 实现 Serializable

serialVersionUID: -6052424284110960213L

序列化方法

readObject

private void readObject(ObjectInputStream is)
                 throws ClassNotFoundException,
                        IOException
从给定的串行流重构 URI。

调用 ObjectInputStream.defaultReadObject() 方法以读取 string 字段的值。然后按通常方式对结果进行解析。

抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream os)
                  throws IOException
将此 URI 的内容保存到给定的串行流中。

URI 实例的惟一可序列化字段是 string 字段。如果该字段原来没有值，则给定一个值，然后调用给定对象输出流的 ObjectOutputStream.defaultWriteObject() 方法。

抛出：
IOException
序列化字段

string

String string
此 URI 的字符串表示形式。

类 java.net.URISyntaxException 继承 Exception 实现 Serializable

序列化字段

input

String input

index

int index

类 java.net.URL 继承 Object 实现 Serializable

serialVersionUID: -7627629688361524110L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject，以便从流中恢复 URL 的状态。它读取 URL 的各个组成部分并查找本地流处理程序。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
调用 WriteObject，将 URL 的状态保存到 ObjectOutputStream 中。不保存该处理程序，因为它特定于此系统。

序列数据：
默认的写入对象的值。当读取返回时，reader 必须确保调用的具有协议变量的 getURLStreamHandler 返回有效的 URLStreamHandler，如果返回无效的 URLStreamHandler，则抛出 IOException 异常。
抛出：
IOException
序列化字段

protocol

String protocol
要使用的协议（ftp、http、nntp，...等）。

host

String host
要连接的主机名。

port

int port
要连接的协议端口。

file

String file
相应主机上的指定文件名。file 定义的格式为 path[?query]

authority

String authority
此 URL 的授权部分。

ref

String ref
# 引用。

hashCode

int hashCode
软件包 java.nio

类 java.nio.BufferOverflowException 继承 RuntimeException 实现 Serializable

类 java.nio.BufferUnderflowException 继承 RuntimeException 实现 Serializable

类 java.nio.InvalidMarkException 继承 IllegalStateException 实现 Serializable

类 java.nio.ReadOnlyBufferException 继承 UnsupportedOperationException 实现 Serializable

软件包 java.nio.channels

类 java.nio.channels.AlreadyConnectedException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.AsynchronousCloseException 继承 ClosedChannelException 实现 Serializable

类 java.nio.channels.CancelledKeyException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.ClosedByInterruptException 继承 AsynchronousCloseException 实现 Serializable

类 java.nio.channels.ClosedChannelException 继承 IOException 实现 Serializable

类 java.nio.channels.ClosedSelectorException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.ConnectionPendingException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.FileLockInterruptionException 继承 IOException 实现 Serializable

类 java.nio.channels.IllegalBlockingModeException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.IllegalSelectorException 继承 IllegalArgumentException 实现 Serializable

类 java.nio.channels.NoConnectionPendingException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.NonReadableChannelException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.NonWritableChannelException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.NotYetBoundException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.NotYetConnectedException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.OverlappingFileLockException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.UnresolvedAddressException 继承 IllegalArgumentException 实现 Serializable

类 java.nio.channels.UnsupportedAddressTypeException 继承 IllegalArgumentException 实现 Serializable

软件包 java.nio.charset

类 java.nio.charset.CharacterCodingException 继承 IOException 实现 Serializable

类 java.nio.charset.CoderMalfunctionError 继承 Error 实现 Serializable

类 java.nio.charset.IllegalCharsetNameException 继承 IllegalArgumentException 实现 Serializable

序列化字段

charsetName

String charsetName

类 java.nio.charset.MalformedInputException 继承 CharacterCodingException 实现 Serializable

序列化字段

inputLength

int inputLength

类 java.nio.charset.UnmappableCharacterException 继承 CharacterCodingException 实现 Serializable

序列化字段

inputLength

int inputLength

类 java.nio.charset.UnsupportedCharsetException 继承 IllegalArgumentException 实现 Serializable

序列化字段

charsetName

String charsetName
软件包 java.rmi

类 java.rmi.AccessException 继承 RemoteException 实现 Serializable

serialVersionUID: 6314925228044966088L

类 java.rmi.AlreadyBoundException 继承 Exception 实现 Serializable

serialVersionUID: 9218657361741657110L

类 java.rmi.ConnectException 继承 RemoteException 实现 Serializable

serialVersionUID: 4863550261346652506L

类 java.rmi.ConnectIOException 继承 RemoteException 实现 Serializable

serialVersionUID: -8087809532704668744L

类 java.rmi.MarshalException 继承 RemoteException 实现 Serializable

serialVersionUID: 6223554758134037936L

类 java.rmi.MarshalledObject 继承 Object 实现 Serializable

serialVersionUID: 8988374069173025854L

序列化字段

objBytes

byte[] objBytes
字节的序列化表示形式。如果 objBytes 为 null，则已编组的对象为 null 引用。

locBytes

byte[] locBytes
由 equals 忽略的字节位置注释。如果 locBytes 为 null，则在编组过程中存在非 null 注释。

hash

int hash
所包含对象存储的哈希码。
另请参见：
MarshalledObject.hashCode()

类 java.rmi.NoSuchObjectException 继承 RemoteException 实现 Serializable

serialVersionUID: 6619395951570472985L

类 java.rmi.NotBoundException 继承 Exception 实现 Serializable

serialVersionUID: -1857741824849069317L

类 java.rmi.RemoteException 继承 IOException 实现 Serializable

serialVersionUID: -5148567311918794206L

序列化字段

detail

Throwable detail
远程异常的原因。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获取此信息的首选方法。

类 java.rmi.RMISecurityException 继承 SecurityException 实现 Serializable

serialVersionUID: -8433406075740433514L

类 java.rmi.ServerError 继承 RemoteException 实现 Serializable

serialVersionUID: 8455284893909696482L

类 java.rmi.ServerException 继承 RemoteException 实现 Serializable

serialVersionUID: -4775845313121906682L

类 java.rmi.ServerRuntimeException 继承 RemoteException 实现 Serializable

serialVersionUID: 7054464920481467219L

类 java.rmi.StubNotFoundException 继承 RemoteException 实现 Serializable

serialVersionUID: -7088199405468872373L

类 java.rmi.UnexpectedException 继承 RemoteException 实现 Serializable

serialVersionUID: 1800467484195073863L

类 java.rmi.UnknownHostException 继承 RemoteException 实现 Serializable

serialVersionUID: -8152710247442114228L

类 java.rmi.UnmarshalException 继承 RemoteException 实现 Serializable

serialVersionUID: 594380845140740218L

软件包 java.rmi.activation

类 java.rmi.activation.ActivateFailedException 继承 RemoteException 实现 Serializable

serialVersionUID: 4863550261346652506L

类 java.rmi.activation.ActivationDesc 继承 Object 实现 Serializable

serialVersionUID: 7455834104417690957L

序列化字段

groupID

ActivationGroupID groupID
组标识符

className

String className
对象的类名

location

String location
对象的代码基

data

MarshalledObject<T> data
对象的初始化数据

restart

boolean restart
表示对象是否应当被重新启动。

类 java.rmi.activation.ActivationException 继承 Exception 实现 Serializable

serialVersionUID: -4320118837291406071L

序列化字段

detail

Throwable detail
激活异常的原因。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获取此信息的首选方法。

类 java.rmi.activation.ActivationGroup 继承 UnicastRemoteObject 实现 Serializable

serialVersionUID: -7696947875314805420L

序列化字段

groupID

ActivationGroupID groupID
组标识符

monitor

ActivationMonitor monitor
组监视器

incarnation

long incarnation
组的代号

类 java.rmi.activation.ActivationGroup_Stub 继承 RemoteStub 实现 Serializable

类 java.rmi.activation.ActivationGroupDesc 继承 Object 实现 Serializable

serialVersionUID: -4936225423168276595L

序列化字段

className

String className
组的完全限定包的类名。

location

String location
要加载组类的位置。

data

MarshalledObject<T> data
组的初始化数据。

env

ActivationGroupDesc.CommandEnvironment env
在另一个进程中执行 VM 的控制选项。

props

Properties props
一个将重写子进程环境中默认设置的属性映射表。

类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 继承 Object 实现 Serializable

serialVersionUID: 6165754737887770191L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
针对自定义序列化的 readObject。

此方法按以下方式读取该类的此对象的序列化形式：

此方法首先调用指定对象输入流上的 defaultReadObject，如果 options 为 null，则 options 被设置为零长度的 String 数组。

抛出：
IOException
ClassNotFoundException
序列化字段

command

String command

options

String[] options

类 java.rmi.activation.ActivationGroupID 继承 Object 实现 Serializable

serialVersionUID: -1648432278909740833L

序列化字段

system

ActivationSystem system
组的激活系统。

uid

UID uid
组的唯一 id。

类 java.rmi.activation.ActivationID 继承 Object 实现 Serializable

serialVersionUID: -4608673054848209235L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
针对自定义序列化的 readObject。

此方法为此类读取此对象的序列化形式，方式如下：

readObject 方法在 in 被调用，以读取此对象的惟一标识符（一个 UID 实例）。

接下来，readUTF 方法在 in 上被调用，以读取此对象的激活器的 RemoteRef 实例的外部引用类型名称。然后，对应于外部引用类型名称（由 readUTF 返回），RemoteRef 实例由一个特定于实现的类创建，并且 readExternal 方法在该 RemoteRef 实例上被调用，以读取对应于外部引用类型名称的外部形式。

注：如果外部引用类型名称为 "UnicastRef"、"UnicastServerRef"、"UnicastRef2"、"UnicastServerRef2" 或 "ActivatableRef"，则必须找到对应的特定于实现的类，并且其 readExternal 方法必须为外部类型名称读取序列数据，正如指定将此类写入 serialData 文档一样。如果外部引用类型名称是任何其他字符串（长度不为零），则将抛出 ClassNotFoundException，除非该实现提供了对应于外部引用类型名称的特定于实现的类，在这种情况下，RemoteRef 将是特定于实现的类的一个实例。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException,
                         ClassNotFoundException
针对自定义序列化的 writeObject。

此方法为此类写入此对象的序列化形式，方式如下：

传入此对象的惟一标识符（一个 UID 实例）作为参数，writeObject 方法在 out 上被调用。

接下来，getRefClass 方法在激活器的 RemoteRef 实例上被调用，以获得其外部引用类型名称。然后，writeUTF 方法使用 getRefClass 返回的值在 out 上被调用，接着 writeExternal 方法传递 out 作为参数在 RemoteRef 实例上被调用。

序列数据：
此类的序列化数据组成一个 java.rmi.server.UID（用 ObjectOutput.writeObject 方法写入），后面紧跟激活器 RemoteRef 实例（用 ObjectOutput.writeUTF 写入的一个字符串）的外部类型名称，后面紧跟由其 writeExternal 方法写入的 RemoteRef 实例的外部形式。

使用在 RemoteObject 的 writeObject 方法 serialData 规范中指定的外部引用类型名称的定义来确定 RemoteRef 实例的外部引用类型名称。类似地，通过 RemoteRef 实现类的 writeExternal 方法写入和通过 readExternal 方法读取的数据对应于在 RemoteObject writeObject 方法 serialData 规范中指定的每一个已定义外部引用类型名称。

抛出：
IOException
ClassNotFoundException

类 java.rmi.activation.UnknownGroupException 继承 ActivationException 实现 Serializable

serialVersionUID: 7056094974750002460L

类 java.rmi.activation.UnknownObjectException 继承 ActivationException 实现 Serializable

serialVersionUID: 3425547551622251430L

软件包 java.rmi.dgc

类 java.rmi.dgc.Lease 继承 Object 实现 Serializable

serialVersionUID: -5713411624328831948L

序列化字段

vmid

VMID vmid
与此 Lease 关联的虚拟机 ID。
另请参见：
Lease.getVMID()

value

long value
此 lease 的期限。
另请参见：
Lease.getValue()

类 java.rmi.dgc.VMID 继承 Object 实现 Serializable

serialVersionUID: -538642295484486218L

序列化字段

addr

byte[] addr
唯一地标识创建于其上的主机的 byte 数组

uid

UID uid
有关创建于其上的主机的唯一标识符
软件包 java.rmi.server

类 java.rmi.server.ExportException 继承 RemoteException 实现 Serializable

serialVersionUID: -9155485338494060170L

类 java.rmi.server.ObjID 继承 Object 实现 Serializable

serialVersionUID: -6386392263968365220L

序列化字段

objNum

long objNum
object number
另请参见：
ObjID.hashCode()

space

UID space
address space identifier (unique to host over time)

类 java.rmi.server.RemoteObject 继承 Object 实现 Serializable

serialVersionUID: -3215090123894869218L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
用于自定义序列化的 readObject。

此方法按以下方式读取该类的此对象的序列化形式：

在 in 上调用 readUTF 方法来读取 RemoteRef 实例的外部 ref 类型名称，以将其填充到此对象的 ref 字段。如果 readUTF 返回的字符串长度为 0，则在 in 上调用 readObject 方法，然后将 readObject 返回的值转换为 RemoteRef，并将此对象的 ref 字段设置为该值。否则，此对象的 ref 字段将设置为从与 readUTF 返回的外部 ref 类型名称相对应的特定于实现的类创建的 RemoteRef 实例，然后在此对象的 ref 字段上调用 readExternal 方法。

如果外部 ref 类型名称为 "UnicastRef"、"UnicastServerRef"、"UnicastRef2"、"UnicastServerRef2" 或 "ActivatableRef"，则必须找到一个相应的特定于实现的类，并且其 readExternal 方法在指定要写入此类的 serialData 文档时必须读取外部 ref 类型名称的序列数据。如果外部 ref 类型名称是任何其他字符串（长度不是 0），则将抛出 ClassNotFoundException，除非该实现提供相对于该外部 ref 类型名称的特定于实现的类，在这种情况下，将把此对象的 ref 字段设置为一个该特定于实现的类的实例。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException,
                         ClassNotFoundException
用于自定义序列化的 writeObject。

此方法按以下方式写入该类的此对象的序列化形式：

在此对象的 ref 字段上调用 getRefClass 方法，以获得其外部 ref 类型名称。如果 getRefClass 返回的值是长度大于 0 的非 null 字符串，则在具有 getRefClass 返回的值的 out 上调用 writeUTF 方法，然后在作为参数传递 out 的此对象的 ref 字段上调用 writeExternal 方法；否则，在具有 0 长度字符串 ("") 的 out 上调用 writeUTF 方法，然后在作为参数传递此对象的 ref 字段的 out 上调用 writeObject 方法。

序列数据：
此类的序列化数据包含一个字符串（用 ObjectOutput.writeUTF 写入），该字符串可以是包含的 RemoteRef 实例（ref 字段）的外部 ref 类型名称，也可以是一个 0 长度字符串，如果该字符串的长度不是 0，则后跟 writeExternal 方法写入的 ref 字段的外部形式；如果该字符串的长度为 0，则后跟将其传递到序列化流的 writeObject 时写入的 ref 字段的序列化形式。

如果此对象是一个从任何 UnicastRemoteObject.exportObject 方法返回的 RemoteStub 或 RemoteObjectInvocationHandler 的实例，且未使用自定义套接字工厂，则外部 ref 类型名称为 "UnicastRef"。 如果此对象是一个从任何 UnicastRemoteObject.exportObject 方法返回的 RemoteStub 或 RemoteObjectInvocationHandler 的实例，且使用自定义套接字工厂，则外部 ref 类型名称为 "UnicastRef2"。 如果此对象是一个从任何 java.rmi.activation.Activatable.exportObject 方法返回的 RemoteStub 或 RemoteObjectInvocationHandler 的实例，则外部 ref 类型名称为 "ActivatableRef"。 如果此对象是一个从 RemoteObject.toStub 方法返回的 RemoteStub 或 RemoteObjectInvocationHandler 的实例（并且传入 toStub 的参数本身不是 RemoteStub），则外部 ref 类型名称是一个传入 toStub 的远程对象的导出方式的函数，如上所述。 如果此对象是一个最初通过反序列化创建的 RemoteStub 或 RemoteObjectInvocationHandler 的实例，则外部 ref 类型名称与此对象进行反序列化时读取的类型名称相同。

如果此对象是一个未使用自定义套接字工厂的 java.rmi.server.UnicastRemoteObject 的实例，则外部 ref 类型名称为 "UnicastServerRef"。 如果此对象是一个使用自定义套接字工厂的 UnicastRemoteObject 实例，则外部 ref 类型名称为 "UnicastServerRef2"。

下面是必须由 writeExternal 方法写入且由 RemoteRef 实现类的 readExternal 方法读取的数据，该实现类对应于每个定义的外部 ref 类型名称：

对于 "UnicastRef"：

  • 引用的远程对象的主机名，由 DataOutput.writeUTF(String) 写入
  • 引用的远程对象的端口，由 DataOutput.writeInt(int) 写入
  • 作为引用中包含的 ObjID 实例上调用 {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} 的结果写入的数据
  • boolean 值 false，由 DataOutput.writeBoolean(boolean) 写入

对于具有 null 客户机套接字工厂的 "UnicastRef2"：

  • 字节值 0x00（指示 null 客户机套接字工厂），由 DataOutput.writeByte(int) 写入
  • 引用的远程对象的主机名，由 DataOutput.writeUTF(String) 写入
  • 引用的远程对象的端口，由 DataOutput.writeInt(int) 写入
  • 作为引用中包含的 ObjID 实例上调用 {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} 的结果写入的数据
  • boolean 值 false，由 DataOutput.writeBoolean(boolean) 写入

对于具有非 null 客户机套接字工厂的 "UnicastRef2"：

  • 字节值 0x01（指示非 null 客户机套接字工厂），由 DataOutput.writeByte(int) 写入
  • 引用的远程对象的主机名，由 DataOutput.writeUTF(String) 写入
  • 引用的远程对象的端口，由 DataOutput.writeInt(int) 写入
  • 客户机套接字工厂（类型 java.rmi.server.RMIClientSocketFactory 的对象），通过将其传递到流实例上的 writeObject 的调用写入
  • 作为引用中包含的 ObjID 实例上调用 {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} 的结果写入的数据
  • boolean 值 false，由 DataOutput.writeBoolean(boolean) 写入

对于具有 null 嵌入远程引用的 "ActivatableRef"：

  • java.rmi.activation.ActivationID 的实例，通过将其传递到流实例上的 writeObject 的调用写入
  • 0 长度字符串 ("")，由 DataOutput.writeUTF(String) 写入

对于具有非 null 嵌入远程引用的 "ActivatableRef"：

  • java.rmi.activation.ActivationID 的实例，通过将其传递到流实例上的 writeObject 的调用写入
  • 嵌入的远程引用的外部 ref 类型名称（必须是 "UnicastRef2"），由 DataOutput.writeUTF(String) 写入
  • 嵌入的远程引用的外部形式，通过调用其具有流实例的 writeExternal 方法写入（请参阅上述 "UnicastRef2" 的外部形式的描述）

对于 "UnicastServerRef" 和 "UnicastServerRef2"，不能通过 writeExternal 方法写入数据，也不能通过 readExternal 方法读取数据。

抛出：
IOException
ClassNotFoundException

类 java.rmi.server.RemoteObjectInvocationHandler 继承 RemoteObject 实现 Serializable

serialVersionUID: 2L

序列化方法

readObjectNoData

private void readObjectNoData()
                       throws InvalidObjectException
抛出：
InvalidObjectException - 无条件抛出

类 java.rmi.server.RemoteServer 继承 RemoteObject 实现 Serializable

serialVersionUID: -4100238210092549637L

类 java.rmi.server.RemoteStub 继承 RemoteObject 实现 Serializable

serialVersionUID: -1585587260594494182L

类 java.rmi.server.ServerCloneException 继承 CloneNotSupportedException 实现 Serializable

serialVersionUID: 6617456357664815945L

序列化字段

detail

Exception detail
异常原因。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获取此信息的首选方法。

类 java.rmi.server.ServerNotActiveException 继承 Exception 实现 Serializable

serialVersionUID: 4687940720827538231L

类 java.rmi.server.SkeletonMismatchException 继承 RemoteException 实现 Serializable

serialVersionUID: -7780460454818859281L

类 java.rmi.server.SkeletonNotFoundException 继承 RemoteException 实现 Serializable

serialVersionUID: -7860299673822761231L

类 java.rmi.server.SocketSecurityException 继承 ExportException 实现 Serializable

serialVersionUID: -7622072999407781979L

类 java.rmi.server.UID 继承 Object 实现 Serializable

serialVersionUID: 1086053664494604050L

序列化字段

unique

int unique
唯一标识此 UID 在其中生成的 VM 的数字，该数字和主机和给定的时间有关

time

long time
此 UID 在其中生成的 VM 处于活动状态时的时间（由 System.currentTimeMillis() 返回）

count

short count
用来区分按同一时间在同一 VM 中创建的 UID 实例的 16 位数字

类 java.rmi.server.UnicastRemoteObject 继承 RemoteServer 实现 Serializable

serialVersionUID: 4974527148936298033L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
将远程对象进行反序列化时重新将其导出。

抛出：
IOException
ClassNotFoundException
序列化字段

port

int port
要在其上导出对象的端口号

csf

RMIClientSocketFactory csf
客户端套接字工厂（如果有）

ssf

RMIServerSocketFactory ssf
导出对象时使用的服务器端套接字工厂（如果有）
软件包 java.security

类 java.security.AccessControlException 继承 SecurityException 实现 Serializable

serialVersionUID: 5138225684096988535L

序列化字段

perm

Permission perm

类 java.security.AllPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: -4023755556366636806L

序列化字段

all_allowed

boolean all_allowed

类 java.security.AuthProvider 继承 Provider 实现 Serializable

类 java.security.BasicPermission 继承 Permission 实现 Serializable

serialVersionUID: 6279438298436773498L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject，从流中恢复 BasicPermission 的状态。

抛出：
IOException
ClassNotFoundException

类 java.security.BasicPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: 739301742472979399L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore the state of the BasicPermissionCollection from a stream.

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
Default fields.
抛出：
IOException
序列化字段

all_allowed

boolean all_allowed
This is set to true if this BasicPermissionCollection contains a BasicPermission with '*' as its permission name.

permClass

Class<T> permClass
The class to which all BasicPermissions in this BasicPermissionCollection belongs.

permissions

Hashtable<K,V> permissions
The BasicPermissions in this BasicPermissionCollection. All BasicPermissions in the collection must belong to the same class. The Hashtable is indexed by the BasicPermission name; the value of the Hashtable entry is the permission.

类 java.security.CodeSigner 继承 Object 实现 Serializable

serialVersionUID: 6819288105193937581L

序列化字段

signerCertPath

CertPath signerCertPath
签名者的证书路径。

timestamp

Timestamp timestamp

类 java.security.CodeSource 继承 Object 实现 Serializable

serialVersionUID: 4977541819976013951L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
从流还原此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
将此对象写出到流中（也就是将其序列化）。

序列数据：
初始 URL 后跟一个 int，指示要遵守的证书数（值“零”表示不存在与此对象关联的证书）。所有证书的撰写都以表示证书类型的 String 开头，后跟一个指定证书编码长度的 int，再后跟作为 byte 数组写出的证书编码本身。最后，如果出现代码签名者，则同时序列化和写出代码签名者的数组。
抛出：
IOException
序列化字段

location

URL location
代码位置。

类 java.security.DigestException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 5821450303093652515L

类 java.security.GeneralSecurityException 继承 Exception 实现 Serializable

serialVersionUID: 894798122053539237L

类 java.security.GuardedObject 继承 Object 实现 Serializable

serialVersionUID: -5240450096227834308L

序列化方法

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
将此对象写出到流中（即将其序列化）。如果存在 guard，则检查它。

抛出：
IOException
序列化字段

object

Object object

guard

Guard guard

类 java.security.Identity 继承 Object 实现 Serializable

serialVersionUID: 3609922007826600659L

序列化字段

name

String name
已过时。
此 Identity 的名称。

publicKey

PublicKey publicKey
已过时。
此 Identity 的公钥。

info

String info
已过时。
Generic, descriptive information about the identity.

scope

IdentityScope scope
已过时。
The scope of the identity.

certificates

Vector<E> certificates
已过时。
The certificates for this identity.

类 java.security.IdentityScope 继承 Identity 实现 Serializable

serialVersionUID: -2337346281189773310L

类 java.security.InvalidAlgorithmParameterException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 2864672297499471472L

类 java.security.InvalidKeyException 继承 KeyException 实现 Serializable

serialVersionUID: 5698479920593359816L

类 java.security.InvalidParameterException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: -857968536935667808L

类 java.security.KeyException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -7483676942812432108L

类 java.security.KeyManagementException 继承 KeyException 实现 Serializable

serialVersionUID: 947674216157062695L

类 java.security.KeyPair 继承 Object 实现 Serializable

serialVersionUID: -7565189502268009837L

序列化字段

privateKey

PrivateKey privateKey

publicKey

PublicKey publicKey

类 java.security.KeyRep 继承 Object 实现 Serializable

serialVersionUID: -4757683898830641853L

序列化方法

readResolve

protected Object readResolve()
                      throws ObjectStreamException
解析 Key 对象。

此方法支持三种 Type/format 组合：

  • Type.SECRET/"RAW" - 返回使用编码的密钥字节和算法构建的 SecretKeySpec 对象
  • Type.PUBLIC/"X.509" - 获取该密钥算法的 KeyFactory 实例，用编码的密钥字节构建 X509EncodedKeySpec，根据 spec 生成公钥
  • Type.PRIVATE/"PKCS#8" - 获取该密钥算法的 KeyFactory 实例，用编码的密钥字节构造 PKCS8EncodedKeySpec，根据 spec 生成私钥

抛出：
ObjectStreamException - 如果 Type/format 组合是不能识别的；如果算法、密钥格式或编码的密钥字节是不能识别的/无效的；如果由于任何原因密钥解析失败。
序列化字段

type

KeyRep.Type type
Type.SECRET、Type.PUBLIC 或 Type.PRIVATE 之一。

algorithm

String algorithm
Key 算法

format

String format
Key 编码格式

encoded

byte[] encoded
编码的 Key 的字节

类 java.security.KeyStoreException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -1119353179322377262L

类 java.security.NoSuchAlgorithmException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -7443947487218346562L

类 java.security.NoSuchProviderException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 8488111756688534474L

类 java.security.Permission 继承 Object 实现 Serializable

serialVersionUID: -5636570222231596674L

序列化字段

name

String name

类 java.security.PermissionCollection 继承 Object 实现 Serializable

serialVersionUID: -6727011328946861783L

序列化字段

readOnly

boolean readOnly

类 java.security.PermissionsHash 继承 PermissionCollection 实现 Serializable

serialVersionUID: -8491988220802933440L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
Default fields.
抛出：
IOException
序列化字段

perms

Hashtable<K,V> perms
A table of the Permissions (both key and value are same).

类 java.security.PrivilegedActionException 继承 Exception 实现 Serializable

serialVersionUID: 4724086851538908602L

序列化字段

exception

Exception exception

类 java.security.Provider 继承 Properties 实现 Serializable

serialVersionUID: -4298000515446427739L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException
序列化字段

name

String name
provider 名称

info

String info
provider 及其服务的描述。

version

double version
provider 版本号。

类 java.security.ProviderException 继承 RuntimeException 实现 Serializable

serialVersionUID: 5256023526693665674L

类 java.security.SecureRandom 继承 Random 实现 Serializable

serialVersionUID: 4940670005562187L

序列化字段

provider

Provider provider
提供者。

从以下版本开始：
1.2

secureRandomSpi

SecureRandomSpi secureRandomSpi
提供者实现。

从以下版本开始：
1.2

algorithm

String algorithm

state

byte[] state

digest

MessageDigest digest

randomBytes

byte[] randomBytes
我们知道，MessageDigest 类不实现 java.io.Serializable。但由于不再使用此字段，所以它始终为 NULL，不会影响 SecureRandom 类本身的序列化。

randomBytesUsed

int randomBytesUsed

counter

long counter

类 java.security.SecureRandomSpi 继承 Object 实现 Serializable

serialVersionUID: -2991854161009191830L

类 java.security.SecurityPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 5236109936224050470L

类 java.security.SignatureException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 7509989324975124438L

类 java.security.SignedObject 继承 Object 实现 Serializable

serialVersionUID: 720502720485447167L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject，从流中恢复 SignedObject 的状态。

抛出：
IOException
ClassNotFoundException
序列化字段

content

byte[] content

signature

byte[] signature

thealgorithm

String thealgorithm

类 java.security.Signer 继承 Identity 实现 Serializable

serialVersionUID: -1763464102261361480L

序列化字段

privateKey

PrivateKey privateKey
已过时。
signer 的私钥。

类 java.security.Timestamp 继承 Object 实现 Serializable

serialVersionUID: -5502683707821851294L

序列化字段

timestamp

Date timestamp
时间戳的日期和时间

signerCertPath

CertPath signerCertPath
TSA 的证书路径。

类 java.security.UnrecoverableEntryException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -4527142945246286535L

类 java.security.UnrecoverableKeyException 继承 UnrecoverableEntryException 实现 Serializable

serialVersionUID: 7275063078190151277L

类 java.security.UnresolvedPermission 继承 Permission 实现 Serializable

serialVersionUID: -4821973115467008846L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
从流还原此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
将此对象写入流中（也就是将其序列化）。

序列数据：
初始 String（表示 type）后跟一个 String（表示 name），其后又跟一个 String（表示 actions），它后面又跟一个 int，指示要使用的证书数量；如果该值为“零”，则表示没有与此对象相关的证书。每个证书的编写都从一个表示证书类型的 String 开始，其后是 int，用来指定证书编码的长度，再向后是以 byte 数组形式写出的证书编码本身。
抛出：
IOException
序列化字段

type

String type
解析此未解析的权限时将创建 Permission 类的类名称。

name

String name
权限名称。

actions

String actions
对权限的操作。

类 java.security.UnresolvedPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: -7176153071733132400L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
Default field.
抛出：
IOException
序列化字段

permissions

Hashtable<K,V> permissions
A table of the UnresolvedPermissions keyed on type, value is Vector of permissions
软件包 java.security.acl

类 java.security.acl.AclNotFoundException 继承 Exception 实现 Serializable

serialVersionUID: 5684295034092681791L

类 java.security.acl.LastOwnerException 继承 Exception 实现 Serializable

serialVersionUID: -5141997548211140359L

类 java.security.acl.NotOwnerException 继承 Exception 实现 Serializable

serialVersionUID: -5555597911163362399L

软件包 java.security.cert

类 java.security.cert.Certificate 继承 Object 实现 Serializable

serialVersionUID: -3585440601605666277L

序列化方法

writeReplace

protected Object writeReplace()
                       throws ObjectStreamException
替换要被序列化的 Certificate。

抛出：
ObjectStreamException - 如果新对象表示无法创建此 Certificate
从以下版本开始：
1.3
序列化字段

type

String type

类 java.security.cert.Certificate.CertificateRep 继承 Object 实现 Serializable

serialVersionUID: -8563758940495660020L

序列化方法

readResolve

protected Object readResolve()
                      throws ObjectStreamException
解析该 Certificate 对象。

抛出：
ObjectStreamException - 如果无法解析该 Certificate
序列化字段

type

String type

data

byte[] data

类 java.security.cert.CertificateEncodingException 继承 CertificateException 实现 Serializable

serialVersionUID: 6219492851589449162L

类 java.security.cert.CertificateException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 3192535253797119798L

类 java.security.cert.CertificateExpiredException 继承 CertificateException 实现 Serializable

serialVersionUID: 9071001339691533771L

类 java.security.cert.CertificateNotYetValidException 继承 CertificateException 实现 Serializable

serialVersionUID: 4355919900041064702L

类 java.security.cert.CertificateParsingException 继承 CertificateException 实现 Serializable

serialVersionUID: -7989222416793322029L

类 java.security.cert.CertPath 继承 Object 实现 Serializable

serialVersionUID: 6068470306649138683L

序列化方法

writeReplace

protected Object writeReplace()
                       throws ObjectStreamException
使用 CertPathRep 对象替换要被序列化的 CertPath。

抛出：
ObjectStreamException - 如果不能创建表示此证书路径的 CertPathRep 对象
序列化字段

type

String type

类 java.security.cert.CertPath.CertPathRep 继承 Object 实现 Serializable

serialVersionUID: 3015633072427920915L

序列化方法

readResolve

protected Object readResolve()
                      throws ObjectStreamException
返回根据类型和数据所构造的 CertPath。

抛出：
ObjectStreamException - 如果无法构造 CertPath
序列化字段

type

String type
Certificate 类型。

data

byte[] data
CertPath 的编码形式。

类 java.security.cert.CertPathBuilderException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 5316471420178794402L

类 java.security.cert.CertPathValidatorException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -3083180014971893139L

序列化字段

index

int index
导致该异常抛出的证书在证书路径中的索引

certPath

CertPath certPath
异常抛出时所验证的 CertPath

类 java.security.cert.CertStoreException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 2395296107471573245L

类 java.security.cert.CRLException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -6694728944094197147L

类 java.security.cert.X509Certificate 继承 Certificate 实现 Serializable

serialVersionUID: -2491127588187038216L

软件包 java.security.interfaces
软件包 java.security.spec

类 java.security.spec.InvalidKeySpecException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 3546139293998810778L

类 java.security.spec.InvalidParameterSpecException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -970468769593399342L

软件包 java.sql

类 java.sql.BatchUpdateException 继承 SQLException 实现 Serializable

serialVersionUID: 5977529877145521757L

序列化字段

updateCounts

int[] updateCounts
描述批处理执行结果的数组。

从以下版本开始：
1.2

类 java.sql.ClientInfoException 继承 SQLException 实现 Serializable

序列化字段

failedProperties

Properties failedProperties

类 java.sql.DataTruncation 继承 SQLWarning 实现 Serializable

serialVersionUID: 6464298989504059473L

序列化字段

index

int index

parameter

boolean parameter

read

boolean read

dataSize

int dataSize

transferSize

int transferSize

类 java.sql.Date 继承 Date 实现 Serializable

serialVersionUID: 1511598038487230103L

类 java.sql.SQLClientInfoException 继承 SQLException 实现 Serializable

serialVersionUID: -4319604256824655880L

序列化字段

failedProperties

Map<K,V> failedProperties

类 java.sql.SQLDataException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: -6889123282670549800L

类 java.sql.SQLDataSetSyncException 继承 java.sql.SQLRuntimeException 实现 Serializable

序列化字段

ds

java.sql.DataSetResolver<T> ds

类 java.sql.SQLException 继承 Exception 实现 Serializable

serialVersionUID: 2135244094396331484L

序列化字段

SQLState

String SQLState

vendorCode

int vendorCode

next

SQLException next

类 java.sql.SQLFeatureNotSupportedException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: -1026510870282316051L

类 java.sql.SQLIntegrityConstraintViolationException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: 8033405298774849169L

类 java.sql.SQLInvalidAuthorizationSpecException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: -64105250450891498L

类 java.sql.SQLNonTransientConnectionException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: -5852318857474782892L

类 java.sql.SQLNonTransientException 继承 SQLException 实现 Serializable

serialVersionUID: -9104382843534716547L

类 java.sql.SQLPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: -1439323187199563495L

类 java.sql.SQLRecoverableException 继承 SQLException 实现 Serializable

serialVersionUID: -4144386502923131579L

类 java.sql.SQLRuntimeException 继承 RuntimeException 实现 Serializable

类 java.sql.SQLSyntaxErrorException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: -1843832610477496053L

类 java.sql.SQLTimeoutException 继承 SQLTransientException 实现 Serializable

serialVersionUID: -4487171280562520262L

类 java.sql.SQLTransactionRollbackException 继承 SQLTransientException 实现 Serializable

serialVersionUID: 5246680841170837229L

类 java.sql.SQLTransientConnectionException 继承 SQLTransientException 实现 Serializable

serialVersionUID: -2520155553543391200L

类 java.sql.SQLTransientException 继承 SQLException 实现 Serializable

serialVersionUID: -9042733978262274539L

类 java.sql.SQLWarning 继承 SQLException 实现 Serializable

serialVersionUID: 3917336774604784856L

类 java.sql.Time 继承 Date 实现 Serializable

serialVersionUID: 8397324403548013681L

类 java.sql.Timestamp 继承 Date 实现 Serializable

serialVersionUID: 2745179027874758501L

序列化字段

nanos

int nanos
软件包 java.text

类 java.text.AttributedCharacterIterator.Attribute 继承 Object 实现 Serializable

serialVersionUID: -9142742483513960612L

序列化方法

readResolve

protected Object readResolve()
                      throws InvalidObjectException
解析将被反序列化为预定义常量的实例。

抛出：
InvalidObjectException
序列化字段

name

String name
属性的名称。名称主要由 readResolve 方法在反序列化一个实例时用于查找相应的预定义实例。

类 java.text.ChoiceFormat 继承 NumberFormat 实现 Serializable

serialVersionUID: 1795184449645032964L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从输入流读取一个对象后，进行简单的验证，以维护类的不变量。

抛出：
InvalidObjectException - 如果从该流读取的对象无效。
IOException
ClassNotFoundException
序列化字段

choiceLimits

double[] choiceLimits
choice 的较低边界的列表。如果正在格式化的数大于等于 choiceLimits[i] 且小于 choiceLimits[i+1]，则该格式器将返回 choiceFormats[i]。

choiceFormats

String[] choiceFormats
choice 字符串列表。如果正在格式化的数大于等于 choiceLimits[i] 且小于 choiceLimits[i+1]，则该格式器将返回 choiceFormats[i]。

类 java.text.DateFormat 继承 Format 实现 Serializable

serialVersionUID: 7218322306649953788L

序列化字段

calendar

Calendar calendar
DateFormat 使用 calendar 来生成实现日期和时间格式化所需的时间字段值。子类应将此 calendar 初始化为适合于与此 DateFormat 关联的语言环境的日历。

numberFormat

NumberFormat numberFormat
数字格式器，DateFormat 用其来格式化日期和时间中的数字。子类应将此数字格式器初始化为适合于与此 DateFormat 关联的语言环境的数字格式。

类 java.text.DateFormat.Field 继承 Format.Field 实现 Serializable

serialVersionUID: 7441350119349544720L

序列化方法

readResolve

protected Object readResolve()
                      throws InvalidObjectException
将反序列化的实例解析成预定义的常量。

抛出：
InvalidObjectException - 如果无法解析该常量。
序列化字段

calendarField

int calendarField
Calendar 字段。

类 java.text.DateFormatSymbols 继承 Object 实现 Serializable

serialVersionUID: -5987973545549424702L

序列化方法

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
为了确保向后兼容性，在确保 zoneStrings 字段被初始化之后写出默认可序列化数据。

抛出：
IOException
从以下版本开始：
1.6
序列化字段

eras

String[] eras
Era strings. For example: "AD" and "BC". An array of 2 strings, indexed by Calendar.BC and Calendar.AD.

months

String[] months
Month strings. For example: "January", "February", etc. An array of 13 strings (some calendars have 13 months), indexed by Calendar.JANUARY, Calendar.FEBRUARY, etc.

shortMonths

String[] shortMonths
Short month strings. For example: "Jan", "Feb", etc. An array of 13 strings (some calendars have 13 months), indexed by Calendar.JANUARY, Calendar.FEBRUARY, etc.

weekdays

String[] weekdays
Weekday strings. For example: "Sunday", "Monday", etc. An array of 8 strings, indexed by Calendar.SUNDAY, Calendar.MONDAY, etc. The element weekdays[0] is ignored.

shortWeekdays

String[] shortWeekdays
Short weekday strings. For example: "Sun", "Mon", etc. An array of 8 strings, indexed by Calendar.SUNDAY, Calendar.MONDAY, etc. The element shortWeekdays[0] is ignored.

ampms

String[] ampms
AM and PM strings. For example: "AM" and "PM". An array of 2 strings, indexed by Calendar.AM and Calendar.PM.

zoneStrings

String[][] zoneStrings
Localized names of time zones in this locale. This is a two-dimensional array of strings of size n by m, where m is at least 5. Each of the n rows is an entry containing the localized names for a single TimeZone. Each such row contains (with i ranging from 0..n-1):
  • zoneStrings[i][0] - time zone ID
  • zoneStrings[i][1] - long name of zone in standard time
  • zoneStrings[i][2] - short name of zone in standard time
  • zoneStrings[i][3] - long name of zone in daylight saving time
  • zoneStrings[i][4] - short name of zone in daylight saving time
The zone ID is not localized; it's one of the valid IDs of the TimeZone class that are not custom IDs. All other entries are localized names.

另请参见：
TimeZone

localPatternChars

String localPatternChars
Localized date-time pattern characters. For example, a locale may wish to use 'u' rather than 'y' to represent years in its date format pattern strings. This string must be exactly 18 characters long, with the index of the characters described by DateFormat.ERA_FIELD, DateFormat.YEAR_FIELD, etc. Thus, if the string were "Xz...", then localized patterns would use 'X' for era and 'z' for year.

locale

Locale locale
The locale which is used for initializing this DateFormatSymbols object.

从以下版本开始：
1.6

类 java.text.DecimalFormat 继承 NumberFormat 实现 Serializable

serialVersionUID: 864413376551465018L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
从流中读取默认的可序列化字段，并对较旧的序列化版本执行验证和调整。该验证和调整有：
  1. 验证超类的位数计数字段是否正确地反映了在除 BigInteger 和 BigDecimal 对象之外的格式化数字上所施加的限制。这些限制存储在与较旧版本序列化兼容的超类中，而 BigInteger 和 BigDecimal 对象的限制也保存在此类中。在该超类中，如果最小或最大整数位数计数大于 DOUBLE_INTEGER_DIGITS，或者最小或最大小数位数计数大于 DOUBLE_FRACTION_DIGITS，则流数据无效并且此方法抛出 InvalidObjectException。
  2. 如果 serialVersionOnStream 小于 4，则将 roundingMode 初始化为 RoundingMode.HALF_EVEN。此字段是版本 4 的新字段。
  3. 如果 serialVersionOnStream 小于 3，则为最小和最大整数和小数位数调用具有相应超类 getter 值的 setter，以初始化此类中的各个字段。此类中的各个字段是版本 3 的新字段。
  4. 如果 serialVersionOnStream 小于 1，则指示该流是用 JDK 1.1 所编写的，初始化 useExponentialNotation 会得到 false，因为在 JDK 1.1 中没有它。
  5. 如果再次流出此对象，则可将 serialVersionOnStream 设置为最大的允许值，以使默认的序列化可以正常工作。

版本早于 2 的流没有前后缀模式变量 posPrefixPattern 等。所以将其初始化为 null，这意味着前后缀字符串将采用字面量值。这正是我们想要的，因为这对应于早于版本 2 的版本行为。

抛出：
IOException
ClassNotFoundException
序列化字段

positivePrefix

String positivePrefix
格式化正数时用作前缀的符号，例如 "+"。

另请参见：
DecimalFormat.getPositivePrefix()

positiveSuffix

String positiveSuffix
格式化正数时用作后缀的符号。这通常是一个空字符串。

另请参见：
DecimalFormat.getPositiveSuffix()

negativePrefix

String negativePrefix
格式化负数时用作前缀的符号，例如 "-"。

另请参见：
DecimalFormat.getNegativePrefix()

negativeSuffix

String negativeSuffix
格式化负数时用作后缀的符号。这通常是一个空字符串。

另请参见：
DecimalFormat.getNegativeSuffix()

posPrefixPattern

String posPrefixPattern
非负数的前缀模式。此变量对应于 positivePrefix。

此模式由方法 expandAffix() 对 positivePrefix 进行扩展得到，以更新后者从而反映 symbols 中的改变。如果此变量为 null，则将 positivePrefix 用作字面量值，在 symbols 改变时不改变该值。对于从早于流版本 2 的流中恢复的 DecimalFormat 对象而言，此变量始终为 null。

从以下版本开始：
1.3

posSuffixPattern

String posSuffixPattern
非负数的后缀模式。此变量对应于 positiveSuffix。此变量类似于 posPrefixPattern；有关进一步的内容，请参见该变量。

从以下版本开始：
1.3

negPrefixPattern

String negPrefixPattern
负数的前缀模式。此变量对应于 negativePrefix。此变量类似于 posPrefixPattern；有关进一步的内容，请参见该变量。

从以下版本开始：
1.3

negSuffixPattern

String negSuffixPattern
负数的后缀模式。此变量对应于 negativeSuffix。此变量类似于 posPrefixPattern；有关进一步的内容，请参见该变量。

从以下版本开始：
1.3

multiplier

int multiplier
百分数、千分数等使用的乘数。

另请参见：
DecimalFormat.getMultiplier()

groupingSize

byte groupingSize
数的整数部分中分组分隔符之间的数字位数。如果 NumberFormat.groupingUsed 为 true，则该值必须大于 0。

另请参见：
DecimalFormat.getGroupingSize(), NumberFormat.isGroupingUsed()

decimalSeparatorAlwaysShown

boolean decimalSeparatorAlwaysShown
如果为 true，则强制小数分隔符总是出现在已格式化的数中，即使数的小数部分为零也是如此。

另请参见：
DecimalFormat.isDecimalSeparatorAlwaysShown()

parseBigDecimal

boolean parseBigDecimal
如果为 true，则只要有可能，解析就返回 BigDecimal。

从以下版本开始：
1.5
另请参见：
DecimalFormat.isParseBigDecimal()

symbols

DecimalFormatSymbols symbols
此格式使用的 DecimalFormatSymbols 对象。它包含用于格式化数的符号，例如分组分隔符、小数分隔符等等。

另请参见：
DecimalFormat.setDecimalFormatSymbols(java.text.DecimalFormatSymbols), DecimalFormatSymbols

useExponentialNotation

boolean useExponentialNotation
如果为 True，则在格式化数时强制使用指数（也就是科学）计数法。

从以下版本开始：
1.2

minExponentDigits

byte minExponentDigits
以科学计数法格式化数时，用于显示指数的最小数字位数。如果 useExponentialNotation 不为 true，则忽略此字段。

从以下版本开始：
1.2

maximumIntegerDigits

int maximumIntegerDigits
BigInteger 或 BigDecimal 的整数部分中所允许的最大数字位数。maximumIntegerDigits 必须大于等于 minimumIntegerDigits。

从以下版本开始：
1.5
另请参见：
DecimalFormat.getMaximumIntegerDigits()

minimumIntegerDigits

int minimumIntegerDigits
BigInteger 或 BigDecimal 的整数部分中所允许的最小数字位数。minimumIntegerDigits 必须小于等于 maximumIntegerDigits。

从以下版本开始：
1.5
另请参见：
DecimalFormat.getMinimumIntegerDigits()

maximumFractionDigits

int maximumFractionDigits
BigInteger 或 BigDecimal 的小数部分中所允许的最大数字位数。maximumFractionDigits 必须大于等于 minimumFractionDigits。

从以下版本开始：
1.5
另请参见：
DecimalFormat.getMaximumFractionDigits()

minimumFractionDigits

int minimumFractionDigits
BigInteger 或 BigDecimal 的小数部分中所允许的最小数字位数。minimumFractionDigits 必须小于等于 maximumFractionDigits。

从以下版本开始：
1.5
另请参见：
DecimalFormat.getMinimumFractionDigits()

roundingMode

RoundingMode roundingMode
在此 DecimalFormat 中使用的 RoundingMode。

从以下版本开始：
1.6

serialVersionOnStream

int serialVersionOnStream
声明写入何种版本的内部系列版本。可能的值为：
  • 0（默认值）：Java 2 平台 v1.2 之前的版本
  • 1：1.2 版本，包括两个新字段 useExponentialNotation 和 minExponentDigits。
  • 2：1.3 和以后版本，添加了四个新字段：posPrefixPattern、posSuffixPattern、negPrefixPattern 和 negSuffixPattern。
  • 3：1.5 和以后版本，添加了五个新字段：maximumIntegerDigits、minimumIntegerDigits、maximumFractionDigits、minimumFractionDigits 和 parseBigDecimal。
  • 4：1.6 和以后版本，添加了一个新字段：roundingMode。

从以下版本开始：
1.2

类 java.text.DecimalFormatSymbols 继承 Object 实现 Serializable

serialVersionUID: 5772796243397350300L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
读取默认的可序列化字段、为较旧系列版本的对象提供默认值，并对不可序列化的字段进行初始化。如果 serialVersionOnStream 小于 1，则将 monetarySeparator 初始化为与 decimalSeparator 相同，并将 exponential 初始化为 'E'。如果 serialVersionOnStream 小于 2，则将 locale 初始化为根语言环境。如果 serialVersionOnStream 小于 3，则它使用 exponential 初始化 exponentialSeparator。如果再次流出此对象，则可将 serialVersionOnStream 设置回最大的允许值，以使默认的序列化可以正常工作。根据 intlCurrencySymbol 字段来初始化货币。

抛出：
IOException
ClassNotFoundException
从以下版本开始：
JDK 1.1.6
序列化字段

zeroDigit

char zeroDigit
用于零的字符。

另请参见：
DecimalFormatSymbols.getZeroDigit()

groupingSeparator

char groupingSeparator
用于千位分隔符的字符。

另请参见：
DecimalFormatSymbols.getGroupingSeparator()

decimalSeparator

char decimalSeparator
用于十进制符号的字符。

另请参见：
DecimalFormatSymbols.getDecimalSeparator()

perMill

char perMill
用于千分数符号的字符。

另请参见：
DecimalFormatSymbols.getPerMill()

percent

char percent
用于百分数符号的字符。

另请参见：
DecimalFormatSymbols.getPercent()

digit

char digit
用于某种模式中数字的字符。

另请参见：
DecimalFormatSymbols.getDigit()

patternSeparator

char patternSeparator
用于在模式中分隔正数和负数子模式的字符。

另请参见：
DecimalFormatSymbols.getPatternSeparator()

infinity

String infinity
用于表示无穷大的字符串。

另请参见：
DecimalFormatSymbols.getInfinity()

NaN

String NaN
用于表示“非数字”的字符串。

另请参见：
DecimalFormatSymbols.getNaN()

minusSign

char minusSign
用于表示减号的字符。

另请参见：
DecimalFormatSymbols.getMinusSign()

currencySymbol

String currencySymbol
表示本地货币的字符串，如 "$"。

另请参见：
DecimalFormatSymbols.getCurrencySymbol()

intlCurrencySymbol

String intlCurrencySymbol
表示本地货币的 ISO 4217 货币代码，如 "USD"。

另请参见：
DecimalFormatSymbols.getInternationalCurrencySymbol()

monetarySeparator

char monetarySeparator
格式化货币值时使用的小数点。

从以下版本开始：
JDK 1.1.6
另请参见：
DecimalFormatSymbols.getMonetaryDecimalSeparator()

exponential

char exponential
用于以指数计数法格式化数字时，区分数字中指数的字符，例如像数字 "1.23E45" 中的 'E'。

注意，公共的 API 没有提供设置此字段的方法，即使实现和流格式支持该设置也是如此。在以后会将该功能添加到 API 中。

从以下版本开始：
JDK 1.1.6

exponentialSeparator

String exponentialSeparator
用于分隔尾数和指数的字符串。示例：1.23x10^4 中的 "x10^"，1.23E4 中的 "E"。

如果 exponential 和 exponentialSeparator 都存在，则优先使用此 exponentialSeparator。

从以下版本开始：
1.6

locale

Locale locale
这些货币格式符号的语言环境。

从以下版本开始：
1.4

serialVersionOnStream

int serialVersionOnStream
描述流中存在的 DecimalFormatSymbols 的版本。可能的值为：
  • 0（或未初始化的）：JDK 1.1.6 之前的版本。
  • 1：使用 JDK 1.1.6 或更高版本所编写，包括两个新字段：monetarySeparator 和 exponential。
  • 2：使用 J2SE 1.4 或更高版本所编写，包括新的 locale 字段。
  • 3: 使用 J2SE 1.6 或更高版本所编写，包括新的 exponentialSeparator 字段。
流出 DecimalFormatSymbols 时，总是写入最新的格式（对应于允许的最高 serialVersionOnStream）。

从以下版本开始：
JDK 1.1.6

类 java.text.Format 继承 Object 实现 Serializable

serialVersionUID: -299282585814624189L

类 java.text.Format.Field 继承 AttributedCharacterIterator.Attribute 实现 Serializable

serialVersionUID: 276966692217360283L

类 java.text.MessageFormat 继承 Format 实现 Serializable

serialVersionUID: 6479157306784022952L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从输入流中读取一个对象后，进行简单的验证以维护类常量。

抛出：
InvalidObjectException - 如果从流读入的对象无效。
IOException
ClassNotFoundException
序列化字段

locale

Locale locale
用于格式化数字和日期的语言环境。

pattern

String pattern
要插入格式化后的值的字符串。换句话说，这是对所有取出的 {} 表达式进行构造所提供的方法。

formats

Format[] formats
格式器数组，它们用于对参数进行格式化。

offsets

int[] offsets
每个参数格式化结果要插入到模式中的位置。

argumentNumbers

int[] argumentNumbers
对应于每个格式器的参数个数。（格式器按照它们在模式中出现的顺序进行存储，而不是按照参数被指定的顺序）。

maxOffset

int maxOffset
比 offsets 中的条目数少 1。也可以看作正被使用的 offsets 中的最高数字的元素的索引。所有这些数组必须具有与 offsets 相同个数的元素，因此该变量能够告知我们数组中有多少个条目。

类 java.text.MessageFormat.Field 继承 Format.Field 实现 Serializable

serialVersionUID: 7899943957617360810L

序列化方法

readResolve

protected Object readResolve()
                      throws InvalidObjectException
把正被反序列化的实例解析为预定义的常量。

抛出：
InvalidObjectException - 如果常量无法解析。

类 java.text.NumberFormat 继承 Format 实现 Serializable

serialVersionUID: -2308460125733713944L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
首先，读取默认的序列化数据。 然后，如果 serialVersionOnStream 小于 1，指示流是用 JDK 1.1 编写的，则设置 int 字段（例如 maximumIntegerDigits）等于 byte 字段（例如 maxIntegerDigits），因为 int 字段在 JDK 1.1 中不存在。最后，将 serialVersionOnStream 重新设置为允许的最大值，这样如果此对象再次流出时，默认的序列化可以正常工作。

如果 minimumIntegerDigits 大于 maximumIntegerDigits，或者 minimumFractionDigits 大于 maximumFractionDigits，则流数据无效且此方法抛出 InvalidObjectException。此外，如果这些值中的任何一个是负数，则此方法抛出 InvalidObjectException。

抛出：
IOException
ClassNotFoundException
从以下版本开始：
1.2

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
为了与流格式的 JDK 1.1 版本保持兼容，首先设置 byte 字段（例如 maxIntegerDigits）等于 int 字段（例如 maximumIntegerDigits）（或者等于 Byte.MAX_VALUE，取决于二者中那个值更小），然后写出默认的序列化数据。

抛出：
IOException
从以下版本开始：
1.2
序列化字段

groupingUsed

boolean groupingUsed
如果格式化和解析数值时使用了组（即千位）分隔符，则返回 true。

另请参见：
NumberFormat.isGroupingUsed()

maxIntegerDigits

byte maxIntegerDigits
数值的整数部分允许的最大位数。maxIntegerDigits 必须大于等于 minIntegerDigits。

注：此字段仅在与 JDK 1.1 兼容的序列化中存在。在 Java 2 平台 的 v1.2 和更高版本中，用 int 字段 maximumIntegerDigits 来替代。当写入一个流时，maxIntegerDigits 被设置为 maximumIntegerDigits 或 Byte.MAX_VALUE 中较小的一个。当从一个流读取时，仅当 serialVersionOnStream 小于 1 时使用此字段。

另请参见：
NumberFormat.getMaximumIntegerDigits()

minIntegerDigits

byte minIntegerDigits
数的整数部分允许的最小位数，minimumIntegerDigits 必须小于等于 maximumIntegerDigits。

注：此字段仅在与 JDK 1.1 兼容的序列化中存在。在 Java 2 平台 的 v1.2 和更高版本中，用新的 int 字段 minimumIntegerDigits 来替代。当写入一个流时，minIntegerDigits 被设置为 minimumIntegerDigits 或 Byte.MAX_VALUE 中较小的一个。当从一个流读取时，仅当 serialVersionOnStream 小于 1 时使用此字段。

另请参见：
NumberFormat.getMinimumIntegerDigits()

maxFractionDigits

byte maxFractionDigits
数的小数部分允许的最大位数，maximumFractionDigits 必须大于等于 minimumFractionDigits。

注： 此字段仅在与 JDK 1.1 兼容的序列化中存在。在 Java 2 平台 的 v1.2 和更高版本中，用新的 int 字段 maximumFractionDigits 来替代。当写入一个流时，maxFractionDigits 被设置为 maximumFractionDigits 或 Byte.MAX_VALUE 中较小的一个。当从一个流读取时，仅当 serialVersionOnStream 小于 1 时使用此字段。

另请参见：
NumberFormat.getMaximumFractionDigits()

minFractionDigits

byte minFractionDigits
数的小数部分允许的最小位数。minimumFractionDigits 必须小于等于 maximumFractionDigits。

注：此字段仅在与 JDK 1.1 兼容的序列化中存在。在 Java 2 平台 的 v1.2 和更高版本中，用新的 int field minimumFractionDigits 来替代。当写入一个流时，minFractionDigits 被设置为 minimumFractionDigits 或 Byte.MAX_VALUE 中较小的一个。当从一个流读取时，仅当 serialVersionOnStream 小于 1 时使用此字段。

另请参见：
NumberFormat.getMinimumFractionDigits()

parseIntegerOnly

boolean parseIntegerOnly
如果此格式仅将数作为整数解析，则返回 true。

另请参见：
NumberFormat.isParseIntegerOnly()

maximumIntegerDigits

int maximumIntegerDigits
数的整数部分允许的最大位数。maximumIntegerDigits 必须大于等于 minimumIntegerDigits。

从以下版本开始：
1.2
另请参见：
NumberFormat.getMaximumIntegerDigits()

minimumIntegerDigits

int minimumIntegerDigits
数的整数部分允许的最小位数。minimumIntegerDigits 必须小于等于 maximumIntegerDigits。

从以下版本开始：
1.2
另请参见：
NumberFormat.getMinimumIntegerDigits()

maximumFractionDigits

int maximumFractionDigits
数的小数部分允许的最大位数。maximumFractionDigits 必须大于等于 minimumFractionDigits。

从以下版本开始：
1.2
另请参见：
NumberFormat.getMaximumFractionDigits()

minimumFractionDigits

int minimumFractionDigits
数的小数部分允许的最小位数。minimumFractionDigits 必须小于等于 maximumFractionDigits。

从以下版本开始：
1.2
另请参见：
NumberFormat.getMinimumFractionDigits()

serialVersionOnStream

int serialVersionOnStream
描述了流上存在的 NumberFormat 的版本。可能的值为：
  • 0（或未初始化）：流格式的 JDK 1.1 版本。在此版本中，诸如 maximumIntegerDigits 之类的 int 字段不存在，而使用如 maxIntegerDigits 这样的 byte 字段来替代。
  • 1：流格式的 1.2 版本。诸如 maxIntegerDigits 之类的 byte 字段的值被忽略，而使用如 maximumIntegerDigits 这样的 int 字段来替代。
当流出 NumberFormat 时，总是写入最近的格式（对应于允许的最高 serialVersionOnStream）。

从以下版本开始：
1.2

类 java.text.NumberFormat.Field 继承 Format.Field 实现 Serializable

serialVersionUID: 7494728892700160890L

序列化方法

readResolve

protected Object readResolve()
                      throws InvalidObjectException
将正被反序列化的实例解析为预定义的常量。

抛出：
InvalidObjectException - 如果无法解析常量。

类 java.text.ParseException 继承 Exception 实现 Serializable

序列化字段

errorOffset

int errorOffset
从零开始的字符偏移量，在解析过程中，在字符串中的此处发现错误。

类 java.text.SimpleDateFormat 继承 DateFormat 实现 Serializable

serialVersionUID: 4774881970558875024L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
在从输入流中读取对象后，验证对象中的格式模式。

抛出：
InvalidObjectException - 如果模式无效
IOException
ClassNotFoundException
序列化字段

serialVersionOnStream

int serialVersionOnStream
流上序列化数据的版本。可能的值：
  • 0 或者不出现在流上：JDK 1.1.3。此版本在流上没有 defaultCenturyStart。
  • 1 JDK 1.1.4 或更高版本。此版本增加了 defaultCenturyStart。
在流出此类时，编写最新格式和所允许的最高 serialVersionOnStream。

从以下版本开始：
JDK1.1.4

pattern

String pattern
此格式器的模式字符串。这始终是一个非本地化的模式。不能为 null。有关详细信息，请参阅类文档。

formatData

DateFormatSymbols formatData
此格式器为周名称、月名称等使用的符号。不能为 null。

另请参见：
DateFormatSymbols

defaultCenturyStart

Date defaultCenturyStart
我们将两位数字的年份日期映射到从 defaultCenturyStart 开始的世纪（可以为任何日期）。不能为 null。

从以下版本开始：
JDK1.1.4

locale

Locale locale
用于实例化此 SimpleDateFormat 的 Locale。如果此对象已由旧的 SimpleDateFormat 创建并且进行了反序列化，则值可以为 null。

从以下版本开始：
1.6
软件包 java.util

类 java.util.AbstractMap.SimpleEntry 继承 Object 实现 Serializable

serialVersionUID: -8499721149061103585L

序列化字段

key

Object key

value

Object value

类 java.util.AbstractMap.SimpleImmutableEntry 继承 Object 实现 Serializable

serialVersionUID: 7138329143949025153L

序列化字段

key

Object key

value

Object value

类 java.util.ArrayDeque 继承 AbstractCollection<E> 实现 Serializable

serialVersionUID: 2340985798034038923L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
将此双端队列反序列化。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此双端队列序列化。

序列数据：
双端队列的当前大小 (int)，按从前到后的顺序紧跟其所有元素（一个对象引用一个）。
抛出：
IOException

类 java.util.ArrayList 继承 AbstractList<E> 实现 Serializable

serialVersionUID: 8683452581122892189L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构 ArrayList 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 ArrayList 实例的状态保存到流中（也就是将其序列化）。

序列数据：
支持发出 ArrayList 实例的数组的长度 (int)，后面是按适当顺序排列的所有元素（每个元素都是一个 Object）。
抛出：
IOException
序列化字段

size

int size
ArrayList 的大小（它包含的元素数）。

类 java.util.Arrays.ArrayList 继承 AbstractList<E> 实现 Serializable

serialVersionUID: -2764017481108945198L

序列化字段

a

Object[] a

类 java.util.BitSet 继承 Object 实现 Serializable

serialVersionUID: 7997698588986878753L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重建 BitSet 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 BitSet 实例保存到流中（也就是将其序列化）。

抛出：
IOException
序列化字段

bits

long[] bits
此 BitSet 中的位。第 i 个位存储在数位位置为 i % 64 的 bits[i/64]中（其中数位位置 0 表示最低有效位，数位位置 63 表示最高有效位）。

类 java.util.Calendar 继承 Object 实现 Serializable

serialVersionUID: -1807547505821590642L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
从流重构此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
将此对象的状态保存到流中（也就是将其序列化）。 理想情况下，Calendar 将只写出其状态数据和当前时间，并且不会写出任何字段数据，比如 fields[]、isTimeSet、areFieldsSet 和 isSet[]。nextStamp 不应该是持久存储状态的一部分。不幸的是，在发行 JDK 1.1 之前，事情并非如此。为了与 JDK 1.1 兼容，必须总是写出字段值和状态标志。不过，可以从序列化流中移除 nextStamp；可能在以后会实现。

抛出：
IOException
序列化字段

fields

int[] fields
此日历当前设置时间的日历字段值。这是一个 FIELD_COUNT 整数数组，索引值为 ERA 到 DST_OFFSET。

isSet

boolean[] isSet
通知是否设置了该日历某一指定日历字段的标志。新的对象没有设置任何字段。在第一次调用生成该字段的某一方法后，这些字段都将保留调用之后的设置。这是一个 FIELD_COUNT 布尔值数组，索引值为 ERA 到 DST_OFFSET。

time

long time
日历的当前设置时间，以毫秒为单位，表示自格林威治标准时间 1970 年 1月 1 日 0:00:00 后经过的时间。

另请参见：
Calendar.isTimeSet

isTimeSet

boolean isTimeSet
如果 time 值是一个有效值，则返回 true。通过更改 field[] 的项，可以使时间无效。

另请参见：
Calendar.time

areFieldsSet

boolean areFieldsSet
如果 fields[] 与当前的设置时间同步，则返回 true。如果返回 false，则在下一次试图获得某一字段的值时，将强行重新计算 time 当前值中的所有字段。

lenient

boolean lenient
如果此日历允许在计算 fields[] 中的 time 时使用超出范围的字段值，则返回 True。

另请参见：
Calendar.setLenient(boolean), Calendar.isLenient()

zone

TimeZone zone
此日历使用的 TimeZone。Calendar 使用时区数据来实现语言环境与 GMT 时间的转换。

firstDayOfWeek

int firstDayOfWeek
一星期中的第一天，可能的值是 SUNDAY、MONDAY，等等。这是一个同语言环境有关的值。

minimalDaysInFirstWeek

int minimalDaysInFirstWeek
一月或一年中第一个星期所需的天数，可能的值是从 1 到 7。这是一个同语言环境有关的值。

nextStamp

int nextStamp
stamp[]（一个内部数组）的下一个可用值。实际上不应该将该方法写出到流中，在以后，可能从流中将其移除。同时，应该使用 MINIMUM_USER_STAMP 值。

serialVersionOnStream

int serialVersionOnStream
流中序列化数据的版本。可能的值是：
0 或流中不存在该数据
JDK 1.1.5 或更早的版本。
1
JDK 1.1.6 或更高的版本。为其他字段编写一个正确的 'time' 值以及兼容的值。这是一种过渡格式。
在流出此类时，编写最新格式和所允许的最高 serialVersionOnStream。

从以下版本开始：
JDK1.1.6

类 java.util.Collections.CheckedCollection 继承 Object 实现 Serializable

serialVersionUID: 1578914078182001775L

序列化字段

c

Collection<E> c

type

Class<T> type

zeroLengthElementArray

Object[] zeroLengthElementArray

类 java.util.Collections.CheckedList 继承 java.util.Collections.CheckedCollection<E> 实现 Serializable

serialVersionUID: 65247728283967356L

序列化字段

list

List<E> list

类 java.util.Collections.CheckedMap 继承 Object 实现 Serializable

serialVersionUID: 5742860141034234728L

序列化字段

m

Map<K,V> m

keyType

Class<T> keyType

valueType

Class<T> valueType

zeroLengthKeyArray

Object[] zeroLengthKeyArray

zeroLengthValueArray

Object[] zeroLengthValueArray

类 java.util.Collections.CheckedRandomAccessList 继承 java.util.Collections.CheckedList<E> 实现 Serializable

serialVersionUID: 1638200125423088369L

类 java.util.Collections.CheckedSet 继承 java.util.Collections.CheckedCollection<E> 实现 Serializable

serialVersionUID: 4694047833775013803L

类 java.util.Collections.CheckedSortedMap 继承 java.util.Collections.CheckedMap<K,V> 实现 Serializable

serialVersionUID: 1599671320688067438L

序列化字段

sm

SortedMap<K,V> sm

类 java.util.Collections.CheckedSortedSet 继承 java.util.Collections.CheckedSet<E> 实现 Serializable

serialVersionUID: 1599911165492914959L

序列化字段

ss

SortedSet<E> ss

类 java.util.Collections.CopiesList 继承 AbstractList<E> 实现 Serializable

serialVersionUID: 2739099268398711800L

序列化字段

n

int n

element

Object element

类 java.util.Collections.EmptyList 继承 AbstractList<Object> 实现 Serializable

serialVersionUID: 8842843931221139166L

序列化方法

readResolve

private Object readResolve()

类 java.util.Collections.EmptySet 继承 AbstractSet<Object> 实现 Serializable

serialVersionUID: 1582296315990362920L

序列化方法

readResolve

private Object readResolve()

类 java.util.Collections.ReverseComparator 继承 Object 实现 Serializable

serialVersionUID: 7207038068494060240L

序列化方法

readResolve

private Object readResolve()

类 java.util.Collections.ReverseComparator2 继承 Object 实现 Serializable

serialVersionUID: 4374092139857L

序列化字段

cmp

Comparator<T> cmp
The comparator specified in the static factory. This will never be null, as the static factory returns a ReverseComparator instance if its argument is null.

类 java.util.Collections.SingletonSet 继承 AbstractSet<E> 实现 Serializable

serialVersionUID: 3193687207550431679L

序列化字段

element

Object element

类 java.util.Collections.SynchronizedCollection 继承 Object 实现 Serializable

serialVersionUID: 3053995032091335093L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException
序列化字段

c

Collection<E> c

mutex

Object mutex

类 java.util.Collections.SynchronizedList 继承 java.util.Collections.SynchronizedCollection<E> 实现 Serializable

serialVersionUID: -7754090372962971524L

序列化方法

readResolve

private Object readResolve()
SynchronizedRandomAccessList instances are serialized as SynchronizedList instances to allow them to be deserialized in pre-1.4 JREs (which do not have SynchronizedRandomAccessList). This method inverts the transformation. As a beneficial side-effect, it also grafts the RandomAccess marker onto SynchronizedList instances that were serialized in pre-1.4 JREs. Note: Unfortunately, SynchronizedRandomAccessList instances serialized in 1.4.1 and deserialized in 1.4 will become SynchronizedList instances, as this method was missing in 1.4.

序列化字段

list

List<E> list

类 java.util.Collections.SynchronizedMap 继承 Object 实现 Serializable

serialVersionUID: 1978198479659022715L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException
序列化字段

m

Map<K,V> m

mutex

Object mutex

类 java.util.Collections.SynchronizedRandomAccessList 继承 java.util.Collections.SynchronizedList<E> 实现 Serializable

serialVersionUID: 1530674583602358482L

序列化方法

writeReplace

private Object writeReplace()
Allows instances to be deserialized in pre-1.4 JREs (which do not have SynchronizedRandomAccessList). SynchronizedList has a readResolve method that inverts this transformation upon deserialization.

类 java.util.Collections.SynchronizedSet 继承 java.util.Collections.SynchronizedCollection<E> 实现 Serializable

serialVersionUID: 487447009682186044L

类 java.util.Collections.SynchronizedSortedMap 继承 java.util.Collections.SynchronizedMap<K,V> 实现 Serializable

serialVersionUID: -8798146769416483793L

序列化字段

sm

SortedMap<K,V> sm

类 java.util.Collections.SynchronizedSortedSet 继承 java.util.Collections.SynchronizedSet<E> 实现 Serializable

serialVersionUID: 8695801310862127406L

序列化字段

ss

SortedSet<E> ss

类 java.util.Collections.UnmodifiableCollection 继承 Object 实现 Serializable

serialVersionUID: 1820017752578914078L

序列化字段

c

Collection<E> c

类 java.util.Collections.UnmodifiableList 继承 java.util.Collections.UnmodifiableCollection<E> 实现 Serializable

serialVersionUID: -283967356065247728L

序列化方法

readResolve

private Object readResolve()
UnmodifiableRandomAccessList instances are serialized as UnmodifiableList instances to allow them to be deserialized in pre-1.4 JREs (which do not have UnmodifiableRandomAccessList). This method inverts the transformation. As a beneficial side-effect, it also grafts the RandomAccess marker onto UnmodifiableList instances that were serialized in pre-1.4 JREs. Note: Unfortunately, UnmodifiableRandomAccessList instances serialized in 1.4.1 and deserialized in 1.4 will become UnmodifiableList instances, as this method was missing in 1.4.

序列化字段

list

List<E> list

类 java.util.Collections.UnmodifiableMap 继承 Object 实现 Serializable

serialVersionUID: -1034234728574286014L

序列化字段

m

Map<K,V> m

类 java.util.Collections.UnmodifiableMap.UnmodifiableEntrySet 继承 java.util.Collections.UnmodifiableSet<Map.Entry<K,V>> 实现 Serializable

serialVersionUID: 7854390611657943733L

类 java.util.Collections.UnmodifiableRandomAccessList 继承 java.util.Collections.UnmodifiableList<E> 实现 Serializable

serialVersionUID: -2542308836966382001L

序列化方法

writeReplace

private Object writeReplace()
Allows instances to be deserialized in pre-1.4 JREs (which do not have UnmodifiableRandomAccessList). UnmodifiableList has a readResolve method that inverts this transformation upon deserialization.

类 java.util.Collections.UnmodifiableSet 继承 java.util.Collections.UnmodifiableCollection<E> 实现 Serializable

serialVersionUID: -9215047833775013803L

类 java.util.Collections.UnmodifiableSortedMap 继承 java.util.Collections.UnmodifiableMap<K,V> 实现 Serializable

serialVersionUID: -8806743815996713206L

序列化字段

sm

SortedMap<K,V> sm

类 java.util.Collections.UnmodifiableSortedSet 继承 java.util.Collections.UnmodifiableSet<E> 实现 Serializable

serialVersionUID: -4929149591599911165L

序列化字段

ss

SortedSet<E> ss

类 java.util.ConcurrentModificationException 继承 RuntimeException 实现 Serializable

类 java.util.Currency 继承 Object 实现 Serializable

serialVersionUID: -158308464356906721L

序列化方法

readResolve

private Object readResolve()
把正被反序列化的实例解析为每种货币的单个实例。

序列化字段

currencyCode

String currencyCode
此货币的 ISO 4217 货币代码。

类 java.util.Date 继承 Object 实现 Serializable

serialVersionUID: 7523967970034938905L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此对象的状态保存到流中（也就是将其序列化）。

序列数据：
发出由 getTime() 返回的值 (long)。它表示自 1970 年 1 月 1 日 00:00:00 GMT 的偏移量（以毫秒为单位）。
抛出：
IOException

类 java.util.DuplicateFormatFlagsException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 18890531L

序列化字段

flags

String flags

类 java.util.EmptyStackException 继承 RuntimeException 实现 Serializable

类 java.util.EnumMap 继承 AbstractMap<K extends Enum<K>,V> 实现 Serializable

serialVersionUID: 458661240069192865L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
重新构造来自流的 EnumMap 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 EnumMap 实例的状态保存到流中（也就是将其序列化）。

序列数据：
发出枚举映射的 size（键-值映射关系数），后跟由枚举映射表示的每个键-值映射关系的键 (Object) 和值 (Object)。
抛出：
IOException
序列化字段

keyType

Class<T> keyType
此映射所有键的枚举类型的 Class 对象。

类 java.util.EnumSet.SerializationProxy 继承 Object 实现 Serializable

serialVersionUID: 362491234563181265L

序列化方法

readResolve

private Object readResolve()
序列化字段

elementType

Class<T> elementType
The element type of this enum set.

elements

Enum<E extends Enum<E>>[] elements
The elements contained in this enum set.

类 java.util.EventObject 继承 Object 实现 Serializable

serialVersionUID: 5516075349620653480L

类 java.util.FormatFlagsConversionMismatchException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 19120414L

序列化字段

f

String f

c

char c

类 java.util.FormatterClosedException 继承 IllegalStateException 实现 Serializable

serialVersionUID: 18111216L

类 java.util.GregorianCalendar 继承 Calendar 实现 Serializable

serialVersionUID: -8125100834729963327L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
更新内部状态。

抛出：
IOException
ClassNotFoundException
序列化字段

gregorianCutover

long gregorianCutover
格里高利历规则的使用点，从标准新纪元开始以毫秒为单位来测量。默认时间 1582 年 10 月 15 日（格里高利历）00:00:00 UTC 或 -12219292800000L。对此默认值，1582 年 10 月 4 日（儒略历）之后是 1582 年 10 月 15 日（格里高利历）。这对应于儒略历日期号 2299161。

类 java.util.HashMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: 362498820763181265L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 HashMap 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 HashMap 实例的状态保存到流中（也就是将其序列化）。

序列数据：
发出 HashMap 的容量（桶数组的长度，为 int 值），后跟 size（一个 int 值，键-值映射关系数），后跟每个键-值映射关系的键 (Object) 和值 (Object)。发出的键-值映射关系没有特定顺序。
抛出：
IOException
序列化字段

threshold

int threshold
The next size value at which to resize (capacity * load factor).

loadFactor

float loadFactor
哈希表的加载因子。

类 java.util.HashSet 继承 AbstractSet<E> 实现 Serializable

serialVersionUID: -5024744406713321676L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 HashSet 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 HashSet 实例的状态保存到流中（也就是将它序列化）。

序列数据：
发出底层 HashMap 实例的容量（int）及其加载因子（float），后跟 set 的大小（所包含元素的数量（int）），再后跟着它的所有元素（每个元素都是一个对象），这些元素没有按特定顺序排列。
抛出：
IOException

类 java.util.Hashtable 继承 Dictionary<K,V> 实现 Serializable

serialVersionUID: 1421746759512286392L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 Hashtable（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 Hashtable 的状态保存到流中（也就是将其序列化）。

序列数据：
发出 Hashtable 的容量（桶数组的长度（为 int）），后跟 Hashtable 的大小（键-值映射关系的数量），再后面是由 Hashtable 表示的每个键-值映射关系的键（Object）和值（Object），发出这些键-值映射关系没有按照任何特定顺序。
抛出：
IOException
序列化字段

threshold

int threshold
如果表的大小超出此阈值，则要对其执行 rehash 操作。（阈值是一个 int 值，等于容量与加载因子的乘积。）

loadFactor

float loadFactor
哈希表的加载因子。

类 java.util.IdentityHashMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: 8188218128353913216L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 IdentityHashMap 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 IdentityHashMap 实例的状态保存到流中（也就是将其序列化）。

序列数据：
HashMap（键-值映射关系数）的大小 (int)，然后是 IdentityHashMap 所表示的每个键-值映射关系的键（对象）和值（对象）。发出的键-值映射关系没有特定顺序。
抛出：
IOException
序列化字段

size

int size
返回此标识哈希映射中的键-值映射关系数。

类 java.util.IllegalFormatCodePointException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 19080630L

序列化字段

c

int c

类 java.util.IllegalFormatConversionException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 17000126L

序列化字段

c

char c

arg

Class<T> arg

类 java.util.IllegalFormatException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: 18830826L

类 java.util.IllegalFormatFlagsException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 790824L

序列化字段

flags

String flags

类 java.util.IllegalFormatPrecisionException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 18711008L

序列化字段

p

int p

类 java.util.IllegalFormatWidthException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 16660902L

序列化字段

w

int w

类 java.util.InputMismatchException 继承 NoSuchElementException 实现 Serializable

类 java.util.LinkedHashMap 继承 HashMap<K,V> 实现 Serializable

serialVersionUID: 3801124242820219131L

序列化字段

accessOrder

boolean accessOrder
此链接哈希映射的迭代排序方法：访问顺序为 true；插入顺序为 false。

类 java.util.LinkedHashSet 继承 HashSet<E> 实现 Serializable

serialVersionUID: -2851667679971038690L

类 java.util.LinkedList 继承 AbstractSequentialList<E> 实现 Serializable

serialVersionUID: 876323262645176354L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构此 LinkedList 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此 LinkedList 实例的状态保存到流中（也就是将其序列化）。

序列数据：
列表的大小（它所包含的元素数）(int)，然后是其按恰当顺序排列的所有元素（每个对象）。
抛出：
IOException

类 java.util.Locale 继承 Object 实现 Serializable

serialVersionUID: 9149081749638150636L

序列化方法

readResolve

private Object readResolve()
                    throws ObjectStreamException
用新创建的对象替换已反序列化的 Locale 对象。用较旧的 ISO 代码替换较新的语言代码。用内部 String 副本替换国家/地区和变量代码。

抛出：
ObjectStreamException
序列化字段

language

String language
另请参见：
Locale.getLanguage()

country

String country
另请参见：
Locale.getCountry()

variant

String variant
另请参见：
Locale.getVariant()

hashcode

int hashcode
对象的哈希码的占位符。总为 -1。

类 java.util.MissingFormatArgumentException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 19190115L

序列化字段

s

String s

类 java.util.MissingFormatWidthException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 15560123L

序列化字段

s

String s

类 java.util.MissingResourceException 继承 RuntimeException 实现 Serializable

serialVersionUID: -4876345176062000401L

序列化字段

className

String className
用户所请求的资源包的类名。

key

String key
用户所请求的特定资源名。

类 java.util.NoSuchElementException 继承 RuntimeException 实现 Serializable

类 java.util.PriorityQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: -7720805057305804111L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 PriorityQueue 实例（即将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将实例的状态保存到流中（即将其序列化）。

序列数据：
底层实例数组的长度 (int)，然后是其按恰当顺序排列的所有元素（每个 Object）。
抛出：
IOException
序列化字段

size

int size
优先级队列中的元素数目。

comparator

Comparator<T> comparator
比较器，如果优先级队列使用元素的自然顺序，则为 null。

类 java.util.Properties 继承 Hashtable<Object,Object> 实现 Serializable

serialVersionUID: 4112578634029874840L

序列化字段

defaults

Properties defaults
一个属性列表，包含属性列表中所有未找到值的键的默认值。

类 java.util.PropertyPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: 7015263904581634791L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
Default fields.
抛出：
IOException
序列化字段

all_allowed

boolean all_allowed
boolean saying if "*" is in the collection.

permissions

Hashtable<K,V> permissions
A table of the PropertyPermissions.

类 java.util.Random 继承 Object 实现 Serializable

serialVersionUID: 3905348978240129619L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构 Random 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 Random 实例保存到流中。

抛出：
IOException
序列化概述
Random 的可序列化字段。

序列化字段

haveNextNextGaussian

boolean haveNextNextGaussian
nextNextGaussian 是有效的

nextNextGaussian

double；要返回的下一个 nextNextGaussian
Gaussian

seed

long； seed
随机计算的种子

类 java.util.ServiceConfigurationError 继承 Error 实现 Serializable

serialVersionUID: 74132770414881L

类 java.util.SimpleTimeZone 继承 TimeZone 实现 Serializable

serialVersionUID: -403250971215465050L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
从流重构此对象（也就是将其反序列化）。 我们同时处理 JDK 1.1 二进制格式和具有打包字节数组的完全格式。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
将此对象的状态保存到流中（也就是将其序列化）。

序列数据：
我们编写了两种格式，JDK 1.1 兼容格式，它使用 DOW_IN_MONTH_MODE 规则，在必需部分中后跟完全规则，在可选部分中则使用打包格式。在流入时 JDK 1.1 代码将忽略可选部分。

可选部分的内容：发出字节数组的长度 (int)；对于此版本为 4。发出给定长度的字节数组。字节数组的内容是字段 startDay、startDayOfWeek、endDay 和 endDayOfWeek 的 true 值。在必需部分中这些字段的值是适合于规则模式 DOW_IN_MONTH_MODE 的近似值，它是 JDK 1.1 唯一可识别的模式。

抛出：
IOException
序列化字段

startMonth

int startMonth
夏令时开始的月份。此值必须介于 Calendar.JANUARY 和 Calendar.DECEMBER（包含）之间。此值必须不能等于 endMonth。

如果 useDaylight 为 false，则忽略此值。

startDay

int startDay
此字段有两种可能的解释：
startMode == DOW_IN_MONTH
startDay 指示夏令时是在 startMonth 月份中的哪个日期开始的，该日期可以是从 1 到 28、30 或 31，具体取决于 startMonth。
startMode != DOW_IN_MONTH
startDay 指示夏令时是在 startMonth 月份中的哪个 startDayOfWeek 开始。例如，一个 +1 值和一个 Calendar.SUNDAY 的 startDayOfWeek 指示 startMonth 的第一个星期日。同样，+2 则指示第二个星期日，-1 指示最后一个星期日。0 值是非法的。

如果 useDaylight 为 false，则忽略此值。

startDayOfWeek

int startDayOfWeek
夏令时开始时是一周的星期几。此值必须介于 Calendar.SUNDAY 和 Calendar.SATURDAY（包括）之间。

如果 useDaylight 为 false 或 startMode == DAY_OF_MONTH，则忽略此值。

startTime

int startTime
夏令时开始日的子夜之后以毫秒表示的时间。此值表示为挂钟时间、标准时间或 UTC 时间，具体取决于 startTimeMode 的设置。

如果 useDaylight 为 false，则忽略此值。

startTimeMode

int startTimeMode
startTime 的格式，可为 WALL_TIME、STANDARD_TIME 或 UTC_TIME。

从以下版本开始：
1.3

endMonth

int endMonth
夏令时结束的月份。此值必须介于 Calendar.JANUARY 和 Calendar.UNDECIMBER 之间。此值必须不能等于 startMonth。

如果 useDaylight 为 false，则忽略此值。

endDay

int endDay
此字段有两种可能的解释：
endMode == DOW_IN_MONTH
endDay 指示夏令时是在 endMonth 月份中的哪个日期结束的，该日期可以是从 1 到 28、30 或 31，具体取决于 endMonth。
endMode != DOW_IN_MONTH
endDay 指示夏令时是在 endMonth 月份中哪个 endDayOfWeek 结束。例如，一个 +1 值和一个 Calendar.SUNDAY 的 endDayOfWeek 指示 endMonth 的第一个星期日。同样，+2 则指示第二个星期日，-1 指示最后一个星期日。0 值是非法的。

如果 useDaylight 为 false，则忽略此值。

endDayOfWeek

int endDayOfWeek
夏令时结束时，一周的星期几。此值必须介于 Calendar.SUNDAY 和 Calendar.SATURDAY（包括）之间。

如果 useDaylight 为 false 或 endMode == DAY_OF_MONTH，则忽略此值。

endTime

int endTime
夏令时结束日的子夜之后以毫秒表示的时间。此值表示为挂钟时间、标准时间或 UTC 时间，具体取决于 endTimeMode 的设置。

如果 useDaylight 为 false，则忽略此值。

endTimeMode

int endTimeMode
endTime 的格式，可为 WALL_TIME、STANDARD_TIME 或 UTC_TIME。

从以下版本开始：
1.3

startYear

int startYear
夏令时首次实施的年份。它是一个 AD 值。如果此值小于 1，则在所有的 AD 年份中都实施夏令时。

如果 useDaylight 为 false，则忽略此值。

rawOffset

int rawOffset
此时区与 GMT 之间以毫秒为单位的偏移量。负偏移表示西时区。要获得本地标准 时间，可用偏移量加上 GMT 时间。要获取本地挂钟时间，则还须加上 dstSavings。

useDaylight

boolean useDaylight
一个布尔值，当且仅当此时区使用夏令时时才为 true。如果此值为 false，则忽略其他几个字段。

monthLength

byte[] monthLength
此字段在 JDK 1.1 中是序列化的，因此，我们必须保持该顺序，以维护序列化的兼容性。不过，无需在每次创建新时区时都重新创建此数组。

包含值 {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31} 的字节数组。从 Java 2 平台 v1.2 开始忽略了此顺序，但为了保持与 JDK 1.1 的兼容性，还必须保持它的有序性。

startMode

int startMode
指定开始规则模式的变量。采用下面的值：
DOM_MODE
具体日期；例如，3 月 1 日。
DOW_IN_MONTH_MODE
一个月中的星期几；例如，3 月的最后一个星期日。
DOW_GE_DOM_MODE
一个月的某一天之后的星期几；例如，3 月 15 日或之后的星期日。
DOW_LE_DOM_MODE
一个月的某一天之前的星期几；例如，3 月 15 日或之前的星期日。
此字段的设置影响 startDay 字段的解释。

如果 useDaylight 为 false，则忽略此值。

从以下版本开始：
1.1.4

endMode

int endMode
指定结束规则模式的变量。采用下面的值：
DOM_MODE
具体日期；例如，3 月 1 日。
DOW_IN_MONTH_MODE
一个月中的星期几；例如，3 月的最后一个星期日。
DOW_GE_DOM_MODE
一个月的某一天之后的星期几；例如，3 月 15 日或之后的星期日。
DOW_LE_DOM_MODE
一个月的某一天之前的星期几；例如，3 月 15 日或之前的星期日。
此字段的设置影响 endDay 字段的解释。

如果 useDaylight 为 false，则忽略此值。

从以下版本开始：
1.1.4

dstSavings

int dstSavings
正值指示在 DST 期间节省的时间量（以毫秒为单位）。一般为 1 小时 (3600000)，有时为 30 分钟 (1800000)。

如果 useDaylight 为 false，则忽略此值。

从以下版本开始：
1.1.4

serialVersionOnStream

int serialVersionOnStream
流上序列化数据的版本。可能的值：
0 或者在流上不出现
JDK 1.1.3 或较早版本。
1
JDK 1.1.4 或更高版本。包括三个新字段：startMode、endMode 和 dstSavings。
2
JDK 1.3 或更高版本。包括两个新字段：startTimeMode 和 endTimeMode。
在流出此类时，编写最新格式和所允许的最高 serialVersionOnStream。

从以下版本开始：
1.1.4

类 java.util.Stack 继承 Vector<E> 实现 Serializable

serialVersionUID: 1224463164541339165L

类 java.util.TimeZone 继承 Object 实现 Serializable

serialVersionUID: 3581463369166924961L

序列化字段

ID

String ID
此 TimeZone 的字符串标识符。这是一个编程标识符，供内部用于从系统表中查询 TimeZone 对象，也用于把它们映射到它们的本地化显示名称。ID 值在系统表中是唯一的，但可能不是针对动态创建的区域。

类 java.util.TooManyListenersException 继承 Exception 实现 Serializable

类 java.util.TreeMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: 919286545866124006L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
在某一流中重新构造 TreeMap 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 TreeMap 实例的状态保存到流中（也就是将其序列化）。

序列数据：
发出 TreeMap 的大小（健值映射关系数，用一个 int 值表示），后跟 TreeMap 表示的每个键-值映射关系的键（Object）和值（Object）。键-值映射关系是按照键的顺序发出的（由 TreeMap 的 Comparator 确定，如果 TreeMap 没有 Comparator，则该顺序由键的自然顺序确定）。
抛出：
IOException
序列化字段

comparator

Comparator<T> comparator
用来保持此树映射（tree map）中的顺序的比较器，如果此树映射使用它的键的自然顺序，则返回 null。

类 java.util.TreeMap.AscendingSubMap 继承 java.util.TreeMap.NavigableSubMap<K,V> 实现 Serializable

serialVersionUID: 912986545866124060L

类 java.util.TreeMap.DescendingSubMap 继承 java.util.TreeMap.NavigableSubMap<K,V> 实现 Serializable

serialVersionUID: 912986545866120460L

序列化字段

reverseComparator

Comparator<T> reverseComparator

类 java.util.TreeMap.NavigableSubMap 继承 AbstractMap<K,V> 实现 Serializable

序列化字段

m

TreeMap<K,V> m
The backing map.

lo

Object lo
Endpoints are represented as triples (fromStart, lo, loInclusive) and (toEnd, hi, hiInclusive). If fromStart is true, then the low (absolute) bound is the start of the backing map, and the other values are ignored. Otherwise, if loInclusive is true, lo is the inclusive bound, else lo is the exclusive bound. Similarly for the upper bound.

hi

Object hi
Endpoints are represented as triples (fromStart, lo, loInclusive) and (toEnd, hi, hiInclusive). If fromStart is true, then the low (absolute) bound is the start of the backing map, and the other values are ignored. Otherwise, if loInclusive is true, lo is the inclusive bound, else lo is the exclusive bound. Similarly for the upper bound.

fromStart

boolean fromStart

toEnd

boolean toEnd

loInclusive

boolean loInclusive

hiInclusive

boolean hiInclusive

类 java.util.TreeMap.SubMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: -6520786458950516097L

序列化方法

readResolve

private Object readResolve()
序列化字段

fromStart

boolean fromStart

toEnd

boolean toEnd

fromKey

Object fromKey

toKey

Object toKey

类 java.util.TreeMap$SubMap$DescendingEntrySetView 继承 Object 实现 Serializable

类 java.util.TreeMap$DescendingEntryIterator 继承 Object 实现 Serializable

类 java.util.TreeMap$DescendingEntrySet 继承 Object 实现 Serializable

类 java.util.TreeMap$DescendingKeySet 继承 Object 实现 Serializable

类 java.util.TreeMap$DescendingSubMapEntryIterator 继承 Object 实现 Serializable

类 java.util.TreeMap$SubMapEntryIterator 继承 Object 实现 Serializable

类 java.util.TreeSet 继承 AbstractSet<E> 实现 Serializable

serialVersionUID: -2479143000061671589L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
在某一流中重新构造 TreeSet 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 TreeSet 实例的状态保存到流中（也就是将其序列化）。

序列数据：
发出用于对此 set 进行排序的比较器，如果其元素遵循自然顺序（Object），则发出 null，后跟该 set 的大小（它包含的元素数，用一个 int 值表示），再后面是其按顺序排列的所有元素（每个元素是一个 Object）（该顺序由 set 的 Comparator 确定；如果 set 没有 Comparator，则该顺序由元素的自然顺序确定）。
抛出：
IOException

类 java.util.UnknownFormatConversionException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 19060418L

序列化字段

s

String s

类 java.util.UnknownFormatFlagsException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 19370506L

序列化字段

flags

String flags

类 java.util.UUID 继承 Object 实现 Serializable

serialVersionUID: -4856846361193249489L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
根据流重构 UUID 实例（也就是将其反序列化）。这对于将各个 transient 字段设置为其正确的未初始化的值以便按需重新计算很有必要。

抛出：
IOException
ClassNotFoundException
序列化字段

mostSigBits

long mostSigBits

leastSigBits

long leastSigBits

类 java.util.Vector 继承 AbstractList<E> 实现 Serializable

serialVersionUID: -2767605614048989439L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 Vector 实例的状态保存到流中（也就是将其序列化）。此方法只在同步时使用。它仅调用默认的 writeObject 方法。

抛出：
IOException
序列化字段

elementData

Object[] elementData
存储向量组件的数组缓冲区。vector 的容量就是此数据缓冲区的长度，该长度至少要足以包含向量的所有元素。

Vector 中的最后一个元素后的任何数组元素都为 null。

elementCount

int elementCount
Vector 对象中的有效组件数。从 elementData[0] 到 elementData[elementCount-1] 的组件均为实际项。

capacityIncrement

int capacityIncrement
向量的大小大于其容量时，容量自动增加的量。如果容量的增量小于等于零，则每次需要增大容量时，向量的容量将增大一倍。

软件包 java.util.concurrent

类 java.util.concurrent.ArrayBlockingQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: -817911632652898426L

序列化字段

items

Object[] items
已加入队列的项

takeIndex

int takeIndex
下次提取、轮询或移除的项索引

putIndex

int putIndex
下次放入、提供或添加的项索引

count

int count
队列中的项的数量

lock

ReentrantLock lock
保护所有访问的主锁

notEmpty

Condition notEmpty
等待取出的条件

notFull

Condition notFull
等待放入的条件

类 java.util.concurrent.BrokenBarrierException 继承 Exception 实现 Serializable

serialVersionUID: 7117394618823254244L

类 java.util.concurrent.CancellationException 继承 IllegalStateException 实现 Serializable

serialVersionUID: -9202173006928992231L

类 java.util.concurrent.ConcurrentHashMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: 7249069246763182397L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构 ConcurrentHashMap 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 ConcurrentHashMap 实例的状态保存到流中（也就是将其序列化）。

序列数据：
每个键-值映射关系的键 (Object) 和值 (Object)，后跟一个 null 对。键-值映射关系的发出没有任何特定顺序。
抛出：
IOException
序列化字段

segmentMask

int segmentMask
用来对段进行索引的掩码值。哈希表的键的高位被用来选择段。

segmentShift

int segmentShift
用来在段中进行索引的移位值。

segments

java.util.concurrent.ConcurrentHashMap.Segment<K,V>[] segments
每个段都是一个专门的哈希表。

类 java.util.concurrent.ConcurrentLinkedQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: 196745693267521676L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
在某一流中重构 Queue 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将状态保存到流中（也就是将其序列化）。

序列数据：
以恰当顺序排列的所有元素（每个元素是一个 E），后跟一个 null
抛出：
IOException

类 java.util.concurrent.ConcurrentSkipListMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: -8627078645895051609L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构映射。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此映射的状态保存到流中。

序列数据：
映射表示的每个键-值映射关系的键 (Object) 和值 (Object)，后跟 null。按照键顺序（由 Comparator 确定，如果没有 Comparator，则由键的自然顺序确定）发出键-值映射关系。
抛出：
IOException
序列化字段

comparator

Comparator<T> comparator
用于维护此映射中顺序的比较器；如果使用自然顺序，则为 null。

类 java.util.concurrent.ConcurrentSkipListMap$DescendingEntryIterator 继承 Object 实现 Serializable

类 java.util.concurrent.ConcurrentSkipListMap$DescendingEntrySet 继承 Object 实现 Serializable

类 java.util.concurrent.ConcurrentSkipListMap$DescendingKeyIterator 继承 Object 实现 Serializable

类 java.util.concurrent.ConcurrentSkipListMap$DescendingKeySet 继承 Object 实现 Serializable

类 java.util.concurrent.ConcurrentSkipListMap.SubMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: -7647078645895051609L

序列化字段

m

ConcurrentSkipListMap<K,V> m
Underlying map

lo

Object lo
lower bound key, or null if from start

hi

Object hi
upper bound key, or null if to end

loInclusive

boolean loInclusive
inclusion flag for lo

hiInclusive

boolean hiInclusive
inclusion flag for hi

isDescending

boolean isDescending
direction

类 java.util.concurrent.ConcurrentSkipListSet 继承 AbstractSet<E> 实现 Serializable

serialVersionUID: -2479143111061671589L

序列化字段

m

ConcurrentNavigableMap<K,V> m
底层映射。将 Boolean.TRUE 用作每个元素的值。为了线程安全将此字段声明为 final，这会在 clone() 中带来一些丑陋的外观。

类 java.util.concurrent.CopyOnWriteArrayList 继承 Object 实现 Serializable

serialVersionUID: 8673264195747942595L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构列表（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将列表状态保存到流中（也就是将其序列化）。

序列数据：
发出支持列表的数组的长度（一个 int 值），后跟以适当顺序排列的所有数组元素（均为对象）。
抛出：
IOException

类 java.util.concurrent.CopyOnWriteArraySet 继承 AbstractSet<E> 实现 Serializable

serialVersionUID: 5457747651344034263L

序列化字段

al

CopyOnWriteArrayList<E> al

类 java.util.concurrent.ExecutionException 继承 Exception 实现 Serializable

serialVersionUID: 7830266012832686185L

类 java.util.concurrent.LinkedBlockingDeque 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: -387911632671998426L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构此双端队列（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此双端队列的状态保存到流中（也就是将其序列化）。

序列数据：
容量 (int)，后跟以恰当顺序排列的元素（每个都是 Object），然后是 null
抛出：
IOException
序列化字段

capacity

int capacity
双端队列中的最大条目数

lock

ReentrantLock lock
保护所有访问的主锁

notEmpty

Condition notEmpty
等待 take 的条件

notFull

Condition notFull
等待 put 的条件

类 java.util.concurrent.LinkedBlockingQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: -6903933977591709194L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构此队列实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将状态保存到流中（也就是将其序列化）。

序列数据：
发出容量 (int)，后跟按适当顺序排列的所有元素（每个都是顺序正确的 Object），后跟 null。
抛出：
IOException
序列化字段

capacity

int capacity
容量上限，如果没有则为 Integer.MAX_VALUE。

count

AtomicInteger count
当前的元素数。

takeLock

ReentrantLock takeLock
由 take、poll 等所保持的锁。

notEmpty

Condition notEmpty
等待 take 的等待队列。

putLock

ReentrantLock putLock
由 put、offer 等所保持的锁。

notFull

Condition notFull
等待 put 的等待队列。

类 java.util.concurrent.PriorityBlockingQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: 5595510919245408276L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将状态保存到流中（也就是将其序列化）。这只包装锁内的默认序列化内容。该内容的序列化策略留给底层 Queue 负责。注意，在反序列化时不需要锁，所以并未定义 readObject，使用默认值即可。

抛出：
IOException
序列化字段

q

PriorityQueue<E> q

lock

ReentrantLock lock

notEmpty

Condition notEmpty

类 java.util.concurrent.RejectedExecutionException 继承 RuntimeException 实现 Serializable

serialVersionUID: -375805702767069545L

类 java.util.concurrent.Semaphore 继承 Object 实现 Serializable

serialVersionUID: -3222578661600680210L

序列化字段

sync

java.util.concurrent.Semaphore.Sync sync
通过 AbstractQueuedSynchronizer 子类实现的所有机制。

类 java.util.concurrent.SynchronousQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: -3223113410248163686L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将该状态保存到流中（也就是将其序列化）。

抛出：
IOException
序列化字段

qlock

ReentrantLock qlock

waitingProducers

java.util.concurrent.SynchronousQueue.WaitQueue waitingProducers

waitingConsumers

java.util.concurrent.SynchronousQueue.WaitQueue waitingConsumers

类 java.util.concurrent.TimeoutException 继承 Exception 实现 Serializable

serialVersionUID: 1900926677490660714L

软件包 java.util.concurrent.atomic

类 java.util.concurrent.atomic.AtomicBoolean 继承 Object 实现 Serializable

serialVersionUID: 4654671469794556979L

序列化字段

value

int value

类 java.util.concurrent.atomic.AtomicInteger 继承 Number 实现 Serializable

serialVersionUID: 6214790243416807050L

序列化字段

value

int value

类 java.util.concurrent.atomic.AtomicIntegerArray 继承 Object 实现 Serializable

serialVersionUID: 2862133569453604235L

序列化字段

array

int[] array

类 java.util.concurrent.atomic.AtomicLong 继承 Number 实现 Serializable

serialVersionUID: 1927816293512124184L

序列化字段

value

long value

类 java.util.concurrent.atomic.AtomicLongArray 继承 Object 实现 Serializable

serialVersionUID: -2308431214976778248L

序列化字段

array

long[] array

类 java.util.concurrent.atomic.AtomicReference 继承 Object 实现 Serializable

serialVersionUID: -1848883965231344442L

序列化字段

value

Object value

类 java.util.concurrent.atomic.AtomicReferenceArray 继承 Object 实现 Serializable

serialVersionUID: -6209656149925076980L

序列化字段

array

Object[] array
软件包 java.util.concurrent.locks

类 java.util.concurrent.locks.AbstractOwnableSynchronizer 继承 Object 实现 Serializable

serialVersionUID: 3737899427754241961L

类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 继承 AbstractOwnableSynchronizer 实现 Serializable

serialVersionUID: 7373984972572414692L

序列化字段

state

long state
同步状态。

类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 继承 Object 实现 Serializable

serialVersionUID: 1173984872572414699L

类 java.util.concurrent.locks.AbstractQueuedSynchronizer 继承 AbstractOwnableSynchronizer 实现 Serializable

serialVersionUID: 7373984972572414691L

序列化字段

state

int state
同步状态。

类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 继承 Object 实现 Serializable

serialVersionUID: 1173984872572414699L

类 java.util.concurrent.locks.ReentrantLock 继承 Object 实现 Serializable

serialVersionUID: 7373984872572414699L

序列化字段

sync

java.util.concurrent.locks.ReentrantLock.Sync sync
提供所有实现机制的同步器

类 java.util.concurrent.locks.ReentrantReadWriteLock 继承 Object 实现 Serializable

serialVersionUID: -6992448646407690164L

序列化字段

readerLock

ReentrantReadWriteLock.ReadLock readerLock
提供读取锁的内部类

writerLock

ReentrantReadWriteLock.WriteLock writerLock
提供写入锁的内部类

sync

java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync
执行所有同步机制

类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 继承 Object 实现 Serializable

serialVersionUID: -5992448646407690164L

序列化字段

sync

java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync

类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 继承 Object 实现 Serializable

serialVersionUID: -4992448646407690164L

序列化字段

sync

java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync
软件包 java.util.jar

类 java.util.jar.JarException 继承 ZipException 实现 Serializable

软件包 java.util.logging

类 java.util.logging.Level 继承 Object 实现 Serializable

serialVersionUID: -8176160795706313070L

序列化方法

readResolve

private Object readResolve()
序列化字段

name

String name
级别的非本地化名称。

value

int value
级别的整数值。

resourceBundleName

String resourceBundleName
本地化级别名称时使用的资源包名称。

类 java.util.logging.LoggingPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 63564341580231582L

类 java.util.logging.LogRecord 继承 Object 实现 Serializable

serialVersionUID: 5372048053134512534L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
默认字段，后跟两个字节的版本号（前面是主字节，后面是次字节），后跟关于日志记录参数数组的信息。如果不存在参数数组，则写入 -1。如果存在参数数组（可能长度为零），则作为整数写入数组长度，后跟每个参数的 String 值。如果参数为 null，则写入 null String。否则，写入 Object.toString() 的输出。
抛出：
IOException
序列化字段

level

Level level
日志消息级别

sequenceNumber

long sequenceNumber
序列号

sourceClassName

String sourceClassName
发出日志调用的类

sourceMethodName

String sourceMethodName
发出日志调用的方法

message

String message
非本地化的原始消息文本

threadID

int threadID
发出日志调用的线程的线程 ID。

millis

long millis
自从 1970 年以毫秒为单位的事件时间

thrown

Throwable thrown
与日志消息相关联的 Throwable（如果有）

loggerName

String loggerName
源 Logger 的名称。

resourceBundleName

String resourceBundleName
本地化日志消息的资源包名称。
软件包 java.util.prefs

类 java.util.prefs.BackingStoreException 继承 Exception 实现 Serializable

serialVersionUID: 859796500401108469L

类 java.util.prefs.InvalidPreferencesFormatException 继承 Exception 实现 Serializable

serialVersionUID: -791715184232119669L

软件包 java.util.regex

类 java.util.regex.Pattern 继承 Object 实现 Serializable

serialVersionUID: 5073258162644648461L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重新编译 Pattern 实例。读入初始模式字符串并从中重新编译对象树。

抛出：
IOException
ClassNotFoundException
序列化字段

pattern

String pattern
初始正则表达式模式字符串。

flags

int flags
初始模式标志。

类 java.util.regex.PatternSyntaxException 继承 IllegalArgumentException 实现 Serializable

序列化字段

desc

String desc

pattern

String pattern

index

int index
软件包 java.util.zip

类 java.util.zip.DataFormatException 继承 Exception 实现 Serializable

类 java.util.zip.ZipError 继承 InternalError 实现 Serializable

serialVersionUID: 853973422266861979L

类 java.util.zip.ZipException 继承 IOException 实现 Serializable

软件包 javax.activation

类 javax.activation.ActivationDataFlavor 继承 DataFlavor 实现 Serializable

序列化方法

readExternal

public void readExternal(ObjectInput is)
                  throws IOException,
                         ClassNotFoundException
根据 Serialized 状态还原此 DataFlavor。

抛出：
IOException - 如果发生 I/O 错误
ClassNotFoundException - 如果无法找到需要恢复的某个对象的类。

writeExternal

public void writeExternal(ObjectOutput os)
                   throws IOException
序列化此 DataFlavor。

抛出：
IOException - 包含可能发生的所有 I/O 异常

类 javax.activation.MimeType 继承 Object 实现 Serializable

序列化方法

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。readExternal 方法必须按照与 writeExternal 写入值时使用的相同顺序和类型来读取这些值。

抛出：
ClassNotFoundException - 如果找不到要恢复的对象的类。I
IOException - 如果发生 I/O 错误

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException
对象可实现 writeExternal 方法来保存其内容：对于其基本值，调用 DataOutput 的方法；对于对象、字符串和数组，调用 ObjectOutput 的 writeObject 方法。

抛出：
IOException - 包括可能发生的所有 I/O 异常

类 javax.activation.MimeTypeParseException 继承 Exception 实现 Serializable

类 javax.activation.UnsupportedDataTypeException 继承 IOException 实现 Serializable

软件包 javax.activity

类 javax.activity.ActivityCompletedException 继承 RemoteException 实现 Serializable

类 javax.activity.ActivityRequiredException 继承 RemoteException 实现 Serializable

类 javax.activity.InvalidActivityException 继承 RemoteException 实现 Serializable

软件包 javax.annotation.processing

类 javax.annotation.processing.FilerException 继承 IOException 实现 Serializable

serialVersionUID: 8426423106453163293L

软件包 javax.crypto

类 javax.crypto.BadPaddingException 继承 GeneralSecurityException 实现 Serializable

类 javax.crypto.ExemptionMechanismException 继承 GeneralSecurityException 实现 Serializable

类 javax.crypto.IllegalBlockSizeException 继承 GeneralSecurityException 实现 Serializable

类 javax.crypto.NoSuchPaddingException 继承 GeneralSecurityException 实现 Serializable

类 javax.crypto.SealedObject 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中还原 SealedObject 的状态。

抛出：
NullPointerException - 如果 s 为 null。
IOException
ClassNotFoundException
序列化字段

encodedParams

byte[] encodedParams
由密封 Cipher 使用的加密参数，以默认格式进行编码。

即 cipher.getParameters().getEncoded()。

encryptedContent

byte[] encryptedContent
以加密格式存在的序列化对象内容。

sealAlg

String sealAlg
用于密封此对象的算法。

paramsAlg

String paramsAlg
所用的参数算法。

类 javax.crypto.ShortBufferException 继承 GeneralSecurityException 实现 Serializable

软件包 javax.crypto.interfaces
软件包 javax.crypto.spec

类 javax.crypto.spec.SecretKeySpec 继承 Object 实现 Serializable

序列化字段

key

byte[] key
密钥。

algorithm

String algorithm
与此密钥关联的算法名称。

软件包 javax.imageio

类 javax.imageio.IIOException 继承 IOException 实现 Serializable

软件包 javax.imageio.metadata

类 javax.imageio.metadata.IIOInvalidTreeException 继承 IIOException 实现 Serializable

序列化字段

offendingNode

Node offendingNode
导致解析错误的 Node，或 null。

软件包 javax.lang.model.element

类 javax.lang.model.element.UnknownAnnotationValueException 继承 RuntimeException 实现 Serializable

serialVersionUID: 269L

类 javax.lang.model.element.UnknownElementException 继承 RuntimeException 实现 Serializable

serialVersionUID: 269L

软件包 javax.lang.model.type

类 javax.lang.model.type.MirroredTypeException 继承 RuntimeException 实现 Serializable

serialVersionUID: 269L

类 javax.lang.model.type.MirroredTypesException 继承 RuntimeException 实现 Serializable

serialVersionUID: 269L

类 javax.lang.model.type.UnknownTypeException 继承 RuntimeException 实现 Serializable

serialVersionUID: 269L

软件包 javax.management

类 javax.management.AndQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -1081892073854801359L

序列化字段

exp1

QueryExp exp1
The first QueryExp of the conjunction

exp2

QueryExp exp2
The second QueryExp of the conjunction

类 javax.management.Attribute 继承 Object 实现 Serializable

serialVersionUID: 2484220110589082382L

序列化字段

name

String name
Attribute 名称。

value

Object value
Attribute 值。

类 javax.management.AttributeChangeNotification 继承 Notification 实现 Serializable

serialVersionUID: 535176054565814134L

序列化字段

attributeName

String attributeName
MBean 属性名称。

attributeType

String attributeType
MBean 属性类型。

oldValue

Object oldValue
MBean 属性的旧值。

newValue

Object newValue
MBean 属性的新值。

类 javax.management.AttributeChangeNotificationFilter 继承 Object 实现 Serializable

serialVersionUID: -6347317584796410029L

序列化字段

enabledAttributes

Vector<E> enabledAttributes
包含已启用属性名称的 Vector。默认值是一个空向量。

类 javax.management.AttributeList 继承 ArrayList<Object> 实现 Serializable

serialVersionUID: -4077085769279709076L

类 javax.management.AttributeNotFoundException 继承 OperationsException 实现 Serializable

serialVersionUID: 6511584241791106926L

类 javax.management.AttributeValueExp 继承 Object 实现 Serializable

serialVersionUID: -7768025046539163385L

序列化字段

attr

String attr

类 javax.management.BadAttributeValueExpException 继承 Exception 实现 Serializable

serialVersionUID: -3105272988410493376L

序列化字段

val

Object val
产生此异常的属性值

类 javax.management.BadBinaryOpValueExpException 继承 Exception 实现 Serializable

serialVersionUID: 5068475589449021227L

序列化字段

exp

ValueExp exp
产生此异常的 ValueExp

类 javax.management.BadStringOperationException 继承 Exception 实现 Serializable

serialVersionUID: 7802201238441662100L

序列化字段

op

String op
对产生此异常的操作的描述

类 javax.management.BetweenQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -2933597532866307444L

序列化字段

exp1

ValueExp exp1
The checked value

exp2

ValueExp exp2
The lower bound value

exp3

ValueExp exp3
The upper bound value

类 javax.management.BinaryOpValueExp 继承 QueryEval 实现 Serializable

serialVersionUID: 1216286847881456786L

序列化字段

op

int op
The operator

exp1

ValueExp exp1
The first value

exp2

ValueExp exp2
The second value

类 javax.management.BinaryRelQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -5690656271650491000L

序列化字段

relOp

int relOp
The operator

exp1

ValueExp exp1
The first value

exp2

ValueExp exp2
The second value

类 javax.management.BooleanValueExp 继承 QueryEval 实现 Serializable

serialVersionUID: 7754922052666594581L

序列化字段

val

boolean val
The boolean value

类 javax.management.ClassAttributeValueExp 继承 AttributeValueExp 实现 Serializable

序列化字段

attr

String attr
The name of the attribute

The serialVersionUID of this class is -1081892073854801359L.

类 javax.management.ImmutableDescriptor 继承 Object 实现 Serializable

serialVersionUID: 8853308591080540165L

序列化方法

readResolve

private Object readResolve()
                    throws InvalidObjectException
此方法可以使用另一个实例替换此类的反序列化实例。例如，它可以使用 ImmutableDescriptor.EMPTY_DESCRIPTOR 替换反序列化的空 ImmutableDescriptor。

抛出：
InvalidObjectException - 如果读取的对象包含无效字段。
序列化字段

names

String[] names
此 ImmutableDescriptor 中具有其原始大小写的字段名称。名称必须按 String.CASE_INSENSITIVE_ORDER 确定的方式以字母顺序排列。

values

Object[] values
此 ImmutableDescriptor 中字段的值。此数组中的元素与 names 数组中的相应元素匹配。

类 javax.management.InQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -5801329450358952434L

序列化字段

val

ValueExp val
The ValueExp to be found

valueList

ValueExp[] valueList
The array of ValueExp to be searched

类 javax.management.InstanceAlreadyExistsException 继承 OperationsException 实现 Serializable

serialVersionUID: 8893743928912733931L

类 javax.management.InstanceNotFoundException 继承 OperationsException 实现 Serializable

serialVersionUID: -882579438394773049L

类 javax.management.InstanceOfQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -1081892073854801359L

序列化字段

classNameValue

StringValueExp classNameValue
The StringValueExp returning the name of the class of which selected MBeans should be instances.

类 javax.management.IntrospectionException 继承 OperationsException 实现 Serializable

serialVersionUID: 1054516935875481725L

类 javax.management.InvalidApplicationException 继承 Exception 实现 Serializable

serialVersionUID: -3048022274675537269L

序列化字段

val

Object val
表示 MBean 的类的对象

类 javax.management.InvalidAttributeValueException 继承 OperationsException 实现 Serializable

serialVersionUID: 2164571879317142449L

类 javax.management.JMException 继承 Exception 实现 Serializable

serialVersionUID: 350520924977331825L

类 javax.management.JMRuntimeException 继承 RuntimeException 实现 Serializable

serialVersionUID: 6573344628407841861L

类 javax.management.ListenerNotFoundException 继承 OperationsException 实现 Serializable

serialVersionUID: -7242605822448519061L

类 javax.management.MalformedObjectNameException 继承 OperationsException 实现 Serializable

serialVersionUID: -572689714442915824L

类 javax.management.MatchQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -7156603696948215014L

序列化字段

exp

AttributeValueExp exp
The attribute value to be matched

pattern

String pattern
The pattern to be matched

类 javax.management.MBeanAttributeInfo 继承 MBeanFeatureInfo 实现 Serializable

序列化字段

attributeType

String attributeType
The actual attribute type.

isWrite

boolean isWrite
The attribute write right.

isRead

boolean isRead
The attribute read right.

is

boolean is
Indicates if this method is a "is"

类 javax.management.MBeanConstructorInfo 继承 MBeanFeatureInfo 实现 Serializable

serialVersionUID: 4433990064191844427L

序列化字段

signature

MBeanParameterInfo[] signature
The signature of the method, that is, the class names of the arguments.

类 javax.management.MBeanException 继承 JMException 实现 Serializable

serialVersionUID: 4066342430588744142L

序列化字段

exception

Exception exception
Encapsulated Exception

类 javax.management.MBeanFeatureInfo 继承 Object 实现 Serializable

serialVersionUID: 3952882688968447265L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
根据 ObjectInputStream 反序列化 MBeanFeatureInfo。

序列数据：
For compatibility reasons, an object of this class is deserialized as follows.
    The method defaultReadObject() is called first to deserialize the object except the field descriptor, which is not serialized in the default way. Then the method read() is called to read a byte, the field descriptor is deserialized according to the value of the byte value:
    • 1. The method readObject() is called twice to obtain the field names (a String[]) and the field values (a Object[]) of the descriptor. The two obtained values then are used to construct an ImmutableDescriptor instance for the field descriptor;
    • 0. The value for the field descriptor is obtained directly by calling the method readObject(). If the obtained value is null, the field descriptor is set to EMPTY_DESCRIPTOR;
    • -1. This means that there is no byte to read and that the object is from an earlier version of the JMX API. The field descriptor is set to EMPTY_DESCRIPTOR
    • Any other value. A StreamCorruptedException is thrown.
抛出：
IOException
ClassNotFoundException
从以下版本开始：
1.6

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 MBeanFeatureInfo 序列化为 ObjectOutputStream。

序列数据：
For compatibility reasons, an object of this class is serialized as follows.
    The method defaultWriteObject() is called first to serialize the object except the field descriptor which is declared as transient. The field descriptor is serialized as follows:
    • If descriptor is an instance of the class ImmutableDescriptor, the method write(int val) is called to write a byte with the value 1, then the method writeObject(Object obj) is called twice to serialize the field names and the field values of the descriptor, respectively as a String[] and an Object[];
    • Otherwise, the method write(int val) is called to write a byte with the value 0, then the method writeObject(Object obj) is called to serialize directly the field descriptor.
抛出：
IOException
从以下版本开始：
1.6
序列化字段

name

String name
该功能的名称。推荐子类调用 MBeanFeatureInfo.getName() 方法，而不是读取此字段，并且子类不能更改该字段。

该功能的名称。

description

String description
该功能的可读描述。推荐子类调用 MBeanFeatureInfo.getDescription() 方法，而不是读取此字段，并且子类不能更改该字段。

该功能的可读描述。

类 javax.management.MBeanInfo 继承 Object 实现 Serializable

serialVersionUID: -6451021435135161911L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 MBeanInfo。

序列数据：
For compatibility reasons, an object of this class is deserialized as follows.
    The method defaultReadObject() is called first to deserialize the object except the field descriptor, which is not serialized in the default way. Then the method read() is called to read a byte, the field descriptor is deserialized according to the value of the byte value:
    • 1. The method readObject() is called twice to obtain the field names (a String[]) and the field values (a Object[]) of the descriptor. The two obtained values then are used to construct an ImmutableDescriptor instance for the field descriptor;
    • 0. The value for the field descriptor is obtained directly by calling the method readObject(). If the obtained value is null, the field descriptor is set to EMPTY_DESCRIPTOR;
    • -1. This means that there is no byte to read and that the object is from an earlier version of the JMX API. The field descriptor is set to EMPTY_DESCRIPTOR.
    • Any other value. A StreamCorruptedException is thrown.
抛出：
IOException
ClassNotFoundException
从以下版本开始：
1.6

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 MBeanInfo 序列化为 ObjectOutputStream。

序列数据：
For compatibility reasons, an object of this class is serialized as follows.
    The method defaultWriteObject() is called first to serialize the object except the field descriptor which is declared as transient. The field descriptor is serialized as follows:
    • If descriptor is an instance of the class ImmutableDescriptor, the method write(int val) is called to write a byte with the value 1, then the method writeObject(Object obj) is called twice to serialize the field names and the field values of the descriptor, respectively as a String[] and an Object[];
    • Otherwise, the method write(int val) is called to write a byte with the value 0, then the method writeObject(Object obj) is called to serialize the field descriptor directly.
抛出：
IOException
从以下版本开始：
1.6
序列化字段

description

String description
The human readable description of the class.

className

String className
The MBean qualified name.

attributes

MBeanAttributeInfo[] attributes
The MBean attribute descriptors.

operations

MBeanOperationInfo[] operations
The MBean operation descriptors.

constructors

MBeanConstructorInfo[] constructors
The MBean constructor descriptors.

notifications

MBeanNotificationInfo[] notifications
The MBean notification descriptors.

类 javax.management.MBeanNotificationInfo 继承 MBeanFeatureInfo 实现 Serializable

serialVersionUID: -3888371564530107064L

序列化字段

types

String[] types
The different types of the notification.

类 javax.management.MBeanOperationInfo 继承 MBeanFeatureInfo 实现 Serializable

serialVersionUID: -6178860474881375330L

序列化字段

type

String type
The method's return value.

signature

MBeanParameterInfo[] signature
The signature of the method, that is, the class names of the arguments.

impact

int impact
返回该方法的影响，为 INFO、ACTION、ACTION_INFO、UNKNOWN 之一。

类 javax.management.MBeanParameterInfo 继承 MBeanFeatureInfo 实现 Serializable

serialVersionUID: 7432616882776782338L

序列化字段

type

String type
The type or class name of the data.

类 javax.management.MBeanPermission 继承 Permission 实现 Serializable

serialVersionUID: -2416928705275160661L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
根据此对象的名称和操作反序列化它。

抛出：
IOException
ClassNotFoundException
序列化字段

actions

String actions
操作字符串。

类 javax.management.MBeanRegistrationException 继承 MBeanException 实现 Serializable

serialVersionUID: 4482382455277067805L

类 javax.management.MBeanServerNotification 继承 Notification 实现 Serializable

serialVersionUID: 2876477500475969677L

序列化字段

objectName

ObjectName objectName
与此通知有关的 MBean 的对象名

类 javax.management.MBeanServerPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: -5661980843569388590L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

类 javax.management.MBeanServerPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: -5661980843569388590L

序列化字段

collectionPermission

MBeanServerPermission collectionPermission
Null if no permissions in collection, otherwise a single permission that is the union of all permissions that have been added.

类 javax.management.MBeanTrustPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: -2952178077029018140L

类 javax.management.NotCompliantMBeanException 继承 OperationsException 实现 Serializable

serialVersionUID: 5175579583207963577L

类 javax.management.Notification 继承 EventObject 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 中反序列化 Notification。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 Notification 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

message

String message
通知消息。

sequenceNumber

long sequenceNumber
通知序列号。序列号在通知源的上下文中标识特定的通知实例。

source

Object source
最初发生通知的对象。

timeStamp

long timeStamp
通知时间戳。指示通知的生成时间

type

String type
通知类型。用和 Java 属性类似的点标注法表示的 string。通知类型的示例：network.alarm.router

userData

Object userData
通知的用户数据。用于通知源希望与其使用者所交流的所有其他数据

类 javax.management.NotificationFilterSupport 继承 Object 实现 Serializable

serialVersionUID: 6579080007561786969L

序列化字段

enabledTypes

List<E> enabledTypes
包含已启用通知类型的 Vector。默认值是一个空向量。

类 javax.management.NotQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: 5269643775896723397L

序列化字段

exp

QueryExp exp
The negated QueryExp

类 javax.management.NumericValueExp 继承 QueryEval 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a NumericValueExp from an ObjectInputStream.

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a NumericValueExp to an ObjectOutputStream.

抛出：
IOException
序列化字段

val

Number val
The numeric value

The serialVersionUID of this class is -4679739485102359104L.

类 javax.management.ObjectInstance 继承 Object 实现 Serializable

serialVersionUID: -4099952623687795850L

序列化字段

name

ObjectName name
Object name.

className

String className
Class name.

类 javax.management.ObjectName 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
根据 ObjectInputStream 反序列化 ObjectName。

序列数据：
  • 在目前的序列形式中（属性 jmx.serial.form 的值不是 1.0）：字符串 "<域>:<属性><通配符>"，其中：
    • <域> 表示 ObjectName 的域部分
    • <属性> 表示属性列表，由 ObjectName.getKeyPropertyListString() 所返回
    • 如果 isPropertyPattern 返回 false，则 <通配符> 为空；如果 isPropertyPattern 和 <属性> 为空，则 <通配符> 为字符 "*"；如果 isPropertyPattern 和 <属性> 不为空，则 <通配符> 为 ",*"。
    目的是可将此字符串提供给 ObjectName.ObjectName(String) 构造方法，以生成等效的 ObjectName。
  • 在旧的序列形式中（属性 jmx.serial.form 的值是 1.0）：<域> <属性列表> <属性列表 String> <规范名> <模式> <属性模式>，其中：
    • <域> 表示 ObjectName 的域部分
    • <属性列表> 是包含此 ObjectName 所有键值对的 Hashtable
    • <属性列表 String> 是以任意顺序出现的属性列表的 String 表示形式（并不强制使用规范的表示形式）
    • <规范名> 是包含此 ObjectName 的规范名称的 String
    • <模式> 是一个 boolean 值，如果此 ObjectName 包含模式，则为 true
    • <属性模式> 是一个 boolean 值，如果此 ObjectName 在属性列表中包含模式，则为 true
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ObjectName 序列化为 ObjectOutputStream。

序列数据：
  • 在目前的序列形式中（属性 jmx.serial.form 的值不是 1.0）：字符串 "<域>:<属性><通配符>"，其中：
    • <域> 表示 ObjectName 的域部分
    • <属性> 表示属性列表，由 ObjectName.getKeyPropertyListString() 所返回
    • 如果 isPropertyPattern 返回 false，则 <通配符> 为空；如果此 isPropertyPattern 和 <属性> 为空，则 <通配符> 为字符 "*"；如果 isPropertyPattern 和 <属性> 不为空，则 <通配符> 为 ",*"。
    目的是可将此字符串提供给 ObjectName.ObjectName(String) 构造方法，以生成等效的 ObjectName。
  • 在旧的序列形式中（属性 jmx.serial.form 的值是 1.0）：<域> <属性列表> <属性列表 String> <规范名> <模式> <属性模式>，其中：
    • <域> 表示 ObjectName 的域部分
    • <属性列表> 是包含此 ObjectName 所有键值对的 Hashtable
    • <属性列表 String> 是以任意顺序出现的属性列表的 String 表示形式（并不强制使用规范的表示形式）
    • <规范名> 是包含此 ObjectName 的规范名称的 String
    • <模式> 是一个 boolean 值，如果此 ObjectName 包含模式，则为 true
    • <属性模式> 是一个 boolean 值，如果此 ObjectName 在属性列表中包含模式，则为 true
抛出：
IOException
序列化字段

类 javax.management.OperationsException 继承 JMException 实现 Serializable

serialVersionUID: -4967597595580536216L

类 javax.management.OrQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: 2962973084421716523L

序列化字段

exp1

QueryExp exp1
The left query expression

exp2

QueryExp exp2
The right query expression

类 javax.management.QualifiedAttributeValueExp 继承 AttributeValueExp 实现 Serializable

serialVersionUID: 8832517277410933254L

序列化字段

className

String className
The attribute class name

类 javax.management.QueryEval 继承 Object 实现 Serializable

serialVersionUID: 2675899265640874796L

类 javax.management.ReflectionException 继承 JMException 实现 Serializable

serialVersionUID: 9170809325636915553L

序列化字段

exception

Exception exception
包装的 Exception

类 javax.management.RuntimeErrorException 继承 JMRuntimeException 实现 Serializable

serialVersionUID: 704338937753949796L

序列化字段

error

Error error
封装的 Error

类 javax.management.RuntimeMBeanException 继承 JMRuntimeException 实现 Serializable

serialVersionUID: 5274912751982730171L

序列化字段

runtimeException

RuntimeException runtimeException
封装的 RuntimeException

类 javax.management.RuntimeOperationsException 继承 JMRuntimeException 实现 Serializable

serialVersionUID: -8408923047489133588L

序列化字段

runtimeException

RuntimeException runtimeException
封装的 RuntimeException

类 javax.management.ServiceNotFoundException 继承 OperationsException 实现 Serializable

serialVersionUID: -3990675661956646827L

类 javax.management.StringValueExp 继承 Object 实现 Serializable

serialVersionUID: -3256390509806284044L

序列化字段

val

String val
字符串文本
软件包 javax.management.loading

类 javax.management.loading.MLet 继承 URLClassLoader 实现 Serializable

serialVersionUID: 3636148327800330130L

序列化方法

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

从给定的 ObjectInput 恢复此 MLet 的内容。不是所有的实现都支持此方法。不支持此方法的实现将抛出 UnsupportedOperationException。子类可以重写此方法以支持它或更改读取数据的格式。

读取数据的格式是未指定的，但如果某个实现支持 MLet.readExternal(java.io.ObjectInput)，则它必须也支持 MLet.writeExternal(java.io.ObjectOutput)，以便前者可以读取后者所写入的内容。

抛出：
IOException - 如果在读取时出现问题。
ClassNotFoundException - 如果找不到要恢复的对象的类。
UnsupportedOperationException - 如果此实现不支持此操作。

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

将此 MLet 的内容保存到给定的 ObjectOutput。不是所有的实现都支持此方法。不支持此方法的实现将抛出 UnsupportedOperationException。子类可以重写此方法以支持它或更改写入数据的格式。

写入数据的格式是未指定的，但如果某个实现支持 MLet.writeExternal(java.io.ObjectOutput)，则它必须也支持 MLet.readExternal(java.io.ObjectInput)，以便后者可以读取前者所写入的内容。

抛出：
IOException - 如果在写入时发生问题。
UnsupportedOperationException - 如果此实现不支持此操作。

类 javax.management.loading.PrivateMLet 继承 MLet 实现 Serializable

serialVersionUID: 2503458973393711979L

序列化方法

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

从给定的 ObjectInput 恢复此 MLet 的内容。不是所有的实现都支持此方法。不支持此方法的实现将抛出 UnsupportedOperationException。子类可以重写此方法以支持它或更改读取数据的格式。

读取数据的格式是未指定的，但如果某个实现支持 MLet.readExternal(java.io.ObjectInput)，则它必须也支持 MLet.writeExternal(java.io.ObjectOutput)，以便前者可以读取后者所写入的内容。

抛出：
IOException - 如果在读取时出现问题。
ClassNotFoundException - 如果找不到要恢复的对象的类。
UnsupportedOperationException - 如果此实现不支持此操作。

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

将此 MLet 的内容保存到给定的 ObjectOutput。不是所有的实现都支持此方法。不支持此方法的实现将抛出 UnsupportedOperationException。子类可以重写此方法以支持它或更改写入数据的格式。

写入数据的格式是未指定的，但如果某个实现支持 MLet.writeExternal(java.io.ObjectOutput)，则它必须也支持 MLet.readExternal(java.io.ObjectInput)，以便后者可以读取前者所写入的内容。

抛出：
IOException - 如果在写入时发生问题。
UnsupportedOperationException - 如果此实现不支持此操作。
软件包 javax.management.modelmbean

类 javax.management.modelmbean.DescriptorSupport 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 DescriptorSupport。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 DescriptorSupport 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

descriptor

HashMap<K,V> descriptor
表示此描述符的字段的集合

类 javax.management.modelmbean.InvalidTargetObjectTypeException 继承 Exception 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 InvalidTargetObjectTypeException。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 InvalidTargetObjectTypeException 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

exception

Exception exception
封装的 {@link Exception}

类 javax.management.modelmbean.ModelMBeanAttributeInfo 继承 MBeanAttributeInfo 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 ModelMBeanAttributeInfo。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ModelMBeanAttributeInfo 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

attrDescriptor

Descriptor attrDescriptor
包含对应于此属性的元数据的 {@link Descriptor}

类 javax.management.modelmbean.ModelMBeanConstructorInfo 继承 MBeanConstructorInfo 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 ModelMBeanConstructorInfo。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ModelMBeanConstructorInfo 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

consDescriptor

Descriptor consDescriptor
包含此实例的元数据的 {@link Descriptor}

类 javax.management.modelmbean.ModelMBeanInfoSupport 继承 MBeanInfo 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 ModelMBeanInfoSupport。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ModelMBeanInfoSupport 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

modelMBeanAttributes

ModelMBeanAttributeInfo[] modelMBeanAttributes
带有描述符的 {@link ModelMBeanAttributeInfo} 对象数组

modelMBeanConstructors

MBeanConstructorInfo[] modelMBeanConstructors
带有描述符的 {@link ModelMBeanConstructorInfo} 对象数组

modelMBeanDescriptor

Descriptor modelMBeanDescriptor
包含 MBean 级策略的描述符

modelMBeanNotifications

MBeanNotificationInfo[] modelMBeanNotifications
带有描述符的 {@link ModelMBeanNotificationInfo} 对象数组

modelMBeanOperations

MBeanOperationInfo[] modelMBeanOperations
带有描述符的 {@link ModelMBeanOperationInfo} 对象数组

类 javax.management.modelmbean.ModelMBeanNotificationInfo 继承 MBeanNotificationInfo 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 ModelMBeanNotificationInfo。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ModelMBeanNotificationInfo 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

notificationDescriptor

Descriptor notificationDescriptor
包含此实例的适当元数据的描述符

类 javax.management.modelmbean.ModelMBeanOperationInfo 继承 MBeanOperationInfo 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 ModelMBeanOperationInfo。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ModelMBeanOperationInfo 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

operationDescriptor

Descriptor operationDescriptor
包含此实例的适当元数据的描述符

类 javax.management.modelmbean.XMLParseException 继承 Exception 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 XMLParseException。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 XMLParseException 序列化为ObjectOutputStream。

抛出：
IOException
序列化字段
软件包 javax.management.monitor

类 javax.management.monitor.MonitorNotification 继承 Notification 实现 Serializable

serialVersionUID: -4608189663661929204L

序列化字段

observedObject

ObjectName observedObject
Monitor notification observed object.

observedAttribute

String observedAttribute
Monitor notification observed attribute.

derivedGauge

Object derivedGauge
Monitor notification derived gauge.

trigger

Object trigger
Monitor notification release mechanism.此值用来保留触发此通知的阈值/字符串（取决于监视器类型）。

类 javax.management.monitor.MonitorSettingException 继承 JMRuntimeException 实现 Serializable

serialVersionUID: -8807913418190202007L

软件包 javax.management.openmbean

类 javax.management.openmbean.ArrayType 继承 OpenType<T> 实现 Serializable

serialVersionUID: 720504429830309770L

序列化方法

readResolve

private Object readResolve()
                    throws ObjectStreamException
在从流中读取的对象返回到调用者之前对其进行替换和解析。

序列数据：
The new serial form of this class defines a new serializable boolean field primitiveArray. In order to guarantee the interoperability with previous versions of this class the new serial form must continue to refer to primitive wrapper types even when the ArrayType instance describes a primitive type array. So when primitiveArray is true the className, typeName and description serializable fields are converted into primitive types before the deserialized ArrayType instance is return to the caller. The elementType field always returns the SimpleType corresponding to the primitive wrapper type of the array's primitive type.

Therefore the following serializable fields are deserialized as follows:

  • if primitiveArray is true the className field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "[[Ljava.lang.Integer;" will be deserialized as "[[I".
  • if primitiveArray is true the typeName field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "[[Ljava.lang.Integer;" will be deserialized as "[[I".
  • if primitiveArray is true the description field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "2-dimension array of java.lang.Integer" will be deserialized as "2-dimension array of int".
抛出：
ObjectStreamException
从以下版本开始：
1.6

writeReplace

private Object writeReplace()
                     throws ObjectStreamException
在流中的此对象被写入前制定一个替换对象。

序列数据：
The new serial form of this class defines a new serializable boolean field primitiveArray. In order to guarantee the interoperability with previous versions of this class the new serial form must continue to refer to primitive wrapper types even when the ArrayType instance describes a primitive type array. So when primitiveArray is true the className, typeName and description serializable fields are converted into wrapper types before the serialized ArrayType instance is written to the stream. The elementType field always returns the SimpleType corresponding to the primitive wrapper type of the array's primitive type.

Therefore the following serializable fields are serialized as follows:

  • if primitiveArray is true the className field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "[[I" will be serialized as "[[Ljava.lang.Integer;".
  • if primitiveArray is true the typeName field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "[[I" will be serialized as "[[Ljava.lang.Integer;".
  • if primitiveArray is true the description field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "2-dimension array of int" will be serialized as "2-dimension array of java.lang.Integer".
抛出：
ObjectStreamException
从以下版本开始：
1.6
序列化字段

dimension

int dimension
此 ArrayType 实例描述的数组的维度。

elementType

OpenType<T> elementType
此 ArrayType 实例描述的数组中包含的元素值的开放类型。

primitiveArray

boolean primitiveArray
This flag indicates whether this ArrayType describes a primitive array.
从以下版本开始：
1.6

类 javax.management.openmbean.CompositeDataSupport 继承 Object 实现 Serializable

serialVersionUID: 8003518976613702244L

序列化字段

contents

SortedMap<K,V> contents
它们各自值的项名称的映射关系的内部表示形式。SortedMap 用于较快速的元素检索。

compositeType

CompositeType compositeType
此复合数据 实例的复合类型。

类 javax.management.openmbean.CompositeType 继承 OpenType<CompositeData> 实现 Serializable

serialVersionUID: -5366242454346948798L

序列化字段

nameToDescription

TreeMap<K,V> nameToDescription
项名称到其描述的有序映射

nameToType

TreeMap<K,V> nameToType
项名称到其开放类型的有序映射

类 javax.management.openmbean.InvalidKeyException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: 4224269443946322062L

类 javax.management.openmbean.InvalidOpenTypeException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: -2837312755412327534L

类 javax.management.openmbean.KeyAlreadyExistsException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: 1845183636745282866L

类 javax.management.openmbean.OpenDataException 继承 JMException 实现 Serializable

serialVersionUID: 8346311255433349870L

类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 继承 MBeanAttributeInfo 实现 Serializable

serialVersionUID: -4867215622149721849L

序列化方法

readResolve

private Object readResolve()
在 Descriptor 被添加到此类之前，用此版本的 API 进行序列化的对象的 Descriptor 将为空或 null。 为了与此版本的操作保持一致，必须使用另一个对象取代该对象，用来取代的那个对象的 Descriptor 应该反映 openType、defaultValue 等等的值。

序列化字段

openType

OpenType<T> openType
open mbean 属性的开放类型

defaultValue

Object defaultValue
open mbean 属性的默认值

legalValues

Set<E> legalValues
open mbean 属性的合法值。此 Set 是不可修改的。

minValue

Comparable<T> minValue
open mbean 属性的最小值

maxValue

Comparable<T> maxValue
open mbean 属性的最大值

类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 继承 MBeanConstructorInfo 实现 Serializable

serialVersionUID: -4400441579007477003L

类 javax.management.openmbean.OpenMBeanInfoSupport 继承 MBeanInfo 实现 Serializable

serialVersionUID: 4349395935420511492L

类 javax.management.openmbean.OpenMBeanOperationInfoSupport 继承 MBeanOperationInfo 实现 Serializable

serialVersionUID: 4996859732565369366L

序列化方法

readResolve

private Object readResolve()
An object serialized in a version of the API before Descriptors were added to this class will have an empty or null Descriptor. For consistency with our behavior in this version, we must replace the object with one where the Descriptors reflect the same value of returned openType.

序列化字段

returnOpenType

OpenType<T> returnOpenType
此 OpenMBeanOperationInfo 实例描述的操作所返回的值的开放类型。

类 javax.management.openmbean.OpenMBeanParameterInfoSupport 继承 MBeanParameterInfo 实现 Serializable

serialVersionUID: -7235016873758443122L

序列化方法

readResolve

private Object readResolve()
在 Descriptor 被添加到此类之前，用此版本的 API 进行序列化的对象的 Descriptor 将为空或 null。为了与此版本的操作保持一致，必须使用另一个对象取代该对象，用来取代的那个对象的 Descriptor 应该反映 openType、defaultValue 等等的值。

序列化字段

openType

OpenType<T> openType
open mbean 参数的开放类型

defaultValue

Object defaultValue
open mbean 参数的默认值

legalValues

Set<E> legalValues
open mbean 参数的合法值。此 Set 是不可修改的。

minValue

Comparable<T> minValue
open mbean 参数的最小值

maxValue

Comparable<T> maxValue
open mbean 参数的最大值

类 javax.management.openmbean.OpenType 继承 Object 实现 Serializable

serialVersionUID: -9195195325186646468L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 java.io.OpenType。

抛出：
IOException
ClassNotFoundException
序列化字段

className

String className
此类型描述的开放数据值的完全限定的 Java 类名。

description

String description
类型描述（不应为 null 或空）。

typeName

String typeName
为此类型提供的名称（不应为 null 或空）。

类 javax.management.openmbean.SimpleType 继承 OpenType<T> 实现 Serializable

serialVersionUID: 2215577471957694503L

序列化方法

readResolve

public Object readResolve()
                   throws ObjectStreamException
使用该值的唯一实例替换从 ObjectInputStream 读取的对象。

抛出：
ObjectStreamException - 如果读取对象不能被解析。

类 javax.management.openmbean.TabularDataSupport 继承 Object 实现 Serializable

serialVersionUID: 5720150593236309827L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 TabularDataSupport。

抛出：
IOException
ClassNotFoundException
序列化字段

dataMap

Map<K,V> dataMap
此表格数据实例的内容：一个 HashMap

tabularType

TabularType tabularType
此表格数据实例的表格类型

类 javax.management.openmbean.TabularType 继承 OpenType<TabularData> 实现 Serializable

serialVersionUID: 6554071860220659261L

序列化字段

rowType

CompositeType rowType
行的复合类型

indexNames

List<E> indexNames
用于索引每个行元素的项，它保持用户给定的顺序。这是一个不可修改的 ArrayList
软件包 javax.management.relation

类 javax.management.relation.InvalidRelationIdException 继承 RelationException 实现 Serializable

serialVersionUID: -7115040321202754171L

类 javax.management.relation.InvalidRelationServiceException 继承 RelationException 实现 Serializable

serialVersionUID: 3400722103759507559L

类 javax.management.relation.InvalidRelationTypeException 继承 RelationException 实现 Serializable

serialVersionUID: 3007446608299169961L

类 javax.management.relation.InvalidRoleInfoException 继承 RelationException 实现 Serializable

serialVersionUID: 7517834705158932074L

类 javax.management.relation.InvalidRoleValueException 继承 RelationException 实现 Serializable

serialVersionUID: -2066091747301983721L

类 javax.management.relation.MBeanServerNotificationFilter 继承 NotificationFilterSupport 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 MBeanServerNotificationFilter。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 MBeanServerNotificationFilter 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

deselectedNames

List<E> deselectedNames
List of {@link ObjectName}s with no interest
  • null 意味着隐式地取消选中所有 {@link ObjectName}（复选表示显式选择）
  • 空向量意味着没有任何 {@link ObjectName} 被显式取消选中。

selectedNames

List<E> selectedNames
List of {@link ObjectName}s of interest
  • null 意味着隐式选中所有 {@link ObjectName}（复选表示显式取消选择）
  • 空向量意味着没有任何 {@link ObjectName} 被显式选中。

类 javax.management.relation.RelationException 继承 JMException 实现 Serializable

serialVersionUID: 5434016005679159613L

类 javax.management.relation.RelationNotFoundException 继承 RelationException 实现 Serializable

serialVersionUID: -3793951411158559116L

类 javax.management.relation.RelationNotification 继承 Notification 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 RelationNotification。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 RelationNotification 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

newRoleValue

List<E> newRoleValue
New role value ({@link ArrayList} of {@link ObjectName}s) (only for role update)

oldRoleValue

List<E> oldRoleValue
Old role value ({@link ArrayList} of {@link ObjectName}s) (only for role update)

relationId

String relationId
Relation identifier of created/removed/updated relation

relationObjName

ObjectName relationObjName
{@link ObjectName} of the relation MBean of created/removed/updated relation (only if the relation is represented by an MBean)

relationTypeName

String relationTypeName
Relation type name of created/removed/updated relation

roleName

String roleName
Name of updated role (only for role update)

unregisterMBeanList

List<E> unregisterMBeanList
List of {@link ObjectName}s of referenced MBeans to be unregistered due to relation removal

类 javax.management.relation.RelationServiceNotRegisteredException 继承 RelationException 实现 Serializable

serialVersionUID: 8454744887157122910L

类 javax.management.relation.RelationTypeNotFoundException 继承 RelationException 实现 Serializable

serialVersionUID: 1274155316284300752L

类 javax.management.relation.RelationTypeSupport 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 RelationTypeSupport。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 RelationTypeSupport 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

isInRelationService

boolean isInRelationService
Flag specifying whether the relation type has been declared in the Relation Service (so can no longer be updated)

roleName2InfoMap

Map<K,V> roleName2InfoMap
{@link Map} holding the mapping: <role name ({@link String})> -> <role info ({@link RoleInfo} object)>

typeName

String typeName
Relation type name

类 javax.management.relation.Role 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 Role。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 Role 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

name

String name
Role name

objectNameList

List<E> objectNameList
{@link List} of {@link ObjectName}s of referenced MBeans

类 javax.management.relation.RoleInfo 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 RoleInfo。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 RoleInfo 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

description

String description
Role description

isReadable

boolean isReadable
Read access mode: true if role is readable

isWritable

boolean isWritable
Write access mode: true if role is writable

maxDegree

int maxDegree
Maximum degree (i.e. maximum number of referenced MBeans in corresponding role)

minDegree

int minDegree
Minimum degree (i.e. minimum number of referenced MBeans in corresponding role)

name

String name
Role name

referencedMBeanClassName

String referencedMBeanClassName
Name of class of MBean(s) expected to be referenced in corresponding role

类 javax.management.relation.RoleInfoNotFoundException 继承 RelationException 实现 Serializable

serialVersionUID: 4394092234999959939L

类 javax.management.relation.RoleList 继承 ArrayList<Object> 实现 Serializable

serialVersionUID: 5568344346499649313L

类 javax.management.relation.RoleNotFoundException 继承 RelationException 实现 Serializable

serialVersionUID: -2986406101364031481L

类 javax.management.relation.RoleResult 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 RoleResult。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 RoleResult 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

roleList

RoleList roleList
List of roles successfully accessed

unresolvedRoleList

RoleUnresolvedList unresolvedRoleList
List of roles unsuccessfully accessed

类 javax.management.relation.RoleUnresolved 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 RoleUnresolved。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 RoleUnresolved 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

problemType

int problemType
Problem type

roleName

String roleName
Role name

roleValue

List<E> roleValue
Role value ({@link List} of {@link ObjectName} objects)

类 javax.management.relation.RoleUnresolvedList 继承 ArrayList<Object> 实现 Serializable

serialVersionUID: 4054902803091433324L

软件包 javax.management.remote

类 javax.management.remote.JMXConnectionNotification 继承 Notification 实现 Serializable

serialVersionUID: -2331308725952627538L

序列化字段

connectionId

String connectionId
The connection ID to which this notification pertains.
另请参见：
JMXConnectionNotification.getConnectionId()

类 javax.management.remote.JMXPrincipal 继承 Object 实现 Serializable

serialVersionUID: -4184480100214577411L

序列化字段

name

String name
The JMX Remote API name for the identity represented by this JMXPrincipal object.
另请参见：
JMXPrincipal.getName()

类 javax.management.remote.JMXProviderException 继承 IOException 实现 Serializable

serialVersionUID: -3166703627550447198L

序列化字段

cause

Throwable cause
An exception that caused this exception to be thrown.此字段可以为 null。
另请参见：
JMXProviderException.getCause()

类 javax.management.remote.JMXServerErrorException 继承 IOException 实现 Serializable

serialVersionUID: 3996732239558744666L

序列化字段

cause

Error cause
An Error that caused this exception to be thrown.
另请参见：
JMXServerErrorException.getCause()

类 javax.management.remote.JMXServiceURL 继承 Object 实现 Serializable

serialVersionUID: 8173364409860779292L

序列化字段

protocol

String protocol
由 JMXServiceURL.getProtocol() 返回的值。

host

String host
由 JMXServiceURL.getHost() 返回的值。

port

int port
由 JMXServiceURL.getPort() 返回的值。

urlPath

String urlPath
由 JMXServiceURL.getURLPath() 返回的值。

类 javax.management.remote.NotificationResult 继承 Object 实现 Serializable

serialVersionUID: 1191800228721395279L

序列化字段

earliestSequenceNumber

long earliestSequenceNumber

nextSequenceNumber

long nextSequenceNumber

targetedNotifications

TargetedNotification[] targetedNotifications

类 javax.management.remote.SubjectDelegationPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 1481618113008682343L

类 javax.management.remote.TargetedNotification 继承 Object 实现 Serializable

serialVersionUID: 7676132089779300926L

序列化字段

notif

Notification notif
A notification to transmit to the other side.
另请参见：
TargetedNotification.getNotification()

id

Integer id
The ID of the listener to which the notification is targeted.
另请参见：
TargetedNotification.getListenerID()
软件包 javax.management.remote.rmi

类 javax.management.remote.rmi._RMIConnection_Stub 继承 Stub 实现 Serializable

类 javax.management.remote.rmi._RMIServer_Stub 继承 Stub 实现 Serializable

类 javax.management.remote.rmi.RMIConnectionImpl_Stub 继承 RemoteStub 实现 Serializable

serialVersionUID: 2L

类 javax.management.remote.rmi.RMIConnectionImpl$6 继承 Object 实现 Serializable

类 javax.management.remote.rmi.RMIConnectionImpl$7 继承 Object 实现 Serializable

类 javax.management.remote.rmi.RMIConnector 继承 Object 实现 Serializable

serialVersionUID: 817323035842634473L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 读入 RMIConnector 字段。调用 s.defaultReadObject() 并接着初始化所有需要初始化的中间变量。

抛出：
InvalidObjectException - 如果 rmiServer stub 或 jmxServiceURL 均未设置。
IOException
ClassNotFoundException
另请参见：
RMIConnector.RMIConnector(JMXServiceURL,Map), RMIConnector.RMIConnector(RMIServer,Map)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 RMIConnector 字段写入到 ObjectOutputStream。

如果需要的话，在初始化之前，将基础 RMIServer stub 连接到一个 ORB。通过使用为构造方法提供的环境映射（如果有）来完成此连接，如在 javax.management.remote.rmi 中描述的那样。

然后此方法调用 s.defaultWriteObject()。通常，如果此对象是使用 JMXServiceURL 构造的，则 rmiServer 为 null，如果此对象是使用 RMIServer stub 构造的，则 jmxServiceURL 为 null。

注意，环境 Map 并未序列化，因为假定它包含的对象只对于本地环境（类加载器、ORB，等等）而言是上下文相关的。

对 RMIConnector 反序列化后，假定用户将调用 RMIConnector.connect(Map)，则它提供了一个包含与新本地环境上下文相关的值的 Map。

由于在序列化之前需要连接到 ORB，并且要连接到的 ORB 为上下文相关的参数之一，不建议对刚刚序列化过的对象重新序列化，因为反序列化的对象不具有映射。因此，需要将一个 RMIConnector 对象序列化或传输到一个远程应用程序时，建议通过调用 RMIConnectorServer.toJMXConnector(Map) 获得新的 RMIConnector stub。

抛出：
InvalidObjectException - 如果 rmiServer stub 或 jmxServiceURL 均未设置。
IOException
另请参见：
RMIConnector.RMIConnector(JMXServiceURL,Map), RMIConnector.RMIConnector(RMIServer,Map)
序列化字段

rmiServer

RMIServer rmiServer
The RMIServer stub of the RMI JMX Connector server to which this client connector is (or will be) connected.当 jmxServiceURL 不为 null 时，此字段可以为 null。这包括了 jmxServiceURL 包含序列化的 RMIServer stub 的情况。如果 rmiServer 和 jmxServiceURL 都为 null，则序列化将失败。
另请参见：
RMIConnector.RMIConnector(RMIServer,Map)

jmxServiceURL

JMXServiceURL jmxServiceURL
The JMXServiceURL of the RMI JMX Connector server to which this client connector will be connected.当 rmiServer 不为 null 时，此字段可以为 null。如果 rmiServer 和 jmxServiceURL 都为 null，则序列化将失败。
另请参见：
RMIConnector.RMIConnector(JMXServiceURL,Map)

类 javax.management.remote.rmi.RMIServerImpl_Stub 继承 RemoteStub 实现 Serializable

serialVersionUID: 2L

软件包 javax.management.timer

类 javax.management.timer.TimerNotification 继承 Notification 实现 Serializable

serialVersionUID: 1798492029603825750L

序列化字段

notificationID

Integer notificationID
Timer notification identifier.此标识符用来从通知的计时器列表中检索计时器通知。
软件包 javax.naming

类 javax.naming.AuthenticationException 继承 NamingSecurityException 实现 Serializable

serialVersionUID: 3678497619904568096L

类 javax.naming.AuthenticationNotSupportedException 继承 NamingSecurityException 实现 Serializable

serialVersionUID: -7149033933259492300L

类 javax.naming.BinaryRefAddr 继承 RefAddr 实现 Serializable

serialVersionUID: -3415254970957330361L

序列化字段

buf

byte[] buf
包含地址字节。此字段由构造方法初始化，并使用 getAddressBytes() 和 getAddressContents() 返回。

类 javax.naming.Binding 继承 NameClassPair 实现 Serializable

serialVersionUID: 8839217842691845890L

序列化字段

boundObj

Object boundObj
包含此绑定的对象。它由构造方法初始化，可以使用 setObject 更新。

另请参见：
Binding.getObject(), Binding.setObject(java.lang.Object)

类 javax.naming.CannotProceedException 继承 NamingException 实现 Serializable

serialVersionUID: 1219724816191576813L

序列化字段

remainingNewName

Name remainingNewName
包含 Context.rename() 第二个 "name" 参数的剩余未解析部分。此信息对于继续 Context.rename() 操作是必需的。

此字段被初始化为 null。不应该直接操作它：应该使用 getRemainingName() 和 setRemainingName() 访问和更新。

另请参见：
CannotProceedException.getRemainingNewName(), CannotProceedException.setRemainingNewName(javax.naming.Name)

environment

Hashtable<K,V> environment
包含与无法继续进行的 Context 或 DirContext 方法有关的环境。

此字段被初始化为 null。不应该直接操作它：应该使用 getEnvironment() 和 setEnvironment() 访问和更新。

另请参见：
CannotProceedException.getEnvironment(), CannotProceedException.setEnvironment(java.util.Hashtable)

altName

Name altName
包含已解析对象的名称，该名称相对于上下文 altNameCtx。该名称是一个复合名称。如果为 null，则不指定任何名称。有关如何使用此方法的详细信息，请参见 javax.naming.spi.ObjectFactory.getObjectInstance 方法。

此字段被初始化为 null。不应该直接操作它：应该使用 getAltName() 和 setAltName() 访问和更新。

另请参见：
CannotProceedException.getAltName(), CannotProceedException.setAltName(javax.naming.Name), CannotProceedException.altNameCtx, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

altNameCtx

Context altNameCtx
包含上下文，altName 是相对于该上下文指定的。如果为 null，则暗指默认初始上下文。有关如何使用此方法的详细信息，请参见 javax.naming.spi.ObjectFactory.getObjectInstance 方法。

此字段被初始化为 null。不应该直接操作它：应该使用 getAltNameCtx() 和 setAltNameCtx() 访问和更新。

另请参见：
CannotProceedException.getAltNameCtx(), CannotProceedException.setAltNameCtx(javax.naming.Context), CannotProceedException.altName, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

类 javax.naming.CommunicationException 继承 NamingException 实现 Serializable

serialVersionUID: 3618507780299986611L

类 javax.naming.CompositeName 继承 Object 实现 Serializable

serialVersionUID: 1667768148915813118L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
重写以避免存在实现依赖关系。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
重写以避免存在实现依赖关系。

序列数据：
个别组件后跟着的组件数（一个 int），每个组件都是一个 String。
抛出：
IOException

类 javax.naming.CompoundName 继承 Object 实现 Serializable

serialVersionUID: 3513100557083972036L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
重写以避免存在实现依赖关系。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
重写以避免存在实现依赖关系。

序列数据：
语法 Properties，后跟组件数（一个 int），以及个别组件，每个组件都是一个 String。
抛出：
IOException

类 javax.naming.ConfigurationException 继承 NamingException 实现 Serializable

serialVersionUID: -2535156726228855704L

类 javax.naming.ContextNotEmptyException 继承 NamingException 实现 Serializable

serialVersionUID: 1090963683348219877L

类 javax.naming.InsufficientResourcesException 继承 NamingException 实现 Serializable

serialVersionUID: 6227672693037844532L

类 javax.naming.InterruptedNamingException 继承 NamingException 实现 Serializable

serialVersionUID: 6404516648893194728L

类 javax.naming.InvalidNameException 继承 NamingException 实现 Serializable

serialVersionUID: -8370672380823801105L

类 javax.naming.LimitExceededException 继承 NamingException 实现 Serializable

serialVersionUID: -776898738660207856L

类 javax.naming.LinkException 继承 NamingException 实现 Serializable

serialVersionUID: -7967662604076777712L

序列化字段

linkResolvedName

Name linkResolvedName
包含已成功解析的链接部分。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
LinkException.getLinkResolvedName(), LinkException.setLinkResolvedName(javax.naming.Name)

linkResolvedObj

Object linkResolvedObj
包含一个对象，已成功解析的链接部分一直到达该对象。可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
LinkException.getLinkResolvedObj(), LinkException.setLinkResolvedObj(java.lang.Object)

linkRemainingName

Name linkRemainingName
包含尚未解析的剩余链接名称。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
LinkException.getLinkRemainingName(), LinkException.setLinkRemainingName(javax.naming.Name)

linkExplanation

String linkExplanation
包含链接解析失败原因的异常。可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
LinkException.getLinkExplanation(), LinkException.setLinkExplanation(java.lang.String)

类 javax.naming.LinkLoopException 继承 LinkException 实现 Serializable

serialVersionUID: -3119189944325198009L

类 javax.naming.LinkRef 继承 Reference 实现 Serializable

serialVersionUID: -5386290613498931298L

类 javax.naming.MalformedLinkException 继承 LinkException 实现 Serializable

serialVersionUID: -3066740437737830242L

类 javax.naming.NameAlreadyBoundException 继承 NamingException 实现 Serializable

serialVersionUID: -8491441000356780586L

类 javax.naming.NameClassPair 继承 Object 实现 Serializable

serialVersionUID: 5620776610160863339L

序列化字段

name

String name
包含此 NameClassPair 的名称。它由构造方法初始化，可以使用 setName() 更新。

另请参见：
NameClassPair.getName(), NameClassPair.setName(java.lang.String)

className

String className
包含此 NameClassPair 中包含的类名称。它由构造方法初始化，可以使用 setClassName() 更新。

另请参见：
NameClassPair.getClassName(), NameClassPair.setClassName(java.lang.String)

fullName

String fullName
包含其自己的名称空间中此 NameClassPair 的完全名称。它使用 setNameInNamespace() 初始化

另请参见：
NameClassPair.getNameInNamespace(), NameClassPair.setNameInNamespace(java.lang.String)

isRel

boolean isRel
记录此 NameClassPair 的名称是否相对于目标上下文。它由构造方法初始化，可以使用 setRelative() 更新。

另请参见：
NameClassPair.isRelative(),
NameClassPair.setRelative(boolean),
NameClassPair.getName(),
NameClassPair.setName(java.lang.String)

类 javax.naming.NameNotFoundException 继承 NamingException 实现 Serializable

serialVersionUID: -8007156725367842053L

类 javax.naming.NamingException 继承 Exception 实现 Serializable

serialVersionUID: -1299181962103167177L

序列化字段

resolvedName

Name resolvedName
包含已成功解析的名称部分。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
NamingException.getResolvedName(), NamingException.setResolvedName(javax.naming.Name)

resolvedObj

Object resolvedObj
包含一个对象，已成功解析的名称部分进行到该对象。可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
NamingException.getResolvedObj(), NamingException.setResolvedObj(java.lang.Object)

remainingName

Name remainingName
包含尚未解析的剩余名称。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get、set 和 "append" 方法访问和操作此字段。

另请参见：
NamingException.getRemainingName(),
NamingException.setRemainingName(javax.naming.Name),
NamingException.appendRemainingName(javax.naming.Name),
NamingException.appendRemainingComponent(java.lang.String)

rootException

Throwable rootException
包含导致抛出此 NamingException 的原始异常。如果存在可以从原始异常中获得的附加信息，或者无法将原始异常映射到 NamingException 的子类，则设置此字段。可以为 null。

此字段早于通用异常链设施。NamingException.initCause(Throwable) 和 NamingException.getCause() 方法现在是访问此信息的首选方法。

另请参见：
NamingException.getRootCause(),
NamingException.setRootCause(Throwable),
NamingException.initCause(Throwable),
NamingException.getCause()

类 javax.naming.NamingSecurityException 继承 NamingException 实现 Serializable

serialVersionUID: 5855287647294685775L

类 javax.naming.NoInitialContextException 继承 NamingException 实现 Serializable

serialVersionUID: -3413733186901258623L

类 javax.naming.NoPermissionException 继承 NamingSecurityException 实现 Serializable

serialVersionUID: 8395332708699751775L

类 javax.naming.NotContextException 继承 NamingException 实现 Serializable

serialVersionUID: 849752551644540417L

类 javax.naming.OperationNotSupportedException 继承 NamingException 实现 Serializable

serialVersionUID: 5493232822427682064L

类 javax.naming.PartialResultException 继承 NamingException 实现 Serializable

serialVersionUID: 2572144970049426786L

类 javax.naming.RefAddr 继承 Object 实现 Serializable

serialVersionUID: -1468165120479154358L

序列化字段

addrType

String addrType
包含此地址的类型。

类 javax.naming.Reference 继承 Object 实现 Serializable

serialVersionUID: -1673475790065791735L

序列化字段

className

String className
包含此 Reference 所引用的对象类的完全限定名称。

另请参见：
Class.getName()

addrs

Vector<E> addrs
包含此 Reference 中所包含的地址。由构造方法初始化。

classFactory

String classFactory
包含用来创建此 Reference 所引用的对象实例的工厂类名称。被初始化为 null。

classFactoryLocation

String classFactoryLocation
包含工厂类的位置。被初始化为 null。

类 javax.naming.ReferralException 继承 NamingException 实现 Serializable

serialVersionUID: -2881363844695698876L

类 javax.naming.ServiceUnavailableException 继承 NamingException 实现 Serializable

serialVersionUID: -4996964726566773444L

类 javax.naming.SizeLimitExceededException 继承 LimitExceededException 实现 Serializable

serialVersionUID: 7129289564879168579L

类 javax.naming.StringRefAddr 继承 RefAddr 实现 Serializable

serialVersionUID: -8913762495138505527L

序列化字段

contents

String contents
包含此地址的内容。可以为 null。

类 javax.naming.TimeLimitExceededException 继承 LimitExceededException 实现 Serializable

serialVersionUID: -3597009011385034696L

软件包 javax.naming.directory

类 javax.naming.directory.AttributeInUseException 继承 NamingException 实现 Serializable

serialVersionUID: 4437710305529322564L

类 javax.naming.directory.AttributeModificationException 继承 NamingException 实现 Serializable

serialVersionUID: 8060676069678710186L

序列化字段

unexecs

ModificationItem[] unexecs
包含未执行修改的可能为 null 的列表。

类 javax.naming.directory.BasicAttribute 继承 Object 实现 Serializable

serialVersionUID: 6743528196119291326L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
重写以避免公开实现细节。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
重写以避免公开实现细节

序列数据：
Default field (the attribute ID -- a String), followed by the number of values (an int), and the individual values.
抛出：
IOException
序列化字段

attrID

String attrID
保存属性的 id。其由公共构造方法初始化且不能为 null，除非已经重写 BasicAttribute 中使用 attrID 的方法。

ordered

boolean ordered
记录此属性的值是否有序的标志。

类 javax.naming.directory.BasicAttributes 继承 Object 实现 Serializable

serialVersionUID: 4980164073184639448L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
重写以避免公开实现细节。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
重写以避免公开实现细节。

序列数据：
Default field (ignoreCase flag -- a boolean), followed by the number of attributes in the set (an int), and then the individual Attribute objects.
抛出：
IOException
序列化字段

ignoreCase

boolean ignoreCase
指示是否忽略属性 id 的大小写。

类 javax.naming.directory.InvalidAttributeIdentifierException 继承 NamingException 实现 Serializable

serialVersionUID: -9036920266322999923L

类 javax.naming.directory.InvalidAttributesException 继承 NamingException 实现 Serializable

serialVersionUID: 2607612850539889765L

类 javax.naming.directory.InvalidAttributeValueException 继承 NamingException 实现 Serializable

serialVersionUID: 8720050295499275011L

类 javax.naming.directory.InvalidSearchControlsException 继承 NamingException 实现 Serializable

serialVersionUID: -5124108943352665777L

类 javax.naming.directory.InvalidSearchFilterException 继承 NamingException 实现 Serializable

serialVersionUID: 2902700940682875441L

类 javax.naming.directory.ModificationItem 继承 Object 实现 Serializable

serialVersionUID: 7573258562534746850L

序列化字段

mod_op

int mod_op
包含标识要执行的修改的整数。

attr

Attribute attr
包含标识要应用于修改的属性和/或其值的属性。

类 javax.naming.directory.NoSuchAttributeException 继承 NamingException 实现 Serializable

serialVersionUID: 4836415647935888137L

类 javax.naming.directory.SchemaViolationException 继承 NamingException 实现 Serializable

serialVersionUID: -3041762429525049663L

类 javax.naming.directory.SearchControls 继承 Object 实现 Serializable

serialVersionUID: -2480540967773454797L

序列化字段

searchScope

int searchScope
包含应用搜索的范围。ONELEVEL_SCOPE、OBJECT_SCOPE 或 SUBTREE_SCOPE 之一。

timeLimit

int timeLimit
包含从搜索返回前要等待的毫秒数。

derefLink

boolean derefLink
指示在搜索期间是否取消对 JNDI 链接的引用。

returnObj

boolean returnObj
指示是否在 SearchResult 中返回对象。

countLimit

long countLimit
包含要返回的最大 SearchResults 数。

attributesToReturn

String[] attributesToReturn
包含要为搜索的每个匹配项在 SearchResult 中返回的属性所组成的列表。null 指示要返回所有属性。

类 javax.naming.directory.SearchResult 继承 Binding 实现 Serializable

serialVersionUID: -9158063327699723172L

序列化字段

attrs

Attributes attrs
包含与对象一起返回的属性。

软件包 javax.naming.event

类 javax.naming.event.NamingEvent 继承 EventObject 实现 Serializable

serialVersionUID: -7126752885365133499L

序列化字段

changeInfo

Object changeInfo
包含关于生成此事件的更改的信息。

type

int type
包含此事件的类型。

另请参见：
NamingEvent.OBJECT_ADDED, NamingEvent.OBJECT_REMOVED, NamingEvent.OBJECT_RENAMED, NamingEvent.OBJECT_CHANGED

oldBinding

Binding oldBinding
包含关于更改前对象的信息。

newBinding

Binding newBinding
包含关于更改后对象的信息。

类 javax.naming.event.NamingExceptionEvent 继承 EventObject 实现 Serializable

serialVersionUID: -4877678086134736336L

序列化字段

exception

NamingException exception
包含抛出过的异常

软件包 javax.naming.ldap

类 javax.naming.ldap.BasicControl 继承 Object 实现 Serializable

serialVersionUID: -4233907508771791687L

序列化字段

id

String id
控件的对象标识符字符串。

criticality

boolean criticality
控件的关键性。

value

byte[] value
控件的 ASN.1 BER 编码值。

类 javax.naming.ldap.LdapName 继承 Object 实现 Serializable

serialVersionUID: -1595520034788997356L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
仅序列化未解析的 DN，以更紧密并避免任何实现依赖关系。

序列数据：
The DN string
抛出：
IOException

类 javax.naming.ldap.LdapReferralException 继承 ReferralException 实现 Serializable

serialVersionUID: -1668992791764950804L

类 javax.naming.ldap.ManageReferralControl 继承 BasicControl 实现 Serializable

serialVersionUID: 3017756160149982566L

类 javax.naming.ldap.PagedResultsControl 继承 BasicControl 实现 Serializable

serialVersionUID: 6684806685736844298L

类 javax.naming.ldap.PagedResultsResponseControl 继承 BasicControl 实现 Serializable

serialVersionUID: -8819778744844514666L

序列化字段

resultSize

int resultSize
搜索结果中的项数的估计值。

cookie

byte[] cookie
服务器生成的 cookie。

类 javax.naming.ldap.Rdn 继承 Object 实现 Serializable

serialVersionUID: -5994465067210009656L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
仅序列化未解析的 RDN，以更紧密并避免任何实现依赖关系。

序列数据：
The RDN string
抛出：
IOException

类 javax.naming.ldap.SortControl 继承 BasicControl 实现 Serializable

serialVersionUID: -1965961680233330744L

类 javax.naming.ldap.SortResponseControl 继承 BasicControl 实现 Serializable

serialVersionUID: 5142939176006310877L

序列化字段

resultCode

int resultCode
排序结果代码。

badAttrId

String badAttrId
导致排序失败的属性的 ID。

类 javax.naming.ldap.StartTlsRequest 继承 Object 实现 Serializable

serialVersionUID: 4441679576360753397L

类 javax.naming.ldap.StartTlsResponse 继承 Object 实现 Serializable

serialVersionUID: 8372842182579276418L

类 javax.naming.ldap.UnsolicitedNotificationEvent 继承 EventObject 实现 Serializable

serialVersionUID: -2382603380799883705L

序列化字段

notice

UnsolicitedNotification notice
导致触发此事件的通知。

软件包 javax.naming.spi

类 javax.naming.spi.ResolveResult 继承 Object 实现 Serializable

serialVersionUID: -4552108072002407559L

序列化字段

resolvedObj

Object resolvedObj
该字段包含已成功解析成的 Object。它只在使用子类构造时可以为 null。构造方法应该总是初始化此字段。

remainingName

Name remainingName
该字段包含要解析的剩余名称。它只在使用子类构造时可以为 null。构造方法应该总是初始化此字段。

软件包 javax.net.ssl

类 javax.net.ssl.HandshakeCompletedEvent 继承 EventObject 实现 Serializable

类 javax.net.ssl.SSLException 继承 IOException 实现 Serializable

类 javax.net.ssl.SSLHandshakeException 继承 SSLException 实现 Serializable

类 javax.net.ssl.SSLKeyException 继承 SSLException 实现 Serializable

类 javax.net.ssl.SSLPeerUnverifiedException 继承 SSLException 实现 Serializable

类 javax.net.ssl.SSLPermission 继承 BasicPermission 实现 Serializable

类 javax.net.ssl.SSLProtocolException 继承 SSLException 实现 Serializable

类 javax.net.ssl.SSLSessionBindingEvent 继承 EventObject 实现 Serializable

序列化字段

name

String name
将对象绑定到的或从其解除绑定的名称

类 javax.net.ssl.SSLSocketFactory$1 继承 Object 实现 Serializable

软件包 javax.print

类 javax.print.DocFlavor 继承 Object 实现 Serializable

serialVersionUID: -4512080796965449721L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
根据流重构实例（也就是将其反序列化）。

序列数据：
DocFlavor 的序列化形式是名称为表示形式类的 String，后跟表示 MIME 类型规范形式的 String。
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将实例写入流中（也就是序列化该对象）。

抛出：
IOException
序列化字段

myClassName

String myClassName
表示形式类名。

类 javax.print.DocFlavor.BYTE_ARRAY 继承 DocFlavor 实现 Serializable

serialVersionUID: -9065578006593857475L

类 javax.print.DocFlavor.CHAR_ARRAY 继承 DocFlavor 实现 Serializable

serialVersionUID: -8720590903724405128L

类 javax.print.DocFlavor.INPUT_STREAM 继承 DocFlavor 实现 Serializable

serialVersionUID: -7045842700749194127L

类 javax.print.DocFlavor.READER 继承 DocFlavor 实现 Serializable

serialVersionUID: 7100295812579351567L

类 javax.print.DocFlavor.SERVICE_FORMATTED 继承 DocFlavor 实现 Serializable

serialVersionUID: 6181337766266637256L

类 javax.print.DocFlavor.STRING 继承 DocFlavor 实现 Serializable

serialVersionUID: 4414407504887034035L

类 javax.print.DocFlavor.URL 继承 DocFlavor 实现 Serializable

类 javax.print.PrintException 继承 Exception 实现 Serializable

软件包 javax.print.attribute

类 javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet 继承 Object 实现 Serializable

序列化字段

attrset

AttributeSet attrset

类 javax.print.attribute.AttributeSetUtilities.SynchronizedDocAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.SynchronizedPrintJobAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.SynchronizedPrintRequestAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.SynchronizedPrintServiceAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet 继承 Object 实现 Serializable

序列化字段

attrset

AttributeSet attrset

类 javax.print.attribute.AttributeSetUtilities.UnmodifiableDocAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintJobAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintRequestAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintServiceAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet 实现 Serializable

类 javax.print.attribute.DateTimeSyntax 继承 Object 实现 Serializable

serialVersionUID: -1400819079791208582L

序列化字段

value

Date value
此日期-时间属性的 java.util.Date 值。

类 javax.print.attribute.EnumSyntax 继承 Object 实现 Serializable

serialVersionUID: -2739521845085831642L

序列化方法

readResolve

protected Object readResolve()
                      throws ObjectStreamException
在对象输入过程中，将此反序列化的枚举实例转换为枚举属性类中定义的适当枚举值。

抛出：
ObjectStreamException - 如果无法对流反序列化
InvalidObjectException - 如果枚举值表为 null，此枚举值的整数值与枚举值表中的元素不对应，或枚举值表中的对应元素为 null，则抛出该异常。（注：InvalidObjectException 是 ObjectStreamException 的一个子类，ObjectStreamException 由 readResolve() 声明抛出。
序列化字段

value

int value
此枚举值的整数值。

类 javax.print.attribute.HashAttributeSet 继承 Object 实现 Serializable

serialVersionUID: 5311560590283707917L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从流重构一个实例（也就是将其反序列化）。

抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将该实例写入到流（即：将该对象序列化）

序列数据：
属性集的序列化形式显式写入该集合中的属性的数量和每个属性。这不保证序列化形式的相等性，因为未定义写入属性的顺序。
抛出：
IOException
序列化字段

myInterface

Class<T> myInterface
此属性集的所有成员必须是其实例的接口。假设是接口 Attribute 或其子接口。

类 javax.print.attribute.HashDocAttributeSet 继承 HashAttributeSet 实现 Serializable

serialVersionUID: -1128534486061432528L

类 javax.print.attribute.HashPrintJobAttributeSet 继承 HashAttributeSet 实现 Serializable

serialVersionUID: -4204473656070350348L

类 javax.print.attribute.HashPrintRequestAttributeSet 继承 HashAttributeSet 实现 Serializable

serialVersionUID: 2364756266107751933L

类 javax.print.attribute.HashPrintServiceAttributeSet 继承 HashAttributeSet 实现 Serializable

serialVersionUID: 6642904616179203070L

类 javax.print.attribute.IntegerSyntax 继承 Object 实现 Serializable

serialVersionUID: 3644574816328081943L

序列化字段

value

int value
此整数属性的整数值。

类 javax.print.attribute.ResolutionSyntax 继承 Object 实现 Serializable

serialVersionUID: 2706743076526672017L

序列化字段

crossFeedResolution

int crossFeedResolution
以每 100 英寸点数 (dphi) 为单位的反向进纸分辨率。

feedResolution

int feedResolution
以每 100 英寸点数 (dphi) 为单位的进纸分辨率。

类 javax.print.attribute.SetOfIntegerSyntax 继承 Object 实现 Serializable

serialVersionUID: 3666874174847632203L

序列化字段

members

int[][] members
规范数组形式表示的此集合的成员。

类 javax.print.attribute.Size2DSyntax 继承 Object 实现 Serializable

serialVersionUID: 5584439964938660530L

序列化字段

x

int x
以微米 (µm) 为单位的 X 维度。

y

int y
以微米 (µm) 为单位的 Y 维度。

类 javax.print.attribute.TextSyntax 继承 Object 实现 Serializable

serialVersionUID: -8130648736378144102L

序列化字段

value

String value
此文本属性的字符串值。

locale

Locale locale
此文本属性的语言环境。

类 javax.print.attribute.UnmodifiableSetException 继承 RuntimeException 实现 Serializable

类 javax.print.attribute.URISyntax 继承 Object 实现 Serializable

serialVersionUID: -7842661210486401678L

序列化字段

uri

URI uri
此 URI 属性的 URI 值。

软件包 javax.print.attribute.standard

类 javax.print.attribute.standard.Chromaticity 继承 EnumSyntax 实现 Serializable

serialVersionUID: 4660543931355214012L

类 javax.print.attribute.standard.ColorSupported 继承 EnumSyntax 实现 Serializable

serialVersionUID: -2700555589688535545L

类 javax.print.attribute.standard.Compression 继承 EnumSyntax 实现 Serializable

serialVersionUID: -5716748913324997674L

类 javax.print.attribute.standard.Copies 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -6426631521680023833L

类 javax.print.attribute.standard.CopiesSupported 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: 6927711687034846001L

类 javax.print.attribute.standard.DateTimeAtCompleted 继承 DateTimeSyntax 实现 Serializable

serialVersionUID: 6497399708058490000L

类 javax.print.attribute.standard.DateTimeAtCreation 继承 DateTimeSyntax 实现 Serializable

serialVersionUID: -2923732231056647903L

类 javax.print.attribute.standard.DateTimeAtProcessing 继承 DateTimeSyntax 实现 Serializable

serialVersionUID: -3710068197278263244L

类 javax.print.attribute.standard.Destination 继承 URISyntax 实现 Serializable

serialVersionUID: 6776739171700415321L

类 javax.print.attribute.standard.DocumentName 继承 TextSyntax 实现 Serializable

serialVersionUID: 7883105848533280430L

类 javax.print.attribute.standard.Fidelity 继承 EnumSyntax 实现 Serializable

serialVersionUID: 6320827847329172308L

类 javax.print.attribute.standard.Finishings 继承 EnumSyntax 实现 Serializable

serialVersionUID: -627840419548391754L

类 javax.print.attribute.standard.JobHoldUntil 继承 DateTimeSyntax 实现 Serializable

serialVersionUID: -1664471048860415024L

类 javax.print.attribute.standard.JobImpressions 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 8225537206784322464L

类 javax.print.attribute.standard.JobImpressionsCompleted 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 6722648442432393294L

类 javax.print.attribute.standard.JobImpressionsSupported 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: -4887354803843173692L

类 javax.print.attribute.standard.JobKOctets 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -8959710146498202869L

类 javax.print.attribute.standard.JobKOctetsProcessed 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -6265238509657881806L

类 javax.print.attribute.standard.JobKOctetsSupported 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: -2867871140549897443L

类 javax.print.attribute.standard.JobMediaSheets 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 408871131531979741L

类 javax.print.attribute.standard.JobMediaSheetsCompleted 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 1739595973810840475L

类 javax.print.attribute.standard.JobMediaSheetsSupported 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: 2953685470388672940L

类 javax.print.attribute.standard.JobMessageFromOperator 继承 TextSyntax 实现 Serializable

serialVersionUID: -4620751846003142047L

类 javax.print.attribute.standard.JobName 继承 TextSyntax 实现 Serializable

serialVersionUID: 4660359192078689545L

类 javax.print.attribute.standard.JobOriginatingUserName 继承 TextSyntax 实现 Serializable

serialVersionUID: -8052537926362933477L

类 javax.print.attribute.standard.JobPriority 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -4599900369040602769L

类 javax.print.attribute.standard.JobPrioritySupported 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 2564840378013555894L

类 javax.print.attribute.standard.JobSheets 继承 EnumSyntax 实现 Serializable

serialVersionUID: -4735258056132519759L

类 javax.print.attribute.standard.JobState 继承 EnumSyntax 实现 Serializable

serialVersionUID: 400465010094018920L

类 javax.print.attribute.standard.JobStateReason 继承 EnumSyntax 实现 Serializable

serialVersionUID: -8765894420449009168L

类 javax.print.attribute.standard.JobStateReasons 继承 HashSet<JobStateReason> 实现 Serializable

serialVersionUID: 8849088261264331812L

类 javax.print.attribute.standard.Media 继承 EnumSyntax 实现 Serializable

serialVersionUID: -2823970704630722439L

类 javax.print.attribute.standard.MediaName 继承 Media 实现 Serializable

serialVersionUID: 4653117714524155448L

类 javax.print.attribute.standard.MediaPrintableArea 继承 Object 实现 Serializable

serialVersionUID: -1597171464050795793L

序列化字段

x

int x

y

int y

w

int w

h

int h

units

int units

类 javax.print.attribute.standard.MediaSize 继承 Size2DSyntax 实现 Serializable

serialVersionUID: -1967958664615414771L

序列化字段

mediaName

MediaSizeName mediaName

类 javax.print.attribute.standard.MediaSizeName 继承 Media 实现 Serializable

serialVersionUID: 2778798329756942747L

类 javax.print.attribute.standard.MediaTray 继承 Media 实现 Serializable

serialVersionUID: -982503611095214703L

类 javax.print.attribute.standard.MultipleDocumentHandling 继承 EnumSyntax 实现 Serializable

serialVersionUID: 8098326460746413466L

类 javax.print.attribute.standard.NumberOfDocuments 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 7891881310684461097L

类 javax.print.attribute.standard.NumberOfInterveningJobs 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 2568141124844982746L

类 javax.print.attribute.standard.NumberUp 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -3040436486786527811L

类 javax.print.attribute.standard.NumberUpSupported 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: -1041573395759141805L

类 javax.print.attribute.standard.OrientationRequested 继承 EnumSyntax 实现 Serializable

serialVersionUID: -4447437289862822276L

类 javax.print.attribute.standard.OutputDeviceAssigned 继承 TextSyntax 实现 Serializable

serialVersionUID: 5486733778854271081L

类 javax.print.attribute.standard.PageRanges 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: 8639895197656148392L

类 javax.print.attribute.standard.PagesPerMinute 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -6366403993072862015L

类 javax.print.attribute.standard.PagesPerMinuteColor 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 1684993151687470944L

类 javax.print.attribute.standard.PDLOverrideSupported 继承 EnumSyntax 实现 Serializable

serialVersionUID: -4393264467928463934L

类 javax.print.attribute.standard.PresentationDirection 继承 EnumSyntax 实现 Serializable

serialVersionUID: 8294728067230931780L

类 javax.print.attribute.standard.PrinterInfo 继承 TextSyntax 实现 Serializable

serialVersionUID: 7765280618777599727L

类 javax.print.attribute.standard.PrinterIsAcceptingJobs 继承 EnumSyntax 实现 Serializable

serialVersionUID: -5052010680537678061L

类 javax.print.attribute.standard.PrinterLocation 继承 TextSyntax 实现 Serializable

serialVersionUID: -1598610039865566337L

类 javax.print.attribute.standard.PrinterMakeAndModel 继承 TextSyntax 实现 Serializable

serialVersionUID: 4580461489499351411L

类 javax.print.attribute.standard.PrinterMessageFromOperator 继承 TextSyntax 实现 Serializable

serialVersionUID: -4486871203218629318L

类 javax.print.attribute.standard.PrinterMoreInfo 继承 URISyntax 实现 Serializable

serialVersionUID: 4555850007675338574L

类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 继承 URISyntax 实现 Serializable

serialVersionUID: 3323271346485076608L

类 javax.print.attribute.standard.PrinterName 继承 TextSyntax 实现 Serializable

serialVersionUID: 299740639137803127L

类 javax.print.attribute.standard.PrinterResolution 继承 ResolutionSyntax 实现 Serializable

serialVersionUID: 13090306561090558L

类 javax.print.attribute.standard.PrinterState 继承 EnumSyntax 实现 Serializable

serialVersionUID: -649578618346507718L

类 javax.print.attribute.standard.PrinterStateReason 继承 EnumSyntax 实现 Serializable

serialVersionUID: -1623720656201472593L

类 javax.print.attribute.standard.PrinterStateReasons 继承 HashMap<PrinterStateReason,Severity> 实现 Serializable

serialVersionUID: -3731791085163619457L

类 javax.print.attribute.standard.PrinterURI 继承 URISyntax 实现 Serializable

serialVersionUID: 7923912792485606497L

类 javax.print.attribute.standard.PrintQuality 继承 EnumSyntax 实现 Serializable

serialVersionUID: -3072341285225858365L

类 javax.print.attribute.standard.QueuedJobCount 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 7499723077864047742L

类 javax.print.attribute.standard.ReferenceUriSchemesSupported 继承 EnumSyntax 实现 Serializable

serialVersionUID: -8989076942813442805L

类 javax.print.attribute.standard.RequestingUserName 继承 TextSyntax 实现 Serializable

serialVersionUID: -2683049894310331454L

类 javax.print.attribute.standard.Severity 继承 EnumSyntax 实现 Serializable

serialVersionUID: 8781881462717925380L

类 javax.print.attribute.standard.SheetCollate 继承 EnumSyntax 实现 Serializable

serialVersionUID: 7080587914259873003L

类 javax.print.attribute.standard.Sides 继承 EnumSyntax 实现 Serializable

serialVersionUID: -6890309414893262822L

软件包 javax.print.event

类 javax.print.event.PrintEvent 继承 EventObject 实现 Serializable

serialVersionUID: 2286914924430763847L

类 javax.print.event.PrintJobAttributeEvent 继承 PrintEvent 实现 Serializable

serialVersionUID: -6534469883874742101L

序列化字段

attributes

PrintJobAttributeSet attributes

类 javax.print.event.PrintJobEvent 继承 PrintEvent 实现 Serializable

serialVersionUID: -1711656903622072997L

序列化字段

reason

int reason

类 javax.print.event.PrintServiceAttributeEvent 继承 PrintEvent 实现 Serializable

serialVersionUID: -7565987018140326600L

序列化字段

attributes

PrintServiceAttributeSet attributes
软件包 javax.rmi.CORBA

类 javax.rmi.CORBA.ClassDesc 继承 Object 实现 Serializable

序列化字段

repid

String repid
该类的 RepositoryId。

codebase

String codebase
代码基 URL 的空格分隔的列表。

类 javax.rmi.CORBA.Stub 继承 ObjectImpl 实现 Serializable

serialVersionUID: 1087775603798577179L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
恢复 IOR 状态的序列化方法。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
保存 IOR 状态的序列化方法。

序列数据：
IOR 类型 ID (int) 的长度，后跟 IOR 类型 ID（使用 ISO8859-1 编码的字节数组），后跟 IOR 配置文件数 (int)，后跟 IOR 配置文件。每个 IOR 配置文件作为配置文件标签 (int) 写入，后跟配置文件数据 (int) 的长度，后跟配置文件数据（字节数组）。
抛出：
IOException
软件包 javax.rmi.ssl

类 javax.rmi.ssl.SslRMIClientSocketFactory 继承 Object 实现 Serializable

serialVersionUID: -8310631444933958385L

软件包 javax.script

类 javax.script.ScriptException 继承 Exception 实现 Serializable

序列化字段

fileName

String fileName

lineNumber

int lineNumber

columnNumber

int columnNumber
软件包 javax.security.auth

类 javax.security.auth.AuthPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 5806031445061587174L

类 javax.security.auth.DestroyFailedException 继承 Exception 实现 Serializable

serialVersionUID: -7790152857282749162L

类 javax.security.auth.PrivateCredentialPermission 继承 Permission 实现 Serializable

serialVersionUID: 5284372143517237068L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流读取此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException
序列化字段

credentialClass

String credentialClass

principals

Set<E> principals
与此 permission 相关联的 Principals 。该集合包含 PrivateCredentialPermission.CredOwner 类型的元素。

testing

boolean testing

类 javax.security.auth.PrivateCredentialPermission.CredOwner 继承 Object 实现 Serializable

serialVersionUID: -5607449830436408266L

序列化字段

principalClass

String principalClass

principalName

String principalName

类 javax.security.auth.RefreshFailedException 继承 Exception 实现 Serializable

serialVersionUID: 5058444488565265840L

类 javax.security.auth.Subject 继承 Object 实现 Serializable

serialVersionUID: -8308522755600156056L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流读取此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
将此对象写入到流中（也就是将其序列化）。

抛出：
IOException
序列化字段

principals

Set<E> principals
A Set that provides a view of all of this Subject's Principals

Each element in this set is a java.security.Principal. The set is a Subject.SecureSet.

readOnly

boolean readOnly
此 Subject 是否为只读的

类 javax.security.auth.Subject.SecureSet 继承 AbstractSet 实现 Serializable

serialVersionUID: 7911754171111800359L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Writes this object out to a stream (i.e., serializes it).

序列数据：
If this is a private credential set, a security check is performed to ensure that the caller has permission to access each credential in the set. If the security check passes, the set is serialized.
抛出：
IOException
序列化字段

elements

LinkedList<E> elements
The elements in this set.

this$0

Subject this$0
The outer Subject instance.
软件包 javax.security.auth.callback

类 javax.security.auth.callback.ChoiceCallback 继承 Object 实现 Serializable

serialVersionUID: -3975664071579892167L

序列化字段

prompt

String prompt
从以下版本开始：
1.4

choices

String[] choices
选项列表
从以下版本开始：
1.4

defaultChoice

int defaultChoice
用作默认选项的选项
从以下版本开始：
1.4

multipleSelectionsAllowed

boolean multipleSelectionsAllowed
选项列表中是否允许进行多重选择
从以下版本开始：
1.4

selections

int[] selections
选中的选项，表示为 choices 列表中的索引。
从以下版本开始：
1.4

类 javax.security.auth.callback.ConfirmationCallback 继承 Object 实现 Serializable

serialVersionUID: -9095656433782481624L

序列化字段

prompt

String prompt
从以下版本开始：
1.4

messageType

int messageType
从以下版本开始：
1.4

optionType

int optionType
从以下版本开始：
1.4

defaultOption

int defaultOption
从以下版本开始：
1.4

options

String[] options
从以下版本开始：
1.4

selection

int selection
从以下版本开始：
1.4

类 javax.security.auth.callback.LanguageCallback 继承 Object 实现 Serializable

serialVersionUID: 2019050433478903213L

序列化字段

locale

Locale locale
从以下版本开始：
1.4

类 javax.security.auth.callback.NameCallback 继承 Object 实现 Serializable

serialVersionUID: 3770938795909392253L

序列化字段

prompt

String prompt
从以下版本开始：
1.4

defaultName

String defaultName
从以下版本开始：
1.4

inputName

String inputName
从以下版本开始：
1.4

类 javax.security.auth.callback.PasswordCallback 继承 Object 实现 Serializable

serialVersionUID: 2267422647454909926L

序列化字段

prompt

String prompt
从以下版本开始：
1.4

echoOn

boolean echoOn
从以下版本开始：
1.4

inputPassword

char[] inputPassword
从以下版本开始：
1.4

类 javax.security.auth.callback.TextInputCallback 继承 Object 实现 Serializable

serialVersionUID: -8064222478852811804L

序列化字段

prompt

String prompt
从以下版本开始：
1.4

defaultText

String defaultText
从以下版本开始：
1.4

inputText

String inputText
从以下版本开始：
1.4

类 javax.security.auth.callback.TextOutputCallback 继承 Object 实现 Serializable

serialVersionUID: 1689502495511663102L

序列化字段

messageType

int messageType
从以下版本开始：
1.4

message

String message
从以下版本开始：
1.4

类 javax.security.auth.callback.UnsupportedCallbackException 继承 Exception 实现 Serializable

serialVersionUID: -6873556327655666839L

序列化字段

callback

Callback callback
软件包 javax.security.auth.kerberos

类 javax.security.auth.kerberos.DelegationPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 883133252142523922L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject 从流中恢复 DelegationPermission 的状态。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
调用 WriteObject 将 DelegationPermission 的状态保存到流中。操作已被序列化，超类负责管理名称。

抛出：
IOException

类 javax.security.auth.kerberos.KerberosKey 继承 Object 实现 Serializable

serialVersionUID: -4625402278148246993L

序列化字段

principal

KerberosPrincipal principal
此秘密密钥所属的主体。

versionNum

int versionNum
此秘密密钥的版本号。

key

javax.security.auth.kerberos.KeyImpl key
通过写出加密密钥的 ASN1 Encoded 字节来序列化 KeyImpl。ASN1 编码在 RFC1510 中得到定义，如下所示：
                        EncryptionKey ::=   SEQUENCE {
                                keytype[0]    INTEGER,
                                keyvalue[1]   OCTET STRING
                                }

类 javax.security.auth.kerberos.KerberosPrincipal 继承 Object 实现 Serializable

serialVersionUID: -7374788026156829911L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
从流读取此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
将 KerberosPrincipal 对象保存到流中。

序列数据：
通过以 DER-encoded 形式（在 RFC1510 的 5.2 小节中指定）写出 PrincipalName 和域来序列化 KerberosPrincipal。
抛出：
IOException

类 javax.security.auth.kerberos.KerberosTicket 继承 Object 实现 Serializable

serialVersionUID: 7395334370157380539L

序列化字段

asn1Encoding

byte[] asn1Encoding
定义在 Kerberos Protocol Specification RFC1510 中的 Ticket ASN.1 DER Encoding。

sessionKey

javax.security.auth.kerberos.KeyImpl sessionKey
通过写出加密密钥的 ASN1 Encoded 字节来序列化 KeyImpl。ASN1 编码在 RFC1510 中定义如下：

                        EncryptionKey ::=   SEQUENCE {
                                keytype[0]    INTEGER,
                                keyvalue[1]   OCTET STRING
                                }

flags

boolean[] flags
Kerberos Protocol Specification RFC1510 中定义了票据标志。

authTime

Date authTime
初始的验证时间。

startTime

Date startTime
经过这段时间后票据开始生效。

endTime

Date endTime
经过这段时间后将不再支持此票据。（其过期时间）。

renewTill

Date renewTill
对于可更新的 Ticket，它指示包含在某一更新中的最长终止时间。可以认为它是票据的绝对过期时间，其中包括所有的更新。对于不可更新的票据，此字段可以为 null。

client

KerberosPrincipal client
拥有服务票据的客户端。

server

KerberosPrincipal server
一项服务，已将票据发送给它。

clientAddresses

InetAddress[] clientAddresses
客户端可以从其所在位置使用票据的地址。如果票据在任何地址都是可用的，则此字段可以为 null。

类 javax.security.auth.kerberos.KeyImpl 继承 Object 实现 Serializable

serialVersionUID: -7889313790214321193L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream ois)
                  throws IOException
序列数据：
this KeyImpl is serialized by writing out the ASN1 Encoded bytes of the encryption key. The ASN1 encoding is defined in RFC1510 and as follows: EncryptionKey ::= SEQUENCE { keytype[0] INTEGER, keyvalue[1] OCTET STRING }
抛出：
IOException

类 javax.security.auth.kerberos.ServicePermission 继承 Permission 实现 Serializable

serialVersionUID: -1227585031618624935L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject 从流中恢复 ServicePermission 的状态。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
调用 WriteObject 将 ServicePermission 的状态保存到流中。操作已被序列化，超类负责管理名称。

抛出：
IOException
序列化字段

actions

String actions
动作字符串。

软件包 javax.security.auth.login

类 javax.security.auth.login.AccountException 继承 LoginException 实现 Serializable

serialVersionUID: -2112878680072211787L

类 javax.security.auth.login.AccountExpiredException 继承 AccountException 实现 Serializable

serialVersionUID: -6064064890162661560L

类 javax.security.auth.login.AccountLockedException 继承 AccountException 实现 Serializable

serialVersionUID: 8280345554014066334L

类 javax.security.auth.login.AccountNotFoundException 继承 AccountException 实现 Serializable

serialVersionUID: 1498349563916294614L

类 javax.security.auth.login.CredentialException 继承 LoginException 实现 Serializable

serialVersionUID: -4772893876810601859L

类 javax.security.auth.login.CredentialExpiredException 继承 CredentialException 实现 Serializable

serialVersionUID: -5344739593859737937L

类 javax.security.auth.login.CredentialNotFoundException 继承 CredentialException 实现 Serializable

serialVersionUID: -7779934467214319475L

类 javax.security.auth.login.FailedLoginException 继承 LoginException 实现 Serializable

serialVersionUID: 802556922354616286L

类 javax.security.auth.login.LoginException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -4679091624035232488L

软件包 javax.security.auth.x500

类 javax.security.auth.x500.X500Principal 继承 Object 实现 Serializable

serialVersionUID: -500463348111345721L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        NotActiveException,
                        ClassNotFoundException
从流读取此对象（即将其反序列化）。

抛出：
IOException
NotActiveException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 X500Principal 对象保存到流中。

序列数据：
此 X500Principal 通过写出它的 DER 编码格式（getEncoded 的值被序列化）来获得序列化。
抛出：
IOException
软件包 javax.security.cert

类 javax.security.cert.CertificateEncodingException 继承 CertificateException 实现 Serializable

类 javax.security.cert.CertificateException 继承 Exception 实现 Serializable

类 javax.security.cert.CertificateExpiredException 继承 CertificateException 实现 Serializable

类 javax.security.cert.CertificateNotYetValidException 继承 CertificateException 实现 Serializable

类 javax.security.cert.CertificateParsingException 继承 CertificateException 实现 Serializable

软件包 javax.security.sasl

类 javax.security.sasl.AuthenticationException 继承 SaslException 实现 Serializable

serialVersionUID: -3579708765071815007L

类 javax.security.sasl.AuthorizeCallback 继承 Object 实现 Serializable

serialVersionUID: -2353344186490470805L

序列化字段

authenticationID

String authenticationID
要检查的（已验证的）验证 id。

authorizationID

String authorizationID
要检查的授权 id。

authorizedID

String authorizedID
已授权实体的 id。如果为 null，则已授权实体的 id 是 authorizationID。

authorized

boolean authorized
一个标志，指示是否允许用验证 id 代表授权 id。

类 javax.security.sasl.RealmCallback 继承 TextInputCallback 实现 Serializable

serialVersionUID: -4342673378785456908L

类 javax.security.sasl.RealmChoiceCallback 继承 ChoiceCallback 实现 Serializable

serialVersionUID: -8588141348846281332L

类 javax.security.sasl.SaslException 继承 IOException 实现 Serializable

serialVersionUID: 4579784287983423626L

序列化字段

_exception

Throwable _exception
根本原因异常，可能为 null。

软件包 javax.sound.midi

类 javax.sound.midi.InvalidMidiDataException 继承 Exception 实现 Serializable

类 javax.sound.midi.MidiUnavailableException 继承 Exception 实现 Serializable

软件包 javax.sound.sampled

类 javax.sound.sampled.AudioPermission 继承 BasicPermission 实现 Serializable

类 javax.sound.sampled.LineUnavailableException 继承 Exception 实现 Serializable

类 javax.sound.sampled.UnsupportedAudioFileException 继承 Exception 实现 Serializable

软件包 javax.sql

类 javax.sql.ConnectionEvent 继承 EventObject 实现 Serializable

serialVersionUID: -4843217645290030002L

序列化字段

ex

SQLException ex
发生错误且入池连接不再可用时驱动程序将向应用程序抛出的 SQLException。

类 javax.sql.RowSetEvent 继承 EventObject 实现 Serializable

serialVersionUID: -1875450876546332005L

类 javax.sql.StatementEvent 继承 EventObject 实现 Serializable

序列化字段

exception

SQLException exception

statement

PreparedStatement statement
软件包 javax.sql.rowset

类 javax.sql.rowset.BaseRowSet 继承 Object 实现 Serializable

serialVersionUID: 4886719666485113312L

序列化字段

binaryStream

InputStream binaryStream
将由方法 getBinaryStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

unicodeStream

InputStream unicodeStream
将由方法 getUnicodeStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

asciiStream

InputStream asciiStream
将由方法 getAsciiStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

charStream

Reader charStream
将由方法 getCharacterStream 返回的 Reader 对象，该方法在 ResultSet 接口中指定。

command

String command
发送到 DBMS 的查询，调用方法 execute 时执行该查询。

URL

String URL
当使用 DriverManager 获得连接时，reader、writer 或二者提供给方法 DriverManager.getConnection 的 JDBC URL。

该 JDBC URL 标识用于建立连接的驱动程序。可在驱动程序供应商提供的文档中找到此 URL。

dataSource

String dataSource
为了从 Java Directory and Naming Interface (JNDI) 命名服务中获取 DataSource 对象，reader/writer 应该使用的数据源逻辑名。

rowSetType

int rowSetType
指示此 JDBC RowSet 对象类型的常量。它必须是以下 ResultSet 常量之一：TYPE_FORWARD_ONLY、TYPE_SCROLL_INSENSITIVE 或 TYPE_SCROLL_SENSITIVE。

showDeleted

boolean showDeleted
指示已删除行在此 JDBC RowSet 对象中是否可见的 boolean 值。

queryTimeout

int queryTimeout
驱动程序等待执行命令的最大秒数。当此 JDBC RowSet 对象连接到其数据源时应用此限制，也就是用数据填充该对象和该对象将数据写回数据源时。

maxRows

int maxRows
reader 应该读取的最大行数。

maxFieldSize

int maxFieldSize
reader 应该读取的最大字段大小。

concurrency

int concurrency
指示此 JDBC RowSet 对象并发性的常量。它必须是以下 ResultSet 常量之一：CONCUR_READ_ONLY 或 CONCUR_UPDATABLE。

readOnly

boolean readOnly
指示此 JDBC RowSet 对象是否为只读的 boolean 值。true 指示它是只读的；false 指示它是可写入的。

escapeProcessing

boolean escapeProcessing
指示此 JDBC RowSet 对象的 reader 是否应该执行转义处理的 boolean 值。true 表示开启转义处理；false 表示关闭。默认值为 true。

isolation

int isolation
指示此 JDBC RowSet 对象连接的隔离级别的常量。它必须是以下 Connection 常量之一：TRANSACTION_NONE、TRANSACTION_READ_UNCOMMITTED、TRANSACTION_READ_COMMITTED、TRANSACTION_REPEATABLE_READ 或 TRANSACTION_SERIALIZABLE。

fetchDir

int fetchDir
用作驱动程序提示的常量，指示要从此 JDBC RowSet 对象获取数据时所用的方向。可能的 ResultSet 常量值如下：FETCH_FORWARD、FETCH_REVERSE、FETCH_UNKNOWN。

目前未使用。

fetchSize

int fetchSize
为驱动程序提供的提示，指示此 JDBC RowSet 对象中的预期行数。

目前未使用。

map

Map<K,V> map
一个 java.util.Map 对象，其中包含的项提供了 SQL 类型名称到 Java 编程语言中类的映射，以用于用户定义类型的自定义映射。

listeners

Vector<E> listeners
一个 Vector 对象，保存已向此 RowSet 对象注册的侦听器所组成的列表。

params

Hashtable<K,V> params
一个 Vector 对象，保存此 RowSet 对象的当前命令的参数集。

类 javax.sql.rowset.RowSetMetaDataImpl 继承 Object 实现 Serializable

serialVersionUID: 6893806403181801867L

序列化字段

colCount

int colCount
创建此 RowSetMetaDataImpl 对象的 RowSet 对象中的列数。

colInfo

javax.sql.rowset.RowSetMetaDataImpl.ColInfo[] colInfo
ColInfo 对象数组，这些对象用于存储关于 RowSet 对象（此 RowSetMetaDataImpl 对象为其创建）中每个列的信息。此数组中的第一个 ColInfo 对象包含关于 RowSet 对象中第一个列的信息，第二个元素包含关于第二列的信息，依此类推。

类 javax.sql.rowset.RowSetWarning 继承 SQLException 实现 Serializable

serialVersionUID: 6678332766434564774L

序列化字段

rwarning

RowSetWarning rwarning
RowSetWarning 对象句柄。

软件包 javax.sql.rowset.serial

类 javax.sql.rowset.serial.SerialArray 继承 Object 实现 Serializable

serialVersionUID: -8466174297270688520L

序列化字段

elements

Object[] elements
序列化数组，每个数组元素都是一个 Java 编程语言中表示 SQL ARRAY 值的 Object。

baseType

int baseType
此 SerialArray 对象中 SQL 类型的元素。该类型表示为 java.sql.Types 类中的一个常量。

baseTypeName

String baseTypeName
DBMS 将该类型名称用于此 SerialArray 对象所表示的 SQL ARRAY 值中的元素。

len

int len
此 SerialArray 对象中的元素数，同时还是此 SerialArray 对象所表示的 SQL ARRAY 值中的元素数。

类 javax.sql.rowset.serial.SerialBlob 继承 Object 实现 Serializable

serialVersionUID: -8144641928112860441L

序列化字段

buf

byte[] buf
表示此 SerialBlob 对象值的序列化未解释字节数组。

blob

Blob blob
Blob 对象的内部表示形式，此 SerialBlob 对象以该对象为基础。

len

long len
此 SerialBlob 对象的字节数组中的字节数。

origLen

long origLen
刚建立时此 SerialBlob 对象的字节数组中的原始字节数。

类 javax.sql.rowset.serial.SerialClob 继承 Object 实现 Serializable

serialVersionUID: -1662519690087375313L

序列化字段

buf

char[] buf
一个序列化字符数组，包含此 SerialClob 对象所表示的 SQL CLOB 值的数据。

clob

Clob clob
使用 Clob 初始化 SerialClob 时内部 Clob 表示形式

len

long len
此 SerialClob 对象内部字符数组的长度（以字符为单位）。

origLen

long origLen
此 SerialClob 对象内部字符数组的原始长度（以字符为单位）。

类 javax.sql.rowset.serial.SerialDatalink 继承 Object 实现 Serializable

serialVersionUID: 2826907821828733626L

序列化字段

url

URL url
提取的 URL 字段，该字段是从 DATALINK 字段获取的。

baseType

int baseType
此 SerialDatalink 对象中 SQL 类型的元素。该类型表示为 java.sql.Types 类中的常量之一。

baseTypeName

String baseTypeName
DBMS 将该类型名称用于此 SerialDatalink 对象所表示的 SQL DATALINK 值中的元素。

类 javax.sql.rowset.serial.SerialException 继承 SQLException 实现 Serializable

serialVersionUID: -489794565168592690L

类 javax.sql.rowset.serial.SerialJavaObject 继承 Object 实现 Serializable

serialVersionUID: -1465795139032831023L

序列化字段

obj

Object obj
要序列化的对象的占位符。

chain

Vector<E> chain
A container for the warnings issued on this SerialJavaObject object. When there are multiple warnings, each warning is chained to the previous warning.

类 javax.sql.rowset.serial.SerialRef 继承 Object 实现 Serializable

serialVersionUID: -4727123500609662274L

序列化字段

baseTypeName

String baseTypeName
包含基本类型名称的字符串。

object

Object object
此类将类型 Ref 存储为 Object。

reference

Ref reference
Ref 引用的私有副本。

类 javax.sql.rowset.serial.SerialStruct 继承 Object 实现 Serializable

serialVersionUID: -8322445504027483372L

序列化字段

SQLTypeName

String SQLTypeName
此 SerialStruct 对象所表示的结构类型的 SQL 类型名称。此为在 SQL 结构类型的 SQL 定义中使用的名称。

attribs

Object[] attribs
Object 实例数组，每个数组元素都是此 SerialStruct 对象所表示的 SQL 结构类型的属性。这些属性按照它们在 SQL 结构类型定义中的顺序排列。

软件包 javax.sql.rowset.spi

类 javax.sql.rowset.spi.SyncFactoryException 继承 SQLException 实现 Serializable

serialVersionUID: -4354595476433200352L

类 javax.sql.rowset.spi.SyncProviderException 继承 SQLException 实现 Serializable

serialVersionUID: -939908523620640692L

序列化字段

syncResolver

SyncResolver syncResolver
调用 getSyncResolver 方法时此 SyncProviderException 对象将返回的 javax.sql.rowset.spi.SyncResolver 实例。

软件包 javax.tools

类 javax.tools.ToolProvider$1 继承 Object 实现 Serializable

软件包 javax.transaction

类 javax.transaction.InvalidTransactionException 继承 RemoteException 实现 Serializable

类 javax.transaction.TransactionRequiredException 继承 RemoteException 实现 Serializable

类 javax.transaction.TransactionRolledbackException 继承 RemoteException 实现 Serializable

软件包 javax.transaction.xa

类 javax.transaction.xa.XAException 继承 Exception 实现 Serializable

序列化字段

errorCode

int errorCode
用其创建 SystemException 的错误代码。

该异常的错误代码
软件包 javax.xml.bind

类 javax.xml.bind.JAXBElement 继承 Object 实现 Serializable

serialVersionUID: 1L

序列化字段

name

QName name
xml 元素标记名称。

declaredType

Class<T> declaredType
xml 元素声明类型的 Java 数据类型绑定。

scope

Class<T> scope
表示此 xml 元素实例的 xml 元素声明的作用域。可以是以下值之一：全局 xml 元素声明的 JAXBElement.GlobalScope。局部元素声明有一个被设置为包含 xml 元素声明的复杂类型定义的 Java 类表示形式的作用域。

value

Object value
xml 元素值。表示 xml 元素实例的内容模式和属性。

nil

boolean nil
如果 xml 元素实例具有 xsi:nil="true" 属性，则 nil 为 true。

类 javax.xml.bind.JAXBException 继承 Exception 实现 Serializable

serialVersionUID: -5621384651494307979L

序列化字段

errorCode

String errorCode
特定于供应商的错误代码。

linkedException

Throwable linkedException
异常引用。

类 javax.xml.bind.MarshalException 继承 JAXBException 实现 Serializable

类 javax.xml.bind.PropertyException 继承 JAXBException 实现 Serializable

类 javax.xml.bind.TypeConstraintException 继承 RuntimeException 实现 Serializable

序列化字段

errorCode

String errorCode
特定于供应商的错误代码。

linkedException

Throwable linkedException
异常引用。

类 javax.xml.bind.UnmarshalException 继承 JAXBException 实现 Serializable

类 javax.xml.bind.ValidationException 继承 JAXBException 实现 Serializable

软件包 javax.xml.crypto

类 javax.xml.crypto.KeySelectorException 继承 Exception 实现 Serializable

serialVersionUID: -7480033639322531109L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable，如果此异常不是由另一个 throwable 引起的，或者导致抛出异常的 throwable 对于此异常是未知的，则 cause 为 null。

类 javax.xml.crypto.MarshalException 继承 Exception 实现 Serializable

serialVersionUID: -863185580332643547L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable；如果此异常不是由另一个 throwable 引起的，或者导致抛出异常的 throwable 对于此异常是未知的，则该值为 null。

类 javax.xml.crypto.NoSuchMechanismException 继承 RuntimeException 实现 Serializable

serialVersionUID: 4189669069570660166L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable；如果此异常不是由另一个 throwable 引起的，或者导致抛出异常的 throwable 对于此异常是未知的，则 cause 为 null。

类 javax.xml.crypto.URIReferenceException 继承 Exception 实现 Serializable

serialVersionUID: 7173469703932561419L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable，如果此异常不是由另一个 throwable 引起的，或者导致抛出异常的 throwable 对于此异常是未知的，则 cause 为 null。

uriReference

URIReference uriReference
软件包 javax.xml.crypto.dsig

类 javax.xml.crypto.dsig.TransformException 继承 Exception 实现 Serializable

serialVersionUID: 5082634801360427800L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable，如果此异常不是由其他 throwable 引起的；如果导致抛出异常的 throwable 对于此异常是未知的，则 cause 为 null。

类 javax.xml.crypto.dsig.XMLSignatureException 继承 Exception 实现 Serializable

serialVersionUID: -3438102491013869995L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable，如果此异常不是由其他 throwable 引起的，或者导致抛出异常的 throwable 对于此异常是未知的，则 cause 为 null。

软件包 javax.xml.datatype

类 javax.xml.datatype.DatatypeConfigurationException 继承 Exception 实现 Serializable

软件包 javax.xml.namespace

类 javax.xml.namespace.QName 继承 Object 实现 Serializable

序列化字段

namespaceURI

String namespaceURI

此 QName 的名称空间 URI。

localPart

String localPart

此 QName 的本地部分。

prefix

String prefix

此 QName 的前缀。

软件包 javax.xml.parsers

类 javax.xml.parsers.FactoryConfigurationError 继承 Error 实现 Serializable

序列化字段

exception

Exception exception
表示该错误的 Exception。

类 javax.xml.parsers.ParserConfigurationException 继承 Exception 实现 Serializable

软件包 javax.xml.soap

类 javax.xml.soap.SOAPException 继承 Exception 实现 Serializable

序列化字段

cause

Throwable cause
软件包 javax.xml.stream

类 javax.xml.stream.FactoryConfigurationError 继承 Error 实现 Serializable

序列化字段

nested

Exception nested

类 javax.xml.stream.XMLStreamException 继承 Exception 实现 Serializable

序列化字段

nested

Throwable nested

location

Location location
软件包 javax.xml.transform

类 javax.xml.transform.TransformerConfigurationException 继承 TransformerException 实现 Serializable

类 javax.xml.transform.TransformerException 继承 Exception 实现 Serializable

序列化字段

locator

SourceLocator locator
Field locator specifies where the error occured

containedException

Throwable containedException
Field containedException specifies a wrapped exception. May be null.

类 javax.xml.transform.TransformerFactoryConfigurationError 继承 Error 实现 Serializable

序列化字段

exception

Exception exception
TransformerFactoryConfigurationError 的 Exception。

软件包 javax.xml.ws

类 javax.xml.ws.ProtocolException 继承 WebServiceException 实现 Serializable

类 javax.xml.ws.WebServiceException 继承 RuntimeException 实现 Serializable

类 javax.xml.ws.WebServicePermission 继承 BasicPermission 实现 Serializable

serialVersionUID: -146474640053770988L

软件包 javax.xml.ws.http

类 javax.xml.ws.http.HTTPException 继承 ProtocolException 实现 Serializable

序列化字段

statusCode

int statusCode
软件包 javax.xml.ws.soap

类 javax.xml.ws.soap.SOAPFaultException 继承 ProtocolException 实现 Serializable

序列化字段

fault

SOAPFault fault
软件包 javax.xml.xpath

类 javax.xml.xpath.XPathException 继承 Exception 实现 Serializable

serialVersionUID: -1837080260374986980L

序列化字段

cause

Throwable cause

类 javax.xml.xpath.XPathExpressionException 继承 XPathException 实现 Serializable

serialVersionUID: -1837080260374986980L

类 javax.xml.xpath.XPathFactoryConfigurationException 继承 XPathException 实现 Serializable

serialVersionUID: -1837080260374986980L

类 javax.xml.xpath.XPathFunctionException 继承 XPathExpressionException 实现 Serializable

serialVersionUID: -1837080260374986980L

软件包 org.ietf.jgss

类 org.ietf.jgss.GSSException 继承 Exception 实现 Serializable

serialVersionUID: -2706218945227726672L

序列化字段

major

int major
此异常的主要代码。

minor

int minor
此异常的次要代码。

minorMessage

String minorMessage
次要代码的文本字符串

majorString

String majorString
主要代码的替换文本字符串

软件包 org.omg.CosNaming

类 org.omg.CosNaming._BindingIteratorImplBase 继承 DynamicImplementation 实现 Serializable

类 org.omg.CosNaming._BindingIteratorStub 继承 ObjectImpl 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException
抛出：
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException

类 org.omg.CosNaming._NamingContextExtStub 继承 ObjectImpl 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException
抛出：
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException

类 org.omg.CosNaming._NamingContextImplBase 继承 DynamicImplementation 实现 Serializable

类 org.omg.CosNaming._NamingContextStub 继承 ObjectImpl 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException
抛出：
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException

类 org.omg.CosNaming.Binding 继承 Object 实现 Serializable

序列化字段

binding_name

NameComponent[] binding_name

binding_type

BindingType binding_type

类 org.omg.CosNaming.BindingType 继承 Object 实现 Serializable

序列化字段

__value

int __value

类 org.omg.CosNaming.NameComponent 继承 Object 实现 Serializable

序列化字段

id

String id

kind

String kind
软件包 org.w3c.dom

类 org.w3c.dom.DOMException 继承 RuntimeException 实现 Serializable

serialVersionUID: 6627732366795969916L

序列化字段

code

short code
软件包 org.w3c.dom.events

类 org.w3c.dom.events.EventException 继承 RuntimeException 实现 Serializable

序列化字段

code

short code
软件包 org.w3c.dom.ls

类 org.w3c.dom.ls.LSException 继承 RuntimeException 实现 Serializable

序列化字段

code

short code
软件包 org.xml.sax

类 org.xml.sax.SAXException 继承 Exception 实现 Serializable

serialVersionUID: 583241635256073760L

序列化字段

exception

Exception exception
使用隧道时的嵌入异常，否则为 null。

类 org.xml.sax.SAXNotRecognizedException 继承 SAXException 实现 Serializable

serialVersionUID: 5440506620509557213L

类 org.xml.sax.SAXNotSupportedException 继承 SAXException 实现 Serializable

serialVersionUID: -1422818934641823846L

类 org.xml.sax.SAXParseException 继承 SAXException 实现 Serializable

serialVersionUID: -5651165872476709336L

序列化字段

publicId

String publicId
公共标识符或 null。
另请参见：
SAXParseException.getPublicId()

systemId

String systemId
系统标识符或 null。
另请参见：
SAXParseException.getSystemId()

lineNumber

int lineNumber
行号或 -1。
另请参见：
SAXParseException.getLineNumber()

columnNumber

int columnNumber
列号或 -1。
另请参见：
SAXParseException.getColumnNumber()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


A - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

A

a - 类 java.awt.AWTEventMulticaster 中的变量
A - 类 java.awt.PageAttributes.MediaType 中的静态变量
Engineering A (8 1/2 x 11 in) 的 MediaType 实例。
A - 类 javax.print.attribute.standard.MediaSize.Engineering 中的静态变量
指定 engineering A 尺寸，8.5 inch × 11 inch。
A - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A 尺寸。
A - 类 javax.swing.text.html.HTML.Tag 中的静态变量
A0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A0 的别名。
A0 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A0 尺寸，841 mm × 1189 mm。
A1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A1 的别名。
A1 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A1 尺寸，594 mm × 841 mm。
A10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A10 的别名。
A10 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A10 尺寸，26 mm × 37 mm。
A2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A2 的别名。
A2 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A2 尺寸，420 mm × 594 mm。
A3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A3 的别名。
A3 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A3 尺寸，297 mm × 420 mm。
A4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A4 的别名。
A4 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A4 尺寸，210 × by 297 mm。
A5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A5 的别名。
A5 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A5 尺寸，148 mm × 210 mm。
A6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A6 的别名。
A6 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A6 尺寸，105 mm × 148 mm。
A7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A7 的别名。
A7 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A7 尺寸，74 mm × 105 mm。
A8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A8 的别名。
A8 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A8 尺寸，52 mm × 74 mm。
A9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A9 的别名。
A9 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A9 尺寸，37 mm × 52 mm。
ABORT - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示被异步跟踪的图像在生成完成前即已中止。
abort() - 类 java.net.CacheRequest 中的方法
中止缓存响应的尝试。
abort() - 类 javax.imageio.ImageReader 中的方法
请求中止当前所有读取操作。
abort() - 类 javax.imageio.ImageWriter 中的方法
请求中止任何当前写入操作。
abort() - 接口 javax.security.auth.spi.LoginModule 中的方法
中止验证过程的方法（阶段 2）。
abort() - 接口 org.w3c.dom.ls.LSParser 中的方法
中断对当前由 LSParser 加载的文档的加载。
ABORTED - 类 java.awt.MediaTracker 中的静态变量
指示媒体下载已中止的标志。
ABORTED - 类 javax.print.attribute.standard.JobState 中的静态变量
作业已被系统中止（通常当作业处于 PROCESSING 或 PROCESSING_STOPPED 状态时），打印机已完成正在中止的作业，且所有作业状态属性已达到作业的最终值。
ABORTED_BY_SYSTEM - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
系统中止了作业。
abortGrabbing() - 类 java.awt.image.PixelGrabber 中的方法
请求 PixelGrabber 中止获取图像。
abortRequested() - 类 javax.imageio.ImageReader 中的方法
如果从实例化 reader 或调用 clearAbortRequest 时起，已经请求了中止当前读取操作，则返回 true。
abortRequested() - 类 javax.imageio.ImageWriter 中的方法
如果自从 writer 被实例化或 clearAbortRequest 被调用开始，已经发出中止当前写入操作的请求，则返回 true。
ABOUT_UIROLE - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个充当提供 "About" 信息角色的 UI。
ABOVE_BASELINE - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
ABOVE_BASELINE_LEADING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
ABOVE_BASELINE_TRAILING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
ABOVE_BOTTOM - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框底端线的顶部。
ABOVE_TOP - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框顶端线的上部。
abs(int) - 类 java.lang.Math 中的静态方法
返回 int 值的绝对值。
abs(long) - 类 java.lang.Math 中的静态方法
返回 long 值的绝对值。
abs(float) - 类 java.lang.Math 中的静态方法
返回 float 值的绝对值。
abs(double) - 类 java.lang.Math 中的静态方法
返回 double 值的绝对值。
abs(int) - 类 java.lang.StrictMath 中的静态方法
返回 int 值的绝对值。
abs(long) - 类 java.lang.StrictMath 中的静态方法
返回 long 值的绝对值。
abs(float) - 类 java.lang.StrictMath 中的静态方法
返回 float 值的绝对值。
abs(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的绝对值。
abs() - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其值为此 BigDecimal 的绝对值，其标度为 this.scale()。
abs(MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为此 BigDecimal 绝对值的 BigDecimal（根据上下文设置进行舍入）。
abs() - 类 java.math.BigInteger 中的方法
返回其值是此 BigInteger 的绝对值的 BigInteger。
absolute(int) - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的给定行编号。
absolutePath() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.absolutePath() 中的规范实现 absolutePath 方法。
absolutePath() - 类 java.util.prefs.Preferences 中的方法
返回此首选项节点的绝对路径名。
ABSTRACT - 类 java.lang.reflect.Modifier 中的静态变量
表示 abstract 修饰符的 int 的值。
AbstractAction - javax.swing 中的 类
此类提供 JFC Action 接口的默认实现。
AbstractAction() - 类 javax.swing.AbstractAction 的构造方法
用默认描述字符串和默认图标定义一个 Action 对象。
AbstractAction(String) - 类 javax.swing.AbstractAction 的构造方法
用指定描述字符串和默认图标定义一个 Action 对象。
AbstractAction(String, Icon) - 类 javax.swing.AbstractAction 的构造方法
用指定描述字符串和指定图标定义一个 Action 对象。
AbstractAnnotationValueVisitor6<R,P> - javax.lang.model.util 中的 类
注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
AbstractAnnotationValueVisitor6() - 类 javax.lang.model.util.AbstractAnnotationValueVisitor6 的构造方法
要调用的具体子类的构造方法。
AbstractBorder - javax.swing.border 中的 类
实现无大小限制的空边框类。
AbstractBorder() - 类 javax.swing.border.AbstractBorder 的构造方法
AbstractButton - javax.swing 中的 类
定义按钮和菜单项的一般行为。
AbstractButton() - 类 javax.swing.AbstractButton 的构造方法
AbstractButton.AccessibleAbstractButton - javax.swing 中的 类
此类实现对 AbstractButton 类的可访问性支持。
AbstractButton.AccessibleAbstractButton() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 的构造方法
AbstractButton.ButtonChangeListener - javax.swing 中的 类
将 ChangeListener 扩展为可序列化的。
AbstractCellEditor - javax.swing 中的 类
AbstractCellEditor() - 类 javax.swing.AbstractCellEditor 的构造方法
AbstractCollection<E> - java.util 中的 类
此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
AbstractCollection() - 类 java.util.AbstractCollection 的构造方法
唯一的构造方法。
AbstractColorChooserPanel - javax.swing.colorchooser 中的 类
这是用于颜色选取器的抽象超类。
AbstractColorChooserPanel() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 的构造方法
AbstractDocument - javax.swing.text 中的 类
文档接口的实现，可作为实现各种文档的基础。
AbstractDocument(AbstractDocument.Content) - 类 javax.swing.text.AbstractDocument 的构造方法
构造具有某种指定内容存储机制的新 AbstractDocument。
AbstractDocument(AbstractDocument.Content, AbstractDocument.AttributeContext) - 类 javax.swing.text.AbstractDocument 的构造方法
构造具有某种指定内容存储机制的新 AbstractDocument。
AbstractDocument.AbstractElement - javax.swing.text 中的 类
实现元素的抽象部分。
AbstractDocument.AbstractElement(Element, AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 的构造方法
创建新的 AbstractElement。
AbstractDocument.AttributeContext - javax.swing.text 中的 接口
一个接口，它用于允许 MutableAttributeSet 的实现使用可插入属性压缩技术。
AbstractDocument.BranchElement - javax.swing.text 中的 类
实现一个包含其他元素的复合元素。
AbstractDocument.BranchElement(Element, AttributeSet) - 类 javax.swing.text.AbstractDocument.BranchElement 的构造方法
构造最初不包含任何子元素的复合元素。
AbstractDocument.Content - javax.swing.text 中的 接口
描述可编辑的字符序列内容的接口。
AbstractDocument.DefaultDocumentEvent - javax.swing.text 中的 类
存储修改文档时发生的文档更改。
AbstractDocument.DefaultDocumentEvent(int, int, DocumentEvent.EventType) - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 的构造方法
构造更改记录。
AbstractDocument.ElementEdit - javax.swing.text 中的 类
一个 ElementChange 实现，可将其添加到文档事件中。
AbstractDocument.ElementEdit(Element, int, Element[], Element[]) - 类 javax.swing.text.AbstractDocument.ElementEdit 的构造方法
构造一个编辑记录。
AbstractDocument.LeafElement - javax.swing.text 中的 类
实现可直接表示某类内容的元素。
AbstractDocument.LeafElement(Element, AttributeSet, int, int) - 类 javax.swing.text.AbstractDocument.LeafElement 的构造方法
构造一个表示文档中内容的元素（没有子元素）。
AbstractElementVisitor6<R,P> - javax.lang.model.util 中的 类
程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
AbstractElementVisitor6() - 类 javax.lang.model.util.AbstractElementVisitor6 的构造方法
要调用的具体子类的构造方法。
AbstractExecutorService - java.util.concurrent 中的 类
提供 ExecutorService 执行方法的默认实现。
AbstractExecutorService() - 类 java.util.concurrent.AbstractExecutorService 的构造方法
AbstractInterruptibleChannel - java.nio.channels.spi 中的 类
可中断通道的基本实现类。
AbstractInterruptibleChannel() - 类 java.nio.channels.spi.AbstractInterruptibleChannel 的构造方法
初始化此类的一个新实例。
AbstractLayoutCache - javax.swing.tree 中的 类
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
AbstractLayoutCache() - 类 javax.swing.tree.AbstractLayoutCache 的构造方法
AbstractLayoutCache.NodeDimensions - javax.swing.tree 中的 类
由 AbstractLayoutCache 使用，用于确定特定节点的大小和 x 原点。
AbstractLayoutCache.NodeDimensions() - 类 javax.swing.tree.AbstractLayoutCache.NodeDimensions 的构造方法
AbstractList<E> - java.util 中的 类
此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
AbstractList() - 类 java.util.AbstractList 的构造方法
唯一的构造方法。
AbstractListModel - javax.swing 中的 类
该数据模型的抽象定义提供一个带内容的 List。
AbstractListModel() - 类 javax.swing.AbstractListModel 的构造方法
AbstractMap<K,V> - java.util 中的 类
此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。
AbstractMap() - 类 java.util.AbstractMap 的构造方法
唯一的构造方法。
AbstractMap.SimpleEntry<K,V> - java.util 中的 类
维护键和值的 Entry。
AbstractMap.SimpleEntry(K, V) - 类 java.util.AbstractMap.SimpleEntry 的构造方法
创建一个项，它表示从指定键到指定值的映射关系。
AbstractMap.SimpleEntry(Map.Entry<? extends K, ? extends V>) - 类 java.util.AbstractMap.SimpleEntry 的构造方法
创建一个项，它表示的映射关系与指定的项相同。
AbstractMap.SimpleImmutableEntry<K,V> - java.util 中的 类
维护不可变的键和值的 Entry。
AbstractMap.SimpleImmutableEntry(K, V) - 类 java.util.AbstractMap.SimpleImmutableEntry 的构造方法
创建一个项，它表示从指定键到指定值的映射关系。
AbstractMap.SimpleImmutableEntry(Map.Entry<? extends K, ? extends V>) - 类 java.util.AbstractMap.SimpleImmutableEntry 的构造方法
创建一个项，它表示的映射关系与指定项相同。
AbstractMarshallerImpl - javax.xml.bind.helpers 中的 类
部分默认 Marshaller 实现。
AbstractMarshallerImpl() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 的构造方法
AbstractMethodError - java.lang 中的 错误
当应用程序试图调用一个抽象方法时，抛出此错误。
AbstractMethodError() - 错误 java.lang.AbstractMethodError 的构造方法
构造不带详细消息的 AbstractMethodError。
AbstractMethodError(String) - 错误 java.lang.AbstractMethodError 的构造方法
构造带指定详细消息的 AbstractMethodError。
AbstractOwnableSynchronizer - java.util.concurrent.locks 中的 类
可以由线程以独占方式拥有的同步器。
AbstractOwnableSynchronizer() - 类 java.util.concurrent.locks.AbstractOwnableSynchronizer 的构造方法
供子类使用的空构造方法。
AbstractPreferences - java.util.prefs 中的 类
此类提供了 Preferences 类的骨干实现，从而大大简化了实现此类的任务。
AbstractPreferences(AbstractPreferences, String) - 类 java.util.prefs.AbstractPreferences 的构造方法
用指定的父节点和与其父节点相关的指定名称创建首选项节点。
AbstractProcessor - javax.annotation.processing 中的 类
旨在用作最具体注释 processor 的便捷超类的抽象注释 processor。
AbstractProcessor() - 类 javax.annotation.processing.AbstractProcessor 的构造方法
子类要调用的构造方法。
AbstractQueue<E> - java.util 中的 类
此类提供某些 Queue 操作的骨干实现。
AbstractQueue() - 类 java.util.AbstractQueue 的构造方法
子类使用的构造方法。
AbstractQueuedLongSynchronizer - java.util.concurrent.locks 中的 类
以 long 形式维护同步状态的一个 AbstractQueuedSynchronizer 版本。
AbstractQueuedLongSynchronizer() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 的构造方法
创建一个初始同步状态为 0 的新 AbstractQueuedLongSynchronizer 实例。
AbstractQueuedLongSynchronizer.ConditionObject - java.util.concurrent.locks 中的 类
作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。
AbstractQueuedLongSynchronizer.ConditionObject() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 的构造方法
创建一个新的 ConditionObject 实例。
AbstractQueuedSynchronizer - java.util.concurrent.locks 中的 类
为实现依赖于先进先出 (FIFO) 等待队列的阻塞锁和相关同步器（信号量、事件，等等）提供一个框架。
AbstractQueuedSynchronizer() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 的构造方法
创建具有初始同步状态 0 的新 AbstractQueuedSynchronizer 实例。
AbstractQueuedSynchronizer.ConditionObject - java.util.concurrent.locks 中的 类
AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。
AbstractQueuedSynchronizer.ConditionObject() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 的构造方法
创建一个新的 ConditionObject 实例。
AbstractScriptEngine - javax.script 中的 类
为几个 eval 方法的变体提供标准实现。
AbstractScriptEngine() - 类 javax.script.AbstractScriptEngine 的构造方法
创建一个新的 AbstractScriptEngine 实例，使用 SimpleScriptContext 作为其默认 ScriptContext。
AbstractScriptEngine(Bindings) - 类 javax.script.AbstractScriptEngine 的构造方法
创建一个新实例，使用指定 Bindings 作为受保护 context 字段中的 ENGINE_SCOPE Bindings。
AbstractSelectableChannel - java.nio.channels.spi 中的 类
可选择通道的基本实现类。
AbstractSelectableChannel(SelectorProvider) - 类 java.nio.channels.spi.AbstractSelectableChannel 的构造方法
初始化此类的一个新实例。
AbstractSelectionKey - java.nio.channels.spi 中的 类
选择键的基本实现类。
AbstractSelectionKey() - 类 java.nio.channels.spi.AbstractSelectionKey 的构造方法
初始化此类的一个新实例。
AbstractSelector - java.nio.channels.spi 中的 类
选择器的基本实现类。
AbstractSelector(SelectorProvider) - 类 java.nio.channels.spi.AbstractSelector 的构造方法
初始化此类的一个新实例。
AbstractSequentialList<E> - java.util 中的 类
此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
AbstractSequentialList() - 类 java.util.AbstractSequentialList 的构造方法
单独的构造方法。
AbstractSet<E> - java.util 中的 类
此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
AbstractSet() - 类 java.util.AbstractSet 的构造方法
单独的构造方法。
AbstractSpinnerModel - javax.swing 中的 类
此类提供 SpinnerModel 接口的 ChangeListener 部分，该接口应该适用于最具体的 SpinnerModel 实现。
AbstractSpinnerModel() - 类 javax.swing.AbstractSpinnerModel 的构造方法
AbstractTableModel - javax.swing.table 中的 类
此抽象类为 TableModel 接口中的大多数方法提供默认实现。
AbstractTableModel() - 类 javax.swing.table.AbstractTableModel 的构造方法
AbstractTypeVisitor6<R,P> - javax.lang.model.util 中的 类
类型的骨干 visitor，具有适用于第 6 版语言级别的默认行为。
AbstractTypeVisitor6() - 类 javax.lang.model.util.AbstractTypeVisitor6 的构造方法
要调用的具体子类的构造方法。
AbstractUndoableEdit - javax.swing.undo 中的 类
UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。
AbstractUndoableEdit() - 类 javax.swing.undo.AbstractUndoableEdit 的构造方法
创建一个 AbstractUndoableEdit，其将 hasBeenDone 和 alive 默认为 true。
AbstractUnmarshallerImpl - javax.xml.bind.helpers 中的 类
部分默认 Unmarshaller 实现。
AbstractUnmarshallerImpl() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 的构造方法
AbstractWriter - javax.swing.text 中的 类
AbstractWriter 是一个抽象类，它实际执行元素树（包括属性）的写出工作。
AbstractWriter(Writer, Document) - 类 javax.swing.text.AbstractWriter 的构造方法
创建新的 AbstractWriter。
AbstractWriter(Writer, Document, int, int) - 类 javax.swing.text.AbstractWriter 的构造方法
创建新的 AbstractWriter。
AbstractWriter(Writer, Element) - 类 javax.swing.text.AbstractWriter 的构造方法
创建新的 AbstractWriter。
AbstractWriter(Writer, Element, int, int) - 类 javax.swing.text.AbstractWriter 的构造方法
创建新的 AbstractWriter。
accelerationPriority - 类 java.awt.Image 中的变量
用于加速此图像的优先级。
ACCELERATOR_KEY - 接口 javax.swing.Action 中的静态变量
用来存储将用作动作加速器的 KeyStroke 的键。
acceleratorFont - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
acceleratorForeground - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
acceleratorSelectionForeground - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
accept(Component) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
确定是否可以接受选择某个 Component 作为新的焦点拥有者。
accept(Component) - 类 java.awt.DefaultFocusTraversalPolicy 中的方法
确定是否可以接受选择某个 Component 作为新的焦点所有者。
accept(File) - 接口 java.io.FileFilter 中的方法
测试指定抽象路径名是否应该包含在某个路径名列表中。
accept(File, String) - 接口 java.io.FilenameFilter 中的方法
测试指定文件是否应该包含在某一文件列表中。
accept() - 类 java.net.ServerSocket 中的方法
侦听并接受到此套接字的连接。
accept(SocketImpl) - 类 java.net.SocketImpl 中的方法
接受连接。
accept() - 类 java.nio.channels.ServerSocketChannel 中的方法
接受到此通道套接字的连接。
accept(AnnotationValueVisitor<R, P>, P) - 接口 javax.lang.model.element.AnnotationValue 中的方法
将一个 visitor 应用到此值。
accept(ElementVisitor<R, P>, P) - 接口 javax.lang.model.element.Element 中的方法
将一个 visitor 应用到此元素。
accept(TypeVisitor<R, P>, P) - 接口 javax.lang.model.type.TypeMirror 中的方法
将一个 visitor 应用于此类型。
accept(File) - 类 javax.swing.filechooser.FileFilter 中的方法
此过滤器是否接受给定的文件。
accept(File) - 类 javax.swing.filechooser.FileNameExtensionFilter 中的方法
测试指定的文件，如果该文件被接受，则返回 true，否则返回 false。
accept(File) - 类 javax.swing.JFileChooser 中的方法
如果应该显示该文件，则返回 true。
accept(Component) - 类 javax.swing.LayoutFocusTraversalPolicy 中的方法
确定是否可以接受选择指定的 Component 作为新的焦点所有者。
accept(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter 中的方法
accept(Component) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
确定是否可以接受选择某个 Component 作为新的焦点拥有者。
accept(XMLEvent) - 接口 javax.xml.stream.EventFilter 中的方法
测试此事件是否为此流的一部分。
accept(XMLStreamReader) - 接口 javax.xml.stream.StreamFilter 中的方法
测试当前状态是否为此流的一部分。
ACCEPT_ALL - 接口 java.net.CookiePolicy 中的静态变量
一种预定义策略，表示接受所有 cookie。
ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识是否使用 AcceptAllFileFilter。
ACCEPT_NONE - 接口 java.net.CookiePolicy 中的静态变量
一种预定义策略，表示不接受任何 cookie。
ACCEPT_ONLY - 接口 org.ietf.jgss.GSSCredential 中的静态变量
凭据使用标志，要求凭据仅可用于上下文接受。
ACCEPT_ORIGINAL_SERVER - 接口 java.net.CookiePolicy 中的静态变量
一种预定义策略，表示只接受来自原始服务器的 cookie。
acceptChanges() - 接口 javax.sql.rowset.CachedRowSet 中的方法
将对此 CachedRowSet 对象所做的行更新、插入以及删除更改传播到底层数据源。
acceptChanges(Connection) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将所有行更新、插入以及删除更改传播到支持此 CachedRowSet 对象的数据源，使用指定的 Connection 对象建立到数据源的连接。
acceptDrag(int) - 类 java.awt.dnd.DropTargetContext 中的方法
接受该 Drag。
acceptDrag(int) - 类 java.awt.dnd.DropTargetDragEvent 中的方法
接受 drag。
acceptDrop(int) - 类 java.awt.dnd.DropTargetContext 中的方法
调用以指示放置操作是可接受的（使用指定的操作）。
acceptDrop(int) - 类 java.awt.dnd.DropTargetDropEvent 中的方法
使用指定的操作接受 drop。
ACCEPTING_JOBS - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的静态变量
打印机当前接受作业。
acceptNode(Node) - 接口 org.w3c.dom.ls.LSParserFilter 中的方法
此方法将由解析器在完成对每个节点的解析后调用。
acceptSecContext(byte[], int, int) - 接口 org.ietf.jgss.GSSContext 中的方法
由上下文接受端在收到同位体的标记后调用。
acceptSecContext(InputStream, OutputStream) - 接口 org.ietf.jgss.GSSContext 中的方法
由上下文接受端调用，以处理来自使用流的同位体的标记。
acceptsURL(String) - 接口 java.sql.Driver 中的方法
查询驱动程序是否认为它可以打开到给定 URL 的连接。
access - 类 org.omg.CORBA.ValueMember 中的变量
此 ValueMember 对象所描述的 value 成员的访问类型（公共或私有）。
AccessControlContext - java.security 中的 类
AccessControlContext 用于基于它所封装的上下文作出系统资源访问决定。
AccessControlContext(ProtectionDomain[]) - 类 java.security.AccessControlContext 的构造方法
创建带有给定 ProtectionDomain 集合的 AccessControlContext。
AccessControlContext(AccessControlContext, DomainCombiner) - 类 java.security.AccessControlContext 的构造方法
创建具有给定 AccessControlContext 和 DomainCombiner 的新 AccessControlContext。
AccessControlException - java.security 中的 异常
此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
AccessControlException(String) - 异常 java.security.AccessControlException 的构造方法
构造带指定详细消息的 AccessControlException。
AccessControlException(String, Permission) - 异常 java.security.AccessControlException 的构造方法
构造带指定详细消息和导致异常的请求权限的 AccessControlException。
AccessController - java.security 中的 类
AccessController 类用于与访问控制相关的操作和决定。
AccessException - java.rmi 中的 异常
AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
AccessException(String) - 异常 java.rmi.AccessException 的构造方法
构造带指定详细消息的 AccessException。
AccessException(String, Exception) - 异常 java.rmi.AccessException 的构造方法
构造带指定详细消息和嵌入异常的 AccessException。
Accessible - javax.accessibility 中的 接口
Accessible 接口是可访问性包的主接口。
ACCESSIBLE_ACTION_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示支持的动作集已更改的常量。
ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定组件的活动子级已更改的常量。
ACCESSIBLE_CARET_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleText 插入符已更改的常量。
ACCESSIBLE_CHILD_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定何时向对象添加或从对象移除 Accessible 子级的常量。
ACCESSIBLE_COMPONENT_BOUNDS_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
指示组件边界已更改的 PropertyChangeEvent。
ACCESSIBLE_DESCRIPTION_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleDescription 属性已更改的常量。
ACCESSIBLE_HYPERTEXT_OFFSET - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示超文本元素已收到焦点的常量。
ACCESSIBLE_INVALIDATE_CHILDREN - 类 javax.accessibility.AccessibleContext 中的静态变量
指示某个组件（例如树或文本）的子级已发生重要更改的 PropertyChangeEvent。
ACCESSIBLE_NAME_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleName 属性已更改的常量。
ACCESSIBLE_SELECTION_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleSelection 已更改的常量。
ACCESSIBLE_STATE_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleStateSet 属性已更改的常量。
ACCESSIBLE_TABLE_CAPTION_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示表标题已更改的常量。
ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示列描述已更改的常量。
ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示列标题已更改的常量。
ACCESSIBLE_TABLE_MODEL_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示表数据已更改的常量。
ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示行描述已更改的常量。
ACCESSIBLE_TABLE_ROW_HEADER_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示行标题已更改的常量。
ACCESSIBLE_TABLE_SUMMARY_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示表摘要已更改的常量。
ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
指示文本属性已更改的 PropertyChangeEvent。
ACCESSIBLE_TEXT_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
指示文本已更改的 PropertyChangeEvent。
ACCESSIBLE_VALUE_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleValue 属性已更改的常量。
ACCESSIBLE_VISIBLE_DATA_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定对象的可见外观已更改的常量。
AccessibleAction - javax.accessibility 中的 接口
任何能够执行一个或多个动作的对象都应该支持 AccessibleAction 接口。
AccessibleAttributeSequence - javax.accessibility 中的 类
此类汇集共享相同连续属性集的文本的跨度，以及该属性集。
AccessibleAttributeSequence(int, int, AttributeSet) - 类 javax.accessibility.AccessibleAttributeSequence 的构造方法
构造带有给定参数的 AccessibleAttributeSequence。
accessibleAWTComponentHandler - 类 java.awt.Component.AccessibleAWTComponent 中的变量
accessibleAWTFocusHandler - 类 java.awt.Component.AccessibleAWTComponent 中的变量
AccessibleBundle - javax.accessibility 中的 类
用于维护强类型枚举的基类。
AccessibleBundle() - 类 javax.accessibility.AccessibleBundle 的构造方法
AccessibleComponent - javax.accessibility 中的 接口
屏幕上呈现的任何对象都应该支持 AccessibleComponent 接口。
accessibleContainerHandler - 类 java.awt.Container.AccessibleAWTContainer 中的变量
accessibleContainerHandler - 类 javax.swing.JComponent.AccessibleJComponent 中的变量
AccessibleContext - javax.accessibility 中的 类
AccessibleContext 表示所有可访问对象返回的最少信息。
AccessibleContext() - 类 javax.accessibility.AccessibleContext 的构造方法
accessibleContext - 类 javax.swing.CellRendererPane 中的变量
accessibleContext - 类 javax.swing.JApplet 中的变量
accessibleContext - 类 javax.swing.JColorChooser 中的变量
accessibleContext - 类 javax.swing.JComponent 中的变量
与此 JComponent 关联的 AccessibleContext。
accessibleContext - 类 javax.swing.JDialog 中的变量
accessibleContext - 类 javax.swing.JFileChooser 中的变量
accessibleContext - 类 javax.swing.JFrame 中的变量
可访问的上下文属性。
accessibleContext - 类 javax.swing.JWindow 中的变量
可访问的上下文属性。
accessibleContext - 类 javax.swing.ProgressMonitor 中的变量
ProgressMonitor 的 AccessibleContext
accessibleDescription - 类 javax.accessibility.AccessibleContext 中的变量
包含对象描述的本地化 String。
AccessibleEditableText - javax.accessibility 中的 接口
在显示器上显示可编辑文本信息的所有类都应该实现 AccessibleEditableText 接口。
AccessibleExtendedComponent - javax.accessibility 中的 接口
屏幕上呈现的任何对象都应该支持 AccessibleExtendedComponent 接口。
AccessibleExtendedTable - javax.accessibility 中的 接口
AccessibleExtendedTable 类提供了有关以二维表的格式呈现数据的用户界面组件的扩展信息。
AccessibleExtendedText - javax.accessibility 中的 接口
AccessibleExtendedText 接口包含 AccessibleText 接口所未提供的其他方法 应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 AccessibleContext.getAccessibleText() 方法，能够确定该对象是否支持 AccessibleExtendedText 接口。
accessibleFocusHandler - 类 javax.swing.JComponent.AccessibleJComponent 中的变量
AccessibleHyperlink - javax.accessibility 中的 类
Hypertext 文档中的某个链接或一组链接（例如客户端 imagemap）的封装。
AccessibleHyperlink() - 类 javax.accessibility.AccessibleHyperlink 的构造方法
AccessibleHypertext - javax.accessibility 中的 接口
AccessibleHypertext 类是在显示器上显示超文本信息的所有类的基类。
AccessibleIcon - javax.accessibility 中的 接口
任何具有关联图标（例如按钮）的对象都应支持 AccessibleIcon 接口。
AccessibleKeyBinding - javax.accessibility 中的 接口
任何具有键盘绑定（例如可用于选择对象的键盘助记符和/或键盘快捷键）功能的对象都应支持 AccessibleKeyBinding 接口。
accessibleName - 类 javax.accessibility.AccessibleContext 中的变量
包含对象名称的本地化 String。
AccessibleObject - java.lang.reflect 中的 类
AccessibleObject 类是 Field、Method 和 Constructor 对象的基类。
AccessibleObject() - 类 java.lang.reflect.AccessibleObject 的构造方法
构造方法：仅供 Java 虚拟机使用。
accessibleParent - 类 javax.accessibility.AccessibleContext 中的变量
此对象的可访问父级。
AccessibleRelation - javax.accessibility 中的 类
AccessibleRelation 类描述了实现 AccessibleRelation 的对象与一个或多个其他对象之间的关系。
AccessibleRelation(String) - 类 javax.accessibility.AccessibleRelation 的构造方法
使用给定的与语言环境无关的键创建新的 AccessibleRelation。
AccessibleRelation(String, Object) - 类 javax.accessibility.AccessibleRelation 的构造方法
使用给定的与语言环境无关的键创建新的 AccessibleRelation。
AccessibleRelation(String, Object[]) - 类 javax.accessibility.AccessibleRelation 的构造方法
使用给定的与语言环境无关的键创建新的 AccessibleRelation。
AccessibleRelationSet - javax.accessibility 中的 类
AccessibleRelationSet 类确定了组件的关系集。
AccessibleRelationSet() - 类 javax.accessibility.AccessibleRelationSet 的构造方法
创建新的空关系集。
AccessibleRelationSet(AccessibleRelation[]) - 类 javax.accessibility.AccessibleRelationSet 的构造方法
创建具有传入的关系数组中所包含的初始关系集的新关系。
AccessibleResourceBundle - javax.accessibility 中的 类
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。
AccessibleResourceBundle() - 类 javax.accessibility.AccessibleResourceBundle 的构造方法
已过时。
AccessibleRole - javax.accessibility 中的 类
AccessibleRole 类确定组件的职责。
AccessibleRole(String) - 类 javax.accessibility.AccessibleRole 的构造方法
使用与语言环境无关的给定键创建新的 AccessibleRole。
AccessibleSelection - javax.accessibility 中的 接口
此 AccessibleSelection 接口提供了辅助技术的标准机制，以确定当前选定了哪些子级，以及修改选项集合。
AccessibleState - javax.accessibility 中的 类
AccessibleState 类描述了组件的特殊状态。
AccessibleState(String) - 类 javax.accessibility.AccessibleState 的构造方法
使用给定的与语言环境无关的键创建新的 AccessibleState。
AccessibleStateSet - javax.accessibility 中的 类
AccessibleStateSet 类确定组件的状态集。
AccessibleStateSet() - 类 javax.accessibility.AccessibleStateSet 的构造方法
创建新的空状态集。
AccessibleStateSet(AccessibleState[]) - 类 javax.accessibility.AccessibleStateSet 的构造方法
创建一个新状态，其初始状态集包含在传入的状态数组中。
AccessibleStreamable - javax.accessibility 中的 接口
任何表示显示屏组件背后原始流的组件的 AccessibleContext 都必须实现 AccessibleStreamable 接口。
AccessibleTable - javax.accessibility 中的 接口
AccessibleTable 类描述了以二维表格式呈现数据的用户界面组件。
AccessibleTableModelChange - javax.accessibility 中的 接口
AccessibleTableModelChange 接口描述了表模型的更改。
AccessibleText - javax.accessibility 中的 接口
所有在显示器上显示文本信息的类都应该实现 AccessibleText 接口。
AccessibleTextSequence - javax.accessibility 中的 类
此类汇集文本区域的关键细节。
AccessibleTextSequence(int, int, String) - 类 javax.accessibility.AccessibleTextSequence 的构造方法
构造带有给定参数的 AccessibleTextSequence。
AccessibleValue - javax.accessibility 中的 接口
任何支持数字值的对象（例如滚动条）都应支持 AccessibleValue 接口。
ACCESSORY_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
声明正在使用不同的 accessory 组件（例如预览文件）。
AccountException - javax.security.auth.login 中的 异常
一般的帐户异常。
AccountException() - 异常 javax.security.auth.login.AccountException 的构造方法
构造不带详细消息的 AccountException。
AccountException(String) - 异常 javax.security.auth.login.AccountException 的构造方法
构造带指定详细消息的 AccountException。
AccountExpiredException - javax.security.auth.login 中的 异常
当用户帐户到期时抛出此异常。
AccountExpiredException() - 异常 javax.security.auth.login.AccountExpiredException 的构造方法
构造不带详细消息的 AccountExpiredException。
AccountExpiredException(String) - 异常 javax.security.auth.login.AccountExpiredException 的构造方法
构造带指定详细消息的 AccountExpiredException。
AccountLockedException - javax.security.auth.login 中的 异常
帐户被锁定时抛出此异常。
AccountLockedException() - 异常 javax.security.auth.login.AccountLockedException 的构造方法
构造不带详细消息的 AccountLockedException。
AccountLockedException(String) - 异常 javax.security.auth.login.AccountLockedException 的构造方法
构造带指定详细消息的 AccountLockedException。
AccountNotFoundException - javax.security.auth.login 中的 异常
未找到帐户时抛出此异常。
AccountNotFoundException() - 异常 javax.security.auth.login.AccountNotFoundException 的构造方法
构造不带详细消息的 AccountNotFoundException。
AccountNotFoundException(String) - 异常 javax.security.auth.login.AccountNotFoundException 的构造方法
构造带指定详细消息的 AccountNotFoundException。
Acl - java.security.acl 中的 接口
表示访问控制列表 (ACL) 的接口。
AclEntry - java.security.acl 中的 接口
这是用于表示访问控制列表 (ACL) 中某个项的接口。
AclNotFoundException - java.security.acl 中的 异常
如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。
AclNotFoundException() - 异常 java.security.acl.AclNotFoundException 的构造方法
构造一个 AclNotFoundException。
acos(double) - 类 java.lang.Math 中的静态方法
返回一个值的反余弦；返回的角度范围在 0.0 到 pi 之间。
acos(double) - 类 java.lang.StrictMath 中的静态方法
返回值的反余弦；返回角的范围在 0.0 到 pi 之间。
acquire(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以独占模式获取，忽略中断。
acquire(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以独占模式获取对象，忽略中断。
acquire() - 类 java.util.concurrent.Semaphore 中的方法
从此信号量获取一个许可，在提供一个许可前一直将线程阻塞，否则线程被中断。
acquire(int) - 类 java.util.concurrent.Semaphore 中的方法
从此信号量获取给定数目的许可，在提供这些许可前一直将线程阻塞，或者线程已被中断。
acquireInterruptibly(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以独占模式获取，如果被中断则中止。
acquireInterruptibly(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以独占模式获取对象，如果被中断则中止。
acquireShared(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以共享模式获取，忽略中断。
acquireShared(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以共享模式获取对象，忽略中断。
acquireSharedInterruptibly(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以共享模式获取，如果被中断则中止。
acquireSharedInterruptibly(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以共享模式获取对象，如果被中断则中止。
acquireUninterruptibly() - 类 java.util.concurrent.Semaphore 中的方法
从此信号量中获取许可，在有可用的许可前将其阻塞。
acquireUninterruptibly(int) - 类 java.util.concurrent.Semaphore 中的方法
从此信号量获取给定数目的许可，在提供这些许可前一直将线程阻塞。
action(Event, Object) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。
ACTION - 类 javax.management.MBeanOperationInfo 中的静态变量
指示该操作与写入操作类似，并将以某种方式修改 MBean，通常是写入某个值或更改某个配置。
Action - javax.swing 中的 接口
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。
ACTION - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ACTION_APPEND_AS_CHILDREN - 接口 org.w3c.dom.ls.LSParser 中的静态变量
将解析操作的结果追加为上下文节点的子节点。
ACTION_COMMAND_KEY - 接口 javax.swing.Action 中的静态变量
用来确定 ActionEvent 的命令 String 的键，ActionEvent 是在 Action 因驻留在与 JComponent 关联的 Keymap 中而被通知时所创建的。
ACTION_COPY - 类 java.awt.dnd.DnDConstants 中的静态变量
表示“复制”操作的 int 值。
ACTION_COPY_OR_MOVE - 类 java.awt.dnd.DnDConstants 中的静态变量
表示“复制”或“移动”操作的 int 值。
ACTION_EVENT - 类 java.awt.Event 中的静态变量
此事件指示用户想要某个事件发生。
ACTION_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择操作事件的事件掩码。
ACTION_FIRST - 类 java.awt.event.ActionEvent 中的静态变量
用于标识动作事件的 ID 序列的起始编号。
ACTION_INFO - 类 javax.management.MBeanOperationInfo 中的静态变量
指示该操作与读取和写入操作类似。
ACTION_INSERT_AFTER - 接口 org.w3c.dom.ls.LSParser 中的静态变量
把解析操作的结果作为上下文节点的直接后续兄弟节点插入。
ACTION_INSERT_BEFORE - 接口 org.w3c.dom.ls.LSParser 中的静态变量
把解析操作的结果作为上下文节点的直接前置兄弟节点插入。
ACTION_LAST - 类 java.awt.event.ActionEvent 中的静态变量
用于标识动作事件的 ID 序列的结束编号。
ACTION_LINK - 类 java.awt.dnd.DnDConstants 中的静态变量
表示“链接”操作的 int 值。
ACTION_MOVE - 类 java.awt.dnd.DnDConstants 中的静态变量
表示“移动”操作的 int 值。
ACTION_NONE - 类 java.awt.dnd.DnDConstants 中的静态变量
表示无操作的 int 值。
ACTION_PERFORMED - 类 java.awt.event.ActionEvent 中的静态变量
此事件 id 指示发生了有意义的动作。
ACTION_REFERENCE - 类 java.awt.dnd.DnDConstants 中的静态变量
表示“引用”操作的 int 值（等同于 ACTION_LINK）。
ACTION_REPLACE - 接口 org.w3c.dom.ls.LSParser 中的静态变量
用解析操作的结果替换上下文节点。
ACTION_REPLACE_CHILDREN - 接口 org.w3c.dom.ls.LSParser 中的静态变量
用解析操作的结果替换上下文节点的所有子节点。
actionCommand - 类 javax.swing.DefaultButtonModel 中的变量
按钮所触发的动作命令字符串。
actionCommand - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
ActionEvent - java.awt.event 中的 类
指示发生了组件定义的动作的语义事件。
ActionEvent(Object, int, String) - 类 java.awt.event.ActionEvent 的构造方法
构造一个 ActionEvent 对象。
ActionEvent(Object, int, String, int) - 类 java.awt.event.ActionEvent 的构造方法
使用修改键构造一个 ActionEvent 对象。
ActionEvent(Object, int, String, long, int) - 类 java.awt.event.ActionEvent 的构造方法
使用指定修改键和时间戳构造一个 ActionEvent 对象。
ActionListener - java.awt.event 中的 接口
用于接收操作事件的侦听器接口。
actionListener - 类 javax.swing.AbstractButton 中的变量
按钮模型的 ActionListener。
ActionMap - javax.swing 中的 类
ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。
ActionMap() - 类 javax.swing.ActionMap 的构造方法
创建一个没有父级和映射关系的 ActionMap。
ActionMapUIResource - javax.swing.plaf 中的 类
实现 UIResource 的 javax.swing.ActionMap 的子类。
ActionMapUIResource() - 类 javax.swing.plaf.ActionMapUIResource 的构造方法
actionName - 类 javax.swing.text.JTextComponent.KeyBinding 中的变量
键的操作名称。
actionPerformed(ActionEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 actionPerformed 方法处理 actionPerformed 事件。
actionPerformed(ActionEvent) - 类 java.awt.dnd.DropTarget.DropTargetAutoScroller 中的方法
导致发生自动滚动
actionPerformed(ActionEvent) - 接口 java.awt.event.ActionListener 中的方法
发生操作时调用。
actionPerformed(ActionEvent) - 类 java.awt.List.AccessibleAWTList 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
在执行操作时，编辑被终止。
actionPerformed(ActionEvent) - 类 javax.swing.JComboBox 中的方法
此方法由于实现的副作用而存在的公共方法。
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.ActionScroller 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的方法
因 Timer 而将此方法作为公共方法。
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.BeepAction 中的方法
触发此动作时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.CopyAction 中的方法
触发此动作时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.CutAction 中的方法
触发此动作时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction 中的方法
动作触发时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.InsertBreakAction 中的方法
触发此动作时执行该操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.InsertContentAction 中的方法
此动作触发时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.InsertTabAction 中的方法
此动作触发时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.PasteAction 中的方法
触发此动作时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.html.FormView 中的方法
负责处理 ActionEvent。
actionPerformed(ActionEvent) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的方法
将 HTML 插入文档。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.AlignmentAction 中的方法
设置对齐方式。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.BoldAction 中的方法
切换粗体属性。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.FontFamilyAction 中的方法
设置字体系列。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.FontSizeAction 中的方法
设置字体大小。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.ForegroundAction 中的方法
设置前景色。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.ItalicAction 中的方法
切换斜体属性。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.UnderlineAction 中的方法
切换下划线属性。
actionPerformed(ActionEvent) - 类 javax.swing.ToolTipManager.insideTimerAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.ToolTipManager.outsideTimerAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.ToolTipManager.stillInsideTimerAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
计时器被激发时传递消息，这将启动编辑会话。
actionPropertyChanged(Action, String) - 类 javax.swing.AbstractButton 中的方法
更新按钮的状态以响应相关的操作中的属性更改。
actionPropertyChanged(Action, String) - 类 javax.swing.JComboBox 中的方法
更新组合框的状态以响应关联动作中的属性更改。
actionPropertyChanged(Action, String) - 类 javax.swing.JMenuItem 中的方法
更新按钮的状态以响应相关的操作中的属性更改。
actionPropertyChanged(Action, String) - 类 javax.swing.JTextField 中的方法
更新文本字段的状态以响应关联动作中的属性更改。
Activatable - java.rmi.activation 中的 类
Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
Activatable(String, MarshalledObject<?>, boolean, int) - 类 java.rmi.activation.Activatable 的构造方法
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
Activatable(String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.activation.Activatable 的构造方法
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
Activatable(ActivationID, int) - 类 java.rmi.activation.Activatable 的构造方法
构造方法用于在指定端口上激活/导出对象。
Activatable(ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.activation.Activatable 的构造方法
构造方法用于在指定端口上激活/导出对象。
activate() - 接口 java.awt.im.spi.InputMethod 中的方法
激活输入方法，以便立即进行输入处理。
activate(Applet) - 接口 java.beans.AppletInitializer 中的方法
激活和/或将 Applet 标记为激活。
activate(boolean) - 类 java.rmi.activation.ActivationID 中的方法
激活此 id 的对象。
activate(ActivationID, boolean) - 接口 java.rmi.activation.Activator 中的方法
激活与激活标识符 id 关联的对象。
activate(IIOParam) - 接口 javax.imageio.IIOParamController 中的方法
激活控制器。
activate(IIOMetadata) - 接口 javax.imageio.metadata.IIOMetadataController 中的方法
激活控制器。
activate() - 接口 org.omg.PortableServer.POAManagerOperations 中的方法
此操作将 POA 管理器更改为激活状态，促使关联的 POA 开始处理请求。
activate_object(Servant) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作生成一个 Object Id，并将该 Object Id 和指定的 servant 输入 Active Object Map。
activate_object_with_id(byte[], Servant) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。
activateController() - 类 javax.imageio.IIOParam 中的方法
激活为此 IIOParam 对象安装的 IIOParamController，并返回得到的值。
activateController() - 类 javax.imageio.metadata.IIOMetadata 中的方法
激活为此 IIOMetadata 对象安装的 IIOMetadataController，并返回所得到的值。
ACTIVATED - 类 javax.swing.event.HyperlinkEvent.EventType 中的静态变量
激活类型。
ActivateFailedException - java.rmi.activation 中的 异常
在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。
ActivateFailedException(String) - 异常 java.rmi.activation.ActivateFailedException 的构造方法
构造带指定详细消息的 ActivateFailedException。
ActivateFailedException(String, Exception) - 异常 java.rmi.activation.ActivateFailedException 的构造方法
构造带指定详细消息和嵌套异常的 ActivateFailedException。
activateFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
此方法将激活 f，将它移动到前台。
activateFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常指示此窗体拥有焦点。
activateFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
窗体变为被选择状态时调用此方法。
activateLink(int, JEditorPane) - 类 javax.swing.text.html.HTMLEditorKit.LinkController 中的方法
如果给定位置表示一个链接，则调用关联 JEditorPane 上的 linkActivated。
ActivationDataFlavor - javax.activation 中的 类
ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。
ActivationDataFlavor(Class, String, String) - 类 javax.activation.ActivationDataFlavor 的构造方法
构造一个表示任意 Java 对象的 DataFlavor。
ActivationDataFlavor(Class, String) - 类 javax.activation.ActivationDataFlavor 的构造方法
构造一个表示 MimeType 的 DataFlavor。
ActivationDataFlavor(String, String) - 类 javax.activation.ActivationDataFlavor 的构造方法
构造一个表示 MimeType 的 DataFlavor。
ActivationDesc - java.rmi.activation 中的 类
激活描述符包含激活对象所必需的信息： 对象的组标识符， 对象的完全限定的类名， 对象的代码基（类中的位置），一个代码基 URL 路径， 对象的重启“模式”，以及 一个可包含特定于对象的初始化数据的“编组”对象。
ActivationDesc(String, String, MarshalledObject<?>) - 类 java.rmi.activation.ActivationDesc 的构造方法
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(String, String, MarshalledObject<?>, boolean) - 类 java.rmi.activation.ActivationDesc 的构造方法
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>) - 类 java.rmi.activation.ActivationDesc 的构造方法
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>, boolean) - 类 java.rmi.activation.ActivationDesc 的构造方法
为类名为 className 的对象构造一个对象描述符，这可从代码的 location 处加载，并且其初始化信息为 data。
ActivationException - java.rmi.activation 中的 异常
激活接口所使用的一般异常。
ActivationException() - 异常 java.rmi.activation.ActivationException 的构造方法
构造一个 ActivationException。
ActivationException(String) - 异常 java.rmi.activation.ActivationException 的构造方法
构造带指定详细消息的 ActivationException。
ActivationException(String, Throwable) - 异常 java.rmi.activation.ActivationException 的构造方法
构造带指定详细消息和原因的 ActivationException。
ActivationGroup - java.rmi.activation 中的 类
ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
ActivationGroup(ActivationGroupID) - 类 java.rmi.activation.ActivationGroup 的构造方法
用给定的激活组标识符创建一个激活组。
ActivationGroup_Stub - java.rmi.activation 中的 类
ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。
ActivationGroup_Stub(RemoteRef) - 类 java.rmi.activation.ActivationGroup_Stub 的构造方法
为 ActivationGroup 类构造一个 stub。
ActivationGroupDesc - java.rmi.activation 中的 类
激活组描述符包含了创建/重建在其中激活对象的一个激活组所必需的信息。
ActivationGroupDesc(Properties, ActivationGroupDesc.CommandEnvironment) - 类 java.rmi.activation.ActivationGroupDesc 的构造方法
使用组实现的系统默认值和代码基来构造一个组描述符。
ActivationGroupDesc(String, String, MarshalledObject<?>, Properties, ActivationGroupDesc.CommandEnvironment) - 类 java.rmi.activation.ActivationGroupDesc 的构造方法
指定一个用于该组的替代组实现和执行环境。
ActivationGroupDesc.CommandEnvironment - java.rmi.activation 中的 类
ActivationGroup 实现的启动选项。
ActivationGroupDesc.CommandEnvironment(String, String[]) - 类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 的构造方法
用所有必要的信息创建一个 CommandEnvironment。
ActivationGroupID - java.rmi.activation 中的 类
针对一个注册激活组的标识符，它完成几个目标： 在激活系统中唯一地标识该组，以及 包含指向该组的激活系统的引用，以便该组在必要时能够联络上其激活系统。
ActivationGroupID(ActivationSystem) - 类 java.rmi.activation.ActivationGroupID 的构造方法
构造一个唯一的组 id。
ActivationID - java.rmi.activation 中的 类
激活利用特定的标识符来表示远程对象，对象能随着时间被激活。
ActivationID(Activator) - 类 java.rmi.activation.ActivationID 的构造方法
ActivationID 的构造方法带有单个参数 activator，这指定了一个对激活器（负责激活与此标识符相关联的对象）的远程引用。
ActivationInstantiator - java.rmi.activation 中的 接口
ActivationInstantiator 负责创建“可激活”对象的实例。
ActivationMonitor - java.rmi.activation 中的 接口
一个 ActivationMonitor 特定于一个 ActivationGroup，当一个组通过对 ActivationSystem.activeGroup 的调用（这是内部完成的）被报告为活动时，获得一个 ActivationMonitor。
ActivationSystem - java.rmi.activation 中的 接口
ActivationSystem 为注册组和在那些组中要被激活的“可激活”对象提供一种方式。
Activator - java.rmi.activation 中的 接口
Activator 方便了远程对象激活。
ACTIVATOR_ID - 类 java.rmi.server.ObjID 中的静态变量
激活程序的已知 ObjID 的对象数。
ACTIVE - 类 javax.accessibility.AccessibleState 中的静态变量
指示某个窗口当前是活动窗口。
active - 类 javax.sound.midi.VoiceStatus 中的变量
指示声音当前是否正在处理 MIDI 音符。
ACTIVE - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/ACTIVE.java。
ACTIVE - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
ACTIVE_CAPTION - 类 java.awt.SystemColor 中的静态变量
SystemColor.activeCaption 系统颜色的数组索引。
ACTIVE_CAPTION_BORDER - 类 java.awt.SystemColor 中的静态变量
SystemColor.activeCaptionBorder 系统颜色的数组索引。
ACTIVE_CAPTION_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.activeCaptionText 系统颜色的数组索引。
ACTIVE_SENSING - 类 javax.sound.midi.ShortMessage 中的静态变量
ACTIVE_SENSING 消息的状态字节（0xFE 或 254）。
activeCaption - 类 java.awt.SystemColor 中的静态变量
为当前活动窗口的窗口标题提供的背景色。
activeCaptionBorder - 类 java.awt.SystemColor 中的静态变量
为当前活动窗口的边框提供的颜色。
activeCaptionText - 类 java.awt.SystemColor 中的静态变量
为当前活动窗口的窗口标题文本提供的颜色。
activeCount() - 类 java.lang.Thread 中的静态方法
返回当前线程的线程组中活动线程的数目。
activeCount() - 类 java.lang.ThreadGroup 中的方法
返回此线程组中活动线程的估计数。
ActiveEvent - java.awt 中的 接口
知道如何对自身进行指派的事件的接口。
activeGroup(ActivationGroupID, ActivationInstantiator, long) - 接口 java.rmi.activation.ActivationSystem 中的方法
通过回调来通知激活系统该组现在是活动的。
activeGroupCount() - 类 java.lang.ThreadGroup 中的方法
返回此线程组中活动线程组的估计数。
activeObject(ActivationID, Remote) - 类 java.rmi.activation.ActivationGroup 中的方法
当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
activeObject(ActivationID, MarshalledObject<? extends Remote>) - 类 java.rmi.activation.ActivationGroup 中的方法
如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
activeObject(ActivationID, MarshalledObject<? extends Remote>) - 接口 java.rmi.activation.ActivationMonitor 中的方法
通知某个对象现在是活动的。
ACTIVITY_COMPLETED - org.omg.CORBA 中的 异常
ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
ACTIVITY_COMPLETED() - 异常 org.omg.CORBA.ACTIVITY_COMPLETED 的构造方法
构造一个 ACTIVITY_COMPLETED 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。
ACTIVITY_COMPLETED(String) - 异常 org.omg.CORBA.ACTIVITY_COMPLETED 的构造方法
使用指定消息构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_COMPLETED(int, CompletionStatus) - 异常 org.omg.CORBA.ACTIVITY_COMPLETED 的构造方法
使用指定次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_COMPLETED(String, int, CompletionStatus) - 异常 org.omg.CORBA.ACTIVITY_COMPLETED 的构造方法
使用指定消息、次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_REQUIRED - org.omg.CORBA 中的 异常
ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
ACTIVITY_REQUIRED() - 异常 org.omg.CORBA.ACTIVITY_REQUIRED 的构造方法
构造一个 ACTIVITY_REQUIRED 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。
ACTIVITY_REQUIRED(String) - 异常 org.omg.CORBA.ACTIVITY_REQUIRED 的构造方法
使用指定消息构造一个 ACTIVITY_REQUIRED 异常。
ACTIVITY_REQUIRED(int, CompletionStatus) - 异常 org.omg.CORBA.ACTIVITY_REQUIRED 的构造方法
使用指定次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。
ACTIVITY_REQUIRED(String, int, CompletionStatus) - 异常 org.omg.CORBA.ACTIVITY_REQUIRED 的构造方法
使用指定消息、次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。
ActivityCompletedException - javax.activity 中的 异常
任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
ActivityCompletedException() - 异常 javax.activity.ActivityCompletedException 的构造方法
构造一个新实例，其详细消息为 null。
ActivityCompletedException(String) - 异常 javax.activity.ActivityCompletedException 的构造方法
构造带有指定详细消息的新实例。
ActivityCompletedException(Throwable) - 异常 javax.activity.ActivityCompletedException 的构造方法
构造带有指定 cause 的新 throwable。
ActivityCompletedException(String, Throwable) - 异常 javax.activity.ActivityCompletedException 的构造方法
构造带有指定详细消息和 cause 的新 throwable。
ActivityRequiredException - javax.activity 中的 异常
如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
ActivityRequiredException() - 异常 javax.activity.ActivityRequiredException 的构造方法
构造一个新实例，其详细消息为 null。
ActivityRequiredException(String) - 异常 javax.activity.ActivityRequiredException 的构造方法
构造带有指定详细消息的新实例。
ActivityRequiredException(Throwable) - 异常 javax.activity.ActivityRequiredException 的构造方法
构造带有指定 cause 的新 throwable。
ActivityRequiredException(String, Throwable) - 异常 javax.activity.ActivityRequiredException 的构造方法
构造带有指定详细消息和 cause 的新 throwable。
AD - 类 java.util.GregorianCalendar 中的静态变量
ERA 字段的值指示公元后（耶稣纪元后）的时期（也称为 CE）。
adapter_id() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回对象适配器的不透明标识符。
adapter_manager_state_changed(int, short) - 接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations 中的方法
只要适配器管理器的状态更改时便调用此方法。
adapter_name() - 接口 org.omg.PortableInterceptor.ObjectReferenceTemplate 中的方法
adapter_name() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回字符串序列，这些字符串标识正处理此请求的对象适配器实例。
adapter_state_changed(ObjectReferenceTemplate[], short) - 接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations 中的方法
只要对象适配器的状态发生更改，并且该状态更改不是由适配器管理器引起的，便调用此方法。
adapter_template() - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
返回刚创建并在 IOR interceptor 上运行的对象适配器的对象引用模板。
AdapterActivator - org.omg.PortableServer 中的 接口
一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
AdapterActivatorOperations - org.omg.PortableServer 中的 接口
一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
AdapterAlreadyExists - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
AdapterAlreadyExists() - 异常 org.omg.PortableServer.POAPackage.AdapterAlreadyExists 的构造方法
AdapterAlreadyExists(String) - 异常 org.omg.PortableServer.POAPackage.AdapterAlreadyExists 的构造方法
AdapterAlreadyExistsHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java。
AdapterAlreadyExistsHelper() - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 的构造方法
AdapterInactive - org.omg.PortableServer.POAManagerPackage 中的 异常
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。
AdapterInactive() - 异常 org.omg.PortableServer.POAManagerPackage.AdapterInactive 的构造方法
AdapterInactive(String) - 异常 org.omg.PortableServer.POAManagerPackage.AdapterInactive 的构造方法
AdapterInactiveHelper - org.omg.PortableServer.POAManagerPackage 中的 类
org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java。
AdapterInactiveHelper() - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 的构造方法
AdapterManagerIdHelper - org.omg.PortableInterceptor 中的 类
适配器管理器标识符。
AdapterManagerIdHelper() - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 的构造方法
AdapterNameHelper - org.omg.PortableInterceptor 中的 类
对象适配器的名称。
AdapterNameHelper() - 类 org.omg.PortableInterceptor.AdapterNameHelper 的构造方法
AdapterNonExistent - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
AdapterNonExistent() - 异常 org.omg.PortableServer.POAPackage.AdapterNonExistent 的构造方法
AdapterNonExistent(String) - 异常 org.omg.PortableServer.POAPackage.AdapterNonExistent 的构造方法
AdapterNonExistentHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java。
AdapterNonExistentHelper() - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 的构造方法
AdapterStateHelper - org.omg.PortableInterceptor 中的 类
对象适配器状态的类型。
AdapterStateHelper() - 类 org.omg.PortableInterceptor.AdapterStateHelper 的构造方法
add(ComponentListener, ComponentListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加组件侦听器 a 和组件侦听器 b，并返回得到的多路广播侦听器。
add(ContainerListener, ContainerListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加容器侦听器 a 和容器侦听器 b，并返回得到的多路广播侦听器。
add(FocusListener, FocusListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加焦点侦听器 a 和焦点侦听器 b，并返回得到的多路广播侦听器。
add(KeyListener, KeyListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加键侦听器 a 和键侦听器 b，并返回得到的多路广播侦听器。
add(MouseListener, MouseListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加鼠标侦听器 a 和鼠标侦听器 b，并返回得到的多路广播侦听器。
add(MouseMotionListener, MouseMotionListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加鼠标移动侦听器 a 和鼠标移动侦听器 b，并返回得到的多路广播侦听器。
add(WindowListener, WindowListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加窗口侦听器 a 和窗口侦听器 b，并返回得到的多路广播侦听器。
add(WindowStateListener, WindowStateListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加窗口状态侦听器 a 和窗口状态侦听器 b，并返回得到的多路广播侦听器。
add(WindowFocusListener, WindowFocusListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加窗口焦点侦听器 a 和窗口焦点侦听器 b，并返回得到的多路广播侦听器。
add(ActionListener, ActionListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加操作侦听器 a 和操作侦听器 b，并返回得到的多路广播侦听器。
add(ItemListener, ItemListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加项侦听器 a 和项侦听器 b，并返回得到的多路广播侦听器。
add(AdjustmentListener, AdjustmentListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加调整侦听器 a 和调整侦听器 b，并返回得到的多路广播侦听器。
add(TextListener, TextListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
add(InputMethodListener, InputMethodListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加输入方法侦听器 a 和输入方法侦听器 b，并返回得到的多路广播侦听器。
add(HierarchyListener, HierarchyListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加层次结构侦听器 a 和层次结构侦听器 b，并返回得到的多路广播侦听器。
add(HierarchyBoundsListener, HierarchyBoundsListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加层次结构边界侦听器 a 和层次结构边界侦听器 b，并返回得到的多路广播侦听器。
add(MouseWheelListener, MouseWheelListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加鼠标滚轮侦听器 a 和鼠标滚轮侦听器 b，并返回得到的多路广播侦听器。
add(String) - 类 java.awt.Choice 中的方法
将一个项添加到此 Choice 菜单中。
add(PopupMenu) - 类 java.awt.Component 中的方法
向组件添加指定的弹出菜单。
add(Component) - 类 java.awt.Container 中的方法
将指定组件追加到此容器的尾部。
add(String, Component) - 类 java.awt.Container 中的方法
将指定组件添加到此容器中。
add(Component, int) - 类 java.awt.Container 中的方法
将指定组件添加到此容器的给定位置上。
add(Component, Object) - 类 java.awt.Container 中的方法
将指定的组件添加到此容器的尾部。
add(Component, Object, int) - 类 java.awt.Container 中的方法
使用指定约束，将指定组件添加到此容器的指定索引所在的位置上。
add(Area) - 类 java.awt.geom.Area 中的方法
将指定 Area 的形状添加到此 Area 的形状中。
add(double, double) - 类 java.awt.geom.Rectangle2D 中的方法
将由 double 精度参数 newx 和 newy 指定的点添加到此 Rectangle2D 中。
add(Point2D) - 类 java.awt.geom.Rectangle2D 中的方法
将 Point2D 对象 pt 添加到此 Rectangle2D 中。
add(Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的方法
将 Rectangle2D 对象添加到此 Rectangle2D 中。
add(Object) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Object 添加到此参数列表。
add(byte) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Byte 添加到此参数列表。
add(char) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Character 添加到此参数列表。
add(short) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Short 添加到此参数列表。
add(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Integer 添加到此参数列表。
add(long) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Long 添加到此参数列表。
add(float) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Float 添加到此参数列表。
add(double) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Double 添加到此参数列表。
add(String) - 类 java.awt.List 中的方法
向滚动列表的末尾添加指定的项。
add(String, int) - 类 java.awt.List 中的方法
向滚动列表中索引指示的位置添加指定的项。
add(MenuItem) - 类 java.awt.Menu 中的方法
将指定的菜单项添加到此菜单。
add(String) - 类 java.awt.Menu 中的方法
将带有指定标签的项添加到此菜单。
add(Menu) - 类 java.awt.MenuBar 中的方法
将指定的菜单添加到菜单栏。
add(int, int) - 类 java.awt.Rectangle 中的方法
将一个由整数参数 newx,newy 指定的点添加到此 Rectangle 的边界。
add(Point) - 类 java.awt.Rectangle 中的方法
将指定的 Point 添加到此 Rectangle 的边界。
add(Rectangle) - 类 java.awt.Rectangle 中的方法
将一个 Rectangle 添加到此 Rectangle 中。
add(RenderingHints) - 类 java.awt.RenderingHints 中的方法
将指定 RenderingHints 对象中的所有键和相应的值添加到此 RenderingHints 对象中。
add(TrayIcon) - 类 java.awt.SystemTray 中的方法
将 TrayIcon 添加到 SystemTray。
add(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在此 BeanContext 中添加/嵌套一个子级。
add(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this + augend)，其标度为 max(this.scale(), augend.scale())。
add(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (this + augend) 的 BigDecimal（根据上下文设置进行舍入）。
add(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this + val) 的 BigInteger。
add(URI, HttpCookie) - 接口 java.net.CookieStore 中的方法
将一个 HTTP cookie 添加到存储区中。
add(Permission) - 类 java.security.PermissionCollection 中的方法
将一个权限对象添加到当前权限对象的集合。
add(Permission) - 类 java.security.Permissions 中的方法
将一个 permission 对象添加到该权限所属的类的 PermissionCollection 中。
add(E) - 类 java.util.AbstractCollection 中的方法
确保此 collection 包含指定的元素（可选操作）。
add(E) - 类 java.util.AbstractList 中的方法
将指定的元素添加到此列表的尾部（可选操作）。
add(int, E) - 类 java.util.AbstractList 中的方法
在列表的指定位置插入指定元素（可选操作）。
add(E) - 类 java.util.AbstractQueue 中的方法
将指定的元素插入到此队列中（如果立即可行且不会违反容量限制），在成功时返回 true，如果当前没有可用空间，则抛出 IllegalStateException。
add(int, E) - 类 java.util.AbstractSequentialList 中的方法
在此列表中的指定位置上插入指定的元素（可选操作）。
add(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的末尾。
add(E) - 类 java.util.ArrayList 中的方法
将指定的元素添加到此列表的尾部。
add(int, E) - 类 java.util.ArrayList 中的方法
将指定的元素插入此列表中的指定位置。
add(int, int) - 类 java.util.Calendar 中的方法
根据日历的规则，为给定的日历字段添加或减去指定的时间量。
add(E) - 接口 java.util.Collection 中的方法
确保此 collection 包含指定的元素（可选操作）。
add(E) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
将指定的元素插入到此队列的尾部（如果立即可行且不会超过该队列的容量），在成功时返回 true，如果此队列已满，则抛出 IllegalStateException。
add(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
Inserts the 如果立即可行且不违反容量限制，则将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），并在成功时返回 true；如果当前没有空间可用，则抛出 IllegalStateException。
add(E) - 接口 java.util.concurrent.BlockingQueue 中的方法
将指定元素插入此队列中（如果立即可行且不会违反容量限制），成功时返回 true，如果当前没有可用的空间，则抛出 IllegalStateException。
add(E) - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
将指定元素插入此队列的尾部。
add(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
如果此 set 中不包含指定元素，则添加指定元素。
add(E) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
将指定元素添加到此列表的尾部。
add(int, E) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
在此列表的指定位置上插入指定元素。
add(E) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果指定元素并不存在于此 set 中，则添加它。
add(E) - 类 java.util.concurrent.DelayQueue 中的方法
将指定元素插入此延迟队列中。
add(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
在不违反容量限制的情况下，将指定的元素插入此双端队列的末尾。
add(E) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
将指定元素插入此优先级队列。
add(E) - 接口 java.util.Deque 中的方法
将指定元素插入此双端队列所表示的队列（换句话说，此双端队列的尾部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用空间，则抛出 IllegalStateException。
add(int, int) - 类 java.util.GregorianCalendar 中的方法
根据日历规则，将指定的（有符号的）时间量添加到给定的日历字段中。
add(E) - 类 java.util.HashSet 中的方法
如果此 set 中尚未包含指定元素，则添加指定元素。
add(E) - 类 java.util.LinkedList 中的方法
将指定元素添加到此列表的结尾。
add(int, E) - 类 java.util.LinkedList 中的方法
在此列表中指定的位置插入指定的元素。
add(E) - 接口 java.util.List 中的方法
向列表的尾部添加指定的元素（可选操作）。
add(int, E) - 接口 java.util.List 中的方法
在列表的指定位置插入指定元素（可选操作）。
add(E) - 接口 java.util.ListIterator 中的方法
将指定的元素插入列表（可选操作）。
add(E) - 类 java.util.PriorityQueue 中的方法
将指定的元素插入此优先级队列。
add(E) - 接口 java.util.Queue 中的方法
将指定的元素插入此队列（如果立即可行且不会违反容量限制），在成功时返回 true，如果当前没有可用的空间，则抛出 IllegalStateException。
add(E) - 接口 java.util.Set 中的方法
如果 set 中尚未存在指定的元素，则添加此元素（可选操作）。
add(E) - 类 java.util.TreeSet 中的方法
将指定的元素添加到此 set（如果该元素尚未存在于 set 中）。
add(E) - 类 java.util.Vector 中的方法
将指定元素添加到此向量的末尾。
add(int, E) - 类 java.util.Vector 中的方法
在此向量的指定位置插入指定的元素。
add(AccessibleRelation) - 类 javax.accessibility.AccessibleRelationSet 中的方法
将新关系添加到当前关系集中。
add(AccessibleState) - 类 javax.accessibility.AccessibleStateSet 中的方法
如果某个新状态不在当前状态集中，则将它添加到当前状态集中。
add(Attribute) - 类 javax.management.AttributeList 中的方法
添加指定的 Attribute 作为列表的最后一个元素。
add(int, Attribute) - 类 javax.management.AttributeList 中的方法
插入指定的属性作为指定位置处的元素。
add(Object) - 类 javax.management.AttributeList 中的方法
add(int, Object) - 类 javax.management.AttributeList 中的方法
add(Role) - 类 javax.management.relation.RoleList 中的方法
添加指定为列表中最后一个元素的 Role。
add(int, Role) - 类 javax.management.relation.RoleList 中的方法
插入指定为指定位置处的元素的角色。
add(Object) - 类 javax.management.relation.RoleList 中的方法
add(int, Object) - 类 javax.management.relation.RoleList 中的方法
add(RoleUnresolved) - 类 javax.management.relation.RoleUnresolvedList 中的方法
添加指定为列表中最后一个元素的 RoleUnresolved。
add(int, RoleUnresolved) - 类 javax.management.relation.RoleUnresolvedList 中的方法
在指定位置处插入指定为元素的未解析角色。
add(Object) - 类 javax.management.relation.RoleUnresolvedList 中的方法
add(int, Object) - 类 javax.management.relation.RoleUnresolvedList 中的方法
add(String) - 类 javax.naming.CompositeName 中的方法
将单个组件添加到此复合名称的末尾。
add(int, String) - 类 javax.naming.CompositeName 中的方法
在此复合名称中的指定位置添加单个组件。
add(String) - 类 javax.naming.CompoundName 中的方法
将单个组件添加到此组合名称的末尾。
add(int, String) - 类 javax.naming.CompoundName 中的方法
在此组合名称中的指定位置添加单个组件。
add(Object) - 接口 javax.naming.directory.Attribute 中的方法
向属性添加新值。
add(int, Object) - 接口 javax.naming.directory.Attribute 中的方法
将属性值添加到属性值的有序列表中。
add(Object) - 类 javax.naming.directory.BasicAttribute 中的方法
向此属性添加新值。
add(int, Object) - 类 javax.naming.directory.BasicAttribute 中的方法
add(String) - 类 javax.naming.ldap.LdapName 中的方法
将单个组件添加到此 LDAP 名称的末尾。
add(Rdn) - 类 javax.naming.ldap.LdapName 中的方法
将单个 RDN 添加到此 LDAP 名称的末尾。
add(int, String) - 类 javax.naming.ldap.LdapName 中的方法
将单个组件添加到此 LDAP 名称中的指定位置。
add(int, Rdn) - 类 javax.naming.ldap.LdapName 中的方法
将单个 RDN 添加到此 LDAP 名称中的指定位置。
add(String) - 接口 javax.naming.Name 中的方法
将单个组件添加到此名称的末尾。
add(int, String) - 接口 javax.naming.Name 中的方法
在此名称中的指定位置添加单个组件。
add(RefAddr) - 类 javax.naming.Reference 中的方法
将地址添加到地址列表的末尾。
add(int, RefAddr) - 类 javax.naming.Reference 中的方法
将地址添加到地址列表中的索引 posn 处。
add(Attribute) - 接口 javax.print.attribute.AttributeSet 中的方法
如果指定的属性尚不存在，则将它添加到此属性集中，首先要移除与指定属性值相同的属性类别中的任何现有值。
add(Attribute) - 接口 javax.print.attribute.DocAttributeSet 中的方法
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
add(Attribute) - 类 javax.print.attribute.HashAttributeSet 中的方法
如果指定的属性不存在，则将它添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有属性。
add(Attribute) - 接口 javax.print.attribute.PrintJobAttributeSet 中的方法
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
add(Attribute) - 接口 javax.print.attribute.PrintRequestAttributeSet 中的方法
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
add(Attribute) - 接口 javax.print.attribute.PrintServiceAttributeSet 中的方法
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
add(JobStateReason) - 类 javax.print.attribute.standard.JobStateReasons 中的方法
将指定的元素添加到此作业状态原因属性（如果它尚未存在）。
add(MidiEvent) - 类 javax.sound.midi.Track 中的方法
将新事件添加至音轨。
add(AbstractButton) - 类 javax.swing.ButtonGroup 中的方法
将按钮添加到组中。
add(int, Object) - 类 javax.swing.DefaultListModel 中的方法
在此列表的指定位置处插入指定元素。
add(Class<T>, T) - 类 javax.swing.event.EventListenerList 中的方法
将侦听器作为指定类型的侦听器进行添加。
add(JMenuItem) - 类 javax.swing.JMenu 中的方法
将某个菜单项追加到此菜单的末尾。
add(Component) - 类 javax.swing.JMenu 中的方法
将某个组件追加到此菜单的末尾。
add(Component, int) - 类 javax.swing.JMenu 中的方法
将指定组件添加到此容器的给定位置上。
add(String) - 类 javax.swing.JMenu 中的方法
创建具有指定文本的新菜单项，并将其追加到此菜单的末尾。
add(Action) - 类 javax.swing.JMenu 中的方法
创建连接到指定 Action 对象的新菜单项，并将其追加到此菜单的末尾。
add(JMenu) - 类 javax.swing.JMenuBar 中的方法
将指定的菜单追加到菜单栏的末尾。
add(JMenuItem) - 类 javax.swing.JPopupMenu 中的方法
将指定菜单项添加到此菜单的末尾。
add(String) - 类 javax.swing.JPopupMenu 中的方法
创建具有指定文本的菜单项，并将其添加到此菜单的末尾。
add(Action) - 类 javax.swing.JPopupMenu 中的方法
将指派指定 Action 对象的新菜单项添加到菜单的末尾。
add(Component) - 类 javax.swing.JTabbedPane 中的方法
添加一个 component，其选项卡的默认值为调用 component.getName 返回的组件的名称。
add(String, Component) - 类 javax.swing.JTabbedPane 中的方法
添加具有指定选项卡标题的 component。
add(Component, int) - 类 javax.swing.JTabbedPane 中的方法
在指定的选项卡索引位置添加一个 component，默认的选项卡标题为组件名称。
add(Component, Object) - 类 javax.swing.JTabbedPane 中的方法
将一个 component 添加到选项卡窗格中。
add(Component, Object, int) - 类 javax.swing.JTabbedPane 中的方法
在指定的选项卡索引位置添加一个 component。
add(Action) - 类 javax.swing.JToolBar 中的方法
添加一个指派动作的新的 JButton。
add(MutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
从其父节点移除 newChild，并通过将其添加到此节点的子数组的结尾，使其成为此节点的子节点。
add(Duration) - 类 javax.xml.datatype.Duration 中的方法
计算值为 this+rhs 的新持续时间。
add(Duration) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将 duration 添加到此实例。
add(XMLEvent) - 接口 javax.xml.stream.util.XMLEventConsumer 中的方法
此方法为使用者添加一个事件。
add(XMLEvent) - 接口 javax.xml.stream.XMLEventWriter 中的方法
向输出流添加事件。
add(XMLEventReader) - 接口 javax.xml.stream.XMLEventWriter 中的方法
将整个流添加到输出流，在 hasNext() 返回 false 前对 inputStream 参数调用 next()。
add(GSSName, int, int, Oid, int) - 接口 org.ietf.jgss.GSSCredential 中的方法
将特定于机制的凭据元素添加到现有的凭据中。
add(String) - 类 org.omg.CORBA.ContextList 中的方法
将 String 对象添加到此 ContextList 对象中。
add(TypeCode) - 类 org.omg.CORBA.ExceptionList 中的方法
将描述异常的 TypeCode 对象添加到此 ExceptionList 对象中。
add(int) - 类 org.omg.CORBA.NVList 中的方法
创建一个新的 NamedValue 对象，使用给定标志初始化该对象，并将它添加到此 NVList 对象的末尾。
ADD_ATTRIBUTE - 接口 javax.naming.directory.DirContext 中的静态变量
此常量指定使用指定值添加属性。
add_client_request_interceptor(ClientRequestInterceptor) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
此方法用来将客户端的请求 Interceptor 添加到客户端请求 Interceptor 列表。
add_in_arg() - 类 org.omg.CORBA.Request 中的方法
创建一个输入参数，并将它添加到此 Request 对象中。
add_inout_arg() - 类 org.omg.CORBA.Request 中的方法
将一个输入/输出参数添加到此 Request 对象中。
add_ior_component(TaggedComponent) - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component，以便向构造 IOR 时要包括的设置添加带标记的组件。
add_ior_component_to_profile(TaggedComponent, int) - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component_to_profile，以便向构造 IOR 时要包括的设置添加带标记的组件。
add_ior_interceptor(IORInterceptor) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
此方法用来将 IOR Interceptor 添加到 IOR Interceptor 列表。
add_item(String, int) - 类 org.omg.CORBA.NVList 中的方法
创建一个新的 NamedValue 对象，使用给定名称和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
add_named_in_arg(String) - 类 org.omg.CORBA.Request 中的方法
使用给定名称创建一个输入参数，并将它添加到此 Request 对象中。
add_named_inout_arg(String) - 类 org.omg.CORBA.Request 中的方法
将具有给定名称的输入/输出参数添加到此 Request 对象中。
add_named_out_arg(String) - 类 org.omg.CORBA.Request 中的方法
将具有给定名称的输出参数添加到此 Request 对象中。
add_out_arg() - 类 org.omg.CORBA.Request 中的方法
将输出参数添加到此 Request 对象中。
ADD_OVERRIDE - 类 org.omg.CORBA.SetOverrideType 中的静态变量
用于枚举值 ADD_OVERRIDE 的 SetOverrideType 常量。
add_reply_service_context(ServiceContext, boolean) - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
允许 Interceptor 将服务上下文添加到请求。
add_request_service_context(ServiceContext, boolean) - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
允许 Interceptor 将服务上下文添加到请求。
add_server_request_interceptor(ServerRequestInterceptor) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
此方法用来将服务器端的请求 Interceptor 添加到服务器端请求 Interceptor 列表。
add_value(String, Any, int) - 类 org.omg.CORBA.NVList 中的方法
创建一个新的 NamedValue 对象，使用给定名称、值和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
addAccessibleSelection(int) - 类 java.awt.List.AccessibleAWTList 中的方法
将对象中的指定选项添加到对象选择中。
addAccessibleSelection(int) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
将该对象的指定 Accessible 子对象添加到该对象的选择中。
addAccessibleSelection(int) - 接口 javax.accessibility.AccessibleSelection 中的方法
将对象的指定 Accessible 子级添加到该对象的选项中。
addAccessibleSelection(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
将该对象的指定 Accessible 子对象添加到该对象的选择中。
addAccessibleSelection(int) - 类 javax.swing.JList.AccessibleJList 中的方法
将对象中的指定选项添加到对象选择中。
addAccessibleSelection(int) - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
选择菜单中的第 i 个菜单。
addAccessibleSelection(int) - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
在菜单栏中选择第 n 个菜单，并强制其弹出。
addAccessibleSelection(int) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
addAccessibleSelection(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
将该对象的指定 Accessible 子对象添加到该对象的选择中。
addAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
将对象中指定选择的项添加到对象的选择中。
addAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree 中的方法
将对象中指定选择的项添加到对象的选择中。
addActionForKeyStroke(KeyStroke, Action) - 接口 javax.swing.text.Keymap 中的方法
向 keymap 添加绑定。
addActionListener(ActionListener) - 类 java.awt.Button 中的方法
添加指定的动作侦听器，以接收发自此按钮的动作事件。
addActionListener(ActionListener) - 类 java.awt.List 中的方法
添加指定的动作侦听器以从此列表接收动作事件。
addActionListener(ActionListener) - 类 java.awt.MenuItem 中的方法
添加指定的动作侦听器，以从此菜单项接收动作事件。
addActionListener(ActionListener) - 类 java.awt.TextField 中的方法
添加指定的操作侦听器，以从此文本字段接收操作事件。
addActionListener(ActionListener) - 类 java.awt.TrayIcon 中的方法
添加指定的动作侦听器，以接收发自此 TrayIcon 的 ActionEvent。
addActionListener(ActionListener) - 类 javax.swing.AbstractButton 中的方法
将一个 ActionListener 添加到按钮中。
addActionListener(ActionListener) - 接口 javax.swing.ButtonModel 中的方法
向模型添加一个 ActionListener。
addActionListener(ActionListener) - 接口 javax.swing.ComboBoxEditor 中的方法
添加一个 ActionListener。
addActionListener(ActionListener) - 类 javax.swing.DefaultButtonModel 中的方法
向模型添加一个 ActionListener。
addActionListener(ActionListener) - 类 javax.swing.JComboBox 中的方法
添加 ActionListener。
addActionListener(ActionListener) - 类 javax.swing.JFileChooser 中的方法
向文件选择器添加一个 ActionListener。
addActionListener(ActionListener) - 类 javax.swing.JTextField 中的方法
添加指定的操作侦听器以从此文本字段接收操作事件。
addActionListener(ActionListener) - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
addActionListener(ActionListener) - 类 javax.swing.Timer 中的方法
将一个动作侦听器添加到 Timer。
addAdjustmentListener(AdjustmentListener) - 接口 java.awt.Adjustable 中的方法
添加侦听器，以便在可调整对象的值更改时接收调整事件。
addAdjustmentListener(AdjustmentListener) - 类 java.awt.Scrollbar 中的方法
添加指定的调整侦听器，以接收发自此滚动条的 AdjustmentEvent 实例。
addAdjustmentListener(AdjustmentListener) - 类 java.awt.ScrollPaneAdjustable 中的方法
添加指定的调整侦听器，以接收发自此 ScrollPaneAdjustable 的调整事件。
addAdjustmentListener(AdjustmentListener) - 类 javax.swing.JScrollBar 中的方法
添加一个 AdjustmentListener。
addAll(Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
将 Collection 添加到 Children（不受支持的）实现的集合，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
addAll(Collection<? extends E>) - 类 java.util.AbstractCollection 中的方法
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。
addAll(int, Collection<? extends E>) - 类 java.util.AbstractList 中的方法
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。
addAll(Collection<? extends E>) - 类 java.util.AbstractQueue 中的方法
将指定 collection 中的所有元素都添加到此队列中。
addAll(int, Collection<? extends E>) - 类 java.util.AbstractSequentialList 中的方法
在此列表中指定的位置上插入指定 collection 中的所有元素（可选操作）。
addAll(Collection<? extends E>) - 类 java.util.ArrayList 中的方法
按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。
addAll(int, Collection<? extends E>) - 类 java.util.ArrayList 中的方法
从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。
addAll(Collection<? extends E>) - 接口 java.util.Collection 中的方法
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。
addAll(Collection<? super T>, T...) - 类 java.util.Collections 中的静态方法
将所有指定元素添加到指定 collection 中。
addAll(Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中的所有元素添加此列表的尾部。
addAll(int, Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
从指定位置开始，将指定 collection 的所有元素插入此列表。
addAll(Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果此 set 中没有指定 collection 中的所有元素，则将它们都添加到此 set 中。
addAll(Collection<? extends E>) - 类 java.util.LinkedList 中的方法
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序。
addAll(int, Collection<? extends E>) - 类 java.util.LinkedList 中的方法
将指定 collection 中的所有元素从指定位置开始插入此列表。
addAll(Collection<? extends E>) - 接口 java.util.List 中的方法
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序（可选操作）。
addAll(int, Collection<? extends E>) - 接口 java.util.List 中的方法
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。
addAll(Collection<? extends E>) - 接口 java.util.Set 中的方法
如果 set 中没有指定 collection 中的所有元素，则将其添加到此 set 中（可选操作）。
addAll(Collection<? extends E>) - 类 java.util.TreeSet 中的方法
将指定 collection 中的所有元素添加到此 set 中。
addAll(Collection<? extends E>) - 类 java.util.Vector 中的方法
将指定 Collection 中的所有元素添加到此向量的末尾，按照指定 collection 的迭代器所返回的顺序添加这些元素。
addAll(int, Collection<? extends E>) - 类 java.util.Vector 中的方法
在指定位置将指定 Collection 中的所有元素插入到此向量中。
addAll(AccessibleRelation[]) - 类 javax.accessibility.AccessibleRelationSet 中的方法
将所有关系添加到现有关系集中。
addAll(AccessibleState[]) - 类 javax.accessibility.AccessibleStateSet 中的方法
将所有状态添加到现有状态集中。
addAll(AttributeList) - 类 javax.management.AttributeList 中的方法
将指定 AttributeList 中的所有元素追加到列表的末尾，元素的顺序是指定 AttributeList 的 Iterator 所返回的顺序。
addAll(int, AttributeList) - 类 javax.management.AttributeList 中的方法
将指定 AttributeList 中的所有元素插入此列表，从指定的位置开始插入，元素的顺序是指定 Attribute 的 Iterator 所返回的顺序。
addAll(Collection<?>) - 类 javax.management.AttributeList 中的方法
addAll(int, Collection<?>) - 类 javax.management.AttributeList 中的方法
addAll(RoleList) - 类 javax.management.relation.RoleList 中的方法
将指定 RoleList 中的所有元素追加到列表末尾，这些元素按指定 RoleList 的迭代器返回的顺序排列。
addAll(int, RoleList) - 类 javax.management.relation.RoleList 中的方法
从指定位置开始，将指定 RoleList 中的所有元素插入此列表，这些元素按指定 RoleList 的迭代器返回的顺序排列。
addAll(Collection<?>) - 类 javax.management.relation.RoleList 中的方法
addAll(int, Collection<?>) - 类 javax.management.relation.RoleList 中的方法
addAll(RoleUnresolvedList) - 类 javax.management.relation.RoleUnresolvedList 中的方法
将指定 RoleUnresolvedList 中的所有元素追加到列表末尾，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
addAll(int, RoleUnresolvedList) - 类 javax.management.relation.RoleUnresolvedList 中的方法
从指定位置开始，将指定 RoleUnresolvedList 中的所有元素插入此列表，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
addAll(Collection<?>) - 类 javax.management.relation.RoleUnresolvedList 中的方法
addAll(int, Collection<?>) - 类 javax.management.relation.RoleUnresolvedList 中的方法
addAll(Name) - 类 javax.naming.CompositeName 中的方法
按顺序将复合名称的组件添加到此复合名称的末尾。
addAll(int, Name) - 类 javax.naming.CompositeName 中的方法
按顺序将复合名称的组件添加到此复合名称中的指定位置。
addAll(Name) - 类 javax.naming.CompoundName 中的方法
按顺序将组合名称的组件添加到此组合名称的末尾。
addAll(int, Name) - 类 javax.naming.CompoundName 中的方法
按顺序将组合名称的组件添加到此组合名称中的指定位置。
addAll(Name) - 类 javax.naming.ldap.LdapName 中的方法
按顺序将名称的组件添加到此名称的末尾。
addAll(List<Rdn>) - 类 javax.naming.ldap.LdapName 中的方法
按顺序将名称的 RDN 添加到此名称的末尾。
addAll(int, Name) - 类 javax.naming.ldap.LdapName 中的方法
按顺序将名称的组件添加到此名称中的指定位置。
addAll(int, List<Rdn>) - 类 javax.naming.ldap.LdapName 中的方法
按顺序将名称的 RDN 添加到此名称中的指定位置。
addAll(Name) - 接口 javax.naming.Name 中的方法
按顺序将名称的组件添加到此名称的末尾。
addAll(int, Name) - 接口 javax.naming.Name 中的方法
按顺序将名称的组件添加到此名称中的指定位置。
addAll(AttributeSet) - 接口 javax.print.attribute.AttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAll(AttributeSet) - 接口 javax.print.attribute.DocAttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAll(AttributeSet) - 类 javax.print.attribute.HashAttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAll(AttributeSet) - 接口 javax.print.attribute.PrintJobAttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAll(AttributeSet) - 接口 javax.print.attribute.PrintRequestAttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAll(AttributeSet) - 接口 javax.print.attribute.PrintServiceAttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAllAbsent(Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中尚未包含在此列表中的所有元素添加列表的尾部。
addAncestorListener(AncestorListener) - 类 javax.swing.JComponent 中的方法
注册 listener，从而当组件或其任意祖先移动，或者变得可见或不可见时该侦听器将收到 AncestorEvent。
addAndGet(int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将给定值与当前值相加。
addAndGet(int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将给定值与索引 i 的元素相加。
addAndGet(T, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将给定值添加到此更新器管理的给定对象的字段当前值。
addAndGet(long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将给定值添加到当前值。
addAndGet(int, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将给定值添加到索引 i 的元素。
addAndGet(T, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将给定值添加到此更新器管理的给定对象的字段的当前值。
addAttachmentPart(AttachmentPart) - 类 javax.xml.soap.SOAPMessage 中的方法
将给定的 AttachmentPart 对象添加到此 SOAPMessage 对象。
addAttribute(AttributedCharacterIterator.Attribute, Object) - 类 java.text.AttributedString 中的方法
将一个属性添加到整个字符串中。
addAttribute(AttributedCharacterIterator.Attribute, Object, int, int) - 类 java.text.AttributedString 中的方法
将一个属性添加到字符串的子范围。
addAttribute(String, String, int, boolean, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将新属性添加到以前定义的可以被设置为任意值的元素中。
addAttribute(String, String, int, boolean, String, List<String>) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将新属性添加到以前定义的元素中，该元素将由一组枚举值定义。
addAttribute(String, String, int, boolean, String, String, String, boolean, boolean) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将新属性添加到以前定义的元素中，该元素将由一系列值定义。
addAttribute(String, String, int, boolean, int, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将新属性添加到以前定义的元素中，该元素将由值的列表定义。
addAttribute(Object, Object) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
向该元素添加一个属性。
addAttribute(AttributeSet, Object, Object) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
向给定属性集中添加一个属性，并返回新的有代表性的属性集。
addAttribute(AttributeSet, Object, Object) - 类 javax.swing.text.html.StyleSheet 中的方法
向给定集合添加属性，并返回新的表示方式的集合。
addAttribute(Object, Object) - 接口 javax.swing.text.MutableAttributeSet 中的方法
创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。
addAttribute(Object, Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
向列表添加属性。
addAttribute(AttributeSet, Object, Object) - 类 javax.swing.text.StyleContext 中的方法
向给定的集合中添加属性，并返回新的有代表性的集合。
addAttribute(Object, Object) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
添加属性。
addAttribute(Name, String) - 接口 javax.xml.soap.SOAPElement 中的方法
将带有指定名称和值的属性添加到此 SOAPElement 对象。
addAttribute(QName, String) - 接口 javax.xml.soap.SOAPElement 中的方法
将带有指定名称和值的属性添加到此 SOAPElement 对象。
addAttribute(String, String, String, String, String) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
将属性添回到列表的末尾，将其“指定的”标志设置为 true。
addAttribute(String, String, String) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 向属性列表添加属性。
addAttribute(String, String, String, String, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
将属性添加到列表的末尾。
addAttributeChangeNotificationListener(NotificationListener, String, Object) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
注册一个将 NotificationListener 接口实现为侦听器的对象。
addAttributeChangeNotificationListener(NotificationListener, String, Object) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
addAttributes(Map<? extends AttributedCharacterIterator.Attribute, ?>, int, int) - 类 java.text.AttributedString 中的方法
将属性集添加到字符串的子范围。
addAttributes(AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
向该元素添加一个属性集合。
addAttributes(AttributeSet, AttributeSet) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
向元素添加一组属性。
addAttributes(AttributeSet, AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
向元素添加属性集。
addAttributes(AttributeSet) - 接口 javax.swing.text.MutableAttributeSet 中的方法
创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。
addAttributes(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 中的方法
向列表添加属性集。
addAttributes(AttributeSet, AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
向元素添加属性集。
addAttributes(AttributeSet) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
将属性集添加到元素。
addAuxiliaryLookAndFeel(LookAndFeel) - 类 javax.swing.UIManager 中的静态方法
将 LookAndFeel 添加到辅助外观的列表中。
addAWTEventListener(AWTEventListener, long) - 类 java.awt.Toolkit 中的方法
添加一个 AWTEventListener，以接收与给定 eventMask 一致的系统范围内指派的所有 AWTEvent。
addBatch() - 接口 java.sql.PreparedStatement 中的方法
将一组参数添加到此 PreparedStatement 对象的批处理命令中。
addBatch(String) - 接口 java.sql.Statement 中的方法
将给定的 SQL 命令添加到此 Statement 对象的当前命令列表中。
addBeanContextMembershipListener(BeanContextMembershipListener) - 接口 java.beans.beancontext.BeanContext 中的方法
添加指定的 BeanContextMembershipListener，以便无论何时添加或移除一个子 Component，都可以接收来自此 BeanContext 的 BeanContextMembershipEvents。
addBeanContextMembershipListener(BeanContextMembershipListener) - 类 java.beans.beancontext.BeanContextSupport 中的方法
添加一个 BeanContextMembershipListener。
addBeanContextServicesListener(BeanContextServicesListener) - 接口 java.beans.beancontext.BeanContextServices 中的方法
将一个 BeanContextServicesListener 添加到此 BeanContext
addBeanContextServicesListener(BeanContextServicesListener) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
添加一个 BeanContextServicesListener。
addBody() - 接口 javax.xml.soap.SOAPEnvelope 中的方法
创建一个 SOAPBody 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPBody 对象。
addBodyElement(Name) - 接口 javax.xml.soap.SOAPBody 中的方法
使用指定名称创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
addBodyElement(QName) - 接口 javax.xml.soap.SOAPBody 中的方法
使用指定 QName 创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
addBooleanAttribute(String, String, boolean, boolean) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将新属性添加到以前定义的元素中，该元素将由枚举值 TRUE 和 FALSE 定义，数据类型为 DATATYPE_BOOLEAN。
addButtonComponents(Container, Object[], int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
创建表示 buttons 中每个对象的适当对象并将其添加到 container。
addCaretListener(CaretListener) - 类 javax.swing.text.JTextComponent 中的方法
添加插入符侦听器，以便侦听任何插入符的更改通知。
addCellEditorListener(CellEditorListener) - 类 javax.swing.AbstractCellEditor 中的方法
将一个 CellEditorListener 添加到侦听器列表中。
addCellEditorListener(CellEditorListener) - 接口 javax.swing.CellEditor 中的方法
当编辑器停止运作或取消编辑时，向被通知的列表添加一个侦听器。
addCellEditorListener(CellEditorListener) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
添加 CellEditorListener。
addCertificate(Certificate) - 类 java.security.Identity 中的方法
已过时。 为此 Identity 添加一个证书。
addCertPathChecker(PKIXCertPathChecker) - 类 java.security.cert.PKIXParameters 中的方法
向证书路径检查器列表中添加一个 PKIXCertPathChecker。
addCertStore(CertStore) - 类 java.security.cert.PKIXParameters 中的方法
将 CertStore 添加到查找证书和 CRL 所使用的 CertStore 列表末尾。
addChangeListener(ChangeListener) - 类 javax.swing.AbstractButton 中的方法
向按钮添加一个 ChangeListener。
addChangeListener(ChangeListener) - 类 javax.swing.AbstractSpinnerModel 中的方法
将一个 ChangeListener 添加到模型的侦听器列表中。
addChangeListener(ChangeListener) - 接口 javax.swing.BoundedRangeModel 中的方法
将一个 ChangeListener 添加到模型的侦听器列表中。
addChangeListener(ChangeListener) - 接口 javax.swing.ButtonModel 中的方法
向模型添加一个 ChangeListener。
addChangeListener(ChangeListener) - 接口 javax.swing.colorchooser.ColorSelectionModel 中的方法
在模型中添加作为更改侦听器的 listener。
addChangeListener(ChangeListener) - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
将一个 ChangeListener 添加到模型中。
addChangeListener(ChangeListener) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
添加一个 ChangeListener。
addChangeListener(ChangeListener) - 类 javax.swing.DefaultButtonModel 中的方法
向模型添加一个 ChangeListener。
addChangeListener(ChangeListener) - 类 javax.swing.DefaultSingleSelectionModel 中的方法
向按钮添加一个 ChangeListener。
addChangeListener(ChangeListener) - 类 javax.swing.JProgressBar 中的方法
将指定的 ChangeListener 添加到进度条。
addChangeListener(ChangeListener) - 类 javax.swing.JSlider 中的方法
将一个 ChangeListener 添加到滑块。
addChangeListener(ChangeListener) - 类 javax.swing.JSpinner 中的方法
为每次发生模型更改时要通知的列表添加侦听器。
addChangeListener(ChangeListener) - 类 javax.swing.JTabbedPane 中的方法
将一个 ChangeListener 添加到此选项卡窗格中。
addChangeListener(ChangeListener) - 类 javax.swing.JViewport 中的方法
将一个 ChangeListener 添加到每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表。
addChangeListener(ChangeListener) - 类 javax.swing.MenuSelectionManager 中的方法
向按钮添加 ChangeListener。
addChangeListener(ChangeListener) - 接口 javax.swing.SingleSelectionModel 中的方法
在模型中添加作为更改侦听侦听器的 listener。
addChangeListener(ChangeListener) - 接口 javax.swing.SpinnerModel 中的方法
向该模型的侦听器列表添加一个 ChangeListener。
addChangeListener(ChangeListener) - 接口 javax.swing.text.Caret 中的方法
添加作为跟踪任何插入符位置更改的侦听器。
addChangeListener(ChangeListener) - 类 javax.swing.text.DefaultCaret 中的方法
添加一个侦听器，以便对插入符位置改变进行跟踪。
addChangeListener(ChangeListener) - 接口 javax.swing.text.Style 中的方法
添加一个侦听器，以便随时跟踪属性的更改。
addChangeListener(ChangeListener) - 类 javax.swing.text.StyleContext 中的方法
添加一个侦听器，以跟踪何时添加或删除样式。
addChangeListener(ChangeListener) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
添加更改侦听器。
addChildElement(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将现有元素添加到给定父节点类型的合法子节点的列表中。
addChildElement(Name) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用给定 Name 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
addChildElement(QName) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用给定 QName 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
addChildElement(String) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用指定本地名称初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
addChildElement(String, String) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用指定本地名称和前缀初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
addChildElement(String, String, String) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用指定本地名称、前缀和 URI 初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
addChildElement(SOAPElement) - 接口 javax.xml.soap.SOAPElement 中的方法
将 SOAPElement 作为此 SOAPElement 实例的子级添加。
addChoosableFileFilter(FileFilter) - 类 javax.swing.JFileChooser 中的方法
向用户可选择的文件过滤器列表添加一个过滤器。
addChooserPanel(AbstractColorChooserPanel) - 类 javax.swing.JColorChooser 中的方法
将颜色选取器面板添加到颜色选取器。
addColumn(TableColumn) - 类 javax.swing.JTable 中的方法
将 aColumn 追加到此 JTable 的列模型所保持的列数组的尾部。
addColumn(TableColumn) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
将 aColumn 追加到 tableColumns 数组的结尾。
addColumn(Object) - 类 javax.swing.table.DefaultTableModel 中的方法
将一列添加到模型中。
addColumn(Object, Vector) - 类 javax.swing.table.DefaultTableModel 中的方法
将一列添加到模型中。
addColumn(Object, Object[]) - 类 javax.swing.table.DefaultTableModel 中的方法
将一列添加到模型中。
addColumn(TableColumn) - 接口 javax.swing.table.TableColumnModel 中的方法
将 aColumn 追加到 tableColumns 数组的结尾。
addColumnModelListener(TableColumnModelListener) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
添加表列模型事件的侦听器。
addColumnModelListener(TableColumnModelListener) - 接口 javax.swing.table.TableColumnModel 中的方法
为表列模型事件添加侦听器。
addColumnSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
将从 index0 到 index1 之间（包含两端）的列添加到当前选择中。
addComponent(Component) - 类 javax.swing.GroupLayout.Group 中的方法
将 Component 添加到此 Group。
addComponent(Component, int, int, int) - 类 javax.swing.GroupLayout.Group 中的方法
使用指定大小将 Component 添加到此 Group。
addComponent(Component) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
将 Component 添加到此 Group。
addComponent(Component, int, int, int) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
使用指定大小将 Component 添加到此 Group。
addComponent(Component, GroupLayout.Alignment) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
使用指定的对齐方式将 Component 添加到此 ParallelGroup。
addComponent(Component, GroupLayout.Alignment, int, int, int) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
使用指定的对齐方式和大小将 Component 添加到此 ParallelGroup。
addComponent(Component) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将 Component 添加到此 Group。
addComponent(boolean, Component) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将 Component 添加到此 Group。
addComponent(Component, int, int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
使用指定大小将 Component 添加到此 Group。
addComponent(boolean, Component, int, int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
使用指定大小将 Component 添加到此 Group。
addComponentListener(ComponentListener) - 类 java.awt.Component 中的方法
添加指定的组件侦听器，以接收发自此组件的组件事件。
addConnectionEventListener(ConnectionEventListener) - 接口 javax.sql.PooledConnection 中的方法
注册给定的事件侦听器，以便在此 PooledConnection 对象上发生事件时它将得到通知。
addConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - 接口 javax.management.remote.JMXConnector 中的方法
添加一个接收连接状态改变的侦听器。
addConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.remote.rmi.RMIConnector 中的方法
addConsumer(ImageConsumer) - 类 java.awt.image.FilteredImageSource 中的方法
将指定的 ImageConsumer 添加到对过滤图像的数据感兴趣的使用者列表。
addConsumer(ImageConsumer) - 接口 java.awt.image.ImageProducer 中的方法
为了在稍后的 Image 重构期间访问图像数据，向 ImageProducer 注册一个 ImageConsumer。
addConsumer(ImageConsumer) - 类 java.awt.image.MemoryImageSource 中的方法
将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表。
addConsumer(ImageConsumer) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表。
addContainerGap() - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
添加一个表示容器边缘和触到容器边框的组件之间首选间隙的元素。
addContainerGap(int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
使用指定大小添加一个元素，它表示容器的一个边缘和下一个或前一个 Component 之间的首选间隙。
addContainerListener(ContainerListener) - 类 java.awt.Container 中的方法
添加指定容器的侦听器，以接收来自此容器的容器事件。
addContent(char[], int, int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
添加某个具有当前字符属性的文本。
addContent(char[], int, int, boolean) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
添加某个具有当前字符属性的文本。
addControlButtons() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
addControllerEventListener(ControllerEventListener, int[]) - 接口 javax.sound.midi.Sequencer 中的方法
注册一个控件事件侦听器，以便在 sequencer 处理所请求的一种或多种类型的控制更改事件时接收通知。
addCSSAttribute(MutableAttributeSet, CSS.Attribute, String) - 类 javax.swing.text.html.StyleSheet 中的方法
将 CSS 属性添加到给定的集合。
addCSSAttributeFromHTML(MutableAttributeSet, CSS.Attribute, String) - 类 javax.swing.text.html.StyleSheet 中的方法
将 CSS 属性添加到给定的集合。
addCustomEntriesToTable(UIDefaults) - 类 javax.swing.plaf.metal.MetalTheme 中的方法
将特定于此主题的值添加到默认表。
addCustomEntriesToTable(UIDefaults) - 类 javax.swing.plaf.metal.OceanTheme 中的方法
将此主题的自定义条目添加到默认表中。
addDetail() - 接口 javax.xml.soap.SOAPFault 中的方法
创建可选的 Detail 对象，并将其设置为此 SOAPFault 对象的 Detail 对象。
addDetailEntry(Name) - 接口 javax.xml.soap.Detail 中的方法
使用给定名称创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
addDetailEntry(QName) - 接口 javax.xml.soap.Detail 中的方法
使用给定 QName 创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
addDirtyRegion(JComponent, int, int, int, int) - 类 javax.swing.RepaintManager 中的方法
在应刷新的组件列表中添加组件。
addDirtyRegion(Window, int, int, int, int) - 类 javax.swing.RepaintManager 中的方法
将 window 添加到需要重绘的 Component 列表。
addDirtyRegion(Applet, int, int, int, int) - 类 javax.swing.RepaintManager 中的方法
将 applet 添加到需要重绘的 Component 列表。
addDocument(Document) - 接口 javax.xml.soap.SOAPBody 中的方法
将 DOM Document 的根节点添加到此 SOAPBody 对象。
addDocumentListener(DocumentListener) - 类 javax.swing.text.AbstractDocument 中的方法
添加负责通知任何更改的文档侦听器。
addDocumentListener(DocumentListener) - 类 javax.swing.text.DefaultStyledDocument 中的方法
添加负责通知任何更改的文档侦听器。
addDocumentListener(DocumentListener) - 接口 javax.swing.text.Document 中的方法
注册给定的观察者以便开始接收文档发生更改的通知。
addDragGestureListener(DragGestureListener) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
注册一个新的 DragGestureListener。
addDragSourceListener(DragSourceListener) - 类 java.awt.dnd.DragSource 中的方法
将指定的 DragSourceListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动源事件。
addDragSourceListener(DragSourceListener) - 类 java.awt.dnd.DragSourceContext 中的方法
如果尚未将 DragSourceListener 添加到此 DragSourceContext，则添加一个。
addDragSourceMotionListener(DragSourceMotionListener) - 类 java.awt.dnd.DragSource 中的方法
将指定的 DragSourceMotionListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动移动事件。
addDropTargetListener(DropTargetListener) - 类 java.awt.dnd.DropTarget 中的方法
添加一个新的 DropTargetListener (UNICAST SOURCE)。
addEdit(UndoableEdit) - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
添加文档编辑。
addEdit(UndoableEdit) - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
此默认实现返回 false。
addEdit(UndoableEdit) - 类 javax.swing.undo.CompoundEdit 中的方法
如果此编辑为 inProgress，则接受 anEdit 并返回 true。
addEdit(UndoableEdit) - 接口 javax.swing.undo.UndoableEdit 中的方法
将 UndoableEdit 添加到此 UndoableEdit。
addEdit(UndoableEdit) - 类 javax.swing.undo.UndoManager 中的方法
如果可能，将一个 UndoableEdit 添加到此 UndoManager。
addEditor() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此公共方法是特定于实现的，应该为私有，不要调用或重写。
addElement(E) - 类 java.util.Vector 中的方法
将指定的组件添加到此向量的末尾，将其大小增加 1。
addElement(String, String, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
使用某个子策略（CHILD_POLICY_REPEAT 除外）将新元素类型添加到此元数据文档格式中。
addElement(String, String, int, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
使用子策略 CHILD_POLICY_REPEAT 将新元素类型添加到此元数据文档格式中。
addElement(Object) - 类 javax.swing.DefaultComboBoxModel 中的方法
addElement(Object) - 类 javax.swing.DefaultListModel 中的方法
将指定组件添加到此类表的末尾。
addElement(Object) - 接口 javax.swing.MutableComboBoxModel 中的方法
在模型的末尾添加项。
addEntry(Principal, AclEntry) - 接口 java.security.acl.Acl 中的方法
向此 ACL 中添加 ACL 项。
addEventListener(String, EventListener, boolean) - 接口 org.w3c.dom.events.EventTarget 中的方法
此方法允许在事件目标上注册事件侦听器。
addFault() - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
addFault(Name, String, Locale) - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
addFault(QName, String, Locale) - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
addFault(Name, String) - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
addFault(QName, String) - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
addFaultReasonText(String, Locale) - 接口 javax.xml.soap.SOAPFault 中的方法
追加或替换包含指定文本消息的 Reason Text 项，以及从 locale 派生的 xml:lang。
addFirst(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的开头。
addFirst(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头；如果当前没有空间可用，则抛出 IllegalStateException。
addFirst(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
addFirst(E) - 接口 java.util.Deque 中的方法
将指定元素插入此双端队列的开头（如果可以直接这样做而不违反容量限制）。
addFirst(E) - 类 java.util.LinkedList 中的方法
将指定元素插入此列表的开头。
addFlavorForUnencodedNative(String, DataFlavor) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
添加从单个 String native 到单个 DataFlavor 的映射。
addFlavorListener(FlavorListener) - 类 java.awt.datatransfer.Clipboard 中的方法
注册指定的 FlavorListener，以从此剪贴板接收 FlavorEvent。
addFocusListener(FocusListener) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
添加指定的焦点侦听器，以接收发自此组件的焦点事件。
addFocusListener(FocusListener) - 类 java.awt.Component 中的方法
添加指定的焦点侦听器，以便当此组件获得输入焦点时能够接收发自此组件的焦点事件。
addFocusListener(FocusListener) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
添加指定的焦点侦听器，以从此组件接收焦点事件。
addFocusListener(FocusListener) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
添加指定的焦点侦听器，以从此组件接收焦点事件。
addFocusListener(FocusListener) - 接口 javax.accessibility.AccessibleComponent 中的方法
添加指定的焦点侦听器，以接收来自此组件的焦点事件。
addFocusListener(FocusListener) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
addFocusListener(FocusListener) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
addFocusListener(FocusListener) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
addFocusListener(FocusListener) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
addGap(int) - 类 javax.swing.GroupLayout.Group 中的方法
将固定间隙添加到此 Group。
addGap(int, int, int) - 类 javax.swing.GroupLayout.Group 中的方法
将指定大小的间隙添加到此 Group。
addGap(int) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
将固定间隙添加到此 Group。
addGap(int, int, int) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
将指定大小的间隙添加到此 Group。
addGap(int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将固定间隙添加到此 Group。
addGap(int, int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将指定大小的间隙添加到此 Group。
addGroup(GroupLayout.Group) - 类 javax.swing.GroupLayout.Group 中的方法
将 Group 添加到此 Group。
addGroup(GroupLayout.Group) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
将 Group 添加到此 Group。
addGroup(GroupLayout.Alignment, GroupLayout.Group) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
使用指定的对齐方式将 Group 添加到此 ParallelGroup。
addGroup(GroupLayout.Group) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将 Group 添加到此 Group。
addGroup(boolean, GroupLayout.Group) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将 Group 添加到此 Group。
addHandler(Handler) - 类 java.util.logging.Logger 中的方法
添加一个日志 Handler 以接收日志记录消息。
addHandshakeCompletedListener(HandshakeCompletedListener) - 类 javax.net.ssl.SSLSocket 中的方法
注册一个事件侦听器来接收此连接上的 SSL 握手已经完成的通知。
addHeader(String, String) - 类 javax.xml.soap.MimeHeaders 中的方法
将带有指定名称和值的 MimeHeader 对象添加到此 MimeHeaders 对象的头列表。
addHeader() - 接口 javax.xml.soap.SOAPEnvelope 中的方法
创建一个 SOAPHeader 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPHeader 对象。
addHeaderElement(Name) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定名称初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addHeaderElement(QName) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定 qname 初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addHierarchyBoundsListener(HierarchyBoundsListener) - 类 java.awt.Component 中的方法
添加指定的层次结构边界侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构边界事件。
addHierarchyListener(HierarchyListener) - 类 java.awt.Component 中的方法
添加指定的层次结构侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构变化事件。
addHighlight(int, int, Highlighter.HighlightPainter) - 类 javax.swing.text.DefaultHighlighter 中的方法
向视图添加高亮显示。
addHighlight(int, int, Highlighter.HighlightPainter) - 接口 javax.swing.text.Highlighter 中的方法
向视图添加高亮显示。
addHyperlinkListener(HyperlinkListener) - 类 javax.swing.JEditorPane 中的方法
为了通知所有的更改（例如选中和进入某个链接）而添加一个超链接侦听器。
addIcon(Container) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
创建并添加 JLabel，它表示对 top 调用 getIcon 所返回的图标。
addIdentity(Identity) - 类 java.security.IdentityScope 中的方法
已过时。 向此身份作用域添加一个身份。
addIfAbsent(E) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
添加元素（如果不存在）。
addIIOReadProgressListener(IIOReadProgressListener) - 类 javax.imageio.ImageReader 中的方法
将 IIOReadProgressListener 添加到已注册的进度侦听器列表中。
addIIOReadUpdateListener(IIOReadUpdateListener) - 类 javax.imageio.ImageReader 中的方法
将 IIOReadUpdateListener 添加到已注册的更新侦听器列表中。
addIIOReadWarningListener(IIOReadWarningListener) - 类 javax.imageio.ImageReader 中的方法
将 IIOReadWarningListener 添加到已注册的警告侦听器的列表中。
addIIOWriteProgressListener(IIOWriteProgressListener) - 类 javax.imageio.ImageWriter 中的方法
将 IIOWriteProgressListener 添加到已注册的进度侦听器列表中。
addIIOWriteWarningListener(IIOWriteWarningListener) - 类 javax.imageio.ImageWriter 中的方法
将 IIOWriteWarningListener 添加到已注册的警告侦听器的列表中。
addImage(Image, int) - 类 java.awt.MediaTracker 中的方法
向此媒体跟踪器正在跟踪的图像列表添加一个图像。
addImage(Image, int, int, int) - 类 java.awt.MediaTracker 中的方法
向此媒体跟踪器正在跟踪的图像列表添加一个经过缩放的图像。
addImpl(Component, Object, int) - 类 java.awt.Container 中的方法
将指定组件添加到此容器的指定索引所在的位置上。
addImpl(Component, Object, int) - 类 java.awt.ScrollPane 中的方法
将指定的组件添加到此滚动窗格容器。
addImpl(Component, Object, int) - 类 javax.swing.AbstractButton 中的方法
将指定组件添加到此容器的指定索引所在的位置上，有关此方法的完整描述，请参阅 Container.addImpl(Component, Object, int)。
addImpl(Component, Object, int) - 类 javax.swing.CellRendererPane 中的方法
如果指定组件已经是此组件的子组件，则不必再操心去做任何事，堆栈顺序对于单元格渲染器组件而言无关紧要（CellRendererPane 不管怎样都不进行绘制）。
addImpl(Component, Object, int) - 类 javax.swing.JApplet 中的方法
添加指定的子 Component。
addImpl(Component, Object, int) - 类 javax.swing.JDesktopPane 中的方法
将指定组件添加到此容器的指定索引所在的位置上。
addImpl(Component, Object, int) - 类 javax.swing.JDialog 中的方法
添加指定的子 Component。
addImpl(Component, Object, int) - 类 javax.swing.JFrame 中的方法
添加指定的子 Component。
addImpl(Component, Object, int) - 类 javax.swing.JInternalFrame 中的方法
添加指定的子 Component。
addImpl(Component, Object, int) - 类 javax.swing.JLayeredPane 中的方法
addImpl(Component, Object, int) - 类 javax.swing.JRootPane 中的方法
重写以便将玻璃组件的位置强行设置成零位子级。
addImpl(Component, Object, int) - 类 javax.swing.JSplitPane 中的方法
将指定组件添加到此分隔窗格。
addImpl(Component, Object, int) - 类 javax.swing.JToolBar 中的方法
在添加 JButton 时，它最初被设置为 disabled。
addImpl(Component, Object, int) - 类 javax.swing.JViewport 中的方法
设置 JViewport 的轻量子对象，可以为 null。
addImpl(Component, Object, int) - 类 javax.swing.JWindow 中的方法
添加指定的子 Component。
addInputMethodListener(InputMethodListener) - 类 java.awt.Component 中的方法
添加指定的输入方法侦听器，以接收发自此组件的输入方法事件。
addInputMethodListener(InputMethodListener) - 类 javax.swing.text.JTextComponent 中的方法
addInternal(EventListener, EventListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从正添加的侦听器 a 和侦听器 b 中一起返回得到的多路广播侦听器。
addInternalFrameListener(InternalFrameListener) - 类 javax.swing.JInternalFrame 中的方法
添加指定的侦听器，以从此内部窗体接收内部窗体事件。
addInvalidComponent(JComponent) - 类 javax.swing.RepaintManager 中的方法
按照布局需要标记组件，并将事件指派线程的 runnable 排入队列，该线程将验证组件的第一个 isValidateRoot() 祖先。
addIssuer(X500Principal) - 类 java.security.cert.X509CRLSelector 中的方法
向 issuerNames 标准中添加名称。
addIssuerName(String) - 类 java.security.cert.X509CRLSelector 中的方法
已过时，使用 X509CRLSelector.addIssuer(X500Principal) 或 X509CRLSelector.addIssuerName(byte[]) 替代。
addIssuerName(byte[]) - 类 java.security.cert.X509CRLSelector 中的方法
向 issuerNames 标准中添加名称。
addItem(String) - 类 java.awt.Choice 中的方法
如果对于 Java 2 platform v1.1 已过时，请使用 add 方法替换。
addItem(String) - 类 java.awt.List 中的方法
已过时。 由 add(String) 取代。
addItem(String, int) - 类 java.awt.List 中的方法
已过时。 由 add(String, int) 取代。
addItem(Object) - 类 javax.swing.JComboBox 中的方法
为项列表添加项。
addItemListener(ItemListener) - 类 java.awt.Checkbox 中的方法
添加指定的项侦听器，以接收来自此复选框的项事件。
addItemListener(ItemListener) - 类 java.awt.CheckboxMenuItem 中的方法
添加指定的项侦听器，以接收发自此复选框菜单项的项事件。
addItemListener(ItemListener) - 类 java.awt.Choice 中的方法
添加指定的项侦听器，以接收发自此 Choice 菜单的项事件。
addItemListener(ItemListener) - 接口 java.awt.ItemSelectable 中的方法
添加侦听器，以接收用户更改项状态时的项事件。
addItemListener(ItemListener) - 类 java.awt.List 中的方法
添加指定的项侦听器以接收此列表的项事件。
addItemListener(ItemListener) - 类 javax.swing.AbstractButton 中的方法
将一个 ItemListener 添加到 checkbox 中。
addItemListener(ItemListener) - 接口 javax.swing.ButtonModel 中的方法
向模型添加一个 ItemListener。
addItemListener(ItemListener) - 类 javax.swing.DefaultButtonModel 中的方法
向模型添加一个 ItemListener。
addItemListener(ItemListener) - 类 javax.swing.JComboBox 中的方法
添加 ItemListener。
ADDITION - 接口 org.w3c.dom.events.MutationEvent 中的静态变量
只添加 Attr。
AdditionalComments - 类 javax.swing.text.html.HTMLDocument 中的静态变量
文档属性键值。
addKeyEventDispatcher(KeyEventDispatcher) - 类 java.awt.KeyboardFocusManager 中的方法
将 KeyEventDispatcher 添加到此 KeyboardFocusManager 的调度程序链中。
addKeyEventPostProcessor(KeyEventPostProcessor) - 类 java.awt.KeyboardFocusManager 中的方法
将 KeyEventPostProcessor 添加到此 KeyboardFocusManager 的后处理器链中。
addKeyListener(KeyListener) - 类 java.awt.Component 中的方法
添加指定的按键侦听器，以接收发自此组件的按键事件。
addKeymap(String, Keymap) - 类 javax.swing.text.JTextComponent 中的静态方法
将一个新 keymap 添加到 keymap 层次结构。
addLast(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的末尾。
addLast(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾；如果当前没有空间可用，则抛出 IllegalStateException。
addLast(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
addLast(E) - 接口 java.util.Deque 中的方法
将指定元素插入此双端队列的末尾（如果可以直接这样做而不违反容量限制）。
addLast(E) - 类 java.util.LinkedList 中的方法
将指定元素添加到此列表的结尾。
addLayoutComponent(Component, Object) - 类 java.awt.BorderLayout 中的方法
使用指定的约束对象将指定组件添加到布局中。
addLayoutComponent(String, Component) - 类 java.awt.BorderLayout 中的方法
已过时。 由 addLayoutComponent(Component, Object) 取代。
addLayoutComponent(Component, Object) - 类 java.awt.CardLayout 中的方法
将指定的组件添加到此卡片布局的内部名称表。
addLayoutComponent(String, Component) - 类 java.awt.CardLayout 中的方法
已过时。 由 addLayoutComponent(Component, Object) 取代。
addLayoutComponent(String, Component) - 类 java.awt.FlowLayout 中的方法
将指定的组件添加到布局中。
addLayoutComponent(String, Component) - 类 java.awt.GridBagLayout 中的方法
无效，因为此布局管理器不使用每组件字符串。
addLayoutComponent(Component, Object) - 类 java.awt.GridBagLayout 中的方法
使用指定 constraints 对象将指定组件添加到布局中。
addLayoutComponent(String, Component) - 类 java.awt.GridLayout 中的方法
将具有指定名称的指定组件添加到布局。
addLayoutComponent(String, Component) - 接口 java.awt.LayoutManager 中的方法
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
addLayoutComponent(Component, Object) - 接口 java.awt.LayoutManager2 中的方法
使用指定约束对象，将指定组件添加到布局。
addLayoutComponent(String, Component) - 类 javax.swing.BoxLayout 中的方法
此类不使用。
addLayoutComponent(Component, Object) - 类 javax.swing.BoxLayout 中的方法
此类不使用。
addLayoutComponent(String, Component) - 类 javax.swing.GroupLayout 中的方法
已将 Component 添加到父容器的通知。
addLayoutComponent(Component, Object) - 类 javax.swing.GroupLayout 中的方法
已将 Component 添加到父容器的通知。
addLayoutComponent(String, Component) - 类 javax.swing.JRootPane.RootLayout 中的方法
addLayoutComponent(Component, Object) - 类 javax.swing.JRootPane.RootLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
此 LayoutManager 方法不执行任何操作。
addLayoutComponent(String, Component) - 类 javax.swing.OverlayLayout 中的方法
将指定的组件添加到布局中。
addLayoutComponent(Component, Object) - 类 javax.swing.OverlayLayout 中的方法
使用指定的约束对象将指定组件添加到布局中。
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
在 place 位置添加组件。
addLayoutComponent(Component, Object) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
使用指定的约束对象将指定组件添加到布局中。
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.ScrollPaneLayout 中的方法
将指定的组件添加到布局中。
addLayoutComponent(String, Component) - 类 javax.swing.SpringLayout 中的方法
无效，因为此布局管理器不使用每组件字符串。
addLayoutComponent(Component, Object) - 类 javax.swing.SpringLayout 中的方法
如果 constraints 是 SpringLayout.Constraints 的一个实例，则将该约束与指定组件相关联。
addLayoutComponent(String, Component) - 类 javax.swing.ViewportLayout 中的方法
将指定的组件添加到布局中。
addLineListener(LineListener) - 接口 javax.sound.sampled.Line 中的方法
将侦听器添加到此行。
addListDataListener(ListDataListener) - 类 javax.swing.AbstractListModel 中的方法
将某个侦听器添加到每次更改数据模型都要通知的列表。
addListDataListener(ListDataListener) - 接口 javax.swing.ListModel 中的方法
将一个侦听器添加到每次在数据模型发生更改时都得到通知的列表。
addListSelectionListener(ListSelectionListener) - 类 javax.swing.DefaultListSelectionModel 中的方法
将侦听器添加到每次在选择发生更改时都得到通知的列表。
addListSelectionListener(ListSelectionListener) - 类 javax.swing.JList 中的方法
将侦听器添加到列表，每次选择发生更改时将获得通知；这是侦听选择状态更改的首选方式。
addListSelectionListener(ListSelectionListener) - 接口 javax.swing.ListSelectionModel 中的方法
将侦听器添加到每次在选择发生更改时都得到通知的列表。
addLogger(Logger) - 类 java.util.logging.LogManager 中的方法
添加指定的 logger。
addMailcap(String) - 类 javax.activation.MailcapCommandMap 中的方法
将条目添加到注册表。
addMember(Principal) - 接口 java.security.acl.Group 中的方法
向组中添加指定的成员。
addMenuDragMouseListener(MenuDragMouseListener) - 类 javax.swing.JMenuItem 中的方法
将 MenuDragMouseListener 添加到菜单项。
addMenuKeyListener(MenuKeyListener) - 类 javax.swing.JMenuItem 中的方法
将 MenuKeyListener 添加到菜单项。
addMenuKeyListener(MenuKeyListener) - 类 javax.swing.JPopupMenu 中的方法
将 MenuKeyListener 添加到弹出菜单。
addMenuListener(MenuListener) - 类 javax.swing.JMenu 中的方法
添加菜单事件的侦听器。
addMessageComponents(Container, GridBagConstraints, Object, int, boolean) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
创建表示 msg 的适当对象并将其置于 container 中。
addMetaEventListener(MetaEventListener) - 接口 javax.sound.midi.Sequencer 中的方法
注册一个元事件侦听器，以便在 sequence 中遇到元事件并由此 sequencer 处理时接收通知。
addMimeHeader(String, String) - 类 javax.xml.soap.AttachmentPart 中的方法
将带有指定名称和值的 MIME 头添加到此 AttachmentPart 对象。
addMimeHeader(String, String) - 类 javax.xml.soap.SOAPPart 中的方法
使用指定名称和值创建 MimeHeader 对象，并将其添加到此 SOAPPart 对象。
addMimeTypes(String) - 类 javax.activation.MimetypesFileTypeMap 中的方法
将 MIME 类型值预先添加到注册表。
addMouseListener(MouseListener) - 类 java.awt.Component 中的方法
添加指定的鼠标侦听器，以接收发自此组件的鼠标事件。
addMouseListener(MouseListener) - 类 java.awt.TrayIcon 中的方法
添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标事件。
addMouseMotionListener(MouseMotionListener) - 类 java.awt.Component 中的方法
添加指定的鼠标移动侦听器，以接收发自此组件的鼠标移动事件。
addMouseMotionListener(MouseMotionListener) - 类 java.awt.TrayIcon 中的方法
添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标移动事件。
addMouseWheelListener(MouseWheelListener) - 类 java.awt.Component 中的方法
添加指定的鼠标滚轮侦听器，以接收发自此组件的鼠标滚轮事件。
addMtomAttachment(DataHandler, String, String) - 类 javax.xml.bind.attachment.AttachmentMarshaller 中的方法
将用于优化二进制存储的 MIME 内容 data 作为附件。
addMtomAttachment(byte[], int, int, String, String, String) - 类 javax.xml.bind.attachment.AttachmentMarshaller 中的方法
将用于优化二进制存储的二进制 data 作为附件。
addNamespaceDeclaration(String, String) - 接口 javax.xml.soap.SOAPElement 中的方法
将带有指定前缀和 URI 的名称空间声明添加到此 SOAPElement 对象。
addNamingListener(Name, int, NamingListener) - 接口 javax.naming.event.EventContext 中的方法
添加接收命名事件的侦听器，这些事件在目标和范围所标识的对象发生更改时触发。
addNamingListener(String, int, NamingListener) - 接口 javax.naming.event.EventContext 中的方法
添加接收命名事件的侦听器，这些事件在目标名称和范围指定的对象发生更改时触发。
addNamingListener(Name, String, SearchControls, NamingListener) - 接口 javax.naming.event.EventDirContext 中的方法
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。
addNamingListener(String, String, SearchControls, NamingListener) - 接口 javax.naming.event.EventDirContext 中的方法
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。
addNamingListener(Name, String, Object[], SearchControls, NamingListener) - 接口 javax.naming.event.EventDirContext 中的方法
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
addNamingListener(String, String, Object[], SearchControls, NamingListener) - 接口 javax.naming.event.EventDirContext 中的方法
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
addNodeChangeListener(NodeChangeListener) - 类 java.util.prefs.AbstractPreferences 中的方法
addNodeChangeListener(NodeChangeListener) - 类 java.util.prefs.Preferences 中的方法
注册指定侦听器以接收此节点的节点更改事件。
addNotification(String, String, Object, Date, long, long, boolean) - 类 javax.management.timer.Timer 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
addNotification(String, String, Object, Date, long, long) - 类 javax.management.timer.Timer 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
addNotification(String, String, Object, Date, long) - 类 javax.management.timer.Timer 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
addNotification(String, String, Object, Date) - 类 javax.management.timer.Timer 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
addNotification(String, String, Object, Date, long, long, boolean) - 接口 javax.management.timer.TimerMBean 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
addNotification(String, String, Object, Date, long, long) - 接口 javax.management.timer.TimerMBean 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
addNotification(String, String, Object, Date, long) - 接口 javax.management.timer.TimerMBean 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
addNotification(String, String, Object, Date) - 接口 javax.management.timer.TimerMBean 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - 接口 javax.management.MBeanServer 中的方法
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - 接口 javax.management.MBeanServer 中的方法
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - 接口 javax.management.MBeanServerConnection 中的方法
向已注册的 MBean 添加一个侦听器。
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - 接口 javax.management.MBeanServerConnection 中的方法
向已注册的 MBean 添加一个侦听器。
addNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.MBeanServerDelegate 中的方法
addNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
注册一个将 NotificationListener 接口实现为侦听器的对象。
addNotificationListener(NotificationListener, NotificationFilter, Object) - 接口 javax.management.NotificationBroadcaster 中的方法
在此 MBean 中添加一个侦听器。
addNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.NotificationBroadcasterSupport 中的方法
添加一个侦听器。
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
addNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.StandardEmitterMBean 中的方法
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
addNotify() - 类 java.awt.Button 中的方法
创建按钮的同位体。
addNotify() - 类 java.awt.Canvas 中的方法
创建 canvas 的同位体。
addNotify() - 类 java.awt.Checkbox 中的方法
创建 Checkbox 的同位体。
addNotify() - 类 java.awt.CheckboxMenuItem 中的方法
创建复选框项的同位体。
addNotify() - 类 java.awt.Choice 中的方法
创建 Choice 的同位体。
addNotify() - 类 java.awt.Component 中的方法
通过将此 Component 连接到一个本机屏幕资源使其成为可显示的。
addNotify() - 类 java.awt.Container 中的方法
通过将这个 Container 连接到本机屏幕资源，使其可以显示。
addNotify() - 类 java.awt.Dialog 中的方法
通过将此 Dialog 连接到本机屏幕资源，从而使其成为可显示的。
addNotify(ComponentPeer) - 类 java.awt.dnd.DropTarget 中的方法
通知 DropTarget 它已经与某个 Component 关联。
addNotify(DropTargetContextPeer) - 类 java.awt.dnd.DropTargetContext 中的方法
与 DropTargetContextPeer 关联时调用。
addNotify() - 类 java.awt.FileDialog 中的方法
创建文件对话框的同位体。
addNotify() - 类 java.awt.Frame 中的方法
通过将此窗体连接到本机屏幕资源，使其成为可显示的。
addNotify() - 类 java.awt.Label 中的方法
创建此标签的同位体。
addNotify() - 类 java.awt.List 中的方法
创建列表的同位体。
addNotify() - 类 java.awt.Menu 中的方法
创建该菜单的同位体。
addNotify() - 类 java.awt.MenuBar 中的方法
创建该菜单栏的同位体。
addNotify() - 类 java.awt.MenuItem 中的方法
创建该菜单项的同位体。
addNotify() - 类 java.awt.Panel 中的方法
创建 Panel 的同位体。
addNotify() - 类 java.awt.PopupMenu 中的方法
创建弹出式菜单的同位体。
addNotify() - 类 java.awt.Scrollbar 中的方法
创建 Scrollbar 的同位体。
addNotify() - 类 java.awt.ScrollPane 中的方法
创建滚动窗格的同位体。
addNotify() - 类 java.awt.TextArea 中的方法
创建 TextArea 的同位体。
addNotify() - 类 java.awt.TextComponent 中的方法
通过将此 Component 连接到一个本机屏幕资源，使其成为可显示的。
addNotify() - 类 java.awt.TextField 中的方法
创建 TextField 的同位体。
addNotify() - 类 java.awt.Window 中的方法
通过创建到本机屏幕资源的连接，使此窗口变得可显示。
addNotify() - 类 javax.swing.JComponent 中的方法
通知此组件它现在已有了一个父组件。
addNotify() - 类 javax.swing.JMenuBar 中的方法
重写 JComponent.addNotify 以向当前键盘管理器注册此菜单栏。
addNotify() - 类 javax.swing.JRootPane 中的方法
将本身注册为 SystemEventQueueUtils 的新的根窗格。
addNotify() - 类 javax.swing.JTable 中的方法
调用 configureEnclosingScrollPane 方法。
addNotify() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
addNotUnderstoodHeaderElement(QName) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定名称初始化的新的 NotUnderstood SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addObjectValue(String, Class<T>, boolean, T) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
addObjectValue(String, Class<T>, boolean, T, List<? extends T>) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
addObjectValue(String, Class<T>, T, Comparable<? super T>, Comparable<? super T>, boolean, boolean) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
addObjectValue(String, Class<?>, int, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
addObservedObject(ObjectName) - 类 javax.management.monitor.Monitor 中的方法
如果尚未显示此对象，则在观察到的 MBean 集中添加指定的对象。
addObservedObject(ObjectName) - 接口 javax.management.monitor.MonitorMBean 中的方法
将指定的对象添加到所观察的 MBean 集中。
addObserver(Observer) - 类 java.util.Observable 中的方法
如果观察者与集合中已有的观察者不同，则向对象的观察者集中添加此观察者。
addOwner(Principal, Principal) - 接口 java.security.acl.Owner 中的方法
添加一个所有者。
addPathToName(int, String) - 类 java.security.cert.X509CertSelector 中的方法
向 pathToNames 标准中添加一个名称。
addPathToName(int, byte[]) - 类 java.security.cert.X509CertSelector 中的方法
向 pathToNames 标准中添加一个名称。
addPermission(Permission) - 接口 java.security.acl.AclEntry 中的方法
向此 ACL 项添加指定的权限。
addPoint(int, int) - 类 java.awt.Polygon 中的方法
将指定的坐标追加到此 Polygon。
addPopupMenuListener(PopupMenuListener) - 类 javax.swing.JComboBox 中的方法
添加 PopupMenu 侦听器，该侦听器将侦听取自组合框弹出部分的通知消息。
addPopupMenuListener(PopupMenuListener) - 类 javax.swing.JPopupMenu 中的方法
添加 PopupMenu 侦听器。
addPort(QName, String, String) - 类 javax.xml.ws.Service 中的方法
为服务创建新的端口。
addPort(QName, String, String) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
为服务创建新的端口。
addPreferenceChangeListener(PreferenceChangeListener) - 类 java.util.prefs.AbstractPreferences 中的方法
addPreferenceChangeListener(PreferenceChangeListener) - 类 java.util.prefs.Preferences 中的方法
注册指定侦听器以接收此首选项节点的首选项更改事件。
addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
添加一个表示两个组件之间首选间隙的元素。
addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
添加一个表示两个组件之间首选间隙的元素。
addPreferredGap(LayoutStyle.ComponentPlacement) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
添加一个表示两个距离最近的组件之间首选间隙的元素。
addPreferredGap(LayoutStyle.ComponentPlacement, int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
添加一个表示两个距离最近的组件之间首选间隙的元素。
addPrintJobAttributeListener(PrintJobAttributeListener, PrintJobAttributeSet) - 接口 javax.print.DocPrintJob 中的方法
为指定属性中的更改注册一个侦听器。
addPrintJobListener(PrintJobListener) - 接口 javax.print.DocPrintJob 中的方法
为此 PrintJob 执行期间所出现的事件注册一个侦听器。
addPrintServiceAttributeListener(PrintServiceAttributeListener) - 接口 javax.print.PrintService 中的方法
为此 PrintService 上的事件注册一个侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
将 PropertyChangeListener 添加到侦听器列表中。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.Component 中的方法
向侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Component 中的方法
向指定属性的侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.Container.AccessibleAWTContainer 中的方法
向侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.Container 中的方法
将一个 PropertyChangeListener 添加到侦听器列表中。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Container 中的方法
将一个 PropertyChangeListener 添加到某个指定属性的侦听器列表中。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
将 PropertyChangeListener 添加到特定属性的侦听器列表。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.SystemTray 中的方法
将 PropertyChangeListener 添加到特定属性的侦听器列表中。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Toolkit 中的方法
为指定的桌面属性添加指定的属性更改侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.Window 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Window 中的方法
将 PropertyChangeListener 添加到某个特定属性的侦听器列表。
addPropertyChangeListener(String, PropertyChangeListener) - 接口 java.beans.beancontext.BeanContextChild 中的方法
将一个 PropertyChangeListener 添加到此 BeanContextChild 中，以便无论指定属性何时发生更改都可以接收一个 PropertyChangeEvent。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
为特定属性添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 接口 java.beans.Customizer 中的方法
注册一个用于 PropertyChange 事件的侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 java.beans.PropertyChangeSupport 中的方法
向侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.beans.PropertyChangeSupport 中的方法
为指定的属性向侦听器列表中添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 接口 java.beans.PropertyEditor 中的方法
注册一个用于 PropertyChange 事件的侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 java.beans.PropertyEditorSupport 中的方法
注册一个用于 PropertyChange 事件的侦听器。
addPropertyChangeListener(PropertyChangeListener) - 接口 java.util.jar.Pack200.Packer 中的方法
为属性映射上的 PropertyChange 事件注册一个侦听器。
addPropertyChangeListener(PropertyChangeListener) - 接口 java.util.jar.Pack200.Unpacker 中的方法
为属性映射上的 PropertyChange 事件注册一个侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 java.util.logging.LogManager 中的方法
添加重读日志属性时调用的事件侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.accessibility.AccessibleContext 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.AbstractAction 中的方法
向侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 接口 javax.swing.Action 中的方法
添加一个 PropertyChange 侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
将一个 PropertyChangeListener 添加到侦听器列表中。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
将一个 PropertyChangeListener 添加到侦听器列表中。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
将一个 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.SwingWorker 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.table.TableColumn 中的方法
向侦听器列表中添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
将一个 PropertyChangeListener 添加到侦听器列表中。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.UIDefaults 中的方法
向侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.UIManager 中的静态方法
将一个 PropertyChangeListener 添加到侦听器列表。
addProvider(Provider) - 类 java.security.Security 中的静态方法
将提供者添加到下一个可用位置。
addProviderAtEnd(Provider, Oid) - 类 org.ietf.jgss.GSSManager 中的方法
此方法用于向 GSSManager 指示，如果没有其他的提供者支持指定的机制，则应用程序将使用特定的提供者。
addProviderAtFront(Provider, Oid) - 类 org.ietf.jgss.GSSManager 中的方法
此方法用来向 GSSManager 表示，当支持是指定的机制所需要的支持时，应用程序希望优先于其他所有提供者使用特定的提供者。
addRelation(ObjectName) - 类 javax.management.relation.RelationService 中的方法
作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
addRelation(ObjectName) - 接口 javax.management.relation.RelationServiceMBean 中的方法
作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
addRelationType(RelationType) - 类 javax.management.relation.RelationService 中的方法
作为关系类型添加给定的对象。
addRelationType(RelationType) - 接口 javax.management.relation.RelationServiceMBean 中的方法
作为关系类型添加给定的对象。
addRenderingHints(Map<?, ?>) - 类 java.awt.Graphics2D 中的方法
为呈现算法设置任意数量的首选项值。
addRequestProperty(String, String) - 类 java.net.URLConnection 中的方法
添加由键值对指定的一般请求属性。
addResourceBundle(String) - 类 javax.swing.UIDefaults 中的方法
将一个资源包添加到从中搜索本地化值的资源包的列表中。
address() - 类 java.net.Proxy 中的方法
返回代理的套接字地址，如果其为直接连接，则返回 null。
address - 类 java.net.SocketImpl 中的变量
此套接字的远程端点的 IP 地址。
ADDRESS - 类 javax.swing.text.html.HTML.Tag 中的静态变量
AddressHelper - org.omg.CosNaming.NamingContextExtPackage 中的 类
地址是以 String 形式表示的主机和端口信息。
AddressHelper() - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 的构造方法
addRoleInfo(RoleInfo) - 类 javax.management.relation.RelationTypeSupport 中的方法
添加角色信息。
addRow(Vector) - 类 javax.swing.table.DefaultTableModel 中的方法
添加一行到模型的结尾。
addRow(Object[]) - 类 javax.swing.table.DefaultTableModel 中的方法
添加一行到模型的结尾。
addRowSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
将从 index0 到 index1 之间（包含两端）的行添加到当前选择中。
addRowSet(Joinable) - 接口 javax.sql.rowset.JoinRowSet 中的方法
将给定的 RowSet 对象添加到此 JoinRowSet 对象。
addRowSet(RowSet, int) - 接口 javax.sql.rowset.JoinRowSet 中的方法
将给定的 RowSet 对象添加到此 JoinRowSet 对象，并将指定的列设置为 RowSet 对象的匹配列。
addRowSet(RowSet, String) - 接口 javax.sql.rowset.JoinRowSet 中的方法
将 rowset 添加到此 JoinRowSet 对象，并将指定的列设置为匹配列。
addRowSet(RowSet[], int[]) - 接口 javax.sql.rowset.JoinRowSet 中的方法
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列索引数组中的匹配列。
addRowSet(RowSet[], String[]) - 接口 javax.sql.rowset.JoinRowSet 中的方法
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列名数组中的匹配列。
addRowSetListener(RowSetListener) - 接口 javax.sql.RowSet 中的方法
注册给定侦听器，以便此 RowSet 对象上发生事件时将得到通知。
addRowSetListener(RowSetListener) - 类 javax.sql.rowset.BaseRowSet 中的方法
只要在此 RowSet 对象上发生事件，就将通知该侦听器。
addRowSorterListener(RowSorterListener) - 类 javax.swing.RowSorter 中的方法
添加一个 RowSorterListener 来接收有关此 RowSorter 的通知。
addrs - 类 javax.naming.Reference 中的变量
包含此 Reference 中所包含的地址。
addrType - 类 javax.naming.RefAddr 中的变量
包含此地址的类型。
addRule(String) - 类 javax.swing.text.html.StyleSheet 中的方法
向 sheet 添加规则集合。
addSelectionInterval(int, int) - 类 javax.swing.DefaultListSelectionModel 中的方法
将选择更改为当前选择与 index0 和 index1（包括）之间索引的并集。
addSelectionInterval(int, int) - 类 javax.swing.JList 中的方法
将选择设置为指定间隔与当前选择的并集。
addSelectionInterval(int, int) - 类 javax.swing.JTree 中的方法
将 index0 和 index1（包含）之间的路径添加到该选择。
addSelectionInterval(int, int) - 接口 javax.swing.ListSelectionModel 中的方法
将选择更改为当前选择与 index0 和 index1 之间（包括两者）索引的并集。
addSelectionPath(TreePath) - 类 javax.swing.JTree 中的方法
将由指定的 TreePath 标识的节点添加到当前选择。
addSelectionPath(TreePath) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
将路径添加到当前的 selection 中。
addSelectionPath(TreePath) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
将路径添加到当前的选择中。
addSelectionPaths(TreePath[]) - 类 javax.swing.JTree 中的方法
将路径数组中的每个路径添加到当前选择。
addSelectionPaths(TreePath[]) - 类 javax.swing.JTree.EmptySelectionModel 中的方法
一个未添加任何内容的 null 实现。
addSelectionPaths(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
向当前的 selection 中添加路径。
addSelectionPaths(TreePath[]) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
向当前的选择中添加路径。
addSelectionRow(int) - 类 javax.swing.JTree 中的方法
将指定行处的路径添加到当前选择。
addSelectionRows(int[]) - 类 javax.swing.JTree 中的方法
将每个指定行处的路径添加到当前选择。
addSeparator() - 类 java.awt.Menu 中的方法
将一个分隔线或连字符添加到菜单的当前位置。
addSeparator() - 类 javax.swing.JMenu 中的方法
将新分隔符追加到菜单的末尾。
addSeparator() - 类 javax.swing.JPopupMenu 中的方法
将新分隔符添加到菜单的末尾。
addSeparator() - 类 javax.swing.JToolBar 中的方法
将默认大小的分隔符添加到工具栏的末尾。
addSeparator(Dimension) - 类 javax.swing.JToolBar 中的方法
将指定大小的分隔符添加到工具栏的末尾。
addService(Class, BeanContextServiceProvider) - 接口 java.beans.beancontext.BeanContextServices 中的方法
向此 BeanContext 添加服务。
addService(Class, BeanContextServiceProvider) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
添加服务。
addService(Class, BeanContextServiceProvider, boolean) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
添加服务。
addShutdownHook(Thread) - 类 java.lang.Runtime 中的方法
注册新的虚拟机来关闭钩子。
addSingletonComponent(Component, Component) - 类 javax.swing.ScrollPaneLayout 中的方法
移除现有组件。
addSource(Object) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个图像添加到源列表的末尾。
addSource(DOMImplementationSource) - 类 org.w3c.dom.bootstrap.DOMImplementationRegistry 中的方法
注册实现。
addSpecialElement(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
添加基本上完全是在属性集中指定的内容。
addStatementEventListener(StatementEventListener) - 接口 javax.sql.PooledConnection 中的方法
向此 PooledConnection 对象注册一个 StatementEventListener。
addStyle(String, Style) - 类 javax.swing.JTextPane 中的方法
将一个新样式添加到逻辑样式层次结构中。
addStyle(String, Style) - 类 javax.swing.text.DefaultStyledDocument 中的方法
向逻辑样式层次结构中添加新样式。
addStyle(String, Style) - 类 javax.swing.text.StyleContext 中的方法
将新的样式添加到样式层次中。
addStyle(String, Style) - 接口 javax.swing.text.StyledDocument 中的方法
向逻辑样式层次中添加新样式。
addStyleSheet(StyleSheet) - 类 javax.swing.text.html.StyleSheet 中的方法
将 StyleSheet ss 中的规则添加到接收者的规则中。
addSubComponents() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
addSubComponents() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
重写父级的方法，避免创建一个菜单栏。
addSubjectAlternativeName(int, String) - 类 java.security.cert.X509CertSelector 中的方法
向 subjectAlternativeNames 标准中添加一个名称。
addSubjectAlternativeName(int, byte[]) - 类 java.security.cert.X509CertSelector 中的方法
向 subjectAlternativeNames 标准中添加一个名称。
addSwaRefAttachment(DataHandler) - 类 javax.xml.bind.attachment.AttachmentMarshaller 中的方法
将 MIME data 作为附件添加，并返回附件的内容 id（即 cid）。
addSystemMenuItems(JMenu) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
addSystemMenuItems(JMenu) - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
重写父级的方法，使其不执行任何操作。
addTab(String, Icon, Component, String) - 类 javax.swing.JTabbedPane 中的方法
添加由 title 和/或 icon 表示的 component 和 tip，其中任意一个都可以为 null。
addTab(String, Icon, Component) - 类 javax.swing.JTabbedPane 中的方法
添加一个由 title 和/或 icon 表示的 component，其任意一个都可以为 null。
addTab(String, Component) - 类 javax.swing.JTabbedPane 中的方法
添加一个由 title 表示，且没有图标的 component。
addTableModelListener(TableModelListener) - 类 javax.swing.table.AbstractTableModel 中的方法
每次数据模型发生更改时，就向被通知的列表添加一个侦听器。
addTableModelListener(TableModelListener) - 接口 javax.swing.table.TableModel 中的方法
每当数据模型发生更改时，就将一个侦听器添加到被通知的列表中。
addTag - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的变量
HTML 中的 Tag（从此 Tag 开始添加标记）。
addTask(Runnable) - 类 javax.swing.text.LayoutQueue 中的方法
添加一个任务，该任务不必立即执行，原因是其结果可能是不可见的。
addTextListener(TextListener) - 类 java.awt.TextComponent 中的方法
添加指定的文本事件侦听器，以接收此文本组件发出的文本事件。
addTextNode(String) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用给定 String 初始化的新 Text 对象，并将其添加到此 SOAPElement 对象。
addTileObserver(TileObserver) - 类 java.awt.image.BufferedImage 中的方法
添加一个 tile observer。
addTileObserver(TileObserver) - 接口 java.awt.image.WritableRenderedImage 中的方法
添加一个观察器。
addTo(Calendar) - 类 javax.xml.datatype.Duration 中的方法
将此持续时间添加到 Calendar 对象。
addTo(Date) - 类 javax.xml.datatype.Duration 中的方法
将此持续时间添加到 Date 对象。
addToEnvironment(String, Object) - 接口 javax.naming.Context 中的方法
将一个新环境属性添加到此上下文的环境中。
addToEnvironment(String, Object) - 类 javax.naming.InitialContext 中的方法
addTransformer(ClassFileTransformer, boolean) - 接口 java.lang.instrument.Instrumentation 中的方法
注册提供的转换器。
addTransformer(ClassFileTransformer) - 接口 java.lang.instrument.Instrumentation 中的方法
注册提供的转换器。
addTreeExpansionListener(TreeExpansionListener) - 类 javax.swing.JTree 中的方法
为 TreeExpansion 事件添加侦听器。
addTreeModelListener(TreeModelListener) - 类 javax.swing.tree.DefaultTreeModel 中的方法
为树更改后发布的 TreeModelEvent 添加侦听器。
addTreeModelListener(TreeModelListener) - 接口 javax.swing.tree.TreeModel 中的方法
为树更改后发布的 TreeModelEvent 添加侦听器。
addTreeSelectionListener(TreeSelectionListener) - 类 javax.swing.JTree 中的方法
为 TreeSelection 事件添加侦听器。
addTreeSelectionListener(TreeSelectionListener) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
向每次已选的 TreePaths 集合发生更改时都会得到通知的侦听器列表添加 x。
addTreeSelectionListener(TreeSelectionListener) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
向侦听器列表添加 x，每次选定的 TreePath 集合发生更改时，这些侦听器都会得到通知。
addTreeWillExpandListener(TreeWillExpandListener) - 类 javax.swing.JTree 中的方法
为 TreeWillExpand 事件添加侦听器。
addUndoableEditListener(UndoableEditListener) - 类 javax.swing.text.AbstractDocument 中的方法
添加负责通知任何更改的撤消侦听器。
addUndoableEditListener(UndoableEditListener) - 接口 javax.swing.text.Document 中的方法
注册给定的观察者以便开始接收文档发生不可撤消的编辑的通知。
addUndoableEditListener(UndoableEditListener) - 类 javax.swing.undo.UndoableEditSupport 中的方法
注册一个 UndoableEditListener。
addUnencodedNativeForFlavor(DataFlavor, String) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
添加从指定的 DataFlavor（和等于指定 DataFlavor 的所有 DataFlavor）到指定 String native 的映射。
addUpgradeHeaderElement(Iterator) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定的 SOAP URI 支持列表初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addUpgradeHeaderElement(String[]) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定 SOAP URI 支持数组初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addUpgradeHeaderElement(String) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定受支持 SOAP URI 初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addURL(URL) - 类 java.net.URLClassLoader 中的方法
将指定的 URL 添加到 URL 列表中，以便搜索类和资源。
addURL(URL) - 类 javax.management.loading.MLet 中的方法
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
addURL(String) - 类 javax.management.loading.MLet 中的方法
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
addURL(URL) - 接口 javax.management.loading.MLetMBean 中的方法
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
addURL(String) - 接口 javax.management.loading.MLetMBean 中的方法
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
addVetoableChangeListener(VetoableChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
将 VetoableChangeListener 添加到侦听器列表。
addVetoableChangeListener(String, VetoableChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
将 VetoableChangeListener 添加到特定属性的侦听器列表。
addVetoableChangeListener(String, VetoableChangeListener) - 接口 java.beans.beancontext.BeanContextChild 中的方法
将一个 VetoableChangeListener 添加到此 BeanContextChild，以便无论指定属性何时发生更改都可以接收事件。
addVetoableChangeListener(String, VetoableChangeListener) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
为特定属性添加一个 VetoableChangeListener。
addVetoableChangeListener(VetoableChangeListener) - 类 java.beans.VetoableChangeSupport 中的方法
向侦听器列表添加一个 VetoableListener。
addVetoableChangeListener(String, VetoableChangeListener) - 类 java.beans.VetoableChangeSupport 中的方法
为特定属性添加一个 VetoableChangeListener。
addVetoableChangeListener(VetoableChangeListener) - 类 javax.swing.JComponent 中的方法
向侦听器列表添加一个 VetoableChangeListener。
addWindowFocusListener(WindowFocusListener) - 类 java.awt.Window 中的方法
添加指定的窗口焦点侦听器，以从此窗口接收窗口事件。
addWindowListener(WindowListener) - 类 java.awt.Window 中的方法
添加指定的窗口侦听器，以从此窗口接收窗口事件。
addWindowStateListener(WindowStateListener) - 类 java.awt.Window 中的方法
添加指定的窗口状态侦听器，以从此窗口接收窗口事件。
Adjustable - java.awt 中的 接口
此接口用于那些具有可调整数值的对象，数值应包含在有限范围的值之内。
adjustAllocation(Shape) - 类 javax.swing.text.FieldView 中的方法
调整给定视图的分配区域，使其适合文本字段的分配区域。
adjustForGravity(GridBagConstraints, Rectangle) - 类 java.awt.GridBagLayout 中的方法
根据约束几何结构和填充将 x、y、宽度和高度四个字段调整为正确值。
AdjustForGravity(GridBagConstraints, Rectangle) - 类 java.awt.GridBagLayout 中的方法
此方法已过时，仅为提供向后兼容性；新代码应该调用 adjustForGravity 来代替。
ADJUSTMENT_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择调整事件的事件掩码。
ADJUSTMENT_FIRST - 类 java.awt.event.AdjustmentEvent 中的静态变量
标记调整事件 id 范围的第一个整数 id。
ADJUSTMENT_LAST - 类 java.awt.event.AdjustmentEvent 中的静态变量
标记调整事件 id 范围的最后一个整数 id。
ADJUSTMENT_VALUE_CHANGED - 类 java.awt.event.AdjustmentEvent 中的静态变量
调整值更改事件。
AdjustmentEvent - java.awt.event 中的 类
由 Adjustable 对象所发出的调整事件。
AdjustmentEvent(Adjustable, int, int, int) - 类 java.awt.event.AdjustmentEvent 的构造方法
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。
AdjustmentEvent(Adjustable, int, int, int, boolean) - 类 java.awt.event.AdjustmentEvent 的构造方法
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。
AdjustmentListener - java.awt.event 中的 接口
用于接收调整事件的侦听器接口。
adjustmentValueChanged(AdjustmentEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 adjustmentValueChanged 方法处理 adjustmentValueChanged 事件。
adjustmentValueChanged(AdjustmentEvent) - 接口 java.awt.event.AdjustmentListener 中的方法
在可调整的值发生更改时调用该方法。
adjustRow(FlowView, int, int, int) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
如有可能，调整给定行以使其适合布局区域。
adjustRow(ParagraphView.Row, int, int) - 类 javax.swing.text.ParagraphView 中的方法
如有可能，调整给定行以使其处于布局区域内。
adjustSizes(int, SizeRequirements[]) - 类 javax.swing.SizeRequirements 中的静态方法
按给定总量调整指定的大小数组。
adjustVisibility(Rectangle) - 类 javax.swing.text.DefaultCaret 中的方法
滚动关联的视图（如果有）以使插入符可见。
Adler32 - java.util.zip 中的 类
可用于计算数据流的 Adler-32 校验和的类。
Adler32() - 类 java.util.zip.Adler32 的构造方法
创建新的 Adler32 对象。
ADMIN_UIROLE - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个充当管理角色的 UI。
adoptNode(Node) - 接口 org.w3c.dom.Document 中的方法
试图把另一文档中的节点采用到此文档。
AEGEAN_NUMBERS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Aegean Numbers”Unicode 字符块的常量。
AffineTransform - java.awt.geom 中的 类
AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
AffineTransform() - 类 java.awt.geom.AffineTransform 的构造方法
构造一个表示恒等变换的新 AffineTransform。
AffineTransform(AffineTransform) - 类 java.awt.geom.AffineTransform 的构造方法
构造一个新 AffineTransform，让它作为指定 AffineTransform 对象的副本。
AffineTransform(float, float, float, float, float, float) - 类 java.awt.geom.AffineTransform 的构造方法
根据表示 3x3 变换矩阵 6 个可指定条目的 6 个浮点值构造一个新 AffineTransform。
AffineTransform(float[]) - 类 java.awt.geom.AffineTransform 的构造方法
根据一个浮点值数组构造一个新 AffineTransform，该数组要么表示 3x3 变换矩阵的 4 个非平移条目，要么表示 3x3 变换矩阵的 6 个可指定条目。
AffineTransform(double, double, double, double, double, double) - 类 java.awt.geom.AffineTransform 的构造方法
根据表示 3x3 变换矩阵 6 个可指定条目的 6 个双精度值构造一个新 AffineTransform。
AffineTransform(double[]) - 类 java.awt.geom.AffineTransform 的构造方法
根据双精度值数组构造一个新 AffineTransform，该数组要么表示 3x3 变换矩阵的 4 个非平移条目，要么表示它的 6 个可指定条目。
AffineTransformOp - java.awt.image 中的 类
此类使用仿射转换来执行从源图像或 Raster 中 2D 坐标到目标图像或 Raster 中 2D 坐标的线性映射。
AffineTransformOp(AffineTransform, RenderingHints) - 类 java.awt.image.AffineTransformOp 的构造方法
根据仿射转换构造 AffineTransformOp。
AffineTransformOp(AffineTransform, int) - 类 java.awt.image.AffineTransformOp 的构造方法
根据仿射转换和插值类型构造一个 AffineTransformOp。
after(Timestamp) - 类 java.sql.Timestamp 中的方法
指示此 Timestamp 对象是否晚于给定的 Timestamp 对象。
after(Object) - 类 java.util.Calendar 中的方法
判断此 Calendar 表示的时间是否在指定 Object 表示的时间之后，返回判断结果。
after(Date) - 类 java.util.Date 中的方法
测试此日期是否在指定日期之后。
AFTER_LAST_LINE - 类 java.awt.BorderLayout 中的静态变量
与 PAGE_END 同义。
AFTER_LINE_ENDS - 类 java.awt.BorderLayout 中的静态变量
与 LINE_END 同义。
afterExecute(Runnable, Throwable) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
基于完成执行给定 Runnable 所调用的方法。
afterLast() - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的末尾，正好位于最后一行之后。
afterMarshal(Object) - 类 javax.xml.bind.Marshaller.Listener 中的方法

将 source 编组到 XML 之后调用的回调方法。

afterOffset(int) - 类 java.awt.font.TextHitInfo 中的静态方法
在指定偏移量处创建一个与偏移量之后的字符关联的 TextHitInfo。
afterUnmarshal(Object, Object) - 类 javax.xml.bind.Unmarshaller.Listener 中的方法

将 XML 数据解组到 target 之后调用的回调方法。

AIFC - 类 javax.sound.sampled.AudioFileFormat.Type 中的静态变量
指定 AIFF-C 文件。
AIFF - 类 javax.sound.sampled.AudioFileFormat.Type 中的静态变量
指定 AIFF 文件。
ALAW - 类 javax.sound.sampled.AudioFormat.Encoding 中的静态变量
指定 a-law 编码数据。
ALERT - 类 javax.accessibility.AccessibleRole 中的静态变量
可用于就某事向用户报警的对象。
AlgorithmMethod - javax.xml.crypto 中的 接口
XML Security 规范中定义的算法的抽象表示。
AlgorithmParameterGenerator - java.security 中的 类
AlgorithmParameterGenerator 类用于生成将在某个特定算法中使用的参数集合。
AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi, Provider, String) - 类 java.security.AlgorithmParameterGenerator 的构造方法
创建一个 AlgorithmParameterGenerator 对象。
AlgorithmParameterGeneratorSpi - java.security 中的 类
此类为 AlgorithmParameterGenerator 类定义服务提供者接口 (SPI)，AlgorithmParameterGenerator 类用于生成在某个特定算法中使用的参数集合。
AlgorithmParameterGeneratorSpi() - 类 java.security.AlgorithmParameterGeneratorSpi 的构造方法
AlgorithmParameters - java.security 中的 类
此类用作密码参数的不透明表示形式。
AlgorithmParameters(AlgorithmParametersSpi, Provider, String) - 类 java.security.AlgorithmParameters 的构造方法
创建一个 AlgorithmParameters 对象。
AlgorithmParameterSpec - java.security.spec 中的 接口
加密参数的（透明）规范。
AlgorithmParametersSpi - java.security 中的 类
此类为 AlgorithmParameters 类定义服务提供者接口 (SPI)，AlgorithmParameters 类用于管理算法参数。
AlgorithmParametersSpi() - 类 java.security.AlgorithmParametersSpi 的构造方法
aliases() - 类 java.nio.charset.Charset 中的方法
返回包含此 charset 各个别名的集合。
aliases() - 类 java.security.KeyStore 中的方法
列出此 keystore 的所有别名。
ALIGN - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ALIGN_BAR - 类 javax.swing.text.TabStop 中的静态变量
ALIGN_CENTER - 类 javax.swing.text.StyleConstants 中的静态变量
段落对齐的可能值。
ALIGN_CENTER - 类 javax.swing.text.TabStop 中的静态变量
制表符后的字符所放置的位置：直到下一个制表符/新行的所有字符都以制表符位置为中心放置。
ALIGN_DECIMAL - 类 javax.swing.text.TabStop 中的静态变量
制表符后的字符对齐的方式：下一个数字/制表符/新行位于制表符位置，与 RIGHT_TAB 非常类似，仅包括了数字作为要查找的附加字符。
ALIGN_JUSTIFIED - 类 javax.swing.text.StyleConstants 中的静态变量
段落对齐的可能值。
ALIGN_LEFT - 类 javax.swing.text.StyleConstants 中的静态变量
段落对齐方式的可能值。
ALIGN_LEFT - 类 javax.swing.text.TabStop 中的静态变量
制表符后的字符所放置的位置。
ALIGN_RIGHT - 类 javax.swing.text.StyleConstants 中的静态变量
段落对齐的可能值。
ALIGN_RIGHT - 类 javax.swing.text.TabStop 中的静态变量
制表符后的字符所放置的位置：直到下一个制表符/新行的所有字符都以此位置结束。
alignment - 类 javax.swing.SizeRequirements 中的变量
对齐方式，指定为介于 0.0 和 1.0 之间的值，包含这两个边界值。
Alignment - 类 javax.swing.text.StyleConstants 中的静态变量
段落的对齐方式。
ALINK - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ALL - 类 java.awt.JobAttributes.DefaultSelectionType 中的静态变量
用于指定应该打印全部作业页面的 DefaultSelectionType 实例。
ALL - 类 java.util.logging.Level 中的静态变量
ALL 指示应该记录所有消息。
ALL_COLUMNS - 类 javax.swing.event.TableModelEvent 中的静态变量
指定一行或一些行中的所有列。
ALL_RANGES - 类 java.awt.font.NumericShaper 中的静态变量
标识所有的范围，用于完整的上下文成形。
ALL_STYLES - 类 java.util.Calendar 中的静态变量
指示所有风格名称的 getDisplayNames 的风格说明符，比如 "January" 和 "Jan"。
ALLBITS - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示现在已完成了一幅以前绘制的静态图像，并且可以其最终形式再次绘制它。
allKeys() - 类 javax.swing.ActionMap 中的方法
返回在此 ActionMap 及其父级中定义的键所组成的数组。
allKeys() - 类 javax.swing.InputMap 中的方法
返回在此 InputMap 及其父级中定义的 KeyStroke 组成的数组。
allNotesOff() - 接口 javax.sound.midi.MidiChannel 中的方法
关闭此通道上当前发声的所有音符。
allocate(int) - 类 java.nio.ByteBuffer 中的静态方法
分配一个新的字节缓冲区。
allocate(int) - 类 java.nio.CharBuffer 中的静态方法
分配新的字符缓冲区。
allocate(int) - 类 java.nio.DoubleBuffer 中的静态方法
分配新的 double 缓冲区。
allocate(int) - 类 java.nio.FloatBuffer 中的静态方法
分配新的 float 缓冲区。
allocate(int) - 类 java.nio.IntBuffer 中的静态方法
分配新的 int 缓冲区。
allocate(int) - 类 java.nio.LongBuffer 中的静态方法
分配新的 long 缓冲区。
allocate(int) - 类 java.nio.ShortBuffer 中的静态方法
分配新的 short 缓冲区。
allocate(XMLStreamReader) - 接口 javax.xml.stream.util.XMLEventAllocator 中的方法
此方法在给定 XMLStreamReader 当前状态的情况下分配事件。
allocate(XMLStreamReader, XMLEventConsumer) - 接口 javax.xml.stream.util.XMLEventAllocator 中的方法
此方法在给定 XMLStreamReader 当前状态的情况下分配一个事件或一个事件组，并将该事件或事件组添加给传入的使用者。
allocate_slot_id() - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
调用此方法来在 PortableInterceptor.Current 上分配槽 (slot)。
allocateArray(int) - 类 javax.swing.text.GapContent 中的方法
分配一个存储适当类型项的数组（由子类确定）。
allocateDirect(int) - 类 java.nio.ByteBuffer 中的静态方法
分配新的直接字节缓冲区。
ALLOCATOR - 类 javax.xml.stream.XMLInputFactory 中的静态变量
用于设置/获取分配器实现的属性。
allOf(Class<E>) - 类 java.util.EnumSet 中的静态方法
创建一个包含指定元素类型的所有元素的枚举 set。
ALLOW_UNASSIGNED - 类 java.net.IDN 中的静态变量
允许处理未分配代码点的标志。
allowCoreThreadTimeOut(boolean) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
如果在保持活动时间内没有任务到达，新任务到达时正在替换（如果需要），则设置控制核心线程是超时还是终止的策略。
ALLOWED_CLASSNAMES - 类 javax.management.openmbean.OpenType 中的静态变量
已过时。 使用 ALLOWED_CLASSNAMES_LIST 取代。
ALLOWED_CLASSNAMES_LIST - 类 javax.management.openmbean.OpenType 中的静态变量
开放数据值允许的 Java 类的完全限定名称的列表。
allowMultipleSelections() - 类 javax.security.auth.callback.ChoiceCallback 中的方法
获取布尔值，该布尔值确定是否允许从该 choices 列表进行多重选择。
allowsChildren - 类 javax.swing.tree.DefaultMutableTreeNode 中的变量
如果该节点可以有子节点，则为 true
allowsCoreThreadTimeOut() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
如果此池允许核心线程超时和终止，如果在 keepAlive 时间内没有任务到达，新任务到达时正在替换（如果需要），则返回 true。
allowsMultipleSelections() - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 isMultipleMode() 取代。
allowThreadSuspension(boolean) - 类 java.lang.ThreadGroup 中的方法
已过时。 此调用的定义取决于 ThreadGroup.suspend()，它被废弃了。更进一步地说，此调用的行为从不被指定。
allowUserInteraction - 类 java.net.URLConnection 中的变量
如果为 true，则在允许用户交互（例如弹出一个验证对话框）的上下文中对此 URL 进行检查。
AllPermission - java.security 中的 类
AllPermission 是暗含所有其他权限的权限。
AllPermission() - 类 java.security.AllPermission 的构造方法
创建新的 AllPermission 对象。
AllPermission(String, String) - 类 java.security.AllPermission 的构造方法
创建新的 AllPermission 对象。
allProceduresAreCallable() - 接口 java.sql.DatabaseMetaData 中的方法
获取当前用户是否可以调用 getProcedures 方法返回的所有过程。
allRowsChanged() - 类 javax.swing.DefaultRowSorter 中的方法
当底层模型的内容完全更改时，调用此方法。
allRowsChanged() - 类 javax.swing.RowSorter 中的方法
当底层模型的内容完全更改时，调用此方法。
allSoundOff() - 接口 javax.sound.midi.MidiChannel 中的方法
立即关闭通道上所有发声的音符，同时忽略当前 Instrument 的 Hold Pedal 状态和内部衰减率。
allTablesAreSelectable() - 接口 java.sql.DatabaseMetaData 中的方法
获取当前用户是否可以使用 SELECT 语句中的 getTables 方法返回的所有表。
ALPHABETIC_PRESENTATION_FORMS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Alphabetic Presentation Forms”Unicode 字符块的常量。
AlphaComposite - java.awt 中的 类
AlphaComposite 类实现一些基本的 alpha 合成规则，将源色与目标色组合，在图形和图像中实现混合和透明效果。
AlreadyBound - org.omg.CosNaming.NamingContextPackage 中的 异常
org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
AlreadyBound() - 异常 org.omg.CosNaming.NamingContextPackage.AlreadyBound 的构造方法
AlreadyBound(String) - 异常 org.omg.CosNaming.NamingContextPackage.AlreadyBound 的构造方法
AlreadyBoundException - java.rmi 中的 异常
如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
AlreadyBoundException() - 异常 java.rmi.AlreadyBoundException 的构造方法
构造不带指定详细消息的 AlreadyBoundException。
AlreadyBoundException(String) - 异常 java.rmi.AlreadyBoundException 的构造方法
构造带指定详细消息的 AlreadyBoundException。
AlreadyBoundHelper - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java。
AlreadyBoundHelper() - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 的构造方法
AlreadyBoundHolder - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java。
AlreadyBoundHolder() - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 的构造方法
AlreadyBoundHolder(AlreadyBound) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 的构造方法
AlreadyConnectedException - java.nio.channels 中的 异常
试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
AlreadyConnectedException() - 异常 java.nio.channels.AlreadyConnectedException 的构造方法
构造此类的一个实例。
alreadyNotified - 类 javax.management.monitor.Monitor 中的变量
已过时。 等效于 Monitor.alreadyNotifieds[0]。
alreadyNotifieds - 类 javax.management.monitor.Monitor 中的变量
已经通知的选定监视器错误。
ALT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ALT_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Alt 键的扩展修饰符常量。
ALT_GRAPH_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
AltGraph 键的扩展修饰符常量。
ALT_GRAPH_MASK - 类 java.awt.event.InputEvent 中的静态变量
AltGraph 键修饰符常量。
ALT_MASK - 类 java.awt.event.ActionEvent 中的静态变量
alt 修饰符。
ALT_MASK - 类 java.awt.Event 中的静态变量
此标志指示当事件发生时按下 Alt 键。
ALT_MASK - 类 java.awt.event.InputEvent 中的静态变量
Alt 键修饰符常量。
ALTERNATE - 类 java.util.FormattableFlags 中的静态变量
要求输出使用替换形式。
alternateAddTag - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的变量
HTML 中的替换 Tag，如果未找到 parentTag 但找到了 alternateParentTag，则从此替换 Tag 开始添加标记。
alternateParentTag - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的变量
如果未找到 parentTag，则要在文档中检查的替换 Tag。
altName - 异常 javax.naming.CannotProceedException 中的变量
包含已解析对象的名称，该名称相对于上下文 altNameCtx。
altNameCtx - 异常 javax.naming.CannotProceedException 中的变量
包含上下文，altName 是相对于该上下文指定的。
ALWAYS_UPDATE - 类 javax.swing.text.DefaultCaret 中的静态变量
指示无论文档更新是否是在事件调度线程中执行，始终根据文档更改更新插入符位置。
AM - 类 java.util.Calendar 中的静态变量
指示从午夜到中午之前这段时间的 Calendar.AM_PM 字段值。
AM_PM - 类 java.text.DateFormat.Field 中的静态变量
标识每日时间指示符（例如 "a.m." 或 "p.m."）的常量。
AM_PM - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示 HOUR 是在中午之前还是在中午之后。
AM_PM_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 AM_PM 字段的有用常量。
ANCESTOR_ADDED - 类 javax.swing.event.AncestorEvent 中的静态变量
某个祖先组件被添加到可见对象的层次结构中（使其可见），并且目前正显示该组件。
ANCESTOR_MOVED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示祖先 Container 被移动的事件 id。
ANCESTOR_MOVED - 类 javax.swing.event.AncestorEvent 中的静态变量
某个祖先组件更改了其屏幕位置。
ANCESTOR_REMOVED - 类 javax.swing.event.AncestorEvent 中的静态变量
某个祖先组件从可见对象的层次结构中被移除（隐藏它），并且不再显示该组件。
ANCESTOR_RESIZED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示祖先 Container 大小被调整的事件 id。
ancestorAdded(AncestorEvent) - 接口 javax.swing.event.AncestorListener 中的方法
当通过调用 setVisible(true) 或将其添加到组件层次结构中而使源组件或其祖先之一变得可见时调用。
AncestorEvent - javax.swing.event 中的 类
报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。
AncestorEvent(JComponent, int, Container, Container) - 类 javax.swing.event.AncestorEvent 的构造方法
构造一个 AncestorEvent 对象，以标识祖先组件显示状态的更改。
AncestorListener - javax.swing.event 中的 接口
AncestorListener 接口支持 JComponent 或其祖先之一发生更改时进行通知。
ancestorMoved(HierarchyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 ancestorMoved 方法处理 ancestorMoved 事件。
ancestorMoved(HierarchyEvent) - 类 java.awt.event.HierarchyBoundsAdapter 中的方法
移动源的祖先时调用。
ancestorMoved(HierarchyEvent) - 接口 java.awt.event.HierarchyBoundsListener 中的方法
移动源的祖先时调用。
ancestorMoved(AncestorEvent) - 接口 javax.swing.event.AncestorListener 中的方法
在源组件或其祖先之一被移动时调用。
ancestorRemoved(AncestorEvent) - 接口 javax.swing.event.AncestorListener 中的方法
当通过调用 setVisible(false) 或将其从组件层次结构中移除而使源组件或其祖先之一变得不可见时调用。
ancestorResized(HierarchyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 ancestorResized 方法处理 ancestorResized 事件。
ancestorResized(HierarchyEvent) - 类 java.awt.event.HierarchyBoundsAdapter 中的方法
调整源的祖先的大小时调用。
ancestorResized(HierarchyEvent) - 接口 java.awt.event.HierarchyBoundsListener 中的方法
调整源的祖先的大小时调用。
anchor - 类 java.awt.GridBagConstraints 中的变量
当组件小于其显示区域时使用此字段。
ANCHOR_SELECTION_PATH_PROPERTY - 类 javax.swing.JTree 中的静态变量
定位选择路径的绑定属性名称。
and(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this & val) 的 BigInteger。
and(BitSet) - 类 java.util.BitSet 中的方法
对此目标位 set 和参数位 set 执行逻辑与操作。
and(QueryExp, QueryExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，它是其他两个查询表达式的“与”。
andFilter(Iterable<? extends RowFilter<? super M, ? super I>>) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
andNot(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this & ~val) 的 BigInteger。
andNot(BitSet) - 类 java.util.BitSet 中的方法
清除此 BitSet 中所有的位，其相应的位在指定的 BitSet 中已设置。
annotateClass(Class<?>) - 类 java.io.ObjectOutputStream 中的方法
子类可以实现此方法，从而允许在流中存储类数据。
AnnotatedElement - java.lang.reflect 中的 接口
表示目前正在此 VM 中运行的程序的一个已注释元素。
annotateProxyClass(Class<?>) - 类 java.io.ObjectOutputStream 中的方法
子类可以实现此方法，从而在流中存储定制数据和动态代理类的描述符。
Annotation - java.lang.annotation 中的 接口
所有 annotation 类型都要扩展的公共接口。
Annotation - java.text 中的 类
如果文本属性具有 annotation 特征，则 Annotation 对象用作文本属性值的包装器。
Annotation(Object) - 类 java.text.Annotation 的构造方法
构造一条具有给定值（可能为 null）的 annotation 记录。
AnnotationFormatError - java.lang.annotation 中的 错误
当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。
AnnotationFormatError(String) - 错误 java.lang.annotation.AnnotationFormatError 的构造方法
构造具有指定详细消息的新 AnnotationFormatError。
AnnotationFormatError(String, Throwable) - 错误 java.lang.annotation.AnnotationFormatError 的构造方法
构造带指定详细消息和原因的新 AnnotationFormatError。
AnnotationFormatError(Throwable) - 错误 java.lang.annotation.AnnotationFormatError 的构造方法
构造带指定原因和详细消息的新 AnnotationFormatError，该消息为 (cause == null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
AnnotationMirror - javax.lang.model.element 中的 接口
表示一个注释。
annotationType() - 接口 java.lang.annotation.Annotation 中的方法
返回此 annotation 的注释类型。
annotationType() - 异常 java.lang.annotation.IncompleteAnnotationException 中的方法
返回带有缺少元素的注释类型的 Class 对象。
AnnotationTypeMismatchException - java.lang.annotation 中的 异常
若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
AnnotationTypeMismatchException(Method, String) - 异常 java.lang.annotation.AnnotationTypeMismatchException 的构造方法
构造针对指定的注释类型元素和找到的数据类型的 AnnotationTypeMismatchException。
AnnotationValue - javax.lang.model.element 中的 接口
表示注释类型元素的值。
AnnotationValueVisitor<R,P> - javax.lang.model.element 中的 接口
注释类型元素值的 visitor，使用 visitor 设计模式的变体。
ANY - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Any - org.omg.CORBA 中的 类
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
Any() - 类 org.omg.CORBA.Any 的构造方法
AnyHolder - org.omg.CORBA 中的 类
Any 的 Holder。
AnyHolder() - 类 org.omg.CORBA.AnyHolder 的构造方法
构造一个新的 AnyHolder 对象，将其 value 字段初始化为 null。
AnyHolder(Any) - 类 org.omg.CORBA.AnyHolder 的构造方法
为给定的 Any 对象构造一个新 AnyHolder 对象。
AnySeqHelper - org.omg.CORBA 中的 类
AnySeq 的 Helper。
AnySeqHelper() - 类 org.omg.CORBA.AnySeqHelper 的构造方法
AnySeqHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/AnySeqHelper.java。
AnySeqHelper() - 类 org.omg.DynamicAny.AnySeqHelper 的构造方法
AnySeqHolder - org.omg.CORBA 中的 类
AnySeq 的 Holder。
AnySeqHolder() - 类 org.omg.CORBA.AnySeqHolder 的构造方法
AnySeqHolder(Any[]) - 类 org.omg.CORBA.AnySeqHolder 的构造方法
anySubString(AttributeValueExp, StringValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于字符串参数的约束条件。
AppConfigurationEntry - javax.security.auth.login 中的 类
此类表示为在 Configuration 类中的 getAppConfigurationEntry(String appName) 方法中指定的应用程序配置的单个 LoginModule 条目。
AppConfigurationEntry(String, AppConfigurationEntry.LoginModuleControlFlag, Map<String, ?>) - 类 javax.security.auth.login.AppConfigurationEntry 的构造方法
此类的默认构造方法。
AppConfigurationEntry.LoginModuleControlFlag - javax.security.auth.login 中的 类
此类表示 LoginModule 是否为 REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL。
append(Shape, boolean) - 类 java.awt.geom.Path2D 中的方法
将指定 Shape 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
append(PathIterator, boolean) - 类 java.awt.geom.Path2D 中的方法
将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
append(PathIterator, boolean) - 类 java.awt.geom.Path2D.Double 中的方法
将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
append(PathIterator, boolean) - 类 java.awt.geom.Path2D.Float 中的方法
将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
append(Printable, PageFormat) - 类 java.awt.print.Book 中的方法
将单个页面追加到此 Book 的尾部。
append(Printable, PageFormat, int) - 类 java.awt.print.Book 中的方法
将 numPages 个页面追加到此 Book 的尾部。
append(String) - 类 java.awt.TextArea 中的方法
将给定文本追加到文本区的当前文本。
append(CharSequence) - 类 java.io.CharArrayWriter 中的方法
将指定的字符序列添加到此 writer。
append(CharSequence, int, int) - 类 java.io.CharArrayWriter 中的方法
将指定字符序列的子序列添加到此 writer。
append(char) - 类 java.io.CharArrayWriter 中的方法
将指定字符添加到此 writer。
append(CharSequence) - 类 java.io.PrintStream 中的方法
将指定字符序列添加到此输出流。
append(CharSequence, int, int) - 类 java.io.PrintStream 中的方法
将指定字符序列的子序列添加到此输出流。
append(char) - 类 java.io.PrintStream 中的方法
将指定字符添加到此输出流。
append(CharSequence) - 类 java.io.PrintWriter 中的方法
将指定的字符序列添加到此 writer。
append(CharSequence, int, int) - 类 java.io.PrintWriter 中的方法
将指定字符序列的子序列添加到此 writer。
append(char) - 类 java.io.PrintWriter 中的方法
将指定字符添加到此 writer。
append(CharSequence) - 类 java.io.StringWriter 中的方法
将指定的字符序列添加到此 writer。
append(CharSequence, int, int) - 类 java.io.StringWriter 中的方法
将指定字符序列的子序列添加到此 writer。
append(char) - 类 java.io.StringWriter 中的方法
将指定字符添加到此 writer。
append(CharSequence) - 类 java.io.Writer 中的方法
将指定字符序列添加到此 writer。
append(CharSequence, int, int) - 类 java.io.Writer 中的方法
将指定字符序列的子序列添加到此 writer.Appendable。
append(char) - 类 java.io.Writer 中的方法
将指定字符添加到此 writer。
append(CharSequence) - 接口 java.lang.Appendable 中的方法
向此 Appendable 添加指定的字符序列。
append(CharSequence, int, int) - 接口 java.lang.Appendable 中的方法
向此 Appendable 添加指定字符序列的子序列。
append(char) - 接口 java.lang.Appendable 中的方法
向此 Appendable 添加指定字符。
append(Object) - 类 java.lang.StringBuffer 中的方法
append(String) - 类 java.lang.StringBuffer 中的方法
append(StringBuffer) - 类 java.lang.StringBuffer 中的方法
将指定的 StringBuffer 添加到此序列中。
append(CharSequence) - 类 java.lang.StringBuffer 中的方法
将指定的 CharSequence 添加到该序列。
append(CharSequence, int, int) - 类 java.lang.StringBuffer 中的方法
append(char[]) - 类 java.lang.StringBuffer 中的方法
append(char[], int, int) - 类 java.lang.StringBuffer 中的方法
append(boolean) - 类 java.lang.StringBuffer 中的方法
append(char) - 类 java.lang.StringBuffer 中的方法
append(int) - 类 java.lang.StringBuffer 中的方法
append(long) - 类 java.lang.StringBuffer 中的方法
append(float) - 类 java.lang.StringBuffer 中的方法
append(double) - 类 java.lang.StringBuffer 中的方法
append(Object) - 类 java.lang.StringBuilder 中的方法
append(String) - 类 java.lang.StringBuilder 中的方法
append(StringBuffer) - 类 java.lang.StringBuilder 中的方法
将指定的 StringBuffer 添加到此序列。
append(CharSequence) - 类 java.lang.StringBuilder 中的方法
append(CharSequence, int, int) - 类 java.lang.StringBuilder 中的方法
append(char[]) - 类 java.lang.StringBuilder 中的方法
append(char[], int, int) - 类 java.lang.StringBuilder 中的方法
append(boolean) - 类 java.lang.StringBuilder 中的方法
append(char) - 类 java.lang.StringBuilder 中的方法
append(int) - 类 java.lang.StringBuilder 中的方法
append(long) - 类 java.lang.StringBuilder 中的方法
append(float) - 类 java.lang.StringBuilder 中的方法
append(double) - 类 java.lang.StringBuilder 中的方法
append(CharSequence) - 类 java.nio.CharBuffer 中的方法
将指定的字符序列添加到此缓冲区（可选操作）。
append(CharSequence, int, int) - 类 java.nio.CharBuffer 中的方法
将指定字符序列的子序列添加到此缓冲区（可选操作）。
append(char) - 类 java.nio.CharBuffer 中的方法
将指定字符添加到此缓冲区（可选操作）。
append(String) - 类 javax.swing.JTextArea 中的方法
将给定文本追加到文档结尾。
append(View) - 类 javax.swing.text.View 中的方法
追加单个子视图。
Appendable - java.lang 中的 接口
能够被添加 char 序列和值的对象。
appendChild(Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
将节点 newChild 添加到此节点子节点列表的末尾。
appendChild(Node) - 接口 org.w3c.dom.Node 中的方法
将节点 newChild 添加到此节点的子节点列表的末尾。
appendCodePoint(int) - 类 java.lang.StringBuffer 中的方法
appendCodePoint(int) - 类 java.lang.StringBuilder 中的方法
appendData(String) - 接口 org.w3c.dom.CharacterData 中的方法
将字符串追加到节点的字符数据的结尾。
appendEvent(InputEvent) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
Recognizer 在 Component 上注册的侦听器将通过此 API 记录所有识别的 Event，识别的 Event 是组成 Drag 和 Drop 开始动作的系列 Event 的一部分。
appendFaultSubcode(QName) - 接口 javax.xml.soap.SOAPFault 中的方法
将 Subcode 添加到此 SOAPFault 包含的 Subcode 序列的末尾。
appendRemainingComponent(String) - 异常 javax.naming.NamingException 中的方法
将 name 作为剩余名称中最后的组件添加。
appendRemainingComponent(String) - 类 javax.naming.spi.ResolveResult 中的方法
将单个组件添加到剩余名称末尾。
appendRemainingName(Name) - 异常 javax.naming.NamingException 中的方法
将 'name' 中的组件作为剩余名称中最后的组件添加。
appendRemainingName(Name) - 类 javax.naming.spi.ResolveResult 中的方法
将组件添加到剩余名称的末尾。
appendReplacement(StringBuffer, String) - 类 java.util.regex.Matcher 中的方法
实现非终端添加和替换步骤。
appendTail(StringBuffer) - 类 java.util.regex.Matcher 中的方法
实现终端添加和替换步骤。
appendText(String) - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 append(String) 取代。
appendToBootstrapClassLoaderSearch(JarFile) - 接口 java.lang.instrument.Instrumentation 中的方法
指定 JAR 文件，检测类由引导类加载器定义。
appendToSystemClassLoaderSearch(JarFile) - 接口 java.lang.instrument.Instrumentation 中的方法
指定 JAR 文件，检测类由系统类加载器定义。
Applet - java.applet 中的 类
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。
Applet() - 类 java.applet.Applet 的构造方法
构造一个新 Applet。
APPLET - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定搜索其他属性时将使用的初始上下文构造方法的 applet 的环境属性名称。
APPLET - 类 javax.swing.text.html.HTML.Tag 中的静态变量
applet - 类 javax.swing.text.html.parser.DTD 中的变量
Applet.AccessibleApplet - java.applet 中的 类
此类实现对 Applet 类的可访问性支持。
Applet.AccessibleApplet() - 类 java.applet.Applet.AccessibleApplet 的构造方法
AppletContext - java.applet 中的 接口
此接口对应于 applet 的环境：包含 applet 的文档以及同一文档中的其他 applet。
AppletInitializer - java.beans 中的 接口
此接口设计用于与 java.beans.Beans.instantiate 联合使用。
appletResize(int, int) - 接口 java.applet.AppletStub 中的方法
当 applet 想要重新调整大小时调用。
AppletStub - java.applet 中的 接口
当 applet 第一次被创建时，使用 applet 的 setStub 方法把 applet stub 连接到它。
ApplicationException - org.omg.CORBA.portable 中的 异常
此类用来报告 ORB 和 stub 之间的应用程序级异常。
ApplicationException(String, InputStream) - 异常 org.omg.CORBA.portable.ApplicationException 的构造方法
根据异常的 CORBA 存储库 ID 和一个输入流（可从中读取异常数据作为其参数）构造 ApplicationException。
apply(ObjectName) - 类 javax.management.AttributeValueExp 中的方法
在 MBean 上应用 AttributeValueExp。
apply(ObjectName) - 类 javax.management.ObjectName 中的方法
测试此 ObjectName（可以是一个模式）是否与另一个 ObjectName 匹配。
apply(ObjectName) - 接口 javax.management.QueryExp 中的方法
在 MBean 上应用 QueryExp。
apply(ObjectName) - 类 javax.management.StringValueExp 中的方法
在 MBean 上应用 ValueExp。
apply(ObjectName) - 接口 javax.management.ValueExp 中的方法
在 MBean 上应用 ValueExp。
APPLY_REVERB - 类 javax.sound.sampled.BooleanControl.Type 中的静态变量
表示是否将回响应用于行的控件。
applyComponentOrientation(ComponentOrientation) - 类 java.awt.Component 中的方法
设置此组件及其包含的所有组件的 ComponentOrientation 属性。
applyComponentOrientation(ComponentOrientation) - 类 java.awt.Container 中的方法
设置此容器和其中包含的所有组件的 ComponentOrientation 属性。
applyComponentOrientation(ComponentOrientation) - 类 javax.swing.JMenu 中的方法
设置此菜单及其中包含的所有组件的 ComponentOrientation 属性。
applyLocalizedPattern(String) - 类 java.text.DecimalFormat 中的方法
将给定的模式应用于此 Format 对象。
applyLocalizedPattern(String) - 类 java.text.SimpleDateFormat 中的方法
将给定的本地化模式字符串应用于此日期格式。
applyPattern(String) - 类 java.text.ChoiceFormat 中的方法
设置模式。
applyPattern(String) - 类 java.text.DecimalFormat 中的方法
将给定的模式应用于此 Format 对象。
applyPattern(String) - 类 java.text.MessageFormat 中的方法
设置此消息格式所使用的模式。
applyPattern(String) - 类 java.text.SimpleDateFormat 中的方法
将给定模式字符串应用于此日期格式。
applyResourceBundle(ResourceBundle) - 类 java.awt.Window 中的方法
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
applyResourceBundle(String) - 类 java.awt.Window 中的方法
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
appRandom - 类 java.security.SignatureSpi 中的变量
应用程序指定的随机源。
APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识用于确认（yes、ok）按钮的助记符的更改。
APPROVE_BUTTON_TEXT_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识确认（yes、ok）按钮上的文本更改。
APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识用于确认（yes、ok）按钮的工具提示文本的更改。
APPROVE_OPTION - 类 javax.swing.JFileChooser 中的静态变量
选择确认（yes、ok）后返回该值。
APPROVE_SELECTION - 类 javax.swing.JFileChooser 中的静态变量
指示确认当前的选择（与按下 yes 或 ok 相同）。
approveSelection() - 类 javax.swing.JFileChooser 中的方法
用户单击 Approve 按钮（默认情况下标有 "Open" 或 "Save"）时由 UI 调用此方法。
APRIL - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第四个月的 Calendar.MONTH 字段值。
APRIL - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第四个月的值。
ARABIC - 类 java.awt.font.NumericShaper 中的静态变量
标识 ARABIC 范围和十进制基数。
ARABIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Arabic”Unicode 字符块的常量。
ARABIC_PRESENTATION_FORMS_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Arabic Presentation Forms-A”Unicode 字符块的常量。
ARABIC_PRESENTATION_FORMS_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Arabic Presentation Forms-B”Unicode 字符块的常量。
Arc2D - java.awt.geom 中的 类
Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。
Arc2D(int) - 类 java.awt.geom.Arc2D 的构造方法
这是一个不能直接实例化的抽象类。
Arc2D.Double - java.awt.geom 中的 类
此类定义以 double 精度指定的弧。
Arc2D.Double() - 类 java.awt.geom.Arc2D.Double 的构造方法
构造一个新 OPEN 弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)。
Arc2D.Double(int) - 类 java.awt.geom.Arc2D.Double 的构造方法
构造一个新弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)、指定的闭合类型。
Arc2D.Double(double, double, double, double, double, double, int) - 类 java.awt.geom.Arc2D.Double 的构造方法
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
Arc2D.Double(Rectangle2D, double, double, int) - 类 java.awt.geom.Arc2D.Double 的构造方法
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
Arc2D.Float - java.awt.geom 中的 类
此类定义以 float 精度指定的弧。
Arc2D.Float() - 类 java.awt.geom.Arc2D.Float 的构造方法
构造一个新 OPEN 弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)。
Arc2D.Float(int) - 类 java.awt.geom.Arc2D.Float 的构造方法
构造一个新弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)，角跨越 (start = 0, extent = 0)、指定的闭合类型。
Arc2D.Float(float, float, float, float, float, float, int) - 类 java.awt.geom.Arc2D.Float 的构造方法
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
Arc2D.Float(Rectangle2D, float, float, int) - 类 java.awt.geom.Arc2D.Float 的构造方法
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
archeight - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
圆角弧的高度。
archeight - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
圆角弧的高度。
ARCHIVE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
arcwidth - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
圆角弧的宽度。
arcwidth - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
圆角弧的宽度。
Area - java.awt.geom 中的 类
Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。
Area() - 类 java.awt.geom.Area 的构造方法
创建空区域的默认构造方法。
Area(Shape) - 类 java.awt.geom.Area 的构造方法
Area 类可以根据指定的 Shape 对象创建区域几何形状。
AREA - 类 javax.swing.text.html.HTML.Tag 中的静态变量
AreaAveragingScaleFilter - java.awt.image 中的 类
这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。
AreaAveragingScaleFilter(int, int) - 类 java.awt.image.AreaAveragingScaleFilter 的构造方法
构造一个 AreaAveragingScaleFilter，它对由 width 和 height 参数所指定的源图像的像素进行缩放。
areFieldsSet - 类 java.util.Calendar 中的变量
如果 fields[] 与当前的设置时间同步，则返回 true。
areFocusTraversalKeysSet(int) - 类 java.awt.Component 中的方法
返回是否为此 Component 显式定义了给定焦点遍历操作的焦点遍历键 Set。
areFocusTraversalKeysSet(int) - 类 java.awt.Container 中的方法
返回是否已经为此 Container 明确定义了用于给定焦点遍历操作的焦点遍历键的 Set。
areNew - 类 javax.swing.event.TreeSelectionEvent 中的变量
对于每条路径，标识该路径实际上是否为一条新路径。
arePathsContiguous(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
如果路径是连续的，或者此对象没有 RowMapper，则返回 true。
areTablesSet() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
如果表是当前设置的，则返回 true。
areTablesSet() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
如果表是当前设置的，则返回 true。
arg - 类 java.awt.Event 中的变量
事件的任意参数。
ARG_IN - org.omg.CORBA 中的 接口
向调用符号化 "input" 参数，表示从客户端将该参数传递到服务器。
ARG_INOUT - org.omg.CORBA 中的 接口
表示用于某一调用的输入和输出的参数，意味着将该参数从客户端传到服务器，然后再从服务器传回客户端。
ARG_OUT - org.omg.CORBA 中的 接口
表示调用的 "input" 参数的常量，意味着从服务器将该参数传递到客户端。
ARGUMENT - 类 java.text.MessageFormat.Field 中的静态变量
标识消息某一部分的常量，其中此消息是从传入 formatToCharacterIterator 的参数生成的。
argument - 类 org.omg.Dynamic.Parameter 中的变量
arguments() - 类 org.omg.CORBA.Request 中的方法
检索包含将被调用方法的参数的 NVList 对象。
arguments(NVList) - 类 org.omg.CORBA.ServerRequest 中的方法
指定方法参数类型并检索 "in" 和 "inout" 参数值。
arguments() - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
返回传递给 ORB.init 的参数。
arguments() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回一个 Parameter 对象数组，包含将调用的操作上的参数。
ARGV - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它将一个位置参数数组传递给某一脚本。
ArithmeticException - java.lang 中的 异常
当出现异常的运算条件时，抛出此异常。
ArithmeticException() - 异常 java.lang.ArithmeticException 的构造方法
构造不带详细消息的 ArithmeticException。
ArithmeticException(String) - 异常 java.lang.ArithmeticException 的构造方法
构造具有指定详细消息的 ArithmeticException。
ARMED - 类 javax.accessibility.AccessibleState 中的静态变量
指示选中了此对象。
ARMED - 类 javax.swing.DefaultButtonModel 中的静态变量
标识位掩码中“选中的”位，该位指示选择/触发按钮操作的部分委托事项。
ARMENIAN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Armenian”Unicode 字符块的常量。
arrangeGrid(Container) - 类 java.awt.GridBagLayout 中的方法
布置网格。
ArrangeGrid(Container) - 类 java.awt.GridBagLayout 中的方法
此方法已过时，仅为提供向后兼容性；新代码应该调用 arrangeGrid 来代替。
Array - java.lang.reflect 中的 类
Array 类提供了动态创建和访问 Java 数组的方法。
array() - 类 java.nio.Buffer 中的方法
返回此缓冲区的底层实现数组（可选操作）。
array() - 类 java.nio.ByteBuffer 中的方法
返回实现此缓冲区的 byte 数组（可选操作）。
array() - 类 java.nio.CharBuffer 中的方法
返回实现此缓冲区的字符数组（可选操作）。
array() - 类 java.nio.DoubleBuffer 中的方法
返回实现此缓冲区的 double 数组（可选操作）。
array() - 类 java.nio.FloatBuffer 中的方法
返回实现此缓冲区的 float 数组（可选操作）。
array() - 类 java.nio.IntBuffer 中的方法
返回实现此缓冲区的 int 数组（可选操作）。
array() - 类 java.nio.LongBuffer 中的方法
返回实现此缓冲区的 long 数组（可选操作）。
array() - 类 java.nio.ShortBuffer 中的方法
返回实现此缓冲区的 short 数组（可选操作）。
Array - java.sql 中的 接口
SQL 类型 ARRAY 在 Java 编程语言中的映射关系。
ARRAY - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 ARRAY 的 Java 编程语言中的常量（有时称为类型代码）。
array - 类 javax.swing.text.Segment 中的变量
这是包含了所需文本的数组。
ArrayBlockingQueue<E> - java.util.concurrent 中的 类
一个由数组支持的有界阻塞队列。
ArrayBlockingQueue(int) - 类 java.util.concurrent.ArrayBlockingQueue 的构造方法
创建一个带有给定的（固定）容量和默认访问策略的 ArrayBlockingQueue。
ArrayBlockingQueue(int, boolean) - 类 java.util.concurrent.ArrayBlockingQueue 的构造方法
创建一个具有给定的（固定）容量和指定访问策略的 ArrayBlockingQueue。
ArrayBlockingQueue(int, boolean, Collection<? extends E>) - 类 java.util.concurrent.ArrayBlockingQueue 的构造方法
创建一个具有给定的（固定）容量和指定访问策略的 ArrayBlockingQueue，它最初包含给定 collection 的元素，并以 collection 迭代器的遍历顺序添加元素。
arraycopy(Object, int, Object, int, int) - 类 java.lang.System 中的静态方法
从指定源数组中复制一个数组，复制从指定的位置开始，到目标数组的指定位置结束。
ArrayDeque<E> - java.util 中的 类
Deque 接口的大小可变数组的实现。
ArrayDeque() - 类 java.util.ArrayDeque 的构造方法
构造一个初始容量能够容纳 16 个元素的空数组双端队列。
ArrayDeque(int) - 类 java.util.ArrayDeque 的构造方法
构造一个初始容量能够容纳指定数量的元素的空数组双端队列。
ArrayDeque(Collection<? extends E>) - 类 java.util.ArrayDeque 的构造方法
构造一个包含指定 collection 的元素的双端队列，这些元素按 collection 的迭代器返回的顺序排列。
ArrayIndexOutOfBoundsException - java.lang 中的 异常
用非法索引访问数组时抛出的异常。
ArrayIndexOutOfBoundsException() - 异常 java.lang.ArrayIndexOutOfBoundsException 的构造方法
构造不带详细消息的 ArrayIndexOutOfBoundsException。
ArrayIndexOutOfBoundsException(int) - 异常 java.lang.ArrayIndexOutOfBoundsException 的构造方法
构造具有指示非法索引的参数的新 ArrayIndexOutOfBoundsException 类。
ArrayIndexOutOfBoundsException(String) - 异常 java.lang.ArrayIndexOutOfBoundsException 的构造方法
构造具有指定详细消息的 ArrayIndexOutOfBoundsException 类。
ArrayList<E> - java.util 中的 类
List 接口的大小可变数组的实现。
ArrayList(int) - 类 java.util.ArrayList 的构造方法
构造一个具有指定初始容量的空列表。
ArrayList() - 类 java.util.ArrayList 的构造方法
构造一个初始容量为 10 的空列表。
ArrayList(Collection<? extends E>) - 类 java.util.ArrayList 的构造方法
构造一个包含指定 collection 的元素的列表，这些元素是按照该 collection 的迭代器返回它们的顺序排列的。
arrayOffset() - 类 java.nio.Buffer 中的方法
返回此缓冲区的底层实现数组中第一个缓冲区元素的偏移量（可选操作）。
arrayOffset() - 类 java.nio.ByteBuffer 中的方法
返回此缓冲区中的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.CharBuffer 中的方法
返回此缓冲区中的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.DoubleBuffer 中的方法
返回此缓冲区中的第一个 double 元素在缓冲区的底层实现数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.FloatBuffer 中的方法
返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.IntBuffer 中的方法
返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.LongBuffer 中的方法
返回此缓冲区中第一个元素在缓冲区的支持数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.ShortBuffer 中的方法
返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
Arrays - java.util 中的 类
此类包含用来操作数组（比如排序和搜索）的各种方法。
ArrayStoreException - java.lang 中的 异常
试图将错误类型的对象存储到一个对象数组时抛出的异常。
ArrayStoreException() - 异常 java.lang.ArrayStoreException 的构造方法
构造不带详细消息的 ArrayStoreException。
ArrayStoreException(String) - 异常 java.lang.ArrayStoreException 的构造方法
构造具有指定详细消息的 ArrayStoreException。
ArrayType - javax.lang.model.type 中的 接口
表示一个数组类型。
ArrayType<T> - javax.management.openmbean 中的 类
ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。
ArrayType(int, OpenType<?>) - 类 javax.management.openmbean.ArrayType 的构造方法
构造一个描述开放数据 值的 ArrayType 实例，该值是其元素的开放类型 为 elementType、元素的维度为 dimension 的数组。
ArrayType(SimpleType<?>, boolean) - 类 javax.management.openmbean.ArrayType 的构造方法
为提供的 SimpleType 构造一个一维 ArrayType 实例。
ARROW_BUTTON - 类 javax.swing.plaf.synth.Region 中的静态变量
ArrowButton 是特殊类型的按钮，也呈现了一个方向指示器（通常是一个箭头）。
arrowButton - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
arrowIcon - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
ARROWS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Arrows”Unicode 字符块的常量。
asCharacters() - 接口 javax.xml.stream.events.XMLEvent 中的方法
将此事件作为 Characters 返回，如果此事件不是字符，则可能导致类强制转化异常。
asCharBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 char 缓冲区。
ASCII_STREAM_PARAM - 类 javax.sql.rowset.BaseRowSet 中的静态变量
该常量向 RowSetReaderImpl 对象指示给定的参数是一个 ASCII 流。
asciiStream - 类 javax.sql.rowset.BaseRowSet 中的变量
将由方法 getAsciiStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
asDoubleBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 double 缓冲区。
asElement() - 接口 javax.lang.model.type.DeclaredType 中的方法
返回对应于此类型的元素。
asElement() - 接口 javax.lang.model.type.TypeVariable 中的方法
返回对应于此类型变量的元素。
asElement(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回对应于类型的元素。
asEndElement() - 接口 javax.xml.stream.events.XMLEvent 中的方法
将此事件作为结束元素事件返回，如果此事件不是结束元素，则可能导致类强制转换异常。
asFloatBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 float 缓冲区。
asin(double) - 类 java.lang.Math 中的静态方法
返回一个值的反正弦；返回的角度范围在 -pi/2 到 pi/2 之间。
asin(double) - 类 java.lang.StrictMath 中的静态方法
返回值的反正弦；返回角的范围在 -pi/2 到 pi/2 之间。
asIntBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 int 缓冲区。
asksAllowsChildren - 类 javax.swing.tree.DefaultTreeModel 中的变量
确定 isLeaf 方法如何判断一个节点是否为叶节点。
asksAllowsChildren() - 类 javax.swing.tree.DefaultTreeModel 中的方法
告知如何确定叶节点。
asLifoQueue(Deque<T>) - 类 java.util.Collections 中的静态方法
以后进先出 (Lifo) Queue 的形式返回某个 Deque 的视图。
asList(T...) - 类 java.util.Arrays 中的静态方法
返回一个受指定数组支持的固定大小的列表。
asList() - 类 javax.management.AttributeList 中的方法
以 List<Attribute> 的形式返回此列表的视图。
asList() - 类 javax.management.relation.RoleList 中的方法
以 List<Role> 的形式返回此列表的示图。
asList() - 类 javax.management.relation.RoleUnresolvedList 中的方法
以 List<RoleUnresolved> 的形式返回此列表的视图。
asLongBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 long 缓冲区。
asMemberOf(DeclaredType, Element) - 接口 javax.lang.model.util.Types 中的方法
当元素被视为给定类型的成员或者直接由给定类型包含时，返回该元素的类型。
asReadOnlyBuffer() - 类 java.nio.ByteBuffer 中的方法
创建共享此缓冲区内容的新的只读字节缓冲区。
asReadOnlyBuffer() - 类 java.nio.CharBuffer 中的方法
创建共享此缓冲区内容的新的只读字符缓冲区。
asReadOnlyBuffer() - 类 java.nio.DoubleBuffer 中的方法
创建共享此缓冲区内容的新的只读 double 缓冲区。
asReadOnlyBuffer() - 类 java.nio.FloatBuffer 中的方法
创建共享此缓冲区内容的新的只读 float 缓冲区。
asReadOnlyBuffer() - 类 java.nio.IntBuffer 中的方法
创建共享此缓冲区内容的新的只读 int 缓冲区。
asReadOnlyBuffer() - 类 java.nio.LongBuffer 中的方法
创建共享此缓冲区内容的新的只读 long 缓冲区。
asReadOnlyBuffer() - 类 java.nio.ShortBuffer 中的方法
创建共享此缓冲区内容的新的只读 short 缓冲区。
assembleSystemMenu() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
assembleSystemMenu() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
重写父级的方法，使其不执行任何操作。
AssertionError - java.lang 中的 错误
抛出该异常指示某个断言失败。
AssertionError() - 错误 java.lang.AssertionError 的构造方法
构造一个不带详细消息的 AssertionError。
AssertionError(Object) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的对象，该对象将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(boolean) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 boolean，该 boolean 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(char) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 char，该 char 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(int) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 int，该 int 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(long) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 long，该 long 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(float) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 float，该 float 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(double) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 double，该 double 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
asShortBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 short 缓冲区。
assign(DynAny) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 将内容从一个 Dynamic Any 复制到另一个 Dynamic Any 中。
assign(DynAny) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynStructStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynValueStub 中的方法
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
assign(DynAny) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
asStartElement() - 接口 javax.xml.stream.events.XMLEvent 中的方法
将此事件作为开始元素事件返回，如果此事件不是开始元素，则可能导致类强制转换异常。
asSubclass(Class<U>) - 类 java.lang.Class 中的方法
强制转换该 Class 对象，以表示指定的 class 对象所表示的类的一个子类。
assureRectsCreated(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
asType() - 接口 javax.lang.model.element.Element 中的方法
返回此元素定义的类型。
AsyncBoxView - javax.swing.text 中的 类
异步执行布局处理的框。
AsyncBoxView(Element, int) - 类 javax.swing.text.AsyncBoxView 的构造方法
构造执行异步布局处理的 BoxView。
AsyncBoxView.ChildLocator - javax.swing.text 中的 类
该类在本地化区域发生更改时，管理该本地化区域中子视图的有效位置。
AsyncBoxView.ChildLocator() - 类 javax.swing.text.AsyncBoxView.ChildLocator 的构造方法
构造 ChildLocator。
AsyncBoxView.ChildState - javax.swing.text 中的 类
表示子视图布局状态的记录。
AsyncBoxView.ChildState(View) - 类 javax.swing.text.AsyncBoxView.ChildState 的构造方法
构造子视图状态。
AsyncHandler<T> - javax.xml.ws 中的 接口
AsyncHandler 接口由希望接收关于完成了异步调用服务端点操作的回调通知的客户端实现。
AsynchronousCloseException - java.nio.channels 中的 异常
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
AsynchronousCloseException() - 异常 java.nio.channels.AsynchronousCloseException 的构造方法
构造此类的一个实例。
AT_TARGET - 接口 org.w3c.dom.events.Event 中的静态变量
目前事件正在目标 EventTarget 接受评诂。
atan(double) - 类 java.lang.Math 中的静态方法
返回一个值的反正切；返回的角度范围在 -pi/2 到 pi/2 之间。
atan(double) - 类 java.lang.StrictMath 中的静态方法
返回值的反正切；返回角的范围在 -pi/2 到 pi/2 之间。
atan2(double, double) - 类 java.lang.Math 中的静态方法
将矩形坐标 (x, y) 转换成极坐标 (r, theta)，返回所得角 theta。
atan2(double, double) - 类 java.lang.StrictMath 中的静态方法
将矩形坐标 (x, y) 转换成极坐标 (r, theta)，并返回角 theta。
AtomicBoolean - java.util.concurrent.atomic 中的 类
可以用原子方式更新的 boolean 值。
AtomicBoolean(boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 的构造方法
使用给定的初始值创建新的 AtomicBoolean。
AtomicBoolean() - 类 java.util.concurrent.atomic.AtomicBoolean 的构造方法
使用初始值 false 创建新的 AtomicBoolean。
AtomicInteger - java.util.concurrent.atomic 中的 类
可以用原子方式更新的 int 值。
AtomicInteger(int) - 类 java.util.concurrent.atomic.AtomicInteger 的构造方法
创建具有给定初始值的新 AtomicInteger。
AtomicInteger() - 类 java.util.concurrent.atomic.AtomicInteger 的构造方法
创建具有初始值 0 的新 AtomicInteger。
AtomicIntegerArray - java.util.concurrent.atomic 中的 类
可以用原子方式更新其元素的 int 数组。
AtomicIntegerArray(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 的构造方法
创建给定长度的新 AtomicIntegerArray。
AtomicIntegerArray(int[]) - 类 java.util.concurrent.atomic.AtomicIntegerArray 的构造方法
创建与给定数组具有相同长度的新 AtomicIntegerArray，并从给定数组复制其所有元素。
AtomicIntegerFieldUpdater<T> - java.util.concurrent.atomic 中的 类
基于反射的实用工具，可以对指定类的指定 volatile int 字段进行原子更新。
AtomicIntegerFieldUpdater() - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 的构造方法
受保护的无操作构造方法，供子类使用。
AtomicLong - java.util.concurrent.atomic 中的 类
可以用原子方式更新的 long 值。
AtomicLong(long) - 类 java.util.concurrent.atomic.AtomicLong 的构造方法
创建具有给定初始值的新 AtomicLong。
AtomicLong() - 类 java.util.concurrent.atomic.AtomicLong 的构造方法
创建具有初始值 0 的新 AtomicLong。
AtomicLongArray - java.util.concurrent.atomic 中的 类
可以用原子方式更新其元素的 long 数组。
AtomicLongArray(int) - 类 java.util.concurrent.atomic.AtomicLongArray 的构造方法
创建给定长度的新 AtomicLongArray。
AtomicLongArray(long[]) - 类 java.util.concurrent.atomic.AtomicLongArray 的构造方法
创建与给定数组具有相同长度的新 AtomicLongArray，并从给定数组复制其所有元素。
AtomicLongFieldUpdater<T> - java.util.concurrent.atomic 中的 类
基于反射的实用工具，可以对指定类的指定 volatile long 字段进行原子更新。
AtomicLongFieldUpdater() - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 的构造方法
受保护的无操作构造方法，供子类使用。
AtomicMarkableReference<V> - java.util.concurrent.atomic 中的 类
AtomicMarkableReference 维护带有标记位的对象引用，可以原子方式对其进行更新。
AtomicMarkableReference(V, boolean) - 类 java.util.concurrent.atomic.AtomicMarkableReference 的构造方法
创建具有给定初始值的新 AtomicMarkableReference。
AtomicReference<V> - java.util.concurrent.atomic 中的 类
可以用原子方式更新的对象引用。
AtomicReference(V) - 类 java.util.concurrent.atomic.AtomicReference 的构造方法
使用给定的初始值创建新的 AtomicReference。
AtomicReference() - 类 java.util.concurrent.atomic.AtomicReference 的构造方法
使用 null 初始值创建新的 AtomicReference。
AtomicReferenceArray<E> - java.util.concurrent.atomic 中的 类
可以用原子方式更新其元素的对象引用数组。
AtomicReferenceArray(int) - 类 java.util.concurrent.atomic.AtomicReferenceArray 的构造方法
创建给定长度的新 AtomicReferenceArray。
AtomicReferenceArray(E[]) - 类 java.util.concurrent.atomic.AtomicReferenceArray 的构造方法
创建与给定数组具有相同长度的新 AtomicReferenceArray，并从给定数组复制其所有元素。
AtomicReferenceFieldUpdater<T,V> - java.util.concurrent.atomic 中的 类
基于反射的实用工具，可以对指定类的指定 volatile 字段进行原子更新。
AtomicReferenceFieldUpdater() - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 的构造方法
受保护的无操作构造方法，供子类使用。
AtomicStampedReference<V> - java.util.concurrent.atomic 中的 类
AtomicStampedReference 维护带有整数“标志”的对象引用，可以用原子方式对其进行更新。
AtomicStampedReference(V, int) - 类 java.util.concurrent.atomic.AtomicStampedReference 的构造方法
创建具有给定初始值的新 AtomicStampedReference。
attach(Object) - 类 java.nio.channels.SelectionKey 中的方法
将给定的对象附加到此键。
attachment() - 类 java.nio.channels.SelectionKey 中的方法
获取当前的附加对象。
AttachmentMarshaller - javax.xml.bind.attachment 中的 类
启用 JAXB 编组来优化二进制数据存储。
AttachmentMarshaller() - 类 javax.xml.bind.attachment.AttachmentMarshaller 的构造方法
AttachmentPart - javax.xml.soap 中的 类
SOAPMessage 对象的一个附件。
AttachmentPart() - 类 javax.xml.soap.AttachmentPart 的构造方法
AttachmentUnmarshaller - javax.xml.bind.attachment 中的 类
启用包含优化的二进制数据格式的根文档的 JAXB 解组。
AttachmentUnmarshaller() - 类 javax.xml.bind.attachment.AttachmentUnmarshaller 的构造方法
ATTEMPTED - 类 javax.print.attribute.standard.PDLOverrideSupported 中的静态变量
打印机会尝试让外部作业属性值优先于嵌入到文档打印数据中的指令，但是不保证确实会如此。
attemptMark(V, boolean) - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
如果当前引用 == 预期引用，则以原子方式将该标记的值设置为给定的更新值。
attemptStamp(V, int) - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
如果当前引用 == 预期引用，则以原子方式将该标志的值设置为给定的更新值。
attr(String) - 类 javax.management.Query 中的静态方法
返回新的属性表达式。
attr(String, String) - 类 javax.management.Query 中的静态方法
返回新的限定属性表达式。
Attr - org.w3c.dom 中的 接口
Attr 接口表示 Element 对象中的属性。
Attribute - javax.management 中的 类
通过将 MBean 属性名与其值相关联来表示 MBean 属性。
Attribute(String, Object) - 类 javax.management.Attribute 的构造方法
构造将给定的属性名与给定值相关联的 Attribute 对象。
Attribute - javax.naming.directory 中的 接口
此接口表示与命名对象关联的属性。
Attribute - javax.print.attribute 中的 接口
接口 Attribute 是由任何一个打印属性类实现的基本接口，用于指示该类表示某一打印属性。
Attribute - javax.xml.stream.events 中的 接口
包含关于属性信息的接口。
ATTRIBUTE - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个属性
ATTRIBUTE_CHANGE - 类 javax.management.AttributeChangeNotification 中的静态变量
通知类型，指示所观察的 MBean 属性值已更改。
ATTRIBUTE_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Attr。
ATTRIBUTE_RUN - 接口 javax.accessibility.AccessibleExtendedText 中的静态变量
用于指示应被检索的文本部分是具有相同文本属性的连续文本的常量。
AttributeChangeNotification - javax.management 中的 类
提供 MBean 所发送的属性更改通知的定义。
AttributeChangeNotification(Object, long, long, String, String, String, Object, Object) - 类 javax.management.AttributeChangeNotification 的构造方法
构造一个 AttributeChangeNotification 对象。
AttributeChangeNotificationFilter - javax.management 中的 类
此类实现 attribute change notification 的 NotificationFilter 接口。
AttributeChangeNotificationFilter() - 类 javax.management.AttributeChangeNotificationFilter 的构造方法
AttributedCharacterIterator - java.text 中的 接口
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。
AttributedCharacterIterator.Attribute - java.text 中的 类
定义用于标识文本属性的属性键。
AttributedCharacterIterator.Attribute(String) - 类 java.text.AttributedCharacterIterator.Attribute 的构造方法
构造具有给定名称的 Attribute。
attributeDecl(String, String, String, String, String) - 接口 org.xml.sax.ext.DeclHandler 中的方法
报告属性类型声明。
attributeDecl(String, String, String, String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
AttributedString - java.text 中的 类
AttributedString 保存文本及相关属性信息。
AttributedString(String) - 类 java.text.AttributedString 的构造方法
构造带给定文本的 AttributedString 实例。
AttributedString(String, Map<? extends AttributedCharacterIterator.Attribute, ?>) - 类 java.text.AttributedString 的构造方法
构造带给定文本和属性的 AttributedString。
AttributedString(AttributedCharacterIterator) - 类 java.text.AttributedString 的构造方法
构造带有 AttributedCharacterIterator 表示的给定属性文本的 AttributedString。
AttributedString(AttributedCharacterIterator, int, int) - 类 java.text.AttributedString 的构造方法
构造带有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。
AttributedString(AttributedCharacterIterator, int, int, AttributedCharacterIterator.Attribute[]) - 类 java.text.AttributedString 的构造方法
构造具有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。
AttributeException - javax.print 中的 接口
接口 AttributeException 是一个混合接口，PrintException 的子类可实现该接口以报告涉及一个或多个打印属性的错误条件，特定的 Print Service 实例不支持该条件。
AttributeInUseException - javax.naming.directory 中的 异常
当操作试图添加已经存在的属性时抛出此异常。
AttributeInUseException(String) - 异常 javax.naming.directory.AttributeInUseException 的构造方法
使用解释构造一个新的 AttributeInUseException 实例。
AttributeInUseException() - 异常 javax.naming.directory.AttributeInUseException 的构造方法
构造一个新的 AttributeInUseException 实例。
AttributeList - javax.management 中的 类
表示 MBean 属性值的列表。
AttributeList() - 类 javax.management.AttributeList 的构造方法
构造一个空 AttributeList。
AttributeList(int) - 类 javax.management.AttributeList 的构造方法
构造一个具有指定初始容量的空 AttributeList。
AttributeList(AttributeList) - 类 javax.management.AttributeList 的构造方法
构造一个包含指定 AttributeList 元素的 AttributeList，元素的顺序是该 AttributeList 的迭代器所返回的顺序。
AttributeList(List<Attribute>) - 类 javax.management.AttributeList 的构造方法
构造一个包含指定 List 的元素的 AttributeList，这些元素按 List 的迭代器返回的顺序排列。
AttributeList - javax.swing.text.html.parser 中的 类
此类使用 ATTLIST 构造定义 DTD 中描述的 SGML 元素的属性。
AttributeList(String) - 类 javax.swing.text.html.parser.AttributeList 的构造方法
创建一个属性列表元素。
AttributeList(String, int, int, String, Vector<?>, AttributeList) - 类 javax.swing.text.html.parser.AttributeList 的构造方法
创建一个属性列表元素。
AttributeList - org.xml.sax 中的 接口
已过时。 此接口已经被 SAX2 Attributes 接口取代，后者包括名称空间支持。
AttributeListImpl - org.xml.sax.helpers 中的 类
已过时。 此类实现不推荐使用的接口 AttributeList；该接口已被 AttributesImpl 帮助器类中实现的 Attributes 取代。
AttributeListImpl() - 类 org.xml.sax.helpers.AttributeListImpl 的构造方法
已过时。 创建空的属性列表。
AttributeListImpl(AttributeList) - 类 org.xml.sax.helpers.AttributeListImpl 的构造方法
已过时。 构造现有属性列表的持久副本。
AttributeModificationException - javax.naming.directory 中的 异常
当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
AttributeModificationException(String) - 异常 javax.naming.directory.AttributeModificationException 的构造方法
使用解释构造一个新的 AttributeModificationException 实例。
AttributeModificationException() - 异常 javax.naming.directory.AttributeModificationException 的构造方法
构造一个新的 AttributeModificationException 实例。
attributeNames() - 类 java.beans.FeatureDescriptor 中的方法
获得与语言环境无关的此特性名称的枚举。
attributeNoNulls - 接口 java.sql.DatabaseMetaData 中的静态变量
指示可能不允许使用 NULL 值。
AttributeNotFoundException - javax.management 中的 异常
指定的属性不存在或无法检索。
AttributeNotFoundException() - 异常 javax.management.AttributeNotFoundException 的构造方法
默认的构造方法。
AttributeNotFoundException(String) - 异常 javax.management.AttributeNotFoundException 的构造方法
允许指定具体错误消息的构造方法。
attributeNullable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示明确允许使用 NULL 值。
attributeNullableUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道是否允许使用 NULL 值。
Attributes - java.util.jar 中的 类
Attributes 类将 Manifest 属性名称映射到关联的字符串值。
Attributes() - 类 java.util.jar.Attributes 的构造方法
构造具有默认大小的新的空 Attributes 对象。
Attributes(int) - 类 java.util.jar.Attributes 的构造方法
构造具有指定初始大小的新的空 Attributes 对象。
Attributes(Attributes) - 类 java.util.jar.Attributes 的构造方法
构造新的 Attributes 对象，该对象与指定的 Attributes 具有相同的属性名称-值映射关系。
attributes - 类 javax.accessibility.AccessibleAttributeSequence 中的变量
文本属性
Attributes - javax.naming.directory 中的 接口
此接口表示属性的集合。
Attributes - org.xml.sax 中的 接口
关于 XML 属性列表的接口。
Attributes.Name - java.util.jar 中的 类
Attributes.Name 类表示存储在此 Map 中的一个属性名称。
Attributes.Name(String) - 类 java.util.jar.Attributes.Name 的构造方法
用给定字符串名称构造一个新的属性名称。
Attributes2 - org.xml.sax.ext 中的 接口
SAX2 扩展，用于扩充通过 Attributes 提供的每个属性信息。
Attributes2Impl - org.xml.sax.ext 中的 类
用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。
Attributes2Impl() - 类 org.xml.sax.ext.Attributes2Impl 的构造方法
构造一个新的空 Attributes2Impl 对象。
Attributes2Impl(Attributes) - 类 org.xml.sax.ext.Attributes2Impl 的构造方法
复制现有属性或 Attributes2 对象。
AttributeSet - javax.print.attribute 中的 接口
接口 AttributeSet 为打印属性集指定接口。
AttributeSet - javax.swing.text 中的 接口
唯一属性的集合。
AttributeSet.CharacterAttribute - javax.swing.text 中的 接口
此接口是类型签名，可出现在任意属性键上以帮助实现字符级的表示。
AttributeSet.ColorAttribute - javax.swing.text 中的 接口
此接口是类型签名，可出现在任意属性键上以帮助实现颜色的表示。
AttributeSet.FontAttribute - javax.swing.text 中的 接口
此接口是类型签名，可出现在任意属性键上以帮助确定使用何种字体来呈现某类文本。
AttributeSet.ParagraphAttribute - javax.swing.text 中的 接口
此接口是类型签名，可出现在任意属性键上以帮助实现段落级的表示。
AttributeSetUtilities - javax.print.attribute 中的 类
类 AttributeSetUtilities 为操作 AttributeSets 提供静态方法。
AttributesImpl - org.xml.sax.helpers 中的 类
Attributes 接口的默认实现。
AttributesImpl() - 类 org.xml.sax.helpers.AttributesImpl 的构造方法
构造一个新的空 AttributesImpl 对象。
AttributesImpl(Attributes) - 类 org.xml.sax.helpers.AttributesImpl 的构造方法
复制现有 Attributes 对象。
attributeUpdate(PrintJobAttributeEvent) - 接口 javax.print.event.PrintJobAttributeListener 中的方法
通知侦听器某些打印作业属性已更改。
attributeUpdate(PrintServiceAttributeEvent) - 接口 javax.print.event.PrintServiceAttributeListener 中的方法
调用此方法来通知侦听器关于打印服务中的事件。
AttributeValueExp - javax.management 中的 类
表示用作关系约束参数的属性。
AttributeValueExp() - 类 javax.management.AttributeValueExp 的构造方法
已过时。 在查询中不能使用此构造方法所创建的实例。
AttributeValueExp(String) - 类 javax.management.AttributeValueExp 的构造方法
创建一个表示指定对象属性 attr 的新 AttributeValueExp。
attrID - 类 javax.naming.directory.BasicAttribute 中的变量
保存属性的 id。
atts - 类 javax.swing.text.html.parser.Element 中的变量
AU - 类 javax.sound.sampled.AudioFileFormat.Type 中的静态变量
指定 AU 文件。
AudioClip - java.applet 中的 接口
AudioClip 接口是用于播放音频剪辑的简单抽象。
AudioFileFormat - javax.sound.sampled 中的 类
AudioFileFormat 类的实例描述音频文件，包括文件类型、文件长度（以字节为单位）、文件中包含的音频数据的长度（以示例帧为单位），以及音频数据的格式。
AudioFileFormat(AudioFileFormat.Type, int, AudioFormat, int) - 类 javax.sound.sampled.AudioFileFormat 的构造方法
构造音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type, AudioFormat, int) - 类 javax.sound.sampled.AudioFileFormat 的构造方法
构造音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type, AudioFormat, int, Map<String, Object>) - 类 javax.sound.sampled.AudioFileFormat 的构造方法
构造具有定义的属性集合的音频文件格式对象。
AudioFileFormat.Type - javax.sound.sampled 中的 类
Type 类的实例表示音频文件的标准类型之一。
AudioFileFormat.Type(String, String) - 类 javax.sound.sampled.AudioFileFormat.Type 的构造方法
构造文件类型。
AudioFileReader - javax.sound.sampled.spi 中的 类
音频文件读取服务的提供者。
AudioFileReader() - 类 javax.sound.sampled.spi.AudioFileReader 的构造方法
AudioFileWriter - javax.sound.sampled.spi 中的 类
音频文件写入服务的提供者。
AudioFileWriter() - 类 javax.sound.sampled.spi.AudioFileWriter 的构造方法
AudioFormat - javax.sound.sampled 中的 类
AudioFormat 是在声音流中指定特定数据安排的类。
AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean) - 类 javax.sound.sampled.AudioFormat 的构造方法
构造具有给定参数的 AudioFormat。
AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean, Map<String, Object>) - 类 javax.sound.sampled.AudioFormat 的构造方法
构造具有给定参数的 AudioFormat。
AudioFormat(float, int, int, boolean, boolean) - 类 javax.sound.sampled.AudioFormat 的构造方法
构造具有线性 PCM 编码和给定参数的 AudioFormat。
AudioFormat.Encoding - javax.sound.sampled 中的 类
Encoding 类命名用于音频流的数据表示形式的特定类型。
AudioFormat.Encoding(String) - 类 javax.sound.sampled.AudioFormat.Encoding 的构造方法
构造一个新编码。
AudioInputStream - javax.sound.sampled 中的 类
音频输入流是具有指定音频格式和长度的输入流。
AudioInputStream(InputStream, AudioFormat, long) - 类 javax.sound.sampled.AudioInputStream 的构造方法
使用指定输入流中的音频数据构造具有请求的格式和长度（以示例帧为单位）的音频输入流。
AudioInputStream(TargetDataLine) - 类 javax.sound.sampled.AudioInputStream 的构造方法
构造从指示的目标数据行读取数据的音频输入流。
AudioPermission - javax.sound.sampled 中的 类
AudioPermission 类表示对音频系统资源的访问权限。
AudioPermission(String) - 类 javax.sound.sampled.AudioPermission 的构造方法
创建具有指定符号名（如 "play" 或 "record"）的 AudioPermission 对象。
AudioPermission(String, String) - 类 javax.sound.sampled.AudioPermission 的构造方法
创建具有指定符号名（"play" 或 "record"）的 AudioPermission 对象。
AudioSystem - javax.sound.sampled 中的 类
AudioSystem 类充当取样音频系统资源的入口点。
augmentList(Action[], Action[]) - 类 javax.swing.text.TextAction 中的静态方法
取一个命令列表并用另一个命令列表去扩充。
AUGUST - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第八个月的 Calendar.MONTH 字段值。
AUGUST - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第八个月的值。
authenticate(Object) - 接口 javax.management.remote.JMXAuthenticator 中的方法
用给定的客户端凭据验证 MBeanServerConnection 客户端。
AuthenticationException - javax.naming 中的 异常
当访问命名或目录服务发生验证错误时，抛出此异常。
AuthenticationException(String) - 异常 javax.naming.AuthenticationException 的构造方法
使用所提供的解释构造一个新的 AuthenticationException 实例。
AuthenticationException() - 异常 javax.naming.AuthenticationException 的构造方法
构造一个新的 AuthenticationException 实例。
AuthenticationException - javax.security.sasl 中的 异常
此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。
AuthenticationException() - 异常 javax.security.sasl.AuthenticationException 的构造方法
构造一个新的 AuthenticationException 实例。
AuthenticationException(String) - 异常 javax.security.sasl.AuthenticationException 的构造方法
构造带详细消息的新 AuthenticationException 实例。
AuthenticationException(String, Throwable) - 异常 javax.security.sasl.AuthenticationException 的构造方法
构造带详细消息和根异常的新 AuthenticationException 实例。
AuthenticationNotSupportedException - javax.naming 中的 异常
当所请求验证的特定 flavor 不受支持时，抛出此异常。
AuthenticationNotSupportedException(String) - 异常 javax.naming.AuthenticationNotSupportedException 的构造方法
使用解释构造一个新的 AuthenticationNotSupportedException 实例。
AuthenticationNotSupportedException() - 异常 javax.naming.AuthenticationNotSupportedException 的构造方法
构造一个新的 AuthenticationNotSupportedException 实例，将解释和所有名称解析字段初始化为 null。
Authenticator - java.net 中的 类
Authenticator 类表示懂得如何获得网络连接验证的对象。
Authenticator() - 类 java.net.Authenticator 的构造方法
AUTHENTICATOR - 类 javax.management.remote.JMXConnectorServer 中的静态变量
为连接器服务器指定经验证的属性名称。
Authenticator.RequestorType - java.net 中的 枚举
请求验证的实体的类型。
AUTHORITATIVE - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定所请求服务的权威性的环境属性名称。
AuthorizeCallback - javax.security.sasl 中的 类
此回调由 SaslServer 使用，以确定某个实体（由已验证的验证 id 所标识）能否代表另一个实体（由授权 id 所标识）。
AuthorizeCallback(String, String) - 类 javax.security.sasl.AuthorizeCallback 的构造方法
构造 AuthorizeCallback 的实例。
AuthPermission - javax.security.auth 中的 类
此类用于验证权限。
AuthPermission(String) - 类 javax.security.auth.AuthPermission 的构造方法
创建具有指定名称的新 AuthPermission。
AuthPermission(String, String) - 类 javax.security.auth.AuthPermission 的构造方法
创建具有指定名称的新 AuthPermission 对象。
AuthProvider - java.security 中的 类
此类定义 provider 的登录和注销方法。
AuthProvider(String, double, String) - 类 java.security.AuthProvider 的构造方法
构造具有指定名称、版本号和信息的 provider。
AUTO_RESIZE_ALL_COLUMNS - 类 javax.swing.JTable 中的静态变量
在所有的调整大小操作中，按比例调整所有的列。
AUTO_RESIZE_LAST_COLUMN - 类 javax.swing.JTable 中的静态变量
在所有的调整大小操作中，只对最后一列进行调整。
AUTO_RESIZE_NEXT_COLUMN - 类 javax.swing.JTable 中的静态变量
在 UI 中调整了一个列时，对其下一列进行相反方向的调整。
AUTO_RESIZE_OFF - 类 javax.swing.JTable 中的静态变量
不自动调整列的宽度；使用滚动条。
AUTO_RESIZE_SUBSEQUENT_COLUMNS - 类 javax.swing.JTable 中的静态变量
在 UI 调整中，更改后续列以保持总宽度不变；此为默认行为。
autoCommitFailureClosesAllResultSets() - 接口 java.sql.DatabaseMetaData 中的方法
当 autoCommit 为 true 时，获取 SQLException 是否指示所有打开的 ResultSets 已关闭（包括那些可保持的）。
autoCreateColumnsFromModel - 类 javax.swing.JTable 中的变量
如果为 true，则表对 TableModel 进行查询以构建默认列集。
autoResizeMode - 类 javax.swing.JTable 中的变量
确定表是否自动调整列的宽度以占用表的整个宽度，以及如何进行调整。
Autoscroll - java.awt.dnd 中的 接口
在 DnD 操作期间，用户有可能希望将操作目标放入一个可滚动的 GUI 控件区域中，而该区域当前对用户是不可见的。
autoscroll(Point) - 接口 java.awt.dnd.Autoscroll 中的方法
通知 Component 自动滚动
autoScrollDown() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
autoscrollTimer - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
autoScrollUp() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
AUTOSENSE - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
AUTOSENSE - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
AUTOSENSE - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
AUX_RETURN - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上辅助返回音量的控件。
AUX_SEND - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上辅助发送音量的控件。
available() - 类 java.io.BufferedInputStream 中的方法
返回可以从此输入流读取（或跳过）、且不受此输入流接下来的方法调用阻塞的估计字节数。
available() - 类 java.io.ByteArrayInputStream 中的方法
返回可从此输入流读取（或跳过）的剩余字节数。
available() - 类 java.io.FileInputStream 中的方法
返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。
available() - 类 java.io.FilterInputStream 中的方法
返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。
available() - 类 java.io.InputStream 中的方法
返回此输入流下一个方法调用可以不受阻塞地从此输入流读取（或跳过）的估计字节数。
available() - 类 java.io.LineNumberInputStream 中的方法
已过时。 无阻塞情况下返回可以从此输入流中读取的字节数。
available() - 接口 java.io.ObjectInput 中的方法
返回可以无阻塞地读取的字节数。
available() - 类 java.io.ObjectInputStream 中的方法
返回可以不受阻塞地读取的字节数。
available() - 类 java.io.PipedInputStream 中的方法
返回可以不受阻塞地从此输入流中读取的字节数。
available() - 类 java.io.PushbackInputStream 中的方法
返回可以不受下一次调用此输入流的方法阻塞地从此输入流读取（或跳过）的估计字节数。
available() - 类 java.io.SequenceInputStream 中的方法
返回不受阻塞地从当前底层输入流读取（或跳过）的字节数的估计值，方法是通过下一次调用当前底层输入流的方法。
available() - 类 java.io.StringBufferInputStream 中的方法
已过时。 返回无阻塞情况下可以从此输入流读取的字节数。
available() - 类 java.net.SocketImpl 中的方法
返回可以不受阻塞地从此套接字中读取的字节数。
available() - 类 java.util.zip.DeflaterInputStream 中的方法
在到达 EOF 后返回 0；否则始终返回 1。
available() - 类 java.util.zip.InflaterInputStream 中的方法
在到达 EOF 后返回 0；否则始终返回 1。
available() - 类 java.util.zip.ZipInputStream 中的方法
在 EOF 到达当前条目数据后，返回 0；否则，始终返回 1。
available() - 类 javax.crypto.CipherInputStream 中的方法
返回不发生阻塞地从此输入流读取的字节数。
available() - 类 javax.sound.sampled.AudioInputStream 中的方法
返回可不受阻塞地从此音频输入流中读取（或跳过）的最大字节数。
available() - 接口 javax.sound.sampled.DataLine 中的方法
获得当前可用于数据行内部缓冲区中处理的应用程序的数据字节数。
availableCharsets() - 类 java.nio.charset.Charset 中的静态方法
构造从规范 charset 名称到 charset 对象的有序映射。
availableLocales - 类 javax.imageio.ImageReader 中的变量
可以用来本地化警告消息的 Locale 组成的数组，如果不支持本地化，则为 null。
availableLocales - 类 javax.imageio.ImageWriter 中的变量
可以用来本地化警告消息和压缩设置值的 Locale 组成的数组，如果本地化不受支持，则将它们初始化为 null。
availablePermits() - 类 java.util.concurrent.Semaphore 中的方法
返回此信号量中当前可用的许可数。
availableProcessors() - 类 java.lang.Runtime 中的方法
向 Java 虚拟机返回可用处理器的数目。
averageBytesPerChar() - 类 java.nio.charset.CharsetEncoder 中的方法
返回为每个输入字符生成的平均字节数。
averageCharsPerByte() - 类 java.nio.charset.CharsetDecoder 中的方法
返回为每个输入字节生成的平均字符数。
avoidingGui() - 类 java.beans.beancontext.BeanContextSupport 中的方法
用于确定 BeanContext 子级是否避免使用其 GUI。
avoidingGui() - 接口 java.beans.Visibility 中的方法
确定此 bean 是否避免使用 GUI。
await() - 类 java.util.concurrent.CountDownLatch 中的方法
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断。
await(long, TimeUnit) - 类 java.util.concurrent.CountDownLatch 中的方法
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断或超出了指定的等待时间。
await() - 类 java.util.concurrent.CyclicBarrier 中的方法
在所有参与者都已经在此 barrier 上调用 await 方法之前，将一直等待。
await(long, TimeUnit) - 类 java.util.concurrent.CyclicBarrier 中的方法
在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。
await() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
实现可中断的条件等待。
await(long, TimeUnit) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
实现定时条件等待。
await() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
实现不可中断的条件等待。
await(long, TimeUnit) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
实现定时的条件等待。
await() - 接口 java.util.concurrent.locks.Condition 中的方法
造成当前线程在接到信号或被中断之前一直处于等待状态。
await(long, TimeUnit) - 接口 java.util.concurrent.locks.Condition 中的方法
造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
awaitNanos(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
实现定时条件等待。
awaitNanos(long) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
实现定时的条件等待。
awaitNanos(long) - 接口 java.util.concurrent.locks.Condition 中的方法
造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
awaitTermination(long, TimeUnit) - 接口 java.util.concurrent.ExecutorService 中的方法
请求关闭、发生超时或者当前线程中断，无论哪一个首先发生之后，都将导致阻塞，直到所有任务完成执行。
awaitTermination(long, TimeUnit) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
awaitUninterruptibly() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
实现不可中断的条件等待。
awaitUninterruptibly() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
实现不可中断的条件等待。
awaitUninterruptibly() - 接口 java.util.concurrent.locks.Condition 中的方法
造成当前线程在接到信号之前一直处于等待状态。
awaitUntil(Date) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
实现绝对定时条件等待。
awaitUntil(Date) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
实现绝对定时条件等待。
awaitUntil(Date) - 接口 java.util.concurrent.locks.Condition 中的方法
造成当前线程在接到信号、被中断或到达指定最后期限之前一直处于等待状态。
AWT_COMPONENT - 类 javax.accessibility.AccessibleRole 中的静态变量
一个 AWT 组件，但关于它的其他信息都是未知的。
AWTError - java.awt 中的 错误
当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。
AWTError(String) - 错误 java.awt.AWTError 的构造方法
构造带指定详细消息的 AWTError 的实例。
AWTEvent - java.awt 中的 类
所有 AWT 事件的根事件类。
AWTEvent(Event) - 类 java.awt.AWTEvent 的构造方法
从 1.0 样式的事件参数构造一个 AWTEvent 对象。
AWTEvent(Object, int) - 类 java.awt.AWTEvent 的构造方法
使用指定的源对象和类型构造一个 AWTEvent 对象。
AWTEventListener - java.awt.event 中的 接口
该侦听器接口用于接收指派给对象的事件的通知，这些对象是 Component、MenuComponent 或其子类的实例。
AWTEventListenerProxy - java.awt.event 中的 类
扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。
AWTEventListenerProxy(long, AWTEventListener) - 类 java.awt.event.AWTEventListenerProxy 的构造方法
将 AWTEventListener 绑定到特定事件掩码的构造方法。
AWTEventMulticaster - java.awt 中的 类
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
AWTEventMulticaster(EventListener, EventListener) - 类 java.awt.AWTEventMulticaster 的构造方法
创建一个将侦听器 a 和侦听器 b 链接起来的事件多路广播器实例。
AWTException - java.awt 中的 异常
表示发生了 Absract Window Toolkit 异常。
AWTException(String) - 异常 java.awt.AWTException 的构造方法
构造带指定详细消息的 AWTException 实例。
AWTKeyStroke - java.awt 中的 类
AWTKeyStroke 表示键盘（或等效输入设备）上的键操作。
AWTKeyStroke() - 类 java.awt.AWTKeyStroke 的构造方法
使用默认值构造 AWTKeyStroke。
AWTKeyStroke(char, int, int, boolean) - 类 java.awt.AWTKeyStroke 的构造方法
使用指定值构造 AWTKeyStroke。
AWTPermission - java.awt 中的 类
此类用于 AWT 权限。
AWTPermission(String) - 类 java.awt.AWTPermission 的构造方法
创建具有指定名称的新 AWTPermission。
AWTPermission(String, String) - 类 java.awt.AWTPermission 的构造方法
创建具有指定名称的新 AWTPermission 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


B - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

B

b - 类 java.awt.AWTEventMulticaster 中的变量
B - 类 java.awt.PageAttributes.MediaType 中的静态变量
Engineering B (11 x 17 in) 的 MediaType 实例。
B - 类 javax.print.attribute.standard.MediaSize.Engineering 中的静态变量
指定 engineering B 尺寸，11 inch × 17 inch。
B - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
B 尺寸。
B - 类 javax.swing.text.html.HTML.Tag 中的静态变量
B0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B0 的别名。
B0 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B0 尺寸，1000 mm × 1414 mm。
B0 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B0 尺寸，1030 mm × 1456 mm。
B1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B1 的别名。
B1 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B1 尺寸，707 mm × 1000 mm。
B1 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B1 尺寸，728 mm × 1030 mm。
B10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B10 的别名。
B10 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B10 尺寸，31 mm × 44 mm。
B10 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B10 尺寸，32 mm × 45 mm。
B2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B2 的别名。
B2 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B2 尺寸，500 mm × 707 mm。
B2 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B2 尺寸，515 mm × 728 mm。
B3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B3 的别名。
B3 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B3 尺寸，353 mm × 500 mm。
B3 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B3 尺寸，364 mm × 515 mm。
B4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B4 的别名。
B4 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B4 尺寸，250 mm × 353 mm。
B4 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B4 尺寸，257 mm × 364 mm。
B5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B5 的别名。
B5 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B5 尺寸，176 mm × 250 mm。
B5 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B5 尺寸，182 mm × 257 mm。
B6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B6 的别名。
B6 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B6 尺寸，125 mm × 176 mm。
B6 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B6 尺寸，128 mm × 182 mm。
B7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B7 的别名。
B7 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B7 尺寸，88 mm × 125 mm。
B7 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B7 尺寸，91 mm × 128 mm。
B8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B8 的别名。
B8 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B8 尺寸，62 mm × 88 mm。
B8 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B8 尺寸，64 mm × 91 mm。
B9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B9 的别名。
B9 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B9 尺寸，44 mm × 62 mm。
B9 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B9 尺寸，45 mm × 64 mm。
BACK_SPACE - 类 java.awt.Event 中的静态变量
BackSpace 键。
backBuffers - 类 java.awt.Component.BltBufferStrategy 中的变量
后台缓冲区
BACKGROUND - 类 java.awt.BufferCapabilities.FlipContents 中的静态变量
当翻转内容为 BACKGROUND 时，后台缓冲区的内容在翻转后使用背景颜色清除。
BACKGROUND - 类 java.awt.font.TextAttribute 中的静态变量
用于呈现文本背景的 paint 的属性键。
BACKGROUND - 类 javax.swing.plaf.synth.ColorType 中的静态变量
某一 region 背景的 ColorType。
BACKGROUND - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BACKGROUND - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
Background - 类 javax.swing.text.StyleConstants 中的静态变量
背景色属性的名称。
BACKGROUND_ATTACHMENT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BACKGROUND_COLOR - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BACKGROUND_IMAGE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BACKGROUND_POSITION - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BACKGROUND_REPEAT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
backgroundNonSelectionColor - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
不选定节点时用于背景的颜色。
backgroundSelectionColor - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
选定节点时用于背景的颜色。
backingStore - 类 javax.swing.JViewport 中的变量
已过时。 从 Java 2 平台 v1.3 开始
BACKINGSTORE_SCROLL_MODE - 类 javax.swing.JViewport 中的静态变量
将视口内容拉入屏幕外图像。
BackingStoreException - java.util.prefs 中的 异常
抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。
BackingStoreException(String) - 异常 java.util.prefs.BackingStoreException 的构造方法
构造带指定详细消息的 BackingStoreException。
BackingStoreException(Throwable) - 异常 java.util.prefs.BackingStoreException 的构造方法
构造带指定原因的 BackingStoreException。
backingStoreImage - 类 javax.swing.JViewport 中的变量
用于后备存储的视图图像。
Backward - 类 javax.swing.text.Position.Bias 中的静态变量
指示到模型中上一字符的偏差。
BACKWARD_TRAVERSAL_KEYS - 类 java.awt.KeyboardFocusManager 中的静态变量
Backward 焦点遍历键的标识符。
backwardAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符在逻辑上向后移动一个位置的动作名称。
BAD_BINDINGS - 异常 org.ietf.jgss.GSSException 中的静态变量
通道绑定不匹配。
BAD_CONTEXT - org.omg.CORBA 中的 异常
当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
BAD_CONTEXT() - 异常 org.omg.CORBA.BAD_CONTEXT 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(String) - 异常 org.omg.CORBA.BAD_CONTEXT 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_CONTEXT 的构造方法
使用指定次要代码和完成状态构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_CONTEXT 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 BAD_CONTEXT 异常。
BAD_INV_ORDER - org.omg.CORBA 中的 异常
此异常指示调用者按错误顺序调用了操作。
BAD_INV_ORDER() - 异常 org.omg.CORBA.BAD_INV_ORDER 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(String) - 异常 org.omg.CORBA.BAD_INV_ORDER 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_INV_ORDER 的构造方法
使用指定次要代码和完成状态构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_INV_ORDER 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 BAD_INV_ORDER 异常。
BAD_LOCATION - 类 javax.swing.text.AbstractDocument 中的静态变量
指示位置错误的错误消息。
BAD_MECH - 异常 org.ietf.jgss.GSSException 中的静态变量
请求了不受支持的机制。
BAD_MIC - 异常 org.ietf.jgss.GSSException 中的静态变量
具有无效的完整性检查的标记。
BAD_NAME - 异常 org.ietf.jgss.GSSException 中的静态变量
提供了无效名称。
BAD_NAMETYPE - 异常 org.ietf.jgss.GSSException 中的静态变量
提供了不受支持的类型的名称。
BAD_OPERATION - org.omg.CORBA 中的 异常
当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
BAD_OPERATION() - 异常 org.omg.CORBA.BAD_OPERATION 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_OPERATION 异常。
BAD_OPERATION(String) - 异常 org.omg.CORBA.BAD_OPERATION 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_OPERATION 异常。
BAD_OPERATION(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_OPERATION 的构造方法
使用指定次要代码和完成状态构造一个 BAD_OPERATION 异常。
BAD_OPERATION(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_OPERATION 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 BAD_OPERATION 异常。
BAD_PARAM - org.omg.CORBA 中的 异常
当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
BAD_PARAM() - 异常 org.omg.CORBA.BAD_PARAM 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_PARAM 异常。
BAD_PARAM(String) - 异常 org.omg.CORBA.BAD_PARAM 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_PARAM 异常。
BAD_PARAM(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_PARAM 的构造方法
使用指定次要代码和完成状态构造一个 BAD_PARAM 异常。
BAD_PARAM(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_PARAM 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 BAD_PARAM 异常。
BAD_POLICY - org.omg.CORBA 中的 接口
将填充在 PolicyError 异常中的 PolicyErrorCode。
BAD_POLICY_TYPE - org.omg.CORBA 中的 接口
将填充在 PolicyError 异常中的 PolicyErrorCode。
BAD_POLICY_VALUE - org.omg.CORBA 中的 接口
包含指示某个策略值的值，该策略值对于 create_policy 方法（在 ORB 类中定义）调用中的有效策略类型而言是不正确的。
BAD_QOP - 异常 org.ietf.jgss.GSSException 中的静态变量
不受支持的 QOP 值。
BAD_QOS - org.omg.CORBA 中的 异常
只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
BAD_QOS() - 异常 org.omg.CORBA.BAD_QOS 的构造方法
构造一个 BAD_QOS 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。
BAD_QOS(String) - 异常 org.omg.CORBA.BAD_QOS 的构造方法
使用指定消息构造一个 BAD_QOS 异常。
BAD_QOS(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_QOS 的构造方法
使用指定次要代码和完成状态构造一个 BAD_QOS 异常。
BAD_QOS(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_QOS 的构造方法
使用指定消息、次要代码和完成状态构造一个 BAD_QOS 异常。
BAD_STATUS - 异常 org.ietf.jgss.GSSException 中的静态变量
无效的状态码。
BAD_TYPECODE - org.omg.CORBA 中的 异常
当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
BAD_TYPECODE() - 异常 org.omg.CORBA.BAD_TYPECODE 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(String) - 异常 org.omg.CORBA.BAD_TYPECODE 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_TYPECODE 的构造方法
使用指定次要代码和完成状态构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_TYPECODE 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 BAD_TYPECODE 异常。
BadAttributeValueExpException - javax.management 中的 异常
向构造的查询方法传递无效的 MBean 属性时，抛出此异常。
BadAttributeValueExpException(Object) - 异常 javax.management.BadAttributeValueExpException 的构造方法
构造带指定 Object 的 BadAttributeValueExpException。
BadBinaryOpValueExpException - javax.management 中的 异常
向构造查询的方法传递无效的表达式时，抛出此异常。
BadBinaryOpValueExpException(ValueExp) - 异常 javax.management.BadBinaryOpValueExpException 的构造方法
构造带指定 ValueExp 的 BadBinaryOpValueExpException。
BadBreakWeight - 类 javax.swing.text.View 中的静态变量
该权重指示对于格式化来说视图未处于拆分的好时机。
BadKind - org.omg.CORBA.TypeCodePackage 中的 异常
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。
BadKind() - 异常 org.omg.CORBA.TypeCodePackage.BadKind 的构造方法
构造一个不带任何原因消息的 BadKind 异常。
BadKind(String) - 异常 org.omg.CORBA.TypeCodePackage.BadKind 的构造方法
构造一个带有指定原因消息的 BadKind 异常。
BadLocationException - javax.swing.text 中的 异常
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
BadLocationException(String, int) - 异常 javax.swing.text.BadLocationException 的构造方法
创建新的 BadLocationException 对象。
BadPaddingException - javax.crypto 中的 异常
当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
BadPaddingException() - 异常 javax.crypto.BadPaddingException 的构造方法
构造不带详细消息的 BadPaddingException。
BadPaddingException(String) - 异常 javax.crypto.BadPaddingException 的构造方法
构造带指定详细消息的 BadPaddingException。
BadStringOperationException - javax.management 中的 异常
向构造查询的方法传递无效的字符串操作时，抛出此异常。
BadStringOperationException(String) - 异常 javax.management.BadStringOperationException 的构造方法
构造带指定详细消息的 BadStringOperationException。
BALANCE - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示两个立体声扬声器之间立体声信号相对平衡的控件。
BandCombineOp - java.awt.image 中的 类
此类使用一个指定矩阵对 Raster 中的 band 进行任意线性组合。
BandCombineOp(float[][], RenderingHints) - 类 java.awt.image.BandCombineOp 的构造方法
构造一个具有指定矩阵的 BandCombineOp。
BandedSampleModel - java.awt.image 中的 类
此类表示以 band 交错方式存储的图像数据，像素的每个样本都占用 DataBuffer 的一个数据元素。
BandedSampleModel(int, int, int, int) - 类 java.awt.image.BandedSampleModel 的构造方法
构造一个具有指定参数的 BandedSampleModel。
BandedSampleModel(int, int, int, int, int[], int[]) - 类 java.awt.image.BandedSampleModel 的构造方法
构造一个具有指定参数的 BandedSampleModel。
bandOffsets - 类 java.awt.image.ComponentSampleModel 中的变量
数据数组元素中所有 band 的偏移量。
bank - 类 javax.sound.midi.VoiceStatus 中的变量
此声音当前正在使用的乐器的库号。
bankIndices - 类 java.awt.image.ComponentSampleModel 中的变量
各个存储图像数据 band 的存储单元的索引。
banks - 类 java.awt.image.DataBuffer 中的变量
此 DataBuffer 中存储单元的数量。
BASE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
base - 类 javax.swing.text.html.parser.DTD 中的变量
BASE64 - 接口 javax.xml.crypto.dsig.Transform 中的静态变量
Base64 转换算法 URI。
BASEFONT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
baseIsLeftToRight() - 类 java.text.Bidi 中的方法
如果基本方向是从左到右，则返回 true。
BASELINE - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
BASELINE - 类 javax.swing.SpringLayout 中的静态变量
指定组件的基线。
BASELINE_LEADING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
BASELINE_TRAILING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
baselineLayout(int, int, int[], int[]) - 类 javax.swing.text.BoxView 中的方法
在给定的 targetSpan 区域，即我们将使用的区域的宽度（或高度），计算每个子视图在此 BoxView 中的位置和扩展。
baselineRequirements(int, SizeRequirements) - 类 javax.swing.text.BoxView 中的方法
通过检查每个子视图的大小计算此 BoxView 的大小要求。
BaseRowSet - javax.sql.rowset 中的 类
提供一个具有基本功能的 RowSet 对象的抽象类。
BaseRowSet() - 类 javax.sql.rowset.BaseRowSet 的构造方法
构造一个新的 BaseRowSet 对象，使用默认的 Vector 对象初始化其 listeners 字段。
baseWireHandle - 接口 java.io.ObjectStreamConstants 中的静态变量
分配的第一个句柄。
BASIC_LATIN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Basic Latin”Unicode 字符块的常量。
BasicArrowButton - javax.swing.plaf.basic 中的 类
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
BasicArrowButton(int, Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicArrowButton 的构造方法
创建一个在指定方向上绘制其箭头并具有指定颜色的 BasicArrowButton。
BasicArrowButton(int) - 类 javax.swing.plaf.basic.BasicArrowButton 的构造方法
创建一个在指定方向上绘制其箭头的 BasicArrowButton。
BasicAttribute - javax.naming.directory 中的 类
此类提供 Attribute 接口的基本实现。
BasicAttribute(String) - 类 javax.naming.directory.BasicAttribute 的构造方法
构造一个不带值无序属性的新实例。
BasicAttribute(String, Object) - 类 javax.naming.directory.BasicAttribute 的构造方法
构造一个带有单个值的无序属性的新实例。
BasicAttribute(String, boolean) - 类 javax.naming.directory.BasicAttribute 的构造方法
构造一个不带值的可能为有序属性的新实例。
BasicAttribute(String, Object, boolean) - 类 javax.naming.directory.BasicAttribute 的构造方法
构造一个带有单个值的可能为有序属性的新实例。
BasicAttributes - javax.naming.directory 中的 类
此类提供 Attributes 接口的基本实现。
BasicAttributes() - 类 javax.naming.directory.BasicAttributes 的构造方法
构造一个新的 Attributes 实例。
BasicAttributes(boolean) - 类 javax.naming.directory.BasicAttributes 的构造方法
构造一个新的 Attributes 实例。
BasicAttributes(String, Object) - 类 javax.naming.directory.BasicAttributes 的构造方法
构造带有一个属性的新 Attributes 实例。
BasicAttributes(String, Object, boolean) - 类 javax.naming.directory.BasicAttributes 的构造方法
构造带有一个属性的新 Attributes 实例。
BasicBorders - javax.swing.plaf.basic 中的 类
可以提供适合基本 L&F 的 Border 的工厂对象。
BasicBorders() - 类 javax.swing.plaf.basic.BasicBorders 的构造方法
BasicBorders.ButtonBorder - javax.swing.plaf.basic 中的 类
BasicBorders.ButtonBorder(Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 的构造方法
BasicBorders.FieldBorder - javax.swing.plaf.basic 中的 类
BasicBorders.FieldBorder(Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 的构造方法
BasicBorders.MarginBorder - javax.swing.plaf.basic 中的 类
BasicBorders.MarginBorder() - 类 javax.swing.plaf.basic.BasicBorders.MarginBorder 的构造方法
BasicBorders.MenuBarBorder - javax.swing.plaf.basic 中的 类
BasicBorders.MenuBarBorder(Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 的构造方法
BasicBorders.RadioButtonBorder - javax.swing.plaf.basic 中的 类
BasicBorders.RadioButtonBorder(Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 的构造方法
BasicBorders.RolloverButtonBorder - javax.swing.plaf.basic 中的 类
用于翻转工具栏按钮的特殊细边框。
BasicBorders.RolloverButtonBorder(Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder 的构造方法
BasicBorders.SplitPaneBorder - javax.swing.plaf.basic 中的 类
绘制围绕拆分窗格的边框。
BasicBorders.SplitPaneBorder(Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 的构造方法
BasicBorders.ToggleButtonBorder - javax.swing.plaf.basic 中的 类
BasicBorders.ToggleButtonBorder(Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 的构造方法
BasicButtonListener - javax.swing.plaf.basic 中的 类
按钮侦听器。
BasicButtonListener(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonListener 的构造方法
BasicButtonUI - javax.swing.plaf.basic 中的 类
BasicButton 实现
BasicButtonUI() - 类 javax.swing.plaf.basic.BasicButtonUI 的构造方法
BasicCheckBoxMenuItemUI - javax.swing.plaf.basic 中的 类
BasicCheckboxMenuItem 实现
BasicCheckBoxMenuItemUI() - 类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 的构造方法
BasicCheckBoxUI - javax.swing.plaf.basic 中的 类
BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicCheckBoxUI() - 类 javax.swing.plaf.basic.BasicCheckBoxUI 的构造方法
BasicColorChooserUI - javax.swing.plaf.basic 中的 类
为 JColorChooser 提供基本外观。
BasicColorChooserUI() - 类 javax.swing.plaf.basic.BasicColorChooserUI 的构造方法
BasicColorChooserUI.PropertyHandler - javax.swing.plaf.basic 中的 类
因编译器故障而被标记为 "public" 的内部类。
BasicColorChooserUI.PropertyHandler() - 类 javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler 的构造方法
BasicComboBoxEditor - javax.swing.plaf.basic 中的 类
用于可编辑组合框的默认编辑器。
BasicComboBoxEditor() - 类 javax.swing.plaf.basic.BasicComboBoxEditor 的构造方法
BasicComboBoxEditor.UIResource - javax.swing.plaf.basic 中的 类
实现 UIResource 的 BasicComboBoxEditor 的子类。
BasicComboBoxEditor.UIResource() - 类 javax.swing.plaf.basic.BasicComboBoxEditor.UIResource 的构造方法
BasicComboBoxRenderer - javax.swing.plaf.basic 中的 类
ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicComboBoxRenderer() - 类 javax.swing.plaf.basic.BasicComboBoxRenderer 的构造方法
BasicComboBoxRenderer.UIResource - javax.swing.plaf.basic 中的 类
实现 UIResource 的 BasicComboBoxRenderer 的子类。
BasicComboBoxRenderer.UIResource() - 类 javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource 的构造方法
BasicComboBoxUI - javax.swing.plaf.basic 中的 类
JComboBox 的基本 UI 实现。
BasicComboBoxUI() - 类 javax.swing.plaf.basic.BasicComboBoxUI 的构造方法
BasicComboBoxUI.ComboBoxLayoutManager - javax.swing.plaf.basic 中的 类
此布局管理器处理组合框的“标准”布局。
BasicComboBoxUI.ComboBoxLayoutManager() - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 的构造方法
BasicComboBoxUI.FocusHandler - javax.swing.plaf.basic 中的 类
失去焦点时，此侦听器将隐藏弹出部分。
BasicComboBoxUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler 的构造方法
BasicComboBoxUI.ItemHandler - javax.swing.plaf.basic 中的 类
此侦听器观察组合框中选择的更改。
BasicComboBoxUI.ItemHandler() - 类 javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler 的构造方法
BasicComboBoxUI.KeyHandler - javax.swing.plaf.basic 中的 类
此侦听器检查键事件是否不是导航键。
BasicComboBoxUI.KeyHandler() - 类 javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler 的构造方法
BasicComboBoxUI.ListDataHandler - javax.swing.plaf.basic 中的 类
此侦听器观察 ComboBoxModel 中的更改。
BasicComboBoxUI.ListDataHandler() - 类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 的构造方法
BasicComboBoxUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
此侦听器观察在组合框中发生更改的绑定 (bound) 属性。
BasicComboBoxUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler 的构造方法
BasicComboPopup - javax.swing.plaf.basic 中的 类
此为 ComboPopup 接口的基本实现。
BasicComboPopup(JComboBox) - 类 javax.swing.plaf.basic.BasicComboPopup 的构造方法
BasicComboPopup.InvocationKeyHandler - javax.swing.plaf.basic 中的 类
从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。
BasicComboPopup.InvocationKeyHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler 的构造方法
BasicComboPopup.InvocationMouseHandler - javax.swing.plaf.basic 中的 类
要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
BasicComboPopup.InvocationMouseHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler 的构造方法
BasicComboPopup.InvocationMouseMotionHandler - javax.swing.plaf.basic 中的 类
此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。
BasicComboPopup.InvocationMouseMotionHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler 的构造方法
BasicComboPopup.ItemHandler - javax.swing.plaf.basic 中的 类
此侦听器观察组合框中选择的更改。
BasicComboPopup.ItemHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.ItemHandler 的构造方法
BasicComboPopup.ListDataHandler - javax.swing.plaf.basic 中的 类
从 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
BasicComboPopup.ListDataHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 的构造方法
BasicComboPopup.ListMouseHandler - javax.swing.plaf.basic 中的 类
在列表中释放鼠标时，此侦听器隐藏弹出部分。
BasicComboPopup.ListMouseHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler 的构造方法
BasicComboPopup.ListMouseMotionHandler - javax.swing.plaf.basic 中的 类
在列表上移动鼠标时，此侦听器更改所选项。
BasicComboPopup.ListMouseMotionHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler 的构造方法
BasicComboPopup.ListSelectionHandler - javax.swing.plaf.basic 中的 类
从 Java 2 平台 v 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
BasicComboPopup.ListSelectionHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler 的构造方法
BasicComboPopup.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
此侦听器观察已在组合框中更改的绑定 (bound) 属性 希望侦听组合框属性更改的子类应该调用超类方法来确保组合框弹出部分正确处理属性更改。
BasicComboPopup.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler 的构造方法
BasicControl - javax.naming.ldap 中的 类
此类提供 Control 接口的基本实现。
BasicControl(String) - 类 javax.naming.ldap.BasicControl 的构造方法
构造一个非关键控件。
BasicControl(String, boolean, byte[]) - 类 javax.naming.ldap.BasicControl 的构造方法
使用提供的参数构造控件。
BasicDesktopIconUI - javax.swing.plaf.basic 中的 类
用于桌面最小化窗口的 L&F。
BasicDesktopIconUI() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 的构造方法
BasicDesktopIconUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
侦听鼠标移动及对其操作。
BasicDesktopIconUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 的构造方法
BasicDesktopPaneUI - javax.swing.plaf.basic 中的 类
桌面的基本 L&F。
BasicDesktopPaneUI() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 的构造方法
BasicDesktopPaneUI.CloseAction - javax.swing.plaf.basic 中的 类
处理关闭一个内部窗体。
BasicDesktopPaneUI.CloseAction() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction 的构造方法
BasicDesktopPaneUI.MaximizeAction - javax.swing.plaf.basic 中的 类
处理最大化一个内部窗体。
BasicDesktopPaneUI.MaximizeAction() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction 的构造方法
BasicDesktopPaneUI.MinimizeAction - javax.swing.plaf.basic 中的 类
处理最小化一个内部窗体。
BasicDesktopPaneUI.MinimizeAction() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction 的构造方法
BasicDesktopPaneUI.NavigateAction - javax.swing.plaf.basic 中的 类
处理导航到下一个内部窗体。
BasicDesktopPaneUI.NavigateAction() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction 的构造方法
BasicDesktopPaneUI.OpenAction - javax.swing.plaf.basic 中的 类
处理恢复一个最小化或最大化的内部窗体。
BasicDesktopPaneUI.OpenAction() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction 的构造方法
BasicDirectoryModel - javax.swing.plaf.basic 中的 类
文件列表的基本实现。
BasicDirectoryModel(JFileChooser) - 类 javax.swing.plaf.basic.BasicDirectoryModel 的构造方法
BasicEditorPaneUI - javax.swing.plaf.basic 中的 类
为 JEditorPane 提供外观。
BasicEditorPaneUI() - 类 javax.swing.plaf.basic.BasicEditorPaneUI 的构造方法
创建新的 BasicEditorPaneUI。
BasicFileChooserUI - javax.swing.plaf.basic 中的 类
FileChooser 的基本 L&F 实现。
BasicFileChooserUI(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 的构造方法
BasicFileChooserUI.AcceptAllFileFilter - javax.swing.plaf.basic 中的 类
BasicFileChooserUI.AcceptAllFileFilter() - 类 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter 的构造方法
BasicFileChooserUI.ApproveSelectionAction - javax.swing.plaf.basic 中的 类
响应 Open 或 Save 请求
BasicFileChooserUI.ApproveSelectionAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction 的构造方法
BasicFileChooserUI.BasicFileView - javax.swing.plaf.basic 中的 类
BasicFileChooserUI.BasicFileView() - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 的构造方法
BasicFileChooserUI.CancelSelectionAction - javax.swing.plaf.basic 中的 类
响应取消请求。
BasicFileChooserUI.CancelSelectionAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction 的构造方法
BasicFileChooserUI.ChangeToParentDirectoryAction - javax.swing.plaf.basic 中的 类
BasicFileChooserUI.ChangeToParentDirectoryAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction 的构造方法
BasicFileChooserUI.DoubleClickListener - javax.swing.plaf.basic 中的 类
BasicFileChooserUI.DoubleClickListener(JList) - 类 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener 的构造方法
BasicFileChooserUI.GoHomeAction - javax.swing.plaf.basic 中的 类
基于“Home”键事件或等效事件的动作。
BasicFileChooserUI.GoHomeAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction 的构造方法
BasicFileChooserUI.NewFolderAction - javax.swing.plaf.basic 中的 类
创建新文件夹。
BasicFileChooserUI.NewFolderAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction 的构造方法
BasicFileChooserUI.SelectionListener - javax.swing.plaf.basic 中的 类
BasicFileChooserUI.SelectionListener() - 类 javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener 的构造方法
BasicFileChooserUI.UpdateAction - javax.swing.plaf.basic 中的 类
重新扫描当前目录中的文件。
BasicFileChooserUI.UpdateAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction 的构造方法
BasicFormattedTextFieldUI - javax.swing.plaf.basic 中的 类
提供 JFormattedTextField 的外观实现。
BasicFormattedTextFieldUI() - 类 javax.swing.plaf.basic.BasicFormattedTextFieldUI 的构造方法
BasicGraphicsUtils - javax.swing.plaf.basic 中的 类
BasicGraphicsUtils() - 类 javax.swing.plaf.basic.BasicGraphicsUtils 的构造方法
BasicHTML - javax.swing.plaf.basic 中的 类
支持为 swing 组件提供 html 视图。
BasicHTML() - 类 javax.swing.plaf.basic.BasicHTML 的构造方法
BasicIconFactory - javax.swing.plaf.basic 中的 类
提供适于基本 L & F 使用的 Icon 的工厂对象。
BasicIconFactory() - 类 javax.swing.plaf.basic.BasicIconFactory 的构造方法
BasicInternalFrameTitlePane - javax.swing.plaf.basic 中的 类
管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicInternalFrameTitlePane(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 的构造方法
BasicInternalFrameTitlePane.CloseAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.CloseAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction 的构造方法
BasicInternalFrameTitlePane.IconifyAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.IconifyAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction 的构造方法
BasicInternalFrameTitlePane.MaximizeAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.MaximizeAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction 的构造方法
BasicInternalFrameTitlePane.MoveAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.MoveAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction 的构造方法
BasicInternalFrameTitlePane.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler 的构造方法
BasicInternalFrameTitlePane.RestoreAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.RestoreAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction 的构造方法
BasicInternalFrameTitlePane.SizeAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.SizeAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction 的构造方法
BasicInternalFrameTitlePane.SystemMenuBar - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.SystemMenuBar() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 的构造方法
BasicInternalFrameTitlePane.TitlePaneLayout - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.TitlePaneLayout() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 的构造方法
BasicInternalFrameUI - javax.swing.plaf.basic 中的 类
JInternalFrame 的基本 L&F 实现。
BasicInternalFrameUI(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 的构造方法
BasicInternalFrameUI.BasicInternalFrameListener - javax.swing.plaf.basic 中的 类
BasicInternalFrameUI.BasicInternalFrameListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 的构造方法
BasicInternalFrameUI.BorderListener - javax.swing.plaf.basic 中的 类
侦听边框调整。
BasicInternalFrameUI.BorderListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 的构造方法
BasicInternalFrameUI.ComponentHandler - javax.swing.plaf.basic 中的 类
BasicInternalFrameUI.ComponentHandler() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 的构造方法
BasicInternalFrameUI.GlassPaneDispatcher - javax.swing.plaf.basic 中的 类
BasicInternalFrameUI.GlassPaneDispatcher() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 的构造方法
BasicInternalFrameUI.InternalFrameLayout - javax.swing.plaf.basic 中的 类
BasicInternalFrameUI.InternalFrameLayout() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 的构造方法
BasicInternalFrameUI.InternalFramePropertyChangeListener - javax.swing.plaf.basic 中的 类
BasicInternalFrameUI.InternalFramePropertyChangeListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener 的构造方法
BasicLabelUI - javax.swing.plaf.basic 中的 类
LabelUI 的 Windows L&F 实现。
BasicLabelUI() - 类 javax.swing.plaf.basic.BasicLabelUI 的构造方法
BasicListUI - javax.swing.plaf.basic 中的 类
ListUI 的可扩展实现。
BasicListUI() - 类 javax.swing.plaf.basic.BasicListUI 的构造方法
BasicListUI.FocusHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicListUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicListUI.FocusHandler 的构造方法
BasicListUI.ListDataHandler - javax.swing.plaf.basic 中的 类
在 installUI 时和只要 JList.model 属性更改时就要添加到 JList 模型的 ListDataListener。
BasicListUI.ListDataHandler() - 类 javax.swing.plaf.basic.BasicListUI.ListDataHandler 的构造方法
BasicListUI.ListSelectionHandler - javax.swing.plaf.basic 中的 类
在 installUI 时和只要 JList.selectionModel 属性更改时就要添加到 JList 模型的 ListSelectionListener。
BasicListUI.ListSelectionHandler() - 类 javax.swing.plaf.basic.BasicListUI.ListSelectionHandler 的构造方法
BasicListUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
鼠标输入和 JList 的焦点处理。
BasicListUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 的构造方法
BasicListUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
在 installUI 时添加到 JList 的 PropertyChangeListener。
BasicListUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler 的构造方法
BasicLookAndFeel - javax.swing.plaf.basic 中的 类
为 Swing 创建外观时要使用的基类。
BasicLookAndFeel() - 类 javax.swing.plaf.basic.BasicLookAndFeel 的构造方法
BasicMenuBarUI - javax.swing.plaf.basic 中的 类
MenuBarUI 的默认 L&F 实现。
BasicMenuBarUI() - 类 javax.swing.plaf.basic.BasicMenuBarUI 的构造方法
BasicMenuItemUI - javax.swing.plaf.basic 中的 类
BasicMenuItem 实现
BasicMenuItemUI() - 类 javax.swing.plaf.basic.BasicMenuItemUI 的构造方法
BasicMenuItemUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
BasicMenuItemUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 的构造方法
BasicMenuUI - javax.swing.plaf.basic 中的 类
MenuUI 的默认 L&F 实现。
BasicMenuUI() - 类 javax.swing.plaf.basic.BasicMenuUI 的构造方法
BasicMenuUI.ChangeHandler - javax.swing.plaf.basic 中的 类
从 Java 2 平台 1.4 开始，已废弃这种以前没有记录的类。
BasicMenuUI.ChangeHandler(JMenu, BasicMenuUI) - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 的构造方法
BasicMenuUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
BasicMenuUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 的构造方法
BasicOptionPaneUI - javax.swing.plaf.basic 中的 类
为 JOptionPane 提供基本外观。
BasicOptionPaneUI() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 的构造方法
BasicOptionPaneUI.ButtonActionListener - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicOptionPaneUI.ButtonActionListener(int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener 的构造方法
BasicOptionPaneUI.ButtonAreaLayout - javax.swing.plaf.basic 中的 类
ButtonAreaLayout 的行为方式类似于 FlowLayout。
BasicOptionPaneUI.ButtonAreaLayout(boolean, int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 的构造方法
BasicOptionPaneUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicOptionPaneUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler 的构造方法
BasicPanelUI - javax.swing.plaf.basic 中的 类
BasicPanel 实现
BasicPanelUI() - 类 javax.swing.plaf.basic.BasicPanelUI 的构造方法
BasicPasswordFieldUI - javax.swing.plaf.basic 中的 类
为密码字段提供 Windows 外观。
BasicPasswordFieldUI() - 类 javax.swing.plaf.basic.BasicPasswordFieldUI 的构造方法
BasicPermission - java.security 中的 类
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
BasicPermission(String) - 类 java.security.BasicPermission 的构造方法
创建具有指定名称的新 BasicPermission。
BasicPermission(String, String) - 类 java.security.BasicPermission 的构造方法
创建具有指定名称的新 BasicPermission 对象。
BasicPopupMenuSeparatorUI - javax.swing.plaf.basic 中的 类
PopupMenuSeparatorUI 的基本 L&F 实现。
BasicPopupMenuSeparatorUI() - 类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 的构造方法
BasicPopupMenuUI - javax.swing.plaf.basic 中的 类
PopupMenuUI 的 Windows L&F 实现。
BasicPopupMenuUI() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 的构造方法
BasicProgressBarUI - javax.swing.plaf.basic 中的 类
ProgressBarUI 的基本 L&F 实现。
BasicProgressBarUI() - 类 javax.swing.plaf.basic.BasicProgressBarUI 的构造方法
BasicProgressBarUI.ChangeHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicProgressBarUI.ChangeHandler() - 类 javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler 的构造方法
BasicRadioButtonMenuItemUI - javax.swing.plaf.basic 中的 类
BasicRadioButtonMenuItem 实现
BasicRadioButtonMenuItemUI() - 类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 的构造方法
BasicRadioButtonUI - javax.swing.plaf.basic 中的 类
BasicRadioButtonUI 的 RadioButtonUI 实现
BasicRadioButtonUI() - 类 javax.swing.plaf.basic.BasicRadioButtonUI 的构造方法
BasicRootPaneUI - javax.swing.plaf.basic 中的 类
RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。
BasicRootPaneUI() - 类 javax.swing.plaf.basic.BasicRootPaneUI 的构造方法
BasicScrollBarUI - javax.swing.plaf.basic 中的 类
基本外观的 ScrollBarUI 的实现
BasicScrollBarUI() - 类 javax.swing.plaf.basic.BasicScrollBarUI 的构造方法
BasicScrollBarUI.ArrowButtonListener - javax.swing.plaf.basic 中的 类
光标键的侦听器。
BasicScrollBarUI.ArrowButtonListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener 的构造方法
BasicScrollBarUI.ModelListener - javax.swing.plaf.basic 中的 类
侦听模型更改的侦听器。
BasicScrollBarUI.ModelListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI.ModelListener 的构造方法
BasicScrollBarUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
BasicScrollBarUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler 的构造方法
BasicScrollBarUI.ScrollListener - javax.swing.plaf.basic 中的 类
在 ScrollPane 中发起的滚动事件的侦听器。
BasicScrollBarUI.ScrollListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 的构造方法
BasicScrollBarUI.ScrollListener(int, boolean) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 的构造方法
BasicScrollBarUI.TrackListener - javax.swing.plaf.basic 中的 类
跟踪鼠标拖动。
BasicScrollBarUI.TrackListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 的构造方法
BasicScrollPaneUI - javax.swing.plaf.basic 中的 类
ScrollPaneUI 的默认 L&F 实现。
BasicScrollPaneUI() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 的构造方法
BasicScrollPaneUI.HSBChangeListener - javax.swing.plaf.basic 中的 类
水平滚动条侦听器。
BasicScrollPaneUI.HSBChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener 的构造方法
BasicScrollPaneUI.MouseWheelHandler - javax.swing.plaf.basic 中的 类
MouseWheelHandler 是实现 MouseWheelListener 接口的内部类。
BasicScrollPaneUI.MouseWheelHandler() - 类 javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler 的构造方法
BasicScrollPaneUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
BasicScrollPaneUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler 的构造方法
BasicScrollPaneUI.ViewportChangeHandler - javax.swing.plaf.basic 中的 类
视口事件的侦听器。
BasicScrollPaneUI.ViewportChangeHandler() - 类 javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler 的构造方法
BasicScrollPaneUI.VSBChangeListener - javax.swing.plaf.basic 中的 类
垂直滚动条侦听器。
BasicScrollPaneUI.VSBChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener 的构造方法
BasicSeparatorUI - javax.swing.plaf.basic 中的 类
SeparatorUI 的基本 L&F 实现。
BasicSeparatorUI() - 类 javax.swing.plaf.basic.BasicSeparatorUI 的构造方法
BasicSliderUI - javax.swing.plaf.basic 中的 类
SliderUI 的基本 L&F 实现。
BasicSliderUI(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 的构造方法
BasicSliderUI.ActionScroller - javax.swing.plaf.basic 中的 类
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
BasicSliderUI.ActionScroller(JSlider, int, boolean) - 类 javax.swing.plaf.basic.BasicSliderUI.ActionScroller 的构造方法
BasicSliderUI.ChangeHandler - javax.swing.plaf.basic 中的 类
数据模型侦听器。
BasicSliderUI.ChangeHandler() - 类 javax.swing.plaf.basic.BasicSliderUI.ChangeHandler 的构造方法
BasicSliderUI.ComponentHandler - javax.swing.plaf.basic 中的 类
调整事件大小的侦听器。
BasicSliderUI.ComponentHandler() - 类 javax.swing.plaf.basic.BasicSliderUI.ComponentHandler 的构造方法
BasicSliderUI.FocusHandler - javax.swing.plaf.basic 中的 类
焦点更改侦听器。
BasicSliderUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicSliderUI.FocusHandler 的构造方法
BasicSliderUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
BasicSliderUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler 的构造方法
BasicSliderUI.ScrollListener - javax.swing.plaf.basic 中的 类
滚动事件侦听器。
BasicSliderUI.ScrollListener() - 类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 的构造方法
BasicSliderUI.ScrollListener(int, boolean) - 类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 的构造方法
BasicSliderUI.TrackListener - javax.swing.plaf.basic 中的 类
跟踪鼠标移动。
BasicSliderUI.TrackListener() - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 的构造方法
BasicSpinnerUI - javax.swing.plaf.basic 中的 类
默认 Spinner UI 委托。
BasicSpinnerUI() - 类 javax.swing.plaf.basic.BasicSpinnerUI 的构造方法
BasicSplitPaneDivider - javax.swing.plaf.basic 中的 类
BasicSplitPaneUI 使用的分隔符。
BasicSplitPaneDivider(BasicSplitPaneUI) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 的构造方法
创建 BasicSplitPaneDivider 的实例。
BasicSplitPaneDivider.DividerLayout - javax.swing.plaf.basic 中的 类
用于布置 BasicSplitPaneDivider。
BasicSplitPaneDivider.DividerLayout() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 的构造方法
BasicSplitPaneDivider.DragController - javax.swing.plaf.basic 中的 类
在面向 HORIZONTAL_SPLIT 的拆分窗格的拖动会话期间处理事件。
BasicSplitPaneDivider.DragController(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 的构造方法
BasicSplitPaneDivider.MouseHandler - javax.swing.plaf.basic 中的 类
MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
BasicSplitPaneDivider.MouseHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 的构造方法
BasicSplitPaneDivider.VerticalDragController - javax.swing.plaf.basic 中的 类
在面向 VERTICAL_SPLIT 的拆分窗格的拖动会话期间处理事件。
BasicSplitPaneDivider.VerticalDragController(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController 的构造方法
BasicSplitPaneUI - javax.swing.plaf.basic 中的 类
SplitPaneUI 的基本 L&F 实现。
BasicSplitPaneUI() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 的构造方法
BasicSplitPaneUI.BasicHorizontalLayoutManager - javax.swing.plaf.basic 中的 类
具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。
BasicSplitPaneUI.BasicVerticalLayoutManager - javax.swing.plaf.basic 中的 类
用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。
BasicSplitPaneUI.BasicVerticalLayoutManager() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager 的构造方法
BasicSplitPaneUI.FocusHandler - javax.swing.plaf.basic 中的 类
JSplitPane UI 使用的 FocusListener 的实现。
BasicSplitPaneUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler 的构造方法
BasicSplitPaneUI.KeyboardDownRightHandler - javax.swing.plaf.basic 中的 类
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
BasicSplitPaneUI.KeyboardDownRightHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler 的构造方法
BasicSplitPaneUI.KeyboardEndHandler - javax.swing.plaf.basic 中的 类
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
BasicSplitPaneUI.KeyboardEndHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler 的构造方法
BasicSplitPaneUI.KeyboardHomeHandler - javax.swing.plaf.basic 中的 类
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
BasicSplitPaneUI.KeyboardHomeHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler 的构造方法
BasicSplitPaneUI.KeyboardResizeToggleHandler - javax.swing.plaf.basic 中的 类
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
BasicSplitPaneUI.KeyboardResizeToggleHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler 的构造方法
BasicSplitPaneUI.KeyboardUpLeftHandler - javax.swing.plaf.basic 中的 类
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
BasicSplitPaneUI.KeyboardUpLeftHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler 的构造方法
BasicSplitPaneUI.PropertyHandler - javax.swing.plaf.basic 中的 类
JSplitPane UI 使用的 PropertyChangeListener 的实现。
BasicSplitPaneUI.PropertyHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler 的构造方法
BasicStroke - java.awt 中的 类
BasicStroke 类定义针对图形图元轮廓呈现属性的一个基本集合，这些图元使用 Graphics2D 对象呈现，而该对象的 Stroke 属性设置为此 BasicStroke。
BasicStroke(float, int, int, float, float[], float) - 类 java.awt.BasicStroke 的构造方法
构造一个具有指定属性的新 BasicStroke。
BasicStroke(float, int, int, float) - 类 java.awt.BasicStroke 的构造方法
构造一个具有指定属性的实心的 BasicStroke。
BasicStroke(float, int, int) - 类 java.awt.BasicStroke 的构造方法
构造一个具有指定属性的实心的 BasicStroke。
BasicStroke(float) - 类 java.awt.BasicStroke 的构造方法
构造一个具有指定线条宽度以及 cap 和 join 风格的默认值的实心 BasicStroke。
BasicStroke() - 类 java.awt.BasicStroke 的构造方法
构造一个具有所有属性的默认值的新 BasicStroke。
BasicTabbedPaneUI - javax.swing.plaf.basic 中的 类
TabbedPaneUI 的基本 L&F 实现。
BasicTabbedPaneUI() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 的构造方法
BasicTabbedPaneUI.FocusHandler - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicTabbedPaneUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler 的构造方法
BasicTabbedPaneUI.MouseHandler - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicTabbedPaneUI.MouseHandler() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler 的构造方法
BasicTabbedPaneUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicTabbedPaneUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler 的构造方法
BasicTabbedPaneUI.TabbedPaneLayout - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicTabbedPaneUI.TabbedPaneLayout() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 的构造方法
BasicTabbedPaneUI.TabSelectionHandler - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicTabbedPaneUI.TabSelectionHandler() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler 的构造方法
BasicTableHeaderUI - javax.swing.plaf.basic 中的 类
BasicTableHeaderUI 实现
BasicTableHeaderUI() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 的构造方法
BasicTableHeaderUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicTableHeaderUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 的构造方法
BasicTableUI - javax.swing.plaf.basic 中的 类
BasicTableUI 实现
BasicTableUI() - 类 javax.swing.plaf.basic.BasicTableUI 的构造方法
BasicTableUI.FocusHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicTableUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicTableUI.FocusHandler 的构造方法
BasicTableUI.KeyHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicTableUI.KeyHandler() - 类 javax.swing.plaf.basic.BasicTableUI.KeyHandler 的构造方法
BasicTableUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicTableUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 的构造方法
BasicTextAreaUI - javax.swing.plaf.basic 中的 类
为纯文本编辑器提供外观。
BasicTextAreaUI() - 类 javax.swing.plaf.basic.BasicTextAreaUI 的构造方法
构造新的 BasicTextAreaUI 对象。
BasicTextFieldUI - javax.swing.plaf.basic 中的 类
JTextField 的外观的基础。
BasicTextFieldUI() - 类 javax.swing.plaf.basic.BasicTextFieldUI 的构造方法
创建新的 BasicTextFieldUI。
BasicTextPaneUI - javax.swing.plaf.basic 中的 类
为样式化文本编辑器提供外观。
BasicTextPaneUI() - 类 javax.swing.plaf.basic.BasicTextPaneUI 的构造方法
创建新的 BasicTextPaneUI。
BasicTextUI - javax.swing.plaf.basic 中的 类
此类是文本组件外观的基础。
BasicTextUI() - 类 javax.swing.plaf.basic.BasicTextUI 的构造方法
创建新的 UI。
BasicTextUI.BasicCaret - javax.swing.plaf.basic 中的 类
BasicTextUI.BasicCaret() - 类 javax.swing.plaf.basic.BasicTextUI.BasicCaret 的构造方法
BasicTextUI.BasicHighlighter - javax.swing.plaf.basic 中的 类
BasicTextUI.BasicHighlighter() - 类 javax.swing.plaf.basic.BasicTextUI.BasicHighlighter 的构造方法
BasicToggleButtonUI - javax.swing.plaf.basic 中的 类
BasicToggleButton 实现
BasicToggleButtonUI() - 类 javax.swing.plaf.basic.BasicToggleButtonUI 的构造方法
BasicToolBarSeparatorUI - javax.swing.plaf.basic 中的 类
ToolBarSeparatorUI 的基本 L&F 实现。
BasicToolBarSeparatorUI() - 类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 的构造方法
BasicToolBarUI - javax.swing.plaf.basic 中的 类
ToolBarUI 的基本 L&F 实现。
BasicToolBarUI() - 类 javax.swing.plaf.basic.BasicToolBarUI 的构造方法
BasicToolBarUI.DockingListener - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicToolBarUI.DockingListener(JToolBar) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 的构造方法
BasicToolBarUI.DragWindow - javax.swing.plaf.basic 中的 类
BasicToolBarUI.FrameListener - javax.swing.plaf.basic 中的 类
BasicToolBarUI.FrameListener() - 类 javax.swing.plaf.basic.BasicToolBarUI.FrameListener 的构造方法
BasicToolBarUI.PropertyListener - javax.swing.plaf.basic 中的 类
BasicToolBarUI.PropertyListener() - 类 javax.swing.plaf.basic.BasicToolBarUI.PropertyListener 的构造方法
BasicToolBarUI.ToolBarContListener - javax.swing.plaf.basic 中的 类
BasicToolBarUI.ToolBarContListener() - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener 的构造方法
BasicToolBarUI.ToolBarFocusListener - javax.swing.plaf.basic 中的 类
BasicToolBarUI.ToolBarFocusListener() - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener 的构造方法
BasicToolTipUI - javax.swing.plaf.basic 中的 类
标准工具提示 L&F。
BasicToolTipUI() - 类 javax.swing.plaf.basic.BasicToolTipUI 的构造方法
BasicTreeUI - javax.swing.plaf.basic 中的 类
层次数据结构的基本 L&F。
BasicTreeUI() - 类 javax.swing.plaf.basic.BasicTreeUI 的构造方法
BasicTreeUI.CellEditorHandler - javax.swing.plaf.basic 中的 类
侦听器负责获取单元格编辑事件并相应地更新树。
BasicTreeUI.CellEditorHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler 的构造方法
BasicTreeUI.ComponentHandler - javax.swing.plaf.basic 中的 类
滚动时更新首选大小（如果需要）。
BasicTreeUI.ComponentHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 的构造方法
BasicTreeUI.FocusHandler - javax.swing.plaf.basic 中的 类
失去/获得焦点时重绘前导选择行。
BasicTreeUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.FocusHandler 的构造方法
BasicTreeUI.KeyHandler - javax.swing.plaf.basic 中的 类
用于获取多个按键事件以适当生成事件。
BasicTreeUI.KeyHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 的构造方法
BasicTreeUI.MouseHandler - javax.swing.plaf.basic 中的 类
TreeMouseListener 负责基于鼠标事件更新选择。
BasicTreeUI.MouseHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 的构造方法
BasicTreeUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。
BasicTreeUI.MouseInputHandler(Component, Component, MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 的构造方法
BasicTreeUI.NodeDimensionsHandler - javax.swing.plaf.basic 中的 类
负责获取节点大小的类，其方法被转发到 BasicTreeUI 方法。
BasicTreeUI.NodeDimensionsHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler 的构造方法
BasicTreeUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
树的 PropertyChangeListener。
BasicTreeUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler 的构造方法
BasicTreeUI.SelectionModelPropertyChangeHandler - javax.swing.plaf.basic 中的 类
TreeSelectionModel 上的侦听器，如果模型的任何属性发生更改，则重置行选择。
BasicTreeUI.SelectionModelPropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler 的构造方法
BasicTreeUI.TreeCancelEditingAction - javax.swing.plaf.basic 中的 类
执行操作时调用 cancelEditing 的 ActionListener。
BasicTreeUI.TreeCancelEditingAction(String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction 的构造方法
BasicTreeUI.TreeExpansionHandler - javax.swing.plaf.basic 中的 类
更新 TreeState 以响应节点的展开/折叠。
BasicTreeUI.TreeExpansionHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler 的构造方法
BasicTreeUI.TreeHomeAction - javax.swing.plaf.basic 中的 类
TreeHomeAction 用于处理 end/home 动作。
BasicTreeUI.TreeHomeAction(int, String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 的构造方法
BasicTreeUI.TreeIncrementAction - javax.swing.plaf.basic 中的 类
TreeIncrementAction 用于处理向上/向下操作。
BasicTreeUI.TreeIncrementAction(int, String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 的构造方法
BasicTreeUI.TreeModelHandler - javax.swing.plaf.basic 中的 类
将所有 TreeModel 事件转发到 TreeState。
BasicTreeUI.TreeModelHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 的构造方法
BasicTreeUI.TreePageAction - javax.swing.plaf.basic 中的 类
TreePageAction 处理向上翻页和向下翻页事件。
BasicTreeUI.TreePageAction(int, String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 的构造方法
BasicTreeUI.TreeSelectionHandler - javax.swing.plaf.basic 中的 类
侦听选择模型中的更改并相应地更新显示。
BasicTreeUI.TreeSelectionHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler 的构造方法
BasicTreeUI.TreeToggleAction - javax.swing.plaf.basic 中的 类
对于第一个选定行展开将被切换。
BasicTreeUI.TreeToggleAction(String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction 的构造方法
BasicTreeUI.TreeTraverseAction - javax.swing.plaf.basic 中的 类
TreeTraverseAction 是用于向左/向右方向键的动作。
BasicTreeUI.TreeTraverseAction(int, String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 的构造方法
BasicViewportUI - javax.swing.plaf.basic 中的 类
BasicViewport 实现
BasicViewportUI() - 类 javax.swing.plaf.basic.BasicViewportUI 的构造方法
BATCHSIZE - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定通过服务协议返回数据时要使用的批处理量 (batch size) 的环境属性名称。
BatchUpdateException - java.sql 中的 异常
进行批量更新操作期间发生错误时抛出的 SQLException 子类。
BatchUpdateException(String, String, int, int[]) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason、SQLState、vendorCode 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String, String, int[]) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason、SQLState 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String, int[]) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(int[]) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException() - 异常 java.sql.BatchUpdateException 的构造方法
构造一个 BatchUpdateException 对象。
BatchUpdateException(Throwable) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 cause 初始化的 BatchUpdateException 对象。
BatchUpdateException(int[], Throwable) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String, int[], Throwable) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason、cause 和 updateCounts 构造的 BatchUpdateException 对象。
BatchUpdateException(String, String, int[], Throwable) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason、SQLState、cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String, String, int, int[], Throwable) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason、SQLState、vendorCode、cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BC - 类 java.util.GregorianCalendar 中的静态变量
ERA 字段的值指示公元前（Christ 前）的时期（也称为 BCE）。
bcmListeners - 类 java.beans.beancontext.BeanContextSupport 中的变量
protected ArrayList bcmListeners 字段的所有访问在该对象上都将是同步的。
bcsChildren() - 类 java.beans.beancontext.BeanContextSupport 中的方法
返回此 BeanContext 所有子级的迭代器。
bcsListeners - 类 java.beans.beancontext.BeanContextServicesSupport 中的变量
BeanContextServicesListener 对象的列表。
bcsPreDeserializationHook(ObjectInputStream) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
在反序列化子级之前，从 BeanContextSupport readObject 中调用。
bcsPreDeserializationHook(ObjectInputStream) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在调用 defaultReadObject() 之后，但在反序列化任意子级之前，由 readObject 调用。
bcsPreSerializationHook(ObjectOutputStream) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
在序列化子级之前，从 BeanContextSupport writeObject 中调用。
bcsPreSerializationHook(ObjectOutputStream) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在调用 defaultWriteObject() 之后，但在序列化当前可序列化子级之前，由 writeObject 调用。
BeanContext - java.beans.beancontext 中的 接口
BeanContext 是 JavaBean 的逻辑层次容器。
beanContext - 类 java.beans.beancontext.BeanContextChildSupport 中的变量
BeanContextChild - java.beans.beancontext 中的 接口
正如 BeanContext 子接口所定义的，希望在其中进行嵌套并获得对其执行环境（或文本）的引用的 JavaBeans 应该实现此接口。
BeanContextChildComponentProxy - java.beans.beancontext 中的 接口
此接口由具有与之相关的 AWT Component 的 BeanContextChildren 实现。
beanContextChildPeer - 类 java.beans.beancontext.BeanContextChildSupport 中的变量
在其中嵌套此 BeanContextChild 的 BeanContext。
BeanContextChildSupport - java.beans.beancontext 中的 类
这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
BeanContextChildSupport() - 类 java.beans.beancontext.BeanContextChildSupport 的构造方法
构造一个 BeanContextChildSupport，其中已经为此类创建了子类以便实现 JavaBean 组件自身。
BeanContextChildSupport(BeanContextChild) - 类 java.beans.beancontext.BeanContextChildSupport 的构造方法
构造一个 BeanContextChildSupport，其中 JavaBean 组件自身实现 BeanContextChild 并封装它，并将该接口委托给此实现
BeanContextContainerProxy - java.beans.beancontext 中的 接口
此接口由具有与之关联的 AWT Container 的 BeanContext 实现。
BeanContextEvent - java.beans.beancontext 中的 类
BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。
BeanContextEvent(BeanContext) - 类 java.beans.beancontext.BeanContextEvent 的构造方法
构造一个 BeanContextEvent
BeanContextMembershipEvent - java.beans.beancontext 中的 类
BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。
BeanContextMembershipEvent(BeanContext, Collection) - 类 java.beans.beancontext.BeanContextMembershipEvent 的构造方法
构造一个 BeanContextMembershipEvent
BeanContextMembershipEvent(BeanContext, Object[]) - 类 java.beans.beancontext.BeanContextMembershipEvent 的构造方法
构造一个 BeanContextMembershipEvent
BeanContextMembershipListener - java.beans.beancontext 中的 接口
当 BeanContext 的成员关系状态发生更改时，兼容的 BeanContext 在此接口上触发事件。
BeanContextProxy - java.beans.beancontext 中的 接口
此接口由并不直接拥有（通过实现该接口或一个子接口拥有）与之关联的 BeanContext(Child)，但是拥有它代理的一个公共 BeanContext(Child) 的 JavaBean 实现。
BeanContextServiceAvailableEvent - java.beans.beancontext 中的 类
BeanContextServicesListener 使用此事件类型来标识将被注册的服务。
BeanContextServiceAvailableEvent(BeanContextServices, Class) - 类 java.beans.beancontext.BeanContextServiceAvailableEvent 的构造方法
构造一个 BeanContextAvailableServiceEvent。
BeanContextServiceProvider - java.beans.beancontext 中的 接口
BeanContext 的主要功能之一是充当 JavaBeans 与 BeanContextServiceProviders 之间的集合点。
BeanContextServiceProviderBeanInfo - java.beans.beancontext 中的 接口
希望提供关于其 bean 可能提供服务的显式消息的 BeanContextServiceProvider 实现者应实现某个 BeanInfo 类，该类实现此 BeanInfo 的子接口并提供有关其服务的方法、属性、事件等显式信息。
BeanContextServiceRevokedEvent - java.beans.beancontext 中的 类
BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。
BeanContextServiceRevokedEvent(BeanContextServices, Class, boolean) - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 的构造方法
构造一个 BeanContextServiceEvent。
BeanContextServiceRevokedListener - java.beans.beancontext 中的 接口
用于接收 BeanContextServiceRevokedEvent 对象的侦听器接口。
BeanContextServices - java.beans.beancontext 中的 接口
BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。
BeanContextServicesListener - java.beans.beancontext 中的 接口
用于接收 BeanContextServiceAvailableEvent 对象的侦听器接口。
BeanContextServicesSupport - java.beans.beancontext 中的 类
此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
BeanContextServicesSupport(BeanContextServices, Locale, boolean, boolean) - 类 java.beans.beancontext.BeanContextServicesSupport 的构造方法
构造一个 BeanContextServicesSupport 实例
BeanContextServicesSupport(BeanContextServices, Locale, boolean) - 类 java.beans.beancontext.BeanContextServicesSupport 的构造方法
使用指定 Locale 和设计模式创建一个实例。
BeanContextServicesSupport(BeanContextServices, Locale) - 类 java.beans.beancontext.BeanContextServicesSupport 的构造方法
使用指定语言环境创建一个实例。
BeanContextServicesSupport(BeanContextServices) - 类 java.beans.beancontext.BeanContextServicesSupport 的构造方法
创建一个具有同位体的实例
BeanContextServicesSupport() - 类 java.beans.beancontext.BeanContextServicesSupport 的构造方法
创建不是另一个对象代理的实例。
BeanContextServicesSupport.BCSSChild - java.beans.beancontext 中的 类
BeanContextServicesSupport.BCSSProxyServiceProvider - java.beans.beancontext 中的 类
BeanContextServicesSupport.BCSSServiceProvider - java.beans.beancontext 中的 类
子类可以为此嵌套类创建子类，以便为每个 BeanContextServicesProvider 添加行为。
BeanContextSupport - java.beans.beancontext 中的 类
此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。
BeanContextSupport(BeanContext, Locale, boolean, boolean) - 类 java.beans.beancontext.BeanContextSupport 的构造方法
构造一个 BeanContextSupport 实例。
BeanContextSupport(BeanContext, Locale, boolean) - 类 java.beans.beancontext.BeanContextSupport 的构造方法
使用指定 Locale 和设计模式创建一个实例。
BeanContextSupport(BeanContext, Locale) - 类 java.beans.beancontext.BeanContextSupport 的构造方法
使用指定语言环境创建一个实例。
BeanContextSupport(BeanContext) - 类 java.beans.beancontext.BeanContextSupport 的构造方法
使用默认语言环境创建一个实例
BeanContextSupport() - 类 java.beans.beancontext.BeanContextSupport 的构造方法
创建不是另一个对象代理的实例。
BeanContextSupport.BCSChild - java.beans.beancontext 中的 类
BeanContextSupport.BCSIterator - java.beans.beancontext 中的 类
受保护的最终子类，它封装一个迭代器但实现无操作 remove() 方法。
BeanDescriptor - java.beans 中的 类
BeanDescriptor 提供有关 "bean" 的全局信息，其中包括其 Java 类、其 displayName 等等。
BeanDescriptor(Class<?>) - 类 java.beans.BeanDescriptor 的构造方法
为没有 customizer 的 bean 创建一个 BeanDescriptor。
BeanDescriptor(Class<?>, Class<?>) - 类 java.beans.BeanDescriptor 的构造方法
为有 customizer 的 bean 创建一个 BeanDescriptor。
BeanInfo - java.beans 中的 接口
希望提供有关其 bean 的显式信息的 bean 实现者可以提供某个 BeanInfo 类，该类实现此 BeanInfo 接口并提供有关其 bean 的方法、属性、事件等显式信息。
Beans - java.beans 中的 类
此类提供一些通用的 bean 控制方法。
Beans() - 类 java.beans.Beans 的构造方法
beep() - 类 java.awt.Toolkit 中的方法
发出一个音频嘟嘟声。
beepAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于创建蜂鸣声的动作名称。
before(Timestamp) - 类 java.sql.Timestamp 中的方法
指示此 Timestamp 对象是否早于给定的 Timestamp 对象。
before(Object) - 类 java.util.Calendar 中的方法
判断此 Calendar 表示的时间是否在指定 Object 表示的时间之前，返回判断结果。
before(Date) - 类 java.util.Date 中的方法
测试此日期是否在指定日期之前。
BEFORE_FIRST_LINE - 类 java.awt.BorderLayout 中的静态变量
与 PAGE_START 同义。
BEFORE_LINE_BEGINS - 类 java.awt.BorderLayout 中的静态变量
与 LINE_START 同义。
beforeExecute(Thread, Runnable) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
在执行给定线程中的给定 Runnable 之前调用的方法。
beforeFirst() - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的开头，正好位于第一行之前。
beforeMarshal(Object) - 类 javax.xml.bind.Marshaller.Listener 中的方法

从 source 编组到 XML 之前调用的回调方法。

beforeOffset(int) - 类 java.awt.font.TextHitInfo 中的静态方法
在指定偏移量处创建一个与偏移量之前的字符关联的 TextHitInfo。
beforeUnmarshal(Object, Object) - 类 javax.xml.bind.Unmarshaller.Listener 中的方法

在解组到 target 之前调用的回调方法。

begin() - 类 java.nio.channels.spi.AbstractInterruptibleChannel 中的方法
标记可能无限期阻塞的 I/O 操作的开始。
begin() - 类 java.nio.channels.spi.AbstractSelector 中的方法
标记可能无限期阻塞的 I/O 操作的开始。
beginAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到文档开头的 Action 名称。
beginDragDividerLocation - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
拖动会话开始时分隔符的位置。
beginDraggingFrame(JComponent) - 类 javax.swing.DefaultDesktopManager 中的方法
beginDraggingFrame(JComponent) - 接口 javax.swing.DesktopManager 中的方法
通常在用户已经指示他们将开始拖动某个组件时调用此方法。
beginHandshake() - 类 javax.net.ssl.SSLEngine 中的方法
在此 SSLEngine 上发起握手（初始的或重新协商）。
beginLineAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到行首的 Action 名称。
beginParagraphAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到段落开头的 Action 名称。
beginResizingFrame(JComponent, int) - 类 javax.swing.DefaultDesktopManager 中的方法
beginResizingFrame(JComponent, int) - 接口 javax.swing.DesktopManager 中的方法
通常在用户已经指示他们将开始重新调整窗体的大小时调用此方法。
beginUpdate() - 类 javax.swing.undo.UndoableEditSupport 中的方法
beginWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到字首的 Action 名称。
BELOW_BASELINE - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
BELOW_BASELINE_LEADING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
BELOW_BASELINE_TRAILING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
BELOW_BOTTOM - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框底端线的底部。
BELOW_TOP - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框顶端线的底部。
BENGALI - 类 java.awt.font.NumericShaper 中的静态变量
标识 BENGALI 范围和十进制基数。
BENGALI - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Bengali”Unicode 字符块的常量。
BEST_COMPRESSION - 类 java.util.zip.Deflater 中的静态变量
最佳压缩的压缩级别。
BEST_SPEED - 类 java.util.zip.Deflater 中的静态变量
最快压缩的压缩级别。
bestRowNotPseudo - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符“不”是伪列。
bestRowPseudo - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符是伪列。
bestRowSession - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符的作用域是当前会话的剩余部分。
bestRowTemporary - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符的作用域是临时的，仅在使用该行时可用。
bestRowTransaction - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符的作用域是当前事务的剩余部分。
bestRowUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符可能是伪列 (pseudo column)，也可能不是。
between(ValueExp, ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示一个值在其他两个值之间的约束条件。
BevelBorder - javax.swing.border 中的 类
该类实现简单的双线斜面边框。
BevelBorder(int) - 类 javax.swing.border.BevelBorder 的构造方法
创建具有指定类型的斜面边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生。
BevelBorder(int, Color, Color) - 类 javax.swing.border.BevelBorder 的构造方法
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
BevelBorder(int, Color, Color, Color, Color) - 类 javax.swing.border.BevelBorder 的构造方法
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
bevelType - 类 javax.swing.border.BevelBorder 中的变量
BGCOLOR - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
Bidi - java.text 中的 类
此类实现了 Unicode 双向算法 (Unicode Bidirectional Algorithm)。
Bidi(String, int) - 类 java.text.Bidi 的构造方法
由给定的文本段和基本方向构造 Bidi。
Bidi(AttributedCharacterIterator) - 类 java.text.Bidi 的构造方法
由给定的文本段构造 Bidi。
Bidi(char[], int, byte[], int, int, int) - 类 java.text.Bidi 的构造方法
由给定的文本、嵌入和方向信息构造 Bidi。
BIDI_EMBEDDING - 类 java.awt.font.TextAttribute 中的静态变量
文本嵌入级别的属性键。
BidiElementName - 类 javax.swing.text.AbstractDocument 中的静态变量
用于保存单向操作的元素名。
BidiLevel - 类 javax.swing.text.StyleConstants 中的静态变量
由 Unicode bidi 算法指派的字符双向级别。
BIG - 类 javax.swing.text.html.HTML.Tag 中的静态变量
BIG_ENDIAN - 类 java.nio.ByteOrder 中的静态变量
表示 big-endian 字节顺序的常量。
BigDecimal - java.math 中的 类
不可变的、任意精度的有符号十进制数。
BigDecimal(char[], int, int) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列，同时允许指定子数组。
BigDecimal(char[], int, int, MathContext) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列，同时允许指定子数组，并根据上下文设置进行舍入。
BigDecimal(char[]) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列。
BigDecimal(char[], MathContext) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列（根据上下文设置进行舍入）。
BigDecimal(String) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符串表示形式转换为 BigDecimal。
BigDecimal(String, MathContext) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符串表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符串（按照上下文设置进行舍入）。
BigDecimal(double) - 类 java.math.BigDecimal 的构造方法
将 double 转换为 BigDecimal，后者是 double 的二进制浮点值准确的十进制表示形式。
BigDecimal(double, MathContext) - 类 java.math.BigDecimal 的构造方法
将 double 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(BigInteger) - 类 java.math.BigDecimal 的构造方法
将 BigInteger 转换为 BigDecimal。
BigDecimal(BigInteger, MathContext) - 类 java.math.BigDecimal 的构造方法
将 BigInteger 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(BigInteger, int) - 类 java.math.BigDecimal 的构造方法
将 BigInteger 非标度值和 int 标度转换为 BigDecimal。
BigDecimal(BigInteger, int, MathContext) - 类 java.math.BigDecimal 的构造方法
将 BigInteger 非标度值和 int 标度转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(int) - 类 java.math.BigDecimal 的构造方法
将 int 转换为 BigDecimal。
BigDecimal(int, MathContext) - 类 java.math.BigDecimal 的构造方法
将 int 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(long) - 类 java.math.BigDecimal 的构造方法
将 long 转换为 BigDecimal。
BigDecimal(long, MathContext) - 类 java.math.BigDecimal 的构造方法
将 long 转换为 BigDecimal（根据上下文设置进行舍入）。
BIGDECIMAL - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigDecimal 的值。
bigEndian - 类 javax.sound.sampled.AudioFormat 中的变量
指示是以 big-endian 顺序还是 little-endian 顺序存储音频数据。
BIGINT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 BIGINT 的 Java 编程语言中的常量（有时称为类型代码）。
BigInteger - java.math 中的 类
不可变的任意精度的整数。
BigInteger(byte[]) - 类 java.math.BigInteger 的构造方法
将包含 BigInteger 的二进制补码表示形式的 byte 数组转换为 BigInteger。
BigInteger(int, byte[]) - 类 java.math.BigInteger 的构造方法
将 BigInteger 的符号-数量表示形式转换为 BigInteger。
BigInteger(String, int) - 类 java.math.BigInteger 的构造方法
将指定基数的 BigInteger 的字符串表示形式转换为 BigInteger。
BigInteger(String) - 类 java.math.BigInteger 的构造方法
将 BigInteger 的十进制字符串表示形式转换为 BigInteger。
BigInteger(int, Random) - 类 java.math.BigInteger 的构造方法
构造一个随机生成的 BigInteger，它是在 0 到 (2numBits - 1)（包括）范围内均匀分布的值。
BigInteger(int, int, Random) - 类 java.math.BigInteger 的构造方法
构造一个随机生成的正 BigInteger，它可能是一个具有指定 bitLength 的素数。
BIGINTEGER - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigInteger 的值。
BINARY - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 BINARY 的 Java 编程语言中的常量（有时称为类型代码）。
BINARY_STREAM_PARAM - 类 javax.sql.rowset.BaseRowSet 中的静态变量
该常量向 RowSetReaderImpl 对象指示给定的参数是一个二进制流。
BinaryRefAddr - javax.naming 中的 类
此类表示通信终端地址的二进制形式。
BinaryRefAddr(String, byte[]) - 类 javax.naming.BinaryRefAddr 的构造方法
使用地址类型和用于内容的字节数组构造一个新的 BinaryRefAddr 实例。
BinaryRefAddr(String, byte[], int, int) - 类 javax.naming.BinaryRefAddr 的构造方法
使用地址类型和用于内容的字节数组区域构造一个新的 BinaryRefAddr 实例。
binarySearch(long[], long) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 long 型数组，以获得指定的值。
binarySearch(long[], int, int, long) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 long 型数组的范围，以获得指定的值。
binarySearch(int[], int) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 int 型数组，以获得指定的值。
binarySearch(int[], int, int, int) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 int 型数组的范围，以获得指定的值。
binarySearch(short[], short) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 short 型数组，以获得指定的值。
binarySearch(short[], int, int, short) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 short 型数组的范围，以获得指定的值。
binarySearch(char[], char) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 char 型数组，以获得指定的值。
binarySearch(char[], int, int, char) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 char 型数组的范围，以获得指定的值。
binarySearch(byte[], byte) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 byte 型数组，以获得指定的值。
binarySearch(byte[], int, int, byte) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 byte 型数组的范围，以获得指定的值。
binarySearch(double[], double) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 double 型数组，以获得指定的值。
binarySearch(double[], int, int, double) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 double 型数组的范围，以获得指定的值。
binarySearch(float[], float) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 float 型数组，以获得指定的值。
binarySearch(float[], int, int, float) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 float 型数组的范围，以获得指定的值。
binarySearch(Object[], Object) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定数组，以获得指定对象。
binarySearch(Object[], int, int, Object) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定数组的范围，以获得指定对象。
binarySearch(T[], T, Comparator<? super T>) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定数组，以获得指定对象。
binarySearch(T[], int, int, T, Comparator<? super T>) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定数组的范围，以获得指定对象。
binarySearch(List<? extends Comparable<? super T>>, T) - 类 java.util.Collections 中的静态方法
使用二分搜索法搜索指定列表，以获得指定对象。
binarySearch(List<? extends T>, T, Comparator<? super T>) - 类 java.util.Collections 中的静态方法
使用二分搜索法搜索指定列表，以获得指定对象。
binaryStream - 类 javax.sql.rowset.BaseRowSet 中的变量
将由方法 getBinaryStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
bind(SocketAddress) - 类 java.net.DatagramSocket 中的方法
将此 DatagramSocket 绑定到特定的地址和端口。
bind(int, InetAddress) - 类 java.net.DatagramSocketImpl 中的方法
将数据报套接字绑定到本地端口和地址。
bind(SocketAddress) - 类 java.net.ServerSocket 中的方法
将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
bind(SocketAddress, int) - 类 java.net.ServerSocket 中的方法
将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
bind(SocketAddress) - 类 java.net.Socket 中的方法
将套接字绑定到本地地址。
bind(InetAddress, int) - 类 java.net.SocketImpl 中的方法
将此套接字绑定到指定的本地 IP 地址和端口号。
bind(String, Remote) - 类 java.rmi.Naming 中的静态方法
将指定 name 绑定到远程对象。
bind(String, Remote) - 接口 java.rmi.registry.Registry 中的方法
绑定对此注册表中指定 name 的远程引用。
bind(Name, Object) - 接口 javax.naming.Context 中的方法
将名称绑定到对象。
bind(String, Object) - 接口 javax.naming.Context 中的方法
将名称绑定到对象。
bind(Name, Object, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
将名称与关联的属性一起绑定到一个对象。
bind(String, Object, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
将名称与关联的属性一起绑定到一个对象。
bind(String, Object, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
bind(Name, Object, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
bind(String, Object) - 类 javax.naming.InitialContext 中的方法
bind(Name, Object) - 类 javax.naming.InitialContext 中的方法
BIND - 类 javax.print.attribute.standard.Finishings 中的静态变量
此值指示要将某个绑定应用于文档；绑定的类型和布局是由位置定义的。
bind(NameComponent[], Object) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
在命名上下文中创建名称和对象的绑定。
bind(NameComponent[], Object) - 类 org.omg.CosNaming._NamingContextStub 中的方法
在命名上下文中创建名称和对象的绑定。
bind(NameComponent[], Object) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
在命名上下文中创建名称和对象的绑定。
bind_context(NameComponent[], NamingContext) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
命名作为命名上下文的对象。
bind_context(NameComponent[], NamingContext) - 类 org.omg.CosNaming._NamingContextStub 中的方法
命名作为命名上下文的对象。
bind_context(NameComponent[], NamingContext) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
命名作为命名上下文的对象。
bind_new_context(NameComponent[]) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作创建新上下文并将其绑定到作为参数提供的名称。
bind_new_context(NameComponent[]) - 类 org.omg.CosNaming._NamingContextStub 中的方法
此操作创建一个新上下文并将其绑定到作为参数提供的名称。
bind_new_context(NameComponent[]) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
此操作创建新上下文并将其绑定到作为参数提供的名称。
Binder<XmlNode> - javax.xml.bind 中的 类
在 XML 信息集节点和表示相同 XML 文档的 JAXB 对象之间启用同步。
Binder() - 类 javax.xml.bind.Binder 的构造方法
BindException - java.net 中的 异常
试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
BindException(String) - 异常 java.net.BindException 的构造方法
构造一个新的 BindException，使其具有关于绑定错误产生原因的指定详细消息。
BindException() - 异常 java.net.BindException 的构造方法
构造不带详细消息的新 BindException。
Binding - javax.naming 中的 类
此类表示上下文中一个名称到对象的绑定。
Binding(String, Object) - 类 javax.naming.Binding 的构造方法
在给定其名称和对象的情况下构造一个 Binding 实例。
Binding(String, Object, boolean) - 类 javax.naming.Binding 的构造方法
在给定其名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。
Binding(String, String, Object) - 类 javax.naming.Binding 的构造方法
在给定其名称、类名称和对象的情况下构造一个 Binding 实例。
Binding(String, String, Object, boolean) - 类 javax.naming.Binding 的构造方法
在给定其名称、类名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。
Binding - javax.xml.ws 中的 接口
Binding 接口是 JAX-WS 协议绑定的基本接口。
Binding - org.omg.CosNaming 中的 类
org/omg/CosNaming/Binding.java。
Binding() - 类 org.omg.CosNaming.Binding 的构造方法
Binding(NameComponent[], BindingType) - 类 org.omg.CosNaming.Binding 的构造方法
binding_name - 类 org.omg.CosNaming.Binding 中的变量
binding_type - 类 org.omg.CosNaming.Binding 中的变量
BindingHelper - org.omg.CosNaming 中的 类
org/omg/CosNaming/BindingHelper.java。
BindingHelper() - 类 org.omg.CosNaming.BindingHelper 的构造方法
BindingHolder - org.omg.CosNaming 中的 类
org/omg/CosNaming/BindingHolder.java。
BindingHolder() - 类 org.omg.CosNaming.BindingHolder 的构造方法
BindingHolder(Binding) - 类 org.omg.CosNaming.BindingHolder 的构造方法
BindingIterator - org.omg.CosNaming 中的 接口
BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
BindingIteratorHelper - org.omg.CosNaming 中的 类
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
BindingIteratorHelper() - 类 org.omg.CosNaming.BindingIteratorHelper 的构造方法
BindingIteratorHolder - org.omg.CosNaming 中的 类
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
BindingIteratorHolder() - 类 org.omg.CosNaming.BindingIteratorHolder 的构造方法
BindingIteratorHolder(BindingIterator) - 类 org.omg.CosNaming.BindingIteratorHolder 的构造方法
BindingIteratorOperations - org.omg.CosNaming 中的 接口
BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
BindingIteratorPOA - org.omg.CosNaming 中的 类
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
BindingIteratorPOA() - 类 org.omg.CosNaming.BindingIteratorPOA 的构造方法
BindingListHelper - org.omg.CosNaming 中的 类
绑定列表。
BindingListHelper() - 类 org.omg.CosNaming.BindingListHelper 的构造方法
BindingListHolder - org.omg.CosNaming 中的 类
绑定列表。
BindingListHolder() - 类 org.omg.CosNaming.BindingListHolder 的构造方法
BindingListHolder(Binding[]) - 类 org.omg.CosNaming.BindingListHolder 的构造方法
BindingProvider - javax.xml.ws 中的 接口
BindingProvider 接口提供对用于请求和响应消息处理的协议绑定及关联上下文对象的访问。
Bindings - javax.script 中的 接口
所有键均为 String 的键/值对映射关系。
BindingType - javax.xml.ws 中的 注释类型
BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
BindingType - org.omg.CosNaming 中的 类
指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
BindingType(int) - 类 org.omg.CosNaming.BindingType 的构造方法
BindingTypeHelper - org.omg.CosNaming 中的 类
指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
BindingTypeHelper() - 类 org.omg.CosNaming.BindingTypeHelper 的构造方法
BindingTypeHolder - org.omg.CosNaming 中的 类
指定给定的绑定是对象（非命名上下文的对象）的还是命名上下文的。
BindingTypeHolder() - 类 org.omg.CosNaming.BindingTypeHolder 的构造方法
BindingTypeHolder(BindingType) - 类 org.omg.CosNaming.BindingTypeHolder 的构造方法
BIT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 BIT 的 Java 编程语言中的常量（有时称为类型代码）。
BIT_DEPTH_MULTI - 类 java.awt.DisplayMode 中的静态变量
位深的值（如果此显示模式支持多个位深）。
bitCount(int) - 类 java.lang.Integer 中的静态方法
返回指定 int 值的二进制补码表示形式的 1 位的数量。
bitCount(long) - 类 java.lang.Long 中的静态方法
返回指定 long 值的二进制补码表示形式中的 1 位的数量。
bitCount() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的二进制补码表示形式中与符号不同的位的数量。
bitLength() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的最小的二进制补码表示形式的位数，不包括 符号位。
BITMASK - 接口 java.awt.Transparency 中的静态变量
表示保证完全不透明的图像数据（alpha 值为 1.0）或完全透明的图像数据（alpha 值为 0.0）。
bitOffset - 类 javax.imageio.stream.ImageInputStreamImpl 中的变量
流中的当前位偏移量。
BitSet - java.util 中的 类
此类实现了一个按需增长的位向量。
BitSet() - 类 java.util.BitSet 的构造方法
创建一个新的位 set。
BitSet(int) - 类 java.util.BitSet 的构造方法
创建一个位 set，它的初始大小足以显式表示索引范围在 0 到 nbits-1 的位。
black - 类 java.awt.Color 中的静态变量
黑色。
BLACK - 类 java.awt.Color 中的静态变量
黑色。
BLIT_SCROLL_MODE - 类 javax.swing.JViewport 中的静态变量
使用 graphics.copyArea 来实现滚动。
Blob - java.sql 中的 接口
SQL BLOB 值在 JavaTM 编程语言中的表示形式（映射关系）。
BLOB - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 BLOB 的 Java 编程语言中的常量（有时称为类型代码）。
BLOCK_DECREMENT - 类 java.awt.event.AdjustmentEvent 中的静态变量
块减量调整类型。
BLOCK_ELEMENTS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Block Elements”Unicode 字符块的常量。
BLOCK_INCREMENT - 类 java.awt.event.AdjustmentEvent 中的静态变量
块增量调整类型。
blockClose(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
向解析器缓冲区添加一条指令，以关闭给定类型的块元素。
blockIncrement - 类 javax.swing.JScrollBar 中的变量
BlockingDeque<E> - java.util.concurrent 中的 接口
支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。
blockingLock() - 类 java.nio.channels.SelectableChannel 中的方法
获取其 configureBlocking 和 register 方法实现同步的对象。
blockingLock() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
BlockingQueue<E> - java.util.concurrent 中的 接口
支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。
blockOpen(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
向解析器缓冲区添加一条指令，以创建具有给定属性的块元素。
BLOCKQUOTE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
BlockView - javax.swing.text.html 中的 类
用来显示具有 CSS 规范的块（作为一个框）的视图实现。
BlockView(Element, int) - 类 javax.swing.text.html.BlockView 的构造方法
创建表示 html 框的新视图。
blue - 类 java.awt.Color 中的静态变量
蓝色。
BLUE - 类 java.awt.Color 中的静态变量
蓝色。
BLUECOMPONENT - 类 java.awt.color.ICC_ProfileRGB 中的静态变量
用于获取蓝色分量的 gamma 值或 TRC。
BMPImageWriteParam - javax.imageio.plugins.bmp 中的 类
用于以 BMP 格式编码图像的 ImageWriteParam 的子类。
BMPImageWriteParam(Locale) - 类 javax.imageio.plugins.bmp.BMPImageWriteParam 的构造方法
构造一个设置为使用给定 Locale 并且所有参数都采用默认值的 BMPImageWriteParam。
BMPImageWriteParam() - 类 javax.imageio.plugins.bmp.BMPImageWriteParam 的构造方法
构造一个所有参数均为默认值并具有为 null 的 Locale 的 BMPImageWriteParam 对象。
BODY - 类 javax.swing.text.html.HTML.Tag 中的静态变量
body - 类 javax.swing.text.html.parser.DTD 中的变量
BOLD - 类 java.awt.Font 中的静态变量
粗体样式常量。
Bold - 类 javax.swing.text.StyleConstants 中的静态变量
粗体属性的名称。
BOLD_ACTION - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
粗体动作标识符
Book - java.awt.print 中的 类
Book 类提供文档的表示形式，该文档的页面可以使用不同的页面格式和页面 painter。
Book() - 类 java.awt.print.Book 的构造方法
创建新的空 Book。
Boolean - java.lang 中的 类
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Boolean(boolean) - 类 java.lang.Boolean 的构造方法
分配一个表示 value 参数的 Boolean 对象。
Boolean(String) - 类 java.lang.Boolean 的构造方法
如果 String 参数不为 null 且在忽略大小写时等于 "true"，则分配一个表示 true 值的 Boolean 对象。
BOOLEAN - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 BOOLEAN 的 Java 编程语言中的常量（有时称为类型代码）。
BOOLEAN - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Boolean 的值。
BOOLEAN - 类 javax.xml.xpath.XPathConstants 中的静态变量
XPath 1.0 布尔值数据类型。
BooleanControl - javax.sound.sampled 中的 类
BooleanControl 能够在影响行音频的两个可能的设置之间切换。
BooleanControl(BooleanControl.Type, boolean, String, String) - 类 javax.sound.sampled.BooleanControl 的构造方法
构造一个具有给定参数的新 boolean 控件对象。
BooleanControl(BooleanControl.Type, boolean) - 类 javax.sound.sampled.BooleanControl 的构造方法
构造一个具有给定参数的新 boolean 控件对象。
BooleanControl.Type - javax.sound.sampled 中的 类
BooleanControl.Type 类的实例标识一种 boolean 控件。
BooleanControl.Type(String) - 类 javax.sound.sampled.BooleanControl.Type 的构造方法
构造新的 boolean 控件类型。
BooleanHolder - org.omg.CORBA 中的 类
Boolean 的 Holder。
BooleanHolder() - 类 org.omg.CORBA.BooleanHolder 的构造方法
构造一个新的 BooleanHolder 对象，将其 value 字段初始化为 false。
BooleanHolder(boolean) - 类 org.omg.CORBA.BooleanHolder 的构造方法
构造一个新的 BooleanHolder 对象，并使用给定 boolean 初始化其 value 字段。
BooleanSeqHelper - org.omg.CORBA 中的 类
BooleanSeq 的 Helper。
BooleanSeqHelper() - 类 org.omg.CORBA.BooleanSeqHelper 的构造方法
BooleanSeqHolder - org.omg.CORBA 中的 类
BooleanSeq 的 Holder。
BooleanSeqHolder() - 类 org.omg.CORBA.BooleanSeqHolder 的构造方法
BooleanSeqHolder(boolean[]) - 类 org.omg.CORBA.BooleanSeqHolder 的构造方法
booleanValue() - 类 java.lang.Boolean 中的方法
将此 Boolean 对象的值作为基本布尔值返回。
BOPOMOFO - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Bopomofo”Unicode 字符块的常量。
BOPOMOFO_EXTENDED - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Bopomofo Extended”Unicode 字符块的常量。
Border - javax.swing.border 中的 接口
该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。
border - 类 javax.swing.border.TitledBorder 中的变量
BORDER - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
border - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 中的变量
要使用的边框。
BORDER_BOTTOM - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_BOTTOM_WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_COLOR - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_LEFT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_LEFT_WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_PAINTED_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识是否绘制边框的更改。
BORDER_PAINTED_FLAT_CHANGED_PROPERTY - 类 javax.swing.JCheckBox 中的静态变量
标识 flat 属性的更改。
BORDER_RIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_RIGHT_WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_STYLE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_TOP - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_TOP_WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BorderFactory - javax.swing 中的 类
提供标准 Border 对象的工厂类。
borderInsets - 类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 中的静态变量
borderInsets - 类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 中的静态变量
borderInsets - 类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 中的静态变量
borderInsets - 类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 中的静态变量
BorderLayout - java.awt 中的 类
这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。
BorderLayout() - 类 java.awt.BorderLayout 的构造方法
构造一个组件之间没有间距的新边框布局。
BorderLayout(int, int) - 类 java.awt.BorderLayout 的构造方法
构造一个具有指定组件间距的边框布局。
borderListener - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
borderSelectionColor - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
如果应绘制边框选择色，则为 true。
borderSelectionColor - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
节点具有焦点时，用于焦点指示符的颜色。
BorderUIResource - javax.swing.plaf 中的 类
BorderUIResource(Border) - 类 javax.swing.plaf.BorderUIResource 的构造方法
创建一个 UIResource 边框对象，该对象包装了一个现有 Border 实例。
BorderUIResource.BevelBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.BevelBorderUIResource(int) - 类 javax.swing.plaf.BorderUIResource.BevelBorderUIResource 的构造方法
BorderUIResource.BevelBorderUIResource(int, Color, Color) - 类 javax.swing.plaf.BorderUIResource.BevelBorderUIResource 的构造方法
BorderUIResource.BevelBorderUIResource(int, Color, Color, Color, Color) - 类 javax.swing.plaf.BorderUIResource.BevelBorderUIResource 的构造方法
BorderUIResource.CompoundBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.CompoundBorderUIResource(Border, Border) - 类 javax.swing.plaf.BorderUIResource.CompoundBorderUIResource 的构造方法
BorderUIResource.EmptyBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.EmptyBorderUIResource(int, int, int, int) - 类 javax.swing.plaf.BorderUIResource.EmptyBorderUIResource 的构造方法
BorderUIResource.EmptyBorderUIResource(Insets) - 类 javax.swing.plaf.BorderUIResource.EmptyBorderUIResource 的构造方法
BorderUIResource.EtchedBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.EtchedBorderUIResource() - 类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的构造方法
BorderUIResource.EtchedBorderUIResource(int) - 类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的构造方法
BorderUIResource.EtchedBorderUIResource(Color, Color) - 类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的构造方法
BorderUIResource.EtchedBorderUIResource(int, Color, Color) - 类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的构造方法
BorderUIResource.LineBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.LineBorderUIResource(Color) - 类 javax.swing.plaf.BorderUIResource.LineBorderUIResource 的构造方法
BorderUIResource.LineBorderUIResource(Color, int) - 类 javax.swing.plaf.BorderUIResource.LineBorderUIResource 的构造方法
BorderUIResource.MatteBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.MatteBorderUIResource(int, int, int, int, Color) - 类 javax.swing.plaf.BorderUIResource.MatteBorderUIResource 的构造方法
BorderUIResource.MatteBorderUIResource(int, int, int, int, Icon) - 类 javax.swing.plaf.BorderUIResource.MatteBorderUIResource 的构造方法
BorderUIResource.MatteBorderUIResource(Icon) - 类 javax.swing.plaf.BorderUIResource.MatteBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.TitledBorderUIResource(String) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource(Border) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource(Border, String) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource(Border, String, int, int) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource(Border, String, int, int, Font) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource(Border, String, int, int, Font, Color) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BOTH - 类 java.awt.GridBagConstraints 中的静态变量
在水平方向和垂直方向上同时调整组件大小。
bottom - 类 java.awt.Insets 中的变量
底部的 inset。
BOTTOM - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的底层进纸托盘。
bottom - 类 javax.swing.border.EmptyBorder 中的变量
BOTTOM - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框底端线的中部。
BOTTOM - 类 javax.swing.JSplitPane 中的静态变量
用于添加一个 Component 到另一个 Component 的下面。
BOTTOM - 接口 javax.swing.SwingConstants 中的静态变量
用于指定框底部位置的框方向常量。
BOTTOM_ALIGNMENT - 类 java.awt.Component 中的静态变量
getAlignmentY 的易于使用的常量。
BOTTOM_ALIGNMENT - 类 java.awt.font.GraphicAttribute 中的静态变量
将图形底部与行的底部对齐。
BoundedRangeModel - javax.swing 中的 接口
定义由 Slider 和 ProgressBar 这类组件使用的数据模型。
bounds() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
bounds - 类 java.awt.Polygon 中的变量
此 Polygon 的边界。
Bounds - org.omg.CORBA 中的 异常
当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
Bounds() - 异常 org.omg.CORBA.Bounds 的构造方法
构造不带指定详细消息的 Bounds。
Bounds(String) - 异常 org.omg.CORBA.Bounds 的构造方法
构造带指定详细消息的 Bounds。
Bounds - org.omg.CORBA.TypeCodePackage 中的 异常
提供 TypeCode 操作 member_name()、member_type() 和 member_label。
Bounds() - 异常 org.omg.CORBA.TypeCodePackage.Bounds 的构造方法
构造一个不带任何原因信息的 Bounds 异常。
Bounds(String) - 异常 org.omg.CORBA.TypeCodePackage.Bounds 的构造方法
构造一个带有指定原因信息的 Bounds 异常。
Box - javax.swing 中的 类
使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
Box(int) - 类 javax.swing.Box 的构造方法
创建一个沿指定坐标轴显示其组件的 Box。
Box.AccessibleBox - javax.swing 中的 类
此类实现 Box 类的可访问性支持。
Box.AccessibleBox() - 类 javax.swing.Box.AccessibleBox 的构造方法
Box.Filler - javax.swing 中的 类
参与布局但没有视图的轻量级组件的实现。
Box.Filler(Dimension, Dimension, Dimension) - 类 javax.swing.Box.Filler 的构造方法
使用给定的大小范围创建形状的构造方法。
Box.Filler.AccessibleBoxFiller - javax.swing 中的 类
此类实现 Box.Filler 类的可访问性支持。
Box.Filler.AccessibleBoxFiller() - 类 javax.swing.Box.Filler.AccessibleBoxFiller 的构造方法
BOX_DRAWING - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Box Drawing”Unicode 字符块的常量。
boxedClass(PrimitiveType) - 接口 javax.lang.model.util.Types 中的方法
返回给定基本类型的装箱 (boxed) 值类型的类。
BoxedValueHelper - org.omg.CORBA.portable 中的 接口
BoxLayout - javax.swing 中的 类
允许垂直或水平布置多个组件的布局管理器。
BoxLayout(Container, int) - 类 javax.swing.BoxLayout 的构造方法
创建一个将沿给定轴放置组件的布局管理器。
boxRect - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的变量
用于保存要绘制的跳动框（由 getBox 返回）的位置和大小。
BoxView - javax.swing.text 中的 类
一个视图，它通过沿某轴平铺将其子级排列到框形状中。
BoxView(Element, int) - 类 javax.swing.text.BoxView 的构造方法
构造一个 BoxView。
BR - 类 javax.swing.text.html.HTML.Tag 中的静态变量
BRAILLE_PATTERNS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Braille Patterns”Unicode 字符块的常量。
breadthFirstEnumeration() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回一个枚举，该枚举按广度优先的顺序遍历以此节点为根的子树。
BreakIterator - java.text 中的 类
BreakIterator 类实现用于查找文本中边界位置的方法。
BreakIterator() - 类 java.text.BreakIterator 的构造方法
构造方法。
BreakIteratorProvider - java.text.spi 中的 类
提供 BreakIterator 类具体实现的服务提供者的抽象类。
BreakIteratorProvider() - 类 java.text.spi.BreakIteratorProvider 的构造方法
唯一的构造方法。
breaksFlow() - 类 javax.swing.text.html.HTML.Tag 中的方法
如果此标记导致数据流换行，则返回 true；否则返回 false。
breaksFlow() - 类 javax.swing.text.html.parser.TagElement 中的方法
breakView(int, int, float, float) - 类 javax.swing.text.GlyphView 中的方法
在给定的轴上以给定的长度拆分此视图。
breakView(int, int, float, float) - 类 javax.swing.text.html.InlineView 中的方法
尝试在给定轴上拆分此视图。
breakView(int, float, Shape) - 类 javax.swing.text.ParagraphView 中的方法
以给定的长度在给定的轴上拆分此视图。
breakView(int, int, float, float) - 类 javax.swing.text.View 中的方法
试图在给定的轴上拆分视图。
BRIEF - 类 java.rmi.server.LogStream 中的静态变量
已过时。 日志级别常量（简明日志记录）。
brighter() - 类 java.awt.Color 中的方法
创建一个新 Color，它具有比此 Color 更亮的颜色。
BrokenBarrierException - java.util.concurrent 中的 异常
当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。
BrokenBarrierException() - 异常 java.util.concurrent.BrokenBarrierException 的构造方法
构造不带指定详细消息的 BrokenBarrierException。
BrokenBarrierException(String) - 异常 java.util.concurrent.BrokenBarrierException 的构造方法
构造带指定详细消息的 BrokenBarrierException。
browse(URI) - 类 java.awt.Desktop 中的方法
启动默认浏览器来显示 URI。
BUBBLING_PHASE - 接口 org.w3c.dom.events.Event 中的静态变量
当前的事件阶段为 bubbling 阶段。
buf - 类 java.io.BufferedInputStream 中的变量
存储数据的内部缓冲区数组。
buf - 类 java.io.BufferedOutputStream 中的变量
存储数据的内部缓冲区。
buf - 类 java.io.ByteArrayInputStream 中的变量
由该流的创建者提供的 byte 数组。
buf - 类 java.io.ByteArrayOutputStream 中的变量
存储数据的缓冲区。
buf - 类 java.io.CharArrayReader 中的变量
字符缓冲区。
buf - 类 java.io.CharArrayWriter 中的变量
存储数据的缓冲区。
buf - 类 java.io.PushbackInputStream 中的变量
推回缓冲区。
buf - 类 java.util.zip.DeflaterInputStream 中的变量
读取压缩数据的输入缓冲区。
buf - 类 java.util.zip.DeflaterOutputStream 中的变量
写入压缩数据的输出缓冲区。
buf - 类 java.util.zip.InflaterInputStream 中的变量
用于解压缩的输入缓冲区。
buf - 类 java.util.zip.InflaterOutputStream 中的变量
写入未压缩数据的输出缓冲区。
buffer - 类 java.io.PipedInputStream 中的变量
放置传入数据的循环缓冲区。
buffer - 类 java.io.StringBufferInputStream 中的变量
已过时。 从中读取字节的字符串。
Buffer - java.nio 中的 类
一个用于特定基本类型数据的容器。
buffer - 类 javax.swing.text.DefaultStyledDocument 中的变量
BUFFER_SIZE_DEFAULT - 类 javax.swing.text.DefaultStyledDocument 中的静态变量
初始内容缓冲区的默认大小。
BufferCapabilities - java.awt 中的 类
缓冲区的能力和属性。
BufferCapabilities(ImageCapabilities, ImageCapabilities, BufferCapabilities.FlipContents) - 类 java.awt.BufferCapabilities 的构造方法
创建一个指定缓冲区能力的新对象
BufferCapabilities.FlipContents - java.awt 中的 类
页面翻转后可能的后台缓冲区内容的一个类型安全的枚举
BUFFERED_OPTION - 类 javax.swing.DebugGraphics 中的静态变量
在一个单独的 Frame 中显示已缓冲的操作。
BufferedImage - java.awt.image 中的 类
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。
BufferedImage(int, int, int) - 类 java.awt.image.BufferedImage 的构造方法
构造一个类型为预定义图像类型之一的 BufferedImage。
BufferedImage(int, int, int, IndexColorModel) - 类 java.awt.image.BufferedImage 的构造方法
构造一个类型为预定义图像类型之一的 BufferedImage：TYPE_BYTE_BINARY 或 TYPE_BYTE_INDEXED。
BufferedImage(ColorModel, WritableRaster, boolean, Hashtable<?, ?>) - 类 java.awt.image.BufferedImage 的构造方法
构造一个具有指定 ColorModel 和 Raster 的新 BufferedImage。
BufferedImageFilter - java.awt.image 中的 类
BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。
BufferedImageFilter(BufferedImageOp) - 类 java.awt.image.BufferedImageFilter 的构造方法
构造具有指定单一源图像/单一目标图像操作符的 BufferedImageFilter。
BufferedImageOp - java.awt.image 中的 接口
此接口描述对 BufferedImage 对象所执行的单输入/单输出操作。
BufferedInputStream - java.io 中的 类
BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。
BufferedInputStream(InputStream) - 类 java.io.BufferedInputStream 的构造方法
创建一个 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。
BufferedInputStream(InputStream, int) - 类 java.io.BufferedInputStream 的构造方法
创建具有指定缓冲区大小的 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。
BufferedOutputStream - java.io 中的 类
该类实现缓冲的输出流。
BufferedOutputStream(OutputStream) - 类 java.io.BufferedOutputStream 的构造方法
创建一个新的缓冲输出流，以将数据写入指定的底层输出流。
BufferedOutputStream(OutputStream, int) - 类 java.io.BufferedOutputStream 的构造方法
创建一个新的缓冲输出流，以将具有指定缓冲区大小的数据写入指定的底层输出流。
BufferedReader - java.io 中的 类
从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。
BufferedReader(Reader, int) - 类 java.io.BufferedReader 的构造方法
创建一个使用指定大小输入缓冲区的缓冲字符输入流。
BufferedReader(Reader) - 类 java.io.BufferedReader 的构造方法
创建一个使用默认大小输入缓冲区的缓冲字符输入流。
BufferedWriter - java.io 中的 类
将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
BufferedWriter(Writer) - 类 java.io.BufferedWriter 的构造方法
创建一个使用默认大小输出缓冲区的缓冲字符输出流。
BufferedWriter(Writer, int) - 类 java.io.BufferedWriter 的构造方法
创建一个使用给定大小输出缓冲区的新缓冲字符输出流。
BufferOverflowException - java.nio 中的 异常
当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
BufferOverflowException() - 异常 java.nio.BufferOverflowException 的构造方法
构造此类的一个实例。
BufferStrategy - java.awt.image 中的 类
BufferStrategy 类表示用来在特定的 Canvas 或 Window 上组织复杂内存的机制。
BufferStrategy() - 类 java.awt.image.BufferStrategy 的构造方法
BufferUnderflowException - java.nio 中的 异常
当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
BufferUnderflowException() - 异常 java.nio.BufferUnderflowException 的构造方法
构造此类的一个实例。
BUHID - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Buhid”Unicode 字符块的常量。
build(CertPathParameters) - 类 java.security.cert.CertPathBuilder 中的方法
尝试使用指定的算法参数集构建一个证书路径。
buildChooser() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
建立一个新的选取器面板。
bumps - 类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 中的变量
bumps - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的变量
burstStringInto(Container, String, int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
递归式创建表示 d 的新 JLabel 实例每个 JLabel 实例都将被添加到 c。
BUSY - 类 javax.accessibility.AccessibleState 中的静态变量
指示当前对象忙。
Button - java.awt 中的 类
此类创建一个标签按钮。
Button() - 类 java.awt.Button 的构造方法
构造一个标签字符串为空的按钮。
Button(String) - 类 java.awt.Button 的构造方法
构造一个带指定标签的按钮。
BUTTON - 类 javax.swing.plaf.synth.Region 中的静态变量
Button 的 region。
Button.AccessibleAWTButton - java.awt 中的 类
此类实现对 Button 类的可访问性支持。
Button.AccessibleAWTButton() - 类 java.awt.Button.AccessibleAWTButton 的构造方法
BUTTON1 - 类 java.awt.event.MouseEvent 中的静态变量
指示鼠标按键 #1；由 MouseEvent.getButton() 使用。
BUTTON1_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button1 的扩展修饰符常量。
BUTTON1_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button1 修饰符常量。
BUTTON2 - 类 java.awt.event.MouseEvent 中的静态变量
指示鼠标按键 #2；由 MouseEvent.getButton() 使用。
BUTTON2_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button2 的扩展修饰符常量。
BUTTON2_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button2 修饰符常量。
BUTTON3 - 类 java.awt.event.MouseEvent 中的静态变量
指示鼠标按键 #3；由 MouseEvent.getButton() 使用。
BUTTON3_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button3 的扩展修饰符常量。
BUTTON3_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button3 修饰符常量。
ButtonGroup - javax.swing 中的 类
此类用于为一组按钮创建一个多斥（multiple-exclusion）作用域。
ButtonGroup() - 类 javax.swing.ButtonGroup 的构造方法
创建一个新的 ButtonGroup。
buttonIndex - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener 中的变量
buttonListener - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
ButtonModel - javax.swing 中的 接口
按钮的状态模型。
buttons - 类 javax.swing.ButtonGroup 中的变量
ButtonUI - javax.swing.plaf 中的 类
JButton 的可插入外观界面。
ButtonUI() - 类 javax.swing.plaf.ButtonUI 的构造方法
Byte - java.lang 中的 类
Byte 类将基本类型 byte 的值包装在一个对象中。
Byte(byte) - 类 java.lang.Byte 的构造方法
构造一个新分配的 Byte 对象，以表示指定的 byte 值。
Byte(String) - 类 java.lang.Byte 的构造方法
构造一个新分配的 Byte 对象，以表示 String 参数所指示的 byte 值。
BYTE - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Byte 的值。
ByteArrayInputStream - java.io 中的 类
ByteArrayInputStream 包含一个内部缓冲区，该缓冲区包含从流中读取的字节。
ByteArrayInputStream(byte[]) - 类 java.io.ByteArrayInputStream 的构造方法
创建一个 ByteArrayInputStream，使用 buf 作为其缓冲区数组。
ByteArrayInputStream(byte[], int, int) - 类 java.io.ByteArrayInputStream 的构造方法
创建 ByteArrayInputStream，使用 buf 作为其缓冲区数组。
ByteArrayOutputStream - java.io 中的 类
此类实现了一个输出流，其中的数据被写入一个 byte 数组。
ByteArrayOutputStream() - 类 java.io.ByteArrayOutputStream 的构造方法
创建一个新的 byte 数组输出流。
ByteArrayOutputStream(int) - 类 java.io.ByteArrayOutputStream 的构造方法
创建一个新的 byte 数组输出流，它具有指定大小的缓冲区容量（以字节为单位）。
ByteBuffer - java.nio 中的 类
字节缓冲区。
ByteChannel - java.nio.channels 中的 接口
可读取和写入字节的信道。
ByteHolder - org.omg.CORBA 中的 类
Byte 的 Holder。
ByteHolder() - 类 org.omg.CORBA.ByteHolder 的构造方法
构造一个新的 ByteHolder 对象，将其 value 字段初始化为 0。
ByteHolder(byte) - 类 org.omg.CORBA.ByteHolder 的构造方法
为给定 byte 构造一个新的 ByteHolder 对象。
byteLength - 类 javax.sound.midi.MidiFileFormat 中的变量
MIDI 文件的长度，以字节为单位。
ByteLookupTable - java.awt.image 中的 类
此类定义一个 lookup table 对象。
ByteLookupTable(int, byte[][]) - 类 java.awt.image.ByteLookupTable 的构造方法
根据字节数组的数组（表示每个 band 的 lookup table）构造一个 ByteLookupTable 对象。
ByteLookupTable(int, byte[]) - 类 java.awt.image.ByteLookupTable 的构造方法
根据字节数组（表示应用于所有 band 的 lookup table）构造一个 ByteLookupTable 对象。
ByteOrder - java.nio 中的 类
字节顺序的类型安全枚举。
byteOrder - 类 javax.imageio.stream.ImageInputStreamImpl 中的变量
流的字节顺序，其为枚举类 java.nio.ByteOrder 的实例，其中 ByteOrder.BIG_ENDIAN 指示网络字节顺序，ByteOrder.LITTLE_ENDIAN 指示反向顺序。
bytesConsumed() - 类 javax.net.ssl.SSLEngineResult 中的方法
返回使用的输入缓冲区中的字节数。
bytesProduced() - 类 javax.net.ssl.SSLEngineResult 中的方法
返回写入到输出缓冲区中的字节数。
bytesTransferred - 异常 java.io.InterruptedIOException 中的变量
报告 I/O 操作中断之前传输了其中多少字节。
bytesWidth(byte[], int, int) - 类 java.awt.FontMetrics 中的方法
返回显示此 Font 中指定字节数组的总 advance width。
byteValue() - 类 java.lang.Byte 中的方法
作为一个 byte 返回此 Byte 的值。
byteValue() - 类 java.lang.Double 中的方法
以 byte 形式返回此 Double 的值（通过强制转换为 byte）。
byteValue() - 类 java.lang.Float 中的方法
将此 Float 值以 byte 形式返回（强制转换为 byte）。
byteValue() - 类 java.lang.Integer 中的方法
以 byte 类型返回该 Integer 的值。
byteValue() - 类 java.lang.Long 中的方法
以 byte 形式返回此 Long 的值。
byteValue() - 类 java.lang.Number 中的方法
以 byte 形式返回指定的数值。
byteValue() - 类 java.lang.Short 中的方法
以 byte 形式返回此 Short 的值。
byteValueExact() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 byte，以检查丢失的信息。
BYZANTINE_MUSICAL_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Byzantine Musical Symbols”Unicode 字符块的常量。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


C - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

C

C - 类 java.awt.PageAttributes.MediaType 中的静态变量
Engineering C (17 x 22 in) 的 MediaType 实例。
C - 类 javax.print.attribute.standard.MediaSize.Engineering 中的静态变量
指定 engineering C 尺寸，17 inch × 22 inch。
C - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
C 尺寸。
C0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C0 的别名。
C1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C1 的别名。
C10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C10 的别名。
C14NMethodParameterSpec - javax.xml.crypto.dsig.spec 中的 接口
CanonicalizationMethod 算法的算法参数规范。
C2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C2 的别名。
C3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C3 的别名。
C3 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO C3 尺寸，324 mm × 458 mm。
C4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C4 的别名。
C4 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO C4 尺寸，229 mm × 324 mm。
C5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C5 的别名。
C5 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO C5 尺寸，162 mm × 229 mm。
C6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C6 的别名。
C6 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO C6 尺寸，114 mm × 162 mm。
C7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C7 的别名。
C8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C8 的别名。
C9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C9 的别名。
cachedChildren() - 类 java.util.prefs.AbstractPreferences 中的方法
返回此节点的所有已知未移除子节点。
cachedMinimumSize - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
CachedRowSet - javax.sql.rowset 中的 接口
所有标准 CachedRowSet 实现都必须实现的接口。
cacheIcon(File, Icon) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法
cacheMBeanInfo(MBeanInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：缓存为此对象构建的 MBeanInfo。
CacheRequest - java.net 中的 类
表示在 ResponseCache 中存储资源的通道。
CacheRequest() - 类 java.net.CacheRequest 的构造方法
CacheResponse - java.net 中的 类
表示从 ResponseCache 获取资源的通道。
CacheResponse() - 类 java.net.CacheResponse 的构造方法
calcRect - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
用于通用布局计算以避免运行中构造多个新 Rectangle 的矩形。
calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[]) - 类 javax.swing.SizeRequirements 中的静态方法
创建一组偏移量/区域对，指定如何按照指定对齐方式对一组组件进行布局。
calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean) - 类 javax.swing.SizeRequirements 中的静态方法
创建一组偏移量/区域对，指定如何按指定对齐方式对一组组件进行布局。
calculateBreakPosition(int, int) - 类 javax.swing.text.WrappedPlainView 中的方法
此方法由嵌套换行视图调用，以确定拆分位置。
calculateContentRect() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateFocusRect() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateGeometry() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateIndex(CompositeData) - 接口 javax.management.openmbean.TabularData 中的方法
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例中后引用该参数。
calculateIndex(CompositeData) - 类 javax.management.openmbean.TabularDataSupport 中的方法
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例后引用该参数。
calculateInnerArea(JComponent, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
将指定组件的内部绘制区域的位置和大小存储在 r 中，然后返回 r。
calculateLabelRect() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateLayoutInfo() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
calculateMajorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.BoxView 中的方法
计算主轴 axis 的大小要求。
calculateMajorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.html.BlockView 中的方法
计算块沿主轴的要求（即沿其平铺的轴）。
calculateMaxTabHeight(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateMaxTabHeight(int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
calculateMaxTabWidth(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateMinorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.BoxView 中的方法
计算辅轴 axis 的大小要求。
calculateMinorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.FlowView 中的方法
计算沿辅轴的要求。
calculateMinorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.html.BlockView 中的方法
计算块沿辅轴的要求（即垂直沿其平铺的轴的轴）。
calculateMinorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.html.ParagraphView 中的方法
计算段落沿辅轴的要求。
calculateMinorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.TableView 中的方法
计算辅轴的所需大小。
calculateSize(boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
calculateTabAreaHeight(int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateTabAreaWidth(int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateTabHeight(int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateTabRects(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
calculateTabWidth(int, int, FontMetrics) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateThumbLocation() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateThumbSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateTickRect() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[]) - 类 javax.swing.SizeRequirements 中的静态方法
创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean) - 类 javax.swing.SizeRequirements 中的静态方法
创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
calculateTrackBuffer() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateTrackRect() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calendar - 类 java.text.DateFormat 中的变量
DateFormat 使用 calendar 来生成实现日期和时间格式化所需的时间字段值。
Calendar - java.util 中的 类
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
Calendar() - 类 java.util.Calendar 的构造方法
构造一个带有默认时区和语言环境的 Calendar。
Calendar(TimeZone, Locale) - 类 java.util.Calendar 的构造方法
构造一个带有指定时区和语言环境的 Calendar。
call() - 接口 java.util.concurrent.Callable 中的方法
计算结果，如果无法计算结果，则抛出一个异常。
call() - 接口 javax.tools.JavaCompiler.CompilationTask 中的方法
执行此编译任务。
call(SOAPMessage, Object) - 类 javax.xml.soap.SOAPConnection 中的方法
将给定消息发送到指定端点，在返回应答前将一直阻塞。
Callable<V> - java.util.concurrent 中的 接口
返回结果并且可能抛出异常的任务。
callable(Runnable, T) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可运行给定的任务并返回给定的结果。
callable(Runnable) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可运行给定的任务并返回 null。
callable(PrivilegedAction<?>) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可运行给定特权的操作并返回其结果。
callable(PrivilegedExceptionAction<?>) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可运行给定特权的异常操作并返回其结果。
CallableStatement - java.sql 中的 接口
用于执行 SQL 存储过程的接口。
Callback - javax.security.auth.callback 中的 接口
将此接口的实现传递给 CallbackHandler，允许底层安全服务与调用的应用程序交互，从而获取特定的验证数据（如用户名和密码），或者显示特定的信息（如错误和警告消息）。
CallbackHandler - javax.security.auth.callback 中的 接口
应用程序实现 CallbackHandler，并将其传递到底层安全服务，以便它们能与应用程序交互，从而获得特定的验证数据（如用户名和密码），或显示特定的信息（如错误和警告消息）。
CANADA - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
CANADA_FRENCH - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
cancel() - 类 java.awt.print.PrinterJob 中的方法
取消正在进行的打印作业。
cancel() - 类 java.nio.channels.SelectionKey 中的方法
请求取消此键的通道到其选择器的注册。
cancel() - 类 java.nio.channels.spi.AbstractSelectionKey 中的方法
取消此键。
cancel() - 接口 java.sql.Statement 中的方法
如果 DBMS 和驱动程序都支持中止 SQL 语句，则取消此 Statement 对象。
cancel(boolean) - 接口 java.util.concurrent.Future 中的方法
试图取消对此任务的执行。
cancel(boolean) - 类 java.util.concurrent.FutureTask 中的方法
cancel() - 类 java.util.Timer 中的方法
终止此计时器，丢弃所有当前已安排的任务。
cancel() - 类 java.util.TimerTask 中的方法
取消此计时器任务。
cancel() - 接口 javax.print.CancelablePrintJob 中的方法
停止对打印作业的进一步处理。
CANCEL - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
CANCEL 选项。
cancel(boolean) - 类 javax.swing.SwingWorker 中的方法
试图取消对此任务的执行。
CANCEL_OPTION - 类 javax.swing.JFileChooser 中的静态变量
选择 cancel 后的返回该值。
CANCEL_OPTION - 类 javax.swing.JOptionPane 中的静态变量
选择 CANCEL 时从类方法返回的值。
CANCEL_SELECTION - 类 javax.swing.JFileChooser 中的静态变量
指示取消当前的选择。
CancelablePrintJob - javax.print 中的 接口
打印应用程序使用此接口来取消打印作业。
cancelButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
cancelButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
cancelButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
cancelCellEditing() - 类 javax.swing.AbstractCellEditor 中的方法
调用 fireEditingCanceled。
cancelCellEditing() - 接口 javax.swing.CellEditor 中的方法
告知编辑器取消编辑并且不接受任何已部分编辑的值。
cancelCellEditing() - 类 javax.swing.DefaultCellEditor 中的方法
将消息从 CellEditor 转发到 delegate。
cancelCellEditing() - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
取消编辑。
cancelCellEditing() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
将 cancelCellEditing 发送到 realEditor，并从此实例移除它。
CANCELED - 类 javax.print.attribute.standard.JobState 中的静态变量
作业已被人为操作取消，打印机已完成了正取消的作业，且所有作业状态属性已达到作业的最终值。
cancelEditing() - 类 javax.swing.JTree 中的方法
取消当前编辑会话。
cancelEditing(JTree) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
取消当前编辑会话。
cancelEditing(JTree) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 cancelEditing 方法。
cancelEditing(JTree) - 类 javax.swing.plaf.TreeUI 中的方法
取消当前编辑会话。
cancelLatestCommittedText(AttributedCharacterIterator.Attribute[]) - 接口 java.awt.im.InputMethodRequests 中的方法
从文本编辑组件中获取最新的提交文本，并将其从该组件的文本正文中移除。
CancellationException - java.util.concurrent 中的 异常
如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
CancellationException() - 异常 java.util.concurrent.CancellationException 的构造方法
构造不带详细消息的 CancellationException。
CancellationException(String) - 异常 java.util.concurrent.CancellationException 的构造方法
构造带指定详细消息的 CancellationException。
CancelledKeyException - java.nio.channels 中的 异常
当试图使用不再有效的选择键时，抛出此未经检查的异常。
CancelledKeyException() - 异常 java.nio.channels.CancelledKeyException 的构造方法
构造此类的一个实例。
cancelledKeys() - 类 java.nio.channels.spi.AbstractSelector 中的方法
获取此选择器的已取消键集。
cancelRowUpdates() - 接口 java.sql.ResultSet 中的方法
取消对 ResultSet 对象中的当前行所作的更新。
cancelSelection() - 类 javax.swing.JFileChooser 中的方法
用户选择 Cancel 按钮时由 UI 调用此方法。
canDecodeInput(Object) - 类 javax.imageio.spi.ImageReaderSpi 中的方法
如果给定的源对象看起来是此 reader 支持的格式，则返回 true。
canDisplay(char) - 类 java.awt.Font 中的方法
检查此 Font 是否具有指定字符的字形。
canDisplay(int) - 类 java.awt.Font 中的方法
检查此 Font 是否具有指定字符的字形。
canDisplayUpTo(String) - 类 java.awt.Font 中的方法
指示此 Font 是否可以显示指定的 String。
canDisplayUpTo(char[], int, int) - 类 java.awt.Font 中的方法
指示此 Font 是否可以显示指定 text 中从 start 开始至 limit 结束的所有字符。
canDisplayUpTo(CharacterIterator, int, int) - 类 java.awt.Font 中的方法
指示此 Font 是否可以显示由 iter 指定的文本（从 start 开始至 limit 结束）。
canDock(Component, Point) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
canEdit - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
从 Java 2 平台 v1.4 开始，不应再使用此字段。
canEditImmediately(EventObject) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果 event 为 null，或者它是一个单击计数 > 2 的 MouseEvent，并且 inHitRegion 返回 true，则此方法返回 true。
canEncode() - 类 java.nio.charset.Charset 中的方法
通知此 charset 是否支持编码。
canEncode(char) - 类 java.nio.charset.CharsetEncoder 中的方法
通知此编码器是否能够编码给定的字符。
canEncode(CharSequence) - 类 java.nio.charset.CharsetEncoder 中的方法
通过此编码器是否能够编码给定的字符序列。
canEncodeImage(ImageTypeSpecifier) - 类 javax.imageio.spi.ImageWriterSpi 中的方法
如果与此服务提供者关联的 ImageWriter 实现能够使用给定的布局编码图像，则返回 true。
canEncodeImage(RenderedImage) - 类 javax.imageio.spi.ImageWriterSpi 中的方法
如果与此服务提供者关联的 ImageWriter 实现能够编码给定的 RenderedImage 实例，则返回 true。
canExecute() - 类 java.io.File 中的方法
测试应用程序是否可以执行此抽象路径名表示的文件。
canFilterIndexColorModel - 类 java.awt.image.RGBImageFilter 中的变量
此布尔值指示是否可以接受用 filterRGB 方法的颜色过滤替代逐像素过滤，并应用于 IndexColorModel 对象的颜色表项。
canImport(TransferHandler.TransferSupport) - 类 javax.swing.TransferHandler 中的方法
在拖放操作期间重复调用此方法，以允许开发人员配置传输的可接受性属性，并返回传输的可接受性；返回 true 值指示给定 TransferSupport（它包含该传输的所有细节）所表示的传输在当前是可以接受的，false 值指示拒绝该传输。
canImport(JComponent, DataFlavor[]) - 类 javax.swing.TransferHandler 中的方法
指示一个组件在实际尝试导入给定数据 flavor 的集合之前是否接受其导入。
canInsertEmpty(int) - 类 javax.imageio.ImageWriter 中的方法
如果 writer 支持在给定索引处插入新的空图像，则返回 true。
canInsertImage(int) - 类 javax.imageio.ImageWriter 中的方法
如果 writer 支持在给定索引处插入新图像，则返回 true。
canNodeAppear(String, ImageTypeSpecifier) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
如果允许元素（和它下面的子树）在给定类型（由 ImageTypeSpecifier 定义）的图像的元数据文档中出现，则返回 true。
canNodeAppear(String, ImageTypeSpecifier) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
CannotProceed - org.omg.CosNaming.NamingContextPackage 中的 异常
org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
CannotProceed() - 异常 org.omg.CosNaming.NamingContextPackage.CannotProceed 的构造方法
CannotProceed(NamingContext, NameComponent[]) - 异常 org.omg.CosNaming.NamingContextPackage.CannotProceed 的构造方法
CannotProceed(String, NamingContext, NameComponent[]) - 异常 org.omg.CosNaming.NamingContextPackage.CannotProceed 的构造方法
CannotProceedException - javax.naming 中的 异常
抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
CannotProceedException(String) - 异常 javax.naming.CannotProceedException 的构造方法
使用解释构造一个新的 CannotProceedException 实例。
CannotProceedException() - 异常 javax.naming.CannotProceedException 的构造方法
构造一个新的 CannotProceedException 实例。
CannotProceedHelper - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java。
CannotProceedHelper() - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 的构造方法
CannotProceedHolder - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java。
CannotProceedHolder() - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 的构造方法
CannotProceedHolder(CannotProceed) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 的构造方法
CannotRedoException - javax.swing.undo 中的 异常
当 UndoableEdit 被通知 redo() 但无法执行时抛出。
CannotRedoException() - 异常 javax.swing.undo.CannotRedoException 的构造方法
CannotUndoException - javax.swing.undo 中的 异常
当 UndoableEdit 被通知 undo() 但无法执行时抛出。
CannotUndoException() - 异常 javax.swing.undo.CannotUndoException 的构造方法
canOffsetTiles - 类 javax.imageio.ImageWriteParam 中的变量
如果此 ImageWriteParam 允许使用 tiling 网格偏移量参数，则返回为 true 的 boolean 值。
canOffsetTiles() - 类 javax.imageio.ImageWriteParam 中的方法
如果 writer 在执行写入操作的同时可以使用非零网格偏移量进行平铺，则返回 true。
CANON_EQ - 类 java.util.regex.Pattern 中的静态变量
启用规范等价。
CANONICAL - 类 javax.security.auth.x500.X500Principal 中的静态变量
标识名的规范化字符串格式。
CANONICAL_DECOMPOSITION - 类 java.text.Collator 中的静态变量
Decomposition 模式值。
CanonicalizationMethod - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。
canonicalize(Oid) - 接口 org.ietf.jgss.GSSName 中的方法
创建一个针对某种机制而规范化的名称。
canPathsBeAdded(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
用于测试是否可以添加特定的 TreePath 集合。
canPathsBeRemoved(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
如果可以移除该路径而不中断该模型的连续性，则返回 true。
canRead() - 类 java.io.File 中的方法
测试应用程序是否可以读取此抽象路径名表示的文件。
canReadRaster() - 类 javax.imageio.ImageReader 中的方法
如果此插件支持只读取像素数据的 Raster，则返回 true。
canRedo() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
如果此编辑为 alive 并且 hasBeenDone 为 false，则返回 true。
canRedo() - 类 javax.swing.undo.CompoundEdit 中的方法
如果 isInProgress 或者超类返回 false，则此方法返回 false。
canRedo() - 接口 javax.swing.undo.UndoableEdit 中的方法
如果可以恢复此编辑，则返回 true。
canRedo() - 类 javax.swing.undo.UndoManager 中的方法
如果可以恢复编辑，则返回 true。
canRemoveImage(int) - 类 javax.imageio.ImageWriter 中的方法
如果 writer 支持在给定索引处移除现有图像，则返回 true。
canReplaceImageMetadata(int) - 类 javax.imageio.ImageWriter 中的方法
如果有可能使用索引 imageIndex 替换与现有图像有关的图像元数据，则返回 true。
canReplacePixels(int) - 类 javax.imageio.ImageWriter 中的方法
如果 writer 允许使用 replacePixels 方法替换给定图像的索引，则返回 true。
canReplaceStreamMetadata() - 类 javax.imageio.ImageWriter 中的方法
如果有可能替换已存在于输出中的流元数据，则返回 true。
canSetParameter(String, Object) - 接口 org.w3c.dom.DOMConfiguration 中的方法
检查是否支持将参数设置为特定值。
canSetSourceRenderSize - 类 javax.imageio.ImageReadParam 中的变量
如果此 ImageReadParam 允许设置源呈现维数，则为 true。
canSetSourceRenderSize() - 类 javax.imageio.ImageReadParam 中的方法
如果此 reader 允许通过使用 setSourceRenderSize 方法以任意大小将源图像呈现为解码过程的一部分，则返回 true。
canUndo() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
如果此编辑为 alive 并且 hasBeenDone 为 true，则返回 true。
canUndo() - 类 javax.swing.undo.CompoundEdit 中的方法
如果 isInProgress 或者超类返回 false，则此方法返回 false。
canUndo() - 接口 javax.swing.undo.UndoableEdit 中的方法
如果可以撤消此编辑，则返回 true。
canUndo() - 类 javax.swing.undo.UndoManager 中的方法
如果可以撤消编辑，则返回 true。
canUndoOrRedo() - 类 javax.swing.undo.UndoManager 中的方法
如果可以调用 undo 或 redo，则返回 true。
canUseCacheFile() - 类 javax.imageio.spi.ImageInputStreamSpi 中的方法
如果与此服务提供者关联的 ImageInputStream 实现可选择利用缓存文件改善性能和/或内存占用，则返回 true。
canUseCacheFile() - 类 javax.imageio.spi.ImageOutputStreamSpi 中的方法
如果与此服务提供者关联的 ImageOutputStream 实现可选择利用缓存 File 改善性能和/或内存占用，则返回 true。
Canvas - java.awt 中的 类
Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
Canvas() - 类 java.awt.Canvas 的构造方法
构造一个新的 Canvas。
Canvas(GraphicsConfiguration) - 类 java.awt.Canvas 的构造方法
根据给定 GraphicsConfiguration 对象构造一个新的 Canvas。
CANVAS - 类 javax.accessibility.AccessibleRole 中的静态变量
可用于绘制和捕获事件的对象。
Canvas.AccessibleAWTCanvas - java.awt 中的 类
此类实现对 Canvas 类的可访问性支持。
Canvas.AccessibleAWTCanvas() - 类 java.awt.Canvas.AccessibleAWTCanvas 的构造方法
canWrite() - 类 java.io.File 中的方法
测试应用程序是否可以修改此抽象路径名表示的文件。
canWriteCompressed - 类 javax.imageio.ImageWriteParam 中的变量
如果此 writer 可以使用压缩写入图像，则返回为 true 的 boolean 值。
canWriteCompressed() - 类 javax.imageio.ImageWriteParam 中的方法
如果此 writer 支持压缩，则返回 true。
canWriteEmpty() - 类 javax.imageio.ImageWriter 中的方法
如果 writer 支持写入由单个图像组成的完整图像流，则返回 true，这些对象带有要输出的不确定像素值、有关元数据和缩略图。
canWriteProgressive - 类 javax.imageio.ImageWriteParam 中的变量
如果此 ImageWriteParam 允许以一个质量递增传递的逐步序列的方式写入图像，则返回为 true 的 boolean 值。
canWriteProgressive() - 类 javax.imageio.ImageWriteParam 中的方法
如果 writer 能够以一系列质量逐渐递增的传递的方式将图像写出，则返回 true。
canWriteRasters() - 类 javax.imageio.ImageWriter 中的方法
如果采用 IIOImage 参数的方法能够处理 Raster（相对于 RenderedImage）源图像，则返回 true。
canWriteSequence() - 类 javax.imageio.ImageWriter 中的方法
如果 writer 能够将图像添加到已经包含头信息和可能的以前图像的图像流中，则返回 true。
canWriteTiles - 类 javax.imageio.ImageWriteParam 中的变量
如果此 ImageWriteParam 允许设置 tile 的宽度和高度参数，则返回为 true 的 boolean 值。
canWriteTiles() - 类 javax.imageio.ImageWriteParam 中的方法
如果 writer 在执行写入操作的同时可以进行平铺，则返回 true。
CAP_BUTT - 类 java.awt.BasicStroke 中的静态变量
无装饰地结束未封闭的子路径和虚线线段。
CAP_ROUND - 类 java.awt.BasicStroke 中的静态变量
使用半径等于画笔宽度一半的圆形装饰结束未封闭的子路径和虚线线段。
CAP_SQUARE - 类 java.awt.BasicStroke 中的静态变量
使用正方形结束未封闭的子路径和虚线线段，正方形越过线段端点，并延长等于线条宽度一半的距离。
capacity() - 类 java.lang.StringBuffer 中的方法
capacity() - 类 java.nio.Buffer 中的方法
返回此缓冲区的容量。
capacity() - 类 java.util.Vector 中的方法
返回此向量的当前容量。
capacity() - 类 javax.swing.DefaultListModel 中的方法
返回此列表的当前容量。
capacityIncrement - 类 java.util.Vector 中的变量
向量的大小大于其容量时，容量自动增加的量。
capacityIncrement - 类 javax.management.monitor.Monitor 中的静态变量
监视器数组的大小大于其容量时，容量自动递增的量。
caps - 类 java.awt.Component.BltBufferStrategy 中的变量
缓冲区能力
caps - 类 java.awt.Component.FlipBufferStrategy 中的变量
缓冲能力。
CAPS_LOCK - 类 java.awt.Event 中的静态变量
Caps Lock 键，一个非 ASCII 操作键。
CAPTION - 类 javax.swing.text.html.HTML.Tag 中的静态变量
capture(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
对类型应用 capture 转换。
CAPTURING_PHASE - 接口 org.w3c.dom.events.Event 中的静态变量
当前的事件阶段是捕获阶段。
cardinality() - 类 java.util.BitSet 中的方法
返回此 BitSet 中设置为 true 的位数。
CardLayout - java.awt 中的 类
CardLayout 对象是容器的布局管理器。
CardLayout() - 类 java.awt.CardLayout 的构造方法
创建一个间距大小为 0 的新卡片布局。
CardLayout(int, int) - 类 java.awt.CardLayout 的构造方法
创建一个具有指定水平间距和垂直间距的新卡片布局。
Caret - javax.swing.text 中的 接口
文档视图中的一个位置，它表示文档模型中能插入其他内容的位置。
CARET_POSITION_CHANGED - 类 java.awt.event.InputMethodEvent 中的静态变量
事件类型，它指示输入方法文本中修改的插入点。
CaretEvent - javax.swing.event 中的 类
CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。
CaretEvent(Object) - 类 javax.swing.event.CaretEvent 的构造方法
创建一个新的 CaretEvent 对象。
CaretListener - javax.swing.event 中的 接口
用于侦听文本组件插入符的位置更改的侦听器。
caretPositionChanged(InputMethodEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 caretPositionChanged 方法处理 caretPositionChanged 事件。
caretPositionChanged(InputMethodEvent) - 接口 java.awt.event.InputMethodListener 中的方法
当撰写文本中的 caret 发生变化时调用。
caretUpdate(CaretEvent) - 接口 javax.swing.event.CaretListener 中的方法
当插入符的位置被更新时调用。
caretUpdate(CaretEvent) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
处理插入符更新（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_CARET_PROPERTY 和 AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY）。
CASE_INSENSITIVE - 类 java.util.regex.Pattern 中的静态变量
启用不区分大小写的匹配。
CASE_INSENSITIVE_ORDER - 类 java.lang.String 中的静态变量
一个对 String 对象进行排序的 Comparator，作用与 compareToIgnoreCase 相同。
cast(Object) - 类 java.lang.Class 中的方法
将一个对象强制转换成此 Class 对象所表示的类或接口。
catchExceptions - 类 java.awt.event.InvocationEvent 中的变量
如果 dispatch() 捕获了 Throwable 并将其存储在异常实例变量中，则设置为 true。
cbrt(double) - 类 java.lang.Math 中的静态方法
返回 double 值的立方根。
cbrt(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的立方根。
CDATA - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
CDATA - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个 CDATA 节
CDATA_SECTION_ELEMENTS - 类 javax.xml.transform.OutputKeys 中的静态变量
cdata-section-elements = expanded names. cdata-section-elements 指定了由空白分隔的元素名称列表，其中的文本节点子级应使用 CDATA 部分来输出。
CDATA_SECTION_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 CDATASection。
CDATASection - org.w3c.dom 中的 接口
CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。
ceil(double) - 类 java.lang.Math 中的静态方法
返回最小的（最接近负无穷大）double 值，该值大于等于参数，并等于某个整数。
ceil(double) - 类 java.lang.StrictMath 中的静态方法
返回最小的（最接近负无穷大）double 值，该值大于等于参数，并且等于某个整数。
ceiling(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
ceiling(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 中大于等于给定元素的最小元素；如果不存在这样的元素，则返回 null。
ceiling(E) - 类 java.util.TreeSet 中的方法
ceilingEntry(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与大于等于给定键的最小键关联的键-值映射关系；如果不存在这样的条目，则返回 null。
ceilingEntry(K) - 接口 java.util.NavigableMap 中的方法
返回一个键-值映射关系，它与大于等于给定键的最小键关联；如果不存在这样的键，则返回 null。
ceilingEntry(K) - 类 java.util.TreeMap 中的方法
ceilingKey(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
ceilingKey(K) - 接口 java.util.NavigableMap 中的方法
返回大于等于给定键的最小键；如果不存在这样的键，则返回 null。
ceilingKey(K) - 类 java.util.TreeMap 中的方法
CELL_EDITOR_PROPERTY - 类 javax.swing.JTree 中的静态变量
cellEditor 的绑定属性名称。
CELL_RENDERER_PROPERTY - 类 javax.swing.JTree 中的静态变量
cellRenderer 的绑定属性名称。
CELL_RENDERER_PROPERTY - 类 javax.swing.table.TableColumn 中的静态变量
从 Java 2 platform v1.3 开始已过时。
CellEditor - javax.swing 中的 接口
此接口定义任何通用编辑器应该能够实现的方法。
cellEditor - 类 javax.swing.JTable 中的变量
活动单元格编辑器对象，它重写当前单元格占用的屏幕空间，并允许用户更改其内容。
cellEditor - 类 javax.swing.JTree 中的变量
条目编辑器。
cellEditor - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
树的编辑器。
cellEditor - 类 javax.swing.table.TableColumn 中的变量
用于编辑列的数据单元格的编辑器。
CellEditorListener - javax.swing.event 中的 接口
CellEditorListener 定义用于侦听 CellEditor 中更改的对象的接口
cellHeight - 类 javax.swing.plaf.basic.BasicListUI 中的变量
cellHeights - 类 javax.swing.plaf.basic.BasicListUI 中的变量
CELLPADDING - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
cellRenderer - 类 javax.swing.JTree 中的变量
用于绘制节点的单元格。
cellRenderer - 类 javax.swing.table.TableColumn 中的变量
用于绘制列的数据单元格的渲染器。
cellRendererChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
CellRendererPane - javax.swing 中的 类
此类被插入在单元格渲染器与使用它们的组件之间。
CellRendererPane() - 类 javax.swing.CellRendererPane 的构造方法
构造一个 CellRendererPane 对象。
CellRendererPane.AccessibleCellRendererPane - javax.swing 中的 类
此类实现 Panel 类的可访问性支持。
CellRendererPane.AccessibleCellRendererPane() - 类 javax.swing.CellRendererPane.AccessibleCellRendererPane 的构造方法
cellSelectionEnabled - 类 javax.swing.JTable 中的变量
从 Java 2 平台 v1.3 开始已过时。
CELLSPACING - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
cellWidth - 类 javax.swing.plaf.basic.BasicListUI 中的变量
CENTER - 类 java.awt.BorderLayout 中的静态变量
中间区域的布局约束（容器中央）。
CENTER - 类 java.awt.FlowLayout 中的静态变量
此值指示每一行组件都应该是居中的。
CENTER - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的中心。
CENTER - 类 java.awt.Label 中的静态变量
指示标签文本应居中。
CENTER - 类 javax.swing.border.TitledBorder 中的静态变量
将标题文本置于边框线的中心。
CENTER - 接口 javax.swing.SwingConstants 中的静态变量
某区域的中心位置。
CENTER - 类 javax.swing.text.html.HTML.Tag 中的静态变量
CENTER_ALIGNMENT - 类 java.awt.Component 中的静态变量
getAlignmentY 和 getAlignmentX 的易于使用的常量。
CENTER_BASELINE - 类 java.awt.Font 中的静态变量
布置文本时，在表意文字的脚本（如中文、日文和韩文）中使用的基线。
CENTER_BASELINE - 类 java.awt.font.GraphicAttribute 中的静态变量
将图形的原点与行的中心基线对齐。
centersChildren - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的变量
如果为 true，则子级将在父级中汇总在一起。
Certificate - java.security.cert 中的 类
管理各种身份证书的抽象类。
Certificate(String) - 类 java.security.cert.Certificate 的构造方法
创建指定类型的证书。
Certificate - java.security 中的 接口
已过时。 在 Java 平台中创建了新的证书处理包。此 Certificate 接口已完全废弃，其仍存在是为了能平稳地过渡到新包。
Certificate - javax.security.cert 中的 类
管理各种身份证书的抽象类。
Certificate() - 类 javax.security.cert.Certificate 的构造方法
Certificate.CertificateRep - java.security.cert 中的 类
用于序列化的替换 Certificate 类。
Certificate.CertificateRep(String, byte[]) - 类 java.security.cert.Certificate.CertificateRep 的构造方法
构造带有 Certificate 类型和 Certificate 编码字节的替代 Certificate 类。
CertificateEncodingException - java.security.cert 中的 异常
证书编码异常。
CertificateEncodingException() - 异常 java.security.cert.CertificateEncodingException 的构造方法
构造不带详细消息的 CertificateEncodingException。
CertificateEncodingException(String) - 异常 java.security.cert.CertificateEncodingException 的构造方法
构造带指定详细消息的 CertificateEncodingException。
CertificateEncodingException(String, Throwable) - 异常 java.security.cert.CertificateEncodingException 的构造方法
创建带指定详细消息和原因的 CertificateEncodingException。
CertificateEncodingException(Throwable) - 异常 java.security.cert.CertificateEncodingException 的构造方法
创建带指定原因和详细消息的 CertificateEncodingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertificateEncodingException - javax.security.cert 中的 异常
证书编码异常。
CertificateEncodingException() - 异常 javax.security.cert.CertificateEncodingException 的构造方法
构造不带详细消息的 CertificateEncodingException。
CertificateEncodingException(String) - 异常 javax.security.cert.CertificateEncodingException 的构造方法
构造带指定详细信息的 CertificateEncodingException。
CertificateException - java.security.cert 中的 异常
此异常指示各种证书问题中的一种。
CertificateException() - 异常 java.security.cert.CertificateException 的构造方法
构造不带详细消息的 Certificate 异常。
CertificateException(String) - 异常 java.security.cert.CertificateException 的构造方法
构造带给定详细消息的 Certificate 异常。
CertificateException(String, Throwable) - 异常 java.security.cert.CertificateException 的构造方法
创建带指定详细消息和原因的 CertificateException。
CertificateException(Throwable) - 异常 java.security.cert.CertificateException 的构造方法
创建带指定原因和详细消息的 CertificateException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertificateException - javax.security.cert 中的 异常
此异常指示各种证书问题之一。
CertificateException() - 异常 javax.security.cert.CertificateException 的构造方法
构造不带详细消息的 CertificateException。
CertificateException(String) - 异常 javax.security.cert.CertificateException 的构造方法
构造带给定详细消息的 CertificateException。
CertificateExpiredException - java.security.cert 中的 异常
证书过期异常。
CertificateExpiredException() - 异常 java.security.cert.CertificateExpiredException 的构造方法
构造不带详细消息的 CertificateExpiredException。
CertificateExpiredException(String) - 异常 java.security.cert.CertificateExpiredException 的构造方法
构造带指定详细消息的 CertificateExpiredException。
CertificateExpiredException - javax.security.cert 中的 异常
证书过期异常。
CertificateExpiredException() - 异常 javax.security.cert.CertificateExpiredException 的构造方法
构造不带详细消息的 CertificateExpiredException。
CertificateExpiredException(String) - 异常 javax.security.cert.CertificateExpiredException 的构造方法
构造带指定详细信息的 CertificateExpiredException。
CertificateFactory - java.security.cert 中的 类
此类定义了用于从相关的编码中生成证书、证书路径 (CertPath) 和证书撤消列表 (CRL) 对象的 CertificateFactory 功能。
CertificateFactory(CertificateFactorySpi, Provider, String) - 类 java.security.cert.CertificateFactory 的构造方法
创建给定类型的 CertificateFactory 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertificateFactorySpi - java.security.cert 中的 类
此类定义了 CertificateFactory 类的服务提供者接口 (SPI)。
CertificateFactorySpi() - 类 java.security.cert.CertificateFactorySpi 的构造方法
CertificateNotYetValidException - java.security.cert 中的 异常
证书尚无效异常。
CertificateNotYetValidException() - 异常 java.security.cert.CertificateNotYetValidException 的构造方法
构造不带详细消息的 CertificateNotYetValidException。
CertificateNotYetValidException(String) - 异常 java.security.cert.CertificateNotYetValidException 的构造方法
构造带指定详细消息的 CertificateNotYetValidException。
CertificateNotYetValidException - javax.security.cert 中的 异常
证书不再有效异常。
CertificateNotYetValidException() - 异常 javax.security.cert.CertificateNotYetValidException 的构造方法
构造不带详细消息的 CertificateNotYetValidException。
CertificateNotYetValidException(String) - 异常 javax.security.cert.CertificateNotYetValidException 的构造方法
构造带指定详细消息的 CertificateNotYetValidException。
CertificateParsingException - java.security.cert 中的 异常
证书解析异常。
CertificateParsingException() - 异常 java.security.cert.CertificateParsingException 的构造方法
构造不带详细消息的 CertificateParsingException。
CertificateParsingException(String) - 异常 java.security.cert.CertificateParsingException 的构造方法
构造带指定详细消息的 CertificateParsingException。
CertificateParsingException(String, Throwable) - 异常 java.security.cert.CertificateParsingException 的构造方法
创建带指定详细消息和原因的 CertificateParsingException。
CertificateParsingException(Throwable) - 异常 java.security.cert.CertificateParsingException 的构造方法
创建带指定原因和详细消息的 CertificateParsingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertificateParsingException - javax.security.cert 中的 异常
证书解析异常。
CertificateParsingException() - 异常 javax.security.cert.CertificateParsingException 的构造方法
构造不带详细消息的 CertificateParsingException。
CertificateParsingException(String) - 异常 javax.security.cert.CertificateParsingException 的构造方法
构造带指定详细信息的 CertificateParsingException。
certificates() - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 所有证书的一个副本。
CertPath - java.security.cert 中的 类
不可变的证书序列（证书路径）。
CertPath(String) - 类 java.security.cert.CertPath 的构造方法
创建指定类型的 CertPath。
CertPath.CertPathRep - java.security.cert 中的 类
用于序列化的替换 CertPath 类。
CertPath.CertPathRep(String, byte[]) - 类 java.security.cert.CertPath.CertPathRep 的构造方法
创建具有指定证书路径类型和编码形式的 CertPathRep。
CertPathBuilder - java.security.cert 中的 类
构建证书路径（也称为证书链）的类。
CertPathBuilder(CertPathBuilderSpi, Provider, String) - 类 java.security.cert.CertPathBuilder 的构造方法
创建一个给定算法的 CertPathBuilder 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertPathBuilderException - java.security.cert 中的 异常
指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
CertPathBuilderException() - 异常 java.security.cert.CertPathBuilderException 的构造方法
创建详细消息为 null 的 CertPathBuilderException。
CertPathBuilderException(String) - 异常 java.security.cert.CertPathBuilderException 的构造方法
创建带给定详细消息的 CertPathBuilderException。
CertPathBuilderException(Throwable) - 异常 java.security.cert.CertPathBuilderException 的构造方法
创建包装指定 throwable 的 CertPathBuilderException。
CertPathBuilderException(String, Throwable) - 异常 java.security.cert.CertPathBuilderException 的构造方法
创建带指定详细消息和原因的 CertPathBuilderException。
CertPathBuilderResult - java.security.cert 中的 接口
证书路径生成器算法的结果的规范。
CertPathBuilderSpi - java.security.cert 中的 类
CertPathBuilder 类的服务提供者接口 (SPI)。
CertPathBuilderSpi() - 类 java.security.cert.CertPathBuilderSpi 的构造方法
默认的构造方法。
CertPathParameters - java.security.cert 中的 接口
证书路径算法参数的规范。
CertPathTrustManagerParameters - javax.net.ssl 中的 类
CertPathParameters 的包装器。
CertPathTrustManagerParameters(CertPathParameters) - 类 javax.net.ssl.CertPathTrustManagerParameters 的构造方法
根据指定的 parameters 构造新的 CertPathTrustManagerParameters。
CertPathValidator - java.security.cert 中的 类
验证证书路径（也称为证书链）的类。
CertPathValidator(CertPathValidatorSpi, Provider, String) - 类 java.security.cert.CertPathValidator 的构造方法
创建一个给定算法的 CertPathValidator 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertPathValidatorException - java.security.cert 中的 异常
指示在验证一个证书路径时遇到了某种问题的异常。
CertPathValidatorException() - 异常 java.security.cert.CertPathValidatorException 的构造方法
创建不带详细消息的 CertPathValidatorException。
CertPathValidatorException(String) - 异常 java.security.cert.CertPathValidatorException 的构造方法
创建带给定详细消息的 CertPathValidatorException。
CertPathValidatorException(Throwable) - 异常 java.security.cert.CertPathValidatorException 的构造方法
创建包装指定 throwable 的 CertPathValidatorException。
CertPathValidatorException(String, Throwable) - 异常 java.security.cert.CertPathValidatorException 的构造方法
创建带指定详细消息和 cause 的 CertPathValidatorException。
CertPathValidatorException(String, Throwable, CertPath, int) - 异常 java.security.cert.CertPathValidatorException 的构造方法
创建带指定详细消息、cause、证书路径和索引的 CertPathValidatorException。
CertPathValidatorResult - java.security.cert 中的 接口
证书路径验证器算法的结果的规范。
CertPathValidatorSpi - java.security.cert 中的 类
CertPathValidator 类的服务提供者接口 (SPI)。
CertPathValidatorSpi() - 类 java.security.cert.CertPathValidatorSpi 的构造方法
默认的构造方法。
CertSelector - java.security.cert 中的 接口
一个定义了一套选择 Certificate 的标准的选择器。
CertStore - java.security.cert 中的 类
用于从存储库中获取 Certificate 和 CRL 的类。
CertStore(CertStoreSpi, Provider, String, CertStoreParameters) - 类 java.security.cert.CertStore 的构造方法
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。
CertStoreException - java.security.cert 中的 异常
指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
CertStoreException() - 异常 java.security.cert.CertStoreException 的构造方法
创建详细消息为 null 的 CertStoreException。
CertStoreException(String) - 异常 java.security.cert.CertStoreException 的构造方法
创建带指定详细消息的 CertStoreException。
CertStoreException(Throwable) - 异常 java.security.cert.CertStoreException 的构造方法
创建包装指定 throwable 的 CertStoreException。
CertStoreException(String, Throwable) - 异常 java.security.cert.CertStoreException 的构造方法
创建带指定详细消息和 cause 的 CertStoreException。
CertStoreParameters - java.security.cert 中的 接口
CertStore 参数的规范。
CertStoreSpi - java.security.cert 中的 类
CertStore 类的服务提供者接口 (SPI)。
CertStoreSpi(CertStoreParameters) - 类 java.security.cert.CertStoreSpi 的构造方法
唯一的构造方法。
CHANGE - 类 javax.swing.event.DocumentEvent.EventType 中的静态变量
更改类型。
change(int, int, AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
更改内容。
CHANGED - 类 java.awt.dnd.DragSourceContext 中的静态变量
updateCurrentCursor() 使用的 int 值，指示用户操作已改变。
ChangedCharSetException - javax.swing.text 中的 异常
顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。
ChangedCharSetException(String, boolean) - 异常 javax.swing.text.ChangedCharSetException 的构造方法
changedUpdate(DocumentEvent) - 接口 javax.swing.event.DocumentListener 中的方法
给出属性或属性集发生了更改的通知。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.FlowView 中的方法
发出通知，通知文档中此视图负责的某个位置的属性已更改。
changedUpdate(FlowView, DocumentEvent, Rectangle) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
发出通知，通知文档中此视图负责的某个位置的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.GlyphView 中的方法
发出通知，通知文档此视图负责的位置处的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.html.BlockView 中的方法
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.html.ImageView 中的方法
当 Elements 属性已更改时调用。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.html.InlineView 中的方法
发出通知，通知文档此视图负责的位置处的属性已更改。
changedUpdate(DocumentEvent) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.LabelView 中的方法
发出通知，通知文档此视图负责的位置处的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.ParagraphView 中的方法
发出通知，通知文档中此视图负责的某个位置的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.PlainView 中的方法
发出通知，通知文档中此视图负责的某个位置的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.View 中的方法
发出通知，通知文档此视图负责的位置处的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.WrappedPlainView 中的方法
发出文档中此视图负责的位置上的属性已发生更改的通知。
changeEvent - 类 javax.swing.AbstractButton 中的变量
每个按钮实例都只需要一个 ChangeEvent，因为事件的唯一状态是源属性。
changeEvent - 类 javax.swing.AbstractCellEditor 中的变量
changeEvent - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的变量
由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。
changeEvent - 类 javax.swing.DefaultBoundedRangeModel 中的变量
由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。
changeEvent - 类 javax.swing.DefaultButtonModel 中的变量
每个按钮模型实例只需要一个 ChangeEvent，因为事件的唯一状态是源属性。
changeEvent - 类 javax.swing.DefaultSingleSelectionModel 中的变量
ChangeEvent - javax.swing.event 中的 类
ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
ChangeEvent(Object) - 类 javax.swing.event.ChangeEvent 的构造方法
构造一个 ChangeEvent 对象。
changeEvent - 类 javax.swing.JProgressBar 中的变量
每个实例只需要一个 ChangeEvent，因为事件的唯一感兴趣属性是不可变源，即进度条。
changeEvent - 类 javax.swing.JSlider 中的变量
一个滑块实例仅需要一个 ChangeEvent，因为该事件唯一（只读）的状态是源属性。
changeEvent - 类 javax.swing.JTabbedPane 中的变量
由于事件仅有的（只读）状态是源属性，因此每个 TabPane 实例只需要一个 ChangeEvent。
changeEvent - 类 javax.swing.MenuSelectionManager 中的变量
每个按钮模型实例只需要一个 ChangeEvent，因为事件的惟一状态是 source 属性。
changeEvent - 类 javax.swing.table.DefaultTableColumnModel 中的变量
更改事件（只需要一个）
changeEvent - 类 javax.swing.text.DefaultCaret 中的变量
此模型的更改事件。
changeEvent - 类 javax.swing.text.StyleContext.NamedStyle 中的变量
由于事件的惟一状态（只读）为源属性，因此每个模型实例只需要一个 ChangeEvent。
changeHighlight(Object, int, int) - 类 javax.swing.text.DefaultHighlighter 中的方法
更改高亮显示。
changeHighlight(Object, int, int) - 接口 javax.swing.text.Highlighter 中的方法
更改给定的高亮显示，以使其横跨文档的不同部分。
changeInfo - 类 javax.naming.event.NamingEvent 中的变量
包含关于生成此事件的更改的信息。
changeListener - 类 javax.swing.AbstractButton 中的变量
按钮模型的 changeListener。
ChangeListener - javax.swing.event 中的 接口
定义一个侦听 ChangeEvent 的对象。
changeListener - 类 javax.swing.JProgressBar 中的变量
侦听由进度条的模型发送的更改事件，并将其再次指派到在此进度条上注册的更改事件侦听器。
changeListener - 类 javax.swing.JSlider 中的变量
changeListener（无前缀）是添加到滑块模型的侦听器。
changeListener - 类 javax.swing.JTabbedPane 中的变量
changeListener 是添加到模型中的侦听器。
changeListener - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的变量
changeListener - 类 javax.swing.plaf.basic.BasicMenuUI 中的变量
changeListener - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的变量
changeListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
changeSelection(int, int, boolean, boolean) - 类 javax.swing.JTable 中的方法
根据 toggle 和 extend 这两个标志的状态，更新表的选择模型。
changeShape(Dimension, Dimension, Dimension) - 类 javax.swing.Box.Filler 中的方法
更改此形状的大小请求。
changeSupport - 类 javax.swing.AbstractAction 中的变量
如果已经注册了任意 PropertyChangeListener，则 changeSupport 字段负责描述它们。
changeSupport - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
用于接收通知的注册侦听器。
changeToParentDirectory() - 类 javax.swing.JFileChooser 中的方法
将要设置的目录更改为当前目录的父级。
changeUpdate() - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
更新元素结构，以响应文档中的更改。
Channel - java.nio.channels 中的 接口
用于 I/O 操作的连接。
channel() - 类 java.nio.channels.FileLock 中的方法
返回文件通道，此锁定保持在该通道的文件上。
channel() - 类 java.nio.channels.SelectionKey 中的方法
返回为之创建此键的通道。
channel - 类 javax.sound.midi.VoiceStatus 中的变量
在其上演奏此声音的 MIDI 通道。
CHANNEL_PRESSURE - 类 javax.sound.midi.ShortMessage 中的静态变量
CHANNEL_PRESSURE (Aftertouch) 消息的命令值（0xD0 或 208）
ChannelBinding - org.ietf.jgss 中的 类
此类封装关于调用者提供的通道绑定信息的概念。
ChannelBinding(InetAddress, InetAddress, byte[]) - 类 org.ietf.jgss.ChannelBinding 的构造方法
使用用户提供的地址信息和数据创建 ChannelBinding 对象。
ChannelBinding(byte[]) - 类 org.ietf.jgss.ChannelBinding 的构造方法
创建不带任何说明性信息的 ChannelBinding 对象。
Channels - java.nio.channels 中的 类
针对信道和流的实用工具方法。
channels - 类 javax.sound.sampled.AudioFormat 中的变量
使用此格式的音频信道数（单声道为 1，立体声为 2）。
CHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 CHAR 的 Java 编程语言中的常量（有时称为类型代码）。
CHAR_REPLACEMENT - 类 java.awt.font.TextAttribute 中的静态变量
用于取代字符的字体标准字型显示的用户定义字形的属性键。
CHAR_UNDEFINED - 类 java.awt.event.KeyEvent 中的静态变量
KEY_PRESSED 和 KEY_RELEASED 事件没有映射到一个有效的 Unicode 字符时使用此值作为 keyChar 值。
Character - java.lang 中的 类
Character 类在对象中包装一个基本类型 char 的值。
Character(char) - 类 java.lang.Character 的构造方法
构造一个新分配的 Character 对象，用以表示指定的 char 值。
CHARACTER - 接口 javax.accessibility.AccessibleText 中的静态变量
用于指示应获取的文本部分是一个字符的常量。
CHARACTER - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Character 的值。
Character.Subset - java.lang 中的 类
此类的实例表示 Unicode 字符集的特定子集。
Character.Subset(String) - 类 java.lang.Character.Subset 的构造方法
构造一个新的 Subset 实例。
Character.UnicodeBlock - java.lang 中的 类
表示 Unicode 规范中字符块的一系列字符子集。
CHARACTER_SET_ENCODING - 类 javax.xml.soap.SOAPMessage 中的静态变量
指定 SOAP Message 的字符类型编码。
CharacterCodingException - java.nio.charset 中的 异常
出现字符编码或解码错误时，抛出此经过检查的异常。
CharacterCodingException() - 异常 java.nio.charset.CharacterCodingException 的构造方法
构造此类的一个实例。
CharacterData - org.w3c.dom 中的 接口
CharacterData 接口使用属性集合和用于访问 DOM 中字符数据的方法扩展节点。
CharacterIterator - java.text 中的 接口
此接口定义了对文本进行双向迭代的协议。
Characters - javax.xml.stream.events 中的 接口
此方法将描述 Characters 事件的接口。
CHARACTERS - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一些字符
characters(char[], int, int) - 接口 org.xml.sax.ContentHandler 中的方法
接收字符数据的通知。
characters(char[], int, int) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收字符数据的通知。
characters(char[], int, int) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收元素内字符数据的通知。
characters(char[], int, int) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收元素中字符数据的通知。
characters(char[], int, int) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
characters(char[], int, int) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个字符数据事件。
characters(char[], int, int) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 字符事件。
CharArrayReader - java.io 中的 类
此类实现一个可用作字符输入流的字符缓冲区。
CharArrayReader(char[]) - 类 java.io.CharArrayReader 的构造方法
根据指定的 char 数组创建一个 CharArrayReader。
CharArrayReader(char[], int, int) - 类 java.io.CharArrayReader 的构造方法
根据指定的 char 数组创建一个 CharArrayReader。
CharArrayWriter - java.io 中的 类
此类实现一个可用作 Writer 的字符缓冲区。
CharArrayWriter() - 类 java.io.CharArrayWriter 的构造方法
创建一个新的 CharArrayWriter。
CharArrayWriter(int) - 类 java.io.CharArrayWriter 的构造方法
创建一个具有指定初始大小的新 CharArrayWriter。
charAt(int) - 接口 java.lang.CharSequence 中的方法
返回指定索引的 char 值。
charAt(int) - 类 java.lang.String 中的方法
返回指定索引处的 char 值。
charAt(int) - 类 java.lang.StringBuffer 中的方法
charAt(int) - 类 java.nio.CharBuffer 中的方法
读取相对于当前位置的给定索引处的字符。
charAt(int) - 类 javax.swing.text.Segment 中的方法
返回指定索引的 char 值。
charAttr - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的变量
CharBuffer - java.nio 中的 类
字符缓冲区。
CharConversionException - java.io 中的 异常
用于字符转换异常的基类。
CharConversionException() - 异常 java.io.CharConversionException 的构造方法
此异常不提供详细消息。
CharConversionException(String) - 异常 java.io.CharConversionException 的构造方法
此异常提供详细消息。
charCount(int) - 类 java.lang.Character 中的静态方法
确定表示指定字符（Unicode 代码点）所需的 char 值的数量。
CharHolder - org.omg.CORBA 中的 类
Char 的 Holder。
CharHolder() - 类 org.omg.CORBA.CharHolder 的构造方法
构造一个新的 CharHolder 对象，将其 value 字段初始化为 0。
CharHolder(char) - 类 org.omg.CORBA.CharHolder 的构造方法
为给定 char 值构造一个新的 CharHolder 对象。
CharSeqHelper - org.omg.CORBA 中的 类
CharSeq 的 Helper。
CharSeqHelper() - 类 org.omg.CORBA.CharSeqHelper 的构造方法
CharSeqHolder - org.omg.CORBA 中的 类
CharSeq 的 Holder。
CharSeqHolder() - 类 org.omg.CORBA.CharSeqHolder 的构造方法
CharSeqHolder(char[]) - 类 org.omg.CORBA.CharSeqHolder 的构造方法
CharSequence - java.lang 中的 接口
CharSequence 是 char 值的一个可读序列。
Charset - java.nio.charset 中的 类
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。
Charset(String, String[]) - 类 java.nio.charset.Charset 的构造方法
使用给定的规范名称和别名集合初始化新 charset。
charset() - 类 java.nio.charset.CharsetDecoder 中的方法
返回创建此解码器的 charset。
charset() - 类 java.nio.charset.CharsetEncoder 中的方法
返回创建此编码器的 charset。
CharsetDecoder - java.nio.charset 中的 类
能够把特定 charset 中的字节序列转换成 16 位 Unicode 字符序列的引擎。
CharsetDecoder(Charset, float, float) - 类 java.nio.charset.CharsetDecoder 的构造方法
初始化新的解码器。
CharsetEncoder - java.nio.charset 中的 类
能够把 16 位 Unicode 字符序列转换成特定 charset 中字节序列的引擎。
CharsetEncoder(Charset, float, float, byte[]) - 类 java.nio.charset.CharsetEncoder 的构造方法
初始化新的编码器。
CharsetEncoder(Charset, float, float) - 类 java.nio.charset.CharsetEncoder 的构造方法
初始化新的编码器。
charsetForName(String) - 类 java.nio.charset.spi.CharsetProvider 中的方法
用给定的 charset 名称获取 charset。
CharsetProvider - java.nio.charset.spi 中的 类
Charset 服务提供者类。
CharsetProvider() - 类 java.nio.charset.spi.CharsetProvider 的构造方法
初始化新的 charset 提供者。
charsets() - 类 java.nio.charset.spi.CharsetProvider 中的方法
创建在此提供者所支持的 charset 上进行迭代的迭代器。
charStream - 类 javax.sql.rowset.BaseRowSet 中的变量
将由方法 getCharacterStream 返回的 Reader 对象，该方法在 ResultSet 接口中指定。
charsWidth(char[], int, int) - 类 java.awt.FontMetrics 中的方法
返回显示此 Font 中指定字符数组的总 advance width。
charValue() - 类 java.lang.Character 中的方法
返回此 Character 对象的值。
charWidth(int) - 类 java.awt.FontMetrics 中的方法
返回此 Font 中指定字符的 advance width。
charWidth(char) - 类 java.awt.FontMetrics 中的方法
返回此 Font 中指定字符的 advance width。
check(Certificate, Collection<String>) - 类 java.security.cert.PKIXCertPathChecker 中的方法
使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。
check(String, URL, String, MLetContent) - 类 javax.management.loading.MLet 中的方法
当扩展此服务来支持缓存和版本控制时，要重写此方法。
CHECK_BOX - 类 javax.accessibility.AccessibleRole 中的静态变量
可以被选中或不被选中的选项，它针对当前状态提供了单独的指示符。
CHECK_BOX - 类 javax.swing.plaf.synth.Region 中的静态变量
CheckBox 的 region。
CHECK_BOX_MENU_ITEM - 类 javax.swing.plaf.synth.Region 中的静态变量
CheckBoxMenuItem 的 region。
checkAccept(String, int) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程从指定的主机和端口号接受套接字连接，则抛出 SecurityException。
checkAccess(Thread) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程修改 thread 参数，则抛出 SecurityException。
checkAccess(ThreadGroup) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程修改线程组参数，则抛出 SecurityException。
checkAccess() - 类 java.lang.Thread 中的方法
判定当前运行的线程是否有权修改该线程。
checkAccess() - 类 java.lang.ThreadGroup 中的方法
确定当前运行的线程是否有权修改此线程组。
checkAccess() - 类 java.util.logging.LogManager 中的方法
检查使用当前上下文来修改日志配置是否受信任。
checkAll() - 类 java.awt.MediaTracker 中的方法
查看此媒体跟踪器正在跟踪的所有图像是否已完成加载。
checkAll(boolean) - 类 java.awt.MediaTracker 中的方法
检查此媒体跟踪器正在跟踪的所有图像是否都已完成加载。
checkAwtEventQueueAccess() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问 AWT 事件队列，则抛出 SecurityException。
Checkbox - java.awt 中的 类
复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
Checkbox() - 类 java.awt.Checkbox 的构造方法
使用空字符串标签创建一个复选框。
Checkbox(String) - 类 java.awt.Checkbox 的构造方法
使用指定标签创建一个复选框。
Checkbox(String, boolean) - 类 java.awt.Checkbox 的构造方法
使用指定标签创建一个复选框，并将它设置为指定状态。
Checkbox(String, boolean, CheckboxGroup) - 类 java.awt.Checkbox 的构造方法
构造具有指定标签的 Checkbox，并将它设置为指定状态，使它处于指定复选框组中。
Checkbox(String, CheckboxGroup, boolean) - 类 java.awt.Checkbox 的构造方法
创建具有指定标签的 Checkbox，并使它处于指定复选框组内，将它设置为指定状态。
Checkbox.AccessibleAWTCheckbox - java.awt 中的 类
此类实现对 Checkbox 类的可访问性支持。
Checkbox.AccessibleAWTCheckbox() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 的构造方法
CheckboxGroup - java.awt 中的 类
CheckboxGroup 类用于集合 Checkbox 按钮集。
CheckboxGroup() - 类 java.awt.CheckboxGroup 的构造方法
创建 CheckboxGroup 的一个新实例。
CheckboxMenuItem - java.awt 中的 类
此类表示一个可包括在菜单中的复选框。
CheckboxMenuItem() - 类 java.awt.CheckboxMenuItem 的构造方法
创建具有空标签的复选框菜单项。
CheckboxMenuItem(String) - 类 java.awt.CheckboxMenuItem 的构造方法
创建具有指定标签的复选框菜单项。
CheckboxMenuItem(String, boolean) - 类 java.awt.CheckboxMenuItem 的构造方法
创建 具有指定标签和状态的复选框菜单项。
CheckboxMenuItem.AccessibleAWTCheckboxMenuItem - java.awt 中的 类
用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
CheckboxMenuItem.AccessibleAWTCheckboxMenuItem() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 的构造方法
checkClientTrusted(X509Certificate[], String) - 接口 javax.net.ssl.X509TrustManager 中的方法
给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的客户端 SSL 验证。
checkClosed() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
如果已经关闭流，则抛出 IOException。
checkConnect(String, int) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程打开到指定主机和端口号的套接字连接，则抛出 SecurityException。
checkConnect(String, int, Object) - 类 java.lang.SecurityManager 中的方法
如果不允许指定的安全上下文打开与指定主机和端口号的套接字连接，则抛出 SecurityException。
checkCreateClassLoader() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程创建新的类加载器，则抛出 SecurityException。
checkDelete(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程删除指定的文件，则抛出 SecurityException。
CHECKED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象当前被选中。
CHECKED - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
checkedCollection(Collection<E>, Class<E>) - 类 java.util.Collections 中的静态方法
返回指定 collection 的一个动态类型安全视图。
CheckedInputStream - java.util.zip 中的 类
需要维护所读取数据校验和的输入流。
CheckedInputStream(InputStream, Checksum) - 类 java.util.zip.CheckedInputStream 的构造方法
使用指定校验和创建输入流。
checkedList(List<E>, Class<E>) - 类 java.util.Collections 中的静态方法
返回指定列表的一个动态类型安全视图。
checkedMap(Map<K, V>, Class<K>, Class<V>) - 类 java.util.Collections 中的静态方法
返回指定映射的一个动态类型安全视图。
CheckedOutputStream - java.util.zip 中的 类
需要维护写入数据校验和的输出流。
CheckedOutputStream(OutputStream, Checksum) - 类 java.util.zip.CheckedOutputStream 的构造方法
使用指定校验和创建输出流。
checkedSet(Set<E>, Class<E>) - 类 java.util.Collections 中的静态方法
返回指定 set 的一个动态类型安全视图。
checkedSortedMap(SortedMap<K, V>, Class<K>, Class<V>) - 类 java.util.Collections 中的静态方法
返回指定有序映射的一个动态类型安全视图。
checkedSortedSet(SortedSet<E>, Class<E>) - 类 java.util.Collections 中的静态方法
返回指定有序 set 的一个动态类型安全视图。
checkError() - 类 java.io.PrintStream 中的方法
刷新流并检查其错误状态。
checkError() - 类 java.io.PrintWriter 中的方法
如果流没有关闭，则刷新流且检查其错误状态。
checkExec(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程创建一个子进程，则抛出 SecurityException。
checkExit(int) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程使用特定的状态码暂停 Java 虚拟机，则抛出 SecurityException。
checkForClickInExpandControl(TreePath, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果 mouseX 和 mouseY 位于 row 的展开/折叠区域内，则此方法将切换行。
checkGuard(Object) - 接口 java.security.Guard 中的方法
确定是否允许访问受保护的 object 对象。
checkGuard(Object) - 类 java.security.Permission 中的方法
为某权限实现 guard 接口。
checkHorizontalKey(int, String) - 类 javax.swing.AbstractButton 中的方法
验证 key 参数是否为 horizontalAlignment 和 horizontalTextPosition 属性的合法值。
checkHorizontalKey(int, String) - 类 javax.swing.JLabel 中的方法
验证该键是否为 horizontalAlignment 属性的合法值。
checkIcon - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
checkID(int) - 类 java.awt.MediaTracker 中的方法
检查由此媒体跟踪器跟踪且使用指定标识符标记的所有图像是否已完成加载。
checkID(int, boolean) - 类 java.awt.MediaTracker 中的方法
检查由此媒体跟踪器跟踪且使用指定标识符标记的所有图像是否已完成加载。
checkImage(Image, ImageObserver) - 类 java.awt.Component 中的方法
返回指定图像屏幕表示的构造状态。
checkImage(Image, int, int, ImageObserver) - 类 java.awt.Component 中的方法
返回指定图像屏幕表示的构造状态。
checkImage(Image, int, int, ImageObserver) - 类 java.awt.Toolkit 中的方法
指示正准备显示的指定图像的构造状态。
checkLink(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程动态链接由字符串参数文件指定的库代码，则抛出 SecurityException。
checkListen(int) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程等待与指定本地端口号进行连接的请求，则抛出 SecurityException。
checkMaxDegree(int) - 类 javax.management.relation.RoleInfo 中的方法
如果 value 参数小于或等于期望的最大程度，则返回 true；否则返回 false。
checkMemberAccess(Class<?>, int) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问程序，则抛出 SecurityException。
checkMinDegree(int) - 类 javax.management.relation.RoleInfo 中的方法
如果 value 参数大于或等于期望的最小程度，则返回 true；否则返回 false。
checkMulticast(InetAddress) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程使用（加入/离开/发送/接收）IP 多址广播，则抛出 SecurityException。
checkMulticast(InetAddress, byte) - 类 java.lang.SecurityManager 中的方法
已过时。 由 #checkPermission(java.security.Permission) 取代
checkOpacity(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
checkPackageAccess(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问由参数指定的包，则抛出 SecurityException。
checkPackageDefinition(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程在参数指定的包中定义类，则抛出 SecurityException。
checkPainter() - 类 javax.swing.text.GlyphView 中的方法
检查是否存在字形 painter。
checkPermission(Permission) - 类 java.lang.SecurityManager 中的方法
如果基于当前有效的安全策略，不允许执行根据给定权限所指定的请求访问，则抛出 SecurityException。
checkPermission(Permission, Object) - 类 java.lang.SecurityManager 中的方法
如果拒绝指定的安全上下文访问由给定权限所指定的资源，则抛出 SecurityException。
checkPermission(Permission) - 类 java.security.AccessControlContext 中的方法
基于当前生效的安全策略和此对象中的上下文确定是否允许指定权限指示的访问请求。
checkPermission(Permission) - 类 java.security.AccessController 中的静态方法
基于当前 AccessControlContext 和安全策略确定是否允许指定权限所指示的访问请求。
checkPermission(Principal, Permission) - 接口 java.security.acl.Acl 中的方法
检查指定的主体是否具有指定的权限。
checkPermission(Permission) - 接口 java.security.acl.AclEntry 中的方法
检查指定的权限是否为此项中权限集合的一部分。
checkPrintJobAccess() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程发起一个打印作业请求，则抛出 SecurityException。
checkPropertiesAccess() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问或修改系统属性，则抛出 SecurityException。
checkPropertyAccess(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问具有指定的 key 名的系统属性，则抛出 SecurityException。
checkRead(FileDescriptor) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程从指定的文件描述符进行读取，则抛出 SecurityException。
checkRead(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程读取由字符串参数指定的文件，则抛出 SecurityException。
checkRead(String, Object) - 类 java.lang.SecurityManager 中的方法
如果不允许指定的安全上下文读取由字符串参数所指定的文件，则抛出 SecurityException。
checkReadParamBandSettings(ImageReadParam, int, int) - 类 javax.imageio.ImageReader 中的静态方法
reader 可用来测试 ImageReadParam 的源和目标 band 设置的有效性的实用方法。
checkRoleReading(String, String) - 类 javax.management.relation.RelationService 中的方法
检查给定 Role 能否以给定类型的关系进行读取。
checkRoleReading(String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检查给定 Role 能否在给定类型的关系中读取。
checkRoleWriting(Role, String, Boolean) - 类 javax.management.relation.RelationService 中的方法
检查给定 Role 能否以给定类型的关系进行设置。
checkRoleWriting(Role, String, Boolean) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检查给定 Role 能否在给定类型的关系中设置。
checkSecurityAccess(String) - 类 java.lang.SecurityManager 中的方法
确定是应该允许还是拒绝具有指定权限目标名的权限。
checkServerTrusted(X509Certificate[], String) - 接口 javax.net.ssl.X509TrustManager 中的方法
给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的服务器 SSL 验证。
checkSetFactory() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程设置由 ServerSocket 或 Socket 使用的套接字工厂，或者由 URL 使用的流处理程序工厂，则抛出 SecurityException。
Checksum - java.util.zip 中的 接口
表示数据校验和的接口。
checkSystemClipboardAccess() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问系统剪贴板，则抛出 SecurityException。
checkTopLevelWindow(Object) - 类 java.lang.SecurityManager 中的方法
如果不受信任的调用线程调出由 window 参数指出的顶层窗口，则返回 false。
checkValidity() - 类 java.security.cert.X509Certificate 中的方法
检查证书目前是否有效。
checkValidity(Date) - 类 java.security.cert.X509Certificate 中的方法
检查给定的日期是否处于证书的有效期内。
checkValidity() - 类 javax.security.cert.X509Certificate 中的方法
检查证书目前是否有效。
checkValidity(Date) - 类 javax.security.cert.X509Certificate 中的方法
检查指定的日期是否处于证书的有效期内。
checkVerticalKey(int, String) - 类 javax.swing.AbstractButton 中的方法
验证 key 参数是否为垂直属性的合法值。
checkVerticalKey(int, String) - 类 javax.swing.JLabel 中的方法
验证该键是否为 verticalAlignment 或 verticalTextPosition 属性的合法值。
checkWrite(FileDescriptor) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程写入指定的文件描述符，则抛出 SecurityException。
checkWrite(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程写由字符串参数指定的文件，则抛出 SecurityException。
CHEROKEE - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Cherokee”Unicode 字符块的常量。
CHILD_NODE_OF - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个对象的子节点。
CHILD_NODE_OF_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个或多个对象之间的 CHILD_NODE_OF 关系已更改。
CHILD_POLICY_ALL - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示某个元素必须具有按顺序排列的其每个合法子元素的单个实例。
CHILD_POLICY_CHOICE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示元素必须具有从其合法子元素中选择的零个或一个子元素。
CHILD_POLICY_EMPTY - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示某个元素不具有任何子元素。
CHILD_POLICY_MAX - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
最大有效 CHILD_POLICY_* 常量，将用于范围检查。
CHILD_POLICY_REPEAT - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示元素必须具有其唯一合法子元素的零个或多个实例。
CHILD_POLICY_SEQUENCE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示元素必须具有其所有合法子元素的实例序列。
CHILD_POLICY_SOME - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示元素必须具有按顺序排列的其每个合法子元素的零个或一个实例。
childAdded(NodeChangeEvent) - 接口 java.util.prefs.NodeChangeListener 中的方法
添加子节点时调用此方法。
childAlloc - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的变量
用于子级分配区域以避免创建大量垃圾的形状。
childAllocation(int, Rectangle) - 类 javax.swing.text.BoxView 中的方法
为子视图分配一个区域。
childAllocation(int, Rectangle) - 类 javax.swing.text.CompositeView 中的方法
返回给定子级的分配区域。
childChanged(AsyncBoxView.ChildState) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
子级已更改的通知。
childDeserializedHook(Object, BeanContextSupport.BCSChild) - 类 java.beans.beancontext.BeanContextSupport 中的方法
由 readObject 利用新近反序列化的子级和 BCSChild 调用。
childIndices - 类 javax.swing.event.TreeModelEvent 中的变量
标识子节点所在位置的索引。
childJustAddedHook(Object, BeanContextSupport.BCSChild) - 类 java.beans.beancontext.BeanContextSupport 中的方法
子类可以重写此方法，以便在已经添加子对象之后，且在发生事件通知之前，只扩展 add() 语义。
childJustRemovedHook(Object, BeanContextSupport.BCSChild) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
在已成功移除子级之后，从超类的子级移除操作中调用。
childJustRemovedHook(Object, BeanContextSupport.BCSChild) - 类 java.beans.beancontext.BeanContextSupport 中的方法
子类可以重写此方法，以便在已经移除子对象之后，且在发生事件通知之前，只扩展 remove() 语义。
childRemoved(NodeChangeEvent) - 接口 java.util.prefs.NodeChangeListener 中的方法
移除子节点时调用此方法。
children - 类 java.beans.beancontext.BeanContextMembershipEvent 中的变量
受此事件通知影响的子级的列表。
children - 类 java.beans.beancontext.BeanContextSupport 中的变量
protected HashMap children 字段的所有访问在该对象上都将是同步的。
children - 类 javax.swing.event.TreeModelEvent 中的变量
已被移除的子节点。
children() - 类 javax.swing.JTree.DynamicUtilTreeNode 中的方法
必要时创建子类以加载此子节点。
children() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
以 Enumeration 形式返回接收方的子级。
children() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
以 Enumeration 的形式返回接收者的子级。
children() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
以 Enumeration 的形式返回接收者的子级。
children - 类 javax.swing.tree.DefaultMutableTreeNode 中的变量
子节点的数组，如果此节点没有子节点，则可以为 null
children() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回此节点的子节点的正向枚举。
children() - 接口 javax.swing.tree.TreeNode 中的方法
以 Enumeration 的形式返回接收者的子节点。
childrenAdded(BeanContextMembershipEvent) - 接口 java.beans.beancontext.BeanContextMembershipListener 中的方法
在将一个子级或子级列表添加到此侦听器在其中注册的 BeanContext 中时调用。
childrenNames() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.childrenNames() 中的规范实现 children 方法。
childrenNames() - 类 java.util.prefs.Preferences 中的方法
返回此首选项节点相对于此节点的子节点名称。
childrenNamesSpi() - 类 java.util.prefs.AbstractPreferences 中的方法
返回此首选项节点的子节点名称。
childrenRemoved(BeanContextMembershipEvent) - 接口 java.beans.beancontext.BeanContextMembershipListener 中的方法
在将一个子级或子级列表从此侦听器在其中注册的 BeanContext 中移除时调用。
childSpi(String) - 类 java.util.prefs.AbstractPreferences 中的方法
返回此首选项节点的指定子节点；如果该子节点尚未存在，则创建它。
childValue(T) - 类 java.lang.InheritableThreadLocal 中的方法
在创建子线程时，计算这个可继承线程局部变量的子线程的初始值，将该值作为父线程值的一个函数。
childValue - 类 javax.swing.JTree.DynamicUtilTreeNode 中的变量
用于创建子节点的值。
CHINA - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
CHINESE - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
Choice - java.awt 中的 类
Choice 类表示一个弹出式选择菜单。
Choice() - 类 java.awt.Choice 的构造方法
创建一个新的选择菜单。
Choice.AccessibleAWTChoice - java.awt 中的 类
此类实现对 Choice 类的可访问性支持。
Choice.AccessibleAWTChoice() - 类 java.awt.Choice.AccessibleAWTChoice 的构造方法
ChoiceCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。
ChoiceCallback(String, String[], int, boolean) - 类 javax.security.auth.callback.ChoiceCallback 的构造方法
构造一个 ChoiceCallback，带有提示、选项列表、默认选项和指定选项列表是否允许进行多重选择的布尔值。
ChoiceFormat - java.text 中的 类
ChoiceFormat 允许将格式应用到某个范围的数。
ChoiceFormat(String) - 类 java.text.ChoiceFormat 的构造方法
根据 limit 和相应的 format（基于模式）构造。
ChoiceFormat(double[], String[]) - 类 java.text.ChoiceFormat 的构造方法
根据 limit 和相应的 format 构造。
choices - 类 java.sql.DriverPropertyInfo 中的变量
如果可以从特定一组值中选择 DriverPropertyInfo.value 字段的值，则返回可能值组成的数组；否则返回 null。
CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识预定义文件过滤器列表的更改，用户可从该列表中进行选择。
chooseClientAlias(String[], Principal[], Socket) - 接口 javax.net.ssl.X509KeyManager 中的方法
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。
chooseEngineClientAlias(String[], Principal[], SSLEngine) - 类 javax.net.ssl.X509ExtendedKeyManager 中的方法
选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。
chooseEngineServerAlias(String, Principal[], SSLEngine) - 类 javax.net.ssl.X509ExtendedKeyManager 中的方法
选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。
chooser - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的变量
在其上安装此 BasicColorChooserUI 的 JColorChooser。
CHOOSER_PANELS_PROPERTY - 类 javax.swing.JColorChooser 中的静态变量
chooserPanel 数组属性名。
chooseServerAlias(String, Principal[], Socket) - 接口 javax.net.ssl.X509KeyManager 中的方法
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。
CHORD - 类 java.awt.geom.Arc2D 中的静态变量
闭合类型，用于通过从弧段的起始点到弧段的结束点画一条直线来闭合的弧。
CHOU_1 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #1 信封尺寸，142 mm × 332 mm。
CHOU_2 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #2 信封尺寸，119 mm × 277 mm。
CHOU_3 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #3 信封尺寸，120 mm by 235 mm。
CHOU_30 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #30 信封尺寸，92 mm by 235 mm。
CHOU_4 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #4 信封尺寸，90 mm × 205 mm。
CHOU_40 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #40 信封尺寸，90 mm × 225 mm。
Chromaticity - javax.print.attribute.standard 中的 类
Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
Chromaticity(int) - 类 javax.print.attribute.standard.Chromaticity 的构造方法
构造具有给定整数值的新色度枚举值。
chunkLength - 类 java.net.HttpURLConnection 中的变量
使用存储块编码流模式进行输出时的存储块长度。
Cipher - javax.crypto 中的 类
此类为加密和解密提供密码功能。
Cipher(CipherSpi, Provider, String) - 类 javax.crypto.Cipher 的构造方法
创建 Cipher 对象。
CipherInputStream - javax.crypto 中的 类
CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。
CipherInputStream(InputStream, Cipher) - 类 javax.crypto.CipherInputStream 的构造方法
根据 InputStream 和 Cipher 构造 CipherInputStream。
CipherInputStream(InputStream) - 类 javax.crypto.CipherInputStream 的构造方法
根据 InputStream 构造 CipherInputStream，不指定 Cipher。
CipherOutputStream - javax.crypto 中的 类
CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。
CipherOutputStream(OutputStream, Cipher) - 类 javax.crypto.CipherOutputStream 的构造方法
从 OutputStream 和 Cipher 构造 CipherOutputStream。
CipherOutputStream(OutputStream) - 类 javax.crypto.CipherOutputStream 的构造方法
从 OutputStream 构造 CipherOutputStream，不指定 Cipher。
CipherSpi - javax.crypto 中的 类
此类为 Cipher 类定义了服务提供者接口 (SPI)。
CipherSpi() - 类 javax.crypto.CipherSpi 的构造方法
CITE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
CJK_COMPATIBILITY - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Compatibility”Unicode 字符块的常量。
CJK_COMPATIBILITY_FORMS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Compatibility Forms”Unicode 字符块的常量。
CJK_COMPATIBILITY_IDEOGRAPHS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Compatibility Ideographs”Unicode 字符块的常量。
CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Compatibility Ideographs Supplement”Unicode 字符块的常量。
CJK_RADICALS_SUPPLEMENT - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Radicals Supplement”Unicode 字符块的常量。
CJK_SYMBOLS_AND_PUNCTUATION - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Symbols and Punctuation”Unicode 字符块的常量。
CJK_UNIFIED_IDEOGRAPHS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Unified Ideographs”Unicode 字符块的常量。
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Unified Ideographs Extension A”Unicode 字符块的常量。
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Unified Ideographs Extension B”Unicode 字符块的常量。
Class<T> - java.lang 中的 类
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
CLASS - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
CLASS_ABSTRACT - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是抽象。
CLASS_ATTRIBUTE_PFX - 接口 java.util.jar.Pack200.Packer 中的静态变量
当与类属性名称连在一起时，使用 JSR 200 规范中指定的布局语言指出该属性的格式。
CLASS_COLORSPACECONVERSION - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是颜色空间变换。
CLASS_DEVICELINK - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是设备链接。
CLASS_DISPLAY - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是显示。
CLASS_INPUT - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是输入。
CLASS_LOADING_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
ClassLoadingMXBean 的 ObjectName 的字符串表示形式。
CLASS_NAMEDCOLOR - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是指定的颜色。
CLASS_OUTPUT - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是输出。
CLASS_PATH - 类 java.util.jar.Attributes.Name 中的静态变量
Class-Path 的 Name 对象具有的属性。
classattr() - 类 javax.management.Query 中的静态方法
返回一个新的类属性表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
ClassCastException - java.lang 中的 异常
当试图将对象强制转换为不是实例的子类时，抛出该异常。
ClassCastException() - 异常 java.lang.ClassCastException 的构造方法
构造不带详细消息的 ClassCastException。
ClassCastException(String) - 异常 java.lang.ClassCastException 的构造方法
构造带指定详细消息的 ClassCastException。
ClassCircularityError - java.lang 中的 错误
当初始化类时检测到类的循环调用的时候，抛出该错误。
ClassCircularityError() - 错误 java.lang.ClassCircularityError 的构造方法
构造不带详细消息的 ClassCircularityError。
ClassCircularityError(String) - 错误 java.lang.ClassCircularityError 的构造方法
构造带指定详细消息的 ClassCircularityError。
ClassDefinition - java.lang.instrument 中的 类
此类用作 Instrumentation.redefineClasses 方法的参数锁定。
ClassDefinition(Class<?>, byte[]) - 类 java.lang.instrument.ClassDefinition 的构造方法
使用提供的类和类文件字节创建一个新的 ClassDefinition 绑定。
classDepth(String) - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
ClassDesc - javax.rmi.CORBA 中的 类
此类用于对 IIOP 上的 java.lang.Class 对象进行编组。
ClassDesc() - 类 javax.rmi.CORBA.ClassDesc 的构造方法
classEquals(Class, Class) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
测试以查看两个类对象或其名称是否相等。
classFactory - 类 javax.naming.Reference 中的变量
包含用来创建此 Reference 所引用的对象实例的工厂类名称。
classFactoryLocation - 类 javax.naming.Reference 中的变量
包含工厂类的位置。
ClassFileTransformer - java.lang.instrument 中的 接口
一个提供此接口的实现以转换类文件的代理。
ClassFormatError - java.lang 中的 错误
当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
ClassFormatError() - 错误 java.lang.ClassFormatError 的构造方法
构造不带详细消息的 ClassFormatError。
ClassFormatError(String) - 错误 java.lang.ClassFormatError 的构造方法
构造带指定详细消息的 ClassFormatError。
CLASSID - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ClassLoader - java.lang 中的 类
类加载器是负责加载类的对象。
ClassLoader(ClassLoader) - 类 java.lang.ClassLoader 的构造方法
使用指定的、用于委托操作的父类加载器创建新的类加载器。
ClassLoader() - 类 java.lang.ClassLoader 的构造方法
使用方法 getSystemClassLoader() 返回的 ClassLoader 创建一个新的类加载器，将该加载器作为父类加载器。
classLoaderDepth() - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
ClassLoaderRepository - javax.management.loading 中的 接口
此接口的实例用于保持在 MBean Server 中注册的 ClassLoader 的列表。
ClassLoadingMXBean - java.lang.management 中的 接口
用于 Java 虚拟机的类加载系统的管理接口。
classname - 异常 java.io.InvalidClassException 中的变量
无效类的名称。
className - 类 javax.naming.Reference 中的变量
包含此 Reference 所引用的对象类的完全限定名称。
ClassNotFoundException - java.lang 中的 异常
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
ClassNotFoundException() - 异常 java.lang.ClassNotFoundException 的构造方法
构造不带详细消息的 ClassNotFoundException。
ClassNotFoundException(String) - 异常 java.lang.ClassNotFoundException 的构造方法
构造带指定详细消息的 ClassNotFoundException。
ClassNotFoundException(String, Throwable) - 异常 java.lang.ClassNotFoundException 的构造方法
构造一个 ClassNotFoundException，它带有指定详细消息和加载类时引发的可选异常。
clean(ObjID[], long, VMID, boolean) - 接口 java.rmi.dgc.DGC 中的方法
洁调用从 'ids' 指示的每个远程对象的引用列表中移除 'vmid'。
CLEAR - 类 java.awt.AlphaComposite 中的静态变量
目标色和目标 alpha 值都被清除（Porter-Duff Clear 规则）。
Clear - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 CLEAR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
clear() - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 removeAll() 取代。
clear() - 类 java.awt.RenderingHints 中的方法
清除所有键/值对的 RenderingHints 对象。
clear() - 类 java.beans.beancontext.BeanContextSupport 中的方法
清除子对象（不受支持的）实现，这些实现在分层结构锁定和 "children" 受保护字段上必须是同步的
clear() - 类 java.lang.ref.Reference 中的方法
清除此引用对象。
clear() - 类 java.nio.Buffer 中的方法
清除此缓冲区。
clear() - 类 java.security.Provider 中的方法
清除此 provider，使其不再包含用来查找由该 provider 实现的设施的属性。
clear() - 类 java.util.AbstractCollection 中的方法
移除此 collection 中的所有元素（可选操作）。
clear() - 类 java.util.AbstractList 中的方法
从此列表中移除所有元素（可选操作）。
clear() - 类 java.util.AbstractMap 中的方法
从此映射中移除所有映射关系（可选操作）。
clear() - 类 java.util.AbstractQueue 中的方法
移除此队列中的所有元素。
clear() - 类 java.util.ArrayDeque 中的方法
从此双端队列中移除所有元素。
clear() - 类 java.util.ArrayList 中的方法
移除此列表中的所有元素。
clear(int) - 类 java.util.BitSet 中的方法
将索引指定处的位设置为 false。
clear(int, int) - 类 java.util.BitSet 中的方法
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为 false。
clear() - 类 java.util.BitSet 中的方法
将此 BitSet 中的所有位设置为 false。
clear() - 类 java.util.Calendar 中的方法
将此 Calendar 的所日历字段值和时间值（从历元至现在的毫秒偏移量）设置成未定义。
clear(int) - 类 java.util.Calendar 中的方法
将此 Calendar 的给定日历字段值和时间值（从历元至现在的毫秒偏移量）设置成未定义。
clear() - 接口 java.util.Collection 中的方法
移除此 collection 中的所有元素（可选操作）。
clear() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
自动移除此队列中的所有元素。
clear() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
从该映射中移除所有映射关系
clear() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
从此映射中移除所有映射关系。
clear() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
从此 set 中移除所有元素。
clear() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
从此列表移除所有元素。
clear() - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
移除此 set 中的所有元素。
clear() - 类 java.util.concurrent.DelayQueue 中的方法
自动移除此延迟队列的所有元素。
clear() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
以原子方式 (atomically) 从此双端队列移除所有元素。
clear() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
从队列彻底移除所有元素。
clear() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
完全移除此队列中的所有元素。
clear() - 类 java.util.concurrent.SynchronousQueue 中的方法
不执行任何操作。
clear() - 类 java.util.EnumMap 中的方法
从此映射中移除所有映射关系。
clear() - 类 java.util.HashMap 中的方法
从此映射中移除所有映射关系。
clear() - 类 java.util.HashSet 中的方法
从此 set 中移除所有元素。
clear() - 类 java.util.Hashtable 中的方法
将此哈希表清空，使其不包含任何键。
clear() - 类 java.util.IdentityHashMap 中的方法
从映射中移除所有映射关系。
clear() - 类 java.util.jar.Attributes 中的方法
从此 Map 中移除所有属性。
clear() - 类 java.util.jar.Manifest 中的方法
清除此 Manifest 中的主 Attributes 和条目。
clear() - 类 java.util.LinkedHashMap 中的方法
从该映射中移除所有映射关系。
clear() - 类 java.util.LinkedList 中的方法
从此列表中移除所有元素。
clear() - 接口 java.util.List 中的方法
从列表中移除所有元素（可选操作）。
clear() - 接口 java.util.Map 中的方法
从此映射中移除所有映射关系（可选操作）。
clear() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.clear() 中的规范实现 clear 方法。
clear() - 类 java.util.prefs.Preferences 中的方法
移除此首选项节点中的所有首选项（键-值关联）。
clear() - 类 java.util.PriorityQueue 中的方法
从此优先级队列中移除所有元素。
clear() - 接口 java.util.Set 中的方法
移除此 set 中的所有元素（可选操作）。
clear() - 类 java.util.TreeMap 中的方法
从此映射中移除所有映射关系。
clear() - 类 java.util.TreeSet 中的方法
移除此 set 中的所有元素。
clear() - 类 java.util.Vector 中的方法
从此向量中移除所有元素。
clear() - 类 java.util.WeakHashMap 中的方法
从此映射中移除所有映射关系。
clear() - 类 javax.accessibility.AccessibleRelationSet 中的方法
从当前关系集中移除所有关系。
clear() - 类 javax.accessibility.AccessibleStateSet 中的方法
从当前状态集中移除所有状态。
clear() - 接口 javax.management.openmbean.TabularData 中的方法
从此 TabularData 实例中移除所有 CompositeData 值（即各行）。
clear() - 类 javax.management.openmbean.TabularDataSupport 中的方法
从此 TabularDataSupport 实例中移除所有行。
clear() - 接口 javax.naming.directory.Attribute 中的方法
从此属性移除所有值。
clear() - 类 javax.naming.directory.BasicAttribute 中的方法
clear() - 类 javax.naming.Reference 中的方法
从此引用中删除所有地址。
clear() - 接口 javax.print.attribute.AttributeSet 中的方法
从此属性集中移除所有属性。
clear() - 类 javax.print.attribute.HashAttributeSet 中的方法
从此属性集中移除所有属性。
clear() - 类 javax.script.SimpleBindings 中的方法
从此映射中移除所有映射关系（可选操作）。
clear() - 类 javax.swing.ActionMap 中的方法
从此 ActionMap 中移除所有映射关系。
clear() - 类 javax.swing.ComponentInputMap 中的方法
从此对象中移除所有映射关系。
clear() - 类 javax.swing.DefaultListModel 中的方法
从此列表中移除所有元素。
clear() - 类 javax.swing.InputMap 中的方法
从此 InputMap 中移除所有映射关系。
CLEAR - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
CLEAR - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
clear() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
取消设置所有未定义的字段。
clear() - 类 org.omg.CORBA.Environment 中的方法
清除此 Environment 对象中的异常。
clear() - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 清除属性列表。
clear() - 类 org.xml.sax.helpers.AttributesImpl 中的方法
为了重用而清除属性列表。
clearAbortRequest() - 类 javax.imageio.ImageReader 中的方法
清除任何以前的中止请求。
clearAbortRequest() - 类 javax.imageio.ImageWriter 中的方法
清除任何以前的中止请求。
clearAccessibleSelection() - 类 java.awt.List.AccessibleAWTList 中的方法
清除对象中的选择，从而对象中没有选择任何项。
clearAccessibleSelection() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
清除该对象中的选择，使该对象中没有子对象被选择。
clearAccessibleSelection() - 接口 javax.accessibility.AccessibleSelection 中的方法
清除对象中的选项，使该对象中没有选中的子对象。
clearAccessibleSelection() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
清除对象中的选择，使对象中任何子对象都未被选中。
clearAccessibleSelection() - 类 javax.swing.JList.AccessibleJList 中的方法
清除对象中的选择，从而对象中没有选择任何项。
clearAccessibleSelection() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
清除对象中的选择，从而对象中没有选择任何项。
clearAccessibleSelection() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
清除对象中的选择，从而对象中没有选择任何项。
clearAccessibleSelection() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
clearAccessibleSelection() - 类 javax.swing.JTable.AccessibleJTable 中的方法
清除该对象中的选择，使该对象中不存在选择的子对象。
clearAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
清除对象中的选择，这样此对象中什么也没有选择。
clearAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree 中的方法
清除对象中的选择，这样此对象中什么也没有选择。
clearAssertionStatus() - 类 java.lang.ClassLoader 中的方法
将此类加载器的默认断言状态设置为 false，并放弃与此类加载器关联的所有默认包或类断言状态设置。
clearAutoscroll() - 类 java.awt.dnd.DropTarget 中的方法
清除自动滚动
clearBatch() - 接口 java.sql.Statement 中的方法
清空此 Statement 对象的当前 SQL 命令列表。
clearBit(int) - 类 java.math.BigInteger 中的方法
返回其值与清除了指定位的此 BigInteger 等效的 BigInteger。
clearCache() - 类 java.util.ResourceBundle 中的静态方法
从已经使用调用者的类加载器加载的缓存中移除所有资源包。
clearCache(ClassLoader) - 类 java.util.ResourceBundle 中的静态方法
从已经使用给定类加载器加载的缓存中移除所有资源包。
clearChanged() - 类 java.util.Observable 中的方法
指示对象不再改变，或者它已对其所有的观察者通知了最近的改变，所以 hasChanged 方法将返回 false。
clearContent() - 类 javax.xml.soap.AttachmentPart 中的方法
清除此 AttachmentPart 对象的内容。
clearError() - 类 java.io.PrintStream 中的方法
清除此流的内部错误状态。
clearError() - 类 java.io.PrintWriter 中的方法
清除此流的错误状态。
clearGlobalFocusOwner() - 类 java.awt.KeyboardFocusManager 中的方法
在 Java 和本机级别清除全局焦点所有者。
clearIconCache() - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法
clearIconCache() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
clearParameters() - 接口 java.sql.PreparedStatement 中的方法
立即清除当前参数值。
clearParameters() - 类 javax.sql.rowset.BaseRowSet 中的方法
清除所有此 RowSet 对象的内部参数表示形式的当前参数值，这些参数值将在执行此 RowSet 对象的命令时在其中设置这些参数。
clearParameters() - 接口 javax.sql.RowSet 中的方法
清除为此 RowSet 对象命令设置的参数。
clearParameters() - 类 javax.xml.transform.Transformer 中的方法
清除所有通过 setParameter 设置的参数。
clearPassword() - 类 javax.crypto.spec.PBEKeySpec 中的方法
清空密码的内部副本。
clearPassword() - 类 javax.security.auth.callback.PasswordCallback 中的方法
清除获取到的密码。
clearProperty(String) - 类 java.lang.System 中的静态方法
移除指定键指示的系统属性。
clearRect(int, int, int, int) - 类 java.awt.Graphics 中的方法
通过使用当前绘图表面的背景色进行填充来清除指定的矩形。
clearRect(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.clearRect。
clearSelectedPath() - 类 javax.swing.MenuSelectionManager 中的方法
告知菜单选项，以关闭和取消选择所有菜单组件。
clearSelection() - 类 javax.swing.ButtonGroup 中的方法
清除选中内容，从而没有选择 ButtonGroup 中的任何按钮。
clearSelection() - 类 javax.swing.DefaultListSelectionModel 中的方法
将该选择更改为空集。
clearSelection() - 类 javax.swing.DefaultSingleSelectionModel 中的方法
clearSelection() - 类 javax.swing.JList 中的方法
清除选择；调用此方法后，isSelectionEmpty 将返回 true。
clearSelection() - 类 javax.swing.JTable 中的方法
取消选中所有已选定的行和列。
clearSelection() - 类 javax.swing.JTree 中的方法
清除该选择。
clearSelection() - 接口 javax.swing.ListSelectionModel 中的方法
将该选择更改为空集。
clearSelection() - 接口 javax.swing.SingleSelectionModel 中的方法
清除选项（返回 -1）。
clearSelection() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
清空当前的 selection。
clearSelection() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
清空当前的选择。
clearTextShiftOffset() - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
clearToggledPaths() - 类 javax.swing.JTree 中的方法
清除切换的树路径的缓存。
clearWarnings() - 接口 java.sql.Connection 中的方法
清除为此 Connection 对象报告的所有警告。
clearWarnings() - 接口 java.sql.ResultSet 中的方法
清除在此 ResultSet 对象上报告的所有警告。
clearWarnings() - 接口 java.sql.Statement 中的方法
清除在此 Statement 对象上报告的所有警告。
CLICK - 接口 javax.accessibility.AccessibleAction 中的静态变量
导致某个组件执行其默认动作的动作。
clickCount - 类 java.awt.Event 中的变量
对于 MOUSE_DOWN 事件来说，此字段指示连续点击的次数。
clickCountToStart - 类 javax.swing.DefaultCellEditor 中的变量
指定开始编辑所需单击次数的整数。
clientClosed(RMIConnection) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
关闭由 makeClient 创建的客户端连接时调用的方法。
ClientInfoStatus - java.sql 中的 枚举
无法通过调用 Connection.setClientInfo 设置属性的原因状态的枚举。
ClientRequestInfo - org.omg.PortableInterceptor 中的 接口
客户端请求 interceptor 可访问的请求信息。
ClientRequestInfoOperations - org.omg.PortableInterceptor 中的 接口
客户端请求 interceptor 可访问的请求信息。
ClientRequestInterceptor - org.omg.PortableInterceptor 中的 接口
客户端 interceptor。
ClientRequestInterceptorOperations - org.omg.PortableInterceptor 中的 接口
客户端的请求 interceptor。
clip(Shape) - 类 java.awt.Graphics2D 中的方法
将当前 Clip 与指定 Shape 的内部区域相交，并将 Clip 设置为所得的交集。
Clip - javax.sound.sampled 中的 接口
Clip 接口表示特殊种类的数据行，该数据行的音频数据可以在回放前加载，而不是实时流出。
Clipboard - java.awt.datatransfer 中的 类
此类实现一种使用剪切/复制/粘贴操作传输数据的机制。
Clipboard(String) - 类 java.awt.datatransfer.Clipboard 的构造方法
创建剪贴板对象。
ClipboardOwner - java.awt.datatransfer 中的 接口
为提供数据到剪贴板的类所定义的接口。
clipRect(int, int, int, int) - 类 java.awt.Graphics 中的方法
将当前剪贴区与指定的矩形相交。
clipRect(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.clipRect。
Clob - java.sql 中的 接口
SQL 类型 CLOB 在 JavaTM 编程语言中的映射关系。
CLOB - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 CLOB 的 Java 编程语言中的常量（有时称为类型代码）。
clockSequence() - 类 java.util.UUID 中的方法
与此 UUID 相关联的时钟序列值。
clone() - 类 java.awt.BufferCapabilities 中的方法
clone() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的副本。
clone() - 类 java.awt.font.TextLayout 中的方法
创建此 TextLayout 的副本。
clone() - 类 java.awt.font.TextMeasurer 中的方法
clone() - 类 java.awt.geom.AffineTransform 中的方法
返回此 AffineTransform 对象的副本。
clone() - 类 java.awt.geom.Area 中的方法
返回此 Area 对象的精确副本。
clone() - 类 java.awt.geom.CubicCurve2D 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Dimension2D 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Line2D 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Path2D 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Path2D.Double 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Path2D.Float 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Point2D 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 java.awt.geom.QuadCurve2D 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 java.awt.geom.RectangularShape 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 java.awt.GridBagConstraints 中的方法
创建此网格包约束（grid bag constraint）的副本。
clone() - 类 java.awt.image.ImageFilter 中的方法
复制此对象。
clone() - 类 java.awt.image.Kernel 中的方法
复制此对象。
clone() - 类 java.awt.image.renderable.ParameterBlock 中的方法
创建 ParameterBlock 的一个副本。
clone() - 类 java.awt.image.renderable.RenderContext 中的方法
对 RenderContext 进行复制。
clone() - 类 java.awt.ImageCapabilities 中的方法
clone() - 类 java.awt.Insets 中的方法
创建此对象的副本。
clone() - 类 java.awt.JobAttributes 中的方法
创建并返回此 JobAttributes 的一个副本。
clone() - 类 java.awt.PageAttributes 中的方法
创建并返回此 PageAttributes 的一个副本。
clone() - 类 java.awt.print.PageFormat 中的方法
制作此 PageFormat 的副本，使它与此 PageFormat 具有相同的内容。
clone() - 类 java.awt.print.Paper 中的方法
创建此 Paper 的一个副本，内容与此 Paper 相同。
clone() - 类 java.awt.RenderingHints 中的方法
创建此 RenderingHints 对象的一个副本，它与此 RenderingHints 对象具有相同的内容。
clone() - 类 java.lang.Enum 中的方法
抛出 CloneNotSupportedException。
clone() - 类 java.lang.Object 中的方法
创建并返回此对象的一个副本。
clone() - 类 java.net.HttpCookie 中的方法
创建并返回此对象的一个副本。
clone() - 类 java.rmi.server.UnicastRemoteObject 中的方法
返回与初始对象不同的远程对象的副本。
clone() - 接口 java.security.acl.AclEntry 中的方法
复制此 ACL 项。
clone() - 接口 java.security.cert.CertPathBuilderResult 中的方法
对此 CertPathBuilderResult 进行复制。
clone() - 接口 java.security.cert.CertPathParameters 中的方法
对此 CertPathParameters 进行复制。
clone() - 接口 java.security.cert.CertPathValidatorResult 中的方法
对此 CertPathValidatorResult 进行复制。
clone() - 接口 java.security.cert.CertSelector 中的方法
对此 CertSelector 进行复制。
clone() - 接口 java.security.cert.CertStoreParameters 中的方法
对此 CertStoreParameters 进行复制。
clone() - 类 java.security.cert.CollectionCertStoreParameters 中的方法
返回此对象的副本。
clone() - 接口 java.security.cert.CRLSelector 中的方法
对此 CRLSelector 进行复制。
clone() - 类 java.security.cert.LDAPCertStoreParameters 中的方法
返回此对象的副本。
clone() - 类 java.security.cert.PKIXCertPathChecker 中的方法
返回此对象的副本。
clone() - 类 java.security.cert.PKIXCertPathValidatorResult 中的方法
返回此对象的副本。
clone() - 类 java.security.cert.PKIXParameters 中的方法
对此 PKIXParameters 对象进行复制。
clone() - 类 java.security.cert.X509CertSelector 中的方法
返回此对象的副本。
clone() - 类 java.security.cert.X509CRLSelector 中的方法
返回此对象的副本。
clone() - 类 java.security.MessageDigest 中的方法
如果实现是可复制的，则返回一个副本。
clone() - 类 java.security.MessageDigestSpi 中的方法
如果实现是可复制的，则返回一个副本。
clone() - 类 java.security.Signature 中的方法
如果此实现可以复制，则返回副本。
clone() - 类 java.security.SignatureSpi 中的方法
如果此实现可以复制，则返回一个副本。
clone() - 类 java.text.BreakIterator 中的方法
创建此迭代器的副本。
clone() - 接口 java.text.CharacterIterator 中的方法
创建此迭代器的一个副本
clone() - 类 java.text.ChoiceFormat 中的方法
重写 Cloneable
clone() - 类 java.text.Collator 中的方法
重写 Cloneable
clone() - 类 java.text.DateFormat 中的方法
重写 Cloneable
clone() - 类 java.text.DateFormatSymbols 中的方法
重写 Cloneable。
clone() - 类 java.text.DecimalFormat 中的方法
标准重写；没有语义上的变化。
clone() - 类 java.text.DecimalFormatSymbols 中的方法
标准重写。
clone() - 类 java.text.Format 中的方法
创建并返回此对象的一个副本。
clone() - 类 java.text.MessageFormat 中的方法
创建并返回此对象的一个副本。
clone() - 类 java.text.NumberFormat 中的方法
重写 Cloneable
clone() - 类 java.text.RuleBasedCollator 中的方法
标准重写，无语义变化。
clone() - 类 java.text.SimpleDateFormat 中的方法
创建此 SimpleDateFormat 的一个副本。
clone() - 类 java.text.StringCharacterIterator 中的方法
创建此迭代器的副本。
clone() - 类 java.util.AbstractMap 中的方法
返回此 AbstractMap 实例的浅表副本：不复制键和值本身。
clone() - 类 java.util.ArrayDeque 中的方法
返回此双端队列的副本。
clone() - 类 java.util.ArrayList 中的方法
返回此 ArrayList 实例的浅表副本。
clone() - 类 java.util.BitSet 中的方法
复制此 BitSet，生成一个与之相等的新 BitSet。
clone() - 类 java.util.Calendar 中的方法
创建并返回此对象的一个副本。
clone() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回此 ConcurrentSkipListMap 实例的浅表副本。
clone() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
返回此 ConcurrentSkipListSet 实例的浅表副本。
clone() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表的浅表副本。
clone() - 类 java.util.Date 中的方法
返回此对象的副本。
clone() - 类 java.util.EnumMap 中的方法
返回此枚举映射的浅表副本。
clone() - 类 java.util.EnumSet 中的方法
返回 set 的副本。
clone() - 类 java.util.GregorianCalendar 中的方法
clone() - 类 java.util.HashMap 中的方法
返回此 HashMap 实例的浅表副本：并不复制键和值本身。
clone() - 类 java.util.HashSet 中的方法
返回此 HashSet 实例的浅表副本：并没有复制这些元素本身。
clone() - 类 java.util.Hashtable 中的方法
创建此哈希表的浅表副本。
clone() - 类 java.util.IdentityHashMap 中的方法
返回此标识哈希映射的浅表副本：不复制键和值本身。
clone() - 类 java.util.jar.Attributes 中的方法
返回 Attributes 的副本，实现方法如下: public Object clone() { return new Attributes(this); } 由于属性名称和值本身不可变，因此可以安全地修改返回的 Attributes，而不会影响原始值。
clone() - 类 java.util.jar.Manifest 中的方法
返回 Manifest 的浅表副本。
clone() - 类 java.util.LinkedList 中的方法
返回此 LinkedList 的浅表副本。
clone() - 类 java.util.Locale 中的方法
重写 Cloneable。
clone() - 类 java.util.SimpleTimeZone 中的方法
返回此 SimpleTimeZone 实例的一个副本。
clone() - 类 java.util.TimeZone 中的方法
创建此 TimeZone 的一个副本。
clone() - 类 java.util.TreeMap 中的方法
返回此 TreeMap 实例的浅表副本。
clone() - 类 java.util.TreeSet 中的方法
返回 TreeSet 实例的浅表副本。
clone() - 类 java.util.Vector 中的方法
返回向量的一个副本。
clone() - 类 java.util.zip.ZipEntry 中的方法
返回此条目的副本。
clone() - 类 javax.crypto.Mac 中的方法
如果提供者实现可以复制，则返回一个副本。
clone() - 类 javax.crypto.MacSpi 中的方法
如果此实现可以复制，则返回一个副本。
clone() - 接口 javax.management.Descriptor 中的方法
返回一个与此描述符相等的描述符。
clone() - 类 javax.management.ImmutableDescriptor 中的方法
返回一个与此描述符相等的描述符。
clone() - 类 javax.management.MBeanAttributeInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.MBeanConstructorInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.MBeanInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.MBeanNotificationInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.MBeanOperationInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.MBeanParameterInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.modelmbean.DescriptorSupport 中的方法
返回作为 Descriptor 副本的新 Descriptor。
clone() - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 中的方法
创建并返回新的 ModelMBeanAttributeInfo，它是此 ModelMBeanAttributeInfo 的副本。
clone() - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 中的方法
创建并返回新 ModelMBeanConstructorInfo，它是此 ModelMBeanConstructorInfo 的副本。
clone() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
创建并返回此对象的一个副本。
clone() - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
返回此实例的浅表复制。
clone() - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 中的方法
创建并返回新 ModelMBeanNotificationInfo，它是此 ModelMBeanNotificationInfo 的副本。
clone() - 类 javax.management.modelmbean.ModelMBeanOperationInfo 中的方法
创建并返回新的 ModelMBeanOperationInfo，它是此 ModelMBeanOperationInfo 的副本。
clone() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularDataSupport 实例的一个副本：通过调用 super.clone()，然后副本此基础映射，即可得到该副本。
clone() - 类 javax.management.relation.Role 中的方法
复制角色对象。
clone() - 类 javax.management.relation.RoleUnresolved 中的方法
复制此对象。
clone() - 类 javax.naming.CompositeName 中的方法
生成此复合名称的副本。
clone() - 类 javax.naming.CompoundName 中的方法
创建此组合名称的副本。
clone() - 接口 javax.naming.directory.Attribute 中的方法
对属性进行复制。
clone() - 接口 javax.naming.directory.Attributes 中的方法
对属性集进行复制。
clone() - 类 javax.naming.directory.BasicAttribute 中的方法
clone() - 类 javax.naming.directory.BasicAttributes 中的方法
clone() - 类 javax.naming.ldap.LdapName 中的方法
生成此名称的新副本。
clone() - 接口 javax.naming.Name 中的方法
生成此名称的新副本。
clone() - 类 javax.naming.Reference 中的方法
使用地址的类名称列表、类工厂名称和类工厂位置创建此引用的副本。
clone() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的一个副本，该副本保留了枚举值的语义，它是与此枚举值相同的对象。
clone() - 类 javax.sound.midi.MetaMessage 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 javax.sound.midi.MidiMessage 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 javax.sound.midi.ShortMessage 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 javax.sound.midi.SysexMessage 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 javax.swing.AbstractAction 中的方法
复制抽象操作。
clone() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回此选择模型的具有相同选择的副本。
clone() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
复制 AbstractFormatter。
clone() - 类 javax.swing.text.DefaultFormatter 中的方法
创建此 DefaultFormatter 的副本。
clone(Element, Element) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
创建此元素的一个副本，使其具有不同的父级。
clone() - 类 javax.swing.text.EditorKit 中的方法
创建此编辑器工具包的副本。
clone() - 类 javax.swing.text.ElementIterator 中的方法
复制 ElementIterator。
clone() - 类 javax.swing.text.GlyphView 中的方法
创建一个浅表复制。
clone() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
创建编辑器工具包的一个副本。
clone() - 类 javax.swing.text.InternationalFormatter 中的方法
创建该 DefaultFormatter 的一个副本。
clone() - 类 javax.swing.text.Segment 中的方法
创建一个浅表副本。
clone() - 类 javax.swing.text.SimpleAttributeSet 中的方法
复制属性集。
clone() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
复制属性集。
clone() - 类 javax.swing.text.StyledEditorKit 中的方法
创建此编辑器工具包的一个副本。
clone() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
重写以复制 public。
clone() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回具有相同 selection 的此对象的副本。
clone() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
创建并返回此对象的一个副本。
Cloneable - java.lang 中的 接口
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
cloneNode(boolean) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回此节点的副本。
cloneNode(boolean) - 接口 org.w3c.dom.Node 中的方法
返回此节点的副本，即允当节点的一般复制构造方法。
CloneNotSupportedException - java.lang 中的 异常
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
CloneNotSupportedException() - 异常 java.lang.CloneNotSupportedException 的构造方法
构造不带详细消息的 CloneNotSupportedException。
CloneNotSupportedException(String) - 异常 java.lang.CloneNotSupportedException 的构造方法
构造带指定详细消息的 CloneNotSupportedException。
cloneWithSource(Object) - 类 javax.swing.event.TreeSelectionEvent 中的方法
返回接收方的副本，但带有将成为 newSource 的源。
closable - 类 javax.swing.JInternalFrame 中的变量
窗体可关闭。
close() - 类 java.awt.SplashScreen 中的方法
隐藏闪现屏幕、关闭窗口并释放所有相关资源。
close() - 类 java.beans.XMLDecoder 中的方法
此方法关闭与此流相关联的输入流。
close() - 类 java.beans.XMLEncoder 中的方法
此方法调用 flush，写入结束后文，然后关闭与此流有关的输出流。
close() - 类 java.io.BufferedInputStream 中的方法
关闭此输入流并释放与该流关联的所有系统资源。
close() - 类 java.io.BufferedReader 中的方法
close() - 类 java.io.BufferedWriter 中的方法
close() - 类 java.io.ByteArrayInputStream 中的方法
关闭 ByteArrayInputStream 无效。
close() - 类 java.io.ByteArrayOutputStream 中的方法
关闭 ByteArrayOutputStream 无效。
close() - 类 java.io.CharArrayReader 中的方法
关闭该流并释放与之关联的所有系统资源。
close() - 类 java.io.CharArrayWriter 中的方法
关闭该流。
close() - 接口 java.io.Closeable 中的方法
关闭此流并释放与此流关联的所有系统资源。
close() - 类 java.io.FileInputStream 中的方法
关闭此文件输入流并释放与此流有关的所有系统资源。
close() - 类 java.io.FileOutputStream 中的方法
关闭此文件输出流并释放与此流有关的所有系统资源。
close() - 类 java.io.FilterInputStream 中的方法
关闭此输入流并释放与此流关联的所有系统资源。
close() - 类 java.io.FilterOutputStream 中的方法
关闭此输出流并释放与此流有关的所有系统资源。
close() - 类 java.io.FilterReader 中的方法
close() - 类 java.io.FilterWriter 中的方法
close() - 类 java.io.InputStream 中的方法
关闭此输入流并释放与该流关联的所有系统资源。
close() - 类 java.io.InputStreamReader 中的方法
close() - 接口 java.io.ObjectInput 中的方法
关闭输入流。
close() - 类 java.io.ObjectInputStream 中的方法
关闭输入流。
close() - 接口 java.io.ObjectOutput 中的方法
关闭该流。
close() - 类 java.io.ObjectOutputStream 中的方法
关闭流。
close() - 类 java.io.OutputStream 中的方法
关闭此输出流并释放与此流有关的所有系统资源。
close() - 类 java.io.OutputStreamWriter 中的方法
close() - 类 java.io.PipedInputStream 中的方法
关闭此管道输入流并释放与该流相关的所有系统资源。
close() - 类 java.io.PipedOutputStream 中的方法
关闭此管道输出流并释放与此流有关的所有系统资源。
close() - 类 java.io.PipedReader 中的方法
关闭此传送流并释放与该流相关的所有系统资源。
close() - 类 java.io.PipedWriter 中的方法
关闭此管道输出流并释放与此流相关的所有系统资源。
close() - 类 java.io.PrintStream 中的方法
关闭流。
close() - 类 java.io.PrintWriter 中的方法
关闭该流并释放与之关联的所有系统资源。
close() - 类 java.io.PushbackInputStream 中的方法
关闭此输入流并释放与该流关联的所有系统资源。
close() - 类 java.io.PushbackReader 中的方法
关闭该流并释放与之关联的所有系统资源。
close() - 类 java.io.RandomAccessFile 中的方法
关闭此随机访问文件流并释放与该流关联的所有系统资源。
close() - 类 java.io.Reader 中的方法
关闭该流并释放与之关联的所有资源。
close() - 类 java.io.SequenceInputStream 中的方法
关闭此输入流并释放与此流关联的所有系统资源。
close() - 类 java.io.StringReader 中的方法
关闭该流并释放与之关联的所有系统资源。
close() - 类 java.io.StringWriter 中的方法
关闭 StringWriter 无效。
close() - 类 java.io.Writer 中的方法
关闭此流，但要先刷新它。
close() - 类 java.net.DatagramSocket 中的方法
关闭此数据报套接字。
close() - 类 java.net.DatagramSocketImpl 中的方法
关闭套接字。
close() - 类 java.net.ServerSocket 中的方法
关闭此套接字。
close() - 类 java.net.Socket 中的方法
关闭此套接字。
close() - 类 java.net.SocketImpl 中的方法
关闭此套接字。
close() - 接口 java.nio.channels.Channel 中的方法
关闭此通道。
close() - 接口 java.nio.channels.InterruptibleChannel 中的方法
关闭此通道。
close() - 类 java.nio.channels.Selector 中的方法
关闭此选择器。
close() - 类 java.nio.channels.spi.AbstractInterruptibleChannel 中的方法
关闭此通道。
close() - 类 java.nio.channels.spi.AbstractSelector 中的方法
关闭此选择器。
close() - 接口 java.sql.Connection 中的方法
立即释放此 Connection 对象的数据库和 JDBC 资源，而不是等待它们被自动释放。
close() - 接口 java.sql.ResultSet 中的方法
立即释放此 ResultSet 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。
close() - 接口 java.sql.Statement 中的方法
立即释放此 Statement 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。
close() - 类 java.util.Formatter 中的方法
关闭此 formatter。
close() - 类 java.util.logging.ConsoleHandler 中的方法
重写 StreamHandler.close 以进行刷新，但是不关闭输出流。
close() - 类 java.util.logging.FileHandler 中的方法
关闭所有文件。
close() - 类 java.util.logging.Handler 中的方法
关闭 Handler，并释放所有相关的资源。
close() - 类 java.util.logging.MemoryHandler 中的方法
关闭 Handler，并释放所有相关的资源。
close() - 类 java.util.logging.SocketHandler 中的方法
关闭此输出流。
close() - 类 java.util.logging.StreamHandler 中的方法
关闭当前输出流。
close() - 类 java.util.Scanner 中的方法
关闭此扫描器。
close() - 类 java.util.zip.DeflaterInputStream 中的方法
关闭此输入流和它的底层输入流，丢弃挂起的未压缩数据。
close() - 类 java.util.zip.DeflaterOutputStream 中的方法
将剩余压缩数据写入输出流并关闭底层流。
close() - 类 java.util.zip.GZIPInputStream 中的方法
关闭此输入流并释放与该流关联的所有系统资源。
close() - 类 java.util.zip.InflaterInputStream 中的方法
关闭此输入流并释放与该流关联的所有系统资源。
close() - 类 java.util.zip.InflaterOutputStream 中的方法
将剩余未压缩数据写入输出流并关闭底层输出流。
close() - 类 java.util.zip.ZipFile 中的方法
关闭 ZIP 文件。
close() - 类 java.util.zip.ZipInputStream 中的方法
关闭此输入流并释放与此流关联的所有系统资源。
close() - 类 java.util.zip.ZipOutputStream 中的方法
关闭 ZIP 输出流和正在过滤的流。
close() - 类 javax.crypto.CipherInputStream 中的方法
关闭该输入流并释放任何与该流关联的系统资源。
close() - 类 javax.crypto.CipherOutputStream 中的方法
关闭此输出流并释放任何与此流关联的系统资源。
close() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
关闭此 FileCacheImageInputStream，关闭并移除缓存文件。
close() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
关闭此 FileCacheImageOututStream。
close() - 类 javax.imageio.stream.FileImageInputStream 中的方法
close() - 类 javax.imageio.stream.FileImageOutputStream 中的方法
close() - 接口 javax.imageio.stream.ImageInputStream 中的方法
关闭流。
close() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
close() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
关闭此 MemoryCacheImageInputStream，释放缓存。
close() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
关闭此 MemoryCacheImageOutputStream。
close() - 接口 javax.management.remote.JMXConnector 中的方法
关闭客户端到其服务器的连接。
close() - 接口 javax.management.remote.rmi.RMIConnection 中的方法
关闭此连接。
close() - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
close() - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
close() - 类 javax.management.remote.rmi.RMIConnector 中的方法
close() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
关闭此连接服务器。
close() - 接口 javax.naming.Context 中的方法
关闭此上下文。
close() - 类 javax.naming.InitialContext 中的方法
close() - 类 javax.naming.ldap.StartTlsResponse 中的方法
妥善地关闭 TLS 连接并转换回底层连接。
close() - 接口 javax.naming.NamingEnumeration 中的方法
关闭此枚举。
close() - 接口 javax.sound.midi.MidiDevice 中的方法
关闭设备，指示设备现在应释放任何正在使用的系统资源。
close() - 接口 javax.sound.midi.Receiver 中的方法
指示应用程序已结束使用接收器，以及其请求的受限制资源可能已被释放或已可用。
close() - 接口 javax.sound.midi.Transmitter 中的方法
指示应用程序已结束使用传输器，以及其请求的受限制资源可能已被释放或已可用。
close() - 类 javax.sound.sampled.AudioInputStream 中的方法
关闭此音频输入流并释放与该流关联的所有系统资源。
close() - 接口 javax.sound.sampled.Line 中的方法
关闭行，指示可以释放的该行使用的所有系统资源。
CLOSE - 类 javax.sound.sampled.LineEvent.Type 中的静态变量
行关闭（释放该行在打开时获得的系统资源）时发送的事件类型。
close() - 接口 javax.sql.PooledConnection 中的方法
关闭此 PooledConnection 对象表示的物理连接。
close() - 类 javax.swing.ProgressMonitor 中的方法
指示操作已完成。
close() - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.close，以便关闭进度监视器以及流。
close() - 类 javax.tools.ForwardingJavaFileManager 中的方法
close() - 接口 javax.tools.JavaFileManager 中的方法
释放此文件管理器直接或间接打开的所有资源。
close() - 类 javax.xml.soap.SOAPConnection 中的方法
关闭此 SOAPConnection 对象。
close() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
close() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
close() - 接口 javax.xml.stream.XMLEventReader 中的方法
释放所有与此 Reader 关联的资源。
close() - 接口 javax.xml.stream.XMLEventWriter 中的方法
释放所有与此流关联的资源。
close() - 接口 javax.xml.stream.XMLStreamReader 中的方法
释放与此 Reader 关联的所有资源。
close() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
关闭此 writer 并释放与 writer 关联的所有资源。
close(MessageContext) - 接口 javax.xml.ws.handler.Handler 中的方法
消息交换模式结束时调用，正好发生在 JAX-WS 运行时指派消息、错误或异常之前。
CLOSE_ALL_RESULTS - 接口 java.sql.Statement 中的静态变量
该常量指示调用 getMoreResults 时应该关闭以前一直打开的所有 ResultSet 对象。
CLOSE_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
CLOSE_CURRENT_RESULT - 接口 java.sql.Statement 中的静态变量
该常量指示调用 getMoreResults 时应该关闭当前 ResultSet 对象。
CLOSE_CURSORS_AT_COMMIT - 接口 java.sql.ResultSet 中的静态变量
该常量指示提交当前事务时，具有此可保存性的打开的 ResultSet 对象将被关闭。
CLOSE_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
CLOSE_FAILURE 用于对输出流的关闭失败时。
Closeable - java.io 中的 接口
Closeable 是可以关闭的数据源或目标。
closeAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
closeButton - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
closeClient(RMIConnection) - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法
closeClient(RMIConnection) - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法
closeClient(RMIConnection) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
关闭由 makeClient 建立的客户端连接。
CLOSED - 类 javax.management.remote.JMXConnectionNotification 中的静态变量
关闭连接通知的通知类型字符串。
CLOSED_OPTION - 类 javax.swing.JOptionPane 中的静态变量
用户没有做出任何选择而关闭了窗口时从类方法返回的值，很可能将此值视为 CANCEL_OPTION 或 NO_OPTION。
ClosedByInterruptException - java.nio.channels 中的 异常
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
ClosedByInterruptException() - 异常 java.nio.channels.ClosedByInterruptException 的构造方法
构造此类的一个实例。
ClosedChannelException - java.nio.channels 中的 异常
当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
ClosedChannelException() - 异常 java.nio.channels.ClosedChannelException 的构造方法
构造此类的一个实例。
closedIcon - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
用于显示无扩展的非叶节点的图标。
ClosedSelectorException - java.nio.channels 中的 异常
试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
ClosedSelectorException() - 异常 java.nio.channels.ClosedSelectorException 的构造方法
构造此类的一个实例。
closeEntry() - 类 java.util.zip.ZipInputStream 中的方法
关闭当前 ZIP 条目并定位流以读取下一个条目。
closeEntry() - 类 java.util.zip.ZipOutputStream 中的方法
关闭当前 ZIP 条目并定位流以写入下一个条目。
closeFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
从父窗体中移除窗体，如有必要，还要移除 desktopIcon。
closeFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常，此调用应该从其父窗体中移除窗体。
closeFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
当用户要关闭窗体时调用此方法。
closeIcon - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
closeInbound() - 类 javax.net.ssl.SSLEngine 中的方法
通知没有更多的入站网络数据将发送到此 SSLEngine。
closeKey - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
已过时。 从 1.3 开始。
closeOutbound() - 类 javax.net.ssl.SSLEngine 中的方法
通知没有更多的出站应用程序数据将在此 SSLEngine 上发送。
closeOutUnwantedEmbeddedTags(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
搜索属性集和存储在标记向量中的每个标记。
closePath() - 类 java.awt.geom.Path2D 中的方法
通过绘制一条向后延伸到最后一个 moveTo 的坐标的直线，封闭当前子路径。
closeServer() - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法
由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。
closeServer() - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法
由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。
closeServer() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
由 RMIServerImpl.close() 调用以关闭连接器服务器。
CMMException - java.awt.color 中的 异常
如果本机 CMM 返回一个错误，则抛出此异常。
CMMException(String) - 异常 java.awt.color.CMMException 的构造方法
构造带指定详细消息的 CMMException。
coalesceEvents(AWTEvent, AWTEvent) - 类 java.awt.Component 中的方法
将正发送的事件与现有事件组合在一起。
CODE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
CODE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
code - 异常 org.w3c.dom.DOMException 中的变量
code - 异常 org.w3c.dom.events.EventException 中的变量
code - 异常 org.w3c.dom.ls.LSException 中的变量
CODE_ATTRIBUTE_PFX - 接口 java.util.jar.Pack200.Packer 中的静态变量
当与代码属性名称连在一起时，指出该属性的格式。
CODEBASE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
Codec - org.omg.IOP 中的 接口
IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。
codec_factory() - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
返回 IOP.CodecFactory。
CodecFactory - org.omg.IOP 中的 接口
Codec 可从 CodecFactory 中获得。
CodecFactoryHelper - org.omg.IOP 中的 类
Codec 可从 CodecFactory 中获得。
CodecFactoryHelper() - 类 org.omg.IOP.CodecFactoryHelper 的构造方法
CodecFactoryOperations - org.omg.IOP 中的 接口
Codec 可从 CodecFactory 中获得。
CodecOperations - org.omg.IOP 中的 接口
IOR 组件格式和 ORB 服务使用的服务上下文数据通常被定义为 IDL 定义数据类型的 CDR 封装编码实例。
codePointAt(CharSequence, int) - 类 java.lang.Character 中的静态方法
返回 CharSequence 的给定索引上的代码点。
codePointAt(char[], int) - 类 java.lang.Character 中的静态方法
返回 char 数组的给定索引上的代码点。
codePointAt(char[], int, int) - 类 java.lang.Character 中的静态方法
返回 char 数组的给定索引上的代码点，该数组中只有那些具有小于 limit 的 index 值的数组元素可以使用。
codePointAt(int) - 类 java.lang.String 中的方法
返回指定索引处的字符（Unicode 代码点）。
codePointAt(int) - 类 java.lang.StringBuffer 中的方法
codePointBefore(CharSequence, int) - 类 java.lang.Character 中的静态方法
返回 CharSequence 的给定索引前面的代码点。
codePointBefore(char[], int) - 类 java.lang.Character 中的静态方法
返回 char 数组的给定索引前面的代码点。
codePointBefore(char[], int, int) - 类 java.lang.Character 中的静态方法
返回 char 数组的给定索引前面的代码点，该数组中只有那些具有大于等于 start 的 index 值的数组元素可以使用。
codePointBefore(int) - 类 java.lang.String 中的方法
返回指定索引之前的字符（Unicode 代码点）。
codePointBefore(int) - 类 java.lang.StringBuffer 中的方法
codePointCount(CharSequence, int, int) - 类 java.lang.Character 中的静态方法
返回指定字符序列的文本范围内的 Unicode 代码点数量。
codePointCount(char[], int, int) - 类 java.lang.Character 中的静态方法
返回 char 数组参数的子数组中 Unicode 代码点的数量。
codePointCount(int, int) - 类 java.lang.String 中的方法
返回此 String 的指定文本范围中的 Unicode 代码点数。
codePointCount(int, int) - 类 java.lang.StringBuffer 中的方法
CoderMalfunctionError - java.nio.charset 中的 错误
当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。
CoderMalfunctionError(Exception) - 错误 java.nio.charset.CoderMalfunctionError 的构造方法
初始化此类的一个实例。
CoderResult - java.nio.charset 中的 类
coder 结果状态的描述。
CODESET_INCOMPATIBLE - org.omg.CORBA 中的 异常
当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
CODESET_INCOMPATIBLE() - 异常 org.omg.CORBA.CODESET_INCOMPATIBLE 的构造方法
构造一个 CODESET_INCOMPATIBLE 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。
CODESET_INCOMPATIBLE(String) - 异常 org.omg.CORBA.CODESET_INCOMPATIBLE 的构造方法
使用指定消息构造一个 CODESET_INCOMPATIBLE 异常。
CODESET_INCOMPATIBLE(int, CompletionStatus) - 异常 org.omg.CORBA.CODESET_INCOMPATIBLE 的构造方法
使用指定次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。
CODESET_INCOMPATIBLE(String, int, CompletionStatus) - 异常 org.omg.CORBA.CODESET_INCOMPATIBLE 的构造方法
使用指定消息、次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。
CodeSets - org.omg.IOP 中的 接口
org/omg/IOP/CodeSets.java。
CodeSigner - java.security 中的 类
此类封装关于代码签名者的信息。
CodeSigner(CertPath, Timestamp) - 类 java.security.CodeSigner 的构造方法
构造 CodeSigner 对象。
CodeSource - java.security 中的 类
此类扩展 codebase 的概念，不仅可以封装位置 (URL) 而且可以封装用于验证起源于该位置的签名代码的证书链。
CodeSource(URL, Certificate[]) - 类 java.security.CodeSource 的构造方法
构造一个 CodeSource 并将其与指定位置和证书集合相关联。
CodeSource(URL, CodeSigner[]) - 类 java.security.CodeSource 的构造方法
构造一个 CodeSource 并将其与指定位置和代码签名者集合相关联。
CODETYPE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
CodingErrorAction - java.nio.charset 中的 类
编码错误操作的类型安全的枚举。
coerceData(boolean) - 类 java.awt.image.BufferedImage 中的方法
强制该数据与 isAlphaPremultiplied 变量中指定的状态相匹配。
coerceData(WritableRaster, boolean) - 类 java.awt.image.ColorModel 中的方法
强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
coerceData(WritableRaster, boolean) - 类 java.awt.image.ComponentColorModel 中的方法
强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
coerceData(WritableRaster, boolean) - 类 java.awt.image.DirectColorModel 中的方法
强制光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定此 ColorModel 现在已对该数据进行正确描述。
colHead - 类 javax.swing.ScrollPaneLayout 中的变量
子级列标题。
COLLAPSED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是折叠的。
collapsedIcon - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
CollapsedStringAdapter - javax.xml.bind.annotation.adapters 中的 类
用来处理 xs:token 及其派生类型的内置 XmlAdapter。
CollapsedStringAdapter() - 类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 的构造方法
collapsePath(TreePath) - 类 javax.swing.JTree 中的方法
确保指定路径标识的节点是折叠的，并且可查看。
collapseRow(int) - 类 javax.swing.JTree 中的方法
确保指定行中的节点是折叠的。
COLLATED - 类 javax.print.attribute.standard.SheetCollate 中的静态变量
当打印多个副本时，文档中的纸张以整理后的顺序出现。
CollationElementIterator - java.text 中的 类
CollationElementIterator 类用作一个迭代器，以遍历国际化字符串的每个字符。
CollationKey - java.text 中的 类
CollationKey 表示遵守特定 Collator 对象规则的 String。
CollationKey(String) - 类 java.text.CollationKey 的构造方法
CollationKey 构造方法。
Collator - java.text 中的 类
Collator 类执行区分语言环境的 String 比较。
Collator() - 类 java.text.Collator 的构造方法
默认的构造方法。
CollatorProvider - java.text.spi 中的 类
提供 Collator 类具体实现的服务提供者的抽象类。
CollatorProvider() - 类 java.text.spi.CollatorProvider 的构造方法
唯一的构造方法（由子类构造方法调用，通常是隐式的）。
Collection<E> - java.util 中的 接口
Collection 层次结构 中的根接口。
CollectionCertStoreParameters - java.security.cert 中的 类
用作 Collection CertStore 算法输入的参数。
CollectionCertStoreParameters(Collection<?>) - 类 java.security.cert.CollectionCertStoreParameters 的构造方法
创建 CollectionCertStoreParameters 的一个实例，它允许从指定的 Collection 中获取证书和 CRL。
CollectionCertStoreParameters() - 类 java.security.cert.CollectionCertStoreParameters 的构造方法
创建具有默认参数值（一个空的并且不可变的 Collection）的 CollectionCertStoreParameters 的实例
Collections - java.util 中的 类
此类完全由在 collection 上进行操作或返回 collection 的静态方法组成。
Color - java.awt 中的 类
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Color(int, int, int) - 类 java.awt.Color 的构造方法
创建具有指定红色、绿色和蓝色值的不透明的 sRGB 颜色，这些值都在 (0 - 255) 的范围内。
Color(int, int, int, int) - 类 java.awt.Color 的构造方法
创建具有指定红色、绿色、蓝色和 alpha 值的 sRGB 颜色，这些值都在 (0 - 255) 的范围内。
Color(int) - 类 java.awt.Color 的构造方法
创建具有指定组合的 RGB 值的不透明的 sRGB 颜色，此 sRGB 值的 16-23 位表示红色分量，8-15 位表示绿色分量，0-7 位表示蓝色分量。
Color(int, boolean) - 类 java.awt.Color 的构造方法
创建具有指定组合的 RGBA 值的 sRGB 颜色，此 RGBA 值的 24-31 位表示 alpha 分量，16-23 位表示红色分量，8-15 位表示绿色分量，0-7 位表示蓝色分量。
Color(float, float, float) - 类 java.awt.Color 的构造方法
创建具有指定红色、绿色和蓝色值的不透明的 sRGB 颜色，这三个颜色值都在 (0.0 - 1.0) 的范围内。
Color(float, float, float, float) - 类 java.awt.Color 的构造方法
创建具有指定红色、绿色、蓝色和 alpha 值的 sRGB 颜色，这些值都在 (0.0 - 1.0) 的范围内。
Color(ColorSpace, float[], float) - 类 java.awt.Color 的构造方法
创建具有 float 数组中指定的颜色分量和指定的 alpha 值的指定 ColorSpace 中的颜色。
COLOR - 类 java.awt.PageAttributes.ColorType 中的静态变量
用来指定颜色打印的 ColorType 实例。
COLOR - 类 javax.print.attribute.standard.Chromaticity 中的静态变量
彩色打印。
color - 类 javax.swing.border.MatteBorder 中的变量
COLOR - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
COLOR - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
COLOR_ACTION - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
Color 选择动作标识符（颜色作为参数传递）
COLOR_CHOOSER - 类 javax.accessibility.AccessibleRole 中的静态变量
允许用户选择颜色的专用窗格。
COLOR_CHOOSER - 类 javax.swing.plaf.synth.Region 中的静态变量
ColorChooser 的 region。
COLOR_CHOOSER_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
ColorChooserComponentFactory - javax.swing.colorchooser 中的 类
旨在生成要插入到颜色选取器中的预先配置的“访问器”对象的类。
ColorChooserUI - javax.swing.plaf 中的 类
JColorChooser 的可插入外观界面。
ColorChooserUI() - 类 javax.swing.plaf.ColorChooserUI 的构造方法
ColorConvertOp - java.awt.image 中的 类
此类对源图像中的数据执行逐像素的颜色转换。
ColorConvertOp(RenderingHints) - 类 java.awt.image.ColorConvertOp 的构造方法
构造从源颜色空间到目标颜色空间转换的新 ColorConvertOp。
ColorConvertOp(ColorSpace, RenderingHints) - 类 java.awt.image.ColorConvertOp 的构造方法
根据 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ColorSpace, ColorSpace, RenderingHints) - 类 java.awt.image.ColorConvertOp 的构造方法
根据两个 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ICC_Profile[], RenderingHints) - 类 java.awt.image.ColorConvertOp 的构造方法
根据 ICC_Profiles 的数组构造新的 ColorConvertOp。
ColorModel - java.awt.image 中的 类
此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。
ColorModel(int) - 类 java.awt.image.ColorModel 的构造方法
构造 ColorModel，将指定位数的像素转换为颜色/alpha 分量。
ColorModel(int, int[], ColorSpace, boolean, boolean, int, int) - 类 java.awt.image.ColorModel 的构造方法
构造将像素值转换为颜色/alpha 分量的 ColorModel。
colorModel - 类 javax.imageio.ImageTypeSpecifier 中的变量
将用作原型的 ColorModel。
ColorSelectionModel - javax.swing.colorchooser 中的 接口
支持选取 Color 的模型。
ColorSpace - java.awt.color 中的 类
此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。
ColorSpace(int, int) - 类 java.awt.color.ColorSpace 的构造方法
构造一个给定颜色空间类型和分量数的 ColorSpace。
ColorSupported - javax.print.attribute.standard 中的 类
ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
ColorSupported(int) - 类 javax.print.attribute.standard.ColorSupported 的构造方法
构造具有给定整数值的支持新颜色的枚举值。
ColorType - javax.swing.plaf.synth 中的 类
可从某种风格中获取的一些颜色的类型安全枚举。
ColorType(String) - 类 javax.swing.plaf.synth.ColorType 的构造方法
创建一个具有指定描述的 ColorType。
ColorUIResource - javax.swing.plaf 中的 类
ColorUIResource(int, int, int) - 类 javax.swing.plaf.ColorUIResource 的构造方法
ColorUIResource(int) - 类 javax.swing.plaf.ColorUIResource 的构造方法
ColorUIResource(float, float, float) - 类 javax.swing.plaf.ColorUIResource 的构造方法
ColorUIResource(Color) - 类 javax.swing.plaf.ColorUIResource 的构造方法
COLS - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
COLSPAN - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
column - 类 javax.swing.event.TableModelEvent 中的变量
COLUMN_HEADER - 类 javax.accessibility.AccessibleRole 中的静态变量
数据列的头。
COLUMN_HEADER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口顶部左上角和右上角之间的区域。
COLUMN_WIDTH_PROPERTY - 类 javax.swing.table.TableColumn 中的静态变量
从 Java 2 platform v1.3 开始已过时。
columnAdded(TableColumnModelEvent) - 接口 javax.swing.event.TableColumnModelListener 中的方法
告知侦听器有一列被添加到模型中。
columnAdded(TableColumnModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表内容的变更（列插入）
columnAdded(TableColumnModelEvent) - 类 javax.swing.JTable 中的方法
将列添加到表的列模型时调用。
columnAdded(TableColumnModelEvent) - 类 javax.swing.table.JTableHeader 中的方法
将列添加到表列模型时调用。
columnAtPoint(Point) - 类 javax.swing.JTable 中的方法
返回 point 所在的列索引；如果结果不在 [0, getColumnCount()-1] 范围内，则返回 -1。
columnAtPoint(Point) - 类 javax.swing.table.JTableHeader 中的方法
返回该 point 所处列的索引，如果列位于边界外，则返回 -1。
columnHeader - 类 javax.swing.JScrollPane 中的变量
列标题子级。
columnIdentifiers - 类 javax.swing.table.DefaultTableModel 中的变量
Vector，由多个列标识符组成。
columnMargin - 类 javax.swing.table.DefaultTableColumnModel 中的变量
每列之间的空白宽度
columnMarginChanged(ChangeEvent) - 接口 javax.swing.event.TableColumnModelListener 中的方法
告知侦听器因为页边空白更改，有一列被移除。
columnMarginChanged(ChangeEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪由于空白变更而引起的列移动的变更。
columnMarginChanged(ChangeEvent) - 类 javax.swing.JTable 中的方法
当列由于间距的更改而被移动时调用。
columnMarginChanged(ChangeEvent) - 类 javax.swing.table.JTableHeader 中的方法
当列由于间距改变而被移动时调用。
columnModel - 类 javax.swing.JTable 中的变量
表的 TableColumnModel。
columnModel - 类 javax.swing.table.JTableHeader 中的变量
表头的 TableColumnModel。
columnMoved(TableColumnModelEvent) - 接口 javax.swing.event.TableColumnModelListener 中的方法
告知侦听器有一列被重新调整位置。
columnMoved(TableColumnModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪列重新定位的变更。
columnMoved(TableColumnModelEvent) - 类 javax.swing.JTable 中的方法
重新定位列时调用。
columnMoved(TableColumnModelEvent) - 类 javax.swing.table.JTableHeader 中的方法
重新定位列时调用。
columnNoNulls - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中可能不允许使用 NULL 值。
columnNoNulls - 接口 java.sql.ResultSetMetaData 中的静态变量
指示列不允许使用 NULL 值的常量。
columnNullable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中明确允许使用 NULL 值。
columnNullable - 接口 java.sql.ResultSetMetaData 中的静态变量
指示列允许使用 NULL 值的常量。
columnNullableUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道列是否可为 null。
columnNullableUnknown - 接口 java.sql.ResultSetMetaData 中的静态变量
指示不知道列的值是否可为 null 的常量。
columnRemoved(TableColumnModelEvent) - 接口 javax.swing.event.TableColumnModelListener 中的方法
告知侦听器有一列从模型中移除。
columnRemoved(TableColumnModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表内容的变更（列删除）
columnRemoved(TableColumnModelEvent) - 类 javax.swing.JTable 中的方法
从表的列模型中移除列时调用。
columnRemoved(TableColumnModelEvent) - 类 javax.swing.table.JTableHeader 中的方法
从表列模型中移除列时调用。
columnSelectionAllowed - 类 javax.swing.table.DefaultTableColumnModel 中的变量
此列模型中允许的列选择
columnSelectionChanged(ListSelectionEvent) - 接口 javax.swing.event.TableColumnModelListener 中的方法
告知侦听器 TableColumnModel 的选择模型发生更改。
columnSelectionChanged(ListSelectionEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
对变更的 TableColumnModel 的选择模型进行跟踪。
columnSelectionChanged(ListSelectionEvent) - 类 javax.swing.JTable 中的方法
TableColumnModel 的选择模型更改时调用。
columnSelectionChanged(ListSelectionEvent) - 类 javax.swing.table.JTableHeader 中的方法
当 TableColumnModel 的选择模型更改时调用。
columnUpdated(int) - 接口 javax.sql.rowset.CachedRowSet 中的方法
指示此 CachedRowSet 对象当前行中的指定列是否已更新。
columnUpdated(String) - 接口 javax.sql.rowset.CachedRowSet 中的方法
指示此 CachedRowSet 对象当前行中的指定列是否已更新。
columnWeights - 类 java.awt.GridBagLayout 中的变量
此字段保持对列权重的重写。
columnWidths - 类 java.awt.GridBagLayout 中的变量
此字段保持对列最小宽度的重写。
combine(ProtectionDomain[], ProtectionDomain[]) - 接口 java.security.DomainCombiner 中的方法
修改或更新提供的 ProtectionDomain。
combine(ProtectionDomain[], ProtectionDomain[]) - 类 javax.security.auth.SubjectDomainCombiner 中的方法
使用与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新相关的 ProtectionDomains。
COMBINING - 类 java.awt.font.GlyphMetrics 中的静态变量
指示表示组合字符的字形，例如元音变音。
COMBINING_DIACRITICAL_MARKS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Combining Diacritical Marks”Unicode 字符块的常量。
COMBINING_HALF_MARKS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Combining Half Marks”Unicode 字符块的常量。
COMBINING_MARKS_FOR_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Combining Diacritical Marks for Symbols”Unicode 字符块的常量。
COMBINING_SPACING_MARK - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Mc”。
COMBO_BOX - 类 javax.accessibility.AccessibleRole 中的静态变量
用户可以从中进行选择的选项列表。
COMBO_BOX - 类 javax.swing.plaf.synth.Region 中的静态变量
ComboBox 的 region。
comboBox - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
comboBox - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
comboBox - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的变量
ComboBoxEditor - javax.swing 中的 接口
用于 JComboBox 组件的编辑器组件。
ComboBoxModel - javax.swing 中的 接口
用于组合框的数据模型。
ComboBoxUI - javax.swing.plaf 中的 类
JComboBox 的可插入外观界面。
ComboBoxUI() - 类 javax.swing.plaf.ComboBoxUI 的构造方法
comboIcon - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的变量
ComboPopup - javax.swing.plaf.basic 中的 接口
定义实现组合框弹出部分所需方法的接口。
COMM_FAILURE - org.omg.CORBA 中的 异常
如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
COMM_FAILURE() - 异常 org.omg.CORBA.COMM_FAILURE 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 COMM_FAILURE 异常。
COMM_FAILURE(String) - 异常 org.omg.CORBA.COMM_FAILURE 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 COMM_FAILURE 异常。
COMM_FAILURE(int, CompletionStatus) - 异常 org.omg.CORBA.COMM_FAILURE 的构造方法
使用指定次要代码和完成状态构造一个 COMM_FAILURE 异常。
COMM_FAILURE(String, int, CompletionStatus) - 异常 org.omg.CORBA.COMM_FAILURE 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 COMM_FAILURE 异常。
command(Object) - 类 java.lang.Compiler 中的静态方法
检查参数类型及其字段，并执行一些文档操作。
command(List<String>) - 类 java.lang.ProcessBuilder 中的方法
设置此进程生成器的操作系统程序和参数。
command(String...) - 类 java.lang.ProcessBuilder 中的方法
设置此进程生成器的操作系统程序和参数。
command() - 类 java.lang.ProcessBuilder 中的方法
返回此进程生成器的操作系统程序和参数。
CommandInfo - javax.activation 中的 类
CommandMap 实现使用 CommandInfo 类描述命令请求的结果。
CommandInfo(String, String) - 类 javax.activation.CommandInfo 的构造方法
CommandInfo 的构造方法。
CommandMap - javax.activation 中的 类
CommandMap 类为系统中可用的命令对象注册表提供接口。
CommandMap() - 类 javax.activation.CommandMap 的构造方法
CommandObject - javax.activation 中的 接口
Activation Framework 所知的 JavaBean 组件实现此接口，以找出请求这些组件执行的命令动词，并获取表示这些组件要操作的数据的 DataHandler。
COMMENT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
COMMENT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
所有注释以此标记作为标签。
comment(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出注释。
Comment - javax.xml.stream.events 中的 接口
注释事件的接口。
COMMENT - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个注释
Comment - org.w3c.dom 中的 接口
此接口继承自 CharacterData 表示注释的内容，即起始 '<!--' 和结束 '-->' 之间的所有字符。
comment(char[], int, int) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
comment(char[], int, int) - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告文档的任何位置的 XML 注释。
COMMENT_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Comment。
commentChar(int) - 类 java.io.StreamTokenizer 中的方法
指定该字符参数启动一个单行注释。
COMMENTS - 类 java.util.regex.Pattern 中的静态变量
模式中允许空白和注释。
commit() - 接口 java.sql.Connection 中的方法
使所有上一次提交/回滚后进行的更改成为持久更改，并释放此 Connection 对象当前持有的所有数据库锁。
commit() - 接口 javax.security.auth.spi.LoginModule 中的方法
提交验证过程的方法（阶段 2）。
commit() - 接口 javax.sql.rowset.CachedRowSet 中的方法
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。
commit() - 接口 javax.sql.rowset.JdbcRowSet 中的方法
每个 JdbcRowSet 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。
commit() - 接口 javax.sql.rowset.spi.TransactionalWriter 中的方法
使最后一次调用 commit 或 rollback 方法以来 acceptChanges 执行的所有更改永久化。
COMMIT - 类 javax.swing.JFormattedTextField 中的静态变量
标识丢失焦点时，应该调用 commitEdit 的常量。
commit(Xid, boolean) - 接口 javax.transaction.xa.XAResource 中的方法
提交 xid 指定的全局事务。
COMMIT_ON_ACCEPT_CHANGES - 接口 javax.sql.rowset.CachedRowSet 中的静态变量
导致在调用 acceptChanges() 时，CachedRowSet 对象的 SyncProvider 提交更改。
COMMIT_OR_REVERT - 类 javax.swing.JFormattedTextField 中的静态变量
标识丢失焦点时，应该调用 commitEdit 的常量。
commitEdit() - 类 javax.swing.JFormattedTextField 中的方法
强制从 AbstractFormatter 获得当前值并将其设置为当前值。
commitEdit() - 类 javax.swing.JSpinner 中的方法
将当前编辑的值提交给 SpinnerModel。
commitEdit() - 类 javax.swing.JSpinner.DefaultEditor 中的方法
将当前编辑值赋给 SpinnerModel。
COMMON - 类 java.awt.JobAttributes.DialogType 中的静态变量
用于指定跨平台的纯 Java 打印对话框的 DialogType 实例。
CommonDataSource - javax.sql 中的 接口
此接口定义在 DataSource、XADataSource 和 ConnectionPoolDataSource 之间公用的方法。
CommunicationException - javax.naming 中的 异常
当客户端无法与目录或命名服务通信时，抛出此异常。
CommunicationException(String) - 异常 javax.naming.CommunicationException 的构造方法
使用所提供的参数构造一个新的 CommunicationException 实例。
CommunicationException() - 异常 javax.naming.CommunicationException 的构造方法
构造一个新的 CommunicationException 实例。
compact() - 类 java.nio.ByteBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.CharBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.DoubleBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.FloatBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.IntBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.LongBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.ShortBuffer 中的方法
压缩此缓冲区（可选操作）。
COMPACT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
COMPACT_DISC - 类 javax.sound.sampled.Port.Info 中的静态变量
从 CD-ROM 驱动器获得音频端口类型。
Comparable<T> - java.lang 中的 接口
此接口强行对实现它的每个类的对象进行整体排序。
Comparator<T> - java.util 中的 接口
强行对某个对象 collection 进行整体排序 的比较函数。
comparator() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
comparator() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
comparator() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
返回用于对此队列元素进行排序的比较器；如果此队列使用其元素的自然顺序，则返回 null。
comparator() - 类 java.util.PriorityQueue 中的方法
返回用来对此队列中的元素进行排序的比较器；如果此队列根据其元素的自然顺序进行排序，则返回 null。
comparator() - 接口 java.util.SortedMap 中的方法
返回对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null。
comparator() - 接口 java.util.SortedSet 中的方法
返回对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null。
comparator() - 类 java.util.TreeMap 中的方法
comparator() - 类 java.util.TreeSet 中的方法
compare(double, double) - 类 java.lang.Double 中的静态方法
比较两个指定的 double 值。
compare(float, float) - 类 java.lang.Float 中的静态方法
比较两个指定的 float 值。
compare(String, String) - 类 java.text.Collator 中的方法
根据此 Collator 的整理规则来比较源字符串和目标字符串。
compare(Object, Object) - 类 java.text.Collator 中的方法
比较此方法两个参数的顺序。
compare(String, String) - 类 java.text.RuleBasedCollator 中的方法
根据表规则比较存储在两个不同字符串中的字符数据。
compare(T, T) - 接口 java.util.Comparator 中的方法
比较用来排序的两个参数。
compare(Duration) - 类 javax.xml.datatype.Duration 中的方法
与此 Duration 实例的部分顺序关系比较。
compare(XMLGregorianCalendar) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
根据 W3C XML 模式 1.0 第二部分 3.2.7.3 小节 Order relation on dateTime 中定义的部分顺序关系，比较 W3C XML 模式 1.0 日期/时间数据类型的两个实例。
compareAndSet(boolean, boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
compareAndSet(int, int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
compareAndSet(int, int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
compareAndSet(T, int, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段值设置为给定的更新值。
compareAndSet(long, long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
compareAndSet(int, long, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
compareAndSet(T, long, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段设置为给定的更新值。
compareAndSet(V, V, boolean, boolean) - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
如果当前引用 == 预期引用，并且当前标记等于预期标记，那么以原子方式将引用和标记的值设置为给定的更新值。
compareAndSet(V, V) - 类 java.util.concurrent.atomic.AtomicReference 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
compareAndSet(int, E, E) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
compareAndSet(T, V, V) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器管理的给定对象的字段设置为给定的更新值。
compareAndSet(V, V, int, int) - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
如果当前引用 == 预期引用，并且当前标志等于预期标志，则以原子方式将该引用和该标志的值设置为给定的更新值。
compareAndSetState(long, long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
如果当前状态值等于预期值，则以原子方式将同步状态设置为给定的更新值。
compareAndSetState(int, int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
如果当前状态值等于预期值，则以原子方式将同步状态设置为给定的更新值。
compareDocumentPosition(Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
compareDocumentPosition(Node) - 接口 org.w3c.dom.Node 中的方法
就节点在文档中的位置并按照文档的顺序，比较引用节点（即在其上调用此方法的节点）与作为参数传递的节点。
compareTabOrder(Component, Component) - 类 javax.swing.DefaultFocusManager 中的方法
compareTo(File) - 类 java.io.File 中的方法
按字母顺序比较两个抽象路径名。
compareTo(Object) - 类 java.io.ObjectStreamField 中的方法
将此字段与另一个 ObjectStreamField 进行比较。
compareTo(Boolean) - 类 java.lang.Boolean 中的方法
将此 Boolean 实例与其他实例进行比较。
compareTo(Byte) - 类 java.lang.Byte 中的方法
在数字上比较两个 Byte 对象。
compareTo(Character) - 类 java.lang.Character 中的方法
根据数字比较两个 Character 对象。
compareTo(T) - 接口 java.lang.Comparable 中的方法
比较此对象与指定对象的顺序。
compareTo(Double) - 类 java.lang.Double 中的方法
对两个 Double 对象所表示的数值进行比较。
compareTo(E) - 类 java.lang.Enum 中的方法
比较此枚举与指定对象的顺序。
compareTo(Float) - 类 java.lang.Float 中的方法
比较两个 Float 对象所表示的数值。
compareTo(Integer) - 类 java.lang.Integer 中的方法
在数字上比较两个 Integer 对象。
compareTo(Long) - 类 java.lang.Long 中的方法
在数字上比较两个 Long 对象。
compareTo(Short) - 类 java.lang.Short 中的方法
比较两个 Short 对象所表示的数值。
compareTo(String) - 类 java.lang.String 中的方法
按字典顺序比较两个字符串。
compareTo(BigDecimal) - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 与指定的 BigDecimal 比较。
compareTo(BigInteger) - 类 java.math.BigInteger 中的方法
将此 BigInteger 与指定的 BigInteger 进行比较。
compareTo(URI) - 类 java.net.URI 中的方法
将此 URI 与另一个对象（也必须是 URI）进行比较。
compareTo(ByteBuffer) - 类 java.nio.ByteBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(CharBuffer) - 类 java.nio.CharBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(Charset) - 类 java.nio.charset.Charset 中的方法
比较此 charset 与其他 charset。
compareTo(DoubleBuffer) - 类 java.nio.DoubleBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(FloatBuffer) - 类 java.nio.FloatBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(IntBuffer) - 类 java.nio.IntBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(LongBuffer) - 类 java.nio.LongBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(ShortBuffer) - 类 java.nio.ShortBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(Timestamp) - 类 java.sql.Timestamp 中的方法
将此 Timestamp 对象与给定 Timestamp 对象相比较。
compareTo(Date) - 类 java.sql.Timestamp 中的方法
将此 Timestamp 对象与给定的 Date（必须为 Timestamp 对象）相比较。
compareTo(CollationKey) - 类 java.text.CollationKey 中的方法
比较此 CollationKey 与目标 CollationKey。
compareTo(Calendar) - 类 java.util.Calendar 中的方法
比较两个 Calendar 对象表示的时间值（从历元至现在的毫秒偏移量）。
compareTo(Date) - 类 java.util.Date 中的方法
比较两个日期的顺序。
compareTo(UUID) - 类 java.util.UUID 中的方法
将此 UUID 与指定的 UUID 比较。
compareTo(ObjectName) - 类 javax.management.ObjectName 中的方法
比较两个 ObjectName 实例。
compareTo(Object) - 类 javax.naming.CompositeName 中的方法
比较此 CompositeName 与指定 Object 的顺序。
compareTo(Object) - 类 javax.naming.CompoundName 中的方法
比较此 CompoundName 与指定 Object 的顺序。
compareTo(Object) - 类 javax.naming.ldap.LdapName 中的方法
比较此 LdapName 与指定 Object 的顺序。
compareTo(Object) - 类 javax.naming.ldap.Rdn 中的方法
比较此 Rdn 与指定 Object 的顺序。
compareTo(Object) - 接口 javax.naming.Name 中的方法
比较此名称与另一个名称的顺序。
compareToIgnoreCase(String) - 类 java.lang.String 中的方法
按字典顺序比较两个字符串，不考虑大小写。
Compilable - javax.script 中的 接口
由 ScriptEngines 实现的可选接口，该 ScriptEngines 的方法将脚本编译成无需重新编译就能反复执行的某种形式。
COMPILATION_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
CompilationMXBean 的 ObjectName 的字符串表示形式。
CompilationMXBean - java.lang.management 中的 接口
用于 Java 虚拟机的编译系统的管理接口。
compile(String) - 类 java.util.regex.Pattern 中的静态方法
将给定的正则表达式编译到模式中。
compile(String, int) - 类 java.util.regex.Pattern 中的静态方法
将给定的正则表达式编译到具有给定标志的模式中。
compile(String) - 接口 javax.script.Compilable 中的方法
编译脚本（以 String 形式表示的源），以便以后执行。
compile(Reader) - 接口 javax.script.Compilable 中的方法
编译脚本（从 Reader 读取的源），以便以后执行。
compile(String) - 接口 javax.xml.xpath.XPath 中的方法
编译 XPath 表达式供以后计算使用。
compileClass(Class<?>) - 类 java.lang.Compiler 中的静态方法
编译指定的类。
compileClasses(String) - 类 java.lang.Compiler 中的静态方法
编译那些名称与指定字符串相匹配的所有类。
CompiledScript - javax.script 中的 类
存储编译结果的类扩展自此类。
CompiledScript() - 类 javax.script.CompiledScript 的构造方法
Compiler - java.lang 中的 类
Compiler 类主要支持 Java 到本机代码的编译器及相关服务。
complementOf(EnumSet<E>) - 类 java.util.EnumSet 中的静态方法
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含指定 set 中所不 包含的此类型的所有元素。
COMPLETE - 类 java.awt.MediaTracker 中的静态变量
指示媒体下载已成功完成的标志。
complete() - 类 java.util.Calendar 中的方法
填充日历字段中所有未设置的字段。
COMPLETED - 类 javax.print.attribute.standard.JobState 中的静态变量
作业已成功完成，或以警告或错误结束，所有作业介质纸张已成功堆栈到适当的输出纸盒（或多个纸盒）中，且所有作业状态已达到作业的最终值。
completed - 异常 org.omg.CORBA.SystemException 中的变量
抛出此异常的操作的状态。
COMPLETED_MAYBE - 类 org.omg.CORBA.CompletionStatus 中的静态变量
使用常量 _COMPLETED_MAYBE 初始化的 CompletionStatus 实例。
COMPLETED_NO - 类 org.omg.CORBA.CompletionStatus 中的静态变量
使用常量 _COMPLETED_NO 初始化的 CompletionStatus 实例。
COMPLETED_YES - 类 org.omg.CORBA.CompletionStatus 中的静态变量
使用常量 _COMPLETED_YES 初始化的 CompletionStatus 实例。
completeDrag(int, int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
completeDrag(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
用鼠标事件的新位置传递 finishDraggingTo 的消息。
completeEditing() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
传递消息以停止编辑会话。
completeEditing(boolean, boolean, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
停止编辑会话。
COMPLETESCANLINES - 接口 java.awt.image.ImageConsumer 中的静态变量
按照一次（多个）完整扫描行的方式传递像素。
completeUIInstall() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
在安装所有默认值/侦听器之后根据 installUI 调用。
completeUIUninstall() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
Completion - javax.annotation.processing 中的 接口
某一注释的建议 completion。
Completions - javax.annotation.processing 中的 类
用来组合 Completion 对象的实用工具类。
CompletionService<V> - java.util.concurrent 中的 接口
将生产新的异步任务与使用已完成任务的结果分离开来的服务。
CompletionStatus - org.omg.CORBA 中的 类
指示某一方法抛出 SystemException 时是否已结束运行的对象。
CompletionStatusHelper - org.omg.CORBA 中的 类
CompletionStatus 的 Helper。
CompletionStatusHelper() - 类 org.omg.CORBA.CompletionStatusHelper 的构造方法
Component - java.awt 中的 类
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Component() - 类 java.awt.Component 的构造方法
构造一个新组件。
component - 类 java.awt.dnd.DragGestureRecognizer 中的变量
与此 DragGestureRecognizer 关联的 Component。
COMPONENT - 类 java.awt.font.GlyphMetrics 中的静态变量
指示在内部存储中没有相应字符的字形。
component - 类 javax.swing.ImageIcon 中的静态变量
Component.AccessibleAWTComponent - java.awt 中的 类
用来为可访问性提供默认支持的 Component 的内部类。
Component.AccessibleAWTComponent() - 类 java.awt.Component.AccessibleAWTComponent 的构造方法
虽然该类是抽象的，但其所有子类都应该能够调用此方法。
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler - java.awt 中的 类
当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler() - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 的构造方法
Component.AccessibleAWTComponent.AccessibleAWTFocusHandler - java.awt 中的 类
当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）
Component.AccessibleAWTComponent.AccessibleAWTFocusHandler() - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 的构造方法
Component.BaselineResizeBehavior - java.awt 中的 枚举
常见方式的枚举，指示组件的基线可以随大小的更改而更改。
Component.BltBufferStrategy - java.awt 中的 类
用于将屏幕外的画面以位图传输方式传输到一个组件的内部类。
Component.BltBufferStrategy(int, BufferCapabilities) - 类 java.awt.Component.BltBufferStrategy 的构造方法
围绕组件创建一个新的 blt 缓冲区策略
Component.FlipBufferStrategy - java.awt 中的 类
在组件上翻转缓冲区的内部类。
Component.FlipBufferStrategy(int, BufferCapabilities) - 类 java.awt.Component.FlipBufferStrategy 的构造方法
为此组件创建新的翻转缓冲区策略。
COMPONENT_ADDED - 类 java.awt.event.ContainerEvent 中的静态变量
此事件指示组件已被添加到容器中。
component_count() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回 DynAny 的组件数。
component_count() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
返回 DynAny 的组件数。
component_data - 类 org.omg.IOP.TaggedComponent 中的变量
与组件 id 关联的组件数据。
COMPONENT_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择组件事件的事件掩码。
COMPONENT_FIRST - 类 java.awt.event.ComponentEvent 中的静态变量
用于组件事件的 id 范围的起始编号。
COMPONENT_HIDDEN - 类 java.awt.event.ComponentEvent 中的静态变量
此事件指示组件呈现为不可见。
COMPONENT_LAST - 类 java.awt.event.ComponentEvent 中的静态变量
用于组件事件的 id 范围的结束编号。
COMPONENT_MOVED - 类 java.awt.event.ComponentEvent 中的静态变量
此事件指示组件位置已更改。
COMPONENT_REMOVED - 类 java.awt.event.ContainerEvent 中的静态变量
此事件指示已从容器中移除组件。
COMPONENT_RESIZED - 类 java.awt.event.ComponentEvent 中的静态变量
此事件指示组件大小已更改。
COMPONENT_SHOWN - 类 java.awt.event.ComponentEvent 中的静态变量
此事件指示组件已变得可见。
ComponentAdapter - java.awt.event 中的 类
用于接收组件事件的抽象适配器类。
ComponentAdapter() - 类 java.awt.event.ComponentAdapter 的构造方法
componentAdded(ContainerEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentAdded 方法处理 componentAdded 容器事件。
componentAdded(ContainerEvent) - 类 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler 中的方法
componentAdded(ContainerEvent) - 类 java.awt.event.ContainerAdapter 中的方法
已将组件添加到容器中时调用。
componentAdded(ContainerEvent) - 接口 java.awt.event.ContainerListener 中的方法
已将组件添加到容器中时调用。
componentAdded(ContainerEvent) - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler 中的方法
componentAdded(ContainerEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener 中的方法
ComponentAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
组件属性的名称。
ComponentColorModel - java.awt.image 中的 类
使用像素值将颜色和 alpha 信息表示为独立样本的 ColorModel 类，该类以独立的数据元素存储每个样本。
ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int) - 类 java.awt.image.ComponentColorModel 的构造方法
根据指定参数构造 ComponentColorModel。
ComponentColorModel(ColorSpace, boolean, boolean, int, int) - 类 java.awt.image.ComponentColorModel 的构造方法
根据指定参数构造 ComponentColorModel。
ComponentElementName - 类 javax.swing.text.StyleConstants 中的静态变量
用于表示组件的元素名称。
ComponentEvent - java.awt.event 中的 类
指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
ComponentEvent(Component, int) - 类 java.awt.event.ComponentEvent 的构造方法
构造一个 ComponentEvent 对象。
componentForPoint(Component, Point) - 类 javax.swing.MenuSelectionManager 中的方法
返回包含 sourcePoint 的当前选择路径的组件。
componentHidden(ComponentEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentHidden 方法处理 componentHidden 事件。
componentHidden(ComponentEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 中的方法
componentHidden(ComponentEvent) - 类 java.awt.event.ComponentAdapter 中的方法
组件变得不可见时调用。
componentHidden(ComponentEvent) - 接口 java.awt.event.ComponentListener 中的方法
组件变得不可见时调用。
componentHidden(ComponentEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 中的方法
ComponentIdHelper - org.omg.IOP 中的 类
表示多组件配置文件的标准方式。
ComponentIdHelper() - 类 org.omg.IOP.ComponentIdHelper 的构造方法
ComponentInputMap - javax.swing 中的 类
ComponentInputMap 是与特定 JComponent 相关联的 InputMap。
ComponentInputMap(JComponent) - 类 javax.swing.ComponentInputMap 的构造方法
创建一个与给定组件相关联的 ComponentInputMap。
ComponentInputMapUIResource - javax.swing.plaf 中的 类
实现 UIResource 的 javax.swing.ComponentInputMap 的子类。
ComponentInputMapUIResource(JComponent) - 类 javax.swing.plaf.ComponentInputMapUIResource 的构造方法
ComponentListener - java.awt.event 中的 接口
用于接收组件事件的侦听器接口。
componentListener - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
componentListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
componentMoved(ComponentEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentMoved 方法处理 componentMoved 事件。
componentMoved(ComponentEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 中的方法
componentMoved(ComponentEvent) - 类 java.awt.event.ComponentAdapter 中的方法
组件位置更改时调用。
componentMoved(ComponentEvent) - 接口 java.awt.event.ComponentListener 中的方法
组件位置更改时调用。
componentMoved(ComponentEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 中的方法
componentMoved(ComponentEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的方法
ComponentOrientation - java.awt 中的 类
ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。
componentRemoved(ContainerEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentRemoved 方法处理 componentRemoved 容器事件。
componentRemoved(ContainerEvent) - 类 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler 中的方法
componentRemoved(ContainerEvent) - 类 java.awt.event.ContainerAdapter 中的方法
已从容器中移除组件时调用。
componentRemoved(ContainerEvent) - 接口 java.awt.event.ContainerListener 中的方法
已从容器中移除组件时调用。
componentRemoved(ContainerEvent) - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler 中的方法
componentRemoved(ContainerEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener 中的方法
componentResized(ComponentEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentResized 方法处理 componentResized 事件。
componentResized(ComponentEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 中的方法
componentResized(ComponentEvent) - 类 java.awt.event.ComponentAdapter 中的方法
组件大小更改时调用。
componentResized(ComponentEvent) - 接口 java.awt.event.ComponentListener 中的方法
组件大小更改时调用。
componentResized(ComponentEvent) - 类 javax.swing.JViewport.ViewListener 中的方法
componentResized(ComponentEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 中的方法
当 JInternalFrame 的父级大小更改时调用。
componentResized(ComponentEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.ComponentHandler 中的方法
components - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的变量
components_established(IORInfo) - 接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations 中的方法
在已经对所有已注册 IORInterceptor 实例调用 establish_components 方法后，对所有已注册 IORInterceptor_3_0 实例调用 components_established 方法。
ComponentSampleModel - java.awt.image 中的 类
此类表示按每个像素样本占用 DataBuffer 中一个数据元素的方式存储的图像数据。
ComponentSampleModel(int, int, int, int, int, int[]) - 类 java.awt.image.ComponentSampleModel 的构造方法
构造具有指定参数的 ComponentSampleModel。
ComponentSampleModel(int, int, int, int, int, int[], int[]) - 类 java.awt.image.ComponentSampleModel 的构造方法
构造具有指定参数的 ComponentSampleModel。
componentShown(ComponentEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentShown 方法处理 componentShown 事件。
componentShown(ComponentEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 中的方法
componentShown(ComponentEvent) - 类 java.awt.event.ComponentAdapter 中的方法
组件变得可见时调用。
componentShown(ComponentEvent) - 接口 java.awt.event.ComponentListener 中的方法
组件变得可见时调用。
componentShown(ComponentEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 中的方法
ComponentUI - javax.swing.plaf 中的 类
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。
ComponentUI() - 类 javax.swing.plaf.ComponentUI 的构造方法
单独的构造方法。
ComponentView - javax.swing.text 中的 类
实现视图接口的组件装饰器。
ComponentView(Element) - 类 javax.swing.text.ComponentView 的构造方法
创建新的 ComponentView 对象。
compose(Raster, Raster, WritableRaster) - 接口 java.awt.CompositeContext 中的方法
组合两个源 Raster 对象并将结果置于目标 WritableRaster 中。
ComposedTextAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
撰写文本的输入法属性的名称。
composeName(Name, Name) - 接口 javax.naming.Context 中的方法
将此上下文的名称与相对于此上下文的名称组合。
composeName(String, String) - 接口 javax.naming.Context 中的方法
将此上下文的名称与相对于此上下文的名称组合。
composeName(String, String) - 类 javax.naming.InitialContext 中的方法
将此上下文的名称与相对于此上下文的名称组合。
composeName(Name, Name) - 类 javax.naming.InitialContext 中的方法
将此上下文的名称与相对于此上下文的名称组合。
Composite - java.awt 中的 接口
Composite 接口和 CompositeContext 一起定义了用基础图形区域组合绘图基本元素的方法。
CompositeContext - java.awt 中的 接口
CompositeContext 接口为复合操作定义了已封装和已优化的环境。
CompositeData - javax.management.openmbean 中的 接口
CompositeData 接口指定表示复合数据 结构的复杂开放数据 对象的特定类型的行为。
CompositeDataInvocationHandler - javax.management.openmbean 中的 类
将获取方法转发给 CompositeData 的 InvocationHandler。
CompositeDataInvocationHandler(CompositeData) - 类 javax.management.openmbean.CompositeDataInvocationHandler 的构造方法
构造一个受给定 CompositeData 支持的处理程序。
CompositeDataSupport - javax.management.openmbean 中的 类
CompositeDataSupport 类是实现 CompositeData 接口的开放数据 类。
CompositeDataSupport(CompositeType, String[], Object[]) - 类 javax.management.openmbean.CompositeDataSupport 的构造方法
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。
CompositeDataSupport(CompositeType, Map<String, ?>) - 类 javax.management.openmbean.CompositeDataSupport 的构造方法
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。
CompositeDataView - javax.management.openmbean 中的 接口
Java 类可以实现此接口，以指示如何通过 MXBean 框架将其转换为 CompositeData。
CompositeName - javax.naming 中的 类
此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
CompositeName(Enumeration<String>) - 类 javax.naming.CompositeName 的构造方法
使用由 'comps' 指定的组件构造一个新的复合名称实例。
CompositeName(String) - 类 javax.naming.CompositeName 的构造方法
通过使用复合名称语法（从左到右，用斜杠分隔）解析字符串 n 来构造一个新的复合名称实例。
CompositeName() - 类 javax.naming.CompositeName 的构造方法
构造一个新的空复合名称。
CompositeType - javax.management.openmbean 中的 类
CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。
CompositeType(String, String, String[], String[], OpenType<?>[]) - 类 javax.management.openmbean.CompositeType 的构造方法
构造一个 CompositeType 实例，检查给定参数的有效性。
CompositeView - javax.swing.text 中的 类
CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。
CompositeView(Element) - 类 javax.swing.text.CompositeView 的构造方法
为给定元素构造一个 CompositeView。
CompoundBorder - javax.swing.border 中的 类
一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
CompoundBorder() - 类 javax.swing.border.CompoundBorder 的构造方法
创建一个组合边框，其内部边框和外部边框均为 null。
CompoundBorder(Border, Border) - 类 javax.swing.border.CompoundBorder 的构造方法
按照指定的内部边框和外部边框创建组合边框。
CompoundControl - javax.sound.sampled 中的 类
CompoundControl（如图形均衡器）控制两个或多个相关属性，每个属性本身都表示为 Control。
CompoundControl(CompoundControl.Type, Control[]) - 类 javax.sound.sampled.CompoundControl 的构造方法
构造一个具有给定参数的新组合控件对象。
CompoundControl.Type - javax.sound.sampled 中的 类
CompoundControl.Type 内部类的实例标识一种组合控件。
CompoundControl.Type(String) - 类 javax.sound.sampled.CompoundControl.Type 的构造方法
构造一个新的组合控件类型。
CompoundEdit - javax.swing.undo 中的 类
AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
CompoundEdit() - 类 javax.swing.undo.CompoundEdit 的构造方法
compoundEdit - 类 javax.swing.undo.UndoableEditSupport 中的变量
CompoundName - javax.naming 中的 类
此类表示一个组合名称，即一个取自层次名称空间的名称。
CompoundName(Enumeration<String>, Properties) - 类 javax.naming.CompoundName 的构造方法
使用 comps 和 syntax 指定的组件构造一个新的组合名称实例。
CompoundName(String, Properties) - 类 javax.naming.CompoundName 的构造方法
通过解析使用提供的 syntax 属性所指定的语法的字符串 n 来构造一个新的组合名称实例。
COMPRESS - 类 javax.print.attribute.standard.Compression 中的静态变量
UNIX 压缩技术。
Compression - javax.print.attribute.standard 中的 类
Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
Compression(int) - 类 javax.print.attribute.standard.Compression 的构造方法
构造具有给定整数值的新压缩枚举值。
COMPRESSION_ERROR - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
系统中止了作业，因为打印机在解压缩文档数据中遇到错误。
compressionMode - 类 javax.imageio.ImageWriteParam 中的变量
控制压缩设置的模式，必须将它设置为四个 MODE_* 值之一。
compressionQuality - 类 javax.imageio.ImageWriteParam 中的变量
包含当前压缩质量设置的 float 值。
compressionType - 类 javax.imageio.ImageWriteParam 中的变量
包含当前压缩类型名称的 String，如果没有设置压缩类型，则返回 null。
compressionTypes - 类 javax.imageio.ImageWriteParam 中的变量
包含可用压缩类型名称的 String 数组。
comptable - 类 java.awt.GridBagLayout 中的变量
此哈希表维持组件与其网格包约束之间的关联。
computeBlit(int, int, Point, Point, Dimension, Rectangle) - 类 javax.swing.JViewport 中的方法
计算 blit 的参数，其中后备存储图像当前在左上角包含 oldLoc，并且我们滚动到 newLoc。
computeDifference(Rectangle, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
返回矩形数组的便捷方法，该矩形表示不与 rectB 重叠的 rectA 内的区域。
computeFields() - 类 java.util.Calendar 中的方法
将当前毫秒时间值 Calendar.time 转换为 fields[] 中的日历字段值。
computeFields() - 类 java.util.GregorianCalendar 中的方法
将时间值（从 Epoch 至现在的毫秒偏移量）转换为日历字段值。
computeIntersection(int, int, int, int, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
在未分配新矩形的情况下计算两个矩形的交集的便捷方法。
computePopupBounds(int, int, int, int) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
基于组合框的位置和封闭的屏幕界限计算组合框的弹出部分的位置和大小。
computeRegions(ImageReadParam, int, int, BufferedImage, Rectangle, Rectangle) - 类 javax.imageio.ImageReader 中的静态方法
计算感兴趣的源区域和目标区域，将源图像的宽度和高度、可选目标图像和可选 ImageReadParam 都考虑在内。
computerIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
computeStringWidth(SynthContext, Font, FontMetrics, String) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
返回传入字符串的大小。
computeStringWidth(FontMetrics, String) - 类 javax.swing.SwingUtilities 中的静态方法
使用具有指定“规格”（大小）的字体计算字符串的宽度。
computeTime() - 类 java.util.Calendar 中的方法
将 fields[] 中的当前日历字段值转换为毫秒时间值 Calendar.time。
computeTime() - 类 java.util.GregorianCalendar 中的方法
将日历字段值转换为时间值（从 Epoch 至现在的毫秒偏移量）。
computeUnion(int, int, int, int, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
在未分配新矩形的情况下计算两个矩形的并集的便捷方法。
computeVisibleRect(Rectangle) - 类 javax.swing.JComponent 中的方法
返回该 Component 的“可见 rect 矩形”，即此组件及其所有祖先的可见矩形的交集。
concat(String) - 类 java.lang.String 中的方法
将指定字符串连接到此字符串的结尾。
concatenate(AffineTransform) - 类 java.awt.geom.AffineTransform 中的方法
以最常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，以提供由 Tx 映射到以前用户空间的新用户空间。
concatenateTransform(AffineTransform) - 类 java.awt.image.renderable.RenderContext 中的方法
通过追加另一变换修改当前的“用户到设备”变换。
concetenateTransform(AffineTransform) - 类 java.awt.image.renderable.RenderContext 中的方法
已过时。 由 concatenateTransform(AffineTransform) 所替代。
concrete_base_type() - 类 org.omg.CORBA.TypeCode 中的方法
返回一个 TypeCode 对象，它描述此 TypeCode 对象所描述 value 类型的具体基本类型。
CONCUR_READ_ONLY - 接口 java.sql.ResultSet 中的静态变量
该常量指示不可以更新的 ResultSet 对象的并发模式。
CONCUR_UPDATABLE - 接口 java.sql.ResultSet 中的静态变量
该常量指示可以更新的 ResultSet 对象的并发模式。
ConcurrentHashMap<K,V> - java.util.concurrent 中的 类
支持获取的完全并发和更新的所期望可调整并发的哈希表。
ConcurrentHashMap(int, float, int) - 类 java.util.concurrent.ConcurrentHashMap 的构造方法
创建一个带有指定初始容量、加载因子和并发级别的新的空映射。
ConcurrentHashMap(int, float) - 类 java.util.concurrent.ConcurrentHashMap 的构造方法
创建一个带有指定初始容量、加载因子和默认 concurrencyLevel (16) 的新的空映射。
ConcurrentHashMap(int) - 类 java.util.concurrent.ConcurrentHashMap 的构造方法
创建一个带有指定初始容量、默认加载因子 (0.75) 和 concurrencyLevel (16) 的新的空映射。
ConcurrentHashMap() - 类 java.util.concurrent.ConcurrentHashMap 的构造方法
创建一个带有默认初始容量 (16)、加载因子 (0.75) 和 concurrencyLevel (16) 的新的空映射。
ConcurrentHashMap(Map<? extends K, ? extends V>) - 类 java.util.concurrent.ConcurrentHashMap 的构造方法
构造一个与给定映射具有相同映射关系的新映射。
ConcurrentLinkedQueue<E> - java.util.concurrent 中的 类
一个基于链接节点的无界线程安全队列。
ConcurrentLinkedQueue() - 类 java.util.concurrent.ConcurrentLinkedQueue 的构造方法
创建一个最初为空的 ConcurrentLinkedQueue。
ConcurrentLinkedQueue(Collection<? extends E>) - 类 java.util.concurrent.ConcurrentLinkedQueue 的构造方法
创建一个最初包含给定 collection 元素的 ConcurrentLinkedQueue，按照此 collection 迭代器的遍历顺序来添加元素。
ConcurrentMap<K,V> - java.util.concurrent 中的 接口
提供其他原子 putIfAbsent、remove、replace 方法的 Map。
ConcurrentModificationException - java.util 中的 异常
当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
ConcurrentModificationException() - 异常 java.util.ConcurrentModificationException 的构造方法
构造不带详细消息的 ConcurrentModificationException。
ConcurrentModificationException(String) - 异常 java.util.ConcurrentModificationException 的构造方法
构造带指定详细消息的 ConcurrentModificationException。
ConcurrentNavigableMap<K,V> - java.util.concurrent 中的 接口
支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。
ConcurrentSkipListMap<K,V> - java.util.concurrent 中的 类
可缩放的并发 ConcurrentNavigableMap 实现。
ConcurrentSkipListMap() - 类 java.util.concurrent.ConcurrentSkipListMap 的构造方法
构造一个新的空映射，该映射按照键的自然顺序进行排序。
ConcurrentSkipListMap(Comparator<? super K>) - 类 java.util.concurrent.ConcurrentSkipListMap 的构造方法
构造一个新的空映射，该映射按照指定的比较器进行排序。
ConcurrentSkipListMap(Map<? extends K, ? extends V>) - 类 java.util.concurrent.ConcurrentSkipListMap 的构造方法
构造一个新映射，该映射所包含的映射关系与给定映射包含的映射关系相同，并按照键的自然顺序进行排序。
ConcurrentSkipListMap(SortedMap<K, ? extends V>) - 类 java.util.concurrent.ConcurrentSkipListMap 的构造方法
构造一个新映射，该映射所包含的映射关系与指定的有序映射包含的映射关系相同，使用的顺序也相同。
ConcurrentSkipListSet<E> - java.util.concurrent 中的 类
一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
ConcurrentSkipListSet() - 类 java.util.concurrent.ConcurrentSkipListSet 的构造方法
构造一个新的空 set，该 set 按照元素的自然顺序对其进行排序。
ConcurrentSkipListSet(Comparator<? super E>) - 类 java.util.concurrent.ConcurrentSkipListSet 的构造方法
构造一个新的空 set，该 set 按照指定的比较器对其元素进行排序。
ConcurrentSkipListSet(Collection<? extends E>) - 类 java.util.concurrent.ConcurrentSkipListSet 的构造方法
构造一个包含指定 collection 中元素的新 set，这个新 set 按照元素的自然顺序对其进行排序。
ConcurrentSkipListSet(SortedSet<E>) - 类 java.util.concurrent.ConcurrentSkipListSet 的构造方法
构造一个新 set，该 set 所包含的元素与指定的有序 set 包含的元素相同，使用的顺序也相同。
Condition - java.util.concurrent.locks 中的 接口
Condition 将 Object 监视器方法（wait、notify 和 notifyAll）分解成截然不同的对象，以便通过将这些对象与任意 Lock 实现组合使用，为每个对象提供多个等待 set（wait-set）。
CONFIG - 类 java.util.logging.Level 中的静态变量
CONFIG 是用于静态配置消息的消息级别。
config(String) - 类 java.util.logging.Logger 中的方法
记录一条 CONFIG 消息。
Configuration - javax.security.auth.login 中的 类
Configuration 对象负责指定应该将哪一个 LoginModule 用于某一特定应用程序，以及应该以什么样的顺序调用 LoginModule。
Configuration() - 类 javax.security.auth.login.Configuration 的构造方法
唯一的构造方法。
Configuration.Parameters - javax.security.auth.login 中的 接口
此类表示 Configuration 参数的标记接口。
ConfigurationException - javax.naming 中的 异常
当存在配置问题时，抛出此异常。
ConfigurationException(String) - 异常 javax.naming.ConfigurationException 的构造方法
使用解释构造一个新的 ConfigurationException 实例。
ConfigurationException() - 异常 javax.naming.ConfigurationException 的构造方法
构造一个新的 ConfigurationException 实例，将解释和所有名称解析字段初始化为 null。
ConfigurationSpi - javax.security.auth.login 中的 类
此类为 Configuration 类定义服务提供者接口（SPI）。
ConfigurationSpi() - 类 javax.security.auth.login.ConfigurationSpi 的构造方法
configureArrowButton() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此公共方法是特定于实现的，应该为私有。
configureBlocking(boolean) - 类 java.nio.channels.SelectableChannel 中的方法
调整此通道的阻塞模式。
configureBlocking(boolean) - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
调整此通道的阻塞模式。
configureEditor(ComboBoxEditor, Object) - 类 javax.swing.JComboBox 中的方法
利用指定项初始化编辑器。
configureEditor() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
configureEditor() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
configureEnclosingScrollPane() - 类 javax.swing.JTable 中的方法
如果此 JTable 是一个封闭 JScrollPane 的 viewportView（通常情况如此），那么可通过安装表的 tableHeader 作为滚动窗格的 columnHeaderView 来配置此 ScrollPane。
configureLayoutCache() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
基于为其提供外观的树重置 TreeState 实例。
configureList() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
配置用于保存弹出部分中的组合框项的列表。
configurePopup() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
配置组合框的弹出部分。
configurePropertiesFromAction(Action) - 类 javax.swing.AbstractButton 中的方法
在此按钮上设置属性以匹配指定 Action 中的属性。
configurePropertiesFromAction(Action) - 类 javax.swing.JComboBox 中的方法
在此组合框上设置属性以匹配指定 Action 中的属性。
configurePropertiesFromAction(Action) - 类 javax.swing.JMenuItem 中的方法
在此按钮上设置属性以匹配指定 Action 中的属性。
configurePropertiesFromAction(Action) - 类 javax.swing.JTextField 中的方法
在此文本字段上设置属性，以匹配指定 Action 中的值。
configureScrollBarColors() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
configureScrollBarColors() - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
configureScroller() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
配置在组合框弹出控件中保存列表的可滚动部分。
ConfirmationCallback - javax.security.auth.callback 中的 类
底层安全服务实例化 ConfirmationCallback，并将其传递到 CallbackHandler 的 handle 方法，以请求 YES/NO、OK/CANCEL、YES/NO/CANCEL 或其他类似的确认信息。
ConfirmationCallback(int, int, int) - 类 javax.security.auth.callback.ConfirmationCallback 的构造方法
构造一个带有消息类型、选项类型和默认选项的 ConfirmationCallback。
ConfirmationCallback(int, String[], int) - 类 javax.security.auth.callback.ConfirmationCallback 的构造方法
构造一个带有消息类型、选项列表和默认选项的 ConfirmationCallback。
ConfirmationCallback(String, int, int, int) - 类 javax.security.auth.callback.ConfirmationCallback 的构造方法
构造一个带有提示、消息类型、选项类型和默认选项的 ConfirmationCallback。
ConfirmationCallback(String, int, String[], int) - 类 javax.security.auth.callback.ConfirmationCallback 的构造方法
构造一个带有提示、消息类型、选项列表和默认选项的 ConfirmationCallback。
connect(PipedOutputStream) - 类 java.io.PipedInputStream 中的方法
使此管道输入流连接到管道输出流 src。
connect(PipedInputStream) - 类 java.io.PipedOutputStream 中的方法
将此管道输出流连接到接收者。
connect(PipedWriter) - 类 java.io.PipedReader 中的方法
使此传送 reader 连接到传送 writer src。
connect(PipedReader) - 类 java.io.PipedWriter 中的方法
将此传送 writer 连接到接收方。
connect(InetAddress, int) - 类 java.net.DatagramSocket 中的方法
将套接字连接到此套接字的远程地址。
connect(SocketAddress) - 类 java.net.DatagramSocket 中的方法
将此套接字连接到远程套接字地址（IP 地址 + 端口号）。
connect(InetAddress, int) - 类 java.net.DatagramSocketImpl 中的方法
将数据报套接字连接到远程目标。
connect(SocketAddress) - 类 java.net.Socket 中的方法
将此套接字连接到服务器。
connect(SocketAddress, int) - 类 java.net.Socket 中的方法
将此套接字连接到服务器，并指定一个超时值。
connect(String, int) - 类 java.net.SocketImpl 中的方法
将此套接字连接到指定主机上的指定端口。
connect(InetAddress, int) - 类 java.net.SocketImpl 中的方法
将此套接字连接到指定主机上的指定端口号。
connect(SocketAddress, int) - 类 java.net.SocketImpl 中的方法
将此套接字连接到指定主机上的指定端口号。
connect() - 类 java.net.URLConnection 中的方法
打开到此 URL 引用的资源的通信链接（如果尚未建立这样的连接）。
connect(SocketAddress) - 类 java.nio.channels.DatagramChannel 中的方法
连接此通道的套接字。
connect(SocketAddress) - 类 java.nio.channels.SocketChannel 中的方法
连接此通道的套接字。
connect(String, Properties) - 接口 java.sql.Driver 中的方法
试图创建一个到给定 URL 的数据库连接。
connect() - 接口 javax.management.remote.JMXConnector 中的方法
建立到连接器服务器的连接。
connect(Map<String, ?>) - 接口 javax.management.remote.JMXConnector 中的方法
建立到连接器服务器的连接。
connect(JMXServiceURL) - 类 javax.management.remote.JMXConnectorFactory 中的静态方法
创建到位于给定地址的连接器服务器的连接。
connect(JMXServiceURL, Map<String, ?>) - 类 javax.management.remote.JMXConnectorFactory 中的静态方法
创建到位于给定地址的连接器服务器的连接。
connect() - 类 javax.management.remote.rmi.RMIConnector 中的方法
connect(Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnector 中的方法
connect(Remote, Remote) - 接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 中的方法
PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 的委托调用。
connect(ORB) - 类 javax.rmi.CORBA.Stub 中的方法
将此 stub 连接到 ORB。
connect(Stub, ORB) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.connect(org.omg.CORBA.ORB) 的委托调用。
connect(Remote, Remote) - 类 javax.rmi.PortableRemoteObject 中的静态方法
使 Remote 对象准备好进行远程通信。
connect(Object) - 类 org.omg.CORBA.ORB 中的方法
将给定 servant 对象（作为服务器实现类的实例的 Java 对象）连接到 ORB。
connected - 类 java.net.URLConnection 中的变量
如果为 false，则此连接对象尚未创建到指定 URL 的通信链接。
ConnectException - java.net 中的 异常
试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
ConnectException(String) - 异常 java.net.ConnectException 的构造方法
构造一个新的 ConnectException，使其具有关于连接错误产生原因的指定详细消息。
ConnectException() - 异常 java.net.ConnectException 的构造方法
构造不带详细信息的新 ConnectException。
ConnectException - java.rmi 中的 异常
如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
ConnectException(String) - 异常 java.rmi.ConnectException 的构造方法
构造带指定详细消息的 ConnectException。
ConnectException(String, Exception) - 异常 java.rmi.ConnectException 的构造方法
构造带指定详细消息和嵌入异常的 ConnectException。
connectFailed(URI, SocketAddress, IOException) - 类 java.net.ProxySelector 中的方法
调用此方法来指示无法建立到代理/socks 服务器的连接。
CONNECTING_TO_DEVICE - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
打印机已经在输出设备中安排了作业，并且正在与共享的网络输出设备进行连接（并且可能在相当长的时间内无法实际开始打印作业，因为这取决于网络上其他服务器对该输出设备的使用情况）。
ConnectIOException - java.rmi 中的 异常
如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
ConnectIOException(String) - 异常 java.rmi.ConnectIOException 的构造方法
构造带指定详细消息的 ConnectIOException。
ConnectIOException(String, Exception) - 异常 java.rmi.ConnectIOException 的构造方法
构造带指定详细消息和嵌入异常的 ConnectIOException。
Connection - java.sql 中的 接口
与特定数据库的连接（会话）。
connectionClosed(String, String, Object) - 类 javax.management.remote.JMXConnectorServer 中的方法
正常关闭客户端连接时由子类调用。
connectionClosed(String, String, Object) - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
connectionClosed(ConnectionEvent) - 接口 javax.sql.ConnectionEventListener 中的方法
通知此 ConnectionEventListener 应用程序已对其入池连接的表示形式调用 close 方法。
connectionErrorOccurred(ConnectionEvent) - 接口 javax.sql.ConnectionEventListener 中的方法
通知此 ConnectionEventListener 发生了严重错误，入池连接不再可用。
ConnectionEvent - javax.sql 中的 类
提供关于连接相关事件的源信息的 Event 对象。
ConnectionEvent(PooledConnection) - 类 javax.sql.ConnectionEvent 的构造方法
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象进行初始化。
ConnectionEvent(PooledConnection, SQLException) - 类 javax.sql.ConnectionEvent 的构造方法
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象和 SQLException 对象进行初始化。
ConnectionEventListener - javax.sql 中的 接口
注册该对象便可获得由 PooledConnection 对象生成的事件的通知。
connectionFailed(String, String, Object) - 类 javax.management.remote.JMXConnectorServer 中的方法
客户端连接失败时由子类调用。
connectionFailed(String, String, Object) - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
connectionOpened(String, String, Object) - 类 javax.management.remote.JMXConnectorServer 中的方法
打开新的客户端连接时由子类调用。
connectionOpened(String, String, Object) - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
ConnectionPendingException - java.nio.channels 中的 异常
试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
ConnectionPendingException() - 异常 java.nio.channels.ConnectionPendingException 的构造方法
构造此类的一个实例。
ConnectionPoolDataSource - javax.sql 中的 接口
PooledConnection 对象的工厂。
CONNECTOR_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Pc”。
CONREF - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Console - java.io 中的 类
此类包含多个方法，可访问与当前 Java 虚拟机关联的基于字符的控制台设备（如果有）。
console() - 类 java.lang.System 中的静态方法
返回与当前 Java 虚拟机关联的唯一 Console 对象（如果有）。
ConsoleHandler - java.util.logging 中的 类
此 Handler 向 System.err 发布日志记录。
ConsoleHandler() - 类 java.util.logging.ConsoleHandler 的构造方法
为 System.err 创建一个 ConsoleHandler。
constant(int) - 类 javax.swing.Spring 中的静态方法
返回一个 strut -- 一个其 minimum、preferred 和 maximum 值每个都有值 pref 的 spring。
constant(int, int, int) - 类 javax.swing.Spring 中的静态方法
返回一个其 minimum、preferred 和 maximum 值具有以下值的 spring：分别是 min、pref 和 max。
constantName() - 异常 java.lang.EnumConstantNotPresentException 中的方法
返回缺少的枚举常量的名称。
constraintBeforeFloating - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
Constructor<T> - java.lang.reflect 中的 类
Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
ConstructorProperties - java.beans 中的 注释类型
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。
constructorsIn(Iterable<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
elements 中构造方法的列表。
constructorsIn(Set<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中构造方法的集合。
consume() - 类 java.awt.AWTEvent 中的方法
如果能够使用此事件，则使用此事件。
consume() - 类 java.awt.event.InputEvent 中的方法
使用此事件，以便不会按照默认的方式由产生此事件的源代码来处理此事件。
consume() - 类 java.awt.event.InputMethodEvent 中的方法
使用此事件，以便不会按默认方式由产生此事件的源代码来处理此事件。
consumed - 类 java.awt.AWTEvent 中的变量
在源处理了事件之后，控制是否将事件发送回同位体，false 表示将事件发送给同位体；true 则不发送。
consumer - 类 java.awt.image.ImageFilter 中的变量
特定图像数据流的使用者，而此 ImageFilter 实例也是为这个使用者来过滤数据的。
containedIn(Oid[]) - 类 org.ietf.jgss.Oid 中的方法
一种实用工具方法，可测试此 Oid 值是否包含在所提供的 Oid 数组中。
Container - java.awt 中的 类
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Container() - 类 java.awt.Container 的构造方法
构造一个新的 Container。
Container.AccessibleAWTContainer - java.awt 中的 类
用于对可访问性提供默认支持的 Container 内部类。
Container.AccessibleAWTContainer() - 类 java.awt.Container.AccessibleAWTContainer 的构造方法
Container.AccessibleAWTContainer.AccessibleContainerHandler - java.awt 中的 类
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
Container.AccessibleAWTContainer.AccessibleContainerHandler() - 类 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler 的构造方法
CONTAINER_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择容器事件的事件掩码。
CONTAINER_FIRST - 类 java.awt.event.ContainerEvent 中的静态变量
用于容器事件的 id 范围的起始编号。
CONTAINER_LAST - 类 java.awt.event.ContainerEvent 中的静态变量
用于容器事件的 id 范围的结束编号。
ContainerAdapter - java.awt.event 中的 类
用于接收容器事件的抽象适配器类。
ContainerAdapter() - 类 java.awt.event.ContainerAdapter 的构造方法
ContainerEvent - java.awt.event 中的 类
指示容器内容因为添加或移除组件而更改的低级别事件。
ContainerEvent(Component, int, Component) - 类 java.awt.event.ContainerEvent 的构造方法
构造一个 ContainerEvent 对象。
ContainerListener - java.awt.event 中的 接口
用于接收容器事件的侦听器接口。
containerListener - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的变量
ContainerOrderFocusTraversalPolicy - java.awt 中的 类
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
ContainerOrderFocusTraversalPolicy() - 类 java.awt.ContainerOrderFocusTraversalPolicy 的构造方法
contains(Point) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
检查指定的点是否在此对象的边界内，该点的 x 坐标和 y 坐标是相对于该对象的坐标系来定义的。
contains(int, int) - 类 java.awt.Component 中的方法
检查组件是否“包含”指定的点，其中 x 和 y 是相对于此组件的坐标系定义的。
contains(Point) - 类 java.awt.Component 中的方法
检查组件是否“包含”指定的点，其中该点的 x 和 y 坐标是相对于此组件的坐标系定义的。
contains(double, double) - 类 java.awt.geom.Arc2D 中的方法
确定指定的点是否位于弧的边界内。
contains(double, double, double, double) - 类 java.awt.geom.Arc2D 中的方法
确定弧的内部是否完全包含指定的矩形。
contains(Rectangle2D) - 类 java.awt.geom.Arc2D 中的方法
确定弧的内部是否完全包含指定的矩形。
contains(double, double) - 类 java.awt.geom.Area 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 类 java.awt.geom.Area 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.Area 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 类 java.awt.geom.Area 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(double, double) - 类 java.awt.geom.CubicCurve2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 类 java.awt.geom.CubicCurve2D 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.CubicCurve2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 类 java.awt.geom.CubicCurve2D 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(double, double) - 类 java.awt.geom.Ellipse2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.Ellipse2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(double, double) - 类 java.awt.geom.Line2D 中的方法
测试指定坐标是否在此 Line2D 对象的边界内。
contains(Point2D) - 类 java.awt.geom.Line2D 中的方法
测试给定 Point2D 是否在此 Line2D 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.Line2D 中的方法
测试此 Line2D 的内部是否完全包含指定矩形坐标集。
contains(Rectangle2D) - 类 java.awt.geom.Line2D 中的方法
测试此 Line2D 内部是否完全包含指定的 Rectangle2D。
contains(PathIterator, double, double) - 类 java.awt.geom.Path2D 中的静态方法
测试指定的坐标是否在指定 PathIterator 的封闭边界内。
contains(PathIterator, Point2D) - 类 java.awt.geom.Path2D 中的静态方法
测试指定的 Point2D 是否在指定 PathIterator 的封闭边界内。
contains(double, double) - 类 java.awt.geom.Path2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 类 java.awt.geom.Path2D 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(PathIterator, double, double, double, double) - 类 java.awt.geom.Path2D 中的静态方法
测试指定矩形区域是否完全在指定 PathIterator 的封闭边界内。
contains(PathIterator, Rectangle2D) - 类 java.awt.geom.Path2D 中的静态方法
测试指定的 Rectangle2D 是否完全在指定 PathIterator 的封闭区域内。
contains(double, double, double, double) - 类 java.awt.geom.Path2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 类 java.awt.geom.Path2D 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(double, double) - 类 java.awt.geom.QuadCurve2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 类 java.awt.geom.QuadCurve2D 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.QuadCurve2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 类 java.awt.geom.QuadCurve2D 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(double, double) - 类 java.awt.geom.Rectangle2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.Rectangle2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Point2D) - 类 java.awt.geom.RectangularShape 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(Rectangle2D) - 类 java.awt.geom.RectangularShape 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(double, double) - 类 java.awt.geom.RoundRectangle2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.RoundRectangle2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Point) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
检查指定点是否位于此对象的界限中，其中该点的 X 坐标和 Y 坐标是相对于对象的定义的。
contains(Point) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系相关。
contains(Point) - 类 java.awt.Polygon 中的方法
确定指定的 Point 是否位于此 Polygon 的内部。
contains(int, int) - 类 java.awt.Polygon 中的方法
确定指定的坐标是否位于此 Polygon 的内部。
contains(double, double) - 类 java.awt.Polygon 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 类 java.awt.Polygon 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.Polygon 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 类 java.awt.Polygon 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(Point) - 类 java.awt.Rectangle 中的方法
检查此 Rectangle 是否包含指定的 Point。
contains(int, int) - 类 java.awt.Rectangle 中的方法
检查此 Rectangle 是否包含位于指定位置 (x,y) 的点。
contains(Rectangle) - 类 java.awt.Rectangle 中的方法
检查此 Rectangle 是否完全包含指定的 Rectangle。
contains(int, int, int, int) - 类 java.awt.Rectangle 中的方法
检查此 Rectangle 是否完全包含位于指定位置 (X,Y) 且具有指定维数 (W,H) 的 Rectangle。
contains(double, double) - 接口 java.awt.Shape 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 接口 java.awt.Shape 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(double, double, double, double) - 接口 java.awt.Shape 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 接口 java.awt.Shape 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(Object) - 类 java.beans.beancontext.BeanContextMembershipEvent 中的方法
指定子级受事件影响吗？
contains(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
确定指定对象当前是否是此 BeanContext 的子级。
contains(CharSequence) - 类 java.lang.String 中的方法
当且仅当此字符串包含指定的 char 值序列时，返回 true。
contains(Charset) - 类 java.nio.charset.Charset 中的方法
通知此 charset 是否包含给定的 charset。
contains(Object) - 类 java.util.AbstractCollection 中的方法
如果此 collection 包含指定的元素，则返回 true。
contains(Object) - 类 java.util.ArrayDeque 中的方法
如果此双端队列包含指定元素，则返回 true。
contains(Object) - 类 java.util.ArrayList 中的方法
如果此列表中包含指定的元素，则返回 true。
contains(Object) - 接口 java.util.Collection 中的方法
如果此 collection 包含指定的元素，则返回 true。
contains(Object) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
如果此队列包含指定的元素，则返回 true。
contains(Object) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果此双端队列包含指定的元素，则返回 true。
contains(Object) - 接口 java.util.concurrent.BlockingQueue 中的方法
如果此队列包含指定元素，则返回 true。
contains(Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
一种遗留方法，测试此表中是否有一些与指定值存在映射关系的键。
contains(Object) - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
如果此队列包含指定元素，则返回 true。
contains(Object) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
如果此 set 包含指定的元素，则返回 true。
contains(Object) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
如果此列表包含指定的元素，则返回 true。
contains(Object) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果此 set 包含指定元素，则返回 true。
contains(Object) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
如果此双端队列包含指定的元素，则返回 true。
contains(Object) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
如果队列包含指定的元素，则返回 true。
contains(Object) - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 false。
contains(Object) - 接口 java.util.Deque 中的方法
如果此双端队列包含指定元素，则返回 true。
contains(Object) - 类 java.util.HashSet 中的方法
如果此 set 包含指定元素，则返回 true。
contains(Object) - 类 java.util.Hashtable 中的方法
测试此映射表中是否存在与指定值关联的键。
contains(Object) - 类 java.util.LinkedList 中的方法
如果此列表包含指定元素，则返回 true。
contains(Object) - 接口 java.util.List 中的方法
如果列表包含指定的元素，则返回 true。
contains(Object) - 类 java.util.PriorityQueue 中的方法
如果此队列包含指定的元素，则返回 true。
contains(Object) - 接口 java.util.Set 中的方法
如果 set 包含指定的元素，则返回 true。
contains(Object) - 类 java.util.TreeSet 中的方法
如果此 set 包含指定的元素，则返回 true。
contains(Object) - 类 java.util.Vector 中的方法
如果此向量包含指定的元素，则返回 true。
contains(Point) - 接口 javax.accessibility.AccessibleComponent 中的方法
检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
contains(String) - 类 javax.accessibility.AccessibleRelationSet 中的方法
返回关系集是否包含与指定键匹配的关系。
contains(AccessibleState) - 类 javax.accessibility.AccessibleStateSet 中的方法
检查当前状态是否在状态集中。
contains(Object) - 类 javax.imageio.spi.ServiceRegistry 中的方法
如果当前注册了 provider，则返回 true。
contains(TypeMirror, TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
测试一个类型参数是否包含 另一个类型参数。
contains(Object) - 接口 javax.naming.directory.Attribute 中的方法
确定某个值是否在属性中。
contains(Object) - 类 javax.naming.directory.BasicAttribute 中的方法
确定值是否在此属性中。
contains(int) - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
确定此整数集属性是否包含给定的值。
contains(IntegerSyntax) - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
确定此整数集属性是否包含给定的整数属性的值。
contains(Object) - 类 javax.swing.DefaultListModel 中的方法
测试指定对象是否为此类表中的组件。
contains(int, int) - 类 javax.swing.JComponent 中的方法
为了进行鼠标处理，让 UI 委托来定义此组件的精确形状。
contains(Point) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
contains(Point) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系统相关。
contains(Point) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
contains(Object) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
contains(JComponent, int, int) - 类 javax.swing.plaf.ComponentUI 中的方法
如果指定 x,y 位置包含在指定组件外观的已定义形状中，则返回 true。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(Point) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
contains(String) - 接口 org.w3c.dom.DOMStringList 中的方法
测试一个字符串是否是此 DOMStringList 的一部分。
contains(String) - 接口 org.w3c.dom.NameList 中的方法
测试名称是否是此 NameList 中的一部分。
containsAlias(String) - 类 java.security.KeyStore 中的方法
检查给定别名是否存在于此 keystore 中。
containsAll(Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
测试以查看指定 Collection 中的所有对象是否是此 BeanContext 的子对象。
containsAll(Collection<?>) - 类 java.util.AbstractCollection 中的方法
如果此 collection 包含指定 collection 中的所有元素，则返回 true。
containsAll(Collection<?>) - 接口 java.util.Collection 中的方法
如果此 collection 包含指定 collection 中的所有元素，则返回 true。
containsAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
如果此列表包含指定 collection 的所有元素，则返回 true。
containsAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果此 set 包含指定 collection 的所有元素，则返回 true。
containsAll(Collection<?>) - 类 java.util.concurrent.SynchronousQueue 中的方法
除非给定 collection 为空，否则返回 false。
containsAll(Collection<?>) - 接口 java.util.List 中的方法
如果列表包含指定 collection 的所有元素，则返回 true。
containsAll(Collection<?>) - 接口 java.util.Set 中的方法
如果此 set 包含指定 collection 的所有元素，则返回 true。
containsAll(Collection<?>) - 类 java.util.Vector 中的方法
如果此向量包含指定 Collection 中的所有元素，则返回 true。
containsAngle(double) - 类 java.awt.geom.Arc2D 中的方法
确定指定的角度是否位于弧的角跨越内。
containsAttribute(Object, Object) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
检查是否定义了给定的属性名称/值。
containsAttribute(Object, Object) - 接口 javax.swing.text.AttributeSet 中的方法
如果此集合用相同的名称和相等值定义一个属性，则返回 true 。
containsAttribute(Object, Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
检查属性列表中是否包含了指定的属性名称/值对。
containsAttribute(Object, Object) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
确定给定的属性名称/值是否已定义。
containsAttribute(Object, Object) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
检查给定的属性名称/值是否已定义。
containsAttributes(AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
检查该元素是否包含所有的属性。
containsAttributes(AttributeSet) - 接口 javax.swing.text.AttributeSet 中的方法
如果此集合用相等值定义给定集合中的所有属性，则返回 true。
containsAttributes(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 中的方法
确定属性列表中是否包含所有指定的名称/值对。
containsAttributes(AttributeSet) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
检查元素是否包含了所有属性。
containsAttributes(AttributeSet) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
检查属性集是否包含了所有给定的属性。
containsCustomComponents(JOptionPane) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
如果在上一次对 validateComponent 的调用中消息或按钮包含 Component 的子类，则返回 true。
containsCustomComponents(JOptionPane) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 containsCustomComponents 方法。
containsCustomComponents(JOptionPane) - 类 javax.swing.plaf.OptionPaneUI 中的方法
如果用户已经为选项或消息提供 Component 实例，则返回 true。
containsKey(Object) - 类 java.awt.RenderingHints 中的方法
如果此 RenderingHints 包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
确定指定对象当前是否是此 BeanContext 的子级。
containsKey(Object) - 类 java.util.AbstractMap 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
测试指定对象是否为此表中的键。
containsKey(Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.util.EnumMap 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.util.HashMap 中的方法
如果此映射包含对于指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.util.Hashtable 中的方法
测试指定对象是否为此哈希表中的键。
containsKey(Object) - 类 java.util.IdentityHashMap 中的方法
测试指定的对象引用是否为此标识哈希映射中的键。
containsKey(Object) - 类 java.util.jar.Attributes 中的方法
如果此 Map 包含指定的属性名称（键），则返回 true。
containsKey(Object) - 接口 java.util.Map 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(String) - 类 java.util.ResourceBundle 中的方法
确定给定 key 是否包含在此 ResourceBundle 及其父包中。
containsKey(Object) - 类 java.util.TreeMap 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.util.WeakHashMap 中的方法
如果此映射对于指定的键包含映射关系，则返回 true。
containsKey(String) - 接口 javax.management.openmbean.CompositeData 中的方法
当且仅当此 CompositeData 实例包含名称为 key 的项时，返回 true。
containsKey(String) - 类 javax.management.openmbean.CompositeDataSupport 中的方法
当且仅当此 CompositeData 实例包含名称是 key 的项时，才返回 true。
containsKey(String) - 类 javax.management.openmbean.CompositeType 中的方法
如果此 CompositeType 实例定义了名称为 itemName 的项，则返回 true。
containsKey(Object[]) - 接口 javax.management.openmbean.TabularData 中的方法
当且仅当此 TabularData 实例包含其索引为指定 key 的 CompositeData 值（即行）时，才返回 true。
containsKey(Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。
containsKey(Object[]) - 类 javax.management.openmbean.TabularDataSupport 中的方法
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。
containsKey(Class<?>) - 接口 javax.print.attribute.AttributeSet 中的方法
如果此属性集包含指定类别的一个属性，则返回 true。
containsKey(Class<?>) - 类 javax.print.attribute.HashAttributeSet 中的方法
如果此属性集包含指定类别的属性，则返回 true。
containsKey(Object) - 接口 javax.script.Bindings 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 javax.script.SimpleBindings 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsNS(String, String) - 接口 org.w3c.dom.NameList 中的方法
测试 namespaceURI/name 对是否是此 NameList 中的一部分。
containsObservedObject(ObjectName) - 类 javax.management.monitor.Monitor 中的方法
测试指定的对象是否在所观察的 MBean 集中。
containsObservedObject(ObjectName) - 接口 javax.management.monitor.MonitorMBean 中的方法
测试指定的对象是否在所观察的 MBean 集中。
containsValue(Object) - 类 java.awt.RenderingHints 中的方法
如果此 RenderingHints 将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.AbstractMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
如果此映射为指定值映射一个或多个键，则返回 true。
containsValue(Object) - 类 java.util.EnumMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.HashMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.Hashtable 中的方法
如果此 Hashtable 将一个或多个键映射到此值，则返回 true。
containsValue(Object) - 类 java.util.IdentityHashMap 中的方法
测试指定的对象引用是否为此标识哈希映射中的值。
containsValue(Object) - 类 java.util.jar.Attributes 中的方法
如果此 Map 将一个或多个属性名称（键）映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.LinkedHashMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 接口 java.util.Map 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.TreeMap 中的方法
如果此映射为指定值映射一个或多个键，则返回 true。
containsValue(Object) - 类 java.util.WeakHashMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 接口 javax.management.openmbean.CompositeData 中的方法
当且仅当此 CompositeData 实例包含值为 value 的项时，返回 true。
containsValue(Object) - 类 javax.management.openmbean.CompositeDataSupport 中的方法
当且仅当此 CompositeData 实例包含其值是 value 的项时，返回 true。
containsValue(CompositeData) - 接口 javax.management.openmbean.TabularData 中的方法
当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。
containsValue(CompositeData) - 类 javax.management.openmbean.TabularDataSupport 中的方法
当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。
containsValue(Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
当且仅当此 TabularData 实例包含指定的值时，才返回 true。
containsValue(Attribute) - 接口 javax.print.attribute.AttributeSet 中的方法
如果此属性集包含给定的属性值，则返回 true。
containsValue(Attribute) - 类 javax.print.attribute.HashAttributeSet 中的方法
如果此属性集包含给定的属性，则返回 true。
containsValue(Object) - 类 javax.script.SimpleBindings 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
CONTENT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
CONTENT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
所有文本内容以此标记作为标签。
content - 类 javax.swing.text.html.parser.ContentModel 中的变量
内容。
content - 类 javax.swing.text.html.parser.Element 中的变量
CONTENT_AREA_FILLED_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对按钮绘制的内容区域的更改。
CONTENT_PANE_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
CONTENT_TYPE - 类 java.util.jar.Attributes.Name 中的静态变量
Content-Type 的 Name 对象具有的属性。
content_type() - 类 org.omg.CORBA.TypeCode 中的方法
返回表示此 TypeCode 对象所描述成员 IDL 类型的 TypeCode 对象。
contentBorderInsets - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
ContentElementName - 类 javax.swing.text.AbstractDocument 中的静态变量
用于表示内容的元素名
contentEquals(StringBuffer) - 类 java.lang.String 中的方法
将此字符串与指定的 StringBuffer 比较。
contentEquals(CharSequence) - 类 java.lang.String 中的方法
将此字符串与指定的 CharSequence 比较。
contentEquals(CharSequence) - 接口 javax.lang.model.element.Name 中的方法
将此名称与指定的 CharSequence 进行比较。
ContentHandler - java.net 中的 类
抽象类 ContentHandler 是从 URLConnection 读取 Object 的所有类的超类。
ContentHandler() - 类 java.net.ContentHandler 的构造方法
ContentHandler - org.xml.sax 中的 接口
接收文档逻辑内容的通知。
ContentHandlerFactory - java.net 中的 接口
此接口定义内容处理程序的工厂。
ContentModel - javax.swing.text.html.parser 中的 类
内容模式的表示形式。
ContentModel() - 类 javax.swing.text.html.parser.ContentModel 的构造方法
ContentModel(Element) - 类 javax.swing.text.html.parser.ContentModel 的构造方法
为元素创建一个内容模式。
ContentModel(int, ContentModel) - 类 javax.swing.text.html.parser.ContentModel 的构造方法
创建一个特定类型的内容模式。
ContentModel(int, Object, ContentModel) - 类 javax.swing.text.html.parser.ContentModel 的构造方法
创建一个特定类型的内容模式。
contentPane - 类 javax.swing.JRootPane 中的变量
内容窗格。
contentRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
contents - 类 java.awt.datatransfer.Clipboard 中的变量
CONTENTS_CHANGED - 类 javax.swing.event.ListDataEvent 中的静态变量
标识列表内容中的一处或多处更改。
contentsChanged(ListDataEvent) - 接口 javax.swing.event.ListDataListener 中的方法
在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。
contentsChanged(ListDataEvent) - 类 javax.swing.JComboBox 中的方法
此方法作为实现的副作用存在的公共方法。
contentsChanged(ListDataEvent) - 类 javax.swing.JList.AccessibleJList 中的方法
List Data Listener 内容更改方法。
contentsChanged(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 中的方法
contentsChanged(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 中的方法
contentsChanged(ListDataEvent) - 类 javax.swing.plaf.basic.BasicListUI.ListDataHandler 中的方法
contentsLost() - 类 java.awt.Component.BltBufferStrategy 中的方法
contentsLost() - 类 java.awt.Component.FlipBufferStrategy 中的方法
contentsLost() - 类 java.awt.image.BufferStrategy 中的方法
返回上次调用 getDrawGraphics 后绘制缓冲区是否丢失。
contentsLost() - 类 java.awt.image.VolatileImage 中的方法
如果上次调用 validate 后呈现数据丢失，则返回 true。
contentsRestored() - 类 java.awt.Component.BltBufferStrategy 中的方法
contentsRestored() - 类 java.awt.Component.FlipBufferStrategy 中的方法
contentsRestored() - 类 java.awt.image.BufferStrategy 中的方法
返回绘制缓冲区最近是否从丢失状态恢复，并重新初始化为默认背景色（白色）。
ContentType - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getType 的可能值。
context - 类 java.awt.dnd.DropTargetEvent 中的变量
与此 DropTargetEvent 相关的 DropTargetContext。
Context - javax.naming 中的 接口
此接口表示一个命名上下文，它由一组名称到对象的绑定组成。
context - 类 javax.script.AbstractScriptEngine 中的变量
此 AbstractScriptEngine 的默认 ScriptContext。
Context - org.omg.CORBA 中的 类
用于在 Request 操作中指定上下文对象的对象，上下文字符串在与请求调用一起被发送之前，必须在该指定的上下文对象中进行解析。
Context() - 类 org.omg.CORBA.Context 的构造方法
context_data - 类 org.omg.IOP.ServiceContext 中的变量
与此服务上下文关联的数据
CONTEXT_EXPIRED - 异常 org.ietf.jgss.GSSException 中的静态变量
安全上下文过期。
context_id - 类 org.omg.IOP.ServiceContext 中的变量
服务上下文 id
context_name() - 类 org.omg.CORBA.Context 中的方法
检索此 Context 对象的名称。
ContextList - org.omg.CORBA 中的 类
一个对象，它包含表示属性名称的 String 对象所组成的可修改列表。
ContextList() - 类 org.omg.CORBA.ContextList 的构造方法
ContextNotEmptyException - javax.naming 中的 异常
当试图销毁一个不为空的上下文时，抛出此异常。
ContextNotEmptyException(String) - 异常 javax.naming.ContextNotEmptyException 的构造方法
使用解释构造一个新的 ContextNotEmptyException 实例。
ContextNotEmptyException() - 异常 javax.naming.ContextNotEmptyException 的构造方法
构造一个新的 ContextNotEmptyException 实例，将解释和所有名称解析字段初始化为 null。
contexts() - 类 org.omg.CORBA.Request 中的方法
检索用于此请求的 ContextList 对象。
contexts() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回一个 String 对象数组，这些对象描述可以在此操作调用上传递的上下文。
ContextualRenderedImageFactory - java.awt.image.renderable 中的 接口
ContextualRenderedImageFactory 为在 RenderableImageOp 实例之间可能不同的功能提供接口。
CONTIGUOUS_TREE_SELECTION - 接口 javax.swing.tree.TreeSelectionModel 中的静态变量
选择只能是连续的。
CONTINUE - 类 javax.sound.midi.ShortMessage 中的静态变量
CONTINUE 消息的状态字节（0xFB 或 251）。
continueDrag(int, int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
continueDrag(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
用鼠标事件的新位置传递 dragDividerTo 的消息。
CONTINUOUS_LAYOUT_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 continuousLayout 属性名称。
continuousLayout - 类 javax.swing.JSplitPane 中的变量
当调整大小时视图是否连续重新显示。
contListener - 类 javax.swing.plaf.metal.MetalToolBarUI 中的变量
此受保护的字段是特定于实现的。
CONTROL - 类 java.awt.SystemColor 中的静态变量
SystemColor.control 系统颜色的数组索引。
control - 类 java.awt.SystemColor 中的静态变量
为控制面板和控制对象（比如按钮）提供的颜色。
CONTROL - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Cc”。
Control - javax.naming.ldap 中的 接口
此接口表示在 RFC 2251 中定义的 LDAPv3 控件。
Control - javax.sound.sampled 中的 类
Line 常常具有一个控件（如 gain 和 pan）集合，这些控件都会影响通过行传递的音频信号。
Control(Control.Type) - 类 javax.sound.sampled.Control 的构造方法
构造具有指定类型的控件。
Control.Type - javax.sound.sampled 中的 类
Type 类的实例表示控件的类型。
Control.Type(String) - 类 javax.sound.sampled.Control.Type 的构造方法
构造具有指定名称的新控件类型。
CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
指示显示控制按钮。
CONTROL_CHANGE - 类 javax.sound.midi.ShortMessage 中的静态变量
CONTROL_CHANGE 消息的命令值（0xB0 或 176）
CONTROL_DK_SHADOW - 类 java.awt.SystemColor 中的静态变量
SystemColor.controlDkShadow 系统颜色的数组索引。
CONTROL_FACTORIES - 接口 javax.naming.ldap.LdapContext 中的静态变量
该常量保存用来指定要使用的控件工厂列表的环境属性名称。
CONTROL_HIGHLIGHT - 类 java.awt.SystemColor 中的静态变量
SystemColor.controlHighlight 系统颜色的数组索引。
CONTROL_LT_HIGHLIGHT - 类 java.awt.SystemColor 中的静态变量
SystemColor.controlLtHighlight 系统颜色的数组索引。
CONTROL_PICTURES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Control Pictures”Unicode 字符块的常量。
CONTROL_SHADOW - 类 java.awt.SystemColor 中的静态变量
SystemColor.controlShadow 系统颜色的数组索引。
CONTROL_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.controlText 系统颜色的数组索引。
controlChange(ShortMessage) - 接口 javax.sound.midi.ControllerEventListener 中的方法
当 Sequencer 遇到并处理了一个此侦听器需要的控制更改事件时调用。
controlChange(int, int) - 接口 javax.sound.midi.MidiChannel 中的方法
对指定控件的值的更改作出反应。
controlDkShadow - 类 java.awt.SystemColor 中的静态变量
为 3D 控制对象（比如按钮）的加黑阴影区域提供的颜色。
controlDown() - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
ControlFactory - javax.naming.ldap 中的 类
此抽象类表示用于创建 LDAPv3 控件的工厂。
ControlFactory() - 类 javax.naming.ldap.ControlFactory 的构造方法
controlHighlight - 类 java.awt.SystemColor 中的静态变量
为 3D 控制对象（比如按钮）的亮区提供的颜色。
CONTROLLED_BY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象由一个或多个目标对象控制。
CONTROLLED_BY_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
标识正在进行控制操作的目标对象已更改
controller - 类 javax.imageio.IIOParam 中的变量
调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的 IIOParamController。
controller - 类 javax.imageio.metadata.IIOMetadata 中的变量
调用 activateController 方法时，将用来为此 IIOMetadataController 对象提供设置值的 IIOParamController。
CONTROLLER_FOR - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个目标对象的控制器。
CONTROLLER_FOR_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
标识目标对象的控制器已更改
ControllerEventListener - javax.sound.midi 中的 接口
ControllerEventListener 接口应由一个其实例需要在 Sequencer 处理了请求的 MIDI 控制更改事件类型时接收通知的类实现。
controlLtHighlight - 类 java.awt.SystemColor 中的静态变量
为 3D 控制对象（比如按钮）的高亮区域提供的颜色。
controlShadow - 类 java.awt.SystemColor 中的静态变量
为 3D 控制对象（比如按钮）的阴影区域提供的颜色。
controlText - 类 java.awt.SystemColor 中的静态变量
为控制面板和控制对象（比如按钮）的文本提供的颜色。
convert(long, TimeUnit) - 枚举 java.util.concurrent.TimeUnit 中的方法
将给定单元的时间段转换到此单元。
convertColumnIndexToModel(int) - 类 javax.swing.JTable 中的方法
将视图中位于 viewColumnIndex 的列索引映射到表模型中的列索引。
convertColumnIndexToView(int) - 类 javax.swing.JTable 中的方法
将表模型中位于 modelColumnIndex 的列索引映射到视图中的列索引。
CONVERTED_TEXT - 类 java.awt.im.InputMethodHighlight 中的静态变量
已转换文本状态的常量。
convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam) - 接口 javax.imageio.ImageTranscoder 中的方法
返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
convertMouseEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
convertMouseEvent(Component, MouseEvent, Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回类似于 sourceEvent 的 MouseEvent，除了其 x 和 y 成员已转换到 destination 的坐标系统。
convertPoint(Component, Point, Component) - 类 javax.swing.SwingUtilities 中的静态方法
将 source 坐标系统中的 aPoint 转换到 destination 坐标系统。
convertPoint(Component, int, int, Component) - 类 javax.swing.SwingUtilities 中的静态方法
将 source 坐标系统中的点 (x,y) 转换到 destination 坐标系统。
convertPointFromScreen(Point, Component) - 类 javax.swing.SwingUtilities 中的静态方法
将一个点从屏幕坐标转换到组件的坐标系统
convertPointToScreen(Point, Component) - 类 javax.swing.SwingUtilities 中的静态方法
将一个点从组件的坐标系统转换到屏幕坐标。
convertPreviousRowIndexToModel(int) - 类 javax.swing.event.RowSorterEvent 中的方法
返回基于模型排序之前的 index 的位置。
convertRectangle(Component, Rectangle, Component) - 类 javax.swing.SwingUtilities 中的静态方法
将 source 坐标系统中的矩形 aRectangle 转换到 destination 坐标系统。
convertRowIndexToModel(int) - 类 javax.swing.DefaultRowSorter 中的方法
返回基于底层模型的 index 的位置。
convertRowIndexToModel(int) - 类 javax.swing.JTable 中的方法
将基于视图的行索引映射到底层 TableModel。
convertRowIndexToModel(int) - 类 javax.swing.RowSorter 中的方法
返回基于底层模型的 index 的位置。
convertRowIndexToView(int) - 类 javax.swing.DefaultRowSorter 中的方法
返回基于视图 index 的位置。
convertRowIndexToView(int) - 类 javax.swing.JTable 中的方法
将基于 TableModel 的行索引映射到该视图。
convertRowIndexToView(int) - 类 javax.swing.RowSorter 中的方法
返回基于视图 index 的位置。
convertRowToY(int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回指定行的原点的 JList 相对 Y 坐标，如果 row 无效，则返回 -1。
convertStreamMetadata(IIOMetadata, ImageWriteParam) - 接口 javax.imageio.ImageTranscoder 中的方法
返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
convertStreamMetadata(IIOMetadata, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
convertToIntDiscrete(Raster, boolean) - 类 java.awt.image.IndexColorModel 中的方法
返回一个 TYPE_INT_ARGB 或 TYPE_INT_RGB 的新 BufferedImage，其 Raster 的像素数据是通过使用此 ColorModel 的颜色/alpha 分量数组扩展源 Raster 中的各索引来计算的。
convertToVector(Object[]) - 类 javax.swing.table.DefaultTableModel 中的静态方法
返回一个包含与该数组相同的对象的向量。
convertToVector(Object[][]) - 类 javax.swing.table.DefaultTableModel 中的静态方法
返回一个 vector，该 vector 由包含与该数组相同的对象的多个 vector 组成。
convertValueToText(Object, boolean, boolean, boolean, int, boolean) - 类 javax.swing.JTree 中的方法
通过渲染器调用以将指定值转换为文本。
convertYToRow(int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
基于当前布局，将 JList 相对坐标转换为包含它的行。
ConvolveOp - java.awt.image 中的 类
此类实现从源到目标的卷积。
ConvolveOp(Kernel, int, RenderingHints) - 类 java.awt.image.ConvolveOp 的构造方法
构造给定 Kernel、边缘条件和 RenderingHint 对象（可以为 null）的 ConvolveOp。
ConvolveOp(Kernel) - 类 java.awt.image.ConvolveOp 的构造方法
构造给定了 Kernel 的 ConvolveOp。
CookieHandler - java.net 中的 类
CookieHandler 对象提供一种回调机制以将 HTTP 状态管理策略实现挂钩到 HTTP 协议处理程序。
CookieHandler() - 类 java.net.CookieHandler 的构造方法
CookieHolder - org.omg.PortableServer.ServantLocatorPackage 中的 类
native 类型 PortableServer::ServantLocator::Cookie 被映射到 java.lang.Object。
CookieHolder() - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 的构造方法
CookieHolder(Object) - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 的构造方法
CookieManager - java.net 中的 类
CookieManager 提供 CookieHandler 的具体实现，它将 cookie 的存储区与围绕接受和拒绝 cookie 的策略分离开来。
CookieManager() - 类 java.net.CookieManager 的构造方法
创建一个新 cookie 管理器。
CookieManager(CookieStore, CookiePolicy) - 类 java.net.CookieManager 的构造方法
使用指定 cookie 存储区和 cookie 策略创建一个新 cookie 管理器。
CookiePolicy - java.net 中的 接口
CookiePolicy 实现决定应该接受哪个 cookie 以及应该拒绝哪个 cookie。
CookieStore - java.net 中的 接口
表示 cookie 存储区的 CookieStore 对象。
COORDS - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
COPIED - 类 java.awt.BufferCapabilities.FlipContents 中的静态变量
当翻转内容为 COPIED 时，翻转时将后台缓冲区的内容复制到前台缓冲区。
Copies - javax.print.attribute.standard 中的 类
Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
Copies(int) - 类 javax.print.attribute.standard.Copies 的构造方法
构造具有给定整数值的新副本属性。
CopiesSupported - javax.print.attribute.standard 中的 类
CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
CopiesSupported(int) - 类 javax.print.attribute.standard.CopiesSupported 的构造方法
构造一个新的支持副本的属性，它包含单个整数。
CopiesSupported(int, int) - 类 javax.print.attribute.standard.CopiesSupported 的构造方法
构造一个新的支持副本的属性，它包含一个整数范围。
copy(List<? super T>, List<? extends T>) - 类 java.util.Collections 中的静态方法
将所有元素从一个列表复制到另一个列表。
copy() - 类 javax.swing.JPasswordField 中的方法
对当前外观调用 provideErrorFeedback，这通常启动错误蜂鸣。
copy - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的变量
copy() - 类 javax.swing.text.JTextComponent 中的方法
将关联文本模型中当前选定的范围传输到系统剪贴板，并在文本模型中保留内容。
COPY - 类 javax.swing.TransferHandler 中的静态变量
表示“复制”传输动作的 int 值。
copy() - 类 org.omg.CORBA._PolicyStub 中的方法
复制策略对象。
copy() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 克隆此 DynAny 对象。
copy() - 接口 org.omg.CORBA.PolicyOperations 中的方法
返回 Policy 对象的副本。
copy() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynStructStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynValueStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
COPY_OR_MOVE - 类 javax.swing.TransferHandler 中的静态变量
表示“复制”或“移动”的源操作功能的 int 值。
copyAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
复制选定区域并将其内容置于剪贴板中的动作名称。
copyArea(int, int, int, int, int, int) - 类 java.awt.Graphics 中的方法
将组件的区域复制到由 dx 和 dy 指定的距离处。
copyArea(int, int, int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.copyArea。
copyAttributes() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
复制属性集合。
copyAttributes() - 接口 javax.swing.text.AttributeSet 中的方法
返回保证固定不变的属性集。
copyAttributes() - 类 javax.swing.text.SimpleAttributeSet 中的方法
创建属性的副本。
copyAttributes() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
复制属性集。
copyAttributes() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
复制属性集。
copyChildren() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得此 BeanContext 子级的副本。
copyData(WritableRaster) - 类 java.awt.image.BufferedImage 中的方法
计算 BufferedImage 的一个任意矩形区域，并将其复制到指定的 WritableRaster。
copyData(WritableRaster) - 接口 java.awt.image.RenderedImage 中的方法
计算 RenderedImage 的任意矩形区域，并将其复制到调用者提供的 WritableRaster 中。
copyInto(Object[]) - 类 java.util.Vector 中的方法
将此向量的组件复制到指定的数组中。
copyInto(Object[]) - 类 javax.swing.DefaultListModel 中的方法
将此列表的组件复制到指定数组中。
copyObject(Object, ORB) - 类 javax.rmi.CORBA.Util 中的静态方法
复制或连接一个对象。
copyObject(Object, ORB) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。
copyObjects(Object[], ORB) - 类 javax.rmi.CORBA.Util 中的静态方法
复制或连接一个对象数组。
copyObjects(Object[], ORB) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。
copyOf(T[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。
copyOf(U[], int, Class<? extends T[]>) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。
copyOf(byte[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(short[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(int[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(long[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(char[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 null 字符填充（如有必要），以使副本具有指定的长度。
copyOf(float[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(double[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(boolean[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 false 填充（如有必要），以使副本具有指定的长度。
copyOf(EnumSet<E>) - 类 java.util.EnumSet 中的静态方法
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含相同的元素（如果有的话）。
copyOf(Collection<E>) - 类 java.util.EnumSet 中的静态方法
创建一个从指定 collection 初始化的枚举 set。
copyOfRange(T[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(U[], int, int, Class<? extends T[]>) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(byte[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(short[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(int[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(long[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(char[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(float[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(double[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(boolean[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
CopyOnWriteArrayList<E> - java.util.concurrent 中的 类
ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。
CopyOnWriteArrayList() - 类 java.util.concurrent.CopyOnWriteArrayList 的构造方法
创建一个空列表。
CopyOnWriteArrayList(Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArrayList 的构造方法
创建一个按 collection 的迭代器返回元素的顺序包含指定 collection 元素的列表。
CopyOnWriteArrayList(E[]) - 类 java.util.concurrent.CopyOnWriteArrayList 的构造方法
创建一个保存给定数组的副本的列表。
CopyOnWriteArraySet<E> - java.util.concurrent 中的 类
对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
CopyOnWriteArraySet() - 类 java.util.concurrent.CopyOnWriteArraySet 的构造方法
创建一个空 set。
CopyOnWriteArraySet(Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArraySet 的构造方法
创建一个包含指定 collection 所有元素的 set。
copySign(double, double) - 类 java.lang.Math 中的静态方法
返回带有第二个浮点参数符号的第一个浮点参数。
copySign(float, float) - 类 java.lang.Math 中的静态方法
返回带有第二个浮点参数符号的第一个浮点参数。
copySign(double, double) - 类 java.lang.StrictMath 中的静态方法
返回带有第二个浮点参数符号的第一个浮点参数。
copySign(float, float) - 类 java.lang.StrictMath 中的静态方法
返回带有第二个浮点参数符号的第一个浮点参数。
copyValueOf(char[], int, int) - 类 java.lang.String 中的静态方法
返回指定数组中表示该字符序列的 String。
copyValueOf(char[]) - 类 java.lang.String 中的静态方法
返回指定数组中表示该字符序列的 String。
cos(double) - 类 java.lang.Math 中的静态方法
返回角的三角余弦。
cos(double) - 类 java.lang.StrictMath 中的静态方法
返回角的三角余弦。
cosh(double) - 类 java.lang.Math 中的静态方法
返回 double 值的双曲线余弦。
cosh(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的双曲线余弦。
count - 类 java.io.BufferedInputStream 中的变量
比缓冲区中最后一个有效字节的索引大 1 的索引。
count - 类 java.io.BufferedOutputStream 中的变量
缓冲区中的有效字节数。
count - 类 java.io.ByteArrayInputStream 中的变量
比输入流缓冲区中最后一个有效字符的索引大一的索引。
count - 类 java.io.ByteArrayOutputStream 中的变量
缓冲区中的有效字节数。
count - 类 java.io.CharArrayReader 中的变量
此缓冲区结尾处的索引。
count - 类 java.io.CharArrayWriter 中的变量
缓冲区中的 char 数目。
count - 类 java.io.StringBufferInputStream 中的变量
已过时。 输入流缓冲区中有效字符数。
count - 类 javax.swing.text.Segment 中的变量
这是构成所需文本的数组元素的数目。
count() - 类 org.omg.CORBA.ContextList 中的方法
返回此 ContextList 对象中的 String 对象数。
count() - 类 org.omg.CORBA.ExceptionList 中的方法
检索此 ExceptionList 对象中 TypeCode 对象的个数。
count() - 类 org.omg.CORBA.NVList 中的方法
返回已添加到此 NVList 对象的 NamedValue 对象数。
countAttachments() - 类 javax.xml.soap.SOAPMessage 中的方法
获取此消息中附件数量的计数。
countComponents() - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 etComponentCount() 取代。
countDown() - 类 java.util.concurrent.CountDownLatch 中的方法
递减锁存器的计数，如果计数到达零，则释放所有等待的线程。
CountDownLatch - java.util.concurrent 中的 类
一个同步辅助类，在完成一组正在其他线程中执行的操作之前，它允许一个或多个线程一直等待。
CountDownLatch(int) - 类 java.util.concurrent.CountDownLatch 的构造方法
构造一个用给定计数初始化的 CountDownLatch。
CounterMonitor - javax.management.monitor 中的 类
定义专门用来观察计数器属性值的监视器 MBean。
CounterMonitor() - 类 javax.management.monitor.CounterMonitor 的构造方法
默认的构造方法。
CounterMonitorMBean - javax.management.monitor 中的 接口
公开计数器监视器 MBean 的远程管理接口。
countItems() - 类 java.awt.Choice 中的方法
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。
countItems() - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。
countItems() - 类 java.awt.Menu 中的方法
已过时。 从 JDK version 1.1 开始，已由 getItemCount() 取代。
countMenus() - 类 java.awt.MenuBar 中的方法
已过时。 从 JDK version 1.1 开始，由 getMenuCount() 取代。
countObservers() - 类 java.util.Observable 中的方法
返回 Observable 对象的观察者数目。
countStackFrames() - 类 java.lang.Thread 中的方法
已过时。 该调用的定义依赖于 Thread.suspend()，但它遭到了反对。此外，该调用的结果从来都不是意义明确的。
countTokens() - 类 java.util.StringTokenizer 中的方法
计算在生成异常之前可以调用此 tokenizer 的 nextToken 方法的次数。
COVER - 类 javax.print.attribute.standard.Finishings 中的静态变量
当需要为文档选择非打印（或预打印）封面时指定此值。
COVER_OPEN - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备上的一个或多个机盖处于打开状态。
CPE - 类 javax.naming.spi.NamingManager 中的静态变量
保存环境属性名称的常量，getContinuationContext() 将其 CannotProceedException 参数的值保存在该环境属性中。
crc - 类 java.util.zip.GZIPInputStream 中的变量
未压缩数据的 CRC-32。
crc - 类 java.util.zip.GZIPOutputStream 中的变量
未压缩数据的 CRC-32 。
CRC32 - java.util.zip 中的 类
可用于计算数据流的 CRC-32 的类。
CRC32() - 类 java.util.zip.CRC32 的构造方法
创建新的 CRC32 对象。
create() - 类 java.awt.Graphics 中的方法
创建一个新的 Graphics 对象，它是此 Graphics 对象的副本。
create(int, int, int, int) - 类 java.awt.Graphics 中的方法
基于此 Graphics 对象创建一个新的 Graphics 对象，但是使用新的转换和剪贴区域。
create(RenderContext, ParameterBlock) - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
根据给定包含操作的源和参数的 RenderContext 和 ParameterBlock 创建一个呈现。
create(ParameterBlock, RenderingHints) - 接口 java.awt.image.renderable.RenderedImageFactory 中的方法
针对给定的 ParameterBlock 和 RenderingHints 创建表示成像操作（或操作链）结果的 RenderedImage。
create(Class<T>, Object, String) - 类 java.beans.EventHandler 中的静态方法
创建 listenerInterface 的实现，在该实现中，侦听器接口中的所有 方法都会将处理程序的 action 应用到 target。
create(Class<T>, Object, String, String) - 类 java.beans.EventHandler 中的静态方法
创建 listenerInterface 的实现，在该实现中，所有 方法都会将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。
create(Class<T>, Object, String, String, String) - 类 java.beans.EventHandler 中的静态方法
创建 listenerInterface 的实现，在该实现中，名为 listenerMethodName 的方法将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。
create() - 类 java.net.DatagramSocketImpl 中的方法
创建数据报套接字。
create(boolean) - 类 java.net.SocketImpl 中的方法
创建一个流或数据报套接字。
create(String) - 类 java.net.URI 中的静态方法
通过解析给定的字符串创建 URI。
create() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.create 来返回一个 DebugGraphics 对象。
create(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.create 来返回一个 DebugGraphics 对象。
create(Element) - 类 javax.swing.plaf.basic.BasicPasswordFieldUI 中的方法
创建元素的视图 (PasswordView)。
create(Element) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
创建元素的视图。
create(Element) - 类 javax.swing.plaf.basic.BasicTextFieldUI 中的方法
基于元素创建视图 (FieldView)。
create(Element) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
创建元素的视图。
create(Element, int, int) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
创建元素的视图。
create(DefaultStyledDocument.ElementSpec[]) - 类 javax.swing.text.DefaultStyledDocument 中的方法
初始化文档，以反映给定元素结构（即由 getDefaultRootElement 方法报告的结构）。
create(DefaultStyledDocument.ElementSpec[]) - 类 javax.swing.text.html.HTMLDocument 中的方法
替换具有给定元素规范的文档内容。
create(Element) - 类 javax.swing.text.html.HTMLEditorKit.HTMLFactory 中的方法
根据元素创建视图。
create(Element) - 接口 javax.swing.text.ViewFactory 中的方法
根据给定的文档的结构化元素创建一个视图。
create(Name) - 类 javax.xml.soap.SOAPElementFactory 中的方法
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换
create(String) - 类 javax.xml.soap.SOAPElementFactory 中的方法
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换
create(String, String, String) - 类 javax.xml.soap.SOAPElementFactory 中的方法
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换
create(Object) - 类 javax.xml.ws.Endpoint 中的静态方法
创建具有指定实现者对象的端点。
create(String, Object) - 类 javax.xml.ws.Endpoint 中的静态方法
创建具有指定绑定类型和实现者对象的端点。
create(URL, QName) - 类 javax.xml.ws.Service 中的静态方法
创建 Service 实例。
create(QName) - 类 javax.xml.ws.Service 中的静态方法
创建 Service 实例。
create_abstract_interface_tc(String, String) - 类 org.omg.CORBA.ORB 中的方法
为 IDL 抽象接口创建一个 TypeCode 对象。
create_alias_tc(String, String, TypeCode) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL alias 的 TypeCode 对象 (typedef)。
create_any() - 类 org.omg.CORBA.ORB 中的方法
创建一个 IDL Any 对象，初始化后该对象包含一个 kind 字段被设置为 TCKind.tc_null 的 Typecode 对象。
create_array_tc(int, TypeCode) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL array 的 TypeCode 对象。
create_basic_dyn_any(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_child(String) - 类 org.omg.CORBA.Context 中的方法
创建一个 Context 对象，使用给定字符串作为其名称，并将此 Context 对象设置为其父对象。
create_codec(Encoding) - 接口 org.omg.IOP.CodecFactoryOperations 中的方法
创建一个给定编码的 Codec。
create_context_list() - 类 org.omg.CORBA.ORB 中的方法
创建一个空的 ContextList 对象。
create_dyn_any(Any) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_dyn_any(Any) - 类 org.omg.DynamicAny._DynAnyFactoryStub 中的方法
根据 any 值创建新 DynAny 对象。
create_dyn_any(Any) - 接口 org.omg.DynamicAny.DynAnyFactoryOperations 中的方法
根据 any 值创建新 DynAny 对象。
create_dyn_any_from_type_code(TypeCode) - 类 org.omg.DynamicAny._DynAnyFactoryStub 中的方法
根据 TypeCode 创建 DynAny。
create_dyn_any_from_type_code(TypeCode) - 接口 org.omg.DynamicAny.DynAnyFactoryOperations 中的方法
根据 TypeCode 创建 DynAny。
create_dyn_array(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_dyn_enum(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_dyn_sequence(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_dyn_struct(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_dyn_union(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_enum_tc(String, String, String[]) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL enum 的 TypeCode 对象。
create_environment() - 类 org.omg.CORBA.ORB 中的方法
创建一个 Environment 对象。
create_exception_list() - 类 org.omg.CORBA.ORB 中的方法
创建一个空的 ExceptionList 对象。
create_exception_tc(String, String, StructMember[]) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL exception 的 TypeCode 对象。
create_fixed_tc(short, short) - 类 org.omg.CORBA.ORB 中的方法
为 IDL fixed 类型创建一个 TypeCode 对象。
create_id_assignment_policy(IdAssignmentPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_id_uniqueness_policy(IdUniquenessPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_implicit_activation_policy(ImplicitActivationPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_input_stream() - 类 org.omg.CORBA.Any 中的方法
创建一个输入流，可以从中解组此 Any 对象的值。
create_input_stream() - 类 org.omg.CORBA.portable.OutputStream 中的方法
返回一个具有相同缓冲区的输入流。
create_interface_tc(String, String) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL interface 的 TypeCode 对象。
create_lifespan_policy(LifespanPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_list(int) - 类 org.omg.CORBA.ORB 中的方法
为指定数量的 NamedValue 对象分配具有（可能）足够空间的 NVList。
create_named_value(String, Any, int) - 类 org.omg.CORBA.ORB 中的方法
使用给定名称、值和参数模式标志创建一个 NamedValue 对象。
create_native_tc(String, String) - 类 org.omg.CORBA.ORB 中的方法
为 IDL native 类型创建一个 TypeCode 对象。
create_operation_list(Object) - 类 org.omg.CORBA.ORB 中的方法
创建一个 NVList，并使用给定 OperationDef 对象中所述操作的参数描述进行初始化。
create_output_stream() - 类 org.omg.CORBA.Any 中的方法
创建一个输出流，可以将此 Any 对象的值编组到其中。
create_output_stream() - 类 org.omg.CORBA.ORB 中的方法
创建一个新的 org.omg.CORBA.portable.OutputStream，在执行方法调用期间，可在该输出流中对 IDL 方法参数进行编组。
create_POA(String, POAManager, Policy[]) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作创建一个新的 POA 作为目标 POA 的子 POA。
create_policy(int, Any) - 类 org.omg.CORBA.ORB 中的方法
可以调用此方法创建特定类型的新策略对象实例，并且其类型具有指定的初始状态。
create_policy(int, Any) - 接口 org.omg.PortableInterceptor.PolicyFactoryOperations 中的方法
返回派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。
create_recursive_sequence_tc(int, int) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用 create_recursive_tc 和 create_sequence_tc 的组合替代它
create_recursive_tc(String) - 类 org.omg.CORBA.ORB 中的方法
创建一个递归 TypeCode 对象，在创建包含递归的 TypeCodes 期间，该对象充当具体 TypeCode 的占位符。
create_reference(String) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作创建一个对象引用，该引用封装 POA 生成的 Object Id 值和指定的接口存储库 id。
create_reference_with_id(byte[], String) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作创建一个对象引用，该引用封装指定的 Object Id 和接口存储库 Id 值。
create_request(Object, Context, String, NVList, NamedValue) - 类 org.omg.CORBA.portable.Delegate 中的方法
创建在动态调用接口中使用的 Request 实例。
create_request(Object, Context, String, NVList, NamedValue, ExceptionList, ContextList) - 类 org.omg.CORBA.portable.Delegate 中的方法
创建在动态调用接口中使用的 Request 实例。
create_request_processing_policy(RequestProcessingPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_sequence_tc(int, TypeCode) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL sequence 的 TypeCode 对象。
create_servant_retention_policy(ServantRetentionPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_string_tc(int) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示有界 IDL string 的 TypeCode 对象。
create_struct_tc(String, String, StructMember[]) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL struct 的 TypeCode 对象。
create_thread_policy(ThreadPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这种操作都返回一个对具有指定值的策略对象的引用。
create_union_tc(String, String, TypeCode, UnionMember[]) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL union 的 TypeCode 对象。
create_value_box_tc(String, String, TypeCode) - 类 org.omg.CORBA.ORB 中的方法
为 IDL value box 类型创建一个 TypeCode 对象。
create_value_tc(String, String, short, TypeCode, ValueMember[]) - 类 org.omg.CORBA.ORB 中的方法
为 IDL value 类型创建一个 TypeCode 对象。
create_wstring_tc(int) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示有界 IDL wstring (wide string) 的 TypeCode 对象。
createActionChangeListener(JMenuItem) - 类 javax.swing.JMenu 中的方法
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
createActionChangeListener(JMenuItem) - 类 javax.swing.JPopupMenu 中的方法
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
createActionChangeListener(JButton) - 类 javax.swing.JToolBar 中的方法
返回正确配置的 PropertyChangeListener，它根据 Action 的更改对控件进行更新，如果需要使用默认的属性更改侦听器，则为 null。
createActionComponent(Action) - 类 javax.swing.JMenu 中的方法
该工厂方法创建添加到 JMenu 的 Action 的 JMenuItem。
createActionComponent(Action) - 类 javax.swing.JPopupMenu 中的方法
该工厂方法为添加到 JPopupMenu 的 Action 创建对应的 JMenuItem。
createActionComponent(Action) - 类 javax.swing.JToolBar 中的方法
将为 Action 创建 JButton 的工厂方法添加到 JToolBar 中。
createActionListener() - 类 javax.swing.AbstractButton 中的方法
createActionMap() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createActionPropertyChangeListener(Action) - 类 javax.swing.AbstractButton 中的方法
创建并返回 PropertyChangeListener，它负责侦听指定 Action 的更改以及更新适当的属性。
createActionPropertyChangeListener(Action) - 类 javax.swing.JComboBox 中的方法
创建并返回一个 PropertyChangeListener，它负责侦听指定 Action 的更改并更新适当属性。
createActionPropertyChangeListener(Action) - 类 javax.swing.JTextField 中的方法
创建并返回一个负责侦听指定 Action 的更改以及更新适当属性的 PropertyChangeListener。
createActions() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createAndPublishEndpoint(String, Object) - 类 javax.xml.ws.spi.Provider 中的方法
创建和发布具有指定地址和实现对象的端点对象。
createArrayOf(String, Object[]) - 接口 java.sql.Connection 中的方法
创建 Array 对象的工厂方法。
createArrowButton() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建一个按钮，将使用它来控制显示或隐藏组合框的弹出部分。
createArrowButton() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
createArrowButtonListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createAttachmentPart() - 类 javax.xml.soap.SOAPMessage 中的方法
创建一个新的空 AttachmentPart 对象。
createAttachmentPart(DataHandler) - 类 javax.xml.soap.SOAPMessage 中的方法
创建 AttachmentPart 对象并使用给定的 DataHandler 对象填充。
createAttachmentPart(Object, String) - 类 javax.xml.soap.SOAPMessage 中的方法
创建 AttachmentPart 对象并使用指定内容类型的指定数据填充。
createAttribute(String, String, String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 Attribute。
createAttribute(String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 Attribute。
createAttribute(QName, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 Attribute。
createAttribute(String) - 接口 org.w3c.dom.Document 中的方法
创建给定名称的 Attr。
createAttributeNS(String, String) - 接口 org.w3c.dom.Document 中的方法
创建给定的限定名称和名称空间 URI 的属性。
createAudioAction(Object) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
创建并返回用于播放音频的 Action。
createBackBuffers(int) - 类 java.awt.Component.BltBufferStrategy 中的方法
创建后台缓冲区
createBanded(ColorSpace, int[], int[], int, boolean, boolean) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回带状图像格式的说明符，它将使用 ComponentColorModel 和 BandedSampleModel 来存储单独数组中的每个通道。
createBandedRaster(int, int, int, int, Point) - 类 java.awt.image.Raster 中的静态方法
根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
createBandedRaster(int, int, int, int, int[], int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
createBandedRaster(DataBuffer, int, int, int, int[], int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 BandedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
createBaselineGroup(boolean, boolean) - 类 javax.swing.GroupLayout 中的方法
创建并返回一个沿基线对齐其元素的 ParallelGroup。
createBCSChild(Object, Object) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。
createBCSChild(Object, Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。
createBCSSServiceProvider(Class, BeanContextServiceProvider) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
子类可以重写此方法来创建 BCSSServiceProvider 的新子类，而不必为了实例化而重写 addService()。
createBevelBorder(int) - 类 javax.swing.BorderFactory 中的静态方法
创建一个指定类型的斜面边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
createBevelBorder(int, Color, Color) - 类 javax.swing.BorderFactory 中的静态方法
使用指定高亮显示和阴影显示方式来创建一个指定类型的斜面边框。
createBevelBorder(int, Color, Color, Color, Color) - 类 javax.swing.BorderFactory 中的静态方法
创建一个指定类型的斜面边框，使用内部和外部高亮显示区域及阴影区域的指定颜色。
createBinder(Class<T>) - 类 javax.xml.bind.JAXBContext 中的方法
创建一个可用于关联/原地解组/编组操作的 Binder 对象。
createBinder() - 类 javax.xml.bind.JAXBContext 中的方法
为 W3C DOM 创建一个 Binder。
createBindings() - 接口 javax.script.ScriptEngine 中的方法
返回一个未初始化的 Bindings。
createBlackLineBorder() - 类 javax.swing.border.LineBorder 中的静态方法
获取一个颜色为黑色、厚度为 1 的线边框的便捷方法。
createBlob() - 接口 java.sql.Connection 中的方法
构造实现 Blob 接口的对象。
createBorderListener(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createBorderListener(JInternalFrame) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
返回将在 TitlePane 上安装的 MouseInputAdapter。
createBranchElement(Element, AttributeSet) - 类 javax.swing.text.AbstractDocument 中的方法
创建文档分支元素，它可包含其他元素。
createBranchElement(Element, AttributeSet) - 类 javax.swing.text.html.HTMLDocument 中的方法
创建文档分支元素，它可以包含其他元素。
createBufferedImage(int, int) - 类 javax.imageio.ImageTypeSpecifier 中的方法
根据此对象中包含的规范创建一个具有给定宽度和高度的 BufferedImage。
createBuffers(int, BufferCapabilities) - 类 java.awt.Component.FlipBufferStrategy 中的方法
创建一个或多个具有给定能力的、复杂的翻转缓冲区。
createBufferStrategy(int) - 类 java.awt.Canvas 中的方法
创建一个新的策略，用于对此组件的多次缓冲。
createBufferStrategy(int, BufferCapabilities) - 类 java.awt.Canvas 中的方法
创建一个新的策略，使用所需的缓冲区能力对此组件进行多次缓冲。
createBufferStrategy(int) - 类 java.awt.Window 中的方法
为此组件上的多缓冲创建一个新策略。
createBufferStrategy(int, BufferCapabilities) - 类 java.awt.Window 中的方法
根据所需缓冲区能力为此组件上的多缓冲创建新策略。
createButton(Button) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Button 实现。
createButtonActionListener(int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
createButtonArea() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
创建并返回包含按钮的 Container。
createButtonListener(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
createButtonListener(AbstractButton) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
createButtons() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createButtons() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
createCanvas(Canvas) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Canvas 实现。
createCaret() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
创建用于插入符的对象。
createCaret() - 类 javax.swing.text.DefaultEditorKit 中的方法
获取能在由关联的 ViewFactory 生成的视图中导航的插入符。
createCaret() - 类 javax.swing.text.EditorKit 中的方法
获取能在由关联的 ViewFactory 生成的视图中导航的插入符。
createCData(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 CData 标记设置为 true 的 Character 事件。
createCDATASection(String) - 接口 org.w3c.dom.Document 中的方法
创建其值为指定字符串的 CDATASection 节点。
createCellEditorListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建在当前编辑器中处理事件的侦听器。
createCellRendererPane() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回用于放置渲染器组件的渲染器窗格。
createChangeListener() - 类 javax.swing.AbstractButton 中的方法
想以不同的方式处理 ChangeEvent 的子类可以重写此方法，以返回另一个 ChangeListener 实现。
createChangeListener() - 类 javax.swing.JProgressBar 中的方法
要以不同方式处理来自模型的更改事件的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。
createChangeListener() - 类 javax.swing.JSlider 中的方法
想要以不同方式处理模型的 ChangeEvent 的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。
createChangeListener() - 类 javax.swing.JTabbedPane 中的方法
要对 ChangeEvents 进行不同处理的子类可以重写它，从而返回 ModelListener 的一个子类，或者返回另一个 ChangeListener 实现。
createChangeListener() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
createChangeListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createChangeListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createChangeListener() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
createCharacters(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 Character 事件，此方法不检查内容是否全部为空白。
createCheckbox(Checkbox) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Checkbox 实现。
createCheckboxMenuItem(CheckboxMenuItem) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 CheckboxMenuItem 实现。
createChild(int, int, int, int, int, int, int[]) - 类 java.awt.image.Raster 中的方法
返回共享此 Raster 全部或部分 DataBuffer 的新 Raster。
createChildren(DefaultMutableTreeNode, Object) - 类 javax.swing.JTree.DynamicUtilTreeNode 中的静态方法
将 children 中的所有子节点添加到父节点。
createChildState(View) - 类 javax.swing.text.AsyncBoxView 中的方法
通过此方法创建新的 ChildState 记录，以允许扩展 ChildState 记录的子类执行/保存更多状态。
createChoice(Choice) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Choice 实现。
createClassFile(CharSequence, Element...) - 接口 javax.annotation.processing.Filer 中的方法
创建一个新的类文件，并返回一个对象以允许写入它。
createClob() - 接口 java.sql.Connection 中的方法
构造实现 Clob 接口的对象。
createComment(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个注释。
createComment(String) - 接口 org.w3c.dom.Document 中的方法
创建给定指定字符串的 Comment 节点。
createCompatibleDestImage(BufferedImage, ColorModel) - 类 java.awt.image.AffineTransformOp 中的方法
创建一个具有正确大小和 band 数的经过检查的目标图像。
createCompatibleDestImage(BufferedImage, ColorModel) - 接口 java.awt.image.BufferedImageOp 中的方法
创建一个具有正确大小和 band 数的经过检查的目标图像。
createCompatibleDestImage(BufferedImage, ColorModel) - 类 java.awt.image.ColorConvertOp 中的方法
创建给定源的具有正确大小和 band 数量的归零目标图像。
createCompatibleDestImage(BufferedImage, ColorModel) - 类 java.awt.image.ConvolveOp 中的方法
创建具有正确 band 大小和数量的归零目标图像。
createCompatibleDestImage(BufferedImage, ColorModel) - 类 java.awt.image.LookupOp 中的方法
创建一幅具有正确大小和 band 数的、经过检查的目标图像。
createCompatibleDestImage(BufferedImage, ColorModel) - 类 java.awt.image.RescaleOp 中的方法
创建一个具有正确大小和 band 数的经检查的目标图像。
createCompatibleDestRaster(Raster) - 类 java.awt.image.AffineTransformOp 中的方法
创建一个具有正确大小和 band 数的经过检查的目标 Raster。
createCompatibleDestRaster(Raster) - 类 java.awt.image.BandCombineOp 中的方法
创建一个经过检查的目标 Raster，它具有正确大小和 band 数。
createCompatibleDestRaster(Raster) - 类 java.awt.image.ColorConvertOp 中的方法
创建给定源且具有正确 band 大小和数量的归零目标 Raster。
createCompatibleDestRaster(Raster) - 类 java.awt.image.ConvolveOp 中的方法
创建给定源且具有正确 band 大小和数量的归零目标 Raster。
createCompatibleDestRaster(Raster) - 类 java.awt.image.LookupOp 中的方法
在给定源 Raster 的情况下，创建一幅具有正确大小和 band 数的、经过检查的目标 Raster。
createCompatibleDestRaster(Raster) - 接口 java.awt.image.RasterOp 中的方法
创建一个具有正确大小和 band 数的归零目标 Raster。
createCompatibleDestRaster(Raster) - 类 java.awt.image.RescaleOp 中的方法
在给出源的情况下，创建一个具有正确大小和 band 数的经检查的目标 Raster。
createCompatibleImage(int, int) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。
createCompatibleImage(int, int, int) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个支持指定透明度，并且数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。
createCompatibleSampleModel(int, int) - 类 java.awt.image.BandedSampleModel 中的方法
创建一个具有指定宽度和高度的新的 BandedSampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.ColorModel 中的方法
用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。
createCompatibleSampleModel(int, int) - 类 java.awt.image.ComponentColorModel 中的方法
用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。
createCompatibleSampleModel(int, int) - 类 java.awt.image.ComponentSampleModel 中的方法
创建具有指定宽度和高度的 ComponentSampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.IndexColorModel 中的方法
创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
构造一个具有指定宽度和高度的新 MultiPixelPackedSampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.PackedColorModel 中的方法
创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.PixelInterleavedSampleModel 中的方法
创建一个具有指定宽度和高度的 PixelInterleavedSampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.SampleModel 中的方法
创建一个用此 SampleModel 的格式描述数据，但宽度和高度不同的 SampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
创建一个具有指定宽度和高度的新 SinglePixelPackedSampleModel。
createCompatibleVolatileImage(int, int) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
createCompatibleVolatileImage(int, int, int) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
createCompatibleVolatileImage(int, int, ImageCapabilities) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力的 VolatileImage。
createCompatibleVolatileImage(int, int, ImageCapabilities, int) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力和透明度值的 VolatileImage。
createCompatibleWritableRaster(int, int) - 类 java.awt.image.ColorModel 中的方法
用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。
createCompatibleWritableRaster(int, int) - 类 java.awt.image.ComponentColorModel 中的方法
用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。
createCompatibleWritableRaster(int, int) - 类 java.awt.image.DirectColorModel 中的方法
创建具有指定宽度和高度、拥有与此 ColorModel 兼容的数据布局 (SampleModel) 的 WritableRaster。
createCompatibleWritableRaster(int, int) - 类 java.awt.image.IndexColorModel 中的方法
创建一个具有指定宽度和高度、数据布局 (SampleModel) 与此 ColorModel 兼容的 WritableRaster。
createCompatibleWritableRaster() - 类 java.awt.image.Raster 中的方法
创建一个兼容的 WritableRaster，使其具有与此 Raster 相同的大小、SampleModel，以及一个新初始化的 DataBuffer。
createCompatibleWritableRaster(int, int) - 类 java.awt.image.Raster 中的方法
创建一个兼容的 WritableRaster，使其具有指定大小、新 SampleModel 和新初始化的 DataBuffer。
createCompatibleWritableRaster(Rectangle) - 类 java.awt.image.Raster 中的方法
创建一个兼容的 WritableRaster，使其具有由 rect 指定的位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
createCompatibleWritableRaster(int, int, int, int) - 类 java.awt.image.Raster 中的方法
创建一个兼容的 WritableRaster，使其具有指定位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
createComponent(Component) - 类 java.awt.Toolkit 中的方法
创建组件或容器的同位体。
createComponent() - 类 javax.swing.text.ComponentView 中的方法
创建与此视图关联的组件。
createComponent() - 类 javax.swing.text.html.FormView 中的方法
创建组件。
createComponent() - 类 javax.swing.text.html.ObjectView 中的方法
创建组件。
createComponentListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createComponentListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createComponentListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建并返回新的 ComponentHandler。
createCompoundBorder() - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有 null 内部边缘和 null 外部边缘的合成边框。
createCompoundBorder(Border, Border) - 类 javax.swing.BorderFactory 中的静态方法
创建一个合成边框，指定了用于外部和内部边缘的 border 对象。
createCompoundEdit() - 类 javax.swing.undo.UndoableEditSupport 中的方法
仅从 beginUpdate 调用。
createConnection() - 类 javax.xml.soap.SOAPConnectionFactory 中的方法
创建新的 SOAPConnection。
createContainer() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
创建管理 editingComponent 放置的容器。
createContainerListener() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
createContainerListener() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
创建一个将添加到 JToolBar 中的容器侦听器。
createContentHandler(String) - 接口 java.net.ContentHandlerFactory 中的方法
创建从 URLStreamHandler 读取对象的新 ContentHandler。
createContentPane() - 类 javax.swing.JRootPane 中的方法
由构造方法调用以便创建默认的 contentPane。
createContext(ColorModel, ColorModel, RenderingHints) - 类 java.awt.AlphaComposite 中的方法
为合成操作创建一个上下文。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.Color 中的方法
创建并返回用来生成固定颜色模式的 PaintContext。
createContext(ColorModel, ColorModel, RenderingHints) - 接口 java.awt.Composite 中的方法
创建一个上下文，其中包含用于执行复合操作的状态。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.GradientPaint 中的方法
创建并返回用来生成颜色模式的上下文。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.LinearGradientPaint 中的方法
创建并返回用来生成颜色模式的 PaintContext。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 接口 java.awt.Paint 中的方法
创建并返回用来生成颜色模式的 PaintContext。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.RadialGradientPaint 中的方法
创建并返回用来生成颜色模式的 PaintContext。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.SystemColor 中的方法
创建并返回用来生成纯色模式的 PaintContext。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.TexturePaint 中的方法
创建并返回用于生成颜色模式的上下文。
createContext(GSSName, Oid, GSSCredential, int) - 类 org.ietf.jgss.GSSManager 中的方法
在初始端一方创建上下文的 Factory 方法。
createContext(GSSCredential) - 类 org.ietf.jgss.GSSManager 中的方法
为接受端一方创建上下文的 Factory 方法。
createContext(byte[]) - 类 org.ietf.jgss.GSSManager 中的方法
创建以前导出的上下文的 Factory 方法。
createCopy() - 接口 javax.sql.rowset.CachedRowSet 中的方法
创建一个 RowSet 对象，它是此 CachedRowSet 对象中数据的深层副本。
createCopyNoConstraints() - 接口 javax.sql.rowset.CachedRowSet 中的方法
创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象数据的深层副本，但是独立于此 CachedRowSet 对象。
createCopySchema() - 接口 javax.sql.rowset.CachedRowSet 中的方法
创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象的空副本。
createCredential(int) - 类 org.ietf.jgss.GSSManager 中的方法
获取默认凭据的 Factory 方法。
createCredential(GSSName, int, Oid, int) - 类 org.ietf.jgss.GSSManager 中的方法
获取单个机制凭据的 Factory 方法。
createCredential(GSSName, int, Oid[], int) - 类 org.ietf.jgss.GSSManager 中的方法
通过一套机制获取凭据的 Factory 方法。
createCustomCursor(Image, Point, String) - 类 java.awt.Toolkit 中的方法
创建一个新的自定义光标对象。
createDataBuffer() - 类 java.awt.image.BandedSampleModel 中的方法
创建一个与此 BandedSampleModel 对应的 DataBuffer，该 DataBuffer 的数据类型、存储单元数和大小都将与此 BandedSampleModel 一致。
createDataBuffer() - 类 java.awt.image.ComponentSampleModel 中的方法
创建对应于此 ComponentSampleModel 的 DataBuffer。
createDataBuffer() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
创建一个与此 MultiPixelPackedSampleModel 对应的 DataBuffer。
createDataBuffer() - 类 java.awt.image.SampleModel 中的方法
创建一个对应于此 SampleModel 的 DataBuffer。
createDataBuffer() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
创建一个对应于此 SinglePixelPackedSampleModel 的 DataBuffer。
createDataContentHandler(String) - 类 javax.activation.CommandMap 中的方法
查找与 MIME 类型对应的 DataContentHandler。
createDataContentHandler(String, DataSource) - 类 javax.activation.CommandMap 中的方法
查找与 MIME 类型对应的 DataContentHandler。
createDataContentHandler(String) - 接口 javax.activation.DataContentHandlerFactory 中的方法
针对 MIME 类型创建一个新的 DataContentHandler 对象。
createDataContentHandler(String) - 类 javax.activation.MailcapCommandMap 中的方法
返回指定 MIME 类型的 DataContentHandler。
createDatagramSocketImpl() - 接口 java.net.DatagramSocketImplFactory 中的方法
创建新的 DatagramSocketImpl 实例。
createdCellEditor - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
如果当前位于树中的编辑器由此实例创建，则设置为 true。
createDecreaseButton(int) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createDecreaseButton(int) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
返回表示减少量视图的视图。
createDefaultCellEditor() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建默认单元格编辑器。
createDefaultCellRenderer() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回用于为每个节点添加标志的默认单元格渲染器。
createDefaultChoosers() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
createDefaultColumnModel() - 类 javax.swing.JTable 中的方法
返回默认的列模型对象，它是一个 DefaultTableColumnModel。
createDefaultColumnModel() - 类 javax.swing.table.JTableHeader 中的方法
返回默认的列模型对象，它是 DefaultTableColumnModel。
createDefaultColumnsFromModel() - 类 javax.swing.JTable 中的方法
使用 TableModel 接口中定义的 getColumnCount 方法根据数据模型创建默认的表列。
createDefaultDataModel() - 类 javax.swing.JTable 中的方法
返回默认的表模型对象，它是一个 DefaultTableModel。
createDefaultDivider() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
创建默认的分隔符。
createDefaultDivider() - 类 javax.swing.plaf.metal.MetalSplitPaneUI 中的方法
创建默认分隔符。
createDefaultDocument() - 类 javax.swing.text.DefaultEditorKit 中的方法
创建一个适合此编辑器类型的未初始化文本存储模型 (PlainDocument)。
createDefaultDocument() - 类 javax.swing.text.EditorKit 中的方法
创建一个适合此编辑器类型的未初始化的文本存储模型。
createDefaultDocument() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
创建一个适合此编辑器类型的未初始化文本存储模型。
createDefaultDocument() - 类 javax.swing.text.StyledEditorKit 中的方法
创建一个适合此编辑器类型的未初始化文本存储模型。
createDefaultDragGestureRecognizer(Component, int, DragGestureListener) - 类 java.awt.dnd.DragSource 中的方法
创建一个新的 DragGestureRecognizer，为此 DragSource 实现 DragGestureRecognizer 的默认抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
createDefaultEditorKit() - 类 javax.swing.JEditorPane 中的方法
首次创建组件时，创建默认的编辑器工具包 (PlainEditorKit)。
createDefaultEditorKit() - 类 javax.swing.JTextPane 中的方法
创建默认使用的 EditorKit。
createDefaultEditors() - 类 javax.swing.JTable 中的方法
为 object、number 和 boolean 值创建默认的单元格编辑器。
createDefaultHeaderRenderer() - 类 javax.swing.table.TableColumn 中的方法
从 Java 2 platform v1.3 开始，TableColumn 构造方法不再调用此方法。
createDefaultKeySelectionManager() - 类 javax.swing.JComboBox 中的方法
返回默认键选择管理器的实例。
createDefaultModel() - 类 javax.swing.JTextArea 中的方法
如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。
createDefaultModel() - 类 javax.swing.JTextField 中的方法
如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。
createDefaultNonContinuousLayoutDivider() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回默认的非连续布局分隔符，该分隔符是使用深灰色填充背景的 Canvas 的实例。
createDefaultRenderer() - 类 javax.swing.table.JTableHeader 中的方法
返回 TableColumn 未定义头渲染器时所使用的默认渲染器。
createDefaultRenderers() - 类 javax.swing.JTable 中的方法
为 object、number、double、date、boolean 和 icon 创建默认的单元格渲染器。
createDefaultRendering() - 接口 java.awt.image.renderable.RenderableImage 中的方法
返回此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。
createDefaultRendering() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
获取此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。
createDefaultRoot() - 类 javax.swing.text.DefaultStyledDocument 中的方法
创建用于代表默认文档结构的根元素。
createDefaultRoot() - 类 javax.swing.text.html.HTMLDocument 中的方法
创建用于表示默认文档结构的根元素。
createDefaultRoot() - 类 javax.swing.text.PlainDocument 中的方法
创建用于表示默认文档结构的根元素。
createDefaultSelectionModel() - 类 javax.swing.JTable 中的方法
返回默认的选择模型对象，它是一个 DefaultListSelectionModel。
createDefaultTableHeader() - 类 javax.swing.JTable 中的方法
返回默认的表标题对象，它是一个 JTableHeader。
createDefaultTheme() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
确保当前 MetalTheme 为非 null。
createDesktopManager() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createDesktopPeer(Desktop) - 类 java.awt.Toolkit 中的方法
使用指定的同位体接口创建此工具包的 Desktop 实现。
createDetail() - 类 javax.xml.soap.SOAPFactory 中的方法
创建充当 DetailEntry 对象容器的新 Detail 对象。
createDetailsView(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createDialog(Dialog) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Dialog 实现。
createDialog(Component, String, boolean, JColorChooser, ActionListener, ActionListener) - 类 javax.swing.JColorChooser 中的静态方法
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
createDialog(Component) - 类 javax.swing.JFileChooser 中的方法
创建并返回包含 this 的新 JDialog，在 parent 窗体中的 parent 上居中。
createDialog(Component, String) - 类 javax.swing.JOptionPane 中的方法
创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。
createDialog(String) - 类 javax.swing.JOptionPane 中的方法
创建并返回一个新的带有指定标题的无父 JDialog。
createDirectoryComboBoxModel(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createDirectoryComboBoxRenderer(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createDisabledImage(Image) - 类 javax.swing.GrayFilter 中的静态方法
创建一个禁用图像
createDispatch(QName, Class<T>, Service.Mode) - 类 javax.xml.ws.Service 中的方法
创建与用户选择的对象一起使用的 Dispatch 实例。
createDispatch(QName, JAXBContext, Service.Mode) - 类 javax.xml.ws.Service 中的方法
创建与生成的 JAXB 对象一起使用的 Dispatch 实例。
createDispatch(QName, Class<T>, Service.Mode) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
创建与用户选择的对象一起使用的 Dispatch 实例。
createDispatch(QName, JAXBContext, Service.Mode) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。
createDockingListener() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createDockingListener() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
createDocument(String, String, DocumentType) - 接口 org.w3c.dom.DOMImplementation 中的方法
创建具有文档元素的指定类型的 DOM Document 对象。
createDocumentFragment() - 接口 org.w3c.dom.Document 中的方法
创建空 DocumentFragment 对象。
createDocumentType(String, String, String) - 接口 org.w3c.dom.DOMImplementation 中的方法
创建空 DocumentType 节点。
createDoubleClickListener(JFileChooser, JList) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
createDragGestureRecognizer(Class<T>, Component, int, DragGestureListener) - 类 java.awt.dnd.DragSource 中的方法
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
createDragGestureRecognizer(Class<T>, DragSource, Component, int, DragGestureListener) - 类 java.awt.Toolkit 中的方法
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。
createDragSourceContext(DragSourceContextPeer, DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - 类 java.awt.dnd.DragSource 中的方法
创建处理此拖动的 DragSourceContext。
createDragSourceContextPeer(DragGestureEvent) - 类 java.awt.Toolkit 中的方法
创建 DragSourceContext 的同位体。
createDragWindow(JToolBar) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createdRenderer - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
如果当前在树中使用的渲染器由此实例创建，则设置为 true。
createDropTargetAutoScroller(Component, Point) - 类 java.awt.dnd.DropTarget 中的方法
创建一个嵌入式自动滚动条
createDropTargetContext() - 类 java.awt.dnd.DropTarget 中的方法
创建与此 DropTarget 关联的 DropTargetContext。
createDTD(DTD, String) - 类 javax.swing.text.html.parser.ParserDelegator 中的静态方法
createDTD(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个文档类型定义事件。
createEastPane(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createEditor(SpinnerModel) - 类 javax.swing.JSpinner 中的方法
此方法由构造方法调用，以创建显示序列当前值的 JComponent。
createEditor() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将在可编辑的组合框中使用的默认编辑器。
createEditor() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
installUI 通过调用此方法获取 JSpinner 的编辑器组件。
createEditor() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
createEditorComponent() - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
创建内部编辑器组件。
createEditorKitForContentType(String) - 类 javax.swing.JEditorPane 中的静态方法
根据默认的编辑器工具包注册表为给定的类型创建处理程序。
createElement(Element) - 类 javax.xml.soap.SOAPFactory 中的方法
根据现有的 DOM Element 创建 SOAPElement 对象。
createElement(Name) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定 Name 对象初始化的 SOAPElement 对象。
createElement(QName) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定 QName 对象初始化的 SOAPElement 对象。
createElement(String) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定本地名称初始化的 SOAPElement 对象。
createElement(String, String, String) - 类 javax.xml.soap.SOAPFactory 中的方法
使用本地名称、前缀和 URI 创建新的 SOAPElement 对象。
createElement(String) - 接口 org.w3c.dom.Document 中的方法
创建指定类型的元素。
createElementNS(String, String) - 接口 org.w3c.dom.Document 中的方法
创建给定的限定名称和名称空间 URI 的元素。
createEmptyBorder() - 类 javax.swing.BorderFactory 中的静态方法
创建一个不占用空间的空边框。
createEmptyBorder(int, int, int, int) - 类 javax.swing.BorderFactory 中的静态方法
创建一个占用空间但没有绘制的空边框，指定了顶线、底线、左边框线和右边框线的宽度。
createEmptyFrameIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法
createEndDocument() - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 EndDocument 事件的新实例。
createEndElement(QName, Iterator) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 EndElement。
createEndElement(String, String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 EndElement。
createEndElement(String, String, String, Iterator) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 EndElement。
createEndpoint(String, Object) - 类 javax.xml.ws.spi.Provider 中的方法
创建具有提供的绑定和实现对象的端点对象。
createEntityReference(String, EntityDeclaration) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 EntityReference 事件的新实例。
createEntityReference(String) - 接口 org.w3c.dom.Document 中的方法
创建 EntityReference 对象。
createEtchedBorder() - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。
createEtchedBorder(Color, Color) - 类 javax.swing.BorderFactory 中的静态方法
使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
createEtchedBorder(int) - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。
createEtchedBorder(int, Color, Color) - 类 javax.swing.BorderFactory 中的静态方法
使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
createEvent(String) - 接口 org.w3c.dom.events.DocumentEvent 中的方法
createExceptionReply() - 接口 org.omg.CORBA.portable.ResponseHandler 中的方法
在方法调用期间由 servant 调用。
createExtendedResponse(String, byte[], int, int) - 接口 javax.naming.ldap.ExtendedRequest 中的方法
创建与此请求对应的响应对象。
createExtendedResponse(String, byte[], int, int) - 类 javax.naming.ldap.StartTlsRequest 中的方法
创建与 LDAP StartTLS 扩展请求相对应的扩展响应对象。
createFault(String, QName) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象
createFault() - 类 javax.xml.soap.SOAPFactory 中的方法
创建一个新的默认 SOAPFault 对象
createFileDialog(FileDialog) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 FileDialog 实现。
createFileObject(File, String) - 类 javax.swing.filechooser.FileSystemView 中的方法
返回根据给定的 filename 在 dir 中构造的 File 对象。
createFileObject(String) - 类 javax.swing.filechooser.FileSystemView 中的方法
返回根据给定路径字符串构造的 File 对象。
createFileSystemRoot(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
创建针对 f 的新 File 对象，使其对于文件系统根目录而言具有正确的行为。
createFilterComboBoxModel() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createFilterComboBoxRenderer() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createFilteredReader(XMLStreamReader, StreamFilter) - 类 javax.xml.stream.XMLInputFactory 中的方法
创建过滤的 reader，它用过滤器包装 reader。
createFilteredReader(XMLEventReader, EventFilter) - 类 javax.xml.stream.XMLInputFactory 中的方法
创建过滤的事件 reader，它用过滤器包装事件 reader。
createFloatingFrame(JToolBar) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
不再使用，使用 BasicToolBarUI.createFloatingWindow(JToolBar)
createFloatingWindow(JToolBar) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
创建将工具栏拖出其容器后包含该工具栏的窗口
createFocusListener() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将添加到组合框的 FocusListener。
createFocusListener() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
createFocusListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createFocusListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
创建 JSplitPane UI 的 FocusListener。
createFocusListener() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
createFocusListener() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
创建在 JTable 中处理键盘导航的焦点侦听器。
createFocusListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建失去/获取焦点时负责更新显示的侦听器。
createFont(int, InputStream) - 类 java.awt.Font 中的静态方法
返回一个使用指定字体类型和输入数据的新 Font。
createFont(int, File) - 类 java.awt.Font 中的静态方法
返回一个使用指定字体类型和指定字体文件的新 Font。
createFragment(int, int) - 类 javax.swing.text.GlyphView 中的方法
创建表示元素某部分的视图。
createFragment(int, int) - 类 javax.swing.text.View 中的方法
创建一个表示元素某部分的视图。
createFrame(Frame) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Frame 实现。
createFrameListener() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createFromBufferedImageType(int) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回一个 ImageTypeSpecifier，它将对某一标准 BufferedImage 类型（而不是 TYPE_CUSTOM）进行编码。
createFromRenderedImage(RenderedImage) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回一个 ImageTypeSpecifier，它将对 RenderedImage（可能是 BufferedImage）的布局进行编码。
createGlassPane() - 类 javax.swing.JRootPane 中的方法
由构造方法调用以便创建默认的 glassPane。
createGlassPaneDispatcher() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createGlue() - 类 javax.swing.Box 中的静态方法
创建一个不可见的 "glue" 组件，其可见组件有一个最大宽度（对于横向 box）或高度（对于纵向 box）的 Box，该组件可能很有用。
createGlyphVector(FontRenderContext, String) - 类 java.awt.Font 中的方法
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
createGlyphVector(FontRenderContext, char[]) - 类 java.awt.Font 中的方法
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
createGlyphVector(FontRenderContext, CharacterIterator) - 类 java.awt.Font 中的方法
根据此 Font 中的 Unicode cmap 将指定字符一一映射到字形，从而创建一个 GlyphVector。
createGlyphVector(FontRenderContext, int[]) - 类 java.awt.Font 中的方法
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
createGraphics(BufferedImage) - 类 java.awt.GraphicsEnvironment 中的方法
返回一个呈现指定 BufferedImage 的 Graphics2D 对象。
createGraphics() - 类 java.awt.image.BufferedImage 中的方法
创建一个 Graphics2D，可以将它绘制到此 BufferedImage 中。
createGraphics() - 类 java.awt.image.VolatileImage 中的方法
创建一个 Graphics2D，可以将它绘制到此 VolatileImage 中。
createGraphics() - 类 java.awt.SplashScreen 中的方法
创建闪现屏幕叠加图像的图形上下文（Graphics2D 形式），它允许在闪现屏幕上进行绘制。
createGrayLineBorder() - 类 javax.swing.border.LineBorder 中的静态方法
获取一个颜色为灰色、厚度为 1 的线条边框的便捷方法。
createGrayscale(int, int, boolean) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回灰度级图像格式的说明符，它会将给定位深 (bit depth) 的像素压缩成指定数据类型的数组元素。
createGrayscale(int, int, boolean, boolean) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回灰度级图像格式和 alpha 图像格式的说明符，它会将给定位深的像素压缩成指定数据类型的数组元素。
createGroup(ActivationGroupID, ActivationGroupDesc, long) - 类 java.rmi.activation.ActivationGroup 中的静态方法
为当前 VM 创建并设置激活组。
createHighlighter() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
创建用于添加高亮显示的对象。
createHorizontalBox() - 类 javax.swing.Box 中的静态方法
创建一个从左到右显示其组件的 Box。
createHorizontalGlue() - 类 javax.swing.Box 中的静态方法
创建一个横向 glue 组件。
createHorizontalScrollBar() - 类 javax.swing.JScrollPane 中的方法
默认返回 JScrollPane.ScrollBar。
createHorizontalStrut(int) - 类 javax.swing.Box 中的静态方法
创建一个不可见的、固定宽度的组件。
createHSBChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
createHTMLView(JComponent, String) - 类 javax.swing.plaf.basic.BasicHTML 中的静态方法
创建给定组件和 html 字符串的 html 渲染器。
createIgnorableSpace(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个可忽略的空间。
createImage(ImageProducer) - 类 java.awt.Component 中的方法
根据指定的图像生成器创建一幅图像。
createImage(int, int) - 类 java.awt.Component 中的方法
创建一幅用于双缓冲的、可在屏幕外绘制的图像。
createImage(String) - 类 java.awt.Toolkit 中的方法
返回从指定文件获取像素数据的图像。
createImage(URL) - 类 java.awt.Toolkit 中的方法
返回一幅图像，该图像从指定 URL 获取像素数据。
createImage(ImageProducer) - 类 java.awt.Toolkit 中的方法
使用指定的图像生成器创建一幅图像。
createImage(byte[]) - 类 java.awt.Toolkit 中的方法
创建一幅图像，该图像对存储在指定字节数组中的图像进行解码。
createImage(byte[], int, int) - 类 java.awt.Toolkit 中的方法
创建一幅图像，该图像对存储在指定字节数组中指定偏移量和长度处的图像进行解码。
createImageInputStream(Object) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 ImageInputStream，它将从给定 Object 中获取输入。
createImageOutputStream(Object) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 ImageOutputStream，它将其输出发送到给定 Object。
createIncreaseButton(int) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createIncreaseButton(int) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
返回表示增加量视图的视图。
createIndexed(byte[], byte[], byte[], byte[], int, int) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回索引颜色图像格式的说明符，它将给定位深的索引值压缩成指定数据类型的数组元素。
createInitialContextFactory(Hashtable<?, ?>) - 接口 javax.naming.spi.InitialContextFactoryBuilder 中的方法
使用指定环境创建一个初始上下文工厂。
createInputAttributes(Element, MutableAttributeSet) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
将 element 的 AttributeSet 键/值复制到 set 中。
createInputAttributes(Element, MutableAttributeSet) - 类 javax.swing.text.StyledEditorKit 中的方法
将 element 的 AttributeSet 键/值复制到 set 中。
createInputMethod() - 接口 java.awt.im.spi.InputMethodDescriptor 中的方法
创建相应输入方法的新实例。
createInputMethodJFrame(String, boolean) - 接口 java.awt.im.spi.InputMethodContext 中的方法
创建输入方法使用的顶层 Swing JFrame。
createInputMethodWindow(String, boolean) - 接口 java.awt.im.spi.InputMethodContext 中的方法
创建输入方法使用的顶层窗口。
createInputStreamInstance(Object, boolean, File) - 类 javax.imageio.spi.ImageInputStreamSpi 中的方法
返回与此服务提供者关联的 ImageInputStream 实现的实例。
createInputStreamInstance(Object) - 类 javax.imageio.spi.ImageInputStreamSpi 中的方法
返回与此服务提供者关联的 ImageInputStream 实现的实例。
createInterleaved(ColorSpace, int[], int, boolean, boolean) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回交错图像格式的说明符，它将使用 ComponentColorModel 和 PixelInterleavedSampleModel 来存储单个 byte、short 或 int 值形式的每个像素组件。
createInterleavedRaster(int, int, int, int, Point) - 类 java.awt.image.Raster 中的静态方法
根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
createInterleavedRaster(int, int, int, int, int, int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
createInterleavedRaster(DataBuffer, int, int, int, int, int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 PixelInterleavedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
createInternalFrame(Component, String) - 类 javax.swing.JOptionPane 中的方法
创建并返回 JInternalFrame 的实例。
createInternalFrameListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createIntersection(Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
createIntersection(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Double 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
createIntersection(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Float 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
createIntersection(Rectangle2D) - 类 java.awt.Rectangle 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
createInverse() - 类 java.awt.geom.AffineTransform 中的方法
返回表示逆向变换的 AffineTransform 对象。
createItemListener() - 类 javax.swing.AbstractButton 中的方法
createItemListener() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将添加到组合框的 ItemListener。
createItemListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将添加到组合框的 ItemListener。
createJAXBIntrospector() - 类 javax.xml.bind.JAXBContext 中的方法
创建一个可以用于内省 JAXB 对象的 JAXBIntrospector 对象。
createKeyboardDownRightListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 platform v1.3 开始。
createKeyboardEndListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 platform v1.3 开始。
createKeyboardHomeListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 platform v1.3 开始。
createKeyboardResizeToggleListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 platform v1.3 开始。
createKeyboardUpLeftListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 platform v1.3 开始。
createKeyListener() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将添加到组合框的 KeyListener。
createKeyListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将添加到组合框的键侦听器。
createKeyListener() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
创建在 JTable 中处理键盘导航的键侦听器。
createKeyListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建负责从树获取键事件的侦听器。
createKeymap() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
创建用于文本组件的 keymap，并在其中安装必需的绑定。
createLabel(Label) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Label 实现。
createLargeAttributeSet(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
创建一个以空间来换取时间的大属性集合。
createLargeAttributeSet(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
创建一个以空间来换取时间的大属性集合。
createLayeredPane() - 类 javax.swing.JRootPane 中的方法
由构造方法调用以便创建默认的 layeredPane。
createLayout() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createLayout() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
创建管理 JSpinner 的 editor、nextButton 和 previousButton 子级的 LayoutManager。
createLayout() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
createLayoutCache() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建负责管理展开内容及节点大小的对象。
createLayoutManager() - 类 javax.swing.JViewport 中的方法
子类可以重写此方法以在该构造方法中安装一个不同布局的管理器（或者为 null）。
createLayoutManager() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建用于管理构成组合框的组件的布局管理器。
createLayoutManager() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createLayoutManager() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
createLayoutManager() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
由 installUI 调用，用于创建布局管理器对象以管理 JTabbedPane。
createLayoutManager() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
createLayoutManager() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
createLeafElement(Element, AttributeSet, int, int) - 类 javax.swing.text.AbstractDocument 中的方法
创建文档叶元素。
createLeafElement(Element, AttributeSet, int, int) - 类 javax.swing.text.html.HTMLDocument 中的方法
创建直接表示文本的文档叶元素（没有任何子级）。
createLeftOneTouchButton() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的左边组件。
createLineBidi(int, int) - 类 java.text.Bidi 中的方法
构造一个 Bidi 对象，表示当前 Bidi 所代表的段落中的一行文本上的双向信息。
createLineBorder(Color) - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有指定颜色的线边框。
createLineBorder(Color, int) - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有指定颜色和宽度的线边框。
createList(List) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 List 实现。
createList() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建在显示组合框模型项的弹出控件中使用的 JList。
createList(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createListDataListener() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将添加到 ComboBoxModel 的列表数据侦听器。
createListDataListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将添加到 ComboBoxModel 的列表数据侦听器。
createListDataListener() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
创建在需要时由模型添加到 JList 的 ListDataListener 的实例。
createListMouseListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建观察弹出列表中的鼠标事件的鼠标侦听器。
createListMouseMotionListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建观察弹出列表中的鼠标移动事件的鼠标移动侦听器。
createListSelectionListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建观察弹出列表中的选择更改的列表选择侦听器。
createListSelectionListener(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
createListSelectionListener() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
创建在需要时由 selectionModel 添加到 JList 的 ListSelectionHandler 的实例。
createListSelectionListener(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
创建一个用于文件和目录列表的选择侦听器。
createLoweredBevelBorder() - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有凹入斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
createLSInput() - 接口 org.w3c.dom.ls.DOMImplementationLS 中的方法
创建一个新的空输入源对象，其中，LSInput.characterStream、LSInput.byteStream、LSInput.stringData LSInput.systemId、LSInput.publicId、LSInput.baseURI 和 LSInput.encoding 为 null，LSInput.certifiedText 为 false。
createLSOutput() - 接口 org.w3c.dom.ls.DOMImplementationLS 中的方法
创建新的空输出目标对象，其中，LSOutput.characterStream、LSOutput.byteStream、LSOutput.systemId 和 LSOutput.encoding 为 null。
createLSParser(short, String) - 接口 org.w3c.dom.ls.DOMImplementationLS 中的方法
创建一个新的 LSParser。
createLSSerializer() - 接口 org.w3c.dom.ls.DOMImplementationLS 中的方法
创建新的 LSSerializer 对象。
createMarshaller() - 类 javax.xml.bind.JAXBContext 中的方法
创建一个可以用来将 java 内容树转换为 XML 数据的 Marshaller 对象。
createMatteBorder(int, int, int, int, Color) - 类 javax.swing.BorderFactory 中的静态方法
使用纯色创建一个类似衬边的边框。
createMatteBorder(int, int, int, int, Icon) - 类 javax.swing.BorderFactory 中的静态方法
创建一个由多层指定图标组成的、类似衬边的边框。
createMBean(String, ObjectName) - 接口 javax.management.MBeanServer 中的方法
createMBean(String, ObjectName, ObjectName) - 接口 javax.management.MBeanServer 中的方法
createMBean(String, ObjectName, Object[], String[]) - 接口 javax.management.MBeanServer 中的方法
createMBean(String, ObjectName, ObjectName, Object[], String[]) - 接口 javax.management.MBeanServer 中的方法
createMBean(String, ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
在 MBean 服务器中实例化并注册一个 MBean。
createMBean(String, ObjectName, ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
在 MBean 服务器中实例化并注册一个 MBean。
createMBean(String, ObjectName, Object[], String[]) - 接口 javax.management.MBeanServerConnection 中的方法
在 MBean 服务器中实例化并注册一个 MBean。
createMBean(String, ObjectName, ObjectName, Object[], String[]) - 接口 javax.management.MBeanServerConnection 中的方法
在 MBean 服务器中实例化并注册一个 MBean。
createMBean(String, ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
createMBean(String, ObjectName, ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
createMBean(String, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
createMBean(String, ObjectName, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
createMBean(String, ObjectName, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
createMBean(String, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
createMBeanServer() - 类 javax.management.MBeanServerFactory 中的静态方法
返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口。
createMBeanServer(String) - 类 javax.management.MBeanServerFactory 中的静态方法
返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口。
createMenu(Menu) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Menu 实现。
createMenuBar(MenuBar) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 MenuBar 实现。
createMenuDragMouseListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
createMenuDragMouseListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createMenuItem(MenuItem) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 MenuItem 实现。
createMenuKeyListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
createMenuKeyListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createMenuListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createMessage() - 类 javax.xml.soap.MessageFactory 中的方法
使用默认的 SOAPPart、SOAPEnvelope、SOAPBody 和 SOAPHeader 对象创建新的 SOAPMessage 对象。
createMessage(MimeHeaders, InputStream) - 类 javax.xml.soap.MessageFactory 中的方法
将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
createMessageArea() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
从 installComponents 获取消息以创建包含消息正文的 Container。
createModel() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
createModelListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createMouseInputListener() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
createMouseInputListener() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
创建实现 MouseInputListener 的委托。
createMouseInputListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
createMouseInputListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createMouseInputListener() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
创建 JTableHeader 的鼠标侦听器。
createMouseInputListener() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
创建 JTable 的鼠标侦听器。
createMouseListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将观察组合框上的鼠标按下和释放事件的侦听器。
createMouseListener() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
createMouseListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建负责基于鼠标事件更新选择的侦听器。
createMouseMotionListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将添加到组合框的鼠标移动侦听器。
createMouseWheelListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
创建一个 MouseWheelListener 的实例，该实例由 installUI() 添加到 JScrollPane。
createMultiDocPrintJob() - 接口 javax.print.MultiDocPrintService 中的方法
创建一个可打印 multiDoc 的作业。
createName(String, String, String) - 接口 javax.xml.soap.SOAPEnvelope 中的方法
创建使用给定本地名称、名称空间前缀和名称空间 URL 初始化的新 Name 对象。
createName(String) - 接口 javax.xml.soap.SOAPEnvelope 中的方法
创建使用给定本地名称初始化的新 Name 对象。
createName(String, String, String) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定本地名称、名称空间前缀和名称空间 URI 初始化的新 Name 对象。
createName(String) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定本地名称初始化的新 Name 对象。
createName(String, Oid) - 类 org.ietf.jgss.GSSManager 中的方法
将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。
createName(byte[], Oid) - 类 org.ietf.jgss.GSSManager 中的方法
将包含名称的字节数组从指定的名称空间转换到 GSSName 对象的 Factory 方法。
createName(String, Oid, Oid) - 类 org.ietf.jgss.GSSManager 中的方法
将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
createName(byte[], Oid, Oid) - 类 org.ietf.jgss.GSSManager 中的方法
将包含名称的字符串数组从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
createNamespace(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新的默认 Namespace。
createNamespace(String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新的 Namespace。
createNClob() - 接口 java.sql.Connection 中的方法
构造实现 NClob 接口的对象。
createNewFile() - 类 java.io.File 中的方法
当且仅当不存在具有此抽象路径名指定名称的文件时，不可分地创建一个新的空文件。
createNewFolder(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
创建具有默认文件夹名称的新文件夹。
createNextButton() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
创建将用 spinner.getNextValue 返回的对象取代 spinner 模型值的组件。
createNodeDimensions() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建能够确定树中给定节点大小的 NodeDimensions 的实例。
createNonRolloverBorder() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
创建工具栏组件的非翻转边框。
createNonRolloverBorder() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
createNorthPane(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createNorthPane(JInternalFrame) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
createObjectFactory(Object, Hashtable<?, ?>) - 接口 javax.naming.spi.ObjectFactoryBuilder 中的方法
使用所提供的环境创建一个新对象工厂。
createOutput(String, String) - 类 javax.xml.bind.SchemaOutputResolver 中的方法
确定写入模式文件（由给定名称空间 URI 指定）的位置，并以 Result 对象的形式返回它。
createOutputStreamInstance(Object, boolean, File) - 类 javax.imageio.spi.ImageOutputStreamSpi 中的方法
返回与此服务提供者关联的 ImageOutputStream 实现的实例。
createOutputStreamInstance(Object) - 类 javax.imageio.spi.ImageOutputStreamSpi 中的方法
返回与此服务提供者关联的 ImageOutputStream 实现的实例。
createPacked(ColorSpace, int, int, int, int, int, boolean) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回压缩图像格式的说明符，它将使用 DirectColorModel 和一个压缩的 SampleModel 来存储压缩成单个 byte、short 或 int 值的像素。
createPackedRaster(int, int, int, int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 SinglePixelPackedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 掩码的 Raster。
createPackedRaster(int, int, int, int, int, Point) - 类 java.awt.image.Raster 中的静态方法
根据打包的 SampleModel 创建一个具有指定数据类型、宽度、高度、band 数和每 band 位数的 Raster。
createPackedRaster(DataBuffer, int, int, int, int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 SinglePixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 Raster。
createPackedRaster(DataBuffer, int, int, int, Point) - 类 java.awt.image.Raster 中的静态方法
根据 MultiPixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度和每像素位数的 Raster。
createPanel(Panel) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Panel 实现。
createParallelGroup() - 类 javax.swing.GroupLayout 中的方法
使用 Alignment.LEADING 的对齐方式创建并返回一个 ParallelGroup。
createParallelGroup(GroupLayout.Alignment) - 类 javax.swing.GroupLayout 中的方法
使用指定的对齐方式创建并返回一个 ParallelGroup。
createParallelGroup(GroupLayout.Alignment, boolean) - 类 javax.swing.GroupLayout 中的方法
使用指定的对齐方式和调整大小行为创建并返回一个 ParallelGroup。
createPopup() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建组合框的弹出部分。
createPopup() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
createPopupMenu(PopupMenu) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 PopupMenu 实现。
createPosition(int) - 接口 javax.swing.text.AbstractDocument.Content 中的方法
在内容中创建一个位置，该位置将在内容改变时跟踪更改。
createPosition(int) - 类 javax.swing.text.AbstractDocument 中的方法
返回更改文档时，将跟踪更改的位置。
createPosition(int) - 接口 javax.swing.text.Document 中的方法
此方法允许应用程序在字符内容序列中标记位置。
createPosition(int) - 类 javax.swing.text.GapContent 中的方法
在内容中创建一个位置，使其在内容发生变化时能跟踪内容的更改。
createPosition(int) - 类 javax.swing.text.StringContent 中的方法
在内容中创建一个位置，让其跟踪随内容的变化而进行的更改。
createPreviousButton() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
创建将用 spinner.getPreviousValue 返回的对象取代 spinner 模型值的组件。
createPrintJob() - 接口 javax.print.PrintService 中的方法
创建并返回一个 PrintJob，它应能够处理取自任意受支持的 docflavor 的数据。
createProcessingInstruction(String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个处理指令。
createProcessingInstruction(String, String) - 接口 org.w3c.dom.Document 中的方法
创建给定指定名称和数据字符串的 ProcessingInstruction 节点。
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将添加到组合框的 PropertyChangeListener。
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将添加到组合框的 PropertyChangeListener。
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
返回要安装到 JDesktopPane 上的 PropertyChangeListener。
createPropertyChangeListener(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
创建由 installUI() 添加到 JList 的 PropertyChangeHandler 的实例。
createPropertyChangeListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
创建一个将被添加到菜单项的 PropertyChangeListener。
createPropertyChangeListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
创建由 installUI() 添加到 JScrollPane 的 PropertyChangeListener 的实例。
createPropertyChangeListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
创建一个可以添加到 JSpinner 本身的 PropertyChangeListener。
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
创建 JSplitPane UI 的 PropertyChangeListener。
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建负责基于树的更改方式更新 UI 的侦听器。
createPropertyChangeListener() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
createPropertyChangeListener(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
createPropertyChangeListener(JSlider) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
createPropertyEditor(Object) - 类 java.beans.PropertyDescriptor 中的方法
使用当前属性编辑器类构造一个属性编辑器实例。
createPropertyListener() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createQName(String, String) - 接口 javax.xml.soap.SOAPElement 中的方法
创建一个 QName，其名称空间 URI 应与此 SOAPElement 上下文中的参数、prefix 相关联。
createRaisedBevelBorder() - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有凸出斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
createRaster(SampleModel, DataBuffer, Point) - 类 java.awt.image.Raster 中的静态方法
创建具有指定 SampleModel 和 DataBuffer 的 Raster。
createReaderInstance() - 类 javax.imageio.spi.ImageReaderSpi 中的方法
返回与此服务提供者关联的 ImageReader 实现的实例。
createReaderInstance(Object) - 类 javax.imageio.spi.ImageReaderSpi 中的方法
返回与此服务提供者关联的 ImageReader 实现的实例。
createRegistry(int) - 类 java.rmi.registry.LocateRegistry 中的静态方法
创建并导出接受指定 port 请求的本地主机上的 Registry 实例。
createRegistry(int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.registry.LocateRegistry 中的静态方法
在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。
createRelation(String, String, RoleList) - 类 javax.management.relation.RelationService 中的方法
创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
createRelation(String, String, RoleList) - 接口 javax.management.relation.RelationServiceMBean 中的方法
创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
createRelationType(String, RoleInfo[]) - 类 javax.management.relation.RelationService 中的方法
用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
createRelationType(String, RoleInfo[]) - 接口 javax.management.relation.RelationServiceMBean 中的方法
用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
createRenderer() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将在不可编辑的组合框中使用的默认渲染器。
createRendering(RenderContext) - 接口 java.awt.image.renderable.RenderableImage 中的方法
使用给定的 RenderContext 创建表示此图像一个呈现的 RenderedImage。
createRendering(RenderContext) - 类 java.awt.image.renderable.RenderableImageOp 中的方法
创建一个表示根据给定 RenderContext 呈现的 RenderableImageOp（包括其 Renderable 源）的 RenderedImage。
createReply() - 接口 org.omg.CORBA.portable.ResponseHandler 中的方法
在方法调用期间由 servant 调用。
createResource(JavaFileManager.Location, CharSequence, CharSequence, Element...) - 接口 javax.annotation.processing.Filer 中的方法
创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
createRightOneTouchButton() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的右边组件。
createRigidArea(Dimension) - 类 javax.swing.Box 中的静态方法
创建一个总是具有指定大小的不可见组件。
createRolloverBorder() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
创建工具栏组件的翻转边框。
createRolloverBorder() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
createRolloverListener() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
创建一个将添加到 JToolBar 中的属性更改侦听器。
createRootLayout() - 类 javax.swing.JRootPane 中的方法
由构造方法调用以便创建默认的 layoutManager。
createRootPane() - 类 javax.swing.JApplet 中的方法
构造方法调用此方法创建默认 rootPane。
createRootPane() - 类 javax.swing.JDialog 中的方法
构造方法调用此方法来创建默认的 rootPane。
createRootPane() - 类 javax.swing.JFrame 中的方法
由构造方法调用，以创建默认的 rootPane。
createRootPane() - 类 javax.swing.JInternalFrame 中的方法
构造方法调用此方法来设置 JRootPane。
createRootPane() - 类 javax.swing.JWindow 中的方法
由该构造方法调用以创建默认的 rootPane。
createRow() - 类 javax.swing.text.FlowView 中的方法
创建应在保持流中子级行值时使用的视图。
createRow() - 类 javax.swing.text.ParagraphView 中的方法
创建用于在流中存储子级行值的 View。
createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler) - 类 javax.security.sasl.Sasl 中的静态方法
使用提供的参数创建 SaslClient。
createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler) - 接口 javax.security.sasl.SaslClientFactory 中的方法
使用提供的参数创建 SaslClient。
createSaslServer(String, String, String, Map<String, ?>, CallbackHandler) - 类 javax.security.sasl.Sasl 中的静态方法
为指定机制创建一个 SaslServer。
createSaslServer(String, String, String, Map<String, ?>, CallbackHandler) - 接口 javax.security.sasl.SaslServerFactory 中的方法
使用提供的参数创建 SaslServer。
createScaledRendering(int, int, RenderingHints) - 接口 java.awt.image.renderable.RenderableImage 中的方法
创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
createScaledRendering(int, int, RenderingHints) - 类 java.awt.image.renderable.RenderableImageOp 中的方法
创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
createScreenCapture(Rectangle) - 类 java.awt.Robot 中的方法
创建包含从屏幕中读取的像素的图像。
createScrollbar(Scrollbar) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Scrollbar 实现。
createScrollBarSwapListener() - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的方法
createScrollButton(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
创建并返回一个 JButton，它将为用户提供朝某一特定方向滚动选项卡的方式。
createScroller() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建容纳可滚动列表的滚动窗格。
createScrollListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createScrollListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createScrollPane(ScrollPane) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 ScrollPane 实现。
createScrollPaneForTable(JTable) - 类 javax.swing.JTable 中的静态方法
已过时。 从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。
createSelectionModel() - 类 javax.swing.JList 中的方法
返回一个 DefaultListSelectionModel 实例；在构造期间调用此方法初始化列表的选择模型属性。
createSelectionModel() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
创建新的默认列表选择模型。
createSelectionModelPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建负责从选择模型获取属性更改事件的侦听器。
createSeparator() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
createSequentialGroup() - 类 javax.swing.GroupLayout 中的方法
创建并返回一个 SequentialGroup。
createServerSocket(int) - 接口 java.rmi.server.RMIServerSocketFactory 中的方法
在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
createServerSocket(int) - 类 java.rmi.server.RMISocketFactory 中的方法
在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
createServerSocket() - 类 javax.net.ServerSocketFactory 中的方法
返回未绑定的服务器套接字。
createServerSocket(int) - 类 javax.net.ServerSocketFactory 中的方法
返回绑定到指定端口的服务器套接字。
createServerSocket(int, int) - 类 javax.net.ServerSocketFactory 中的方法
返回绑定到指定端口的服务器套接字，并且使用指定的连接 backlog。
createServerSocket(int, int, InetAddress) - 类 javax.net.ServerSocketFactory 中的方法
返回绑定到指定端口的服务器套接字，该套接字带有指定的侦听 backlog 和本地 IP。
createServerSocket(int) - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
创建一个服务器套接字，该套接字接受根据此工厂的 SSL 套接字配置参数配置的 SSL 连接。
createServiceDelegate(URL, QName, Class) - 类 javax.xml.ws.spi.Provider 中的方法
创建一个服务委托对象。
createShared() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回一个新的 RowSet 对象，支持该对象的数据与此 CachedRowSet 对象的相同。
createSmallAttributeSet(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
创建可以共享的属性压缩集。
createSmallAttributeSet(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
创建一个可能用于共享的压缩属性集。
createSocket(String, int) - 接口 java.rmi.server.RMIClientSocketFactory 中的方法
创建连接到指定主机和端口的客户机套接字。
createSocket(String, int) - 类 java.rmi.server.RMISocketFactory 中的方法
创建连接到指定主机和端口的客户机套接字。
createSocket() - 类 javax.net.SocketFactory 中的方法
创建一个未连接的套接字。
createSocket(String, int) - 类 javax.net.SocketFactory 中的方法
创建一个套接字并把它连接到指定远程主机上的指定远程端口。
createSocket(String, int, InetAddress, int) - 类 javax.net.SocketFactory 中的方法
创建一个套接字并把它连接到指定远程主机上的指定远程端口。
createSocket(InetAddress, int) - 类 javax.net.SocketFactory 中的方法
创建一个套接字并把它连接到指定地址上的指定端口号。
createSocket(InetAddress, int, InetAddress, int) - 类 javax.net.SocketFactory 中的方法
创建一个套接字并把它连接到指定远程端口上的指定远程地址。
createSocket(Socket, String, int, boolean) - 类 javax.net.ssl.SSLSocketFactory 中的方法
返回在连接到指定主机的给定端口的现有套接字上分层的套接字。
createSocket(String, int) - 类 javax.rmi.ssl.SslRMIClientSocketFactory 中的方法
创建一个 SSL 套接字。
createSocketImpl() - 接口 java.net.SocketImplFactory 中的方法
创建新的 SocketImpl 实例。
createSourceFile(CharSequence, Element...) - 接口 javax.annotation.processing.Filer 中的方法
创建一个新的源文件，并返回一个对象以允许写入它。
createSouthPane(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createSpace(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 isSpace 标记设置为 true 的 Character 事件。
createSQLXML() - 接口 java.sql.Connection 中的方法
构造实现 SQLXML 接口的对象。
createSSLEngine() - 类 javax.net.ssl.SSLContext 中的方法
使用此上下文创建新的 SSLEngine。
createSSLEngine(String, int) - 类 javax.net.ssl.SSLContext 中的方法
使用此上下文创建新的 SSLEngine，该上下文使用劝告同位体信息。
createStandardLabels(int) - 类 javax.swing.JSlider 中的方法
创建一个数字文本标签的 Hashtable，从滑块最小值处开始并使用指定的增量。
createStandardLabels(int, int) - 类 javax.swing.JSlider 中的方法
创建一个数字文本标签的 Hashtable，从指定起始点处开始并使用指定的增量。
createStartDocument() - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 StartDocument 事件的新实例。
createStartDocument(String, String, boolean) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 StartDocument 事件的新实例。
createStartDocument(String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 StartDocument 事件的新实例。
createStartDocument(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 StartDocument 事件的新实例。
createStartElement(QName, Iterator, Iterator) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 StartElement。
createStartElement(String, String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 StartElement。
createStartElement(String, String, String, Iterator, Iterator) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 StartElement。
createStartElement(String, String, String, Iterator, Iterator, NamespaceContext) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 StartElement。
createStatement() - 接口 java.sql.Connection 中的方法
创建一个 Statement 对象来将 SQL 语句发送到数据库。
createStatement(int, int) - 接口 java.sql.Connection 中的方法
创建一个 Statement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
createStatement(int, int, int) - 接口 java.sql.Connection 中的方法
创建一个 Statement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
createStrokedShape(Shape) - 类 java.awt.BasicStroke 中的方法
返回一个 Shape，它在内部定义了指定 Shape 的笔划轮廓。
createStrokedShape(Shape) - 接口 java.awt.Stroke 中的方法
返回一个轮廓 Shape，它封闭了应该在根据规则描绘 Shape 时绘制的区域，这些规则是由实现 Stroke 接口的对象定义的。
createStruct(String, Object[]) - 接口 java.sql.Connection 中的方法
创建 Struct 对象的工厂方法。
createSubcontext(Name) - 接口 javax.naming.Context 中的方法
创建并绑定一个新上下文。
createSubcontext(String) - 接口 javax.naming.Context 中的方法
创建并绑定一个新上下文。
createSubcontext(Name, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
创建并绑定新的上下文及关联的属性。
createSubcontext(String, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
创建并绑定新的上下文及关联的属性。
createSubcontext(String, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
createSubcontext(Name, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
createSubcontext(String) - 类 javax.naming.InitialContext 中的方法
createSubcontext(Name) - 类 javax.naming.InitialContext 中的方法
createSubsetSampleModel(int[]) - 类 java.awt.image.BandedSampleModel 中的方法
创建一个具有此 BandedSampleModel 的 band 子集的新 BandedSampleModel。
createSubsetSampleModel(int[]) - 类 java.awt.image.ComponentSampleModel 中的方法
创建具有此 ComponentSampleModel 的 band 子集的新 ComponentSampleModel。
createSubsetSampleModel(int[]) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
创建一个具有此 MultiPixelPackedSampleModel band 子集的新 MultiPixelPackedSampleModel。
createSubsetSampleModel(int[]) - 类 java.awt.image.PixelInterleavedSampleModel 中的方法
创建一个具有此 PixelInterleavedSampleModel 的 band 子集的 PixelInterleavedSampleModel。
createSubsetSampleModel(int[]) - 类 java.awt.image.SampleModel 中的方法
创建一个新 SampleModel，它具有此 SampleModel 的 band 子集。
createSubsetSampleModel(int[]) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
创建一个新 SinglePixelPackedSampleModel，使其具有此 SinglePixelPackedSampleModel 的 band 子集。
createSystemMenu() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createSystemMenuBar() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createTableCell(Element) - 类 javax.swing.text.TableView 中的方法
已过时。 现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。
createTableRow(Element) - 类 javax.swing.text.TableView 中的方法
创建新的表格行。
createTempFile(String, String, File) - 类 java.io.File 中的静态方法
在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
createTempFile(String, String) - 类 java.io.File 中的静态方法
在默认临时文件目录中创建一个空文件，使用给定前缀和后缀生成其名称。
createTextArea(TextArea) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 TextArea 实现。
createTextField(TextField) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 TextField 实现。
createTextNode(String) - 接口 org.w3c.dom.Document 中的方法
创建给定指定字符串的 Text 节点。
createTitledBorder(String) - 类 javax.swing.BorderFactory 中的静态方法
创建一个新标题边框，使其具有指定的标题、默认的边框类型（由当前外观确定）、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
createTitledBorder(Border) - 类 javax.swing.BorderFactory 中的静态方法
创建一个空标题的新标题边框，使其具有指定的边框对象、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
createTitledBorder(Border, String) - 类 javax.swing.BorderFactory 中的静态方法
向现有边框添加一个标题，使其具有默认的位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
createTitledBorder(Border, String, int, int) - 类 javax.swing.BorderFactory 中的静态方法
向现有边框添加一个标题，使其具有指定的位置和默认字体和文本颜色（由当前外观确定）。
createTitledBorder(Border, String, int, int, Font) - 类 javax.swing.BorderFactory 中的静态方法
向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。
createTitledBorder(Border, String, int, int, Font, Color) - 类 javax.swing.BorderFactory 中的静态方法
向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
createToolBarContListener() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createToolBarFocusListener() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createToolTip() - 类 javax.swing.JComponent 中的方法
返回用于显示工具提示的 JToolTip 实例。
createTrack() - 类 javax.sound.midi.Sequence 中的方法
创建一个新的、初始为空的轨道作为此 Sequence 的一部分。
createTrackListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createTrackListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createTranscoderInstance() - 类 javax.imageio.spi.ImageTranscoderSpi 中的方法
返回与此服务提供者关联的 ImageTranscoder 实现的实例。
createTransferable(JComponent) - 类 javax.swing.TransferHandler 中的方法
创建一个要用作数据传输源的 Transferable。
createTransferableProxy(Transferable, boolean) - 类 java.awt.dnd.DropTargetContext 中的方法
创建一个代理指定 Transferable 的 TransferableProxy。
createTransformedArea(AffineTransform) - 类 java.awt.geom.Area 中的方法
创建一个新 Area 对象，使它与由指定 AffineTransform 变换的 Area 包含相同的几何形状。
createTransformedShape(Shape) - 类 java.awt.geom.AffineTransform 中的方法
返回新的 Shape 对象，它在通过此变换之后，由指定 Shape 的几何形状定义。
createTransformedShape(AffineTransform) - 类 java.awt.geom.Path2D 中的方法
返回一个表示此 Path2D 变换形式的新 Shape。
createTranslatedChild(int, int) - 类 java.awt.image.Raster 中的方法
创建一个 Raster，使其大小、SampleModel 和 DataBuffer 与此 Raster 相同，但是位置不同。
createTreeCellEditor() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果构造方法中没有提供 TreeCellEditor，则调用此方法。
createTreeExpansionListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建并返回在节点展开状态更改时负责更新 treestate 的对象。
createTreeModel(Object) - 类 javax.swing.JTree 中的静态方法
返回一个 TreeModel，它包装指定的对象。
createTreeModelListener() - 类 javax.swing.JTree 中的方法
创建并返回 TreeModelHandler 的一个实例。
createTreeModelListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回可以在模型更改时更新树的侦听器。
createTreeSelectionListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建基于选择更改方法更新显示的侦听器。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicCheckBoxUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的静态方法
创建 JTextPane 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicFormattedTextFieldUI 中的静态方法
创建 JFormattedTextField 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的静态方法
返回 BasicListUI 的新实例。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的静态方法
创建一个新的 BasicOptionPaneUI 实例。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicPanelUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicPasswordFieldUI 中的静态方法
创建 JPasswordField 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的静态方法
返回 BasicSpinnerUI 的新实例。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的静态方法
创建新的 BasicSplitPaneUI 实例
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的静态方法
创建 JTextArea 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextFieldUI 中的静态方法
创建 JTextField 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextPaneUI 中的静态方法
创建 JTextPane 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicToggleButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicViewportUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.ComponentUI 中的静态方法
返回指定组件的一个 UI 委托实例。
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalCheckBoxUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalLabelUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalMenuBarUI 中的静态方法
为传入的组件创建 ComponentUI 实现。
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalProgressBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalRootPaneUI 中的静态方法
为 JRootPane 创建一个 UI。
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalSeparatorUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalSplitPaneUI 中的静态方法
创建一个新的 MetalSplitPaneUI 实例
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalTextFieldUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolTipUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalTreeUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
为传入的 JComponent 创建 Synth 外观 ComponentUI。
createUIs(ComponentUI, Vector, JComponent) - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的静态方法
创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。
createUnion(Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
createUnion(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Double 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
createUnion(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Float 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
createUnion(Rectangle2D) - 类 java.awt.Rectangle 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
createUnmarshalException(SAXException) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
从 SAXException 创建 UnmarshalException。
createUnmarshaller(ValidationEventHandler) - 接口 javax.xml.bind.annotation.DomHandler 中的方法
当 JAXB 提供者需要将文档的一部分解组为信息集表示形式时，首先要调用此方法创建一个 Result 对象。
createUnmarshaller(ValidationEventHandler) - 类 javax.xml.bind.annotation.W3CDomHandler 中的方法
createUnmarshaller() - 类 javax.xml.bind.JAXBContext 中的方法
创建一个可以用来将 XML 数据转换为 java 内容树的 Unmarshaller 对象。
createUnresolved(String, int) - 类 java.net.InetSocketAddress 中的静态方法
根据主机名和端口号创建未解析的套接字地址。
createURLStreamHandler(String) - 接口 java.net.URLStreamHandlerFactory 中的方法
创建具有指定协议的新 URLStreamHandler 实例。
createValidator() - 类 javax.xml.bind.JAXBContext 中的方法
已过时。 从 JAXB 2.0 开始
createValue(UIDefaults) - 接口 javax.swing.UIDefaults.ActiveValue 中的方法
创建从 UIDefaults 表中检索的值。
createValue(UIDefaults) - 类 javax.swing.UIDefaults.LazyInputMap 中的方法
使用传入的绑定创建一个 InputMap。
createValue(UIDefaults) - 接口 javax.swing.UIDefaults.LazyValue 中的方法
创建从 UIDefaults 表中检索的实际值。
createValue(UIDefaults) - 类 javax.swing.UIDefaults.ProxyLazyValue 中的方法
创建从 UIDefaults 表中检索的值。
createValueHandler() - 类 javax.rmi.CORBA.Util 中的静态方法
返回实现 ValueHandler 接口的类的单一实例。
createValueHandler() - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.createValueHandler() 的委托调用。
createVerticalBox() - 类 javax.swing.Box 中的静态方法
创建一个从上到下显示其组件的 Box。
createVerticalGlue() - 类 javax.swing.Box 中的静态方法
创建一个纵向 glue 组件。
createVerticalScrollBar() - 类 javax.swing.JScrollPane 中的方法
默认返回 JScrollPane.ScrollBar。
createVerticalStrut(int) - 类 javax.swing.Box 中的静态方法
创建一个不可见的、固定高度的组件。
createView(FlowView, int, int, int) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
创建一个可用于表示流的当前片段的视图。
createViewListener() - 类 javax.swing.JViewport 中的方法
为该视图创建侦听器。
createViewport() - 类 javax.swing.JScrollPane 中的方法
默认返回新的 JViewport。
createViewportChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
createVolatileImage(int, int) - 类 java.awt.Component 中的方法
创建一幅用于双缓冲的、可变的、可在屏幕外绘制的图像。
createVolatileImage(int, int, ImageCapabilities) - 类 java.awt.Component 中的方法
创建一幅具有给定能力的、可变的、可在屏幕外绘制的图像。
createVSBChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
createWestPane(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createWindow(Window) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Window 实现。
createWinListener(JPopupMenu) - 类 javax.swing.JMenu 中的方法
创建弹出菜单的窗口关闭侦听器。
createWritableChild(int, int, int, int, int, int, int[]) - 类 java.awt.image.WritableRaster 中的方法
返回新的 WritableRaster，它共享此 WritableRaster 的全部或部分 DataBuffer。
createWritableRaster(SampleModel, Point) - 类 java.awt.image.Raster 中的静态方法
创建一个具有指定 SampleModel 的 WritableRaster。
createWritableRaster(SampleModel, DataBuffer, Point) - 类 java.awt.image.Raster 中的静态方法
创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
createWritableTranslatedChild(int, int) - 类 java.awt.image.WritableRaster 中的方法
在不同的位置上创建一个与此 WritableRaster 具有相同大小、SampleModel 和 DataBuffer 的 WritableRaster。
createWriterInstance() - 类 javax.imageio.spi.ImageWriterSpi 中的方法
返回与此服务提供者关联的 ImageWriter 实现的实例。
createWriterInstance(Object) - 类 javax.imageio.spi.ImageWriterSpi 中的方法
返回与此服务提供者关联的 ImageWriter 实现的实例。
createXMLEventReader(Reader) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 reader 创建一个新 XMLEventReader。
createXMLEventReader(String, Reader) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 reader 创建一个新 XMLEventReader。
createXMLEventReader(XMLStreamReader) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 XMLStreamReader 创建一个新 XMLEventReader。
createXMLEventReader(Source) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 JAXP 源创建一个新 XMLEventReader。
createXMLEventReader(InputStream) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLEventReader。
createXMLEventReader(InputStream, String) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLEventReader。
createXMLEventReader(String, InputStream) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLEventReader。
createXMLEventWriter(Result) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到 JAXP 结果的新 XMLEventWriter。
createXMLEventWriter(OutputStream) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到流的新 XMLEventWriter。
createXMLEventWriter(OutputStream, String) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到流的新 XMLEventWriter。
createXMLEventWriter(Writer) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到 writer 的新 XMLEventWriter。
createXMLReader() - 类 org.xml.sax.helpers.XMLReaderFactory 中的静态方法
尝试从系统默认值创建一个 XMLReader。
createXMLReader(String) - 类 org.xml.sax.helpers.XMLReaderFactory 中的静态方法
尝试从类名称创建一个 XML 阅读器。
createXMLStreamReader(Reader) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 reader 创建一个新 XMLStreamReader。
createXMLStreamReader(Source) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 JAXP 源创建一个新 XMLStreamReader。
createXMLStreamReader(InputStream) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLStreamReader。
createXMLStreamReader(InputStream, String) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLStreamReader。
createXMLStreamReader(String, InputStream) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLStreamReader。
createXMLStreamReader(String, Reader) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLStreamReader。
createXMLStreamWriter(Writer) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到 writer 的新 XMLStreamWriter。
createXMLStreamWriter(OutputStream) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到流的新 XMLStreamWriter。
createXMLStreamWriter(OutputStream, String) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到流的新 XMLStreamWriter。
createXMLStreamWriter(Result) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到 JAXP 结果的新 XMLStreamWriter。
createZipEntry(String) - 类 java.util.jar.JarInputStream 中的方法
为指定的 JAR 文件条目名称创建新的 JarEntry (ZipEntry)。
createZipEntry(String) - 类 java.util.zip.ZipInputStream 中的方法
为指定条目名称创建一个新的 ZipEntry 对象。
createZone(int, int) - 类 javax.swing.text.ZoneView 中的方法
针对模型中的给定范围（应该在此对象的职责范围内），创建一个视图来表示分区。
CredentialException - javax.security.auth.login 中的 异常
一般证书异常。
CredentialException() - 异常 javax.security.auth.login.CredentialException 的构造方法
构造不带详细消息的 CredentialException。
CredentialException(String) - 异常 javax.security.auth.login.CredentialException 的构造方法
构造带指定详细消息的 CredentialException。
CredentialExpiredException - javax.security.auth.login 中的 异常
当 Credential 到期时抛出此异常。
CredentialExpiredException() - 异常 javax.security.auth.login.CredentialExpiredException 的构造方法
构造不带详细消息的 CredentialExpiredException。
CredentialExpiredException(String) - 异常 javax.security.auth.login.CredentialExpiredException 的构造方法
构造带指定详细消息的 CredentialExpiredException。
CredentialNotFoundException - javax.security.auth.login 中的 异常
找不到证书时抛出此异常。
CredentialNotFoundException() - 异常 javax.security.auth.login.CredentialNotFoundException 的构造方法
构造不带详细消息的 CredentialNotFoundException。
CredentialNotFoundException(String) - 异常 javax.security.auth.login.CredentialNotFoundException 的构造方法
构造带指定详细消息的 CredentialNotFoundException。
CREDENTIALS - 接口 javax.management.remote.JMXConnector 中的静态变量
属性的名称，它指定了连接过程中发送给连接器服务器的凭据。
CREDENTIALS - 类 javax.security.sasl.Sasl 中的静态变量
属性的名称，它指定要使用的证书。
CREDENTIALS_EXPIRED - 异常 org.ietf.jgss.GSSException 中的静态变量
过期的凭据。
CRITICAL - 接口 javax.naming.ldap.Control 中的静态变量
指示关键控件。
criticality - 类 javax.naming.ldap.BasicControl 中的变量
控件的关键性。
CRL - java.security.cert 中的 类
此类是具有不同格式但很常用的证书撤消列表 (CRL) 的抽象。
CRL(String) - 类 java.security.cert.CRL 的构造方法
创建指定类型的 CRL。
CRLException - java.security.cert 中的 异常
CRL（证书撤消列表）异常。
CRLException() - 异常 java.security.cert.CRLException 的构造方法
构造不带详细消息的 CRLException。
CRLException(String) - 异常 java.security.cert.CRLException 的构造方法
构造带指定详细消息的 CRLException。
CRLException(String, Throwable) - 异常 java.security.cert.CRLException 的构造方法
创建带指定详细消息和 cause 的 CRLException。
CRLException(Throwable) - 异常 java.security.cert.CRLException 的构造方法
创建带指定 cause 和详细消息的 CRLException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CRLSelector - java.security.cert 中的 接口
一个定义了一套选择 CRL 的标准的选择器。
CropImageFilter - java.awt.image 中的 类
用于裁剪图像的 ImageFilter 类。
CropImageFilter(int, int, int, int) - 类 java.awt.image.CropImageFilter 的构造方法
按指定 x、y、w 和 h 参数从源 Image 提取绝对矩形区域来构造 CropImageFilter。
CROSS_JOIN - 接口 javax.sql.rowset.JoinRowSet 中的静态变量
ANSI 风格的 JOIN，提供两个表的交叉乘积。
CROSSHAIR_CURSOR - 类 java.awt.Cursor 中的静态变量
十字光标类型。
CROSSHAIR_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.CROSSHAIR_CURSOR 取代。
CS_CIEXYZ - 类 java.awt.color.ColorSpace 中的静态变量
上面定义的 CIEXYZ 变换颜色空间。
CS_GRAY - 类 java.awt.color.ColorSpace 中的静态变量
内置的线性灰度颜色空间。
CS_LINEAR_RGB - 类 java.awt.color.ColorSpace 中的静态变量
内置的线性 RGB 颜色空间。
CS_PYCC - 类 java.awt.color.ColorSpace 中的静态变量
Photo YCC 变换颜色空间。
CS_sRGB - 类 java.awt.color.ColorSpace 中的静态变量
sRGB 颜色空间的定义位于 http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html。
CSS - javax.swing.text.html 中的 类
将 CSS attributes 集定义为类型安全的枚举。
CSS() - 类 javax.swing.text.html.CSS 的构造方法
CSS.Attribute - javax.swing.text.html 中的 类
用作 AttributeSet 的键的定义，此属性集可存储 CSS 属性。
CTRL_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Control 键的扩展修饰符常量。
CTRL_MASK - 类 java.awt.event.ActionEvent 中的静态变量
Ctrl 修饰符。
CTRL_MASK - 类 java.awt.Event 中的静态变量
此标志指示当事件发生时按下 Control 键。
CTRL_MASK - 类 java.awt.event.InputEvent 中的静态变量
Ctrl 键修饰符常量。
ctrlx - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段控制点的 X 坐标。
ctrlx - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段控制点的 X 坐标。
ctrlx1 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段第一个控制点的 X 坐标。
ctrlx1 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段第一个控制点的 X 坐标。
ctrlx2 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段第二个控制点的 X 坐标。
ctrlx2 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段第二个控制点的 X 坐标。
ctrly - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段控制点的 Y 坐标。
ctrly - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段控制点的 Y 坐标。
ctrly1 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段第一个控制点的 Y 坐标。
ctrly1 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段第一个控制点的 Y 坐标。
ctrly2 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段第二个控制点的 Y 坐标。
ctrly2 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段第二个控制点的 Y 坐标。
ctx() - 类 org.omg.CORBA.Request 中的方法
检索用于此请求的 Context 对象。
ctx(Context) - 类 org.omg.CORBA.Request 中的方法
将此请求的 Context 对象设置为给定对象。
ctx() - 类 org.omg.CORBA.ServerRequest 中的方法
当操作不是一个属性访问并且该操作的 IDL 定义中包含上下文表达式时，该操作返回用 IDL 指定的上下文信息；否则返回 nil Context 引用。
CTX_RESTRICT_SCOPE - org.omg.CORBA 中的 接口
可以用作 Context.get_values 方法的第二个参数以限制搜索范围的标志。
CubicCurve2D - java.awt.geom 中的 类
CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。
CubicCurve2D() - 类 java.awt.geom.CubicCurve2D 的构造方法
这是一个不可直接实例化的抽象类。
CubicCurve2D.Double - java.awt.geom 中的 类
使用 double 坐标指定的三次参数曲线段。
CubicCurve2D.Double() - 类 java.awt.geom.CubicCurve2D.Double 的构造方法
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 CubicCurve。
CubicCurve2D.Double(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D.Double 的构造方法
根据指定的 double 坐标构造并初始化一个 CubicCurve2D。
CubicCurve2D.Float - java.awt.geom 中的 类
使用 float 坐标指定的三次参数曲线段。
CubicCurve2D.Float() - 类 java.awt.geom.CubicCurve2D.Float 的构造方法
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 CubicCurve。
CubicCurve2D.Float(float, float, float, float, float, float, float, float) - 类 java.awt.geom.CubicCurve2D.Float 的构造方法
根据指定的 float 坐标构造并初始化一个 CubicCurve2D。
CURRENCY - 类 java.text.NumberFormat.Field 中的静态变量
标识货币字段的常量。
Currency - java.util 中的 类
表示货币。
CURRENCY_SYMBOL - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Sc”。
CURRENCY_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Currency Symbols”Unicode 字符块的常量。
CurrencyNameProvider - java.util.spi 中的 类
为 Currency 类提供本地化货币符号的服务提供者的抽象类。
CurrencyNameProvider() - 类 java.util.spi.CurrencyNameProvider 的构造方法
唯一的构造方法。
current() - 类 java.text.BreakIterator 中的方法
返回最近由 next()、next(int)、previous()、first()、last()、following(int) 或 preceding(int) 返回的文本边界的字符索引。
current() - 接口 java.text.CharacterIterator 中的方法
获取当前位置（由 getIndex() 返回）的字符。
current() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.current()。
current() - 类 javax.swing.text.ElementIterator 中的方法
获取当前 Element。
CURRENT - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
current() - 类 javax.swing.text.Segment 中的方法
获取当前位置（由 getIndex() 返回）的字符。
Current - org.omg.CORBA 中的 接口
从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
Current - org.omg.PortableInterceptor 中的 接口
Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。
Current - org.omg.PortableServer 中的 接口
从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。
current_component() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 返回一个 DynAny 对象引用，可用来获取/设置当前所访问组件的值。
current_component() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
返回当前位置上的组件的 DynAny。
current_factory() - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。
current_factory(ObjectReferenceFactory) - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。
current_member_kind() - 接口 org.omg.CORBA.DynStruct 中的方法
已过时。 返回描述当前成员的种类的 TCKind 对象。
current_member_kind() - 接口 org.omg.CORBA.DynValue 中的方法
已过时。 返回描述当前成员的 TCKind 对象。
current_member_kind() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回与当前位置的成员关联的 TCKind。
current_member_kind() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回与当前位置的成员有关联的 TCKind。
current_member_kind() - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
返回与当前位置的成员关联的 TCKind。
current_member_kind() - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
返回与当前位置的成员关联的 TCKind。
current_member_name() - 接口 org.omg.CORBA.DynStruct 中的方法
已过时。 在遍历期间返回当前成员的名称。
current_member_name() - 接口 org.omg.CORBA.DynValue 中的方法
已过时。 在遍历表示某个 Value 对象的 DynAny 对象时，返回当前成员的名称。
current_member_name() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回当前位置上的成员的名称。
current_member_name() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回当前位置上成员的名称。
current_member_name() - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
返回当前位置的成员的名称。
current_member_name() - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
返回当前位置上的成员的名称。
currentCellRenderer - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
要用于进行实际单元格绘制的渲染器。
currentClassLoader() - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
currentGroupID() - 类 java.rmi.activation.ActivationGroup 中的静态方法
返回当前激活组的标识符。
CurrentHelper - org.omg.CORBA 中的 类
Current 的 Helper。
CurrentHelper() - 类 org.omg.CORBA.CurrentHelper 的构造方法
CurrentHelper - org.omg.PortableInterceptor 中的 类
Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文和请求方或应答的服务上下文之间传输其上下文数据。
CurrentHelper() - 类 org.omg.PortableInterceptor.CurrentHelper 的构造方法
CurrentHelper - org.omg.PortableServer 中的 类
从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。
CurrentHelper() - 类 org.omg.PortableServer.CurrentHelper 的构造方法
CurrentHolder - org.omg.CORBA 中的 类
Current 的 Holder。
CurrentHolder() - 类 org.omg.CORBA.CurrentHolder 的构造方法
CurrentHolder(Current) - 类 org.omg.CORBA.CurrentHolder 的构造方法
currentLoadedClass() - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
currentManager(Component) - 类 javax.swing.RepaintManager 中的静态方法
在给定 Component 的情况下，返回调用线程的 RepaintManager。
currentManager(JComponent) - 类 javax.swing.RepaintManager 中的静态方法
在给定 JComponent 的情况下，返回调用线程的 RepaintManager。
currentMouseX - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的变量
currentMouseX - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的变量
currentMouseY - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的变量
currentMouseY - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的变量
CurrentOperations - org.omg.CORBA 中的 接口
Current 的接口。
CurrentOperations - org.omg.PortableInterceptor 中的 接口
Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。
CurrentOperations - org.omg.PortableServer 中的 接口
从 CORBA::Current 中派生的 PortableServer::Current 接口，它提供一些能够访问调用方法的对象身份的方法实现。
currentSegment(float[]) - 类 java.awt.geom.FlatteningPathIterator 中的方法
使用迭代返回当前路径段的坐标和类型。
currentSegment(double[]) - 类 java.awt.geom.FlatteningPathIterator 中的方法
使用迭代返回当前路径段的坐标和类型。
currentSegment(float[]) - 接口 java.awt.geom.PathIterator 中的方法
使用迭代返回当前路径段的坐标和类型。
currentSegment(double[]) - 接口 java.awt.geom.PathIterator 中的方法
使用迭代返回当前路径段的坐标和类型。
currentThread() - 类 java.lang.Thread 中的静态方法
返回对当前正在执行的线程对象的引用。
currentTimeMillis() - 类 java.lang.System 中的静态方法
返回以毫秒为单位的当前时间。
currentValuePane - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
Cursor - java.awt 中的 类
封装鼠标光标的位图表示形式的类。
Cursor(int) - 类 java.awt.Cursor 的构造方法
用指定类型创建一个新的光标对象。
Cursor(String) - 类 java.awt.Cursor 的构造方法
用指定名称创建一个新的定制光标对象。
cursorMoved(RowSetEvent) - 接口 javax.sql.RowSetListener 中的方法
通知已注册侦听器 RowSet 对象的指针已移动。
curveTo(double, double, double, double, double, double) - 类 java.awt.geom.Path2D 中的方法
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
curveTo(double, double, double, double, double, double) - 类 java.awt.geom.Path2D.Double 中的方法
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
curveTo(double, double, double, double, double, double) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
curveTo(float, float, float, float, float, float) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
CUSTOM_CURSOR - 类 java.awt.Cursor 中的静态变量
与所有定制光标有关的类型。
CUSTOM_DIALOG - 类 javax.swing.JFileChooser 中的静态变量
指示 JFileChooser 支持特定于开发人员文件操作的类型值。
Customizer - java.beans 中的 接口
customizer 类提供一个用来自定义目标 Java Bean 的完全自定义 GUI。
CustomMarshal - org.omg.CORBA 中的 接口
将由 ORB 而不是由用户使用的抽象 value 类型。
CustomValue - org.omg.CORBA.portable 中的 接口
通过自定义值类型实现的 ValueBase 扩展。
cut(int, int) - 接口 javax.accessibility.AccessibleEditableText 中的方法
将两个索引之间的文本剪切到系统剪贴板中。
cut() - 类 javax.swing.JPasswordField 中的方法
对当前外观调用 provideErrorFeedback，这通常启动错误蜂鸣。
cut(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
将两个索引之间的文本剪切到系统剪贴板中。
cut(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
将两个索引之间的文本剪切到系统剪贴板中。
cut() - 类 javax.swing.text.JTextComponent 中的方法
将关联文本模型中当前选定的范围传输到系统剪贴板，并从模型中移除内容。
cutAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
剪切选定区域并将其内容置于剪贴板中的动作名称。
cxt - 异常 org.omg.CosNaming.NamingContextPackage.CannotProceed 中的变量
cyan - 类 java.awt.Color 中的静态变量
青色。
CYAN - 类 java.awt.Color 中的静态变量
青色。
CyclicBarrier - java.util.concurrent 中的 类
一个同步辅助类，它允许一组线程互相等待，直到到达某个公共屏障点 (common barrier point)。
CyclicBarrier(int, Runnable) - 类 java.util.concurrent.CyclicBarrier 的构造方法
创建一个新的 CyclicBarrier，它将在给定数量的参与者（线程）处于等待状态时启动，并在启动 barrier 时执行给定的屏障操作，该操作由最后一个进入 barrier 的线程执行。
CyclicBarrier(int) - 类 java.util.concurrent.CyclicBarrier 的构造方法
创建一个新的 CyclicBarrier，它将在给定数量的参与者（线程）处于等待状态时启动，但它不会在启动 barrier 时执行预定义的操作。
CYPRIOT_SYLLABARY - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Cypriot Syllabary”Unicode 字符块的常量。
CYRILLIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Cyrillic”Unicode 字符块的常量。
CYRILLIC_SUPPLEMENTARY - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Cyrillic Supplementary”Unicode 字符块的常量。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


D - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

D

D - 类 java.awt.PageAttributes.MediaType 中的静态变量
Engineering D (22 x 34 in) 的 MediaType 实例。
D - 类 javax.print.attribute.standard.MediaSize.Engineering 中的静态变量
指定 engineering D 尺寸，22 inch × 34 inch。
D - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
D 尺寸。
damage(Rectangle) - 类 javax.swing.text.DefaultCaret 中的方法
毁坏围绕插入符的区域以使该区域在新的位置重绘。
damageLineRange(int, int, Shape, Component) - 类 javax.swing.text.PlainView 中的方法
重新绘制给定的行范围。
damageRange(JTextComponent, int, int) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
促使重新绘制负责模型给定部分的那部分视图。
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
促使重新绘制负责模型给定部分的那部分视图。
damageRange(JTextComponent, int, int) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 damageRange 方法。
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 damageRange 方法。
damageRange(JTextComponent, int, int) - 类 javax.swing.plaf.TextUI 中的方法
促使重新绘制负责模型给定部分的那部分视图。
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - 类 javax.swing.plaf.TextUI 中的方法
促使重新绘制负责模型给定部分的那部分视图。
DARK - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态变量
DARK_GRAY - 类 java.awt.Color 中的静态变量
深灰色。
darker() - 类 java.awt.Color 中的方法
创建一个新 Color，它具有比此 Color 更暗的颜色。
darkGray - 类 java.awt.Color 中的静态变量
深灰色。
darkShadow - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的变量
darkShadow - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的变量
darkShadow - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
darkShadowColor - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
DASH_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Pd”。
data - 类 javax.sound.midi.MidiMessage 中的变量
MIDI 消息数据。
DATA - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
data - 类 javax.swing.text.html.parser.Element 中的变量
存储用户数据的字段。
data - 类 javax.swing.text.html.parser.Entity 中的变量
Data - javax.xml.crypto 中的 接口
取消引用 URIReference 或后续 Transform 的输入/输出所得结果的抽象表示。
DATA_CONVERSION - org.omg.CORBA 中的 异常
如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
DATA_CONVERSION() - 异常 org.omg.CORBA.DATA_CONVERSION 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(String) - 异常 org.omg.CORBA.DATA_CONVERSION 的构造方法
使用指定详细消息构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(int, CompletionStatus) - 异常 org.omg.CORBA.DATA_CONVERSION 的构造方法
使用指定次要代码和完成状态构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(String, int, CompletionStatus) - 异常 org.omg.CORBA.DATA_CONVERSION 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 DATA_CONVERSION 异常。
DATA_TRANSFER_COMPLETE - 类 javax.print.event.PrintJobEvent 中的静态变量
不必打印该作业，但数据已经成功地从客户端传输到了打印服务。
DatabaseMetaData - java.sql 中的 接口
关于数据库的整体综合信息。
DataBuffer - java.awt.image 中的 类
此类用于包装一个或多个数据数组。
DataBuffer(int, int) - 类 java.awt.image.DataBuffer 的构造方法
构造包含一个指定数据类型和大小的存储单元的 DataBuffer。
DataBuffer(int, int, int) - 类 java.awt.image.DataBuffer 的构造方法
构造包含了指定数量的存储单元的 DataBuffer。
DataBuffer(int, int, int, int) - 类 java.awt.image.DataBuffer 的构造方法
构造包含指定存储单元数量的 DataBuffer。
DataBuffer(int, int, int, int[]) - 类 java.awt.image.DataBuffer 的构造方法
构造包含指定存储单元数量的 DataBuffer。
dataBuffer - 类 java.awt.image.Raster 中的变量
存储图像数据的 DataBuffer。
DataBufferByte - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部按字节存储数据。
DataBufferByte(int) - 类 java.awt.image.DataBufferByte 的构造方法
构造具有单个存储单元和指定大小且基于字节的 DataBuffer。
DataBufferByte(int, int) - 类 java.awt.image.DataBufferByte 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于字节的 DataBuffer。
DataBufferByte(byte[], int) - 类 java.awt.image.DataBufferByte 的构造方法
使用指定数组构造具有单个存储单元且基于字节的 DataBuffer。
DataBufferByte(byte[], int, int) - 类 java.awt.image.DataBufferByte 的构造方法
使用指定数组、大小和偏移量构造具有单个存储单元且基于字节的 DataBuffer。
DataBufferByte(byte[][], int) - 类 java.awt.image.DataBufferByte 的构造方法
构造具有指定数组且基于字节的 DataBuffer。
DataBufferByte(byte[][], int, int[]) - 类 java.awt.image.DataBufferByte 的构造方法
构造具有指定数组、大小和偏移量且基于字节的 DataBuffer。
DataBufferDouble - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部以 double 形式存储数据。
DataBufferDouble(int) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定大小且基于 double 的 DataBuffer。
DataBufferDouble(int, int) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 double 的 DataBuffer。
DataBufferDouble(double[], int) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定数据数组且基于 double 的 DataBuffer。
DataBufferDouble(double[], int, int) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定数据数组且基于 double 的 DataBuffer。
DataBufferDouble(double[][], int) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定数据数组且基于 double 的 DataBuffer。
DataBufferDouble(double[][], int, int[]) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定数据数组、大小和每存储单元偏移量且基于 double 的 DataBuffer。
DataBufferFloat - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部以 float 形式存储数据。
DataBufferFloat(int) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定大小的且基于 float 的 DataBuffer。
DataBufferFloat(int, int) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 float 的 DataBuffer。
DataBufferFloat(float[], int) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定数据数组且基于 float 的 DataBuffer。
DataBufferFloat(float[], int, int) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定数据数组且基于 float 的 DataBuffer。
DataBufferFloat(float[][], int) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定数据数组且基于 float 的 DataBuffer。
DataBufferFloat(float[][], int, int[]) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定数据数组、大小和每存储单元偏移量且基于 float 的 DataBuffer。
DataBufferInt - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部以整数形式存储数据。
DataBufferInt(int) - 类 java.awt.image.DataBufferInt 的构造方法
构造具有单个存储单元和指定大小且基于整数的 DataBuffer。
DataBufferInt(int, int) - 类 java.awt.image.DataBufferInt 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于整数的 DataBuffer。
DataBufferInt(int[], int) - 类 java.awt.image.DataBufferInt 的构造方法
使用指定数组构造具有单个存储单元且基于整数的 DataBuffer。
DataBufferInt(int[], int, int) - 类 java.awt.image.DataBufferInt 的构造方法
使用指定数组、大小和偏移量构造具有单个存储单元且基于整数的 DataBuffer。
DataBufferInt(int[][], int) - 类 java.awt.image.DataBufferInt 的构造方法
构造具有指定数组且基于整数的 DataBuffer。
DataBufferInt(int[][], int, int[]) - 类 java.awt.image.DataBufferInt 的构造方法
构造具有指定数组、大小和偏移量且基于整数的 DataBuffer。
DataBufferShort - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部以 short 类型存储数据。
DataBufferShort(int) - 类 java.awt.image.DataBufferShort 的构造方法
构造具有单个存储单元和指定大小且基于 short 的 DataBuffer。
DataBufferShort(int, int) - 类 java.awt.image.DataBufferShort 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 short 的 DataBuffer。
DataBufferShort(short[], int) - 类 java.awt.image.DataBufferShort 的构造方法
使用指定数组构造具有单个存储单元且基于 short 的 DataBuffer。
DataBufferShort(short[], int, int) - 类 java.awt.image.DataBufferShort 的构造方法
使用指定数组、大小和偏移量构造具有单个存储单元且基于 short 的 DataBuffer。
DataBufferShort(short[][], int) - 类 java.awt.image.DataBufferShort 的构造方法
构造具有指定数组且基于 short 的 DataBuffer。
DataBufferShort(short[][], int, int[]) - 类 java.awt.image.DataBufferShort 的构造方法
构造具有指定数组、大小和偏移量且基于 short 的 DataBuffer。
DataBufferUShort - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部以 short 类型存储数据。
DataBufferUShort(int) - 类 java.awt.image.DataBufferUShort 的构造方法
构造具有单个存储单元和指定大小且基于无符号 short 的 DataBuffer。
DataBufferUShort(int, int) - 类 java.awt.image.DataBufferUShort 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[], int) - 类 java.awt.image.DataBufferUShort 的构造方法
使用指定数组构造具有单个存储单元且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[], int, int) - 类 java.awt.image.DataBufferUShort 的构造方法
使用指定数组、大小和偏移量构造具有单个存储单元且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[][], int) - 类 java.awt.image.DataBufferUShort 的构造方法
构造具有指定数组且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[][], int, int[]) - 类 java.awt.image.DataBufferUShort 的构造方法
构造具有指定数组、大小和偏移量且基于无符号 short 的 DataBuffer。
DataContentHandler - javax.activation 中的 接口
DataContentHandler 接口由可用于扩展 Transferable 接口的 DataHandler 实现性能的对象来实现。
DataContentHandlerFactory - javax.activation 中的 接口
此接口定义了 DataContentHandler 的工厂。
dataDefinitionCausesTransactionCommit() - 接口 java.sql.DatabaseMetaData 中的方法
获取事务中的数据定义语句是否强迫该事务进行提交。
dataDefinitionIgnoredInTransactions() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否忽略事务中的数据定义语句。
DataFlavor - java.awt.datatransfer 中的 类
DataFlavor 提供有关数据的元信息。
DataFlavor() - 类 java.awt.datatransfer.DataFlavor 的构造方法
构造一个新的 DataFlavor。
DataFlavor(Class<?>, String) - 类 java.awt.datatransfer.DataFlavor 的构造方法
构造一个表示 Java 类的 DataFlavor。
DataFlavor(String, String) - 类 java.awt.datatransfer.DataFlavor 的构造方法
构造一个表示 MimeType 的 DataFlavor。
DataFlavor(String, String, ClassLoader) - 类 java.awt.datatransfer.DataFlavor 的构造方法
构造一个表示 MimeType 的 DataFlavor。
DataFlavor(String) - 类 java.awt.datatransfer.DataFlavor 的构造方法
根据 mimeType 字符串构造 DataFlavor。
DataFormatException - java.util.zip 中的 异常
当数据格式发生错误时，抛出此异常。
DataFormatException() - 异常 java.util.zip.DataFormatException 的构造方法
构造不带详细消息的 DataFormatException。
DataFormatException(String) - 异常 java.util.zip.DataFormatException 的构造方法
构造带指定详细消息的 DataFormatException。
DatagramChannel - java.nio.channels 中的 类
针对面向数据报套接字的可选择通道。
DatagramChannel(SelectorProvider) - 类 java.nio.channels.DatagramChannel 的构造方法
初始化此类的一个新实例。
DatagramPacket - java.net 中的 类
此类表示数据报包。
DatagramPacket(byte[], int, int) - 类 java.net.DatagramPacket 的构造方法
构造 DatagramPacket，用来接收长度为 length 的包，在缓冲区中指定了偏移量。
DatagramPacket(byte[], int) - 类 java.net.DatagramPacket 的构造方法
构造 DatagramPacket，用来接收长度为 length 的数据包。
DatagramPacket(byte[], int, int, InetAddress, int) - 类 java.net.DatagramPacket 的构造方法
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[], int, int, SocketAddress) - 类 java.net.DatagramPacket 的构造方法
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[], int, InetAddress, int) - 类 java.net.DatagramPacket 的构造方法
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[], int, SocketAddress) - 类 java.net.DatagramPacket 的构造方法
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramSocket - java.net 中的 类
此类表示用来发送和接收数据报包的套接字。
DatagramSocket() - 类 java.net.DatagramSocket 的构造方法
构造数据报套接字并将其绑定到本地主机上任何可用的端口。
DatagramSocket(DatagramSocketImpl) - 类 java.net.DatagramSocket 的构造方法
创建带有指定 DatagramSocketImpl 的未绑定数据报套接字。
DatagramSocket(SocketAddress) - 类 java.net.DatagramSocket 的构造方法
创建数据报套接字，将其绑定到指定的本地套接字地址。
DatagramSocket(int) - 类 java.net.DatagramSocket 的构造方法
创建数据报套接字并将其绑定到本地主机上的指定端口。
DatagramSocket(int, InetAddress) - 类 java.net.DatagramSocket 的构造方法
创建数据报套接字，将其绑定到指定的本地地址。
DatagramSocketImpl - java.net 中的 类
数据报和多播套接字实现的抽象基类。
DatagramSocketImpl() - 类 java.net.DatagramSocketImpl 的构造方法
DatagramSocketImplFactory - java.net 中的 接口
此接口定义用于数据报套接字实现的工厂。
DataHandler - javax.activation 中的 类
DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。
DataHandler(DataSource) - 类 javax.activation.DataHandler 的构造方法
创建引用指定 DataSource 的 DataHandler 实例。
DataHandler(Object, String) - 类 javax.activation.DataHandler 的构造方法
创建表示此 MIME 类型对象的 DataHandler 实例。
DataHandler(URL) - 类 javax.activation.DataHandler 的构造方法
创建引用 URL 的 DataHandler 实例。
DataInput - java.io 中的 接口
DataInput 接口用于从二进制流中读取字节，并根据所有 Java 基本类型数据进行重构。
DataInputStream - java.io 中的 类
数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
DataInputStream(InputStream) - 类 java.io.DataInputStream 的构造方法
使用指定的底层 InputStream 创建一个 DataInputStream。
DataInputStream - org.omg.CORBA 中的 接口
定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。
DataLine - javax.sound.sampled 中的 接口
DataLine 将与介质相关的功能添加到其超接口 Line。
DataLine.Info - javax.sound.sampled 中的 类
除了继承自其超类的类信息之外，DataLine.Info 还提供特定于数据行的其他信息。
DataLine.Info(Class<?>, AudioFormat[], int, int) - 类 javax.sound.sampled.DataLine.Info 的构造方法
根据指定信息构造数据行的信息对象，这些包括受支持音频格式的集合和缓冲区大小的范围。
DataLine.Info(Class<?>, AudioFormat, int) - 类 javax.sound.sampled.DataLine.Info 的构造方法
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式和所需的缓冲区大小。
DataLine.Info(Class<?>, AudioFormat) - 类 javax.sound.sampled.DataLine.Info 的构造方法
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式。
DATALINK - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 DATALINK 的 Java 编程语言中的常量（有时称为类型代码）。
dataModel - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
dataModel - 类 javax.swing.JTable 中的变量
表的 TableModel。
DataOutput - java.io 中的 接口
DataOutput 接口用于将数据从任意 Java 基本类型转换为一系列字节，并将这些字节写入二进制流。
DataOutputStream - java.io 中的 类
数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
DataOutputStream(OutputStream) - 类 java.io.DataOutputStream 的构造方法
创建一个新的数据输出流，将数据写入指定基础输出流。
DataOutputStream - org.omg.CORBA 中的 接口
定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。
DataSource - javax.activation 中的 接口
DataSource 接口为 JavaBeans Activation Framework 提供任意数据集合的抽象。
DataSource - javax.sql 中的 接口
该工厂用于提供到此 DataSource 对象所表示的物理数据源的连接。
DATASOURCE_DB_LOCK - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示锁定整个数据源，该数据源是正在使用此 SyncProvider 对象的 RowSet 对象的数据源。
DATASOURCE_NO_LOCK - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示在原始数据源上不保持任何锁定。
DATASOURCE_ROW_LOCK - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示锁定原始 SQL 语句涉及的行，该语句用于填充正在使用此 SyncProvider 对象的 RowSet 对象。
DATASOURCE_TABLE_LOCK - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示锁定原始 SQL 语句涉及的所有表，该语句用于填充正在使用此 SyncProvider 对象的 RowSet 对象。
DataTruncation - java.sql 中的 异常
以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
DataTruncation(int, boolean, boolean, int, int) - 异常 java.sql.DataTruncation 的构造方法
创建一个 DataTruncation 对象，当 read 被设置为 true 时，该对象的 SQLState 初始化为 01004，当 read 被设置为 false 时，则初始化为 22001，reason 被设置为 "Data truncation"，供应商代码被设置为 0，其他字段被设置为给定值。
DataTruncation(int, boolean, boolean, int, int, Throwable) - 异常 java.sql.DataTruncation 的构造方法
创建一个 DataTruncation 对象，当 read 被设置为 true 时，该对象的 SQLState 初始化为 01004，当 read 被设置为 false 时，则初始化为 22001，reason 被设置为 "Data truncation"，供应商代码被设置为 0，其他字段被设置为给定值。
dataType - 类 java.awt.image.DataBuffer 中的变量
此 DataBuffer 的数据类型。
dataType - 类 java.awt.image.SampleModel 中的变量
存储像素数据的 DataBuffer 的数据类型。
DATATYPE_BOOLEAN - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeDataType 返回的常量，指示属性的值为 'true' 或 'false'。
DATATYPE_DOUBLE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
由 getAttributeDataType 返回的常量，指示属性的值为双精度十进制浮点数的字符串表示形式。
DATATYPE_FLOAT - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
由 getAttributeDataType 返回的常量，指示属性的值为十进制浮点数的字符串表示形式。
DATATYPE_INTEGER - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeDataType 返回的常量，指示属性的值为整数的字符串表示形式。
DATATYPE_STRING - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeDataType 返回的常量，指示属性的值为通用的 Unicode 字符串。
DatatypeConfigurationException - javax.xml.datatype 中的 异常
指示严重的配置错误。
DatatypeConfigurationException() - 异常 javax.xml.datatype.DatatypeConfigurationException 的构造方法
创建不带任何指定详细消息和原因的新 DatatypeConfigurationException。
DatatypeConfigurationException(String) - 异常 javax.xml.datatype.DatatypeConfigurationException 的构造方法
创建带指定详细消息的新 DatatypeConfigurationException。
DatatypeConfigurationException(String, Throwable) - 异常 javax.xml.datatype.DatatypeConfigurationException 的构造方法
创建带有指定详细消息和原因的新 DatatypeConfigurationException。
DatatypeConfigurationException(Throwable) - 异常 javax.xml.datatype.DatatypeConfigurationException 的构造方法
使用指定的原因创建一个新的 DatatypeConfigurationException。
DatatypeConstants - javax.xml.datatype 中的 类
包含基本 Datatype 值作为常量的实用工具类。
DatatypeConstants.Field - javax.xml.datatype 中的 类
类型安全的枚举类，它表示 Duration 类的六个字段。
DatatypeConverter - javax.xml.bind 中的 类
可以使用 javaType 绑定声明来自定义 XML 模式数据类型到 Java 数据类型的绑定。
DatatypeConverterInterface - javax.xml.bind 中的 接口
该 DatatypeConverterInterface 仅适用于 JAXB 提供者。
DatatypeFactory - javax.xml.datatype 中的 类
创建新 javax.xml.datatype Object 的工厂，创建的对象可提供 XML 和 Java Object 之间的映射。
DatatypeFactory() - 类 javax.xml.datatype.DatatypeFactory 的构造方法
受保护的构造方法，包外无法实例化。
DATATYPEFACTORY_IMPLEMENTATION_CLASS - 类 javax.xml.datatype.DatatypeFactory 中的静态变量
JSR 206: Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。
DATATYPEFACTORY_PROPERTY - 类 javax.xml.datatype.DatatypeFactory 中的静态变量
JSR 206:Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。
dataVector - 类 javax.swing.table.DefaultTableModel 中的变量
Vector，由包含多个 Object 值的 Vector 组成。
Date - java.sql 中的 类
一个包装了毫秒值的瘦包装器 (thin wrapper)，它允许 JDBC 将毫秒值标识为 SQL DATE 值。
Date(int, int, int) - 类 java.sql.Date 的构造方法
已过时。 使用构造方法 Date(long date) 替代
Date(long) - 类 java.sql.Date 的构造方法
使用给定毫秒时间值构造一个 Date 对象。
DATE - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 DATE 的 Java 编程语言中的常量（有时称为类型代码）。
DATE - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一个月中的某天。
Date - java.util 中的 类
类 Date 表示特定的瞬间，精确到毫秒。
Date() - 类 java.util.Date 的构造方法
分配 Date 对象并初始化此对象，以表示分配它的时间（精确到毫秒）。
Date(long) - 类 java.util.Date 的构造方法
分配 Date 对象并初始化此对象，以表示自从标准基准时间（称为“历元（epoch）”，即 1970 年 1 月 1 日 00:00:00 GMT）以来的指定毫秒数。
Date(int, int, int) - 类 java.util.Date 的构造方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date) 或 GregorianCalendar(year + 1900, month, date) 取代。
Date(int, int, int, int, int) - 类 java.util.Date 的构造方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min) 或 GregorianCalendar(year + 1900, month, date, hrs, min) 取代。
Date(int, int, int, int, int, int) - 类 java.util.Date 的构造方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代。
Date(String) - 类 java.util.Date 的构造方法
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。
DATE - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.util.Date 的值。
DATE - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 date 的完全限定名称。
DATE_EDITOR - 类 javax.accessibility.AccessibleRole 中的静态变量
DATE_EDITOR 是允许用户编辑 java.util.Date 和 java.util.Time 对象的组件。
DATE_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 DATE 字段的有用常量。
dateFilter(RowFilter.ComparisonType, Date, int...) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Date 值的条目。
DateFormat - java.text 中的 类
DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
DateFormat() - 类 java.text.DateFormat 的构造方法
创建一个新的 DateFormat。
DateFormat.Field - java.text 中的 类
定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
DateFormat.Field(String, int) - 类 java.text.DateFormat.Field 的构造方法
创建一个 Field。
DateFormatProvider - java.text.spi 中的 类
提供 DateFormat 类具体实现的服务提供者的抽象类。
DateFormatProvider() - 类 java.text.spi.DateFormatProvider 的构造方法
唯一的构造方法。
DateFormatSymbols - java.text 中的 类
DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。
DateFormatSymbols() - 类 java.text.DateFormatSymbols 的构造方法
通过从默认语言环境资源加载格式数据，构造一个 DateFormatSymbols 对象。
DateFormatSymbols(Locale) - 类 java.text.DateFormatSymbols 的构造方法
通过从给定语言环境资源加载格式数据，构造一个 DateFormatSymbols 对象。
DateFormatSymbolsProvider - java.text.spi 中的 类
提供 DateFormatSymbols 类实例的服务提供者的抽象类。
DateFormatSymbolsProvider() - 类 java.text.spi.DateFormatSymbolsProvider 的构造方法
唯一的构造方法。
DateFormatter - javax.swing.text 中的 类
DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
DateFormatter() - 类 javax.swing.text.DateFormatter 的构造方法
这是 new DateFormatter(DateFormat.getDateInstance()) 的简写。
DateFormatter(DateFormat) - 类 javax.swing.text.DateFormatter 的构造方法
返回用指定的 Format 实例配置的 DateFormatter。
DATETIME - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 dateTime 的完全限定名称。
DateTimeAtCompleted - javax.print.attribute.standard 中的 类
DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
DateTimeAtCompleted(Date) - 类 javax.print.attribute.standard.DateTimeAtCompleted 的构造方法
构造具有给定 Date 值的新 date-time at completed 属性。
DateTimeAtCreation - javax.print.attribute.standard 中的 类
DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
DateTimeAtCreation(Date) - 类 javax.print.attribute.standard.DateTimeAtCreation 的构造方法
构造具有给定 Date 值的新的 DateTimeAtCreation 属性。
DateTimeAtProcessing - javax.print.attribute.standard 中的 类
DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
DateTimeAtProcessing(Date) - 类 javax.print.attribute.standard.DateTimeAtProcessing 的构造方法
构造具有给定 Date 值的新的 DateTimeAtProcessing 属性。
DateTimeSyntax - javax.print.attribute 中的 类
类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。
DateTimeSyntax(Date) - 类 javax.print.attribute.DateTimeSyntax 的构造方法
构造具有给定 java.util.Date 值的新的日期-时间属性。
DAY_OF_MONTH - 类 java.text.DateFormat.Field 中的静态变量
标识 DAY_OF_MONTH 字段的常量。
DAY_OF_MONTH - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一个月中的某天。
DAY_OF_WEEK - 类 java.text.DateFormat.Field 中的静态变量
标识 DAY_OF_WEEK 字段的常量。
DAY_OF_WEEK - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一个星期中的某天。
DAY_OF_WEEK_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 DAY_OF_WEEK 字段的有用常量。
DAY_OF_WEEK_IN_MONTH - 类 java.text.DateFormat.Field 中的静态变量
标识 DAY_OF_WEEK_IN_MONTH 字段的常量。
DAY_OF_WEEK_IN_MONTH - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示当前月中的第几个星期。
DAY_OF_WEEK_IN_MONTH_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 DAY_OF_WEEK_IN_MONTH 字段的有用常量。
DAY_OF_YEAR - 类 java.text.DateFormat.Field 中的静态变量
标识 DAY_OF_YEAR 字段的常量。
DAY_OF_YEAR - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示当前年中的天数。
DAY_OF_YEAR_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 DAY_OF_YEAR 字段的有用常量。
DAYS - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示日字段的常量。
dbgTag - 类 javax.management.monitor.Monitor 中的变量
已过时。 无替代版本。
DD - 类 javax.swing.text.html.HTML.Tag 中的静态变量
deactivate(boolean) - 接口 java.awt.im.spi.InputMethod 中的方法
让输入方法处于非活动状态。
deactivate() - 接口 javax.rmi.CORBA.Tie 中的方法
取消激活此 tie 表示的目标对象。
deactivate(boolean, boolean) - 接口 org.omg.PortableServer.POAManagerOperations 中的方法
此操作将 POA 管理器的状态更改为非激活 (inactive)，促使关联的 POA 拒绝尚未开始执行的请求以及任何新的请求。
deactivate_object(byte[]) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作促使在 oid 参数中指定的 ObjectId 被取消激活。
deactivateFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
deactivateFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常指示此窗体失去焦点。
deactivateFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
窗体不再是被选择状态时调用此方法。
DebugGraphics - javax.swing 中的 类
支持图形调试的图形子类。
DebugGraphics() - 类 javax.swing.DebugGraphics 的构造方法
构造一个支持减速绘制的新调试图形上下文。
DebugGraphics(Graphics, JComponent) - 类 javax.swing.DebugGraphics 的构造方法
根据现有图形上下文构造一个调试图形上下文，该上下文可以减慢指定组件的绘制。
DebugGraphics(Graphics) - 类 javax.swing.DebugGraphics 的构造方法
根据现有图形上下文构造一个调试图形上下文，该上下文支持减慢绘制。
decapitalize(String) - 类 java.beans.Introspector 中的静态方法
获得一个字符串并将它转换成普通 Java 变量名称大写形式的实用工具方法。
DECEMBER - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第十二个月的 Calendar.MONTH 字段值。
DECEMBER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第十二个月的值。
DECIMAL - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 DECIMAL 的 Java 编程语言中的常量（有时称为类型代码）。
DECIMAL128 - 类 java.math.MathContext 中的静态变量
一个 MathContext 对象，其精度设置与 IEEE 754R Decimal128 格式（即 34 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
DECIMAL32 - 类 java.math.MathContext 中的静态变量
一个 MathContext 对象，其精度设置与 IEEE 754R Decimal32 格式（即 7 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
DECIMAL64 - 类 java.math.MathContext 中的静态变量
一个 MathContext 对象，其精度设置与 IEEE 754R Decimal64 格式（即 16 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
DECIMAL_DIGIT_NUMBER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Nd”。
DECIMAL_SEPARATOR - 类 java.text.NumberFormat.Field 中的静态变量
标识小数点字段的常量。
DecimalFormat - java.text 中的 类
DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。
DecimalFormat() - 类 java.text.DecimalFormat 的构造方法
使用默认模式和默认语言环境的符号创建一个 DecimalFormat。
DecimalFormat(String) - 类 java.text.DecimalFormat 的构造方法
使用给定的模式和默认语言环境的符号创建一个 DecimalFormat。
DecimalFormat(String, DecimalFormatSymbols) - 类 java.text.DecimalFormat 的构造方法
使用给定的模式和符号创建一个 DecimalFormat。
DecimalFormatSymbols - java.text 中的 类
此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。
DecimalFormatSymbols() - 类 java.text.DecimalFormatSymbols 的构造方法
为默认的语言环境创建一个 DecimalFormatSymbols 对象。
DecimalFormatSymbols(Locale) - 类 java.text.DecimalFormatSymbols 的构造方法
为给定的语言环境创建一个 DecimalFormatSymbols 对象。
DecimalFormatSymbolsProvider - java.text.spi 中的 类
提供 DecimalFormatSymbols 类实例的服务提供者的抽象类。
DecimalFormatSymbolsProvider() - 类 java.text.spi.DecimalFormatSymbolsProvider 的构造方法
唯一的构造方法。
DECLARE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
DECLARED - 接口 java.lang.reflect.Member 中的静态变量
标识类或接口的所有已声明成员的集合。
DeclaredType - javax.lang.model.type 中的 接口
表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。
declaredType - 类 javax.xml.bind.JAXBElement 中的变量
xml 元素声明类型的 Java 数据类型绑定。
declarePrefix(String, String) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
声明名称空间前缀。
DeclHandler - org.xml.sax.ext 中的 接口
用于 DTD 声明事件的 SAX2 扩展处理程序。
decode(String) - 类 java.awt.Color 中的静态方法
将 String 转换成整数，并返回指定的不透明 Color。
decode(String) - 类 java.awt.Font 中的静态方法
返回 str 参数所描述的 Font。
decode(String) - 类 java.lang.Byte 中的静态方法
将 String 解码为 Byte。
decode(String) - 类 java.lang.Integer 中的静态方法
将 String 解码为 Integer。
decode(String) - 类 java.lang.Long 中的静态方法
将 String 解码成 Long。
decode(String) - 类 java.lang.Short 中的静态方法
将 String 解码为 Short。
decode(String) - 类 java.net.URLDecoder 中的静态方法
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。
decode(String, String) - 类 java.net.URLDecoder 中的静态方法
使用指定的编码机制对 application/x-www-form-urlencoded 字符串解码。
decode(ByteBuffer) - 类 java.nio.charset.Charset 中的方法
将此 charset 中的字节解码成 Unicode 字符的便捷方法。
decode(ByteBuffer, CharBuffer, boolean) - 类 java.nio.charset.CharsetDecoder 中的方法
从给定的输入缓冲区中解码尽可能多的字节，把结果写入给定的输出缓冲区。
decode(ByteBuffer) - 类 java.nio.charset.CharsetDecoder 中的方法
把单个输入字节缓冲区的剩余内容解码到新分配的字符缓冲区的便捷方法。
decode(InputStream) - 接口 java.security.Certificate 中的方法
已过时。 从输入流解码证书。
decode(byte[]) - 接口 org.omg.IOP.CodecOperations 中的方法
基于对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。
decode_value(byte[], TypeCode) - 接口 org.omg.IOP.CodecOperations 中的方法
基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。
decodeDataFlavor(String) - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
解码 String native 以用作 DataFlavor。
decodeJavaMIMEType(String) - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
解码 String native 以用作 Java MIME 类型。
decodeLineStyle(Object) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
此方法进行传入客户端属性中的字符串和内部表示形式（当前的并且用 int 值表示）之间的转换
decodeLoop(ByteBuffer, CharBuffer) - 类 java.nio.charset.CharsetDecoder 中的方法
将一个或多个字节解码为一个或多个字符。
decorateTask(Runnable, RunnableScheduledFuture<V>) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
修改或替换用于执行 runnable 的任务。
decorateTask(Callable<V>, RunnableScheduledFuture<V>) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
修改或替换用于执行 callable 的任务。
decrButton - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
DECREASE_HIGHLIGHT - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的静态变量
decreaseButton - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的变量
DECREMENT - 接口 javax.accessibility.AccessibleAction 中的静态变量
减少某个值的动作。
decrementAndGet() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将当前值减 1。
decrementAndGet(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将索引 i 的元素减 1。
decrementAndGet(T) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象的字段的当前值减 1。
decrementAndGet() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将当前值减 1。
decrementAndGet(int) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将索引 i 的元素减1。
decrementAndGet(T) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象字段当前值减 1。
decrIndent() - 类 javax.swing.text.AbstractWriter 中的方法
降低缩进级别。
DECRYPT - 类 javax.xml.crypto.KeySelector.Purpose 中的静态变量
用于解密的密钥。
DECRYPT_MODE - 类 javax.crypto.Cipher 中的静态变量
用于将 Cipher 初始化为解密模式的常量。
deepEquals(Object[], Object[]) - 类 java.util.Arrays 中的静态方法
如果两个指定数组彼此是深层相等 的，则返回 true。
deepHashCode(Object[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的“深层内容”返回哈希码。
deepToString(Object[]) - 类 java.util.Arrays 中的静态方法
返回指定数组“深层内容”的字符串表示形式。
def - 类 java.util.zip.DeflaterInputStream 中的变量
此流的压缩器。
def - 类 java.util.zip.DeflaterOutputStream 中的变量
此流的压缩器。
def_kind() - 类 org.omg.CORBA._IDLTypeStub 中的方法
def_kind() - 接口 org.omg.CORBA.IRObjectOperations 中的方法
返回对应于此接口存储库对象的 DefinitionKind。
defAttributeList(String, int, int, String, String, AttributeList) - 类 javax.swing.text.html.parser.DTD 中的方法
创建并返回一个 AttributeList。
DEFAULT - 类 java.awt.dnd.DragSourceContext 中的静态变量
updateCurrentCursor() 使用的 int 值，指示应该将 Cursor 改为默认（未放置）的 Cursor。
DEFAULT - 类 java.security.spec.PSSParameterSpec 中的静态变量
带所有默认值的 PSS 参数集合。
DEFAULT - 类 java.text.DateFormat 中的静态变量
用于默认模式的常量。
DEFAULT - 类 javax.crypto.spec.OAEPParameterSpec 中的静态变量
使用所有默认值的 OAEP 参数设置。
DEFAULT - 类 javax.crypto.spec.PSource.PSpecified 中的静态变量
其值与 byte[0] 相等的编码输入 P。
DEFAULT - 接口 javax.swing.Action 中的静态变量
当前未使用。
DEFAULT - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示 region 是默认区域。
DEFAULT - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
DEFAULT - 类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 中的静态变量
指示默认名称空间（“#default”）。
DEFAULT_CARET_POLICY - 类 java.awt.font.TextLayout 中的静态变量
客户端未指定策略时使用此 CaretPolicy。
DEFAULT_CLASS_LOADER - 类 javax.management.remote.JMXConnectorFactory 中的静态变量
指定默认的类加载器的属性名称。
DEFAULT_CLASS_LOADER - 类 javax.management.remote.JMXConnectorServerFactory 中的静态变量
指定默认的类加载器的属性名称。
DEFAULT_CLASS_LOADER_NAME - 类 javax.management.remote.JMXConnectorServerFactory 中的静态变量
指定默认的类加载器 MBean 名称的属性名称。
DEFAULT_COMPRESSION - 类 java.util.zip.Deflater 中的静态变量
默认压缩级别。
DEFAULT_CSS - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
用于设置标记视图的默认级联样式表 (Cascading Style Sheet) 文件。
DEFAULT_CURSOR - 类 java.awt.Cursor 中的静态变量
默认光标类型（如果没有定义光标，则获取该设置）。
DEFAULT_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.DEFAULT_CURSOR 取代。
default_index() - 类 org.omg.CORBA.TypeCode 中的方法
返回默认成员的索引，如果没有默认成员，则返回 -1。
DEFAULT_JUSTIFICATION - 类 javax.swing.border.TitledBorder 中的静态变量
标题文本使用默认的对齐方式。
DEFAULT_KEYMAP - 类 javax.swing.text.JTextComponent 中的静态变量
将由所有 JTextComponent 实例共享的默认 keymap，除非这些实例已有另一个 keymap 集合。
DEFAULT_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Default 层的便捷对象。
DEFAULT_LIFETIME - 接口 org.ietf.jgss.GSSContext 中的静态变量
一个表示默认的上下文生存期的生存期常量。
DEFAULT_LIFETIME - 接口 org.ietf.jgss.GSSCredential 中的静态变量
一个表示默认的凭据生存期的生存期常量。
DEFAULT_MODALITY_TYPE - 类 java.awt.Dialog 中的静态变量
有模式 dialog 的默认模式类型。
DEFAULT_NS_PREFIX - 类 javax.xml.XMLConstants 中的静态变量
用于表示默认 XML 名称空间的前缀。
DEFAULT_OBJECT_MODEL_URI - 类 javax.xml.xpath.XPathFactory 中的静态变量
默认 Object Model URI。
DEFAULT_OPTION - 类 javax.swing.JOptionPane 中的静态变量
意味着外观不应该提供任何选项的类型，即仅使用取自 JOptionPane 的选项。
default_POA(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
此方法的默认行为是从关联 servant 的 ORB 实例返回根 POA。
DEFAULT_POSITION - 类 javax.swing.border.TitledBorder 中的静态变量
标题文本使用默认的垂直方向。
DEFAULT_PROPERTY_NAME - 类 javax.xml.xpath.XPathFactory 中的静态变量
遵守 JAXP 规范的默认属性名称。
DEFAULT_SIZE - 类 javax.swing.GroupLayout 中的静态变量
指示组件或间隙的大小应该用于特定的范围值。
DEFAULT_SOAP_PROTOCOL - 接口 javax.xml.soap.SOAPConstants 中的静态变量
默认协议：向后兼容的 SOAP 1.1。
DEFAULT_STRATEGY - 类 java.util.zip.Deflater 中的静态变量
默认压缩策略。
DEFAULT_STYLE - 类 javax.swing.text.StyleContext 中的静态变量
赋予与段落相关的默认逻辑样式的名称。
DEFAULT_VALUE - 类 javax.lang.model.util.ElementScanner6 中的变量
指定的默认值。
DEFAULT_VALUE - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的变量
要返回的默认值；defaultAction 返回此值，除非该方法被重写。
DEFAULT_VALUE - 类 javax.lang.model.util.SimpleElementVisitor6 中的变量
要返回的默认值；defaultAction 返回此值，除非该方法被重写。
DEFAULT_VALUE - 类 javax.lang.model.util.SimpleTypeVisitor6 中的变量
要返回的默认值；defaultAction 返回此值，除非该方法被重写。
DEFAULT_VALUE_FIELD - 类 javax.management.JMX 中的静态变量
defaultValue 字段的名称。
defaultAction(Object, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
visit 方法的默认动作。
defaultAction(Element, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
visit 方法的默认动作。
defaultAction(TypeMirror, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
visit 方法的默认动作。
DefaultBoundedRangeModel - javax.swing 中的 类
BoundedRangeModel 的一般实现。
DefaultBoundedRangeModel() - 类 javax.swing.DefaultBoundedRangeModel 的构造方法
使用默认值初始化所有属性。
DefaultBoundedRangeModel(int, int, int, int) - 类 javax.swing.DefaultBoundedRangeModel 的构造方法
初始化 value、extent、minimum 和 maximum。
defaultButton - 类 javax.swing.JRootPane 中的变量
当窗格成为焦点并有类似按下 Enter 键的特定于 UI 的操作发生时被激活的按钮。
DefaultButtonModel - javax.swing 中的 类
Button 组件的数据模型的默认实现。
DefaultButtonModel() - 类 javax.swing.DefaultButtonModel 的构造方法
构造一个 DefaultButtonModel。
DefaultCaret - javax.swing.text 中的 类
插入符的默认实现。
DefaultCaret() - 类 javax.swing.text.DefaultCaret 的构造方法
构造默认的插入符。
DefaultCellEditor - javax.swing 中的 类
表单元格和树单元格的默认编辑器。
DefaultCellEditor(JTextField) - 类 javax.swing.DefaultCellEditor 的构造方法
构造一个使用文本字段的 DefaultCellEditor。
DefaultCellEditor(JCheckBox) - 类 javax.swing.DefaultCellEditor 的构造方法
构造一个使用复选框的 DefaultCellEditor 对象。
DefaultCellEditor(JComboBox) - 类 javax.swing.DefaultCellEditor 的构造方法
构造一个使用组合框的 DefaultCellEditor 对象。
DefaultCellEditor.EditorDelegate - javax.swing 中的 类
受保护的 (protected) EditorDelegate 类。
DefaultCellEditor.EditorDelegate() - 类 javax.swing.DefaultCellEditor.EditorDelegate 的构造方法
defaultCharset() - 类 java.nio.charset.Charset 中的静态方法
返回此 Java 虚拟机的默认 charset。
defaultChoosers - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的变量
DefaultColorSelectionModel - javax.swing.colorchooser 中的 类
ColorSelectionModel 的一般实现。
DefaultColorSelectionModel() - 类 javax.swing.colorchooser.DefaultColorSelectionModel 的构造方法
创建一个 DefaultColorSelectionModel，其当前颜色被设置为 Color.white。
DefaultColorSelectionModel(Color) - 类 javax.swing.colorchooser.DefaultColorSelectionModel 的构造方法
创建一个 DefaultColorSelectionModel，其当前颜色被设置为 color，该颜色不应为 null。
DefaultComboBoxModel - javax.swing 中的 类
组合框的默认模型。
DefaultComboBoxModel() - 类 javax.swing.DefaultComboBoxModel 的构造方法
构造一个空的 DefaultComboBoxModel 对象。
DefaultComboBoxModel(Object[]) - 类 javax.swing.DefaultComboBoxModel 的构造方法
构造一个用对象数组初始化的 DefaultComboBoxModel 对象。
DefaultComboBoxModel(Vector<?>) - 类 javax.swing.DefaultComboBoxModel 的构造方法
构造一个用向量初始化的 DefaultComboBoxModel 对象。
defaultConstraints - 类 java.awt.GridBagLayout 中的变量
此字段保持包含默认值的网格包约束实例，因此如果某个组件没有与其相关联的网格包约束，则会分配给该组件一个 defaultConstraints 的副本。
defaultController - 类 javax.imageio.IIOParam 中的变量
调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的默认 IIOParamController。
defaultController - 类 javax.imageio.metadata.IIOMetadata 中的变量
建议用作此 IIOMetadata 对象的控制器的 IIOMetadataController。
DefaultCopyDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于复制操作的默认 Cursor，指示当前允许放置。
DefaultCopyNoDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于复制操作的默认 Cursor，指示当前不允许放置。
DefaultDesktopManager - javax.swing 中的 类
此类是 DesktopManager 的实现。
DefaultDesktopManager() - 类 javax.swing.DefaultDesktopManager 的构造方法
defaulted(String) - 类 java.io.ObjectInputStream.GetField 中的方法
如果指定的字段是默认字段并且在此流中不存在任何值，则返回 true。
DefaultEditorKit - javax.swing.text 中的 类
这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
DefaultEditorKit() - 类 javax.swing.text.DefaultEditorKit 的构造方法
DefaultEditorKit 的默认构造方法
DefaultEditorKit.BeepAction - javax.swing.text 中的 类
创建蜂鸣声。
DefaultEditorKit.BeepAction() - 类 javax.swing.text.DefaultEditorKit.BeepAction 的构造方法
使用适当的标识符创建此对象。
DefaultEditorKit.CopyAction - javax.swing.text 中的 类
复制选定的区域并将其内容放入系统剪贴板中。
DefaultEditorKit.CopyAction() - 类 javax.swing.text.DefaultEditorKit.CopyAction 的构造方法
使用适当的标识符创建此对象。
DefaultEditorKit.CutAction - javax.swing.text 中的 类
剪切选定的区域并将其内容放入系统剪贴板中。
DefaultEditorKit.CutAction() - 类 javax.swing.text.DefaultEditorKit.CutAction 的构造方法
使用适当的标识符创建此对象。
DefaultEditorKit.DefaultKeyTypedAction - javax.swing.text 中的 类
如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
DefaultEditorKit.DefaultKeyTypedAction() - 类 javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction 的构造方法
用适当的标识符创建此对象。
DefaultEditorKit.InsertBreakAction - javax.swing.text 中的 类
在文档中放置行/段落中断。
DefaultEditorKit.InsertBreakAction() - 类 javax.swing.text.DefaultEditorKit.InsertBreakAction 的构造方法
创建此对象，使其具有相应的标识符。
DefaultEditorKit.InsertContentAction - javax.swing.text 中的 类
将内容置于关联的文档中。
DefaultEditorKit.InsertContentAction() - 类 javax.swing.text.DefaultEditorKit.InsertContentAction 的构造方法
创建此对象，使其具有相应的标识符。
DefaultEditorKit.InsertTabAction - javax.swing.text 中的 类
将一个制表符置于文档中。
DefaultEditorKit.InsertTabAction() - 类 javax.swing.text.DefaultEditorKit.InsertTabAction 的构造方法
创建此对象，使其具有相应的标识符。
DefaultEditorKit.PasteAction - javax.swing.text 中的 类
将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
DefaultEditorKit.PasteAction() - 类 javax.swing.text.DefaultEditorKit.PasteAction 的构造方法
创建此对象，使其具有相应的标识符。
defaultEditorsByColumnClass - 类 javax.swing.JTable 中的变量
一个由对象组成的表，它显示并编辑单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。
DefaultFocusManager - javax.swing 中的 类
此类已被废弃，用 1.4 focus API 取代。
DefaultFocusManager() - 类 javax.swing.DefaultFocusManager 的构造方法
DefaultFocusTraversalPolicy - java.awt 中的 类
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
DefaultFocusTraversalPolicy() - 类 java.awt.DefaultFocusTraversalPolicy 的构造方法
DefaultFormatter - javax.swing.text 中的 类
DefaultFormatter 格式化任意对象。
DefaultFormatter() - 类 javax.swing.text.DefaultFormatter 的构造方法
创建 DefaultFormatter。
DefaultFormatterFactory - javax.swing.text 中的 类
JFormattedTextField.AbstractFormatterFactory 的一个实现。
DefaultFormatterFactory() - 类 javax.swing.text.DefaultFormatterFactory 的构造方法
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 的构造方法
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 的构造方法
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 的构造方法
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 的构造方法
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultHandler - org.xml.sax.helpers 中的 类
SAX2 事件处理程序的默认基类。
DefaultHandler() - 类 org.xml.sax.helpers.DefaultHandler 的构造方法
DefaultHandler2 - org.xml.sax.ext 中的 类
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。
DefaultHandler2() - 类 org.xml.sax.ext.DefaultHandler2 的构造方法
构造忽略所有解析事件的处理程序。
DefaultHighlighter - javax.swing.text 中的 类
实现 Highlighter 接口。
DefaultHighlighter() - 类 javax.swing.text.DefaultHighlighter 的构造方法
创建新 DefaultHighlighther 对象。
DefaultHighlighter.DefaultHighlightPainter - javax.swing.text 中的 类
只高亮显示用纯色填充高亮显示区域的 painter。
DefaultHighlighter.DefaultHighlightPainter(Color) - 类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 的构造方法
构造新的高亮显示 painter。
defaultInitCtx - 类 javax.naming.InitialContext 中的变量
该字段保存调用 NamingManager.getInitialContext() 的结果。
DefaultKeyboardFocusManager - java.awt 中的 类
AWT 应用程序的默认 KeyboardFocusManager。
DefaultKeyboardFocusManager() - 类 java.awt.DefaultKeyboardFocusManager 的构造方法
defaultKeyTypedAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
在接收到键输入事件 并且无 keymap 输入时默认执行的动作名称。
DefaultLinkDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于链接操作的默认 Cursor，指示当前允许放置。
DefaultLinkNoDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于链接操作的默认 Cursor，指示当前不允许放置。
DefaultListCellRenderer - javax.swing 中的 类
呈现列表中的一个项。
DefaultListCellRenderer() - 类 javax.swing.DefaultListCellRenderer 的构造方法
为列表中的项构造默认渲染器对象。
DefaultListCellRenderer.UIResource - javax.swing 中的 类
实现 UIResource 的 DefaultListCellRenderer 的子类。
DefaultListCellRenderer.UIResource() - 类 javax.swing.DefaultListCellRenderer.UIResource 的构造方法
DefaultListModel - javax.swing 中的 类
此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。
DefaultListModel() - 类 javax.swing.DefaultListModel 的构造方法
DefaultListSelectionModel - javax.swing 中的 类
列表选择的默认数据模型。
DefaultListSelectionModel() - 类 javax.swing.DefaultListSelectionModel 的构造方法
DefaultLoaderRepository - javax.management 中的 类
已过时。 使用 MBeanServer.getClassLoaderRepository() 取代。
DefaultLoaderRepository() - 类 javax.management.DefaultLoaderRepository 的构造方法
已过时。
DefaultLoaderRepository - javax.management.loading 中的 类
已过时。 使用 MBeanServer.getClassLoaderRepository()} 替代。
DefaultLoaderRepository() - 类 javax.management.loading.DefaultLoaderRepository 的构造方法
已过时。
defaultManager() - 类 javax.swing.MenuSelectionManager 中的静态方法
返回默认菜单选项管理器。
DefaultMenuLayout - javax.swing.plaf.basic 中的 类
Popup 菜单和菜单栏的默认布局管理器。
DefaultMenuLayout(Container, int) - 类 javax.swing.plaf.basic.DefaultMenuLayout 的构造方法
DefaultMetalTheme - javax.swing.plaf.metal 中的 类
提供 Java 外观原型的 MetalTheme 的一个具体实现，代码名称为“Steel”。
DefaultMetalTheme() - 类 javax.swing.plaf.metal.DefaultMetalTheme 的构造方法
创建并返回 DefaultMetalTheme 的一个实例。
DefaultMoveDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于移动操作的默认 Cursor，指示当前允许放置。
DefaultMoveNoDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于移动操作的默认 Cursor，指示当前不允许放置。
DefaultMutableTreeNode - javax.swing.tree 中的 类
DefaultMutableTreeNode 是树数据结构中的通用节点。
DefaultMutableTreeNode() - 类 javax.swing.tree.DefaultMutableTreeNode 的构造方法
创建没有父节点和子节点的树节点，该树节点允许有子节点。
DefaultMutableTreeNode(Object) - 类 javax.swing.tree.DefaultMutableTreeNode 的构造方法
创建没有父节点和子节点、但允许有子节点的树节点，并使用指定的用户对象对它进行初始化。
DefaultMutableTreeNode(Object, boolean) - 类 javax.swing.tree.DefaultMutableTreeNode 的构造方法
创建没有父节点和子节点的树节点，使用指定的用户对象对它进行初始化，仅在指定时才允许有子节点。
defaultPage(PageFormat) - 类 java.awt.print.PrinterJob 中的方法
复制 PageFormat 参数，并更改该副本，以描述默认页面的大小和方向。
defaultPage() - 类 java.awt.print.PrinterJob 中的方法
创建新的 PageFormat 实例，并将它设置为默认大小和方向。
DefaultPainter - 类 javax.swing.text.DefaultHighlighter 中的静态变量
LayeredHighlighter.LayerPainter 的默认实现，可用于绘制高亮显示区域。
DefaultPersistenceDelegate - java.beans 中的 类
DefaultPersistenceDelegate 是 PersistenceDelegate 抽象类的具体实现，是没有关于其可用信息的类在默认情况下使用的委托。
DefaultPersistenceDelegate() - 类 java.beans.DefaultPersistenceDelegate 的构造方法
为具有 null 构造方法的类创建持久委托。
DefaultPersistenceDelegate(String[]) - 类 java.beans.DefaultPersistenceDelegate 的构造方法
为其构造方法的参数是属性名称值（由 constructorPropertyNames 指定）的类创建默认持久委托。
defaultPressAction - 类 javax.swing.JRootPane 中的变量
已过时。 从 Java 2 platform v1.3 开始
defaultReadObject() - 类 java.io.ObjectInputStream 中的方法
从此流读取当前类的非静态和非瞬态字段。
defaultReleaseAction - 类 javax.swing.JRootPane 中的变量
已过时。 从 Java 2 platform v1.3 开始
defaultRenderersByColumnClass - 类 javax.swing.JTable 中的变量
一个由对象组成的表，它显示单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。
DefaultRowSorter<M,I> - javax.swing 中的 类
RowSorter 的一个实现，它围绕基于网格的数据模型提供排序和过滤操作。
DefaultRowSorter() - 类 javax.swing.DefaultRowSorter 的构造方法
创建一个空 DefaultRowSorter。
DefaultRowSorter.ModelWrapper<M,I> - javax.swing 中的 类
DefaultRowSorter.ModelWrapper 负责提供由 DefaultRowSorter 进行排序的数据。
DefaultRowSorter.ModelWrapper() - 类 javax.swing.DefaultRowSorter.ModelWrapper 的构造方法
创建一个新的 ModelWrapper。
defaults - 类 java.util.Properties 中的变量
一个属性列表，包含属性列表中所有未找到值的键的默认值。
DefaultSingleSelectionModel - javax.swing 中的 类
SingleSelectionModel 的一般实现。
DefaultSingleSelectionModel() - 类 javax.swing.DefaultSingleSelectionModel 的构造方法
DefaultStyledDocument - javax.swing.text 中的 类
能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。
DefaultStyledDocument(AbstractDocument.Content, StyleContext) - 类 javax.swing.text.DefaultStyledDocument 的构造方法
构造样式化文档。
DefaultStyledDocument(StyleContext) - 类 javax.swing.text.DefaultStyledDocument 的构造方法
构造具有默认的内容存储实现和一组共享样式的样式化文档。
DefaultStyledDocument() - 类 javax.swing.text.DefaultStyledDocument 的构造方法
构造默认的样式化文档。
DefaultStyledDocument.AttributeUndoableEdit - javax.swing.text 中的 类
用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。
DefaultStyledDocument.AttributeUndoableEdit(Element, AttributeSet, boolean) - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 的构造方法
DefaultStyledDocument.ElementBuffer - javax.swing.text 中的 类
管理对元素层次结构更改的类。
DefaultStyledDocument.ElementBuffer(Element) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 的构造方法
创建新的 ElementBuffer。
DefaultStyledDocument.ElementSpec - javax.swing.text 中的 类
构建元素的规范。
DefaultStyledDocument.ElementSpec(AttributeSet, short) - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 的构造方法
当标记不在文档中存储时供标记使用的构造方法。
DefaultStyledDocument.ElementSpec(AttributeSet, short, int) - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 的构造方法
供文档内部解析使用的构造方法，在数据已添加但还需要 len 信息时使用。
DefaultStyledDocument.ElementSpec(AttributeSet, short, char[], int, int) - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 的构造方法
用于外部创建规范的构造方法，供批量输入内容和标记到文档中。
DefaultStyledDocument.SectionElement - javax.swing.text 中的 类
文档的默认根元素... 与所包含的段落/行对应。
DefaultStyledDocument.SectionElement() - 类 javax.swing.text.DefaultStyledDocument.SectionElement 的构造方法
创建新 SectionElement。
DefaultTableCellRenderer - javax.swing.table 中的 类
呈现（显示） JTable 中每个单元格的标准类。
DefaultTableCellRenderer() - 类 javax.swing.table.DefaultTableCellRenderer 的构造方法
创建一个默认的表单元格渲染器。
DefaultTableCellRenderer.UIResource - javax.swing.table 中的 类
DefaultTableCellRenderer 的一个子类，它实现 UIResource。
DefaultTableCellRenderer.UIResource() - 类 javax.swing.table.DefaultTableCellRenderer.UIResource 的构造方法
DefaultTableColumnModel - javax.swing.table 中的 类
JTable 的标准列处理程序。
DefaultTableColumnModel() - 类 javax.swing.table.DefaultTableColumnModel 的构造方法
创建默认的表列模型。
DefaultTableModel - javax.swing.table 中的 类
这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。
DefaultTableModel() - 类 javax.swing.table.DefaultTableModel 的构造方法
构造默认的 DefaultTableModel，它是一个零列零行的表。
DefaultTableModel(int, int) - 类 javax.swing.table.DefaultTableModel 的构造方法
构造一个具有 rowCount 行和 columnCount 列的 null 对象值的 DefaultTableModel。
DefaultTableModel(Vector, int) - 类 javax.swing.table.DefaultTableModel 的构造方法
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。
DefaultTableModel(Object[], int) - 类 javax.swing.table.DefaultTableModel 的构造方法
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。
DefaultTableModel(Vector, Vector) - 类 javax.swing.table.DefaultTableModel 的构造方法
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。
DefaultTableModel(Object[][], Object[]) - 类 javax.swing.table.DefaultTableModel 的构造方法
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。
defaultTextIconGap - 类 javax.swing.plaf.basic.BasicButtonUI 中的变量
defaultTextIconGap - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
defaultTextShiftOffset - 类 javax.swing.plaf.basic.BasicButtonUI 中的变量
DefaultTextUI - javax.swing.text 中的 类
已过时。
DefaultTextUI() - 类 javax.swing.text.DefaultTextUI 的构造方法
已过时。
defaultThreadFactory() - 类 java.util.concurrent.Executors 中的静态方法
返回用于创建新线程的默认线程工厂。
DefaultTreeCellEditor - javax.swing.tree 中的 类
TreeCellEditor。
DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer) - 类 javax.swing.tree.DefaultTreeCellEditor 的构造方法
使用指定呈现器和默认编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。
DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer, TreeCellEditor) - 类 javax.swing.tree.DefaultTreeCellEditor 的构造方法
使用指定的呈现器和指定的编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。
DefaultTreeCellEditor.DefaultTextField - javax.swing.tree 中的 类
不提供任何编辑器时所使用的 TextField。
DefaultTreeCellEditor.DefaultTextField(Border) - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 的构造方法
构造一个 DefaultTreeCellEditor.DefaultTextField 对象。
DefaultTreeCellEditor.EditorContainer - javax.swing.tree 中的 类
负责存放 editingComponent 的容器。
DefaultTreeCellEditor.EditorContainer() - 类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 的构造方法
构造一个 EditorContainer 对象。
DefaultTreeCellRenderer - javax.swing.tree 中的 类
显示树中的条目。
DefaultTreeCellRenderer() - 类 javax.swing.tree.DefaultTreeCellRenderer 的构造方法
返回 DefaultTreeCellRenderer 的新实例。
DefaultTreeModel - javax.swing.tree 中的 类
使用 TreeNodes 的简单树数据模型。
DefaultTreeModel(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 的构造方法
创建其中任何节点都可以有子节点的树。
DefaultTreeModel(TreeNode, boolean) - 类 javax.swing.tree.DefaultTreeModel 的构造方法
创建一棵树，指定某个节点是否可以有子节点，或者是否仅某些节点可以有子节点。
DefaultTreeSelectionModel - javax.swing.tree 中的 类
TreeSelectionModel 的默认实现。
DefaultTreeSelectionModel() - 类 javax.swing.tree.DefaultTreeSelectionModel 的构造方法
使用 DISCONTIGUOUS_TREE_SELECTION 的选择模式创建空的 DefaultTreeSelectionModel 新实例。
DefaultValidationEventHandler - javax.xml.bind.helpers 中的 类
唯一的 JAXB 1.0 默认验证事件处理程序。
DefaultValidationEventHandler() - 类 javax.xml.bind.helpers.DefaultValidationEventHandler 的构造方法
defaultWriteObject() - 类 java.io.ObjectOutputStream 中的方法
将当前类的非静态和非瞬态字段写入此流。
defContentModel(int, Object, ContentModel) - 类 javax.swing.text.html.parser.DTD 中的方法
创建并返回一个新的内容模式。
DEFECTIVE_CREDENTIAL - 异常 org.ietf.jgss.GSSException 中的静态变量
有缺陷的凭据。
DEFECTIVE_TOKEN - 异常 org.ietf.jgss.GSSException 中的静态变量
有缺陷的标记。
defElement(String, int, boolean, boolean, ContentModel, String[], String[], AttributeList) - 类 javax.swing.text.html.parser.DTD 中的方法
创建并返回一个 Element。
defEntity(String, int, int) - 类 javax.swing.text.html.parser.DTD 中的方法
创建并返回一个字符 Entity。
defEntity(String, int, String) - 类 javax.swing.text.html.parser.DTD 中的方法
创建并返回一个 Entity。
defineAttributes(String, AttributeList) - 类 javax.swing.text.html.parser.DTD 中的方法
定义 Element 的属性。
defineClass(byte[], int, int) - 类 java.lang.ClassLoader 中的方法
已过时。 由 defineClass(String, byte[], int, int) 取代
defineClass(String, byte[], int, int) - 类 java.lang.ClassLoader 中的方法
将一个 byte 数组转换为 Class 类的实例。
defineClass(String, byte[], int, int, ProtectionDomain) - 类 java.lang.ClassLoader 中的方法
使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。
defineClass(String, ByteBuffer, ProtectionDomain) - 类 java.lang.ClassLoader 中的方法
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。
defineClass(String, byte[], int, int, CodeSource) - 类 java.security.SecureClassLoader 中的方法
使用可选的 CodeSource 将 byte 数组转换为 Class 类的实例。
defineClass(String, ByteBuffer, CodeSource) - 类 java.security.SecureClassLoader 中的方法
使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。
defined_in - 类 org.omg.CORBA.ValueMember 中的变量
用来定义此成员的 value 的存储库 ID。
defineElement(String, int, boolean, boolean, ContentModel, BitSet, BitSet, AttributeList) - 类 javax.swing.text.html.parser.DTD 中的方法
返回与指定参数匹配的 Element。
defineEntity(String, int, char[]) - 类 javax.swing.text.html.parser.DTD 中的方法
定义一个实体。
definePackage(String, String, String, String, String, String, String, URL) - 类 java.lang.ClassLoader 中的方法
根据 name 在此 ClassLoader 中定义包。
definePackage(String, Manifest, URL) - 类 java.net.URLClassLoader 中的方法
用该 ClassLoader 中的名称定义一个新包。
DefinitionKind - org.omg.CORBA 中的 类
该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。
DefinitionKind(int) - 类 org.omg.CORBA.DefinitionKind 的构造方法
构造一个 DefinitionKind 对象，使用给定值初始化其 _value 字段。
DefinitionKindHelper - org.omg.CORBA 中的 类
DefinitionKind 的 Helper。
DefinitionKindHelper() - 类 org.omg.CORBA.DefinitionKindHelper 的构造方法
deflate(byte[], int, int) - 类 java.util.zip.Deflater 中的方法
使用压缩数据填充指定缓冲区。
deflate(byte[]) - 类 java.util.zip.Deflater 中的方法
使用压缩数据填充指定缓冲区。
deflate() - 类 java.util.zip.DeflaterOutputStream 中的方法
将下一个压缩数据块写入输出流。
DEFLATE - 类 javax.print.attribute.standard.Compression 中的静态变量
ZIP 公共域 inflate/deflate 压缩技术。
DEFLATE_HINT - 接口 java.util.jar.Pack200.Packer 中的静态变量
如果将此属性设置为 Pack200.Packer.TRUE 或 Pack200.Packer.FALSE，则打包器将在输出存档中设置相应的压缩提示，并且不传输存档元素的单个压缩提示。
DEFLATE_HINT - 接口 java.util.jar.Pack200.Unpacker 中的静态变量
此属性指示解包器应该忽略 DEFLATE_HINT 的所有已传输的值，并用给定值 Pack200.Unpacker.TRUE 或 Pack200.Unpacker.FALSE 替换它们。
DEFLATED - 类 java.util.zip.Deflater 中的静态变量
deflate 算法（当前支持的唯一算法）的压缩方法。
DEFLATED - 类 java.util.zip.ZipEntry 中的静态变量
用于已压缩 (deflated) 条目的压缩方法。
DEFLATED - 类 java.util.zip.ZipOutputStream 中的静态变量
用于已压缩 (DEFLATED) 条目的压缩方法。
Deflater - java.util.zip 中的 类
此类使用流行的 ZLIB 压缩程序库为通用压缩提供支持。
Deflater(int, boolean) - 类 java.util.zip.Deflater 的构造方法
使用指定压缩级别创建新的压缩器。
Deflater(int) - 类 java.util.zip.Deflater 的构造方法
使用指定压缩级别创建新的压缩器。
Deflater() - 类 java.util.zip.Deflater 的构造方法
使用默认压缩级别创建新的压缩器。
DeflaterInputStream - java.util.zip 中的 类
为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。
DeflaterInputStream(InputStream) - 类 java.util.zip.DeflaterInputStream 的构造方法
创建一个带有默认压缩器和缓冲区大小的新输入流。
DeflaterInputStream(InputStream, Deflater) - 类 java.util.zip.DeflaterInputStream 的构造方法
创建一个带有指定压缩器和默认缓冲区大小的新输入流。
DeflaterInputStream(InputStream, Deflater, int) - 类 java.util.zip.DeflaterInputStream 的构造方法
创建一个带有指定压缩器和缓冲区大小的新输入流。
DeflaterOutputStream - java.util.zip 中的 类
此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
DeflaterOutputStream(OutputStream, Deflater, int) - 类 java.util.zip.DeflaterOutputStream 的构造方法
使用指定压缩器和缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream, Deflater) - 类 java.util.zip.DeflaterOutputStream 的构造方法
使用指定压缩器和默认缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream) - 类 java.util.zip.DeflaterOutputStream 的构造方法
使用默认压缩器和缓冲区大小创建一个新输出流。
deiconifyFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
从父窗体中移除 desktopIcon，并将其窗体添加到父窗体中。
deiconifyFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常移除现有的任何图标表示形式，并将窗体恢复到其原始大小和位置。
deiconifyFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
当用户要取消图标化窗体时调用此方法。
deiconize() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
deinstall(JTextComponent) - 接口 javax.swing.text.Caret 中的方法
在将 UI 从 JTextComponent 的接口中移除时调用。
deinstall(JTextComponent) - 类 javax.swing.text.DefaultCaret 中的方法
当 UI 从一个 JTextComponent 的接口移除时调用。
deinstall(JTextComponent) - 类 javax.swing.text.DefaultHighlighter 中的方法
从 JTextComponent 的接口移除 UI 时调用。
deinstall(JEditorPane) - 类 javax.swing.text.EditorKit 中的方法
从 JEditorPane 中移除工具包时调用。
deinstall(JTextComponent) - 接口 javax.swing.text.Highlighter 中的方法
将 UI 从 JTextComponent 的接口移除时调用。
deinstall(JEditorPane) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
工具包从 JEditorPane 移除时调用。
deinstall(JEditorPane) - 类 javax.swing.text.StyledEditorKit 中的方法
工具包从 JEditorPane 移除时调用。
deinstallMouseHandlers(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
delay(int) - 类 java.awt.Robot 中的方法
睡眠指定的时间。
Delayed - java.util.concurrent 中的 接口
一种混合风格的接口，用来标记那些应该在给定延迟时间之后执行的对象。
DelayQueue<E extends Delayed> - java.util.concurrent 中的 类
Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
DelayQueue() - 类 java.util.concurrent.DelayQueue 的构造方法
创建一个最初为空的新 DelayQueue。
DelayQueue(Collection<? extends E>) - 类 java.util.concurrent.DelayQueue 的构造方法
创建一个最初包含 Delayed 实例的给定 collection 元素的 DelayQueue。
delegate - 类 javax.swing.DefaultCellEditor 中的变量
处理从 CellEditor 发送的所有方法的委托类。
Delegate - org.omg.CORBA.portable 中的 类
为 org.omg.CORBA.Object 方法特定于供应商的 ORB 实现指定一个可移植的 API。
Delegate() - 类 org.omg.CORBA.portable.Delegate 的构造方法
Delegate - org.omg.CORBA_2_3.portable 中的 类
Delegate 类提供 CORBA 对象特定于 ORB 供应商的实现。
Delegate() - 类 org.omg.CORBA_2_3.portable.Delegate 的构造方法
Delegate - org.omg.PortableServer.portable 中的 接口
可移植性包包含供 ORB 实现者使用的接口和类。
DELEGATE_NAME - 类 javax.management.MBeanServerDelegate 中的静态变量
定义 MBeanServerDelegate 的默认 ObjectName。
delegateFocus(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此为一种实用程序方法，用于帮助事件处理程序计算出在调出弹出控件时将焦点发送到的位置。
delegateFocus(MouseEvent) - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup 中的方法
已过时。
DelegationPermission - javax.security.auth.kerberos 中的 类
此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。
DelegationPermission(String) - 类 javax.security.auth.kerberos.DelegationPermission 的构造方法
创建带有指定从属主体和目标主体的新 DelegationPermission。
DelegationPermission(String, String) - 类 javax.security.auth.kerberos.DelegationPermission 的构造方法
创建带有指定从属主体和目标主体的新 DelegationPermission。
DELETE - 类 java.awt.Event 中的静态变量
Delete 键。
delete() - 类 java.io.File 中的方法
删除此抽象路径名表示的文件或目录。
delete(int, int) - 类 java.lang.StringBuffer 中的方法
delete(int, int) - 类 java.lang.StringBuilder 中的方法
delete(int, int) - 接口 javax.accessibility.AccessibleEditableText 中的方法
删除两个索引之间的文本
DELETE - 接口 javax.accessibility.AccessibleTableModelChange 中的静态变量
标识行和/或列的删除。
DELETE - 类 javax.swing.event.TableModelEvent 中的静态变量
标识行或列的移除。
delete(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
删除两个索引之间的文本
delete(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
删除两个索引之间的文本
delete() - 接口 javax.tools.FileObject 中的方法
删除此文件对象。
delete() - 类 javax.tools.ForwardingFileObject 中的方法
delete() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现不执行任何操作。
DELETE_ROW_CONFLICT - 接口 javax.sql.rowset.spi.SyncResolver 中的静态变量
指示在 RowSet 对象试图删除数据源中的行时发生冲突。
delete_values(String) - 类 org.omg.CORBA.Context 中的方法
从此 Context 对象中删除 name 字段与给定属性名称匹配的 NamedValue 对象。
deleteChar(AttributedCharacterIterator, int) - 类 java.awt.font.LineBreakMeasurer 中的方法
从文本删除单个字符之后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。
deleteChar(AttributedCharacterIterator, int) - 类 java.awt.font.TextMeasurer 中的方法
从当前由此 TextMeasurer 表示的段落中删除一个字符后，更新 TextMeasurer。
deleteCharAt(int) - 类 java.lang.StringBuffer 中的方法
deleteCharAt(int) - 类 java.lang.StringBuilder 中的方法
deleteData(int, int) - 接口 org.w3c.dom.CharacterData 中的方法
从该节点移除某个范围的 16 位单元。
deleteEntry(String) - 类 java.security.KeyStore 中的方法
删除此 keystore 中给定别名标识的条目。
deleteNextCharAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
删除当前插入符位置之后字符内容的动作名称。
deleteNextWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
删除选择开始位置之后单词的动作名称。
deleteObserver(Observer) - 类 java.util.Observable 中的方法
从对象的观察者集合中删除某个观察者。
deleteObservers() - 类 java.util.Observable 中的方法
清除观察者列表，使此对象不再有任何观察者。
deleteOnExit() - 类 java.io.File 中的方法
在虚拟机终止时，请求删除此抽象路径名表示的文件或目录。
deleteOwner(Principal, Principal) - 接口 java.security.acl.Owner 中的方法
删除一个所有者。
deletePrevCharAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
删除当前插入符位置之前字符内容的动作名称。
deletePrevWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
删除选择开始位置之前单词的动作名称。
deleteRow() - 接口 java.sql.ResultSet 中的方法
从此 ResultSet 对象和底层数据库中删除当前行。
deletesAreDetected(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以通过调用 ResultSet.rowDeleted 方法检测可见行的删除。
deleteShortcut(MenuShortcut) - 类 java.awt.MenuBar 中的方法
删除指定的菜单快捷方式。
deleteShortcut() - 类 java.awt.MenuItem 中的方法
删除与此菜单项关联的任何 MenuShortcut 对象。
deleteTrack(Track) - 类 javax.sound.midi.Sequence 中的方法
从 Sequence 中移除指定的轨道。
delimiter() - 类 java.util.Scanner 中的方法
返回此 Scanner 当前正在用于匹配分隔符的 Pattern。
delItem(int) - 类 java.awt.List 中的方法
已过时。 由 remove(String) 和 remove(int) 取代。
delItems(int, int) - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，后来不再公开使用。只希望作为包私有方法时保留此方法。
deliverEvent(Event) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent e) 取代。
deliverEvent(Event) - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 dispatchEvent(AWTEvent e) 取代
deltaTransform(Point2D, Point2D) - 类 java.awt.geom.AffineTransform 中的方法
变换由 ptSrc 指定的相对距离向量，并将结果存储在 ptDst 中。
deltaTransform(double[], int, double[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换相对距离向量数组。
Deprecated - java.lang 中的 注释类型
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
depth() - 类 javax.swing.text.ElementIterator 中的方法
获取元素树的当前深度。
depthFirstEnumeration() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回一个枚举，该枚举按深度优先的顺序遍历以此节点为根的子树。
depthOffset - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
要正确计算 x 位置应该偏移的深度。
Deque<E> - java.util 中的 接口
一个线性 collection，支持在两端插入和移除元素。
dequeueKeyEvents(long, Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
释放正常指派到当前焦点所有者的所有 KeyEvent，这些 KeyEvent 因为调用了具有相同时间戳和 Component 的 enqueueKeyEvents 而被加入队列。
dequeueKeyEvents(long, Component) - 类 java.awt.KeyboardFocusManager 中的方法
由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。
dereference(XMLCryptoContext) - 接口 javax.xml.crypto.dsig.keyinfo.RetrievalMethod 中的方法
取消引用此 RetrievalMethod 引用的 KeyInfo 信息，并应用指定的 Transform。
dereference(URIReference, XMLCryptoContext) - 接口 javax.xml.crypto.URIDereferencer 中的方法
取消引用指定 URIReference 并返回已取消引用的数据。
deregister(AbstractSelectionKey) - 类 java.nio.channels.spi.AbstractSelector 中的方法
从其通道的键集中移除给定的键。
deregisterAll(Class<?>) - 类 javax.imageio.spi.ServiceRegistry 中的方法
注销给定类别下当前注册的所有服务提供者对象。
deregisterAll() - 类 javax.imageio.spi.ServiceRegistry 中的方法
从所有类别注销所有当前注册的服务提供者。
deregisterDriver(Driver) - 类 java.sql.DriverManager 中的静态方法
从 DriverManager 的列表中删除一个驱动程序。
deregisterServiceProvider(T, Class<T>) - 类 javax.imageio.spi.ServiceRegistry 中的方法
从给定的类别中移除服务提供者对象。
deregisterServiceProvider(Object) - 类 javax.imageio.spi.ServiceRegistry 中的方法
从包含它的所有类别中移除服务提供者对象。
DERIVATION_EXTENSION - 接口 org.w3c.dom.TypeInfo 中的静态变量
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示由 extension 派生出的。
DERIVATION_LIST - 接口 org.w3c.dom.TypeInfo 中的静态变量
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示 列表。
DERIVATION_RESTRICTION - 接口 org.w3c.dom.TypeInfo 中的静态变量
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示通过 restriction 进行的派生（如果涉及复杂的类型）或 restriction（如果涉及简单的类型）。
DERIVATION_UNION - 接口 org.w3c.dom.TypeInfo 中的静态变量
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示 union（如果涉及简单类型）。
derive(int) - 类 java.awt.AlphaComposite 中的方法
返回一个类似的 AlphaComposite 对象，该对象使用指定的复合规则。
derive(float) - 类 java.awt.AlphaComposite 中的方法
返回一个类似的 AlphaComposite 对象，该对象使用指定的 alpha 值。
deriveFont(int, float) - 类 java.awt.Font 中的方法
通过复制此 Font 对象并应用新样式和大小，创建一个新 Font 对象。
deriveFont(int, AffineTransform) - 类 java.awt.Font 中的方法
通过复制此 Font 对象并应用新样式和变换，创建一个新 Font 对象。
deriveFont(float) - 类 java.awt.Font 中的方法
通过复制当前 Font 对象并应用新的大小，创建一个新 Font 对象。
deriveFont(AffineTransform) - 类 java.awt.Font 中的方法
通过复制当前 Font 对象并应用新的变换，创建一个新 Font 对象。
deriveFont(int) - 类 java.awt.Font 中的方法
通过复制当前的 Font 对象，并应用新的样式，创建一个新 Font 对象。
deriveFont(Map<? extends AttributedCharacterIterator.Attribute, ?>) - 类 java.awt.Font 中的方法
通过复制当前 Font 对象并应用新的字体属性集，创建一个新 Font 对象。
deriveMMFont(float[]) - 接口 java.awt.font.MultipleMaster 中的方法
根据指定数组中包含的设计轴值，创建 multiple master 字体的新实例。
deriveMMFont(float[], float, float, float, float) - 接口 java.awt.font.MultipleMaster 中的方法
根据详细的规格信息，创建 multiple master 字体的新实例。
DES_EDE_KEY_LEN - 类 javax.crypto.spec.DESedeKeySpec 中的静态变量
定义以 byte 为单位的 DESede 密钥长度的常量。
DES_KEY_LEN - 类 javax.crypto.spec.DESKeySpec 中的静态变量
定义以字节为单位的 DES 密钥长度的常量。
descendingIterator() - 类 java.util.ArrayDeque 中的方法
descendingIterator() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
返回在此 set 的元素上以降序进行迭代的迭代器。
descendingIterator() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回在此双端队列的元素上以逆向连续顺序进行迭代的迭代器。
descendingIterator() - 接口 java.util.Deque 中的方法
返回以逆向顺序在此双端队列的元素上进行迭代的迭代器。
descendingIterator() - 类 java.util.LinkedList 中的方法
descendingIterator() - 接口 java.util.NavigableSet 中的方法
以降序返回在此 set 的元素上进行迭代的迭代器。
descendingIterator() - 类 java.util.TreeSet 中的方法
返回在此 set 元素上按降序进行迭代的迭代器。
descendingKeySet() - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
返回此映射中所包含键的逆序 NavigableSet 视图。
descendingKeySet() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
descendingKeySet() - 接口 java.util.NavigableMap 中的方法
返回此映射中所包含键的逆序 NavigableSet 视图。
descendingKeySet() - 类 java.util.TreeMap 中的方法
descendingMap() - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
返回此映射中所包含映射关系的逆序视图。
descendingMap() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
descendingMap() - 接口 java.util.NavigableMap 中的方法
返回此映射中所包含映射关系的逆序视图。
descendingMap() - 类 java.util.TreeMap 中的方法
descendingSet() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
返回此 set 中所包含元素的逆序视图。
descendingSet() - 接口 java.util.NavigableSet 中的方法
返回此 set 中所包含元素的逆序视图。
descendingSet() - 类 java.util.TreeSet 中的方法
description - 类 java.sql.DriverPropertyInfo 中的变量
属性的简要描述，可能为 null。
description - 类 javax.management.MBeanFeatureInfo 中的变量
该功能的可读描述。
Descriptor - javax.management 中的 接口
JMX 元素的附加元数据。
DescriptorAccess - javax.management 中的 接口
此接口用于获得对 Descriptor 类的描述符的访问，这些 Descriptor 类与某个 JMX 组件相关联，比如 MBean、MBeanInfo、MBeanAttributeInfo、MBeanNotificationInfo、MBeanOperationInfo 和 MBeanParameterInfo。
DescriptorKey - javax.management 中的 注释类型
描述注释元素与 Descriptor 中字段之间关联方式的元注释。
DescriptorRead - javax.management 中的 接口
读取管理接口元素（如 MBeanInfo）的 Descriptor 的接口。
DescriptorSupport - javax.management.modelmbean 中的 类
此类表示 ModelMBean 元素的元数据集。
DescriptorSupport() - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
描述符默认的构造方法。
DescriptorSupport(int) - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
描述符构造方法。
DescriptorSupport(DescriptorSupport) - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
采用 Descriptor 作为参数的描述符构造方法。
DescriptorSupport(String) - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
Descriptor 构造方法带有一个 XML String。
DescriptorSupport(String[], Object[]) - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
带有字段名称和字段值的构造方法。
DescriptorSupport(String...) - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
带有 fieldName=fieldValue 格式的字段的构造方法。
DESedeKeySpec - javax.crypto.spec 中的 类
此类指定一个 DES-EDE ("triple-DES") 密钥。
DESedeKeySpec(byte[]) - 类 javax.crypto.spec.DESedeKeySpec 的构造方法
创建一个 DESedeKeySpec 对象，使用 key 中的前 24 个字节作为 DES-EDE 密钥的密钥内容。
DESedeKeySpec(byte[], int) - 类 javax.crypto.spec.DESedeKeySpec 的构造方法
创建一个 DESedeKeySpec 对象，使用 key 中始于且包含 offset 的前 24 个字节作为 DES-EDE 密钥的密钥内容。
deselect(int) - 类 java.awt.List 中的方法
取消选择指定索引处的项。
DESELECTED - 类 java.awt.event.ItemEvent 中的静态变量
此状态更改值指示已选定的项被取消选定。
DESERET - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Deseret”Unicode 字符块的常量。
deserialize(ObjectInputStream, Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
readObject 使用此方法来反序列化一个 collection。
deserialize(ObjectName, byte[]) - 接口 javax.management.MBeanServer 中的方法
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
deserialize(String, byte[]) - 接口 javax.management.MBeanServer 中的方法
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
deserialize(String, ObjectName, byte[]) - 接口 javax.management.MBeanServer 中的方法
已过时。 使用 getClassLoader 为反序列化获得类加载器。
DESIGNATED_LONG - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO Designated Long 尺寸，110 mm × 220 mm。
DesignMode - java.beans 中的 接口
此接口由 java.beans.beancontext.BeanContext 的实例实现或委托，以便将当前的 "designTime" 属性传播到 java.beans.beancontext.BeanContextChild 实例的嵌套层次结构。
designTime - 类 java.beans.beancontext.BeanContextSupport 中的变量
指示此对象目前是否处于设计时间模式下的 boolean 值。
desiredAssertionStatus() - 类 java.lang.Class 中的方法
如果要在调用此方法时将要初始化该类，则返回将分配给该类的断言状态。
DESKeySpec - javax.crypto.spec 中的 类
此类指定一个 DES 密钥。
DESKeySpec(byte[]) - 类 javax.crypto.spec.DESKeySpec 的构造方法
创建一个 DESKeySpec 对象，使用 key 中的前 8 个字节作为 DES 密钥的密钥内容。
DESKeySpec(byte[], int) - 类 javax.crypto.spec.DESKeySpec 的构造方法
创建一个 DESKeySpec 对象，使用 key 中始于且包含 offset 的前 8 个字节作为 DES-EDE 密钥的密钥内容。
Desktop - java.awt 中的 类
Desktop 类允许 Java 应用程序启动已在本机桌面上注册的关联应用程序，以处理 URI 或文件。
DESKTOP - 类 java.awt.SystemColor 中的静态变量
SystemColor.desktop 系统颜色的数组索引。
desktop - 类 java.awt.SystemColor 中的静态变量
为桌面背景提供的颜色。
desktop - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
Desktop.Action - java.awt 中的 枚举
表示动作类型。
DESKTOP_ICON - 类 javax.accessibility.AccessibleRole 中的静态变量
DESKTOP_PANE 中的图标化的内部 frame。
DESKTOP_ICON - 类 javax.swing.plaf.synth.Region 中的静态变量
DesktopIcon 的 region。
DESKTOP_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
支持内部窗体和这些内部窗体的图标化形式的窗格。
DESKTOP_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
DesktopPane 的 region。
desktopIcon - 类 javax.swing.JInternalFrame 中的变量
此内部窗体图标化时所显示的图标。
desktopIcon - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的变量
DesktopIconUI - javax.swing.plaf 中的 类
JDesktopIcon 的可插入外观界面。
DesktopIconUI() - 类 javax.swing.plaf.DesktopIconUI 的构造方法
DesktopManager - javax.swing 中的 接口
DesktopManager 对象由 DesktopPane 对象所拥有。
desktopManager - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
DesktopPaneUI - javax.swing.plaf 中的 类
JDesktopPane 的可插入外观界面。
DesktopPaneUI() - 类 javax.swing.plaf.DesktopPaneUI 的构造方法
desktopProperties - 类 java.awt.Toolkit 中的变量
desktopPropsSupport - 类 java.awt.Toolkit 中的变量
destHeight - 类 java.awt.image.ReplicateScaleFilter 中的变量
缩放图像的目标高度。
destination - 类 javax.imageio.ImageReadParam 中的变量
当前目标 BufferedImage；如果没有设置目标图像，则为 null。
Destination - javax.print.attribute.standard 中的 类
Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
Destination(URI) - 类 javax.print.attribute.standard.Destination 的构造方法
构造具有给定 URI 的新目标属性。
destination - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的变量
接收所有事件的目的地。
destinationBands - 类 javax.imageio.ImageReadParam 中的变量
要使用的目标 band 集合（int 数组的形式）。
destinationOffset - 类 javax.imageio.IIOParam 中的变量
目标区域中的偏移量，应将左上部解码像素置于此处。
destinationType - 类 javax.imageio.IIOParam 中的变量
一个 ImageTypeSpecifier，用来在进行读取操作时生成目标图像，或者在进行写入操作时设置输出颜色类型。
destroy() - 类 java.applet.Applet 中的方法
由浏览器或 applet viewer 调用，通知此 applet 它正在被回收，它应该销毁分配给它的任何资源。
destroy() - 类 java.lang.Process 中的方法
杀掉子进程。
destroy() - 类 java.lang.Thread 中的方法
已过时。 该方法最初用于破坏该线程，但不作任何清除。它所保持的任何监视器都会保持锁定状态。不过，该方法决不会被实现。即使要实现，它也极有可能以 Thread.suspend() 方式被死锁。如果目标线程被破坏时保持一个保护关键系统资源的锁，则任何线程在任何时候都无法再次访问该资源。如果另一个线程曾试图锁定该资源，则会出现死锁。这类死锁通常会证明它们自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
destroy() - 类 java.lang.ThreadGroup 中的方法
销毁此线程组及其所有子组。
destroy() - 类 java.security.KeyStore.PasswordProtection 中的方法
清除密码。
destroy() - 接口 javax.security.auth.Destroyable 中的方法
销毁此 Object。
destroy() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
销毁此密钥。
destroy() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
销毁票据和存储在其中的敏感信息。
destroy() - 类 javax.security.auth.x500.X500PrivateCredential 中的方法
清除对此对象中的 X.509 证书、私钥和 KeyStore 别名的引用。
destroy() - 类 org.omg.CORBA._IDLTypeStub 中的方法
destroy() - 类 org.omg.CORBA._PolicyStub 中的方法
销毁策略对象。
destroy() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 销毁此 DynAny 对象，释放用来表示与之关联的数据值的所有资源。
destroy() - 接口 org.omg.CORBA.IRObjectOperations 中的方法
销毁此对象。
destroy() - 类 org.omg.CORBA.ORB 中的方法
销毁 ORB，以便可以回收其资源。
destroy() - 接口 org.omg.CORBA.PolicyOperations 中的方法
销毁 Policy 对象。
destroy() - 类 org.omg.CosNaming._BindingIteratorStub 中的方法
此操作销毁迭代器。
destroy() - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
destroy 操作删除命名上下文。
destroy() - 类 org.omg.CosNaming._NamingContextStub 中的方法
destroy 操作删除命名上下文。
destroy() - 接口 org.omg.CosNaming.BindingIteratorOperations 中的方法
此操作销毁迭代器。
destroy() - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
destroy 操作删除命名上下文。
destroy() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynStructStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynValueStub 中的方法
销毁 DynAny 对象。
destroy() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
销毁 DynAny 对象。
destroy() - 接口 org.omg.PortableInterceptor.InterceptorOperations 中的方法
提供销毁此 interceptor 的机会。
destroy(boolean, boolean) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作销毁 POA 及所有子代 POA。
Destroyable - javax.security.auth 中的 接口
诸如 credentials 之类的对象可以选择实现此接口以便提供销毁它的内容的功能。
destroyBuffers() - 类 java.awt.Component.FlipBufferStrategy 中的方法
销毁通过此对象所创建的缓冲区。
DestroyFailedException - javax.security.auth 中的 异常
当 destroy 操作失败时，抛出此异常。
DestroyFailedException() - 异常 javax.security.auth.DestroyFailedException 的构造方法
构造不带详细消息的 DestroyFailedException。
DestroyFailedException(String) - 异常 javax.security.auth.DestroyFailedException 的构造方法
构造带指定详细消息的 DestroyFailedException。
destroySubcontext(Name) - 接口 javax.naming.Context 中的方法
销毁指定上下文，并将它从名称空间中移除。
destroySubcontext(String) - 接口 javax.naming.Context 中的方法
销毁指定上下文，并将它从名称空间中移除。
destroySubcontext(String) - 类 javax.naming.InitialContext 中的方法
destroySubcontext(Name) - 类 javax.naming.InitialContext 中的方法
destWidth - 类 java.awt.image.ReplicateScaleFilter 中的变量
缩放图像的目标宽度。
detachNode() - 接口 javax.xml.soap.Node 中的方法
从树中移除此 Node 对象。
detail - 异常 java.io.WriteAbortedException 中的变量
在写入 ObjectStream 时捕获的异常。
detail - 异常 java.rmi.activation.ActivationException 中的变量
激活异常的原因。
detail - 异常 java.rmi.RemoteException 中的变量
远程异常的原因。
detail - 异常 java.rmi.server.ServerCloneException 中的变量
异常原因。
Detail - javax.xml.soap 中的 接口
DetailEntry 对象的容器。
DetailEntry - javax.xml.soap 中的 接口
Detail 对象的内容，给出 SOAPFault 对象的详细信息。
detailsViewIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
detectedCharset() - 类 java.nio.charset.CharsetDecoder 中的方法
获取此解码器检测到的 charset（可选操作）。
determineOffset(JTree, Object, boolean, boolean, boolean, int) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
DEVANAGARI - 类 java.awt.font.NumericShaper 中的静态变量
标识 DEVANAGARI 范围和十进制基数。
DEVANAGARI - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Devanagari”Unicode 字符块的常量。
DEVELOPER_EMPTY - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备显影剂已用完。
DEVELOPER_LOW - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备显影剂不足。
DFN - 类 javax.swing.text.html.HTML.Tag 中的静态变量
DGC - java.rmi.dgc 中的 接口
DGC 抽象用于分布式垃圾回收算法的服务器端。
DGC_ID - 类 java.rmi.server.ObjID 中的静态变量
分布式垃圾回收器的已知 ObjID 的对象数。
DHGenParameterSpec - javax.crypto.spec 中的 类
此类指定用于生成在 Diffie-Hellman 密钥协议中使用的 Diffie-Hellman（系统）参数的参数集合。
DHGenParameterSpec(int, int) - 类 javax.crypto.spec.DHGenParameterSpec 的构造方法
为生成 Diffie-Hellman（系统）参数构造一个参数集。
DHKey - javax.crypto.interfaces 中的 接口
Diffie-Hellman 密钥的接口。
DHParameterSpec - javax.crypto.spec 中的 类
此类指定随同 Diffie-Hellman 算法使用的参数集合，该算法在 PKCS #3：Diffie-Hellman Key-Agreement Standard 中指定。
DHParameterSpec(BigInteger, BigInteger) - 类 javax.crypto.spec.DHParameterSpec 的构造方法
使用质数模数 p 和基生成器 g 为 Diffie-Hellman 构造一个参数集。
DHParameterSpec(BigInteger, BigInteger, int) - 类 javax.crypto.spec.DHParameterSpec 的构造方法
使用质数模数 p、基生成器 g 以及以位为单位的随机指数大小 l（私有值）为 Diffie-Hellman 构造一个参数集。
DHPrivateKey - javax.crypto.interfaces 中的 接口
Diffie-Hellman 私钥接口。
DHPrivateKeySpec - javax.crypto.spec 中的 类
此类使用其关联的参数指定一个 Diffie-Hellman 私钥。
DHPrivateKeySpec(BigInteger, BigInteger, BigInteger) - 类 javax.crypto.spec.DHPrivateKeySpec 的构造方法
带有一个私有值 x、一个质数模数 p 以及一个基生成器 g 的构造方法。
DHPublicKey - javax.crypto.interfaces 中的 接口
Diffie-Hellman 公钥接口。
DHPublicKeySpec - javax.crypto.spec 中的 类
此类使用关联的参数指定一个 Diffie-Hellman 公钥。
DHPublicKeySpec(BigInteger, BigInteger, BigInteger) - 类 javax.crypto.spec.DHPublicKeySpec 的构造方法
带有一个公有值 y、一个质数模数 p 以及一个基生成器 g 的构造方法。
Diagnostic<S> - javax.tools 中的 接口
用于来自工具的诊断的接口。
Diagnostic.Kind - javax.tools 中的 枚举
诊断的种类，例如，错误或者警告。
DiagnosticCollector<S> - javax.tools 中的 类
提供将诊断收集到一个列表中的简单方法。
DiagnosticCollector() - 类 javax.tools.DiagnosticCollector 的构造方法
DiagnosticListener<S> - javax.tools 中的 接口
用于接收来自工具的诊断的接口。
Dialog - java.awt 中的 类
Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
Dialog(Frame) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Frame 和一个空标题。
Dialog(Frame, boolean) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定所有者 Frame、模式和一个空标题。
Dialog(Frame, String) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Frame 和标题。
Dialog(Frame, String, boolean) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题和模式。
Dialog(Frame, String, boolean, GraphicsConfiguration) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题、模式和 GraphicsConfiguration。
Dialog(Dialog) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Dialog 和一个空标题。
Dialog(Dialog, String) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Dialog 和标题。
Dialog(Dialog, String, boolean) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题和模式。
Dialog(Dialog, String, boolean, GraphicsConfiguration) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题、模式和 GraphicsConfiguration。
Dialog(Window) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Window 和一个空标题。
Dialog(Window, String) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Window 和标题。
Dialog(Window, Dialog.ModalityType) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定所有者 Window、模式和一个空标题。
Dialog(Window, String, Dialog.ModalityType) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题和模式。
Dialog(Window, String, Dialog.ModalityType, GraphicsConfiguration) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。
DIALOG - 类 java.awt.Font 中的静态变量
逻辑字体 "Dialog" 的规范系列名称的 String 常量。
DIALOG - 类 javax.accessibility.AccessibleRole 中的静态变量
带有标题栏和边框的顶层窗口。
Dialog.AccessibleAWTDialog - java.awt 中的 类
此类实现对 Dialog 类的可访问性支持。
Dialog.AccessibleAWTDialog() - 类 java.awt.Dialog.AccessibleAWTDialog 的构造方法
Dialog.ModalExclusionType - java.awt 中的 枚举
任何顶层窗口都可以标记为不受模式对话框阻塞。
Dialog.ModalityType - java.awt 中的 枚举
模式对话框阻塞对某些顶层窗口的所有输入。
DIALOG_INPUT - 类 java.awt.Font 中的静态变量
逻辑字体 "DialogInput" 的规范系列名称的 String 常量。
DIALOG_TITLE_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识对话框标题的更改。
DIALOG_TYPE_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识显示文件类型的更改（仅显示文件、仅显示目录或显示文件和目录）。
DIALOG_UI - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个作为 AWT 对话框实现的 UI。
dialogInit() - 类 javax.swing.JDialog 中的方法
构造方法调用此方法来正确初始化 JDialog。
Dictionary<K,V> - java.util 中的 类
Dictionary 类是任何可将键映射到相应值的类（如 Hashtable）的抽象父类。
Dictionary() - 类 java.util.Dictionary 的构造方法
单独的构造方法。
die() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
将 alive 设置为 false。
die() - 类 javax.swing.undo.CompoundEdit 中的方法
按添加时相反的顺序将 die 发送到每个子编辑。
die() - 接口 javax.swing.undo.UndoableEdit 中的方法
通知某个编辑不应再使用它。
digest - 类 java.security.DigestInputStream 中的变量
与此流关联的消息摘要。
digest - 类 java.security.DigestOutputStream 中的变量
与此流关联的消息摘要。
digest() - 类 java.security.MessageDigest 中的方法
通过执行诸如填充之类的最终操作完成哈希计算。
digest(byte[], int, int) - 类 java.security.MessageDigest 中的方法
通过执行诸如填充之类的最终操作完成哈希计算。
digest(byte[]) - 类 java.security.MessageDigest 中的方法
使用指定的 byte 数组对摘要进行最后更新，然后完成摘要计算。
DigestException - java.security 中的 异常
此为一般 Message Digest 异常。
DigestException() - 异常 java.security.DigestException 的构造方法
构造不带详细消息的 DigestException。
DigestException(String) - 异常 java.security.DigestException 的构造方法
构造带指定详细消息的 DigestException。
DigestException(String, Throwable) - 异常 java.security.DigestException 的构造方法
创建带指定详细消息和 cause 的 DigestException。
DigestException(Throwable) - 异常 java.security.DigestException 的构造方法
创建带指定 cause 和详细消息 DigestException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。
DigestInputStream - java.security 中的 类
使用通过流的位更新关联消息摘要的透明流。
DigestInputStream(InputStream, MessageDigest) - 类 java.security.DigestInputStream 的构造方法
使用指定的输入流和消息摘要创建一个摘要输入流。
DigestMethod - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML DigestMethod 元素的表示形式。
DigestMethodParameterSpec - javax.xml.crypto.dsig.spec 中的 接口
用于 DigestMethod 算法的算法参数的规范。
DigestOutputStream - java.security 中的 类
使用通过流的位更新关联消息摘要的透明流。
DigestOutputStream(OutputStream, MessageDigest) - 类 java.security.DigestOutputStream 的构造方法
使用指定的输出流和消息摘要创建一个摘要输出流。
digit(char, int) - 类 java.lang.Character 中的静态方法
返回使用指定基数的字符 ch 的数值。
digit(int, int) - 类 java.lang.Character 中的静态方法
返回使用指定基数的指定字符（Unicode 代码点）的数值。
Dimension - java.awt 中的 类
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Dimension() - 类 java.awt.Dimension 的构造方法
创建 Dimension 的一个实例（宽度为零，高度为零）。
Dimension(Dimension) - 类 java.awt.Dimension 的构造方法
创建 Dimension 的一个实例（宽度和高度与指定的 dimension 相同）。
Dimension(int, int) - 类 java.awt.Dimension 的构造方法
构造一个 Dimension，并将其初始化为指定宽度和高度。
Dimension2D - java.awt.geom 中的 类
Dimension2D 类用于封装宽度和高度尺寸。
Dimension2D() - 类 java.awt.geom.Dimension2D 的构造方法
这是一个不可直接实例化的抽象类。
DimensionUIResource - javax.swing.plaf 中的 类
DimensionUIResource(int, int) - 类 javax.swing.plaf.DimensionUIResource 的构造方法
DINGBATS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Dingbats”Unicode 字符块的常量。
DIR - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
DIR - 类 javax.swing.text.html.HTML.Tag 中的静态变量
DirContext - javax.naming.directory 中的 接口
目录服务接口，包含一些用于检查和更新与对象关联的属性以及搜索目录的方法。
DirectColorModel - java.awt.image 中的 类
DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。
DirectColorModel(int, int, int, int) - 类 java.awt.image.DirectColorModel 的构造方法
根据指定的指示 int 像素表示形式中哪些位包含红色、绿色和蓝色颜色样本的掩码构造 DirectColorModel。
DirectColorModel(int, int, int, int, int) - 类 java.awt.image.DirectColorModel 的构造方法
根据指定的指示在 int 像素表示形式中哪些位包含红色、绿色和蓝色颜色样本与 alpha 样本（如果存在）的掩码构造 DirectColorModel。
DirectColorModel(ColorSpace, int, int, int, int, int, boolean, int) - 类 java.awt.image.DirectColorModel 的构造方法
根据指定参数构造 DirectColorModel。
direction - 类 javax.swing.plaf.basic.BasicArrowButton 中的变量
箭头的方向。
direction - 类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 中的变量
direction - 类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 中的变量
指定用于调整选择的方向。
direction - 类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 中的变量
指定用于调整选择的方向。
direction - 类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 中的变量
确定要遍历的方向，1 意味着展开，-1 意味着折叠。
DIRECTION_DEFAULT_LEFT_TO_RIGHT - 类 java.text.Bidi 中的静态变量
表示基本方向依赖于根据 Unicode 双向算法得到的文本中第一个强方向字符的常量。
DIRECTION_DEFAULT_RIGHT_TO_LEFT - 类 java.text.Bidi 中的静态变量
表示基本方向依赖于根据 Unicode 双向算法得到的文本中第一个强方向字符的常量。
DIRECTION_LEFT_TO_RIGHT - 类 java.text.Bidi 中的静态变量
表示基本方向是从左到右的常量。
DIRECTION_RIGHT_TO_LEFT - 类 java.text.Bidi 中的静态变量
表示基本方向是从右到左的常量。
DIRECTIONALITY_ARABIC_NUMBER - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“AN”。
DIRECTIONALITY_BOUNDARY_NEUTRAL - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“BN”。
DIRECTIONALITY_COMMON_NUMBER_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“CS”。
DIRECTIONALITY_EUROPEAN_NUMBER - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“EN”。
DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“ES”。
DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“ET”。
DIRECTIONALITY_LEFT_TO_RIGHT - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“L”。
DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“LRE”。
DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“LRO”。
DIRECTIONALITY_NONSPACING_MARK - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“NSM”。
DIRECTIONALITY_OTHER_NEUTRALS - 类 java.lang.Character 中的静态变量
Unicode 规范中的非特定双向字符类型“ON”。
DIRECTIONALITY_PARAGRAPH_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的非特定双向字符类型“B”。
DIRECTIONALITY_POP_DIRECTIONAL_FORMAT - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“PDF”。
DIRECTIONALITY_RIGHT_TO_LEFT - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“R”。
DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“AL”。
DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“RLE”。
DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“RLO”。
DIRECTIONALITY_SEGMENT_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的非特定双向字符类型“S”。
DIRECTIONALITY_UNDEFINED - 类 java.lang.Character 中的静态变量
未定义的双向字符类型。
DIRECTIONALITY_WHITESPACE - 类 java.lang.Character 中的静态变量
Unicode 规范中的非特定双向字符类型“WS”。
DIRECTORIES_ONLY - 类 javax.swing.JFileChooser 中的静态变量
指示仅显示目录。
directory() - 类 java.lang.ProcessBuilder 中的方法
返回此进程生成器的工作目录。
directory(File) - 类 java.lang.ProcessBuilder 中的方法
设置此进程生成器的工作目录。
DIRECTORY_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识用户的目录更改。
DIRECTORY_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
允许用户在目录内容中导航并进行选择的窗格。
directoryIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
DirectoryManager - javax.naming.spi 中的 类
此类包含支持 DirContext 实现的方法。
directoryOpenButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
选择了目录且当前选择模式是 FILES_ONLY 时用于确认按钮的助记符键代码。
directoryOpenButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的标签文本。
directoryOpenButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的工具提示文本。
directSupertypes(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回类型的直接超类型。
DirObjectFactory - javax.naming.spi 中的 接口
此接口表示一个工厂，该工厂用来在给定某一对象以及有关该对象的属性的情况下创建该对象。
DirStateFactory - javax.naming.spi 中的 接口
此接口表示一个工厂，该工厂用来获得对象的状态和用于绑定的相应属性。
DirStateFactory.Result - javax.naming.spi 中的 类
用于返回 DirStateFactory.getStateToBind() 的结果的对象/属性对。
DirStateFactory.Result(Object, Attributes) - 类 javax.naming.spi.DirStateFactory.Result 的构造方法
构造一个 Result 实例。
dirty(ObjID[], long, Lease) - 接口 java.rmi.dgc.DGC 中的方法
脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。
disable() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
disable() - 类 java.awt.MenuItem 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
disable() - 类 java.lang.Compiler 中的静态方法
使编译器停止操作。
disable() - 类 javax.swing.JComponent 中的方法
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
disableAllAttributes() - 类 javax.management.AttributeChangeNotificationFilter 中的方法
禁用所有属性名称。
disableAllObjectNames() - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
禁用任何 MBeanServerNotification（取消选中所有的 ObjectName）。
disableAllTypes() - 类 javax.management.NotificationFilterSupport 中的方法
禁止所有通知类型。
disableAttribute(String) - 类 javax.management.AttributeChangeNotificationFilter 中的方法
禁用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定属性名称。
DISABLED - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示 region 未被启用的基本状态。
DISABLED_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识禁用按钮时使用的图标的更改。
DISABLED_SELECTED_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识禁用并选定按钮时使用的图标的更改。
disabledForeground - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
disabledTextColor - 类 javax.swing.plaf.metal.MetalButtonUI 中的变量
disabledTextColor - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的变量
disabledTextColor - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的变量
disableEvents(long) - 类 java.awt.Component 中的方法
禁用由传递给此组件的指定事件掩码参数所定义的事件。
disableEvents(long) - 类 java.awt.MenuItem 中的方法
禁止将事件提交到将由指定事件掩码参数定义的事件的菜单项。
disableObjectName(ObjectName) - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
禁用与给定 ObjectName 有关的 MBeanServerNotification。
disableResizedPosting() - 类 javax.swing.table.TableColumn 中的方法
已过时。 从 Java 2 platform v1.3 开始
disableSwingFocusManager() - 类 javax.swing.FocusManager 中的静态方法
已过时。 从 1.4 开始，由 KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy) 取代
disableType(String) - 类 javax.management.NotificationFilterSupport 中的方法
从前缀列表中移除给定的前缀。
discard_requests(boolean) - 接口 org.omg.PortableServer.POAManagerOperations 中的方法
此操作将 POA 管理器的状态更改为丢弃 (discarding)。
discardAllEdits() - 类 javax.swing.undo.UndoManager 中的方法
清空撤消管理器，向进程中的每个编辑发送一个 die 消息。
DISCARDING - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/DISCARDING.java。
DISCARDING - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
discardKeyEvents(Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
放弃因为一次或多次调用具有指定 Component 或其子代之一的 enqueueKeyEvents 而加入队列的所有 KeyEvent。
discardKeyEvents(Component) - 类 java.awt.KeyboardFocusManager 中的方法
由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。
disconnect() - 类 java.net.DatagramSocket 中的方法
断开套接字的连接。
disconnect() - 类 java.net.DatagramSocketImpl 中的方法
断开数据报套接字和远程目标的连接。
disconnect() - 类 java.net.HttpURLConnection 中的方法
指示近期服务器不太可能有其他请求。
disconnect() - 类 java.nio.channels.DatagramChannel 中的方法
断开此通道套接字的连接。
disconnect(Object) - 类 org.omg.CORBA.ORB 中的方法
断开给定 servant 对象与 ORB 的连接。
DISCONTIGUOUS_TREE_SELECTION - 接口 javax.swing.tree.TreeSelectionModel 中的静态变量
选择可以包含任何数量的项，这些项不必是连续的。
discriminator() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 返回一个 DynAny 对象引用，为了插入/获取鉴别符值，必须将该对象收缩为该鉴别符的类型。
discriminator_kind() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 返回与此 union 的鉴别符关联的 TCKind 对象。
discriminator_kind() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回鉴别符 TypeCode 的 TCKind 值。
discriminator_kind() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
返回鉴别符 TypeCode 的 TCKind 值。
discriminator_type() - 类 org.omg.CORBA.TypeCode 中的方法
返回描述所有非默认成员标签的 TypeCode 对象。
disjoint(Collection<?>, Collection<?>) - 类 java.util.Collections 中的静态方法
如果两个指定 collection 中没有相同的元素，则返回 true。
dismiss(JSpinner) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
将此编辑器从指定的 JSpinner 断开连接。
dispatch() - 接口 java.awt.ActiveEvent 中的方法
将事件指派给目标、事件源侦听器，或者做任何希望此事件去做的事情。
dispatch() - 类 java.awt.event.InvocationEvent 中的方法
执行 Runnable 的 run() 方法并在 run() 返回时通知 notifier（如果有）。
dispatch(Remote, RemoteCall, int, long) - 接口 java.rmi.server.Skeleton 中的方法
已过时。 无替代版本
dispatch(NamingListener) - 类 javax.naming.event.NamingEvent 中的方法
对此事件调用适当的侦听器方法。
dispatch(NamingListener) - 类 javax.naming.event.NamingExceptionEvent 中的方法
使用此事件对侦听器调用 namingExceptionThrown() 方法。
dispatch(UnsolicitedNotificationListener) - 类 javax.naming.ldap.UnsolicitedNotificationEvent 中的方法
使用此事件对侦听器调用 notificationReceived() 方法。
Dispatch<T> - javax.xml.ws 中的 接口
Dispatch 接口提供对动态调用服务端点操作的支持。
dispatchEvent(AWTEvent) - 类 java.awt.Component 中的方法
为组件或其子组件之一指派事件。
dispatchEvent(AWTEvent) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
此方法由 AWT 事件调度程序调用，该调度程序请求当前的 KeyboardFocusManager 以它的名义指派指定的事件。
dispatchEvent(AWTEvent) - 类 java.awt.EventQueue 中的方法
指派一个事件。
dispatchEvent(AWTEvent) - 类 java.awt.im.InputContext 中的方法
将事件指派到处于活动状态的输入方法。
dispatchEvent(AWTEvent) - 接口 java.awt.im.spi.InputMethod 中的方法
将事件指派到输入方法。
dispatchEvent(AWTEvent) - 类 java.awt.KeyboardFocusManager 中的方法
AWT 事件调度程序可以调用此方法，请求当前的 KeyboardFocusManager 为其指派指定的事件。
dispatchEvent(AWTEvent) - 类 java.awt.MenuComponent 中的方法
将事件传递给此组件或其子组件之一。
dispatchEvent(Event) - 接口 org.w3c.dom.events.EventTarget 中的方法
此方法允许将事件指派到实现事件模型。
dispatchInputMethodEvent(int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - 接口 java.awt.im.spi.InputMethodContext 中的方法
根据给定的参数创建输入方法事件并将其指派到客户端组件。
dispatchKeyEvent(KeyEvent) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
如果调度程序链中其他 KeyEventDispatcher 都没有调度 KeyEvent，或者没有注册其他 KeyEventDispatcher，则由 dispatchEvent 调用此方法。
dispatchKeyEvent(KeyEvent) - 类 java.awt.KeyboardFocusManager 中的方法
通常情况下，如果该指派程序链中的其他 KeyEventDispatcher 没有指派 KeyEvent 或者没有注册其他 KeyEventDispatcher，则 dispatchEvent 将调用此方法。
dispatchKeyEvent(KeyEvent) - 接口 java.awt.KeyEventDispatcher 中的方法
当前 KeyboardFocusManager 调用此方法，请求此 KeyEventDispatcher 为其指派指定的事件。
DISPLAY - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
DISPLAYABILITY_CHANGED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示 HIERARCHY_CHANGED 事件是因为层次结构的可显示性发生更改而生成的。
DISPLAYED_MNEMONIC_INDEX_KEY - 接口 javax.swing.Action 中的静态变量
用来存储对应于文本（由 NAME 属性标识）索引的 Integer 值的键，助记符的装饰应在该文本中呈现。
displayMessage(String, String, TrayIcon.MessageType) - 类 java.awt.TrayIcon 中的方法
在托盘图标附近显示弹出消息。
DisplayMode - java.awt 中的 类
DisplayMode 类封装 GraphicsDevice 的位深、高度、宽度和刷新率。
DisplayMode(int, int, int, int) - 类 java.awt.DisplayMode 的构造方法
使用提供的参数创建一个新的显示模式对象。
displayName() - 类 java.nio.charset.Charset 中的方法
返回此 charset 用于默认语言环境的可读名称。
displayName(Locale) - 类 java.nio.charset.Charset 中的方法
返回此 charset 用于给定语言环境的可读名称。
dispose() - 类 java.awt.Component.BltBufferStrategy 中的方法
释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。
dispose() - 类 java.awt.Component.FlipBufferStrategy 中的方法
释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。
dispose() - 接口 java.awt.CompositeContext 中的方法
释放分配给上下文的资源。
dispose() - 类 java.awt.Graphics 中的方法
释放此图形的上下文以及它使用的所有系统资源。
dispose() - 类 java.awt.im.InputContext 中的方法
释放由此输入上下文使用过的资源。
dispose() - 接口 java.awt.im.spi.InputMethod 中的方法
释放由此输入方法使用的资源。
dispose() - 类 java.awt.image.BufferStrategy 中的方法
释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。
dispose() - 接口 java.awt.PaintContext 中的方法
释放为操作分配的资源。
dispose() - 类 java.awt.Window 中的方法
释放由此 Window、其子组件及其拥有的所有子组件所使用的所有本机屏幕资源。
dispose() - 类 javax.imageio.ImageReader 中的方法
允许释放此对象占用的所有资源。
dispose() - 类 javax.imageio.ImageWriter 中的方法
允许释放此对象保存的所有资源。
dispose() - 类 javax.print.StreamPrintService 中的方法
处置此 StreamPrintService。
dispose() - 接口 javax.security.sasl.SaslClient 中的方法
处置 SaslClient 可能使用的所有系统资源或安全敏感信息。
dispose() - 接口 javax.security.sasl.SaslServer 中的方法
处置 SaslServer 可能使用的所有系统资源或安全敏感信息。
dispose() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.dispose。
dispose() - 类 javax.swing.JInternalFrame 中的方法
使此内部窗体不可见、取消选定并关闭它。
dispose() - 接口 org.ietf.jgss.GSSContext 中的方法
释放存储在上下文对象中并且使上下文无效的系统资源和加密信息。
dispose() - 接口 org.ietf.jgss.GSSCredential 中的方法
释放 GSSCredential 对象可能包含的任何敏感信息。
DISPOSE_ON_CLOSE - 接口 javax.swing.WindowConstants 中的静态变量
移除窗口的默认窗口关闭操作。
distance(double, double, double, double) - 类 java.awt.geom.Point2D 中的静态方法
返回两个点之间距离。
distance(double, double) - 类 java.awt.geom.Point2D 中的方法
返回从此 Point2D 到指定点的距离。
distance(Point2D) - 类 java.awt.geom.Point2D 中的方法
返回从此 Point2D 到指定 Point2D 的距离。
distanceSq(double, double, double, double) - 类 java.awt.geom.Point2D 中的静态方法
返回两个点之间距离的平方。
distanceSq(double, double) - 类 java.awt.geom.Point2D 中的方法
返回从此 Point2D 到指定点的距离的平方。
distanceSq(Point2D) - 类 java.awt.geom.Point2D 中的方法
返回从此 Point2D 到指定 Point2D 的距离的平方。
DISTINCT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 DISTINCT 的 Java 编程语言中的常量（有时称为类型代码）。
DIV - 类 javax.management.Query 中的静态变量
表示 Query.div(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
div(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个二进制表达式，表示两个数值的商。
DIV - 类 javax.swing.text.html.HTML.Tag 中的静态变量
divide(BigDecimal, int, int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
divide(BigDecimal, int, RoundingMode) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
divide(BigDecimal, int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
divide(BigDecimal, RoundingMode) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
divide(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this / divisor)，其首选标度为 (this.scale() - divisor.scale())；如果无法表示准确的商值（因为它有无穷的十进制扩展），则抛出 ArithmeticException。
divide(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (this / divisor) 的 BigDecimal（根据上下文设置进行舍入）。
divide(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this / val) 的 BigInteger。
divideAndRemainder(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟对两个操作数计算所得到的 remainder。
divideAndRemainder(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟根据上下文设置对两个操作数进行舍入计算所得到的 remainder 的结果。
divideAndRemainder(BigInteger) - 类 java.math.BigInteger 中的方法
返回包含 (this / val) 后跟 (this % val) 的两个 BigInteger 的数组。
DIVIDER - 类 javax.swing.JSplitPane 中的静态变量
用于添加一个表示分隔条的 Component。
divider - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
此 JSplitPane 的分隔符的实例。
DIVIDER_LOCATION_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 dividerLocation 属性。
DIVIDER_SIZE_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 border 属性名称。
dividerResizeToggleKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
dividerSize - 类 javax.swing.JSplitPane 中的变量
分隔条大小。
dividerSize - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
分隔符的大小。
dividerSize - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
拖动会话有效时分隔符的大小。
divideToIntegralValue(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其值为向下舍入所得商值 (this / divisor) 的整数部分。
divideToIntegralValue(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其值为 (this / divisor) 的整数部分。
divisionType - 类 javax.sound.midi.MidiFileFormat 中的变量
MIDI 文件的 division 类型。
divisionType - 类 javax.sound.midi.Sequence 中的变量
sequence 的定时 division 类型。
dk_AbstractInterface - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象表示一个抽象接口的静态 DefinitionKind 实例。
dk_Alias - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Alias 的静态 DefinitionKind 实例。
dk_all - 类 org.omg.CORBA.DefinitionKind 中的静态变量
通配符 DefinitionKind 常量，可用于 DefinitionKind 适合的所有情况。
dk_Array - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Array 的静态 DefinitionKind 实例。
dk_Attribute - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Attribute 的静态 DefinitionKind 实例。
dk_Constant - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个常量的静态 DefinitionKind 实例。
dk_Enum - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Enum 的静态 DefinitionKind 实例。
dk_Exception - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Exception 的静态 DefinitionKind 实例。
dk_Fixed - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Fixed value 的静态 DefinitionKind 实例。
dk_Interface - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Interface 的静态 DefinitionKind 实例。
dk_Module - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Module 的静态 DefinitionKind 实例。
dk_Native - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Native value 的静态 DefinitionKind 实例。
dk_none - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有任何定义种类的静态 DefinitionKind 实例。
dk_Operation - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Operation 的静态 DefinitionKind 实例。
dk_Primitive - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Primitive 的静态 DefinitionKind 实例。
dk_Repository - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Repository 的静态 DefinitionKind 实例。
dk_Sequence - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Sequence 的静态 DefinitionKind 实例。
dk_String - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 String 的静态 DefinitionKind 实例。
dk_Struct - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Struct 的静态 DefinitionKind 实例。
dk_Typedef - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Typedef 的静态 DefinitionKind 实例。
dk_Union - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Union 的静态 DefinitionKind 实例。
dk_Value - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Value 的静态 DefinitionKind 实例。
dk_ValueBox - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 ValueBox 的静态 DefinitionKind 实例。
dk_ValueMember - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 ValueMember 的静态 DefinitionKind 实例。
dk_Wstring - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Wstring 的静态 DefinitionKind 实例。
DL - 类 javax.swing.text.html.HTML.Tag 中的静态变量
DnDConstants - java.awt.dnd 中的 类
此类包含了表示 Drag 和 Drop 操作所执行的操作类型的常量值。
DNS_URL - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定用于 JNDI URL 上下文的 DNS 主机名和域名（例如 "dns://somehost/wiz.com"）的环境属性名称。
DO_NOTHING_ON_CLOSE - 接口 javax.swing.WindowConstants 中的静态变量
无操作默认窗口关闭操作。
doAccessibleAction(int) - 类 java.awt.Button.AccessibleAWTButton 中的方法
在对象上执行指定的操作
doAccessibleAction(int) - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
在对象上执行指定的操作
doAccessibleAction(int) - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
在对象上执行指定的操作
doAccessibleAction(int) - 类 java.awt.Choice.AccessibleAWTChoice 中的方法
在对象上执行指定的操作
doAccessibleAction(int) - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
对该对象执行指定的操作
doAccessibleAction(int) - 接口 javax.accessibility.AccessibleAction 中的方法
对对象执行指定的 Action
doAccessibleAction(int) - 类 javax.accessibility.AccessibleHyperlink 中的方法
对该对象执行指定的 Action
doAccessibleAction(int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
对该对象执行指定的 Action
doAccessibleAction(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
对该对象执行指定的 Action
doAccessibleAction(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
对该对象执行指定的 Action
doAccessibleAction(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
对该对象执行指定的操作
doAccessibleAction(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
执行树节点上的指定操作。
doAccessibleAction(int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
对该对象执行指定的 Action
doAs(Subject, PrivilegedAction<T>) - 类 javax.security.auth.Subject 中的静态方法
作为特定的 Subject 的功能。
doAs(Subject, PrivilegedExceptionAction<T>) - 类 javax.security.auth.Subject 中的静态方法
作为特定的 Subject 的功能。
doAsPrivileged(Subject, PrivilegedAction<T>, AccessControlContext) - 类 javax.security.auth.Subject 中的静态方法
作为特定的 Subject 的特权功能。
doAsPrivileged(Subject, PrivilegedExceptionAction<T>, AccessControlContext) - 类 javax.security.auth.Subject 中的静态方法
作为特定的 Subject 的特权功能。
Doc - javax.print 中的 接口
接口 Doc 指定某个对象的接口，该接口为 PrintJob 提供部分打印数据。
DocAttribute - javax.print.attribute 中的 接口
接口 DocAttribute 是打印属性类实现的一个标记接口，用于指示属性表示文档 (doc) 的设置（“Doc”是一个简短的、容易发音的术语，指“打印数据的片段”。
DocAttributeSet - javax.print.attribute 中的 接口
接口 DocAttributeSet 指定文档属性（即：实现接口 DocAttribute 的打印属性）集的接口。
DocFlavor - javax.print 中的 类
类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。
DocFlavor(String, String) - 类 javax.print.DocFlavor 的构造方法
根据给定的 MIME 类型和表示形式类名构造新的 DocFlavor 对象。
DocFlavor.BYTE_ARRAY - javax.print 中的 类
类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.BYTE_ARRAY(String) - 类 javax.print.DocFlavor.BYTE_ARRAY 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "[B"（byte 数组）的新 DocFlavor。
DocFlavor.CHAR_ARRAY - javax.print 中的 类
类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.CHAR_ARRAY(String) - 类 javax.print.DocFlavor.CHAR_ARRAY 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "[C"（字符数组）的新 DocFlavor。
DocFlavor.INPUT_STREAM - javax.print 中的 类
类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.INPUT_STREAM(String) - 类 javax.print.DocFlavor.INPUT_STREAM 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.InputStream"（byte 流）的新 DocFlavor。
DocFlavor.READER - javax.print 中的 类
类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.READER(String) - 类 javax.print.DocFlavor.READER 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.Reader"（字符流）的新 DocFlavor。
DocFlavor.SERVICE_FORMATTED - javax.print 中的 类
类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
DocFlavor.SERVICE_FORMATTED(String) - 类 javax.print.DocFlavor.SERVICE_FORMATTED 的构造方法
构造具有 "application/x-java-jvm-local-objectref" MIME 类型（指示服务格式化打印数据）和给定打印数据表示形式类名的新 DocFlavor。
DocFlavor.STRING - javax.print 中的 类
类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.STRING(String) - 类 javax.print.DocFlavor.STRING 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "java.lang.String" 的新 DocFlavor。
DocFlavor.URL - javax.print 中的 类
类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。
DocFlavor.URL(String) - 类 javax.print.DocFlavor.URL 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "java.net.URL" 的新 DocFlavor。
dockingBorderColor - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
dockingColor - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
dockingListener - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
doClick() - 类 javax.swing.AbstractButton 中的方法
以编程方式执行“单击”。
doClick(int) - 类 javax.swing.AbstractButton 中的方法
以编程方式执行“单击”。
doClick(int) - 类 javax.swing.JMenu 中的方法
以编程方式执行“单击”。
doClick(MenuSelectionManager) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
要激活菜单项时调用此方法。
DocPrintJob - javax.print 中的 接口
此接口表示了一个可使用作业属性集打印指定文档的打印作业。
DOCTYPE_PUBLIC - 类 javax.xml.transform.OutputKeys 中的静态变量
doctype-public = string. 有关关键值应为何值的描述，请参阅 OutputKeys.DOCTYPE_SYSTEM 属性文档。
DOCTYPE_SYSTEM - 类 javax.xml.transform.OutputKeys 中的静态变量
doctype-system = string. doctype-system 指定了要在文档类型声明中使用的系统标识符。
Document - javax.swing.text 中的 接口
Document 是一个作为 swing 文本组件模型的文本容器。
Document - org.w3c.dom 中的 接口
Document 接口表示整个 HTML 或 XML 文档。
DOCUMENT_ACCESS_ERROR - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机不能访问由引用传递的一个或多个文档（即打印数据表示形式对象为 URL）。
DOCUMENT_FORMAT_ERROR - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
系统中止了作业，因为打印机在处理文档数据时遇到错误。
DOCUMENT_FRAGMENT_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 DocumentFragment。
DOCUMENT_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Document。
DOCUMENT_POSITION_CONTAINED_BY - 接口 org.w3c.dom.Node 中的静态变量
引用节点包含该节点。
DOCUMENT_POSITION_CONTAINS - 接口 org.w3c.dom.Node 中的静态变量
该节点包含引用节点。
DOCUMENT_POSITION_DISCONNECTED - 接口 org.w3c.dom.Node 中的静态变量
两个节点断开连接。
DOCUMENT_POSITION_FOLLOWING - 接口 org.w3c.dom.Node 中的静态变量
该节点在引用节点之后。
DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC - 接口 org.w3c.dom.Node 中的静态变量
对前后位置的确定是特定于实现的。
DOCUMENT_POSITION_PRECEDING - 接口 org.w3c.dom.Node 中的静态变量
第二个节点在引用节点之前。
DOCUMENT_TYPE_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 DocumentType。
documentBaseKey - 类 javax.swing.plaf.basic.BasicHTML 中的静态变量
存储为客户端属性以指示用作解析相关引用的基址的键。
DocumentBuilder - javax.xml.parsers 中的 类
定义 API， 使其从 XML 文档获取 DOM 文档实例。
DocumentBuilder() - 类 javax.xml.parsers.DocumentBuilder 的构造方法
受保护的构造方法
DocumentBuilderFactory - javax.xml.parsers 中的 类
定义工厂 API，使应用程序能够从 XML 文档获取生成 DOM 对象树的解析器。
DocumentBuilderFactory() - 类 javax.xml.parsers.DocumentBuilderFactory 的构造方法
用于阻止实例化的受保护构造方法。
Documented - java.lang.annotation 中的 注释类型
指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
DocumentEvent - javax.swing.event 中的 接口
用于文档更改通知的接口。
DocumentEvent - org.w3c.dom.events 中的 接口
DocumentEvent 接口提供一种机制，通过该机制用户可以创建实现支持的 Event 类型。
DocumentEvent.ElementChange - javax.swing.event 中的 接口
描述对特定元素所做的更改。
DocumentEvent.EventType - javax.swing.event 中的 类
文档事件类型的枚举
DocumentFilter - javax.swing.text 中的 类
DocumentFilter，顾名思义，它是 Document 改变方法的一个过滤器。
DocumentFilter() - 类 javax.swing.text.DocumentFilter 的构造方法
DocumentFilter.FilterBypass - javax.swing.text 中的 类
充当避开回调 Document 进行更改的方法。
DocumentFilter.FilterBypass() - 类 javax.swing.text.DocumentFilter.FilterBypass 的构造方法
DocumentFragment - org.w3c.dom 中的 接口
DocumentFragment 是“轻量级”或“最小”Document 对象。
DocumentHandler - org.xml.sax 中的 接口
已过时。 此接口已经被 SAX2 ContentHandler 接口取代，后者包括名称空间支持。
DocumentListener - javax.swing.event 中的 接口
观察者使用该接口注册以接收文本文档的更改通知。
DocumentName - javax.print.attribute.standard 中的 类
DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
DocumentName(String, Locale) - 类 javax.print.attribute.standard.DocumentName 的构造方法
构造具有给定文档名称和语言环境的新文档名称属性。
DocumentParser - javax.swing.text.html.parser 中的 类
HTML 文档的解析器 (Parser)（实际上，您可以指定一个 DTD，但实际上仅应将此类与 swing 中的 html dtd 一起使用）。
DocumentParser(DTD) - 类 javax.swing.text.html.parser.DocumentParser 的构造方法
DocumentType - org.w3c.dom 中的 接口
每个 Document 都有 doctype 属性，该属性的值可以为 null，也可以为 DocumentType 对象。
doDefaultCloseAction() - 类 javax.swing.JInternalFrame 中的方法
激发 INTERNAL_FRAME_CLOSING 事件，然后执行内部窗体的默认 close 操作所指定的操作。
doesMaxRowSizeIncludeBlobs() - 接口 java.sql.DatabaseMetaData 中的方法
获取 getMaxRowSize 方法的返回值是否包括 SQL 数据类型 LONGVARCHAR 和 LONGVARBINARY。
doFinal() - 类 javax.crypto.Cipher 中的方法
结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
doFinal(byte[], int) - 类 javax.crypto.Cipher 中的方法
结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
doFinal(byte[]) - 类 javax.crypto.Cipher 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
doFinal(byte[], int, int) - 类 javax.crypto.Cipher 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
doFinal(byte[], int, int, byte[]) - 类 javax.crypto.Cipher 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
doFinal(byte[], int, int, byte[], int) - 类 javax.crypto.Cipher 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
doFinal(ByteBuffer, ByteBuffer) - 类 javax.crypto.Cipher 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
doFinal() - 类 javax.crypto.Mac 中的方法
完成 MAC 操作。
doFinal(byte[], int) - 类 javax.crypto.Mac 中的方法
完成 MAC 操作。
doFinal(byte[]) - 类 javax.crypto.Mac 中的方法
处理给定的 byte 数组并完成 MAC 操作。
doInBackground() - 类 javax.swing.SwingWorker 中的方法
计算结果；如果无法计算结果，则抛出异常。
doInput - 类 java.net.URLConnection 中的变量
此变量由 setDoInput 方法设置。
doLayout() - 类 java.awt.Component 中的方法
提示布局管理器布局此组件。
doLayout() - 类 java.awt.Container 中的方法
使此容器布置其组件。
doLayout() - 类 java.awt.ScrollPane 中的方法
通过将子组件的大小调整为其首选大小来布置此容器。
doLayout() - 类 javax.swing.JTable 中的方法
使此表布局其行和列。
doLayout() - 类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 中的方法
对此 Container 进行布局。
doLookup(Name) - 类 javax.naming.InitialContext 中的静态方法
获取指定对象的静态方法。
doLookup(String) - 类 javax.naming.InitialContext 中的静态方法
获取指定对象的静态方法。
DOM_OBJECT_MODEL - 类 javax.xml.xpath.XPathConstants 中的静态变量
DOM 对象模型的 URI，"http://java.sun.com/jaxp/xpath/dom"。
DomainCombiner - java.security 中的 接口
DomainCombiner 提供一个动态更新与当前 AccessControlContext 关联的 ProtectionDomain 的方法。
DomainManager - org.omg.CORBA 中的 接口
提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
DomainManagerOperations - org.omg.CORBA 中的 接口
向 DomainManager 提供访问策略的方法。
domainMatches(String, String) - 类 java.net.HttpCookie 中的静态方法
检查主机名是否在域中的实用方法。
DOMConfiguration - org.w3c.dom 中的 接口
该 DOMConfiguration 接口表示文档的配置，并维护一个可识别的参数表。
DOMCryptoContext - javax.xml.crypto.dom 中的 类
此类提供 XMLCryptoContext 接口特定于 DOM 的实现。
DOMCryptoContext() - 类 javax.xml.crypto.dom.DOMCryptoContext 的构造方法
默认的构造方法。
DOMError - org.w3c.dom 中的 接口
DOMError 是一个描述错误的接口。
DOMErrorHandler - org.w3c.dom 中的 接口
DOMErrorHandler 是在报告处理 XML 数据时发生的错误或在进行某些其他处理（如验证文档）时 DOM 实现可以调用的回调接口。
DOMException - org.w3c.dom 中的 异常
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。
DOMException(short, String) - 异常 org.w3c.dom.DOMException 的构造方法
DomHandler<ElementT,ResultT extends Result> - javax.xml.bind.annotation 中的 接口
在元素（及其子代）与 DOM（或类似对象）表示形式之间相互转换。
DOMImplementation - org.w3c.dom 中的 接口
DOMImplementation 接口为执行独立于文档对象模型的任何特定实例的操作提供了许多方法。
DOMImplementationList - org.w3c.dom 中的 接口
DOMImplementationList 接口提供对 DOM 实现的有序集合的抽象，没有定义或约束如何实现此集合。
DOMImplementationLS - org.w3c.dom.ls 中的 接口
DOMImplementationLS 包括创建 Load 和 Save 对象的工厂方法。
DOMImplementationRegistry - org.w3c.dom.bootstrap 中的 类
启用应用程序来获得 DOMImplementation 实例的工厂。
DOMImplementationSource - org.w3c.dom 中的 接口
此接口允许 DOM 实现程序根据请求的功能和版本提供一个或多个实现，如下所述。
DOMLocator - javax.xml.transform.dom 中的 接口
指示源 DOM 中节点的位置，主要用于错误报告。
DOMLocator - org.w3c.dom 中的 接口
DOMLocator 是一个描述位置（如发生错误的位置）的接口。
DOMResult - javax.xml.transform.dom 中的 类
以 Document Object Model（DOM）树的形式充当转换结果树的持有者。
DOMResult() - 类 javax.xml.transform.dom.DOMResult 的构造方法
零参数的默认构造方法。
DOMResult(Node) - 类 javax.xml.transform.dom.DOMResult 的构造方法
使用 DOM 节点创建新输出目标。
DOMResult(Node, String) - 类 javax.xml.transform.dom.DOMResult 的构造方法
使用 DOM 节点创建带有指定 System ID 的新输出目标。
DOMResult(Node, Node) - 类 javax.xml.transform.dom.DOMResult 的构造方法
使用 DOM 节点创建新输出目标，此目标指定了应该插入的结果节点之后的子节点。
DOMResult(Node, Node, String) - 类 javax.xml.transform.dom.DOMResult 的构造方法
使用 DOM 节点创建新输出目标，此目标指定了子节点，其中结果节点为指定 System ID 且应该插入到该子节点之前。
DOMSignContext - javax.xml.crypto.dsig.dom 中的 类
特定于 DOM 的 XMLSignContext。
DOMSignContext(Key, Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 的构造方法
创建带有指定签名密钥和父节点的 DOMSignContext。
DOMSignContext(Key, Node, Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 的构造方法
创建带有指定的签名密钥、父节点和下一个兄弟节点的 DOMSignContext。
DOMSignContext(KeySelector, Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 的构造方法
创建带有指定密钥选择器和父节点的 DOMSignContext。
DOMSignContext(KeySelector, Node, Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 的构造方法
创建带有指定密钥选择器、父节点和下一个兄弟节点的 DOMSignContext。
DOMSource - javax.xml.transform.dom 中的 类
以 Document Object Model（DOM）树的形式充当转换 Source 树的持有者。
DOMSource() - 类 javax.xml.transform.dom.DOMSource 的构造方法
零参数的默认构造方法。
DOMSource(Node) - 类 javax.xml.transform.dom.DOMSource 的构造方法
创建带有 DOM 节点的新输入源。
DOMSource(Node, String) - 类 javax.xml.transform.dom.DOMSource 的构造方法
创建带有 DOM 节点的新输入源，系统 ID 也作为基本 URI 被传入。
DOMSTRING_SIZE_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果文本的指定范围不适合 DOMString。
DOMStringList - org.w3c.dom 中的 接口
DOMStringList 接口提供对 DOMString 值的有序集合的抽象，没有定义或约束此集合是如何实现的。
DOMStructure - javax.xml.crypto.dom 中的 类
特定于 DOM 的 XMLStructure。
DOMStructure(Node) - 类 javax.xml.crypto.dom.DOMStructure 的构造方法
创建包含指定节点的 DOMStructure。
DOMURIReference - javax.xml.crypto.dom 中的 接口
特定于 DOM 的 URIReference。
DOMValidateContext - javax.xml.crypto.dsig.dom 中的 类
特定于 DOM 的 XMLValidateContext。
DOMValidateContext(KeySelector, Node) - 类 javax.xml.crypto.dsig.dom.DOMValidateContext 的构造方法
创建包含指定密钥选择器和节点的 DOMValidateContext。
DOMValidateContext(Key, Node) - 类 javax.xml.crypto.dsig.dom.DOMValidateContext 的构造方法
创建包含指定密钥和节点的 DOMValidateContext。
done() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
done(RemoteCall) - 接口 java.rmi.server.RemoteRef 中的方法
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
DONE - 类 java.text.BreakIterator 中的静态变量
在已经到达第一个或最后一个文本边界时，previous()、next()、next(int)、preceding(int) 和 following(int) 将返回 DONE。
DONE - 接口 java.text.CharacterIterator 中的静态变量
当迭代器已到达文本末尾或开始处时返回的常量。
done() - 类 java.util.concurrent.FutureTask 中的方法
当此任务转换到状态 isDone（不管是正常地还是通过取消）时，调用受保护的方法。
done() - 类 javax.swing.SwingWorker 中的方法
doInBackground 方法完成后，在事件指派线程 上执行此方法。
dontUseGui() - 类 java.beans.beancontext.BeanContextSupport 中的方法
通知此实例它可以不再呈现一个 GUI。
dontUseGui() - 接口 java.beans.Visibility 中的方法
此方法指示不应该使用 Gui 的 bean。
DOOR_OPEN - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备上的一个或多个门处于打开状态。
doOutput - 类 java.net.URLConnection 中的变量
此变量由 setDoOutput 方法设置。
doPhase(Key, boolean) - 类 javax.crypto.KeyAgreement 中的方法
用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
doPrivileged(PrivilegedAction<T>) - 类 java.security.AccessController 中的静态方法
启用特权，执行指定的 PrivilegedAction。
doPrivileged(PrivilegedAction<T>, AccessControlContext) - 类 java.security.AccessController 中的静态方法
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedAction。
doPrivileged(PrivilegedExceptionAction<T>) - 类 java.security.AccessController 中的静态方法
启用特权，执行指定的 PrivilegedExceptionAction。
doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext) - 类 java.security.AccessController 中的静态方法
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedExceptionAction。
doPrivilegedWithCombiner(PrivilegedAction<T>) - 类 java.security.AccessController 中的静态方法
启用特权，执行指定的 PrivilegedAction。
doPrivilegedWithCombiner(PrivilegedExceptionAction<T>) - 类 java.security.AccessController 中的静态方法
启用特权，执行指定的 PrivilegedExceptionAction。
DOTALL - 类 java.util.regex.Pattern 中的静态变量
启用 dotall 模式。
Double - java.lang 中的 类
Double 类在对象中包装一个基本类型 double 的值。
Double(double) - 类 java.lang.Double 的构造方法
构造一个新分配的 Double 对象，它表示基本的 double 参数。
Double(String) - 类 java.lang.Double 的构造方法
构造一个新分配的 Double 对象，表示用字符串表示的 double 类型的浮点值。
DOUBLE - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 DOUBLE 的 Java 编程语言中的常量（有时称为类型代码）。
DOUBLE - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Double 的值。
DoubleBuffer - java.nio 中的 类
double 缓冲区。
DoubleHolder - org.omg.CORBA 中的 类
Double 的 Holder。
DoubleHolder() - 类 org.omg.CORBA.DoubleHolder 的构造方法
构造一个新的 DoubleHolder 对象，将其 value 字段初始化为 0.0。
DoubleHolder(double) - 类 org.omg.CORBA.DoubleHolder 的构造方法
为给定 double 值构造一个新的 DoubleHolder 对象。
DoubleSeqHelper - org.omg.CORBA 中的 类
DoubleSeq 的 Helper。
DoubleSeqHelper() - 类 org.omg.CORBA.DoubleSeqHelper 的构造方法
DoubleSeqHolder - org.omg.CORBA 中的 类
DoubleSeq 的 Holder。
DoubleSeqHolder() - 类 org.omg.CORBA.DoubleSeqHolder 的构造方法
DoubleSeqHolder(double[]) - 类 org.omg.CORBA.DoubleSeqHolder 的构造方法
doubleToLongBits(double) - 类 java.lang.Double 中的静态方法
根据 IEEE 754 浮点双精度格式 ("double format") 位布局，返回指定浮点值的表示形式。
doubleToRawLongBits(double) - 类 java.lang.Double 中的静态方法
根据 IEEE 754 浮点“双精度格式”位布局，返回指定浮点值的表示形式，并保留 NaN 值。
doubleValue() - 类 java.lang.Byte 中的方法
作为一个 double 返回此 Byte 的值。
doubleValue() - 类 java.lang.Double 中的方法
返回此 Double 对象的 double 值。
doubleValue() - 类 java.lang.Float 中的方法
返回此 Float 对象的 double 值。
doubleValue() - 类 java.lang.Integer 中的方法
以 double 类型返回该 Integer 的值。
doubleValue() - 类 java.lang.Long 中的方法
以 double 形式返回此 Long 的值。
doubleValue() - 类 java.lang.Number 中的方法
以 double 形式返回指定的数值。
doubleValue() - 类 java.lang.Short 中的方法
以 double 形式返回此 Short 的值。
doubleValue() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 double。
doubleValue() - 类 java.math.BigInteger 中的方法
将此 BigInteger 转换为 double。
doubleValue() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
doubleValue() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
DOWN - 类 java.awt.Event 中的静态变量
Down Arrow 键，一个非 ASCII 操作键。
DOWN_CYCLE_TRAVERSAL_KEYS - 类 java.awt.KeyboardFocusManager 中的静态变量
Down Cycle 焦点遍历键的标识符。
downAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符在逻辑上向下移动一个位置的动作名称。
downFocusCycle(Container) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
将焦点下移一个焦点遍历循环。
downFocusCycle(Container) - 类 java.awt.KeyboardFocusManager 中的方法
将焦点下移一个焦点遍历循环。
downFocusCycle() - 类 java.awt.KeyboardFocusManager 中的方法
当且仅当当前焦点所有者是一个作为焦点循环根的 Container 时，从当前焦点所有者将焦点下移一个焦点遍历循环。
downKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
downKey - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
downKey - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
已过时。 从 Java 2 平台 v1.3 开始。
DPCM - 类 javax.print.attribute.ResolutionSyntax 中的静态变量
指示每厘米点数为单位 (dpcm) 的值。
DPI - 类 javax.print.attribute.ResolutionSyntax 中的静态变量
指示每英寸点数为单位 (dpi) 的值。
DRAFT - 类 java.awt.PageAttributes.PrintQualityType 中的静态变量
用于指定草稿打印质量的 PrintQualityType 实例。
DRAFT - 类 javax.print.attribute.standard.PrintQuality 中的静态变量
打印机可提供的最低打印质量。
DRAG_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Drag 层的便捷对象。
dragDividerTo(int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
利用包含此实例的 dragDividerTo 传递 BasicSplitPaneUI 的消息。
dragDividerTo(int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
拖动会话期间传递消息以便将分隔符移动到传入位置。
dragDropEnd(DragSourceDropEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
调用此方法来通知 Drag 和 Drop 操作已完成。
dragDropEnd(DragSourceDropEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragDropEnd，并将指定的 DragSourceDropEvent 传递给它们。
dragDropEnd(DragSourceDropEvent) - 接口 java.awt.dnd.DragSourceListener 中的方法
调用此方法来通知 Drag 和 Drop 操作已完成。
dragEnter(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
光标的热点进入放置点（与平台相关）时调用该方法。
dragEnter(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragEnter，并将指定的 DragSourceDragEvent 传递给它们。
dragEnter(DragSourceDragEvent) - 接口 java.awt.dnd.DragSourceListener 中的方法
光标的热点进入放置点（与平台相关）时调用该方法。
dragEnter(DropTargetDragEvent) - 类 java.awt.dnd.DropTarget 中的方法
在已注册的 DropTargetListener 上调用 dragEnter，并将其传递给指定的 DropTargetDragEvent。
dragEnter(DropTargetDragEvent) - 类 java.awt.dnd.DropTargetAdapter 中的方法
当鼠标指针进入向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行的同时调用该方法。
dragEnter(DropTargetDragEvent) - 接口 java.awt.dnd.DropTargetListener 中的方法
正在进行 drag 操作时调用，此时鼠标指针进入 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
dragExit(DragSourceEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
光标的热点离开放置点（与平台相关）时调用该方法。
dragExit(DragSourceEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragExit，并将指定的 DragSourceEvent 传递给它们。
dragExit(DragSourceEvent) - 接口 java.awt.dnd.DragSourceListener 中的方法
光标的热点离开放置点（与平台相关）时调用该方法。
dragExit(DropTargetEvent) - 类 java.awt.dnd.DropTarget 中的方法
在已注册的 DropTargetListener 上调用 dragExit，并将其传递给指定的 DropTargetEvent。
dragExit(DropTargetEvent) - 类 java.awt.dnd.DropTargetAdapter 中的方法
当鼠标指针已经离开向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行时调用该方法。
dragExit(DropTargetEvent) - 接口 java.awt.dnd.DropTargetListener 中的方法
正在进行 drag 操作时调用，此时鼠标指针已退出 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
dragFrame(JComponent, int, int) - 类 javax.swing.DefaultDesktopManager 中的方法
将正被拖动窗体的可见位置移动到指定位置。
dragFrame(JComponent, int, int) - 接口 javax.swing.DesktopManager 中的方法
用户已经移动窗体。
draggedColumn - 类 javax.swing.table.JTableHeader 中的变量
被拖动列的索引。
draggedDistance - 类 javax.swing.table.JTableHeader 中的变量
列被拖离其初始位置的距离。
dragger - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
处理要进行实际拖动操作的鼠标拖动消息。
DragGestureEvent - java.awt.dnd 中的 类
当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。
DragGestureEvent(DragGestureRecognizer, int, Point, List<? extends InputEvent>) - 类 java.awt.dnd.DragGestureEvent 的构造方法
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。
DragGestureListener - java.awt.dnd 中的 接口
此接口源于 DragGestureRecognizer，当该（子）类的对象检测到拖动启动动作时，调用此接口。
dragGestureListener - 类 java.awt.dnd.DragGestureRecognizer 中的变量
与此 DragGestureRecognizer 关联的 DragGestureListener。
dragGestureRecognized(DragGestureEvent) - 接口 java.awt.dnd.DragGestureListener 中的方法
DragGestureRecognizer 已经检测到与平台有关的拖动启动动作，并且正通知此侦听器，以便启动用户操作。
DragGestureRecognizer - java.awt.dnd 中的 类
DragGestureRecognizer 是一个针对与平台相关的侦听器规范的抽象基类，它可以与特定 Component 关联以标识与平台相关的拖动开始动作。
DragGestureRecognizer(DragSource, Component, int, DragGestureListener) - 类 java.awt.dnd.DragGestureRecognizer 的构造方法
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component、此 Drag 和 Drop 操作所支持的操作和一旦检测到拖动开始动作要通知的 DragGestureListener。
DragGestureRecognizer(DragSource, Component, int) - 类 java.awt.dnd.DragGestureRecognizer 的构造方法
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component 和此 Drag 和 Drop 操作所支持的动作。
DragGestureRecognizer(DragSource, Component) - 类 java.awt.dnd.DragGestureRecognizer 的构造方法
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource 和此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component。
DragGestureRecognizer(DragSource) - 类 java.awt.dnd.DragGestureRecognizer 的构造方法
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource。
draggingHW - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
如果任何一个子级（不包括 nonContinuousLayoutDivider）是重量级的，则在 startDragging 中设置 true。
dragMouseMoved(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
在拖动操作期间，只要移动了鼠标就调用该方法。
dragMouseMoved(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向与此 DragSourceContext 关联的 DragSource 注册的 DragSourceMotionListener 调用 dragMouseMoved，并将指定的 DragSourceDragEvent 传递给它们。
dragMouseMoved(DragSourceDragEvent) - 接口 java.awt.dnd.DragSourceMotionListener 中的方法
只要在拖动操作期间鼠标移动了，就调用该方法。
dragOver(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
光标的热点在放置点（与平台相关）上移动时调用该方法。
dragOver(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceContext 调用 dragOver，并将指定的 DragSourceDragEvent 传递给它们。
dragOver(DragSourceDragEvent) - 接口 java.awt.dnd.DragSourceListener 中的方法
光标的热点在放置点（与平台相关）上移动时调用该方法。
dragOver(DropTargetDragEvent) - 类 java.awt.dnd.DropTarget 中的方法
在已注册的 DropTargetListener 上调用 dragOver，并将其传递给指定的 DropTargetDragEvent。
dragOver(DropTargetDragEvent) - 类 java.awt.dnd.DropTargetAdapter 中的方法
当鼠标指针仍旧处于向此侦听器注册的 DropTarget 放置点可操作部分上时，则在拖动操作正在进行时调用该方法。
dragOver(DropTargetDragEvent) - 接口 java.awt.dnd.DropTargetListener 中的方法
正在进行 drag 操作时调用，此时鼠标指针仍然处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
dragSource - 类 java.awt.dnd.DragGestureRecognizer 中的变量
与此 DragGestureRecognizer 关联的 DragSource。
DragSource - java.awt.dnd 中的 类
DragSource 是负责开始 Drag 和 Drop 操作的实体，可以用在如下场景中： JVM 生命周期中每个 JVM 的一个默认实例。
DragSource() - 类 java.awt.dnd.DragSource 的构造方法
创建一个新的 DragSource。
DragSourceAdapter - java.awt.dnd 中的 类
用于接收拖动源事件的抽象适配器类。
DragSourceAdapter() - 类 java.awt.dnd.DragSourceAdapter 的构造方法
DragSourceContext - java.awt.dnd 中的 类
DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。
DragSourceContext(DragSourceContextPeer, DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - 类 java.awt.dnd.DragSourceContext 的构造方法
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。
DragSourceDragEvent - java.awt.dnd 中的 类
通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。
DragSourceDragEvent(DragSourceContext, int, int, int) - 类 java.awt.dnd.DragSourceDragEvent 的构造方法
构造一个 DragSourceDragEvent。
DragSourceDragEvent(DragSourceContext, int, int, int, int, int) - 类 java.awt.dnd.DragSourceDragEvent 的构造方法
构造一个具有指定 DragSourceContext、用户放置动作、目标放置动作、修改键和坐标的 DragSourceDragEvent。
DragSourceDropEvent - java.awt.dnd 中的 类
通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。
DragSourceDropEvent(DragSourceContext, int, boolean) - 类 java.awt.dnd.DragSourceDropEvent 的构造方法
放置构造一个具有给定 DragSourceContext、放置操作和指示放置是否成功的 boolean 值的 DragSourceDropEvent。
DragSourceDropEvent(DragSourceContext, int, boolean, int, int) - 类 java.awt.dnd.DragSourceDropEvent 的构造方法
针对放置构造一个具有给定 DragSourceContext、放置操作、表示放置是否成功的 boolean 值和坐标的 DragSourceDropEvent。
DragSourceDropEvent(DragSourceContext) - 类 java.awt.dnd.DragSourceDropEvent 的构造方法
针对没有引起放置的拖动构造一个 DragSourceDropEvent。
DragSourceEvent - java.awt.dnd 中的 类
此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。
DragSourceEvent(DragSourceContext) - 类 java.awt.dnd.DragSourceEvent 的构造方法
根据一个指定的 DragSourceContext 来构造一个 DragSourceEvent。
DragSourceEvent(DragSourceContext, int, int) - 类 java.awt.dnd.DragSourceEvent 的构造方法
根据指定的 DragSourceContext 和光标位置坐标构造一个 DragSourceEvent。
DragSourceListener - java.awt.dnd 中的 接口
DragSourceListener 定义了事件接口，Drag 和 Drop 操作的始发端使用它来跟踪用户操作的状态，并通过 Drag 和 Drop 操作为用户提供合适的“拖动结束”反馈。
DragSourceMotionListener - java.awt.dnd 中的 接口
用于接收拖动操作期间鼠标移动事件的侦听器接口。
dragTo(Point, Point) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
dragWindow - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
drain() - 类 java.io.ObjectOutputStream 中的方法
排空 ObjectOutputStream 中的所有已缓冲数据。
drain() - 接口 javax.sound.sampled.DataLine 中的方法
通过在清空数据行的内部缓冲区之前继续数据 I/O，排空数据行中的列队数据。
drainPermits() - 类 java.util.concurrent.Semaphore 中的方法
获取并返回立即可用的所有许可。
drainTo(Collection<? super E>) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
drainTo(Collection<? super E>) - 接口 java.util.concurrent.BlockingQueue 中的方法
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
drainTo(Collection<? super E>, int) - 接口 java.util.concurrent.BlockingQueue 中的方法
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
drainTo(Collection<? super E>) - 类 java.util.concurrent.DelayQueue 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.DelayQueue 中的方法
drainTo(Collection<? super E>) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
drainTo(Collection<? super E>) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
drainTo(Collection<? super E>) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
drainTo(Collection<? super E>) - 类 java.util.concurrent.SynchronousQueue 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.SynchronousQueue 中的方法
draw(Graphics2D, float, float) - 类 java.awt.font.GraphicAttribute 中的方法
在指定的位置呈现此 GraphicAttribute。
draw(Graphics2D, float, float) - 类 java.awt.font.ImageGraphicAttribute 中的方法
在指定的位置呈现此 GraphicAttribute。
draw(Graphics2D, float, float) - 类 java.awt.font.ShapeGraphicAttribute 中的方法
在指定的位置呈现此 GraphicAttribute。
draw(Graphics2D, float, float) - 类 java.awt.font.TextLayout 中的方法
在指定的 Graphics2D 上下文中的指定位置上呈现此 TextLayout。
draw(Shape) - 类 java.awt.Graphics2D 中的方法
使用当前 Graphics2D 上下文的设置勾画 Shape 的轮廓。
draw3DRect(int, int, int, int, boolean) - 类 java.awt.Graphics 中的方法
绘制指定矩形的 3-D 高亮显示边框。
draw3DRect(int, int, int, int, boolean) - 类 java.awt.Graphics2D 中的方法
绘制指定矩形的 3-D 高亮显示边框。
draw3DRect(int, int, int, int, boolean) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.draw3DRect。
drawArc(int, int, int, int, int, int) - 类 java.awt.Graphics 中的方法
绘制一个覆盖指定矩形的圆弧或椭圆弧边框。
drawArc(int, int, int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawArc。
drawBezel(Graphics, int, int, int, int, boolean, boolean, Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
drawBuffer - 类 java.awt.Component.FlipBufferStrategy 中的变量
绘制缓冲区。
drawBytes(byte[], int, int, int, int) - 类 java.awt.Graphics 中的方法
使用此图形上下文的当前字体和颜色绘制由指定 byte 数组给定的文本。
drawBytes(byte[], int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawBytes。
drawCentered(Component, Graphics, Icon, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
drawChars(char[], int, int, int, int) - 类 java.awt.Graphics 中的方法
使用此图形上下文的当前字体和颜色绘制由指定字符数组给定的文本。
drawChars(char[], int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawChars。
drawCheck(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 中的方法
drawDashedHorizontalLine(Graphics, int, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
drawDashedRect(Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
drawDashedVerticalLine(Graphics, int, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
drawEchoCharacter(Graphics, int, int, char) - 类 javax.swing.text.PasswordView 中的方法
呈现回显字符，或呈现用来显示密码字符的图形。
drawEtchedRect(Graphics, int, int, int, int, Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
drawGlyphVector(GlyphVector, float, float) - 类 java.awt.Graphics2D 中的方法
使用 Graphics2D 上下文的呈现属性，呈现指定 GlyphVector 的文本。
drawGroove(Graphics, int, int, int, int, Color, Color) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
drawImage(Image, int, int, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制指定图像中当前可用的图像。
drawImage(Image, int, int, int, int, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制指定图像中已缩放到适合指定矩形内部的图像。
drawImage(Image, int, int, Color, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制指定图像中当前可用的图像。
drawImage(Image, int, int, int, int, Color, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制指定图像中已缩放到适合指定矩形内部的图像。
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
drawImage(Image, AffineTransform, ImageObserver) - 类 java.awt.Graphics2D 中的方法
呈现一个图像，在绘制前进行从图像空间到用户空间的转换。
drawImage(BufferedImage, BufferedImageOp, int, int) - 类 java.awt.Graphics2D 中的方法
呈现使用 BufferedImageOp 过滤的 BufferedImage。
drawImage(Image, int, int, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawImage(Image, int, int, int, int, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawImage(Image, int, int, Color, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawImage(Image, int, int, int, int, Color, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawingCache - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
用于最小化垂直线的绘制。
drawInverted() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
drawLine(int, int, int, int) - 类 java.awt.Graphics 中的方法
在此图形上下文的坐标系中，使用当前颜色在点 (x1, y1) 和 (x2, y2) 之间画一条线。
drawLine(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawLine。
drawLine(SynthContext, Object, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
在两个端点之间绘制一条线。
drawLine(SynthContext, Object, Graphics, int, int, int, int, Object) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
在两个端点之间绘制一条线。
drawLine(int, Graphics, int, int) - 类 javax.swing.text.PlainView 中的方法
呈现文本的某一行，取消末尾的空白并扩展所有的制表符。
drawLine(int, int, Graphics, int, int) - 类 javax.swing.text.WrappedPlainView 中的方法
取消结尾空格并扩展所有制表符，从而呈现一行文本。
drawLoweredBezel(Graphics, int, int, int, int, Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
drawOval(int, int, int, int) - 类 java.awt.Graphics 中的方法
绘制椭圆的边框。
drawOval(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawOval。
drawPolygon(int[], int[], int) - 类 java.awt.Graphics 中的方法
绘制一个由 x 和 y 坐标数组定义的闭合多边形。
drawPolygon(Polygon) - 类 java.awt.Graphics 中的方法
绘制由指定的 Polygon 对象定义的多边形边框。
drawPolygon(int[], int[], int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawPolygon。
drawPolyline(int[], int[], int) - 类 java.awt.Graphics 中的方法
绘制由 x 和 y 坐标数组定义的一系列连接线。
drawPolyline(int[], int[], int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawPolyline。
drawRect(int, int, int, int) - 类 java.awt.Graphics 中的方法
绘制指定矩形的边框。
drawRect(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawRect。
drawRenderableImage(RenderableImage, AffineTransform) - 类 java.awt.Graphics2D 中的方法
呈现 RenderableImage，在绘制前进行从图像空间到用户空间的转换。
drawRenderedImage(RenderedImage, AffineTransform) - 类 java.awt.Graphics2D 中的方法
呈现 RenderedImage，在绘制前进行从图像空间到用户空间的转换。
drawRoundRect(int, int, int, int, int, int) - 类 java.awt.Graphics 中的方法
用此图形上下文的当前颜色绘制圆角矩形的边框。
drawRoundRect(int, int, int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawRoundRect。
drawSelectedText(Graphics, int, int, int, int) - 类 javax.swing.text.PasswordView 中的方法
将模型中给定的范围呈现为选定文本。
drawSelectedText(Graphics, int, int, int, int) - 类 javax.swing.text.PlainView 中的方法
将模型中给定的范围呈现为选定文本。
drawSelectedText(Graphics, int, int, int, int) - 类 javax.swing.text.WrappedPlainView 中的方法
将模型中给定的范围呈现为所选文本。
drawString(String, int, int) - 类 java.awt.Graphics 中的方法
使用此图形上下文的当前字体和颜色绘制由指定 string 给定的文本。
drawString(AttributedCharacterIterator, int, int) - 类 java.awt.Graphics 中的方法
依据 TextAttribute 类的规范应用指定迭代器的属性，呈现迭代器的文本。
drawString(String, int, int) - 类 java.awt.Graphics2D 中的方法
使用 Graphics2D 上下文中的当前文本属性状态呈现指定的 String 的文本。
drawString(String, float, float) - 类 java.awt.Graphics2D 中的方法
使用 Graphics2D 上下文中当前文本属性状态呈现由指定 String 指定的文本。
drawString(AttributedCharacterIterator, int, int) - 类 java.awt.Graphics2D 中的方法
依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。
drawString(AttributedCharacterIterator, float, float) - 类 java.awt.Graphics2D 中的方法
依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。
drawString(String, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawString。
drawString(AttributedCharacterIterator, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawString。
drawString(Graphics, String, int, int, int) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
像 g.drawString 那样利用图形 g 在位置 (x,y) 绘制字符串。
drawStringUnderlineCharAt(Graphics, String, int, int, int) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
像 g.drawString 那样利用图形 g 在位置 (x, y) 绘制字符串。
drawTabbedText(Segment, int, int, Graphics, TabExpander, int) - 类 javax.swing.text.Utilities 中的静态方法
使用给定的制表符扩展方式来扩展给定文本所包含的任何制表符，从而绘制给定的文本。
drawUnselectedText(Graphics, int, int, int, int) - 类 javax.swing.text.PasswordView 中的方法
将模型中给定的范围呈现为正常的未选定文本。
drawUnselectedText(Graphics, int, int, int, int) - 类 javax.swing.text.PlainView 中的方法
将模型中给定的范围呈现为正常的未选定文本。
drawUnselectedText(Graphics, int, int, int, int) - 类 javax.swing.text.WrappedPlainView 中的方法
将模型中的给定范围呈现为普通未选择的文本。
drawVBuffer - 类 java.awt.Component.FlipBufferStrategy 中的变量
作为可变图像的绘制缓冲区。
Driver - java.sql 中的 接口
每个驱动程序类必须实现的接口。
DriverManager - java.sql 中的 类
管理一组 JDBC 驱动程序的基本服务。
DriverPropertyInfo - java.sql 中的 类
用于建立连接的驱动程序属性。
DriverPropertyInfo(String, String) - 类 java.sql.DriverPropertyInfo 的构造方法
构造一个带有给定名称和值的 DriverPropertyInfo 对象。
drop(DropTargetDropEvent) - 类 java.awt.dnd.DropTarget 中的方法
如果此 DropTarget 处于激活状态，则在已注册的 DropTargetListener 上调用 drop，并将其传递给指定的 DropTargetDropEvent。
drop(DropTargetDropEvent) - 接口 java.awt.dnd.DropTargetListener 中的方法
在 drag 操作已终止时调用，此时 drop 处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
dropActionChanged(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
当用户修改放置操作时调用该方法。
dropActionChanged(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dropActionChanged，并将指定的 DragSourceDragEvent 传递给它们。
dropActionChanged(DragSourceDragEvent) - 接口 java.awt.dnd.DragSourceListener 中的方法
当用户修改放置操作时调用该方法。
dropActionChanged(DropTargetDragEvent) - 类 java.awt.dnd.DropTarget 中的方法
在已注册的 DropTargetListener 上调用 dropActionChanged，并将其传递给指定的 DropTargetDragEvent。
dropActionChanged(DropTargetDragEvent) - 类 java.awt.dnd.DropTargetAdapter 中的方法
如果用户已经修改了当前的放置操作，则调用该方法。
dropActionChanged(DropTargetDragEvent) - 接口 java.awt.dnd.DropTargetListener 中的方法
在用户已经修改了当前 drop 操作后调用。
dropComplete(boolean) - 类 java.awt.dnd.DropTargetContext 中的方法
此方法指示放置操作完成以及成功与否。
dropComplete(boolean) - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法通知 DragSource drop 传输已完成。
DropMode - javax.swing 中的 枚举
放置模式，用于确定组件在拖放过程中跟踪和指示放置位置 (drop location) 的方法。
DropTarget - java.awt.dnd 中的 类
在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
DropTarget(Component, int, DropTargetListener, boolean, FlavorMap) - 类 java.awt.dnd.DropTarget 的构造方法
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。
DropTarget(Component, int, DropTargetListener, boolean) - 类 java.awt.dnd.DropTarget 的构造方法
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener 和表示 DropTarget 当前是否接受 drop 的 boolean 值的情况下，创建一个 DropTarget。
DropTarget() - 类 java.awt.dnd.DropTarget 的构造方法
创建一个 DropTarget
DropTarget(Component, DropTargetListener) - 类 java.awt.dnd.DropTarget 的构造方法
在给出与之关联的 Component 和执行事件处理的 DropTargetListener 的情况下创建一个 DropTarget。
DropTarget(Component, int, DropTargetListener) - 类 java.awt.dnd.DropTarget 的构造方法
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值和执行事件处理的 DropTargetListener 的情况下，创建一个 DropTarget。
DropTarget.DropTargetAutoScroller - java.awt.dnd 中的 类
此受保护的嵌套类实现自动滚动
DropTarget.DropTargetAutoScroller(Component, Point) - 类 java.awt.dnd.DropTarget.DropTargetAutoScroller 的构造方法
构造一个 DropTargetAutoScroller
DropTargetAdapter - java.awt.dnd 中的 类
接收放置目标事件的抽象适配器类。
DropTargetAdapter() - 类 java.awt.dnd.DropTargetAdapter 的构造方法
DropTargetContext - java.awt.dnd 中的 类
每当与 Drag 和 Drop 操作相关的逻辑光标和与 DropTarget 相关的 Component 的可见几何结构重合时，就创建一个 DropTargetContext。
DropTargetContext.TransferableProxy - java.awt.dnd 中的 类
TransferableProxy 是一个帮助器内部类，它实现 Transferable 接口，并用作另一个表示特定 drag-n-drop（拖放）操作数据转换的 Transferable 对象的代理。
DropTargetDragEvent - java.awt.dnd 中的 类
通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。
DropTargetDragEvent(DropTargetContext, Point, int, int) - 类 java.awt.dnd.DropTargetDragEvent 的构造方法
在给出此操作的 DropTargetContext、Component 坐标中 "Drag" Cursor 热点的位置、用户 drop 操作和源 drop 操作的情况下，构造一个 DropTargetDragEvent。
DropTargetDropEvent - java.awt.dnd 中的 类
通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。
DropTargetDropEvent(DropTargetContext, Point, int, int) - 类 java.awt.dnd.DropTargetDropEvent 的构造方法
在给出此操作的 DropTargetContext、Component 坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作和当前受源对象支持的操作集合的情况下，构造一个 DropTargetDropEvent。
DropTargetDropEvent(DropTargetContext, Point, int, int, boolean) - 类 java.awt.dnd.DropTargetDropEvent 的构造方法
在给出此操作的 DropTargetContext、Component 的坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作、当前受源对象支持的操作集合，以及一个指示源对象与目标对象是否在同一 JVM 中的 boolean 值的情况下，构造一个 DropTargetEvent。
DropTargetEvent - java.awt.dnd 中的 类
DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。
DropTargetEvent(DropTargetContext) - 类 java.awt.dnd.DropTargetEvent 的构造方法
构造一个具有指定 DropTargetContext 的 DropTargetEvent。
DropTargetListener - java.awt.dnd 中的 接口
DropTargetListener 接口是 DropTarget 类所使用的回调接口，用于提供所涉及的 DropTarget 的 DnD 操作的通知。
DSA_SHA1 - 接口 javax.xml.crypto.dsig.SignatureMethod 中的静态变量
DSAwithSHA1 (DSS) 签名方法的算法 URI。
DSA_TYPE - 接口 javax.xml.crypto.dsig.keyinfo.KeyValue 中的静态变量
标识 DSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#DSAKeyValue。
DSAKey - java.security.interfaces 中的 接口
DSA 公用或专用密钥的接口。
DSAKeyPairGenerator - java.security.interfaces 中的 接口
能够生成 DSA 密钥对的对象的接口。
DSAParameterSpec - java.security.spec 中的 类
此类指定用于 DSA 算法的参数的集合。
DSAParameterSpec(BigInteger, BigInteger, BigInteger) - 类 java.security.spec.DSAParameterSpec 的构造方法
创建一个具有指定参数值的新的 DSAParameterSpec。
DSAParams - java.security.interfaces 中的 接口
特定于 DSA 的密钥参数集的接口，它定义 DSA 密钥系列。
DSAPrivateKey - java.security.interfaces 中的 接口
DSA 专用密钥的标准接口。
DSAPrivateKeySpec - java.security.spec 中的 类
此类指定带关联参数的 DSA 专用密钥。
DSAPrivateKeySpec(BigInteger, BigInteger, BigInteger, BigInteger) - 类 java.security.spec.DSAPrivateKeySpec 的构造方法
创建一个具有指定参数值的新 DSAPrivateKeySpec。
DSAPublicKey - java.security.interfaces 中的 接口
DSA 公用密钥的接口。
DSAPublicKeySpec - java.security.spec 中的 类
此类指定带关联参数的 DSA 公用密钥。
DSAPublicKeySpec(BigInteger, BigInteger, BigInteger, BigInteger) - 类 java.security.spec.DSAPublicKeySpec 的构造方法
创建一个具有指定参数值的新 DSAPublicKeySpec。
DST - 类 java.awt.AlphaComposite 中的静态变量
目标色不变（Porter-Duff Destination 规则）。
Dst - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 DST 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
DST_ATOP - 类 java.awt.AlphaComposite 中的静态变量
在源色之上合成源色中的目标色部分，并将替换目标色（Porter-Duff Destination Atop Source 规则）。
DST_IN - 类 java.awt.AlphaComposite 中的静态变量
源色中的目标色部分将替换目标色（Porter-Duff Destination In Source 规则）。
DST_OFFSET - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，以毫秒为单位指示夏令时的偏移量。
DST_OUT - 类 java.awt.AlphaComposite 中的静态变量
源色以外的目标色部分将替换目标色（Porter-Duff Destination Held Out By Source 规则）。
DST_OVER - 类 java.awt.AlphaComposite 中的静态变量
在源色之上合成目标色，产生的结果将替代目标色（Porter-Duff Destination Over Source 规则）。
DstAtop - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 DST_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
DstIn - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 DST_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
DstOut - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 DST_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
DstOver - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 DST_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
DT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
DTD - javax.swing.text.html.parser 中的 类
SGML DTD 的表示形式。
DTD(String) - 类 javax.swing.text.html.parser.DTD 的构造方法
创建具有指定名称的新 DTD。
dtd - 类 javax.swing.text.html.parser.Parser 中的变量
DTD - javax.xml.stream.events 中的 接口
它是处理 DTD 的事件的顶层接口。
DTD - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个 DTD
DTDConstants - javax.swing.text.html.parser 中的 接口
DTD 中使用的 SGML 常量。
DTDHandler - org.xml.sax 中的 接口
接收基本的 DTD 相关的事件的通知。
DUMMY - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
dump(PrintStream, int) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
转储该元素层次结构的调试表示形式。
dump(PrintStream) - 类 javax.swing.text.AbstractDocument 中的方法
提供诊断转储 (dump)。
dumpAllThreads(boolean, boolean) - 接口 java.lang.management.ThreadMXBean 中的方法
返回所有活动线程的线程信息，并带有堆栈跟踪和同步信息。
dumpStack() - 类 java.lang.Thread 中的静态方法
将当前线程的堆栈跟踪打印至标准错误流。
DUPLEX - 类 javax.print.attribute.standard.Sides 中的静态变量
“双面长边”的别名（请参阅 TWO_SIDED_LONG_EDGE）。
duplicate() - 类 java.nio.ByteBuffer 中的方法
创建共享此缓冲区内容的新的字节缓冲区。
duplicate() - 类 java.nio.CharBuffer 中的方法
创建共享此缓冲区内容的新的字符缓冲区。
duplicate() - 类 java.nio.DoubleBuffer 中的方法
创建共享此缓冲区内容的新的 double 缓冲区。
duplicate() - 类 java.nio.FloatBuffer 中的方法
创建共享此缓冲区内容的新的 float 缓冲区。
duplicate() - 类 java.nio.IntBuffer 中的方法
创建共享此缓冲区内容的新的 int 缓冲区。
duplicate() - 类 java.nio.LongBuffer 中的方法
创建共享此缓冲区内容的新的 long 缓冲区。
duplicate() - 类 java.nio.ShortBuffer 中的方法
创建共享此缓冲区内容的新的 short 缓冲区。
duplicate(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
返回所提供对象引用的复本。
DUPLICATE_ELEMENT - 异常 org.ietf.jgss.GSSException 中的静态变量
请求了重复的凭据元素。
DUPLICATE_TOKEN - 异常 org.ietf.jgss.GSSException 中的静态变量
该标记是前面标记的一个副本。
DuplicateFormatFlagsException - java.util 中的 异常
格式说明符中提供重复标志时抛出的未经检查的异常。
DuplicateFormatFlagsException(String) - 异常 java.util.DuplicateFormatFlagsException 的构造方法
构造带指定标志的此类的一个实例。
DuplicateName - org.omg.PortableInterceptor.ORBInitInfoPackage 中的 异常
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。
DuplicateName() - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName 的构造方法
DuplicateName(String) - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName 的构造方法
DuplicateName(String, String) - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName 的构造方法
DuplicateNameHelper - org.omg.PortableInterceptor.ORBInitInfoPackage 中的 类
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java。
DuplicateNameHelper() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 的构造方法
DURATION - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式数据类型 duration 的完全限定名称。
Duration - javax.xml.datatype 中的 类
W3C XML 模式 1.0 规范中定义的时间范围的不可变表示形式。
Duration() - 类 javax.xml.datatype.Duration 的构造方法
默认的无参数构造方法。
DURATION_DAYTIME - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
XQuery 1.0 和 Path 2.0 数据类型 dayTimeDuration 的完全限定名称。
DURATION_YEARMONTH - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
XQuery 1.0 和 XPath 2.0 数据类型 yearMonthDuration 的完全限定名称。
DYNAMIC_SOAP_PROTOCOL - 接口 javax.xml.soap.SOAPConstants 中的静态变量
用于创建 MessageFactory 实例，该实例可创建 SOAPMessages，SOAPMessages 的具体类型取决于传递给 createMessage 方法的 Content-Type MIME 头。
DynamicImplementation - org.omg.CORBA 中的 类
已过时。 org.omg.CORBA.DynamicImplementation
DynamicImplementation() - 类 org.omg.CORBA.DynamicImplementation 的构造方法
已过时。
DynamicImplementation - org.omg.PortableServer 中的 类
允许动态处理对象调用。
DynamicImplementation() - 类 org.omg.PortableServer.DynamicImplementation 的构造方法
DynamicMBean - javax.management 中的 接口
定义了 Dynamic MBean（公开了动态管理接口的 MBean）应该实现的各个方法。
DynAny - org.omg.CORBA 中的 接口
已过时。 使用新的 DynAny 替代
DynAny - org.omg.DynamicAny 中的 接口
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynAnyFactory - org.omg.DynamicAny 中的 接口
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyFactoryHelper - org.omg.DynamicAny 中的 类
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyFactoryHelper() - 类 org.omg.DynamicAny.DynAnyFactoryHelper 的构造方法
DynAnyFactoryOperations - org.omg.DynamicAny 中的 接口
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyHelper - org.omg.DynamicAny 中的 类
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynAnyHelper() - 类 org.omg.DynamicAny.DynAnyHelper 的构造方法
DynAnyOperations - org.omg.DynamicAny 中的 接口
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynAnySeqHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/DynAnySeqHelper.java。
DynAnySeqHelper() - 类 org.omg.DynamicAny.DynAnySeqHelper 的构造方法
DynArray - org.omg.CORBA 中的 接口
已过时。 使用新的 DynArray 替代
DynArray - org.omg.DynamicAny 中的 接口
DynArray 对象支持对 IDL 数组的操作。
DynArrayHelper - org.omg.DynamicAny 中的 类
DynArray 对象支持对 IDL 数组的操作。
DynArrayHelper() - 类 org.omg.DynamicAny.DynArrayHelper 的构造方法
DynArrayOperations - org.omg.DynamicAny 中的 接口
DynArray 对象支持对 IDL 数组的操作。
DynEnum - org.omg.CORBA 中的 接口
已过时。 使用新的 DynEnum 替代
DynEnum - org.omg.DynamicAny 中的 接口
DynEnum 对象支持对 IDL 枚举值的操作。
DynEnumHelper - org.omg.DynamicAny 中的 类
DynEnum 对象支持对 IDL 枚举值的操作。
DynEnumHelper() - 类 org.omg.DynamicAny.DynEnumHelper 的构造方法
DynEnumOperations - org.omg.DynamicAny 中的 接口
DynEnum 对象支持对 IDL enumerated value 的操作。
DynFixed - org.omg.CORBA 中的 接口
已过时。 使用新的 DynFixed 替代
DynFixed - org.omg.DynamicAny 中的 接口
DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
DynFixedHelper - org.omg.DynamicAny 中的 类
DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
DynFixedHelper() - 类 org.omg.DynamicAny.DynFixedHelper 的构造方法
DynFixedOperations - org.omg.DynamicAny 中的 接口
DynFixed 对象支持对 IDL 定值的操作。
DynSequence - org.omg.CORBA 中的 接口
已过时。 使用新的 DynSequence 替代
DynSequence - org.omg.DynamicAny 中的 接口
DynSequence 对象支持对 IDL 序列的操作。
DynSequenceHelper - org.omg.DynamicAny 中的 类
DynSequence 对象支持对 IDL 序列的操作。
DynSequenceHelper() - 类 org.omg.DynamicAny.DynSequenceHelper 的构造方法
DynSequenceOperations - org.omg.DynamicAny 中的 接口
DynSequence 对象支持对 IDL 序列的操作。
DynStruct - org.omg.CORBA 中的 接口
已过时。 使用新的 DynStruct 替代
DynStruct - org.omg.DynamicAny 中的 接口
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
DynStructHelper - org.omg.DynamicAny 中的 类
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
DynStructHelper() - 类 org.omg.DynamicAny.DynStructHelper 的构造方法
DynStructOperations - org.omg.DynamicAny 中的 接口
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常 (exception) 值的操作。
DynUnion - org.omg.CORBA 中的 接口
已过时。 使用新的 DynUnion 替代
DynUnion - org.omg.DynamicAny 中的 接口
DynUnion 对象支持对 IDL 联合 (union) 的操作。
DynUnionHelper - org.omg.DynamicAny 中的 类
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
DynUnionHelper() - 类 org.omg.DynamicAny.DynUnionHelper 的构造方法
DynUnionOperations - org.omg.DynamicAny 中的 接口
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
DynValue - org.omg.CORBA 中的 接口
已过时。 使用新的 DynValue 替代
DynValue - org.omg.DynamicAny 中的 接口
DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
DynValueBox - org.omg.DynamicAny 中的 接口
DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
DynValueBoxOperations - org.omg.DynamicAny 中的 接口
DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
DynValueCommon - org.omg.DynamicAny 中的 接口
DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
DynValueCommonOperations - org.omg.DynamicAny 中的 接口
DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
DynValueHelper - org.omg.DynamicAny 中的 类
DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
DynValueHelper() - 类 org.omg.DynamicAny.DynValueHelper 的构造方法
DynValueOperations - org.omg.DynamicAny 中的 接口
DynValue 对象支持对 IDL 非装箱 (boxed) 值类型的支持。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


E - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

E

E - 类 java.awt.PageAttributes.MediaType 中的静态变量
Engineering E (34 x 44 in) 的 MediaType 实例。
E - 类 java.lang.Math 中的静态变量
比任何其他值都更接近 e（即自然对数的底数）的 double 值。
E - 类 java.lang.StrictMath 中的静态变量
比任何其他值都更接近 e（即自然对数的底数）的 double 值。
E - 类 javax.print.attribute.standard.MediaSize.Engineering 中的静态变量
指定 engineering E 尺寸，34 inch × 44 inch。
E - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
E 尺寸。
E_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口右边框大小的光标类型。
E_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.E_RESIZE_CURSOR 取代。
EAST - 类 java.awt.BorderLayout 中的静态变量
东区域的布局约束（容器右边）。
EAST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的右部，并在垂直方向上居中。
EAST - 类 javax.swing.SpringLayout 中的静态变量
指定组件的边界矩形的右边。
EAST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向东（右）。
EASTERN_ARABIC - 类 java.awt.font.NumericShaper 中的静态变量
标识 ARABIC 范围和 ARABIC_EXTENDED 十进制基数。
eastPane - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
ECField - java.security.spec 中的 接口
此接口表示椭圆曲线 (EC) 有限字段。
ECFieldF2m - java.security.spec 中的 类
此不可变类定义椭圆曲线 (EC) 首数为 2 的有限字段。
ECFieldF2m(int) - 类 java.security.spec.ECFieldF2m 的构造方法
使用常规方法创建一个椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
ECFieldF2m(int, BigInteger) - 类 java.security.spec.ECFieldF2m 的构造方法
使用多项式方法创建一个椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
ECFieldF2m(int, int[]) - 类 java.security.spec.ECFieldF2m 的构造方法
使用多项式方法创建椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
ECFieldFp - java.security.spec 中的 类
此不可变类定义椭圆曲线 (EC) 素数的有限字段。
ECFieldFp(BigInteger) - 类 java.security.spec.ECFieldFp 的构造方法
根据指定的素数 p 创建一个椭圆曲线素数的有限字段。
ECGenParameterSpec - java.security.spec 中的 类
此不可变类指定用于生成椭圆曲线 (EC) 域参数的参数集。
ECGenParameterSpec(String) - 类 java.security.spec.ECGenParameterSpec 的构造方法
使用标准的（或预定义的）名称 stdName 创建用于 EC 参数生成的参数规范，以便生成相应的（预计算的）椭圆曲线域参数。
echoCharIsSet() - 类 java.awt.TextField 中的方法
指示此文本字段是否有一个回显字符集。
echoCharIsSet() - 类 javax.swing.JPasswordField 中的方法
如果此 JPasswordField 具有为回显设置的字符，则返回 true。
ECKey - java.security.interfaces 中的 接口
椭圆曲线 (EC) 密钥的接口。
ECParameterSpec - java.security.spec 中的 类
此不可变类指定用于椭圆曲线加密方法 (ECC) 的域参数集。
ECParameterSpec(EllipticCurve, ECPoint, BigInteger, int) - 类 java.security.spec.ECParameterSpec 的构造方法
创建基于指定值的椭圆曲线域参数。
ECPoint - java.security.spec 中的 类
此不可变类在仿射坐标中表示椭圆曲线 (EC) 上的点。
ECPoint(BigInteger, BigInteger) - 类 java.security.spec.ECPoint 的构造方法
根据指定的仿射 x 坐标 x 和仿射 y 坐标 y 创建 ECPoint。
ECPrivateKey - java.security.interfaces 中的 接口
椭圆曲线 (EC) 专用密钥的接口。
ECPrivateKeySpec - java.security.spec 中的 类
此不可变类指定带关联参数的椭圆曲线专用密钥。
ECPrivateKeySpec(BigInteger, ECParameterSpec) - 类 java.security.spec.ECPrivateKeySpec 的构造方法
使用指定的参数值创建一个新的 ECPrivateKeySpec。
ECPublicKey - java.security.interfaces 中的 接口
椭圆曲线 (EC) 公用密钥的接口。
ECPublicKeySpec - java.security.spec 中的 类
此不可变类指定带关联参数的椭圆曲线公用密钥。
ECPublicKeySpec(ECPoint, ECParameterSpec) - 类 java.security.spec.ECPublicKeySpec 的构造方法
根据指定参数值，创建一个新的 ECPublicKeySpec。
EDGE_NO_OP - 类 java.awt.image.ConvolveOp 中的静态变量
将位于源图像边缘的像素复制为目标中相应的像素，不加修改。
EDGE_SPACING - 类 javax.swing.border.TitledBorder 中的静态变量
EDGE_STITCH - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿某个边的一个或多个装订点（金属针脚）绑定。
EDGE_STITCH_BOTTOM - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿底边的一个或多个装订点（金属针脚）绑定。
EDGE_STITCH_LEFT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿左边的一个或多个装订点（金属针脚）绑定。
EDGE_STITCH_RIGHT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿右边的一个或多个装订点（金属针脚）绑定。
EDGE_STITCH_TOP - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿顶边的一个或多个装订点（金属针脚）绑定。
EDGE_ZERO_FILL - 类 java.awt.image.ConvolveOp 中的静态变量
位于目标图像边缘的像素被设置为 0。
edit(File) - 类 java.awt.Desktop 中的方法
启动关联编辑器应用程序并打开用于编辑的文件。
EDITABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示用户可以更改此对象的内容。
editable - 类 javax.swing.JTree 中的变量
树是否可以编辑？默认值为 false。
EDITABLE_PROPERTY - 类 javax.swing.JTree 中的静态变量
editable 的绑定属性名称。
editablePropertyChanged(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
已过时。 从 Java 2 platform v1.4 开始。
EDITBAR - 类 javax.accessibility.AccessibleRole 中的静态变量
该职责表示充当一个求值公式的对象。
editCellAt(int, int) - 类 javax.swing.JTable 中的方法
如果 row 和 column 位置的索引在有效范围内，并且这些索引处的单元格是可编辑的，则以编程方式启动该位置单元格的编辑。
editCellAt(int, int, EventObject) - 类 javax.swing.JTable 中的方法
如果 row 和 column 位置的索引在有效范围内，并且这些索引处的单元格是可编辑的，则以编程方式启动该位置单元格的编辑。
editingCanceled(ChangeEvent) - 接口 javax.swing.event.CellEditorListener 中的方法
此方法告知侦听器编辑器已经取消编辑
editingCanceled(ChangeEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
编辑取消时调用。
editingCanceled(ChangeEvent) - 类 javax.swing.JTable 中的方法
编辑取消时调用。
editingCanceled(ChangeEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler 中的方法
在树中取消编辑时传递消息。
editingColumn - 类 javax.swing.JTable 中的变量
标识所编辑的单元格的列。
editingComponent - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
编辑时，它将是进行实际编辑的 Component。
editingComponent - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
用于编辑的组件，从 editingContainer 获取。
editingContainer - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
将包含 editorComponent 的编辑容器。
editingIcon - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
编辑时要使用的图标。
editingPath - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
要编辑的路径。
editingRow - 类 javax.swing.JTable 中的变量
标识所编辑的单元格的行。
editingRow - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
要编辑的行。
editingStopped(ChangeEvent) - 接口 javax.swing.event.CellEditorListener 中的方法
此方法告知侦听器编辑器已经结束编辑
editingStopped(ChangeEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪单元格内容的变更。
editingStopped(ChangeEvent) - 类 javax.swing.JTable 中的方法
编辑结束时调用。
editingStopped(ChangeEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler 中的方法
在树中停止编辑时传递消息。
editor - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
editor - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的变量
editor - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
EDITOR_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
EditorPane 的 region。
editorBorderInsets - 类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 中的变量
editorBorderInsets - 类 javax.swing.plaf.metal.MetalComboBoxEditor 中的静态变量
默认编辑器边框 Insets。
editorComp - 类 javax.swing.JTable 中的变量
在编辑时处理编辑的 Component。
editorComponent - 类 javax.swing.DefaultCellEditor 中的变量
正被编辑的 Swing 组件。
EditorContainer() - 类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 中的方法
editorHasDifferentSize - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
如果编辑器的大小不同于渲染器，则设置为 true。
EditorKit - javax.swing.text 中的 类
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
EditorKit() - 类 javax.swing.text.EditorKit 的构造方法
构造一个 EditorKit。
edits - 类 javax.swing.undo.CompoundEdit 中的变量
由此 CompoundEdit 全部撤消/恢复的 UndoableEdit 的集合。
editToBeRedone() - 类 javax.swing.undo.UndoManager 中的方法
如果调用 redo，则返回下一个要恢复的有效编辑。
editToBeUndone() - 类 javax.swing.undo.UndoManager 中的方法
如果调用 undo，则返回下一个要撤消的有效编辑。
effective_profile() - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回将用来发送请求的配置文件。
effective_target() - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回实际调用操作的对象。
EFFORT - 接口 java.util.jar.Pack200.Packer 中的静态变量
如果将此属性设置为单个十进制数字，则打包器将在压缩存档时使用指定压缩级别。
element() - 异常 java.lang.annotation.AnnotationTypeMismatchException 中的方法
返回类型不正确的元素的 Method 对象。
element() - 类 java.util.AbstractQueue 中的方法
获取但不移除此队列的头。
element() - 类 java.util.ArrayDeque 中的方法
获取，但不移除此双端队列所表示的队列的头。
element() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取但不移除此双端队列表示的队列的头部（即此双端队列的第一个元素）。
element() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
获取但不移除此双端队列表示的队列的头部。
element() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）。
element() - 类 java.util.LinkedList 中的方法
获取但不移除此列表的头（第一个元素）。
element() - 接口 java.util.Queue 中的方法
获取，但是不移除此队列的头。
Element - javax.lang.model.element 中的 接口
表示一个程序元素，比如包、类或者方法。
element - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的变量
Element - javax.swing.text 中的 接口
描述文档的结构元素的接口。
Element - javax.swing.text.html.parser 中的 类
使用 ELEMENT 构造在 DTD 中描述的一个元素。
Element - javax.xml.bind 中的 接口
这是一个元素标记接口。
Element - org.w3c.dom 中的 接口
Element 接口表示 HTML 或 XML 文档中的一个元素。
ELEMENT_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Element。
elementAt(int) - 类 java.util.Vector 中的方法
返回指定索引处的组件。
elementAt(int) - 类 javax.swing.DefaultListModel 中的方法
返回指定索引处的组件。
elementCount - 类 java.util.Vector 中的变量
Vector 对象中的有效组件数。
elementCount - 类 javax.management.monitor.Monitor 中的变量
被观察对象的向量中的有效组件数。
elementCountToTag(HTMLDocument, int, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 中的方法
返回要获得表示 tag 的元素时，从最深的叶元素开始所需的元素数。
elementData - 类 java.util.Vector 中的变量
存储向量组件的数组缓冲区。
elementDecl(String, String) - 接口 org.xml.sax.ext.DeclHandler 中的方法
报告元素类型声明。
elementDecl(String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
ElementFilter - javax.lang.model.util 中的 类
用来从元素集合中只选择所需元素的过滤器。
elementHash - 类 javax.swing.text.html.parser.DTD 中的变量
ElementIterator - javax.swing.text 中的 类
ElementIterator，顾名思义，沿 Element 树进行迭代。
ElementIterator(Document) - 类 javax.swing.text.ElementIterator 的构造方法
创建新的 ElementIterator。
ElementIterator(Element) - 类 javax.swing.text.ElementIterator 的构造方法
创建新的 ElementIterator。
ElementKind - javax.lang.model.element 中的 枚举
元素的 kind。
ElementKindVisitor6<R,P> - javax.lang.model.util 中的 类
基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。
ElementKindVisitor6() - 类 javax.lang.model.util.ElementKindVisitor6 的构造方法
具体子类的构造方法；使用 null 作为默认值。
ElementKindVisitor6(R) - 类 javax.lang.model.util.ElementKindVisitor6 的构造方法
具体子类的构造方法；使用参数作为默认值。
elementName() - 异常 java.lang.annotation.IncompleteAnnotationException 中的方法
返回缺少元素的名称。
ElementNameAttribute - 类 javax.swing.text.AbstractDocument 中的静态变量
用于指定元素名的属性名。
elements() - 类 java.security.PermissionCollection 中的方法
返回集合中所有 Permission 对象的枚举。
elements() - 类 java.security.Permissions 中的方法
返回此 Permissions 对象中所有 PermissionCollection 中的所有 Permission 对象的枚举。
elements() - 类 java.security.Provider 中的方法
elements() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此表中值的枚举。
elements() - 类 java.util.Dictionary 中的方法
返回此 dictionary 中值的枚举。
elements() - 类 java.util.Hashtable 中的方法
返回此哈希表中的值的枚举。
elements() - 类 java.util.Vector 中的方法
返回此向量的组件的枚举。
Elements - javax.lang.model.util 中的 接口
用来对程序元素进行操作的实用工具方法。
elements() - 类 javax.swing.DefaultListModel 中的方法
返回此列表的组件枚举。
elements - 类 javax.swing.text.html.parser.DTD 中的变量
ElementScanner6<R,P> - javax.lang.model.util 中的 类
程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。
ElementScanner6() - 类 javax.lang.model.util.ElementScanner6 的构造方法
具体子类的构造方法；使用 null 作为默认值。
ElementScanner6(R) - 类 javax.lang.model.util.ElementScanner6 的构造方法
具体子类的构造方法；使用参数作为默认值。
ElementType - java.lang.annotation 中的 枚举
程序元素类型。
ElementVisitor<R,P> - javax.lang.model.element 中的 接口
程序元素的 visitor，使用 visitor 设计模式的样式。
Ellipse2D - java.awt.geom 中的 类
Ellipse2D 类描述窗体矩形定义的椭圆。
Ellipse2D() - 类 java.awt.geom.Ellipse2D 的构造方法
这是一个无法直接实例化的抽象类。
Ellipse2D.Double - java.awt.geom 中的 类
Double 类以 double 精度定义椭圆。
Ellipse2D.Double() - 类 java.awt.geom.Ellipse2D.Double 的构造方法
构造一个新 Ellipse2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。
Ellipse2D.Double(double, double, double, double) - 类 java.awt.geom.Ellipse2D.Double 的构造方法
根据指定坐标构造和初始化 Ellipse2D。
Ellipse2D.Float - java.awt.geom 中的 类
Float 类以 float 精度定义椭圆。
Ellipse2D.Float() - 类 java.awt.geom.Ellipse2D.Float 的构造方法
构造一个新 Ellipse2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。
Ellipse2D.Float(float, float, float, float) - 类 java.awt.geom.Ellipse2D.Float 的构造方法
根据指定坐标构造和初始化 Ellipse2D。
EllipticCurve - java.security.spec 中的 类
此不可变类持有表示椭圆曲线所必需的值。
EllipticCurve(ECField, BigInteger, BigInteger) - 类 java.security.spec.EllipticCurve 的构造方法
使用指定的椭圆字段 field 以及系数 a 和 b 创建椭圆曲线。
EllipticCurve(ECField, BigInteger, BigInteger, byte[]) - 类 java.security.spec.EllipticCurve 的构造方法
使用指定的椭圆字段 field、系数 a 和 b，以及用于生成曲线的 seed 创建椭圆曲线。
EM - 类 javax.swing.text.html.HTML.Tag 中的静态变量
EMBEDDED_BY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象嵌入一个或多个对象。
EMBEDDED_BY_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个或多个对象之间的 EMBEDDED_BY 关系已更改。
EMBEDS - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象具有一个或多个嵌入它的对象。
EMBEDS_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个或多个对象之间的 EMBEDS 关系已更改。
empty() - 类 java.util.Stack 中的方法
测试堆栈是否为空。
empty() - 类 javax.swing.text.html.parser.ContentModel 中的方法
如果内容模式可以匹配一个空输入流，则返回 true。
EMPTY - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
EMPTY - 类 javax.swing.text.SimpleAttributeSet 中的静态变量
空的属性集。
EMPTY_DESCRIPTOR - 类 javax.management.ImmutableDescriptor 中的静态变量
空描述符。
EMPTY_ENUMERATION - 类 javax.swing.tree.DefaultMutableTreeNode 中的静态变量
始终为空的枚举。
EMPTY_LIST - 类 java.util.Collections 中的静态变量
空的列表（不可变的）。
EMPTY_MAP - 类 java.util.Collections 中的静态变量
空的映射（不可变的）。
EMPTY_SET - 类 java.util.Collections 中的静态变量
空的 set（不可变的）。
EmptyBorder - javax.swing.border 中的 类
该类提供了一个占用空间但不执行绘制的空透明边框。
EmptyBorder(int, int, int, int) - 类 javax.swing.border.EmptyBorder 的构造方法
创建具有指定 insets 的空边框
EmptyBorder(Insets) - 类 javax.swing.border.EmptyBorder 的构造方法
创建具有指定 insets 的空边框
emptyList() - 类 java.util.Collections 中的静态方法
返回空的列表（不可变的）。
emptyMap() - 类 java.util.Collections 中的静态方法
返回空的映射（不可变的）。
emptySet() - 类 java.util.Collections 中的静态方法
返回空的 set（不可变的）。
EmptyStackException - java.util 中的 异常
该异常由 Stack 类中的方法抛出，以表明堆栈为空。
EmptyStackException() - 异常 java.util.EmptyStackException 的构造方法
构造一个将 null 作为其错误消息字符串的新 EmptyStackException。
emptyTag(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出所有空元素（没有对应结束标记的所有标记）。
enable() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
enable(boolean) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
enable() - 类 java.awt.MenuItem 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
enable(boolean) - 类 java.awt.MenuItem 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
enable() - 类 java.lang.Compiler 中的静态方法
使编译器恢复操作。
enable() - 类 javax.swing.JComponent 中的方法
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
enableActions() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
enableAllObjectNames() - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
启用所有 MBeanServerNotification（选中所有 ObjectName）。
enableAttribute(String) - 类 javax.management.AttributeChangeNotificationFilter 中的方法
启用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定名称。
enableClientWindowNotification(InputMethod, boolean) - 接口 java.awt.im.spi.InputMethodContext 中的方法
启用或禁用指定输入方法的当前客户端窗口位置或状态的通知。
ENABLED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是启用的。
enabled - 类 javax.swing.AbstractAction 中的变量
指定是否启用操作；默认值为 true。
ENABLED - 类 javax.swing.DefaultButtonModel 中的静态变量
标识位掩码中“启用的”位，该位指示可以通过输入设备（如鼠标指针）选择按钮。
ENABLED - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示组件被启用的基本状态。
enableEvents(long) - 类 java.awt.Component 中的方法
启用由传递给此组件的指定事件掩码参数所定义的事件。
enableEvents(long) - 类 java.awt.MenuItem 中的方法
允许将事件提交到将由指定事件掩码参数定义的事件的菜单项。
enableInputMethods(boolean) - 类 java.awt.Component 中的方法
启用或禁用此组件的输入方法支持。
enableInputMethods(boolean) - 类 java.awt.TextComponent 中的方法
启用或禁用此文本组件的输入法支持。
enableObjectName(ObjectName) - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
启用与给定 ObjectName 有关的 MBeanServerNotification。
enableReplaceObject(boolean) - 类 java.io.ObjectOutputStream 中的方法
允许流对流中的对象进行替换。
enableResizedPosting() - 类 javax.swing.table.TableColumn 中的方法
已过时。 从 Java 2 platform v1.3 开始
enableResolveObject(boolean) - 类 java.io.ObjectInputStream 中的方法
使流允许从该流读取的对象被替代。
enableType(String) - 类 javax.management.NotificationFilterSupport 中的方法
允许将其类型以指定前缀开始的所有通知发送到该侦听器。
ENCLOSED_ALPHANUMERICS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Enclosed Alphanumerics”Unicode 字符块的常量。
ENCLOSED_CJK_LETTERS_AND_MONTHS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Enclosed CJK Letters and Months”Unicode 字符块的常量。
ENCLOSING_MARK - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Me”。
encode(String) - 类 java.net.URLEncoder 中的静态方法
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。
encode(String, String) - 类 java.net.URLEncoder 中的静态方法
使用指定的编码机制将字符串转换为 application/x-www-form-urlencoded 格式。
encode(CharBuffer) - 类 java.nio.charset.Charset 中的方法
将此 charset 中的 Unicode 字符编码成字节的便捷方法。
encode(String) - 类 java.nio.charset.Charset 中的方法
将此 charset 中的字符串编码成字节的便捷方法。
encode(CharBuffer, ByteBuffer, boolean) - 类 java.nio.charset.CharsetEncoder 中的方法
从给定输入缓冲区中编码尽可能多的字符，把结果写入给定的输出缓冲区。
encode(CharBuffer) - 类 java.nio.charset.CharsetEncoder 中的方法
把单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区的便捷方法。
encode(OutputStream) - 接口 java.security.Certificate 中的方法
已过时。 以 decode 方法可以解码的格式将证书编码到输出流。
encode(Any) - 接口 org.omg.IOP.CodecOperations 中的方法
基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
encode_value(Any) - 接口 org.omg.IOP.CodecOperations 中的方法
基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
encodeDataFlavor(DataFlavor) - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
编码 DataFlavor 以用作 String native。
EncodedKeySpec - java.security.spec 中的 类
此类用编码格式表示公用密钥或专用密钥。
EncodedKeySpec(byte[]) - 类 java.security.spec.EncodedKeySpec 的构造方法
根据给定的编码密钥创建一个新的 EncodedKeySpec。
encodedParams - 类 javax.crypto.SealedObject 中的变量
由密封 Cipher 使用的加密参数，以默认格式进行编码。
encodeJavaMIMEType(String) - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
编码 MIME 类型以用作 String native。
encodeLoop(CharBuffer, ByteBuffer) - 类 java.nio.charset.CharsetEncoder 中的方法
将一个或多个字符编码为一个或多个字节。
Encoder - java.beans 中的 类
Encoder 是这样的类，它可用于创建根据其公共 API 对 JavaBeans 集合状态进行编码的文件或流。
Encoder() - 类 java.beans.Encoder 的构造方法
encoding - 类 javax.sound.sampled.AudioFormat 中的变量
此格式使用的音频编码技术。
ENCODING - 类 javax.xml.transform.OutputKeys 中的静态变量
encoding = string. encoding 指定了首选的字符编码，Transformer 应使用此编码将字符序列编码作为字节序列进行编码。
Encoding - org.omg.IOP 中的 类
org/omg/IOP/Encoding.java。
Encoding() - 类 org.omg.IOP.Encoding 的构造方法
Encoding(short, byte, byte) - 类 org.omg.IOP.Encoding 的构造方法
ENCODING_CDR_ENCAPS - org.omg.IOP 中的 接口
org/omg/IOP/ENCODING_CDR_ENCAPS.java。
encodingSet() - 接口 javax.xml.stream.events.StartDocument 中的方法
如果在文档的编码声明中设置了 CharacterEncodingScheme，则返回 true。
ENCRYPT - 类 javax.xml.crypto.KeySelector.Purpose 中的静态变量
用于加密的密钥。
ENCRYPT_MODE - 类 javax.crypto.Cipher 中的静态变量
用于将 Cipher 初始化为加密模式的常量。
EncryptedPrivateKeyInfo - javax.crypto 中的 类
此类实现 EncryptedPrivateKeyInfo 类型，如在 PKCS #8 中定义的那样。
EncryptedPrivateKeyInfo(byte[]) - 类 javax.crypto.EncryptedPrivateKeyInfo 的构造方法
根据其 ASN.1 编码构造（即解析）EncryptedPrivateKeyInfo。
EncryptedPrivateKeyInfo(String, byte[]) - 类 javax.crypto.EncryptedPrivateKeyInfo 的构造方法
根据加密算法名称和加密数据构造 EncryptedPrivateKeyInfo。
EncryptedPrivateKeyInfo(AlgorithmParameters, byte[]) - 类 javax.crypto.EncryptedPrivateKeyInfo 的构造方法
根据加密算法参数和加密数据构造 EncryptedPrivateKeyInfo。
ENCTYPE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
END - 类 java.awt.Event 中的静态变量
End 键，一个非 ASCII 操作键。
end() - 类 java.awt.PrintJob 中的方法
终止打印作业并进行必要的清除操作。
end(boolean) - 类 java.nio.channels.spi.AbstractInterruptibleChannel 中的方法
标记可能无限期阻塞的 I/O 操作的结尾。
end() - 类 java.nio.channels.spi.AbstractSelector 中的方法
标记可能无限期阻塞的 I/O 操作的结束。
end() - 类 java.util.regex.Matcher 中的方法
返回最后匹配字符之后的偏移量。
end(int) - 类 java.util.regex.Matcher 中的方法
返回在以前的匹配操作期间，由给定组所捕获子序列的最后字符之后的偏移量。
end() - 接口 java.util.regex.MatchResult 中的方法
返回最后匹配字符之后的偏移量。
end(int) - 接口 java.util.regex.MatchResult 中的方法
返回在匹配期间由给定组所捕获子序列的最后字符之后的偏移量。
end() - 类 java.util.zip.Deflater 中的方法
关闭解压缩器并放弃所有未处理的输入。
end() - 类 java.util.zip.Inflater 中的方法
关闭解压缩器并放弃所有未处理的输入。
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 中的方法
当发现此动作所注册的标记类型的结束标记时调用。
end() - 类 javax.swing.undo.CompoundEdit 中的方法
将 inProgress 设置为 false。
end() - 类 javax.swing.undo.StateEdit 中的方法
获取 StateEditable 对象的后编辑状态，并结束编辑。
end() - 类 javax.swing.undo.UndoManager 中的方法
将此 UndoManager 转换为标准 CompoundEdit。
end(Xid, int) - 接口 javax.transaction.xa.XAResource 中的方法
终止代表事务分支所执行的工作。
END_DOCUMENT - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个结束文档
END_ELEMENT - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个结束元素
END_OF_EXCLUSIVE - 类 javax.sound.midi.ShortMessage 中的静态变量
End of System Exclusive 消息的状态字节（0xF7 或 247）。
END_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Pe”。
end_value() - 接口 org.omg.CORBA.portable.ValueInputStream 中的方法
end_value 方法读取嵌套自定义 valuetype 的结束标记（在跳过结束标记之前的所有数据后）并将 valuetype 嵌套层次加 1。
end_value() - 接口 org.omg.CORBA.portable.ValueOutputStream 中的方法
end_value 方法结束任何当前开启的程序块，写入嵌套自定义 valuetype 的结束标记，并将 valuetype 嵌套层次减 1。
endAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到文档末尾的 Action 名称。
endCDATA() - 类 org.xml.sax.ext.DefaultHandler2 中的方法
endCDATA() - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告 CDATA 节的结束。
endComposition() - 类 java.awt.im.InputContext 中的方法
结束当前可能在此上下文进行的任何输入撰写。
endComposition() - 接口 java.awt.im.spi.InputMethod 中的方法
结束当前可能在此上下文中正进行的任何输入撰写。
EndDocument - javax.xml.stream.events 中的 接口
文档结尾的标记接口。
endDocument() - 接口 org.xml.sax.ContentHandler 中的方法
接收文档的结尾的通知。
endDocument() - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收文档结束的通知。
endDocument() - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收文档结束的通知。
endDocument() - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收文档结束的通知。
endDocument() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
endDocument() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个结束文档事件。
endDocument() - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
结束文档事件。
endDraggingFrame(JComponent) - 类 javax.swing.DefaultDesktopManager 中的方法
endDraggingFrame(JComponent) - 接口 javax.swing.DesktopManager 中的方法
此方法在拖动会话结束时发出信号。
endDTD() - 类 org.xml.sax.ext.DefaultHandler2 中的方法
endDTD() - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告 DTD 声明的结束。
EndElement - javax.xml.stream.events 中的 接口
结束元素事件的接口。
endElement(String, String, String) - 接口 org.xml.sax.ContentHandler 中的方法
接收元素结束的通知。
endElement(String) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收元素结束的通知。
endElement(String) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收元素结束的通知。
endElement(String, String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收元素结束的通知。
endElement(String) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
endElement(String, String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个结束元素事件。
endElement(String, String, String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 结束元素事件。
endEntity(String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
endEntity(String) - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告实体的结束。
endFontTag() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
此方法已不再使用，而用写出 <span> 来替换。
endIndex - 类 javax.accessibility.AccessibleAttributeSequence 中的变量
文本序列的结束索引
endIndex - 类 javax.accessibility.AccessibleTextSequence 中的变量
文本序列的结束索引
endInsertEmpty() - 类 javax.imageio.ImageWriter 中的方法
完成对新图像的插入，该操作是从以前调用 prepareInsertEmpty 开始的。
endKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
endLineAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到行尾的 Action 名称。
EndOfLineStringProperty - 类 javax.swing.text.DefaultEditorKit 中的静态变量
在读取文档时，如果遇到 CRLF，将添加具有此名称的一个属性，属性值为 "\r\n"。
endParagraphAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到段落末尾的 Action 名称。
Endpoint - javax.xml.ws 中的 类
Web 服务端点。
Endpoint() - 类 javax.xml.ws.Endpoint 的构造方法
ENDPOINT_ADDRESS_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
标准属性：目标服务端点地址。
endPrefixMapping(String) - 接口 org.xml.sax.ContentHandler 中的方法
结束前缀 URI 范围的映射。
endPrefixMapping(String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收名称空间映射结束的通知。
endPrefixMapping(String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个结束名称空间前缀映射事件。
endPrefixMapping(String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 结束前缀映射事件。
endReplacePixels() - 类 javax.imageio.ImageWriter 中的方法
终止调用 replacePixels 的序列。
endResizingFrame(JComponent) - 类 javax.swing.DefaultDesktopManager 中的方法
endResizingFrame(JComponent) - 接口 javax.swing.DesktopManager 中的方法
此方法在重新调整大小会话结束时发出信号。
endsWith(String) - 类 java.lang.String 中的方法
测试此字符串是否以指定的后缀结束。
endsWith(Name) - 类 javax.naming.CompositeName 中的方法
确定某一复合名称是否是此复合名称的后缀。
endsWith(Name) - 类 javax.naming.CompoundName 中的方法
确定某一组合名称是否是此组合名称的后缀。
endsWith(Name) - 类 javax.naming.ldap.LdapName 中的方法
确定此 LDAP 名称是否以某一指定 LDAP 名称后缀结尾。
endsWith(List<Rdn>) - 类 javax.naming.ldap.LdapName 中的方法
确定指定的 RDN 序列是否形成此 LDAP 名称的后缀。
endsWith(Name) - 接口 javax.naming.Name 中的方法
确定此名称是否以某一指定后缀结束。
ENDTAG - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
endTag(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出元素的结束标记。
ENDTAG - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
endTag(boolean) - 类 javax.swing.text.html.parser.Parser 中的方法
处理结束标记。
EndTagType - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getType 的可能值。
endUpdate() - 类 javax.swing.undo.UndoableEditSupport 中的方法
死锁警告：调用此方法可能调用所有侦听器中的 undoableEditHappened。
endWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到字尾的动作名称。
endWriteEmpty() - 类 javax.imageio.ImageWriter 中的方法
完成对新图像的写入，该操作是从优先调用 prepareWriteEmpty 开始的。
endWriteSequence() - 类 javax.imageio.ImageWriter 中的方法
完成以 prepareWriteSequence 开头的一系列图像的写入。
ENGINE - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它是 ScriptEngine 实现的名称。
ENGINE_SCOPE - 接口 javax.script.ScriptContext 中的静态变量
EngineScope 属性在单个 ScriptEngine 的生存期是可见的，并为每个引擎维护一个属性集。
ENGINE_VERSION - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它标识 ScriptEngine 实现的版本。
engineAliases() - 类 java.security.KeyStoreSpi 中的方法
列出此 keystore 的所有别名。
engineBuild(CertPathParameters) - 类 java.security.cert.CertPathBuilderSpi 中的方法
尝试使用指定的算法参数集构建一个证书路径。
engineContainsAlias(String) - 类 java.security.KeyStoreSpi 中的方法
检查给定别名是否存在于此 keystore 中。
engineCreateSSLEngine() - 类 javax.net.ssl.SSLContextSpi 中的方法
使用此上下文创建新的 SSLEngine。
engineCreateSSLEngine(String, int) - 类 javax.net.ssl.SSLContextSpi 中的方法
使用此上下文创建 SSLEngine。
engineDeleteEntry(String) - 类 java.security.KeyStoreSpi 中的方法
删除由此 keystore 中给定的别名标识的项。
engineDigest() - 类 java.security.MessageDigestSpi 中的方法
通过执行诸如填充等之类的最终操作完成哈希计算。
engineDigest(byte[], int, int) - 类 java.security.MessageDigestSpi 中的方法
通过执行诸如填充等之类的最终操作完成哈希计算。
engineDoFinal(byte[], int, int) - 类 javax.crypto.CipherSpi 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
engineDoFinal(byte[], int, int, byte[], int) - 类 javax.crypto.CipherSpi 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
engineDoFinal(ByteBuffer, ByteBuffer) - 类 javax.crypto.CipherSpi 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
engineDoFinal() - 类 javax.crypto.MacSpi 中的方法
完成 MAC 计算并且重新设置 MAC 以便进一步使用，维护 MAC 初始化所用的秘密密钥。
engineDoPhase(Key, boolean) - 类 javax.crypto.KeyAgreementSpi 中的方法
用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
engineEntryInstanceOf(String, Class<? extends KeyStore.Entry>) - 类 java.security.KeyStoreSpi 中的方法
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
engineGenerateCertificate(InputStream) - 类 java.security.cert.CertificateFactorySpi 中的方法
生成一个证书对象并使用从输入流 inStream 中读取的数据对它进行初始化。
engineGenerateCertificates(InputStream) - 类 java.security.cert.CertificateFactorySpi 中的方法
返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
engineGenerateCertPath(InputStream) - 类 java.security.cert.CertificateFactorySpi 中的方法
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
engineGenerateCertPath(InputStream, String) - 类 java.security.cert.CertificateFactorySpi 中的方法
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
engineGenerateCertPath(List<? extends Certificate>) - 类 java.security.cert.CertificateFactorySpi 中的方法
生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
engineGenerateCRL(InputStream) - 类 java.security.cert.CertificateFactorySpi 中的方法
生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
engineGenerateCRLs(InputStream) - 类 java.security.cert.CertificateFactorySpi 中的方法
返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
engineGenerateKey() - 类 javax.crypto.KeyGeneratorSpi 中的方法
生成一个秘密密钥。
engineGenerateParameters() - 类 java.security.AlgorithmParameterGeneratorSpi 中的方法
生成参数。
engineGeneratePrivate(KeySpec) - 类 java.security.KeyFactorySpi 中的方法
根据所提供的密钥规范（密钥材料）生成私钥对象。
engineGeneratePublic(KeySpec) - 类 java.security.KeyFactorySpi 中的方法
根据所提供的密钥规范（密钥材料）生成公钥对象。
engineGenerateSecret() - 类 javax.crypto.KeyAgreementSpi 中的方法
生成共享秘密密钥并在新的缓冲区中返回它。
engineGenerateSecret(byte[], int) - 类 javax.crypto.KeyAgreementSpi 中的方法
生成共享秘密密钥，并将从 offset 开始（包括）的部分放入缓冲区 sharedSecret。
engineGenerateSecret(String) - 类 javax.crypto.KeyAgreementSpi 中的方法
创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
engineGenerateSecret(KeySpec) - 类 javax.crypto.SecretKeyFactorySpi 中的方法
根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
engineGenerateSeed(int) - 类 java.security.SecureRandomSpi 中的方法
返回给定的种子字节数。
engineGenExemptionBlob() - 类 javax.crypto.ExemptionMechanismSpi 中的方法
生成豁免机制密钥 blob。
engineGenExemptionBlob(byte[], int) - 类 javax.crypto.ExemptionMechanismSpi 中的方法
生成豁免机制密钥 blob 并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
engineGetAppConfigurationEntry(String) - 类 javax.security.auth.login.ConfigurationSpi 中的方法
获取指定 name 的 AppConfigurationEntry。
engineGetBlockSize() - 类 javax.crypto.CipherSpi 中的方法
返回块的大小（以字节为单位）。
engineGetCertificate(String) - 类 java.security.KeyStoreSpi 中的方法
返回与给定别名关联的证书。
engineGetCertificateAlias(Certificate) - 类 java.security.KeyStoreSpi 中的方法
返回其证书和给定证书匹配的第一个 keystore 项的名称（别名）。
engineGetCertificateChain(String) - 类 java.security.KeyStoreSpi 中的方法
返回与给定别名关联的证书链。
engineGetCertificates(CertSelector) - 类 java.security.cert.CertStoreSpi 中的方法
返回与指定选择器匹配的 Certificate 的 Collection。
engineGetCertPathEncodings() - 类 java.security.cert.CertificateFactorySpi 中的方法
返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。
engineGetClientSessionContext() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回此上下文的客户端 SSLSessionContext 对象。
engineGetCreationDate(String) - 类 java.security.KeyStoreSpi 中的方法
返回该别名标识的项的创建日期。
engineGetCRLs(CRLSelector) - 类 java.security.cert.CertStoreSpi 中的方法
返回与指定选择器匹配的 CRL 的 Collection。
engineGetDefaultSSLParameters() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。
engineGetDigestLength() - 类 java.security.MessageDigestSpi 中的方法
返回以字节为单位的摘要长度。
engineGetEncoded() - 类 java.security.AlgorithmParametersSpi 中的方法
返回基本编码格式的参数。
engineGetEncoded(String) - 类 java.security.AlgorithmParametersSpi 中的方法
返回以指定格式编码的参数。
engineGetEntry(String, KeyStore.ProtectionParameter) - 类 java.security.KeyStoreSpi 中的方法
使用指定保护参数获取指定别名的 KeyStore.Entry。
engineGetIV() - 类 javax.crypto.CipherSpi 中的方法
返回新缓冲区中的初始化向量 (IV)。
engineGetKey(String, char[]) - 类 java.security.KeyStoreSpi 中的方法
返回与给定别名关联的密钥，使用给定密码恢复它。
engineGetKeyManagers() - 类 javax.net.ssl.KeyManagerFactorySpi 中的方法
为每类密钥内容返回一个密钥管理器。
engineGetKeySize(Key) - 类 javax.crypto.CipherSpi 中的方法
返回给定密钥对象的密钥大小，以位为单位。
engineGetKeySpec(Key, Class<T>) - 类 java.security.KeyFactorySpi 中的方法
返回给定密钥对象的规范（密钥材料）。
engineGetKeySpec(SecretKey, Class) - 类 javax.crypto.SecretKeyFactorySpi 中的方法
以所需格式返回给定密钥对象的规范（密钥材料）。
engineGetMacLength() - 类 javax.crypto.MacSpi 中的方法
返回以字节为单位的 MAC 的长度。
engineGetOutputSize(int) - 类 javax.crypto.CipherSpi 中的方法
在给定了输入长度 inputLen（以字节为单位）的情况下，返回用于保存下一个 update 或 doFinal 操作结果所需的输出缓冲区长度的字节数。
engineGetOutputSize(int) - 类 javax.crypto.ExemptionMechanismSpi 中的方法
给定了输入长度 inputLen （以字节为单位）的情况下，返回用于保存下一个 engineGenExemptionBlob 操作结果所需的输出缓冲区长度的字节长度。
engineGetParameter(String) - 类 java.security.SignatureSpi 中的方法
已过时。
engineGetParameters() - 类 java.security.SignatureSpi 中的方法
此方法将由提供者重写，以返回与此签名引擎配合使用的参数，如果此签名引擎未使用任何参数，则返回 null。
engineGetParameters() - 类 javax.crypto.CipherSpi 中的方法
返回此 cipher 使用的参数。
engineGetParameterSpec(Class<T>) - 类 java.security.AlgorithmParametersSpi 中的方法
返回此参数对象的（透明）规范。
engineGetPermissions(CodeSource) - 类 java.security.PolicySpi 中的方法
返回包含授予指定 CodeSource 的权限集的 PermissionCollection 对象。
engineGetPermissions(ProtectionDomain) - 类 java.security.PolicySpi 中的方法
返回包含授予指定 ProtectionDomain 的权限集的 PermissionCollection 对象。
engineGetServerSessionContext() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回此上下文的服务器 SSLSessionContext 对象。
engineGetServerSocketFactory() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回此上下文的 ServerSocketFactory 对象。
engineGetSocketFactory() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回此上下文的 SocketFactory 对象。
engineGetSupportedSSLParameters() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回表示此 SSL 上下文最大受支持设置的 SSLParameters 的副本。
engineGetTrustManagers() - 类 javax.net.ssl.TrustManagerFactorySpi 中的方法
为每种信任材料返回一个信任管理器。
engineImplies(ProtectionDomain, Permission) - 类 java.security.PolicySpi 中的方法
检查该策略是否已将 Permission 授予 ProtectionDomain。
engineInit(int, SecureRandom) - 类 java.security.AlgorithmParameterGeneratorSpi 中的方法
针对某个特定大小和随机源初始化此参数生成器。
engineInit(AlgorithmParameterSpec, SecureRandom) - 类 java.security.AlgorithmParameterGeneratorSpi 中的方法
利用特定于算法的参数生成值的集合初始化此参数生成器。
engineInit(AlgorithmParameterSpec) - 类 java.security.AlgorithmParametersSpi 中的方法
使用在 paramSpec 中指定的参数初始化此参数对象。
engineInit(byte[]) - 类 java.security.AlgorithmParametersSpi 中的方法
根据参数的基本解码格式导入指定的参数并对其解码。
engineInit(byte[], String) - 类 java.security.AlgorithmParametersSpi 中的方法
根据指定的解码格式从 params 导入参数并对其解码。
engineInit(int, Key, SecureRandom) - 类 javax.crypto.CipherSpi 中的方法
用密钥和随机源初始化此 cipher。
engineInit(int, Key, AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.CipherSpi 中的方法
用一个密钥、一组算法参数和一个随机源初始化此 cipher。
engineInit(int, Key, AlgorithmParameters, SecureRandom) - 类 javax.crypto.CipherSpi 中的方法
用一个密钥、一组算法参数和一个随机源初始化此 cipher。
engineInit(Key) - 类 javax.crypto.ExemptionMechanismSpi 中的方法
用密钥初始化此豁免机制。
engineInit(Key, AlgorithmParameterSpec) - 类 javax.crypto.ExemptionMechanismSpi 中的方法
用一个密钥和一组算法参数初始化此豁免机制。
engineInit(Key, AlgorithmParameters) - 类 javax.crypto.ExemptionMechanismSpi 中的方法
用一个密钥和一组算法参数初始化此豁免机制。
engineInit(Key, SecureRandom) - 类 javax.crypto.KeyAgreementSpi 中的方法
用给定密钥和随机源初始化此密钥协定。
engineInit(Key, AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.KeyAgreementSpi 中的方法
用给定密钥、算法参数集和随机源初始化此密钥协定。
engineInit(SecureRandom) - 类 javax.crypto.KeyGeneratorSpi 中的方法
初始化该密钥生成器。
engineInit(AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.KeyGeneratorSpi 中的方法
用指定参数集和用户提供的随机源初始化密钥生成器。
engineInit(int, SecureRandom) - 类 javax.crypto.KeyGeneratorSpi 中的方法
使用给定随机源初始化此密钥生成器，以获取确定的密钥长度。
engineInit(Key, AlgorithmParameterSpec) - 类 javax.crypto.MacSpi 中的方法
用给定的（秘密）密钥和算法参数初始化 MAC。
engineInit(KeyStore, char[]) - 类 javax.net.ssl.KeyManagerFactorySpi 中的方法
使用密钥内容源初始化此工厂。
engineInit(ManagerFactoryParameters) - 类 javax.net.ssl.KeyManagerFactorySpi 中的方法
使用密钥内容源初始化此工厂。
engineInit(KeyManager[], TrustManager[], SecureRandom) - 类 javax.net.ssl.SSLContextSpi 中的方法
初始化此上下文。
engineInit(KeyStore) - 类 javax.net.ssl.TrustManagerFactorySpi 中的方法
用证书授权源和相关的信任材料初始化此工厂。
engineInit(ManagerFactoryParameters) - 类 javax.net.ssl.TrustManagerFactorySpi 中的方法
使用特定于提供者的密钥材料源初始化此工厂。
engineInitSign(PrivateKey) - 类 java.security.SignatureSpi 中的方法
通过用于签名操作的指定私钥初始化此签名对象。
engineInitSign(PrivateKey, SecureRandom) - 类 java.security.SignatureSpi 中的方法
通过用于签名操作的指定私钥和随机源初始化此签名对象。
engineInitVerify(PublicKey) - 类 java.security.SignatureSpi 中的方法
通过用于验证操作的指定公钥初始化此签名对象。
engineIsCertificateEntry(String) - 类 java.security.KeyStoreSpi 中的方法
如果给定别名标识的项是通过调用 setCertificateEntry 或者调用使用 TrustedCertificateEntry 作为参数的 setEntry 来创建的，则返回 true。
engineIsKeyEntry(String) - 类 java.security.KeyStoreSpi 中的方法
如果给定别名标识的项是通过调用 setKeyEntry 或者调用使用 PrivateKeyEntry 或 SecretKeyEntry 作为参数的 setEntry 创建的，则返回 true。
engineLoad(InputStream, char[]) - 类 java.security.KeyStoreSpi 中的方法
从给定的输入流中加载此 KeyStore。
engineLoad(KeyStore.LoadStoreParameter) - 类 java.security.KeyStoreSpi 中的方法
使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
engineNextBytes(byte[]) - 类 java.security.SecureRandomSpi 中的方法
生成用户指定的随机字节数。
engineRefresh() - 类 java.security.PolicySpi 中的方法
刷新/重载策略配置。
engineRefresh() - 类 javax.security.auth.login.ConfigurationSpi 中的方法
刷新并重新加载 Configuration。
engineReset() - 类 java.security.MessageDigestSpi 中的方法
为进一步使用重置摘要。
engineReset() - 类 javax.crypto.MacSpi 中的方法
为了进一步使用而重新设置 MAC，维护 MAC 初始化所用的秘密密钥。
engineScope - 类 javax.script.SimpleScriptContext 中的变量
此字段是引擎范围 bindings。
engineSetCertificateEntry(String, Certificate) - 类 java.security.KeyStoreSpi 中的方法
将给定证书分配给给定别名。
engineSetEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter) - 类 java.security.KeyStoreSpi 中的方法
用指定别名保存 KeyStore.Entry。
engineSetKeyEntry(String, Key, char[], Certificate[]) - 类 java.security.KeyStoreSpi 中的方法
将给定的密钥分配给给定的别名，用给定的密码保护它。
engineSetKeyEntry(String, byte[], Certificate[]) - 类 java.security.KeyStoreSpi 中的方法
将给定密钥（已经被保护）分配给给定别名。
engineSetMode(String) - 类 javax.crypto.CipherSpi 中的方法
设置此 cipher 的模式。
engineSetPadding(String) - 类 javax.crypto.CipherSpi 中的方法
设置此 cipher 的填充机制。
engineSetParameter(String, Object) - 类 java.security.SignatureSpi 中的方法
已过时。 由 engineSetParameter 取代。
engineSetParameter(AlgorithmParameterSpec) - 类 java.security.SignatureSpi 中的方法
此方法将由提供者重写，以便使用指定的参数设置初始化此签名引擎。
engineSetSeed(byte[]) - 类 java.security.SecureRandomSpi 中的方法
重新提供此随机对象的种子。
engineSign() - 类 java.security.SignatureSpi 中的方法
返回迄今为止所有更新的数据的签名字节。
engineSign(byte[], int, int) - 类 java.security.SignatureSpi 中的方法
完成此签名操作，并从 offset 开始将得到的签名字节保存在提供的缓冲区 outbuf 中。
engineSize() - 类 java.security.KeyStoreSpi 中的方法
获取此 keystore 中项的数目。
engineStore(OutputStream, char[]) - 类 java.security.KeyStoreSpi 中的方法
将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
engineStore(KeyStore.LoadStoreParameter) - 类 java.security.KeyStoreSpi 中的方法
使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
engineToString() - 类 java.security.AlgorithmParametersSpi 中的方法
返回描述参数的格式化字符串。
engineTranslateKey(Key) - 类 java.security.KeyFactorySpi 中的方法
将其 provider 可能是未知的或可能不受信任的密钥对象转换成此密钥工厂的相应密钥对象。
engineTranslateKey(SecretKey) - 类 javax.crypto.SecretKeyFactorySpi 中的方法
将一个密钥对象（其提供者未知或可能不受信任）转换为此密钥工厂的相应密钥对象。
engineUnwrap(byte[], String, int) - 类 javax.crypto.CipherSpi 中的方法
打开一个以前包装的密钥。
engineUpdate(byte) - 类 java.security.MessageDigestSpi 中的方法
使用指定的字节更新摘要。
engineUpdate(byte[], int, int) - 类 java.security.MessageDigestSpi 中的方法
使用指定的 byte 数组，在指定的偏移量处开始更新摘要。
engineUpdate(ByteBuffer) - 类 java.security.MessageDigestSpi 中的方法
使用指定的 ByteBuffer 更新摘要。
engineUpdate(byte) - 类 java.security.SignatureSpi 中的方法
使用指定的字节更新要签名或验证的数据。
engineUpdate(byte[], int, int) - 类 java.security.SignatureSpi 中的方法
使用指定的 byte 数组，从指定的偏移量开始更新要签名或验证的数据。
engineUpdate(ByteBuffer) - 类 java.security.SignatureSpi 中的方法
使用指定的 ByteBuffer 更新要签名或验证的数据。
engineUpdate(byte[], int, int) - 类 javax.crypto.CipherSpi 中的方法
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
engineUpdate(byte[], int, int, byte[], int) - 类 javax.crypto.CipherSpi 中的方法
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
engineUpdate(ByteBuffer, ByteBuffer) - 类 javax.crypto.CipherSpi 中的方法
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
engineUpdate(byte) - 类 javax.crypto.MacSpi 中的方法
处理给定的字节。
engineUpdate(byte[], int, int) - 类 javax.crypto.MacSpi 中的方法
从 offset 开始处（包含），处理 input 中的前len 个字节。
engineUpdate(ByteBuffer) - 类 javax.crypto.MacSpi 中的方法
从 input.position() 开始处，处理 ByteBuffer input 中的 input.remaining() 字节。
engineValidate(CertPath, CertPathParameters) - 类 java.security.cert.CertPathValidatorSpi 中的方法
使用指定的算法参数集验证指定的证书路径。
engineVerify(byte[]) - 类 java.security.SignatureSpi 中的方法
验证传入的签名。
engineVerify(byte[], int, int) - 类 java.security.SignatureSpi 中的方法
在指定的 byte 数组中，从指定的偏移量处开始，验证传入的签名。
engineWrap(Key) - 类 javax.crypto.CipherSpi 中的方法
将密钥包装。
ENGLISH - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
enqueue() - 类 java.lang.ref.Reference 中的方法
将此引用对象添加到引用对象已向其注册的队列（如果有）。
enqueueKeyEvents(long, Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
延迟对 KeyEvent 的指派，直到指定的 Component 成为焦点所有者。
enqueueKeyEvents(long, Component) - 类 java.awt.KeyboardFocusManager 中的方法
在指定的 Component 成为焦点所有者以前由 AWT 调用，以通知 KeyboardFocusManager 延迟指派 KeyEvent。
ensureCapacity(int) - 类 java.lang.StringBuffer 中的方法
ensureCapacity(int) - 类 java.util.ArrayList 中的方法
如有必要，增加此 ArrayList 实例的容量，以确保它至少能够容纳最小容量参数所指定的元素数。
ensureCapacity(int) - 类 java.util.Vector 中的方法
增加此向量的容量（如有必要），以确保其至少能够保存最小容量参数指定的组件数。
ensureCapacity(int) - 类 javax.swing.DefaultListModel 中的方法
增加此列表的容量（如有必要），以确保其至少能够保存最小容量参数指定的组件数。
ensureFileIsVisible(File) - 类 javax.swing.JFileChooser 中的方法
确保指定的文件是可见的，不是隐藏的。
ensureFileIsVisible(JFileChooser, File) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
ensureFileIsVisible(JFileChooser, File) - 类 javax.swing.plaf.FileChooserUI 中的方法
ensureFileIsVisible(JFileChooser, File) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
ensureFileIsVisible(JFileChooser, File) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 ensureFileIsVisible 方法。
ensureIndexIsVisible(int) - 类 javax.swing.JList 中的方法
滚动封闭视口中的列表，使指定单元完全可见。
ensureRowsAreVisible(int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
确保 beginRow 通过 endRow 标识的行是可见的。
ENTER - 类 java.awt.dnd.DragSourceContext 中的静态变量
updateCurrentCursor() 使用的 int 值，指示 Cursor 已进入 DropTarget。
ENTER - 类 java.awt.Event 中的静态变量
Enter 键。
ENTERED - 类 javax.swing.event.HyperlinkEvent.EventType 中的静态变量
进入类型。
entering(String, String) - 类 java.util.logging.Logger 中的方法
记录一个方法条目。
entering(String, String, Object) - 类 java.util.logging.Logger 中的方法
记录一个方法条目，带有一个参数。
entering(String, String, Object[]) - 类 java.util.logging.Logger 中的方法
记录一个方法条目，带有一组参数。
ENTITIES - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
ENTITY - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Entity - javax.swing.text.html.parser 中的 类
使用 ENTITY 构造在 DTD 中描述了一个实体。
Entity(String, int, char[]) - 类 javax.swing.text.html.parser.Entity 的构造方法
创建一个实体。
Entity - org.w3c.dom 中的 接口
此接口表示在 XML 文档中解析和未解析的已知实体。
ENTITY_DECLARATION - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示一个 Entity Declaration
ENTITY_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Entity。
ENTITY_REFERENCE - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个实体引用
ENTITY_REFERENCE_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 EntityReference。
EntityDeclaration - javax.xml.stream.events 中的 接口
处理实体声明的接口。
entityHash - 类 javax.swing.text.html.parser.DTD 中的变量
EntityReference - javax.xml.stream.events 中的 接口
处理实体事件的接口。
EntityReference - org.w3c.dom 中的 接口
EntityReference 节点可以用来在树中表示实体引用。
EntityResolver - org.xml.sax 中的 接口
用于解析实体的基本接口。
EntityResolver2 - org.xml.sax.ext 中的 接口
扩展的接口，用于将外部实体引用映射到输入源，或用于提供缺少的外部子集。
entries() - 接口 java.security.acl.Acl 中的方法
返回此 ACL 中各项的枚举。
entries() - 类 java.util.jar.JarFile 中的方法
返回 zip 文件条目的枚举。
entries() - 类 java.util.zip.ZipFile 中的方法
返回 ZIP 文件条目的枚举。
entryInstanceOf(String, Class<? extends KeyStore.Entry>) - 类 java.security.KeyStore 中的方法
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
entrySet() - 类 java.awt.RenderingHints 中的方法
返回此 RenderingHints 中所包含映射关系的 Set 视图。
entrySet() - 类 java.security.Provider 中的方法
返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。
entrySet() - 类 java.util.AbstractMap 中的方法
entrySet() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此映射所包含的映射关系的 Set 视图。
entrySet() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回此映射中所包含的映射关系的 Set 视图。
entrySet() - 类 java.util.EnumMap 中的方法
返回此映射中所包含映射关系的 Set 视图。
entrySet() - 类 java.util.HashMap 中的方法
返回此映射所包含的映射关系的 Set 视图。
entrySet() - 类 java.util.Hashtable 中的方法
返回此映射中包含的键的 Set 视图。
entrySet() - 类 java.util.IdentityHashMap 中的方法
返回此映射所包含映射关系的 Set 视图。
entrySet() - 类 java.util.jar.Attributes 中的方法
返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。
entrySet() - 接口 java.util.Map 中的方法
返回此映射中包含的映射关系的 Set 视图。
entrySet() - 接口 java.util.SortedMap 中的方法
返回在此映射中包含的映射关系的 Set 视图。
entrySet() - 类 java.util.TreeMap 中的方法
返回此映射中包含的映射关系的 Set 视图。
entrySet() - 类 java.util.WeakHashMap 中的方法
返回此映射所包含的映射关系的 Set 视图。
entrySet() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。
entrySet() - 类 javax.script.SimpleBindings 中的方法
返回此映射中包含的映射关系的 Set 视图。
Enum<E extends Enum<E>> - java.lang 中的 类
这是所有 Java 语言枚举类型的公共基本类。
Enum(String, int) - 类 java.lang.Enum 的构造方法
单独的构造方法。
EnumConstantNotPresentException - java.lang 中的 异常
当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
EnumConstantNotPresentException(Class<? extends Enum>, String) - 异常 java.lang.EnumConstantNotPresentException 的构造方法
为指定常量构造一个 EnumConstantNotPresentException。
EnumControl - javax.sound.sampled 中的 类
EnumControl 提供对一组截然不同的可能值的控制，每个值都由一个对象表示。
EnumControl(EnumControl.Type, Object[], Object) - 类 javax.sound.sampled.EnumControl 的构造方法
构造一个具有给定参数的新枚举控件对象。
EnumControl.Type - javax.sound.sampled 中的 类
EnumControl.Type 内部类的实例标识了某种枚举控件。
EnumControl.Type(String) - 类 javax.sound.sampled.EnumControl.Type 的构造方法
构造一个新的枚举控件类型。
enumerate(Thread[]) - 类 java.lang.Thread 中的静态方法
将当前线程的线程组及其子组中的每一个活动线程复制到指定的数组中。
enumerate(Thread[]) - 类 java.lang.ThreadGroup 中的方法
把此线程组及其子组中的所有活动线程复制到指定数组中。
enumerate(Thread[], boolean) - 类 java.lang.ThreadGroup 中的方法
把此线程组中的所有活动线程复制到指定数组中。
enumerate(ThreadGroup[]) - 类 java.lang.ThreadGroup 中的方法
把对此线程组中的所有活动子组的引用复制到指定数组中。
enumerate(ThreadGroup[], boolean) - 类 java.lang.ThreadGroup 中的方法
把对此线程组中的所有活动子组的引用复制到指定数组中。
enumeration(Collection<T>) - 类 java.util.Collections 中的静态方法
返回一个指定 collection 上的枚举。
Enumeration<E> - java.util 中的 接口
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EnumMap<K extends Enum<K>,V> - java.util 中的 类
与枚举类型键一起使用的专用 Map 实现。
EnumMap(Class<K>) - 类 java.util.EnumMap 的构造方法
创建一个具有指定键类型的空枚举映射。
EnumMap(EnumMap<K, ? extends V>) - 类 java.util.EnumMap 的构造方法
创建一个其键类型与指定枚举映射相同的枚举映射，最初包含相同的映射关系（如果有的话）。
EnumMap(Map<K, ? extends V>) - 类 java.util.EnumMap 的构造方法
创建一个枚举映射，从指定映射对其初始化。
EnumSet<E extends Enum<E>> - java.util 中的 类
与枚举类型一起使用的专用 Set 实现。
EnumSyntax - javax.print.attribute 中的 类
类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。
EnumSyntax(int) - 类 javax.print.attribute.EnumSyntax 的构造方法
使用给定的整数值构造一个新枚举值。
enumType() - 异常 java.lang.EnumConstantNotPresentException 中的方法
返回缺少的枚举常量的类型。
env() - 类 org.omg.CORBA.Request 中的方法
检索用于此请求的 Environment 对象。
ENV_10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_NUMBER_10_ENVELOPE 的别名。
ENV_10X13 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_10X13_ENVELOPE 的别名。
ENV_10X14 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_10X14_ENVELOPE 的别名。
ENV_10X15 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_10X15_ENVELOPE 的别名。
ENV_11 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_NUMBER_11_ENVELOPE 的别名。
ENV_12 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_NUMBER_12_ENVELOPE 的别名。
ENV_14 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_NUMBER_14_ENVELOPE 的别名。
ENV_6X9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_6X9_ENVELOPE 的别名。
ENV_7X9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_7X9_ENVELOPE 的别名。
ENV_9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_NUMBER_9_ENVELOPE 的别名。
ENV_9X11 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_9X11_ENVELOPE 的别名。
ENV_9X12 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_9X12_ENVELOPE 的别名。
ENV_INVITE - 类 java.awt.PageAttributes.MediaType 中的静态变量
INVITE_ENVELOPE 的别名。
ENV_ITALY - 类 java.awt.PageAttributes.MediaType 中的静态变量
ITALY_ENVELOPE 的别名。
ENV_MONARCH - 类 java.awt.PageAttributes.MediaType 中的静态变量
MONARCH_ENVELOPE 的别名。
ENV_PERSONAL - 类 java.awt.PageAttributes.MediaType 中的静态变量
PERSONAL_ENVELOPE 的别名。
ENVELOPE - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的信封进纸托盘。
ENVELOPED - 接口 javax.xml.crypto.dsig.Transform 中的静态变量
Enveloped Signature 转换算法 URI。
environment() - 类 java.lang.ProcessBuilder 中的方法
返回此进程生成器环境的字符串映射视图。
environment - 异常 javax.naming.CannotProceedException 中的变量
包含与无法继续进行的 Context 或 DirContext 方法有关的环境。
Environment - org.omg.CORBA 中的 类
用于 Request 操作的异常的容器 (holder)，使异常可用于客户端。
Environment() - 类 org.omg.CORBA.Environment 的构造方法
eof - 异常 java.io.OptionalDataException 中的变量
如果流的缓冲部分不再有数据，则为 True。
EOFException - java.io 中的 异常
当输入过程中意外到达文件或流的末尾时，抛出此异常。
EOFException() - 异常 java.io.EOFException 的构造方法
构造 EOFException，使用 null 作为其错误详细消息。
EOFException(String) - 异常 java.io.EOFException 的构造方法
构造带有指定详细消息的 EOFException。
eolIsSignificant(boolean) - 类 java.io.StreamTokenizer 中的方法
确定是否将行末尾视为标记。
eos - 类 java.util.zip.GZIPInputStream 中的变量
指示输入流的结尾。
EQ - 类 javax.management.Query 中的静态变量
表示 Query.eq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
eq(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于两个值的等于约束条件。
EQUAL - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
比较结果。
equal(Any) - 类 org.omg.CORBA.Any 中的方法
检查此 Any 对象与给定 Any 对象是否相等。
equal(TypeCode) - 类 org.omg.CORBA.TypeCode 中的方法
将此 TypeCode 对象与给定对象比较，测试它们是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynStructStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynValueStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
比较两个 DynAny 值是否相等。
equals(Object) - 类 java.awt.AlphaComposite 中的方法
确定指定的对象是否等于此 AlphaComposite。
equals(Object) - 类 java.awt.AWTKeyStroke 中的方法
如果此对象与指定对象相同，则返回 true。
equals(Object) - 类 java.awt.BasicStroke 中的方法
测试指定对象与此 BasicStroke 是否相等，首先测试指定对象是否是一个 BasicStroke，然后将其宽度、连接、cap、斜接限制、虚线和虚线相位属性与 BasicStroke 的那些属性进行比较。
equals(Object) - 类 java.awt.Color 中的方法
确定另一个对象是否与此 Color 相同。
equals(Object) - 类 java.awt.datatransfer.DataFlavor 中的方法
测试任意 Object 与此 DataFlavor 的相等性。
equals(DataFlavor) - 类 java.awt.datatransfer.DataFlavor 中的方法
测试 DataFlavor 与此 DataFlavor 的相等性。
equals(String) - 类 java.awt.datatransfer.DataFlavor 中的方法
已过时。 与 hashCode() 协定不一致，使用 isMimeTypeEqual(String) 代替。
equals(Object) - 类 java.awt.Dimension 中的方法
检查两个 dimension 对象是否具有相同的值。
equals(DisplayMode) - 类 java.awt.DisplayMode 中的方法
返回对两个显示模式是否相同的判断。
equals(Object) - 类 java.awt.DisplayMode 中的方法
指示其他某个对象是否与此对象“相等”。
equals(Object) - 类 java.awt.Font 中的方法
将此 Font 对象与指定 Object 进行比较。
equals(Object) - 类 java.awt.font.FontRenderContext 中的方法
如果 obj 是 FontRenderContext 的一个实例，并且具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。
equals(FontRenderContext) - 类 java.awt.font.FontRenderContext 中的方法
如果 rhs 具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。
equals(GlyphVector) - 类 java.awt.font.GlyphVector 中的方法
测试指定的 GlyphVector 是否恰好等于此 GlyphVector。
equals(Object) - 类 java.awt.font.ImageGraphicAttribute 中的方法
比较此 ImageGraphicAttribute 与指定的 Object。
equals(ImageGraphicAttribute) - 类 java.awt.font.ImageGraphicAttribute 中的方法
比较此 ImageGraphicAttribute 与指定的 ImageGraphicAttribute。
equals(Object) - 类 java.awt.font.NumericShaper 中的方法
如果指定的对象是 NumericShaper 的一个实例，并且完全一致地成形到此实例，则返回 true。
equals(Object) - 类 java.awt.font.ShapeGraphicAttribute 中的方法
将此 ShapeGraphicAttribute 与指定的 Object 进行比较。
equals(ShapeGraphicAttribute) - 类 java.awt.font.ShapeGraphicAttribute 中的方法
将此 ShapeGraphicAttribute 与指定的 ShapeGraphicAttribute 进行比较。
equals(Object) - 类 java.awt.font.TextHitInfo 中的方法
如果指定的 Object 是一个 TextHitInfo 并且等于此 TextHitInfo，则返回 true。
equals(TextHitInfo) - 类 java.awt.font.TextHitInfo 中的方法
如果指定的 TextHitInfo 具有与此 TextHitInfo 相同的 charIndex 和 isLeadingEdge，则返回 true。
equals(Object) - 类 java.awt.font.TextLayout 中的方法
如果指定 Object 是一个 TextLayout 对象，且指定的 Object 等于此 TextLayout，则返回 true。
equals(TextLayout) - 类 java.awt.font.TextLayout 中的方法
如果两个布局相等，则返回 true。
equals(Object) - 类 java.awt.font.TransformAttribute 中的方法
如果 rhs 是一个变换等效于此 TransformAttribute 变换的 TransformAttribute，则返回 true。
equals(Object) - 类 java.awt.geom.AffineTransform 中的方法
如果此 AffineTransform 表示与指定参数相同的仿射坐标变换，则返回 true。
equals(Object) - 类 java.awt.geom.Arc2D 中的方法
确定指定的 Object 是否与此 Arc2D 相等。
equals(Area) - 类 java.awt.geom.Area 中的方法
测试两个 Area 对象的几何形状是否相等。
equals(Object) - 类 java.awt.geom.Ellipse2D 中的方法
确定指定的 Object 是否与此 Ellipse2D 相等。
equals(Object) - 类 java.awt.geom.Point2D 中的方法
确定两个点是否相等。
equals(Object) - 类 java.awt.geom.Rectangle2D 中的方法
确定指定的 Object 是否与此 Rectangle2D 相等。
equals(Object) - 类 java.awt.geom.RoundRectangle2D 中的方法
确定指定的 Object 是否与此 RoundRectangle2D 相等。
equals(Object) - 类 java.awt.image.ColorModel 中的方法
测试指定的 Object 是否是 ColorModel 的实例，以及它是否等于此 ColorModel。
equals(Object) - 类 java.awt.image.ComponentColorModel 中的方法
将此颜色模型与其他模型进行相等性比较。
equals(Object) - 类 java.awt.image.ComponentSampleModel 中的方法
equals(Object) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
equals(Object) - 类 java.awt.image.PackedColorModel 中的方法
测试指定的 Object 是否为 PackedColorModel 的一个实例并且等于此 PackedColorModel。
equals(Object) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
equals(Object) - 类 java.awt.Insets 中的方法
检查两个 insets 对象是否等价。
equals(Object) - 类 java.awt.JobAttributes 中的方法
确定两个 JobAttributes 是否相等。
equals(MenuShortcut) - 类 java.awt.MenuShortcut 中的方法
返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。
equals(Object) - 类 java.awt.MenuShortcut 中的方法
返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。
equals(Object) - 类 java.awt.PageAttributes 中的方法
确定两个 PageAttributes 是否相等。
equals(Object) - 类 java.awt.Point 中的方法
确定两个点是否相等。
equals(Object) - 类 java.awt.Rectangle 中的方法
检查两个矩形是否相等。
equals(Object) - 类 java.awt.RenderingHints 中的方法
对指定的 Object 与此 RenderingHints 进行相等性比较。
equals(Object) - 类 java.awt.RenderingHints.Key 中的方法
用于所有 Key 对象的 equals 方法将返回与等号运算符 '==' 相同的结果。
equals(Object) - 类 java.beans.IndexedPropertyDescriptor 中的方法
将此 PropertyDescriptor 与指定对象比较。
equals(Object) - 类 java.beans.PropertyDescriptor 中的方法
将此 PropertyDescriptor 与指定对象进行比较。
equals(Object) - 类 java.io.File 中的方法
测试此抽象路径名与给定对象是否相等。
equals(Object) - 类 java.io.FilePermission 中的方法
检查两个 FilePermission 对象是否相等。
equals(Object) - 接口 java.lang.annotation.Annotation 中的方法
如果指定的对象表示在逻辑上等效于此接口的注释，则返回 true。
equals(Object) - 类 java.lang.Boolean 中的方法
当且仅当参数不是 null，而是一个与此对象一样，都表示同一个 Boolean 值的 boolean 对象时，才返回 true。
equals(Object) - 类 java.lang.Byte 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.lang.Character 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.lang.Character.Subset 中的方法
比较两个 Subset 对象的相等性。
equals(Object) - 类 java.lang.Double 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.lang.Enum 中的方法
当指定对象等于此枚举常量时，返回 true。
equals(Object) - 类 java.lang.Float 中的方法
将此对象与指定对象进行比较。
equals(Object) - 类 java.lang.Integer 中的方法
比较此对象与指定对象。
equals(Object) - 类 java.lang.Long 中的方法
将此对象与指定对象进行比较。
equals(Object) - 类 java.lang.Object 中的方法
指示其他某个对象是否与此对象“相等”。
equals(Object) - 类 java.lang.reflect.Constructor 中的方法
将此 Constructor 对象与指定的对象进行比较。
equals(Object) - 类 java.lang.reflect.Field 中的方法
将此 Field 与指定对象比较。
equals(Object) - 类 java.lang.reflect.Method 中的方法
将此 Method 与指定对象进行比较。
equals(Object) - 类 java.lang.Short 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.lang.StackTraceElement 中的方法
如果指定的对象是另一个 StackTraceElement 实例，并且该对象表示的执行点与该实例的相同，则返回 ture。
equals(Object) - 类 java.lang.String 中的方法
将此字符串与指定的对象比较。
equals(Object) - 类 java.math.BigDecimal 中的方法
比较此 BigDecimal 与指定的 Object 的相等性。
equals(Object) - 类 java.math.BigInteger 中的方法
比较此 BigInteger 与指定的 Object 的相等性。
equals(Object) - 类 java.math.MathContext 中的方法
将此 MathContext 与指定的 Object 进行相等性比较。
equals(Object) - 类 java.net.HttpCookie 中的方法
测试两个 http cookie 的相等性。
equals(Object) - 类 java.net.Inet4Address 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.Inet6Address 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.InetAddress 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.InetSocketAddress 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.InterfaceAddress 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.NetworkInterface 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.Proxy 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.SocketPermission 中的方法
检查两个 SocketPermission 对象的相等性。
equals(Object) - 类 java.net.URI 中的方法
测试此 URI 与另一对象的相等性。
equals(Object) - 类 java.net.URL 中的方法
比较此 URL 是否等于另一个对象。
equals(URL, URL) - 类 java.net.URLStreamHandler 中的方法
提供默认的 equals 计算。
equals(Object) - 类 java.nio.ByteBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.CharBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.charset.Charset 中的方法
通知此对象是否和其他对象相等。
equals(Object) - 类 java.nio.DoubleBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.FloatBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.IntBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.LongBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.ShortBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.rmi.activation.ActivationDesc 中的方法
比较两个激活描述符的内容相等性。
equals(Object) - 类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 中的方法
比较两个命令环境的内容相等性。
equals(Object) - 类 java.rmi.activation.ActivationGroupDesc 中的方法
比较两个激活组描述符的内容相等性。
equals(Object) - 类 java.rmi.activation.ActivationGroupID 中的方法
比较两个组标识符的内容相等性。
equals(Object) - 类 java.rmi.activation.ActivationID 中的方法
比较两个激活 id 的内容相等性。
equals(Object) - 类 java.rmi.dgc.VMID 中的方法
将此 VMID 与另一个进行比较，如果它们是同一标识符，则返回 true。
equals(Object) - 类 java.rmi.MarshalledObject 中的方法
将此 MarshalledObject 与另一对象进行比较。
equals(Object) - 类 java.rmi.server.ObjID 中的方法
比较指定对象与此 ObjID 是否相等。
equals(Object) - 类 java.rmi.server.RemoteObject 中的方法
比较两个远程对象是否相等。
equals(Object) - 类 java.rmi.server.UID 中的方法
比较给定对象与此 UID 的相等性。
equals(Object) - 类 java.security.AccessControlContext 中的方法
检查两个 AccessControlContext 对象是否相等。
equals(Object) - 接口 java.security.acl.Permission 中的方法
如果传递的对象与此接口中所表示的权限相匹配，则返回 true。
equals(Object) - 类 java.security.AllPermission 中的方法
检查两个 AllPermission 对象是否相等。
equals(Object) - 类 java.security.BasicPermission 中的方法
检查两个 BasicPermission 对象是否相等。
equals(Object) - 类 java.security.cert.Certificate 中的方法
比较此证书与指定对象的相等性。
equals(Object) - 类 java.security.cert.CertPath 中的方法
比较此证书路径与指定对象的相等性。
equals(Object) - 类 java.security.cert.X509CRL 中的方法
比较此 CRL 与给定对象的相等性。
equals(Object) - 类 java.security.cert.X509CRLEntry 中的方法
比较此 CRL 项与给定对象的相等性。
equals(Object) - 类 java.security.CodeSigner 中的方法
测试指定对象与此代码签名者之间是否相等。
equals(Object) - 类 java.security.CodeSource 中的方法
测试指定对象与此对象之间的相等性。
equals(Object) - 类 java.security.Identity 中的方法
已过时。 测试指定对象与此 Identity 的相等性。
equals(Object) - 类 java.security.Permission 中的方法
检查两个 Permission 对象是否相等。
equals(Object) - 接口 java.security.Principal 中的方法
将此主体与指定对象比较。
equals(Object) - 类 java.security.spec.ECFieldF2m 中的方法
比较此有限字段与指定对象的相等性。
equals(Object) - 类 java.security.spec.ECFieldFp 中的方法
比较此素数有限字段与指定对象的相等性。
equals(Object) - 类 java.security.spec.ECPoint 中的方法
比较此椭圆曲线点与指定对象的相等性。
equals(Object) - 类 java.security.spec.EllipticCurve 中的方法
比较此椭圆曲线与指定对象的相等性。
equals(Object) - 类 java.security.Timestamp 中的方法
比较指定的对象和此时间戳之间的相同性。
equals(Object) - 类 java.security.UnresolvedPermission 中的方法
检查两个 UnresolvedPermission 对象的相等性。
equals(Object) - 接口 java.sql.RowId 中的方法
将此 RowId 与指定对象比较。
equals(Timestamp) - 类 java.sql.Timestamp 中的方法
测试此 Timestamp 对象是否等于给定的 Timestamp 对象。
equals(Object) - 类 java.sql.Timestamp 中的方法
测试此对象是否等于给定的 Timestamp 对象。
equals(Object) - 类 java.text.AttributedCharacterIterator.Attribute 中的方法
比较两个对象的相等性。
equals(Object) - 类 java.text.ChoiceFormat 中的方法
两个对象之间的相等性比较。
equals(String, String) - 类 java.text.Collator 中的方法
根据此 Collator 的整理规则比较两个字符串是否相等的便捷方法。
equals(Object) - 类 java.text.Collator 中的方法
比较两个 Collator 的相等性。
equals(Object) - 类 java.text.DateFormat 中的方法
重写 equals
equals(Object) - 类 java.text.DateFormatSymbols 中的方法
重写 equals。
equals(Object) - 类 java.text.DecimalFormat 中的方法
重写 equals
equals(Object) - 类 java.text.DecimalFormatSymbols 中的方法
重写 equals。
equals(Object) - 类 java.text.FieldPosition 中的方法
重写 equals
equals(Object) - 类 java.text.MessageFormat 中的方法
两个消息格式对象之间的相等性比较
equals(Object) - 类 java.text.NumberFormat 中的方法
重写 equals
equals(Object) - 类 java.text.ParsePosition 中的方法
重写 equals
equals(Object) - 类 java.text.RuleBasedCollator 中的方法
比较两个 collation 对象的相等性。
equals(Object) - 类 java.text.SimpleDateFormat 中的方法
比较给定对象与此 SimpleDateFormat 的相等性。
equals(Object) - 类 java.text.StringCharacterIterator 中的方法
比较两个 StringCharacterIterator 对象的相等性。
equals(Object) - 类 java.util.AbstractList 中的方法
将指定的对象与此列表进行相等性比较。
equals(Object) - 类 java.util.AbstractMap 中的方法
比较指定对象与此映射的相等性。
equals(Object) - 类 java.util.AbstractMap.SimpleEntry 中的方法
比较指定对象与此项的相等性。
equals(Object) - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
比较指定对象与此项的相等性。
equals(Object) - 类 java.util.AbstractSet 中的方法
比较指定对象与此 set 的相等性。
equals(long[], long[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 long 型数组彼此相等，则返回 true。
equals(int[], int[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 int 型数组彼此相等，则返回 true。
equals(short[], short[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 short 型数组彼此相等，则返回 true。
equals(char[], char[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 char 型数组彼此相等，则返回 true。
equals(byte[], byte[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 byte 型数组彼此相等，则返回 true。
equals(boolean[], boolean[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 boolean 型数组彼此相等，则返回 true。
equals(double[], double[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 double 型数组彼此相等，则返回 true。
equals(float[], float[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 float 型数组彼此相等，则返回 true。
equals(Object[], Object[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 Objects 数组彼此相等，则返回 true。
equals(Object) - 类 java.util.BitSet 中的方法
将此对象与指定的对象进行比较。
equals(Object) - 类 java.util.Calendar 中的方法
将此 Calendar 与指定 Object 比较。
equals(Object) - 接口 java.util.Collection 中的方法
比较此 collection 与指定对象是否相等。
equals(Object) - 接口 java.util.Comparator 中的方法
指示某个其他对象是否“等于”此 Comparator。
equals(Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
比较指定对象与此映射的相等性。
equals(Object) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
比较指定对象与此 set 的相等性。
equals(Object) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
比较指定对象与此列表的相等性。
equals(Object) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
比较指定对象与此 set 的相等性。
equals(Object) - 类 java.util.Date 中的方法
比较两个日期的相等性。
equals(Object) - 类 java.util.EnumMap 中的方法
比较指定对象与此映射的相等性。
equals(Object) - 类 java.util.GregorianCalendar 中的方法
比较此 GregorianCalendar 与指定的 Object。
equals(Object) - 类 java.util.Hashtable 中的方法
按照 Map 接口的定义，比较指定 Object 与此 Map 是否相等。
equals(Object) - 类 java.util.IdentityHashMap 中的方法
比较指定对象与此映射的相等性。
equals(Object) - 类 java.util.jar.Attributes 中的方法
将指定的 Attributes 对象与此 Map 进行相等性比较。
equals(Object) - 类 java.util.jar.Attributes.Name 中的方法
将此属性名称与另一个属性名称进行相等性比较。
equals(Object) - 类 java.util.jar.Manifest 中的方法
如果指定的 Object 也是一个 Manifest，并且具有相同的主 Attributes 和条目，则返回 true。
equals(Object) - 接口 java.util.List 中的方法
比较指定的对象与列表是否相等。
equals(Object) - 类 java.util.Locale 中的方法
如果该 Locale 等于另一个对象，则返回 true。
equals(Object) - 类 java.util.logging.Level 中的方法
比较两个对象值的相等性。
equals(Object) - 接口 java.util.Map.Entry 中的方法
比较指定对象与此项的相等性。
equals(Object) - 接口 java.util.Map 中的方法
比较指定的对象与此映射是否相等。
equals(Object) - 类 java.util.PropertyPermission 中的方法
检查两个 PropertyPermission 对象是否相等。
equals(Object) - 接口 java.util.Set 中的方法
比较指定对象与此 set 的相等性。
equals(Object) - 类 java.util.SimpleTimeZone 中的方法
比较两个 SimpleTimeZone 对象的相等性。
equals(Object) - 类 java.util.UUID 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.util.Vector 中的方法
比较指定对象与此向量的相等性。
equals(DataFlavor) - 类 javax.activation.ActivationDataFlavor 中的方法
将传入的 DataFlavor 与此 DataFlavor 进行比较；调用 isMimeTypeEqual 方法。
equals(Object) - 类 javax.crypto.spec.RC2ParameterSpec 中的方法
测试给定对象与此对象的相等性。
equals(Object) - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
测试给定对象与此对象的相等性。
equals(Object) - 类 javax.crypto.spec.SecretKeySpec 中的方法
测试给定对象与此对象的相等性。
equals(Object) - 类 javax.imageio.ImageTypeSpecifier 中的方法
如果给定 Object 是一个 ImageTypeSpecifier 并且具有与此对象相同的 SampleModel 和 ColorModel，则返回 true。
equals(Object) - 接口 javax.lang.model.element.Element 中的方法
如果参数表示与此元素相同的元素，则返回 true；否则返回 false。
equals(Object) - 接口 javax.lang.model.element.Name 中的方法
如果参数表示与 this 相同的名称，则返回 true，否则返回 false。
equals(Object) - 接口 javax.lang.model.type.TypeMirror 中的方法
遵守 Object.equals 的常规协定。
equals(Object) - 类 javax.management.Attribute 中的方法
比较当前的 Attribute Object 与另一个 Attribute Object。
equals(Object) - 接口 javax.management.Descriptor 中的方法
将此描述符与给定对象比较。
equals(Object) - 类 javax.management.ImmutableDescriptor 中的方法
将此描述符与给定对象进行比较。
equals(Object) - 类 javax.management.MBeanAttributeInfo 中的方法
比较此 MBeanAttributeInfo 与另一个 MBeanAttributeInfo。
equals(Object) - 类 javax.management.MBeanConstructorInfo 中的方法
比较此 MBeanConstructorInfo 与另一个 MBeanConstructorInfo。
equals(Object) - 类 javax.management.MBeanFeatureInfo 中的方法
比较此 MBeanFeatureInfo 与另一个 MBeanFeatureInfo。
equals(Object) - 类 javax.management.MBeanInfo 中的方法
比较此 MBeanInfo 与另一个 MBeanInfo。
equals(Object) - 类 javax.management.MBeanNotificationInfo 中的方法
把此 MBeanNotificationInfo 与另一个 MBeanNotificationInfo 进行比较。
equals(Object) - 类 javax.management.MBeanOperationInfo 中的方法
比较此 MBeanOperationInfo 与另一个 MBeanOperationInfo。
equals(Object) - 类 javax.management.MBeanParameterInfo 中的方法
比较此 MBeanParameterInfo 与另一个 MBeanParameterInfo。
equals(Object) - 类 javax.management.MBeanPermission 中的方法
检查两个 MBeanPermission 对象的相等性。
equals(Object) - 类 javax.management.MBeanServerPermission 中的方法
检查两个 MBeanServerPermission 对象的相等性。
equals(Object) - 类 javax.management.modelmbean.DescriptorSupport 中的方法
将此描述符与给定对象比较。
equals(Object) - 类 javax.management.ObjectInstance 中的方法
比较当前的 ObjectInstance 与另一个 ObjectInstance 是否相等。
equals(Object) - 类 javax.management.ObjectName 中的方法
比较当前的对象名与另一个对象名是否相等。
equals(Object) - 类 javax.management.openmbean.ArrayType 中的方法
比较指定的 obj 参数与此 ArrayType 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.CompositeData 中的方法
比较指定 obj 参数与此 CompositeData 实例的相等性。
equals(Object) - 类 javax.management.openmbean.CompositeDataSupport 中的方法
比较指定的 obj 参数与此 CompositeDataSupport 实例的相等性。
equals(Object) - 类 javax.management.openmbean.CompositeType 中的方法
比较指定的 obj 参数与此 CompositeType 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
比较指定的 obj 参数与此 OpenMBeanAttributeInfo 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
比较指定 obj 参数与此 OpenMBeanAttributeInfoSupport 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
比较指定的 obj 参数与此 OpenMBeanConstructorInfo 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 中的方法
比较指定 obj 参数与此 OpenMBeanConstructorInfoSupport 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
比较指定 obj 参数与此 OpenMBeanInfo 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenMBeanInfoSupport 中的方法
比较指定 obj 参数与此 OpenMBeanInfoSupport 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
比较指定 obj 参数与此 OpenMBeanOperationInfo 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 中的方法
比较指定的 obj 参数与此 OpenMBeanOperationInfoSupport 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
比较指定的 obj 参数与此 OpenMBeanParameterInfo 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
比较指定的 obj 参数与此 OpenMBeanParameterInfoSupport 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenType 中的方法
比较指定的 obj 参数与此开放类型实例的相等性。
equals(Object) - 类 javax.management.openmbean.SimpleType 中的方法
比较指定 obj 参数与此 SimpleType 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.TabularData 中的方法
比较指定的 obj 参数与此 TabularData 实例的相等性。
equals(Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
比较指定的 obj 参数与此 TabularDataSupport 实例的相等性。
equals(Object) - 类 javax.management.openmbean.TabularType 中的方法
比较指定的 obj 参数与此 TabularType 实例的相等性。
equals(Object) - 类 javax.management.remote.JMXPrincipal 中的方法
比较指定的 Object 与此 JMXPrincipal 是否相等。
equals(Object) - 类 javax.management.remote.JMXServiceURL 中的方法
指示是否有其他的对象等于此对象。
equals(Object) - 类 javax.naming.BinaryRefAddr 中的方法
确定 obj 是否等于此地址。
equals(Object) - 类 javax.naming.CompositeName 中的方法
确定两个复合名称是否相等。
equals(Object) - 类 javax.naming.CompoundName 中的方法
确定 obj 在语法上是否等同于此组合名称。
equals(Object) - 类 javax.naming.directory.BasicAttribute 中的方法
确定 obj 是否等于此属性。
equals(Object) - 类 javax.naming.directory.BasicAttributes 中的方法
确定此 BasicAttributes 是否等于另一个 Attributes。
equals(Object) - 类 javax.naming.ldap.LdapName 中的方法
确定两个 LDAP 名称是否相等。
equals(Object) - 类 javax.naming.ldap.Rdn 中的方法
比较指定 Object 与此 Rdn 的相等性。
equals(Object) - 类 javax.naming.RefAddr 中的方法
确定 obj 是否等于此 RefAddr。
equals(Object) - 类 javax.naming.Reference 中的方法
确定 obj 是否是一个与此引用具有相同地址（按相同顺序）的引用。
equals(Object) - 接口 javax.print.attribute.AttributeSet 中的方法
比较指定的对象与此属性集的相等性。
equals(Object) - 类 javax.print.attribute.DateTimeSyntax 中的方法
返回此日期-时间属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.HashAttributeSet 中的方法
比较指定的对象与此属性集的相等性。
equals(Object) - 类 javax.print.attribute.IntegerSyntax 中的方法
返回此整数属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回此分辨率属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
返回此整数集属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.Size2DSyntax 中的方法
返回此二维大小属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.Copies 中的方法
返回此副本属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.CopiesSupported 中的方法
返回支持副本的此属性是否等于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.DateTimeAtCompleted 中的方法
返回此 DateTimeAtCompleted 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.DateTimeAtCreation 中的方法
返回此 DateTimeAtCreation 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.DateTimeAtProcessing 中的方法
返回此 DateTimeAtProcessing 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.Destination 中的方法
返回此目标属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.DocumentName 中的方法
返回此文档名称属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobHoldUntil 中的方法
返回此 JobHoldUntil 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobImpressions 中的方法
返回此作业印张属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobImpressionsCompleted 中的方法
返回此 JobImpressionsCompleted 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobImpressionsSupported 中的方法
返回此 JobImpressionsSupported 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobKOctets 中的方法
返回此 JobKOctets 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobKOctetsProcessed 中的方法
返回此 JobKOctetsProcessed 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobKOctetsSupported 中的方法
返回此 JobKOctetsSupported 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobMediaSheets 中的方法
返回此 JobMediaSheets 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobMediaSheetsCompleted 中的方法
返回此 JobMediaSheetsCompleted 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobMediaSheetsSupported 中的方法
返回支持的此 JobMediaSheetsSupported 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobMessageFromOperator 中的方法
返回 Operator 属性传来的此作业消息是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobName 中的方法
返回此作业名称属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobOriginatingUserName 中的方法
返回此 JobOriginatingUserName 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobPriority 中的方法
返回此作业优先级属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobPrioritySupported 中的方法
返回支持的此作业优先级属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.Media 中的方法
返回此介质属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
返回此介质页边距属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.MediaSize 中的方法
返回此介质尺寸属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.NumberOfDocuments 中的方法
返回此文档数属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.NumberOfInterveningJobs 中的方法
返回此 NumberOfInterveningJobs 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.NumberUp 中的方法
返回此计数属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.NumberUpSupported 中的方法
返回此 NumberUpSupported 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.OutputDeviceAssigned 中的方法
返回此 OutputDeviceAssigned 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PageRanges 中的方法
返回此 PageRanges 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PagesPerMinute 中的方法
返回此 PagesPerMinute 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PagesPerMinuteColor 中的方法
返回此 PagesPerMinuteColor 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterInfo 中的方法
返回此 PrinterInfo 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterLocation 中的方法
返回此 PrinterLocation 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterMakeAndModel 中的方法
返回此 PrinterMakeAndModel 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterMessageFromOperator 中的方法
返回此 PrinterMessageFromOperator 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterMoreInfo 中的方法
返回此 PrinterMoreInfo 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 中的方法
返回此 PrinterMoreInfoManufacturer 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterName 中的方法
返回此 PrinterName 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterResolution 中的方法
返回此 PrinterResolution 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterURI 中的方法
返回此打印机名称属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.QueuedJobCount 中的方法
返回此 QueuedJobCount 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.RequestingUserName 中的方法
返回此 RequestingUserName 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.TextSyntax 中的方法
返回此文本属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.URISyntax 中的方法
返回此 URI 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.DocFlavor 中的方法
确定此 DocFlavor 对象是否等于给定的对象。
equals(Object) - 接口 javax.print.PrintService 中的方法
确定两个服务是否引用相同的底层服务。
equals(Object) - 类 javax.rmi.CORBA.Stub 中的方法
比较两个 stub 的相等性。
equals(Stub, Object) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.equals(java.lang.Object) 的委托调用。
equals(Object) - 类 javax.rmi.ssl.SslRMIClientSocketFactory 中的方法
指示某个其他对象是否“等于”此对象。
equals(Object) - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
指示某个其他对象是否“等于”此对象。
equals(Object) - 类 javax.security.auth.kerberos.DelegationPermission 中的方法
检查两个 DelegationPermission 对象是否相等。
equals(Object) - 类 javax.security.auth.kerberos.KerberosKey 中的方法
比较指定 Object 与此 KerberosKey 的相等性。
equals(Object) - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
比较指定的对象与此 Principal 是否相等。
equals(Object) - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
比较给定 Object 与此 KerberosTicket 的相等性。
equals(Object) - 类 javax.security.auth.kerberos.ServicePermission 中的方法
检查两个 ServicePermission 对象是否相等。
equals(Object) - 类 javax.security.auth.PrivateCredentialPermission 中的方法
检查两个 PrivateCredentialPermission 对象是否相等。
equals(Object) - 类 javax.security.auth.Subject 中的方法
比较指定对象与此 Subject 的相等性。
equals(Object) - 类 javax.security.auth.x500.X500Principal 中的方法
比较指定的 Object 与此 X500Principal 的相等性。
equals(Object) - 类 javax.security.cert.Certificate 中的方法
比较此证书是否与指定对象相等。
equals(Object) - 类 javax.sound.midi.MidiDevice.Info 中的方法
报告两个对象是否相等。
equals(Object) - 类 javax.sound.midi.Sequencer.SyncMode 中的方法
确定两个对象是否等价。
equals(Object) - 类 javax.sound.sampled.AudioFileFormat.Type 中的方法
终止 equals 方法
equals(Object) - 类 javax.sound.sampled.AudioFormat.Encoding 中的方法
终止 equals 方法
equals(Object) - 类 javax.sound.sampled.Control.Type 中的方法
终止 equals 方法
equals(Object) - 类 javax.sound.sampled.LineEvent.Type 中的方法
指示指定对象是否等于此事件类型，如果对象是相同的，则返回 true。
equals(Object) - 类 javax.sound.sampled.Mixer.Info 中的方法
指示两个 info 对象是否相等；如果相等，则返回 true。
equals(Object) - 类 javax.sound.sampled.Port.Info 中的方法
终止 equals 方法
equals(Object) - 类 javax.sound.sampled.ReverbType 中的方法
指示指定对象是否等于此回响类型，如果对象相同，则返回 true。
equals(Object) - 类 javax.swing.RowSorter.SortKey 中的方法
如果此对象与指定对象相等，则返回 true。
equals(Object) - 类 javax.swing.text.DefaultCaret 中的方法
将此对象与指定的对象进行比较。
equals(Object) - 类 javax.swing.text.html.HTML.UnknownTag 中的方法
将此对象与指定对象进行比较。
equals(Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
将该对象与指定对象比较。
equals(Object) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
将此对象与指定对象比较。
equals(Object) - 类 javax.swing.text.TabSet 中的方法
指示此 TabSet 是否与另一个相等。
equals(Object) - 类 javax.swing.text.TabStop 中的方法
如果制表符相等，则返回 true。
equals(Object) - 类 javax.swing.tree.TreePath 中的方法
通过检查路径中每个元素的相等性，测试两个 TreePaths 的相等性。
equals(Object) - 类 javax.xml.datatype.Duration 中的方法
检查此持续时间对象是否与另一个 Duration 对象具有相同的持续时间。
equals(Object) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将此日历与指定的对象进行比较。
equals(Object) - 类 javax.xml.namespace.QName 中的方法
测试此 QName 与另一个 Object 的相等性。
equals(Object) - 类 org.ietf.jgss.ChannelBinding 中的方法
比较 ChannelBinding 的两个实例。
equals(Object) - 接口 org.ietf.jgss.GSSCredential 中的方法
进行测试，看此 GSSCredential 是否具有与提供的对象相同的实体。
equals(GSSName) - 接口 org.ietf.jgss.GSSName 中的方法
比较两个 GSSName 对象，以确定它们是否指的是同一个实体。
equals(Object) - 接口 org.ietf.jgss.GSSName 中的方法
将此 GSSName 对象与可能是 GSSName 的另一个对象进行比较。
equals(Object) - 类 org.ietf.jgss.Oid 中的方法
测试两个 Oid 对象是否表示相同的 Object 标识符值。
equals(Object, Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
提供重写委托 CORBA 对象方法 equals(java.lang.Object obj) 的实现。
equals(Object) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
比较此 ObjectImpl 对象与给定对象是否相等。
equalsIgnoreCase(String) - 类 java.lang.String 中的方法
将此 String 与另一个 String 比较，不考虑大小写。
equivalent(TypeCode) - 类 org.omg.CORBA.TypeCode 中的方法
测试给定 TypeCode 对象是否等于此 TypeCode 对象。
ERA - 类 java.text.DateFormat.Field 中的静态变量
标识 ERA 字段的常量。
ERA - 类 java.util.Calendar 中的静态变量
指示年代的 get 和 set 的字段数字，比如罗马儒略历中的 AD 或 BC。
ERA_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 ERA 字段的有用常量。
erasure(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回删除状态的类型。
err - 类 java.io.FileDescriptor 中的静态变量
标准错误流的句柄。
err - 类 java.lang.System 中的静态变量
“标准”错误输出流。
ERROR - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示被异步跟踪的图像遇到了错误。
Error - java.lang 中的 错误
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Error() - 错误 java.lang.Error 的构造方法
构造详细消息为 null 的新错误。
Error(String) - 错误 java.lang.Error 的构造方法
构造带指定详细消息的新错误。
Error(String, Throwable) - 错误 java.lang.Error 的构造方法
构造带指定详细消息和原因的新错误。
Error(Throwable) - 错误 java.lang.Error 的构造方法
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息来构造新的错误（通常包含 cause 的类和详细消息）。
ERROR - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "error"，某些属性的可能值。
error(String, Exception, int) - 类 java.util.logging.ErrorManager 中的方法
在发生 Handler 失败时调用 error 方法。
ERROR - 类 javax.print.attribute.standard.Severity 中的静态变量
指示 PrinterStateReason 是 "error"（最严重）。
ERROR - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
ERROR 消息类型。
ERROR - 类 javax.security.auth.callback.TextOutputCallback 中的静态变量
错误消息。
error(String, String, String, String) - 类 javax.swing.text.html.parser.Parser 中的方法
调用错误处理程序。
error(String, String, String) - 类 javax.swing.text.html.parser.Parser 中的方法
error(String, String) - 类 javax.swing.text.html.parser.Parser 中的方法
error(String) - 类 javax.swing.text.html.parser.Parser 中的方法
ERROR - 接口 javax.xml.bind.ValidationEvent 中的静态变量
对应于 W3C XML 1.0 Recommendation 第 1.2 节中的“错误”的定义的条件。
error(TransformerException) - 接口 javax.xml.transform.ErrorListener 中的方法
接收可恢复错误的通知。
error(SAXParseException) - 接口 org.xml.sax.ErrorHandler 中的方法
接收可恢复的错误的通知。
error(SAXParseException) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收可恢复的解析器错误的通知。
error(SAXParseException) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收可恢复的解析器错误的通知。
error(SAXParseException) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个错误事件。
ERROR_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
ERROR_MESSAGE - 类 javax.swing.JOptionPane 中的静态变量
用于错误消息。
ERROR_OPTION - 类 javax.swing.JFileChooser 中的静态变量
发生错误后返回该值。
errorCode - 异常 javax.transaction.xa.XAException 中的变量
用其创建 SystemException 的错误代码。
ERRORED - 类 java.awt.MediaTracker 中的静态变量
指示媒体下载出错的标志。
ErrorHandler - org.xml.sax 中的 接口
SAX 错误处理程序的基本接口。
ErrorListener - javax.xml.transform 中的 接口
要提供自定义错误处理，则需实现此接口并使用 setErrorListener 方法注册一个带有 Transformer 的实现的实例。
ErrorManager - java.util.logging 中的 类
可将 ErrorManager 对象附加到 Handler，以便处理日志记录过程中 Handler 上所发生的错误。
ErrorManager() - 类 java.util.logging.ErrorManager 的构造方法
errorRaised() - 接口 javax.annotation.processing.RoundEnvironment 中的方法
如果在以前的处理 round 中发生错误，则返回 true；否则返回 false。
ErrorType - javax.lang.model.type 中的 接口
表示无法正常建模的类或接口类型。
errorWriter - 类 javax.script.SimpleScriptContext 中的变量
此字段是用于脚本输出错误的 writer。
ESCAPE - 类 java.awt.Event 中的静态变量
Escape 键。
escapeValue(Object) - 类 javax.naming.ldap.Rdn 中的静态方法
在给定属性值的情况下返回根据 RFC 2253 中指定的规则转义的字符串。
establish_components(IORInfo) - 接口 org.omg.PortableInterceptor.IORInterceptorOperations 中的方法
在汇编将包括在对象引用配置文件中的组件列表时，服务器端 ORB 对所有已注册 IORInterceptor 实例调用 establish_components 操作。
EtchedBorder - javax.swing.border 中的 类
该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。
EtchedBorder() - 类 javax.swing.border.EtchedBorder 的构造方法
创建一个阴刻浮雕化类型的边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生。
EtchedBorder(int) - 类 javax.swing.border.EtchedBorder 的构造方法
创建具有指定蚀刻类型的浮雕化边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生
EtchedBorder(Color, Color) - 类 javax.swing.border.EtchedBorder 的构造方法
创建具有指定高亮显示和阴影颜色的阴刻浮雕化边框
EtchedBorder(int, Color, Color) - 类 javax.swing.border.EtchedBorder 的构造方法
创建具有指定蚀刻类型、高亮显示和阴影颜色的浮雕化边框
etchType - 类 javax.swing.border.EtchedBorder 中的变量
etherealize(byte[], POA, Servant, boolean, boolean) - 类 org.omg.PortableServer._ServantActivatorStub 中的方法
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要停用对象的 servant 就会调用此操作。
etherealize(byte[], POA, Servant, boolean, boolean) - 接口 org.omg.PortableServer.ServantActivatorOperations 中的方法
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要取消激活对象的 servant 就会调用此操作。
ETHIOPIC - 类 java.awt.font.NumericShaper 中的静态变量
标识 ETHIOPIC 范围和十进制基数。
ETHIOPIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Ethiopic”Unicode 字符块的常量。
EUROPEAN - 类 java.awt.font.NumericShaper 中的静态变量
标识 Latin-1（欧洲语）和扩展范围，以及 Latin-1（欧洲语）十进制基数。
eval(Reader, Bindings) - 类 javax.script.AbstractScriptEngine 中的方法
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。
eval(String, Bindings) - 类 javax.script.AbstractScriptEngine 中的方法
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。
eval(Reader) - 类 javax.script.AbstractScriptEngine 中的方法
eval(Reader) 调用抽象 eval(Reader, ScriptContext)，并传递 context 字段的值给它。
eval(String) - 类 javax.script.AbstractScriptEngine 中的方法
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader) 相同。
eval(ScriptContext) - 类 javax.script.CompiledScript 中的方法
执行存储在此 CompiledScript 对象中的程序。
eval(Bindings) - 类 javax.script.CompiledScript 中的方法
执行存储在 CompiledScript 对象中的程序，脚本执行期间使用所提供的属性的 Bindings 作为关联 ScriptEngine 的 ENGINE_SCOPE。
eval() - 类 javax.script.CompiledScript 中的方法
执行存储在 CompiledScript 对象中的程序。
eval(String, ScriptContext) - 接口 javax.script.ScriptEngine 中的方法
立即执行脚本，该脚本的源是作为第一个参数传递的 String。
eval(Reader, ScriptContext) - 接口 javax.script.ScriptEngine 中的方法
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。
eval(String) - 接口 javax.script.ScriptEngine 中的方法
执行指定的脚本。
eval(Reader) - 接口 javax.script.ScriptEngine 中的方法
除了脚本的源是以 Reader 形式提供的外，与 eval(String) 相同。
eval(String, Bindings) - 接口 javax.script.ScriptEngine 中的方法
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。
eval(Reader, Bindings) - 接口 javax.script.ScriptEngine 中的方法
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。
evaluate(RowSet) - 接口 javax.sql.rowset.Predicate 中的方法
此方法通常称为 FilteredRowSet 对象内部方法（非公共），它控制 RowSet 对象的指针从一行移动到下一行。
evaluate(Object, int) - 接口 javax.sql.rowset.Predicate 中的方法
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter() 方法设置的过滤标准（或标准，如果存在多个约束）中。
evaluate(Object, String) - 接口 javax.sql.rowset.Predicate 中的方法
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter 方法设置的过滤标准中。
evaluate(String, Object, QName) - 接口 javax.xml.xpath.XPath 中的方法
计算指定上下文中的 XPath 表达式并返回指定类型的结果。
evaluate(String, Object) - 接口 javax.xml.xpath.XPath 中的方法
计算指定上下文中的 XPath 表达式并返回 String 形式的结果。
evaluate(String, InputSource, QName) - 接口 javax.xml.xpath.XPath 中的方法
计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。
evaluate(String, InputSource) - 接口 javax.xml.xpath.XPath 中的方法
计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。
evaluate(Object, QName) - 接口 javax.xml.xpath.XPathExpression 中的方法
计算指定上下文中的 XPath 表达式并返回指定类型的结果。
evaluate(Object) - 接口 javax.xml.xpath.XPathExpression 中的方法
计算指定上下文中编译后的 XPath 表达式并以 String 形式返回结果。
evaluate(InputSource, QName) - 接口 javax.xml.xpath.XPathExpression 中的方法
计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。
evaluate(InputSource) - 接口 javax.xml.xpath.XPathExpression 中的方法
计算指定 InputSource 上下文中编译后的 XPath 表达式并以 String 形式返回结果。
evaluate(List) - 接口 javax.xml.xpath.XPathFunction 中的方法
计算带指定参数的函数。
evaluateChallenge(byte[]) - 接口 javax.security.sasl.SaslClient 中的方法
评估 challenge 数据并生成一个响应。
evaluateResponse(byte[]) - 接口 javax.security.sasl.SaslServer 中的方法
评估响应数据并生成一个 challenge。
Event - java.awt 中的 类
注：Event 类已废弃，只可用于向后兼容。
Event(Object, long, int, int, int, int, int, Object) - 类 java.awt.Event 的构造方法
注：Event 类已废弃，只可用于向后兼容。
Event(Object, long, int, int, int, int, int) - 类 java.awt.Event 的构造方法
注：Event 类已废弃，只可用于向后兼容。
Event(Object, int, Object) - 类 java.awt.Event 的构造方法
注：Event 类已废弃，只可用于向后兼容。
event - 异常 javax.swing.tree.ExpandVetoException 中的变量
为其创建异常的事件。
Event - org.w3c.dom.events 中的 接口
Event 接口用于为处理事件的处理程序提供关于事件的上下文信息。
EventContext - javax.naming.event 中的 接口
包含注册/注销侦听器的一些方法，这些侦听器在上下文中命名的对象发生更改时获得触发事件的通知。
EventDirContext - javax.naming.event 中的 接口
包含注册侦听器的一些方法，这些侦听器在目录上下文中命名的对象发生更改时将获得触发事件的通知。
eventDispatched(AWTEvent) - 接口 java.awt.event.AWTEventListener 中的方法
在 AWT 中指派事件时调用。
eventDispatched(AWTEvent) - 类 java.awt.event.AWTEventListenerProxy 中的方法
将属性更改事件转发给侦听器代理。
EventException - org.w3c.dom.events 中的 异常
事件操作可以像在其方法描述中指定的那样抛出 EventException。
EventException(short, String) - 异常 org.w3c.dom.events.EventException 的构造方法
EventFilter - javax.xml.stream 中的 接口
此接口声明了一个简单的过滤器接口，用户可创建它来过滤 XMLEventReader。
EventHandler - java.beans 中的 类
EventHandler 类为动态生成事件侦听器提供支持，这些侦听器的方法执行一条涉及传入事件对象和目标对象的简单语句。
EventHandler(Object, String, String, String) - 类 java.beans.EventHandler 的构造方法
创建一个新的 EventHandler 对象；通常使用 create 方法之一，而不是直接调用此构造方法。
EventListener - java.util 中的 接口
所有事件侦听器接口必须扩展的标记接口。
EventListener - org.w3c.dom.events 中的 接口
EventListener 接口是处理事件的主要方法。
EventListenerList - javax.swing.event 中的 类
保存 EventListener 列表的类。
EventListenerList() - 类 javax.swing.event.EventListenerList 的构造方法
EventListenerProxy - java.util 中的 类
将一组附加参数与侦听器关联的 EventListener 类的抽象包装器类。
EventListenerProxy(EventListener) - 类 java.util.EventListenerProxy 的构造方法
EventObject - java.util 中的 类
所有事件状态对象都将从其派生的根类。
EventObject(Object) - 类 java.util.EventObject 的构造方法
构造一个原型 Event。
EventQueue - java.awt 中的 类
EventQueue 是一个与平台无关的类，它将来自于底层同位体类和受信任的应用程序类的事件列入队列。
EventQueue() - 类 java.awt.EventQueue 的构造方法
EventReaderDelegate - javax.xml.stream.util 中的 类
该类是用于派生 XMLEventReader 过滤器的基类。
EventReaderDelegate() - 类 javax.xml.stream.util.EventReaderDelegate 的构造方法
构造没有父过滤器的空过滤器。
EventReaderDelegate(XMLEventReader) - 类 javax.xml.stream.util.EventReaderDelegate 的构造方法
用指定的父过滤器来构造一个过滤器。
events - 类 java.awt.dnd.DragGestureRecognizer 中的变量
DragGestureRecognizer“识别”为触发拖动的“动作”事件列表（按顺序）。
EventSetDescriptor - java.beans 中的 类
描述给定 Java bean 激发的一组事件的 EventSetDescriptor。
EventSetDescriptor(Class<?>, String, Class<?>, String) - 类 java.beans.EventSetDescriptor 的构造方法
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。
EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String) - 类 java.beans.EventSetDescriptor 的构造方法
使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String, String) - 类 java.beans.EventSetDescriptor 的构造方法
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(String, Class<?>, Method[], Method, Method) - 类 java.beans.EventSetDescriptor 的构造方法
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String, Class<?>, Method[], Method, Method, Method) - 类 java.beans.EventSetDescriptor 的构造方法
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String, Class<?>, MethodDescriptor[], Method, Method) - 类 java.beans.EventSetDescriptor 的构造方法
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventTarget - org.w3c.dom.events 中的 接口
EventTarget 接口由支持 DOM Event Model 的实现中的所有 Nodes 实现。
eventTypeEnabled(int) - 类 java.awt.ScrollPane 中的方法
如果启用滚轮滚动，则对 MouseWheelEvents 返回 true
evt - 类 java.awt.Event 中的变量
下一事件。
examineAllHeaderElements() - 接口 javax.xml.soap.SOAPHeader 中的方法
返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator。
examineHeaderElements(String) - 接口 javax.xml.soap.SOAPHeader 中的方法
返回可在此 SOAPHeader 对象中具有指定的 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator。
examineMustUnderstandHeaderElements(String) - 接口 javax.xml.soap.SOAPHeader 中的方法
返回可在此 SOAPHeader 对象中所有符合以下条件的 SOAPHeaderElement 对象上进行迭代的 Iterator：具有指定的 actor 以及一个值等于 true 的 MustUnderstand 属性。
ExcC14NParameterSpec - javax.xml.crypto.dsig.spec 中的 类
W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。
ExcC14NParameterSpec() - 类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 的构造方法
创建带有空前缀列表的 ExcC14NParameterSpec。
ExcC14NParameterSpec(List) - 类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 的构造方法
创建带有指定前缀列表的 ExcC14NParameterSpec。
ExcellentBreakWeight - 类 javax.swing.text.View 中的静态变量
该权重指示视图支持拆分，并且表示拆分的极好时机。
except(Any) - 类 org.omg.CORBA.ServerRequest 中的方法
已过时。 使用 set_exception()
except - 异常 org.omg.CORBA.UnknownUserException 中的变量
包含由服务器抛出的实际用户异常的 Any 实例。
Exception - java.lang 中的 异常
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Exception() - 异常 java.lang.Exception 的构造方法
构造详细消息为 null 的新异常。
Exception(String) - 异常 java.lang.Exception 的构造方法
构造带指定详细消息的新异常。
Exception(String, Throwable) - 异常 java.lang.Exception 的构造方法
构造带指定详细消息和原因的新异常。
Exception(Throwable) - 异常 java.lang.Exception 的构造方法
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造新异常（它通常包含 cause 的类和详细消息）。
exception() - 类 org.omg.CORBA.Environment 中的方法
检索此 Environment 对象中的异常。
exception(Exception) - 类 org.omg.CORBA.Environment 中的方法
将给定异常插入此 Environment 对象。
ExceptionDetailMessage - org.omg.IOP 中的 接口
org/omg/IOP/ExceptionDetailMessage.java。
ExceptionInInitializerError - java.lang 中的 错误
静态初始化程序中发生意外异常的信号。
ExceptionInInitializerError() - 错误 java.lang.ExceptionInInitializerError 的构造方法
构造一个 ExceptionInInitializerError，使用 null 作为其详细消息字符串，并且不使用任何保存的 throwable 对象。
ExceptionInInitializerError(Throwable) - 错误 java.lang.ExceptionInInitializerError 的构造方法
保存对抛出的 Throwable 对象的引用，以便以后通过 ExceptionInInitializerError.getException() 方法对其进行获取，通过这种方式构造一个新的 ExceptionInInitializerError 类。
ExceptionInInitializerError(String) - 错误 java.lang.ExceptionInInitializerError 的构造方法
构造带指定详细消息的 ExceptionInInitializerError。
ExceptionList - org.omg.CORBA 中的 类
Request 操作中使用的对象，用于描述可由某一方法抛出的异常。
ExceptionList() - 类 org.omg.CORBA.ExceptionList 的构造方法
ExceptionListener - java.beans 中的 接口
ExceptionListener 是在发生内部异常时获得通知。
exceptions() - 类 org.omg.CORBA.Request 中的方法
检索用于此请求的 ExceptionList 对象。
exceptions() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回一个 TypeCode 对象数组，这些对象描述此操作调用可能抛出的用户异常的 TypeCode。
exceptionThrown(Exception) - 接口 java.beans.ExceptionListener 中的方法
此方法在捕获可恢复的异常时调用。
exchange(V) - 类 java.util.concurrent.Exchanger 中的方法
等待另一个线程到达此交换点（除非当前线程被中断），然后将给定的对象传送给该线程，并接收该线程的对象。
exchange(V, long, TimeUnit) - 类 java.util.concurrent.Exchanger 中的方法
等待另一个线程到达此交换点（除非当前线程被中断，或者超出了指定的等待时间），然后将给定的对象传送给该线程，同时接收该线程的对象。
Exchanger<V> - java.util.concurrent 中的 类
可以在对中对元素进行配对和交换的线程的同步点。
Exchanger() - 类 java.util.concurrent.Exchanger 的构造方法
创建一个新的 Exchanger。
exclusions - 类 javax.swing.text.html.parser.Element 中的变量
EXCLUSIVE - 接口 javax.xml.crypto.dsig.CanonicalizationMethod 中的静态变量
Exclusive Canonical XML（不带注释）规范化方法的算法 URI。
EXCLUSIVE_WITH_COMMENTS - 接口 javax.xml.crypto.dsig.CanonicalizationMethod 中的静态变量
带注释的 Exclusive Canonical XML 规范化方法的算法 URI。
exclusiveOr(Area) - 类 java.awt.geom.Area 中的方法
将此 Area 的形状设置为其当前形状与指定 Area 形状的组合区域，并减去其交集。
exec(String) - 类 java.lang.Runtime 中的方法
在单独的进程中执行指定的字符串命令。
exec(String, String[]) - 类 java.lang.Runtime 中的方法
在指定环境的单独进程中执行指定的字符串命令。
exec(String, String[], File) - 类 java.lang.Runtime 中的方法
在有指定环境和工作目录的独立进程中执行指定的字符串命令。
exec(String[]) - 类 java.lang.Runtime 中的方法
在单独的进程中执行指定命令和变量。
exec(String[], String[]) - 类 java.lang.Runtime 中的方法
在指定环境的独立进程中执行指定命令和变量。
exec(String[], String[], File) - 类 java.lang.Runtime 中的方法
在指定环境和工作目录的独立进程中执行指定的命令和变量。
ExecutableElement - javax.lang.model.element 中的 接口
表示某个类或接口的方法、构造方法或初始化程序（静态或实例），包括注释类型元素。
ExecutableType - javax.lang.model.type 中的 接口
表示 executable 的类型。
execute() - 类 java.beans.Statement 中的方法
执行方法找到一个与 methodName 属性同名的方法，并在目标上调用该方法。
execute() - 接口 java.sql.PreparedStatement 中的方法
在此 PreparedStatement 对象中执行 SQL 语句，该语句可以是任何种类的 SQL 语句。
execute(String) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句，该语句可能返回多个结果。
execute(String, int) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序所有自动生成的键都应该可用于获取。
execute(String, int[]) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
execute(String, String[]) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
execute(Runnable) - 接口 java.util.concurrent.Executor 中的方法
在未来某个时间执行给定的命令。
execute(Runnable) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
使用所要求的零延迟执行命令。
execute(Runnable) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
在将来某个时间执行给定任务。
execute(Connection) - 接口 javax.sql.rowset.CachedRowSet 中的方法
用数据填充此 CachedRowSet 对象，使用给定的连接来生成从中读取数据的结果集。
execute() - 接口 javax.sql.RowSet 中的方法
使用数据填充此 RowSet 对象。
execute() - 类 javax.swing.SwingWorker 中的方法
调度此 SwingWorker 以便在 worker 线程上执行。
EXECUTE_FAILED - 接口 java.sql.Statement 中的静态变量
该常量指示在执行批量语句时发生错误。
executeBatch() - 接口 java.sql.Statement 中的方法
将一批命令提交给数据库来执行，如果全部命令执行成功，则返回更新计数组成的数组。
executeCall() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
executeQuery() - 接口 java.sql.PreparedStatement 中的方法
在此 PreparedStatement 对象中执行 SQL 查询，并返回该查询生成的 ResultSet 对象。
executeQuery(String) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句，该语句返回单个 ResultSet 对象。
executeUpdate() - 接口 java.sql.PreparedStatement 中的方法
在此 PreparedStatement 对象中执行 SQL 语句，该语句必须是一个 SQL 数据操作语言（Data Manipulation Language，DML）语句，比如 INSERT、UPDATE 或 DELETE 语句；或者是无返回内容的 SQL 语句，比如 DDL 语句。
executeUpdate(String) - 接口 java.sql.Statement 中的方法
执行给定 SQL 语句，该语句可能为 INSERT、UPDATE 或 DELETE 语句，或者不返回任何内容的 SQL 语句（如 SQL DDL 语句）。
executeUpdate(String, int) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句，并用给定标志通知驱动程序由此 Statement 生成的自动生成键是否可用于获取。
executeUpdate(String, int[]) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
executeUpdate(String, String[]) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
ExecutionException - java.util.concurrent 中的 异常
当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
ExecutionException() - 异常 java.util.concurrent.ExecutionException 的构造方法
构造不带详细消息的 ExecutionException。
ExecutionException(String) - 异常 java.util.concurrent.ExecutionException 的构造方法
构造带指定详细消息的 ExecutionException。
ExecutionException(String, Throwable) - 异常 java.util.concurrent.ExecutionException 的构造方法
构造带指定详细消息和原因的 ExecutionException。
ExecutionException(Throwable) - 异常 java.util.concurrent.ExecutionException 的构造方法
构造带指定原因的 ExecutionException。
EXECUTIVE - 类 java.awt.PageAttributes.MediaType 中的静态变量
Executive (7 1/4 x 10 1/2 in) 的 MediaType 实例。
EXECUTIVE - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 executive 尺寸，7.25 inch × 10.5 inch。
EXECUTIVE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
executive 尺寸。
Executor - java.util.concurrent 中的 接口
执行已提交的 Runnable 任务的对象。
ExecutorCompletionService<V> - java.util.concurrent 中的 类
使用提供的 Executor 来执行任务的 CompletionService。
ExecutorCompletionService(Executor) - 类 java.util.concurrent.ExecutorCompletionService 的构造方法
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将 LinkedBlockingQueue 作为完成队列。
ExecutorCompletionService(Executor, BlockingQueue<Future<V>>) - 类 java.util.concurrent.ExecutorCompletionService 的构造方法
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将所提供的队列作为其完成队列。
Executors - java.util.concurrent 中的 类
此包中所定义的 Executor、ExecutorService、ScheduledExecutorService、ThreadFactory 和 Callable 类的工厂和实用方法。
ExecutorService - java.util.concurrent 中的 接口
Executor 提供了管理终止的方法，以及可为跟踪一个或多个异步任务执行状况而生成 Future 的方法。
ExemptionMechanism - javax.crypto 中的 类
此类提供了豁免 (exemption) 机制的功能，例如，密钥恢复、密钥唤醒 和密钥托管。
ExemptionMechanism(ExemptionMechanismSpi, Provider, String) - 类 javax.crypto.ExemptionMechanism 的构造方法
创建 ExemptionMechanism 对象。
ExemptionMechanismException - javax.crypto 中的 异常
此为一般 ExemptionMechanism 异常。
ExemptionMechanismException() - 异常 javax.crypto.ExemptionMechanismException 的构造方法
构造不带详细消息的 ExemptionMechanismException。
ExemptionMechanismException(String) - 异常 javax.crypto.ExemptionMechanismException 的构造方法
构造带指定详细消息的 ExemptionMechanismException。
ExemptionMechanismSpi - javax.crypto 中的 类
此类为 ExemptionMechanism 类定义了服务提供者接口 (SPI)。
ExemptionMechanismSpi() - 类 javax.crypto.ExemptionMechanismSpi 的构造方法
exists() - 类 java.io.File 中的方法
测试此抽象路径名表示的文件或目录是否存在。
exit(int) - 类 java.lang.Runtime 中的方法
通过启动虚拟机的关闭序列，终止当前正在运行的 Java 虚拟机。
exit(int) - 类 java.lang.System 中的静态方法
终止当前正在运行的 Java 虚拟机。
EXIT_ON_CLOSE - 类 javax.swing.JFrame 中的静态变量
退出应用程序后的默认窗口关闭操作。
EXIT_ON_CLOSE - 接口 javax.swing.WindowConstants 中的静态变量
退出应用程序默认窗口关闭操作。
EXITED - 类 javax.swing.event.HyperlinkEvent.EventType 中的静态变量
退出类型。
exiting(String, String) - 类 java.util.logging.Logger 中的方法
记录一个方法返回。
exiting(String, String, Object) - 类 java.util.logging.Logger 中的方法
记录一个方法返回，带有结果对象。
exitValue() - 类 java.lang.Process 中的方法
返回子进程的出口值。
exp(double) - 类 java.lang.Math 中的静态方法
返回欧拉数 e 的 double 次幂的值。
exp(double) - 类 java.lang.StrictMath 中的静态方法
返回欧拉数 e 的 double 次幂的值。
EXPANDABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象允许逐步显示其子级。
EXPANDED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是展开的。
expandedIcon - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
expandPath(TreePath) - 类 javax.swing.JTree 中的方法
确保指定路径标识的节点展开，并且可查看。
expandRow(int) - 类 javax.swing.JTree 中的方法
确保指定行中的节点展开，并且可查看。
EXPANDS_SELECTED_PATHS_PROPERTY - 类 javax.swing.JTree 中的静态变量
展开选择路径属性的绑定属性名称
expandTabRunsArray() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
ExpandVetoException - javax.swing.tree 中的 异常
用于阻止扩展/折叠发生的异常。
ExpandVetoException(TreeExpansionEvent) - 异常 javax.swing.tree.ExpandVetoException 的构造方法
构造不带任何消息的 ExpandVetoException 对象。
ExpandVetoException(TreeExpansionEvent, String) - 异常 javax.swing.tree.ExpandVetoException 的构造方法
构造带指定消息的 ExpandVetoException 对象。
expm1(double) - 类 java.lang.Math 中的静态方法
返回 ex -1。
expm1(double) - 类 java.lang.StrictMath 中的静态方法
返回 ex -1。
EXPONENT - 类 java.text.NumberFormat.Field 中的静态变量
标识指数字段的常量。
EXPONENT_SIGN - 类 java.text.NumberFormat.Field 中的静态变量
标识指数符号 (exponent sign) 字段的常量。
EXPONENT_SYMBOL - 类 java.text.NumberFormat.Field 中的静态变量
标识指数符号 (exponent symbol) 字段的常量。
export() - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法
export() - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法
export() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
导出此 RMI 对象。
export() - 接口 org.ietf.jgss.GSSContext 中的方法
导出此上下文，以便使其他进程能够导入它。
export() - 接口 org.ietf.jgss.GSSName 中的方法
返回机制名称 (MN) 的规范化连续字节表示形式，适合通过授权的功能进行直接的、逐字节比较。
exportAsDrag(JComponent, InputEvent, int) - 类 javax.swing.TransferHandler 中的方法
导致 Swing 拖动支持的启用。
exportDone(JComponent, Transferable, int) - 类 javax.swing.TransferHandler 中的方法
在导出数据之后调用。
ExportException - java.rmi.server 中的 异常
ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
ExportException(String) - 异常 java.rmi.server.ExportException 的构造方法
构造带指定详细消息的 ExportException。
ExportException(String, Exception) - 异常 java.rmi.server.ExportException 的构造方法
构造带指定详细消息和嵌入异常的 ExportException。
exportNode(OutputStream) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.exportNode(OutputStream) 中的规范实现 exportNode 方法。
exportNode(OutputStream) - 类 java.util.prefs.Preferences 中的方法
在指定输出流上发出表示此节点（不是其子节点）中包含的所有首选项的 XML 文档。
exportObject(Remote, String, MarshalledObject<?>, boolean, int) - 类 java.rmi.activation.Activatable 中的静态方法
注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
exportObject(Remote, String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.activation.Activatable 中的静态方法
注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
exportObject(Remote, ActivationID, int) - 类 java.rmi.activation.Activatable 中的静态方法
将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
exportObject(Remote, ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.activation.Activatable 中的静态方法
将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
exportObject(Remote, Object) - 接口 java.rmi.server.ServerRef 中的方法
为提供的 Remote 对象创建客户机 stub 对象。
exportObject(Remote) - 类 java.rmi.server.UnicastRemoteObject 中的静态方法
使用匿名端口导出远程对象，以便能够接收传入的调用。
exportObject(Remote, int) - 类 java.rmi.server.UnicastRemoteObject 中的静态方法
使用提供的特定端口导出远程对象，以便能够接收传入的调用。
exportObject(Remote, int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.server.UnicastRemoteObject 中的静态方法
使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。
exportObject(Remote) - 接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 中的方法
PortableRemoteObject.exportObject(java.rmi.Remote) 的委托调用。
exportObject(Remote) - 类 javax.rmi.PortableRemoteObject 中的静态方法
准备服务器对象，以接收远程调用。
exportSubtree(OutputStream) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.exportSubtree(OutputStream) 中的规范实现 exportSubtree 方法。
exportSubtree(OutputStream) - 类 java.util.prefs.Preferences 中的方法
发出表示此节点及其所有子节点中包含的全部首选项的 XML 文档。
exportToClipboard(JComponent, Clipboard, int) - 类 javax.swing.TransferHandler 中的方法
导致从给定组件到给定剪贴板的传输。
Expression - java.beans 中的 类
Expression 对象表示基本表达式，其中将单个方法应用于某一目标和一组参数，以返回结果，与在 "a.getFoo()" 中一样。
Expression(Object, String, Object[]) - 类 java.beans.Expression 的构造方法
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。
Expression(Object, Object, String, Object[]) - 类 java.beans.Expression 的构造方法
为某个返回结果的方法创建一个新的 Expression 对象。
extendedOperation(ExtendedRequest) - 类 javax.naming.ldap.InitialLdapContext 中的方法
extendedOperation(ExtendedRequest) - 接口 javax.naming.ldap.LdapContext 中的方法
执行扩展操作。
ExtendedRequest - javax.naming.ldap 中的 接口
此接口表示在 RFC 2251 中定义的 LDAPv3 扩展操作请求。
ExtendedResponse - javax.naming.ldap 中的 接口
此接口表示在 RFC 2251 中定义的 LDAP 扩展操作响应。
extension - 枚举 javax.tools.JavaFileObject.Kind 中的变量
通常用于此类文件对象的扩展名（按照约定）。
EXTENSION_INSTALLATION - 类 java.util.jar.Attributes.Name 中的静态变量
Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
EXTENSION_LIST - 类 java.util.jar.Attributes.Name 中的静态变量
Extension-List 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
EXTENSION_NAME - 类 java.util.jar.Attributes.Name 中的静态变量
Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
extent - 类 java.awt.geom.Arc2D.Double 中的变量
弧的角跨越（以度数表示）。
extent - 类 java.awt.geom.Arc2D.Float 中的变量
弧的角跨越（以度数表示）。
externalEntityDecl(String, String, String) - 接口 org.xml.sax.ext.DeclHandler 中的方法
报告解析的外部实体声明。
externalEntityDecl(String, String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
Externalizable - java.io 中的 接口
Externalizable 实例类的唯一特性是可以被写入序列化流中，该类负责保存和恢复实例内容。
extract(Any) - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.CurrentHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ObjectHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.PolicyHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.StringValueHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.BindingHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.IstringHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NameHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.IORHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
extract(Any) - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
extract_any() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 Any 对象。
extract_boolean() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 boolean 值。
extract_char() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 char 值。
extract_double() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 double 值。
extract_fixed() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 java.math.BigDecimal 对象。
extract_float() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 float 值。
extract_long() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 int 值。
extract_longlong() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 long 值。
extract_Object() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 org.omg.CORBA.Object。
extract_octet() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 byte 值。
extract_Principal() - 类 org.omg.CORBA.Any 中的方法
已过时。 由 CORBA 2.2 取代。
extract_short() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 short 值。
extract_Streamable() - 类 org.omg.CORBA.Any 中的方法
从此 Any 对象的 value 字段提取 Streamable。
extract_string() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 String 对象。
extract_TypeCode() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 TypeCode 对象。
extract_ulong() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 int 值。
extract_ulonglong() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 long 值。
extract_ushort() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 short 值。
extract_Value() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 java.io.Serializable 对象。
extract_wchar() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 char 值。
extract_wstring() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 String 对象。
extractAllHeaderElements() - 接口 javax.xml.soap.SOAPHeader 中的方法
返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。
extractContentAsDocument() - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 DOM Document，并将此 SOAPBody 的第一个子元素设置为它的文档元素。
extractHeaderElements(String) - 接口 javax.xml.soap.SOAPHeader 中的方法
返回可在此 SOAPHeader 对象中所有具有指定 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。
extraImageMetadataFormatClassNames - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的其他任何图像元数据格式的类名称的 String 数组，该数组最初为 null。
extraImageMetadataFormatNames - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的其他任何图像元数据格式的名称的 String 数组，该数组最初为 null。
extraMetadataFormatClassNames - 类 javax.imageio.metadata.IIOMetadata 中的变量
实现 IIOMetadataFormat 和表示此插件支持的元数据格式（标准格式和本机格式除外）的类的名称所组成的数组，初始化为 null，通过构造方法设置。
extraMetadataFormatNames - 类 javax.imageio.metadata.IIOMetadata 中的变量
此插件支持的格式（标准格式和本机格式除外）的名称所组成的数组，初始化为 null，通过构造方法设置。
extraStreamMetadataFormatClassNames - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的其他任何流元数据格式的类名称的 String 数组，该数组最初为 null。
extraStreamMetadataFormatNames - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的其他任何流元数据格式的名称的 String 数组，该字符串最初为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


F - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

F

F0 - 类 java.security.spec.RSAKeyGenParameterSpec 中的静态变量
公用指数值 F0 = 3。
F1 - 类 java.awt.Event 中的静态变量
F1 功能键，一个非 ASCII 操作键。
F10 - 类 java.awt.Event 中的静态变量
F10 功能键，一个非 ASCII 操作键。
F11 - 类 java.awt.Event 中的静态变量
F11 功能键，一个非 ASCII 操作键。
F12 - 类 java.awt.Event 中的静态变量
F12 功能键，一个非 ASCII 操作键。
F2 - 类 java.awt.Event 中的静态变量
F2 功能键，一个非 ASCII 操作键。
F3 - 类 java.awt.Event 中的静态变量
F3 功能键，一个非 ASCII 操作键。
F4 - 类 java.awt.Event 中的静态变量
F4 功能键，一个非 ASCII 操作键。
F4 - 类 java.security.spec.RSAKeyGenParameterSpec 中的静态变量
公用指数值 F4 = 65537。
F5 - 类 java.awt.Event 中的静态变量
F5 功能键，一个非 ASCII 操作键。
F6 - 类 java.awt.Event 中的静态变量
F6 功能键，一个非 ASCII 操作键。
F7 - 类 java.awt.Event 中的静态变量
F7 功能键，一个非 ASCII 操作键。
F8 - 类 java.awt.Event 中的静态变量
F8 功能键，一个非 ASCII 操作键。
F9 - 类 java.awt.Event 中的静态变量
F9 功能键，一个非 ASCII 操作键。
FACE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
FactoryConfigurationError - javax.xml.parsers 中的 错误
当解析器工厂的配置存在问题时抛出该异常。
FactoryConfigurationError() - 错误 javax.xml.parsers.FactoryConfigurationError 的构造方法
创建一个新的不带详细消息的 FactoryConfigurationError。
FactoryConfigurationError(String) - 错误 javax.xml.parsers.FactoryConfigurationError 的构造方法
创建一个新的 FactoryConfigurationError，并将 String 指定为一个错误消息。
FactoryConfigurationError(Exception) - 错误 javax.xml.parsers.FactoryConfigurationError 的构造方法
使用错误的给定 Exception 基本原因创建一个新的 FactoryConfigurationError。
FactoryConfigurationError(Exception, String) - 错误 javax.xml.parsers.FactoryConfigurationError 的构造方法
使用给定 Exception 的基本原因和详细消息创建一个新的 FactoryConfigurationError。
FactoryConfigurationError - javax.xml.stream 中的 错误
一个用于报告工厂配置错误的错误类。
FactoryConfigurationError() - 错误 javax.xml.stream.FactoryConfigurationError 的构造方法
默认构造方法。
FactoryConfigurationError(Exception) - 错误 javax.xml.stream.FactoryConfigurationError 的构造方法
构造具有嵌套内部异常的异常。
FactoryConfigurationError(Exception, String) - 错误 javax.xml.stream.FactoryConfigurationError 的构造方法
构造具有嵌套内部异常和消息的异常。
FactoryConfigurationError(String, Exception) - 错误 javax.xml.stream.FactoryConfigurationError 的构造方法
构造具有嵌套内部异常和消息的异常。
FactoryConfigurationError(String) - 错误 javax.xml.stream.FactoryConfigurationError 的构造方法
构造具有关联消息的异常。
FAILED - 类 javax.management.remote.JMXConnectionNotification 中的静态变量
连接失败通知的通知类型字符串。
FailedLoginException - javax.security.auth.login 中的 异常
当用户验证失败时抛出此异常。
FailedLoginException() - 异常 javax.security.auth.login.FailedLoginException 的构造方法
构造不带详细消息的 FailedLoginException。
FailedLoginException(String) - 异常 javax.security.auth.login.FailedLoginException 的构造方法
构造带指定详细消息的 FailedLoginException。
failure(Exception) - 接口 java.rmi.server.RMIFailureHandler 中的方法
在 RMI 运行时无法通过 RMISocketFactory 创建 ServerSocket 时调用该 failure 回调。
FAILURE - 异常 org.ietf.jgss.GSSException 中的静态变量
未在 GSS-API 级别指定的一般故障。
FALSE - 类 java.lang.Boolean 中的静态变量
对应基值 false 的 Boolean 对象。
FALSE - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "false"，某些属性的可能值。
FALSE - 接口 java.util.jar.Pack200.Unpacker 中的静态变量
字符串 "false"，某些属性的可能值。
FAMILY - 类 java.awt.font.TextAttribute 中的静态变量
字体名称的属性键。
Family - 类 javax.swing.text.StyleConstants 中的静态变量
字体系列的名称。
FATAL_ERROR - 接口 javax.xml.bind.ValidationEvent 中的静态变量
对应于 W3C XML 1.0 Recommendation 第 1.2 节中的“致命错误”的定义的条件。
fatalError(TransformerException) - 接口 javax.xml.transform.ErrorListener 中的方法
接收不可恢复错误的通知。
fatalError(SAXParseException) - 接口 org.xml.sax.ErrorHandler 中的方法
接收不可恢复的错误的通知。
fatalError(SAXParseException) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 报告严重的 XML 解析错误。
fatalError(SAXParseException) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
报告严重的 XML 解析错误。
fatalError(SAXParseException) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个严重的错误事件。
fd - 类 java.net.DatagramSocketImpl 中的变量
文件描述符对象。
fd - 类 java.net.SocketImpl 中的变量
此套接字的文件描述符对象。
FEATURE - 类 javax.xml.transform.dom.DOMResult 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。
FEATURE - 类 javax.xml.transform.dom.DOMSource 中的静态变量
当将此值作为参数传递时如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。
FEATURE - 类 javax.xml.transform.sax.SAXResult 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。
FEATURE - 类 javax.xml.transform.sax.SAXSource 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。
FEATURE - 类 javax.xml.transform.sax.SAXTransformerFactory 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则从 TransformerFactory.newInstance() 返回的 TransformerFactory 可以安全地被转换为 SAXTransformerFactory。
FEATURE - 类 javax.xml.transform.stax.StAXResult 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Result 输出。
FEATURE - 类 javax.xml.transform.stax.StAXSource 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Source 输入。
FEATURE - 类 javax.xml.transform.stream.StreamResult 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。
FEATURE - 类 javax.xml.transform.stream.StreamSource 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source。
FEATURE_SECURE_PROCESSING - 类 javax.xml.XMLConstants 中的静态变量
用于安全处理的功能。
FEATURE_XMLFILTER - 类 javax.xml.transform.sax.SAXTransformerFactory 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 SAXTransformerFactory.newXMLFilter(Source src) 和 SAXTransformerFactory.newXMLFilter(Templates templates) 方法是受支持的。
FeatureDescriptor - java.beans 中的 类
FeatureDescriptor 类是 PropertyDescriptor、EventSetDescriptor 和 MethodDescriptor 等的公共基类。
FeatureDescriptor() - 类 java.beans.FeatureDescriptor 的构造方法
构造一个 FeatureDescriptor。
FEBRUARY - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第二个月的 Calendar.MONTH 字段值。
FEBRUARY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第二个月的值。
FETCH_FORWARD - 接口 java.sql.ResultSet 中的静态变量
该常量指示将按正向（即从第一个到最后一个）处理结果集中的行。
FETCH_REVERSE - 接口 java.sql.ResultSet 中的静态变量
该常量指示将按逆向（即从最后一个到第一个）处理结果集中的行处理。
FETCH_UNKNOWN - 接口 java.sql.ResultSet 中的静态变量
该常量指示结果集中的行的处理顺序未知。
fetchNotifications(long, int, long) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
检索来自连接器服务器的通知。
fetchNotifications(long, int, long) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
fetchNotifications(long, int, long) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
fictional() - 类 javax.swing.text.html.parser.TagElement 中的方法
Fidelity - javax.print.attribute.standard 中的 类
Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
Fidelity(int) - 类 javax.print.attribute.standard.Fidelity 的构造方法
构造具有给定整数值的新保真度枚举值。
FIDELITY_FALSE - 类 javax.print.attribute.standard.Fidelity 中的静态变量
打印机应对打印作业进行合理尝试，即使它不能完全按照指定的要求打印该作业。
FIDELITY_TRUE - 类 javax.print.attribute.standard.Fidelity 中的静态变量
必须完全按照指定的要求打印作业，或者拒绝该作业。
Field - java.lang.reflect 中的 类
Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。
FIELD_ATTRIBUTE_PFX - 接口 java.util.jar.Pack200.Packer 中的静态变量
当与字段属性名称连在一起时，指出该属性的格式。
FIELD_COUNT - 类 java.util.Calendar 中的静态变量
get 和 set 可识别的不同字段的数量。
FIELD_UNDEFINED - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
指定不设置“int”字段。
FieldNameHelper - org.omg.CORBA 中的 类
FieldName 的 Helper。
FieldNameHelper() - 类 org.omg.CORBA.FieldNameHelper 的构造方法
FieldNameHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/FieldNameHelper.java。
FieldNameHelper() - 类 org.omg.DynamicAny.FieldNameHelper 的构造方法
FieldPosition - java.text 中的 类
FieldPosition 是 Format 及其子类用于在格式输出中标识字段的简单类。
FieldPosition(int) - 类 java.text.FieldPosition 的构造方法
为给定字段创建一个 FieldPosition 对象。
FieldPosition(Format.Field) - 类 java.text.FieldPosition 的构造方法
为给定的字段常量创建一个 FieldPosition 对象。
FieldPosition(Format.Field, int) - 类 java.text.FieldPosition 的构造方法
为给定的字段创建一个 FieldPosition 对象。
fields - 类 java.util.Calendar 中的变量
此日历当前设置时间的日历字段值。
fieldsIn(Iterable<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中字段的列表。
fieldsIn(Set<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中字段的集合。
FieldView - javax.swing.text 中的 类
扩展多行纯文本视图，使其适合单行编辑器视图。
FieldView(Element) - 类 javax.swing.text.FieldView 的构造方法
构造包装了元素的新 FieldView。
FILE - 类 java.awt.JobAttributes.DestinationType 中的静态变量
用于指定打印到文件的 DestinationType 实例。
File - java.io 中的 类
文件和目录路径名的抽象表示形式。
File(String) - 类 java.io.File 的构造方法
通过将给定路径名字符串转换为抽象路径名来创建一个新 File 实例。
File(String, String) - 类 java.io.File 的构造方法
根据 parent 路径名字符串和 child 路径名字符串创建一个新 File 实例。
File(File, String) - 类 java.io.File 的构造方法
根据 parent 抽象路径名和 child 路径名字符串创建一个新 File 实例。
File(URI) - 类 java.io.File 的构造方法
通过将给定的 file: URI 转换为一个抽象路径名来创建一个新的 File 实例。
FILE - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
特定于主机的文件名称。
FILE_CHOOSER - 类 javax.accessibility.AccessibleRole 中的静态变量
一个专用的对话框，它显示目录中的文件，并允许用户选择文件、浏览不同的目录，或指定一个文件名。
FILE_CHOOSER - 类 javax.swing.plaf.synth.Region 中的静态变量
FileChooser 的 region。
FILE_CHOOSER_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
FILE_FILTER_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
用户更改要显示的文件种类。
FILE_HIDING_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识在显示隐藏文件属性中的更改。
FILE_SELECTION_MODE_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识在选择种类（选择单个、多个等等）方面的更改。
FILE_SYSTEM_VIEW_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
声明使用其他对象在系统上查找可用的驱动器。
FILE_VERSION - 类 javax.swing.text.html.parser.DTD 中的静态变量
FILE_VIEW_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
声明使用其他对象检索文件信息。
FileCacheImageInputStream - javax.imageio.stream 中的 类
从常规 InputStream 获取其输入的 ImageInputStream 的实现。
FileCacheImageInputStream(InputStream, File) - 类 javax.imageio.stream.FileCacheImageInputStream 的构造方法
构造一个将从给定 InputStream 进行读取的 FileCacheImageInputStream。
FileCacheImageOutputStream - javax.imageio.stream 中的 类
将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
FileCacheImageOutputStream(OutputStream, File) - 类 javax.imageio.stream.FileCacheImageOutputStream 的构造方法
构造一个将向给定 outputStream 进行写入的 FileCacheImageOutputStream。
FileChannel - java.nio.channels 中的 类
用于读取、写入、映射和操作文件的通道。
FileChannel() - 类 java.nio.channels.FileChannel 的构造方法
初始化此类的一个新实例。
FileChannel.MapMode - java.nio.channels 中的 类
文件映射模式的类型安全的枚举。
FileChooserUI - javax.swing.plaf 中的 类
JFileChooser 的可插入外观界面。
FileChooserUI() - 类 javax.swing.plaf.FileChooserUI 的构造方法
FileDataSource - javax.activation 中的 类
FileDataSource 类实现一个封装文件的简单 DataSource 对象。
FileDataSource(File) - 类 javax.activation.FileDataSource 的构造方法
根据 File 对象创建 FileDataSource。
FileDataSource(String) - 类 javax.activation.FileDataSource 的构造方法
根据指定的路径名创建 FileDataSource。
FileDescriptor - java.io 中的 类
文件描述符类的实例用作与基础机器有关的某种结构的不透明句柄，该结构表示开放文件、开放套接字或者字节的另一个源或接收者。
FileDescriptor() - 类 java.io.FileDescriptor 的构造方法
构造一个（无效的）FileDescriptor 对象。
FileDialog - java.awt 中的 类
FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
FileDialog(Frame) - 类 java.awt.FileDialog 的构造方法
创建一个文件对话框，用于加载文件。
FileDialog(Frame, String) - 类 java.awt.FileDialog 的构造方法
创建一个具有指定标题的文件对话框窗口，用于加载文件。
FileDialog(Frame, String, int) - 类 java.awt.FileDialog 的构造方法
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。
FileDialog(Dialog) - 类 java.awt.FileDialog 的构造方法
创建一个文件对话框，用于加载文件。
FileDialog(Dialog, String) - 类 java.awt.FileDialog 的构造方法
创建一个具有指定标题的文件对话框，用于加载文件。
FileDialog(Dialog, String, int) - 类 java.awt.FileDialog 的构造方法
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。
FileFilter - java.io 中的 接口
用于抽象路径名的过滤器。
FileFilter - javax.swing.filechooser 中的 类
FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。
FileFilter() - 类 javax.swing.filechooser.FileFilter 的构造方法
FileHandler - java.util.logging 中的 类
简单的文件日志记录 Handler。
FileHandler() - 类 java.util.logging.FileHandler 的构造方法
构造一个默认的 FileHandler。
FileHandler(String) - 类 java.util.logging.FileHandler 的构造方法
初始化要写入给定文件名的 FileHandler 。
FileHandler(String, boolean) - 类 java.util.logging.FileHandler 的构造方法
初始化要写入给定文件名的 FileHandler（使用可选的 append）。
FileHandler(String, int, int) - 类 java.util.logging.FileHandler 的构造方法
初始化要写入文件集的 FileHandler。
FileHandler(String, int, int, boolean) - 类 java.util.logging.FileHandler 的构造方法
初始化要写入文件集的 FileHandler（使用可选的 append）。
fileIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
FileImageInputStream - javax.imageio.stream 中的 类
从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。
FileImageInputStream(File) - 类 javax.imageio.stream.FileImageInputStream 的构造方法
构造一个将从给定 File 进行读取的 FileImageInputStream。
FileImageInputStream(RandomAccessFile) - 类 javax.imageio.stream.FileImageInputStream 的构造方法
构造一个将从给定 RandomAccessFile 进行读取的 FileImageInputStream。
FileImageOutputStream - javax.imageio.stream 中的 类
将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
FileImageOutputStream(File) - 类 javax.imageio.stream.FileImageOutputStream 的构造方法
构造一个将向给定 File 进行写入的 FileImageOutputStream。
FileImageOutputStream(RandomAccessFile) - 类 javax.imageio.stream.FileImageOutputStream 的构造方法
构造一个向给定 FileImageOutputStream 进行写入的 RandomAccessFile。
FileInputStream - java.io 中的 类
FileInputStream 从文件系统中的某个文件中获得输入字节。
FileInputStream(String) - 类 java.io.FileInputStream 的构造方法
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的路径名 name 指定。
FileInputStream(File) - 类 java.io.FileInputStream 的构造方法
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的 File 对象 file 指定。
FileInputStream(FileDescriptor) - 类 java.io.FileInputStream 的构造方法
通过使用文件描述符 fdObj 创建一个 FileInputStream，该文件描述符表示到文件系统中某个实际文件的现有连接。
FileLock - java.nio.channels 中的 类
表示文件区域锁定的标记。
FileLock(FileChannel, long, long, boolean) - 类 java.nio.channels.FileLock 的构造方法
初始化此类的一个新实例。
FileLockInterruptionException - java.nio.channels 中的 异常
当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。
FileLockInterruptionException() - 异常 java.nio.channels.FileLockInterruptionException 的构造方法
构造此类的一个实例。
fileManager - 类 javax.tools.ForwardingJavaFileManager 中的变量
一个文件管理器，所有方法都将委托给它。
FILENAME - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它是将被执行的文件的名称。
FileNameExtensionFilter - javax.swing.filechooser 中的 类
FileFilter 的一个实现，它使用指定的扩展名集合进行过滤。
FileNameExtensionFilter(String, String...) - 类 javax.swing.filechooser.FileNameExtensionFilter 的构造方法
使用指定的描述和文件扩展名创建一个 FileNameExtensionFilter。
FilenameFilter - java.io 中的 接口
实现此接口的类实例可用于过滤器文件名。
FileNameMap - java.net 中的 接口
提供在文件名和 MIME 类型字符串之间进行映射的机制的简单接口。
FileNotFoundException - java.io 中的 异常
当试图打开指定路径名表示的文件失败时，抛出此异常。
FileNotFoundException() - 异常 java.io.FileNotFoundException 的构造方法
使用 null 作为错误详细消息构造 FileNotFoundException。
FileNotFoundException(String) - 异常 java.io.FileNotFoundException 的构造方法
构造带有指定详细消息的 FileNotFoundException。
FileObject - javax.tools 中的 接口
工具的文件抽象。
fileObject - 类 javax.tools.ForwardingFileObject 中的变量
一个文件对象，所有方法都将委托给它。
FileOutputStream - java.io 中的 类
文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。
FileOutputStream(String) - 类 java.io.FileOutputStream 的构造方法
创建一个向具有指定名称的文件中写入数据的输出文件流。
FileOutputStream(String, boolean) - 类 java.io.FileOutputStream 的构造方法
创建一个向具有指定 name 的文件中写入数据的输出文件流。
FileOutputStream(File) - 类 java.io.FileOutputStream 的构造方法
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(File, boolean) - 类 java.io.FileOutputStream 的构造方法
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(FileDescriptor) - 类 java.io.FileOutputStream 的构造方法
创建一个向指定文件描述符处写入数据的输出文件流，该文件描述符表示一个到文件系统中的某个实际文件的现有连接。
FilePermission - java.io 中的 类
此类表示对文件和目录的访问。
FilePermission(String, String) - 类 java.io.FilePermission 的构造方法
创建具有指定操作的新 FilePermission 对象，path 是文件或目录的路径名，actions 包含对文件或目录授予的所需操作的列表，该列表由逗号分隔。
Filer - javax.annotation.processing 中的 接口
此接口支持通过注释处理器创建新文件。
FileReader - java.io 中的 类
用来读取字符文件的便捷类。
FileReader(String) - 类 java.io.FileReader 的构造方法
在给定从中读取数据的文件名的情况下创建一个新 FileReader。
FileReader(File) - 类 java.io.FileReader 的构造方法
在给定从中读取数据的 File 的情况下创建一个新 FileReader。
FileReader(FileDescriptor) - 类 java.io.FileReader 的构造方法
在给定从中读取数据的 FileDescriptor 的情况下创建一个新 FileReader。
FilerException - javax.annotation.processing 中的 异常
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。
FilerException(String) - 异常 javax.annotation.processing.FilerException 的构造方法
构造带指定详细消息的异常。
FILES_AND_DIRECTORIES - 类 javax.swing.JFileChooser 中的静态变量
指示显示文件和目录。
FILES_ONLY - 类 javax.swing.JFileChooser 中的静态变量
指示仅显示文件。
FileSystemView - javax.swing.filechooser 中的 类
FileSystemView 是 JFileChooser 的文件系统网关。
FileSystemView() - 类 javax.swing.filechooser.FileSystemView 的构造方法
FileTypeMap - javax.activation 中的 类
FileTypeMap 是一个抽象类，它为文件提供数据分类接口。
FileTypeMap() - 类 javax.activation.FileTypeMap 的构造方法
默认的构造方法。
FileView - javax.swing.filechooser 中的 类
FileView 定义一个抽象类，可以实现该抽象类来为 File 提供带 UI 信息的文件选择器。
FileView() - 类 javax.swing.filechooser.FileView 的构造方法
FileWriter - java.io 中的 类
用来写入字符文件的便捷类。
FileWriter(String) - 类 java.io.FileWriter 的构造方法
根据给定的文件名构造一个 FileWriter 对象。
FileWriter(String, boolean) - 类 java.io.FileWriter 的构造方法
根据给定的文件名以及指示是否附加写入数据的 boolean 值来构造 FileWriter 对象。
FileWriter(File) - 类 java.io.FileWriter 的构造方法
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(File, boolean) - 类 java.io.FileWriter 的构造方法
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(FileDescriptor) - 类 java.io.FileWriter 的构造方法
构造与某个文件描述符相关联的 FileWriter 对象。
FILL - 类 java.awt.font.ShapeGraphicAttribute 中的静态变量
指示应填充该形状的键。
fill(Shape) - 类 java.awt.Graphics2D 中的方法
使用 Graphics2D 上下文的设置，填充 Shape 的内部区域。
fill - 类 java.awt.GridBagConstraints 中的变量
当组件的显示区域大于它所请求的显示区域的大小时使用此字段。
fill(long[], long) - 类 java.util.Arrays 中的静态方法
将指定的 long 值分配给指定 long 型数组的每个元素。
fill(long[], int, int, long) - 类 java.util.Arrays 中的静态方法
将指定的 long 值分配给指定 long 型数组指定范围中的每个元素。
fill(int[], int) - 类 java.util.Arrays 中的静态方法
将指定的 int 值分配给指定 int 型数组的每个元素。
fill(int[], int, int, int) - 类 java.util.Arrays 中的静态方法
将指定的 int 值分配给指定 int 型数组指定范围中的每个元素。
fill(short[], short) - 类 java.util.Arrays 中的静态方法
将指定的 short 值分配给指定 short 型数组的每个元素。
fill(short[], int, int, short) - 类 java.util.Arrays 中的静态方法
将指定的 short 值分配给指定 short 型数组指定范围中的每个元素。
fill(char[], char) - 类 java.util.Arrays 中的静态方法
将指定的 char 值分配给指定 char 型数组的每个元素。
fill(char[], int, int, char) - 类 java.util.Arrays 中的静态方法
将指定的 char 值分配给指定 char 型数组指定范围中的每个元素。
fill(byte[], byte) - 类 java.util.Arrays 中的静态方法
将指定的 byte 值分配给指定 byte 节型数组的每个元素。
fill(byte[], int, int, byte) - 类 java.util.Arrays 中的静态方法
将指定的 byte 值分配给指定 byte 型数组指定范围中的每个元素。
fill(boolean[], boolean) - 类 java.util.Arrays 中的静态方法
将指定的 boolean 值分配给指定 boolean 型数组的每个元素。
fill(boolean[], int, int, boolean) - 类 java.util.Arrays 中的静态方法
将指定的 boolean 值分配给指定 boolean 型数组指定范围中的每个元素。
fill(double[], double) - 类 java.util.Arrays 中的静态方法
将指定的 double 值分配给指定 double 型数组的每个元素。
fill(double[], int, int, double) - 类 java.util.Arrays 中的静态方法
将指定的 double 值分配给指定 double 型数组指定范围中的每个元素。
fill(float[], float) - 类 java.util.Arrays 中的静态方法
将指定的 float 值分配给指定 float 型数组的每个元素。
fill(float[], int, int, float) - 类 java.util.Arrays 中的静态方法
将指定的 float 值分配给指定 float 型数组指定范围中的每个元素。
fill(Object[], Object) - 类 java.util.Arrays 中的静态方法
将指定的 Object 引用分配给指定 Object 数组的每个元素。
fill(Object[], int, int, Object) - 类 java.util.Arrays 中的静态方法
将指定的 Object 引用分配给指定 Object 数组指定范围中的每个元素。
fill(List<? super T>, T) - 类 java.util.Collections 中的静态方法
使用指定元素替换指定列表中的所有元素。
fill() - 类 java.util.zip.InflaterInputStream 中的方法
使用更多要解压缩的数据填充输入缓冲区。
fill3DRect(int, int, int, int, boolean) - 类 java.awt.Graphics 中的方法
绘制一个用当前颜色填充的 3-D 高亮显示矩形。
fill3DRect(int, int, int, int, boolean) - 类 java.awt.Graphics2D 中的方法
绘制一个用当前颜色填充的 3-D 高亮显示矩形。
fill3DRect(int, int, int, int, boolean) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fill3DRect。
fillArc(int, int, int, int, int, int) - 类 java.awt.Graphics 中的方法
填充覆盖指定矩形的圆弧或椭圆弧。
fillArc(int, int, int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fillArc。
filledSlider - 类 javax.swing.plaf.metal.MetalSliderUI 中的变量
FILLER - 类 javax.accessibility.AccessibleRole 中的静态变量
填补用户界面空间的对象。
fillInStackTrace() - 类 java.lang.Throwable 中的方法
在异常堆栈跟踪中填充。
fillOval(int, int, int, int) - 类 java.awt.Graphics 中的方法
使用当前颜色填充外接指定矩形框的椭圆。
fillOval(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fillOval。
fillPolygon(int[], int[], int) - 类 java.awt.Graphics 中的方法
填充由 x 和 y 坐标数组定义的闭合多边形。
fillPolygon(Polygon) - 类 java.awt.Graphics 中的方法
用图形上下文的当前颜色填充指定 Polygon 对象定义的多边形。
fillPolygon(int[], int[], int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fillPolygon。
fillRect(int, int, int, int) - 类 java.awt.Graphics 中的方法
填充指定的矩形。
fillRect(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fillRect。
fillRoundRect(int, int, int, int, int, int) - 类 java.awt.Graphics 中的方法
用当前颜色填充指定的圆角矩形。
fillRoundRect(int, int, int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fillRoundRect。
filter(BufferedImage, BufferedImage) - 类 java.awt.image.AffineTransformOp 中的方法
转换源 BufferedImage 并将结果存储在目标 BufferedImage 中。
filter(Raster, WritableRaster) - 类 java.awt.image.AffineTransformOp 中的方法
转换源 Raster 并将结果存储在目标 Raster 中。
filter(Raster, WritableRaster) - 类 java.awt.image.BandCombineOp 中的方法
使用构造方法中指定的矩阵变换该 Raster。
filter(BufferedImage, BufferedImage) - 接口 java.awt.image.BufferedImageOp 中的方法
对 BufferedImage 执行单输入/单输出操作。
filter(BufferedImage, BufferedImage) - 类 java.awt.image.ColorConvertOp 中的方法
对源 BufferedImage 进行颜色转换。
filter(Raster, WritableRaster) - 类 java.awt.image.ColorConvertOp 中的方法
对源 Raster 中的图像数据进行颜色转换。
filter(BufferedImage, BufferedImage) - 类 java.awt.image.ConvolveOp 中的方法
对 BufferedImage 执行卷积运算。
filter(Raster, WritableRaster) - 类 java.awt.image.ConvolveOp 中的方法
对 Raster 执行卷积运算。
filter(BufferedImage, BufferedImage) - 类 java.awt.image.LookupOp 中的方法
对 BufferedImage 执行查找操作。
filter(Raster, WritableRaster) - 类 java.awt.image.LookupOp 中的方法
在 Raster 上执行查找操作。
filter(Raster, WritableRaster) - 接口 java.awt.image.RasterOp 中的方法
执行从源 Raster 到目标 Raster 的单输入/单输出操作。
filter(BufferedImage, BufferedImage) - 类 java.awt.image.RescaleOp 中的方法
对源 BufferedImage 进行重缩放。
filter(Raster, WritableRaster) - 类 java.awt.image.RescaleOp 中的方法
对源 Raster 中的像素数据进行重缩放。
Filter - java.util.logging 中的 接口
Filter 可用于为记录内容提供比记录级别所提供的更细粒度的控制。
filter(Object) - 接口 javax.imageio.spi.ServiceRegistry.Filter 中的方法
如果给定的 provider 对象与由此 Filter 定义的条件匹配，则返回 true。
FILTER_ACCEPT - 接口 org.w3c.dom.ls.LSParserFilter 中的静态变量
接受节点。
FILTER_INTERRUPT - 接口 org.w3c.dom.ls.LSParserFilter 中的静态变量
中断对文档的常规处理。
FILTER_REJECT - 接口 org.w3c.dom.ls.LSParserFilter 中的静态变量
拒绝节点及其子节点。
FILTER_SKIP - 接口 org.w3c.dom.ls.LSParserFilter 中的静态变量
跳过此单个节点。
FILTERED - 类 java.util.zip.Deflater 中的静态变量
最适用于主要由小值组成并具有某种程度随意分布的数据的压缩策略。
FilteredImageSource - java.awt.image 中的 类
此类是 ImageProducer 接口的一个实现，该接口使用现有的图像和过滤器对象作为参数，并使用它们为原图像的新过滤版本产生图像数据。
FilteredImageSource(ImageProducer, ImageFilter) - 类 java.awt.image.FilteredImageSource 的构造方法
根据现有的 ImageProducer 和过滤器对象构造一个 ImageProducer 对象。
FilteredRowSet - javax.sql.rowset 中的 接口
所有标准 FilteredRowSet 实现都必须实现的标准接口。
filterIndexColorModel(IndexColorModel) - 类 java.awt.image.RGBImageFilter 中的方法
过滤 IndexColorModel 对象：通过 filterRGB 函数（RGBImageFilter 子类必须提供该函数）运行该对象颜色表中的每一项。
FilterInputStream - java.io 中的 类
FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
FilterInputStream(InputStream) - 类 java.io.FilterInputStream 的构造方法
将参数 in 分配给字段 this.in，以便记住它供以后使用，通过这种方式创建一个 FilterInputStream。
FilterOutputStream - java.io 中的 类
此类是过滤输出流的所有类的超类。
FilterOutputStream(OutputStream) - 类 java.io.FilterOutputStream 的构造方法
创建一个构建在指定基础输出流之上的输出流过滤器。
FilterReader - java.io 中的 类
用于读取已过滤的字符流的抽象类。
FilterReader(Reader) - 类 java.io.FilterReader 的构造方法
创建一个新的 filtered reader。
filterRGB(int, int, int) - 类 java.awt.image.RGBImageFilter 中的方法
子类必须指定该方法，以将使用默认 RGB ColorModel 的单个输入像素转换成单个输出像素。
filterRGB(int, int, int) - 类 javax.swing.GrayFilter 中的方法
重写 RGBImageFilter.filterRGB。
filterRGBPixels(int, int, int, int, int[], int, int) - 类 java.awt.image.RGBImageFilter 中的方法
过滤缓冲区中使用默认 RGB ColorModel 的像素：将其一个接一个地传递给 filterRGB 方法。
filters - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的变量
FilterWriter - java.io 中的 类
用于写入已过滤的字符流的抽象类。
FilterWriter(Writer) - 类 java.io.FilterWriter 的构造方法
创建一个新的 filtered writer。
FINAL - 类 java.lang.reflect.Modifier 中的静态变量
表示 final 修饰符的 int 值。
FINAL_QUOTE_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Pf”。
finalize() - 类 java.awt.color.ICC_Profile 中的方法
释放与 ICC_Profile 对象关联的资源。
finalize() - 类 java.awt.Font 中的方法
移除本机 Font 对象。
finalize() - 类 java.awt.Graphics 中的方法
一旦不再引用此图形上下文就释放它。
finalize() - 类 java.awt.image.ColorModel 中的方法
一旦不再引用此 ColorModel，就要释放与此 ColorModel 相关的系统资源。
finalize() - 类 java.awt.image.IndexColorModel 中的方法
不再引用此 ColorModel 后，释放与此 ColorModel 关联的系统资源。
finalize() - 类 java.awt.PrintJob 中的方法
一旦不再引用此打印作业，即可终止它。
finalize() - 类 java.io.FileInputStream 中的方法
确保在不再引用文件输入流时调用其 close 方法。
finalize() - 类 java.io.FileOutputStream 中的方法
清理到文件的连接，并确保在不再引用此文件输出流时调用此流的 close 方法。
finalize() - 类 java.lang.Enum 中的方法
枚举类不能有 finalize 方法。
finalize() - 类 java.lang.Object 中的方法
当垃圾回收器确定不存在对该对象的更多引用时，由对象的垃圾回收器调用此方法。
finalize() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
当不再引用此执行程序时，调用 shutdown。
finalize() - 类 java.util.zip.Deflater 中的方法
回收垃圾时关闭压缩器。
finalize() - 类 java.util.zip.Inflater 中的方法
回收垃圾时关闭解压缩器。
finalize() - 类 java.util.zip.ZipFile 中的方法
确保不再引用此 ZIP 文件时调用它的 close 方法。
finalize() - 类 javax.crypto.ExemptionMechanism 中的方法
确保不存在对此 ExemptionMechanism 对象存储的密钥的引用时，该密钥将被除去。
finalize() - 类 javax.imageio.spi.ServiceRegistry 中的方法
在垃圾回收前终止此对象。
finalize() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
在垃圾回收前结束此对象。
finalize() - 类 javax.imageio.stream.FileImageInputStream 中的方法
在垃圾回收前结束此对象。
finalize() - 类 javax.imageio.stream.FileImageOutputStream 中的方法
在垃圾回收前结束此对象。
finalize() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
在垃圾回收前结束此对象。
finalize() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
在垃圾回收前结束此对象。
finalSubString(AttributeValueExp, StringValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于字符串参数的约束条件。
find() - 类 java.util.regex.Matcher 中的方法
尝试查找与该模式匹配的输入序列的下一个子序列。
find(int) - 类 java.util.regex.Matcher 中的方法
重置此匹配器，然后尝试查找匹配该模式、从指定索引开始的输入序列的下一个子序列。
find_POA(String, boolean) - 接口 org.omg.PortableServer.POAOperations 中的方法
如果目标 POA 是具有指定名称的子 POA（相对于目标 POA）的父 POA，则返回该子 POA。
findAssociatedMBeans(ObjectName, String, String) - 类 javax.management.relation.RelationService 中的方法
检索与关系中给定关系相关的 MBean。
findAssociatedMBeans(ObjectName, String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索与关系中给定关系相关的 MBean。
findClass(String) - 类 java.lang.ClassLoader 中的方法
使用指定的二进制名称查找类。
findClass(String) - 类 java.net.URLClassLoader 中的方法
通过 URL 搜索路径查找并加载具有指定名称的类。
findClass(String) - 类 javax.management.loading.MLet 中的方法
这是要重新定义的类加载器的主要方法。
findColumn(String) - 接口 java.sql.ResultSet 中的方法
将给定的 ResultSet 列标签映射到其 ResultSet 列索引。
findColumn(String) - 类 javax.swing.table.AbstractTableModel 中的方法
返回具有给定名称的列。
findComponentAt(int, int) - 类 java.awt.Container 中的方法
对包含指定位置的可视子组件进行定位。
findComponentAt(Point) - 类 java.awt.Container 中的方法
对包含指定点的可视子组件进行定位。
findDeadlockedThreads() - 接口 java.lang.management.ThreadMXBean 中的方法
查找因为等待获得对象监视器或可拥有同步器而处于死锁状态的线程循环。
findEditor(Class<?>) - 类 java.beans.PropertyEditorManager 中的静态方法
查找给定目标类型的值编辑器。
findElementMatchingTag(HTMLDocument, int, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 中的方法
返回在 offset 处与 tag 匹配的最深的元素。
findFocusOwner(Component) - 类 javax.swing.SwingUtilities 中的静态方法
已过时。 从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。
findInLine(String) - 类 java.util.Scanner 中的方法
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。
findInLine(Pattern) - 类 java.util.Scanner 中的方法
试图在忽略分隔符的情况下查找下一个指定模式。
findLibrary(String) - 类 java.lang.ClassLoader 中的方法
返回本机库的绝对路径名。
findLibrary(String) - 类 javax.management.loading.MLet 中的方法
返回本机库的绝对路径名称。
findLoadedClass(String) - 类 java.lang.ClassLoader 中的方法
如果 Java 虚拟机已将此加载器记录为具有给定二进制名称的某个类的启动加载器，则返回该二进制名称的类。
findMBeanServer(String) - 类 javax.management.MBeanServerFactory 中的静态方法
返回已注册 MBeanServer 对象的列表。
findMedia(float, float, int) - 类 javax.print.attribute.standard.MediaSize 中的静态方法
指定的维度用于从所有标准 MediaSize 实例中定位一个匹配的 MediaSize 实例。
findMonitorDeadlockedThreads() - 接口 java.lang.management.ThreadMXBean 中的方法
找到处于死锁状态（等待获取对象监视器）的线程的周期。
findOffsetToCharactersInString(char[], int) - 类 javax.swing.text.ParagraphView 中的方法
根据 string 中字符查找文档中的下一个字符，起点是偏移量 start。
findReferencingRelations(ObjectName, String, String) - 类 javax.management.relation.RelationService 中的方法
检索在引用给定 MBean 的引用关系。
findReferencingRelations(ObjectName, String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索在其中引用给定 MBean 的关系。
findRelationsOfType(String) - 类 javax.management.relation.RelationService 中的方法
返回给定类型的关系的关系 id。
findRelationsOfType(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
返回给定类型的关系的关系 id。
findResource(String) - 类 java.lang.ClassLoader 中的方法
查找具有给定名称的资源。
findResource(String) - 类 java.net.URLClassLoader 中的方法
在 URL 搜索路径中查找具有指定名称的资源。
findResources(String) - 类 java.lang.ClassLoader 中的方法
返回表示所有具有给定名称的资源的 URL 对象的枚举。
findResources(String) - 类 java.net.URLClassLoader 中的方法
返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。
findSystemClass(String) - 类 java.lang.ClassLoader 中的方法
查找具有指定的二进制名称的类，必要时加载它。
findWithinHorizon(String, int) - 类 java.util.Scanner 中的方法
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。
findWithinHorizon(Pattern, int) - 类 java.util.Scanner 中的方法
试图查找下一个指定模式。
FINE - 类 java.util.logging.Level 中的静态变量
FINE 是提供跟踪信息的消息级别。
fine(String) - 类 java.util.logging.Logger 中的方法
记录一条 FINE 消息。
FINER - 类 java.util.logging.Level 中的静态变量
FINER 指示一条相当详细的跟踪消息。
finer(String) - 类 java.util.logging.Logger 中的方法
记录一条 FINER 消息。
FINEST - 类 java.util.logging.Level 中的静态变量
FINEST 指示一条最详细的跟踪消息。
finest(String) - 类 java.util.logging.Logger 中的方法
记录一条 FINEST 消息。
finish() - 类 java.util.zip.Deflater 中的方法
调用时，指示压缩应当以输入缓冲区的当前内容结尾。
finish() - 类 java.util.zip.DeflaterOutputStream 中的方法
完成将压缩数据写入输出流的操作，无需关闭底层流。
finish() - 类 java.util.zip.GZIPOutputStream 中的方法
完成将压缩数据写入输出流的操作，无需关闭底层流。
finish() - 类 java.util.zip.InflaterOutputStream 中的方法
完成将未压缩数据写入输出流的操作，无需关闭底层流。
finish() - 类 java.util.zip.ZipOutputStream 中的方法
完成写入 ZIP 输出流的内容，无需关闭底层流。
finishConnect() - 类 java.nio.channels.SocketChannel 中的方法
完成套接字通道的连接过程。
finishDraggingTo(int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
利用包含此实例的 finishDraggingTo 传递 BasicSplitPaneUI 的消息。
finishDraggingTo(int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
传递消息以完成拖动会话。
finished() - 类 java.util.zip.Deflater 中的方法
如果已到达压缩数据输出流的结尾，则返回 true。
finished() - 类 java.util.zip.Inflater 中的方法
如果已到达压缩数据流的结尾，则返回 true。
finishedPaintingChildren(JSplitPane, Graphics) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
在 JSplitPane 接收者将为绘制其子级提供外观后传递消息。
finishedPaintingChildren(JSplitPane, Graphics) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 finishedPaintingChildren 方法。
finishedPaintingChildren(JSplitPane, Graphics) - 类 javax.swing.plaf.SplitPaneUI 中的方法
在 JSplitPane 接收方提供外观来绘制其子组件之后传递消息。
Finishings - javax.print.attribute.standard 中的 类
Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
Finishings(int) - 类 javax.print.attribute.standard.Finishings 的构造方法
构造具有给定整数值的新 finishings 绑定枚举值。
fireActionEvent() - 类 javax.swing.JComboBox 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireActionPerformed(ActionEvent) - 类 javax.swing.AbstractButton 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireActionPerformed(ActionEvent) - 类 javax.swing.DefaultButtonModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireActionPerformed(String) - 类 javax.swing.JFileChooser 中的方法
通知对此事件类型感兴趣的所有侦听器。
fireActionPerformed() - 类 javax.swing.JTextField 中的方法
通知对此事件类型需要的所有侦听器。
fireActionPerformed(ActionEvent) - 类 javax.swing.Timer 中的方法
通知为此事件类型的通知而注册的所有侦听器。
fireAdjustmentValueChanged(int, int, int) - 类 javax.swing.JScrollBar 中的方法
通知侦听器该滚动条的模型已更改。
fireCaretUpdate(CaretEvent) - 类 javax.swing.text.JTextComponent 中的方法
通知所有已注册需要此事件类型的通知的侦听器。
fireChangedUpdate(DocumentEvent) - 类 javax.swing.text.AbstractDocument 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireChangedUpdate(DocumentEvent) - 类 javax.swing.text.html.HTMLDocument 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireChildrenAdded(BeanContextMembershipEvent) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。
fireChildrenRemoved(BeanContextMembershipEvent) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。
fireColumnAdded(TableColumnModelEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireColumnMarginChanged() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireColumnMoved(TableColumnModelEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireColumnRemoved(TableColumnModelEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireColumnSelectionChanged(ListSelectionEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireContentsChanged(Object, int, int) - 类 javax.swing.AbstractListModel 中的方法
AbstractListModel 子类必须在列表的一个或多个元素发生更改之后调用此方法。
fireContentsChanged() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
fireDragGestureRecognized(int, Point) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
通知 DragGestureListener 已发生了 Drag 和 Drop 开始动作。
fireEditingCanceled() - 类 javax.swing.AbstractCellEditor 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireEditingStopped() - 类 javax.swing.AbstractCellEditor 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireHyperlinkUpdate(HyperlinkEvent) - 类 javax.swing.JEditorPane 中的方法
通知因对此事件类型的通知感兴趣而已注册的所有侦听器。
fireIndexedPropertyChange(String, int, Object, Object) - 类 java.beans.PropertyChangeSupport 中的方法
报告所有已注册侦听器的绑定 (bound) 索引 (indexed) 属性更新。
fireIndexedPropertyChange(String, int, int, int) - 类 java.beans.PropertyChangeSupport 中的方法
以 int 值形式报告所有已注册侦听器的绑定索引属性更新。
fireIndexedPropertyChange(String, int, boolean, boolean) - 类 java.beans.PropertyChangeSupport 中的方法
以 boolean 值形式报告所有已注册侦听器的绑定索引属性更新。
fireInsertUpdate(DocumentEvent) - 类 javax.swing.text.AbstractDocument 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireInternalFrameEvent(int) - 类 javax.swing.JInternalFrame 中的方法
激发内部窗体事件。
fireIntervalAdded(Object, int, int) - 类 javax.swing.AbstractListModel 中的方法
AbstractListModel 子类必须在将一个或多个元素添加到模型中之后调用此方法。
fireIntervalRemoved(Object, int, int) - 类 javax.swing.AbstractListModel 中的方法
AbstractListModel 子类必须在从模型中移除一个或多个元素之后调用此方法。
fireItemStateChanged(ItemEvent) - 类 javax.swing.AbstractButton 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireItemStateChanged(ItemEvent) - 类 javax.swing.DefaultButtonModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireItemStateChanged(ItemEvent) - 类 javax.swing.JComboBox 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireMenuCanceled() - 类 javax.swing.JMenu 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireMenuDeselected() - 类 javax.swing.JMenu 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireMenuDragMouseDragged(MenuDragMouseEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuDragMouseEntered(MenuDragMouseEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuDragMouseExited(MenuDragMouseEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuDragMouseReleased(MenuDragMouseEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuKeyPressed(MenuKeyEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuKeyReleased(MenuKeyEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuKeyTyped(MenuKeyEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuSelected() - 类 javax.swing.JMenu 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
firePopupMenuCanceled() - 类 javax.swing.JComboBox 中的方法
通知 PopupMenuListener 组合框的弹出部分已被取消。
firePopupMenuCanceled() - 类 javax.swing.JPopupMenu 中的方法
通知 PopupMenuListener 此弹出菜单将被取消。
firePopupMenuCanceled() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
firePopupMenuWillBecomeInvisible() - 类 javax.swing.JComboBox 中的方法
通知 PopupMenuListener 组合框的弹出部分已变得不可见。
firePopupMenuWillBecomeInvisible() - 类 javax.swing.JPopupMenu 中的方法
通知 PopupMenuListener 此弹出菜单将变得不可见。
firePopupMenuWillBecomeInvisible() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
firePopupMenuWillBecomeVisible() - 类 javax.swing.JComboBox 中的方法
通知 PopupMenuListener 组合框的弹出部分将变得可见。
firePopupMenuWillBecomeVisible() - 类 javax.swing.JPopupMenu 中的方法
通知 PopupMenuListener 此弹出菜单将变得可见。
firePopupMenuWillBecomeVisible() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
firePropertyChange(String, Object, Object) - 类 java.awt.Component 中的方法
支持报告 Object 属性的绑定属性改变。
firePropertyChange(String, boolean, boolean) - 类 java.awt.Component 中的方法
支持报告布尔属性的绑定属性改变。
firePropertyChange(String, int, int) - 类 java.awt.Component 中的方法
支持报告整数属性的绑定属性改变。
firePropertyChange(String, byte, byte) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, char, char) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, short, short) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, long, long) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, float, float) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, double, double) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, Object, Object) - 类 java.awt.KeyboardFocusManager 中的方法
激发 PropertyChangeEvent 以响应绑定属性中的更改。
firePropertyChange(String, Object, Object) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
向所有已注册的侦听器报告绑定 (bound) 属性更新。
firePropertyChange(String, Object, Object) - 类 java.beans.PropertyChangeSupport 中的方法
报告所有已注册侦听器的绑定属性更新。
firePropertyChange(String, int, int) - 类 java.beans.PropertyChangeSupport 中的方法
以 int 值形式报告所有已注册侦听器的绑定属性更新。
firePropertyChange(String, boolean, boolean) - 类 java.beans.PropertyChangeSupport 中的方法
以 boolean 值形式报告所有已注册侦听器的绑定属性更新。
firePropertyChange(PropertyChangeEvent) - 类 java.beans.PropertyChangeSupport 中的方法
对所有已注册侦听器激发一个现有 PropertyChangeEvent。
firePropertyChange() - 类 java.beans.PropertyEditorSupport 中的方法
报告已经修改所有感兴趣的侦听器。
firePropertyChange(String, Object, Object) - 类 javax.accessibility.AccessibleContext 中的方法
对报告 bound 属性更改的支持。
firePropertyChange(String, Object, Object) - 类 javax.swing.AbstractAction 中的方法
支持报告绑定 (bound) 属性的改变。
firePropertyChange(String, Object, Object) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, byte, byte) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, char, char) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, short, short) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, int, int) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, long, long) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, float, float) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, double, double) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, boolean, boolean) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(PropertyChangeEvent) - 类 javax.swing.event.SwingPropertyChangeSupport 中的方法
对所有已注册侦听器激发一个现有 PropertyChangeEvent。
firePropertyChange(String, boolean, boolean) - 类 javax.swing.JComponent 中的方法
支持报告 boolean 属性的绑定属性更改。
firePropertyChange(String, int, int) - 类 javax.swing.JComponent 中的方法
支持报告整数属性的绑定属性更改。
firePropertyChange(String, char, char) - 类 javax.swing.JComponent 中的方法
firePropertyChange(String, Object, Object) - 类 javax.swing.JViewport 中的方法
通知侦听器发生的属性更改。
firePropertyChange(String, Object, Object) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
支持报告 boolean 属性的绑定属性的改变。
firePropertyChange(String, Object, Object) - 类 javax.swing.SwingWorker 中的方法
向所有已注册的侦听器报告绑定属性更新。
firePropertyChange(String, Object, Object) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, boolean, boolean) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, Object, Object) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, byte, byte) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, char, char) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, short, short) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, int, int) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, long, long) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, float, float) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, double, double) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, boolean, boolean) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, Object, Object) - 类 javax.swing.UIDefaults 中的方法
支持报告绑定属性更改。
fireRemoveUpdate(DocumentEvent) - 类 javax.swing.text.AbstractDocument 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireRowSorterChanged(int[]) - 类 javax.swing.RowSorter 中的方法
通知侦听器映射关系发生了更改。
fireSelectionValueChanged(int, int, boolean) - 类 javax.swing.JList 中的方法
通知直接添加到列表的 ListSelectionListener 对列表模型做出了选择更改。
fireServiceAdded(Class) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
触发一个通知新服务的 BeanContextServiceEvent。
fireServiceAdded(BeanContextServiceAvailableEvent) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
触发一个指示新服务已变得可用的 BeanContextServiceAvailableEvent。
fireServiceRevoked(BeanContextServiceRevokedEvent) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
触发一个通知将被取消的服务的 BeanContextServiceEvent。
fireServiceRevoked(Class, boolean) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
触发一个指示某一特定服务不再可用的 BeanContextServiceRevokedEvent。
fireSortOrderChanged() - 类 javax.swing.RowSorter 中的方法
通知侦听器排序顺序发生了更改。
fireStateChanged() - 类 javax.swing.AbstractButton 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireStateChanged() - 类 javax.swing.AbstractSpinnerModel 中的方法
运行每个 ChangeListeners stateChanged() 方法。
fireStateChanged() - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
运行每个 ChangeListener 的 stateChanged 方法。
fireStateChanged() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
运行每个 ChangeListener 的 stateChanged 方法。
fireStateChanged() - 类 javax.swing.DefaultButtonModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireStateChanged() - 类 javax.swing.DefaultSingleSelectionModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireStateChanged() - 类 javax.swing.JProgressBar 中的方法
将一个 ChangeEvent（其源是此 JProgressBar）发送给针对 ChangeEvent 的所有已注册 ChangeListener。
fireStateChanged() - 类 javax.swing.JSlider 中的方法
将一个其源为此 JSlider 的 ChangeEvent 发送到所有需要 ChangeEvent 的已注册 ChangeListener。
fireStateChanged() - 类 javax.swing.JSpinner 中的方法
将一个其源为此 JSpinner 的 ChangeEvent 发送到每个 ChangeListener。
fireStateChanged() - 类 javax.swing.JTabbedPane 中的方法
将一个 ChangeEvent（以此 JTabbedPane 作为源）发送到每个已注册的侦听器。
fireStateChanged() - 类 javax.swing.JViewport 中的方法
在视图的大小、位置或视口的扩展大小更改时通知所有 ChangeListeners。
fireStateChanged() - 类 javax.swing.MenuSelectionManager 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireStateChanged() - 类 javax.swing.text.DefaultCaret 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireStateChanged() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireTableCellUpdated(int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，已更新 [row, column] 处的单元格值。
fireTableChanged(TableModelEvent) - 类 javax.swing.table.AbstractTableModel 中的方法
将给定的通知事件转发到所有将自身注册为此表模型的侦听器的 TableModelListeners。
fireTableDataChanged() - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，表的所有行单元格值可能已更改。
fireTableRowsDeleted(int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，已删除范围在 [firstRow, lastRow]（包括）的行。
fireTableRowsInserted(int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，已插入范围在 [firstRow, lastRow]（包括）的行。
fireTableRowsUpdated(int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，已更新范围在 [firstRow, lastRow]（包括）的行。
fireTableStructureChanged() - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，表的结构已更改。
fireTreeCollapsed(TreePath) - 类 javax.swing.JTree 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireTreeExpanded(TreePath) - 类 javax.swing.JTree 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireTreeNodesChanged(Object, Object[], int[], Object[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireTreeNodesInserted(Object, Object[], int[], Object[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireTreeNodesRemoved(Object, Object[], int[], Object[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireTreeStructureChanged(Object, Object[], int[], Object[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireTreeWillCollapse(TreePath) - 类 javax.swing.JTree 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireTreeWillExpand(TreePath) - 类 javax.swing.JTree 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireUndoableEditUpdate(UndoableEditEvent) - 类 javax.swing.text.AbstractDocument 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireUndoableEditUpdate(UndoableEditEvent) - 类 javax.swing.text.html.HTMLDocument 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireValueChanged(boolean) - 类 javax.swing.DefaultListSelectionModel 中的方法
通知侦听器已经结束了一系列的调整。
fireValueChanged(int, int) - 类 javax.swing.DefaultListSelectionModel 中的方法
通知 ListSelectionListener 选择的值已发生更改，该值在 firstIndex 和 lastIndex 组成的闭区间内。
fireValueChanged(int, int, boolean) - 类 javax.swing.DefaultListSelectionModel 中的方法
fireValueChanged(TreeSelectionEvent) - 类 javax.swing.JTree 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireValueChanged(TreeSelectionEvent) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
通知已注册此对象上的树选择事件的所有侦听器。
fireVetoableChange(String, Object, Object) - 类 java.awt.KeyboardFocusManager 中的方法
激发 PropertyChangeEvent 以响应可否决属性中的更改。
fireVetoableChange(String, Object, Object) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
向所有已注册的侦听器报告 vetoable 属性更新。
fireVetoableChange(String, Object, Object) - 类 java.beans.VetoableChangeSupport 中的方法
向所有已注册的侦听器报告 vetoable 属性更新。
fireVetoableChange(String, int, int) - 类 java.beans.VetoableChangeSupport 中的方法
向所有已注册的侦听器报告一个 int vetoable 属性更新。
fireVetoableChange(String, boolean, boolean) - 类 java.beans.VetoableChangeSupport 中的方法
向所有已注册的侦听器报告一个 boolean vetoable 属性更新。
fireVetoableChange(PropertyChangeEvent) - 类 java.beans.VetoableChangeSupport 中的方法
对所有已注册侦听器激发一个 vetoable 属性更新。
fireVetoableChange(String, Object, Object) - 类 javax.swing.JComponent 中的方法
支持报告约束 (constrained) 属性的更改。
fireVisibleDataPropertyChange() - 类 javax.swing.JTree.AccessibleJTree 中的方法
激发可见数据属性更改通知。
first(Container) - 类 java.awt.CardLayout 中的方法
翻转到容器的第一张卡片。
first() - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的第一行。
first() - 类 java.text.BreakIterator 中的方法
返回第一个边界。
first() - 接口 java.text.CharacterIterator 中的方法
将位置设置为 getBeginIndex()，并返回该位置的字符。
first() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.first()。
first() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
first() - 接口 java.util.SortedSet 中的方法
返回此 set 中当前第一个（最低）元素。
first() - 类 java.util.TreeSet 中的方法
first() - 类 javax.swing.text.ElementIterator 中的方法
获取第一个元素。
first(Object) - 类 javax.swing.text.html.parser.ContentModel 中的方法
如果标记可能为输入流中第一个标记，则返回 true。
first() - 类 javax.swing.text.html.parser.ContentModel 中的方法
返回必须具有下一个的元素。
first() - 类 javax.swing.text.Segment 中的方法
将位置设置为 getBeginIndex()，并返回该位置的字符。
FIRST_LINE_END - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于显示区域的一角，在该区域中，当前 ComponentOrienation 的页面的第一个文本行正常结束。
FIRST_LINE_START - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的开始位置。
firstColumn - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的变量
firstElement() - 类 java.util.Vector 中的方法
返回此向量的第一个组件（位于索引 0) 处的项）。
firstElement() - 类 javax.swing.DefaultListModel 中的方法
返回此列表中的第一个组件。
firstEntry() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。
firstEntry() - 接口 java.util.NavigableMap 中的方法
返回一个与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
firstEntry() - 类 java.util.TreeMap 中的方法
firstKey() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
firstKey() - 接口 java.util.SortedMap 中的方法
返回此映射中当前第一个（最低）键。
firstKey() - 类 java.util.TreeMap 中的方法
firstLineIndent - 类 javax.swing.text.ParagraphView 中的变量
相对于左边的 inset 进行的第一行的缩进。
FirstLineIndent - 类 javax.swing.text.StyleConstants 中的静态变量
段落第一行要缩进的空间量。
firstRow - 类 javax.swing.event.TableModelEvent 中的变量
firstRow - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的变量
FIXED - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
fixed_digits() - 类 org.omg.CORBA.TypeCode 中的方法
返回此 TypeCode 对象所描述的 fixed 类型中数字的数量。
fixed_scale() - 类 org.omg.CORBA.TypeCode 中的方法
返回此 TypeCode 对象所描述的 fixed 类型的标度。
fixedCellHeightChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
fixedCellWidthChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
fixedContentLength - 类 java.net.HttpURLConnection 中的变量
使用固定长度流模式时的固定内容长度。
FixedHeightLayoutCache - javax.swing.tree 中的 类
注：在以后的版本中，这将变得更加开放。
FixedHeightLayoutCache() - 类 javax.swing.tree.FixedHeightLayoutCache 的构造方法
FixedHolder - org.omg.CORBA 中的 类
Fixed 的 Holder。
FixedHolder() - 类 org.omg.CORBA.FixedHolder 的构造方法
构造 FixedHolder，不初始化所包含的值。
FixedHolder(BigDecimal) - 类 org.omg.CORBA.FixedHolder 的构造方法
构造 FixedHolder，并使用给定值初始化。
FLAG_COMPLEX_GLYPHS - 类 java.awt.font.GlyphVector 中的静态变量
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 具有从字形到字符的复杂映射关系（此映射并非严格按照与排列方向匹配的升序或降序顺序将字形一一映射到字符）。
FLAG_HAS_POSITION_ADJUSTMENTS - 类 java.awt.font.GlyphVector 中的静态变量
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 调整了位置。
FLAG_HAS_TRANSFORMS - 类 java.awt.font.GlyphVector 中的静态变量
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 的每个字形都有转换。
FLAG_MASK - 类 java.awt.font.GlyphVector 中的静态变量
getLayoutFlags 支持标志的掩码。
FLAG_RUN_RTL - 类 java.awt.font.GlyphVector 中的静态变量
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 具有从右到左的排列方向。
flags() - 类 java.util.regex.Pattern 中的方法
返回此模式的匹配标志。
flags() - 类 org.omg.CORBA.NamedValue 中的方法
检索用于此 NamedValue 对象的参数模式标志。
FLASH_OPTION - 类 javax.swing.DebugGraphics 中的静态变量
Flash 图形操作。
flashColor() - 类 javax.swing.DebugGraphics 中的静态方法
返回用于 flash 绘制操作的 Color。
flashCount() - 类 javax.swing.DebugGraphics 中的静态方法
绘制操作将要 flash 的次数。
flashTime() - 类 javax.swing.DebugGraphics 中的静态方法
返回绘制操作 flash 的时间延迟。
FlatteningPathIterator - java.awt.geom 中的 类
FlatteningPathIterator 类返回另一个 PathIterator 对象的变平视图。
FlatteningPathIterator(PathIterator, double) - 类 java.awt.geom.FlatteningPathIterator 的构造方法
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。
FlatteningPathIterator(PathIterator, double, int) - 类 java.awt.geom.FlatteningPathIterator 的构造方法
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。
FlavorEvent - java.awt.datatransfer 中的 类
FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。
FlavorEvent(Clipboard) - 类 java.awt.datatransfer.FlavorEvent 的构造方法
构造一个 FlavorEvent 对象。
FlavorException - javax.print 中的 接口
接口 FlavorException 是一个混合接口，PrintException 的子类可实现它来报告有关某个 DocFlavor 或多个 DocFlavor（类 DocFlavor）的错误状况。
FlavorListener - java.awt.datatransfer 中的 接口
定义侦听 FlavorEvent 的对象。
FlavorMap - java.awt.datatransfer 中的 接口
"native" (String)（对应于特定平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的双向 Map。
flavorsChanged(FlavorEvent) - 接口 java.awt.datatransfer.FlavorListener 中的方法
当侦听器的目标 Clipboard 已更改其可用的 DataFlavor 时调用。
FlavorTable - java.awt.datatransfer 中的 接口
放宽传统一对一 Map 限制的 FlavorMap。
flip(BufferCapabilities.FlipContents) - 类 java.awt.Component.FlipBufferStrategy 中的方法
将底层缓冲区的内容翻转移动到前台缓冲区，可通过复制或移动视频指针来执行。
flip() - 类 java.nio.Buffer 中的方法
反转此缓冲区。
flip(int) - 类 java.util.BitSet 中的方法
将指定索引处的位设置为其当前值的补码。
flip(int, int) - 类 java.util.BitSet 中的方法
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的每个位设置为其当前值的补码。
flipBit(int) - 类 java.math.BigInteger 中的方法
返回其值与对此 BigInteger 进行指定位翻转后的值等效的 BigInteger。
flipEastAndWestAtEnds(int, Position.Bias) - 类 javax.swing.text.BoxView 中的方法
确定下一个视图的放置方向。
flipEastAndWestAtEnds(int, Position.Bias) - 类 javax.swing.text.CompositeView 中的方法
确定下一个视图放置的朝向。
flipEastAndWestAtEnds(int, Position.Bias) - 类 javax.swing.text.ParagraphView 中的方法
确定下一个视图要布置的方向。
Float - java.lang 中的 类
Float 类在对象中包装一个基本类型 float 的值。
Float(float) - 类 java.lang.Float 的构造方法
构造一个新分配的 Float 对象，它表示基本的 float 参数。
Float(double) - 类 java.lang.Float 的构造方法
构造一个新分配的 Float 对象，它表示转换为 float 类型的参数。
Float(String) - 类 java.lang.Float 的构造方法
构造一个新分配的 Float 对象，它表示用字符串表示的 float 类型的浮点值。
FLOAT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 FLOAT 的 Java 编程语言中的常量（有时称为类型代码）。
FLOAT - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Float 的值。
FLOAT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
floatAt(Point, Point) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
FloatBuffer - java.nio 中的 类
float 缓冲区。
FloatControl - javax.sound.sampled 中的 类
FloatControl 对象提供对浮点值范围的控制。
FloatControl(FloatControl.Type, float, float, float, int, float, String, String, String, String) - 类 javax.sound.sampled.FloatControl 的构造方法
构造具有给定参数的新 float 控件对象
FloatControl(FloatControl.Type, float, float, float, int, float, String) - 类 javax.sound.sampled.FloatControl 的构造方法
构造具有给定参数的新 float 控件对象。
FloatControl.Type - javax.sound.sampled 中的 类
FloatControl.Type 内部类的实例标识了某种 float 控件。
FloatControl.Type(String) - 类 javax.sound.sampled.FloatControl.Type 的构造方法
构造新的 float 控件类型。
FloatHolder - org.omg.CORBA 中的 类
Float 的 Holder。
FloatHolder() - 类 org.omg.CORBA.FloatHolder 的构造方法
构造一个新的 FloatHolder 对象，将其 value 字段初始化为 0.0。
FloatHolder(float) - 类 org.omg.CORBA.FloatHolder 的构造方法
为给定 float 值构造一个新 FloatHolder 对象。
floatingBorderColor - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
floatingColor - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
FloatSeqHelper - org.omg.CORBA 中的 类
FloatSeq 的 Helper。
FloatSeqHelper() - 类 org.omg.CORBA.FloatSeqHelper 的构造方法
FloatSeqHolder - org.omg.CORBA 中的 类
FloatSeq 的 Holder。
FloatSeqHolder() - 类 org.omg.CORBA.FloatSeqHolder 的构造方法
FloatSeqHolder(float[]) - 类 org.omg.CORBA.FloatSeqHolder 的构造方法
floatToIntBits(float) - 类 java.lang.Float 中的静态方法
根据 IEEE 754 浮点“单一格式”位布局，返回指定浮点值的表示形式。
floatToRawIntBits(float) - 类 java.lang.Float 中的静态方法
根据 IEEE 754 浮点“单一格式”位布局，返回指定浮点值的表示形式，并保留非数字 (NaN) 值。
floatValue() - 类 java.lang.Byte 中的方法
作为一个 float 返回此 Byte 的值。
floatValue() - 类 java.lang.Double 中的方法
返回此 Double 对象的 float 值。
floatValue() - 类 java.lang.Float 中的方法
返回此 Float 对象的 float 值。
floatValue() - 类 java.lang.Integer 中的方法
以 float 类型返回该 Integer 的值。
floatValue() - 类 java.lang.Long 中的方法
以 float 形式返回此 Long 的值。
floatValue() - 类 java.lang.Number 中的方法
以 float 形式返回指定的数值。
floatValue() - 类 java.lang.Short 中的方法
以 float 形式返回此 Short 的值。
floatValue() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 float。
floatValue() - 类 java.math.BigInteger 中的方法
将此 BigInteger 转换为 float。
floatValue() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
floatValue() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
floor(double) - 类 java.lang.Math 中的静态方法
返回最大的（最接近正无穷大）double 值，该值小于等于参数，并等于某个整数。
floor(double) - 类 java.lang.StrictMath 中的静态方法
返回最大的（最接近正无穷大）double 值，该值小于等于参数，并等于某个整数。
floor(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
floor(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 中小于等于给定元素的最大元素；如果不存在这样的元素，则返回 null。
floor(E) - 类 java.util.TreeSet 中的方法
floorEntry(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与小于等于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。
floorEntry(K) - 接口 java.util.NavigableMap 中的方法
返回一个键-值映射关系，它与小于等于给定键的最大键关联；如果不存在这样的键，则返回 null。
floorEntry(K) - 类 java.util.TreeMap 中的方法
floorKey(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
floorKey(K) - 接口 java.util.NavigableMap 中的方法
返回小于等于给定键的最大键；如果不存在这样的键，则返回 null。
floorKey(K) - 类 java.util.TreeMap 中的方法
floppyDriveIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
FlowLayout - java.awt 中的 类
流布局用于安排有向流中的组件，这非常类似于段落中的文本行。
FlowLayout() - 类 java.awt.FlowLayout 的构造方法
构造一个新的 FlowLayout，它是居中对齐的，默认的水平和垂直间隙是 5 个单位。
FlowLayout(int) - 类 java.awt.FlowLayout 的构造方法
构造一个新的 FlowLayout，它具有指定的对齐方式，默认的水平和垂直间隙是 5 个单位。
FlowLayout(int, int, int) - 类 java.awt.FlowLayout 的构造方法
创建一个新的流布局管理器，它具有指定的对齐方式以及指定的水平和垂直间隙。
FLOWS_FROM - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象出现在该对象前面。
FLOWS_FROM_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个对象之间的 FLOWS_FROM 关系已更改。
FLOWS_TO - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象在该对象后面出现。
FLOWS_TO_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个对象之间的 FLOWS_TO 关系已更改。
FlowView - javax.swing.text 中的 类
试图将其子级流入某个部分受约束的空间的视图。
FlowView(Element, int) - 类 javax.swing.text.FlowView 的构造方法
构造给定元素的 FlowView。
FlowView.FlowStrategy - javax.swing.text 中的 类
维护流的物理形式的策略。
FlowView.FlowStrategy() - 类 javax.swing.text.FlowView.FlowStrategy 的构造方法
flush() - 类 java.awt.Image 中的方法
刷新此 Image 对象正在使用的所有可重构的资源。
flush() - 类 java.beans.XMLEncoder 中的方法
如果还没有写出导言，那么此方法将写出与 XML 编码有关的导言，并随后写出从最后一次调用 flush 以来写入流中的所有值。
flush() - 类 java.io.BufferedOutputStream 中的方法
刷新此缓冲的输出流。
flush() - 类 java.io.BufferedWriter 中的方法
刷新该流的缓冲。
flush() - 类 java.io.CharArrayWriter 中的方法
刷新该流的缓冲。
flush() - 类 java.io.Console 中的方法
刷新控制台，并强制立即写入所有缓冲的输出。
flush() - 类 java.io.DataOutputStream 中的方法
清空此数据输出流。
flush() - 类 java.io.FilterOutputStream 中的方法
刷新此输出流，并强制将所有已缓冲的输出字节写入该流中。
flush() - 类 java.io.FilterWriter 中的方法
刷新该流的缓冲。
flush() - 接口 java.io.Flushable 中的方法
通过将所有已缓冲输出写入底层流来刷新此流。
flush() - 接口 java.io.ObjectOutput 中的方法
刷新该流的缓冲。
flush() - 类 java.io.ObjectOutputStream 中的方法
刷新该流的缓冲。
flush() - 类 java.io.OutputStream 中的方法
刷新此输出流并强制写出所有缓冲的输出字节。
flush() - 类 java.io.OutputStreamWriter 中的方法
刷新该流的缓冲。
flush() - 类 java.io.PipedOutputStream 中的方法
刷新此输出流并强制写出所有缓冲的输出字节。
flush() - 类 java.io.PipedWriter 中的方法
刷新此输出流并强制写出所有缓冲的输出字符。
flush() - 类 java.io.PrintStream 中的方法
刷新该流的缓冲。
flush() - 类 java.io.PrintWriter 中的方法
刷新该流的缓冲。
flush() - 类 java.io.StringWriter 中的方法
刷新该流的缓冲。
flush() - 类 java.io.Writer 中的方法
刷新该流的缓冲。
flush(CharBuffer) - 类 java.nio.charset.CharsetDecoder 中的方法
刷新此解码器。
flush(ByteBuffer) - 类 java.nio.charset.CharsetEncoder 中的方法
刷新此编码器。
flush() - 类 java.util.Formatter 中的方法
刷新此 formatter。
flush() - 类 java.util.logging.Handler 中的方法
刷新所有的缓冲输出。
flush() - 类 java.util.logging.MemoryHandler 中的方法
导致目标 Handler 上的刷新。
flush() - 类 java.util.logging.StreamHandler 中的方法
刷新所有缓冲消息。
flush() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.flush() 中的规范实现 flush 方法。
flush() - 类 java.util.prefs.Preferences 中的方法
强制进行从此首选项节点及其子节点到持久存储的内容更改。
flush() - 类 java.util.zip.InflaterOutputStream 中的方法
刷新此输出流，并强制写出挂起的所有缓冲输出字节。
flush() - 类 javax.crypto.CipherOutputStream 中的方法
强制写出已由封装的密码对象处理的任何缓存输出字节来刷新此输出流。
flush() - 接口 javax.imageio.stream.ImageInputStream 中的方法
丢弃当前流位置之前的流初始部分。
flush() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
flush() - 接口 javax.sound.sampled.DataLine 中的方法
刷新数据行中已列队的数据。
flush() - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
在 reader 上调用的最后一个方法。
flush() - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
flush() - 类 javax.tools.ForwardingJavaFileManager 中的方法
flush() - 接口 javax.tools.JavaFileManager 中的方法
刷新此文件管理器直接或间接为输出打开的所有资源。
flush() - 接口 javax.xml.stream.XMLEventWriter 中的方法
将所有缓存事件写入到底层输出机制。
flush() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
将所有缓存数据写入底层输出机制。
FLUSH_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
FLUSH_FAILURE 用于对输出流的刷新失败时。
Flushable - java.io 中的 接口
Flushable 是可刷新数据的目标地。
flushAttributes() - 类 javax.swing.text.html.parser.Parser 中的方法
flushBefore(long) - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
flushBefore(long) - 接口 javax.imageio.stream.ImageInputStream 中的方法
丢弃所指示位置之前的流初始部分。
flushBefore(long) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
flushBefore(long) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
刷新给定位置之前所有数据的缓冲并转到底层目标（如 OutputStream 或 File）。
flushBefore(long) - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
flushBefore(long) - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
flushBits() - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
如果位偏移量为非零，则将当前字节中的剩余位强制归 0，并将流位置前移一个字节。
flushCaches() - 类 java.beans.Introspector 中的静态方法
刷新所有 Introspector 的内部缓存。
flushedPos - 类 javax.imageio.stream.ImageInputStreamImpl 中的变量
可能丢弃的数据前面的那个位置。
flushFromCaches(Class<?>) - 类 java.beans.Introspector 中的静态方法
刷新给定类的 Introspector 的内部缓存信息。
flushRequirementChanges() - 类 javax.swing.text.AsyncBoxView 中的方法
将首选项中的更改向上发布到父视图。
flushSpi() - 类 java.util.prefs.AbstractPreferences 中的方法
此方法是在此节点被锁定的情况下调用的。
focus - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
FOCUS - 类 javax.swing.plaf.synth.ColorType 中的静态变量
焦点的 ColorType。
FOCUS_ACCELERATOR_KEY - 类 javax.swing.text.JTextComponent 中的静态变量
焦点加速键的绑定 (bound) 属性名称。
FOCUS_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择焦点事件的事件掩码。
FOCUS_FIRST - 类 java.awt.event.FocusEvent 中的静态变量
用于焦点事件的 id 范围的起始编号。
FOCUS_GAINED - 类 java.awt.event.FocusEvent 中的静态变量
此事件指示 Component 现在是焦点所有者。
FOCUS_LAST - 类 java.awt.event.FocusEvent 中的静态变量
用于焦点事件的 id 范围的结束编号。
FOCUS_LOST - 类 java.awt.event.FocusEvent 中的静态变量
此事件指示 Component 不再是焦点所有者。
FOCUS_MANAGER_CLASS_PROPERTY - 类 javax.swing.FocusManager 中的静态变量
该字段已被废弃，不鼓励使用它，因为它的规范与 1.4 focus API 不兼容。
FOCUS_PAINTED_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识是否在边框拥有焦点时高亮显示。
FOCUSABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象可以接受键盘焦点，这意味着当它具有焦点时，由键盘上的键入操作所产生的所有事件将被传递到此对象。
FocusAdapter - java.awt.event 中的 类
用于接收键盘焦点事件的抽象适配器类。
FocusAdapter() - 类 java.awt.event.FocusAdapter 的构造方法
focusColor - 类 javax.swing.plaf.metal.MetalButtonUI 中的变量
focusColor - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的变量
focusColor - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的变量
FOCUSED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象当前具有键盘焦点。
FOCUSED - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示 region 拥有焦点。
focusedCompIndex - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
FocusEvent - java.awt.event 中的 类
指示 Component 已获得或失去输入焦点的低级别事件。
FocusEvent(Component, int, boolean, Component) - 类 java.awt.event.FocusEvent 的构造方法
构造一个 FocusEvent 对象，它具有指定的暂时状态和对立 Component。
FocusEvent(Component, int, boolean) - 类 java.awt.event.FocusEvent 的构造方法
构造一个 FocusEvent 对象，并将标识更改是否为暂时的。
FocusEvent(Component, int) - 类 java.awt.event.FocusEvent 的构造方法
构造一个 FocusEvent 对象，并将它标识为一个持久性焦点更改。
focusGained(FocusEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 focusGained 方法处理 focusGained 事件。
focusGained(FocusEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 中的方法
focusGained(FocusEvent) - 类 java.awt.event.FocusAdapter 中的方法
组件获得键盘焦点时调用。
focusGained(FocusEvent) - 接口 java.awt.event.FocusListener 中的方法
组件获得键盘焦点时调用。
focusGained(FocusEvent) - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicListUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicTableUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.FocusHandler 中的方法
在当前树上激活焦点、重绘前导行时调用。
focusGained(FocusEvent) - 类 javax.swing.text.DefaultCaret 中的方法
在包含插入符的组件获得焦点时调用。
focusInsets - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
FocusListener - java.awt.event 中的 接口
用于接收组件上的键盘焦点事件的侦听器接口。
focusListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
focusListener - 类 javax.swing.plaf.basic.BasicListUI 中的变量
focusListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
focusListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
此 JSplitPane 的 FocusListener 的实例。
focusListener - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
focusListener - 类 javax.swing.plaf.basic.BasicTableUI 中的变量
focusLost(FocusEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 focusLost 方法处理 focusLost 事件。
focusLost(FocusEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 中的方法
focusLost(FocusEvent) - 类 java.awt.event.FocusAdapter 中的方法
组件失去键盘焦点时调用。
focusLost(FocusEvent) - 接口 java.awt.event.FocusListener 中的方法
组件失去键盘焦点时调用。
focusLost(FocusEvent) - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicListUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicTableUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.FocusHandler 中的方法
在当前树上激活焦点、重绘前导行时调用。
focusLost(FocusEvent) - 类 javax.swing.text.DefaultCaret 中的方法
在包含插入符的组件失去焦点时调用。
FocusManager - javax.swing 中的 类
从 1.4 focus API 开始，此类已被废弃。
FocusManager() - 类 javax.swing.FocusManager 的构造方法
focusNextComponent(Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
使 aComponent 后面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。
focusNextComponent(Component) - 类 java.awt.KeyboardFocusManager 中的方法
聚焦 aComponent 之后的 Component，通常基于 FocusTraversalPolicy。
focusNextComponent() - 类 java.awt.KeyboardFocusManager 中的方法
聚焦当前焦点所有者之后的 Component。
focusPreviousComponent(Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
使 aComponent 前面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。
focusPreviousComponent(Component) - 类 java.awt.KeyboardFocusManager 中的方法
聚焦 aComponent 之前的 Component，通常基于 FocusTraversalPolicy。
focusPreviousComponent() - 类 java.awt.KeyboardFocusManager 中的方法
聚焦当前焦点所有者之前的 Component。
focusRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
FocusTraversalPolicy - java.awt 中的 类
FocusTraversalPolicy 定义一种顺序，按此顺序遍历具有特定焦点循环根的 Component。
FocusTraversalPolicy() - 类 java.awt.FocusTraversalPolicy 的构造方法
FOLIO - 类 java.awt.PageAttributes.MediaType 中的静态变量
Folio (8 1/2 x 13 in) 的 MediaType 实例。
FOLIO - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 folio 尺寸，8.5 inch × 13 inch。
FOLIO - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
folio 尺寸。
following(int) - 类 java.text.BreakIterator 中的方法
返回指定字符偏移量后面的第一个边界。
Font - java.awt 中的 类
Font 类表示字体，可以使用它以可见方式呈现文本。
Font(String, int, int) - 类 java.awt.Font 的构造方法
根据指定名称、样式和磅值大小，创建一个新 Font。
Font(Map<? extends AttributedCharacterIterator.Attribute, ?>) - 类 java.awt.Font 的构造方法
创建一个具有指定属性的新 Font。
Font(Font) - 类 java.awt.Font 的构造方法
根据指定 font 创建一个新 Font。
FONT - 类 java.awt.font.TextAttribute 中的静态变量
用于提供呈现文本字体的属性键。
font - 类 java.awt.FontMetrics 中的变量
实际的 Font，字体规格是由此创建的。
FONT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
FONT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
font - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
用以绘制的字体，null 指示将使用呈现器的字体。
FONT_CHANGE_BIGGER - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
字体大小增大到下一个值的动作标识符
FONT_CHANGE_SMALLER - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
字体大小减小到下一个值的动作标识符
FONT_CHOOSER - 类 javax.accessibility.AccessibleRole 中的静态变量
FONT_CHOOSER 是允许用户选择各种字体属性的组件。
FONT_FAMILY - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
FONT_SIZE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
FONT_STYLE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
FONT_VARIANT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
FONT_WEIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
fontChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
FontFamily - 类 javax.swing.text.StyleConstants 中的静态变量
字体系列的名称。
FontFormatException - java.awt 中的 异常
此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。
FontFormatException(String) - 异常 java.awt.FontFormatException 的构造方法
报告一个指定了原因的 FontFormatException。
FontMetrics - java.awt 中的 类
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
FontMetrics(Font) - 类 java.awt.FontMetrics 的构造方法
创建一个新 FontMetrics 对象，用于查找该 Font 中关于指定 Font 和特定字符字形的 height 和 width 信息。
FontRenderContext - java.awt.font 中的 类
FontRenderContext 类是正确测量文本所需的信息容器。
FontRenderContext() - 类 java.awt.font.FontRenderContext 的构造方法
构造一个新 FontRenderContext 对象。
FontRenderContext(AffineTransform, boolean, boolean) - 类 java.awt.font.FontRenderContext 的构造方法
根据可选的 AffineTransform 和两个 boolean 值构造一个 FontRenderContext 对象，这两个 boolean 值确定新构造的对象是否具有 anti-aliasing 或 fractional metrics 属性。
FontRenderContext(AffineTransform, Object, Object) - 类 java.awt.font.FontRenderContext 的构造方法
根据一个可选 AffineTransform 和两个 Object 值构造一个 FontRenderContext 对象，这两个值决定了新创建的对象是具有 anti-aliasing 属性，还是具有 fractional metrics 属性。
FontSize - 类 javax.swing.text.StyleConstants 中的静态变量
字体大小的名称。
FontUIResource - javax.swing.plaf 中的 类
实现 UIResource 的 java.awt.Font 的子类。
FontUIResource(String, int, int) - 类 javax.swing.plaf.FontUIResource 的构造方法
FontUIResource(Font) - 类 javax.swing.plaf.FontUIResource 的构造方法
FOOTER - 类 javax.accessibility.AccessibleRole 中的静态变量
文本脚注
force(boolean) - 类 java.nio.channels.FileChannel 中的方法
强制将所有对此通道的文件更新写入包含该文件的存储设备中。
force() - 类 java.nio.MappedByteBuffer 中的方法
将此缓冲区所做的内容更改强制写入包含映射文件的存储设备中。
ForcedBreakWeight - 类 javax.swing.text.View 中的静态变量
该权重指示视图支持拆分，并且在被置入一个通过拆分其子级来格式化子级的视图时，必须拆分该视图以恰当的表示它。
forClass() - 类 java.io.ObjectStreamClass 中的方法
返回此版本所映射的本地 VM 中的类。
forDigit(int, int) - 类 java.lang.Character 中的静态方法
确定使用指定基数的特定数字的字符表示形式。
FOREGROUND - 类 java.awt.font.TextAttribute 中的静态变量
用于呈现文本的 paint 的属性键。
FOREGROUND - 类 javax.swing.plaf.synth.ColorType 中的静态变量
某一 region 前景的 ColorType。
Foreground - 类 javax.swing.text.StyleConstants 中的静态变量
前景色属性的名称。
forget(Xid) - 接口 javax.transaction.xa.XAResource 中的方法
告知资源管理器忽略以启发式完成的事务分支。
FORM - 类 javax.swing.text.html.HTML.Tag 中的静态变量
format(String, Object...) - 类 java.io.Console 中的方法
使用指定格式字符串和参数将格式化字符串写入此控制台的输出流中。
format(String, Object...) - 类 java.io.PrintStream 中的方法
使用指定格式字符串和参数将格式化字符串写入此输出流中。
format(Locale, String, Object...) - 类 java.io.PrintStream 中的方法
使用指定格式字符串和参数将格式化字符串写入此输出流中。
format(String, Object...) - 类 java.io.PrintWriter 中的方法
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
format(Locale, String, Object...) - 类 java.io.PrintWriter 中的方法
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
FORMAT - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Cf”。
format(String, Object...) - 类 java.lang.String 中的静态方法
使用指定的格式字符串和参数返回一个格式化字符串。
format(Locale, String, Object...) - 类 java.lang.String 中的静态方法
使用指定的语言环境、格式字符串和参数返回一个格式化字符串。
format(long, StringBuffer, FieldPosition) - 类 java.text.ChoiceFormat 中的方法
特殊格式。
format(double, StringBuffer, FieldPosition) - 类 java.text.ChoiceFormat 中的方法
返回带已格式化 double 的模式。
format(Object, StringBuffer, FieldPosition) - 类 java.text.DateFormat 中的方法
重写 Format。
format(Date, StringBuffer, FieldPosition) - 类 java.text.DateFormat 中的方法
将一个 Date 格式化为日期/时间字符串。
format(Date) - 类 java.text.DateFormat 中的方法
将一个 Date 格式化为日期/时间字符串。
format(Object, StringBuffer, FieldPosition) - 类 java.text.DecimalFormat 中的方法
格式化一个数，并将所得文本追加到给定的字符串缓冲区。
format(double, StringBuffer, FieldPosition) - 类 java.text.DecimalFormat 中的方法
格式化一个 double 值，以生成一个字符串。
format(long, StringBuffer, FieldPosition) - 类 java.text.DecimalFormat 中的方法
格式化一个 long 值，以生成一个字符串。
Format - java.text 中的 类
Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。
Format() - 类 java.text.Format 的构造方法
单独的构造方法。
format(Object) - 类 java.text.Format 中的方法
格式化一个对象以生成一个字符串。
format(Object, StringBuffer, FieldPosition) - 类 java.text.Format 中的方法
格式化一个对象，并将得到的文本添加到给定的字符缓冲区。
format(Object[], StringBuffer, FieldPosition) - 类 java.text.MessageFormat 中的方法
格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
format(String, Object...) - 类 java.text.MessageFormat 中的静态方法
创建具有给定模式的 MessageFormat，并用它来格式化给定的参数。
format(Object, StringBuffer, FieldPosition) - 类 java.text.MessageFormat 中的方法
格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
format(Object, StringBuffer, FieldPosition) - 类 java.text.NumberFormat 中的方法
格式化一个数并将所得文本添加到给定字符串缓冲区。
format(double) - 类 java.text.NumberFormat 中的方法
格式规范。
format(long) - 类 java.text.NumberFormat 中的方法
格式规范。
format(double, StringBuffer, FieldPosition) - 类 java.text.NumberFormat 中的方法
格式规范。
format(long, StringBuffer, FieldPosition) - 类 java.text.NumberFormat 中的方法
格式规范。
format(Date, StringBuffer, FieldPosition) - 类 java.text.SimpleDateFormat 中的方法
将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
format(String, Object...) - 类 java.util.Formatter 中的方法
使用指定格式字符串和参数将一个格式化字符串写入此对象的目标文件中。
format(Locale, String, Object...) - 类 java.util.Formatter 中的方法
使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。
format(LogRecord) - 类 java.util.logging.Formatter 中的方法
格式化给定的日志记录，并返回格式化后的字符串。
format(LogRecord) - 类 java.util.logging.SimpleFormatter 中的方法
格式化给定的 LogRecord。
format(LogRecord) - 类 java.util.logging.XMLFormatter 中的方法
将给定消息格式化为 XML。
format - 类 javax.sound.sampled.AudioInputStream 中的变量
流中包含的音频数据的格式。
format - 类 org.omg.IOP.Encoding 中的变量
编码格式。
Format.Field - java.text 中的 类
定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。
Format.Field(String) - 类 java.text.Format.Field 的构造方法
创建具有指定名称的 Field。
FORMAT_CLASS - 类 java.util.ResourceBundle.Control 中的静态变量
包含 "java.class" 的纯类 (class-only) 格式 List。
FORMAT_DEFAULT - 类 java.util.ResourceBundle.Control 中的静态变量
默认的格式 List，它包含字符串 "java.class" 和 "java.properties"（按此顺序）。
FORMAT_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
FORMAT_FAILURE 用于因任何格式化问题导致的失败 。
FORMAT_PROPERTIES - 类 java.util.ResourceBundle.Control 中的静态变量
包含 "java.properties" 的纯属性 (properties-only) 格式 List。
FormatConversionProvider - javax.sound.sampled.spi 中的 类
格式转换提供者提供从一种或多种输入格式到一种或多种输出格式的格式转换服务。
FormatConversionProvider() - 类 javax.sound.sampled.spi.FormatConversionProvider 的构造方法
FormatFlagsConversionMismatchException - java.util 中的 异常
转换与标志不兼容时抛出未经检查的异常。
FormatFlagsConversionMismatchException(String, char) - 异常 java.util.FormatFlagsConversionMismatchException 的构造方法
构造带指定标志和转换的此类的一个实例。
formatMessage(LogRecord) - 类 java.util.logging.Formatter 中的方法
本地化和格式化来自日志记录的消息字符串。
FormatMismatch - org.omg.IOP.CodecPackage 中的 异常
org/omg/IOP/CodecPackage/FormatMismatch.java。
FormatMismatch() - 异常 org.omg.IOP.CodecPackage.FormatMismatch 的构造方法
FormatMismatch(String) - 异常 org.omg.IOP.CodecPackage.FormatMismatch 的构造方法
FormatMismatchHelper - org.omg.IOP.CodecPackage 中的 类
org/omg/IOP/CodecPackage/FormatMismatchHelper.java。
FormatMismatchHelper() - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 的构造方法
Formattable - java.util 中的 接口
Formattable 接口必须通过需要执行自定义格式化（使用 Formatter 的 's' 转换说明符）的任何类来实现。
FormattableFlags - java.util 中的 类
将 FomattableFlags 传递给 Formattable.formatTo() 方法，并修改 Formattables 的输出格式。
FORMATTED_TEXT_FIELD - 类 javax.swing.plaf.synth.Region 中的静态变量
FormattedTextField 的 region。
Formatter - java.util 中的 类
printf 风格的格式字符串的解释程序。
Formatter() - 类 java.util.Formatter 的构造方法
构造一个新 formatter。
Formatter(Appendable) - 类 java.util.Formatter 的构造方法
构造一个带指定目标文件的新 formatter。
Formatter(Locale) - 类 java.util.Formatter 的构造方法
构造一个带指定语言环境的新 formatter。
Formatter(Appendable, Locale) - 类 java.util.Formatter 的构造方法
构造一个带指定目标文件和语言环境的新 formatter。
Formatter(String) - 类 java.util.Formatter 的构造方法
构造一个带指定文件名的新 formatter。
Formatter(String, String) - 类 java.util.Formatter 的构造方法
构造一个带指定文件名和字符集的新 formatter。
Formatter(String, String, Locale) - 类 java.util.Formatter 的构造方法
构造一个带指定文件名、字符集和语言环境的新 formatter。
Formatter(File) - 类 java.util.Formatter 的构造方法
构造一个带指定文件的新 formatter。
Formatter(File, String) - 类 java.util.Formatter 的构造方法
构造一个带指定文件和字符集的新 formatter。
Formatter(File, String, Locale) - 类 java.util.Formatter 的构造方法
构造一个带指定文件、字符集和语言环境的新 formatter。
Formatter(PrintStream) - 类 java.util.Formatter 的构造方法
构造一个带指定输出流的新 formatter。
Formatter(OutputStream) - 类 java.util.Formatter 的构造方法
构造一个带指定输出流的新 formatter。
Formatter(OutputStream, String) - 类 java.util.Formatter 的构造方法
构造一个带指定输出流和字符集的新 formatter。
Formatter(OutputStream, String, Locale) - 类 java.util.Formatter 的构造方法
构造一个带指定输出流、字符集和语言环境的新 formatter。
Formatter - java.util.logging 中的 类
Formatter 为格式化 LogRecords 提供支持。
Formatter() - 类 java.util.logging.Formatter 的构造方法
构造一个新的 Formatter。
Formatter.BigDecimalLayoutForm - java.util 中的 枚举
FormatterClosedException - java.util 中的 异常
格式器已关闭时抛出的未经检查的异常。
FormatterClosedException() - 异常 java.util.FormatterClosedException 的构造方法
构造此类的一个实例。
formatTo(Formatter, int, int, int) - 接口 java.util.Formattable 中的方法
使用提供的格式器来格式化对象。
formatToCharacterIterator(Object) - 类 java.text.DecimalFormat 中的方法
格式化一个 Object，以生成一个 AttributedCharacterIterator。
formatToCharacterIterator(Object) - 类 java.text.Format 中的方法
格式化一个对象，生成一个 AttributedCharacterIterator。
formatToCharacterIterator(Object) - 类 java.text.MessageFormat 中的方法
格式化一个对象数组，并将它们插入 MessageFormat 的模式中，生成一个 AttributedCharacterIterator。
formatToCharacterIterator(Object) - 类 java.text.SimpleDateFormat 中的方法
格式化生成 AttributedCharacterIterator 的对象。
FormSubmitEvent - javax.swing.text.html 中的 类
FormSubmitEvent 用于通知提交表单所需的参与者。
FormSubmitEvent.MethodType - javax.swing.text.html 中的 枚举
表示 HTML 表单方法类型。
FormView - javax.swing.text.html 中的 类
实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
FormView(Element) - 类 javax.swing.text.html.FormView 的构造方法
创建新的 FormView 对象。
FormView.MouseEventListener - javax.swing.text.html 中的 类
当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
FormView.MouseEventListener() - 类 javax.swing.text.html.FormView.MouseEventListener 的构造方法
forName(String) - 类 java.lang.Character.UnicodeBlock 中的静态方法
返回带有给定名称的 UnicodeBlock。
forName(String) - 类 java.lang.Class 中的静态方法
返回与带有给定字符串名的类或接口相关联的 Class 对象。
forName(String, boolean, ClassLoader) - 类 java.lang.Class 中的静态方法
使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。
forName(String) - 类 java.nio.charset.Charset 中的静态方法
返回指定 charset 的 charset 对象。
Forward - 类 javax.swing.text.Position.Bias 中的静态变量
指示到模型中下一字符的偏差。
forward - 异常 org.omg.PortableInterceptor.ForwardRequest 中的变量
将请求转发到的新对象。
forward_reference() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
如果 reply_status 属性为 LOCATION_FORWARD，则包含要将请求转发到的对象。
forward_reference - 异常 org.omg.PortableServer.ForwardRequest 中的变量
FORWARD_TRAVERSAL_KEYS - 类 java.awt.KeyboardFocusManager 中的静态变量
Forward 焦点遍历键的标识符。
forwardAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符逻辑向前移动一个位置的动作名称。
ForwardingFileObject<F extends FileObject> - javax.tools 中的 类
将调用转发到给定的文件对象。
ForwardingFileObject(F) - 类 javax.tools.ForwardingFileObject 的构造方法
创建一个新的 ForwardingFileObject 实例。
ForwardingJavaFileManager<M extends JavaFileManager> - javax.tools 中的 类
将调用转发到给定的文件管理器。
ForwardingJavaFileManager(M) - 类 javax.tools.ForwardingJavaFileManager 的构造方法
创建一个新的 ForwardingJavaFileManager 的实例。
ForwardingJavaFileObject<F extends JavaFileObject> - javax.tools 中的 类
将调用转发到给定的文件对象。
ForwardingJavaFileObject(F) - 类 javax.tools.ForwardingJavaFileObject 的构造方法
创建一个新的 ForwardingJavaFileObject 实例。
ForwardRequest - org.omg.PortableInterceptor 中的 异常
org/omg/PortableInterceptor/ForwardRequest.java。
ForwardRequest() - 异常 org.omg.PortableInterceptor.ForwardRequest 的构造方法
ForwardRequest(Object) - 异常 org.omg.PortableInterceptor.ForwardRequest 的构造方法
ForwardRequest(String, Object) - 异常 org.omg.PortableInterceptor.ForwardRequest 的构造方法
ForwardRequest - org.omg.PortableServer 中的 异常
org/omg/PortableServer/ForwardRequest.java。
ForwardRequest() - 异常 org.omg.PortableServer.ForwardRequest 的构造方法
ForwardRequest(Object) - 异常 org.omg.PortableServer.ForwardRequest 的构造方法
ForwardRequest(String, Object) - 异常 org.omg.PortableServer.ForwardRequest 的构造方法
ForwardRequestHelper - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/ForwardRequestHelper.java。
ForwardRequestHelper() - 类 org.omg.PortableInterceptor.ForwardRequestHelper 的构造方法
ForwardRequestHelper - org.omg.PortableServer 中的 类
org/omg/PortableServer/ForwardRequestHelper.java。
ForwardRequestHelper() - 类 org.omg.PortableServer.ForwardRequestHelper 的构造方法
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.BoxView 中的方法
将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.TableView 中的方法
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.View 中的方法
将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
forwardUpdateToView(View, DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.View 中的方法
将 DocumentEvent 转发到给定的子视图。
foundType() - 异常 java.lang.annotation.AnnotationTypeMismatchException 中的方法
返回在类型不正确的元素中找到的数据类型。
FRACTION - 类 java.text.NumberFormat.Field 中的静态变量
标识小数字段的常量。
FRACTION_FIELD - 类 java.text.NumberFormat 中的静态变量
用于构造 FieldPosition 对象的字段常量。
Frame - java.awt 中的 类
Frame 是带有标题和边框的顶层窗口。
Frame() - 类 java.awt.Frame 的构造方法
构造一个最初不可见的 Frame 新实例（）。
Frame(GraphicsConfiguration) - 类 java.awt.Frame 的构造方法
使用指定的 GraphicsConfiguration 构造一个最初不可见的新 Frame。
Frame(String) - 类 java.awt.Frame 的构造方法
构造一个新的、最初不可见的、具有指定标题的 Frame 对象。
Frame(String, GraphicsConfiguration) - 类 java.awt.Frame 的构造方法
构造一个新的、初始不可见的、具有指定标题和 GraphicsConfiguration 的 Frame 对象。
FRAME - 类 javax.accessibility.AccessibleRole 中的静态变量
带有标题栏、边框、菜单栏等的顶层窗口。
FRAME - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
frame - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的变量
frame - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
frame - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
FRAME - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Frame.AccessibleAWTFrame - java.awt 中的 类
此类实现对 Frame 类的可访问性支持。
Frame.AccessibleAWTFrame() - 类 java.awt.Frame.AccessibleAWTFrame 的构造方法
FRAME_CONTENT_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Frame Content 层的便捷对象。
FRAME_ICON_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
FRAMEBITS - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示多帧图像（以前绘制的）的另一个完整帧现在可以再次绘制。
FRAMEBORDER - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
frameIcon - 类 javax.swing.JInternalFrame 中的变量
此内部窗体左上角显示的图标。
frameInit() - 类 javax.swing.JFrame 中的方法
由构造方法调用，以适当地初始化 JFrame。
frameLength - 类 javax.sound.sampled.AudioInputStream 中的变量
此流的长度，以示例帧为单位。
framePos - 类 javax.sound.sampled.AudioInputStream 中的变量
此流中的当前位置，以示例帧为单位（从零开始）。
frameRate - 类 javax.sound.sampled.AudioFormat 中的变量
具有此格式的声音每秒播放和录制的帧数。
FRAMESET - 类 javax.swing.text.html.HTML.Tag 中的静态变量
frameSize - 类 javax.sound.sampled.AudioFormat 中的变量
每个具有此格式的声音帧包含的字节数。
frameSize - 类 javax.sound.sampled.AudioInputStream 中的变量
每帧的大小，以字节为单位。
FRANCE - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
free() - 接口 java.sql.Array 中的方法
此方法释放 Array 对象以及它占用的资源。
free() - 接口 java.sql.Blob 中的方法
此方法释放 Blob 对象以及它所占用的资源。
free() - 接口 java.sql.Clob 中的方法
此方法释放 Clob 对象以及它所占用的资源。
free() - 接口 java.sql.SQLXML 中的方法
此方法关闭此对象并释放其持有的资源。
free() - 类 javax.sql.rowset.serial.SerialArray 中的方法
此方法释放 Array 对象及其占有的资源。
free() - 类 javax.sql.rowset.serial.SerialBlob 中的方法
此方法释放 Blob 对象及其占有的资源。
free() - 类 javax.sql.rowset.serial.SerialClob 中的方法
FREE_MEM - org.omg.CORBA 中的 异常
当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
FREE_MEM() - 异常 org.omg.CORBA.FREE_MEM 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 FREE_MEM 异常。
FREE_MEM(String) - 异常 org.omg.CORBA.FREE_MEM 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 FREE_MEM 异常。
FREE_MEM(int, CompletionStatus) - 异常 org.omg.CORBA.FREE_MEM 的构造方法
使用指定次要代码和完成状态构造一个 FREE_MEM 异常。
FREE_MEM(String, int, CompletionStatus) - 异常 org.omg.CORBA.FREE_MEM 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 FREE_MEM 异常。
FREE_STANDING_PROP - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的静态变量
freeMemory() - 类 java.lang.Runtime 中的方法
返回 Java 虚拟机中的空闲内存量。
FRENCH - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
frequency(Collection<?>, Object) - 类 java.util.Collections 中的静态方法
返回指定 collection 中等于指定对象的元素数。
FRIDAY - 类 java.util.Calendar 中的静态变量
指示 Friday 的 Calendar.DAY_OF_WEEK 字段值。
from(CompositeData) - 类 java.lang.management.MemoryNotificationInfo 中的静态方法
返回由给定 CompositeData 表示的 MemoryNotificationInfo 对象。
from(CompositeData) - 类 java.lang.management.MemoryUsage 中的静态方法
返回由给定 CompositeData 表示的 MemoryUsage 对象。
from(CompositeData) - 类 java.lang.management.MonitorInfo 中的静态方法
返回给定 CompositeData 表示的 MonitorInfo 对象。
from(CompositeData) - 类 java.lang.management.ThreadInfo 中的静态方法
返回由给定 CompositeData 表示的 ThreadInfo 对象。
from_any(Any) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 根据 Any 对象生成一个 DynAny 对象。
from_any(Any) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynStructStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynValueStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
from_any(Any) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
from_int(int) - 类 org.omg.CORBA.CompletionStatus 中的静态方法
根据给定的 int 创建一个 CompletionStatus 对象。
from_int(int) - 类 org.omg.CORBA.DefinitionKind 中的静态方法
创建一个对应于给定代码的 DefinitionKind 实例。
from_int(int) - 类 org.omg.CORBA.ParameterMode 中的静态方法
from_int(int) - 类 org.omg.CORBA.SetOverrideType 中的静态方法
将给定 int 值转换成相应的 SetOverrideType 实例。
from_int(int) - 类 org.omg.CORBA.TCKind 中的静态方法
将给定 int 值转换成相应的 TCKind 实例。
from_int(int) - 类 org.omg.CosNaming.BindingType 中的静态方法
from_int(int) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态方法
from_int(int) - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.LifespanPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态方法
from_int(int) - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.ThreadPolicyValue 中的静态方法
fromCIEXYZ(float[]) - 类 java.awt.color.ColorSpace 中的方法
将假定为 CS_CIEXYZ 变换颜色空间中的颜色值转换成此 ColorSpace 中的值。
fromCIEXYZ(float[]) - 类 java.awt.color.ICC_ColorSpace 中的方法
将假定为 CS_CIEXYZ 变换颜色空间中的颜色值转换为此 ColorSpace 中的值。
fromIndex - 类 javax.swing.event.TableColumnModelEvent 中的变量
列的索引，从该索引处移动或移除列
fromRGB(float[]) - 类 java.awt.color.ColorSpace 中的方法
将假定为默认 CS_sRGB 颜色空间中的颜色值转换成此 ColorSpace 中的值。
fromRGB(float[]) - 类 java.awt.color.ICC_ColorSpace 中的方法
将假定为默认 CS_sRGB 颜色空间中的颜色值转换成此 ColorSpace 中的值。
fromString(String) - 类 java.util.UUID 中的静态方法
根据 UUID.toString() 方法中描述的字符串标准表示形式创建 UUID。
FTP - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
文件传输协议 (FTP)。
FULL - 类 java.text.DateFormat 中的静态变量
用于 FULL 模式的常量。
FULL_DECOMPOSITION - 类 java.text.Collator 中的静态变量
Decomposition 模式值。
FULL_JOIN - 接口 javax.sql.rowset.JoinRowSet 中的静态变量
ANSI 风格的 JOIN，提供一个完全 JOIN。
FULLWIDTH_DIGITS - 类 java.awt.im.InputSubset 中的静态变量
Unicode 半角和全角字符块中包括的全角数字常量。
FULLWIDTH_LATIN - 类 java.awt.im.InputSubset 中的静态变量
Unicode 半角和全角字符块的全角 ASCII 变体子集常量。
functionColumnIn - 接口 java.sql.DatabaseMetaData 中的静态变量
指示参数或列是一个 IN 参数。
functionColumnInOut - 接口 java.sql.DatabaseMetaData 中的静态变量
指示参数或列是一个 INOUT 参数。
functionColumnOut - 接口 java.sql.DatabaseMetaData 中的静态变量
指示参数或列是一个 OUT 参数。
functionColumnResult - 接口 java.sql.DatabaseMetaData 中的静态变量
指示参数或列是结果集中的一列。
functionColumnUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示该类型的参数或列未知。
functionNoNulls - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不允许 NULL 值。
functionNoTable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示函数不返回一个表。
functionNullable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示允许 NULL 值。
functionNullableUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示是否允许 NULL 值是未知的。
functionResultUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道函数是返回一个结果还是一个表。
functionReturn - 接口 java.sql.DatabaseMetaData 中的静态变量
指示参数或列是一个返回值。
functionReturnsTable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示函数返回一个表。
FUSER_OVER_TEMP - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
热熔器温度高于正常值。
FUSER_UNDER_TEMP - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
热熔器温度低于正常值。
Future<V> - java.util.concurrent 中的 接口
Future 表示异步计算的结果。
FutureTask<V> - java.util.concurrent 中的 类
可取消的异步计算。
FutureTask(Callable<V>) - 类 java.util.concurrent.FutureTask 的构造方法
创建一个 FutureTask，一旦运行就执行给定的 Callable。
FutureTask(Runnable, V) - 类 java.util.concurrent.FutureTask 的构造方法
创建一个 FutureTask，一旦运行就执行给定的 Runnable，并安排成功完成时 get 返回给定的结果 。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


G - 索引 (Java 2 Platform SE 6)

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM 2 Platform
Standard Ed. 6

上一个字母 下一个字母

框架 无框架

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

G

GAP_TOKEN - 异常 org.ietf.jgss.GSSException 中的静态变量
未收到需要的 per-message 标记。
GapContent - javax.swing.text 中的 类
AbstractDocument.Content 接口的一个实现，使用类似于 emacs 使用的间隙缓冲区来实现。
GapContent() - 类 javax.swing.text.GapContent 的构造方法
创建新的 GapContent 对象。
GapContent(int) - 类 javax.swing.text.GapContent 的构造方法
创建具有指定初始大小的新 GapContent 对象。
GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE - 类 java.lang.management.ManagementFactory 中的静态变量
GarbageCollectorMXBean 的 ObjectName 中的域名和类型键属性。
GarbageCollectorMXBean - java.lang.management 中的 接口
用于 Java 虚拟机的垃圾回收的管理接口。
GatheringByteChannel - java.nio.channels 中的 接口
可从缓冲区序列写入字节的通道。
GaugeMonitor - javax.management.monitor 中的 类
定义专门用来观察尺度属性值的监视器 MBean。
GaugeMonitor() - 类 javax.management.monitor.GaugeMonitor 的构造方法
默认的构造方法。
GaugeMonitorMBean - javax.management.monitor 中的 接口
公开尺度监视器 MBean 的远程管理接口。
gc() - 接口 java.lang.management.MemoryMXBean 中的方法
运行垃圾回收器。
gc() - 类 java.lang.Runtime 中的方法
运行垃圾回收器。
gc() - 类 java.lang.System 中的静态方法
运行垃圾回收器。
gcd(BigInteger) - 类 java.math.BigInteger 中的方法
返回一个 BigInteger，其值是 abs(this) 和 abs(val) 的最大公约数。
GDAY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 gDay 的完全限定名称。
GE - 类 javax.management.Query 中的静态变量
表示 Query.geq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
GENERAL - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量

GENERAL_PUNCTUATION - 类 java.lang.Character.UnicodeBlock 中的静态变量
“General Punctuation”Unicode 字符块的常量。
GeneralPath - java.awt.geom 中的 类
GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
GeneralPath() - 类 java.awt.geom.GeneralPath 的构造方法
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的单精度空 GeneralPath 对象。
GeneralPath(int) - 类 java.awt.geom.GeneralPath 的构造方法
根据指定旋绕规则构造一个新的 GeneralPath 对象，以控制需要定义路径内部的操作。
GeneralPath(int, int) - 类 java.awt.geom.GeneralPath 的构造方法
根据指定旋绕规则和指定初始容量构造一个新的 GeneralPath 对象，以存储路径坐标。
GeneralPath(Shape) - 类 java.awt.geom.GeneralPath 的构造方法
根据任意 Shape 对象构造一个新 GeneralPath 对象。
GeneralSecurityException - java.security 中的 异常
GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
GeneralSecurityException() - 异常 java.security.GeneralSecurityException 的构造方法
构造不带详细消息的 GeneralSecurityException。
GeneralSecurityException(String) - 异常 java.security.GeneralSecurityException 的构造方法
构造带指定详细消息的 GeneralSecurityException。
GeneralSecurityException(String, Throwable) - 异常 java.security.GeneralSecurityException 的构造方法
创建带指定详细消息和 cause 的 GeneralSecurityException。
GeneralSecurityException(Throwable) - 异常 java.security.GeneralSecurityException 的构造方法
用指定的原因和详细消息创建一个 GeneralSecurityException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。
generateCertificate(InputStream) - 类 java.security.cert.CertificateFactory 中的方法
生成一个证书对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
generateCertificates(InputStream) - 类 java.security.cert.CertificateFactory 中的方法
返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
generateCertPath(InputStream) - 类 java.security.cert.CertificateFactory 中的方法
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
generateCertPath(InputStream, String) - 类 java.security.cert.CertificateFactory 中的方法
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
generateCertPath(List<? extends Certificate>) - 类 java.security.cert.CertificateFactory 中的方法
生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。
generateCRL(InputStream) - 类 java.security.cert.CertificateFactory 中的方法
生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
generateCRLs(InputStream) - 类 java.security.cert.CertificateFactory 中的方法
返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
Generated - javax.annotation 中的 注释类型
Generated 注释用于标记已生成的源代码。
generateKey() - 类 javax.crypto.KeyGenerator 中的方法
生成一个密钥。
generateKeyPair() - 类 java.security.KeyPairGenerator 中的方法
生成一个密钥对。
generateKeyPair() - 类 java.security.KeyPairGeneratorSpi 中的方法
生成密钥对。
generateParameters() - 类 java.security.AlgorithmParameterGenerator 中的方法
生成参数。
generatePrivate(KeySpec) - 类 java.security.KeyFactory 中的方法
根据提供的密钥规范（密钥材料）生成私钥对象。
generatePublic(KeySpec) - 类 java.security.KeyFactory 中的方法
根据提供的密钥规范（密钥材料）生成公钥对象。
generateSchema(SchemaOutputResolver) - 类 javax.xml.bind.JAXBContext 中的方法
生成此上下文的模式文档。
generateSecret() - 类 javax.crypto.KeyAgreement 中的方法
生成共享秘密并在新的缓冲区中返回它。
generateSecret(byte[], int) - 类 javax.crypto.KeyAgreement 中的方法
生成共享秘密，并将其放入缓冲区 sharedSecret，从 offset（包括）开始。
generateSecret(String) - 类 javax.crypto.KeyAgreement 中的方法
创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
generateSecret(KeySpec) - 类 javax.crypto.SecretKeyFactory 中的方法
根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
generateSeed(int) - 类 java.security.SecureRandom 中的方法
返回给定的种子字节数量，该数量可使用此类用来将自身设置为种子的种子生成算法来计算。
GENERIC_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
GENERIC_FAILURE 用于不属于其他任何一类的失败。
GenericArrayType - java.lang.reflect 中的 接口
GenericArrayType 表示一种数组类型，其组件类型为参数化类型或类型变量。
GenericDeclaration - java.lang.reflect 中的 接口
声明类型变量的所有实体的公共接口。
GenericSignatureFormatError - java.lang.reflect 中的 错误
当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。
GenericSignatureFormatError() - 错误 java.lang.reflect.GenericSignatureFormatError 的构造方法

genExemptionBlob() - 类 javax.crypto.ExemptionMechanism 中的方法
生成豁免机制密钥 blob。
genExemptionBlob(byte[]) - 类 javax.crypto.ExemptionMechanism 中的方法
生成豁免机制密钥 blob，并将结果存储在 output 缓冲区中。
genExemptionBlob(byte[], int) - 类 javax.crypto.ExemptionMechanism 中的方法
生成豁免机制密钥 blob，并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
genKeyPair() - 类 java.security.KeyPairGenerator 中的方法
生成密钥对。
GEOMETRIC_SHAPES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Geometric Shapes”Unicode 字符块的常量。
GEORGIAN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Georgian”Unicode 字符块的常量。
geq(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于两个值的“大于或等于”约束条件。
GERMAN - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
GERMANY - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
get(Object) - 类 java.awt.RenderingHints 中的方法
返回指定键所映射的值。
get(Object) - 类 java.beans.Encoder 中的方法
在由此流创建的环境中返回 oldInstance 的一个实验值。
get(String, boolean) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定的 boolean 字段值。
get(String, byte) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定字节字段的值。
get(String, char) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定 char 字段的值。
get(String, short) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定的 short 字段值。
get(String, int) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定的 int 字段值。
get(String, long) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定 long 字段的值。
get(String, float) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定 float 字段的值。
get(String, double) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定 double 字段的值。
get(String, Object) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定 Object 字段的值。
get() - 类 java.lang.ref.PhantomReference 中的方法
返回此引用对象的指示对象。
get() - 类 java.lang.ref.Reference 中的方法
返回此引用对象的指示对象。
get() - 类 java.lang.ref.SoftReference 中的方法
返回此引用对象的指示对象。
get(Object, int) - 类 java.lang.reflect.Array 中的静态方法
返回指定数组对象中索引组件的值。
get(Object) - 类 java.lang.reflect.Field 中的方法
返回指定对象上此 Field 表示的字段的值。
get() - 类 java.lang.ThreadLocal 中的方法
返回此线程局部变量的当前线程副本中的值。
get(URI, Map<String, List<String>>) - 类 java.net.CookieHandler 中的方法
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
get(URI, Map<String, List<String>>) - 类 java.net.CookieManager 中的方法

get(URI) - 接口 java.net.CookieStore 中的方法
获取与给定 URI 关联或其域与给定 URI 匹配的 cookie。
get(URI, String, Map<String, List<String>>) - 类 java.net.ResponseCache 中的方法
根据请求的 uri、请求方法和请求头获取缓存的响应。
get() - 类 java.nio.ByteBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.ByteBuffer 中的方法
绝对 get 方法。
get(byte[], int, int) - 类 java.nio.ByteBuffer 中的方法
相对批量 get 方法。
get(byte[]) - 类 java.nio.ByteBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.CharBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.CharBuffer 中的方法
绝对 get 方法。
get(char[], int, int) - 类 java.nio.CharBuffer 中的方法
相对批量 get 方法。
get(char[]) - 类 java.nio.CharBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.DoubleBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.DoubleBuffer 中的方法
绝对 get 方法。
get(double[], int, int) - 类 java.nio.DoubleBuffer 中的方法
相对批量 get 方法。
get(double[]) - 类 java.nio.DoubleBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.FloatBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.FloatBuffer 中的方法
绝对 get 方法。
get(float[], int, int) - 类 java.nio.FloatBuffer 中的方法
相对批量 get 方法。
get(float[]) - 类 java.nio.FloatBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.IntBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.IntBuffer 中的方法
绝对 get 方法。
get(int[], int, int) - 类 java.nio.IntBuffer 中的方法
相对批量 get 方法。
get(int[]) - 类 java.nio.IntBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.LongBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.LongBuffer 中的方法
绝对 get 方法。
get(long[], int, int) - 类 java.nio.LongBuffer 中的方法
相对批量 get 方法。
get(long[]) - 类 java.nio.LongBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.ShortBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.ShortBuffer 中的方法
绝对 get 方法。
get(short[], int, int) - 类 java.nio.ShortBuffer 中的方法
相对批量 get 方法。
get(short[]) - 类 java.nio.ShortBuffer 中的方法
相对批量 get 方法。
get() - 类 java.rmi.MarshalledObject 中的方法
返回所包含的 marshalledobject 的新副本。
get(Object) - 类 java.security.Provider 中的方法

get(int) - 类 java.util.AbstractList 中的方法
返回列表中指定位置的元素。
get(Object) - 类 java.util.AbstractMap 中的方法
返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。
get(int) - 类 java.util.AbstractSequentialList 中的方法
返回此列表中指定位置上的元素。
get(int) - 类 java.util.ArrayList 中的方法
返回此列表中指定位置上的元素。
get(int) - 类 java.util.BitSet 中的方法
返回指定索引处的位值。
get(int, int) - 类 java.util.BitSet 中的方法
返回一个新的 BitSet，它由此 BitSet 中从 fromIndex（包括）到 toIndex（不包括）范围内的位组成。
get(int) - 类 java.util.Calendar 中的方法
返回给定日历字段的值。
get() - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
返回当前值。
get() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
获取当前值。
get(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
获取位置 i 的当前值。
get(T) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
获取此更新器管理的在给定对象的字段中保持的当前值。
get() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
获取当前值。
get(int) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
获取位置 i 的当前值。
get(T) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
获取此更新器管理的在给定对象的字段中保持的当前值。
get(boolean[]) - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
返回该引用和该标记的当前值。
get() - 类 java.util.concurrent.atomic.AtomicReference 中的方法
获取当前值。
get(int) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
获取位置 i 的当前值。
get(T) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
获取由此更新器管理的在给定对象的字段中保持的当前值。
get(int[]) - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
返回该引用和该标志的当前值。
get(Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回指定键所映射到的值，如果此映射不包含该键的映射关系，则返回 null。
get(Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回指定键所映射到的值；如果此映射不包含该键的映射关系，则返回 null。
get(int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回列表中指定位置的元素。
get() - 接口 java.util.concurrent.Future 中的方法
如有必要，等待计算完成，然后获取其结果。
get(long, TimeUnit) - 接口 java.util.concurrent.Future 中的方法
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
get() - 类 java.util.concurrent.FutureTask 中的方法

get(long, TimeUnit) - 类 java.util.concurrent.FutureTask 中的方法

get(Object) - 类 java.util.Dictionary 中的方法
返回此 dictionary 中该键所映射到的值。
get(Object) - 类 java.util.EnumMap 中的方法
返回指定键所映射的值，如果此映射不包含此键的映射关系，则返回 null。
get(Object) - 类 java.util.HashMap 中的方法
返回指定键所映射的值；如果对于该键来说，此映射不包含任何映射关系，则返回 null。
get(Object) - 类 java.util.Hashtable 中的方法
返回指定键所映射到的值，如果此映射不包含此键的映射，则返回 null. 更确切地讲，如果此映射包含满足 (key.equals(k)) 的从键 k 到值 v 的映射，则此方法返回 v；否则，返回 null。
get(Object) - 类 java.util.IdentityHashMap 中的方法
返回指定键映射的值；如果映射不包含此键的任何映射关系，则返回 null。
get(Object) - 类 java.util.jar.Attributes 中的方法
返回指定的属性名称的值，如果未找到属性名称，则返回 null。
get(Object) - 类 java.util.LinkedHashMap 中的方法
返回此映射到指定键的值。
get(int) - 类 java.util.LinkedList 中的方法
返回此列表中指定位置处的元素。
get(int) - 接口 java.util.List 中的方法
返回列表中指定位置的元素。
get(Object) - 接口 java.util.Map 中的方法
返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。
get(String, String) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.get(String,String) 中的规范实现 get 方法。
get(String, String) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定键相关联的值。
get(Object) - 类 java.util.TreeMap 中的方法
返回指定键所映射的值，如果对于该键而言，此映射不包含任何映射关系，则返回 null。
get(int) - 类 java.util.Vector 中的方法
返回向量中指定位置的元素。
get(Object) - 类 java.util.WeakHashMap 中的方法
返回指定键所映射的值，如果对于该键来说，此映射不包含任何映射关系，则返回 null。
get(String) - 类 javax.accessibility.AccessibleRelationSet 中的方法
返回与指定键匹配的关系。
get(String) - 类 javax.activation.MimeTypeParameterList 中的方法
获取与给定名称关联的值；如果不存在当前关联，则返回 null。
get(String) - 接口 javax.management.openmbean.CompositeData 中的方法
返回名称为 key 的项的值。
get(String) - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回其名称是 key 的项的值。
get(Object[]) - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例中其索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。
get(Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
此方法仅调用 get((Object[]) key)。
get(Object[]) - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularData 实例中索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。
get(int) - 类 javax.naming.CompositeName 中的方法
检索此复合名称的组件。
get(int) - 类 javax.naming.CompoundName 中的方法
检索此组合名称的组件。
get() - 接口 javax.naming.directory.Attribute 中的方法
检索此属性的其中一个值。
get(int) - 接口 javax.naming.directory.Attribute 中的方法
从属性值的有序列表中检索属性值。
get(String) - 接口 javax.naming.directory.Attributes 中的方法
利用属性集中的给定属性 id 检索属性。
get() - 类 javax.naming.directory.BasicAttribute 中的方法
检索此属性的其中一个值。
get(int) - 类 javax.naming.directory.BasicAttribute 中的方法

get(String) - 类 javax.naming.directory.BasicAttributes 中的方法

get(int) - 类 javax.naming.ldap.LdapName 中的方法
以字符串形式检索此 LDAP 名称的组件。
get(int) - 接口 javax.naming.Name 中的方法
检索此名称的组件。
get(String) - 类 javax.naming.Reference 中的方法
检索地址类型为 'addrType' 的第一个地址。
get(int) - 类 javax.naming.Reference 中的方法
检索索引 posn 处的地址。
get(Class<?>) - 接口 javax.print.attribute.AttributeSet 中的方法
返回此属性集在给定的属性类别中包含的属性值。
get(Class<?>) - 类 javax.print.attribute.HashAttributeSet 中的方法
返回此属性集在给定的属性类别中包含的属性值。
get(String) - 类 javax.script.AbstractScriptEngine 中的方法
获取受保护 context 字段的 ENGINE_SCOPE 中指定键的值。
get(Object) - 接口 javax.script.Bindings 中的方法
返回此映射将指定键所映射的值。
get(String) - 接口 javax.script.ScriptEngine 中的方法
获取在此引擎的状态中设置的值。
get(String) - 类 javax.script.ScriptEngineManager 中的方法
获取 Global Scope 中指定键的值。
get(Object) - 类 javax.script.SimpleBindings 中的方法
返回此映射将指定键所映射到的值。
get(int) - 类 javax.sound.midi.Track 中的方法
获得位于指定索引处的事件。
get(Object) - 类 javax.swing.ActionMap 中的方法
返回 key 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 ActionMap。
get(int) - 类 javax.swing.DefaultListModel 中的方法
返回列表中指定位置处的元素。
get(KeyStroke) - 类 javax.swing.InputMap 中的方法
返回 keyStroke 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 InputMap。
get(SynthContext, Object) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
某个 region 特定样式属性的获取器。
get() - 类 javax.swing.SwingWorker 中的方法
如有必要，等待计算完成，然后获取其结果。
get(long, TimeUnit) - 类 javax.swing.SwingWorker 中的方法
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
get(Object) - 类 javax.swing.UIDefaults 中的方法
返回键的值。
get(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
返回与给定语言环境相关的那些键的值。
get(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个对象。
get(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个对象。
get(Object) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 获取指定键所映射的对象。
get(Object) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回此上下文将指定键映射到的值。
get(Object) - 类 javax.xml.soap.SOAPConnection 中的方法
从特定端点获取消息，在收到消息前将一直阻塞。
get2DigitYearStart() - 类 java.text.SimpleDateFormat 中的方法
返回在 100 年周期内被解释的两位数字年份的开始日期。
get_any() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Any。
get_any() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
提取由此 DynAny 表示的 Any 中包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynStructStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynValueStub 中的方法
提取由此 DynAny 表示的 Any 中包含的 Any 值。
get_any() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_as_string() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
以 IDL 标识符的形式返回 DynEnum 的值。
get_as_string() - 接口 org.omg.DynamicAny.DynEnumOperations 中的方法
以 IDL 标识符的形式返回 DynEnum 的值。
get_as_ulong() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
以枚举值的序数值 (ordinal value) 的形式返回 DynEnum 的值。
get_as_ulong() - 接口 org.omg.DynamicAny.DynEnumOperations 中的方法
以枚举值序号的形式返回 DynEnum 的值。
get_boolean() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 析取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 boolean 值。
get_boxed_value() - 接口 org.omg.DynamicAny.DynValueBoxOperations 中的方法
以 Any 的形式返回装箱值。
get_boxed_value_as_dyn_any() - 接口 org.omg.DynamicAny.DynValueBoxOperations 中的方法
以 DynAny 的形式返回已装箱值。
get_char() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 char 值。
get_char() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 析取 char 值。
get_char() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 析取 char 值。
get_char() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 char 值。
get_codebase(Object) - 类 org.omg.CORBA_2_3.portable.Delegate 中的方法
返回提供的对象引用的代码基。
get_compact_typecode() - 类 org.omg.CORBA.TypeCode 中的方法
剔除所有可选名称和成员名称字段，但使所有别名 typecode 保留原样。
get_current() - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用 resolve_initial_references。
get_default_context() - 类 org.omg.CORBA.ORB 中的方法
获取默认 Context 对象。
get_discriminator() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回当前鉴别符值。
get_discriminator() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
返回当前鉴别符值。
get_domain_managers(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
检索此对象的 DomainManager。
get_domain_policy(int) - 接口 org.omg.CORBA.DomainManagerOperations 中的方法
此方法为此域中的对象返回指定类型的策略。
get_double() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 double 值。
get_double() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 析取 double 值。
get_double() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 double 值。
get_dyn_any() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynStructStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynValueStub 中的方法
提取由此 DynAny 表示的 Any 中包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_effective_component(int) - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回为此请求选择的配置文件中带有给定 ID 的 IOP.TaggedComponent。
get_effective_components(int) - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回为此请求选择的配置文件中具有给定 ID 的带标记组件所组成的数组。
get_effective_policy(int) - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
允许 ORB 服务实现确定对将构造的 IOR 有效的特定类型服务器端策略。
get_elements() - 接口 org.omg.CORBA.DynArray 中的方法
已过时。 返回此数组所有元素的值。
get_elements() - 接口 org.omg.CORBA.DynSequence 中的方法
已过时。 返回此 sequence 中每个元素的值。
get_elements() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
返回 DynArray 的元素。
get_elements() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回序列的元素。
get_elements() - 接口 org.omg.DynamicAny.DynArrayOperations 中的方法
返回 DynArray 的元素。
get_elements() - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
返回序列的元素。
get_elements_as_dyn_any() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
以 DynAny 的形式返回 DynArray 的元素。
get_elements_as_dyn_any() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回表示序列的元素的 DynAny。
get_elements_as_dyn_any() - 接口 org.omg.DynamicAny.DynArrayOperations 中的方法
以 DynAny 的形式返回 DynArray 的元素。
get_elements_as_dyn_any() - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
返回表示序列元素的 DynAny。
get_float() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 float 值。
get_float() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 float 值。
get_id() - 接口 org.omg.CORBA.portable.BoxedValueHelper 中的方法

get_id() - 类 org.omg.CORBA.StringValueHelper 中的方法

get_id() - 类 org.omg.CORBA.WStringValueHelper 中的方法

get_interface_def(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
返回一个所提供对象引用的 InterfaceDef。
get_interface_def(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
此操作返回接口 Repository 中的一个对象，该对象提供可能对编程有用的类型信息。
get_length() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回当前序列的长度。
get_length() - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
返回序列的当前长度。
get_long() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 int 值。
get_long() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 析取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 integer 值。
get_longlong() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 long 值。
get_members() - 接口 org.omg.CORBA.DynStruct 中的方法
已过时。 返回包含所有已存储 struct 成员的数组。
get_members() - 接口 org.omg.CORBA.DynValue 中的方法
已过时。 返回一个数组，它包含存储在此 DynValue 中 value 对象的所有成员。
get_members() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
get_members() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
get_members() - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
get_members() - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
get_members_as_dyn_any() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
get_members_as_dyn_any() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
get_members_as_dyn_any() - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
get_members_as_dyn_any() - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
get_next_response() - 类 org.omg.CORBA.ORB 中的方法
获取已接收到响应的下一个 Request 实例。
get_object_id() - 接口 org.omg.PortableServer.CurrentOperations 中的方法
返回一个 ObjectId，标识此方法在其上下文中调用的对象。
get_octet() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 析取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 析取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 byte 值。
get_POA() - 接口 org.omg.PortableServer.CurrentOperations 中的方法
返回对 POA 的引用，该 POA 实现此方法在其上下文中调用的对象。
get_policy(Object, int) - 类 org.omg.CORBA.portable.Delegate 中的方法
返回应用于此对象的指定类型的 Policy 对象。
get_primitive_tc(TCKind) - 类 org.omg.CORBA.ORB 中的方法
检索表示给定基本 IDL 类型的 TypeCode 对象。
get_reference() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Other。
get_reference() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 析取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reply_service_context(int) - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回具有给定 ID 的与应答关联的服务上下文复本。
get_request_policy(int) - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回此操作实行的给定策略。
get_request_service_context(int) - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回具有给定 ID 的与请求关联的服务上下文复本。
get_response() - 类 org.omg.CORBA.Request 中的方法
允许用户访问之前使用 send_deferred 方法所触发调用的响应。
get_servant() - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作返回与 POA 关联的默认 servant。
get_servant_manager() - 接口 org.omg.PortableServer.POAOperations 中的方法
如果 POA 的 ServantRetentionPolicy 为 RETAIN，则 ServantManager 参数 (imgr) 应该支持 ServantActivator 接口。
get_server_policy(int) - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回此操作实行的具有给定策略类型的策略。
get_service_information(short, ServiceInformationHolder) - 类 org.omg.CORBA.ORB 中的方法
用来获取有关受此 ORB 支持的 CORBA 资源和服务的信息。
get_short() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 short 值。
get_short() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 析取 short 值。
get_short() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 short 值。
get_slot(int) - 接口 org.omg.PortableInterceptor.CurrentOperations 中的方法
检索应用程序通过 get_slot 在 PICurrent 中设置的槽数据。
get_slot(int) - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回请求域内 PortableInterceptor.Current 给定槽 (slot) 中的数据。
get_state() - 接口 org.omg.PortableServer.POAManagerOperations 中的方法
此操作返回 POA 管理器的状态。
get_string() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 String。
get_string() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 string 值。
get_typecode() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.TypeCode。
get_typecode() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 析取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_ulong() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 int 值。
get_ulong() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 integer 值。
get_ulonglong() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 long 值。
get_ushort() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 short 值。
get_val() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 java.io.Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 Serializable 对象。
get_value() - 接口 org.omg.CORBA.DynFixed 中的方法
已过时。 返回此 DynFixed 对象表示的 fixed 类型的值。
get_value() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
返回 DynFixed 的值。
get_value() - 接口 org.omg.DynamicAny.DynFixedOperations 中的方法
返回 DynFixed 的值。
get_value_def(String) - 类 org.omg.CORBA_2_3.ORB 中的方法

get_values(String, int, String) - 类 org.omg.CORBA.Context 中的方法
检索 name 字段与给定名称或名称模式匹配的 NamedValue 对象。
get_wchar() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 char 值。
get_wchar() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 long 值。
get_wstring() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 String。
get_wstring() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 string 值。
getA() - 类 java.security.spec.EllipticCurve 中的方法
返回椭圆曲线的第一个系数 a。
getAbsoluteFile() - 类 java.io.File 中的方法
返回此抽象路径名的绝对路径名形式。
getAbsolutePath() - 类 java.io.File 中的方法
返回此抽象路径名的绝对路径名字符串。
getAccelerationPriority() - 类 java.awt.Image 中的方法
返回加速优先级提示的当前值。
getAccelerator() - 类 javax.swing.JMenuItem 中的方法
返回作为菜单项的加速器的 KeyStroke。
getAcceleratorForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的加速器前景颜色。
getAcceleratorForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回加速器前景色。
getAcceleratorSelectedForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的加速器选中前景颜色。
getAcceleratorSelectedForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回加速器选中前景色。
getAcceleratorString() - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法

getAcceptAllFileFilter() - 类 javax.swing.JFileChooser 中的方法
返回 AcceptAll 文件过滤器。
getAcceptAllFileFilter(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
返回默认接受所有文件过滤器
getAcceptAllFileFilter(JFileChooser) - 类 javax.swing.plaf.FileChooserUI 中的方法

getAcceptAllFileFilter(JFileChooser) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getAcceptAllFileFilter 方法。
getAcceptedIssuers() - 接口 javax.net.ssl.X509TrustManager 中的方法
返回受验证同位体信任的认证中心的数组。
getAcceptorAddress() - 类 org.ietf.jgss.ChannelBinding 中的方法
获得此通道绑定的接受端的地址。
getAccessibleAction() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取与此对象相关的 AccessibleAction。
getAccessibleAction() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取与此对象相关的 AccessibleAction。
getAccessibleAction() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取与此对象相关的 AccessibleAction。
getAccessibleAction() - 类 java.awt.Choice.AccessibleAWTChoice 中的方法
获取与此对象相关的 AccessibleAction。
getAccessibleAction() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
获取与此对象关联的 AccessibleAction。
getAccessibleAction() - 类 javax.accessibility.AccessibleContext 中的方法
获取与此对象关联的可支持一个或多个动作的 AccessibleAction。
getAccessibleAction() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
获取与此对象关联的 AccessibleAction。
getAccessibleAction() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
获取与此对象关联的 AccessibleAction。
getAccessibleAction() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleAction() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取与此对象关联的可支持一个或多个操作的 AccessibleAction。
getAccessibleAction() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此对象关联的 AccessibleAction（如果存在）。
getAccessibleAction() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此对象关联的 AccessibleAction。
getAccessibleAction() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleAction() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法

getAccessibleActionAnchor(int) - 类 javax.accessibility.AccessibleHyperlink 中的方法
返回表示适合于该链接的链接锚点的对象。
getAccessibleActionAnchor(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
返回表示适合于该链接的链接锚点的对象。
getAccessibleActionCount() - 类 java.awt.Button.AccessibleAWTButton 中的方法
返回此对象中可用的 Action 的数目。
getAccessibleActionCount() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
返回此对象中可用的 Action 的数目。
getAccessibleActionCount() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
返回此对象中可用的 Actions 的数目。
getAccessibleActionCount() - 类 java.awt.Choice.AccessibleAWTChoice 中的方法
返回此对象中可用的可访问操作的数目，如果大于 1，则第一个作为该对象的“默认”操作。
getAccessibleActionCount() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
返回此对象中可用的操作数。
getAccessibleActionCount() - 接口 javax.accessibility.AccessibleAction 中的方法
返回此对象中可用的可访问动作数。
getAccessibleActionCount() - 类 javax.accessibility.AccessibleHyperlink 中的方法
返回此 Link 中可用的可访问动作数（如果有多个），不认为第一个操作是此 LINK 对象的“默认”操作（例如，在 HTML imagemap 中）。
getAccessibleActionCount() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回此对象中可用 Action 的数量。
getAccessibleActionCount() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回此对象中可用 Action 的数量。
getAccessibleActionCount() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
返回此 Link 中的可访问操作数目（如果有多个），不认为首个操作是此 LINK 对象的“默认”操作（例如，在 HTML imagemap 中）。
getAccessibleActionCount() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回此对象中可访问的操作数，如果多于一个，则第一个就被认为是此对象的“默认”操作。
getAccessibleActionCount() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回此树节点中可用的可访问操作数。
getAccessibleActionCount() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回此对象中可用的可访问操作的数目，如果多于一个，则第一个视为该对象的“默认”操作。
getAccessibleActionDescription(int) - 类 java.awt.Button.AccessibleAWTButton 中的方法
返回对象指定操作的描述。
getAccessibleActionDescription(int) - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
返回对象指定操作的描述。
getAccessibleActionDescription(int) - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
返回对象指定操作的描述。
getAccessibleActionDescription(int) - 类 java.awt.Choice.AccessibleAWTChoice 中的方法
返回对象指定操作的描述。
getAccessibleActionDescription(int) - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
返回对该对象指定操作的描述。
getAccessibleActionDescription(int) - 接口 javax.accessibility.AccessibleAction 中的方法
返回对对象指定动作的描述。
getAccessibleActionDescription(int) - 类 javax.accessibility.AccessibleHyperlink 中的方法
返回此特定链接动作的 String 描述。
getAccessibleActionDescription(int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回对该对象的指定操作的描述。
getAccessibleActionDescription(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回该对象的指定操作的描述。
getAccessibleActionDescription(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
返回此特定链接操作的 String 描述。
getAccessibleActionDescription(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回此对象指定操作的描述。
getAccessibleActionDescription(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回该树节点的指定操作的描述。
getAccessibleActionDescription(int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回对该对象的指定操作的描述。
getAccessibleActionObject(int) - 类 javax.accessibility.AccessibleHyperlink 中的方法
返回表示适合于该链接的链接动作的对象。
getAccessibleActionObject(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
返回表示该链接的 URL 对象。
getAccessibleAt(Point) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回包含在局部坐标 Point 上的 Accessible 子对象（如果存在这样的对象）。
getAccessibleAt(Point) - 类 java.awt.Container.AccessibleAWTContainer 中的方法
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
getAccessibleAt(Point) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回该子级。
getAccessibleAt(Point) - 类 java.awt.List.AccessibleAWTList 中的方法
返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
getAccessibleAt(Point) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回本地坐标 Point 包含的 Accessible 子对象（如果存在）。
getAccessibleAt(Point) - 接口 javax.accessibility.AccessibleComponent 中的方法
返回本地坐标 Point 包含的可访问子级（如果存在）。
getAccessibleAt(int, int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中指定行和列处的 Accessible。
getAccessibleAt(Point) - 类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 中的方法
返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
getAccessibleAt(Point) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleAt(Point) - 类 javax.swing.JList.AccessibleJList 中的方法
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
getAccessibleAt(Point) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
getAccessibleAt(Point) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法

getAccessibleAt(Point) - 类 javax.swing.JTable.AccessibleJTable 中的方法
如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回 Accessible 子级。
getAccessibleAt(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法

getAccessibleAt(Point) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
getAccessibleAt(Point) - 类 javax.swing.JTree.AccessibleJTree 中的方法
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
getAccessibleAt(Component, Point) - 类 javax.swing.SwingUtilities 中的静态方法
如果存在，则返回本地坐标 Point 处包含的 Accessible 子对象。
getAccessibleAt(Point) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleAt(Point) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader 中的方法
返回本地坐标 Point 包含的可访问子级（如果存在）。
getAccessibleCaption() - 接口 javax.accessibility.AccessibleTable 中的方法
返回此表的标题。
getAccessibleCaption() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回此表的标题。
getAccessibleChild(int) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回该对象的第 n 个 Accessible 子对象。
getAccessibleChild(int) - 类 java.awt.Container.AccessibleAWTContainer 中的方法
返回对象的第 n 个 Accessible 子容器。
getAccessibleChild(int) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
返回对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 java.awt.List.AccessibleAWTList 中的方法
返回对象的第 n 个可访问子级。
getAccessibleChild(int) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回该对象的第 n 个 Accessible 子对象。
getAccessibleChild(int) - 类 javax.accessibility.AccessibleContext 中的方法
返回该对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
返回对象的第 n 个 Accessible 子对象。
getAccessibleChild(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回对象的第 n 个可访问子级。
getAccessibleChild(int) - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
返回对象的第 n 个可访问子级。
getAccessibleChild(int) - 类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 中的方法
返回对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleChild(int) - 类 javax.swing.JList.AccessibleJList 中的方法
返回对象的第 n 个可访问子级。
getAccessibleChild(int) - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
返回对象的第 n 个 Accessible 子对象。
getAccessibleChild(int) - 类 javax.swing.JRootPane.AccessibleJRootPane 中的方法
返回对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
返回对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
返回此对象的指定的 Accessible 子对象。
getAccessibleChild(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回该对象的第 n 个 Accessible 子对象。
getAccessibleChild(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回对象的指定 Accessible 子对象。
getAccessibleChild(int) - 类 javax.swing.JTree.AccessibleJTree 中的方法
返回对象的第 n 个可访问子对象。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法

getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.ComponentUI 中的方法
返回对象的第 i 个 Accessible 子对象。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回该对象指定的 Accessible 子对象。
getAccessibleChild(Component, int) - 类 javax.swing.SwingUtilities 中的静态方法
返回对象的第 n 个可访问子对象。
getAccessibleChild(int) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleChild(int) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader 中的方法
返回该对象的第 n 个可访问子对象。
getAccessibleChildrenCount() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回此对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 java.awt.Container.AccessibleAWTContainer 中的方法
返回对象中可访问的子容器数。
getAccessibleChildrenCount() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
返回对象的可访问子级数。
getAccessibleChildrenCount() - 类 java.awt.List.AccessibleAWTList 中的方法
返回对象的可访问子级数。
getAccessibleChildrenCount() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回该对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 javax.accessibility.AccessibleContext 中的方法
返回该对象的可访问子级数。
getAccessibleChildrenCount() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
返回对象中 accessible 子对象的数量。
getAccessibleChildrenCount() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回对象中可访问的子级数。
getAccessibleChildrenCount() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
返回对象中可访问的子级数。
getAccessibleChildrenCount() - 类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 中的方法
返回对象的可访问子级数。
getAccessibleChildrenCount() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleChildrenCount() - 类 javax.swing.JList.AccessibleJList 中的方法
返回对象中可访问的子级数。
getAccessibleChildrenCount() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
返回该对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 javax.swing.JRootPane.AccessibleJRootPane 中的方法
返回对象的可访问子级数。
getAccessibleChildrenCount() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回对象的可访问子级数。
getAccessibleChildrenCount() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
返回对象中可访问的子级数。
getAccessibleChildrenCount() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
返回此对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回该对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回对象中的可访问子对象数。
getAccessibleChildrenCount() - 类 javax.swing.JTree.AccessibleJTree 中的方法
返回此 JTree 的顶层子节点数。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法

getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
返回对象中的可访问子对象数。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回对象中可访问的子级数。
getAccessibleChildrenCount(Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleChildrenCount() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader 中的方法
返回该对象中可访问的子对象数。
getAccessibleColumn(int) - 接口 javax.accessibility.AccessibleExtendedTable 中的方法
返回表中一个索引的列号。
getAccessibleColumn(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中一个索引的列数。
getAccessibleColumnAtIndex(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回在表中给定的索引位置的列。
getAccessibleColumnCount() - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中的列数。
getAccessibleColumnCount() - 类 javax.swing.JTable.AccessibleJTable 中的方法

getAccessibleColumnDescription(int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中指定列的描述文本。
getAccessibleColumnDescription(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回对表中指定列的描述。
getAccessibleColumnExtentAt(int, int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中指定行和列处 Accessible 占用的列数。
getAccessibleColumnExtentAt(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回 Accessible 在给定的 (row, column) 占用的列数。
getAccessibleColumnHeader() - 接口 javax.accessibility.AccessibleTable 中的方法
返回以 AccessibleTable 表示的列标题。
getAccessibleColumnHeader() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回以 AccessibleTable 表示的列标题。
getAccessibleComponent() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取与此对象相关的 AccessibleComponent（如果存在一个这样的组件）。
getAccessibleComponent() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取与此对象关联的 AccessibleComponent（如果存在）。
getAccessibleComponent() - 类 javax.accessibility.AccessibleContext 中的方法
获取与此对象关联的 AccessibleComponent，它具有图形表示形式。
getAccessibleComponent() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
获取与此对象关联的 AccessibleComponent。
getAccessibleComponent() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此对象关联的 AccessibleComponent（如果存在）。
getAccessibleComponent() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此对象关联的 AccessibleComponent。
getAccessibleComponent() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取与此对象关联的 AccessibleComponent，它具有图形表示形式。
getAccessibleComponent() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
获取与此对象关联的 AccessibleComponent。
getAccessibleContext() - 类 java.applet.Applet 中的方法
获取与此 Applet 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Button 中的方法
获取与此 Button 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Canvas 中的方法
获取与此 Canvas 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Checkbox 中的方法
获取与此 Checkbox 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.CheckboxMenuItem 中的方法
获取与此 CheckboxMenuItem 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Choice 中的方法
获取与此 Choice 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Component 中的方法
获取与此 Component 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Dialog 中的方法
获取与此 Dialog 有关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Frame 中的方法
获取与此窗体有关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Label 中的方法
获取与此标签相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的 AccessibleContext。
getAccessibleContext() - 类 java.awt.List 中的方法
获取与此 List 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Menu 中的方法
获取与此菜单关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.MenuBar 中的方法
获取与此菜单栏关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.MenuComponent 中的方法
获取与此 MenuComponent 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.MenuItem 中的方法
获取与此菜单项关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Panel 中的方法
获取与 Panel 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.PopupMenu 中的方法
获取与此 PopupMenu 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Scrollbar 中的方法
获取与此 Scrollbar 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.ScrollPane 中的方法
获取与此 ScrollPane 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.TextArea 中的方法
返回与此 TextArea 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.TextComponent 中的方法
获取与此 TextComponent 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.TextField 中的方法
获取与此 TextField 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Window 中的方法
获取与此窗口关联的 AccessibleContext。
getAccessibleContext() - 接口 javax.accessibility.Accessible 中的方法
返回与此对象关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.Box.Filler 中的方法
获取与此 Box.Filler 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.Box 中的方法
获取与此 Box 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.CellRendererPane 中的方法
获取与此 CellRendererPane 相关的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.ImageIcon 中的方法
获得与此 ImageIcon 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JApplet 中的方法
获取与此 JApplet 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JButton 中的方法
获取与此 JButton 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JCheckBox 中的方法
获取与此 JCheckBox 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JCheckBoxMenuItem 中的方法
获得与此 JCheckBoxMenuItem 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JColorChooser 中的方法
获取与此 JColorChooser 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JComboBox 中的方法
获取与此 JComboBox 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JComponent 中的方法
返回与此 JComponent 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JDesktopPane 中的方法
获取与此 JDesktopPane 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JDialog 中的方法
获取与此 JDialog 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JEditorPane 中的方法
获取与此 JEditorPane 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JFileChooser 中的方法
获取与此 JFileChooser 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JFrame 中的方法
获得与此 JFrame 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JInternalFrame 中的方法
获得与此 JInternalFrame 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
获取与此 JDesktopIcon 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JLabel 中的方法
获得此对象的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JLayeredPane 中的方法
获得与此 JLayeredPane 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
获取此对象的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JList 中的方法
获取与此 JList 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JMenu 中的方法
获取与此 JMenu 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JMenuBar 中的方法
获取与此 JMenuBar 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JMenuItem 中的方法
返回与此 JMenuItem 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JOptionPane 中的方法
返回与此 JOptionPane 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JPanel 中的方法
获取与此 JPanel 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JPasswordField 中的方法
返回与此 JPasswordField 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JPopupMenu 中的方法
获取与此 JPopupMenu 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JProgressBar 中的方法
获得与此 JProgressBar 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JRadioButton 中的方法
获取与此 JRadioButton 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JRadioButtonMenuItem 中的方法
获取与此 JRadioButtonMenuItem 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JRootPane 中的方法
获取与此 JRootPane 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JScrollBar 中的方法
获取与此 JScrollBar 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JScrollPane 中的方法
获取与此 JScrollPane 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JSeparator 中的方法
获取与此 JSeparator 相关的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JSlider 中的方法
获取与此 JSlider 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JSpinner 中的方法
获取此 JSpinner 的 AccessibleContext
getAccessibleContext() - 类 javax.swing.JSplitPane 中的方法
获取与 JSplitPane 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTabbedPane 中的方法
获取与此 JTabbedPane 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此组件关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTable 中的方法
获取与此 JTable 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTextArea 中的方法
获取与此 JTextArea 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTextField 中的方法
获取与此 JTextField 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JToggleButton 中的方法
获取与此 JToggleButton 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JToolBar 中的方法
获取与此 JToolBar 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JToolTip 中的方法
获取与此 JToolTip 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此树节点关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTree 中的方法
获取与此 JTree 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JViewport 中的方法
获取与此 JViewport 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JWindow 中的方法
获取与此 JWindow 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
获取与此 BasicComboPopup 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.ProgressMonitor 中的方法
获得 ProgressMonitor 的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
获取与此对象关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.table.JTableHeader 中的方法
获取与此 JTableHeader 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
返回与此编辑器工具包关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.text.JTextComponent 中的方法
获取与此 JTextComponent 关联的 AccessibleContext。
getAccessibleDescription() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的可访问描述。
getAccessibleDescription() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的可访问的描述。
getAccessibleDescription() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象的 accessibleDescription 属性。
getAccessibleDescription() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
获取此对象的可访问描述。
getAccessibleDescription() - 类 javax.swing.JEditorPane.AccessibleJEditorPane 中的方法
获得此对象的 accessibleDescription 属性。
getAccessibleDescription() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleDescription() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的可访问的描述。
getAccessibleDescription() - 类 javax.swing.JToolTip.AccessibleJToolTip 中的方法
获取此对象的可访问的描述。
getAccessibleDescription() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的可访问的描述。
getAccessibleDescription() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取对象的 accessibleDescription 属性。
getAccessibleDescription() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleEditableText() - 类 javax.accessibility.AccessibleContext 中的方法
获取与在显示器上显示可编辑文本的此对象关联的 AccessibleEditableText。
getAccessibleEditableText() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回此文本组件的 AccessibleEditableText 接口。
getAccessibleIcon() - 类 javax.accessibility.AccessibleContext 中的方法
获取与此对象关联的具有一个或多个相关图标的 AccessibleIcons
getAccessibleIcon() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。
getAccessibleIcon() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。
getAccessibleIcon() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
返回元素渲染器的图标，作为 AccessibleIcon 数组的唯一项；如果渲染器组件不包含任何图标，则返回一个 null 数组。
getAccessibleIconDescription() - 接口 javax.accessibility.AccessibleIcon 中的方法
获取此图标的描述。
getAccessibleIconDescription() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得此图标的描述。
getAccessibleIconHeight() - 接口 javax.accessibility.AccessibleIcon 中的方法
获取图标的高度。
getAccessibleIconHeight() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得图标的高度。
getAccessibleIconWidth() - 接口 javax.accessibility.AccessibleIcon 中的方法
获取图标的宽度。
getAccessibleIconWidth() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得图标的宽度。
getAccessibleIndex(int, int) - 接口 javax.accessibility.AccessibleExtendedTable 中的方法

getAccessibleIndex(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中在某一行和某一列的索引。
getAccessibleIndexAt(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中在给定的 (row, column) 位置的索引。
getAccessibleIndexInParent() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象在其可访问父对象中的索引。
getAccessibleIndexInParent() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的可访问父级中基于 0 的索引。
getAccessibleIndexInParent() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象在其可访问的父对象中的索引。
getAccessibleIndexInParent() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象在其可访问父级中的基于零的索引。
getAccessibleIndexInParent() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得此对象在其可访问的父对象中的索引。
getAccessibleIndexInParent() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleIndexInParent() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象在其可访问的父对象中的索引。
getAccessibleIndexInParent() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象在其可访问父对象中的索引。
getAccessibleIndexInParent() - 类 javax.swing.JTree.AccessibleJTree 中的方法
获取此对象在其可访问父对象中的索引。
getAccessibleIndexInParent() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取此对象在其可访问的父对象中的索引。
getAccessibleIndexInParent(Component) - 类 javax.swing.SwingUtilities 中的静态方法
获取此对象在其可访问的父对象中的索引。
getAccessibleIndexInParent() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleKeyBinding() - 接口 javax.accessibility.AccessibleExtendedComponent 中的方法
返回与此对象关联的键绑定。
getAccessibleKeyBinding(int) - 接口 javax.accessibility.AccessibleKeyBinding 中的方法
返回此对象的键绑定。
getAccessibleKeyBinding() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回与此对象有关的键绑定。
getAccessibleKeyBinding() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
返回与此对象关联的键绑定
getAccessibleKeyBinding() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回与此对象关联的键绑定
getAccessibleKeyBindingCount() - 接口 javax.accessibility.AccessibleKeyBinding 中的方法
返回此对象的键绑定数。
getAccessibleName() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 java.awt.Label.AccessibleAWTLabel 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的可访问的名称。
getAccessibleName() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象的 accessibleName 属性。
getAccessibleName() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JDialog.AccessibleJDialog 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JFrame.AccessibleJFrame 中的方法
获得此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleName() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
返回此对象的可访问名称；如果没有可访问名称，则返回 null。
getAccessibleName() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的可访问的名称。
getAccessibleName() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取此对象的 accessibleName 属性。
getAccessibleName() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleParent() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的 Accessible 父对象。
getAccessibleParent() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的 Accessible 父对象。
getAccessibleParent() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象的 Accessible 父对象。
getAccessibleParent() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得此对象的 Accessible 父对象。
getAccessibleParent() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的 Accessible 父对象。
getAccessibleParent() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的 Accessible 父对象。
getAccessibleParent() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取此对象的 Accessible 父对象。
getAccessibleRelationSet() - 类 javax.accessibility.AccessibleContext 中的方法
获取与某个对象关联的 AccessibleRelationSet
getAccessibleRelationSet() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
获得与此对象关联的 AccessibleRelationSet（如果存在）。
getAccessibleRelationSet() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
获取与此对象关联的 AccessibleRelationSet（如果存在）。
getAccessibleRole() - 类 java.applet.Applet.AccessibleApplet 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Canvas.AccessibleAWTCanvas 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Choice.AccessibleAWTChoice 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Dialog.AccessibleAWTDialog 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Frame.AccessibleAWTFrame 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Label.AccessibleAWTLabel 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.List.AccessibleAWTList 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Menu.AccessibleAWTMenu 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.MenuBar.AccessibleAWTMenuBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Panel.AccessibleAWTPanel 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.PopupMenu.AccessibleAWTPopupMenu 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.ScrollPane.AccessibleAWTScrollPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Window.AccessibleAWTWindow 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.Box.AccessibleBox 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.Box.Filler.AccessibleBoxFiller 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.CellRendererPane.AccessibleCellRendererPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得此对象的职责。
getAccessibleRole() - 类 javax.swing.JButton.AccessibleJButton 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JCheckBox.AccessibleJCheckBox 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JColorChooser.AccessibleJColorChooser 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
获取此对象的功能。
getAccessibleRole() - 类 javax.swing.JDesktopPane.AccessibleJDesktopPane 中的方法
获取此对象的功能。
getAccessibleRole() - 类 javax.swing.JFileChooser.AccessibleJFileChooser 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JLayeredPane.AccessibleJLayeredPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleRole() - 类 javax.swing.JList.AccessibleJList 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JMenuItem.AccessibleJMenuItem 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JOptionPane.AccessibleJOptionPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JPanel.AccessibleJPanel 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JPopupMenu.AccessibleJPopupMenu 中的方法
获得此对象的职责。
getAccessibleRole() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JRadioButton.AccessibleJRadioButton 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JRootPane.AccessibleJRootPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JScrollPane.AccessibleJScrollPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JSeparator.AccessibleJSeparator 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
获取此对象的功能。
getAccessibleRole() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的功能。
getAccessibleRole() - 类 javax.swing.JTable.AccessibleJTable 中的方法
获取此对象的功能。
getAccessibleRole() - 类 javax.swing.JToggleButton.AccessibleJToggleButton 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JToolBar.AccessibleJToolBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JToolTip.AccessibleJToolTip 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JTree.AccessibleJTree 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JViewport.AccessibleJViewport 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleRole() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
获取此对象的职责。
getAccessibleRow(int) - 接口 javax.accessibility.AccessibleExtendedTable 中的方法
返回表中一个索引的行号。
getAccessibleRow(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中一个索引的行数。
getAccessibleRowAtIndex(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中在一个给定的索引位置的行。
getAccessibleRowCount() - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中的行数。
getAccessibleRowCount() - 类 javax.swing.JTable.AccessibleJTable 中的方法

getAccessibleRowDescription(int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回对表中指定行的描述。
getAccessibleRowDescription(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回对表中指定行的描述。
getAccessibleRowExtentAt(int, int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中指定行和列处的 Accessible 所占用的行数。
getAccessibleRowExtentAt(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回 Accessible 在表中指定行和列占用的行数。
getAccessibleRowHeader() - 接口 javax.accessibility.AccessibleTable 中的方法
返回以 AccessibleTable 表示的行标题。
getAccessibleRowHeader() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回以 AccessibleTable 表示的行标题。
getAccessibleSelection() - 类 java.awt.List.AccessibleAWTList 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 java.awt.List.AccessibleAWTList 中的方法
返回表示对象中指定选项的 Accessible。
getAccessibleSelection() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子对象。
getAccessibleSelection(int) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回 Accessible，它表示该对象中指定的已选择的子对象。
getAccessibleSelection() - 类 javax.accessibility.AccessibleContext 中的方法
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。
getAccessibleSelection(int) - 接口 javax.accessibility.AccessibleSelection 中的方法
返回表示指定的所选对象子级的 Accessible。
getAccessibleSelection() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回表示弹出对象中指定选择子级的 Accessible。
getAccessibleSelection() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleSelection() - 类 javax.swing.JList.AccessibleJList 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JList.AccessibleJList 中的方法
返回表示对象中指定选项的 Accessible。
getAccessibleSelection() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
返回当前选择的子菜单（如果选择了），否则返回 null（只能选择一项并且只能选择子菜单，除非菜单项没有保持选中状态）。
getAccessibleSelection() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
返回当前选择的菜单（如果选择了一个）；否则返回 null。
getAccessibleSelection() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
获取与此对象关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法

getAccessibleSelection() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此对象关联的 AccessibleSelection（如果存在）。
getAccessibleSelection() - 类 javax.swing.JTable.AccessibleJTable 中的方法
获取与此对象关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回 Accessible，它表示该对象中指定的已选择的子对象。
getAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此对象关联的 AccessibleSelection（如果存在）。
getAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回表示对象中指定选择项的 Accessible。
getAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree 中的方法
返回表示对象中指定选择项的 Accessible。
getAccessibleSelection() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleSelectionCount() - 类 java.awt.List.AccessibleAWTList 中的方法
返回当前选择的项数。
getAccessibleSelectionCount() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回当前选择的 Accessible 子对象数。
getAccessibleSelectionCount() - 接口 javax.accessibility.AccessibleSelection 中的方法
返回当前选中的 Accessible 子级数。
getAccessibleSelectionCount() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回当前选定的 Accessible 子对象数。
getAccessibleSelectionCount() - 类 javax.swing.JList.AccessibleJList 中的方法
返回当前选择的项数。
getAccessibleSelectionCount() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
如果当前在此菜单中选择了子菜单，则返回 1。
getAccessibleSelectionCount() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
如果当前在此菜单栏中选择了菜单，则返回 1。
getAccessibleSelectionCount() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法

getAccessibleSelectionCount() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回当前选择的 Accessible 子对象数。
getAccessibleSelectionCount() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回当前选中的项数。
getAccessibleSelectionCount() - 类 javax.swing.JTree.AccessibleJTree 中的方法
返回当前选中的项数。
getAccessibleStateSet() - 类 java.applet.Applet.AccessibleApplet 中的方法
获得此对象的状态。
getAccessibleStateSet() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 java.awt.Dialog.AccessibleAWTDialog 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 java.awt.Frame.AccessibleAWTFrame 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.List.AccessibleAWTList 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.TextArea.AccessibleAWTTextArea 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
获取 TextComponent 的状态设置。
getAccessibleStateSet() - 类 java.awt.TextField.AccessibleAWTTextField 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.Window.AccessibleAWTWindow 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象的状态集合。
getAccessibleStateSet() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
获得此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得此对象的状态。
getAccessibleStateSet() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 javax.swing.JDialog.AccessibleJDialog 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 javax.swing.JEditorPane.AccessibleJEditorPane 中的方法
获取此对象的状态集。
getAccessibleStateSet() - 类 javax.swing.JFrame.AccessibleJFrame 中的方法
获得此对象的状态。
getAccessibleStateSet() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleStateSet() - 类 javax.swing.JList.AccessibleJList 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
获得此对象的可访问性状态设置。
getAccessibleStateSet() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取此对象的状态集。
getAccessibleStateSet() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取此对象的状态集。
getAccessibleStateSet() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JTextArea.AccessibleJTextArea 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JTextField.AccessibleJTextField 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JToolBar.AccessibleJToolBar 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取此对象的状态集。
getAccessibleStateSet(Component) - 类 javax.swing.SwingUtilities 中的静态方法
获取此对象的状态。
getAccessibleStateSet() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleStateSet() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
获取 JTextComponent 的状态设置。
getAccessibleSummary() - 接口 javax.accessibility.AccessibleTable 中的方法
返回表的摘要描述。
getAccessibleSummary() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表的摘要描述。
getAccessibleTable() - 类 javax.accessibility.AccessibleContext 中的方法
获取与某个对象关联的 AccessibleTable
getAccessibleTable() - 类 javax.swing.JTable.AccessibleJTable 中的方法
获取与此对象关联的 AccessibleTable。
getAccessibleText() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
获取与此对象相关的 AccessibleText。
getAccessibleText() - 类 javax.accessibility.AccessibleContext 中的方法
获取与在显示器上显示文本的此对象关联的 AccessibleText。
getAccessibleText() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法

getAccessibleText() - 类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 中的方法

getAccessibleText() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法

getAccessibleText() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleText() - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
获取 JPasswordField 的 AccessibleText。
getAccessibleText() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取与此对象相关联的可在显示器上表示的 AccessibleText。
getAccessibleText() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此对象关联的 AccessibleText （如果存在）。
getAccessibleText() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此对象关联的 AccessibleText（如果存在）。
getAccessibleText() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取与在显示器上显示文本的此对象关联的 AccessibleText。
getAccessibleText() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleText() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
获取与此对象关联的 AccessibleText。
getAccessibleValue() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取与此对象相关的 AccessibleValue。
getAccessibleValue() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取与此对象相关的 AccessibleValue。
getAccessibleValue() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取与此对象相关的 AccessibleValue。
getAccessibleValue() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获得与此对象相关的 AccessibleValue。
getAccessibleValue() - 类 javax.accessibility.AccessibleContext 中的方法
获取与此对象关联的支持 Numerical 值的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleValue() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获得与此对象相关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此对象关联的 AccessibleValue（如果存在）。
getAccessibleValue() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此对象关联的 AccessibleValue（如果存在）。
getAccessibleValue() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取与此对象关联的 AccessibleValue，该对象支持数值。
getAccessibleValue() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessLevel() - 类 javax.tools.ForwardingJavaFileObject 中的方法

getAccessLevel() - 接口 javax.tools.JavaFileObject 中的方法
提供有关此文件对象表示的类的访问级别的提示。
getAccessLevel() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现返回 null。
getAccessory() - 类 javax.swing.JFileChooser 中的方法
返回 accessory 组件。
getAccessoryPanel() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getACHuffmanTables() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
返回最近一次调用 setDecodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getACHuffmanTables() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
返回最近一次调用 setEncodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getAction() - 类 java.beans.EventHandler 中的方法
返回此事件处理程序将设置的目标的可写属性名称，或者此事件处理程序将在目标上调用的方法名称。
getAction() - 类 javax.swing.AbstractButton 中的方法
返回当前为此 ActionEvent 源设置的 Action，如果没有设置任何 Action，则返回 null。
getAction() - 类 javax.swing.JComboBox 中的方法
返回此 ActionEvent 源当前设置的 Action，如果没有设置任何 Action，则返回 null。
getAction() - 类 javax.swing.JTextField 中的方法
返回此 ActionEvent 源当前设置的 Action，如果没有设置 Action 则返回 null。
getAction(KeyStroke) - 接口 javax.swing.text.Keymap 中的方法
获取适合于给定符号事件序列的操作。
getActionCommand() - 类 java.awt.Button 中的方法
返回此按钮激发的动作事件的命令名称。
getActionCommand() - 类 java.awt.event.ActionEvent 中的方法
返回与此动作相关的命令字符串。
getActionCommand() - 类 java.awt.MenuItem 中的方法
获取由此菜单项引发的动作事件的命令名。
getActionCommand() - 类 java.awt.TrayIcon 中的方法
返回由此托盘图标触发的动作事件的命令名。
getActionCommand() - 类 javax.swing.AbstractButton 中的方法
返回此按钮的动作命令。
getActionCommand() - 接口 javax.swing.ButtonModel 中的方法
返回该按钮的动作命令字符串。
getActionCommand() - 类 javax.swing.DefaultButtonModel 中的方法
返回该按钮的动作命令字符串。
getActionCommand() - 类 javax.swing.JComboBox 中的方法
返回发送到动作侦听器的事件中包括的动作命令。
getActionCommand() - 类 javax.swing.Timer 中的方法
返回将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。
getActionForKeyStroke(KeyStroke) - 类 javax.swing.JComponent 中的方法
返回执行针对给定键击而注册的操作的对象。
getActionListeners() - 类 java.awt.Button 中的方法
返回在此按钮上注册的所有动作侦听器的一个数组。
getActionListeners() - 类 java.awt.List 中的方法
返回已在此列表上注册的所有动作侦听器的数组。
getActionListeners() - 类 java.awt.MenuItem 中的方法
返回在此菜单项上注册的所有动作侦听器组成的数组。
getActionListeners() - 类 java.awt.TextField 中的方法
返回此文本字段上已注册的所有操作侦听器的数组。
getActionListeners() - 类 java.awt.TrayIcon 中的方法
返回在已此 TrayIcon 上注册的所有动作侦听器的数组。
getActionListeners() - 类 javax.swing.AbstractButton 中的方法
返回使用 addActionListener() 添加到此 AbstractButton 的所有 ActionListener 组成的数组。
getActionListeners() - 类 javax.swing.DefaultButtonModel 中的方法
返回此 DefaultButtonModel 上所有已注册的操作侦听器组成的数组。
getActionListeners() - 类 javax.swing.JComboBox 中的方法
返回使用 addActionListener() 添加到此 JComboBox 的所有 ActionListener 组成的数组。
getActionListeners() - 类 javax.swing.JFileChooser 中的方法
返回在此文件选择器上注册的所有操作侦听器的数组。
getActionListeners() - 类 javax.swing.JTextField 中的方法
返回通过 addActionListener() 添加到此 JTextField 中的所有 ActionListener 的数组。
getActionListeners() - 类 javax.swing.Timer 中的方法
返回已在此计时器上注册的所有动作侦听器所组成的数组。
getActionMap() - 类 javax.swing.JComponent 中的方法
返回用于确定为特定 KeyStroke 绑定触发何种 Action 的 ActionMap。
getActionMap() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getActions() - 类 java.io.FilePermission 中的方法
返回操作的“规范化字符串表示形式”。
getActions() - 类 java.net.SocketPermission 中的方法
返回动作的规范化字符串表示形式。
getActions() - 类 java.security.AllPermission 中的方法
返回操作的规范化字符串表示形式。
getActions() - 类 java.security.BasicPermission 中的方法
返回操作的规范化字符串表示形式，该表示形式当前为空字符串 ""，因为不存在 BasicPermission 的操作。
getActions() - 类 java.security.Permission 中的方法
以 String 的形式返回操作。
getActions() - 类 java.security.UnresolvedPermission 中的方法
返回这些操作的规范的字符串表示形式，该字符串当前为空字符串 ""，原因是没有针对 UnresolvedPermission 的操作。
getActions() - 类 java.util.PropertyPermission 中的方法
返回动作的“规范化字符串表示形式”。
getActions() - 类 javax.management.MBeanPermission 中的方法
返回操作的“规范化字符串表示形式”。
getActions() - 类 javax.security.auth.kerberos.ServicePermission 中的方法
返回动作的规范化字符串表示形式。
getActions() - 类 javax.security.auth.PrivateCredentialPermission 中的方法
返回操作的“规范的字符串表示形式”。
getActions() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
如果想提供自定义的 Action 集合，则应进行子类化和重写。
getActions() - 类 javax.swing.JFormattedTextField 中的方法
获取编辑器的命令列表。
getActions() - 类 javax.swing.JTextField 中的方法
获取编辑器的命令列表。
getActions() - 类 javax.swing.text.DefaultEditorKit 中的方法
获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。
getActions() - 类 javax.swing.text.EditorKit 中的方法
获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。
getActions() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取编辑器的命令列表。
getActions() - 类 javax.swing.text.InternationalFormatter 中的方法
如果 getSupportsIncrement 返回 true，则这将返回两个适合增加/减少该值的 Action。
getActions() - 类 javax.swing.text.JTextComponent 中的方法
获取编辑器的命令列表。
getActions() - 类 javax.swing.text.StyledEditorKit 中的方法
获取编辑器的命令列表。
getActivationDesc(ActivationID) - 接口 java.rmi.activation.ActivationSystem 中的方法
为具有该激活标识符 id 的对象返回激活描述符。
getActivationGroupDesc(ActivationGroupID) - 接口 java.rmi.activation.ActivationSystem 中的方法
为具有该激活组标识符 id 的组返回激活组描述符。
getActiveCount() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回主动执行任务的近似线程数。
getActiveWindow() - 类 java.awt.KeyboardFocusManager 中的方法
如果活动 Window 与调用线程位于同一个上下文中，则返回活动 Window。
getActor() - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
返回此 SOAPHeaderElement actor 属性的 URL。
getActualMaximum(int) - 类 java.util.Calendar 中的方法
给定此 Calendar 的时间值，返回指定日历字段可能拥有的最大值。
getActualMaximum(int) - 类 java.util.GregorianCalendar 中的方法
考虑到给定的时间值和 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，返回此日历字段可能具有的最大值。
getActualMinimum(int) - 类 java.util.Calendar 中的方法
给定此 Calendar 的时间值，返回指定日历字段可能拥有的最小值。
getActualMinimum(int) - 类 java.util.GregorianCalendar 中的方法
考虑到给定的时间值和 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，返回此日历字段可能具有的最小值。
getActualTypeArguments() - 接口 java.lang.reflect.ParameterizedType 中的方法
返回表示此类型实际类型参数的 Type 对象的数组。
getAdapter(Class<A>) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法

getAdapter(Class<A>) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法

getAdapter(Class<A>) - 接口 javax.xml.bind.Marshaller 中的方法
获取与指定类型关联的适配器。
getAdapter(Class<A>) - 接口 javax.xml.bind.Unmarshaller 中的方法
获取与指定类型关联的适配器。
getAdditionalBeanInfo() - 接口 java.beans.BeanInfo 中的方法
此方法允许 BeanInfo 对象返回提供关于当前 bean 额外信息的 BeanInfo 对象组成的任意集合。
getAdditionalBeanInfo() - 类 java.beans.SimpleBeanInfo 中的方法
声明没有其他有关的 BeanInfo 对象。
getAdditionalHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 中的方法

getAdditionalHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 中的方法

getAdditionalHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon 中的方法

getAdditionalHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon 中的方法

getAddListenerMethod() - 类 java.beans.EventSetDescriptor 中的方法
获得用来添加事件侦听器的方法。
getAddress() - 类 java.net.DatagramPacket 中的方法
返回某台机器的 IP 地址，此数据报将要发往该机器或者是从该机器接收到的。
getAddress() - 类 java.net.Inet4Address 中的方法
返回此 InetAddress 对象的原始 IP 地址。
getAddress() - 类 java.net.Inet6Address 中的方法
返回此 InetAddress 对象的原始 IP 地址。
getAddress() - 类 java.net.InetAddress 中的方法
返回此 InetAddress 对象的原始 IP 地址。
getAddress() - 类 java.net.InetSocketAddress 中的方法
获取 InetAddress。
getAddress() - 类 java.net.InterfaceAddress 中的方法
返回此地址的 InetAddress。
getAddress() - 接口 javax.management.remote.JMXAddressable 中的方法
此对象的地址。
getAddress() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
该连接器服务器的地址。
getAddress() - 类 javax.management.remote.rmi.RMIConnector 中的方法
此连接器的地址。
getAddress() - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法

getAdjustable() - 类 java.awt.event.AdjustmentEvent 中的方法
返回发起此事件的 Adjustable 对象。
getAdjustmentListeners() - 类 java.awt.Scrollbar 中的方法
返回在此滚动条上所有已注册调整侦听器组成的数组。
getAdjustmentListeners() - 类 java.awt.ScrollPaneAdjustable 中的方法
返回在此 ScrollPaneAdjustable 上所有已注册调整侦听器组成的数组。
getAdjustmentListeners() - 类 javax.swing.JScrollBar 中的方法
返回使用 addAdjustmentListener() 添加到此 JScrollBar 中的 AdjustmentListener 组成的数组。
getAdjustmentType() - 类 java.awt.event.AdjustmentEvent 中的方法
返回导致值更改事件的调整类型。
getAdler() - 类 java.util.zip.Deflater 中的方法
返回未压缩数据的 ADLER-32 值。
getAdler() - 类 java.util.zip.Inflater 中的方法
返回未压缩数据的 ADLER-32 值。
getAdvance() - 类 java.awt.font.GlyphMetrics 中的方法
返回沿基线（水平基线或垂直基线）的字形 advance。
getAdvance() - 类 java.awt.font.GraphicAttribute 中的方法
返回此 GraphicAttribute 的 advance。
getAdvance() - 类 java.awt.font.ImageGraphicAttribute 中的方法
返回此 ImageGraphicAttribute 的 advance。
getAdvance() - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回此 ShapeGraphicAttribute 的 advance。
getAdvance() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的 advance。
getAdvanceBetween(int, int) - 类 java.awt.font.TextMeasurer 中的方法
返回从 start 开始并包括一直到 limit 的字符的行的图形宽度。
getAdvanceX() - 类 java.awt.font.GlyphMetrics 中的方法
返回字形 advance 的 x 分量。
getAdvanceY() - 类 java.awt.font.GlyphMetrics 中的方法
返回字形 advance 的 y 分量。
getAffineX() - 类 java.security.spec.ECPoint 中的方法
返回仿射 x 坐标 x。
getAffineY() - 类 java.security.spec.ECPoint 中的方法
返回仿射 y 坐标 y。
getAfterIndex(int, int) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回给定索引后面的 String。
getAfterIndex(int, int) - 接口 javax.accessibility.AccessibleText 中的方法
返回给定索引后面的 String。
getAfterIndex(int, int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回给定索引之后的 String。
getAfterIndex(int, int) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回给定索引后的 String。
getAfterIndex(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 之后的 String。
getAfterIndex(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回给定索引后的 String。
getAfterIndex(int, int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回给定索引后面的 String。
getAfterIndex(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定索引之后的 String。
getAlgName() - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
返回加密算法。
getAlgorithm() - 类 java.security.AlgorithmParameterGenerator 中的方法
返回与此参数生成器关联的算法的标准名称。
getAlgorithm() - 类 java.security.AlgorithmParameters 中的方法
返回与此参数对象关联的算法的名称。
getAlgorithm() - 类 java.security.cert.CertPathBuilder 中的方法
返回此 CertPathBuilder 的算法名称。
getAlgorithm() - 类 java.security.cert.CertPathValidator 中的方法
返回此 CertPathValidator 的算法名称。
getAlgorithm() - 接口 java.security.Key 中的方法
返回此密钥的标准算法名称。
getAlgorithm() - 类 java.security.KeyFactory 中的方法
获取与此 KeyFactory 关联的算法的名称。
getAlgorithm() - 类 java.security.KeyPairGenerator 中的方法
返回此密钥对生成器算法的标准名称。
getAlgorithm() - 类 java.security.MessageDigest 中的方法
返回标识算法的独立于实现细节的字符串。
getAlgorithm() - 类 java.security.Provider.Service 中的方法
返回此服务的算法的名称。
getAlgorithm() - 类 java.security.SecureRandom 中的方法
返回此 SecureRandom 对象实现的算法的名称。
getAlgorithm() - 类 java.security.Signature 中的方法
返回此签名对象的算法名称。
getAlgorithm() - 类 java.security.SignedObject 中的方法
获取签名算法的名称。
getAlgorithm() - 类 javax.crypto.Cipher 中的方法
返回此 Cipher 对象的算法名称。
getAlgorithm() - 类 javax.crypto.KeyAgreement 中的方法
返回此 KeyAgreement 对象的算法名称。
getAlgorithm() - 类 javax.crypto.KeyGenerator 中的方法
返回此 KeyGenerator 对象的算法名称。
getAlgorithm() - 类 javax.crypto.Mac 中的方法
返回此 Mac 对象的算法名称。
getAlgorithm() - 类 javax.crypto.SealedObject 中的方法
返回用于密封此对象的算法。
getAlgorithm() - 类 javax.crypto.SecretKeyFactory 中的方法
返回此 SecretKeyFactory 对象的算法名称。
getAlgorithm() - 类 javax.crypto.spec.PSource 中的方法
返回 PSource 算法名称。
getAlgorithm() - 类 javax.crypto.spec.SecretKeySpec 中的方法
返回与此密钥关联的算法的名称。
getAlgorithm() - 类 javax.net.ssl.KeyManagerFactory 中的方法
返回此 KeyManagerFactory 对象的算法名称。
getAlgorithm() - 类 javax.net.ssl.TrustManagerFactory 中的方法
返回此 TrustManagerFactory 对象的算法名称。
getAlgorithm() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回此密钥的标准算法名称。
getAlgorithm() - 接口 javax.xml.crypto.AlgorithmMethod 中的方法
返回此 AlgorithmMethod 的算法 URI。
getAlgorithm() - 类 javax.xml.crypto.dsig.TransformService 中的方法
返回此 TransformService 支持的算法 URI。
getAlgorithmProperty(String, String) - 类 java.security.Security 中的静态方法
已过时。 此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。
getAlgorithms(String) - 类 java.security.Security 中的静态方法
返回字符串 Set，这些字符串包含了指定的 Java 加密服务的所有可用算法或类型的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。
getAlgParameters() - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
返回加密算法使用的算法参数。
getAlias() - 类 javax.security.auth.x500.X500PrivateCredential 中的方法
返回 KeyStore 别名。
getAlignedSizeRequirements(SizeRequirements[]) - 类 javax.swing.SizeRequirements 中的静态方法
确定对齐一组组件所需的总空间。
getAlignment() - 类 java.awt.FlowLayout 中的方法
获取此布局的对齐方式。
getAlignment() - 类 java.awt.font.GraphicAttribute 中的方法
返回此 GraphicAttribute 的对齐方式。
getAlignment() - 类 java.awt.Label 中的方法
获取此标签的当前对齐方式。
getAlignment(int) - 类 javax.swing.text.BoxView 中的方法
确定此视图沿某个轴所需的调整值。
getAlignment(int) - 类 javax.swing.text.ComponentView 中的方法
确定此视图沿某轴所需的对齐方式。
getAlignment(int) - 类 javax.swing.text.GlyphView 中的方法
确定此视图沿某个轴所需的对齐方式。
getAlignment(int) - 类 javax.swing.text.html.BlockView 中的方法
获取对齐方式。
getAlignment(int) - 类 javax.swing.text.html.ImageView 中的方法
确定此视图沿某个轴所需的调整值。
getAlignment(int) - 类 javax.swing.text.html.ListView 中的方法
计算所需的列表形状。
getAlignment(int) - 类 javax.swing.text.IconView 中的方法
确定此视图沿某个轴所需的调整值。
getAlignment(int) - 类 javax.swing.text.ParagraphView 中的方法
确定此视图沿某轴所需的对齐方式。
getAlignment(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取对齐设置。
getAlignment() - 类 javax.swing.text.TabStop 中的方法
以 integer 的形式返回制表符的对齐方式。
getAlignment(int) - 类 javax.swing.text.View 中的方法
确定此视图沿某个轴所需的对齐方式。
getAlignmentX() - 类 java.awt.Component 中的方法
返回 x 轴的对齐方式。
getAlignmentX() - 类 java.awt.Container 中的方法
返回沿 x 轴的对齐方式。
getAlignmentX() - 类 javax.swing.JComponent 中的方法
重写 Container.getAlignmentX 以返回垂直对齐方式。
getAlignmentY() - 类 java.awt.Component 中的方法
返回 y 轴的对齐方式。
getAlignmentY() - 类 java.awt.Container 中的方法
返回沿 y 轴的对齐方式。
getAlignmentY() - 类 javax.swing.JComponent 中的方法
重写 Container.getAlignmentY 以返回水平对齐方式。
getAlignOnBaseline() - 类 java.awt.FlowLayout 中的方法
如果组件将沿其基线垂直对齐，则返回 true。
getAll(String[]) - 接口 javax.management.openmbean.CompositeData 中的方法
返回通过 keys 指定其项名称的值组成的数组，值排列的顺序与 keys 相同。
getAll(String[]) - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回由 keys 指定其项名称的值的数组，顺序与 keys 相同。
getAll() - 类 javax.naming.CompositeName 中的方法
以字符串枚举的形式检索此复合名称的组件。
getAll() - 类 javax.naming.CompoundName 中的方法
以字符串枚举的形式检索此组合名称的组件。
getAll() - 接口 javax.naming.directory.Attribute 中的方法
检索属性值的枚举。
getAll() - 接口 javax.naming.directory.Attributes 中的方法
检索属性集中属性的枚举。
getAll() - 类 javax.naming.directory.BasicAttribute 中的方法
检索此属性值的枚举。
getAll() - 类 javax.naming.directory.BasicAttributes 中的方法

getAll() - 类 javax.naming.ldap.LdapName 中的方法
以字符串枚举的形式检索此名称的组件。
getAll() - 接口 javax.naming.Name 中的方法
以字符串枚举的形式检索此名称的组件。
getAll() - 类 javax.naming.Reference 中的方法
返回此索引中的地址所组成的枚举。
getAllAnnotationMirrors(Element) - 接口 javax.lang.model.util.Elements 中的方法
返回元素的所有注释，不管是继承的还是直接存在的。
getAllAttributeKeys() - 接口 java.text.AttributedCharacterIterator 中的方法
返回定义于迭代器文本范围上的所有属性的键。
getAllAttributeKeys() - 类 javax.swing.text.html.CSS 中的静态方法
返回所有可能的 CSS 属性键集合。
getAllAttributeKeys() - 类 javax.swing.text.html.HTML 中的静态方法
返回所识别的 HTML 属性集。
getAllAttributes() - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在此 SOAPElement 对象中所有属性 Name 对象上进行迭代的 Iterator。
getAllAttributesAsQNames() - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在此 SOAPElement 对象（以 QName 对象的形式）中的所有属性上进行迭代的 Iterator。
getAllByName(String) - 类 java.net.InetAddress 中的静态方法
在给定主机名的情况下，根据系统上配置的名称服务返回其 IP 地址所组成的数组。
getAllCommands(String) - 类 javax.activation.CommandMap 中的方法
获取此类型的所有可用命令。
getAllCommands(String, DataSource) - 类 javax.activation.CommandMap 中的方法
获取此类型的所有可用命令。
getAllCommands() - 类 javax.activation.DataHandler 中的方法
返回此数据类型的所有命令。
getAllCommands(String) - 类 javax.activation.MailcapCommandMap 中的方法
针对此 MIME 类型获取此 MailcapCommandMap 实例已知的所有 mailcap 文件中的所有可用命令。
getAllFonts() - 类 java.awt.GraphicsEnvironment 中的方法
返回一个数组，它包含此 GraphicsEnvironment 中所有可用字体的像素级实例。
getAllFrames() - 类 javax.swing.JDesktopPane 中的方法
返回桌面中当前显示的所有 JInternalFrames。
getAllFramesInLayer(int) - 类 javax.swing.JDesktopPane 中的方法
返回桌面指定层中当前所显示的所有 JInternalFrames。
getAllHeaders() - 类 javax.xml.soap.MimeHeaders 中的方法
返回此 MimeHeaders 对象中的所有 MimeHeader。
getAllLoadedClasses() - 接口 java.lang.instrument.Instrumentation 中的方法
返回 JVM 当前加载的所有类的数组。
getAllMembers(TypeElement) - 接口 javax.lang.model.util.Elements 中的方法
返回类型元素的所有成员，不管是继承的还是直接声明的。
getAllMimeHeaders() - 类 javax.xml.soap.AttachmentPart 中的方法
以 MimeHeader 对象上的迭代器形式，检索此 AttachmentPart 对象的所有头。
getAllMimeHeaders() - 类 javax.xml.soap.SOAPPart 中的方法
以可在 MimeHeader 对象上进行迭代的迭代器形式，检索此 SOAPPart 对象的所有头。
getAllNotificationIDs() - 类 javax.management.timer.Timer 中的方法
获得所有在通知列表中注册的计时器通知标识符。
getAllNotificationIDs() - 接口 javax.management.timer.TimerMBean 中的方法
获得所有在通知的列表中注册的计时器通知标识符。
getAllowsChildren() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
如果接收方允许有子级，则返回 true。
getAllowsChildren() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
如果接收者允许接收子元素，则返回 true。
getAllowsChildren() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
如果接收者允许接收子元素，则返回 true。
getAllowsChildren() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果允许此节点拥有子节点，则返回 true。
getAllowsChildren() - 接口 javax.swing.tree.TreeNode 中的方法
如果接收者允许有子节点，则返回 true。
getAllowsInvalid() - 类 javax.swing.text.DefaultFormatter 中的方法
返回编辑的值是否在一段时间内允许为无效。
getAllowUserInteraction() - 类 java.net.URLConnection 中的方法
返回此对象的 allowUserInteraction 字段的值。
getAllRelationIds() - 类 javax.management.relation.RelationService 中的方法
返回由 Relation Service 处理的所有关系的所有关系 id。
getAllRelationIds() - 接口 javax.management.relation.RelationServiceMBean 中的方法
返回由 Relation Service 处理的所有关系的所有关系 id。
getAllRelationTypeNames() - 类 javax.management.relation.RelationService 中的方法
检索所有已知关系类型的名称。
getAllRelationTypeNames() - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索所有已知关系类型的名称。
getAllRoles() - 接口 javax.management.relation.Relation 中的方法
返回该关系中存在的所有角色。
getAllRoles(String) - 类 javax.management.relation.RelationService 中的方法
返回关系中存在的所有角色。
getAllRoles(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
返回关系中存在的所有角色。
getAllRoles() - 类 javax.management.relation.RelationSupport 中的方法
返回关系中存在的所有角色。
getAllStackTraces() - 类 java.lang.Thread 中的静态方法
返回所有活动线程的堆栈跟踪的一个映射。
getAllTags() - 类 javax.swing.text.html.HTML 中的静态方法
返回默认 HTML reader 所识别的实际 HTML 标记集。
getAllThreadIds() - 接口 java.lang.management.ThreadMXBean 中的方法
返回活动线程 ID。
getAlpha() - 类 java.awt.AlphaComposite 中的方法
返回此 AlphaComposite 的 alpha 值。
getAlpha() - 类 java.awt.Color 中的方法
返回位于范围 0-255 中的 alpha 分量。
getAlpha(int) - 类 java.awt.image.ColorModel 中的方法
返回指定像素（缩放范围从 0 到 255）的 alpha 分量。
getAlpha(Object) - 类 java.awt.image.ColorModel 中的方法
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。
getAlpha(int) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素（缩放范围从 0 到 255）的 alpha 分量。
getAlpha(Object) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。
getAlpha(int) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素（缩放范围从 0 到 255）的 alpha 分量。
getAlpha(Object) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。
getAlpha(int) - 类 java.awt.image.IndexColorModel 中的方法
返回指定像素的 alpha 分量，该值为 0 到 255。
getAlphaMask() - 类 java.awt.image.DirectColorModel 中的方法
返回指示 int 像素表示形式中哪些位包含 alpha 分量的掩码。
getAlphaRaster() - 类 java.awt.image.BufferedImage 中的方法
返回一个 WritableRaster，它使用支持单独空间 alpha 通道的 ColorModel 对象（比如 ComponentColorModel 和 DirectColorModel）表示 BufferedImage 对象的 alpha 通道。
getAlphaRaster(WritableRaster) - 类 java.awt.image.ColorModel 中的方法
返回表示图像（从输入 Raster 中提取）的 alpha 通道的 Raster，除非此 ColorModel 的像素值将颜色和 alpha 信息表示为独立的空间 band（如 ComponentColorModel 和 DirectColorModel）。
getAlphaRaster(WritableRaster) - 类 java.awt.image.ComponentColorModel 中的方法
返回表示某图像（从输入 Raster 提取）的 alpha 通道的 Raster。
getAlphaRaster(WritableRaster) - 类 java.awt.image.PackedColorModel 中的方法
返回从输入 WritableRaster 提取，并且表示图像 alpha 通道的 WritableRaster。
getAlphas(byte[]) - 类 java.awt.image.IndexColorModel 中的方法
将 alpha 透明度分量数组复制到指定的数组中。
getAltKey() - 接口 org.w3c.dom.events.MouseEvent 中的方法
用于指示在触发事件期间是否按下 'alt' 键。
getAltName() - 异常 javax.naming.CannotProceedException 中的方法
检索此异常的 altName 字段。
getAltNameCtx() - 异常 javax.naming.CannotProceedException 中的方法
检索此异常的 altNameCtx 字段。
getAltText() - 类 javax.swing.text.html.ImageView 中的方法
如果不能加载图像，则返回要显示的文本。
getAmountFull(Insets, int, int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
此方法确定进度条的量，该量应该基于从模型搜集的完成百分比填充。
getAmPmStrings() - 类 java.text.DateFormatSymbols 中的方法
获取 ampm 字符串。
getAncestor() - 类 javax.swing.event.AncestorEvent 中的方法
返回实际发生事件的祖先组件。
getAncestorListeners() - 类 javax.swing.JComponent 中的方法
返回在此组件上注册的所有祖先侦听器所组成的数组。
getAncestorNamed(String, Component) - 类 javax.swing.SwingUtilities 中的静态方法
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的 name 第一个对象。
getAncestorOfClass(Class<?>, Component) - 类 javax.swing.SwingUtilities 中的静态方法
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的类 c 的第一个对象。
getAncestorParent() - 类 javax.swing.event.AncestorEvent 中的方法
返回实际发生事件的祖先组件的父组件。
getAnchorRect() - 类 java.awt.TexturePaint 中的方法
返回定位纹理图像并设置其大小的固定矩形的副本。
getAnchorSelectionIndex() - 类 javax.swing.DefaultListSelectionModel 中的方法
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第一个索引参数。
getAnchorSelectionIndex() - 类 javax.swing.JList 中的方法
返回定位选择索引。
getAnchorSelectionIndex() - 接口 javax.swing.ListSelectionModel 中的方法
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第一个索引参数。
getAnchorSelectionPath() - 类 javax.swing.JTree 中的方法
返回标识为定位的路径。
getAndAdd(int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将给定值与当前值相加。
getAndAdd(int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将给定值与索引 i 的元素相加。
getAndAdd(T, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将给定值添加到此更新器管理的给定对象的当前值。
getAndAdd(long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将给定值添加到当前值。
getAndAdd(int, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将给定值与索引 i 的元素相加。
getAndAdd(T, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将给定值添加到此更新器管理的给定对象的字段的当前值。
getAndDecrement() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将当前值减 1。
getAndDecrement(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将索引 i 的元素减 1。
getAndDecrement(T) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象的当前值减 1。
getAndDecrement() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将当前值减 1。
getAndDecrement(int) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将索引 i 的元素减 1。
getAndDecrement(T) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象字段当前值减 1。
getAndIncrement() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将当前值加 1。
getAndIncrement(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将索引 i 的元素加 1。
getAndIncrement(T) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象的当前值加 1。
getAndIncrement() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将当前值加 1。
getAndIncrement(int) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将索引 i 的元素加 1。
getAndIncrement(T) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象字段的当前值加 1。
getAndSet(boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
以原子方式设置为给定值，并返回以前的值。
getAndSet(int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式设置为给定值，并返回旧值。
getAndSet(int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
将位置 i 的元素以原子方式设置为给定值，并返回旧值。
getAndSet(T, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象的字段设置为给定值，并返回旧值。
getAndSet(long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式设置为给定值，并返回旧值。
getAndSet(int, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将位置 i 的元素设置为给定值，并返回旧值。
getAndSet(T, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
将此更新器管理的给定对象的字段以原子方式设置为给定值，并返回旧值。
getAndSet(V) - 类 java.util.concurrent.atomic.AtomicReference 中的方法
以原子方式设置为给定值，并返回旧值。
getAndSet(int, E) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
以原子方式将位置 i 的元素设置为给定值，并返回旧值。
getAndSet(T, V) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
将此更新器管理的给定对象的字段自动设置为给定值，并返回旧值。
getAngleExtent() - 类 java.awt.geom.Arc2D.Double 中的方法
返回弧的角跨越。
getAngleExtent() - 类 java.awt.geom.Arc2D.Float 中的方法
返回弧的角跨越。
getAngleExtent() - 类 java.awt.geom.Arc2D 中的方法
返回弧的角跨越。
getAngleStart() - 类 java.awt.geom.Arc2D.Double 中的方法
返回弧的起始角度。
getAngleStart() - 类 java.awt.geom.Arc2D.Float 中的方法
返回弧的起始角度。
getAngleStart() - 类 java.awt.geom.Arc2D 中的方法
返回弧的起始角度。
getAnimationIndex() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
获取当前动画窗体的索引。
getAnnotation(Class<A>) - 类 java.lang.Class 中的方法

getAnnotation(Class<A>) - 类 java.lang.Package 中的方法

getAnnotation(Class<T>) - 类 java.lang.reflect.AccessibleObject 中的方法

getAnnotation(Class<T>) - 接口 java.lang.reflect.AnnotatedElement 中的方法
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
getAnnotation(Class<T>) - 类 java.lang.reflect.Constructor 中的方法

getAnnotation(Class<T>) - 类 java.lang.reflect.Field 中的方法

getAnnotation(Class<T>) - 类 java.lang.reflect.Method 中的方法

getAnnotation(Class<A>) - 接口 javax.lang.model.element.Element 中的方法
返回此元素针对指定类型的注释（如果存在这样的注释），否则返回 null。
getAnnotationMirrors() - 接口 javax.lang.model.element.Element 中的方法
返回直接存在于此元素上的注释。
getAnnotations() - 类 java.lang.Class 中的方法

getAnnotations() - 类 java.lang.Package 中的方法

getAnnotations() - 类 java.lang.reflect.AccessibleObject 中的方法

getAnnotations() - 接口 java.lang.reflect.AnnotatedElement 中的方法
返回此元素上存在的所有注释。
getAnnotationType() - 接口 javax.lang.model.element.AnnotationMirror 中的方法
返回此注释的类型。
getAnonymityState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定是否会向上下文接受端对上下文初始端进行匿名验证。
getAnonymousLogger() - 类 java.util.logging.Logger 中的静态方法
创建一个匿名的 Logger。
getAnonymousLogger(String) - 类 java.util.logging.Logger 中的静态方法
创建一个匿名的 Logger。
getAntiAliasingHint() - 类 java.awt.font.FontRenderContext 中的方法
返回此 FontRenderContext 中使用的文本 anti-aliasing 呈现模式提示。
getAppConfigurationEntry(String) - 类 javax.security.auth.login.Configuration 中的方法
获取此 Configuration 中指定 name 的 AppConfigurationEntry。
getApplet(String) - 接口 java.applet.AppletContext 中的方法
通过给定名称找到并返回此 applet 上下文表示的文档中的 applet。
getAppletContext() - 类 java.applet.Applet 中的方法
确定此 applet 的上下文，上下文允许 applet 查询和影响它所运行的环境。
getAppletContext() - 接口 java.applet.AppletStub 中的方法
返回 applet 的上下文。
getAppletInfo() - 类 java.applet.Applet 中的方法
返回有关此 applet 的信息。
getApplets() - 接口 java.applet.AppletContext 中的方法
找到此 applet 上下文表示的文档中的所有 applet。
getApplicationBufferSize() - 接口 javax.net.ssl.SSLSession 中的方法
获取使用此会话时期望的最大应用程序数据的当前大小。
getApplicationData() - 类 org.ietf.jgss.ChannelBinding 中的方法
获得此通道绑定的应用程序指定的数据。
getApproveButton(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getApproveButton(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getApproveButtonMnemonic() - 类 javax.swing.JFileChooser 中的方法
返回确认按钮的助记符。
getApproveButtonMnemonic(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getApproveButtonText() - 类 javax.swing.JFileChooser 中的方法
返回 ApproveButton 中的 FileChooserUI 内使用的文本。
getApproveButtonText(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getApproveButtonText(JFileChooser) - 类 javax.swing.plaf.FileChooserUI 中的方法

getApproveButtonText(JFileChooser) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getApproveButtonText 方法。
getApproveButtonToolTipText() - 类 javax.swing.JFileChooser 中的方法
返回 ApproveButton 中使用的工具提示文本。
getApproveButtonToolTipText(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getApproveSelectionAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getArch() - 接口 java.lang.management.OperatingSystemMXBean 中的方法
返回操作系统的架构。
getArcHeight() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
获取圆角弧的高度。
getArcHeight() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
获取圆角弧的高度。
getArcHeight() - 类 java.awt.geom.RoundRectangle2D 中的方法
获取圆角弧的高度。
getArcType() - 类 java.awt.geom.Arc2D 中的方法
返回弧的弧闭合类型：Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE。
getArcWidth() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
获取圆角弧的宽度。
getArcWidth() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
获取圆角弧的宽度。
getArcWidth() - 类 java.awt.geom.RoundRectangle2D 中的方法
获取圆角弧的宽度。
getAreaOfInterest() - 类 java.awt.image.renderable.RenderContext 中的方法
获取当前包含在 RenderContext 中的感兴趣区域。
getArgument() - 异常 javax.lang.model.element.UnknownAnnotationValueException 中的方法
返回附加参数。
getArgument() - 异常 javax.lang.model.element.UnknownElementException 中的方法
返回附加参数。
getArgument() - 异常 javax.lang.model.type.UnknownTypeException 中的方法
返回附加参数。
getArgumentClass() - 异常 java.util.IllegalFormatConversionException 中的方法
返回不匹配参数的类。
getArguments() - 类 java.beans.Statement 中的方法
返回此语句的参数。
getArray() - 接口 java.sql.Array 中的方法
以 Java 编程语言数组的形式获取由此 Array 对象指定的 SQL ARRAY 值的内容。
getArray(Map<String, Class<?>>) - 接口 java.sql.Array 中的方法
获取由此 Array 对象指定的 SQL ARRAY 值的内容。
getArray(long, int) - 接口 java.sql.Array 中的方法
获取由此 Array 对象指定的 SQL ARRAY 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
getArray(long, int, Map<String, Class<?>>) - 接口 java.sql.Array 中的方法
获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
getArray(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Array 对象的形式获取指定的 JDBC ARRAY 参数的值。
getArray(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.ARRAY 对象的形式获取 JDBC ARRAY 参数的值。
getArray(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getArray(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getArray() - 类 javax.sql.rowset.serial.SerialArray 中的方法
返回一个新数组，它是此 SerialArray 对象的副本。
getArray(Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialArray 中的方法
返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。
getArray(long, int) - 类 javax.sql.rowset.serial.SerialArray 中的方法
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
getArray(long, int, Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialArray 中的方法
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
getArray() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得字符数组。
getArrayLength() - 类 javax.swing.text.GapContent 中的方法
获取分配的数组的长度。
getArrayType(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回具有指定组件类型的数组类型。
getArrayType(OpenType<E>) - 类 javax.management.openmbean.ArrayType 中的静态方法
以类型安全的方式创建一个 ArrayType 实例。
getAscent() - 类 java.awt.font.GraphicAttribute 中的方法
返回此 GraphicAttribute 的 ascent。
getAscent() - 类 java.awt.font.ImageGraphicAttribute 中的方法
返回此 ImageGraphicAttribute 的 ascent。
getAscent() - 类 java.awt.font.LineMetrics 中的方法
返回该文本的 ascent。
getAscent() - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回此 ShapeGraphicAttribute 的 ascent。
getAscent() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的 ascent。
getAscent() - 类 java.awt.FontMetrics 中的方法
确定此 FontMetrics 对象所描述的 Font 的 font ascent。
getAscent(GlyphView) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法

getAsciiStream() - 接口 java.sql.Clob 中的方法
以 ascii 流形式获取此 Clob 对象指定的 CLOB 值。
getAsciiStream(int) - 接口 java.sql.ResultSet 中的方法
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
getAsciiStream(String) - 接口 java.sql.ResultSet 中的方法
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
getAsciiStream() - 类 javax.sql.rowset.serial.SerialClob 中的方法
以 ascii 流的形式获取此 SerialClob 对象指定的 CLOB 值。
getAspectRatio(int) - 类 javax.imageio.ImageReader 中的方法
以 float 的形式返回给定图像的高宽比（即宽度除以高度）。
getAssociatedStylesheet(Source, String, String, String) - 类 javax.xml.transform.TransformerFactory 中的方法
通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。
getAsText() - 接口 java.beans.PropertyEditor 中的方法
以文本形式获得属性值。
getAsText() - 类 java.beans.PropertyEditorSupport 中的方法
获得人类可编辑的适当字符串表示形式的属性值。
getAsTree(String) - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回 XML DOM Node 对象，该对象表示此对象所包含的元数据树的根（根据给定元数据格式定义的约定）。
getAsync() - 接口 org.w3c.dom.ls.LSParser 中的方法
如果 LSParser 是异步的，为 true，如果它是同步的，则为 false。
getAsynchronousLoadPriority() - 类 javax.swing.text.AbstractDocument 中的方法
获得异步加载优先级。
getAtIndex(int, int) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 接口 javax.accessibility.AccessibleText 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 处的 String。
getAtIndex(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定索引处的 String。
getAttachment(SOAPElement) - 类 javax.xml.soap.SOAPMessage 中的方法
返回与此 SOAPElement 引用的附件关联的 AttachmentPart 对象，如果不存在此类附件，则返回 null。
getAttachmentAsByteArray(String) - 类 javax.xml.bind.attachment.AttachmentUnmarshaller 中的方法
以 byte[] 形式检索由内容 id（即 cid）标识的附件。
getAttachmentAsDataHandler(String) - 类 javax.xml.bind.attachment.AttachmentUnmarshaller 中的方法
通过内容 id（即 cid）查找 MIME 内容，并作为 DataHandler 返回。
getAttachmentMarshaller() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法

getAttachmentMarshaller() - 接口 javax.xml.bind.Marshaller 中的方法

getAttachments() - 类 javax.xml.soap.SOAPMessage 中的方法
检索所有作为此 SOAPMessage 对象一部分的 AttachmentPart 对象。
getAttachments(MimeHeaders) - 类 javax.xml.soap.SOAPMessage 中的方法
检索所有头条目匹配指定头的 AttachmentPart 对象。
getAttachmentUnmarshaller() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法

getAttachmentUnmarshaller() - 接口 javax.xml.bind.Unmarshaller 中的方法

getAttrChange() - 接口 org.w3c.dom.events.MutationEvent 中的方法
attrChange 指示触发 DOMAttrModified 事件的更改类型。
getAttribute(String) - 类 java.security.Provider.Service 中的方法
返回指定属性的值，如果没有为此 Service 设置此属性，则返回 null。
getAttribute(AttributedCharacterIterator.Attribute) - 接口 java.text.AttributedCharacterIterator 中的方法
返回当前字符的命名属性的值。
getAttribute(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getAttribute(ObjectName) - 类 javax.management.AttributeValueExp 中的方法
返回指定的 MBean 中给定属性的值。
getAttribute(String) - 接口 javax.management.DynamicMBean 中的方法
获得 Dynamic MBean 的特定属性的值。
getAttribute(ObjectName, String) - 接口 javax.management.MBeanServer 中的方法

getAttribute(ObjectName, String) - 接口 javax.management.MBeanServerConnection 中的方法
获得指定 MBean 的特定属性值。
getAttribute(String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回通过名称请求的 ModelMBeanAttributeInfo。
getAttribute(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getAttribute(String) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
返回为此 ModelMBean 定义的指定属性的值。
getAttribute(ObjectName, String, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
getAttribute(ObjectName, String, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getAttribute(ObjectName, String, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getAttribute(String) - 类 javax.management.StandardMBean 中的方法

getAttribute() - 类 javax.naming.directory.ModificationItem 中的方法
检索与此修改项关联的属性。
getAttribute(Class<T>) - 接口 javax.print.PrintService 中的方法
获取单个指定服务属性的值。
getAttribute(String, int) - 接口 javax.script.ScriptContext 中的方法
获取给定范围中某一属性的值。
getAttribute(String) - 接口 javax.script.ScriptContext 中的方法
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。
getAttribute(String) - 类 javax.script.SimpleScriptContext 中的方法
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。
getAttribute(String, int) - 类 javax.script.SimpleScriptContext 中的方法
获取给定范围中某一属性的值。
getAttribute(Object) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取属性值。
getAttribute(Object) - 接口 javax.swing.text.AttributeSet 中的方法
获取给定属性的值。
getAttribute(String) - 类 javax.swing.text.html.CSS 中的静态方法
将字符串转换为 CSS.Attribute 对象。
getAttribute(String) - 类 javax.swing.text.html.parser.Element 中的方法
按名称获取一个元素。
getAttribute(Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
获取属性的值。
getAttribute(Object) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
获取属性的值。
getAttribute(Object) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
获取属性的值。
getAttribute(String) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
允许用户在底层实现上检索特定属性。
getAttribute(String) - 类 javax.xml.transform.TransformerFactory 中的方法
允许用户在底层实现上检索指定属性。
getAttribute(String) - 接口 org.w3c.dom.Element 中的方法
通过名称获得属性值。
getAttributeByName(QName) - 接口 javax.xml.stream.events.StartElement 中的方法
返回此名称引用的属性
getAttributeByValue(String) - 类 javax.swing.text.html.parser.Element 中的方法
按值获取一个属性。
getAttributeContext() - 类 javax.swing.text.AbstractDocument 中的方法
获取管理属性的上下文。
getAttributeCount() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取所定义的属性数量。
getAttributeCount() - 接口 javax.swing.text.AttributeSet 中的方法
返回此集合中本地定义的属性个数。
getAttributeCount() - 类 javax.swing.text.SimpleAttributeSet 中的方法
获取属性数目的总数。
getAttributeCount() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
返回定义的属性数。
getAttributeCount() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
返回定义的属性数。
getAttributeCount() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeCount() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回此 START_ELEMENT 中的属性计数，此方法仅对 START_ELEMENT 或 ATTRIBUTE 有效。
getAttributeDataType(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回以 DATATYPE_ 开头的常量之一，指示指定元素中给定属性的值的格式和解释。
getAttributeDataType(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeDefaultValue(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
如果指定属性不显式存在于指定元素中，则以 String 的形式返回其默认值；如果不存在可用的默认值，则返回 null。
getAttributeDefaultValue(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeDefinition() - 接口 javax.naming.directory.Attribute 中的方法
检索属性的模式定义。
getAttributeDefinition() - 类 javax.naming.directory.BasicAttribute 中的方法
检索此属性的模式定义。
getAttributeDescription(String, String, Locale) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回包含指定属性的描述的 String，或者 null。
getAttributeDescription(String, String, Locale) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
返回包含指定属性的描述的 String，或者 null。
getAttributeEnumerations(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回一个 String 数组，其包含指定元素中给定属性的合法枚举值。
getAttributeEnumerations(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeID() - 类 javax.naming.ldap.SortKey 中的方法
检索排序键的属性 ID。
getAttributeID() - 类 javax.naming.ldap.SortResponseControl 中的方法
检索导致排序失败的属性的 ID。
getAttributeKey(String) - 类 javax.swing.text.html.HTML 中的静态方法
获取已知属性名称的属性常量（即集合 {FACE, COMMENT, SIZE, COLOR, CLEAR, BACKGROUND, BGCOLOR, TEXT, LINK, VLINK, ALINK, WIDTH, HEIGHT, ALIGN, NAME, HREF, REL, REV, TITLE, TARGET, SHAPE, COORDS, ISMAP, NOHREF, ALT, ID, SRC, HSPACE, VSPACE, USEMAP, LOWSRC, CODEBASE, CODE, ARCHIVE, VALUE, VALUETYPE, TYPE, CLASS, STYLE, LANG, DIR, DECLARE, CLASSID, DATA, CODETYPE, STANDBY, BORDER, SHAPES, NOSHADE, COMPACT, START, ACTION, METHOD, ENCTYPE, CHECKED, MAXLENGTH, MULTIPLE, SELECTED, ROWS, COLS, DUMMY, CELLSPACING, CELLPADDING, VALIGN, HALIGN, NOWRAP, ROWSPAN, COLSPAN, PROMPT, HTTPEQUIV, CONTENT, LANGUAGE, VERSION, N, FRAMEBORDER, MARGINWIDTH, MARGINHEIGHT, SCROLLING, NORESIZE, MEDIA, ENDTAG} 中的某个属性）。
getAttributeListMaxLength(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回可用于定义此属性的最大列表项数。
getAttributeListMaxLength(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeListMinLength(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回可用于定义此属性的最小列表项数。
getAttributeListMinLength(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeLocalName(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeLocalName(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回所提供索引处的属性的 localName
getAttributeMaxValue(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回属性的最大合法值。
getAttributeMaxValue(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeMinValue(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回属性的最小合法值。
getAttributeMinValue(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeName() - 类 javax.management.AttributeChangeNotification 中的方法
获得已更改属性的名称。
getAttributeName() - 类 javax.management.AttributeValueExp 中的方法
返回该属性名称的字符串表示形式。
getAttributeName(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeName(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回所提供索引处的属性的 qname
getAttributeNames(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回一个 String 数组，该数组列出了与指定元素关联的属性的名称。
getAttributeNames(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeNames() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取所有属性的名称。
getAttributeNames() - 接口 javax.swing.text.AttributeSet 中的方法
返回集合中本地定义的属性名称的枚举。
getAttributeNames() - 类 javax.swing.text.SimpleAttributeSet 中的方法
获取集合中的属性名称。
getAttributeNames() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
获取所有属性的名称。
getAttributeNames() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
获取所有属性的名称。
getAttributeNamespace(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeNamespace(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回所提供索引处的属性的名称空间
getAttributeNode(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getAttributeNode(String) - 接口 org.w3c.dom.Element 中的方法
通过名称获得属性节点。
getAttributeNodeNS(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 getAttributeNode(localName)。
getAttributeNodeNS(String, String) - 接口 org.w3c.dom.Element 中的方法
通过本地名称和名称空间 URI 获得 Attr 节点。
getAttributeNS(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 getAttribute(localName)。
getAttributeNS(String, String) - 接口 org.w3c.dom.Element 中的方法
通过本地名称和名称空间 URI 获得属性值。
getAttributePrefix(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributePrefix(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回所提供索引处的属性的前缀
getAttributes() - 类 java.awt.Font 中的方法
返回此 Font 中可用的字体属性的映射。
getAttributes() - 类 java.net.JarURLConnection 中的方法
如果此连接的 URL 指向 JAR 文件条目，则返回其 Attribute 对象；否则返回 null。
getAttributes(String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取可在给定模式和类别中使用的用户定义类型 (UDT) 的给定类型的给定属性的描述。
getAttributes() - 接口 java.sql.Struct 中的方法
生成此 Struct 对象所表示的 SQL 结构类型属性的有序值。
getAttributes(Map<String, Class<?>>) - 接口 java.sql.Struct 中的方法
生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。
getAttributes() - 接口 java.text.AttributedCharacterIterator 中的方法
返回具有定义于当前字符上的多个属性的映射。
getAttributes() - 类 java.util.jar.JarEntry 中的方法
返回此条目的 Manifest Attributes；如果没有，则返回 null。
getAttributes(String) - 类 java.util.jar.Manifest 中的方法
返回指定条目名称的 Attributes。
getAttributes() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getAttributes(String[]) - 接口 javax.management.DynamicMBean 中的方法
获得 Dynamic MBean 多个属性的值。
getAttributes() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记的属性。
getAttributes() - 类 javax.management.MBeanInfo 中的方法
返回为了便于管理而公开的属性的列表。
getAttributes(ObjectName, String[]) - 接口 javax.management.MBeanServer 中的方法

getAttributes(ObjectName, String[]) - 接口 javax.management.MBeanServerConnection 中的方法
获得指定 MBean 的多个属性值。
getAttributes() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回为管理公开的属性列表。
getAttributes(String[]) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
返回 ModelMBean 中几个属性的值。
getAttributes() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回 OpenMBeanAttributeInfo 实例的数组，该实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个属性。
getAttributes() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
此连接器服务器的属性。
getAttributes(ObjectName, String[], Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
getAttributes(ObjectName, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getAttributes(ObjectName, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getAttributes() - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法

getAttributes(String[]) - 类 javax.management.StandardMBean 中的方法

getAttributes(Name) - 接口 javax.naming.directory.DirContext 中的方法
检索与命名对象关联的所有属性。
getAttributes(String) - 接口 javax.naming.directory.DirContext 中的方法
检索所有与命名对象关联的属性。
getAttributes(Name, String[]) - 接口 javax.naming.directory.DirContext 中的方法
检索与命名对象关联的选定属性。
getAttributes(String, String[]) - 接口 javax.naming.directory.DirContext 中的方法
检索与命名对象关联的选定属性。
getAttributes(String) - 类 javax.naming.directory.InitialDirContext 中的方法

getAttributes(String, String[]) - 类 javax.naming.directory.InitialDirContext 中的方法

getAttributes(Name) - 类 javax.naming.directory.InitialDirContext 中的方法

getAttributes(Name, String[]) - 类 javax.naming.directory.InitialDirContext 中的方法

getAttributes() - 类 javax.naming.directory.SearchResult 中的方法
检索此搜索结果中的属性。
getAttributes() - 类 javax.naming.spi.DirStateFactory.Result 中的方法
检索要绑定的属性。
getAttributes() - 接口 javax.print.Doc 中的方法
获取此 doc 对象的打印属性集。
getAttributes() - 接口 javax.print.DocPrintJob 中的方法
获取此 PrintJob 的打印属性集。
getAttributes() - 类 javax.print.event.PrintJobAttributeEvent 中的方法
确定已经更改的打印属性及其新值。
getAttributes() - 类 javax.print.event.PrintServiceAttributeEvent 中的方法
确定已经更改的打印服务属性及其新值。
getAttributes() - 接口 javax.print.PrintService 中的方法
获得此 PrintService 的打印机描述属性集，这些属性给出了此 PrintService 的状态。
getAttributes() - 类 javax.print.SimpleDoc 中的方法
获得此 doc 对象的打印属性集。
getAttributes() - 类 javax.sql.rowset.serial.SerialStruct 中的方法
获取 Object 值的数组，该数组包含此 SerialStruct 对象所表示的 SQL 结构类型的属性。
getAttributes(Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialStruct 中的方法
获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。
getAttributes() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素的属性。
getAttributes() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得元素属性。
getAttributes() - 接口 javax.swing.text.Element 中的方法
获取此元素包含的属性集合。
getAttributes() - 类 javax.swing.text.html.BlockView 中的方法
获取呈现时要使用的属性。
getAttributes() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
返回此标记的属性。
getAttributes() - 类 javax.swing.text.html.ImageView 中的方法
获取呈现时要使用的属性。
getAttributes() - 类 javax.swing.text.html.InlineView 中的方法
获取呈现时要使用的属性。
getAttributes() - 类 javax.swing.text.html.Option 中的方法
获取与此选项相关的属性。
getAttributes() - 类 javax.swing.text.html.ParagraphView 中的方法
获取呈现时所使用的属性。
getAttributes() - 类 javax.swing.text.html.parser.Element 中的方法
获取属性。
getAttributes() - 类 javax.swing.text.html.parser.Parser 中的方法

getAttributes() - 类 javax.swing.text.View 中的方法
获取呈现时要使用的属性。
getAttributes() - 接口 javax.xml.stream.events.StartElement 中的方法
返回在此 START_ELEMENT 上声明的已声明非名称空间属性的 Iterator；如果没有这样的属性，则返回空迭代器。
getAttributes() - 接口 org.w3c.dom.Node 中的方法
包含此节点的属性的 NamedNodeMap（如果它是 Element）；否则为 null。
getAttributesScope(String) - 接口 javax.script.ScriptContext 中的方法
获取定义了某个属性的最小范围。
getAttributesScope(String) - 类 javax.script.SimpleScriptContext 中的方法
获取用来定义属性的最小范围。
getAttributeSyntaxDefinition() - 接口 javax.naming.directory.Attribute 中的方法
检索与属性关联的语法定义。
getAttributeSyntaxDefinition() - 类 javax.naming.directory.BasicAttribute 中的方法
检索与此属性关联的语法定义。
getAttributeType() - 类 javax.management.AttributeChangeNotification 中的方法
获得已更改属性的类型。
getAttributeType(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeType(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回所提供索引处的属性的 XML 类型
getAttributeTypeInfo(int) - 类 javax.xml.validation.TypeInfoProvider 中的方法
返回指定的当前元素属性的不可变的 TypeInfo 对象。
getAttributeValue(Name) - 接口 javax.xml.soap.SOAPElement 中的方法
返回带有指定名称的属性值。
getAttributeValue(QName) - 接口 javax.xml.soap.SOAPElement 中的方法
返回带有指定 qname 的属性值。
getAttributeValue(String, String) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeValue(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeValue(String, String) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回带有名称空间和 localName 的属性的规范化属性值。
getAttributeValue(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回 index 处的属性值
getAttributeValueType(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回以 VALUE_ 开头的常量之一，指示指定元素中给定属性的值是任意值、被限制在指定范围中的值、被限制为一组枚举值之一，还是一个任意值的以空白分隔的列表。
getAttributeValueType(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttrName() - 接口 org.w3c.dom.events.MutationEvent 中的方法
attrName 指示 DOMAttrModified 事件中已更改的 Attr 节点的名称。
getAudioActionMap() - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
返回包含此外观音频动作的 ActionMap。
getAudioClip(URL) - 类 java.applet.Applet 中的方法
返回 URL 参数指定的 AudioClip 对象。
getAudioClip(URL, String) - 类 java.applet.Applet 中的方法
返回 URL 和 name 参数指定的 AudioClip 对象。
getAudioClip(URL) - 接口 java.applet.AppletContext 中的方法
创建音频剪辑。
getAudioFileFormat(InputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得提供的音频输入流的音频文件格式。
getAudioFileFormat(URL) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得指定 URL 的音频文件格式。
getAudioFileFormat(File) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得指定 File 的音频文件格式。
getAudioFileFormat(InputStream) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
获得所提供输入流的音频文件格式。
getAudioFileFormat(URL) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
获得所提供 URL 的音频文件格式。
getAudioFileFormat(File) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
获得所提供 File 的音频文件格式。
getAudioFileTypes() - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得由系统为其提供文件写入支持的文件类型。
getAudioFileTypes(AudioInputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得系统可从指定音频输入流写入的文件类型。
getAudioFileTypes() - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
获得此音频文件 writer 为其提供文件写入支持的文件类型。
getAudioFileTypes(AudioInputStream) - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
获得此音频文件 writer 可以从指定的音频输入流写入的文件类型。
getAudioInputStream(AudioFormat.Encoding, AudioInputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
通过转换提供的音频输入流，获得所指示编码的音频输入流。
getAudioInputStream(AudioFormat, AudioInputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
通过转换提供的音频输入流，获得所指示格式的音频输入流。
getAudioInputStream(InputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
从提供的输入流获得音频输入流。
getAudioInputStream(URL) - 类 javax.sound.sampled.AudioSystem 中的静态方法
从提供的 URL 获得音频输入流。
getAudioInputStream(File) - 类 javax.sound.sampled.AudioSystem 中的静态方法
从提供的 File 获得音频输入流。
getAudioInputStream(InputStream) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
从所提供的输入流中获得音频输入流。
getAudioInputStream(URL) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
从所提供的 URL 获得音频输入流。
getAudioInputStream(File) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
从所提供的 File 获得音频输入流。
getAudioInputStream(AudioFormat.Encoding, AudioInputStream) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
从给定的音频输入流获得具有指定编码的音频输入流。
getAudioInputStream(AudioFormat, AudioInputStream) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
从给定的音频输入流获得具有指定格式的音频输入流。
getAuthenticationID() - 类 javax.security.sasl.AuthorizeCallback 中的方法
返回要检查的验证 id。
getAuthority() - 类 java.net.URI 中的方法
返回此 URI 的已解码的授权组成部分。
getAuthority() - 类 java.net.URL 中的方法
获取此 URL 的授权部分。
getAuthorityKeyIdentifier() - 类 java.security.cert.X509CertSelector 中的方法
返回 authorityKeyIdentifier 标准。
getAuthorizationID() - 类 javax.security.sasl.AuthorizeCallback 中的方法
返回要检查的授权 id。
getAuthorizationID() - 接口 javax.security.sasl.SaslServer 中的方法
报告此会话客户端的有效授权 ID。
getAuthorizedID() - 类 javax.security.sasl.AuthorizeCallback 中的方法
返回已授权用户的 id。
getAuthTime() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回客户端进行验证的时间。
getAutoCommit() - 接口 java.sql.Connection 中的方法
获取此 Connection 对象的当前自动提交模式。
getAutoCommit() - 接口 javax.sql.rowset.JdbcRowSet 中的方法
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
getAutoCreateColumnsFromModel() - 类 javax.swing.JTable 中的方法
确定表是否要根据模型创建默认的列。
getAutoCreateContainerGaps() - 类 javax.swing.GroupLayout 中的方法
如果自动创建容器与触到容器边框的组件之间的间隙，则返回 true。
getAutoCreateGaps() - 类 javax.swing.GroupLayout 中的方法
如果自动创建组件之间的间隙，则返回 true。
getAutoCreateRowSorter() - 类 javax.swing.JTable 中的方法
如果每当模型更改时，都应该创建一个新 RowSorter 并作为该表的排序器安装，则返回 true；否则，返回 false。
getAutoDelay() - 类 java.awt.Robot 中的方法
返回此 Robot 在生成一个事件后睡眠的毫秒数。
getAutoResizeMode() - 类 javax.swing.JTable 中的方法
返回表的自动调整模式。
getAutoscrollInsets() - 接口 java.awt.dnd.Autoscroll 中的方法
此方法返回 Insets，用于描述相对于实现 Component 几何形状的自动滚动区域或边界。
getAutoscrolls() - 类 javax.swing.JComponent 中的方法
获取 autoscrolls 属性。
getAuxiliaryLookAndFeels() - 类 javax.swing.UIManager 中的静态方法
返回辅助外观的列表（可以为 null）。
getAvailableAcceleratedMemory() - 类 java.awt.GraphicsDevice 中的方法
此方法返回此设备上加速内存中可用的字节数。
getAvailableAttributes() - 类 java.awt.Font 中的方法
返回由此 Font 支持的所有属性的键。
getAvailableDataFlavors() - 类 java.awt.datatransfer.Clipboard 中的方法
返回 DataFlavor 的数组，其中提供了此剪贴板的当前内容。
getAvailableFontFamilyNames() - 类 java.awt.GraphicsEnvironment 中的方法
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，它针对默认语言环境进行了本地化，由 Locale.getDefault() 返回。
getAvailableFontFamilyNames(Locale) - 类 java.awt.GraphicsEnvironment 中的方法
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，已针对默认语言环境对它进行了本地化。
getAvailableIDs(int) - 类 java.util.TimeZone 中的静态方法
根据给定的时区偏移量（以毫秒为单位）获取可用的 ID。
getAvailableIDs() - 类 java.util.TimeZone 中的静态方法
获取受支持的所有可用 ID。
getAvailableInstruments() - 接口 javax.sound.midi.Synthesizer 中的方法
获得该合成器随附的乐器列表。
getAvailableLocales() - 接口 java.awt.im.spi.InputMethodDescriptor 中的方法
返回相应输入方法支持的语言环境。
getAvailableLocales() - 类 java.text.BreakIterator 中的静态方法
返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。
getAvailableLocales() - 类 java.text.Collator 中的静态方法
返回一个所有受支持语言环境的数组，此类的 getInstance 方法可为这些语言环境返回已本地化的实例。
getAvailableLocales() - 类 java.text.DateFormat 中的静态方法
返回所有语言环境的数组，此类的 get*Instance 方法可以为其返回已本地化的实例。
getAvailableLocales() - 类 java.text.DateFormatSymbols 中的静态方法
返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。
getAvailableLocales() - 类 java.text.DecimalFormatSymbols 中的静态方法
返回一个数组，它包括所有此类的 getInstance 方法可为之返回本地化实例的语言环境。
getAvailableLocales() - 类 java.text.NumberFormat 中的静态方法
返回一个数组，它包含所有此类的 get*Instance 方法可以为其返回本地化实例的语言环境。
getAvailableLocales() - 类 java.util.Calendar 中的静态方法
返回所有语言环境的数组，此类的 getInstance 方法可以为其返回本地化的实例。
getAvailableLocales() - 类 java.util.Locale 中的静态方法
返回所有已安装语言环境的数组。
getAvailableLocales() - 类 java.util.spi.LocaleServiceProvider 中的方法
返回一个数组，它包含此语言环境服务提供者可以为其提供本地化对象或名称的所有语言环境。
getAvailableLocales() - 类 javax.imageio.ImageReader 中的方法
返回可用来初始化警告侦听器和压缩设置值的 Locale 所组成的数组。
getAvailableLocales() - 类 javax.imageio.ImageWriter 中的方法
返回可用来初始化警告侦听器和压缩设置的 Locale 组成的数组。
getAvailableProcessors() - 接口 java.lang.management.OperatingSystemMXBean 中的方法
返回 Java 虚拟机可以使用的处理器数目。
getAvailableSize(Dimension, Insets) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回基于容器大小和 Insets 的可用宽度。
getAWTEventListeners() - 类 java.awt.Toolkit 中的方法
返回在此工具包上所有已注册 AWTEventListener 所组成的数组。
getAWTEventListeners(long) - 类 java.awt.Toolkit 中的方法
返回已在此工具包上注册的所有 AWTEventListener 所组成的数组，这些侦听器侦听用 eventMask 参数指定的所有事件类型。
getAWTKeyStroke(char) - 类 java.awt.AWTKeyStroke 中的静态方法
返回表示指定字符的 KEY_TYPED 事件的 AWTKeyStroke 的一个共享实例。
getAWTKeyStroke(Character, int) - 类 java.awt.AWTKeyStroke 中的静态方法
返回一个共享的 AWTKeyStroke 实例，它表示针对指定 Character 对象和一组组合键的 KEY_TYPED 事件。
getAWTKeyStroke(int, int, boolean) - 类 java.awt.AWTKeyStroke 中的静态方法
在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例，指定该键在按下或释放时是否是被激活。
getAWTKeyStroke(int, int) - 类 java.awt.AWTKeyStroke 中的静态方法
在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例。
getAWTKeyStroke(String) - 类 java.awt.AWTKeyStroke 中的静态方法
分析字符串并返回一个 AWTKeyStroke。
getAWTKeyStrokeForEvent(KeyEvent) - 类 java.awt.AWTKeyStroke 中的静态方法
返回一个 AWTKeyStroke，它表示生成给定 KeyEvent 的键击事件。
getAxis() - 类 javax.swing.BoxLayout 中的方法
返回用于布局组件的轴。
getAxis() - 类 javax.swing.text.BoxView 中的方法
获取平铺轴属性。
getB() - 类 java.security.spec.EllipticCurve 中的方法
返回椭圆曲线的第二个系数 b。
getBackBuffer() - 类 java.awt.Component.FlipBufferStrategy 中的方法

getBackBufferCapabilities() - 类 java.awt.BufferCapabilities 中的方法

getBackground() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的背景色。
getBackground() - 类 java.awt.Component 中的方法
获取组件的背景色。
getBackground() - 类 java.awt.Graphics2D 中的方法
返回用于清除区域的背景色。
getBackground() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的背景颜色。
getBackground() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的背景色。
getBackground() - 类 java.awt.TextComponent 中的方法
获得此文本组件的背景色。
getBackground() - 接口 javax.accessibility.AccessibleComponent 中的方法
获取此对象的背景色。
getBackground() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getBackground() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的背景色。
getBackground() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的背景色。
getBackground() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getBackground(AttributeSet) - 类 javax.swing.text.DefaultStyledDocument 中的方法
从属性集获得背景颜色。
getBackground() - 类 javax.swing.text.GlyphView 中的方法
获取用于呈现字形的背景色。
getBackground(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
获取一个属性集并将其转换为背景色规范。
getBackground() - 类 javax.swing.text.LabelView 中的方法
获取用于呈现字形的背景色。
getBackground(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取背景色设置。
getBackground(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
使用一个属性集并将其转换成为一个背景色规范。
getBackground(AttributeSet) - 接口 javax.swing.text.StyledDocument 中的方法
使用一个属性集并将其转换为一个背景色规范。
getBackgroundAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡背景色。
getBackgroundNonSelectionColor() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回用于非选定节点的背景色。
getBackgroundSelectionColor() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回在选定节点的情况下背景所使用的颜色。
getBandOffsets() - 类 java.awt.image.ComponentSampleModel 中的方法
返回所有 band 的 band 偏移量。
getBank() - 类 javax.sound.midi.Patch 中的方法
返回包含该 Patch 指定其位置乐器的库的号码。
getBankData() - 类 java.awt.image.DataBufferByte 中的方法
返回所有存储单元的数据数组。
getBankData() - 类 java.awt.image.DataBufferDouble 中的方法
返回所有存储单元的数据数组。
getBankData() - 类 java.awt.image.DataBufferFloat 中的方法
返回所有存储单元的数据数组。
getBankData() - 类 java.awt.image.DataBufferInt 中的方法
返回所有存储单元的数据数组。
getBankData() - 类 java.awt.image.DataBufferShort 中的方法
返回所有存储单元的数据数组。
getBankData() - 类 java.awt.image.DataBufferUShort 中的方法
返回所有存储单元的数据数组。
getBankIndices() - 类 java.awt.image.ComponentSampleModel 中的方法
返回所有 band 的存储单元索引。
getBase() - 类 javax.swing.text.html.HTMLDocument 中的方法
返回解析相对 URL 所根据的位置。
getBase() - 类 javax.swing.text.html.StyleSheet 中的方法
返回 base。
getBase64Content() - 类 javax.xml.soap.AttachmentPart 中的方法
以 Base64 编码字符数据的形式返回可用于获取 AttachmentPart 内容的 InputStream，此方法将对附件的原始字节进行 Base64 编码，然后返回该内容。
getBaseLevel() - 类 java.text.Bidi 中的方法
返回基本层次（如果是从左到右，则为 0；如果是从右到左，则为 1）。
getBaseline(int, int) - 类 java.awt.Component 中的方法
返回基线。
getBaseline() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的基线。
getBaseline(Component, int, int) - 类 javax.swing.border.AbstractBorder 中的方法
返回基线。
getBaseline(Component, int, int) - 类 javax.swing.border.TitledBorder 中的方法
返回基线。
getBaseline(int, int) - 类 javax.swing.JComponent 中的方法
返回基线。
getBaseline(int, int) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回基线。
getBaseline(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回指定选项卡的基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTextFieldUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.ComponentUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
返回基线。
getBaselineFor(char) - 类 java.awt.Font 中的方法
返回适合用来显示此字符的基线。
getBaselineIndex() - 类 java.awt.font.LineMetrics 中的方法
返回该文本的基线索引。
getBaselineOffset() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回基线偏移的距离。
getBaselineOffset() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
返回基线偏移的距离。
getBaselineOffsets() - 类 java.awt.font.LineMetrics 中的方法
返回文本的基线偏移量（相对于文本的基线）。
getBaselineOffsets() - 类 java.awt.font.TextLayout 中的方法
返回用于此 TextLayout 的基线偏移量数组。
getBaselineResizeBehavior() - 类 java.awt.Component 中的方法
返回一个指示组件的基线如何随大小发生更改的枚举。
getBaselineResizeBehavior(Component) - 类 javax.swing.border.AbstractBorder 中的方法
返回一个枚举，指示组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(Component) - 类 javax.swing.border.TitledBorder 中的方法
返回一个枚举，指示该边框的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior() - 类 javax.swing.JComponent 中的方法
返回一个枚举，指示组件的基线如何随大小更改而发生更改。
getBaselineResizeBehavior() - 类 javax.swing.JSpinner.DefaultEditor 中的方法
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
返回指示该组件的基线如何随大小的改变而发生更改的枚举。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicTextFieldUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
返回一个枚举，指示组件的基线如何随大小的改变而发生更改。
getBaseType() - 接口 java.sql.Array 中的方法
在由此 Array 对象指定的数组中获取元素的 JDBC 类型。
getBaseType() - 类 javax.activation.MimeType 中的方法
返回此对象的 String 表示形式，不带参数列表。
getBaseType() - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取此 SerialArray 对象中 SQL 类型的元素。
getBaseTypeName() - 接口 java.sql.Array 中的方法
在由此 Array 对象指定的数组中获取元素的 SQL 类型名称。
getBaseTypeName() - 接口 java.sql.Ref 中的方法
获取此 Ref 对象所引用 SQL 结构类型的完全限定的 SQL 名称。
getBaseTypeName() - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取此 SerialArray 对象元素特定于 DBMS 的类型名称。
getBaseTypeName() - 类 javax.sql.rowset.serial.SerialRef 中的方法
返回描述 Ref 的基本类型名称的字符串。
getBaseURI() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getBaseURI() - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法

getBaseURI() - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回基本 URI。
getBaseURI() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
获取此引用的基准 URI，如果此信息不可用，则获得 null
getBaseURI() - 接口 org.w3c.dom.ls.LSInput 中的方法
基 URI（请参阅 [IETF RFC 2396]中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。
getBaseURI() - 接口 org.w3c.dom.Node 中的方法
此节点的绝对基 URI；如果实现不能获得绝对 URI，则为 null。
getBasicConstraints() - 类 java.security.cert.X509Certificate 中的方法
从关键 BasicConstraints 扩展 (OID = 2.5.29.19) 中获取证书的限制路径长度。
getBasicConstraints() - 类 java.security.cert.X509CertSelector 中的方法
返回 BasicConstraints 限制。
getBasicSplitPaneUI() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回接收者当前位于其中的 SplitPaneUI。
getBean(CommandInfo) - 类 javax.activation.DataHandler 中的方法
一个便捷方法，它接受 CommandInfo 对象并且实例化相应的命令，通常是 JavaBean 组件。
getBeanClass() - 类 java.beans.BeanDescriptor 中的方法
获得 bean 的 Class 对象。
getBeanContext() - 接口 java.beans.beancontext.BeanContextChild 中的方法
获得与此 BeanContextChild 相关联的 BeanContext。
getBeanContext() - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
获得此 BeanContextChildSupport 的嵌套 BeanContext。
getBeanContext() - 类 java.beans.beancontext.BeanContextEvent 中的方法
获得与此事件相关联的 BeanContext。
getBeanContextChildPeer() - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
获得与此 BeanContextChildSupport 相关联的 BeanContextChild。
getBeanContextPeer() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得 BeanContext 的实例，此对象将为其提供实现。
getBeanContextProxy() - 接口 java.beans.beancontext.BeanContextProxy 中的方法
获得与此对象相关联的 BeanContextChild（或子接口）。
getBeanContextServicesPeer() - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
获得与此 BeanContextServicesSupport 相关联的 BeanContextServices。
getBeanDescriptor() - 接口 java.beans.BeanInfo 中的方法
获得 beans BeanDescriptor。
getBeanDescriptor() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝关于 bean 的类和 customizer 的信息。
getBeanInfo(Class<?>) - 类 java.beans.Introspector 中的静态方法
在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件。
getBeanInfo(Class<?>, int) - 类 java.beans.Introspector 中的静态方法
在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件，并将结果用一些控制标记表示。
getBeanInfo(Class<?>, Class<?>) - 类 java.beans.Introspector 中的静态方法
在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
getBeanInfoSearchPath() - 类 java.beans.Introspector 中的静态方法
获得将用来查找 BeanInfo 类的包名称的列表。
getBeforeIndex(int, int) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回给定索引前面的 String。
getBeforeIndex(int, int) - 接口 javax.accessibility.AccessibleText 中的方法
返回给定索引前面的 String。
getBeforeIndex(int, int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回给定索引前面的 String。
getBeforeIndex(int, int) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回给定索引前的 String。
getBeforeIndex(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 之前的 String。
getBeforeIndex(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回给定索引前的 String。
getBeforeIndex(int, int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回给定索引前面的 String。
getBeforeIndex(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定索引之前的 String。
getBeginIndex() - 接口 java.text.CharacterIterator 中的方法
返回文本的起始索引。
getBeginIndex() - 类 java.text.FieldPosition 中的方法
获取请求字段中第一个字符的索引。
getBeginIndex() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.getBeginIndex()。
getBeginIndex() - 类 javax.swing.text.Segment 中的方法
返回文本的起始索引。
getBestConfiguration(GraphicsConfiguration[]) - 类 java.awt.GraphicsConfigTemplate 中的方法
返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
getBestConfiguration(GraphicsConfigTemplate) - 类 java.awt.GraphicsDevice 中的方法
返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
getBestCursorSize(int, int) - 类 java.awt.Toolkit 中的方法
返回最接近所需大小的受支持光标尺寸。
getBestRowIdentifier(String, String, String, int, boolean) - 接口 java.sql.DatabaseMetaData 中的方法
获取唯一标识行的表的最佳列集合的描述。
getBevelType() - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框的类型。
getBias() - 类 javax.swing.text.JTextComponent.DropLocation 中的方法
返回放置索引的偏差。
getBidiLevel(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取 BidiLevel 设置。
getBidiRootElement() - 类 javax.swing.text.AbstractDocument 中的方法
返回此文档双向结构的根元素。
getBigDecimal(int, int) - 接口 java.sql.CallableStatement 中的方法
已过时。 使用 getBigDecimal(int parameterIndex) 或 getBigDecimal(String parameterName)
getBigDecimal(int) - 接口 java.sql.CallableStatement 中的方法
以 java.math.BigDecimal 对象的形式获取指定 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
getBigDecimal(String) - 接口 java.sql.CallableStatement 中的方法
以 java.math.BigDecimal 对象的形式获取 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
getBigDecimal(int, int) - 接口 java.sql.ResultSet 中的方法
已过时。
getBigDecimal(String, int) - 接口 java.sql.ResultSet 中的方法
已过时。
getBigDecimal(int) - 接口 java.sql.ResultSet 中的方法
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
getBigDecimal(String) - 接口 java.sql.ResultSet 中的方法
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
getBinaryName(TypeElement) - 接口 javax.lang.model.util.Elements 中的方法
返回类型元素的二进制名称。
getBinaryStream() - 接口 java.sql.Blob 中的方法
以流的形式获取此 Blob 实例指定的 BLOB 值。
getBinaryStream(long, long) - 接口 java.sql.Blob 中的方法
返回包含部分 Blob 值的 InputStream 对象，该值从 pos 指定的字节开始，长度为 length 个字节。
getBinaryStream(int) - 接口 java.sql.ResultSet 中的方法
以未解释字节的流的形式获取此 ResultSet 对象的当前行中指定列的值。
getBinaryStream(String) - 接口 java.sql.ResultSet 中的方法
以未解释的 byte 流的形式获取此 ResultSet 对象的当前行中指定列的值。
getBinaryStream() - 接口 java.sql.SQLXML 中的方法
以流的形式获取此 SQLXML 实例指定的 XML 值。
getBinaryStream() - 类 javax.sql.rowset.serial.SerialBlob 中的方法
以输入流的形式返回此 SerialBlob 对象。
getBinaryStream(long, long) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
返回一个包含部分 Blob 值的 InputStream 对象，它从 pos 指定的字节开始，具有 length 个字节长度。
getBinding() - 接口 javax.xml.ws.BindingProvider 中的方法
获取此绑定提供者的 Binding。
getBinding() - 类 javax.xml.ws.Endpoint 中的方法
返回此端点的绑定。
getBindingID() - 接口 javax.xml.ws.handler.PortInfo 中的方法
获取标识正由被访问的端口所用绑定的 URI。
getBindings(int) - 类 javax.script.AbstractScriptEngine 中的方法
返回受保护 context 字段中具有指定范围值的 Bindings。
getBindings(int) - 接口 javax.script.ScriptContext 中的方法
获取与此 ScriptContext 中的给定范围关联的 Bindings。
getBindings(int) - 接口 javax.script.ScriptEngine 中的方法
返回指定值的范围。
getBindings() - 类 javax.script.ScriptEngineManager 中的方法
getBindings 返回 globalScope 字段的值。
getBindings(int) - 类 javax.script.SimpleScriptContext 中的方法
如果指定范围为 ENGINE_SCOPE，则返回 engineScope 字段的值。
getBitDepth() - 类 java.awt.DisplayMode 中的方法
返回显示的位深（以位/像素表示）。
getBitMasks() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回所有 band 的位掩码。
getBitOffset(int) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回数据元素中存储扫描行第 x 个像素的偏移量(以位为单位)。
getBitOffset() - 接口 javax.imageio.stream.ImageInputStream 中的方法
以整数的形式返回当前位偏移量，该整数在 0 到 7 之间（包含两者）。
getBitOffset() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法

getBitOffsets() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回表示所有 band 像素的数据数组元素中的位偏移量。
getBitRate(float) - 类 javax.imageio.ImageWriteParam 中的方法
返回一个 float 值，该值指示对给定质量级别上用于输入图像数据的每个位的输出数据位数的估计。
getBitsPerBand(int) - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回用来表示给定 band 样本的位数。
getBlack() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的黑色。
getBlack() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回黑色。
getBlack() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回黑色。
getBlackBoxBounds(int, int) - 类 java.awt.font.TextLayout 中的方法
返回指定范围中字符的黑框边界。
getBlackLineBorderUIResource() - 类 javax.swing.plaf.BorderUIResource 中的静态方法

getBlinkRate() - 接口 javax.swing.text.Caret 中的方法
获取插入符的闪烁率。
getBlinkRate() - 类 javax.swing.text.DefaultCaret 中的方法
获取插入符闪烁率。
getBlob(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
getBlob(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Blob 对象的形式获取 JDBC BLOB 参数的值。
getBlob(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getBlob(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getBlockedCount() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程被阻塞进入或重进入监视器的总次数。
getBlockedTime() - 类 java.lang.management.ThreadInfo 中的方法
返回自从启用线程争用监视以来，与此 ThreadInfo 关联的线程被阻塞进入或重进入监视器的近似累计时间（以毫秒为单位）。
getBlocker(Thread) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
返回提供给最近一次尚未解除阻塞的 park 方法调用的 blocker 对象，如果该调用不受阻塞，则返回 null。
getBlockIncrement() - 接口 java.awt.Adjustable 中的方法
获取可调整对象的块值增量。
getBlockIncrement() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的块增量。
getBlockIncrement() - 类 java.awt.ScrollPaneAdjustable 中的方法

getBlockIncrement(int) - 类 javax.swing.JScrollBar 中的方法
针对一个向上/向下滚动一个块（通常为 "page"）的请求，返回滚动条值的更改量。
getBlockIncrement() - 类 javax.swing.JScrollBar 中的方法
供与 java.awt.Scrollbar 向后兼容。
getBlockIncrement(int) - 类 javax.swing.JScrollPane.ScrollBar 中的方法
如果视口中的视图为 Scrollable 对象，将计算滚动的块增量值。
getBlockSize() - 类 javax.crypto.Cipher 中的方法
返回块的大小（以字节为单位）。
getBlue() - 类 java.awt.Color 中的方法
返回默认 sRGB 空间中位于范围 0-255 中的蓝色分量。
getBlue(int) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的蓝色分量的值，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(Object) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(int) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的蓝色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(Object) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(int) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的蓝色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(Object) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(int) - 类 java.awt.image.IndexColorModel 中的方法
返回指定像素的蓝色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。
getBlueMask() - 类 java.awt.image.DirectColorModel 中的方法
返回指示 int 像素表示形式中哪些位包含蓝色颜色分量的掩码。
getBlues(byte[]) - 类 java.awt.image.IndexColorModel 中的方法
将蓝色分量数组复制到指定的数组中。
getBody() - 类 java.net.CacheRequest 中的方法
返回可以将响应正文写入其中的 OutputStream。
getBody() - 类 java.net.CacheResponse 中的方法
以 InputStream 的形式返回响应正文。
getBody() - 接口 javax.xml.soap.SOAPEnvelope 中的方法
返回与此 SOAPEnvelope 对象关联的 SOAPBody 对象。
getBoolean(String) - 类 java.lang.Boolean 中的静态方法
当且仅当以参数命名的系统属性存在，且等于 "true" 字符串时，才返回 true。
getBoolean(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 boolean 形式返回指定数组对象中索引组件的值。
getBoolean(Object) - 类 java.lang.reflect.Field 中的方法
获取一个静态或实例 boolean 字段的值。
getBoolean(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 boolean 值的形式获取指定的 JDBC BIT 或 BOOLEAN 参数的值。
getBoolean(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 boolean 值的形式获取 JDBC BIT 或 BOOLEAN 参数的值。
getBoolean(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。
getBoolean(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。
getBoolean(String, boolean) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getBoolean(String,boolean) 中的规范实现 getBoolean 方法。
getBoolean(String, boolean) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定的键相关联的、由字符串表示的 boolean 值。
getBoolean(SynthContext, Object, boolean) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
获得其值是一个 Boolean 值的特定样式属性的便捷方法。
getBoolean(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 是 boolean 值，则返回该 boolean 值，否则返回 false。
getBoolean(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值是 boolean 值，则返回该 boolean 值，否则返回 false。
getBoolean(Object) - 类 javax.swing.UIManager 中的静态方法
从与键值相关的默认值中返回一个布尔变量。
getBoolean(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从与键值和给定的 Locale 相关的默认值中返回一个布尔变量。
getBootClassPath() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回由引导类加载器用于搜索类文件的引导类路径。
getBorder() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的边框。
getBorder() - 类 javax.swing.JComponent 中的方法
返回此组件的边框；如果当前未设置边框，则返回 null。
getBorder() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回此组件的边框，如果当前没有设置边框，则返回 null。
getBorder() - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 中的方法
重写 JComponent.getBorder，以返回当前边框。
getBorder(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Border，则返回该 Border，否则返回 null。
getBorder(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Border，则返回该 Border，否则返回 null。
getBorder(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个边框。
getBorder(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个边框。
getBorderColor() - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法

getBorderInsets(Component) - 类 javax.swing.border.AbstractBorder 中的方法
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
getBorderInsets(Component, Insets) - 类 javax.swing.border.AbstractBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 类 javax.swing.border.BevelBorder 中的方法
返回边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.BevelBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 接口 javax.swing.border.Border 中的方法
返回该边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.CompoundBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 类 javax.swing.border.CompoundBorder 中的方法
返回复合边框的 insets，它是外部边框的 insets 与内部边框的 insets 相加所得的结果。
getBorderInsets(Component) - 类 javax.swing.border.EmptyBorder 中的方法
返回此边框的 insets
getBorderInsets(Component, Insets) - 类 javax.swing.border.EmptyBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数
getBorderInsets() - 类 javax.swing.border.EmptyBorder 中的方法
返回此边框的 insets。
getBorderInsets(Component) - 类 javax.swing.border.EtchedBorder 中的方法
返回边框的 insets
getBorderInsets(Component, Insets) - 类 javax.swing.border.EtchedBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数
getBorderInsets(Component) - 类 javax.swing.border.LineBorder 中的方法
返回边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.LineBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 类 javax.swing.border.MatteBorder 中的方法
返回边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.MatteBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets() - 类 javax.swing.border.MatteBorder 中的方法
返回此边框的 insets。
getBorderInsets(Component) - 类 javax.swing.border.SoftBevelBorder 中的方法
返回边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.SoftBevelBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 类 javax.swing.border.TitledBorder 中的方法
返回边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.TitledBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.MarginBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.MarginBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.BorderUIResource 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.PaletteBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.PaletteBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 中的方法

getBorderSelectionColor() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
返回绘制边框的颜色。
getBorderSelectionColor() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回绘制边框时所使用的颜色。
getBorderTitle(Border) - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
在边界层次结构（如果存在）中递归地搜索带有非 null 标题的 TitledBorder。
getBottomComponent() - 类 javax.swing.JSplitPane 中的方法
返回分隔条下面或者右边的组件。
getBottomInset() - 类 javax.swing.text.AsyncBoxView 中的方法
获得视图四周底部的空白部分。
getBottomInset() - 类 javax.swing.text.CompositeView 中的方法
获取底部 inset。
getBottomPanel() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getBoundActions() - 接口 javax.swing.text.Keymap 中的方法
获取在此 keymap 中定义的所有操作。
getBoundedPosition(GlyphView, int, float, float) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
确定表示符合给定区域的最大 advance 的模型位置。
getBoundingBox() - 类 java.awt.Polygon 中的方法
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
getBoundKeyStrokes() - 接口 javax.swing.text.Keymap 中的方法
获取在此映射中绑定到其他操作的所有击键。
getBounds() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的边界，用 Rectangle 对象的形式表示它。
getBounds() - 类 java.awt.Component 中的方法
以 Rectangle 对象的形式获取组件的边界。
getBounds(Rectangle) - 类 java.awt.Component 中的方法
将组件的边界存储到“返回值”rv 中并返回 rv。
getBounds() - 类 java.awt.font.GraphicAttribute 中的方法
返回包括所有位的 Rectangle2D，这些位由与呈现位置相关的 GraphicAttribute 绘制。
getBounds() - 类 java.awt.font.ImageGraphicAttribute 中的方法
返回一个 Rectangle2D，它封装此 ImageGraphicAttribute 相对于呈现位置呈现的所有位。
getBounds() - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回一个 Rectangle2D，它封装此 ShapeGraphicAttribute 相对于呈现位置绘制的所有位。
getBounds() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的边界。
getBounds() - 类 java.awt.geom.Area 中的方法
返回完全包围此 Area 的边界 Rectangle。
getBounds() - 类 java.awt.geom.CubicCurve2D 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.geom.Line2D 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.geom.Path2D 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.geom.QuadCurve2D 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.geom.RectangularShape 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.GraphicsConfiguration 中的方法
返回 GraphicsConfiguration 在设备坐标中的边界。
getBounds() - 类 java.awt.image.Raster 中的方法
返回此 Raster 的边界 Rectangle。
getBounds() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
以 Rectangle 对象的形式获取此对象的界限。
getBounds() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
以 Rectangle 对象的形式获取此对象的边界。
getBounds() - 类 java.awt.Polygon 中的方法
获取此 Polygon 的边界框。
getBounds() - 类 java.awt.Rectangle 中的方法
获取此 Rectangle 的边界 Rectangle。
getBounds() - 接口 java.awt.Shape 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.SplashScreen 中的方法
以 Rectangle 形式返回闪现屏幕窗口的边界。
getBounds() - 接口 java.lang.reflect.TypeVariable 中的方法
返回表示此类型变量上边界的 Type 对象的数组。
getBounds() - 接口 javax.accessibility.AccessibleComponent 中的方法
获取 Rectangle 对象形式的此对象的边界。
getBounds() - 接口 javax.lang.model.element.TypeParameterElement 中的方法
返回此类型参数的边界。
getBounds(Rectangle) - 类 javax.swing.JComponent 中的方法
将此组件的边界存储到“返回值”rv 中并返回 rv。
getBounds() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getBounds() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法

getBounds() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getBounds() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getBounds(TreePath, Rectangle) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回一个矩形，该矩形给出了绘制路径所需的 bounds。
getBounds(TreePath, Rectangle) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回给出绘制路径所需边界的矩形。
getBounds(TreePath, Rectangle) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回 Rectangle，它包围在其中绘制 path 标识的项的标签部分。
getBounds2D() - 类 java.awt.font.GlyphMetrics 中的方法
返回该字形的边界。
getBounds2D() - 类 java.awt.geom.Arc2D 中的方法
返回弧的高精度窗体矩形。
getBounds2D() - 类 java.awt.geom.Area 中的方法
返回完全包围此 Area 的高精度边界 Rectangle2D。
getBounds2D() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Ellipse2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Ellipse2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Line2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Line2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Path2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Path2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Rectangle2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Rectangle2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Rectangle2D 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D(BufferedImage) - 类 java.awt.image.AffineTransformOp 中的方法
返回转换后的目标图像的边界框。
getBounds2D(Raster) - 类 java.awt.image.AffineTransformOp 中的方法
返回转换后的目标图像的边界框。
getBounds2D(Raster) - 类 java.awt.image.BandCombineOp 中的方法
返回变换后目标图像的边界框。
getBounds2D(BufferedImage) - 接口 java.awt.image.BufferedImageOp 中的方法
返回已过滤目标图像的边界框。
getBounds2D(BufferedImage) - 类 java.awt.image.ColorConvertOp 中的方法
返回给定源的目标边界框。
getBounds2D(Raster) - 类 java.awt.image.ColorConvertOp 中的方法
返回给定源的目标边界框。
getBounds2D(BufferedImage) - 类 java.awt.image.ConvolveOp 中的方法
返回已过滤目标图像的边界框。
getBounds2D(Raster) - 类 java.awt.image.ConvolveOp 中的方法
返回已过滤目标 Raster 的边界框。
getBounds2D(BufferedImage) - 类 java.awt.image.LookupOp 中的方法
返回过滤后的目标图像的边界框。
getBounds2D(Raster) - 类 java.awt.image.LookupOp 中的方法
返回过滤后目标 Raster 的边界框。
getBounds2D(Raster) - 接口 java.awt.image.RasterOp 中的方法
返回过滤后目标 Raster 的边界框。
getBounds2D(ParameterBlock) - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
返回操作的输出的边界框，该操作在与呈现无关的空间中给定的一组源上执行。
getBounds2D(BufferedImage) - 类 java.awt.image.RescaleOp 中的方法
返回重缩放后的目标图像的边界框。
getBounds2D(Raster) - 类 java.awt.image.RescaleOp 中的方法
返回重缩放后的目标 Raster 的边界框。
getBounds2D() - 类 java.awt.Polygon 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.Rectangle 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 接口 java.awt.Shape 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBoundsAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡边界。
getBoundsForIconOf(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
iconifyFrame() 代码调用此方法来确定 desktopIcon 的适当边界。
getBox(Rectangle) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
存储将为 r 中的当前动画索引绘制并返回 r 的跳动框中位置和大小。
getBoxLength(int, int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回要绘制的“跳动框”的长度。
getBoxPainter(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
获取给定 CSS 属性集合使用的框 formatter。
getBranchQualifier() - 接口 javax.transaction.xa.Xid 中的方法
获取 XID 的事务分支标识符部分作为字节数组。
getBreakLocation(Segment, FontMetrics, int, int, TabExpander, int) - 类 javax.swing.text.Utilities 中的静态方法
确定对给定文本进行拆分的位置，以符合给定的跨距。
getBreakWeight(int, float, float) - 类 javax.swing.text.GlyphView 中的方法
确定此视图拆分几率有多大。
getBreakWeight(int, float, float) - 类 javax.swing.text.html.InlineView 中的方法
确定此视图拆分的可能性有多大。
getBreakWeight(int, float) - 类 javax.swing.text.ParagraphView 中的方法
获取给定位置的拆分权重。
getBreakWeight(int, float, float) - 类 javax.swing.text.View 中的方法
确定此视图中拆分时机的权重大小。
getBroadcast() - 类 java.net.DatagramSocket 中的方法
检测是否启用了 SO_BROADCAST。
getBroadcast() - 类 java.net.InterfaceAddress 中的方法
返回此 InterfaceAddress 广播地址的 InetAddress。
getBubbles() - 接口 org.w3c.dom.events.Event 中的方法
用于指示事件是否是 bubbling 事件。
getBuffer() - 类 java.io.StringWriter 中的方法
返回该字符串缓冲区本身。
getBufferCapabilities() - 类 java.awt.GraphicsConfiguration 中的方法
返回此 GraphicsConfiguration 的缓冲区能力。
getBufferedImageOp() - 类 java.awt.image.BufferedImageFilter 中的方法
返回 BufferedImageOp。
getBufferedImageType() - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回一个 int 值，它包含某一来自 BufferedImage 的描述图像的枚举常量值。
getBufferSize() - 接口 javax.sound.sampled.DataLine 中的方法
获得将适合数据行的内部缓冲区的最大数据字节数。
getBufferStrategy() - 类 java.awt.Canvas 中的方法
返回由此组件使用的 BufferStrategy。
getBufferStrategy() - 类 java.awt.Window 中的方法
返回此组件使用的 BufferStrategy。
getBuilder() - 类 javax.xml.bind.annotation.W3CDomHandler 中的方法

getBundle(String) - 类 java.util.ResourceBundle 中的静态方法
使用指定的基本名称、默认的语言环境和调用者的类加载器获取资源包。
getBundle(String, ResourceBundle.Control) - 类 java.util.ResourceBundle 中的静态方法
使用指定基本名称、默认语言环境和指定控件返回一个资源包。
getBundle(String, Locale) - 类 java.util.ResourceBundle 中的静态方法
使用指定的基本名称、语言环境和调用者的类加载器获取资源包。
getBundle(String, Locale, ResourceBundle.Control) - 类 java.util.ResourceBundle 中的静态方法
使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。
getBundle(String, Locale, ClassLoader) - 类 java.util.ResourceBundle 中的静态方法
使用指定的基本名称、语言环境和类加载器获取资源包。
getBundle(String, Locale, ClassLoader, ResourceBundle.Control) - 类 java.util.ResourceBundle 中的静态方法
使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
getBusy() - 接口 org.w3c.dom.ls.LSParser 中的方法
如果 LSParser 当前正忙于加载文档，则为 true，否则为 false。
getButton() - 类 java.awt.event.MouseEvent 中的方法
返回更改了状态的鼠标按键（如果有）。
getButton() - 接口 org.w3c.dom.events.MouseEvent 中的方法
在由按下或释放鼠标的按键引起的鼠标事件期间，button 用于指示哪一个鼠标按键改变了状态。
getButtonBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getButtonBorder() - 类 javax.swing.plaf.metal.MetalBorders 中的静态方法
返回一个用于 JButton 的 border 实例
getButtonCount() - 类 javax.swing.ButtonGroup 中的方法
返回此组中的按钮数。
getButtonPanel() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getButtons() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回从接收者为其提供外观的 JOptionPane 显示的按钮。
getButtonWidth() - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法

getByAddress(String, byte[], NetworkInterface) - 类 java.net.Inet6Address 中的静态方法
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。
getByAddress(String, byte[], int) - 类 java.net.Inet6Address 中的静态方法
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为给定的数字值。
getByAddress(String, byte[]) - 类 java.net.InetAddress 中的静态方法
根据提供的主机名和 IP 地址创建 InetAddress。
getByAddress(byte[]) - 类 java.net.InetAddress 中的静态方法
在给定原始 IP 地址的情况下，返回 InetAddress 对象。
getByInetAddress(InetAddress) - 类 java.net.NetworkInterface 中的静态方法
一个便捷方法，搜索绑定了指定 Internet 协议 (IP) 地址的网络接口。
getByName(String) - 类 java.net.InetAddress 中的静态方法
在给定主机名的情况下确定主机的 IP 地址。
getByName(String) - 类 java.net.NetworkInterface 中的静态方法
搜索具有指定名称的网络接口。
getByte(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 byte 形式返回指定数组对象中索引组件的值。
getByte(Object) - 类 java.lang.reflect.Field 中的方法
获取一个静态或实例 byte 字段的值。
getByte(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 byte 的形式获取指定的 JDBC TINYINT 参数的值。
getByte(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 byte 值的形式获取 JDBC TINYINT 参数的值。
getByte(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。
getByte(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。
getByteArray(String, byte[]) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getByteArray(String,byte[]) 中的规范实现 getByteArray 方法。
getByteArray(String, byte[]) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定键相关联的、由字符串表示的字节数组。
getByteLength() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得 MIDI 文件的长度，用 8 位字节表示。
getByteLength() - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得以字节为单位的整个文件（不只是其音频数据）的大小。
getByteOffset() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的输入源中的字节偏移量；如果没有可用的字节偏移量，则为 -1。
getByteOrder() - 接口 javax.imageio.stream.ImageInputStream 中的方法
以 java.nio.ByteOrder 枚举实例的形式返回从此流中读取数据值时所使用的字节顺序。
getByteOrder() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法

getByteParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 byte 返回参数的便捷方法。
getBytes(int, int, byte[], int) - 类 java.lang.String 中的方法
已过时。 该方法无法将字符正确转换为字节。从 JDK 1.1 起，完成该转换的首选方法是通过 String.getBytes() 方法，该方法使用平台的默认字符集。
getBytes(String) - 类 java.lang.String 中的方法
使用指定的字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。
getBytes(Charset) - 类 java.lang.String 中的方法
使用给定的 charset 将此 String 编码到 byte 序列，并将结果存储到新的 byte 数组。
getBytes() - 类 java.lang.String 中的方法
使用平台的默认字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。
getBytes(long, int) - 接口 java.sql.Blob 中的方法
以 byte 数组的形式获取此 Blob 对象表示的全部或部分 BLOB 值。
getBytes(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 byte 数组值的形式获取指定的 JDBC BINARY 或 VARBINARY 参数的值。
getBytes(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 byte 数组值的形式获取 JDBC BINARY 或 VARBINARY 参数的值。
getBytes(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。
getBytes(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。
getBytes() - 接口 java.sql.RowId 中的方法
返回表示此 java.sql.RowId 对象指定的 SQL ROWID 值的 byte 数组。
getBytes(long, int) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
将指定的字节数（从给定位置开始）从此 SerialBlob 对象复制到另一个字节数组。
getBytesRead() - 类 java.util.zip.Deflater 中的方法
返回到目前为止输入未压缩字节的总数。
getBytesRead() - 类 java.util.zip.Inflater 中的方法
返回到目前为止输入压缩字节的总数。
getByteStream() - 接口 org.w3c.dom.ls.LSInput 中的方法
依赖于语言和绑定类型的属性，表示字节的流。
getByteStream() - 接口 org.w3c.dom.ls.LSOutput 中的方法
具有语言和绑定依赖性类型的属性，表示字节的可写流。
getByteStream() - 类 org.xml.sax.InputSource 中的方法
获取此输入源的字节流。
getBytesWritten() - 类 java.util.zip.Deflater 中的方法
返回到目前为止输出压缩字节的总数。
getBytesWritten() - 类 java.util.zip.Inflater 中的方法
返回到目前为止输出未压缩字节的总数。
getCA() - 类 java.security.cert.TrustAnchor 中的方法
以 X500Principal 的形式返回最受信任的 CA 的名称。
getCachedIcon(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法

getCacheDirectory() - 类 javax.imageio.ImageIO 中的静态方法
返回由 setCacheDirectory 设置的当前值；如果没有显式设置该值，则返回 null。
getCachedMBeanInfo() - 类 javax.management.StandardMBean 中的方法
自定义钩子：返回为此对象缓存的 MBeanInfo。
getCalculatedDigestValue() - 接口 javax.xml.crypto.dsig.Reference 中的方法
返回执行验证操作后计算的此 Reference 的摘要值。
getCalendar() - 类 java.text.DateFormat 中的方法
获取与此日期/时间格式器关联的日历。
getCalendarField() - 类 java.text.DateFormat.Field 中的方法
返回与此属性关联的 Calendar 字段。
getCalendarField() - 类 javax.swing.SpinnerDateModel 中的方法
返回由 nextValue 和 previousValue 方法添加或去掉的 Calendar 字段。
getCallback() - 异常 javax.security.auth.callback.UnsupportedCallbackException 中的方法
获取未识别的 Callback。
getCallbackHandler() - 类 java.security.KeyStore.CallbackHandlerProtection 中的方法
返回 CallbackHandler。
getCAName() - 类 java.security.cert.TrustAnchor 中的方法
以 RFC 2253 String 格式返回最受信任的 CA 的名称。
getCancelable() - 接口 org.w3c.dom.events.Event 中的方法
用于指示事件是否可以阻止其默认操作。
getCancelSelectionAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getCandidateLocales(String, Locale) - 类 java.util.ResourceBundle.Control 中的方法
返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。
getCanonicalFile() - 类 java.io.File 中的方法
返回此抽象路径名的规范形式。
getCanonicalHostName() - 类 java.net.InetAddress 中的方法
获取此 IP 地址的完全限定域名。
getCanonicalizationMethod() - 接口 javax.xml.crypto.dsig.SignedInfo 中的方法
返回此 SignedInfo 的规范化方法。
getCanonicalizedData() - 接口 javax.xml.crypto.dsig.SignedInfo 中的方法
在执行签名或验证操作后，返回规范化的签名信息字节。
getCanonicalKeyPropertyListString() - 类 javax.management.ObjectName 中的方法
返回键属性列表的字符串表示形式，其中键属性按词汇顺序排序。
getCanonicalName() - 类 java.lang.Class 中的方法
返回 Java Language Specification 中所定义的底层类的规范化名称。
getCanonicalName() - 类 javax.management.ObjectName 中的方法
返回该名称的规范形式；也就是说，一种字符串表示形式，其中属性按词汇顺序排序。
getCanonicalPath() - 类 java.io.File 中的方法
返回此抽象路径名的规范路径名字符串。
getCanWrapLines() - 类 javax.swing.text.AbstractWriter 中的方法
返回是否可以换行。
getCapabilities() - 类 java.awt.Component.BltBufferStrategy 中的方法

getCapabilities() - 类 java.awt.Component.FlipBufferStrategy 中的方法

getCapabilities() - 类 java.awt.image.BufferStrategy 中的方法
返回此 BufferStrategy 的 BufferCapabilities。
getCapabilities(GraphicsConfiguration) - 类 java.awt.Image 中的方法
返回 ImageCapabilities 对象，查询该对象便可以了解使用指定 GraphicsConfiguration 时此 Image 的功能。
getCapabilities() - 类 java.awt.image.VolatileImage 中的方法
返回 ImageCapabilities 对象，查询此对象即可了解此 VolatileImage 的特定功能。
getCAPublicKey() - 类 java.security.cert.TrustAnchor 中的方法
返回最受信任的 CA 的公钥。
getCaret() - 类 java.awt.event.InputMethodEvent 中的方法
获取插入符。
getCaret() - 类 javax.swing.text.JTextComponent 中的方法
获取允许在视图上进行面向文本导航的插入符。
getCaret() - 类 javax.swing.text.NavigationFilter.FilterBypass 中的方法
返回不断变化的 Caret。
getCaretColor() - 类 javax.swing.text.JTextComponent 中的方法
获取用于呈现插入符的当前颜色。
getCaretInfo(TextHitInfo, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回与对应于 hit 的插入符有关的信息。
getCaretInfo(TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回与对应于 hit 的插入符有关的信息。
getCaretListeners() - 类 javax.swing.text.JTextComponent 中的方法
返回在此文本组件上已注册的所有插入符侦听器的数组。
getCaretPosition() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回插入记号的从零开始的偏移量。
getCaretPosition() - 类 java.awt.TextComponent 中的方法
返回文本插入符的位置。
getCaretPosition() - 接口 javax.accessibility.AccessibleText 中的方法
返回插入符从 0 开始的偏移量。
getCaretPosition() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回插入符号的从零开始的偏移量。
getCaretPosition() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回从 0 开始的插入符号偏移量。
getCaretPosition() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回从 0 开始的插入符号偏移量。
getCaretPosition() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回插入符号的从零开始的偏移量。
getCaretPosition() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回插入符的从零开始的偏移量。
getCaretPosition() - 类 javax.swing.text.JTextComponent 中的方法
返回文本组件的文本插入符的位置。
getCaretShape(TextHitInfo, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回表示指定边界内指定目标字符处插入符的 Shape。
getCaretShape(TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回表示此 TextLayout 的自然边界中指定目标字符处插入符的 Shape。
getCaretShapes(int, Rectangle2D, TextLayout.CaretPolicy) - 类 java.awt.font.TextLayout 中的方法
返回对应于强插入符和弱插入符的两条路径。
getCaretShapes(int, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回对应于强插入符和弱插入符的两条路径。
getCaretShapes(int) - 类 java.awt.font.TextLayout 中的方法
返回对应于强插入符和弱插入符的两条路径。
getCatalog() - 接口 java.sql.Connection 中的方法
获取此 Connection 对象的当前目录名称。
getCatalogName(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的表目录名称。
getCatalogName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取派生指定列中值的表的类别名称。
getCatalogs() - 接口 java.sql.DatabaseMetaData 中的方法
获取可在此数据库中使用的类别名称。
getCatalogSeparator() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库用作类别和表名之间的分隔符的 String。
getCatalogTerm() - 接口 java.sql.DatabaseMetaData 中的方法
获取数据库供应商用于 "catalog" 的首选术语。
getCategories() - 类 javax.imageio.spi.ServiceRegistry 中的方法
返回指示当前类别集的 Class 对象的 Iterator。
getCategory() - 接口 javax.print.attribute.Attribute 中的方法
将此打印属性值添加到属性集时，为它获取用作“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Chromaticity 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.ColorSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Compression 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Copies 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.CopiesSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.DateTimeAtCompleted 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.DateTimeAtCreation 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.DateTimeAtProcessing 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Destination 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.DocumentName 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Fidelity 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Finishings 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobHoldUntil 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobImpressions 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobImpressionsCompleted 中的方法
获取被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobImpressionsSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobKOctets 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobKOctetsProcessed 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobKOctetsSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobMediaSheets 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobMediaSheetsCompleted 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobMediaSheetsSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobMessageFromOperator 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobName 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobOriginatingUserName 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobPriority 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobPrioritySupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobSheets 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobState 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobStateReason 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobStateReasons 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Media 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.MediaSize 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.NumberOfDocuments 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.NumberOfInterveningJobs 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.NumberUp 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.NumberUpSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.OrientationRequested 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.OutputDeviceAssigned 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PageRanges 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PagesPerMinute 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PagesPerMinuteColor 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PDLOverrideSupported 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PresentationDirection 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterInfo 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterLocation 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterMakeAndModel 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterMessageFromOperator 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterMoreInfo 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterName 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterResolution 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterState 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterStateReason 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterStateReasons 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterURI 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrintQuality 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.QueuedJobCount 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.RequestingUserName 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Severity 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.SheetCollate 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Sides 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCause() - 异常 java.awt.print.PrinterIOException 中的方法
返回此异常的 cause（终止打印作业的 IOException）。
getCause() - 异常 java.io.WriteAbortedException 中的方法
返回终止操作的异常（即 cause）。
getCause() - 异常 java.lang.ClassNotFoundException 中的方法
返回此异常的原因（尝试加载类时发生错误引发的异常；否则返回 null）。
getCause() - 错误 java.lang.ExceptionInInitializerError 中的方法
返回导致该错误的原因（导致发生此错误的静态初始化期间发生的异常）。
getCause() - 异常 java.lang.reflect.InvocationTargetException 中的方法
返回此异常的原因（抛出的目标异常，可能为 null）。
getCause() - 异常 java.lang.reflect.UndeclaredThrowableException 中的方法
返回此异常的原因（此 UndeclaredThrowableException 中包装的 Throwable 实例，可能为 null）。
getCause() - 类 java.lang.Throwable 中的方法
返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。
getCause() - 异常 java.rmi.activation.ActivationException 中的方法
返回此异常的原因。
getCause() - 异常 java.rmi.RemoteException 中的方法
返回此异常的原因。
getCause() - 异常 java.rmi.server.ServerCloneException 中的方法
返回此异常的原因。
getCause() - 异常 java.security.PrivilegedActionException 中的方法
返回此异常（特权计算抛出的异常，该异常导致此 PrivilegedActionException）的 cause。
getCause() - 异常 javax.management.MBeanException 中的方法
返回实际抛出的 Exception。
getCause() - 异常 javax.management.ReflectionException 中的方法
返回抛出的实际 Exception。
getCause() - 异常 javax.management.remote.JMXProviderException 中的方法

getCause() - 异常 javax.management.remote.JMXServerErrorException 中的方法

getCause() - 异常 javax.management.RuntimeErrorException 中的方法
返回抛出的实际 Error。
getCause() - 异常 javax.management.RuntimeMBeanException 中的方法
返回抛出的实际 RuntimeException。
getCause() - 异常 javax.management.RuntimeOperationsException 中的方法
返回抛出的实际 RuntimeException。
getCause() - 异常 javax.naming.NamingException 中的方法
返回此异常的 cause。
getCause() - 异常 javax.security.sasl.SaslException 中的方法

getCause() - 异常 javax.xml.bind.JAXBException 中的方法

getCause() - 异常 javax.xml.crypto.dsig.TransformException 中的方法
返回此 TransformException 的 cause，如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.crypto.dsig.XMLSignatureException 中的方法
返回此 XMLSignatureException 的 cause；如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.crypto.KeySelectorException 中的方法
返回此 KeySelectorException 的 cause，如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.crypto.MarshalException 中的方法
返回此 MarshalException 的 cause；如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.crypto.NoSuchMechanismException 中的方法
返回此 NoSuchMechanismException 的 cause，如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.crypto.URIReferenceException 中的方法
返回此 URIReferenceException 的 cause，如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.soap.SOAPException 中的方法
返回此 SOAPException 中嵌入的 Throwable 对象（如果有）。
getCause() - 异常 javax.xml.transform.TransformerException 中的方法
返回此抛出对象的原因，如果原因不存在或未知，则返回 null。
getCause() - 异常 javax.xml.xpath.XPathException 中的方法
获取此 XPathException 的 cause。
getCellBounds(int, int) - 类 javax.swing.JList 中的方法
返回列表的坐标系统中两个索引所指定单元范围内的边界矩形。
getCellBounds(JList, int, int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
getCellBounds(JList, int, int) - 类 javax.swing.plaf.ListUI 中的方法
返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
getCellBounds(JList, int, int) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getCellBounds 方法。
getCellEditor() - 类 javax.swing.JTable 中的方法
返回活动单元格编辑器；如果该表当前没有被编辑，则返回 null。
getCellEditor(int, int) - 类 javax.swing.JTable 中的方法
返回适用于由 row 和 column 所指定单元格的编辑器。
getCellEditor() - 类 javax.swing.JTree 中的方法
返回用于编辑树中条目的编辑器。
getCellEditor() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getCellEditor() - 类 javax.swing.table.TableColumn 中的方法
返回 JTable 用于编辑此列各值的 TableCellEditor。
getCellEditorListeners() - 类 javax.swing.AbstractCellEditor 中的方法
返回使用 addCellEditorListener() 添加到此 AbstractCellEditor 中的所有 CellEditorListener 组成的数组。
getCellEditorListeners() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
返回使用 addCellEditorListener() 添加到此 DefaultTreeCellEditor 中的所有 CellEditorListener 组成的数组。
getCellEditorValue() - 接口 javax.swing.CellEditor 中的方法
返回编辑器中包含的值。
getCellEditorValue() - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
返回此单元格的值。
getCellEditorValue() - 类 javax.swing.DefaultCellEditor 中的方法
将消息从 CellEditor 转发到 delegate。
getCellEditorValue() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
返回当前正在编辑的值。
getCellLength() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回要在进度条中呈现的每个单个单元格/单元的宽度（如果为 HORIZONTAL）或高度（如果为 VERTICAL）。
getCellRect(int, int, boolean) - 类 javax.swing.JTable 中的方法
返回位于 row 和 column 相交位置的单元格矩形。
getCellRenderer() - 类 javax.swing.JList 中的方法
返回负责绘制列表项的对象。
getCellRenderer(int, int) - 类 javax.swing.JTable 中的方法
返回适于由此行和列所指定单元格的渲染器。
getCellRenderer() - 类 javax.swing.JTree 中的方法
返回正在呈现每个单元格的当前 TreeCellRenderer。
getCellRenderer() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回 currentCellRenderer，可以为树渲染器，也可以为 defaultCellRenderer，无论哪个都不为 null。
getCellRenderer() - 类 javax.swing.table.TableColumn 中的方法
返回 JTable 用于绘制此列各值的 TableCellRenderer。
getCellSelectionEnabled() - 类 javax.swing.JTable 中的方法
如果同时启用了行选择模型和列选择模型，则返回 true。
getCellSpacing() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回进度条中每个单元格/单元之间的间隔。
getCenterPoint() - 类 java.awt.GraphicsEnvironment 中的方法
返回 Windows 应居中的点。
getCenterPoint() - 类 java.awt.RadialGradientPaint 中的方法
返回辐射状渐变中心点的副本。
getCentersChildren() - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法

getCenterX() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 的窗体矩形中心的 X 坐标。
getCenterY() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 的窗体矩形中心的 Y 坐标。
getCertificate() - 类 java.security.cert.X509CertSelector 中的方法
返回 certificateEquals 标准。
getCertificate(String) - 类 java.security.KeyStore 中的方法
返回与给定别名关联的证书。
getCertificate() - 类 java.security.KeyStore.PrivateKeyEntry 中的方法
从此项中的证书链获取终端实体 Certificate。
getCertificate() - 类 javax.security.auth.x500.X500PrivateCredential 中的方法
返回 X.509 证书。
getCertificateAlias(Certificate) - 类 java.security.KeyStore 中的方法
返回证书与给定证书匹配的第一个 keystore 条目的别名。
getCertificateChain(String) - 类 java.security.KeyStore 中的方法
返回与给定别名关联的证书链。
getCertificateChain() - 类 java.security.KeyStore.PrivateKeyEntry 中的方法
从此项获取 Certificate 链。
getCertificateChain(String) - 接口 javax.net.ssl.X509KeyManager 中的方法
返回与给定别名关联的证书链。
getCertificateChecking() - 类 java.security.cert.X509CRLSelector 中的方法
返回要检查的证书。
getCertificateIssuer() - 类 java.security.cert.X509CRLEntry 中的方法
获取此项所描述的 X509Certificate 的发布方。
getCertificates() - 类 java.net.JarURLConnection 中的方法
如果此连接的 URL 指向 JAR 文件条目，则返回其 Certificate 对象；否则返回 null。
getCertificates() - 类 java.security.cert.CertPath 中的方法
返回此证书路径中的证书列表。
getCertificates(CertSelector) - 类 java.security.cert.CertStore 中的方法
返回与指定选择器匹配的 Certificate 的 Collection。
getCertificates() - 类 java.security.CodeSource 中的方法
返回与此 CodeSource 关联的证书。
getCertificates() - 类 java.util.jar.JarEntry 中的方法
返回此条目的 Certificate 对象；如果没有，则返回 null。
getCertificateValid() - 类 java.security.cert.X509CertSelector 中的方法
返回 certificateValid 标准。
getCertifiedText() - 接口 org.w3c.dom.ls.LSInput 中的方法
如果设置为 true，则假定解析 [XML 1.1] 时对输入进行认证（请参阅 [XML 1.1] 中的 2.13 节）。
getCertPath() - 接口 java.security.cert.CertPathBuilderResult 中的方法
返回已构建的证书路径。
getCertPath() - 异常 java.security.cert.CertPathValidatorException 中的方法
返回抛出异常时正在验证的证书路径
getCertPath() - 类 java.security.cert.PKIXCertPathBuilderResult 中的方法
返回已构建并已验证的证书路径。
getCertPathCheckers() - 类 java.security.cert.PKIXParameters 中的方法
返回证书路径检查器的 List。
getCertPathEncodings() - 类 java.security.cert.CertificateFactory 中的方法
返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。
getCertStoreParameters() - 类 java.security.cert.CertStore 中的方法
返回初始化此 CertStore 所用的参数。
getCertStores() - 类 java.security.cert.PKIXParameters 中的方法
返回用于查找证书和 CRL 的不可变 CertStore List。
getChange(Element) - 接口 javax.swing.event.DocumentEvent 中的方法
获得给定元素的更改信息。
getChange(Element) - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
获得元素的更改。
getChanged() - 类 java.awt.event.HierarchyEvent 中的方法
返回位于被更改层次结构顶部的 Component。
getChangedParent() - 类 java.awt.event.HierarchyEvent 中的方法
返回由 getChanged() 返回的 Component 的父级。
getChangeFlags() - 类 java.awt.event.HierarchyEvent 中的方法
返回指示此事件对象中表示的 HIERARCHY_CHANGED 事件类型的位掩码。
getChangeInfo() - 类 javax.naming.event.NamingEvent 中的方法
检索此事件的更改信息。
getChangeListeners() - 类 javax.swing.AbstractButton 中的方法
返回使用 addChangeListener() 添加到此 AbstractButton 中的所有 ChangeListener 组成的数组。
getChangeListeners() - 类 javax.swing.AbstractSpinnerModel 中的方法
返回使用 addChangeListener() 添加到此 AbstractSpinnerModel 中的所有 ChangeListener 组成的数组。
getChangeListeners() - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
返回一个使用 addChangeListener 添加到此 DefaultColorSelectionModel 中的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回此 DefaultBoundedRangeModel 上所有已注册的更改侦听器组成的数组。
getChangeListeners() - 类 javax.swing.DefaultButtonModel 中的方法
返回此 DefaultButtonModel 上所有已注册的更改侦听器组成的数组。
getChangeListeners() - 类 javax.swing.DefaultSingleSelectionModel 中的方法
返回此 DefaultSingleSelectionModel 上所有已注册的更改侦听器组成的数组。
getChangeListeners() - 类 javax.swing.JProgressBar 中的方法
返回通过 addChangeListener 添加到此进度条的所有 ChangeListener 组成的数组。
getChangeListeners() - 类 javax.swing.JSlider 中的方法
返回一个通过 addChangeListener() 方法添加此 JSlider 的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.JSpinner 中的方法
返回一个通过 addChangeListener() 方法添加到此 JSpinner 的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.JTabbedPane 中的方法
返回通过 addChangeListener 方法添加到此 JTabbedPane 中的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.JViewport 中的方法
返回使用 addChangeListener() 添加到此 JViewport 的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.MenuSelectionManager 中的方法
返回使用 addChangeListener() 添加到此 MenuSelectionManager 的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.text.DefaultCaret 中的方法
返回此插入符上所有已注册的更改侦听器组成的数组。
getChangeListeners() - 类 javax.swing.text.StyleContext 中的方法
返回使用 addChangeListener() 添加到此 StyleContext 中的所有 ChangeListener 组成的数组。
getChangeListeners() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
返回使用 addChangeListener() 添加到此 NamedStyle 中的所有 ChangeListener 组成的数组。
getChangeToParentDirectoryAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getChannel() - 类 java.io.FileInputStream 中的方法
返回与此文件输入流有关的唯一 FileChannel 对象。
getChannel() - 类 java.io.FileOutputStream 中的方法
返回与此文件输出流有关的唯一 FileChannel 对象。
getChannel() - 类 java.io.RandomAccessFile 中的方法
返回与此文件关联的唯一 FileChannel 对象。
getChannel() - 类 java.net.DatagramSocket 中的方法
返回与此数据报套接字关联的唯一 DatagramChannel 对象（如果有）。
getChannel() - 类 java.net.ServerSocket 中的方法
返回与此套接字关联的唯一 ServerSocketChannel 对象（如果有）。
getChannel() - 类 java.net.Socket 中的方法
返回与此数据报套接字关联的唯一 SocketChannel 对象（如果有）。
getChannel() - 类 javax.sound.midi.ShortMessage 中的方法
获取与此事件关联的 MIDI 通道。
getChannelPressure() - 接口 javax.sound.midi.MidiChannel 中的方法
获得通道的键盘力度。
getChannels() - 接口 javax.sound.midi.Synthesizer 中的方法
获得此合成器控制的一组 MIDI 通道。
getChannels() - 类 javax.sound.sampled.AudioFormat 中的方法
获取信道数。
getChar(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 char 形式返回指定数组对象中索引组件的值。
getChar(Object) - 类 java.lang.reflect.Field 中的方法
获取 char 类型或另一个通过扩展转换可以转换为 char 类型的基本类型的静态或实例字段的值。
getChar() - 类 java.nio.ByteBuffer 中的方法
用于读取 char 值的相对 get 方法。
getChar(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 char 值的绝对 get 方法。
getCharacterAttribute(int) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回给定字符（位于给定索引处）的 AttributeSet。
getCharacterAttribute(int) - 接口 javax.accessibility.AccessibleText 中的方法
返回给定索引处给定字符的 AttributeSet
getCharacterAttribute(int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回位于给定索引处的给定字符的 AttributeSet。
getCharacterAttribute(int) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回给定索引处给定字符的 AttributeSet
getCharacterAttribute(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回给定索引处给定字符的 AttributeSet
getCharacterAttribute(int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回位于给定索引处的给定字符的 AttributeSet
getCharacterAttribute(int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定字符（位于给定索引处）的 AttributeSet。
getCharacterAttributeRun() - 类 javax.swing.text.StyledEditorKit 中的方法
获取表示该插入符处当前运行的字符属性的元素。
getCharacterAttributes() - 类 javax.swing.JTextPane 中的方法
获取在当前插入符号位置的有效字符属性，或者 null。
getCharacterBounds(int) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
确定字符串中给定索引处的字符的边界框。
getCharacterBounds(int) - 接口 javax.accessibility.AccessibleText 中的方法
确定字符串中给定索引处的字符的边界框。
getCharacterBounds(int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
确定字符串中给定索引处的字符的边界框。
getCharacterBounds(int) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
确定给定字符串索引处字符的边界框。
getCharacterBounds(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
确定给定字符串索引处字符的边界。
getCharacterBounds(int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
确定字符串中给定索引处的字符的边界框。
getCharacterBounds(int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
确定字符串中给定索引处的字符的边界框。
getCharacterCount() - 类 java.awt.font.TextLayout 中的方法
返回由此 TextLayout 表示的字符数。
getCharacterElement(int) - 类 javax.swing.text.DefaultStyledDocument 中的方法
获得基于某个位置的字符元素。
getCharacterElement(int) - 接口 javax.swing.text.StyledDocument 中的方法
获取表示文档中给定偏移量处字符的元素。
getCharacterEncodingScheme() - 接口 javax.xml.stream.events.StartDocument 中的方法
返回 XML 数据的编码样式
getCharacterEncodingScheme() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getCharacterEncodingScheme() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回 xml 声明中声明的字符编码。
getCharacterInstance() - 类 java.text.BreakIterator 中的静态方法
返回一个用于默认语言环境 字符分解的新 BreakIterator 实例。
getCharacterInstance(Locale) - 类 java.text.BreakIterator 中的静态方法
返回一个用于给定语言环境字符分解的新 BreakIterator 实例。
getCharacterInstance(Locale) - 类 java.text.spi.BreakIteratorProvider 中的方法
为给定语言环境的字符分解返回新的 BreakIterator 实例。
getCharacterLevel(int) - 类 java.awt.font.TextLayout 中的方法
返回 index 处字符的级别。
getCharacterOffset() - 接口 javax.xml.stream.Location 中的方法
返回此位置所指向的输入源中的字节或字符偏移量。
getCharacterStream(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
getCharacterStream(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
getCharacterStream() - 接口 java.sql.Clob 中的方法
以 java.io.Reader 对象形式（或字符流形式）获取此 Clob 对象指定的 CLOB 值。
getCharacterStream(long, long) - 接口 java.sql.Clob 中的方法
返回包含部分 Clob 值的 Reader 对象，该值从 pos 指定的字符开始，长度为 length 个字符。
getCharacterStream(int) - 接口 java.sql.ResultSet 中的方法
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getCharacterStream(String) - 接口 java.sql.ResultSet 中的方法
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getCharacterStream() - 接口 java.sql.SQLXML 中的方法
以 java.io.Reader 对象的形式获取此 SQLXML 实例指定的 XML 值。
getCharacterStream() - 类 javax.sql.rowset.serial.SerialClob 中的方法
以 Unicode 字符流的形式返回此 SerialClob 对象的数据。
getCharacterStream(long, long) - 类 javax.sql.rowset.serial.SerialClob 中的方法

getCharacterStream() - 接口 org.w3c.dom.ls.LSInput 中的方法
依赖于语言和绑定类型的属性，表示 16 位单元流。
getCharacterStream() - 接口 org.w3c.dom.ls.LSOutput 中的方法
具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。
getCharacterStream() - 类 org.xml.sax.InputSource 中的方法
获取此输入源的字符流。
getCharContent(boolean) - 接口 javax.tools.FileObject 中的方法
返回此文件对象的字符内容（如果有）。
getCharContent(boolean) - 类 javax.tools.ForwardingFileObject 中的方法

getCharContent(boolean) - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现总是抛出 UnsupportedOperationException。
getCharCount() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回字符（有效索引）的数量
getCharCount() - 接口 javax.accessibility.AccessibleText 中的方法
返回字符（有效索引）数
getCharCount() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回字符（有效索引）的数量
getCharCount() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回字符（有效索引）数。
getCharCount() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回字符（有效索引）数。
getCharCount() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回字符（有效索引）的数量
getCharCount() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回字符（有效索引）的数量
getCharIndex() - 类 java.awt.font.TextHitInfo 中的方法
返回目标字符的索引。
getCharParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 char 返回参数的便捷方法。
getChars(int, int, char[], int) - 类 java.lang.String 中的方法
将字符从此字符串复制到目标字符数组。
getChars(int, int, char[], int) - 类 java.lang.StringBuffer 中的方法

getChars(int, int, Segment) - 接口 javax.swing.text.AbstractDocument.Content 中的方法
获得字符序列并将其复制到 Segment 中。
getChars(int, int, Segment) - 类 javax.swing.text.GapContent 中的方法
检索部分内容。
getChars(int, int, Segment) - 类 javax.swing.text.StringContent 中的方法
检索内容的某一部分，where ＋ len 必须 <= length()
getCharsetName() - 异常 java.nio.charset.IllegalCharsetNameException 中的方法
获取非法的 charset 名称。
getCharsetName() - 异常 java.nio.charset.UnsupportedCharsetException 中的方法
获取不受支持的 charset 的名称。
getCharSetSpec() - 异常 javax.swing.text.ChangedCharSetException 中的方法

getCheckboxGroup() - 类 java.awt.Checkbox 中的方法
确定此复选框的组。
getCheckBoxIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getCheckBoxIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法
返回一个复选框图标。
getCheckBoxMenuItemIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getCheckBoxMenuItemIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getChecksum() - 类 java.util.zip.CheckedInputStream 中的方法
返回此输入流的校验和。
getChecksum() - 类 java.util.zip.CheckedOutputStream 中的方法
返回此输出流的校验和。
getChild() - 类 java.awt.event.ContainerEvent 中的方法
返回受事件影响的组件。
getChild(String) - 类 java.util.prefs.AbstractPreferences 中的方法
如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。
getChild() - 类 java.util.prefs.NodeChangeEvent 中的方法
返回添加或移除的节点。
getChild(File, String) - 类 javax.swing.filechooser.FileSystemView 中的方法

getChild(Object, int) - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回父节点的子节点数组中索引 index 处的 parent 的子节点。
getChild(Object, int) - 接口 javax.swing.tree.TreeModel 中的方法
返回父节点的子数组中索引 index 位置的 parent 的子节点。
getChildAfter(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的子节点数组中刚好跟在 aChild 之后的子节点，它必须是此节点的子节点。
getChildAllocation(int, Shape) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
获取用于子视图的分配区域。
getChildAllocation(int) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
获取用于子视图的分配区域。
getChildAllocation(int, Shape) - 类 javax.swing.text.AsyncBoxView 中的方法
获取给定子视图的分配区域。
getChildAllocation(int, Shape) - 类 javax.swing.text.BoxView 中的方法
获取给定子视图的分配。
getChildAllocation(int, Shape) - 类 javax.swing.text.CompositeView 中的方法
获取要在其中呈现的给定子视图的分配区域。
getChildAllocation(int, Shape) - 类 javax.swing.text.View 中的方法
获取给定子视图的分配。
getChildAt(int) - 类 javax.swing.JTree.DynamicUtilTreeNode 中的方法
必要时创建子类以加载此子节点。
getChildAt(int) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
在索引 childIndex 处返回子级 TreeNode。
getChildAt(int) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的子节点数组中指定索引处的子节点。
getChildAt(int) - 接口 javax.swing.tree.TreeNode 中的方法
返回索引 childIndex 位置的子 TreeNode。
getChildBeanContextChild(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
与指定 Child 相关联的 BeanContextChild（如果有）。
getChildBeanContextMembershipListener(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
与指定 Child 相关联的 BeanContextMembershipListener（如果有）。
getChildBeanContextServicesListener(Object) - 类 java.beans.beancontext.BeanContextServicesSupport 中的静态方法
获得指定子级的 BeanContextServicesListener（如果有）。
getChildBefore(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的子节点数组中刚好在 aChild 之前的子节点，它必须是此节点的子节点。
getChildCount() - 类 javax.swing.JTree.DynamicUtilTreeNode 中的方法
返回子节点数。
getChildCount() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
返回接受方所包含的子级 TreeNode 的数量。
getChildCount() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的子节点数。
getChildCount(Object) - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回 parent 的子节点数。
getChildCount(Object) - 接口 javax.swing.tree.TreeModel 中的方法
返回 parent 的子节点数。
getChildCount() - 接口 javax.swing.tree.TreeNode 中的方法
返回接收者包含的子 TreeNode 数。
getChildElements() - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在此元素的所有直接子 Node 上进行迭代的 Iterator。
getChildElements(Name) - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在带有指定名称的此元素所有直接子 Node 上进行迭代的 Iterator。
getChildElements(QName) - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在带有指定 qname 的此元素所有直接子 Node 上进行迭代的 Iterator。
getChildIndex() - 类 javax.swing.JTree.DropLocation 中的方法
对于 getPath() 返回的路径，返回应该插入放置数据的位置的索引。
getChildIndices() - 类 javax.swing.event.TreeModelEvent 中的方法
返回子索引的值。
getChildNames(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回一个按出现顺序排列的 String 数组，指示允许作为指定元素子元素的元素的名称。
getChildNames(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getChildNodes() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getChildNodes() - 接口 org.w3c.dom.Node 中的方法
包含此节点的所有子节点的 NodeList。
getChildPolicy(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回以 CHILD_POLICY_ 开头的常量之一，指示指定元素子元素的合法模式。
getChildPolicy(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getChildPropertyChangeListener(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
与指定 Child 相关联的 PropertyChangeListener（如果有）
getChildren() - 接口 java.security.cert.PolicyNode 中的方法
返回在此节点的子节点上进行迭代的迭代器。
getChildren() - 类 javax.swing.event.TreeModelEvent 中的方法
返回位于 getChildIndices 指定位置处的、作为 getPath 所标识节点的子节点的对象。
getChildrenAdded() - 接口 javax.swing.event.DocumentEvent.ElementChange 中的方法
获得添加到给定父元素中的子元素。
getChildrenAdded() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
获得已添加的子元素列表。
getChildrenRemoved() - 接口 javax.swing.event.DocumentEvent.ElementChange 中的方法
获得从给定父元素中移除的子元素。
getChildrenRemoved() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
获得已移除的子元素列表。
getChildSerializable(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
获得与指定 Child 相关联的 Serializable（如果有）
getChildState(int) - 类 javax.swing.text.AsyncBoxView 中的方法
获取对象，该对象表示在给定索引位置的子视图的布局状态。
getChildVetoableChangeListener(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
与指定 Child 相关联的 VetoableChangeListener（如果有）。
getChildView() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
获取此记录表示的子视图。
getChildVisibility(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
获得与指定子级相关联的 Component（如果有）。
getChoices() - 类 javax.security.auth.callback.ChoiceCallback 中的方法
获取选项列表。
getChoosableFileFilters() - 类 javax.swing.JFileChooser 中的方法
获得用户可选择的文件过滤器列表。
getChooserPanels() - 类 javax.swing.JColorChooser 中的方法
返回指定的颜色面板。
getCipherSuite() - 类 java.net.SecureCacheResponse 中的方法
返回正在获得了网络资源的初始连接上使用的密码套件。
getCipherSuite() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回由握手产生的会话所使用的密码套件。
getCipherSuite() - 类 javax.net.ssl.HttpsURLConnection 中的方法
返回在此连接上使用的密码套件。
getCipherSuite() - 接口 javax.net.ssl.SSLSession 中的方法
返回会话中的所有连接所使用的 SSL 密码套件的名称。
getCipherSuites() - 类 javax.net.ssl.SSLParameters 中的方法
返回密码套件数组的副本；如果未设置，则返回 null。
getClass() - 类 java.lang.Object 中的方法
返回此 Object 的运行时类。
getClassAnnotation(Class<?>) - 类 java.rmi.server.RMIClassLoader 中的静态方法
返回表示类定义位置的注释字符串，RMI 将在编组给定类的对象时用其注释类描述符。
getClassAnnotation(Class<?>) - 类 java.rmi.server.RMIClassLoaderSpi 中的方法
提供 RMIClassLoader.getClassAnnotation(Class) 的实现。
getClassContext() - 类 java.lang.SecurityManager 中的方法
以类数组的形式返回当前执行堆栈。
getClasses() - 类 java.lang.Class 中的方法
返回一个包含某些 Class 对象的数组，这些对象表示属于此 Class 对象所表示的类的成员的所有公共类和接口。
getClassLoader() - 类 java.lang.Class 中的方法
返回该类的类加载器。
getClassLoader(String) - 类 java.rmi.server.RMIClassLoader 中的静态方法
返回从给定的基本代码 URL 路径加载类的类加载器。
getClassLoader(String) - 类 java.rmi.server.RMIClassLoaderSpi 中的方法
提供 RMIClassLoader.getClassLoader(String) 的实现。
getClassLoader() - 类 java.security.ProtectionDomain 中的方法
返回此域的 ClassLoader。
getClassLoader(ObjectName) - 接口 javax.management.MBeanServer 中的方法
返回指定的 ClassLoader。
getClassLoader(JavaFileManager.Location) - 类 javax.tools.ForwardingJavaFileManager 中的方法

getClassLoader(JavaFileManager.Location) - 接口 javax.tools.JavaFileManager 中的方法
获取可从给定位置加载插件的类加载器。
getClassLoaderFor(ObjectName) - 接口 javax.management.MBeanServer 中的方法
返回用于加载指定 MBean 的类的 ClassLoader。
getClassLoaderRepository() - 接口 javax.management.MBeanServer 中的方法
返回此 MBeanServer 的 ClassLoaderRepository。
getClassLoaderRepository(MBeanServer) - 类 javax.management.MBeanServerFactory 中的静态方法
返回给定 MBeanServer 使用的 ClassLoaderRepository。
getClassLoaderRepository() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
返回用于执行类加载的 Class Loader Repository。
getClassLoadingMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机的类加载系统的管理 Bean。
getClassName() - 类 java.lang.management.LockInfo 中的方法
返回锁对象的完全限定类名称。
getClassName() - 类 java.lang.StackTraceElement 中的方法
返回类的完全限定名，该类包含由该堆栈跟踪元素所表示的执行点。
getClassName() - 类 java.rmi.activation.ActivationDesc 中的方法
返回此描述符指定的对象的类名。
getClassName() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
返回组的类名（可能为 null）。
getClassName() - 类 java.security.Provider.Service 中的方法
返回实现此服务的类的名称。
getClassName() - 异常 java.util.MissingResourceException 中的方法
获得构造方法所传递的参数。
getClassName() - 类 javax.management.MBeanInfo 中的方法
返回此 MBeanInfo 描述的 MBean 的 Java 类名。
getClassName() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回此 MBeanInfo 所描述的 MBean 的 Java 类名称。
getClassName() - 类 javax.management.ObjectInstance 中的方法
返回类部分。
getClassName() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回此 OpenMBeanInfo 描述的 open MBean 实例的完全限定的 Java 类名。
getClassName() - 类 javax.management.openmbean.OpenType 中的方法
返回此开放类型描述的开放数据值的完全限定的 Java 类名。
getClassName(MBeanInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 className。
getClassName() - 类 javax.naming.Binding 中的方法
检索绑定到此绑定名称的对象的类名称。
getClassName() - 类 javax.naming.NameClassPair 中的方法
检索绑定到此绑定名称的对象的类名称。
getClassName() - 类 javax.naming.Reference 中的方法
检索此引用所引用对象的类名称。
getClassName() - 类 javax.swing.UIManager.LookAndFeelInfo 中的方法
返回实现此外观的类名称。
getClassPath() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回系统类加载器用于搜索类文件的 Java 类路径。
getClickCount() - 类 java.awt.event.MouseEvent 中的方法
返回与此事件关联的鼠标单击次数。
getClickCountToStart() - 类 javax.swing.DefaultCellEditor 中的方法
返回开始编辑所需的单击次数。
getClient() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回与此票据有关联的客户端主体。
getClientAddresses() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回可从其所指位置使用票据的地址列表。
getClientAliases(String, Principal[]) - 接口 javax.net.ssl.X509KeyManager 中的方法
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字客户端的匹配别名。
getClientHost() - 类 java.rmi.server.RemoteServer 中的静态方法
返回一个客户机主机的字符串表示形式，用于在当前线程中正在处理的远程方法调用。
getClientHost() - 接口 java.rmi.server.ServerRef 中的方法
返回当前客户机的主机名。
getClientInfo(String) - 接口 java.sql.Connection 中的方法
返回通过名称指定的客户端信息属性的值。
getClientInfo() - 接口 java.sql.Connection 中的方法
返回一个列表，它包含驱动程序支持的每个客户端信息属性的名称和当前值。
getClientInfoProperties() - 接口 java.sql.DatabaseMetaData 中的方法
获取驱动程序支持的客户端信息属性的列表。
getClientProperty(Object) - 类 javax.swing.JComponent 中的方法
返回具有指定键的属性的值。
getClientSessionContext() - 类 javax.net.ssl.SSLContext 中的方法
返回客户端会话上下文，它表示可供客户端 SSL 套接字握手阶段所使用的 SSL 会话集。
getClientX() - 接口 org.w3c.dom.events.MouseEvent 中的方法
相对于 DOM 实现的客户区域的水平坐标(事件发生在此处)。
getClientY() - 接口 org.w3c.dom.events.MouseEvent 中的方法
相对于 DOM 实现的客户区域的垂直坐标(事件发生在此处)。
getClip() - 类 java.awt.Graphics 中的方法
获取当前剪贴区域。
getClip() - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得可用于回放音频文件或音频流的剪辑。
getClip(Mixer.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
从指定混频器获得可用于回放音频文件或音频流的剪辑。
getClip() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.getClip。
getClipBounds() - 类 java.awt.Graphics 中的方法
返回当前剪贴区域的边界矩形。
getClipBounds(Rectangle) - 类 java.awt.Graphics 中的方法
返回当前剪贴区域的边界矩形。
getClipBounds() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.getClipBounds。
getClipRect() - 类 java.awt.Graphics 中的方法
已过时。 从 JDK version 1.1 开始，由 getClipBounds() 取代。
getClob(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
getClob(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.CLOB 对象的形式获取 JDBC CLOB 参数的值。
getClob(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getClob(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getClosedIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回用于表示没有扩展的非叶节点的图标。
getClosestPathForLocation(int, int) - 类 javax.swing.JTree 中的方法
返回离 x,y 最近的节点的路径。
getClosestPathForLocation(JTree, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回到达最接近于 x,y 的那个节点的路径。
getClosestPathForLocation(JTree, int, int) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getClosestPathForLocation 方法。
getClosestPathForLocation(JTree, int, int) - 类 javax.swing.plaf.TreeUI 中的方法
返回到达最接近于 x,y 的那个节点的路径。
getClosestPositionTo(int, Position.Bias, Shape, int, Position.Bias[], int, int) - 类 javax.swing.text.ParagraphView 中的方法
返回最接近 x 处的模型位置。
getClosestRowForLocation(int, int) - 类 javax.swing.JTree 中的方法
返回离 x,y 最近的节点的行。
getCode() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记的 CODE 属性的值。
getCode() - 接口 javax.tools.Diagnostic 中的方法
获取指示诊断类型的诊断代码。
getCodeBase() - 类 java.applet.Applet 中的方法
获得基 URL。
getCodeBase() - 接口 java.applet.AppletStub 中的方法
获取基 URL。
getCodeBase() - 类 javax.management.loading.MLetContent 中的方法
获取代码基 URL。
getCodebase(Class) - 类 javax.rmi.CORBA.Util 中的静态方法
返回给定类的代码基（如果存在）。
getCodebase(Class) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.getCodebase(java.lang.Class) 的委托调用。
getCodePoint() - 异常 java.util.IllegalFormatCodePointException 中的方法
返回 Character.isValidCodePoint(int) 所定义的非法代码点。
getCodeSigners() - 类 java.security.CodeSource 中的方法
返回与此 CodeSource 关联的代码签名者。
getCodeSigners() - 类 java.util.jar.JarEntry 中的方法
返回此条目的 CodeSigner 对象；如果没有，则返回 null。
getCodeSource() - 类 java.security.ProtectionDomain 中的方法
返回此域的 CodeSource。
getCofactor() - 类 java.security.spec.ECParameterSpec 中的方法
返回余因子。
getCollapsedIcon() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getCollationElementIterator(String) - 类 java.text.RuleBasedCollator 中的方法
返回给定 String 的 CollationElementIterator。
getCollationElementIterator(CharacterIterator) - 类 java.text.RuleBasedCollator 中的方法
返回给定 String 的 CollationElementIterator。
getCollationKey(String) - 类 java.text.Collator 中的方法
将该 String 转换为一系列可以和其他 CollationKey 按位进行比较的位。
getCollationKey(String) - 类 java.text.RuleBasedCollator 中的方法
将字符串转换为能够与 CollationKey.compareTo 进行比较的一系列字符。
getCollection() - 类 java.security.cert.CollectionCertStoreParameters 中的方法
返回从中获取 Certificate 和 CRL 的 Collection。
getCollectionCount() - 接口 java.lang.management.GarbageCollectorMXBean 中的方法
返回已发生的回收的总次数。
getCollectionTime() - 接口 java.lang.management.GarbageCollectorMXBean 中的方法
返回近似的累积回收时间（以毫秒为单位）。
getCollectionUsage() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回 Java 虚拟机最近回收了此内存池中的不使用的对象之后的内存使用量。
getCollectionUsageThreshold() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回此内存池的回收使用量阈值（以字节为单位）。
getCollectionUsageThresholdCount() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回 Java 虚拟机已检测到内存使用量达到或超过回收使用量阈值的次数。
getColor(String) - 类 java.awt.Color 中的静态方法
查找系统属性中的一种颜色。
getColor(String, Color) - 类 java.awt.Color 中的静态方法
查找系统属性中的一种颜色。
getColor(String, int) - 类 java.awt.Color 中的静态方法
查找系统属性中的一种颜色。
getColor() - 类 java.awt.Graphics 中的方法
获取此图形上下文的当前颜色。
getColor() - 类 java.awt.PageAttributes 中的方法
返回使用这些属性的页面是以彩色呈现，还是以单色呈现。
getColor() - 类 javax.swing.DebugGraphics 中的方法
返回用于文本绘制操作的 Color。
getColor() - 类 javax.swing.JColorChooser 中的方法
获取颜色选取器的当前颜色值。
getColor(SynthContext, ColorType) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回指定状态的颜色。
getColor() - 类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 中的方法
返回高亮显示的颜色。
getColor(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Color，则返回它，否则返回 null。
getColor(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Color，则返回它，否则返回 null。
getColor(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值返回一种颜色。
getColor(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一种颜色。
getColor1() - 类 java.awt.GradientPaint 中的方法
返回点 P1 的颜色 C1。
getColor2() - 类 java.awt.GradientPaint 中的方法
返回点 P2 的颜色 C2。
getColorComponents(float[]) - 类 java.awt.Color 中的方法
根据 Color 的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的颜色分量。
getColorComponents(ColorSpace, float[]) - 类 java.awt.Color 中的方法
根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的颜色分量。
getColorForGap(int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法

getColorForState(SynthContext, ColorType) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回指定状态的颜色。
getColorFromModel() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
返回当前所选取的颜色。
getColorModel() - 类 java.awt.Component 中的方法
获取用于在输出设备上显示组件的 ColorModel 实例。
getColorModel() - 类 java.awt.GraphicsConfiguration 中的方法
返回与此 GraphicsConfiguration 关联的 ColorModel。
getColorModel(int) - 类 java.awt.GraphicsConfiguration 中的方法
返回与此 GraphicsConfiguration 关联并支持指定透明度的 ColorModel。
getColorModel() - 类 java.awt.image.BufferedImage 中的方法
返回 ColorModel。
getColorModel() - 类 java.awt.image.PixelGrabber 中的方法
获取该数组中所存储像素的 ColorModel。
getColorModel() - 接口 java.awt.image.RenderedImage 中的方法
返回与此图像相关的 ColorModel。
getColorModel() - 接口 java.awt.PaintContext 中的方法
返回输出的 ColorModel。
getColorModel() - 类 java.awt.Toolkit 中的方法
确定此工具包屏幕的颜色模型。
getColorModel() - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回此对象指定的 ColorModel。
getColors() - 类 java.awt.MultipleGradientPaint 中的方法
返回此渐变所使用的颜色数组的副本。
getColorSelectionModel() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
返回选取器面板正在编辑的模型。
getColorSpace() - 类 java.awt.Color 中的方法
返回此 Color 的 ColorSpace。
getColorSpace() - 类 java.awt.image.ColorModel 中的方法
返回与此 ColorModel 相关的 ColorSpace。
getColorSpace() - 类 java.awt.MultipleGradientPaint 中的方法
返回指定用于插值的颜色空间的枚举类型。
getColorSpaceType() - 类 java.awt.color.ICC_Profile 中的方法
返回颜色空间类型。
getColumn() - 类 javax.swing.event.TableModelEvent 中的方法
返回事件的列。
getColumn() - 类 javax.swing.JTable.DropLocation 中的方法
返回表中应该用来放入放置项的列索引。
getColumn(Object) - 类 javax.swing.JTable 中的方法
返回表中列的 TableColumn 对象，当使用 equals 进行比较时，表的标识符等于 identifier。
getColumn() - 类 javax.swing.RowSorter.SortKey 中的方法
返回列的索引。
getColumn(int) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回 columnIndex 处列的 TableColumn 对象。
getColumn(int) - 接口 javax.swing.table.TableColumnModel 中的方法
返回 columnIndex 位置列的 TableColumn 对象。
getColumnClass(int) - 类 javax.swing.JTable 中的方法
返回出现在视图中 column 列位置处的列类型。
getColumnClass(int) - 类 javax.swing.table.AbstractTableModel 中的方法
返回 Object.class 而不管 columnIndex 是多少。
getColumnClass(int) - 接口 javax.swing.table.TableModel 中的方法
针对列中所有的单元格值，返回最具体的超类。
getColumnClassName(int) - 接口 java.sql.ResultSetMetaData 中的方法
如果调用方法 ResultSet.getObject 从列中获取值，则返回构造其实例的 Java 类的完全限定名称。
getColumnClassName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取 Java 编程语言中一个类的完全限定名，该类是指定列中的值将映射到的那个类。
getColumnCount() - 接口 java.sql.ResultSetMetaData 中的方法
返回此 ResultSet 对象中的列数。
getColumnCount() - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中的列数。
getColumnCount() - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
返回模型中的列数。
getColumnCount() - 类 javax.swing.JTable 中的方法
返回列模型中的列数。
getColumnCount() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回 tableColumns 数组中的列数。
getColumnCount() - 类 javax.swing.table.DefaultTableModel 中的方法
返回此数据表中的列数。
getColumnCount() - 接口 javax.swing.table.TableColumnModel 中的方法
返回该模型中的列数。
getColumnCount() - 接口 javax.swing.table.TableModel 中的方法
返回该模型中的列数。
getColumnCount() - 类 javax.swing.text.TableView.TableCell 中的方法
已过时。 获取此单元格所跨的列数（即网格宽度）。
getColumnDisplaySize(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示指定列的最大标准宽度，以字符为单位。
getColumnDisplaySize(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取以 char 为单位的指定列的正常最大宽度。
getColumnHeader() - 类 javax.swing.JScrollPane 中的方法
返回列标题。
getColumnHeader() - 类 javax.swing.ScrollPaneLayout 中的方法
返回列标题对应的 JViewport 对象。
getColumnIndex(Object) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回 tableColumns 数组中第一列的索引，当使用 equals 进行比较时，该列的标识符等于 identifier。
getColumnIndex(Object) - 接口 javax.swing.table.TableColumnModel 中的方法
返回该表中首列的索引，使用 equals 进行比较时，该列的标识符等于 identifier。
getColumnIndexAtX(int) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回位于 x 处列的索引，如果该点处没有列，则返回 -1。
getColumnIndexAtX(int) - 接口 javax.swing.table.TableColumnModel 中的方法
返回位于该水平点 xPosition 位置列的索引；如果该点位于任何列边界外，则返回 -1。
getColumnLabel(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取用于打印输出和显示的指定列的建议标题。
getColumnLabel(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取用于打印输出和显示的指定列的建议列标题。
getColumnMargin() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回 TableColumn 的空白宽度。
getColumnMargin() - 接口 javax.swing.table.TableColumnModel 中的方法
返回每列中单元格之间的宽度。
getColumnModel() - 类 javax.swing.JTable 中的方法
返回包含此表所有列信息的 TableColumnModel。
getColumnModel() - 类 javax.swing.table.JTableHeader 中的方法
返回包含此表头所有列信息的 TableColumnModel。
getColumnModelListeners() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回一个包含在此模型上注册的所有列模型侦听器的数组。
getColumnName(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的名称。
getColumnName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取指定列的名称。
getColumnName(int) - 类 javax.swing.JTable 中的方法
返回出现在视图中 column 列位置处的列名称。
getColumnName(int) - 类 javax.swing.table.AbstractTableModel 中的方法
返回列默认名称，其中列使用以下工作表约定：A、B、C……Z、AA、AB 等等。
getColumnName(int) - 类 javax.swing.table.DefaultTableModel 中的方法
返回列名称。
getColumnName(int) - 接口 javax.swing.table.TableModel 中的方法
返回 columnIndex 位置的列的名称。
getColumnNumber() - 异常 javax.script.ScriptException 中的方法
获取发生错误的列号。
getColumnNumber() - 接口 javax.tools.Diagnostic 中的方法
返回由 Diagnostic.getPosition() 返回的字符偏移量的列号。
getColumnNumber() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getColumnNumber() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回列号（如果可用）。
getColumnNumber() - 接口 javax.xml.stream.Location 中的方法
返回当前事件结束位置的列号，如果没有可用的列号，则返回 -1。
getColumnNumber() - 接口 javax.xml.transform.SourceLocator 中的方法
返回当前文档事件结束的字符位置。
getColumnNumber() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的列号；如果没有可用的列号，则为 -1。
getColumnNumber() - 类 org.xml.sax.helpers.LocatorImpl 中的方法
返回保存的列数（从 1 开始）。
getColumnNumber() - 接口 org.xml.sax.Locator 中的方法
返回当前文档事件结束处的列号。
getColumnNumber() - 异常 org.xml.sax.SAXParseException 中的方法
发生异常的文本结尾的列号。
getColumnPrivileges(String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取用于表列的访问权的描述。
getColumns() - 类 java.awt.GridLayout 中的方法
获取此布局中的列数。
getColumns() - 类 java.awt.TextArea 中的方法
返回此文本区中的列数。
getColumns() - 类 java.awt.TextField 中的方法
获取此文本字段中的列数。
getColumns(String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取可在指定类别中使用的表列的描述。
getColumns() - 类 javax.swing.JTextArea 中的方法
返回 TextArea 中的列数。
getColumns() - 类 javax.swing.JTextField 中的方法
返回此 TextField 中的列数。
getColumns() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回该模型中所有列的一个 Enumeration。
getColumns() - 接口 javax.swing.table.TableColumnModel 中的方法
返回该模型中所有列的 Enumeration。
getColumnSelectionAllowed() - 类 javax.swing.JTable 中的方法
如果可以选择列，则返回 true。
getColumnSelectionAllowed() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
如果允许列选择，则返回 true，否则返回 false。
getColumnSelectionAllowed() - 接口 javax.swing.table.TableColumnModel 中的方法
如果可以选择列，则返回 true。
getColumnType(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的 SQL 类型。
getColumnType(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取存储在指定行中值的 SQL 类型的类型代码（java.sql.Types 常量之一）。
getColumnTypeName(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的数据库特定的类型名称。
getColumnTypeName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取存储在指定列中值的特定于 DBMS 的类型名称。
getColumnWidth() - 类 javax.swing.JTextArea 中的方法
获取列的宽度。
getColumnWidth() - 类 javax.swing.JTextField 中的方法
返回列宽度。
getComboBox() - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法

getComboIcon() - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法

getCommand(String, String) - 类 javax.activation.CommandMap 中的方法
获取与 MIME 类型对应的默认命令。
getCommand(String, String, DataSource) - 类 javax.activation.CommandMap 中的方法
获取与 MIME 类型对应的默认命令。
getCommand(String) - 类 javax.activation.DataHandler 中的方法
获取命令 cmdName。
getCommand(String, String) - 类 javax.activation.MailcapCommandMap 中的方法
针对 MIME 类型获取与 cmdName 对应的命令。
getCommand() - 类 javax.sound.midi.ShortMessage 中的方法
获取与此事件关联的 MIDI 命令。
getCommand() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取作为此 RowSet 对象的命令的 SQL 查询。
getCommand() - 接口 javax.sql.RowSet 中的方法
获取此 RowSet 对象的命令属性。
getCommandClass() - 类 javax.activation.CommandInfo 中的方法
返回命令的类名。
getCommandEnvironment() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
返回组的命令环境控制对象。
getCommandName() - 类 javax.activation.CommandInfo 中的方法
返回命令动词。
getCommandObject(DataHandler, ClassLoader) - 类 javax.activation.CommandInfo 中的方法
返回已实例化的 JavaBean 组件。
getCommandOptions() - 类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 中的方法
取得配置的 java 命令选项。
getCommandPath() - 类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 中的方法
取得配置的限定路径的 java 命令名称。
getComment() - 类 java.net.HttpCookie 中的方法
返回描述此 cookie 用途的注释；如果该 cookie 没有注释，则返回 null。
getComment() - 类 java.util.zip.ZipEntry 中的方法
返回条目的注释字符串；如果没有，则返回 null。
getCommentURL() - 类 java.net.HttpCookie 中的方法
返回描述此 cookie 用途的注释 URL；如果 cookie 没有注释 URL，则返回 null。
getCommitsOnValidEdit() - 类 javax.swing.text.DefaultFormatter 中的方法
返回何时将编辑内容发布回 JFormattedTextField。
getCommitted() - 类 java.lang.management.MemoryUsage 中的方法
返回已提交给 Java 虚拟机使用的内存量（以字节为单位）。
getCommittedCharacterCount() - 类 java.awt.event.InputMethodEvent 中的方法
获取文本中已提交字符的数量。
getCommittedText(int, int, AttributedCharacterIterator.Attribute[]) - 接口 java.awt.im.InputMethodRequests 中的方法
获取提供对文本编辑组件中包含的除未提交文本外整个文本和属性访问的迭代器。
getCommittedTextLength() - 接口 java.awt.im.InputMethodRequests 中的方法
获取文本编辑组件中包含的除未提交（撰写）文本外整个文本的长度。
getComparator(int) - 类 javax.swing.DefaultRowSorter 中的方法
返回指定列的 Comparator。
getComparator() - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回将用于对焦点遍历循环中的 Components 排序的 Comparator。
getComparator(int) - 类 javax.swing.table.TableRowSorter 中的方法
返回指定列的 Comparator。
getCompilationMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机的编译系统的管理 Bean。
getCompletedTaskCount() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回已完成执行的近似任务总数。
getCompletions(Element, AnnotationMirror, ExecutableElement, String) - 类 javax.annotation.processing.AbstractProcessor 中的方法
返回一个空的 completion 迭代。
getCompletions(Element, AnnotationMirror, ExecutableElement, String) - 接口 javax.annotation.processing.Processor 中的方法
向工具框架返回某一注释的建议 completion 迭代。
getComponent(int) - 类 java.awt.Container 中的方法
获取此容器中的第 n 个组件。
getComponent() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回与此 DragGestureEvent 关联的 Component。
getComponent() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
此方法返回 DragGestureRecognizer 所“观察”的 Component，以便了解拖动开始动作。
getComponent() - 类 java.awt.dnd.DragSourceContext 中的方法
返回与此 DragSourceContext 关联的 Component。
getComponent() - 类 java.awt.dnd.DropTarget 中的方法
获取与此 DropTarget 关联的 Component。
getComponent() - 类 java.awt.dnd.DropTargetContext 中的方法
此方法返回与此 DropTargetContext 相关的 Component。
getComponent() - 类 java.awt.event.ComponentEvent 中的方法
返回事件的始发者。
getComponent() - 类 java.awt.event.HierarchyEvent 中的方法
返回事件的始发者。
getComponent() - 接口 java.beans.beancontext.BeanContextChildComponentProxy 中的方法
获得与此 BeanContextChild 相关联的 java.awt.Component。
getComponent() - 类 javax.swing.ComponentInputMap 中的方法
返回为其创建 InputMap 的组件。
getComponent() - 类 javax.swing.DefaultCellEditor 中的方法
返回对编辑器组件的引用。
getComponent() - 类 javax.swing.event.AncestorEvent 中的方法
返回添加了侦听器的组件。
getComponent() - 类 javax.swing.JMenu 中的方法
返回用于绘制此 MenuElement 的 java.awt.Component。
getComponent() - 类 javax.swing.JMenuBar 中的方法
实现为 MenuElement。
getComponent() - 类 javax.swing.JMenuItem 中的方法
返回用于绘制此对象的 java.awt.Component。
getComponent() - 类 javax.swing.JPopupMenu 中的方法
返回此 JPopupMenu 组件。
getComponent() - 类 javax.swing.JToolTip 中的方法
返回工具提示所描述的组件。
getComponent() - 接口 javax.swing.MenuElement 中的方法
此方法应返回用于绘制接收元素的 java.awt.Component。
getComponent() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取与此 UI 实现关联的文本组件。
getComponent() - 类 javax.swing.plaf.synth.SynthContext 中的方法
返回包含 region 的承载组件。
getComponent() - 接口 javax.swing.Renderer 中的方法
返回用于呈现该值的组件。
getComponent() - 类 javax.swing.text.ComponentView 中的方法
获取与此视图关联的组件。
getComponent() - 类 javax.swing.text.DefaultCaret 中的方法
获取此插入符所绑定的文本编辑器组件。
getComponent(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取组件设置。
getComponent() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
返回此传输的目标组件。
getComponentAfter(Container, Component) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回应该接收 aComponent 后面的焦点的 Component。
getComponentAfter(Container, Component) - 类 java.awt.FocusTraversalPolicy 中的方法
返回应该接收 aComponent 之后的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或者焦点遍历策略提供者。
getComponentAfter(Container, Component) - 类 javax.swing.DefaultFocusManager 中的方法

getComponentAfter(Container, Component) - 类 javax.swing.LayoutFocusTraversalPolicy 中的方法
返回应在 aComponent 之后接收焦点的 Component。
getComponentAfter(Container, Component) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回应该接收 aComponent 后面的焦点的 Component。
getComponentAt(int, int) - 类 java.awt.Component 中的方法
确定此组件或其直接子组件之一是否包含（x，y）位置，并且如果是，则返回包含该位置的组件。
getComponentAt(Point) - 类 java.awt.Component 中的方法
返回包含指定点的组件或子组件。
getComponentAt(int, int) - 类 java.awt.Container 中的方法
对包含 x，y 位置的组件进行定位。
getComponentAt(Point) - 类 java.awt.Container 中的方法
获取包含指定点的组件。
getComponentAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的组件。
getComponentAtIndex(int) - 类 javax.swing.JMenuBar 中的方法
已过时。 由 getComponent(int i) 取代
getComponentAtIndex(int) - 类 javax.swing.JPopupMenu 中的方法
已过时。 由 Container.getComponent(int) 取代
getComponentAtIndex(int) - 类 javax.swing.JToolBar 中的方法
返回指定索引位置的组件。
getComponentBefore(Container, Component) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回应该接收 aComponent 前面的焦点的 Component。
getComponentBefore(Container, Component) - 类 java.awt.FocusTraversalPolicy 中的方法
返回应该接收 aComponent 之前的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或焦点遍历策略提供者。
getComponentBefore(Container, Component) - 类 javax.swing.DefaultFocusManager 中的方法

getComponentBefore(Container, Component) - 类 javax.swing.LayoutFocusTraversalPolicy 中的方法
返回应在 aComponent 之前接收焦点的 Component。
getComponentBefore(Container, Component) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回应该接收 aComponent 前面的焦点的 Component。
getComponentCount() - 类 java.awt.Container 中的方法
获取此面板中的组件数。
getComponentCountInLayer(int) - 类 javax.swing.JLayeredPane 中的方法
返回指定层中当前的子组件数。
getComponentGraphics(Graphics) - 类 javax.swing.JComponent 中的方法
返回用于绘制此组件的图形对象。
getComponentIndex(Component) - 类 javax.swing.JMenuBar 中的方法
返回指定组件的索引。
getComponentIndex(Component) - 类 javax.swing.JPopupMenu 中的方法
返回指定组件的索引。
getComponentIndex(Component) - 类 javax.swing.JToolBar 中的方法
返回指定组件的索引。
getComponentListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的组件侦听器的数组。
getComponentOrientation() - 类 java.awt.Component 中的方法
检索将用于排序此组件内的元素或文本的语言敏感的方向。
getComponentPopupMenu() - 类 javax.swing.JComponent 中的方法
返回为此组件分配的 JPopupMenu。
getComponents(float[]) - 类 java.awt.Color 中的方法
根据 Color 的 ColorSpace，返回一个 float 数组，该数组包含 Color 的颜色分量和 alpha 分量。
getComponents(ColorSpace, float[]) - 类 java.awt.Color 中的方法
根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的 alpha 分量。
getComponents() - 类 java.awt.Container 中的方法
获取此容器中的所有组件。
getComponents(int, int[], int) - 类 java.awt.image.ColorModel 中的方法
返回在 ColorModel 中已给定像素的非标准化颜色/alpha 分量。
getComponents(Object, int[], int) - 类 java.awt.image.ColorModel 中的方法
返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。
getComponents(int, int[], int) - 类 java.awt.image.ComponentColorModel 中的方法
返回在 ColorModel 中已给定像素的非标准化颜色/alpha 分量。
getComponents(Object, int[], int) - 类 java.awt.image.ComponentColorModel 中的方法
返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。
getComponents(int, int[], int) - 类 java.awt.image.DirectColorModel 中的方法
返回在 ColorModel 中已给定像素的未标准化颜色/alpha 分量。
getComponents(Object, int[], int) - 类 java.awt.image.DirectColorModel 中的方法
返回在 ColorModel 中已给定像素的未标准化颜色/alpha 分量。
getComponents(int, int[], int) - 类 java.awt.image.IndexColorModel 中的方法
返回此 ColorModel 中指定像素的非标准化颜色/alpha 分量数组。
getComponents(Object, int[], int) - 类 java.awt.image.IndexColorModel 中的方法
返回此 ColorModel 中指定像素的非标准化颜色/alpha 分量数组。
getComponentsInLayer(int) - 类 javax.swing.JLayeredPane 中的方法
返回指定层中组件的数组。
getComponentSize(int) - 类 java.awt.image.ColorModel 中的方法
返回指定颜色/alpha 分量的位数。
getComponentSize() - 类 java.awt.image.ColorModel 中的方法
返回每个颜色/alpha 分量的位数数组。
getComponentSize() - 类 java.awt.image.IndexColorModel 中的方法
返回包含各个颜色/alpha 分量位数的数组。
getComponentState() - 类 javax.swing.plaf.synth.SynthContext 中的方法
返回窗口小部件的状态，它是 SynthConstants 中定义的值的位掩码。
getComponentToLayer() - 类 javax.swing.JLayeredPane 中的方法
返回将组件映射到层的哈希表。
getComponentType() - 类 java.lang.Class 中的方法
返回表示数组组件类型的 Class。
getComponentType() - 接口 javax.lang.model.type.ArrayType 中的方法
返回此数组类型的组件类型。
getComponentZOrder(Component) - 类 java.awt.Container 中的方法
返回容器内组件的 z 顺序索引。
getComposite() - 类 java.awt.Graphics2D 中的方法
返回 Graphics2D 上下文中的当前 Composite
getCompositeData() - 类 javax.management.openmbean.CompositeDataInvocationHandler 中的方法
返回提供给构造方法的 CompositeData。
getCompositeType() - 接口 javax.management.openmbean.CompositeData 中的方法
返回此复合数据 实例的复合类型。
getCompositeType() - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回此复合数据 实例的复合类型。
getCompressedSize() - 类 java.util.zip.ZipEntry 中的方法
返回压缩条目数据的大小；如果未知，则返回 -1。
getCompressionMode() - 类 javax.imageio.ImageWriteParam 中的方法
如果支持压缩，则返回当前压缩模式。
getCompressionQuality() - 类 javax.imageio.ImageWriteParam 中的方法
返回当前压缩质量设置。
getCompressionQualityDescriptions() - 类 javax.imageio.ImageWriteParam 中的方法
返回一个 String 数组，可作为用户界面的一部分与 getCompressionQualityValues 一起使用，以设置或显示压缩质量级别。
getCompressionQualityDescriptions() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法

getCompressionQualityValues() - 类 javax.imageio.ImageWriteParam 中的方法
返回一个 float 数组，可作为用户界面的一部分与 getCompressionQualityDescriptions 一起使用，以设置或显示压缩质量级别。
getCompressionQualityValues() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法

getCompressionThreshold() - 类 javax.swing.text.StyleContext 中的方法
返回键/值对的最大数目，尝试将其压缩到一个惟一/不可变的集合中。
getCompressionType() - 类 javax.imageio.ImageWriteParam 中的方法
返回当前设置的压缩类型，如果没有设置任何压缩类型，则返回 null。
getCompressionTypes() - 类 javax.imageio.ImageWriteParam 中的方法
以数组或 String 形式返回可用压缩类型的列表，如果不能使用这些接口选择压缩类型，则返回 null。
getConcurrency() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的并发模式。
getConcurrency() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回此 RowSet 对象的并发性。
getConditionForKeyStroke(KeyStroke) - 类 javax.swing.JComponent 中的方法
返回确定是否发生已注册动作以响应指定键击事件的条件。
getConfiguration() - 类 javax.security.auth.login.Configuration 中的静态方法
获取已安装的登录 Configuration。
getConfigurations() - 类 java.awt.GraphicsDevice 中的方法
返回与此 GraphicsDevice 关联的所有 GraphicsConfiguration 对象。
getConflictValue(int) - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。
getConflictValue(String) - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。
getConfState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定数据机密性是否可用于上下文。
getConnectControls() - 类 javax.naming.ldap.InitialLdapContext 中的方法

getConnectControls() - 接口 javax.naming.ldap.LdapContext 中的方法
检索对此上下文有效的连接请求控件。
getConnection() - 接口 java.sql.DatabaseMetaData 中的方法
获取此元数据对象所产生的连接。
getConnection(String, Properties) - 类 java.sql.DriverManager 中的静态方法
试图建立到给定数据库 URL 的连接。
getConnection(String, String, String) - 类 java.sql.DriverManager 中的静态方法
试图建立到给定数据库 URL 的连接。
getConnection(String) - 类 java.sql.DriverManager 中的静态方法
试图建立到给定数据库 URL 的连接。
getConnection() - 接口 java.sql.Statement 中的方法
获取生成此 Statement 对象的 Connection 对象。
getConnection() - 接口 javax.sql.DataSource 中的方法
尝试建立与此 DataSource 对象所表示的数据源的连接。
getConnection(String, String) - 接口 javax.sql.DataSource 中的方法
尝试建立与此 DataSource 对象所表示的数据源的连接。
getConnection() - 接口 javax.sql.PooledConnection 中的方法
创建并返回一个 Connection 对象，它是此 PooledConnection 对象表示的物理连接的句柄。
getConnection() - 接口 javax.sql.RowSetInternal 中的方法
获取传递给此 RowSet 对象的 Connection 对象。
getConnectionId() - 类 javax.management.remote.JMXConnectionNotification 中的方法
该通知所属连接的连接 ID。
getConnectionId() - 接口 javax.management.remote.JMXConnector 中的方法
获得来自连接器服务器的连接 ID。
getConnectionId() - 接口 javax.management.remote.rmi.RMIConnection 中的方法
返回连接 ID。
getConnectionId() - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getConnectionId() - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getConnectionId() - 类 javax.management.remote.rmi.RMIConnector 中的方法

getConnectionIds() - 类 javax.management.remote.JMXConnectorServer 中的方法

getConnectionIds() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
当前打开的到此连接器服务器的连接 ID 列表。
getConnectTimeout() - 类 java.net.URLConnection 中的方法
返回连接超时设置。
getConstantExpression(Object) - 接口 javax.lang.model.util.Elements 中的方法
返回表示基本值或字符串的常量表达式 文本。
getConstantValue() - 接口 javax.lang.model.element.VariableElement 中的方法
如果此变量是一个被初始化为编译时常量的 static final 字段，则返回此变量的值。
getConstraint(String) - 类 javax.swing.SpringLayout.Constraints 中的方法
返回指定边的值，它可以为一个派生值，甚至可以为 null。
getConstraint(String, Component) - 类 javax.swing.SpringLayout 中的方法
返回控制该组件指定边及其父级的顶边或左边之间距离的 spring。
getConstraints(Component) - 类 java.awt.BorderLayout 中的方法
获取指定组件的约束
getConstraints(Component) - 类 java.awt.GridBagLayout 中的方法
获取指定组件的约束。
getConstraints(Component) - 类 javax.swing.SpringLayout 中的方法
返回指定组件的约束。
getConstructor(Class<?>...) - 类 java.lang.Class 中的方法
返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
getConstructor(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
返回通过名称请求的 ModelMBeanConstructorInfo。
getConstructors() - 类 java.lang.Class 中的方法
返回一个包含某些 Constructor 对象的数组，这些对象反映此 Class 对象所表示的类的所有公共构造方法。
getConstructors() - 类 javax.management.MBeanInfo 中的方法
返回 MBean 的公共构造方法列表。
getConstructors() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回 MBean 的公共构造方法列表。
getConstructors() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回 OpenMBeanConstructorInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个构造方法。
getConstructors(MBeanConstructorInfo[], Object) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 MBeanConstructorInfo[]。
getContainer() - 类 java.awt.event.ContainerEvent 中的方法
返回事件的始发者。
getContainer() - 接口 java.beans.beancontext.BeanContextContainerProxy 中的方法
获得与此 BeanContext 相关联的 java.awt.Container。
getContainer() - 类 javax.swing.text.View 中的方法
获取承载视图的容器。
getContainerGap(JComponent, int, Container) - 类 javax.swing.LayoutStyle 中的方法
返回组件与其父容器的指定边缘之间放置的空格数量。
getContainerListeners() - 类 java.awt.Container 中的方法
返回已在此容器上注册的所有容器侦听器的数组。
getContent(URLConnection) - 类 java.net.ContentHandler 中的方法
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并根据其创建对象。
getContent(URLConnection, Class[]) - 类 java.net.ContentHandler 中的方法
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。
getContent() - 类 java.net.URL 中的方法
获取此 URL 的内容。
getContent(Class[]) - 类 java.net.URL 中的方法
获取此 URL 的内容。
getContent() - 类 java.net.URLConnection 中的方法
获取此 URL 连接的内容。
getContent(Class[]) - 类 java.net.URLConnection 中的方法
获取此 URL 连接的内容。
getContent(DataSource) - 接口 javax.activation.DataContentHandler 中的方法
返回一个对象，该对象表示其首选形式的数据。
getContent() - 类 javax.activation.DataHandler 中的方法
以其首选 Object 的形式返回数据。
getContent() - 类 javax.naming.BinaryRefAddr 中的方法
以 Object 形式检索此地址的内容。
getContent() - 类 javax.naming.RefAddr 中的方法
检索此地址的内容。
getContent() - 类 javax.naming.StringRefAddr 中的方法
检索此地址的内容。
getContent() - 类 javax.swing.text.AbstractDocument 中的方法
获得文档的内容。
getContent() - 类 javax.swing.text.html.parser.Element 中的方法
获取内容模式
getContent() - 接口 javax.xml.crypto.dsig.keyinfo.KeyInfo 中的方法
返回包含密钥信息的 unmodifiable list。
getContent() - 接口 javax.xml.crypto.dsig.keyinfo.X509Data 中的方法
返回一个不可修改的列表，由此 X509Data 的内容组成。
getContent() - 接口 javax.xml.crypto.dsig.SignatureProperty 中的方法
返回一个不可修改的列表，由包含在此 SignatureProperty 中的一个或多个 XMLStructure 组成。
getContent() - 接口 javax.xml.crypto.dsig.XMLObject 中的方法
返回一个可修改列表，由包含在此 XMLObject 中的 XMLStructure 组成，其中 XMLObject 表示来自任何命名空间的元素。
getContent() - 类 javax.xml.soap.AttachmentPart 中的方法
以 Java 对象的形式获取此 AttachmentPart 对象的内容。
getContent() - 类 javax.xml.soap.SOAPPart 中的方法
以 JAXP Source 对象的形式返回 SOAPEnvelope 的内容。
getContentBorderInsets(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getContentDescription() - 类 javax.xml.soap.SOAPMessage 中的方法
检索此 SOAPMessage 对象内容的描述。
getContentEncoding() - 类 java.net.URLConnection 中的方法
返回 content-encoding 头字段的值。
getContentHandler() - 类 javax.xml.validation.ValidatorHandler 中的方法
获取接收扩充的验证结果的 ContentHandler。
getContentHandler() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
返回当前内容处理程序。
getContentHandler() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
获取内容事件处理程序。
getContentHandler() - 接口 org.xml.sax.XMLReader 中的方法
返回当前的内容处理程序。
getContentId() - 类 javax.xml.soap.AttachmentPart 中的方法
获取名为 "Content-ID" 的 MIME 头的值。
getContentId() - 类 javax.xml.soap.SOAPPart 中的方法
检索名为 "Content-Id" 的 MIME 头的值。
getContentLength() - 类 java.net.URLConnection 中的方法
返回 content-length 头字段的值。
getContentLocation() - 类 javax.xml.soap.AttachmentPart 中的方法
获取名为 "Content-Location" 的 MIME 头的值。
getContentLocation() - 类 javax.xml.soap.SOAPPart 中的方法
检索名为 "Content-Location" 的 MIME 头的值。
getContentPane() - 类 javax.swing.JApplet 中的方法
返回此 applet 的 contentPane 对象。
getContentPane() - 类 javax.swing.JDialog 中的方法
返回此对话框的 contentPane 对象。
getContentPane() - 类 javax.swing.JFrame 中的方法
返回此窗体的 contentPane 对象
getContentPane() - 类 javax.swing.JInternalFrame 中的方法
返回此内部窗体的内容窗格。
getContentPane() - 类 javax.swing.JRootPane 中的方法
返回内容窗格，它是保存以根窗格为父级的组件的容器。
getContentPane() - 类 javax.swing.JWindow 中的方法
返回作为此窗口的 contentPane 的 Container。
getContentPane() - 接口 javax.swing.RootPaneContainer 中的方法
返回 contentPane。
getContents(Object) - 类 java.awt.datatransfer.Clipboard 中的方法
返回表示剪贴板当前内容的 transferable 对象。
getContents() - 类 java.util.ListResourceBundle 中的方法
返回一个数组，其中 Object 数组中的每个项都是一个对象对。
getContents() - 类 javax.accessibility.AccessibleResourceBundle 中的方法
已过时。 返回编程键和本地化显示字符串之间的映射关系。
getContentType() - 类 java.net.URLConnection 中的方法
返回 content-type 头字段的值。
getContentType() - 类 javax.activation.DataHandler 中的方法
返回从源对象中获取的此对象的 MIME 类型。
getContentType() - 接口 javax.activation.DataSource 中的方法
此方法以字符串形式返回数据的 MIME 类型。
getContentType() - 类 javax.activation.FileDataSource 中的方法
此方法以字符串形式返回数据的 MIME 类型。
getContentType(File) - 类 javax.activation.FileTypeMap 中的方法
返回文件对象的类型。
getContentType(String) - 类 javax.activation.FileTypeMap 中的方法
返回传入文件的类型。
getContentType(File) - 类 javax.activation.MimetypesFileTypeMap 中的方法
返回该文件对象的 MIME 类型。
getContentType(String) - 类 javax.activation.MimetypesFileTypeMap 中的方法
返回基于指定文件名的 MIME 类型。
getContentType() - 类 javax.activation.URLDataSource 中的方法
返回 URL 内容-类型 (content-type) 头字段的值。
getContentType() - 类 javax.swing.JEditorPane 中的方法
获得设置此编辑器当前要处理的内容类型。
getContentType() - 类 javax.swing.text.DefaultEditorKit 中的方法
获取此工具包声明支持的数据的 MIME 类型。
getContentType() - 类 javax.swing.text.EditorKit 中的方法
获得此工具包声明支持的数据的 MIME 类型。
getContentType() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取此工具包支持的 MIME 类型的数据。
getContentType() - 类 javax.swing.text.rtf.RTFEditorKit 中的方法
获取此工具包支持的 MIME 类型的数据。
getContentType() - 类 javax.xml.soap.AttachmentPart 中的方法
获取名为 "Content-Type" 的 MIME 头的值。
getContentTypeFor(String) - 接口 java.net.FileNameMap 中的方法
获取指定文件名的 MIME 类型。
getContext() - 类 java.security.AccessController 中的静态方法
此方法获取当前调用上下文（包括当前 Thread 的继承 AccessControlContext）的“快照”，并将其置于 AccessControlContext 对象中。
getContext() - 类 javax.script.AbstractScriptEngine 中的方法
返回受保护 context 字段的值。
getContext() - 接口 javax.script.ScriptEngine 中的方法
返回 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。
getContext() - 接口 javax.xml.ws.Response 中的方法
获取所含的响应上下文。
getContextClassLoader() - 类 java.lang.Thread 中的方法
返回该线程的上下文 ClassLoader。
getContextualShaper(int) - 类 java.awt.font.NumericShaper 中的静态方法
返回提供的 unicode 范围的上下文成形器。
getContextualShaper(int, int) - 类 java.awt.font.NumericShaper 中的静态方法
返回提供的 unicode 范围的上下文成形器。
getContinuationContext(CannotProceedException) - 类 javax.naming.spi.NamingManager 中的静态方法
创建一个将继续上下文操作的上下文。
getContinuationDirContext(CannotProceedException) - 类 javax.naming.spi.DirectoryManager 中的静态方法
创建一个将继续某个 DirContext 操作的上下文。
getContinueExistingPeriodicTasksAfterShutdownPolicy() - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
获取有关在此执行程序已 shutdown 的情况下、是否继续执行现有定期任务的策略。
getControl(List<String>) - 类 java.util.ResourceBundle.Control 中的静态方法
返回 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats。
getControl(Control.Type) - 接口 javax.sound.sampled.Line 中的方法
获得指定类型的控件，如果有的话。
getControl() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件颜色。
getControl() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件颜色。
getControlButtonsAreShown() - 类 javax.swing.JFileChooser 中的方法
返回 controlButtonsAreShown 属性的值。
getControlDarkShadow() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件加黑阴影颜色。
getControlDarkShadow() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件加黑阴影颜色。
getControlDisabled() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件禁用颜色。
getControlDisabled() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件禁用的颜色。
getControlFlag() - 类 javax.security.auth.login.AppConfigurationEntry 中的方法
返回此 LoginModule 的 controlFlag（REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL 中的任何一个）。
getControlHighlight() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件高亮显示颜色。
getControlHighlight() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件高亮显示颜色。
getControlInfo() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件信息颜色。
getControlInfo() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件信息颜色。
getControlInstance(Control) - 类 javax.naming.ldap.ControlFactory 中的方法
使用此控件工厂创建控件。
getControlInstance(Control, Context, Hashtable<?, ?>) - 类 javax.naming.ldap.ControlFactory 中的静态方法
使用已知控件工厂创建控件。
getController() - 类 javax.imageio.IIOParam 中的方法
返回当前已安装的所有 IIOParamController。
getController() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回当前已安装的所有 IIOMetadataController。
getController(int) - 接口 javax.sound.midi.MidiChannel 中的方法
获得指定控件的当前值。
getControlObject() - 接口 java.awt.im.spi.InputMethod 中的方法
从此输入方法返回一个控制对象，或 null。
getControls() - 接口 javax.naming.ldap.HasControls 中的方法
从实现此接口的对象中检索 Control 数组。
getControls() - 接口 javax.sound.sampled.Line 中的方法
获得与此行相关的控件集合。
getControlShadow() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件阴影颜色。
getControlShadow() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件阴影颜色。
getControlSize() - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 中的方法

getControlTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件文本颜色。
getControlTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件文本颜色。
getControlTextColor() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回控件文本颜色。
getControlTextFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回控件文本字体。
getControlTextFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件文本字体。
getControlTextFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件文本字体。
getConversion() - 异常 java.util.FormatFlagsConversionMismatchException 中的方法
返回不兼容的转换。
getConversion() - 异常 java.util.IllegalFormatConversionException 中的方法
返回不适用的转换。
getConversion() - 异常 java.util.UnknownFormatConversionException 中的方法
返回未知的转换。
getCookie() - 类 javax.naming.ldap.PagedResultsResponseControl 中的方法
检索服务器生成的 cookie。
getCookies() - 接口 java.net.CookieStore 中的方法
获取 cookie 存储区中所有未过期的 cookie。
getCookieStore() - 类 java.net.CookieManager 中的方法
获取当前 cookie 存储区。
getCopies() - 类 java.awt.JobAttributes 中的方法
返回应用程序应该使用这些属性呈现作业的份数。
getCopies() - 类 java.awt.print.PrinterJob 中的方法
获取要打印的副本数。
getCopyAction() - 类 javax.swing.TransferHandler 中的静态方法
返回一个执行复制到剪贴板操作的 Action。
getCorePoolSize() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回核心线程数。
getCorner(String) - 类 javax.swing.JScrollPane 中的方法
返回位于指定角的组件。
getCorner(String) - 类 javax.swing.ScrollPaneLayout 中的方法
返回位于指定角的 Component。
getCount() - 类 java.lang.management.MemoryNotificationInfo 中的方法
返回构造通知时内存使用量超过阈值的次数。
getCount() - 类 java.util.concurrent.CountDownLatch 中的方法
返回当前计数。
getCountLimit() - 类 javax.naming.directory.SearchControls 中的方法
检索将作为搜索结果返回的最大项数。
getCountry() - 类 java.util.Locale 中的方法
返回此语言环境的国家/地区代码，将为空字符串或大写的 ISO 3166 两字母代码。
getCrc() - 类 java.util.zip.ZipEntry 中的方法
返回未压缩条目数据的 CRC-32 校验和；如果未知，则返回 -1。
getCreationDate(String) - 类 java.security.KeyStore 中的方法
返回给定别名标识的条目的创建日期。
getCreationTime() - 接口 javax.net.ssl.SSLSession 中的方法
返回创建此会话表示的时间，该时间是自协调世界时 1970 年 1 月 1 日午夜起经过的毫秒数。
getCredDelegState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定是否在此上下文上启用凭据委托。
getCredentialClass() - 类 javax.security.auth.PrivateCredentialPermission 中的方法
返回与此 PrivateCredentialPermission 相关联的 Credential 的 Class 名称。
getCriticalExtensionOIDs() - 接口 java.security.cert.X509Extension 中的方法
获取实现此接口的对象所管理的证书/CRL 中，被标记为 CRITICAL 的扩展的 OID 字符串 Set。
getCRLs(CRLSelector) - 类 java.security.cert.CertStore 中的方法
返回与指定选择器匹配的 CRL 的 Collection。
getCrossFeedResolution(int) - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回给定单位的此分辨率属性的反向进纸分辨率。
getCrossFeedResolutionDphi() - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回以 dphi 为单位的此分辨率属性的反向进纸分辨率。
getCrossPlatformLookAndFeelClassName() - 类 javax.swing.UIManager 中的静态方法
返回实现默认的跨平台外观 -- Java Look and Feel (JLF) -- 的 LookAndFeel 类的名称。
getCrossReference(String, String, String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取给定外键列表中外键列的描述，这些列引用主键或表示父表（可能是相同的表，也可能是不同的表）唯一约束的列。
getCrtCoefficient() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 crtCoefficient。
getCrtCoefficient() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回 crtCoefficient。
getCrtCoefficient() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 crtCoefficient。
getCrtCoefficient() - 类 java.security.spec.RSAOtherPrimeInfo 中的方法
返回素数的 crtCoefficient。
getCrtCoefficient() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回 crtCoefficient。
getCtrlKey() - 接口 org.w3c.dom.events.MouseEvent 中的方法
用于指示在触发事件事件期间是否按下 'ctrl' 键。
getCtrlP1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
返回第一个控制点。
getCtrlP1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
返回第一个控制点。
getCtrlP1() - 类 java.awt.geom.CubicCurve2D 中的方法
返回第一个控制点。
getCtrlP2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
返回第二个控制点。
getCtrlP2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
返回第二个控制点。
getCtrlP2() - 类 java.awt.geom.CubicCurve2D 中的方法
返回第二个控制点。
getCtrlPt() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
返回控制点。
getCtrlPt() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
返回控制点。
getCtrlPt() - 类 java.awt.geom.QuadCurve2D 中的方法
返回控制点。
getCtrlX() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回控制点的 X 坐标。
getCtrlX() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回控制点的 X 坐标。
getCtrlX() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回控制点的 X 坐标。
getCtrlX1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回第一个控制点的 X 坐标。
getCtrlX1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回第一个控制点的 X 坐标。
getCtrlX1() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回第一个控制点的 X 坐标。
getCtrlX2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回第二个控制点的 X 坐标。
getCtrlX2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回第二个控制点的 X 坐标。
getCtrlX2() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回第二个控制点的 X 坐标。
getCtrlY() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回控制点的 Y 坐标。
getCtrlY() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回控制点的 Y 坐标。
getCtrlY() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回控制点的 Y 坐标。
getCtrlY1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回第一个控制点的 Y 坐标。
getCtrlY1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回第一个控制点的 Y 坐标。
getCtrlY1() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回第一个控制点的 Y 坐标。
getCtrlY2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回第二个控制点的 Y 坐标。
getCtrlY2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回第二个控制点的 Y 坐标。
getCtrlY2() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回第二个控制点的 Y 坐标。
getCurrency() - 类 java.text.DecimalFormat 中的方法
获取格式化货币值时，此十进制格式使用的货币。
getCurrency() - 类 java.text.DecimalFormatSymbols 中的方法
获得这些 DecimalFormatSymbols 的货币。
getCurrency() - 类 java.text.NumberFormat 中的方法
获取格式化货币值时此数值格式使用的货币。
getCurrencyCode() - 类 java.util.Currency 中的方法
获取此货币的 ISO 4217 货币代码。
getCurrencyInstance() - 类 java.text.NumberFormat 中的静态方法
返回当前默认语言环境的货币格式。
getCurrencyInstance(Locale) - 类 java.text.NumberFormat 中的静态方法
返回指定语言环境的货币格式。
getCurrencyInstance(Locale) - 类 java.text.spi.NumberFormatProvider 中的方法
返回新的 NumberFormat 实例，此实例为指定的语言环境格式化货币价值。
getCurrencySymbol() - 类 java.text.DecimalFormatSymbols 中的方法
返回这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。
getCurrent() - 类 java.awt.CheckboxGroup 中的方法
已过时。 从 JDK version 1.1 开始，由 getSelectedCheckbox() 取代。
getCurrentAccessibleContext() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取表单元格渲染器的 AccessibleContext。
getCurrentAccessibleValue() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取此对象的值，它是一个 Number。
getCurrentAccessibleValue() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取此对象的值，它是一个 Number。
getCurrentAccessibleValue() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取此对象的值，它是一个 Number。
getCurrentAccessibleValue() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
以数字形式获取此对象的值。
getCurrentAccessibleValue() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获取此对象的可访问值。
getCurrentAccessibleValue() - 接口 javax.accessibility.AccessibleValue 中的方法
以 Number 形式获取此对象的值。
getCurrentAccessibleValue() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
以 Number 形式获取此对象的值。
getCurrentAccessibleValue() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
以 Number 形式获取此对象的值。
getCurrentAccessibleValue() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
以 Number 形式获取此对象的值。
getCurrentAccessibleValue() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获取此对象的可访问值。
getCurrentAccessibleValue() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取此对象的可访问值。
getCurrentAccessibleValue() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取此对象的可访问值。
getCurrentAccessibleValue() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取此对象数字形式的值。
getCurrentAccessibleValue() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取此对象的可访问值。
getCurrentComponent() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取表单元格渲染器组件。
getCurrentDataFlavors() - 类 java.awt.dnd.DropTargetContext 中的方法
获取此操作的 Transferable 操作数的可用 DataFlavor。
getCurrentDataFlavors() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回来自 DropTargetContext 的当前 DataFlavor。
getCurrentDataFlavors() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回当前的 DataFlavor。
getCurrentDataFlavorsAsList() - 类 java.awt.dnd.DropTargetContext 中的方法
此方法返回 Transferable 操作数当前可用的 DataFlavor，作为一个 java.util.List。
getCurrentDataFlavorsAsList() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法以 java.util.List 形式返回当前的 DataFlavor
getCurrentDataFlavorsAsList() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法以 java.util.List 形式返回当前可用的 DataFlavor。
getCurrentDirectory() - 类 javax.swing.JFileChooser 中的方法
返回当前目录。
getCurrentEvent() - 类 java.awt.EventQueue 中的静态方法
返回当前正在被 EventQueue（它与正在调用的线程相关）指派的事件。
getCurrentFocusCycleRoot() - 类 java.awt.KeyboardFocusManager 中的方法
如果当前焦点循环根与调用线程位于相同的上下文中，则返回当前焦点循环根。
getCurrentKeyboardFocusManager() - 类 java.awt.KeyboardFocusManager 中的静态方法
返回调用线程上下文的当前 KeyboardFocusManager 实例。
getCurrentLine() - 类 javax.swing.text.html.parser.Parser 中的方法

getCurrentLineLength() - 类 javax.swing.text.AbstractWriter 中的方法
返回当前行的长度。
getCurrentManager() - 类 javax.swing.FocusManager 中的静态方法
返回调用线程上下文的当前 KeyboardFocusManager 实例。
getCurrentPoint() - 类 java.awt.geom.Path2D 中的方法
返回最近添加到路径尾部的坐标（以 Point2D 对象形式）。
getCurrentPos() - 类 javax.swing.text.html.parser.Parser 中的方法

getCurrentServiceClasses() - 接口 java.beans.beancontext.BeanContextServices 中的方法
获得此上下文的当前可用服务。
getCurrentServiceClasses() - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法

getCurrentServiceSelectors() - 类 java.beans.beancontext.BeanContextServiceAvailableEvent 中的方法
获得与服务相关的选择器列表。
getCurrentServiceSelectors(BeanContextServices, Class) - 接口 java.beans.beancontext.BeanContextServiceProvider 中的方法
由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。
getCurrentServiceSelectors(Class) - 接口 java.beans.beancontext.BeanContextServices 中的方法
通过在基础 BeanContextServiceProvider 上调用 getCurrentServiceSelectors() 获得指定服务的与服务有关的服务参数列表（服务选择器）。
getCurrentServiceSelectors(BeanContextServices, Class) - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider 中的方法

getCurrentServiceSelectors(Class) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法

getCurrentTarget() - 接口 org.w3c.dom.events.Event 中的方法
用于指示当前正在处理其 EventListeners 的 EventTarget。
getCurrentTheme() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回 MetalLookAndFeel 当前正在使用的主题。
getCurrentThreadCpuTime() - 接口 java.lang.management.ThreadMXBean 中的方法
返回当前线程的总 CPU 时间（以毫微秒为单位）。
getCurrentThreadUserTime() - 接口 java.lang.management.ThreadMXBean 中的方法
返回当前线程在用户模式中执行的 CPU 时间（以毫微秒为单位）。
getCurrentWriter() - 类 javax.swing.text.AbstractDocument 中的方法
获取当前的写入线程（如果有的话）。
getCursor() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的 Cursor。
getCursor() - 类 java.awt.Component 中的方法
获取组件中的光标集合。
getCursor() - 类 java.awt.dnd.DragSourceContext 中的方法
返回当前的拖动 Cursor
getCursor() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的 Cursor。
getCursor() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的 Cursor。
getCursor() - 接口 javax.accessibility.AccessibleComponent 中的方法
获取此对象的 Cursor。
getCursor() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getCursor() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的 Cursor。
getCursor() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getCursor() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getCursorName() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象使用的 SQL 光标的名称。
getCursorType() - 类 java.awt.Frame 中的方法
已过时。 从 JDK version 1.1 开始，由 Component.getCursor() 取代。
getCurve() - 类 java.security.spec.ECParameterSpec 中的方法
返回此参数定义的椭圆曲线。
getCustomEditor() - 接口 java.beans.PropertyEditor 中的方法
PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。
getCustomEditor() - 类 java.beans.PropertyEditorSupport 中的方法
PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。
getCustomizerClass() - 类 java.beans.BeanDescriptor 中的方法
获得 bean 的 customizer 的 Class 对象。
getCutAction() - 类 javax.swing.TransferHandler 中的静态方法
返回一个执行剪切到剪贴板操作的 Action。
getCycleMethod() - 类 java.awt.MultipleGradientPaint 中的方法
返回指定循环行为的枚举类型。
getDaemonThreadCount() - 接口 java.lang.management.ThreadMXBean 中的方法
返回活动守护线程的当前数目。
getDashArray() - 类 java.awt.BasicStroke 中的方法
返回表示虚线线段长度的数组。
getDashPhase() - 类 java.awt.BasicStroke 中的方法
返回当前虚线相位。
getData() - 类 java.awt.color.ICC_Profile 中的方法
返回与 ICC_Profile 数据相对应的 byte 数组。
getData(int) - 类 java.awt.color.ICC_Profile 中的方法
从配置文件中返回包含特定标记数据元素的 byte 数组。
getData(DataFlavor) - 类 java.awt.datatransfer.Clipboard 中的方法
返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。
getData() - 类 java.awt.image.BufferedImage 中的方法
以一个大 tile 的形式返回图像。
getData(Rectangle) - 类 java.awt.image.BufferedImage 中的方法
计算并返回 BufferedImage 的一个任意区域。
getData() - 类 java.awt.image.DataBufferByte 中的方法
返回默认（第一个）字节数据数组。
getData(int) - 类 java.awt.image.DataBufferByte 中的方法
返回指定存储单元的数据数组。
getData() - 类 java.awt.image.DataBufferDouble 中的方法
返回默认（第一个）double 数据数组。
getData(int) - 类 java.awt.image.DataBufferDouble 中的方法
返回指定存储单元的数据数组。
getData() - 类 java.awt.image.DataBufferFloat 中的方法
返回默认（第一个）float 数据数组。
getData(int) - 类 java.awt.image.DataBufferFloat 中的方法
返回指定存储单元的数据数组。
getData() - 类 java.awt.image.DataBufferInt 中的方法
返回 DataBuffer 中的默认（第一个）int 数据数组。
getData(int) - 类 java.awt.image.DataBufferInt 中的方法
返回指定存储单元的数据数组。
getData() - 类 java.awt.image.DataBufferShort 中的方法
返回默认（第一个）字节数据数组。
getData(int) - 类 java.awt.image.DataBufferShort 中的方法
返回指定存储单元的数据数组。
getData() - 类 java.awt.image.DataBufferUShort 中的方法
返回默认的（第一个）无符号 short 数据数组。
getData(int) - 类 java.awt.image.DataBufferUShort 中的方法
返回指定存储单元的数据数组。
getData() - 接口 java.awt.image.RenderedImage 中的方法
以一个大 tile 的形式返回图像（对于基于 tile 的图像，此方法需要获取整个图像并复制全部图像数据）。
getData(Rectangle) - 接口 java.awt.image.RenderedImage 中的方法
计算并返回 RenderedImage 的任意区域。
getData() - 类 java.net.DatagramPacket 中的方法
返回数据缓冲区。
getData() - 类 java.rmi.activation.ActivationDesc 中的方法
为此描述符指定的对象返回包含初始化/激活数据的“编组对象”。
getData() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
返回组的初始化数据。
getData() - 类 javax.imageio.stream.IIOByteBuffer 中的方法
返回对字节数组的引用。
getData() - 类 javax.sound.midi.MetaMessage 中的方法
获得元消息数据的副本。
getData() - 类 javax.sound.midi.SoundbankResource 中的方法
获得存储在此 SoundbankResource 中的采样音频。
getData() - 类 javax.sound.midi.SysexMessage 中的方法
获得系统独占消息数据的副本。
getData() - 类 javax.swing.text.html.FormSubmitEvent 中的方法
获取表单提交数据。
getData() - 类 javax.swing.text.html.parser.Entity 中的方法
返回 data。
getData() - 接口 javax.xml.stream.events.Characters 中的方法
获取此事件的字符数据。
getData() - 接口 javax.xml.stream.events.ProcessingInstruction 中的方法
处理指令的数据部分。
getData() - 接口 org.w3c.dom.CharacterData 中的方法
实现此接口的节点的字符数据。
getData() - 接口 org.w3c.dom.ProcessingInstruction 中的方法
此处理指令的内容。
getData1() - 类 javax.sound.midi.ShortMessage 中的方法
获取消息中的第一个数据字节。
getData2() - 类 javax.sound.midi.ShortMessage 中的方法
获取消息中的第二个数据字节。
getDatabaseMajorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取底层数据库的主版本号。
getDatabaseMinorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
底层数据库的次版本号。
getDatabaseProductName() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库产品的名称。
getDatabaseProductVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库产品的版本号。
getDataBitOffset() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回数据位的偏移量（以位为单位）。
getDataBuffer() - 类 java.awt.image.Raster 中的方法
返回与此 Raster 关联的 DataBuffer。
getDataClass() - 类 javax.sound.midi.SoundbankResource 中的方法
获得此采样所使用的表示其数据的类。
getDataElement(int[], int) - 类 java.awt.image.ColorModel 中的方法
在已给定非标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中以 int 类型表示的像素值。
getDataElement(float[], int) - 类 java.awt.image.ColorModel 中的方法
在已给定标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。
getDataElement(int[], int) - 类 java.awt.image.ComponentColorModel 中的方法
返回在 ColorModel 中表示为 int 的像素值（已给定非标准化颜色/alpha 分量的数组）。
getDataElement(float[], int) - 类 java.awt.image.ComponentColorModel 中的方法
在已给定标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。
getDataElement(int[], int) - 类 java.awt.image.DirectColorModel 中的方法
在给定未标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。
getDataElement(int[], int) - 类 java.awt.image.IndexColorModel 中的方法
在给定非标准化颜色/alpha 分量数组的情况下，以 int 形式返回此 ColorModel 中的像素值。
getDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
在 TransferType 类型基本数组中返回单个像素的数据。
getDataElements(int, Object) - 类 java.awt.image.ColorModel 中的方法
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。
getDataElements(int[], int, Object) - 类 java.awt.image.ColorModel 中的方法
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
getDataElements(float[], int, Object) - 类 java.awt.image.ColorModel 中的方法
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
getDataElements(int, Object) - 类 java.awt.image.ComponentColorModel 中的方法
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。
getDataElements(int[], int, Object) - 类 java.awt.image.ComponentColorModel 中的方法
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
getDataElements(float[], int, Object) - 类 java.awt.image.ComponentColorModel 中的方法
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
getDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
以 TransferType 类型基本数组形式返回单个像素的数据。
getDataElements(int, Object) - 类 java.awt.image.DirectColorModel 中的方法
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。
getDataElements(int[], int, Object) - 类 java.awt.image.DirectColorModel 中的方法
在给定未标准化的颜色/alpha 分量的数组的情况下，返回此 ColorModel 中的像素的数据元素数组表示形式。
getDataElements(int, Object) - 类 java.awt.image.IndexColorModel 中的方法
根据默认 RGB 颜色模型中的整数像素表示形式，返回此 ColorModel 中像素的数据元素数组表示形式。
getDataElements(int[], int, Object) - 类 java.awt.image.IndexColorModel 中的方法
在给定非标准化颜色/alpha 分量数组的情况下，返回表示此 ColorModel 中像素的数据元素数组。
getDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回 TransferType 类型基本数组中单个像素的数据。
getDataElements(int, int, Object) - 类 java.awt.image.Raster 中的方法
以 TransferType 类型的基本数组形式返回单个像素的数据。
getDataElements(int, int, int, int, Object) - 类 java.awt.image.Raster 中的方法
以 TransferType 类型基本数组形式返回指定像素矩形的像素数据。
getDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在 TransferType 类型的基本数组中返回单个像素的数据。
getDataElements(int, int, int, int, Object, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在 TransferType 类型基本数组中返回指定像素矩形的像素数据。
getDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回 TransferType 类型基本数组中单个像素的数据。
getDataFlavors() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
返回此传输的数据 flavor。
getDataHandler() - 类 javax.xml.soap.AttachmentPart 中的方法
获取针对此 AttachmentPart 对象的 DataHandler 对象。
getDataLength(int) - 类 javax.sound.midi.ShortMessage 中的方法
检索与特定状态字节值关联的数据字节数。
getDatalink() - 类 javax.sql.rowset.serial.SerialDatalink 中的方法
返回一个新 URL，它是此 SerialDatalink 对象的副本。
getDataSize() - 异常 java.sql.DataTruncation 中的方法
获得应该传输的数据字节数。
getDataSource() - 类 javax.activation.DataHandler 中的方法
返回与此 DataHandler 实例关联的 DataSource。
getDataSourceLock() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回在此 SyncProvider 实现中活动的当前数据源锁定严重性级别。
getDataSourceName() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回向使用 Java Naming and Directory Interface (JNDI) API 的命名服务所提供的逻辑名，这将获得 javax.sql.DataSource 对象。
getDataSourceName() - 接口 javax.sql.RowSet 中的方法
获取标识此 RowSet 对象的数据源的逻辑名称。
getDataType() - 类 java.awt.image.DataBuffer 中的方法
返回此 DataBuffer 的数据类型。
getDataType() - 类 java.awt.image.SampleModel 中的方法
返回存储像素数据的 DataBuffer 的数据类型。
getDataTypeSize(int) - 类 java.awt.image.DataBuffer 中的静态方法
返回由给定 datatype 标记所代表的数据类型的大小（以位为单位）。
getDataVector() - 类 javax.swing.table.DefaultTableModel 中的方法
返回由多个包含表数据值的 Vector 组成的 Vector。
getDate() - 类 java.net.URLConnection 中的方法
返回 date 头字段的值。
getDate() - 类 java.security.cert.PKIXParameters 中的方法
返回应该确定证书路径有效性的时间。
getDate(int) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值。
getDate(int, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
getDate(String) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值。
getDate(String, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
getDate(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getDate(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中的 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getDate(int, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getDate(String, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getDate() - 类 java.sql.Time 中的方法
已过时。
getDate() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_MONTH) 取代。
getDate(Integer) - 类 javax.management.timer.Timer 中的方法
获得与计时器通知关联的日期的一个副本。
getDate(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与计时器通知关联的日期的一个副本。
getDate() - 类 javax.swing.SpinnerDateModel 中的方法
返回此 Date 序列中的当前元素。
getDateAndTime() - 类 java.security.cert.X509CRLSelector 中的方法
返回 dateAndTime 标准。
getDateFormatSymbols() - 类 java.text.SimpleDateFormat 中的方法
获取此日期格式的日期和时间格式符号的一个副本。
getDateInstance() - 类 java.text.DateFormat 中的静态方法
获取日期格式器，该格式器具有默认语言环境的默认格式化风格。
getDateInstance(int) - 类 java.text.DateFormat 中的静态方法
获取日期格式器，该格式器具有默认语言环境的给定格式化风格。
getDateInstance(int, Locale) - 类 java.text.DateFormat 中的静态方法
获取日期格式器，该格式器具有给定语言环境的给定格式化风格。
getDateInstance(int, Locale) - 类 java.text.spi.DateFormatProvider 中的方法
返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期。
getDateTimeInstance() - 类 java.text.DateFormat 中的静态方法
获取日期/时间格式器，该格式器具有默认语言环境的默认格式化风格。
getDateTimeInstance(int, int) - 类 java.text.DateFormat 中的静态方法
获取日期/时间格式器，该格式器具有默认语言环境的给定日期和时间格式化风格。
getDateTimeInstance(int, int, Locale) - 类 java.text.DateFormat 中的静态方法
获取日期/时间格式器，该格式器具有给定语言环境的给定格式化风格。
getDateTimeInstance(int, int, Locale) - 类 java.text.spi.DateFormatProvider 中的方法
返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期和时间。
getDay() - 类 java.sql.Time 中的方法
已过时。
getDay() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_WEEK) 取代。
getDay() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回月中的日或 DatatypeConstants.FIELD_UNDEFINED。
getDays() - 类 javax.xml.datatype.Duration 中的方法
获取整数值形式的 DAYS 字段的值，如果不存在，则值为 0。
getDCHuffmanTables() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
返回最近一次调用 setDecodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getDCHuffmanTables() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
返回最近一次调用 setEncodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getDebugGraphicsOptions() - 类 javax.swing.JComponent 中的方法
返回图形调试的状态。
getDebugOptions() - 类 javax.swing.DebugGraphics 中的方法
返回此 DebugGraphics 的当前调试选项。
getDecayTime() - 类 javax.sound.sampled.ReverbType 中的方法
获得衰减时间，该时间是晚期反射削弱到有效 0 的总时间差。
getDecimalFormatSymbols() - 类 java.text.DecimalFormat 中的方法
返回小数格式符号的一个副本，通常程序员或用户不改变此副本。
getDecimalSeparator() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于十进制符号的字符。
getDeclaration(String) - 类 javax.swing.text.html.StyleSheet 中的方法
将 CSS 声明转换为表示 CSS 声明的 AttributeSet。
getDeclaration() - 接口 javax.xml.stream.events.EntityReference 中的方法
返回此实体的声明。
getDeclaredAnnotations() - 类 java.lang.Class 中的方法

getDeclaredAnnotations() - 类 java.lang.Package 中的方法

getDeclaredAnnotations() - 类 java.lang.reflect.AccessibleObject 中的方法

getDeclaredAnnotations() - 接口 java.lang.reflect.AnnotatedElement 中的方法
返回直接存在于此元素上的所有注释。
getDeclaredAnnotations() - 类 java.lang.reflect.Constructor 中的方法

getDeclaredAnnotations() - 类 java.lang.reflect.Field 中的方法

getDeclaredAnnotations() - 类 java.lang.reflect.Method 中的方法

getDeclaredClasses() - 类 java.lang.Class 中的方法
返回 Class 对象的一个数组，这些对象反映声明为此 Class 对象所表示的类的成员的所有类和接口。
getDeclaredConstructor(Class<?>...) - 类 java.lang.Class 中的方法
返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
getDeclaredConstructors() - 类 java.lang.Class 中的方法
返回 Constructor 对象的一个数组，这些对象反映此 Class 对象表示的类声明的所有构造方法。
getDeclaredField(String) - 类 java.lang.Class 中的方法
返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。
getDeclaredFields() - 类 java.lang.Class 中的方法
返回 Field 对象的一个数组，这些对象反映此 Class 对象所表示的类或接口所声明的所有字段。
getDeclaredMethod(String, Class<?>...) - 类 java.lang.Class 中的方法
返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
getDeclaredMethods() - 类 java.lang.Class 中的方法
返回 Method 对象的一个数组，这些对象反映此 Class 对象表示的类或接口声明的所有方法，包括公共、保护、默认（包）访问和私有方法，但不包括继承的方法。
getDeclaredPrefixes() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
返回此上下文中声明的所有前缀的枚举。
getDeclaredType(TypeElement, TypeMirror...) - 接口 javax.lang.model.util.Types 中的方法
返回对应于类型元素和实际类型参数的类型。
getDeclaredType(DeclaredType, TypeElement, TypeMirror...) - 接口 javax.lang.model.util.Types 中的方法
根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
getDeclaredType() - 类 javax.xml.bind.JAXBElement 中的方法
返回 xml 元素声明的类型属性的 Java 绑定。
getDeclaringClass() - 类 java.lang.Class 中的方法
如果此 Class 对象所表示的类或接口是另一个类的成员，则返回的 Class 对象表示该对象的声明类。
getDeclaringClass() - 类 java.lang.Enum 中的方法
返回与此枚举常量的枚举类型相对应的 Class 对象。
getDeclaringClass() - 类 java.lang.reflect.Constructor 中的方法
返回 Class 对象，该对象表示声明由此 Constructor 对象表示的构造方法的类。
getDeclaringClass() - 类 java.lang.reflect.Field 中的方法
返回表示类或接口的 Class 对象，该类或接口声明由此 Field 对象表示的字段。
getDeclaringClass() - 接口 java.lang.reflect.Member 中的方法
返回表示声明由此 Member 表示的成员或构造方法的类或接口的 Class 对象。
getDeclaringClass() - 类 java.lang.reflect.Method 中的方法
返回表示声明由此 Method 对象表示的方法的类或接口的 Class 对象。
getDecomposition() - 类 java.text.Collator 中的方法
获取此 Collator 的 decomposition 模式。
getDeepestComponentAt(Component, int, int) - 类 javax.swing.SwingUtilities 中的静态方法
返回包含位置 x、y 的 parent 的最深可见后代组件。
getDefault() - 类 java.net.CookieHandler 中的静态方法
获取系统级 cookie 处理程序。
getDefault() - 类 java.net.ProxySelector 中的静态方法
获取系统级代理选择器。
getDefault() - 类 java.net.ResponseCache 中的静态方法
获取系统级响应缓存。
getDefault() - 类 java.util.Locale 中的静态方法
获得此 Java 虚拟机实例的当前默认语言环境值。
getDefault() - 类 java.util.TimeZone 中的静态方法
获取此主机的默认 TimeZone。
getDefault() - 类 javax.net.ServerSocketFactory 中的静态方法
返回该环境默认套接字工厂的一个副本。
getDefault() - 类 javax.net.SocketFactory 中的静态方法
返回该环境默认套接字工厂的一个副本。
getDefault() - 类 javax.net.ssl.SSLContext 中的静态方法
返回默认的 SSL 上下文。
getDefault() - 类 javax.net.ssl.SSLServerSocketFactory 中的静态方法
返回默认的 SSL 服务器套接字工厂。
getDefault() - 类 javax.net.ssl.SSLSocketFactory 中的静态方法
返回默认的 SSL 套接字工厂。
getDefaultAction() - 接口 javax.swing.text.Keymap 中的方法
当击键（即接收 KEY_TYPED KeyEvent）且该键没有绑定操作的情况下获取激发的默认操作。
getDefaultActions() - 类 java.awt.dnd.DropTarget 中的方法
获取表示受此 DropTarget 支持的当前操作的 int 值。
getDefaultAlgorithm() - 类 javax.net.ssl.KeyManagerFactory 中的静态方法
获取默认的 KeyManagerFactory 算法名称。
getDefaultAlgorithm() - 类 javax.net.ssl.TrustManagerFactory 中的静态方法
获取默认的 TrustManagerFactory 算法名称。
getDefaultAllowUserInteraction() - 类 java.net.URLConnection 中的静态方法
返回 allowUserInteraction 字段的默认值。
getDefaultAttributeValue(Class<? extends Attribute>) - 接口 javax.print.PrintService 中的方法
确定给定类别中此 PrintService 的默认打印属性值。
getDefaultButton() - 类 javax.swing.JRootPane 中的方法
返回 defaultButton 属性的值。
getDefaultChoice() - 类 javax.security.auth.callback.ChoiceCallback 中的方法
获取 defaultChoice。
getDefaultChooserPanels() - 类 javax.swing.colorchooser.ColorChooserComponentFactory 中的静态方法

getDefaultCipherSuites() - 类 javax.net.ssl.SSLServerSocketFactory 中的方法
返回默认情况下启用的密码套件的列表。
getDefaultCipherSuites() - 类 javax.net.ssl.SSLSocketFactory 中的方法
返回默认情况下启用的密码套件的列表。
getDefaultClassLoader() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
获得此连接器服务器使用的默认 ClassLoader。
getDefaultClosedIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回默认图标，对于当前的 laf，它用于表示没有扩展的非叶节点。
getDefaultCloseOperation() - 类 javax.swing.JDialog 中的方法
返回用户在此对话框上启动 "close" 时所执行的操作。
getDefaultCloseOperation() - 类 javax.swing.JFrame 中的方法
返回用户在此窗体上发起 "close" 时执行的操作。
getDefaultCloseOperation() - 类 javax.swing.JInternalFrame 中的方法
返回用户在此内部窗体上发起 "close" 时默认执行的操作。
getDefaultCommandMap() - 类 javax.activation.CommandMap 中的静态方法
获取默认的 CommandMap。
getDefaultComponent(Container) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回默认拥有焦点的 Component。
getDefaultComponent(Container) - 类 java.awt.FocusTraversalPolicy 中的方法
返回要聚焦的默认 Component。
getDefaultComponent(Container) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回默认拥有焦点的 Component。
getDefaultConfiguration() - 类 java.awt.GraphicsDevice 中的方法
返回与此 GraphicsDevice 关联的默认 GraphicsConfiguration。
getDefaultController() - 类 javax.imageio.IIOParam 中的方法
返回默认 IIOParamController（如果有），不考虑当前安装的控制器。
getDefaultController() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回默认 IIOMetadataController（如果有），不考虑当前安装的控制器。
getDefaultCursor() - 类 java.awt.Cursor 中的静态方法
返回系统默认光标。
getDefaultCursor() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
返回默认光标。
getDefaultDirectory() - 类 javax.swing.filechooser.FileSystemView 中的方法
返回文件选择器的用户默认起始目录。
getDefaultDomain() - 接口 javax.management.MBeanServer 中的方法

getDefaultDomain() - 接口 javax.management.MBeanServerConnection 中的方法
返回对 MBean 命名时使用的默认域。
getDefaultDomain(Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getDefaultDomain() 方法。
getDefaultDomain(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getDefaultDomain(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getDefaultDragSource() - 类 java.awt.dnd.DragSource 中的静态方法
获取与基础平台关联的 DragSource 对象。
getDefaultEditor(Class<?>) - 类 javax.swing.JTable 中的方法
尚未在 TableColumn 中设置编辑器时，返回要使用的编辑器。
getDefaultEventIndex() - 接口 java.beans.BeanInfo 中的方法
bean 可能有一个“默认”事件，即使用 bean 时通常最有可能由用户使用的事件。
getDefaultEventIndex() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝默认事件的信息。
getDefaultFileTypeMap() - 类 javax.activation.FileTypeMap 中的静态方法
返回系统的默认 FileTypeMap。
getDefaultFlavorMap() - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
返回此线程的 ClassLoader 的默认 FlavorMap。
getDefaultFocusTraversalKeys(int) - 类 java.awt.KeyboardFocusManager 中的方法
返回给定遍历操作的默认焦点遍历键的 Set。
getDefaultFocusTraversalPolicy() - 类 java.awt.KeyboardFocusManager 中的方法
返回默认 FocusTraversalPolicy。
getDefaultFormatter() - 类 javax.swing.text.DefaultFormatterFactory 中的方法
返回供最后选择使用的 JFormattedTextField.AbstractFormatter，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。
getDefaultFractionDigits() - 类 java.util.Currency 中的方法
获取与此货币一起使用的默认小数位数。
getDefaultHostnameVerifier() - 类 javax.net.ssl.HttpsURLConnection 中的静态方法
获取此类的新实例所继承的默认 HostnameVerifier。
getDefaultIcon() - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法

getDefaultImageMetadata(ImageTypeSpecifier, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
返回包含用来编码给定类型图像的默认值的 IIOMetadata 对象。
getDefaultInitCtx() - 类 javax.naming.InitialContext 中的方法
通过调用 NamingManager.getInitialContext() 获取初始上下文，并将它缓存在 defaultInitCtx 中。
getDefaultInstance() - 类 javax.imageio.spi.IIORegistry 中的静态方法
返回 Image I/O API 使用的默认 IIORegistry 实例。
getDefaultLeafIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回默认图标，对于当前的 laf，它用于表示叶节点。
getDefaultLightWeightPopupEnabled() - 类 javax.swing.JPopupMenu 中的静态方法
获取 defaultLightWeightPopupEnabled 属性，默认情况下，该属性为 true。
getDefaultLocale() - 类 javax.swing.JComponent 中的静态方法
返回在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。
getDefaultLocale() - 类 javax.swing.UIDefaults 中的方法
返回该默认语言环境。
getDefaultName() - 类 javax.security.auth.callback.NameCallback 中的方法
获取默认名称。
getDefaultNamespacePrefix() - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法

getDefaultNamespacePrefix() - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回默认名称空间前缀。
getDefaultOpenIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回默认图标，对于当前的 laf，它用于表示扩展的非叶节点。
getDefaultOption() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取默认选项。
getDefaultPort() - 类 java.net.URL 中的方法
获取与此 URL 关联协议的默认端口号。
getDefaultPort() - 类 java.net.URLStreamHandler 中的方法
返回由该处理程序解析的 URL 的默认端口。
getDefaultPrintService() - 类 javax.print.PrintServiceLookup 中的方法
应用程序不直接调用它。
getDefaultPropertyIndex() - 接口 java.beans.BeanInfo 中的方法
bean 可能有一个“默认”属性，即通常最有可能由自定义 bean 的用户一开始就选择更新的属性。
getDefaultPropertyIndex() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝默认属性的信息。
getDefaultProviderInstance() - 类 java.rmi.server.RMIClassLoader 中的静态方法
返回服务提供者接口 RMIClassLoaderSpi 的默认提供者的规范化实例。
getDefaultQueue() - 类 javax.swing.text.LayoutQueue 中的静态方法
返回默认的布局队列。
getDefaultReadParam() - 类 javax.imageio.ImageReader 中的方法
返回一个适合此格式的默认 ImageReadParam 对象。
getDefaultRenderer(Class<?>) - 类 javax.swing.JTable 中的方法
尚未在 TableColumn 中设置渲染器时，返回要使用的单元格渲染器。
getDefaultRenderer() - 类 javax.swing.table.JTableHeader 中的方法
返回 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。
getDefaultRepresentationClass() - 类 java.awt.datatransfer.DataFlavor 中的方法

getDefaultRepresentationClassAsString() - 类 java.awt.datatransfer.DataFlavor 中的方法

getDefaultRequestProperty(String) - 类 java.net.URLConnection 中的静态方法
已过时。 应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。
getDefaultRootElement() - 类 javax.swing.text.AbstractDocument 中的方法
返回视图赖依存在的根元素，除非提供了向元素结构指派视图的其他机制。
getDefaultRootElement() - 类 javax.swing.text.DefaultStyledDocument 中的方法
获得默认的根元素。
getDefaultRootElement() - 接口 javax.swing.text.Document 中的方法
返回视图赖以存在的根元素，除非提供了向元素结构指定视图的其他机制。
getDefaultRootElement() - 类 javax.swing.text.PlainDocument 中的方法
获取文档模型的默认根元素。
getDefaults() - 类 javax.swing.LookAndFeel 中的方法
返回外观的默认值。
getDefaults() - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
返回外观默认值。
getDefaults() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回外观的默认值。
getDefaults() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
创建、初始化并返回特定于外观的默认值。
getDefaults() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回此 SynthLookAndFeel 的默认值。
getDefaults() - 类 javax.swing.UIManager 中的静态方法
返回该默认值。
getDefaultScreenDevice() - 类 java.awt.GraphicsEnvironment 中的方法
返回默认的屏幕 GraphicsDevice。
getDefaultSelection() - 类 java.awt.JobAttributes 中的方法
指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。
getDefaultSize() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回使用当前渲染器和字体的组合框的空显示区域的默认大小。
getDefaultSocketFactory() - 类 java.rmi.server.RMISocketFactory 中的静态方法
返回对此 RMI 实现使用的默认套接字工厂的引用。
getDefaultSoundbank() - 接口 javax.sound.midi.Synthesizer 中的方法
获得合成器的默认音库（如果合成器存在）。
getDefaultSSLParameters() - 类 javax.net.ssl.SSLContext 中的方法
返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。
getDefaultSSLSocketFactory() - 类 javax.net.ssl.HttpsURLConnection 中的静态方法
获取此类的新实例所继承的默认静态 SSLSocketFactory。
getDefaultStream() - 类 java.rmi.server.LogStream 中的静态方法
已过时。 无替代版本
getDefaultStreamMetadata(ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
返回包含用来对图像流进行编码的默认值的 IIOMetadata 对象。
getDefaultStyleContext() - 类 javax.swing.text.StyleContext 中的静态方法
返回由所有文档共享的默认 AttributeContext，这些文档不影响定义/提供其自己的上下文。
getDefaultText() - 类 javax.security.auth.callback.TextInputCallback 中的方法
获取默认文本。
getDefaultTextIconGap(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getDefaultToolkit() - 类 java.awt.Toolkit 中的静态方法
获取默认工具包。
getDefaultTransactionIsolation() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库的默认事务隔离级别。
getDefaultTransform() - 类 java.awt.GraphicsConfiguration 中的方法
返回此 GraphicsConfiguration 的默认 AffineTransform。
getDefaultTreeModel() - 类 javax.swing.JTree 中的静态方法
创建并返回一个示例 TreeModel。
getDefaultType() - 类 java.security.cert.CertPathBuilder 中的静态方法
返回 Java 安全属性文件中所指定的默认 CertPathBuilder 类型，如果没有此属性，则返回字符串 "PKIX"。
getDefaultType() - 类 java.security.cert.CertPathValidator 中的静态方法
返回 Java 安全属性文件中所指定的默认 CertPathValidator 类型，如果没有此属性，则返回字符串 "PKIX"。
getDefaultType() - 类 java.security.cert.CertStore 中的静态方法
返回 Java 安全属性文件中指定的默认 CertStore 类型；如果没有此属性，则返回字符串 "LDAP"。
getDefaultType() - 类 java.security.KeyStore 中的静态方法
返回 Java 安全属性文件中指定的默认 keystore 类型；如果不存在此类属性，则返回字符串 "jks"（"Java keystore" 的首字母缩写）。
getDefaultUncaughtExceptionHandler() - 类 java.lang.Thread 中的静态方法
返回线程由于未捕获到异常而突然终止时调用的默认处理程序。
getDefaultUseCaches() - 类 java.net.URLConnection 中的方法
返回 URLConnection 的 useCaches 标志的默认值。
getDefaultValue() - 类 java.lang.reflect.Method 中的方法
返回由此 Method 实例表示的注释成员的默认值。
getDefaultValue() - 接口 javax.lang.model.element.ExecutableElement 中的方法
如果此 executable 是一个注释类型元素，则返回默认值。
getDefaultValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的默认值（如果已指定），否则返回 null。
getDefaultValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此参数的默认值（如果存在），否则返回 null。
getDefaultValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的默认值（如果指定），否则返回 null。
getDefaultValue() - 类 javax.swing.text.html.CSS.Attribute 中的方法
获取属性的默认值。
getDefaultWriteParam() - 类 javax.imageio.ImageWriter 中的方法
返回适用于此文件格式的适当类型的新 ImageWriteParam 对象，该对象包含默认值，即那些将在没有指定 ImageWriteParam 对象时使用的值。
getDefinitionClass() - 类 java.lang.instrument.ClassDefinition 中的方法
返回该类。
getDefinitionClassFile() - 类 java.lang.instrument.ClassDefinition 中的方法
返回包含新的类文件的 byte 数组。
getDelay(TimeUnit) - 接口 java.util.concurrent.Delayed 中的方法
返回与此对象相关的剩余延迟时间，以给定的时间单位表示。
getDelay() - 类 javax.swing.JMenu 中的方法
返回子菜单向上或向下弹出前建议的延迟（以毫秒为单位）。
getDelay() - 类 javax.swing.Timer 中的方法
返回两次触发动作事件间延迟，以毫秒为单位。
getDelegatedTask() - 类 javax.net.ssl.SSLEngine 中的方法
返回此 SSLEngine 的一个委托 Runnable 任务。
getDelegCred() - 接口 org.ietf.jgss.GSSContext 中的方法
获取上下文初始端委托给上下文接受端的凭据。
getDepth() - 接口 java.security.cert.PolicyNode 中的方法
返回有效策略树中此节点的深度。
getDepth(int) - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 中的方法

getDepth() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回以此节点为根的树的深度 -- 从此节点到叶节点的最长距离。
getDER() - 类 org.ietf.jgss.Oid 中的方法
返回此 oid 对象的全部 ASN.1 DER 编码，其中包括标记和长度。
getDereferencedData() - 接口 javax.xml.crypto.dsig.Reference 中的方法
如果已启用引用缓存，则返回被取消引用的数据。
getDerefLinkFlag() - 类 javax.naming.directory.SearchControls 中的方法
确定在搜索期间是否将取消对链接的引用。
getDerivedGauge(ObjectName) - 类 javax.management.monitor.CounterMonitor 中的方法
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
getDerivedGauge() - 类 javax.management.monitor.CounterMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getDerivedGauge(ObjectName) 取代
getDerivedGauge() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGauge(ObjectName) 取代
getDerivedGauge(ObjectName) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取指定的 MBean 的派生尺度。
getDerivedGauge(ObjectName) - 类 javax.management.monitor.GaugeMonitor 中的方法
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
getDerivedGauge() - 类 javax.management.monitor.GaugeMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGauge(ObjectName) 取代
getDerivedGauge() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGauge(ObjectName) 取代
getDerivedGauge(ObjectName) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取指定的 MBean 的派生尺度。
getDerivedGauge() - 类 javax.management.monitor.MonitorNotification 中的方法
获取此监视器通知的派生尺度。
getDerivedGauge(ObjectName) - 类 javax.management.monitor.StringMonitor 中的方法
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生的尺度，否则将为 null。
getDerivedGauge() - 类 javax.management.monitor.StringMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 StringMonitor.getDerivedGauge(ObjectName) 取代
getDerivedGauge() - 接口 javax.management.monitor.StringMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGauge(ObjectName) 取代
getDerivedGauge(ObjectName) - 接口 javax.management.monitor.StringMonitorMBean 中的方法
获取指定 MBean 的派生尺度。
getDerivedGaugeTimeStamp(ObjectName) - 类 javax.management.monitor.CounterMonitor 中的方法
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
getDerivedGaugeTimeStamp() - 类 javax.management.monitor.CounterMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp(ObjectName) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取指定 MBean 的派生尺度时间戳。
getDerivedGaugeTimeStamp(ObjectName) - 类 javax.management.monitor.GaugeMonitor 中的方法
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
getDerivedGaugeTimeStamp() - 类 javax.management.monitor.GaugeMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp(ObjectName) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取指定 MBean 的派生尺度时间戳。
getDerivedGaugeTimeStamp(ObjectName) - 类 javax.management.monitor.StringMonitor 中的方法
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
getDerivedGaugeTimeStamp() - 类 javax.management.monitor.StringMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 StringMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp() - 接口 javax.management.monitor.StringMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp(ObjectName) - 接口 javax.management.monitor.StringMonitorMBean 中的方法
获取指定 MBean 的派生尺度时间戳。
getDescendantToggledPaths(TreePath) - 类 javax.swing.JTree 中的方法
返回已展开且为 parent 的子路径的 TreePath 的 Enumeration。
getDescent() - 类 java.awt.font.GraphicAttribute 中的方法
返回此 GraphicAttribute 的 descent。
getDescent() - 类 java.awt.font.ImageGraphicAttribute 中的方法
返回此 ImageGraphicAttribute 的 descent。
getDescent() - 类 java.awt.font.LineMetrics 中的方法
返回该文本的 descent。
getDescent() - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回此 ShapeGraphicAttribute 的 descent。
getDescent() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的 descent。
getDescent() - 类 java.awt.FontMetrics 中的方法
确定此 FontMetrics 对象所描述的 Font 的 font descent。
getDescent(GlyphView) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法

getDescription() - 异常 java.util.regex.PatternSyntaxException 中的方法
获取错误的描述。
getDescription(Locale) - 类 javax.imageio.spi.IIOServiceProvider 中的方法
返回此服务提供者及其相关实现的一个简明的可读描述。
getDescription() - 类 javax.management.MBeanFeatureInfo 中的方法
返回该功能的可读描述。
getDescription() - 类 javax.management.MBeanInfo 中的方法
返回该 MBean 的可读描述。
getDescription() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回 MBean 的可读描述。
getDescription(String) - 类 javax.management.openmbean.CompositeType 中的方法
返回名称是 itemName 的项的描述，如果此 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。
getDescription() - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
返回此 OpenMBeanConstructorInfo 实例描述的构造方法的可读描述。
getDescription() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回此 OpenMBeanInfo 描述的 open MBean 实例的类型的可读描述。
getDescription() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 实例描述的操作的可读描述。
getDescription() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此 OpenMBeanParameterInfo 实例描述的参数的可读描述。
getDescription() - 类 javax.management.openmbean.OpenType 中的方法
返回此 OpenType 实例的文本描述。
getDescription() - 类 javax.management.relation.RoleInfo 中的方法
返回角色的描述文本。
getDescription(MBeanInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的描述。
getDescription(MBeanFeatureInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanFeatureInfo 中使用的描述。
getDescription(MBeanAttributeInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanAttributeInfo 中使用的描述。
getDescription(MBeanConstructorInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanConstructorInfo 中使用的描述。
getDescription(MBeanConstructorInfo, MBeanParameterInfo, int) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的描述。
getDescription(MBeanOperationInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的描述。
getDescription(MBeanOperationInfo, MBeanParameterInfo, int) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的描述。
getDescription() - 类 javax.sound.midi.MidiDevice.Info 中的方法
获得关于设备的描述。
getDescription() - 接口 javax.sound.midi.Soundbank 中的方法
获得音库适于显示的文本描述。
getDescription() - 类 javax.sound.sampled.Mixer.Info 中的方法
获得混频器的描述。
getDescription() - 类 javax.swing.event.HyperlinkEvent 中的方法
获得链接描述的字符串表示形式。
getDescription() - 类 javax.swing.filechooser.FileFilter 中的方法
此过滤器的描述。
getDescription() - 类 javax.swing.filechooser.FileNameExtensionFilter 中的方法
此过滤器的描述。
getDescription(File) - 类 javax.swing.filechooser.FileView 中的方法
文件的可读描述。
getDescription() - 类 javax.swing.ImageIcon 中的方法
获得图像的描述。
getDescription(File) - 类 javax.swing.JFileChooser 中的方法
返回文件描述。
getDescription() - 类 javax.swing.LookAndFeel 中的方法
返回对此外观实现的单行描述，例如，"The CDE/Motif Look and Feel"。
getDescription() - 类 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter 中的方法

getDescription(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法

getDescription() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回此外观的简短描述。
getDescription() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
返回对此外观的一行描述。
getDescription() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回 SynthLookAndFeel 的文本描述。
getDescriptor() - 接口 javax.management.DescriptorRead 中的方法
返回 Descriptor 的副本。
getDescriptor() - 类 javax.management.MBeanFeatureInfo 中的方法
返回该功能的描述符。
getDescriptor() - 类 javax.management.MBeanInfo 中的方法
获取此 MBean 的描述符。
getDescriptor() - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 中的方法
获取 ModelMBeanAttributeInfo 的关联 Descriptor 的副本。
getDescriptor() - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 中的方法
返回关联 Descriptor 的副本。
getDescriptor(String, String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回通过 name 和 descriptorType 请求的 Descriptor。
getDescriptor(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
返回通过名称请求的 Descriptor。
getDescriptor(String, String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getDescriptor() - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getDescriptor() - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 中的方法
返回 ModelMBeanNotificationInfo 的关联 Descriptor 的副本。
getDescriptor() - 类 javax.management.modelmbean.ModelMBeanOperationInfo 中的方法
返回 ModelMBeanOperationInfo 的关联 Descriptor 的副本。
getDescriptors(String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。
getDescriptors(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getDesignAxisDefaults() - 接口 java.awt.font.MultipleMaster 中的方法
返回每个轴的默认设计值的数组。
getDesignAxisNames() - 接口 java.awt.font.MultipleMaster 中的方法
返回每个设计轴的名称。
getDesignAxisRanges() - 接口 java.awt.font.MultipleMaster 中的方法
为每个轴返回以 [from->to] 形式交错的设计限制的数组。
getDesktop() - 类 java.awt.Desktop 中的静态方法
返回当前浏览器上下文的 Desktop 实例。
getDesktopColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的桌面颜色。
getDesktopColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回桌面颜色。
getDesktopColor() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回桌面颜色。
getDesktopIcon() - 类 javax.swing.JInternalFrame 中的方法
返回图标化此 JInternalFrame 时使用的 JDesktopIcon。
getDesktopIconBorder() - 类 javax.swing.plaf.metal.MetalBorders 中的静态方法
返回一个用于 Desktop Icon 的 border 实例
getDesktopManager() - 类 javax.swing.JDesktopPane 中的方法
返回处理特定于桌面 UI 操作的 DesktopManger。
getDesktopManager() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
返回适当的 DesktopManager。
getDesktopPane() - 类 javax.swing.JInternalFrame 中的方法
在祖先层次结构中搜索 JDesktop 实例的便捷方法。
getDesktopPane() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
询问该图标所属的 Desktop 对象的便捷方法。
getDesktopPaneForComponent(Component) - 类 javax.swing.JOptionPane 中的静态方法
返回指定组件的桌面窗格。
getDesktopProperty(String) - 类 java.awt.Toolkit 中的方法
获取指定桌面属性的值。
getDesktopPropertyValue(String, Object) - 类 javax.swing.LookAndFeel 中的静态方法
通过调用 Toolkit.getDefaultToolkit().getDesktopProperty() 返回指定系统桌面属性的值。
getDestination() - 类 java.awt.JobAttributes 中的方法
指定将输出到打印机还是使用这些属性的作业文件。
getDestination(ImageReadParam, Iterator<ImageTypeSpecifier>, int, int) - 类 javax.imageio.ImageReader 中的静态方法
返回应该在其中写入解码的像素数据的 BufferedImage。
getDestination() - 类 javax.imageio.ImageReadParam 中的方法
返回当前由 setDestination 方法设置的 BufferedImage，如果没有设置，则返回 null。
getDestinationBands() - 类 javax.imageio.ImageReadParam 中的方法
返回 band 索引的集合，数据将置于该集合中。
getDestinationOffset() - 类 javax.imageio.IIOParam 中的方法
返回目标图像中的偏移量，像素将置于该处。
getDestinationType() - 类 javax.imageio.IIOParam 中的方法
以 ImageTypeSpecifier 的形式返回将由读取操作返回的图像类型，如果通过调用 setDestination(ImageTypeSpecifier) 设置了类型的话。
getDetail() - 接口 javax.xml.soap.SOAPFault 中的方法
返回此 SOAPFault 对象的可选 detail 元素。
getDetail() - 接口 org.w3c.dom.events.UIEvent 中的方法
指定关于 Event 的一些详细信息，具体取决于事件的类型。
getDetailEntries() - 接口 javax.xml.soap.Detail 中的方法
获取在此 Detail 对象中所有 DetailEntry 上进行迭代的迭代器。
getDeterminant() - 类 java.awt.geom.AffineTransform 中的方法
返回变换的矩阵表示形式的决定因子。
getDevice() - 类 java.awt.GraphicsConfiguration 中的方法
返回与此 GraphicsConfiguration 关联的 GraphicsDevice。
getDevice() - 类 java.awt.PointerInfo 中的方法
返回在创建此 PointerInfo 时鼠标指针所在的 GraphicsDevice。
getDevice(MidiDevice.Info) - 类 javax.sound.midi.spi.MidiDeviceProvider 中的方法
获得由信息对象表示的设备的实例。
getDeviceConfiguration() - 类 java.awt.Graphics2D 中的方法
返回与此 Graphics2D 关联的设备配置。
getDeviceInfo() - 接口 javax.sound.midi.MidiDevice 中的方法
获得有关设备的信息，其中包括包含了其名称、供应商和描述的 Java 类和 Strings。
getDeviceInfo() - 类 javax.sound.midi.spi.MidiDeviceProvider 中的方法
获得表示设备或由此 MidiDeviceProvider 提供的设备的信息对象集合。
getDiagnostics() - 类 javax.tools.DiagnosticCollector 中的方法
获取此对象收集的诊断所组成的列表视图。
getDialog() - 类 java.awt.JobAttributes 中的方法
返回对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。
getDialogTitle() - 类 javax.swing.JFileChooser 中的方法
获得 JFileChooser 的标题栏中所显示的字符串。
getDialogTitle(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
返回此对话框的标题
getDialogTitle(JFileChooser) - 类 javax.swing.plaf.FileChooserUI 中的方法

getDialogTitle(JFileChooser) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getDialogTitle 方法。
getDialogType() - 类 javax.swing.JFileChooser 中的方法
返回此对话框的类型。
getDifferenceMode() - 类 javax.management.monitor.CounterMonitor 中的方法
获取所有观察到的 MBeans 的共同的差分模式标志值。
getDifferenceMode() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取差分模式标志值。
getDifferenceMode() - 类 javax.management.monitor.GaugeMonitor 中的方法
获取所有观察到的 MBean 的公共差分模式标志值。
getDifferenceMode() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取差分模式标志值。
getDigestAlgorithm() - 类 java.security.spec.MGF1ParameterSpec 中的方法
返回掩码生成函数使用的消息摘要的算法名称。
getDigestAlgorithm() - 类 java.security.spec.PSSParameterSpec 中的方法
返回消息摘要算法名称。
getDigestAlgorithm() - 类 javax.crypto.spec.OAEPParameterSpec 中的方法
返回信息摘要算法名称。
getDigestInputStream() - 接口 javax.xml.crypto.dsig.Reference 中的方法
如果已启用引用缓存，则返回预整理的输入流。
getDigestLength() - 类 java.security.MessageDigest 中的方法
返回以字节为单位的摘要长度，如果提供者不支持此操作并且实现是不可复制的，则返回 0。
getDigestMethod() - 接口 javax.xml.crypto.dsig.Reference 中的方法
返回此 Reference 的摘要方法。
getDigestValue() - 接口 javax.xml.crypto.dsig.Reference 中的方法
返回此 Reference 的摘要值。
getDigit() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于某种模式中数字的字符。
getDimension() - 类 javax.management.openmbean.ArrayType 中的方法
返回此 ArrayType 实例描述的数组的维度。
getDimension(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
getDimension(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
getDimension(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个维数。
getDimension(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个维数。
getDirection() - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
返回箭头的方向。
getDirection() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得方向。
getDirectionality(char) - 类 java.lang.Character 中的静态方法
返回给定字符的 Unicode 方向属性。
getDirectionality(int) - 类 java.lang.Character 中的静态方法
返回给定字符（Unicode 代码点）的 Unicode 方向属性。
getDirectories() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法

getDirectory() - 类 java.awt.FileDialog 中的方法
获取此文件对话框的目录。
getDirectory() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
记忆当前在 UI 中选择的目录的属性。
getDirectoryName() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getDirectoryName() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getDirtyRegion(JComponent) - 类 javax.swing.RepaintManager 中的方法
返回组件的当前脏区。
getDisabledIcon() - 类 javax.swing.AbstractButton 中的方法
返回禁用按钮时按钮使用的图标。
getDisabledIcon() - 类 javax.swing.JLabel 中的方法
返回该标签被禁用时所使用的图标。
getDisabledIcon(JComponent, Icon) - 类 javax.swing.LookAndFeel 中的方法
返回具有禁用外观的 Icon。
getDisabledIcon(JComponent, Icon) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回具有禁用外观的 Icon。
getDisabledIconAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡禁用图标。
getDisabledObjectNames() - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
获取禁用的所有 ObjectName。
getDisabledSelectedIcon() - 类 javax.swing.AbstractButton 中的方法
返回禁用并选择按钮时按钮使用的图标。
getDisabledSelectedIcon(JComponent, Icon) - 类 javax.swing.LookAndFeel 中的方法
返回由选定的禁用组件使用的 Icon。
getDisabledSelectedIcon(JComponent, Icon) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回由选定的禁用组件使用的 Icon。
getDisabledTextColor() - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法

getDisabledTextColor() - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法

getDisabledTextColor() - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法

getDisabledTextColor() - 类 javax.swing.text.JTextComponent 中的方法
获取用于呈现禁用文本的当前颜色。
getDiscard() - 类 java.net.HttpCookie 中的方法
返回 cookie 的丢弃属性
getDismissDelay() - 类 javax.swing.ToolTipManager 中的方法
返回取消工具提示的延迟值。
getDisplayCountry() - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境国家/地区名。
getDisplayCountry(Locale) - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境国家/地区名。
getDisplayCountry(String, Locale) - 类 java.util.spi.LocaleNameProvider 中的方法
返回适合向用户显示的给定 ISO 3166 国家代码和给定语言环境的本地化名称。
getDisplayedMnemonic() - 类 javax.swing.JLabel 中的方法
返回指示助记符键的键代码。
getDisplayedMnemonicIndex() - 类 javax.swing.AbstractButton 中的方法
以索引形式返回字符，它表示助记符字符，外观应该对其提供装饰。
getDisplayedMnemonicIndex() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
提供关于 getDisplayName 中字符的索引在外观方面的提示，字符索引应以可视化的方式标识为助记符。
getDisplayedMnemonicIndex() - 类 javax.swing.JLabel 中的方法
以索引的形式返回字符，外观应提供该字符的装饰以表示助记符。
getDisplayedMnemonicIndexAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回作为索引的字符，外观必须提供它来表示助记符字符。
getDisplayFormatter() - 类 javax.swing.text.DefaultFormatterFactory 中的方法
返回在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
getDisplayLanguage() - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境语言名。
getDisplayLanguage(Locale) - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境语言名。
getDisplayLanguage(String, Locale) - 类 java.util.spi.LocaleNameProvider 中的方法
返回适合向用户显示的给定 ISO 639 语言代码和给定语言环境的本地化名称。
getDisplayMode() - 类 java.awt.GraphicsDevice 中的方法
返回此 GraphicsDevice 的当前显示模式。
getDisplayModes() - 类 java.awt.GraphicsDevice 中的方法
返回可用于此 GraphicsDevice 的所有显示模式。
getDisplayName() - 类 java.beans.FeatureDescriptor 中的方法
获得此特性的本地化显示名称。
getDisplayName() - 类 java.net.NetworkInterface 中的方法
获取此网络接口的显示名称。
getDisplayName(int, int, Locale) - 类 java.util.Calendar 中的方法
返回给定 style 和 locale 下的日历 field 值的字符串表示形式。
getDisplayName() - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境名。
getDisplayName(Locale) - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境名。
getDisplayName(String, boolean, int, Locale) - 类 java.util.spi.TimeZoneNameProvider 中的方法
返回适于展示给指定语言环境用户的给定时区 ID 名称。
getDisplayName() - 类 java.util.TimeZone 中的方法
返回适合于展示给默认区域的用户的时区名称。
getDisplayName(Locale) - 类 java.util.TimeZone 中的方法
返回适合于展示给指定区域的用户的时区名称。
getDisplayName(boolean, int) - 类 java.util.TimeZone 中的方法
返回适合于展示给默认区域的用户的时区名称。
getDisplayName(boolean, int, Locale) - 类 java.util.TimeZone 中的方法
返回适合于展示给指定区域的用户的时区名称。
getDisplayName() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
返回一个包含面板显示名称的字符串。
getDisplayNames(int, int, Locale) - 类 java.util.Calendar 中的方法
返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。
getDisplaySize() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回显示区域的计算大小。
getDisplayVariant() - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境变量代码名。
getDisplayVariant(Locale) - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境变量代码名。
getDisplayVariant(String, Locale) - 类 java.util.spi.LocaleNameProvider 中的方法
返回适合向用户显示的给定变量代码和给定语言环境的本地化名称。
getDivider() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回顶层 Component 之间的分隔符。
getDividerBorderSize() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 平台 v1.3 开始，由在分隔符上设置边框取代。
getDividerLocation() - 类 javax.swing.JSplitPane 中的方法
返回最后传递给 setDividerLocation 的值。
getDividerLocation(JSplitPane) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回分隔符的位置，该位置可能不同于拆分窗格认为分隔符所在的位置。
getDividerLocation(JSplitPane) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getDividerLocation 方法。
getDividerLocation(JSplitPane) - 类 javax.swing.plaf.SplitPaneUI 中的方法
返回分隔符的位置。
getDividerSize() - 类 javax.swing.JSplitPane 中的方法
返回分隔条的大小。
getDividerSize() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回分隔符的大小。
getDivisionType() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得 MIDI 文件的定时 division 类型。
getDivisionType() - 类 javax.sound.midi.Sequence 中的方法
获得此 Sequence 的定时 division 类型。
getDoc() - 接口 javax.print.MultiDoc 中的方法
获取当前的 doc 对象。
getDocComment(Element) - 接口 javax.lang.model.util.Elements 中的方法
返回元素的文档（"Javadoc"）注释文本。
getDocFlavor() - 接口 javax.print.Doc 中的方法
确定此 doc 对象提供其部分打印数据所用的 DocFlavor。
getDocFlavor() - 类 javax.print.SimpleDoc 中的方法
确定其 doc 对象将提供其部分打印数据的 doc flavor。
getDockingColor() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
获取在连接 (docking) 区域上时显示的颜色。
getDoctype() - 接口 org.w3c.dom.Document 中的方法
与此文档相关的文档类型声明（参见 DocumentType）。
getDocument() - 接口 javax.swing.event.DocumentEvent 中的方法
获得发起更改事件的文档。
getDocument() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获得基础模型。
getDocument() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
获得发起更改事件的文档。
getDocument() - 类 javax.swing.text.AbstractWriter 中的方法
获取文档。
getDocument() - 类 javax.swing.text.DocumentFilter.FilterBypass 中的方法
返回发生变化的 Document。
getDocument() - 接口 javax.swing.text.Element 中的方法
获取与此元素关联的文档。
getDocument() - 类 javax.swing.text.JTextComponent 中的方法
获取与编辑器关联的模型。
getDocument() - 类 javax.swing.text.View 中的方法
获取与视图关联的模型。
getDocumentBase() - 类 java.applet.Applet 中的方法
获取嵌入此 applet 的文档的 URL。
getDocumentBase() - 接口 java.applet.AppletStub 中的方法
获取嵌入 applet 的文档的 URL。
getDocumentBase() - 类 javax.management.loading.MLetContent 中的方法
获取 MLet 文本文件的基本 URL。
getDocumentElement() - 接口 org.w3c.dom.Document 中的方法
这是一种便捷属性，该属性允许直接访问文档的文档元素的子节点。
getDocumentFilter() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
如果想要提供某个 DocumentFilter 以限制输入内容，则应进行子类化和重写。
getDocumentFilter() - 类 javax.swing.text.AbstractDocument 中的方法
返回负责进行插入/移除过滤的 DocumentFilter。
getDocumentFilter() - 类 javax.swing.text.DefaultFormatter 中的方法
返回用于限制放置到 JFormattedTextField 中的字符的 DocumentFilter。
getDocumentListeners() - 类 javax.swing.text.AbstractDocument 中的方法
返回在此文档上注册的所有文档侦听器的数组。
getDocumentProperties() - 类 javax.swing.text.AbstractDocument 中的方法
支持管理属性集。
getDocumentTypeDeclaration() - 接口 javax.xml.stream.events.DTD 中的方法
以字符串形式返回完整文档类型声明，其中包括内部 DTD 子集。
getDocumentURI() - 接口 org.w3c.dom.Document 中的方法
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。
getDoInput() - 类 java.net.URLConnection 中的方法
返回此 URLConnection 的 doInput 标志的值。
getDomain() - 类 java.net.HttpCookie 中的方法
返回为此 cookie 设置的域名。
getDomain() - 类 javax.management.ObjectName 中的方法
返回域部分。
getDomainCombiner() - 类 java.security.AccessControlContext 中的方法
获取与此 AccessControlContext 关联的 DomainCombiner。
getDomains() - 接口 javax.management.MBeanServer 中的方法

getDomains() - 接口 javax.management.MBeanServerConnection 中的方法
返回其中所有 MBean 当前已注册的域的列表。
getDomains(Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getDomains() 方法。
getDomains(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getDomains(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getDomConfig() - 接口 org.w3c.dom.Document 中的方法
调用 Document.normalizeDocument() 时使用的配置。
getDomConfig() - 接口 org.w3c.dom.ls.LSParser 中的方法
解析输入源时使用的 DOMConfiguration 对象。
getDomConfig() - 接口 org.w3c.dom.ls.LSSerializer 中的方法
在序列化 DOM 节点时由 LSSerializer 使用的 DOMConfiguration 对象。
getDOMImplementation() - 类 javax.xml.parsers.DocumentBuilder 中的方法
获取 DOMImplementation 对象的一个实例。
getDOMImplementation(String) - 类 org.w3c.dom.bootstrap.DOMImplementationRegistry 中的方法
返回第一个具有所需功能的实现；如果找不到具有所需功能的任何实现，则返回 null。
getDOMImplementation(String) - 接口 org.w3c.dom.DOMImplementationSource 中的方法
请求支持指定的功能的第一个 DOM 实现的方法。
getDOMImplementationList(String) - 类 org.w3c.dom.bootstrap.DOMImplementationRegistry 中的方法
返回支持所需功能的实现列表。
getDOMImplementationList(String) - 接口 org.w3c.dom.DOMImplementationSource 中的方法
请求支持指定功能和版本的 DOM 实现的列表的方法，如下所述。
getDoOutput() - 类 java.net.URLConnection 中的方法
返回此 URLConnection 的 doOutput 标志的值。
getDot() - 类 javax.swing.event.CaretEvent 中的方法
获得插入符的位置。
getDot() - 接口 javax.swing.text.Caret 中的方法
获取插入符的当前位置。
getDot() - 类 javax.swing.text.DefaultCaret 中的方法
获取插入符的当前位置。
getDotBias() - 类 javax.swing.text.DefaultCaret 中的方法
返回插入符位置的偏差。
getDouble(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 double 形式返回指定数组对象中索引组件的值。
getDouble(Object) - 类 java.lang.reflect.Field 中的方法
获取 double 类型或另一个通过扩展转换可以转换为 double 类型的基本类型的静态或实例字段的值。
getDouble() - 类 java.nio.ByteBuffer 中的方法
用于读取 double 值的相对 get 方法。
getDouble(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 double 值的绝对 get 方法。
getDouble(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 double 值的形式获取指定的 JDBC DOUBLE 参数的值。
getDouble(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 double 值的形式获取 JDBC DOUBLE 参数的值。
getDouble(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。
getDouble(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。
getDouble(String, double) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getDouble(String,double) 中的规范实现 getDouble 方法。
getDouble(String, double) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定的键相关联的、由字符串表示的 double 值。
getDoubleBufferMaximumSize() - 类 javax.swing.RepaintManager 中的方法
返回最大双缓冲区大小。
getDoubleParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 double 返回参数的便捷方法。
getDragAction() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回用户所选操作的 int 表示形式。
getDragEnabled() - 类 javax.swing.JColorChooser 中的方法
获取 dragEnabled 属性的值。
getDragEnabled() - 类 javax.swing.JFileChooser 中的方法
获得 dragEnabled 属性的值。
getDragEnabled() - 类 javax.swing.JList 中的方法
返回是否启用自动拖动处理。
getDragEnabled() - 类 javax.swing.JTable 中的方法
返回是否启用自动拖动处理。
getDragEnabled() - 类 javax.swing.JTree 中的方法
返回是否启用自动拖动处理。
getDragEnabled() - 类 javax.swing.text.JTextComponent 中的方法
返回是否启用自动拖动处理。
getDraggedColumn() - 类 javax.swing.table.JTableHeader 中的方法
当且仅当正在进行拖动时，返回被拖动的列，否则返回 null。
getDraggedDistance() - 类 javax.swing.table.JTableHeader 中的方法
当且仅当正在进行拖动时，返回该列到其初始位置的水平距离。
getDragMode() - 类 javax.swing.JDesktopPane 中的方法
获取桌面窗格当前使用的“拖动样式”。
getDragOrigin() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回 Component 坐标中开始拖动位置的 Point。
getDragSource() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回 DragSource。
getDragSource() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
此方法返回 DragSource，为了进行 Drag 和 Drop 操作，将使用此 DragGestureRecognizer。
getDragSource() - 类 java.awt.dnd.DragSourceContext 中的方法
返回实例化此 DragSourceContext 的 DragSource。
getDragSourceContext() - 类 java.awt.dnd.DragSourceEvent 中的方法
此方法返回引起事件的 DragSourceContext。
getDragSourceListeners() - 类 java.awt.dnd.DragSource 中的方法
获得向此 DragSource 注册的所有 DragSourceListener。
getDragSourceMotionListeners() - 类 java.awt.dnd.DragSource 中的方法
获得向此 DragSource 注册的所有 DragSourceMotionListener。
getDragThreshold() - 类 java.awt.dnd.DragSource 中的静态方法
返回拖动操作移动阈值。
getDrawGraphics() - 类 java.awt.Component.BltBufferStrategy 中的方法

getDrawGraphics() - 类 java.awt.Component.FlipBufferStrategy 中的方法

getDrawGraphics() - 类 java.awt.image.BufferStrategy 中的方法
创建用于绘制缓冲区的图形上下文。
getDrawsLayeredHighlights() - 类 javax.swing.text.DefaultHighlighter 中的方法

getDriver(String) - 类 java.sql.DriverManager 中的静态方法
试图查找能理解给定 URL 的驱动程序。
getDriverMajorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此 JDBC 驱动程序的主版本号。
getDriverMinorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此 JDBC 驱动程序的次版本号。
getDriverName() - 接口 java.sql.DatabaseMetaData 中的方法
获取此 JDBC 驱动程序的名称。
getDrivers() - 类 java.sql.DriverManager 中的静态方法
获取带有当前调用者可以访问的所有当前已加载 JDBC 驱动程序的 Enumeration。
getDriverVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此 JDBC 驱动程序的 String 形式的版本号。
getDropAction() - 类 java.awt.dnd.DragSourceDragEvent 中的方法
此方法返回目标放置动作与拖动源支持的放置动作集合的逻辑交集。
getDropAction() - 类 java.awt.dnd.DragSourceDropEvent 中的方法
此方法返回一个 int 值，表示放置主题目标执行的操作。
getDropAction() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回用户 drop 操作。
getDropAction() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回用户 drop 操作。
getDropAction() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
当此 TransferSupport 表示放置操作时，返回为其选择的动作。
getDropLocation() - 类 javax.swing.JList 中的方法
返回在该组件上执行 DnD 操作期间此组件应该视觉上指示为放置位置的位置；如果当前没有任何显示的位置，则返回 null。
getDropLocation() - 类 javax.swing.JTable 中的方法
返回对组件的 DnD 操作期间此组件应该可见地指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。
getDropLocation() - 类 javax.swing.JTree 中的方法
返回该组件上 DnD 操作期间此组件应该视觉上指示为放置操作的位置；如果当前未显示任何位置，则返回 null。
getDropLocation() - 类 javax.swing.text.JTextComponent 中的方法
返回在组件上进行 DnD 操作过程中此组件在视觉上指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。
getDropLocation() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
此 TransferSupport 表示一个放置操作时，返回组件的当前放置位置（非 null）。
getDropMode() - 类 javax.swing.JList 中的方法
返回此组件的放置模式。
getDropMode() - 类 javax.swing.JTable 中的方法
返回此组件的放置模式。
getDropMode() - 类 javax.swing.JTree 中的方法
返回此组件的放置模式。
getDropMode() - 类 javax.swing.text.JTextComponent 中的方法
返回此组件的放置模式。
getDropPoint() - 类 javax.swing.TransferHandler.DropLocation 中的方法
返回放置点，表示组件内鼠标的当前位置。
getDropSuccess() - 类 java.awt.dnd.DragSourceDropEvent 中的方法
此方法返回表示放置是否成功的 boolean 值。
getDropTarget() - 类 java.awt.Component 中的方法
获取与此 Component 相关的 DropTarget。
getDropTarget() - 类 java.awt.dnd.DropTargetContext 中的方法
此方法返回与此 DropTargetContext 相关的 DropTarget。
getDropTargetContext() - 类 java.awt.dnd.DropTarget 中的方法
获取与此 DropTarget 关联的 DropTargetContext。
getDropTargetContext() - 类 java.awt.dnd.DropTargetEvent 中的方法
此方法返回与该 DropTargetEvent 相关的 DropTargetContext。
getDSTSavings() - 类 java.util.SimpleTimeZone 中的方法
返回设置在夏令时期间时钟提前的时间量（以毫秒为单位）。
getDSTSavings() - 类 java.util.TimeZone 中的方法
返回要添加到本地标准时间以获取本地挂钟时间的时间量。
getDTD(String) - 类 javax.swing.text.html.parser.DTD 中的静态方法
返回具有指定 name 的 DTD。
getDTDHandler() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
返回当前 DTD 处理程序。
getDTDHandler() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
获取当前 DTD 事件处理程序。
getDTDHandler() - 接口 org.xml.sax.XMLReader 中的方法
返回当前的 DTD 处理程序。
getDTDType() - 接口 javax.xml.stream.events.Attribute 中的方法
获取此属性的类型，默认值是字符串 "CDATA"，
getEarliestSequenceNumber() - 类 javax.management.remote.NotificationResult 中的方法
返回缓存中保留的最早通知的序列号。
getEarlyReflectionDelay() - 类 javax.sound.sampled.ReverbType 中的方法
返回早期反射延迟时间，以微秒为单位。
getEarlyReflectionIntensity() - 类 javax.sound.sampled.ReverbType 中的方法
返回早期反射密度，以分贝为单位。
getEastPane() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getEchoChar() - 类 java.awt.TextField 中的方法
获取用于回显的字符。
getEchoChar() - 类 javax.swing.JPasswordField 中的方法
返回要用于回显的字符。
getEdgeCondition() - 类 java.awt.image.ConvolveOp 中的方法
返回边缘条件。
getEdit() - 类 javax.swing.event.UndoableEditEvent 中的方法
返回 edit 值。
getEditFormatter() - 类 javax.swing.text.DefaultFormatterFactory 中的方法
返回在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
getEditingColumn() - 类 javax.swing.JTable 中的方法
返回包含当前被编辑的单元格的列索引。
getEditingPath() - 类 javax.swing.JTree 中的方法
返回当前正在编辑的元素的路径。
getEditingPath(JTree) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回到达正被编辑的元素的路径。
getEditingPath(JTree) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getEditingPath 方法。
getEditingPath(JTree) - 类 javax.swing.plaf.TreeUI 中的方法
返回到达正被编辑的元素的路径。
getEditingRow() - 类 javax.swing.JTable 中的方法
返回包含当前被编辑的单元格的行索引。
getEditor() - 类 javax.swing.JComboBox 中的方法
返回用于绘制和编辑 JComboBox 字段中所选项的编辑器。
getEditor() - 类 javax.swing.JSpinner 中的方法
返回显示和潜在更改模型值的组件。
getEditor(ActionEvent) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 中的方法
获得操作的目标编辑器。
getEditorComponent() - 接口 javax.swing.ComboBoxEditor 中的方法
返回应该添加到此编辑器的树层次结构中的组件。
getEditorComponent() - 类 javax.swing.JTable 中的方法
返回处理编辑会话的组件。
getEditorComponent() - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法

getEditorKit() - 类 javax.swing.JEditorPane 中的方法
获取用于处理内容的、当前已安装的工具包。
getEditorKit(JTextComponent) - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的方法
获取 UI 的 EditorKit。
getEditorKit(JTextComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取 UI 的 EditorKit。
getEditorKit(JTextComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getEditorKit 方法。
getEditorKit(JTextComponent) - 类 javax.swing.plaf.TextUI 中的方法
获取为要编辑的文档类型设置策略的服务绑定。
getEditorKitClassNameForContentType(String) - 类 javax.swing.JEditorPane 中的静态方法
返回当前向类型 type 所注册的 EditorKit 类名。
getEditorKitForContentType(String) - 类 javax.swing.JEditorPane 中的方法
获取用于给定内容类型的编辑器工具包。
getEditorSearchPath() - 类 java.beans.PropertyEditorManager 中的静态方法
获得用来搜索属性编辑器的包名称。
getEffectiveKeyBits() - 类 javax.crypto.spec.RC2ParameterSpec 中的方法
返回以位为单位的有效密钥大小。
getElem(int) - 类 java.awt.image.DataBuffer 中的方法
以整数类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBuffer 中的方法
以整数类型返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferByte 中的方法
返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferByte 中的方法
返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferDouble 中的方法
以 int 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferDouble 中的方法
以 int 类型返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferFloat 中的方法
以 int 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferFloat 中的方法
以 int 类型返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferInt 中的方法
返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferInt 中的方法
返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferShort 中的方法
返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferShort 中的方法
返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferUShort 中的方法
返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferUShort 中的方法
返回指定存储单元中所请求的数据数组元素。
getElemDouble(int) - 类 java.awt.image.DataBuffer 中的方法
以 double 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElemDouble(int, int) - 类 java.awt.image.DataBuffer 中的方法
以 double 类型返回指定存储单元所请求的数据数组元素。
getElemDouble(int) - 类 java.awt.image.DataBufferDouble 中的方法
以 double 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElemDouble(int, int) - 类 java.awt.image.DataBufferDouble 中的方法
以 double 类型返回指定存储单元中所请求的数据数组元素。
getElemDouble(int) - 类 java.awt.image.DataBufferFloat 中的方法
以 double 类型返回第一个（默认）存储单元所请求的数据数组元素。
getElemDouble(int, int) - 类 java.awt.image.DataBufferFloat 中的方法
以 double 类型返回指定存储单元所请求的数据数组元素。
getElement() - 接口 javax.swing.event.DocumentEvent.ElementChange 中的方法
返回所表示的元素。
getElement(int) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取子元素。
getElement(int) - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得一个子元素。
getElement() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
返回基础元素。
getElement(int) - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
获得一个子元素。
getElement(int) - 接口 javax.swing.text.Element 中的方法
获取给定索引处的子元素。
getElement(String) - 类 javax.swing.text.html.HTMLDocument 中的方法
返回具有给定 id Attribute 的元素。
getElement(Element, Object, Object) - 类 javax.swing.text.html.HTMLDocument 中的方法
返回 e（它包含具有值 value 的属性 attribute）的子元素，如果未找到，则返回 null。
getElement(String) - 类 javax.swing.text.html.parser.DTD 中的方法
按名称获取一个元素。
getElement(int) - 类 javax.swing.text.html.parser.DTD 中的方法
按索引获取一个元素。
getElement() - 类 javax.swing.text.html.parser.TagElement 中的方法

getElement() - 类 javax.swing.text.View 中的方法
获取此视图所映射的主题的结构化部分。
getElement(ResultT) - 接口 javax.xml.bind.annotation.DomHandler 中的方法
将部分发送到 Result 后，JAXB 提供者将调用此方法来获取已解组元素表示形式。
getElement(DOMResult) - 类 javax.xml.bind.annotation.W3CDomHandler 中的方法

getElementAt(int) - 类 javax.swing.DefaultComboBoxModel 中的方法

getElementAt(int) - 类 javax.swing.DefaultListModel 中的方法
返回指定索引处的组件。
getElementAt(int) - 接口 javax.swing.ListModel 中的方法
返回指定索引处的值。
getElementAt(int) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法

getElementAt(int) - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 中的方法

getElementAt(int) - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的方法

getElementById(String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
返回具有指定 ID 属性值的 Element。
getElementById(String) - 接口 org.w3c.dom.Document 中的方法
返回具有带给定值的 ID 属性的 Element。
getElementCount() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素子级的数量。
getElementCount() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得该元素的子元素数。
getElementCount() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
返回子元素的数量。
getElementCount() - 接口 javax.swing.text.Element 中的方法
获得此元素包含的子元素数。
getElementDescription(String, Locale) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回包含指定元素的描述的 String，或者 null。
getElementDescription(String, Locale) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
返回包含指定元素的描述的 String，或者 null。
getElementIndex(int) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取最接近给定模型偏移量的子元素索引。
getElementIndex(int) - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得与给定模型偏移量最接近的子元素索引。
getElementIndex(int) - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
获得与给定模型偏移量最接近的子元素索引。
getElementIndex(int) - 接口 javax.swing.text.Element 中的方法
获得离给定偏移量最近的子元素索引。
getElementIterator() - 类 javax.swing.text.AbstractWriter 中的方法
获取 ElementIterator。
getElementMaxChildren(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最大子元素数。
getElementMaxChildren(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getElementMinChildren(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最小子元素数。
getElementMinChildren(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getElementName(Object) - 类 javax.xml.bind.JAXBIntrospector 中的方法
获取 jaxbElement 的 xml 元素 qname。
getElementName() - 接口 javax.xml.soap.SOAPElement 中的方法
返回此 SOAPElement 对象的名称。
getElementOpenType() - 类 javax.management.openmbean.ArrayType 中的方法
返回此 ArrayType 实例描述的数组中包含的元素值的开放类型。
getElementQName() - 接口 javax.xml.soap.SOAPElement 中的方法
返回此 SOAPElement 对象的 qname。
getElements() - 类 javax.swing.ButtonGroup 中的方法
返回此组中的所有按钮。
getElements(Vector<Element>) - 类 javax.swing.text.html.parser.ContentModel 中的方法
使用作为此 contentModel 一部分的元素列表更新 elemVec。
getElementsAnnotatedWith(TypeElement) - 接口 javax.annotation.processing.RoundEnvironment 中的方法
返回使用给定注释类型注释的元素。
getElementsAnnotatedWith(Class<? extends Annotation>) - 接口 javax.annotation.processing.RoundEnvironment 中的方法
返回使用给定注释类型注释的元素。
getElementsAt(HTMLDocument, int) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 中的方法
返回包含 offset 的 Elements 数组。
getElementsByTagName(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getElementsByTagName(String) - 接口 org.w3c.dom.Document 中的方法
按文档顺序返回包含在文档中且具有给定标记名称的所有 Element 的 NodeList。
getElementsByTagName(String) - 接口 org.w3c.dom.Element 中的方法
以文档顺序返回具有给定标记名称的所有后代 Elements 的 NodeList。
getElementsByTagNameNS(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 getElementsByTagName(localName)。
getElementsByTagNameNS(String, String) - 接口 org.w3c.dom.Document 中的方法
以文档顺序返回具有给定本地名称和名称空间 URI 的所有 Elements 的 NodeList。
getElementsByTagNameNS(String, String) - 接口 org.w3c.dom.Element 中的方法
以文档顺序返回具有给定本地名称和名称空间 URI 的所有后代 Elements 的 NodeList。
getElementText() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法

getElementText() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getElementText() - 接口 javax.xml.stream.XMLEventReader 中的方法
读取纯文本元素的内容。
getElementText() - 接口 javax.xml.stream.XMLStreamReader 中的方法
读取纯文本元素的内容，如果不是纯文本元素，则抛出异常。
getElementTypeInfo() - 类 javax.xml.validation.TypeInfoProvider 中的方法
返回当前元素的不可变的 TypeInfo 对象。
getElementUtils() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回用来在元素上进行操作的某些实用工具方法的实现。
getElementValues() - 接口 javax.lang.model.element.AnnotationMirror 中的方法
返回此注释元素的值。
getElementValuesWithDefaults(AnnotationMirror) - 接口 javax.lang.model.util.Elements 中的方法
返回注释元素的值，包括默认值。
getElemFloat(int) - 类 java.awt.image.DataBuffer 中的方法
以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElemFloat(int, int) - 类 java.awt.image.DataBuffer 中的方法
以 float 类型返回指定存储单元中所请求的数据数组元素。
getElemFloat(int) - 类 java.awt.image.DataBufferDouble 中的方法
以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElemFloat(int, int) - 类 java.awt.image.DataBufferDouble 中的方法
以 float 类型返回指定存储单元中所请求的数据数组元素。
getElemFloat(int) - 类 java.awt.image.DataBufferFloat 中的方法
以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElemFloat(int, int) - 类 java.awt.image.DataBufferFloat 中的方法
以 float 类型返回指定存储单元中所请求的数据数组元素。
getEmptySet() - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
获取一个空的 AttributeSet。
getEmptySet() - 类 javax.swing.text.StyleContext 中的方法
获取空 AttributeSet。
getEnabledAttributes() - 类 javax.management.AttributeChangeNotificationFilter 中的方法
获得此过滤器的所有已启用属性名称。
getEnabledCipherSuites() - 类 javax.net.ssl.SSLEngine 中的方法
返回为了在此引擎上使用而当前已启用的 SSL 密码套件名称。
getEnabledCipherSuites() - 类 javax.net.ssl.SSLServerSocket 中的方法
返回当前被启用以供新接受的连接使用的密码套件列表。
getEnabledCipherSuites() - 类 javax.net.ssl.SSLSocket 中的方法
返回当前启用以供此连接使用的 SSL 密码套件的名称。
getEnabledCipherSuites() - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的密码套件的名称，如果此工厂使用默认启用的密码套件，则返回 null。
getEnabledObjectNames() - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
获取所有已启用的 ObjectName。
getEnabledProtocols() - 类 javax.net.ssl.SSLEngine 中的方法
返回当前已启用的，以便让 SSLEngine 使用的协议版本的名称。
getEnabledProtocols() - 类 javax.net.ssl.SSLServerSocket 中的方法
返回当前新接受的连接启用的协议的名称。
getEnabledProtocols() - 类 javax.net.ssl.SSLSocket 中的方法
返回当前启用以供此连接使用的协议版本的名称。
getEnabledProtocols() - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的协议版本的名称，如果此工厂使用默认启用的协议版本，则返回 null。
getEnabledTypes() - 类 javax.management.NotificationFilterSupport 中的方法
获得此过滤器的所有允许通知类型。
getEnableSessionCreation() - 类 javax.net.ssl.SSLEngine 中的方法
如果可以由此引擎建立新的 SSL 会话，则返回 true。
getEnableSessionCreation() - 类 javax.net.ssl.SSLServerSocket 中的方法
如果新 SSL 会话可以通过此服务器套接字创建的套接字建立，则返回 true。
getEnableSessionCreation() - 类 javax.net.ssl.SSLSocket 中的方法
如果可以使用此套接字建立新的 SSL 会话，则返回 true。
getEnclosedElements() - 接口 javax.lang.model.element.Element 中的方法
返回此元素直接封装（非严格意义上）的元素。
getEnclosingClass() - 类 java.lang.Class 中的方法
返回底层类的立即封闭类。
getEnclosingConstructor() - 类 java.lang.Class 中的方法
如果该 Class 对象表示构造方法中的一个本地或匿名类，则返回 Constructor 对象，它表示底层类的立即封闭构造方法。
getEnclosingElement() - 接口 javax.lang.model.element.Element 中的方法
返回封装此元素（非严格意义上）的最里层元素。
getEnclosingMethod() - 类 java.lang.Class 中的方法
如果此 Class 对象表示某一方法中的一个本地或匿名类，则返回 Method 对象，它表示底层类的立即封闭方法。
getEnclosingType() - 接口 javax.lang.model.type.DeclaredType 中的方法
返回封装实例的最里层类型；如果没有任何封装实例，则返回种类为 NONE 的 NoType。
getEncoded() - 类 java.security.AlgorithmParameters 中的方法
返回基本编码格式的参数。
getEncoded(String) - 类 java.security.AlgorithmParameters 中的方法
返回以指定方案编码的参数。
getEncoded() - 类 java.security.cert.Certificate 中的方法
返回此证书的编码形式。
getEncoded() - 类 java.security.cert.CertPath 中的方法
返回此证书路径的编码形式，使用默认的编码。
getEncoded(String) - 类 java.security.cert.CertPath 中的方法
返回此证书路径的编码形式，使用指定的编码。
getEncoded() - 类 java.security.cert.PolicyQualifierInfo 中的方法
返回此 PolicyQualifierInfo 的 ASN.1 DER 编码形式。
getEncoded() - 类 java.security.cert.X509CRL 中的方法
返回此 CRL 的 ASN.1 DER 编码形式。
getEncoded() - 类 java.security.cert.X509CRLEntry 中的方法
返回此 CRL Entry 的 ASN.1 DER 编码形式，即内部 SEQUENCE。
getEncoded() - 接口 java.security.Key 中的方法
返回基本编码格式的密钥，如果此密钥不支持编码，则返回 null。
getEncoded() - 类 java.security.spec.EncodedKeySpec 中的方法
返回编码密钥。
getEncoded() - 类 java.security.spec.PKCS8EncodedKeySpec 中的方法
返回按照 PKCS #8 标准编码的密钥字节。
getEncoded() - 类 java.security.spec.X509EncodedKeySpec 中的方法
返回按照 X.509 标准进行编码的密钥的字节。
getEncoded() - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
返回此对象的 ASN.1 编码。
getEncoded() - 类 javax.crypto.spec.SecretKeySpec 中的方法
返回此密钥的密钥内容。
getEncoded() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回秘密密钥的密钥材料。
getEncoded() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回整个票据的 ASN.1 编码。
getEncoded() - 类 javax.security.auth.x500.X500Principal 中的方法
返回 ASN.1 DER 编码形式的标识名。
getEncoded() - 类 javax.security.cert.Certificate 中的方法
返回此证书的编码形式。
getEncodedValue() - 类 javax.naming.ldap.BasicControl 中的方法
检索控件的 ASN.1 BER 编码值。
getEncodedValue() - 接口 javax.naming.ldap.Control 中的方法
检索 LDAP 控件的 ASN.1 BER 编码值。
getEncodedValue() - 接口 javax.naming.ldap.ExtendedRequest 中的方法
检索 LDAP 扩展操作请求的 ASN.1 BER 编码值。
getEncodedValue() - 接口 javax.naming.ldap.ExtendedResponse 中的方法
检索 LDAP 扩展操作响应的 ASN.1 BER 编码值。
getEncodedValue() - 类 javax.naming.ldap.StartTlsRequest 中的方法
检索 StartTLS 请求的 ASN.1 BER 编码值。
getEncodedValue() - 类 javax.naming.ldap.StartTlsResponse 中的方法
检索 StartTLS 响应的 ASN.1 BER 编码值。
getEncoding() - 类 java.io.InputStreamReader 中的方法
返回此流使用的字符编码的名称。
getEncoding() - 类 java.io.OutputStreamWriter 中的方法
返回此流使用的字符编码的名称。
getEncoding() - 类 java.util.logging.Handler 中的方法
返回该 Handler 的字符编码。
getEncoding() - 类 javax.sound.sampled.AudioFormat 中的方法
获取此格式声音的编码类型。
getEncoding() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
获取当前输出编码的便捷方法。
getEncoding() - 接口 javax.xml.crypto.dsig.XMLObject 中的方法
返回此 XMLObject 的编码 URI。
getEncoding() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getEncoding() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果输入编码已知，则返回输入编码；如果未知，则返回 null。
getEncoding() - 接口 org.w3c.dom.ls.LSInput 中的方法
字符编码（如果已知）。
getEncoding() - 接口 org.w3c.dom.ls.LSOutput 中的方法
用于输出的字符编码。
getEncoding() - 接口 org.xml.sax.ext.Locator2 中的方法
返回实体的字符编码的名称。
getEncoding() - 类 org.xml.sax.ext.Locator2Impl 中的方法
返回编码属性的当前值。
getEncoding() - 类 org.xml.sax.InputSource 中的方法
获取字节流或 URI 的字符编码。
getEncodings() - 类 java.security.cert.CertPath 中的方法
返回此证书路径支持的编码的迭代，默认编码方式优先。
getEncodingStyle() - 接口 javax.xml.soap.SOAPElement 中的方法
返回此 SOAPElement 对象的编码样式。
getEncryptedData() - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
返回加密的数据。
getEnd() - 类 javax.swing.SpinnerDateModel 中的方法
返回序列中的最后一个 Date。
getEndCap() - 类 java.awt.BasicStroke 中的方法
返回端点的 cap 样式。
getEndIndex() - 接口 java.text.CharacterIterator 中的方法
返回文本的结束索引。
getEndIndex() - 类 java.text.FieldPosition 中的方法
获取紧跟请求字段中最后一个字符的字符索引。
getEndIndex() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.getEndIndex()。
getEndIndex() - 类 javax.accessibility.AccessibleHyperlink 中的方法
获得此链接结束处该超文本文档的索引
getEndIndex() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
获得此链接结束处该超文本文档的索引
getEndIndex() - 类 javax.swing.text.Segment 中的方法
返回文本的结束索引。
getEndOffset() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素在此模型中的终止偏移量。
getEndOffset() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得模型中该元素的结束偏移量。
getEndOffset() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
获得模型中该元素的结束偏移量。
getEndOffset() - 类 javax.swing.text.AbstractWriter 中的方法
选择要输出内容的最后一个偏移量。
getEndOffset() - 接口 javax.swing.text.Element 中的方法
获取此元素结束处的文档起始偏移量。
getEndOffset() - 类 javax.swing.text.GlyphView 中的方法
获取此视图负责的一部分模型。
getEndOffset() - 接口 javax.swing.text.Highlighter.Highlight 中的方法
获取高亮显示结束模型偏移量。
getEndOffset() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
返回当前出现的标记所定义的并具有相同属性的范围结尾处。
getEndOffset() - 类 javax.swing.text.View 中的方法
获取此视图负责的模型的一部分。
getEndPoint() - 类 java.awt.geom.Arc2D 中的方法
返回弧的结束点。
getEndPoint() - 类 java.awt.LinearGradientPaint 中的方法
返回渐变轴结束点的副本。
getEndPosition() - 类 javax.swing.text.AbstractDocument 中的方法
返回表示文档结尾的位置。
getEndPosition() - 接口 javax.swing.text.Document 中的方法
返回代表文档结束处的位置。
getEndPosition() - 接口 javax.tools.Diagnostic 中的方法
获取距文件开始位置的字符偏移量，其中文件与指示问题结束位置的此诊断关联。
getEndTime() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回此票据有效期的期满时间。
getEngine() - 类 javax.script.CompiledScript 中的方法
返回用 compile 方法创建了此 CompiledScript 的 ScriptEngine。
getEngineByExtension(String) - 类 javax.script.ScriptEngineManager 中的方法
查找并创建一个给定扩展的 ScriptEngine。
getEngineByMimeType(String) - 类 javax.script.ScriptEngineManager 中的方法
查找并创建一个给定 mime 类型的 ScriptEngine。
getEngineByName(String) - 类 javax.script.ScriptEngineManager 中的方法
查找并创建一个给定名称的 ScriptEngine。
getEngineFactories() - 类 javax.script.ScriptEngineManager 中的方法
返回一个数组，该数组的元素是发现机制找到的所有 ScriptEngineFactory 类的实例。
getEngineName() - 接口 javax.script.ScriptEngineFactory 中的方法
返回 ScriptEngine 的完全名称。
getEngineVersion() - 接口 javax.script.ScriptEngineFactory 中的方法
返回 ScriptEngine 的版本。
getEntities() - 接口 javax.xml.stream.events.DTD 中的方法
返回一个列表，其中包含在 DTD 中声明的外部和内部常规实体。
getEntities() - 接口 org.w3c.dom.DocumentType 中的方法
包含在 DTD 中声明的内部和外部常规实体的 NamedNodeMap。
getEntity(String) - 类 javax.swing.text.html.parser.DTD 中的方法
按名称获取一个实体。
getEntity(int) - 类 javax.swing.text.html.parser.DTD 中的方法
获取一个字符实体。
getEntityResolver() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
返回当前实体解析器。
getEntityResolver() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
获取当前实体解析器。
getEntityResolver() - 接口 org.xml.sax.XMLReader 中的方法
返回当前的实体解析器。
getEntries() - 类 java.util.jar.Manifest 中的方法
返回此 Manifest 中所包含条目的 Map。
getEntry(String, KeyStore.ProtectionParameter) - 类 java.security.KeyStore 中的方法
使用指定保护参数获取指定别名的 keystore Entry。
getEntry(String) - 类 java.util.jar.JarFile 中的方法
返回给定条目名称的 ZipEntry；如果未找到，则返回 null。
getEntry(String) - 类 java.util.zip.ZipFile 中的方法
返回指定名称的 ZIP 文件条目；如果未找到，则返回 null。
getEntryName() - 类 java.net.JarURLConnection 中的方法
返回此连接的条目名称。
getEnumConstants() - 类 java.lang.Class 中的方法
如果此 Class 对象不表示枚举类型，则返回枚举类的元素或 null。
getEnumValueTable() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的枚举类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Chromaticity 中的方法
返回 Chromaticity 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.ColorSupported 中的方法
返回 ColorSupported 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Compression 中的方法
返回 Compression 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Fidelity 中的方法
返回 Fidelity 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Finishings 中的方法
返回 Finishings 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.JobSheets 中的方法
返回 class JobSheets 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.JobState 中的方法
返回 JobState 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.JobStateReason 中的方法
返回 JobStateReason 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.MediaName 中的方法
返回 MediaTray 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.MediaSizeName 中的方法
返回 MediaSizeName 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.MediaTray 中的方法
返回 MediaTray 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的方法
返回 MultipleDocumentHandling 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.OrientationRequested 中的方法
返回类 OrientationRequested 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PDLOverrideSupported 中的方法
返回类 PDLOverrideSupported 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PresentationDirection 中的方法
返回类 PresentationDirection 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的方法
返回类 PrinterIsAcceptingJobs 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PrinterState 中的方法
返回类 PrinterState 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PrinterStateReason 中的方法
返回类 PrinterStateReason 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PrintQuality 中的方法
返回类 PrintQuality 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的方法
返回类 ReferenceUriSchemesSupported 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Severity 中的方法
返回类 Severity 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.SheetCollate 中的方法
返回类 SheetCollate 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Sides 中的方法
返回类 Sides 的枚举值表。
getenv(String) - 类 java.lang.System 中的静态方法
获取指定的环境变量值。
getenv() - 类 java.lang.System 中的静态方法
返回一个不能修改的当前系统环境的字符串映射视图。
getEnvelope() - 类 javax.xml.soap.SOAPPart 中的方法
获取与此 SOAPPart 对象关联的 SOAPEnvelope 对象。
getEnvironment() - 异常 javax.naming.CannotProceedException 中的方法
检索创建此异常时受影响的环境。
getEnvironment() - 接口 javax.naming.Context 中的方法
检索对此上下文有效的环境。
getEnvironment() - 类 javax.naming.InitialContext 中的方法

getEon() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回 year XML 模式 1.0 日期时间数据类型字段的高顺序组件。
getEonAndYear() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回 year XML 模式 1.0 的日期时间数据类型字段。
getEras() - 类 java.text.DateFormatSymbols 中的方法
获取年代字符串。
getErrorCode() - 异常 java.sql.SQLException 中的方法
获取此 SQLException 对象的特定于供应商的异常代码。
getErrorCode() - 异常 javax.xml.bind.JAXBException 中的方法
获取特定于供应商的错误代码。
getErrorCode() - 异常 javax.xml.bind.TypeConstraintException 中的方法
获取特定于供应商的错误代码。
getErrorHandler() - 类 javax.xml.validation.SchemaFactory 中的方法
获取设置为此 SchemaFactory 的当前 ErrorHandler。
getErrorHandler() - 类 javax.xml.validation.Validator 中的方法
获取设置为此 Validator 的当前 ErrorHandler。
getErrorHandler() - 类 javax.xml.validation.ValidatorHandler 中的方法
获取设置为此 ValidatorHandler 的当前 ErrorHandler。
getErrorHandler() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
返回当前错误处理程序。
getErrorHandler() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
获取当前错误事件处理程序。
getErrorHandler() - 接口 org.xml.sax.XMLReader 中的方法
返回当前的错误处理程序。
getErrorIndex() - 类 java.text.ParsePosition 中的方法
获取出错时的索引，如果没有设置错误索引，则为 -1。
getErrorListener() - 类 javax.xml.transform.Transformer 中的方法
获取转换的实际错误事件处理程序。
getErrorListener() - 类 javax.xml.transform.TransformerFactory 中的方法
获取 TransformerFactory 的错误事件处理程序。
getErrorManager() - 类 java.util.logging.Handler 中的方法
获取该 Handler 的 ErrorManager。
getErrorOffset() - 异常 java.text.ParseException 中的方法
返回发现错误的位置。
getErrorsAny() - 类 java.awt.MediaTracker 中的方法
返回所有出错媒体的列表。
getErrorsID(int) - 类 java.awt.MediaTracker 中的方法
返回具有出错的指定 ID 的媒体列表。
getErrorStream() - 类 java.lang.Process 中的方法
获取子进程的错误流。
getErrorStream() - 类 java.net.HttpURLConnection 中的方法
如果连接失败但服务器仍然发送了有用数据，则返回错误流。
getErrorWriter() - 接口 javax.script.ScriptContext 中的方法
返回用来显示错误输出的 Writer。
getErrorWriter() - 类 javax.script.SimpleScriptContext 中的方法
返回用来显示错误输出的 Writer。
getEscapeProcessing() - 类 javax.sql.rowset.BaseRowSet 中的方法
确定是否为此 RowSet 对象启用了转义处理。
getEscapeProcessing() - 接口 javax.sql.RowSet 中的方法
获取是否为此 RowSet 对象启用转义处理。
getEstimatedMajorSpan() - 类 javax.swing.text.AsyncBoxView 中的方法
主跨距当前是估计值吗？
getEtchedBorderUIResource() - 类 javax.swing.plaf.BorderUIResource 中的静态方法

getEtchedInsets() - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
返回 drawEtchedRect() 绘制边框占用的空间量。
getEtchType() - 类 javax.swing.border.EtchedBorder 中的方法
返回浮雕化边框设置的蚀刻类型。
getEventAllocator() - 类 javax.xml.stream.XMLInputFactory 中的方法
获取用此工厂创建的流所使用的分配器。
getEventContext() - 类 javax.naming.event.NamingEvent 中的方法
检索触发此事件的事件源。
getEventContext() - 类 javax.naming.event.NamingExceptionEvent 中的方法
检索触发此事件的 EventContext。
getEventHandler() - 类 javax.xml.bind.Binder 中的方法
当前的事件处理程序；如果没有设置，则返回默认事件处理程序。
getEventHandler() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法

getEventHandler() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
getEventHandler() - 接口 javax.xml.bind.Marshaller 中的方法
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
getEventHandler() - 接口 javax.xml.bind.Unmarshaller 中的方法
返回当前的事件处理程序，如果没有设置事件处理程序，则返回默认的事件处理程序。
getEventHandler() - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
getEventMask() - 类 java.awt.event.AWTEventListenerProxy 中的方法
返回与侦听器有关的事件掩码。
getEventPhase() - 接口 org.w3c.dom.events.Event 中的方法
用于指示当前正在评诂哪个阶段的事件流。
getEventPropertyName() - 类 java.beans.EventHandler 中的方法
返回应该在应用于目标的动作中使用的事件属性。
getEvents() - 类 javax.xml.bind.util.ValidationEventCollector 中的方法
返回一个 ValidationEvent 对象数组，这些对象包含所有收集的错误和警告的副本。
getEventSetDescriptors() - 接口 java.beans.BeanInfo 中的方法
获得 beans EventSetDescriptor。
getEventSetDescriptors() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝事件集的信息。
getEventType() - 类 javax.swing.event.HyperlinkEvent 中的方法
获得事件类型。
getEventType() - 接口 javax.xml.stream.events.XMLEvent 中的方法
返回此事件的整数码。
getEventType() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getEventType() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回一个整数码，指示光标所指向的事件的类型。
getException() - 类 java.awt.event.InvocationEvent 中的方法
返回在执行 Runnable 的 run() 方法时捕获的任何 Exception。
getException() - 异常 java.lang.ClassNotFoundException 中的方法
返回尝试加载类时发生错误引发的异常。
getException() - 错误 java.lang.ExceptionInInitializerError 中的方法
返回静态初始化期间发生的异常，该异常导致发生此错误。
getException() - 异常 java.security.PrivilegedActionException 中的方法
返回特权计算抛出的异常，该异常导致此 PrivilegedActionException。
getException() - 类 javax.naming.event.NamingExceptionEvent 中的方法
检索抛出的异常。
getException() - 类 javax.naming.ldap.SortResponseControl 中的方法
检索适合结果代码的 NamingException。
getException() - 接口 javax.naming.ldap.UnsolicitedNotification 中的方法
检索使用服务器发送的信息构造的异常。
getException() - 错误 javax.xml.parsers.FactoryConfigurationError 中的方法
返回引发此异常的实际异常（如果有）。
getException() - 错误 javax.xml.stream.FactoryConfigurationError 中的方法
返回嵌套异常（如果有）。
getException() - 异常 javax.xml.transform.TransformerException 中的方法
此方法检索此异常所包装的异常。
getException() - 错误 javax.xml.transform.TransformerFactoryConfigurationError 中的方法
返回引发此异常的实际异常（如果有）。
getException() - 异常 org.xml.sax.SAXException 中的方法
返回嵌入的异常（如果有）。
getExceptionListener() - 类 java.beans.Encoder 中的方法
获得此流的异常处理程序。
getExceptionListener() - 类 java.beans.XMLDecoder 中的方法
获得此流的异常处理程序。
getExceptionTypes() - 类 java.lang.reflect.Constructor 中的方法
返回一组表示声明要抛出的异常类型的 Class 对象，这些异常是由此 Constructor 对象表示的底层构造方法抛出的。
getExceptionTypes() - 类 java.lang.reflect.Method 中的方法
返回 Class 对象的数组，这些对象描述了声明将此 Method 对象表示的底层方法抛出的异常类型。
getExclusiveOwnerThread() - 类 java.util.concurrent.locks.AbstractOwnableSynchronizer 中的方法
返回由 setExclusiveOwnerThread 最后设置的线程；如果从未设置，则返回 null。
getExclusiveQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回一个 collection，该 collection 包含正以独占模式等待获取的线程。
getExclusiveQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回包含可能正以独占模式等待获取的线程 collection。
getExecuteExistingDelayedTasksAfterShutdownPolicy() - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
获取有关在此执行程序已 shutdown 的情况下是否继续执行现有延迟任务的策略。
getExecutor() - 类 javax.xml.ws.Endpoint 中的方法
返回此 Endpoint 实例的执行程序。
getExecutor() - 类 javax.xml.ws.Service 中的方法
返回此 Service 实例的执行程序。
getExecutor() - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
返回此 Service 实例的执行程序。
getExemptionMechanism() - 类 javax.crypto.Cipher 中的方法
返回此 Cipher 使用的豁免 (exemption) 机制对象。
getExp() - 异常 javax.management.BadBinaryOpValueExpException 中的方法
返回产生该异常的 ValueExp。
getExpandedDescendants(TreePath) - 类 javax.swing.JTree 中的方法
返回当前展开的 parent 路径的子路径的 Enumeration。
getExpandedIcon() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getExpandedState(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
如果路径已扩展并且可视，则返回 true。
getExpandedState(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
如果该路径已扩展，并且可见，则返回 true。
getExpandedState(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
如果路径已扩展，并且可见，则返回 true。
getExpandsSelectedPaths() - 类 javax.swing.JTree 中的方法
返回 expandsSelectedPaths 属性。
getExpectedPolicies() - 接口 java.security.cert.PolicyNode 中的方法
返回预期的策略集，其中的策略将满足下一个要处理证书中此节点的有效策略。
getExpiration() - 类 java.net.URLConnection 中的方法
返回 expires 头字段的值。
getExplanation() - 异常 javax.naming.NamingException 中的方法
检索与此异常关联的解释。
getExponent(float) - 类 java.lang.Math 中的静态方法
返回 float 表示形式中使用的无偏指数。
getExponent(double) - 类 java.lang.Math 中的静态方法
返回 double 表示形式中使用的无偏指数。
getExponent(float) - 类 java.lang.StrictMath 中的静态方法
返回 float 表示形式中使用的无偏指数。
getExponent(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 表示形式中使用的无偏指数。
getExponent() - 类 java.security.spec.RSAOtherPrimeInfo 中的方法
返回素数的指数。
getExponentSeparator() - 类 java.text.DecimalFormatSymbols 中的方法
返回用于分隔尾数和指数的字符串。
getExponentSize() - 类 javax.crypto.spec.DHGenParameterSpec 中的方法
以位为单位返回随机指数的大小（私有值）。
getExportedKeys(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取引用给定表的主键列（表导入的外键）的外键列的描述。
getExpression() - 类 javax.xml.crypto.dsig.spec.XPathType 中的方法
返回要计算的 XPath 表达式。
getExtendedKeyUsage() - 类 java.security.cert.X509Certificate 中的方法
获取一个不可修改的 String 列表，表示已扩展的密钥使用扩展 (OID = 2.5.29.37) 中 ExtKeyUsageSyntax 字段的对象标识符（OBJECT IDENTIFIER）。
getExtendedKeyUsage() - 类 java.security.cert.X509CertSelector 中的方法
返回 extendedKeyUsage 标准。
getExtendedState() - 类 java.awt.Frame 中的方法
获取此窗体的状态。
getExtendsBound() - 接口 javax.lang.model.type.WildcardType 中的方法
返回此通配符的上边界。
getExtension() - 类 javax.sound.sampled.AudioFileFormat.Type 中的方法
获得此文件类型的常见文件扩展名。
getExtensions() - 接口 javax.script.ScriptEngineFactory 中的方法
返回文件扩展名的不可变列表，这些扩展名通常标识使用此 ScriptEngine 支持的语言所编写的脚本。
getExtensions() - 类 javax.swing.filechooser.FileNameExtensionFilter 中的方法
返回要测试文件的文件扩展名集合。
getExtensionValue(String) - 接口 java.security.cert.X509Extension 中的方法
获取扩展值 (extnValue) 的 DER 编码 OCTET 字符串，该扩展值由传入的 oid String 标识。
getExtent() - 接口 javax.swing.BoundedRangeModel 中的方法
返回模型的 extent，即从模型的 value 开始的内部范围的长度。
getExtent() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回模型的 extent。
getExtent() - 类 javax.swing.JSlider 中的方法
从 BoundedRangeModel 返回“范围”。
getExtentSize() - 类 javax.swing.JViewport 中的方法
返回视图坐标中视图的可见部分的大小。
getExternalElements() - 接口 javax.xml.crypto.dsig.keyinfo.PGPData 中的方法
返回一个不可修改列表，由表示外部名称空间元素中的 XMLStructure 组成。
getExternalSubset(String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。
getExternalSubset(String, String) - 接口 org.xml.sax.ext.EntityResolver2 中的方法
允许应用程序为不能显式定义外部子集的文档提供外部子集。
getExtra() - 类 java.util.zip.ZipEntry 中的方法
返回条目的额外字段数据；如果没有，则返回 null。
getExtraImageMetadataFormatNames() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回包含其他文档格式名称，而不是此插件生成或使用的图像元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。
getExtraMetadataFormatNames() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回一个 String 数组，包含此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的其他元数据格式（本机格式和标准格式除外）的名称。
getExtraNameCharacters() - 接口 java.sql.DatabaseMetaData 中的方法
获取可以在不带引号的标识符名称中使用的所有“额外”字符（除了 a-z、A-Z、0-9 和 _ 以外的字符）。
getExtraStreamMetadataFormatNames() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回包含其他文档格式名称，而不是此插件生成或使用的流元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。
getFactory() - 接口 javax.script.ScriptEngine 中的方法
返回此 ScriptEngine 所属的类的 ScriptEngineFactory。
getFactoryClassLocation() - 类 javax.naming.Reference 中的方法
检索此引用所引用对象的工厂的位置。
getFactoryClassName() - 类 javax.naming.Reference 中的方法
检索此引用所引用对象的工厂的类名称。
getFailedProperties() - 异常 java.sql.SQLClientInfoException 中的方法
返回无法设置的客户端信息属性列表。
getFailureHandler() - 类 java.rmi.server.RMISocketFactory 中的静态方法
返回由 setFailureHandler 方法设置的套接字创建失败的处理程序。
getFallbackLocale(String, Locale) - 类 java.util.ResourceBundle.Control 中的方法
返回一个要用作回退语言环境的 Locale，用于 ResourceBundle.getBundle 工厂方法进行进一步资源包搜索。
getFamily() - 类 java.awt.Font 中的方法
返回此 Font 的系列名称。
getFamily(Locale) - 类 java.awt.Font 中的方法
返回此 Font 的系列名称（已经针对指定语言环境进行了本地化）。
getFault() - 接口 javax.xml.soap.SOAPBody 中的方法
返回此 SOAPBody 对象中的 SOAPFault 对象。
getFault() - 异常 javax.xml.ws.soap.SOAPFaultException 中的方法
获取嵌入的 SOAPFault 实例。
getFaultActor() - 接口 javax.xml.soap.SOAPFault 中的方法
获取此 SOAPFault 对象的错误参与者。
getFaultCode() - 接口 javax.xml.soap.SOAPFault 中的方法
获取此 SOAPFault 对象的错误代码。
getFaultCodeAsName() - 接口 javax.xml.soap.SOAPFault 中的方法
以 SAAJ Name 对象形式获取此 SOAPFault 对象的强制性 SOAP 1.1 错误代码。
getFaultCodeAsQName() - 接口 javax.xml.soap.SOAPFault 中的方法
以 QName 对象形式获取此 SOAPFault 对象的错误代码。
getFaultNode() - 接口 javax.xml.soap.SOAPFault 中的方法
返回此 SOAPFault 对象的可选 Node 元素值。
getFaultReasonLocales() - 接口 javax.xml.soap.SOAPFault 中的方法
返回一个 Iterator，它可以在与 Reason Text 项关联的 Locale 独特序列上进行迭代。
getFaultReasonText(Locale) - 接口 javax.xml.soap.SOAPFault 中的方法
返回与给定 Locale 关联的 Reason Text。
getFaultReasonTexts() - 接口 javax.xml.soap.SOAPFault 中的方法
返回一个 Iterator，它可以在包含此 SOAPFault 所有 Reason Text 项的 String 对象序列上进行迭代。
getFaultRole() - 接口 javax.xml.soap.SOAPFault 中的方法
返回此 SOAPFault 对象的可选 Role 元素值。
getFaultString() - 接口 javax.xml.soap.SOAPFault 中的方法
获取此 SOAPFault 对象的错误字符串。
getFaultStringLocale() - 接口 javax.xml.soap.SOAPFault 中的方法
获取此 SOAPFault 对象错误字符串的语言环境。
getFaultSubcodes() - 接口 javax.xml.soap.SOAPFault 中的方法
以 QNames 迭代器形式获取此 SOAPFault 的 Subcode。
getFD() - 类 java.io.FileInputStream 中的方法
返回表示到文件系统中实际文件的连接的 FileDescriptor 对象，该文件系统正被此 FileInputStream 使用。
getFD() - 类 java.io.FileOutputStream 中的方法
返回与此流有关的文件描述符。
getFD() - 类 java.io.RandomAccessFile 中的方法
返回与此流关联的不透明文件描述符对象。
getFeature(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getFeature(String) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
获取指定功能的状态。
getFeature(String) - 类 javax.xml.parsers.SAXParserFactory 中的方法
返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。
getFeature(String) - 类 javax.xml.transform.TransformerFactory 中的方法
查找功能值。
getFeature(String) - 类 javax.xml.validation.SchemaFactory 中的方法
查找功能标志的值。
getFeature(String) - 类 javax.xml.validation.Validator 中的方法
查找功能标志的值。
getFeature(String) - 类 javax.xml.validation.ValidatorHandler 中的方法
查找特性标志的值。
getFeature(String) - 类 javax.xml.xpath.XPathFactory 中的方法
获取指定功能的状态。
getFeature(String, String) - 接口 org.w3c.dom.DOMImplementation 中的方法
此方法返回一个特定的对象，该对象实现了 DOM Features 中所指定的特定特性或版本的特殊 API。
getFeature(String, String) - 接口 org.w3c.dom.Node 中的方法
此方法返回一个特定的对象，该对象实现指定功能或版本的特定 API，如下所述。
getFeature(String) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
检查解析器功能标志。
getFeature(String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
查找功能值。
getFeature(String) - 接口 org.xml.sax.XMLReader 中的方法
查找功能标志的值。
getFeedResolution(int) - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回给定单位的此分辨率属性的进纸分辨率。
getFeedResolutionDphi() - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回以 dphi 为单位的此分辨率属性的进纸分辨率。
getFetchDirection() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的获取方向。
getFetchDirection() - 接口 java.sql.Statement 中的方法
获取从数据库表获取行的方向，该方向是根据此 Statement 对象生成的结果集合的默认值。
getFetchDirection() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取此 RowSet 对象的当前有关获取方向的设置。
getFetchSize() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的获取大小。
getFetchSize() - 接口 java.sql.Statement 中的方法
获取结果集合的行数，该数是根据此 Statement 对象生成的 ResultSet 对象的默认获取大小。
getFetchSize() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回此 RowSet 对象的获取大小。
getField(String) - 类 java.io.ObjectStreamClass 中的方法
按名称获取此类的字段。
getField(String) - 类 java.lang.Class 中的方法
返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。
getField() - 类 java.security.spec.EllipticCurve 中的方法
返回此椭圆曲线结束的有限字段 field。
getField() - 类 java.text.FieldPosition 中的方法
获取字段的标识符。
getField(DatatypeConstants.Field) - 类 javax.xml.datatype.Duration 中的方法
获取字段的值。
getFieldAttribute() - 类 java.text.FieldPosition 中的方法
以来自 Field 子类之一的属性常量返回该字段的标识符。
getFieldNames() - 接口 javax.management.Descriptor 中的方法
返回描述符中的所有字段名。
getFieldNames() - 类 javax.management.ImmutableDescriptor 中的方法

getFieldNames() - 类 javax.management.modelmbean.DescriptorSupport 中的方法

getFields() - 类 java.io.ObjectStreamClass 中的方法
返回此可序列化类的字段组成的数组。
getFields() - 类 java.lang.Class 中的方法
返回一个包含某些 Field 对象的数组，这些对象反映此 Class 对象所表示的类或接口的所有可访问公共字段。
getFields() - 接口 javax.management.Descriptor 中的方法
以 string 数组的形式返回此 descriptor 中所包含的所有字段。
getFields() - 类 javax.management.ImmutableDescriptor 中的方法

getFields() - 类 javax.management.modelmbean.DescriptorSupport 中的方法

getFields() - 类 javax.sql.rowset.serial.SerialJavaObject 中的方法
返回 Field 对象数组，该对象包含此帮助器类将序列化的对象的每个字段。
getFields(int) - 类 javax.swing.text.InternationalFormatter 中的方法
返回与 offset 处的文本相关的 Format.Field 常量。
getFieldSize() - 接口 java.security.spec.ECField 中的方法
返回以比特为单位的字段大小。
getFieldSize() - 类 java.security.spec.ECFieldF2m 中的方法
返回以比特为单位的字段大小，对于此首数为 2 的有限字段，该字段大小为 m。
getFieldSize() - 类 java.security.spec.ECFieldFp 中的方法
返回以比特为单位的字段大小，对于此素数有限字段，则为素数 p 的大小。
getFieldValue(String) - 接口 javax.management.Descriptor 中的方法
返回指定字段名的值，如果该名称不存在任何值，则返回 null。
getFieldValue(String) - 类 javax.management.ImmutableDescriptor 中的方法

getFieldValue(String) - 类 javax.management.modelmbean.DescriptorSupport 中的方法

getFieldValues(String...) - 接口 javax.management.Descriptor 中的方法
以 Object 数组的形式返回该 descriptor 中的所有字段值。
getFieldValues(String...) - 类 javax.management.ImmutableDescriptor 中的方法

getFieldValues(String...) - 类 javax.management.modelmbean.DescriptorSupport 中的方法

getFile() - 类 java.awt.FileDialog 中的方法
获取此文件对话框的选定文件。
getFile() - 类 java.net.URL 中的方法
获取此 URL 的文件名。
getFile() - 类 javax.activation.FileDataSource 中的方法
返回与此 FileDataSource 对应的 File 对象。
getFileChooser() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getFileChooserDetailViewIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getFileChooserHomeFolderIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getFileChooserListViewIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getFileChooserNewFolderIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getFileChooserUpFolderIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getFileDescriptor() - 类 java.net.DatagramSocketImpl 中的方法
获取数据报套接字文件描述符。
getFileDescriptor() - 类 java.net.SocketImpl 中的方法
返回此套接字的 fd 字段的值。
getFileFilter() - 类 javax.swing.JFileChooser 中的方法
返回当前选择的文件过滤器。
getFileForInput(JavaFileManager.Location, String, String) - 类 javax.tools.ForwardingJavaFileManager 中的方法

getFileForInput(JavaFileManager.Location, String, String) - 接口 javax.tools.JavaFileManager 中的方法
获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。
getFileForOutput(JavaFileManager.Location, String, String, FileObject) - 类 javax.tools.ForwardingJavaFileManager 中的方法

getFileForOutput(JavaFileManager.Location, String, String, FileObject) - 接口 javax.tools.JavaFileManager 中的方法
获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。
getFileName() - 类 java.awt.JobAttributes 中的方法
指定使用这些属性的作业的输出文件的文件名。
getFileName() - 类 java.lang.StackTraceElement 中的方法
返回源文件名，该文件包含由该堆栈跟踪元素所表示的执行点。
getFileName() - 异常 javax.script.ScriptException 中的方法
获取导致错误的脚本的源。
getFileName() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getFileName() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getFilenameFilter() - 类 java.awt.FileDialog 中的方法
确定此文件对话框的文件名过滤器。
getFileNameMap() - 类 java.net.URLConnection 中的静态方法
从数据文件加载文件名映射（一个 mimetable）。
getFilePointer() - 类 java.io.RandomAccessFile 中的方法
返回此文件中的当前偏移量。
getFiler() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回用来创建新源、类或辅助文件的 Filer。
getFiles(File, boolean) - 类 javax.swing.filechooser.FileSystemView 中的方法
获取显示的（即未隐藏）文件的列表。
getFiles() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法

getFileSelectionMode() - 类 javax.swing.JFileChooser 中的方法
返回当前的文件选择模式。
getFileSuffixes() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回一个包含通常可由与此服务提供者关联的 ImageReader 或 ImageWriter 实现所用格式所关联文件后缀列表的 String 数组。
getFileSystemView() - 类 javax.swing.filechooser.FileSystemView 中的静态方法

getFileSystemView() - 类 javax.swing.JFileChooser 中的方法
返回文件系统视图。
getFileView() - 类 javax.swing.JFileChooser 中的方法
返回当前的文件视图。
getFileView(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getFileView(JFileChooser) - 类 javax.swing.plaf.FileChooserUI 中的方法

getFileView(JFileChooser) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getFileView 方法。
getFillsViewportHeight() - 类 javax.swing.JTable 中的方法
返回此表是否始终大到足以填充封闭视口的高度。
getFilter() - 类 java.util.logging.Handler 中的方法
获得该 Handler 的当前 Filter。
getFilter() - 类 java.util.logging.Logger 中的方法
获取此 Logger 的当前过滤器。
getFilter() - 接口 javax.sql.rowset.FilteredRowSet 中的方法
获取此 FilteredRowSet 对象的活动过滤器。
getFilter() - 类 javax.xml.crypto.dsig.spec.XPathType 中的方法
返回过滤操作。
getFilter() - 接口 org.w3c.dom.ls.LSParser 中的方法
当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。
getFilter() - 接口 org.w3c.dom.ls.LSSerializer 中的方法
当应用程序提供过滤器时，在序列化每个节点前串行器先调出过滤器。
getFilterInstance(ImageConsumer) - 类 java.awt.image.ImageFilter 中的方法
返回为指定 ImageConsumer 实际执行过滤的 ImageFilter 对象的惟一实例。
getFirst() - 类 java.util.ArrayDeque 中的方法

getFirst() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法

getFirst() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列的第一个元素。
getFirst() - 类 java.util.LinkedList 中的方法
返回此列表的第一个元素。
getFirstChild() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
此节点的第一个子节点；如果该节点没有子节点，则返回 null。
getFirstChild() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的第一个子节点。
getFirstChild() - 接口 org.w3c.dom.Node 中的方法
此节点的第一个子节点。
getFirstColumn() - 接口 javax.accessibility.AccessibleTableModelChange 中的方法
返回已更改的第一列。
getFirstColumn() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的方法

getFirstComponent(Container) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回遍历循环中的第一个 Component。
getFirstComponent(Container) - 类 java.awt.FocusTraversalPolicy 中的方法
返回遍历循环中的第一个 Component。
getFirstComponent(Container) - 类 javax.swing.DefaultFocusManager 中的方法

getFirstComponent(Container) - 类 javax.swing.LayoutFocusTraversalPolicy 中的方法
返回遍历循环中的第一个 Component。
getFirstComponent(Container) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回遍历循环中的第一个 Component。
getFirstDayOfWeek() - 类 java.util.Calendar 中的方法
获取一星期的第一天；例如，在美国，这一天是 SUNDAY，而在法国，这一天是 MONDAY。
getFirstIndex() - 类 javax.swing.event.ListSelectionEvent 中的方法
返回第一个选择状态可能发生更改的行的索引。
getFirstLeaf() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
查找并返回为此节点后代的第一个叶节点，即此节点或其第一个子节点的第一个叶节点。
getFirstLineIndent(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取首行缩进设置。
getFirstQueuedThread() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回队列中第一个（等待时间最长的）线程；如果当前没有将任何线程加入队列，则返回 null。
getFirstQueuedThread() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回队列中第一个（等待时间最长的）线程，如果目前没有将任何线程加入队列，则返回 null. 在此实现中，该操作是以固定时间返回的，但是，如果其他线程目前正在并发修改该队列，则可能出现循环争用。
getFirstRow() - 接口 javax.accessibility.AccessibleTableModelChange 中的方法
返回已更改的第一行。
getFirstRow() - 类 javax.swing.event.TableModelEvent 中的方法
返回第一个被更改的行。
getFirstRow() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的方法

getFirstVisibleIndex() - 类 javax.swing.JList 中的方法
返回当前可见的最小的列表索引。
getFixedCellHeight() - 类 javax.swing.JList 中的方法
返回 fixedCellHeight 属性的值。
getFixedCellWidth() - 类 javax.swing.JList 中的方法
返回 fixedCellWidth 属性的值。
getFixedRate(Integer) - 类 javax.management.timer.Timer 中的方法
获得此种标志的一个副本：该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
getFixedRate(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得此种标志的一个副本，该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
getFlags() - 异常 java.util.DuplicateFormatFlagsException 中的方法
返回包含重复标志的一组标志。
getFlags() - 异常 java.util.FormatFlagsConversionMismatchException 中的方法
返回不兼容的标志。
getFlags() - 异常 java.util.IllegalFormatFlagsException 中的方法
返回包含非法组合的标志的集合。
getFlags() - 异常 java.util.UnknownFormatFlagsException 中的方法
返回包含未知标志的标志集。
getFlags() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回与此票据有关联的标志。
getFlatness(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D 中的静态方法
返回由指示控制点指定的三次曲线的平面度。
getFlatness(double[], int) - 类 java.awt.geom.CubicCurve2D 中的静态方法
返回由控制点（存储在指示数组中的指示索引处）指定的三次曲线的平面度。
getFlatness() - 类 java.awt.geom.CubicCurve2D 中的方法
返回此曲线的平面度。
getFlatness() - 类 java.awt.geom.FlatteningPathIterator 中的方法
返回此迭代器的平面度。
getFlatness(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D 中的静态方法
返回由指示控制点指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）。
getFlatness(double[], int) - 类 java.awt.geom.QuadCurve2D 中的静态方法
返回由控制点（存储在指示数组中的指示索引处）指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）。
getFlatness() - 类 java.awt.geom.QuadCurve2D 中的方法
返回此 QuadCurve2D 的平面度（或者说从控制点到连接端点的线的最大距离）。
getFlatnessSq(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D 中的静态方法
返回由指示的控制点指定的三次曲线平面度的平方。
getFlatnessSq(double[], int) - 类 java.awt.geom.CubicCurve2D 中的静态方法
返回由控制点（存储在指示数组中的指示索引处）指定的三次曲线平面度的平方。
getFlatnessSq() - 类 java.awt.geom.CubicCurve2D 中的方法
返回此曲线平面度的平方。
getFlatnessSq(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D 中的静态方法
返回由指示控制点指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）的平方。
getFlatnessSq(double[], int) - 类 java.awt.geom.QuadCurve2D 中的静态方法
返回由控制点（存储在指示数组中的指示索引处）指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）的平方。
getFlatnessSq() - 类 java.awt.geom.QuadCurve2D 中的方法
返回此 QuadCurve2D 的平面度（或者说从控制点到连接端点的线的最大距离）的平方。
getFlavorListeners() - 类 java.awt.datatransfer.Clipboard 中的方法
返回一组目前在此 Clipboard 上注册的所有 FlavorListener。
getFlavorMap() - 类 java.awt.dnd.DragSource 中的方法
此方法返回此 DragSource 的 FlavorMap。
getFlavorMap() - 类 java.awt.dnd.DropTarget 中的方法
获取与此 DropTarget 关联的 FlavorMap。
getFlavorsForNative(String) - 接口 java.awt.datatransfer.FlavorTable 中的方法
返回与指定 String 对应的 DataFlavor 的 List。
getFlavorsForNative(String) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
返回数据传输子系统可以将指定 String native 转换成的 DataFlavor 的 List。
getFlavorsForNatives(String[]) - 接口 java.awt.datatransfer.FlavorMap 中的方法
返回指定 String native 到其相应 DataFlavor 的 Map。
getFlavorsForNatives(String[]) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
返回指定 String native 到其大多数首选 DataFlavor 的 Map。
getFlipContents() - 类 java.awt.BufferCapabilities 中的方法

getFloat(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 float 形式返回指定数组对象中索引组件的值。
getFloat(Object) - 类 java.lang.reflect.Field 中的方法
获取 float 类型或另一个通过扩展转换可以转换为 float 类型的基本类型的静态或实例字段的值。
getFloat() - 类 java.nio.ByteBuffer 中的方法
用于读取 float 值的相对 get 方法。
getFloat(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 float 值的绝对 get 方法。
getFloat(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 float 值的形式获取指定的 JDBC FLOAT 参数的值。
getFloat(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 float 值的形式获取 JDBC FLOAT 参数的值。
getFloat(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。
getFloat(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。
getFloat(String, float) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getFloat(String,float) 中的规范实现 getFloat 方法。
getFloat(String, float) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定的键相关联的、由字符串表示的 float 值。
getFloatingColor() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
获取在浮动区域上时显示的颜色。
getFloatParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 float 返回参数的便捷方法。
getFlowAxis() - 类 javax.swing.text.FlowView 中的方法
获取应沿其流入视图的轴。
getFlowSpan(int) - 类 javax.swing.text.FlowView 中的方法
获取给定子索引流入的约束区域。
getFlowSpan(int) - 类 javax.swing.text.ParagraphView 中的方法
获取给定子索引流入的约束区域。
getFlowStart(int) - 类 javax.swing.text.FlowView 中的方法
获取沿流轴的流区域开始位置。
getFlowStart(int) - 类 javax.swing.text.ParagraphView 中的方法
获取沿流轴的流区域开始位置。
getFlushedPosition() - 接口 javax.imageio.stream.ImageInputStream 中的方法
返回流中可以执行查找的最早位置。
getFlushedPosition() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法

getFocusableWindowState() - 类 java.awt.Window 中的方法
返回如果此窗口满足 isFocusableWindow 中列出的其他要求，其是否可以成为焦点窗口。
getFocusAccelerator() - 类 javax.swing.text.JTextComponent 中的方法
返回将导致接收文本组件获取焦点的加速键。
getFocusColor() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getFocusColor() - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法

getFocusColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的焦点颜色。
getFocusColor() - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法

getFocusColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回焦点颜色。
getFocusColor() - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法

getFocusCycleRootAncestor() - 类 java.awt.Component 中的方法
返回作为此 Component 焦点遍历循环的焦点循环根的 Container。
getFocusCycleRootAncestor() - 类 java.awt.Window 中的方法
始终返回 null，因为窗口没有祖先；它们表示组件层次结构的顶层。
getFocusCycleRootAncestor() - 类 javax.swing.JInternalFrame 中的方法
始终返回 null，原因是 JInternalFrame 必须始终为焦点遍历循环的根。
getFocusedComponent() - 类 javax.swing.text.TextAction 中的方法
获取当前具有焦点的文本组件。
getFocusedWindow() - 类 java.awt.KeyboardFocusManager 中的方法
如果聚焦窗口与调用线程位于同一个上下文中，则返回聚焦窗口。
getFocusIndex() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回具有焦点的选项卡的索引。
getFocusListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的焦点侦听器的数组。
getFocusLostBehavior() - 类 javax.swing.JFormattedTextField 中的方法
返回丢失焦点时的行为。
getFocusOwner() - 类 java.awt.KeyboardFocusManager 中的方法
如果焦点所有者与调用线程位于同一个上下文中，则返回该焦点所有者。
getFocusOwner() - 类 java.awt.Window 中的方法
如果此窗口为焦点窗口，则返回是焦点窗口的子组件；否则返回 null。
getFocusOwner() - 类 javax.swing.JInternalFrame 中的方法
如果此 JInternalFrame 处于激活状态，则返回具有焦点的子组件。
getFocusPoint() - 类 java.awt.RadialGradientPaint 中的方法
返回渐变轴结束点的副本。
getFocusTraversalKeys(int) - 类 java.awt.Component 中的方法
返回此 Component 的给定遍历操作的焦点遍历键 Set。
getFocusTraversalKeys(int) - 类 java.awt.Container 中的方法
为此 Container 的给定遍历操作返回焦点遍历键的 Set。
getFocusTraversalKeys(int) - 类 java.awt.Window 中的方法
获取此窗口的焦点遍历键。
getFocusTraversalKeysEnabled() - 类 java.awt.Component 中的方法
返回是否已为此 Component 启用了焦点遍历键。
getFocusTraversalPolicy() - 类 java.awt.Container 中的方法
返回焦点遍历策略，用于管理此 Container 子组件的键盘遍历；如果此 Container 不是一个焦点循环根，则返回 null。
getFollowRedirects() - 类 java.net.HttpURLConnection 中的静态方法
返回指示是否应该自动执行 HTTP 重定向 (3xx) 的 boolean 值。
getFont() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的 Font。
getFont() - 类 java.awt.Component 中的方法
获取组件的字体。
getFont(Map<? extends AttributedCharacterIterator.Attribute, ?>) - 类 java.awt.Font 中的静态方法
返回适合于这些属性的 Font。
getFont(String) - 类 java.awt.Font 中的静态方法
从系统属性列表返回一个 Font 对象。
getFont(String, Font) - 类 java.awt.Font 中的静态方法
从系统属性列表获取指定的 Font。
getFont() - 类 java.awt.font.GlyphVector 中的方法
返回与此 GlyphVector 关联的 Font。
getFont() - 类 java.awt.FontMetrics 中的方法
获取此 FontMetrics 对象所描述的 Font。
getFont() - 类 java.awt.Graphics 中的方法
获取当前字体。
getFont() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的 Font。
getFont() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的 Font。
getFont() - 类 java.awt.MenuComponent 中的方法
获取用于此菜单组件的字体。
getFont() - 接口 java.awt.MenuContainer 中的方法

getFont() - 接口 javax.accessibility.AccessibleComponent 中的方法
获取此对象的 Font。
getFont(Component) - 类 javax.swing.border.TitledBorder 中的方法

getFont() - 类 javax.swing.DebugGraphics 中的方法
返回用于文本绘制操作的 Font。
getFont() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getFont() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的 Font。
getFont() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getFont(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回指定状态的 Font。
getFont() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getFont(AttributeSet) - 类 javax.swing.text.DefaultStyledDocument 中的方法
从属性集获得字体。
getFont() - 类 javax.swing.text.GlyphView 中的方法
获取字形应该以其为依据的字体。
getFont(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
获取给定属性集使用的字体。
getFont() - 类 javax.swing.text.LabelView 中的方法
获取字形应该以其为依据的字体。
getFont(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
从属性集中获取字体。
getFont(String, int, int) - 类 javax.swing.text.StyleContext 中的方法
获取新字体。
getFont(AttributeSet) - 接口 javax.swing.text.StyledDocument 中的方法
使用一个属性集并将其转换为字体规范。
getFont() - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 中的方法

getFont() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
获取用于编辑的字体。
getFont() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
获取此组件的字体。
getFont(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Font，则返回该 Font，否则返回 null。
getFont(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Font，则返回它，否则返回 null。
getFont(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值返回一种字体。
getFont(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一种字体。
getFontFamily(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取字体系列设置。
getFontForState(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回指定状态的字体。
getFontList() - 类 java.awt.Toolkit 中的方法
已过时。 请参阅 GraphicsEnvironment.getAvailableFontFamilyNames()
getFontMetrics(Font) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的 FontMetrics。
getFontMetrics(Font) - 类 java.awt.Component 中的方法
获取指定字体的字体规格。
getFontMetrics() - 类 java.awt.Graphics 中的方法
获取当前字体的字体规格。
getFontMetrics(Font) - 类 java.awt.Graphics 中的方法
获取指定字体的字体规格。
getFontMetrics(Font) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置此对象的 FontMetrics。
getFontMetrics(Font) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的 FontMetrics。
getFontMetrics(Font) - 类 java.awt.Toolkit 中的方法
已过时。 从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。
getFontMetrics(Font) - 接口 javax.accessibility.AccessibleComponent 中的方法
获取此对象的 FontMetrics。
getFontMetrics() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.getFontMetrics。
getFontMetrics(Font) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.getFontMetrics。
getFontMetrics(Font) - 类 javax.swing.JComponent 中的方法
获取指定 Font 的 FontMetrics。
getFontMetrics(Font) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getFontMetrics(Font) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的 FontMetrics。
getFontMetrics(Font) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getFontMetrics() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getFontMetrics(Font) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getFontMetrics() - 类 javax.swing.text.FieldView 中的方法
获取与承载此视图组件相关的字体规格。
getFontMetrics() - 类 javax.swing.text.LabelView 中的方法
已过时。 FontMetrics 不用于在 JDK 中运行时的字形呈现。
getFontMetrics(Font) - 类 javax.swing.text.StyleContext 中的方法
获取某种字体的字体规格。
getFontName() - 类 java.awt.Font 中的方法
返回此 Font 的字体外观名称。
getFontName(Locale) - 类 java.awt.Font 中的方法
返回此 Font 的字体外观名称（已经针对指定语言环境进行了本地化）。
getFontPeer(String, int) - 类 java.awt.Toolkit 中的方法
已过时。 请参阅 java.awt.GraphicsEnvironment#getAllFonts
getFontRenderContext() - 类 java.awt.font.GlyphVector 中的方法
返回与此 GlyphVector 关联的 FontRenderContext。
getFontRenderContext() - 类 java.awt.FontMetrics 中的方法
获取此 FontMetrics 对象用来测量文本的 FontRenderContext。
getFontRenderContext() - 类 java.awt.Graphics2D 中的方法
获取此 Graphics2D 上下文中 Font 的呈现上下文。
getFontSize(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取字体大小设置。
getFontTable(int) - 接口 java.awt.font.OpenType 中的方法
返回作为指定标签字节数组的表。
getFontTable(String) - 接口 java.awt.font.OpenType 中的方法
返回作为指定标签字节数组的表。
getFontTable(int, int, int) - 接口 java.awt.font.OpenType 中的方法
返回作为指定标签字节数组的表的子集。
getFontTable(String, int, int) - 接口 java.awt.font.OpenType 中的方法
返回作为指定标签字节数组的表的子集。
getFontTableSize(int) - 接口 java.awt.font.OpenType 中的方法
返回指定标签的表的大小。
getFontTableSize(String) - 接口 java.awt.font.OpenType 中的方法
返回指定标签的表的大小。
getForeground() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的前景色。
getForeground() - 类 java.awt.Component 中的方法
获取组件的前景色。
getForeground() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的前景颜色。
getForeground() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的前景色。
getForeground() - 接口 javax.accessibility.AccessibleComponent 中的方法
获取此对象的前景色。
getForeground() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getForeground() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的前景色。
getForeground() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的前景色。
getForeground() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getForeground(AttributeSet) - 类 javax.swing.text.DefaultStyledDocument 中的方法
从属性集获得前景色。
getForeground() - 类 javax.swing.text.GlyphView 中的方法
获取用于呈现字形的前景色。
getForeground(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
获取一个属性集并将其转换为前景色规范。
getForeground() - 类 javax.swing.text.LabelView 中的方法
获取用于呈现字形的前景色。
getForeground(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取前景色设置。
getForeground(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
使用一个属性集并将其转换成为一个前景色规范。
getForeground(AttributeSet) - 接口 javax.swing.text.StyledDocument 中的方法
使用一个属性集并将其转换成为一个前景色规范。
getForegroundAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡背景色。
getFormat() - 接口 java.security.Certificate 中的方法
已过时。 返回编码格式的名称。
getFormat() - 接口 java.security.Key 中的方法
返回此密钥的基本编码格式，如果此密钥不支持编码，则返回 null。
getFormat() - 类 java.security.spec.EncodedKeySpec 中的方法
返回与此密钥规范关联的编码格式的名称。
getFormat() - 类 java.security.spec.PKCS8EncodedKeySpec 中的方法
返回与此密钥规范关联的编码格式的名称。
getFormat() - 类 java.security.spec.X509EncodedKeySpec 中的方法
返回与此密钥规范关联的编码格式的名称。
getFormat() - 类 javax.crypto.spec.SecretKeySpec 中的方法
返回此密钥编码格式的名称。
getFormat() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回此秘密密钥的编码格式的名称。
getFormat() - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得音频文件中包含的音频数据的格式。
getFormat() - 类 javax.sound.sampled.AudioInputStream 中的方法
获得此音频输入流中声音数据的音频格式。
getFormat() - 接口 javax.sound.sampled.DataLine 中的方法
获得数据行的音频数据的当前格式（编码、样本频率、信道数，等等）。
getFormat() - 类 javax.swing.JSpinner.DateEditor 中的方法
返回 JFormattedTextField 用于分析和格式化数字的 java.text.SimpleDateFormat 对象。
getFormat() - 类 javax.swing.JSpinner.NumberEditor 中的方法
返回 JFormattedTextField 用于分析和格式化数字的 java.text.DecimalFormat 对象。
getFormat() - 类 javax.swing.text.InternationalFormatter 中的方法
返回指示可以编辑和显示的合法值的格式。
getFormatId() - 接口 javax.transaction.xa.Xid 中的方法
获取 XID 的格式标识符部分。
getFormatName() - 类 javax.imageio.ImageReader 中的方法
返回一个标识输入源格式的 String。
getFormatNames() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回一个 String 数组，该数组包含通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的那些格式的可读名称。
getFormats() - 类 java.text.ChoiceFormat 中的方法
获取传入构造方法的 format。
getFormats() - 类 java.text.MessageFormat 中的方法
获取用于以前所设置的模式字符串中格式元素的格式。
getFormats(String) - 类 java.util.ResourceBundle.Control 中的方法
返回 String 的 List，它包含要用于加载给定 baseName 的资源包的格式。
getFormats() - 类 javax.sound.sampled.DataLine.Info 中的方法
获得数据行支持的音频格式的集合。
getFormatsByArgumentIndex() - 类 java.text.MessageFormat 中的方法
获取传递给 format 方法或从 parse 方法返回的值的格式。
getFormatSpecifier() - 异常 java.util.MissingFormatArgumentException 中的方法
返回不匹配的格式说明符。
getFormatSpecifier() - 异常 java.util.MissingFormatWidthException 中的方法
返回没有宽度的格式说明符。
getFormattedTextField() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
返回 AbstractFormatter 所安装到的当前 JFormattedTextField。
getFormatter() - 类 java.util.logging.Handler 中的方法
返回该 Handler 的 Formatter。
getFormatter(JFormattedTextField) - 类 javax.swing.JFormattedTextField.AbstractFormatterFactory 中的方法
返回一个 AbstractFormatter，它对传入的 JFormattedTextField 进行格式化。
getFormatter() - 类 javax.swing.JFormattedTextField 中的方法
返回用于格式化和分析当前值的 AbstractFormatter。
getFormatter(JFormattedTextField) - 类 javax.swing.text.DefaultFormatterFactory 中的方法
根据 JFormattedTextField 的状态返回默认的 formatter、显示 formatter、编辑器 formatter 或 null formatter。
getFormatterFactory() - 类 javax.swing.JFormattedTextField 中的方法
返回当前的 AbstractFormatterFactory。
getFractionalMetricsHint() - 类 java.awt.font.FontRenderContext 中的方法
返回此 FontRenderContext 中使用的文本 fractional metrics 呈现模式提示。
getFractionalSecond() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回小数秒。
getFractions() - 类 java.awt.MultipleGradientPaint 中的方法
返回此渐变所使用的 float 数组的副本，以计算颜色分布。
getFragment() - 类 java.net.URI 中的方法
返回此 URI 的已解码的片段组成部分。
getFrame() - 类 java.awt.geom.RectangularShape 中的方法
返回定义此对象的总体形状的窗体 Rectangle2D。
getFrameCount() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回不确定 JProgessBar 所使用的完整动画循环的窗体数。
getFrameForComponent(Component) - 类 javax.swing.JOptionPane 中的静态方法
返回指定组件的 Frame。
getFrameIcon() - 类 javax.swing.JInternalFrame 中的方法
返回要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。
getFrameLength() - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得文件中包含的音频数据的长度，以示例帧为单位表示。
getFrameLength() - 类 javax.sound.sampled.AudioInputStream 中的方法
获得流的长度，以示例帧表示，而不是以字节表示。
getFrameLength() - 接口 javax.sound.sampled.Clip 中的方法
获得介质长度（以示例帧为单位）。
getFramePosition() - 接口 javax.sound.sampled.DataLine 中的方法
获得音频数据中的当前位置（以样本帧为单位）。
getFramePosition() - 类 javax.sound.sampled.LineEvent 中的方法
获得事件发生时行的音频数据的位置，用样本帧表示。
getFrameRate() - 类 javax.sound.sampled.AudioFormat 中的方法
获取以帧每秒为单位的帧速率。
getFrames() - 类 java.awt.Frame 中的静态方法
返回一个此应用程序创建的所有 Frame 所组成的数组。
getFrameSize() - 类 javax.sound.sampled.AudioFormat 中的方法
获取以字节为单位的帧大小。
getFreeSpace() - 类 java.io.File 中的方法
返回此抽象路径名指定的分区中未分配的字节数。
getFromIndex() - 类 javax.swing.event.TableColumnModelEvent 中的方法
返回 fromIndex。
getFromPage() - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则返回要打印的第一页。
getFrontBufferCapabilities() - 类 java.awt.BufferCapabilities 中的方法

getFullScreenWindow() - 类 java.awt.GraphicsDevice 中的方法
如果设备处于全屏模式，则返回表示全屏窗口的 Window 对象。
getFunctionColumns(String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取给定类别的系统或用户函数参数和返回类型的描述。
getFunctions(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取给定类别中可用的系统和用户函数的描述。
getG() - 接口 java.security.interfaces.DSAParams 中的方法
返回基数 g。
getG() - 类 java.security.spec.DSAParameterSpec 中的方法
返回基数 g。
getG() - 类 java.security.spec.DSAPrivateKeySpec 中的方法
返回基数 g。
getG() - 类 java.security.spec.DSAPublicKeySpec 中的方法
返回基数 g。
getG() - 类 javax.crypto.spec.DHParameterSpec 中的方法
返回基生成器 g。
getG() - 类 javax.crypto.spec.DHPrivateKeySpec 中的方法
返回基生成器 g。
getG() - 类 javax.crypto.spec.DHPublicKeySpec 中的方法
返回基生成器 g。
getGamma() - 类 java.awt.color.ICC_ProfileGray 中的方法
返回一个表示色调再现曲线 (TRC) 的 gamma 值。
getGamma(int) - 类 java.awt.color.ICC_ProfileRGB 中的方法
返回表示特定分量色调再现曲线 (TRC) 的 gamma 值。
getGarbageCollectorMXBeans() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机中的 GarbageCollectorMXBean 对象列表。
getGeneratedKeys() - 接口 java.sql.Statement 中的方法
获取由于执行此 Statement 对象而创建的所有自动生成的键。
getGenerator() - 类 java.security.spec.ECParameterSpec 中的方法
返回也称为基点的生成器。
getGenericComponentType() - 接口 java.lang.reflect.GenericArrayType 中的方法
返回表示此数组的组件类型的 Type 对象。
getGenericDeclaration() - 接口 java.lang.reflect.TypeVariable 中的方法
返回 GenericDeclaration 对象，该对象表示声明此类型变量的一般声明。
getGenericElement() - 接口 javax.lang.model.element.TypeParameterElement 中的方法
返回由此类型参数参数化的一般类、接口、方法或构造方法。
getGenericExceptionTypes() - 类 java.lang.reflect.Constructor 中的方法
返回一组 Type 对象，这些对象表示声明要由此 Constructor 对象抛出的异常。
getGenericExceptionTypes() - 类 java.lang.reflect.Method 中的方法
返回 Type 对象数组，这些对象描述了声明由此 Method 对象抛出的异常。
getGenericInterfaces() - 类 java.lang.Class 中的方法
返回表示某些接口的 Type，这些接口由此对象所表示的类或接口直接实现。
getGenericParameterTypes() - 类 java.lang.reflect.Constructor 中的方法
按照声明顺序返回一组 Type 对象，这些对象表示此 Constructor 对象所表示的方法的形参类型。
getGenericParameterTypes() - 类 java.lang.reflect.Method 中的方法
按照声明顺序返回 Type 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型的。
getGenericReturnType() - 类 java.lang.reflect.Method 中的方法
返回表示由此 Method 对象所表示方法的正式返回类型的 Type 对象。
getGenericSuperclass() - 类 java.lang.Class 中的方法
返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的直接超类的 Type。
getGenericType() - 类 java.lang.reflect.Field 中的方法
返回一个 Type 对象，它表示此 Field 对象所表示字段的声明类型。
getGestureModifiers() - 类 java.awt.dnd.DragSourceDragEvent 中的方法
此方法返回一个 int 值，表示与用户动作关联的输入设备修饰符的当前状态。
getGestureModifiersEx() - 类 java.awt.dnd.DragSourceDragEvent 中的方法
此方法返回一个 int 值，表示与用户动作关联的输入设备扩展修饰符的当前状态。
getGetListenerMethod() - 类 java.beans.EventSetDescriptor 中的方法
获得用来访问已注册事件侦听器的方法。
getGlassPane() - 类 javax.swing.JApplet 中的方法
返回此 applet 的 glassPane 对象。
getGlassPane() - 类 javax.swing.JDialog 中的方法
返回此对话框的 glassPane 对象。
getGlassPane() - 类 javax.swing.JFrame 中的方法
返回此窗体的 glassPane 对象。
getGlassPane() - 类 javax.swing.JInternalFrame 中的方法
返回此内部窗体的玻璃窗格。
getGlassPane() - 类 javax.swing.JRootPane 中的方法
返回此 JRootPane 的当前玻璃窗格。
getGlassPane() - 类 javax.swing.JWindow 中的方法
返回此窗口的 glassPane Component。
getGlassPane() - 接口 javax.swing.RootPaneContainer 中的方法
返回 glassPane。
getGlobalActiveWindow() - 类 java.awt.KeyboardFocusManager 中的方法
返回活动 Window，即使调用线程处于活动 Window 之外的上下文中。
getGlobalCurrentFocusCycleRoot() - 类 java.awt.KeyboardFocusManager 中的方法
返回当前焦点循环根，即使调用线程处于当前焦点循环根之外的上下文中。
getGlobalFocusedWindow() - 类 java.awt.KeyboardFocusManager 中的方法
返回聚焦 Window，即使调用线程处于聚焦 Window 之外的上下文中。
getGlobalFocusOwner() - 类 java.awt.KeyboardFocusManager 中的方法
返回焦点所有者，即使调用线程处于焦点所有者之外的上下文中。
getGlobalPermanentFocusOwner() - 类 java.awt.KeyboardFocusManager 中的方法
返回持久焦点所有者，即使调用线程处于该持久焦点所有者之外的上下文中。
getGlobalTransactionId() - 接口 javax.transaction.xa.Xid 中的方法
获取 XID 的全局事务标识符部分作为字节数组。
getGlyphCharIndex(int) - 类 java.awt.font.GlyphVector 中的方法
返回指定字形的字符索引。
getGlyphCharIndices(int, int, int[]) - 类 java.awt.font.GlyphVector 中的方法
返回指定字形的字符索引。
getGlyphCode(int) - 类 java.awt.font.GlyphVector 中的方法
返回指定字形的 glyphcode。
getGlyphCodes(int, int, int[]) - 类 java.awt.font.GlyphVector 中的方法
返回指定字形的 glyphcode 数组。
getGlyphJustificationInfo(int) - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 中指定索引处的字形调整信息。
getGlyphLogicalBounds(int) - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 中指定字形的逻辑边界。
getGlyphMetrics(int) - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 中指定索引处的字形规格。
getGlyphOutline(int) - 类 java.awt.font.GlyphVector 中的方法
返回其内部区域与此 GlyphVector 中指定字形的可视表示形式对应的 Shape。
getGlyphOutline(int, float, float) - 类 java.awt.font.GlyphVector 中的方法
返回一个 Shape，其内部区域与此 GlyphVector 中指定字形的可视表示形式对应，并偏移到 x、y。
getGlyphPainter() - 类 javax.swing.text.GlyphView 中的方法
获取当前安装的字形 painter。
getGlyphPixelBounds(int, FontRenderContext, float, float) - 类 java.awt.font.GlyphVector 中的方法
返回当此 GlyphVector 在 Graphics 中以给定 FontRenderContext 在给定位置呈现时，index 处字形的像素边界。
getGlyphPosition(int) - 类 java.awt.font.GlyphVector 中的方法
返回与此 GlyphVector 原点对应的指定字形的位置。
getGlyphPositions(int, int, float[]) - 类 java.awt.font.GlyphVector 中的方法
返回包含指定字形位置的数组。
getGlyphTransform(int) - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 中指定字形的转换。
getGlyphVisualBounds(int) - 类 java.awt.font.GlyphVector 中的方法
返回 GlyphVector 中指定字形的可视边界。
getGoHomeAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getGranularityPeriod() - 类 javax.management.monitor.Monitor 中的方法
获取粒度周期（以毫秒为单位）。
getGranularityPeriod() - 接口 javax.management.monitor.MonitorMBean 中的方法
获取粒度时段（以毫秒为单位）。
getGraphics() - 类 java.awt.Component 中的方法
为组件创建一个图形上下文。
getGraphics() - 类 java.awt.image.BufferedImage 中的方法
此方法返回 Graphics2D，但此处是出于向后兼容性的考虑。
getGraphics() - 类 java.awt.Image 中的方法
创建供绘制闭屏图像（off-screen image）使用的图形上下文。
getGraphics() - 类 java.awt.image.VolatileImage 中的方法
此方法返回 Graphics2D，但它存在于此处是出于向后兼容性的考虑。
getGraphics() - 类 java.awt.PrintJob 中的方法
获取将绘制到下一页的 Graphics 对象。
getGraphics() - 类 javax.swing.JApplet 中的方法
为组件创建一个图形上下文。
getGraphics() - 类 javax.swing.JComponent 中的方法
返回此组件的图形上下文，该上下文允许您绘制组件。
getGraphics() - 类 javax.swing.JDialog 中的方法
为组件创建一个图形上下文。
getGraphics() - 类 javax.swing.JFrame 中的方法
为组件创建一个图形上下文。
getGraphics() - 类 javax.swing.JWindow 中的方法
为组件创建一个图形上下文。
getGraphics() - 类 javax.swing.text.View 中的方法
获取用于呈现的 Graphics。
getGraphicsConfiguration() - 类 java.awt.Component 中的方法
获取与此 Component 相关的 GraphicsConfiguration。
getGraphicsConfiguration() - 类 java.awt.Window 中的方法
此方法返回由此窗口使用的 GraphicsConfiguration。
getGraphicsUtils(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回指定上下文的 SynthGraphicUtils。
getGreatestMinimum(int) - 类 java.util.Calendar 中的方法
返回此 Calendar 实例给定日历字段的最高的最小值。
getGreatestMinimum(int) - 类 java.util.GregorianCalendar 中的方法
返回此 GregorianCalendar 实例给定日历字段的最高的最小值。
getGreen() - 类 java.awt.Color 中的方法
返回默认 sRGB 空间中位于范围 0-255 中的绿色分量。
getGreen(int) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getGreen(Object) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255）。
getGreen(int) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的绿色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getGreen(Object) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的绿色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getGreen(int) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的绿色颜色分量，指定像素在默认 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getGreen(Object) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getGreen(int) - 类 java.awt.image.IndexColorModel 中的方法
返回指定像素的绿色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。
getGreenMask() - 类 java.awt.image.DirectColorModel 中的方法
返回指示 int 像素表示形式中哪些位包含绿色颜色分量的掩码。
getGreens(byte[]) - 类 java.awt.image.IndexColorModel 中的方法
将绿色分量数组复制到指定的数组中。
getGregorianChange() - 类 java.util.GregorianCalendar 中的方法
获得格里高利历的更改日期。
getGridColor() - 类 javax.swing.JTable 中的方法
返回用来绘制网格线的颜色。
getGridColumn() - 类 javax.swing.text.TableView.TableCell 中的方法
已过时。 获取网格位置的列
getGridRow() - 类 javax.swing.text.TableView.TableCell 中的方法
已过时。 获取网格位置的行
getGrooveInsets() - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
返回 drawGroove() 绘制边框占用的空间量。
getGroup() - 类 javax.swing.DefaultButtonModel 中的方法
返回该按钮所属的组。
getGroupID() - 类 java.rmi.activation.ActivationDesc 中的方法
返回由此描述符指定的对象的组标识符。
getGroupingSeparator() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于千位分隔符的字符。
getGroupingSize() - 类 java.text.DecimalFormat 中的方法
返回分组大小。
getGuarantor() - 接口 java.security.Certificate 中的方法
已过时。 返回证书的保证人，即某个主体，其保证与此证书关联的公钥是与此证书关联的主体的公钥。
getHAdjustable() - 类 java.awt.ScrollPane 中的方法
返回表示水平滚动条状态的 ScrollPaneAdjustable 对象。
getHandler() - 类 javax.xml.transform.sax.SAXResult 中的方法
获取作为 Result 的 ContentHandler。
getHandlerChain() - 接口 javax.xml.ws.Binding 中的方法
获取协议绑定实例处理程序链的副本。
getHandlerChain(PortInfo) - 接口 javax.xml.ws.handler.HandlerResolver 中的方法
获取指定端口的处理程序链。
getHandlerResolver() - 类 javax.xml.ws.Service 中的方法
返回已配置的处理程序解析器。
getHandlerResolver() - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
返回已配置的处理程序解析器。
getHandlers() - 类 java.util.logging.Logger 中的方法
获得与此 logger 相关的 Handler。
getHandshakeStatus() - 类 javax.net.ssl.SSLEngine 中的方法
返回此 SSLEngine 的当前握手状态。
getHandshakeStatus() - 类 javax.net.ssl.SSLEngineResult 中的方法
获得此 SSLEngine 操作的握手状态。
getHardwareAddress() - 类 java.net.NetworkInterface 中的方法
如果存在硬件地址并可以使用给定的当前权限访问，则返回该硬件地址（通常是 MAC）。
getHashColor() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getHead(Handler) - 类 java.util.logging.Formatter 中的方法
返回一组格式化记录的头部字符串。
getHead(Handler) - 类 java.util.logging.XMLFormatter 中的方法
返回一组 XML 格式记录的头部字符串。
getHeader(String) - 类 javax.xml.soap.MimeHeaders 中的方法
以 String 对象数组的形式返回指定头的所有值。
getHeader() - 接口 javax.xml.soap.SOAPEnvelope 中的方法
返回此 SOAPEnvelope 对象的 SOAPHeader 对象。
getHeaderField(int) - 类 java.net.HttpURLConnection 中的方法
返回 nth 头字段的值。
getHeaderField(String) - 类 java.net.URLConnection 中的方法
返回指定的头字段的值。
getHeaderField(int) - 类 java.net.URLConnection 中的方法
返回第 n 个头字段的值。
getHeaderFieldDate(String, long) - 类 java.net.HttpURLConnection 中的方法

getHeaderFieldDate(String, long) - 类 java.net.URLConnection 中的方法
返回解析为日期的指定字段的值。
getHeaderFieldInt(String, int) - 类 java.net.URLConnection 中的方法
返回解析为数字的指定字段的值。
getHeaderFieldKey(int) - 类 java.net.HttpURLConnection 中的方法
返回 nth 头字段的键。
getHeaderFieldKey(int) - 类 java.net.URLConnection 中的方法
返回第 n 个头字段的键。
getHeaderFields() - 类 java.net.URLConnection 中的方法
返回头字段的不可修改的 Map。
getHeaderRect(int) - 类 javax.swing.table.JTableHeader 中的方法
返回包含 column 处头 tile 的矩形。
getHeaderRenderer() - 类 javax.swing.table.TableColumn 中的方法
返回用于绘制 TableColumn 标题的 TableCellRenderer。
getHeaders() - 类 java.net.CacheResponse 中的方法
以 Map 的形式返回响应头。
getHeaders() - 接口 javax.xml.ws.handler.soap.SOAPHandler 中的方法
获取可以由此处理程序实例处理的头块。
getHeaders(QName, JAXBContext, boolean) - 接口 javax.xml.ws.handler.soap.SOAPMessageContext 中的方法
从消息上下文的消息中获得具有特定限定名的头。
getHeaderValue() - 类 javax.swing.table.TableColumn 中的方法
返回用作标题渲染器值的 Object。
getHeapMemoryUsage() - 接口 java.lang.management.MemoryMXBean 中的方法
返回用于对象分配的堆的当前内存使用量。
getHeight() - 类 java.awt.Component 中的方法
返回组件的当前高度。
getHeight() - 类 java.awt.Dimension 中的方法
返回此 Dimension 的高度（以 double 精度表示）。
getHeight() - 类 java.awt.DisplayMode 中的方法
返回显示的高度（以像素表示）。
getHeight() - 类 java.awt.font.LineMetrics 中的方法
返回该文本的高度。
getHeight() - 类 java.awt.FontMetrics 中的方法
获取此 Font 中文本行的标准 height。
getHeight() - 类 java.awt.geom.Arc2D.Double 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.Arc2D.Float 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.Dimension2D 中的方法
返回此 Dimension 的高度（以 double 精度表示）。
getHeight() - 类 java.awt.geom.Ellipse2D.Double 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.Ellipse2D.Float 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.Rectangle2D.Double 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.Rectangle2D.Float 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.image.BufferedImage 中的方法
返回 BufferedImage 的高度。
getHeight(ImageObserver) - 类 java.awt.image.BufferedImage 中的方法
返回 BufferedImage 的高度。
getHeight(ImageObserver) - 类 java.awt.Image 中的方法
确定图像的高度。
getHeight() - 类 java.awt.image.Kernel 中的方法
返回此 Kernel 的高度。
getHeight() - 类 java.awt.image.PixelGrabber 中的方法
获取（调整图像高度后的）像素缓冲区的高度。
getHeight() - 类 java.awt.image.Raster 中的方法
返回 Raster 的像素高度。
getHeight() - 接口 java.awt.image.renderable.RenderableImage 中的方法
获取用户坐标空间中的高度。
getHeight() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
获取用户坐标空间中的高度。
getHeight() - 接口 java.awt.image.RenderedImage 中的方法
返回 RenderedImage 的高度。
getHeight() - 类 java.awt.image.SampleModel 中的方法
返回像素高度。
getHeight() - 类 java.awt.image.VolatileImage 中的方法
返回此 VolatileImage 的高度。
getHeight() - 类 java.awt.print.PageFormat 中的方法
返回页面的高度（以 1/72 英寸为单位）。
getHeight() - 类 java.awt.print.Paper 中的方法
返回页面的高度（以 1/72 英寸为单位）。
getHeight() - 类 java.awt.Rectangle 中的方法
以 double 精度返回边界 Rectangle 的高度。
getHeight(int) - 类 javax.imageio.ImageReader 中的方法
返回输入源中的给定图像的高度，以像素为单位。
getHeight(int) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以指定单位获取可打印区域的 height。
getHeight() - 类 javax.swing.JComponent 中的方法
返回此组件的当前高度。
getHeight() - 类 javax.swing.SpringLayout.Constraints 中的方法
返回 height 属性的值。
getHeight() - 类 javax.swing.text.BoxView 中的方法
返回框的当前高度。
getHeight(GlyphView) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法

getHeightOfHighValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getHeightOfLowValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getHeightOfTallestLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getHelpMenu() - 类 java.awt.MenuBar 中的方法
获取该菜单栏上的帮助菜单。
getHelpMenu() - 类 javax.swing.JMenuBar 中的方法
获取菜单栏的帮助菜单。
getHere() - 接口 javax.xml.crypto.dom.DOMURIReference 中的方法
返回当前位置的节点。
getHgap() - 类 java.awt.BorderLayout 中的方法
返回组件之间的水平间距。
getHgap() - 类 java.awt.CardLayout 中的方法
获取组件之间的水平间距。
getHgap() - 类 java.awt.FlowLayout 中的方法
获取组件之间以及组件与 Container 的边之间的水平间隙。
getHgap() - 类 java.awt.GridLayout 中的方法
获取组件之间的水平间距。
getHideActionText() - 类 javax.swing.AbstractButton 中的方法
返回 hideActionText 属性的值，该属性确定按钮是否显示 Action 的文本。
getHierarchyBoundsListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的层次结构边界侦听器的数组。
getHierarchyListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的层次结构侦听器的数组。
getHighestValue() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回在标签表中有一个项的最大值。
getHighestValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回与标签表中的最低滑块值相对应的标签。
getHighlightColor(Component) - 类 javax.swing.border.EtchedBorder 中的方法
返回浮雕化边框在指定组件上呈现的高亮显示颜色。
getHighlightColor() - 类 javax.swing.border.EtchedBorder 中的方法
返回浮雕化边框的高亮显示颜色。
getHighlightColor() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getHighlightedTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的加亮文本颜色。
getHighlightedTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回高亮显示的文本颜色。
getHighlighter() - 类 javax.swing.text.JTextComponent 中的方法
获取负责进行高亮显示的对象。
getHighlightInnerColor(Component) - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框在指定组件上呈现的内部高亮显示颜色。
getHighlightInnerColor() - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框内部的高亮显示颜色。
getHighlightOuterColor(Component) - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框在指定组件上呈现的外部高亮显示颜色。
getHighlightOuterColor() - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框外部的高亮显示颜色。
getHighlights() - 类 javax.swing.text.DefaultHighlighter 中的方法
制作高亮显示的副本。
getHighlights() - 接口 javax.swing.text.Highlighter 中的方法
获取高亮显示的当前列表。
getHighThreshold() - 类 javax.management.monitor.GaugeMonitor 中的方法
获取所有所观察的 MBean 的公共高阈值。
getHighThreshold() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取高阈值。
getHoldability() - 接口 java.sql.Connection 中的方法
获取使用此 Connection 对象创建的 ResultSet 对象的当前可保存性。
getHoldability() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的可保存性
getHoldCount() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询当前线程保持此锁的次数。
getHoldCount() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
查询当前线程保持写入锁的数量。
getHomeDirectory() - 类 javax.swing.filechooser.FileSystemView 中的方法

getHonorsVisibility() - 类 javax.swing.GroupLayout 中的方法
返回确定组件的大小和位置时是否要考虑组件的可见性。
getHorizontalAlignment() - 类 javax.swing.AbstractButton 中的方法
返回图标和文本的水平对齐方式。
getHorizontalAlignment() - 类 javax.swing.JLabel 中的方法
返回标签内容沿 X 轴的对齐方式。
getHorizontalAlignment() - 类 javax.swing.JTextField 中的方法
返回文本的水平对齐方式。
getHorizontalLegBuffer() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
默认情况下，节点间支路的水平元素开始于子节点左侧的右边。
getHorizontalLegBuffer() - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法

getHorizontalScrollBar() - 类 javax.swing.JScrollPane 中的方法
返回控制视口的水平视图位置的水平滚动条。
getHorizontalScrollBar() - 类 javax.swing.ScrollPaneLayout 中的方法
返回处理水平滚动的 JScrollBar 对象。
getHorizontalScrollBarPolicy() - 类 javax.swing.JScrollPane 中的方法
返回水平滚动条策略值。
getHorizontalScrollBarPolicy() - 类 javax.swing.ScrollPaneLayout 中的方法
返回水平滚动条的显示策略。
getHorizontalSliderThumbIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getHorizontalTextPosition() - 类 javax.swing.AbstractButton 中的方法
返回文本相对于图标的水平位置。
getHorizontalTextPosition() - 类 javax.swing.JLabel 中的方法
返回标签的文本相对其图像的水平位置。
getHorizontalVisibility() - 类 javax.swing.JTextField 中的方法
获取文本字段的可见性。
getHost() - 类 java.net.URI 中的方法
返回此 URI 的主机组成部分。
getHost() - 类 java.net.URL 中的方法
获取此 URL 的主机名（如果适用）。
getHost() - 类 javax.management.remote.JMXServiceURL 中的方法
Service URL 的主机部分。
getHostAddress() - 类 java.net.Inet4Address 中的方法
返回 IP 地址字符串（以文本表现形式）。
getHostAddress() - 类 java.net.Inet6Address 中的方法
返回 IP 地址字符串（以文本表现形式）。
getHostAddress() - 类 java.net.InetAddress 中的方法
返回 IP 地址字符串（以文本表现形式）。
getHostAddress(URL) - 类 java.net.URLStreamHandler 中的方法
获取主机的 IP 地址。
getHostName() - 类 java.net.InetAddress 中的方法
获取此 IP 地址的主机名。
getHostName() - 类 java.net.InetSocketAddress 中的方法
获取 hostname。
getHostnameVerifier() - 类 javax.net.ssl.HttpsURLConnection 中的方法
获取此实例适当的 HostnameVerifier。
getHour() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回时或 DatatypeConstants.FIELD_UNDEFINED。
getHours() - 类 java.sql.Date 中的方法
已过时。
getHours() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.HOUR_OF_DAY) 取代。
getHours() - 类 javax.xml.datatype.Duration 中的方法
获取整数值形式的 HOURS 字段的值，如果不存在，则值为 0。
getHSBColor(float, float, float) - 类 java.awt.Color 中的静态方法
根据所指定的数值，创建一个基于 HSB 颜色模型的 Color 对象。
getHScrollbarHeight() - 类 java.awt.ScrollPane 中的方法
返回水平滚动条占用的高度，它与当前是否由滚动窗格显示无关。
getHTMLBaseline(View, int, int) - 类 javax.swing.plaf.basic.BasicHTML 中的静态方法
返回 html 渲染器的基线。
getHTMLDocument(JEditorPane) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 中的方法

getHTMLEditorKit(JEditorPane) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 中的方法

getHTMLTag() - 类 javax.swing.text.html.parser.TagElement 中的方法

getHumanPresentableName() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 表示的数据格式的得体的名称。
getHumanPresentableName() - 类 javax.activation.ActivationDataFlavor 中的方法
返回得体的名称。
getHyperlinkListeners() - 类 javax.swing.JEditorPane 中的方法
返回使用 addHyperlinkListener() 添加到此 JEditorPane 的所有 HyperLinkListener 的数组。
getICC_Profiles() - 类 java.awt.image.ColorConvertOp 中的方法
返回用于构造此 ColorConvertOp 的 ICC_Profiles 的数组。
getIcon(int) - 接口 java.beans.BeanInfo 中的方法
此方法返回一个图像对象，可用该对象表示工具框、工具栏等中的 bean。
getIcon(int) - 类 java.beans.SimpleBeanInfo 中的方法
声明没有可用的图标。
getIcon() - 类 javax.swing.AbstractButton 中的方法
返回默认图标。
getIcon(File) - 类 javax.swing.filechooser.FileView 中的方法
表示 JFileChooser 中此文件的图标。
getIcon(File) - 类 javax.swing.JFileChooser 中的方法
返回此文件或文件类型的图标，这取决于系统。
getIcon() - 类 javax.swing.JLabel 中的方法
返回该标签显示的图形图像（字形、图标）。
getIcon() - 类 javax.swing.JOptionPane 中的方法
返回此窗格显示的图标。
getIcon(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法

getIcon() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回来自接收者为其提供外观的 JOptionPane 的图标，或者从 getDefaultIcon 返回的默认图标。
getIcon(SynthContext, Object) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
获得其值是一个 Icon 的特定样式属性的便捷方法。
getIcon(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取图标设置。
getIcon(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Icon，则返回该 Icon，否则返回 null。
getIcon(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Icon，则返回该 Icon，否则返回 null。
getIcon(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个 Icon。
getIcon(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个 Icon。
getIconAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡图标。
getIconForTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getIconForType(int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回用于传入类型的图标。
getIconHeight() - 接口 javax.swing.Icon 中的方法
返回图标的高度。
getIconHeight() - 类 javax.swing.ImageIcon 中的方法
获得图标的高度。
getIconHeight() - 类 javax.swing.plaf.IconUIResource 中的方法

getIconHeight() - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 中的方法

getIconHeight() - 类 javax.swing.plaf.metal.MetalComboBoxIcon 中的方法
创建一个满足该接口的 stub。
getIconHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 中的方法

getIconHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 中的方法

getIconHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 中的方法

getIconHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 中的方法

getIconImage() - 类 java.awt.Frame 中的方法
返回要作为此窗体图标显示的图像。
getIconImages() - 类 java.awt.Window 中的方法
返回要作为此窗口的图标显示的图像序列。
getIconTextGap() - 类 javax.swing.AbstractButton 中的方法
返回此按钮中显示的文本与图标之间的间隔量。
getIconTextGap() - 类 javax.swing.JLabel 中的方法
返回此标签中显示的文本和图标之间的间隔量。
getIconWidth() - 接口 javax.swing.Icon 中的方法
返回图标的宽度。
getIconWidth() - 类 javax.swing.ImageIcon 中的方法
获得图标的宽度。
getIconWidth() - 类 javax.swing.plaf.IconUIResource 中的方法

getIconWidth() - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 中的方法

getIconWidth() - 类 javax.swing.plaf.metal.MetalComboBoxIcon 中的方法
创建一个满足该接口的 stub。
getIconWidth() - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 中的方法

getIconWidth() - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 中的方法

getIconWidth() - 类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 中的方法

getIconWidth() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 中的方法

getID() - 类 java.awt.AWTEvent 中的方法
返回事件类型。
getId() - 类 java.lang.Thread 中的方法
返回该线程的标识符。
getID() - 类 java.rmi.activation.Activatable 中的方法
返回对象的激活标识符。
getID() - 类 java.util.TimeZone 中的方法
获取此时区的 ID。
getID() - 接口 javax.naming.directory.Attribute 中的方法
检索此属性的 id。
getID() - 类 javax.naming.directory.BasicAttribute 中的方法

getID() - 类 javax.naming.ldap.BasicControl 中的方法
检索控件的对象标识符字符串。
getID() - 接口 javax.naming.ldap.Control 中的方法
检索为 LDAP 控件分配的对象标识符。
getID() - 接口 javax.naming.ldap.ExtendedRequest 中的方法
检索请求的对象标识符。
getID() - 接口 javax.naming.ldap.ExtendedResponse 中的方法
检索响应的对象标识符。
getID() - 类 javax.naming.ldap.StartTlsRequest 中的方法
检索 StartTLS 请求的对象标识符字符串。
getID() - 类 javax.naming.ldap.StartTlsResponse 中的方法
检索 StartTLS 响应的对象标识符字符串。
getId() - 接口 javax.net.ssl.SSLSession 中的方法
返回分配给此会话的标识符。
getID() - 类 javax.swing.LookAndFeel 中的方法
返回标识此外观的字符串。
getID() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
此外观的标识符。
getID() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
返回适合应用程序/服务使用、标识此外观的 string。
getID() - 类 javax.swing.plaf.synth.ColorType 中的方法
以整数形式返回此 ColorType 的唯一 id。
getID() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回一个标识此外观的短字符串。
getId() - 接口 javax.xml.crypto.dsig.keyinfo.KeyInfo 中的方法
返回此 KeyInfo 的可选 Id 属性，这对于从其他 XML 结构引用此 KeyInfo 可能很有用。
getId() - 接口 javax.xml.crypto.dsig.Manifest 中的方法
返回此 Manifest 的 Id。
getId() - 接口 javax.xml.crypto.dsig.Reference 中的方法
返回此 Reference 的可选 Id 属性，该属性允许从其他地方引用此 Reference。
getId() - 接口 javax.xml.crypto.dsig.SignatureProperties 中的方法
返回此 SignatureProperties 的 Id。
getId() - 接口 javax.xml.crypto.dsig.SignatureProperty 中的方法
返回此 SignatureProperty 的 Id。
getId() - 接口 javax.xml.crypto.dsig.SignedInfo 中的方法
返回此 SignedInfo 的可选 Id 属性。
getId() - 接口 javax.xml.crypto.dsig.XMLObject 中的方法
返回此 XMLObject 的 Id。
getId() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
返回此 XMLSignature 的可选 Id。
getId() - 接口 javax.xml.crypto.dsig.XMLSignature.SignatureValue 中的方法
返回此 SignatureValue 的可选 Id 属性，该属性允许从其他地方引用此元素。
getId() - 类 javax.xml.datatype.DatatypeConstants.Field 中的方法
获取此字段的 ID。
getId() - 异常 org.omg.CORBA.portable.ApplicationException 中的方法
返回异常的 CORBA 存储库 ID 而不会将其从异常输入流中移除。
getIdentifier(int) - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
返回指定行的标识符。
getIdentifier() - 类 javax.swing.RowFilter.Entry 中的方法
返回条目的标识符（在模型中）。
getIdentifier() - 类 javax.swing.table.TableColumn 中的方法
返回此列的 identifier 对象。
getIdentifierQuoteString() - 接口 java.sql.DatabaseMetaData 中的方法
获取用于引用 SQL 标识符的字符串。
getIdentity(String) - 类 java.security.IdentityScope 中的方法
已过时。 返回此作用域内具有指定名称的身份（如果有的话）。
getIdentity(Principal) - 类 java.security.IdentityScope 中的方法
已过时。 获取名称与指定的主体相同的身份。
getIdentity(PublicKey) - 类 java.security.IdentityScope 中的方法
已过时。 获取具有指定公钥的身份。
getIdentityHashCode() - 类 java.lang.management.LockInfo 中的方法
返回从 System.identityHashCode(java.lang.Object) 方法返回的锁对象的标识哈希码。
getIDs() - 接口 javax.naming.directory.Attributes 中的方法
检索属性集中属性的 id 的枚举。
getIDs() - 类 javax.naming.directory.BasicAttributes 中的方法

getIds() - 接口 javax.net.ssl.SSLSessionContext 中的方法
返回在此 SSLSessionContext 下分组的所有会话 id 的 Enumeration。
getIDstring() - 类 java.awt.GraphicsDevice 中的方法
返回与此 GraphicsDevice 关联的标识字符串。
getIfModifiedSince() - 类 java.net.URLConnection 中的方法
返回此对象的 ifModifiedSince 字段的值。
getIgnoreRepaint() - 类 java.awt.Component 中的方法

getImage(URL) - 类 java.applet.Applet 中的方法
返回能被绘制到屏幕上的 Image 对象。
getImage(URL, String) - 类 java.applet.Applet 中的方法
返回能被绘制到屏幕上的 Image 对象。
getImage(URL) - 接口 java.applet.AppletContext 中的方法
返回能被绘制到屏幕上的 Image 对象。
getImage() - 类 java.awt.TexturePaint 中的方法
返回用于填充形状的 BufferedImage 纹理。
getImage(String) - 类 java.awt.Toolkit 中的方法
返回一幅图像，该图像从指定文件中获取像素数据，图像格式可以是 GIF、JPEG 或 PNG。
getImage(URL) - 类 java.awt.Toolkit 中的方法
返回一幅图像，该图像从指定 URL 获取像素数据。
getImage() - 类 java.awt.TrayIcon 中的方法
返回用于此 TrayIcon 的当前图像。
getImage() - 类 javax.swing.ImageIcon 中的方法
返回此图标的 Image。
getImage() - 类 javax.swing.text.html.ImageView 中的方法
返回要呈现的图像。
getImageableHeight() - 类 java.awt.print.PageFormat 中的方法
返回页面可成像区域的高度（以 1/72 英寸为单位）。
getImageableHeight() - 类 java.awt.print.Paper 中的方法
返回此 Paper 对象可成像区域的高度。
getImageableWidth() - 类 java.awt.print.PageFormat 中的方法
返回页面可成像区域的宽度（以 1/72 英寸为单位）。
getImageableWidth() - 类 java.awt.print.Paper 中的方法
返回此 Paper 对象可成像区域的宽度。
getImageableX() - 类 java.awt.print.PageFormat 中的方法
返回与此 PageFormat 相关的 Paper 对象的可成像区域左上方点的 x 坐标。
getImageableX() - 类 java.awt.print.Paper 中的方法
返回此 Paper 对象可成像区域左上角的 x 坐标。
getImageableY() - 类 java.awt.print.PageFormat 中的方法
返回与此 PageFormat 相关的 Paper 对象的可成像区域左上方点的 y 坐标。
getImageableY() - 类 java.awt.print.Paper 中的方法
返回此 Paper 对象可成像区域左上角的 y 坐标。
getImageCapabilities() - 类 java.awt.GraphicsConfiguration 中的方法
返回此 GraphicsConfiguration 的图像能力。
getImageLoadStatus() - 类 javax.swing.ImageIcon 中的方法
返回图像加载操作的状态。
getImageMetadata(int) - 类 javax.imageio.ImageReader 中的方法
返回包含与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
getImageMetadata(int, String, Set<String>) - 类 javax.imageio.ImageReader 中的方法
返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。
getImageMetadataFormat(String) - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回描述给定的图像元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
getImageObserver() - 类 javax.swing.ImageIcon 中的方法
返回图像的图像观察者。
getImageReader(ImageWriter) - 类 javax.imageio.ImageIO 中的静态方法
返回对应于给定 ImageWriter 的 ImageReader（如果有）；如果此 ImageWriter 的插件没有指定相应的 ImageReader，或者给定 ImageWriter 没有注册，则返回 null。
getImageReaders(Object) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码所提供的 Object（通常是一个 ImageInputStream）。
getImageReadersByFormatName(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码指定格式。
getImageReadersByMIMEType(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定 MIME 类型的文件。
getImageReadersBySuffix(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定后缀的文件。
getImageReaderSpiNames() - 类 javax.imageio.spi.ImageWriterSpi 中的方法
返回一个 String 数组，该数组包含所有能够理解由与此服务提供者关联的 ImageWriter 使用的内部元数据表示形式的 ImageReaderSpi 类的完全限定名。
getImageTranscoders(ImageReader, ImageWriter) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。
getImageTypes(int) - 类 javax.imageio.ImageReader 中的方法
以 ImageTypeSpecifier 形式返回包含可能的图像类型的 Iterator，给定图像可能被解码成这些类型。
getImageURL() - 类 java.awt.SplashScreen 中的方法
返回当前闪现屏幕图像。
getImageURL() - 类 javax.swing.text.html.ImageView 中的方法
返回图像源的 URL，如果不能确定图像源，则返回 null。
getImageWriter(ImageReader) - 类 javax.imageio.ImageIO 中的静态方法
返回对应于给定 ImageReader 的 ImageWriter（如果有）；如果此 ImageReader 的插件没有指定相应的 ImageWriter，或者给定的 ImageReader 没有注册，则返回 null。
getImageWriters(ImageTypeSpecifier, String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。
getImageWritersByFormatName(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码指定格式。
getImageWritersByMIMEType(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定 MIME 类型的文件。
getImageWritersBySuffix(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定后缀的文件。
getImageWriterSpiNames() - 类 javax.imageio.spi.ImageReaderSpi 中的方法
返回一个 String 数组，其包含所有能够理解由与此服务提供者关联的 ImageReader 使用的内部元数据表示形式的 ImageWriterSpi 类的完全限定名。
getImpact() - 类 javax.management.MBeanOperationInfo 中的方法
返回该方法所产生的影响，为 INFO、ACTION、ACTION_INFO、UNKNOWN 之一。
getImpact() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回一个 int 常量，该常量限定此 OpenMBeanOperationInfo 实例描述的操作的效果。
getImpact(MBeanOperationInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的操作的 impact 标志。
getImplementation() - 类 javax.management.StandardMBean 中的方法
获取此 Standard MBean（或 MXBean）的实现。
getImplementation() - 接口 org.w3c.dom.Document 中的方法
处理此文档的 DOMImplementation 对象。
getImplementationClass() - 类 javax.management.StandardMBean 中的方法
获取此 Standard MBean（或 MXBean）的实现类。
getImplementationName() - 类 javax.management.MBeanServerDelegate 中的方法
返回 JMX 实现的名称（此产品的名称）。
getImplementationName() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回 JMX 实现名（此产品的名称）。
getImplementationTitle() - 类 java.lang.Package 中的方法
返回此包的标题。
getImplementationVendor() - 类 java.lang.Package 中的方法
返回提供该实现的组织、供应商或公司的名称。
getImplementationVendor() - 类 javax.management.MBeanServerDelegate 中的方法
返回 JMX 实现供应商（此产品的供应商）。
getImplementationVendor() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回 JMX 实现供应商（此产品的供应商）。
getImplementationVersion() - 类 java.lang.Package 中的方法
返回该实现的版本。
getImplementationVersion() - 类 javax.management.MBeanServerDelegate 中的方法
返回 JMX 实现的版本（此产品的版本）。
getImplementationVersion() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回 JMX 实现版本（此产品的版本）。
getImplementor() - 类 javax.xml.ws.Endpoint 中的方法
返回此端点的实现对象。
getImplicitDownCycleTraversal() - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回对此 ContainerOrderFocusTraversalPolicy 是否隐式将焦点传递给下一个循环的判断。
getImplicitDownCycleTraversal() - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回对此 SortingFocusTraversalPolicy 是否隐式将焦点传输给下一个循环的判断。
getImportedKeys(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取由给定表的外键列（表导入的主键）引用的主键列的描述。
getInactiveControlTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的非活动控件文本颜色。
getInactiveControlTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回非活动控件文本颜色。
getInactiveControlTextColor() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回非活动控件文本颜色。
getInactiveSystemTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的非活动系统文本颜色。
getInactiveSystemTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回非活动系统文本颜色。
getInCheck() - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
getIndentLevel() - 类 javax.swing.text.AbstractWriter 中的方法
返回当前的缩进级别。
getIndentSpace() - 类 javax.swing.text.AbstractWriter 中的方法
返回要缩进的空格量。
getIndex() - 类 java.beans.IndexedPropertyChangeEvent 中的方法
获得被更改属性的索引。
getIndex() - 异常 java.net.URISyntaxException 中的方法
返回输入字符串中出现解析错误的位置的索引，或者如果该位置为未知，则返回 -1。
getIndex() - 异常 java.security.cert.CertPathValidatorException 中的方法
返回导致该异常抛出的证书在证书路径中的索引。
getIndex() - 异常 java.sql.DataTruncation 中的方法
获取被截断的列或参数的索引。
getIndex() - 接口 java.text.CharacterIterator 中的方法
返回当前索引。
getIndex() - 类 java.text.ParsePosition 中的方法
获取当前的解析位置。
getIndex() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.getIndex()。
getIndex() - 异常 java.util.regex.PatternSyntaxException 中的方法
获取错误的索引。
getIndex() - 接口 javax.swing.event.DocumentEvent.ElementChange 中的方法
获得所表示元素中的索引。
getIndex() - 类 javax.swing.JList.DropLocation 中的方法
返回列表中应该用来放入放置数据的索引。
getIndex(int) - 类 javax.swing.SizeSequence 中的方法
返回与指定位置对应的条目的索引。
getIndex(TreeNode) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
返回接收方子级中 node 的索引。
getIndex() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
返回元素列表中的索引。
getIndex() - 类 javax.swing.text.html.parser.Element 中的方法
获取索引。
getIndex() - 类 javax.swing.text.JTextComponent.DropLocation 中的方法
返回关联组件中应该用来插入放置数据的位置的索引。
getIndex() - 类 javax.swing.text.Segment 中的方法
返回当前索引。
getIndex(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的子节点数组中指定子节点的索引。
getIndex(TreeNode) - 接口 javax.swing.tree.TreeNode 中的方法
返回接收者子节点中的 node 的索引。
getIndex(String, String) - 接口 org.xml.sax.Attributes 中的方法
通过名称空间的名称查找属性的索引。
getIndex(String) - 接口 org.xml.sax.Attributes 中的方法
通过 XML 限定（前缀）名查找属性的索引。
getIndex(String, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过名称空间名称查找属性的索引。
getIndex(String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过限定（加前缀的）名称查找属性的索引。
getIndex0() - 类 javax.swing.event.ListDataEvent 中的方法
返回该范围的较小的索引。
getIndex1() - 类 javax.swing.event.ListDataEvent 中的方法
返回该范围的较大的索引。
getIndexAtPoint(Point) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
给出本地坐标中的一个点，返回该 Point 下的、从零开始的字符索引。
getIndexAtPoint(Point) - 接口 javax.accessibility.AccessibleText 中的方法
给定本地坐标中的一点，返回在该点下的字符从 0 开始的索引。
getIndexAtPoint(Point) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。
getIndexAtPoint(Point) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。
getIndexAtPoint(Point) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。
getIndexAtPoint(Point) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
在本地坐标中给定一个点，返回该 Point 下字符的从零开始的索引。
getIndexAtPoint(Point) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。
getIndexedPropertyType() - 类 java.beans.IndexedPropertyDescriptor 中的方法
获得索引属性类型的 Class 对象。
getIndexedReadMethod() - 类 java.beans.IndexedPropertyDescriptor 中的方法
获得应该用于读取索引属性值的方法。
getIndexedWriteMethod() - 类 java.beans.IndexedPropertyDescriptor 中的方法
获得应该用于写入索引属性值的方法。
getIndexInfo(String, String, String, boolean, boolean) - 接口 java.sql.DatabaseMetaData 中的方法
获取给定表的索引和统计信息的描述。
getIndexNames() - 类 javax.management.openmbean.TabularType 中的方法
按照提供此实例的构造方法的顺序返回一个不可修改的项名称列表，可以使用该列表的值唯一地索引此 TabularType 实例所描述的表格数据值的每个行元素。
getIndexOf(Object) - 类 javax.swing.DefaultComboBoxModel 中的方法
返回指定对象在列表中的索引位置。
getIndexOf(Component) - 类 javax.swing.JLayeredPane 中的方法
返回指定 Component 的索引。
getIndexOfChild(Object, Object) - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回父节点中子节点的索引。
getIndexOfChild(Object, Object) - 接口 javax.swing.tree.TreeModel 中的方法
返回父节点中子节点的索引。
getIndexOfSize(float) - 类 javax.swing.text.html.StyleSheet 中的静态方法

getInetAddress() - 类 java.net.DatagramSocket 中的方法
返回此套接字连接的地址。
getInetAddress() - 类 java.net.ServerSocket 中的方法
返回此服务器套接字的本地地址。
getInetAddress() - 类 java.net.Socket 中的方法
返回套接字连接的地址。
getInetAddress() - 类 java.net.SocketImpl 中的方法
返回此套接字的 address 字段的值。
getInetAddresses() - 类 java.net.NetworkInterface 中的方法
一个便捷方法，返回一个具有绑定到此网络接口全部或部分 InetAddress 的 Enumeration。
getInfinity() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于表示无穷大的字符串。
getInfo() - 类 java.security.Identity 中的方法
已过时。 返回以前为此 Identity 指定的常规信息字符串。
getInfo() - 类 java.security.Provider 中的方法
返回 provider 及其服务的人可读 (human-readable) 的描述。
getInheritsPopupMenu() - 类 javax.swing.JComponent 中的方法
如果应该从父组件继承 JPopupMenu，则返回 true。
getInit() - 类 java.lang.management.MemoryUsage 中的方法
返回 Java 虚拟机最初从操作系统请求用于内存管理的内存量（以字节为单位）。
getInitialComponent(Window) - 类 java.awt.FocusTraversalPolicy 中的方法
返回第一次将窗口设置为可见时，应该接收焦点的 Component。
getInitialComponent(JInternalFrame) - 类 javax.swing.InternalFrameFocusTraversalPolicy 中的方法
返回第一次选择 JInternalFrame 时应该接收焦点的 Component。
getInitialContext(Hashtable<?, ?>) - 接口 javax.naming.spi.InitialContextFactory 中的方法
创建一个初始上下文，以便开始进行名称解析。
getInitialContext(Hashtable<?, ?>) - 类 javax.naming.spi.NamingManager 中的静态方法
使用指定环境属性创建一个初始上下文工厂。
getInitialDelay() - 类 javax.swing.Timer 中的方法
返回 Timer 的初始延迟。
getInitialDelay() - 类 javax.swing.ToolTipManager 中的方法
返回初始延迟值。
getInitialLocation(Insets) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
如果 Insets 不为 null，则返回左边 inset；如果其为 null，则返回 0。
getInitialPolicies() - 类 java.security.cert.PKIXParameters 中的方法
返回初始策略标识符（OID 字符串）的不可变 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。
getInitialSelectionValue() - 类 javax.swing.JOptionPane 中的方法
返回（根据最初选择）向用户显示的输入值。
getInitialValue() - 类 javax.swing.JOptionPane 中的方法
返回初始值。
getInitialValueIndex() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
将初始索引返回给要选择的按钮。
getInitiatedClasses(ClassLoader) - 接口 java.lang.instrument.Instrumentation 中的方法
返回所有初始化加载器是 loader 的类的数组。
getInitiatorAddress() - 类 org.ietf.jgss.ChannelBinding 中的方法
获得此通道绑定的初始端地址。
getInitThreshold() - 类 javax.management.monitor.CounterMonitor 中的方法
获取所有观察对象的公共初始阈值。
getInitThreshold() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取所有 observed 对象的公共初始阈值。
getInput() - 异常 java.net.URISyntaxException 中的方法
返回输入字符串。
getInput() - 类 javax.imageio.ImageReader 中的方法
返回以前设置为输入源的 ImageInputStream 或其他 Object。
getInput() - 接口 org.w3c.dom.ls.LSLoadEvent 中的方法
被解析的输入源。
getInput() - 接口 org.w3c.dom.ls.LSProgressEvent 中的方法
被解析的输入源。
getInputArguments() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回传递给 Java 虚拟机的输入变量，其中不包括传递给 main 方法的变量。
getInputAttributes() - 类 javax.swing.JTextPane 中的方法
获取窗格的输入属性。
getInputAttributes() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取该样式编辑动作的输入属性。
getInputAttributes() - 类 javax.swing.text.StyledEditorKit 中的方法
获取该窗格的输入属性。
getInputClass() - 类 javax.imageio.spi.ImageInputStreamSpi 中的方法
返回表示必须由输入源实现（以便使用 createInputStreamInstance 方法在 ImageInputStream 中“包装”）的类或接口的类型的 Class 对象。
getInputContext() - 类 java.awt.Component 中的方法
获取此组件使用的输入上下文，用于处理在此组件中输入文本时与输入方法的通信。
getInputContext() - 类 java.awt.Window 中的方法
获取此窗口的输入上下文。
getInputEncoding() - 接口 org.w3c.dom.Document 中的方法
指定解析时此文档使用的编码的属性。
getInputEncoding() - 接口 org.w3c.dom.Entity 中的方法
当实体为外部解析实体时，它是在解析时用于此实体的指定编码的属性。
getInputLength() - 异常 java.nio.charset.MalformedInputException 中的方法

getInputLength() - 异常 java.nio.charset.UnmappableCharacterException 中的方法

getInputMap(int) - 类 javax.swing.JComponent 中的方法
返回 condition 中所使用的 InputMap。
getInputMap() - 类 javax.swing.JComponent 中的方法
返回组件具有焦点时所使用的 InputMap。
getInputMethodControlObject() - 类 java.awt.im.InputContext 中的方法
返回当前输入方法中的一个控制对象，或 null。
getInputMethodDisplayName(Locale, Locale) - 接口 java.awt.im.spi.InputMethodDescriptor 中的方法
用将显示该名称的语言返回用户可视名称，该名称与给定的输入语言环境的输入方法相对应。
getInputMethodIcon(Locale) - 接口 java.awt.im.spi.InputMethodDescriptor 中的方法
返回相应输入方法的图标。
getInputMethodListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的输入方法侦听器的数组。
getInputMethodRequests() - 类 java.awt.Component 中的方法
获取输入方法请求处理程序，该处理程序支持此组件输入方法发出的请求。
getInputMethodRequests() - 类 java.awt.TextComponent 中的方法

getInputMethodRequests() - 类 javax.swing.text.JTextComponent 中的方法

getInputSource() - 类 javax.xml.transform.sax.SAXSource 中的方法
获取要用于 Source 的 SAX InputSource。
getInputStream() - 类 java.lang.Process 中的方法
获取子进程的输入流。
getInputStream() - 类 java.net.Socket 中的方法
返回此套接字的输入流。
getInputStream() - 类 java.net.SocketImpl 中的方法
返回此套接字的输入流。
getInputStream() - 类 java.net.URLConnection 中的方法
返回从此打开的连接读取的输入流。
getInputStream() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
getInputStream(ZipEntry) - 类 java.util.jar.JarFile 中的方法
返回用于读取指定 zip 文件条目内容的输入流。
getInputStream(ZipEntry) - 类 java.util.zip.ZipFile 中的方法
返回输入流以读取指定 ZIP 文件条目的内容。
getInputStream() - 类 javax.activation.DataHandler 中的方法
获取此对象的 InputSteam。
getInputStream() - 接口 javax.activation.DataSource 中的方法
此方法返回一个表示数据的 InputStream；如果无法提供，则抛出适当的异常。
getInputStream() - 类 javax.activation.FileDataSource 中的方法
此方法将返回一个表示数据的 InputStream；如果不能返回，则抛出 IOException。
getInputStream() - 类 javax.activation.URLDataSource 中的方法
URL 的 getInputStream 方法。
getInputStream() - 类 javax.xml.transform.stream.StreamSource 中的方法
获取通过 setByteStream 设置的字节流。
getInputStream() - 异常 org.omg.CORBA.portable.ApplicationException 中的方法
返回可从中读取异常数据作为其参数的输入流。
getInputTypes() - 类 javax.imageio.spi.ImageReaderSpi 中的方法
返回 Class 对象数组，指示可用作 reader 的 setInput 方法参数的对象类型。
getInputValue() - 类 javax.swing.JOptionPane 中的方法
如果 wantsInput 为 true，则返回用户已输入的值。
getInputVerifier() - 类 javax.swing.JComponent 中的方法
返回此组件的输入校验器。
getInsertionIndex() - 类 java.awt.font.TextHitInfo 中的方法
返回插入索引。
getInsertPositionOffset() - 接口 java.awt.im.InputMethodRequests 中的方法
获取文本编辑组件中包含的提交文本中的插入位置偏移量。
getInset(int, View) - 类 javax.swing.text.html.StyleSheet.BoxPainter 中的方法
获取给定边上所需的 inset，以便计算空白、边框和填充数量。
getInsets() - 类 java.awt.Container 中的方法
确定此容器的 insets，它指示容器边框的大小。
getInsets() - 类 javax.swing.JComponent 中的方法
如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。
getInsets(Insets) - 类 javax.swing.JComponent 中的方法
返回包含此组件 inset 值的 Insets 对象。
getInsets() - 类 javax.swing.JViewport 中的方法
返回 inset（边框）维数 (0,0,0,0)，因为在 JViewport 上不支持边框。
getInsets(Insets) - 类 javax.swing.JViewport 中的方法
返回包含此 JViewport 的 inset 值的 inset 对象。
getInsets() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
获取 JComboBox 的 insets。
getInsets(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法

getInsets() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。
getInsets(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回 insets。
getInsets() - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法

getInsets(SynthContext, Insets) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回用来计算大小调整信息的 Insets。
getInsets(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Insets，则返回它，否则返回 null。
getInsets(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Insets，则返回该 Insets，否则返回 null。
getInsets(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个 Insets 对象。
getInsets(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个 Insets 对象。
getInsetSpan(int) - 类 javax.swing.text.AsyncBoxView 中的方法
获取 insets 所占据的沿某个轴的跨距。
getInsideAllocation(Shape) - 类 javax.swing.text.CompositeView 中的方法
将分配给视图的不可变分配区域转换为表示内部分配区域的可变分配区域（即给定分配区域的边界，其顶部、左部、底部和右部的 insets 已移除）。
getInsideBorder() - 类 javax.swing.border.CompoundBorder 中的方法
返回内部边框对象。
getInstalledLookAndFeels() - 类 javax.swing.UIManager 中的静态方法
返回表示当前可用的 LookAndFeel 实现的 LookAndFeelInfo 数组。
getInstance(int) - 类 java.awt.AlphaComposite 中的静态方法
创建一个具有指定规则的 AlphaComposite 对象。
getInstance(int, float) - 类 java.awt.AlphaComposite 中的静态方法
创建一个 AlphaComposite 对象，它具有指定的规则和用来乘源色 alpha 值的常量 alpha 值。
getInstance(int) - 类 java.awt.color.ColorSpace 中的静态方法
返回表示特定于预定义颜色空间之一的 ColorSpace。
getInstance(byte[]) - 类 java.awt.color.ICC_Profile 中的静态方法
构造一个与 byte 数组中的数据相对应的 ICC_Profile 对象。
getInstance(int) - 类 java.awt.color.ICC_Profile 中的静态方法
构造一个与 ColorSpace 类所定义的指定颜色空间之一（如 CS_sRGB）相对应的 ICC_Profile。
getInstance(String) - 类 java.awt.color.ICC_Profile 中的静态方法
构造一个与文件中的数据相对应的 ICC_Profile。
getInstance(InputStream) - 类 java.awt.color.ICC_Profile 中的静态方法
构造一个与 InputStream 中的数据相对应的 ICC_Profile。
getInstance() - 类 java.awt.im.InputContext 中的静态方法
返回新 InputContext 实例。
getInstance(String) - 类 java.security.AlgorithmParameterGenerator 中的静态方法
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
getInstance(String, String) - 类 java.security.AlgorithmParameterGenerator 中的静态方法
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
getInstance(String, Provider) - 类 java.security.AlgorithmParameterGenerator 中的静态方法
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
getInstance(String) - 类 java.security.AlgorithmParameters 中的静态方法
返回指定算法的参数对象。
getInstance(String, String) - 类 java.security.AlgorithmParameters 中的静态方法
返回指定算法的参数对象。
getInstance(String, Provider) - 类 java.security.AlgorithmParameters 中的静态方法
返回指定算法的参数对象。
getInstance(String) - 类 java.security.cert.CertificateFactory 中的静态方法
返回实现指定证书类型的 CertificateFactory 对象。
getInstance(String, String) - 类 java.security.cert.CertificateFactory 中的静态方法
返回指定证书类型的 CertificateFactory 对象。
getInstance(String, Provider) - 类 java.security.cert.CertificateFactory 中的静态方法
返回指定证书类型的 CertificateFactory 对象。
getInstance(String) - 类 java.security.cert.CertPathBuilder 中的静态方法
返回实现了指定算法的 CertPathBuilder 对象。
getInstance(String, String) - 类 java.security.cert.CertPathBuilder 中的静态方法
返回实现了指定算法的 CertPathBuilder 对象。
getInstance(String, Provider) - 类 java.security.cert.CertPathBuilder 中的静态方法
返回实现了指定算法的 CertPathBuilder 对象。
getInstance(String) - 类 java.security.cert.CertPathValidator 中的静态方法
返回实现了指定算法的 CertPathValidator 对象。
getInstance(String, String) - 类 java.security.cert.CertPathValidator 中的静态方法
返回实现指定算法的 CertPathValidator 对象。
getInstance(String, Provider) - 类 java.security.cert.CertPathValidator 中的静态方法
返回实现指定算法的 CertPathValidator 对象。
getInstance(String, CertStoreParameters) - 类 java.security.cert.CertStore 中的静态方法
返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
getInstance(String, CertStoreParameters, String) - 类 java.security.cert.CertStore 中的静态方法
返回一个实现指定 CertStore 类型的 CertStore 对象。
getInstance(String, CertStoreParameters, Provider) - 类 java.security.cert.CertStore 中的静态方法
返回一个实现指定 CertStore 类型的 CertStore 对象。
getInstance(String) - 类 java.security.KeyFactory 中的静态方法
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
getInstance(String, String) - 类 java.security.KeyFactory 中的静态方法
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
getInstance(String, Provider) - 类 java.security.KeyFactory 中的静态方法
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
getInstance(String) - 类 java.security.KeyPairGenerator 中的静态方法
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
getInstance(String, String) - 类 java.security.KeyPairGenerator 中的静态方法
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
getInstance(String, Provider) - 类 java.security.KeyPairGenerator 中的静态方法
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
getInstance(String) - 类 java.security.KeyStore 中的静态方法
返回指定类型的 keystore 对象。
getInstance(String, String) - 类 java.security.KeyStore 中的静态方法
返回指定类型的 keystore 对象。
getInstance(String, Provider) - 类 java.security.KeyStore 中的静态方法
返回指定类型的 keystore 对象。
getInstance(String) - 类 java.security.MessageDigest 中的静态方法
返回实现指定摘要算法的 MessageDigest 对象。
getInstance(String, String) - 类 java.security.MessageDigest 中的静态方法
返回实现指定摘要算法的 MessageDigest 对象。
getInstance(String, Provider) - 类 java.security.MessageDigest 中的静态方法
返回实现指定摘要算法的 MessageDigest 对象。
getInstance(String, Policy.Parameters) - 类 java.security.Policy 中的静态方法
返回指定类型的 Policy 对象。
getInstance(String, Policy.Parameters, String) - 类 java.security.Policy 中的静态方法
返回指定类型的 Policy 对象。
getInstance(String, Policy.Parameters, Provider) - 类 java.security.Policy 中的静态方法
返回指定类型的 Policy 对象。
getInstance(String) - 类 java.security.SecureRandom 中的静态方法
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
getInstance(String, String) - 类 java.security.SecureRandom 中的静态方法
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
getInstance(String, Provider) - 类 java.security.SecureRandom 中的静态方法
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
getInstance(String) - 类 java.security.Signature 中的静态方法
返回实现指定签名算法的 Signature 对象。
getInstance(String, String) - 类 java.security.Signature 中的静态方法
返回实现指定签名算法的 Signature 对象。
getInstance(String, Provider) - 类 java.security.Signature 中的静态方法
返回实现指定签名算法的 Signature 对象。
getInstance() - 类 java.text.Collator 中的静态方法
获取当前默认语言环境的 Collator。
getInstance(Locale) - 类 java.text.Collator 中的静态方法
获取所需语言环境的 Collator。
getInstance() - 类 java.text.DateFormat 中的静态方法
获取为日期和时间使用 SHORT 风格的默认日期/时间格式器。
getInstance() - 类 java.text.DateFormatSymbols 中的静态方法
获取默认语言环境的 DateFormatSymbols 实例。
getInstance(Locale) - 类 java.text.DateFormatSymbols 中的静态方法
获取指定语言环境的 DateFormatSymbols 实例。
getInstance() - 类 java.text.DecimalFormatSymbols 中的静态方法
获取默认语言环境的 DecimalFormatSymbols 实例。
getInstance(Locale) - 类 java.text.DecimalFormatSymbols 中的静态方法
获取指定语言环境的 DecimalFormatSymbols 实例。
getInstance() - 类 java.text.NumberFormat 中的静态方法
返回当前默认语言环境的通用数值格式。
getInstance(Locale) - 类 java.text.NumberFormat 中的静态方法
返回指定语言环境的通用数值格式。
getInstance(Locale) - 类 java.text.spi.CollatorProvider 中的方法
为指定语言环境返回新的 Collator 实例。
getInstance(Locale) - 类 java.text.spi.DateFormatSymbolsProvider 中的方法
为指定语言环境返回一个新的 DateFormatSymbols 实例。
getInstance(Locale) - 类 java.text.spi.DecimalFormatSymbolsProvider 中的方法
为指定语言环境返回新的 DecimalFormatSymbols 实例。
getInstance() - 类 java.util.Calendar 中的静态方法
使用默认时区和语言环境获得一个日历。
getInstance(TimeZone) - 类 java.util.Calendar 中的静态方法
使用指定时区和默认语言环境获得一个日历。
getInstance(Locale) - 类 java.util.Calendar 中的静态方法
使用默认时区和指定语言环境获得一个日历。
getInstance(TimeZone, Locale) - 类 java.util.Calendar 中的静态方法
使用指定时区和语言环境获得一个日历。
getInstance(String) - 类 java.util.Currency 中的静态方法
返回给定货币代码的 Currency 实例。
getInstance(Locale) - 类 java.util.Currency 中的静态方法
返回给定语言环境的国家/地区的 Currency 实例。
getInstance(String) - 类 javax.crypto.Cipher 中的静态方法
返回实现指定转换的 Cipher 对象。
getInstance(String, String) - 类 javax.crypto.Cipher 中的静态方法
返回实现指定转换的 Cipher 对象。
getInstance(String, Provider) - 类 javax.crypto.Cipher 中的静态方法
返回实现指定转换的 Cipher 对象。
getInstance(String) - 类 javax.crypto.ExemptionMechanism 中的静态方法
返回实现指定豁免机制算法的 ExemptionMechanism 对象。
getInstance(String, String) - 类 javax.crypto.ExemptionMechanism 中的静态方法
返回实现指定豁免机制算法的 ExemptionMechanism 对象。
getInstance(String, Provider) - 类 javax.crypto.ExemptionMechanism 中的静态方法
返回实现指定豁免机制算法的 ExemptionMechanism 对象。
getInstance(String) - 类 javax.crypto.KeyAgreement 中的静态方法
返回实现指定密钥协定算法的 KeyAgreement 对象。
getInstance(String, String) - 类 javax.crypto.KeyAgreement 中的静态方法
返回实现指定密钥协定算法的 KeyAgreement 对象。
getInstance(String, Provider) - 类 javax.crypto.KeyAgreement 中的静态方法
返回实现指定密钥协定算法的 KeyAgreement 对象。
getInstance(String) - 类 javax.crypto.KeyGenerator 中的静态方法
返回生成指定算法的秘密密钥的 KeyGenerator 对象。
getInstance(String, String) - 类 javax.crypto.KeyGenerator 中的静态方法
返回生成指定算法的秘密密钥的 KeyGenerator 对象。
getInstance(String, Provider) - 类 javax.crypto.KeyGenerator 中的静态方法
返回生成指定算法的秘密密钥的 KeyGenerator 对象。
getInstance(String) - 类 javax.crypto.Mac 中的静态方法
返回实现指定 MAC 算法的 Mac 对象。
getInstance(String, String) - 类 javax.crypto.Mac 中的静态方法
返回实现指定 MAC 算法的 Mac 对象。
getInstance(String, Provider) - 类 javax.crypto.Mac 中的静态方法
返回实现指定 MAC 算法的 Mac 对象。
getInstance(String) - 类 javax.crypto.SecretKeyFactory 中的静态方法
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
getInstance(String, String) - 类 javax.crypto.SecretKeyFactory 中的静态方法
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
getInstance(String, Provider) - 类 javax.crypto.SecretKeyFactory 中的静态方法
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
getInstance(String) - 类 javax.management.ObjectName 中的静态方法
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。
getInstance(String, String, String) - 类 javax.management.ObjectName 中的静态方法
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。
getInstance(String, Hashtable<String, String>) - 类 javax.management.ObjectName 中的静态方法
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。
getInstance(ObjectName) - 类 javax.management.ObjectName 中的静态方法
返回 ObjectName 的实例，该 ObjectName 可用于任何可使用给定对象的地方。
getInstance(String) - 类 javax.net.ssl.KeyManagerFactory 中的静态方法
返回充当密钥管理器工厂的 KeyManagerFactory 对象。
getInstance(String, String) - 类 javax.net.ssl.KeyManagerFactory 中的静态方法
返回充当密钥管理器工厂的 KeyManagerFactory 对象。
getInstance(String, Provider) - 类 javax.net.ssl.KeyManagerFactory 中的静态方法
返回充当密钥管理器工厂的 KeyManagerFactory 对象。
getInstance(String) - 类 javax.net.ssl.SSLContext 中的静态方法
返回实现指定安全套接字协议的 SSLContext 对象。
getInstance(String, String) - 类 javax.net.ssl.SSLContext 中的静态方法
返回实现指定安全套接字协议的 SSLContext 对象。
getInstance(String, Provider) - 类 javax.net.ssl.SSLContext 中的静态方法
返回实现指定安全套接字协议的 SSLContext 对象。
getInstance(String) - 类 javax.net.ssl.TrustManagerFactory 中的静态方法
返回充当信任管理器工厂的 TrustManagerFactory 对象。
getInstance(String, String) - 类 javax.net.ssl.TrustManagerFactory 中的静态方法
返回充当信任管理器工厂的 TrustManagerFactory 对象。
getInstance(String, Provider) - 类 javax.net.ssl.TrustManagerFactory 中的静态方法
返回充当信任管理器工厂的 TrustManagerFactory 对象。
getInstance(String, Configuration.Parameters) - 类 javax.security.auth.login.Configuration 中的静态方法
返回指定类型的 Configuration 对象。
getInstance(String, Configuration.Parameters, String) - 类 javax.security.auth.login.Configuration 中的静态方法
返回指定类型的 Configuration 对象。
getInstance(String, Configuration.Parameters, Provider) - 类 javax.security.auth.login.Configuration 中的静态方法
返回指定类型的 Configuration 对象。
getInstance(InputStream) - 类 javax.security.cert.X509Certificate 中的静态方法
实例化一个 X509Certificate 对象，并使用从输入流 inStream 读取的数据初始化它。
getInstance(byte[]) - 类 javax.security.cert.X509Certificate 中的静态方法
实例化一个 X509Certificate 对象，并使用指定的 byte 数组初始化它。
getInstance(String) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
返回 providerID 标识的 SyncProvider 实例。
getInstance() - 类 javax.swing.LayoutStyle 中的静态方法
返回 LayoutStyle 的共享实例。
getInstance(String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的静态方法
返回 KeyInfoFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。
getInstance(String, Provider) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的静态方法
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。
getInstance(String, String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的静态方法
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。
getInstance() - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的静态方法
返回支持默认 XML 处理机制和表示形式类型（“DOM”） 的 KeyInfoFactory。
getInstance(String, String) - 类 javax.xml.crypto.dsig.TransformService 中的静态方法
返回支持指定算法 URI 的 TransformService（比如：Transform.XPATH2）和机制类型（比如：DOM）。
getInstance(String, String, Provider) - 类 javax.xml.crypto.dsig.TransformService 中的静态方法
返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
getInstance(String, String, String) - 类 javax.xml.crypto.dsig.TransformService 中的静态方法
返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
getInstance(String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的静态方法
返回 XMLSignatureFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。
getInstance(String, Provider) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的静态方法
返回支持请求的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
getInstance(String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的静态方法
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
getInstance() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的静态方法
返回支持默认的 XML 处理机制和表示形式类型（“DOM”） 的 XMLSignatureFactory。
getInstance() - 类 org.ietf.jgss.GSSManager 中的静态方法
返回默认的 GSSManager 实现。
getInstanceFollowRedirects() - 类 java.net.HttpURLConnection 中的方法
返回此 HttpURLConnection 的 instanceFollowRedirects 字段的值。
getInstanceOf(Object, Class<?>) - 类 java.beans.Beans 中的静态方法
从给定 bean 中获得表示源对象的指定类型视图的对象。
getInstrument(Patch) - 接口 javax.sound.midi.Soundbank 中的方法
获得取自给定 Patch 的 Instrument。
getInstruments() - 接口 javax.sound.midi.Soundbank 中的方法
获得包含在此音库中的乐器列表。
getInt(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 int 形式返回指定数组对象中索引组件的值。
getInt(Object) - 类 java.lang.reflect.Field 中的方法
获取 int 类型或另一个通过扩展转换可以转换为 int 类型的基本类型的静态或实例字段的值。
getInt() - 类 java.nio.ByteBuffer 中的方法
用于读取 int 值的相对 get 方法。
getInt(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 int 值的绝对 get 方法。
getInt(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 int 值的形式获取指定的 JDBC INTEGER 参数的值。
getInt(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 int 值的形式获取 JDBC INTEGER 参数的值。
getInt(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。
getInt(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。
getInt(String, int) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getInt(String,int) 中的规范实现 getInt 方法。
getInt(String, int) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中与指定键相关联的、由字符串表示的 int 值。
getInt(SynthContext, Object, int) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
获得值为 Number 的一个特定样式属性的便捷方法。
getInt(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Integer，则返回该整数值，否则返回 0。
getInt(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Integer，则返回其整数值，否则返回 0。
getInt(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个整数。
getInt(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个整数。
getInteger(String) - 类 java.lang.Integer 中的静态方法
确定具有指定名称的系统属性的整数值。
getInteger(String, int) - 类 java.lang.Integer 中的静态方法
确定具有指定名称的系统属性的整数值。
getInteger(String, Integer) - 类 java.lang.Integer 中的静态方法
返回具有指定名称的系统属性的整数值。
getIntegerAttributeValue(AttributeSet, HTML.Attribute, int) - 类 javax.swing.text.html.HTML 中的静态方法
获取整数属性值。
getIntegerInstance() - 类 java.text.NumberFormat 中的静态方法
返回当前默认语言环境的整数格式。
getIntegerInstance(Locale) - 类 java.text.NumberFormat 中的静态方法
返回指定语言环境的整数格式。
getIntegerInstance(Locale) - 类 java.text.spi.NumberFormatProvider 中的方法
返回新的 NumberFormat 实例，此实例为指定的语言环境格式化整数值。
getIntegState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定数据完整性是否可用于上下文。
getIntercellSpacing() - 类 javax.swing.JTable 中的方法
返回单元格之间的水平间距和垂直间距。
getInterface() - 类 java.net.MulticastSocket 中的方法
获取用于多播数据包的网络接口的地址。
getInterface(Class<T>) - 接口 javax.script.Invocable 中的方法
返回一个接口的实现，该接口使用解释器中编译的函数。
getInterface(Object, Class<T>) - 接口 javax.script.Invocable 中的方法
返回一个接口的实现，该接口使用解释器中已编译脚本对象的成员函数。
getInterfaceAddresses() - 类 java.net.NetworkInterface 中的方法
获取此网络接口的全部或部分 InterfaceAddresses 所组成的列表。
getInterfaces() - 类 java.lang.Class 中的方法
确定此对象所表示的类或接口实现的接口。
getInterfaces() - 接口 javax.lang.model.element.TypeElement 中的方法
返回直接由此类实现或直接由此接口扩展的接口类型。
getInteriorRectangle(Component, int, int, int, int) - 类 javax.swing.border.AbstractBorder 中的方法
此便捷方法调用静态方法。
getInteriorRectangle(Component, Border, int, int, int, int) - 类 javax.swing.border.AbstractBorder 中的静态方法
返回一个用所给的参数减去边框 insets 得到的矩形。
getInternalFrame() - 类 javax.swing.event.InternalFrameEvent 中的方法
返回事件的发起者。
getInternalFrame() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
返回与此 DesktopIcon 关联的 JInternalFrame。
getInternalFrameAltMaximizeIcon(int) - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getInternalFrameBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getInternalFrameCloseIcon(int) - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getInternalFrameDefaultMenuIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getInternalFrameListeners() - 类 javax.swing.JInternalFrame 中的方法
返回使用 addInternalFrameListener 添加到此 JInternalFrame 的所有 InternalFrameListener 的数组。
getInternalFrameMaximizeIcon(int) - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getInternalFrameMinimizeIcon(int) - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getInternalSubset() - 接口 org.w3c.dom.DocumentType 中的方法
以字符串表示的内部子集，如果没有内部子集，则为 null。
getInternationalCurrencySymbol() - 类 java.text.DecimalFormatSymbols 中的方法
返回这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。
getInterpolationType() - 类 java.awt.image.AffineTransformOp 中的方法
返回由此 op 使用的插值类型。
getIntParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 int 返回参数的便捷方法。
getInvalidCharacters() - 类 javax.swing.text.MaskFormatter 中的方法
返回输入无效的字符。
getInverted() - 类 javax.swing.JSlider 中的方法
如果滑块显示的值范围反转，则返回 true。
getInvocationHandler(Object) - 类 java.lang.reflect.Proxy 中的静态方法
返回指定代理实例的调用处理程序。
getInvoker() - 类 javax.swing.JPopupMenu 中的方法
返回作为此弹出菜单的“调用者”的组件。
getInvokesStopCellEditing() - 类 javax.swing.JTree 中的方法
返回告知编辑中断时发生了什么情况的指示符。
getIOException() - 异常 java.awt.print.PrinterIOException 中的方法
返回终止打印作业的 IOException。
getISO3Country() - 类 java.util.Locale 中的方法
返回此语言环境国家/地区的三字母缩写。
getISO3Language() - 类 java.util.Locale 中的方法
返回此语言环境语言的三字母缩写。
getISOCountries() - 类 java.util.Locale 中的静态方法
返回 ISO 3166 中所定义的所有两字母国家/地区代码。
getISOLanguages() - 类 java.util.Locale 中的静态方法
返回 ISO 639 中所定义的所有两字母语言代码。
getIssuer() - 类 java.security.cert.X509CertSelector 中的方法
以 X500Principal 的形式返回 issuer 标准。
getIssuerAlternativeNames() - 类 java.security.cert.X509Certificate 中的方法
从 IssuerAltName 扩展 (OID = 2.5.29.18) 中获取一个发布方替换名称的不可变集合。
getIssuerAsBytes() - 类 java.security.cert.X509CertSelector 中的方法
返回以 byte 数组表示的 issuer 标准。
getIssuerAsString() - 类 java.security.cert.X509CertSelector 中的方法
已过时，使用 X509CertSelector.getIssuer() 或 X509CertSelector.getIssuerAsBytes() 替代。
getIssuerDN() - 类 java.security.cert.X509Certificate 中的方法
已过时，由 X509Certificate.getIssuerX500Principal() 替代。
getIssuerDN() - 类 java.security.cert.X509CRL 中的方法
已过时，由 X509CRL.getIssuerX500Principal() 替代。
getIssuerDN() - 类 javax.security.cert.X509Certificate 中的方法
获取证书的 issuer（发布方的标识名）值。
getIssuerName() - 接口 javax.xml.crypto.dsig.keyinfo.X509IssuerSerial 中的方法
返回 RFC 2253 String 格式的此 X509IssuerSerial 的 X.500 标识名。
getIssuerNames() - 类 java.security.cert.X509CRLSelector 中的方法
返回该 issuerNames 标准的一个副本。
getIssuers() - 类 java.security.cert.X509CRLSelector 中的方法
返回 issuerNames 标准。
getIssuerUniqueID() - 类 java.security.cert.X509Certificate 中的方法
获取证书的 issuerUniqueID 值。
getIssuerX500Principal() - 类 java.security.cert.X509Certificate 中的方法
以 X500Principal 的形式返回证书的发布方（发布方标识名）值。
getIssuerX500Principal() - 类 java.security.cert.X509CRL 中的方法
以 X500Principal 的形式返回 CRL 的发布方（发布方标识名）值。
getItalicAngle() - 类 java.awt.Font 中的方法
返回此 Font 的斜角。
getItem(int) - 类 java.awt.Choice 中的方法
获取此 Choice 菜单中指定索引上的字符串。
getItem() - 类 java.awt.event.ItemEvent 中的方法
返回受事件影响的项。
getItem(int) - 类 java.awt.List 中的方法
获取与指定索引关联的项。
getItem(int) - 类 java.awt.Menu 中的方法
获取此菜单的指定索引处的项。
getItem() - 接口 javax.swing.ComboBoxEditor 中的方法
返回已编辑项。
getItem(int) - 类 javax.swing.JMenu 中的方法
返回指定位置的 JMenuItem。
getItem() - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法

getItemAt(int) - 类 javax.swing.JComboBox 中的方法
返回指定索引处的列表项。
getItemCount() - 类 java.awt.Choice 中的方法
返回此 Choice 菜单中项的数量。
getItemCount() - 类 java.awt.List 中的方法
获取列表中的项数。
getItemCount() - 类 java.awt.Menu 中的方法
获取此菜单中的项数。
getItemCount() - 类 javax.swing.JComboBox 中的方法
返回列表中的项数。
getItemCount() - 类 javax.swing.JMenu 中的方法
返回菜单上的项数，包括分隔符。
getItemListeners() - 类 java.awt.Checkbox 中的方法
返回已在此复选框上注册的所有项侦听器所组成的数组。
getItemListeners() - 类 java.awt.CheckboxMenuItem 中的方法
返回在此复选框菜单项上注册的所有项侦听器组成的数组。
getItemListeners() - 类 java.awt.Choice 中的方法
返回已在此选择上注册的所有项侦听器组成的数组。
getItemListeners() - 类 java.awt.List 中的方法
返回已在此列表上注册的所有项侦听器的数组。
getItemListeners() - 类 javax.swing.AbstractButton 中的方法
返回使用 addItemListener() 添加到此 AbstractButton 中的所有 ItemListener 组成的数组。
getItemListeners() - 类 javax.swing.DefaultButtonModel 中的方法
返回此 DefaultButtonModel 上所有已注册的项侦听器组成的数组。
getItemListeners() - 类 javax.swing.JComboBox 中的方法
返回使用 addItemListener() 添加到此 JComboBox 中的所有 ItemListener 组成的数组。
getItems() - 类 java.awt.List 中的方法
获取列表中的项。
getItemSelectable() - 类 java.awt.event.ItemEvent 中的方法
返回事件的产生程序。
getIterationCount() - 接口 javax.crypto.interfaces.PBEKey 中的方法
返回迭代计数；如果未指定，则返回 0。
getIterationCount() - 类 javax.crypto.spec.PBEKeySpec 中的方法
返回迭代计数，如果未指定则返回 0。
getIterationCount() - 类 javax.crypto.spec.PBEParameterSpec 中的方法
返回迭代计数。
getIterator() - 类 java.text.AttributedString 中的方法
创建一个 AttributedCharacterIterator 实例，提供对整个字符串内容的访问。
getIterator(AttributedCharacterIterator.Attribute[]) - 类 java.text.AttributedString 中的方法
创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
getIterator(AttributedCharacterIterator.Attribute[], int, int) - 类 java.text.AttributedString 中的方法
创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
getIterator(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument 中的方法
获取指定 HTML 标记的迭代器。
getIV() - 类 javax.crypto.Cipher 中的方法
返回新缓冲区中的初始化向量 (IV)。
getIV() - 类 javax.crypto.spec.IvParameterSpec 中的方法
返回初始化向量 (IV)。
getIV() - 类 javax.crypto.spec.RC2ParameterSpec 中的方法
返回 IV，如果此参数集没有包含 IV 则返回 null。
getIV() - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
返回 IV，如果此参数集没有包含 IV 则返回 null。
getJarEntry() - 类 java.net.JarURLConnection 中的方法
返回此连接的 JAR 条目对象（如果有）。
getJarEntry(String) - 类 java.util.jar.JarFile 中的方法
返回给定条目名称的 JarEntry；如果未找到，则返回 null。
getJarFile() - 类 java.net.JarURLConnection 中的方法
返回此连接的 JAR 文件。
getJarFiles() - 类 javax.management.loading.MLetContent 中的方法
获取由 MLET 标记的 ARCHIVE 属性指定的 .jar 文件的列表。
getJarFileURL() - 类 java.net.JarURLConnection 中的方法
返回此连接的 Jar 文件的 URL。
getJavaEncoding(String) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
从 IANA 名称获取相应的 Java 编码名称。
getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind) - 类 javax.tools.ForwardingJavaFileManager 中的方法

getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind) - 接口 javax.tools.JavaFileManager 中的方法
获取输入的文件对象，它表示给定位置处指定类型的指定类。
getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject) - 类 javax.tools.ForwardingJavaFileManager 中的方法

getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject) - 接口 javax.tools.JavaFileManager 中的方法
获取输出的文件对象，它表示给定位置处指定类型的指定类。
getJavaFileObjects(File...) - 接口 javax.tools.StandardJavaFileManager 中的方法
获取表示给定文件的文件对象。
getJavaFileObjects(String...) - 接口 javax.tools.StandardJavaFileManager 中的方法
获取表示给定文件名称的文件对象。
getJavaFileObjectsFromFiles(Iterable<? extends File>) - 接口 javax.tools.StandardJavaFileManager 中的方法
获取表示给定文件的文件对象。
getJavaFileObjectsFromStrings(Iterable<String>) - 接口 javax.tools.StandardJavaFileManager 中的方法
获取表示给定文件名称的文件对象。
getJavaInitializationString() - 接口 java.beans.PropertyEditor 中的方法
返回一部分 Java 代码，可以使用这部分代码来设置某个属性，以匹配编辑器当前状态。
getJavaInitializationString() - 类 java.beans.PropertyEditorSupport 中的方法
生成 Java 代码来设置属性值时使用此方法。
getJAXBNode(XmlNode) - 类 javax.xml.bind.Binder 中的方法
获取与给定 XML 元素关联的 JAXB 对象。
getJDBCMajorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此驱动程序的主 JDBC 版本号。
getJDBCMinorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此驱动程序的次 JDBC 版本号。
getJMenuBar() - 类 javax.swing.JApplet 中的方法
返回此 applet 上的菜单栏设置。
getJMenuBar() - 类 javax.swing.JDialog 中的方法
返回此对话框上设置的菜单栏。
getJMenuBar() - 类 javax.swing.JFrame 中的方法
返回此窗体上设置的菜单栏。
getJMenuBar() - 类 javax.swing.JInternalFrame 中的方法
返回此 JInternalFrame 的当前 JMenuBar；如果尚未设置菜单栏，则返回 null。
getJMenuBar() - 类 javax.swing.JRootPane 中的方法
返回窗格层的菜单栏。
getJobName() - 类 java.awt.print.PrinterJob 中的方法
获取要打印的文档名称。
getJoinType() - 接口 javax.sql.rowset.JoinRowSet 中的方法
返回一个 int 值，它描述控制此 JoinRowSet 实例的已设置 SQL JOIN 类型。
getJustificationInfo() - 类 java.awt.font.GraphicAttribute 中的方法
返回此 GraphicAttribute 的调整信息。
getJustifiedLayout(float) - 类 java.awt.font.TextLayout 中的方法
创建调整到指定宽度的此 TextLayout 的一个副本。
getKeepAlive() - 类 java.net.Socket 中的方法
测试是否启用 SO_KEEPALIVE。
getKeepAliveTime(TimeUnit) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回线程保持活动的时间，该时间就是超过核心池大小的线程可以在终止前保持空闲的时间值。
getKernel() - 类 java.awt.image.ConvolveOp 中的方法
返回 Kernel。
getKernelData(float[]) - 类 java.awt.image.Kernel 中的方法
以行优先顺序返回 kernel 数据。
getKey() - 类 java.awt.MenuShortcut 中的方法
返回此菜单快捷方式的原键代码。
getKey(String, char[]) - 类 java.security.KeyStore 中的方法
返回与给定别名关联的密钥，并用给定密码来恢复它。
getKey() - 类 java.util.AbstractMap.SimpleEntry 中的方法
返回对应于此项的键。
getKey() - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
返回对应于此项的键。
getKey() - 接口 java.util.Map.Entry 中的方法
返回与此项对应的键。
getKey() - 异常 java.util.MissingResourceException 中的方法
获得构造方法所传递的参数。
getKey() - 类 java.util.prefs.PreferenceChangeEvent 中的方法
返回已更改首选项的键。
getKey() - 类 javax.accessibility.AccessibleRelation 中的方法
返回此关系的键
getKey() - 类 javax.crypto.spec.DESedeKeySpec 中的方法
返回 DES-EDE 密钥。
getKey() - 类 javax.crypto.spec.DESKeySpec 中的方法
返回 DES 密钥内容。
getKey() - 接口 javax.xml.crypto.KeySelectorResult 中的方法
返回选定的密钥。
getKeyChar() - 类 java.awt.AWTKeyStroke 中的方法
返回此 AWTKeyStroke 的字符。
getKeyChar() - 类 java.awt.event.KeyEvent 中的方法
返回与此事件中的键关联的字符。
getKeyCode() - 类 java.awt.AWTKeyStroke 中的方法
返回此 AWTKeyStroke 的数字键代码。
getKeyCode() - 类 java.awt.event.KeyEvent 中的方法
返回与此事件中的键关联的整数 keyCode。
getKeyColumns() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回一个包含一个或多个列号的数组，这些列号指示了形成某个键的列，该键唯一地标识了此 CachedRowSet 对象中的某个行。
getKeyEventDispatchers() - 类 java.awt.KeyboardFocusManager 中的方法
作为 List 返回此 KeyboardFocusManager 的 KeyEventDispatcher 链。
getKeyEventPostProcessors() - 类 java.awt.KeyboardFocusManager 中的方法
作为 List 返回此 KeyboardFocusManager 的 KeyEventPostProcessor 链。
getKeyEventType() - 类 java.awt.AWTKeyStroke 中的方法
返回 KeyEvent 的类型，它对应于此 AWTKeyStroke。
getKeyId() - 接口 javax.xml.crypto.dsig.keyinfo.PGPData 中的方法
返回此 PGPData 的 PGP 公钥标识符，正如第 11.2 节的 RFC 2440 中所定义的。
getKeyInfo() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
返回此 XMLSignature 的密钥信息。
getKeyInfoFactory() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
返回创建 KeyInfo 对象的 KeyInfoFactory。
getKeyLength() - 类 javax.crypto.spec.PBEKeySpec 中的方法
返回要导出的密钥长度，如果未指定则返回 0。
getKeyListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.getKeyListener() 的实现。
getKeyListener() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
返回将添加到组合框的键侦听器或 null。
getKeyListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的按键侦听器的数组。
getKeyLocation() - 类 java.awt.event.KeyEvent 中的方法
返回产生此按键事件的键位置。
getKeyManagers() - 类 javax.net.ssl.KeyManagerFactory 中的方法
为每类密钥内容返回一个密钥管理器。
getKeymap() - 类 javax.swing.text.JTextComponent 中的方法
获取当前在此文本组件中活动的 keymap。
getKeymap(String) - 类 javax.swing.text.JTextComponent 中的静态方法
获取以前添加到文档中的已命名 keymap。
getKeymapName() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取默认情况下为此 UI 安装或用于此 UI 的 keymap 的名称。
getKeyModifiersText(int) - 类 java.awt.event.KeyEvent 中的静态方法
返回描述修改键的 String，如 "Shift" 或 "Ctrl+Shift"。
getKeyPacket() - 接口 javax.xml.crypto.dsig.keyinfo.PGPData 中的方法
返回此 PGPData 的 PGP 密钥材料包，正如第 5.5 节的 RFC 2440 中所定义的。
getKeyProperty(String) - 类 javax.management.ObjectName 中的方法
获得与键属性中某个键相关联的值。
getKeyPropertyList() - 类 javax.management.ObjectName 中的方法
以哈希表的形式返回键属性。
getKeyPropertyListString() - 类 javax.management.ObjectName 中的方法
返回创建时指定的键属性列表的字符串表示形式。
getKeys() - 类 java.util.ListResourceBundle 中的方法
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。
getKeys() - 类 java.util.PropertyResourceBundle 中的方法
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。
getKeys() - 类 java.util.ResourceBundle 中的方法
返回键的枚举。
getKeys() - 类 javax.swing.AbstractAction 中的方法
返回 Object 的数组，这些对象是一些已经为其设置此 AbstractAction 值的键，如果没有已经设置该值的键，则返回 null。
getKeySelectionManager() - 类 javax.swing.JComboBox 中的方法
返回列表的键选择管理器。
getKeySelector() - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法

getKeySelector() - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回用于查找某个密钥的密钥选择器。
getKeySelectorResult() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
在对此 XMLSignature 进行签名或验证后，返回密钥选择器 KeySelector（如果已指定）的结果。
getKeysize() - 类 java.security.spec.RSAKeyGenParameterSpec 中的方法
返回密钥大小。
getKeySpec(Key, Class<T>) - 类 java.security.KeyFactory 中的方法
返回给定密钥对象的规范（密钥材料）。
getKeySpec(Cipher) - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
getKeySpec(Key) - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
getKeySpec(Key, String) - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
getKeySpec(Key, Provider) - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
getKeySpec(SecretKey, Class) - 类 javax.crypto.SecretKeyFactory 中的方法
以请求的格式返回给定密钥对象的规范（密钥材料）。
getKeyStore() - 类 java.security.KeyStore.Builder 中的方法
返回此对象描述的 KeyStore。
getKeyStroke(char) - 类 javax.swing.KeyStroke 中的静态方法
返回 KeyStroke 的共享实例，前者表示指定字符的 KEY_TYPED 事件。
getKeyStroke(char, boolean) - 类 javax.swing.KeyStroke 中的静态方法
已过时。 使用 getKeyStroke(char)
getKeyStroke(Character, int) - 类 javax.swing.KeyStroke 中的静态方法
返回 KeyStroke 的一个共享实例，它表示指定 Character 对象和一组修饰符的 KEY_TYPED 事件。
getKeyStroke(int, int, boolean) - 类 javax.swing.KeyStroke 中的静态方法
在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例，指定该键在按下或释放时是否为已激活。
getKeyStroke(int, int) - 类 javax.swing.KeyStroke 中的静态方法
在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例。
getKeyStroke(String) - 类 javax.swing.KeyStroke 中的静态方法
分析字符串并返回 KeyStroke。
getKeyStrokeForEvent(KeyEvent) - 类 javax.swing.KeyStroke 中的静态方法
返回一个 KeyStroke，它表示生成给定 KeyEvent 的快捷键事件。
getKeyStrokesForAction(Action) - 接口 javax.swing.text.Keymap 中的方法
获取将导致给定操作的击键。
getKeyText(int) - 类 java.awt.event.KeyEvent 中的静态方法
返回描述 keyCode 的 String，如 "HOME"、"F1" 或 "A"。
getKeyType() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回此长期密钥的密钥类型。
getKeyUsage() - 类 java.security.cert.X509Certificate 中的方法
获取一个表示 KeyUsage 扩展 (OID = 2.5.29.15) 的各个位的 boolean 数组。
getKeyUsage() - 类 java.security.cert.X509CertSelector 中的方法
返回 keyUsage 标准。
getKind() - 接口 javax.lang.model.element.Element 中的方法
返回此元素的类型。
getKind() - 接口 javax.lang.model.type.TypeMirror 中的方法
返回此类型的 kind。
getKind() - 接口 javax.tools.Diagnostic 中的方法
获取此诊断的类型，例如，错误或者警告。
getKind() - 类 javax.tools.ForwardingJavaFileObject 中的方法

getKind() - 接口 javax.tools.JavaFileObject 中的方法
获取此文件对象的种类。
getKind() - 类 javax.tools.SimpleJavaFileObject 中的方法

getL() - 类 javax.crypto.spec.DHParameterSpec 中的方法
返回以位为单位的随机指数的大小 l（私有值）。
getLabel() - 类 java.awt.Button 中的方法
获取此按钮的标签。
getLabel() - 类 java.awt.Checkbox 中的方法
获取此复选框的标签。
getLabel() - 类 java.awt.MenuItem 中的方法
获取此菜单项的标签。
getLabel() - 类 javax.swing.AbstractButton 中的方法
已过时。 - 由 getText 取代
getLabel() - 类 javax.swing.JPopupMenu 中的方法
返回弹出菜单的标签。
getLabel() - 类 javax.swing.text.html.Option 中的方法
获取与该选项相关的标签。
getLabelFor() - 类 javax.swing.JLabel 中的方法
获取要添加标签的组件。
getLabelTable() - 类 javax.swing.JSlider 中的方法
返回哪些标签在哪些值处绘制的字典。
getLanguage() - 类 java.util.Locale 中的方法
返回此语言环境的语言代码，可以是空字符串或小写的 ISO 639 代码。
getLanguageName() - 接口 javax.script.ScriptEngineFactory 中的方法
返回此 ScriptEngine 支持的脚本语言的名称。
getLanguageVersion() - 接口 javax.script.ScriptEngineFactory 中的方法
返回此 ScriptEngine 支持的脚本语言的版本。
getLargeDisplayIcon() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
返回此面板的大显示图标。
getLargestPoolSize() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回曾经同时位于池中的最大线程数。
getLast() - 类 java.util.ArrayDeque 中的方法

getLast() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法

getLast() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列的最后一个元素。
getLast() - 类 java.util.LinkedList 中的方法
返回此列表的最后一个元素。
getLastAccessedTime() - 接口 javax.net.ssl.SSLSession 中的方法
返回此会话表示上一次被会话层应用访问的时间，该时间是自协调世界时 1970 年 1 月 1 日午夜起经过的毫秒数。
getLastChild() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回此节点的最后一个子节点；如果该节点没有子节点，则返回 null。
getLastChild() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的最后一个子节点。
getLastChild() - 接口 org.w3c.dom.Node 中的方法
此节点的最后一个节点。
getLastChildPath(TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回到 parent 的最后一个子节点的路径。
getLastColumn() - 接口 javax.accessibility.AccessibleTableModelChange 中的方法
返回已更改的最后一列。
getLastColumn() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的方法

getLastComponent(Container) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回遍历循环中的最后一个 Component。
getLastComponent(Container) - 类 java.awt.FocusTraversalPolicy 中的方法
返回遍历循环中的最后一个 Component。
getLastComponent(Container) - 类 javax.swing.DefaultFocusManager 中的方法

getLastComponent(Container) - 类 javax.swing.LayoutFocusTraversalPolicy 中的方法
返回遍历循环中的最后一个 Component。
getLastComponent(Container) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回遍历循环中的最后一个 Component。
getLastCursor() - 类 javax.swing.JInternalFrame 中的方法
返回通过 setCursor 方法设置的最后一个 Cursor，它是不可调整大小的 Cursor。
getLastDividerLocation() - 类 javax.swing.JSplitPane 中的方法
返回分隔条所处的最后位置。
getLastDragLocation() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回 JSplitPane 的最后拖动位置。
getLastIndex() - 类 javax.swing.event.ListSelectionEvent 中的方法
返回最后一个选择状态可能已发生更改的行的索引。
getLastLeaf() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
查找并返回为此节点后代的最后一个叶节点，即此节点或其最后一个子节点的最后一个叶节点。
getLastModified() - 类 java.net.URLConnection 中的方法
返回 last-modified 头字段的值。
getLastModified() - 接口 javax.tools.FileObject 中的方法
获取最后一次修改此文件对象的时间。
getLastModified() - 类 javax.tools.ForwardingFileObject 中的方法

getLastModified() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现返回 0L。
getLastPathComponent() - 类 javax.swing.tree.TreePath 中的方法
返回此路径的最后一个组件。
getLastRow() - 接口 javax.accessibility.AccessibleTableModelChange 中的方法
返回已更改的最后一行。
getLastRow() - 类 javax.swing.event.TableModelEvent 中的方法
返回最后一个被更改的行。
getLastRow() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的方法

getLastSelectedPathComponent() - 类 javax.swing.JTree 中的方法
返回当前选择的第一个节点中的最后一个路径组件。
getLastVisibleIndex() - 类 javax.swing.JList 中的方法
返回当前可见的最大列表索引。
getLatency() - 接口 javax.sound.midi.Synthesizer 中的方法
获得此合成器导致的处理延迟，用微秒表示。
getLateReflectionDelay() - 类 javax.sound.sampled.ReverbType 中的方法
返回晚期反射延迟时间，以微秒为单位。
getLateReflectionIntensity() - 类 javax.sound.sampled.ReverbType 中的方法
返回晚期反射密度，以分贝为单位。
getLayer() - 类 javax.swing.JInternalFrame 中的方法
获得此组件 layer 属性的便捷方法。
getLayer(JComponent) - 类 javax.swing.JLayeredPane 中的静态方法
获得 JComponent 的 layer 属性，此方法不会产生与 setLayer() 类似的副作用（绘制、添加/移除等）。
getLayer(Component) - 类 javax.swing.JLayeredPane 中的方法
返回指定 Component 的 layer 属性。
getLayeredPane() - 类 javax.swing.JApplet 中的方法
返回此 applet 的 layeredPane 对象。
getLayeredPane() - 类 javax.swing.JDialog 中的方法
返回此对话框的 layeredPane 对象。
getLayeredPane() - 类 javax.swing.JFrame 中的方法
返回此窗体的 layeredPane 对象。
getLayeredPane() - 类 javax.swing.JInternalFrame 中的方法
返回此内部窗体的分层窗格。
getLayeredPane() - 类 javax.swing.JRootPane 中的方法
获取供根窗格使用的分层窗格。
getLayeredPane() - 类 javax.swing.JWindow 中的方法
返回此窗口的 layeredPane 对象。
getLayeredPane() - 接口 javax.swing.RootPaneContainer 中的方法
返回 layeredPane。
getLayeredPaneAbove(Component) - 类 javax.swing.JLayeredPane 中的静态方法
一个便捷方法，它返回包含指定组件的第一个 JLayeredPane。
getLayout() - 类 java.awt.Container 中的方法
获取此容器的布局管理器。
getLayout(int, int) - 类 java.awt.font.TextMeasurer 中的方法
返回给定字符范围上的 TextLayout。
getLayoutAlignmentX(Container) - 类 java.awt.BorderLayout 中的方法
返回沿 x 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 java.awt.CardLayout 中的方法
返回沿 x 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 java.awt.GridBagLayout 中的方法
返回沿 X 轴的对齐方式。
getLayoutAlignmentX(Container) - 接口 java.awt.LayoutManager2 中的方法
返回沿 X 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 javax.swing.BoxLayout 中的方法
返回容器沿 X 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 javax.swing.GroupLayout 中的方法
返回沿 x 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法

getLayoutAlignmentX(Container) - 类 javax.swing.OverlayLayout 中的方法
返回容器沿 X 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回容器沿 X 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 javax.swing.SpringLayout 中的方法
返回 0.5f（居中）。
getLayoutAlignmentY(Container) - 类 java.awt.BorderLayout 中的方法
返回沿 y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 java.awt.CardLayout 中的方法
返回沿 y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 java.awt.GridBagLayout 中的方法
返回沿 y 轴的对齐方式。
getLayoutAlignmentY(Container) - 接口 java.awt.LayoutManager2 中的方法
返回沿 Y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 javax.swing.BoxLayout 中的方法
返回容器沿 Y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 javax.swing.GroupLayout 中的方法
返回沿 y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法

getLayoutAlignmentY(Container) - 类 javax.swing.OverlayLayout 中的方法
返回容器沿 Y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回容器沿 Y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 javax.swing.SpringLayout 中的方法
返回 0.5f（居中）。
getLayoutComponent(Object) - 类 java.awt.BorderLayout 中的方法
获取使用给定约束添加的组件。
getLayoutComponent(Container, Object) - 类 java.awt.BorderLayout 中的方法
基于目标 Container 的组件方向，返回给定约束位置对应的组件。
getLayoutDimensions() - 类 java.awt.GridBagLayout 中的方法
确定布局网格的列宽度和行高度。
getLayoutFlags() - 类 java.awt.font.GlyphVector 中的方法
返回描述该 GlyphVector 全局状态的标志。
getLayoutInfo(Container, int) - 类 java.awt.GridBagLayout 中的方法
为当前受管子级的集合填充 GridBagLayoutInfo 的实例。
GetLayoutInfo(Container, int) - 类 java.awt.GridBagLayout 中的方法
此方法已过时，仅为提供向后兼容性；新代码应该调用 getLayoutInfo 来代替。
getLayoutOrientation() - 类 javax.swing.JList 中的方法
返回列表的布局方向属性：如果布局是单列单元，则返回 VERTICAL；如果布局是“报纸样式”并且内容按先垂直后水平排列， 则返回 VERTICAL_WRAP；如果布局是“报纸样式”并且内容按先水平后垂直排列，则返回 HORIZONTAL_WRAP。
getLayoutOrigin() - 类 java.awt.GridBagLayout 中的方法
在目标容器的图形坐标空间确定布局区域的原点。
getLayoutPath() - 类 java.awt.font.TextLayout 中的方法
返回 LayoutPath，如果布局路径是默认路径（x 映射到 advance，y 映射到 offset），则返回 null。
getLayoutQueue() - 类 javax.swing.text.AsyncBoxView 中的方法
获取用于布局处理的队列。
getLayoutStyle() - 类 javax.swing.GroupLayout 中的方法
返回 LayoutStyle，用于计算组件之间的首选间隙。
getLayoutStyle() - 类 javax.swing.LookAndFeel 中的方法
返回此外观的 LayoutStyle。
getLayoutStyle() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回一个 LayoutStyle，它实现 http://java.sun.com/products/jlf/ed2/book/HIG.Visual2.html 中指定的 Java 外观设计原则。
getLayoutView(int) - 类 javax.swing.text.ParagraphView 中的方法
返回给定 index 处的视图。
getLayoutViewCount() - 类 javax.swing.text.ParagraphView 中的方法
返回此视图负责的视图数。
getLayoutWeights() - 类 java.awt.GridBagLayout 中的方法
确定布局网格的行与列的权重。
getLeader() - 类 javax.swing.text.TabStop 中的方法
返回制表符的前导字符。
getLeading() - 类 java.awt.font.LineMetrics 中的方法
返回该文本的 leading。
getLeading() - 类 java.awt.font.TextLayout 中的方法
返回 TextLayout 的行距。
getLeading() - 类 java.awt.FontMetrics 中的方法
确定此 FontMetrics 对象所描述的 Font 的标准行间距。
getLeadSelectionIndex() - 类 javax.swing.DefaultListSelectionModel 中的方法
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第二个索引参数。
getLeadSelectionIndex() - 类 javax.swing.JList 中的方法
返回前导选择索引。
getLeadSelectionIndex() - 接口 javax.swing.ListSelectionModel 中的方法
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第二个索引参数。
getLeadSelectionPath() - 类 javax.swing.JTree 中的方法
返回标识为前导的路径。
getLeadSelectionPath() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回添加的最后一条路径。
getLeadSelectionPath() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回添加的最后一个路径。
getLeadSelectionRow() - 类 javax.swing.JTree 中的方法
返回与前导路径对应的行索引。
getLeadSelectionRow() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回 lead selection 索引。
getLeadSelectionRow() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回前导选择索引。
getLeafCount() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回为此节点后代的叶节点总数。
getLeafIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回用于表示叶节点的图标。
getLeastMaximum(int) - 类 java.util.Calendar 中的方法
返回此 Calendar 实例给定日历字段的最低的最大值。
getLeastMaximum(int) - 类 java.util.GregorianCalendar 中的方法
返回此 GregorianCalendar 实例给定日历字段的最低的最大值。
getLeastSignificantBits() - 类 java.util.UUID 中的方法
返回此 UUID 的 128 位值中的最低有效 64 位。
getLeftChildIndent() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getLeftComponent() - 类 javax.swing.JSplitPane 中的方法
返回分隔条左边（或者上面）的组件。
getLeftIndent(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取左边缩进设置。
getLeftInset() - 类 javax.swing.text.AsyncBoxView 中的方法
获得视图四周左侧的空白部分。
getLeftInset() - 类 javax.swing.text.CompositeView 中的方法
获取左部 inset。
getLegalValues() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的合法值的不可修改的 Set（如果已指定），否则返回 null。
getLegalValues() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此参数的合法值的集合（如果存在），否则返回 null。
getLegalValues() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例描述的合法参数值的不可修改的 Set（如果指定），否则返回 null。
getLength(Object) - 类 java.lang.reflect.Array 中的静态方法
以 int 形式返回指定数组对象的长度。
getLength() - 类 java.net.DatagramPacket 中的方法
返回将要发送或接收到的数据的长度。
getLength() - 类 java.text.Bidi 中的方法
返回该行中文本的长度。
getLength() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getLength() - 类 javax.imageio.stream.IIOByteBuffer 中的方法
返回 getData 返回的字节数组中感兴趣的数据长度。
getLength() - 类 javax.sound.midi.MidiMessage 中的方法
获得 MIDI 消息的总长度，以字节为单位。
getLength() - 接口 javax.swing.event.DocumentEvent 中的方法
返回更改的长度。
getLength() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
返回更改的长度。
getLength() - 类 javax.swing.text.AbstractDocument 中的方法
返回数据的长度。
getLength() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得长度。
getLength() - 接口 javax.swing.text.Document 中的方法
返回文档中当前内容的字符数。
getLength() - 接口 org.w3c.dom.CharacterData 中的方法
通过下面的 data 和 substringData 方法可使用的 16 位单元数。
getLength() - 接口 org.w3c.dom.DOMImplementationList 中的方法
列表中 DOMImplementation 的数目。
getLength() - 接口 org.w3c.dom.DOMStringList 中的方法
列表中 DOMString 的数目。
getLength() - 接口 org.w3c.dom.NamedNodeMap 中的方法
此映射中的节点数。
getLength() - 接口 org.w3c.dom.NameList 中的方法
列表中的对（名称和名称空间 URI）数。
getLength() - 接口 org.w3c.dom.NodeList 中的方法
列表中的节点数。
getLength() - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回此列表中属性的个数。
getLength() - 接口 org.xml.sax.Attributes 中的方法
返回此列表中的属性个数。
getLength() - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 返回列表中的属性个数。
getLength() - 类 org.xml.sax.helpers.AttributesImpl 中的方法
返回列表中的属性个数。
getLengths() - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的方法
返回 short 数组，该数组包含 Huffman 表每个长度的值数。
getLevel() - 类 java.util.logging.Handler 中的方法
获得用于指定该 Handler 所记录信息的日志级别。
getLevel() - 类 java.util.logging.Logger 中的方法
获取已为此 Logger 指定的日志级别（Level）。
getLevel() - 类 java.util.logging.LogRecord 中的方法
获取日志消息级别，例如 Level.SEVERE。
getLevel() - 接口 javax.sound.sampled.DataLine 中的方法
获得行的当前音量级别。
getLevel() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点上的级数 -- 从根到此节点的距离。
getLevelAt(int) - 类 java.text.Bidi 中的方法
返回偏移位置处的字符的解析层次。
getLexicalHandler() - 类 javax.xml.transform.sax.SAXResult 中的方法
获取输出的 SAX2 LexicalHandler。
getLibraryDirectory() - 类 javax.management.loading.MLet 中的方法
获取库加载器在将本机库加载到内存中之前用于存储这些本机库的当前目录。
getLibraryDirectory() - 接口 javax.management.loading.MLetMBean 中的方法
获取在将本机库加载到内存中之前库加载器用来存储这些本机库的当前目录。
getLibraryPath() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 库路径。
getLifetime() - 接口 org.ietf.jgss.GSSContext 中的方法
确定此上下文剩余的生存期是多长。
getLimit() - 类 javax.swing.undo.UndoManager 中的方法
返回此 UndoManager 保持的最大编辑数。
getLimits() - 类 java.text.ChoiceFormat 中的方法
获取传入构造方法的 limit。
getLine(Line.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得与指定 Line.Info 对象中的描述匹配的行。
getLine() - 类 javax.sound.sampled.LineEvent 中的方法
获得作为此事件的源的音频行。
getLine(Line.Info) - 接口 javax.sound.sampled.Mixer 中的方法
获得可供使用并且与指定 Line.Info 对象中的描述匹配的行。
getLineBreakIndex(int, float) - 类 java.awt.font.TextMeasurer 中的方法
返回不能置于文本行上的第一个字符，该文本行从 start 开始并可能测量到图形宽度的 maxAdvance。
getLineBuffer() - 类 javax.swing.text.PlainView 中的方法
提供对可用于从相关文档获取文本的缓冲区的访问。
getLineBuffer() - 类 javax.swing.text.WrappedPlainView 中的方法
提供对能用于从关联文档获取文本的缓冲区的访问。
getLineClass() - 类 javax.sound.sampled.Line.Info 中的方法
获得此 Line.Info 对象所描述的行的类。
getLineColor() - 类 javax.swing.border.LineBorder 中的方法
返回边框的颜色。
getLineCount() - 类 javax.swing.JTextArea 中的方法
确定文本区中所包含的行数。
getLineEndOffset(int) - 类 javax.swing.JTextArea 中的方法
确定给定行结尾处的偏移量。
getLineIncrement() - 类 java.awt.Scrollbar 中的方法
已过时。 从 JDK version 1.1 开始，由 getUnitIncrement() 取代。
getLineInfo() - 接口 javax.sound.sampled.Line 中的方法
获得描述此行的 Line.Info 对象。
getLineInstance() - 类 java.text.BreakIterator 中的静态方法
返回一个用于默认语言环境 行分解的新 BreakIterator 实例。
getLineInstance(Locale) - 类 java.text.BreakIterator 中的静态方法
返回一个用于给定语言环境行分解的新 BreakIterator 实例。
getLineInstance(Locale) - 类 java.text.spi.BreakIteratorProvider 中的方法
为给定语言环境的行分解返回新的 BreakIterator 实例。
getLineJoin() - 类 java.awt.BasicStroke 中的方法
返回线条连接样式。
getLineLength() - 类 javax.swing.text.AbstractWriter 中的方法
返回最大行长度。
getLineMetrics(String, FontRenderContext) - 类 java.awt.Font 中的方法
返回一个使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。
getLineMetrics(String, int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回使用指定参数创建的 LineMetrics 对象。
getLineMetrics(char[], int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回使用指定参数创建的 LineMetrics 对象。
getLineMetrics(CharacterIterator, int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回使用指定参数创建的 LineMetrics 对象。
getLineMetrics(String, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
getLineMetrics(String, int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
getLineMetrics(char[], int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定字符数组的 LineMetrics 对象。
getLineMetrics(CharacterIterator, int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定 CharacterIterator 的 LineMetrics 对象。
getLineNumber() - 类 java.io.LineNumberInputStream 中的方法
已过时。 返回当前行号。
getLineNumber() - 类 java.io.LineNumberReader 中的方法
获得当前行号。
getLineNumber() - 类 java.lang.StackTraceElement 中的方法
返回源行的行号，该行包含由该堆栈该跟踪元素所表示的执行点。
getLineNumber() - 异常 javax.script.ScriptException 中的方法
获取发生错误的行号。
getLineNumber() - 接口 javax.tools.Diagnostic 中的方法
返回由 Diagnostic.getPosition() 返回的字符偏移量的行号。
getLineNumber() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getLineNumber() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回行号（如果可用）。
getLineNumber() - 接口 javax.xml.stream.Location 中的方法
返回当前事件结束位置的行号，如果没有可用的行号，则返回 -1。
getLineNumber() - 接口 javax.xml.transform.SourceLocator 中的方法
返回当前文档事件结束位置的行数。
getLineNumber() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的行号；如果没有可用的行号，则为 -1。
getLineNumber() - 类 org.xml.sax.helpers.LocatorImpl 中的方法
返回保存的行数（从 1 开始）。
getLineNumber() - 接口 org.xml.sax.Locator 中的方法
返回当前文档事件结束处的行号。
getLineNumber() - 异常 org.xml.sax.SAXParseException 中的方法
发生异常的文本结尾的行号。
getLineOfOffset(int) - 类 javax.swing.JTextArea 中的方法
将组件文本中的偏移量转换为行号。
getLineSeparator() - 类 javax.swing.text.AbstractWriter 中的方法
返回用于表示换行的 String。
getLineSpacing(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取行间距设置。
getLineStartOffset(int) - 类 javax.swing.JTextArea 中的方法
确定给定行起始处的偏移量。
getLineWidth() - 类 java.awt.BasicStroke 中的方法
返回线条的宽度。
getLineWrap() - 类 javax.swing.JTextArea 中的方法
获取文本区的换行策略。
getLink(int) - 接口 javax.accessibility.AccessibleHypertext 中的方法
返回此 Hypertext 文档中第 n 个链接。
getLink(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 中的方法
返回超链接数组中该索引处的链接。
getLinkCount() - 接口 javax.accessibility.AccessibleHypertext 中的方法
返回此超文本文档中的链接数。
getLinkCount() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 中的方法
返回此超文本文档中的链接数。
getLinkCursor() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
返回要在超链接上使用的光标。
getLinkedException() - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法

getLinkedException() - 异常 javax.xml.bind.JAXBException 中的方法
获取链接的异常。
getLinkedException() - 异常 javax.xml.bind.TypeConstraintException 中的方法
获取链接的异常。
getLinkedException() - 接口 javax.xml.bind.ValidationEvent 中的方法
检索此警告/错误的链接异常。
getLinkExplanation() - 异常 javax.naming.LinkException 中的方法
检索与解析某一链接时遇到的问题关联的解释。
getLinkIndex(int) - 接口 javax.accessibility.AccessibleHypertext 中的方法
返回超链接数组中与此字符索引关联的索引；如果没有与此索引关联的超链接，则返回 -1。
getLinkIndex(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 中的方法
返回超链接数组中与此字符索引关联的超链接索引；如果没有与此索引关联的超链接，则返回 -1。
getLinkName() - 类 javax.naming.LinkRef 中的方法
检索此链接的名称。
getLinkRemainingName() - 异常 javax.naming.LinkException 中的方法
检索链接名称的剩余未解析部分。
getLinkResolvedName() - 异常 javax.naming.LinkException 中的方法
检索成功被解析的链接名称的开头部分。
getLinkResolvedObj() - 异常 javax.naming.LinkException 中的方法
检索已成功解析成的对象。
getLinkText(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 中的方法
返回文档中与此超链接关联的连续文本。
getList() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.getList() 的实现。
getList() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
返回要用于在组合框中绘制项的列表。
getList() - 类 javax.swing.SpinnerListModel 中的方法
返回定义此模型的序列的 List。
getListCellRendererComponent(JList, Object, int, boolean, boolean) - 类 javax.swing.DefaultListCellRenderer 中的方法

getListCellRendererComponent(JList, Object, int, boolean, boolean) - 接口 javax.swing.ListCellRenderer 中的方法
返回已配置用于显示指定值的组件。
getListCellRendererComponent(JList, Object, int, boolean, boolean) - 类 javax.swing.plaf.basic.BasicComboBoxRenderer 中的方法

getListCellRendererComponent(JList, Object, int, boolean, boolean) - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer 中的方法

getListDataListeners() - 类 javax.swing.AbstractListModel 中的方法
返回已在此 AbstractListModel 上注册的所有列表数据侦听器组成的数组。
getListener() - 类 java.util.EventListenerProxy 中的方法

getListener() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法

getListener() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法

getListener() - 接口 javax.xml.bind.Marshaller 中的方法
返回向此 Marshaller 注册的 Marshaller.Listener。
getListener() - 接口 javax.xml.bind.Unmarshaller 中的方法
返回向此 Unmarshaller 注册的 Unmarshaller.Listener。
getListenerCount() - 类 javax.swing.event.EventListenerList 中的方法
返回此侦听器列表中侦听器的总数。
getListenerCount(Class<?>) - 类 javax.swing.event.EventListenerList 中的方法
返回此侦听器列表中所提供类型的侦听器的总数。
getListenerID() - 类 javax.management.remote.TargetedNotification 中的方法
此通知所定向的侦听器的 ID。
getListenerList() - 类 javax.swing.event.EventListenerList 中的方法
将事件侦听器列表以 ListenerType 侦听器对数组的形式传回。
getListenerMethodDescriptors() - 类 java.beans.EventSetDescriptor 中的方法
获得目标侦听器接口的 MethodDescriptor。
getListenerMethodName() - 类 java.beans.EventHandler 中的方法
返回将触发动作的属性名称。
getListenerMethods() - 类 java.beans.EventSetDescriptor 中的方法
获得目标侦听器接口的方法。
getListeners(EventListener, Class<T>) - 类 java.awt.AWTEventMulticaster 中的静态方法
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.Button 中的方法
返回当前在此 Button 上注册为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.Checkbox 中的方法
返回目前已在此 Checkbox 上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 java.awt.CheckboxMenuItem 中的方法
返回当前在此 CheckboxMenuItem 上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 java.awt.Choice 中的方法
返回目前已在此 Choice 上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 java.awt.Component 中的方法
返回一个当前在此 Component 上作为 FooListener 注册的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.Container 中的方法
返回当前已在此 Container 上注册为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.dnd.DragSource 中的方法
获得目前已在此 DragSource 上注册为 FooListener 的所有对象。
getListeners(Class<T>) - 类 java.awt.List 中的方法
返回目前已在此 List 上注册为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.MenuItem 中的方法
返回当前在此 MenuItem 上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 java.awt.Scrollbar 中的方法
返回目前已在此 Scrollbar 上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 java.awt.TextComponent 中的方法
返回当前已在此 TextComponent 上注册为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.TextField 中的方法
返回当前已在此 TextField 上注册为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.Window 中的方法
返回当前在此 Window 上注册为 FooListener 的所有对象所组成的数组。
getListeners(Class<T>) - 类 javax.swing.AbstractListModel 中的方法
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.AbstractSpinnerModel 中的方法
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
getListeners(Class<T>) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.DefaultButtonModel 中的方法
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.DefaultListSelectionModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.DefaultSingleSelectionModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.event.EventListenerList 中的方法
返回给定类型的所有侦听器组成的数组。
getListeners(Class<T>) - 类 javax.swing.JComponent 中的方法
返回当前在此 JComponent 上注册为 FooListener 的所有对象所组成的数组。
getListeners(Class<T>) - 类 javax.swing.table.AbstractTableModel 中的方法
返回一个包含当前注册为此 AbstractTableModel 上的 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.text.AbstractDocument 中的方法
返回目前已在此文档上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.text.DefaultCaret 中的方法
返回目前已在此插入符上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
getListeners(Class<T>) - 类 javax.swing.Timer 中的方法
返回目前已在此 Timer 上注册为 FooListener 的所有对象所组成的数组。
getListeners(Class<T>) - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListenerType() - 类 java.beans.EventSetDescriptor 中的方法
获得目标接口的 Class 对象。
getListPainter(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
获取给定 CSS 属性集合使用的列表 formatter。
getListSelectionListeners() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回已在此 DefaultListSelectionModel 上注册的所有列表选择侦听器组成的数组。
getListSelectionListeners() - 类 javax.swing.JList 中的方法
返回通过 addListSelectionListener 添加到此 JList 中的所有 ListSelectionListener 所组成的数组。
getLoadedClassCount() - 接口 java.lang.management.ClassLoadingMXBean 中的方法
返回当前加载到 Java 虚拟机中的类的数量。
getLoadedInstruments() - 接口 javax.sound.midi.Synthesizer 中的方法
获得当前加载到此 Synthesizer 中的乐器列表。
getLoadingImageIcon() - 类 javax.swing.text.html.ImageView 中的方法
返回加载图像过程中要使用的图标。
getLoadsSynchronously() - 类 javax.swing.text.html.ImageView 中的方法
如果图像应该在首次被请求时加载，则返回 true。
getLocalAddress() - 类 java.net.DatagramSocket 中的方法
获取套接字绑定的本地地址。
getLocalAddress() - 类 java.net.Socket 中的方法
获取套接字绑定的本地地址。
getLocalBounds(Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回组件 aComponent 的矩形 (0,0,bounds.width,bounds.height)。
getLocalCertificateChain() - 类 java.net.SecureCacheResponse 中的方法
返回在获得了网络资源的初始连接的联络期间发送到服务器的证书链。
getLocalCertificates() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回握手期间发送到同位体的证书。
getLocalCertificates() - 类 javax.net.ssl.HttpsURLConnection 中的方法
返回握手期间发送给服务器的证书。
getLocalCertificates() - 接口 javax.net.ssl.SSLSession 中的方法
返回握手期间发送给同位体的证书。
getLocale() - 类 java.applet.Applet 中的方法
获取 applet 的语言环境。
getLocale() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回此对象的区域。
getLocale() - 类 java.awt.Component 中的方法
获取组件的语言环境。
getLocale() - 类 java.awt.im.InputContext 中的方法
返回当前输入方法或键盘布局的当前语言环境。
getLocale() - 接口 java.awt.im.spi.InputMethod 中的方法
返回当前的输入语言环境。
getLocale() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取组件的区域设置。
getLocale() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回此对象的区域。
getLocale() - 类 java.awt.Window 中的方法
如果设置了区域，则获取与此窗口关联的 Locale 对象。
getLocale() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得此 BeanContext 的语言环境。
getLocale() - 类 java.text.MessageFormat 中的方法
获取创建或比较子格式时所使用的语言环境。
getLocale() - 类 java.util.ResourceBundle 中的方法
返回此资源包的语言环境。
getLocale() - 类 javax.accessibility.AccessibleContext 中的方法
获取该组件的语言环境。
getLocale() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回当前语言环境；如果没有有效的语言环境，则返回 null。
getLocale() - 类 javax.imageio.ImageReader 中的方法
返回当前设置的 Locale，如果没有设置 Locale，则返回 null。
getLocale() - 类 javax.imageio.ImageWriteParam 中的方法
返回当前设置的 Locale，如果仅支持默认 Locale，则返回 null。
getLocale() - 类 javax.imageio.ImageWriter 中的方法
返回当前设置的 Locale，如果没有设置 Locale，则返回 null。
getLocale() - 类 javax.print.attribute.TextSyntax 中的方法
返回此文本属性的文本字符串的自然语言（语言环境）。
getLocale() - 类 javax.security.auth.callback.LanguageCallback 中的方法
获取检索到的 Locale。
getLocale() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
返回此对象的区域。
getLocale() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getLocale() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取该组件的语言环境。
getLocale() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取组件的区域。
getLocale() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取该组件的语言环境。
getLocale() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getLocalGraphicsEnvironment() - 类 java.awt.GraphicsEnvironment 中的静态方法
返回本地 GraphicsEnvironment。
getLocalHost() - 类 java.net.InetAddress 中的静态方法
返回本地主机。
getLocalizedCompressionTypeName() - 类 javax.imageio.ImageWriteParam 中的方法
返回当前压缩类型的本地化名称，使用 getLocale 返回的 Locale。
getLocalizedInputStream(InputStream) - 类 java.lang.Runtime 中的方法
已过时。 从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。
getLocalizedMessage() - 类 java.lang.Throwable 中的方法
创建此 throwable 的本地化描述。
getLocalizedName() - 类 java.util.logging.Level 中的方法
返回当前默认语言环境的 Level 的本地化字符串名称。
getLocalizedOutputStream(OutputStream) - 类 java.lang.Runtime 中的方法
已过时。 从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。
getLocalName() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 getNodeName。
getLocalName() - 接口 javax.xml.soap.Name 中的方法
获取此 Name 对象表示的 XML 名称的本地名称部分。
getLocalName() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getLocalName() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回当前事件的（本地）名称。
getLocalName() - 接口 org.w3c.dom.Node 中的方法
返回此节点限定名称的本地部分。
getLocalName(int) - 接口 org.xml.sax.Attributes 中的方法
通过索引查找属性的本地名称。
getLocalName(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
返回属性的本地名称。
getLocalPart() - 类 javax.xml.namespace.QName 中的方法
获取此 QName 的本地部分。
getLocalPatternChars() - 类 java.text.DateFormatSymbols 中的方法
获取本地化的日期-时间模式字符。
getLocalPort() - 类 java.net.DatagramSocket 中的方法
返回此套接字绑定的本地主机上的端口号。
getLocalPort() - 类 java.net.DatagramSocketImpl 中的方法
获取本地端口。
getLocalPort() - 类 java.net.ServerSocket 中的方法
返回此套接字在其上侦听的端口。
getLocalPort() - 类 java.net.Socket 中的方法
返回此套接字绑定到的本地端口。
getLocalPort() - 类 java.net.SocketImpl 中的方法
返回此套接字的 localport 字段的值。
getLocalPrincipal() - 类 java.net.SecureCacheResponse 中的方法
返回在获得了网络资源的初始连接中的联络期间发送到服务器的主体。
getLocalPrincipal() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回握手期间发送到同位体的主体。
getLocalPrincipal() - 类 javax.net.ssl.HttpsURLConnection 中的方法
返回握手期间发送到服务器的主体。
getLocalPrincipal() - 接口 javax.net.ssl.SSLSession 中的方法
返回握手期间发送给同位体的主体。
getLocalSocketAddress() - 类 java.net.DatagramSocket 中的方法
返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
getLocalSocketAddress() - 类 java.net.ServerSocket 中的方法
返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
getLocalSocketAddress() - 类 java.net.Socket 中的方法
返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
getLocation() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
通过用一个点指定该对象的左上角在屏幕坐标空间中的位置的形式，获取此对象相对于父对象的位置。
getLocation() - 类 java.awt.Component 中的方法
获取组件的位置，形式是指定组件左上角的一个点。
getLocation(Point) - 类 java.awt.Component 中的方法
将组件的 x，y 原点存储到“返回值” rv 中并返回 rv。
getLocation() - 类 java.awt.dnd.DragSourceEvent 中的方法
此方法返回一个 Point，指示事件发生时光标在屏幕坐标中的位置，如果没有为此事件指定光标位置，则返回 null。
getLocation() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回一个指示 Component 坐标中 Cursor 当前位置的 Point。
getLocation() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回一个 Point，指示 Component 坐标中 Cursor 的当前位置。
getLocation() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
getLocation() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
getLocation() - 类 java.awt.Point 中的方法
返回此点的位置。
getLocation() - 类 java.awt.PointerInfo 中的方法
返回在屏幕上表示指针坐标的 Point。
getLocation() - 类 java.awt.Rectangle 中的方法
返回此 Rectangle 的位置。
getLocation() - 异常 java.net.HttpRetryException 中的方法
如果重定向产生错误，则返回 Location 头字段的值。
getLocation() - 类 java.rmi.activation.ActivationDesc 中的方法
返回此描述符指定的对象的代码基。
getLocation() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
返回组的代码基。
getLocation() - 类 java.security.CodeSource 中的方法
返回与此 CodeSource 关联的位置。
getLocation() - 接口 javax.accessibility.AccessibleComponent 中的方法
获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
getLocation(Point) - 类 javax.swing.JComponent 中的方法
将此组件的 x，y 原点存储到“返回值”rv 中并返回 rv。
getLocation() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getLocation() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
getLocation() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getLocation() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getLocation(JavaFileManager.Location) - 接口 javax.tools.StandardJavaFileManager 中的方法
获取与给定位置关联的路径。
getLocation() - 接口 javax.xml.stream.events.XMLEvent 中的方法
返回此事件的位置。
getLocation() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getLocation() - 异常 javax.xml.stream.XMLStreamException 中的方法
获取异常的位置
getLocation() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回处理器的当前位置。
getLocation() - 接口 org.w3c.dom.DOMError 中的方法
错误的位置。
getLocationAsString() - 异常 javax.xml.transform.TransformerException 中的方法
获取字符串形式的位置信息。
getLocationInJTree() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getLocationOffset(int, int) - 接口 java.awt.im.InputMethodRequests 中的方法
获取撰写文本相对于屏幕上指定 x 和 y 绝对坐标的偏移量。
getLocationOnScreen() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回对象在屏幕上的位置。
getLocationOnScreen() - 类 java.awt.Component 中的方法
获取组件的位置，形式是一个指定屏幕坐标空间中组件左上角的一个点。
getLocationOnScreen() - 类 java.awt.event.MouseEvent 中的方法
返回事件的绝对 x, y 坐标。
getLocationOnScreen() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
返回对象在屏幕上的位置。
getLocationOnScreen() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回对象在屏幕上的位置。
getLocationOnScreen() - 接口 javax.accessibility.AccessibleComponent 中的方法
返回对象在屏幕上的位置。
getLocationOnScreen() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getLocationOnScreen() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
返回对象在屏幕上的位置。
getLocationOnScreen() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getLocationOnScreen() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getLocator() - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法

getLocator() - 接口 javax.xml.bind.ValidationEvent 中的方法
检索此警告/错误的定位符。
getLocator() - 异常 javax.xml.transform.TransformerException 中的方法
getLocator 方法检索 SourceLocator 对象的实例，此对象指定了错误发生的位置。
getLockedMonitors() - 类 java.lang.management.ThreadInfo 中的方法
返回 MonitorInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的对象监视器。
getLockedStackDepth() - 类 java.lang.management.MonitorInfo 中的方法
返回锁定对象监视器的堆栈跟踪中的深度。
getLockedStackFrame() - 类 java.lang.management.MonitorInfo 中的方法
返回锁定对象监视器的堆栈帧。
getLockedSynchronizers() - 类 java.lang.management.ThreadInfo 中的方法
返回 LockInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的可拥有同步器。
getLockInfo() - 类 java.lang.management.ThreadInfo 中的方法
返回对象的 LockInfo，与此 ThreadInfo 关联的线程被阻塞并等待该对象。
getLockingKeyState(int) - 类 java.awt.Toolkit 中的方法
返回键盘上给定锁定键是否处于 "on" 状态。
getLockName() - 类 java.lang.management.ThreadInfo 中的方法
返回对象的字符串表示形式，与此 ThreadInfo 关联的线程被锁定并等待该对象。
getLockOwnerId() - 类 java.lang.management.ThreadInfo 中的方法
返回拥有对象的线程的 ID，与此 ThreadInfo 关联的线程被阻塞并等待该对象。
getLockOwnerName() - 类 java.lang.management.ThreadInfo 中的方法
返回拥有对象的线程的名称，与此 ThreadInfo 关联的线程被阻塞并等待该对象。
getLog() - 类 java.rmi.server.RemoteServer 中的静态方法
返回用于 RMI 调用日志的流。
getLogger(String) - 类 java.util.logging.Logger 中的静态方法
为指定子系统查找或创建一个 logger。
getLogger(String, String) - 类 java.util.logging.Logger 中的静态方法
为指定子系统查找或创建一个 logger。
getLogger(String) - 类 java.util.logging.LogManager 中的方法
查找指定 logger 的方法。
getLogger() - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
返回应用程序的日志对象，以获取 SyncProvider 实现发送的同步事件。
getLoggerLevel(String) - 接口 java.util.logging.LoggingMXBean 中的方法
获取与指定 logger 相关的日志级别名称。
getLoggerName() - 类 java.util.logging.LogRecord 中的方法
获取源 Logger 名称
getLoggerNames() - 接口 java.util.logging.LoggingMXBean 中的方法
返回当前已注册的 logger 列表。
getLoggerNames() - 类 java.util.logging.LogManager 中的方法
获取已知 logger 名称的枚举。
getLoggingMXBean() - 类 java.util.logging.LogManager 中的静态方法
返回管理 logger 的 LoggingMXBean。
getLogicalBounds() - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 的逻辑边界。
getLogicalHighlightShape(int, int, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回封闭指定范围中扩展到指定 bounds 的逻辑选择范围的 Shape。
getLogicalHighlightShape(int, int) - 类 java.awt.font.TextLayout 中的方法
返回封装指定范围中逻辑选择范围的 Shape，它扩展到此 TextLayout 的自然边界。
getLogicalRangesForVisualSelection(TextHitInfo, TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回对应于可视选择范围的逻辑文本范围。
getLogicalStyle() - 类 javax.swing.JTextPane 中的方法
获取分配给由当前插入符号位置表示的段落的逻辑样式，或者 null。
getLogicalStyle(int) - 类 javax.swing.text.DefaultStyledDocument 中的方法
获取表示给定位置处分配给段落的逻辑样式。
getLogicalStyle(int) - 接口 javax.swing.text.StyledDocument 中的方法
获取段落中给定位置的逻辑样式。
getLogicalView(FlowView) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
此方法提供访问 FlowView 的逻辑视图的流策略。
getLoginModuleName() - 类 javax.security.auth.login.AppConfigurationEntry 中的方法
获取所配置的 LoginModule 的类名称。
getLoginTimeout() - 类 java.sql.DriverManager 中的静态方法
获取驱动程序试图登录到某一数据库时可以等待的最长时间，以秒为单位。
getLoginTimeout() - 接口 javax.sql.CommonDataSource 中的方法
获取此数据源试图连接到某一数据库时可以等待的最长时间，以秒为单位。
getLogManager() - 类 java.util.logging.LogManager 中的静态方法
返回全局 LogManager 对象。
getLogStream() - 类 java.sql.DriverManager 中的静态方法
已过时。
getLogTimers() - 类 javax.swing.Timer 中的静态方法
如果启用了日志记录，则返回 true。
getLogWriter() - 类 java.sql.DriverManager 中的静态方法
获取日志 writer。
getLogWriter() - 接口 javax.sql.CommonDataSource 中的方法
获取此 DataSource 对象的日志 writer。
getLong(String) - 类 java.lang.Long 中的静态方法
确定具有指定名称的系统属性的 long 值。
getLong(String, long) - 类 java.lang.Long 中的静态方法
使用指定名称确定系统属性的 long 值。
getLong(String, Long) - 类 java.lang.Long 中的静态方法
使用指定名称返回系统属性的 long 值。
getLong(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 long 形式返回指定数组对象中索引组件的值。
getLong(Object) - 类 java.lang.reflect.Field 中的方法
获取 long 类型或另一个通过扩展转换可以转换为 long 类型的基本类型的静态或实例字段的值。
getLong() - 类 java.nio.ByteBuffer 中的方法
用于读取 long 值的相对 get 方法。
getLong(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 long 值的绝对 get 方法。
getLong(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 long 值的形式获取指定的 JDBC BIGINT 参数的值。
getLong(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 long 值的形式获取 JDBC BIGINT 参数的值。
getLong(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。
getLong(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。
getLong(String, long) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getLong(String,long) 中的规范实现 getLong 方法。
getLong(String, long) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定的键相关联的、由字符串表示的 long 值。
getLongFramePosition() - 接口 javax.sound.sampled.DataLine 中的方法
获得音频数据中的当前位置（以样本帧为单位）。
getLongParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 long 返回参数的便捷方法。
getLookAndFeel() - 类 javax.swing.UIManager 中的静态方法
返回当前外观或 null。
getLookAndFeelDefaults() - 类 javax.swing.UIManager 中的静态方法
从当前外观返回 UIDefaults，UIDefaults 在安装该外观时获得。
getLoopbackMode() - 类 java.net.MulticastSocket 中的方法
获取多播数据报的本地回送的设置。
getLoopCount() - 接口 javax.sound.midi.Sequencer 中的方法
获得回放的重复次数。
getLoopEndPoint() - 接口 javax.sound.midi.Sequencer 中的方法
获得循环的结束位置，以 MIDI 节拍为单位。
getLoopStartPoint() - 接口 javax.sound.midi.Sequencer 中的方法
获得循环的起始位置，以 MIDI 节拍为单位。
getLowerBound() - 接口 javax.lang.model.type.TypeVariable 中的方法
返回此类型变量的下边界。
getLowerBounds() - 接口 java.lang.reflect.WildcardType 中的方法
返回表示此类型变量下边界的 Type 对象的数组。
getLoweredBevelBorderUIResource() - 类 javax.swing.plaf.BorderUIResource 中的静态方法

getLowestSetBit() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 最右端（最低位）1 比特的索引（即从此字节的右端开始到本字节中最右端 1 比特之间的 0 比特的位数）。
getLowestValue() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回在标签表中有一个项的最小值。
getLowestValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回与标签表中的最高滑块值相对应的标签。
getLowThreshold() - 类 javax.management.monitor.GaugeMonitor 中的方法
获取所有观察到的 MBean 的公共低阈值。
getLowThreshold() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取低阈值。
getLSB() - 类 java.awt.font.GlyphMetrics 中的方法
返回该字形的左（上）跨距。
getM() - 类 java.security.spec.ECFieldF2m 中的方法
返回此首数为 2 的有限字段的值 m。
getMacLength() - 类 javax.crypto.Mac 中的方法
返回 MAC 的长度，以字节为单位。
getMagicCaretPosition() - 接口 javax.swing.text.Caret 中的方法
获取当前插入符可见位置。
getMagicCaretPosition() - 类 javax.swing.text.DefaultCaret 中的方法
获取保存的插入符位置。
getMainAttributes() - 类 java.net.JarURLConnection 中的方法
返回此连接的 JAR 文件的主要 Attribute。
getMainAttributes() - 类 java.util.jar.Manifest 中的方法
返回 Manifest 的主 Attributes。
getMajor() - 异常 org.ietf.jgss.GSSException 中的方法
返回导致抛出此异常的问题的 GSS-API 级主要错误代码。
getMajorAxis() - 类 javax.swing.text.AsyncBoxView 中的方法
获取主轴（即子级平铺时沿用的轴）。
getMajorOffset() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
沿主轴的偏移量是什么。
getMajorSpan() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
沿主轴的跨距是什么。
getMajorString() - 异常 org.ietf.jgss.GSSException 中的方法
返回一个字符串，解释在此异常中 GSS-API 级的主要错误代码。
getMajorTickSpacing() - 类 javax.swing.JSlider 中的方法
此方法返回主刻度标记的间隔。
getMajorVersion() - 类 java.awt.color.ICC_Profile 中的方法
返回配置文件的主版本号。
getMajorVersion() - 接口 java.sql.Driver 中的方法
获取此驱动程序的主版本号。
getManagementSpecVersion() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回正在运行的 Java 虚拟机实现的管理接口的规范版本。
getManifest() - 类 java.net.JarURLConnection 中的方法
返回此连接的 Manifest；如果没有，则返回 null。
getManifest() - 类 java.util.jar.JarFile 中的方法
返回 jar 文件清单；如果没有，则返回 null。
getManifest() - 类 java.util.jar.JarInputStream 中的方法
返回此 JAR 文件的 Manifest；如果没有，则返回 null。
getMapSize() - 类 java.awt.image.IndexColorModel 中的方法
返回此 IndexColorModel 中颜色/alpha 分量数组的大小。
getMargin() - 类 javax.swing.AbstractButton 中的方法
返回按钮边框和标签之间的空白。
getMargin() - 类 javax.swing.JMenuBar 中的方法
返回菜单栏的边框与其菜单之间的空白。
getMargin() - 类 javax.swing.JPopupMenu 中的方法
返回弹出菜单的边框与其包含内容之间的空白（以像素表示）。
getMargin() - 类 javax.swing.JToolBar 中的方法
返回工具栏边框和它的按钮之间的空白。
getMargin() - 类 javax.swing.text.JTextComponent 中的方法
返回文本组件的边框和它的文本之间的空白。
getMark() - 类 javax.swing.event.CaretEvent 中的方法
获得逻辑选择的另一端的位置。
getMark() - 接口 javax.swing.text.Caret 中的方法
获取标记的当前位置。
getMark() - 类 javax.swing.text.DefaultCaret 中的方法
获取标记的当前位置。
getMarkBias() - 类 javax.swing.text.DefaultCaret 中的方法
返回标记的偏差。
getMask(int) - 类 java.awt.image.PackedColorModel 中的方法
返回指示像素中哪些位包含指定颜色/alpha 采样的掩码。
getMask() - 类 javax.swing.text.MaskFormatter 中的方法
返回格式化掩码。
getMasks() - 类 java.awt.image.PackedColorModel 中的方法
返回指示像素中的哪些位包含颜色和 alpha 采样的掩码数组。
getMasterSyncMode() - 接口 javax.sound.midi.Sequencer 中的方法
获得此 sequencer 的当前主同步模式。
getMasterSyncModes() - 接口 javax.sound.midi.Sequencer 中的方法
获得此 sequencer 支持的主同步模式集。
getMatchAllSubjectAltNames() - 类 java.security.cert.X509CertSelector 中的方法
指示 X509Certificate 是否必须包含 setSubjectAlternativeNames 或 addSubjectAlternativeName 方法中所指定的所有或至少某个 subjectAlternativeNames。
getMatchColumnIndexes() - 接口 javax.sql.rowset.Joinable 中的方法
获取使用方法 setMatchColumn(int[] columnIdxes) 为此 RowSet 对象设置的匹配列的索引。
getMatchColumnNames() - 接口 javax.sql.rowset.Joinable 中的方法
获取使用方法 setMatchColumn(String [] columnNames) 为此 RowSet 对象设置的匹配列的名称。
getMatchingHeaders(String[]) - 类 javax.xml.soap.MimeHeaders 中的方法
返回其名称与给定名称数组中的任一名称匹配的所有 MimeHeader 对象。
getMatchingMimeHeaders(String[]) - 类 javax.xml.soap.AttachmentPart 中的方法
检索匹配给定数组中名称的所有 MimeHeader 对象。
getMatchingMimeHeaders(String[]) - 类 javax.xml.soap.SOAPPart 中的方法
检索与给定数组中的名称匹配的所有 MimeHeader 对象。
getMatchingRuleID() - 类 javax.naming.ldap.SortKey 中的方法
检索用于排序属性值的匹配规则 ID。
getMatrix() - 类 java.awt.color.ICC_ProfileRGB 中的方法
返回一个由配置文件的 redColorantTag、greenColorantTag 和 blueColorantTag 的 X、Y 和 Z 分量构造的 3x3 float 矩阵。
getMatrix(double[]) - 类 java.awt.geom.AffineTransform 中的方法
在 3x3 仿射变换矩阵中检索 6 个可指定值，并将其置于双精度值的数组中。
getMatrix() - 类 java.awt.image.BandCombineOp 中的方法
返回线性组合矩阵的一个副本。
getMatrix() - 类 java.awt.print.PageFormat 中的方法
返回一个变换矩阵，该矩阵将呈现的用户空间向请求的方向平移。
getMatteColor() - 类 javax.swing.border.MatteBorder 中的方法
返回平铺边框的颜色，如果使用了平铺图标，则返回 null。
getMax() - 类 java.lang.management.MemoryUsage 中的方法
返回可以用于内存管理的最大内存量（以字节为单位）。
getMaxAdvance() - 类 java.awt.FontMetrics 中的方法
获取此 Font 中所有字符的最大 advance width。
getMaxAge() - 类 java.net.HttpCookie 中的方法
返回以秒为单位指定的 cookie 最大生存时间。
getMaxAllowedKeyLength(String) - 类 javax.crypto.Cipher 中的静态方法
根据所安装的 JCE 仲裁策略文件，返回指定转换的最大密钥长度。
getMaxAllowedParameterSpec(String) - 类 javax.crypto.Cipher 中的静态方法
根据仲裁策略文件，返回包含最大 Cipher 参数值的 AlgorithmParameterSpec 对象。
getMaxAscent() - 类 java.awt.FontMetrics 中的方法
确定此 FontMetrics 对象所描述的 Font 的最大 ascent。
getMaxBinaryLiteralLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在内嵌二进制字面值中使用的最大十六进制字符数。
getMaxBufferSize() - 类 javax.sound.sampled.DataLine.Info 中的方法
获得数据行支持的最大缓冲区大小。
getMaxCatalogNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于类别名称的最大字符数。
getMaxCharactersPerLineCount() - 类 javax.swing.JOptionPane 中的方法
返回要置于消息的行中的最大字符数。
getMaxCharactersPerLineCount() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回要置于行中的最大字符数。
getMaxCharBounds(FontRenderContext) - 类 java.awt.Font 中的方法
返回最大边界定义在 FontRenderContext 中的字符的边界。
getMaxCharBounds(Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中具有最大边界的字符的边界。
getMaxCharLiteralLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于字符字面值的最大字符数。
getMaxColumnNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于列名称的最大字符数。
getMaxColumnsInGroupBy() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在 GROUP BY 子句中使用的最大列数。
getMaxColumnsInIndex() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在索引中使用的最大列数。
getMaxColumnsInOrderBy() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在 ORDER BY 子句中使用的最大列数。
getMaxColumnsInSelect() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在 SELECT 列表中使用的最大列数。
getMaxColumnsInTable() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在表中使用的最大列数。
getMaxConnections() - 接口 java.sql.DatabaseMetaData 中的方法
获取连接到此数据库的并发连接的可能最大数。
getMaxCRL() - 类 java.security.cert.X509CRLSelector 中的方法
返回 maxCRLNumber 标准。
getMaxCursorNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于游标名称的最大字符数。
getMaxDecent() - 类 java.awt.FontMetrics 中的方法
已过时。 从 JDK version 1.1.1 开始，由 getMaxDescent() 取代。
getMaxDegree() - 类 javax.management.relation.RoleInfo 中的方法
返回相应角色引用的最大程度。
getMaxDescent() - 类 java.awt.FontMetrics 中的方法
确定此 FontMetrics 对象所描述的 Font 的最大 descent。
getMaxExpansion(int) - 类 java.text.CollationElementIterator 中的方法
返回以指定比较顺序结束的所有扩展序列的最大长度。
getMaxFieldSize() - 接口 java.sql.Statement 中的方法
获取可以为此 Statement 对象所生成 ResultSet 对象中的字符和二进制列值返回的最大字节数。
getMaxFieldSize() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取可用于此 RowSet 对象列值的最大字节数。
getMaxFieldSize() - 接口 javax.sql.RowSet 中的方法
获取可以对某些列值返回的最大字节数。
getMaximizedBounds() - 类 java.awt.Frame 中的方法
获取此窗体的最大化边界。
getMaximum() - 接口 java.awt.Adjustable 中的方法
获取可调整对象的最大值。
getMaximum() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的最大值。
getMaximum() - 类 java.awt.ScrollPaneAdjustable 中的方法

getMaximum(int) - 类 java.util.Calendar 中的方法
返回此 Calendar 实例给定日历字段的最大值。
getMaximum(int) - 类 java.util.GregorianCalendar 中的方法
返回此 GregorianCalendar 实例的给定日历字段的最大值。
getMaximum() - 类 javax.sound.sampled.FloatControl 中的方法
获得所允许的最大值。
getMaximum() - 接口 javax.swing.BoundedRangeModel 中的方法
返回模型的 maximum。
getMaximum() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回模型的 maximum。
getMaximum() - 类 javax.swing.JProgressBar 中的方法
从 BoundedRangeModel 返回进度条的 maximum 值。
getMaximum() - 类 javax.swing.JScrollBar 中的方法
滚动条的最大值为最大跨度。
getMaximum() - 类 javax.swing.JSlider 中的方法
从 BoundedRangeModel 返回滑块所支持的最大值。
getMaximum() - 类 javax.swing.ProgressMonitor 中的方法
返回最大值 - 进度值的较高端。
getMaximum() - 类 javax.swing.SpinnerNumberModel 中的方法
返回该序列中的最后一个数字。
getMaximum() - 类 javax.swing.text.InternationalFormatter 中的方法
返回最大允许值。
getMaximumAccessibleValue() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取此对象的最大值，它是一个 Number。
getMaximumAccessibleValue() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取此对象的最大值，它是一个 Number。
getMaximumAccessibleValue() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取此对象的最大值，它是一个 Number。
getMaximumAccessibleValue() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
以数字形式获取此对象的最大值。
getMaximumAccessibleValue() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获取此对象的最大可访问值。
getMaximumAccessibleValue() - 接口 javax.accessibility.AccessibleValue 中的方法
以 Number 形式获取此对象的最大值。
getMaximumAccessibleValue() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
以 Number 形式获取此对象的最大值。
getMaximumAccessibleValue() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
以 Number 形式获取此对象的最大值。
getMaximumAccessibleValue() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
以 Number 形式获取此对象的最大值。
getMaximumAccessibleValue() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获取此对象的最大可访问值。
getMaximumAccessibleValue() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取此对象的最大可访问值。
getMaximumAccessibleValue() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取此对象的最大可访问值。
getMaximumAccessibleValue() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取此对象数字形式的最大值。
getMaximumAccessibleValue() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取此对象的最大可访问值。
getMaximumCharHeight(SynthContext) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
根据传入的 SynthContext 返回 Font 的最大高度。
getMaximumCursorColors() - 类 java.awt.Toolkit 中的方法
返回自定义光标调色板中 Toolkit 支持的最大颜色数。
getMaximumDividerLocation() - 类 javax.swing.JSplitPane 中的方法
返回外观实现中分隔条的最大位置。
getMaximumDividerLocation(JSplitPane) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
获取分隔符的最大位置。
getMaximumDividerLocation(JSplitPane) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumDividerLocation 方法。
getMaximumDividerLocation(JSplitPane) - 类 javax.swing.plaf.SplitPaneUI 中的方法
返回分隔符的最大可能位置。
getMaximumFractionDigits() - 类 java.text.DecimalFormat 中的方法
获取某个数的小数部分中所允许的最大数字位数。
getMaximumFractionDigits() - 类 java.text.NumberFormat 中的方法
返回数的小数部分所允许的最大位数。
getMaximumIntegerDigits() - 类 java.text.DecimalFormat 中的方法
获取某个数的整数部分中所允许的最大数字位数。
getMaximumIntegerDigits() - 类 java.text.NumberFormat 中的方法
返回数的整数部分所允许的最大位数。
getMaximumPoolSize() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回允许的最大线程数。
getMaximumRowCount() - 类 javax.swing.JComboBox 中的方法
返回组合框不使用滚动条可以显示的最大项数
getMaximumSize() - 类 java.awt.Component 中的方法
获取组件的最大大小。
getMaximumSize() - 类 java.awt.Container 中的方法
返回此容器的最大大小。
getMaximumSize() - 类 javax.swing.JComponent 中的方法
如果已将最大大小设置为一个非 null 值，则返回该值。
getMaximumSize() - 类 javax.swing.JScrollBar 中的方法
滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。
getMaximumSize() - 类 javax.swing.JToolBar.Separator 中的方法
返回分隔符的最小大小。
getMaximumSize() - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
返回 BasicArrowButton 的最大大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
不能调整桌面图标的大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回传入组件的最大大小，该大小将传递给当前布局管理器。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
返回标题的最大大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
返回表的最大大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取编辑器组件的最大大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回此组件的最大大小，如果实例当前位于 JTree 中或 0, 0 处，则该大小将为首选大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
返回指定组件的适合外观的最大大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
返回 JFileChooser 的最大大小。
getMaximumSize() - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
返回正确呈现图标和文本所需的最大大小。
getMaximumSpan(int) - 类 javax.swing.text.AsyncBoxView 中的方法
确定此视图沿某轴的最大跨距。
getMaximumSpan(int) - 类 javax.swing.text.BoxView 中的方法
确定此视图沿某个轴的最大区域。
getMaximumSpan(int) - 类 javax.swing.text.ComponentView 中的方法
确定此视图沿某轴的最大区域。
getMaximumSpan(int) - 类 javax.swing.text.html.BlockView 中的方法
确定此视图沿某轴的最大区域。
getMaximumSpan(int) - 类 javax.swing.text.html.FormView 中的方法
确定此视图沿某轴的最大区域。
getMaximumSpan(int) - 类 javax.swing.text.html.ParagraphView 中的方法
确定此视图沿某轴的最大区域。
getMaximumSpan(int) - 类 javax.swing.text.View 中的方法
确定此视图沿某个轴的最大跨距。
getMaximumSpan(int) - 类 javax.swing.text.WrappedPlainView 中的方法
确定此视图沿某个轴的最大跨距。
getMaximumStreamFormatVersion() - 接口 javax.rmi.CORBA.ValueHandlerMultiFormat 中的方法
返回由此 ValueHandler 对象支持的 RMI/IDL 自定义值类型的最大流格式版本。
getMaximumThumbSize() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
返回 thumb 的最大可接受大小。
getMaximumValue() - 类 javax.swing.Spring 中的方法
返回此 Spring 的 maximum 值。
getMaximumWindowBounds() - 类 java.awt.GraphicsEnvironment 中的方法
返回居中 Windows 的最大边界。
getMaximumZoneSize() - 类 javax.swing.text.ZoneView 中的方法
获取当前最大的分区大小。
getMaxIndexLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于索引（包括索引的所有部分）的最大字节数。
getMaxLabel() - 类 javax.sound.sampled.FloatControl 中的方法
获得最大值的标签，如 "Right" 或 "Full"。
getMaxLines(Line.Info) - 接口 javax.sound.sampled.Mixer 中的方法
获得可以在此混频器上同时打开的所请求类型的行的最大近似数。
getMaxPage() - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，用户可以指定为要打印的最后一页的最大值。
getMaxPathLength() - 类 java.security.cert.PKIXBuilderParameters 中的方法
返回证书路径中可能存在的中间非自发布证书的最大数目值。
getMaxPolyphony() - 接口 javax.sound.midi.Synthesizer 中的方法
获得此合成器可同时发声的最大音符数。
getMaxPriority() - 类 java.lang.ThreadGroup 中的方法
返回此线程组的最高优先级。
getMaxProcedureNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于过程名称的最大字符数。
getMaxReceivers() - 接口 javax.sound.midi.MidiDevice 中的方法
获得该 MIDI 设备上用于接收 MIDI 数据的最大可用 MIDI IN 连接数。
getMaxRows() - 接口 java.sql.Statement 中的方法
获取由此 Statement 对象生成的 ResultSet 对象可以包含的最大行数。
getMaxRows() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取此 RowSet 对象可以包含的最大行数。
getMaxRows() - 接口 javax.sql.RowSet 中的方法
获取此 RowSet 对象可以包含的最大行数。
getMaxRowSize() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在单行中使用的最大字节数。
getMaxSchemaNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在模式名称中使用的最大字符数。
getMaxSelectionIndex() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回最后选择的索引，如果选择为空，则返回 -1。
getMaxSelectionIndex() - 类 javax.swing.JList 中的方法
返回选择的最大单元索引；如果选择为空，则返回 -1。
getMaxSelectionIndex() - 接口 javax.swing.ListSelectionModel 中的方法
返回最后选择的索引，如果选择为空，则返回 -1。
getMaxSelectionRow() - 类 javax.swing.JTree 中的方法
返回选择的最后一行。
getMaxSelectionRow() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回从 RowMapper 获取的已选择的 TreePath 的当前集合中的最大值。
getMaxSelectionRow() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回从 RowMapper 获取的已选的 TreePath 当前集合中的最大值。
getMaxSortKeys() - 类 javax.swing.DefaultRowSorter 中的方法
返回排序键的最大数量。
getMaxStatementLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在 SQL 语句中使用的最大字符数。
getMaxStatements() - 接口 java.sql.DatabaseMetaData 中的方法
获取在此数据库中在同一时间内可处于开放状态的最大活动语句数。
getMaxTableNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在表名称中使用的最大字符数。
getMaxTablesInSelect() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在 SELECT 语句中使用的表的最大数量。
getMaxTransmitters() - 接口 javax.sound.midi.MidiDevice 中的方法
获得该 MIDI 设备用于传输 MIDI 数据的最大可用 MIDI OUT 连接数。
getMaxUserNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在用户名称中使用的最大字符数。
getMaxValue(int) - 类 java.awt.color.ColorSpace 中的方法
返回指定分量的最大标准化颜色分量值。
getMaxValue(int) - 类 java.awt.color.ICC_ColorSpace 中的方法
返回指定分量的最大标准化颜色分量值。
getMaxValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最大值（如果已指定），否则返回 null。
getMaxValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此参数的最大值（如果存在），否则返回 null。
getMaxValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最大值（如果指定），否则返回 null。
getMaxWidth() - 类 javax.swing.table.TableColumn 中的方法
返回 TableColumn 的最大宽度。
getMaxX() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 窗体矩形的最大 X 坐标。
getMaxY() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 窗体矩形的最大 Y 坐标。
getMaxZonesLoaded() - 类 javax.swing.text.ZoneView 中的方法
获取当前设置的允许同时加载的分区数。
getMBeanCount() - 接口 javax.management.MBeanServer 中的方法
返回 MBean 服务器中已注册的 MBean 的数目。
getMBeanCount() - 接口 javax.management.MBeanServerConnection 中的方法
返回 MBean 服务器中已注册的 MBean 数目。
getMBeanCount(Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getMBeanCount() 方法。
getMBeanCount(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getMBeanCount(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getMBeanDescriptor() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回包含 MBean 级策略的 ModelMBean 的描述符。
getMBeanDescriptor() - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getMBeanInfo() - 接口 javax.management.DynamicMBean 中的方法
使用 MBeanInfo 对象提供该 Dynamic MBean 已公开的属性和操作。
getMBeanInfo(ObjectName) - 接口 javax.management.MBeanServer 中的方法

getMBeanInfo(ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
此方法发现了 MBean 为管理而公开的属性和操作。
getMBeanInfo() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
返回此 RequiredModelMBean 公开的属性、操作、构造方法和通知是为了便于管理。
getMBeanInfo(ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
getMBeanInfo(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getMBeanInfo(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getMBeanInfo() - 类 javax.management.StandardMBean 中的方法
获取此 MBean 的 MBeanInfo。
getMBeanInterface() - 类 javax.management.StandardMBean 中的方法
获取此 Standard MBean（或 MXBean）的管理接口。
getMBeanName() - 类 javax.management.MBeanServerNotification 中的方法
返回导致该通知的 MBean 的对象名。
getMBeanServer() - 类 javax.management.QueryEval 中的静态方法
返回此线程最近一次提供给 setMBeanServer 方法的 MBean 服务器。
getMBeanServer() - 类 javax.management.remote.JMXConnectorServer 中的方法
返回该连接器服务器连接到的 MBean 服务器。
getMBeanServer() - 接口 javax.management.remote.MBeanServerForwarder 中的方法
返回请求将转发到其上的 MBeanServer 对象。
getMBeanServer() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
此连接器服务器所连接的 MBeanServer。
getMBeanServerConnection() - 类 javax.management.MBeanServerInvocationHandler 中的方法
MBean 服务器连接，使用此处理程序的代理的方法是通过此连接转发的。
getMBeanServerConnection() - 接口 javax.management.remote.JMXConnector 中的方法
返回一个代表远程 MBean 服务器的 MBeanServerConnection 对象。
getMBeanServerConnection(Subject) - 接口 javax.management.remote.JMXConnector 中的方法
返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。
getMBeanServerConnection() - 类 javax.management.remote.rmi.RMIConnector 中的方法

getMBeanServerConnection(Subject) - 类 javax.management.remote.rmi.RMIConnector 中的方法

getMBeanServerId() - 类 javax.management.MBeanServerDelegate 中的方法
返回 MBean 服务器代理标识。
getMBeanServerId() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回 MBean 服务器代理标识。
getMBeansFromURL(URL) - 类 javax.management.loading.MLet 中的方法
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
getMBeansFromURL(String) - 类 javax.management.loading.MLet 中的方法
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
getMBeansFromURL(String) - 接口 javax.management.loading.MLetMBean 中的方法
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
getMBeansFromURL(URL) - 接口 javax.management.loading.MLetMBean 中的方法
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
getMBeansToUnregister() - 类 javax.management.relation.RelationNotification 中的方法
返回因为关系移除而需要注销的 MBean 的 ObjectName 列表（仅限于关系移除）。
getMech() - 接口 org.ietf.jgss.GSSContext 中的方法
确定什么机制正用于此上下文。
getMechanismName() - 接口 javax.security.sasl.SaslClient 中的方法
返回此 SASL 客户端的 IANA 注册机制名。
getMechanismName() - 接口 javax.security.sasl.SaslServer 中的方法
返回此 SASL 服务器的 IANA 注册机制名。
getMechanismNames(Map<String, ?>) - 接口 javax.security.sasl.SaslClientFactory 中的方法
返回与指定的机制选择策略相符的机制的名称数组。
getMechanismNames(Map<String, ?>) - 接口 javax.security.sasl.SaslServerFactory 中的方法
返回与指定的机制选择策略相符的机制的名称数组。
getMechanismType() - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
返回此 KeyInfoFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。
getMechanismType() - 类 javax.xml.crypto.dsig.TransformService 中的方法
返回此 TransformService 支持的机制类型。
getMechanismType() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
返回此 XMLSignatureFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。
getMechs() - 接口 org.ietf.jgss.GSSCredential 中的方法
返回受此凭据支持的机制的列表。
getMechs() - 类 org.ietf.jgss.GSSManager 中的方法
返回一个可通过此 GSSManager 提供给 GSS-API 调用者的机制列表。
getMechsForName(Oid) - 类 org.ietf.jgss.GSSManager 中的方法
返回支持指定的名称类型的机制的列表。
getMedia() - 类 java.awt.PageAttributes 中的方法
返回使用这些属性的页面的纸张尺寸。
getMediaSizeForName(MediaSizeName) - 类 javax.print.attribute.standard.MediaSize 中的静态方法
获取指定的命名介质的 MediaSize。
getMediaSizeName() - 类 javax.print.attribute.standard.MediaSize 中的方法
获取此尺寸的介质名称（如果有）。
getMediaSubtype() - 类 javax.print.DocFlavor 中的方法
返回此 DocFlavor 对象的媒体子类型（根据 MIME 类型）。
getMediaType() - 类 javax.print.DocFlavor 中的方法
返回此 DocFlavor 对象的媒体类型（根据 MIME 类型）。
getMediaWhitePoint() - 类 java.awt.color.ICC_ProfileGray 中的方法
返回一个长度为 3 的 float 数组，在其 ICC 配置文件中包含 mediaWhitePointTag 的 X、Y 和 Z 分量。
getMediaWhitePoint() - 类 java.awt.color.ICC_ProfileRGB 中的方法
返回包含配置文件的 mediaWhitePointTag 分量的数组。
getMemberControls() - 类 javax.sound.sampled.CompoundControl 中的方法
返回组成组合控件的成员控件集合。
getMembers() - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
获取规范数组形式的此整数集属性的成员。
getMemoryManagerMXBeans() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机中的 MemoryManagerMXBean 对象列表。
getMemoryManagerNames() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回管理此内存池的内存管理器的名称。
getMemoryMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机的内存系统的管理 Bean。
getMemoryPoolMXBeans() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机中的 MemoryPoolMXBean 对象列表。
getMemoryPoolNames() - 接口 java.lang.management.MemoryManagerMXBean 中的方法
返回此内存管理器管理的内存池名称。
getMenu(int) - 类 java.awt.MenuBar 中的方法
获取指定的菜单。
getMenu(int) - 类 javax.swing.JMenuBar 中的方法
返回菜单栏中指定位置的菜单。
getMenuArrowIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getMenuArrowIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getMenuBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单背景颜色。
getMenuBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单背景色。
getMenuBar() - 类 java.awt.Frame 中的方法
获取此窗体的菜单栏。
getMenuBar() - 类 javax.swing.JInternalFrame 中的方法
已过时。 从 Swing version 1.0.3 开始，由 getJMenuBar() 取代。
getMenuBar() - 类 javax.swing.JRootPane 中的方法
已过时。 从 Swing 版本 1.0.3 开始，由 getJMenuBar() 取代。
getMenuBarBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getMenuComponent(int) - 类 javax.swing.JMenu 中的方法
返回位于位置 n 的组件。
getMenuComponentCount() - 类 javax.swing.JMenu 中的方法
返回菜单上的组件数。
getMenuComponents() - 类 javax.swing.JMenu 中的方法
返回菜单子组件的 Component 数组。
getMenuCount() - 类 java.awt.MenuBar 中的方法
获取该菜单栏上的菜单数。
getMenuCount() - 类 javax.swing.JMenuBar 中的方法
返回菜单栏上的菜单数。
getMenuDisabledForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单禁用前景颜色。
getMenuDisabledForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单禁用前景色。
getMenuDisabledForeground() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回菜单禁用前景色。
getMenuDragMouseListeners() - 类 javax.swing.JMenuItem 中的方法
返回利用 addMenuDragMouseListener() 添加到此 JMenuItem 的所有 MenuDragMouseListener 组成的数组。
getMenuForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单前景颜色。
getMenuForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单前景色。
getMenuItemArrowIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getMenuItemArrowIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getMenuItemCheckIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getMenuItemCheckIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法
返回一个将由 JCheckBoxMenuItem 使用的图标。
getMenuKeyListeners() - 类 javax.swing.JMenuItem 中的方法
返回利用 addMenuKeyListener() 添加到此 JMenuItem 的所有 MenuKeyListener 的数组。
getMenuKeyListeners() - 类 javax.swing.JPopupMenu 中的方法
返回利用 addMenuKeyListener() 添加到此 JPopupMenu 的所有 MenuKeyListener 组成的数组。
getMenuListeners() - 类 javax.swing.JMenu 中的方法
返回利用 addMenuListener() 添加到此 JMenu 的所有 MenuListener 组成的数组。
getMenuSelectedBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单选中背景颜色。
getMenuSelectedBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单选中背景色。
getMenuSelectedForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单选中前景颜色。
getMenuSelectedForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单选中前景色。
getMenuSelectionManager() - 类 javax.swing.event.MenuDragMouseEvent 中的方法
返回当前菜单选项管理器。
getMenuSelectionManager() - 类 javax.swing.event.MenuKeyEvent 中的方法
返回当前菜单选项管理器。
getMenuShortcutKeyMask() - 类 java.awt.Toolkit 中的方法
确定哪一个修改键是菜单快捷方式的适当加速键。
getMenuTextFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回菜单文本字体。
getMenuTextFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单文本字体。
getMenuTextFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单文本字体。
getMessage() - 异常 java.awt.HeadlessException 中的方法

getMessage() - 异常 java.io.InvalidClassException 中的方法
生成消息并包括类名称（如果存在）。
getMessage() - 异常 java.io.WriteAbortedException 中的方法
生成此消息并包括嵌入异常的消息（如果有）。
getMessage() - 类 java.lang.Throwable 中的方法
返回此 throwable 的详细消息字符串。
getMessage() - 异常 java.net.URISyntaxException 中的方法
返回描述解析错误的字符串。
getMessage() - 异常 java.nio.charset.MalformedInputException 中的方法

getMessage() - 异常 java.nio.charset.UnmappableCharacterException 中的方法

getMessage() - 异常 java.rmi.activation.ActivationException 中的方法
返回包含来自此异常的原因（如果有）的消息的详细消息。
getMessage() - 异常 java.rmi.RemoteException 中的方法
返回此异常的详细消息，包括来自原因（如果有）方面的消息。
getMessage() - 异常 java.rmi.server.ServerCloneException 中的方法
返回此异常的详细信息，包括原因的消息（如果有）。
getMessage() - 异常 java.util.DuplicateFormatFlagsException 中的方法

getMessage() - 异常 java.util.FormatFlagsConversionMismatchException 中的方法

getMessage() - 异常 java.util.IllegalFormatCodePointException 中的方法

getMessage() - 异常 java.util.IllegalFormatConversionException 中的方法

getMessage() - 异常 java.util.IllegalFormatFlagsException 中的方法

getMessage() - 异常 java.util.IllegalFormatPrecisionException 中的方法

getMessage() - 异常 java.util.IllegalFormatWidthException 中的方法

getMessage() - 类 java.util.logging.LogRecord 中的方法
获取本地化或格式化之前的“原始”日志消息。
getMessage() - 异常 java.util.MissingFormatArgumentException 中的方法

getMessage() - 异常 java.util.MissingFormatWidthException 中的方法

getMessage() - 异常 java.util.regex.PatternSyntaxException 中的方法
返回多行字符串，包含语法错误及其索引的描述、错误的正则表达式模式和模式中错误索引的可视化指示。
getMessage() - 异常 java.util.UnknownFormatConversionException 中的方法

getMessage() - 异常 java.util.UnknownFormatFlagsException 中的方法

getMessage() - 接口 javax.annotation.processing.Completion 中的方法
返回包含许多有关 completion 信息的消息。
getMessage() - 类 javax.management.Notification 中的方法
获得通知消息。
getMessage() - 异常 javax.script.ScriptException 中的方法
返回一条消息，该消息包含传递给构造方法的 String，以及行号、列号和文件名（如果它们已知）。
getMessage() - 类 javax.security.auth.callback.TextOutputCallback 中的方法
获取将要显示的消息。
getMessage() - 类 javax.sound.midi.MidiEvent 中的方法
获得事件中包含的 MIDI 消息。
getMessage() - 类 javax.sound.midi.MidiMessage 中的方法
获得 MIDI 消息数据。
getMessage() - 类 javax.swing.JOptionPane 中的方法
返回此窗格显示的消息对象。
getMessage() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回从接收者为其提供外观的 JOptionPane 显示的消息。
getMessage(Locale) - 接口 javax.tools.Diagnostic 中的方法
获取给定语言环境的本地化消息。
getMessage() - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法

getMessage() - 接口 javax.xml.bind.ValidationEvent 中的方法
检索此警告/错误的文本消息。
getMessage() - 错误 javax.xml.parsers.FactoryConfigurationError 中的方法
返回此错误的消息（如果有）。
getMessage() - 异常 javax.xml.soap.SOAPException 中的方法
返回此 SOAPException 对象的详细消息。
getMessage() - 错误 javax.xml.stream.FactoryConfigurationError 中的方法
报告与此错误关联的消息。
getMessage() - 错误 javax.xml.transform.TransformerFactoryConfigurationError 中的方法
返回针对此错误的消息（如果有）。
getMessage() - 接口 javax.xml.ws.handler.LogicalMessageContext 中的方法
从此消息上下文中获得消息。
getMessage() - 接口 javax.xml.ws.handler.soap.SOAPMessageContext 中的方法
从此消息上下文中获取 SOAPMessage。
getMessage() - 异常 org.ietf.jgss.GSSException 中的方法
返回主要和次要状态码的文本表示形式。
getMessage() - 接口 org.w3c.dom.DOMError 中的方法
描述所发生错误的特定于实现的字符串。
getMessage() - 异常 org.xml.sax.SAXException 中的方法
返回此异常的详细消息。
getMessageAndLocation() - 异常 javax.xml.transform.TransformerException 中的方法
获取带有追加的位置信息的错误消息。
getMessageContext() - 接口 javax.xml.ws.WebServiceContext 中的方法
调用此方法时，返回正在服务的请求的 MessageContext。
getMessageDigest() - 类 java.security.DigestInputStream 中的方法
返回与此流关联的消息摘要。
getMessageDigest() - 类 java.security.DigestOutputStream 中的方法
返回与此流关联的消息摘要。
getMessageFactory() - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
获取此 SOAP 绑定使用的 SAAJ MessageFactory 实例。
getMessager() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回用来报告错误、警报和其他通知的 Messager。
getMessageType() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取消息类型。
getMessageType() - 类 javax.security.auth.callback.TextOutputCallback 中的方法
获取消息类型。
getMessageType() - 类 javax.swing.JOptionPane 中的方法
返回消息类型。
getMetaData() - 接口 java.sql.Connection 中的方法
获取一个 DatabaseMetaData 对象，该对象包含关于此 Connection 对象所连接的数据库的元数据。
getMetaData() - 接口 java.sql.PreparedStatement 中的方法
获取包含有关 ResultSet 对象列信息的 ResultSetMetaData 对象，ResultSet 对象将在执行此 PreparedStatement 对象时返回。
getMetaData() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的列的编号、类型和属性。
getMetadata() - 类 javax.imageio.IIOImage 中的方法
返回对当前 IIOMetadata 对象的引用，如果没有设置任何这样的对象，则返回 null。
getMetadata() - 类 javax.xml.ws.Endpoint 中的方法
返回服务的元数据文档列表。
getMetadataFormat(String) - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回描述给定元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
getMetadataFormatNames() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回一个 String 数组，包含包括此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的所有元数据格式（包括本机格式和标准格式）的名称。
getMetaKey() - 接口 org.w3c.dom.events.MouseEvent 中的方法
用于指示在触发事件期间是否按下 'meta' 键。
getMethod() - 类 java.beans.MethodDescriptor 中的方法
获得此 MethodDescriptor 封装的方法。
getMethod(String, Class<?>...) - 类 java.lang.Class 中的方法
返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。
getMethod() - 类 java.util.zip.ZipEntry 中的方法
返回条目的压缩方法；如果未指定，则返回 -1。
getMethod() - 类 javax.swing.text.html.FormSubmitEvent 中的方法
获取表单方法类型。
getMethodCallSyntax(String, String, String...) - 接口 javax.script.ScriptEngineFactory 中的方法
返回一个 String，该 String 可用来调用使用受支持脚本语言语法的 Java 对象的方法。
getMethodDescriptors() - 接口 java.beans.BeanInfo 中的方法
获得 beans MethodDescriptor。
getMethodDescriptors() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝方法的信息。
getMethodName() - 类 java.beans.Statement 中的方法
返回方法名称。
getMethodName() - 类 java.lang.StackTraceElement 中的方法
返回方法名，此方法包含由该堆栈跟踪元素所表示的执行点。
getMethods() - 类 java.lang.Class 中的方法
返回一个包含某些 Method 对象的数组，这些对象反映此 Class 对象所表示的类或接口（包括那些由该类或接口声明的以及从超类和超接口继承的那些的类或接口）的公共 member 方法。
getMGFAlgorithm() - 类 java.security.spec.PSSParameterSpec 中的方法
返回掩码生成函数算法名称。
getMGFAlgorithm() - 类 javax.crypto.spec.OAEPParameterSpec 中的方法
返回掩码生成函数算法名称。
getMGFParameters() - 类 java.security.spec.PSSParameterSpec 中的方法
返回掩码生成函数的参数。
getMGFParameters() - 类 javax.crypto.spec.OAEPParameterSpec 中的方法
返回掩码生成函数的参数。
getMIC(byte[], int, int, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
返回包含所提供消息的加密消息完整性代码 (MIC) 的标记，以便传输到同位体应用程序。
getMIC(InputStream, OutputStream, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
getMicrosecondLength() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得 MIDI 文件的长度，用微秒表示。
getMicrosecondLength() - 类 javax.sound.midi.Sequence 中的方法
获得此 Sequence 的持续时间，用微秒表示。
getMicrosecondLength() - 接口 javax.sound.midi.Sequencer 中的方法
获得当前 sequence 的长度，用微秒表示，如果未设置 sequence，则为 0。
getMicrosecondLength() - 接口 javax.sound.sampled.Clip 中的方法
获得介质持续时间（以微秒为单位）
getMicrosecondPosition() - 接口 javax.sound.midi.MidiDevice 中的方法
获得设备的当前时间戳，以微秒为单位。
getMicrosecondPosition() - 接口 javax.sound.midi.Sequencer 中的方法
获得 sequence 中的当前位置，用微秒表示。
getMicrosecondPosition() - 接口 javax.sound.sampled.DataLine 中的方法
获得音频数据中的当前位置（以微秒为单位）。
getMidiDevice(MidiDevice.Info) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得请求的 MIDI 设备。
getMidiDeviceInfo() - 类 javax.sound.midi.MidiSystem 中的静态方法
获得信息对象数组，表示系统中可用的所有 MIDI 设备集。
getMidiFileFormat(InputStream) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得指定的输入流中数据的 MIDI 文件格式。
getMidiFileFormat(URL) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得指定 URL 中数据的 MIDI 文件格式。
getMidiFileFormat(File) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得指定 File 的 MIDI 文件格式。
getMidiFileFormat(InputStream) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
获得所提供的输入流的 MIDI 文件格式。
getMidiFileFormat(URL) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
获得提供的 URL 的 MIDI 文件格式。
getMidiFileFormat(File) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
获得提供的 File 的 MIDI 文件格式。
getMidiFileTypes() - 类 javax.sound.midi.MidiSystem 中的静态方法
获得系统为其提供文件写入支持的 MIDI 文件类型的集合。
getMidiFileTypes(Sequence) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得系统可从指定 sequence 写入的 MIDI 文件类型集合。
getMidiFileTypes() - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
获得此文件 writer 为其提供文件写入支持的 MIDI 文件类型的集合。
getMidiFileTypes(Sequence) - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
获得此文件 writer 可从指定的序列写入的文件类型。
getMidLabel() - 类 javax.sound.sampled.FloatControl 中的方法
获得中点值的标签，如 "Center" 或 "Default"。
getMidTermsOfReductionPolynomial() - 类 java.security.spec.ECFieldF2m 中的方法
对于多项式方法，返回包含降序排列多项式的中间项顺序的整数数组，对于常规方法，返回 null。
getMillis() - 类 java.util.logging.LogRecord 中的方法
获取自从 1970 年以毫秒为单位的事件时间。
getMillisecond() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回 XMLGregorianCalendar.getFractionalSecond() 的毫秒精度。
getMillisToDecideToPopup() - 类 javax.swing.ProgressMonitor 中的方法
返回在确定是否弹出进度监视器之前此对象等待的时间量。
getMillisToPopup() - 类 javax.swing.ProgressMonitor 中的方法
返回显示弹出监视器花费的时间量。
getMimeHeader(String) - 类 javax.xml.soap.AttachmentPart 中的方法
获取给定 String 所标识的头的所有值。
getMimeHeader(String) - 类 javax.xml.soap.SOAPPart 中的方法
获取此 SOAPPart 对象中所有由给定 String 标识的 MimeHeader 对象的值。
getMimeHeaders() - 类 javax.xml.soap.SOAPMessage 中的方法
以与传输无关的方式返回此 SOAPMessage 对象所有特定于传输的 MIME 头。
getMimeType() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的 MIME 类型字符串。
getMimeType() - 类 javax.activation.ActivationDataFlavor 中的方法
返回此 DataFlavor 的 MIME 类型。
getMimeType() - 类 javax.print.DocFlavor 中的方法
根据 MIME 类型的规范形式返回此 DocFlavor 对象的 MIME 类型字符串。
getMimeType() - 接口 javax.xml.crypto.dsig.XMLObject 中的方法
返回此 XMLObject 的 MIME 类型。
getMimeType() - 类 javax.xml.crypto.OctetStreamData 中的方法
返回与由此 OctetStreamData 表示的数据对象关联的 MIME 类型。
getMimeTypes() - 接口 javax.accessibility.AccessibleStreamable 中的方法
返回此对象所支持的 MIME 类型的 DataFlavor 对象数组。
getMimeTypes() - 类 javax.activation.CommandMap 中的方法
获取此命令映射已知的所有 MIME 类型。
getMimeTypes() - 类 javax.activation.MailcapCommandMap 中的方法
获取此命令映射已知的所有 MIME 类型。
getMIMETypes() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回一个 String 数组，该数组包含与通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的格式有关的 MIME 类型的列表。
getMimeTypes() - 接口 javax.script.ScriptEngineFactory 中的方法
返回 mimetypes 的不可变列表，这些 mimetypes 与可由引擎执行的脚本关联。
getMinBufferSize() - 类 javax.sound.sampled.DataLine.Info 中的方法
获得数据行支持的最小缓冲区大小。
getMinCRL() - 类 java.security.cert.X509CRLSelector 中的方法
返回 minCRLNumber 标准。
getMinDegree() - 类 javax.management.relation.RoleInfo 中的方法
返回相应角色引用的最小程度。
getMinimalDaysInFirstWeek() - 类 java.util.Calendar 中的方法
获取一年中第一个星期所需的最少天数，例如，如果定义第一个星期包含一年第一个月的第一天，则此方法将返回 1。
getMinimum() - 接口 java.awt.Adjustable 中的方法
获取可调整对象的最小值。
getMinimum() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的最小值。
getMinimum() - 类 java.awt.ScrollPaneAdjustable 中的方法

getMinimum(int) - 类 java.util.Calendar 中的方法
返回此 Calendar 实例给定日历字段的最小值。
getMinimum(int) - 类 java.util.GregorianCalendar 中的方法
返回此 GregorianCalendar 实例的给定日历字段的最小值。
getMinimum() - 类 javax.sound.sampled.FloatControl 中的方法
获得所允许的最小值。
getMinimum() - 接口 javax.swing.BoundedRangeModel 中的方法
返回最小的可接受值。
getMinimum() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回模型的 minimum。
getMinimum() - 类 javax.swing.JProgressBar 中的方法
从 BoundedRangeModel 返回进度条的 minimum 值。
getMinimum() - 类 javax.swing.JScrollBar 中的方法
返回滚动条支持的最小值（通常为 0）。
getMinimum() - 类 javax.swing.JSlider 中的方法
从 BoundedRangeModel 返回滑块所支持的最小值。
getMinimum() - 类 javax.swing.ProgressMonitor 中的方法
返回最小值 - 进度值的较低端。
getMinimum() - 类 javax.swing.SpinnerNumberModel 中的方法
返回此序列中的第一个数字。
getMinimum() - 类 javax.swing.text.InternationalFormatter 中的方法
返回最小允许值。
getMinimumAccessibleValue() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取此对象的最小值，它是一个 Number。
getMinimumAccessibleValue() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取此对象的最小值，它是一个 Number。
getMinimumAccessibleValue() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取此对象的最小值，它是一个 Number。
getMinimumAccessibleValue() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
以数字形式获取此对象的最小值。
getMinimumAccessibleValue() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获取此对象的最小可访问值。
getMinimumAccessibleValue() - 接口 javax.accessibility.AccessibleValue 中的方法
以 Number 形式设置此对象的最小值。
getMinimumAccessibleValue() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
以 Number 形式获取此对象的最小值。
getMinimumAccessibleValue() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
以 Number 形式获取此对象的最小值。
getMinimumAccessibleValue() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
以 Number 形式获取此对象的最小值。
getMinimumAccessibleValue() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获取此对象的最小可访问值。
getMinimumAccessibleValue() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取此对象的最小可访问值。
getMinimumAccessibleValue() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取此对象的最小可访问值。
getMinimumAccessibleValue() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取此对象数字形式的最小值。
getMinimumAccessibleValue() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取此对象的最小可访问值。
getMinimumDividerLocation() - 类 javax.swing.JSplitPane 中的方法
返回外观实现中分隔条的最小位置。
getMinimumDividerLocation(JSplitPane) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
获取分隔符的最小位置。
getMinimumDividerLocation(JSplitPane) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumDividerLocation 方法。
getMinimumDividerLocation(JSplitPane) - 类 javax.swing.plaf.SplitPaneUI 中的方法
返回分隔符的最小可能位置。
getMinimumFractionDigits() - 类 java.text.DecimalFormat 中的方法
获取某个数的小数部分中所允许的最小数字位数。
getMinimumFractionDigits() - 类 java.text.NumberFormat 中的方法
返回数的小数部分所允许的最小位数。
getMinimumHorizontalSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getMinimumIntegerDigits() - 类 java.text.DecimalFormat 中的方法
获取某个数的整数部分中所允许的最小数字位数。
getMinimumIntegerDigits() - 类 java.text.NumberFormat 中的方法
返回数的整数部分所允许的最小位数。
getMinimumOptionPaneSize() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回选项窗格应该具有的最小大小。
getMinimumSize() - 类 java.awt.Component 中的方法
获取组件的最小大小。
getMinimumSize() - 类 java.awt.Container 中的方法
返回此容器的最小大小。
getMinimumSize(int) - 类 java.awt.List 中的方法
获取具有指定行数的列表的最少维数。
getMinimumSize() - 类 java.awt.List 中的方法
确定此滚动列表的最小大小。
getMinimumSize(int, int) - 类 java.awt.TextArea 中的方法
确定具有指定行数和列数的文本区的最小大小。
getMinimumSize() - 类 java.awt.TextArea 中的方法
确定此文本区的最小大小。
getMinimumSize(int) - 类 java.awt.TextField 中的方法
获取具有指定列数的文本字段的最小尺寸。
getMinimumSize() - 类 java.awt.TextField 中的方法
获取此文本字段的最小尺寸。
getMinimumSize(Component) - 类 javax.swing.border.TitledBorder 中的方法
返回此边框完全显示边框和标题所需的最小大小。
getMinimumSize() - 类 javax.swing.JComponent 中的方法
如果已将最小大小设置为一个非 null 值，则返回该值。
getMinimumSize() - 类 javax.swing.JScrollBar 中的方法
滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。
getMinimumSize() - 类 javax.swing.JToolBar.Separator 中的方法
返回分隔符的最小大小。
getMinimumSize() - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
返回 BasicArrowButton 的最小大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
最小大小为显示区域加上 insets 再加上按钮的大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
此组件的最小大小为 10。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getMinimumSize() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回 dividerSize x dividerSize
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回传入组件的最小大小，该大小将传递给当前布局管理器。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
返回标题的最小大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
返回表的最小大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
重写此方法以将插入符的宽度考虑在内。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取编辑器组件的最小大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回此组件的最小大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
返回指定组件的适合外观的最小大小。
getMinimumSize() - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
返回 JFileChooser 的最小大小。
getMinimumSize() - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
返回正确呈现图标和文本所需的最小大小。
getMinimumSpan(int) - 类 javax.swing.text.AsyncBoxView 中的方法
确定此视图沿某轴的最小跨距。
getMinimumSpan(int) - 类 javax.swing.text.BoxView 中的方法
确定此视图沿某个轴的最小区域。
getMinimumSpan(int) - 类 javax.swing.text.ComponentView 中的方法
确定此视图沿某轴的最小区域。
getMinimumSpan(int) - 类 javax.swing.text.html.BlockView 中的方法
确定此视图沿某个轴的最小区域。
getMinimumSpan(int) - 类 javax.swing.text.html.ParagraphView 中的方法
确定此视图沿某轴的最小区域。
getMinimumSpan(int) - 类 javax.swing.text.View 中的方法
确定此视图沿某个轴的最小跨距。
getMinimumSpan(int) - 类 javax.swing.text.WrappedPlainView 中的方法
确定此视图沿某个轴的最小跨距。
getMinimumThumbSize() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
返回 thumb 的最小可接受大小。
getMinimumThumbSize() - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法

getMinimumValue() - 类 javax.swing.Spring 中的方法
返回此 Spring 的 minimum 值。
getMinimumVerticalSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getMinIndex() - 类 javax.imageio.ImageReader 中的方法
返回用于读取图像、缩略图或图像元数据的最低有效索引。
getMinLabel() - 类 javax.sound.sampled.FloatControl 中的方法
获得最小值的标签，如 "Left" 或 "Off"。
getMinor() - 异常 org.ietf.jgss.GSSException 中的方法
返回导致抛出此异常的问题的机制级错误代码。
getMinorAxis() - 类 javax.swing.text.AsyncBoxView 中的方法
获取辅轴（与平铺轴垂直的轴）。
getMinorOffset() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
沿辅轴的偏移量是什么
getMinorSpan() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
沿辅轴的跨距是什么。
getMinorStatus() - 类 org.ietf.jgss.MessageProp 中的方法
检索基础验证机制可能已经为此 per-message 操作设置的次要状态码.
getMinorString() - 异常 org.ietf.jgss.GSSException 中的方法
返回解释特定于机制的错误代码的字符串。
getMinorString() - 类 org.ietf.jgss.MessageProp 中的方法
检索解释次要状态码的字符串。
getMinorTickSpacing() - 类 javax.swing.JSlider 中的方法
此方法返回次刻度标记的间隔。
getMinorVersion() - 类 java.awt.color.ICC_Profile 中的方法
返回配置文件的次版本号。
getMinorVersion() - 接口 java.sql.Driver 中的方法
获得此驱动程序的次版本号。
getMinPage() - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，用户可以指定为要打印的第一页的最小值。
getMinSelectionIndex() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回第一个选择的索引，如果选择为空，则返回 -1。
getMinSelectionIndex() - 类 javax.swing.JList 中的方法
返回选择的最小单元索引；如果选择为空，则返回 -1。
getMinSelectionIndex() - 接口 javax.swing.ListSelectionModel 中的方法
返回第一个选择的索引，如果选择为空，则返回 -1。
getMinSelectionRow() - 类 javax.swing.JTree 中的方法
获取选择的第一行。
getMinSelectionRow() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回从 RowMapper 获取的已选择的 TreePath 的当前集合中的最小值。
getMinSelectionRow() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回从 RowMapper 获取的已选的 TreePath 当前集合中的最小值。
getMinSize(Container, GridBagLayoutInfo) - 类 java.awt.GridBagLayout 中的方法
基于 getLayoutInfo 中的信息计算其所有者的最小大小。
GetMinSize(Container, GridBagLayoutInfo) - 类 java.awt.GridBagLayout 中的方法
此方法已过时，仅为提供向后兼容性；新代码应该调用 getMinSize 来代替。
getMinTileX() - 类 java.awt.image.BufferedImage 中的方法
返回 x 方向的最小 tile 索引。
getMinTileX() - 接口 java.awt.image.RenderedImage 中的方法
返回 X 方向的最小 tile 索引。
getMinTileY() - 类 java.awt.image.BufferedImage 中的方法
返回 y 方向的最小 tile 索引。
getMinTileY() - 接口 java.awt.image.RenderedImage 中的方法
返回 Y 方向的最小 tile 索引。
getMinusSign() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于表示减号的字符。
getMinute() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回分或 DatatypeConstants.FIELD_UNDEFINED。
getMinutes() - 类 java.sql.Date 中的方法
已过时。
getMinutes() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MINUTE) 取代。
getMinutes() - 类 javax.xml.datatype.Duration 中的方法
获取整数值形式的 MINUTES 字段的值，如果不存在，则值为 0。
getMinValue(int) - 类 java.awt.color.ColorSpace 中的方法
返回指定分量的最小标准化颜色分量值。
getMinValue(int) - 类 java.awt.color.ICC_ColorSpace 中的方法
返回指定分量的最小标准化颜色分量值。
getMinValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最小值（如果已指定），否则返回 null。
getMinValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此参数的最小值（如果存在），否则返回 null。
getMinValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最小值（如果指定），否则返回 null。
getMinWidth() - 类 javax.swing.table.TableColumn 中的方法
返回 TableColumn 的最小宽度。
getMinX() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 窗体矩形的最小 X 坐标。
getMinX() - 类 java.awt.image.BufferedImage 中的方法
返回此 BufferedImage 的最小 x 坐标。
getMinX() - 类 java.awt.image.Raster 中的方法
返回 Raster 的最小有效 X 坐标。
getMinX() - 接口 java.awt.image.renderable.RenderableImage 中的方法
获取与呈现无关的图像数据的最小 X 坐标。
getMinX() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
获取与呈现无关的图像数据的最小 X 坐标。
getMinX() - 接口 java.awt.image.RenderedImage 中的方法
返回 RenderedImage 的最小 X 坐标（包括）。
getMinY() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 窗体矩形的最小 Y 坐标。
getMinY() - 类 java.awt.image.BufferedImage 中的方法
返回此 BufferedImage 的最小 y 坐标。
getMinY() - 类 java.awt.image.Raster 中的方法
返回 Raster 的最小有效 Y 坐标。
getMinY() - 接口 java.awt.image.renderable.RenderableImage 中的方法
获取与呈现无关的图像数据的最小 Y 坐标。
getMinY() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
获取与呈现无关的图像数据的最小 Y 坐标。
getMinY() - 接口 java.awt.image.RenderedImage 中的方法
返回 RenderedImage 的最小 Y 坐标（包括）。
getMissingGlyphCode() - 类 java.awt.Font 中的方法
返回此 Font 不具有指定的 unicode 字形时所使用的 glyphCode 代码点。
getMiterLimit() - 类 java.awt.BasicStroke 中的方法
返回斜接的限制。
getMixer(Mixer.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得请求的音频混频器。
getMixer(Mixer.Info) - 类 javax.sound.sampled.spi.MixerProvider 中的方法
获得由 info 对象表示的混频器的实例。
getMixerInfo() - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得混频器信息对象的数组，该数组表示当前安装在系统上的音频混频器的集合。
getMixerInfo() - 接口 javax.sound.sampled.Mixer 中的方法
获得关于此混频器的信息，包括产品名称、版本、供应商，等等。
getMixerInfo() - 类 javax.sound.sampled.spi.MixerProvider 中的方法
获得表示由该 MixerProvider 提供的混频器的 info 对象集合。
getMnemonic() - 类 javax.swing.AbstractButton 中的方法
返回当前模型中的键盘助记符。
getMnemonic() - 接口 javax.swing.ButtonModel 中的方法
获取该按钮的键盘助记符。
getMnemonic() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
提供关于 KeyEvent.VK 常量的外观方面的提示，此常量可用作访问面板的助记符。
getMnemonic() - 类 javax.swing.DefaultButtonModel 中的方法
获取该按钮的键盘助记符。
getMnemonicAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回用于访问指定选项卡的键盘助记符。
getModalExclusionType() - 类 java.awt.Window 中的方法
返回此窗口的模式排斥类型。
getModalityType() - 类 java.awt.Dialog 中的方法
返回此 dialog 的模式类型。
getMode() - 类 java.awt.FileDialog 中的方法
指示此文件对话框是用于从文件加载内容还是将内容保存到文件。
getModel() - 类 javax.swing.AbstractButton 中的方法
返回此按钮表示的模型。
getModel() - 类 javax.swing.DefaultRowSorter 中的方法
返回底层模型。
getModel() - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
返回此 Model 包装的底层模型。
getModel() - 类 javax.swing.JComboBox 中的方法
返回 JComboBox 当前使用的数据模型。
getModel() - 类 javax.swing.JList 中的方法
返回保存由 JList 组件显示的项列表的数据模型。
getModel() - 类 javax.swing.JProgressBar 中的方法
返回此进度条使用的数据模型。
getModel() - 类 javax.swing.JScrollBar 中的方法
返回处理滚动条的四个基本属性的数据模型：minimum、maximum、value 和 extent。
getModel() - 类 javax.swing.JSlider 中的方法
返回处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。
getModel() - 类 javax.swing.JSpinner.DateEditor 中的方法
返回微调器祖先的 SpinnerDateModel。
getModel() - 类 javax.swing.JSpinner 中的方法
返回定义此 spinner 值序列的 SpinnerModel。
getModel() - 类 javax.swing.JSpinner.ListEditor 中的方法
返回 spinner 祖先的 SpinnerNumberModel。
getModel() - 类 javax.swing.JSpinner.NumberEditor 中的方法
返回 spinner 祖先的 SpinnerNumberModel。
getModel() - 类 javax.swing.JTabbedPane 中的方法
返回与此选项卡窗格关联的模型。
getModel() - 类 javax.swing.JTable 中的方法
返回提供此 JTable 所显示数据的 TableModel。
getModel() - 类 javax.swing.JTree 中的方法
返回正在提供数据的 TreeModel。
getModel() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getModel() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getModel() - 类 javax.swing.RowFilter.Entry 中的方法
返回底层模型。
getModel() - 类 javax.swing.RowSorter 中的方法
返回底层模型。
getModel() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回要提供数据的 TreeModel。
getModelIndex() - 类 javax.swing.table.TableColumn 中的方法
返回此列的模型索引。
getModelRowCount() - 类 javax.swing.DefaultRowSorter 中的方法
返回底层模型中的行数。
getModelRowCount() - 类 javax.swing.RowSorter 中的方法
返回底层模型中的行数。
getModelWrapper() - 类 javax.swing.DefaultRowSorter 中的方法
返回模型包装器，它提供将要进行排序和过滤的数据。
getModificationOp() - 类 javax.naming.directory.ModificationItem 中的方法
检索此修改项的修改代码。
getModifier() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getModifiers() - 类 java.awt.AWTKeyStroke 中的方法
返回此 AWTKeyStroke 的修饰符键。
getModifiers() - 类 java.awt.event.ActionEvent 中的方法
返回发生此动作事件期间按下的修改键。
getModifiers() - 类 java.awt.event.InputEvent 中的方法
返回此事件的修饰符掩码。
getModifiers() - 类 java.lang.Class 中的方法
返回此类或接口以整数编码的 Java 语言修饰符。
getModifiers() - 类 java.lang.reflect.Constructor 中的方法
以整数形式返回此 Constructor 对象所表示构造方法的 Java 语言修饰符。
getModifiers() - 类 java.lang.reflect.Field 中的方法
以整数形式返回由此 Field 对象表示的字段的 Java 语言修饰符。
getModifiers() - 接口 java.lang.reflect.Member 中的方法
作为整数返回由此 Member 所表示的成员或构造方法的 Java 语言修饰符。
getModifiers() - 类 java.lang.reflect.Method 中的方法
以整数形式返回此 Method 对象所表示方法的 Java 语言修饰符。
getModifiers() - 接口 javax.lang.model.element.Element 中的方法
返回此元素的修饰符，不包括注释。
getModifiersEx() - 类 java.awt.event.InputEvent 中的方法
返回此事件的扩展修饰符掩码。
getModifiersExText(int) - 类 java.awt.event.InputEvent 中的静态方法
返回描述扩展修改键和鼠标按钮（例如 "Shift"、"Button1" 或 "Ctrl+Shift"）的 String。
getModulus() - 接口 java.security.interfaces.RSAKey 中的方法
返回该系数。
getModulus() - 类 java.security.spec.RSAPrivateKeySpec 中的方法
返回系数。
getModulus() - 类 java.security.spec.RSAPublicKeySpec 中的方法
返回该系数。
getModulus() - 类 javax.management.monitor.CounterMonitor 中的方法
获取所有观察到的 MBeans 共同的模值。
getModulus() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取模值。
getMonetaryDecimalSeparator() - 类 java.text.DecimalFormatSymbols 中的方法
返回货币小数点分隔符。
getMono() - 接口 javax.sound.midi.MidiChannel 中的方法
获得当前的 mono/poly 模式。
getMonth() - 类 java.sql.Time 中的方法
已过时。
getMonth() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MONTH) 取代。
getMonth() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回月数或 DatatypeConstants.FIELD_UNDEFINED。
getMonths() - 类 java.text.DateFormatSymbols 中的方法
获取月份字符串。
getMonths() - 类 javax.xml.datatype.Duration 中的方法
获取整数值形式的 MONTHS 字段的值，如果不存在，则值为 0。
getMoreResults() - 接口 java.sql.Statement 中的方法
移动到此 Statement 对象的下一个结果，如果其为 ResultSet 对象，则返回 true，并隐式关闭利用方法 getResultSet 获取的所有当前 ResultSet 对象。
getMoreResults(int) - 接口 java.sql.Statement 中的方法
将此 Statement 对象移动到下一个结果，根据给定标志指定的指令处理所有当前 ResultSet 对象；如果下一个结果为 ResultSet 对象，则返回 true。
getMostRecentEventTime() - 类 java.awt.EventQueue 中的静态方法
返回最近事件的时间戳（如果有），该事件从 EventQueue（它与正在调用的线程相关）进行指派。
getMostRecentFocusOwner() - 类 java.awt.Window 中的方法
返回此窗口的子组件，该子组件在此窗口为焦点窗口时将接收焦点。
getMostRecentFocusOwner() - 类 javax.swing.JInternalFrame 中的方法
返回选定此 JInternalFrame 时，将接收焦点的 JInternalFrame 子组件。
getMostSignificantBits() - 类 java.util.UUID 中的方法
返回此 UUID 的 128 位值中的最高有效 64 位。
getMouseInfoPeer() - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 MouseInfo 实现。
getMouseListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.getMouseListener() 的实现。
getMouseListener() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
返回将添加到组合框的鼠标侦听器或 null。
getMouseListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的鼠标侦听器的数组。
getMouseListeners() - 类 java.awt.TrayIcon 中的方法
返回已在此 TrayIcon 上注册的所有鼠标侦听器的数组。
getMouseModifiersText(int) - 类 java.awt.event.MouseEvent 中的静态方法
返回一个描述事件期间所按下的修改键和鼠标按键（如“Shift”或“Ctrl+Shift”）的 String。
getMouseMotionListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.getMouseMotionListener() 的实现。
getMouseMotionListener() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
返回将添加到组合框的鼠标移动侦听器或 null。
getMouseMotionListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的鼠标移动侦听器的数组。
getMouseMotionListeners() - 类 java.awt.TrayIcon 中的方法
返回已在此 TrayIcon 上注册的所有鼠标移动侦听器的数组。
getMousePosition() - 类 java.awt.Component 中的方法
如果此 Component 正好位于鼠标指针下，则返回鼠标指针在该 Component 的坐标空间中的位置；否则返回 null。
getMousePosition(boolean) - 类 java.awt.Container 中的方法
如果 Container 位于鼠标指针下，则返回鼠标指针在此 Container 的坐标中的位置，否则返回 null。
getMouseWheelListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的鼠标滚轮侦听器的数组。
getMTU() - 类 java.net.NetworkInterface 中的方法
返回此接口的最大传输单元（Maximum Transmission Unit，MTU）。
getMultiClickThreshhold() - 类 javax.swing.AbstractButton 中的方法
获取对按钮按下鼠标到生成相应动作事件所需的时间量（以毫秒为单位）。
getMultiDocPrintServices(DocFlavor[], AttributeSet) - 类 javax.print.PrintServiceLookup 中的方法
应用程序不直接调用它。
getMultipleDocumentHandling() - 类 java.awt.JobAttributes 中的方法
为使用这些属性的作业指定多份处理，包括整理。
getMultiplier() - 类 java.text.DecimalFormat 中的方法
获取百分数、千分数和类似格式中使用的乘数。
getMustUnderstand() - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
返回此 SOAPHeaderElement mustUnderstand 属性的 boolean 值。
getMute() - 接口 javax.sound.midi.MidiChannel 中的方法
获得此通道的当前静音状态。
getMutualAuthState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定是否在此上下文上启用了相互验证。
getName(int) - 类 java.awt.color.ColorSpace 中的方法
返回给定分量索引处的分量名称。
getName() - 类 java.awt.Component 中的方法
获取组件的名称。
getName() - 类 java.awt.Cursor 中的方法
返回此光标的名称。
getName() - 类 java.awt.datatransfer.Clipboard 中的方法
返回此剪贴板对象的名称。
getName() - 类 java.awt.Font 中的方法
返回此 Font 的逻辑名称。
getName() - 类 java.awt.MenuComponent 中的方法
获取该菜单组件的名称。
getName() - 类 java.beans.FeatureDescriptor 中的方法
获得此特性的编程名称。
getName() - 类 java.io.File 中的方法
返回由此抽象路径名表示的文件或目录的名称。
getName() - 类 java.io.ObjectStreamClass 中的方法
返回由此描述符描述的类的名称。
getName() - 类 java.io.ObjectStreamField 中的方法
获取此字段的名称。
getName() - 类 java.lang.Class 中的方法
以 String 的形式返回此 Class 对象所表示的实体（类、接口、数组类、基本类型或 void）名称。
getName() - 接口 java.lang.management.CompilationMXBean 中的方法
返回即时 (JIT) 编译器的名称。
getName() - 接口 java.lang.management.MemoryManagerMXBean 中的方法
返回表示此内存管理器的名称。
getName() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回表示此内存池的名称。
getName() - 接口 java.lang.management.OperatingSystemMXBean 中的方法
返回操作系统名称。
getName() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回表示正在运行的 Java 虚拟机的名称。
getName() - 类 java.lang.Package 中的方法
返回此包的名称。
getName() - 类 java.lang.reflect.Constructor 中的方法
以字符串形式返回此构造方法的名称。
getName() - 类 java.lang.reflect.Field 中的方法
返回此 Field 对象表示的字段的名称。
getName() - 接口 java.lang.reflect.Member 中的方法
返回此 Member 表示的底层成员或构造方法的简单名称。
getName() - 类 java.lang.reflect.Method 中的方法
以 String 形式返回此 Method 对象表示的方法名称。
getName() - 接口 java.lang.reflect.TypeVariable 中的方法
返回此类型变量的名称，它出现在源代码中。
getName() - 类 java.lang.Thread 中的方法
返回该线程的名称。
getName() - 类 java.lang.ThreadGroup 中的方法
返回此线程组的名称。
getName() - 类 java.net.HttpCookie 中的方法
返回 cookie 的名称。
getName() - 类 java.net.NetworkInterface 中的方法
获取此网络接口的名称。
getName() - 接口 java.security.acl.Acl 中的方法
返回此 ACL 的名称。
getName() - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 的名称。
getName() - 类 java.security.Permission 中的方法
返回此 Permission 的名称。
getName() - 接口 java.security.Principal 中的方法
返回此主体的名称。
getName() - 类 java.security.Provider 中的方法
返回此 provider 的名称。
getName() - 类 java.security.spec.ECGenParameterSpec 中的方法
返回要生成的 EC 域参数的标准名称或预定义名称。
getName() - 类 java.text.AttributedCharacterIterator.Attribute 中的方法
返回此属性的名称。
getName() - 类 java.util.logging.Level 中的方法
返回 Level 的非本地化字符串名称。
getName() - 类 java.util.logging.Logger 中的方法
获取此 logger 的名称。
getName() - 类 java.util.zip.ZipEntry 中的方法
返回条目名称。
getName() - 类 java.util.zip.ZipFile 中的方法
返回 ZIP 文件的路径名。
getName() - 类 javax.activation.DataHandler 中的方法
返回数据对象的名称。
getName() - 接口 javax.activation.DataSource 中的方法
返回此对象的名称，其中对象的名称依赖于底层对象的特性。
getName() - 类 javax.activation.FileDataSource 中的方法
返回此对象的名称。
getName() - 类 javax.activation.URLDataSource 中的方法
调用用于实例化对象的 URL 的 getFile 方法。
getName() - 类 javax.crypto.ExemptionMechanism 中的方法
返回此 ExemptionMechanism 对象的豁免机制名称。
getName(CharSequence) - 接口 javax.lang.model.util.Elements 中的方法
返回与参数具有相同字符序列的名称。
getName() - 类 javax.management.Attribute 中的方法
返回包含该 Attribute 的名称的 String。
getName() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记的 NAME 属性的值。
getName() - 类 javax.management.MBeanFeatureInfo 中的方法
返回该功能的名称。
getName() - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
返回此 OpenMBeanConstructorInfo 实例描述的构造方法名称。
getName() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 实例描述的操作名称。
getName() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此 OpenMBeanParameterInfo 实例描述的参数名称。
getName() - 类 javax.management.relation.RoleInfo 中的方法
返回角色名称。
getName() - 类 javax.management.remote.JMXPrincipal 中的方法
返回此 principal 的名称。
getName() - 类 javax.naming.NameClassPair 中的方法
检索此绑定的名称。
getName() - 类 javax.net.ssl.SSLSessionBindingEvent 中的方法
返回将对象绑定到或从其解除绑定的名称。
getName() - 接口 javax.print.attribute.Attribute 中的方法
获取类别的名称,此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.Chromaticity 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.ColorSupported 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.Compression 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.Copies 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.CopiesSupported 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.DateTimeAtCompleted 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.DateTimeAtCreation 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.DateTimeAtProcessing 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.Destination 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.DocumentName 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.Fidelity 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.Finishings 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobHoldUntil 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobImpressions 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobImpressionsCompleted 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobImpressionsSupported 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobKOctets 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobKOctetsProcessed 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobKOctetsSupported 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobMediaSheets 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobMediaSheetsCompleted 中的方法
获取类别名称，此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.JobMediaSheetsSupported 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobMessageFromOperator 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobName 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobOriginatingUserName 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobPriority 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobPrioritySupported 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobSheets 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobState 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobStateReason 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobStateReasons 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.Media 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.MediaSize 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.NumberOfDocuments 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.NumberOfInterveningJobs 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.NumberUp 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.NumberUpSupported 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.OrientationRequested 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.OutputDeviceAssigned 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PageRanges 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PagesPerMinute 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PagesPerMinuteColor 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PDLOverrideSupported 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PresentationDirection 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterInfo 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterLocation 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterMakeAndModel 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterMessageFromOperator 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterMoreInfo 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterName 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterResolution 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterState 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterStateReason 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterStateReasons 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterURI 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrintQuality 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.QueuedJobCount 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.RequestingUserName 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.Severity 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.SheetCollate 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.Sides 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 接口 javax.print.PrintService 中的方法
返回此 PrintService 的 String 名称，应用程序可以使用该名称来请求特定的 PrintService。
getName() - 类 javax.security.auth.callback.NameCallback 中的方法
获取检索到的名称。
getName() - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
返回的字符串对应于 Kerberos Principal 名称的 single-string 表示形式，RFC 1964 的 2.1 小节中指定了这种表示形式。
getName() - 类 javax.security.auth.x500.X500Principal 中的方法
返回使用 RFC 2253 中所定义格式的 X.500 标识名的字符串表示形式。
getName(String) - 类 javax.security.auth.x500.X500Principal 中的方法
返回使用指定格式的 X.500 标识名的字符串表示形式。
getName(String, Map<String, String>) - 类 javax.security.auth.x500.X500Principal 中的方法
返回使用指定格式的 X.500 标识名的字符串表示形式。
getName() - 类 javax.sound.midi.MidiDevice.Info 中的方法
获得设备的名称。
getName() - 接口 javax.sound.midi.Soundbank 中的方法
获得音库的名称。
getName() - 类 javax.sound.midi.SoundbankResource 中的方法
获得资源的名称。
getName() - 类 javax.sound.sampled.Mixer.Info 中的方法
获得混频器的名称。
getName() - 类 javax.sound.sampled.Port.Info 中的方法
获得端口的名称。
getName() - 类 javax.sound.sampled.ReverbType 中的方法
获得此回响类型的名称。
getName(File) - 类 javax.swing.filechooser.FileView 中的方法
文件名称。
getName(File) - 类 javax.swing.JFileChooser 中的方法
返回文件名。
getName() - 类 javax.swing.LookAndFeel 中的方法
返回标识此外观的短字符串，例如 "CDE/Motif"。
getName(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法

getName() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回此主题的名称。
getName() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回此外观的名称。
getName() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回此主题的名称。
getName() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回此主题的名称，即 "Ocean"。
getName() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
返回适合在菜单中使用、标识此外观的 string。
getName() - 类 javax.swing.plaf.synth.Region 中的方法
返回 region 的名称。
getName() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回一个标识此外观的短字符串。
getName() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素的名称。
getName() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得元素名。
getName() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
获得元素名。
getName() - 类 javax.swing.text.DefaultStyledDocument.SectionElement 中的方法
获得元素的名称。
getName() - 接口 javax.swing.text.Element 中的方法
获取元素的名称。
getName() - 类 javax.swing.text.html.HTMLDocument.BlockElement 中的方法
获取元素名称。
getName() - 类 javax.swing.text.html.HTMLDocument.RunElement 中的方法
获取元素名称。
getName() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getName() - 类 javax.swing.text.html.parser.DTD 中的方法
获取 DTD 的名称。
getName() - 类 javax.swing.text.html.parser.Element 中的方法
获取元素的名称。
getName() - 类 javax.swing.text.html.parser.Entity 中的方法
获取实体的名称。
getName() - 接口 javax.swing.text.Keymap 中的方法
获取键绑定集合的名称。
getName() - 接口 javax.swing.text.Style 中的方法
获取样式名称。
getName() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
获取样式的名称。
getName() - 类 javax.swing.UIManager.LookAndFeelInfo 中的方法
以适合菜单或其他展示的形式返回外观的名称
getName() - 接口 javax.tools.FileObject 中的方法
获取此文件对象的用户友好 (user-friendly) 的名称。
getName() - 类 javax.tools.ForwardingFileObject 中的方法

getName() - 接口 javax.tools.JavaFileManager.Location 中的方法
获取此位置的名称。
getName() - 类 javax.tools.SimpleJavaFileObject 中的方法

getName() - 枚举 javax.tools.StandardLocation 中的方法

getName() - 类 javax.xml.bind.JAXBElement 中的方法
返回 xml 元素标记名称。
getName() - 接口 javax.xml.crypto.dsig.keyinfo.KeyName 中的方法
返回此 KeyName 的名称。
getName() - 类 javax.xml.soap.MimeHeader 中的方法
返回此 MimeHeader 对象的名称。
getName() - 接口 javax.xml.stream.events.Attribute 中的方法
返回此属性的 QName。
getName() - 接口 javax.xml.stream.events.EndElement 中的方法
获取此事件的名称
getName() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
实体的名称
getName() - 接口 javax.xml.stream.events.EntityReference 中的方法
实体的名称
getName() - 接口 javax.xml.stream.events.NotationDeclaration 中的方法
注释的名称。
getName() - 接口 javax.xml.stream.events.StartElement 中的方法
获取此事件的名称
getName() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getName() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回当前 START_ELEMENT 或 END_ELEMENT 事件的 QName
getName() - 接口 org.ietf.jgss.GSSCredential 中的方法
检索凭据所维护的实体的名称。
getName(Oid) - 接口 org.ietf.jgss.GSSCredential 中的方法
检索凭据所维护的实体的 Mechanism Name（机制名称）。
getName() - 接口 org.w3c.dom.Attr 中的方法
返回此属性的名称。
getName() - 接口 org.w3c.dom.DocumentType 中的方法
DTD 的名称；即紧跟在 DOCTYPE 关键字后面的名称。
getName(int) - 接口 org.w3c.dom.NameList 中的方法
返回集合中的第 index 个名称项。
getName(int) - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回此列表中属性的名称（根据位置）。
getName(int) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 获取属性名称（按位置）。
getNameConstraints() - 类 java.security.cert.TrustAnchor 中的方法
返回 nameConstraints 参数。
getNameConstraints() - 类 java.security.cert.X509CertSelector 中的方法
返回 NameConstraints 标准。
getNamedItem(String) - 接口 org.w3c.dom.NamedNodeMap 中的方法
检索通过名称指定的节点。
getNamedItemNS(String, String) - 接口 org.w3c.dom.NamedNodeMap 中的方法
检索通过本地名称和名称空间 URI 指定的节点。
getNameInNamespace() - 接口 javax.naming.Context 中的方法
在此上下文自己的名称空间中检索其完全名称。
getNameInNamespace() - 类 javax.naming.InitialContext 中的方法

getNameInNamespace() - 类 javax.naming.NameClassPair 中的方法
检索此绑定的完全名称。
getNameParser(Name) - 接口 javax.naming.Context 中的方法
检索与指定上下文关联的解析器。
getNameParser(String) - 接口 javax.naming.Context 中的方法
检索与指定上下文关联的解析器。
getNameParser(String) - 类 javax.naming.InitialContext 中的方法

getNameParser(Name) - 类 javax.naming.InitialContext 中的方法

getNames() - 类 javax.activation.MimeTypeParameterList 中的方法
获取此列表中所有名称的枚举。
getNames() - 接口 javax.script.ScriptEngineFactory 中的方法
返回 ScriptEngine 短名称的不可变列表，这些名称由 ScriptEngineManager 用来标识 ScriptEngine。
getNamesForMech(Oid) - 类 org.ietf.jgss.GSSManager 中的方法
然后返回由指定的机制所支持的名称类型。
getNamespaceContext() - 接口 javax.xml.stream.events.StartElement 中的方法
获取只读名称空间上下文。
getNamespaceContext() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespaceContext() - 接口 javax.xml.stream.XMLEventWriter 中的方法
返回当前名称空间上下文。
getNamespaceContext() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回当前位置的只读名称空间上下文。
getNamespaceContext() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
返回当前名称空间上下文。
getNamespaceContext() - 接口 javax.xml.xpath.XPath 中的方法
返回当前的名称空间上下文。
getNamespaceCount() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespaceCount() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回在 START_ELEMENT 或 END_ELEMENT 中声明的名称空间的计数，此方法仅对 START_ELEMENT、END_ELEMENT 或 NAMESPACE 有效。
getNamespaceMap() - 类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 中的方法
返回名称空间前缀的映射表。
getNamespaceMap() - 类 javax.xml.crypto.dsig.spec.XPathType 中的方法
返回名称空间前缀的映射表。
getNamespacePrefix(String, String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 来获取指定 URI 所映射的前缀。
getNamespacePrefix(String, String) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回与指定的名称空间 URI 关联的名称空间前缀。
getNamespacePrefix(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespacePrefix(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回在 index 处声明的名称空间前缀。
getNamespacePrefixes() - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在此元素声明的名称空间前缀 String 上进行迭代的 Iterator。
getNamespaces() - 接口 javax.xml.stream.events.EndElement 中的方法
返回超出范围名称空间的 Iterator。
getNamespaces() - 接口 javax.xml.stream.events.StartElement 中的方法
返回在此元素上声明的名称空间的 Iterator。
getNamespaceURI() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回 null，因为不支持名称空间。
getNamespaceURI(String) - 接口 javax.xml.namespace.NamespaceContext 中的方法
获取绑定到当前范围中的前缀的名称空间 URI。
getNamespaceURI() - 类 javax.xml.namespace.QName 中的方法
获取此 QName 的名称空间 URI。
getNamespaceURI(String) - 接口 javax.xml.soap.SOAPElement 中的方法
返回带有给定前缀的名称空间的 URI。
getNamespaceURI() - 接口 javax.xml.stream.events.Namespace 中的方法
获取绑定到此名称空间的前缀的 URI。
getNamespaceURI(String) - 接口 javax.xml.stream.events.StartElement 中的方法
获取绑定在此元素上下文中的前缀的值。
getNamespaceURI(String) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespaceURI(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespaceURI() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespaceURI(String) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回给定前缀的 URI。
getNamespaceURI(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回在 index 处声明的名称空间 URI。
getNamespaceURI() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果当前事件是 START_ELEMENT 或 END_ELEMENT，则此方法返回前缀的 URI 或默认名称空间。
getNamespaceURI(int) - 接口 org.w3c.dom.NameList 中的方法
返回集合中的第 index 个 namespaceURI 项。
getNamespaceURI() - 接口 org.w3c.dom.Node 中的方法
此节点的名称空间 URI；如果它未被指定，则返回 null（参见）。
getNameType() - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
返回 KerberosPrincipal 的名称类型。
getNaN() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于表示“非数字”的字符串。
getNanos() - 类 java.sql.Timestamp 中的方法
获取此 Timestamp 对象的 nanos 值。
getNativeCommands(String) - 类 javax.activation.MailcapCommandMap 中的方法
获取给定 MIME 类型的本地命令。
getNativeContainer(Component) - 类 java.awt.Toolkit 中的静态方法
使本机同位体能够查询给定本机组件的本机容器（例如，直接父组件可以是轻量级的）。
getNativeImageMetadataFormatName() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回此插件的“本地”图像元数据格式的名称，它通常允许无损失地编码或传输按照由此插件处理的格式存储的图像元数据。
getNativeMetadataFormatName() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回此插件的“本机”元数据格式的名称，该格式通常允许无损失地编码和传输以此插件处理的格式存储的元数据。
getNativesForFlavor(DataFlavor) - 接口 java.awt.datatransfer.FlavorTable 中的方法
返回与指定 DataFlavor 对应的 String native 的 List。
getNativesForFlavor(DataFlavor) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
返回数据传输子系统可以将指定 DataFlavor 转换成的 String native 的 List。
getNativesForFlavors(DataFlavor[]) - 接口 java.awt.datatransfer.FlavorMap 中的方法
返回指定 DataFlavor 到其对应的 String native 的 Map。
getNativesForFlavors(DataFlavor[]) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
返回指定 DataFlavor 到其大多数首选的 String native 的 Map。
getNativeStreamMetadataFormatName() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回此插件的“本地”流元数据格式的名称，它通常允许无损失地编码和传输按照由此插件处理的格式存储的流元数据。
getNavigationFilter() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
如果想要提供过滤器以限制用户可导航的位置，则应进行子类化和重写。
getNavigationFilter() - 类 javax.swing.text.DefaultFormatter 中的方法
返回用于限制光标放置位置的 NavigationFilter。
getNavigationFilter() - 类 javax.swing.text.JTextComponent 中的方法
返回 NavigationFilter。
getNbNotifications() - 类 javax.management.timer.Timer 中的方法
获得在通知列表中注册的计时器通知数。
getNbNotifications() - 接口 javax.management.timer.TimerMBean 中的方法
获得在通知的列表中注册的计时器通知数。
getNbOccurences(Integer) - 类 javax.management.timer.Timer 中的方法
获得与计时器通知关联的剩余出现数量的一个副本。
getNbOccurences(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与计时器通知关联的剩余出现数量的一个副本。
getNCharacterStream(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
getNCharacterStream(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
getNCharacterStream(int) - 接口 java.sql.ResultSet 中的方法
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getNCharacterStream(String) - 接口 java.sql.ResultSet 中的方法
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getNClob(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.NClob 对象的形式获取指定的 JDBC NCLOB 参数的值。
getNClob(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.NClob 对象的形式获取 JDBC NCLOB 参数的值。
getNClob(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getNClob(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getNeedClientAuth() - 类 javax.net.ssl.SSLEngine 中的方法
如果引擎要求 客户端验证，则返回 true。
getNeedClientAuth() - 类 javax.net.ssl.SSLParameters 中的方法
返回是否应该要求客户机验证。
getNeedClientAuth() - 类 javax.net.ssl.SSLServerSocket 中的方法
如果新 accept 的服务器模式的 SSLSocket 要求 客户端验证，则返回 true。
getNeedClientAuth() - 类 javax.net.ssl.SSLSocket 中的方法
如果套接字要求 客户机验证，则返回 true。
getNeedClientAuth() - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
如果由此工厂创建的服务器套接字所接受的 SSL 连接上要求客户机进行验证，则返回 true。
getNeededLocation(int, int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
返回 x 参数，因为可以将其用于水平拆分。
getNeededLocation(int, int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController 中的方法
返回 y 参数，因为可以将其用于垂直拆分。
getNegativePrefix() - 类 java.text.DecimalFormat 中的方法
获取负数前缀。
getNegativeSuffix() - 类 java.text.DecimalFormat 中的方法
获取负数后缀。
getNegotiatedProperty(String) - 接口 javax.security.sasl.SaslClient 中的方法
获取已协商的属性。
getNegotiatedProperty(String) - 接口 javax.security.sasl.SaslServer 中的方法
获取已协商的属性。
getNestedException() - 异常 javax.xml.stream.XMLStreamException 中的方法
获取嵌套异常。
getNestingKind() - 接口 javax.lang.model.element.TypeElement 中的方法
返回此类型元素的嵌套种类 (nesting kind)。
getNestingKind() - 类 javax.tools.ForwardingJavaFileObject 中的方法

getNestingKind() - 接口 javax.tools.JavaFileObject 中的方法
提供有关此文件对象表示的类的嵌套层次的提示。
getNestingKind() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现返回 null。
getNetworkInterface() - 类 java.net.MulticastSocket 中的方法
获取多播网络接口集合。
getNetworkInterfaces() - 类 java.net.NetworkInterface 中的静态方法
返回此机器上的所有接口。
getNetworkPrefixLength() - 类 java.net.InterfaceAddress 中的方法
返回此地址的网络前缀长度。
getNewBinding() - 类 javax.naming.event.NamingEvent 中的方法
检索更改后对象的绑定。
getNewDocument() - 接口 org.w3c.dom.ls.LSLoadEvent 中的方法
完成加载的文档。
getNewFolderAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getNewLeadSelectionPath() - 类 javax.swing.event.TreeSelectionEvent 中的方法
返回当前前导路径。
getNewLine() - 接口 org.w3c.dom.ls.LSSerializer 中的方法
在所写出的 XML 中使用的字符的行尾序列。
getNewRoleValue() - 类 javax.management.relation.RelationNotification 中的方法
返回更新的角色的新值（仅限于角色更新）。
getNewState() - 类 java.awt.event.WindowEvent 中的方法
对于 WINDOW_STATE_CHANGED 事件，返回新的窗口状态。
getNewValue() - 类 java.beans.PropertyChangeEvent 中的方法
获取属性的新值，以 Object 的形式表示。
getNewValue() - 类 java.util.prefs.PreferenceChangeEvent 中的方法
返回首选项的新值。
getNewValue() - 类 javax.management.AttributeChangeNotification 中的方法
获得已更改属性的新值。
getNewValue() - 接口 org.w3c.dom.events.MutationEvent 中的方法
newValue 指示 DOMAttrModified 事件中 Attr 节点的新值，以及 DOMCharacterDataModified 中 CharacterData 节点的新值。
getNext() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getNextEastWestVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.CompositeView 中的方法
返回光标的下一个可视位置，可以在东或在西。
getNextEntry() - 类 java.util.jar.JarInputStream 中的方法
读取下一个 ZIP 文件条目，并将流定位于此条目数据的开始处。
getNextEntry() - 类 java.util.zip.ZipInputStream 中的方法
读取下一个 ZIP 文件条目并将流定位到该条目数据的开始处。
getNextEvent() - 类 java.awt.EventQueue 中的方法
从 EventQueue 中移除一个事件，并返回该事件。
getNextException() - 异常 java.sql.SQLException 中的方法
通过 setNextException(SQLException ex) 获取链接到此 SQLException 对象的异常。
getNextFocusableComponent() - 类 javax.swing.JComponent 中的方法
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代。
getNextJarEntry() - 类 java.util.jar.JarInputStream 中的方法
读取下一个 JAR 文件条目，并将流定位于此条目数据的开始处。
getNextLeaf() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点后面的叶节点，如果此节点是树中的最后一个叶节点，则返回 null。
getNextLeftHit(TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
getNextLeftHit(int, TextLayout.CaretPolicy) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
getNextLeftHit(int) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
getNextMatch(String, int, Position.Bias) - 类 javax.swing.JList 中的方法
返回其 toString 值以给定前缀开头的下一个列表元素。
getNextMatch(String, int, Position.Bias) - 类 javax.swing.JTree 中的方法
将 TreePath 返回到以一个前缀开头的下一个树元素。
getNextNode() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回在此节点的树的前序遍历中此节点之后的节点。
getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.CompositeView 中的方法
返回光标的下一个可视位置，可以在北也可以在南。
getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.ParagraphView 中的方法
在东或西方向返回光标的下一个可视位置。
getNextRightHit(TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
getNextRightHit(int, TextLayout.CaretPolicy) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
getNextRightHit(int) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
getNextSequenceNumber() - 类 javax.management.remote.NotificationResult 中的方法
返回下一个可供查询使用的通知的序列号。
getNextSibling() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回此节点的下一个兄弟节点；如果该节点没有下一个兄弟节点，则返回 null。
getNextSibling() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回父节点的子节点数组中此节点的下一个兄弟节点。
getNextSibling() - 类 javax.xml.crypto.dsig.dom.DOMSignContext 中的方法
返回 nextSibling 节点。
getNextSibling() - 类 javax.xml.transform.dom.DOMResult 中的方法
获取将要插入的结果节点之后的子节点。
getNextSibling() - 接口 org.w3c.dom.Node 中的方法
直接在此节点之后的节点。
getNextTabIndex(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getNextTabIndexInRun(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getNextTabRun(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getNextUpdate() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 的 nextUpdate 日期。
getNextValue() - 类 javax.swing.JSpinner 中的方法
返回序列中由 getValue() 所返回的对象之后的对象。
getNextValue() - 类 javax.swing.SpinnerDateModel 中的方法
返回序列中的下一个 Date，如果下一个日期在 end 之后，则返回 null。
getNextValue() - 类 javax.swing.SpinnerListModel 中的方法
返回基础序列的下一个合法值，如果值已经是最后一个元素，则返回 null。
getNextValue() - 接口 javax.swing.SpinnerModel 中的方法
返回该序列中出现在 getValue() 返回的对象之后的对象。
getNextValue() - 类 javax.swing.SpinnerNumberModel 中的方法
返回该序列中的下一个数字。
getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
提供确定下一个可以放置一个插入符的可见模型位置的方法。
getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - 类 javax.swing.plaf.TextUI 中的方法
提供确定下一个可以放置一个插入符的可见模型位置的方法。
getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.AsyncBoxView 中的方法
提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.CompositeView 中的方法
提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.GlyphView 中的方法
提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
getNextVisualPositionFrom(GlyphView, int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - 类 javax.swing.text.NavigationFilter 中的方法
返回从现在位置起的下一个放置插入符的可视位置。
getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.View 中的方法
提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
getNextWarning() - 异常 java.sql.SQLWarning 中的方法
通过 setNextWarning 获取链接到此 SQLWarning 对象的警告。
getNextWarning() - 异常 javax.sql.rowset.RowSetWarning 中的方法
获取链接到此 SQLWarning 对象的警告。
getNextWord(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定针对给定位置的下一个单词开头。
getNode() - 类 java.util.prefs.PreferenceChangeEvent 中的方法
返回发出事件的首选项节点。
getNode(Object) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
默认情况下，getNode 方法不受支持并抛出 UnsupportedOperationException。
getNode() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getNode(Object) - 接口 javax.xml.bind.Marshaller 中的方法
获取内容树的 DOM 树视图（可选）。
getNode() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回对 DOM Node 的引用（如果可用）。
getNode() - 类 javax.xml.crypto.dom.DOMStructure 中的方法
返回包含在此 DOMStructure 中的节点。
getNode() - 类 javax.xml.crypto.dsig.dom.DOMValidateContext 中的方法
返回节点。
getNode() - 类 javax.xml.transform.dom.DOMResult 中的方法
获取将包含结果 DOM 树的节点。
getNode() - 类 javax.xml.transform.dom.DOMSource 中的方法
获取表示 Source DOM 树的节点。
getNodeDimensions(Object, int, int, boolean, Rectangle) - 类 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler 中的方法
负责获取特定节点的大小。
getNodeDimensions() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回呈现树中节点的对象，它负责计算各个节点的尺寸。
getNodeDimensions(Object, int, int, boolean, Rectangle) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回通过 placeIn 中的引用，表示 value 所需的大小。
getNodeDimensions(Object, int, int, boolean, Rectangle) - 类 javax.swing.tree.AbstractLayoutCache.NodeDimensions 中的方法
通过对 bounds 的引用，返回用于保存值的节点的大小和其在 x 轴上的起点。
getNodeName() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回与此节点关联的节点名称。
getNodeName() - 接口 org.w3c.dom.Node 中的方法
此节点的名称，取决于其类型；参见上表。
getNodeType() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回节点类型，其始终为 ELEMENT_NODE。
getNodeType() - 接口 org.w3c.dom.Node 中的方法
表示基础对象的类型的节点，如上所述。
getNodeValue() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getNodeValue() - 接口 org.w3c.dom.Node 中的方法
此节点的值，取决于其类型；参见上表。
getNoFallbackControl(List<String>) - 类 java.util.ResourceBundle.Control 中的静态方法
返回一个 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats，getFallbackLocale 方法在其中返回 null。
getNoImageIcon() - 类 javax.swing.text.html.ImageView 中的方法
如果不能找到图像，则返回要使用的图标。
getNonContinuousLayoutDivider() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回要在将 splitPane 配置为非连续布局时使用的分隔符。
getNonCriticalExtensionOIDs() - 接口 java.security.cert.X509Extension 中的方法
获取实现此接口的对象所管理的证书/CRL 中，被标记为 NON-CRITICAL 的扩展的 OID 字符串 Set。
getNonHeapMemoryUsage() - 接口 java.lang.management.MemoryMXBean 中的方法
返回 Java 虚拟机使用的非堆内存的当前内存使用量。
getNonMatchingHeaders(String[]) - 类 javax.xml.soap.MimeHeaders 中的方法
返回其名称与给定名称数组中的任何名称都不匹配的所有 MimeHeader 对象。
getNonMatchingMimeHeaders(String[]) - 类 javax.xml.soap.AttachmentPart 中的方法
检索所有名称不匹配给定数组中任一名称的 MimeHeader 对象。
getNonMatchingMimeHeaders(String[]) - 类 javax.xml.soap.SOAPPart 中的方法
检索名称与给定数组中任一名称不匹配的所有 MimeHeader 对象。
getNonRolloverBorder(AbstractButton) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
返回按钮的非翻转边框。
getNoNSSchemaLocation() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
获取当前 noNamespaceSchemaLocation 的便捷方法。
getNormalBounds() - 类 javax.swing.JInternalFrame 中的方法
如果 JInternalFrame 未处于最大化状态，则返回 getBounds()；否则返回还原 JInternalFrame 后的边界。
getNormalizedComponents(int[], int, float[], int) - 类 java.awt.image.ColorModel 中的方法
在给定标准化分量数组的情况下，返回以标准化形式存在的所有颜色/alpha 分量的数组。
getNormalizedComponents(Object, float[], int) - 类 java.awt.image.ColorModel 中的方法
返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。
getNormalizedComponents(int[], int, float[], int) - 类 java.awt.image.ComponentColorModel 中的方法
在给定标准化分量数组的情况下，返回以标准化形式存在的所有颜色/alpha 分量的数组。
getNormalizedComponents(Object, float[], int) - 类 java.awt.image.ComponentColorModel 中的方法
返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。
getNormalizingTransform() - 类 java.awt.GraphicsConfiguration 中的方法
返回可与 GraphicsConfiguration 的默认 AffineTransform 连接的 AffineTransform，从而用户空间的 72 单位等于设备空间的 1 英寸。
getNorthPane() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getNotAfter() - 类 java.security.cert.X509Certificate 中的方法
获取证书有效期的 notAfter 日期。
getNotAfter() - 类 javax.security.cert.X509Certificate 中的方法
获取证书有效期的 notAfter 日期。
getNotationName() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
关联的注释的名称。
getNotationName() - 接口 org.w3c.dom.Entity 中的方法
对于未解析实体，则为该实体的表示法名称。
getNotations() - 接口 javax.xml.stream.events.DTD 中的方法
返回一个 List，其中包含在 DTD 中声明的注释。
getNotations() - 接口 org.w3c.dom.DocumentType 中的方法
包含在 DTD 中声明的表示法的 NamedNodeMap。
getNotBefore() - 类 java.security.cert.X509Certificate 中的方法
获取证书有效期的 notBefore 日期。
getNotBefore() - 类 javax.security.cert.X509Certificate 中的方法
获取证书有效期的 notBefore 日期。
getNote() - 类 javax.swing.ProgressMonitor 中的方法
指定随进度消息一起显示的其他注释。
getNotification(String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回通过名称请求的 ModelMBeanNotificationInfo。
getNotification(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getNotification() - 类 javax.management.remote.TargetedNotification 中的方法
发出的通知。
getNotification() - 类 javax.naming.ldap.UnsolicitedNotificationEvent 中的方法
返回未经请求的通知。
getNotificationID() - 类 javax.management.timer.TimerNotification 中的方法
获取此计时器通知的标识符。
getNotificationIDs(String) - 类 javax.management.timer.Timer 中的方法
获得所有与指定类型对应的计时器通知的标识符。
getNotificationIDs(String) - 接口 javax.management.timer.TimerMBean 中的方法
获得所有与指定类型对应的计时器通知的标识符。
getNotificationInfo() - 类 javax.management.MBeanServerDelegate 中的方法

getNotificationInfo() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
返回总是由 RequiredModelMBean 生成的 Notification 数组。
getNotificationInfo() - 类 javax.management.monitor.CounterMonitor 中的方法
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由计数器监视器发送的通知类型。
getNotificationInfo() - 类 javax.management.monitor.GaugeMonitor 中的方法
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由尺度监视器发送的通知类型。
getNotificationInfo() - 类 javax.management.monitor.StringMonitor 中的方法
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由字符串监视器发送的通知类型。
getNotificationInfo() - 接口 javax.management.NotificationBroadcaster 中的方法
返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。
getNotificationInfo() - 类 javax.management.NotificationBroadcasterSupport 中的方法

getNotificationInfo() - 类 javax.management.relation.RelationService 中的方法
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和发送的通知类型。
getNotificationInfo() - 类 javax.management.remote.JMXConnectorServer 中的方法
返回一个指示由该 MBean 发送的通知的数组。
getNotificationInfo() - 类 javax.management.StandardEmitterMBean 中的方法

getNotificationInfo() - 类 javax.management.timer.Timer 中的方法

getNotificationMessage(Integer) - 类 javax.management.timer.Timer 中的方法
获得与指定标识符对应的计时器通知的详细消息。
getNotificationMessage(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与指定的标识符对应的计时器通知的详细消息。
getNotifications() - 类 javax.management.MBeanInfo 中的方法
返回 MBean 所发出的通知列表。
getNotifications() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回 MBean 所发送的通知列表。
getNotifications() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回 MBeanNotificationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 所发出的每个通知。
getNotificationType(Integer) - 类 javax.management.timer.Timer 中的方法
获得与指定标识符对应的计时器通知类型。
getNotificationType(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与指定标识符对应的计时器通知类型。
getNotificationUserData(Integer) - 类 javax.management.timer.Timer 中的方法
获得与指定标识符对应的计时器通知用户数据对象。
getNotificationUserData(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与指定的标识符对应的计时器通知用户数据对象。
getNotifTypes() - 类 javax.management.MBeanNotificationInfo 中的方法
返回包含 MBean 可发出的通知类型的字符串数组（用点表示）。
getNotify() - 类 javax.management.monitor.CounterMonitor 中的方法
获取所有观察到的 MBeans 共同的通知的开/关切换值。
getNotify() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取通知的开/关切换值。
getNotifyDiffer() - 类 javax.management.monitor.StringMonitor 中的方法
获取所有观察到的 MBeans 共同的不同通知的开/关切换值。
getNotifyDiffer() - 接口 javax.management.monitor.StringMonitorMBean 中的方法
获取不同通知的开/关切换值。
getNotifyHigh() - 类 javax.management.monitor.GaugeMonitor 中的方法
获取所有观察到的 MBean 的公共高阈值通知 (high notification) 的开/关切换值。
getNotifyHigh() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取高阈值通知的开/关切换值。
getNotifyLow() - 类 javax.management.monitor.GaugeMonitor 中的方法
获取所有观察到的 MBean 的公共低阈值通知 (low notification) 的开/关切换值。
getNotifyLow() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取低阈值通知的开/关切换值。
getNotifyMatch() - 类 javax.management.monitor.StringMonitor 中的方法
获取所有观察到的 MBeans 共同的匹配通知的开/关切换值。
getNotifyMatch() - 接口 javax.management.monitor.StringMonitorMBean 中的方法
获取匹配的通知的开/关切换值。
getNoType(TypeKind) - 接口 javax.lang.model.util.Types 中的方法
返回在实际类型不适用的地方所使用的伪类型。
getNString(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。
getNString(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。
getNString(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
getNString(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
getNullFormatter() - 类 javax.swing.text.DefaultFormatterFactory 中的方法
返回值为 null 时使用的 formatter。
getNullType() - 接口 javax.lang.model.util.Types 中的方法
返回 null 类型。
getNumBands() - 类 java.awt.image.Raster 中的方法
返回此 Raster 中的 band 数（每像素样本）。
getNumBands() - 类 java.awt.image.SampleModel 中的方法
返回图像数据的总 band 数。
getNumBands() - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回此对象指定的 band 数。
getNumBanks() - 类 java.awt.image.DataBuffer 中的方法
返回此 DataBuffer 中存储单元的数量。
getNumber() - 类 javax.swing.SpinnerNumberModel 中的方法
返回该序列的当前元素的值。
getNumberFormat() - 类 java.text.DateFormat 中的方法
获取此日期/时间格式器用于格式化和解析时间的数字格式器。
getNumberInstance() - 类 java.text.NumberFormat 中的静态方法
返回当前默认语言环境的通用数值格式。
getNumberInstance(Locale) - 类 java.text.NumberFormat 中的静态方法
返回指定语言环境的通用数值格式。
getNumberInstance(Locale) - 类 java.text.spi.NumberFormatProvider 中的方法
为指定语言环境返回新的通用 NumberFormat 实例。
getNumberOfButtons() - 类 java.awt.MouseInfo 中的静态方法
返回鼠标上的按钮数。
getNumberOfPages() - 类 java.awt.print.Book 中的方法
返回此 Book 中的页数。
getNumberOfPages() - 接口 java.awt.print.Pageable 中的方法
返回集合中的页面数。
getNumberWaiting() - 类 java.util.concurrent.CyclicBarrier 中的方法
返回当前在屏障处等待的参与者数目。
getNumChars() - 类 java.awt.font.LineMetrics 中的方法
返回文本中的字符数量（char 值），该文本的规格由此 LineMetrics 对象封装。
getNumColorComponents() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 中颜色分量数。
getNumComponents() - 类 java.awt.color.ColorSpace 中的方法
返回此 ColorSpace 的分量数。
getNumComponents() - 类 java.awt.color.ICC_Profile 中的方法
返回配置文件的“输入”颜色空间中的颜色分量数。
getNumComponents() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 中分量数（包括 alpha 分量数）。
getNumComponents() - 类 java.awt.image.LookupTable 中的方法
返回查找表中的分量数。
getNumComponents() - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回此对象指定的颜色组件的数量。
getNumDataElements() - 类 java.awt.image.ComponentSampleModel 中的方法
返回使用 ComponentSampleModel.getDataElements(int, int, Object, DataBuffer) 和 ComponentSampleModel.setDataElements(int, int, Object, DataBuffer) 方法传输像素所需的数据元素的数量。
getNumDataElements() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回通过 MultiPixelPackedSampleModel.getDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) 和 MultiPixelPackedSampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) 方法传输一个像素所需的数据元素数。
getNumDataElements() - 类 java.awt.image.Raster 中的方法
返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。
getNumDataElements() - 类 java.awt.image.SampleModel 中的方法
返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。
getNumDataElements() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。
getNumDesignAxes() - 接口 java.awt.font.MultipleMaster 中的方法
返回 multiple master 设计控制的数量。
getNumericFunctions() - 接口 java.sql.DatabaseMetaData 中的方法
获取可用于此数据库的数学函数的逗号分隔列表。
getNumericValue(char) - 类 java.lang.Character 中的静态方法
返回指定的 Unicode 字符表示的 int 值。
getNumericValue(int) - 类 java.lang.Character 中的静态方法
返回指定字符（Unicode 代码点）表示的 int 值。
getNumFactors() - 类 java.awt.image.RescaleOp 中的方法
返回此 RescaleOp 中使用的缩放因子和偏移量的数量。
getNumGlyphs() - 类 java.awt.Font 中的方法
返回此 Font 中的字形数量。
getNumGlyphs() - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 中的字形数。
getNumImages(boolean) - 类 javax.imageio.ImageReader 中的方法
返回当前输入源中可用的图像数，不包括缩略图。
getNumParameters() - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回参数的数量（不包括源图像）。
getNumSources() - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回源图像的数量。
getNumThumbnails() - 类 javax.imageio.IIOImage 中的方法
返回此 IIOImage 中存储的缩略图的数量。
getNumThumbnails(int) - 类 javax.imageio.ImageReader 中的方法
返回与给定图像关联的缩略图预览图像的数量。
getNumThumbnailsSupported(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata) - 类 javax.imageio.ImageWriter 中的方法
返回受将写入的格式、给定图像类型和任何其他 write 参数支持的缩略图，以及将在编码期间使用的元数据对象。
getNumXTiles() - 类 java.awt.image.BufferedImage 中的方法
返回 x 方向的 tile 数。
getNumXTiles() - 接口 java.awt.image.RenderedImage 中的方法
返回 X 方向的 tile 数量。
getNumYTiles() - 类 java.awt.image.BufferedImage 中的方法
返回 y 方向的 tile 数。
getNumYTiles() - 接口 java.awt.image.RenderedImage 中的方法
返回 Y 方向的 tile 数量。
getObject() - 类 java.security.GuardedObject 中的方法
获取受保护对象；如果 guard 拒绝了对受保护对象的访问，则抛出异常。
getObject() - 类 java.security.SignedObject 中的方法
获取已封装的对象。
getObject(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Object 的形式获取指定参数的值。
getObject(int, Map<String, Class<?>>) - 接口 java.sql.CallableStatement 中的方法
返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。
getObject(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Object 的形式获取参数的值。
getObject(String, Map<String, Class<?>>) - 接口 java.sql.CallableStatement 中的方法
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。
getObject(Map<String, Class<?>>) - 接口 java.sql.Ref 中的方法
获取引用对象并使用给定类型映射表将其映射到 Java 类型。
getObject() - 接口 java.sql.Ref 中的方法
获取此 Ref 对象引用的 SQL 结构类型实例。
getObject(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
getObject(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
getObject(int, Map<String, Class<?>>) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
getObject(String, Map<String, Class<?>>) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
getObject(String) - 类 java.util.ResourceBundle 中的方法
从此资源包或它的某个父包中获取给定键的对象。
getObject(Key) - 类 javax.crypto.SealedObject 中的方法
获取原始（封装的）对象。
getObject(Cipher) - 类 javax.crypto.SealedObject 中的方法
获取原始（封装的）对象。
getObject(Key, String) - 类 javax.crypto.SealedObject 中的方法
获取原始（封装的）对象。
getObject() - 类 javax.naming.Binding 中的方法
检索绑定到此绑定名称的对象。
getObject() - 类 javax.naming.spi.DirStateFactory.Result 中的方法
检索要绑定的对象。
getObject() - 类 javax.sql.rowset.serial.SerialJavaObject 中的方法
返回一个 Object，它是此 SerialJavaObject 对象的副本。
getObject(Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialRef 中的方法
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
getObject() - 类 javax.sql.rowset.serial.SerialRef 中的方法
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
getObject() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getObject() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回对 Java 内容树中对象的引用（如果可用）。
getObjectArrayMaxLength(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回指定元素中可用于定义 Object 引用的最大数组元素数。
getObjectArrayMaxLength(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectArrayMinLength(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回指定元素中可用于定义 Object 引用的最小数组元素数。
getObjectArrayMinLength(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectClass(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回存储在元素中的 Class 类型的 Object 引用。
getObjectClass(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectDefaultValue(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回包含指定元素中 Object 引用的默认值的 Object。
getObjectDefaultValue(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectEnumerations(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回一个 Object 数组，该数组包含指定元素中 Object 引用的合法枚举值。
getObjectEnumerations(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectForLayer(int) - 类 javax.swing.JLayeredPane 中的方法
返回与指定层关联的 Integer 对象。
getObjectInstance(ObjectName) - 接口 javax.management.MBeanServer 中的方法

getObjectInstance(ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
getObjectInstance(ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
getObjectInstance(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getObjectInstance(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes) - 类 javax.naming.spi.DirectoryManager 中的静态方法
为指定对象、属性和环境创建一个对象实例。
getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes) - 接口 javax.naming.spi.DirObjectFactory 中的方法
使用位置或引用信息以及指定的属性创建一个对象。
getObjectInstance(Object, Name, Context, Hashtable<?, ?>) - 类 javax.naming.spi.NamingManager 中的静态方法
为指定对象和环境创建一个对象实例。
getObjectInstance(Object, Name, Context, Hashtable<?, ?>) - 接口 javax.naming.spi.ObjectFactory 中的方法
使用指定的位置或引用信息创建一个对象。
getObjectMaxValue(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回指定元素中 Object 引用的最大合法值。
getObjectMaxValue(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectMinValue(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回指定元素中 Object 引用的最小合法值。
getObjectMinValue(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectName() - 类 javax.management.MBeanServerInvocationHandler 中的方法
MBean 服务器中 MBean 的名称，一些方法将转发到该 MBean。
getObjectName() - 类 javax.management.ObjectInstance 中的方法
返回对象名部分。
getObjectName() - 类 javax.management.relation.RelationNotification 中的方法
返回创建/移除/更新的关系的 ObjectName。
getObjectParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
获取作为对象的参数。
getObjectPendingFinalizationCount() - 接口 java.lang.management.MemoryMXBean 中的方法
返回其终止被挂起的对象的近似数目。
getObjects() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
返回一个可修改的列表，由包含在此 XMLSignature 中的 XMLObject 组成。
getObjectSize(Object) - 接口 java.lang.instrument.Instrumentation 中的方法
返回指定对象使用的特定于实现的近似存储量。
getObjectStreamClass() - 类 java.io.ObjectInputStream.GetField 中的方法
获取描述流中字段的 ObjectStreamClass。
getObjectValueType(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回以 VALUE_ 开头的枚举值之一，指示允许用于 Object 引用的值（枚举、范围或数组）的类型。
getObjectValueType(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObservedAttribute() - 类 javax.management.monitor.Monitor 中的方法
获取要观察的属性。
getObservedAttribute() - 接口 javax.management.monitor.MonitorMBean 中的方法
获取要观察的属性。
getObservedAttribute() - 类 javax.management.monitor.MonitorNotification 中的方法
获取此监视器通知的被观察属性。
getObservedObject() - 类 javax.management.monitor.Monitor 中的方法
已过时。 从 JMX 1.2 开始，由 Monitor.getObservedObjects() 取代
getObservedObject() - 接口 javax.management.monitor.MonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 MonitorMBean.getObservedObjects() 取代
getObservedObject() - 类 javax.management.monitor.MonitorNotification 中的方法
获取此监视器通知的被观察对象。
getObservedObjects() - 类 javax.management.monitor.Monitor 中的方法
返回一个包含要观察的对象的数组。
getObservedObjects() - 接口 javax.management.monitor.MonitorMBean 中的方法
返回一个包含要观察的对象的数组。
getOctetStream() - 类 javax.xml.crypto.OctetStreamData 中的方法
返回此 OctetStreamData 的输入流。
getOffendingNode() - 异常 javax.imageio.metadata.IIOInvalidTreeException 中的方法
返回导致解析错误的 Node。
getOffscreenBuffer(Component, int, int) - 类 javax.swing.RepaintManager 中的方法
返回屏幕外缓冲区，它应用作带有组件 c 的双缓冲区。
getOffset(int, int) - 类 java.awt.image.ComponentSampleModel 中的方法
获取像素 (x,y) 的第一个 band 的偏移量。
getOffset(int, int, int) - 类 java.awt.image.ComponentSampleModel 中的方法
获取像素 (x,y) 的 band b 的偏移量。
getOffset() - 类 java.awt.image.DataBuffer 中的方法
返回数组元素中默认存储单元的偏移量。
getOffset() - 类 java.awt.image.LookupTable 中的方法
返回偏移量。
getOffset(int, int) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回数据数组元素中像素 (x, y) 的偏移量。
getOffset(int, int) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回像素 (x,y)（在数据数组元素中）的偏移量。
getOffset() - 类 java.io.ObjectStreamField 中的方法
实例数据中字段的偏移量。
getOffset() - 类 java.net.DatagramPacket 中的方法
返回将要发送或接收到的数据的偏移量。
getOffset() - 类 java.text.CollationElementIterator 中的方法
返回源文本中对应于下一个 collation 元素的字符偏移量。
getOffset(long) - 类 java.util.SimpleTimeZone 中的方法
从给定时间的 UTC 返回此时区的偏移量。
getOffset(int, int, int, int, int, int) - 类 java.util.SimpleTimeZone 中的方法
返回以毫秒为单位的本地时间与 UTC 之间的差别，对于指定日期和时间，把原始偏移量和夏令时的效果同时考虑在内。
getOffset(int, int, int, int, int, int) - 类 java.util.TimeZone 中的方法
获取当前日期的时区偏移量（在夏令时情况下进行修改）。
getOffset(long) - 类 java.util.TimeZone 中的方法
从给定日期的 UTC 返回此时区的偏移量。
getOffset() - 类 javax.imageio.stream.IIOByteBuffer 中的方法
返回 getData 返回的字节数组中的偏移量，感兴趣的数据从该处开始。
getOffset() - 类 javax.management.monitor.CounterMonitor 中的方法
获取所有观察到的 MBeans 共同的偏移量值。
getOffset() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取偏移值。
getOffset() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的枚举类使用的最小整数值。
getOffset() - 类 javax.print.attribute.standard.Finishings 中的方法
返回 Finishings 类所使用的最小整数值。
getOffset() - 类 javax.print.attribute.standard.OrientationRequested 中的方法
返回类 OrientationRequested 所使用的最小整数值。
getOffset() - 类 javax.print.attribute.standard.PrintQuality 中的方法
返回类 PrintQuality 所使用的最小整数值。
getOffset() - 接口 javax.swing.event.DocumentEvent 中的方法
返回文档中更改开始的偏移量。
getOffset() - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法

getOffset() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
返回文档中更改开始位置的偏移量。
getOffset(int, int) - 类 javax.swing.text.BoxView 中的方法
获取特定子级当前布局的偏移量。
getOffset() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得起始偏移量。
getOffset() - 接口 javax.swing.text.Position 中的方法
获取文档内的当前偏移量。
getOffset() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getOffset() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回字节偏移量（如果可用）。
getOffsetHit(int) - 类 java.awt.font.TextHitInfo 中的方法
创建一个 TextHitInfo，其字符索引从此 TextHitInfo 的 charIndex 偏移 delta。
getOffsets() - 类 java.awt.image.DataBuffer 中的方法
返回所有存储单元的偏移量（按数组元素）。
getOffsets(float[]) - 类 java.awt.image.RescaleOp 中的方法
返回给定数组中的偏移量。
getOldBinding() - 类 javax.naming.event.NamingEvent 中的方法
检索更改前对象的绑定。
getOldLeadSelectionPath() - 类 javax.swing.event.TreeSelectionEvent 中的方法
返回以前是前导路径的路径。
getOldRoleValue() - 类 javax.management.relation.RelationNotification 中的方法
返回更新的角色的旧值（仅限于角色更新）。
getOldState() - 类 java.awt.event.WindowEvent 中的方法
对于 WINDOW_STATE_CHANGED 事件，返回以前的窗口状态。
getOldValue() - 类 java.beans.PropertyChangeEvent 中的方法
获取属性的旧值，以 Object 的形式表示。
getOldValue() - 类 javax.management.AttributeChangeNotification 中的方法
获得已更改属性的旧值。
getOmni() - 接口 javax.sound.midi.MidiChannel 中的方法
获得当前的 omni 模式。
getOOBInline() - 类 java.net.Socket 中的方法
测试是否启用 OOBINLINE。
getOpenIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回用于表示扩展的非叶节点的图标。
getOpenType() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性值的开放类型。
getOpenType() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此 OpenMBeanParameterInfo 实例描述的参数值的开放类型。
getOpenType() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例描述的参数值的开放类型。
getOperatingSystemMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回运行 Java 虚拟机的操作系统的管理 Bean。
getOperation() - 类 java.rmi.server.Operation 中的方法
已过时。 无替代版本
getOperation(String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回通过名称请求的 ModelMBeanOperationInfo。
getOperation(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getOperations() - 接口 java.rmi.server.Skeleton 中的方法
已过时。 无替代版本
getOperations() - 类 javax.management.MBeanInfo 中的方法
返回 MBean 的操作列表。
getOperations() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回 MBean 的操作列表。
getOperations() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回 OpenMBeanOperationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例所描述的 open MBean 中的每个操作。
getOppositeComponent() - 类 java.awt.event.FocusEvent 中的方法
返回此焦点更改中涉及的另一个 Component。
getOppositeWindow() - 类 java.awt.event.WindowEvent 中的方法
返回在此焦点或活动性变化中所涉及的其他 Window。
getOptimizeHuffmanTables() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
返回传入对 setOptimizeHuffmanTables 的最近一次调用中的值；如果从未调用 setOptimizeHuffmanTables，则返回 false。
getOption(int) - 接口 java.net.SocketOptions 中的方法
获取选项的值。
getOptions() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回传递给注释处理工具的特定于 processor 的选项。
getOptions() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取确认选项。
getOptions() - 类 javax.security.auth.login.AppConfigurationEntry 中的方法
获取为此 LoginModule 配置的选项。
getOptions() - 类 javax.swing.JOptionPane 中的方法
返回用户可以作出的选择。
getOptionType() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取选项类型。
getOptionType() - 类 javax.swing.JOptionPane 中的方法
返回显示的选项类型。
getOrder() - 类 java.security.spec.ECParameterSpec 中的方法
返回生成器的顺序。
getOrientation() - 接口 java.awt.Adjustable 中的方法
获取此可调整对象的方向。
getOrientation(Locale) - 类 java.awt.ComponentOrientation 中的静态方法
返回适合于给定区域的方向。
getOrientation(ResourceBundle) - 类 java.awt.ComponentOrientation 中的静态方法
已过时。 在 J2SE 1.4 中，使用 ComponentOrientation.getOrientation(java.util.Locale)。
getOrientation() - 类 java.awt.print.PageFormat 中的方法
返回此 PageFormat 的方向。
getOrientation() - 类 java.awt.Scrollbar 中的方法
返回此滚动条的方向。
getOrientation() - 类 java.awt.ScrollPaneAdjustable 中的方法
返回此滚动条的方向。
getOrientation() - 类 javax.swing.JProgressBar 中的方法
根据进度条的方向返回 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。
getOrientation() - 类 javax.swing.JScrollBar 中的方法
返回组件的方向（横向或纵向）。
getOrientation() - 类 javax.swing.JSeparator 中的方法
返回此分隔符的方向。
getOrientation() - 类 javax.swing.JSlider 中的方法
返回此滑块的垂直或者水平方向。
getOrientation() - 类 javax.swing.JSplitPane 中的方法
返回方向。
getOrientation() - 类 javax.swing.JToolBar 中的方法
返回工具栏的当前方向。
getOrientation() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回 JSplitPane 的方向。
getOrientation() - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法
当工具栏浮动时，返回工具栏窗口的方向。
getOrientationRequested() - 类 java.awt.PageAttributes 中的方法
返回使用这些属性的页面的打印方向。
getOrigin() - 类 java.awt.PageAttributes 中的方法
返回在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。
getOriginal() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回一个包含此 CachedRowSet 对象原始值的 ResultSet 对象。
getOriginal() - 接口 javax.sql.RowSetInternal 中的方法
获取包含此 RowSet 对象原始值的 ResultSet 对象。
getOriginalRow() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回一个只包含此 CachedRowSet 对象当前行原始值的 ResultSet 对象。
getOriginalRow() - 接口 javax.sql.RowSetInternal 中的方法
获取仅包含当前行原始值的 ResultSet 对象。
getOriginatingNode() - 接口 javax.xml.transform.dom.DOMLocator 中的方法
返回事件发生的节点位置。
getOriginatingProvider() - 类 javax.imageio.ImageReader 中的方法
返回传入构造方法的 ImageReaderSpi。
getOriginatingProvider() - 类 javax.imageio.ImageWriter 中的方法
返回创建此 ImageWriter 的 ImageWriterSpi 对象，如果此对象不是通过 IIORegistry 创建的，则返回 null。
getOtherHit() - 类 java.awt.font.TextHitInfo 中的方法
在插入点的另一侧创建一个 TextHitInfo。
getOtherPrimeInfo() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 otherPrimeInfo；如果仅存在两个素数因子（p 和 q），则返回 null。
getOtherPrimeInfo() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 otherPrimeInfo 的副本，如果仅有两个素数因子（p 和 q），则返回 null。
getOutline() - 类 java.awt.font.GlyphVector 中的方法
返回其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。
getOutline(float, float) - 类 java.awt.font.GlyphVector 中的方法
返回在 x、y 处呈现时，其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。
getOutline(AffineTransform) - 类 java.awt.font.GraphicAttribute 中的方法
返回表示此 GraphicAttribute 呈现区域的 Shape。
getOutline(AffineTransform) - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回一个表示此 ShapeGraphicAttribute 呈现区域的 Shape。
getOutline(AffineTransform) - 类 java.awt.font.TextLayout 中的方法
返回表示此 TextLayout 的轮廓的 Shape。
getOutput() - 类 javax.imageio.ImageWriter 中的方法
返回 ImageOutputStream 或最近一次调用 setOutput 方法设置的其他 Object如果没有设置目标，则返回 null。
getOutputClass() - 类 javax.imageio.spi.ImageOutputStreamSpi 中的方法
返回表示必须由输出目标位置实现（以便使用 createOutputStreamInstance 方法在 ImageOutputStream 中“包装”）的类或接口的类型的 Class 对象。
getOutputFormat() - 类 javax.print.StreamPrintService 中的方法
返回此 PrintService 所发出的文档格式。
getOutputFormat() - 类 javax.print.StreamPrintServiceFactory 中的方法
查询该工厂，了解从此工厂获得的打印机所发出的文档的格式。
getOutputLength() - 类 javax.xml.crypto.dsig.spec.HMACParameterSpec 中的方法
返回截断长度。
getOutputProperties() - 接口 javax.xml.transform.Templates 中的方法
获取对应于有效 xsl:output 元素的属性。
getOutputProperties() - 类 javax.xml.transform.Transformer 中的方法
获取转换的输出属性的副本。
getOutputProperty(String) - 类 javax.xml.transform.Transformer 中的方法
获取对转换器有效的输出属性。
getOutputSize(int) - 类 javax.crypto.Cipher 中的方法
根据给定的输入长度 inputLen（以字节为单位），返回保存下一个 update 或 doFinal 操作结果所需的输出缓冲区长度（以字节为单位）。
getOutputSize(int) - 类 javax.crypto.ExemptionMechanism 中的方法
根据给定的输入长度 inputLen（以字节为单位），返回保存下一个 genExemptionBlob 操作结果所需的输出缓冲区长度（以字节为单位）。
getOutputStatement(String) - 接口 javax.script.ScriptEngineFactory 中的方法
返回一个 String，该 String 可用作一个语句来显示使用受支持脚本语言语法的指定 String。
getOutputStream() - 类 java.lang.Process 中的方法
获取子进程的输出流。
getOutputStream() - 类 java.net.Socket 中的方法
返回此套接字的输出流。
getOutputStream() - 类 java.net.SocketImpl 中的方法
返回此套接字的输出流。
getOutputStream() - 类 java.net.URLConnection 中的方法
返回写入到此连接的输出流。
getOutputStream() - 类 java.rmi.server.LogStream 中的方法
已过时。 无替代版本
getOutputStream() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
getOutputStream() - 类 javax.activation.DataHandler 中的方法
获取此 DataHandler 的 OutputStream，以允许重写底层数据。
getOutputStream() - 接口 javax.activation.DataSource 中的方法
此方法返回一个可以写入数据的 OutputStream，如果无法返回，则抛出适当的异常。
getOutputStream() - 类 javax.activation.FileDataSource 中的方法
此方法将返回一个表示数据的 OutputStream；如果不能返回，则抛出 IOException。
getOutputStream() - 类 javax.activation.URLDataSource 中的方法
URL 的 getOutputStream 方法。
getOutputStream() - 类 javax.print.StreamPrintService 中的方法
获得输出流。
getOutputStream() - 类 javax.xml.transform.stream.StreamResult 中的方法
获取通过 setOutputStream 设置的字节流。
getOutputTypes() - 类 javax.imageio.spi.ImageWriterSpi 中的方法
返回 Class 对象数组，指示可用作 setOutput 方法参数的对象类型。
getOutsideBorder() - 类 javax.swing.border.CompoundBorder 中的方法
返回外部边框对象。
getOverwriteMode() - 类 javax.swing.text.DefaultFormatter 中的方法
返回插入字符时的行为。
getOwnedWindows() - 类 java.awt.Window 中的方法
返回包含此窗口当前拥有的所有窗口的数组。
getOwner() - 类 java.awt.Window 中的方法
返回此窗口的所有者。
getOwner() - 类 java.beans.XMLDecoder 中的方法
获得此解码器的所有者。
getOwner() - 类 java.beans.XMLEncoder 中的方法
获得此编码器的所有者。
getOwner() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回目前拥有此锁的线程，如果此锁不被任何线程拥有，则返回 null。
getOwner() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回当前拥有写入锁的线程，如果没有这样的线程，则返回 null。
getOwnerDocument() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回 null，因为 IIOMetadataNode 不属于任何 Document。
getOwnerDocument() - 接口 org.w3c.dom.Node 中的方法
与此节点相关的 Document 对象。
getOwnerElement() - 接口 org.w3c.dom.Attr 中的方法
此属性连接到的 Element 节点；如果未使用此属性，则为 null。
getOwnerlessWindows() - 类 java.awt.Window 中的静态方法
返回一个数组，该数组由此应用程序创建的所有没有所有者的 Window 组成。
getOwnerType() - 接口 java.lang.reflect.ParameterizedType 中的方法
返回 Type 对象，表示此类型是其成员之一的类型。
getP() - 接口 java.security.interfaces.DSAParams 中的方法
返回素数 p。
getP() - 类 java.security.spec.DSAParameterSpec 中的方法
返回素数 p。
getP() - 类 java.security.spec.DSAPrivateKeySpec 中的方法
返回素数 p。
getP() - 类 java.security.spec.DSAPublicKeySpec 中的方法
返回素数 p。
getP() - 类 java.security.spec.ECFieldFp 中的方法
返回此素数有限字段的素数 p。
getP() - 类 javax.crypto.spec.DHParameterSpec 中的方法
返回质数模数 p。
getP() - 类 javax.crypto.spec.DHPrivateKeySpec 中的方法
返回质数模数 p。
getP() - 类 javax.crypto.spec.DHPublicKeySpec 中的方法
返回质数模数 p。
getP1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
返回起始点。
getP1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
返回起始点。
getP1() - 类 java.awt.geom.CubicCurve2D 中的方法
返回起始点。
getP1() - 类 java.awt.geom.Line2D.Double 中的方法
返回此 Line2D 的起始 Point2D。
getP1() - 类 java.awt.geom.Line2D.Float 中的方法
返回此 Line2D 的起始 Point2D。
getP1() - 类 java.awt.geom.Line2D 中的方法
返回此 Line2D 的起始 Point2D。
getP1() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
返回起始点。
getP1() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
返回起始点。
getP1() - 类 java.awt.geom.QuadCurve2D 中的方法
返回起始点。
getP2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
返回结束点。
getP2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
返回结束点。
getP2() - 类 java.awt.geom.CubicCurve2D 中的方法
返回结束点。
getP2() - 类 java.awt.geom.Line2D.Double 中的方法
返回此 Line2D 的结束 Point2D。
getP2() - 类 java.awt.geom.Line2D.Float 中的方法
返回此 Line2D 的结束 Point2D。
getP2() - 类 java.awt.geom.Line2D 中的方法
返回此 Line2D 的结束 Point2D。
getP2() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
返回结束点。
getP2() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
返回结束点。
getP2() - 类 java.awt.geom.QuadCurve2D 中的方法
返回结束点。
getPackage() - 类 java.lang.Class 中的方法
获取此类的包。
getPackage(String) - 类 java.lang.ClassLoader 中的方法
返回由此类加载器或其任何祖先所定义的 Package。
getPackage(String) - 类 java.lang.Package 中的静态方法
通过调用方的 ClassLoader 实例中的名称找到一个包。
getPackageElement(CharSequence) - 接口 javax.lang.model.util.Elements 中的方法
返回已给出其完全限定名称的包。
getPackageOf(Element) - 接口 javax.lang.model.util.Elements 中的方法
返回元素的包。
getPackages() - 类 java.lang.ClassLoader 中的方法
返回此类加载器及其祖先所定义的所有 Package。
getPackages() - 类 java.lang.Package 中的静态方法
获得调用方的 ClassLoader 实例当前已知的所有包。
getPacketBufferSize() - 接口 javax.net.ssl.SSLSession 中的方法
获取使用此会话时期望的最大 SSL/TLS 包的当前大小。
getPadding() - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法

getPage() - 类 javax.swing.JEditorPane 中的方法
获得当前正在显示的 URL。
getPageDimension() - 类 java.awt.PrintJob 中的方法
返回页面的维数，以像素为单位。
getPageFormat(int) - 类 java.awt.print.Book 中的方法
返回 pageIndex 指定的页面的 PageFormat。
getPageFormat(int) - 接口 java.awt.print.Pageable 中的方法
返回 pageIndex 指定的页面的 PageFormat。
getPageFormat(PrintRequestAttributeSet) - 类 java.awt.print.PrinterJob 中的方法
使用与受此作业 PrintService 支持的那些值一致的值（即由 getPrintService() 返回的值），以及 attributes 中包含的介质、可打印区域和方向计算 PageFormat。
getPageIncrement() - 类 java.awt.Scrollbar 中的方法
已过时。 从 JDK version 1.1 开始，由 getBlockIncrement() 取代。
getPageRanges() - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的页面范围。
getPageResolution() - 类 java.awt.PrintJob 中的方法
返回页面的分辨率，以每英寸的像素为单位。
getPageSize() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回 CachedRowSet 对象的页大小。
getPaint() - 类 java.awt.Graphics2D 中的方法
返回 Graphics2D 上下文中的当前 Paint
getPainter(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回将用于绘制的 SynthPainter。
getPainter(GlyphView, int, int) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
创建用于给定 GlyphView 的 painter。
getPainter() - 接口 javax.swing.text.Highlighter.Highlight 中的方法
获取 highlighter 的 painter。
getPaintLabels() - 类 javax.swing.JSlider 中的方法
告知是否绘制标签。
getPaintTicks() - 类 javax.swing.JSlider 中的方法
告知是否绘制刻度标记。
getPaintTrack() - 类 javax.swing.JSlider 中的方法
告知是否绘制滑道（滑块滑动的区域）。
getPaper() - 类 java.awt.print.PageFormat 中的方法
返回与此 PageFormat 相关的 Paper 对象的一个副本。
getParagraphAttributes() - 类 javax.swing.JTextPane 中的方法
获取插入符号位置的当前有效段落属性，如果没有，则返回 null。
getParagraphElement(int) - 类 javax.swing.text.AbstractDocument 中的方法
获得包含给定位置的段落元素。
getParagraphElement(int) - 类 javax.swing.text.DefaultStyledDocument 中的方法
获得位于偏移量 pos 的段落元素。
getParagraphElement(int) - 类 javax.swing.text.PlainDocument 中的方法
获取包含给定位置的段落元素。
getParagraphElement(int) - 接口 javax.swing.text.StyledDocument 中的方法
获取表示包含文档中给定偏移量的段落的元素。
getParagraphElement(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定某个段落/行要使用的元素。
getParamClasses() - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回描述该参数的 Class 对象的数组。
getParameter(String) - 类 java.applet.Applet 中的方法
返回 HTML 标记中指定参数的值。
getParameter(String) - 接口 java.applet.AppletStub 中的方法
返回 HTML 标记中命名参数的值。
getParameter(String) - 类 java.awt.datatransfer.DataFlavor 中的方法
如果 paramName 等于 "humanPresentableName"，则返回此 DataFlavor 的得体的名称。
getParameter(String) - 类 java.security.Signature 中的方法
已过时。
getParameter() - 异常 java.sql.DataTruncation 中的方法
指示被截断的值是一个参数值还是一个列值。
getParameter(String) - 类 javax.activation.MimeType 中的方法
获取与给定名称关联的值；如果没有当前关联，则返回 null。
getParameter(String) - 类 javax.print.DocFlavor 中的方法
返回表示 MIME 参数的 String。
getParameter(String) - 接口 javax.script.ScriptEngineFactory 中的方法
返回属性值，该属性的含义可能是特定于实现的。
getParameter(String) - 类 javax.xml.transform.Transformer 中的方法
获取通过 setParameter 显式设置的参数。
getParameter(String) - 接口 org.w3c.dom.DOMConfiguration 中的方法
如果已知，则返回参数的值。
getParameterAnnotations() - 类 java.lang.reflect.Constructor 中的方法
按照声明顺序返回一组数组，这些数组表示通过此 Constructor 对象表示的方法的形参上的注释。
getParameterAnnotations() - 类 java.lang.reflect.Method 中的方法
返回表示按照声明顺序对此 Method 对象所表示方法的形参进行注释的那个数组的数组。
getParameterBlock() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
返回到对当前参数块的一个引用。
getParameterClassName(int) - 接口 java.sql.ParameterMetaData 中的方法
获取 Java 类的完全限定名称，该类的实例应该传递给 PreparedStatement.setObject 方法。
getParameterCount() - 接口 java.sql.ParameterMetaData 中的方法
获取 PreparedStatement 对象中的参数的数量，此 ParameterMetaData 对象包含了该对象的信息。
getParameterDescriptors() - 类 java.beans.MethodDescriptor 中的方法
获得此 MethodDescriptor 每个方法参数的 ParameterDescriptor。
getParameterInfo() - 类 java.applet.Applet 中的方法
返回此 applet 理解的关于参数的信息。
getParameterMetaData() - 接口 java.sql.PreparedStatement 中的方法
获取此 PreparedStatement 对象的参数的编号、类型和属性。
getParameterMode(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的模式。
getParameterName(MBeanConstructorInfo, MBeanParameterInfo, int) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的名称。
getParameterName(MBeanOperationInfo, MBeanParameterInfo, int) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的名称。
getParameterNames() - 接口 org.w3c.dom.DOMConfiguration 中的方法
此 DOMConfiguration 对象支持的参数列表，并且应用程序至少可以为其设置一个值。
getParameters() - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回参数的整个 Vector。
getParameters() - 类 java.security.Policy 中的方法
返回 Policy 参数。
getParameters() - 类 java.security.Signature 中的方法
返回与此签名对象一起使用的参数。
getParameters() - 类 java.util.logging.LogRecord 中的方法
获取日志消息的参数。
getParameters() - 类 javax.activation.MimeType 中的方法
获取此对象的参数列表。
getParameters() - 类 javax.crypto.Cipher 中的方法
返回此 Cipher 使用的参数。
getParameters() - 接口 javax.lang.model.element.ExecutableElement 中的方法
返回此 executable 的形参。
getParameters() - 类 javax.net.ssl.CertPathTrustManagerParameters 中的方法
返回此类封装的 CertPathParameters 的副本。
getParameters() - 类 javax.net.ssl.KeyStoreBuilderParameters 中的方法
返回此对象封装的不可修改的 KeyStore.Builder 列表。
getParameters() - 类 javax.security.auth.login.Configuration 中的方法
返回 Configuration 参数。
getParameterSpec(Class<T>) - 类 java.security.AlgorithmParameters 中的方法
返回此参数对象的（透明）规范。
getParameterSpec() - 接口 javax.xml.crypto.AlgorithmMethod 中的方法
返回此 AlgorithmMethod 的算法参数。
getParameterSpec() - 接口 javax.xml.crypto.dsig.CanonicalizationMethod 中的方法
返回与此 CanonicalizationMethod 关联的特定于算法的输入参数。
getParameterSpec() - 接口 javax.xml.crypto.dsig.DigestMethod 中的方法
返回与此 DigestMethod 关联的特定于算法的输入参数。
getParameterSpec() - 接口 javax.xml.crypto.dsig.SignatureMethod 中的方法
返回此 SignatureMethod 的特定于算法的输入参数。
getParameterSpec() - 接口 javax.xml.crypto.dsig.Transform 中的方法
返回与此 Transform 关联的特定于算法的输入参数。
getParameterType(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的 SQL 类型。
getParameterTypeName(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的特定于数据库的类型名称。
getParameterTypes() - 类 java.lang.reflect.Constructor 中的方法
按照声明顺序返回一组 Class 对象，这些对象表示此 Constructor 对象所表示构造方法的形参类型。
getParameterTypes() - 类 java.lang.reflect.Method 中的方法
按照声明顺序返回 Class 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型。
getParameterTypes() - 接口 javax.lang.model.type.ExecutableType 中的方法
返回此 executable 的形参类型。
getParameterTypes() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记中每个嵌套 <PARAM> 标记中的 TYPE 属性值的列表。
getParameterValues() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记中每个嵌套 <PARAM> 标记中的 VALUE 属性值的列表。
getParams() - 接口 java.security.interfaces.DSAKey 中的方法
返回特定于 DSA 的密钥参数。
getParams() - 接口 java.security.interfaces.ECKey 中的方法
返回与此密钥关联的域参数。
getParams() - 类 java.security.spec.ECPrivateKeySpec 中的方法
返回关联的椭圆曲线域参数。
getParams() - 类 java.security.spec.ECPublicKeySpec 中的方法
返回关联的椭圆曲线域参数。
getParams() - 接口 javax.crypto.interfaces.DHKey 中的方法
返回密钥参数。
getParams() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取一个数组，其中包含为此 RowSet 对象命令设置的参数值（包括 Object 和基本类型），如果尚未设置任何参数，则抛出 SQLException 对象。
getParams() - 接口 javax.sql.RowSetInternal 中的方法
获取已为此 RowSet 对象的命令设置的参数。
getParent() - 类 java.awt.Component 中的方法
获取此组件的父级。
getParent() - 类 java.awt.image.Raster 中的方法
返回此 Raster 的父 Raster（如果有），或者 null。
getParent() - 类 java.awt.MenuComponent 中的方法
返回此菜单组件的父容器。
getParent() - 类 java.awt.PopupMenu 中的方法
返回此菜单组件的父容器。
getParent() - 类 java.io.File 中的方法
返回此抽象路径名父目录的路径名字符串；如果此路径名没有指定父目录，则返回 null。
getParent() - 类 java.lang.ClassLoader 中的方法
返回委托的父类加载器。
getParent() - 类 java.lang.ThreadGroup 中的方法
返回此线程组的父线程组。
getParent() - 类 java.net.NetworkInterface 中的方法
如果此接口是子接口，则返回它的父 NetworkInterface；如果它是物理（非虚拟）接口或没有父接口，则返回 null。
getParent() - 接口 java.security.cert.PolicyNode 中的方法
返回此节点的父节点，如果此节点是根节点，则返回 null。
getParent() - 类 java.util.logging.Logger 中的方法
返回此 Logger 的父 logger。
getParent() - 类 java.util.prefs.NodeChangeEvent 中的方法
返回添加或移除节点的父节点。
getParent() - 类 javax.swing.ActionMap 中的方法
返回此 ActionMap 的父级。
getParent() - 类 javax.swing.InputMap 中的方法
获得此 InputMap 的父级。
getParent() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
返回接收方的父级 TreeNode。
getParent() - 类 javax.swing.text.View 中的方法
返回视图的父级。
getParent() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的父节点，如果此节点没有父节点，则返回 null。
getParent() - 接口 javax.swing.tree.TreeNode 中的方法
返回接收者的父 TreeNode。
getParent() - 类 javax.xml.crypto.dsig.dom.DOMSignContext 中的方法
返回父节点。
getParent() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
获取此实例的父实例。
getParent() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
获取此实例的父实例。
getParent() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
获取父读取器。
getParent() - 接口 org.xml.sax.XMLFilter 中的方法
获取父阅读器。
getParentDirectory(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
返回 dir 的父目录。
getParentElement() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素的父级。
getParentElement() - 接口 javax.swing.text.Element 中的方法
获得父元素。
getParentElement() - 接口 javax.xml.soap.Node 中的方法
返回此 Node 对象的父元素。
getParentFile() - 类 java.io.File 中的方法
返回此抽象路径名父目录的抽象路径名；如果此路径名没有指定父目录，则返回 null。
getParentLoggerName(String) - 接口 java.util.logging.LoggingMXBean 中的方法
返回指定 logger 的父 logger 名称。
getParentNode() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回此节点的父节点。
getParentNode() - 接口 org.w3c.dom.Node 中的方法
此节点的父节点。
getParentPath() - 类 javax.swing.tree.TreePath 中的方法
返回包含除最后一个路径组件之外的此对象所有元素的路径。
getParser() - 类 javax.swing.text.html.HTMLDocument 中的方法
返回将 HTML 插入现有文档时所使用的解析器。
getParser() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取要用于读取 HTML 流的解析器。
getParser() - 类 javax.xml.parsers.SAXParser 中的方法
返回由此类的实现封装的 SAX 解析器。
getPartialSize(int, int) - 类 javax.swing.text.ParagraphView 中的方法
返回 startOffset 和 endOffset 之间的视图使用的大小。
getPartialSpan(int, int) - 类 javax.swing.text.GlyphView 中的方法
确定沿与选项卡扩展同轴的区域是否为该视图的一部分。
getPartialSpan(int, int) - 接口 javax.swing.text.TabableView 中的方法
确定部分视图沿与制表符扩展相同的轴的跨距。
getParties() - 类 java.util.concurrent.CyclicBarrier 中的方法
返回要求启动此 barrier 的参与者数目。
getPassword() - 类 java.net.PasswordAuthentication 中的方法
返回用户密码。
getPassword() - 类 java.security.KeyStore.PasswordProtection 中的方法
获取密码。
getPassword() - 接口 javax.crypto.interfaces.PBEKey 中的方法
返回密码。
getPassword() - 类 javax.crypto.spec.PBEKeySpec 中的方法
返回密码的一份副本。
getPassword() - 类 javax.security.auth.callback.PasswordCallback 中的方法
获取检索到的密码。
getPassword() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回用于创建此 RowSet 对象的数据库连接的密码。
getPassword() - 接口 javax.sql.RowSet 中的方法
获取用于创建数据库连接的密码。
getPassword() - 类 javax.swing.JPasswordField 中的方法
返回此 TextComponent 中所包含的文本。
getPasswordAuthentication() - 类 java.net.Authenticator 中的方法
需要密码授权时调用。
getPasteAction() - 类 javax.swing.TransferHandler 中的静态方法
返回一个从剪贴板执行粘贴操作的 Action。
getPatch() - 类 javax.sound.midi.Instrument 中的方法
获得 Patch 对象，该对象指示此乐器在合成器中存储位置处的库和程序号。
getPatchList() - 类 javax.sound.midi.Sequence 中的方法
获得此 Sequence 中引用的包列表。
getPath() - 类 java.io.File 中的方法
将此抽象路径名转换为一个路径名字符串。
getPath() - 类 java.net.HttpCookie 中的方法
返回浏览器将此 cookie 返回到的服务器上的路径。
getPath() - 类 java.net.URI 中的方法
返回此 URI 的已解码的路径组成部分。
getPath() - 类 java.net.URL 中的方法
获取此 URL 的路径部分。
getPath() - 类 javax.swing.event.MenuDragMouseEvent 中的方法
返回选定菜单项所在的路径。
getPath() - 类 javax.swing.event.MenuKeyEvent 中的方法
返回到达此事件引用的菜单项的路径。
getPath() - 类 javax.swing.event.TreeExpansionEvent 中的方法
返回到达已被扩展/折叠的值的路径。
getPath() - 类 javax.swing.event.TreeModelEvent 中的方法
从此事件包装的 TreePath 实例中获得对象数组的便捷方法。
getPath() - 类 javax.swing.event.TreeSelectionEvent 中的方法
返回第一个路径元素。
getPath() - 类 javax.swing.JTree.DropLocation 中的方法
返回树中应该用来放入放置数据的路径。
getPath() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getPath() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回从根到达此节点的路径。
getPath() - 类 javax.swing.tree.TreePath 中的方法
返回有序的 Objects 数组，它包含此 TreePath 的组件。
getPathBetweenRows(int, int) - 类 javax.swing.JTree 中的方法
返回 JTreePath 实例，它表示 index0 和 index1（包括 index1）之间的路径。
getPathBounds(TreePath) - 类 javax.swing.JTree 中的方法
返回将指定节点绘入的 Rectangle。
getPathBounds(JTree, TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
getPathBounds(JTree, TreePath) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getPathBounds 方法。
getPathBounds(JTree, TreePath) - 类 javax.swing.plaf.TreeUI 中的方法
返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
getPathClosestTo(int, int) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回最接近 x,y 节点的路径。
getPathClosestTo(int, int) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回最接近 x,y 的节点的路径。
getPathClosestTo(int, int) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回最接近 x,y 的节点的路径。
getPathComponent(int) - 类 javax.swing.tree.TreePath 中的方法
返回指定索引位置的路径组件。
getPathCount() - 类 javax.swing.tree.TreePath 中的方法
返回路径中的元素数。
getPathForLocation(int, int) - 类 javax.swing.JTree 中的方法
返回指定位置处的节点路径。
getPathForRow(int) - 类 javax.swing.JTree 中的方法
返回指定行的路径。
getPathForRow(JTree, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回传入的 row 的路径。
getPathForRow(JTree, int) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getPathForRow 方法。
getPathForRow(JTree, int) - 类 javax.swing.plaf.TreeUI 中的方法
返回传入的 row 的路径。
getPathForRow(int) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回传入行的路径。
getPathForRow(int) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回传入行的路径。
getPathForRow(int) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回 row 的路径。
getPathIterator(AffineTransform) - 类 java.awt.geom.Arc2D 中的方法
返回定义弧边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Area 中的方法
为此 Area 对象的轮廓创建一个 PathIterator。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.Area 中的方法
为此 Area 对象的变平轮廓创建 PathIterator。
getPathIterator(AffineTransform) - 类 java.awt.geom.CubicCurve2D 中的方法
返回定义形状边界的迭代对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.CubicCurve2D 中的方法
返回定义变平形状边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Ellipse2D 中的方法
返回定义此 Ellipse2D 边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Line2D 中的方法
返回定义此 Line2D 边界的迭代对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.Line2D 中的方法
返回定义此变平的 Line2D 边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Path2D.Double 中的方法
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Path2D.Float 中的方法
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.Path2D 中的方法
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.QuadCurve2D 中的方法
返回定义此 QuadCurve2D 的形状边界的迭代对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.QuadCurve2D 中的方法
返回定义此 QuadCurve2D 的变平形状边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Rectangle2D 中的方法
返回定义此 Rectangle2D 边界的迭代对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.Rectangle2D 中的方法
返回定义变平的 Rectangle2D 边界的迭代对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.RectangularShape 中的方法
返回一个迭代器对象，它可沿 Shape 对象的边界进行迭代，并提供对 Shape 对象轮廓几何形状平面视图的访问。
getPathIterator(AffineTransform) - 类 java.awt.geom.RoundRectangle2D 中的方法
返回定义此 RoundRectangle2D 边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.Polygon 中的方法
返回迭代器对象，此对象沿此 Polygon 的边界进行迭代，并且提供对此 Polygon 轮廓的几何形状的访问。
getPathIterator(AffineTransform, double) - 类 java.awt.Polygon 中的方法
返回迭代器对象，此对象沿 Shape 的边界进行迭代，并且提供了对 Shape 轮廓的几何形状的访问。
getPathIterator(AffineTransform) - 接口 java.awt.Shape 中的方法
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
getPathIterator(AffineTransform, double) - 接口 java.awt.Shape 中的方法
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
getPaths() - 类 javax.swing.event.TreeSelectionEvent 中的方法
返回已经添加到该选择中或已从中移除的路径。
getPathToNames() - 类 java.security.cert.X509CertSelector 中的方法
返回 pathToNames 标准的一个副本。
getPathToRoot(TreeNode, int) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
构建节点的父节点一直到根节点（包括根节点），其中源节点是返回数组中的最后一个元素。
getPathToRoot(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
getPathToRoot(TreeNode, int) - 类 javax.swing.tree.DefaultTreeModel 中的方法
向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
getPattern() - 异常 java.util.regex.PatternSyntaxException 中的方法
获取错误的正则表达式模式。
getPatternSeparator() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于在模式中分隔正数和负数子模式的字符。
getPayload() - 接口 javax.xml.ws.LogicalMessage 中的方法
以 XML 源的形式获取消息负载，可以在相同的 LogicalMessage 实例上多次调用，总是返回可以用来检索整个消息负载的新的 Source。
getPayload(JAXBContext) - 接口 javax.xml.ws.LogicalMessage 中的方法
以 JAXB 对象的形式获取消息负载。
getPCSType() - 类 java.awt.color.ICC_Profile 中的方法
返回配置文件连接空间 (PCS) 的颜色空间类型。
getPeakThreadCount() - 接口 java.lang.management.ThreadMXBean 中的方法
返回自从 Java 虚拟机启动或峰值重置以来峰值活动线程计数。
getPeakUsage() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回自 Java 虚拟机启动以来或自峰值重置以来此内存池的峰值内存使用量。
getPeer() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体；由 boolean isDisplayable() 取代。
getPeer() - 类 java.awt.Font 中的方法
已过时。 现在，字体呈现与平台无关。
getPeer() - 类 java.awt.MenuComponent 中的方法
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体。
getPeerCertificateChain() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回同位体的标识，同位体是作为定义会话的一部分而标识的。
getPeerCertificateChain() - 接口 javax.net.ssl.SSLSession 中的方法
返回同级身份，该同级身份被标识作为定义会话的一部分。
getPeerCertificates() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回同位体的标识，同位体是作为定义会话的一部分而建立的。
getPeerCertificates() - 接口 javax.net.ssl.SSLSession 中的方法
返回同级身份，该同级身份是作为定义会话的一部分而建立的。
getPeerHost() - 类 javax.net.ssl.SSLEngine 中的方法
返回同位体的主机名。
getPeerHost() - 接口 javax.net.ssl.SSLSession 中的方法
返回此会话中同位体的主机名称。
getPeerPort() - 类 javax.net.ssl.SSLEngine 中的方法
返回同位体的端口号。
getPeerPort() - 接口 javax.net.ssl.SSLSession 中的方法
返回此会话中同位体的端口号。
getPeerPrincipal() - 类 java.net.SecureCacheResponse 中的方法
返回服务器的主体，该主体是作为在获得了网络资源的初始连接期间定义会话的一部分建立的。
getPeerPrincipal() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回同位体的标识，同位体是作为定义会话的一部分而建立的。
getPeerPrincipal() - 类 javax.net.ssl.HttpsURLConnection 中的方法
返回服务器的主体，它是作为定义会话的一部分而建立的。
getPeerPrincipal() - 接口 javax.net.ssl.SSLSession 中的方法
返回同级身份，该同级身份是作为定义会话的一部分而建立的。
getPercent() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于百分数符号的字符。
getPercentComplete() - 类 javax.swing.JProgressBar 中的方法
返回进度条的完成百分比。
getPercentInstance() - 类 java.text.NumberFormat 中的静态方法
返回当前默认语言环境的百分比格式。
getPercentInstance(Locale) - 类 java.text.NumberFormat 中的静态方法
返回指定语言环境的百分比格式。
getPercentInstance(Locale) - 类 java.text.spi.NumberFormatProvider 中的方法
返回新的 NumberFormat 实例，此实例为指定语言环境格式化百分比值。
getPeriod(Integer) - 类 javax.management.timer.Timer 中的方法
获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
getPeriod(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
getPermanentFocusOwner() - 类 java.awt.KeyboardFocusManager 中的方法
如果持久焦点所有者与调用线程位于同一个上下文中，则返回持久焦点所有者。
getPerMill() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于千分数符号的字符。
getPermission() - 类 java.net.HttpURLConnection 中的方法

getPermission() - 类 java.net.URLConnection 中的方法
返回一个权限对象，其代表建立此对象表示的连接所需的权限。
getPermission() - 异常 java.security.AccessControlException 中的方法
获取与此异常关联的 Permission 对象；如果不存在相应的 Permission 对象，则为 null。
getPermissions(CodeSource) - 类 java.net.URLClassLoader 中的方法
返回给定 codesource 对象的权限。
getPermissions(Principal) - 接口 java.security.acl.Acl 中的方法
返回一个指定主体（表示一个实体，如个体或组）的许可权限集合的枚举。
getPermissions(CodeSource) - 类 java.security.Policy 中的方法
返回一个 PermissionCollection 对象，它包含授予指定 CodeSource 的权限集。
getPermissions(ProtectionDomain) - 类 java.security.Policy 中的方法
返回一个 PermissionCollection 对象，它包含授予指定 ProtectionDomain 的权限集。
getPermissions() - 类 java.security.ProtectionDomain 中的方法
返回授予此域的静态权限。
getPermissions(CodeSource) - 类 java.security.SecureClassLoader 中的方法
返回给定的 CodeSource 对象的权限。
getPermissions(Subject, CodeSource) - 类 javax.security.auth.Policy 中的方法
已过时。 获取授予与指定的 CodeSource 关联的 Principals 的 Permissions。
getPersistenceDelegate(Class<?>) - 类 java.beans.Encoder 中的方法
返回给定类型的持久委托。
getPIData() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getPIData() - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取处理指令的数据节
getPITarget() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getPITarget() - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取处理指令的目标
getPitchBend() - 接口 javax.sound.midi.MidiChannel 中的方法
获得此通道的向上或向下的音高偏移量。
getPixel(int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
在 int 数组中返回指定像素的所有样本。
getPixel(int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
返回对应 int 数组中指定像素的所有样本，每个数组元素对应一个样本。
getPixel(int, int, int[], DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回 int 数组第一个元素中的指定单个 band 像素。
getPixel(int, int, int[]) - 类 java.awt.image.Raster 中的方法
以 int 数组形式返回指定像素的样本。
getPixel(int, int, float[]) - 类 java.awt.image.Raster 中的方法
以 float 数组形式返回指定像素的样本。
getPixel(int, int, double[]) - 类 java.awt.image.Raster 中的方法
以 double 数组形式返回指定像素的样本。
getPixel(int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 int 数组中返回指定像素的样本，每个数组元素对应一个样本。
getPixel(int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 float 数组中返回指定像素的样本。
getPixel(int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 double 数组中返回指定像素的样本。
getPixel(int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
在一个 int 数组中返回对应于指定像素的所有样本。
getPixelBitStride() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回像素位间距，以位为单位。
getPixelBounds(FontRenderContext, float, float) - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 在图形中以给定 FontRenderContext 在给定位置处呈现时的像素边界。
getPixelBounds(FontRenderContext, float, float) - 类 java.awt.font.TextLayout 中的方法
返回在图形中使用给定 FontRenderContext 在给定位置处呈现 TextLayout 时的像素边界。
getPixelColor(int, int) - 类 java.awt.Robot 中的方法
返回给定屏幕坐标处的像素颜色。
getPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
在 int 数组中返回指定像素矩形的所有样本，每个数据数组元素对应一个样本。
getPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
返回对应 int 数组中像素指定矩形区域的所有样本（每个数组元素对应一个样本）。
getPixels() - 类 java.awt.image.PixelGrabber 中的方法
获取像素缓冲区。
getPixels(int, int, int, int, int[]) - 类 java.awt.image.Raster 中的方法
返回一个包含像素矩形所有样本的 int 数组，每个数组元素对应一个样本。
getPixels(int, int, int, int, float[]) - 类 java.awt.image.Raster 中的方法
返回一个包含像素矩形所有样本的 float 数组，每个数组元素对应一个样本。
getPixels(int, int, int, int, double[]) - 类 java.awt.image.Raster 中的方法
返回一个包含像素矩形所有样本的 double 数组，每个数组元素对应一个样本。
getPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 int 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
getPixels(int, int, int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 float 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
getPixels(int, int, int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 double 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
getPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
在一个 int 数组中返回对应于指定像素矩形的所有样本，每个数组元素对应一个样本。
getPixelSize() - 类 java.awt.image.ColorModel 中的方法
返回由此 ColorModel 描述的每像素的位数。
getPixelStride() - 类 java.awt.image.ComponentSampleModel 中的方法
返回此 ComponentSampleModel 的像素间距。
getPlaceholder() - 类 javax.swing.text.MaskFormatter 中的方法
如果值未完全填充掩码，则返回要使用的 String。
getPlaceholderCharacter() - 类 javax.swing.text.MaskFormatter 中的方法
返回用来替代值中没有的字符的字符（即用户必须填充它们）。
getPlatformMBeanServer() - 类 java.lang.management.ManagementFactory 中的静态方法
返回平台 MBeanServer。
getPluginClassName() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回与此服务提供者关联的 ImageReader 或 ImageWriter 插件的完全限定类名称。
getPoint() - 类 java.awt.event.MouseEvent 中的方法
返回事件相对于源组件的 x, y 坐标。
getPoint1() - 类 java.awt.GradientPaint 中的方法
返回着第一种颜色的点 P1 的副本。
getPoint2() - 类 java.awt.GradientPaint 中的方法
返回着第二种颜色的点 P2 的副本。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.AffineTransformOp 中的方法
返回与源图像中给定点对应的目标点的位置。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.BandCombineOp 中的方法
返回与源 Raster 中给定点对应的目标点的位置。
getPoint2D(Point2D, Point2D) - 接口 java.awt.image.BufferedImageOp 中的方法
返回与源图像中给定点对应的目标点的位置。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.ColorConvertOp 中的方法
返回源中给定点的目标点的位置。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.ConvolveOp 中的方法
返回源中给定点的目标点位置。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.LookupOp 中的方法
在给定源图像中某个点的情况下，返回目标点的位置。
getPoint2D(Point2D, Point2D) - 接口 java.awt.image.RasterOp 中的方法
在给定源 Raster 中一个点的情况下，返回目标点的位置。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.RescaleOp 中的方法
给定源中的一个点，返回对应目标点的位置。
getPointerInfo() - 类 java.awt.MouseInfo 中的静态方法
返回表示鼠标指针当前位置的 PointerInfo 实例。
getPointSize(int) - 类 javax.swing.text.html.StyleSheet 中的方法
在给定大小索引的情况下返回点大小。
getPointSize(String) - 类 javax.swing.text.html.StyleSheet 中的方法
如果给定字符串（如 "+2"、"-2" 或 "2"），则返回点大小值。
getPolicy() - 类 java.security.cert.X509CertSelector 中的方法
返回策略标准。
getPolicy() - 类 java.security.Policy 中的静态方法
返回安装的 Policy 对象。
getPolicy() - 类 javax.security.auth.Policy 中的静态方法
已过时。 返回安装的 Policy 对象。
getPolicyQualifier() - 类 java.security.cert.PolicyQualifierInfo 中的方法
返回此 PolicyQualifierInfo 的 qualifier 字段的 ASN.1 DER 编码形式。
getPolicyQualifierId() - 类 java.security.cert.PolicyQualifierInfo 中的方法
返回此 PolicyQualifierInfo 的 policyQualifierId 字段。
getPolicyQualifiers() - 接口 java.security.cert.PolicyNode 中的方法
返回与此节点所表示的有效策略相关联的策略限定符集。
getPolicyQualifiersRejected() - 类 java.security.cert.PKIXParameters 中的方法
获取 PolicyQualifiersRejected 标志。
getPolicyTree() - 类 java.security.cert.PKIXCertPathValidatorResult 中的方法
返回 PKIX 证书路径验证算法所得的有效策略树的根节点。
getPolyPressure(int) - 接口 javax.sound.midi.MidiChannel 中的方法
获得指定键被按下的力度。
getPooledConnection() - 接口 javax.sql.ConnectionPoolDataSource 中的方法
尝试建立可用作入池连接的物理数据库连接。
getPooledConnection(String, String) - 接口 javax.sql.ConnectionPoolDataSource 中的方法
尝试建立可用作入池连接的物理数据库连接。
getPoolName() - 类 java.lang.management.MemoryNotificationInfo 中的方法
返回触发此通知的内存池的名称。
getPoolSize() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回池中的当前线程数。
getPopup(JPopupMenu, int, int) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getPopup 方法。
getPopup(JPopupMenu, int, int) - 类 javax.swing.plaf.PopupMenuUI 中的方法
返回将负责显示 JPopupMenu 的 Popup。
getPopup(Component, Component, int, int) - 类 javax.swing.PopupFactory 中的方法
为包含 Component contents 的 Component owner 创建 Popup。
getPopupHeightForRowCount(int) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
基于当前 ListCellRenderer 和最大行数检索弹出部分的高度。
getPopupLocation(MouseEvent) - 类 javax.swing.JComponent 中的方法
返回在此组件坐标系统中显示弹出式菜单的首选位置。
getPopupMenu() - 类 java.awt.TrayIcon 中的方法
返回与此 TrayIcon 关联的弹出菜单。
getPopupMenu() - 类 javax.swing.JMenu 中的方法
返回与此菜单关联的弹出菜单。
getPopupMenuListeners() - 类 javax.swing.JComboBox 中的方法
返回利用 addPopupMenuListener() 添加到此 JComboBox 的所有 PopupMenuListener 组成的数组。
getPopupMenuListeners() - 类 javax.swing.JPopupMenu 中的方法
返回利用 addPopupMenuListener() 添加到此 JMenuItem 的所有 PopupMenuListener 组成的数组。
getPopupMenuOrigin() - 类 javax.swing.JMenu 中的方法
计算 JMenu 的弹出菜单的原点。
getPort() - 类 java.net.DatagramPacket 中的方法
返回某台远程主机的端口号，此数据报将要发往该主机或者是从该主机接收到的。
getPort() - 类 java.net.DatagramSocket 中的方法
返回此套接字的端口。
getPort() - 类 java.net.InetSocketAddress 中的方法
获取端口号。
getPort() - 类 java.net.Socket 中的方法
返回此套接字连接到的远程端口。
getPort() - 类 java.net.SocketImpl 中的方法
返回此套接字的 port 字段的值。
getPort() - 类 java.net.URI 中的方法
返回此 URI 的端口号。
getPort() - 类 java.net.URL 中的方法
获取此 URL 的端口号。
getPort() - 类 java.security.cert.LDAPCertStoreParameters 中的方法
返回 LDAP 服务器的端口号。
getPort() - 类 javax.management.remote.JMXServiceURL 中的方法
Service URL 的端口部分。
getPort(QName, Class<T>) - 类 javax.xml.ws.Service 中的方法
getPort 方法返回 stub。
getPort(Class<T>) - 类 javax.xml.ws.Service 中的方法
getPort 返回 stub。
getPort(QName, Class<T>) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
getPort 方法返回一个桩模块 (stub)。
getPort(Class<T>) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
getPort 方法返回一个桩模块。
getPortlist() - 类 java.net.HttpCookie 中的方法
返回 cookie 的端口列表属性
getPortName() - 接口 javax.xml.ws.handler.PortInfo 中的方法
获取正被访问的 WSDL 端口的限定名。
getPorts() - 类 javax.xml.ws.Service 中的方法
返回一个 Iterator，它用于此服务所组合的服务端点的 QName 列表。
getPorts() - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
返回一个 Iterator，该迭代器用于根据此服务分组的服务端点的 QName 列表。
getPosition() - 类 java.awt.font.LineBreakMeasurer 中的方法
返回此 LineBreakMeasurer 的当前位置。
getPosition(Component) - 类 javax.swing.JLayeredPane 中的方法
获得该组件在其所在层中的相对位置。
getPosition(int) - 类 javax.swing.SizeSequence 中的方法
返回指定条目的起始位置。
getPosition() - 类 javax.swing.text.TabStop 中的方法
以 float 的形式返回制表符的位置。
getPosition() - 接口 javax.tools.Diagnostic 中的方法
获取距源对象开始位置的字符偏移量，其中源对象与指示问题位置的此诊断关联。
getPosition() - 接口 org.w3c.dom.ls.LSProgressEvent 中的方法
输入源中的当前位置，包括所有的外部实体和已经读取的其他资源。
getPositionAbove(JTextComponent, int, int) - 类 javax.swing.text.Utilities 中的静态方法
确定模型中离行上方给定的视图位置最近的位置。
getPositionBelow(JTextComponent, int, int) - 类 javax.swing.text.Utilities 中的静态方法
确定模型中离行下方给定的视图位置最近的位置。
getPositionsInRange(Vector, int, int) - 类 javax.swing.text.GapContent 中的方法
返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
getPositionsInRange(Vector, int, int) - 类 javax.swing.text.StringContent 中的方法
返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
getPositivePrefix() - 类 java.text.DecimalFormat 中的方法
获取正数前缀。
getPositiveSuffix() - 类 java.text.DecimalFormat 中的方法
获取正数后缀。
getPrecision() - 类 java.math.MathContext 中的方法
返回 precision 设置。
getPrecision(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的指定列大小。
getPrecision(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的指定列宽。
getPrecision() - 异常 java.util.IllegalFormatPrecisionException 中的方法
返回精度。
getPrecision() - 类 javax.sound.sampled.FloatControl 中的方法
获得该控件的分辨率或粒度，以该控件测量的单位为准。
getPrecision(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取存储在指定列中的值的数字总数。
getPredefinedCursor(int) - 类 java.awt.Cursor 中的静态方法
返回一个具有指定预定义类型的光标对象。
getPreferredButtonSize(AbstractButton, int) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法

getPreferredCommands(String) - 类 javax.activation.CommandMap 中的方法
从 MIME 类型获取首选命令表。
getPreferredCommands(String, DataSource) - 类 javax.activation.CommandMap 中的方法
从 MIME 类型获取首选命令表。
getPreferredCommands() - 类 javax.activation.DataHandler 中的方法
返回此数据类型的首选 命令。
getPreferredCommands(String) - 类 javax.activation.MailcapCommandMap 中的方法
获取 MIME 类型的首选命令列表。
getPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, Container) - 类 javax.swing.LayoutStyle 中的方法
返回两个组件之间使用的空格的数量。
getPreferredHeight() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回首选高度。
getPreferredHeight() - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回首选高度。
getPreferredHorizontalSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getPreferredInnerHorizontal() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法

getPreferredInnerVertical() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getPreferredMinSize() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回最小首选大小。
getPreferredScrollableViewportSize() - 类 javax.swing.JList 中的方法
计算显示 visibleRowCount 行所需的视口的大小。
getPreferredScrollableViewportSize() - 类 javax.swing.JTable 中的方法
返回此表视口的首选大小。
getPreferredScrollableViewportSize() - 类 javax.swing.JTextArea 中的方法
如果此组件被嵌入 JScrollPane 中，则返回 viewport 的首选大小。
getPreferredScrollableViewportSize() - 类 javax.swing.JTree 中的方法
返回 JTree 的首选显示大小。
getPreferredScrollableViewportSize() - 接口 javax.swing.Scrollable 中的方法
返回视图组件视口的首选大小。
getPreferredScrollableViewportSize() - 类 javax.swing.text.JTextComponent 中的方法
返回视图组件视口的首选大小。
getPreferredSize() - 类 java.awt.Component 中的方法
获取组件的首选大小。
getPreferredSize() - 类 java.awt.Container 中的方法
返回此容器的首选大小。
getPreferredSize(int) - 类 java.awt.List 中的方法
获取具有指定行数的列表的首选维数。
getPreferredSize() - 类 java.awt.List 中的方法
获取此滚动列表的首选大小。
getPreferredSize(int, int) - 类 java.awt.TextArea 中的方法
确定具有指定行数和列数的文本区的首选大小。
getPreferredSize() - 类 java.awt.TextArea 中的方法
确定此文本区的首选大小。
getPreferredSize(int) - 类 java.awt.TextField 中的方法
获取具有指定列数的文本字段的首选大小。
getPreferredSize() - 类 java.awt.TextField 中的方法
获取此文本字段的首选大小。
getPreferredSize() - 类 javax.swing.JComponent 中的方法
如果 preferredSize 已设置为一个非 null 值，则返回该值。
getPreferredSize() - 类 javax.swing.JEditorPane 中的方法
返回该 JEditorPane 的首选大小。
getPreferredSize() - 类 javax.swing.JTextArea 中的方法
返回 TextArea 的首选大小。
getPreferredSize() - 类 javax.swing.JTextField 中的方法
返回此 TextField 所需的首选大小 Dimensions。
getPreferredSize() - 类 javax.swing.JToolBar.Separator 中的方法
返回分隔符的首选大小。
getPreferredSize() - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
返回 BasicArrowButton 的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getPreferredSize() - 类 javax.swing.plaf.basic.BasicComboBoxRenderer 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
列表的 preferredSize 依赖于布局方向。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
如果 c 为包含接收者的 JOptionPane，则返回的首选大小为 JOptionPane 的 LayoutManager 的最大首选大小和 getMinimumOptionPaneSize。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法
单选按钮的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
垂直滚动条的首选宽度是（非 null）递增/递减按钮的首选宽度的最大值，也是 thumb 的最小宽度。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getPreferredSize() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回 dividerSize x dividerSize
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回传入组件的首选大小，该大小将传递给当前布局管理器。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
返回标题的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
返回表的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
重写此方法以将插入符的宽度考虑在内。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取编辑器组件的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回首选大小以正确显示树，这是一种 getPreferredSize(c, false) 的替代方法。
getPreferredSize(JComponent, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回首选大小以表示 c 中的树。
getPreferredSize(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
返回指定组件的适合外观的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
返回指定 JFileChooser 的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法

getPreferredSize() - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalSeparatorUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
返回正确呈现图标和文本所需的首选大小。
getPreferredSize() - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 中的方法
重写 JTextField.getPreferredSize，以根据当前字体（如果设置）返回首选大小，否则使用 renderer 的字体。
getPreferredSize() - 类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 中的方法
返回 Container 的首选大小。
getPreferredSize() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
重写 JComponent.getPreferredSize，以返回稍宽的首选大小值。
getPreferredSizeOfComponent(Component) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回传入 Component 的首选大小的宽度。
getPreferredSpan(int) - 类 javax.swing.text.AsyncBoxView 中的方法
确定此视图沿某轴的首选跨距。
getPreferredSpan(int) - 类 javax.swing.text.BoxView 中的方法
确定此视图沿某个轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.ComponentView 中的方法
确定此视图沿某轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.FieldView 中的方法
确定此视图沿某轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.GlyphView 中的方法
确定此视图沿某个轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.html.BlockView 中的方法
确定此视图沿某个轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.html.ImageView 中的方法
确定此视图沿某轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.html.ParagraphView 中的方法
确定此视图的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.IconView 中的方法
确定此视图沿某个轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.PasswordView 中的方法
确定此视图沿某轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.PlainView 中的方法
确定此视图沿某轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.View 中的方法
确定此视图沿某个轴的首选跨距。
getPreferredSpan(int) - 类 javax.swing.text.WrappedPlainView 中的方法
确定此视图沿某个轴的首选跨距。
getPreferredThumbnailSizes(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata) - 类 javax.imageio.ImageWriter 中的方法
返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
getPreferredTileSizes() - 类 javax.imageio.ImageWriteParam 中的方法
返回一个 Dimension 数组，指示在输出文件或流中进行编码时 tile 的合法大小范围。
getPreferredValue() - 类 javax.swing.Spring 中的方法
返回此 Spring 的 preferred 值。
getPreferredVerticalSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getPreferredWidth() - 类 javax.swing.table.TableColumn 中的方法
返回 TableColumn 的首选宽度。
getPreferredWidth(Rectangle) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回传入区域的首选宽度。
getPreferredWidth(Rectangle) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回 visibleRegion 中区域的首选宽度和高度。
getPrefix() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回 null，因为不支持名称空间。
getPrefix(int) - 类 javax.naming.CompositeName 中的方法
创建一个复合名称，其组件由此复合名称中组件的前缀组成。
getPrefix(int) - 类 javax.naming.CompoundName 中的方法
创建一个组合名称，其组件由此组合名称中组件的前缀组成。
getPrefix(int) - 类 javax.naming.ldap.LdapName 中的方法
创建一个名称，其组件由此 LDAP 名称中组件的前缀组成。
getPrefix(int) - 接口 javax.naming.Name 中的方法
创建一个名称，其组件由此名称中组件的前缀组成。
getPrefix(String) - 接口 javax.xml.namespace.NamespaceContext 中的方法
获取绑定到当前范围中名称空间 URI 的前缀。
getPrefix() - 类 javax.xml.namespace.QName 中的方法
获取此 QName 的前缀。
getPrefix() - 接口 javax.xml.soap.Name 中的方法
返回初始化此 Name 对象时指定的前缀。
getPrefix() - 接口 javax.xml.stream.events.Namespace 中的方法
获取前缀，如果它是默认名称空间声明，则返回 ""。
getPrefix() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getPrefix(String) - 接口 javax.xml.stream.XMLEventWriter 中的方法
获取绑定 URI 的前缀。
getPrefix() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回当前事件的前缀，如果事件没有前缀，则返回 null
getPrefix(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
获取绑定 URI 的前缀
getPrefix() - 接口 org.w3c.dom.Node 中的方法
此节点的名称空间前缀；如果它未被指定，则为 null。
getPrefix(String) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
返回映射到名称空间 URI 的前缀之一。
getPrefixes(String) - 接口 javax.xml.namespace.NamespaceContext 中的方法
获取绑定到当前范围中名称空间 URI 的所有前缀。
getPrefixes() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
返回所有前缀的枚举，其声明在当前上下文中是活动的。
getPrefixes(String) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
返回给定 URI 的 所有前缀的枚举，给定 URI 的声明在当前上下文中是活动的。
getPrefixList() - 类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 中的方法
返回相容名称空间前缀列表。
getPresentationName() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
提供此次编辑的已本地化的、可读的描述，比如，适合于在更改日志中使用的。
getPresentationName() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
此默认实现返回 ""。
getPresentationName() - 类 javax.swing.undo.CompoundEdit 中的方法
从添加到 edits 的最后 UndoableEdit 返回 getPresentationName。
getPresentationName() - 类 javax.swing.undo.StateEdit 中的方法
获取此编辑的表示名称
getPresentationName() - 接口 javax.swing.undo.UndoableEdit 中的方法
返回此编辑的本地化可读描述，例如，适于在更改日志中使用。
getPreservesUnknownTags() - 类 javax.swing.text.html.HTMLDocument 中的方法
返回在遇到未知标记时所观察到的解析器行为。
getPressedIcon() - 类 javax.swing.AbstractButton 中的方法
返回按钮的按下图标。
getPreviewPanel() - 类 javax.swing.colorchooser.ColorChooserComponentFactory 中的静态方法

getPreviewPanel() - 类 javax.swing.JColorChooser 中的方法
返回显示选取颜色的预览面板。
getPreviousBounds(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
在将组件最大化之前，获得该组件的普通边界。
getPreviousLeaf() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点之前的叶节点，如果此节点是树中的第一个叶节点，则返回 null。
getPreviousNode() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回在此节点树的前序遍历中此节点之前的节点。
getPreviousRowCount() - 类 javax.swing.event.RowSorterEvent 中的方法
返回排序之前行的数量。
getPreviousSibling() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回此节点的上一个兄弟节点；如果该节点没有上一个兄弟节点，则返回 null。
getPreviousSibling() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回父节点的子节点数组中此节点的前一个兄弟节点。
getPreviousSibling() - 接口 org.w3c.dom.Node 中的方法
直接在此节点之前的节点。
getPreviousTabIndex(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getPreviousTabIndexInRun(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getPreviousTabRun(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getPreviousValue() - 类 javax.swing.JSpinner 中的方法
返回序列中由 getValue() 所返回对象之前的对象。
getPreviousValue() - 类 javax.swing.SpinnerDateModel 中的方法
返回序列中上一个 Date，如果上一个日期是在 start 之前，则返回 null。
getPreviousValue() - 类 javax.swing.SpinnerListModel 中的方法
返回该基础序列的前一个元素，如果值已经是第一个元素，则返回 null。
getPreviousValue() - 接口 javax.swing.SpinnerModel 中的方法
返回该序列中出现在 getValue() 返回的对象之前的对象。
getPreviousValue() - 类 javax.swing.SpinnerNumberModel 中的方法
返回该序列中的上一个数字。
getPreviousWord(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定针对给定位置的上一个单词开头。
getPrevValue() - 接口 org.w3c.dom.events.MutationEvent 中的方法
prevValue 指示 DOMAttrModified 事件中 Attr 节点以前的值，以及 DOMCharacterDataModified 事件中 CharacterData 节点以前的值。
getPrimary1() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 primary 1 颜色。
getPrimary1() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 1 颜色。
getPrimary1() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 primary 1 颜色。
getPrimary2() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 primary 2 颜色。
getPrimary2() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 2 颜色。
getPrimary2() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 primary 2 颜色。
getPrimary3() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 primary 3 颜色。
getPrimary3() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 3 颜色。
getPrimary3() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 primary 3 颜色。
getPrimaryControl() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的 primary 控件颜色。
getPrimaryControl() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 控件颜色。
getPrimaryControlDarkShadow() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的 primary 控件加黑阴影颜色。
getPrimaryControlDarkShadow() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 控件加黑阴影颜色。
getPrimaryControlHighlight() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的 primary 控件高亮显示颜色。
getPrimaryControlHighlight() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 控件高亮显示颜色。
getPrimaryControlInfo() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的 primary 控件信息颜色。
getPrimaryControlInfo() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 控件信息颜色。
getPrimaryControlShadow() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的 primary 控件阴影颜色。
getPrimaryControlShadow() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 控件阴影颜色。
getPrimaryKeys(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取对给定表的主键列的描述。
getPrimaryType() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的基本 MIME 类型。
getPrimaryType() - 类 javax.activation.MimeType 中的方法
获取此对象的基本类型。
getPrime() - 类 java.security.spec.RSAOtherPrimeInfo 中的方法
返回素数。
getPrimeExponentP() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 primeExponentP。
getPrimeExponentP() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回 primeExponentP。
getPrimeExponentP() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 primeExponentP。
getPrimeExponentP() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回 primeExponentP。
getPrimeExponentQ() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 primeExponentQ。
getPrimeExponentQ() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回 primeExponentQ。
getPrimeExponentQ() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 primeExponentQ。
getPrimeExponentQ() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回 primeExponentQ。
getPrimeP() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 primeP。
getPrimeP() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回 primeP。
getPrimeP() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 primeP。
getPrimeP() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回 primeP。
getPrimeQ() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 primeQ。
getPrimeQ() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回 primeQ。
getPrimeQ() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 primeQ。
getPrimeQ() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回 primeQ。
getPrimeSize() - 类 javax.crypto.spec.DHGenParameterSpec 中的方法
以位为单位返回质数模数的大小。
getPrimitiveArrayType(Class<T>) - 类 javax.management.openmbean.ArrayType 中的静态方法
以类型安全的方式创建一个 ArrayType 实例。
getPrimitiveType(TypeKind) - 接口 javax.lang.model.util.Types 中的方法
返回基本类型。
getPrincipal() - 接口 java.security.acl.AclEntry 中的方法
返回此 ACL 项将为其授予或拒绝权限的主体。
getPrincipal() - 接口 java.security.Certificate 中的方法
已过时。 返回保证人所保证的主体密钥对的主体。
getPrincipal() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回此密钥所属的主体。
getPrincipals() - 类 java.security.ProtectionDomain 中的方法
返回此域的 principals 数组。
getPrincipals() - 类 javax.security.auth.PrivateCredentialPermission 中的方法
返回与此 PrivateCredentialPermission 相关联的 Principal 类和名称。
getPrincipals() - 类 javax.security.auth.Subject 中的方法
返回与此 Subject 关联的 Principal Set。
getPrincipals(Class<T>) - 类 javax.security.auth.Subject 中的方法
返回与此 Subject 关联的 Principal Set，它是指定的 Class 的实例或子类。
getPrintable(int) - 类 java.awt.print.Book 中的方法
返回 Printable 实例，该实例负责呈现 pageIndex 指定的页面。
getPrintable(int) - 接口 java.awt.print.Pageable 中的方法
返回负责呈现 pageIndex 指定的页面的 Printable 实例。
getPrintable(JTable.PrintMode, MessageFormat, MessageFormat) - 类 javax.swing.JTable 中的方法
返回打印此 JTable 中所使用的 Printable。
getPrintable(MessageFormat, MessageFormat) - 类 javax.swing.text.JTextComponent 中的方法
返回一个 Printable，用于打印此 JTextComponent 的内容。
getPrintableArea(int) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以顺序为 x, y, w, h 的 4 个值的数组形式获取可打印区域。
getPrintData() - 接口 javax.print.Doc 中的方法
获得打印数据表示形式对象，该对象包含此 doc 对象的部分打印数据，其格式对应于受支持的 DocFlavor。
getPrintData() - 类 javax.print.SimpleDoc 中的方法

getPrinter() - 类 java.awt.JobAttributes 中的方法
为使用这些属性的作业返回目标打印机。
getPrinterJob() - 接口 java.awt.print.PrinterGraphics 中的方法
返回正在控制当前呈现请求的 PrinterJob。
getPrinterJob() - 类 java.awt.print.PrinterJob 中的静态方法
创建并返回初始化时与默认打印机关联的 PrinterJob。
getPrinterResolution() - 类 java.awt.PageAttributes 中的方法
返回使用这些属性的页面的打印分辨率。
getPrintEventType() - 类 javax.print.event.PrintJobEvent 中的方法
获得此事件的原因。
getPrintJob() - 接口 java.awt.PrintGraphics 中的方法
返回从其产生 PrintGraphics 对象的 PrintJob 对象。
getPrintJob(Frame, String, Properties) - 类 java.awt.Toolkit 中的方法
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
getPrintJob(Frame, String, JobAttributes, PageAttributes) - 类 java.awt.Toolkit 中的方法
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
getPrintJob() - 类 javax.print.event.PrintJobAttributeEvent 中的方法
确定此打印作业事件适合的 Print Job。
getPrintJob() - 类 javax.print.event.PrintJobEvent 中的方法
确定此打印作业事件适合的 DocPrintJob。
getPrintQuality() - 类 java.awt.PageAttributes 中的方法
返回使用这些属性的页面的打印质量。
getPrintService() - 类 java.awt.print.PrinterJob 中的方法
返回此打印机作业的服务（打印机）。
getPrintService() - 接口 javax.print.DocPrintJob 中的方法
确定此 PrintJob 对象所绑定到的 PrintService 对象。
getPrintService() - 类 javax.print.event.PrintServiceAttributeEvent 中的方法
返回打印服务。
getPrintService(OutputStream) - 类 javax.print.StreamPrintServiceFactory 中的方法
返回可打印到指定输出流的 StreamPrintService。
getPrintServices(DocFlavor, AttributeSet) - 类 javax.print.PrintServiceLookup 中的方法
查找肯定可支持指定属性和 DocFlavor 组合的服务。
getPrintServices() - 类 javax.print.PrintServiceLookup 中的方法
应用程序不直接调用它。
getPriority() - 类 java.lang.Thread 中的方法
返回线程的优先级。
getPrivacy() - 类 org.ietf.jgss.MessageProp 中的方法
检索私密状态。
getPrivate() - 类 java.security.KeyPair 中的方法
返回对此密钥对的私钥组件的引用。
getPrivateCredentials() - 类 javax.security.auth.Subject 中的方法
返回此 Subject 中包含的私有证书 Set。
getPrivateCredentials(Class<T>) - 类 javax.security.auth.Subject 中的方法
返回与此 Subject关联的私有证书 Set，它是指定的 Class 的实例或子类。
getPrivateExponent() - 接口 java.security.interfaces.RSAPrivateKey 中的方法
返回专用指数。
getPrivateExponent() - 类 java.security.spec.RSAPrivateKeySpec 中的方法
返回专用指数。
getPrivateKey() - 类 java.security.KeyStore.PrivateKeyEntry 中的方法
从此项获取 PrivateKey。
getPrivateKey() - 类 java.security.Signer 中的方法
已过时。 返回此 signer 的私钥。
getPrivateKey(String) - 接口 javax.net.ssl.X509KeyManager 中的方法
返回与给定别名关联的密钥。
getPrivateKey() - 类 javax.security.auth.x500.X500PrivateCredential 中的方法
返回 PrivateKey。
getPrivateKeyValid() - 类 java.security.cert.X509CertSelector 中的方法
返回 privateKeyValid 标准。
getProblemType() - 类 javax.management.relation.RoleUnresolved 中的方法
检索问题类型。
getProcedureColumns(String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取给定类别的存储过程参数和结果列的描述。
getProcedures(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取可在给定类别中使用的存储过程的描述。
getProcedureTerm() - 接口 java.sql.DatabaseMetaData 中的方法
获取数据库供应商用于 "procedure" 的首选术语。
getProcessedDTD() - 接口 javax.xml.stream.events.DTD 中的方法
返回定义 DTD 表示形式的实现。
getProfile() - 类 java.awt.color.ICC_ColorSpace 中的方法
返回此 ICC_ColorSpace 的 ICC_Profile。
getProfileClass() - 类 java.awt.color.ICC_Profile 中的方法
返回配置文件类。
getProgram(String...) - 接口 javax.script.ScriptEngineFactory 中的方法
返回一个包含给定语句的有效脚本语言的可执行程序。
getProgram() - 接口 javax.sound.midi.MidiChannel 中的方法
获得此通道的当前程序号。
getProgram() - 类 javax.sound.midi.Patch 中的方法
返回该 Patch 指定其位置的乐器在库中的索引号。
getProgress() - 类 javax.swing.SwingWorker 中的方法
返回 progress 绑定属性。
getProgressBarBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getProgressiveMode() - 类 javax.imageio.ImageWriteParam 中的方法
返回以逐步方式将数据写入流的当前模式。
getProgressMonitor() - 类 javax.swing.ProgressMonitorInputStream 中的方法
获取此流使用的 ProgressMonitor 对象。
getPrompt() - 类 javax.security.auth.callback.ChoiceCallback 中的方法
获取提示。
getPrompt() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取提示。
getPrompt() - 类 javax.security.auth.callback.NameCallback 中的方法
获取提示。
getPrompt() - 类 javax.security.auth.callback.PasswordCallback 中的方法
获取提示。
getPrompt() - 类 javax.security.auth.callback.TextInputCallback 中的方法
获取提示。
getPropagatedFrom() - 类 java.beans.beancontext.BeanContextEvent 中的方法
获得作为此事件传播源的 BeanContext。
getPropagationId() - 类 java.beans.PropertyChangeEvent 中的方法
保留 "propagationId" 字段以供将来使用。
getProperties() - 类 java.lang.System 中的静态方法
确定当前的系统属性。
getProperties() - 接口 javax.xml.crypto.dsig.SignatureProperties 中的方法
返回一个可修改的列表，由包含此在 SignatureProperties 中的一个或多个 SignatureProperty 组成。
getProperties() - 类 javax.xml.ws.Endpoint 中的方法
返回此 Endpoint 实例的属性包。
getProperty(String, ImageObserver) - 类 java.awt.image.BufferedImage 中的方法
按名称返回图像的属性。
getProperty(String) - 类 java.awt.image.BufferedImage 中的方法
按名称返回图像的属性。
getProperty(String, ImageObserver) - 类 java.awt.Image 中的方法
通过名称获取此图像的属性。
getProperty(ParameterBlock, String) - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
获取由 name 参数指定的属性的适当实例。
getProperty(String) - 接口 java.awt.image.renderable.RenderableImage 中的方法
从此图像的属性集中获取某个属性。
getProperty(String) - 类 java.awt.image.renderable.RenderableImageOp 中的方法
从此图像的属性集中获取某个属性。
getProperty(String) - 接口 java.awt.image.RenderedImage 中的方法
从此图像的属性设置中获取一个属性。
getProperty(String, String) - 类 java.awt.Toolkit 中的静态方法
获取具有指定键和默认值的属性。
getProperty(String) - 类 java.lang.System 中的静态方法
获取指定键指示的系统属性。
getProperty(String, String) - 类 java.lang.System 中的静态方法
获取用指定键描述的系统属性。
getProperty(String) - 类 java.security.Provider 中的方法

getProperty(String) - 类 java.security.Security 中的静态方法
获取安全属性值。
getProperty(String) - 类 java.util.logging.LogManager 中的方法
获取日志属性的值。
getProperty(String) - 类 java.util.Properties 中的方法
用指定的键在此属性列表中搜索属性。
getProperty(String, String) - 类 java.util.Properties 中的方法
用指定的键在属性列表中搜索属性。
getProperty(String) - 类 javax.sound.midi.MidiFileFormat 中的方法
获得由键指定的属性值。
getProperty(String) - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得键指定的属性值。
getProperty(String) - 类 javax.sound.sampled.AudioFormat 中的方法
获取键指定的属性值。
getProperty(Object) - 类 javax.swing.text.AbstractDocument 中的方法
查找属性值的便捷方法。
getProperty(Object) - 接口 javax.swing.text.Document 中的方法
获得与文档关联的属性。
getProperty(String) - 类 javax.xml.bind.Binder 中的方法
获取 Binder 的基础实现中的特定属性。
getProperty(String) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
getProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。
getProperty(String) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
由于没有必需的属性，getProperty 方法的默认实现总是抛出 PropertyException。
getProperty(String) - 接口 javax.xml.bind.Marshaller 中的方法
获取 Marshaller 底层实现中的特定属性。
getProperty(String) - 接口 javax.xml.bind.Unmarshaller 中的方法
获取 Unmarshaller 底层实现中的特定属性。
getProperty(String) - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
getProperty(String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 获取指定名称所映射的对象。
getProperty(String) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回指定属性的值。
getProperty(String) - 类 javax.xml.parsers.SAXParser 中的方法
返回 XMLReader 的底层实现中请求的特定属性。
getProperty(String) - 类 javax.xml.soap.SOAPMessage 中的方法
检索指定属性的值。
getProperty(String) - 类 javax.xml.stream.util.EventReaderDelegate 中的方法

getProperty(String) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getProperty(String) - 接口 javax.xml.stream.XMLEventReader 中的方法
从底层实现获取功能/属性值。
getProperty(String) - 类 javax.xml.stream.XMLInputFactory 中的方法
从底层实现获取功能/属性的值。
getProperty(String) - 类 javax.xml.stream.XMLOutputFactory 中的方法
获取底层实现上的功能/属性
getProperty(String) - 接口 javax.xml.stream.XMLStreamReader 中的方法
从底层实现获取功能/属性的值
getProperty(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
从底层实现获取功能/属性值
getProperty(String) - 类 javax.xml.validation.SchemaFactory 中的方法
查找属性值。
getProperty(String) - 类 javax.xml.validation.Validator 中的方法
查找属性值。
getProperty(String) - 类 javax.xml.validation.ValidatorHandler 中的方法
查找属性值。
getProperty(String) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
获取解析器属性。
getProperty(String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
查找属性值。
getProperty(String) - 接口 org.xml.sax.XMLReader 中的方法
查找属性的值。
getPropertyChangeEvent() - 异常 java.beans.PropertyVetoException 中的方法
获得禁止的 PropertyChangeEvent。
getPropertyChangeListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的属性更改侦听器的数组。
getPropertyChangeListeners(String) - 类 java.awt.Component 中的方法
返回与指定属性相关联的所有侦听器的数组。
getPropertyChangeListeners() - 类 java.awt.KeyboardFocusManager 中的方法
返回在此键盘焦点管理器上注册的所有属性更改侦听器组成的数组。
getPropertyChangeListeners(String) - 类 java.awt.KeyboardFocusManager 中的方法
返回与指定属性相关联的所有 PropertyChangeListener 组成的数组。
getPropertyChangeListeners(String) - 类 java.awt.SystemTray 中的方法
返回与指定属性关联的所有侦听器的数组。
getPropertyChangeListeners() - 类 java.awt.Toolkit 中的方法
返回在此工具包上所有已注册的属性更改侦听器所组成的数组。
getPropertyChangeListeners(String) - 类 java.awt.Toolkit 中的方法
返回与指定属性关联的所有 PropertyChangeListener 所组成的数组。
getPropertyChangeListeners() - 类 java.beans.PropertyChangeSupport 中的方法
返回使用 addPropertyChangeListener() 添加到此 PropertyChangeSupport 对象中的所有侦听器组成的数组。
getPropertyChangeListeners(String) - 类 java.beans.PropertyChangeSupport 中的方法
返回与指定属性相关联的所有侦听器的列表。
getPropertyChangeListeners() - 类 javax.swing.AbstractAction 中的方法
返回使用 addPropertyChangeListener() 添加到此 AbstractAction 中的所有 PropertyChangeListener 组成的数组。
getPropertyChangeListeners() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
返回一个在此组件上注册的所有属性更改侦听器的数组。
getPropertyChangeListeners() - 类 javax.swing.table.TableColumn 中的方法
返回使用 addPropertyChangeListener() 添加到此 TableColumn 的所有 PropertyChangeListener 组成的数组。
getPropertyChangeListeners() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回此 DefaultTreeSelectionModel 上注册的所有属性更改侦听器组成的数组。
getPropertyChangeListeners() - 类 javax.swing.UIDefaults 中的方法
返回使用 addPropertyChangeListener() 添加到此 UIDefaults 的所有 PropertyChangeListener 组成的数组。
getPropertyChangeListeners() - 类 javax.swing.UIManager 中的静态方法
返回添加到此 UIManager（具有 addPropertyChangeListener()）的所有 PropertyChangeListener 的数组。
getPropertyChangeSupport() - 类 javax.swing.SwingWorker 中的方法
返回此 SwingWorker 的 PropertyChangeSupport。
getPropertyDescriptors() - 接口 java.beans.BeanInfo 中的方法
获得 beans PropertyDescriptor。
getPropertyDescriptors() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝属性的信息。
getPropertyEditorClass() - 类 java.beans.PropertyDescriptor 中的方法
获得已为此属性注册的任何显式 PropertyEditor Class。
getPropertyInfo(String, Properties) - 接口 java.sql.Driver 中的方法
获得此驱动程序的可能属性信息。
getPropertyName() - 类 java.beans.PropertyChangeEvent 中的方法
获取已更改属性的编程名称。
getPropertyName() - 类 java.beans.PropertyChangeListenerProxy 中的方法
返回与侦听器相关联的指定属性的名称。
getPropertyName() - 类 java.beans.VetoableChangeListenerProxy 中的方法
返回与侦听器有关联的指定属性的名称。
getPropertyNames() - 类 java.awt.image.BufferedImage 中的方法
返回由 getProperty(String) 识别的名称数组；如果没有识别出属性名，则返回 null。
getPropertyNames() - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
返回由 getProperty 识别的名称列表。
getPropertyNames() - 接口 java.awt.image.renderable.RenderableImage 中的方法
返回由 getProperty 识别的名称列表。
getPropertyNames() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
返回由 getProperty 识别的名称列表。
getPropertyNames() - 接口 java.awt.image.RenderedImage 中的方法
返回由 getProperty(String) 识别的名称的数组，如果没有属性名被识别，则返回 null。
getPropertyOverrides() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
返回组的重写属性列表。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicCheckBoxUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicFormattedTextFieldUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicPasswordFieldUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicTextFieldUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicTextPaneUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取通过 UIManager 查找属性时用作键的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicToggleButtonUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.metal.MetalCheckBoxUI 中的方法

getPropertyType() - 类 java.beans.PropertyDescriptor 中的方法
获得属性的 Class 对象。
getProtectionDomain() - 类 java.lang.Class 中的方法
返回该类的 ProtectionDomain。
getProtectionParameter(String) - 类 java.security.KeyStore.Builder 中的方法
返回应该用来获取具有给定别名的 Entry 的 ProtectionParameters。
getProtectionParameter() - 接口 java.security.KeyStore.LoadStoreParameter 中的方法
获取用于保护 keystore 数据的参数。
getProtocol() - 类 java.net.URL 中的方法
获取此 URL 的协议名称。
getProtocol() - 类 javax.management.remote.JMXServiceURL 中的方法
Service URL 的协议部分。
getProtocol() - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法

getProtocol() - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法

getProtocol() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
返回该对象的协议字符串。
getProtocol() - 类 javax.net.ssl.SSLContext 中的方法
返回此 SSLContext 对象的协议名称。
getProtocol() - 接口 javax.net.ssl.SSLSession 中的方法
返回会话中的所有连接使用的协议的标准名称。
getProtocols() - 类 javax.net.ssl.SSLParameters 中的方法
返回协议数组的副本；如果未设置，则返回 null。
getPrototypeCellValue() - 类 javax.swing.JList 中的方法
返回“原型的”单元值，即用于计算单元的固定宽度和高度的值。
getPrototypeDisplayValue() - 类 javax.swing.JComboBox 中的方法
返回“原型显示”值，即用于计算显示高度和宽度的 Object。
getProvider() - 类 java.security.AlgorithmParameterGenerator 中的方法
返回此算法参数生成器对象的提供者。
getProvider() - 类 java.security.AlgorithmParameters 中的方法
返回此参数对象的提供者。
getProvider() - 类 java.security.cert.CertificateFactory 中的方法
返回此 CertificateFactory 的提供者。
getProvider() - 类 java.security.cert.CertPathBuilder 中的方法
返回此 CertPathBuilder 的提供者。
getProvider() - 类 java.security.cert.CertPathValidator 中的方法
返回此 CertPathValidator 的 Provider。
getProvider() - 类 java.security.cert.CertStore 中的方法
返回此 CertStore 的提供者。
getProvider() - 类 java.security.KeyFactory 中的方法
返回此密钥工厂对象的提供者。
getProvider() - 类 java.security.KeyPairGenerator 中的方法
返回此密钥对生成器对象的提供者。
getProvider() - 类 java.security.KeyStore 中的方法
返回此 keystore 的提供者。
getProvider() - 类 java.security.MessageDigest 中的方法
返回此信息摘要对象的提供者。
getProvider() - 类 java.security.Policy 中的方法
返回此 Policy 的 Provider。
getProvider() - 类 java.security.Provider.Service 中的方法
返回此服务的 Provider。
getProvider() - 类 java.security.SecureRandom 中的方法
返回此 SecureRandom 对象的提供者。
getProvider(String) - 类 java.security.Security 中的静态方法
返回使用指定的名称安装的提供者（如果有）。
getProvider() - 类 java.security.Signature 中的方法
返回此签名对象的提供者。
getProvider() - 类 javax.crypto.Cipher 中的方法
返回此 Cipher 对象的提供者。
getProvider() - 类 javax.crypto.ExemptionMechanism 中的方法
返回此 ExemptionMechanism 对象的提供者。
getProvider() - 类 javax.crypto.KeyAgreement 中的方法
返回此 KeyAgreement 对象的提供者。
getProvider() - 类 javax.crypto.KeyGenerator 中的方法
返回此 KeyGenerator 对象的提供者。
getProvider() - 类 javax.crypto.Mac 中的方法
返回此 Mac 对象的提供者。
getProvider() - 类 javax.crypto.SecretKeyFactory 中的方法
返回此 SecretKeyFactory 对象的提供者。
getProvider() - 类 javax.net.ssl.KeyManagerFactory 中的方法
返回此 KeyManagerFactory 对象的提供者。
getProvider() - 类 javax.net.ssl.SSLContext 中的方法
返回此 SSLContext 对象的提供者。
getProvider() - 类 javax.net.ssl.TrustManagerFactory 中的方法
返回此 TrustManagerFactory 对象的提供者。
getProvider() - 类 javax.security.auth.login.Configuration 中的方法
返回此 Configuration 的 Provider。
getProvider() - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
返回此 KeyInfoFactory 的提供者。
getProvider() - 类 javax.xml.crypto.dsig.TransformService 中的方法
返回此 TransformService 的提供者。
getProvider() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
返回此 XMLSignatureFactory 的提供者。
getProviderGrade() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回一个常量，它指示 RowSet 对象希望从此 SyncProvider 对象获得的同步等级。
getProviderID() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回此 SyncProvider 对象的唯一标识符。
getProviders() - 类 java.security.Security 中的静态方法
返回包含所有已安装的提供者的数组。
getProviders(String) - 类 java.security.Security 中的静态方法
返回包含满足指定的选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。
getProviders(Map<String, String>) - 类 java.security.Security 中的静态方法
返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。
getProxyClass(ClassLoader, Class<?>...) - 类 java.lang.reflect.Proxy 中的静态方法
返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
getPSName() - 类 java.awt.Font 中的方法
返回此 Font 的 postscript 名称。
getPSource() - 类 javax.crypto.spec.OAEPParameterSpec 中的方法
返回编码输入 P 的源。
getPublic() - 类 java.security.KeyPair 中的方法
返回对此密钥对的公钥组件的引用。
getPublicCredentials() - 类 javax.security.auth.Subject 中的方法
返回此 Subject 中包含的公开证书 Set。
getPublicCredentials(Class<T>) - 类 javax.security.auth.Subject 中的方法
返回与此 Subject 关联的公开证书 Set，它是指定的 Class 的实例或子类。
getPublicExponent() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回公用指数。
getPublicExponent() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回公用指数。
getPublicExponent() - 接口 java.security.interfaces.RSAPublicKey 中的方法
返回该公用指数。
getPublicExponent() - 类 java.security.spec.RSAKeyGenParameterSpec 中的方法
返回公用指数值。
getPublicExponent() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回公用指数。
getPublicExponent() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回公用指数。
getPublicExponent() - 类 java.security.spec.RSAPublicKeySpec 中的方法
返回该公用指数。
getPublicId() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
实体的公共标识符，如果未给定该标识符，则为 null
getPublicId() - 接口 javax.xml.stream.events.NotationDeclaration 中的方法
注释的公共标识符，如果未提供该标识符，则为 null。
getPublicId() - 接口 javax.xml.stream.Location 中的方法
返回 XML 的公共 ID
getPublicId() - 接口 javax.xml.transform.SourceLocator 中的方法
返回当前文档事件的公共标识符。
getPublicId() - 类 javax.xml.transform.stream.StreamSource 中的方法
获取通过 setPublicId 设置的公共标识符。
getPublicId() - 接口 org.w3c.dom.DocumentType 中的方法
外部子集的公共标识符。
getPublicId() - 接口 org.w3c.dom.Entity 中的方法
如果已指定，则为与实体相关的公共标识符；否则为 null。
getPublicId() - 接口 org.w3c.dom.ls.LSInput 中的方法
此输入源的公共标识符。
getPublicId() - 接口 org.w3c.dom.Notation 中的方法
此表示法的公共标识符。
getPublicId() - 类 org.xml.sax.helpers.LocatorImpl 中的方法
返回保存的公开标识符。
getPublicId() - 类 org.xml.sax.InputSource 中的方法
获取此输入源的公共标识符。
getPublicId() - 接口 org.xml.sax.Locator 中的方法
返回当前文档事件的公共标识符。
getPublicId() - 异常 org.xml.sax.SAXParseException 中的方法
获取发生异常的实体的公共标识符。
getPublicKey() - 类 java.security.cert.Certificate 中的方法
从此证书中获取公钥。
getPublicKey() - 类 java.security.cert.PKIXCertPathValidatorResult 中的方法
返回证书路径主体（目标）的公钥，如果适用，要包括所有继承的公钥参数。
getPublicKey() - 接口 java.security.Certificate 中的方法
已过时。 返回保证人所保证的主体密钥对的密钥。
getPublicKey() - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 的公钥。
getPublicKey() - 类 javax.security.cert.Certificate 中的方法
从此证书中获取公钥。
getPublicKey() - 接口 javax.xml.crypto.dsig.keyinfo.KeyValue 中的方法
返回此 KeyValue 的公钥。
getPurgeFlag() - 类 javax.management.relation.RelationService 中的方法
返回一个标志，以指示何时接收注销关系中引用的 MBean 的通知，指示是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在将显式调用 purgeRelations 方法时执行该操作。
getPurgeFlag() - 接口 javax.management.relation.RelationServiceMBean 中的方法
返回一个标志，以指示注销关系中引用的 MBean 时是否接收到通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。
getPushLevel() - 类 java.util.logging.MemoryHandler 中的方法
获得 pushLevel。
getQ() - 接口 java.security.interfaces.DSAParams 中的方法
返回子素数 q。
getQ() - 类 java.security.spec.DSAParameterSpec 中的方法
返回子素数 q。
getQ() - 类 java.security.spec.DSAPrivateKeySpec 中的方法
返回子素数 q。
getQ() - 类 java.security.spec.DSAPublicKeySpec 中的方法
返回子素数 q。
getQName(int) - 接口 org.xml.sax.Attributes 中的方法
通过索引查找属性的 XML 限定（前缀）名。
getQName(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
返回属性的限定（加前缀的）名称。
getQOP() - 类 org.ietf.jgss.MessageProp 中的方法
检索 QOP 值。
getQTables() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
返回最近一次调用 setDecodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getQTables() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
返回最近一次调用 setEncodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getQuadrantRotateInstance(int) - 类 java.awt.geom.AffineTransform 中的静态方法
返回按指定象限数旋转坐标的变换。
getQuadrantRotateInstance(int, double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回按指定象限数绕指定锚点旋转坐标的变换。
getQualifiedName() - 接口 javax.lang.model.element.PackageElement 中的方法
返回此包的完全限定名称。
getQualifiedName() - 接口 javax.lang.model.element.TypeElement 中的方法
返回此类型元素的完全限定名称。
getQualifiedName() - 接口 javax.xml.soap.Name 中的方法
获取此 Name 对象表示的 XML 名称限定于命名空间的名称。
getQuery() - 类 java.net.URI 中的方法
返回此 URI 的已解码的查询组成部分。
getQuery() - 类 java.net.URL 中的方法
获取此 URL 的查询部分。
getQueryTimeout() - 接口 java.sql.Statement 中的方法
获取驱动程序等待 Statement 对象执行的秒数。
getQueryTimeout() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取驱动程序等待查询执行的最大秒数。
getQueryTimeout() - 接口 javax.sql.RowSet 中的方法
获取驱动程序等待语句执行的最大秒数。
getQueue() - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
返回此执行程序使用的任务队列。
getQueue() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回此执行程序使用的任务队列。
getQueuedReaderThreads() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回一个 collection，它包含可能正在等待获取读取锁的线程。
getQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回一个 collection，该 collection 包含正在等待获取的线程。
getQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回包含可能正在等待获取的线程 collection。
getQueuedThreads() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回一个 collection，它包含可能正等待获取此锁的线程。
getQueuedThreads() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回一个 collection，它包含可能正在等待获取读取或写入锁的线程。
getQueuedThreads() - 类 java.util.concurrent.Semaphore 中的方法
返回一个 collection，包含可能等待获取的线程。
getQueuedWriterThreads() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回一个 collection，它包含可能正在等待获取写入锁的线程。
getQueueLength() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回等待获取的线程估计数。
getQueueLength() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回等待获取的线程数估计值。
getQueueLength() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回正等待获取此锁的线程估计数。
getQueueLength() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回等待获取读取或写入锁的线程估计数目。
getQueueLength() - 类 java.util.concurrent.Semaphore 中的方法
返回正在等待获取的线程的估计数目。
getRadioButtonBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getRadioButtonIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getRadioButtonIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getRadioButtonMenuItemIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getRadioButtonMenuItemIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getRadius() - 类 java.awt.RadialGradientPaint 中的方法
返回定义辐射状渐变的圆的半径。
getRaisedBevelBorderUIResource() - 类 javax.swing.plaf.BorderUIResource 中的静态方法

getRanges() - 类 java.awt.font.NumericShaper 中的方法
返回一个 int，它使用或操作 (OR) 连接所有将成形的范围的值。
getRaster() - 类 java.awt.image.BufferedImage 中的方法
返回 WritableRaster。
getRaster(int, int, int, int) - 接口 java.awt.PaintContext 中的方法
返回包含为图形操作生成的颜色的 Raster。
getRaster() - 类 javax.imageio.IIOImage 中的方法
返回当前设置好的 Raster，如果只有一个 RenderedImage 可用，则返回 null。
getRawAuthority() - 类 java.net.URI 中的方法
返回此 URI 的原始授权组成部分。
getRawContent() - 类 javax.xml.soap.AttachmentPart 中的方法
以 InputStream 的形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。
getRawContentBytes() - 类 javax.xml.soap.AttachmentPart 中的方法
以 byte[] 数组形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。
getRawFragment() - 类 java.net.URI 中的方法
返回此 URI 的原始片段组成部分。
getRawImageType(int) - 类 javax.imageio.ImageReader 中的方法
返回一个 ImageTypeSpecifier，指示最能代表图像“原始”内部格式的 SampleModel 和 ColorModel。
getRawOffset() - 类 java.util.SimpleTimeZone 中的方法
获取此时区的 GMT 偏移量。
getRawOffset() - 类 java.util.TimeZone 中的方法
返回添加到 UTC 以获取此时区中的标准时间的时间量（以毫秒为单位）。
getRawPath() - 类 java.net.URI 中的方法
返回此 URI 的原始路径组成部分。
getRawQuery() - 类 java.net.URI 中的方法
返回此 URI 的原始查询组成部分。
getRawSchemeSpecificPart() - 类 java.net.URI 中的方法
返回此 URI 原始的、特定于方案的部分。
getRawType() - 接口 java.lang.reflect.ParameterizedType 中的方法
返回 Type 对象，表示声明此类型的类或接口。
getRawUserInfo() - 类 java.net.URI 中的方法
返回此 URI 的原始用户信息组成部分。
getRdn(int) - 类 javax.naming.ldap.LdapName 中的方法
以 Rdn 形式检索此 LDAP 名称的 RDN。
getRdns() - 类 javax.naming.ldap.LdapName 中的方法
检索相对标识名列表。
getRead() - 异常 java.sql.DataTruncation 中的方法
指示该值是否在读取时被截断。
getReader() - 接口 javax.script.ScriptContext 中的方法
返回脚本用来读取输入的 Reader。
getReader() - 类 javax.script.SimpleScriptContext 中的方法
返回脚本用来读取输入的 Reader。
getReader(int) - 类 javax.swing.text.html.HTMLDocument 中的方法
获取加载带有 HTML 的文档时所用解析器的 reader。
getReader(int, int, int, HTML.Tag) - 类 javax.swing.text.html.HTMLDocument 中的方法
返回加载带有 HTML 的文档时所用解析器的 reader。
getReader() - 类 javax.xml.transform.stream.StreamSource 中的方法
获取通过 setReader 设置的字符流。
getReaderFileSuffixes() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出与当前已注册 reader 集合所理解的格式关联的所有文件后缀。
getReaderFormatNames() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有非正式格式名称。
getReaderForText(Transferable) - 类 java.awt.datatransfer.DataFlavor 中的方法
获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。
getReaderForText() - 接口 javax.print.Doc 中的方法
获得一个从此 doc 中提取字符打印数据的 reader。
getReaderForText() - 类 javax.print.SimpleDoc 中的方法
获得一个从此 doc 中提取字符打印数据的 reader。
getReaderMIMETypes() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有 MIME 类型。
getReaderServiceProviderName() - 类 javax.imageio.spi.ImageTranscoderSpi 中的方法
返回 ImageReaderSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。
getReadHoldCount() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询当前线程在此锁上保持的重入读取锁数量。
getReadLockCount() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询为此锁保持的读取锁数量。
getReadMethod() - 类 java.beans.PropertyDescriptor 中的方法
获得应该用于读取属性值的方法。
getReadTimeout() - 类 java.net.URLConnection 中的方法
返回读入超时设置。
getRealm() - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
返回此 Kerberos 主体的域组件。
getReason() - 异常 java.net.HttpRetryException 中的方法
返回解释不能重试 http 请求的原因的字符串。
getReason() - 异常 java.net.URISyntaxException 中的方法
返回一个字符串，解释输入字符串不能解析的原因。
getReason() - 接口 javax.print.URIException 中的方法
返回事件的原因。
getReceiveBufferSize() - 类 java.net.DatagramSocket 中的方法
获取此 DatagramSocket 的 SO_RCVBUF 选项的值，该值是平台在 DatagramSocket 上输入时使用的缓冲区大小。
getReceiveBufferSize() - 类 java.net.ServerSocket 中的方法
获取此 ServerSocket 的 SO_RCVBUF 选项的值，该值是将用于从此 ServerSocket 接受的套接字的建议缓冲区大小。
getReceiveBufferSize() - 类 java.net.Socket 中的方法
获取此 Socket 的 SO_RCVBUF 选项的值，该值是平台在 Socket 上输入时使用的缓冲区大小。
getReceiver() - 接口 javax.sound.midi.MidiDevice 中的方法
获得 MIDI 设备可通过其接收 MIDI 数据的 MIDI IN 接收器。
getReceiver() - 类 javax.sound.midi.MidiSystem 中的静态方法
从外部 MIDI 端口或其他默认设备获得 MIDI 接收器。
getReceiver() - 接口 javax.sound.midi.Transmitter 中的方法
获得此传输器将向其传送 MIDI 消息的当前接收器。
getReceivers() - 接口 javax.sound.midi.MidiDevice 中的方法
返回与该 MidiDevice 连接的所有当前活动的、非关闭的接收器。
getRecursionLimit() - 类 java.awt.geom.FlatteningPathIterator 中的方法
返回此迭代器的递归限制。
getRed() - 类 java.awt.Color 中的方法
返回默认 sRGB 空间中位于范围 0-255 中的红色分量。
getRed(int) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(Object) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(int) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的红色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(Object) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的红色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(int) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(Object) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(int) - 类 java.awt.image.IndexColorModel 中的方法
返回指定像素的红色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。
getRedMask() - 类 java.awt.image.DirectColorModel 中的方法
返回指定 int 像素表示形式中哪些位包含红色分量的掩码。
getRedoPresentationName() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
提供此次编辑可重复执行形式的、已本地化的、可读的描述，例如用作 Redo 菜单项。
getRedoPresentationName() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
检索默认表中 AbstractUndoableEdit.redoText 键的值，并返回该值，后跟一个空格和 getPresentationName。
getRedoPresentationName() - 类 javax.swing.undo.CompoundEdit 中的方法
从添加到 edits 的最后 UndoableEdit 返回 getRedoPresentationName。
getRedoPresentationName() - 接口 javax.swing.undo.UndoableEdit 中的方法
返回此编辑可恢复形式的本地化可读描述，例如，适于用作 “Redo” 菜单项。
getRedoPresentationName() - 类 javax.swing.undo.UndoManager 中的方法
返回此编辑可恢复形式的描述。
getReds(byte[]) - 类 java.awt.image.IndexColorModel 中的方法
将红色分量数组复制到指定的数组中。
getReductionPolynomial() - 类 java.security.spec.ECFieldF2m 中的方法
对于多项式方法，返回一个 BigInteger，其第 i 位对应于降序排列多项式的第 i 个系数，对于常规方法，返回 null。
getRef() - 类 java.net.URL 中的方法
获取此 URL 的锚点（也称为“引用”）。
getRef() - 类 java.rmi.server.RemoteObject 中的方法
返回远程对象的远程引用。
getRef(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Ref 对象的形式获取指定的 JDBC REF(<structured-type>) 参数的值。
getRef(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Ref 对象的形式获取 JDBC REF(<structured-type>) 参数的值。
getRef(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getRef(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getRefClass(ObjectOutput) - 接口 java.rmi.server.RemoteRef 中的方法
返回要在流 'out' 上序列化的 ref 类型的类名称。
getReference() - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
返回该引用的当前值。
getReference() - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
返回该引用的当前值。
getReference() - 接口 javax.naming.Referenceable 中的方法
检索此对象的 Reference。
getReferencedMBeans() - 接口 javax.management.relation.Relation 中的方法
检索在该关系的各种角色中引用的 MBean。
getReferencedMBeans(String) - 类 javax.management.relation.RelationService 中的方法
检索关系的各种角色中引用的 MBean。
getReferencedMBeans(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索关系的各种角色中引用的 MBean。
getReferencedMBeans() - 类 javax.management.relation.RelationSupport 中的方法
检索在该关系的各种角色中引用的 MBean。
getReferences() - 接口 javax.xml.crypto.dsig.Manifest 中的方法
返回一个不可修改的列表，由包含在此 Manifest 中的一个或多个 Reference 组成。
getReferences() - 接口 javax.xml.crypto.dsig.SignedInfo 中的方法
返回一个或多个 Reference 的不可修改的列表。
getReferralContext() - 异常 javax.naming.ldap.LdapReferralException 中的方法
使用上下文的环境（但不使用控件）检索继续该方法的上下文。
getReferralContext(Hashtable<?, ?>) - 异常 javax.naming.ldap.LdapReferralException 中的方法
使用环境属性（但不使用控件）检索继续该方法的上下文。
getReferralContext(Hashtable<?, ?>, Control[]) - 异常 javax.naming.ldap.LdapReferralException 中的方法
使用请求控件和环境属性检索继续该方法的上下文。
getReferralContext() - 异常 javax.naming.ReferralException 中的方法
检索继续该方法的上下文。
getReferralContext(Hashtable<?, ?>) - 异常 javax.naming.ReferralException 中的方法
使用环境属性检索继续该方法的上下文。
getReferralInfo() - 异常 javax.naming.ReferralException 中的方法
检索与此引用有关的信息（比如 URL）。
getReferrals() - 接口 javax.naming.ldap.UnsolicitedNotification 中的方法
检索服务器发送的引用。
getRefMBeanClassName() - 类 javax.management.relation.RoleInfo 中的方法
返回期望在相应角色中引用的 MBean 的类型名称。
getRefreshRate() - 类 java.awt.DisplayMode 中的方法
返回显示的刷新率（以赫兹表示）如果信息不可用，则它可以是 REFRESH_RATE_UNKNOWN。
getRegion() - 类 javax.swing.plaf.synth.SynthContext 中的方法
返回标识此状态的 Region。
getRegion(JComponent) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
返回 JComponent c 的 Region。
getRegisteredKeyStrokes() - 类 javax.swing.JComponent 中的方法
返回启动已注册动作的 KeyStrokes。
getRegisteredProviders() - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
返回当前已注册的同步提供者所组成的枚举。
getRegistry() - 类 java.rmi.registry.LocateRegistry 中的静态方法
返回本地主机在默认注册表端口 1099 上对远程对象 Registry 的引用。
getRegistry(int) - 类 java.rmi.registry.LocateRegistry 中的静态方法
返回本地主机在指定 port 上对远程对象 Registry 的引用。
getRegistry(String) - 类 java.rmi.registry.LocateRegistry 中的静态方法
返回指定 host 在默认注册表端口 1099 上对远程对象 Registry 的引用。
getRegistry(String, int) - 类 java.rmi.registry.LocateRegistry 中的静态方法
返回指定的 host 和 port 上对远程对象 Registry 的引用。
getRegistry(String, int, RMIClientSocketFactory) - 类 java.rmi.registry.LocateRegistry 中的静态方法
返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。
getRejectedExecutionHandler() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回用于未执行任务的当前处理程序。
getRelatedData() - 接口 org.w3c.dom.DOMError 中的方法
相关的与 DOMError.type 有关的数据（如果有）。
getRelatedException() - 接口 org.w3c.dom.DOMError 中的方法
相关的与相关平台有关的异常（如果有）。
getRelatedNode() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的节点；如果没有可用的节点，则为 null。
getRelatedNode() - 接口 org.w3c.dom.events.MutationEvent 中的方法
relatedNode 用于识别与 mutation 事件相关联的辅助节点。
getRelatedTarget() - 接口 org.w3c.dom.events.MouseEvent 中的方法
用于识别与 UI 事件相关的辅助 EventTarget。
getRelationId() - 接口 javax.management.relation.Relation 中的方法
返回关系标识符（用于唯一标识 Relation Service 内的关系）。
getRelationId() - 类 javax.management.relation.RelationNotification 中的方法
返回创建/移除/更新的关系的关系标识符。
getRelationId() - 类 javax.management.relation.RelationSupport 中的方法
返回关系标识符（用于唯一标识 Relation Service 中的关系）。
getRelationServiceName() - 接口 javax.management.relation.Relation 中的方法
返回处理关系的 Relation Service 的 ObjectName。
getRelationServiceName() - 类 javax.management.relation.RelationSupport 中的方法
返回处理关系的 Relation Service 的 ObjectName。
getRelationTypeName() - 接口 javax.management.relation.Relation 中的方法
返回相关关系类型的名称。
getRelationTypeName() - 类 javax.management.relation.RelationNotification 中的方法
返回创建/移除/更新的关系的关系类型名称。
getRelationTypeName(String) - 类 javax.management.relation.RelationService 中的方法
返回给定关系的相关关系类型的名称。
getRelationTypeName(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
返回给定关系的相关关系类型的名称。
getRelationTypeName() - 类 javax.management.relation.RelationSupport 中的方法
返回相关关系类型的名称。
getRelationTypeName() - 接口 javax.management.relation.RelationType 中的方法
返回关系类型名称。
getRelationTypeName() - 类 javax.management.relation.RelationTypeSupport 中的方法
返回关系类型名称。
getRelay() - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
返回此 SOAPHeaderElement relay 属性的 boolean 值。
getRemaining() - 类 java.util.zip.Inflater 中的方法
返回输入缓冲区中剩余的字节总数。
getRemainingAcceptLifetime(Oid) - 接口 org.ietf.jgss.GSSCredential 中的方法
返回凭据以秒为单位的生存期，以便能够继续使用指定的机制接受安全上下文。
getRemainingInitLifetime(Oid) - 接口 org.ietf.jgss.GSSCredential 中的方法
返回凭据以秒为单位的生存期，以便能够继续使用指定的机制初始化安全上下文。
getRemainingLifetime() - 接口 org.ietf.jgss.GSSCredential 中的方法
返回凭据所剩余的以秒为单位的生存期。
getRemainingName() - 异常 javax.naming.NamingException 中的方法
检索名称的剩余未解析部分。
getRemainingName() - 类 javax.naming.spi.ResolveResult 中的方法
检索名称的剩余未解析部分。
getRemainingNewName() - 异常 javax.naming.CannotProceedException 中的方法
检索此异常的 "remaining new name" 字段，当执行 rename() 操作期间抛出此异常时，将使用该字段。
getRemoteSocketAddress() - 类 java.net.DatagramSocket 中的方法
返回此套接字连接的端点的地址，如果未连接则返回 null。
getRemoteSocketAddress() - 类 java.net.Socket 中的方法
返回此套接字连接的端点的地址，如果未连接则返回 null。
getRemoveListenerMethod() - 类 java.beans.EventSetDescriptor 中的方法
获得用来移除事件侦听器的方法。
getRenderableSource(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回作为 RenderableImage 的源。
getRenderedImage() - 类 javax.imageio.IIOImage 中的方法
返回当前设置好的 RenderedImage，如果只有一个 Raster 可用，则返回 null。
getRenderedSource(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回作为 RenderedImage 的源。
getRenderer() - 类 javax.swing.JComboBox 中的方法
返回用于显示 JComboBox 字段中所选项的渲染器。
getRenderingHint(RenderingHints.Key) - 类 java.awt.Graphics2D 中的方法
返回呈现算法的单个首选项的值。
getRenderingHints() - 类 java.awt.Graphics2D 中的方法
获取呈现算法的首选项。
getRenderingHints() - 类 java.awt.image.AffineTransformOp 中的方法
返回此转换操作使用的呈现提示。
getRenderingHints() - 类 java.awt.image.BandCombineOp 中的方法
返回针对此操作呈现的提示。
getRenderingHints() - 接口 java.awt.image.BufferedImageOp 中的方法
返回针对此操作所呈现的提示。
getRenderingHints() - 类 java.awt.image.ColorConvertOp 中的方法
此操作使用的呈现提示。
getRenderingHints() - 类 java.awt.image.ConvolveOp 中的方法
返回此 op 的呈现提示。
getRenderingHints() - 类 java.awt.image.LookupOp 中的方法
返回此操作的呈现提示。
getRenderingHints() - 接口 java.awt.image.RasterOp 中的方法
返回此 RasterOp 的呈现提示。
getRenderingHints() - 类 java.awt.image.renderable.RenderContext 中的方法
获取此 RenderContext 的呈现提示。
getRenderingHints() - 类 java.awt.image.RescaleOp 中的方法
返回此操作的呈现提示。
getRenewTill() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回此票据最新的期满时间，包括所有的更新。
getReorderingAllowed() - 类 javax.swing.table.JTableHeader 中的方法
如果允许用户通过拖动各列的头对其进行重新安排，则返回 true；否则返回 false。
getReplacementText() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
实体的替换文本。
getReplayDetState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定是否针对此上下文中的 per-message 安全服务启用了重放检测。
getRepresentationClass() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回请求此 DataFlavor 时，支持此 DataFlavor 的对象将返回的 Class。
getRepresentationClass() - 类 javax.activation.ActivationDataFlavor 中的方法
返回表示形式类。
getRepresentationClassName() - 类 javax.print.DocFlavor 中的方法
返回此 DocFlavor 对象的表示形式类名。
getRequestContext() - 接口 javax.xml.ws.BindingProvider 中的方法
获取用于初始化请求消息的消息上下文的上下文。
getRequestControls() - 类 javax.naming.ldap.InitialLdapContext 中的方法

getRequestControls() - 接口 javax.naming.ldap.LdapContext 中的方法
检索对此上下文有效的请求控件。
getRequestingHost() - 类 java.net.Authenticator 中的方法
获取请求验证的站点或代理的 hostname；如果不可用，则为 null。
getRequestingPort() - 类 java.net.Authenticator 中的方法
获取所请求的连接的端口号。
getRequestingPrompt() - 类 java.net.Authenticator 中的方法
获取请求方给出的提示字符串。
getRequestingProtocol() - 类 java.net.Authenticator 中的方法
给出正在请求连接的协议。
getRequestingScheme() - 类 java.net.Authenticator 中的方法
获取请求方的方案（例如，HTTP 防火墙的 HTTP 方案）。
getRequestingSite() - 类 java.net.Authenticator 中的方法
获取请求授权的站点的 InetAddress；如果不可用，则为 null。
getRequestingURL() - 类 java.net.Authenticator 中的方法
返回导致请求验证的 URL。
getRequestMethod() - 类 java.net.HttpURLConnection 中的方法
获取请求方法。
getRequestorType() - 类 java.net.Authenticator 中的方法
返回请求方是代理还是服务器。
getRequestProperties() - 类 java.net.URLConnection 中的方法
返回一个由此连接的一般请求属性构成的不可修改的 Map。
getRequestProperty(String) - 类 java.net.URLConnection 中的方法
返回此连接指定的一般请求属性值。
getReshowDelay() - 类 javax.swing.ToolTipManager 中的方法
返回重新显示延迟属性。
getResizable() - 类 javax.swing.table.TableColumn 中的方法
如果允许用户调整 TableColumn 的宽度，则返回 true；否则返回 false。
getResizeWeight() - 类 javax.swing.JSplitPane 中的方法
返回确定额外空间如何分配的数。
getResizeWeight(int) - 类 javax.swing.text.BoxView 中的方法
获取调整的权重。
getResizeWeight(int) - 类 javax.swing.text.FieldView 中的方法
确定视图沿给定轴的大小可调整性。
getResizeWeight(int) - 类 javax.swing.text.html.BlockView 中的方法
获取调整的权重。
getResizeWeight(int) - 类 javax.swing.text.TableView.TableRow 中的方法
确定视图沿给定轴的大小可调整性。
getResizeWeight(int) - 类 javax.swing.text.View 中的方法
确定视图沿给定轴的大小可调整性。
getResizingAllowed() - 类 javax.swing.table.JTableHeader 中的方法
如果允许用户通过在头间拖动来调整各列的大小，则返回 true；否则返回 false。
getResizingColumn() - 类 javax.swing.table.JTableHeader 中的方法
返回正在调整其大小的列。
getResolution(int) - 类 javax.print.attribute.ResolutionSyntax 中的方法
获取给定单位的此分辨率属性的分辨率值。
getResolution() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得 MIDI 文件的定时精度。
getResolution() - 类 javax.sound.midi.Sequence 中的方法
获得此 Sequence 的定时精度。
getResolvedName() - 异常 javax.naming.NamingException 中的方法
检索成功被解析的名称的开头部分。
getResolvedObj() - 异常 javax.naming.NamingException 中的方法
检索已成功解析成的对象。
getResolvedObj() - 类 javax.naming.spi.ResolveResult 中的方法
检索已成功解析成的 Object。
getResolveParent() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取要解析的父级。
getResolveParent() - 接口 javax.swing.text.AttributeSet 中的方法
获取解析父集合。
getResolveParent() - 类 javax.swing.text.html.HTMLDocument.BlockElement 中的方法
获得解析父级。
getResolveParent() - 类 javax.swing.text.html.HTMLDocument.RunElement 中的方法
获得解析父级。
getResolveParent() - 接口 javax.swing.text.Keymap 中的方法
获取用于解析键绑定的父级 keymap。
getResolveParent() - 类 javax.swing.text.SimpleAttributeSet 中的方法
获取正解析的父级。
getResolveParent() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
从父级获取属性。
getResolveParent() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
如果未重写，解析父级默认为是解析父元素。
getResource(String, BeanContextChild) - 接口 java.beans.beancontext.BeanContext 中的方法
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
getResource(String, BeanContextChild) - 类 java.beans.beancontext.BeanContextSupport 中的方法

getResource(String) - 类 java.lang.Class 中的方法
查找带有给定名称的资源。
getResource(String) - 类 java.lang.ClassLoader 中的方法
查找具有给定名称的资源。
getResource(JavaFileManager.Location, CharSequence, CharSequence) - 接口 javax.annotation.processing.Filer 中的方法
返回一个用于读取现有资源的对象。
getResource(String) - 接口 javax.management.loading.MLetMBean 中的方法
查找具有给定名称的资源。
getResourceAsStream(String, BeanContextChild) - 接口 java.beans.beancontext.BeanContext 中的方法
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
getResourceAsStream(String, BeanContextChild) - 类 java.beans.beancontext.BeanContextSupport 中的方法

getResourceAsStream(String) - 类 java.lang.Class 中的方法
查找具有给定名称的资源。
getResourceAsStream(String) - 类 java.lang.ClassLoader 中的方法
返回读取指定资源的输入流。
getResourceAsStream(String) - 接口 javax.management.loading.MLetMBean 中的方法
返回读取指定资源的输入流。
getResourceBaseName() - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
返回当前设置的用于查找 ResourceBundle 的基本名称。
getResourceBundle() - 类 java.util.logging.Logger 中的方法
获取此 logger 在当前默认语言环境的本地化资源包。
getResourceBundle() - 类 java.util.logging.LogRecord 中的方法
获取本地化资源包。
getResourceBundleName() - 类 java.util.logging.Level 中的方法
返回级别的本地化资源包名称；如果没有定义本地化包，则返回 null。
getResourceBundleName() - 类 java.util.logging.Logger 中的方法
获取此 logger 的本地化资源包名称。
getResourceBundleName() - 类 java.util.logging.LogRecord 中的方法
获取本地化资源包名称。
getResourceResolver() - 类 javax.xml.validation.SchemaFactory 中的方法
获取设置为此 SchemaFactory 的当前 LSResourceResolver。
getResourceResolver() - 类 javax.xml.validation.Validator 中的方法
获取设置为此 Validator 的当前 LSResourceResolver。
getResourceResolver() - 类 javax.xml.validation.ValidatorHandler 中的方法
获取设置到此 ValidatorHandler 的当前 LSResourceResolver。
getResources(String) - 类 java.lang.ClassLoader 中的方法
查找所有给定名称的资源。
getResources(String) - 接口 javax.management.loading.MLetMBean 中的方法
查找所有具有给定名称的资源。
getResources() - 接口 javax.sound.midi.Soundbank 中的方法
提取音库中包含的非乐器资源列表。
getResponseCode() - 类 java.net.HttpURLConnection 中的方法
从 HTTP 响应消息获取状态码。
getResponseContext() - 接口 javax.xml.ws.BindingProvider 中的方法
获取处理响应消息所得的上下文。
getResponseControls() - 类 javax.naming.ldap.InitialLdapContext 中的方法

getResponseControls() - 接口 javax.naming.ldap.LdapContext 中的方法
检索对此上下文调用的最后一个方法所生成的响应控件。
getResponseMessage() - 类 java.net.HttpURLConnection 中的方法
获取与来自服务器的响应代码一起返回的 HTTP 响应消息（如果有）。
getRestartMode() - 类 java.rmi.activation.ActivationDesc 中的方法
返回与此激活描述符关联的对象的“重启”模式。
getResult() - 接口 javax.xml.bind.UnmarshallerHandler 中的方法
获得解组的结果。
getResult() - 类 javax.xml.bind.util.JAXBResult 中的方法
获取通过转换创建的已解组对象。
getResult() - 类 javax.xml.soap.SAAJResult 中的方法

getResultCode() - 类 javax.naming.ldap.SortResponseControl 中的方法
检索排序操作的 LDAP 结果代码。
getResultSet() - 接口 java.sql.Array 中的方法
获取包含此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
getResultSet(Map<String, Class<?>>) - 接口 java.sql.Array 中的方法
获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
getResultSet(long, int) - 接口 java.sql.Array 中的方法
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
getResultSet(long, int, Map<String, Class<?>>) - 接口 java.sql.Array 中的方法
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
getResultSet() - 接口 java.sql.Statement 中的方法
以 ResultSet 对象的形式获取当前结果。
getResultSet(long, int) - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取保存子数组元素的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
getResultSet(Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。
getResultSet() - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 ARRAY 值中的元素。
getResultSet(long, int, Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
getResultSetConcurrency() - 接口 java.sql.Statement 中的方法
获取此 Statement 对象生成的 ResultSet 对象的结果集合并发性。
getResultSetHoldability() - 接口 java.sql.DatabaseMetaData 中的方法
针对 ResultSet 对象获取此数据库的默认可保存性。
getResultSetHoldability() - 接口 java.sql.Statement 中的方法
获取此 Statement 对象生成的 ResultSet 对象的结果集合可保存性。
getResultSetType() - 接口 java.sql.Statement 中的方法
获取此 Statement 对象生成的 ResultSet 对象的结果集合类型。
getResultSize() - 类 javax.naming.ldap.PagedResultsResponseControl 中的方法
检索搜索结果中的项数（估计值）。
getResultStream(boolean) - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
getReturningAttributes() - 类 javax.naming.directory.SearchControls 中的方法
检索将作为搜索的一部分返回的属性。
getReturningObjFlag() - 类 javax.naming.directory.SearchControls 中的方法
确定对象是否将作为结果的一部分返回。
getReturnOpenType() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 描述的操作所返回的值的开放类型。
getReturnOpenType() - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 中的方法
返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的开放类型。
getReturnType() - 类 java.lang.reflect.Method 中的方法
返回一个 Class 对象，该对象描述了此 Method 对象所表示的方法的正式返回类型。
getReturnType() - 接口 javax.lang.model.element.ExecutableElement 中的方法
返回此 executable 的返回类型。
getReturnType() - 接口 javax.lang.model.type.ExecutableType 中的方法
返回此 executable 的返回类型。
getReturnType() - 类 javax.management.MBeanOperationInfo 中的方法
返回该方法的返回值的类型。
getReturnType() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的完全限定的 Java 类名。
getReuseAddress() - 类 java.net.DatagramSocket 中的方法
检测是否启用了 SO_REUSEADDR。
getReuseAddress() - 类 java.net.ServerSocket 中的方法
测试是否启用 SO_REUSEADDR。
getReuseAddress() - 类 java.net.Socket 中的方法
测试是否启用 SO_REUSEADDR。
getRevocationDate() - 类 java.security.cert.X509CRLEntry 中的方法
获取此 X509CRLEntry 的撤消日期 revocationDate。
getRevokedCertificate(BigInteger) - 类 java.security.cert.X509CRL 中的方法
获取具有给定证书 serialNumber 的 CRL 项（如果有）。
getRevokedCertificate(X509Certificate) - 类 java.security.cert.X509CRL 中的方法
获取给定证书的 CRL 项（如果有）。
getRevokedCertificates() - 类 java.security.cert.X509CRL 中的方法
获取此 CRL 中的所有项。
getRGB() - 类 java.awt.Color 中的方法
返回默认 sRGB ColorModel 中表示颜色的 RGB 值。
getRGB(int, int) - 类 java.awt.image.BufferedImage 中的方法
返回默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中的整数像素。
getRGB(int, int, int, int, int[], int, int) - 类 java.awt.image.BufferedImage 中的方法
从图像数据的某一部分返回默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中整数像素数组。
getRGB(int) - 类 java.awt.image.ColorModel 中的方法
返回默认的 RGB 颜色模型格式中像素的颜色/alpha 分量。
getRGB(Object) - 类 java.awt.image.ColorModel 中的方法
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
getRGB(int) - 类 java.awt.image.ComponentColorModel 中的方法
返回默认的 RGB 颜色模型格式中像素的颜色/alpha 分量。
getRGB(Object) - 类 java.awt.image.ComponentColorModel 中的方法
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
getRGB(int) - 类 java.awt.image.DirectColorModel 中的方法
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
getRGB(Object) - 类 java.awt.image.DirectColorModel 中的方法
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
getRGB(int) - 类 java.awt.image.IndexColorModel 中的方法
以默认 RGB 颜色模型格式返回像素的颜色/alpha 分量。
getRGB() - 类 java.awt.SystemColor 中的方法
获取表示象征性颜色的“当前”RGB 值。
getRGBColorComponents(float[]) - 类 java.awt.Color 中的方法
根据默认的 sRGB color space，返回一个 float 数组，该数组只包含 Color 的颜色分量。
getRGBComponents(float[]) - 类 java.awt.Color 中的方法
根据默认的 sRGB color space，返回一个 float 数组，该数组包含 Color 的颜色分量和 alpha 分量。
getRGBdefault() - 类 java.awt.image.ColorModel 中的静态方法
返回描述整数 RGB 值的默认格式的 DirectColorModel，该整数 RGB 值可以在便于程序员使用的 AWT 图像接口中的许多方法中使用。
getRGBs(int[]) - 类 java.awt.image.IndexColorModel 中的方法
将颜色和 alpha 分量数组中每个索引的数据转换成默认 RGB ColorModel 格式的 int 值，并将得到的 32 位 ARGB 值复制到指定数组中。
getRightChildIndent() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getRightComponent() - 类 javax.swing.JSplitPane 中的方法
返回分隔条右边（或者下面）的组件。
getRightIndent(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取右边缩进设置。
getRightInset() - 类 javax.swing.text.AsyncBoxView 中的方法
获得视图四周右侧的空白部分。
getRightInset() - 类 javax.swing.text.CompositeView 中的方法
获取右部 inset。
getRMIRepositoryID(Class) - 接口 javax.rmi.CORBA.ValueHandler 中的方法
返回给定 Java 类的 CORBA RepositoryId。
getRole(String) - 接口 javax.management.relation.Relation 中的方法
检索给定角色名称的角色值。
getRole(String, String) - 类 javax.management.relation.RelationService 中的方法
检索给定关系中给定角色名称的角色值。
getRole(String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索给定关系中给定角色名称的角色值。
getRole(String) - 类 javax.management.relation.RelationSupport 中的方法
检索给定角色名称的角色值。
getRole() - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
返回此 SOAPHeaderElement Role 属性的值。
getRoleCardinality(String) - 接口 javax.management.relation.Relation 中的方法
返回当前在给定角色中引用的 MBean 数。
getRoleCardinality(String, String) - 类 javax.management.relation.RelationService 中的方法
检索给定角色中当前引用的 MBean 数。
getRoleCardinality(String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索给定角色中当前引用的 MBean 数。
getRoleCardinality(String) - 类 javax.management.relation.RelationSupport 中的方法
返回当前在给定角色中引用的 MBean 数。
getRoleInfo(String, String) - 类 javax.management.relation.RelationService 中的方法
检索给定关系类型的给定角色名称的角色信息。
getRoleInfo(String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索给定关系类型的给定角色的角色信息。
getRoleInfo(String) - 接口 javax.management.relation.RelationType 中的方法
返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。
getRoleInfo(String) - 类 javax.management.relation.RelationTypeSupport 中的方法
返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。
getRoleInfos(String) - 类 javax.management.relation.RelationService 中的方法
检索给定关系类型的角色信息（RoleInfo 对象）的列表。
getRoleInfos(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索给定关系类型的角色信息（RoleInfo 对象）的列表。
getRoleInfos() - 接口 javax.management.relation.RelationType 中的方法
返回角色定义的列表（RoleInfo 对象的 ArrayList）。
getRoleInfos() - 类 javax.management.relation.RelationTypeSupport 中的方法
返回角色定义的列表（RoleInfo 对象的 ArrayList）。
getRoleName() - 类 javax.management.relation.RelationNotification 中的方法
返回更新关系的更新角色的名称（仅限于角色更新）。
getRoleName() - 类 javax.management.relation.Role 中的方法
检索角色名称。
getRoleName() - 类 javax.management.relation.RoleUnresolved 中的方法
检索角色名称。
getRoles(String[]) - 接口 javax.management.relation.Relation 中的方法
检索具有给定名称的角色值。
getRoles(String, String[]) - 类 javax.management.relation.RelationService 中的方法
检索给定关系中具有给定名称的角色值。
getRoles(String, String[]) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索给定关系中具有给定名称的角色值。
getRoles(String[]) - 类 javax.management.relation.RelationSupport 中的方法
检索具有给定名称的角色值。
getRoles() - 类 javax.management.relation.RoleResult 中的方法
检索成功访问的角色列表。
getRoles() - 接口 javax.xml.ws.handler.soap.SOAPMessageContext 中的方法
获取与执行处理程序链关联的 SOAP 参与者角色。
getRoles() - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
获取 SOAP 绑定实例所扮演的角色。
getRolesUnresolved() - 类 javax.management.relation.RoleResult 中的方法
检索未成功访问的角色列表。
getRoleValue() - 类 javax.management.relation.Role 中的方法
检索角色值。
getRoleValue() - 类 javax.management.relation.RoleUnresolved 中的方法
检索角色值。
getRolloverBorder(AbstractButton) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
返回按钮的翻转边框。
getRolloverColumn() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
返回鼠标当前位于其上的列标题的索引。
getRolloverIcon() - 类 javax.swing.AbstractButton 中的方法
返回按钮的翻转图标。
getRolloverSelectedIcon() - 类 javax.swing.AbstractButton 中的方法
返回按钮的翻转选定图标。
getRolloverTab() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回当前有鼠标位于其上方的选项卡；如果鼠标不再位于任何选项卡上，则返回 -1。
getRoot(Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回当前组件树结构的根组件。
getRoot() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回包含此节点的树的根。
getRoot() - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回树的根。
getRoot() - 接口 javax.swing.tree.TreeModel 中的方法
返回树的根。
getRootCause() - 异常 javax.naming.NamingException 中的方法
检索此 NamingException 的根 cause，如果有的话。
getRootElement() - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
获得根元素。
getRootElements() - 接口 javax.annotation.processing.RoundEnvironment 中的方法
返回以前的 round 生成的注释处理根元素。
getRootElements() - 类 javax.swing.text.AbstractDocument 中的方法
获得已定义的所有根元素。
getRootElements() - 接口 javax.swing.text.Document 中的方法
返回定义的所有根元素。
getRootFrame() - 类 javax.swing.JOptionPane 中的静态方法
返回用于不提供窗体的类方法中的 Frame。
getRootName() - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回格式的根元素的名称。
getRootName() - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getRootPane() - 类 javax.swing.JApplet 中的方法
返回此 applet 的 rootPane 对象。
getRootPane() - 类 javax.swing.JComponent 中的方法
返回此组件的 JRootPane 祖先。
getRootPane() - 类 javax.swing.JDialog 中的方法
返回此对话框的 rootPane 对象。
getRootPane() - 类 javax.swing.JFrame 中的方法
返回此窗体的 rootPane 对象。
getRootPane() - 类 javax.swing.JInternalFrame 中的方法
返回此内部窗体的 rootPane 对象。
getRootPane() - 类 javax.swing.JWindow 中的方法
返回此窗口的 rootPane 对象。
getRootPane() - 接口 javax.swing.RootPaneContainer 中的方法
返回此组件的单个 JRootPane 子组件。
getRootPane(Component) - 类 javax.swing.SwingUtilities 中的静态方法
如果 c 是一个 JRootPane 后代，则返回其 JRootPane 祖先。
getRoots() - 类 javax.swing.filechooser.FileSystemView 中的方法
返回此系统的所有根分区。
getRootView(JTextComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取分配了相关文本组件（即层次结构的根）的 View，可通过遍历该视图确定模型在空间中的表示形式。
getRootView(JTextComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getRootView 方法。
getRootView(JTextComponent) - 类 javax.swing.plaf.TextUI 中的方法
获取分配了相关文本组件（即层次结构的根）的 View，可遍历这些组件来确定在空间中表示模型的形式。
getRotateInstance(double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回表示旋转变换的变换。
getRotateInstance(double, double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回绕锚点旋转坐标的变换。
getRotateInstance(double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回根据旋转向量旋转坐标的变换。
getRotateInstance(double, double, double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回根据旋转向量绕锚点坐标旋转坐标的变换。
getRoundedCorners() - 类 javax.swing.border.LineBorder 中的方法
返回是否将此边框绘制为圆弧拐角边框。
getRoundingMode() - 类 java.math.MathContext 中的方法
返回 roundingMode 设置。
getRoundingMode() - 类 java.text.DecimalFormat 中的方法
获取在此 DecimalFormat 中使用的 RoundingMode。
getRoundingMode() - 类 java.text.NumberFormat 中的方法
获取在此 NumberFormat 中使用的 RoundingMode。
getRounds() - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
返回 rounds 的数量。
getRow() - 接口 java.sql.ResultSet 中的方法
获取当前行编号。
getRow() - 类 javax.swing.JTable.DropLocation 中的方法
返回表中应该用来放入放置项的行索引。
getRowBounds(int) - 类 javax.swing.JTree 中的方法
返回将指定行处的节点绘入的 Rectangle。
getRowCount() - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
返回模型中的行数。
getRowCount() - 类 javax.swing.JTable 中的方法
返回 JTable 中可以显示的行数（给定无限空间）。
getRowCount() - 类 javax.swing.JTree 中的方法
返回当前正在显示的行数。
getRowCount(JTree) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回将显示的行数。
getRowCount(JTree) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getRowCount 方法。
getRowCount(JTree) - 类 javax.swing.plaf.TreeUI 中的方法
返回将显示的行数。
getRowCount() - 类 javax.swing.table.DefaultTableModel 中的方法
返回此数据表中的行数。
getRowCount() - 接口 javax.swing.table.TableModel 中的方法
返回该模型中的行数。
getRowCount() - 类 javax.swing.text.TableView.TableCell 中的方法
已过时。 获取此单元格所跨的行数（即网格高度）。
getRowCount() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
显示的行数。
getRowCount() - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回可视的行数。
getRowCount() - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回可见的行数。
getRowEnd(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定包含指定模型位置的行的结束行模型位置。
getRowFilter() - 类 javax.swing.DefaultRowSorter 中的方法
返回用于确定哪些行（如果有）应该在视图中隐藏的过滤器。
getRowForLocation(int, int) - 类 javax.swing.JTree 中的方法
返回指定位置的行。
getRowForPath(TreePath) - 类 javax.swing.JTree 中的方法
返回显示由指定路径标识的节点的行。
getRowForPath(JTree, TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回可在其中看见路径中标识的最后一个项的行。
getRowForPath(JTree, TreePath) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getRowForPath 方法。
getRowForPath(JTree, TreePath) - 类 javax.swing.plaf.TreeUI 中的方法
返回可在其中看见路径中标识的最后一个项的行。
getRowForPath(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回其路径中标识的最后一项可视的行。
getRowForPath(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回路径中标识的最后一项可见的行。
getRowForPath(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回路径中标识的最后一项在其中可见的行。
getRowHeader() - 类 javax.swing.JScrollPane 中的方法
返回行标题。
getRowHeader() - 类 javax.swing.ScrollPaneLayout 中的方法
返回行标题对应的 JViewport 对象。
getRowHeight() - 类 javax.swing.JTable 中的方法
返回表的行高，以像素为单位。
getRowHeight(int) - 类 javax.swing.JTable 中的方法
返回 row 中单元格的高度，以像素为单位。
getRowHeight() - 类 javax.swing.JTextArea 中的方法
定义行高的意义。
getRowHeight() - 类 javax.swing.JTree 中的方法
返回每个行的高度。
getRowHeight(int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回基于当前布局的指定行的高度。
getRowHeight() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getRowHeight() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回每行高度。
getRowId(int) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
getRowId(String) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
getRowId(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getRowId(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getRowIdLifetime() - 接口 java.sql.DatabaseMetaData 中的方法
指示此数据源是否支持 SQL ROWID 类型，如果支持，则 RowId 对象在该类型的生存期内持续有效。
getRowMapper() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回能够将 TreePath 映射到行的 RowMapper 实例。
getRowMapper() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回能够将 TreePath 映射到行的 RowMapper 实例。
getRowMargin() - 类 javax.swing.JTable 中的方法
获取单元格之间的间距，以像素为单位。
getRows() - 类 java.awt.GridLayout 中的方法
获取此布局中的行数。
getRows() - 类 java.awt.List 中的方法
获取此列表中的可视行数。
getRows() - 类 java.awt.TextArea 中的方法
返回此文本区的行数。
getRows() - 类 javax.swing.JTextArea 中的方法
返回 TextArea 中的行数。
getRowSelectionAllowed() - 类 javax.swing.JTable 中的方法
如果可以选择行，则返回 true。
getRowSetNames() - 接口 javax.sql.rowset.JoinRowSet 中的方法
返回一个 String 数组，包含添加到此 JoinRowSet 对象的 RowSet 对象的名称。
getRowSetReader() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回 javax.sql.RowSetReader 对象，它可以用于填充带有数据的 RowSet 对象。
getRowSets() - 接口 javax.sql.rowset.JoinRowSet 中的方法
返回一个 Collection 对象，包含已经添加到此 JoinRowSet 对象的 RowSet 对象。
getRowSetWarnings() - 接口 javax.sql.rowset.CachedRowSet 中的方法
获取此 RowSet 对象上的调用报告的第一个警告。
getRowSetWarnings() - 接口 javax.sql.rowset.JdbcRowSet 中的方法
获取此 JdbcRowSet 对象上的调用报告的第一个警告。
getRowSetWriter() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回 javax.sql.RowSetWriter 对象，它可以用于将 RowSet 对象的数据写回底层数据源。
getRowsForPaths(TreePath[]) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回在其中显示 path 中 TreePath 实例的行。
getRowsForPaths(TreePath[]) - 接口 javax.swing.tree.RowMapper 中的方法
返回显示 path 中的 TreePath 实例的行。
getRowSorter() - 类 javax.swing.JTable 中的方法
返回负责排序的对象。
getRowStart(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定包含指定模型位置的行的起始行模型位置。
getRowType() - 类 javax.management.openmbean.TabularType 中的方法
返回此 TabularType 实例描述的表格数据值的行元素的类型。
getRowX(int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回沿 x 轴呈现特定行的位置。
getRowX(int, int) - 类 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler 中的方法

getRSB() - 类 java.awt.font.GlyphMetrics 中的方法
返回该字形的右（底）跨距。
getRule() - 类 java.awt.AlphaComposite 中的方法
返回此 AlphaComposite 的合成规则。
getRule(HTML.Tag, Element) - 类 javax.swing.text.html.StyleSheet 中的方法
获取用来呈现给定类型的 HTML 标记的样式。
getRule(String) - 类 javax.swing.text.html.StyleSheet 中的方法
获取最能匹配以字符串形式表示的选择器的规则。
getRules() - 类 java.text.RuleBasedCollator 中的方法
获取 collation 对象的基于表的规则。
getRunCount() - 类 java.text.Bidi 中的方法
返回层次运行的数目。
getRunForTab(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getRunLevel(int) - 类 java.text.Bidi 中的方法
返回该行中第 n 次逻辑运行的层次。
getRunLimit() - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的所有属性的运行之后的第一个字符的索引。
getRunLimit(AttributedCharacterIterator.Attribute) - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的给定属性的运行之后的第一个字符的索引。
getRunLimit(Set<? extends AttributedCharacterIterator.Attribute>) - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的给定多个属性的运行之后的第一个字符的索引。
getRunLimit(int) - 类 java.text.Bidi 中的方法
以该行开始的偏移量返回该行中第 n 次逻辑运行之后的字符索引。
getRunStart() - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的所有属性的运行的第一个字符的索引。
getRunStart(AttributedCharacterIterator.Attribute) - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的给定属性的运行的第一个字符的索引。
getRunStart(Set<? extends AttributedCharacterIterator.Attribute>) - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的给定多个属性的运行的第一个字符的索引。
getRunStart(int) - 类 java.text.Bidi 中的方法
以该行开始的偏移量返回该行中第 n 次逻辑运行开始时的字符索引。
getRuntime() - 类 java.lang.Runtime 中的静态方法
返回与当前 Java 应用程序相关的运行时对象。
getRunTimeCodeBase() - 接口 javax.rmi.CORBA.ValueHandler 中的方法
返回此 ValueHandler 的 CodeBase。
getRuntimeMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机的运行时系统的管理 Bean。
getS() - 接口 java.security.interfaces.ECPrivateKey 中的方法
返回专用密钥值 S。
getS() - 类 java.security.spec.ECPrivateKeySpec 中的方法
返回专用值 S。
getSalt() - 接口 javax.crypto.interfaces.PBEKey 中的方法
返回 salt；如果未指定，则返回 null。
getSalt() - 类 javax.crypto.spec.PBEKeySpec 中的方法
返回 salt 的一份副本，如果未指定则返回 null。
getSalt() - 类 javax.crypto.spec.PBEParameterSpec 中的方法
返回 salt。
getSaltLength() - 类 java.security.spec.PSSParameterSpec 中的方法
返回 salt 长度（以比特为单位）。
getSample(int, int, int, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSample(int, int, int, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSample(int, int, int, DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
以 int 形式返回指定 band 中对应于 (x, y) 处像素的样本。
getSample(int, int, int) - 类 java.awt.image.Raster 中的方法
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSample(int, int, int, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSample(int, int, int, DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleDouble(int, int, int, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleDouble(int, int, int, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleDouble(int, int, int) - 类 java.awt.image.Raster 中的方法
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleDouble(int, int, int, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleFloat(int, int, int, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleFloat(int, int, int, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleFloat(int, int, int) - 类 java.awt.image.Raster 中的方法
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleFloat(int, int, int, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleModel() - 类 java.awt.image.BufferedImage 中的方法
返回与此 BufferedImage 关联的 SampleModel。
getSampleModel() - 类 java.awt.image.Raster 中的方法
返回描述图像数据布局的 SampleModel。
getSampleModel() - 接口 java.awt.image.RenderedImage 中的方法
返回与此图像相关的 SampleModel。
getSampleModel() - 类 javax.imageio.ImageTypeSpecifier 中的方法
根据此对象中封装的设置返回一个 SampleModel。
getSampleModel(int, int) - 类 javax.imageio.ImageTypeSpecifier 中的方法
根据此对象中封装的设置值返回一个 SampleModel。
getSampleModelTranslateX() - 类 java.awt.image.Raster 中的方法
返回从 SampleModel 坐标系到 Raster 坐标系的 X 平移。
getSampleModelTranslateY() - 类 java.awt.image.Raster 中的方法
返回从 SampleModel 坐标系到 Raster 坐标系的 Y 平移。
getSampleRate() - 类 javax.sound.sampled.AudioFormat 中的方法
获取样本速率。
getSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
在 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数据数组元素对应一个样本。
getSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
返回指定 band 中对应于 int 数组中指定像素矩形的样本，每个数据数组元素一个样本。
getSamples(int, int, int, int, int, int[]) - 类 java.awt.image.Raster 中的方法
以 int 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, float[]) - 类 java.awt.image.Raster 中的方法
以 float 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, double[]) - 类 java.awt.image.Raster 中的方法
以 double 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 float 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 double 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSampleSize() - 类 java.awt.image.ComponentSampleModel 中的方法
返回所有 band 每个样本的位数。
getSampleSize(int) - 类 java.awt.image.ComponentSampleModel 中的方法
返回指定 band 每个样本的位数。
getSampleSize() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回所有 band 的每样本位数。
getSampleSize(int) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回指定 band 的每样本位数。
getSampleSize() - 类 java.awt.image.SampleModel 中的方法
返回所有 band 样本的大小（以位为单位）。
getSampleSize(int) - 类 java.awt.image.SampleModel 中的方法
返回指定 band 样本的大小（以位为单位）。
getSampleSize() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回所有 band 的每样本位数。
getSampleSize(int) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回指定 band 的每样本位数。
getSampleSizeInBits() - 类 javax.sound.sampled.AudioFormat 中的方法
获取样本的大小。
getSaslClientFactories() - 类 javax.security.sasl.Sasl 中的静态方法
获得用于生成 SaslClient 的已知工厂的枚举。
getSaslServerFactories() - 类 javax.security.sasl.Sasl 中的静态方法
获得用于生成 SaslServer 的已知工厂的枚举。
getSavepointId() - 接口 java.sql.Savepoint 中的方法
获取此 Savepoint 对象表示的保存点的生成 ID。
getSavepointName() - 接口 java.sql.Savepoint 中的方法
获取此 Savepoint 对象表示的保存点的名称。
getScale(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的小数点右边的位数。
getScale(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的小数点右边的位数。
getScale(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取存储在指定列中的值的小数点右边的数字数。
getScaledInstance(int, int, int) - 类 java.awt.Image 中的方法
创建此图像的缩放版本。
getScaledInstance(float, boolean) - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的方法
返回新的量化表，其中所有值都乘以 scaleFactor，然后取 1 到 32767（如果 forceBaseline 为 true，则使用 1 到 255）范围中的值。
getScaleFactors(float[]) - 类 java.awt.image.RescaleOp 中的方法
返回给定数组中的缩放因子。
getScaleInstance(double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回表示缩放变换的变换。
getScaleX() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵缩放元素 (m00) 的 X 坐标。
getScaleY() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵缩放元素 (m11) 的 Y 坐标。
getScanlineStride() - 类 java.awt.image.ComponentSampleModel 中的方法
返回此 ComponentSampleModel 的扫描行间距。
getScanlineStride() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回扫描行的间距。
getScanlineStride() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回此 SinglePixelPackedSampleModel 的扫描行间距。
getSchema(Name) - 接口 javax.naming.directory.DirContext 中的方法
检索与命名对象关联的模式。
getSchema(String) - 接口 javax.naming.directory.DirContext 中的方法
检索与命名对象关联的模式。
getSchema(String) - 类 javax.naming.directory.InitialDirContext 中的方法

getSchema(Name) - 类 javax.naming.directory.InitialDirContext 中的方法

getSchema() - 类 javax.xml.bind.Binder 中的方法
获取 Binder.setSchema(Schema) 方法设置的最后一个 Schema 对象（包括 null）。
getSchema() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法

getSchema() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法

getSchema() - 接口 javax.xml.bind.Marshaller 中的方法
获取用于执行编组时验证的 JAXP 1.3 Schema 对象。
getSchema() - 接口 javax.xml.bind.Unmarshaller 中的方法
获取用于执行解组时验证的 JAXP 1.3 Schema 对象。
getSchema() - 类 javax.xml.parsers.DocumentBuilder 中的方法
获取由 XML 处理器使用的 Schema 的引用。
getSchema() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
获取通过 DocumentBuilderFactory.setSchema(Schema schema) 方法指定的 Schema 对象。
getSchema() - 类 javax.xml.parsers.SAXParser 中的方法
获取对 XML 处理器使用的 Schema 的引用。
getSchema() - 类 javax.xml.parsers.SAXParserFactory 中的方法
获取通过 SAXParserFactory.setSchema(Schema schema) 方法指定的 Schema 对象。
getSchemaClassDefinition(Name) - 接口 javax.naming.directory.DirContext 中的方法
检索包含命名对象类定义的模式对象的上下文。
getSchemaClassDefinition(String) - 接口 javax.naming.directory.DirContext 中的方法
检索包含命名对象类定义的模式对象的上下文。
getSchemaClassDefinition(String) - 类 javax.naming.directory.InitialDirContext 中的方法

getSchemaClassDefinition(Name) - 类 javax.naming.directory.InitialDirContext 中的方法

getSchemaLocation() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
获取当前 schemaLocation 的便捷方法。
getSchemaName(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的表模式。
getSchemaName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取派生指定列中值的表的模式名称。
getSchemas() - 接口 java.sql.DatabaseMetaData 中的方法
获取可在此数据库中使用的模式名称。
getSchemas(String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库中可用的模式名称。
getSchemaTerm() - 接口 java.sql.DatabaseMetaData 中的方法
获取数据库供应商用于 "schema" 的首选术语。
getSchemaType() - 接口 javax.xml.stream.events.XMLEvent 中的方法
提供此方法是为了提供有关关联事件的可选类型信息。
getSchemaTypeInfo() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getSchemaTypeInfo() - 接口 org.w3c.dom.Attr 中的方法
与此属性相关联的类型信息。
getSchemaTypeInfo() - 接口 org.w3c.dom.Element 中的方法
与此元素相关的类型信息。
getScheme() - 类 java.net.URI 中的方法
返回此 URI 的方案组成部分。
getSchemeSpecificPart() - 类 java.net.URI 中的方法
返回此 URI 的特定于方案的解码部分。
getScope() - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 的作用域。
getScope() - 类 javax.xml.bind.JAXBElement 中的方法
返回 xml 元素声明的作用域。
getScope(String) - 接口 javax.xml.ws.handler.MessageContext 中的方法
获得属性的作用域。
getScopedInterface() - 类 java.net.Inet6Address 中的方法
如果此实例是使用范围接口创建的，则返回范围接口。
getScopeId() - 类 java.net.Inet6Address 中的方法
如果此实例与接口关联，则返回数字 scoped_id。
getScopes() - 接口 javax.script.ScriptContext 中的方法
返回 ScriptContext 中所有有效范围值的不可变 List。
getScopes() - 类 javax.script.SimpleScriptContext 中的方法
返回 ScriptContext 中所有有效范围值的不可变 List。
getScreenDevices() - 类 java.awt.GraphicsEnvironment 中的方法
返回所有屏幕 GraphicsDevice 对象组成的数组。
getScreenInsets(GraphicsConfiguration) - 类 java.awt.Toolkit 中的方法
获得屏幕的 insets。
getScreenResolution() - 类 java.awt.Toolkit 中的方法
返回屏幕分辨率，以每英寸的点数为单位。
getScreenSize() - 类 java.awt.Toolkit 中的方法
获取屏幕的大小。
getScreenX() - 接口 org.w3c.dom.events.MouseEvent 中的方法
相对于屏幕坐标系统原点的水平坐标(事件发生在此处)。
getScreenY() - 接口 org.w3c.dom.events.MouseEvent 中的方法
相对于屏幕坐标系统原点的垂直坐标(事件发生在此处)。
getScriptContext(Bindings) - 类 javax.script.AbstractScriptEngine 中的方法
返回一个 SimpleScriptContext。
getScriptEngine() - 接口 javax.script.ScriptEngineFactory 中的方法
返回与此 ScriptEngineFactory 关联的 ScriptEngine 的实例。
getScrollableBlockIncrement(Rectangle, int, int) - 类 javax.swing.JList 中的方法
返回为显露上一个或下一个块而滚动的距离。
getScrollableBlockIncrement(Rectangle, int, int) - 类 javax.swing.JTable 中的方法
返回 visibleRect.height 或 visibleRect.width，这取决于此表的方向。
getScrollableBlockIncrement(Rectangle, int, int) - 类 javax.swing.JTree 中的方法
返回块增量的数量，它是基于 orientation 的 visibleRect 高度或宽度。
getScrollableBlockIncrement(Rectangle, int, int) - 接口 javax.swing.Scrollable 中的方法
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。
getScrollableBlockIncrement(Rectangle, int, int) - 类 javax.swing.text.JTextComponent 中的方法
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。
getScrollableTracksViewportHeight() - 类 javax.swing.JEditorPane 中的方法
如果某个视口始终应该强迫此 Scrollable 的高度符合该视口的高度，则返回 true。
getScrollableTracksViewportHeight() - 类 javax.swing.JList 中的方法
如果此 JList 在 JViewport 中显示并且视口的高度大于列表的首选高度，或者布局方向为 VERTICAL_WRAP 或 visibleRowCount <= 0，则返回 true；否则返回 false。
getScrollableTracksViewportHeight() - 类 javax.swing.JTable 中的方法
返回 false 指示表的高度不是由视口的高度决定的，除非 getFillsViewportHeight 为 true 并且该表的首选高度小于视口的高度。
getScrollableTracksViewportHeight() - 类 javax.swing.JTree 中的方法
返回 false 指示视口的高度不能确定表的高度，除非树的首选高度小于视口高度。
getScrollableTracksViewportHeight() - 接口 javax.swing.Scrollable 中的方法
如果视口总是强制此 Scrollable 的高度与视口高度匹配，则返回 true。
getScrollableTracksViewportHeight() - 类 javax.swing.text.JTextComponent 中的方法
如果视口总是强制此 Scrollable 的高度与视口高度匹配，则返回 true。
getScrollableTracksViewportWidth() - 类 javax.swing.JEditorPane 中的方法
如果某个视口始终应该强迫此 Scrollable 的宽度符合该视口的宽度，则返回 true。
getScrollableTracksViewportWidth() - 类 javax.swing.JList 中的方法
如果此 JList 在 JViewport 中显示并且视口的宽度大于列表的首选宽度，或者布局方向为 HORIZONTAL_WRAP 和 visibleRowCount <= 0，则返回 true；否则返回 false。
getScrollableTracksViewportWidth() - 类 javax.swing.JTable 中的方法
如果 autoResizeMode 设置为 AUTO_RESIZE_OFF，则返回 false，这指示表的宽度不是由视口的宽度决定的。
getScrollableTracksViewportWidth() - 类 javax.swing.JTextArea 中的方法
如果 viewport 总是强制要求此 Scrollable 的宽度与 viewport 的宽度相匹配，则返回 true。
getScrollableTracksViewportWidth() - 类 javax.swing.JTree 中的方法
返回 false 指示视口的宽度不能确定表的宽度，除非树的首选宽度小于视口宽度。
getScrollableTracksViewportWidth() - 接口 javax.swing.Scrollable 中的方法
如果视口总是强制此 Scrollable 的宽度与视口宽度匹配，则返回 true。
getScrollableTracksViewportWidth() - 类 javax.swing.text.JTextComponent 中的方法
如果视口总是强制此 Scrollable 的宽度与视口宽度匹配，则返回 true。
getScrollableUnitIncrement(Rectangle, int, int) - 类 javax.swing.JList 中的方法
返回为显露上一个或下一个行（垂直滚动）或列（水平滚动）而滚动的距离。
getScrollableUnitIncrement(Rectangle, int, int) - 类 javax.swing.JTable 中的方法
返回完全呈现出一个新行或新列（取决于方向）的滚动增量（以像素为单位）。
getScrollableUnitIncrement(Rectangle, int, int) - 类 javax.swing.JTextArea 中的方法
显示逻辑行或列的组件应根据方向的值计算滚动增量，此滚动增量将完全显示一个新行或新列。
getScrollableUnitIncrement(Rectangle, int, int) - 类 javax.swing.JTree 中的方法
返回滚动时增加的数量。
getScrollableUnitIncrement(Rectangle, int, int) - 接口 javax.swing.Scrollable 中的方法
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。
getScrollableUnitIncrement(Rectangle, int, int) - 类 javax.swing.text.JTextComponent 中的方法
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。
getScrollAmount() - 类 java.awt.event.MouseWheelEvent 中的方法
返回每转动一下鼠标滚轮应该滚动的单位数。
getScrollbarDisplayPolicy() - 类 java.awt.ScrollPane 中的方法
返回滚动条的显示策略。
getScrollbarVisibility() - 类 java.awt.TextArea 中的方法
返回指示文本区使用何种滚动条的枚举值。
getScrollMode() - 类 javax.swing.JViewport 中的方法
返回当前的滚动模式。
getScrollOffset() - 类 javax.swing.JTextField 中的方法
获取滚动偏移量（以像素为单位）。
getScrollPane() - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的方法
返回容纳 JTree 的 JScrollPane；如果一个也没有找到，则返回 null。
getScrollPosition() - 类 java.awt.ScrollPane 中的方法
返回子组件中的当前 x,y 位置，子组件显示在滚动窗格视口的 0,0 位置。
getScrollsOnExpand() - 类 javax.swing.JTree 中的方法
返回 scrollsOnExpand 属性的值。
getScrollType() - 类 java.awt.event.MouseWheelEvent 中的方法
返回响应此事件时应该发生的滚动类型。
getSearchScope() - 类 javax.naming.directory.SearchControls 中的方法
检索这些 SearchControls 的搜索范围。
getSearchStringEscape() - 接口 java.sql.DatabaseMetaData 中的方法
获取可用于转义通配符的字符串。
getSecond() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回秒或 DatatypeConstants.FIELD_UNDEFINED。
getSecondary1() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 secondary 1 颜色。
getSecondary1() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 secondary 1 颜色。
getSecondary1() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 secondary 1 颜色。
getSecondary2() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 secondary 2 颜色。
getSecondary2() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 secondary 2 颜色。
getSecondary2() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 secondary 2 颜色。
getSecondary3() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 secondary 3 颜色。
getSecondary3() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 secondary 3 颜色。
getSecondary3() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 secondary 3 颜色。
getSeconds() - 类 java.sql.Date 中的方法
已过时。
getSeconds() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.SECOND) 取代。
getSeconds() - 类 javax.xml.datatype.Duration 中的方法
获取整数值形式的 SECONDS 字段的值，如果不存在，则值为 0。
getSecretKey() - 类 java.security.KeyStore.SecretKeyEntry 中的方法
从此项中获取 SecretKey。
getSecure() - 类 java.net.HttpCookie 中的方法
如果浏览器仅通过安全协议发送 cookie，则返回 true；如果浏览器可以使用任何协议发送 cookie，则返回 false。
getSecurityContext() - 类 java.lang.SecurityManager 中的方法
创建一个封装当前执行环境的对象。
getSecurityContext(ClassLoader) - 接口 java.rmi.server.LoaderHandler 中的方法
已过时。 无替代版本
getSecurityContext(ClassLoader) - 类 java.rmi.server.RMIClassLoader 中的静态方法
已过时。 无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。
getSecurityManager() - 类 java.lang.System 中的静态方法
获取系统安全接口。
getSeed(int) - 类 java.security.SecureRandom 中的静态方法
返回给定的种子字节数量，该数量可使用此类用来将自身设置为种子的种子生成算法来计算。
getSeed() - 类 java.security.spec.EllipticCurve 中的方法
返回曲线生成期间所使用的种子字节 seed。
getSelectColor() - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法

getSelectColor() - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法

getSelectColor() - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法

getSelectedAccessibleColumns() - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中选中的列。
getSelectedAccessibleColumns() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中选择的列。
getSelectedAccessibleRows() - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中选中的行。
getSelectedAccessibleRows() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中选择的行。
getSelectedCheckbox() - 类 java.awt.CheckboxGroup 中的方法
从此复选框组中获取当前选择。
getSelectedColor() - 接口 javax.swing.colorchooser.ColorSelectionModel 中的方法
返回所选取的 Color，它不应为 null。
getSelectedColor() - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
返回所选取的 Color，它不应为 null。
getSelectedColumn() - 类 javax.swing.JTable 中的方法
返回第一个选定列的索引；如果没有选定的列，则返回 -1。
getSelectedColumnCount() - 类 javax.swing.JTable 中的方法
返回选定列数。
getSelectedColumnCount() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回选定的列数。
getSelectedColumnCount() - 接口 javax.swing.table.TableColumnModel 中的方法
返回选定的列数。
getSelectedColumns() - 类 javax.swing.JTable 中的方法
返回所有选定列的索引。
getSelectedColumns() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回包含选定列的数组。
getSelectedColumns() - 接口 javax.swing.table.TableColumnModel 中的方法
返回所有选定列的索引数组。
getSelectedComponent() - 类 javax.swing.JTabbedPane 中的方法
返回此选项卡窗格当前选择的组件。
getSelectedFile() - 类 javax.swing.JFileChooser 中的方法
返回选中的文件。
getSelectedFiles() - 类 javax.swing.JFileChooser 中的方法
如果将文件选择器设置为允许选择多个文件，则返回选中文件的列表。
getSelectedFrame() - 类 javax.swing.JDesktopPane 中的方法
返回此 JDesktopPane 中当前活动的 JInternalFrame，如果当前没有活动的 JInternalFrame，则返回 null。
getSelectedIcon() - 类 javax.swing.AbstractButton 中的方法
返回按钮的选择图标。
getSelectedIndex() - 类 java.awt.Choice 中的方法
返回当前选定项的索引。
getSelectedIndex() - 类 java.awt.List 中的方法
获取列表中选中项的索引。
getSelectedIndex() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取选中的确认选项。
getSelectedIndex() - 类 javax.swing.DefaultSingleSelectionModel 中的方法

getSelectedIndex() - 类 javax.swing.JComboBox 中的方法
返回列表中与给定项匹配的第一个选项。
getSelectedIndex() - 类 javax.swing.JList 中的方法
返回最小的选择单元索引；只选择了列表中单个项时，返回该选择。
getSelectedIndex() - 类 javax.swing.JTabbedPane 中的方法
返回当前选择的此选项卡窗格的索引。
getSelectedIndex() - 接口 javax.swing.SingleSelectionModel 中的方法
返回模型的选项。
getSelectedIndexes() - 类 java.awt.List 中的方法
获取列表中选中的索引。
getSelectedIndexes() - 类 javax.security.auth.callback.ChoiceCallback 中的方法
获取选中的选项。
getSelectedIndices() - 类 javax.swing.JList 中的方法
返回所选的全部索引的数组（按升序排列）。
getSelectedItem() - 类 java.awt.Choice 中的方法
获取当前选择的字符串表示形式。
getSelectedItem() - 类 java.awt.List 中的方法
获取此滚动列表中选中的项。
getSelectedItem() - 接口 javax.swing.ComboBoxModel 中的方法
返回选择的项
getSelectedItem() - 类 javax.swing.DefaultComboBoxModel 中的方法

getSelectedItem() - 类 javax.swing.JComboBox 中的方法
返回当前所选项。
getSelectedItem() - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 中的方法

getSelectedItem() - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的方法

getSelectedItems() - 类 java.awt.List 中的方法
获取此滚动列表中选中的项。
getSelectedObjects() - 类 java.awt.Checkbox 中的方法
返回包含复选框标签的数组 (length 1)，如果没有选定复选框，则返回 null。
getSelectedObjects() - 类 java.awt.CheckboxMenuItem 中的方法
返回一个数组（长度为 1)，它包含复选框菜单项的标签，如果没有选中复选框，则返回 null。
getSelectedObjects() - 类 java.awt.Choice 中的方法
返回包含当前选定项的数组（长度为 1）。
getSelectedObjects() - 接口 java.awt.ItemSelectable 中的方法
返回选定项；如果没有选定的项，则返回 null。
getSelectedObjects() - 类 java.awt.List 中的方法
获取对象数组中此滚动列表的选中项。
getSelectedObjects() - 类 javax.swing.AbstractButton 中的方法
返回包含标签的数组（长度为 1），如果没有选择按钮，则返回 null。
getSelectedObjects() - 类 javax.swing.DefaultButtonModel 中的方法
重写以返回 null。
getSelectedObjects() - 类 javax.swing.JCheckBoxMenuItem 中的方法
返回包含复选框菜单项标签的数组 (length 1)，如果没有选定复选框，则返回 null。
getSelectedObjects() - 类 javax.swing.JComboBox 中的方法
返回包含所选项的数组。
getSelectedPath() - 类 javax.swing.MenuSelectionManager 中的方法
返回当前选择菜单项的路径
getSelectedRow() - 类 javax.swing.JTable 中的方法
返回第一个选定行的索引；如果没有选定的行，则返回 -1。
getSelectedRowCount() - 类 javax.swing.JTable 中的方法
返回选定行数。
getSelectedRows() - 类 javax.swing.JTable 中的方法
返回所有选定行的索引。
getSelectedTabPadInsets(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getSelectedText(AttributedCharacterIterator.Attribute[]) - 接口 java.awt.im.InputMethodRequests 中的方法
从文本编辑组件中获取当前已选定文本。
getSelectedText() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回选定文本的一部分。
getSelectedText() - 类 java.awt.TextComponent 中的方法
返回此文本组件所表示文本的选定文本。
getSelectedText() - 接口 javax.accessibility.AccessibleText 中的方法
返回选定的部分文本。
getSelectedText() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回选定文本的一部分。
getSelectedText() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回选定的部分文本。
getSelectedText() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回选中的部分文本。
getSelectedText() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回选择的一部分文本。
getSelectedText() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回选定文本的某一部分。
getSelectedText() - 类 javax.swing.text.JTextComponent 中的方法
返回此 TextComponent 中包含的选定文本。
getSelectedTextColor() - 类 javax.swing.text.JTextComponent 中的方法
获取用于呈现选定文本的当前颜色。
getSelectedValue() - 类 javax.swing.JList 中的方法
返回最小的选择单元索引的值；只选择了列表中单个项时，返回所选值。
getSelectedValues() - 类 javax.swing.JList 中的方法
返回所有选择值的数组，根据其列表中的索引顺序按升序排序。
getSelection() - 类 javax.swing.ButtonGroup 中的方法
返回选择按钮的模型。
getSelectionBackground() - 类 javax.swing.JList 中的方法
返回用于绘制选定项的背景的颜色。
getSelectionBackground() - 类 javax.swing.JTable 中的方法
返回选定单元格的背景色。
getSelectionBackground() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
如果在进度条的未填充区域上绘制文本，则文本的颜色为 "selectionBackground"。
getSelectionColor() - 类 javax.swing.text.JTextComponent 中的方法
获取用于呈现选定的当前颜色。
getSelectionCount() - 类 javax.swing.JTree 中的方法
返回选择的节点数。
getSelectionCount() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回选择的路径数。
getSelectionCount() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回选择的路径数。
getSelectionEnd() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回选定文本中的终止偏移量。
getSelectionEnd() - 类 java.awt.TextComponent 中的方法
获取此文本组件中选定文本的结束位置。
getSelectionEnd() - 接口 javax.accessibility.AccessibleText 中的方法
返回选定文本中的结束偏移量。
getSelectionEnd() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回选定文本中的结束偏移量。
getSelectionEnd() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回选定文本中的结尾偏移量。
getSelectionEnd() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回选定文本中的结尾偏移量。
getSelectionEnd() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回选择文本中的结束偏移量。
getSelectionEnd() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回选定文本中的结束偏移量。
getSelectionEnd() - 类 javax.swing.text.JTextComponent 中的方法
返回选定文本的结束位置。
getSelectionForeground() - 类 javax.swing.JList 中的方法
返回用于绘制选定项的前景的颜色。
getSelectionForeground() - 类 javax.swing.JTable 中的方法
返回选定单元格的前景色。
getSelectionForeground() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
如果在进度条的填充区域上绘制文本，文本的颜色为 "selectionForeground"。
getSelectionMode() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回当前选择模式。
getSelectionMode() - 类 javax.swing.JList 中的方法
返回列表的当前选择模式。
getSelectionMode() - 接口 javax.swing.ListSelectionModel 中的方法
返回当前选择模式。
getSelectionMode() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回选择模式，它是 SINGLE_TREE_SELECTION、DISCONTIGUOUS_TREE_SELECTION 或 CONTIGUOUS_TREE_SELECTION 之一。
getSelectionMode() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回当前选择的模式（SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一）。
getSelectionModel() - 类 javax.swing.JColorChooser 中的方法
返回处理颜色选择的数据模型。
getSelectionModel() - 类 javax.swing.JList 中的方法
返回当前选择模型。
getSelectionModel() - 类 javax.swing.JMenuBar 中的方法
返回处理单个选择的模型对象。
getSelectionModel() - 类 javax.swing.JPopupMenu 中的方法
返回处理单个选择的模型对象。
getSelectionModel() - 类 javax.swing.JTable 中的方法
返回用来维持行选择状态的 ListSelectionModel。
getSelectionModel() - 类 javax.swing.JTree 中的方法
返回选择的模型。
getSelectionModel() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getSelectionModel() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回用来维护列选择状态的 ListSelectionModel。
getSelectionModel() - 接口 javax.swing.table.TableColumnModel 中的方法
返回当前的选择模型。
getSelectionModel() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回用于维护该选择的模型。
getSelectionPainter() - 类 javax.swing.text.DefaultCaret 中的方法
获取此 Highlighter 的 painter。
getSelectionPath() - 类 javax.swing.JTree 中的方法
返回首选节点的路径。
getSelectionPath() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回 selection 中的第一个路径。
getSelectionPath() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回选择中的第一个路径。
getSelectionPaths() - 类 javax.swing.JTree 中的方法
返回所有选择值的路径。
getSelectionPaths() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回 selection 中的路径。
getSelectionPaths() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回选择中的路径。
getSelectionRows() - 类 javax.swing.JTree 中的方法
返回所有当前选择的行。
getSelectionRows() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回当前已选的所有行。
getSelectionRows() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回所有当前已选的行。
getSelectionStart() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回选定文本中的起始偏移量。
getSelectionStart() - 类 java.awt.TextComponent 中的方法
获取此文本组件中选定文本的开始位置。
getSelectionStart() - 接口 javax.accessibility.AccessibleText 中的方法
返回选定文本中的起始偏移量。
getSelectionStart() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回选定文本中的起始偏移量。
getSelectionStart() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回选定文本中的开始偏移量。
getSelectionStart() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回选定文本中的开始偏移量。
getSelectionStart() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回选择的文本中的初始偏移量。
getSelectionStart() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回选定文本中的起始偏移量。
getSelectionStart() - 类 javax.swing.text.JTextComponent 中的方法
返回选定文本的起始位置。
getSelectionValues() - 类 javax.swing.JOptionPane 中的方法
返回输入选择值。
getSendBufferSize() - 类 java.net.DatagramSocket 中的方法
获取此 DatagramSocket 的 SO_SNDBUF 选项的值，该值是平台在 DatagramSocket 上输出时使用的缓冲区大小。
getSendBufferSize() - 类 java.net.Socket 中的方法
获取此 Socket 的 SO_SNDBUF 选项的值，该值是平台在 Socket 上输出时使用的缓冲区大小。
getSendPastNotifications() - 类 javax.management.timer.Timer 中的方法
获得一个指示计时器是否发送过期通知的标志。
getSendPastNotifications() - 接口 javax.management.timer.TimerMBean 中的方法
获得一个指示计时器是否发送过期通知的标志。
getSentenceInstance() - 类 java.text.BreakIterator 中的静态方法
返回一个用于默认语言环境 句子分解的新 BreakIterator 实例。
getSentenceInstance(Locale) - 类 java.text.BreakIterator 中的静态方法
返回一个用于给定语言环境句子分解的新 BreakIterator 实例。
getSentenceInstance(Locale) - 类 java.text.spi.BreakIteratorProvider 中的方法
为给定语言环境的句子分解返回新的 BreakIterator 实例。
getSeparatorBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的分隔符背景颜色。
getSeparatorBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回分隔符背景色。
getSeparatorForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的分隔符前景颜色。
getSeparatorForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回分隔符前景色。
getSeparatorSize() - 类 javax.swing.JToolBar.Separator 中的方法
返回分隔符的大小
getSequence(InputStream) - 类 javax.sound.midi.MidiSystem 中的静态方法
从指定的输入流获得 MIDI 序列。
getSequence(URL) - 类 javax.sound.midi.MidiSystem 中的静态方法
从指定的 URL 获得 MIDI 序列。
getSequence(File) - 类 javax.sound.midi.MidiSystem 中的静态方法
从指定的 File 获得 MIDI 序列。
getSequence() - 接口 javax.sound.midi.Sequencer 中的方法
获得 Sequencer 当前所操作的 sequence。
getSequence(InputStream) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
从提供的输入流获得 MIDI 序列。
getSequence(URL) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
从提供的 URL 获得 MIDI 序列。
getSequence(File) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
从提供的 File 获得 MIDI 序列。
getSequenceDetState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定是否针对本上下文中的 per-message 安全服务启用了序列检查。
getSequenceNumber() - 类 java.util.logging.LogRecord 中的方法
获取序列号。
getSequenceNumber() - 类 javax.management.Notification 中的方法
获得通知序列号。
getSequencer() - 类 javax.sound.midi.MidiSystem 中的静态方法
获得连接到默认设备上的默认的 Sequencer。
getSequencer(boolean) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得默认的 Sequencer，它可选地连接到默认设备上。
getSerializedObject() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记的 OBJECT 属性的值。
getSerialNumber() - 类 java.security.cert.X509Certificate 中的方法
获取证书的 serialNumber 值。
getSerialNumber() - 类 java.security.cert.X509CertSelector 中的方法
返回 serialNumber 标准。
getSerialNumber() - 类 java.security.cert.X509CRLEntry 中的方法
获取此 X509CRLEntry 的序列号 userCertificate。
getSerialNumber() - 类 javax.security.cert.X509Certificate 中的方法
获取证书的 serialNumber 值。
getSerialNumber() - 接口 javax.xml.crypto.dsig.keyinfo.X509IssuerSerial 中的方法
返回此 X509IssuerSerial 的序列号。
getSerialVersionUID() - 类 java.io.ObjectStreamClass 中的方法
返回此类的 serialVersionUID。
getServer() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回与此票据有关联的服务主体。
getServerAliases(String, Principal[]) - 接口 javax.net.ssl.X509KeyManager 中的方法
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字服务器端的别名。
getServerCertificateChain() - 类 java.net.SecureCacheResponse 中的方法
从缓存返回服务器的证书链，该证书链是作为在获得了网络资源的初始连接中定义会话的一部分建立的。
getServerCertificates() - 类 javax.net.ssl.HttpsURLConnection 中的方法
返回服务器的证书链，它是作为定义会话的一部分而建立的。
getServerName() - 类 java.security.cert.LDAPCertStoreParameters 中的方法
返回 LDAP 服务器的 DNS 名称。
getServerSessionContext() - 类 javax.net.ssl.SSLContext 中的方法
返回服务器会话上下文，它表示可供服务器端 SSL 套接字握手阶段所使用的 SSL 会话集。
getServerSocketFactory() - 类 javax.net.ssl.SSLContext 中的方法
返回此上下文的 ServerSocketFactory 对象。
getService(BeanContextServices, Object, Class, Object) - 接口 java.beans.beancontext.BeanContextServiceProvider 中的方法
由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。
getService(BeanContextChild, Object, Class, Object, BeanContextServiceRevokedListener) - 接口 java.beans.beancontext.BeanContextServices 中的方法
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
getService(BeanContextServices, Object, Class, Object) - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider 中的方法

getService(BeanContextChild, Object, Class, Object, BeanContextServiceRevokedListener) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
获得一个可被委托的服务。
getService(String, String) - 类 java.security.Provider 中的方法
获取描述此算法或别名的指定类型的此 Provider 实现的服务。
getServiceClass() - 类 java.beans.beancontext.BeanContextServiceAvailableEvent 中的方法
获得作为此通知主题的服务类。
getServiceClass() - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 中的方法
获得作为此通知主题的服务类
getServiceName() - 接口 javax.xml.ws.handler.PortInfo 中的方法
获取包含正被访问端口的 WSDL 服务名称的限定名。
getServiceName() - 类 javax.xml.ws.Service 中的方法
获取此服务的名称。
getServiceName() - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
获取此服务的名称。
getServiceProvider() - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider 中的方法

getServiceProviderByClass(Class<T>) - 类 javax.imageio.spi.ServiceRegistry 中的方法
返回当前注册的属于给定类类型的服务提供者对象。
getServiceProviders(Class<T>, boolean) - 类 javax.imageio.spi.ServiceRegistry 中的方法
返回一个包含给定类别中的所有已注册的服务提供者的 Iterator。
getServiceProviders(Class<T>, ServiceRegistry.Filter, boolean) - 类 javax.imageio.spi.ServiceRegistry 中的方法
返回一个 Iterator，其包含给定类别中满足由指定的 ServiceRegistry.Filter 对象的 filter 方法定义的条件的服务提供者对象。
getServices() - 类 java.security.Provider 中的方法
获取此 Provider 支持的所有服务的一个不可修改的 Set。
getServicesBeanInfo() - 接口 java.beans.beancontext.BeanContextServiceProviderBeanInfo 中的方法
获得一个 BeanInfo 数组，为每个可从此 ServiceProvider 中静态得到的类或接口返回一个数组。
getServiceUIFactory() - 接口 javax.print.PrintService 中的方法
返回 UI 组件的工厂方法，该组件允许用户通过各种角色与服务交互。
getSession() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回触发此事件的会话。
getSession() - 类 javax.net.ssl.SSLEngine 中的方法
返回此 SSLEngine 中使用的 SSLSession。
getSession() - 类 javax.net.ssl.SSLSessionBindingEvent 中的方法
返回 SSLSession，将侦听器绑定其中或从其解除绑定。
getSession(byte[]) - 接口 javax.net.ssl.SSLSessionContext 中的方法
返回绑定到指定会话 id 的 SSLSession。
getSession() - 类 javax.net.ssl.SSLSocket 中的方法
返回此连接使用的 SSL 会话。
getSessionCacheSize() - 接口 javax.net.ssl.SSLSessionContext 中的方法
返回用来存储在此 SSLSessionContext 下分组的 SSLSession 对象的缓存大小。
getSessionContext() - 接口 javax.net.ssl.SSLSession 中的方法
返回此会话所在的上下文。
getSessionKey() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回与此票据有关联的会话密钥。
getSessionKeyType() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回与此票据有关联的会话密钥的密钥类型（由 Kerberos Protocol Specification 定义）。
getSessionTimeout() - 接口 javax.net.ssl.SSLSessionContext 中的方法
返回在此 SSLSessionContext 下分组的 SSLSession 对象的超时值限制。
getSeverity() - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法

getSeverity() - 接口 javax.xml.bind.ValidationEvent 中的方法
检索此警告/错误的严重性代码。
getSeverity() - 接口 org.w3c.dom.DOMError 中的方法
错误的严重性，SEVERITY_WARNING、SEVERITY_ERROR 或 SEVERITY_FATAL_ERROR。
getShadowColor(Component) - 类 javax.swing.border.EtchedBorder 中的方法
返回浮雕化边框在指定组件上呈现的阴影颜色。
getShadowColor() - 类 javax.swing.border.EtchedBorder 中的方法
返回浮雕化边框的阴影颜色。
getShadowColor() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getShadowInnerColor(Component) - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框在指定组件上呈现的内部阴影颜色。
getShadowInnerColor() - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框内部的阴影颜色。
getShadowOuterColor(Component) - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框在指定组件上呈现的外部阴影颜色。
getShadowOuterColor() - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框的外部阴影颜色。
getShaper(int) - 类 java.awt.font.NumericShaper 中的静态方法
返回所提供的 unicode 范围的成形器。
getSharedAncestor(DefaultMutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点和 aNode 最近的共同祖先。
getSharedInstance() - 类 javax.swing.PopupFactory 中的静态方法
返回共享 PopupFactory，它可用于获取 Popup。
getSharedQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回一个 collection，该 collection 包含正以共享模式等待获取的线程。
getSharedQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回包含可能正以共享模式等待获取的线程 collection。
getShearInstance(double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回表示错切变换的变换。
getShearX() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵错切元素 (m01) 的 X 坐标。
getShearY() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵错切元素 (m10) 的 Y 坐标。
getShift() - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 中的方法

getShift() - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 中的方法

getShift() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon 中的方法

getShift() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon 中的方法

getShiftKey() - 接口 org.w3c.dom.events.MouseEvent 中的方法
用于指示在触发事件期间是否按下 'shift' 键。
getShort(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 short 形式返回指定数组对象中索引组件的值。
getShort(Object) - 类 java.lang.reflect.Field 中的方法
获取 short 类型或另一个通过扩展转换可以转换为 short 类型的基本类型的静态或实例字段的值。
getShort() - 类 java.nio.ByteBuffer 中的方法
用于读取 short 值的相对 get 方法。
getShort(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 short 值的绝对 get 方法。
getShort(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 short 值的形式获取指定的 JDBC SMALLINT 参数的值。
getShort(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 short 值的形式获取 JDBC SMALLINT 参数的值。
getShort(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。
getShort(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。
getShortcut() - 类 java.awt.MenuItem 中的方法
获取与此菜单项关联的 MenuShortcut 对象。
getShortcutMenuItem(MenuShortcut) - 类 java.awt.MenuBar 中的方法
获取与指定 MenuShortcut 对象关联的 MenuItem 的实例，如果此菜单栏正在管理的菜单项均与指定的菜单快捷方式无关联，则为 null。
getShortDescription() - 类 java.beans.FeatureDescriptor 中的方法
获得此特性的简短描述。
getShortMonths() - 类 java.text.DateFormatSymbols 中的方法
获取简短形式的月份字符串。
getShortParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 short 返回参数的便捷方法。
getShortWeekdays() - 类 java.text.DateFormatSymbols 中的方法
获取简短形式的星期字符串。
getShowDeleted() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
getShowDeleted() - 接口 javax.sql.rowset.CachedRowSet 中的方法
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
getShowDeleted() - 接口 javax.sql.rowset.JdbcRowSet 中的方法
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
getShowHorizontalLines() - 类 javax.swing.JTable 中的方法
如果表绘制单元格之间的水平线，则返回 true，否则返回 false。
getShowsRootHandles() - 类 javax.swing.JTree 中的方法
返回 showsRootHandles 属性的值。
getShowsRootHandles() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getShowVerticalLines() - 类 javax.swing.JTable 中的方法
如果表绘制单元格之间的垂直线，则返回 true，否则返回 false。
getSiblingCount() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的兄弟节点数。
getSides() - 类 java.awt.JobAttributes 中的方法
返回对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。
getSigAlgName() - 类 java.security.cert.X509Certificate 中的方法
获取证书签名算法的签名算法名。
getSigAlgName() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 签名算法的签名算法名。
getSigAlgName() - 类 javax.security.cert.X509Certificate 中的方法
获取用于该证书签名算法的名称。
getSigAlgOID() - 类 java.security.cert.X509Certificate 中的方法
获取证书的签名算法 OID 字符串。
getSigAlgOID() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 的签名算法 OID 字符串。
getSigAlgOID() - 类 javax.security.cert.X509Certificate 中的方法
获取证书的签名算法 OID 字符串。
getSigAlgParams() - 类 java.security.cert.X509Certificate 中的方法
从此证书的签名算法中获取 DER 编码形式的签名算法参数。
getSigAlgParams() - 类 java.security.cert.X509CRL 中的方法
获取此 CRL 的签名算法中 DER 编码形式的签名算法参数。
getSigAlgParams() - 类 javax.security.cert.X509Certificate 中的方法
从此证书的签名算法中获取 DER 编码形式的签名算法参数。
getSign() - 类 javax.xml.datatype.Duration 中的方法
以 -1、0 或 1 的形式返回此持续时间的符号。
getSignature() - 类 java.security.cert.X509Certificate 中的方法
获取证书的 signature 值（原始签名位）。
getSignature() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 的 signature 值（原始签名位）。
getSignature() - 类 java.security.SignedObject 中的方法
在已签名对象上按 byte 数组的形式获取签名。
getSignature() - 类 javax.management.MBeanConstructorInfo 中的方法
返回此构造方法的参数列表。
getSignature() - 类 javax.management.MBeanOperationInfo 中的方法
返回此操作的参数列表。
getSignature() - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
返回 OpenMBeanParameterInfo 实例的数组，该实例描述此 OpenMBeanConstructorInfo 实例描述的构造方法签名中的每个参数。
getSignature() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回 OpenMBeanOperationInfo 实例的数组，该实例描述此 OpenMBeanParameterInfo 实例所描述操作的签名中的每个参数。
getSignatureMethod() - 接口 javax.xml.crypto.dsig.SignedInfo 中的方法
返回此 SignedInfo 的签名方法。
getSignatureValue() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
返回此 XMLSignature 的签名值。
getSignedInfo() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
返回此 XMLSignature 的签名信息。
getSignerCertPath() - 类 java.security.CodeSigner 中的方法
返回签名者的证书路径。
getSignerCertPath() - 类 java.security.Timestamp 中的方法
返回 Timestamping Authority 的证书路径。
getSigners() - 类 java.lang.Class 中的方法
获取此类的标记。
getSigProvider() - 类 java.security.cert.PKIXParameters 中的方法
返回签名提供者的名称，如果未设置，则返回 null。
getSimpleName() - 类 java.lang.Class 中的方法
返回源代码中给出的底层类的简称。
getSimpleName() - 接口 javax.lang.model.element.Element 中的方法
返回此元素的简单（未限定）名称。
getSize() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回此对象的大小，用 Dimension 对象的形式表示它。
getSize() - 类 java.awt.Component 中的方法
以 Dimension 对象的形式返回组件的大小。
getSize(Dimension) - 类 java.awt.Component 中的方法
将组件的宽度/高度存储到“返回值”rv 中并返回 rv。
getSize() - 类 java.awt.Dimension 中的方法
获取此 Dimension 对象的大小。
getSize() - 类 java.awt.Font 中的方法
返回此 Font 的磅值大小，舍入为整数。
getSize() - 类 java.awt.image.DataBuffer 中的方法
返回所有存储单元的大小（按数组元素）。
getSize() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
以 Dimension 对象的形式返回此对象的大小。
getSize() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
以 Dimension 对象的形式返回此对象的大小。
getSize() - 类 java.awt.Rectangle 中的方法
获取此 Rectangle 的大小，用返回的 Dimension 表示。
getSize() - 类 java.awt.SplashScreen 中的方法
以 Dimension 形式返回闪现屏幕窗口的大小。
getSize() - 类 java.awt.TrayIcon 中的方法
返回托盘图标在系统托盘上占用的空间大小（以像素为单位）。
getSize() - 类 java.util.zip.ZipEntry 中的方法
返回条目数据的未压缩大小；如果未知，则返回 -1。
getSize() - 接口 javax.accessibility.AccessibleComponent 中的方法
以 Dimension 对象的形式返回此对象的大小。
getSize(int) - 类 javax.print.attribute.Size2DSyntax 中的方法
获取给定单位的此二维大小属性的维度作为浮点值。
getSize() - 类 javax.swing.DefaultComboBoxModel 中的方法

getSize() - 类 javax.swing.DefaultListModel 中的方法
返回此列表中的组件数。
getSize(Dimension) - 类 javax.swing.JComponent 中的方法
将此组件的宽度/高度存储到“返回值”rv 中并返回 rv。
getSize() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getSize() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法

getSize() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getSize() - 接口 javax.swing.ListModel 中的方法
返回列表的长度。
getSize() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法

getSize() - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 中的方法

getSize() - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的方法

getSize(int) - 类 javax.swing.SizeSequence 中的方法
返回指定条目的大小。
getSize() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getSize() - 类 javax.xml.soap.AttachmentPart 中的方法
返回此 AttachmentPart 对象中的字节数。
getSize2D() - 类 java.awt.Font 中的方法
返回此 Font 的磅值大小（以 float 值表示）。
getSizeButtonsToSameWidth() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回 true，基本 L&F 希望所有按钮具有相同的宽度。
getSizeOfComponent(Component) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回传入组件的宽度。
getSizes() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回组件的大小。
getSizes() - 类 javax.swing.SizeSequence 中的方法
返回所有条目的大小。
getSlaveSyncMode() - 接口 javax.sound.midi.Sequencer 中的方法
获得此 sequencer 的当前从同步模式。
getSlaveSyncModes() - 接口 javax.sound.midi.Sequencer 中的方法
获得此 sequencer 支持的从同步模式集。
getSmallDisplayIcon() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
返回此面板的小图标。
getSnapshot() - 类 java.awt.image.VolatileImage 中的方法
返回此对象的静态快照图像。
getSnapToTicks() - 类 javax.swing.JSlider 中的方法
如果滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值，则返回为 true。
getSOAPBody() - 类 javax.xml.soap.SOAPMessage 中的方法
获取此 SOAPMessage 对象中包含的 SOAP Body。
getSOAPFactory() - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
获取此 SOAP 绑定使用的 SAAJ SOAPFactory 实例。
getSOAPHeader() - 类 javax.xml.soap.SOAPMessage 中的方法
获取此 SOAPMessage 对象中包含的 SOAP Header。
getSOAPPart() - 类 javax.xml.soap.SOAPMessage 中的方法
获取此 SOAPMessage 对象的 SOAP 部分。
getSocket() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回作为此事件源的套接字。
getSocketAddress() - 类 java.net.DatagramPacket 中的方法
获取要将此包发送到的或发出此数据报的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。
getSocketFactory() - 类 java.rmi.server.RMISocketFactory 中的静态方法
返回由 setSocketFactory 方法设置的套接字工厂。
getSocketFactory() - 类 javax.net.ssl.SSLContext 中的方法
返回此上下文的 SocketFactory 对象。
getSoLinger() - 类 java.net.Socket 中的方法
返回 SO_LINGER 的设置。
getSolo() - 接口 javax.sound.midi.MidiChannel 中的方法
获得此通道的当前 solo 状态。
getSortKeys() - 类 javax.swing.DefaultRowSorter 中的方法
返回当前排序键。
getSortKeys() - 类 javax.swing.RowSorter 中的方法
返回当前排序键。
getSortOrder() - 类 javax.swing.RowSorter.SortKey 中的方法
返回列的排序顺序。
getSortsOnUpdates() - 类 javax.swing.DefaultRowSorter 中的方法
如果底层模型更新时应该进行排序，则返回 true；否则返回 false。
getSoTimeout() - 类 java.net.DatagramSocket 中的方法
获取 SO_TIMEOUT 的设置。
getSoTimeout() - 类 java.net.ServerSocket 中的方法
获取 SO_TIMEOUT 的设置。
getSoTimeout() - 类 java.net.Socket 中的方法
返回 SO_TIMEOUT 的设置。
getSoundbank(InputStream) - 类 javax.sound.midi.MidiSystem 中的静态方法
通过从指定的流读取来构造一个 MIDI 音库。
getSoundbank(URL) - 类 javax.sound.midi.MidiSystem 中的静态方法
通过从指定的 URL 处读取来构造一个 Soundbank。
getSoundbank(File) - 类 javax.sound.midi.MidiSystem 中的静态方法
通过从指定的 File 读取来构造一个 Soundbank。
getSoundbank() - 类 javax.sound.midi.SoundbankResource 中的方法
获得包含此 SoundbankResource 的音库。
getSoundbank(URL) - 类 javax.sound.midi.spi.SoundbankReader 中的方法
从提供的 URL 获得音库对象。
getSoundbank(InputStream) - 类 javax.sound.midi.spi.SoundbankReader 中的方法
从提供的 InputStream 获得音库对象。
getSoundbank(File) - 类 javax.sound.midi.spi.SoundbankReader 中的方法
从提供的 File 获得音库对象。
getSource() - 类 java.awt.image.BufferedImage 中的方法
返回生成该图像像素的对象。
getSource() - 类 java.awt.Image 中的方法
获取生成图像像素的对象。
getSource(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回作为通用 Object 的源。
getSource() - 类 java.awt.image.VolatileImage 中的方法
此方法返回此 VolatileImage 的 ImageProducer。
getSource() - 类 java.beans.PropertyEditorSupport 中的方法
返回用作事件源的 bean。
getSource(Class<T>) - 接口 java.sql.SQLXML 中的方法
返回读取此 SQLXML 实例指定的 XML 值的 Source。
getSource() - 类 java.util.EventObject 中的方法
最初发生 Event 的对象。
getSource() - 类 javax.swing.event.RowSorterEvent 中的方法
返回以 RowSorter 形式表示的事件源。
getSource() - 接口 javax.tools.Diagnostic 中的方法
获取与此诊断关联的源对象。
getSourceActions() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
此方法返回 Drag 和 Drop 操作所支持动作类型的 int 表示形式。
getSourceActions() - 类 java.awt.dnd.DragSourceContext 中的方法
返回 DnDConstants 的位掩码，表示拖动源针对与此 DragSourceContext 关联的拖动操作所支持的放置动作集合。
getSourceActions() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回源 drop 操作。
getSourceActions() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回源 drop 操作。
getSourceActions(JComponent) - 类 javax.swing.TransferHandler 中的方法
返回源支持的传输动作的类型；COPY、MOVE 和 LINK 的任意按位或组合。
getSourceAsBeanContextServices() - 类 java.beans.beancontext.BeanContextServiceAvailableEvent 中的方法
获得作为 BeanContextServices 类型引用的源。
getSourceAsBeanContextServices() - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 中的方法
获得作为 BeanContextServices 类型引用的源
getSourceAsDragGestureRecognizer() - 类 java.awt.dnd.DragGestureEvent 中的方法
以 DragGestureRecognizer 的形式返回源。
getSourceBands() - 类 javax.imageio.IIOParam 中的方法
返回要使用的源 band 的集合。
getSourceClassName() - 类 java.util.logging.LogRecord 中的方法
获取发出日志请求的类的名称。
getSourceDataLine(AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得一个源数据行，该行可用于以 AudioFormat 对象指定的格式回放音频数据。
getSourceDataLine(AudioFormat, Mixer.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。
getSourceDropActions() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
当此 TransferSupport 表示放置操作时，返回拖动源受支持的放置动作。
getSourceElement() - 类 javax.swing.event.HyperlinkEvent 中的方法
返回对应于事件源的 Element。
getSourceEncodings() - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
获得源格式编码的集合，此提供者从该集合中提供格式转换服务。
getSourceLineInfo(Line.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得关于已安装混频器所支持特定类型的全部源行的信息。
getSourceLineInfo() - 接口 javax.sound.sampled.Mixer 中的方法
获得关于此混频器支持的源行集合的信息。
getSourceLineInfo(Line.Info) - 接口 javax.sound.sampled.Mixer 中的方法
获得关于此混频器支持的特定类型源行的信息。
getSourceLines() - 接口 javax.sound.sampled.Mixer 中的方法
获得当前对此混频器打开的所有源行的集合。
getSourceMaxProgressivePass() - 类 javax.imageio.ImageReadParam 中的方法
如果 getSourceNumProgressivePasses 等于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。
getSourceMethodName() - 类 java.util.logging.LogRecord 中的方法
获取（可能）发出日志请求的方法的名称。
getSourceMinProgressivePass() - 类 javax.imageio.ImageReadParam 中的方法
返回将被解码的第一个逐步传递的索引。
getSourceNumProgressivePasses() - 类 javax.imageio.ImageReadParam 中的方法
返回将被解码的逐步传递的数量。
getSourceRegion() - 类 javax.imageio.IIOParam 中的方法
返回将使用的源区域。
getSourceRegion(ImageReadParam, int, int) - 类 javax.imageio.ImageReader 中的静态方法
reader 可用来计算应该读取的源图像区域的一个实用方法，计算时考虑任何源区域，并在所提供的 ImageReadParam 中对偏移量设置进行二次取样。
getSourceRenderSize() - 类 javax.imageio.ImageReadParam 中的方法
返回解码期间将呈现的源图像的宽度和高度，如果已经通过 setSourceRenderSize 方法设置了的话。
getSources() - 类 java.awt.image.BufferedImage 中的方法
返回 RenderedImage 对象的 Vector，该对象是此 BufferedImage 图像数据的直接来源，而不是这些直接来源的来源。
getSources() - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回源的整个 Vector。
getSources() - 接口 java.awt.image.renderable.RenderableImage 中的方法
返回作为此 RenderableImage 的图像数据源的 RenderableImage 的向量。
getSources() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
返回作为此 RenderableImage 图像数据源的 RenderableImage 的向量。
getSources() - 接口 java.awt.image.RenderedImage 中的方法
返回作为此 RenderedImage 直接图像数据源的 RenderedImage 向量。
getSourceString() - 类 java.text.CollationKey 中的方法
返回此 CollationKey 表示的 String。
getSourceVersion() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回任何生成的源和类文件应该符合的源版本。
getSourceVersions() - 接口 javax.tools.Tool 中的方法
获取此工具支持的 Java™ 编程语言的源版本。
getSourceXSubsampling() - 类 javax.imageio.IIOParam 中的方法
返回对于每个像素要前进的源列数。
getSourceYSubsampling() - 类 javax.imageio.IIOParam 中的方法
返回对于每个像素要前进的行数。
getSouthPane() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getSpaceAbove(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取上部空间设置。
getSpaceBelow(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取下部空间设置。
getSpan(int, int) - 类 javax.swing.text.BoxView 中的方法
获取特定子级的当前布局的区域。
getSpan(GlyphView, int, int, TabExpander, float) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
确定给定开始位置（相对于选项卡扩展而言）的字形区域。
getSpecificationName() - 类 javax.management.MBeanServerDelegate 中的方法
返回此产品实现的 JMX 规范的全名。
getSpecificationName() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回此产品实现的 JMX 规范的全名。
getSpecificationTitle() - 类 java.lang.Package 中的方法
返回此包实现的规范标题。
getSpecificationVendor() - 类 java.lang.Package 中的方法
返回拥有并维护实现此包的类规范的组织、供应商或公司的名称。
getSpecificationVendor() - 类 javax.management.MBeanServerDelegate 中的方法
返回此产品实现的 JMX 规范的供应商。
getSpecificationVendor() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回此产品实现的 JMX 规范的供应商。
getSpecificationVersion() - 类 java.lang.Package 中的方法
返回此包实现的规范的版本号。
getSpecificationVersion() - 类 javax.management.MBeanServerDelegate 中的方法
返回此产品实现的 JMX 规范的版本。
getSpecificationVersion() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回此产品实现的 JMX 规范的版本。
getSpecified() - 接口 org.w3c.dom.Attr 中的方法
如果在实例文档中显式给此属性一个值，则为 True；否则为 false。
getSpecName() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机规范名称。
getSpecVendor() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机规范供应商。
getSpecVersion() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机规范版本。
getSpi(String) - 类 java.util.prefs.AbstractPreferences 中的方法
返回与此首选项节点上的指定键相关联的值；如果不存在此键的关联值或此时无法确定该关联值，则返回 null。
getSpinner() - 类 javax.swing.JSpinner.DefaultEditor 中的方法
如果此编辑器的 JSpinner 祖先，如果祖先都不为 JSpinner，则返回 null。
getSplashScreen() - 类 java.awt.SplashScreen 中的静态方法
返回用于 Java 启动闪现屏幕控制的 SplashScreen 对象。
getSplitPane() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回当前包含此实例的拆分窗格。
getSplitPaneBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getSplitPaneDividerBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法
返回 JSplitPane 分隔符的边框实例
getSQLException() - 类 javax.sql.ConnectionEvent 中的方法
获取此 ConnectionEvent 对象的 SQLException。
getSQLException() - 类 javax.sql.StatementEvent 中的方法
返回驱动程序将要抛出的 SQLException。
getSQLKeywords() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库的还“不”是 SQL:2003 关键字的所有 SQL 关键字的逗号分隔列表。
getSQLState() - 异常 java.sql.SQLException 中的方法
获取此 SQLException 对象的 SQLState。
getSQLStateType() - 接口 java.sql.DatabaseMetaData 中的方法
指示由 SQLException.getSQLState 返回的 SQLSTATE 是 X/Open（现在称为 Open Group）SQL CLI 还是 SQL:2003。
getSQLTypeName() - 接口 java.sql.SQLData 中的方法
返回此对象表示的 SQL 用户定义类型的完全限定名。
getSQLTypeName() - 接口 java.sql.Struct 中的方法
获取此 Struct 对象所表示 SQL 结构的完全限定的 SQL 名称。
getSQLTypeName() - 类 javax.sql.rowset.serial.SerialStruct 中的方法
获取此 SerialStruct 对象的 SQL 类型名称。
getSQLXML(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
getSQLXML(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
getSQLXML(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getSQLXML(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getSrcName() - 接口 org.ietf.jgss.GSSContext 中的方法
返回上下文初始端的名称。
getSSLParameters() - 类 javax.net.ssl.SSLEngine 中的方法
返回对此 SSLEngine 有效的 SSLParameters。
getSSLParameters() - 类 javax.net.ssl.SSLSocket 中的方法
返回对此 SSLSocket 有效的 SSLParameters。
getSSLSocketFactory() - 类 javax.net.ssl.HttpsURLConnection 中的方法
获取为安全 https URL 连接创建套接字时使用的 SSL 套接字工厂。
getStackTrace() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程的堆栈跟踪。
getStackTrace() - 类 java.lang.Thread 中的方法
返回一个表示该线程堆栈转储的堆栈跟踪元素数组。
getStackTrace() - 类 java.lang.Throwable 中的方法
提供编程访问由 Throwable.printStackTrace() 输出的堆栈跟踪信息。
getStamp() - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
返回该标志的当前值。
getStandardChromaNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的色度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardCompressionNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的压缩信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardDataNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的数据格式信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardDimensionNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的维度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardDocumentNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的文档信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardFileManager(DiagnosticListener<? super JavaFileObject>, Locale, Charset) - 接口 javax.tools.JavaCompiler 中的方法
为此工具获取一个标准文件管理器实现的新实例。
getStandardFormatInstance() - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的静态方法
返回描述标准、插件无关的 javax.imageio_1.0 元数据文档格式的 IIOMetadataFormat 对象，该文档格式在 javax.imageio.metadata 包的注释中描述。
getStandardTextNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的文本信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardTileNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的平铺信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardTransparencyNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的透明度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardTree() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示此对象中所包含元数据的 IIOMetadataNode 的树（根据标准 javax_imageio_1.0 元数据格式的约定）的实用方法。
getStart() - 类 javax.swing.SpinnerDateModel 中的方法
返回序列中的第一个 Date。
getStartIndex() - 类 javax.accessibility.AccessibleHyperlink 中的方法
获得此链接开始处该超文本文档的索引
getStartIndex() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
获得此链接开始处该超文本文档的索引
getStartOffset() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素在此模型中的起始偏移量。
getStartOffset() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得模型中该元素的起始偏移量。
getStartOffset() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
获得模型中该元素的起始偏移量。
getStartOffset() - 类 javax.swing.text.AbstractWriter 中的方法
返回要输出内容的第一个偏移量。
getStartOffset() - 接口 javax.swing.text.Element 中的方法
获取此元素开始处的文档起始偏移量。
getStartOffset() - 类 javax.swing.text.GlyphView 中的方法
获取此视图负责的一部分模型。
getStartOffset() - 接口 javax.swing.text.Highlighter.Highlight 中的方法
获取高亮显示的初始模型偏移量。
getStartOffset() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
返回当前出现的标记所定义的并具有相同属性的范围起始处。
getStartOffset() - 类 javax.swing.text.View 中的方法
获取此视图负责的模型的一部分。
getStartPoint() - 类 java.awt.geom.Arc2D 中的方法
返回弧的起始点。
getStartPoint() - 类 java.awt.LinearGradientPaint 中的方法
返回渐变轴起始点的副本。
getStartPosition() - 类 javax.swing.text.AbstractDocument 中的方法
返回表示文档开始的位置。
getStartPosition() - 接口 javax.swing.text.Document 中的方法
返回代表文档起始处的位置。
getStartPosition() - 接口 javax.tools.Diagnostic 中的方法
获取距文件开始位置的字符偏移量，其中文件与指示问题开始位置的此诊断关联。
getStartTime() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机的启动时间（以毫秒为单位）。
getStartTime() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回此票据有效期的开始时间。
getState() - 类 java.awt.Checkbox 中的方法
确定此复选框是处于“开”状态，还是处于“关”状态。
getState() - 类 java.awt.CheckboxMenuItem 中的方法
确定此复选框菜单项的状态是 "开" 还是 "关"。
getState() - 类 java.awt.Frame 中的方法
获取此窗体的状态（已废弃）。
getState() - 类 java.awt.im.InputMethodHighlight 中的方法
返回文本范围的转换状态。
getState() - 类 java.lang.Thread 中的方法
返回该线程的状态。
getState() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回同步状态的当前值。
getState() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回同步状态的当前值。
getState() - 类 javax.swing.JCheckBoxMenuItem 中的方法
返回菜单项的选定状态。
getState() - 类 javax.swing.SwingWorker 中的方法
返回 SwingWorker 状态绑定属性。
getStateChange() - 类 java.awt.event.ItemEvent 中的方法
返回状态更改的类型（已选定或已取消选定）。
getStateLabel(boolean) - 类 javax.sound.sampled.BooleanControl 中的方法
获得指定状态的标签。
getStatement() - 接口 java.sql.ResultSet 中的方法
获取生成此 ResultSet 对象的 Statement 对象。
getStatement() - 类 javax.sql.StatementEvent 中的方法
返回正在关闭或无效的 PreparedStatement。
getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes) - 类 javax.naming.spi.DirectoryManager 中的静态方法
在给定初始对象及其属性时，检索用于绑定的对象的状态。
getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes) - 接口 javax.naming.spi.DirStateFactory 中的方法
在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
getStateToBind(Object, Name, Context, Hashtable<?, ?>) - 类 javax.naming.spi.NamingManager 中的静态方法
检索用于绑定的对象的状态。
getStateToBind(Object, Name, Context, Hashtable<?, ?>) - 接口 javax.naming.spi.StateFactory 中的方法
检索用于绑定的对象状态。
getStaticAttribute(Object) - 类 javax.swing.text.StyleContext 中的静态方法
返回以前用 registerStaticAttributeKey 注册的对象。
getStaticAttributeKey(Object) - 类 javax.swing.text.StyleContext 中的静态方法
返回其 key 将要注册的 String
getStatus() - 类 java.awt.image.PixelGrabber 中的方法
返回像素的状态。
getStatus() - 类 javax.net.ssl.SSLEngineResult 中的方法
获得此 SSLEngine 操作的返回值。
getStatus() - 类 javax.sound.midi.MidiMessage 中的方法
获得 MIDI 消息的状态字节。
getStatus() - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
获取此 SyncResolver 的当前行的冲突状态，它指示在发生冲突时 RowSet 对象正尝试的操作。
getStatusCode() - 异常 javax.xml.ws.http.HTTPException 中的方法
获取 HTTP 状态代码。
getStepSize() - 类 javax.swing.SpinnerNumberModel 中的方法
返回由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。
getStream(String) - 接口 java.applet.AppletContext 中的方法
返回此 applet 上下文中指定键所关联的流。
getStream(DataFlavor) - 接口 javax.accessibility.AccessibleStreamable 中的方法
返回 DataFlavor 的 InputStream
getStream(URL) - 类 javax.swing.JEditorPane 中的方法
获取给定 URL 的流，该 URL 是将要由 setPage 方法加载的。
getStreamForBytes() - 接口 javax.print.Doc 中的方法
获得一个从此 doc 中提取 byte 打印数据的输入流。
getStreamForBytes() - 类 javax.print.SimpleDoc 中的方法
获得一个从此 doc 中提取 byte 打印数据的输入流。
getStreamKeys() - 接口 java.applet.AppletContext 中的方法
找到此 applet 上下文中所有流对应的键。
getStreamMetadata() - 类 javax.imageio.ImageReader 中的方法
返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）；如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
getStreamMetadata(String, Set<String>) - 类 javax.imageio.ImageReader 中的方法
返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。
getStreamMetadataFormat(String) - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回描述给定的流元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
getStreamPosition() - 接口 javax.imageio.stream.ImageInputStream 中的方法
返回流的当前字节位置。
getStreamPosition() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法

getStrength() - 类 java.text.Collator 中的方法
返回此 Collator 的 strength 属性。
getStrictErrorChecking() - 接口 org.w3c.dom.Document 中的方法
指定是否强制执行错误检查的属性。
getStrikethroughOffset() - 类 java.awt.font.LineMetrics 中的方法
返回删除线相对于基线的位置。
getStrikethroughThickness() - 类 java.awt.font.LineMetrics 中的方法
返回删除线的宽度。
getString(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 String 的形式获取指定的 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。
getString(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 String 的形式获取 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。
getString(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
getString(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
getString() - 接口 java.sql.SQLXML 中的方法
返回此 SQLXML 实例指定的 XML 值的字符串表示形式。
getString(String) - 类 java.util.ResourceBundle 中的方法
从此资源包或它的某个父包中获取给定键的字符串。
getString() - 类 javax.swing.JProgressBar 中的方法
返回当前进度的 String 表示形式。
getString(SynthContext, Object, String) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
获得其值是一个 String 值的特定样式属性的便捷方法。
getString(int, int) - 接口 javax.swing.text.AbstractDocument.Content 中的方法
获取序列中包含的字符串。
getString(int, int) - 类 javax.swing.text.GapContent 中的方法
检索部分内容。
getString() - 类 javax.swing.text.html.parser.Entity 中的方法
返回以 String 表示的数据。
getString(int, int) - 类 javax.swing.text.StringContent 中的方法
检索内容的某一部分，where ＋ len 必须 <= length()。
getString(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 String，则返回该 String，否则返回 null。
getString(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 String，则返回该 String，否则返回 null。
getString(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个字符串。
getString(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个字符串。
getStringArray(String) - 类 java.util.ResourceBundle 中的方法
从此资源包或它的某个父包中获取给定键的字符串数组。
getStringBounds(String, FontRenderContext) - 类 java.awt.Font 中的方法
返回指定 FontRenderContext 中指定 String 的逻辑边界。
getStringBounds(String, int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回指定 FontRenderContext 中指定 String 的逻辑边界。
getStringBounds(char[], int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回指定 FontRenderContext 指定字符数组的逻辑边界。
getStringBounds(CharacterIterator, int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的逻辑边界。
getStringBounds(String, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定 String 的边界。
getStringBounds(String, int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定 String 的边界。
getStringBounds(char[], int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定字符数组的边界。
getStringBounds(CharacterIterator, int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回用指定 Graphics 上下文中指定 CharacterIterator 进行索引的字符的边界。
getStringConverter() - 类 javax.swing.table.TableRowSorter 中的方法
返回负责将值从模型转换为字符串的对象。
getStringData() - 接口 org.w3c.dom.ls.LSInput 中的方法
要解析的字符串数据。
getStringFunctions() - 接口 java.sql.DatabaseMetaData 中的方法
获取可用于此数据库的字符串函数的逗号分隔列表。
getStringNameType() - 接口 org.ietf.jgss.GSSName 中的方法
返回此名称的可打印表示形式的名称类型，此名称可从 toString 方法中获取。
getStringPlacement(Graphics, String, int, int, int, int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
指定将绘制进度字符串的位置。
getStringTable() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的枚举类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Chromaticity 中的方法
返回 Chromaticity 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.ColorSupported 中的方法
返回 ColorSupported 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Compression 中的方法
返回 Compression 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Fidelity 中的方法
返回 Fidelity 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Finishings 中的方法
返回 Finishings 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.JobSheets 中的方法
返回 JobSheets 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.JobState 中的方法
返回 JobState 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.JobStateReason 中的方法
返回 JobStateReason 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.MediaName 中的方法
返回 MediaTray 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.MediaSizeName 中的方法
返回 MediaSizeName 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.MediaTray 中的方法
返回 MediaTray 类字符串表。
getStringTable() - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的方法
返回 MultipleDocumentHandling 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.OrientationRequested 中的方法
返回类 OrientationRequested 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PDLOverrideSupported 中的方法
返回类 PDLOverrideSupported 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PresentationDirection 中的方法
返回类 PresentationDirection 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的方法
返回类 PrinterIsAcceptingJobs 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PrinterState 中的方法
返回类 PrinterState 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PrinterStateReason 中的方法
返回类 PrinterStateReason 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PrintQuality 中的方法
返回类 PrintQuality 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的方法
返回类 ReferenceUriSchemesSupported 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Severity 中的方法
返回类 Severity 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.SheetCollate 中的方法
返回类 SheetCollate 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Sides 中的方法
返回类 Sides 的字符串表。
getStringToCompare() - 类 javax.management.monitor.StringMonitor 中的方法
获取要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。
getStringToCompare() - 接口 javax.management.monitor.StringMonitorMBean 中的方法
获取要与 observed 属性进行比较的字符串。
getStringValue(int) - 类 javax.swing.RowFilter.Entry 中的方法
返回指定索引处的字符串值。
getStringValueAt(int, int) - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
以 String 的形式返回指定索引处的值。
getStroke() - 类 java.awt.Graphics2D 中的方法
返回 Graphics2D 上下文中的当前 Stroke
getStrongCaret(TextHitInfo, TextHitInfo, TextLayout) - 类 java.awt.font.TextLayout.CaretPolicy 中的方法
选择一个指定的 TextHitInfo 实例作为指定 TextLayout 中的强插入符。
getStyle() - 类 java.awt.Font 中的方法
返回此 Font 的样式。
getStyle() - 类 java.awt.im.InputMethodHighlight 中的方法
返回文本范围的呈现样式属性，或 null。
getStyle(String) - 类 javax.swing.JTextPane 中的方法
获取以前添加的已命名的非 null 样式。
getStyle() - 类 javax.swing.plaf.synth.SynthContext 中的方法
返回与此 Region 相关的样式。
getStyle(JComponent, Region) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
获取指定组件的指定 region 的 SynthStyle。
getStyle(JComponent, Region) - 类 javax.swing.plaf.synth.SynthStyleFactory 中的方法
返回指定 Component 的样式。
getStyle(String) - 类 javax.swing.text.DefaultStyledDocument 中的方法
获取以前添加的已命名的样式。
getStyle(String) - 类 javax.swing.text.StyleContext 中的方法
获取以前添加到文档中的已命名样式
getStyle(String) - 接口 javax.swing.text.StyledDocument 中的方法
获取以前添加的指定样式。
getStyledDocument() - 类 javax.swing.JTextPane 中的方法
获取与编辑器关联的模型。
getStyledDocument(JEditorPane) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 中的方法
获取与编辑器窗格相关的文档。
getStyledEditorKit() - 类 javax.swing.JTextPane 中的方法
获取编辑器工具包。
getStyledEditorKit(JEditorPane) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 中的方法
获取与编辑器窗格相关的编辑器工具包。
getStyleFactory() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
返回当前 SynthStyleFactory。
getStyleNames() - 类 javax.swing.text.DefaultStyledDocument 中的方法
获取样式名称列表。
getStyleNames() - 类 javax.swing.text.StyleContext 中的方法
获取定义的样式名称。
getStyleSheet() - 类 javax.swing.text.html.BlockView 中的方法

getStyleSheet() - 类 javax.swing.text.html.HTMLDocument 中的方法
获取具有特定于文档的显示规则（CSS）的 StyleSheet，其中这些规则是在 HTML 文档本身中指定的。
getStyleSheet() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取当前正用于呈现 HTML 元素的样式集。
getStyleSheet() - 类 javax.swing.text.html.ImageView 中的方法
获取 StyleSheet 的便捷方法。
getStyleSheet() - 类 javax.swing.text.html.InlineView 中的方法

getStyleSheet() - 类 javax.swing.text.html.ParagraphView 中的方法

getStylesheet() - 类 javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec 中的方法
返回样式表。
getStyleSheets() - 类 javax.swing.text.html.StyleSheet 中的方法
返回一个链接 StyleSheet 的数组。
getSubElements() - 类 javax.swing.JMenu 中的方法
返回由 MenuElement 组成的数组，其中包含此菜单组件的子菜单。
getSubElements() - 类 javax.swing.JMenuBar 中的方法
实现为 MenuElement（返回此菜单栏中的菜单）。
getSubElements() - 类 javax.swing.JMenuItem 中的方法
此方法返回包含此菜单组件的子菜单组件的数组。
getSubElements() - 类 javax.swing.JPopupMenu 中的方法
返回 MenuElement 组成的数组，包含此菜单组件的子菜单。
getSubElements() - 接口 javax.swing.MenuElement 中的方法
此方法应返回一个包含接收菜单元素的子元素的数组
getSubimage(int, int, int, int) - 类 java.awt.image.BufferedImage 中的方法
返回由指定矩形区域定义的子图像。
getSubInterfaces() - 类 java.net.NetworkInterface 中的方法
获取具有连接到此网络接口的所有子接口（也称虚拟接口）的 Enumeration。
getSubject() - 类 java.security.cert.X509CertSelector 中的方法
以 X500Principal 的形式返回 subject 标准。
getSubject() - 类 javax.security.auth.login.LoginContext 中的方法
返回已进行验证的 Subject。
getSubject(AccessControlContext) - 类 javax.security.auth.Subject 中的静态方法
获取与提供的 AccessControlContext 关联的 Subject。
getSubject() - 类 javax.security.auth.SubjectDomainCombiner 中的方法
获取与此 SubjectDomainCombiner 关联的 Subject。
getSubjectAlternativeNames() - 类 java.security.cert.X509Certificate 中的方法
从 SubjectAltName 扩展 (OID = 2.5.29.17) 中获取一个主体替换名称的不可变集合。
getSubjectAlternativeNames() - 类 java.security.cert.X509CertSelector 中的方法
返回 subjectAlternativeNames 标准的一个副本。
getSubjectAsBytes() - 类 java.security.cert.X509CertSelector 中的方法
以 byte 数组的形式返回 subject 标准。
getSubjectAsString() - 类 java.security.cert.X509CertSelector 中的方法
已过时，使用 X509CertSelector.getSubject() 或 X509CertSelector.getSubjectAsBytes() 替代。
getSubjectDN() - 类 java.security.cert.X509Certificate 中的方法
已过时，由 X509Certificate.getSubjectX500Principal() 替代。
getSubjectDN() - 类 javax.security.cert.X509Certificate 中的方法
获取证书的 subject（主体的标识名）值。
getSubjectKeyIdentifier() - 类 java.security.cert.X509CertSelector 中的方法
返回 subjectKeyIdentifier 标准。
getSubjectPublicKey() - 类 java.security.cert.X509CertSelector 中的方法
返回 subjectPublicKey 标准。
getSubjectPublicKeyAlgID() - 类 java.security.cert.X509CertSelector 中的方法
返回 subjectPublicKeyAlgID 标准。
getSubjectUniqueID() - 类 java.security.cert.X509Certificate 中的方法
获取证书的 subjectUniqueID 值。
getSubjectX500Principal() - 类 java.security.cert.X509Certificate 中的方法
以 X500Principal 的形式返回证书的主体（主体标识名）值。
getSubsamplingXOffset() - 类 javax.imageio.IIOParam 中的方法
返回二次取样网格的水平偏移量。
getSubsamplingYOffset() - 类 javax.imageio.IIOParam 中的方法
返回二次取样网格的垂直偏移量。
getSubString(long, int) - 接口 java.sql.Clob 中的方法
获取此 Clob 对象指定的 CLOB 值中指定子字符串的副本。
getSubString(long, int) - 类 javax.sql.rowset.serial.SerialClob 中的方法
返回包含在此 SerialClob 对象中的子字符串的副本，从给定位置开始，后跟指定字符数。
getSubTextFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回子文本字体。
getSubTextFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的子文本字体。
getSubTextFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回子文本字体。
getSubType() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的子 MIME 类型。
getSubType() - 类 javax.activation.MimeType 中的方法
获取此对象的子类型。
getSuffix(int) - 类 javax.naming.CompositeName 中的方法
创建一个复合名称，其组件由此复合名称中组件的后缀组成。
getSuffix(int) - 类 javax.naming.CompoundName 中的方法
创建一个组合名称，其组件由该组合名称中组件的后缀组成。
getSuffix(int) - 类 javax.naming.ldap.LdapName 中的方法
创建一个名称，其组件由此 LDAP 名称中组件的后缀组成。
getSuffix(int) - 接口 javax.naming.Name 中的方法
创建一个名称，其组件由此名称中组件的后缀组成。
getSuperBound() - 接口 javax.lang.model.type.WildcardType 中的方法
返回此通配符的下边界。
getSuperclass() - 类 java.lang.Class 中的方法
返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的超类的 Class。
getSuperclass() - 接口 javax.lang.model.element.TypeElement 中的方法
返回此类型元素的直接超类。
getSuperTables(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取在此数据库的特定模式中定义的表分层结构的描述。
getSuperTypes(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取在此数据库的特定模式中定义的用户定义类型 (UDT) 分层结构的描述。
getSupportedAnnotationTypes() - 类 javax.annotation.processing.AbstractProcessor 中的方法
如果 processor 类是使用 SupportedAnnotationTypes 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。
getSupportedAnnotationTypes() - 接口 javax.annotation.processing.Processor 中的方法
返回此 Processor 支持的注释类型的名称。
getSupportedAttributeCategories() - 接口 javax.print.PrintService 中的方法
确定客户端在设置此 PrintService 的作业时，可以指定的打印属性类别。
getSupportedAttributeValues(Class<? extends Attribute>, DocFlavor, AttributeSet) - 接口 javax.print.PrintService 中的方法
确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
getSupportedCipherSuites() - 类 javax.net.ssl.SSLEngine 中的方法
返回为了在此引擎上使用而可以启用的密码套件名称。
getSupportedCipherSuites() - 类 javax.net.ssl.SSLServerSocket 中的方法
返回可以启用以供 SSL 连接使用的密码套件的名称。
getSupportedCipherSuites() - 类 javax.net.ssl.SSLServerSocketFactory 中的方法
返回可以在由此工厂创建的 SSL 连接上启用的密码套件的名称。
getSupportedCipherSuites() - 类 javax.net.ssl.SSLSocket 中的方法
返回可以启用以供此连接使用的密码套件的名称。
getSupportedCipherSuites() - 类 javax.net.ssl.SSLSocketFactory 中的方法
返回可以在 SSL 连接上启用的密码套件的名称。
getSupportedDocFlavors() - 接口 javax.print.PrintService 中的方法
确定在设置此 PrintService 的作业时，客户端可以指定的打印数据格式。
getSupportedDocFlavors() - 类 javax.print.StreamPrintServiceFactory 中的方法
查询该工厂，了解从此工厂所获得打印机可接受的 doc flavor。
getSupportedExtensions() - 类 java.security.cert.PKIXCertPathChecker 中的方法
返回一个此 PKIXCertPathChecker 支持（也就是识别，即能够处理）的 X.509 证书扩展的不可变的 Set，如果不支持这些扩展，则返回 null。
getSupportedOptions() - 类 javax.annotation.processing.AbstractProcessor 中的方法
如果 processor 类是使用 SupportedOptions 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。
getSupportedOptions() - 接口 javax.annotation.processing.Processor 中的方法
返回此 Processor 识别的选项。
getSupportedProtocols() - 类 javax.net.ssl.SSLEngine 中的方法
返回能够被启用，以便让 SSLEngine 可使用的协议的名称。
getSupportedProtocols() - 类 javax.net.ssl.SSLServerSocket 中的方法
返回可以启用的协议的名称。
getSupportedProtocols() - 类 javax.net.ssl.SSLSocket 中的方法
返回能够被启用以供 SSL 连接使用的协议的名称。
getSupportedSourceVersion() - 类 javax.annotation.processing.AbstractProcessor 中的方法
如果 processor 类是使用 SupportedSourceVersion 注释的，则返回注释中的源版本。
getSupportedSourceVersion() - 接口 javax.annotation.processing.Processor 中的方法
返回此注释 Processor 支持的最新的源版本。
getSupportedSSLParameters() - 类 javax.net.ssl.SSLContext 中的方法
返回表示此 SSL 上下文受支持设置的 SSLParameters 的副本。
getSupportsAbsolutePositioning() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
指示用户是否可以利用鼠标动作（通常使用中间的鼠标按键）来绝对定位 thumb。
getSupportsWindowDecorations() - 类 javax.swing.LookAndFeel 中的方法
如果 LookAndFeel 返回的 RootPaneUI 实例支持 JRootPane 中提供 Window 装饰，则返回 true。
getSupportsWindowDecorations() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回 true； metal 可以提供 Window 装饰。
getSurrendersFocusOnKeystroke() - 类 javax.swing.JTable 中的方法
如果在键击导致编辑器被激活时编辑器应该获得焦点，则返回 true
getSymbol() - 类 java.util.Currency 中的方法
获取默认语言环境的货币符号。
getSymbol(Locale) - 类 java.util.Currency 中的方法
获取指定语言环境的货币符号。
getSymbol(String, Locale) - 类 java.util.spi.CurrencyNameProvider 中的方法
获取指定语言环境的给定货币代码的符号。
getSyncAllWidths() - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法

getSyncFactory() - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
返回一个 SyncFactory。
getSyncProvider() - 接口 javax.sql.rowset.CachedRowSet 中的方法
获取此 CachedRowSet 对象的 SyncProvider 实现。
getSyncResolver() - 异常 javax.sql.rowset.spi.SyncProviderException 中的方法
获取为此 SyncProviderException 对象设置的 SyncResolver 对象，如果没有设置，则获取包含在参考实现中的默认 SyncResolver 实现的实例。
getSynthesizer() - 类 javax.sound.midi.MidiSystem 中的静态方法
获得默认的合成器。
getSystem() - 类 java.rmi.activation.ActivationGroup 中的静态方法
返回该 VM 的激活系统。
getSystem() - 类 java.rmi.activation.ActivationGroupID 中的方法
返回组的激活系统。
getSystemClassLoader() - 类 java.lang.ClassLoader 中的静态方法
返回委托的系统类加载器。
getSystemClipboard() - 类 java.awt.Toolkit 中的方法
获取系统 Clipboard 的一个实例，该 Clipboard 可作为本机平台提供的剪贴板工具的接口。
getSystemCustomCursor(String) - 类 java.awt.Cursor 中的静态方法
返回与指定名称匹配的特定于系统的定制光标对象。
getSystemDisplayName(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
在系统文件浏览器中显示的文件、目录或文件夹名。
getSystemEventQueue() - 类 java.awt.Toolkit 中的方法
获取应用程序或 applet 的 EventQueue 实例。
getSystemEventQueueImpl() - 类 java.awt.Toolkit 中的方法
获取应用程序或 applet 的 EventQueue 实例，不检查访问权。
getSystemFunctions() - 接口 java.sql.DatabaseMetaData 中的方法
获取可用于此数据库的系统函数的逗号分隔列表。
getSystemIcon(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
在系统文件浏览器中显示的文件、目录或文件夹的图标。
getSystemId() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
实体的系统标识符。
getSystemId() - 接口 javax.xml.stream.events.NotationDeclaration 中的方法
注释的系统标识符，如果未提供该标识符，则为 null。
getSystemId() - 接口 javax.xml.stream.events.StartDocument 中的方法
返回 XML 数据的系统 ID
getSystemId() - 接口 javax.xml.stream.Location 中的方法
返回 XML 的系统 ID
getSystemId() - 类 javax.xml.transform.dom.DOMResult 中的方法
获取系统标识符。
getSystemId() - 类 javax.xml.transform.dom.DOMSource 中的方法
获取将从其解析 URL 的基本 ID（URL 或系统 ID）。
getSystemId() - 接口 javax.xml.transform.Result 中的方法
获取通过 setSystemId 设置的系统标识符。
getSystemId() - 类 javax.xml.transform.sax.SAXResult 中的方法
获取通过 setSystemId 设置的系统标识符。
getSystemId() - 类 javax.xml.transform.sax.SAXSource 中的方法
获取要从其解析 URI 的基本 ID（URI 或系统 ID）。
getSystemId() - 接口 javax.xml.transform.sax.TemplatesHandler 中的方法
获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。
getSystemId() - 接口 javax.xml.transform.sax.TransformerHandler 中的方法
获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。
getSystemId() - 接口 javax.xml.transform.Source 中的方法
获取通过 setSystemId 设置的系统标识符。
getSystemId() - 接口 javax.xml.transform.SourceLocator 中的方法
返回当前文档事件的系统标识符。
getSystemId() - 类 javax.xml.transform.stax.StAXResult 中的方法
返回的系统标识符始终为 null。
getSystemId() - 类 javax.xml.transform.stax.StAXSource 中的方法
获取此 StAXSource 使用的系统标识符。
getSystemId() - 类 javax.xml.transform.stream.StreamResult 中的方法
获取通过 setSystemId 设置的系统标识符。
getSystemId() - 类 javax.xml.transform.stream.StreamSource 中的方法
获取通过 setSystemId 设置的系统标识符。
getSystemId() - 接口 org.w3c.dom.DocumentType 中的方法
外部子集的系统标识符。
getSystemId() - 接口 org.w3c.dom.Entity 中的方法
如果已指定，则为与实体相关的系统标识符；否则为 null。
getSystemId() - 接口 org.w3c.dom.ls.LSInput 中的方法
系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。
getSystemId() - 接口 org.w3c.dom.ls.LSOutput 中的方法
系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。
getSystemId() - 接口 org.w3c.dom.Notation 中的方法
此表示法的系统标识符。
getSystemId() - 类 org.xml.sax.helpers.LocatorImpl 中的方法
返回保存的系统标识符。
getSystemId() - 类 org.xml.sax.InputSource 中的方法
获取此输入源的系统标识符。
getSystemId() - 接口 org.xml.sax.Locator 中的方法
返回当前文档事件的系统标识符。
getSystemId() - 异常 org.xml.sax.SAXParseException 中的方法
获取发生异常的实体的系统标识符。
getSystemJavaCompiler() - 类 javax.tools.ToolProvider 中的静态方法
获取此平台提供的 Java™ 编程语言编译器。
getSystemLoadAverage() - 接口 java.lang.management.OperatingSystemMXBean 中的方法
返回最后一分钟内系统加载平均值。
getSystemLookAndFeelClassName() - 类 javax.swing.UIManager 中的静态方法
如果有实现本机系统外观的 LookAndFeel 类的名称，则返回该名称；否则返回默认的跨平台 LookAndFeel 类的名称。
getSystemProperties() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回所有系统属性的名称和值的映射。
getSystemResource(String) - 类 java.lang.ClassLoader 中的静态方法
从用来加载类的搜索路径中查找具有指定名称的资源。
getSystemResourceAsStream(String) - 类 java.lang.ClassLoader 中的静态方法
从用来加载类的搜索路径打开具有指定名称的资源，以读取该资源。
getSystemResources(String) - 类 java.lang.ClassLoader 中的静态方法
从用来加载类的搜索路径中查找所有具有指定名称的资源。
getSystemScope() - 类 java.security.IdentityScope 中的静态方法
已过时。 返回系统的身份作用域。
getSystemSelection() - 类 java.awt.Toolkit 中的方法
以 Clipboard 对象的形式获取系统选择的一个实例。
getSystemTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的系统文本颜色。
getSystemTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回系统文本颜色。
getSystemTextFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回系统文本字体。
getSystemTextFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的系统文本字体。
getSystemTextFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回系统文本字体。
getSystemToolClassLoader() - 类 javax.tools.ToolProvider 中的静态方法
返回此平台提供的工具的类加载器。
getSystemTray() - 类 java.awt.SystemTray 中的静态方法
获取表示桌面托盘区的 SystemTray 实例。
getSystemTypeDescription(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
在系统文件浏览器中显示的文件、目录或文件夹类型描述。
getTab(int) - 类 javax.swing.text.TabSet 中的方法
返回索引 index 处的 TabStop。
getTabAfter(float) - 类 javax.swing.text.TabSet 中的方法
返回 location 之后的 Tab 实例。
getTabAreaInsets(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabBase() - 类 javax.swing.text.ParagraphView 中的方法
返回从中计算制表符的位置。
getTabbedSpan(float, TabExpander) - 类 javax.swing.text.GlyphView 中的方法
确定使用给定选项卡扩展实现时所需的区域。
getTabbedSpan(float, TabExpander) - 接口 javax.swing.text.TabableView 中的方法
确定当使用给定的制表符扩展实现时所需的跨距。
getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int) - 类 javax.swing.text.Utilities 中的静态方法
确定给定文本中的某个相对偏移量，使其能最好的表示视图坐标系统中的给定跨距。
getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int, boolean) - 类 javax.swing.text.Utilities 中的静态方法

getTabbedTextWidth(Segment, FontMetrics, int, TabExpander, int) - 类 javax.swing.text.Utilities 中的静态方法
确定给定的考虑制表符的文本段的宽度。
getTabBounds(JTabbedPane, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回指定选项卡索引的边界。
getTabBounds(int, Rectangle) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回 JTabbedPane 组件的坐标空间中指定选项卡的边界。
getTabBounds(JTabbedPane, int) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getTabBounds 方法。
getTabBounds(JTabbedPane, int) - 类 javax.swing.plaf.TabbedPaneUI 中的方法

getTabComponentAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置上的选项卡组件。
getTabCount() - 类 javax.swing.JTabbedPane 中的方法
返回此 tabbedpane 的选项卡数。
getTabCount() - 类 javax.swing.text.TabSet 中的方法
返回接收者包含的 Tab 实例数。
getTabExpander() - 类 javax.swing.text.GlyphView 中的方法
如果此视图中存在选项卡，则获取要使用的 TabExpander。
getTabIndex(TabStop) - 类 javax.swing.text.TabSet 中的方法

getTabIndexAfter(float) - 类 javax.swing.text.TabSet 中的方法
返回 location 之后使用的 Tab 的索引。
getTabInsets(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabLabelShiftX(int, int, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabLabelShiftX(int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
重写该方法，使其不对 Java L&F 进行任何操作。
getTabLabelShiftY(int, int, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabLabelShiftY(int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
重写该方法，使其不对 Java L&F 进行任何操作。
getTabLayoutPolicy() - 类 javax.swing.JTabbedPane 中的方法
返回在一次运行中不能放入所有的选项卡时，选项卡窗格使用的对选项卡进行布局安排的策略。
getTable() - 类 java.awt.image.ByteLookupTable 中的方法
按引用返回 lookup table 数据。
getTable() - 类 java.awt.image.LookupOp 中的方法
返回 LookupTable。
getTable() - 类 java.awt.image.ShortLookupTable 中的方法
根据引用返回查找表数据。
getTable() - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的方法
以 int 数组的形式按自然（非 Z 字形）顺序返回当前量化表的副本。
getTable() - 类 javax.swing.table.JTableHeader 中的方法
返回与此头关联的表。
getTableCellEditorComponent(JTable, Object, boolean, int, int) - 类 javax.swing.DefaultCellEditor 中的方法
实现 TableCellEditor 接口。
getTableCellEditorComponent(JTable, Object, boolean, int, int) - 接口 javax.swing.table.TableCellEditor 中的方法
为编辑器设置初始 value。
getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
返回默认的表单元格渲染器。
getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int) - 接口 javax.swing.table.TableCellRenderer 中的方法
返回用于绘制单元格的组件。
getTableHeader() - 类 javax.swing.JTable 中的方法
返回此 JTable 所使用的 tableHeader。
getTableModelListeners() - 类 javax.swing.table.AbstractTableModel 中的方法
返回一个包含在此模型上注册的所有表模型侦听器的数组。
getTableName(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的名称。
getTableName() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回创建此 CachedRowSet 对象时所用对象（表）的标识符。
getTableName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取派生指定列中值的表名称。
getTablePrivileges(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取可在类别中使用的每个表的访问权的描述。
getTables(String, String, String, String[]) - 接口 java.sql.DatabaseMetaData 中的方法
获取可在给定类别中使用的表的描述。
getTableTypes() - 接口 java.sql.DatabaseMetaData 中的方法
获取可在此数据库中使用的表类型。
getTabPlacement() - 类 javax.swing.JTabbedPane 中的方法
返回此选项卡窗格的选项卡布局。
getTabRunCount() - 类 javax.swing.JTabbedPane 中的方法
返回当前运行的用于显示选项卡的选项卡数。
getTabRunCount(JTabbedPane) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabRunCount(JTabbedPane) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getTabRunCount 方法。
getTabRunCount(JTabbedPane) - 类 javax.swing.plaf.TabbedPaneUI 中的方法

getTabRunIndent(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabRunOffset(int, int, int, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabRunOverlay(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabRunOverlay(int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法

getTabSet() - 类 javax.swing.text.ParagraphView 中的方法
获取计算制表符时使用的 Tabset。
getTabSet(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取 TabSet。
getTabSize() - 类 javax.swing.JTextArea 中的方法
获取用于扩展选项卡的字符数。
getTabSize() - 类 javax.swing.text.PlainView 中的方法
返回文档中制表符大小的集合，默认值是 8。
getTabSize() - 类 javax.swing.text.WrappedPlainView 中的方法
返回文档的制表符大小设置，默认为 8。
getTabularType() - 接口 javax.management.openmbean.TabularData 中的方法
返回描述此 TabularData 实例的表格类型。
getTabularType() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回描述此 TabularData 实例的表格类型。
getTag(String) - 类 javax.swing.text.html.HTML 中的静态方法
获取已知标记名称的标记常量（即集合 {A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOBR, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, S, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR} 中的某个标记）。
getTag() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
此迭代器所表示的标记类型。
getTagName() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getTagName() - 接口 org.w3c.dom.Element 中的方法
元素的名称。
getTags() - 接口 java.beans.PropertyEditor 中的方法
如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记数组。
getTags() - 类 java.beans.PropertyEditorSupport 中的方法
如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记值数组。
getTail(Handler) - 类 java.util.logging.Formatter 中的方法
返回一组格式化记录的尾部字符串。
getTail(Handler) - 类 java.util.logging.XMLFormatter 中的方法
返回一组 XML 格式记录的尾部字符串。
getTarget() - 类 java.beans.EventHandler 中的方法
返回此事件处理程序将为其发送消息的对象。
getTarget() - 类 java.beans.Statement 中的方法
返回此语句的目标。
getTarget() - 类 javax.accessibility.AccessibleRelation 中的方法
返回此关系的目标对象
getTarget() - 接口 javax.rmi.CORBA.Tie 中的方法
返回此 tie 的目标。
getTarget() - 类 javax.swing.BoxLayout 中的方法
返回使用此布局管理器的容器。
getTarget() - 类 javax.swing.OverlayLayout 中的方法
返回使用此布局管理器的容器。
getTarget() - 类 javax.swing.text.html.HTMLFrameHyperlinkEvent 中的方法
返回链接的目标。
getTarget() - 接口 javax.xml.crypto.dsig.SignatureProperty 中的方法
返回此 SignatureProperty 的目标 URI。
getTarget() - 接口 javax.xml.stream.events.ProcessingInstruction 中的方法
处理指令的目标部分。
getTarget() - 接口 org.w3c.dom.events.Event 中的方法
用于指示 EventTarget，最初将事件指派给它。
getTarget() - 接口 org.w3c.dom.ProcessingInstruction 中的方法
此处理指令的目标。
getTargetActions() - 类 java.awt.dnd.DragSourceDragEvent 中的方法
此方法返回目标放置动作。
getTargetActions() - 类 java.awt.dnd.DropTargetContext 中的方法
此方法返回一个 int，表示此 DropTarget 将接受的当前操作。
getTargetCertConstraints() - 类 java.security.cert.PKIXParameters 中的方法
返回目标证书所需的限制。
getTargetDataLine(AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得一个目标数据行，该行可用于以 AudioFormat 对象指定的格式记录音频数据。
getTargetDataLine(AudioFormat, Mixer.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。
getTargetedNotifications() - 类 javax.management.remote.NotificationResult 中的方法
返回查询到的通知以及相应的侦听器。
getTargetEncodings(AudioFormat.Encoding) - 类 javax.sound.sampled.AudioSystem 中的静态方法
使用已安装的格式转换器集合获得系统可以从具有指定编码的音频输入流中获得的编码。
getTargetEncodings(AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
使用已安装的格式转换器集合，获得系统可以从具有指定格式的音频输入流中获得的编码。
getTargetEncodings() - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
获得目标格式编码的集合，此提供者向该集合提供格式转换服务。
getTargetEncodings(AudioFormat) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
获得受给定了特定源格式的格式转换器支持的目标格式编码集合。
getTargetError() - 异常 javax.management.RuntimeErrorException 中的方法
返回抛出的实际 Error。
getTargetException() - 异常 java.lang.reflect.InvocationTargetException 中的方法
获取抛出的目标异常。
getTargetException() - 异常 javax.management.MBeanException 中的方法
返回实际抛出的 Exception。
getTargetException() - 异常 javax.management.ReflectionException 中的方法
返回抛出的实际 Exception。
getTargetException() - 异常 javax.management.RuntimeMBeanException 中的方法
返回抛出的实际 RuntimeException。
getTargetException() - 异常 javax.management.RuntimeOperationsException 中的方法
返回抛出的实际 RuntimeException。
getTargetFormats(AudioFormat.Encoding, AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
使用已安装的格式转换器，获得具有特定编码的格式，以及系统可以从指定格式的流中获得的格式。
getTargetFormats(AudioFormat.Encoding, AudioFormat) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
获得具有受格式转换器支持的指定编码的目标格式集合。
getTargetLineInfo(Line.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得关于已安装混频器所支持特定类型的全部目标行的信息。
getTargetLineInfo() - 接口 javax.sound.sampled.Mixer 中的方法
获得关于此混频器支持的目标行集合的信息。
getTargetLineInfo(Line.Info) - 接口 javax.sound.sampled.Mixer 中的方法
获得关于此混频器支持的特定类型目标行的信息。
getTargetLines() - 接口 javax.sound.sampled.Mixer 中的方法
获得当前从此混频器打开的所有目标行的集合。
getTargName() - 接口 org.ietf.jgss.GSSContext 中的方法
返回上下文接受端的名称。
getTask(Writer, JavaFileManager, DiagnosticListener<? super JavaFileObject>, Iterable<String>, Iterable<String>, Iterable<? extends JavaFileObject>) - 接口 javax.tools.JavaCompiler 中的方法
使用给定组件和参数创建编译任务的 future。
getTaskCount() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回曾计划执行的近似任务总数。
getTBSCertificate() - 类 java.security.cert.X509Certificate 中的方法
从此证书中获取以 DER 编码的证书信息，即 tbsCertificate。
getTBSCertList() - 类 java.security.cert.X509CRL 中的方法
从此 CRL 中获取以 DER 编码的 CRL 信息，即 tbsCertList。
getTcpNoDelay() - 类 java.net.Socket 中的方法
测试是否启用 TCP_NODELAY。
getTemplates() - 接口 javax.xml.transform.sax.TemplatesHandler 中的方法
当 TemplatesHandler 对象用作 ContentHandler（用于转换指令的解析）时，它创建 Templates 对象，调用者可以在 SAX 事件已完成后获取该对象。
getTempoFactor() - 接口 javax.sound.midi.Sequencer 中的方法
返回 sequencer 的当前速度因子。
getTempoInBPM() - 接口 javax.sound.midi.Sequencer 中的方法
获得当前的速度，用每分钟的拍数表示。
getTempoInMPQ() - 接口 javax.sound.midi.Sequencer 中的方法
获得当前的速度，用每四分音符的微秒数表示。
getText() - 类 java.awt.event.InputMethodEvent 中的方法
获取已提交文本和撰写文本的组合。
getText() - 类 java.awt.Label 中的方法
获取此标签的文本。
getText() - 类 java.awt.TextComponent 中的方法
返回此文本组件表示的文本。
getText() - 类 java.text.BreakIterator 中的方法
获取被扫描的文本
getText() - 类 javax.security.auth.callback.TextInputCallback 中的方法
获取检索到的文本。
getText() - 类 javax.swing.AbstractButton 中的方法
返回按钮的文本。
getText() - 类 javax.swing.JEditorPane 中的方法
根据此编辑器的内容类型返回此 TextComponent 中所包含的文本。
getText() - 类 javax.swing.JLabel 中的方法
返回该标签所显示的文本字符串。
getText() - 类 javax.swing.JPasswordField 中的方法
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。
getText(int, int) - 类 javax.swing.JPasswordField 中的方法
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。
getText(int, int) - 类 javax.swing.text.AbstractDocument 中的方法
从文档中获得文本序列。
getText(int, int, Segment) - 类 javax.swing.text.AbstractDocument 中的方法
获取文档给定部分内包含的文本。
getText(Element) - 类 javax.swing.text.AbstractWriter 中的方法
返回与该元素关联的文本。
getText(int, int) - 接口 javax.swing.text.Document 中的方法
获取文档中给定部分包含的文本。
getText(int, int, Segment) - 接口 javax.swing.text.Document 中的方法
获取文档中给定部分包含的文本。
getText(int, int) - 类 javax.swing.text.GlyphView 中的方法
获取对占用给定范围的文本的引用。
getText(int, int) - 类 javax.swing.text.JTextComponent 中的方法
获取由组件表示的文本部分。
getText() - 类 javax.swing.text.JTextComponent 中的方法
返回此 TextComponent 中包含的文本。
getText() - 接口 javax.xml.stream.events.Comment 中的方法
返回注释的字符串数据，如果不存在这样的数据，则返回空字符串。
getText() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getText() - 接口 javax.xml.stream.XMLStreamReader 中的方法
以字符串的形式返回解析事件的当前值，此方法返回 CHARACTERS 事件的字符串值，返回 COMMENT 的值、ENTITY_REFERENCE 的替代值、CDATA 节的字符串值、SPACE 事件的字符串值、DTD 内部子集的字符串值。
getTextBorder() - 类 javax.swing.plaf.metal.MetalBorders 中的静态方法
返回一个用于文本组件的 border 实例
getTextBounds(int, int) - 接口 javax.accessibility.AccessibleExtendedText 中的方法
返回两个索引之间文本的边界矩形。
getTextBounds(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回包围两个索引之间文本的 Rectangle。
getTextCharacters(int, char[], int, int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getTextCharacters() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getTextCharacters() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回一个包含此事件中字符的数组。
getTextCharacters(int, char[], int, int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取与 CHARACTERS、SPACE 或 CDATA 事件关联的文本。
getTextComponent(ActionEvent) - 类 javax.swing.text.TextAction 中的方法
确定动作所使用的组件。
getTextContent() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getTextContent() - 接口 org.w3c.dom.Node 中的方法
此属性返回此节点及其后代的文本内容。
getTextField() - 类 javax.swing.JSpinner.DefaultEditor 中的方法
返回此编辑器的子 JFormattedTextField。
getTextFieldBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getTextFieldBorder() - 类 javax.swing.plaf.metal.MetalBorders 中的静态方法
返回一个用于 JTextField 的 border 实例
getTextHighlightColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的文本高亮显示颜色。
getTextHighlightColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回文本高亮显示的颜色。
getTextLength() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getTextLength() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回文本字符数组中此文本事件的字符序列长度。
getTextListeners() - 类 java.awt.TextComponent 中的方法
返回在此文本组件上所有已注册文本侦听器的数组。
getTextLocation(TextHitInfo) - 接口 java.awt.im.InputMethodRequests 中的方法
获取当前撰写文本中指定偏移量的位置，或已提交文本中的选择位置。
getTextNonSelectionColor() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回未选定节点时绘制文本所使用的颜色。
getTextPlainUnicodeFlavor() - 类 java.awt.datatransfer.DataFlavor 中的静态方法
返回表示具有 Unicode 编码的纯文本的 DataFlavor，其中： representationClass = java.io.InputStream mimeType = "text/plain; charset=<platform default Unicode encoding>" Sun 的 Microsoft Windows 实现使用编码 utf-16le。
getTextRange(int, int) - 接口 javax.accessibility.AccessibleEditableText 中的方法
返回两个索引之间的文本字符串。
getTextRange(int, int) - 接口 javax.accessibility.AccessibleExtendedText 中的方法
返回两个索引之间的文本。
getTextRange(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回两个索引之间的文本。
getTextRange(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回两个索引之间的文本字符串。
getTextRange(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回两个索引之间的文本字符串。
getTextSelectionColor() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回选定节点时绘制文本所使用的颜色。
getTextSequenceAfter(int, int) - 接口 javax.accessibility.AccessibleExtendedText 中的方法
返回给定索引后面的 AccessibleTextSequence。
getTextSequenceAfter(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 之后的 AccessibleTextSequence。
getTextSequenceAfter(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定 index 之后的 AccessibleTextSequence。
getTextSequenceAt(int, int) - 接口 javax.accessibility.AccessibleExtendedText 中的方法
返回给定索引处的 AccessibleTextSequence。
getTextSequenceAt(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 处的 AccessibleTextSequence。
getTextSequenceAt(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定 index 处的 AccessibleTextSequence。
getTextSequenceBefore(int, int) - 接口 javax.accessibility.AccessibleExtendedText 中的方法
返回给定索引前面的 AccessibleTextSequence。
getTextSequenceBefore(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 之前的 AccessibleTextSequence。
getTextSequenceBefore(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定 index 之前的 AccessibleTextSequence。
getTextShiftOffset() - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getTextShiftOffset() - 类 javax.swing.plaf.basic.BasicToggleButtonUI 中的方法
重写以便不用为 Toggle 按钮和子类交替呈现文本。
getTextStart() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getTextStart() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回存储（此文本事件的）第一个字符位置处的文本字符数组的偏移量。
getTextViewForTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回为指定选项卡呈现样式化文本 (HTML) 所需的文本 View 对象；如果此选项卡不需要任何特殊化的文本呈现，则返回 null。
getThickness() - 类 javax.swing.border.LineBorder 中的方法
返回边框的厚度。
getThisUpdate() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 的 thisUpdate 日期。
getThreadCount() - 接口 java.lang.management.ThreadMXBean 中的方法
返回活动线程的当前数目，包括守护线程和非守护线程。
getThreadCpuTime(long) - 接口 java.lang.management.ThreadMXBean 中的方法
返回指定 ID 的线程的总 CPU 时间（以毫微秒为单位）。
getThreadFactory() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回用于创建新线程的线程工厂。
getThreadGroup() - 类 java.lang.SecurityManager 中的方法
调用此方法时，返回所有新创建的线程实例化后所在的线程组。
getThreadGroup() - 类 java.lang.Thread 中的方法
返回该线程所属的线程组。
getThreadId() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程的 ID。
getThreadID() - 类 java.util.logging.LogRecord 中的方法
获取产生消息的线程的标识符。
getThreadInfo(long) - 接口 java.lang.management.ThreadMXBean 中的方法
返回指定 id 的不具有堆栈跟踪的线程的线程信息。
getThreadInfo(long[]) - 接口 java.lang.management.ThreadMXBean 中的方法
返回其 ID 在输出数组 ids 中的每个线程的线程信息，这些线程不具有堆栈跟踪。
getThreadInfo(long, int) - 接口 java.lang.management.ThreadMXBean 中的方法
返回指定 id 的线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。
getThreadInfo(long[], int) - 接口 java.lang.management.ThreadMXBean 中的方法
返回其 ID 在输入数组 ids 中的每个线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。
getThreadInfo(long[], boolean, boolean) - 接口 java.lang.management.ThreadMXBean 中的方法
返回每个线程的线程信息，线程 ID 位于输入数组 ids 中，带有堆栈跟踪和同步信息。
getThreadMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机的线程系统的管理 Bean。
getThreadName() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程的名称。
getThreadState() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程的状态。
getThreadUserTime(long) - 接口 java.lang.management.ThreadMXBean 中的方法
返回指定 ID 的线程在用户模式中执行的 CPU 时间（以毫微秒为单位）。
getThreshold(ObjectName) - 类 javax.management.monitor.CounterMonitor 中的方法
如果指定的对象包含在观察到的 MBeans 集中，则获取指定对象的当前阈值，否则将为 null。
getThreshold() - 类 javax.management.monitor.CounterMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getThreshold(ObjectName) 取代
getThreshold() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getThreshold(ObjectName) 取代
getThreshold(ObjectName) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取指定 MBean 的阈值。
getThrowable() - 类 java.awt.event.InvocationEvent 中的方法
返回在执行 Runnable 的 run() 方法时捕获的任何 Throwable。
getThrown() - 类 java.util.logging.LogRecord 中的方法
获取与日志记录相关联的所有 throwable。
getThrownTypes() - 接口 javax.lang.model.element.ExecutableElement 中的方法
按声明顺序返回此方法或构造方法的 throws 子句中所列出的异常和其他 throwable。
getThrownTypes() - 接口 javax.lang.model.type.ExecutableType 中的方法
返回此 executable 的 throws 子句中列出的异常和其他 throwable。
getThumbBounds() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
返回 thumb 的当前大小/位置。
getThumbnail(int) - 类 javax.imageio.IIOImage 中的方法
返回与主图像关联的缩略图。
getThumbnailHeight(int, int) - 类 javax.imageio.ImageReader 中的方法
返回通过索引 thumbnailIndex 指定的缩略图预览图像的高度，其与通过索引 ImageIndex 指定的图像关联。
getThumbnails() - 类 javax.imageio.IIOImage 中的方法
返回缩略图 BufferedImage 的当前 List，如果没有设置任何缩略图，则返回 null。
getThumbnailWidth(int, int) - 类 javax.imageio.ImageReader 中的方法
返回通过索引 thumbnailIndex 指定的缩略图预览图像的宽度，其与通过索引 ImageIndex 指定的图像关联。
getThumbOverhang() - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
返回 thumb 在滑杆上滑过的量。
getThumbSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getThumbSize() - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法

getTick() - 类 javax.sound.midi.MidiEvent 中的方法
获得事件的用 MIDI 刻度表示的时间戳
getTickLength() - 类 javax.sound.midi.Sequence 中的方法
获得此 Sequence 的持续时间，用 MIDI 节拍数表示。
getTickLength() - 接口 javax.sound.midi.Sequencer 中的方法
获得当前 sequence 的长度，用 MIDI 节拍数表示，如果未设置 sequence，则为 0。
getTickLength() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
获取水平滑块的刻度区域的高度和垂直滑块的刻度区域的宽度。
getTickLength() - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
获取水平滑块的刻度区域高度和垂直滑块的刻度区域宽度。
getTickPosition() - 接口 javax.sound.midi.Sequencer 中的方法
获得 sequence 的当前位置，用 MIDI 节拍数表示。
getTie(Remote) - 类 javax.rmi.CORBA.Util 中的静态方法
返回给定目标对象的 tie（如果存在）。
getTie(Remote) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.getTie(java.rmi.Remote) 的委托调用。
getTile(int, int) - 类 java.awt.image.BufferedImage 中的方法
返回 tile (tileX, tileY)。
getTile(int, int) - 接口 java.awt.image.RenderedImage 中的方法
返回 tile (tileX, tileY)。
getTiledSizeRequirements(SizeRequirements[]) - 类 javax.swing.SizeRequirements 中的静态方法
确定端到端放置一组组件需要占用的总空间。
getTileGridXOffset() - 类 java.awt.image.BufferedImage 中的方法
返回 tile 网格相对于原点的 x 偏移量（例如，tile (0, 0) 位置的 x 坐标）。
getTileGridXOffset() - 接口 java.awt.image.RenderedImage 中的方法
返回 tile 网格相对于原点的 X 偏移量，即 tile (0, 0) 左上角像素的 X 坐标。
getTileGridXOffset(int) - 类 javax.imageio.ImageReader 中的方法
返回给定图像中 tile (0, 0) 的左上角的 X 坐标。
getTileGridXOffset() - 类 javax.imageio.ImageWriteParam 中的方法
返回图像的水平 tile 网格偏移量，将根据该偏移量对输出流进行写入。
getTileGridYOffset() - 类 java.awt.image.BufferedImage 中的方法
返回 tile 网格相对于原点的 y 偏移量（例如，tile (0, 0) 位置的 y 坐标）。
getTileGridYOffset() - 接口 java.awt.image.RenderedImage 中的方法
返回 tile 网格相对于原点的 Y 偏移量，即 tile (0, 0) 左上角像素的 Y 坐标。
getTileGridYOffset(int) - 类 javax.imageio.ImageReader 中的方法
返回给定图像中 tile (0, 0) 的左上角的 Y 坐标。
getTileGridYOffset() - 类 javax.imageio.ImageWriteParam 中的方法
返回图像的垂直 tile 网格偏移量，将根据该偏移量对输出流进行写入。
getTileHeight() - 类 java.awt.image.BufferedImage 中的方法
返回 tile 高度（以像素为单位）。
getTileHeight() - 接口 java.awt.image.RenderedImage 中的方法
返回 tile 的高度，以像素为单位。
getTileHeight(int) - 类 javax.imageio.ImageReader 中的方法
返回给定图像中 tile 的高度。
getTileHeight() - 类 javax.imageio.ImageWriteParam 中的方法
返回图像中每个 tile 的高度，将根据该高度对输出流进行写入。
getTileIcon() - 类 javax.swing.border.MatteBorder 中的方法
返回平铺边框的图标，如果使用了纯色，则返回 null。
getTileWidth() - 类 java.awt.image.BufferedImage 中的方法
返回 tile 宽度（以像素为单位）。
getTileWidth() - 接口 java.awt.image.RenderedImage 中的方法
返回 tile 的宽度，以像素为单位。
getTileWidth(int) - 类 javax.imageio.ImageReader 中的方法
返回给定图像中 tile 的宽度。
getTileWidth() - 类 javax.imageio.ImageWriteParam 中的方法
返回图像中每个 tile 的宽度，将根据该宽度对输出流进行写入。
getTilingMode() - 类 javax.imageio.ImageWriteParam 中的方法
如果支持平铺，则返回当前平铺模式。
getTime(int) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值。
getTime(int, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
getTime(String) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值。
getTime(String, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
getTime(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTime(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTime(int, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTime(String, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTime() - 类 java.sql.Timestamp 中的方法
返回此 Timestamp 对象表示的自 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数。
getTime() - 类 java.util.Calendar 中的方法
返回一个表示此 Calendar 时间值（从历元至现在的毫秒偏移量）的 Date 对象。
getTime() - 类 java.util.Date 中的方法
返回自 1970 年 1 月 1 日 00:00:00 GMT 以来此 Date 对象表示的毫秒数。
getTime() - 类 java.util.zip.ZipEntry 中的方法
返回条目的修改时间；如果未指定，则返回 -1。
getTimeDateFunctions() - 接口 java.sql.DatabaseMetaData 中的方法
获取可用于此数据库的时间和日期函数的逗号分隔列表。
getTimeInMillis() - 类 java.util.Calendar 中的方法
返回此 Calendar 的时间值，以毫秒为单位。
getTimeInMillis(Calendar) - 类 javax.xml.datatype.Duration 中的方法
返回以毫秒为单位的持续时间的长度。
getTimeInMillis(Date) - 类 javax.xml.datatype.Duration 中的方法
返回以毫秒为单位的持续时间的长度。
getTimeInstance() - 类 java.text.DateFormat 中的静态方法
获取时间格式器，该格式器具有默认语言环境的默认格式化风格。
getTimeInstance(int) - 类 java.text.DateFormat 中的静态方法
获取时间格式器，该格式器具有默认语言环境的给定格式化风格。
getTimeInstance(int, Locale) - 类 java.text.DateFormat 中的静态方法
获取时间格式器，该格式器具有给定语言环境的给定格式化风格。
getTimeInstance(int, Locale) - 类 java.text.spi.DateFormatProvider 中的方法
返回一个新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化时间。
getTimeLimit() - 类 javax.naming.directory.SearchControls 中的方法
检索这些 SearchControls 以毫秒为单位的时间限制。
getTimestamp() - 类 java.security.CodeSigner 中的方法
返回签名时间戳。
getTimestamp() - 类 java.security.Timestamp 中的方法
返回生成时间戳时的日期和时间。
getTimestamp(int) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值。
getTimestamp(int, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
getTimestamp(String) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值。
getTimestamp(String, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
getTimestamp(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTimestamp(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTimestamp(int, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTimestamp(String, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTimeStamp() - 类 javax.management.Notification 中的方法
获得通知时间戳。
getTimeStamp() - 接口 org.w3c.dom.events.Event 中的方法
用于指定创建事件的时间（与历元相关，以毫秒为单位）。
getTimeToLive() - 类 java.net.DatagramSocketImpl 中的方法
获取 TTL （生存时间）选项。
getTimeToLive() - 类 java.net.MulticastSocket 中的方法
获取在套接字上发出的多播数据包的默认生存时间。
getTimeToLive(String, Locale) - 类 java.util.ResourceBundle.Control 中的方法
返回在此 ResourceBundle.Control 下加载的资源包生存时间 (TTL) 值。
getTimeZone() - 类 java.text.DateFormat 中的方法
获取时区。
getTimeZone() - 类 java.util.Calendar 中的方法
获得时区。
getTimeZone() - 类 java.util.GregorianCalendar 中的方法

getTimeZone(String) - 类 java.util.TimeZone 中的静态方法
获取给定 ID 的 TimeZone。
getTimezone() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回以分为单位的时区偏移量，如果未定义此可选字段，则返回 DatatypeConstants.FIELD_UNDEFINED。
getTimeZone(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回此类的 java.util.TimeZone。
getTimezoneOffset() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 -(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000) 取代。
getTipText() - 类 javax.swing.JToolTip 中的方法
返回显示工具提示时所显示的文本。
getTitle() - 类 java.awt.Dialog 中的方法
获取 dialog 的标题。
getTitle() - 类 java.awt.Frame 中的方法
获得窗体的标题。
getTitle() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的标题。
getTitle() - 类 javax.swing.JInternalFrame 中的方法
返回 JInternalFrame 的标题。
getTitle(String, FontMetrics, int) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法

getTitleAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡标题。
getTitleColor() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的标题颜色。
getTitledBorderText() - 接口 javax.accessibility.AccessibleExtendedComponent 中的方法
返回有标题的边框文本
getTitledBorderText() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回加标题的边界文本
getTitledBorderText() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
返回有标题边界的文本
getTitledBorderText() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回有标题边框的文本
getTitleFont() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的标题字体。
getTitleJustification() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的标题对齐方式。
getTitlePosition() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的标题位置。
getToggleButtonBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getToggleButtonBorder() - 类 javax.swing.plaf.metal.MetalBorders 中的静态方法
返回一个用于 JToggleButton 的 border 实例
getToggleClickCount() - 类 javax.swing.JTree 中的方法
返回展开或关闭节点所需的鼠标单击数。
getToIndex() - 类 javax.swing.event.TableColumnModelEvent 中的方法
返回 toIndex。
getTokenThreshold() - 类 javax.swing.text.html.HTMLDocument 中的方法
获取在试图更新文档元素结构之前要缓冲的标记数。
getToolkit() - 类 java.awt.Component 中的方法
获取此组件的工具包。
getToolkit() - 类 java.awt.Window 中的方法
返回此窗体的工具包。
getToolTip() - 类 java.awt.TrayIcon 中的方法
返回与此 TrayIcon 关联的工具提示字符串。
getToolTipLocation(MouseEvent) - 类 javax.swing.JComponent 中的方法
返回工具提示在此组件坐标系统中的位置。
getToolTipText() - 接口 javax.accessibility.AccessibleExtendedComponent 中的方法
返回工具提示文本
getToolTipText() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回工具提示文本
getToolTipText() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
返回工具提示文本
getToolTipText() - 类 javax.swing.JComponent 中的方法
返回通过 setToolTipText 所设置的工具提示字符串。
getToolTipText(MouseEvent) - 类 javax.swing.JComponent 中的方法
返回用作 event 工具提示的字符串。
getToolTipText() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回工具提示文本
getToolTipText(MouseEvent) - 类 javax.swing.JList 中的方法
返回用于给定事件的工具提示文本。
getToolTipText(MouseEvent) - 类 javax.swing.JTabbedPane 中的方法
返回由鼠标事件位置确定的组件的工具提示文本。
getToolTipText(MouseEvent) - 类 javax.swing.JTable 中的方法
重写 JComponent 的 getToolTipText 方法，从而允许使用渲染器的提示（如果设置了文本）。
getToolTipText(MouseEvent) - 类 javax.swing.JTree 中的方法
重写 JComponent 的 getToolTipText 方法，以允许使用渲染器的提示（如果渲染器设置了文本）。
getToolTipText(JTextComponent, Point) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
返回在传入位置上用作工具提示的字符串。
getToolTipText(JTextComponent, Point) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getToolTipText 方法。
getToolTipText(JTextComponent, Point) - 类 javax.swing.plaf.TextUI 中的方法
返回在传入位置上用作工具提示的字符串。
getToolTipText(MouseEvent) - 类 javax.swing.table.JTableHeader 中的方法
如果设置了提示文本，则允许使用渲染器的提示。
getToolTipText(float, float, Shape) - 类 javax.swing.text.html.ImageView 中的方法
对于图像，工具提示文本来自于 ALT 属性指定的文本。
getToolTipText(MouseEvent) - 类 javax.swing.text.JTextComponent 中的方法
返回用作 event 的工具提示的字符串。
getToolTipText(float, float, Shape) - 类 javax.swing.text.View 中的方法
返回提定位置的工具提示文本。
getToolTipTextAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡工具提示文本。
getToPage() - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则返回要打印的最后一页（包括该页）。
getTopComponent() - 类 javax.swing.JSplitPane 中的方法
返回分隔条上面或者左边的组件。
getTopInset() - 类 javax.swing.text.AsyncBoxView 中的方法
获得视图四周顶部的空白部分。
getTopInset() - 类 javax.swing.text.CompositeView 中的方法
获取顶部 inset。
getTopLevelAncestor() - 类 javax.swing.JComponent 中的方法
返回此组件的顶层祖先（包含的 Window 或 Applet）；如果尚未将此组件添加到任意容器中，则返回 null。
getTotalColumnWidth() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回所有列的总宽度。
getTotalColumnWidth() - 接口 javax.swing.table.TableColumnModel 中的方法
返回所有列的总宽度。
getTotalCompilationTime() - 接口 java.lang.management.CompilationMXBean 中的方法
返回在编译上花费的累积耗费时间的近似值（以毫秒为单位）。
getTotalIn() - 类 java.util.zip.Deflater 中的方法
返回到目前为止输入未压缩字节的总数。
getTotalIn() - 类 java.util.zip.Inflater 中的方法
返回到目前为止输入压缩字节的总数。
getTotalLoadedClassCount() - 接口 java.lang.management.ClassLoadingMXBean 中的方法
返回自 Java 虚拟机开始执行到目前已经加载的类的总数。
getTotalOut() - 类 java.util.zip.Deflater 中的方法
返回到目前为止输出压缩字节的总数。
getTotalOut() - 类 java.util.zip.Inflater 中的方法
返回到目前为止输出未压缩字节的总数。
getTotalSize() - 接口 org.w3c.dom.ls.LSProgressEvent 中的方法
包括所有外部资源的文档的总大小，如果能看到对更多的外部资源的引用，则此数量可能在解析文档时而改变。
getTotalSpace() - 类 java.io.File 中的方法
返回此抽象路径名指定的分区大小。
getTotalStartedThreadCount() - 接口 java.lang.management.ThreadMXBean 中的方法
返回自从 Java 虚拟机启动以来创建和启动的线程总数目。
getTrackBounds() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
返回滑道的当前边界，即递增和递减按钮之间的空间（减去 insets）。
getTrackLength() - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
返回较长的滑杆尺寸。
getTrackMute(int) - 接口 javax.sound.midi.Sequencer 中的方法
获得轨道的当前静音状态。
getTracks() - 类 javax.sound.midi.Sequence 中的方法
获得包含此 Sequence 中所有轨道的数组。
getTrackSolo(int) - 接口 javax.sound.midi.Sequencer 中的方法
获得轨道的当前 solo 状态。
getTrackWidth() - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
返回较短的滑道尺寸。
getTrafficClass() - 类 java.net.DatagramSocket 中的方法
为从此 DatagramSocket 上发送的包获取 IP 数据报头中的流量类别或服务类型。
getTrafficClass() - 类 java.net.Socket 中的方法
为从此 Socket 上发送的包获取 IP 头中的流量类别或服务类型。
getTrailerField() - 类 java.security.spec.PSSParameterSpec 中的方法
返回尾部字段的值，即：PKCS#1 v2.1 中的 bc。
getTransactionIsolation() - 接口 java.sql.Connection 中的方法
获取此 Connection 对象的当前事务隔离级别。
getTransactionIsolation() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回此 RowSet 对象连接的事务隔离属性。
getTransactionIsolation() - 接口 javax.sql.RowSet 中的方法
获取为此 RowSet 对象设置的事务隔离级别。
getTransactionTimeout() - 接口 javax.transaction.xa.XAResource 中的方法
获取为此 XAResource 实例设置的当前事务超时值。
getTransferable() - 类 java.awt.dnd.DragSourceContext 中的方法
返回与此 DragSourceContext 关联的 Transferable。
getTransferable() - 类 java.awt.dnd.DropTargetContext 中的方法
获取此操作的 Transferable（代理）操作数
getTransferable() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回 Transferable 对象，该对象表示与当前的 drag 操作有关的数据。
getTransferable() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回与 drop 相关的 Transferable 对象。
getTransferable() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
返回与此传输关联的 Transferable。
getTransferData(DataFlavor) - 类 java.awt.datatransfer.StringSelection 中的方法
如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。
getTransferData(DataFlavor) - 接口 java.awt.datatransfer.Transferable 中的方法
返回一个对象，该对象表示将要被传输的数据。
getTransferData(DataFlavor) - 类 java.awt.dnd.DropTargetContext.TransferableProxy 中的方法
返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。
getTransferData(DataFlavor, DataSource) - 接口 javax.activation.DataContentHandler 中的方法
返回一个对象，该对象表示将要传输的数据。
getTransferData(DataFlavor) - 类 javax.activation.DataHandler 中的方法
返回一个对象，该对象表示要传输的数据。
getTransferDataFlavors() - 类 java.awt.datatransfer.StringSelection 中的方法
返回 flavor 的数组，Transferable 可用该 flavor 提供数据。
getTransferDataFlavors() - 接口 java.awt.datatransfer.Transferable 中的方法
返回 DataFlavor 对象的数组，指示可用于提供数据的 flavor。
getTransferDataFlavors() - 类 java.awt.dnd.DropTargetContext.TransferableProxy 中的方法
返回一个 DataFlavor 对象数组，指示该数据的 flavor 是否可由封装的 transferable 提供。
getTransferDataFlavors() - 接口 javax.activation.DataContentHandler 中的方法
返回一个 DataFlavor 对象数组，这些对象指示可用于提供数据的 flavor。
getTransferDataFlavors() - 类 javax.activation.DataHandler 中的方法
返回此数据在其中可用的 DataFlavor。
getTransferHandler() - 类 javax.swing.JApplet 中的方法
获取 transferHandler 属性。
getTransferHandler() - 类 javax.swing.JComponent 中的方法
获取 transferHandler 属性。
getTransferHandler() - 类 javax.swing.JDialog 中的方法
获取 transferHandler 属性。
getTransferHandler() - 类 javax.swing.JFrame 中的方法
获取 transferHandler 属性。
getTransferHandler() - 类 javax.swing.JWindow 中的方法
获取 transferHandler 属性。
getTransferSize() - 异常 java.sql.DataTruncation 中的方法
获得实际传输的数据字节数。
getTransferType() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 的转换类型。
getTransferType() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。
getTransferType() - 类 java.awt.image.Raster 中的方法
返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。
getTransferType() - 类 java.awt.image.SampleModel 中的方法
返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。
getTransform() - 类 java.awt.font.FontRenderContext 中的方法
获取用于在此 FontRenderContext 中将印刷点缩放为像素的转换。
getTransform() - 类 java.awt.Font 中的方法
返回与此 Font 相关的变换的副本。
getTransform() - 类 java.awt.font.TransformAttribute 中的方法
返回包装转换的一个副本。
getTransform() - 类 java.awt.Graphics2D 中的方法
返回 Graphics2D 上下文中当前 Transform 的副本。
getTransform() - 类 java.awt.image.AffineTransformOp 中的方法
返回此转换操作使用的仿射转换。
getTransform() - 类 java.awt.image.renderable.RenderContext 中的方法
获取当前“用户到设备”的 AffineTransform。
getTransform() - 类 java.awt.MultipleGradientPaint 中的方法
返回应用于渐变的变换的副本。
getTransformer() - 接口 javax.xml.transform.sax.TransformerHandler 中的方法
获取与此处理程序关联的 Transformer，用于设置参数和输出属性。
getTransforms() - 接口 javax.xml.crypto.dsig.keyinfo.RetrievalMethod 中的方法
返回一个不可修改的列表，由此 RetrievalMethod 的 Transform 组成。
getTransforms() - 接口 javax.xml.crypto.dsig.Reference 中的方法
返回一个 不可修改的列表，由包含在此 Reference 中的 Transform 组成。
getTransformType() - 类 java.awt.font.FontRenderContext 中的方法
返回此 FontRenderContext 的仿射转换的整数类型，该类型由 AffineTransform.getType() 指定。
getTranslateInstance(double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回表示平移变换的变换。
getTranslateX() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵平移元素 (m02) 的 X 坐标。
getTranslateY() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵平移元素 (m12) 的 Y 坐标。
getTransmitter() - 接口 javax.sound.midi.MidiDevice 中的方法
获得 MIDI 设备将从其传输 MIDI 数据的 MIDI OUT 连接。
getTransmitter() - 类 javax.sound.midi.MidiSystem 中的静态方法
从外部 MIDI 端口或其他默认源获得 MIDI 传输器。
getTransmitters() - 接口 javax.sound.midi.MidiDevice 中的方法
返回与该 MidiDevice 连接的所有当前活动的、非关闭的传输器。
getTransparency() - 类 java.awt.Color 中的方法
返回此 Color 的透明模式。
getTransparency() - 类 java.awt.GradientPaint 中的方法
返回此 GradientPaint 的透明度模式。
getTransparency() - 类 java.awt.image.BufferedImage 中的方法
返回透明度。
getTransparency() - 类 java.awt.image.ColorModel 中的方法
返回透明度。
getTransparency() - 类 java.awt.image.IndexColorModel 中的方法
返回透明度。
getTransparency() - 类 java.awt.image.VolatileImage 中的方法
返回透明度。
getTransparency() - 类 java.awt.MultipleGradientPaint 中的方法
返回此 Paint 对象的透明度模式。
getTransparency() - 类 java.awt.TexturePaint 中的方法
返回此 TexturePaint 的透明模式。
getTransparency() - 接口 java.awt.Transparency 中的方法
返回此 Transparency 的类型。
getTransparentPixel() - 类 java.awt.image.IndexColorModel 中的方法
返回此 IndexColorModel 中透明像素的索引；如果没有 alpha 值为 0 的像素，则返回 -1。
getTrayIcons() - 类 java.awt.SystemTray 中的方法
返回由此应用程序添加到托盘中的所有图标的数组。
getTrayIconSize() - 类 java.awt.SystemTray 中的方法
返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。
getTRC() - 类 java.awt.color.ICC_ProfileGray 中的方法
以 short 数组的形式返回 TRC。
getTRC(int) - 类 java.awt.color.ICC_ProfileRGB 中的方法
以数组形式返回特定分量的 TRC。
getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - 类 javax.swing.DefaultCellEditor 中的方法
实现 TreeCellEditor 接口。
getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
配置编辑器。
getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - 接口 javax.swing.tree.TreeCellEditor 中的方法
设置编辑器的初始值。
getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
配置基于传入组件的渲染器。
getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean) - 接口 javax.swing.tree.TreeCellRenderer 中的方法
将当前树单元格的值设置为 value。
getTreeComputerIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeControlIcon(boolean) - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeExpansionListeners() - 类 javax.swing.JTree 中的方法
返回使用 addTreeExpansionListener() 添加到此 JTree 的所有 TreeExpansionListener 的数组。
getTreeFloppyDriveIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeFolderIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeHardDriveIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeLeafIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeLock() - 类 java.awt.Component 中的方法
获取此组件用于 AWT 组件树和布局操作的锁定对象（拥有线程同步监视器的对象）。
getTreeLock() - 类 java.awt.MenuComponent 中的方法
获取此组件的锁定对象（拥有该线程同步监视器的对象），该对象可用于 AWT 组件树和布局操作。
getTreeModelListeners() - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回在此模型上注册的所有树模型侦听器组成的数组。
getTreePath() - 类 javax.swing.event.TreeModelEvent 中的方法
对于除 treeStructureChanged 以外的所有事件，返回已更改节点的父节点。
getTreeSelectionListeners() - 类 javax.swing.JTree 中的方法
返回使用 addTreeSelectionListener() 添加到此 JTree 的所有 TreeSelectionListener 的数组。
getTreeSelectionListeners() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回已在此模型上注册的所有树选择侦听器组成的数组。
getTreeWillExpandListeners() - 类 javax.swing.JTree 中的方法
返回使用 addTreeWillExpandListener() 添加到此 JTree 的所有 TreeWillExpandListener 的数组。
getTrigger() - 类 java.awt.dnd.DragSourceContext 中的方法
返回最初触发该拖动的 DragGestureEvent。
getTrigger() - 类 javax.management.monitor.MonitorNotification 中的方法
获取触发此监视器通知的阈值/字符串（取决于监视器类型）。
getTriggerEvent() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回触发动作的初始事件。
getTriggerEvent() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
此方法返回发起 Drag 和 Drop 操作的系列事件中的首个事件。
getTrustAnchor() - 类 java.security.cert.PKIXCertPathValidatorResult 中的方法
返回描述作为证书路径受信定位点的 CA 的 TrustAnchor。
getTrustAnchors() - 类 java.security.cert.PKIXParameters 中的方法
返回不可变的、最受信任的 CA Set。
getTrustedCert() - 类 java.security.cert.TrustAnchor 中的方法
返回最受信任的 CA 证书。
getTrustedCertificate() - 类 java.security.KeyStore.TrustedCertificateEntry 中的方法
从此项获取可信 Certficate。
getTrustManagers() - 类 javax.net.ssl.TrustManagerFactory 中的方法
为每种信任材料返回一个信任管理器。
getTTL() - 类 java.net.DatagramSocketImpl 中的方法
已过时。 使用 getTimeToLive 代替。
getTTL() - 类 java.net.MulticastSocket 中的方法
已过时。 使用 getTimeToLive 方法来代替，该方法返回 int（而不是 byte）。
getType() - 类 java.awt.color.ColorSpace 中的方法
返回此 ColorSpace 的颜色空间类型（例如 TYPE_RGB、TYPE_XYZ……）。
getType() - 类 java.awt.Cursor 中的方法
返回此光标的类型。
getType() - 类 java.awt.font.GlyphMetrics 中的方法
返回原始字形类型代码。
getType() - 类 java.awt.geom.AffineTransform 中的方法
检索描述此变换的变换属性的标志位。
getType() - 类 java.awt.GraphicsDevice 中的方法
返回此 GraphicsDevice 的类型。
getType() - 类 java.awt.image.BufferedImage 中的方法
返回图像类型。
getType() - 类 java.io.ObjectStreamField 中的方法
获取字段的类型。
getType(char) - 类 java.lang.Character 中的静态方法
返回一个指示字符的常规类别的值。
getType(int) - 类 java.lang.Character 中的静态方法
返回一个指示字符的常规类别的值。
getType() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回此内存池的类型。
getType() - 类 java.lang.reflect.Field 中的方法
返回一个 Class 对象，它标识了此 Field 对象所表示字段的声明类型。
getType() - 类 java.security.cert.Certificate 中的方法
返回此证书的类型。
getType() - 类 java.security.cert.CertificateFactory 中的方法
返回与此 CertificateFactory 关联的证书类型的名称。
getType() - 类 java.security.cert.CertPath 中的方法
返回此证书路径中的 Certificate 类型。
getType() - 类 java.security.cert.CertStore 中的方法
返回此 CertStore 的类型。
getType() - 类 java.security.cert.CRL 中的方法
返回此 CRL 的类型。
getType() - 类 java.security.KeyStore 中的方法
返回此 keystore 的类型。
getType() - 类 java.security.Policy 中的方法
返回此 Policy 的类型。
getType() - 类 java.security.Provider.Service 中的方法
获取此服务的类型。
getType() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的类型。
getType() - 接口 javax.accessibility.AccessibleTableModelChange 中的方法
返回事件的类型
getType() - 类 javax.management.MBeanAttributeInfo 中的方法
返回该属性的类名。
getType() - 类 javax.management.MBeanParameterInfo 中的方法
返回该数据的类型或类名。
getType() - 类 javax.management.Notification 中的方法
获得通知类型。
getType(String) - 类 javax.management.openmbean.CompositeType 中的方法
返回名称是 itemName 的项的开放类型，如果 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。
getType() - 类 javax.naming.event.NamingEvent 中的方法
返回此事件的类型。
getType() - 类 javax.naming.ldap.Rdn 中的方法
检索一个此 Rdn 的类型。
getType() - 类 javax.naming.RefAddr 中的方法
检索此地址的地址类型。
getType() - 类 javax.security.auth.login.Configuration 中的方法
返回此 Configuration 的类型。
getType() - 类 javax.sound.midi.MetaMessage 中的方法
获得 MetaMessage 的类型。
getType() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得 MIDI 文件类型。
getType() - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得音频文件类型，如 WAVE 或 AU。
getType() - 类 javax.sound.sampled.Control 中的方法
获得控件的类型。
getType() - 类 javax.sound.sampled.LineEvent 中的方法
获得事件的类型。
getType() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回此 RowSet 对象的类型。
getType() - 接口 javax.swing.event.DocumentEvent 中的方法
获得事件类型。
getType() - 类 javax.swing.event.ListDataEvent 中的方法
返回事件类型。
getType() - 类 javax.swing.event.RowSorterEvent 中的方法
返回事件的类型。
getType() - 类 javax.swing.event.TableModelEvent 中的方法
返回事件类型，该类型为以下类型之一：INSERT、UPDATE 和 DELETE。
getType() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的方法

getType() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
返回事件的类型。
getType() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得元素类型。
getType() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getType() - 类 javax.swing.text.html.parser.Element 中的方法
获取类型。
getType() - 类 javax.swing.text.html.parser.Entity 中的方法
获取实体的类型。
getType() - 接口 javax.xml.crypto.URIReference 中的方法
返回通过此 URI 引用的数据类型。
getType() - 接口 org.w3c.dom.DOMError 中的方法
DOMString，指示在 relatedData 中哪个相关数据是所期望的。
getType() - 接口 org.w3c.dom.events.Event 中的方法
事件的名称（不区分大小写）。
getType(int) - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回列表中属性的类型（根据位置）。
getType(String) - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回列表中属性的类型（根据名称）。
getType(int) - 接口 org.xml.sax.Attributes 中的方法
通过索引查找属性的类型。
getType(String, String) - 接口 org.xml.sax.Attributes 中的方法
根据名称空间的名称查找属性的类型。
getType(String) - 接口 org.xml.sax.Attributes 中的方法
通过 XML 限定（前缀）名查找属性的类型。
getType(int) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 获取属性的类型（按位置）。
getType(String) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 获取属性的类型（按名称）。
getType(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过索引返回属性的类型。
getType(String, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过限定名称空间的名称查找属性的类型。
getType(String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过限定（加前缀的）名称查找属性的类型。
getTypeArguments() - 接口 javax.lang.model.type.DeclaredType 中的方法
返回此类型的实际类型参数。
getTypeCode() - 类 java.io.ObjectStreamField 中的方法
返回字段类型的字符编码。
getTypeDescription(File) - 类 javax.swing.filechooser.FileView 中的方法
文件类型的可读描述。
getTypeDescription(File) - 类 javax.swing.JFileChooser 中的方法
返回文件类型。
getTypeDescription(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法

getTypeElement(CharSequence) - 接口 javax.lang.model.util.Elements 中的方法
返回已给出其规范名称的类型元素。
getTypeInfo() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库支持的所有数据类型的描述。
getTypeInfoProvider() - 类 javax.xml.validation.ValidatorHandler 中的方法
获取此 ValidatorHandler 的 TypeInfoProvider 实现。
getTypeMap() - 接口 java.sql.Connection 中的方法
获取与此 Connection 对象关联的 Map 对象。
getTypeMap() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取与此 RowSet 对象的 Connection 对象关联的类型映射表。
getTypeMap() - 接口 javax.sql.RowSet 中的方法
获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。
getTypeMirror() - 异常 javax.lang.model.type.MirroredTypeException 中的方法
返回对应于要访问类型的类型镜像。
getTypeMirrors() - 异常 javax.lang.model.type.MirroredTypesException 中的方法
返回对应于要访问的类型的类型镜像。
getTypeName() - 类 javax.management.openmbean.OpenType 中的方法
返回此 OpenType 实例的名称。
getTypeName() - 接口 org.w3c.dom.TypeInfo 中的方法
为相关元素或属性声明的类型的名称；如果未知，则为 null。
getTypeNamespace() - 接口 org.w3c.dom.TypeInfo 中的方法
为相关元素或属性声明的类型的名称空间；如果该元素没有声明或如果没有名称空间信息可用，则为 null。
getTypeParameters() - 类 java.lang.Class 中的方法
按声明顺序返回 TypeVariable 对象的一个数组，这些对象表示用此 GenericDeclaration 对象所表示的常规声明来声明的类型变量。
getTypeParameters() - 类 java.lang.reflect.Constructor 中的方法
按照声明顺序返回一组 TypeVariable 对象，这些对象表示通过此 GenericDeclaration 对象所表示的一般声明来声明的类型变量。
getTypeParameters() - 接口 java.lang.reflect.GenericDeclaration 中的方法
返回声明顺序的 TypeVariable 对象的数组，这些对象表示由此 GenericDeclaration 对象表示的一般声明声明的类型变量。
getTypeParameters() - 类 java.lang.reflect.Method 中的方法
返回 TypeVariable 对象的数组，这些对象描述了由 GenericDeclaration 对象表示的一般声明按声明顺序来声明的类型变量。
getTypeParameters() - 接口 javax.lang.model.element.ExecutableElement 中的方法
按照声明顺序返回此 executable 的形式类型参数。
getTypeParameters() - 接口 javax.lang.model.element.TypeElement 中的方法
按照声明顺序返回此类型元素的形式类型参数。
getTypeString() - 类 java.io.ObjectStreamField 中的方法
返回 JVM 类型签名。
getTypeUtils() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回用来在类型上进行操作的某些实用工具方法的实现。
getTypeVariables() - 接口 javax.lang.model.type.ExecutableType 中的方法
返回由此 executable 的形式类型参数所声明的类型变量。
getUDTs(String, String, String, int[]) - 接口 java.sql.DatabaseMetaData 中的方法
获取在特定模式中定义的用户定义类型 (UDT) 的描述。
getUI(int, String) - 类 javax.print.ServiceUIFactory 中的方法
获得一个 UI 对象，它可能被应用程序强制转换为所请求的 UI 类型并在该应用程序的用户界面中使用。
getUI() - 类 javax.swing.AbstractButton 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JColorChooser 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JComboBox 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JDesktopPane 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JFileChooser 中的方法
获得实现此组件 L&F 的 UI 对象。
getUI() - 类 javax.swing.JInternalFrame 中的方法
返回呈现此组件的外观对象。
getUI() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
返回呈现此组件的外观对象。
getUI() - 类 javax.swing.JLabel 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JList 中的方法
返回呈现此组件的外观对象 ListUI。
getUI() - 类 javax.swing.JMenuBar 中的方法
返回菜单栏的当前 UI。
getUI() - 类 javax.swing.JOptionPane 中的方法
返回实现此组件 L&F 的 UI 对象。
getUI() - 类 javax.swing.JPanel 中的方法
返回呈现此组件的外观 (L&F) 对象。
getUI() - 类 javax.swing.JPopupMenu 中的方法
返回用于呈现此组件的外观 (L&F) 对象。
getUI() - 类 javax.swing.JProgressBar 中的方法
返回呈现此组件的外观对象。
getUI() - 类 javax.swing.JRootPane 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JScrollBar 中的方法
返回实现此组件的外观的委托。
getUI() - 类 javax.swing.JScrollPane 中的方法
返回呈现此组件的外观 (L&F) 对象。
getUI() - 类 javax.swing.JSeparator 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JSlider 中的方法
获取实现此组件 L&F 的 UI 对象。
getUI() - 类 javax.swing.JSpinner 中的方法
返回呈现此组件的外观 (L&F) 对象。
getUI() - 类 javax.swing.JSplitPane 中的方法
返回提供当前外观的 SplitPaneUI。
getUI() - 类 javax.swing.JTabbedPane 中的方法
返回实现此组件的 L&F 的 UI 对象。
getUI() - 类 javax.swing.JTable 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JToolBar 中的方法
返回工具栏的当前 UI。
getUI() - 类 javax.swing.JToolTip 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JTree 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JViewport 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.table.JTableHeader 中的方法
返回渲染此组件的外观 (L&F) 对象。
getUI() - 类 javax.swing.text.JTextComponent 中的方法
获取此面向文本的编辑器的用户界面工厂。
getUI(JComponent) - 类 javax.swing.UIDefaults 中的方法
创建一个指定组件的 ComponentUI 实现。
getUI(JComponent) - 类 javax.swing.UIManager 中的静态方法
返回 target 的适当 ComponentUI 实现。
getUIActionMap(JComponent) - 类 javax.swing.SwingUtilities 中的静态方法
返回该 UI 在组件 component 中提供的 ActionMap。
getUIClass(String, ClassLoader) - 类 javax.swing.UIDefaults 中的方法
get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。
getUIClass(String) - 类 javax.swing.UIDefaults 中的方法
返回呈现此组件的 L&F 类。
getUIClassID() - 类 javax.swing.JButton 中的方法
返回指定呈现此组件的 L&F 类名的字符串。
getUIClassID() - 类 javax.swing.JCheckBox 中的方法
返回指定呈现此组件的 L&F 类名的字符串。
getUIClassID() - 类 javax.swing.JCheckBoxMenuItem 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JColorChooser 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JComboBox 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JComponent 中的方法
返回用于查找 wing.plaf.ComponentUI 类（定义了此组件的外观）名的 UIDefaults 键。
getUIClassID() - 类 javax.swing.JDesktopPane 中的方法
返回呈现此组件的 L&F 类名。
getUIClassID() - 类 javax.swing.JEditorPane 中的方法
获得该 UI 的类 ID。
getUIClassID() - 类 javax.swing.JFileChooser 中的方法
返回一个指示 L&F 类名的字符串，该类负责呈现此组件。
getUIClassID() - 类 javax.swing.JFormattedTextField 中的方法
获得 UI 的类 ID。
getUIClassID() - 类 javax.swing.JInternalFrame 中的方法
返回呈现此组件的外观类名。
getUIClassID() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
返回呈现此组件的外观类名。
getUIClassID() - 类 javax.swing.JLabel 中的方法
返回一个指定 L&F 类名称的字符串，该类呈现此组件。
getUIClassID() - 类 javax.swing.JList 中的方法
返回 "ListUI"，它是用于查找定义此组件外观的 javax.swing.plaf.ListUI 类名称的 UIDefaults 键。
getUIClassID() - 类 javax.swing.JMenu 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JMenuBar 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JMenuItem 中的方法
返回用于构造呈现此组件时使用的 L&F 类名称的后缀。
getUIClassID() - 类 javax.swing.JOptionPane 中的方法
返回实现此组件 L&F 的 UI 类的名称。
getUIClassID() - 类 javax.swing.JPanel 中的方法
返回指定呈现此组件的 L&F 类名的字符串。
getUIClassID() - 类 javax.swing.JPasswordField 中的方法
返回呈现此组件的 L&F 类名。
getUIClassID() - 类 javax.swing.JPopupMenu 中的方法
返回用于呈现此组件的 L&F 类名。
getUIClassID() - 类 javax.swing.JPopupMenu.Separator 中的方法
返回呈现此组件的 L&F 类名。
getUIClassID() - 类 javax.swing.JProgressBar 中的方法
返回呈现此组件的外观类的名称。
getUIClassID() - 类 javax.swing.JRadioButton 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JRadioButtonMenuItem 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JRootPane 中的方法
返回一个指定呈现此组件的 L&F 类名称的字符串。
getUIClassID() - 类 javax.swing.JScrollBar 中的方法
返回此组件的 LookAndFeel 类的名称。
getUIClassID() - 类 javax.swing.JScrollPane 中的方法
返回用于构造呈现此组件时所用 L&F 类的名称的后缀。
getUIClassID() - 类 javax.swing.JSeparator 中的方法
返回呈现此组件的 L&F 的类名。
getUIClassID() - 类 javax.swing.JSlider 中的方法
返回呈现此组件的 L&F 的类名。
getUIClassID() - 类 javax.swing.JSpinner 中的方法
返回用于构造呈现此组件外观 (L&F) 类的名称的后缀。
getUIClassID() - 类 javax.swing.JSplitPane 中的方法
返回呈现此组件的 L&F 类名。
getUIClassID() - 类 javax.swing.JTabbedPane 中的方法
返回实现此组件的 L&F 的 UI 类的名称。
getUIClassID() - 类 javax.swing.JTable 中的方法
返回用于构造呈现此组件时所用 L&F 类名称的后缀。
getUIClassID() - 类 javax.swing.JTextArea 中的方法
返回 UI 的类 ID。
getUIClassID() - 类 javax.swing.JTextField 中的方法
获取 UI 的类 ID。
getUIClassID() - 类 javax.swing.JTextPane 中的方法
返回 UI 的类 ID。
getUIClassID() - 类 javax.swing.JToggleButton 中的方法
返回指定了 l&f 类名称的字符串，其中 l&f 类呈现此组件。
getUIClassID() - 类 javax.swing.JToolBar 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JToolBar.Separator 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JToolTip 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JTree 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JViewport 中的方法
返回指定呈现此组件的 L&F 类名称的字符串。
getUIClassID() - 类 javax.swing.table.JTableHeader 中的方法
返回用于构造外观 (L&F) 类名称的后缀，该类用于渲染此组件。
getUIClassNamesForRole(int) - 类 javax.print.ServiceUIFactory 中的方法
给定从此工厂获取的 UI 角色，获取实现此角色的此工厂可提供的 UI 类型。
getUIError(String) - 类 javax.swing.UIDefaults 中的方法
如果由于某种原因导致 getUI() 失败，则它会在返回 null 之前调用此方法。
getUIInputMap(JComponent, int) - 类 javax.swing.SwingUtilities 中的静态方法
返回由组件 component 中的条件 condition 的 UI 提供的 InputMap。
getUIs() - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiListUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUncaughtExceptionHandler() - 类 java.lang.Thread 中的方法
返回该线程由于未捕获到异常而突然终止时调用的处理程序。
getUndeclaredThrowable() - 异常 java.lang.reflect.UndeclaredThrowableException 中的方法
返回此 UndeclaredThrowableException 中包装的 Throwable 实例，它可能为 null。
getUnderlineOffset() - 类 java.awt.font.LineMetrics 中的方法
返回下划线相对于基线的位置。
getUnderlineThickness() - 类 java.awt.font.LineMetrics 中的方法
返回下划线的宽度。
getUndoableEditListeners() - 类 javax.swing.text.AbstractDocument 中的方法
返回在此文档上注册的所有可撤消编辑侦听器的数组。
getUndoableEditListeners() - 类 javax.swing.undo.UndoableEditSupport 中的方法
返回使用 addUndoableEditListener() 添加到此 UndoableEditSupport 中的所有 UndoableEditListener 组成的数组。
getUndoOrRedoPresentationName() - 类 javax.swing.undo.UndoManager 中的方法
一个便捷方法，它返回 getUndoPresentationName 或 getRedoPresentationName。
getUndoPresentationName() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
提供此次编辑可撤消形式的、已本地化的、可读的描述，例如，用作 Undo 菜单项。
getUndoPresentationName() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
检索默认表中 AbstractUndoableEdit.undoText 键的值，并返回该值，后跟一个空格和 getPresentationName。
getUndoPresentationName() - 类 javax.swing.undo.CompoundEdit 中的方法
从添加到 edits 的最后 UndoableEdit 返回 getUndoPresentationName。
getUndoPresentationName() - 接口 javax.swing.undo.UndoableEdit 中的方法
返回此编辑可撤消形式的本地化可读描述，例如，适于用作 “Undo” 菜单项。
getUndoPresentationName() - 类 javax.swing.undo.UndoManager 中的方法
返回此编辑可撤消形式的描述。
getUnexecutedModifications() - 异常 javax.naming.directory.AttributeModificationException 中的方法
检索未执行修改的列表。
getUnicodeStream(int) - 接口 java.sql.ResultSet 中的方法
已过时。 使用 getCharacterStream 取代 getUnicodeStream
getUnicodeStream(String) - 接口 java.sql.ResultSet 中的方法
已过时。 使用 getCharacterStream 代替
getUnitIncrement() - 接口 java.awt.Adjustable 中的方法
获取可调整对象的单位值增量。
getUnitIncrement() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的单位增量。
getUnitIncrement() - 类 java.awt.ScrollPaneAdjustable 中的方法

getUnitIncrement(int) - 类 javax.swing.JScrollBar 中的方法
针对一个向上/向下滚动一个单位的请求，返回滚动条值的更改量。
getUnitIncrement() - 类 javax.swing.JScrollBar 中的方法
供与 java.awt.Scrollbar 向后兼容。
getUnitIncrement(int) - 类 javax.swing.JScrollPane.ScrollBar 中的方法
如果视口中的视图为 Scrollable 对象，将计算滚动的单位增量值。
getUnits() - 类 javax.sound.sampled.FloatControl 中的方法
获得表示控件值的单位标签，如 "dB" 或 "frames per second"。
getUnitsToScroll() - 类 java.awt.event.MouseWheelEvent 中的方法
这是帮助实现常用 MouseWheelListener 的便捷方法，以使 ScrollPane 或 JScrollPane 的滚动量符合平台的设置。
getUnknownAnnotationValue() - 异常 javax.lang.model.element.UnknownAnnotationValueException 中的方法
返回未知注释值。
getUnknownElement() - 异常 javax.lang.model.element.UnknownElementException 中的方法
返回未知元素。
getUnknownType() - 异常 javax.lang.model.type.UnknownTypeException 中的方法
返回未知类型。
getUnloadedClassCount() - 接口 java.lang.management.ClassLoadingMXBean 中的方法
返回自 Java 虚拟机开始执行到目前已经卸载的类的总数。
getUnmarshallerHandler() - 接口 javax.xml.bind.Unmarshaller 中的方法
获取可用作 XML 管线中的组件的 unmarshaller 处理程序对象。
getUnnormalizedComponents(float[], int, int[], int) - 类 java.awt.image.ColorModel 中的方法
在已给定标准化分量数组的情况下，返回以非标准化形式存在的所有颜色/alpha 分量的数组。
getUnnormalizedComponents(float[], int, int[], int) - 类 java.awt.image.ComponentColorModel 中的方法
在已给定标准化分量数组的情况下，返回以非标准化形式存在的所有颜色/alpha 分量的数组。
getUnresolvedActions() - 类 java.security.UnresolvedPermission 中的方法
获取尚未解析的基础权限的操作。
getUnresolvedCerts() - 类 java.security.UnresolvedPermission 中的方法
获取尚未解析的基础权限的签署者证书（无任何支持链）。
getUnresolvedName() - 类 java.security.UnresolvedPermission 中的方法
获取尚未解析的基础权限的目标名称。
getUnresolvedType() - 类 java.security.UnresolvedPermission 中的方法
获取尚未解析的基础权限的类型（类名称）。
getUnsupportedAttributes() - 接口 javax.print.AttributeException 中的方法
返回其 PrintService 实例根本不支持该属性的打印属性类数组，如果没有这种属性，则返回 null。
getUnsupportedAttributes(DocFlavor, AttributeSet) - 接口 javax.print.PrintService 中的方法
标识在特定 DocFlavor 的上下文中打印请求不支持的属性。
getUnsupportedFlavors() - 接口 javax.print.FlavorException 中的方法
返回不受支持的 flavor。
getUnsupportedURI() - 接口 javax.print.URIException 中的方法
返回 URI。
getUnsupportedValues() - 接口 javax.print.AttributeException 中的方法
返回其 PrintService 实例支持该属性，但是不支持该属性特定值的打印属性数组，如果没有这种属性值，则返回 null。
getUpdateAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getUpdateCount() - 接口 java.sql.Statement 中的方法
以更新计数的形式获取当前结果；如果结果为 ResultSet 对象或没有更多结果，则返回 -1。
getUpdateCounts() - 异常 java.sql.BatchUpdateException 中的方法
获取发生此异常前批量更新中成功执行的每个更新语句的更新计数。
getUpdateLevel() - 类 javax.swing.undo.UndoableEditSupport 中的方法
返回更新级别值。
getUpdatePeriod() - 类 javax.sound.sampled.FloatControl 中的方法
获得最小时间间隔（以微秒为单位），在此段时间内，控件值可以在移动期间更改。
getUpdatePolicy() - 类 javax.swing.text.DefaultCaret 中的方法
获取文档更新时的插入符移动策略。
getUpdateRect() - 类 java.awt.event.PaintEvent 中的方法
返回表示需要重绘区域以响应此事件的矩形。
getUpdateSelectionOnSort() - 类 javax.swing.JTable 中的方法
如果排序后应该更新选择，则返回 true。
getUpdateTableInRealTime() - 类 javax.swing.table.JTableHeader 中的方法
从 Java 2 platform v1.3 开始已过时。
getUpperBound() - 接口 javax.lang.model.type.TypeVariable 中的方法
返回此类型变量的上边界。
getUpperBounds() - 接口 java.lang.reflect.WildcardType 中的方法
返回表示此类型变量上边界的 Type 对象的数组。
getUptime() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机的正常运行时间（以毫秒为单位）。
getURI() - 类 java.security.URIParameter 中的方法
返回 URI。
getURI() - 类 javax.print.attribute.URISyntax 中的方法
返回此 URI 属性的 URI 值。
getURI() - 接口 javax.xml.crypto.dsig.keyinfo.RetrievalMethod 中的方法
返回已引用的 KeyInfo 信息的 URI。
getURI() - 类 javax.xml.crypto.OctetStreamData 中的方法
返回用来标识由此 OctetStreamData 表示的数据对象的 URI String。
getURI() - 接口 javax.xml.crypto.URIReference 中的方法
返回所引用数据对象的 URI。
getURI() - 接口 javax.xml.soap.Name 中的方法
返回此 Name 对象表示的 XML 名称命名空间的 URI。
getUri() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的 URI；如果没有可用的 URI，则为 null。
getURI(int) - 接口 org.xml.sax.Attributes 中的方法
通过索引查找属性的名称空间 URI。
getURI(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
返回属性的名称空间 URI。
getURI(String) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
查找前缀，并获取当前映射的名称空间 URI。
getURIDereferencer() - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法

getURIDereferencer() - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
返回对 URIDereferencer 的引用，默认情况下用于取消引用 RetrievalMethod 对象中的 URI。
getURIDereferencer() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
返回对 URIDereferencer 的引用，默认情况下该引用用于取消 Reference 对象中对 URI 的引用。
getURIDereferencer() - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回用来取消引用 URIReference 的 URIDereferencer。
getURIReference() - 异常 javax.xml.crypto.URIReferenceException 中的方法
返回抛出异常时正被取消引用的 URIReference。
getURIResolver() - 类 javax.xml.transform.Transformer 中的方法
获取将用于解析在 document() 中使用的 URI 的对象。
getURIResolver() - 类 javax.xml.transform.TransformerFactory 中的方法
获取在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。
getURIs() - 接口 java.net.CookieStore 中的方法
获取所有标识此 cookie 存储区中 cookie 的 URI。
getURL() - 类 java.net.URLConnection 中的方法
返回此 URLConnection 的 URL 字段的值。
getURL(int) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.URL 对象的形式获取指定 JDBC DATALINK 参数的值。
getURL(String) - 接口 java.sql.CallableStatement 中的方法
以 java.net.URL 对象的形式获取 JDBC DATALINK 参数的值。
getURL() - 接口 java.sql.DatabaseMetaData 中的方法
获取此 DBMS 的 URL。
getURL(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getURL(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getURL() - 类 javax.activation.URLDataSource 中的方法
返回用于创建此 DataSource 的 URL。
getUrl() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取此 RowSet 对象的 javax.sql.Reader 对象用来建立与关系数据库连接（使用启用 JDBC 技术的驱动程序）的 JDBC URL。
getUrl() - 接口 javax.sql.RowSet 中的方法
如果此 RowSet 对象使用 DriverManager 而非 DataSource 对象建立连接，则获取创建连接时将使用的 url 属性。
getURL() - 类 javax.swing.event.HyperlinkEvent 中的方法
获得链接引用的 URL。
getURL() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getURL() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回 URL 形式的 XML 源名称（如果可用）。
getURLContext(String, Hashtable<?, ?>) - 类 javax.naming.spi.NamingManager 中的静态方法
为给定的 URL 方案 id 创建一个上下文。
getURLOrDefaultInitCtx(String) - 类 javax.naming.InitialContext 中的方法
获取用来解析字符串名称 name 的上下文。
getURLOrDefaultInitCtx(Name) - 类 javax.naming.InitialContext 中的方法
获取用来解析 name 的上下文。
getURLPath() - 类 javax.management.remote.JMXServiceURL 中的方法
Service URL 的 URL Path 部分。
getURLs() - 类 java.net.URLClassLoader 中的方法
返回用于加载类和资源的 URL 搜索路径。
getURLs() - 类 javax.management.loading.MLet 中的方法
返回用于加载类和资源的 URL 搜索路径。
getURLs() - 接口 javax.management.loading.MLetMBean 中的方法
返回用于加载类和资源的 URL 搜索路径。
getUsableSpace() - 类 java.io.File 中的方法
返回此抽象路径名指定的分区上可用于此虚拟机的字节数。
getUsage() - 类 java.lang.management.MemoryNotificationInfo 中的方法
返回构造此通知时内存池的内存使用量。
getUsage() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回此内存池的内存使用量的估计数。
getUsage() - 接口 org.ietf.jgss.GSSCredential 中的方法
返回凭据使用模式。
getUsage(Oid) - 接口 org.ietf.jgss.GSSCredential 中的方法
返回特定机制的凭据使用模式。
getUsageThreshold() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回此内存池的使用量阈值（以字节为单位）。
getUsageThresholdCount() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回内存使用量超过其阈值的次数。
getUseCache() - 类 javax.imageio.ImageIO 中的静态方法
返回由 setUseCache 设置的当前值；如果没有显式设置该值，则返回 true。
getUseCaches() - 类 java.net.URLConnection 中的方法
返回此 URLConnection 的 useCaches 字段的值。
getUseClientMode() - 类 javax.net.ssl.SSLEngine 中的方法
如果引擎设置为在握手时使用客户端模式，则返回 true。
getUseClientMode() - 类 javax.net.ssl.SSLServerSocket 中的方法
如果接受的连接处于 SSL 客户端模式，则返回 true。
getUseClientMode() - 类 javax.net.ssl.SSLSocket 中的方法
如果套接字设置为握手时使用客户机模式，则返回 true。
getUsed() - 类 java.lang.management.MemoryUsage 中的方法
返回已使用的内存量（以字节为单位）。
getUseParentHandlers() - 类 java.util.logging.Logger 中的方法
获知此 logger 是否将其输出发送到它的父 logger。
getUserAction() - 类 java.awt.dnd.DragSourceDragEvent 中的方法
此方法返回用户放置动作。
getUserData(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getUserData() - 类 javax.management.Notification 中的方法
获得用户数据。
getUserData(String) - 接口 org.w3c.dom.Node 中的方法
检索与此节点上的某个键相关联的对象。
getUserDropAction() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
当此 TransferSupport 表示一个放置操作时，返回其用户放置动作。
getUserInfo() - 类 java.net.URI 中的方法
返回此 URI 的已解码的用户信息组成部分。
getUserInfo() - 类 java.net.URL 中的方法
获取此 URL 的 userInfo 部分。
getUserName() - 类 java.awt.print.PrinterJob 中的方法
获取打印用户的名称。
getUserName() - 类 java.net.PasswordAuthentication 中的方法
返回用户名。
getUserName() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库的已知的用户名称。
getUsername() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回用于创建数据库连接的用户名。
getUsername() - 接口 javax.sql.RowSet 中的方法
获取用于创建此 RowSet 对象的数据库连接的用户名。
getUserObject() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回与此节点关联的 Object 值。
getUserObject() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的用户对象。
getUserObjectPath() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回从根到达此节点的路径。
getUserPrincipal() - 接口 javax.xml.ws.WebServiceContext 中的方法
返回标识当前正服务请求发送方的 Principal。
getUserTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的用户文本颜色。
getUserTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回用户文本颜色。
getUserTextFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回用户文本字体。
getUserTextFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的用户文本字体。
getUserTextFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回用户文本字体。
getUtf16Offset() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的输入源中的 UTF-16 偏移量（如在 [Unicode] 和 [ISO/IEC 10646] 的 Amendment 1 中定义的那样）；如果不存在可用的 UTF-16 偏移量，则为 -1。
getVAdjustable() - 类 java.awt.ScrollPane 中的方法
返回表示垂直滚动条状态的 ScrollPaneAdjustable 对象。
getValidCharacters() - 类 javax.swing.text.MaskFormatter 中的方法
返回可以输入的有效字符。
getValidPixels() - 类 java.awt.image.IndexColorModel 中的方法
返回一个指示 colormap 中有效/无效像素的 BigInteger。
getValidPolicy() - 接口 java.security.cert.PolicyNode 中的方法
返回此节点所表示的有效策略。
getValue() - 接口 java.awt.Adjustable 中的方法
获取可调整对象的当前值。
getValue() - 类 java.awt.event.AdjustmentEvent 中的方法
返回调整事件中的当前值。
getValue() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的当前值。
getValue() - 类 java.awt.ScrollPaneAdjustable 中的方法

getValue() - 类 java.beans.Expression 中的方法
如果此实例的 value 属性尚未设置，则此方法利用这些参数，在此目标上动态查找具有指定 methodName 的方法，并调用该方法。
getValue(String) - 类 java.beans.FeatureDescriptor 中的方法
利用此特性检索指定属性。
getValue() - 接口 java.beans.PropertyEditor 中的方法
获取属性值。
getValue() - 类 java.beans.PropertyEditorSupport 中的方法
获得属性值。
getValue() - 类 java.net.HttpCookie 中的方法
返回 cookie 的值。
getValue() - 类 java.rmi.dgc.Lease 中的方法
返回租借期限。
getValue() - 类 java.text.Annotation 中的方法
返回属性值，可能为 null。
getValue() - 类 java.util.AbstractMap.SimpleEntry 中的方法
返回对应于此项的值。
getValue() - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
返回对应于此项的值。
getValue(String) - 类 java.util.jar.Attributes 中的方法
返回指定属性名称的值，如果未找到，则返回 null。
getValue(Attributes.Name) - 类 java.util.jar.Attributes 中的方法
返回指定的 Attributes.Name 的值，如果未找到，则返回 null。
getValue() - 接口 java.util.Map.Entry 中的方法
返回与此项对应的值。
getValue() - 类 java.util.zip.Adler32 中的方法
返回校验和值。
getValue() - 接口 java.util.zip.Checksum 中的方法
返回当前的校验和值。
getValue() - 类 java.util.zip.CRC32 中的方法
返回 CRC-32 值。
getValue() - 接口 javax.annotation.processing.Completion 中的方法
返回建议 completion 的文本。
getValue() - 类 javax.crypto.spec.PSource.PSpecified 中的方法
返回编码输入 P 的值。
getValue() - 接口 javax.lang.model.element.AnnotationValue 中的方法
返回值。
getValue() - 类 javax.management.Attribute 中的方法
返回此 Attribute 值的 Object。
getValue() - 类 javax.management.StringValueExp 中的方法
返回由 StringValueExp 实例表示的字符串。
getValue() - 类 javax.naming.ldap.Rdn 中的方法
检索一个此 Rdn 的值。
getValue(String) - 接口 javax.net.ssl.SSLSession 中的方法
返回会话的应用层数据中的绑定到给定名称的对象。
getValue() - 类 javax.print.attribute.DateTimeSyntax 中的方法
返回此日期-时间属性的 java.util.Date 值。
getValue() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的整数值。
getValue() - 类 javax.print.attribute.IntegerSyntax 中的方法
返回此整数属性的整数值。
getValue() - 类 javax.print.attribute.TextSyntax 中的方法
返回此文本属性的文本字符串。
getValue() - 类 javax.sound.sampled.BooleanControl 中的方法
获得此控件的当前值。
getValue() - 类 javax.sound.sampled.EnumControl 中的方法
获得此控件的当前值。
getValue() - 类 javax.sound.sampled.FloatControl 中的方法
获得此控件的当前值。
getValue(String) - 类 javax.swing.AbstractAction 中的方法
获得与指定键关联的 Object。
getValue(String) - 接口 javax.swing.Action 中的方法
使用关联的键获取此对象的一个属性。
getValue() - 接口 javax.swing.BoundedRangeModel 中的方法
返回模型的当前值。
getValue() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回模型的当前值。
getValue() - 类 javax.swing.JFormattedTextField 中的方法
返回最后一个有效值。
getValue() - 类 javax.swing.JOptionPane 中的方法
返回用户所选值。
getValue() - 类 javax.swing.JProgressBar 中的方法
从 BoundedRangeModel 返回进度条的当前 value。
getValue() - 类 javax.swing.JScrollBar 中的方法
返回滚动条的值。
getValue() - 类 javax.swing.JSlider 中的方法
从 BoundedRangeModel 返回滑块的当前值。
getValue() - 类 javax.swing.JSpinner 中的方法
返回模型的当前值，通常此值是 editor 所显示的值。
getValue(int) - 类 javax.swing.RowFilter.Entry 中的方法
返回指定索引处的值。
getValue() - 类 javax.swing.SpinnerDateModel 中的方法
返回此 Date 序列中的当前元素。
getValue() - 类 javax.swing.SpinnerListModel 中的方法
返回该序列的当前元素。
getValue() - 接口 javax.swing.SpinnerModel 中的方法
该序列的当前元素。
getValue() - 类 javax.swing.SpinnerNumberModel 中的方法
返回该序列的当前元素的值。
getValue() - 类 javax.swing.Spring 中的方法
返回此 Spring 的当前 value。
getValue() - 类 javax.swing.text.html.Option 中的方法
返回与 value 属性相关的字符串的便捷方法。
getValue() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getValue() - 类 javax.xml.bind.JAXBElement 中的方法
返回此元素的内容模式和属性值。
getValue(Object) - 类 javax.xml.bind.JAXBIntrospector 中的静态方法
获取 JAXB 元素的元素值。
getValue() - 接口 javax.xml.crypto.dsig.XMLSignature.SignatureValue 中的方法
返回此 SignatureValue 的签名值。
getValue() - 类 javax.xml.soap.MimeHeader 中的方法
返回此 MimeHeader 对象的值。
getValue() - 接口 javax.xml.soap.Node 中的方法
如果这是一个 Text 节点，则返回此节点的值，否则返回此节点的直接子节点值。
getValue() - 接口 javax.xml.stream.events.Attribute 中的方法
获取此属性的标准化值。
getValue() - 接口 org.w3c.dom.Attr 中的方法
检索时，该属性值以字符串形式返回。
getValue(int) - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回列表中属性的值（根据位置）。
getValue(String) - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回列表中属性的值（根据名称）。
getValue(int) - 接口 org.xml.sax.Attributes 中的方法
通过索引查找属性的值。
getValue(String, String) - 接口 org.xml.sax.Attributes 中的方法
根据名称空间的名称查找属性的值。
getValue(String) - 接口 org.xml.sax.Attributes 中的方法
通过 XML 限定（前缀）名查找属性的值。
getValue(int) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 获取属性的值（按位置）。
getValue(String) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 获取属性的值（按名称）。
getValue(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过索引返回属性的值。
getValue(String, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过限定名称空间的名称查找属性的值。
getValue(String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过限定（加前缀的）名称查找属性的值。
getValueAt(int, int) - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
返回指定索引处的值。
getValueAt(int, int) - 类 javax.swing.JTable 中的方法
返回 row 和 column 位置的单元格值。
getValueAt(int, int) - 类 javax.swing.table.DefaultTableModel 中的方法
返回 row 和 column 处单元格的属性值。
getValueAt(int, int) - 接口 javax.swing.table.TableModel 中的方法
返回 columnIndex 和 rowIndex 位置的单元格值。
getValueClass() - 类 javax.swing.text.DefaultFormatter 中的方法
返回用于创建新 Objects 的类。
getValueContainsLiteralCharacters() - 类 javax.swing.text.MaskFormatter 中的方法
如果 stringToValue 应该返回掩码中的字面值，则返回 true。
getValueCount() - 类 javax.swing.RowFilter.Entry 中的方法
返回条目中值的数量。
getValueIsAdjusting() - 类 java.awt.event.AdjustmentEvent 中的方法
如果此事件是多个调整事件之一，则返回 true。
getValueIsAdjusting() - 类 java.awt.Scrollbar 中的方法
如果该值作为用户执行动作的结果正处于更改过程中，则返回 true。
getValueIsAdjusting() - 类 java.awt.ScrollPaneAdjustable 中的方法
当作为用户所采用操作的结果的值正处于更改过程中时，返回 true。
getValueIsAdjusting() - 接口 javax.swing.BoundedRangeModel 中的方法
如果 value 属性的当前更改是一系列更改的一部分，则返回 true。
getValueIsAdjusting() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
如果该值由于用户正执行操作而处于更改过程中，则返回 true。
getValueIsAdjusting() - 类 javax.swing.DefaultListSelectionModel 中的方法
如果选择在进行一系列更改，则返回 true。
getValueIsAdjusting() - 类 javax.swing.event.ListSelectionEvent 中的方法
返回此事件是否是仍然在更改的多个不同事件之一。
getValueIsAdjusting() - 类 javax.swing.JList 中的方法
返回选择模型的 isAdjusting 属性的值。
getValueIsAdjusting() - 类 javax.swing.JScrollBar 中的方法
如果滚动条滑块被拖动，则返回 True。
getValueIsAdjusting() - 类 javax.swing.JSlider 中的方法
从模型返回 valueIsAdjusting 属性。
getValueIsAdjusting() - 接口 javax.swing.ListSelectionModel 中的方法
如果选择在进行一系列更改，则返回 true。
getValueNames() - 接口 javax.net.ssl.SSLSession 中的方法
返回绑定到会话中的所有应用层数据对象的名称组成的数组。
getValues() - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的方法
返回 short 数组，该数组包含按其相应代码的长度递增排序的值。
getValues() - 类 javax.sound.sampled.EnumControl 中的方法
返回此控件的可能值的集合。
getValues() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getVariant() - 类 java.util.Locale 中的方法
返回此语言环境的变量代码。
getVariation() - 类 java.awt.im.InputMethodHighlight 中的方法
返回文本范围的变量。
getVendor() - 类 javax.sound.midi.MidiDevice.Info 中的方法
获得提供设备的公司名称。
getVendor() - 接口 javax.sound.midi.Soundbank 中的方法
获得命名提供此音库的公司的 string
getVendor() - 类 javax.sound.sampled.Mixer.Info 中的方法
获得混频器的供应商。
getVendor() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回此 SyncProvider 实例的供应商名称
getVendorName() - 类 javax.imageio.spi.IIOServiceProvider 中的方法
返回负责创建此服务提供者及其相关实现的供应商名称。
getVerifyInputWhenFocusTarget() - 类 javax.swing.JComponent 中的方法
返回值指示是否在此组件请求焦点前，为当前的焦点所有者调用输入校验器。
getVersion() - 接口 java.awt.font.OpenType 中的方法
返回 OpenType 字体的版本。
getVersion() - 接口 java.lang.management.OperatingSystemMXBean 中的方法
返回操作系统的版本。
getVersion() - 类 java.net.HttpCookie 中的方法
返回此 cookie 遵守的协议版本。
getVersion() - 类 java.security.cert.X509Certificate 中的方法
获取证书的 version（版本号）值。
getVersion() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 的 version（版本号）值。
getVersion() - 类 java.security.Provider 中的方法
返回此 provider 的版本号。
getVersion() - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
返回版本。
getVersion() - 类 javax.imageio.spi.IIOServiceProvider 中的方法
返回描述此服务提供者版本号及其相关实现的字符串。
getVersion() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记的 VERSION 属性的值。
getVersion() - 接口 javax.management.remote.rmi.RMIServer 中的方法
此连接器服务器能识别的 RMI 连接协议版本。
getVersion() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法

getVersion() - 类 javax.management.remote.rmi.RMIServerImpl_Stub 中的方法

getVersion() - 类 javax.security.cert.X509Certificate 中的方法
获取证书的 version（版本号）值。
getVersion() - 类 javax.sound.midi.MidiDevice.Info 中的方法
获得设备的版本。
getVersion() - 接口 javax.sound.midi.Soundbank 中的方法
获得音库的版本字符串。
getVersion() - 类 javax.sound.sampled.Mixer.Info 中的方法
获得混频器的版本。
getVersion() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回此 SyncProvider 实例的发行版本。
getVersion() - 接口 javax.xml.stream.events.StartDocument 中的方法
返回此 XML 流的 XML 版本
getVersion() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getVersion() - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取在 xml 声明中声明的 xml 版本，如果没有声明版本，则返回 null
getVersionColumns(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取在更新行中的任意值时自动更新的表列的描述。
getVersionNumber() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回密钥版本号。
getVerticalAlignment() - 类 javax.swing.AbstractButton 中的方法
返回文本和图标的垂直对齐方式。
getVerticalAlignment() - 类 javax.swing.JLabel 中的方法
返回标签内容沿 Y 轴的对齐方式。
getVerticalLegBuffer() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
默认情况下，节点间支路的垂直元素开始于父节点的底部。
getVerticalScrollBar() - 类 javax.swing.JScrollPane 中的方法
返回控制视口垂直视图位置的垂直滚动条。
getVerticalScrollBar() - 类 javax.swing.ScrollPaneLayout 中的方法
返回处理垂直滚动的 JScrollBar 对象。
getVerticalScrollBarPolicy() - 类 javax.swing.JScrollPane 中的方法
返回垂直滚动条策略值。
getVerticalScrollBarPolicy() - 类 javax.swing.ScrollPaneLayout 中的方法
返回垂直滚动条的显示策略。
getVerticalSliderThumbIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getVerticalTextPosition() - 类 javax.swing.AbstractButton 中的方法
返回文本相对于图标的垂直位置。
getVerticalTextPosition() - 类 javax.swing.JLabel 中的方法
返回标签的文本相对其图像的垂直位置。
getVetoableChangeListeners() - 类 java.awt.KeyboardFocusManager 中的方法
返回在此键盘焦点管理器上注册的所有可否决更改侦听器组成的数组。
getVetoableChangeListeners(String) - 类 java.awt.KeyboardFocusManager 中的方法
返回与指定属性相关联的所有 VetoableChangeListener 组成的数组。
getVetoableChangeListeners() - 类 java.beans.VetoableChangeSupport 中的方法
返回 VetoableChangeListener 的列表。
getVetoableChangeListeners(String) - 类 java.beans.VetoableChangeSupport 中的方法
返回与指定属性相关联的所有侦听器组成的数组。
getVetoableChangeListeners() - 类 javax.swing.JComponent 中的方法
返回在此组件上注册的所有可否决更改侦听器所组成的数组。
getVgap() - 类 java.awt.BorderLayout 中的方法
返回组件之间的垂直间距。
getVgap() - 类 java.awt.CardLayout 中的方法
获取组件之间的垂直间距。
getVgap() - 类 java.awt.FlowLayout 中的方法
获取组件之间以及组件与 Container 的边之间的垂直间隙。
getVgap() - 类 java.awt.GridLayout 中的方法
获取组件之间的垂直间距。
getView() - 类 javax.swing.JViewport 中的方法
返回 JViewport 的一个子对象或 null。
getView(int) - 类 javax.swing.text.AsyncBoxView 中的方法
获得第 n 个子视图。
getView(int) - 类 javax.swing.text.CompositeView 中的方法
返回该容器中的第 n 个视图。
getView(int) - 类 javax.swing.text.View 中的方法
获取第 n 个子视图。
getView() - 接口 org.w3c.dom.events.UIEvent 中的方法
view 属性标识生成事件的 AbstractView。
getViewAtPoint(int, int, Rectangle) - 类 javax.swing.text.BoxView 中的方法
获取给定坐标处的子视图。
getViewAtPoint(int, int, Rectangle) - 类 javax.swing.text.CompositeView 中的方法
获取位于给定坐标的子视图。
getViewAtPosition(int, Rectangle) - 类 javax.swing.text.CompositeView 中的方法
获取表示模型中给定位置的子视图。
getViewAtPosition(int, Rectangle) - 类 javax.swing.text.TableView 中的方法
获取表示模型中给定位置的子视图。
getViewAtPosition(int, Rectangle) - 类 javax.swing.text.TableView.TableRow 中的方法
获取表示模型中给定位置的子视图。
getViewAttributes(View) - 类 javax.swing.text.html.StyleSheet 中的方法
获取用来显示视图的属性集。
getViewCount() - 类 javax.swing.text.AsyncBoxView 中的方法
返回此视图中的视图数。
getViewCount() - 类 javax.swing.text.CompositeView 中的方法
返回此视图的子视图数。
getViewCount() - 类 javax.swing.text.View 中的方法
返回此视图中的视图数。
getViewFactory() - 类 javax.swing.text.DefaultEditorKit 中的方法
获取一个适合供由此包所产生的任何模型来产生视图的工厂。
getViewFactory() - 类 javax.swing.text.EditorKit 中的方法
获取适合生成此工具包生成的任何模型视图的工厂。
getViewFactory() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取一个适合供由此包所产生的任何模型来产生视图的工厂。
getViewFactory() - 类 javax.swing.text.StyledEditorKit 中的方法
获取一个适合供由此包所产生的任何模型来产生视图的工厂。
getViewFactory() - 类 javax.swing.text.View 中的方法
获取将提供给视图层次结构的 ViewFactory 实现。
getViewIndex(int, Position.Bias) - 类 javax.swing.text.AsyncBoxView 中的方法
返回该模型中表示给定位置的子视图索引。
getViewIndex(int, Position.Bias) - 类 javax.swing.text.CompositeView 中的方法
返回表示模型中给定位置的子视图索引。
getViewIndex(int, Position.Bias) - 类 javax.swing.text.View 中的方法
返回表示模型中给定位置的子视图索引。
getViewIndex(float, float, Shape) - 类 javax.swing.text.View 中的方法
返回表示视图中给定位置的子视图索引。
getViewIndexAtPoint(float, float, Shape) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
获取位于给定点的子视图索引。
getViewIndexAtPosition(int, Position.Bias) - 类 javax.swing.text.AsyncBoxView 中的方法
获取此模型中表示给定位置的子视图索引。
getViewIndexAtPosition(int) - 类 javax.swing.text.CompositeView 中的方法
获取表示模型中给定位置的子视图索引。
getViewIndexAtPosition(int) - 类 javax.swing.text.FlowView 中的方法
获取此模型中表示给定位置的子视图索引。
getViewIndexAtPosition(int) - 类 javax.swing.text.ZoneView 中的方法
返回表示模型中给定位置的子视图索引。
getViewIndexAtVisualOffset(float) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
查找负责表示沿主轴方向框中偏移量位置的视图。
getViewport() - 类 javax.swing.JScrollPane 中的方法
返回当前的 JViewport。
getViewport() - 类 javax.swing.ScrollPaneLayout 中的方法
返回显示滚动组件内容的 JViewport 对象。
getViewportBorder() - 类 javax.swing.JScrollPane 中的方法
返回围绕该视口的 Border 对象。
getViewportBorderBounds() - 类 javax.swing.JScrollPane 中的方法
返回视口边界的范围。
getViewportBorderBounds(JScrollPane) - 类 javax.swing.ScrollPaneLayout 中的方法
已过时。 从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。
getViewportSize() - 类 java.awt.ScrollPane 中的方法
返回滚动条窗格视口的当前大小。
getViewPosition() - 类 javax.swing.JViewport 中的方法
返回显示在视口左上角的视图坐标，如果不存在视图，则返回（0,0）。
getViewRect() - 类 javax.swing.JViewport 中的方法
返回一个矩形，其原位置在 getViewPosition，大小为 getExtentSize。
getViewRowCount() - 类 javax.swing.DefaultRowSorter 中的方法
返回视图中的行数。
getViewRowCount() - 类 javax.swing.RowSorter 中的方法
返回视图中的行数。
getViewSize() - 类 javax.swing.JViewport 中的方法
如果未显式设置视图的大小，则返回首选大小，否则返回该视图的当前大小。
getVisible() - 类 java.awt.Scrollbar 中的方法
已过时。 从 JDK version 1.1 开始，由 getVisibleAmount() 取代。
getVisibleAdvance() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的 advance，减去结尾空格。
getVisibleAmount() - 接口 java.awt.Adjustable 中的方法
获取比例指示器的长度。
getVisibleAmount() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的可见量。
getVisibleAmount() - 类 java.awt.ScrollPaneAdjustable 中的方法

getVisibleAmount() - 类 javax.swing.JScrollBar 中的方法
返回滚动条的跨度，即它的 "visibleAmount"。
getVisibleChildCount(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回行的可视子节点数。
getVisibleChildCount(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回行的可见子对象数。
getVisibleChildCount(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回 path 的可见子路径数。
getVisibleComponent() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getVisibleEditorRect() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取给出根 View 的分配。
getVisibleIndex() - 类 java.awt.List 中的方法
获取上次由 makeVisible 方法使其可视的项的索引。
getVisibleNamespacePrefixes() - 接口 javax.xml.soap.SOAPElement 中的方法
返回在此元素可见的名称空间前缀 String 上进行迭代的 Iterator。
getVisiblePathsFrom(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回一个 Enumerator，它列举从传入位置开始的可视路径的增量。
getVisiblePathsFrom(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回表示从传入位置开始的可见路径的增量的 Enumerator。
getVisiblePathsFrom(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回从传入位置开始的可见路径的增量的 Enumerator。
getVisiblePosition() - 类 java.awt.event.InputMethodEvent 中的方法
获取对于可见性至关重要的位置。
getVisibleRect() - 类 javax.swing.JComponent 中的方法
返回该 Component 的“可见矩形”，即此组件的可见矩形 new Rectangle(0, 0, getWidth(), getHeight()) 及其所有祖先的可见矩形的交集。
getVisibleRowCount() - 类 javax.swing.JList 中的方法
返回 visibleRowCount 属性的值。
getVisibleRowCount() - 类 javax.swing.JTree 中的方法
返回显示区域中显示的行数。
getVisualBounds() - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 的可视边界，可视边界是此 GlyphVector 轮廓的边界框。
getVisualHighlightShape(TextHitInfo, TextHitInfo, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回封闭指定范围中扩展到 bounds 的可视选择范围的路径。
getVisualHighlightShape(TextHitInfo, TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回封闭指定范围中扩展到指定边界的可视选择范围的 Shape。
getVisualOtherHit(TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回位于指定目标字符插入符另一侧的目标字符。
getVisualRepresentation(Transferable) - 类 javax.swing.TransferHandler 中的方法
返回一个建立传输外观的对象。
getVMID() - 类 java.rmi.dgc.Lease 中的方法
返回与此 lease 关联的客户机 VMID。
getVmName() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机实现名称。
getVmVendor() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机实现供应商。
getVmVersion() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机实现版本。
getVoiceStatus() - 接口 javax.sound.midi.Synthesizer 中的方法
获得由此合成器生成的声音的当前状态。
getVolatileOffscreenBuffer(Component, int, int) - 类 javax.swing.RepaintManager 中的方法
返回可变屏幕外缓冲区，它应用作带有指定组件 c 的双缓冲区。
getVScrollbarWidth() - 类 java.awt.ScrollPane 中的方法
返回垂直滚动条占用的宽度，它与当前是否由滚动窗格显示无关。
getW() - 接口 java.security.interfaces.ECPublicKey 中的方法
返回公用点 W。
getW() - 类 java.security.spec.ECPublicKeySpec 中的方法
返回公用点 W。
getWaitedCount() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程等待通知的总次数。
getWaitedTime() - 类 java.lang.management.ThreadInfo 中的方法
返回自从启用线程争用监视以来,与此 ThreadInfo 关联的线程等待通知的近似累计时间（以毫秒为单位）。
getWaitingThreads() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
返回一个 collection，该 collection 包含那些正在此条件等待的线程。
getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回一个 collection，该 collection 包含那些正在与此同步器关联的给定条件上等待的线程。
getWaitingThreads() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
返回包含那些可能正在等待此条件的线程 collection。
getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回一个 collection，其中包含可能正在等待与此同步器有关的给定条件的那些线程。
getWaitingThreads(Condition) - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回一个 collection，它包含可能正在等待与此锁相关给定条件的那些线程。
getWaitingThreads(Condition) - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回一个 collection，它包含可能正在等待与写入锁相关的给定条件的那些线程。
getWaitQueueLength() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
返回正在此条件等待的线程估计数。
getWaitQueueLength(AbstractQueuedLongSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回正在与此同步器关联的给定条件上等待的线程估计数。
getWaitQueueLength() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
返回正在等待此条件的线程数估计值。
getWaitQueueLength(AbstractQueuedSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回正在等待与此同步器有关的给定条件的线程数估计值。
getWaitQueueLength(Condition) - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回等待与此锁相关的给定条件的线程估计数。
getWaitQueueLength(Condition) - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回正等待与写入锁相关的给定条件的线程估计数目。
getWantClientAuth() - 类 javax.net.ssl.SSLEngine 中的方法
如果引擎请求 客户端验证，则返回 true。
getWantClientAuth() - 类 javax.net.ssl.SSLParameters 中的方法
返回是否应该请求客户机验证。
getWantClientAuth() - 类 javax.net.ssl.SSLServerSocket 中的方法
如果新接受的服务器模式的连接请求 客户端验证，则返回 true。
getWantClientAuth() - 类 javax.net.ssl.SSLSocket 中的方法
如果套接字请求 客户机验证，则返回 true。
getWantsInput() - 类 javax.swing.JOptionPane 中的方法
返回 wantsInput 属性的值。
getWarnings() - 接口 java.sql.Connection 中的方法
获取此 Connection 对象上的调用报告的第一个警告。
getWarnings() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象上的调用报告的第一个警告。
getWarnings() - 接口 java.sql.Statement 中的方法
获取此 Statement 对象上的调用报告的第一个警告。
getWarningString() - 类 java.awt.Window 中的方法
获取此窗口中显示的警告字符串。
getWarningString() - 类 javax.swing.JInternalFrame 中的方法
获取此内部窗体中显示的警告字符串。
getWeekdays() - 类 java.text.DateFormatSymbols 中的方法
获取星期字符串。
getWestPane() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getWhatToShow() - 接口 org.w3c.dom.ls.LSParserFilter 中的方法
告知 LSParser 将向方法 LSParserFilter.acceptNode 显示什么类型的节点。
getWhatToShow() - 接口 org.w3c.dom.ls.LSSerializerFilter 中的方法
告诉 LSSerializer 向过滤器显示什么类型的节点。
getWheelRotation() - 类 java.awt.event.MouseWheelEvent 中的方法
返回鼠标滚轮旋转的“喀哒声”的次数。
getWhen() - 类 java.awt.event.ActionEvent 中的方法
返回发生此事件时的时间戳。
getWhen() - 类 java.awt.event.InputEvent 中的方法
返回此事件发生时的时间戳。
getWhen() - 类 java.awt.event.InputMethodEvent 中的方法
返回此事件发生时的时间戳。
getWhen() - 类 java.awt.event.InvocationEvent 中的方法
返回此事件发生时的时间戳。
getWhereClause() - 接口 javax.sql.rowset.JoinRowSet 中的方法
返回在 JoinRowSet 对象中使用的 WHERE 子句的类似 SQL 的描述。
getWhite() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的白色。
getWhite() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回白色。
getWholeText() - 接口 org.w3c.dom.Text 中的方法
返回 Text 节点（逻辑上与此节点相邻的节点）的以文档顺序串接的所有文本。
getWidth() - 类 java.awt.Component 中的方法
返回组件的当前宽度。
getWidth() - 类 java.awt.Dimension 中的方法
返回此 Dimension 的宽度（以 double 精度表示）。
getWidth() - 类 java.awt.DisplayMode 中的方法
返回显示的宽度（以像素表示）。
getWidth() - 类 java.awt.geom.Arc2D.Double 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.Arc2D.Float 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.Dimension2D 中的方法
返回此 Dimension 的宽度（以 double 精度表示）。
getWidth() - 类 java.awt.geom.Ellipse2D.Double 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.Ellipse2D.Float 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.Rectangle2D.Double 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.Rectangle2D.Float 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.image.BufferedImage 中的方法
返回 BufferedImage 的宽度。
getWidth(ImageObserver) - 类 java.awt.image.BufferedImage 中的方法
返回 BufferedImage 的宽度。
getWidth(ImageObserver) - 类 java.awt.Image 中的方法
确定图像的宽度。
getWidth() - 类 java.awt.image.Kernel 中的方法
返回此 Kernel 的宽度。
getWidth() - 类 java.awt.image.PixelGrabber 中的方法
获取（调整图像宽度后的）像素缓冲区的宽度。
getWidth() - 类 java.awt.image.Raster 中的方法
返回 Raster 的像素宽度。
getWidth() - 接口 java.awt.image.renderable.RenderableImage 中的方法
获取用户坐标空间中的宽度。
getWidth() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
获取用户坐标空间中的宽度。
getWidth() - 接口 java.awt.image.RenderedImage 中的方法
返回 RenderedImage 的宽度。
getWidth() - 类 java.awt.image.SampleModel 中的方法
返回像素宽度。
getWidth() - 类 java.awt.image.VolatileImage 中的方法
返回 VolatileImage 的宽度。
getWidth() - 类 java.awt.print.PageFormat 中的方法
返回页面的宽度（以 1/72 英寸为单位）。
getWidth() - 类 java.awt.print.Paper 中的方法
返回页面的宽度（以 1/72 英寸为单位）。
getWidth() - 类 java.awt.Rectangle 中的方法
以 double 精度返回边界 Rectangle 的宽度。
getWidth() - 异常 java.util.IllegalFormatWidthException 中的方法
返回宽度。
getWidth(int) - 类 javax.imageio.ImageReader 中的方法
返回输入源中的给定图像的宽度，以像素为单位。
getWidth(int) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以指定单位获取可打印区域的 width。
getWidth() - 类 javax.swing.JComponent 中的方法
返回此组件的当前宽度。
getWidth() - 类 javax.swing.SpringLayout.Constraints 中的方法
返回 width 属性的值。
getWidth() - 类 javax.swing.table.TableColumn 中的方法
返回该 TableColumn 的宽度。
getWidth() - 类 javax.swing.text.BoxView 中的方法
返回框的当前宽度。
getWidthOfHighValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getWidthOfLowValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getWidthOfWidestLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getWidths() - 类 java.awt.FontMetrics 中的方法
获取此 Font 中前 256 个字符的 advance width。
getWildcardType(TypeMirror, TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回新的通配符类型参数。
getWindingRule() - 类 java.awt.geom.FlatteningPathIterator 中的方法
返回用于确定路径迭代的旋绕规则。
getWindingRule() - 类 java.awt.geom.Path2D 中的方法
返回填充风格旋绕规则。
getWindingRule() - 接口 java.awt.geom.PathIterator 中的方法
返回用于确定路径迭代的旋绕规则。
getWindow() - 类 java.awt.event.WindowEvent 中的方法
返回事件的发起方。
getWindowAncestor(Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
getWindowBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口背景颜色。
getWindowBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口背景色。
getWindowDecorationStyle() - 类 javax.swing.JRootPane 中的方法
返回一个常量，它标识 JRootPane 提供的 Window 装饰类型。
getWindowFocusListeners() - 类 java.awt.Window 中的方法
返回在此窗口注册的所有窗口焦点侦听器所组成的数组。
getWindowListeners() - 类 java.awt.Window 中的方法
返回在此窗口注册的所有窗口侦听器所组成的数组。
getWindows() - 类 java.awt.Window 中的静态方法
返回一个数组，该数组由此应用程序创建的所有 Window（包括被拥有的和不被拥有的）组成。
getWindowStateListeners() - 类 java.awt.Window 中的方法
返回在此窗口注册的所有窗口状态侦听器所组成的数组。
getWindowTitleBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口标题背景颜色。
getWindowTitleBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口标题背景色。
getWindowTitleFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回窗口标题字体。
getWindowTitleFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口标题字体。
getWindowTitleFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口标题字体。
getWindowTitleForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口标题前景色。
getWindowTitleForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口标题前景色。
getWindowTitleInactiveBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口标题非活动背景颜色。
getWindowTitleInactiveBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口标题非活动背景色。
getWindowTitleInactiveForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口标题非活动前景颜色。
getWindowTitleInactiveForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口标题非活动前景色。
getWordEnd(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定针对给定位置的单词结尾。
getWordInstance() - 类 java.text.BreakIterator 中的静态方法
返回一个用于默认语言环境 单词分解的新 BreakIterator 实例。
getWordInstance(Locale) - 类 java.text.BreakIterator 中的静态方法
返回一个用于给定语言环境单词分解的新 BreakIterator 实例。
getWordInstance(Locale) - 类 java.text.spi.BreakIteratorProvider 中的方法
为给定语言环境的单词分解返回一个新 BreakIterator 实例。
getWordSize() - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
返回以位为单位的 word 大小。
getWordStart(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定针对给定模型位置的单词开头。
getWrapSizeLimit(int, boolean, int) - 接口 org.ietf.jgss.GSSContext 中的方法
用来确定可以传输给 wrap 的消息的大小限制。
getWrapStyleWord() - 类 javax.swing.JTextArea 中的方法
获取换行方式（如果文本区要换行）。
getWritableParent() - 类 java.awt.image.WritableRaster 中的方法
返回此 WritableRaster 的父 WritableRaster（如果有），否则返回 null。
getWritableTile(int, int) - 类 java.awt.image.BufferedImage 中的方法
为写入签出一个 tile。
getWritableTile(int, int) - 接口 java.awt.image.WritableRenderedImage 中的方法
为写入签出一个 tile。
getWritableTileIndices() - 类 java.awt.image.BufferedImage 中的方法
返回 Point 对象的数组，它指示为写入签出了哪些 tile。
getWritableTileIndices() - 接口 java.awt.image.WritableRenderedImage 中的方法
返回 Point 对象的数组，它指示为写入签出了哪些 tile。
getWriteHoldCount() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询当前线程在此锁上保持的重入写入锁数量。
getWriteMethod() - 类 java.beans.PropertyDescriptor 中的方法
获得应该用于写入属性值的方法。
getWriter() - 接口 javax.script.ScriptContext 中的方法
返回脚本的 Writer，以便在显示输出时使用。
getWriter() - 类 javax.script.SimpleScriptContext 中的方法
返回脚本的 Writer，以便在显示输出时使用。
getWriter() - 类 javax.swing.text.AbstractWriter 中的方法
返回用于输出内容的 Writer。
getWriter() - 类 javax.xml.transform.stream.StreamResult 中的方法
获取通过 setWriter 设置的字符流。
getWriterFileSuffixes() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出与当前已注册 writer 集合所理解的格式关联的所有文件后缀。
getWriterFormatNames() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有非正式格式名称。
getWriterMIMETypes() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有 MIME 类型。
getWriterServiceProviderName() - 类 javax.imageio.spi.ImageTranscoderSpi 中的方法
返回 ImageWriterSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。
getWSDLDocumentLocation() - 类 javax.xml.ws.Service 中的方法
获取此 Service 的 WSDL 文档的位置。
getWSDLDocumentLocation() - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
获取此服务的 WSDL 文档的位置。
getX() - 类 java.awt.Component 中的方法
返回组件原点的当前 x 坐标。
getX() - 类 java.awt.dnd.DragSourceEvent 中的方法
此方法返回事件发生时在屏幕坐标中光标位置的水平坐标，如果没有为此事件指定光标位置，则返回零。
getX() - 类 java.awt.event.MouseEvent 中的方法
返回事件相对于源组件的水平 x 坐标。
getX() - 类 java.awt.geom.Arc2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.Arc2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.Ellipse2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.Ellipse2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.Point2D.Double 中的方法
以 double 精度返回此 Point2D 的 X 坐标。
getX() - 类 java.awt.geom.Point2D.Float 中的方法
以 double 精度返回此 Point2D 的 X 坐标。
getX() - 类 java.awt.geom.Point2D 中的方法
以 double 精度返回此 Point2D 的 X 坐标。
getX() - 类 java.awt.geom.Rectangle2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.Rectangle2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.Point 中的方法
以 double 精度返回此 Point2D 的 X 坐标。
getX() - 类 java.awt.Rectangle 中的方法
以 double 精度返回边界 Rectangle 的 X 坐标。
getX() - 接口 java.security.interfaces.DSAPrivateKey 中的方法
返回专用密钥值 x。
getX() - 类 java.security.spec.DSAPrivateKeySpec 中的方法
返回专用密钥 x。
getX() - 接口 javax.crypto.interfaces.DHPrivateKey 中的方法
返回私钥值 x。
getX() - 类 javax.crypto.spec.DHPrivateKeySpec 中的方法
返回私有值 x。
getX(int) - 类 javax.print.attribute.Size2DSyntax 中的方法
返回给定单位的此二维大小属性的 X 维度作为浮点值。
getX(int) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以指定的单位获取可打印区域的原点的 x 位置。
getX() - 类 javax.swing.JComponent 中的方法
返回组件原点的当前 x 坐标。
getX() - 类 javax.swing.SpringLayout.Constraints 中的方法
返回 x 属性的值。
getX1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回起始点的 X 坐标。
getX1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回起始点的 X 坐标。
getX1() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回起始点的 X 坐标。
getX1() - 类 java.awt.geom.Line2D.Double 中的方法
返回起始点的 X 坐标（以 double 精度表示）。
getX1() - 类 java.awt.geom.Line2D.Float 中的方法
返回起始点的 X 坐标（以 double 精度表示）。
getX1() - 类 java.awt.geom.Line2D 中的方法
返回起始点的 X 坐标（以 double 精度表示）。
getX1() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回起始点的 X 坐标。
getX1() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回起始点的 X 坐标。
getX1() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回起始点的 X 坐标。
getX2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回结束点的 X 坐标。
getX2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回结束点的 X 坐标。
getX2() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回结束点的 X 坐标。
getX2() - 类 java.awt.geom.Line2D.Double 中的方法
返回结束点的 X 坐标（以 double 精度表示）。
getX2() - 类 java.awt.geom.Line2D.Float 中的方法
返回结束点的 X 坐标（以 double 精度表示）。
getX2() - 类 java.awt.geom.Line2D 中的方法
返回结束点的 X 坐标（以 double 精度表示）。
getX2() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回结束点的 X 坐标。
getX2() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回结束点的 X 坐标。
getX2() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回结束点的 X 坐标。
getXAConnection() - 接口 javax.sql.XADataSource 中的方法
尝试建立可在分布式事务中使用的物理数据库连接。
getXAConnection(String, String) - 接口 javax.sql.XADataSource 中的方法
使用给定的用户名和密码，尝试建立一个物理数据库连接。
getXAResource() - 接口 javax.sql.XAConnection 中的方法
获取 XAResource 对象，事务管理器将使用该对象管理此 XAConnection 对象如何参与到分布式事务中。
getXMicrometers() - 类 javax.print.attribute.Size2DSyntax 中的方法
返回此二维大小属性的 X 维度（以微米为单位）。
getXmlEncoding() - 接口 org.w3c.dom.Document 中的方法
作为 XML 声明的一部分，指定此文档编码的属性。
getXmlEncoding() - 接口 org.w3c.dom.Entity 中的方法
当实体为外部解析实体时，它是作为文本声明的一部分指定此实体的编码的属性。
getXMLEventReader() - 类 javax.xml.transform.stax.StAXSource 中的方法
获取此 StAXSource 使用的 XMLEventReader。
getXMLEventWriter() - 类 javax.xml.transform.stax.StAXResult 中的方法
获取此 StAXResult 使用的 XMLEventWriter。
getXMLNode(Object) - 类 javax.xml.bind.Binder 中的方法
获取与给定 JAXB 对象关联的 XML 元素。
getXMLReader() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
获取配置好的 XMLReader。
getXMLReader() - 类 javax.xml.parsers.SAXParser 中的方法
返回由此类的实现封装的 XMLReader。
getXMLReader() - 类 javax.xml.transform.sax.SAXSource 中的方法
获取要用于 Source 的 XMLReader。
getXMLReporter() - 类 javax.xml.stream.XMLInputFactory 中的方法
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。
getXMLResolver() - 类 javax.xml.stream.XMLInputFactory 中的方法
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。
getXMLSchemaType() - 类 javax.xml.datatype.Duration 中的方法
返回此实例映射到的 XML 模式日期/时间类型的名称。
getXMLSchemaType() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回此实例映射到的 XML 模式日期/时间类型的名称。
getXmlStandalone() - 接口 org.w3c.dom.Document 中的方法
作为 XML 声明的一部分，指定此文档是否为独立文档的属性。
getXMLStreamReader() - 类 javax.xml.transform.stax.StAXSource 中的方法
获取此 StAXSource 使用的 XMLStreamReader。
getXMLStreamWriter() - 类 javax.xml.transform.stax.StAXResult 中的方法
获取此 StAXResult 使用的 XMLStreamWriter。
getXmlVersion() - 接口 org.w3c.dom.Document 中的方法
作为 XML 声明 的一部分指定此文档版本号的属性。
getXmlVersion() - 接口 org.w3c.dom.Entity 中的方法
当实体为外部解析实体时，它是作为文本声明的一部分指定此实体版本号的属性。
getXMLVersion() - 接口 org.xml.sax.ext.Locator2 中的方法
返回用于该实体的 XML 的版本。
getXMLVersion() - 类 org.xml.sax.ext.Locator2Impl 中的方法
返回版本属性的当前值。
getXOnScreen() - 类 java.awt.event.MouseEvent 中的方法
返回事件的绝对水平 x 坐标。
getXOrigin() - 类 java.awt.image.Kernel 中的方法
返回此 Kernel 的 X 原点。
getXPath() - 类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 中的方法
返回要计算的 XPath 表达式。
getXPathFunctionResolver() - 接口 javax.xml.xpath.XPath 中的方法
返回当前的函数解析器。
getXPathList() - 类 javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec 中的方法
返回一个列表，由一个或多个 XPathType 对象组成。
getXPathVariableResolver() - 接口 javax.xml.xpath.XPath 中的方法
返回当前的变量解析器。
getY() - 类 java.awt.Component 中的方法
返回组件原点的当前 y 坐标。
getY() - 类 java.awt.dnd.DragSourceEvent 中的方法
此方法返回事件发生时在屏幕坐标中光标位置的垂直坐标，如果没有为此事件指定光标位置，则返回零。
getY() - 类 java.awt.event.MouseEvent 中的方法
返回事件相对于源组件的垂直 y 坐标。
getY() - 类 java.awt.geom.Arc2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.Arc2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.Ellipse2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.Ellipse2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.Point2D.Double 中的方法
以 double 精度返回此 Point2D 的 Y 坐标。
getY() - 类 java.awt.geom.Point2D.Float 中的方法
以 double 精度返回此 Point2D 的 Y 坐标。
getY() - 类 java.awt.geom.Point2D 中的方法
以 double 精度返回此 Point2D 的 Y 坐标。
getY() - 类 java.awt.geom.Rectangle2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.Rectangle2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.Point 中的方法
以 double 精度返回此 Point2D 的 Y 坐标。
getY() - 类 java.awt.Rectangle 中的方法
以 double 精度返回边界 Rectangle 的 Y 坐标。
getY() - 接口 java.security.interfaces.DSAPublicKey 中的方法
返回公用密钥值 y。
getY() - 类 java.security.spec.DSAPublicKeySpec 中的方法
返回公用密钥 y。
getY() - 接口 javax.crypto.interfaces.DHPublicKey 中的方法
返回公钥值 y。
getY() - 类 javax.crypto.spec.DHPublicKeySpec 中的方法
返回公有值 y。
getY(int) - 类 javax.print.attribute.Size2DSyntax 中的方法
返回给定单位的此二维大小属性的 Y 维度作为浮点值。
getY(int) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以指定单位获取可打印区域的原点的 y 位置。
getY() - 类 javax.swing.JComponent 中的方法
返回组件原点的当前 y 坐标。
getY() - 类 javax.swing.SpringLayout.Constraints 中的方法
返回 y 属性的值。
getY1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回起始点的 Y 坐标。
getY1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回起始点的 Y 坐标。
getY1() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回起始点的 Y 坐标。
getY1() - 类 java.awt.geom.Line2D.Double 中的方法
返回起始点的 Y 坐标（以 double 精度表示）。
getY1() - 类 java.awt.geom.Line2D.Float 中的方法
返回起始点的 Y 坐标（以 double 精度表示）。
getY1() - 类 java.awt.geom.Line2D 中的方法
返回起始点的 Y 坐标（以 double 精度表示）。
getY1() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回起始点的 Y 坐标。
getY1() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回起始点的 Y 坐标。
getY1() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回起始点的 Y 坐标。
getY2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回结束点的 Y 坐标。
getY2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回结束点的 Y 坐标。
getY2() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回结束点的 Y 坐标。
getY2() - 类 java.awt.geom.Line2D.Double 中的方法
返回结束点的 Y 坐标（以 double 精度表示）。
getY2() - 类 java.awt.geom.Line2D.Float 中的方法
返回结束点的 Y 坐标（以 double 精度表示）。
getY2() - 类 java.awt.geom.Line2D 中的方法
返回结束点的 Y 坐标（以 double 精度表示）。
getY2() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回结束点的 Y 坐标。
getY2() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回结束点的 Y 坐标。
getY2() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回结束点的 Y 坐标。
getYear() - 类 java.sql.Time 中的方法
已过时。
getYear() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.YEAR) - 1900 取代。
getYear() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回 year 或 DatatypeConstants.FIELD_UNDEFINED XML 模式 1.0 日期时间数据类型字段的低顺序组件。
getYears() - 类 javax.xml.datatype.Duration 中的方法
获取此 Duration 以 int 表示的 years 值，如果不存在，则值为 0。
getYMicrometers() - 类 javax.print.attribute.Size2DSyntax 中的方法
返回此二维大小属性的 Y 维度（以微米为单位）。
getYOnScreen() - 类 java.awt.event.MouseEvent 中的方法
返回事件的绝对垂直 y 坐标。
getYOrigin() - 类 java.awt.image.Kernel 中的方法
返回此 Kernel 的 Y 原点。
getZeroDigit() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于零的字符。
getZoneStrings() - 类 java.text.DateFormatSymbols 中的方法
获取时区字符串。
GIF - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "image/gif"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
GIF - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
GIF - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
GLASS_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
一个窗格，保证此窗格在其所有下级窗格之上进行绘制。
GLASS_PANE_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
glassPane - 类 javax.swing.JRootPane 中的变量
覆盖菜单栏和内容窗格的玻璃窗格，便于截取鼠标移动等操作。
glassPaneDispatcher - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量

global - 类 java.util.logging.Logger 中的静态变量
已过时。 此字段的初始化会容易出现死锁。必须由 Logger 类初始化来初始化字段，这可能会导致 LogManager 类初始化的死锁。在这种情况下，两个类初始化都要等待对方完成。从 JDK version 1.6 开始，获取全局 logger 对象的首选方法是通过调用 Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)。
GLOBAL_LOGGER_NAME - 类 java.util.logging.Logger 中的静态变量
GLOBAL_LOGGER_NAME 是全局 logger 的一个名称。
GLOBAL_SCOPE - 接口 javax.script.ScriptContext 中的静态变量
GlobalScope 属性对于同一 ScriptEngineFactory 创建的所有引擎都是可见的。
globalHierarchyLock - 接口 java.beans.beancontext.BeanContext 中的静态变量
BeanContext 和 BeanContextServices 实现者均使用此全局锁定来序列化 BeanContext 中的更改和所有服务请求等。
globalScope - 类 javax.script.SimpleScriptContext 中的变量
此字段是全局范围 bindings。
GlyphJustificationInfo - java.awt.font 中的 类
GlyphJustificationInfo 类表示关于字形调整属性的信息。
GlyphJustificationInfo(float, boolean, int, float, float, boolean, int, float, float) - 类 java.awt.font.GlyphJustificationInfo 的构造方法
构造有关字形调整属性的信息。
GlyphMetrics - java.awt.font 中的 类
GlyphMetrics 类表示单个字形的信息。
GlyphMetrics(float, Rectangle2D, byte) - 类 java.awt.font.GlyphMetrics 的构造方法
构造一个 GlyphMetrics 对象。
GlyphMetrics(boolean, float, float, Rectangle2D, byte) - 类 java.awt.font.GlyphMetrics 的构造方法
构造一个 GlyphMetrics 对象。
GlyphVector - java.awt.font 中的 类
GlyphVector 对象是一个字形的集合，包含在转换坐标空间中放置每个字形的几何信息，该坐标空间对应于最终要显示 GlyphVector 的设备。
GlyphVector() - 类 java.awt.font.GlyphVector 的构造方法

GlyphView - javax.swing.text 中的 类
GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
GlyphView(Element) - 类 javax.swing.text.GlyphView 的构造方法
构造在元素上包装的新视图。
GlyphView.GlyphPainter - javax.swing.text 中的 类
执行字形呈现的类。
GlyphView.GlyphPainter() - 类 javax.swing.text.GlyphView.GlyphPainter 的构造方法

GMONTH - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 gMonth 的完全限定名称。
GMONTHDAY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 gMonthDay 的完全限定名称。
GoodBreakWeight - 类 javax.swing.text.View 中的静态变量
该权重指示视图支持拆分，但是可能存在更好时机。
GOPHER - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
Gopher 协议。
GOT_FOCUS - 类 java.awt.Event 中的静态变量
组件获得焦点。
gotDefault - 类 javax.naming.InitialContext 中的变量
该字段指示是否已通过调用 NamingManager.getInitialContext() 获得了初始上下文。
gotFocus(Event, Object) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
GOTHIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Gothic”Unicode 字符块的常量。
grabFocus() - 类 javax.swing.JComponent 中的方法
请求此 Component 获取输入焦点，并请求此 Component 的顶层祖先成为获得焦点的 Window。
grabPixels() - 类 java.awt.image.PixelGrabber 中的方法
请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素。
grabPixels(long) - 类 java.awt.image.PixelGrabber 中的方法
请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素，或者等待到用完超时期。
GRADE_CHECK_ALL_AT_COMMIT - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示关于原始数据源的高级别乐观同步等级。
GRADE_CHECK_MODIFIED_AT_COMMIT - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示关于原始数据源的低级别乐观同步等级。
GRADE_LOCK_WHEN_LOADED - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示关于原始数据源的最悲观同步等级。
GRADE_LOCK_WHEN_MODIFIED - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示关于原始数据源的悲观同步等级。
GRADE_NONE - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示没有提供与原始数据源的同步。
GradientPaint - java.awt 中的 类
GradientPaint 类提供了使用线性颜色渐变模式填充 Shape 的方法。
GradientPaint(float, float, Color, float, float, Color) - 类 java.awt.GradientPaint 的构造方法
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(Point2D, Color, Point2D, Color) - 类 java.awt.GradientPaint 的构造方法
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(float, float, Color, float, float, Color, boolean) - 类 java.awt.GradientPaint 的构造方法
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
GradientPaint(Point2D, Color, Point2D, Color, boolean) - 类 java.awt.GradientPaint 的构造方法
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
GraphicAttribute - java.awt.font 中的 类
此类与 CHAR_REPLACEMENT 属性一起使用。
GraphicAttribute(int) - 类 java.awt.font.GraphicAttribute 的构造方法
构造一个 GraphicAttribute。
Graphics - java.awt 中的 类
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Graphics() - 类 java.awt.Graphics 的构造方法
构造一个新的 Graphics 对象。
Graphics2D - java.awt 中的 类
此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。
Graphics2D() - 类 java.awt.Graphics2D 的构造方法
构建一个新的 Graphics2D 对象。
GraphicsConfigTemplate - java.awt 中的 类
GraphicsConfigTemplate 类用于获得有效的 GraphicsConfiguration。
GraphicsConfigTemplate() - 类 java.awt.GraphicsConfigTemplate 的构造方法
此类是一个抽象类，因此只有子类才可以实例化。
GraphicsConfiguration - java.awt 中的 类
GraphicsConfiguration 类描述图形目标（如打印机或监视器）的特征。
GraphicsConfiguration() - 类 java.awt.GraphicsConfiguration 的构造方法
这是一个不可直接实例化的抽象类。
GraphicsDevice - java.awt 中的 类
GraphicsDevice 类描述可以在特定图形环境中使用的图形设备。
GraphicsDevice() - 类 java.awt.GraphicsDevice 的构造方法
这是一个无法直接实例化的抽象类。
GraphicsEnvironment - java.awt 中的 类
GraphicsEnvironment 类描述了 Java(tm) 应用程序在特定平台上可用的 GraphicsDevice 对象和 Font 对象的集合。
GraphicsEnvironment() - 类 java.awt.GraphicsEnvironment 的构造方法
这是一个抽象类，不能直接将其实例化。
gray - 类 java.awt.Color 中的静态变量
灰色。
GRAY - 类 java.awt.Color 中的静态变量
灰色。
GrayFilter - javax.swing 中的 类
一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。
GrayFilter(boolean, int) - 类 javax.swing.GrayFilter 的构造方法
构造一个 GrayFilter 对象，该对象将彩色图像过滤成灰度级图像。
GREATER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
比较结果。
GREEK - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Greek and Coptic”Unicode 字符块的常量。
GREEK_EXTENDED - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Greek Extended”Unicode 字符块的常量。
green - 类 java.awt.Color 中的静态变量
绿色。
GREEN - 类 java.awt.Color 中的静态变量
绿色。
GREENCOMPONENT - 类 java.awt.color.ICC_ProfileRGB 中的静态变量
用于获取绿色分量的 gamma 值或 TRC。
GregorianCalendar - java.util 中的 类
GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。
GregorianCalendar() - 类 java.util.GregorianCalendar 的构造方法
在具有默认语言环境的默认时区内使用当前时间构造一个默认的 GregorianCalendar。
GregorianCalendar(TimeZone) - 类 java.util.GregorianCalendar 的构造方法
在具有默认语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(Locale) - 类 java.util.GregorianCalendar 的构造方法
在具有给定语言环境的默认时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(TimeZone, Locale) - 类 java.util.GregorianCalendar 的构造方法
在具有给定语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(int, int, int) - 类 java.util.GregorianCalendar 的构造方法
在具有默认语言环境的默认时区内构造一个带有给定日期设置的 GregorianCalendar。
GregorianCalendar(int, int, int, int, int) - 类 java.util.GregorianCalendar 的构造方法
为具有默认语言环境的默认时区构造一个具有给定日期和时间设置的 GregorianCalendar。
GregorianCalendar(int, int, int, int, int, int) - 类 java.util.GregorianCalendar 的构造方法
为具有默认语言环境的默认时区构造一个具有给定日期和时间设置的 GregorianCalendar。
GridBagConstraints - java.awt 中的 类
GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。
GridBagConstraints() - 类 java.awt.GridBagConstraints 的构造方法
创建一个 GridBagConstraint 对象，将其所有字段都设置为默认值。
GridBagConstraints(int, int, int, int, double, double, int, int, Insets, int, int) - 类 java.awt.GridBagConstraints 的构造方法
创建一个 GridBagConstraints 对象，将其所有字段都设置为传入参数。
GridBagLayout - java.awt 中的 类
GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。
GridBagLayout() - 类 java.awt.GridBagLayout 的构造方法
创建网格包布局管理器。
GridBagLayoutInfo - java.awt 中的 类
GridBagLayoutInfo 是 GridBagLayout 布局管理器的一个实用工具类。
gridColor - 类 javax.swing.JTable 中的变量
网格的颜色。
gridheight - 类 java.awt.GridBagConstraints 中的变量
指定在组件显示区域的一列中的单元格数。
GridLayout - java.awt 中的 类
GridLayout 类是一个布局处理器，它以矩形网格形式对容器的组件进行布置。
GridLayout() - 类 java.awt.GridLayout 的构造方法
创建具有默认值的网格布局，即每个组件占据一行一列。
GridLayout(int, int) - 类 java.awt.GridLayout 的构造方法
创建具有指定行数和列数的网格布局。
GridLayout(int, int, int, int) - 类 java.awt.GridLayout 的构造方法
创建具有指定行数和列数的网格布局。
gridwidth - 类 java.awt.GridBagConstraints 中的变量
指定组件显示区域的某一行中的单元格数。
gridx - 类 java.awt.GridBagConstraints 中的变量
指定包含组件的显示区域开始边的单元格，其中行的第一个单元格为 gridx=0。
gridy - 类 java.awt.GridBagConstraints 中的变量
指定位于组件显示区域的顶部的单元格，其中最上边的单元格为 gridy=0。
Group - java.security.acl 中的 接口
此接口用于表示一个主体组。
group() - 类 java.util.regex.Matcher 中的方法
返回由以前匹配操作所匹配的输入子序列。
group(int) - 类 java.util.regex.Matcher 中的方法
返回在以前匹配操作期间由给定组捕获的输入子序列。
group() - 接口 java.util.regex.MatchResult 中的方法
返回由以前匹配所匹配的输入子序列。
group(int) - 接口 java.util.regex.MatchResult 中的方法
返回在以前匹配操作期间由给定组捕获的输入子序列。
group - 类 javax.swing.DefaultButtonModel 中的变量
按钮所属的按钮组。
GROUP_BOX - 类 javax.accessibility.AccessibleRole 中的静态变量
GROUP_BOX 是包含它周围的边框及其内部组件的简单容器。
groupCount() - 类 java.util.regex.Matcher 中的方法
返回此匹配器模式中的捕获组数。
groupCount() - 接口 java.util.regex.MatchResult 中的方法
返回此匹配结果的模式中的捕获组数。
GROUPING_SEPARATOR - 类 java.text.NumberFormat.Field 中的静态变量
标识组分隔符字段的常量。
GroupLayout - javax.swing 中的 类
GroupLayout 是一个 LayoutManager，它将组件按层次分组，以决定它们在 Container 中的位置。
GroupLayout(Container) - 类 javax.swing.GroupLayout 的构造方法
为指定的 Container 创建 GroupLayout。
GroupLayout.Alignment - javax.swing 中的 枚举
ParallelGroup 能够对齐其子元素的可能方式的枚举。
GroupLayout.Group - javax.swing 中的 类
Group 为 GroupLayout 所支持的以下两种操作提供基础：一个接一个地布置组件（SequentialGroup）或对齐组件（ParallelGroup）。
GroupLayout.ParallelGroup - javax.swing 中的 类
一个 Group，它对齐其子元素并确定其大小。
GroupLayout.SequentialGroup - javax.swing 中的 类
一个 Group，它按顺序一个接一个地确定其元素的位置和大小。
grow(int, int) - 类 java.awt.Rectangle 中的方法
在水平方向和垂直方向上同时调整 Rectangle 的大小。
growAbsorb - 类 java.awt.font.GlyphJustificationInfo 中的变量
如果为 true，那么当此字形增大时，它会占有此 priority 和更低 priority 的所有额外空间。
growLeftLimit - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形左边可以增大的最大量。
growPriority - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形增大时的 priority 级别。
growRightLimit - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形右边可以增大的最大量。
GSSContext - org.ietf.jgss 中的 接口
此接口将封装 GSS-API 安全上下文，并提供可通过上下文提供的安全服务。
GSSCredential - org.ietf.jgss 中的 接口
此接口将为实体封装 GSS-API 凭据。
GSSException - org.ietf.jgss 中的 异常
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。
GSSException(int) - 异常 org.ietf.jgss.GSSException 的构造方法
使用指定的主要代码创建一个 GSSException 对象。
GSSException(int, int, String) - 异常 org.ietf.jgss.GSSException 的构造方法
使用指定的主要代码、次要代码和次要代码文本性解释，创建一个 GSSException 对象。
GSSManager - org.ietf.jgss 中的 类
此类作为其他重要 GSS-API 类的工厂，并且还提供有关受支持的机制的信息。
GSSManager() - 类 org.ietf.jgss.GSSManager 的构造方法

GSSName - org.ietf.jgss 中的 接口
此接口将封装单一的 GSS-API 主体实体。
GT - 类 javax.management.Query 中的静态变量
表示 Query.gt(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
gt(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于两个值的“大于”约束条件。
Guard - java.security 中的 接口
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
GuardedObject - java.security 中的 类
GuardedObject 是一个用来保护对另一个对象的访问的对象。
GuardedObject(Object, Guard) - 类 java.security.GuardedObject 的构造方法
使用指定的对象和 guard 构造 GuardedObject。
guessContentTypeFromName(String) - 类 java.net.URLConnection 中的静态方法
根据 URL 的指定 "file" 部分尝试确定对象的内容类型。
guessContentTypeFromStream(InputStream) - 类 java.net.URLConnection 中的静态方法
根据输入流的开始字符尝试确定输入流的类型。
GUJARATI - 类 java.awt.font.NumericShaper 中的静态变量
标识 GUJARATI 范围和十进制基数。
GUJARATI - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Gujarati”Unicode 字符块的常量。
GURMUKHI - 类 java.awt.font.NumericShaper 中的静态变量
标识 GURMUKHI 范围和十进制基数。
GURMUKHI - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Gurmukhi”Unicode 字符块的常量。
GYEAR - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 gYear 的完全限定名称。
GYEARMONTH - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 gYearMonth 的完全限定名称。
GZIP - 类 javax.print.attribute.standard.Compression 中的静态变量
RFC 1952 中所描述的 GNU zip 压缩技术。
GZIP_MAGIC - 类 java.util.zip.GZIPInputStream 中的静态变量
GZIP 头幻数。
GZIPInputStream - java.util.zip 中的 类
此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
GZIPInputStream(InputStream, int) - 类 java.util.zip.GZIPInputStream 的构造方法
使用指定缓冲区大小创建新的输入流。
GZIPInputStream(InputStream) - 类 java.util.zip.GZIPInputStream 的构造方法
使用默认缓冲区大小创建新的输入流。
GZIPOutputStream - java.util.zip 中的 类
此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
GZIPOutputStream(OutputStream, int) - 类 java.util.zip.GZIPOutputStream 的构造方法
使用指定缓冲区大小创建新的输出流。
GZIPOutputStream(OutputStream) - 类 java.util.zip.GZIPOutputStream 的构造方法
使用默认缓冲区大小创建新的输出流。

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM 2 Platform
Standard Ed. 6

上一个字母 下一个字母

框架 无框架

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


H - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

H

h - 类 java.lang.reflect.Proxy 中的变量
此代理实例的调用处理程序。
H1 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
H2 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
H3 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
H4 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
H5 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
H6 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
HALFWIDTH_AND_FULLWIDTH_FORMS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Halfwidth and Fullwidth Forms”Unicode 字符块的常量。
HALFWIDTH_KATAKANA - 类 java.awt.im.InputSubset 中的静态变量
Unicode 半角和全角字符块的半角片假名子集常量。
HALIGN - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
halt(int) - 类 java.lang.Runtime 中的方法
强行终止目前正在运行的 Java 虚拟机。
HAND_CURSOR - 类 java.awt.Cursor 中的静态变量
手状光标类型。
HAND_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.HAND_CURSOR 取代。
handle(Callback[]) - 接口 javax.security.auth.callback.CallbackHandler 中的方法
获取或显示在提供的 Callback 中请求的信息。
handle(short, String, Object, Node, Node) - 接口 org.w3c.dom.UserDataHandler 中的方法
每当导入或克隆为其注册此处理程序的节点时，调用此方法。
handleComment(char[], int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
handleComment(char[], int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleComment(char[]) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
handleComment(char[]) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到 HTML 注释时调用。
handleEmptyTag(TagElement) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
处理空标记。
handleEmptyTag(TagElement) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到空标记时调用。
handleEndOfLineString(String) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
它的调用是在完成流的解析之后且在调用 flush 之前。
handleEndOfLineString(String) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
它的调用是在完成流的解析之后且在调用 flush 之前。
handleEndTag(HTML.Tag, int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
从解析器回调。
handleEndTag(HTML.Tag, int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleEndTag(TagElement) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
处理结束标记。
handleEndTag(TagElement) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到结束标记时调用。
handleEOFInComment() - 类 javax.swing.text.html.parser.Parser 中的方法
handleError(String, int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleError(int, String) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
handleError(int, String) - 类 javax.swing.text.html.parser.Parser 中的方法
发生了一个错误。
handleError(DOMError) - 接口 org.w3c.dom.DOMErrorHandler 中的方法
发生错误时在错误处理程序上调用此方法。
handleEvent(Event) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processEvent(AWTEvent) 取代。
handleEvent(ValidationEvent) - 类 javax.xml.bind.helpers.DefaultValidationEventHandler 中的方法
handleEvent(ValidationEvent) - 类 javax.xml.bind.util.ValidationEventCollector 中的方法
handleEvent(ValidationEvent) - 接口 javax.xml.bind.ValidationEventHandler 中的方法
接收验证警告或错误的通知。
handleEvent(Event) - 接口 org.w3c.dom.events.EventListener 中的方法
每当发生 EventListener 接口为其注册的类型的事件时，即可调用此方法。
handleExpandControlClick(TreePath, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
当用户单击特定行时传递消息，此方法调用 toggleExpandState。
handleFault(C) - 接口 javax.xml.ws.handler.Handler 中的方法
可调用 handleFault 方法进行错误消息处理。
handleGetObject(String) - 类 java.util.ListResourceBundle 中的方法
handleGetObject(String) - 类 java.util.PropertyResourceBundle 中的方法
handleGetObject(String) - 类 java.util.ResourceBundle 中的方法
从此资源包中获取给定键的对象。
handleJustify(float) - 类 java.awt.font.TextLayout 中的方法
调整此布局。
handleKeySet() - 类 java.util.ListResourceBundle 中的方法
返回只 包含在此 ResourceBundle 中的键的 Set。
handleKeySet() - 类 java.util.PropertyResourceBundle 中的方法
返回只 包含在此 ResourceBundle 中的键的 Set。
handleKeySet() - 类 java.util.ResourceBundle 中的方法
返回只 包含在此 ResourceBundle 中的键的 Set。
handleMBeanUnregistration(ObjectName, String) - 接口 javax.management.relation.Relation 中的方法
在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
handleMBeanUnregistration(ObjectName, String) - 类 javax.management.relation.RelationSupport 中的方法
在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
handleMessage(C) - 接口 javax.xml.ws.handler.Handler 中的方法
可调用 handleMessage 方法进行普通的入站和出站消息处理。
handleNotification(NotificationListener, Notification, Object) - 类 javax.management.NotificationBroadcasterSupport 中的方法
为了向侦听器发送通知，由该侦听器的 sendNotification 调用此方法。
handleNotification(Notification, Object) - 接口 javax.management.NotificationListener 中的方法
出现 JMX 通知时调用。
handleNotification(Notification, Object) - 类 javax.management.relation.RelationService 中的方法
出现 JMX 通知时调用。
handleOption(String, Iterator<String>) - 类 javax.tools.ForwardingJavaFileManager 中的方法
handleOption(String, Iterator<String>) - 接口 javax.tools.JavaFileManager 中的方法
处理一个选项。
Handler - java.util.logging 中的 类
Handler 对象从 Logger 中获取日志信息，并将这些信息导出。
Handler() - 类 java.util.logging.Handler 的构造方法
默认构造方法。
Handler<C extends MessageContext> - javax.xml.ws.handler 中的 接口
Handler 接口是 JAX-WS 处理程序的基本接口。
HandlerBase - org.xml.sax 中的 类
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。
HandlerBase() - 类 org.xml.sax.HandlerBase 的构造方法
已过时。
HandlerChain - javax.jws 中的 注释类型
将 Web Service 与外部定义的处理程序链关联。
handleResponse(Response<T>) - 接口 javax.xml.ws.AsyncHandler 中的方法
当可以获得对异步操作的响应时调用。
HandlerResolver - javax.xml.ws.handler 中的 接口
HandlerResolver 是由应用程序实现的接口，用于控制创建 proxy/dispatch 对象时设置在这些对象上的处理程序链。
handleSimpleTag(HTML.Tag, MutableAttributeSet, int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
从解析器回调。
handleSimpleTag(HTML.Tag, MutableAttributeSet, int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleStartTag(HTML.Tag, MutableAttributeSet, int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
从解析器回调。
handleStartTag(HTML.Tag, MutableAttributeSet, int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleStartTag(TagElement) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
处理开始标记。
handleStartTag(TagElement) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到开始标记时调用。
handleText(char[], int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
解析器调用它来指示遇到一个文本块。
handleText(char[], int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleText(char[]) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
处理文本。
handleText(char[]) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到 PCDATA 时调用。
handleTitle(char[]) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到 HTML 标题标记时调用。
handshakeCompleted(HandshakeCompletedEvent) - 接口 javax.net.ssl.HandshakeCompletedListener 中的方法
当 SSL 握手结束时，在已注册的对象上调用此方法。
HandshakeCompletedEvent - javax.net.ssl 中的 类
此事件指示在给定的 SSL 连接上 SSL 握手结束。
HandshakeCompletedEvent(SSLSocket, SSLSession) - 类 javax.net.ssl.HandshakeCompletedEvent 的构造方法
构造一个新的 HandshakeCompletedEvent。
HandshakeCompletedListener - javax.net.ssl 中的 接口
任何希望接收有关给定 SSL 连接上 SSL 协议握手结束通知的类实现此接口。
HANGING_BASELINE - 类 java.awt.font.GraphicAttribute 中的静态变量
将图形的原点与行的悬挂基线对齐。
HANGING_BASELINE - 类 java.awt.Font 中的静态变量
布置文本时，在 Devanigiri 和类似脚本中使用的基线。
HANGUL_COMPATIBILITY_JAMO - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hangul Compatibility Jamo”Unicode 字符块的常量。
HANGUL_JAMO - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hangul Jamo”Unicode 字符块的常量。
HANGUL_SYLLABLES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hangul Syllables”Unicode 字符块的常量。
HANJA - 类 java.awt.im.InputSubset 中的静态变量
编写韩语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项的韩语汉字字集。
HANUNOO - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hanunoo”Unicode 字符块的常量。
hardDriveIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
has_no_active_member() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
如果联合数据没有活动成员，即这些联合数据值仅由其鉴别符组成（因为鉴别符的值不作为显式 case 标签列出），则返回 true。
has_no_active_member() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
如果联合数据没有活动成员，即这些联合数据值仅由其鉴别符组成（因为鉴别符的值不作为显式 case 标签列出），则返回 true。
hasAlpha() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 中是否支持 alpha。
hasAnchoringBounds() - 类 java.util.regex.Matcher 中的方法
查询此匹配器区域界限的定位。
hasArray() - 类 java.nio.Buffer 中的方法
告知此缓冲区是否具有可访问的底层实现数组。
hasArray() - 类 java.nio.ByteBuffer 中的方法
判断是否可通过一个可访问的 byte 数组实现此缓冲区。
hasArray() - 类 java.nio.CharBuffer 中的方法
判断该缓冲区是否可通过一个可访问的字符数组实现。
hasArray() - 类 java.nio.DoubleBuffer 中的方法
判断是否可通过一个可访问的 double 数组实现此缓冲区。
hasArray() - 类 java.nio.FloatBuffer 中的方法
判断是否可通过一个可访问的 float 数组实现此缓冲区。
hasArray() - 类 java.nio.IntBuffer 中的方法
判断是否可通过一个可访问的 int 数组实现此缓冲区。
hasArray() - 类 java.nio.LongBuffer 中的方法
判断是否可通过一个可访问的 long 数组实现此缓冲区。
hasArray() - 类 java.nio.ShortBuffer 中的方法
判断是否可通过一个可访问的 short 数组实现此缓冲区。
hasAttribute(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
hasAttribute(String) - 接口 org.w3c.dom.Element 中的方法
当具有给定名称的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。
hasAttributeNS(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 hasAttribute(localName)。
hasAttributeNS(String, String) - 接口 org.w3c.dom.Element 中的方法
当具有给定本地名称和名称空间 URI 的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。
hasAttributes() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
hasAttributes() - 接口 org.w3c.dom.Node 中的方法
返回此节点（如果它是一个元素）是否具有任何属性。
hasBeenExpanded(TreePath) - 类 javax.swing.JTree 中的方法
如果已经展开路径标识的节点，则返回 true。
hasChanged() - 类 java.util.Observable 中的方法
测试对象是否改变。
hasChildNodes() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
如果此节点有子节点，则返回 true。
hasChildNodes() - 接口 org.w3c.dom.Node 中的方法
返回此节点是否具有任何子节点。
hasChildren - 类 javax.swing.JTree.DynamicUtilTreeNode 中的变量
此 JTree 是否具有子节点？目前未实现此属性。
hasContended() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
查询是否有线程曾经为获取此同步器而发生争用；也就是说，是否某个 acquire 方法曾被阻塞。
hasContended() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
查询是否其他线程也曾争着获取此同步器；也就是说，是否某个 acquire 方法已经阻塞。
hasController() - 类 javax.imageio.IIOParam 中的方法
如果有一个为此 IIOParam 对象安装的控制器，则返回 true。
hasController() - 类 javax.imageio.metadata.IIOMetadata 中的方法
如果存在为此 IIOMetadata 对象安装的控制器，则返回 true。
HasControls - javax.naming.ldap 中的 接口
此接口用于返回控件，并使对象返回在 NamingEnumeration 中。
hasCustomComponents - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
如果 Component 包含在消息或按钮中，则将其设置为 true。
hasDefaultValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 默认值，则返回 true，否则返回 false。
hasDefaultValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
如果此参数存在指定的默认值，则返回 true，否则返回 false。
hasDefaultValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的默认值，则返回 true，否则返回 false。
hasDetail() - 接口 javax.xml.soap.SOAPFault 中的方法
如果此 SOAPFault 有一个 Detail 子元素，则返回 true，否则返回 false。
hasDynamicLocaleList() - 接口 java.awt.im.spi.InputMethodDescriptor 中的方法
返回可用语言环境列表是否可在运行时更改。
hasEntered - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
hasEvents() - 类 javax.xml.bind.util.ValidationEventCollector 中的方法
如果此事件收集器至少包含一个 ValidationEvent，则返回 true。
hasExpired() - 类 java.net.HttpCookie 中的方法
报告此 http cookie 是否已过期。
hasExtensions() - 类 java.security.cert.X509CRLEntry 中的方法
如果此 CRL 项有扩展，则返回 true。
hasFault() - 接口 javax.xml.soap.SOAPBody 中的方法
指示此 SOAPBody 对象中是否存在 SOAPFault 对象。
hasFeature(String, String) - 接口 org.w3c.dom.DOMImplementation 中的方法
测试 DOM 实现是否实现在 DOM Features 中指定的特定特性和版本。
hasFocus() - 类 java.awt.Component 中的方法
如果此 Component 是焦点所有者，则返回 true。
hasFocus - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
hasFocus - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
如果有焦点，则为 true。
hash(Object, int) - 类 org.omg.CORBA.portable.Delegate 中的方法
返回此对象引用的内部 ORB 标识符（哈希码）。
HashAttributeSet - javax.print.attribute 中的 类
类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。
HashAttributeSet() - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个新的、空属性集。
HashAttributeSet(Attribute) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个最初使用给定属性填充的新属性集。
HashAttributeSet(Attribute[]) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个最初使用给定数组中的值填充的新属性集。
HashAttributeSet(AttributeSet) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集。
HashAttributeSet(Class<?>) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个新的空属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(Attribute, Class<?>) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个最初使用给定属性填充的新属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(Attribute[], Class<?>) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个新的属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(AttributeSet, Class<?>) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于给定的接口。
hashCode() - 类 java.awt.AlphaComposite 中的方法
返回此合成的哈希码。
hashCode() - 类 java.awt.AWTKeyStroke 中的方法
返回此对象的数值，它可能是唯一的，将它用作哈希表中的索引值是一个好选择。
hashCode() - 类 java.awt.BasicStroke 中的方法
返回此笔划的哈希码。
hashCode() - 类 java.awt.Color 中的方法
计算此 Color 的哈希码。
hashCode() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的哈希码。
hashCode() - 类 java.awt.Dimension 中的方法
返回此 Dimension 的哈希码。
hashCode() - 类 java.awt.DisplayMode 中的方法
返回该对象的哈希码值。
hashCode() - 类 java.awt.font.FontRenderContext 中的方法
返回此 FontRenderContext 的哈希码。
hashCode() - 类 java.awt.Font 中的方法
返回此 Font 的哈希码。
hashCode() - 类 java.awt.font.ImageGraphicAttribute 中的方法
返回此 ImageGraphicAttribute 的哈希码。
hashCode() - 类 java.awt.font.NumericShaper 中的方法
返回此成形器的哈希码。
hashCode() - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回此 ShapeGraphicAttribute 的哈希码。
hashCode() - 类 java.awt.font.TextHitInfo 中的方法
返回哈希码。
hashCode() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的哈希码。
hashCode() - 类 java.awt.font.TransformAttribute 中的方法
hashCode() - 类 java.awt.geom.AffineTransform 中的方法
返回此变换的哈希码。
hashCode() - 类 java.awt.geom.Arc2D 中的方法
返回此 Arc2D 的哈希码。
hashCode() - 类 java.awt.geom.Ellipse2D 中的方法
返回此 Ellipse2D 的哈希码。
hashCode() - 类 java.awt.geom.Point2D 中的方法
返回此 Point2D 的哈希码。
hashCode() - 类 java.awt.geom.Rectangle2D 中的方法
返回此 Rectangle2D 的哈希码。
hashCode() - 类 java.awt.geom.RoundRectangle2D 中的方法
返回此 RoundRectangle2D 的哈希码。
hashCode() - 类 java.awt.image.BandedSampleModel 中的方法
hashCode() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 的哈希码。
hashCode() - 类 java.awt.image.ComponentSampleModel 中的方法
hashCode() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
hashCode() - 类 java.awt.image.PixelInterleavedSampleModel 中的方法
hashCode() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
hashCode() - 类 java.awt.Insets 中的方法
返回此 Insets 的哈希码。
hashCode() - 类 java.awt.JobAttributes 中的方法
返回此 JobAttributes 的哈希码值。
hashCode() - 类 java.awt.MenuShortcut 中的方法
返回此菜单快捷方式的哈希码。
hashCode() - 类 java.awt.PageAttributes 中的方法
返回此 PageAttributes 的哈希码值。
hashCode() - 类 java.awt.RenderingHints 中的方法
返回此 RenderingHints 中的哈希码值。
hashCode() - 类 java.awt.RenderingHints.Key 中的方法
所有 Key 对象的哈希码将与 System.identityHashCode() 方法定义的对象的系统识别码相同。
hashCode() - 类 java.beans.IndexedPropertyDescriptor 中的方法
返回对象的哈希码值。
hashCode() - 类 java.beans.PropertyDescriptor 中的方法
返回对象的哈希码。
hashCode() - 类 java.io.File 中的方法
计算此抽象路径名的哈希码。
hashCode() - 类 java.io.FilePermission 中的方法
返回此对象的哈希码值。
hashCode() - 接口 java.lang.annotation.Annotation 中的方法
返回此 annotation 的哈希码，具体说明如下： 一个 annotation 的哈希码是其成员（包括那些带有默认值的成员）的哈希码的和，具体说明如下： annotation 成员的哈希码是成员值哈希码的 XOR（它是 String.hashCode() 计算得到的成员名哈希码的 127 倍），具体说明如下： 成员值的哈希码取决于其类型： 基值 v 的哈希码等于 WrapperType.valueOf(v).hashCode()，其中 WrapperType 是对应 v 的基本类型的包装器类型（Byte、Character、Double、Float、Integer、Long、Short 或 Boolean）。
hashCode() - 类 java.lang.Boolean 中的方法
返回该 Boolean 对象的哈希码。
hashCode() - 类 java.lang.Byte 中的方法
返回此 Byte 的哈希码。
hashCode() - 类 java.lang.Character 中的方法
返回此 Character 的哈希码。
hashCode() - 类 java.lang.Character.Subset 中的方法
返回 Object.hashCode() 方法定义的标准哈希码。
hashCode() - 类 java.lang.Double 中的方法
返回此 Double 对象的哈希码。
hashCode() - 类 java.lang.Enum 中的方法
返回枚举常量的哈希码。
hashCode() - 类 java.lang.Float 中的方法
返回此 Float 对象的哈希码。
hashCode() - 类 java.lang.Integer 中的方法
返回此 Integer 的哈希码。
hashCode() - 类 java.lang.Long 中的方法
返回 Long 的哈希码。
hashCode() - 类 java.lang.Object 中的方法
返回该对象的哈希码值。
hashCode() - 类 java.lang.Package 中的方法
返回从包名称计算的哈希码。
hashCode() - 类 java.lang.reflect.Constructor 中的方法
返回此 Constructor 的哈希码。
hashCode() - 类 java.lang.reflect.Field 中的方法
返回该 Field 的哈希码。
hashCode() - 类 java.lang.reflect.Method 中的方法
返回此 Method 的哈希码。
hashCode() - 类 java.lang.Short 中的方法
返回此 Short 的哈希码。
hashCode() - 类 java.lang.StackTraceElement 中的方法
返回此堆栈跟踪元素的哈希码值。
hashCode() - 类 java.lang.String 中的方法
返回此字符串的哈希码。
hashCode() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的哈希码。
hashCode() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的哈希码。
hashCode() - 类 java.math.MathContext 中的方法
返回此 MathContext 的哈希码。
hashCode() - 类 java.net.HttpCookie 中的方法
返回此 http cookie 的哈希码。
hashCode() - 类 java.net.Inet4Address 中的方法
返回此 IP 地址的哈希码。
hashCode() - 类 java.net.Inet6Address 中的方法
返回此 IP 地址的哈希码。
hashCode() - 类 java.net.InetAddress 中的方法
返回此 IP 地址的哈希码。
hashCode() - 类 java.net.InetSocketAddress 中的方法
返回此套接字地址的哈希码。
hashCode() - 类 java.net.InterfaceAddress 中的方法
返回此接口地址的哈希码。
hashCode() - 类 java.net.NetworkInterface 中的方法
hashCode() - 类 java.net.Proxy 中的方法
返回此代理的哈希码。
hashCode() - 类 java.net.SocketPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.net.URI 中的方法
返回此 URI 的哈希码值。
hashCode() - 类 java.net.URL 中的方法
创建一个适合哈希表索引的整数。
hashCode(URL) - 类 java.net.URLStreamHandler 中的方法
提供默认的哈希计算。
hashCode() - 类 java.nio.ByteBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.nio.CharBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.nio.charset.Charset 中的方法
计算此 charset 的哈希码。
hashCode() - 类 java.nio.DoubleBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.nio.FloatBuffer 中的方法
返回此缓冲区的哈希码。
hashCode() - 类 java.nio.IntBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.nio.LongBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.nio.ShortBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.rmi.activation.ActivationDesc 中的方法
为类似的 ActivationDesc 返回相同的哈希码
hashCode() - 类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 中的方法
返回类似 CommandEnvironment 的相同值。
hashCode() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
为类似的 ActivationGroupDesc 产生同样的数。
hashCode() - 类 java.rmi.activation.ActivationGroupID 中的方法
返回用于组标识符的哈希码。
hashCode() - 类 java.rmi.activation.ActivationID 中的方法
返回激活 id 的哈希码。
hashCode() - 类 java.rmi.dgc.VMID 中的方法
计算针对此 VMID 的哈希码。
hashCode() - 类 java.rmi.MarshalledObject 中的方法
返回该 MarshalledObject 的哈希码。
hashCode() - 类 java.rmi.server.ObjID 中的方法
返回此对象标识符、对象数的哈希码值。
hashCode() - 类 java.rmi.server.RemoteObject 中的方法
返回远程对象的哈希码。
hashCode() - 类 java.rmi.server.UID 中的方法
返回此 UID 的哈希码值。
hashCode() - 类 java.security.AccessControlContext 中的方法
返回此上下文的哈希码值。
hashCode() - 类 java.security.AllPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.security.BasicPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.security.cert.Certificate 中的方法
根据此证书的编码形式返回该证书的哈希码值。
hashCode() - 类 java.security.cert.CertPath 中的方法
返回此证书路径的哈希码。
hashCode() - 类 java.security.cert.X509CRL 中的方法
根据此 CRL 的编码形式返回该 CRL 的哈希码值。
hashCode() - 类 java.security.cert.X509CRLEntry 中的方法
根据此 CRL 项的编码形式返回该 CRL 项的哈希码值。
hashCode() - 类 java.security.CodeSigner 中的方法
返回此代码签名者的哈希码值。
hashCode() - 类 java.security.CodeSource 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 的哈希码。
hashCode() - 类 java.security.Permission 中的方法
返回此 Permission 对象的哈希码值。
hashCode() - 接口 java.security.Principal 中的方法
返回此主体的哈希码。
hashCode() - 类 java.security.spec.ECFieldF2m 中的方法
返回此首数为 2 的有限字段的哈希码值。
hashCode() - 类 java.security.spec.ECFieldFp 中的方法
返回此素数有限字段的哈希码值。
hashCode() - 类 java.security.spec.ECPoint 中的方法
返回此椭圆曲线点的哈希码值。
hashCode() - 类 java.security.spec.EllipticCurve 中的方法
返回此椭圆曲线的哈希码值。
hashCode() - 类 java.security.Timestamp 中的方法
返回此时间戳的哈希码值。
hashCode() - 类 java.security.UnresolvedPermission 中的方法
返回此对象的哈希码值。
hashCode() - 接口 java.sql.RowId 中的方法
返回此 RowId 对象的哈希码值。
hashCode() - 类 java.text.AttributedCharacterIterator.Attribute 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.text.ChoiceFormat 中的方法
为消息格式对象生成哈希码。
hashCode() - 类 java.text.Collator 中的方法
生成此 Collator 的哈希码。
hashCode() - 类 java.text.DateFormat 中的方法
重写 hashCode
hashCode() - 类 java.text.DateFormatSymbols 中的方法
重写 hashCode。
hashCode() - 类 java.text.DecimalFormat 中的方法
重写 hashCode
hashCode() - 类 java.text.DecimalFormatSymbols 中的方法
重写 hashCode。
hashCode() - 类 java.text.FieldPosition 中的方法
返回此 FieldPosition 的哈希码。
hashCode() - 类 java.text.MessageFormat 中的方法
生成此消息格式对象的哈希码。
hashCode() - 类 java.text.NumberFormat 中的方法
重写 hashCode
hashCode() - 类 java.text.ParsePosition 中的方法
返回此 ParsePosition 的哈希码。
hashCode() - 类 java.text.RuleBasedCollator 中的方法
生成基于表的 collation 对象的哈希码
hashCode() - 类 java.text.SimpleDateFormat 中的方法
返回此 SimpleDateFormat 对象的哈希码值。
hashCode() - 类 java.text.StringCharacterIterator 中的方法
计算此迭代器的哈希码。
hashCode() - 类 java.util.AbstractList 中的方法
返回此列表的哈希码值。
hashCode() - 类 java.util.AbstractMap 中的方法
返回此映射的哈希码值。
hashCode() - 类 java.util.AbstractMap.SimpleEntry 中的方法
返回此映射项的哈希码值。
hashCode() - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
返回此映射项的哈希码值。
hashCode() - 类 java.util.AbstractSet 中的方法
返回此 set 的哈希码值。
hashCode(long[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(int[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(short[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(char[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(byte[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(boolean[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(float[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(double[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(Object[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode() - 类 java.util.BitSet 中的方法
返回此位 set 的哈希码值。
hashCode() - 类 java.util.Calendar 中的方法
返回该此日历的哈希码。
hashCode() - 接口 java.util.Collection 中的方法
返回此 collection 的哈希码值。
hashCode() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表的哈希码值。
hashCode() - 类 java.util.Date 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.util.GregorianCalendar 中的方法
生成此 GregorianCalendar 对象的哈希码。
hashCode() - 类 java.util.Hashtable 中的方法
按照 Map 接口的定义，返回此 Map 的哈希码值。
hashCode() - 类 java.util.IdentityHashMap 中的方法
返回映射的哈希码值。
hashCode() - 类 java.util.jar.Attributes 中的方法
返回此 Map 的哈希码值。
hashCode() - 类 java.util.jar.Attributes.Name 中的方法
计算此属性名称的哈希值。
hashCode() - 类 java.util.jar.Manifest 中的方法
返回 Manifest 的哈希码。
hashCode() - 接口 java.util.List 中的方法
返回列表的哈希码值。
hashCode() - 类 java.util.Locale 中的方法
重写 hashCode。
hashCode() - 类 java.util.logging.Level 中的方法
生成哈希码。
hashCode() - 接口 java.util.Map.Entry 中的方法
返回此映射项的哈希码值。
hashCode() - 接口 java.util.Map 中的方法
返回此映射的哈希码值。
hashCode() - 类 java.util.PropertyPermission 中的方法
返回对象的哈希码值。
hashCode() - 接口 java.util.Set 中的方法
返回 set 的哈希码值。
hashCode() - 类 java.util.SimpleTimeZone 中的方法
生成 SimpleDateFormat 对象的哈希码。
hashCode() - 类 java.util.UUID 中的方法
返回此 UUID 的哈希码。
hashCode() - 类 java.util.Vector 中的方法
返回此向量的哈希码值。
hashCode() - 类 java.util.zip.ZipEntry 中的方法
返回此条目的哈希码值。
hashCode() - 类 javax.crypto.spec.RC2ParameterSpec 中的方法
计算此对象的哈希码值。
hashCode() - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
计算此对象的哈希码值。
hashCode() - 类 javax.crypto.spec.SecretKeySpec 中的方法
计算此对象的哈希码值。
hashCode() - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回此 ImageTypeSpecifier 的哈希码。
hashCode() - 接口 javax.lang.model.element.Element 中的方法
遵守 Object.hashCode 的常规协定。
hashCode() - 接口 javax.lang.model.element.Name 中的方法
遵守 Object.hashCode 的常规协定。
hashCode() - 接口 javax.lang.model.type.TypeMirror 中的方法
遵守 Object.hashCode 的常规协定。
hashCode() - 类 javax.management.Attribute 中的方法
返回此属性的哈希码值。
hashCode() - 接口 javax.management.Descriptor 中的方法
返回此描述符的哈希码值。
hashCode() - 类 javax.management.ImmutableDescriptor 中的方法
返回此描述符的哈希码值。
hashCode() - 类 javax.management.MBeanAttributeInfo 中的方法
hashCode() - 类 javax.management.MBeanConstructorInfo 中的方法
hashCode() - 类 javax.management.MBeanFeatureInfo 中的方法
hashCode() - 类 javax.management.MBeanInfo 中的方法
hashCode() - 类 javax.management.MBeanNotificationInfo 中的方法
hashCode() - 类 javax.management.MBeanOperationInfo 中的方法
hashCode() - 类 javax.management.MBeanParameterInfo 中的方法
hashCode() - 类 javax.management.MBeanPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 javax.management.MBeanServerPermission 中的方法
hashCode() - 类 javax.management.modelmbean.DescriptorSupport 中的方法
返回此描述符的哈希码值。
hashCode() - 类 javax.management.ObjectInstance 中的方法
hashCode() - 类 javax.management.ObjectName 中的方法
返回此 ObjectName 的哈希码。
hashCode() - 类 javax.management.openmbean.ArrayType 中的方法
返回此 ArrayType 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.CompositeData 中的方法
返回此 CompositeData 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回此 CompositeDataSupport 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.CompositeType 中的方法
返回此 CompositeType 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
返回此 OpenMBeanAttributeInfo 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
返回此 OpenMBeanConstructorInfo 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 中的方法
返回此 OpenMBeanConstructorInfoSupport 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回此 OpenMBeanInfo 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenMBeanInfoSupport 中的方法
返回此 OpenMBeanInfoSupport 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 中的方法
返回此 OpenMBeanOperationInfoSupport 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此 OpenMBeanParameterInfo 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenType 中的方法
hashCode() - 类 javax.management.openmbean.SimpleType 中的方法
返回此 SimpleType 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularDataSupport 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.TabularType 中的方法
返回此 TabularType 实例的哈希码值。
hashCode() - 类 javax.management.remote.JMXPrincipal 中的方法
返回此 JMXPrincipal 的哈希码。
hashCode() - 类 javax.management.remote.JMXServiceURL 中的方法
hashCode() - 类 javax.naming.BinaryRefAddr 中的方法
使用地址类型和内容计算此地址的哈希码。
hashCode() - 类 javax.naming.CompositeName 中的方法
计算此复合名称的哈希码。
hashCode() - 类 javax.naming.CompoundName 中的方法
计算此组合名称的哈希码。
hashCode() - 类 javax.naming.directory.BasicAttribute 中的方法
计算此属性的哈希码。
hashCode() - 类 javax.naming.directory.BasicAttributes 中的方法
计算此 BasicAttributes 的哈希码。
hashCode() - 类 javax.naming.ldap.LdapName 中的方法
计算此 LDAP 名称的哈希码。
hashCode() - 类 javax.naming.ldap.Rdn 中的方法
返回此 RDN 的哈希码。
hashCode() - 类 javax.naming.RefAddr 中的方法
使用地址类型和内容计算此地址的哈希码。
hashCode() - 类 javax.naming.Reference 中的方法
计算此引用的哈希码。
hashCode() - 接口 javax.print.attribute.AttributeSet 中的方法
返回此属性集的哈希码值。
hashCode() - 类 javax.print.attribute.DateTimeSyntax 中的方法
返回此日期-时间属性的哈希码值。
hashCode() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的哈希码值。
hashCode() - 类 javax.print.attribute.HashAttributeSet 中的方法
返回此属性集的哈希码值。
hashCode() - 类 javax.print.attribute.IntegerSyntax 中的方法
返回此整数属性的哈希码值。
hashCode() - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回此分辨率属性的哈希码值。
hashCode() - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
返回此整数集属性的哈希码值。
hashCode() - 类 javax.print.attribute.Size2DSyntax 中的方法
返回此二维大小属性的哈希码值。
hashCode() - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
返回此属性的哈希码值。
hashCode() - 类 javax.print.attribute.TextSyntax 中的方法
返回此文本属性的哈希码。
hashCode() - 类 javax.print.attribute.URISyntax 中的方法
返回此 URI 属性的哈希码。
hashCode() - 类 javax.print.DocFlavor 中的方法
返回此 DocFlavor 对象的哈希码。
hashCode() - 接口 javax.print.PrintService 中的方法
此方法的实现方式应该与 equals(Object) 具有一致性。
hashCode() - 类 javax.rmi.CORBA.Stub 中的方法
返回对象的哈希码值，对于表示同一远程对象的所有 stub，其哈希码值是相等的。
hashCode(Stub) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.hashCode() 的委托调用。
hashCode() - 类 javax.rmi.ssl.SslRMIClientSocketFactory 中的方法
返回此 SslRMIClientSocketFactory 的哈希码值。
hashCode() - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
返回此 SslRMIServerSocketFactory 的哈希码值。
hashCode() - 类 javax.security.auth.kerberos.DelegationPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回此 KerberosKey 的哈希码。
hashCode() - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
返回此主体的哈希码。
hashCode() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回此 KerberosTicket 的哈希码。
hashCode() - 类 javax.security.auth.kerberos.ServicePermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 javax.security.auth.PrivateCredentialPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 javax.security.auth.Subject 中的方法
返回此 Subject 的哈希码。
hashCode() - 类 javax.security.auth.x500.X500Principal 中的方法
返回此 X500Principal 的哈希码。
hashCode() - 类 javax.security.cert.Certificate 中的方法
返回根据此证书的编码形式得出的证书的哈希码值。
hashCode() - 类 javax.sound.midi.MidiDevice.Info 中的方法
终结 hashcode 方法。
hashCode() - 类 javax.sound.midi.Sequencer.SyncMode 中的方法
终结 hashcode 方法。
hashCode() - 类 javax.sound.sampled.AudioFileFormat.Type 中的方法
终止 hashCode 方法
hashCode() - 类 javax.sound.sampled.AudioFormat.Encoding 中的方法
终止 hashCode 方法
hashCode() - 类 javax.sound.sampled.Control.Type 中的方法
终止 hashCode 方法
hashCode() - 类 javax.sound.sampled.LineEvent.Type 中的方法
终止 hashcode 方法。
hashCode() - 类 javax.sound.sampled.Mixer.Info 中的方法
终止该 hashcode 方法。
hashCode() - 类 javax.sound.sampled.Port.Info 中的方法
终止 hashCode 方法
hashCode() - 类 javax.sound.sampled.ReverbType 中的方法
终止 hashcode 方法。
hashCode() - 类 javax.swing.RowSorter.SortKey 中的方法
返回此 SortKey 的哈希码。
hashCode() - 类 javax.swing.text.html.HTML.UnknownTag 中的方法
返回对应于此标记的字符串的哈希代码。
hashCode() - 类 javax.swing.text.SimpleAttributeSet 中的方法
返回此属性集的哈希代码。
hashCode() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
返回此属性集的一个哈希代码。
hashCode() - 类 javax.swing.text.TabSet 中的方法
返回此 TabStop 集合的哈希代码。
hashCode() - 类 javax.swing.text.TabStop 中的方法
返回此对象的哈希代码。
hashCode() - 类 javax.swing.tree.TreePath 中的方法
返回该对象的 hashCode。
hashCode() - 类 javax.xml.datatype.Duration 中的方法
返回与 equals 方法的定义一致的哈希码。
hashCode() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回与 equals 方法的定义一致的哈希码。
hashCode() - 类 javax.xml.namespace.QName 中的方法
生成此 QName 的哈希码。
hashCode() - 类 org.ietf.jgss.ChannelBinding 中的方法
返回此 ChannelBinding 对象的哈希码值。
hashCode() - 接口 org.ietf.jgss.GSSCredential 中的方法
返回此 GSSCredential 的哈希码值。
hashCode() - 接口 org.ietf.jgss.GSSName 中的方法
返回此 GSSName 的哈希码值。
hashCode() - 类 org.ietf.jgss.Oid 中的方法
返回此 Oid 的哈希码值。
hashCode(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
提供重写委托 CORBA 对象的 hashCode() 方法的实现。
hashCode() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回此 ObjectImpl 对象的哈希码。
HashDocAttributeSet - javax.print.attribute 中的 类
类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。
HashDocAttributeSet() - 类 javax.print.attribute.HashDocAttributeSet 的构造方法
构造一个新的空哈希文档属性集。
HashDocAttributeSet(DocAttribute) - 类 javax.print.attribute.HashDocAttributeSet 的构造方法
构造一个最初使用给定值填充的新哈希文档属性集。
HashDocAttributeSet(DocAttribute[]) - 类 javax.print.attribute.HashDocAttributeSet 的构造方法
构造一个最初使用给定数组中的值填充的新哈希文档属性集。
HashDocAttributeSet(DocAttributeSet) - 类 javax.print.attribute.HashDocAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 DocAttribute 接口。
HashMap<K,V> - java.util 中的 类
基于哈希表的 Map 接口的实现。
HashMap(int, float) - 类 java.util.HashMap 的构造方法
构造一个带指定初始容量和加载因子的空 HashMap。
HashMap(int) - 类 java.util.HashMap 的构造方法
构造一个带指定初始容量和默认加载因子 (0.75) 的空 HashMap。
HashMap() - 类 java.util.HashMap 的构造方法
构造一个具有默认初始容量 (16) 和默认加载因子 (0.75) 的空 HashMap。
HashMap(Map<? extends K, ? extends V>) - 类 java.util.HashMap 的构造方法
构造一个映射关系与指定 Map 相同的新 HashMap。
HashPrintJobAttributeSet - javax.print.attribute 中的 类
类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。
HashPrintJobAttributeSet() - 类 javax.print.attribute.HashPrintJobAttributeSet 的构造方法
构造一个新的空哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttribute) - 类 javax.print.attribute.HashPrintJobAttributeSet 的构造方法
构造一个最初使用给定值填充的新哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttribute[]) - 类 javax.print.attribute.HashPrintJobAttributeSet 的构造方法
构造一个最初使用给定数组中的值填充的新哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttributeSet) - 类 javax.print.attribute.HashPrintJobAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintJobAttribute 接口。
HashPrintRequestAttributeSet - javax.print.attribute 中的 类
类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。
HashPrintRequestAttributeSet() - 类 javax.print.attribute.HashPrintRequestAttributeSet 的构造方法
构造一个新的空打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttribute) - 类 javax.print.attribute.HashPrintRequestAttributeSet 的构造方法
构造一个最初使用给定值填充的新打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttribute[]) - 类 javax.print.attribute.HashPrintRequestAttributeSet 的构造方法
构造一个最初使用给定数组中的值填充的新打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttributeSet) - 类 javax.print.attribute.HashPrintRequestAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 (PrintRequestAttributeSe 接口。
HashPrintServiceAttributeSet - javax.print.attribute 中的 类
类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。
HashPrintServiceAttributeSet() - 类 javax.print.attribute.HashPrintServiceAttributeSet 的构造方法
构造一个新的空哈希打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttribute) - 类 javax.print.attribute.HashPrintServiceAttributeSet 的构造方法
构造一个最初使用给定值填充的新哈希打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttribute[]) - 类 javax.print.attribute.HashPrintServiceAttributeSet 的构造方法
构造一个最初使用给定数组中的值填充的新打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttributeSet) - 类 javax.print.attribute.HashPrintServiceAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintServiceAttribute 接口。
HashSet<E> - java.util 中的 类
此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
HashSet() - 类 java.util.HashSet 的构造方法
构造一个新的空 set，其底层 HashMap 实例的默认初始容量是 16，加载因子是 0.75。
HashSet(Collection<? extends E>) - 类 java.util.HashSet 的构造方法
构造一个包含指定 collection 中的元素的新 set。
HashSet(int, float) - 类 java.util.HashSet 的构造方法
构造一个新的空 set，其底层 HashMap 实例具有指定的初始容量和指定的加载因子。
HashSet(int) - 类 java.util.HashSet 的构造方法
构造一个新的空 set，其底层 HashMap 实例具有指定的初始容量和默认的加载因子（0.75）。
Hashtable<K,V> - java.util 中的 类
此类实现一个哈希表，该哈希表将键映射到相应的值。
Hashtable(int, float) - 类 java.util.Hashtable 的构造方法
用指定初始容量和指定加载因子构造一个新的空哈希表。
Hashtable(int) - 类 java.util.Hashtable 的构造方法
用指定初始容量和默认的加载因子 (0.75) 构造一个新的空哈希表。
Hashtable() - 类 java.util.Hashtable 的构造方法
用默认的初始容量 (11) 和加载因子 (0.75) 构造一个新的空哈希表。
Hashtable(Map<? extends K, ? extends V>) - 类 java.util.Hashtable 的构造方法
构造一个与给定的 Map 具有相同映射关系的新哈希表。
hasInitialContextFactoryBuilder() - 类 javax.naming.spi.NamingManager 中的静态方法
确定是否已经设置了初始上下文工厂生成器。
hasInitialResponse() - 接口 javax.security.sasl.SaslClient 中的方法
确定此机制是否具有可选的初始响应。
hasLayoutAttributes() - 类 java.awt.Font 中的方法
如果此 Font 包含需要额外布局处理的属性，则返回 true。
hasLegalValues() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的合法值集，则返回 true，否则返回 false。
hasLegalValues() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
如果此参数存在指定的合法值的集合，则返回 true，否则返回 false。
hasLegalValues() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的合法值集，则返回 true，否则返回 false。
hasListeners(String) - 类 java.beans.PropertyChangeSupport 中的方法
检查是否存在特定属性的任何侦听器，包括那些已在所有属性上注册的侦听器。
hasListeners(String) - 类 java.beans.VetoableChangeSupport 中的方法
检查是否存在特定属性的侦听器，包括那些已在所有属性上注册的侦听器。
hasLocation(JavaFileManager.Location) - 类 javax.tools.ForwardingJavaFileManager 中的方法
hasLocation(JavaFileManager.Location) - 接口 javax.tools.JavaFileManager 中的方法
确定此文件管理器是否已知某位置。
hasMaxValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的最大值，则返回 true，否则返回 false。
hasMaxValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
如果此参数存在指定的最大值，则返回 true，否则返回 false。
hasMaxValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的最大值，则返回 true，否则返回 false。
hasMinValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的最小值，则返回 true，否则返回 false。
hasMinValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
如果此参数存在指定的最小值，则返回 true，否则返回 false。
hasMinValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
如果此 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的最小值，则返回 true，否则返回 false。
hasMore() - 接口 javax.naming.NamingEnumeration 中的方法
确定枚举中是否还有元素。
hasMoreElements() - 接口 java.util.Enumeration 中的方法
测试此枚举是否包含更多的元素。
hasMoreElements() - 类 java.util.StringTokenizer 中的方法
返回与 hasMoreTokens 方法相同的值。
hasMoreTokens() - 类 java.util.StringTokenizer 中的方法
测试此 tokenizer 的字符串中是否还有更多的可用标记。
hasName() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
hasName() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果当前事件有名称（是 START_ELEMENT 或 END_ELEMENT），则返回 ture，否则返回 false
hasNext() - 类 java.beans.beancontext.BeanContextSupport.BCSIterator 中的方法
hasNext() - 接口 java.util.Iterator 中的方法
如果仍有元素可以迭代，则返回 true。
hasNext() - 接口 java.util.ListIterator 中的方法
以正向遍历列表时，如果列表迭代器有多个元素，则返回 true（换句话说，如果 next 返回一个元素而不是抛出异常，则返回 true）。
hasNext() - 类 java.util.Scanner 中的方法
如果此扫描器的输入中有另一个标记，则返回 true。
hasNext(String) - 类 java.util.Scanner 中的方法
如果下一个标记与从指定字符串构造的模式匹配，则返回 true。
hasNext(Pattern) - 类 java.util.Scanner 中的方法
如果下一个完整标记与指定模式匹配，则返回 true。
hasNext() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
hasNext() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
hasNext() - 接口 javax.xml.stream.XMLEventReader 中的方法
检查是否有多个事件。
hasNext() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果有多个解析事件，则返回 true，如果不再有事件，则返回 false。
hasNextBigDecimal() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextBigDecimal() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 BigDecimal，则返回 true。
hasNextBigInteger() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextBigInteger() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 BigInteger 值，则返回 true。
hasNextBigInteger(int) - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextBigInteger() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 BigInteger 值，则返回 true。
hasNextBoolean() - 类 java.util.Scanner 中的方法
如果通过使用一个从字符串 "true|false" 创建的大小写敏感的模式，此扫描器输入信息中的下一个标记可以解释为一个布尔值，则返回 true。
hasNextByte() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextByte() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个字节值，则返回 true。
hasNextByte(int) - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextByte() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个字节值，则返回 true。
hasNextDouble() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextDouble() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 double 值，则返回 true。
hasNextFloat() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextFloat() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 float 值，则返回 true。
hasNextInt() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextInt() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 int 值，则返回 true。
hasNextInt(int) - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextInt() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 int 值，则返回 true。
hasNextLine() - 类 java.util.Scanner 中的方法
如果在此扫描器的输入中存在另一行，则返回 true。
hasNextLong() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextLong() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 long 值，则返回 true。
hasNextLong(int) - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextLong() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 long 值，则返回 true。
hasNextShort() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextShort() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 short 值，则返回 true。
hasNextShort(int) - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextShort() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 short 值，则返回 true。
hasPrevious() - 接口 java.util.ListIterator 中的方法
如果以逆向遍历列表，列表迭代器有多个元素，则返回 true。
hasQueuedThread(Thread) - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询给定线程是否正在等待获取此锁。
hasQueuedThread(Thread) - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询是否给定线程正在等待获取读取或写入锁。
hasQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
查询是否有等待获取的线程。
hasQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
查询是否有正在等待获取的任何线程。
hasQueuedThreads() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询是否有些线程正在等待获取此锁。
hasQueuedThreads() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询是否所有的线程正在等待获取读取或写入锁。
hasQueuedThreads() - 类 java.util.concurrent.Semaphore 中的方法
查询是否有线程正在等待获取。
hasRaster() - 类 javax.imageio.IIOImage 中的方法
如果此 IIOImage 存储了一个 Raster 而不是 RenderedImage，则返回 true。
hasRelation(String) - 类 javax.management.relation.RelationService 中的方法
用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
hasRelation(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
hasRemaining() - 类 java.nio.Buffer 中的方法
告知在当前位置和限制之间是否有元素。
hasSameRules(TimeZone) - 类 java.util.SimpleTimeZone 中的方法
如果此时区与另一时区具有相同的规则和偏移量，则返回 true。
hasSameRules(TimeZone) - 类 java.util.TimeZone 中的方法
如果此区域和另一个区域具有相同的规则和偏移量，也就是说，如果此区域只可能在 ID 上与另一个区域不同，则返回 true。
hasService(Class) - 接口 java.beans.beancontext.BeanContextServices 中的方法
报告是否可以从此上下文中得到给定服务。
hasService(Class) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
具有一个可被委托的服务。
hasText() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
hasText() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果当前事件具有文本，则返回 true，否则返回 false。
hasThumbnails(int) - 类 javax.imageio.ImageReader 中的方法
如果给定图像具有与之关联的缩略图预览图像，则返回 true。
hasTileWriters() - 类 java.awt.image.BufferedImage 中的方法
返回是否有为写入签出的 tile。
hasTileWriters() - 接口 java.awt.image.WritableRenderedImage 中的方法
返回是否有为写入而签出的 tile。
hasTransparentBounds() - 类 java.util.regex.Matcher 中的方法
查询此匹配器区域边界的透明度。
hasUniformLineMetrics() - 类 java.awt.Font 中的方法
检查此 Font 是否具有统一的行规格。
hasUniformLineMetrics() - 类 java.awt.FontMetrics 中的方法
检查 Font 是否具有统一的行规格。
hasUnsupportedCriticalExtension() - 接口 java.security.cert.X509Extension 中的方法
检查是否存在不支持的关键扩展。
hasWaiters() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
查询是否有线程正在此条件等待。
hasWaiters(AbstractQueuedLongSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
查询是否有线程正在与此同步器关联的给定条件上等待。
hasWaiters() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
查询是否有正在等待此条件的任何线程。
hasWaiters(AbstractQueuedSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
查询是否有线程正在等待给定的、与此同步器相关的条件。
hasWaiters(Condition) - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询是否有些线程正在等待与此锁有关的给定条件。
hasWaiters(Condition) - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询是否有些线程正在等待与写入锁有关的给定条件。
HEAD - 类 javax.swing.text.html.HTML.Tag 中的静态变量
head - 类 javax.swing.text.html.parser.DTD 中的变量
HEADER - 类 javax.accessibility.AccessibleRole 中的静态变量
文本标题
header - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的变量
要将绘制委托给此 UI 的 JTableHeader。
HEADER_RENDERER_PROPERTY - 类 javax.swing.table.TableColumn 中的静态变量
从 Java 2 platform v1.3 开始已过时。
HEADER_ROW - 类 javax.swing.event.TableModelEvent 中的静态变量
标识标题行。
HEADER_VALUE_PROPERTY - 类 javax.swing.table.TableColumn 中的静态变量
从 Java 2 platform v1.3 开始已过时。
headerRenderer - 类 javax.swing.table.TableColumn 中的变量
用于绘制列标题的渲染器。
headerValue - 类 javax.swing.table.TableColumn 中的变量
列的标题值。
HeadlessException - java.awt 中的 异常
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
HeadlessException() - 异常 java.awt.HeadlessException 的构造方法
HeadlessException(String) - 异常 java.awt.HeadlessException 的构造方法
headMap(K, boolean) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
headMap(K) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
headMap(K, boolean) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
headMap(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
headMap(K, boolean) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。
headMap(K) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键值严格小于 toKey。
headMap(K) - 接口 java.util.SortedMap 中的方法
返回此映射的部分视图，其键值严格小于 toKey。
headMap(K, boolean) - 类 java.util.TreeMap 中的方法
headMap(K) - 类 java.util.TreeMap 中的方法
HEADPHONE - 类 javax.sound.sampled.Port.Info 中的静态变量
向耳机插孔发送音频端口类型。
headSet(E, boolean) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
headSet(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
headSet(E, boolean) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement。
headSet(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素严格小于 toElement。
headSet(E) - 接口 java.util.SortedSet 中的方法
返回此 set 的部分视图，其元素严格小于 toElement。
headSet(E, boolean) - 类 java.util.TreeSet 中的方法
headSet(E) - 类 java.util.TreeSet 中的方法
heavyWeightPopupEnabled - 类 javax.swing.ToolTipManager 中的变量
HEBREW - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hebrew”Unicode 字符块的常量。
height - 类 java.awt.Component.BltBufferStrategy 中的变量
height - 类 java.awt.Dimension 中的变量
dimension 的高度，可以使用负值。
height - 类 java.awt.geom.Arc2D.Double 中的变量
完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。
height - 类 java.awt.geom.Arc2D.Float 中的变量
完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。
height - 类 java.awt.geom.Ellipse2D.Double 中的变量
此 Ellipse2D 的总高度。
height - 类 java.awt.geom.Ellipse2D.Float 中的变量
此 Ellipse2D 的总高度。
height - 类 java.awt.geom.Rectangle2D.Double 中的变量
此 Rectangle2D 的高度。
height - 类 java.awt.geom.Rectangle2D.Float 中的变量
此 Rectangle2D 的高度。
height - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
此 RoundRectangle2D 的高度。
height - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
此 RoundRectangle2D 的高度。
HEIGHT - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示基本图像的高度现在可用，并且可从 height 参数中获取此高度到 imageUpdate 回调方法。
height - 类 java.awt.image.Raster 中的变量
此 Raster 的高度。
height - 类 java.awt.image.SampleModel 中的变量
此 SampleModel 描述的图像数据区域的高度（以像素位单位）。
height - 类 java.awt.Rectangle 中的变量
Rectangle 的高度。
height(Component) - 类 javax.swing.Spring 中的静态方法
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的高度定义。
HEIGHT - 类 javax.swing.SpringLayout 中的静态变量
指定组件边界矩形的高度。
HEIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
HEIGHT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
helpButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
helpButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
helpButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
HexBinaryAdapter - javax.xml.bind.annotation.adapters 中的 类
xs:hexBinary 的 XmlAdapter。
HexBinaryAdapter() - 类 javax.xml.bind.annotation.adapters.HexBinaryAdapter 的构造方法
hiddenDivider - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
用于非连续布局模式的分隔符。
hide() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
hide() - 类 java.awt.Dialog 中的方法
已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
hide() - 类 java.awt.Window 中的方法
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
hide() - 类 javax.swing.JInternalFrame 中的方法
hide() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.hide() 的实现。
hide() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
隐藏弹出菜单
hide() - 类 javax.swing.Popup 中的方法
隐藏和移除 Popup。
HIDE_ON_CLOSE - 接口 javax.swing.WindowConstants 中的静态变量
隐藏窗口的默认窗口关闭操作
hidePopup() - 类 javax.swing.JComboBox 中的方法
促使组合框关闭其弹出窗口。
hides(Element, Element) - 接口 javax.lang.model.util.Elements 中的方法
测试一个类型、方法或字段是否隐藏了另一个类型、方法或字段。
hideWindows() - 接口 java.awt.im.spi.InputMethod 中的方法
关闭或隐藏由此输入方法实例或其类打开的所有窗口。
HIERARCHY_BOUNDS_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择层次结构边界事件的事件掩码。
HIERARCHY_CHANGED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示对整个层次结构树进行修改的事件 id。
HIERARCHY_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择层次结构事件的事件掩码。
HIERARCHY_FIRST - 类 java.awt.event.HierarchyEvent 中的静态变量
标记层次结构事件 id 范围的第一个整数 id。
HIERARCHY_LAST - 类 java.awt.event.HierarchyEvent 中的静态变量
标记祖先事件 id 范围的最后一个整数 id。
HIERARCHY_REQUEST_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果在不属于 Node 的位置将任何 Node 插入。
HierarchyBoundsAdapter - java.awt.event 中的 类
用于接收祖先的移动和大小重调事件的抽象适配器类。
HierarchyBoundsAdapter() - 类 java.awt.event.HierarchyBoundsAdapter 的构造方法
HierarchyBoundsListener - java.awt.event 中的 接口
用于接收祖先的移动和大小调整事件的侦听器接口。
hierarchyChanged(HierarchyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 hierarchyChanged 方法处理 hierarchyChanged 事件。
hierarchyChanged(HierarchyEvent) - 接口 java.awt.event.HierarchyListener 中的方法
层次结构已更改时调用。
HierarchyEvent - java.awt.event 中的 类
指示 Component 所属的 Component 层次结构发生更改的事件。
HierarchyEvent(Component, int, Component, Container) - 类 java.awt.event.HierarchyEvent 的构造方法
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
HierarchyEvent(Component, int, Component, Container, long) - 类 java.awt.event.HierarchyEvent 的构造方法
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
HierarchyListener - java.awt.event 中的 接口
用于接收层次结构更改事件的侦听器接口。
HIGH - 类 java.awt.PageAttributes.PrintQualityType 中的静态变量
用于指定高打印质量的 PrintQualityType 实例。
HIGH - 类 javax.print.attribute.standard.PrintQuality 中的静态变量
打印机可提供的最高打印质量。
HIGH_PRIVATE_USE_SURROGATES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“High Private Use Surrogates”Unicode 字符块的常量。
HIGH_SURROGATES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“High Surrogates”Unicode 字符块的常量。
higher(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
higher(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 中严格大于给定元素的最小元素；如果不存在这样的元素，则返回 null。
higher(E) - 类 java.util.TreeSet 中的方法
higherEntry(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与严格大于给定键的最小键关联的键-值映射关系；如果不存在这样的键，则返回 null。
higherEntry(K) - 接口 java.util.NavigableMap 中的方法
返回一个键-值映射关系，它与严格大于给定键的最小键关联；如果不存在这样的键，则返回 null。
higherEntry(K) - 类 java.util.TreeMap 中的方法
higherKey(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
higherKey(K) - 接口 java.util.NavigableMap 中的方法
返回严格大于给定键的最小键；如果不存在这样的键，则返回 null。
higherKey(K) - 类 java.util.TreeMap 中的方法
highestLayer() - 类 javax.swing.JLayeredPane 中的方法
返回所有当前子组件的最高层值。
highestOneBit(int) - 类 java.lang.Integer 中的静态方法
返回具有至多单个 1 位的 int 值，在指定的 int 值中最高位（最左边）的 1 位的位置。
highestOneBit(long) - 类 java.lang.Long 中的静态方法
返回至多有一个 1 位的 long 值，在指定的 long 值中最高位（最左边）的 1 位的位置。
highlight - 类 javax.swing.border.EtchedBorder 中的变量
highlight - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的变量
highlight - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的变量
highlight - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 中的变量
highlight - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的变量
highlight - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
highlightColor - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
Highlighter - javax.swing.text 中的 接口
一个允许用户用带有颜色的区域标出背景的对象接口。
Highlighter.Highlight - javax.swing.text 中的 接口
Highlighter.HighlightPainter - javax.swing.text 中的 接口
呈现高亮显示。
highlightInner - 类 javax.swing.border.BevelBorder 中的变量
highlightOuter - 类 javax.swing.border.BevelBorder 中的变量
HINTS_OBSERVED - 接口 java.awt.image.renderable.RenderableImage 中的静态变量
可以用于在通过 createRendering 或 createScaledRendering 方法获取的 RenderedImage 上标识属性的字符串常量。
HIRAGANA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hiragana”Unicode 字符块的常量。
hit(Rectangle, Shape, boolean) - 类 java.awt.Graphics2D 中的方法
检查指定的 Shape 是否与设备空间中的指定 Rectangle 相交。
hitClip(int, int, int, int) - 类 java.awt.Graphics 中的方法
如果指定的矩形区域与当前的剪贴区域相交，则返回 true。
hitEnd() - 类 java.util.regex.Matcher 中的方法
如果匹配器执行的最后匹配操作中搜索引擎遇到输入结尾，则返回 true。
hitTestChar(float, float, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回对应于指定点的 TextHitInfo。
hitTestChar(float, float) - 类 java.awt.font.TextLayout 中的方法
返回对应于指定点的 TextHitInfo。
hitToPoint(TextHitInfo, Point2D) - 类 java.awt.font.TextLayout 中的方法
将一个命中点转换为标准坐标中的一个点。
HMAC_SHA1 - 接口 javax.xml.crypto.dsig.SignatureMethod 中的静态变量
HMAC-SHA1 MAC 签名方法的算法 URI。
HMACParameterSpec - javax.xml.crypto.dsig.spec 中的 类
XML Signature HMAC Algorithm 的参数。
HMACParameterSpec(int) - 类 javax.xml.crypto.dsig.spec.HMACParameterSpec 的构造方法
创建具有指定截断长度的 HMACParameterSpec。
HOLD_CURSORS_OVER_COMMIT - 接口 java.sql.ResultSet 中的静态变量
该常量指示提交当前事务时，具有此可保存性的打开的 ResultSet 对象将保持开放。
hold_requests(boolean) - 接口 org.omg.PortableServer.POAManagerOperations 中的方法
此操作将 POA 管理器更改为保持 (holding) 状态，促使关联的 POA 将传入请求排队。
Holder<T> - javax.xml.ws 中的 类
包含类型为 T 的值。
Holder() - 类 javax.xml.ws.Holder 的构造方法
创建一个新的持有者，其值为 null。
Holder(T) - 类 javax.xml.ws.Holder 的构造方法
创建具有指定值的新持有者。
HOLDING - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/HOLDING.java。
HOLDING - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
holdsLock(Object) - 类 java.lang.Thread 中的静态方法
当且仅当当前线程在指定的对象上保持监视器锁时，才返回 true。
HOME - 类 java.awt.Event 中的静态变量
Home 键，一个非 ASCII 操作键。
homeFolderIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
homeKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
HONOR_DISPLAY_PROPERTIES - 类 javax.swing.JEditorPane 中的静态变量
用于客户机属性的关键字，指示如果在样式化文本中未指定字体或前景色，那么是否使用该组件的默认字体和前景色。
HORIZONTAL - 接口 java.awt.Adjustable 中的静态变量
指示 Adjustable 具有水平方向。
HORIZONTAL - 类 java.awt.GridBagConstraints 中的静态变量
在水平方向而不是垂直方向上调整组件大小。
HORIZONTAL - 类 java.awt.Scrollbar 中的静态变量
指示一个水平滚动条的常量。
HORIZONTAL - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象的方向为水平方向。
HORIZONTAL - 接口 javax.swing.SwingConstants 中的静态变量
水平方向。
HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的水平对齐方式的更改。
HORIZONTAL_CENTER - 类 javax.swing.SpringLayout 中的静态变量
指定组件边界矩形的水平中央位置。
HORIZONTAL_SCROLLBAR - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识水平滚动条。
HORIZONTAL_SCROLLBAR_ALWAYS - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置水平滚动条策略以使水平滚动条一直显示。
HORIZONTAL_SCROLLBAR_AS_NEEDED - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置水平滚动条策略以使水平滚动条只在需要时显示。
HORIZONTAL_SCROLLBAR_NEVER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置水平滚动条策略以使水平滚动条从不显示。
HORIZONTAL_SCROLLBAR_POLICY - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识水平滚动条策略属性。
HORIZONTAL_SPLIT - 类 javax.swing.JSplitPane 中的静态变量
水平分割表示 Component 沿 x 轴分割。
HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的水平文本位置的更改。
HORIZONTAL_WRAP - 类 javax.swing.JList 中的静态变量
指示“报纸样式”布局，单元按先水平后垂直排列。
horizontalScrollBar - 类 javax.swing.JScrollPane 中的变量
滚动窗格的水平滚动条子级。
horizontalScrollBarPolicy - 类 javax.swing.JScrollPane 中的变量
用于水平滚动条的显示策略。
horizThumbIcon - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
默认水平 thumb Icon。
hostEncoding - 类 javax.print.DocFlavor 中的静态变量
表示主机操作系统编码的 String。
HostnameVerifier - javax.net.ssl 中的 接口
此类是用于主机名验证的基接口。
hostnameVerifier - 类 javax.net.ssl.HttpsURLConnection 中的变量
此对象的 hostnameVerifier。
hostsEqual(URL, URL) - 类 java.net.URLStreamHandler 中的方法
比较两个 URL 的主机组件。
HOUR - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示上午或下午的小时。
HOUR0 - 类 java.text.DateFormat.Field 中的静态变量
标识 HOUR0 字段的常量，其合法的值是 1 到 11。
HOUR0_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐从 0 开始的 HOUR 字段的有用常量。
HOUR1 - 类 java.text.DateFormat.Field 中的静态变量
标识 HOUR1 字段的常量，其合法的值是 1 到 12。
HOUR1_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐从 1 开始的 HOUR 字段的有用常量。
HOUR_OF_DAY - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一天中的小时。
HOUR_OF_DAY0 - 类 java.text.DateFormat.Field 中的静态变量
标识 HOUR_OF_DAY0 字段的常量，其合法的值是 0 到 23。
HOUR_OF_DAY0_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐从 0 开始的 HOUR_OF_DAY 字段的有用常量。
HOUR_OF_DAY1 - 类 java.text.DateFormat.Field 中的静态变量
标识 HOUR_OF_DAY1 字段的常量，其合法的值是 1 到 24。
HOUR_OF_DAY1_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐从 1 开始的 HOUR_OF_DAY 字段的有用常量。
HOURS - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示小时字段的常量。
HR - 类 javax.swing.text.html.HTML.Tag 中的静态变量
HREF - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
hsb - 类 javax.swing.ScrollPaneLayout 中的变量
滚动窗格的子级水平滚动条。
hsbChangeListener - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的变量
hsbPolicy - 类 javax.swing.ScrollPaneLayout 中的变量
水平滚动条的显示策略。
HSBtoRGB(float, float, float) - 类 java.awt.Color 中的静态方法
将由 HSB 模型指定的颜色分量转换为等价的默认 RGB 模型的值的集合。
HSPACE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
HTML - javax.swing.text.html 中的 类
HTMLDocument 中使用的常量。
HTML() - 类 javax.swing.text.html.HTML 的构造方法
HTML - 类 javax.swing.text.html.HTML.Tag 中的静态变量
html - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的变量
要插入的 HTML。
html - 类 javax.swing.text.html.parser.DTD 中的变量
HTML.Attribute - javax.swing.text.html 中的 类
表示 HTML 属性的类型安全的枚举。
HTML.Tag - javax.swing.text.html 中的 类
HTML 标记的类型安全的枚举。
HTML.Tag() - 类 javax.swing.text.html.HTML.Tag 的构造方法
HTML.Tag(String) - 类 javax.swing.text.html.HTML.Tag 的构造方法
创建具有指定 id 的新 Tag，且 causesBreak 和 isBlock 设置为 false。
HTML.Tag(String, boolean, boolean) - 类 javax.swing.text.html.HTML.Tag 的构造方法
创建具有指定 id 的新 Tag；causesBreak 和 isBlock 由用户定义。
HTML.UnknownTag - javax.swing.text.html 中的 类
HTML.UnknownTag(String) - 类 javax.swing.text.html.HTML.UnknownTag 的构造方法
创建具有指定 id 的新 UnknownTag。
HTML_CONTAINER - 类 javax.accessibility.AccessibleRole 中的静态变量
包含一起能表示 HTML 内容的 Accessible 集合的对象。
HTMLDocument - javax.swing.text.html 中的 类
对 HTML 进行建模的文档。
HTMLDocument() - 类 javax.swing.text.html.HTMLDocument 的构造方法
使用默认的缓冲区大小和默认的 StyleSheet 构造 HTML 文档。
HTMLDocument(StyleSheet) - 类 javax.swing.text.html.HTMLDocument 的构造方法
构造具有默认内容存储实现和指定样式/属性存储机制的 HTML 文档。
HTMLDocument(AbstractDocument.Content, StyleSheet) - 类 javax.swing.text.html.HTMLDocument 的构造方法
构造具有给定内容存储实现和给定样式/属性存储机制的 HTML 文档。
HTMLDocument.BlockElement - javax.swing.text.html 中的 类
表示结构性 HTML 块 的元素。
HTMLDocument.BlockElement(Element, AttributeSet) - 类 javax.swing.text.html.HTMLDocument.BlockElement 的构造方法
构造初始不包含子元素的复合元素。
HTMLDocument.HTMLReader - javax.swing.text.html 中的 类
一个 HTML reader，用来加载具有 HTML 元素结构的 HTML 文档。
HTMLDocument.HTMLReader(int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 的构造方法
HTMLDocument.HTMLReader(int, int, int, HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 的构造方法
HTMLDocument.HTMLReader.BlockAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.BlockAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction 的构造方法
HTMLDocument.HTMLReader.CharacterAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.CharacterAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction 的构造方法
HTMLDocument.HTMLReader.FormAction - javax.swing.text.html 中的 类
此动作通过构建所有用于表示表单控件的元素来支持表单。
HTMLDocument.HTMLReader.FormAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction 的构造方法
HTMLDocument.HTMLReader.HiddenAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.HiddenAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction 的构造方法
HTMLDocument.HTMLReader.IsindexAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.IsindexAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction 的构造方法
HTMLDocument.HTMLReader.ParagraphAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.ParagraphAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction 的构造方法
HTMLDocument.HTMLReader.PreAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.PreAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction 的构造方法
HTMLDocument.HTMLReader.SpecialAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.SpecialAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction 的构造方法
HTMLDocument.HTMLReader.TagAction - javax.swing.text.html 中的 类
为响应对标记的解析而执行的动作。
HTMLDocument.HTMLReader.TagAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 的构造方法
HTMLDocument.Iterator - javax.swing.text.html 中的 类
对特定类型的标记进行迭代的迭代器。
HTMLDocument.Iterator() - 类 javax.swing.text.html.HTMLDocument.Iterator 的构造方法
HTMLDocument.RunElement - javax.swing.text.html 中的 类
表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。
HTMLDocument.RunElement(Element, AttributeSet, int, int) - 类 javax.swing.text.html.HTMLDocument.RunElement 的构造方法
构造表示文档内部（没有子级）内容的元素。
HTMLEditorKit - javax.swing.text.html 中的 类
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。
HTMLEditorKit() - 类 javax.swing.text.html.HTMLEditorKit 的构造方法
构造 HTMLEditorKit，创建 StyleContext，并加载样式表。
HTMLEditorKit.HTMLFactory - javax.swing.text.html 中的 类
用于构建 HTML 视图的工厂。
HTMLEditorKit.HTMLFactory() - 类 javax.swing.text.html.HTMLEditorKit.HTMLFactory 的构造方法
HTMLEditorKit.HTMLTextAction - javax.swing.text.html 中的 类
提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
HTMLEditorKit.HTMLTextAction(String) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 的构造方法
HTMLEditorKit.InsertHTMLTextAction - javax.swing.text.html 中的 类
InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。
HTMLEditorKit.InsertHTMLTextAction(String, String, HTML.Tag, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 的构造方法
HTMLEditorKit.InsertHTMLTextAction(String, String, HTML.Tag, HTML.Tag, HTML.Tag, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 的构造方法
HTMLEditorKit.LinkController - javax.swing.text.html 中的 类
此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。
HTMLEditorKit.LinkController() - 类 javax.swing.text.html.HTMLEditorKit.LinkController 的构造方法
HTMLEditorKit.Parser - javax.swing.text.html 中的 类
解析器要支持的接口。
HTMLEditorKit.Parser() - 类 javax.swing.text.html.HTMLEditorKit.Parser 的构造方法
HTMLEditorKit.ParserCallback - javax.swing.text.html 中的 类
解析结果驱动这些回调方法。
HTMLEditorKit.ParserCallback() - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 的构造方法
HTMLFrameHyperlinkEvent - javax.swing.text.html 中的 类
HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String) - 类 javax.swing.text.html.HTMLFrameHyperlinkEvent 的构造方法
创建一个表示 html 框架超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, String) - 类 javax.swing.text.html.HTMLFrameHyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, Element, String) - 类 javax.swing.text.html.HTMLFrameHyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, String) - 类 javax.swing.text.html.HTMLFrameHyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HTMLWriter - javax.swing.text.html 中的 类
这是用于 HTMLDocuments 的 writer。
HTMLWriter(Writer, HTMLDocument) - 类 javax.swing.text.html.HTMLWriter 的构造方法
创建新的 HTMLWriter。
HTMLWriter(Writer, HTMLDocument, int, int) - 类 javax.swing.text.html.HTMLWriter 的构造方法
创建新的 HTMLWriter。
HTTP - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
超文本传输协议 (HTTP)。
HTTP_ACCEPTED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 202：Accepted。
HTTP_BAD_GATEWAY - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 502：Bad Gateway。
HTTP_BAD_METHOD - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 405：Method Not Allowed。
HTTP_BAD_REQUEST - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 400：Bad Request。
HTTP_BINDING - 接口 javax.xml.ws.http.HTTPBinding 中的静态变量
表示 XML/HTTP 绑定标识的常量。
HTTP_CLIENT_TIMEOUT - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 408：Request Time-Out。
HTTP_CONFLICT - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 409：Conflict。
HTTP_CREATED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 201：Created。
HTTP_ENTITY_TOO_LARGE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 413：Request Entity Too Large。
HTTP_FORBIDDEN - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 403：Forbidden。
HTTP_GATEWAY_TIMEOUT - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 504：Gateway Timeout。
HTTP_GONE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 410：Gone。
HTTP_INTERNAL_ERROR - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 500：Internal Server Error。
HTTP_LENGTH_REQUIRED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 411：Length Required。
HTTP_MOVED_PERM - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 301：Moved Permanently。
HTTP_MOVED_TEMP - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 302：Temporary Redirect。
HTTP_MULT_CHOICE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 300：Multiple Choices。
HTTP_NO_CONTENT - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 204：No Content。
HTTP_NOT_ACCEPTABLE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 406：Not Acceptable。
HTTP_NOT_AUTHORITATIVE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 203：Non-Authoritative Information。
HTTP_NOT_FOUND - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 404：Not Found。
HTTP_NOT_IMPLEMENTED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 501：Not Implemented。
HTTP_NOT_MODIFIED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 304：Not Modified。
HTTP_OK - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 200：OK。
HTTP_PARTIAL - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 206：Partial Content。
HTTP_PAYMENT_REQUIRED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 402：Payment Required。
HTTP_PRECON_FAILED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 412：Precondition Failed。
HTTP_PROXY_AUTH - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 407：Proxy Authentication Required。
HTTP_REQ_TOO_LONG - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 414：Request-URI Too Large。
HTTP_REQUEST_HEADERS - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：HTTP 请求头。
HTTP_REQUEST_METHOD - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：HTTP 请求方法。
HTTP_RESET - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 205：Reset Content。
HTTP_RESPONSE_CODE - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：HTTP 响应状态代码。
HTTP_RESPONSE_HEADERS - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：HTTP 响应头。
HTTP_SEE_OTHER - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 303：See Other。
HTTP_SERVER_ERROR - 类 java.net.HttpURLConnection 中的静态变量
已过时。 放错了位置，它不应该存在。
HTTP_UNAUTHORIZED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 401：Unauthorized。
HTTP_UNAVAILABLE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 503：Service Unavailable。
HTTP_UNSUPPORTED_TYPE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 415：Unsupported Media Type。
HTTP_USE_PROXY - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 305：Use Proxy。
HTTP_VERSION - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 505：HTTP Version Not Supported。
HTTPBinding - javax.xml.ws.http 中的 接口
HTTPBinding 接口是 XML/HTTP 绑定的抽象。
HttpCookie - java.net 中的 类
HttpCookie 对象表示一个 http cookie，该 cookie 带有服务器和用户代理之间的状态信息。
HttpCookie(String, String) - 类 java.net.HttpCookie 的构造方法
构造带有指定名称和值的 cookie。
HTTPEQUIV - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
HTTPException - javax.xml.ws.http 中的 异常
HTTPException 异常表示一个 XML/HTTP 故障。
HTTPException(int) - 异常 javax.xml.ws.http.HTTPException 的构造方法
HTTPException 的构造方法
HttpRetryException - java.net 中的 异常
抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
HttpRetryException(String, int) - 异常 java.net.HttpRetryException 的构造方法
根据指定的响应代码和异常详细消息构造新 HttpRetryException。
HttpRetryException(String, int, String) - 异常 java.net.HttpRetryException 的构造方法
构造一个新 HttpRetryException，使其具有详细消息 responseCode 和 Location 响应头字段的内容。
HTTPS - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
安全超文本传输协议 (HTTPS)。
HttpsURLConnection - javax.net.ssl 中的 类
HttpsURLConnection 扩展 HttpURLConnection，支持各种特定于 https 功能。
HttpsURLConnection(URL) - 类 javax.net.ssl.HttpsURLConnection 的构造方法
使用指定的 URL 创建 HttpsURLConnection。
HttpURLConnection - java.net 中的 类
支持 HTTP 特定功能的 URLConnection。
HttpURLConnection(URL) - 类 java.net.HttpURLConnection 的构造方法
HttpURLConnection 的构造方法。
HUFFMAN_ONLY - 类 java.util.zip.Deflater 中的静态变量
仅适用于 Huffman 编码的压缩策略。
HYPERLINK - 类 javax.accessibility.AccessibleRole 中的静态变量
超文本锚
HyperlinkEvent - javax.swing.event 中的 类
HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL) - 类 javax.swing.event.HyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String) - 类 javax.swing.event.HyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element) - 类 javax.swing.event.HyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HyperlinkEvent.EventType - javax.swing.event 中的 类
定义 ENTERED、EXITED 和 ACTIVATED 事件类型，以及由 toString() 返回的这些事件类型的字符串表示形式。
HyperlinkListener - javax.swing.event 中的 接口
HyperlinkListener
hyperlinkUpdate(HyperlinkEvent) - 接口 javax.swing.event.HyperlinkListener 中的方法
在更新超文本链接时调用。
hypot(double, double) - 类 java.lang.Math 中的静态方法
返回 sqrt(x2 +y2)，没有中间溢出或下溢。
hypot(double, double) - 类 java.lang.StrictMath 中的静态方法
返回 sqrt(x2 +y2)，没有中间溢出或下溢。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


I - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

I

I - 类 javax.swing.text.html.HTML.Tag 中的静态变量
icAbsoluteColorimetric - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：AbsoluteColorimetric。
ICC_ColorSpace - java.awt.color 中的 类
ICC_ColorSpace 类是抽象 ColorSpace 类的实现。
ICC_ColorSpace(ICC_Profile) - 类 java.awt.color.ICC_ColorSpace 的构造方法
由 ICC_Profile 对象构造一个新的 ICC_ColorSpace。
ICC_Profile - java.awt.color 中的 类
与设备无关和设备相关颜色空间的颜色配置文件数据表示形式，该表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。
ICC_ProfileGray - java.awt.color 中的 类
ICC_Profile 类的子类，表示满足以下标准的配置文件：配置文件的颜色空间类型是 TYPE_GRAY，并且配置文件包括 grayTRCTag 和 mediaWhitePointTag 标记。
ICC_ProfileRGB - java.awt.color 中的 类
ICC_ProfileRGB 类是 ICC_Profile 类的子类，它表示满足以下标准的配置文件： 配置文件的颜色空间类型是 RGB。
icCurveCount - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件常量：curveType 计数。
icCurveData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件常量：curveType 数据。
icHdrAttributes - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：设备属性。
icHdrCmmId - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：此配置文件的 CMM。
icHdrColorSpace - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：数据的颜色空间。
icHdrCreator - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：配置文件创建者。
icHdrDate - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：创建的日期配置文件。
icHdrDeviceClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：配置文件类型。
icHdrFlags - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：各种位设置。
icHdrIlluminant - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：配置文件光源。
icHdrMagic - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：icMagicNumber。
icHdrManufacturer - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：设备制造商。
icHdrModel - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：设备型号。
icHdrPcs - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：PCS - XYZ 或 Lab。
icHdrPlatform - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：原始平台。
icHdrProfileID - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：配置文件的 ID。
icHdrRenderingIntent - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：呈现目的。
icHdrSize - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：以字节为单位的配置文件的大小。
icHdrVersion - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：格式版本号。
icICCAbsoluteColorimetric - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：ICC-AbsoluteColorimetric。
icMediaRelativeColorimetric - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：Media-RelativeColorimetric。
ICON - 类 javax.accessibility.AccessibleRole 中的静态变量
一个固定大小的小图片，通常用于装饰组件。
Icon - javax.swing 中的 接口
一个小的固定大小图片，通常用于装饰组件。
icon - 类 javax.swing.JOptionPane 中的变量
在窗格中使用的图标。
icon - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的变量
ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对表示该按钮的图标的更改。
ICON_COLOR_16x16 - 接口 java.beans.BeanInfo 中的静态变量
指示 16 x 16 彩色图标的常量。
ICON_COLOR_32x32 - 接口 java.beans.BeanInfo 中的静态变量
指示 32 x 32 彩色图标的常量。
ICON_MONO_16x16 - 接口 java.beans.BeanInfo 中的静态变量
指示 16 x 16 单色图标的常量。
ICON_MONO_32x32 - 接口 java.beans.BeanInfo 中的静态变量
指示 32 x 32 单色图标的常量。
ICON_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
icon 的绑定属性名。
iconable - 类 javax.swing.JInternalFrame 中的变量
可以“图标化”窗体（缩小并显示为图标图像）。
IconAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
图标属性的名称。
iconButton - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
iconCache - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的变量
IconElementName - 类 javax.swing.text.StyleConstants 中的静态变量
用于表示图标的元素名称。
iconIcon - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
ICONIFIED - 类 java.awt.Frame 中的静态变量
此状态位指示将窗体图标化。
ICONIFIED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是最小化的，并只通过一个图标来表示。
ICONIFY_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
iconifyAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
iconifyFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
从父窗体中移除窗体，并将其 desktopIcon 添加到父窗体中。
iconifyFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常从父窗体中移除此窗体，并添加一个图标表示形式。
iconifyFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
当用户要图标化窗体时调用此方法。
iconOnly - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的变量
iconPane - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的变量
在桌面图标中使用的标题窗格组件。
IconUIResource - javax.swing.plaf 中的 类
实现 UIResource 的 Icon 包装类。
IconUIResource(Icon) - 类 javax.swing.plaf.IconUIResource 的构造方法
创建一个 UIResource 图标对象，该对象包装了一个现有 Icon 实例。
IconView - javax.swing.text 中的 类
实现视图接口的图标修饰符。
IconView(Element) - 类 javax.swing.text.IconView 的构造方法
创建表示元素的新图标视图。
icPerceptual - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：Perceptual。
icRelativeColorimetric - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：RelativeColorimetric。
icSaturation - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：Saturation。
icSigAbstractClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'abst'。
icSigAToB0Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'A2B0'。
icSigAToB1Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'A2B1'。
icSigAToB2Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'A2B2'。
icSigBlueColorantTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'bXYZ'。
icSigBlueMatrixColumnTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'bXYZ'。
icSigBlueTRCTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'bTRC'。
icSigBToA0Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'B2A0'。
icSigBToA1Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'B2A1'。
icSigBToA2Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'B2A2'。
icSigCalibrationDateTimeTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'calt'。
icSigCharTargetTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'targ'。
icSigChromaticAdaptationTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'chad'。
icSigChromaticityTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'chrm'。
icSigCmyData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'CMY '。
icSigCmykData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'CMYK'。
icSigColorantOrderTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'clro'。
icSigColorantTableTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'clrt'。
icSigColorSpaceClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'spac'。
icSigCopyrightTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'cprt'。
icSigCrdInfoTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'crdi'。
icSigDeviceMfgDescTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'dmnd'。
icSigDeviceModelDescTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'dmdd'。
icSigDeviceSettingsTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'devs'。
icSigDisplayClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'mntr'。
icSigGamutTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'gamt'。
icSigGrayData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'GRAY'。
icSigGrayTRCTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'kTRC'。
icSigGreenColorantTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'gXYZ'。
icSigGreenMatrixColumnTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'gXYZ'。
icSigGreenTRCTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'gTRC'。
icSigHead - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'head' - 专用。
icSigHlsData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'HLS'。
icSigHsvData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'HSV'。
icSigInputClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'scnr'。
icSigLabData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'Lab '。
icSigLinkClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'link'。
icSigLuminanceTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'lumi'。
icSigLuvData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'Luv '。
icSigMeasurementTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'meas'。
icSigMediaBlackPointTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'bkpt'。
icSigMediaWhitePointTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'wtpt'。
icSigNamedColor2Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'ncl2'。
icSigNamedColorClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'nmcl'。
icSigOutputClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'prtr'。
icSigOutputResponseTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'resp'。
icSigPreview0Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'pre0'。
icSigPreview1Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'pre1'。
icSigPreview2Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'pre2'。
icSigProfileDescriptionTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'desc'。
icSigProfileSequenceDescTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'pseq'。
icSigPs2CRD0Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'psd0'。
icSigPs2CRD1Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'psd1'。
icSigPs2CRD2Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'psd2'。
icSigPs2CRD3Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'psd3'。
icSigPs2CSATag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'ps2s'。
icSigPs2RenderingIntentTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'ps2i'。
icSigRedColorantTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'rXYZ'。
icSigRedMatrixColumnTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'rXYZ'。
icSigRedTRCTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'rTRC'。
icSigRgbData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'RGB '。
icSigScreeningDescTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'scrd'。
icSigScreeningTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'scrn'。
icSigSpace2CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'2CLR'。
icSigSpace3CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'3CLR'。
icSigSpace4CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'4CLR'。
icSigSpace5CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'5CLR'。
icSigSpace6CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'6CLR'。
icSigSpace7CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'7CLR'。
icSigSpace8CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'8CLR'。
icSigSpace9CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'9CLR'。
icSigSpaceACLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'ACLR'。
icSigSpaceBCLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'BCLR'。
icSigSpaceCCLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'CCLR'。
icSigSpaceDCLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'DCLR'。
icSigSpaceECLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'ECLR'。
icSigSpaceFCLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'FCLR'。
icSigTechnologyTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'tech'。
icSigUcrBgTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'bfd '。
icSigViewingCondDescTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'vued'。
icSigViewingConditionsTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'view'。
icSigXYZData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'XYZ '。
icSigYCbCrData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'YCbr'。
icSigYxyData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'Yxy '。
icTagReserved - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件常量：保留。
icTagType - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件常量：标记类型 signaturE。
icXYZNumberX - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件常量：XYZNumber X。
id - 类 java.awt.AWTEvent 中的变量
事件的 id。
id - 类 java.awt.Event 中的变量
指示事件是什么类型的事件，其他哪个 Event 变量与该事件有关。
id - 类 javax.naming.ldap.BasicControl 中的变量
控件的对象标识符字符串。
ID - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ID - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
id() - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
id() - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
id() - 类 org.omg.CORBA.CurrentHelper 中的静态方法
id() - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
id() - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
id() - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
id() - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
id() - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
id - 类 org.omg.CORBA.NameValuePair 中的变量
将通过此 NameValuePair 对象与某一值关联的名称。
id() - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
id() - 类 org.omg.CORBA.ObjectHelper 中的静态方法
id() - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
id() - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
id() - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
id() - 类 org.omg.CORBA.PolicyHelper 中的静态方法
id() - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
id() - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
id() - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
id() - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
id() - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
id() - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
id() - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.StringValueHelper 中的静态方法
id() - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
id() - 类 org.omg.CORBA.TypeCode 中的方法
检索全局标识此 TypeCode 对象类型的 RepositoryId。
id() - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
id() - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
id() - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
id - 类 org.omg.CORBA.ValueMember 中的变量
此 ValueMember 对象所描述的 value 成员的存储库 ID
id() - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
id() - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
id() - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
id() - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
id() - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
id() - 类 org.omg.CosNaming.BindingHelper 中的静态方法
id() - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
id() - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
id() - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
id() - 类 org.omg.CosNaming.IstringHelper 中的静态方法
id - 类 org.omg.CosNaming.NameComponent 中的变量
id() - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
id() - 类 org.omg.CosNaming.NameHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
id() - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
id() - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
id - 类 org.omg.DynamicAny.NameDynAnyPair 中的变量
与 DynAny 关联的名称。
id() - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
id() - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
id - 类 org.omg.DynamicAny.NameValuePair 中的变量
与 Any 有关联的名称。
id() - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
id() - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
id() - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
id() - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
id() - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
id() - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
id() - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
id() - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
id() - 类 org.omg.IOP.IORHelper 中的静态方法
id() - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
id() - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
id() - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
id() - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
id() - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
id() - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
id() - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
id() - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
id() - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
id() - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
id() - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
id() - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作在 POA 的创建过程中返回该 POA 的唯一 id。
id() - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
id() - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
id() - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
ID_ASSIGNMENT_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java。
id_to_reference(byte[]) - 接口 org.omg.PortableServer.POAOperations 中的方法
如果具有指定 Object Id 值的对象当前不是激活状态，则返回一个封装激活该对象时所用信息的引用。
id_to_servant(byte[]) - 接口 org.omg.PortableServer.POAOperations 中的方法
如果 POA 具有 RETAIN 策略并且指定的 ObjectId 存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
ID_UNIQUENESS_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java。
IdAssignmentPolicy - org.omg.PortableServer 中的 接口
IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
IdAssignmentPolicyOperations - org.omg.PortableServer 中的 接口
IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
IdAssignmentPolicyValue - org.omg.PortableServer 中的 类
IdAssignmentPolicyValue 可以具有以下值。
IdAssignmentPolicyValue(int) - 类 org.omg.PortableServer.IdAssignmentPolicyValue 的构造方法
IDENTICAL - 类 java.text.Collator 中的静态变量
Collator 的 strength 值。
identifier - 类 javax.swing.table.TableColumn 中的变量
根据 JTable 的绘制机制，此对象不会在内部使用；可在 TableColumn 中设置标识符，并将其作为标记和定位表列的可选方式。
IdentifierHelper - org.omg.CORBA 中的 类
Identifier 的 Helper。
IdentifierHelper() - 类 org.omg.CORBA.IdentifierHelper 的构造方法
identities() - 类 java.security.IdentityScope 中的方法
已过时。 返回此身份作用域内所有身份的枚举。
IDENTITY - 类 java.awt.font.TransformAttribute 中的静态变量
表示恒等变换的 TransformAttribute。
Identity - java.security 中的 类
已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
Identity() - 类 java.security.Identity 的构造方法
已过时。 只用于序列化的构造器。
Identity(String, IdentityScope) - 类 java.security.Identity 的构造方法
已过时。 构造一个具有指定名称和作用域的 Identity。
Identity(String) - 类 java.security.Identity 的构造方法
已过时。 构造一个具有指定名称且没有作用域的 Identity。
identityEquals(Identity) - 类 java.security.Identity 中的方法
已过时。 测试指定 Identity 与此 Identity 的相等性。
identityHashCode(Object) - 类 java.lang.System 中的静态方法
返回给定对象的哈希码，该代码与默认的方法 hashCode() 返回的代码一样，无论给定对象的类是否重写 hashCode()。
IdentityHashMap<K,V> - java.util 中的 类
此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
IdentityHashMap() - 类 java.util.IdentityHashMap 的构造方法
构造一个具有默认期望最大数量 (21) 的新的空标识哈希映射。
IdentityHashMap(int) - 类 java.util.IdentityHashMap 的构造方法
构造一个具有指定期望最大数量的新的空映射。
IdentityHashMap(Map<? extends K, ? extends V>) - 类 java.util.IdentityHashMap 的构造方法
构造包含指定映射中键-值映射关系的新标识哈希映射。
IdentityScope - java.security 中的 类
已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
IdentityScope() - 类 java.security.IdentityScope 的构造方法
已过时。 此构造方法只用于序列化，不能被子类使用。
IdentityScope(String) - 类 java.security.IdentityScope 的构造方法
已过时。 构造具有指定名称的新身份作用域。
IdentityScope(String, IdentityScope) - 类 java.security.IdentityScope 的构造方法
已过时。 构造具有指定名称和作用域的新身份作用域。
IDEOGRAPHIC_DESCRIPTION_CHARACTERS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Ideographic Description Characters”Unicode 字符块的常量。
IDLE - 类 javax.print.attribute.standard.PrinterState 中的静态变量
指示可以开始处理新作业，无需等待。
IDLEntity - org.omg.CORBA.portable 中的 接口
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
IDLType - org.omg.CORBA 中的 接口
由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
IDLTypeHelper - org.omg.CORBA 中的 类
IDLType 的 Helper。
IDLTypeHelper() - 类 org.omg.CORBA.IDLTypeHelper 的构造方法
IDLTypeOperations - org.omg.CORBA 中的 接口
此接口必须由所有 IDLType 对象实现。
IDN - java.net 中的 类
提供在普通 Unicode 表示形式和 ASCII 兼容性编码 (ACE) 表示形式之间进行国际化域名 (IDN) 转换的方法。
IDREF - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
IDREFS - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
IdUniquenessPolicy - org.omg.PortableServer 中的 接口
IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
IdUniquenessPolicyOperations - org.omg.PortableServer 中的 接口
IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
IdUniquenessPolicyValue - org.omg.PortableServer 中的 类
IdUniquenessPolicyValue 可以具有以下值。
IdUniquenessPolicyValue(int) - 类 org.omg.PortableServer.IdUniquenessPolicyValue 的构造方法
IEEEremainder(double, double) - 类 java.lang.Math 中的静态方法
按照 IEEE 754 标准的规定，对两个参数进行余数运算。
IEEEremainder(double, double) - 类 java.lang.StrictMath 中的静态方法
按照 IEEE 754 标准的规定，对两个参数进行余数运算。
ifModifiedSince - 类 java.net.URLConnection 中的变量
有些协议支持跳过对象获取，除非该对象在某个特定时间点之后又进行了修改。
ignorableWhitespace(char[], int, int) - 接口 org.xml.sax.ContentHandler 中的方法
接收元素内容中可忽略的空白的通知。
ignorableWhitespace(char[], int, int) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收元素内容中可忽略的空白的通知。
ignorableWhitespace(char[], int, int) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收元素内容中可忽略的空白的通知。
ignorableWhitespace(char[], int, int) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收元素内容中可忽略空白的通知。
ignorableWhitespace(char[], int, int) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
ignorableWhitespace(char[], int, int) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个可忽略空格的事件。
ignorableWhitespace(char[], int, int) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 忽略空白事件。
IGNORE - 类 java.nio.charset.CodingErrorAction 中的静态变量
指示通过删除错误输入和恢复编码操作来处理编码错误的操作。
IGNORE_ALL_BEANINFO - 类 java.beans.Introspector 中的静态变量
IGNORE_IMMEDIATE_BEANINFO - 类 java.beans.Introspector 中的静态变量
ignoreMetadata - 类 javax.imageio.ImageReader 中的变量
如果当前输入源已经被 setInput 标记为允许忽略元数据，则为 true。
IIOByteBuffer - javax.imageio.stream 中的 类
表示对某个字节数组及该数组中偏移量和长度的可变引用的类。
IIOByteBuffer(byte[], int, int) - 类 javax.imageio.stream.IIOByteBuffer 的构造方法
构造一个引用给定字节数组、偏移量和长度的 IIOByteBuffer。
IIOException - javax.imageio 中的 异常
该异常类用于发出关于读取和写入操作的运行时故障的信号。
IIOException(String) - 异常 javax.imageio.IIOException 的构造方法
构造带有给定消息 String 的 IIOException。
IIOException(String, Throwable) - 异常 javax.imageio.IIOException 的构造方法
构造一个 IIOException，使其带有给定消息 String 以及作为其底层 cause 的 Throwable。
IIOImage - javax.imageio 中的 类
一个聚集图像、缩略（预览）图像集和表示与图像关联的元数据的对象的简单容器类。
IIOImage(RenderedImage, List<? extends BufferedImage>, IIOMetadata) - 类 javax.imageio.IIOImage 的构造方法
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。
IIOImage(Raster, List<? extends BufferedImage>, IIOMetadata) - 类 javax.imageio.IIOImage 的构造方法
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。
IIOInvalidTreeException - javax.imageio.metadata 中的 异常
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。
IIOInvalidTreeException(String, Node) - 异常 javax.imageio.metadata.IIOInvalidTreeException 的构造方法
构造一个 IIOInvalidTreeException，使其具有消息字符串和对导致解析错误的 Node 的引用。
IIOInvalidTreeException(String, Throwable, Node) - 异常 javax.imageio.metadata.IIOInvalidTreeException 的构造方法
构造一个 IIOInvalidTreeException，使其具有消息字符串、对导致此异常的异常的引用和导致解析错误的 Node 的引用。
IIOMetadata - javax.imageio.metadata 中的 类
将由表示与图像和流关联的元数据（非图像数据）的对象扩展的抽象类。
IIOMetadata() - 类 javax.imageio.metadata.IIOMetadata 的构造方法
构造一个空的 IIOMetadata 对象。
IIOMetadata(boolean, String, String, String[], String[]) - 类 javax.imageio.metadata.IIOMetadata 的构造方法
构造一个 IIOMetadata 对象，使其带有给定格式名称和格式类名称，以及指示是否支持标准格式的 boolean 值。
IIOMetadataController - javax.imageio.metadata 中的 接口
该接口将由可以确定 IIOMetadata 对象设置值（通过提供一个 GUI 来从用户那里获取值或其他方式）的对象实现。
IIOMetadataFormat - javax.imageio.metadata 中的 接口
描述从 IIOMetadata.getAsTree 返回并传递给 IIOMetadata.setFromTree 和 mergeTree 的元数据文档结构的对象。
IIOMetadataFormatImpl - javax.imageio.metadata 中的 类
提供 IIOMetadataFormat 接口的可重用实现的具体类。
IIOMetadataFormatImpl(String, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 的构造方法
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略（CHILD_POLICY_REPEAT 除外）。
IIOMetadataFormatImpl(String, int, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 的构造方法
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略 CHILD_POLICY_REPEAT。
IIOMetadataNode - javax.imageio.metadata 中的 类
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。
IIOMetadataNode() - 类 javax.imageio.metadata.IIOMetadataNode 的构造方法
构造一个空的 IIOMetadataNode。
IIOMetadataNode(String) - 类 javax.imageio.metadata.IIOMetadataNode 的构造方法
构造一个具有给定节点名称的 IIOMetadataNode。
IIOParam - javax.imageio 中的 类
所有描述应该如何对流进行编码和解码的类的超类。
IIOParam() - 类 javax.imageio.IIOParam 的构造方法
受保护的构造方法，只能由子类调用。
IIOParamController - javax.imageio 中的 接口
该接口将由可以确定 IIOParam 对象设置值（通过提供一个 GUI 来从用户那里获取值或其他方式）的对象实现。
IIOReadProgressListener - javax.imageio.event 中的 接口
供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关进度的接口。
IIOReadUpdateListener - javax.imageio.event 中的 接口
供 ImageReader 实现用于通知其图像和缩略图的调用者相关像素更新的接口。
IIOReadWarningListener - javax.imageio.event 中的 接口
供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。
IIORegistry - javax.imageio.spi 中的 类
用于服务提供者实例的注册表。
IIOServiceProvider - javax.imageio.spi 中的 类
一个常用于所有 Image I/O 服务提供者接口 (SPI) 的功能性超接口。
IIOServiceProvider(String, String) - 类 javax.imageio.spi.IIOServiceProvider 的构造方法
构造一个具有给定供应商名称和版本标识符的 IIOServiceProvider。
IIOServiceProvider() - 类 javax.imageio.spi.IIOServiceProvider 的构造方法
构造一个空的 IIOServiceProvider。
IIOWriteProgressListener - javax.imageio.event 中的 接口
供 ImageWriter 实现用于通知其图像和缩略图写入方法的调用者相关进度的方法。
IIOWriteWarningListener - javax.imageio.event 中的 接口
供 ImageWriter 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。
IllegalAccessError - java.lang 中的 错误
当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
IllegalAccessError() - 错误 java.lang.IllegalAccessError 的构造方法
构造不带详细消息的 IllegalAccessError。
IllegalAccessError(String) - 错误 java.lang.IllegalAccessError 的构造方法
构造带指定详细消息的 IllegalAccessError。
IllegalAccessException - java.lang 中的 异常
当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
IllegalAccessException() - 异常 java.lang.IllegalAccessException 的构造方法
构造不带详细消息的 IllegalAccessException 。
IllegalAccessException(String) - 异常 java.lang.IllegalAccessException 的构造方法
构造带指定详细消息的 IllegalAccessException。
IllegalArgumentException - java.lang 中的 异常
抛出的异常表明向方法传递了一个不合法或不正确的参数。
IllegalArgumentException() - 异常 java.lang.IllegalArgumentException 的构造方法
构造不带详细消息的 IllegalArgumentException。
IllegalArgumentException(String) - 异常 java.lang.IllegalArgumentException 的构造方法
构造带指定详细消息的 IllegalArgumentException。
IllegalArgumentException(String, Throwable) - 异常 java.lang.IllegalArgumentException 的构造方法
根据指定的详细消息和原因构造一个新异常。
IllegalArgumentException(Throwable) - 异常 java.lang.IllegalArgumentException 的构造方法
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息构造一个新异常（它通常包含 cause 的类和详细消息）。
IllegalBlockingModeException - java.nio.channels 中的 异常
当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
IllegalBlockingModeException() - 异常 java.nio.channels.IllegalBlockingModeException 的构造方法
构造此类的一个实例。
IllegalBlockSizeException - javax.crypto 中的 异常
如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
IllegalBlockSizeException() - 异常 javax.crypto.IllegalBlockSizeException 的构造方法
构造不带详细信息的 IllegalBlockSizeException。
IllegalBlockSizeException(String) - 异常 javax.crypto.IllegalBlockSizeException 的构造方法
构造带指定详细信息的 IllegalBlockSizeException。
IllegalCharsetNameException - java.nio.charset 中的 异常
将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
IllegalCharsetNameException(String) - 异常 java.nio.charset.IllegalCharsetNameException 的构造方法
构造此类的一个实例。
IllegalClassFormatException - java.lang.instrument 中的 异常
当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。
IllegalClassFormatException() - 异常 java.lang.instrument.IllegalClassFormatException 的构造方法
构造不带详细消息的 IllegalClassFormatException。
IllegalClassFormatException(String) - 异常 java.lang.instrument.IllegalClassFormatException 的构造方法
构造具有指定详细消息的 IllegalClassFormatException。
IllegalComponentStateException - java.awt 中的 异常
当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。
IllegalComponentStateException() - 异常 java.awt.IllegalComponentStateException 的构造方法
构造不带详细消息的 IllegalComponentStateException。
IllegalComponentStateException(String) - 异常 java.awt.IllegalComponentStateException 的构造方法
构造带指定详细消息的 IllegalComponentStateException。
IllegalFormatCodePointException - java.util 中的 异常
将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
IllegalFormatCodePointException(int) - 异常 java.util.IllegalFormatCodePointException 的构造方法
构造此类的实例，使其具有 Character.isValidCodePoint(int) 所定义的指定非法代码点。
IllegalFormatConversionException - java.util 中的 异常
当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
IllegalFormatConversionException(char, Class<?>) - 异常 java.util.IllegalFormatConversionException 的构造方法
使用不匹配转换和相应参数类构造此类的实例。
IllegalFormatException - java.util 中的 异常
当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
IllegalFormatFlagsException - java.util 中的 异常
当给出非法组合标志时，抛出未经检查的异常。
IllegalFormatFlagsException(String) - 异常 java.util.IllegalFormatFlagsException 的构造方法
构造带有指定标志的此类的一个实例。
IllegalFormatPrecisionException - java.util 中的 异常
当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
IllegalFormatPrecisionException(int) - 异常 java.util.IllegalFormatPrecisionException 的构造方法
构造带有指定精度的此类的一个实例。
IllegalFormatWidthException - java.util 中的 异常
当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
IllegalFormatWidthException(int) - 异常 java.util.IllegalFormatWidthException 的构造方法
构造带有指定宽度的此类的一个实例。
IllegalMonitorStateException - java.lang 中的 异常
抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
IllegalMonitorStateException() - 异常 java.lang.IllegalMonitorStateException 的构造方法
构造不带详细消息的 IllegalMonitorStateException。
IllegalMonitorStateException(String) - 异常 java.lang.IllegalMonitorStateException 的构造方法
构造带指定详细消息的 IllegalMonitorStateException。
IllegalPathStateException - java.awt.geom 中的 异常
对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。
IllegalPathStateException() - 异常 java.awt.geom.IllegalPathStateException 的构造方法
构造不带任何详细消息的 IllegalPathStateException。
IllegalPathStateException(String) - 异常 java.awt.geom.IllegalPathStateException 的构造方法
构造带指定详细消息的 IllegalMonitorStateException。
IllegalSelectorException - java.nio.channels 中的 异常
试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
IllegalSelectorException() - 异常 java.nio.channels.IllegalSelectorException 的构造方法
构造此类的一个实例。
IllegalStateException - java.lang 中的 异常
在非法或不适当的时间调用方法时产生的信号。
IllegalStateException() - 异常 java.lang.IllegalStateException 的构造方法
构造不带详细消息的 IllegalStateException。
IllegalStateException(String) - 异常 java.lang.IllegalStateException 的构造方法
构造带指定详细消息的 IllegalStateException。
IllegalStateException(String, Throwable) - 异常 java.lang.IllegalStateException 的构造方法
构造一个新异常，它带有指定的详细消息和原因。
IllegalStateException(Throwable) - 异常 java.lang.IllegalStateException 的构造方法
构造一个新异常，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含 cause 的类和详细消息）。
IllegalThreadStateException - java.lang 中的 异常
指示线程没有处于请求操作所要求的适当状态时抛出的异常。
IllegalThreadStateException() - 异常 java.lang.IllegalThreadStateException 的构造方法
构造不带详细消息的 IllegalThreadStateException。
IllegalThreadStateException(String) - 异常 java.lang.IllegalThreadStateException 的构造方法
构造带指定详细消息的 IllegalThreadStateException。
Image - java.awt 中的 类
抽象类 Image 是表示图形图像的所有类的超类。
Image() - 类 java.awt.Image 的构造方法
image - 类 javax.imageio.IIOImage 中的变量
正被引用的 RenderedImage。
IMAGE_INCOMPATIBLE - 类 java.awt.image.VolatileImage 中的静态变量
经验证的图像与提供的 GraphicsConfiguration 对象不兼容，应该重新创建适当的图像。
IMAGE_OK - 类 java.awt.image.VolatileImage 中的静态变量
经验证的图像准备按原样使用。
IMAGE_RESTORED - 类 java.awt.image.VolatileImage 中的静态变量
经验证的图像已经被恢复并准备使用。
IMAGEABORTED - 接口 java.awt.image.ImageConsumer 中的静态变量
图像创建进程被故意中止。
ImageCapabilities - java.awt 中的 类
图像的功能和属性。
ImageCapabilities(boolean) - 类 java.awt.ImageCapabilities 的构造方法
创建用于指定图像功能的新对象。
imageComplete(int) - 类 java.awt.image.BufferedImageFilter 中的方法
过滤 ImageConsumer 接口的 imageComplete 方法中提供的信息。
imageComplete(int) - 接口 java.awt.image.ImageConsumer 中的方法
当 ImageProducer 已完成源图像所含所有像素的传递时，或者已完成多帧动画的单个帧时，或者加载或生成图像中出现错误时，就调用 imageComplete 方法。
imageComplete(int) - 类 java.awt.image.ImageFilter 中的方法
过滤 ImageConsumer 接口的 imageComplete 方法中所提供的信息。
imageComplete(int) - 类 java.awt.image.PixelGrabber 中的方法
imageComplete 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
imageComplete(ImageReader) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告当前图像读操作已经完成。
imageComplete(ImageWriter) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告图像写操作已经完成。
ImageConsumer - java.awt.image 中的 接口
对通过 ImageProducer 接口的图像数据感兴趣的对象接口。
IMAGEERROR - 接口 java.awt.image.ImageConsumer 中的静态变量
生成图像时遇到错误。
ImageFilter - java.awt.image 中的 类
此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。
ImageFilter() - 类 java.awt.image.ImageFilter 的构造方法
imageFlavor - 类 java.awt.datatransfer.DataFlavor 中的静态变量
DataFlavor 表示 Java Image 类，其中：
ImageGraphicAttribute - java.awt.font 中的 类
ImageGraphicAttribute 类是在 TextLayout 中绘制图像的 GraphicAttribute 实现。
ImageGraphicAttribute(Image, int) - 类 java.awt.font.ImageGraphicAttribute 的构造方法
根据指定的 Image 构造一个 ImageGraphicAttribute。
ImageGraphicAttribute(Image, int, float, float) - 类 java.awt.font.ImageGraphicAttribute 的构造方法
根据指定的 Image 构造一个 ImageGraphicAttribute。
ImageIcon - javax.swing 中的 类
一个 Icon 接口的实现，它根据 Image 绘制 Icon。
ImageIcon(String, String) - 类 javax.swing.ImageIcon 的构造方法
根据指定的文件创建一个 ImageIcon。
ImageIcon(String) - 类 javax.swing.ImageIcon 的构造方法
根据指定的文件创建一个 ImageIcon。
ImageIcon(URL, String) - 类 javax.swing.ImageIcon 的构造方法
根据指定的 URL 创建一个 ImageIcon。
ImageIcon(URL) - 类 javax.swing.ImageIcon 的构造方法
根据指定的 URL 创建一个 ImageIcon。
ImageIcon(Image, String) - 类 javax.swing.ImageIcon 的构造方法
根据图像创建一个 ImageIcon。
ImageIcon(Image) - 类 javax.swing.ImageIcon 的构造方法
根据图像对象创建一个 ImageIcon。
ImageIcon(byte[], String) - 类 javax.swing.ImageIcon 的构造方法
根据字节数组创建一个 ImageIcon，这些字节读取自一个包含受支持图像格式（比如 GIF、JPEG 或从 1.3 版本开始的 PNG）的图像文件。
ImageIcon(byte[]) - 类 javax.swing.ImageIcon 的构造方法
根据字节数组创建一个 ImageIcon，这些字节读取自一个包含受支持图像格式（比如 GIF、JPEG 或从 1.3 版本开始的 PNG）的图像文件。
ImageIcon() - 类 javax.swing.ImageIcon 的构造方法
创建一个未初始化的图像图标。
ImageIcon.AccessibleImageIcon - javax.swing 中的 类
此类实现 ImageIcon 类的可访问性支持。
ImageIcon.AccessibleImageIcon() - 类 javax.swing.ImageIcon.AccessibleImageIcon 的构造方法
ImageInputStream - javax.imageio.stream 中的 接口
供 ImageReader 使用的可查找输入流接口。
ImageInputStreamImpl - javax.imageio.stream 中的 类
实现 ImageInputStream 接口的抽象类。
ImageInputStreamImpl() - 类 javax.imageio.stream.ImageInputStreamImpl 的构造方法
构造一个 ImageInputStreamImpl。
ImageInputStreamSpi - javax.imageio.spi 中的 类
用于 ImageInputStream 的服务提供者接口 (SPI)。
ImageInputStreamSpi() - 类 javax.imageio.spi.ImageInputStreamSpi 的构造方法
构造一个空的 ImageInputStreamSpi。
ImageInputStreamSpi(String, String, Class<?>) - 类 javax.imageio.spi.ImageInputStreamSpi 的构造方法
用给定的一组值构造 ImageInputStreamSpi。
ImageIO - javax.imageio 中的 类
该类包含一些用来查找 ImageReader 和 ImageWriter 以及执行简单编码和解码的静态便捷方法。
ImageObserver - java.awt.image 中的 接口
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。
ImageOutputStream - javax.imageio.stream 中的 接口
供 ImageWriter 使用的可查找输出流接口。
ImageOutputStreamImpl - javax.imageio.stream 中的 类
实现 ImageOutputStream 接口的抽象类。
ImageOutputStreamImpl() - 类 javax.imageio.stream.ImageOutputStreamImpl 的构造方法
构造一个 ImageOutputStreamImpl。
ImageOutputStreamSpi - javax.imageio.spi 中的 类
用于 ImageOutputStream 的服务提供者接口 (SPI)。
ImageOutputStreamSpi() - 类 javax.imageio.spi.ImageOutputStreamSpi 的构造方法
构造一个空的 ImageOutputStreamSpi。
ImageOutputStreamSpi(String, String, Class<?>) - 类 javax.imageio.spi.ImageOutputStreamSpi 的构造方法
用给定的一组值构造 ImageOutputStreamSpi。
ImageProducer - java.awt.image 中的 接口
可为 Image 生成图像数据的对象的接口。
imageProgress(ImageReader, float) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告对关联 ImageReader 的 read 当前调用的近似完成程度。
imageProgress(ImageWriter, float) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告在关联的 ImageWriter 中完成当前 write 调用的近似程度。
ImageReader - javax.imageio 中的 类
用来解析和解码图像的抽象超类。
ImageReader(ImageReaderSpi) - 类 javax.imageio.ImageReader 的构造方法
构造一个 ImageReader，并将其 originatingProvider 字段设置为所提供的值。
ImageReaderSpi - javax.imageio.spi 中的 类
用于 ImageReader 的服务提供者接口 (SPI)。
ImageReaderSpi() - 类 javax.imageio.spi.ImageReaderSpi 的构造方法
构造一个空的 ImageReaderSpi。
ImageReaderSpi(String, String, String[], String[], String[], String, Class[], String[], boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - 类 javax.imageio.spi.ImageReaderSpi 的构造方法
用给定的一组值构造 ImageReaderSpi。
ImageReaderWriterSpi - javax.imageio.spi 中的 类
包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。
ImageReaderWriterSpi(String, String, String[], String[], String[], String, boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - 类 javax.imageio.spi.ImageReaderWriterSpi 的构造方法
用给定的一组值构造 ImageReaderWriterSpi。
ImageReaderWriterSpi() - 类 javax.imageio.spi.ImageReaderWriterSpi 的构造方法
构造一个空的 ImageReaderWriterSpi。
ImageReadParam - javax.imageio 中的 类
描述如何对流进行解码的类。
ImageReadParam() - 类 javax.imageio.ImageReadParam 的构造方法
构造一个 ImageReadParam。
imageStarted(ImageReader, int) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告图像读操作将要开始。
imageStarted(ImageWriter, int) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告图像写操作将要开始。
imageSubmit(String) - 类 javax.swing.text.html.FormView 中的方法
调用此方法来提交表单，以响应在图像上的单击，此图像是类型为 "image" 的 <INPUT> 表单元素。
ImageTranscoder - javax.imageio 中的 接口
提供元数据代码转换功能的接口。
ImageTranscoderSpi - javax.imageio.spi 中的 类
用于 ImageTranscoder 的服务提供者接口 (SPI)。
ImageTranscoderSpi() - 类 javax.imageio.spi.ImageTranscoderSpi 的构造方法
构造一个空的 ImageTranscoderSpi。
ImageTranscoderSpi(String, String) - 类 javax.imageio.spi.ImageTranscoderSpi 的构造方法
用给定的一组值构造 ImageTranscoderSpi。
ImageTypeSpecifier - javax.imageio 中的 类
允许以便捷方式指定图像格式（尤其是其 SampleModel 和 ColorModel）的类。
ImageTypeSpecifier(ColorModel, SampleModel) - 类 javax.imageio.ImageTypeSpecifier 的构造方法
直接根据 ColorModel 和 SampleModel 构造一个 ImageTypeSpecifier。
ImageTypeSpecifier(RenderedImage) - 类 javax.imageio.ImageTypeSpecifier 的构造方法
根据 RenderedImage 构造一个 ImageTypeSpecifier。
imageUpdate(Image, int, int, int, int, int) - 类 java.awt.Component 中的方法
图像已改变时重绘组件。
imageUpdate(Image, int, int, int, int, int) - 接口 java.awt.image.ImageObserver 中的方法
当以前使用异步接口所请求的图像的信息变得可用时就调用此方法。
imageUpdate(ImageReader, BufferedImage, int, int, int, int, int, int, int[]) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告已更新图像的给定区域。
imageUpdate(Image, int, int, int, int, int) - 类 javax.swing.AbstractButton 中的方法
重写的此方法在当前 Icon 的 Image 不等于传入的 Image img 时返回 false。
imageUpdate(Image, int, int, int, int, int) - 类 javax.swing.JLabel 中的方法
如果当前图标的图像不等于传入的图像 img，则重写此方法以返回 false。
ImageView - javax.swing.text.html 中的 类
图像视图，用于支持 HTML <IMG> 标记。
ImageView(Element) - 类 javax.swing.text.html.ImageView 的构造方法
创建表示 IMG 元素的新视图。
ImageWriteParam - javax.imageio 中的 类
描述如何对流进行编码的类。
ImageWriteParam() - 类 javax.imageio.ImageWriteParam 的构造方法
构造一个空的 ImageWriteParam。
ImageWriteParam(Locale) - 类 javax.imageio.ImageWriteParam 的构造方法
构造一个 ImageWriteParam 集，以使用给定 Locale。
ImageWriter - javax.imageio 中的 类
用来编码和写入图像的抽象超类。
ImageWriter(ImageWriterSpi) - 类 javax.imageio.ImageWriter 的构造方法
构造一个 ImageWriter，并将其 originatingProvider 实例变量设置为所提供的值。
ImageWriterSpi - javax.imageio.spi 中的 类
用于 ImageWriter 的服务提供者接口 (SPI)。
ImageWriterSpi() - 类 javax.imageio.spi.ImageWriterSpi 的构造方法
构造一个空的 ImageWriterSpi。
ImageWriterSpi(String, String, String[], String[], String[], String, Class[], String[], boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - 类 javax.imageio.spi.ImageWriterSpi 的构造方法
用给定的一组值构造 ImageWriterSpi。
ImagingOpException - java.awt.image 中的 异常
如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
ImagingOpException(String) - 异常 java.awt.image.ImagingOpException 的构造方法
构造带指定消息的 ImagingOpException 对象。
IMG - 类 javax.swing.text.html.HTML.Tag 中的静态变量
IMG_ALIGN_BOTTOM - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
将图像底部对齐。
IMG_ALIGN_MIDDLE - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
将图像居中对齐。
IMG_ALIGN_TOP - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
将图像顶部对齐。
IMG_BORDER - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
将图像对齐到边框。
IMMUTABLE_INFO_FIELD - 类 javax.management.JMX 中的静态变量
immutableInfo 字段的名称。
ImmutableDescriptor - javax.management 中的 类
不可变的描述符。
ImmutableDescriptor(String[], Object[]) - 类 javax.management.ImmutableDescriptor 的构造方法
构造包含给定字段和值的描述符。
ImmutableDescriptor(String...) - 类 javax.management.ImmutableDescriptor 的构造方法
构造包含给定字段的描述符。
ImmutableDescriptor(Map<String, ?>) - 类 javax.management.ImmutableDescriptor 的构造方法
构造一个描述符，其中字段名称和值是给定 Map 的键和值。
IMP_LIMIT - org.omg.CORBA 中的 异常
此异常指示在 OBR 运行时超过了某一项实现限制。
IMP_LIMIT() - 异常 org.omg.CORBA.IMP_LIMIT 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 IMP_LIMIT 异常。
IMP_LIMIT(String) - 异常 org.omg.CORBA.IMP_LIMIT 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 IMP_LIMIT 异常。
IMP_LIMIT(int, CompletionStatus) - 异常 org.omg.CORBA.IMP_LIMIT 的构造方法
使用指定次要代码和完成状态构造一个 IMP_LIMIT 异常。
IMP_LIMIT(String, int, CompletionStatus) - 异常 org.omg.CORBA.IMP_LIMIT 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 IMP_LIMIT 异常。
impl - 类 javax.naming.CompoundName 中的变量
此组合名称的实现。
implAccept(Socket) - 类 java.net.ServerSocket 中的方法
ServerSocket 的子类使用此方法重写 accept() 以返回它们自己的套接字子类。
implCloseChannel() - 类 java.nio.channels.spi.AbstractInterruptibleChannel 中的方法
关闭此通道。
implCloseChannel() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
关闭此通道。
implCloseSelectableChannel() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
关闭此可选择通道。
implCloseSelector() - 类 java.nio.channels.spi.AbstractSelector 中的方法
关闭此选择器。
implConfigureBlocking(boolean) - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
调整此通道的阻塞模式。
IMPLEMENTATION_TITLE - 类 java.util.jar.Attributes.Name 中的静态变量
Implementation-Title 的 Name 对象给出了用于包的版本控制的属性。
IMPLEMENTATION_URL - 类 java.util.jar.Attributes.Name 中的静态变量
Implementation-Vendor-URL 的 Name 对象给出了用于包的版本控制的属性。
IMPLEMENTATION_VENDOR - 类 java.util.jar.Attributes.Name 中的静态变量
Implementation-Vendor 的 Name 对象给出了用于包的版本控制的属性。
IMPLEMENTATION_VENDOR_ID - 类 java.util.jar.Attributes.Name 中的静态变量
Implementation-Vendor-Id 的 Name 对象给出了用于包的版本控制的属性。
IMPLEMENTATION_VERSION - 类 java.util.jar.Attributes.Name 中的静态变量
Implementation-Version 的 Name 对象给出了用于包的版本控制的属性。
implFlush(CharBuffer) - 类 java.nio.charset.CharsetDecoder 中的方法
刷新此解码器。
implFlush(ByteBuffer) - 类 java.nio.charset.CharsetEncoder 中的方法
刷新此编码器。
IMPLICIT_ACTIVATION - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的静态变量
IMPLICIT_ACTIVATION_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java。
ImplicitActivationPolicy - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 中是否支持隐式激活 servant。
ImplicitActivationPolicyOperations - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 中是否支持隐式激活 servant。
ImplicitActivationPolicyValue - org.omg.PortableServer 中的 类
ImplicitActivationPolicyValue 具有以下语义。
ImplicitActivationPolicyValue(int) - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 的构造方法
IMPLIED - 类 javax.swing.text.html.HTML.Tag 中的静态变量
所有文本内容必须包含在段落元素中。
IMPLIED - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的静态变量
这是作为属性集中的一个属性来传递的，用来指示元素是隐含的，例如字符串 '<>foo<\t>' 包含隐含的 html 元素和隐含的正文元素。
IMPLIED - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
implies(Permission) - 类 java.io.FilePermission 中的方法
检查 FilePermission 对象是否“隐含”指定的权限。
implies(Permission) - 类 java.net.SocketPermission 中的方法
检查此套接字权限对象是否“暗含”指定的权限。
implies(Permission) - 类 java.security.AllPermission 中的方法
检查此对象是否“暗含”指定的权限。
implies(Permission) - 类 java.security.BasicPermission 中的方法
检查此对象是否“暗含”指定的权限。
implies(CodeSource) - 类 java.security.CodeSource 中的方法
如果此 CodeSource 对象“暗含”指定的 CodeSource，则返回 true。
implies(Permission) - 类 java.security.Permission 中的方法
检查此对象的操作是否“暗含”指定权限的操作。
implies(Permission) - 类 java.security.PermissionCollection 中的方法
查看此 PermissionCollection 中保存的 Permission 对象集合是否暗含指定的权限。
implies(Permission) - 类 java.security.Permissions 中的方法
查看此对象用于指定 permission 类的 permissions 的 PermissionCollection 是否暗含了 permission 对象中表示的权限。
implies(ProtectionDomain, Permission) - 类 java.security.Policy 中的方法
计算授予 ProtectionDomain 的权限的全局策略，并测试是否授予了该权限。
implies(Permission) - 类 java.security.ProtectionDomain 中的方法
查看此 ProtectionDomain 是否暗含了 Permission 对象中表示的权限。
implies(Permission) - 类 java.security.UnresolvedPermission 中的方法
对于未解析的权限，此方法始终返回 false。
implies(Permission) - 类 java.util.PropertyPermission 中的方法
检查 PropertyPermission 对象是否“暗指”指定的权限。
implies(Permission) - 类 javax.management.MBeanPermission 中的方法
检查此 MBeanPermission 对象是否“隐含”指定的权限。
implies(Permission) - 类 javax.management.MBeanServerPermission 中的方法
检查此 MBeanServerPermission 对象是否“隐含”指定的权限。
implies(Permission) - 类 javax.security.auth.kerberos.DelegationPermission 中的方法
检查此 Kerberos 代理权限对象是否“隐含”指定的权限。
implies(Permission) - 类 javax.security.auth.kerberos.ServicePermission 中的方法
检查此 Kerberos 服务权限对象是否“隐含”指定的权限。
implies(Permission) - 类 javax.security.auth.PrivateCredentialPermission 中的方法
检查此 PrivateCredentialPermission 是否暗含指定的Permission。
implOnMalformedInput(CodingErrorAction) - 类 java.nio.charset.CharsetDecoder 中的方法
报告此解码器的错误输入操作的更改。
implOnMalformedInput(CodingErrorAction) - 类 java.nio.charset.CharsetEncoder 中的方法
报告此编码器的错误输入操作的更改。
implOnUnmappableCharacter(CodingErrorAction) - 类 java.nio.charset.CharsetDecoder 中的方法
报告此解码器的不可映射的字符操作的更改。
implOnUnmappableCharacter(CodingErrorAction) - 类 java.nio.charset.CharsetEncoder 中的方法
报告此编码器的不可映射的字符操作的更改。
implReplaceWith(String) - 类 java.nio.charset.CharsetDecoder 中的方法
报告此解码器替换值的更改。
implReplaceWith(byte[]) - 类 java.nio.charset.CharsetEncoder 中的方法
报告此编码器替换值的更改。
implReset() - 类 java.nio.charset.CharsetDecoder 中的方法
重置此解码器，清除所有特定于 charset 的内部状态。
implReset() - 类 java.nio.charset.CharsetEncoder 中的方法
重置此编码器，清除所有特定于 charset 的内部状态。
importData(TransferHandler.TransferSupport) - 类 javax.swing.TransferHandler 中的方法
导致从剪贴板或拖放操作的传输。
importData(JComponent, Transferable) - 类 javax.swing.TransferHandler 中的方法
导致从剪贴板或 DND 放置操作向组件的传输。
importedKeyCascade - 接口 java.sql.DatabaseMetaData 中的静态变量
对于 UPDATE_RULE 列，指示在更新主键时，外键（导入的键）的更改要与之一致。
importedKeyInitiallyDeferred - 接口 java.sql.DatabaseMetaData 中的静态变量
指示可延迟性。
importedKeyInitiallyImmediate - 接口 java.sql.DatabaseMetaData 中的静态变量
指示可延迟性。
importedKeyNoAction - 接口 java.sql.DatabaseMetaData 中的静态变量
对于 UPDATE_RULE 和 DELETE_RULE 列，指示如果主键已导入，则无法更新或删除它。
importedKeyNotDeferrable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示可延迟性。
importedKeyRestrict - 接口 java.sql.DatabaseMetaData 中的静态变量
对于 UPDATE_RULE 列，指示如果主键已被另一个表作为外键导入，则可能不更新该主键。
importedKeySetDefault - 接口 java.sql.DatabaseMetaData 中的静态变量
对于 UPDATE_RULE 和 DELETE_RULE 列，指示如果更新或删除了主键，则将外键（导入的键）设置为默认值。
importedKeySetNull - 接口 java.sql.DatabaseMetaData 中的静态变量
对于 UPDATE_RULE 和 DELETE_RULE 列，指示在更新或删除主键时，将外键（导入的键）更改为 NULL。
importNode(Node, boolean) - 接口 org.w3c.dom.Document 中的方法
从另一文档向此文档导入节点，而不改变或移除原始文档中的源节点；此方法创建源节点的一个新副本。
importPreferences(InputStream) - 类 java.util.prefs.Preferences 中的静态方法
导入指定输入流中由 XML 文档表示的所有首选项。
importStyleSheet(URL) - 类 javax.swing.text.html.StyleSheet 中的方法
从 url 导入样式表。
in - 类 java.io.FileDescriptor 中的静态变量
标准输入流的句柄。
in - 类 java.io.FilterInputStream 中的变量
要过滤的输入流。
in - 类 java.io.FilterReader 中的变量
底层字符输入流。
in - 类 java.io.PipedInputStream 中的变量
循环缓冲区中位置的索引，当从连接的管道输出流中接收到下一个数据字节时，会将其存储到该位置。
in - 类 java.lang.System 中的静态变量
“标准”输入流。
in(ValueExp, ValueExp[]) - 类 javax.management.Query 中的静态方法
返回一个表达式，限制某个值为显式列表中的一项。
inactive(ActivationID) - 类 java.rmi.activation.Activatable 中的静态方法
通知系统具有相应激活 id 的对象目前没有处于活动状态的。
INACTIVE - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/INACTIVE.java。
INACTIVE - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
INACTIVE_CAPTION - 类 java.awt.SystemColor 中的静态变量
SystemColor.inactiveCaption 系统颜色的数组索引。
INACTIVE_CAPTION_BORDER - 类 java.awt.SystemColor 中的静态变量
SystemColor.inactiveCaptionBorder 系统颜色的数组索引。
INACTIVE_CAPTION_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.inactiveCaptionText 系统颜色的数组索引。
inactiveCaption - 类 java.awt.SystemColor 中的静态变量
为非活动窗口的窗口标题提供的背景色。
inactiveCaptionBorder - 类 java.awt.SystemColor 中的静态变量
为非活动窗口的边框提供的颜色。
inactiveCaptionText - 类 java.awt.SystemColor 中的静态变量
为非活动窗口的窗口标题文本提供的颜色。
inactiveGroup() - 类 java.rmi.activation.ActivationGroup 中的方法
如果子类要进行对组监视器的 inactiveGroup 回调，则此 protected 方法是必要的。
inactiveGroup(ActivationGroupID, long) - 接口 java.rmi.activation.ActivationMonitor 中的方法
通知该组现在是不活动的。
inactiveObject(ActivationID) - 类 java.rmi.activation.ActivationGroup 中的方法
通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
inactiveObject(ActivationID) - 接口 java.rmi.activation.ActivationMonitor 中的方法
当组中的一个对象成为不活动（取消激活）时，一个激活组调用其监视器的 inactiveObject 方法。
INBOUND_MESSAGE_ATTACHMENTS - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：用于入站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。
incarnate(byte[], POA) - 类 org.omg.PortableServer._ServantActivatorStub 中的方法
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到对当前未激活对象的请求，它就会调用此操作。
incarnate(byte[], POA) - 接口 org.omg.PortableServer.ServantActivatorOperations 中的方法
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到针对当前未激活对象的请求，它就会调用此操作。
INCH - 类 javax.print.attribute.Size2DSyntax 中的静态变量
指示单位为英寸 (in) 的值。
INCH - 类 javax.print.attribute.standard.MediaPrintableArea 中的静态变量
指示以 inch (in) 为单位的值。
inCheck - 类 java.lang.SecurityManager 中的变量
已过时。 建议不使用该类型的安全检查。建议使用 checkPermission 调用。
inClass(String) - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
inClassLoader() - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
include(RowFilter.Entry<? extends M, ? extends I>) - 类 javax.swing.RowFilter 中的方法
如果应该显示指定的条目，则返回 true；如果应该隐藏该条目，则返回 false。
inclusions - 类 javax.swing.text.html.parser.Element 中的变量
INCLUSIVE - 接口 javax.xml.crypto.dsig.CanonicalizationMethod 中的静态变量
Canonical XML（不带注释）的规范化方法的算法 URI。
INCLUSIVE_WITH_COMMENTS - 接口 javax.xml.crypto.dsig.CanonicalizationMethod 中的静态变量
带注释的 Canonical XML 的规范化方法的算法 URI。
IncompatibleClassChangeError - java.lang 中的 错误
在某些类定义中出现不兼容的类更改时抛出该异常。
IncompatibleClassChangeError() - 错误 java.lang.IncompatibleClassChangeError 的构造方法
构造不带详细消息的 IncompatibleClassChangeError。
IncompatibleClassChangeError(String) - 错误 java.lang.IncompatibleClassChangeError 的构造方法
构造带指定详细消息的 IncompatibleClassChangeError。
IncompleteAnnotationException - java.lang.annotation 中的 异常
若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。
IncompleteAnnotationException(Class<? extends Annotation>, String) - 异常 java.lang.annotation.IncompleteAnnotationException 的构造方法
构造一个指示指定注释类型中缺少指定元素的 IncompleteAnnotationException。
InconsistentTypeCode - org.omg.CORBA.ORBPackage 中的 异常
当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
InconsistentTypeCode() - 异常 org.omg.CORBA.ORBPackage.InconsistentTypeCode 的构造方法
构造一个不带任何原因信息的 InconsistentTypeCode 用户异常。
InconsistentTypeCode(String) - 异常 org.omg.CORBA.ORBPackage.InconsistentTypeCode 的构造方法
构造一个带有指定原因信息的 InconsistentTypeCode 用户异常。
InconsistentTypeCode - org.omg.DynamicAny.DynAnyFactoryPackage 中的 异常
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java。
InconsistentTypeCode() - 异常 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode 的构造方法
InconsistentTypeCode(String) - 异常 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode 的构造方法
InconsistentTypeCodeHelper - org.omg.DynamicAny.DynAnyFactoryPackage 中的 类
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java。
InconsistentTypeCodeHelper() - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 的构造方法
incrButton - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
INCREASE_HIGHLIGHT - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的静态变量
increaseButton - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的变量
INCREMENT - 接口 javax.accessibility.AccessibleAction 中的静态变量
增加某个值的动作。
incrementAndGet() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将当前值加 1。
incrementAndGet(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将索引 i 的元素加 1。
incrementAndGet(T) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象的字段的当前值加 1。
incrementAndGet() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将当前值加 1。
incrementAndGet(int) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将索引 i 的元素加1。
incrementAndGet(T) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象字段当前值加 1。
incrementAnimationIndex() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
将当前动画窗体的索引设置为下一个有效值，这将导致进度条的重绘。
incrIndent() - 类 javax.swing.text.AbstractWriter 中的方法
提高缩进级别。
inDaylightTime(Date) - 类 java.util.SimpleTimeZone 中的方法
如果给定日期在夏令时期间，则执行查询。
inDaylightTime(Date) - 类 java.util.TimeZone 中的方法
查询给定的日期是否在此时区的夏令时中。
INDEFINITE_LIFETIME - 接口 org.ietf.jgss.GSSContext 中的静态变量
一个表示不确定的上下文生存期的生存期常量。
INDEFINITE_LIFETIME - 接口 org.ietf.jgss.GSSCredential 中的静态变量
一个表示不确定的凭据生存期的生存期常量。
indent() - 类 javax.swing.text.AbstractWriter 中的方法
执行缩进。
INDENT - 类 javax.xml.transform.OutputKeys 中的静态变量
indent = "yes" | "no". indent 指定了当输出结果树时，Transformer 是否可以添加额外的空白；其值必须为 yes 或 no。
INDETERMINATE - 类 javax.accessibility.AccessibleState 中的静态变量
指示对象状态是不确定的。
INDETERMINATE - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
比较结果。
index - 类 javax.swing.text.html.parser.Element 中的变量
index - 异常 org.omg.PortableServer.POAPackage.InvalidPolicy 中的变量
INDEX_SIZE_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果索引或大小为负，或大于允许的值。
indexAtLocation(int, int) - 类 javax.swing.JTabbedPane 中的方法
返回选项卡边界与指定区域相交的选项卡索引。
IndexColorModel - java.awt.image 中的 类
IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。
IndexColorModel(int, int, byte[], byte[], byte[]) - 类 java.awt.image.IndexColorModel 的构造方法
根据指定的红色、绿色和蓝色分量数组构造一个 IndexColorModel。
IndexColorModel(int, int, byte[], byte[], byte[], int) - 类 java.awt.image.IndexColorModel 的构造方法
根据给定的红色、绿色和蓝色分量数组构造一个 IndexColorModel。
IndexColorModel(int, int, byte[], byte[], byte[], byte[]) - 类 java.awt.image.IndexColorModel 的构造方法
根据给定的红色、绿色、蓝色和 alpha 分量数组构造一个 IndexColorModel。
IndexColorModel(int, int, byte[], int, boolean) - 类 java.awt.image.IndexColorModel 的构造方法
根据交错存取红色、绿色、蓝色和可选 alpha 分量的单个数组构造一个 IndexColorModel。
IndexColorModel(int, int, byte[], int, boolean, int) - 类 java.awt.image.IndexColorModel 的构造方法
根据交错存取红色、绿色、蓝色和可选 alpha 分量的单个数组构造一个 IndexColorModel。
IndexColorModel(int, int, int[], int, boolean, int, int) - 类 java.awt.image.IndexColorModel 的构造方法
根据一个 int 数组构造一个 IndexColorModel，该数组中的每个 int 值都由默认 RGB 颜色模型格式的红色、绿色、蓝色和可选 alpha 分量构成。
IndexColorModel(int, int, int[], int, int, BigInteger) - 类 java.awt.image.IndexColorModel 的构造方法
根据一个 int 数组构造一个 IndexColorModel，该数组中的每个 int 值都由默认 RGB 颜色模型格式的红色、绿色、蓝色和 alpha 分量构成。
IndexedPropertyChangeEvent - java.beans 中的 类
无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。
IndexedPropertyChangeEvent(Object, String, Object, Object, int) - 类 java.beans.IndexedPropertyChangeEvent 的构造方法
构造一个新的 IndexedPropertyChangeEvent 对象。
IndexedPropertyDescriptor - java.beans 中的 类
IndexedPropertyDescriptor 描述了类似数组行为的属性，且有一种访问数组特定元素的索引读和/或索引写方法。
IndexedPropertyDescriptor(String, Class<?>) - 类 java.beans.IndexedPropertyDescriptor 的构造方法
此构造方法通过 getFoo 和 setFoo 存取方法为符合标准 Java 约定的属性构造 IndexedPropertyDescriptor，将其用于索引访问和数组访问。
IndexedPropertyDescriptor(String, Class<?>, String, String, String, String) - 类 java.beans.IndexedPropertyDescriptor 的构造方法
此构造方法带有一个简单属性的名称和用于读写属性的方法名称，它们都是带索引的或不带索引的。
IndexedPropertyDescriptor(String, Method, Method, Method, Method) - 类 java.beans.IndexedPropertyDescriptor 的构造方法
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。
indexOf(int) - 类 java.lang.String 中的方法
返回指定字符在此字符串中第一次出现处的索引。
indexOf(int, int) - 类 java.lang.String 中的方法
返回在此字符串中第一次出现指定字符处的索引，从指定的索引开始搜索。
indexOf(String) - 类 java.lang.String 中的方法
返回指定子字符串在此字符串中第一次出现处的索引。
indexOf(String, int) - 类 java.lang.String 中的方法
返回指定子字符串在此字符串中第一次出现处的索引，从指定的索引开始。
indexOf(String) - 类 java.lang.StringBuffer 中的方法
indexOf(String, int) - 类 java.lang.StringBuffer 中的方法
indexOf(String) - 类 java.lang.StringBuilder 中的方法
indexOf(String, int) - 类 java.lang.StringBuilder 中的方法
indexOf(Object) - 类 java.util.AbstractList 中的方法
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。
indexOf(Object) - 类 java.util.ArrayList 中的方法
返回此列表中首次出现的指定元素的索引，或如果此列表不包含元素，则返回 -1。
indexOf(Object) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。
indexOf(E, int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回第一次出现的指定元素在此列表中的索引，从 index 开始向前搜索，如果没有找到该元素，则返回 -1。
indexOf(Object) - 类 java.util.LinkedList 中的方法
返回此列表中首次出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。
indexOf(Object) - 接口 java.util.List 中的方法
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。
indexOf(Object) - 类 java.util.Vector 中的方法
返回此向量中第一次出现的指定元素的索引，如果此向量不包含该元素，则返回 -1。
indexOf(Object, int) - 类 java.util.Vector 中的方法
返回此向量中第一次出现的指定元素的索引，从 index 处正向搜索，如果未找到该元素，则返回 -1。
indexOf(Object) - 类 javax.swing.DefaultListModel 中的方法
搜索 elem 的第一次出现。
indexOf(Object, int) - 类 javax.swing.DefaultListModel 中的方法
从 index 开始搜索 elem 的第一次出现。
indexOf(Object) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
indexOfComponent(Component) - 类 javax.swing.JTabbedPane 中的方法
返回指定组件的选项卡索引。
indexOfSubList(List<?>, List<?>) - 类 java.util.Collections 中的静态方法
返回指定源列表中第一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
indexOfTab(String) - 类 javax.swing.JTabbedPane 中的方法
返回具有给定 title 的第一个选项卡索引，如果没有具有此标题的选项卡，则返回 -1。
indexOfTab(Icon) - 类 javax.swing.JTabbedPane 中的方法
返回具有给定的 icon 的第一个选项卡索引，如果没有具有此图标的选项卡，则返回 -1。
indexOfTabComponent(Component) - 类 javax.swing.JTabbedPane 中的方法
返回指定选项卡组件的选项卡索引。
IndexOutOfBoundsException - java.lang 中的 异常
指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
IndexOutOfBoundsException() - 异常 java.lang.IndexOutOfBoundsException 的构造方法
构造不带详细消息的 IndexOutOfBoundsException。
IndexOutOfBoundsException(String) - 异常 java.lang.IndexOutOfBoundsException 的构造方法
构造带指定详细消息的 IndexOutOfBoundsException。
indexToLocation(int) - 类 javax.swing.JList 中的方法
返回列表的坐标系统中指定项的原点。
indexToLocation(JList, int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回列表坐标系统中给定 JList 中指定项的原点。
indexToLocation(JList, int) - 类 javax.swing.plaf.ListUI 中的方法
返回列表坐标系统中给定 JList 中指定项的原点。
indexToLocation(JList, int) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 indexToLocation 方法。
IndirectionException - org.omg.CORBA.portable 中的 异常
Indirection 异常是一个特定于 Java 的系统异常。
IndirectionException(int) - 异常 org.omg.CORBA.portable.IndirectionException 的构造方法
使用正确的偏移量值创建一个 IndirectionException。
Inet4Address - java.net 中的 类
此类表示 Internet Protocol version 4 (IPv4) 地址。
Inet6Address - java.net 中的 类
此类表示互联网协议第 6 版 (IPv6) 地址。
InetAddress - java.net 中的 类
此类表示互联网协议 (IP) 地址。
InetSocketAddress - java.net 中的 类
此类实现 IP 套接字地址（IP 地址 + 端口号）。
InetSocketAddress(int) - 类 java.net.InetSocketAddress 的构造方法
创建套接字地址，其中 IP 地址为通配符地址，端口号为指定值。
InetSocketAddress(InetAddress, int) - 类 java.net.InetSocketAddress 的构造方法
根据 IP 地址和端口号创建套接字地址。
InetSocketAddress(String, int) - 类 java.net.InetSocketAddress 的构造方法
根据主机名和端口号创建套接字地址。
inf - 类 java.util.zip.InflaterInputStream 中的变量
流的解压缩器。
inf - 类 java.util.zip.InflaterOutputStream 中的变量
此流的解压缩器。
inferBinaryName(JavaFileManager.Location, JavaFileObject) - 类 javax.tools.ForwardingJavaFileManager 中的方法
inferBinaryName(JavaFileManager.Location, JavaFileObject) - 接口 javax.tools.JavaFileManager 中的方法
根据位置推断文件对象的二进制名称。
inflate(byte[], int, int) - 类 java.util.zip.Inflater 中的方法
将字节解压缩到指定的缓冲区。
inflate(byte[]) - 类 java.util.zip.Inflater 中的方法
将字节解压缩到指定的缓冲区。
Inflater - java.util.zip 中的 类
此类使用流行的 ZLIB 压缩程序库为通用解压缩提供支持。
Inflater(boolean) - 类 java.util.zip.Inflater 的构造方法
创建新的解压缩器。
Inflater() - 类 java.util.zip.Inflater 的构造方法
创建新的解压缩器。
InflaterInputStream - java.util.zip 中的 类
此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
InflaterInputStream(InputStream, Inflater, int) - 类 java.util.zip.InflaterInputStream 的构造方法
使用指定解压缩器和缓冲区大小创建一个新输入流。
InflaterInputStream(InputStream, Inflater) - 类 java.util.zip.InflaterInputStream 的构造方法
创建一个带有指定解压缩器和默认缓冲区大小的新输入流。
InflaterInputStream(InputStream) - 类 java.util.zip.InflaterInputStream 的构造方法
使用默认解压缩器和缓冲区大小创建一个新输入流。
InflaterOutputStream - java.util.zip 中的 类
为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
InflaterOutputStream(OutputStream) - 类 java.util.zip.InflaterOutputStream 的构造方法
创建一个带有默认解压缩器和缓冲区大小的新输出流。
InflaterOutputStream(OutputStream, Inflater) - 类 java.util.zip.InflaterOutputStream 的构造方法
创建一个带有指定解压缩器和默认缓冲区大小的新输出流。
InflaterOutputStream(OutputStream, Inflater, int) - 类 java.util.zip.InflaterOutputStream 的构造方法
创建一个带有指定解压缩器和缓冲区大小的新输出流。
INFO - 类 java.awt.SystemColor 中的静态变量
SystemColor.info 系统颜色的数组索引。
info - 类 java.awt.SystemColor 中的静态变量
为工具栏提示或定点帮助提供的背景色。
INFO - 类 java.util.logging.Level 中的静态变量
INFO 是报告消息的消息级别。
info(String) - 类 java.util.logging.Logger 中的方法
记录一条 INFO 消息。
INFO - 类 javax.management.MBeanOperationInfo 中的静态变量
指示该操作与读取操作类似，它主要返回一些信息。
INFO_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.infoText 系统颜色的数组索引。
inFontTag() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
如果我们当前正处在 <font> 标记中，则返回 true。
INFORMATION - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
INFORMATION 消息类型。
INFORMATION - 类 javax.security.auth.callback.TextOutputCallback 中的静态变量
信息消息。
INFORMATION_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
INFORMATION_MESSAGE - 类 javax.swing.JOptionPane 中的静态变量
用于信息消息。
infoText - 类 java.awt.SystemColor 中的静态变量
为工具栏提示或定点帮助的文本提供的颜色。
InheritableThreadLocal<T> - java.lang 中的 类
该类扩展了 ThreadLocal，为子线程提供从父线程那里继承的值：在创建子线程时，子线程会接收所有可继承的线程局部变量的初始值，以获得父线程所具有的值。
InheritableThreadLocal() - 类 java.lang.InheritableThreadLocal 的构造方法
Inherited - java.lang.annotation 中的 注释类型
指示注释类型被自动继承。
inheritedChannel() - 类 java.lang.System 中的静态方法
返回从创建此 Java 虚拟机的实体中继承的信道。
inheritedChannel() - 类 java.nio.channels.spi.SelectorProvider 中的方法
返回从创建此 Java 虚拟机的实体中继承的通道。
inHitRegion(int, int) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果传入位置是要启动编辑的有效鼠标位置，则返回 true。
init() - 类 java.applet.Applet 中的方法
由浏览器或 applet viewer 调用，通知此 applet 它已经被加载到系统中。
init(int) - 类 java.security.AlgorithmParameterGenerator 中的方法
针对某个特定大小初始化此参数生成器。
init(int, SecureRandom) - 类 java.security.AlgorithmParameterGenerator 中的方法
针对某个特定大小和随机源初始化此参数生成器。
init(AlgorithmParameterSpec) - 类 java.security.AlgorithmParameterGenerator 中的方法
利用特定于算法的参数生成值集合初始化此参数生成器。
init(AlgorithmParameterSpec, SecureRandom) - 类 java.security.AlgorithmParameterGenerator 中的方法
利用特定于算法的参数生成值集合初始化此参数生成器。
init(AlgorithmParameterSpec) - 类 java.security.AlgorithmParameters 中的方法
使用在 paramSpec 中指定的参数初始化此参数对象。
init(byte[]) - 类 java.security.AlgorithmParameters 中的方法
根据参数的基本解码格式导入指定的参数并对其解码。
init(byte[], String) - 类 java.security.AlgorithmParameters 中的方法
根据指定的解码方案从 params 导入参数并对其解码。
init(boolean) - 类 java.security.cert.PKIXCertPathChecker 中的方法
初始化此 PKIXCertPathChecker 的内部状态。
init(ProcessingEnvironment) - 类 javax.annotation.processing.AbstractProcessor 中的方法
用处理环境初始化 processor，方法是将 processingEnv 字段设置为 processingEnv 参数的值。
init(ProcessingEnvironment) - 接口 javax.annotation.processing.Processor 中的方法
用处理环境初始化 Processor。
init(int, Key) - 类 javax.crypto.Cipher 中的方法
用密钥初始化此 Cipher。
init(int, Key, SecureRandom) - 类 javax.crypto.Cipher 中的方法
用密钥和随机源初始化此 Cipher。
init(int, Key, AlgorithmParameterSpec) - 类 javax.crypto.Cipher 中的方法
用密钥和一组算法参数初始化此 Cipher。
init(int, Key, AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.Cipher 中的方法
用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
init(int, Key, AlgorithmParameters) - 类 javax.crypto.Cipher 中的方法
用密钥和一组算法参数初始化此 Cipher。
init(int, Key, AlgorithmParameters, SecureRandom) - 类 javax.crypto.Cipher 中的方法
用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
init(int, Certificate) - 类 javax.crypto.Cipher 中的方法
用取自给定证书的公钥初始化此 Cipher。
init(int, Certificate, SecureRandom) - 类 javax.crypto.Cipher 中的方法
用取自给定证书的公钥和随机源初始化此 Cipher。
init(Key) - 类 javax.crypto.ExemptionMechanism 中的方法
用密钥初始化此豁免机制。
init(Key, AlgorithmParameterSpec) - 类 javax.crypto.ExemptionMechanism 中的方法
用一个密钥和一组算法参数初始化此豁免机制。
init(Key, AlgorithmParameters) - 类 javax.crypto.ExemptionMechanism 中的方法
用一个密钥和一组算法参数初始化此豁免机制。
init(Key) - 类 javax.crypto.KeyAgreement 中的方法
用给定密钥初始化此密钥协定，给定密钥需要包含此密钥协定所需的所有算法参数。
init(Key, SecureRandom) - 类 javax.crypto.KeyAgreement 中的方法
用给定密钥和随机源初始化此密钥协议。
init(Key, AlgorithmParameterSpec) - 类 javax.crypto.KeyAgreement 中的方法
用给定密钥和算法参数集初始化此密钥协定。
init(Key, AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.KeyAgreement 中的方法
用给定密钥、算法参数集和随机源初始化此密钥协定。
init(SecureRandom) - 类 javax.crypto.KeyGenerator 中的方法
初始化此密钥生成器。
init(AlgorithmParameterSpec) - 类 javax.crypto.KeyGenerator 中的方法
用指定参数集初始化此密钥生成器。
init(AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.KeyGenerator 中的方法
用指定参数集和用户提供的随机源初始化此密钥生成器。
init(int) - 类 javax.crypto.KeyGenerator 中的方法
初始化此密钥生成器，使其具有确定的密钥大小。
init(int, SecureRandom) - 类 javax.crypto.KeyGenerator 中的方法
使用用户提供的随机源初始化此密钥生成器，使其具有确定的密钥大小。
init(Key) - 类 javax.crypto.Mac 中的方法
用给定的密钥初始化此 Mac 对象。
init(Key, AlgorithmParameterSpec) - 类 javax.crypto.Mac 中的方法
用给定的密钥和算法参数初始化此 Mac 对象。
init(Hashtable<?, ?>) - 类 javax.naming.InitialContext 中的方法
使用所提供的环境初始化初始上下文。
init(KeyStore, char[]) - 类 javax.net.ssl.KeyManagerFactory 中的方法
使用密钥内容源初始化此工厂。
init(ManagerFactoryParameters) - 类 javax.net.ssl.KeyManagerFactory 中的方法
使用特定于提供者的密钥内容源初始化此工厂。
init(KeyManager[], TrustManager[], SecureRandom) - 类 javax.net.ssl.SSLContext 中的方法
初始化此上下文。
init(KeyStore) - 类 javax.net.ssl.TrustManagerFactory 中的方法
用证书授权源和相关的信任材料初始化此工厂。
init(ManagerFactoryParameters) - 类 javax.net.ssl.TrustManagerFactory 中的方法
使用特定于提供者的信任材料源初始化此工厂。
init(String, Icon) - 类 javax.swing.AbstractButton 中的方法
init(String, Icon) - 类 javax.swing.JMenuItem 中的方法
利用指定文本和图标初始化菜单项。
init(StateEditable, String) - 类 javax.swing.undo.StateEdit 中的方法
init(TransformParameterSpec) - 类 javax.xml.crypto.dsig.TransformService 中的方法
使用指定的参数初始化此 TransformService。
init(XMLStructure, XMLCryptoContext) - 类 javax.xml.crypto.dsig.TransformService 中的方法
使用指定的参数和文档上下文初始化此 TransformService。
init() - 类 org.omg.CORBA.ORB 中的静态方法
返回对象 ORB 单件。
init(String[], Properties) - 类 org.omg.CORBA.ORB 中的静态方法
为独立的应用程序创建一个新的 ORB 实例。
init(Applet, Properties) - 类 org.omg.CORBA.ORB 中的静态方法
为 applet 创建一个新的 ORB 实例。
initCause(Throwable) - 类 java.lang.Throwable 中的方法
将此 throwable 的 cause 初始化为指定值。
initCause(Throwable) - 异常 javax.naming.NamingException 中的方法
将此异常的 cause 初始化为指定值。
initCause(Throwable) - 异常 javax.security.sasl.SaslException 中的方法
initCause(Throwable) - 异常 javax.xml.soap.SOAPException 中的方法
使用给定的 Throwable 对象初始化此 SOAPException 对象的 cause 字段。
initCause(Throwable) - 异常 javax.xml.transform.TransformerException 中的方法
将此抛出对象的原因 初始化为指定值。
initClassDefaults(UIDefaults) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
用从 uiClassID 到 ui 类的完全限定名称的映射关系填充 table。
initClassDefaults(UIDefaults) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
用从 uiClassID 到 ui 类完全限定名的映射关系填充 table。
initComponentDefaults(UIDefaults) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
用基本外观的默认值填充 table。
initComponentDefaults(UIDefaults) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
用 metal 的默认值填充 table。
initEvent(String, boolean, boolean) - 接口 org.w3c.dom.events.Event 中的方法
initEvent 方法用于初始化通过 DocumentEvent 接口创建的 Event 的值。
INITIAL_CONTEXT_FACTORY - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定要使用的初始上下文工厂的环境属性名称。
INITIAL_QUOTE_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Pi”。
INITIAL_SELECTION_VALUE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
initialSelectionValue 的绑定属性名。
INITIAL_VALUE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
initialValue 的绑定属性名。
InitialContext - javax.naming 中的 类
此类是执行命名操作的初始上下文。
InitialContext(boolean) - 类 javax.naming.InitialContext 的构造方法
构造一个带有不进行初始化选项的初始上下文。
InitialContext() - 类 javax.naming.InitialContext 的构造方法
构造一个初始上下文。
InitialContext(Hashtable<?, ?>) - 类 javax.naming.InitialContext 的构造方法
使用所提供的环境构造一个初始上下文。
InitialContextFactory - javax.naming.spi 中的 接口
此接口表示创建初始上下文的工厂。
InitialContextFactoryBuilder - javax.naming.spi 中的 接口
此接口表示创建初始上下文工厂的生成器。
InitialDirContext - javax.naming.directory 中的 类
此类是执行目录操作的初始上下文。
InitialDirContext(boolean) - 类 javax.naming.directory.InitialDirContext 的构造方法
构造一个具有不进行初始化的选项的初始 DirContext。
InitialDirContext() - 类 javax.naming.directory.InitialDirContext 的构造方法
构造一个初始 DirContext。
InitialDirContext(Hashtable<?, ?>) - 类 javax.naming.directory.InitialDirContext 的构造方法
使用所提供的环境构造一个初始 DirContext。
initialFocusComponent - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
利用 selectInitialValue 传递消息时接收焦点的组件。
initialize(Applet, BeanContext) - 接口 java.beans.AppletInitializer 中的方法
如果传递给 java.beans.Beans.instantiate 的适当变体，将调用此方法来将新近实例化的 Applet (JavaBean) 与其 AppletContext、AppletStub 和 Container 相关联。
initialize() - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
由 BeanContextSupport 超类在构造和反序列化期间调用，以初始化子类的瞬态。
initialize() - 类 java.beans.beancontext.BeanContextSupport 中的方法
从构造方法和 readObject 调用的受保护方法，以初始化 BeanContextSupport 实例的瞬态。
initialize(Class<?>, Object, Object, Encoder) - 类 java.beans.DefaultPersistenceDelegate 中的方法
initialize 方法的此默认实现假设保存在此类型对象中的所有状态都是通过匹配 "setter" 和 "getter" 方法对来公开的，公开的顺序是 Introspector 返回它们的顺序。
initialize(Class<?>, Object, Object, Encoder) - 类 java.beans.PersistenceDelegate 中的方法
产生一系列对 newInstance 有副作用的语句，使得新实例等于 oldInstance。
initialize(DSAParams, SecureRandom) - 接口 java.security.interfaces.DSAKeyPairGenerator 中的方法
使用 DSA 系列参数（p、q 和 g）和可选 SecureRandom 位源初始化密钥对生成器。
initialize(int, boolean, SecureRandom) - 接口 java.security.interfaces.DSAKeyPairGenerator 中的方法
使用给定系数长度（而不是参数）和可选 SecureRandom 位源初始化密钥对生成器。
initialize(int) - 类 java.security.KeyPairGenerator 中的方法
初始化确定密钥大小的密钥对生成器，使用默认的参数集合，并使用以最高优先级安装的提供者的 SecureRandom 实现作为随机源。
initialize(int, SecureRandom) - 类 java.security.KeyPairGenerator 中的方法
使用给定的随机源（和默认的参数集合）初始化确定密钥大小的密钥对生成器。
initialize(AlgorithmParameterSpec) - 类 java.security.KeyPairGenerator 中的方法
初始化密钥对生成器，使用指定参数集合，并使用以最高优先级安装的提供者的 SecureRandom 的实现作为随机源。
initialize(AlgorithmParameterSpec, SecureRandom) - 类 java.security.KeyPairGenerator 中的方法
使用给定参数集合和随机源初始化密钥对生成器。
initialize(int, SecureRandom) - 类 java.security.KeyPairGeneratorSpi 中的方法
使用默认参数集初始化确定密钥大小的密钥对生成器。
initialize(AlgorithmParameterSpec, SecureRandom) - 类 java.security.KeyPairGeneratorSpi 中的方法
用指定参数集合和用户提供的随机源初始化密钥对生成器。
initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - 接口 javax.security.auth.spi.LoginModule 中的方法
初始化此 LoginModule。
initialize() - 类 javax.swing.LookAndFeel 中的方法
初始化外观。
initialize() - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
初始化外观。
initialize() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
在安装此外观时由 UIManager 调用。
INITIALIZE - org.omg.CORBA 中的 异常
ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
INITIALIZE() - 异常 org.omg.CORBA.INITIALIZE 的构造方法
使用默认次要代码 0 和完成状态 CompletionStatus.COMPLETED_NO 构造一个 INITIALIZE 异常。
INITIALIZE(String) - 异常 org.omg.CORBA.INITIALIZE 的构造方法
使用指定详细消息、次要代码 0 和完成状态 CompletionStatus.COMPLETED_NO 构造一个 INITIALIZE 异常。
INITIALIZE(int, CompletionStatus) - 异常 org.omg.CORBA.INITIALIZE 的构造方法
使用指定次要代码和完成状态构造一个 INITIALIZE 异常。
INITIALIZE(String, int, CompletionStatus) - 异常 org.omg.CORBA.INITIALIZE 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INITIALIZE 异常。
initializeAutoscrolling(Point) - 类 java.awt.dnd.DropTarget 中的方法
初始化自动滚动
initializeBeanContextResources() - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
子类可重写此方法来提供它们自己的初始化行为。
initializeBeanContextResources() - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
从 setBeanContext 中调用，以通知 BeanContextChild 分配从嵌套 BeanContext 中获得的资源。
initializeDesktopProperties() - 类 java.awt.Toolkit 中的方法
initializeDesktopProperties
initializeLocalVars() - 类 javax.swing.JTable 中的方法
将表的属性初始化为其默认值。
initializeLocalVars() - 类 javax.swing.table.JTableHeader 中的方法
使用默认值初始化局部变量和属性。
InitialLdapContext - javax.naming.ldap 中的 类
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。
InitialLdapContext() - 类 javax.naming.ldap.InitialLdapContext 的构造方法
不使用任何环境属性或连接请求控件构造初始上下文。
InitialLdapContext(Hashtable<?, ?>, Control[]) - 类 javax.naming.ldap.InitialLdapContext 的构造方法
使用环境属性或连接请求控件构造初始上下文。
initialSelectionValue - 类 javax.swing.JOptionPane 中的变量
要在 selectionValues 中选择的初始值。
initialSubString(AttributeValueExp, StringValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于字符串参数的约束条件。
initialValue() - 类 java.lang.ThreadLocal 中的方法
返回此线程局部变量的当前线程的“初始值”。
initialValue - 类 javax.swing.JOptionPane 中的变量
应该在 options 中最初选择的值。
INITIATE_AND_ACCEPT - 接口 org.ietf.jgss.GSSCredential 中的静态变量
凭据使用标志，它要求凭据既可用于上下文初始化也可用于接受。
INITIATE_ONLY - 接口 org.ietf.jgss.GSSCredential 中的静态变量
凭据使用标志，要求凭据仅可用于上下文初始化。
initMouseEvent(String, boolean, boolean, AbstractView, int, int, int, int, int, boolean, boolean, boolean, boolean, short, EventTarget) - 接口 org.w3c.dom.events.MouseEvent 中的方法
initMouseEvent 方法用于初始化通过 DocumentEvent 接口创建的 MouseEvent 的值。
initMutationEvent(String, boolean, boolean, Node, String, String, String, short) - 接口 org.w3c.dom.events.MutationEvent 中的方法
该 initMutationEvent 方法用于初始化通过 DocumentEvent 接口创建的 MutationEvent 的值。
InitParam - javax.jws.soap 中的 注释类型
已过时。 从 JSR-181 2.0 开始，无替代版本。
initParams() - 类 javax.sql.rowset.BaseRowSet 中的方法
执行必需的内部配置和初始化，从而允许所有 JDBC RowSet 实现开始使用 BaseRowSet 实例提供的标准设施。
initSecContext(byte[], int, int) - 接口 org.ietf.jgss.GSSContext 中的方法
由上下文初始端调用，以启动上下文创建阶段，处理由同位体的 acceptSecContext 方法生成的任何标记。
initSecContext(InputStream, OutputStream) - 接口 org.ietf.jgss.GSSContext 中的方法
由上下文初始端调用，以启动上下文的创建阶段，处理由使用流的同位体的 acceptSecContext 方法生成的任何标记。
initSign(PrivateKey) - 类 java.security.Signature 中的方法
初始化这个用于签名的对象。
initSign(PrivateKey, SecureRandom) - 类 java.security.Signature 中的方法
初始化这个用于签名的对象。
initSystemColorDefaults(UIDefaults) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
用系统颜色填充 table。
initSystemColorDefaults(UIDefaults) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
用系统颜色填充 table。
initUIEvent(String, boolean, boolean, AbstractView, int) - 接口 org.w3c.dom.events.UIEvent 中的方法
initUIEvent 方法用于初始化通过 DocumentEvent 接口创建的 UIEvent 的值。
initVerify(PublicKey) - 类 java.security.Signature 中的方法
初始化此用于验证的对象。
initVerify(Certificate) - 类 java.security.Signature 中的方法
使用来自给定证书的公钥初始化此用于验证的对象。
InlineView - javax.swing.text.html 中的 类
显示基于 css 属性的 inline element 样式。
InlineView(Element) - 类 javax.swing.text.html.InlineView 的构造方法
构造在元素上包装的新视图。
INNER_JOIN - 接口 javax.sql.rowset.JoinRowSet 中的静态变量
ANSI 风格的 JOIN，提供两个表之间的内联合 (inner join)。
input - 类 javax.imageio.ImageReader 中的变量
由 setInput 设置并由 getInput 获取的 ImageInputStream 或其他 Object。
INPUT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
INPUT_METHOD_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择输入方法事件的事件掩码。
INPUT_METHOD_FIRST - 类 java.awt.event.InputMethodEvent 中的静态变量
标记输入方法事件 id 范围内的第一个整数 id。
INPUT_METHOD_HIGHLIGHT - 类 java.awt.font.TextAttribute 中的静态变量
用于输入法高亮显示样式的属性键。
INPUT_METHOD_LAST - 类 java.awt.event.InputMethodEvent 中的静态变量
标记输入方法事件 id 范围内最后一个整数 id。
INPUT_METHOD_SEGMENT - 类 java.text.AttributedCharacterIterator.Attribute 中的静态变量
输入法段的属性键。
INPUT_METHOD_TEXT_CHANGED - 类 java.awt.event.InputMethodEvent 中的静态变量
事件类型，它指示修改的输入方法文本。
INPUT_METHOD_UNDERLINE - 类 java.awt.font.TextAttribute 中的静态变量
输入法下划线的属性键。
INPUT_TRAY_MISSING - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备中没有一个或多个输入纸盒。
INPUT_VALUE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
inputValue 的绑定属性名。
inputClass - 类 javax.imageio.spi.ImageInputStreamSpi 中的变量
指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
inputComponent - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
如果 optionPane.getWantsInput() 返回 true，则 JComponent 提供输入。
InputContext - java.awt.im 中的 类
提供控制诸如输入方法和键盘布局之类的文本输入设施的方法。
InputContext() - 类 java.awt.im.InputContext 的构造方法
构造一个 InputContext。
InputEvent - java.awt.event 中的 类
所有组件级别输入事件的根事件类。
InputMap - javax.swing 中的 类
InputMap 提供输入事件（目前只使用 KeyStroke）和 Object 之间的绑定。
InputMap() - 类 javax.swing.InputMap 的构造方法
创建一个没有父级和映射关系的 InputMap。
InputMapUIResource - javax.swing.plaf 中的 类
实现 UIResource 的 javax.swing.InputMap 的子类。
InputMapUIResource() - 类 javax.swing.plaf.InputMapUIResource 的构造方法
InputMethod - java.awt.im.spi 中的 接口
定义支持复杂文本输入的输入方法接口。
InputMethodContext - java.awt.im.spi 中的 接口
提供输入方法可以用来与其客户端组件通信或用来请求其他服务的方法。
InputMethodDescriptor - java.awt.im.spi 中的 接口
定义提供足够的关于输入方法启用选择和该输入方法加载信息的方法。
InputMethodEvent - java.awt.event 中的 类
输入方法事件包含有关使用输入方法进行撰写的文本的信息。
InputMethodEvent(Component, int, long, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - 类 java.awt.event.InputMethodEvent 的构造方法
通过指定源组件、类型、时间、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component, int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - 类 java.awt.event.InputMethodEvent 的构造方法
通过指定源组件、类型、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component, int, TextHitInfo, TextHitInfo) - 类 java.awt.event.InputMethodEvent 的构造方法
通过指定源组件、类型、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodHighlight - java.awt.im 中的 类
InputMethodHighlight 用于描述正在撰写的文本的高亮显示属性。
InputMethodHighlight(boolean, int) - 类 java.awt.im.InputMethodHighlight 的构造方法
构造输入方法高亮显示记录。
InputMethodHighlight(boolean, int, int) - 类 java.awt.im.InputMethodHighlight 的构造方法
构造输入方法高亮显示记录。
InputMethodHighlight(boolean, int, int, Map<TextAttribute, ?>) - 类 java.awt.im.InputMethodHighlight 的构造方法
构造输入方法高亮显示记录。
InputMethodListener - java.awt.event 中的 接口
接收输入方法事件的侦听器接口。
InputMethodRequests - java.awt.im 中的 接口
InputMethodRequests 定义文本编辑组件为了与输入方法一起使用而必须处理的请求。
inputMethodTextChanged(InputMethodEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 inputMethodTextChanged 方法处理 inputMethodTextChanged 事件。
inputMethodTextChanged(InputMethodEvent) - 接口 java.awt.event.InputMethodListener 中的方法
当通过输入方法输入的文本发生变化时调用。
InputMismatchException - java.util 中的 异常
由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
InputMismatchException() - 异常 java.util.InputMismatchException 的构造方法
构造 InputMismatchException，使用 null 作为其错误消息字符串。
InputMismatchException(String) - 异常 java.util.InputMismatchException 的构造方法
构造 InputMismatchException，将引用保存到错误消息字符串 s 中，以便将来由 getMessage 方法获取。
InputSource - org.xml.sax 中的 类
XML 实体的单一输入源。
InputSource() - 类 org.xml.sax.InputSource 的构造方法
零参数默认构造方法。
InputSource(String) - 类 org.xml.sax.InputSource 的构造方法
使用系统标识符创建新的输入源。
InputSource(InputStream) - 类 org.xml.sax.InputSource 的构造方法
使用字节流创建新的输入源。
InputSource(Reader) - 类 org.xml.sax.InputSource 的构造方法
使用字符流创建新的输入源。
InputStream - java.io 中的 类
此抽象类是表示字节输入流的所有类的超类。
InputStream() - 类 java.io.InputStream 的构造方法
InputStream - org.omg.CORBA.portable 中的 类
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
InputStream() - 类 org.omg.CORBA.portable.InputStream 的构造方法
InputStream - org.omg.CORBA_2_3.portable 中的 类
InputStream 提供从流读取所有映射的 IDL 类型的接口。
InputStream() - 类 org.omg.CORBA_2_3.portable.InputStream 的构造方法
InputStreamReader - java.io 中的 类
InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。
InputStreamReader(InputStream) - 类 java.io.InputStreamReader 的构造方法
创建一个使用默认字符集的 InputStreamReader。
InputStreamReader(InputStream, String) - 类 java.io.InputStreamReader 的构造方法
创建使用指定字符集的 InputStreamReader。
InputStreamReader(InputStream, Charset) - 类 java.io.InputStreamReader 的构造方法
创建使用给定字符集的 InputStreamReader。
InputStreamReader(InputStream, CharsetDecoder) - 类 java.io.InputStreamReader 的构造方法
创建使用给定字符集解码器的 InputStreamReader。
InputSubset - java.awt.im 中的 类
定义输入方法使用的其他 Unicode 子集。
inputTypes - 类 javax.imageio.spi.ImageReaderSpi 中的变量
将从 getInputTypes 返回的 Class 对象数组，该数组最初为 null。
inputValue - 类 javax.swing.JOptionPane 中的变量
用户已输入的值。
InputVerifier - javax.swing 中的 类
此类的用途是通过带文本字段的 GUI 帮助客户端支持流畅的焦点导航。
InputVerifier() - 类 javax.swing.InputVerifier 的构造方法
inRange(Element) - 类 javax.swing.text.AbstractWriter 中的方法
此方法确定当前元素是否位于指定的范围内。
insert(String, int) - 类 java.awt.Choice 中的方法
将菜单项插入此选择的指定位置上。
INSERT - 类 java.awt.Event 中的静态变量
Insert 键，一个非 ASCII 操作键。
insert(MenuItem, int) - 类 java.awt.Menu 中的方法
将菜单项插入到此菜单的指定位置。
insert(String, int) - 类 java.awt.Menu 中的方法
将带有指定标签的菜单项插入到此菜单的指定位置。
insert(String, int) - 类 java.awt.TextArea 中的方法
在此文本区的指定位置插入指定文本。
insert(int, char[], int, int) - 类 java.lang.StringBuffer 中的方法
insert(int, Object) - 类 java.lang.StringBuffer 中的方法
insert(int, String) - 类 java.lang.StringBuffer 中的方法
insert(int, char[]) - 类 java.lang.StringBuffer 中的方法
insert(int, CharSequence) - 类 java.lang.StringBuffer 中的方法
insert(int, CharSequence, int, int) - 类 java.lang.StringBuffer 中的方法
insert(int, boolean) - 类 java.lang.StringBuffer 中的方法
insert(int, char) - 类 java.lang.StringBuffer 中的方法
insert(int, int) - 类 java.lang.StringBuffer 中的方法
insert(int, long) - 类 java.lang.StringBuffer 中的方法
insert(int, float) - 类 java.lang.StringBuffer 中的方法
insert(int, double) - 类 java.lang.StringBuffer 中的方法
insert(int, char[], int, int) - 类 java.lang.StringBuilder 中的方法
insert(int, Object) - 类 java.lang.StringBuilder 中的方法
insert(int, String) - 类 java.lang.StringBuilder 中的方法
insert(int, char[]) - 类 java.lang.StringBuilder 中的方法
insert(int, CharSequence) - 类 java.lang.StringBuilder 中的方法
insert(int, CharSequence, int, int) - 类 java.lang.StringBuilder 中的方法
insert(int, boolean) - 类 java.lang.StringBuilder 中的方法
insert(int, char) - 类 java.lang.StringBuilder 中的方法
insert(int, int) - 类 java.lang.StringBuilder 中的方法
insert(int, long) - 类 java.lang.StringBuilder 中的方法
insert(int, float) - 类 java.lang.StringBuilder 中的方法
insert(int, double) - 类 java.lang.StringBuilder 中的方法
INSERT - 接口 javax.accessibility.AccessibleTableModelChange 中的静态变量
标识新行和/或新列的插入。
INSERT - 类 javax.swing.event.DocumentEvent.EventType 中的静态变量
插入类型。
INSERT - 类 javax.swing.event.TableModelEvent 中的静态变量
标识新行或新列的添加。
insert(String, int) - 类 javax.swing.JMenu 中的方法
在给定位置插入具有指定文本的新菜单项。
insert(JMenuItem, int) - 类 javax.swing.JMenu 中的方法
在给定位置插入指定的 JMenuitem。
insert(Action, int) - 类 javax.swing.JMenu 中的方法
在给定位置插入连接到指定 Action 对象的新菜单项。
insert(Action, int) - 类 javax.swing.JPopupMenu 中的方法
在给定位置插入指定 Action 对象的菜单项。
insert(Component, int) - 类 javax.swing.JPopupMenu 中的方法
将指定组件插入到菜单的给定位置。
insert(String, int) - 类 javax.swing.JTextArea 中的方法
将指定文本插入指定位置。
insert(int, int, DefaultStyledDocument.ElementSpec[], AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
插入新内容。
insert(int, DefaultStyledDocument.ElementSpec[]) - 类 javax.swing.text.DefaultStyledDocument 中的方法
批量插入新元素。
insert(int, DefaultStyledDocument.ElementSpec[]) - 类 javax.swing.text.html.HTMLDocument 中的方法
批量插入新元素。
insert(int, View) - 类 javax.swing.text.View 中的方法
插入单个子视图。
insert(MutableTreeNode, int) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
从其现有父节点移除 newChild（如果它有父节点），将子节点的父节点设置为此节点，然后，将该子节点添加到此节点位于索引 childIndex 处的子节点数组。
insert(MutableTreeNode, int) - 接口 javax.swing.tree.MutableTreeNode 中的方法
将 child 添加到 index 位置的接收者。
insert(Any, Any[]) - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
insert(Any, boolean[]) - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
insert(Any, char[]) - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
insert(Any, CompletionStatus) - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
insert(Any, Current) - 类 org.omg.CORBA.CurrentHelper 中的静态方法
insert(Any, DefinitionKind) - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
insert(Any, double[]) - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
insert(Any, float[]) - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
insert(Any, IDLType) - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
insert(Any, long[]) - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
insert(Any, int[]) - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
insert(Any, NameValuePair) - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
insert(Any, Object) - 类 org.omg.CORBA.ObjectHelper 中的静态方法
insert(Any, byte[]) - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
insert(Any, ParameterMode) - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
insert(Any, short) - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
insert(Any, PolicyError) - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
insert(Any, Policy) - 类 org.omg.CORBA.PolicyHelper 中的静态方法
insert(Any, Policy[]) - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
insert(Any, int) - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
insert(Any, ServiceDetail) - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
insert(Any, ServiceInformation) - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
insert(Any, SetOverrideType) - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
insert(Any, short[]) - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
insert(Any, String[]) - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.StringValueHelper 中的静态方法
insert(Any, StructMember) - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
insert(Any, long[]) - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
insert(Any, int[]) - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
insert(Any, UnionMember) - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
insert(Any, UnknownUserException) - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
insert(Any, short[]) - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
insert(Any, Serializable) - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
insert(Any, ValueMember) - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
insert(Any, short) - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
insert(Any, char[]) - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
insert(Any, WrongTransaction) - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
insert(Any, String[]) - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
insert(Any, Binding) - 类 org.omg.CosNaming.BindingHelper 中的静态方法
insert(Any, BindingIterator) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
insert(Any, Binding[]) - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
insert(Any, BindingType) - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
insert(Any, String) - 类 org.omg.CosNaming.IstringHelper 中的静态方法
insert(Any, NameComponent) - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
insert(Any, NameComponent[]) - 类 org.omg.CosNaming.NameHelper 中的静态方法
insert(Any, NamingContextExt) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
insert(Any, String) - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
insert(Any, InvalidAddress) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
insert(Any, String) - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
insert(Any, String) - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
insert(Any, NamingContext) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
insert(Any, AlreadyBound) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
insert(Any, CannotProceed) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
insert(Any, InvalidName) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
insert(Any, NotEmpty) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
insert(Any, NotFound) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
insert(Any, NotFoundReason) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
insert(Any, Any[]) - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
insert(Any, DynAnyFactory) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
insert(Any, InconsistentTypeCode) - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
insert(Any, DynAny) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
insert(Any, InvalidValue) - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
insert(Any, TypeMismatch) - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
insert(Any, DynAny[]) - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
insert(Any, DynArray) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
insert(Any, DynEnum) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
insert(Any, DynFixed) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
insert(Any, DynSequence) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
insert(Any, DynStruct) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
insert(Any, DynUnion) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
insert(Any, DynValue) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
insert(Any, String) - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
insert(Any, NameDynAnyPair) - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
insert(Any, NameDynAnyPair[]) - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
insert(Any, NameValuePair) - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
insert(Any, NameValuePair[]) - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
insert(Any, CodecFactory) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
insert(Any, UnknownEncoding) - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
insert(Any, FormatMismatch) - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
insert(Any, InvalidTypeForEncoding) - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
insert(Any, TypeMismatch) - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
insert(Any, int) - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
insert(Any, IOR) - 类 org.omg.IOP.IORHelper 中的静态方法
insert(Any, TaggedComponent[]) - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
insert(Any, int) - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
insert(Any, ServiceContext) - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
insert(Any, ServiceContext[]) - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
insert(Any, int) - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
insert(Any, TaggedComponent) - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
insert(Any, TaggedProfile) - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
insert(Any, short) - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
insert(Any, int) - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
insert(Any, String[]) - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
insert(Any, short) - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
insert(Any, Current) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
insert(Any, ForwardRequest) - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
insert(Any, InvalidSlot) - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
insert(Any, IORInterceptor_3_0) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
insert(Any, byte[]) - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
insert(Any, ObjectReferenceFactory) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
insert(Any, ObjectReferenceTemplate) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
insert(Any, ObjectReferenceTemplate[]) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
insert(Any, String) - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
insert(Any, DuplicateName) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
insert(Any, InvalidName) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
insert(Any, String) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
insert(Any, String) - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
insert(Any, Current) - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
insert(Any, NoContext) - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
insert(Any, ForwardRequest) - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
insert(Any, POA) - 类 org.omg.PortableServer.POAHelper 中的静态方法
insert(Any, AdapterInactive) - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
insert(Any, AdapterAlreadyExists) - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
insert(Any, AdapterNonExistent) - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
insert(Any, InvalidPolicy) - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
insert(Any, NoServant) - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
insert(Any, ObjectAlreadyActive) - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
insert(Any, ObjectNotActive) - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
insert(Any, ServantAlreadyActive) - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
insert(Any, ServantNotActive) - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
insert(Any, WrongAdapter) - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
insert(Any, WrongPolicy) - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
insert(Any, ServantActivator) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
insert(Any, ServantLocator) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
insert_any(Any) - 类 org.omg.CORBA.Any 中的方法
将给定 Any 对象插入此 Any 对象的 value 字段。
insert_any(Any) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 org.omg.CORBA.Any 对象作为此 DynAny 对象的值。
insert_any(Any) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 Any 值插入由此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_boolean(boolean) - 类 org.omg.CORBA.Any 中的方法
将给定 boolean 值插入此 Any 对象的 value 字段。
insert_boolean(boolean) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 boolean 值作为此 DynAny 对象的值。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 boolean 值插入 DynAny 中。
insert_char(char) - 类 org.omg.CORBA.Any 中的方法
将给定 char 值插入此 Any 对象的 value 字段。
insert_char(char) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 char 值作为此 DynAny 对象的值。
insert_char(char) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 char 值插入 DynAny 中。
insert_double(double) - 类 org.omg.CORBA.Any 中的方法
将给定 double 值插入此 Any 对象的 value 字段。
insert_double(double) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 double 值作为此 DynAny 对象的值。
insert_double(double) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 double 值插入 DynAny 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_fixed(BigDecimal) - 类 org.omg.CORBA.Any 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
insert_fixed(BigDecimal, TypeCode) - 类 org.omg.CORBA.Any 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
insert_float(float) - 类 org.omg.CORBA.Any 中的方法
将给定 float 值插入此 Any 对象的 value 字段。
insert_float(float) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 float 值作为此 DynAny 对象的值。
insert_float(float) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 float 值插入 DynAny 中。
insert_long(int) - 类 org.omg.CORBA.Any 中的方法
将给定 int 值插入此 Any 对象的 value 字段。
insert_long(int) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 int 值作为此 DynAny 对象的值。
insert_long(int) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 integer 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.CORBA.Any 中的方法
将给定 long 值插入此 Any 对象的 value 字段。
insert_longlong(long) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 long 值作为此 DynAny 对象的值。
insert_longlong(long) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 long 值插入 DynAny 中。
insert_Object(Object) - 类 org.omg.CORBA.Any 中的方法
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
insert_Object(Object, TypeCode) - 类 org.omg.CORBA.Any 中的方法
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
insert_octet(byte) - 类 org.omg.CORBA.Any 中的方法
将给定 byte 值插入此 Any 对象的 value 字段。
insert_octet(byte) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 byte 值作为此 DynAny 对象的值。
insert_octet(byte) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 byte 值插入 DynAny 中。
insert_Principal(Principal) - 类 org.omg.CORBA.Any 中的方法
已过时。 由 CORBA 2.2 取代。
insert_reference(Object) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 org.omg.CORBA.Object 作为此 DynAny 对象的值。
insert_reference(Object) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将对 CORBA 对象的引用插入 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将对 CORBA 对象的引用插入 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将对 CORBA 对象的引用插入 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
insert_reference(Object) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
INSERT_ROW_CONFLICT - 接口 javax.sql.rowset.spi.SyncResolver 中的静态变量
指示在 RowSet 对象试图将行插入数据源中时发生冲突。
insert_short(short) - 类 org.omg.CORBA.Any 中的方法
将给定 short 值插入此 Any 对象的 value 字段。
insert_short(short) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 short 值作为此 DynAny 对象的值。
insert_short(short) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 short 值插入 DynAny 中。
insert_Streamable(Streamable) - 类 org.omg.CORBA.Any 中的方法
将给定 Streamable 对象插入此 Any 对象的 value 字段。
insert_string(String) - 类 org.omg.CORBA.Any 中的方法
将给定 String 对象插入此 Any 对象的 value 字段。
insert_string(String) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 String 对象作为此 DynAny 对象的值。
insert_string(String) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 string 值插入 DynAny 中。
insert_TypeCode(TypeCode) - 类 org.omg.CORBA.Any 中的方法
将给定 TypeCode 对象插入此 Any 对象的 value 字段。
insert_typecode(TypeCode) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 org.omg.CORBA.TypeCode 值作为此 DynAny 对象的值。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_ulong(int) - 类 org.omg.CORBA.Any 中的方法
将给定 int 值插入此 Any 对象的 value 字段。
insert_ulong(int) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 int 值作为此 DynAny 对象的值。
insert_ulong(int) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 integer 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.CORBA.Any 中的方法
将给定 long 值插入此 Any 对象的 value 字段。
insert_ulonglong(long) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 long 值作为此 DynAny 对象的值。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 long 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.CORBA.Any 中的方法
将给定 short 值插入此 Any 对象的 value 字段。
insert_ushort(short) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 short 值作为此 DynAny 对象的值。
insert_ushort(short) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 short 值插入 DynAny 中。
insert_val(Serializable) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 java.io.Serializable 对象作为此 DynAny 对象的值。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_Value(Serializable) - 类 org.omg.CORBA.Any 中的方法
将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
insert_Value(Serializable, TypeCode) - 类 org.omg.CORBA.Any 中的方法
将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
insert_wchar(char) - 类 org.omg.CORBA.Any 中的方法
将给定 char 值插入此 Any 对象的 value 字段。
insert_wchar(char) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 char 值作为此 DynAny 对象的值。
insert_wchar(char) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 char 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.CORBA.Any 中的方法
将给定 String 对象插入此 Any 对象的 value 字段。
insert_wstring(String) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 String 作为此 DynAny 对象的值。
insert_wstring(String) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 string 值插入 DynAny 中。
insertAfterEnd(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
将指定为字符串的 HTML 插入给定元素的起始处之后。
insertAfterStart(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
将指定为字符串的 HTML 插入元素的起始处。
insertAtBoundary(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的方法
当在边界上插入时调用。
insertAtBoundry(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的方法
已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
insertBefore(Node, Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
在现有子节点 refChild 之前插入节点 newChild。
insertBefore(Node, Node) - 接口 org.w3c.dom.Node 中的方法
在现有子节点 refChild 之前插入节点 newChild。
insertBeforeEnd(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
将指定为字符串的 HTML 插入元素的结尾处。
insertBeforeStart(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
将指定为字符串的 HTML 插入给定元素的起始处之前。
insertBreakAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
向文档放置行/段中断的动作名称。
insertChar(AttributedCharacterIterator, int) - 类 java.awt.font.LineBreakMeasurer 中的方法
将单个字符插入文本后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。
insertChar(AttributedCharacterIterator, int) - 类 java.awt.font.TextMeasurer 中的方法
在将单个字符插入当前由此 TextMeasurer 表示的段落中后，更新该 TextMeasurer。
insertComponent(Component) - 类 javax.swing.JTextPane 中的方法
将一个组件插入到文档中，以替换当前选择的内容。
insertContentAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
将内容置于关联文档中的动作名称。
insertData(int, String) - 接口 org.w3c.dom.CharacterData 中的方法
在指定的 16 位单元偏移量位置插入一个字符串。
insertElementAt(E, int) - 类 java.util.Vector 中的方法
将指定对象作为此向量中的组件插入到指定的 index 处。
insertElementAt(Object, int) - 类 javax.swing.DefaultComboBoxModel 中的方法
insertElementAt(Object, int) - 类 javax.swing.DefaultListModel 中的方法
将指定对象作为此列表中的组件插入到指定的 index 处。
insertElementAt(Object, int) - 接口 javax.swing.MutableComboBoxModel 中的方法
在指定索引处添加项。
insertEntries(int, int, int) - 类 javax.swing.SizeSequence 中的方法
将一组相邻的条目添加到此 SizeSequence 中。
insertHTML(HTMLDocument, int, String, int, int, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
将 HTML 插入现有文档。
insertHTML(JEditorPane, HTMLDocument, int, String, int, int, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的方法
HTMLEditorKit.insertHTML 的一个覆盖。
insertIcon(Icon) - 类 javax.swing.JTextPane 中的方法
将一个图标插入文档中，以替换当前选择的内容。
insertIndexForLayer(int, int) - 类 javax.swing.JLayeredPane 中的方法
一个根据层和位置要求确定插入新子组件的正确位置的基本方法。
insertIndexInterval(int, int, boolean) - 类 javax.swing.DefaultListSelectionModel 中的方法
从 index 之前/之后开始插入 length 个索引。
insertIndexInterval(int, int, boolean) - 接口 javax.swing.ListSelectionModel 中的方法
在 index 之前/之后开始插入 length 个索引。
insertItemAt(Object, int) - 类 javax.swing.JComboBox 中的方法
在项列表中的给定索引处插入项。
insertNodeInto(MutableTreeNode, MutableTreeNode, int) - 类 javax.swing.tree.DefaultTreeModel 中的方法
对它进行调用，以便在父节点的子节点中的 index 位置插入 newChild。
insertProviderAt(Provider, int) - 类 java.security.Security 中的静态方法
在指定的位置添加新的提供者。
insertRow() - 接口 java.sql.ResultSet 中的方法
将插入行的内容插入到此 ResultSet 对象和数据库中。
insertRow(int, Vector) - 类 javax.swing.table.DefaultTableModel 中的方法
在模型中的 row 位置插入一行。
insertRow(int, Object[]) - 类 javax.swing.table.DefaultTableModel 中的方法
在模型中的 row 位置插入一行。
insertsAreDetected(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以通过调用 ResultSet.rowInserted 方法检测可见行的插入。
insertSeparator(int) - 类 java.awt.Menu 中的方法
在指定的位置插入分隔符。
insertSeparator(int) - 类 javax.swing.JMenu 中的方法
在指定的位置插入分隔符。
insertString(int, String) - 接口 javax.swing.text.AbstractDocument.Content 中的方法
向序列中插入一个字符串。
insertString(int, String, AttributeSet) - 类 javax.swing.text.AbstractDocument 中的方法
将某些内容插入文档。
insertString(int, String, AttributeSet) - 接口 javax.swing.text.Document 中的方法
插入内容字符串。
insertString(int, String, AttributeSet) - 类 javax.swing.text.DocumentFilter.FilterBypass 中的方法
插入指定的文本，绕过 DocumentFilter。
insertString(DocumentFilter.FilterBypass, int, String, AttributeSet) - 类 javax.swing.text.DocumentFilter 中的方法
将文本插入指定的 Document 之前调用。
insertString(int, String) - 类 javax.swing.text.GapContent 中的方法
在内容中插入字符串。
insertString(int, String, AttributeSet) - 类 javax.swing.text.PlainDocument 中的方法
向文档中插入某些内容。
insertString(int, String) - 类 javax.swing.text.StringContent 中的方法
将字符串插入到内容中。
insertTab(String, Icon, Component, String, int) - 类 javax.swing.JTabbedPane 中的方法
在 index 位置插入一个 component，该组件通过 title 和/或 icon（任意一个都可以为 null）来表示。
insertTabAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
将制表符置于文档中的动作名称。
insertText(String, int) - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 insert(String, int) 取代。
insertTextAtIndex(int, String) - 接口 javax.accessibility.AccessibleEditableText 中的方法
在给定索引处插入指定的字符串。
insertTextAtIndex(int, String) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
在给定索引处插入指定的字符串。
insertTextAtIndex(int, String) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
在给定索引处插入指定字符串
insertUpdate(DocumentEvent) - 接口 javax.swing.event.DocumentListener 中的方法
给出对文档执行了插入操作的通知。
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - 类 javax.swing.text.AbstractDocument 中的方法
在文本插入后更新文档结构。
insertUpdate(DefaultStyledDocument.ElementSpec[]) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
向文档添加更新。
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - 类 javax.swing.text.DefaultStyledDocument 中的方法
在文本插入后更新文档结构。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.FieldView 中的方法
通知在文档中此视图负责的某个位置已插入内容。
insertUpdate(FlowView, DocumentEvent, Rectangle) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
发出通知，通知在文档中此视图负责的某个位置已插入内容。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.FlowView 中的方法
发出通知，通知在文档中此视图负责的某个位置已插入内容。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.GlyphView 中的方法
发出通知，通知文档中此视图负责的位置已插入内容。
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - 类 javax.swing.text.html.HTMLDocument 中的方法
由于插入文本而导致更新文档的结构。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.html.InlineView 中的方法
发出通知，通知文档中此视图负责的位置已插入内容。
insertUpdate(DocumentEvent) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
处理文档插入（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - 类 javax.swing.text.PlainDocument 中的方法
随文本插入更新文档结构。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.PlainView 中的方法
发出通知，通知在文档中此视图负责的某个位置已插入内容。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.View 中的方法
发出通知，通知在文档中此视图负责的某个位置已插入内容。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.WrappedPlainView 中的方法
发出在文档中此视图负责的位置插入了某些内容的通知。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.ZoneView 中的方法
给出在文档中此视图负责的位置插入了某些内容的通知。
insetCache - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
insets() - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 getInsets() 取代。
insets - 类 java.awt.GridBagConstraints 中的变量
此字段指定组件的外部填充，即组件与其显示区域边缘之间间距的最小量。
Insets - java.awt 中的 类
Insets 对象是容器边界的表示形式。
Insets(int, int, int, int) - 类 java.awt.Insets 的构造方法
创建并初始化具有指定顶部、左边、底部、右边 inset 的新 Insets 对象。
InsetsUIResource - javax.swing.plaf 中的 类
InsetsUIResource(int, int, int, int) - 类 javax.swing.plaf.InsetsUIResource 的构造方法
inside(int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。
inside(int, int) - 类 java.awt.Polygon 中的方法
已过时。 从 JDK version 1.1 开始, 此函数为 contains(int, int)。
inside(int, int) - 类 java.awt.Rectangle 中的方法
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。
insideBorder - 类 javax.swing.border.CompoundBorder 中的变量
install(JFormattedTextField) - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
将 AbstractFormatter 安装到特定的 JFormattedTextField。
install(JTextComponent) - 接口 javax.swing.text.Caret 中的方法
在将 UI 安装到 JTextComponent 的接口中时调用。
install(JTextComponent) - 类 javax.swing.text.DefaultCaret 中的方法
当 UI 装入一个 JTextComponent 的接口时调用。
install(JFormattedTextField) - 类 javax.swing.text.DefaultFormatter 中的方法
将 DefaultFormatter 安装到特定的 JFormattedTextField。
install(JTextComponent) - 类 javax.swing.text.DefaultHighlighter 中的方法
当 UI 安装到 JTextComponent 的接口时调用。
install(JEditorPane) - 类 javax.swing.text.EditorKit 中的方法
将工具包安装到 JEditorPane 中时调用。
install(JTextComponent) - 接口 javax.swing.text.Highlighter 中的方法
将 UI 安装到 JTextComponent 的接口时调用。
install(JEditorPane) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
将工具包安装到 JEditorPane 中时调用。
install(JFormattedTextField) - 类 javax.swing.text.InternationalFormatter 中的方法
将 DefaultFormatter 安装到特定的 JFormattedTextField 上。
install(JFormattedTextField) - 类 javax.swing.text.MaskFormatter 中的方法
将 DefaultFormatter 安装在特定的 JFormattedTextField 上。
install(JEditorPane) - 类 javax.swing.text.StyledEditorKit 中的方法
工具包安装到 JEditorPane 时调用。
installAncestorListener() - 类 javax.swing.JComboBox 中的方法
installBorder(JComponent, String) - 类 javax.swing.LookAndFeel 中的静态方法
使用默认的值设置组件边框属性的便捷方法。
installChooserPanel(JColorChooser) - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
将面板添加到选取器时被调用。
installColors(JComponent, String, String) - 类 javax.swing.LookAndFeel 中的静态方法
使用默认的值设置组件的前景和背景颜色属性的便捷方法。
installColorsAndFont(JComponent, String, String, String) - 类 javax.swing.LookAndFeel 中的静态方法
使用默认的值设置组件的前景、背景和字体属性的便捷方法。
installComboBoxListeners() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此方法在 JComboBox 中添加必需的侦听器。
installComboBoxModelListeners(ComboBoxModel) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
在组合框模型中安装侦听器。
installComponents() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建并初始化构成聚合组合框的组件。
installComponents() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
installComponents(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installComponents() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installComponents(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
installComponents(JMenuItem) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
installComponents() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
installComponents(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
installComponents() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
installComponents() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
创建并安装 JTabbedPane 的所有必需的子组件。
installComponents() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
installComponents() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
安装作为渲染器窗格的树的子组件。
installComponents() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法
installComponents(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
将默认颜色、默认字体、默认渲染器和默认编辑器安装到 JComboBox 中。
installDefaults() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
installDefaults(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installDefaults(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
初始化 JList 属性（如字体、前景和背景）并添加 CellRendererPane。
installDefaults() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
installDefaults(JPanel) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicPasswordFieldUI 中的方法
在 JPasswordField 上安装所需的属性。
installDefaults() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法
installDefaults(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
installDefaults(JScrollPane) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
installDefaults(JSeparator) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
installDefaults(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
初始化 JSpinner border、foreground、background 属性以及基于默认表中对应的 "Spinner.*" 属性。
installDefaults() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
安装 UI 默认值。
installDefaults() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
初始化 JTableHeader 属性，例如，字体、前景和背景。
installDefaults() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
初始化 JTable 属性，例如，字体、前景和背景。
installDefaults() - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
初始化组件属性，例如，字体、前景、背景、插入符颜色、选择颜色、所选文本颜色、禁用文本颜色，以及边框颜色。
installDefaults(JSeparator) - 类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
installDefaults(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
installDefaults(JComponent) - 类 javax.swing.plaf.basic.BasicViewportUI 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalCheckBoxUI 中的方法
installDefaults() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法
installDefaults() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法
installDefaults() - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
installDefaults(JSeparator) - 类 javax.swing.plaf.metal.MetalSeparatorUI 中的方法
installDefaults() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
installDefaults(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
在 context 的 JComponent 上根据此 Style 安装必要的状态。
installDesktopManager() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
installIcons(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installKeyboardActions(JComponent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
注册默认键动作：按下空格键以“单击”按钮并注册键盘助记符（如果有）。
installKeyboardActions(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
将键盘动作添加到 JComboBox。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installKeyboardActions(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
在与 BasicListUI 关联的 JList 上注册键盘绑定。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
installKeyboardActions(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
installKeyboardActions(JScrollPane) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
installKeyboardActions(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
在 JSpinner 上安装键盘动作。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
安装 UI 的键盘动作。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
在 JTableHeader 上注册所有的键盘动作。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
在 JTable 上注册所有的键盘动作。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
installListeners(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
为组合框及其模型创建并安装侦听器。
installListeners() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
将从 createPropertyChangeListener 返回的 PropertyChangeListener 安装到 JDesktopPane 上。
installListeners(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installListeners(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
为 JList、其模型及其 selectionModel 创建并安装侦听器。
installListeners() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
installListeners(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
installListeners(JScrollPane) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
installListeners(JSeparator) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
installListeners(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
用将感兴趣的 PropertyChangeEvent 委托给受保护方法的共享对象初始化 PropertyChangeListener。
installListeners() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
安装 UI 的事件侦听器。
installListeners() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
将侦听器附加到 JTableHeader 上。
installListeners() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
将侦听器附加到 JTable 上。
installListeners() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
安装 UI 的侦听器。
installListeners() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
installListeners(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
installListeners() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法
installListeners(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
installListeners() - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
installListeners() - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
installListeners(JScrollPane) - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的方法
installListeners() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
installListListeners() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
将侦听器添加到列表控件。
installLookAndFeel(UIManager.LookAndFeelInfo) - 类 javax.swing.UIManager 中的静态方法
将指定的外观添加到可用外观的集合中。
installLookAndFeel(String, String) - 类 javax.swing.UIManager 中的静态方法
将指定的外观添加到可用外观的集合中。
installMouseHandlers(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installNextButtonListeners(Component) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
在下一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。
installNonRolloverBorders(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
在 JComponent 的所有子组件上安装非翻转边框。
installNormalBorders(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
在 JComponent 的所有子组件上安装普通边框。
installPreviewPanel() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
installPreviousButtonListeners(Component) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
在上一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。
installProperty(JComponent, String, Object) - 类 javax.swing.LookAndFeel 中的静态方法
在组件上安装具有指定名称和值的属性的便捷方法，条件是该属性尚未由开发人员设置。
installRolloverBorders(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
在 JComponent 的所有子组件上安装翻转边框。
installStrings(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installStrings(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
installTitlePane() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的方法
安装组件的 UI。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
按顺序调用 installDefaults()、installListeners() 和 installKeyboardActions() 来初始化 this.list。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
安装作为传入 JOptionPane 的 L&F 的接收者。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
调用 installDefaults、installListeners，然后添加由 createNextButton、createPreviousButton 和 createEditor 返回的组件。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
安装 UI。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
安装组件的 UI。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicViewportUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
配置指定组件，使其适合外观。
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalMenuBarUI 中的方法
配置指定组件，使其适合 metal 外观。
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalRootPaneUI 中的方法
调用 installUI 的超实现来在传入的 JRootPane 上安装必要的状态，以呈现 RootPaneUI 的 metal 外观实现。
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
InstanceAlreadyExistsException - javax.management 中的 异常
已经在存储库中注册了 MBean。
InstanceAlreadyExistsException() - 异常 javax.management.InstanceAlreadyExistsException 的构造方法
默认的构造方法。
InstanceAlreadyExistsException(String) - 异常 javax.management.InstanceAlreadyExistsException 的构造方法
允许指定特定错误消息的构造方法。
instanceFollowRedirects - 类 java.net.HttpURLConnection 中的变量
如果为 true，则协议自动执行重定向。
InstanceNotFoundException - javax.management 中的 异常
存储库中不存在指定的 MBean。
InstanceNotFoundException() - 异常 javax.management.InstanceNotFoundException 的构造方法
默认的构造方法。
InstanceNotFoundException(String) - 异常 javax.management.InstanceNotFoundException 的构造方法
允许指定特定错误消息的构造方法。
instantiate(ClassLoader, String) - 类 java.beans.Beans 中的静态方法
实例化 JavaBean。
instantiate(ClassLoader, String, BeanContext) - 类 java.beans.Beans 中的静态方法
实例化 JavaBean。
instantiate(ClassLoader, String, BeanContext, AppletInitializer) - 类 java.beans.Beans 中的静态方法
实例化 bean。
instantiate(Object, Encoder) - 类 java.beans.DefaultPersistenceDelegate 中的方法
instantiate 方法的此默认实现返回一个表达式，该表达式包含预先定义的方法名称 "new"，该名称表示调用带有参数（在 DefaultPersistenceDelegate 的构造方法中指定）的构造方法。
instantiate(Object, Encoder) - 类 java.beans.PersistenceDelegate 中的方法
返回其值为 oldInstance 的表达式。
instantiate(String) - 接口 javax.management.MBeanServer 中的方法
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。
instantiate(String, ObjectName) - 接口 javax.management.MBeanServer 中的方法
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
instantiate(String, Object[], String[]) - 接口 javax.management.MBeanServer 中的方法
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。
instantiate(String, ObjectName, Object[], String[]) - 接口 javax.management.MBeanServer 中的方法
实例化一个对象。
instantiateChild(String) - 接口 java.beans.beancontext.BeanContext 中的方法
实例化指定为此 BeanContext 的一个子级的 javaBean。
instantiateChild(String) - 类 java.beans.beancontext.BeanContextSupport 中的方法
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。
InstantiationError - java.lang 中的 错误
当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
InstantiationError() - 错误 java.lang.InstantiationError 的构造方法
构造不带详细消息的 InstantiationError。
InstantiationError(String) - 错误 java.lang.InstantiationError 的构造方法
构造带指定详细消息的 InstantiationError。
InstantiationException - java.lang 中的 异常
当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
InstantiationException() - 异常 java.lang.InstantiationException 的构造方法
构造不带详细消息的 InstantiationException。
InstantiationException(String) - 异常 java.lang.InstantiationException 的构造方法
构造带指定详细消息的 InstantiationException。
Instrument - javax.sound.midi 中的 类
乐器是带特定参数设置的声音合成算法，通常是为模仿现实世界的特定乐器或为获得特定音效而设计的。
Instrument(Soundbank, Patch, String, Class<?>) - 类 javax.sound.midi.Instrument 的构造方法
从指定的 Patch 构造一个新的 MIDI 乐器。
Instrumentation - java.lang.instrument 中的 接口
此类提供检测 Java 编程语言代码所需的服务。
InsufficientResourcesException - javax.naming 中的 异常
当无法使用资源完成所请求的操作时，抛出此异常。
InsufficientResourcesException(String) - 异常 javax.naming.InsufficientResourcesException 的构造方法
使用解释构造一个新的 InsufficientResourcesException 实例。
InsufficientResourcesException() - 异常 javax.naming.InsufficientResourcesException 的构造方法
构造一个新的 InsufficientResourcesException 实例，将解释和所有名称解析字段初始化为 null。
insureRowContinuity() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
确保当前选择的 TreePath 对于当前选择模式是有效的。
insureUniqueness() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
此方法已过时，并且其实现现在是一个 noop。
intBitsToFloat(int) - 类 java.lang.Float 中的静态方法
返回对应于给定位表示形式的 float 值。
IntBuffer - java.nio 中的 类
int 缓冲区。
Integer - java.lang 中的 类
Integer 类在对象中包装了一个基本类型 int 的值。
Integer(int) - 类 java.lang.Integer 的构造方法
构造一个新分配的 Integer 对象，它表示指定的 int 值。
Integer(String) - 类 java.lang.Integer 的构造方法
构造一个新分配的 Integer 对象，它表示 String 参数所指示的 int 值。
INTEGER - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 INTEGER 的 Java 编程语言中的常量（有时称为类型代码）。
INTEGER - 类 java.text.NumberFormat.Field 中的静态变量
标识整数字段的常量。
INTEGER - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Integer 的值。
INTEGER_FIELD - 类 java.text.NumberFormat 中的静态变量
用于构造 FieldPosition 对象的字段常量。
IntegerSyntax - javax.print.attribute 中的 类
类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。
IntegerSyntax(int) - 类 javax.print.attribute.IntegerSyntax 的构造方法
使用给定的整数值构造一个新的整数属性。
IntegerSyntax(int, int, int) - 类 javax.print.attribute.IntegerSyntax 的构造方法
使用给定的整数值构造一个新的整数属性，它必须位于给定的范围内。
Interceptor - org.omg.PortableInterceptor 中的 接口
所有 Portable Interceptor 实现 Interceptor。
InterceptorOperations - org.omg.PortableInterceptor 中的 接口
所有 Portable Interceptor 实现 Interceptor。
interestOps() - 类 java.nio.channels.SelectionKey 中的方法
获取此键的 interest 集合。
interestOps(int) - 类 java.nio.channels.SelectionKey 中的方法
将此键的 interest 集合设置为给定值。
INTERFACE - 类 java.lang.reflect.Modifier 中的静态变量
表示 interface 修饰符的 int 的值。
INTERFACE_CLASS_NAME_FIELD - 类 javax.management.JMX 中的静态变量
interfaceClassName 字段的名称。
InterfaceAddress - java.net 中的 类
此类表示网络接口地址。
INTERLOCK_OPEN - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
打印机上的一个或多个连锁设备未锁定。
intern() - 类 java.lang.String 中的方法
返回字符串对象的规范化表示形式。
INTERNAL - org.omg.CORBA 中的 异常
此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
INTERNAL() - 异常 org.omg.CORBA.INTERNAL 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTERNAL 异常。
INTERNAL(String) - 异常 org.omg.CORBA.INTERNAL 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTERNAL 异常。
INTERNAL(int, CompletionStatus) - 异常 org.omg.CORBA.INTERNAL 的构造方法
使用指定次要代码和完成状态构造一个 INTERNAL 异常。
INTERNAL(String, int, CompletionStatus) - 异常 org.omg.CORBA.INTERNAL 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INTERNAL 异常。
INTERNAL_CLOCK - 类 javax.sound.midi.Sequencer.SyncMode 中的静态变量
主同步模式，它使 sequencer 从其内部时钟获取计时信息。
INTERNAL_FRAME - 类 javax.accessibility.AccessibleRole 中的静态变量
通过桌面窗格剪切的类似于窗体的对象。
INTERNAL_FRAME - 类 javax.swing.plaf.synth.Region 中的静态变量
InternalFrame 的 region。
INTERNAL_FRAME_ACTIVATED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口激活”事件类型。
INTERNAL_FRAME_CLOSED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口关闭”事件。
INTERNAL_FRAME_CLOSING - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口正在关闭”事件。
INTERNAL_FRAME_DEACTIVATED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口取消激活”事件类型。
INTERNAL_FRAME_DEICONIFIED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口取消图标化”事件类型。
INTERNAL_FRAME_FIRST - 类 javax.swing.event.InternalFrameEvent 中的静态变量
用于内部窗体事件的 ID 范围的起始编号。
INTERNAL_FRAME_ICONIFIED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口图标化”事件。
INTERNAL_FRAME_LAST - 类 javax.swing.event.InternalFrameEvent 中的静态变量
用于内部窗体事件的 ID 范围的结束编号。
INTERNAL_FRAME_OPENED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口打开”事件。
INTERNAL_FRAME_TITLE_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
InternalFrame 的 TitlePane。
internalEntityDecl(String, String) - 接口 org.xml.sax.ext.DeclHandler 中的方法
报告内部实体声明。
internalEntityDecl(String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
InternalError - java.lang 中的 错误
该异常指示 Java 虚拟机中出现一些意外的内部错误。
InternalError() - 错误 java.lang.InternalError 的构造方法
构造不带详细消息的 InternalError。
InternalError(String) - 错误 java.lang.InternalError 的构造方法
构造带指定详细消息的 InternalError。
internalFrameActivated(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体被激活时调用。
internalFrameActivated(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体被激活时调用。
internalFrameActivated(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
InternalFrameAdapter - javax.swing.event 中的 类
用于接收内部窗体事件的抽象适配器类。
InternalFrameAdapter() - 类 javax.swing.event.InternalFrameAdapter 的构造方法
internalFrameClosed(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体已关闭时调用。
internalFrameClosed(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体已关闭时调用。
internalFrameClosed(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
internalFrameClosing(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体正被关闭时调用。
internalFrameClosing(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体正被关闭时调用。
internalFrameClosing(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
internalFrameDeactivated(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体被取消激活时调用。
internalFrameDeactivated(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体被取消激活时调用。
internalFrameDeactivated(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
internalFrameDeiconified(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体被取消图标化时调用。
internalFrameDeiconified(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体被取消图标化时调用。
internalFrameDeiconified(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
InternalFrameEvent - javax.swing.event 中的 类
以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
InternalFrameEvent(JInternalFrame, int) - 类 javax.swing.event.InternalFrameEvent 的构造方法
构造一个 InternalFrameEvent 对象。
InternalFrameFocusTraversalPolicy - javax.swing 中的 类
该 FocusTraversalPolicy 可以有选择地提供确定 JInternalFrame 初始 Component 的算法。
InternalFrameFocusTraversalPolicy() - 类 javax.swing.InternalFrameFocusTraversalPolicy 的构造方法
internalFrameIconified(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体被图标化时调用。
internalFrameIconified(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体被图标化时调用。
internalFrameIconified(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
internalFrameLayout - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
InternalFrameListener - javax.swing.event 中的 接口
用于接收内部窗体事件的侦听器接口。
internalFrameOpened(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体已打开时调用。
internalFrameOpened(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体已打开时调用。
internalFrameOpened(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
InternalFrameUI - javax.swing.plaf 中的 类
JInternalFrame 的可插入外观界面。
InternalFrameUI() - 类 javax.swing.plaf.InternalFrameUI 的构造方法
internalGet(int) - 类 java.util.Calendar 中的方法
返回给定日历字段的值。
InternationalFormatter - javax.swing.text 中的 类
InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
InternationalFormatter() - 类 javax.swing.text.InternationalFormatter 的构造方法
创建一个不带指定 Format 的 InternationalFormatter。
InternationalFormatter(Format) - 类 javax.swing.text.InternationalFormatter 的构造方法
创建一个具有指定 Format 实例的 InternationalFormatter。
INTERPRETER_RESOURCE_UNAVAILABLE - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
解释器资源（例如字体、格式）不可用。
interrupt() - 类 java.lang.Thread 中的方法
中断线程。
interrupt() - 类 java.lang.ThreadGroup 中的方法
中断此线程组中的所有线程。
interrupted() - 类 java.lang.Thread 中的静态方法
测试当前线程是否已经中断。
InterruptedException - java.lang 中的 异常
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
InterruptedException() - 异常 java.lang.InterruptedException 的构造方法
构造不带详细消息的 InterruptedException。
InterruptedException(String) - 异常 java.lang.InterruptedException 的构造方法
构造带指定详细消息的 InterruptedException。
InterruptedIOException - java.io 中的 异常
I/O 操作已中断信号，抛出此异常。
InterruptedIOException() - 异常 java.io.InterruptedIOException 的构造方法
构造一个 InterruptedIOException，使用 null 作为其错误消息。
InterruptedIOException(String) - 异常 java.io.InterruptedIOException 的构造方法
构造带指定详细消息的 InterruptedIOException。
InterruptedNamingException - javax.naming 中的 异常
当正被调用的命名操作已经被中断时，抛出此异常。
InterruptedNamingException(String) - 异常 javax.naming.InterruptedNamingException 的构造方法
使用问题的解释构造一个 InterruptedNamingException 实例。
InterruptedNamingException() - 异常 javax.naming.InterruptedNamingException 的构造方法
构造一个 InterruptedNamingException 实例，将解释和所有名称解析字段初始化为 null。
InterruptibleChannel - java.nio.channels 中的 接口
可被异步关闭和中断的通道。
intersect(Area) - 类 java.awt.geom.Area 中的方法
将此 Area 的形状设置为其当前形状与指定 Area 形状的交集。
intersect(Rectangle2D, Rectangle2D, Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的静态方法
将指定的一对源 Rectangle2D 对象相交，并将结果置于指定的目标 Rectangle2D 对象中。
INTERSECT - 类 javax.xml.crypto.dsig.spec.XPathType.Filter 中的静态变量
相交过滤操作。
intersection(Rectangle) - 类 java.awt.Rectangle 中的方法
计算此 Rectangle 与指定 Rectangle 的交集。
intersects(double, double, double, double) - 类 java.awt.geom.Arc2D 中的方法
确定弧的内部与指定矩形的内部是否相交。
intersects(double, double, double, double) - 类 java.awt.geom.Area 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.Area 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.CubicCurve2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.CubicCurve2D 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.Ellipse2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.Line2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.Line2D 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(PathIterator, double, double, double, double) - 类 java.awt.geom.Path2D 中的静态方法
测试指定 PathIterator 的内部是否与指定直角坐标集的内部相交。
intersects(PathIterator, Rectangle2D) - 类 java.awt.geom.Path2D 中的静态方法
测试指定 PathIterator 的内部是否与指定 Rectangle2D 的内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.Path2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.Path2D 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.QuadCurve2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.QuadCurve2D 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.Rectangle2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.RectangularShape 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.RoundRectangle2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(double, double, double, double) - 类 java.awt.Polygon 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.Polygon 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(Rectangle) - 类 java.awt.Rectangle 中的方法
确定此 Rectangle 是否与指定的 Rectangle 相交。
intersects(double, double, double, double) - 接口 java.awt.Shape 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 接口 java.awt.Shape 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(BitSet) - 类 java.util.BitSet 中的方法
如果指定的 BitSet 中有设置为 true 的位，并且在此 BitSet 中也将其设置为 true，则返回 ture。
intersectsLine(double, double, double, double) - 类 java.awt.geom.Line2D 中的方法
测试从 (x1,y1) 到 (x2,y2) 的线段是否与此线段相交。
intersectsLine(Line2D) - 类 java.awt.geom.Line2D 中的方法
测试指定的线段是否与此线段相交。
intersectsLine(double, double, double, double) - 类 java.awt.geom.Rectangle2D 中的方法
测试指定线段是否与此 Rectangle2D 的内部相交。
intersectsLine(Line2D) - 类 java.awt.geom.Rectangle2D 中的方法
测试指定的线段是否与此 Rectangle2D 的内部相交。
INTERVAL_ADDED - 类 javax.swing.event.ListDataEvent 中的静态变量
标识添加到列表中的一个或多个相邻项
INTERVAL_REMOVED - 类 javax.swing.event.ListDataEvent 中的静态变量
标识从列表中移除的一个或多个相邻项
intervalAdded(ListDataEvent) - 接口 javax.swing.event.ListDataListener 中的方法
在已将 index0,index1 区间中的索引插入数据模型中之后发送。
intervalAdded(ListDataEvent) - 类 javax.swing.JComboBox 中的方法
此方法作为实现的副作用存在的公共方法。
intervalAdded(ListDataEvent) - 类 javax.swing.JList.AccessibleJList 中的方法
List Data Listener 间隔添加方法。
intervalAdded(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 中的方法
intervalAdded(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 中的方法
intervalAdded(ListDataEvent) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
废弃，不使用。
intervalAdded(ListDataEvent) - 类 javax.swing.plaf.basic.BasicListUI.ListDataHandler 中的方法
intervalRemoved(ListDataEvent) - 接口 javax.swing.event.ListDataListener 中的方法
在已将 index0,index1 区间中的索引从数据模型中移除后发送。
intervalRemoved(ListDataEvent) - 类 javax.swing.JComboBox 中的方法
此方法作为实现的副作用存在的公共方法。
intervalRemoved(ListDataEvent) - 类 javax.swing.JList.AccessibleJList 中的方法
List Data Listener 间隔移除方法。
intervalRemoved(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 中的方法
intervalRemoved(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 中的方法
intervalRemoved(ListDataEvent) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
废弃，不使用。
intervalRemoved(ListDataEvent) - 类 javax.swing.plaf.basic.BasicListUI.ListDataHandler 中的方法
INTF_REPOS - org.omg.CORBA 中的 异常
当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
INTF_REPOS() - 异常 org.omg.CORBA.INTF_REPOS 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTF_REPOS 异常。
INTF_REPOS(String) - 异常 org.omg.CORBA.INTF_REPOS 的构造方法
使用指定详细消息构造一个 INTF_REPOS 异常。
INTF_REPOS(int, CompletionStatus) - 异常 org.omg.CORBA.INTF_REPOS 的构造方法
使用指定次要代码和完成状态构造一个 INTF_REPOS 异常。
INTF_REPOS(String, int, CompletionStatus) - 异常 org.omg.CORBA.INTF_REPOS 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INTF_REPOS 异常。
IntHolder - org.omg.CORBA 中的 类
Int 的 Holder。
IntHolder() - 类 org.omg.CORBA.IntHolder 的构造方法
构造一个新的 IntHolder 对象，将其 value 字段初始化为 0。
IntHolder(int) - 类 org.omg.CORBA.IntHolder 的构造方法
构造一个新的 IntHolder 对象，并使用给定 int 初始化其 value 字段。
intKey() - 类 java.awt.RenderingHints.Key 中的方法
返回子类用来实例化此 Key 的私有整数键。
IntrospectionException - java.beans 中的 异常
在 Introspection 期间发生异常时抛出异常。
IntrospectionException(String) - 异常 java.beans.IntrospectionException 的构造方法
构造带详细消息的 IntrospectionException。
IntrospectionException - javax.management 中的 异常
在 MBean 的 introspection 期间出现的异常。
IntrospectionException() - 异常 javax.management.IntrospectionException 的构造方法
默认的构造方法。
IntrospectionException(String) - 异常 javax.management.IntrospectionException 的构造方法
允许指定特定错误消息的构造方法。
Introspector - java.beans 中的 类
Introspector 类为通过工具学习有关受目标 Java Bean 支持的属性、事件和方法的知识提供了一个标准方法。
intValue() - 类 java.lang.Byte 中的方法
作为一个 int 返回此 Byte 的值。
intValue() - 类 java.lang.Double 中的方法
以 int 形式返回此 Double 的值（通过强制转换为 int 类型）。
intValue() - 类 java.lang.Float 中的方法
将此 Float 值以 int 形式返回（强制转换为 int 类型）。
intValue() - 类 java.lang.Integer 中的方法
以 int 类型返回该 Integer 的值。
intValue() - 类 java.lang.Long 中的方法
以 int 形式返回此 Long 的值。
intValue() - 类 java.lang.Number 中的方法
以 int 形式返回指定的数值。
intValue() - 类 java.lang.Short 中的方法
以 int 形式返回此 Short 的值。
intValue() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 int。
intValue() - 类 java.math.BigInteger 中的方法
将此 BigInteger 转换为 int。
intValue() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
intValue() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
intValue() - 类 java.util.logging.Level 中的方法
获得此级别的整数值。
intValueExact() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 int，以检查丢失的信息。
INUSE_ATTRIBUTE_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图添加已经在其他位置使用的属性。
INV_FLAG - org.omg.CORBA 中的 异常
在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
INV_FLAG() - 异常 org.omg.CORBA.INV_FLAG 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_FLAG 异常。
INV_FLAG(String) - 异常 org.omg.CORBA.INV_FLAG 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_FLAG 异常。
INV_FLAG(int, CompletionStatus) - 异常 org.omg.CORBA.INV_FLAG 的构造方法
使用指定次要代码和完成状态构造一个 INV_FLAG 异常。
INV_FLAG(String, int, CompletionStatus) - 异常 org.omg.CORBA.INV_FLAG 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INV_FLAG 异常。
INV_IDENT - org.omg.CORBA 中的 异常
此异常指示 IDL 标识符在语法上是无效的。
INV_IDENT() - 异常 org.omg.CORBA.INV_IDENT 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_IDENT 异常。
INV_IDENT(String) - 异常 org.omg.CORBA.INV_IDENT 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_IDENT 异常。
INV_IDENT(int, CompletionStatus) - 异常 org.omg.CORBA.INV_IDENT 的构造方法
使用指定次要代码和完成状态构造一个 INV_IDENT 异常。
INV_IDENT(String, int, CompletionStatus) - 异常 org.omg.CORBA.INV_IDENT 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INV_IDENT 异常。
INV_OBJREF - org.omg.CORBA 中的 异常
此异常指示对象引用存在内部错误。
INV_OBJREF() - 异常 org.omg.CORBA.INV_OBJREF 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_OBJREF 异常。
INV_OBJREF(String) - 异常 org.omg.CORBA.INV_OBJREF 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_OBJREF 异常。
INV_OBJREF(int, CompletionStatus) - 异常 org.omg.CORBA.INV_OBJREF 的构造方法
使用指定次要代码和完成状态构造一个 INV_OBJREF 异常。
INV_OBJREF(String, int, CompletionStatus) - 异常 org.omg.CORBA.INV_OBJREF 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INV_OBJREF 异常。
INV_POLICY - org.omg.CORBA 中的 异常
当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
INV_POLICY() - 异常 org.omg.CORBA.INV_POLICY 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 INV_POLICY 异常。
INV_POLICY(String) - 异常 org.omg.CORBA.INV_POLICY 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_POLICY 异常。
INV_POLICY(int, CompletionStatus) - 异常 org.omg.CORBA.INV_POLICY 的构造方法
使用指定次要代码和完成状态构造一个 INV_POLICY 异常。
INV_POLICY(String, int, CompletionStatus) - 异常 org.omg.CORBA.INV_POLICY 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 INV_POLICY 异常。
Invalid - org.omg.CORBA.DynAnyPackage 中的 异常
动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
Invalid() - 异常 org.omg.CORBA.DynAnyPackage.Invalid 的构造方法
构造一个 Invalid 对象。
Invalid(String) - 异常 org.omg.CORBA.DynAnyPackage.Invalid 的构造方法
构造一个 Invalid 对象。
INVALID_ACCESS_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果基础对象不支持某个参数或操作。
INVALID_ACTIVITY - org.omg.CORBA 中的 异常
如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
INVALID_ACTIVITY() - 异常 org.omg.CORBA.INVALID_ACTIVITY 的构造方法
使用次要代码 0 和 CompletionStatus COMPLETED_NO 构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(String) - 异常 org.omg.CORBA.INVALID_ACTIVITY 的构造方法
使用指定消息构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(int, CompletionStatus) - 异常 org.omg.CORBA.INVALID_ACTIVITY 的构造方法
使用指定次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(String, int, CompletionStatus) - 异常 org.omg.CORBA.INVALID_ACTIVITY 的构造方法
使用指定消息、次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。
INVALID_CHARACTER_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果指定无效或非法字符，如在 XML 名称中。
INVALID_MODIFICATION_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图修改基础对象的类型。
INVALID_STATE_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图使用不可用或不再可用的对象。
INVALID_TRANSACTION - org.omg.CORBA 中的 异常
当请求带有无效的事务上下文时，抛出此异常。
INVALID_TRANSACTION() - 异常 org.omg.CORBA.INVALID_TRANSACTION 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(String) - 异常 org.omg.CORBA.INVALID_TRANSACTION 的构造方法
使用指定消息构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(int, CompletionStatus) - 异常 org.omg.CORBA.INVALID_TRANSACTION 的构造方法
使用指定次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(String, int, CompletionStatus) - 异常 org.omg.CORBA.INVALID_TRANSACTION 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。
InvalidActivityException - javax.activity 中的 异常
任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。
InvalidActivityException() - 异常 javax.activity.InvalidActivityException 的构造方法
构造一个新实例，其详细消息为 null。
InvalidActivityException(String) - 异常 javax.activity.InvalidActivityException 的构造方法
构造带有指定详细消息的新实例。
InvalidActivityException(Throwable) - 异常 javax.activity.InvalidActivityException 的构造方法
构造带有指定 cause 的新 throwable。
InvalidActivityException(String, Throwable) - 异常 javax.activity.InvalidActivityException 的构造方法
构造带有指定详细消息和 cause 的新 throwable。
InvalidAddress - org.omg.CosNaming.NamingContextExtPackage 中的 异常
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。
InvalidAddress() - 异常 org.omg.CosNaming.NamingContextExtPackage.InvalidAddress 的构造方法
InvalidAddress(String) - 异常 org.omg.CosNaming.NamingContextExtPackage.InvalidAddress 的构造方法
InvalidAddressHelper - org.omg.CosNaming.NamingContextExtPackage 中的 类
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java。
InvalidAddressHelper() - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 的构造方法
InvalidAddressHolder - org.omg.CosNaming.NamingContextExtPackage 中的 类
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java。
InvalidAddressHolder() - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 的构造方法
InvalidAddressHolder(InvalidAddress) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 的构造方法
InvalidAlgorithmParameterException - java.security 中的 异常
用于无效或不合适的算法参数的异常。
InvalidAlgorithmParameterException() - 异常 java.security.InvalidAlgorithmParameterException 的构造方法
构造不带详细消息的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(String) - 异常 java.security.InvalidAlgorithmParameterException 的构造方法
构造带指定详细消息的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(String, Throwable) - 异常 java.security.InvalidAlgorithmParameterException 的构造方法
创建带指定详细消息和 cause 的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(Throwable) - 异常 java.security.InvalidAlgorithmParameterException 的构造方法
创建带指定 cause 和详细消息的 InvalidAlgorithmParameterException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
InvalidApplicationException - javax.management 中的 异常
试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。
InvalidApplicationException(Object) - 异常 javax.management.InvalidApplicationException 的构造方法
构造具有指定 Object 的 InvalidApplicationException。
invalidate() - 类 java.awt.Component 中的方法
使此组件无效。
invalidate() - 类 java.awt.Container 中的方法
使容器失效。
invalidate() - 类 java.awt.Polygon 中的方法
所有内部缓冲数据的失效或刷新都依赖于此 Polygon 的顶点坐标。
invalidate() - 接口 javax.net.ssl.SSLSession 中的方法
使会话失效。
invalidate() - 类 javax.swing.CellRendererPane 中的方法
重写此方法是为了避免配置单元格渲染器的子级时顺着树向上传播 invalidate。
invalidate() - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
invalidate() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
invalidate() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
invalidateFileCache() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
此方法用于中断文件加载线程。
invalidateLayout(Container) - 类 java.awt.BorderLayout 中的方法
使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。
invalidateLayout(Container) - 类 java.awt.CardLayout 中的方法
使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。
invalidateLayout(Container) - 类 java.awt.GridBagLayout 中的方法
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
invalidateLayout(Container) - 接口 java.awt.LayoutManager2 中的方法
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
invalidateLayout(Container) - 类 javax.swing.BoxLayout 中的方法
指示一个子容器已经更改其布局相关信息，因此应该刷新所有已缓存的计算结果。
invalidateLayout(Container) - 类 javax.swing.GroupLayout 中的方法
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
invalidateLayout(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法
invalidateLayout(Container) - 类 javax.swing.OverlayLayout 中的方法
指示子容器已更改其布局相关信息，这会导致刷新所有缓存计算。
invalidateLayout(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
不执行任何操作。
invalidateLayout(Container) - 类 javax.swing.SpringLayout 中的方法
invalidatePathBounds(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
指示 LayoutCache，path 的边界无效，需要进行更新。
invalidatePathBounds(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
不执行任何操作，FixedHeightLayoutCache 不缓存宽度（即所有可以更改的宽度）。
invalidatePathBounds(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
指示 LayoutCache path 的边界无效，需要更新。
invalidateSizes() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
通知 TreeState 需要重新计算它引用的所有大小。
invalidateSizes() - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
通知 TreeState 需要重新计算它引用的所有大小。
invalidateSizes() - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
通知 TreeState 需要重新计算它引用的所有大小。
InvalidAttributeIdentifierException - javax.naming.directory 中的 异常
在试图用无效的属性标识符创建属性时，抛出此异常。
InvalidAttributeIdentifierException(String) - 异常 javax.naming.directory.InvalidAttributeIdentifierException 的构造方法
使用所提供的解释构造一个新的 InvalidAttributeIdentifierException 实例。
InvalidAttributeIdentifierException() - 异常 javax.naming.directory.InvalidAttributeIdentifierException 的构造方法
构造一个新的 InvalidAttributeIdentifierException 实例。
InvalidAttributesException - javax.naming.directory 中的 异常
在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
InvalidAttributesException(String) - 异常 javax.naming.directory.InvalidAttributesException 的构造方法
使用解释构造一个新的 InvalidAttributesException 实例。
InvalidAttributesException() - 异常 javax.naming.directory.InvalidAttributesException 的构造方法
构造一个新的 InvalidAttributesException 实例。
InvalidAttributeValueException - javax.management 中的 异常
指定的值对该属性无效。
InvalidAttributeValueException() - 异常 javax.management.InvalidAttributeValueException 的构造方法
默认的构造方法。
InvalidAttributeValueException(String) - 异常 javax.management.InvalidAttributeValueException 的构造方法
允许指定特定错误消息的构造方法。
InvalidAttributeValueException - javax.naming.directory 中的 异常
在尝试添加一个与属性的模式定义有冲突的属性时，抛出此类。
InvalidAttributeValueException(String) - 异常 javax.naming.directory.InvalidAttributeValueException 的构造方法
使用解释构造一个新的 InvalidAttributeValueException 实例。
InvalidAttributeValueException() - 异常 javax.naming.directory.InvalidAttributeValueException 的构造方法
构造一个新的 InvalidAttributeValueException 实例。
InvalidClassException - java.io 中的 异常
当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
InvalidClassException(String) - 异常 java.io.InvalidClassException 的构造方法
报告指定了原因的 InvalidClassException。
InvalidClassException(String, String) - 异常 java.io.InvalidClassException 的构造方法
构造一个 InvalidClassException 对象。
InvalidDnDOperationException - java.awt.dnd 中的 异常
java.awt.dnd 包中的各种方法都会抛出此异常。
InvalidDnDOperationException() - 异常 java.awt.dnd.InvalidDnDOperationException 的构造方法
创建一个默认的异常。
InvalidDnDOperationException(String) - 异常 java.awt.dnd.InvalidDnDOperationException 的构造方法
创建一个带有其自身描述性消息的异常。
invalidEdit() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
用户键入无效字符时调用此方法。
invalidEdit() - 类 javax.swing.JFormattedTextField 中的方法
用户输入无效值时调用。
InvalidKeyException - java.security 中的 异常
用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
InvalidKeyException() - 异常 java.security.InvalidKeyException 的构造方法
构造不带详细消息的 InvalidKeyException。
InvalidKeyException(String) - 异常 java.security.InvalidKeyException 的构造方法
构造带指定详细消息的 InvalidKeyException。
InvalidKeyException(String, Throwable) - 异常 java.security.InvalidKeyException 的构造方法
创建带指定详细消息和 cause 的 InvalidKeyException。
InvalidKeyException(Throwable) - 异常 java.security.InvalidKeyException 的构造方法
创建带指定 cause 和详细消息的 InvalidKeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
InvalidKeyException - javax.management.openmbean 中的 异常
当方法参数作为复合数据 的项名称或表格数据 的行索引时，如果其无效，则抛出此运行时异常。
InvalidKeyException() - 异常 javax.management.openmbean.InvalidKeyException 的构造方法
不带详细消息的 InvalidKeyException。
InvalidKeyException(String) - 异常 javax.management.openmbean.InvalidKeyException 的构造方法
带详细消息的 InvalidKeyException。
InvalidKeySpecException - java.security.spec 中的 异常
这是针对无效密钥规范的异常。
InvalidKeySpecException() - 异常 java.security.spec.InvalidKeySpecException 的构造方法
构造不带详细消息的 InvalidKeySpecException。
InvalidKeySpecException(String) - 异常 java.security.spec.InvalidKeySpecException 的构造方法
构造带指定详细消息的 InvalidKeySpecException。
InvalidKeySpecException(String, Throwable) - 异常 java.security.spec.InvalidKeySpecException 的构造方法
创建带指定的详细消息和 cause 的 InvalidKeySpecException。
InvalidKeySpecException(Throwable) - 异常 java.security.spec.InvalidKeySpecException 的构造方法
创建带指定的 cause 和详细消息 (cause==null ? null : cause.toString()) 的 InvalidKeySpecException（它通常包含 cause 的类和详细消息）。
InvalidMarkException - java.nio 中的 异常
当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
InvalidMarkException() - 异常 java.nio.InvalidMarkException 的构造方法
构造此类的一个实例。
InvalidMidiDataException - javax.sound.midi 中的 异常
一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
InvalidMidiDataException() - 异常 javax.sound.midi.InvalidMidiDataException 的构造方法
构造一个 InvalidMidiDataException，使用 null 作为其错误详细消息。
InvalidMidiDataException(String) - 异常 javax.sound.midi.InvalidMidiDataException 的构造方法
构造带指定详细消息的 InvalidMidiDataException。
InvalidName - org.omg.CORBA.ORBPackage 中的 异常
当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。
InvalidName() - 异常 org.omg.CORBA.ORBPackage.InvalidName 的构造方法
构造一个不带原因消息的 InvalidName 异常。
InvalidName(String) - 异常 org.omg.CORBA.ORBPackage.InvalidName 的构造方法
构造一个带有指定原因消息的 InvalidName 异常。
InvalidName - org.omg.CosNaming.NamingContextPackage 中的 异常
org/omg/CosNaming/NamingContextPackage/InvalidName.java。
InvalidName() - 异常 org.omg.CosNaming.NamingContextPackage.InvalidName 的构造方法
InvalidName(String) - 异常 org.omg.CosNaming.NamingContextPackage.InvalidName 的构造方法
InvalidName - org.omg.PortableInterceptor.ORBInitInfoPackage 中的 异常
org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java。
InvalidName() - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName 的构造方法
InvalidName(String) - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName 的构造方法
InvalidNameException - javax.naming 中的 异常
此异常指示被指定的名称不符合命名系统的命名语法。
InvalidNameException(String) - 异常 javax.naming.InvalidNameException 的构造方法
使用问题的解释构造一个 InvalidNameException 实例。
InvalidNameException() - 异常 javax.naming.InvalidNameException 的构造方法
构造一个 InvalidNameException 实例，将所有字段设置为 null。
InvalidNameHelper - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java。
InvalidNameHelper() - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 的构造方法
InvalidNameHelper - org.omg.PortableInterceptor.ORBInitInfoPackage 中的 类
org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java。
InvalidNameHelper() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 的构造方法
InvalidNameHolder - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java。
InvalidNameHolder() - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 的构造方法
InvalidNameHolder(InvalidName) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 的构造方法
InvalidObjectException - java.io 中的 异常
指示一个或多个反序列化对象未通过验证测试。
InvalidObjectException(String) - 异常 java.io.InvalidObjectException 的构造方法
构造一个 InvalidObjectException。
InvalidOpenTypeException - javax.management.openmbean 中的 异常
当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
InvalidOpenTypeException() - 异常 javax.management.openmbean.InvalidOpenTypeException 的构造方法
不带详细消息的 InvalidOpenTypeException。
InvalidOpenTypeException(String) - 异常 javax.management.openmbean.InvalidOpenTypeException 的构造方法
带详细消息的 InvalidOpenTypeException。
InvalidParameterException - java.security 中的 异常
当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
InvalidParameterException() - 异常 java.security.InvalidParameterException 的构造方法
构造不带详细消息的 InvalidParameterException。
InvalidParameterException(String) - 异常 java.security.InvalidParameterException 的构造方法
构造带指定详细消息的 InvalidParameterException。
InvalidParameterSpecException - java.security.spec 中的 异常
这是针对无效参数规范的异常。
InvalidParameterSpecException() - 异常 java.security.spec.InvalidParameterSpecException 的构造方法
构造不带详细消息的 InvalidParameterSpecException。
InvalidParameterSpecException(String) - 异常 java.security.spec.InvalidParameterSpecException 的构造方法
构造带指定详细消息的 InvalidParameterSpecException。
InvalidPolicy - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/InvalidPolicy.java。
InvalidPolicy() - 异常 org.omg.PortableServer.POAPackage.InvalidPolicy 的构造方法
InvalidPolicy(short) - 异常 org.omg.PortableServer.POAPackage.InvalidPolicy 的构造方法
InvalidPolicy(String, short) - 异常 org.omg.PortableServer.POAPackage.InvalidPolicy 的构造方法
InvalidPolicyHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java。
InvalidPolicyHelper() - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 的构造方法
InvalidPreferencesFormatException - java.util.prefs 中的 异常
抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。
InvalidPreferencesFormatException(Throwable) - 异常 java.util.prefs.InvalidPreferencesFormatException 的构造方法
构造带指定原因的 InvalidPreferencesFormatException。
InvalidPreferencesFormatException(String) - 异常 java.util.prefs.InvalidPreferencesFormatException 的构造方法
构造带指定详细消息的 InvalidPreferencesFormatException。
InvalidPreferencesFormatException(String, Throwable) - 异常 java.util.prefs.InvalidPreferencesFormatException 的构造方法
构造带指定详细消息和原因的 InvalidPreferencesFormatException。
InvalidPropertiesFormatException - java.util 中的 异常
当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。
InvalidPropertiesFormatException(Throwable) - 异常 java.util.InvalidPropertiesFormatException 的构造方法
构造一个带指定原因的 InvalidPropertiesFormatException。
InvalidPropertiesFormatException(String) - 异常 java.util.InvalidPropertiesFormatException 的构造方法
构造一个带指定详细消息的 InvalidPropertiesFormatException。
InvalidRelationIdException - javax.management.relation 中的 异常
为关系提供的关系 id 已使用时引发此异常。
InvalidRelationIdException() - 异常 javax.management.relation.InvalidRelationIdException 的构造方法
默认的构造方法，其异常中未放置任何消息。
InvalidRelationIdException(String) - 异常 javax.management.relation.InvalidRelationIdException 的构造方法
异常中放置了给定消息的构造方法。
InvalidRelationServiceException - javax.management.relation 中的 异常
提供无效 Relation Service（关系服务）时引发此异常。
InvalidRelationServiceException() - 异常 javax.management.relation.InvalidRelationServiceException 的构造方法
默认的构造方法，其异常中未放置任何消息。
InvalidRelationServiceException(String) - 异常 javax.management.relation.InvalidRelationServiceException 的构造方法
异常中放置了给定消息的构造方法。
InvalidRelationTypeException - javax.management.relation 中的 异常
无效的关系类型。
InvalidRelationTypeException() - 异常 javax.management.relation.InvalidRelationTypeException 的构造方法
默认的构造方法，其异常中未放置任何消息。
InvalidRelationTypeException(String) - 异常 javax.management.relation.InvalidRelationTypeException 的构造方法
异常中放置了给定消息的构造方法。
InvalidRoleInfoException - javax.management.relation 中的 异常
在角色信息中，其最小程度大于其最大程度时，引发此异常。
InvalidRoleInfoException() - 异常 javax.management.relation.InvalidRoleInfoException 的构造方法
默认的构造方法，其异常中未放置任何消息。
InvalidRoleInfoException(String) - 异常 javax.management.relation.InvalidRoleInfoException 的构造方法
异常中放置了给定消息的构造方法。
InvalidRoleValueException - javax.management.relation 中的 异常
角色值无效。
InvalidRoleValueException() - 异常 javax.management.relation.InvalidRoleValueException 的构造方法
默认的构造方法，其异常中未放置任何消息。
InvalidRoleValueException(String) - 异常 javax.management.relation.InvalidRoleValueException 的构造方法
异常中放置了给定消息的构造方法。
InvalidSearchControlsException - javax.naming.directory 中的 异常
在为搜索操作指定的 SearchControls 无效时，抛出此异常。
InvalidSearchControlsException() - 异常 javax.naming.directory.InvalidSearchControlsException 的构造方法
构造一个新的 InvalidSearchControlsException 实例。
InvalidSearchControlsException(String) - 异常 javax.naming.directory.InvalidSearchControlsException 的构造方法
使用解释构造一个新的 InvalidSearchControlsException 实例。
InvalidSearchFilterException - javax.naming.directory 中的 异常
当指定的搜索过滤器无效时，抛出此异常。
InvalidSearchFilterException() - 异常 javax.naming.directory.InvalidSearchFilterException 的构造方法
构造一个新的 InvalidSearchFilterException 实例。
InvalidSearchFilterException(String) - 异常 javax.naming.directory.InvalidSearchFilterException 的构造方法
使用解释构造一个新的 InvalidSearchFilterException 实例。
InvalidSeq - org.omg.CORBA.DynAnyPackage 中的 异常
任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
InvalidSeq() - 异常 org.omg.CORBA.DynAnyPackage.InvalidSeq 的构造方法
构造一个 InvalidSeq 对象。
InvalidSeq(String) - 异常 org.omg.CORBA.DynAnyPackage.InvalidSeq 的构造方法
构造一个 InvalidSeq 对象。
InvalidSlot - org.omg.PortableInterceptor 中的 异常
org/omg/PortableInterceptor/InvalidSlot.java。
InvalidSlot() - 异常 org.omg.PortableInterceptor.InvalidSlot 的构造方法
InvalidSlot(String) - 异常 org.omg.PortableInterceptor.InvalidSlot 的构造方法
InvalidSlotHelper - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/InvalidSlotHelper.java。
InvalidSlotHelper() - 类 org.omg.PortableInterceptor.InvalidSlotHelper 的构造方法
InvalidTargetObjectTypeException - javax.management.modelmbean 中的 异常
当指定了无效的目标对象类型时，抛出此异常。
InvalidTargetObjectTypeException() - 异常 javax.management.modelmbean.InvalidTargetObjectTypeException 的构造方法
默认构造方法。
InvalidTargetObjectTypeException(String) - 异常 javax.management.modelmbean.InvalidTargetObjectTypeException 的构造方法
根据字符串进行构造的构造方法。
InvalidTargetObjectTypeException(Exception, String) - 异常 javax.management.modelmbean.InvalidTargetObjectTypeException 的构造方法
带有异常和字符串的构造方法。
InvalidTransactionException - javax.transaction 中的 异常
此异常指示该请求带来了无效的事务上下文。
InvalidTransactionException() - 异常 javax.transaction.InvalidTransactionException 的构造方法
InvalidTransactionException(String) - 异常 javax.transaction.InvalidTransactionException 的构造方法
InvalidTypeForEncoding - org.omg.IOP.CodecPackage 中的 异常
org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。
InvalidTypeForEncoding() - 异常 org.omg.IOP.CodecPackage.InvalidTypeForEncoding 的构造方法
InvalidTypeForEncoding(String) - 异常 org.omg.IOP.CodecPackage.InvalidTypeForEncoding 的构造方法
InvalidTypeForEncodingHelper - org.omg.IOP.CodecPackage 中的 类
org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java。
InvalidTypeForEncodingHelper() - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 的构造方法
InvalidValue - org.omg.CORBA.DynAnyPackage 中的 异常
InvalidValue() - 异常 org.omg.CORBA.DynAnyPackage.InvalidValue 的构造方法
构造一个 InvalidValue 对象。
InvalidValue(String) - 异常 org.omg.CORBA.DynAnyPackage.InvalidValue 的构造方法
构造一个 InvalidValue 对象。
InvalidValue - org.omg.DynamicAny.DynAnyPackage 中的 异常
org/omg/DynamicAny/DynAnyPackage/InvalidValue.java。
InvalidValue() - 异常 org.omg.DynamicAny.DynAnyPackage.InvalidValue 的构造方法
InvalidValue(String) - 异常 org.omg.DynamicAny.DynAnyPackage.InvalidValue 的构造方法
InvalidValueHelper - org.omg.DynamicAny.DynAnyPackage 中的 类
org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java。
InvalidValueHelper() - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 的构造方法
inverseTransform(Point2D, Point2D) - 类 java.awt.geom.AffineTransform 中的方法
逆向变换指定的 ptSrc 并将结果存储在 ptDst 中。
inverseTransform(double[], int, double[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来逆向变换双精度坐标数组。
invert() - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为它自身的逆变换。
INVITE - 类 java.awt.PageAttributes.MediaType 中的静态变量
INVITE_ENVELOPE 的别名。
INVITE_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
Invitation Envelope (220 x 220 mm) 的 MediaType 实例。
Invocable - javax.script 中的 接口
由 ScriptEngines 实现的可选接口，该 ScriptEngines 的方法允许在以前执行过的脚本中调用程序。
INVOCATION_DEFAULT - 类 java.awt.event.InvocationEvent 中的静态变量
所有 InvocationEvent 的默认 id。
INVOCATION_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择调用事件的事件掩码。
INVOCATION_FIRST - 类 java.awt.event.InvocationEvent 中的静态变量
标记调用事件 id 范围内的第一个整数 id。
INVOCATION_LAST - 类 java.awt.event.InvocationEvent 中的静态变量
标记调用事件 id 范围内的最后一个整数 id。
InvocationEvent - java.awt.event 中的 类
当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。
InvocationEvent(Object, Runnable) - 类 java.awt.event.InvocationEvent 的构造方法
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。
InvocationEvent(Object, Runnable, Object, boolean) - 类 java.awt.event.InvocationEvent 的构造方法
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。
InvocationEvent(Object, int, Runnable, Object, boolean) - 类 java.awt.event.InvocationEvent 的构造方法
构造一个具有指定源和 ID 的 InvocationEvent，此源和 ID 将在被指派时执行 runnable 的 run 方法。
InvocationHandler - java.lang.reflect 中的 接口
InvocationHandler 是代理实例的调用处理程序 实现的接口。
InvocationTargetException - java.lang.reflect 中的 异常
InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。
InvocationTargetException() - 异常 java.lang.reflect.InvocationTargetException 的构造方法
构造以 null 作为目标异常的 InvocationTargetException。
InvocationTargetException(Throwable) - 异常 java.lang.reflect.InvocationTargetException 的构造方法
构造带目标异常的 InvocationTargetException。
InvocationTargetException(Throwable, String) - 异常 java.lang.reflect.InvocationTargetException 的构造方法
构造带目标异常和详细消息的 InvocationTargetException。
INVOICE - 类 java.awt.PageAttributes.MediaType 中的静态变量
Invoice (5 1/2 x 8 1/2 in) 的 MediaType 实例。
INVOICE - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 invoice 尺寸，5.5 inch × 8.5 inch。
INVOICE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
invoice 尺寸。
invoke(Object, Method, Object[]) - 类 java.beans.EventHandler 中的方法
从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。
invoke(Object, Method, Object[]) - 接口 java.lang.reflect.InvocationHandler 中的方法
在代理实例上处理方法调用并返回结果。
invoke(Object, Object...) - 类 java.lang.reflect.Method 中的方法
对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。
invoke(Object, Method, Object[]) - 类 java.rmi.server.RemoteObjectInvocationHandler 中的方法
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。
invoke(Remote, Method, Object[], long) - 接口 java.rmi.server.RemoteRef 中的方法
调用某个方法。
invoke(RemoteCall) - 接口 java.rmi.server.RemoteRef 中的方法
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
invoke(String, Object[], String[]) - 接口 javax.management.DynamicMBean 中的方法
允许在 Dynamic MBean 上调用某个操作。
invoke(ObjectName, String, Object[], String[]) - 接口 javax.management.MBeanServer 中的方法
invoke(ObjectName, String, Object[], String[]) - 接口 javax.management.MBeanServerConnection 中的方法
在 MBean 上调用某个操作。
invoke(Object, Method, Object[]) - 类 javax.management.MBeanServerInvocationHandler 中的方法
invoke(String, Object[], String[]) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。
invoke(Object, Method, Object[]) - 类 javax.management.openmbean.CompositeDataInvocationHandler 中的方法
invoke(ObjectName, String, MarshalledObject, String[], Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
invoke(ObjectName, String, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
invoke(ObjectName, String, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
invoke(String, Object[], String[]) - 类 javax.management.StandardMBean 中的方法
invoke(T) - 接口 javax.xml.ws.Dispatch 中的方法
同步调用服务操作。
invoke(T) - 接口 javax.xml.ws.Provider 中的方法
根据请求消息的内容调用操作。
invoke(ServerRequest) - 类 org.omg.CORBA.DynamicImplementation 中的方法
已过时。 由 Portable Object Adapter 取代
invoke(Object, OutputStream) - 类 org.omg.CORBA.portable.Delegate 中的方法
由 stub 调用，以调用一个操作。
invoke() - 类 org.omg.CORBA.Request 中的方法
使用 Request 对象中的信息进行同步调用。
invoke(ServerRequest) - 类 org.omg.CosNaming._BindingIteratorImplBase 中的方法
invoke(ServerRequest) - 类 org.omg.CosNaming._NamingContextImplBase 中的方法
invoke(ServerRequest) - 类 org.omg.PortableServer.DynamicImplementation 中的方法
接收发布到任何由 DSI servant 实现的 CORBA 对象的请求，并进行执行该请求所需的处理。
invokeAll(Collection<? extends Callable<T>>) - 类 java.util.concurrent.AbstractExecutorService 中的方法
invokeAll(Collection<? extends Callable<T>>, long, TimeUnit) - 类 java.util.concurrent.AbstractExecutorService 中的方法
invokeAll(Collection<? extends Callable<T>>) - 接口 java.util.concurrent.ExecutorService 中的方法
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
invokeAll(Collection<? extends Callable<T>>, long, TimeUnit) - 接口 java.util.concurrent.ExecutorService 中的方法
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
invokeAndWait(Runnable) - 类 java.awt.EventQueue 中的静态方法
导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。
invokeAndWait(Runnable) - 类 javax.swing.SwingUtilities 中的静态方法
导致 doRun.run() 在 AWT 事件指派线程上同步执行。
invokeAny(Collection<? extends Callable<T>>) - 类 java.util.concurrent.AbstractExecutorService 中的方法
invokeAny(Collection<? extends Callable<T>>, long, TimeUnit) - 类 java.util.concurrent.AbstractExecutorService 中的方法
invokeAny(Collection<? extends Callable<T>>) - 接口 java.util.concurrent.ExecutorService 中的方法
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
invokeAny(Collection<? extends Callable<T>>, long, TimeUnit) - 接口 java.util.concurrent.ExecutorService 中的方法
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。
invokeAsync(T) - 接口 javax.xml.ws.Dispatch 中的方法
异步调用服务操作。
invokeAsync(T, AsyncHandler<T>) - 接口 javax.xml.ws.Dispatch 中的方法
异步调用服务操作。
invokeFunction(String, Object...) - 接口 javax.script.Invocable 中的方法
用于调用脚本中定义的顶层程序和函数。
InvokeHandler - org.omg.CORBA.portable 中的 接口
此接口为入呼叫 (incoming call) 提供调度机制。
invokeLater(Runnable) - 类 java.awt.EventQueue 中的静态方法
导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。
invokeLater(Runnable) - 类 javax.swing.SwingUtilities 中的静态方法
导致 doRun.run() 在 AWT 事件指派线程上异步执行。
invokeMethod(Object, String, Object...) - 接口 javax.script.Invocable 中的方法
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。
invokeOneWay(T) - 接口 javax.xml.ws.Dispatch 中的方法
使用单向交互模式调用服务操作。
INVOKES_STOP_CELL_EDITING_PROPERTY - 类 javax.swing.JTree 中的静态变量
messagesStopCellEditing 的绑定属性名称。
invokesStopCellEditing - 类 javax.swing.JTree 中的变量
如果为 true，则在通过更改选择、更改树中的数据或通过其他方法停止编辑时，会调用 stopCellEditing，并保存更改。
IOError - java.io 中的 错误
当发生严重的 I/O 错误时，抛出此错误。
IOError(Throwable) - 错误 java.io.IOError 的构造方法
构造带有指定 cause 的新 IOError 实例。
IOException - java.io 中的 异常
当发生某种 I/O 异常时，抛出此异常。
IOException() - 异常 java.io.IOException 的构造方法
构造一个 IOException，使用 null 作为其错误详细消息。
IOException(String) - 异常 java.io.IOException 的构造方法
构造带指定详细消息的 IOException。
IOException(String, Throwable) - 异常 java.io.IOException 的构造方法
构造带有指定详细消息和 cause 的 IOException。
IOException(Throwable) - 异常 java.io.IOException 的构造方法
构造一个 IOException，使其具有指定的 cause 以及详细消息 (cause==null ? null : cause.toString())（通常包含类和 cause 的详细消息）。
ioException() - 类 java.util.Formatter 中的方法
返回由此 formatter 的 Appendable 方法上次抛出的 IOException 异常。
ioException() - 类 java.util.Scanner 中的方法
返回此 Scanner 的底层 Readable 最后抛出的 IOException。
IOR - org.omg.IOP 中的 类
org/omg/IOP/IOR.java。
IOR() - 类 org.omg.IOP.IOR 的构造方法
IOR(String, TaggedProfile[]) - 类 org.omg.IOP.IOR 的构造方法
IORHelper - org.omg.IOP 中的 类
org/omg/IOP/IORHelper.java。
IORHelper() - 类 org.omg.IOP.IORHelper 的构造方法
IORHolder - org.omg.IOP 中的 类
org/omg/IOP/IORHolder.java。
IORHolder() - 类 org.omg.IOP.IORHolder 的构造方法
IORHolder(IOR) - 类 org.omg.IOP.IORHolder 的构造方法
IORInfo - org.omg.PortableInterceptor 中的 接口
提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
IORInfoOperations - org.omg.PortableInterceptor 中的 接口
提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
IORInterceptor - org.omg.PortableInterceptor 中的 接口
Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
IORInterceptor_3_0 - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/IORInterceptor_3_0.java。
IORInterceptor_3_0Helper - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java。
IORInterceptor_3_0Helper() - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 的构造方法
IORInterceptor_3_0Holder - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java。
IORInterceptor_3_0Holder() - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 的构造方法
IORInterceptor_3_0Holder(IORInterceptor_3_0) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 的构造方法
IORInterceptor_3_0Operations - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java。
IORInterceptorOperations - org.omg.PortableInterceptor 中的 接口
Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
IP_MULTICAST_IF - 接口 java.net.SocketOptions 中的静态变量
设置用于发送多播包的传出接口。
IP_MULTICAST_IF2 - 接口 java.net.SocketOptions 中的静态变量
同上。
IP_MULTICAST_LOOP - 接口 java.net.SocketOptions 中的静态变量
此选项启用或禁用多播数据报的本地回送。
IP_TOS - 接口 java.net.SocketOptions 中的静态变量
此选项为 TCP 或 UDP 套接字在 IP 地址头中设置服务类型或流量类字段。
IPA_EXTENSIONS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“IPA Extensions”Unicode 字符块的常量。
ipadx - 类 java.awt.GridBagConstraints 中的变量
此字段指定组件的内部填充，即给组件的最小宽度添加多大的空间。
ipady - 类 java.awt.GridBagConstraints 中的变量
此字段指定内部填充，即给组件的最小高度添加多大的空间。
IRObject - org.omg.CORBA 中的 接口
IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。
IRObjectOperations - org.omg.CORBA 中的 接口
这是用于 IRObject 的映射的 Operations 接口。
is_a(Object, String) - 类 org.omg.CORBA.portable.Delegate 中的方法
检查对象引用是否是给定接口的实例。
is_a(Servant, String) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
此方法查看指定的 repid 是否存在于 _all_interfaces() 返回的列表上，或者该 repid 是否是通用 CORBA 对象的存储库 id。
IS_CLOSED_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
约束属性名，指示该内部窗体已关闭。
IS_COALESCING - 类 javax.xml.stream.XMLInputFactory 中的静态变量
要求解析器组合相邻字符数据部分的属性。
is_equivalent(Object, Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
确定两个对象引用是否相等。
IS_ICON_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
约束属性名，指示该内部窗体已图标化。
is_local(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
如果此对象由本地 servant 实现，则返回 true。
IS_MAXIMUM_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
约束属性名，指示该内部窗体已最大化。
IS_NAMESPACE_AWARE - 类 javax.xml.stream.XMLInputFactory 中的静态变量
用于开启/关闭名称空间支持的属性，该属性用于支持 XML 1.0 文档，只有 true 设置是必须受支持的。
is_null() - 类 org.omg.DynamicAny._DynValueStub 中的方法
如果 DynValueCommon 表示 null 值类型，则返回 true。
is_null() - 接口 org.omg.DynamicAny.DynValueCommonOperations 中的方法
如果 DynValueCommon 表示 null 值类型，则返回 true。
IS_PALETTE - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的静态变量
IS_REPAIRING_NAMESPACES - 类 javax.xml.stream.XMLOutputFactory 中的静态变量
用于设置输出端上默认前缀的属性。
IS_REPLACING_ENTITY_REFERENCES - 类 javax.xml.stream.XMLInputFactory 中的静态变量
要求解析器用它们的替换文本替换内部实体引用并将它们报告为字符。
IS_SELECTED_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
约束属性名，指示此窗体具有选定状态。
IS_SUPPORTING_EXTERNAL_ENTITIES - 类 javax.xml.stream.XMLInputFactory 中的静态变量
要求解析器解析外部解析实体的属性。
IS_VALIDATING - 类 javax.xml.stream.XMLInputFactory 中的静态变量
用于开启/关闭特定于实现的验证的属性。
isAbsolute() - 类 java.io.File 中的方法
测试此抽象路径名是否为绝对路径名。
isAbsolute() - 类 java.net.URI 中的方法
判断此 URI 是否为绝对的。
isAbstract(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 abstract 修饰符，则返回 true，否则返回 false。
isAccelerated() - 类 java.awt.ImageCapabilities 中的方法
如果对象（它的功能封装在此 ImageCapabilities 中）可以被或者已经被 accelerated，则返回 true。
isAcceleratorHidden() - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法
isAcceptable() - 类 java.nio.channels.SelectionKey 中的方法
测试此键的通道是否已准备好接受新的套接字连接。
isAcceptAllFileFilterUsed() - 类 javax.swing.JFileChooser 中的方法
返回是否使用 AcceptAll FileFilter。
isAccessible() - 类 java.lang.reflect.AccessibleObject 中的方法
获取此对象的 accessible 标志的值。
isAccessibleChildSelected(int) - 类 java.awt.List.AccessibleAWTList 中的方法
如果选择了此对象的当前子级，则返回 true。
isAccessibleChildSelected(int) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
确定是否选择此对象的当前子对象。
isAccessibleChildSelected(int) - 接口 javax.accessibility.AccessibleSelection 中的方法
确定此对象的当前子级是否已选中。
isAccessibleChildSelected(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
确定是否选定此对象的当前子对象。
isAccessibleChildSelected(int) - 类 javax.swing.JList.AccessibleJList 中的方法
如果选择了此对象的当前子级，则返回 true。
isAccessibleChildSelected(int) - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
如果选择了此对象的当前子对象（即此子对象为弹出子菜单），则返回 true。
isAccessibleChildSelected(int) - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
如果选择了此对象的当前子级，则返回 true。
isAccessibleChildSelected(int) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
isAccessibleChildSelected(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
确定是否选择此对象的当前子对象。
isAccessibleChildSelected(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
如果选择了此对象的当前子对象，则返回 true。
isAccessibleChildSelected(int) - 类 javax.swing.JTree.AccessibleJTree 中的方法
如果选择了此对象的当前子对象，则返回 true。
isAccessibleColumnSelected(int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回一个布尔值，它指示指定列是否为选中的。
isAccessibleColumnSelected(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回一个布尔值，它指示是否选择了指定的列。
isAccessibleRowSelected(int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回一个布尔值，它指示给定行是否已选中。
isAccessibleRowSelected(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回一个布尔值，它表示是否选择了指定的行。
isAccessibleSelected(int, int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回一个布尔值，它指示在给定的行和列 accessible 是否选定。
isAccessibleSelected(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回一个布尔值，它表明在给定的 (row, column) 是否选择为可访问的。
isActionKey() - 类 java.awt.event.KeyEvent 中的方法
返回此事件中的键是否为“动作”键。
isActive() - 类 java.applet.Applet 中的方法
确定 applet 是否处于活动状态。
isActive() - 接口 java.applet.AppletStub 中的方法
确定 applet 是否处于激活状态。
isActive() - 类 java.awt.dnd.DropTarget 中的方法
报告此 DropTarget 当前是否为激活状态（准备接受 drop）。
isActive() - 类 java.awt.Window 中的方法
返回此窗口是否为活动窗口。
isActive() - 类 javax.management.monitor.Monitor 中的方法
测试监视器 MBean 是否处于激活状态。
isActive() - 接口 javax.management.monitor.MonitorMBean 中的方法
测试监视器 MBean 是否处于激活状态。
isActive() - 类 javax.management.relation.RelationService 中的方法
检查该 Relation Service 是否处于活动状态。
isActive() - 接口 javax.management.relation.RelationServiceMBean 中的方法
检查该 Relation Service 是否处于活动状态。
isActive() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
确定连接器服务器是否活动。
isActive() - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
isActive() - 类 javax.management.timer.Timer 中的方法
测试计时器 MBean 是否处于激活状态。
isActive() - 接口 javax.management.timer.TimerMBean 中的方法
测试计时器 MBean 是否处于激活状态。
isActive() - 接口 javax.sound.sampled.DataLine 中的方法
指示该行是否正在进行活动 I/O（如回放或捕获）。
isActive() - 类 javax.swing.text.DefaultCaret 中的方法
确定插入符当前是否处于激活状态。
isAddedPath() - 类 javax.swing.event.TreeSelectionEvent 中的方法
如果已经将第一个路径元素添加到选择中，则返回 true。
isAddedPath(TreePath) - 类 javax.swing.event.TreeSelectionEvent 中的方法
如果 path 标识的路径被添加到选择中，则返回 true。
isAddedPath(int) - 类 javax.swing.event.TreeSelectionEvent 中的方法
如果由 index 标识的路径被添加到选择中，则返回 true。
isAfter(int, int, Rectangle) - 类 javax.swing.text.BoxView 中的方法
确定一个点是否位于分配区域的后面。
isAfter(int, int, Rectangle) - 类 javax.swing.text.CompositeView 中的方法
测试一个点是否位于矩形范围之后。
isAfterLast() - 接口 java.sql.ResultSet 中的方法
获取光标是否位于此 ResultSet 对象的最后一行之后。
isAlive() - 类 java.lang.Thread 中的方法
测试线程是否处于活动状态。
isAllocationValid() - 类 javax.swing.text.BoxView 中的方法
子级分配是否仍有效。
isAlphaPremultiplied() - 类 java.awt.image.BufferedImage 中的方法
返回是否已预乘以 alpha。
isAlphaPremultiplied() - 类 java.awt.image.ColorModel 中的方法
返回是否在由此 ColorModel 转换的像素值中预乘 alpha。
isAltDown() - 类 java.awt.event.InputEvent 中的方法
返回 Alt 修饰符在此事件上是否为 down。
isAltGraphDown() - 类 java.awt.event.InputEvent 中的方法
返回 AltGraph 修饰符在此事件上是否为 down。
isAlwaysOnTop() - 类 java.awt.Window 中的方法
返回此窗口是否为 always-on-top 窗口。
isAlwaysOnTopSupported() - 类 java.awt.Toolkit 中的方法
返回此工具包是否支持 always-on-top 模式。
isAlwaysOnTopSupported() - 类 java.awt.Window 中的方法
返回此窗口是否支持 always-on-top 模式。
isAncestorOf(Component) - 类 java.awt.Container 中的方法
检查该组件是否包含在此容器的组件层次结构中。
isAnnotation() - 类 java.lang.Class 中的方法
如果此 Class 对象表示一个注释类型则返回 true。
isAnnotationPresent(Class<? extends Annotation>) - 类 java.lang.Class 中的方法
isAnnotationPresent(Class<? extends Annotation>) - 类 java.lang.Package 中的方法
isAnnotationPresent(Class<? extends Annotation>) - 类 java.lang.reflect.AccessibleObject 中的方法
isAnnotationPresent(Class<? extends Annotation>) - 接口 java.lang.reflect.AnnotatedElement 中的方法
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。
isAnonymous() - 接口 org.ietf.jgss.GSSName 中的方法
测试此名称对象是否表示匿名的实体。
isAnonymousClass() - 类 java.lang.Class 中的方法
当且仅当底层类是匿名类时返回 true。
isAntiAliased() - 类 java.awt.font.FontRenderContext 中的方法
返回一个 boolean 值，指示是否某些形式的抗锯齿由此 FontRenderContext 指定。
isAnyLocalAddress() - 类 java.net.Inet4Address 中的方法
检查 InetAddress 是否是通配符地址的实用例行程序。
isAnyLocalAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否是通配符地址的实用例行程序。
isAnyLocalAddress() - 类 java.net.InetAddress 中的方法
检查 InetAddress 是否是通配符地址的实用例行程序。
isAnyPolicyInhibited() - 类 java.security.cert.PKIXParameters 中的方法
检查当证书中包括了任何策略 OID 时是否应该处理它。
isArmed() - 接口 javax.swing.ButtonModel 中的方法
指示触发按钮操作的部分委托事项。
isArmed() - 类 javax.swing.DefaultButtonModel 中的方法
指示触发按钮操作的部分委托事项。
isArmed() - 类 javax.swing.JMenuItem 中的方法
返回菜单项是否被“调出”。
isArray() - 类 java.lang.Class 中的方法
判定此 Class 对象是否表示一个数组类。
isArray() - 类 javax.management.openmbean.OpenType 中的方法
如果此开放类型描述的开放数据值是数组，则返回 true，否则返回 false。
isAscending() - 类 javax.naming.ldap.SortKey 中的方法
确定排序顺序。
isAssignable(TypeMirror, TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
测试一种类型是否可以指派给另一种类型。
isAssignableFrom(Class<?>) - 类 java.lang.Class 中的方法
判定此 Class 对象所表示的类或接口与指定的 Class 参数所表示的类或接口是否相同，或是否是其超类或超接口。
isAttribute() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 Attribute 的实用工具函数。
isAttributeCategorySupported(Class<? extends Attribute>) - 接口 javax.print.PrintService 中的方法
确定客户端在设置此 PrintService 的作业时，是否可以指定给定打印属性类别。
isAttributeRequired(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
如果指定属性必须在指定元素中存在，则返回 true。
isAttributeRequired(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
isAttributeSpecified(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isAttributeSpecified(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回一个 boolean 值，它指示此属性是否为默认创建的
isAttributeValueSupported(Attribute, DocFlavor, AttributeSet) - 接口 javax.print.PrintService 中的方法
确定客户端在设置此 PrintService 的作业时，是否可以指定给定的打印属性值。
isAuthorized() - 类 javax.security.sasl.AuthorizeCallback 中的方法
确定是否允许用验证 id 代表授权 id。
isAutoDetecting() - 类 java.nio.charset.CharsetDecoder 中的方法
通知此解码器是否实现了自动检测 charset。
isAutoFormSubmission() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
指示是否自动处理 html 表单提交，或只是激发 FormSubmitEvent。
isAutoIncrement(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示是否自动为指定列进行编号。
isAutoIncrement(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取存储在指定列中的值是否自动编号，因而是只读的。
isAutoScrolling - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
isAutoWaitForIdle() - 类 java.awt.Robot 中的方法
返回此 Robot 在生成一个事件后是否自动调用 waitForIdle。
isBackgroundSet() - 类 java.awt.Component 中的方法
返回是否已为此组件显示地设置了背景色。
isBackingStoreEnabled() - 类 javax.swing.JViewport 中的方法
已过时。 从 Java 2 平台 1.3 版开始，由 getScrollMode() 取代。
isBefore(int, int, Rectangle) - 类 javax.swing.text.BoxView 中的方法
确定一个点是否位于分配区域的前面。
isBefore(int, int, Rectangle) - 类 javax.swing.text.CompositeView 中的方法
测试一个点是否位于矩形范围之前。
isBeforeFirst() - 接口 java.sql.ResultSet 中的方法
获取光标是否位于此 ResultSet 对象的第一行之前。
isBigEndian() - 类 javax.sound.sampled.AudioFormat 中的方法
指示是以 big-endian 顺序还是以 little-endian 顺序存储音频数据。
isBlock() - 类 javax.swing.text.html.HTML.Tag 中的方法
如果此标记是块标记（块标记是用于向文档添加结构的标记），则返回 true。
isBlocking() - 类 java.nio.channels.SelectableChannel 中的方法
判断此通道上的每个 I/O 操作在完成前是否被阻塞。
isBlocking() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
isBlockTag(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
确定与该元素关联的 HTML.Tag 是否为块标记。
isBold() - 类 java.awt.Font 中的方法
指示此 Font 对象的样式是否为 BOLD。
isBold(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了粗体属性。
isBootClassPathSupported() - 接口 java.lang.management.RuntimeMXBean 中的方法
测试 Java 虚拟机是否支持由引导类加载器用于搜索类文件的引导类路径机制。
isBorderOpaque() - 类 javax.swing.border.AbstractBorder 中的方法
此默认实现返回 false。
isBorderOpaque() - 类 javax.swing.border.BevelBorder 中的方法
返回边框是否透明。
isBorderOpaque() - 接口 javax.swing.border.Border 中的方法
返回此边框是否透明。
isBorderOpaque() - 类 javax.swing.border.CompoundBorder 中的方法
返回此组合边框是否透明。
isBorderOpaque() - 类 javax.swing.border.EmptyBorder 中的方法
返回此边框是否透明。
isBorderOpaque() - 类 javax.swing.border.EtchedBorder 中的方法
返回边框是否透明。
isBorderOpaque() - 类 javax.swing.border.LineBorder 中的方法
返回此边框是否透明。
isBorderOpaque() - 类 javax.swing.border.MatteBorder 中的方法
返回边框是否透明。
isBorderOpaque() - 类 javax.swing.border.SoftBevelBorder 中的方法
返回边框是否透明。
isBorderOpaque() - 类 javax.swing.border.TitledBorder 中的方法
返回边框是否透明。
isBorderOpaque() - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 中的方法
isBorderOpaque() - 类 javax.swing.plaf.BorderUIResource 中的方法
isBorderPainted() - 类 javax.swing.AbstractButton 中的方法
获取 borderPainted 属性。
isBorderPainted() - 类 javax.swing.JMenuBar 中的方法
如果应该绘制菜单栏的边框，则返回 true。
isBorderPainted() - 类 javax.swing.JPopupMenu 中的方法
检查是否应该绘制边框。
isBorderPainted() - 类 javax.swing.JProgressBar 中的方法
返回 borderPainted 属性。
isBorderPainted() - 类 javax.swing.JToolBar 中的方法
获取 borderPainted 属性。
isBorderPaintedFlat() - 类 javax.swing.JCheckBox 中的方法
获取 borderPaintedFlat 属性的值。
isBound() - 类 java.beans.PropertyDescriptor 中的方法
更新 "bound" 属性将导致更改该属性时激发 "PropertyChange" 事件。
isBound() - 类 java.net.DatagramSocket 中的方法
返回套接字的绑定状态。
isBound() - 类 java.net.ServerSocket 中的方法
返回 ServerSocket 的绑定状态。
isBound() - 类 java.net.Socket 中的方法
返回套接字的绑定状态。
isBoundary(int) - 类 java.text.BreakIterator 中的方法
如果指定字符偏移量是一个文本边界，则返回 true。
isBridge() - 类 java.lang.reflect.Method 中的方法
如果此方法是 bridge 方法，则返回 true；否则，返回 false。
isBroken() - 类 java.util.concurrent.CyclicBarrier 中的方法
查询此屏障是否处于损坏状态。
isCached() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
返回 true，因为此 ImageInputStream 为了允许逆向查找而缓存了数据。
isCached() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
返回 true，因为此 ImageOutputStream为了允许逆向查找而缓存了数据。
isCached() - 接口 javax.imageio.stream.ImageInputStream 中的方法
如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，则返回 true。
isCached() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
默认实现返回 false。
isCached() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
返回 true，因为此 ImageInputStream为了允许逆向查找而缓存了数据。
isCached() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
返回 true，因为此 ImageOutputStream为了允许逆向查找而缓存了数据。
isCachedFile() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
返回 true，因为此 ImageInputStream 维护文件缓存。
isCachedFile() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
返回 true，因为此 ImageOutputStream 维护文件缓存。
isCachedFile() - 接口 javax.imageio.stream.ImageInputStream 中的方法
如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，并且将其保存在临时文件中，则返回 true。
isCachedFile() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
默认实现返回 false。
isCachedFile() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
返回 false，因为此 ImageInputStream 不维护文件缓存。
isCachedFile() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
返回 false，因为此 ImageOutputStream 不维护文件缓存。
isCachedMemory() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
返回 false，因为此 ImageInputStream 不维护主存缓存。
isCachedMemory() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
返回 false，因为此 ImageOutputStream 不维护主存缓存。
isCachedMemory() - 接口 javax.imageio.stream.ImageInputStream 中的方法
如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，并将其保存在主存中，则返回 true。
isCachedMemory() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
默认实现返回 false。
isCachedMemory() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
返回 true，因为此 ImageInputStream 维护主存缓存。
isCachedMemory() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
返回 true，因为此 ImageOutputStream 维护主存缓存。
isCanceled() - 类 javax.swing.ProgressMonitor 中的方法
如果用户单击进度对话框中的 Cancel 按钮，则返回 true。
isCancelled() - 类 java.awt.print.PrinterJob 中的方法
如果打印作业正在进行中，而下一次打印作业将被取消，则返回 true；否则返回 false。
isCancelled() - 接口 java.util.concurrent.Future 中的方法
如果在任务正常完成前将其取消，则返回 true。
isCancelled() - 类 java.util.concurrent.FutureTask 中的方法
isCancelled() - 类 javax.swing.SwingWorker 中的方法
如果在任务正常完成前将其取消，则返回 true。
isCaseIgnored() - 接口 javax.naming.directory.Attributes 中的方法
确定在检索或添加属性时属性集是否忽略属性标识符的大小写。
isCaseIgnored() - 类 javax.naming.directory.BasicAttributes 中的方法
isCaseSensitive(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示列的大小写是否有关系。
isCaseSensitive(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示指定列的名称是否区分大小写。
isCatalogAtStart() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别是否出现在完全限定表名的开头。
isCData() - 接口 javax.xml.stream.events.Characters 中的方法
如果它是一个 CData 节，则返回 true。
isCellEditable(EventObject) - 类 javax.swing.AbstractCellEditor 中的方法
返回 true。
isCellEditable(EventObject) - 接口 javax.swing.CellEditor 中的方法
询问编辑器它是否可以使用 anEvent 开始进行编辑。
isCellEditable(EventObject) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
如果 anEvent 不是一个 MouseEvent，则返回 true。
isCellEditable(EventObject) - 类 javax.swing.DefaultCellEditor 中的方法
将消息从 CellEditor 转发到 delegate。
isCellEditable(int, int) - 类 javax.swing.JTable 中的方法
如果 row 和 column 位置的单元格是可编辑的，则返回 true。
isCellEditable(int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
返回 false。
isCellEditable(int, int) - 类 javax.swing.table.DefaultTableModel 中的方法
无论参数值是多少都返回 true。
isCellEditable(int, int) - 接口 javax.swing.table.TableModel 中的方法
如果 rowIndex 和 columnIndex 位置的单元格是可编辑的，则返回 true。
isCellEditable(EventObject) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果 realEditor 将 true 返回到此消息，则会通知 prepareForEditing，并返回 true。
isCellSelected(int, int) - 类 javax.swing.JTable 中的方法
如果指定的索引位于行和列的有效范围内，并且位于该指定位置的单元格被选定，则返回 true。
isCertificateEntry(String) - 类 java.security.KeyStore 中的方法
如果给定别名标识的条目是通过调用 setCertificateEntry 或者以 TrustedCertificateEntry 为参数的 setEntry 创建的，则返回 true。
isCharacters() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 Characters 的实用工具函数。
isCharacters() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isCharacters() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果光标指向字符数据事件，则返回 true
isCharsetDetected() - 类 java.nio.charset.CharsetDecoder 中的方法
通知此解码器是否已经检测到了一个 charset（可选操作）。
isClass() - 枚举 javax.lang.model.element.ElementKind 中的方法
如果此元素是以下种类的类，则返回 true：CLASS 或 ENUM。
isClosable() - 类 javax.swing.JInternalFrame 中的方法
返回是否可以通过某个用户操作关闭此 JInternalFrame。
isClosed() - 类 java.net.DatagramSocket 中的方法
返回是否关闭了套接字。
isClosed() - 类 java.net.ServerSocket 中的方法
返回 ServerSocket 的关闭状态。
isClosed() - 类 java.net.Socket 中的方法
返回套接字的关闭状态。
isClosed() - 接口 java.sql.Connection 中的方法
查询此 Connection 对象是否已经被关闭。
isClosed() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象是否已关闭。
isClosed() - 接口 java.sql.Statement 中的方法
获取是否已关闭了此 Statement 对象。
isClosed - 类 javax.swing.JInternalFrame 中的变量
窗体已关闭。
isClosed() - 类 javax.swing.JInternalFrame 中的方法
返回此 JInternalFrame 当前是否已关闭。
isCoalesce() - 类 javax.swing.Timer 中的方法
如果 Timer 组合多个挂起的动作事件，则返回 true。
isCoalescing() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成满足以下条件的解析器：该解析器将 CDATA 节点转换为 Text 节点，并将其附加到相邻（如果有）的 Text 节点。
isCollapsed(TreePath) - 类 javax.swing.JTree 中的方法
如果当前折叠了路径标识的值，则返回 true，如果当前未显示路径中的任何值，则返回 false。
isCollapsed(int) - 类 javax.swing.JTree 中的方法
如果折叠了指定显示行处的节点，则返回 true。
isCollectionUsageThresholdExceeded() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
测试在 Java 虚拟机最近一次回收工作之后，此内存池的内存使用量是否达到或超过了其回收使用量阈值。
isCollectionUsageThresholdSupported() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
测试此内存池是否支持回收使用量阈值。
isColumnSelected(int) - 类 javax.swing.JTable 中的方法
如果指定的索引位于列的有效范围内，并且位于该索引的列被选定，则返回 true。
isCombining() - 类 java.awt.font.GlyphMetrics 中的方法
如果这是一个组合字形，则返回 true。
isComment() - 接口 javax.xml.soap.Text 中的方法
检索此 Text 对象是否表示一个注释。
isCompatibleRaster(Raster) - 类 java.awt.image.ColorModel 中的方法
如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。
isCompatibleRaster(Raster) - 类 java.awt.image.ComponentColorModel 中的方法
如果 raster 与此 ColorModel 兼容，则返回 true；如果不兼容，则返回 false。
isCompatibleRaster(Raster) - 类 java.awt.image.DirectColorModel 中的方法
如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。
isCompatibleRaster(Raster) - 类 java.awt.image.IndexColorModel 中的方法
如果 raster 与此 ColorModel 兼容，则返回 true；如果不与此 ColorModel 兼容，则返回 false。
isCompatibleSampleModel(SampleModel) - 类 java.awt.image.ColorModel 中的方法
检查 SampleModel 是否与此 ColorModel 兼容。
isCompatibleSampleModel(SampleModel) - 类 java.awt.image.ComponentColorModel 中的方法
检查指定 SampleModel 是否与此 ColorModel 兼容。
isCompatibleSampleModel(SampleModel) - 类 java.awt.image.IndexColorModel 中的方法
检查指定的 SampleModel 是否与此 ColorModel 兼容。
isCompatibleSampleModel(SampleModel) - 类 java.awt.image.PackedColorModel 中的方法
检查指定的 SampleModel 是否与此 ColorModel 兼容。
isCompatibleValue(Object) - 类 java.awt.RenderingHints.Key 中的方法
如果指定对象是此 Key 的有效值，则返回 true。
isCompatibleWith(String) - 类 java.lang.Package 中的方法
比较此包的规范版本和所需版本。
isCompilationTimeMonitoringSupported() - 接口 java.lang.management.CompilationMXBean 中的方法
测试 Java 虚拟机是否支持监视编译时间。
isComplete() - 接口 javax.security.sasl.SaslClient 中的方法
确定验证交换是否已完成。
isComplete() - 接口 javax.security.sasl.SaslServer 中的方法
确定验证交换是否已完成。
isCompletelyDirty(JComponent) - 类 javax.swing.RepaintManager 中的方法
在下一个 paintDirtyRegions() 中全部绘制 aComponent 时返回 true 的便捷方法。
isComponent() - 类 java.awt.font.GlyphMetrics 中的方法
如果这是一个分量字形，则返回 true。
isComponentPartOfCurrentMenu(Component) - 类 javax.swing.MenuSelectionManager 中的方法
如果 c 是当前使用菜单的一部分，则返回 true
isCompositionEnabled() - 类 java.awt.im.InputContext 中的方法
确定是否已启用当前输入方法以进行撰写。
isCompositionEnabled() - 接口 java.awt.im.spi.InputMethod 中的方法
确定此输入方法是否已启用。
isCompressionLossless() - 类 javax.imageio.ImageWriteParam 中的方法
如果当前压缩类型提供无损失的压缩，则返回 true。
isCompressionLossless() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
返回 false，因为 JPEG 插件仅支持有损失的压缩。
isComputerNode(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
UI 类使用此方法来决定是否为计算机节点显示特殊图标，例如，“我的电脑”或网络服务器。
isConnectable() - 类 java.nio.channels.SelectionKey 中的方法
测试此键的通道是否已完成其套接字连接操作。
isConnected() - 类 java.net.DatagramSocket 中的方法
返回套接字的连接状态。
isConnected() - 类 java.net.Socket 中的方法
返回套接字的连接状态。
isConnected() - 类 java.nio.channels.DatagramChannel 中的方法
判断是否已连接此通道的套接字。
isConnected() - 类 java.nio.channels.SocketChannel 中的方法
判断是否已连接此通道的网络套接字。
isConnectionPending() - 类 java.nio.channels.SocketChannel 中的方法
判断此通道上是否正在进行连接操作。
isConstrained() - 类 java.beans.PropertyDescriptor 中的方法
试图更新 "Constrained" 属性将导致更改该属性时激发 "VetoableChange" 事件。
isConsumed() - 类 java.awt.AWTEvent 中的方法
返回是否已经使用了此事件。
isConsumed() - 类 java.awt.event.InputEvent 中的方法
返回是否已经使用此事件。
isConsumed() - 类 java.awt.event.InputMethodEvent 中的方法
返回是否已经使用此事件。
isConsumer(ImageConsumer) - 类 java.awt.image.FilteredImageSource 中的方法
确定一个 ImageConsumer 是否在对此图像数据感兴趣的使用者列表中。
isConsumer(ImageConsumer) - 接口 java.awt.image.ImageProducer 中的方法
确定指定的 ImageConsumer 对象目前是否已向此 ImageProducer 注册为其使用者之一。
isConsumer(ImageConsumer) - 类 java.awt.image.MemoryImageSource 中的方法
确定某个 ImageConsumer 目前是否处于对此图像数据感兴趣的使用者列表中。
isConsumer(ImageConsumer) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
确定某个 ImageConsumer 是否在当前对此图像的数据感兴趣的使用者列表。
isContentAreaFilled() - 类 javax.swing.AbstractButton 中的方法
获取 contentAreaFilled 属性。
isContextual() - 类 java.awt.font.NumericShaper 中的方法
返回一个 boolean 值，指示此成形器是否以上下文方式成形。
isContinuousLayout() - 类 javax.swing.JSplitPane 中的方法
获取 continuousLayout 属性。
isContinuousLayout() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
确定是否将 JSplitPane 设置为使用连续布局。
isControlDown() - 类 java.awt.event.InputEvent 中的方法
返回 Control 修饰符在此事件上是为 down。
isControlSupported(Control.Type) - 接口 javax.sound.sampled.Line 中的方法
指示该行是否支持特定类型的控件。
isConversionSupported(AudioFormat.Encoding, AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
指示是否可以从具有指定格式的音频输入流获得指定编码的音频输入流。
isConversionSupported(AudioFormat, AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
指示是否可从另一指定格式的音频输入流获得指定格式的音频输入流。
isConversionSupported(AudioFormat.Encoding, AudioFormat) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
指示格式转换器是否支持从特定格式向特定编码的转换。
isConversionSupported(AudioFormat, AudioFormat) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
指示格式转换器是否支持到从一种特定格式到另一种格式的转换。
isCritical() - 接口 java.security.cert.PolicyNode 中的方法
返回最近处理的证书中其证书策略扩展的关键性指示符。
isCritical() - 类 javax.naming.ldap.BasicControl 中的方法
确定控件的关键性。
isCritical() - 接口 javax.naming.ldap.Control 中的方法
确定 LDAP 控件的关键性。
isCryptoAllowed(Key) - 类 javax.crypto.ExemptionMechanism 中的方法
返回此豁免机制是否已成功生成结果 blob。
isCS_sRGB() - 类 java.awt.color.ColorSpace 中的方法
如果 ColorSpace 是 CS_sRGB，则返回 true。
isCurrency(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示指定的列是否是一个哈希代码值。
isCurrency(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示存储在指定列中的值是否为缓存值。
isCurrent() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否仍旧是当前的。
isCurrent() - 接口 javax.security.auth.Refreshable 中的方法
确定此 Object 是否是当前的。
isCurrentServiceInvalidNow() - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 中的方法
报告当前服务是否被强行取消，在该情况下，引用当前无效并且不能使用。
isCurrentThreadCpuTimeSupported() - 接口 java.lang.management.ThreadMXBean 中的方法
测试 Java 虚拟机是否支持当前线程的 CPU 时间测量。
isCursorSet() - 类 java.awt.Component 中的方法
返回是否已为此组件显示地设置了光标。
isCustomMarshaled(Class) - 接口 javax.rmi.CORBA.ValueHandler 中的方法
指示给定的类是执行自定义编组还是默认编组。
isCyclic() - 类 java.awt.GradientPaint 中的方法
如果渐变在两种颜色 C1 和 C2 之间重复循环，则返回 true。
isDaemon() - 类 java.lang.Thread 中的方法
测试该线程是否为守护线程。
isDaemon() - 类 java.lang.ThreadGroup 中的方法
测试此线程组是否为一个后台程序线程组。
isDataFlavorAvailable(DataFlavor) - 类 java.awt.datatransfer.Clipboard 中的方法
返回是否能够以指定的 DataFlavor 形式提供此剪贴板的当前内容。
isDataFlavorSupported(DataFlavor) - 类 java.awt.datatransfer.StringSelection 中的方法
返回所请求的 flavor 是否受此 Transferable 支持。
isDataFlavorSupported(DataFlavor) - 接口 java.awt.datatransfer.Transferable 中的方法
返回此对象是否支持指定的数据 flavor。
isDataFlavorSupported(DataFlavor) - 类 java.awt.dnd.DropTargetContext 中的方法
此方法返回一个 boolean 值，指示给定的 DataFlavor 是否受此 DropTargetContext 支持。
isDataFlavorSupported(DataFlavor) - 类 java.awt.dnd.DropTargetContext.TransferableProxy 中的方法
返回指定的数据 flavor 是否受封装的 transferable 支持。
isDataFlavorSupported(DataFlavor) - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回一个指示指定的 DataFlavor 是否受支持 boolean 值。
isDataFlavorSupported(DataFlavor) - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回一个指示指定的 DataFlavor 是否可在源对象中使用的 boolean 值。
isDataFlavorSupported(DataFlavor) - 类 javax.activation.DataHandler 中的方法
返回此对象是否支持指定的数据 flavor。
isDataFlavorSupported(DataFlavor) - 类 javax.swing.TransferHandler.TransferSupport 中的方法
返回是否支持给定的数据 flavor。
isDecimalSeparatorAlwaysShown() - 类 java.text.DecimalFormat 中的方法
允许获取整数中小数分隔符的行为。
isDeclared(int) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 false，除非在 DTD 中声明了该属性。
isDeclared(String) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 false，除非在 DTD 中声明该属性。
isDeclared(String, String) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 false，除非在 DTD 中声明属性。
isDeclared(int) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“声明的”标志的当前值。
isDeclared(String, String) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“声明的”标志的当前值。
isDeclared(String) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“声明的”标志的当前值。
isDefaultButton() - 类 javax.swing.JButton 中的方法
获取 defaultButton 属性的值，如果为 true 则意味着此按钮是其 JRootPane 的当前默认按钮。
isDefaultCapable() - 类 javax.swing.JButton 中的方法
获取 defaultCapable 属性的值。
isDefaultLookAndFeelDecorated() - 类 javax.swing.JDialog 中的静态方法
如果应该通过当前外观为新创建的 JDialog 提供其 Window 装饰，则返回 true。
isDefaultLookAndFeelDecorated() - 类 javax.swing.JFrame 中的静态方法
如果新创建的 JFrame 应该由当前外观为其提供 Window 装饰，则返回 true。
isDefaultNamespace(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
isDefaultNamespace(String) - 接口 org.w3c.dom.Node 中的方法
此方法检查指定的 namespaceURI 是否是默认名称空间。
isDefaultNamespaceDeclaration() - 接口 javax.xml.stream.events.Namespace 中的方法
如果此属性声明的是默认名称空间，则返回 true。
isDefined(char) - 类 java.lang.Character 中的静态方法
确定字符是否被定义为 Unicode 中的字符。
isDefined(int) - 类 java.lang.Character 中的静态方法
确定字符（Unicode 代码点）是否被定义为 Unicode 中的字符。
isDefined(Object) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
检查是否定义了给定的属性。
isDefined(Object) - 接口 javax.swing.text.AttributeSet 中的方法
检查指定属性是否具有该属性集中指定的值，而无需通过其他属性集进行解析。
isDefined(Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
告知是否定义了给定的属性。
isDefined(Object) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
确定给定属性是否已定义。
isDefined(Object) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
检查给定属性是否已定义。
isDefinitelyWritable(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示在指定的列上进行写操作是否明确可以获得成功。
isDefinitelyWritable(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示在指定的列上进行写操作是否一定可以获得成功。
isDelegated() - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
报告此类是否是另一个类的委托。
isDeprecated(Element) - 接口 javax.lang.model.util.Elements 中的方法
如果元素已过时，则返回 true，否则返回 false。
isDerivedFrom(String, String, int) - 接口 org.w3c.dom.TypeInfo 中的方法
此方法返回引用类型定义（即在其上调用该方法的 TypeInfo）和其他类型定义（即作为参数传递的类型定义）之间是否存在派生。
isDescendant(TreePath) - 类 javax.swing.tree.TreePath 中的方法
如果 aTreePath 为此 TreePath 的后代，则返回 true。
isDescendingFrom(Component, Component) - 类 javax.swing.SwingUtilities 中的静态方法
如果组件 a 从组件 b 继承，则返回 true。
isDesignTime() - 类 java.beans.beancontext.BeanContextSupport 中的方法
报告此对象当前是否处于设计时间模式下。
isDesignTime() - 类 java.beans.Beans 中的静态方法
测试是否正处于设计模式。
isDesignTime() - 接口 java.beans.DesignMode 中的方法
值为 true 表示 JavaBeans 应该在设计时间模式下运转，而 false 表示应该在运行时运转。
isDesktopSupported() - 类 java.awt.Desktop 中的静态方法
测试当前平台是否支持此类。
isDestroyed() - 类 java.lang.ThreadGroup 中的方法
测试此线程组是否已经被销毁。
isDestroyed() - 类 java.security.KeyStore.PasswordProtection 中的方法
确定密码是否已被清除。
isDestroyed() - 接口 javax.security.auth.Destroyable 中的方法
确定此 Object 是否已经销毁。
isDestroyed() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
确定此密钥是否已经销毁。
isDestroyed() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定是否已经销毁此票据。
isDestroyed() - 类 javax.security.auth.x500.X500PrivateCredential 中的方法
确定是否已清除对此对象中的 X.509 证书、私钥和 KeyStore 别名的引用。
isDeviceSupported(MidiDevice.Info) - 类 javax.sound.midi.spi.MidiDeviceProvider 中的方法
指示该设备提供者是否支持由指定的设备信息对象表示的设备。
isDigit(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为数字。
isDigit(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为数字。
isDirect() - 类 java.nio.Buffer 中的方法
告知此缓冲区是否为直接缓冲区。
isDirect() - 类 java.nio.ByteBuffer 中的方法
判断此字节缓冲区是否为直接的。
isDirect() - 类 java.nio.CharBuffer 中的方法
判断此字符缓冲区是否为直接的。
isDirect() - 类 java.nio.DoubleBuffer 中的方法
判断此 double 缓冲区是否为直接的。
isDirect() - 类 java.nio.FloatBuffer 中的方法
判断此 float 缓冲区是否为直接的。
isDirect() - 类 java.nio.IntBuffer 中的方法
判断此 int 缓冲区是否为直接的。
isDirect() - 类 java.nio.LongBuffer 中的方法
判断此 long 缓冲区是否为直接的。
isDirect() - 类 java.nio.ShortBuffer 中的方法
判断此 short 缓冲区是否为直接的。
isDirectory() - 类 java.io.File 中的方法
测试此抽象路径名表示的文件是否是一个目录。
isDirectory() - 类 java.util.zip.ZipEntry 中的方法
如果为目录条目，则返回 true。
isDirectorySelected() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
记忆当前是否在 UI 中选择了目录的属性。
isDirectorySelectionEnabled() - 类 javax.swing.JFileChooser 中的方法
方便的调用，可根据当前的文件选择模式确定目录是否为可选择的。
isDispatchThread() - 类 java.awt.EventQueue 中的静态方法
如果正在调用的线程是当前 AWT EventQueue 的指派线程，则返回 true。
isDisplayable() - 类 java.awt.Component 中的方法
确定此组件是否可以显示。
isDisplayChangeSupported() - 类 java.awt.GraphicsDevice 中的方法
如果此 GraphicsDevice 支持低层显示更改，则返回 true。
isDisposed() - 类 javax.print.StreamPrintService 中的方法
返回一个 boolean 值，指示是否已处置此 StreamPrintService。
isDocFlavorSupported(DocFlavor) - 接口 javax.print.PrintService 中的方法
确定此 PrintService 是否支持具体 DocFlavor。
isDomainPattern() - 类 javax.management.ObjectName 中的方法
根据对象名的域部分检查对象名是否为一个模式。
isDone() - 类 java.awt.geom.FlatteningPathIterator 中的方法
测试迭代是否完成。
isDone() - 接口 java.awt.geom.PathIterator 中的方法
测试迭代是否完成。
isDone() - 接口 java.util.concurrent.Future 中的方法
如果任务已完成，则返回 true。
isDone() - 类 java.util.concurrent.FutureTask 中的方法
isDone() - 类 javax.swing.SwingWorker 中的方法
如果任务已完成，则返回 true。
isDoubleBuffered() - 类 java.awt.Component 中的方法
如果将此组件绘制到一个随后复制到屏幕上的屏幕外图像（“缓冲区”），则返回 true。
isDoubleBuffered() - 类 javax.swing.JComponent 中的方法
返回此组件是否应该使用缓冲区进行绘制。
isDoubleBufferingEnabled() - 类 javax.swing.RepaintManager 中的方法
如果此 RepaintManager 被双缓冲，则返回 true。
isDragging - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
isDragging() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
如果用户在拖动滑块，则返回 true。
isDragging - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的变量
isDragImageSupported() - 类 java.awt.dnd.DragSource 中的静态方法
报告基础平台是否提供对拖动 Image 的支持。
isDrawingBuffer() - 类 javax.swing.DebugGraphics 中的方法
返回 drawingBuffer 值。
isDrive(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
UI 类使用此方法来决定是否为驱动器或分区显示特殊图标，例如，“硬盘”图标。
isDrop() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
返回此 TransferSupport 是否表示一个放置操作。
isDuplicateToken() - 类 org.ietf.jgss.MessageProp 中的方法
测试此标记是否为先前标记的一个副本。
isDynamic() - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
如果使用相同参数的后续呈现（即调用 create(RenderContext, ParameterBlock)）可以生成不同的结果，则返回 true。
isDynamic() - 接口 java.awt.image.renderable.RenderableImage 中的方法
如果使用相同参数的后续呈现（即调用 createRendering() 或 createScaledRendering()）可以生成不同的结果，则返回 true。
isDynamic() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
如果使用相同参数的后续呈现（即调用 createRendering() 或 createScaledRendering()）可以生成不同结果，则返回 true。
isDynamicLayoutActive() - 类 java.awt.Toolkit 中的方法
返回当前是否激活了调整大小时的动态布局（以编程方式设置，并受底层操作系统和/或窗口管理器支持）。
isDynamicLayoutSet() - 类 java.awt.Toolkit 中的方法
返回 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。
isEchoOn() - 类 javax.security.auth.callback.PasswordCallback 中的方法
返回密码是否应该在键入时显示。
isEditable() - 类 java.awt.TextComponent 中的方法
指示此文本组件是否可编辑。
isEditable - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
isEditable() - 类 javax.swing.JComboBox 中的方法
如果 JComboBox 可编辑，则返回 true。
isEditable() - 类 javax.swing.JTree 中的方法
如果树可编辑，则返回 true。
isEditable() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
isEditable() - 类 javax.swing.text.JTextComponent 中的方法
返回指示此 TextComponent 是否可编辑的 boolean。
isEditing() - 类 javax.swing.JTable 中的方法
如果正在编辑单元格，则返回 true。
isEditing() - 类 javax.swing.JTree 中的方法
如果正在编辑树，则返回 true。
isEditing(JTree) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果树正被编辑，则返回 true。
isEditing(JTree) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 isEditing 方法。
isEditing(JTree) - 类 javax.swing.plaf.TreeUI 中的方法
如果树正被编辑，则返回 true。
isEditValid() - 类 javax.swing.JFormattedTextField 中的方法
如果所编辑的当前值有效，则返回 true。
isElement(Object) - 类 javax.xml.bind.JAXBIntrospector 中的方法
如果 object 表示一个 JAXB 元素，则返回 true。
isElementContentWhitespace() - 接口 org.w3c.dom.Text 中的方法
返回此文本节点是否包含 元素内容空白符，即经常所称的“可忽略的空白符”。
isEmpty() - 类 java.awt.geom.Arc2D.Double 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.Arc2D.Float 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.Area 中的方法
测试此 Area 对象是否包括其他区域。
isEmpty() - 类 java.awt.geom.Ellipse2D.Double 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.Ellipse2D.Float 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.Rectangle2D.Double 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.Rectangle2D.Float 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.RectangularShape 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.Rectangle 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.RenderingHints 中的方法
如果此 RenderingHints 未包含键-值映射关系，则返回 true。
isEmpty() - 类 java.beans.beancontext.BeanContextSupport 中的方法
报告此 BeanContext 是否为空。
isEmpty() - 类 java.lang.String 中的方法
当且仅当 String.length() 为 0 时返回 true。
isEmpty() - 类 java.util.AbstractCollection 中的方法
如果此 collection 不包含元素，则返回 true。
isEmpty() - 类 java.util.AbstractMap 中的方法
如果此映射未包含键-值映射关系，则返回 true。
isEmpty() - 类 java.util.ArrayDeque 中的方法
如果此双端队列未包含任何元素，则返回 true。
isEmpty() - 类 java.util.ArrayList 中的方法
如果此列表中没有元素，则返回 true
isEmpty() - 类 java.util.BitSet 中的方法
如果此 BitSet 中没有包含任何设置为 true 的位，则返回 ture。
isEmpty() - 接口 java.util.Collection 中的方法
如果此 collection 不包含元素，则返回 true。
isEmpty() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
如果此映射不包含键-值映射关系，则返回 true。
isEmpty() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
如果此队列不包含任何元素，则返回 true。
isEmpty() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
如果此映射未包含键-值映射关系，则返回 true。
isEmpty() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
如果此 set 不包含任何元素，则返回 true。
isEmpty() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
如果此列表不包含任何元素，则返回 true。
isEmpty() - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果此 set 不包含任何元素，则返回 true。
isEmpty() - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 true。
isEmpty() - 类 java.util.Dictionary 中的方法
测试此 dictionary 是否不存在从键到值的映射。
isEmpty() - 类 java.util.HashMap 中的方法
如果此映射不包含键-值映射关系，则返回 true。
isEmpty() - 类 java.util.HashSet 中的方法
如果此 set 不包含任何元素，则返回 true。
isEmpty() - 类 java.util.Hashtable 中的方法
测试此哈希表是否没有键映射到值。
isEmpty() - 类 java.util.IdentityHashMap 中的方法
如果此标识哈希映射不包含键-值映射关系，则返回 true。
isEmpty() - 类 java.util.jar.Attributes 中的方法
如果此 Map 不包含属性，则返回 true。
isEmpty() - 接口 java.util.List 中的方法
如果列表不包含元素，则返回 true。
isEmpty() - 接口 java.util.Map 中的方法
如果此映射未包含键-值映射关系，则返回 true。
isEmpty() - 接口 java.util.Set 中的方法
如果 set 不包含元素，则返回 true。
isEmpty() - 类 java.util.TreeSet 中的方法
如果此 set 不包含任何元素，则返回 true。
isEmpty() - 类 java.util.Vector 中的方法
测试此向量是否不包含组件。
isEmpty() - 类 java.util.WeakHashMap 中的方法
如果此映射不包含键-值映射关系，则返回 true。
isEmpty() - 类 javax.activation.MimeTypeParameterList 中的方法
确定此列表是否为空。
isEmpty() - 接口 javax.management.openmbean.TabularData 中的方法
如果此 TabularData 实例中包含的 CompositeData 值的数目（即行数）为零，则返回 true。
isEmpty() - 类 javax.management.openmbean.TabularDataSupport 中的方法
如果此 TabularDataSupport 实例不包含任何行，则返回 true。
isEmpty() - 类 javax.management.timer.Timer 中的方法
测试计时器通知列表是否为空。
isEmpty() - 接口 javax.management.timer.TimerMBean 中的方法
测试计时器通知列表是否为空。
isEmpty() - 类 javax.naming.CompositeName 中的方法
确定此复合名称是否为空。
isEmpty() - 类 javax.naming.CompoundName 中的方法
确定此组合名称是否为空。
isEmpty() - 类 javax.naming.ldap.LdapName 中的方法
确定此 LDAP 名称是否为空。
isEmpty() - 接口 javax.naming.Name 中的方法
确定此名称是否为空。
isEmpty() - 接口 javax.print.attribute.AttributeSet 中的方法
如果此属性集不包含任何属性，则返回 true。
isEmpty() - 类 javax.print.attribute.HashAttributeSet 中的方法
如果此属性集不包含任何属性，则返回 true。
isEmpty() - 类 javax.script.SimpleBindings 中的方法
如果此映射未包含键-值映射关系，则返回 true。
isEmpty() - 类 javax.swing.DefaultListModel 中的方法
测试此列表中是否有组件。
isEmpty() - 类 javax.swing.text.html.parser.Element 中的方法
检查是否为空
isEmpty() - 类 javax.swing.text.SimpleAttributeSet 中的方法
检查属性集是否为空。
isEnabled() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
确定是否启用了此对象。
isEnabled() - 类 java.awt.Component 中的方法
确定此组件是否已启用。
isEnabled() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
确定是否已启用对象。
isEnabled() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
确定是否启用该对象。
isEnabled() - 类 java.awt.MenuItem 中的方法
检查是否启用了此菜单项。
isEnabled() - 接口 javax.accessibility.AccessibleComponent 中的方法
确定是否已启用该对象。
isEnabled() - 类 javax.swing.AbstractAction 中的方法
如果启用该操作，则返回 true。
isEnabled() - 接口 javax.swing.Action 中的方法
返回 Action 的启用状态。
isEnabled() - 接口 javax.swing.ButtonModel 中的方法
指示是否可通过输入设备（比如鼠标指针）选择或触发按钮。
isEnabled() - 类 javax.swing.DefaultButtonModel 中的方法
指示是否可通过输入设备（比如鼠标指针）选择或触发按钮。
isEnabled() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
isEnabled() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
确定是否启用该对象。
isEnabled() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicSliderUI.ActionScroller 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 中的方法
isEnabled() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
isEnabled() - 类 javax.swing.ToolTipManager 中的方法
如果启用该对象，则返回 true。
isEnabledAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回当前是否启用了 index 位置的选项卡。
isEndDocument() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 EndDocument 的实用工具函数。
isEndElement() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 EndElement 的实用工具函数。
isEndElement() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isEndElement() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果光标指向结束标记，则返回 true（否则返回 false）
isEnqueued() - 类 java.lang.ref.Reference 中的方法
由程序或垃圾回收器通知是否已将此引用对象加入队列。
isEntityReference() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 EntityReference 的实用工具函数。
isEnum() - 类 java.lang.Class 中的方法
当且仅当该类声明为源代码中的枚举时返回 true。
isEnumConstant() - 类 java.lang.reflect.Field 中的方法
如果此字段表示枚举类型的元素，则返回 true；否则返回 false。
isEqual(byte[], byte[]) - 类 java.security.MessageDigest 中的静态方法
比较两个摘要的相等性。
isEqual(AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
检查两个属性集合是否相等。
isEqual(AttributeSet) - 接口 javax.swing.text.AttributeSet 中的方法
确定两个属性集是否相等。
isEqual(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 中的方法
比较两个属性集。
isEqual(AttributeSet) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
检查两个属性集是否相等。
isEqual(AttributeSet) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
检查两个属性集是否相等。
isEqualNode(Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
isEqualNode(Node) - 接口 org.w3c.dom.Node 中的方法
测试两个节点是否相等。
isError() - 类 java.nio.charset.CoderResult 中的方法
通知此对象是否描述错误情况。
isErrorAny() - 类 java.awt.MediaTracker 中的方法
检查所有图像的错误状态。
isErrorID(int) - 类 java.awt.MediaTracker 中的方法
检查由此媒体跟踪器跟踪且具有指定标识符的所有图像的错误状态。
isEstablished() - 接口 org.ietf.jgss.GSSContext 中的方法
用来在上下文创建期间确定上下文的状态。
isEventDispatchThread() - 类 javax.swing.SwingUtilities 中的静态方法
如果当前线程是 AWT 事件指派线程，则返回 true。
isExpanded(TreePath) - 类 javax.swing.JTree 中的方法
如果当前展开了路径标识的节点，则返回 true。
isExpanded(int) - 类 javax.swing.JTree 中的方法
如果当前展开了指定显示行处的节点，则返回 true。
isExpanded(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
如果当前扩展了由行标识的值，则返回 true。
isExpanded(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
如果当前扩展了由行标识的值，则返回 true。
isExpanded(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
如果当前扩展了 path 标识的值，则返回 true。
isExpandEntityReferences() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成扩展实体引用节点的解析器。
isExpert() - 类 java.beans.FeatureDescriptor 中的方法
"expert" 标志用于区分那些打算供高级用户使用的特性与那些打算供普通用户使用的特性。
isExplicitPolicyRequired() - 类 java.security.cert.PKIXParameters 中的方法
检查是否需要显式策略。
isFair() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
如果此锁的公平设置为 true，则返回 true。
isFair() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
如果此锁将公平性设置为 ture，则返回 true。
isFair() - 类 java.util.concurrent.Semaphore 中的方法
如果此信号量的公平设置为 true，则返回 true。
isFeatureSupported(String) - 类 javax.xml.crypto.dom.DOMStructure 中的方法
isFeatureSupported(String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
指示是否支持指定的功能。
isFeatureSupported(String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
指示是否支持指定的功能。
isFeatureSupported(String) - 接口 javax.xml.crypto.XMLStructure 中的方法
指示是否支持指定的功能。
isField() - 枚举 javax.lang.model.element.ElementKind 中的方法
如果此元素是以下种类的字段，则返回 true：FIELD 或 ENUM_CONSTANT。
isFile() - 类 java.io.File 中的方法
测试此抽象路径名表示的文件是否是一个标准文件。
isFileHidingEnabled() - 类 javax.swing.JFileChooser 中的方法
如果在文件选择器中不显示隐藏文件，则返回 true；否则返回 false。
isFileSelectionEnabled() - 类 javax.swing.JFileChooser 中的方法
方便的调用，可根据当前的文件选择模式确定文件是否为可选择的。
isFileSystem(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
检查 f 是否表示一个相对于特殊文件夹（如 "Desktop"）的实际目录或文件。
isFileSystemRoot(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
判断 dir 是否是文件系统（如驱动器或分区）中的树的根。
isFileTypeSupported(int) - 类 javax.sound.midi.MidiSystem 中的静态方法
指示系统是否提供了指定 MIDI 文件类型的文件写入支持。
isFileTypeSupported(int, Sequence) - 类 javax.sound.midi.MidiSystem 中的静态方法
指示是否可从指示的序列写入指定文件类型的 MIDI 文件。
isFileTypeSupported(int) - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
指示此文件 writer 是否提供指定 MIDI 文件类型的文件写入支持。
isFileTypeSupported(int, Sequence) - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
指示是否可从指示的序列写入指定文件类型的 MIDI 文件。
isFileTypeSupported(AudioFileFormat.Type) - 类 javax.sound.sampled.AudioSystem 中的静态方法
指示系统是否提供指定文件类型的文件写入支持。
isFileTypeSupported(AudioFileFormat.Type, AudioInputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
指示是否可以从指示的音频输入流写入指定文件类型的音频文件。
isFileTypeSupported(AudioFileFormat.Type) - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
指示此音频文件 writer 是否提供指定文件类型的文件写入支持。
isFileTypeSupported(AudioFileFormat.Type, AudioInputStream) - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
指示是否可以从指示的音频输入流写入指定类型的音频文件。
isFinal(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 final 修饰符，则返回 true，否则返回 false。
isFirst() - 接口 java.sql.ResultSet 中的方法
获取光标是否位于此 ResultSet 对象的第一行。
isFixedRowHeight() - 类 javax.swing.JTree 中的方法
如果每个显示行的高度为固定大小，则返回 true。
isFixedRowHeight() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
如果每行的高度为固定大小，则返回 true。
isFlavorJavaFileListType() - 类 java.awt.datatransfer.DataFlavor 中的方法
如果指定的 DataFlavor 表示 File 对象列表，则返回 true。
isFlavorRemoteObjectType() - 类 java.awt.datatransfer.DataFlavor 中的方法
如果指定的 DataFlavor 表示远程对象，则返回 true。
isFlavorSerializedObjectType() - 类 java.awt.datatransfer.DataFlavor 中的方法
如果指定的 DataFlavor 表示序列化对象，则返回 true。
isFlavorTextType() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 是否是 Java 平台此实现的有效文本 flavor。
isFloatable() - 类 javax.swing.JToolBar 中的方法
获取 floatable 属性。
isFloating() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
isFloppyDrive(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
UI 类使用此方法来决定是否为软盘显示特殊图标。
isFocusable() - 类 java.awt.Component 中的方法
返回此 Component 是否可以获得焦点。
isFocusableWindow() - 类 java.awt.Window 中的方法
返回此窗口是否可以成为焦点窗口，也就是说，此窗口或其任何子组件是否可以成为焦点所有者。
isFocusCycleRoot(Container) - 类 java.awt.Component 中的方法
返回指定的 Container 是否为此 Component 焦点遍历循环的焦点循环根。
isFocusCycleRoot(Container) - 类 java.awt.Container 中的方法
返回指定的 Container 是否是此 Container 的焦点遍历循环的焦点循环根。
isFocusCycleRoot() - 类 java.awt.Container 中的方法
返回此 Container 是否是某个焦点遍历循环的根。
isFocusCycleRoot() - 类 java.awt.Window 中的方法
始终返回 true，因为所有窗口必须是焦点遍历循环的根。
isFocusCycleRoot() - 类 javax.swing.JInternalFrame 中的方法
始终返回 true，原因是所有 JInternalFrame 必须为焦点遍历循环的根。
isFocused() - 类 java.awt.Window 中的方法
返回此窗口是否为焦点窗口。
isFocusManagerEnabled() - 类 javax.swing.FocusManager 中的静态方法
已过时。 从 1.4 开始，由 KeyboardFocusManager.getDefaultFocusTraversalPolicy() 取代
isFocusOwner() - 类 java.awt.Component 中的方法
如果此 Component 是焦点所有者，则返回 true。
isFocusPainted() - 类 javax.swing.AbstractButton 中的方法
获取 paintFocus 属性。
isFocusTraversable() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回对此对象是否可以接受焦点的判断。
isFocusTraversable() - 类 java.awt.Component 中的方法
已过时。 从 1.4 开始，由 isFocusable() 取代。
isFocusTraversable() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
返回此对象是否可以接受焦点。
isFocusTraversable() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回此对象是否可以接受焦点。
isFocusTraversable() - 接口 javax.accessibility.AccessibleComponent 中的方法
返回此对象是否可以接受焦点。
isFocusTraversable() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
isFocusTraversable() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
isFocusTraversable() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
isFocusTraversable() - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
返回箭头按钮是否应该获取焦点。
isFocusTraversable(JComboBox) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
确定 JComboBox 是否是可焦点遍历的。
isFocusTraversable() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
重写以无条件返回 false。
isFocusTraversable() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 中的方法
isFocusTraversable(JComboBox) - 类 javax.swing.plaf.ComboBoxUI 中的方法
确定组合框本身是否是可遍历的
isFocusTraversable() - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
isFocusTraversable(JComboBox) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 isFocusTraversable 方法。
isFocusTraversable() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
isFocusTraversalPolicyProvider() - 类 java.awt.Container 中的方法
返回此容器是否提供焦点遍历策略。
isFocusTraversalPolicySet() - 类 java.awt.Container 中的方法
返回是否为此 Container 明确设置焦点遍历策略。
isFontSet() - 类 java.awt.Component 中的方法
返回是否已为此组件显示地设置了字体。
isForegroundSet() - 类 java.awt.Component 中的方法
返回是否已为此组件显式地设置了前景色。
isFormatLossless() - 类 javax.imageio.spi.ImageWriterSpi 中的方法
如果此 writer 输出的格式准确保留了像素数据位，则返回 true。
isFormatSupported(AudioFormat) - 类 javax.sound.sampled.DataLine.Info 中的方法
指示此数据行是否支持特定的音频格式。
isFormattedOutput() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
获取格式化输出标志的便捷方法。
isForwardable() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是可转发的。
isForwardCheckingSupported() - 类 java.security.cert.PKIXCertPathChecker 中的方法
指示是否支持正向检查。
isForwarded() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
根据验证（包括转发的票据授权票据）确定此票据是否已经转发或发出。
isFragment() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
获取片段标志的便捷方法。
isFrameStateSupported(int) - 类 java.awt.Toolkit 中的方法
返回 Toolkit 是否支持 Frame 状态。
isFreeStanding - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的变量
isFullScreenRequired() - 类 java.awt.BufferCapabilities 中的方法
isFullScreenSupported() - 类 java.awt.GraphicsDevice 中的方法
如果此 GraphicsDevice 支持全屏独占模式，则返回 true。
isGapToken() - 类 org.ietf.jgss.MessageProp 中的方法
测试是否未接收到需要的标记（即一个或多个原先的标记尚未成功处理）。
isGeneral() - 类 javax.swing.text.html.parser.Entity 中的方法
如果是常规实体，则返回 true。
isGlobalScope() - 类 javax.xml.bind.JAXBElement 中的方法
如果此 xml 元素声明是全局性的，则返回 true。
isGraphicsConfigSupported(GraphicsConfiguration) - 类 java.awt.GraphicsConfigTemplate 中的方法
返回一个 boolean，它指示指定的 GraphicsConfiguration 是否可用于创建支持指定功能的绘图面。
isGroupingUsed() - 类 java.text.NumberFormat 中的方法
如果此格式中使用了分组，则返回 true。
isGuiAvailable() - 类 java.beans.Beans 中的静态方法
确定 bean 是否可以假定某个 GUI 是可用的。
isHeadless() - 类 java.awt.GraphicsEnvironment 中的静态方法
测试此环境是否支持显示器、键盘和鼠标。
isHeadlessInstance() - 类 java.awt.GraphicsEnvironment 中的方法
返回此图形环境是否支持显示器、键盘和鼠标。
isHeldByCurrentThread() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询当前线程是否保持此锁。
isHeldByCurrentThread() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
查询此写入锁是否由当前线程保持。
isHeldExclusively() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
如果对于当前（调用的）线程，同步是以独占方式进行的，则返回 true。
isHeldExclusively() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
如果对于当前（正调用的）线程，同步是以独占方式进行的，则返回 true。
isHidden() - 类 java.beans.FeatureDescriptor 中的方法
"hidden" 标志用于标识只打算供工具使用、不应对人类开放的特性。
isHidden() - 类 java.io.File 中的方法
测试此抽象路径名指定的文件是否是一个隐藏文件。
isHidden(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法
isHiddenFile(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
返回某个文件是否被隐藏。
isHighSurrogate(char) - 类 java.lang.Character 中的静态方法
确定给出的 char 值是否为一个高代理项代码单元（也称为前导代理项代码单元）。
isHorizontal() - 类 java.awt.ComponentOrientation 中的方法
各行是水平的？这将为水平的、从左到右的书写系统（如罗马语）返回 true。
isHTMLString(String) - 类 javax.swing.plaf.basic.BasicHTML 中的静态方法
检查给定字符串以查看它是否应该在支持 html 呈现的非文本组件中触发 html 呈现逻辑。
isIcon - 类 javax.swing.JInternalFrame 中的变量
窗体已图标化。
isIcon() - 类 javax.swing.JInternalFrame 中的方法
返回 JInternalFrame 当前是否已图标化。
isIconifiable() - 类 javax.swing.JInternalFrame 中的方法
获取该 iconable 属性（默认情况下为 false）。
isIconOnly() - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
isId() - 接口 org.w3c.dom.Attr 中的方法
返回是否此属性属于类型 ID（即包含其所有者元素的标识符）。
isIdAttribute(int) - 类 javax.xml.validation.TypeInfoProvider 中的方法
如果指定属性确定为 ID，则返回 true。
isIdentifier(CharSequence) - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回 name 是否是语法上有效的标识符（简单名称）或最新源版本中的关键字。
isIdentifierIgnorable(char) - 类 java.lang.Character 中的静态方法
确定是否应该认为指定字符是 Java 标识符或 Unicode 标识符中可忽略的一个字符。
isIdentifierIgnorable(int) - 类 java.lang.Character 中的静态方法
确定是否应该认为指定字符（Unicode 代码点）是 Java 标识符或 Unicode 标识符中可忽略的一个字符。
isIdentity() - 类 java.awt.font.TransformAttribute 中的方法
如果包装转换是一个恒等变换，则返回 true。
isIdentity() - 类 java.awt.geom.AffineTransform 中的方法
如果此 AffineTransform 是恒等变换，则返回 true。
isIgnorableWhiteSpace() - 接口 javax.xml.stream.events.Characters 中的方法
如果它是 ignorableWhiteSpace，则返回 ture。
isIgnoringComments() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成忽略注释的解析器。
isIgnoringElementContentWhitespace() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成解析器，该解析器忽略元素内容中的可忽略空格。
isIgnoringMetadata() - 类 javax.imageio.ImageReader 中的方法
如果已经通过传递 true 作为 setInput 方法的 ignoreMetadata 参数将当前输入源标记为允许忽略元数据，则返回 true。
isImageAutoSize() - 类 java.awt.TrayIcon 中的方法
返回自动调整大小属性的值。
isImageTiled(int) - 类 javax.imageio.ImageReader 中的方法
如果图像被组织成 tile（即等大小的非重叠矩形），则返回 true。
isInboundDone() - 类 javax.net.ssl.SSLEngine 中的方法
返回 SSLEngine.unwrap(ByteBuffer, ByteBuffer) 是否再接受更多的入站数据报文。
isInDefaultEventSet() - 类 java.beans.EventSetDescriptor 中的方法
报告事件集是否在“默认”集合中。
isIndeterminate() - 类 javax.swing.JProgressBar 中的方法
返回 indeterminate 属性的值。
ISINDEX - 类 javax.swing.text.html.HTML.Tag 中的静态变量
isindex - 类 javax.swing.text.html.parser.DTD 中的变量
isIndexSelected(int) - 类 java.awt.List 中的方法
确定是否已选中此滚动列表中的指定项。
isInfinite(double) - 类 java.lang.Double 中的静态方法
如果指定数在数值上为无穷大，则返回 true；否则返回 false。
isInfinite() - 类 java.lang.Double 中的方法
如果此 Double 值在数值上为无穷大，则返回 true；否则返回 false。
isInfinite(float) - 类 java.lang.Float 中的静态方法
如果指定数的数值是无穷大，则返回 true，否则返回 false。
isInfinite() - 类 java.lang.Float 中的方法
如果此 Float 值的大小是无穷大，则返回 true，否则返回 false。
isInherited() - 类 javax.swing.text.html.CSS.Attribute 中的方法
指示是否应该从父级继承属性。
isInitial() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是使用 Kerberos AS-Exchange 协议发出的，而不是根据某些票据授权票据发出的。
isInitialized() - 类 javax.annotation.processing.AbstractProcessor 中的方法
如果此对象已被初始化，则返回 true，否则返回 false。
isInitiator() - 接口 org.ietf.jgss.GSSContext 中的方法
确定它是否为上下文初始端。
isInNative() - 类 java.lang.management.ThreadInfo 中的方法
测试与此 ThreadInfo 关联的线程是否通过 Java 本机接口 (JNI) 执行本机代码。
isInProgress() - 类 javax.swing.undo.CompoundEdit 中的方法
如果此编辑正在进行中（即未收到结束通知），则返回 true。
isInputShutdown() - 类 java.net.Socket 中的方法
返回是否关闭套接字连接的半读状态 (read-half)。
isInRelationService() - 类 javax.management.relation.RelationSupport 中的方法
返回指定该对象是否仍然由 Relation Service 处理的内部标志。
isInRelationService() - 接口 javax.management.relation.RelationSupportMBean 中的方法
返回指定该对象是否仍然由 Relation Service 处理的内部标志。
isInsert() - 类 javax.swing.JList.DropLocation 中的方法
返回此位置是否表示一个插入位置。
isInsertColumn() - 类 javax.swing.JTable.DropLocation 中的方法
返回此位置是否表示一个列的插入位置。
isInsertRow() - 类 javax.swing.JTable.DropLocation 中的方法
返回此位置是否表示一个行的插入位置。
isInstance(Object) - 类 java.lang.Class 中的方法
判定指定的 Object 是否与此 Class 所表示的对象赋值兼容。
isInstanceOf(Object, Class<?>) - 类 java.beans.Beans 中的静态方法
检查是否可以将 bean 视为给定目标类型。
isInstanceOf(ObjectName, String) - 接口 javax.management.MBeanServer 中的方法
isInstanceOf(ObjectName, String) - 接口 javax.management.MBeanServerConnection 中的方法
如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。
isInstanceOf(StringValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于 MBean 类的继承约束条件。
isInstanceOf(ObjectName, String, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
isInstanceOf(ObjectName, String, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
isInstanceOf(ObjectName, String, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
isInterface() - 类 java.lang.Class 中的方法
判定指定的 Class 对象是否表示一个接口类型。
isInterface(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 interface 修饰符，则返回 true，否则返回 false。
isInterface() - 枚举 javax.lang.model.element.ElementKind 中的方法
如果此元素是以下种类的接口，则返回 true：INTERFACE 或 ANNOTATION_TYPE。
isInterrupted() - 类 java.lang.Thread 中的方法
测试线程是否已经中断。
isIPv4CompatibleAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否是与 IPv4 兼容的 IPv6 地址的实用例行程序。
isIs() - 类 javax.management.MBeanAttributeInfo 中的方法
指示此属性是否有一个 "is" 获取方法。
isIs() - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
如果通过 isXXX 获取方法（仅适用于 boolean 和 Boolean 值）访问此 OpenMBeanAttributeInfo 实例描述的属性，则返回 true，否则返回 false。
isISOControl(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为 ISO 控制字符。
isISOControl(int) - 类 java.lang.Character 中的静态方法
确定引用的字符（Unicode 代码点）是否为 ISO 控制字符。
isItalic() - 类 java.awt.Font 中的方法
指示此 Font 对象的样式是否为 ITALIC。
isItalic(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了斜体属性。
isJavaIdentifierPart(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否可以是 Java 标识符中首字符以外的部分。
isJavaIdentifierPart(int) - 类 java.lang.Character 中的静态方法
确定字符（Unicode 代码点）是否可以是 Java 标识符中首字符以外的部分。
isJavaIdentifierStart(char) - 类 java.lang.Character 中的静态方法
确定是否允许将指定字符作为 Java 标识符中的首字符。
isJavaIdentifierStart(int) - 类 java.lang.Character 中的静态方法
确定是否允许将字符（Unicode 代码点）作为 Java 标识符中的首字符。
isJavaLetter(char) - 类 java.lang.Character 中的静态方法
已过时。 由 isJavaIdentifierStart(char) 取代。
isJavaLetterOrDigit(char) - 类 java.lang.Character 中的静态方法
已过时。 由 isJavaIdentifierPart(char) 取代。
isJavaMIMEType(String) - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
返回指定的 String 是否为编码的 Java MIME 类型。
isKeyBindingActive() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
isKeyBindingRegistered() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
isKeyDown - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 中的变量
keyPressed 处于激活状态时设置为 true。
isKeyEntry(String) - 类 java.security.KeyStore 中的方法
如果给定别名标识的条目是通过调用 setKeyEntry 或者以 PrivateKeyEntry 或 SecretKeyEntry 为参数的 setEntry 创建的，则返回 true。
isKeyword(CharSequence) - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回 s 是否是最新源版本中的关键字或字面值。
isLargeModel() - 类 javax.swing.JTree 中的方法
如果将树配置为大模型，则返回 true。
isLargeModel() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
isLast() - 接口 java.sql.ResultSet 中的方法
获取光标是否位于此 ResultSet 对象的最后一行。
isLayoutValid() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
是否已对子视图进行布局。
isLayoutValid(int) - 类 javax.swing.text.BoxView 中的方法
确定沿给定轴的布局是否有效。
isLeadAnchorNotificationEnabled() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回 leadAnchorNotificationEnabled 标志的值。
isLeadingEdge() - 类 java.awt.font.TextHitInfo 中的方法
如果字符的开始边是插入点，则返回 true。
isLeaf() - 类 javax.swing.JTree.DynamicUtilTreeNode 中的方法
如果此节点允许子节点，则返回 true。
isLeaf(int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
isLeaf() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
检查该元素是否为叶元素。
isLeaf() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
检查该元素是否为叶元素。
isLeaf() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
检查该元素是否为叶元素。
isLeaf() - 接口 javax.swing.text.Element 中的方法
确定此元素是否为叶元素。
isLeaf() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果此节点没有子节点，则返回 true。
isLeaf(Object) - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回指定的节点是否为叶节点。
isLeaf(Object) - 接口 javax.swing.tree.TreeModel 中的方法
如果 node 为叶节点，则返回 true。
isLeaf() - 接口 javax.swing.tree.TreeNode 中的方法
如果接收者是一个叶节点，则返回 true。
isLeapYear(int) - 类 java.util.GregorianCalendar 中的方法
确定给定的年份是否为闰年。
isLeftMouseButton(MouseEvent) - 类 javax.swing.SwingUtilities 中的静态方法
如果鼠标事件指定左边鼠标按键，则返回 true。
isLeftToRight() - 类 java.awt.ComponentOrientation 中的方法
水平行：各项从左到右布局？
垂直行：各行从左到右布局？
这将为水平的、从左到右的书写系统（如罗马语）返回 true。
isLeftToRight() - 类 java.awt.font.TextLayout 中的方法
如果此 TextLayout 的基本方向是从左到右，则返回 true；如果基本方向是从右到左，则返回 false。
isLeftToRight() - 类 java.text.Bidi 中的方法
如果该行都是从左到右的文本且基本方向也是从左到右，则返回 true。
isLegalReplacement(byte[]) - 类 java.nio.charset.CharsetEncoder 中的方法
通知给定的 byte 数组是否为此编码器的合法替换值。
isLenient() - 类 java.text.DateFormat 中的方法
判断日期/时间解析是否为不严格的。
isLenient() - 类 java.util.Calendar 中的方法
判断日期/时间的解释是否为宽松的。
isLetter(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为字母。
isLetter(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为字母。
isLetterOrDigit(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为字母或数字。
isLetterOrDigit(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为字母或数字。
isLigature() - 类 java.awt.font.GlyphMetrics 中的方法
如果这是一个连字字形，则返回 true。
isLight - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 中的变量
isLightweight() - 类 java.awt.Component 中的方法
轻量级组件没有本机工具包同位体。
isLightweightComponent(Component) - 类 javax.swing.JComponent 中的静态方法
如果此组件是轻量的，也就是说，如果它没有本机窗口系统同位体，则返回 true。
isLightWeightPopupEnabled() - 类 javax.swing.JComboBox 中的方法
获取 lightWeightPopupEnabled 属性的值。
isLightWeightPopupEnabled() - 类 javax.swing.JPopupMenu 中的方法
获取 lightWeightPopupEnabled 属性。
isLightWeightPopupEnabled() - 类 javax.swing.ToolTipManager 中的方法
如果使用轻量级（所有 Java）Tooltips，则返回 true；如果使用重量级（本机同位体）Tooltips，则返回 false。
isLineEmpty() - 类 javax.swing.text.AbstractWriter 中的方法
如果应该将当前行视为空行，则返回 true。
isLineSupported(Line.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
指示系统是否支持与指定 Line.Info 对象匹配的行。
isLineSupported(Line.Info) - 接口 javax.sound.sampled.Mixer 中的方法
指示混频器是否支持与指定 Line.Info 对象匹配的一行（或多行）。
isLinkLocalAddress() - 类 java.net.Inet4Address 中的方法
检查 InetAddress 是否是链接本地地址的实用例行程序。
isLinkLocalAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否是链接本地地址的实用例行程序。
isLinkLocalAddress() - 类 java.net.InetAddress 中的方法
检查 InetAddress 是否是链接本地地址的实用例行程序。
isLoaded() - 类 java.nio.MappedByteBuffer 中的方法
判断此缓冲区的内容是否位于物理内存中。
isLocal - 类 java.awt.dnd.DropTargetContext.TransferableProxy 中的变量
一个 boolean 值，指示所封装的 Transferable 对象是否表示执行本地 drag-n-drop 操作的结果（在同一个 JVM 中）。
isLocal(Stub) - 类 javax.rmi.CORBA.Util 中的静态方法
isLocal 方法与 ObjectImpl._is_local 方法具有相同的语义，否则可能抛出 RemoteException。
isLocal(Stub) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.isLocal(javax.rmi.CORBA.Stub) 的委托调用。
isLocalClass() - 类 java.lang.Class 中的方法
当且仅当底层类是本地类时返回 true。
isLocallyDefined(KeyStroke) - 接口 javax.swing.text.Keymap 中的方法
确定是否本地定义给定的键序列。
isLocalTransfer() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回一个指示源对象与目标对象是否在同一 JVM 中的 int。
isLocationByPlatform() - 类 java.awt.Window 中的方法
如果此窗口下次可见时，出现在本机窗口操作系统的默认位置，则返回 true。
isLocationInExpandControl(TreePath, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果 mouseX 和 mouseY 落在用于展开/折叠节点的行的区域内，并且 row 的节点不表示叶节点，则返回 true。
isLocationInExpandControl(int, int, int, int) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
isLocked() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询此锁是否由任意线程保持。
isLoggable(LogRecord) - 接口 java.util.logging.Filter 中的方法
检查是否应该发布给定的日志记录。
isLoggable(LogRecord) - 类 java.util.logging.Handler 中的方法
检查该 Handler 是否实际记录给定的 LogRecord。
isLoggable(Level) - 类 java.util.logging.Logger 中的方法
检查给定级别的消息实际上是否由此 logger 记录。
isLoggable(LogRecord) - 类 java.util.logging.MemoryHandler 中的方法
检查此 Handler 是否实际将给定的 LogRecord 记录到其内部缓冲区。
isLoggable(LogRecord) - 类 java.util.logging.StreamHandler 中的方法
检查该 Handler 是否实际记录给定的 LogRecord。
isLongerThan(Duration) - 类 javax.xml.datatype.Duration 中的方法
检查此持续时间对象是否严格长于另一个 Duration 对象。
isLoopback() - 类 java.net.NetworkInterface 中的方法
返回网络接口是否是回送接口。
isLoopbackAddress() - 类 java.net.Inet4Address 中的方法
isLoopbackAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否是回送地址中的实用例行程序。
isLoopbackAddress() - 类 java.net.InetAddress 中的方法
检查 InetAddress 是否是回送地址的实用例行程序。
isLowerCase(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为小写字母。
isLowerCase(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为小写字母。
isLowSurrogate(char) - 类 java.lang.Character 中的静态方法
确定给定 char 值是否一个低代理项代码单元（也称为尾部代理项代码单元）。
isMalformed() - 类 java.nio.charset.CoderResult 中的方法
通知此对象是否描述错误输入错误。
isManagingFocus() - 类 javax.swing.JComponent 中的方法
已过时。 从 1.4 版本开始，由 Component.setFocusTraversalKeys(int, Set) 和 Container.setFocusCycleRoot(boolean) 取代。
ISMAP - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
isMarked() - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
返回该标记的当前值。
isMaximizable() - 类 javax.swing.JInternalFrame 中的方法
获取该 maximizable 属性的值。
isMaximum - 类 javax.swing.JInternalFrame 中的变量
已将窗体扩展到其最大大小。
isMaximum() - 类 javax.swing.JInternalFrame 中的方法
返回 JInternalFrame 当前是否已最大化。
isMaximumSizeSet() - 类 java.awt.Component 中的方法
如果已将最大大小设置为非 null 值，则返回 true，否则返回 false。
isMCGlobal() - 类 java.net.Inet4Address 中的方法
检查多播地址是否具有全局范围的实用例行程序。
isMCGlobal() - 类 java.net.Inet6Address 中的方法
检查多播地址是否具有全球范围的实用例行程序。
isMCGlobal() - 类 java.net.InetAddress 中的方法
检查多播地址是否具有全局域的实用例行程序。
isMCLinkLocal() - 类 java.net.Inet4Address 中的方法
检查多播地址是否具有链接范围的实用例行程序。
isMCLinkLocal() - 类 java.net.Inet6Address 中的方法
检查多播地址是否具有链接范围的实用例行程序。
isMCLinkLocal() - 类 java.net.InetAddress 中的方法
检查多播地址是否具有链接范围的实用例行程序。
isMCNodeLocal() - 类 java.net.Inet4Address 中的方法
检查多播地址是否具有节点范围的实用例行程序。
isMCNodeLocal() - 类 java.net.Inet6Address 中的方法
检查多播地址是否具有节点范围的实用例行程序。
isMCNodeLocal() - 类 java.net.InetAddress 中的方法
检查多播地址是否具有节点范围的实用例行程序。
isMCOrgLocal() - 类 java.net.Inet4Address 中的方法
检查多播地址是否具有组织范围的实用例程。
isMCOrgLocal() - 类 java.net.Inet6Address 中的方法
检查多播地址是否具有组织范围的实用例行程序。
isMCOrgLocal() - 类 java.net.InetAddress 中的方法
检查多播地址是否具有组织范围的实用例行程序。
isMCSiteLocal() - 类 java.net.Inet4Address 中的方法
检查多播地址是否具有站点范围的实用例行程序。
isMCSiteLocal() - 类 java.net.Inet6Address 中的方法
检查多播地址是否具有站点范围的实用例行程序。
isMCSiteLocal() - 类 java.net.InetAddress 中的方法
检查多播地址是否具有站点范围的实用例行程序。
isMember(Principal) - 接口 java.security.acl.Group 中的方法
如果传递的主体是组的一个成员，则返回 true。
isMemberClass() - 类 java.lang.Class 中的方法
当且仅当底层类是成员类时返回 true。
isMenuComponent(Component) - 类 javax.swing.JMenu 中的方法
如果在子菜单层次结构中存在指定的组件，则返回 true。
isMetaDown() - 类 java.awt.event.InputEvent 中的方法
返回 Meta 修饰符在此事件上是否为 down。
isMiddleMouseButton(MouseEvent) - 类 javax.swing.SwingUtilities 中的静态方法
如果鼠标事件指定中间鼠标按键，则返回 true。
isMimeTypeEqual(String) - 类 java.awt.datatransfer.DataFlavor 中的方法
返回传入的 MIME 类型的字符串表示形式是否等于此 DataFlavor 的 MIME 类型。
isMimeTypeEqual(DataFlavor) - 类 java.awt.datatransfer.DataFlavor 中的方法
比较两个 DataFlavor 对象的 mimeType。
isMimeTypeEqual(String) - 类 javax.activation.ActivationDataFlavor 中的方法
传入的 MIME 类型的字符串表示形式是否等效于此 DataFlavor 的 MIME 类型。
isMimeTypeSerializedObject() - 类 java.awt.datatransfer.DataFlavor 中的方法
DataFlavor 是否表示序列化对象？
isMinimumSizeDirty - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
isMinimumSizeSet() - 类 java.awt.Component 中的方法
返回是否已用非 null 值调用了 setMinimumSize。
isMirrored(char) - 类 java.lang.Character 中的静态方法
确定指定字符依据 Unicode 规范是否对称。
isMirrored(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）依据 Unicode 规范是否对称。
isMixed() - 类 java.text.Bidi 中的方法
如果该行既不是从左到右也不是从右到左，则返回 true。
isMixerSupported(Mixer.Info) - 类 javax.sound.sampled.spi.MixerProvider 中的方法
指示混频器提供者是否支持由指定混频器 info 对象表示的混频器。
isMN() - 接口 org.ietf.jgss.GSSName 中的方法
测试此名称对象是否表示一个机制名称 (MN)。
isModal() - 类 java.awt.Dialog 中的方法
指出 dialog 是否为有模式的。
isModalExclusionTypeSupported(Dialog.ModalExclusionType) - 类 java.awt.Toolkit 中的方法
返回此工具包是否支持给定的模式排斥类型。
isModalityTypeSupported(Dialog.ModalityType) - 类 java.awt.Toolkit 中的方法
返回此工具包是否支持给定的模式类型。
isModifiableClass(Class<?>) - 接口 java.lang.instrument.Instrumentation 中的方法
确定一个类是否可以被 retransformation 或 redefinition 修改。
isMouseOver() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回鼠标当前是否位于分隔符上
isMTOMEnabled() - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
如果启用了 MTOM，则返回 true。
isMultiBufferAvailable() - 类 java.awt.BufferCapabilities 中的方法
isMulticastAddress() - 类 java.net.Inet4Address 中的方法
检查 InetAddress 是否是 IP 多播地址的实用例行程序。
isMulticastAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否 IP 多播地址的实用例行程序。
isMulticastAddress() - 类 java.net.InetAddress 中的方法
检查 InetAddress 是否是 IP 多播地址的实用例行程序。
isMultipleMode() - 类 java.awt.List 中的方法
确定此列表是否允许进行多项选择。
isMultiSelectEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回 true 表示节点上的鼠标事件应该根据锚点作出选择。
isMultiSelectionEnabled() - 类 javax.swing.JFileChooser 中的方法
如果可以选择多个文件，则返回 true。
isMXBean() - 类 javax.management.MBeanServerInvocationHandler 中的方法
如果为 true，则该代理适用于 MXBean，并将适当映射应用于方法参数和返回值。
isMXBeanInterface(Class<?>) - 类 javax.management.JMX 中的静态方法
测试某接口是否是 MXBean 接口。
isName(CharSequence) - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回 name 是否是最新源版本中语法上有效的限定名称。
isNameCompatible(String, JavaFileObject.Kind) - 类 javax.tools.ForwardingJavaFileObject 中的方法
isNameCompatible(String, JavaFileObject.Kind) - 接口 javax.tools.JavaFileObject 中的方法
检查此文件对象是否与指定的简单名称和种类兼容。
isNameCompatible(String, JavaFileObject.Kind) - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现对其 URI 路径和给定简单名称进行比较。
isNamespace() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 Namespace 的实用工具函数。
isNamespaceAware() - 类 javax.xml.parsers.DocumentBuilder 中的方法
指示此解析器是否被配置为可识别名称空间。
isNamespaceAware() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成具有感知名称空间功能的解析器。
isNamespaceAware() - 类 javax.xml.parsers.SAXParser 中的方法
指示此解析器是否被配置为可识别名称空间。
isNamespaceAware() - 类 javax.xml.parsers.SAXParserFactory 中的方法
指示是否将工厂配置为生成具有感知名称空间功能的解析器。
isNamespaceDeclUris() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
如果将名称空间声明属性放置到名称空间中，则返回 true。
isNaN(double) - 类 java.lang.Double 中的静态方法
如果指定的数是一个 NaN 值，则返回 true；否则返回 false。
isNaN() - 类 java.lang.Double 中的方法
如果此 Double 值是非数字（NaN）值，则返回 true；否则返回 false。
isNaN(float) - 类 java.lang.Float 中的静态方法
如果指定的数是一个非数字 (NaN) 值，则返回 true，否则返回 false。
isNaN() - 类 java.lang.Float 中的方法
如果此 Float 值是一个非数字 (NaN) 值，则返回 true，否则返回 false。
isNative(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 native 修饰符，则返回 true，否则返回 false。
isNativeLookAndFeel() - 类 javax.swing.LookAndFeel 中的方法
如果底层平台具有“本机”外观，而且这是对它的一个实现，则返回 true。
isNativeLookAndFeel() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回 false；MetalLookAndFeel 不是本机外观。
isNativeLookAndFeel() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
返回 false；此外观对于任意平台而言不是本机的。
isNativeLookAndFeel() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回 false，SynthLookAndFeel 不是一个本机外观。
isNativeMethod() - 类 java.lang.StackTraceElement 中的方法
如果包含由该堆栈跟踪元素所表示的执行点的方法是一个本机方法，则返回 true。
isNativeMethodPrefixSupported() - 接口 java.lang.instrument.Instrumentation 中的方法
返回当前 JVM 配置是否支持设置本机方法前缀。
isNavigationKey(int) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回提供的 keyCode 是否映射到用于导航的键中。
isNegative() - 接口 java.security.acl.AclEntry 中的方法
如果此项是一个 negative ACL 项（关联的主体拒绝该项中的权限集合），则返回 true；否则返回 false。
isNested() - 枚举 javax.lang.model.element.NestingKind 中的方法
此常量是否对应于嵌套类型元素？嵌套 (nested) 类型元素是任何非顶层的元素。
isNil() - 类 javax.xml.bind.JAXBElement 中的方法
如果此元素实例内容模式为 nil，则返回 true。
isNodeAncestor(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果 anotherNode 是此节点的祖先 -- 如果它是此节点、此节点的父节点或此节点的父节点的祖先，则返回 true。
isNodeChild(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果 aNode 是此节点的子节点，则返回 true。
isNodeDescendant(DefaultMutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果 anotherNode 是此节点的后代 -- 如果它是此节点、此节点的一个子节点或此节点的一个子节点的后代，则返回 true。
isNodeRelated(DefaultMutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
当且仅当 aNode 位于与此节点相同的树中时，返回 true。
isNodeSibling(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果 anotherNode 是此节点的兄弟节点（与此节点共享同一父节点），则返回 true。
isNormalized(CharSequence, Normalizer.Form) - 类 java.text.Normalizer 中的静态方法
确定给定的 char 值序列是否被标准化。
isNotificationEnabled(Notification) - 类 javax.management.AttributeChangeNotificationFilter 中的方法
向侦听器发送指定的通知之前调用。
isNotificationEnabled(Notification) - 接口 javax.management.NotificationFilter 中的方法
向侦听器发送指定通知前调用。
isNotificationEnabled(Notification) - 类 javax.management.NotificationFilterSupport 中的方法
向侦听器发送指定的通知前调用。
isNotificationEnabled(Notification) - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
向侦听器发送指定通知之前调用。
isNotifyOnEDT() - 类 javax.swing.event.SwingPropertyChangeSupport 中的方法
返回 notifyOnEDT 属性。
isNullable(int) - 接口 java.sql.ParameterMetaData 中的方法
获取是否允许在指定参数中使用 null 值。
isNullable(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示指定列中的值是否可以为 null。
isNullable(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取指示是否可以在指定列中存储 NULL 值的常量。
ISO_2A0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS 2A0 (1189 x 1682 mm) 的 MediaType 实例。
ISO_4A0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS 4A0 ( 1682 x 2378 mm) 的 MediaType 实例。
ISO_A0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A0 (841 x 1189 mm) 的 MediaType 实例。
ISO_A0 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A0 尺寸。
ISO_A1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A1 (594 x 841 mm) 的 MediaType 实例。
ISO_A1 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A1 尺寸。
ISO_A10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A10 (26 x 37 mm) 的 MediaType 实例。
ISO_A10 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A10 尺寸。
ISO_A2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A2 (420 x 594 mm) 的 MediaType 实例。
ISO_A2 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A2 尺寸。
ISO_A3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A3 (297 x 420 mm) 的 MediaType 实例。
ISO_A3 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A3 尺寸。
ISO_A4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A4 (210 x 297 mm) 的 MediaType 实例。
ISO_A4 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A4 尺寸。
ISO_A4_TRANSPARENT - 类 javax.print.attribute.standard.MediaName 中的静态变量
A4 纸透明度。
ISO_A4_WHITE - 类 javax.print.attribute.standard.MediaName 中的静态变量
空白 A4 纸。
ISO_A5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A5 (148 x 210 mm) 的 MediaType 实例。
ISO_A5 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A5 尺寸。
ISO_A6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A6 (105 x 148 mm) 的 MediaType 实例。
ISO_A6 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A6 尺寸。
ISO_A7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A7 (74 x 105 mm) 的 MediaType 实例。
ISO_A7 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A7 尺寸。
ISO_A8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A8 (52 x 74 mm) 的 MediaType 实例。
ISO_A8 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A8 尺寸。
ISO_A9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A9 (37 x 52 mm) 的 MediaType 实例。
ISO_A9 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A9 尺寸。
ISO_B0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B0 (1000 x 1414 mm) 的 MediaType 实例。
ISO_B0 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B0 尺寸。
ISO_B1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B1 ( 707 x 1000 mm) 的 MediaType 实例。
ISO_B1 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B1 尺寸。
ISO_B10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B10 (31 x 44 mm) 的 MediaType 实例。
ISO_B10 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B10 尺寸。
ISO_B2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B2 (500 x 707 mm) 的 MediaType 实例。
ISO_B2 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B2 尺寸。
ISO_B3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B3 (353 x 500 mm) 的 MediaType 实例。
ISO_B3 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B3 尺寸。
ISO_B4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B4 (250 x 353 mm) 的 MediaType 实例。
ISO_B4 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B4 尺寸。
ISO_B4_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B4 的别名。
ISO_B5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B5 (176 x 250 mm) 的 MediaType 实例。
ISO_B5 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B5 尺寸。
ISO_B5_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B5 的别名。
ISO_B6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B6 (125 x 176 mm) 的 MediaType 实例。
ISO_B6 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B6 尺寸。
ISO_B7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B7 (88 x 125 mm) 的 MediaType 实例。
ISO_B7 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B7 尺寸。
ISO_B8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B8 (62 x 88 mm) 的 MediaType 实例。
ISO_B8 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B8 尺寸。
ISO_B9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B9 (44 x 62 mm) 的 MediaType 实例。
ISO_B9 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B9 尺寸。
ISO_C0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C0 (917 x 1297 mm) 的 MediaType 实例。
ISO_C0 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C0 尺寸。
ISO_C0_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C0 的别名。
ISO_C1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C1 (648 x 917 mm) 的 MediaType 实例。
ISO_C1 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C1 尺寸。
ISO_C10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C10 (28 x 40 mm) 的 MediaType 实例。
ISO_C10_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C10 的别名。
ISO_C1_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C1 的别名。
ISO_C2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C2 (458 x 648 mm) 的 MediaType 实例。
ISO_C2 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C2 尺寸。
ISO_C2_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C2 的别名。
ISO_C3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C3 (324 x 458 mm) 的 MediaType 实例。
ISO_C3 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C3 尺寸。
ISO_C3_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C3 的别名。
ISO_C4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C4 (229 x 324 mm) 的 MediaType 实例。
ISO_C4 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C4 尺寸。
ISO_C4_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C4 的别名。
ISO_C5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C5 (162 x 229 mm) 的 MediaType 实例。
ISO_C5 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C5 尺寸。
ISO_C5_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C5 的别名。
ISO_C6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C6 (114 x 162 mm) 的 MediaType 实例。
ISO_C6 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
信纸尺寸。
ISO_C6_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C6 的别名。
ISO_C7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C7 (81 x 114 mm) 的 MediaType 实例。
ISO_C7_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C7 的别名。
ISO_C8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C8 (57 x 81 mm) 的 MediaType 实例。
ISO_C8_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C8 的别名。
ISO_C9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C9 (40 x 57 mm) 的 MediaType 实例。
ISO_C9_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C9 的别名。
ISO_DESIGNATED_LONG - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO Designated Long (110 x 220 mm) 的 MediaType 实例。
ISO_DESIGNATED_LONG - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO designated long 尺寸。
ISO_DESIGNATED_LONG_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_DESIGNATED_LONG 的别名。
isObjectModelSupported(String) - 类 javax.xml.xpath.XPathFactory 中的方法
此 XPathFactory 是否支持指定的对象模型
isObjectMonitorUsageSupported() - 接口 java.lang.management.ThreadMXBean 中的方法
测试 Java 虚拟机是否支持使用对象监视器的监视。
isOldToken() - 类 org.ietf.jgss.MessageProp 中的方法
测试此标记是否还有效（即是否标记已经太陈旧而无法检查其复制情况）。
isOneTouchExpandable() - 类 javax.swing.JSplitPane 中的方法
获取 oneTouchExpandable 属性。
isOnKeyRelease() - 类 java.awt.AWTKeyStroke 中的方法
返回此 AWTKeyStroke 是否表示一个键释放操作。
isOpaque() - 类 java.awt.Component 中的方法
如果组件是完全不透明的，则返回 true，默认返回 false。
isOpaque() - 类 java.net.URI 中的方法
判断此 URI 是否为不透明的。
isOpaque() - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
isOpaque() - 类 javax.swing.JComponent 中的方法
如果此组件是完全不透明的，则返回 true。
isOpaque() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 中的方法
isOpaque(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
如果 region 是不透明的，则返回 true。
isOpaque() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
isOpen() - 接口 java.nio.channels.Channel 中的方法
判断此通道是否处于打开状态。
isOpen() - 类 java.nio.channels.Selector 中的方法
告知此选择器是否已打开。
isOpen() - 类 java.nio.channels.spi.AbstractInterruptibleChannel 中的方法
isOpen() - 类 java.nio.channels.spi.AbstractSelector 中的方法
isOpen() - 接口 javax.sound.midi.MidiDevice 中的方法
报告设备是否为打开状态。
isOpen() - 接口 javax.sound.sampled.Line 中的方法
指示行是否已打开，行已打开则意味着它已保留系统资源并是可操作的，尽管它当前可能没有播放或捕获声音。
isOptimizedDrawingEnabled() - 类 javax.swing.JComponent 中的方法
如果此组件平铺显示其子组件（也就是说，它可以保证子组件不重叠），则返回 true。
isOptimizedDrawingEnabled() - 类 javax.swing.JLayeredPane 中的方法
如果窗格中的组件可以重叠，则返回 false（因为这会导致最优绘制无法进行）。
isOptimizedDrawingEnabled() - 类 javax.swing.JRootPane 中的方法
glassPane 和 contentPane 具有相同的边界，这意味着 JRootPane 并不对其子级平铺，应返回 false。
isOptimizedDrawingEnabled() - 类 javax.swing.JViewport 中的方法
JViewport 重写此方法（在 JComponent 中返回 false）的默认实现。
isOrdered() - 接口 javax.naming.directory.Attribute 中的方法
确定此属性的值是否是有序的。
isOrdered() - 类 javax.naming.directory.BasicAttribute 中的方法
isOutboundDone() - 类 javax.net.ssl.SSLEngine 中的方法
返回 SSLEngine.wrap(ByteBuffer, ByteBuffer) 是否再生成更多的出站数据报文。
isOutputLocation() - 接口 javax.tools.JavaFileManager.Location 中的方法
确定此位置是否为输出位置。
isOutputLocation() - 枚举 javax.tools.StandardLocation 中的方法
isOutputShutdown() - 类 java.net.Socket 中的方法
返回是否关闭套接字连接的半写状态 (write-half)。
isOverflow() - 类 java.nio.charset.CoderResult 中的方法
通知此对象是否描述溢出情况。
isOwner(Principal) - 接口 java.security.acl.Owner 中的方法
如果给定的主体是该 ACL 的所有者，则返回 true。
isOwnReader(ImageReader) - 类 javax.imageio.spi.ImageReaderSpi 中的方法
如果传入的 ImageReader 对象为与此服务提供者关联的 ImageReader 的实例，则返回 true。
isOwnWriter(ImageWriter) - 类 javax.imageio.spi.ImageWriterSpi 中的方法
如果传入的 ImageWriter 对象是与此服务提供者关联的 ImageWriter 的实例，则返回 true。
isPageFlipping() - 类 java.awt.BufferCapabilities 中的方法
isPaintable() - 接口 java.beans.PropertyEditor 中的方法
确定此属性编辑器是否是可绘制的。
isPaintable() - 类 java.beans.PropertyEditorSupport 中的方法
确定该类是否支持 paintValue 方法。
isPaintingForPrint() - 类 javax.swing.JComponent 中的方法
如果此组件上的当前绘制操作是 print 操作的一部分，则返回 true。
isPaintingTile() - 类 javax.swing.JComponent 中的方法
如果组件当前正在绘制 tile，则返回 true。
isPalette - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的变量
isParameter() - 类 javax.swing.text.html.parser.Entity 中的方法
如果为参数实体，则返回 true。
isParent(File, File) - 类 javax.swing.filechooser.FileSystemView 中的方法
在 Windows 中，一个文件可以出现在多个文件夹，但在文件系统中的父目录中除外。
isParityAdjusted(byte[], int) - 类 javax.crypto.spec.DESedeKeySpec 中的静态方法
确定给定的始于且包含 offset 的 DES-EDE 密钥是否是奇偶校验的 (parity-adjusted)。
isParityAdjusted(byte[], int) - 类 javax.crypto.spec.DESKeySpec 中的静态方法
确定给定的始于且包含 offset 的 DES 密钥内容是否是奇偶校验的 (parity-adjusted)。
isParseBigDecimal() - 类 java.text.DecimalFormat 中的方法
返回 DecimalFormat.parse(java.lang.String, java.text.ParsePosition) 方法是否返回 BigDecimal。
isParseIntegerOnly() - 类 java.text.NumberFormat 中的方法
如果此格式只将数作为整数解析，则返回 true。
isPartialReturn() - 类 javax.swing.text.Segment 中的方法
指示部分返回有效的标记。
isPathEditable(TreePath) - 类 javax.swing.JTree 中的方法
返回 isEditable。
isPathSelected(TreePath) - 类 javax.swing.JTree 中的方法
如果当前选择了路径标识的条目，则返回 true。
isPathSelected(TreePath) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
如果当前选择了路径 path，则返回 true。
isPathSelected(TreePath) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
如果路径 path 在当前的选择中，则返回 true。
isPattern() - 类 javax.management.ObjectName 中的方法
检查该对象名是否为一个模式。
isPeriodic() - 接口 java.util.concurrent.RunnableScheduledFuture 中的方法
如果这是一个定期任务，则返回 true。
isPlain() - 类 java.awt.Font 中的方法
指示此 Font 对象的样式是否为 PLAIN。
isPointToPoint() - 类 java.net.NetworkInterface 中的方法
返回网络接口是否是点对点接口。
isPolicyMappingInhibited() - 类 java.security.cert.PKIXParameters 中的方法
检查是否禁止策略映射。
isPolygonal() - 类 java.awt.geom.Area 中的方法
测试此 Area 是否完全由直边多边形组成。
isPoolable() - 接口 java.sql.Statement 中的方法
返回指示 Statement 是否是可池化的值。
isPopupMenuVisible() - 类 javax.swing.JMenu 中的方法
如果菜单的弹出窗口可见，则返回 true。
isPopupTrigger() - 类 java.awt.event.MouseEvent 中的方法
返回此鼠标事件是否为该平台的弹出菜单触发事件。
isPopupTrigger(MouseEvent) - 类 javax.swing.JPopupMenu 中的方法
如果 JPopupMenu 的当前安装 UI 将 MouseEvent 视为弹出菜单触发器，则返回 true。
isPopupTrigger(MouseEvent) - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
isPopupTrigger(MouseEvent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 isPopupTrigger 方法。
isPopupTrigger(MouseEvent) - 类 javax.swing.plaf.PopupMenuUI 中的方法
isPopupVisible() - 类 javax.swing.JComboBox 中的方法
确定弹出窗口的可见性。
isPopupVisible(JComboBox) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
告知弹出控件是否可见。
isPopupVisible(JComboBox) - 类 javax.swing.plaf.ComboBoxUI 中的方法
确定弹出窗口的可见性
isPopupVisible(JComboBox) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 isPopupVisible 方法。
isPostdated() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是延后的。
isPreferred() - 类 java.beans.FeatureDescriptor 中的方法
"preferred" 标志用于标识呈现给用户的特别重要的特性。
isPreferredSizeSet() - 类 java.awt.Component 中的方法
如果已将首选大小设置为非 null 值，则返回 true，否则返回 false。
isPreformatted() - 类 javax.swing.text.html.HTML.Tag 中的方法
如果此标记是预格式化的，则返回 true，即如果此标记是 PRE 或 TEXTAREA，则为 true。
isPreformatted() - 类 javax.swing.text.html.parser.TagElement 中的方法
isPressed() - 接口 javax.swing.ButtonModel 中的方法
指示按钮是否已被按下。
isPressed() - 类 javax.swing.DefaultButtonModel 中的方法
指示按钮是否已被按下。
isPrimitive() - 类 java.io.ObjectStreamField 中的方法
如果此字段为基本类型，则返回 true。
isPrimitive() - 类 java.lang.Class 中的方法
判定指定的 Class 对象是否表示一个基本类型。
isPrimitive() - 枚举 javax.lang.model.type.TypeKind 中的方法
如果此种类对应于某一基本类型，则返回 true，否则返回 false。
isPrimitiveArray() - 类 javax.management.openmbean.ArrayType 中的方法
如果此开放类型描述的开放数据值是基本类型数组，则返回 true；否则返回 false。
isPrivate(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 private 修饰符，则返回 true，否则返回 false。
isProbablePrime(int) - 类 java.math.BigInteger 中的方法
如果此 BigInteger 可能为素数，则返回 true，如果它一定为合数，则返回 false。
isProcessingInstruction() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 ProcessingInstruction 的实用工具函数。
isPropagated() - 类 java.beans.beancontext.BeanContextEvent 中的方法
报告此事件是否传播自某些其他 BeanContext。
isPropertyListPattern() - 类 javax.management.ObjectName 中的方法
检查对象名是否为一个键属性列表模式。
isPropertyPattern() - 类 javax.management.ObjectName 中的方法
检查对象名是否为一个键属性模式。
isPropertySupported(String) - 类 javax.xml.stream.XMLInputFactory 中的方法
查询此工厂支持的属性集合。
isPropertySupported(String) - 类 javax.xml.stream.XMLOutputFactory 中的方法
查询此工厂支持的属性集合。
isPropertyValuePattern() - 类 javax.management.ObjectName 中的方法
检查对象名是否为值部分至少有一个键属性的模式。
isPropertyValuePattern(String) - 类 javax.management.ObjectName 中的方法
检查键属性中与值关联的值是否为一个模式。
isProtected(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 protected 修饰符，则返回 true，否则返回 false。
isProtReady() - 接口 org.ietf.jgss.GSSContext 中的方法
确定上下文是否已为要在其上使用的 per message 准备就绪。
isProxiable() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是可代理的。
isProxy() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是代理票据。
isProxyClass(Class<?>) - 类 java.lang.reflect.Proxy 中的静态方法
当且仅当指定的类通过 getProxyClass 方法或 newProxyInstance 方法动态生成为代理类时，返回 true。
isPublic(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 public 修饰符，则返回 true，否则返回 false。
isPublished() - 类 javax.xml.ws.Endpoint 中的方法
如果端点已处于发布状态，则返回 true。
isQueued(Thread) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
如果给定线程当前已加入队列，则返回 true。
isQueued(Thread) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
如果给定线程的当前已加入队列，则返回 true。
isRandomAccessEasy(int) - 类 javax.imageio.ImageReader 中的方法
如果给定图像的存储格式不会给像素的随机访问带来内在妨碍，则返回 true。
isReachable(int) - 类 java.net.InetAddress 中的方法
测试是否可以达到该地址。
isReachable(NetworkInterface, int, int) - 类 java.net.InetAddress 中的方法
测试是否可以达到该地址。
isReadable() - 类 java.nio.channels.SelectionKey 中的方法
测试此键的通道是否已准备好进行读取。
isReadable() - 类 javax.management.MBeanAttributeInfo 中的方法
该属性的值是否可读。
isReadable() - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
如果此 OpenMBeanAttributeInfo 实例描述的属性为可读的，则返回 true，否则返回 false。
isReadable() - 类 javax.management.relation.RoleInfo 中的方法
返回角色的读取访问模式（如果可读，则返回 true）。
isReadOnly() - 类 java.nio.Buffer 中的方法
告知此缓冲区是否为只读缓冲区。
isReadOnly() - 类 java.security.PermissionCollection 中的方法
如果此 PermissionCollection 对象被标记为只读，则返回 true。
isReadOnly() - 接口 java.sql.Connection 中的方法
查询此 Connection 对象是否处于只读模式。
isReadOnly() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否处于只读模式。
isReadOnly(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示指定的列是否明确不可写入。
isReadOnly() - 类 javax.imageio.metadata.IIOMetadata 中的方法
如果此对象不支持 mergeTree、setFromTree 和 reset 方法，则返回 true。
isReadOnly() - 类 javax.security.auth.Subject 中的方法
查询此 Subject 是否为只读的。
isReadOnly() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回一个指示此 RowSet 对象是否为只读的 boolean 值。
isReadOnly() - 接口 javax.sql.RowSet 中的方法
获取此 RowSet 对象是否是只读的。
isReadOnly(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示指定的列是否一定不可写入，即只读。
isRecording() - 接口 javax.sound.midi.Sequencer 中的方法
指示 Sequencer 当前是否正在录制。
isRectangleContainingRectangle(Rectangle, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
如果 a 包含 b，则返回 true。
isRectangular() - 类 java.awt.geom.Area 中的方法
测试此 Area 的形状是否为矩形。
isRedefineClassesSupported() - 接口 java.lang.instrument.Instrumentation 中的方法
返回当前 JVM 配置是否支持类的重定义。
isRegistered() - 类 java.nio.channels.SelectableChannel 中的方法
判断此通道当前是否已向任何选择器注册。
isRegistered() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
isRegistered() - 类 java.nio.charset.Charset 中的方法
通知此 charset 是否已在 IANA Charset Registry 中注册。
isRegistered(ObjectName) - 接口 javax.management.MBeanServer 中的方法
isRegistered(ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
检查某个 MBean（通过其对象名标识）是否已向 MBean 服务器注册。
isRegistered(ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
isRegistered(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
isRegistered(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
isRelation(ObjectName) - 类 javax.management.relation.RelationService 中的方法
如果已经将 MBean 作为关系添加在 Relation Service 中，则返回与给定 ObjectName 相关的关系 id。
isRelation(ObjectName) - 接口 javax.management.relation.RelationServiceMBean 中的方法
如果 Relation Service 中作为关系添加 MBean，则返回与给定 ObjectName 相关的关系 id。
isRelationMBean(String) - 类 javax.management.relation.RelationService 中的方法
如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
isRelationMBean(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
isRelative() - 类 javax.naming.NameClassPair 中的方法
确定此绑定的名称是否相对于目标上下文（由 list() 方法的第一个参数命名）。
isRemoved() - 类 java.util.prefs.AbstractPreferences 中的方法
当且仅当已经使用 AbstractPreferences.removeNode() 方法移除此节点（或其祖先）时才返回 true。
isRenewable() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是可更新的。
isRepeats() - 类 javax.swing.Timer 中的方法
如果 Timer 多次将一个动作事件发送到其侦听器，则返回 true（默认）。
isReplacing - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的变量
isRepresentationClassByteBuffer() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的表示形式类是 java.nio.ByteBuffer 还是其子类。
isRepresentationClassCharBuffer() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的表示形式类是 java.nio.CharBuffer 还是其子类。
isRepresentationClassInputStream() - 类 java.awt.datatransfer.DataFlavor 中的方法
DataFlavor 是否表示 java.io.InputStream？
isRepresentationClassReader() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的表示形式类是 java.io.Reader 还是其子类。
isRepresentationClassRemote() - 类 java.awt.datatransfer.DataFlavor 中的方法
如果表示形式类为 Remote，则返回 true。
isRepresentationClassSerializable() - 类 java.awt.datatransfer.DataFlavor 中的方法
如果表示形式类可序列化，则返回 true。
isRequestFocusEnabled() - 类 javax.swing.JComponent 中的方法
如果此 JComponent 应该获得焦点，则返回 true；否则返回 false。
isResizable() - 类 java.awt.Dialog 中的方法
指出此 dialog 是否可以由用户调整大小。
isResizable() - 类 java.awt.Frame 中的方法
指示此窗体是否可由用户调整大小。
isResizable() - 类 javax.swing.JInternalFrame 中的方法
返回是否可以通过某个用户操作调整 JInternalFrame 的大小。
isResizable - 类 javax.swing.table.TableColumn 中的变量
如果为 true，则允许用户调整列的大小；默认值为 true。
isRetransformClassesSupported() - 接口 java.lang.instrument.Instrumentation 中的方法
返回当前 JVM 配置是否支持类的重转换。
isRevocationEnabled() - 类 java.security.cert.PKIXParameters 中的方法
检查 RevocationEnabled 标志。
isRevoked(Certificate) - 类 java.security.cert.CRL 中的方法
检查给定的证书是否在此 CRL 中。
isRightMouseButton(MouseEvent) - 类 javax.swing.SwingUtilities 中的静态方法
如果鼠标事件指定右边鼠标按键，则返回 true。
isRightToLeft() - 类 java.text.Bidi 中的方法
如果该行都是从右到左的文本且基本方向也是从右到左，则返回 true。
isRoleStatus(int) - 类 javax.management.relation.RoleStatus 中的静态方法
如果给定值对应于已知角色状态，则返回 true；否则，返回 false。
isRollover() - 接口 javax.swing.ButtonModel 中的方法
指示鼠标是否在按钮上。
isRollover() - 类 javax.swing.DefaultButtonModel 中的方法
指示鼠标是否在按钮上。
isRollover() - 类 javax.swing.JToolBar 中的方法
返回 rollover 状态。
isRolloverBorders() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
返回一个标志，用于确定是否启用翻转按钮边框。
isRolloverEnabled() - 类 javax.swing.AbstractButton 中的方法
获取 rolloverEnabled 属性。
isRoot(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
确定给定文件是否是导航树中的根。
isRoot() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果此节点是树的根，则返回 true。
isRootPaneCheckingEnabled() - 类 javax.swing.JApplet 中的方法
返回是否将对 add 和 setLayout 的调用转发给 contentPane。
isRootPaneCheckingEnabled() - 类 javax.swing.JDialog 中的方法
返回是否将对 add 和 setLayout 的调用转发到 contentPane。
isRootPaneCheckingEnabled() - 类 javax.swing.JFrame 中的方法
返回是否将对 add 和 setLayout 的调用转发到 contentPane。
isRootPaneCheckingEnabled() - 类 javax.swing.JInternalFrame 中的方法
返回是否将对 add 和 setLayout 的调用转发到 contentPane。
isRootPaneCheckingEnabled() - 类 javax.swing.JWindow 中的方法
返回对 add 和 setLayout 的调用是否转发到 contentPane。
isRootVisible() - 类 javax.swing.JTree 中的方法
如果显示树的根节点，则返回 true。
isRootVisible() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
isRootVisible() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
如果显示树的根节点，则返回 true。
isRowSelected(int) - 类 javax.swing.JTable 中的方法
如果指定的索引位于行的有效范围内，并且位于该索引的行被选定，则返回 true。
isRowSelected(int) - 类 javax.swing.JTree 中的方法
如果选择了行标识的节点，则返回 true。
isRowSelected(int) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
如果选择了由 row 标识的行，则返回 true。
isRowSelected(int) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
如果选择了由 row 标识的行，则返回 true。
isRunning() - 接口 javax.sound.midi.Sequencer 中的方法
指示 Sequencer 当前是否正在运行。
isRunning() - 接口 javax.sound.sampled.DataLine 中的方法
指示该行是否正在运行。
isRunning() - 类 javax.swing.Timer 中的方法
如果 Timer 正在运行，则返回 true。
isSameFile(FileObject, FileObject) - 类 javax.tools.ForwardingJavaFileManager 中的方法
isSameFile(FileObject, FileObject) - 接口 javax.tools.JavaFileManager 中的方法
比较两个文件对象，如果它们表示相同的底层对象，则返回 true。
isSameFile(FileObject, FileObject) - 接口 javax.tools.StandardJavaFileManager 中的方法
比较两个文件对象，如果它们表示相同的规范文件、zip 文件条目或者基于任何文件系统的容器中的条目，则返回 true。
isSameNode(Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
isSameNode(Node) - 接口 org.w3c.dom.Node 中的方法
返回此节点是否是与给定节点相同的节点。
isSameRM(XAResource) - 接口 javax.transaction.xa.XAResource 中的方法
调用此方法，以确定目标对象表示的资源管理器实例是否与参数 xares 表示的资源管理器实例相同。
isSameType(TypeMirror, TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
测试两个 TypeMirror 对象是否表示同一类型。
isSchemaLanguageSupported(String) - 类 javax.xml.validation.SchemaFactory 中的方法
此 SchemaFactory 支持指定的模式吗？
isSealed() - 类 java.lang.Package 中的方法
如果此包是密封的，则返回 ture。
isSealed(URL) - 类 java.lang.Package 中的方法
如果此包对于指定的代码源 url 是密封的，则返回 ture。
isSearchable(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示是否可以在 where 子句中使用指定的列。
isSearchable(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示是否可以在 WHERE 子句中使用存储在指定列中的值。
isSeekForwardOnly() - 类 javax.imageio.ImageReader 中的方法
如果已经通过传递 true 作为 setInput 方法的 seekForwardOnly 参数将当前输入源标记为只向前搜索，则返回 true。
isSelected() - 类 java.awt.im.InputMethodHighlight 中的方法
返回是否已选定文本范围。
isSelected(int) - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 isIndexSelected(int) 取代。
isSelected() - 类 javax.swing.AbstractButton 中的方法
返回按钮的状态。
isSelected(ButtonModel) - 类 javax.swing.ButtonGroup 中的方法
返回对是否已选择一个 ButtonModel 的判断。
isSelected() - 接口 javax.swing.ButtonModel 中的方法
指示按钮是否已经被选择。
isSelected() - 类 javax.swing.DefaultButtonModel 中的方法
指示按钮是否已经被选择。
isSelected() - 类 javax.swing.DefaultSingleSelectionModel 中的方法
isSelected - 类 javax.swing.JInternalFrame 中的变量
当前已选中窗体。
isSelected() - 类 javax.swing.JInternalFrame 中的方法
返回 JInternalFrame 当前是否为“选定的”或处于激活状态的窗体。
isSelected() - 类 javax.swing.JMenu 中的方法
如果菜单是当前选择的（即高亮显示的）菜单，则返回 true。
isSelected() - 类 javax.swing.JMenuBar 中的方法
如果当前已选择了菜单栏的组件，则返回 true。
isSelected() - 类 javax.swing.JToggleButton.ToggleButtonModel 中的方法
检查按钮是否是选定的。
isSelected - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 中的变量
isSelected() - 接口 javax.swing.SingleSelectionModel 中的方法
如果选项模型当前有一个选定的值，则返回 true。
isSelected() - 类 javax.swing.text.html.Option 中的方法
获取与此选项相关的选定状态。
isSelectedIndex(int) - 类 javax.swing.DefaultListSelectionModel 中的方法
如果选择了指定的索引，则返回 true。
isSelectedIndex(int) - 类 javax.swing.JList 中的方法
如果选择了指定的索引，则返回 true；否则返回 false。
isSelectedIndex(int) - 接口 javax.swing.ListSelectionModel 中的方法
如果选择了指定的索引，则返回 true。
isSelectionEmpty() - 类 javax.swing.DefaultListSelectionModel 中的方法
如果没有选择索引，则返回 true。
isSelectionEmpty() - 类 javax.swing.JList 中的方法
如果什么也没有选择，则返回 true；否则返回 false。
isSelectionEmpty() - 类 javax.swing.JTree 中的方法
如果该选择当前为空，则返回 true。
isSelectionEmpty() - 接口 javax.swing.ListSelectionModel 中的方法
如果没有选择索引，则返回 true。
isSelectionEmpty() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
如果 selection 当前为空，则返回 true。
isSelectionEmpty() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
如果选择当前为空，则返回 true。
isSelectionVisible() - 接口 javax.swing.text.Caret 中的方法
确定选定项当前是否可见。
isSelectionVisible() - 类 javax.swing.text.DefaultCaret 中的方法
检查当前选定是否可见。
isSerializing() - 类 java.beans.beancontext.BeanContextSupport 中的方法
此 BeanContext 正处于序列化过程中吗？
isServiceClass(Class) - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 中的方法
检查此事件，以确定将被取消的服务是否属于某个特定类。
isSet - 类 java.util.Calendar 中的变量
通知是否设置了该日历某一指定日历字段的标志。
isSet(int) - 类 java.util.Calendar 中的方法
确定给定日历字段是否已经设置了一个值，其中包括因为调用 get 方法触发内部字段计算而导致已经设置该值的情况。
isSet(DatatypeConstants.Field) - 类 javax.xml.datatype.Duration 中的方法
检查是否设置了字段。
isShared() - 类 java.nio.channels.FileLock 中的方法
判断此锁定是否为共享的。
isShiftDown() - 类 java.awt.event.InputEvent 中的方法
返回 Shift 修饰符在此事件上是否为 down。
isShorterThan(Duration) - 类 javax.xml.datatype.Duration 中的方法
检查此持续时间对象是否严格短于另一个 Duration 对象。
isShowing() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
确定是否正在显示该对象。
isShowing() - 类 java.awt.Component 中的方法
确定此组件是否在屏幕上显示。
isShowing() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
确定是否正显示对象。
isShowing() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
确定该对象是否正在显示。
isShowing() - 类 java.awt.Window 中的方法
检查此窗口是否显示在屏幕上。
isShowing() - 接口 javax.accessibility.AccessibleComponent 中的方法
确定是否正显示对象。
isShowing() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
isShowing() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
确定该对象是否正在显示。
isShowing() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
isShowing() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
isShutdown() - 接口 java.util.concurrent.ExecutorService 中的方法
如果此执行程序已关闭，则返回 true。
isShutdown() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
isSigned(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的值是否可以是带符号的数字。
isSigned(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示指定列中的值是否带正负号。
isSigned(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示存储在指定列中的值是否为有符号数。
isSignificant() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
DefaultDocument 事件是有意义的。
isSignificant() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
此默认实现返回 true。
isSignificant() - 类 javax.swing.undo.CompoundEdit 中的方法
如果 edits 中的任何 UndoableEdit 返回 true，则返回 true。
isSignificant() - 接口 javax.swing.undo.UndoableEdit 中的方法
如果认为此编辑有效，则返回 true。
isSingular() - 类 java.awt.geom.Area 中的方法
测试此 Area 是否由单个封闭子路径组成。
isSiteLocalAddress() - 类 java.net.Inet4Address 中的方法
检查 InetAddress 是否是站点本地地址的实用例行程序。
isSiteLocalAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否是站点本地地址的实用例行程序。
isSiteLocalAddress() - 类 java.net.InetAddress 中的方法
检查 InetAddress 是否是站点本地地址的实用例行程序。
isSortable(int) - 类 javax.swing.DefaultRowSorter 中的方法
如果指定的列可排序，则返回 true；否则返回 false。
isSorted() - 类 javax.naming.ldap.SortResponseControl 中的方法
确定是否已成功排序搜索结果。
isSoundbankSupported(Soundbank) - 接口 javax.sound.midi.Synthesizer 中的方法
通知调用者此合成器是否能够从指定的音库加载乐器。
isSource() - 类 javax.sound.sampled.Port.Info 中的方法
指示端口是其混频器的源还是目标。
isSourceEncodingSupported(AudioFormat.Encoding) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
指示格式转换器是否支持从指定源格式编码的转换。
isSpace(char) - 类 java.lang.Character 中的静态方法
已过时。 由 isWhitespace(char) 取代。
isSpaceChar(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为 Unicode 空白字符。
isSpaceChar(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为 Unicode 空白字符。
isSpecified() - 接口 javax.xml.stream.events.Attribute 中的方法
一个标志，用于指示此属性实际上是在其元素的开始标记中指定的，还是在模式中默认指定的。
isSpecified(int) - 类 javax.xml.validation.TypeInfoProvider 中的方法
如果属性是通过验证器添加的，则返回 false。
isSpecified(int) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 true，除非 DTD 默认提供属性值。
isSpecified(String, String) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 true，除非由 DTD 默认提供属性值。
isSpecified(String) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 true，除非由 DTD 默认提供属性值。
isSpecified(int) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“指定的”标志的当前值。
isSpecified(String, String) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“指定的”标志的当前值。
isSpecified(String) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“指定的”标志的当前值。
isStandalone() - 接口 javax.xml.stream.events.StartDocument 中的方法
如果此 XML 是独立的，则返回 true。
isStandalone() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isStandalone() - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取 xml 声明中的独立声明
isStandard() - 类 java.awt.font.GlyphMetrics 中的方法
如果这是一个标准字形，则返回 true。
isStandardImageMetadataFormatSupported() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
如果标准元数据格式为此插件生成或使用的图像元数据对象的 getAsTree 和 setFromTree 方法可识别的文档格式之一，则返回 true。
isStandardMetadataFormatSupported() - 类 javax.imageio.metadata.IIOMetadata 中的方法
如果 getMetadataFormat、getAsTree、setFromTree 和 mergeTree 支持标准元数据格式，则返回 true。
isStandardStreamMetadataFormatSupported() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
如果标准元数据格式是此插件生成或使用的流元数据对象的 getAsTree 和 setFromTree 方法能够识别的文档格式之一，则返回 true。
isStartDocument() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 StartDocument 的实用工具函数。
isStartElement() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 StartElement 的实用工具函数。
isStartElement() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isStartElement() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果光标指向开始标记，则返回 true（否则返回 false）
isStatic(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 static 修饰符，则返回 true，否则返回 false。
isStrict(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 strictfp 修饰符，则返回 true，否则返回 false。
isStrikeThrough() - 类 javax.swing.text.GlyphView 中的方法
确定字形是否应该有删除线。
isStrikeThrough() - 类 javax.swing.text.LabelView 中的方法
确定字形是否应该有删除线。
isStrikeThrough(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了删除线属性。
isStringPainted() - 类 javax.swing.JProgressBar 中的方法
返回 stringPainted 属性的值。
isSubregion() - 类 javax.swing.plaf.synth.Region 中的方法
如果 Region 是 Component 的子 region，则返回 true，否则返回 false。
isSubscript() - 类 javax.swing.text.GlyphView 中的方法
确定字形是否应该呈现为上标。
isSubscript() - 类 javax.swing.text.LabelView 中的方法
确定字形是否应该呈现为上标。
isSubscript(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了下标属性。
isSubsignature(ExecutableType, ExecutableType) - 接口 javax.lang.model.util.Types 中的方法
测试一个方法的签名是否是另一个方法的子签名。
isSubtype(TypeMirror, TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
测试一种类型是否是另一个类型的子类型。
isSuperscript() - 类 javax.swing.text.GlyphView 中的方法
确定字形是否应该呈现为下标。
isSuperscript() - 类 javax.swing.text.LabelView 中的方法
确定字形是否应该呈现为下标。
isSuperscript(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了上标属性。
isSupplementaryCodePoint(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否在增补字符范围内。
isSupported(Desktop.Action) - 类 java.awt.Desktop 中的方法
测试当前平台是否支持某一动作。
isSupported() - 类 java.awt.SystemTray 中的静态方法
返回当前平台是否支持系统托盘。
isSupported(String) - 类 java.nio.charset.Charset 中的静态方法
通知是否支持指定的 charset。
isSupported(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回 false，因为不支持 DOM 功能。
isSupported(String, String) - 接口 org.w3c.dom.Node 中的方法
测试 DOM 实现是否实现特定功能，且该功能是否受此节点支持，如下所述。
isSupportedLookAndFeel() - 类 javax.swing.LookAndFeel 中的方法
如果底层平台支持和/或允许此外观，则返回 true。
isSupportedLookAndFeel() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回 true；可以在任意平台上运行 MetalLookAndFeel。
isSupportedLookAndFeel() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
返回 true；所有平台都允许此外观。
isSupportedLookAndFeel() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回 true，SynthLookAndFeel 总是受支持。
isSupportedOption(String) - 类 javax.tools.ForwardingJavaFileManager 中的方法
isSupportedOption(String) - 接口 javax.tools.OptionChecker 中的方法
确定是否支持给定选项，如果支持，则返回该选项所使用的参数数量。
isSurrogatePair(char, char) - 类 java.lang.Character 中的静态方法
确定指定的 char 值对是否为有效的代理项对。
isSuspended() - 类 java.lang.management.ThreadInfo 中的方法
测试与此 ThreadInfo 关联的线程是否被挂起。
isSynchronizationSupported(Line[], boolean) - 接口 javax.sound.sampled.Mixer 中的方法
报告此混频器是否支持指定行集合的同步。
isSynchronized(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 synchronized 修饰符，则返回 true，否则返回 false。
isSynchronizerUsageSupported() - 接口 java.lang.management.ThreadMXBean 中的方法
测试 Java 虚拟机是否支持使用 可拥有同步器的监视。
isSynthetic() - 类 java.lang.Class 中的方法
如果此类是复合类，则返回 true，否则 false。
isSynthetic() - 类 java.lang.reflect.Constructor 中的方法
如果此构造方法是一个复合构造方法，则返回 true；否则返回 false。
isSynthetic() - 类 java.lang.reflect.Field 中的方法
如果此字段是复合字段，则返回 true；否则返回 false。
isSynthetic() - 接口 java.lang.reflect.Member 中的方法
如果此成员是编译器引入的，则返回 true；否则，返回 false。
isSynthetic() - 类 java.lang.reflect.Method 中的方法
如果此方法为复合方法，则返回 true；否则，返回 false。
isTargetEncodingSupported(AudioFormat.Encoding) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
指示格式转换器是否支持到指定目标格式编码的转换。
isTearOff() - 类 java.awt.Menu 中的方法
指示此菜单是否为分离式菜单。
isTearOff() - 类 javax.swing.JMenu 中的方法
如果此菜单是分离式的，则返回 true。
isTemporary() - 类 java.awt.event.FocusEvent 中的方法
将焦点更改事件标识为暂时性的或持久性的。
isTerminated() - 接口 java.util.concurrent.ExecutorService 中的方法
如果关闭后所有任务都已完成，则返回 true。
isTerminated() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
isTerminating() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
如果此执行程序处于在 shutdown 或 shutdownNow 之后正在终止但尚未完全终止的过程中，则返回 true。
isText(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
如果元素是文本元素，则返回 true。
isThreadContentionMonitoringEnabled() - 接口 java.lang.management.ThreadMXBean 中的方法
测试是否启用了线程争用监视。
isThreadContentionMonitoringSupported() - 接口 java.lang.management.ThreadMXBean 中的方法
测试 Java 虚拟机是否支持线程争用监视。
isThreadCpuTimeEnabled() - 接口 java.lang.management.ThreadMXBean 中的方法
测试是否启用了线程 CPU 时间测量。
isThreadCpuTimeSupported() - 接口 java.lang.management.ThreadMXBean 中的方法
测试 Java 虚拟机实现是否支持任何线程的 CPU 时间测量。
isThumbRollover() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
如果鼠标当前位于 thumb 上，则返回 true。
isTileWritable(int, int) - 类 java.awt.image.BufferedImage 中的方法
返回当前是否为写入签出 tile。
isTileWritable(int, int) - 接口 java.awt.image.WritableRenderedImage 中的方法
返回当前是否正在为写入签出 tile。
isTimeSet - 类 java.util.Calendar 中的变量
如果 time 值是一个有效值，则返回 true。
isTitleCase(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为首字母大写字符。
isTitleCase(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为首字母大写字符。
isToggleEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回 true 指示应该基于事件切换鼠标下的行。
isToggleSelectionEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回 true 表示节点上的鼠标事件应该仅切换鼠标下的行的选择。
isTopDown() - 类 javax.imageio.plugins.bmp.BMPImageWriteParam 中的方法
返回 topDown 参数的值。
isTopLevelMenu() - 类 javax.swing.JMenu 中的方法
如果菜单是“顶层菜单”（即菜单栏的直接子级），则返回 true。
isTransferable() - 接口 org.ietf.jgss.GSSContext 中的方法
确定通过使用 export 方法，该上下文是否可以传输给其他进程。
isTransformed() - 类 java.awt.font.FontRenderContext 中的方法
指示此 FontRenderContext 对象是否需要考虑已转换的呈现上下文中的文本。
isTransformed() - 类 java.awt.Font 中的方法
指示此 Font 对象是否具有影响其大小以及 Size 属性的变换。
isTransient(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 transient 修饰符，则返回 true，否则返回 false。
isTraversable(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
如果可以访问文件（目录），则返回 true。
isTraversable(File) - 类 javax.swing.filechooser.FileView 中的方法
目录是否是可遍历的。
isTraversable(File) - 类 javax.swing.JFileChooser 中的方法
如果可以返回该文件（目录），则返回 true。
IstringHelper - org.omg.CosNaming 中的 类
org/omg/CosNaming/IstringHelper.java。
IstringHelper() - 类 org.omg.CosNaming.IstringHelper 的构造方法
isTrueVolatile() - 类 java.awt.ImageCapabilities 中的方法
如果由此 ImageCapabilities 描述的 VolatileImage 可以丢失其图面，则返回 true。
isTypeSubstituted() - 类 javax.xml.bind.JAXBElement 中的方法
如果此 xml 元素实例的值的类型与 xml 元素声明的声明类型不同，则返回 true。
isUndecorated() - 类 java.awt.Dialog 中的方法
指出此 dialog 是否未装饰。
isUndecorated() - 类 java.awt.Frame 中的方法
指示此窗体是否未装饰。
isUnderflow() - 类 java.nio.charset.CoderResult 中的方法
通知此对象是否描述下溢情况。
isUnderline() - 类 javax.swing.text.GlyphView 中的方法
确定字形是否应加下划线。
isUnderline() - 类 javax.swing.text.LabelView 中的方法
确定字形是否应加下划线。
isUnderline(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了下划线属性。
isUnicast() - 类 java.beans.EventSetDescriptor 中的方法
通常事件源是多播的。
isUnicodeIdentifierPart(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否可以是 Unicode 标识符中首字符以外的部分。
isUnicodeIdentifierPart(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否可以是 Unicode 标识符中首字符以外的部分。
isUnicodeIdentifierStart(char) - 类 java.lang.Character 中的静态方法
确定是否允许将指定字符作为 Unicode 标识符中的首字符。
isUnicodeIdentifierStart(int) - 类 java.lang.Character 中的静态方法
确定是否允许将指定字符（Unicode 代码点）作为 Unicode 标识符中的首字符。
isUnique() - 类 java.rmi.dgc.VMID 中的静态方法
已过时。
isUnmappable() - 类 java.nio.charset.CoderResult 中的方法
通知此对象是否描述不可映射的字符错误。
isUnnamed() - 接口 javax.lang.model.element.PackageElement 中的方法
如果此包是一个未命名的包，则返回 true，否则返回 false。
isUnresolved() - 类 java.net.InetSocketAddress 中的方法
检查是否已解析地址。
isUnseqToken() - 类 org.ietf.jgss.MessageProp 中的方法
测试后面的标记是否已进行处理。
isUnshared() - 类 java.io.ObjectStreamField 中的方法
返回一个 boolean 值，指示由 ObjectStreamField 实例所表示的可序列化字段是否未共享。
isUp() - 类 java.net.NetworkInterface 中的方法
返回网络接口是否已经开启并运行。
isUpperCase(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为大写字母。
isUpperCase(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为大写字母。
isUsageThresholdExceeded() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
测试此内存池的使用量是否达到或超过其使用量阈值。
isUsageThresholdSupported() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
测试此内存池是否支持使用量阈值。
isUserInRole(String) - 接口 javax.xml.ws.WebServiceContext 中的方法
返回一个布尔值，指示指定的逻辑角色中是否包含经过验证的用户。
isUserNode() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.isUserNode() 中的规范实现 isUserNode 方法。
isUserNode() - 类 java.util.prefs.Preferences 中的方法
如果此首选项节点位于用户首选项树中，则返回 true；如果其位于系统首选项树中，则返回 false。
isValid() - 类 java.awt.Component 中的方法
确定组件是否有效。
isValid(int) - 类 java.awt.image.IndexColorModel 中的方法
返回像素是否有效。
isValid() - 类 java.awt.image.IndexColorModel 中的方法
返回所有像素是否有效。
isValid() - 接口 java.lang.management.MemoryManagerMXBean 中的方法
测试此内存管理器在 Java 虚拟机中是否有效。
isValid() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
测试此内存池在 Java 虚拟机中是否有效。
isValid() - 类 java.nio.channels.FileLock 中的方法
判断此锁定是否有效。
isValid() - 类 java.nio.channels.SelectionKey 中的方法
告知此键是否有效。
isValid() - 类 java.nio.channels.spi.AbstractSelectionKey 中的方法
isValid(int) - 接口 java.sql.Connection 中的方法
如果连接尚未关闭并且仍然有效，则返回 true。
isValid() - 类 javax.accessibility.AccessibleHyperlink 中的方法
因为与某个链接相关联的文档可能已更改，所以此方法返回此 Link 是否仍然有效（关于它所引用的文档是否有效）的信息。
isValid() - 接口 javax.management.Descriptor 中的方法
如果所有字段在给定其名称的情况下都有合法值，则返回 true。
isValid() - 类 javax.management.ImmutableDescriptor 中的方法
如果所有字段在给定其名称的情况下都有合法值，则返回 true。
isValid() - 类 javax.management.modelmbean.DescriptorSupport 中的方法
如果所有给定名称的字段都有合法值，则返回 true。
isValid() - 接口 javax.net.ssl.SSLSession 中的方法
返回此会话对于恢复和加入是否是有效的和可用的。
isValid() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
因为与某个链接相关联的文档可能已改变，所以此方法返回此 Link 是否仍然有效（关于它所引用的文档是否有效）。
isValid() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
如果拖动会话有效，则返回 true。
isValid() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
指示当前迭代器是否正在表示出现的标记。
isValid() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
通过 getXMLSchemaType() 约束来验证实例。
isValidateRoot() - 类 javax.swing.JComponent 中的方法
如果此方法返回 true，则此组件的子代调用 revalidate 将导致从此根开始对整棵树进行验证。
isValidateRoot() - 类 javax.swing.JRootPane 中的方法
如果此 JRootPane 的一个后代调用 revalidate，将从此位置开始进行验证。
isValidateRoot() - 类 javax.swing.JScrollPane 中的方法
重写以返回 true，这样任何在此 JScrollPane 的任何后代上对 revalidate 的调用将使从此 JScrollPane 开始的整个树接受验证。
isValidateRoot() - 类 javax.swing.JSplitPane 中的方法
如果返回 true，则在此 JSplitPane 的任何后代上调用 revalidate，将导致在队列中加入一个验证 JSplitPane 及其所有后代的一个请求。
isValidateRoot() - 类 javax.swing.JTextField 中的方法
调用来自文本字段本身的 revalidate，将通过验证文本字段来处理，如果文本字段不包含在 JViewport 中，则在这种情况下将返回 false。
isValidating() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
指示 Unmarshaller 是否被配置为在执行解组操作期间进行验证。
isValidating() - 接口 javax.xml.bind.Unmarshaller 中的方法
已过时。 从 JAXB 2.0 开始，请参阅 Unmarshaller.getSchema()
isValidating() - 类 javax.xml.parsers.DocumentBuilder 中的方法
指示此解析器是否被配置为验证 XML 文档。
isValidating() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成解析器，该解析器在解析时验证 XML 内容。
isValidating() - 类 javax.xml.parsers.SAXParser 中的方法
指示此解析器是否被配置为验证 XML 文档。
isValidating() - 类 javax.xml.parsers.SAXParserFactory 中的方法
指示是否将工厂配置为生成解析器，该解析器在解析时验证 XML 内容。
isValidCodePoint(int) - 类 java.lang.Character 中的静态方法
确定指定的代码点是否为从 0x0000 到 0x10FFFF 范围之内的有效 Unicode 代码点值。
isValue(Object) - 类 javax.management.openmbean.ArrayType 中的方法
测试 obj 是否为此 ArrayType 实例的值。
isValue(Object) - 类 javax.management.openmbean.CompositeType 中的方法
测试 obj 是否为此 CompositeType 实例可以描述的值。
isValue(Object) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
测试 obj 是否为此 OpenMBeanAttributeInfoSupport 实例描述的属性的有效值。
isValue(Object) - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。
isValue(Object) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。
isValue(Object) - 类 javax.management.openmbean.OpenType 中的方法
测试 obj 是否为此开放类型的值。
isValue(Object) - 类 javax.management.openmbean.SimpleType 中的方法
测试 obj 是否为此 SimpleType 实例的值。
isValue(Object) - 类 javax.management.openmbean.TabularType 中的方法
测试 obj 是否为此 TabularType 实例可以描述的值。
isVarArgs() - 类 java.lang.reflect.Constructor 中的方法
如果声明此构造方法可以带可变数量的参数，则返回 true；否则返回 false。
isVarArgs() - 类 java.lang.reflect.Method 中的方法
如果将此方法声明为带有可变数量的参数，则返回 true；否则，返回 false。
isVarArgs() - 接口 javax.lang.model.element.ExecutableElement 中的方法
如果此方法或构造方法接受可变数量的参数，则返回 true，否则返回 false。
isVerbose() - 接口 java.lang.management.ClassLoadingMXBean 中的方法
测试是否已为类加载系统启用了 verbose 输出。
isVerbose() - 接口 java.lang.management.MemoryMXBean 中的方法
测试内存系统的 verbose 输出是否已启用。
isVertical() - 类 java.awt.font.TextLayout 中的方法
如果此 TextLayout 是垂直的，则返回 true。
isViewSizeSet - 类 javax.swing.JViewport 中的变量
在确定视口的维数后为 true。
isVirtual() - 类 java.net.NetworkInterface 中的方法
返回此接口是否是虚拟接口（也称为子接口）。
isVisible() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
确定对象是否可见。
isVisible() - 类 java.awt.Component 中的方法
确定此组件在其父容器可见时是否应该可见。
isVisible() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
确定对象是否可见。
isVisible() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
确定该对象是否可见。
isVisible() - 类 java.awt.SplashScreen 中的方法
确定闪现屏幕是否可见。
isVisible() - 接口 javax.accessibility.AccessibleComponent 中的方法
确定此对象是否可见。
isVisible() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
isVisible() - 类 javax.swing.JPopupMenu 中的方法
如果弹出菜单可见（当前显示的），则返回 true。
isVisible() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
确定该对象是否可见。
isVisible() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
isVisible(TreePath) - 类 javax.swing.JTree 中的方法
如果当前可查看路径标识的值，则返回 true，这意味着该路径或者是根路径，或者它的所有父路径均被展开。
isVisible() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
如果弹出菜单可见（当前显示的），则返回 true。
isVisible() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
isVisible() - 接口 javax.swing.text.Caret 中的方法
确定插入符当前是否可见。
isVisible() - 类 javax.swing.text.DefaultCaret 中的方法
指示插入符当前是否可见。
isVisible() - 类 javax.swing.text.html.ParagraphView 中的方法
指示是否应显示此视图。
isVisible() - 类 javax.swing.text.View 中的方法
返回一个指示视图是否可视的 boolean 值。
isVolatile(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 volatile 修饰符，则返回 true，否则返回 false。
isWeak(byte[], int) - 类 javax.crypto.spec.DESKeySpec 中的静态方法
确定给定的 DES 密钥内容是否是全弱或者半弱的。
isWheelScrollingEnabled() - 类 java.awt.ScrollPane 中的方法
指示是否进行滚动来响应鼠标滚轮。
isWheelScrollingEnabled() - 类 javax.swing.JScrollPane 中的方法
指示是否进行滚动以响应鼠标滚轮。
isWhitespace() - 类 java.awt.font.GlyphMetrics 中的方法
如果这是一个空白字形，则返回 true。
isWhitespace(char) - 类 java.lang.Character 中的静态方法
确定指定字符依据 Java 标准是否为空白字符。
isWhitespace(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）依据 Java 标准是否为空白字符。
isWhiteSpace(char) - 类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 中的静态方法
如果指定的 char 是空白字符，则返回 true。
isWhiteSpace() - 接口 javax.xml.stream.events.Characters 中的方法
如果此 Characters 集合中都是空格，则返回 true。
isWhiteSpace() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isWhiteSpace() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果光标指向由所有空格组成的字符数据事件，则返回 true
isWhiteSpaceExceptSpace(char) - 类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 中的静态方法
如果指定的 char 是空白字符但不是 0x20，则返回 true。
isWrapperFor(Class<?>) - 接口 java.sql.Wrapper 中的方法
如果调用此方法的对象实现接口参数，或者是实现接口参数的对象的直接或间接包装器，则返回 true。
isWrapperFor(Class<?>) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
如果调用者实现接口参数或者是实现接口参数的对象的直接或间接包装器，则返回 true。
isWritable() - 类 java.nio.channels.SelectionKey 中的方法
测试此键的通道是否已准备好进行写入。
isWritable(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示在指定的列上进行写操作是否可以获得成功。
isWritable() - 类 javax.management.MBeanAttributeInfo 中的方法
是否可将新值写入该属性。
isWritable() - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
如果此 OpenMBeanAttributeInfo 实例描述的属性是可写的，则返回 true，否则返回 false。
isWritable() - 类 javax.management.relation.RoleInfo 中的方法
返回角色的写入访问模式（如果可写，则返回 true）。
isWritable(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示在指定的列上进行写操作是否可以获得成功。
isWriteLocked() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询是否某个线程保持了写入锁。
isWriteLockedByCurrentThread() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询当前线程是否保持了写入锁。
isXIncludeAware() - 类 javax.xml.parsers.DocumentBuilder 中的方法
获取此解析器的 XInclude 处理模式。
isXIncludeAware() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
获取 XInclude 处理的状态。
isXIncludeAware() - 类 javax.xml.parsers.SAXParser 中的方法
获取此解析器的 XInclude 处理模式。
isXIncludeAware() - 类 javax.xml.parsers.SAXParserFactory 中的方法
获取 XInclude 处理的状态。
isXOPPackage() - 类 javax.xml.bind.attachment.AttachmentMarshaller 中的方法
只读属性，如果 JAXB 编组器应该启用 XOP 创建，则返回 true。
isXOPPackage() - 类 javax.xml.bind.attachment.AttachmentUnmarshaller 中的方法
只读属性，如果 JAXB 解组程序需要执行 XOP 处理，则返回 true。
isZoneLoaded(View) - 类 javax.swing.text.ZoneView 中的方法
确定某个分区是否处于加载状态。
ITALIAN - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
ITALIC - 类 java.awt.Font 中的静态变量
斜体样式常量。
Italic - 类 javax.swing.text.StyleConstants 中的静态变量
斜体属性的名称。
ITALIC_ACTION - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
斜体动作标识符
ITALY - 类 java.awt.PageAttributes.MediaType 中的静态变量
ITALY_ENVELOPE 的别名。
ITALY - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
ITALY_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
Italy Envelope (110 x 230 mm) 的 MediaType 实例。
ITALY_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 Italy 信封尺寸，110 mm × 230 mm。
ITALY_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
Italy 信封尺寸。
item(int) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
item(int) - 类 org.omg.CORBA.ContextList 中的方法
返回位于给定索引的 String 对象。
item(int) - 类 org.omg.CORBA.ExceptionList 中的方法
返回给定索引处的 TypeCode 对象。
item(int) - 类 org.omg.CORBA.NVList 中的方法
检索给定索引处的 NamedValue 对象。
item(int) - 接口 org.w3c.dom.DOMImplementationList 中的方法
返回集合中的第 index 个项。
item(int) - 接口 org.w3c.dom.DOMStringList 中的方法
返回集合中的第 index 个项。
item(int) - 接口 org.w3c.dom.NamedNodeMap 中的方法
返回映射中第 index 个项。
item(int) - 接口 org.w3c.dom.NodeList 中的方法
返回集合中的第 index 个项。
ITEM_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择项事件的事件掩码。
ITEM_FIRST - 类 java.awt.event.ItemEvent 中的静态变量
项事件使用的 id 范围内的起始编号。
ITEM_LAST - 类 java.awt.event.ItemEvent 中的静态变量
项事件使用的 id 范围内的结束编号。
ITEM_STATE_CHANGED - 类 java.awt.event.ItemEvent 中的静态变量
此事件 id 指示项状态已更改。
ItemEvent - java.awt.event 中的 类
指示项被选定或取消选定的语义事件。
ItemEvent(ItemSelectable, int, Object, int) - 类 java.awt.event.ItemEvent 的构造方法
构造一个 ItemEvent 对象。
ItemListener - java.awt.event 中的 接口
接收项事件的侦听器接口。
itemListener - 类 javax.swing.AbstractButton 中的变量
按钮模型的 ItemListener。
itemListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
itemListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
ItemSelectable - java.awt 中的 接口
包含零个或多个可选则项的集合的对象接口。
itemStateChanged(ItemEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 itemStateChanged 方法处理 itemStateChanged 事件。
itemStateChanged(ItemEvent) - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
当切换按钮的状态变化时，激发可访问的属性更改事件。
itemStateChanged(ItemEvent) - 接口 java.awt.event.ItemListener 中的方法
在用户已选定或取消选定某项时调用。
itemStateChanged(ItemEvent) - 类 java.awt.List.AccessibleAWTList 中的方法
itemStateChanged(ItemEvent) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
在项的状态发生更改时，编辑被终止。
itemStateChanged(ItemEvent) - 类 javax.swing.JToggleButton.AccessibleJToggleButton 中的方法
当切换按钮的状态变化时，激发可访问的属性变更事件。
itemStateChanged(ItemEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler 中的方法
itemStateChanged(ItemEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ItemHandler 中的方法
Iterable<T> - java.lang 中的 接口
实现这个接口允许对象成为 "foreach" 语句的目标。
iterator() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回组成动作的事件 Iterator。
iterator() - 类 java.beans.beancontext.BeanContextMembershipEvent 中的方法
获得受此事件影响的子级的数组。
iterator() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。
iterator() - 接口 java.lang.Iterable 中的方法
返回一个在一组 T 类型的元素上进行迭代的迭代器。
iterator() - 异常 java.sql.SQLException 中的方法
返回在链接的 SQLExceptions 上进行迭代的迭代器。
iterator() - 类 java.util.AbstractCollection 中的方法
返回在此 collection 中的元素上进行迭代的迭代器。
iterator() - 类 java.util.AbstractList 中的方法
返回以恰当顺序在此列表的元素上进行迭代的迭代器。
iterator() - 类 java.util.AbstractSequentialList 中的方法
返回在此列表中的元素上进行迭代的迭代器（按适当顺序）。
iterator() - 类 java.util.ArrayDeque 中的方法
返回在此双端队列的元素上进行迭代的迭代器。
iterator() - 接口 java.util.Collection 中的方法
返回在此 collection 的元素上进行迭代的迭代器。
iterator() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
返回在此队列中的元素上按适当顺序进行迭代的迭代器。
iterator() - 接口 java.util.concurrent.BlockingDeque 中的方法
返回在此双端队列中的元素上以恰当顺序进行迭代的迭代器。
iterator() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
返回在此队列元素上以恰当顺序进行迭代的迭代器。
iterator() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
返回在此 set 的元素上以升序进行迭代的迭代器。
iterator() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回以恰当顺序在此列表元素上进行迭代的迭代器。
iterator() - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
返回按照元素添加顺序在此 set 中包含的元素上进行迭代的迭代器。
iterator() - 类 java.util.concurrent.DelayQueue 中的方法
返回在此队列所有元素（既包括到期的，也包括未到期的）上进行迭代的迭代器。
iterator() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回在此双端队列元素上以恰当顺序进行迭代的迭代器。
iterator() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
返回在队列中的元素上按适当顺序进行迭代的迭代器。
iterator() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
返回在此队列元素上进行迭代的迭代器。
iterator() - 类 java.util.concurrent.SynchronousQueue 中的方法
返回一个空迭代器，其中 hasNext 始终返回 false。
iterator() - 接口 java.util.Deque 中的方法
返回以恰当顺序在此双端队列的元素上进行迭代的迭代器。
iterator() - 类 java.util.HashSet 中的方法
返回对此 set 中元素进行迭代的迭代器。
Iterator<E> - java.util 中的 接口
对 collection 进行迭代的迭代器。
iterator() - 接口 java.util.List 中的方法
返回按适当顺序在列表的元素上进行迭代的迭代器。
iterator() - 接口 java.util.NavigableSet 中的方法
以升序返回在此 set 的元素上进行迭代的迭代器。
iterator() - 类 java.util.PriorityQueue 中的方法
返回在此队列中的元素上进行迭代的迭代器。
iterator() - 类 java.util.ServiceLoader 中的方法
以延迟方式加载此加载器服务的可用提供者。
iterator() - 接口 java.util.Set 中的方法
返回在此 set 中的元素上进行迭代的迭代器。
iterator() - 类 java.util.TreeSet 中的方法
返回在此 set 中的元素上按升序进行迭代的迭代器。
iterator() - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
返回可在此 DOMCryptoContext 的 Id/Element 映射集上进行迭代的只读迭代器。
iterator() - 接口 javax.xml.crypto.NodeSetData 中的方法
返回可按照文档顺序在此 NodeSetData 中包含的节点上进行迭代的只读迭代器。
IvParameterSpec - javax.crypto.spec 中的 类
此类指定一个初始化向量 (IV)。
IvParameterSpec(byte[]) - 类 javax.crypto.spec.IvParameterSpec 的构造方法
使用 iv 中的字节作为 IV 来构造一个 IvParameterSpec 对象。
IvParameterSpec(byte[], int, int) - 类 javax.crypto.spec.IvParameterSpec 的构造方法
使用 iv 中始于且包含 offset 的前 len 个字节作为 IV 来构造一个 IvParameterSpec 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


J - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

J

JANUARY - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第一个月的 Calendar.MONTH 字段值。
JANUARY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第一个月的值。
JAPAN - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
JAPANESE - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
JAPANESE_DOUBLE_POSTCARD - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 Japanese Double 明信片尺寸，148 mm × 200 mm。
JAPANESE_DOUBLE_POSTCARD - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
Japanese Double Postcard 尺寸。
JAPANESE_POSTCARD - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 Japanese 明信片尺寸，100 mm × 148 mm。
JAPANESE_POSTCARD - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
Japanese Postcard 尺寸。
JApplet - javax.swing 中的 类
java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
JApplet() - 类 javax.swing.JApplet 的构造方法
创建一个 swing applet 实例。
JApplet.AccessibleJApplet - javax.swing 中的 类
此类实现对 JApplet 类的可访问性支持。
JApplet.AccessibleJApplet() - 类 javax.swing.JApplet.AccessibleJApplet 的构造方法
JarEntry - java.util.jar 中的 类
此类用于表示 JAR 文件条目。
JarEntry(String) - 类 java.util.jar.JarEntry 的构造方法
为指定的 JAR 文件条目名称创建新的 JarEntry。
JarEntry(ZipEntry) - 类 java.util.jar.JarEntry 的构造方法
使用从指定 ZipEntry 对象获取的字段创建新的 JarEntry。
JarEntry(JarEntry) - 类 java.util.jar.JarEntry 的构造方法
使用从指定的 JarEntry 对象获取的字段创建新的 JarEntry。
JarException - java.util.jar 中的 异常
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。
JarException() - 异常 java.util.jar.JarException 的构造方法
构造不带详细消息的 JarException。
JarException(String) - 异常 java.util.jar.JarException 的构造方法
构造带指定详细消息的 JarException。
JarFile - java.util.jar 中的 类
JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。
JarFile(String) - 类 java.util.jar.JarFile 的构造方法
创建一个要从指定的文件 name 读取的新的 JarFile。
JarFile(String, boolean) - 类 java.util.jar.JarFile 的构造方法
创建一个要从指定的文件 name 读取的新的 JarFile。
JarFile(File) - 类 java.util.jar.JarFile 的构造方法
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File, boolean) - 类 java.util.jar.JarFile 的构造方法
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File, boolean, int) - 类 java.util.jar.JarFile 的构造方法
创建一个要从指定的 File 对象中以指定模式读取的新的 JarFile。
jarFileURLConnection - 类 java.net.JarURLConnection 中的变量
到 JAR 文件 URL 的连接，如果已启动连接。
JarInputStream - java.util.jar 中的 类
JarInputStream 类用于从任何输入流读取 JAR 文件内容。
JarInputStream(InputStream) - 类 java.util.jar.JarInputStream 的构造方法
创建新的 JarInputStream 并读取可选的清单。
JarInputStream(InputStream, boolean) - 类 java.util.jar.JarInputStream 的构造方法
创建新的 JarInputStream 并读取可选的清单。
JarOutputStream - java.util.jar 中的 类
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。
JarOutputStream(OutputStream, Manifest) - 类 java.util.jar.JarOutputStream 的构造方法
使用指定的 Manifest 创建新的 JarOutputStream。
JarOutputStream(OutputStream) - 类 java.util.jar.JarOutputStream 的构造方法
创建不带清单的新的 JarOutputStream。
JarURLConnection - java.net 中的 类
连接到 Java ARchive (JAR) 文件或 JAR 文件中条目的 URL Connection。
JarURLConnection(URL) - 类 java.net.JarURLConnection 的构造方法
创建到指定 URL 的新 JarURLConnection。
java.applet - 软件包 java.applet
提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt - 软件包 java.awt
包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color - 软件包 java.awt.color
提供用于颜色空间的类。
java.awt.datatransfer - 软件包 java.awt.datatransfer
提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd - 软件包 java.awt.dnd
Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event - 软件包 java.awt.event
提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font - 软件包 java.awt.font
提供与字体相关的类和接口。
java.awt.geom - 软件包 java.awt.geom
提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.im - 软件包 java.awt.im
提供输入方法框架所需的类和接口。
java.awt.im.spi - 软件包 java.awt.im.spi
提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image - 软件包 java.awt.image
提供创建和修改图像的各种类。
java.awt.image.renderable - 软件包 java.awt.image.renderable
提供用于生成与呈现无关的图像的类和接口。
java.awt.print - 软件包 java.awt.print
为通用的打印 API 提供类和接口。
java.beans - 软件包 java.beans
包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext - 软件包 java.beans.beancontext
提供与 bean 上下文有关的类和接口。
java.io - 软件包 java.io
通过数据流、序列化和文件系统提供系统输入和输出。
java.lang - 软件包 java.lang
提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation - 软件包 java.lang.annotation
为 Java 编程语言注释设施提供库支持。
java.lang.instrument - 软件包 java.lang.instrument
提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.management - 软件包 java.lang.management
提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.ref - 软件包 java.lang.ref
提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。
java.lang.reflect - 软件包 java.lang.reflect
提供类和接口，以获得关于类和对象的反射信息。
java.math - 软件包 java.math
提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.net - 软件包 java.net
为实现网络应用程序提供类。
java.nio - 软件包 java.nio
定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels - 软件包 java.nio.channels
定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi - 软件包 java.nio.channels.spi
用于 java.nio.channels 包的服务提供者类。
java.nio.charset - 软件包 java.nio.charset
定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.nio.charset.spi - 软件包 java.nio.charset.spi
java.nio.charset 包的服务提供者类。
java.rmi - 软件包 java.rmi
提供 RMI 包。
java.rmi.activation - 软件包 java.rmi.activation
为 RMI 对象激活提供支持。
java.rmi.dgc - 软件包 java.rmi.dgc
为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry - 软件包 java.rmi.registry
提供 RMI 注册表的一个类和两个接口。
java.rmi.server - 软件包 java.rmi.server
提供支持服务器端 RMI 的类和接口。
java.security - 软件包 java.security
为安全框架提供类和接口。
java.security.acl - 软件包 java.security.acl
此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert - 软件包 java.security.cert
提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces - 软件包 java.security.interfaces
提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec - 软件包 java.security.spec
提供密钥规范和算法参数规范的类和接口。
java.sql - 软件包 java.sql
提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text - 软件包 java.text
提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi - 软件包 java.text.spi
java.text 包中类的服务提供者类。
java.util - 软件包 java.util
包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent - 软件包 java.util.concurrent
在并发编程中很常用的实用工具类。
java.util.concurrent.atomic - 软件包 java.util.concurrent.atomic
类的小工具包，支持在单个变量上解除锁的线程安全编程。
java.util.concurrent.locks - 软件包 java.util.concurrent.locks
为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
java.util.jar - 软件包 java.util.jar
提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging - 软件包 java.util.logging
提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs - 软件包 java.util.prefs
此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex - 软件包 java.util.regex
用于匹配字符序列与正则表达式指定模式的类。
java.util.spi - 软件包 java.util.spi
java.util 包中类的服务提供者类。
java.util.zip - 软件包 java.util.zip
提供用于读写标准 ZIP 和 GZIP 文件格式的类。
JAVA_OBJECT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 JAVA_OBJECT 的 Java 编程语言中的常量（有时称为类型代码）。
JavaCompiler - javax.tools 中的 接口
从程序中调用 Java™ 编程语言编译器的接口。
JavaCompiler.CompilationTask - javax.tools 中的 接口
表示编译任务的 future 的接口。
javaFileListFlavor - 类 java.awt.datatransfer.DataFlavor 中的静态变量
要将文件列表传入 Java（及底层平台）或从中传出，需要使用此类型/子类型的 DataFlavor 和 java.util.List 的表示形式类。
JavaFileManager - javax.tools 中的 接口
在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。
JavaFileManager.Location - javax.tools 中的 接口
文件对象位置的接口。
JavaFileObject - javax.tools 中的 接口
在 Java™ 编程语言源和类文件上进行操作的工具的文件抽象。
JavaFileObject.Kind - javax.tools 中的 枚举
JavaFileObject 的种类。
javaJVMLocalObjectMimeType - 类 java.awt.datatransfer.DataFlavor 中的静态变量
要将一个引用传输到不具有关联 MIME Content 类型的任意 Java 对象引用（跨越同一 JVM 中的 Transferable 接口），需要使用具有此类型/子类型的 DataFlavor，其中 representationClass 等于跨越 Transferable 传递的类/接口的类型。
javaRemoteObjectMimeType - 类 java.awt.datatransfer.DataFlavor 中的静态变量
为了通过拖放 ACTION_LINK 操作将活动链接传递到 Remote 对象，应该使用 Mime Content 类型的 application/x-java-remote-object，其中 DataFlavor 的表示形式类表示要传输的 Remote 接口的类型。
javaSerializedObjectMimeType - 类 java.awt.datatransfer.DataFlavor 中的静态变量
MIME Content 类型的 application/x-java-serialized-object 表示已变得持久的 Java 对象的图形。
javax.accessibility - 软件包 javax.accessibility
定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.activation - 软件包 javax.activation
javax.activity - 软件包 javax.activity
包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation - 软件包 javax.annotation
javax.annotation.processing - 软件包 javax.annotation.processing
用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto - 软件包 javax.crypto
为加密操作提供类和接口。
javax.crypto.interfaces - 软件包 javax.crypto.interfaces
根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec - 软件包 javax.crypto.spec
为密钥规范和算法参数规范提供类和接口。
javax.imageio - 软件包 javax.imageio
Java Image I/O API 的主要包。
javax.imageio.event - 软件包 javax.imageio.event
Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.metadata - 软件包 javax.imageio.metadata
用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.plugins.bmp - 软件包 javax.imageio.plugins.bmp
包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg - 软件包 javax.imageio.plugins.jpeg
支持内置 JPEG 插件的类。
javax.imageio.spi - 软件包 javax.imageio.spi
包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream - 软件包 javax.imageio.stream
Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.jws - 软件包 javax.jws
javax.jws.soap - 软件包 javax.jws.soap
javax.lang.model - 软件包 javax.lang.model
用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element - 软件包 javax.lang.model.element
用于 Java 编程语言的模型元素的接口。
javax.lang.model.type - 软件包 javax.lang.model.type
用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util - 软件包 javax.lang.model.util
用来帮助处理程序元素和类型的实用工具。
javax.management - 软件包 javax.management
提供 Java Management Extensions 的核心类。
javax.management.loading - 软件包 javax.management.loading
提供实现高级动态加载的类。
javax.management.modelmbean - 软件包 javax.management.modelmbean
提供了 ModelMBean 类的定义。
javax.management.monitor - 软件包 javax.management.monitor
提供 monitor 类的定义。
javax.management.openmbean - 软件包 javax.management.openmbean
提供开放数据类型和 Open MBean 描述符类。
javax.management.relation - 软件包 javax.management.relation
提供 Relation Service 的定义。
javax.management.remote - 软件包 javax.management.remote
对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi - 软件包 javax.management.remote.rmi
RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer - 软件包 javax.management.timer
提供对 Timer MBean（计时器 MBean）的定义。
javax.naming - 软件包 javax.naming
为访问命名服务提供类和接口。
javax.naming.directory - 软件包 javax.naming.directory
扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event - 软件包 javax.naming.event
在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap - 软件包 javax.naming.ldap
提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi - 软件包 javax.naming.spi
提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.net - 软件包 javax.net
提供用于网络应用程序的类。
javax.net.ssl - 软件包 javax.net.ssl
提供用于安全套接字包的类。
javax.print - 软件包 javax.print
为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute - 软件包 javax.print.attribute
提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard - 软件包 javax.print.attribute.standard
包 javax.print.attribute.standard 包括特定打印属性的类。
javax.print.event - 软件包 javax.print.event
包 javax.print.event 包含事件类和侦听器接口。
javax.rmi - 软件包 javax.rmi
包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA - 软件包 javax.rmi.CORBA
包含用于 RMI-IIOP 的可移植性 API。
javax.rmi.ssl - 软件包 javax.rmi.ssl
通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.script - 软件包 javax.script
脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth - 软件包 javax.security.auth
此包提供用于进行验证和授权的框架。
javax.security.auth.callback - 软件包 javax.security.auth.callback
此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.kerberos - 软件包 javax.security.auth.kerberos
此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.login - 软件包 javax.security.auth.login
此包提供可插入的验证框架。
javax.security.auth.spi - 软件包 javax.security.auth.spi
此包提供用于实现可插入验证模块的接口。
javax.security.auth.x500 - 软件包 javax.security.auth.x500
此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.cert - 软件包 javax.security.cert
为公钥证书提供类。
javax.security.sasl - 软件包 javax.security.sasl
包含用于支持 SASL 的类和接口。
javax.sound.midi - 软件包 javax.sound.midi
提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi - 软件包 javax.sound.midi.spi
在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled - 软件包 javax.sound.sampled
提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi - 软件包 javax.sound.sampled.spi
在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql - 软件包 javax.sql
为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset - 软件包 javax.sql.rowset
JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial - 软件包 javax.sql.rowset.serial
提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi - 软件包 javax.sql.rowset.spi
第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing - 软件包 javax.swing
提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border - 软件包 javax.swing.border
提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser - 软件包 javax.swing.colorchooser
包含供 JColorChooser 组件使用的类和接口。
javax.swing.event - 软件包 javax.swing.event
供 Swing 组件触发的事件使用。
javax.swing.filechooser - 软件包 javax.swing.filechooser
包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf - 软件包 javax.swing.plaf
提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic - 软件包 javax.swing.plaf.basic
提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal - 软件包 javax.swing.plaf.metal
提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi - 软件包 javax.swing.plaf.multi
提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth - 软件包 javax.swing.plaf.synth
Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table - 软件包 javax.swing.table
提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text - 软件包 javax.swing.text
提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html - 软件包 javax.swing.text.html
提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser - 软件包 javax.swing.text.html.parser
提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf - 软件包 javax.swing.text.rtf
提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.swing.tree - 软件包 javax.swing.tree
提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo - 软件包 javax.swing.undo
允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.tools - 软件包 javax.tools
为能够从程序（例如，编译器）中调用的工具提供接口。
javax.transaction - 软件包 javax.transaction
包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa - 软件包 javax.transaction.xa
提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml - 软件包 javax.xml
根据 XML 规范定义核心 XML 常量和功能。
javax.xml.bind - 软件包 javax.xml.bind
为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation - 软件包 javax.xml.bind.annotation
定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters - 软件包 javax.xml.bind.annotation.adapters
XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.bind.attachment - 软件包 javax.xml.bind.attachment
此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。
javax.xml.bind.helpers - 软件包 javax.xml.bind.helpers
仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util - 软件包 javax.xml.bind.util
有用的客户端实用工具类。
javax.xml.crypto - 软件包 javax.xml.crypto
用于 XML 加密的通用类。
javax.xml.crypto.dom - 软件包 javax.xml.crypto.dom
javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig - 软件包 javax.xml.crypto.dsig
用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom - 软件包 javax.xml.crypto.dsig.dom
javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.crypto.dsig.keyinfo - 软件包 javax.xml.crypto.dsig.keyinfo
用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.crypto.dsig.spec - 软件包 javax.xml.crypto.dsig.spec
XML 数字签名的参数类。
javax.xml.datatype - 软件包 javax.xml.datatype
XML/Java 类型映射关系。
javax.xml.namespace - 软件包 javax.xml.namespace
XML 名称空间处理。
javax.xml.parsers - 软件包 javax.xml.parsers
提供允许处理 XML 文档的类。
javax.xml.soap - 软件包 javax.xml.soap
提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream - 软件包 javax.xml.stream
javax.xml.stream.events - 软件包 javax.xml.stream.events
javax.xml.stream.util - 软件包 javax.xml.stream.util
javax.xml.transform - 软件包 javax.xml.transform
此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom - 软件包 javax.xml.transform.dom
此包实现特定于 DOM 的转换 API。
javax.xml.transform.sax - 软件包 javax.xml.transform.sax
此包实现特定于 SAX2 的转换 API。
javax.xml.transform.stax - 软件包 javax.xml.transform.stax
提供特定于 StAX 的转换 API。
javax.xml.transform.stream - 软件包 javax.xml.transform.stream
此包实现特定于流和 URI 的转换 API。
javax.xml.validation - 软件包 javax.xml.validation
此包提供了用于 XML 文档验证的 API。
javax.xml.ws - 软件包 javax.xml.ws
此包包含核心 JAX-WS API。
javax.xml.ws.handler - 软件包 javax.xml.ws.handler
该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap - 软件包 javax.xml.ws.handler.soap
该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.http - 软件包 javax.xml.ws.http
该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap - 软件包 javax.xml.ws.soap
该包定义特定于 SOAP 绑定的 API。
javax.xml.ws.spi - 软件包 javax.xml.ws.spi
该包定义用于 JAX-WS 2.0 的 SPI。
javax.xml.xpath - 软件包 javax.xml.xpath
此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
JAXB_CONTEXT_FACTORY - 类 javax.xml.bind.JAXBContext 中的静态变量
属性名称，它包含能够创建新的 JAXBContext 对象的类名称。
JAXB_ENCODING - 接口 javax.xml.bind.Marshaller 中的静态变量
用来指定已编组 XML 数据中输出编码的属性名称。
JAXB_FORMATTED_OUTPUT - 接口 javax.xml.bind.Marshaller 中的静态变量
用来指定是否使用换行和缩排对已编组 XML 数据进行格式化的属性名称。
JAXB_FRAGMENT - 接口 javax.xml.bind.Marshaller 中的静态变量
用来指定 marshaller 是否将生成文档级事件（即调用 startDocument 或 endDocument）的属性名称。
JAXB_NO_NAMESPACE_SCHEMA_LOCATION - 接口 javax.xml.bind.Marshaller 中的静态变量
用来指定将放置在已编组 XML 输出中的 xsi:noNamespaceSchemaLocation 属性值的属性名称。
JAXB_SCHEMA_LOCATION - 接口 javax.xml.bind.Marshaller 中的静态变量
用来指定将放置在已编组 XML 输出中的 xsi:schemaLocation 属性值的属性名称。
JAXBContext - javax.xml.bind 中的 类
JAXBContext 类提供到 JAXB API 的客户端入口点。
JAXBContext() - 类 javax.xml.bind.JAXBContext 的构造方法
JAXBElement<T> - javax.xml.bind 中的 类
Xml 元素的 JAXB 表示形式。
JAXBElement(QName, Class<T>, Class, T) - 类 javax.xml.bind.JAXBElement 的构造方法
构造一个 xml 元素实例。
JAXBElement(QName, Class<T>, T) - 类 javax.xml.bind.JAXBElement 的构造方法
构造一个 xml 元素实例。
JAXBElement.GlobalScope - javax.xml.bind 中的 类
为 xml 元素指定全局作用域。
JAXBElement.GlobalScope() - 类 javax.xml.bind.JAXBElement.GlobalScope 的构造方法
JAXBException - javax.xml.bind 中的 异常
这是所有 JAXB 异常的根异常类。
JAXBException(String) - 异常 javax.xml.bind.JAXBException 的构造方法
构造带指定详细消息的 JAXBException。
JAXBException(String, String) - 异常 javax.xml.bind.JAXBException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 JAXBException。
JAXBException(Throwable) - 异常 javax.xml.bind.JAXBException 的构造方法
构造带有一个 linkedException 的 JAXBException。
JAXBException(String, Throwable) - 异常 javax.xml.bind.JAXBException 的构造方法
构造带指定的详细消息和 linkedException 的 JAXBException。
JAXBException(String, String, Throwable) - 异常 javax.xml.bind.JAXBException 的构造方法
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 JAXBException。
JAXBIntrospector - javax.xml.bind 中的 类
提供对 JAXB 对象的 JAXB xml 绑定数据的访问。
JAXBIntrospector() - 类 javax.xml.bind.JAXBIntrospector 的构造方法
JAXBResult - javax.xml.bind.util 中的 类
解组 JAXB 对象的 JAXP Result 实现。
JAXBResult(JAXBContext) - 类 javax.xml.bind.util.JAXBResult 的构造方法
创建一个使用指定 JAXBContext 来解组的新实例。
JAXBResult(Unmarshaller) - 类 javax.xml.bind.util.JAXBResult 的构造方法
创建一个使用指定 Unmarshaller 来解组对象的新实例。
JAXBSource - javax.xml.bind.util 中的 类
编组 JAXB 生成的对象的 JAXP Source 实现。
JAXBSource(JAXBContext, Object) - 类 javax.xml.bind.util.JAXBSource 的构造方法
针对给定的内容对象创建一个新 Source。
JAXBSource(Marshaller, Object) - 类 javax.xml.bind.util.JAXBSource 的构造方法
针对给定的内容对象创建一个新 Source。
JAXWSPROVIDER_PROPERTY - 类 javax.xml.ws.spi.Provider 中的静态变量
表示用于查找 Provider 实现类名称的属性的常量。
JButton - javax.swing 中的 类
"push" 按钮的实现。
JButton() - 类 javax.swing.JButton 的构造方法
创建不带有设置文本或图标的按钮。
JButton(Icon) - 类 javax.swing.JButton 的构造方法
创建一个带图标的按钮。
JButton(String) - 类 javax.swing.JButton 的构造方法
创建一个带文本的按钮。
JButton(Action) - 类 javax.swing.JButton 的构造方法
创建一个按钮，其属性从所提供的 Action 中获取。
JButton(String, Icon) - 类 javax.swing.JButton 的构造方法
创建一个带初始文本和图标的按钮。
JButton.AccessibleJButton - javax.swing 中的 类
此类实现对 JButton 类的可访问性支持。
JButton.AccessibleJButton() - 类 javax.swing.JButton.AccessibleJButton 的构造方法
JCheckBox - javax.swing 中的 类
复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
JCheckBox() - 类 javax.swing.JCheckBox 的构造方法
创建一个没有文本、没有图标并且最初未被选定的复选框。
JCheckBox(Icon) - 类 javax.swing.JCheckBox 的构造方法
创建有一个图标、最初未被选定的复选框。
JCheckBox(Icon, boolean) - 类 javax.swing.JCheckBox 的构造方法
创建一个带图标的复选框，并指定其最初是否处于选定状态。
JCheckBox(String) - 类 javax.swing.JCheckBox 的构造方法
创建一个带文本的、最初未被选定的复选框。
JCheckBox(Action) - 类 javax.swing.JCheckBox 的构造方法
创建一个复选框，其属性从所提供的 Action 获取。
JCheckBox(String, boolean) - 类 javax.swing.JCheckBox 的构造方法
创建一个带文本的复选框，并指定其最初是否处于选定状态。
JCheckBox(String, Icon) - 类 javax.swing.JCheckBox 的构造方法
创建带有指定文本和图标的、最初未选定的复选框。
JCheckBox(String, Icon, boolean) - 类 javax.swing.JCheckBox 的构造方法
创建一个带文本和图标的复选框，并指定其最初是否处于选定状态。
JCheckBox.AccessibleJCheckBox - javax.swing 中的 类
此类实现对 JCheckBox 类的可访问性支持。
JCheckBox.AccessibleJCheckBox() - 类 javax.swing.JCheckBox.AccessibleJCheckBox 的构造方法
JCheckBoxMenuItem - javax.swing 中的 类
可以被选定或取消选定的菜单项。
JCheckBoxMenuItem() - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建一个没有设置文本或图标的、最初未选定的复选框菜单项。
JCheckBoxMenuItem(Icon) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建有一个带图标的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建一个带文本的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(Action) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建一个从所提供的 Action 中获取其属性的菜单项。
JCheckBoxMenuItem(String, Icon) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建带有指定文本和图标的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String, boolean) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建带有指定文本和选择状态的复选框菜单项。
JCheckBoxMenuItem(String, Icon, boolean) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建带有指定文本、图标和选择状态的复选框菜单项。
JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem - javax.swing 中的 类
此类实现对 JCheckBoxMenuItem 类的可访问性支持。
JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem() - 类 javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 的构造方法
JColorChooser - javax.swing 中的 类
JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
JColorChooser() - 类 javax.swing.JColorChooser 的构造方法
创建初始颜色为白色的颜色选取器窗格。
JColorChooser(Color) - 类 javax.swing.JColorChooser 的构造方法
创建具有指定初始颜色的颜色选取器窗格。
JColorChooser(ColorSelectionModel) - 类 javax.swing.JColorChooser 的构造方法
创建具有指定 ColorSelectionModel 颜色选取器窗格。
JColorChooser.AccessibleJColorChooser - javax.swing 中的 类
此类实现对 JColorChooser 类的可访问性支持。
JColorChooser.AccessibleJColorChooser() - 类 javax.swing.JColorChooser.AccessibleJColorChooser 的构造方法
JComboBox - javax.swing 中的 类
将按钮或可编辑字段与下拉列表组合的组件。
JComboBox(ComboBoxModel) - 类 javax.swing.JComboBox 的构造方法
创建一个 JComboBox，其项取自现有的 ComboBoxModel。
JComboBox(Object[]) - 类 javax.swing.JComboBox 的构造方法
创建包含指定数组中的元素的 JComboBox。
JComboBox(Vector<?>) - 类 javax.swing.JComboBox 的构造方法
创建包含指定 Vector 中的元素的 JComboBox。
JComboBox() - 类 javax.swing.JComboBox 的构造方法
创建具有默认数据模型的 JComboBox。
JComboBox.AccessibleJComboBox - javax.swing 中的 类
此类实现 JComboBox 类的可访问性支持。
JComboBox.AccessibleJComboBox() - 类 javax.swing.JComboBox.AccessibleJComboBox 的构造方法
返回 AccessibleJComboBox 实例
JComboBox.KeySelectionManager - javax.swing 中的 接口
定义 KeySelectionManager 的接口。
JComponent - javax.swing 中的 类
该类是除顶层容器外所有 Swing 组件的基类。
JComponent() - 类 javax.swing.JComponent 的构造方法
默认的 JComponent 构造方法。
JComponent.AccessibleJComponent - javax.swing 中的 类
用于为可访问性提供默认支持的 JComponent 内部类。
JComponent.AccessibleJComponent() - 类 javax.swing.JComponent.AccessibleJComponent 的构造方法
尽管该类是抽象的，但是应该通过所有子类调用它。
JComponent.AccessibleJComponent.AccessibleContainerHandler - javax.swing 中的 类
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
JComponent.AccessibleJComponent.AccessibleContainerHandler() - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler 的构造方法
JComponent.AccessibleJComponent.AccessibleFocusHandler - javax.swing 中的 类
发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
JComponent.AccessibleJComponent.AccessibleFocusHandler() - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler 的构造方法
JCOMPONENT_UI - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个作为 Swing 组件实现的 UI。
jdbcCompliant() - 接口 java.sql.Driver 中的方法
报告此驱动程序是否是一个真正的 JDBC CompliantTM 驱动程序。
JdbcRowSet - javax.sql.rowset 中的 接口
所有标准 JdbcRowSet 实现都必须实现的标准接口。
JDesktopPane - javax.swing 中的 类
用于创建多文档界面或虚拟桌面的容器。
JDesktopPane() - 类 javax.swing.JDesktopPane 的构造方法
创建一个新的 JDesktopPane。
JDesktopPane.AccessibleJDesktopPane - javax.swing 中的 类
此类实现对 JDesktopPane 类的可访问性支持。
JDesktopPane.AccessibleJDesktopPane() - 类 javax.swing.JDesktopPane.AccessibleJDesktopPane 的构造方法
JDialog - javax.swing 中的 类
创建对话框窗口的主要类。
JDialog() - 类 javax.swing.JDialog 的构造方法
创建一个没有标题并且没有指定 Frame 所有者的无模式对话框。
JDialog(Frame) - 类 javax.swing.JDialog 的构造方法
创建一个没有标题但将指定的 Frame 作为其所有者的无模式对话框。
JDialog(Frame, boolean) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定所有者 Frame、模式和空标题的对话框。
JDialog(Frame, String) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题和指定所有者窗体的无模式对话框。
JDialog(Frame, String, boolean) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、所有者 Frame 和模式的对话框。
JDialog(Frame, String, boolean, GraphicsConfiguration) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、所有者 Frame、模式和 GraphicsConfiguration 的对话框。
JDialog(Dialog) - 类 javax.swing.JDialog 的构造方法
创建一个没有标题但将指定的 Dialog 作为其所有者的无模式对话框。
JDialog(Dialog, boolean) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定所有者 Dialog 和模式的对话框。
JDialog(Dialog, String) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题和指定所有者对话框的无模式对话框。
JDialog(Dialog, String, boolean) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、模式和指定所有者 Dialog 的对话框。
JDialog(Dialog, String, boolean, GraphicsConfiguration) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、所有者 Dialog、模式和 GraphicsConfiguration 的对话框。
JDialog(Window) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定所有者 Window 和空标题的无模式对话框。
JDialog(Window, Dialog.ModalityType) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定所有者 Window、模式和空标题的对话框。
JDialog(Window, String) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题和所有者 Window 的无模式对话框。
JDialog(Window, String, Dialog.ModalityType) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、所有者 Window 和模式的对话框。
JDialog(Window, String, Dialog.ModalityType, GraphicsConfiguration) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。
JDialog.AccessibleJDialog - javax.swing 中的 类
此类实现对 JDialog 类的可访问性支持。
JDialog.AccessibleJDialog() - 类 javax.swing.JDialog.AccessibleJDialog 的构造方法
JDIALOG_UI - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个作为 Swing 对话框实现的 UI。
JEditorPane - javax.swing 中的 类
可编辑各种内容的文本组件。
JEditorPane() - 类 javax.swing.JEditorPane 的构造方法
创建一个新的 JEditorPane。
JEditorPane(URL) - 类 javax.swing.JEditorPane 的构造方法
根据用作输入的指定 URL 创建一个 JEditorPane。
JEditorPane(String) - 类 javax.swing.JEditorPane 的构造方法
根据包含 URL 规范的字符串创建一个 JEditorPane。
JEditorPane(String, String) - 类 javax.swing.JEditorPane 的构造方法
创建一个已初始化为给定文件的 JEditorPane。
JEditorPane.AccessibleJEditorPane - javax.swing 中的 类
此类实现对 JEditorPane 类的可访问性支持。
JEditorPane.AccessibleJEditorPane() - 类 javax.swing.JEditorPane.AccessibleJEditorPane 的构造方法
JEditorPane.AccessibleJEditorPaneHTML - javax.swing 中的 类
此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
JEditorPane.AccessibleJEditorPaneHTML() - 类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 的构造方法
JEditorPane.JEditorPaneAccessibleHypertextSupport - javax.swing 中的 类
AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
JEditorPane.JEditorPaneAccessibleHypertextSupport() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 的构造方法
提供某种支持
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink - javax.swing 中的 类
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 的构造方法
JFileChooser - javax.swing 中的 类
JFileChooser 为用户选择文件提供了一种简单的机制。
JFileChooser() - 类 javax.swing.JFileChooser 的构造方法
构造一个指向用户默认目录的 JFileChooser。
JFileChooser(String) - 类 javax.swing.JFileChooser 的构造方法
构造一个使用给定路径的 JFileChooser。
JFileChooser(File) - 类 javax.swing.JFileChooser 的构造方法
使用给定的 File 作为路径来构造一个 JFileChooser。
JFileChooser(FileSystemView) - 类 javax.swing.JFileChooser 的构造方法
使用给定的 FileSystemView 构造一个 JFileChooser。
JFileChooser(File, FileSystemView) - 类 javax.swing.JFileChooser 的构造方法
使用给定的当前目录和 FileSystemView 构造一个 JFileChooser。
JFileChooser(String, FileSystemView) - 类 javax.swing.JFileChooser 的构造方法
使用给定的当前目录路径和 FileSystemView 构造一个 JFileChooser。
JFileChooser.AccessibleJFileChooser - javax.swing 中的 类
此类实现对 JFileChooser 类的可访问性支持。
JFileChooser.AccessibleJFileChooser() - 类 javax.swing.JFileChooser.AccessibleJFileChooser 的构造方法
JFormattedTextField - javax.swing 中的 类
JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
JFormattedTextField() - 类 javax.swing.JFormattedTextField 的构造方法
创建一个没有 AbstractFormatterFactory 的 JFormattedTextField。
JFormattedTextField(Object) - 类 javax.swing.JFormattedTextField 的构造方法
创建一个具有指定值的 JFormattedTextField。
JFormattedTextField(Format) - 类 javax.swing.JFormattedTextField 的构造方法
创建一个 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatter) - 类 javax.swing.JFormattedTextField 的构造方法
创建一个具有指定 AbstractFormatter 的 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory) - 类 javax.swing.JFormattedTextField 的构造方法
创建一个具有指定 AbstractFormatterFactory 的 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory, Object) - 类 javax.swing.JFormattedTextField 的构造方法
创建一个具有指定 AbstractFormatterFactory 和初始值的 JFormattedTextField。
JFormattedTextField.AbstractFormatter - javax.swing 中的 类
JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。
JFormattedTextField.AbstractFormatter() - 类 javax.swing.JFormattedTextField.AbstractFormatter 的构造方法
JFormattedTextField.AbstractFormatterFactory - javax.swing 中的 类
JFormattedTextField 使用的 AbstractFormatterFactory 实例，用来获得 AbstractFormatter 实例，依次使用该实例格式化各个值。
JFormattedTextField.AbstractFormatterFactory() - 类 javax.swing.JFormattedTextField.AbstractFormatterFactory 的构造方法
JFrame - javax.swing 中的 类
java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
JFrame() - 类 javax.swing.JFrame 的构造方法
构造一个初始时不可见的新窗体。
JFrame(GraphicsConfiguration) - 类 javax.swing.JFrame 的构造方法
以屏幕设备的指定 GraphicsConfiguration 和空白标题创建一个 Frame。
JFrame(String) - 类 javax.swing.JFrame 的构造方法
创建一个新的、初始不可见的、具有指定标题的 Frame。
JFrame(String, GraphicsConfiguration) - 类 javax.swing.JFrame 的构造方法
创建一个具有指定标题和指定屏幕设备的 GraphicsConfiguration 的 JFrame。
JFrame.AccessibleJFrame - javax.swing 中的 类
此类实现对 JFrame 类的可访问性支持。
JFrame.AccessibleJFrame() - 类 javax.swing.JFrame.AccessibleJFrame 的构造方法
JInternalFrame - javax.swing 中的 类
提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
JInternalFrame() - 类 javax.swing.JInternalFrame 的构造方法
创建不可调整大小的、不可关闭的、不可最大化的、不可图标化的、没有标题的 JInternalFrame。
JInternalFrame(String) - 类 javax.swing.JInternalFrame 的构造方法
创建不可调整大小的、不可关闭的、不可最大化的、不可图标化的、具有指定标题的 JInternalFrame。
JInternalFrame(String, boolean) - 类 javax.swing.JInternalFrame 的构造方法
创建不可关闭的、不可最大化的、不可图标化的，以及具有指定标题和可调整大小的 JInternalFrame。
JInternalFrame(String, boolean, boolean) - 类 javax.swing.JInternalFrame 的构造方法
创建不可最大化的、不可图标化的，以及具有指定标题、可调整大小和可关闭的 JInternalFrame。
JInternalFrame(String, boolean, boolean, boolean) - 类 javax.swing.JInternalFrame 的构造方法
创建不可图标化的，但具有指定标题、可调整大小、可关闭和可最大化的 JInternalFrame。
JInternalFrame(String, boolean, boolean, boolean, boolean) - 类 javax.swing.JInternalFrame 的构造方法
创建具有指定标题、可调整、可关闭、可最大化和可图标化的 JInternalFrame。
JInternalFrame.AccessibleJInternalFrame - javax.swing 中的 类
此类实现对 JInternalFrame 类的可访问性支持。
JInternalFrame.AccessibleJInternalFrame() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 的构造方法
JInternalFrame.JDesktopIcon - javax.swing 中的 类
此组件表示 JInternalFrame 的图标化版本。
JInternalFrame.JDesktopIcon(JInternalFrame) - 类 javax.swing.JInternalFrame.JDesktopIcon 的构造方法
为内部 frame 创建一个图标。
JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon - javax.swing 中的 类
此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 的构造方法
JIS_B0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B0 (1030 x 1456 mm) 的 MediaType 实例。
JIS_B0 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B0 尺寸。
JIS_B1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B1 (728 x 1030 mm) 的 MediaType 实例。
JIS_B1 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B1 尺寸。
JIS_B10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B10 (32 x 45 mm) 的 MediaType 实例。
JIS_B10 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B10 尺寸。
JIS_B2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B2 (515 x 728 mm) 的 MediaType 实例。
JIS_B2 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B2 尺寸。
JIS_B3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B3 (364 x 515 mm) 的 MediaType 实例。
JIS_B3 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B3 尺寸。
JIS_B4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B4 (257 x 364 mm) 的 MediaType 实例。
JIS_B4 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B4 尺寸。
JIS_B5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B5 (182 x 257 mm) 的 MediaType 实例。
JIS_B5 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B5 尺寸。
JIS_B6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B6 (128 x 182 mm) 的 MediaType 实例。
JIS_B6 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B6 尺寸。
JIS_B7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B7 (91 x 128 mm) 的 MediaType 实例。
JIS_B7 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B7 尺寸。
JIS_B8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B8 (64 x 91 mm) 的 MediaType 实例。
JIS_B8 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B8 尺寸。
JIS_B9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B9 (45 x 64 mm) 的 MediaType 实例。
JIS_B9 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B9 尺寸。
JLabel - javax.swing 中的 类
用于短文本字符串或图像或二者的显示区。
JLabel(String, Icon, int) - 类 javax.swing.JLabel 的构造方法
创建具有指定文本、图像和水平对齐方式的 JLabel 实例。
JLabel(String, int) - 类 javax.swing.JLabel 的构造方法
创建具有指定文本和水平对齐方式的 JLabel 实例。
JLabel(String) - 类 javax.swing.JLabel 的构造方法
创建具有指定文本的 JLabel 实例。
JLabel(Icon, int) - 类 javax.swing.JLabel 的构造方法
创建具有指定图像和水平对齐方式的 JLabel 实例。
JLabel(Icon) - 类 javax.swing.JLabel 的构造方法
创建具有指定图像的 JLabel 实例。
JLabel() - 类 javax.swing.JLabel 的构造方法
创建无图像并且其标题为空字符串的 JLabel。
JLabel.AccessibleJLabel - javax.swing 中的 类
该类用于获得此对象的可访问性职责。
JLabel.AccessibleJLabel() - 类 javax.swing.JLabel.AccessibleJLabel 的构造方法
JLayeredPane - javax.swing 中的 类
JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
JLayeredPane() - 类 javax.swing.JLayeredPane 的构造方法
创建新的 JLayeredPane
JLayeredPane.AccessibleJLayeredPane - javax.swing 中的 类
此类实现对 JLayeredPane 类的可访问性支持。
JLayeredPane.AccessibleJLayeredPane() - 类 javax.swing.JLayeredPane.AccessibleJLayeredPane 的构造方法
JList - javax.swing 中的 类
显示对象列表并且允许用户选择一个或多个项的组件。
JList(ListModel) - 类 javax.swing.JList 的构造方法
根据指定的非 null 模型构造一个显示元素的 JList。
JList(Object[]) - 类 javax.swing.JList 的构造方法
构造一个 JList，使其显示指定数组中的元素。
JList(Vector<?>) - 类 javax.swing.JList 的构造方法
构造一个 JList，使其显示指定 Vector 中的元素。
JList() - 类 javax.swing.JList 的构造方法
构造一个具有空的、只读模型的 JList。
JList.AccessibleJList - javax.swing 中的 类
此类实现 JList 类的可访问性支持。
JList.AccessibleJList() - 类 javax.swing.JList.AccessibleJList 的构造方法
JList.AccessibleJList.AccessibleJListChild - javax.swing 中的 类
此类实现供 List 子级使用的可访问性支持。
JList.AccessibleJList.AccessibleJListChild(JList, int) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 的构造方法
JList.DropLocation - javax.swing 中的 类
TransferHandler.DropLocation 的一个子类，表示 JList 的放置位置 (drop location)。
JMenu - javax.swing 中的 类
菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
JMenu() - 类 javax.swing.JMenu 的构造方法
构造没有文本的新 JMenu。
JMenu(String) - 类 javax.swing.JMenu 的构造方法
构造一个新 JMenu，用提供的字符串作为其文本。
JMenu(Action) - 类 javax.swing.JMenu 的构造方法
构造一个从提供的 Action 获取其属性的菜单。
JMenu(String, boolean) - 类 javax.swing.JMenu 的构造方法
构造一个新 JMenu，用提供的字符串作为其文本并指定其是否为分离式 (tear-off) 菜单。
JMenu.AccessibleJMenu - javax.swing 中的 类
此类实现 JMenu 类的可访问性支持。
JMenu.AccessibleJMenu() - 类 javax.swing.JMenu.AccessibleJMenu 的构造方法
JMenu.WinListener - javax.swing 中的 类
观察弹出窗口关闭的侦听器类。
JMenu.WinListener(JPopupMenu) - 类 javax.swing.JMenu.WinListener 的构造方法
创建指定弹出菜单的窗口侦听器。
JMenuBar - javax.swing 中的 类
菜单栏的实现。
JMenuBar() - 类 javax.swing.JMenuBar 的构造方法
创建新的菜单栏。
JMenuBar.AccessibleJMenuBar - javax.swing 中的 类
此类实现 JMenuBar 类的可访问性支持。
JMenuBar.AccessibleJMenuBar() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 的构造方法
JMenuItem - javax.swing 中的 类
菜单中的项的实现。
JMenuItem() - 类 javax.swing.JMenuItem 的构造方法
创建不带有设置文本或图标的 JMenuItem。
JMenuItem(Icon) - 类 javax.swing.JMenuItem 的构造方法
创建带有指定图标的 JMenuItem。
JMenuItem(String) - 类 javax.swing.JMenuItem 的构造方法
创建带有指定文本的 JMenuItem。
JMenuItem(Action) - 类 javax.swing.JMenuItem 的构造方法
创建从指定的 Action 获取其属性的菜单项。
JMenuItem(String, Icon) - 类 javax.swing.JMenuItem 的构造方法
创建带有指定文本和图标的 JMenuItem。
JMenuItem(String, int) - 类 javax.swing.JMenuItem 的构造方法
创建带有指定文本和键盘助记符的 JMenuItem。
JMenuItem.AccessibleJMenuItem - javax.swing 中的 类
此类实现 JMenuItem 类的可访问性支持。
JMException - javax.management 中的 异常
由 JMX 实现所抛出的异常。
JMException() - 异常 javax.management.JMException 的构造方法
默认的构造方法。
JMException(String) - 异常 javax.management.JMException 的构造方法
允许指定特定错误消息的构造方法。
JMRuntimeException - javax.management 中的 异常
由 JMX 实现所发出的运行时异常。
JMRuntimeException() - 异常 javax.management.JMRuntimeException 的构造方法
默认的构造方法。
JMRuntimeException(String) - 异常 javax.management.JMRuntimeException 的构造方法
允许指定特定错误消息的构造方法。
JMX - javax.management 中的 类
JMX API 提供的静态方法。
JMXAddressable - javax.management.remote 中的 接口
由可能具有 JMXServiceURL 地址的对象实现。
JMXAuthenticator - javax.management.remote 中的 接口
定义如何将远程凭据转换为 JAAS Subject（主题）的接口。
JMXConnectionNotification - javax.management.remote 中的 类
在客户端连接打开或关闭时，或者当通知丢失时发出的通知。
JMXConnectionNotification(String, Object, String, long, String, Object) - 类 javax.management.remote.JMXConnectionNotification 的构造方法
构造一个新的连接通知。
JMXConnector - javax.management.remote 中的 接口
JMX API 连接器的客户端。
JMXConnectorFactory - javax.management.remote 中的 类
用于创建 JMX API 连接器客户端的工厂。
JMXConnectorProvider - javax.management.remote 中的 接口
使用给定的协议创建 JMX API 连接器客户端的提供者。
JMXConnectorServer - javax.management.remote 中的 类
每个连接器服务器的超类。
JMXConnectorServer() - 类 javax.management.remote.JMXConnectorServer 的构造方法
构造一个将注册为连接到 MBean 服务器的 MBean 的连接器服务器。
JMXConnectorServer(MBeanServer) - 类 javax.management.remote.JMXConnectorServer 的构造方法
构造一个连接到给定 MBean 服务器的连接器服务器。
JMXConnectorServerFactory - javax.management.remote 中的 类
用于创建 JMX API 连接器服务器的工厂。
JMXConnectorServerMBean - javax.management.remote 中的 接口
供连接器服务器使用的 MBean 接口。
JMXConnectorServerProvider - javax.management.remote 中的 接口
使用给定的协议创建 JMX API 连接器服务器的提供者。
JMXPrincipal - javax.management.remote 中的 类
JMX Remote API 的远程客户端的身份。
JMXPrincipal(String) - 类 javax.management.remote.JMXPrincipal 的构造方法
为给定的身份创建一个 JMXPrincipal。
JMXProviderException - javax.management.remote 中的 异常
当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
JMXProviderException() - 异常 javax.management.remote.JMXProviderException 的构造方法
构造一个不带指定详细消息的 JMXProviderException。
JMXProviderException(String) - 异常 javax.management.remote.JMXProviderException 的构造方法
构造带指定详细消息的 JMXProviderException。
JMXProviderException(String, Throwable) - 异常 javax.management.remote.JMXProviderException 的构造方法
构造带指定详细消息和嵌套异常的 JMXProviderException。
JMXServerErrorException - javax.management.remote 中的 异常
在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。
JMXServerErrorException(String, Error) - 异常 javax.management.remote.JMXServerErrorException 的构造方法
构造带指定详细消息和嵌套错误的 JMXServerErrorException。
JMXServiceURL - javax.management.remote 中的 类
JMX API 连接器服务器的地址。
JMXServiceURL(String) - 类 javax.management.remote.JMXServiceURL 的构造方法
通过解析 Service URL 字符串来构造 JMXServiceURL。
JMXServiceURL(String, String, int) - 类 javax.management.remote.JMXServiceURL 的构造方法
构造具有给定协议、主机和端口的 JMXServiceURL。
JMXServiceURL(String, String, int, String) - 类 javax.management.remote.JMXServiceURL 的构造方法
构造具有给定部分的 JMXServiceURL。
JNDI_REBIND_ATTRIBUTE - 类 javax.management.remote.rmi.RMIConnectorServer 中的静态变量
属性名称，它指定代表 RMI 连接器服务器的 RMIServer stub 是否应重写位于同一地址的现有 stub。
JOB_CANCELED - 类 javax.print.event.PrintJobEvent 中的静态变量
作业已被 PrintService 取消。
JOB_CANCELED_AT_DEVICE - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
非标识本地用户取消了作业，即在设备控制台的用户取消了作业。
JOB_CANCELED_BY_OPERATOR - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
操作员取消了作业，操作员即用户，其已被授权为具有操作员权限（无论是本地还是远程）。
JOB_CANCELED_BY_USER - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业所有者取消了作业，作业所有者即用户，通过验证的该用户身份与创建 Print Job 的初始用户的值相同，或某位其他授权终端用户，例如作业所有者安全组成员。
JOB_COMPLETE - 类 javax.print.event.PrintJobEvent 中的静态变量
文档已被完全打印。
JOB_COMPLETED_SUCCESSFULLY - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业成功完成。
JOB_COMPLETED_WITH_ERRORS - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业以错误结束（也可能是警告）。
JOB_COMPLETED_WITH_WARNINGS - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业以警告结束。
JOB_DATA_INSUFFICIENT - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机已创建 Print Job，但打印机在可以将作业转为 PROCESSING 状态之前还需要额外的打印数据。
JOB_FAILED - 类 javax.print.event.PrintJobEvent 中的静态变量
打印服务报告无法完成作业。
JOB_HOLD_UNTIL_SPECIFIED - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
为作业的 JobHoldUntil 属性值指定一个将来的日期-时间。
JOB_INCOMING - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机已创建 Print Job，但打印机尚未完成访问或接收所有打印数据。
JOB_INTERPRETING - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据。
JOB_OUTGOING - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机正将作业传输到输出设备。
JOB_PRINTING - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
输出设备为标记介质。
JOB_QUEUED - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机处于 PROCESSING 状态，更明确地讲，打印机已对文档数据排队。
JOB_QUEUED_FOR_MARKER - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机处于 PENDING_HELD、PENDING 或 PROCESSING 状态，更明确地讲，打印机已完成足够的文档处理，能够开始标记且作业正在等待标记。
JOB_RESTARTABLE - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
此作业被保留，且当前可以重新开始。
JOB_TRANSFORMING - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据并生成另一个电子表示形式。
JobAttributes - java.awt 中的 类
控制打印作业的属性集合。
JobAttributes() - 类 java.awt.JobAttributes 的构造方法
构造一个具有每个属性的默认值的 JobAttributes 实例。
JobAttributes(JobAttributes) - 类 java.awt.JobAttributes 的构造方法
构造一个 JobAttributes 实例，作为所提供的 JobAttributes 的副本。
JobAttributes(int, JobAttributes.DefaultSelectionType, JobAttributes.DestinationType, JobAttributes.DialogType, String, int, int, JobAttributes.MultipleDocumentHandlingType, int[][], String, JobAttributes.SidesType) - 类 java.awt.JobAttributes 的构造方法
构造一个具有每个属性指定值的 JobAttributes 实例。
JobAttributes.DefaultSelectionType - java.awt 中的 类
可能的默认选择状态的类型安全的枚举。
JobAttributes.DestinationType - java.awt 中的 类
可能的作业目标的类型安全枚举。
JobAttributes.DialogType - java.awt 中的 类
显示给用户的可能对话框的类型安全枚举。
JobAttributes.MultipleDocumentHandlingType - java.awt 中的 类
可能的多副本处理状态的类型安全枚举。
JobAttributes.SidesType - java.awt 中的 类
可能的多页整版的类型安全枚举。
JobHoldUntil - javax.print.attribute.standard 中的 类
JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
JobHoldUntil(Date) - 类 javax.print.attribute.standard.JobHoldUntil 的构造方法
构造具有给定 Date 值新 JobHoldUntil 属性。
JobImpressions - javax.print.attribute.standard 中的 类
JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
JobImpressions(int) - 类 javax.print.attribute.standard.JobImpressions 的构造方法
构造具有给定整数值的新作业印张属性。
JobImpressionsCompleted - javax.print.attribute.standard 中的 类
JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
JobImpressionsCompleted(int) - 类 javax.print.attribute.standard.JobImpressionsCompleted 的构造方法
构造具有给定整数值的新的 JobImpressionsCompleted 属性。
JobImpressionsSupported - javax.print.attribute.standard 中的 类
JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
JobImpressionsSupported(int, int) - 类 javax.print.attribute.standard.JobImpressionsSupported 的构造方法
构造包含单个整数范围的新的 JobImpressionsSupported 属性。
JobKOctets - javax.print.attribute.standard 中的 类
JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
JobKOctets(int) - 类 javax.print.attribute.standard.JobKOctets 的构造方法
构造具有给定整数值的新 JobKOctets 属性。
JobKOctetsProcessed - javax.print.attribute.standard 中的 类
JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
JobKOctetsProcessed(int) - 类 javax.print.attribute.standard.JobKOctetsProcessed 的构造方法
构造具有给定整数值的新的 JobKOctetsProcessed 属性。
JobKOctetsSupported - javax.print.attribute.standard 中的 类
JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
JobKOctetsSupported(int, int) - 类 javax.print.attribute.standard.JobKOctetsSupported 的构造方法
构造包含单个整数范围的新的 JobKOctetsSupported 属性。
JobMediaSheets - javax.print.attribute.standard 中的 类
JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
JobMediaSheets(int) - 类 javax.print.attribute.standard.JobMediaSheets 的构造方法
构造具有给定整数值的新 JobMediaSheets 属性。
JobMediaSheetsCompleted - javax.print.attribute.standard 中的 类
JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
JobMediaSheetsCompleted(int) - 类 javax.print.attribute.standard.JobMediaSheetsCompleted 的构造方法
构造具有整数值的 JobMediaSheetsCompleted 属性。
JobMediaSheetsSupported - javax.print.attribute.standard 中的 类
Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
JobMediaSheetsSupported(int, int) - 类 javax.print.attribute.standard.JobMediaSheetsSupported 的构造方法
构造包含单个整数范围的新的 JobMediaSheetsSupported 属性。
JobMessageFromOperator - javax.print.attribute.standard 中的 类
JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
JobMessageFromOperator(String, Locale) - 类 javax.print.attribute.standard.JobMessageFromOperator 的构造方法
使用给定消息和语言环境构造新的 JobMessageFromOperator 属性。
JobName - javax.print.attribute.standard 中的 类
JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
JobName(String, Locale) - 类 javax.print.attribute.standard.JobName 的构造方法
构造具有给定作业名称和语言环境的新JobName属性。
JobOriginatingUserName - javax.print.attribute.standard 中的 类
JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
JobOriginatingUserName(String, Locale) - 类 javax.print.attribute.standard.JobOriginatingUserName 的构造方法
构造具有给定用户名称和语言环境的新的 JobOriginatingUserName 属性。
JobPriority - javax.print.attribute.standard 中的 类
JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
JobPriority(int) - 类 javax.print.attribute.standard.JobPriority 的构造方法
构造具有给定整数值的新 JobPriority 属性。
JobPrioritySupported - javax.print.attribute.standard 中的 类
JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
JobPrioritySupported(int) - 类 javax.print.attribute.standard.JobPrioritySupported 的构造方法
构造具有给定整数值的新的 JobPrioritySupported 属性。
JobSheets - javax.print.attribute.standard 中的 类
JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
JobSheets(int) - 类 javax.print.attribute.standard.JobSheets 的构造方法
构造具有给定整数值的新 JobSheets 枚举值。
JobState - javax.print.attribute.standard 中的 类
JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
JobState(int) - 类 javax.print.attribute.standard.JobState 的构造方法
构造具有给定整数值的新 JobState 枚举值。
JobStateReason - javax.print.attribute.standard 中的 类
JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。
JobStateReason(int) - 类 javax.print.attribute.standard.JobStateReason 的构造方法
构造具有给定整数值的新 JobStateReason 枚举值。
JobStateReasons - javax.print.attribute.standard 中的 类
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。
JobStateReasons() - 类 javax.print.attribute.standard.JobStateReasons 的构造方法
构造新的空作业状态原因属性；底层哈希集合具有默认的初始容量和加载因子。
JobStateReasons(int) - 类 javax.print.attribute.standard.JobStateReasons 的构造方法
构造新的空作业状态原因属性；底层哈希集合具有给定的初始容量和默认的加载因子。
JobStateReasons(int, float) - 类 javax.print.attribute.standard.JobStateReasons 的构造方法
构造新的空作业状态原因属性；底层哈希集合具有给定的容量和加载因子。
JobStateReasons(Collection<JobStateReason>) - 类 javax.print.attribute.standard.JobStateReasons 的构造方法
构造新的作业状态原因属性，它包含与给定集合相同的 JobStateReason 对象。
join(long) - 类 java.lang.Thread 中的方法
等待该线程终止的时间最长为 millis 毫秒。
join(long, int) - 类 java.lang.Thread 中的方法
等待该线程终止的时间最长为 millis 毫秒 + nanos 纳秒。
join() - 类 java.lang.Thread 中的方法
等待该线程终止。
join(InetAddress) - 类 java.net.DatagramSocketImpl 中的方法
加入多播组。
JOIN_BEVEL - 类 java.awt.BasicStroke 中的静态变量
通过直线连接宽体轮廓的外角，将路径线段连接在一起。
JOIN_MITER - 类 java.awt.BasicStroke 中的静态变量
扩展路径线段的外边缘，直到它们连接在一起。
JOIN_ROUND - 类 java.awt.BasicStroke 中的静态变量
通过舍去半径为线长的一半的圆角，将路径线段连接在一起。
Joinable - javax.sql.rowset 中的 接口
1.0 背景 Joinable 接口提供了用于获取和设置匹配列的各种方法，匹配列是形成通过将 RowSet 对象添加到 JoinRowSet 对象所形成的 SQL JOIN 的基础。
JoinFractureDirection - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getDirection 的可能值。
joinGroup(SocketAddress, NetworkInterface) - 类 java.net.DatagramSocketImpl 中的方法
加入多播组。
joinGroup(InetAddress) - 类 java.net.MulticastSocket 中的方法
加入多播组。
joinGroup(SocketAddress, NetworkInterface) - 类 java.net.MulticastSocket 中的方法
加入指定接口上的指定多播组。
JoinNextDirection - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getDirection 的可能值。
JoinPreviousDirection - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getDirection 的可能值。
JoinRowSet - javax.sql.rowset 中的 接口
JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
JOptionPane - javax.swing 中的 类
JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
JOptionPane() - 类 javax.swing.JOptionPane 的构造方法
创建一个带有测试消息的 JOptionPane。
JOptionPane(Object) - 类 javax.swing.JOptionPane 的构造方法
创建一个显示消息的 JOptionPane 的实例，使其使用 UI 提供的普通消息消息类型和默认选项。
JOptionPane(Object, int) - 类 javax.swing.JOptionPane 的构造方法
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和默认选项。
JOptionPane(Object, int, int) - 类 javax.swing.JOptionPane 的构造方法
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和选项。
JOptionPane(Object, int, int, Icon) - 类 javax.swing.JOptionPane 的构造方法
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、选项和图标。
JOptionPane(Object, int, int, Icon, Object[]) - 类 javax.swing.JOptionPane 的构造方法
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。
JOptionPane(Object, int, int, Icon, Object[], Object) - 类 javax.swing.JOptionPane 的构造方法
在指定最初选择的选项的前提下，创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。
JOptionPane.AccessibleJOptionPane - javax.swing 中的 类
此类实现对 JOptionPane 类的可访问性支持。
JOptionPane.AccessibleJOptionPane() - 类 javax.swing.JOptionPane.AccessibleJOptionPane 的构造方法
JPanel - javax.swing 中的 类
JPanel 是一般轻量级容器。
JPanel(LayoutManager, boolean) - 类 javax.swing.JPanel 的构造方法
创建具有指定布局管理器和缓冲策略的新 JPanel。
JPanel(LayoutManager) - 类 javax.swing.JPanel 的构造方法
创建具有指定布局管理器的新缓冲 JPanel。
JPanel(boolean) - 类 javax.swing.JPanel 的构造方法
创建具有 FlowLayout 和指定缓冲策略的新 JPanel。
JPanel() - 类 javax.swing.JPanel 的构造方法
创建具有双缓冲和流布局的新 JPanel。
JPanel.AccessibleJPanel - javax.swing 中的 类
此类实现对 JPanel 类的可访问性支持。
JPanel.AccessibleJPanel() - 类 javax.swing.JPanel.AccessibleJPanel 的构造方法
JPasswordField - javax.swing 中的 类
JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
JPasswordField() - 类 javax.swing.JPasswordField 的构造方法
构造一个新 JPasswordField，使其具有默认文档、为 null 的开始文本字符串和为 0 的列宽度。
JPasswordField(String) - 类 javax.swing.JPasswordField 的构造方法
构造一个利用指定文本初始化的新 JPasswordField。
JPasswordField(int) - 类 javax.swing.JPasswordField 的构造方法
构造一个具有指定列数的新的空 JPasswordField。
JPasswordField(String, int) - 类 javax.swing.JPasswordField 的构造方法
构造一个利用指定文本和列初始化的新 JPasswordField。
JPasswordField(Document, String, int) - 类 javax.swing.JPasswordField 的构造方法
构造一个使用给定文本存储模型和给定列数的新 JPasswordField。
JPasswordField.AccessibleJPasswordField - javax.swing 中的 类
此类实现对 JPasswordField 类的可访问性支持。
JPasswordField.AccessibleJPasswordField() - 类 javax.swing.JPasswordField.AccessibleJPasswordField 的构造方法
JPEG - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
JPEG - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
JPEG - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
JPEGHuffmanTable - javax.imageio.plugins.jpeg 中的 类
封装单个 JPEG Huffman 表的类。
JPEGHuffmanTable(short[], short[]) - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 的构造方法
创建一个 Huffman 表并将其初始化。
JPEGImageReadParam - javax.imageio.plugins.jpeg 中的 类
此类添加了使用内置 JPEG reader 插件时设置 JPEG 量化表和 Huffman 表的能力。
JPEGImageReadParam() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 的构造方法
构造一个 JPEGImageReadParam。
JPEGImageWriteParam - javax.imageio.plugins.jpeg 中的 类
此类添加了使用内置 JPEG writer 插件时设置 JPEG 量化表和 Huffman 表以及请求为图像计算最佳 Huffman 表的能力。
JPEGImageWriteParam(Locale) - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 的构造方法
构造一个 JPEGImageWriteParam。
JPEGQTable - javax.imageio.plugins.jpeg 中的 类
封装单个 JPEG 量化表的类。
JPEGQTable(int[]) - 类 javax.imageio.plugins.jpeg.JPEGQTable 的构造方法
根据参数构造一个量化表，该参数必须包含以自然顺序（非 Z 字形顺序）显示的 64 个元素。
JPopupMenu - javax.swing 中的 类
弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
JPopupMenu() - 类 javax.swing.JPopupMenu 的构造方法
构造一个不带“调用者”的 JPopupMenu。
JPopupMenu(String) - 类 javax.swing.JPopupMenu 的构造方法
构造一个具有指定标题的 JPopupMenu。
JPopupMenu.AccessibleJPopupMenu - javax.swing 中的 类
此类实现 JPopupMenu 类的可访问性支持。
JPopupMenu.AccessibleJPopupMenu() - 类 javax.swing.JPopupMenu.AccessibleJPopupMenu 的构造方法
AccessibleJPopupMenu 构造方法
JPopupMenu.Separator - javax.swing 中的 类
弹出与菜单有关的分隔符。
JPopupMenu.Separator() - 类 javax.swing.JPopupMenu.Separator 的构造方法
JProgressBar - javax.swing 中的 类
以可视化形式显示某些任务进度的组件。
JProgressBar() - 类 javax.swing.JProgressBar 的构造方法
创建一个显示边框但不带进度字符串的水平进度条。
JProgressBar(int) - 类 javax.swing.JProgressBar 的构造方法
创建具有指定方向（SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL）的进度条。
JProgressBar(int, int) - 类 javax.swing.JProgressBar 的构造方法
创建具有指定最小值和最大值的水平进度条。
JProgressBar(int, int, int) - 类 javax.swing.JProgressBar 的构造方法
创建使用指定方向、最小值和最大值的进度条。
JProgressBar(BoundedRangeModel) - 类 javax.swing.JProgressBar 的构造方法
创建使用指定的保存进度条数据模型的水平进度条。
JProgressBar.AccessibleJProgressBar - javax.swing 中的 类
此类实现 JProgressBar 类的可访问性支持。
JProgressBar.AccessibleJProgressBar() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 的构造方法
JRadioButton - javax.swing 中的 类
实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
JRadioButton() - 类 javax.swing.JRadioButton 的构造方法
创建一个初始化为未选择的单选按钮，其文本未设定。
JRadioButton(Icon) - 类 javax.swing.JRadioButton 的构造方法
创建一个初始化为未选择的单选按钮，其具有指定的图像但无文本。
JRadioButton(Action) - 类 javax.swing.JRadioButton 的构造方法
创建一个单选按钮，其属性来自提供的 Action。
JRadioButton(Icon, boolean) - 类 javax.swing.JRadioButton 的构造方法
创建一个具有指定图像和选择状态的单选按钮，但无文本。
JRadioButton(String) - 类 javax.swing.JRadioButton 的构造方法
创建一个具有指定文本的状态为未选择的单选按钮。
JRadioButton(String, boolean) - 类 javax.swing.JRadioButton 的构造方法
创建一个具有指定文本和选择状态的单选按钮。
JRadioButton(String, Icon) - 类 javax.swing.JRadioButton 的构造方法
创建一个具有指定的文本和图像并初始化为未选择的单选按钮。
JRadioButton(String, Icon, boolean) - 类 javax.swing.JRadioButton 的构造方法
创建一个具有指定的文本、图像和选择状态的单选按钮。
JRadioButton.AccessibleJRadioButton - javax.swing 中的 类
此类实现对 JRadioButton 类的可访问性支持。
JRadioButton.AccessibleJRadioButton() - 类 javax.swing.JRadioButton.AccessibleJRadioButton 的构造方法
JRadioButtonMenuItem - javax.swing 中的 类
一个单选按钮菜单项的实现。
JRadioButtonMenuItem() - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个未设置文本或图标的 JRadioButtonMenuItem。
JRadioButtonMenuItem(Icon) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个带图标的 JRadioButtonMenuItem。
JRadioButtonMenuItem(String) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个带文本的 JRadioButtonMenuItem。
JRadioButtonMenuItem(Action) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个单选按钮菜单项，其属性来自提供的 Action。
JRadioButtonMenuItem(String, Icon) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个具有指定文本和 Icon 的单选按钮菜单项。
JRadioButtonMenuItem(String, boolean) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个具有指定文本和选择状态的单选按钮菜单项。
JRadioButtonMenuItem(Icon, boolean) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个具有指定图像和选择状态的单选按钮菜单项，但无文本。
JRadioButtonMenuItem(String, Icon, boolean) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个具有指定的文本、图像和选择状态的单选按钮菜单项。
JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem - javax.swing 中的 类
此类实现对 JRadioButtonMenuItem 类的可访问性支持。
JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem() - 类 javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 的构造方法
JRootPane - javax.swing 中的 类
该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
JRootPane() - 类 javax.swing.JRootPane 的构造方法
创建 JRootPane，设置其 glassPane、layeredPane 以及 contentPane。
JRootPane.AccessibleJRootPane - javax.swing 中的 类
此类实现对 JRootPane 类的可访问性支持。
JRootPane.AccessibleJRootPane() - 类 javax.swing.JRootPane.AccessibleJRootPane 的构造方法
JRootPane.RootLayout - javax.swing 中的 类
该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。
JRootPane.RootLayout() - 类 javax.swing.JRootPane.RootLayout 的构造方法
JScrollBar - javax.swing 中的 类
滚动条的实现。
JScrollBar(int, int, int, int, int) - 类 javax.swing.JScrollBar 的构造方法
创建具有指定方向、值、跨度、最小值和最大值的一个滚动条。
JScrollBar(int) - 类 javax.swing.JScrollBar 的构造方法
创建具有指定方向和下列初始值的滚动条：
JScrollBar() - 类 javax.swing.JScrollBar 的构造方法
创建具有下列初始值的垂直滚动条：
JScrollBar.AccessibleJScrollBar - javax.swing 中的 类
此类实现 JScrollBar 类的可访问性支持。
JScrollBar.AccessibleJScrollBar() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 的构造方法
JScrollPane - javax.swing 中的 类
提供轻量级组件的 scrollable 视图。
JScrollPane(Component, int, int) - 类 javax.swing.JScrollPane 的构造方法
创建一个 JScrollPane，它将视图组件显示在一个视口中，视图位置可使用一对滚动条控制。
JScrollPane(Component) - 类 javax.swing.JScrollPane 的构造方法
创建一个显示指定组件内容的 JScrollPane，只要组件的内容超过视图大小就会显示水平和垂直滚动条。
JScrollPane(int, int) - 类 javax.swing.JScrollPane 的构造方法
创建一个具有指定滚动条策略的空（无视口的视图）JScrollPane。
JScrollPane() - 类 javax.swing.JScrollPane 的构造方法
创建一个空的（无视口的视图）JScrollPane，需要时水平和垂直滚动条都可显示。
JScrollPane.AccessibleJScrollPane - javax.swing 中的 类
此类实现 JScrollPane 类的可访问性支持。
JScrollPane.AccessibleJScrollPane() - 类 javax.swing.JScrollPane.AccessibleJScrollPane 的构造方法
AccessibleJScrollPane 构造方法
JScrollPane.ScrollBar - javax.swing 中的 类
默认情况下，JScrollPane 创建的滚动条为此类的实例。
JScrollPane.ScrollBar(int) - 类 javax.swing.JScrollPane.ScrollBar 的构造方法
创建具有指定方向的滚动条。
JSeparator - javax.swing 中的 类
JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
JSeparator() - 类 javax.swing.JSeparator 的构造方法
创建一个新的水平分隔符。
JSeparator(int) - 类 javax.swing.JSeparator 的构造方法
创建一个具有指定水平或者垂直方向的分隔符。
JSeparator.AccessibleJSeparator - javax.swing 中的 类
此类实现 JSeparator 类的可访问性支持。
JSeparator.AccessibleJSeparator() - 类 javax.swing.JSeparator.AccessibleJSeparator 的构造方法
JSlider - javax.swing 中的 类
一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
JSlider() - 类 javax.swing.JSlider 的构造方法
创建一个范围在 0 到 100 之间并且初始值为 50 的水平滑块。
JSlider(int) - 类 javax.swing.JSlider 的构造方法
使用指定的方向创建一个滑块，范围在 0 到 100 之间并且初始值为 50。
JSlider(int, int) - 类 javax.swing.JSlider 的构造方法
使用指定的最小值和最大值创建一个水平滑块，初始值等于最小值加上最大值的平均值。
JSlider(int, int, int) - 类 javax.swing.JSlider 的构造方法
用指定的最小值、最大值和初始值创建一个水平滑块。
JSlider(int, int, int, int) - 类 javax.swing.JSlider 的构造方法
用指定的方向和指定的最小值、最大值以及初始值创建一个滑块。
JSlider(BoundedRangeModel) - 类 javax.swing.JSlider 的构造方法
使用指定的 BoundedRangeModel 创建一个水平滑块。
JSlider.AccessibleJSlider - javax.swing 中的 类
此类实现 JSlider 类的可访问性支持。
JSlider.AccessibleJSlider() - 类 javax.swing.JSlider.AccessibleJSlider 的构造方法
JSpinner - javax.swing 中的 类
让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
JSpinner(SpinnerModel) - 类 javax.swing.JSpinner 的构造方法
构造具有一对 next/previous 按钮和 SpinnerModel 编辑器的完整 spinner。
JSpinner() - 类 javax.swing.JSpinner 的构造方法
构造一个 spinner，使其具有初始值为 0 并且无任何最小值或者最大值限制的 Integer SpinnerNumberModel。
JSpinner.AccessibleJSpinner - javax.swing 中的 类
AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
JSpinner.AccessibleJSpinner() - 类 javax.swing.JSpinner.AccessibleJSpinner 的构造方法
AccessibleJSpinner 构造方法
JSpinner.DateEditor - javax.swing 中的 类
其模型为 SpinnerDateModel 的 JSpinner 编辑器。
JSpinner.DateEditor(JSpinner) - 类 javax.swing.JSpinner.DateEditor 的构造方法
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。
JSpinner.DateEditor(JSpinner, String) - 类 javax.swing.JSpinner.DateEditor 的构造方法
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。
JSpinner.DefaultEditor - javax.swing 中的 类
一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
JSpinner.DefaultEditor(JSpinner) - 类 javax.swing.JSpinner.DefaultEditor 的构造方法
构造一个针对指定 JSpinner 的编辑器组件。
JSpinner.ListEditor - javax.swing 中的 类
其模型为 SpinnerListModel 的 JSpinner 编辑器。
JSpinner.ListEditor(JSpinner) - 类 javax.swing.JSpinner.ListEditor 的构造方法
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerListModel 的值的显示和编辑。
JSpinner.NumberEditor - javax.swing 中的 类
其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
JSpinner.NumberEditor(JSpinner) - 类 javax.swing.JSpinner.NumberEditor 的构造方法
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerNumberModel 值的显示和编辑。
JSpinner.NumberEditor(JSpinner, String) - 类 javax.swing.JSpinner.NumberEditor 的构造方法
构造一个 JSpinner，使其支持具有一个 JFormattedTextField 的 SpinnerNumberModel 的值。
JSplitPane - javax.swing 中的 类
JSplitPane 用于分隔两个（只能两个）Component。
JSplitPane() - 类 javax.swing.JSplitPane 的构造方法
创建一个配置为将其子组件水平排列、无连续布局、为组件使用两个按钮的新 JSplitPane。
JSplitPane(int) - 类 javax.swing.JSplitPane 的构造方法
创建一个配置为指定方向且无连续布局的新 JSplitPane。
JSplitPane(int, boolean) - 类 javax.swing.JSplitPane 的构造方法
创建一个具有指定方向和重绘方式的新 JSplitPane。
JSplitPane(int, Component, Component) - 类 javax.swing.JSplitPane 的构造方法
创建一个具有指定方向和不连续重绘的指定组件的新 JSplitPane。
JSplitPane(int, boolean, Component, Component) - 类 javax.swing.JSplitPane 的构造方法
创建一个具有指定方向、重绘方式和指定组件的新 JSplitPane。
JSplitPane.AccessibleJSplitPane - javax.swing 中的 类
此类实现 JSplitPane 类的可访问性支持。
JSplitPane.AccessibleJSplitPane() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 的构造方法
JTabbedPane - javax.swing 中的 类
一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
JTabbedPane() - 类 javax.swing.JTabbedPane 的构造方法
创建一个具有默认的 JTabbedPane.TOP 选项卡布局的空 TabbedPane。
JTabbedPane(int) - 类 javax.swing.JTabbedPane 的构造方法
创建一个空的 TabbedPane，使其具有以下指定选项卡布局中的一种：JTabbedPane.TOP、JTabbedPane.BOTTOM、JTabbedPane.LEFT 或 JTabbedPane.RIGHT。
JTabbedPane(int, int) - 类 javax.swing.JTabbedPane 的构造方法
创建一个空的 TabbedPane，使其具有指定的选项卡布局和选项卡布局策略。
JTabbedPane.AccessibleJTabbedPane - javax.swing 中的 类
此类实现对 JTabbedPane 类的可访问性支持。
JTabbedPane.AccessibleJTabbedPane() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 的构造方法
构造 AccessibleJTabbedPane。
JTabbedPane.ModelListener - javax.swing 中的 类
将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。
JTabbedPane.ModelListener() - 类 javax.swing.JTabbedPane.ModelListener 的构造方法
JTable - javax.swing 中的 类
JTable 用来显示和编辑常规二维单元表。
JTable() - 类 javax.swing.JTable 的构造方法
构造一个默认的 JTable，使用默认的数据模型、默认的列模型和默认的选择模型对其进行初始化。
JTable(TableModel) - 类 javax.swing.JTable 的构造方法
构造一个 JTable，使用数据模型 dm、默认的列模型和默认的选择模型对其进行初始化。
JTable(TableModel, TableColumnModel) - 类 javax.swing.JTable 的构造方法
构造一个 JTable，使用数据模型 dm、列模型 cm 和默认的选择模型对其进行初始化。
JTable(TableModel, TableColumnModel, ListSelectionModel) - 类 javax.swing.JTable 的构造方法
构造一个 JTable，使用数据模型 dm、列模型 cm 和选择模型 sm 对其进行初始化。
JTable(int, int) - 类 javax.swing.JTable 的构造方法
使用 DefaultTableModel 构造具有 numRows 行和 numColumns 列个空单元格的 JTable。
JTable(Vector, Vector) - 类 javax.swing.JTable 的构造方法
构造一个 JTable 来显示 Vector 所组成的 Vector rowData 中的值，其列名称为 columnNames。
JTable(Object[][], Object[]) - 类 javax.swing.JTable 的构造方法
构造一个 JTable 来显示二维数组 rowData 中的值，其列名称为 columnNames。
JTable.AccessibleJTable - javax.swing 中的 类
此类实现对 JTable 类的可访问性支持。
JTable.AccessibleJTable() - 类 javax.swing.JTable.AccessibleJTable 的构造方法
AccessibleJTable 构造方法
JTable.AccessibleJTable.AccessibleJTableCell - javax.swing 中的 类
此类提供了适用于表单元格的 Java Accessibility API 实现。
JTable.AccessibleJTable.AccessibleJTableCell(JTable, int, int, int) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 的构造方法
构造一个 AccessibleJTableHeaderEntry。
JTable.AccessibleJTable.AccessibleJTableModelChange - javax.swing 中的 类
JTable.AccessibleJTable.AccessibleJTableModelChange(int, int, int, int, int) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 的构造方法
JTable.DropLocation - javax.swing 中的 类
TransferHandler.DropLocation 的一个子类，表示 JTable 的放置位置 (drop location)。
JTable.PrintMode - javax.swing 中的 枚举
用于打印 JTable 的打印模式。
JTableHeader - javax.swing.table 中的 类
这是管理 JTable 的头的对象。
JTableHeader() - 类 javax.swing.table.JTableHeader 的构造方法
构造具有默认 TableColumnModel 的 JTableHeader。
JTableHeader(TableColumnModel) - 类 javax.swing.table.JTableHeader 的构造方法
构造 JTableHeader，使用 cm 作为列模型对其进行初始化。
JTableHeader.AccessibleJTableHeader - javax.swing.table 中的 类
此类实现对 JTableHeader 类的可访问性支持。
JTableHeader.AccessibleJTableHeader() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader 的构造方法
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry - javax.swing.table 中的 类
此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int, JTableHeader, JTable) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 的构造方法
构造一个 AccessiblJTableHeaaderEntry
JTextArea - javax.swing 中的 类
JTextArea 是一个显示纯文本的多行区域。
JTextArea() - 类 javax.swing.JTextArea 的构造方法
构造新的 TextArea。
JTextArea(String) - 类 javax.swing.JTextArea 的构造方法
构造显示指定文本的新的 TextArea。
JTextArea(int, int) - 类 javax.swing.JTextArea 的构造方法
构造具有指定行数和列数的新的空 TextArea。
JTextArea(String, int, int) - 类 javax.swing.JTextArea 的构造方法
构造具有指定文本、行数和列数的新的 TextArea。
JTextArea(Document) - 类 javax.swing.JTextArea 的构造方法
构造新的 JTextArea，使其具有给定的文档模型，所有其他参数均默认为 (null, 0, 0)。
JTextArea(Document, String, int, int) - 类 javax.swing.JTextArea 的构造方法
构造具有指定行数和列数以及给定模型的新的 JTextArea。
JTextArea.AccessibleJTextArea - javax.swing 中的 类
此类实现对 JTextArea 类的可访问性支持。
JTextArea.AccessibleJTextArea() - 类 javax.swing.JTextArea.AccessibleJTextArea 的构造方法
JTextComponent - javax.swing.text 中的 类
JTextComponent 是 swing 文本组件的基类。
JTextComponent() - 类 javax.swing.text.JTextComponent 的构造方法
创建一个新的 JTextComponent。
JTextComponent.AccessibleJTextComponent - javax.swing.text 中的 类
此类实现 JTextComponent 类的可访问性支持。
JTextComponent.AccessibleJTextComponent() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 的构造方法
构造 AccessibleJTextComponent。
JTextComponent.DropLocation - javax.swing.text 中的 类
表示 JTextComponent 的放置位置 (drop location)。
JTextComponent.KeyBinding - javax.swing.text 中的 类
用于创建键绑定的绑定记录。
JTextComponent.KeyBinding(KeyStroke, String) - 类 javax.swing.text.JTextComponent.KeyBinding 的构造方法
创建新的键绑定。
JTextField - javax.swing 中的 类
JTextField 是一个轻量级组件，它允许编辑单行文本。
JTextField() - 类 javax.swing.JTextField 的构造方法
构造一个新的 TextField。
JTextField(String) - 类 javax.swing.JTextField 的构造方法
构造一个用指定文本初始化的新 TextField。
JTextField(int) - 类 javax.swing.JTextField 的构造方法
构造一个具有指定列数的新的空 TextField。
JTextField(String, int) - 类 javax.swing.JTextField 的构造方法
构造一个用指定文本和列初始化的新 TextField。
JTextField(Document, String, int) - 类 javax.swing.JTextField 的构造方法
构造一个新的 JTextField，它使用给定文本存储模型和给定的列数。
JTextField.AccessibleJTextField - javax.swing 中的 类
此类实现对 JTextField 类的可访问性支持。
JTextField.AccessibleJTextField() - 类 javax.swing.JTextField.AccessibleJTextField 的构造方法
JTextPane - javax.swing 中的 类
可以用以图形方式表示的属性来标记的文本组件。
JTextPane() - 类 javax.swing.JTextPane 的构造方法
创建一个新的 JTextPane。
JTextPane(StyledDocument) - 类 javax.swing.JTextPane 的构造方法
创建具有指定文档模型的新 JTextPane。
JToggleButton - javax.swing 中的 类
具有两个状态的（two-state）按钮的实现。
JToggleButton() - 类 javax.swing.JToggleButton 的构造方法
创建最初未选定的切换按钮，不设置文本或图像。
JToggleButton(Icon) - 类 javax.swing.JToggleButton 的构造方法
创建一个最初未选定的切换按钮，该按钮具有指定的图像但是没有文本。
JToggleButton(Icon, boolean) - 类 javax.swing.JToggleButton 的构造方法
创建具有指定图像和选择状态但没有文本的切换按钮。
JToggleButton(String) - 类 javax.swing.JToggleButton 的构造方法
创建具有指定文本的未选定的切换按钮。
JToggleButton(String, boolean) - 类 javax.swing.JToggleButton 的构造方法
创建具有指定文本和选择状态的切换按钮。
JToggleButton(Action) - 类 javax.swing.JToggleButton 的构造方法
创建一个切换按钮，其属性从所提供的 Action 获取。
JToggleButton(String, Icon) - 类 javax.swing.JToggleButton 的构造方法
创建一个最初未选定的切换按钮，该按钮具有指定的文本和图像。
JToggleButton(String, Icon, boolean) - 类 javax.swing.JToggleButton 的构造方法
创建具有指定文本、图像和选择状态的切换按钮。
JToggleButton.AccessibleJToggleButton - javax.swing 中的 类
此类实现对 JToggleButton 类的可访问性支持。
JToggleButton.AccessibleJToggleButton() - 类 javax.swing.JToggleButton.AccessibleJToggleButton 的构造方法
JToggleButton.ToggleButtonModel - javax.swing 中的 类
ToggleButton 模型。
JToggleButton.ToggleButtonModel() - 类 javax.swing.JToggleButton.ToggleButtonModel 的构造方法
创建一个新的 ToggleButton Model
JToolBar - javax.swing 中的 类
JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
JToolBar() - 类 javax.swing.JToolBar 的构造方法
创建新的工具栏；默认的方向为 HORIZONTAL。
JToolBar(int) - 类 javax.swing.JToolBar 的构造方法
创建具有指定 orientation 的新工具栏。
JToolBar(String) - 类 javax.swing.JToolBar 的构造方法
创建一个具有指定 name 的新工具栏。
JToolBar(String, int) - 类 javax.swing.JToolBar 的构造方法
创建一个具有指定 name 和 orientation 的新工具栏。
JToolBar.AccessibleJToolBar - javax.swing 中的 类
此类实现对 JToolBar 类的可访问性支持。
JToolBar.AccessibleJToolBar() - 类 javax.swing.JToolBar.AccessibleJToolBar 的构造方法
JToolBar.Separator - javax.swing 中的 类
一个特定于工具栏的分隔符。
JToolBar.Separator() - 类 javax.swing.JToolBar.Separator 的构造方法
创建一个新的工具栏分隔符，使其具有当前外观定义的默认大小。
JToolBar.Separator(Dimension) - 类 javax.swing.JToolBar.Separator 的构造方法
创建具有指定大小的新的工具栏分隔符。
JToolTip - javax.swing 中的 类
用来显示 Component 的“提示”。
JToolTip() - 类 javax.swing.JToolTip 的构造方法
创建一个工具提示。
JToolTip.AccessibleJToolTip - javax.swing 中的 类
此类实现对 JToolTip 类的可访问性支持。
JToolTip.AccessibleJToolTip() - 类 javax.swing.JToolTip.AccessibleJToolTip 的构造方法
JTree - javax.swing 中的 类
将分层数据集显示为轮廓的控件。
JTree() - 类 javax.swing.JTree 的构造方法
返回带有示例模型的 JTree。
JTree(Object[]) - 类 javax.swing.JTree 的构造方法
返回 JTree，指定数组的每个元素作为不被显示的新根节点的子节点。
JTree(Vector<?>) - 类 javax.swing.JTree 的构造方法
返回 JTree，指定 Vector 的每个元素作为不被显示的新根节点的子节点。
JTree(Hashtable<?, ?>) - 类 javax.swing.JTree 的构造方法
返回从 Hashtable 创建的 JTree，它不显示根。
JTree(TreeNode) - 类 javax.swing.JTree 的构造方法
返回 JTree，指定的 TreeNode 作为其根，它显示根节点。
JTree(TreeNode, boolean) - 类 javax.swing.JTree 的构造方法
返回 JTree，指定的 TreeNode 作为其根，它用指定的方式显示根节点，并确定节点是否为叶节点。
JTree(TreeModel) - 类 javax.swing.JTree 的构造方法
返回 JTree 的一个实例，它显示根节点 - 使用指定的数据模型创建树。
JTree.AccessibleJTree - javax.swing 中的 类
此类实现 JTree 类的可访问性支持。
JTree.AccessibleJTree() - 类 javax.swing.JTree.AccessibleJTree 的构造方法
JTree.AccessibleJTree.AccessibleJTreeNode - javax.swing 中的 类
此类实现 JTree 子类的可访问性支持。
JTree.AccessibleJTree.AccessibleJTreeNode(JTree, TreePath, Accessible) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 的构造方法
构造一个 AccessibleJTreeNode
JTree.DropLocation - javax.swing 中的 类
TransferHandler.DropLocation 的一个子类，表示 JTree 的放置位置 (drop location)。
JTree.DynamicUtilTreeNode - javax.swing 中的 类
DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。
JTree.DynamicUtilTreeNode(Object, Object) - 类 javax.swing.JTree.DynamicUtilTreeNode 的构造方法
使用指定的对象作为其值并使用指定的子节点创建一个节点。
JTree.EmptySelectionModel - javax.swing 中的 类
EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。
JTree.EmptySelectionModel() - 类 javax.swing.JTree.EmptySelectionModel 的构造方法
JTree.TreeModelHandler - javax.swing 中的 类
在移除或更改节点时，监听模型并相应地更新 expandedState。
JTree.TreeModelHandler() - 类 javax.swing.JTree.TreeModelHandler 的构造方法
JTree.TreeSelectionRedirector - javax.swing 中的 类
使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。
JTree.TreeSelectionRedirector() - 类 javax.swing.JTree.TreeSelectionRedirector 的构造方法
JULY - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第七个月的 Calendar.MONTH 字段值。
JULY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第七个月的值。
JUNE - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第六个月的 Calendar.MONTH 字段值。
JUNE - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第六个月的值。
JUSTIFICATION - 类 java.awt.font.TextAttribute 中的静态变量
段落调整的属性键。
JUSTIFICATION_FULL - 类 java.awt.font.TextAttribute 中的静态变量
将线条调整到完整的请求宽度。
JUSTIFICATION_NONE - 类 java.awt.font.TextAttribute 中的静态变量
不允许调整线条。
JViewport - javax.swing 中的 类
用于查看底层信息的“视口”或“观察孔”。
JViewport() - 类 javax.swing.JViewport 的构造方法
创建一个 JViewport。
JViewport.AccessibleJViewport - javax.swing 中的 类
此类实现对 JViewport 类的可访问性支持。
JViewport.AccessibleJViewport() - 类 javax.swing.JViewport.AccessibleJViewport 的构造方法
JViewport.ViewListener - javax.swing 中的 类
视图的侦听器。
JViewport.ViewListener() - 类 javax.swing.JViewport.ViewListener 的构造方法
JWindow - javax.swing 中的 类
JWindow 是一个容器，可以显示在用户桌面上的任何位置。
JWindow() - 类 javax.swing.JWindow 的构造方法
创建未指定所有者的窗口。
JWindow(GraphicsConfiguration) - 类 javax.swing.JWindow 的构造方法
使用屏幕设备的指定 GraphicsConfiguration 创建窗口。
JWindow(Frame) - 类 javax.swing.JWindow 的构造方法
使用指定的所有者框架创建窗口。
JWindow(Window) - 类 javax.swing.JWindow 的构造方法
使用指定的所有者窗口创建窗口。
JWindow(Window, GraphicsConfiguration) - 类 javax.swing.JWindow 的构造方法
使用屏幕设备的指定所有者窗口和 GraphicsConfiguration 创建窗口。
JWindow.AccessibleJWindow - javax.swing 中的 类
此类实现对 JWindow 类的可访问性支持。
JWindow.AccessibleJWindow() - 类 javax.swing.JWindow.AccessibleJWindow 的构造方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


K - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

K

K1Div2Luminance - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的静态变量
在 JPEG 规范的表 K.1 中给出的样本亮度量化表，其中所有元素都除以 2。
K1Luminance - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的静态变量
在 JPEG 规范的表 K.1 中给出的样本亮度量化表。
K2Chrominance - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的静态变量
在 JPEG 规范的表 K.2 中给出的样本色度量化表。
K2Div2Chrominance - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的静态变量
在 JPEG 规范的表 K.2 中给出的样本色度量化表，其中所有元素都除以 2。
KAKU_0 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #0 信封尺寸，287 mm × 382 mm。
KAKU_1 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #1 信封尺寸，270 mm × 382 mm。
KAKU_2 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #2 信封尺寸，240 mm × 332 mm。
KAKU_20 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #20 信封尺寸，229 mm × 324 mm。
KAKU_3 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #3 信封尺寸，216 mm × 277 mm。
KAKU_4 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #4 信封尺寸，197 mm × 267 mm。
KAKU_5 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #5 信封尺寸，190 mm by 240 mm。
KAKU_6 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #6 信封尺寸，162 mm × 229 mm。
KAKU_7 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #7 信封尺寸，142 mm × 205 mm。
KAKU_8 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #8 信封尺寸，119 mm × 197 mm。
KAKU_A4 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") A4 信封尺寸，228 mm × 312 mm。
KANBUN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Kanbun”Unicode 字符块的常量。
KANGXI_RADICALS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Kangxi Radicals”Unicode 字符块的常量。
KANJI - 类 java.awt.im.InputSubset 中的静态变量
编写日语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的日语汉字字集。
KANNADA - 类 java.awt.font.NumericShaper 中的静态变量
标识 KANNADA 范围和十进制基数。
KANNADA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Kannada”Unicode 字符块的常量。
KATAKANA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Katakana”Unicode 字符块的常量。
KATAKANA_PHONETIC_EXTENSIONS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Katakana Phonetic Extensions”Unicode 字符块的常量。
KBD - 类 javax.swing.text.html.HTML.Tag 中的静态变量
KEEP - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "keep"，某些属性的可能值。
KEEP - 接口 java.util.jar.Pack200.Unpacker 中的静态变量
字符串 "keep"，某些属性的可能值。
KEEP_CURRENT_RESULT - 接口 java.sql.Statement 中的静态变量
该常量指示调用 getMoreResults 时应该关闭当前 ResultSet 对象。
KEEP_FILE_ORDER - 接口 java.util.jar.Pack200.Packer 中的静态变量
如果将此属性设置为 Pack200.Packer.TRUE，则打包器将按它们在源存档中的原始顺序传输所有元素。
KerberosKey - javax.security.auth.kerberos 中的 类
此类为 Kerberos 主体封装一个长期秘密密钥。
KerberosKey(KerberosPrincipal, byte[], int, int) - 类 javax.security.auth.kerberos.KerberosKey 的构造方法
当已知密钥类型和密钥版本号时，根据给出的字节构造 KerberosKey。
KerberosKey(KerberosPrincipal, char[], String) - 类 javax.security.auth.kerberos.KerberosKey 的构造方法
根据主体的密码构造 KerberosKey。
KerberosPrincipal - javax.security.auth.kerberos 中的 类
此类封装 Kerberos 主体。
KerberosPrincipal(String) - 类 javax.security.auth.kerberos.KerberosPrincipal 的构造方法
根据提供的字符串输入构造 KerberosPrincipal。
KerberosPrincipal(String, int) - 类 javax.security.auth.kerberos.KerberosPrincipal 的构造方法
根据提供的字符串和名称类型输入构造 KerberosPrincipal。
KerberosTicket - javax.security.auth.kerberos 中的 类
此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。
KerberosTicket(byte[], KerberosPrincipal, KerberosPrincipal, byte[], int, boolean[], Date, Date, Date, Date, InetAddress[]) - 类 javax.security.auth.kerberos.KerberosTicket 的构造方法
使用客户端从 KDC 接收的或从缓存中读取的证书信息构造 KerberosTicket。
Kernel - java.awt.image 中的 类
Kernel 类定义了一个矩阵，描述指定的像素及其周围像素如何影响过滤操作输出图像中像素位置的计算值。
Kernel(int, int, float[]) - 类 java.awt.image.Kernel 的构造方法
根据 float 数组构造一个 Kernel 对象。
KERNING - 类 java.awt.font.TextAttribute 中的静态变量
请求进行字距调整的属性键。
KERNING_ON - 类 java.awt.font.TextAttribute 中的静态变量
请求标准字距调整。
key - 类 java.awt.Event 中的变量
在键盘事件中被按下的键的键代码。
Key - java.security 中的 接口
Key 是所有密钥的顶层接口。
key - 类 javax.accessibility.AccessibleBundle 中的变量
与语言环境无关的状态名称。
key - 类 javax.swing.text.JTextComponent.KeyBinding 中的变量
键。
KEY_ACTION - 类 java.awt.Event 中的静态变量
用户已经按下一个非 ASCII action 键。
KEY_ACTION_RELEASE - 类 java.awt.Event 中的静态变量
用户已经释放一个非 ASCII action 键。
KEY_ALPHA_INTERPOLATION - 类 java.awt.RenderingHints 中的静态变量
Alpha 插值提示键。
KEY_ANTIALIASING - 类 java.awt.RenderingHints 中的静态变量
抗锯齿提示键。
KEY_COLOR_RENDERING - 类 java.awt.RenderingHints 中的静态变量
颜色呈现提示键。
KEY_DITHERING - 类 java.awt.RenderingHints 中的静态变量
抖动提示键。
KEY_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择键事件的事件掩码。
KEY_FIRST - 类 java.awt.event.KeyEvent 中的静态变量
用于键事件的 id 范围的起始编号。
KEY_FRACTIONALMETRICS - 类 java.awt.RenderingHints 中的静态变量
字体小数规格提示键。
KEY_INTERPOLATION - 类 java.awt.RenderingHints 中的静态变量
插值提示键。
KEY_LAST - 类 java.awt.event.KeyEvent 中的静态变量
用于键事件的 id 范围的结束编号。
KEY_LOCATION_LEFT - 类 java.awt.event.KeyEvent 中的静态变量
该常量指示按下或释放的键位于左侧（此键的位置有多种可能性）。
KEY_LOCATION_NUMPAD - 类 java.awt.event.KeyEvent 中的静态变量
该常量指示按键事件发自于数字键盘或对应于数字键盘的虚拟键。
KEY_LOCATION_RIGHT - 类 java.awt.event.KeyEvent 中的静态变量
该常量指示按下或释放的键位于右侧（此键的位置有多种可能性）。
KEY_LOCATION_STANDARD - 类 java.awt.event.KeyEvent 中的静态变量
该常量指示按下或释放的键不区分左右，并且不是发自数字键盘（或者不是发自对应于数字键盘的虚拟键）。
KEY_LOCATION_UNKNOWN - 类 java.awt.event.KeyEvent 中的静态变量
指示 keyLocation 为不确定或不相关的常量。
KEY_PRESS - 类 java.awt.Event 中的静态变量
用户已经按下一个常规键。
KEY_PRESSED - 类 java.awt.event.KeyEvent 中的静态变量
“按下键”事件。
KEY_RELEASE - 类 java.awt.Event 中的静态变量
用户已经释放一个常规键。
KEY_RELEASED - 类 java.awt.event.KeyEvent 中的静态变量
“释放键”事件。
KEY_RENDERING - 类 java.awt.RenderingHints 中的静态变量
呈现提示键。
KEY_STROKE_CONTROL - 类 java.awt.RenderingHints 中的静态变量
笔划规范化控制提示键。
KEY_TEXT_ANTIALIASING - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示键。
KEY_TEXT_LCD_CONTRAST - 类 java.awt.RenderingHints 中的静态变量
LCD 文本对比呈现提示键。
KEY_TYPED - 类 java.awt.event.KeyEvent 中的静态变量
“键入键”事件。
KeyAdapter - java.awt.event 中的 类
接收键盘事件的抽象适配器类。
KeyAdapter() - 类 java.awt.event.KeyAdapter 的构造方法
KeyAgreement - javax.crypto 中的 类
此类提供密钥协定（或密钥交换）协议的功能。
KeyAgreement(KeyAgreementSpi, Provider, String) - 类 javax.crypto.KeyAgreement 的构造方法
创建一个 KeyAgreement 对象。
KeyAgreementSpi - javax.crypto 中的 类
此类为 KeyAgreement 类定义了服务提供者接口 (SPI)。
KeyAgreementSpi() - 类 javax.crypto.KeyAgreementSpi 的构造方法
KeyAlreadyExistsException - javax.management.openmbean 中的 异常
当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。
KeyAlreadyExistsException() - 异常 javax.management.openmbean.KeyAlreadyExistsException 的构造方法
不带详细消息的 KeyAlreadyExistsException。
KeyAlreadyExistsException(String) - 异常 javax.management.openmbean.KeyAlreadyExistsException 的构造方法
带详细消息的 KeyAlreadyExistsException。
KEYBOARD_DIVIDER_MOVE_OFFSET - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的静态变量
通过键盘上的光标键移动分隔符时移动的距离（相对）。
keyboardDownRightListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
keyboardEndListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
KeyboardFocusManager - java.awt 中的 类
KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。
KeyboardFocusManager() - 类 java.awt.KeyboardFocusManager 的构造方法
初始化 KeyboardFocusManager。
keyboardHomeListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
keyboardResizeToggleListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
keyboardUpLeftListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
keyDown(Event, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
keyEqualsCharSet() - 异常 javax.swing.text.ChangedCharSetException 中的方法
KeyEvent - java.awt.event 中的 类
表示组件中发生键击的事件。
KeyEvent(Component, int, long, int, int, char, int) - 类 java.awt.event.KeyEvent 的构造方法
KeyEvent(Component, int, long, int, int, char) - 类 java.awt.event.KeyEvent 的构造方法
构造一个 KeyEvent 对象。
KeyEvent(Component, int, long, int, int) - 类 java.awt.event.KeyEvent 的构造方法
已过时。 从 JDK1.1 开始
KeyEventDispatcher - java.awt 中的 接口
在指派所有 KeyEvent 和为其确定目标时，KeyEventDispatcher 和当前 KeyboardFocusManager 一起使用。
KeyEventPostProcessor - java.awt 中的 接口
在最终解析所有未使用的 KeyEvent 时，需要将 KeyEventPostProcessor 和当前的 KeyboardFocusManager 一起使用。
KeyException - java.security 中的 异常
此异常是基本的密钥异常。
KeyException() - 异常 java.security.KeyException 的构造方法
构造不带详细消息的 KeyException。
KeyException(String) - 异常 java.security.KeyException 的构造方法
构造带指定详细消息的 KeyException。
KeyException(String, Throwable) - 异常 java.security.KeyException 的构造方法
创建带指定详细消息和 cause 的 KeyException。
KeyException(Throwable) - 异常 java.security.KeyException 的构造方法
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyFactory - java.security 中的 类
密钥工厂用于将密钥（Key 类型的不透明加密密钥）转换成密钥规范（底层密钥材料的透明表示），反之亦然。
KeyFactory(KeyFactorySpi, Provider, String) - 类 java.security.KeyFactory 的构造方法
创建一个 KeyFactory 对象。
KeyFactorySpi - java.security 中的 类
此类为 KeyFactory 类定义服务提供者接口 (SPI)。
KeyFactorySpi() - 类 java.security.KeyFactorySpi 的构造方法
keyFor(Selector) - 类 java.nio.channels.SelectableChannel 中的方法
获取表示通道向给定选择器注册的键。
keyFor(Selector) - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
KeyGenerator - javax.crypto 中的 类
此类提供（对称）密钥生成器的功能。
KeyGenerator(KeyGeneratorSpi, Provider, String) - 类 javax.crypto.KeyGenerator 的构造方法
创建一个 KeyGenerator 对象。
KeyGeneratorSpi - javax.crypto 中的 类
此类为 KeyGenerator 类定义了服务提供者接口 (SPI)。
KeyGeneratorSpi() - 类 javax.crypto.KeyGeneratorSpi 的构造方法
KeyInfo - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyInfo 元素的表示形式。
KeyInfoFactory - javax.xml.crypto.dsig.keyinfo 中的 类
用于从头创建 KeyInfo 对象或从相应的 XML 表示形式解组 KeyInfo 对象的工厂。
KeyInfoFactory() - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 的构造方法
默认的构造方法，由子类调用。
KeyListener - java.awt.event 中的 接口
用于接收键盘事件（击键）的侦听器接口。
keyListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
keyListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
keyListener - 类 javax.swing.plaf.basic.BasicTableUI 中的变量
KeyManagementException - java.security 中的 异常
此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
KeyManagementException() - 异常 java.security.KeyManagementException 的构造方法
构造不带详细消息的 KeyManagementException。
KeyManagementException(String) - 异常 java.security.KeyManagementException 的构造方法
构造带指定详细消息的 KeyManagementException。
KeyManagementException(String, Throwable) - 异常 java.security.KeyManagementException 的构造方法
创建带指定详细消息和 cause 的 KeyManagementException。
KeyManagementException(Throwable) - 异常 java.security.KeyManagementException 的构造方法
创建带指定 cause 和详细消息的 KeyManagementException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyManager - javax.net.ssl 中的 接口
这是用于 JSSE 密钥管理器的基接口。
KeyManagerFactory - javax.net.ssl 中的 类
此类充当基于密钥内容源的密钥管理器的工厂。
KeyManagerFactory(KeyManagerFactorySpi, Provider, String) - 类 javax.net.ssl.KeyManagerFactory 的构造方法
创建 KeyManagerFactory 对象。
KeyManagerFactorySpi - javax.net.ssl 中的 类
此类为 KeyManagerFactory 类定义了服务提供者接口 (SPI)。
KeyManagerFactorySpi() - 类 javax.net.ssl.KeyManagerFactorySpi 的构造方法
Keymap - javax.swing.text 中的 接口
将 KeyStroke 绑定到操作的集合。
KeyName - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyName 元素的表示形式。
KeyPair - java.security 中的 类
此类是简单的密钥对（公钥和私钥）持有者。
KeyPair(PublicKey, PrivateKey) - 类 java.security.KeyPair 的构造方法
根据给定的公钥和私钥构造密钥对。
KeyPairGenerator - java.security 中的 类
KeyPairGenerator 类用于生成公钥和私钥对。
KeyPairGenerator(String) - 类 java.security.KeyPairGenerator 的构造方法
为指定的算法创建 KeyPairGenerator 对象。
KeyPairGeneratorSpi - java.security 中的 类
此类为用来生成公钥和私钥的 KeyPairGenerator 类定义了服务提供者接口 (SPI)。
KeyPairGeneratorSpi() - 类 java.security.KeyPairGeneratorSpi 的构造方法
keyPress(int) - 类 java.awt.Robot 中的方法
按下给定的键。
keyPressed(KeyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 keyPressed 方法处理 keyPressed 事件。
keyPressed(KeyEvent) - 类 java.awt.event.KeyAdapter 中的方法
按下某个键时调用此方法。
keyPressed(KeyEvent) - 接口 java.awt.event.KeyListener 中的方法
按下某个键时调用此方法。
keyPressed(KeyEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler 中的方法
keyPressed(KeyEvent) - 类 javax.swing.plaf.basic.BasicTableUI.KeyHandler 中的方法
keyPressed(KeyEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 中的方法
keyRelease(int) - 类 java.awt.Robot 中的方法
释放给定的键。
keyReleased(KeyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 keyReleased 方法处理 keyReleased 事件。
keyReleased(KeyEvent) - 类 java.awt.event.KeyAdapter 中的方法
释放某个键时调用此方法。
keyReleased(KeyEvent) - 接口 java.awt.event.KeyListener 中的方法
释放某个键时调用此方法。
keyReleased(KeyEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler 中的方法
keyReleased(KeyEvent) - 类 javax.swing.plaf.basic.BasicTableUI.KeyHandler 中的方法
keyReleased(KeyEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 中的方法
KeyRep - java.security 中的 类
已序列化的 Key 对象的标准表示形式。
KeyRep(KeyRep.Type, String, String, byte[]) - 类 java.security.KeyRep 的构造方法
构造替换的 Key 类。
KeyRep.Type - java.security 中的 枚举
Key 类型。
keys() - 类 java.nio.channels.Selector 中的方法
返回此选择器的键集。
keys() - 类 java.security.Provider 中的方法
keys() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此表中键的枚举。
keys() - 类 java.util.Dictionary 中的方法
返回此 dictionary 中的键的枚举。
keys() - 类 java.util.Hashtable 中的方法
返回此哈希表中的键的枚举。
keys() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.keys() 中的规范实现 keys 方法。
keys() - 类 java.util.prefs.Preferences 中的方法
返回在此首选项节点中具有关联值的所有键。
keys() - 类 javax.swing.ActionMap 中的方法
返回此 ActionMap 中绑定的 Action 名称。
keys() - 类 javax.swing.InputMap 中的方法
返回绑定在此 InputMap 中的 KeyStroke。
keySelectionManager - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
KeySelector - javax.xml.crypto 中的 类
一个选择器，可使用 KeyInfo 对象中包含的数据查找并返回某个密钥。
KeySelector() - 类 javax.xml.crypto.KeySelector 的构造方法
默认的不带参数的构造方法；仅由子类调用。
KeySelector.Purpose - javax.xml.crypto 中的 类
将被选中的密钥的用途。
KeySelectorException - javax.xml.crypto 中的 异常
指示由 KeySelector 抛出的异常条件。
KeySelectorException() - 异常 javax.xml.crypto.KeySelectorException 的构造方法
构造用 null 作为其详细消息的新 KeySelectorException。
KeySelectorException(String) - 异常 javax.xml.crypto.KeySelectorException 的构造方法
构造带指定详细信息的新 KeySelectorException。
KeySelectorException(String, Throwable) - 异常 javax.xml.crypto.KeySelectorException 的构造方法
构造带指定详细消息和 cause 的新 KeySelectorException。
KeySelectorException(Throwable) - 异常 javax.xml.crypto.KeySelectorException 的构造方法
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 KeySelectorException（它通常包含 cause 的类和详细消息）。
KeySelectorResult - javax.xml.crypto 中的 接口
由 KeySelector.select 方法返回的结果。
keySet() - 类 java.awt.RenderingHints 中的方法
返回此 RenderingHints 中所包含键的 Set 视图。
keySet() - 类 java.security.Provider 中的方法
返回此 provider 中所包含的属性键的一个不可修改的 Set 视图。
keySet() - 类 java.util.AbstractMap 中的方法
返回此映射中包含的键的 Set 视图。
keySet() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此映射中包含的键的 Set 视图。
keySet() - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
返回此映射中所包含键的 NavigableSet 视图。
keySet() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回此映射中所包含键的 NavigableSet 视图。
keySet() - 类 java.util.EnumMap 中的方法
返回此映射中所包含键的 Set 视图。
keySet() - 类 java.util.HashMap 中的方法
返回此映射中所包含的键的 Set 视图。
keySet() - 类 java.util.Hashtable 中的方法
返回此映射中包含的键的 Set 视图。
keySet() - 类 java.util.IdentityHashMap 中的方法
返回映射中所包含键的基于标识的 set 视图。
keySet() - 类 java.util.jar.Attributes 中的方法
返回此 Map 所包含的属性名称（键）的 Set 视图。
keySet() - 接口 java.util.Map 中的方法
返回此映射中包含的键的 Set 视图。
keySet() - 类 java.util.ResourceBundle 中的方法
返回此 ResourceBundle 及其父包中包含的所有键的 Set。
keySet() - 接口 java.util.SortedMap 中的方法
返回在此映射中所包含键的 Set 视图。
keySet() - 类 java.util.TreeMap 中的方法
返回此映射包含的键的 Set 视图。
keySet() - 类 java.util.WeakHashMap 中的方法
返回此映射所包含的键的 Set 视图。
keySet() - 类 javax.management.openmbean.CompositeType 中的方法
返回此 CompositeType 实例定义的所有项名称的不可修改的 Set 视图。
keySet() - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例中包含的 CompositeData 值（即各行）的键（即索引值）的 set 视图。
keySet() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回包含在此 TabularDataSupport 实例的基础映射中的键的 set 视图，并用于索引行。
keySet() - 类 javax.script.SimpleBindings 中的方法
返回此映射中包含的键的 Set 视图。
KeySpec - java.security.spec 中的 接口
组成加密密钥的密钥内容的（透明）规范。
keysSpi() - 类 java.util.prefs.AbstractPreferences 中的方法
返回在此首选项节点中具有关联值的所有键。
KeyStore - java.security 中的 类
此类表示密钥和证书的存储设施。
KeyStore(KeyStoreSpi, Provider, String) - 类 java.security.KeyStore 的构造方法
创建给定类型的 KeyStore 对象，并在其中封装给定的提供者实现（SPI 对象）。
KeyStore.Builder - java.security 中的 类
将被实例化的 KeyStore 对象的描述。
KeyStore.Builder() - 类 java.security.KeyStore.Builder 的构造方法
构造新的 Builder。
KeyStore.CallbackHandlerProtection - java.security 中的 类
封装 CallbackHandler 的 ProtectionParameter。
KeyStore.CallbackHandlerProtection(CallbackHandler) - 类 java.security.KeyStore.CallbackHandlerProtection 的构造方法
根据 CallbackHandler 构造新的 CallbackHandlerProtection。
KeyStore.Entry - java.security 中的 接口
用于 KeyStore 项类型的标记接口。
KeyStore.LoadStoreParameter - java.security 中的 接口
用于 KeyStore load 和 store 参数的标记接口。
KeyStore.PasswordProtection - java.security 中的 类
ProtectionParameter 的一个基于密码的实现。
KeyStore.PasswordProtection(char[]) - 类 java.security.KeyStore.PasswordProtection 的构造方法
创建一个 password 参数。
KeyStore.PrivateKeyEntry - java.security 中的 类
保存 PrivateKey 和相应证书链的 KeyStore 项。
KeyStore.PrivateKeyEntry(PrivateKey, Certificate[]) - 类 java.security.KeyStore.PrivateKeyEntry 的构造方法
构造带 PrivateKey 和相应证书链的 PrivateKeyEntry。
KeyStore.ProtectionParameter - java.security 中的 接口
用于 keystore 保护参数的标记接口。
KeyStore.SecretKeyEntry - java.security 中的 类
保存 SecretKey 的 KeyStore 项。
KeyStore.SecretKeyEntry(SecretKey) - 类 java.security.KeyStore.SecretKeyEntry 的构造方法
用 SecretKey 构造 SecretKeyEntry。
KeyStore.TrustedCertificateEntry - java.security 中的 类
保存可信的 Certificate 的 KeyStore 项。
KeyStore.TrustedCertificateEntry(Certificate) - 类 java.security.KeyStore.TrustedCertificateEntry 的构造方法
用可信 Certificate 构造 TrustedCertificateEntry。
KeyStoreBuilderParameters - javax.net.ssl 中的 类
封装了 KeyStore.Builders 列表的 X509KeyManagers 参数对象。
KeyStoreBuilderParameters(KeyStore.Builder) - 类 javax.net.ssl.KeyStoreBuilderParameters 的构造方法
根据指定的 KeyStore.Builder 构造新的 KeyStoreBuilderParameters。
KeyStoreBuilderParameters(List) - 类 javax.net.ssl.KeyStoreBuilderParameters 的构造方法
根据 KeyStore.Builder 的列表构造新的 KeyStoreBuilderParameters。
KeyStoreException - java.security 中的 异常
这是一般的 KeyStore 异常。
KeyStoreException() - 异常 java.security.KeyStoreException 的构造方法
构造不带详细消息的 KeyStoreException。
KeyStoreException(String) - 异常 java.security.KeyStoreException 的构造方法
构造带指定详细消息的 KeyStoreException。
KeyStoreException(String, Throwable) - 异常 java.security.KeyStoreException 的构造方法
创建带指定的详细消息和 cause 的 KeyStoreException。
KeyStoreException(Throwable) - 异常 java.security.KeyStoreException 的构造方法
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyStoreSpi - java.security 中的 类
此类为 KeyStore 类定义服务提供者接口 (SPI)。
KeyStoreSpi() - 类 java.security.KeyStoreSpi 的构造方法
KeyStroke - javax.swing 中的 类
表示键盘或等效输入设置上的键操作的 KeyStroke。
keyTyped(KeyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 keyTyped 方法处理 keyTyped 事件。
keyTyped(KeyEvent) - 类 java.awt.event.KeyAdapter 中的方法
键入某个键时调用此方法。
keyTyped(KeyEvent) - 接口 java.awt.event.KeyListener 中的方法
键入某个键时调用此方法。
keyTyped(KeyEvent) - 类 javax.swing.plaf.basic.BasicTableUI.KeyHandler 中的方法
keyTyped(KeyEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 中的方法
键入键时调用。
keyUp(Event, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
KeyValue - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyValue 元素的表示形式。
KHMER - 类 java.awt.font.NumericShaper 中的静态变量
标识 KHMER 范围和十进制基数。
KHMER - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Khmer”Unicode 字符块的常量。
KHMER_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Khmer Symbols”Unicode 字符块的常量。
kind - 类 javax.tools.SimpleJavaFileObject 中的变量
此文件对象的种类。
kind() - 类 org.omg.CORBA.TypeCode 中的方法
检索此 TypeCode 对象的种类。
kind - 类 org.omg.CosNaming.NameComponent 中的变量
KOREA - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
KOREAN - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
KRB_NT_PRINCIPAL - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
用户主体名称类型。
KRB_NT_SRV_HST - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
主机名作为实例 (telnet, rcommands) 的服务的名称类型。
KRB_NT_SRV_INST - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
服务和其他唯一实例 (krbtgt) 名称类型。
KRB_NT_SRV_XHST - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
将主机名作为剩余组件的服务的名称类型。
KRB_NT_UID - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
唯一 ID 名称类型。
KRB_NT_UNKNOWN - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
未知的名称类型。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


L - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

L

Label - java.awt 中的 类
Label 对象是一个可在容器中放置文本的组件。
Label() - 类 java.awt.Label 的构造方法
构造一个空标签。
Label(String) - 类 java.awt.Label 的构造方法
使用指定的文本字符串构造一个新的标签，其文本对齐方式为左对齐。
Label(String, int) - 类 java.awt.Label 的构造方法
构造一个显示指定的文本字符串的新标签，其文本对齐方式为指定的方式。
LABEL - 类 javax.accessibility.AccessibleRole 中的静态变量
用于在界面中显示图标或短字符串的对象。
LABEL - 类 javax.swing.plaf.synth.Region 中的静态变量
Label 的 region。
label - 类 org.omg.CORBA.UnionMember 中的变量
此 UnionMember 对象所描述的 union 成员的标签。
Label.AccessibleAWTLabel - java.awt 中的 类
此类实现对 Label 类的可访问性支持。
Label.AccessibleAWTLabel() - 类 java.awt.Label.AccessibleAWTLabel 的构造方法
LABEL_FOR - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个目标对象的标签。
LABEL_FOR_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
标识某个标签的目标组已更改
LABELED_BY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示一个或多个目标对象作为某个对象的标签。
LABELED_BY_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
标识正在进行标签操作的对象已更改
labelFor - 类 javax.swing.JLabel 中的变量
labelRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
labelsHaveSameBaselines() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
如果标签表中的所有标签具有相同的基线，则返回 true。
labelUI - 类 javax.swing.plaf.basic.BasicLabelUI 中的静态变量
默认 BasicLabelUI 实例。
LabelUI - javax.swing.plaf 中的 类
JLabel 的可插入外观界面。
LabelUI() - 类 javax.swing.plaf.LabelUI 的构造方法
LabelView - javax.swing.text 中的 类
LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。
LabelView(Element) - 类 javax.swing.text.LabelView 的构造方法
构造在元素上包装的新视图。
LANDSCAPE - 类 java.awt.PageAttributes.OrientationRequestedType 中的静态变量
用于指定横向方向的 OrientationRequestedType 实例。
LANDSCAPE - 类 java.awt.print.PageFormat 中的静态变量
原点位于纸张的左下方，x 的方向从下到上，y 的方向从左到右。
LANDSCAPE - 类 javax.print.attribute.standard.OrientationRequested 中的静态变量
沿介质的长边描绘内容。
LANG - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
LANGUAGE - 类 java.text.AttributedCharacterIterator.Attribute 中的静态变量
某些文本的语言的属性键。
LANGUAGE - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定用于服务的首选语言的环境属性名称。
LANGUAGE - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它是受实现支持的 Scripting Language 的完全名称。
LANGUAGE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
LANGUAGE_VERSION - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它标识受实现支持的脚本语言的版本。
LanguageCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 LanguageCallback, 并将其传递给 CallbackHandler 的 handle 方法，以获取用于本地化文本的 Locale。
LanguageCallback() - 类 javax.security.auth.callback.LanguageCallback 的构造方法
构造一个 LanguageCallback。
LAO - 类 java.awt.font.NumericShaper 中的静态变量
标识 LAO 范围和十进制基数。
LAO - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Lao”Unicode 字符块的常量。
LARGE_CAPACITY - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的大容量进纸托盘。
LARGE_ICON_KEY - 接口 javax.swing.Action 中的静态变量
用来存储 Icon 的键。
LARGE_MODEL_PROPERTY - 类 javax.swing.JTree 中的静态变量
largeModel 的绑定属性名称。
largeModel - 类 javax.swing.JTree 中的变量
此树是否为大模型？这是一种代码优化设置。
largeModel - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
如果对 largeModel 进行优化，则为 True。
last(Container) - 类 java.awt.CardLayout 中的方法
翻转到容器的最后一张卡片。
last() - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的最后一行。
last() - 类 java.text.BreakIterator 中的方法
返回最后一个边界。
last() - 接口 java.text.CharacterIterator 中的方法
将位置设置为 getEndIndex()-1（如果文本为空，则为 getEndIndex()），并返回该位置的字符。
last() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.last()。
last() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
last() - 接口 java.util.SortedSet 中的方法
返回此 set 中当前最后一个（最高）元素。
last() - 类 java.util.TreeSet 中的方法
last() - 类 javax.swing.text.Segment 中的方法
将位置设置为 getEndIndex()-1（如果文本为空，则设置为 getEndIndex()），并返回该位置的字符。
LAST_DIVIDER_LOCATION_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 lastLocation 属性。
LAST_LINE_END - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的结束位置。
LAST_LINE_START - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的开始位置。
lastAlloc - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的变量
最后的可见分配区域（用于向上刷新更改时进行重新绘制）。
lastColumn - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的变量
lastDividerLocation - 类 javax.swing.JSplitPane 中的变量
分隔窗格的上一个位置。
lastEdit() - 类 javax.swing.undo.CompoundEdit 中的方法
返回 edits 中最后一个 UndoableEdit，如果 edits 为空，则返回 null。
lastElement() - 类 java.util.Vector 中的方法
返回此向量的最后一个组件。
lastElement() - 类 javax.swing.DefaultListModel 中的方法
返回列表的最后一个组件。
lastEntry() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。
lastEntry() - 接口 java.util.NavigableMap 中的方法
返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。
lastEntry() - 类 java.util.TreeMap 中的方法
lastIndexOf(int) - 类 java.lang.String 中的方法
返回指定字符在此字符串中最后一次出现处的索引。
lastIndexOf(int, int) - 类 java.lang.String 中的方法
返回指定字符在此字符串中最后一次出现处的索引，从指定的索引处开始进行反向搜索。
lastIndexOf(String) - 类 java.lang.String 中的方法
返回指定子字符串在此字符串中最右边出现处的索引。
lastIndexOf(String, int) - 类 java.lang.String 中的方法
返回指定子字符串在此字符串中最后一次出现处的索引，从指定的索引开始反向搜索。
lastIndexOf(String) - 类 java.lang.StringBuffer 中的方法
lastIndexOf(String, int) - 类 java.lang.StringBuffer 中的方法
lastIndexOf(String) - 类 java.lang.StringBuilder 中的方法
lastIndexOf(String, int) - 类 java.lang.StringBuilder 中的方法
lastIndexOf(Object) - 类 java.util.AbstractList 中的方法
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。
lastIndexOf(Object) - 类 java.util.ArrayList 中的方法
返回此列表中最后一次出现的指定元素的索引，或如果此列表不包含索引，则返回 -1。
lastIndexOf(Object) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。
lastIndexOf(E, int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回最后一次出现的指定元素在此列表中的索引，从 index 开始向后搜索，如果没有找到该元素，则返回 -1。
lastIndexOf(Object) - 类 java.util.LinkedList 中的方法
返回此列表中最后出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。
lastIndexOf(Object) - 接口 java.util.List 中的方法
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。
lastIndexOf(Object) - 类 java.util.Vector 中的方法
返回此向量中最后一次出现的指定元素的索引；如果此向量不包含该元素，则返回 -1。
lastIndexOf(Object, int) - 类 java.util.Vector 中的方法
返回此向量中最后一次出现的指定元素的索引，从 index 处逆向搜索，如果未找到该元素，则返回 -1。
lastIndexOf(Object) - 类 javax.swing.DefaultListModel 中的方法
返回 elem 最后一次出现处的索引。
lastIndexOf(Object, int) - 类 javax.swing.DefaultListModel 中的方法
从指定的索引处开始反向搜索 elem，并返回该对象的索引。
lastIndexOfSubList(List<?>, List<?>) - 类 java.util.Collections 中的静态方法
返回指定源列表中最后一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
lastKey() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
lastKey() - 接口 java.util.SortedMap 中的方法
返回映射中当前最后一个（最高）键。
lastKey() - 类 java.util.TreeMap 中的方法
lastModified() - 类 java.io.File 中的方法
返回此抽象路径名表示的文件最后一次被修改的时间。
LastOwnerException - java.security.acl 中的 异常
如果试图删除访问控制列表的最后一个所有者，则抛出此异常。
LastOwnerException() - 异常 java.security.acl.LastOwnerException 的构造方法
构造一个 LastOwnerException。
lastPageFirst() - 类 java.awt.PrintJob 中的方法
如果首先打印最后一页，则返回 true。
lastPaintPosition - 类 javax.swing.JViewport 中的变量
我们绘制的最后一个 viewPosition，因此我们知道有多少有效的后备存储图像。
lastPath - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
选择的最后路径。
lastRow - 类 javax.swing.event.TableModelEvent 中的变量
lastRow - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的变量
lastRow - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
最后传入到 getTreeCellEditorComponent 的行。
lastSelectedRow - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
上一次选中行的索引。
lastTabInRun(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
lastValidOffset - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的变量
最后一次有效偏移量计算的位置。
LATEST - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "latest"，某些属性的可能值。
latest() - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回可以建模的最新源版本。
latestSupported() - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回完全受当前执行环境支持的最新源版本。
LATIN - 类 java.awt.im.InputSubset 中的静态变量
所有拉丁字符常量，包括 BASIC_LATIN、LATIN_1_SUPPLEMENT、LATIN_EXTENDED_A、LATIN_EXTENDED_B Unicode 字符块中的字符。
LATIN_1_SUPPLEMENT - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Latin-1 Supplement”Unicode 字符块的常量。
LATIN_DIGITS - 类 java.awt.im.InputSubset 中的静态变量
BASIC_LATIN Unicode 字符块中包括的数字常量。
LATIN_EXTENDED_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Latin Extended-A”Unicode 字符块的常量。
LATIN_EXTENDED_ADDITIONAL - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Latin Extended Additional”Unicode 字符块的常量。
LATIN_EXTENDED_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Latin Extended-B”Unicode 字符块的常量。
LAYER_PROPERTY - 类 javax.swing.JLayeredPane 中的静态变量
绑定属性
LAYERED_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
允许其子级在各层中进行绘制的专用窗格，提供堆栈顺序的形式。
LAYERED_PANE_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
LayeredHighlighter - javax.swing.text 中的 类
LayeredHighlighter() - 类 javax.swing.text.LayeredHighlighter 的构造方法
LayeredHighlighter.LayerPainter - javax.swing.text 中的 类
分层的高亮显示渲染器。
LayeredHighlighter.LayerPainter() - 类 javax.swing.text.LayeredHighlighter.LayerPainter 的构造方法
layeredPane - 类 javax.swing.JRootPane 中的变量
管理菜单栏和内容窗格的分层窗格。
layout() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。
layout() - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1，用 doLayout() 取代。
layout() - 类 java.awt.ScrollPane 中的方法
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。
layout(int, int) - 类 javax.swing.text.BoxView 中的方法
执行对框的布局
layout(FlowView) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
更新给定 FlowView 的流。
layout(int, int) - 类 javax.swing.text.FlowView 中的方法
布置子级。
LAYOUT_LEFT_TO_RIGHT - 类 java.awt.Font 中的静态变量
layoutGlyphVector 的标志，指示文本是从左到右的，这由 Bidi 分析确定。
LAYOUT_NO_LIMIT_CONTEXT - 类 java.awt.Font 中的静态变量
layoutGlyphVector 的标志，指示不应该检查指定 limit 之后的 char 数组中的文本。
LAYOUT_NO_START_CONTEXT - 类 java.awt.Font 中的静态变量
layoutGlyphVector 的标志，指示不应该检查指定 start 之前的 char 数组中的文本。
LAYOUT_RIGHT_TO_LEFT - 类 java.awt.Font 中的静态变量
layoutGlyphVector 的标志，指示文本是从右到左的，这由 Bidi 分析确定。
layoutChanged(int) - 类 javax.swing.text.BoxView 中的方法
使沿某轴的布局变得无效。
layoutCL(JLabel, FontMetrics, String, Icon, Rectangle, Rectangle, Rectangle) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
将调用转发到 SwingUtilities.layoutCompoundLabel()。
layoutColumns(int, int[], int[], SizeRequirements[]) - 类 javax.swing.text.TableView 中的方法
布局列，使其符合给定的目标跨距。
layoutComboBox(Container, MetalComboBoxUI.MetalComboBoxLayoutManager) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
layoutCompoundLabel(JComponent, FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - 类 javax.swing.SwingUtilities 中的静态方法
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
layoutCompoundLabel(FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - 类 javax.swing.SwingUtilities 中的静态方法
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
layoutContainer(Container) - 类 java.awt.BorderLayout 中的方法
使用此边框布局对容器参数进行布局。
layoutContainer(Container) - 类 java.awt.CardLayout 中的方法
使用此卡片布局布置指定的容器。
layoutContainer(Container) - 类 java.awt.FlowLayout 中的方法
布置该容器。
layoutContainer(Container) - 类 java.awt.GridBagLayout 中的方法
使用此网格包布局布置指定容器。
layoutContainer(Container) - 类 java.awt.GridLayout 中的方法
使用此布局布置指定容器。
layoutContainer(Container) - 接口 java.awt.LayoutManager 中的方法
布置指定容器。
layoutContainer(Container) - 类 javax.swing.BoxLayout 中的方法
在需要布置指定容器时，由 AWT 调用 。
layoutContainer(Container) - 类 javax.swing.GroupLayout 中的方法
布置指定的容器。
layoutContainer(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法
指示布局管理器为指定的容器执行布局。
layoutContainer(Container) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
调整一个（并且是唯一）子级的大小，以完全填充父 insets 中的区域。
layoutContainer(Container) - 类 javax.swing.OverlayLayout 中的方法
当需要布置指定的容器时，由 AWT 调用。
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
进行实际布局。
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager 中的方法
layoutContainer(Container) - 类 javax.swing.ScrollPaneLayout 中的方法
布置滚动窗格。
layoutContainer(Container) - 类 javax.swing.SpringLayout 中的方法
layoutContainer(Container) - 类 javax.swing.ViewportLayout 中的方法
在需要布置指定容器时由 AWT 调用。
LayoutFocusTraversalPolicy - javax.swing 中的 类
根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。
LayoutFocusTraversalPolicy() - 类 javax.swing.LayoutFocusTraversalPolicy 的构造方法
构造一个 LayoutFocusTraversalPolicy。
layoutGlyphVector(FontRenderContext, char[], int, int, int) - 类 java.awt.Font 中的方法
返回一个新 GlyphVector 对象，执行完整的文本布局（如有可能）。
layoutHScrollbar(JScrollBar) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
layoutInfo - 类 java.awt.GridBagLayout 中的变量
此字段保持网格包的布局信息。
layoutLabel(int, FontMetrics, int, String, Icon, Rectangle, Rectangle, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
layoutMajorAxis(int, int, int[], int[]) - 类 javax.swing.text.BoxView 中的方法
执行对框的主轴的布局（即它所代表的轴）。
layoutMajorAxis(int, int, int[], int[]) - 类 javax.swing.text.TableView.TableRow 中的方法
对框的主轴（即其表示的轴）执行布局操作。
LayoutManager - java.awt 中的 接口
定义知道如何布置 Container 类的接口。
layoutManager - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
创建并放到拆分窗格中的 LayoutManager。
LayoutManager2 - java.awt 中的 接口
为类定义接口，该类知道如何根据布局约束对象来布置 Container。
layoutMinorAxis(int, int, int[], int[]) - 类 javax.swing.text.BoxView 中的方法
执行对框的辅轴的布局（即与它所代表的轴垂直的轴）。
layoutMinorAxis(int, int, int[], int[]) - 类 javax.swing.text.html.BlockView 中的方法
执行对框的辅轴（即与它所代表的轴垂直的轴）的布局。
layoutMinorAxis(int, int, int[], int[]) - 类 javax.swing.text.TableView 中的方法
针对框的辅轴（即垂直于其所表示的轴的轴）执行布局操作。
layoutMinorAxis(int, int, int[], int[]) - 类 javax.swing.text.TableView.TableRow 中的方法
对盒子的辅轴（即垂直于其表示的轴的轴）执行布局操作。
LayoutPath - java.awt.font 中的 类
LayoutPath 提供相对于基线的位置与用户空间中的点之间的映射。
LayoutPath() - 类 java.awt.font.LayoutPath 的构造方法
layoutPool - 类 javax.swing.text.FlowView 中的变量
这些都是表示此视图表示的元素（要转换为物理视图的逻辑视图）的子元素的视图。
LayoutQueue - javax.swing.text 中的 类
文本布局任务的队列。
LayoutQueue() - 类 javax.swing.text.LayoutQueue 的构造方法
构造一个布局队列。
layoutRow(FlowView, int, int) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
创建一个符合该行布局区域的视图的行。
layoutSpan - 类 javax.swing.text.FlowView 中的变量
创建流所依靠的默认约束。
LayoutStyle - javax.swing 中的 类
LayoutStyle 提供有关如何确定组件位置的信息。
LayoutStyle() - 类 javax.swing.LayoutStyle 的构造方法
创建一个新的 LayoutStyle。
LayoutStyle.ComponentPlacement - javax.swing 中的 枚举
ComponentPlacement 是两个组件相对于彼此的可能放置方式的枚举。
layoutText(SynthContext, FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
根据通过引用返回的放置图标和文本的位置，布局文本和图标。
layoutVScrollbar(JScrollBar) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
lazilyLoadDesktopProperty(String) - 类 java.awt.Toolkit 中的方法
一个对桌面属性值延迟计算的机会。
lazySet(boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
最终设置为给定值。
lazySet(int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
最后设置为给定值。
lazySet(int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
最后将位置 i 的元素设置为给定值。
lazySet(T, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
最后将此更新器管理的给定对象的字段设置为给定更新值。
lazySet(long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
最后设置为给定值。
lazySet(int, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
最终将位置 i 的元素设置为给定值。
lazySet(T, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
最后将此更新器管理的给定对象的字段设置为给定更新值。
lazySet(V) - 类 java.util.concurrent.atomic.AtomicReference 中的方法
最终设置为给定值。
lazySet(int, E) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
最终将位置 i 的元素设置为给定值。
lazySet(T, V) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
最终将此更新器管理的给定对象的字段设置为给定更新值。
LDAPCertStoreParameters - java.security.cert 中的 类
用作 LDAP CertStore 算法的输入的参数。
LDAPCertStoreParameters(String, int) - 类 java.security.cert.LDAPCertStoreParameters 的构造方法
创建具有指定参数值的 LDAPCertStoreParameters 的实例。
LDAPCertStoreParameters(String) - 类 java.security.cert.LDAPCertStoreParameters 的构造方法
创建具有指定服务器名称和默认端口 389 的 LDAPCertStoreParameters 的实例。
LDAPCertStoreParameters() - 类 java.security.cert.LDAPCertStoreParameters 的构造方法
创建具有默认参数值（服务器名称 "localhost"，端口 389）的 LDAPCertStoreParameters 的实例。
LdapContext - javax.naming.ldap 中的 接口
此接口表示一个上下文，在该上下文中可以利用 LDAPv3 样式的控件执行操作，并且可以执行 LDAPv3 样式的扩展操作。
LdapName - javax.naming.ldap 中的 类
此类表示 RFC 2253 指定的标识名。
LdapName(String) - 类 javax.naming.ldap.LdapName 的构造方法
根据给定标识名构造 LDAP 名称。
LdapName(List<Rdn>) - 类 javax.naming.ldap.LdapName 的构造方法
在给定已解析 RDN 组件的情况下构造 LDAP 名称。
LdapReferralException - javax.naming.ldap 中的 异常
此抽象类用于表示 LDAP 引用异常。
LdapReferralException(String) - 异常 javax.naming.ldap.LdapReferralException 的构造方法
使用所提供的解释构造一个新的 LdapReferralException 实例。
LdapReferralException() - 异常 javax.naming.ldap.LdapReferralException 的构造方法
构造一个新的 LdapReferralException 实例。
LE - 类 javax.management.Query 中的静态变量
表示 Query.leq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
LEAD_DOTS - 类 javax.swing.text.TabStop 中的静态变量
LEAD_EQUALS - 类 javax.swing.text.TabStop 中的静态变量
LEAD_HYPHENS - 类 javax.swing.text.TabStop 中的静态变量
LEAD_NONE - 类 javax.swing.text.TabStop 中的静态变量
LEAD_SELECTION_PATH_PROPERTY - 类 javax.swing.JTree 中的静态变量
leadSelectionPath 的绑定属性名称。
LEAD_THICKLINE - 类 javax.swing.text.TabStop 中的静态变量
LEAD_UNDERLINE - 类 javax.swing.text.TabStop 中的静态变量
leadAnchorNotificationEnabled - 类 javax.swing.DefaultListSelectionModel 中的变量
leadIndex - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
selection 中前导路径的索引。
LEADING - 类 java.awt.FlowLayout 中的静态变量
此值指示每一行组件都应该与容器方向的开始边对齐，例如，对于从左到右的方向，则与左边对齐。
leading(int) - 类 java.awt.font.TextHitInfo 中的静态方法
在指定 charIndex 处的字符开始边上创建一个 TextHitInfo。
LEADING - 类 javax.swing.border.TitledBorder 中的静态变量
从左到右排列时将标题文本置于边框线的左边，从右到左排列时将标题文本置于边框线的右边。
LEADING - 接口 javax.swing.SwingConstants 中的静态变量
标识使用从左到右和从右到左的语言的文本开始边。
leadPath - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
添加的最后一条路径。
leadRow - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
前导行。
leafIcon - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
用于显示叶节点的图标。
Lease - java.rmi.dgc 中的 类
一个 lease 包含了一个唯一的 VM 标识符和一个租借期限。
Lease(VMID, long) - 类 java.rmi.dgc.Lease 的构造方法
构造一个具有指定 VMID 和租借期限的 lease。
leave(InetAddress) - 类 java.net.DatagramSocketImpl 中的方法
退出多播组。
leaveGroup(SocketAddress, NetworkInterface) - 类 java.net.DatagramSocketImpl 中的方法
退出多播组。
leaveGroup(InetAddress) - 类 java.net.MulticastSocket 中的方法
离开多播组。
leaveGroup(SocketAddress, NetworkInterface) - 类 java.net.MulticastSocket 中的方法
离开指定本地接口上的多播组。
LEDGER - 类 java.awt.PageAttributes.MediaType 中的静态变量
Ledger (11 x 17 in) 的 MediaType 实例。
LEDGER - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 ledger 尺寸，11 inch × 17 inch。
LEDGER - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ledger 尺寸。
LEFT - 类 java.awt.Event 中的静态变量
Left Arrow 键，一个非 ASCII 操作键。
LEFT - 类 java.awt.FlowLayout 中的静态变量
此值指示每一行组件都应该是左对齐的。
left - 类 java.awt.Insets 中的变量
左边的 inset。
LEFT - 类 java.awt.Label 中的静态变量
指示标签文本应左对齐。
left - 类 javax.swing.border.EmptyBorder 中的变量
LEFT - 类 javax.swing.border.TitledBorder 中的静态变量
将标题文本置于边框线的左边。
LEFT - 类 javax.swing.JSplitPane 中的静态变量
用于添加一个 Component 到另一个 Component 的左边。
LEFT - 接口 javax.swing.SwingConstants 中的静态变量
用于指定框左侧位置的框方向常量。
LEFT_ALIGNMENT - 类 java.awt.Component 中的静态变量
getAlignmentX 的易于使用的常量。
LEFT_JUSTIFY - 类 java.util.FormattableFlags 中的静态变量
将输出左对齐。
LEFT_OUTER_JOIN - 接口 javax.sql.rowset.JoinRowSet 中的静态变量
ANSI 风格的 JOIN，提供两个表之间的左外联合 (left outer join)。
LEFT_TO_RIGHT - 类 java.awt.ComponentOrientation 中的静态变量
各项从左到右布局，各行从上到下，示例：英语、法语。
leftButton - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
用于快速切换左边组件的按钮。
leftChildIndent - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
从左页边空白到将绘制垂直虚线的位置之间的距离。
leftComponent - 类 javax.swing.JSplitPane 中的变量
左边或者顶部的组件。
LeftIndent - 类 javax.swing.text.StyleConstants 中的静态变量
段落左边的缩进量。
leftKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
leftKey - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
leftKey - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
已过时。 从 Java 2 平台 v1.3 开始。
leftToRightCache - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
LEGAL - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_LEGAL 的别名。
LEGAL - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 合法尺寸，8.5 inch × 14 inch。
LEGAL_VALUES_FIELD - 类 javax.management.JMX 中的静态变量
legalValues 字段的名称。
len - 类 java.util.zip.InflaterInputStream 中的变量
输入缓冲区的长度。
length() - 类 java.io.File 中的方法
返回由此抽象路径名表示的文件的长度。
length - 异常 java.io.OptionalDataException 中的变量
当前缓冲区中可读取的基本数据的字节数。
length() - 类 java.io.RandomAccessFile 中的方法
返回此文件的长度。
length() - 接口 java.lang.CharSequence 中的方法
返回此字符序列的长度。
length() - 类 java.lang.String 中的方法
返回此字符串的长度。
length() - 类 java.lang.StringBuffer 中的方法
length() - 类 java.nio.CharBuffer 中的方法
返回此字符缓冲区的长度。
length() - 类 java.nio.charset.CoderResult 中的方法
返回此对象描述的错误输入的长度（可选操作）。
length() - 接口 java.sql.Blob 中的方法
返回此 Blob 对象指定的 BLOB 值中的字节数。
length() - 接口 java.sql.Clob 中的方法
获取此 Clob 对象指定的 CLOB 值中的字符数。
length() - 类 java.util.BitSet 中的方法
返回此 BitSet 的“逻辑大小”：BitSet 中最高设置位的索引加 1。
length() - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
返回该数组的长度。
length() - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
返回该数组的长度。
length() - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
返回该数组的长度。
length() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
length() - 类 javax.imageio.stream.FileImageInputStream 中的方法
返回底层文件的长度，如果其为未知，则返回 -1。
length() - 类 javax.imageio.stream.FileImageOutputStream 中的方法
length() - 接口 javax.imageio.stream.ImageInputStream 中的方法
返回流的总长度（如果已知）。
length() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
返回 -1L，指示流的长度未知。
length() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
length - 类 javax.sound.midi.MidiMessage 中的变量
MIDI 消息中的字节数，包括状态字节和数据字节。
length() - 类 javax.sql.rowset.serial.SerialBlob 中的方法
获取此 SerialBlob 对象字节数组中的字节数。
length() - 类 javax.sql.rowset.serial.SerialClob 中的方法
获取此 SerialClob 对象字节数组中的字节数。
length() - 接口 javax.swing.text.AbstractDocument.Content 中的方法
当前字符序列内容的长度。
length() - 类 javax.swing.text.GapContent 中的方法
返回内容的长度。
length() - 类 javax.swing.text.Segment 中的方法
返回此字符序列的长度。
length() - 类 javax.swing.text.StringContent 中的方法
返回内容的长度。
length() - 接口 org.omg.CORBA.DynSequence 中的方法
已过时。 返回此 DynFixed 对象表示的 sequence 长度。
length(int) - 接口 org.omg.CORBA.DynSequence 中的方法
已过时。 将此 DynFixed 对象所表示的 sequence 长度设置为给定参数。
length() - 类 org.omg.CORBA.TypeCode 中的方法
返回此 TypeCode 对象所描述类型中的成员数。
leq(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于两个值的“小于或等于”约束条件。
LESS_THAN_MIN_ROLE_DEGREE - 类 javax.management.relation.RoleStatus 中的静态变量
试图用比最小期望容量更少的 ObjectName 设置角色值时的问题类型。
LESSER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
比较结果。
lessThanOrEquals(ResolutionSyntax) - 类 javax.print.attribute.ResolutionSyntax 中的方法
确定此分辨率属性的值是否小于或等于给定分辨率属性的值。
LETTER - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_LETTER 的别名。
LETTER - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 信纸尺寸，8.5 inch × 11 inch。
LETTER_NUMBER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Nl”。
LETTER_SPACING - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
LETTERLIKE_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Letterlike Symbols”Unicode 字符块的常量。
Level - java.util.logging 中的 类
Level 类定义了一组可用来控制日志输出的标准日志级别。
Level(String, int) - 类 java.util.logging.Level 的构造方法
使用给定的整数值创建一个指定的 Level。
Level(String, int, String) - 类 java.util.logging.Level 的构造方法
使用给定的整数值和给定的本地化资源名称创建一个指定的 Level。
LexicalHandler - org.xml.sax.ext 中的 接口
用于词法事件的 SAX2 扩展处理程序。
LI - 类 javax.swing.text.html.HTML.Tag 中的静态变量
LIFESPAN_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/LIFESPAN_POLICY_ID.java。
LifespanPolicy - org.omg.PortableServer 中的 接口
LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
LifespanPolicyOperations - org.omg.PortableServer 中的 接口
LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
LifespanPolicyValue - org.omg.PortableServer 中的 类
LifespanPolicyValue 可以具有以下值。
LifespanPolicyValue(int) - 类 org.omg.PortableServer.LifespanPolicyValue 的构造方法
LIGATURE - 类 java.awt.font.GlyphMetrics 中的静态变量
指示将多个字符表示成连字（例如，'fi' 或 'ffi'）的字形。
LIGATURES - 类 java.awt.font.TextAttribute 中的静态变量
启用可选连字的属性键。
LIGATURES_ON - 类 java.awt.font.TextAttribute 中的静态变量
请求标准可选连字。
LIGHT - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态变量
LIGHT_GRAY - 类 java.awt.Color 中的静态变量
浅灰色。
lightGray - 类 java.awt.Color 中的静态变量
浅灰色。
lightHighlight - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的变量
lightHighlight - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的变量
lightHighlight - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
lightWeightPopupEnabled - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
lightWeightPopupEnabled - 类 javax.swing.ToolTipManager 中的变量
LIMBU - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Limbu”Unicode 字符块的常量。
limit() - 类 java.nio.Buffer 中的方法
返回此缓冲区的限制。
limit(int) - 类 java.nio.Buffer 中的方法
设置此缓冲区的限制。
LimitExceededException - javax.naming 中的 异常
当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
LimitExceededException() - 异常 javax.naming.LimitExceededException 的构造方法
构造一个新的 LimitExceededException 实例，将解释和所有名称解析字段初始化为 null。
LimitExceededException(String) - 异常 javax.naming.LimitExceededException 的构造方法
使用解释构造一个新的 LimitExceededException 实例。
LINE - 接口 javax.accessibility.AccessibleExtendedText 中的静态变量
用于指示应被检索的文本部分是单行文本的常量。
Line - javax.sound.sampled 中的 接口
Line 接口表示单声道或多声道音频供给。
Line.Info - javax.sound.sampled 中的 类
Line.Info 对象包含关于行的信息。
Line.Info(Class<?>) - 类 javax.sound.sampled.Line.Info 的构造方法
构造描述指定类的行的 info 对象。
Line2D - java.awt.geom 中的 类
Line2D 表示 (x,y) 坐标空间中的线段。
Line2D() - 类 java.awt.geom.Line2D 的构造方法
这是一个无法直接实例化的抽象类。
Line2D.Double - java.awt.geom 中的 类
使用 double 坐标指定的线段。
Line2D.Double() - 类 java.awt.geom.Line2D.Double 的构造方法
使用坐标 (0, 0) -> (0, 0) 构造并初始化一个 Line。
Line2D.Double(double, double, double, double) - 类 java.awt.geom.Line2D.Double 的构造方法
根据指定坐标构造并初始化 Line2D。
Line2D.Double(Point2D, Point2D) - 类 java.awt.geom.Line2D.Double 的构造方法
根据指定的 Point2D 对象构造并初始化 Line2D。
Line2D.Float - java.awt.geom 中的 类
使用 float 坐标指定的线段。
Line2D.Float() - 类 java.awt.geom.Line2D.Float 的构造方法
使用坐标 (0, 0) -> (0, 0) 构造并初始化一个 Line。
Line2D.Float(float, float, float, float) - 类 java.awt.geom.Line2D.Float 的构造方法
根据指定坐标构造并初始化 Line。
Line2D.Float(Point2D, Point2D) - 类 java.awt.geom.Line2D.Float 的构造方法
根据指定的 Point2D 对象构造并初始化 Line2D。
LINE_AXIS - 类 javax.swing.BoxLayout 中的静态变量
指定应该根据目标容器的 ComponentOrientation 属性确定的文本行方向放置组件。
LINE_END - 类 java.awt.BorderLayout 中的静态变量
组件出现在布局的行方向的结尾处。
LINE_END - 类 java.awt.GridBagConstraints 中的静态变量
沿显示区域的边缘居中放置组件，在该区域中，当前 ComponentOrienation 的文本行正常结束。
LINE_HEIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
LINE_IN - 类 javax.sound.sampled.Port.Info 中的静态变量
从线路级音频输入插孔获得音频端口类型。
LINE_OUT - 类 javax.sound.sampled.Port.Info 中的静态变量
向线路级音频输出插孔发送音频端口类型。
LINE_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Zl”。
LINE_START - 类 java.awt.BorderLayout 中的静态变量
组件出现在布局的行方向的开始处。
LINE_START - 类 java.awt.GridBagConstraints 中的静态变量
沿显示区域的边缘居中放置组件，在该区域中，当前 ComponentOrienation 的文本行正常开始。
LINEAR_B_IDEOGRAMS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Linear B Ideograms”Unicode 字符块的常量。
LINEAR_B_SYLLABARY - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Linear B Syllabary”Unicode 字符块的常量。
LinearGradientPaint - java.awt 中的 类
LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。
LinearGradientPaint(float, float, float, float, float[], Color[]) - 类 java.awt.LinearGradientPaint 的构造方法
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(float, float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.LinearGradientPaint 的构造方法
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D, Point2D, float[], Color[]) - 类 java.awt.LinearGradientPaint 的构造方法
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.LinearGradientPaint 的构造方法
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod, MultipleGradientPaint.ColorSpaceType, AffineTransform) - 类 java.awt.LinearGradientPaint 的构造方法
构造一个 LinearGradientPaint。
LineBorder - javax.swing.border 中的 类
实现单色、任意厚度线边框的类。
LineBorder(Color) - 类 javax.swing.border.LineBorder 的构造方法
创建具有指定颜色、厚度为 1（thickness = 1）的线边框。
LineBorder(Color, int) - 类 javax.swing.border.LineBorder 的构造方法
创建具有指定颜色和厚度的线边框。
LineBorder(Color, int, boolean) - 类 javax.swing.border.LineBorder 的构造方法
创建具有指定颜色、厚度和拐角形状的线条边框。
LineBreakMeasurer - java.awt.font 中的 类
LineBreakMeasurer 类允许将样式化的文本断为行（或段），以符合特定的可视 advance。
LineBreakMeasurer(AttributedCharacterIterator, FontRenderContext) - 类 java.awt.font.LineBreakMeasurer 的构造方法
为指定的文本构造一个 LineBreakMeasurer。
LineBreakMeasurer(AttributedCharacterIterator, BreakIterator, FontRenderContext) - 类 java.awt.font.LineBreakMeasurer 的构造方法
为指定的文本构造一个 LineBreakMeasurer。
lineColor - 类 javax.swing.border.LineBorder 中的变量
LineEvent - javax.sound.sampled 中的 类
LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。
LineEvent(Line, LineEvent.Type, long) - 类 javax.sound.sampled.LineEvent 的构造方法
构造源自指定行的指定类型的新事件。
LineEvent.Type - javax.sound.sampled 中的 类
该 LineEvent.Type 内部类标识行上所发生事件的种类。
LineEvent.Type(String) - 类 javax.sound.sampled.LineEvent.Type 的构造方法
构造新的事件类型。
lineLimitAttribute - 类 javax.swing.text.PlainDocument 中的静态变量
指定行的最大长度的属性名称（如果有最大长度）。
LineListener - javax.sound.sampled 中的 接口
可以注册实现 LineListener 接口的类的实例来接收行状态更改时发生的事件。
LineMetrics - java.awt.font 中的 类
LineMetrics 类允许访问沿着一行布局字符和多行布局所需要的规格。
LineMetrics() - 类 java.awt.font.LineMetrics 的构造方法
lineno() - 类 java.io.StreamTokenizer 中的方法
返回当前行号。
LineNumberInputStream - java.io 中的 类
已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
LineNumberInputStream(InputStream) - 类 java.io.LineNumberInputStream 的构造方法
已过时。 构造从指定输入流读取其输入的新行号输入流。
LineNumberReader - java.io 中的 类
跟踪行号的缓冲字符输入流。
LineNumberReader(Reader) - 类 java.io.LineNumberReader 的构造方法
使用默认输入缓冲区的大小创建新的行编号 reader。
LineNumberReader(Reader, int) - 类 java.io.LineNumberReader 的构造方法
创建新的行编号 reader，将字符读入给定大小的缓冲区。
linesIntersect(double, double, double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
测试从 (x1,y1) 到 (x2,y2) 的线段是否与从 (x3,y3) 到 (x4,y4) 的线段相交。
LineSpacing - 类 javax.swing.text.StyleConstants 中的静态变量
段落的行之间的空间量。
lineTo(double, double) - 类 java.awt.geom.Path2D.Double 中的方法
通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。
lineTo(double, double) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。
lineTo(float, float) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制一条从当前坐标到指定新坐标（以 float 精度指定）的直线，将一个点添加到路径中。
lineTo(double, double) - 类 java.awt.geom.Path2D 中的方法
通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。
lineToRect(Shape, int) - 类 javax.swing.text.PlainView 中的方法
确定表示给定行的矩形。
LineUnavailableException - javax.sound.sampled 中的 异常
LineUnavailableException 是指示某一行因为不可用而无法打开的异常。
LineUnavailableException() - 异常 javax.sound.sampled.LineUnavailableException 的构造方法
构造将 null 作为错误详细消息的 LineUnavailableException。
LineUnavailableException(String) - 异常 javax.sound.sampled.LineUnavailableException 的构造方法
构造具有指定详细消息的 LineUnavailableException。
LINK - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
LINK - 类 javax.swing.text.html.HTML.Tag 中的静态变量
LINK - 类 javax.swing.TransferHandler 中的静态变量
表示“链接”传输动作的 int 值。
LinkageError - java.lang 中的 错误
LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
LinkageError() - 错误 java.lang.LinkageError 的构造方法
构造不带详细消息的 LinkageError 类。
LinkageError(String) - 错误 java.lang.LinkageError 的构造方法
构造带指定详细消息的 LinkageError 类。
LinkedBlockingDeque<E> - java.util.concurrent 中的 类
一个基于已链接节点的、任选范围的阻塞双端队列。
LinkedBlockingDeque() - 类 java.util.concurrent.LinkedBlockingDeque 的构造方法
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingDeque。
LinkedBlockingDeque(int) - 类 java.util.concurrent.LinkedBlockingDeque 的构造方法
创建一个具有给定（固定）容量的 LinkedBlockingDeque。
LinkedBlockingDeque(Collection<? extends E>) - 类 java.util.concurrent.LinkedBlockingDeque 的构造方法
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingDeque，最初包含给定 collection 的元素，以该 collection 迭代器的遍历顺序添加。
LinkedBlockingQueue<E> - java.util.concurrent 中的 类
一个基于已链接节点的、范围任意的 blocking queue。
LinkedBlockingQueue() - 类 java.util.concurrent.LinkedBlockingQueue 的构造方法
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingQueue。
LinkedBlockingQueue(int) - 类 java.util.concurrent.LinkedBlockingQueue 的构造方法
创建一个具有给定（固定）容量的 LinkedBlockingQueue。
LinkedBlockingQueue(Collection<? extends E>) - 类 java.util.concurrent.LinkedBlockingQueue 的构造方法
创建一个容量是 Integer.MAX_VALUE 的 LinkedBlockingQueue，最初包含给定 collection 的元素，元素按该 collection 迭代器的遍历顺序添加。
LinkedHashMap<K,V> - java.util 中的 类
Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
LinkedHashMap(int, float) - 类 java.util.LinkedHashMap 的构造方法
构造一个带指定初始容量和加载因子的空插入顺序 LinkedHashMap 实例。
LinkedHashMap(int) - 类 java.util.LinkedHashMap 的构造方法
构造一个带指定初始容量和默认加载因子 (0.75) 的空插入顺序 LinkedHashMap 实例。
LinkedHashMap() - 类 java.util.LinkedHashMap 的构造方法
构造一个带默认初始容量 (16) 和加载因子 (0.75) 的空插入顺序 LinkedHashMap 实例。
LinkedHashMap(Map<? extends K, ? extends V>) - 类 java.util.LinkedHashMap 的构造方法
构造一个映射关系与指定映射相同的插入顺序 LinkedHashMap 实例。
LinkedHashMap(int, float, boolean) - 类 java.util.LinkedHashMap 的构造方法
构造一个带指定初始容量、加载因子和排序模式的空 LinkedHashMap 实例。
LinkedHashSet<E> - java.util 中的 类
具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
LinkedHashSet(int, float) - 类 java.util.LinkedHashSet 的构造方法
构造一个带有指定初始容量和加载因子的新空链接哈希 set。
LinkedHashSet(int) - 类 java.util.LinkedHashSet 的构造方法
构造一个带指定初始容量和默认加载因子 (0.75) 的新空链接哈希 set。
LinkedHashSet() - 类 java.util.LinkedHashSet 的构造方法
构造一个带默认初始容量 (16) 和加载因子 (0.75) 的新空链接哈希 set。
LinkedHashSet(Collection<? extends E>) - 类 java.util.LinkedHashSet 的构造方法
构造一个与指定 collection 中的元素相同的新链接哈希 set。
LinkedList<E> - java.util 中的 类
List 接口的链接列表实现。
LinkedList() - 类 java.util.LinkedList 的构造方法
构造一个空列表。
LinkedList(Collection<? extends E>) - 类 java.util.LinkedList 的构造方法
构造一个包含指定 collection 中的元素的列表，这些元素按其 collection 的迭代器返回的顺序排列。
LinkException - javax.naming 中的 异常
此异常用于描述解析链接时遇到的问题。
LinkException(String) - 异常 javax.naming.LinkException 的构造方法
使用解释构造一个新的 LinkException 实例，其他所有字段都初始化为 null。
LinkException() - 异常 javax.naming.LinkException 的构造方法
构造一个新的 LinkException 实例。
linkExplanation - 异常 javax.naming.LinkException 中的变量
包含链接解析失败原因的异常。
LinkLoopException - javax.naming 中的 异常
当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
LinkLoopException(String) - 异常 javax.naming.LinkLoopException 的构造方法
使用解释构造一个新的 LinkLoopException 实例，其他所有字段都被初始化为 null。
LinkLoopException() - 异常 javax.naming.LinkLoopException 的构造方法
构造一个新的 LinkLoopException 实例。
LinkRef - javax.naming 中的 类
此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。
LinkRef(Name) - 类 javax.naming.LinkRef 的构造方法
为某一名称构造一个 LinkRef。
LinkRef(String) - 类 javax.naming.LinkRef 的构造方法
为某一字符串名称构造一个 LinkRef。
linkRemainingName - 异常 javax.naming.LinkException 中的变量
包含尚未解析的剩余链接名称。
linkResolvedName - 异常 javax.naming.LinkException 中的变量
包含已成功解析的链接部分。
linkResolvedObj - 异常 javax.naming.LinkException 中的变量
包含一个对象，已成功解析的链接部分一直到达该对象。
linkSize(Component...) - 类 javax.swing.GroupLayout 中的方法
将指定组件强制调整为具有相同的大小，而不管其首选大小、最小大小或最大大小如何。
linkSize(int, Component...) - 类 javax.swing.GroupLayout 中的方法
将指定组件强制调整为沿指定轴具有相同的大小，而不管其首选大小、最小大小或最大大小如何。
list() - 类 java.awt.Component 中的方法
将组件列表打印到标准系统输出流 System.out。
list(PrintStream) - 类 java.awt.Component 中的方法
将组件列表打印到指定的输出流。
list(PrintStream, int) - 类 java.awt.Component 中的方法
将列表从指定的缩排开始打印到指定的打印流。
list(PrintWriter) - 类 java.awt.Component 中的方法
将列表打印到指定的打印编写器。
list(PrintWriter, int) - 类 java.awt.Component 中的方法
将列表从指定的缩排开始打印到指定的打印编写器。
list(PrintStream, int) - 类 java.awt.Container 中的方法
将此容器的清单打印到指定输出流。
list(PrintWriter, int) - 类 java.awt.Container 中的方法
将一个列表打印到指定打印编写器，从指定缩排位置开始。
List - java.awt 中的 类
List 组件为用户提供了一个可滚动的文本项列表。
List() - 类 java.awt.List 的构造方法
创建新的滚动列表。
List(int) - 类 java.awt.List 的构造方法
创建一个用指定可视行数初始化的新滚动列表。
List(int, boolean) - 类 java.awt.List 的构造方法
创建一个初始化为显示指定行数的新滚动列表。
list() - 类 java.io.File 中的方法
返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中的文件和目录。
list(FilenameFilter) - 类 java.io.File 中的方法
返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中满足指定过滤器的文件和目录。
list() - 类 java.lang.ThreadGroup 中的方法
将有关此线程组的信息打印到标准输出。
list(String) - 类 java.rmi.Naming 中的静态方法
返回在注册表中绑定的名称所组成的数组。
list() - 接口 java.rmi.registry.Registry 中的方法
返回在此注册表中绑定的名称的数组。
list(Enumeration<T>) - 类 java.util.Collections 中的静态方法
返回一个数组列表，它按返回顺序包含指定枚举返回的元素。
List<E> - java.util 中的 接口
有序的 collection（也称为序列）。
list(PrintStream) - 类 java.util.Properties 中的方法
将属性列表输出到指定的输出流。
list(PrintWriter) - 类 java.util.Properties 中的方法
将属性列表输出到指定的输出流。
LIST - 类 javax.accessibility.AccessibleRole 中的静态变量
呈现给用户一个对象列表的对象，它还允许用户从中选择一个或多个对象。
list(Name) - 接口 javax.naming.Context 中的方法
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
list(String) - 接口 javax.naming.Context 中的方法
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
list(String) - 类 javax.naming.InitialContext 中的方法
list(Name) - 类 javax.naming.InitialContext 中的方法
list - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
list - 类 javax.swing.plaf.basic.BasicListUI 中的变量
LIST - 类 javax.swing.plaf.synth.Region 中的静态变量
List 的 region。
list(JavaFileManager.Location, String, Set<JavaFileObject.Kind>, boolean) - 类 javax.tools.ForwardingJavaFileManager 中的方法
list(JavaFileManager.Location, String, Set<JavaFileObject.Kind>, boolean) - 接口 javax.tools.JavaFileManager 中的方法
列出给定位置处符合给定标准的所有文件对象。
list(int, BindingListHolder, BindingIteratorHolder) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
列表操作允许客户端迭代命名上下文中的一组绑定。
list(int, BindingListHolder, BindingIteratorHolder) - 类 org.omg.CosNaming._NamingContextStub 中的方法
列表操作允许客户端迭代命名上下文中的一组绑定。
list(int, BindingListHolder, BindingIteratorHolder) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
list 操作允许客户端迭代命名上下文中的一组绑定。
List.AccessibleAWTList - java.awt 中的 类
此类实现 List 类的可访问性支持。
List.AccessibleAWTList() - 类 java.awt.List.AccessibleAWTList 的构造方法
List.AccessibleAWTList.AccessibleAWTListChild - java.awt 中的 类
此类实现 List 子级的可访问性支持。
List.AccessibleAWTList.AccessibleAWTListChild(List, int) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 的构造方法
LIST_DESELECT - 类 java.awt.Event 中的静态变量
已经取消选择列表中的一项。
list_initial_services() - 类 org.omg.CORBA.ORB 中的方法
返回最初可用 CORBA 对象引用（比如 "NameService" 和 "InterfaceRepository"）的列表。
LIST_ITEM - 类 javax.accessibility.AccessibleRole 中的静态变量
呈现列表元素的对象。
LIST_SELECT - 类 java.awt.Event 中的静态变量
已经选择了列表中的一项。
LIST_STYLE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
LIST_STYLE_IMAGE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
LIST_STYLE_POSITION - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
LIST_STYLE_TYPE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
listBindings(Name) - 接口 javax.naming.Context 中的方法
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
listBindings(String) - 接口 javax.naming.Context 中的方法
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
listBindings(String) - 类 javax.naming.InitialContext 中的方法
listBindings(Name) - 类 javax.naming.InitialContext 中的方法
listBox - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
listBox - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的变量
ListCellRenderer - javax.swing 中的 接口
标识可用作“橡皮图章”以绘制 JList 中单元格的组件。
ListDataEvent - javax.swing.event 中的 类
定义一个封装列表更改的事件。
ListDataEvent(Object, int, int, int) - 类 javax.swing.event.ListDataEvent 的构造方法
构造一个 ListDataEvent 对象。
ListDataListener - javax.swing.event 中的 接口
ListDataListener
listDataListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
listDataListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
listDataListener - 类 javax.swing.plaf.basic.BasicListUI 中的变量
listen(int) - 类 java.net.SocketImpl 中的方法
将传入连接指示（连接请求）的最大队列长度设置为 count 参数。
listenerList - 类 javax.swing.AbstractCellEditor 中的变量
listenerList - 类 javax.swing.AbstractListModel 中的变量
listenerList - 类 javax.swing.AbstractSpinnerModel 中的变量
此模型的 ChangeListener 列表。
listenerList - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的变量
listenerList - 类 javax.swing.DefaultBoundedRangeModel 中的变量
等待模型更改的侦听器。
listenerList - 类 javax.swing.DefaultButtonModel 中的变量
在此模型中存储侦听器。
listenerList - 类 javax.swing.DefaultListSelectionModel 中的变量
listenerList - 类 javax.swing.DefaultSingleSelectionModel 中的变量
已注册侦听器的集合
listenerList - 类 javax.swing.event.EventListenerList 中的变量
listenerList - 类 javax.swing.JComponent 中的变量
此组件的事件侦听器列表。
listenerList - 类 javax.swing.MenuSelectionManager 中的变量
listenerList - 类 javax.swing.table.AbstractTableModel 中的变量
侦听器的列表
listenerList - 类 javax.swing.table.DefaultTableColumnModel 中的变量
TableColumnModelListener 的列表
listenerList - 类 javax.swing.text.AbstractDocument 中的变量
文档的事件侦听器列表。
listenerList - 类 javax.swing.text.DefaultCaret 中的变量
事件侦听器列表。
listenerList - 类 javax.swing.text.StyleContext.NamedStyle 中的变量
模型的更改侦听器。
listenerList - 类 javax.swing.Timer 中的变量
listenerList - 类 javax.swing.tree.DefaultTreeModel 中的变量
侦听器。
listenerList - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
事件侦听器列表。
ListenerNotFoundException - javax.management 中的 异常
存储库中不存在指定的 MBean 侦听器。
ListenerNotFoundException() - 异常 javax.management.ListenerNotFoundException 的构造方法
默认的构造方法。
ListenerNotFoundException(String) - 异常 javax.management.ListenerNotFoundException 的构造方法
允许指定特定错误消息的构造方法。
listeners - 类 javax.swing.undo.UndoableEditSupport 中的变量
listFiles() - 类 java.io.File 中的方法
返回一个抽象路径名数组，这些路径名表示此抽象路径名表示的目录中的文件。
listFiles(FilenameFilter) - 类 java.io.File 中的方法
返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。
listFiles(FileFilter) - 类 java.io.File 中的方法
返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。
listIterator() - 类 java.util.AbstractList 中的方法
返回此列表元素的列表迭代器（按适当顺序）。
listIterator(int) - 类 java.util.AbstractList 中的方法
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
listIterator(int) - 类 java.util.AbstractSequentialList 中的方法
返回在此列表中的元素上进行迭代的列表迭代器（按适当顺序）。
listIterator() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表元素的列表迭代器（按适当顺序）。
listIterator(int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
listIterator(int) - 类 java.util.LinkedList 中的方法
返回此列表中的元素的列表迭代器（按适当顺序），从列表中指定位置开始。
listIterator() - 接口 java.util.List 中的方法
返回此列表元素的列表迭代器（按适当顺序）。
listIterator(int) - 接口 java.util.List 中的方法
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
ListIterator<E> - java.util 中的 接口
系列表迭代器，允许程序员按任一方向遍历列表、迭代期间修改列表，并获得迭代器在列表中的当前位置。
ListModel - javax.swing 中的 接口
此接口定义方法组件（如 JList），这些组件用于获取列表中每个单元格的值以及列表的长度。
listMouseListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
listMouseMotionListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
ListResourceBundle - java.util 中的 类
ListResourceBundle 是 ResourceBundle 的一个抽象类，用于管理方便而又易于使用的列表中的语言环境资源。
ListResourceBundle() - 类 java.util.ListResourceBundle 的构造方法
单独的构造方法。
listRoots() - 类 java.io.File 中的静态方法
列出可用的文件系统根。
ListSelectionEvent - javax.swing.event 中的 类
表现选择中更改的特征的事件。
ListSelectionEvent(Object, int, int, boolean) - 类 javax.swing.event.ListSelectionEvent 的构造方法
表示 firstIndex 与 lastIndex（包括两者）范围内的选择状态的更改。
ListSelectionListener - javax.swing.event 中的 接口
列表选择值发生更改时收到通知的侦听器。
listSelectionListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
listSelectionListener - 类 javax.swing.plaf.basic.BasicListUI 中的变量
ListSelectionModel - javax.swing 中的 接口
此接口表示任何组件的当前选择状态，该组件显示一个具有稳定索引的值列表。
listSelectionModel - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
维护列表选择模型的句柄。
ListUI - javax.swing.plaf 中的 类
JList 的可插入外观代理。
ListUI() - 类 javax.swing.plaf.ListUI 的构造方法
ListView - javax.swing.text.html 中的 类
用于显示 html 列表的视图实现。
ListView(Element) - 类 javax.swing.text.html.ListView 的构造方法
创建表示列表元素的新视图。
listViewIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
LITERAL - 类 java.util.regex.Pattern 中的静态变量
启用模式的字面值解析。
LITTLE_ENDIAN - 类 java.nio.ByteOrder 中的静态变量
表示 little-endian 字节顺序的常量。
LIVE_DRAG_MODE - 类 javax.swing.JDesktopPane 中的静态变量
指示正在被拖动项的所有内容是否应该出现在桌面窗格内部。
LOAD - 类 java.awt.FileDialog 中的静态变量
此常量值指示文件对话框窗口的作用是查找要读取的文件。
load(String) - 类 java.lang.Runtime 中的方法
加载作为动态库的指定文件名。
load(String) - 类 java.lang.System 中的静态方法
从作为动态库的本地文件系统中以指定的文件名加载代码文件。
load() - 类 java.nio.MappedByteBuffer 中的方法
将此缓冲区内容加载到物理内存中。
load(InputStream, char[]) - 类 java.security.KeyStore 中的方法
从给定输入流中加载此 KeyStore。
load(KeyStore.LoadStoreParameter) - 类 java.security.KeyStore 中的方法
使用给定 LoadStoreParameter 加载此 keystore。
load(InputStream) - 类 java.security.Provider 中的方法
从输入流中读取属性列表（键和元素对）。
load(Reader) - 类 java.util.Properties 中的方法
按简单的面向行的格式从输入字符流中读取属性列表（键和元素对）。
load(InputStream) - 类 java.util.Properties 中的方法
从输入流中读取属性列表（键和元素对）。
load(Class<S>, ClassLoader) - 类 java.util.ServiceLoader 中的静态方法
针对给定服务类型和类加载器创建新的服务加载器。
load(Class<S>) - 类 java.util.ServiceLoader 中的静态方法
针对给定服务类型创建新的服务加载器，使用当前线程的上下文类加载器。
load() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
使用在持久存储中找到的 MBean 的数据实例化此 MBean。
load() - 接口 javax.management.PersistentMBean 中的方法
使用持久存储中找到的 MBean 的数据实例化此 MBean 实例。
load(InputStream, Class<?>) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。
load(URL) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。
LOAD_FILE - 类 java.awt.Event 中的静态变量
文件加载事件。
loadAllInstruments(Soundbank) - 接口 javax.sound.midi.Synthesizer 中的方法
将指定 Soundbank 中包含的所有乐器加载到 Synthesizer 中。
loadChildren() - 类 javax.swing.JTree.DynamicUtilTreeNode 中的方法
根据 childValue 加载子节点。
loadChildren(ViewFactory) - 类 javax.swing.text.AsyncBoxView 中的方法
加载初始化该视图的所有子级。
loadChildren(ViewFactory) - 类 javax.swing.text.CompositeView 中的方法
加载所有的子级以初始化该视图。
loadChildren(ViewFactory) - 类 javax.swing.text.FlowView 中的方法
加载初始化该视图的所有子级。
loadChildren(ViewFactory) - 类 javax.swing.text.WrappedPlainView 中的方法
加载所有子级来初始化视图。
loadChildren(ViewFactory) - 类 javax.swing.text.ZoneView 中的方法
加载所有子级来初始化视图。
loadClass(String) - 类 java.lang.ClassLoader 中的方法
使用指定的二进制名称来加载类。
loadClass(String, boolean) - 类 java.lang.ClassLoader 中的方法
使用指定的二进制名称来加载类。
loadClass(String) - 接口 java.rmi.server.LoaderHandler 中的方法
已过时。 无替代版本
loadClass(URL, String) - 接口 java.rmi.server.LoaderHandler 中的方法
已过时。 无替代版本
loadClass(String) - 类 java.rmi.server.RMIClassLoader 中的静态方法
已过时。 由 loadClass(String,String) 方法取代
loadClass(URL, String) - 类 java.rmi.server.RMIClassLoader 中的静态方法
从基本代码 URL 加载类。
loadClass(String, String) - 类 java.rmi.server.RMIClassLoader 中的静态方法
从基本代码 URL 路径加载类。
loadClass(String, String, ClassLoader) - 类 java.rmi.server.RMIClassLoader 中的静态方法
有选择地使用提供的加载器从基本代码 URL 路径加载类。
loadClass(String, String, ClassLoader) - 类 java.rmi.server.RMIClassLoaderSpi 中的方法
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
loadClass(String) - 类 javax.management.DefaultLoaderRepository 中的静态方法
已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
loadClass(String) - 接口 javax.management.loading.ClassLoaderRepository 中的方法
通过类加载器列表加载给定的类名称。
loadClass(String) - 类 javax.management.loading.DefaultLoaderRepository 中的静态方法
已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
loadClass(String, ClassLoaderRepository) - 类 javax.management.loading.MLet 中的方法
如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。
loadClass(String, String, ClassLoader) - 类 javax.rmi.CORBA.Util 中的静态方法
为指定的类返回一个类实例。
loadClass(String, String, ClassLoader) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。
loadClassBefore(ClassLoader, String) - 接口 javax.management.loading.ClassLoaderRepository 中的方法
通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。
loadClassWithout(ClassLoader, String) - 类 javax.management.DefaultLoaderRepository 中的静态方法
已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。
loadClassWithout(ClassLoader, String) - 接口 javax.management.loading.ClassLoaderRepository 中的方法
通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。
loadClassWithout(ClassLoader, String) - 类 javax.management.loading.DefaultLoaderRepository 中的静态方法
已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。
loadedChildren - 类 javax.swing.JTree.DynamicUtilTreeNode 中的变量
是否已加载此子节点？
LoaderHandler - java.rmi.server 中的 接口
已过时。 无替代版本
loadFromXML(InputStream) - 类 java.util.Properties 中的方法
将指定输入流中由 XML 文档所表示的所有属性加载到此属性表中。
loadImage(String) - 类 java.beans.SimpleBeanInfo 中的方法
这是帮助加载图标图像的实用工具方法。
loadImage(Image) - 类 javax.swing.ImageIcon 中的方法
加载图像，并且只在图像已加载时返回。
LOADING - 类 java.awt.MediaTracker 中的静态变量
指示当前正在加载媒体的标志。
loadInstalled(Class<S>) - 类 java.util.ServiceLoader 中的静态方法
针对给定服务类型创建新的服务加载器，使用扩展类加载器。
loadInstrument(Instrument) - 接口 javax.sound.midi.Synthesizer 中的方法
让特定的乐器可用于合成。
loadInstruments(Soundbank, Patch[]) - 接口 javax.sound.midi.Synthesizer 中的方法
从指定 Soundbank 加载指定修补程序所引用的乐器。
loadKeyBindings(InputMap, Object[]) - 类 javax.swing.LookAndFeel 中的静态方法
使用指定绑定填充 InputMap。
loadKeymap(Keymap, JTextComponent.KeyBinding[], Action[]) - 类 javax.swing.text.JTextComponent 中的静态方法
加载带有一组绑定的 keymap。
loadLibrary(String) - 类 java.lang.Runtime 中的方法
加载具有指定库名的动态库。
loadLibrary(String) - 类 java.lang.System 中的静态方法
加载由 libname 参数指定的系统库。
loadProxyClass(String, String[], ClassLoader) - 类 java.rmi.server.RMIClassLoader 中的静态方法
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
loadProxyClass(String, String[], ClassLoader) - 类 java.rmi.server.RMIClassLoaderSpi 中的方法
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。
loadRules(Reader, URL) - 类 javax.swing.text.html.StyleSheet 中的方法
加载 CSS1 语法中指定的规则集合。
loadSystemColors(int[]) - 类 java.awt.Toolkit 中的方法
使用当前系统颜色值填充作为参数提供的整数数组。
loadSystemColors(UIDefaults, String[], boolean) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
用 systemColors 中的 name-color 对填充 table。
localControl(boolean) - 接口 javax.sound.midi.MidiChannel 中的方法
打开或关闭本地控制。
locale - 类 java.beans.beancontext.BeanContextSupport 中的变量
此 BeanContext 的当前语言环境。
locale() - 类 java.util.Formatter 中的方法
返回构造此 formatter 时设置的语言环境。
Locale - java.util 中的 类
Locale 对象表示了特定的地理、政治和文化地区。
Locale(String, String, String) - 类 java.util.Locale 的构造方法
根据语言、国家/地区和变量构造一个语言环境。
Locale(String, String) - 类 java.util.Locale 的构造方法
根据语言和国家/地区构造一个语言环境。
Locale(String) - 类 java.util.Locale 的构造方法
根据语言代码构造一个语言环境。
locale() - 类 java.util.Scanner 中的方法
返回此扫描器的语言环境。
locale - 类 javax.imageio.ImageReader 中的变量
用于本地化的当前 Locale，如果没有设置，则为 null。
locale - 类 javax.imageio.ImageWriteParam 中的变量
用于本地化压缩类型名称和质量描述的 Locale，null 表示使用默认 Locale。
locale - 类 javax.imageio.ImageWriter 中的变量
用于本地化的当前 Locale，如果没有设置 Locale，则将它初始化为 null。
LocaleNameProvider - java.util.spi 中的 类
为 Locale 类提供本地化名称的服务提供者的一个抽象类。
LocaleNameProvider() - 类 java.util.spi.LocaleNameProvider 的构造方法
唯一的构造方法。
LocaleServiceProvider - java.util.spi 中的 类
此类是所有与语言环境有关的服务提供者接口（SPI）的超类。
LocaleServiceProvider() - 类 java.util.spi.LocaleServiceProvider 的构造方法
唯一的构造方法。
LocalObject - org.omg.CORBA 中的 类
用作 Java 语言映射中的本地 IDL 接口实现的基本类。
LocalObject() - 类 org.omg.CORBA.LocalObject 的构造方法
构造一个默认 LocalObject 实例。
localPort - 类 java.net.DatagramSocketImpl 中的变量
本地端口号。
localport - 类 java.net.SocketImpl 中的变量
此套接字连接到的本地端口号。
locate(int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getComponentAt(int, int) 取代。
locate(int, int) - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 getComponentAt(int, int) 取代。
LocateRegistry - java.rmi.registry 中的 类
LocateRegistry 用于获得对特定主机（包括本地主机）上引导远程对象注册表的引用，或用于创建一个接受对特定端口调用的远程对象注册表。
location() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getLocation() 取代。
location(int, int) - 类 java.awt.GridBagLayout 中的方法
确定在布局网格中哪个单元包含由 (x, y) 指定的点。
Location - javax.xml.stream 中的 接口
提供有关事件位置的信息。
location - 异常 javax.xml.stream.XMLStreamException 中的变量
LOCATION_FORWARD - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/LOCATION_FORWARD.java。
locationFor(String) - 枚举 javax.tools.StandardLocation 中的静态方法
使用给定名称获取位置对象。
locationToIndex(Point) - 类 javax.swing.JList 中的方法
返回最接近列表的坐标系统中给定位置的单元索引。
locationToIndex(JList, Point) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。
locationToIndex(JList, Point) - 类 javax.swing.plaf.ListUI 中的方法
返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。
locationToIndex(JList, Point) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 locationToIndex 方法。
locator - 类 javax.swing.text.AsyncBoxView 中的变量
这是管理子视图偏移量的对象。
Locator - org.xml.sax 中的 接口
用来将 SAX 事件与文档位置关联的接口。
Locator2 - org.xml.sax.ext 中的 接口
SAX2 扩展，用于扩充通过 Locator 提供的实体信息。
Locator2Impl - org.xml.sax.ext 中的 类
用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。
Locator2Impl() - 类 org.xml.sax.ext.Locator2Impl 的构造方法
构造一个新的空 Locator2Impl 对象。
Locator2Impl(Locator) - 类 org.xml.sax.ext.Locator2Impl 的构造方法
复制现有 Locator 或 Locator2 对象。
LocatorImpl - org.xml.sax.helpers 中的 类
提供 Locator 的可选的有用实现。
LocatorImpl() - 类 org.xml.sax.helpers.LocatorImpl 的构造方法
零参数的构造方法。
LocatorImpl(Locator) - 类 org.xml.sax.helpers.LocatorImpl 的构造方法
复制构造方法。
locatorsUpdateCopy() - 接口 java.sql.DatabaseMetaData 中的方法
指示对 LOB 的更新是在副本上进行还是直接更新到 LOB。
lock - 类 java.io.Reader 中的变量
用于同步针对此流的操作的对象。
lock - 类 java.io.Writer 中的变量
用于同步针对此流的操作的对象。
lock(long, long, boolean) - 类 java.nio.channels.FileChannel 中的方法
获取此通道的文件给定区域上的锁定。
lock() - 类 java.nio.channels.FileChannel 中的方法
获取对此通道的文件的独占锁定。
Lock - java.util.concurrent.locks 中的 接口
Lock 实现提供了比使用 synchronized 方法和语句可获得的更广泛的锁定操作。
lock() - 接口 java.util.concurrent.locks.Lock 中的方法
获取锁。
lock() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
获取锁。
lock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
获取读取锁。
lock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
获取写入锁。
lock - 类 java.util.prefs.AbstractPreferences 中的变量
使用其监视器锁定此节点的对象。
LockInfo - java.lang.management 中的 类
关于锁 的信息。
LockInfo(String, int) - 类 java.lang.management.LockInfo 的构造方法
构造一个 LockInfo 对象。
lockInterruptibly() - 接口 java.util.concurrent.locks.Lock 中的方法
如果当前线程未被中断，则获取锁。
lockInterruptibly() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
如果当前线程未被中断，则获取锁。
lockInterruptibly() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
获取读取锁，除非当前线程被中断。
lockInterruptibly() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
获取写入锁，除非当前线程被中断。
LockSupport - java.util.concurrent.locks 中的 类
用来创建锁和其他同步类的基本线程阻塞原语。
log(double) - 类 java.lang.Math 中的静态方法
返回 double 值的自然对数（底数是 e）。
log(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的自然对数（底数为 e）。
log(String) - 类 java.rmi.server.LogStream 中的静态方法
已过时。 无替代版本
log(LogRecord) - 类 java.util.logging.Logger 中的方法
记录一条 LogRecord。
log(Level, String) - 类 java.util.logging.Logger 中的方法
记录一条不带参数的消息。
log(Level, String, Object) - 类 java.util.logging.Logger 中的方法
记录带有一个对象参数的消息。
log(Level, String, Object[]) - 类 java.util.logging.Logger 中的方法
记录带有一组对象参数的消息。
log(Level, String, Throwable) - 类 java.util.logging.Logger 中的方法
记录带有相关的可抛出信息的消息。
log10(double) - 类 java.lang.Math 中的静态方法
返回 double 值的底数为 10 的对数。
log10(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的底数为 10 的对数。
log1p(double) - 类 java.lang.Math 中的静态方法
返回参数与 1 之和的自然对数。
log1p(double) - 类 java.lang.StrictMath 中的静态方法
返回参数与 1 之和的自然对数。
LOG_OPTION - 类 javax.swing.DebugGraphics 中的静态变量
记录图形操作。
Logger - java.util.logging 中的 类
Logger 对象用来记录特定系统或应用程序组件的日志消息。
Logger(String, String) - 类 java.util.logging.Logger 的构造方法
受保护的方法，它用于为一个指定子系统的构造 logger。
LOGGING_MXBEAN_NAME - 类 java.util.logging.LogManager 中的静态变量
LoggingMXBean 的 ObjectName 的字符串表示形式。
LoggingMXBean - java.util.logging 中的 接口
日志记录设施的管理接口。
LoggingPermission - java.util.logging 中的 类
当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。
LoggingPermission(String, String) - 类 java.util.logging.LoggingPermission 的构造方法
创建一个新的 LoggingPermission 对象。
LOGICAL_STYLE_ACTION - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
逻辑样式选择动作标识符（逻辑样式作为参数传递）
LogicalHandler<C extends LogicalMessageContext> - javax.xml.ws.handler 中的 接口
LogicalHandler 扩展了 Handler，以便为消息上下文参数提供输入安全性。
LogicalMessage - javax.xml.ws 中的 接口
LogicalMessage 接口表示协议无关的 (protocol agnostic) XML 消息，并包含一些方法提供对消息负载的访问。
LogicalMessageContext - javax.xml.ws.handler 中的 接口
LogicalMessageContext 接口扩展了 MessageContext，以访问以与协议无关的 LogicalMessage 形式包含的消息。
login(Subject, CallbackHandler) - 类 java.security.AuthProvider 中的方法
登录到此 provider 中。
login() - 类 javax.security.auth.login.LoginContext 中的方法
执行验证。
login() - 接口 javax.security.auth.spi.LoginModule 中的方法
对 Subject 进行验证的方法（阶段 1）。
LoginContext - javax.security.auth.login 中的 类
LoginContext 类描述用于验证 Subjects 的基本方法和提供开发与底层验证技术无关的应用程序的方法。
LoginContext(String) - 类 javax.security.auth.login.LoginContext 的构造方法
使用 name 实例化一个新 LoginContext 对象。
LoginContext(String, Subject) - 类 javax.security.auth.login.LoginContext 的构造方法
使用 name 和 Subject 对象实例化一个新 LoginContext 对象。
LoginContext(String, CallbackHandler) - 类 javax.security.auth.login.LoginContext 的构造方法
使用 name 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String, Subject, CallbackHandler) - 类 javax.security.auth.login.LoginContext 的构造方法
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String, Subject, CallbackHandler, Configuration) - 类 javax.security.auth.login.LoginContext 的构造方法
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。
LoginException - javax.security.auth.login 中的 异常
此异常是基本的登录异常。
LoginException() - 异常 javax.security.auth.login.LoginException 的构造方法
构造不带详细消息的 LoginException。
LoginException(String) - 异常 javax.security.auth.login.LoginException 的构造方法
构造带指定详细消息的 LoginException。
LoginModule - javax.security.auth.spi 中的 接口
LoginModule 描述由验证技术提供者实现的接口。
LogManager - java.util.logging 中的 类
存在一个单一的全局 LogManager 对象，它可用于维护 Logger 和日志服务的一组共享状态。
LogManager() - 类 java.util.logging.LogManager 的构造方法
受保护的构造方法。
logout() - 类 java.security.AuthProvider 中的方法
在此 provider 中注销。
logout() - 类 javax.security.auth.login.LoginContext 中的方法
注销 Subject。
logout() - 接口 javax.security.auth.spi.LoginModule 中的方法
注销 Subject 的方法。
logp(Level, String, String, String) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类和方法，不带参数。
logp(Level, String, String, String, Object) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类和方法，带有单个日志消息的对象参数。
logp(Level, String, String, String, Object[]) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类和方法，带有一组对象参数。
logp(Level, String, String, String, Throwable) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定源类和方法，带有相关的可抛出信息。
logrb(Level, String, String, String, String) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类、方法和资源包名，不带参数。
logrb(Level, String, String, String, String, Object) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类、方法和资源包名，带有单个日志消息的对象参数。
logrb(Level, String, String, String, String, Object[]) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类、方法和资源包名，带有一组对象参数。
logrb(Level, String, String, String, String, Throwable) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类、方法和资源包名，带有相关的可抛出对象。
LogRecord - java.util.logging 中的 类
LogRecord 对象用于在日志框架和单个日志 Handler 之间传递日志请求。
LogRecord(Level, String) - 类 java.util.logging.LogRecord 的构造方法
用给定级别和消息值构造 LogRecord。
LogStream - java.rmi.server 中的 类
已过时。 无替代版本
logStream() - 类 javax.swing.DebugGraphics 中的静态方法
返回 DebugGraphics 在其中记录绘制操作的流。
Long - java.lang 中的 类
Long 类在对象中包装了基本类型 long 的值。
Long(long) - 类 java.lang.Long 的构造方法
构造新分配的 Long 对象，表示指定的 long 参数。
Long(String) - 类 java.lang.Long 的构造方法
构造新分配的 Long 对象，表示由 String 参数指示的 long 值。
LONG - 类 java.text.DateFormat 中的静态变量
用于 LONG 模式的常量。
LONG - 类 java.util.Calendar 中的静态变量
指示长名称的 getDisplayName 和 getDisplayNames 的风格说明符，比如 "January"。
LONG - 类 java.util.TimeZone 中的静态变量
指出长名称的 getDisplayName() 的风格说明符。
LONG - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Long 的值。
LONG_DESCRIPTION - 接口 javax.swing.Action 中的静态变量
用来存储动作的较长 String 描述的键，用于上下文相关的帮助文件。
longBitsToDouble(long) - 类 java.lang.Double 中的静态方法
返回对应于给定位表示形式的 double 值。
LongBuffer - java.nio 中的 类
long 缓冲区。
LongHolder - org.omg.CORBA 中的 类
Long 值的 Holder。
LongHolder() - 类 org.omg.CORBA.LongHolder 的构造方法
构造一个新的 LongHolder 对象，将其 value 字段初始化为 0。
LongHolder(long) - 类 org.omg.CORBA.LongHolder 的构造方法
构造一个新的 LongHolder 对象，并使用给定 long 初始化其 value 字段。
LongLongSeqHelper - org.omg.CORBA 中的 类
LongLongSeq 的 Helper。
LongLongSeqHelper() - 类 org.omg.CORBA.LongLongSeqHelper 的构造方法
LongLongSeqHolder - org.omg.CORBA 中的 类
LongLongSeq 的 Holder。
LongLongSeqHolder() - 类 org.omg.CORBA.LongLongSeqHolder 的构造方法
LongLongSeqHolder(long[]) - 类 org.omg.CORBA.LongLongSeqHolder 的构造方法
LONGNVARCHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 LONGNVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
LongSeqHelper - org.omg.CORBA 中的 类
LongSeqHelper 的 Helper。
LongSeqHelper() - 类 org.omg.CORBA.LongSeqHelper 的构造方法
LongSeqHolder - org.omg.CORBA 中的 类
LongSeq 的 Holder。
LongSeqHolder() - 类 org.omg.CORBA.LongSeqHolder 的构造方法
LongSeqHolder(int[]) - 类 org.omg.CORBA.LongSeqHolder 的构造方法
longValue() - 类 java.lang.Byte 中的方法
作为一个 long 返回此 Byte 的值。
longValue() - 类 java.lang.Double 中的方法
以 long 形式返回此 Double 的值（通过强制转换为 long 类型）。
longValue() - 类 java.lang.Float 中的方法
将此 Float 值以 long 形式返回（强制转换为 long 类型）。
longValue() - 类 java.lang.Integer 中的方法
以 long 类型返回该 Integer 的值。
longValue() - 类 java.lang.Long 中的方法
以 long 值的形式返回此 Long 的值。
longValue() - 类 java.lang.Number 中的方法
以 long 形式返回指定的数值。
longValue() - 类 java.lang.Short 中的方法
以 Long 形式返回此 Short 的值。
longValue() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 long。
longValue() - 类 java.math.BigInteger 中的方法
将此 BigInteger 转换为 long。
longValue() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
longValue() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
longValueExact() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 long，以检查丢失的信息。
LONGVARBINARY - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 LONGVARBINARY 的 Java 编程语言中的常量（有时称为类型代码）。
LONGVARCHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 LONGVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
LookAndFeel - javax.swing 中的 类
顾名思义，LookAndFeel 封装了一个外观。
LookAndFeel() - 类 javax.swing.LookAndFeel 的构造方法
lookingAt() - 类 java.util.regex.Matcher 中的方法
尝试将从区域开头开始的输入序列与该模式匹配。
lookup(Class<?>) - 类 java.io.ObjectStreamClass 中的静态方法
查找可序列化类的描述符。
lookup(String) - 类 java.rmi.Naming 中的静态方法
返回与指定 name 关联的远程对象的引用（一个 stub）。
lookup(String) - 接口 java.rmi.registry.Registry 中的方法
返回注册表中绑定到指定 name 的远程引用。
lookup(Name) - 接口 javax.naming.Context 中的方法
检索指定的对象。
lookup(String) - 接口 javax.naming.Context 中的方法
检索指定的对象。
lookup(String) - 类 javax.naming.InitialContext 中的方法
lookup(Name) - 类 javax.naming.InitialContext 中的方法
lookup_value_factory(String) - 类 org.omg.CORBA_2_3.ORB 中的方法
lookupAny(Class<?>) - 类 java.io.ObjectStreamClass 中的静态方法
返回任意类的描述符，不考虑它是否实现 Serializable。
lookupConstraints(Component) - 类 java.awt.GridBagLayout 中的方法
检索指定组件的约束。
lookupDefaultPrintService() - 类 javax.print.PrintServiceLookup 中的静态方法
查找此环境的默认 PrintService。
lookupLink(Name) - 接口 javax.naming.Context 中的方法
按照除名称的最终原子组件以外的链接检索指定对象。
lookupLink(String) - 接口 javax.naming.Context 中的方法
按照除名称的最终原子组件以外的链接检索指定对象。
lookupLink(String) - 类 javax.naming.InitialContext 中的方法
lookupLink(Name) - 类 javax.naming.InitialContext 中的方法
lookupMultiDocPrintServices(DocFlavor[], AttributeSet) - 类 javax.print.PrintServiceLookup 中的静态方法
查找能够打印 MultiDoc（包含所有指定的 doc flavor）的 MultiDoc PrintService。
lookupNamespaceURI(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
lookupNamespaceURI(String) - 接口 org.w3c.dom.Node 中的方法
从此节点开始，查找与给定前缀相关的名称空间 URI。
LookupOp - java.awt.image 中的 类
此类实现从源到目标的查找操作。
LookupOp(LookupTable, RenderingHints) - 类 java.awt.image.LookupOp 的构造方法
在给定查找表和 RenderingHints 对象（可能为 null）的情况下，构造一个 LookupOp 对象。
lookupPixel(int[], int[]) - 类 java.awt.image.ByteLookupTable 中的方法
返回像素的样本数组，使用 lookup table 进行转换。
lookupPixel(byte[], byte[]) - 类 java.awt.image.ByteLookupTable 中的方法
返回像素的样本数组，使用 lookup table 进行转换。
lookupPixel(int[], int[]) - 类 java.awt.image.LookupTable 中的方法
返回一个像素的 int 分量数组。
lookupPixel(int[], int[]) - 类 java.awt.image.ShortLookupTable 中的方法
返回一个使用查找表转换后的像素样本数组。
lookupPixel(short[], short[]) - 类 java.awt.image.ShortLookupTable 中的方法
返回一个使用查找表转换后的像素样本数组。
lookupPrefix(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
lookupPrefix(String) - 接口 org.w3c.dom.Node 中的方法
从此节点开始，查找与给定名称空间 URI 相关的前缀。
lookupPrintServices() - 类 java.awt.print.PrinterJob 中的静态方法
查找 2D 打印服务的便捷方法。
lookupPrintServices(DocFlavor, AttributeSet) - 类 javax.print.PrintServiceLookup 中的静态方法
查找能够打印指定 DocFlavor 的 PrintService。
lookupProviders(Class<T>, ClassLoader) - 类 javax.imageio.spi.ServiceRegistry 中的静态方法
使用给定的类加载器搜索特定服务类的实现。
lookupProviders(Class<T>) - 类 javax.imageio.spi.ServiceRegistry 中的静态方法
使用上下文类加载器定位和递增地实例化给定服务的可用的提供者。
lookupStreamPrintServiceFactories(DocFlavor, String) - 类 javax.print.StreamPrintServiceFactory 中的静态方法
查找 PrintService 的工厂，PrintJob 可使用它来输出数据流，数据格式由 flavor 指定。
lookupStreamPrintServices(String) - 类 java.awt.print.PrinterJob 中的静态方法
定位可以成像 2D 图形的流打印服务工厂的便捷方法。
LookupTable - java.awt.image 中的 类
此抽象类定义了一个查找表对象。
LookupTable(int, int) - 类 java.awt.image.LookupTable 的构造方法
根据分量数和查找表中的偏移量构造一个新 LookupTable。
loop() - 接口 java.applet.AudioClip 中的方法
以循环方式开始播放此音频剪辑。
loop(int) - 接口 javax.sound.sampled.Clip 中的方法
从当前位置开始循环回放。
LOOP_CONTINUOUSLY - 接口 javax.sound.midi.Sequencer 中的静态变量
一个值，指示循环应无限继续而不是在执行完特定次数的循环后停止。
LOOP_CONTINUOUSLY - 接口 javax.sound.sampled.Clip 中的静态变量
指示循环应该无限期继续而不是在指定数量的循环后完成的值。
LOST_FOCUS - 类 java.awt.Event 中的静态变量
组件失去焦点。
lostFocus(Event, Object) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
lostOwnership(Clipboard, Transferable) - 接口 java.awt.datatransfer.ClipboardOwner 中的方法
通知此对象，它已不再是剪贴板所有者。
lostOwnership(Clipboard, Transferable) - 类 java.awt.datatransfer.StringSelection 中的方法
LOW_SURROGATES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Low Surrogates”Unicode 字符块的常量。
lower(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
lower(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 中严格小于给定元素的最大元素；如果不存在这样的元素，则返回 null。
lower(E) - 类 java.util.TreeSet 中的方法
LOWER_LEADING_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的底端开始边角。
LOWER_LEFT_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的左下角。
LOWER_RIGHT_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的右下角。
LOWER_TRAILING_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的底端结束边角。
LOWERCASE_LETTER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Ll”。
lowerCaseMode(boolean) - 类 java.io.StreamTokenizer 中的方法
确定是否对文字标记自动使用小写字母。
LOWERED - 类 javax.swing.border.BevelBorder 中的静态变量
凹入斜面类型。
LOWERED - 类 javax.swing.border.EtchedBorder 中的静态变量
阴刻浮雕化类型。
lowerEntry(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与严格小于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。
lowerEntry(K) - 接口 java.util.NavigableMap 中的方法
返回一个键-值映射关系，它与严格小于给定键的最大键关联；如果不存在这样的键，则返回 null。
lowerEntry(K) - 类 java.util.TreeMap 中的方法
lowerKey(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
lowerKey(K) - 接口 java.util.NavigableMap 中的方法
返回严格小于给定键的最大键；如果不存在这样的键，则返回 null。
lowerKey(K) - 类 java.util.TreeMap 中的方法
lowerLeft - 类 javax.swing.JScrollPane 中的变量
在左下角显示的组件。
lowerLeft - 类 javax.swing.ScrollPaneLayout 中的变量
左下角显示的组件。
lowerRight - 类 javax.swing.JScrollPane 中的变量
在右下角显示的组件。
lowerRight - 类 javax.swing.ScrollPaneLayout 中的变量
右下角显示的组件。
lowestLayer() - 类 javax.swing.JLayeredPane 中的方法
返回所有当前子组件的最低层值。
lowestOneBit(int) - 类 java.lang.Integer 中的静态方法
返回具有至多单个 1 位的 int 值，在指定的 int 值中最低位（最右边）的 1 位的位置。
lowestOneBit(long) - 类 java.lang.Long 中的静态方法
返回至多有一个 1 位的 long 值，在指定的 long 值中最低位（最右边）的 1 位的位置。
LOWSRC - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
LSException - org.w3c.dom.ls 中的 异常
如果处理停止，解析或写操作可以抛出 LSException。
LSException(short, String) - 异常 org.w3c.dom.ls.LSException 的构造方法
LSInput - org.w3c.dom.ls 中的 接口
此接口表示数据的输入源。
LSLoadEvent - org.w3c.dom.ls 中的 接口
此接口表示通知文档加载完成的加载事件对象。
LSOutput - org.w3c.dom.ls 中的 接口
此接口表示数据的输出目标。
LSParser - org.w3c.dom.ls 中的 接口
可以构建的对象接口，或者参数、来自各种输入源的 DOM 树。
LSParserFilter - org.w3c.dom.ls 中的 接口
LSParserFilter 为应用程序提供了在解析期间构建节点时检查这些节点的能力。
LSProgressEvent - org.w3c.dom.ls 中的 接口
此接口表示进度事件对象，该对象在解析文档时通知应用程序有关进度。
LSResourceResolver - org.w3c.dom.ls 中的 接口
LSResourceResolver 为应用程序提供了将引用重定向到外部资源的方法。
LSSerializer - org.w3c.dom.ls 中的 接口
LSSerializer 提供了将 DOM 文档序列化（编写）为 XML 的 API。
LSSerializerFilter - org.w3c.dom.ls 中的 接口
LSSerializerFilter 为应用程序提供了在序列化节点时检查节点以及决定哪些节点应该或不应该序列化的能力。
LT - 类 javax.management.Query 中的静态变量
表示 Query.lt(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
lt(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示 基于两个值的“小于”约束条件。
lt(File, File) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


M - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

M

Mac - javax.crypto 中的 类
此类提供“消息验证码”（Message Authentication Code，MAC）算法的功能。
Mac(MacSpi, Provider, String) - 类 javax.crypto.Mac 的构造方法
创建一个 MAC 对象。
MacSpi - javax.crypto 中的 类
此类为 Mac 类定义服务提供者接口 (SPI)。
MacSpi() - 类 javax.crypto.MacSpi 的构造方法
magenta - 类 java.awt.Color 中的静态变量
洋红色。
MAGENTA - 类 java.awt.Color 中的静态变量
洋红色。
mail() - 类 java.awt.Desktop 中的方法
启动用户默认邮件客户端的邮件组合窗口。
mail(URI) - 类 java.awt.Desktop 中的方法
启动用户默认邮件客户端的邮件组合窗口，填充由 mailto: URI 指定的消息字段。
MailcapCommandMap - javax.activation 中的 类
MailcapCommandMap 扩展 CommandMap 抽象类。
MailcapCommandMap() - 类 javax.activation.MailcapCommandMap 的构造方法
默认的构造方法。
MailcapCommandMap(String) - 类 javax.activation.MailcapCommandMap 的构造方法
允许调用者指定 mailcap 文件路径的构造方法。
MailcapCommandMap(InputStream) - 类 javax.activation.MailcapCommandMap 的构造方法
允许调用者指定一个包含 mailcap 文件的 InputStream 的构造方法。
MAIN - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的主要进纸托盘。
MAIN_CLASS - 类 java.util.jar.Attributes.Name 中的静态变量
Main-Class 的 Name 对象具有的属性，用于启动打包在 JAR 文件中的应用程序。
MAIN_UIROLE - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个充当普通终端用户角色的 UI。
major_version - 类 org.omg.IOP.Encoding 中的变量
此 Encoding 格式的主要形式。
majorRequirementChange(AsyncBoxView.ChildState, float) - 类 javax.swing.text.AsyncBoxView 中的方法
沿主轴上的要求更改。
majorTickSpacing - 类 javax.swing.JSlider 中的变量
主刻度标记（分解次刻度标记的较大标记）之间的值的个数。
make_object(String, byte[]) - 接口 org.omg.PortableInterceptor.ObjectReferenceFactory 中的方法
make_object 根据此模板中的数据，使用给定的存储库 ID 和对象 ID 创建 CORBA 对象引用。
makeBounds(double, double, double, double) - 类 java.awt.geom.Arc2D.Double 中的方法
构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
makeBounds(double, double, double, double) - 类 java.awt.geom.Arc2D.Float 中的方法
构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
makeBounds(double, double, double, double) - 类 java.awt.geom.Arc2D 中的方法
构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
makeClient(String, Subject) - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法
创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。
makeClient(String, Subject) - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法
创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。
makeClient(String, Subject) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
创建一个新的客户端连接。
makeComponentInputMap(JComponent, Object[]) - 类 javax.swing.LookAndFeel 中的静态方法
根据 keys 创建一个 ComponentInputMapUIResource。
makeIcon(Class<?>, String) - 类 javax.swing.LookAndFeel 中的静态方法
创建并返回一个加载图像的 UIDefault.LazyValue。
makeInputMap(Object[]) - 类 javax.swing.LookAndFeel 中的静态方法
根据 keys 创建一个 InputMapUIResource。
makeKeyBindings(Object[]) - 类 javax.swing.LookAndFeel 中的静态方法
构建一个 KeyBinding 数组的便捷方法。
makeParser() - 类 org.xml.sax.helpers.ParserFactory 中的静态方法
已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
makeParser(String) - 类 org.xml.sax.helpers.ParserFactory 中的静态方法
已过时。 使用提供的类名创建一个新的 SAX 解析器对象。
makeTag(Element, boolean) - 类 javax.swing.text.html.parser.Parser 中的方法
制作 TagElement。
makeTag(Element) - 类 javax.swing.text.html.parser.Parser 中的方法
makeVisible(int) - 类 java.awt.List 中的方法
使指定索引处的项可视。
makeVisible(TreePath) - 类 javax.swing.JTree 中的方法
确保路径标识的节点当前可查看。
MALAYALAM - 类 java.awt.font.NumericShaper 中的静态变量
标识 MALAYALAM 范围和十进制基数。
MALAYALAM - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Malayalam”Unicode 字符块的常量。
malformedForLength(int) - 类 java.nio.charset.CoderResult 中的静态方法
静态工厂方法，返回描述给定长度的错误输入错误的唯一对象。
malformedInputAction() - 类 java.nio.charset.CharsetDecoder 中的方法
返回此解码器对错误输入错误的当前操作。
malformedInputAction() - 类 java.nio.charset.CharsetEncoder 中的方法
返回此编码器对错误输入错误的当前操作。
MalformedInputException - java.nio.charset 中的 异常
当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
MalformedInputException(int) - 异常 java.nio.charset.MalformedInputException 的构造方法
MalformedLinkException - javax.naming 中的 异常
如果在解析或构造链接时遇到错误链接，则抛出此异常。
MalformedLinkException(String) - 异常 javax.naming.MalformedLinkException 的构造方法
使用解释构造一个新的 MalformedLinkException 实例，其他所有字段都被初始化为 null。
MalformedLinkException() - 异常 javax.naming.MalformedLinkException 的构造方法
构造一个新的 Malformed LinkException 实例。
MalformedObjectNameException - javax.management 中的 异常
字符串的格式不对应于有效的 ObjectName。
MalformedObjectNameException() - 异常 javax.management.MalformedObjectNameException 的构造方法
默认的构造方法。
MalformedObjectNameException(String) - 异常 javax.management.MalformedObjectNameException 的构造方法
允许指定特定错误消息的构造方法。
MalformedParameterizedTypeException - java.lang.reflect 中的 异常
当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
MalformedParameterizedTypeException() - 异常 java.lang.reflect.MalformedParameterizedTypeException 的构造方法
MalformedURLException - java.net 中的 异常
抛出这一异常指示出现了错误的 URL。
MalformedURLException() - 异常 java.net.MalformedURLException 的构造方法
构造不带详细消息的 MalformedURLException。
MalformedURLException(String) - 异常 java.net.MalformedURLException 的构造方法
构造带指定详细消息的 MalformedURLException。
ManagementFactory - java.lang.management 中的 类
ManagementFactory 类是一种工厂类，用于获取 Java 平台的管理 Bean。
ManagementPermission - java.lang.management 中的 类
使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。
ManagementPermission(String) - 类 java.lang.management.ManagementPermission 的构造方法
构造具有指定名称的 ManagementPermission。
ManagementPermission(String, String) - 类 java.lang.management.ManagementPermission 的构造方法
构造新的 ManagementPermission 对象。
manager_id() - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
返回刚创建并在 IOR interceptor 上运行的对象适配器的对象适配器管理器 id。
ManageReferralControl - javax.naming.ldap 中的 类
将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。
ManageReferralControl() - 类 javax.naming.ldap.ManageReferralControl 的构造方法
构造一个关键的 ManageReferral 控件。
ManageReferralControl(boolean) - 类 javax.naming.ldap.ManageReferralControl 的构造方法
构造一个 ManageReferral 控件。
ManagerFactoryParameters - javax.net.ssl 中的 接口
此类是用来向 KeyManagerFactory 或 TrustManagerFactory 提供特定于算法的信息的基接口。
MANAGES_DESCENDANTS - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象负责管理其子组件。
Manifest - java.util.jar 中的 类
Manifest 类用于维护 Manifest 条目名称及其相关的 Attributes。
Manifest() - 类 java.util.jar.Manifest 的构造方法
构造新的空 Manifest。
Manifest(InputStream) - 类 java.util.jar.Manifest 的构造方法
从指定的输入流构造新的 Manifest。
Manifest(Manifest) - 类 java.util.jar.Manifest 的构造方法
构造新的 Manifest，它是指定 Manifest 的副本。
Manifest - javax.xml.crypto.dsig 中的 接口
在 W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Manifest 元素的表示形式。
MANIFEST_NAME - 类 java.util.jar.JarFile 中的静态变量
JAR 清单文件名称。
MANIFEST_VERSION - 类 java.util.jar.Attributes.Name 中的静态变量
Manifest-Version 的 Name 对象具有的属性。
MANUAL - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的手动进纸托盘。
map(FileChannel.MapMode, long, long) - 类 java.nio.channels.FileChannel 中的方法
将此通道的文件区域直接映射到内存中。
map - 类 java.util.jar.Attributes 中的变量
属性名称-值映射关系。
Map<K,V> - java.util 中的 接口
将键映射到值的对象。
MAP - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Map.Entry<K,V> - java.util 中的 接口
映射项（键-值对）。
mapInputMethodHighlight(InputMethodHighlight) - 类 java.awt.Toolkit 中的方法
返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。
mapLibraryName(String) - 类 java.lang.System 中的静态方法
将一个库名称映射到特定于平台的、表示本机库的字符串中。
MappedByteBuffer - java.nio 中的 类
直接字节缓冲区，其内容是文件的内存映射区域。
mapRenderContext(int, RenderContext, ParameterBlock, RenderableImage) - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。
mapSystemException(SystemException) - 类 javax.rmi.CORBA.Util 中的静态方法
将 SystemException 映射到 RemoteException。
mapSystemException(SystemException) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.mapSystemException(org.omg.CORBA.SystemException) 的委托调用。
MARCH - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第三个月的 Calendar.MONTH 字段值。
MARCH - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第三个月的值。
MARGIN - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
MARGIN_BOTTOM - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
MARGIN_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的边界空白的更改。
MARGIN_LEFT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
MARGIN_RIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
MARGIN_TOP - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
MARGINHEIGHT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
MARGINWIDTH - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
mark(int) - 类 java.io.BufferedInputStream 中的方法
参见 InputStream 的 mark 方法的常规协定。
mark(int) - 类 java.io.BufferedReader 中的方法
标记流中的当前位置。
mark - 类 java.io.ByteArrayInputStream 中的变量
流中当前的标记位置。
mark(int) - 类 java.io.ByteArrayInputStream 中的方法
设置流中的当前标记位置。
mark(int) - 类 java.io.CharArrayReader 中的方法
标记流中的当前位置。
mark(int) - 类 java.io.FilterInputStream 中的方法
在输入流中的当前位置上作标记。
mark(int) - 类 java.io.FilterReader 中的方法
在流中的当前位置上作标记。
mark(int) - 类 java.io.InputStream 中的方法
在此输入流中标记当前的位置。
mark(int) - 类 java.io.LineNumberInputStream 中的方法
已过时。 在此输入流中标记当前的位置。
mark(int) - 类 java.io.LineNumberReader 中的方法
标记该流中的当前位置。
mark(int) - 类 java.io.PushbackInputStream 中的方法
在此输入流中标记当前的位置。
mark(int) - 类 java.io.PushbackReader 中的方法
标记流中的当前位置。
mark(int) - 类 java.io.Reader 中的方法
标记流中的当前位置。
mark(int) - 类 java.io.StringReader 中的方法
标记流中的当前位置。
mark() - 类 java.nio.Buffer 中的方法
在此缓冲区的位置设置标记。
mark(int) - 类 java.util.zip.DeflaterInputStream 中的方法
不支持此操作。
mark(int) - 类 java.util.zip.InflaterInputStream 中的方法
标记此输入流中的当前位置。
mark() - 接口 javax.imageio.stream.ImageInputStream 中的方法
标记流中某个位置，供后续调用 reset 时返回。
mark() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
将当前流位置推进到标记位置的堆栈上。
mark(int) - 类 javax.sound.sampled.AudioInputStream 中的方法
标记此音频输入流中的当前位置。
markCompletelyClean(JComponent) - 类 javax.swing.RepaintManager 中的方法
标记完全干净的组件。
markCompletelyDirty(JComponent) - 类 javax.swing.RepaintManager 中的方法
标记完全弄脏的组件。
markedPos - 类 java.io.CharArrayReader 中的变量
缓冲区中标记的位置。
MARKER_SUPPLY_EMPTY - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）已用完。
MARKER_SUPPLY_LOW - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）不足。
MARKER_WASTE_ALMOST_FULL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备指示器耗材废物容器几乎已填满。
MARKER_WASTE_FULL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备指示器耗材废物容器已填满。
markFirstTime(Element) - 类 javax.swing.text.html.parser.Parser 中的方法
标记在文档中首次看到标记
marklimit - 类 java.io.BufferedInputStream 中的变量
调用 mark 方法后，在后续调用 reset 方法失败之前所允许的最大提前读取量。
markpos - 类 java.io.BufferedInputStream 中的变量
最后一次调用 mark 方法时 pos 字段的值。
markSupported() - 类 java.io.BufferedInputStream 中的方法
测试此输入流是否支持 mark 和 reset 方法。
markSupported() - 类 java.io.BufferedReader 中的方法
判断此流是否支持 mark() 操作（它一定支持）。
markSupported() - 类 java.io.ByteArrayInputStream 中的方法
测试此 InputStream 是否支持 mark/reset。
markSupported() - 类 java.io.CharArrayReader 中的方法
判断此流是否支持 mark() 操作（它一定支持）。
markSupported() - 类 java.io.FilterInputStream 中的方法
测试此输入流是否支持 mark 和 reset 方法。
markSupported() - 类 java.io.FilterReader 中的方法
判断此流是否支持 mark() 操作。
markSupported() - 类 java.io.InputStream 中的方法
测试此输入流是否支持 mark 和 reset 方法。
markSupported() - 类 java.io.PushbackInputStream 中的方法
测试此输入流是否支持 mark 和 reset 方法，此输入流不支持这两个方法。
markSupported() - 类 java.io.PushbackReader 中的方法
判断此流是否支持 mark() 操作（它一定不支持）。
markSupported() - 类 java.io.Reader 中的方法
判断此流是否支持 mark() 操作。
markSupported() - 类 java.io.StringReader 中的方法
判断此流是否支持 mark() 操作以及支持哪一项操作。
markSupported() - 类 java.util.zip.DeflaterInputStream 中的方法
始终返回 false，因为此输入流不支持 mark() 和 reset() 方法。
markSupported() - 类 java.util.zip.InflaterInputStream 中的方法
测试此输入流是否支持 mark 和 reset 方法。
markSupported() - 类 javax.crypto.CipherInputStream 中的方法
测试该输入流是否支持 mark 和 reset 方法以及哪一个方法确实不受支持。
markSupported() - 类 javax.sound.sampled.AudioInputStream 中的方法
测试此音频输入流是否支持 mark 和 reset 方法。
marshal(String) - 类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 中的方法
无任何操作。
marshal(byte[]) - 类 javax.xml.bind.annotation.adapters.HexBinaryAdapter 中的方法
marshal(String) - 类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 中的方法
无任何操作。
marshal(BoundType) - 类 javax.xml.bind.annotation.adapters.XmlAdapter 中的方法
将 bound 类型转换为 value 类型。
marshal(ElementT, ValidationEventHandler) - 接口 javax.xml.bind.annotation.DomHandler 中的方法
在 JAXB 提供者需要将元素编组为 XML 时调用此方法。
marshal(Element, ValidationEventHandler) - 类 javax.xml.bind.annotation.W3CDomHandler 中的方法
marshal(Object, XmlNode) - 类 javax.xml.bind.Binder 中的方法
将 JAXB 对象树编组为新的 XML 文档。
marshal(Object, OutputStream) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, Writer) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, ContentHandler) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, Node) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, XMLEventWriter) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, XMLStreamWriter) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, Result) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到指定的 javax.xml.transform.Result 中。
marshal(Object, OutputStream) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到输出流中。
marshal(Object, Writer) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到 Writer 中。
marshal(Object, ContentHandler) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。
marshal(Object, Node) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到 DOM 树中。
marshal(Object, XMLStreamWriter) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。
marshal(Object, XMLEventWriter) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。
marshal(XMLStructure, XMLCryptoContext) - 接口 javax.xml.crypto.dsig.keyinfo.KeyInfo 中的方法
将密钥信息编组为 XML。
marshal(DataOutputStream) - 接口 org.omg.CORBA.CustomMarshal 中的方法
必须通过自定义的 Marshal 类实现 marshal 方法。
MARSHAL - org.omg.CORBA 中的 异常
表示网络中传来的请求或应答在结构上无效。
MARSHAL() - 异常 org.omg.CORBA.MARSHAL 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 MARSHAL 异常。
MARSHAL(String) - 异常 org.omg.CORBA.MARSHAL 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 MARSHAL 异常。
MARSHAL(int, CompletionStatus) - 异常 org.omg.CORBA.MARSHAL 的构造方法
使用指定次要代码和完成状态构造一个 MARSHAL 异常。
MARSHAL(String, int, CompletionStatus) - 异常 org.omg.CORBA.MARSHAL 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 MARSHAL 异常。
MarshalException - java.rmi 中的 异常
如果在编组远程调用标题、参数或远程方法调用的返回值时发生 java.io.IOException，则抛出 MarshalException。
MarshalException(String) - 异常 java.rmi.MarshalException 的构造方法
构造带有指定详细消息的 MarshalException。
MarshalException(String, Exception) - 异常 java.rmi.MarshalException 的构造方法
构造带指定详细消息和嵌入异常的 MarshalException。
MarshalException - javax.xml.bind 中的 异常
此异常指示在执行提供者无法恢复的编组操作时发生错误。
MarshalException(String) - 异常 javax.xml.bind.MarshalException 的构造方法
构造带指定详细消息的 MarshalException。
MarshalException(String, String) - 异常 javax.xml.bind.MarshalException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 MarshalException。
MarshalException(Throwable) - 异常 javax.xml.bind.MarshalException 的构造方法
构造带有一个 linkedException 的 MarshalException。
MarshalException(String, Throwable) - 异常 javax.xml.bind.MarshalException 的构造方法
构造带指定的详细消息和 linkedException 的 MarshalException。
MarshalException(String, String, Throwable) - 异常 javax.xml.bind.MarshalException 的构造方法
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 MarshalException。
MarshalException - javax.xml.crypto 中的 异常
指示 XML 编组或解组过程中发生的异常条件。
MarshalException() - 异常 javax.xml.crypto.MarshalException 的构造方法
构造使用 null 作为其详细消息的新 MarshalException。
MarshalException(String) - 异常 javax.xml.crypto.MarshalException 的构造方法
构造带指定详细消息的新 MarshalException。
MarshalException(String, Throwable) - 异常 javax.xml.crypto.MarshalException 的构造方法
构造一个带指定详细消息和 cause 的新 MarshalException。
MarshalException(Throwable) - 异常 javax.xml.crypto.MarshalException 的构造方法
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的 MarshalException（它通常包含 cause 的类和详细消息）。
MarshalledObject<T> - java.rmi 中的 类
MarshalledObject 包含一个字节流，该流具有给定了其构造方法的对象的序列化表示形式。
MarshalledObject(T) - 类 java.rmi.MarshalledObject 的构造方法
创建一个新的 MarshalledObject，它包含所提供对象的当前状态的序列化表示形式。
Marshaller - javax.xml.bind 中的 接口
Marshaller 类负责管理将 Java 内容树序列化回 XML 数据的过程。
Marshaller.Listener - javax.xml.bind 中的 类

向 Marshaller 注册此类的一个实现的实例，以从外部侦听编组事件。

Marshaller.Listener() - 类 javax.xml.bind.Marshaller.Listener 的构造方法
marshalParams(XMLStructure, XMLCryptoContext) - 类 javax.xml.crypto.dsig.TransformService 中的方法
对特定于算法的参数进行编组。
MaskFormatter - javax.swing.text 中的 类
MaskFormatter 用于格式化和编辑字符串。
MaskFormatter() - 类 javax.swing.text.MaskFormatter 的构造方法
创建一个不带掩码的 MaskFormatter。
MaskFormatter(String) - 类 javax.swing.text.MaskFormatter 的构造方法
创建具有指定掩码的 MaskFormatter。
MASTER_GAIN - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上总音量的控件。
match(DataFlavor) - 类 java.awt.datatransfer.DataFlavor 中的方法
测试 DataFlavor 与此 DataFlavor 的相等性。
match(Certificate) - 接口 java.security.cert.CertSelector 中的方法
决定是否应该选择某个 Certificate。
match(CRL) - 接口 java.security.cert.CRLSelector 中的方法
决定是否应该选择某个 CRL。
match(Certificate) - 类 java.security.cert.X509CertSelector 中的方法
决定是否应该选择某个 Certificate。
match(CRL) - 类 java.security.cert.X509CRLSelector 中的方法
决定是否应该选择某个 CRL。
match() - 类 java.util.Scanner 中的方法
返回此扫描器所执行的最后扫描操作的匹配结果。
match(MimeType) - 类 javax.activation.MimeType 中的方法
确定此对象的基本类型和子类型与给定类型中的类型是否相同。
match(String) - 类 javax.activation.MimeType 中的方法
确定此对象的基本类型和子类型与 rawdata 中描述的内容类型是否相同。
match(AttributeValueExp, StringValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于字符串参数的匹配约束条件。
Matcher - java.util.regex 中的 类
通过解释 Pattern 对 character sequence 执行匹配操作的引擎。
matcher(CharSequence) - 类 java.util.regex.Pattern 中的方法
创建匹配给定输入与此模式的匹配器。
matches(String) - 类 java.lang.String 中的方法
告知此字符串是否匹配给定的正则表达式。
matches() - 类 java.util.regex.Matcher 中的方法
尝试将整个区域与模式匹配。
matches(String, CharSequence) - 类 java.util.regex.Pattern 中的静态方法
编译给定正则表达式并尝试将给定输入与其匹配。
matches(AudioFormat) - 类 javax.sound.sampled.AudioFormat 中的方法
指示此格式是否与指定格式匹配。
matches(Line.Info) - 类 javax.sound.sampled.DataLine.Info 中的方法
确定指定的信息对象是否与此对象匹配。
matches(Line.Info) - 类 javax.sound.sampled.Line.Info 中的方法
指示指定的信息对象是否与此对象匹配。
matches(Line.Info) - 类 javax.sound.sampled.Port.Info 中的方法
指示此指定 info 对象是否与此对象匹配。
matchNameAttribute(AttributeSet, HTML.Tag) - 类 javax.swing.text.html.HTMLWriter 中的方法
如果 StyleConstants.NameAttribute 与作为参数传入的标记相同，则返回 true。
MatchResult - java.util.regex 中的 接口
匹配操作的结果。
Math - java.lang 中的 类
Math 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。
MATH_SYMBOL - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Sm”。
MathContext - java.math 中的 类
该对象是封装上下文设置的不可变对象，它描述数字运算符的某些规则，例如由 BigDecimal 类实现的规则。
MathContext(int) - 类 java.math.MathContext 的构造方法
构造一个新的 MathContext，它具有指定的精度和 HALF_UP 舍入模式。
MathContext(int, RoundingMode) - 类 java.math.MathContext 的构造方法
构造一个新的 MathContext，它具有指定的精度和舍入模式。
MathContext(String) - 类 java.math.MathContext 的构造方法
根据字符串构造一个新的 MathContext。
MATHEMATICAL_ALPHANUMERIC_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Mathematical Alphanumeric Symbols”Unicode 字符块的常量。
MATHEMATICAL_OPERATORS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Mathematical Operators”Unicode 字符块的常量。
MatteBorder - javax.swing.border 中的 类
该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
MatteBorder(int, int, int, int, Color) - 类 javax.swing.border.MatteBorder 的构造方法
创建具有指定 insets 和颜色的衬边边框。
MatteBorder(Insets, Color) - 类 javax.swing.border.MatteBorder 的构造方法
创建具有指定 insets 和颜色的衬边边框。
MatteBorder(int, int, int, int, Icon) - 类 javax.swing.border.MatteBorder 的构造方法
创建具有指定 insets 和平铺图标的衬边边框。
MatteBorder(Insets, Icon) - 类 javax.swing.border.MatteBorder 的构造方法
创建具有指定 insets 和平铺图标的衬边边框。
MatteBorder(Icon) - 类 javax.swing.border.MatteBorder 的构造方法
创建具有指定平铺图标的衬边边框。
max(int, int) - 类 java.lang.Math 中的静态方法
返回两个 int 值中较大的一个。
max(long, long) - 类 java.lang.Math 中的静态方法
返回两个 long 值中较大的一个。
max(float, float) - 类 java.lang.Math 中的静态方法
返回两个 float 值中较大的一个。
max(double, double) - 类 java.lang.Math 中的静态方法
返回两个 double 值中较大的一个。
max(int, int) - 类 java.lang.StrictMath 中的静态方法
返回两个 int 值中较大的一个。
max(long, long) - 类 java.lang.StrictMath 中的静态方法
返回两个 long 值中较大的一个。
max(float, float) - 类 java.lang.StrictMath 中的静态方法
返回两个 float 值中较大的一个。
max(double, double) - 类 java.lang.StrictMath 中的静态方法
返回两个 double 值中较大的一个。
max(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 和 val 的最大值。
max(BigInteger) - 类 java.math.BigInteger 中的方法
返回此 BigInteger 和 val 的最大值。
max(Collection<? extends T>) - 类 java.util.Collections 中的静态方法
根据元素的自然顺序，返回给定 collection 的最大元素。
max(Collection<? extends T>, Comparator<? super T>) - 类 java.util.Collections 中的静态方法
根据指定比较器产生的顺序，返回给定 collection 的最大元素。
max(Spring, Spring) - 类 javax.swing.Spring 中的静态方法
返回 max(s1, s2)：一个其值始终大于（或等于）s1 加 s2 的值的 spring。
MAX_BUFFER - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定 SaslClient/SaslServer 接收缓冲区的最大大小（以字节为单位）。
MAX_CODE_POINT - 类 java.lang.Character 中的静态变量
Unicode 代码点的最大值。
MAX_COUNT - 类 javax.swing.plaf.synth.ColorType 中的静态变量
最大 ColorType 数。
MAX_EXPONENT - 类 java.lang.Double 中的静态变量
有限 double 变量可能具有的最大指数。
MAX_EXPONENT - 类 java.lang.Float 中的静态变量
有限 float 变量可能具有的最大指数。
MAX_HIGH_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 高代理项代码单元的最大值。
MAX_KEY_LENGTH - 类 java.util.prefs.Preferences 中的静态变量
允许作为键的字符串最大长度（80 个字符）。
MAX_LOW_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 低代理项代码单元的最大值。
MAX_NAME_LENGTH - 类 java.util.prefs.Preferences 中的静态变量
节点名的最大长度（80 个字符）。
MAX_PRIORITY - 类 java.lang.Thread 中的静态变量
线程可以具有的最高优先级。
MAX_RADIX - 类 java.lang.Character 中的静态变量
可用于与字符串相互转换的最大基数。
MAX_SCROLL - 类 javax.swing.plaf.basic.BasicSliderUI 中的静态变量
MAX_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 代理项代码单元的最大值。
MAX_TIMEZONE_OFFSET - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式最大时区偏移量是 -14:00。
MAX_VALUE - 类 java.lang.Byte 中的静态变量
一个常量，保存 byte 类型可取的最大值，即 27-1。
MAX_VALUE - 类 java.lang.Character 中的静态变量
此字段的常量值是 char 类型的最大值，即 '\uFFFF'。
MAX_VALUE - 类 java.lang.Double 中的静态变量
保存 double 类型的最大正有限值的常量，最大正有限值为 (2-2-52)·21023。
MAX_VALUE - 类 java.lang.Float 中的静态变量
保存 float 类型的最大正有限值的常量，即 (2-2-23)·2127。
MAX_VALUE - 类 java.lang.Integer 中的静态变量
值为 231－1 的常量，它表示 int 类型能够表示的最大值。
MAX_VALUE - 类 java.lang.Long 中的静态变量
保持 long 类型的最大值的常量，该值为 263-1。
MAX_VALUE - 类 java.lang.Short 中的静态变量
保存 short 可取的最大值的常量，最大值为 215-1。
MAX_VALUE_FIELD - 类 javax.management.JMX 中的静态变量
maxValue 字段的名称。
MAX_VALUE_LENGTH - 类 java.util.prefs.Preferences 中的静态变量
允许作为值的字符串最大长度（8192 个字符）。
MAXBQUALSIZE - 接口 javax.transaction.xa.Xid 中的静态变量
getBqual 返回的最大字节数。
maxButton - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
maxBytesPerChar() - 类 java.nio.charset.CharsetEncoder 中的方法
返回为每个输入字符生成的最大字节数。
maxCharsPerByte() - 类 java.nio.charset.CharsetDecoder 中的方法
返回为每个输入字节生成的最大字符数。
MAXGRIDSIZE - 类 java.awt.GridBagLayout 中的静态变量
此字段不再用于保留数组和保持向后兼容性。
MAXGTRIDSIZE - 接口 javax.transaction.xa.Xid 中的静态变量
getGtrid 返回的最大字节数。
maxIcon - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
maximizable - 类 javax.swing.JInternalFrame 中的变量
可将窗体扩展到桌面窗格的大小。
MAXIMIZE_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
maximizeAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
MAXIMIZED_BOTH - 类 java.awt.Frame 中的静态变量
此状态位掩码指示将窗体完全最大化（水平和垂直方向）。
MAXIMIZED_HORIZ - 类 java.awt.Frame 中的静态变量
此状态位指示在水平方向将窗体最大化。
MAXIMIZED_VERT - 类 java.awt.Frame 中的静态变量
此状态位指示在垂直方向将窗体最大化。
maximizeFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
重新调整窗体的大小，使其满足其父窗体的限制。
maximizeFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常，应该重新调整窗体的大小，使其满足其父窗体的限制。
maximizeFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
当用户要最大化窗体时调用此方法。
maximizeKey - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
已过时。 从 1.3 开始。
maximum - 类 javax.swing.SizeRequirements 中的变量
允许的最大大小。
maximumLayoutSize(Container) - 类 java.awt.BorderLayout 中的方法
在给出指定目标容器中的组件的前提下，返回此布局的最大尺寸。
maximumLayoutSize(Container) - 类 java.awt.CardLayout 中的方法
给出指定目标容器中的组件，返回此布局的最大尺寸。
maximumLayoutSize(Container) - 类 java.awt.GridBagLayout 中的方法
在给出指定目标容器中的组件的前提下，返回此布局的最大维数
maximumLayoutSize(Container) - 接口 java.awt.LayoutManager2 中的方法
给定指定容器的组件，计算该容器的最大大小维数。
maximumLayoutSize(Container) - 类 javax.swing.BoxLayout 中的方法
返回目标容器布置其所包含的组件时可使用的最大尺寸。
maximumLayoutSize(Container) - 类 javax.swing.GroupLayout 中的方法
返回指定容器的最大大小。
maximumLayoutSize(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法
返回布局能够使用的最大空间量。
maximumLayoutSize(Container) - 类 javax.swing.OverlayLayout 中的方法
返回需要布置组件的最大维数，该组件包含在指定的目标容器中。
maximumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回最大布局大小，该大小在两个方向上都是 Integer.MAX_VALUE。
maximumLayoutSize(Container) - 类 javax.swing.SpringLayout 中的方法
maximumRowCount - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
maximumThumbSize - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
MAXLENGTH - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
maxMemory() - 类 java.lang.Runtime 中的方法
返回 Java 虚拟机试图使用的最大内存量。
maxTabHeight - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
maxTabWidth - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
maxWidth - 类 javax.swing.table.TableColumn 中的变量
列的最大宽度。
MAY - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第五个月的 Calendar.MONTH 字段值。
MAY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第五个月的值。
maybeUpdateLayoutState() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
如果 updateLayoutStateNeeded 为非 0，则调用 updateLayoutState() 并重置 updateLayoutStateNeeded。
MBeanAttributeInfo - javax.management 中的 类
描述出于管理目的而公开的 MBean 属性。
MBeanAttributeInfo(String, String, String, boolean, boolean, boolean) - 类 javax.management.MBeanAttributeInfo 的构造方法
构造一个 MBeanAttributeInfo 对象。
MBeanAttributeInfo(String, String, String, boolean, boolean, boolean, Descriptor) - 类 javax.management.MBeanAttributeInfo 的构造方法
构造一个 MBeanAttributeInfo 对象。
MBeanAttributeInfo(String, String, Method, Method) - 类 javax.management.MBeanAttributeInfo 的构造方法
此构造方法带有简单属性的名称，以及读取和写入属性的 Method 对象。
MBeanConstructorInfo - javax.management 中的 类
描述 MBean 所公开的构造方法。
MBeanConstructorInfo(String, Constructor) - 类 javax.management.MBeanConstructorInfo 的构造方法
构造一个 MBeanConstructorInfo 对象。
MBeanConstructorInfo(String, String, MBeanParameterInfo[]) - 类 javax.management.MBeanConstructorInfo 的构造方法
构造一个 MBeanConstructorInfo 对象。
MBeanConstructorInfo(String, String, MBeanParameterInfo[], Descriptor) - 类 javax.management.MBeanConstructorInfo 的构造方法
构造一个 MBeanConstructorInfo 对象。
MBeanException - javax.management 中的 异常
表示由代理的 MBean 方法所抛出的“用户定义的”异常。
MBeanException(Exception) - 异常 javax.management.MBeanException 的构造方法
创建一个包装实际 java.lang.Exception 的 MBeanException。
MBeanException(Exception, String) - 异常 javax.management.MBeanException 的构造方法
创建一个包装实际 java.lang.Exception 的 MBeanException（带有详细消息）。
MBeanFeatureInfo - javax.management 中的 类
提供 MBean 描述符对象的常规信息。
MBeanFeatureInfo(String, String) - 类 javax.management.MBeanFeatureInfo 的构造方法
构造一个 MBeanFeatureInfo 对象。
MBeanFeatureInfo(String, String, Descriptor) - 类 javax.management.MBeanFeatureInfo 的构造方法
构造一个 MBeanFeatureInfo 对象。
MBeanInfo - javax.management 中的 类
描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
MBeanInfo(String, String, MBeanAttributeInfo[], MBeanConstructorInfo[], MBeanOperationInfo[], MBeanNotificationInfo[]) - 类 javax.management.MBeanInfo 的构造方法
构造一个 MBeanInfo。
MBeanInfo(String, String, MBeanAttributeInfo[], MBeanConstructorInfo[], MBeanOperationInfo[], MBeanNotificationInfo[], Descriptor) - 类 javax.management.MBeanInfo 的构造方法
构造一个 MBeanInfo。
MBeanNotificationInfo - javax.management 中的 类
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
MBeanNotificationInfo(String[], String, String) - 类 javax.management.MBeanNotificationInfo 的构造方法
构造一个 MBeanNotificationInfo 对象。
MBeanNotificationInfo(String[], String, String, Descriptor) - 类 javax.management.MBeanNotificationInfo 的构造方法
构造一个 MBeanNotificationInfo 对象。
MBeanOperationInfo - javax.management 中的 类
描述由 MBean 公开的管理操作。
MBeanOperationInfo(String, Method) - 类 javax.management.MBeanOperationInfo 的构造方法
构造一个 MBeanOperationInfo 对象。
MBeanOperationInfo(String, String, MBeanParameterInfo[], String, int) - 类 javax.management.MBeanOperationInfo 的构造方法
构造一个 MBeanOperationInfo 对象。
MBeanOperationInfo(String, String, MBeanParameterInfo[], String, int, Descriptor) - 类 javax.management.MBeanOperationInfo 的构造方法
构造一个 MBeanOperationInfo 对象。
MBeanParameterInfo - javax.management 中的 类
描述由 MBean 公开的操作的参数。
MBeanParameterInfo(String, String, String) - 类 javax.management.MBeanParameterInfo 的构造方法
构造一个 MBeanParameterInfo 对象。
MBeanParameterInfo(String, String, String, Descriptor) - 类 javax.management.MBeanParameterInfo 的构造方法
构造一个 MBeanParameterInfo 对象。
MBeanPermission - javax.management 中的 类
权限控制对 MBeanServer 操作的访问。
MBeanPermission(String, String) - 类 javax.management.MBeanPermission 的构造方法
创建具有指定目标名称和操作的新 MBeanPermission 对象。
MBeanPermission(String, String, ObjectName, String) - 类 javax.management.MBeanPermission 的构造方法
创建具有指定目标名称（类名、成员、对象名）和操作的 MBeanPermission 对象。
MBeanRegistration - javax.management 中的 接口
可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanRegistrationException - javax.management 中的 异常
包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
MBeanRegistrationException(Exception) - 异常 javax.management.MBeanRegistrationException 的构造方法
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException。
MBeanRegistrationException(Exception, String) - 异常 javax.management.MBeanRegistrationException 的构造方法
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException（带有详细消息）。
MBeanServer - javax.management 中的 接口
这是在代理端进行 MBean 操作的接口。
MBeanServerBuilder - javax.management 中的 类
此类表示创建默认 MBeanServer 实现的生成器。
MBeanServerBuilder() - 类 javax.management.MBeanServerBuilder 的构造方法
公共的默认构造方法。
MBeanServerConnection - javax.management 中的 接口
此接口表示了与 MBean 服务器（无论是本地的还是远程的）进行通信的一种方式。
MBeanServerDelegate - javax.management 中的 类
从管理的角度表示 MBean 服务器。
MBeanServerDelegate() - 类 javax.management.MBeanServerDelegate 的构造方法
创建一个 MBeanServerDelegate 对象。
MBeanServerDelegateMBean - javax.management 中的 接口
定义类 MBeanServerDelegate 的对象的管理接口。
MBeanServerFactory - javax.management 中的 类
提供 MBean 服务器引用。
MBeanServerForwarder - javax.management.remote 中的 接口
此类的对象实现 MBeanServer 接口并包装另一个也实现此接口的对象。
MBeanServerInvocationHandler - javax.management 中的 类
通过 MBean 服务器将 MBean 的管理接口中的方法转发到 MBean 的 InvocationHandler。
MBeanServerInvocationHandler(MBeanServerConnection, ObjectName) - 类 javax.management.MBeanServerInvocationHandler 的构造方法
通过 MBean 服务器将方法转发给 Standard MBean 的调用处理程序。
MBeanServerInvocationHandler(MBeanServerConnection, ObjectName, boolean) - 类 javax.management.MBeanServerInvocationHandler 的构造方法
可以通过 MBean 服务器将方法转发给 Standard MBean 或 MXBean 的调用处理程序。
MBeanServerNotification - javax.management 中的 类
表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。
MBeanServerNotification(String, Object, long, ObjectName) - 类 javax.management.MBeanServerNotification 的构造方法
创建一个指定了导致该通知的 MBean 对象名和指定通知类型的 MBeanServerNotification 对象。
MBeanServerNotificationFilter - javax.management.relation 中的 类
MBeanServerNotification 的过滤器。
MBeanServerNotificationFilter() - 类 javax.management.relation.MBeanServerNotificationFilter 的构造方法
创建一个选中所有 ObjectName 的所有 MBeanServerNotification 通知的过滤器。
MBeanServerPermission - javax.management 中的 类
执行与 MBeanServer 关联的操作的 Permission。
MBeanServerPermission(String) - 类 javax.management.MBeanServerPermission 的构造方法
创建具有给定名称的新 MBeanServerPermission。
MBeanServerPermission(String, String) - 类 javax.management.MBeanServerPermission 的构造方法
创建具有给定名称的新 MBeanServerPermission。
MBeanTrustPermission - javax.management 中的 类
此权限表示“信任”签名者或代码基。
MBeanTrustPermission(String) - 类 javax.management.MBeanTrustPermission 的构造方法
创建具有给定名称的新 MBeanTrustPermission。
MBeanTrustPermission(String, String) - 类 javax.management.MBeanTrustPermission 的构造方法
创建具有给定名称的新 MBeanTrustPermission。
MD - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Media - javax.print.attribute.standard 中的 类
Media 类是打印属性类，它指定了要在其上打印的介质。
Media(int) - 类 javax.print.attribute.standard.Media 的构造方法
构造通过名称指定的新 Media 属性。
MEDIA_EMPTY - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
至少一个输入纸盒是空的。
MEDIA_JAM - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备中卡住了介质。
MEDIA_LOW - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
至少一个输入纸盒的介质不足。
MEDIA_NEEDED - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
纸盒中没有介质。
MEDIA_TYPE - 类 javax.xml.transform.OutputKeys 中的静态变量
media-type = string. media-type 指定了输出结果树得到的数据的介质类型（MIME 内容类型）。
MediaName - javax.print.attribute.standard 中的 类
MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
MediaName(int) - 类 javax.print.attribute.standard.MediaName 的构造方法
构造具有给定整数值的新 MediaName 枚举值。
MediaPrintableArea - javax.print.attribute.standard 中的 类
MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
MediaPrintableArea(float, float, float, float, int) - 类 javax.print.attribute.standard.MediaPrintableArea 的构造方法
从浮点值构造 MediaPrintableArea 对象。
MediaPrintableArea(int, int, int, int, int) - 类 javax.print.attribute.standard.MediaPrintableArea 的构造方法
从整数值构造 MediaPrintableArea 对象。
MediaSize - javax.print.attribute.standard 中的 类
MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。
MediaSize(float, float, int) - 类 javax.print.attribute.standard.MediaSize 的构造方法
从给定浮点值构造新 MediaSize 属性。
MediaSize(int, int, int) - 类 javax.print.attribute.standard.MediaSize 的构造方法
从给定整数值构造新 MediaSize 属性。
MediaSize(float, float, int, MediaSizeName) - 类 javax.print.attribute.standard.MediaSize 的构造方法
从给定浮点值构造新 MediaSize 属性。
MediaSize(int, int, int, MediaSizeName) - 类 javax.print.attribute.standard.MediaSize 的构造方法
从给定整数值构造新 MediaSize 属性。
MediaSize.Engineering - javax.print.attribute.standard 中的 类
MediaSize.Engineering 类包括 engineering 介质的 MediaSize 值。
MediaSize.ISO - javax.print.attribute.standard 中的 类
MediaSize.ISO 类包括 ISO 介质的 MediaSize 值。
MediaSize.JIS - javax.print.attribute.standard 中的 类
MediaSize.JIS 类包括 JIS (Japanese) 介质的 MediaSize 值。
MediaSize.NA - javax.print.attribute.standard 中的 类
MediaSize.NA 类包括 North American 介质的 MediaSize 值。
MediaSize.Other - javax.print.attribute.standard 中的 类
MediaSize.Other 类包括其他介质的 MediaSize 值。
MediaSizeName - javax.print.attribute.standard 中的 类
MediaSizeName 类是 Media 的子类。
MediaSizeName(int) - 类 javax.print.attribute.standard.MediaSizeName 的构造方法
构造具有给定整数值的新 MediaSizeName 枚举值。
MediaTracker - java.awt 中的 类
MediaTracker 类是一个跟踪多种媒体对象状态的实用工具类。
MediaTracker(Component) - 类 java.awt.MediaTracker 的构造方法
创建媒体跟踪器以跟踪给定组件的图像。
MediaTray - javax.print.attribute.standard 中的 类
MediaTray 类是 Media 的子类。
MediaTray(int) - 类 javax.print.attribute.standard.MediaTray 的构造方法
构造具有给定整数值的新 MediaTray 枚举值。
MEDIUM - 类 java.text.DateFormat 中的静态变量
用于 MEDIUM 模式的常量。
Member - java.lang.reflect 中的 接口
成员是一种接口，反映有关单个成员（字段或方法）或构造方法的标识信息。
member() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 返回为了插入/获取此 union 成员而使用的 DynAny 对象引用。
member() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回当前活动成员。
member() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
返回当前活动成员。
member_count() - 类 org.omg.CORBA.TypeCode 中的方法
检索此 TypeCode 对象所描述类型中的成员数。
member_kind() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 返回与此 union 成员关联的 TCKind。
member_kind() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回当前活动成员 TypeCode 的 TCKind 值。
member_kind() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
返回当前活动成员 TypeCode 的 TCKind 值。
member_label(int) - 类 org.omg.CORBA.TypeCode 中的方法
检索给定索引标识的 union 成员的标签。
member_name() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 允许在没有检查鉴别符值的情况下检测此 union 成员的名称。
member_name(String) - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 允许分配此 union 成员的名称。
member_name(int) - 类 org.omg.CORBA.TypeCode 中的方法
检索给定索引标识的成员的简单名称。
member_name() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回当前活动成员的名称。
member_name() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
返回当前活动成员的名称。
MEMBER_OF - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个目标对象集合的成员。
MEMBER_OF_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
标识组成员已更改。
member_type(int) - 类 org.omg.CORBA.TypeCode 中的方法
检索一个 TypeCode 对象，它描述给定索引所标识成员的类型。
member_visibility(int) - 类 org.omg.CORBA.TypeCode 中的方法
返回一个常量，它指示位于给定索引处的成员的可见性。
members() - 接口 java.security.acl.Group 中的方法
返回此组中成员的枚举。
MEMORY_COLLECTION_THRESHOLD_EXCEEDED - 类 java.lang.management.MemoryNotificationInfo 中的静态变量
表示当 Java 虚拟机对内存池中的不使用的对象进行了回收工作之后，内存池的内存使用量大于或等于其集合使用量阈值的通知类型。
MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE - 类 java.lang.management.ManagementFactory 中的静态变量
MemoryManagerMXBean 的 ObjectName 中的域名和类型键属性。
MEMORY_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
MemoryMXBean 的 ObjectName 的字符串表示形式。
MEMORY_POOL_MXBEAN_DOMAIN_TYPE - 类 java.lang.management.ManagementFactory 中的静态变量
MemoryPoolMXBean 的 ObjectName 中的域名和类型键属性。
MEMORY_THRESHOLD_EXCEEDED - 类 java.lang.management.MemoryNotificationInfo 中的静态变量
表示内存池的内存使用量已达到或超过其使用量阈值的通知类型。
MemoryCacheImageInputStream - javax.imageio.stream 中的 类
从常规 InputStream 获取输入的 ImageInputStream 的实现。
MemoryCacheImageInputStream(InputStream) - 类 javax.imageio.stream.MemoryCacheImageInputStream 的构造方法
构造一个将从给定 InputStream 进行读取的 MemoryCacheImageInputStream。
MemoryCacheImageOutputStream - javax.imageio.stream 中的 类
将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
MemoryCacheImageOutputStream(OutputStream) - 类 javax.imageio.stream.MemoryCacheImageOutputStream 的构造方法
构造将向给定 OutputStream 进行写入的 MemoryCacheImageOutputStream。
MemoryHandler - java.util.logging 中的 类
Handler 在内存中的循环缓冲区中对请求进行缓冲处理。
MemoryHandler() - 类 java.util.logging.MemoryHandler 的构造方法
根据 LogManager 配置属性创建一个 MemoryHandler，并对其进行配置。
MemoryHandler(Handler, int, Level) - 类 java.util.logging.MemoryHandler 的构造方法
创建一个 MemoryHandler。
MemoryImageSource - java.awt.image 中的 类
此类是 ImageProducer 接口的一个实现，该接口使用一个数组为 Image 生成像素值。
MemoryImageSource(int, int, ColorModel, byte[], int, int) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int, int, ColorModel, byte[], int, int, Hashtable<?, ?>) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int, int, ColorModel, int[], int, int) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int, int, ColorModel, int[], int, int, Hashtable<?, ?>) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int, int, int[], int, int) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用默认 RGB ColorModel 中的整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int, int, int[], int, int, Hashtable<?, ?>) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用默认 RGB ColorModel 中的整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryManagerMXBean - java.lang.management 中的 接口
内存管理器的管理接口。
MemoryMXBean - java.lang.management 中的 接口
Java 虚拟机内存系统的管理接口。
MemoryNotificationInfo - java.lang.management 中的 类
关于内存通知的信息。
MemoryNotificationInfo(String, MemoryUsage, long) - 类 java.lang.management.MemoryNotificationInfo 的构造方法
构造一个 MemoryNotificationInfo 对象。
MemoryPoolMXBean - java.lang.management 中的 接口
内存池的管理接口。
MemoryType - java.lang.management 中的 枚举
内存池的类型。
MemoryUsage - java.lang.management 中的 类
表示内存使用量快照的 MemoryUsage 对象。
MemoryUsage(long, long, long, long) - 类 java.lang.management.MemoryUsage 的构造方法
构造一个 MemoryUsage 对象。
Menu - java.awt 中的 类
Menu 对象是从菜单栏部署的下拉式菜单组件。
Menu() - 类 java.awt.Menu 的构造方法
构造具有空标签的新菜单。
Menu(String) - 类 java.awt.Menu 的构造方法
构造具有指定标签的新菜单。
Menu(String, boolean) - 类 java.awt.Menu 的构造方法
构造具有指定标签的新菜单，指示该菜单是否可以分离。
MENU - 类 java.awt.SystemColor 中的静态变量
SystemColor.menu 系统颜色的数组索引。
menu - 类 java.awt.SystemColor 中的静态变量
为菜单提供的背景色。
MENU - 类 javax.accessibility.AccessibleRole 中的静态变量
通常出现在菜单栏中的对象，它包含一个用户可以从中选择的动作列表。
menu - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 中的变量
MENU - 类 javax.swing.plaf.synth.Region 中的静态变量
Menu 的 region。
MENU - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Menu.AccessibleAWTMenu - java.awt 中的 类
菜单的内部类，用于为可访问性提供默认支持。
Menu.AccessibleAWTMenu() - 类 java.awt.Menu.AccessibleAWTMenu 的构造方法
MENU_BAR - 类 javax.accessibility.AccessibleRole 中的静态变量
通常被绘制在应用程序的主对话框顶部的对象，它包含用户可以从中进行选择的菜单列表。
MENU_BAR - 类 javax.swing.plaf.synth.Region 中的静态变量
MenuBar 的 region。
MENU_BAR_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
MENU_ITEM - 类 javax.accessibility.AccessibleRole 中的静态变量
通常包含在菜单中的对象，该对象呈现用户可以选择的动作。
MENU_ITEM - 类 javax.swing.plaf.synth.Region 中的静态变量
MenuItem 的 region。
MENU_ITEM_ACCELERATOR - 类 javax.swing.plaf.synth.Region 中的静态变量
MenuItem 的加速器 region。
MENU_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.menuText 系统颜色的数组索引。
MenuBar - java.awt 中的 类
MenuBar 类封装绑定到框架的菜单栏的平台概念。
MenuBar() - 类 java.awt.MenuBar 的构造方法
创建新的菜单栏。
menuBar - 类 javax.swing.JRootPane 中的变量
菜单栏。
menuBar - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
menuBar - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的变量
MenuBar.AccessibleAWTMenuBar - java.awt 中的 类
菜单栏的内部类，用于为可访问性提供默认支持。
MenuBar.AccessibleAWTMenuBar() - 类 java.awt.MenuBar.AccessibleAWTMenuBar 的构造方法
MenuBarUI - javax.swing.plaf 中的 类
JMenuBar 的可插入外观界面。
MenuBarUI() - 类 javax.swing.plaf.MenuBarUI 的构造方法
menuCanceled(MenuEvent) - 接口 javax.swing.event.MenuListener 中的方法
取消菜单时调用。
MenuComponent - java.awt 中的 类
抽象类 MenuComponent 是所有与菜单相关的组件的超类。
MenuComponent() - 类 java.awt.MenuComponent 的构造方法
创建 MenuComponent。
MenuComponent.AccessibleAWTMenuComponent - java.awt 中的 类
用于为可访问性提供默认支持的 MenuComponent 的内部类。
MenuComponent.AccessibleAWTMenuComponent() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 的构造方法
尽管该类是抽象的，但是应该可以通过所有子类调用它。
MenuContainer - java.awt 中的 接口
所有菜单相关容器的超类。
menuDeselected(MenuEvent) - 接口 javax.swing.event.MenuListener 中的方法
取消选择某个菜单时调用。
menuDragMouseDragged(MenuDragMouseEvent) - 接口 javax.swing.event.MenuDragMouseListener 中的方法
当鼠标被拖动到某一菜单组件的显示区域中时调用。
menuDragMouseEntered(MenuDragMouseEvent) - 接口 javax.swing.event.MenuDragMouseListener 中的方法
当拖动的鼠标进入某一菜单组件的显示区域时调用。
MenuDragMouseEvent - javax.swing.event 中的 类
MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
MenuDragMouseEvent(Component, int, long, int, int, int, int, boolean, MenuElement[], MenuSelectionManager) - 类 javax.swing.event.MenuDragMouseEvent 的构造方法
构造一个 MenuDragMouseEvent 对象。
MenuDragMouseEvent(Component, int, long, int, int, int, int, int, int, boolean, MenuElement[], MenuSelectionManager) - 类 javax.swing.event.MenuDragMouseEvent 的构造方法
构造一个 MenuDragMouseEvent 对象。
menuDragMouseExited(MenuDragMouseEvent) - 接口 javax.swing.event.MenuDragMouseListener 中的方法
当拖动的鼠标离开某一菜单组件的显示区域时调用。
MenuDragMouseListener - javax.swing.event 中的 接口
定义一个菜单鼠标拖动侦听器。
menuDragMouseListener - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
menuDragMouseReleased(MenuDragMouseEvent) - 接口 javax.swing.event.MenuDragMouseListener 中的方法
当在菜单组件的显示区域中释放拖动鼠标时调用。
MenuElement - javax.swing 中的 接口
可以放入菜单中的所有组件都应该实现此接口。
MenuEvent - javax.swing.event 中的 类
MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。
MenuEvent(Object) - 类 javax.swing.event.MenuEvent 的构造方法
构造一个 MenuEvent 对象。
MenuItem - java.awt 中的 类
菜单中的所有项必须属于类 MenuItem 或其子类之一。
MenuItem() - 类 java.awt.MenuItem 的构造方法
构造具有空标签且没有键盘快捷方式的新菜单项。
MenuItem(String) - 类 java.awt.MenuItem 的构造方法
构造具有指定的标签且没有键盘快捷方式的新菜单项。
MenuItem(String, MenuShortcut) - 类 java.awt.MenuItem 的构造方法
创建具有关联的键盘快捷方式的菜单项。
menuItem - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
MenuItem.AccessibleAWTMenuItem - java.awt 中的 类
用于为可访问性提供默认支持的 MenuItem 的内部类。
MenuItem.AccessibleAWTMenuItem() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 的构造方法
MenuItemUI - javax.swing.plaf 中的 类
JMenuItem 的可插入外观界面。
MenuItemUI() - 类 javax.swing.plaf.MenuItemUI 的构造方法
MenuKeyEvent - javax.swing.event 中的 类
MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。
MenuKeyEvent(Component, int, long, int, int, char, MenuElement[], MenuSelectionManager) - 类 javax.swing.event.MenuKeyEvent 的构造方法
构造一个 MenuKeyEvent 对象。
MenuKeyListener - javax.swing.event 中的 接口
MenuKeyListener
menuKeyListener - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
menuKeyPressed(MenuKeyEvent) - 接口 javax.swing.event.MenuKeyListener 中的方法
已按下某个键时调用。
menuKeyReleased(MenuKeyEvent) - 接口 javax.swing.event.MenuKeyListener 中的方法
已释放某个键时调用。
menuKeyTyped(MenuKeyEvent) - 接口 javax.swing.event.MenuKeyListener 中的方法
已键入某个键时调用。
MenuListener - javax.swing.event 中的 接口
定义一个菜单事件侦听器。
menuListener - 类 javax.swing.plaf.basic.BasicMenuUI 中的变量
menuSelected(MenuEvent) - 接口 javax.swing.event.MenuListener 中的方法
选择某个菜单时调用。
menuSelectionChanged(boolean) - 类 javax.swing.JMenu 中的方法
当菜单栏选择更改为激活或取消激活此菜单时传递消息。
menuSelectionChanged(boolean) - 类 javax.swing.JMenuBar 中的方法
实现为 MenuElement（不执行任何操作）。
menuSelectionChanged(boolean) - 类 javax.swing.JMenuItem 中的方法
当选择或取消选择 MenuElement 时由 MenuSelectionManager 调用。
menuSelectionChanged(boolean) - 类 javax.swing.JPopupMenu 中的方法
当菜单栏选择发生更改以激活或取消激活此菜单时传递消息。
menuSelectionChanged(boolean) - 接口 javax.swing.MenuElement 中的方法
在向菜单选择中添加或从中删除 MenuElement 时，由 MenuSelectionManager 调用。
MenuSelectionManager - javax.swing 中的 类
MenuSelectionManager 拥有菜单层次结构中的选项。
MenuSelectionManager() - 类 javax.swing.MenuSelectionManager 的构造方法
MenuShortcut - java.awt 中的 类
表示 MenuItem 键盘加速器的 MenuShortcut 类。
MenuShortcut(int) - 类 java.awt.MenuShortcut 的构造方法
为指定的虚拟键代码构造一个新的 MenuShortcut。
MenuShortcut(int, boolean) - 类 java.awt.MenuShortcut 的构造方法
为指定的虚拟键代码构造一个新的菜单快捷方式。
menuText - 类 java.awt.SystemColor 中的静态变量
为菜单文本提供的颜色。
mergeTree(String, Node) - 类 javax.imageio.metadata.IIOMetadata 中的方法
根据 XML DOM Node 树（其语法由给定元数据格式定义）改变此 IIOMetadata 对象的内部状态。
message - 类 javax.swing.JOptionPane 中的变量
要显示的消息。
MESSAGE_OUTBOUND_PROPERTY - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：消息方向，对于出站消息为 true，对于入站消息为 false。
MESSAGE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
message 的绑定属性名。
MESSAGE_TYPE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
type 的绑定属性名。
MessageContext - javax.xml.ws.handler 中的 接口
接口 MessageContext 抽象化由 handle 方法中的处理程序处理的消息上下文。
MessageContext.Scope - javax.xml.ws.handler 中的 枚举
属性作用域。
MessageDigest - java.security 中的 类
此 MessageDigest 类为应用程序提供信息摘要算法的功能，如 MD5 或 SHA 算法。
MessageDigest(String) - 类 java.security.MessageDigest 的构造方法
创建具有指定算法名称的信息摘要。
MessageDigestSpi - java.security 中的 类
此类为 MessageDigest 类定义服务提供者接口 (SPI)，MessageDigest 类提供信息摘要算法的功能，如 MD5 或 SHA。
MessageDigestSpi() - 类 java.security.MessageDigestSpi 的构造方法
MessageFactory - javax.xml.soap 中的 类
创建 SOAPMessage 对象的工厂。
MessageFactory() - 类 javax.xml.soap.MessageFactory 的构造方法
MessageFormat - java.text 中的 类
MessageFormat 提供了以与语言无关方式生成连接消息的方式。
MessageFormat(String) - 类 java.text.MessageFormat 的构造方法
构造默认语言环境和指定模式的 MessageFormat。
MessageFormat(String, Locale) - 类 java.text.MessageFormat 的构造方法
构造指定语言环境和模式的 MessageFormat。
MessageFormat.Field - java.text 中的 类
在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
MessageFormat.Field(String) - 类 java.text.MessageFormat.Field 的构造方法
创建具有指定名称的 Field。
MessageProp - org.ietf.jgss 中的 类
这是一个在 per-message GSSContext 方法中使用的、用来传送 per-message 属性的实用工具类。
MessageProp(boolean) - 类 org.ietf.jgss.MessageProp 的构造方法
设置所需私密状态的构造方法。
MessageProp(int, boolean) - 类 org.ietf.jgss.MessageProp 的构造方法
设置 qop 和私密状态值的构造方法。
Messager - javax.annotation.processing 中的 接口
Messager 提供注释处理器用来报告错误消息、警告和其他通知的方式。
messageType - 类 javax.swing.JOptionPane 中的变量
消息类型。
meta(MetaMessage) - 接口 javax.sound.midi.MetaEventListener 中的方法
在 Sequencer 遇到并处理了一个它正在处理的 Sequence 中的 MetaMessage 时调用。
META - 类 javax.sound.midi.MetaMessage 中的静态变量
MetaMessage 的状态字节（0xFF 或 255），供在 MIDI 文件中使用。
META - 类 javax.swing.text.html.HTML.Tag 中的静态变量
meta - 类 javax.swing.text.html.parser.DTD 中的变量
META_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Meta 键的扩展修饰符常量。
META_MASK - 类 java.awt.event.ActionEvent 中的静态变量
meta 修饰符。
META_MASK - 类 java.awt.event.InputEvent 中的静态变量
Meta 键修饰符常量。
META_MASK - 类 java.awt.Event 中的静态变量
此标志指示当事件发生时按下 Meta 键。
metadata - 类 javax.imageio.IIOImage 中的变量
包含与图像关联的元数据的 IIOMetadata 对象。
metaDown() - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
MetaEventListener - javax.sound.midi 中的 接口
MetaEventListener 接口应由其实例需要在 Sequencer 处理了 MetaMessage 时接收通知的类实现。
MetalBorders - javax.swing.plaf.metal 中的 类
可以提供适用于 metal L & F 的 Border 的工厂对象。
MetalBorders() - 类 javax.swing.plaf.metal.MetalBorders 的构造方法
MetalBorders.ButtonBorder - javax.swing.plaf.metal 中的 类
MetalBorders.ButtonBorder() - 类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 的构造方法
MetalBorders.Flush3DBorder - javax.swing.plaf.metal 中的 类
MetalBorders.Flush3DBorder() - 类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 的构造方法
MetalBorders.InternalFrameBorder - javax.swing.plaf.metal 中的 类
MetalBorders.InternalFrameBorder() - 类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 的构造方法
MetalBorders.MenuBarBorder - javax.swing.plaf.metal 中的 类
MetalBorders.MenuBarBorder() - 类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 的构造方法
MetalBorders.MenuItemBorder - javax.swing.plaf.metal 中的 类
MetalBorders.MenuItemBorder() - 类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 的构造方法
MetalBorders.OptionDialogBorder - javax.swing.plaf.metal 中的 类
MetalBorders.OptionDialogBorder() - 类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 的构造方法
MetalBorders.PaletteBorder - javax.swing.plaf.metal 中的 类
Palette 的边框。
MetalBorders.PaletteBorder() - 类 javax.swing.plaf.metal.MetalBorders.PaletteBorder 的构造方法
MetalBorders.PopupMenuBorder - javax.swing.plaf.metal 中的 类
MetalBorders.PopupMenuBorder() - 类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 的构造方法
MetalBorders.RolloverButtonBorder - javax.swing.plaf.metal 中的 类
MetalBorders.RolloverButtonBorder() - 类 javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder 的构造方法
MetalBorders.ScrollPaneBorder - javax.swing.plaf.metal 中的 类
MetalBorders.ScrollPaneBorder() - 类 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder 的构造方法
MetalBorders.TableHeaderBorder - javax.swing.plaf.metal 中的 类
Table Header 的边框
MetalBorders.TableHeaderBorder() - 类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 的构造方法
MetalBorders.TextFieldBorder - javax.swing.plaf.metal 中的 类
MetalBorders.TextFieldBorder() - 类 javax.swing.plaf.metal.MetalBorders.TextFieldBorder 的构造方法
MetalBorders.ToggleButtonBorder - javax.swing.plaf.metal 中的 类
MetalBorders.ToggleButtonBorder() - 类 javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder 的构造方法
MetalBorders.ToolBarBorder - javax.swing.plaf.metal 中的 类
MetalBorders.ToolBarBorder() - 类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 的构造方法
MetalButtonUI - javax.swing.plaf.metal 中的 类
MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
MetalButtonUI() - 类 javax.swing.plaf.metal.MetalButtonUI 的构造方法
MetalCheckBoxIcon - javax.swing.plaf.metal 中的 类
OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
MetalCheckBoxIcon() - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 的构造方法
MetalCheckBoxUI - javax.swing.plaf.metal 中的 类
MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalCheckBoxUI() - 类 javax.swing.plaf.metal.MetalCheckBoxUI 的构造方法
MetalComboBoxButton - javax.swing.plaf.metal 中的 类
协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalComboBoxButton(JComboBox, Icon, CellRendererPane, JList) - 类 javax.swing.plaf.metal.MetalComboBoxButton 的构造方法
MetalComboBoxButton(JComboBox, Icon, boolean, CellRendererPane, JList) - 类 javax.swing.plaf.metal.MetalComboBoxButton 的构造方法
MetalComboBoxEditor - javax.swing.plaf.metal 中的 类
Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalComboBoxEditor() - 类 javax.swing.plaf.metal.MetalComboBoxEditor 的构造方法
MetalComboBoxEditor.UIResource - javax.swing.plaf.metal 中的 类
实现 UIResource 的 BasicComboBoxEditor 的一个子类。
MetalComboBoxEditor.UIResource() - 类 javax.swing.plaf.metal.MetalComboBoxEditor.UIResource 的构造方法
MetalComboBoxIcon - javax.swing.plaf.metal 中的 类
此实用工具类绘制指示 MetalComboBox 的水平条
MetalComboBoxIcon() - 类 javax.swing.plaf.metal.MetalComboBoxIcon 的构造方法
MetalComboBoxUI - javax.swing.plaf.metal 中的 类
JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalComboBoxUI() - 类 javax.swing.plaf.metal.MetalComboBoxUI 的构造方法
MetalComboBoxUI.MetalComboBoxLayoutManager - javax.swing.plaf.metal 中的 类
此内部类因编译器故障而被标记为 "public"。
MetalComboBoxUI.MetalComboBoxLayoutManager() - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager 的构造方法
MetalComboBoxUI.MetalComboPopup - javax.swing.plaf.metal 中的 类
已过时。 从 Java 2 platform v1.4 开始。
MetalComboBoxUI.MetalComboPopup(JComboBox) - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup 的构造方法
已过时。
MetalComboBoxUI.MetalPropertyChangeListener - javax.swing.plaf.metal 中的 类
此内部类由于编译器故障而被标记为 "public"。
MetalComboBoxUI.MetalPropertyChangeListener() - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener 的构造方法
MetalDesktopIconUI - javax.swing.plaf.metal 中的 类
Metal 桌面图标。
MetalDesktopIconUI() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 的构造方法
MetalFileChooserUI - javax.swing.plaf.metal 中的 类
FileChooser 的 Metal L&F 实现。
MetalFileChooserUI(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 的构造方法
MetalFileChooserUI.DirectoryComboBoxAction - javax.swing.plaf.metal 中的 类
当 DirectoryComboBox 已更改所选项时调用。
MetalFileChooserUI.DirectoryComboBoxAction() - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction 的构造方法
MetalFileChooserUI.DirectoryComboBoxModel - javax.swing.plaf.metal 中的 类
字体选择组合框的数据模型。
MetalFileChooserUI.DirectoryComboBoxModel() - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 的构造方法
MetalFileChooserUI.FileRenderer - javax.swing.plaf.metal 中的 类
MetalFileChooserUI.FileRenderer() - 类 javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer 的构造方法
MetalFileChooserUI.FilterComboBoxModel - javax.swing.plaf.metal 中的 类
字体选择组合框的数据模型。
MetalFileChooserUI.FilterComboBoxModel() - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 的构造方法
MetalFileChooserUI.FilterComboBoxRenderer - javax.swing.plaf.metal 中的 类
呈现不同的类型大小和风格。
MetalFileChooserUI.FilterComboBoxRenderer() - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer 的构造方法
MetalFileChooserUI.SingleClickListener - javax.swing.plaf.metal 中的 类
MetalFileChooserUI.SingleClickListener(JList) - 类 javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener 的构造方法
MetalIconFactory - javax.swing.plaf.metal 中的 类
为 JavaTM 外观 (Metal) 提供 Icon 的工厂对象。
MetalIconFactory() - 类 javax.swing.plaf.metal.MetalIconFactory 的构造方法
MetalIconFactory.FileIcon16 - javax.swing.plaf.metal 中的 类
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.FileIcon16() - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 的构造方法
MetalIconFactory.FolderIcon16 - javax.swing.plaf.metal 中的 类
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.FolderIcon16() - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 的构造方法
MetalIconFactory.PaletteCloseIcon - javax.swing.plaf.metal 中的 类
定义一个用于 Palette 关闭的图标
MetalIconFactory.PaletteCloseIcon() - 类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 的构造方法
MetalIconFactory.TreeControlIcon - javax.swing.plaf.metal 中的 类
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.TreeControlIcon(boolean) - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 的构造方法
MetalIconFactory.TreeFolderIcon - javax.swing.plaf.metal 中的 类
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.TreeFolderIcon() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon 的构造方法
MetalIconFactory.TreeLeafIcon - javax.swing.plaf.metal 中的 类
MetalIconFactory.TreeLeafIcon() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon 的构造方法
MetalInternalFrameTitlePane - javax.swing.plaf.metal 中的 类
管理 JLF 标题栏的类
MetalInternalFrameTitlePane(JInternalFrame) - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 的构造方法
MetalInternalFrameUI - javax.swing.plaf.metal 中的 类
JInternalFrame 的 Metal 实现。
MetalInternalFrameUI(JInternalFrame) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 的构造方法
MetalLabelUI - javax.swing.plaf.metal 中的 类
LabelUI 的 Windows L&F 实现。
MetalLabelUI() - 类 javax.swing.plaf.metal.MetalLabelUI 的构造方法
metalLabelUI - 类 javax.swing.plaf.metal.MetalLabelUI 中的静态变量
默认的 MetalLabelUI 实例。
MetalLookAndFeel - javax.swing.plaf.metal 中的 类
Java 外观，也称为 Metal。
MetalLookAndFeel() - 类 javax.swing.plaf.metal.MetalLookAndFeel 的构造方法
MetalMenuBarUI - javax.swing.plaf.metal 中的 类
MenuBarUI 的 Metal 实现。
MetalMenuBarUI() - 类 javax.swing.plaf.metal.MetalMenuBarUI 的构造方法
MetalPopupMenuSeparatorUI - javax.swing.plaf.metal 中的 类
PopupMenuSeparatorUI 的 Metal L&F 实现。
MetalPopupMenuSeparatorUI() - 类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 的构造方法
MetalProgressBarUI - javax.swing.plaf.metal 中的 类
ProgressBarUI 的 Metal 实现。
MetalProgressBarUI() - 类 javax.swing.plaf.metal.MetalProgressBarUI 的构造方法
MetalRadioButtonUI - javax.swing.plaf.metal 中的 类
MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalRadioButtonUI() - 类 javax.swing.plaf.metal.MetalRadioButtonUI 的构造方法
MetalRootPaneUI - javax.swing.plaf.metal 中的 类
提供 RootPaneUI 的 metal 外观实现。
MetalRootPaneUI() - 类 javax.swing.plaf.metal.MetalRootPaneUI 的构造方法
MetalScrollBarUI - javax.swing.plaf.metal 中的 类
ScrollBarUI 的 Metal 外观实现
MetalScrollBarUI() - 类 javax.swing.plaf.metal.MetalScrollBarUI 的构造方法
MetalScrollButton - javax.swing.plaf.metal 中的 类
Metal 滚动条箭头的 JButton 对象。
MetalScrollButton(int, int, boolean) - 类 javax.swing.plaf.metal.MetalScrollButton 的构造方法
MetalScrollPaneUI - javax.swing.plaf.metal 中的 类
ScrollPaneUI 的 Metal L&F 实现。
MetalScrollPaneUI() - 类 javax.swing.plaf.metal.MetalScrollPaneUI 的构造方法
MetalSeparatorUI - javax.swing.plaf.metal 中的 类
SeparatorUI 的 Metal L&F 实现。
MetalSeparatorUI() - 类 javax.swing.plaf.metal.MetalSeparatorUI 的构造方法
MetalSliderUI - javax.swing.plaf.metal 中的 类
SliderUI 的 Java L&F 实现。
MetalSliderUI() - 类 javax.swing.plaf.metal.MetalSliderUI 的构造方法
MetalSliderUI.MetalPropertyListener - javax.swing.plaf.metal 中的 类
MetalSliderUI.MetalPropertyListener() - 类 javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener 的构造方法
MetalSplitPaneUI - javax.swing.plaf.metal 中的 类
Metal 分隔窗格。
MetalSplitPaneUI() - 类 javax.swing.plaf.metal.MetalSplitPaneUI 的构造方法
MetalTabbedPaneUI - javax.swing.plaf.metal 中的 类
BasicTabbedPaneUI 的 Metal 子类。
MetalTabbedPaneUI() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 的构造方法
MetalTabbedPaneUI.TabbedPaneLayout - javax.swing.plaf.metal 中的 类
此内部类由于编译器故障而被标记为 "public"。
MetalTabbedPaneUI.TabbedPaneLayout() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 的构造方法
MetalTextFieldUI - javax.swing.plaf.metal 中的 类
JTextField 外观的基础。
MetalTextFieldUI() - 类 javax.swing.plaf.metal.MetalTextFieldUI 的构造方法
MetalTheme - javax.swing.plaf.metal 中的 类
MetalTheme 提供 Java 外观所使用的调色板和字体。
MetalTheme() - 类 javax.swing.plaf.metal.MetalTheme 的构造方法
MetalToggleButtonUI - javax.swing.plaf.metal 中的 类
MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalToggleButtonUI() - 类 javax.swing.plaf.metal.MetalToggleButtonUI 的构造方法
MetalToolBarUI - javax.swing.plaf.metal 中的 类
ToolBarUI 的 Metal 外观实现。
MetalToolBarUI() - 类 javax.swing.plaf.metal.MetalToolBarUI 的构造方法
MetalToolBarUI.MetalContainerListener - javax.swing.plaf.metal 中的 类
MetalToolBarUI.MetalContainerListener() - 类 javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener 的构造方法
MetalToolBarUI.MetalDockingListener - javax.swing.plaf.metal 中的 类
MetalToolBarUI.MetalDockingListener(JToolBar) - 类 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener 的构造方法
MetalToolBarUI.MetalRolloverListener - javax.swing.plaf.metal 中的 类
MetalToolBarUI.MetalRolloverListener() - 类 javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener 的构造方法
MetalToolTipUI - javax.swing.plaf.metal 中的 类
BasicToolTipUI 的 Metal L&F 扩展。
MetalToolTipUI() - 类 javax.swing.plaf.metal.MetalToolTipUI 的构造方法
MetalTreeUI - javax.swing.plaf.metal 中的 类
TreeUI 的 metal 外观实现。
MetalTreeUI() - 类 javax.swing.plaf.metal.MetalTreeUI 的构造方法
MetaMessage - javax.sound.midi 中的 类
MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。
MetaMessage() - 类 javax.sound.midi.MetaMessage 的构造方法
构造一个新的 MetaMessage。
MetaMessage(byte[]) - 类 javax.sound.midi.MetaMessage 的构造方法
构造一个新的 MetaMessage。
Method - java.lang.reflect 中的 类
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。
method - 类 java.net.HttpURLConnection 中的变量
HTTP 方法（GET、POST、PUT 等）。
METHOD - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
METHOD - 类 javax.xml.transform.OutputKeys 中的静态变量
method = "xml" | "html" | "text" | expanded name。
METHOD_ATTRIBUTE_PFX - 接口 java.util.jar.Pack200.Packer 中的静态变量
当与方法属性名称连在一起时，指出该属性的格式。
MethodDescriptor - java.beans 中的 类
MethodDescriptor 描述了一种特殊方法，即 Java Bean 支持从其他组件对其进行外部访问。
MethodDescriptor(Method) - 类 java.beans.MethodDescriptor 的构造方法
根据 Method 构造一个 MethodDescriptor。
MethodDescriptor(Method, ParameterDescriptor[]) - 类 java.beans.MethodDescriptor 的构造方法
根据为每个方法参数提供描述性信息的 Method 构造一个 MethodDescriptor。
methodsIn(Iterable<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中方法的列表。
methodsIn(Set<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中方法的集合。
metrics - 类 javax.swing.text.PlainView 中的变量
当前字体的字体规格。
MGF1ParameterSpec - java.security.spec 中的 类
此类指定 OAEP Padding 和 RSA-PSS 签名方案中的掩码生成函数 MGF1（如 PKCS #1 v2.1 标准中所定义的）使用的参数集。
MGF1ParameterSpec(String) - 类 java.security.spec.MGF1ParameterSpec 的构造方法
构造如 PKCS #1 标准中所定义的掩码生成函数 MGF1 的参数集。
MICROPHONE - 类 javax.sound.sampled.Port.Info 中的静态变量
从内置麦克风或麦克风插孔中获得音频端口类型。
microsecondLength - 类 javax.sound.midi.MidiFileFormat 中的变量
MIDI 文件的持续时间，以微秒为单位。
MIDDLE - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的中层进纸托盘。
MIDI_SYNC - 类 javax.sound.midi.Sequencer.SyncMode 中的静态变量
指定使用 MIDI 时钟消息的主或辅同步模式。
MIDI_TIME_CODE - 类 javax.sound.midi.Sequencer.SyncMode 中的静态变量
指定使用 MIDI 时间代码的主或辅同步模式如果此模式用作主同步模式，sequencer 从 MIDI 时间代码消息获取其计时信息。
MIDI_TIME_CODE - 类 javax.sound.midi.ShortMessage 中的静态变量
MIDI Time Code Quarter Frame 消息的状态字节（0xF1 或 241）。
MidiChannel - javax.sound.midi 中的 接口
表示一个单独 MIDI 通道的 MidiChannel 对象。
MidiDevice - javax.sound.midi 中的 接口
MidiDevice 是用于所有 MIDI 设备的基接口。
MidiDevice.Info - javax.sound.midi 中的 类
一个 MidiDevice.Info 对象，它包含了有关 MidiDevice 的各种数据，包括其名称、创建它的公司及描述性文本。
MidiDevice.Info(String, String, String, String) - 类 javax.sound.midi.MidiDevice.Info 的构造方法
构造一个设备 info 对象。
MidiDeviceProvider - javax.sound.midi.spi 中的 类
MidiDeviceProvider 是特定类型的 MIDI 设备的工厂或提供者。
MidiDeviceProvider() - 类 javax.sound.midi.spi.MidiDeviceProvider 的构造方法
MidiEvent - javax.sound.midi 中的 类
MIDI 事件包含一个 MIDI 消息和一个相应的用刻度表示的时间戳，可代表存储在 MIDI 文件或 Sequence 对象中的 MIDI 事件信息。
MidiEvent(MidiMessage, long) - 类 javax.sound.midi.MidiEvent 的构造方法
构造一个新的 MidiEvent。
MidiFileFormat - javax.sound.midi 中的 类
MidiFileFormat 对象，它封装了 MIDI 文件的类型、长度和定时信息。
MidiFileFormat(int, float, int, int, long) - 类 javax.sound.midi.MidiFileFormat 的构造方法
构造一个 MidiFileFormat。
MidiFileFormat(int, float, int, int, long, Map<String, Object>) - 类 javax.sound.midi.MidiFileFormat 的构造方法
构造带一组属性的 MidiFileFormat。
MidiFileReader - javax.sound.midi.spi 中的 类
MidiFileReader 提供 MIDI 文件读取服务。
MidiFileReader() - 类 javax.sound.midi.spi.MidiFileReader 的构造方法
MidiFileWriter - javax.sound.midi.spi 中的 类
MidiFileWriter 提供 MIDI 文件写入服务。
MidiFileWriter() - 类 javax.sound.midi.spi.MidiFileWriter 的构造方法
MidiMessage - javax.sound.midi 中的 类
MidiMessage 是 MIDI 消息的基类。
MidiMessage(byte[]) - 类 javax.sound.midi.MidiMessage 的构造方法
构造一个新的 MidiMessage。
MidiSystem - javax.sound.midi 中的 类
MidiSystem 类提供了对已安装的 MIDI 系统资源的访问，包括诸如 synthesizer、sequencer 和 MIDI 输入和输出端口等设备。
MidiUnavailableException - javax.sound.midi 中的 异常
当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。
MidiUnavailableException() - 异常 javax.sound.midi.MidiUnavailableException 的构造方法
构造一个 MidiUnavailableException，使用 null 作为其错误详细消息。
MidiUnavailableException(String) - 异常 javax.sound.midi.MidiUnavailableException 的构造方法
构造带指定详细消息的 MidiUnavailableException。
MILLISECOND - 类 java.text.DateFormat.Field 中的静态变量
标识 MILLISECOND 字段的常量。
MILLISECOND - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一秒中的毫秒。
MILLISECOND_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 MILLISECOND 字段的有用常量。
MimeHeader - javax.xml.soap 中的 类
存储 MIME 头名称及其值的对象。
MimeHeader(String, String) - 类 javax.xml.soap.MimeHeader 的构造方法
构造使用给定的名称和值初始化的 MimeHeader 对象。
MimeHeaders - javax.xml.soap 中的 类
MimeHeader 对象的容器，这些对象表示出现在消息的 MIME 部分的 MIME 头。
MimeHeaders() - 类 javax.xml.soap.MimeHeaders 的构造方法
构造一个用空 Vector 对象初始化的默认 MimeHeaders 对象。
MimeType - javax.activation 中的 类
RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。
MimeType() - 类 javax.activation.MimeType 的构造方法
默认的构造方法。
MimeType(String) - 类 javax.activation.MimeType 的构造方法
根据 String 构建 MimeType 的构造方法。
MimeType(String, String) - 类 javax.activation.MimeType 的构造方法
用给定的基本类型和子类型构建 MimeType 的构造方法，它的参数列表为空。
MimeTypeParameterList - javax.activation 中的 类
RFC 2045 和 2046 中定义的 MimeType 参数列表。
MimeTypeParameterList() - 类 javax.activation.MimeTypeParameterList 的构造方法
默认的构造方法。
MimeTypeParameterList(String) - 类 javax.activation.MimeTypeParameterList 的构造方法
用传入的数据构造新的 MimeTypeParameterList。
MimeTypeParseException - java.awt.datatransfer 中的 异常
对分析相关异常的 MimeType 进行封装的类
MimeTypeParseException() - 异常 java.awt.datatransfer.MimeTypeParseException 的构造方法
构造不带指定详细消息的 MimeTypeParseException。
MimeTypeParseException(String) - 异常 java.awt.datatransfer.MimeTypeParseException 的构造方法
构造带指定详细消息的 MimeTypeParseException。
MimeTypeParseException - javax.activation 中的 异常
封装与 MimeType 解析相关的异常的类。
MimeTypeParseException() - 异常 javax.activation.MimeTypeParseException 的构造方法
构造不带指定详细消息的 MimeTypeParseException。
MimeTypeParseException(String) - 异常 javax.activation.MimeTypeParseException 的构造方法
构造带指定详细消息的 MimeTypeParseException。
MIMETypes - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
从 getMIMETypes 返回的字符串数组，该数组最初为 null。
MimetypesFileTypeMap - javax.activation 中的 类
此类扩展 FileTypeMap 并通过其文件扩展名提供文件的数据分类。
MimetypesFileTypeMap() - 类 javax.activation.MimetypesFileTypeMap 的构造方法
默认的构造方法。
MimetypesFileTypeMap(String) - 类 javax.activation.MimetypesFileTypeMap 的构造方法
用从指定文件中添加的编程条目构造 MimetypesFileTypeMap。
MimetypesFileTypeMap(InputStream) - 类 javax.activation.MimetypesFileTypeMap 的构造方法
用从 InputStream 中添加的编程条目构造 MimetypesFileTypeMap。
min(int, int) - 类 java.lang.Math 中的静态方法
返回两个 int 值中较小的一个。
min(long, long) - 类 java.lang.Math 中的静态方法
返回两个 long 值中较小的一个。
min(float, float) - 类 java.lang.Math 中的静态方法
返回两个 float 值中较小的一个。
min(double, double) - 类 java.lang.Math 中的静态方法
返回两个 double 值中较小的一个。
min(int, int) - 类 java.lang.StrictMath 中的静态方法
返回两个 int 值中较小的一个。
min(long, long) - 类 java.lang.StrictMath 中的静态方法
返回两个 long 值中较小的一个。
min(float, float) - 类 java.lang.StrictMath 中的静态方法
返回两个 float 值中较小的一个。
min(double, double) - 类 java.lang.StrictMath 中的静态方法
返回两个 double 值中较小的一个。
min(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 和 val 的最小值。
min(BigInteger) - 类 java.math.BigInteger 中的方法
返回此 BigInteger 和 val 的最小值。
min(Collection<? extends T>) - 类 java.util.Collections 中的静态方法
根据元素的自然顺序 返回给定 collection 的最小元素。
min(Collection<? extends T>, Comparator<? super T>) - 类 java.util.Collections 中的静态方法
根据指定比较器产生的顺序，返回给定 collection 的最小元素。
MIN_CODE_POINT - 类 java.lang.Character 中的静态变量
Unicode 代码点的最小值。
MIN_EXPONENT - 类 java.lang.Double 中的静态变量
标准化 double 变量可能具有的最小指数。
MIN_EXPONENT - 类 java.lang.Float 中的静态变量
标准化 float 变量可能具有的最小指数。
MIN_HIGH_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 高代理项代码单元的最小值。
MIN_LOW_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 低代理项代码单元的最小值。
MIN_NORMAL - 类 java.lang.Double 中的静态变量
保存 double 类型的最小正标准值的常量，最小正标准值为 2-1022。
MIN_NORMAL - 类 java.lang.Float 中的静态变量
保存 float 类型数据的最小正标准值的常量，即 2-126。
MIN_PRIORITY - 类 java.lang.Thread 中的静态变量
线程可以具有的最低优先级。
MIN_RADIX - 类 java.lang.Character 中的静态变量
可用于与字符串相互转换的最小基数。
MIN_SCROLL - 类 javax.swing.plaf.basic.BasicSliderUI 中的静态变量
MIN_SUPPLEMENTARY_CODE_POINT - 类 java.lang.Character 中的静态变量
增补代码点的最小值。
MIN_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 代理项代码单元的最小值。
MIN_TIMEZONE_OFFSET - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式最小时区偏移量是 +14:00。
MIN_VALUE - 类 java.lang.Byte 中的静态变量
一个常量，保存 byte 类型可取的最小值，即 -27。
MIN_VALUE - 类 java.lang.Character 中的静态变量
此字段的常量值是 char 类型的最小值，即 '\u0000'。
MIN_VALUE - 类 java.lang.Double 中的静态变量
保存 double 类型的最小正非零值的常量，最小正非零值为 2-1074。
MIN_VALUE - 类 java.lang.Float 中的静态变量
保存 float 类型数据的最小正非零值的常量，即 2-149。
MIN_VALUE - 类 java.lang.Integer 中的静态变量
值为 －231 的常量，它表示 int 类型能够表示的最小值。
MIN_VALUE - 类 java.lang.Long 中的静态变量
保持 long 类型的最小值的常量，该值为 -263。
MIN_VALUE - 类 java.lang.Short 中的静态变量
保存 short 可取的最小值的常量，最小值为 -215。
MIN_VALUE_FIELD - 类 javax.management.JMX 中的静态变量
minValue 字段的名称。
minIcon - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
MinimalHTMLWriter - javax.swing.text.html 中的 类
MinimalHTMLWriter 是一个回退 writer，HTMLEditorKit 使用它为非 EditorKit 生成的文档写出 HTML。
MinimalHTMLWriter(Writer, StyledDocument) - 类 javax.swing.text.html.MinimalHTMLWriter 的构造方法
创建一个新的 MinimalHTMLWriter。
MinimalHTMLWriter(Writer, StyledDocument, int, int) - 类 javax.swing.text.html.MinimalHTMLWriter 的构造方法
创建一个新的 MinimalHTMLWriter。
minimizeFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
使窗体恢复回调用 maximizeFrame 之前的大小和位置。
minimizeFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常，这指示应该将窗体恢复到调用 maximizeFrame() 前的大小和位置。
minimizeFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
当用户要最小化窗体时调用此方法。
minimizeKey - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
已过时。 从 1.3 开始。
minimum - 类 javax.swing.SizeRequirements 中的变量
要求的最小大小。
MinimumHeight - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的静态变量
minimumLayoutSize(Container) - 类 java.awt.BorderLayout 中的方法
使用此布局管理器确定 target 容器的最小大小。
minimumLayoutSize(Container) - 类 java.awt.CardLayout 中的方法
计算指定面板大小的最小值。
minimumLayoutSize(Container) - 类 java.awt.FlowLayout 中的方法
返回需要布置 visible 组件的最小维数，该组件包含在指定的目标容器中。
minimumLayoutSize(Container) - 类 java.awt.GridBagLayout 中的方法
使用此网格包布局确定 parent 容器的最小大小。
minimumLayoutSize(Container) - 类 java.awt.GridLayout 中的方法
使用此网络布局确定最小大小的容器参数。
minimumLayoutSize(Container) - 接口 java.awt.LayoutManager 中的方法
给定指定容器所包含的组件，计算该容器的最小大小维数。
minimumLayoutSize(Container) - 类 javax.swing.BoxLayout 中的方法
返回布置包含在指定目标容器中的组件所需的最小尺寸。
minimumLayoutSize(Container) - 类 javax.swing.GroupLayout 中的方法
返回指定容器的最小大小。
minimumLayoutSize(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法
返回布局需要的最小空间量。
minimumLayoutSize(Container) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
返回第一个（并且是唯一）的子级最小大小与其父 insets 的大小和。
minimumLayoutSize(Container) - 类 javax.swing.OverlayLayout 中的方法
返回需要布置组件的最小维数，该组件包含在指定的目标容器中。
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回包含子级所需的最小大小。
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.ScrollPaneLayout 中的方法
ScrollPane 的最小大小是 insets 加上视口最小大小，加上可见标题的最小大小，加上 displayPolicy 不为 NEVER 的滚动条的最小大小。
minimumLayoutSize(Container) - 类 javax.swing.SpringLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.ViewportLayout 中的方法
返回需要布置指定目标容器中包含的组件的最小维数。
minimumSize() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
minimumSize() - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 getMinimumSize() 取代。
minimumSize(int) - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
minimumSize() - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
minimumSize(int, int) - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int, int) 取代。
minimumSize() - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
minimumSize(int) - 类 java.awt.TextField 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
minimumSize() - 类 java.awt.TextField 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
minimumSize - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
minimumThumbSize - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
MinimumWidth - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的静态变量
minIndex - 类 javax.imageio.ImageReader 中的变量
用来读取的最小有效索引，最初为 0。
minor - 异常 org.omg.CORBA.SystemException 中的变量
CORBA Exception 次要代码。
minor_version - 类 org.omg.IOP.Encoding 中的变量
此 Encoding 格式的次要形式。
minorRequirementChange(AsyncBoxView.ChildState) - 类 javax.swing.text.AsyncBoxView 中的方法
沿辅轴上的要求更改。
minorTickSpacing - 类 javax.swing.JSlider 中的变量
次刻度标记（出现在主刻度标记之间的较小标记）之间的值的个数。
minProgressivePass - 类 javax.imageio.ImageReadParam 中的变量
从源中读取的逐步传递的最小索引。
MINSIZE - 类 java.awt.GridBagLayout 中的静态变量
网格包布局可以布置的最小网格。
minTabWidth - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的变量
MINUS - 类 javax.management.Query 中的静态变量
表示 Query.minus(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
minus(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个二进制表达式，表示两个数值的差。
minus(Spring) - 类 javax.swing.Spring 中的静态方法
返回 -s：一个以与 s 相反方向运行的 spring。
MINUTE - 类 java.text.DateFormat.Field 中的静态变量
标识 MINUTE 字段的常量。
MINUTE - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一小时中的分钟。
MINUTE_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 MINUTE 字段的有用常量。
MINUTES - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示分钟字段的常量。
minWidth - 类 javax.swing.table.TableColumn 中的变量
列的最小宽度。
minX - 类 java.awt.image.Raster 中的变量
此 Raster 左上角像素的 X 坐标。
minY - 类 java.awt.image.Raster 中的变量
此 Raster 左上角像素的 Y 坐标。
MirroredTypeException - javax.lang.model.type 中的 异常
当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
MirroredTypeException(TypeMirror) - 异常 javax.lang.model.type.MirroredTypeException 的构造方法
构造一个针对指定类型的新 MirroredTypeException。
MirroredTypesException - javax.lang.model.type 中的 异常
当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
MirroredTypesException(List<? extends TypeMirror>) - 异常 javax.lang.model.type.MirroredTypesException 的构造方法
构造一个针对指定类型的新 MirroredTypesException。
MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Miscellaneous Mathematical Symbols-A”Unicode 字符块的常量。
MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Miscellaneous Mathematical Symbols-B”Unicode 字符块的常量。
MISCELLANEOUS_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Miscellaneous Symbols”Unicode 字符块的常量。
MISCELLANEOUS_SYMBOLS_AND_ARROWS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Miscellaneous Symbols and Arrows”Unicode 字符块的常量。
MISCELLANEOUS_TECHNICAL - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Miscellaneous Technical”Unicode 字符块的常量。
missing_node - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
MissingFormatArgumentException - java.util 中的 异常
如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
MissingFormatArgumentException(String) - 异常 java.util.MissingFormatArgumentException 的构造方法
构造带有不匹配的格式说明符的此类的一个实例。
MissingFormatWidthException - java.util 中的 异常
请求格式宽度时抛出未经检查的异常。
MissingFormatWidthException(String) - 异常 java.util.MissingFormatWidthException 的构造方法
构造带有指定格式说明符的此类的一个实例。
MissingResourceException - java.util 中的 异常
缺少资源时抛出此异常。
MissingResourceException(String, String, String) - 异常 java.util.MissingResourceException 的构造方法
构造带有指定信息的 MissingResourceException。
Mixer - javax.sound.sampled 中的 接口
混频器是一个具有一行或多行的音频设备。
Mixer.Info - javax.sound.sampled 中的 类
Mixer.Info 类表示关于音频混频器的信息，包括产品的名称、版本和供应商，以及文本描述。
Mixer.Info(String, String, String, String) - 类 javax.sound.sampled.Mixer.Info 的构造方法
构造混频器的 info 对象，并向它传递给定的文本信息。
MixerProvider - javax.sound.sampled.spi 中的 类
特定的混频器类型的提供者和工厂。
MixerProvider() - 类 javax.sound.sampled.spi.MixerProvider 的构造方法
mkdir() - 类 java.io.File 中的方法
创建此抽象路径名指定的目录。
mkdirs() - 类 java.io.File 中的方法
创建此抽象路径名指定的目录，包括所有必需但不存在的父目录。
MLet - javax.management.loading 中的 类
允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
MLet() - 类 javax.management.loading.MLet 的构造方法
使用默认的代理父类加载器构造新的 MLet。
MLet(URL[]) - 类 javax.management.loading.MLet 的构造方法
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。
MLet(URL[], ClassLoader) - 类 javax.management.loading.MLet 的构造方法
为给定的 URL 构造新的 MLet。
MLet(URL[], ClassLoader, URLStreamHandlerFactory) - 类 javax.management.loading.MLet 的构造方法
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLet(URL[], boolean) - 类 javax.management.loading.MLet 的构造方法
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。
MLet(URL[], ClassLoader, boolean) - 类 javax.management.loading.MLet 的构造方法
为给定的 URL 构造新的 MLet。
MLet(URL[], ClassLoader, URLStreamHandlerFactory, boolean) - 类 javax.management.loading.MLet 的构造方法
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLetContent - javax.management.loading 中的 类
此类表示 MLET 标记的内容。
MLetContent(URL, Map<String, String>, List<String>, List<String>) - 类 javax.management.loading.MLetContent 的构造方法
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。
MLetMBean - javax.management.loading 中的 接口
公开 MLet MBean 的远程管理接口。
MM - 类 javax.print.attribute.Size2DSyntax 中的静态变量
指示单位为毫米 (mm) 的值。
MM - 类 javax.print.attribute.standard.MediaPrintableArea 中的静态变量
指示以 millimeters (mm) 为单位的值。
mnemonic - 类 javax.swing.DefaultButtonModel 中的变量
按钮的助记符。
MNEMONIC_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的助记符中的更改。
MNEMONIC_KEY - 接口 javax.swing.Action 中的静态变量
用来存储对应于一个 KeyEvent 键代码的 Integer 值的键。
mod(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this mod m) 的 BigInteger。
MODAL - 类 javax.accessibility.AccessibleState 中的静态变量
指示在用户可以与不同窗口中的某个对象交互之前，必须对此对象采取某些操作。
MODAL_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Modal 层的便捷对象。
modCount - 类 java.util.AbstractList 中的变量
已从结构上修改 此列表的次数。
mode - 类 org.omg.Dynamic.Parameter 中的变量
MODE_ASYNCHRONOUS - 接口 org.w3c.dom.ls.DOMImplementationLS 中的静态变量
创建一个异步 LSParser。
MODE_COPY_FROM_METADATA - 类 javax.imageio.ImageWriteParam 中的静态变量
一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 或 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。
MODE_DEFAULT - 类 javax.imageio.ImageWriteParam 中的静态变量
一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 和 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。
MODE_DISABLED - 类 javax.imageio.ImageWriteParam 中的静态变量
一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 和 setCompressionMode 之类的方法中，以禁用用于以后的写入操作的某个特征。
MODE_EXPLICIT - 类 javax.imageio.ImageWriteParam 中的静态变量
一个常量值，可以传入诸如 setTilingMode 或 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。
MODE_SYNCHRONOUS - 接口 org.w3c.dom.ls.DOMImplementationLS 中的静态变量
创建一个同步 LSParser。
model - 类 javax.swing.AbstractButton 中的变量
确定按钮状态的数据模型。
model - 类 javax.swing.JProgressBar 中的变量
保存进度条数据的对象。
model - 类 javax.swing.JScrollBar 中的变量
表示滚动条的最小、最大、跨度（也叫 "visibleAmount"）和当前值的模型。
model - 类 javax.swing.JTabbedPane 中的变量
默认的选择模型。
MODEL - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
MODEL_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮模型中的更改。
ModelAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
用来标识嵌入了对象的模型的属性，这些嵌入的对象具有分开的模型视图。
modelChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
modelChanged() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
标志模型更改。
modelIndex - 类 javax.swing.table.TableColumn 中的变量
模型中的列索引，通过此 TableColumn 显示该模型。
modelListener - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
ModelMBean - javax.management.modelmbean 中的 接口
ModelMBean 必须实现此接口。
ModelMBeanAttributeInfo - javax.management.modelmbean 中的 类
ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
ModelMBeanAttributeInfo(String, String, Method, Method) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 的构造方法
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String, String, Method, Method, Descriptor) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 的构造方法
构造 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String, String, String, boolean, boolean, boolean) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 的构造方法
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String, String, String, boolean, boolean, boolean, Descriptor) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 的构造方法
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(ModelMBeanAttributeInfo) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 的构造方法
根据此 ModelMBeanAttributeInfo Object 构造新的 ModelMBeanAttributeInfo 对象。
ModelMBeanConstructorInfo - javax.management.modelmbean 中的 类
ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
ModelMBeanConstructorInfo(String, Constructor) - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 的构造方法
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String, Constructor, Descriptor) - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 的构造方法
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String, String, MBeanParameterInfo[]) - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 的构造方法
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String, String, MBeanParameterInfo[], Descriptor) - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 的构造方法
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanInfo - javax.management.modelmbean 中的 接口
此接口由每个 ModelMBean 的 ModelMBeanInfo 实现。
ModelMBeanInfoSupport - javax.management.modelmbean 中的 类
此类表示 ModelMBean 的元数据。
ModelMBeanInfoSupport(ModelMBeanInfo) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 的构造方法
构造作为给定 ModelMBeanInfoSupport 副本的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String, String, ModelMBeanAttributeInfo[], ModelMBeanConstructorInfo[], ModelMBeanOperationInfo[], ModelMBeanNotificationInfo[]) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 的构造方法
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String, String, ModelMBeanAttributeInfo[], ModelMBeanConstructorInfo[], ModelMBeanOperationInfo[], ModelMBeanNotificationInfo[], Descriptor) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 的构造方法
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。
ModelMBeanNotificationBroadcaster - javax.management.modelmbean 中的 接口
ModelMBean 必须实现此接口。
ModelMBeanNotificationInfo - javax.management.modelmbean 中的 类
ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
ModelMBeanNotificationInfo(String[], String, String) - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 的构造方法
构造带有默认描述符的 ModelMBeanNotificationInfo 对象。
ModelMBeanNotificationInfo(String[], String, String, Descriptor) - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 的构造方法
构造 ModelMBeanNotificationInfo 对象。
ModelMBeanNotificationInfo(ModelMBeanNotificationInfo) - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 的构造方法
从此 ModelMBeanNotfication Object 构造新 ModelMBeanNotificationInfo 对象。
ModelMBeanOperationInfo - javax.management.modelmbean 中的 类
ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。
ModelMBeanOperationInfo(String, Method) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 的构造方法
构造带有默认描述符的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String, Method, Descriptor) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 的构造方法
构造 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String, String, MBeanParameterInfo[], String, int) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 的构造方法
构造带有默认描述符的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String, String, MBeanParameterInfo[], String, int, Descriptor) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 的构造方法
构造 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(ModelMBeanOperationInfo) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 的构造方法
根据此 ModelMBeanOperation Object 构造新的 ModelMBeanOperationInfo 对象。
modelStructureChanged() - 类 javax.swing.DefaultRowSorter 中的方法
当底层模型结构完全更改时，调用此方法。
modelStructureChanged() - 类 javax.swing.RowSorter 中的方法
当底层模型结构完全更改时，调用此方法。
modelToView(JTextComponent, int) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
将模型中的给定位置转换成视图坐标系统中的某一个位置。
modelToView(JTextComponent, int, Position.Bias) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
将模型中的给定位置转换成视图坐标系统中的某一个位置。
modelToView(JTextComponent, int) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 modelToView 方法。
modelToView(JTextComponent, int, Position.Bias) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 modelToView 方法。
modelToView(JTextComponent, int) - 类 javax.swing.plaf.TextUI 中的方法
将模型中的给定位置转换成视图坐标系统中的某一个位置。
modelToView(JTextComponent, int, Position.Bias) - 类 javax.swing.plaf.TextUI 中的方法
将模型中的给定位置转换成视图坐标系统中的某一个位置。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.AsyncBoxView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.BoxView 中的方法
提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.ComponentView 中的方法
提供模型坐标空间到视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.CompositeView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Position.Bias, int, Position.Bias, Shape) - 类 javax.swing.text.CompositeView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.FieldView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(GlyphView, int, Position.Bias, Shape) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.GlyphView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.html.ImageView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.IconView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int) - 类 javax.swing.text.JTextComponent 中的方法
将模型中给定位置转换为视图坐标系统中的位置。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.PasswordView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.PlainView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.View 中的方法
为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
modelToView(int, Position.Bias, int, Position.Bias, Shape) - 类 javax.swing.text.View 中的方法
为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
modelToView(int, Shape) - 类 javax.swing.text.View 中的方法
已过时。
MODIFICATION - 接口 org.w3c.dom.events.MutationEvent 中的静态变量
适当修改 Attr。
MODIFICATION_TIME - 接口 java.util.jar.Pack200.Packer 中的静态变量
如果将此属性设置为特殊的字符串 Pack200.Packer.LATEST，则打包器将尝试在原始存档中的所有可用条目中确定最后修改时间，或者确定每个段中所有可用条目的最后修改时间。
ModificationItem - javax.naming.directory 中的 类
此类表示修改项。
ModificationItem(int, Attribute) - 类 javax.naming.directory.ModificationItem 的构造方法
创建一个新的 ModificationItem 实例。
Modifier - java.lang.reflect 中的 类
Modifier 类提供了 static 方法和常量，对类和成员访问修饰符进行解码。
Modifier() - 类 java.lang.reflect.Modifier 的构造方法
Modifier - javax.lang.model.element 中的 枚举
表示程序元素（如类、方法或字段）上的修饰符。
modifier - 类 javax.swing.text.html.parser.AttributeList 中的变量
MODIFIER_LETTER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Lm”。
MODIFIER_SYMBOL - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Sk”。
modifiers - 类 java.awt.Event 中的变量
修饰符键的状态。
modifyAttributes(Name, int, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
修改与命名对象关联的属性。
modifyAttributes(String, int, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
修改与命名对象关联的属性。
modifyAttributes(Name, ModificationItem[]) - 接口 javax.naming.directory.DirContext 中的方法
使用有序的修改列表修改与命名对象关联的属性。
modifyAttributes(String, ModificationItem[]) - 接口 javax.naming.directory.DirContext 中的方法
使用有序的修改列表修改与命名对象关联的属性。
modifyAttributes(String, int, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
modifyAttributes(Name, int, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
modifyAttributes(String, ModificationItem[]) - 类 javax.naming.directory.InitialDirContext 中的方法
modifyAttributes(Name, ModificationItem[]) - 类 javax.naming.directory.InitialDirContext 中的方法
modInverse(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this-1 mod m) 的 BigInteger。
modPow(BigInteger, BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (thisexponent mod m) 的 BigInteger。
MONARCH - 类 java.awt.PageAttributes.MediaType 中的静态变量
MONARCH_ENVELOPE 的别名。
MONARCH_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
Monarch Envelope (3 7/8 x 7 1/2 in) 的 MediaType 实例。
MONARCH_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 Monarch 信封尺寸，3.87 inch × 7.5 inch。
MONARCH_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
monarch 信封尺寸。
MONDAY - 类 java.util.Calendar 中的静态变量
指示 Monday 的 Calendar.DAY_OF_WEEK 字段值。
MONGOLIAN - 类 java.awt.font.NumericShaper 中的静态变量
标识 MONGOLIAN 范围和十进制基数。
MONGOLIAN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Mongolian”Unicode 字符块的常量。
Monitor - javax.management.monitor 中的 类
定义所有监视器 MBean 的公共部分。
Monitor() - 类 javax.management.monitor.Monitor 的构造方法
MonitorInfo - java.lang.management 中的 类
关于对象监视器锁的信息。
MonitorInfo(String, int, int, StackTraceElement) - 类 java.lang.management.MonitorInfo 的构造方法
构造一个 MonitorInfo 对象。
MonitorMBean - javax.management.monitor 中的 接口
公开监视器 MBean 的远程管理接口。
MonitorNotification - javax.management.monitor 中的 类
提供对监视器 MBean 发送的通知的定义。
MonitorSettingException - javax.management.monitor 中的 异常
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。
MonitorSettingException() - 异常 javax.management.monitor.MonitorSettingException 的构造方法
默认的构造方法。
MonitorSettingException(String) - 异常 javax.management.monitor.MonitorSettingException 的构造方法
允许指定错误消息的构造方法。
MONOCHROME - 类 java.awt.PageAttributes.ColorType 中的静态变量
用来指定单色打印的 ColorType 实例。
MONOCHROME - 类 javax.print.attribute.standard.Chromaticity 中的静态变量
单色打印。
MONOSPACED - 类 java.awt.Font 中的静态变量
逻辑字体 "Monospaced" 的规范系列名称的 String 常量。
MONTH - 类 java.text.DateFormat.Field 中的静态变量
标识 MONTH 字段的常量。
MONTH - 类 java.util.Calendar 中的静态变量
指示月份的 get 和 set 的字段数字。
MONTH_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 MONTH 字段的有用常量。
MONTHS - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示月字段的常量。
MORE_THAN_MAX_ROLE_DEGREE - 类 javax.management.relation.RoleStatus 中的静态变量
试图用比最大期望容量更多的 ObjectName 设置角色值时的问题类型。
MOUSE_CLICKED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标单击”事件。
MOUSE_DOWN - 类 java.awt.Event 中的静态变量
用户已经按下鼠标按钮。
MOUSE_DRAG - 类 java.awt.Event 中的静态变量
鼠标已经移动，同时按钮被按下。
MOUSE_DRAGGED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标拖动”事件。
MOUSE_ENTER - 类 java.awt.Event 中的静态变量
鼠标已经进入了一个组件。
MOUSE_ENTERED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标进入”事件。
MOUSE_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择鼠标事件的事件掩码。
MOUSE_EXIT - 类 java.awt.Event 中的静态变量
鼠标已经退出了一个组件。
MOUSE_EXITED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标离开”事件。
MOUSE_FIRST - 类 java.awt.event.MouseEvent 中的静态变量
用于鼠标事件的 id 范围的起始编号。
MOUSE_LAST - 类 java.awt.event.MouseEvent 中的静态变量
用于鼠标事件的 id 范围的结束编号。
MOUSE_MOTION_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择鼠标动作事件的事件掩码。
MOUSE_MOVE - 类 java.awt.Event 中的静态变量
鼠标已经移动，没有按钮被按下。
MOUSE_MOVED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标移动”事件。
MOUSE_OVER - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示鼠标位于 region 之上的基本状态。
MOUSE_PRESSED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标按下”事件。
MOUSE_RELEASED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标释放”事件。
MOUSE_UP - 类 java.awt.Event 中的静态变量
用户已经释放鼠标按钮。
MOUSE_WHEEL - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标滚轮”事件。
MOUSE_WHEEL_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择鼠标滚轮事件的事件掩码。
MouseAdapter - java.awt.event 中的 类
接收鼠标事件的抽象适配器类。
MouseAdapter() - 类 java.awt.event.MouseAdapter 的构造方法
mouseClicked(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseClicked 方法处理 mouseClicked 事件。
mouseClicked(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标在组件上单击时调用。
mouseClicked(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标按键在组件上单击（按下并释放）时调用。
mouseClicked(MouseEvent) - 接口 java.awt.event.MouseListener 中的方法
鼠标按键在组件上单击（按下并释放）时调用。
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
单击鼠标时调用。
mouseClicked(MouseEvent) - 类 javax.swing.text.html.HTMLEditorKit.LinkController 中的方法
鼠标单击事件时调用。
mouseDown(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
mouseDrag(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
mouseDragged(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseDragged 方法处理 mouseDragged 事件。
mouseDragged(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标按钮在组件上按下时调用。
mouseDragged(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标按键在组件上按下并拖动时调用。
mouseDragged(MouseEvent) - 类 java.awt.event.MouseMotionAdapter 中的方法
鼠标按键在组件上按下并拖动时调用。
mouseDragged(MouseEvent) - 接口 java.awt.event.MouseMotionListener 中的方法
鼠标按键在组件上按下并拖动时调用。
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
在菜单上按下鼠标按键并随后拖动鼠标时调用。
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的方法
将模型值设置为 thumb 的 Vertical 滚动条顶部的位置，或者相对于滑道原点的从左到右/从右到左滚动条中 Horizontal 滚动条的左部/右部位置。
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的方法
将模型值设置为相对于滑道原点的 thumb 顶部/左部位置。
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
如果拖动器不为 null，则此方法利用 continueDrag 传递消息。
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
根据鼠标指针当前位置移动插入符位置。
mouseDragged(MouseEvent) - 类 javax.swing.text.html.HTMLEditorKit.LinkController 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.ToolTipManager 中的方法
按下和拖动鼠标时调用。
MouseDragGestureRecognizer - java.awt.dnd 中的 类
DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。
MouseDragGestureRecognizer(DragSource, Component, int, DragGestureListener) - 类 java.awt.dnd.MouseDragGestureRecognizer 的构造方法
给出 Component c 的 DragSource、要观察的 Component、此拖动操作允许的操作，以及检测到拖动动作时发出通知的 DragGestureListener，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource, Component, int) - 类 java.awt.dnd.MouseDragGestureRecognizer 的构造方法
给出 Component c 的 DragSource、要观察的 Component，以及此拖动操作允许的操作，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource, Component) - 类 java.awt.dnd.MouseDragGestureRecognizer 的构造方法
给出 Component c 的 DragSource、要观察的 Component，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource) - 类 java.awt.dnd.MouseDragGestureRecognizer 的构造方法
给出 Component 的 DragSource，构造一个新的 MouseDragGestureRecognizer。
mouseEnter(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
mouseEntered(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseEntered 方法处理 mouseEntered 事件。
mouseEntered(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标移动到组件上时调用。
mouseEntered(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标进入到组件上时调用。
mouseEntered(MouseEvent) - 接口 java.awt.event.MouseListener 中的方法
鼠标进入到组件上时调用。
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener 中的方法
用于表示文件的 JList 由子类创建，但是在此类中监视选择。
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
在指针进入菜单时调用。
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
鼠标进入组件时调用。
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
鼠标进入某个区域时调用。
mouseEntered(MouseEvent) - 类 javax.swing.ToolTipManager 中的方法
鼠标进入组件区域时调用。
MouseEvent - java.awt.event 中的 类
指示组件中发生鼠标动作的事件。
MouseEvent(Component, int, long, int, int, int, int, boolean, int) - 类 java.awt.event.MouseEvent 的构造方法
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。
MouseEvent(Component, int, long, int, int, int, int, boolean) - 类 java.awt.event.MouseEvent 的构造方法
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。
MouseEvent(Component, int, long, int, int, int, int, int, int, boolean, int) - 类 java.awt.event.MouseEvent 的构造方法
构造一个具有指定源组件、类型、修饰符、相对坐标、绝对坐标和单击计数的 MouseEvent 对象。
MouseEvent - org.w3c.dom.events 中的 接口
MouseEvent 接口提供与鼠标事件相关联的特定上下文信息。
mouseExit(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
mouseExited(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseExited 方法处理 mouseExited 事件。
mouseExited(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标离开组件时调用。
mouseExited(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标离开组件时调用。
mouseExited(MouseEvent) - 接口 java.awt.event.MouseListener 中的方法
鼠标离开组件时调用。
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的方法
当鼠标退出滚动条时调用。
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
鼠标退出组件时调用。
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
鼠标退出某个区域时调用。
mouseExited(MouseEvent) - 类 javax.swing.ToolTipManager 中的方法
鼠标退出组件区域时调用。
mouseHandler - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
处理发自此类和拆分窗格的鼠标事件。
MouseInfo - java.awt 中的 类
MouseInfo 提供获取有关鼠标信息的方法，如鼠标指针位置和鼠标按钮数。
MouseInputAdapter - javax.swing.event 中的 类
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。
MouseInputAdapter() - 类 javax.swing.event.MouseInputAdapter 的构造方法
MouseInputListener - javax.swing.event 中的 接口
实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。
mouseInputListener - 类 javax.swing.plaf.basic.BasicListUI 中的变量
mouseInputListener - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
mouseInputListener - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的变量
mouseInputListener - 类 javax.swing.plaf.basic.BasicTableUI 中的变量
MouseListener - java.awt.event 中的 接口
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
mouseListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
mouseListener - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
MouseMotionAdapter - java.awt.event 中的 类
接收鼠标移动事件的抽象适配器类。
MouseMotionAdapter() - 类 java.awt.event.MouseMotionAdapter 的构造方法
MouseMotionListener - java.awt.event 中的 接口
用于接收组件上的鼠标移动事件的侦听器接口。
mouseMotionListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
mouseMove(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
mouseMove(int, int) - 类 java.awt.Robot 中的方法
将鼠标指针移动到给定屏幕坐标。
mouseMoved(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseMoved 方法处理 mouseMoved 事件。
mouseMoved(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标按钮在组件上移动（无按钮按下）时调用。
mouseMoved(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标光标移动到组件上但无按键按下时调用。
mouseMoved(MouseEvent) - 类 java.awt.event.MouseMotionAdapter 中的方法
鼠标按键在组件上移动（无按键按下）时调用。
mouseMoved(MouseEvent) - 接口 java.awt.event.MouseMotionListener 中的方法
鼠标光标移动到组件上但无按键按下时调用。
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
基于方向重置光标。
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 中的方法
已将鼠标按键移动到组件上（但没有按下任何一个按键）时调用。
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
移动鼠标时调用。
mouseMoved(MouseEvent) - 类 javax.swing.text.html.HTMLEditorKit.LinkController 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.ToolTipManager 中的方法
移动鼠标时调用。
mousePress(int) - 类 java.awt.Robot 中的方法
按下一个或多个鼠标按钮。
mousePressed(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mousePressed 方法处理 mousePressed 事件。
mousePressed(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标按钮在 Component 上按下时调用。
mousePressed(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标按键在组件上按下时调用。
mousePressed(MouseEvent) - 接口 java.awt.event.MouseListener 中的方法
鼠标按键在组件上按下时调用。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler 中的方法
响应组合框上的鼠标按下事件。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
在菜单上单击鼠标时调用。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的方法
如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按下鼠标则将滚动条值增加一页。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的方法
如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按鼠标则将滚动条值增加一页。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
通过创建 DragController 的适当实例启动拖动会话。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 中的方法
在组件上按下鼠标按键时调用。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener 中的方法
mousePressed(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
如果按下 button 1，实现它可请求将焦点置于关联的文本组件上，并设置插入符位置。
mousePressed(MouseEvent) - 类 javax.swing.ToolTipManager 中的方法
当按下鼠标时调用。
mouseRelease(int) - 类 java.awt.Robot 中的方法
释放一个或多个鼠标按钮。
mouseReleased(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseReleased 方法处理 mouseReleased 事件。
mouseReleased(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标按钮在组件上释放时调用。
mouseReleased(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标按钮在组件上释放时调用。
mouseReleased(MouseEvent) - 接口 java.awt.event.MouseListener 中的方法
鼠标按钮在组件上释放时调用。
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler 中的方法
响应用户终止从组合框开始的单击或拖动操作。
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
在菜单上释放鼠标时调用。
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
如果拖动器不为 null，则此方法利用 completeDrag 传递消息。
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
释放鼠标时调用。
mouseReleased(MouseEvent) - 类 javax.swing.text.html.FormView.MouseEventListener 中的方法
mouseUp(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
mouseWheel(int) - 类 java.awt.Robot 中的方法
在配有滚轮的鼠标上旋转滚轮。
MouseWheelEvent - java.awt.event 中的 类
表示鼠标滚轮在组件中滚动的事件。
MouseWheelEvent(Component, int, long, int, int, int, int, boolean, int, int, int) - 类 java.awt.event.MouseWheelEvent 的构造方法
构造一个具有指定源组件、类型、修改键、坐标、滚动类型、滚动量和滚轮旋转的 MouseWheelEvent。
MouseWheelEvent(Component, int, long, int, int, int, int, int, int, boolean, int, int, int) - 类 java.awt.event.MouseWheelEvent 的构造方法
构造一个具有指定源组件、类型、修改键、坐标、绝对坐标、滚动类型、滚动量和滚轮滚动的 MouseWheelEvent 对象。
MouseWheelListener - java.awt.event 中的 接口
用于接收组件上的鼠标滚轮事件的侦听器接口。
mouseWheelMoved(MouseWheelEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseWheelMoved 方法处理 mouseWheelMoved 事件。
mouseWheelMoved(MouseWheelEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标滚轮旋转时调用。
mouseWheelMoved(MouseWheelEvent) - 接口 java.awt.event.MouseWheelListener 中的方法
鼠标滚轮旋转时调用。
mouseWheelMoved(MouseWheelEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler 中的方法
当鼠标滚轮在 JScrollPane 上转动时调用。
move(int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
move(int, int) - 类 java.awt.Point 中的方法
将此点移动到 (x,y) 坐标平面中的指定位置。
move(int, int) - 类 java.awt.Rectangle 中的方法
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
MOVE - 类 javax.swing.TransferHandler 中的静态变量
表示“移动”传输动作的 int 值。
MOVE_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
MOVE_CURSOR - 类 java.awt.Cursor 中的静态变量
移动光标类型。
MOVE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.MOVE_CURSOR 取代。
moveAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
moveAndRepaint(JComponent, int, int, int, int) - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 中的方法
moveCaret(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
试图使用 viewToModel() 从鼠标事件的坐标移动插入符的位置。
moveCaretPosition(int) - 类 javax.swing.text.JTextComponent 中的方法
将插入符移动到新的位置，同时保留最后一次调用 setCaretPosition 之前定义的标记。
moveColumn(int, int) - 类 javax.swing.JTable 中的方法
将视图中的 column 列移动到当前被 targetColumn 列所占用的位置。
moveColumn(int, int) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
将 columnIndex 位置的列和标题移到 newIndex。
moveColumn(int, int) - 接口 javax.swing.table.TableColumnModel 中的方法
将 columnIndex 位置的列及其头移至 newIndex。
moveDot(int) - 接口 javax.swing.text.Caret 中的方法
将插入符位置（点）移动到其他某个位置，放在标记后面。
moveDot(int) - 类 javax.swing.text.DefaultCaret 中的方法
将插入符位置移动到指定位置，存在向前偏差。
moveDot(int, Position.Bias) - 类 javax.swing.text.DefaultCaret 中的方法
将插入符位置移动到指定位置，存在指定偏差。
moveDot(int, Position.Bias) - 类 javax.swing.text.NavigationFilter.FilterBypass 中的方法
移动插入符的位置，并跳过 NavigationFilter。
moveDot(NavigationFilter.FilterBypass, int, Position.Bias) - 类 javax.swing.text.NavigationFilter 中的方法
在 Caret 移动点之前调用。
moveLeadSelectionIndex(int) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置 lead 选择索引，并不作更改地保留所有选择值。
movePointLeft(int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，它等效于将该值的小数点向左移动 n 位。
movePointRight(int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，它等效于将该值的小数点向右移动 n 位。
moveRow(int, int, int) - 类 javax.swing.table.DefaultTableModel 中的方法
将 start（包含）到 end（包含）范围中的一行或多行移到模型中的 to 位置。
moveTo(double, double) - 类 java.awt.geom.Path2D.Double 中的方法
通过移动到指定坐标（以双精度指定），将一个点添加到路径中。
moveTo(double, double) - 类 java.awt.geom.Path2D.Float 中的方法
通过移动到指定坐标（以双精度指定），将一个点添加到路径中。
moveTo(float, float) - 类 java.awt.geom.Path2D.Float 中的方法
通过移动到指定的坐标（以 float 精度指定），将一个点添加到路径中。
moveTo(double, double) - 类 java.awt.geom.Path2D 中的方法
通过移动到指定坐标（以双精度指定），将一个点添加到路径中。
moveToBack() - 类 javax.swing.JInternalFrame 中的方法
如果此组件的父组件是 JLayeredPane，则将此组件移至位置 -1 的便捷方法。
moveToBack(Component) - 类 javax.swing.JLayeredPane 中的方法
将该组件移到当前层中所有组件的底层（位置 -1）。
moveToCurrentRow() - 接口 java.sql.ResultSet 中的方法
将光标移动到记住的光标位置，通常为当前行。
moveToFront() - 类 javax.swing.JInternalFrame 中的方法
如果此组件的父组件是 JLayeredPane，则将此组件移至位置 0 的便捷方法。
moveToFront(Component) - 类 javax.swing.JLayeredPane 中的方法
将该组件移到当前层中所有组件的顶层（位置 0）。
moveToInsertRow() - 接口 java.sql.ResultSet 中的方法
将光标移动到插入行。
MOVING_TO_PAUSED - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
已经暂停了打印机，但设备要停下来还需要一些时间。
MS - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
MULTI_LINE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此（文本）对象可以包含多行文本
MULTI_SELECTION_ENABLED_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
允许选择多个文件。
MultiButtonUI - javax.swing.plaf.multi 中的 类
用于组合 ButtonUI 的多路 UI。
MultiButtonUI() - 类 javax.swing.plaf.multi.MultiButtonUI 的构造方法
MulticastSocket - java.net 中的 类
多播数据报套接字类用于发送和接收 IP 多播包。
MulticastSocket() - 类 java.net.MulticastSocket 的构造方法
创建多播套接字。
MulticastSocket(int) - 类 java.net.MulticastSocket 的构造方法
创建多播套接字并将其绑定到特定端口。
MulticastSocket(SocketAddress) - 类 java.net.MulticastSocket 的构造方法
创建绑定到指定套接字地址的 MulticastSocket。
MultiColorChooserUI - javax.swing.plaf.multi 中的 类
用于组合 ColorChooserUI 的多路 UI。
MultiColorChooserUI() - 类 javax.swing.plaf.multi.MultiColorChooserUI 的构造方法
MultiComboBoxUI - javax.swing.plaf.multi 中的 类
用于组合 ComboBoxUI 的多路 UI。
MultiComboBoxUI() - 类 javax.swing.plaf.multi.MultiComboBoxUI 的构造方法
MultiDesktopIconUI - javax.swing.plaf.multi 中的 类
用于组合 DesktopIconUI 的多路 UI。
MultiDesktopIconUI() - 类 javax.swing.plaf.multi.MultiDesktopIconUI 的构造方法
MultiDesktopPaneUI - javax.swing.plaf.multi 中的 类
用于组合 DesktopPaneUI 的多路 UI。
MultiDesktopPaneUI() - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 的构造方法
MultiDoc - javax.print 中的 接口
接口 MultiDoc 指定某个对象的接口，该对象为 PrintJob 提供多部分打印数据。
MultiDocPrintJob - javax.print 中的 接口
从 MultiDocPrintService 中获得，MultiDocPrintJob 可使用作业属性集以单个 PrintJob 的形式打印指定的文档集合。
MultiDocPrintService - javax.print 中的 接口
接口 MultiPrintService 是 MultiDocPrintJob 的工厂。
MultiFileChooserUI - javax.swing.plaf.multi 中的 类
用于组合 FileChooserUI 的多路 UI。
MultiFileChooserUI() - 类 javax.swing.plaf.multi.MultiFileChooserUI 的构造方法
MultiInternalFrameUI - javax.swing.plaf.multi 中的 类
用于组合 InternalFrameUI 的多路 UI。
MultiInternalFrameUI() - 类 javax.swing.plaf.multi.MultiInternalFrameUI 的构造方法
MultiLabelUI - javax.swing.plaf.multi 中的 类
用于组合 LabelUI 的多路 UI。
MultiLabelUI() - 类 javax.swing.plaf.multi.MultiLabelUI 的构造方法
MULTILINE - 类 java.util.regex.Pattern 中的静态变量
启用多行模式。
MultiListUI - javax.swing.plaf.multi 中的 类
用于组合 ListUI 的多路 UI。
MultiListUI() - 类 javax.swing.plaf.multi.MultiListUI 的构造方法
MultiLookAndFeel - javax.swing.plaf.multi 中的 类
多路外观允许同时将多个 UI 与一个组件相关联。
MultiLookAndFeel() - 类 javax.swing.plaf.multi.MultiLookAndFeel 的构造方法
MultiMenuBarUI - javax.swing.plaf.multi 中的 类
用于组合 MenuBarUI 的多路 UI。
MultiMenuBarUI() - 类 javax.swing.plaf.multi.MultiMenuBarUI 的构造方法
MultiMenuItemUI - javax.swing.plaf.multi 中的 类
用于组合 MenuItemUI 的多路 UI。
MultiMenuItemUI() - 类 javax.swing.plaf.multi.MultiMenuItemUI 的构造方法
MultiOptionPaneUI - javax.swing.plaf.multi 中的 类
用于组合 OptionPaneUI 的多路 UI。
MultiOptionPaneUI() - 类 javax.swing.plaf.multi.MultiOptionPaneUI 的构造方法
MultiPanelUI - javax.swing.plaf.multi 中的 类
用于组合 PanelUI 的多路 UI。
MultiPanelUI() - 类 javax.swing.plaf.multi.MultiPanelUI 的构造方法
MultiPixelPackedSampleModel - java.awt.image 中的 类
MultiPixelPackedSampleModel 类表示单 band 图像，能够将多个单样本像素打包到一个数据元素中。
MultiPixelPackedSampleModel(int, int, int, int) - 类 java.awt.image.MultiPixelPackedSampleModel 的构造方法
构造一个具有指定数据类型、宽度、高度和每像素位数的 MultiPixelPackedSampleModel。
MultiPixelPackedSampleModel(int, int, int, int, int, int) - 类 java.awt.image.MultiPixelPackedSampleModel 的构造方法
构造一个具有指定数据类型、宽度、高度、每像素位数、扫描行间距和数据位偏移量的 MultiPixelPackedSampleModel。
MULTIPLE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
MULTIPLE_ID - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的静态变量
MULTIPLE_INTERVAL_SELECTION - 接口 javax.swing.ListSelectionModel 中的静态变量
selectionMode 属性的值：一次选择一个或多个连续的索引范围。
MultipleComponentProfileHelper - org.omg.IOP 中的 类
形成多组件配置文件的一组加标记的组件。
MultipleComponentProfileHelper() - 类 org.omg.IOP.MultipleComponentProfileHelper 的构造方法
MultipleComponentProfileHolder - org.omg.IOP 中的 类
形成多组件配置文件的一组加标记的组件。
MultipleComponentProfileHolder() - 类 org.omg.IOP.MultipleComponentProfileHolder 的构造方法
MultipleComponentProfileHolder(TaggedComponent[]) - 类 org.omg.IOP.MultipleComponentProfileHolder 的构造方法
MultipleDocumentHandling - javax.print.attribute.standard 中的 类
MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
MultipleDocumentHandling(int) - 类 javax.print.attribute.standard.MultipleDocumentHandling 的构造方法
构造具有给定整数值的新 MultipleDocumentHandling 枚举值。
MultipleGradientPaint - java.awt 中的 类
这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。
MultipleGradientPaint.ColorSpaceType - java.awt 中的 枚举
在其中执行渐变插值操作的颜色空间。
MultipleGradientPaint.CycleMethod - java.awt 中的 枚举
在渐变边界以外进行绘制时使用的方法。
MultipleMaster - java.awt.font 中的 接口
MultipleMaster 接口表示 Type 1 Multiple Master 字体。
multiply(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this × multiplicand)，其标度为 (this.scale() + multiplicand.scale())。
multiply(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (this × multiplicand) 的 BigDecimal（根据上下文设置进行舍入）。
multiply(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this * val) 的 BigInteger。
multiply(int) - 类 javax.xml.datatype.Duration 中的方法
计算新的持续时间，值为此持续时间值的 factor 倍。
multiply(BigDecimal) - 类 javax.xml.datatype.Duration 中的方法
计算新的持续时间，其值是此持续时间值的 factor 倍。
MultiPopupMenuUI - javax.swing.plaf.multi 中的 类
用于组合 PopupMenuUI 的多路 UI。
MultiPopupMenuUI() - 类 javax.swing.plaf.multi.MultiPopupMenuUI 的构造方法
MultiProgressBarUI - javax.swing.plaf.multi 中的 类
用于组合 ProgressBarUI 的多路 UI。
MultiProgressBarUI() - 类 javax.swing.plaf.multi.MultiProgressBarUI 的构造方法
MultiRootPaneUI - javax.swing.plaf.multi 中的 类
用于组合 RootPaneUI 的多路 UI。
MultiRootPaneUI() - 类 javax.swing.plaf.multi.MultiRootPaneUI 的构造方法
MultiScrollBarUI - javax.swing.plaf.multi 中的 类
用于组合 ScrollBarUI 的多路 UI。
MultiScrollBarUI() - 类 javax.swing.plaf.multi.MultiScrollBarUI 的构造方法
MultiScrollPaneUI - javax.swing.plaf.multi 中的 类
用于组合 ScrollPaneUI 的多路 UI。
MultiScrollPaneUI() - 类 javax.swing.plaf.multi.MultiScrollPaneUI 的构造方法
MULTISELECTABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象允许同时选定多个子级。
MultiSeparatorUI - javax.swing.plaf.multi 中的 类
用于组合 SeparatorUI 的多路 UI。
MultiSeparatorUI() - 类 javax.swing.plaf.multi.MultiSeparatorUI 的构造方法
MultiSliderUI - javax.swing.plaf.multi 中的 类
用于组合 SliderUI 的多路 UI。
MultiSliderUI() - 类 javax.swing.plaf.multi.MultiSliderUI 的构造方法
MultiSpinnerUI - javax.swing.plaf.multi 中的 类
用于组合 SpinnerUI 的多路 UI。
MultiSpinnerUI() - 类 javax.swing.plaf.multi.MultiSpinnerUI 的构造方法
MultiSplitPaneUI - javax.swing.plaf.multi 中的 类
用于组合 SplitPaneUI 的多路 UI。
MultiSplitPaneUI() - 类 javax.swing.plaf.multi.MultiSplitPaneUI 的构造方法
MultiTabbedPaneUI - javax.swing.plaf.multi 中的 类
用于组合 TabbedPaneUI 的多路 UI。
MultiTabbedPaneUI() - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 的构造方法
MultiTableHeaderUI - javax.swing.plaf.multi 中的 类
用于组合 TableHeaderUI 的多路 UI。
MultiTableHeaderUI() - 类 javax.swing.plaf.multi.MultiTableHeaderUI 的构造方法
MultiTableUI - javax.swing.plaf.multi 中的 类
用于组合 TableUI 的多路 UI。
MultiTableUI() - 类 javax.swing.plaf.multi.MultiTableUI 的构造方法
MultiTextUI - javax.swing.plaf.multi 中的 类
用于组合 TextUI 的多路 UI。
MultiTextUI() - 类 javax.swing.plaf.multi.MultiTextUI 的构造方法
MultiToolBarUI - javax.swing.plaf.multi 中的 类
用于组合 ToolBarUI 的多路 UI。
MultiToolBarUI() - 类 javax.swing.plaf.multi.MultiToolBarUI 的构造方法
MultiToolTipUI - javax.swing.plaf.multi 中的 类
用于组合 ToolTipUI 的多路 UI。
MultiToolTipUI() - 类 javax.swing.plaf.multi.MultiToolTipUI 的构造方法
MultiTreeUI - javax.swing.plaf.multi 中的 类
用于组合 TreeUI 的多路 UI。
MultiTreeUI() - 类 javax.swing.plaf.multi.MultiTreeUI 的构造方法
MultiViewportUI - javax.swing.plaf.multi 中的 类
用于组合 ViewportUI 的多路 UI。
MultiViewportUI() - 类 javax.swing.plaf.multi.MultiViewportUI 的构造方法
MUSICAL_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Musical Symbols”Unicode 字符块的常量。
MutableAttributeSet - javax.swing.text 中的 接口
独特属性的可变集合的通用接口。
MutableComboBoxModel - javax.swing 中的 接口
ComboBoxModel 的可变版本。
MutableTreeNode - javax.swing.tree 中的 接口
定义针对树节点对象的要求，这些树节点可以通过以下操作更改：添加或移除子节点，或更改该节点中存储的用户对象的内容。
mutatesTo(Object, Object) - 类 java.beans.DefaultPersistenceDelegate 中的方法
如果指定构造方法中的参数数量不为零，且 oldInstance 的类显式声明了一个 "equals" 方法，则此方法返回 oldInstance.equals(newInstance) 的值。
mutatesTo(Object, Object) - 类 java.beans.PersistenceDelegate 中的方法
如果 oldInstance 的等效 副本可以可以通过应用 newInstance 的一系列语句来创建，则返回 true。
MutationEvent - org.w3c.dom.events 中的 接口
MutationEvent 接口提供与 Mutation 事件相关的特定上下文信息。
MUTE - 类 javax.sound.sampled.BooleanControl.Type 中的静态变量
表示行的静音状态的控件。
MXBean - javax.management 中的 注释类型
显式地标记某一接口是否为 MXBean 接口的注释。
MXBEAN_FIELD - 类 javax.management.JMX 中的静态变量
mxbean 字段的名称。
MYANMAR - 类 java.awt.font.NumericShaper 中的静态变量
标识 MYANMAR 范围和十进制基数。
MYANMAR - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Myanmar”Unicode 字符块的常量。
myProps - 类 javax.naming.InitialContext 中的变量
与此 InitialContext 关联的环境。
mySyntax - 类 javax.naming.CompoundName 中的变量
此组合名称的语法属性。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


N - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

N

N - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
N_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口上边框大小的光标类型。
N_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.N_RESIZE_CURSOR 取代。
NA_10X13_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (10 x 13 in) 的 MediaType 实例。
NA_10x13_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 10 inch × 13 inch 信封尺寸。
NA_10X13_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
10x13 North American 信封尺寸。
NA_10X14_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (10 x 14 in) 的 MediaType 实例。
NA_10x14_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 10 inch × 14 inch 信封尺寸。
NA_10X14_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
10x14North American 信封尺寸。
NA_10X15_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (10 x 15 in) 的 MediaType 实例。
NA_10X15_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 10 inch × 15 inch 信封尺寸。
NA_10X15_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
10x15 North American 信封尺寸。
NA_5X7 - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 5 inch × 7 inch 纸。
NA_5X7 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
5x7 North American 纸。
NA_6X9_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (6 x 9 in) 的 MediaType 实例。
NA_6X9_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 6 inch × 9 inch 信封尺寸。
NA_6X9_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
6x9 North American 信封尺寸。
NA_7X9_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (7 x 9 in) 的 MediaType 实例。
NA_7X9_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 7 inch × 9 inch 信封尺寸。
NA_7X9_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
7x9 North American 信封尺寸。
NA_8X10 - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 8 inch × 10 inch 纸。
NA_8X10 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
8x10 North American 纸。
NA_9X11_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (9 x 11 in) 的 MediaType 实例。
NA_9x11_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 9 inch × 11 inch 信封尺寸。
NA_9X11_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
9x11 North American 信封尺寸。
NA_9X12_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (9 x 12 in) 的 MediaType 实例。
NA_9x12_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 9 inch × 12 inch 信封尺寸。
NA_9X12_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
9x12 North American 信封尺寸。
NA_LEGAL - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American Legal (8 1/2 x 14 in) 的 MediaType 实例。
NA_LEGAL - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
legal 尺寸。
NA_LETTER - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American Letter (8 1/2 x 11 in) 的 MediaType 实例。
NA_LETTER - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
信纸尺寸。
NA_LETTER_TRANSPARENT - 类 javax.print.attribute.standard.MediaName 中的静态变量
信纸透明度。
NA_LETTER_WHITE - 类 javax.print.attribute.standard.MediaName 中的静态变量
空白信纸。
NA_NUMBER_10_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American #10 Business Envelope (4 1/8 x 9 1/2 in) 的 MediaType 实例。
NA_NUMBER_10_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American Number 10 商用信封尺寸，4.125 inch × 9.5 inch。
NA_NUMBER_10_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
10 号信封尺寸。
NA_NUMBER_11_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American #11 Business Envelope (4 1/2 x 10 3/8 in) 的 MediaType 实例。
NA_NUMBER_11_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American Number 11 商用信封尺寸，4.5 inch × 10.375 inch。
NA_NUMBER_11_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
11 号信封尺寸。
NA_NUMBER_12_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American #12 Business Envelope (4 3/4 x 11 in) 的 MediaType 实例。
NA_NUMBER_12_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American Number 12 商用信封尺寸，4.75 inch × 11 inch。
NA_NUMBER_12_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
12 号信封尺寸。
NA_NUMBER_14_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American #14 Business Envelope (5 x 11 1/2 in) 的 MediaType 实例。
NA_NUMBER_14_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American Number 14 商用信封尺寸，5 inch × 11.5 inch。
NA_NUMBER_14_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
14 号信封尺寸。
NA_NUMBER_9_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American #9 Business Envelope (3 7/8 x 8 7/8 in) 的 MediaType 实例。
NA_NUMBER_9_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American Number 9 商用信封尺寸，3.875 inch × 8.875 inch。
NA_NUMBER_9_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
9 号信封尺寸。
name - 类 java.awt.Cursor 中的变量
光标的用户可视名称。
name - 类 java.awt.Font 中的变量
Font 的逻辑名称，它被传递到构造方法中。
name() - 类 java.lang.Enum 中的方法
返回此枚举常量的名称，在其枚举声明中对其进行声明。
name() - 类 java.nio.charset.Charset 中的方法
返回此 charset 的规范名称。
name - 类 java.sql.DriverPropertyInfo 中的变量
属性的名称。
name() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.name() 中的规范实现 name 方法。
name() - 类 java.util.prefs.Preferences 中的方法
返回此首选项节点相对于父节点的名称。
Name - javax.lang.model.element 中的 接口
字符的不可变序列。
name - 类 javax.management.MBeanFeatureInfo 中的变量
该功能的名称。
Name - javax.naming 中的 接口
Name 接口表示一个一般名称，即一个有序的组件序列。
NAME - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它标识脚本语言的短名称。
NAME - 接口 javax.swing.Action 中的静态变量
用来存储动作的 String 名称的键，用于菜单或按钮。
NAME - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
name - 类 javax.swing.text.html.parser.AttributeList 中的变量
name - 类 javax.swing.text.html.parser.DTD 中的变量
NAME - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
name - 类 javax.swing.text.html.parser.Element 中的变量
name - 类 javax.swing.text.html.parser.Entity 中的变量
name - 类 javax.xml.bind.JAXBElement 中的变量
xml 元素标记名称。
Name - javax.xml.soap 中的 接口
XML 名称的表示形式。
name() - 类 org.omg.CORBA.NamedValue 中的方法
检索此 NamedValue 对象的名称。
name(byte[]) - 类 org.omg.CORBA.Principal 中的方法
已过时。 已由 CORBA 2.2 取代。
name() - 类 org.omg.CORBA.Principal 中的方法
已过时。 已由 CORBA 2.2 取代。
name - 类 org.omg.CORBA.StructMember 中的变量
此 StructMember 对象所描述的 struct 成员的名称。
name() - 类 org.omg.CORBA.TypeCode 中的方法
在 TypeCode 对象的封闭作用域内检索标识此对象的简单名称。
name - 类 org.omg.CORBA.UnionMember 中的变量
此 UnionMember 对象所描述的 union 成员的名称。
name - 类 org.omg.CORBA.ValueMember 中的变量
此 ValueMember 对象所描述的 value 成员的名称。
name() - 接口 org.omg.PortableInterceptor.InterceptorOperations 中的方法
返回 interceptor 的名称。
name - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName 中的变量
已为其注册了 interceptor 的名称。
name2type(String) - 类 javax.swing.text.html.parser.AttributeList 中的静态方法
name2type(String) - 类 javax.swing.text.html.parser.Element 中的静态方法
name2type(String) - 类 javax.swing.text.html.parser.Entity 中的静态方法
将 nm 字符串转换为相应的实体类型。
NAME_NOT_MN - 异常 org.ietf.jgss.GSSException 中的静态变量
包含多机制元素的名称。
NameAlreadyBoundException - javax.naming 中的 异常
一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
NameAlreadyBoundException(String) - 异常 javax.naming.NameAlreadyBoundException 的构造方法
使用所提供的解释构造一个新的 NameAlreadyBoundException 实例。
NameAlreadyBoundException() - 异常 javax.naming.NameAlreadyBoundException 的构造方法
构造一个新的 NameAlreadyBoundException 实例。
NameAttribute - 接口 javax.swing.text.AttributeSet 中的静态变量
用于命名属性集合的属性名。
NameAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
用于命名属性集合的属性名称。
NameCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 NameCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取名称信息。
NameCallback(String) - 类 javax.security.auth.callback.NameCallback 的构造方法
构造一个带提示的 NameCallback。
NameCallback(String, String) - 类 javax.security.auth.callback.NameCallback 的构造方法
构造一个带提示和默认名称的 NameCallback。
NameClassPair - javax.naming 中的 类
此类表示存在于上下文中的某一绑定的对象名称和类名称对。
NameClassPair(String, String) - 类 javax.naming.NameClassPair 的构造方法
在给定名称和类名称的情况下构造一个 NameClassPair 实例。
NameClassPair(String, String, boolean) - 类 javax.naming.NameClassPair 的构造方法
在给定其名称、类名称以及该名称是否相对于列表上下文的情况下构造一个 NameClassPair 实例。
NameComponent - org.omg.CosNaming 中的 类
org/omg/CosNaming/NameComponent.java。
NameComponent() - 类 org.omg.CosNaming.NameComponent 的构造方法
NameComponent(String, String) - 类 org.omg.CosNaming.NameComponent 的构造方法
NameComponentHelper - org.omg.CosNaming 中的 类
org/omg/CosNaming/NameComponentHelper.java。
NameComponentHelper() - 类 org.omg.CosNaming.NameComponentHelper 的构造方法
NameComponentHolder - org.omg.CosNaming 中的 类
org/omg/CosNaming/NameComponentHolder.java。
NameComponentHolder() - 类 org.omg.CosNaming.NameComponentHolder 的构造方法
NameComponentHolder(NameComponent) - 类 org.omg.CosNaming.NameComponentHolder 的构造方法
NamedNodeMap - org.w3c.dom 中的 接口
实现 NamedNodeMap 接口的对象用于表示可以通过名称访问的节点的集合。
NamedValue - org.omg.CORBA 中的 类
在 DII 和 DSI 中用来描述参数和返回值的对象。
NamedValue() - 类 org.omg.CORBA.NamedValue 的构造方法
NameDynAnyPair - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameDynAnyPair.java。
NameDynAnyPair() - 类 org.omg.DynamicAny.NameDynAnyPair 的构造方法
NameDynAnyPair(String, DynAny) - 类 org.omg.DynamicAny.NameDynAnyPair 的构造方法
NameDynAnyPairHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameDynAnyPairHelper.java。
NameDynAnyPairHelper() - 类 org.omg.DynamicAny.NameDynAnyPairHelper 的构造方法
NameDynAnyPairSeqHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameDynAnyPairSeqHelper.java。
NameDynAnyPairSeqHelper() - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 的构造方法
NameHelper - org.omg.CosNaming 中的 类
名称是名称组件的序列。
NameHelper() - 类 org.omg.CosNaming.NameHelper 的构造方法
NameHolder - org.omg.CosNaming 中的 类
名称是名称组件的序列。
NameHolder() - 类 org.omg.CosNaming.NameHolder 的构造方法
NameHolder(NameComponent[]) - 类 org.omg.CosNaming.NameHolder 的构造方法
NameList - org.w3c.dom 中的 接口
NameList 接口提供对并行的名称和名称空间值对（可以为 null 值）的有序集合的抽象，无需定义或约束如何实现此集合。
NameNotFoundException - javax.naming 中的 异常
当名称的组件由于没有被绑定而无法解析时，抛出此异常。
NameNotFoundException(String) - 异常 javax.naming.NameNotFoundException 的构造方法
使用所提供的解释构造一个新的 NameNotFoundException 实例。
NameNotFoundException() - 异常 javax.naming.NameNotFoundException 的构造方法
构造一个新的 NameNotFoundException 实例，将解释和所有名称解析字段和初始化为 null。
NameParser - javax.naming 中的 接口
此接口用于解析取自分层的名称空间的名称。
names - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
从 getFormatNames 返回的字符串数组，该数组最初为 null。
NAMES - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Namespace - javax.xml.stream.events 中的 接口
包含有关名称空间的信息的接口。
NAMESPACE - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个名称空间声明
NAMESPACE_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图以一种与名称空间有关的错误的方式创建或更改一个对象。
NamespaceChangeListener - javax.naming.event 中的 接口
指定对名称空间更改感兴趣的侦听器必须实现的方法。
NamespaceContext - javax.xml.namespace 中的 接口
用于只读 XML 名称空间上下文处理的接口。
NamespaceSupport - org.xml.sax.helpers 中的 类
封装名称空间逻辑，以便由使用 SAX 的应用程序使用，或由 SAX 驱动程序内部使用。
NamespaceSupport() - 类 org.xml.sax.helpers.NamespaceSupport 的构造方法
创建新的名称空间支持对象。
nameUUIDFromBytes(byte[]) - 类 java.util.UUID 中的静态方法
根据指定的字节数组获取类型 3（基于名称的）UUID 的静态工厂。
NameValuePair - org.omg.CORBA 中的 类
将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。
NameValuePair() - 类 org.omg.CORBA.NameValuePair 的构造方法
创建一个空的 NameValuePair 对象。
NameValuePair(String, Any) - 类 org.omg.CORBA.NameValuePair 的构造方法
构造一个 NameValuePair 对象，该对象将给定名称与给定 org.omg.CORBA.Any 对象关联。
NameValuePair - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameValuePair.java。
NameValuePair() - 类 org.omg.DynamicAny.NameValuePair 的构造方法
NameValuePair(String, Any) - 类 org.omg.DynamicAny.NameValuePair 的构造方法
NameValuePairHelper - org.omg.CORBA 中的 类
NameValuePair 的 Helper。
NameValuePairHelper() - 类 org.omg.CORBA.NameValuePairHelper 的构造方法
NameValuePairHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameValuePairHelper.java。
NameValuePairHelper() - 类 org.omg.DynamicAny.NameValuePairHelper 的构造方法
NameValuePairSeqHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameValuePairSeqHelper.java。
NameValuePairSeqHelper() - 类 org.omg.DynamicAny.NameValuePairSeqHelper 的构造方法
Naming - java.rmi 中的 类
Naming 类提供在对象注册表中存储和获得远程对远程对象引用的方法。
NamingContext - org.omg.CosNaming 中的 接口
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextExt - org.omg.CosNaming 中的 接口
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtHelper - org.omg.CosNaming 中的 类
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtHelper() - 类 org.omg.CosNaming.NamingContextExtHelper 的构造方法
NamingContextExtHolder - org.omg.CosNaming 中的 类
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtHolder() - 类 org.omg.CosNaming.NamingContextExtHolder 的构造方法
NamingContextExtHolder(NamingContextExt) - 类 org.omg.CosNaming.NamingContextExtHolder 的构造方法
NamingContextExtOperations - org.omg.CosNaming 中的 接口
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtPOA - org.omg.CosNaming 中的 类
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtPOA() - 类 org.omg.CosNaming.NamingContextExtPOA 的构造方法
NamingContextHelper - org.omg.CosNaming 中的 类
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextHelper() - 类 org.omg.CosNaming.NamingContextHelper 的构造方法
NamingContextHolder - org.omg.CosNaming 中的 类
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextHolder() - 类 org.omg.CosNaming.NamingContextHolder 的构造方法
NamingContextHolder(NamingContext) - 类 org.omg.CosNaming.NamingContextHolder 的构造方法
NamingContextOperations - org.omg.CosNaming 中的 接口
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextPOA - org.omg.CosNaming 中的 类
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextPOA() - 类 org.omg.CosNaming.NamingContextPOA 的构造方法
NamingEnumeration<T> - javax.naming 中的 接口
此接口用于枚举 javax.naming 和 javax.naming.directory 包中的方法所返回的列表。
NamingEvent - javax.naming.event 中的 类
此类表示命名/目录服务触发的事件。
NamingEvent(EventContext, int, Binding, Binding, Object) - 类 javax.naming.event.NamingEvent 的构造方法
构造一个 NamingEvent 的实例。
NamingException - javax.naming 中的 异常
此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
NamingException(String) - 异常 javax.naming.NamingException 的构造方法
使用解释构造一个新的 NamingException。
NamingException() - 异常 javax.naming.NamingException 的构造方法
构造一个新的 NamingException。
NamingExceptionEvent - javax.naming.event 中的 类
此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。
NamingExceptionEvent(EventContext, NamingException) - 类 javax.naming.event.NamingExceptionEvent 的构造方法
使用在抛出过 NamingException 的上下文和抛出的异常构造一个 NamingExceptionEvent 的实例。
namingExceptionThrown(NamingExceptionEvent) - 接口 javax.naming.event.NamingListener 中的方法
在试图触发 NamingEvent 期间抛出命名异常时调用此方法。
NamingListener - javax.naming.event 中的 接口
此接口是处理 NamingEvent 的侦听器接口的根。
NamingManager - javax.naming.spi 中的 类
此类包含一些方法来创建上下文对象以及通过命名或目录服务中的信息引用的对象。
NamingSecurityException - javax.naming 中的 异常
此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
NamingSecurityException(String) - 异常 javax.naming.NamingSecurityException 的构造方法
使用所提供的解释构造一个新的 NamingSecurityException 实例。
NamingSecurityException() - 异常 javax.naming.NamingSecurityException 的构造方法
构造一个新的 NamingSecurityException 实例。
NaN - 类 java.lang.Double 中的静态变量
保存 double 类型的 NaN 值的常量。
NaN - 类 java.lang.Float 中的静态变量
保存 float 类型的非数字 (NaN) 值的常量。
nanoTime() - 类 java.lang.System 中的静态方法
返回最准确的可用系统计时器的当前值，以毫微秒为单位。
narrow(Object, Class) - 接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 中的方法
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。
narrow(Object, Class) - 类 javax.rmi.PortableRemoteObject 中的静态方法
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。
narrow(Object) - 类 org.omg.CORBA.CurrentHelper 中的静态方法
narrow(Object) - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
narrow(Object) - 类 org.omg.CORBA.PolicyHelper 中的静态方法
narrow(Object) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
narrow(Object) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
narrow(Object) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
narrow(Object) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
narrow(Object) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
narrow(Object) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
narrow(Object) - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
narrow(Object) - 类 org.omg.PortableServer.POAHelper 中的静态方法
narrow(Object) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
narrow(Object) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
NATIVE - 类 java.awt.JobAttributes.DialogType 中的静态变量
用于指定平台的本机打印对话框的 DialogType 实例。
NATIVE - 类 java.lang.reflect.Modifier 中的静态变量
表示 native 修饰符的 int 的值。
nativeImageMetadataFormatClassName - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的本地流元数据格式的类名称的 String，该字符串最初为 null。
nativeImageMetadataFormatName - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。
nativeMetadataFormatClassName - 类 javax.imageio.metadata.IIOMetadata 中的变量
实现 IIOMetadataFormat 和表示本机元数据格式的类的名称，初始化为 null，通过构造方法设置。
nativeMetadataFormatName - 类 javax.imageio.metadata.IIOMetadata 中的变量
此对象本机元数据格式的名称，初始化为 null，通过构造方法设置。
nativeOrder() - 类 java.nio.ByteOrder 中的静态方法
获取底层平台的本机字节顺序。
nativeSQL(String) - 接口 java.sql.Connection 中的方法
将给定的 SQL 语句转换成系统本机 SQL 语法。
nativeStreamMetadataFormatClassName - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的本地流元数据格式的类名称的 String，初始为 null。
nativeStreamMetadataFormatName - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。
navigableKeySet() - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
返回此映射中所包含键的 NavigableSet 视图。
navigableKeySet() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
navigableKeySet() - 接口 java.util.NavigableMap 中的方法
返回此映射中所包含键的 NavigableSet 视图。
navigableKeySet() - 类 java.util.TreeMap 中的方法
NavigableMap<K,V> - java.util 中的 接口
扩展的 SortedMap，具有了针对给定搜索目标返回最接近匹配项的导航方法。
NavigableSet<E> - java.util 中的 接口
扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
navigateFocusedComp(int) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
navigateKey - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
已过时。 从 1.3 开始。
navigateKey2 - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
已过时。 从 1.3 开始。
navigateSelectedTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
NavigationFilter - javax.swing.text 中的 类
NavigationFilter 可用于限制光标的定位。
NavigationFilter() - 类 javax.swing.text.NavigationFilter 的构造方法
NavigationFilter.FilterBypass - javax.swing.text 中的 类
用作防止回调插入符以定位光标的方式。
NavigationFilter.FilterBypass() - 类 javax.swing.text.NavigationFilter.FilterBypass 的构造方法
NCHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 NCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
NClob - java.sql 中的 接口
SQL NCLOB 类型在 JavaTM 编程语言中的映射。
NCLOB - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 NCLOB 的 Java 编程语言中的常量（有时称为类型代码）。
ncontext - 类 org.omg.CosNaming.BindingType 中的静态变量
nCopies(int, T) - 类 java.util.Collections 中的静态方法
返回由指定对象的 n 个副本组成的不可变列表。
NE_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口右上角大小的光标类型。
NE_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.NE_RESIZE_CURSOR 取代。
needsCacheFile() - 类 javax.imageio.spi.ImageInputStreamSpi 中的方法
如果与此服务提供者关联的 ImageInputStream 实现要求使用缓存 File，则返回 true。
needsCacheFile() - 类 javax.imageio.spi.ImageOutputStreamSpi 中的方法
如果与此服务提供者关联的 ImageOutputStream 实现要求使用缓存 File，则返回 true。
needsDictionary() - 类 java.util.zip.Inflater 中的方法
如果解压缩需要预置字典，则返回 true。
needsGui() - 类 java.beans.beancontext.BeanContextSupport 中的方法
此方法通常从环境中调用，以便确定实现者是否“需要” GUI。
needsGui() - 接口 java.beans.Visibility 中的方法
确定此 bean 是否需要一个 GUI。
needsInput() - 类 java.util.zip.Deflater 中的方法
如果输入数据缓冲区为空，并且应调用 setInput() 以提供更多输入，则返回 true。
needsInput() - 类 java.util.zip.Inflater 中的方法
如果输入缓冲区中没有剩余数据，则返回 true。
needsReload(String, Locale, String, ClassLoader, ResourceBundle, long) - 类 java.util.ResourceBundle.Control 中的方法
确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。
negate() - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其值为 (-this)，其标度为 this.scale()。
negate(MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (-this) 的 BigDecimal（根据上下文设置进行舍入）。
negate() - 类 java.math.BigInteger 中的方法
返回其值是 (-this) 的 BigInteger。
negate() - 类 javax.xml.datatype.Duration 中的方法
返回值为 -this 的新 Duration 对象。
NEGATIVE_INFINITY - 类 java.lang.Double 中的静态变量
保存 double 类型的负无穷大值的常量。
NEGATIVE_INFINITY - 类 java.lang.Float 中的静态变量
保存 float 类型的负无穷大值的常量。
NEGATIVE_SCROLL - 类 javax.swing.plaf.basic.BasicSliderUI 中的静态变量
NegativeArraySizeException - java.lang 中的 异常
如果应用程序试图创建大小为负的数组，则抛出该异常。
NegativeArraySizeException() - 异常 java.lang.NegativeArraySizeException 的构造方法
构造不带详细消息的 NegativeArraySizeException。
NegativeArraySizeException(String) - 异常 java.lang.NegativeArraySizeException 的构造方法
构造带指定详细消息的 NegativeArraySizeException。
negotiate() - 类 javax.naming.ldap.StartTlsResponse 中的方法
使用默认的 SSL 套接字工厂协商 TLS 会话。
negotiate(SSLSocketFactory) - 类 javax.naming.ldap.StartTlsResponse 中的方法
使用 SSL 套接字工厂协商 TLS 会话。
nested - 异常 javax.xml.stream.XMLStreamException 中的变量
NestingKind - javax.lang.model.element 中的 枚举
某一类型元素的嵌套种类 (nesting kind)。
NetPermission - java.net 中的 类
此类可用于各种网络权限。
NetPermission(String) - 类 java.net.NetPermission 的构造方法
创建具有指定名称的新 NetPermission。
NetPermission(String, String) - 类 java.net.NetPermission 的构造方法
创建带指定名称的新 NetPermission。
NetworkInterface - java.net 中的 类
此类表示一个由名称和分配给此接口的 IP 地址列表组成的网络接口。
NEVER_UPDATE - 类 javax.swing.text.DefaultCaret 中的静态变量
指示无论文档有任何更新，插入符都应在文档中保持同一绝对位置，由于删除使文档长度小于当前插入符位置除外。
new_context() - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
new_context() - 类 org.omg.CosNaming._NamingContextStub 中的方法
此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
new_context() - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
newAttributes - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的变量
newAudioClip(URL) - 类 java.applet.Applet 中的静态方法
从给定 URL 处获取音频剪辑。
newBinding - 类 javax.naming.event.NamingEvent 中的变量
包含关于更改后对象的信息。
newBundle(String, Locale, String, ClassLoader, boolean) - 类 java.util.ResourceBundle.Control 中的方法
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。
newCachedThreadPool() - 类 java.util.concurrent.Executors 中的静态方法
创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们。
newCachedThreadPool(ThreadFactory) - 类 java.util.concurrent.Executors 中的静态方法
创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们，并在需要时使用提供的 ThreadFactory 创建新线程。
newCall(RemoteObject, Operation[], int, long) - 接口 java.rmi.server.RemoteRef 中的方法
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。
newCanonicalizationMethod(String, C14NMethodParameterSpec) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 CanonicalizationMethod。
newCanonicalizationMethod(String, XMLStructure) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 CanonicalizationMethod。
newChannel(InputStream) - 类 java.nio.channels.Channels 中的静态方法
构造从给定流读取字节的信道。
newChannel(OutputStream) - 类 java.nio.channels.Channels 中的静态方法
构造向给定流写入字节的信道。
newClient(Object) - 接口 javax.management.remote.rmi.RMIServer 中的方法
建立一个使用该 RMI 连接器的新连接。
newClient(Object) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
创建一个新的客户端连接。
newClient(Object) - 类 javax.management.remote.rmi.RMIServerImpl_Stub 中的方法
newCondition() - 接口 java.util.concurrent.locks.Lock 中的方法
返回绑定到此 Lock 实例的新 Condition 实例。
newCondition() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回用来与此 Lock 实例一起使用的 Condition 实例。
newCondition() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
因为 ReadLocks 不支持条件，所以将抛出 UnsupportedOperationException。
newCondition() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
返回一个用来与此 Lock 实例一起使用的 Condition 实例。
newDataAvailable(TableModelEvent) - 类 javax.swing.table.DefaultTableModel 中的方法
等效于 fireTableChanged。
newDecoder() - 类 java.nio.charset.Charset 中的方法
为此 charset 构造新的解码器。
newDigestMethod(String, DigestMethodParameterSpec) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 DigestMethod。
newDocument() - 类 javax.xml.parsers.DocumentBuilder 中的方法
获取 DOM Document 对象的一个新实例来生成一个 DOM 树。
newDocumentBuilder() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
使用当前配置的参数创建一个新的 DocumentBuilder 实例。
newDuration(String) - 类 javax.xml.datatype.DatatypeFactory 中的方法
获取新的 Duration 实例，它根据 XML 模式 1.0 第 3.2.6.1 节中的定义将 Duration 指定为其字符串表示形式 "PnYnMnDTnHnMnS"。
newDuration(long) - 类 javax.xml.datatype.DatatypeFactory 中的方法
获取新的 Duration 实例，它将 Duration 指定为毫秒。
newDuration(boolean, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigDecimal) - 类 javax.xml.datatype.DatatypeFactory 中的方法
获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
newDuration(boolean, int, int, int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
newDurationDayTime(String) - 类 javax.xml.datatype.DatatypeFactory 中的方法
通过解析其 String 表示形式 "PnDTnHnMnS"（XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration）创建类型为 xdt:dayTimeDuration 的 Duration。
newDurationDayTime(long) - 类 javax.xml.datatype.DatatypeFactory 中的方法
使用 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中定义的指定毫秒创建类型为 xdt:dayTimeDuration 的 Duration。
newDurationDayTime(boolean, BigInteger, BigInteger, BigInteger, BigInteger) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
newDurationDayTime(boolean, int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
newDurationYearMonth(String) - 类 javax.xml.datatype.DatatypeFactory 中的方法
通过解析其 String 表示形式 "PnYnM"（XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration）创建类型为 xdt:yearMonthDuration 的 Duration。
newDurationYearMonth(long) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定毫秒创建类型为 xdt:yearMonthDuration 的 Duration。
newDurationYearMonth(boolean, BigInteger, BigInteger) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
newDurationYearMonth(boolean, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
newEncoder() - 类 java.nio.charset.Charset 中的方法
为此 charset 构造新的编码器。
newFactory(String) - 类 javax.xml.validation.SchemaFactoryLoader 中的方法
创建指定模式语言的新 SchemaFactory 对象。
newFixedThreadPool(int) - 类 java.util.concurrent.Executors 中的静态方法
创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程。
newFixedThreadPool(int, ThreadFactory) - 类 java.util.concurrent.Executors 中的静态方法
创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程，在需要时使用提供的 ThreadFactory 创建新线程。
newFolderIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
newInputStream(ReadableByteChannel) - 类 java.nio.channels.Channels 中的静态方法
构造从给定信道读取字节的流。
newInstance() - 类 java.lang.Class 中的方法
创建此 Class 对象所表示的类的一个新实例。
newInstance(Class<?>, int) - 类 java.lang.reflect.Array 中的静态方法
创建一个具有指定的组件类型和长度的新数组。
newInstance(Class<?>, int...) - 类 java.lang.reflect.Array 中的静态方法
创建一个具有指定的组件类型和维度的新数组。
newInstance(Object...) - 类 java.lang.reflect.Constructor 中的方法
使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。
newInstance(URL[], ClassLoader) - 类 java.net.URLClassLoader 中的静态方法
为指定的 URL 和父类加载器创建新 URLClassLoader 实例。
newInstance(URL[]) - 类 java.net.URLClassLoader 中的静态方法
为指定的 URL 和默认的父类加载器创建新 URLClassLoader 实例。
newInstance(ActivationID, ActivationDesc) - 类 java.rmi.activation.ActivationGroup_Stub 中的方法
ActivationGroup.newInstance 的 stub 方法。
newInstance(ActivationID, ActivationDesc) - 接口 java.rmi.activation.ActivationInstantiator 中的方法
激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。
newInstance(KeyStore, KeyStore.ProtectionParameter) - 类 java.security.KeyStore.Builder 中的静态方法
返回封装给定 KeyStore 的新 Builder。
newInstance(String, Provider, File, KeyStore.ProtectionParameter) - 类 java.security.KeyStore.Builder 中的静态方法
返回新的 Builder 对象。
newInstance(String, Provider, KeyStore.ProtectionParameter) - 类 java.security.KeyStore.Builder 中的静态方法
返回新的 Builder 对象。
newInstance(Object) - 类 java.security.Provider.Service 中的方法
返回此服务描述的实现的新实例。
newInstance(Control[]) - 类 javax.naming.ldap.InitialLdapContext 中的方法
newInstance(Control[]) - 接口 javax.naming.ldap.LdapContext 中的方法
创建此上下文的新实例，使用请求控件进行初始化。
newInstance(String) - 类 javax.xml.bind.JAXBContext 中的静态方法
获得 JAXBContext 类的新实例。
newInstance(String, ClassLoader) - 类 javax.xml.bind.JAXBContext 中的静态方法
获得 JAXBContext 类的新实例。
newInstance(String, ClassLoader, Map<String, ?>) - 类 javax.xml.bind.JAXBContext 中的静态方法
获得 JAXBContext 类的新实例。
newInstance(Class...) - 类 javax.xml.bind.JAXBContext 中的静态方法
获得 JAXBContext 类的新实例。
newInstance(Class[], Map<String, ?>) - 类 javax.xml.bind.JAXBContext 中的静态方法
获得 JAXBContext 类的新实例。
newInstance() - 类 javax.xml.datatype.DatatypeFactory 中的静态方法
获取新的 DatatypeFactory 实例。
newInstance(String, ClassLoader) - 类 javax.xml.datatype.DatatypeFactory 中的静态方法
从类名称中获取新的 DatatypeFactory 实例。
newInstance() - 类 javax.xml.parsers.DocumentBuilderFactory 中的静态方法
获取 DocumentBuilderFactory 的新实例。
newInstance(String, ClassLoader) - 类 javax.xml.parsers.DocumentBuilderFactory 中的静态方法
从类名称中获取新的 DocumentBuilderFactory 实例。
newInstance() - 类 javax.xml.parsers.SAXParserFactory 中的静态方法
获取 SAXParserFactory 的一个新实例。
newInstance(String, ClassLoader) - 类 javax.xml.parsers.SAXParserFactory 中的静态方法
从类名称中获取新的 SAXParserFactory 实例。
newInstance() - 类 javax.xml.soap.MessageFactory 中的静态方法
创建新的 MessageFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
newInstance(String) - 类 javax.xml.soap.MessageFactory 中的静态方法
创建新的 MessageFactory 对象，该对象是指定实现的实例。
newInstance() - 类 javax.xml.soap.SOAPConnectionFactory 中的静态方法
创建默认 SOAPConnectionFactory 对象的实例。
newInstance() - 类 javax.xml.soap.SOAPElementFactory 中的静态方法
已过时。 创建新的 SOAPElementFactory 实例。
newInstance() - 类 javax.xml.soap.SOAPFactory 中的静态方法
创建新的 SOAPFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
newInstance(String) - 类 javax.xml.soap.SOAPFactory 中的静态方法
创建新的 SOAPFactory 对象，该对象是指定实现的实例，此方法使用 SAAJMetaFactory 来定位实现类并创建 SOAPFactory 实例。
newInstance() - 接口 javax.xml.stream.util.XMLEventAllocator 中的方法
此方法创建一个 XMLEventAllocator 实例。
newInstance() - 类 javax.xml.stream.XMLEventFactory 中的静态方法
创建一个新的工厂实例。
newInstance(String, ClassLoader) - 类 javax.xml.stream.XMLEventFactory 中的静态方法
创建一个新的工厂实例。
newInstance() - 类 javax.xml.stream.XMLInputFactory 中的静态方法
创建一个新的工厂实例。
newInstance(String, ClassLoader) - 类 javax.xml.stream.XMLInputFactory 中的静态方法
创建一个新的工厂实例。
newInstance() - 类 javax.xml.stream.XMLOutputFactory 中的静态方法
创建一个新的工厂实例。
newInstance(String, ClassLoader) - 类 javax.xml.stream.XMLOutputFactory 中的静态方法
创建一个的新工厂实例。
newInstance() - 类 javax.xml.transform.TransformerFactory 中的静态方法
获取 TransformerFactory 的新实例。
newInstance(String, ClassLoader) - 类 javax.xml.transform.TransformerFactory 中的静态方法
根据类名称获得一个新 TransformerFactory 实例。
newInstance(String) - 类 javax.xml.validation.SchemaFactory 中的静态方法
查找支持指定模式语言的 SchemaFactory 的实现并返回它。
newInstance(String, String, ClassLoader) - 类 javax.xml.validation.SchemaFactory 中的静态方法
根据类名称获得一个新 SchemaFactory 实例。
newInstance() - 类 javax.xml.xpath.XPathFactory 中的静态方法
获取使用默认对象模型 XPathFactory.DEFAULT_OBJECT_MODEL_URI（即 W3C DOM）的新 XPathFactory 实例。
newInstance(String) - 类 javax.xml.xpath.XPathFactory 中的静态方法
获取使用指定对象模型的新 XPathFactory 实例。
newInstance(String, String, ClassLoader) - 类 javax.xml.xpath.XPathFactory 中的静态方法
根据工厂类名称获取一个新 XPathFactory 实例。
newInstance() - 类 org.w3c.dom.bootstrap.DOMImplementationRegistry 中的静态方法
获得 DOMImplementationRegistry 的新实例。
newJMXConnector(JMXServiceURL, Map<String, ?>) - 类 javax.management.remote.JMXConnectorFactory 中的静态方法
为位于给定地址的连接器服务器创建一个连接器客户端。
newJMXConnector(JMXServiceURL, Map<String, ?>) - 接口 javax.management.remote.JMXConnectorProvider 中的方法
创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。
newJMXConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - 类 javax.management.remote.JMXConnectorServerFactory 中的静态方法
创建位于给定地址的连接器服务器。
newJMXConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - 接口 javax.management.remote.JMXConnectorServerProvider 中的方法
创建位于给定地址的新连接器服务器。
newKeyInfo(List) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
创建包含指定的密钥信息类型列表的 KeyInfo。
newKeyInfo(List, String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
创建包含指定的密钥信息类型列表和可选 id 的 KeyInfo。
newKeyName(String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的名称创建 KeyName。
newKeyValue(PublicKey) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的公钥创建 KeyValue。
newLeadSelectionPath - 类 javax.swing.event.TreeSelectionEvent 中的变量
在路径被更改之后的 leadSelectionPath，可能为 null。
newLine() - 类 java.io.BufferedWriter 中的方法
写入一个行分隔符。
NEWLINE - 类 javax.swing.text.AbstractWriter 中的静态变量
text 包模拟新行的方式。
newManifest(List) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建包含指定的 Reference 列表的 Manifest。
newManifest(List, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建包含指定的 Reference 列表和可选 id 的 Manifest。
newMBeanProxy(MBeanServerConnection, ObjectName, Class<T>) - 类 javax.management.JMX 中的静态方法
在本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
newMBeanProxy(MBeanServerConnection, ObjectName, Class<T>, boolean) - 类 javax.management.JMX 中的静态方法
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
newMBeanServer(String, MBeanServer, MBeanServerDelegate) - 类 javax.management.MBeanServerBuilder 中的方法
此方法创建一个新的 MBeanServer 实现对象。
newMBeanServer() - 类 javax.management.MBeanServerFactory 中的静态方法
返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。
newMBeanServer(String) - 类 javax.management.MBeanServerFactory 中的静态方法
返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。
newMBeanServerDelegate() - 类 javax.management.MBeanServerBuilder 中的方法
此方法为新的 MBeanServer 创建新的 MBeanServerDelegate。
newMessageFactory(String) - 类 javax.xml.soap.SAAJMetaFactory 中的方法
创建给定 String 协议的 MessageFactory 对象。
newmodel - 类 java.awt.image.RGBImageFilter 中的变量
用户调用 substituteColorModel 时替换 origmodel 的 ColorModel。
newMXBeanProxy(MBeanServerConnection, ObjectName, Class<T>) - 类 javax.management.JMX 中的静态方法
在本地或远程 MBean Server 中为 MXBean 构造一个代理。
newMXBeanProxy(MBeanServerConnection, ObjectName, Class<T>, boolean) - 类 javax.management.JMX 中的静态方法
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 MXBean 构造一个代理。
newNode - 类 java.util.prefs.AbstractPreferences 中的变量
如果在创建此对象前内部存储中不存在此节点，则该字段为 true。
newOutputStream(WritableByteChannel) - 类 java.nio.channels.Channels 中的静态方法
构造向给定信道写入字节的流。
newPacker() - 类 java.util.jar.Pack200 中的静态方法
获取一个实现 Packer 的新的类实例。
newPermissionCollection() - 类 java.io.FilePermission 中的方法
返回用于存储 FilePermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 java.net.SocketPermission 中的方法
用于存储 SocketPermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 java.security.AllPermission 中的方法
返回用于存储 AllPermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 java.security.BasicPermission 中的方法
用于存储 BasicPermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 java.security.Permission 中的方法
对给定 Permission 对象返回空 PermissionCollection，如果没有定义则返回 null。
newPermissionCollection() - 类 java.security.UnresolvedPermission 中的方法
返回存储 UnresolvedPermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 java.util.PropertyPermission 中的方法
用于存储 PropertyPermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 javax.management.MBeanServerPermission 中的方法
newPermissionCollection() - 类 javax.security.auth.kerberos.DelegationPermission 中的方法
返回用于存储 DelegationPermission 对象的 PermissionCollection 对象。
newPermissionCollection() - 类 javax.security.auth.kerberos.ServicePermission 中的方法
返回用于存储 ServicePermission 对象的 PermissionCollection 对象。
newPermissionCollection() - 类 javax.security.auth.PrivateCredentialPermission 中的方法
返回 PermissionCollection 中同类的 PrivateCredentialPermissions 集合。
newPGPData(byte[]) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的 PGP 公钥标识符创建 PGPData。
newPGPData(byte[], byte[], List) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的 PGP 公钥标识符、可选的密钥材料包和外部元素的列表，创建 PGPData。
newPGPData(byte[], List) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的 PGP 密钥材料包和可选的外部元素列表创建 PGPData。
newPixels() - 类 java.awt.image.MemoryImageSource 中的方法
将全部的新像素缓冲区发送到所有目前对此图像数据感兴趣的 ImageConsumer，并通知这些 ImageConsumer 一个动画帧已完成。
newPixels(int, int, int, int) - 类 java.awt.image.MemoryImageSource 中的方法
将像素缓冲区的矩形区域发送到所有目前对此图像数据感兴趣的 ImageConsumer，并通知这些 ImageConsumer 一个动画帧已完成。
newPixels(int, int, int, int, boolean) - 类 java.awt.image.MemoryImageSource 中的方法
将像素缓冲区的矩形区域发送到所有目前对此图像数据感兴趣的 ImageConsumer。
newPixels(byte[], ColorModel, int, int) - 类 java.awt.image.MemoryImageSource 中的方法
改用一个新的 byte 数组以保存此图像的像素。
newPixels(int[], ColorModel, int, int) - 类 java.awt.image.MemoryImageSource 中的方法
改用一个新的 int 数组以保存此图像的像素。
newPlatformMXBeanProxy(MBeanServerConnection, String, Class<T>) - 类 java.lang.management.ManagementFactory 中的静态方法
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。
newProxyInstance(ClassLoader, Class<?>[], InvocationHandler) - 类 java.lang.reflect.Proxy 中的静态方法
返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。
newProxyInstance(MBeanServerConnection, ObjectName, Class<T>, boolean) - 类 javax.management.MBeanServerInvocationHandler 中的静态方法
返回一个代理，该代理通过将其方法从给定 MBean 服务器转发到指定 MBean 来实现给定的接口。
newReader(ReadableByteChannel, CharsetDecoder, int) - 类 java.nio.channels.Channels 中的静态方法
构造一个 reader，它用给定的解码器对取自给定信道的字节进行解码。
newReader(ReadableByteChannel, String) - 类 java.nio.channels.Channels 中的静态方法
构造一个 reader，它根据命名的 charset 对取自给定信道的字节进行解码。
newReference(String, DigestMethod) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定 URI 和摘要方法的 Reference。
newReference(String, DigestMethod, List, String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定参数的 Reference。
newReference(String, DigestMethod, List, String, String, byte[]) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定参数和预计算的摘要值的 Reference。
newReference(String, DigestMethod, List, Data, List, String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定参数的 Reference。
newRetrievalMethod(String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的 URI 创建 RetrievalMethod。
newRetrievalMethod(String, String, List) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的参数创建 RetrievalMethod。
newRowsAdded(TableModelEvent) - 类 javax.swing.table.DefaultTableModel 中的方法
确保新行的列数正确。
NEWS - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
USENET 新闻。
newSAXParser() - 类 javax.xml.parsers.SAXParserFactory 中的方法
使用当前配置的工厂参数创建 SAXParser 的一个新实例。
newScheduledThreadPool(int) - 类 java.util.concurrent.Executors 中的静态方法
创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
newScheduledThreadPool(int, ThreadFactory) - 类 java.util.concurrent.Executors 中的静态方法
创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
newSchema(Source) - 类 javax.xml.validation.SchemaFactory 中的方法
解析作为模式的指定源并以模式形式返回它。
newSchema(File) - 类 javax.xml.validation.SchemaFactory 中的方法
解析作为模式的指定 File 并以 Schema 的形式返回它。
newSchema(URL) - 类 javax.xml.validation.SchemaFactory 中的方法
解析作为模式的指定 URL 并以 Schema 形式返回它。
newSchema(Source[]) - 类 javax.xml.validation.SchemaFactory 中的方法
解析作为模式的指定源（或多个源），并以模式形式返回它。
newSchema() - 类 javax.xml.validation.SchemaFactory 中的方法
创建特殊的 Schema 对象。
newSetFromMap(Map<E, Boolean>) - 类 java.util.Collections 中的静态方法
返回指定映射支持的 set。
newSignatureMethod(String, SignatureMethodParameterSpec) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 SignatureMethod。
newSignatureProperties(List, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建包含指定的 SignatureProperty 列表和可选 id 的 SignatureProperties。
newSignatureProperty(List, String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建包含指定的 XMLStructure 列表、目标 URI 和可选 id 的SignatureProperty。
newSignedInfo(CanonicalizationMethod, SignatureMethod, List) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
newSignedInfo(CanonicalizationMethod, SignatureMethod, List, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定参数的 SignedInfo。
newSingleThreadExecutor() - 类 java.util.concurrent.Executors 中的静态方法
创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程。
newSingleThreadExecutor(ThreadFactory) - 类 java.util.concurrent.Executors 中的静态方法
创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程，并在需要时使用提供的 ThreadFactory 创建新线程。
newSingleThreadScheduledExecutor() - 类 java.util.concurrent.Executors 中的静态方法
创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
newSingleThreadScheduledExecutor(ThreadFactory) - 类 java.util.concurrent.Executors 中的静态方法
创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
newSOAPFactory(String) - 类 javax.xml.soap.SAAJMetaFactory 中的方法
创建给定 String 协议的 SOAPFactory 对象。
newTaskFor(Runnable, T) - 类 java.util.concurrent.AbstractExecutorService 中的方法
为给定可运行任务和默认值返回一个 RunnableFuture。
newTaskFor(Callable<T>) - 类 java.util.concurrent.AbstractExecutorService 中的方法
为给定可调用任务返回一个 RunnableFuture。
newTemplates(Source) - 类 javax.xml.transform.TransformerFactory 中的方法
将 Source 处理为 Templates 对象，后者是源的编译后表示形式。
newTemplatesHandler() - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
获取能够将 SAX ContentHandler 事件处理为 Templates 对象的 TemplatesHandler 对象。
newThread(Runnable) - 接口 java.util.concurrent.ThreadFactory 中的方法
构造一个新 Thread。
newTransform(String, TransformParameterSpec) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 Transform。
newTransform(String, XMLStructure) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 Transform。
newTransformer() - 接口 javax.xml.transform.Templates 中的方法
创建此 Templates 对象的新转换上下文。
newTransformer(Source) - 类 javax.xml.transform.TransformerFactory 中的方法
将 Source 处理为 Transformer Object。
newTransformer() - 类 javax.xml.transform.TransformerFactory 中的方法
创建执行从 Source 到 Result 的复制的新 Transformer。
newTransformerHandler(Source) - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
基于参数所指定的转换指令，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
newTransformerHandler(Templates) - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
基于 Templates 参数，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
newTransformerHandler() - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
newUnpacker() - 类 java.util.jar.Pack200 中的静态方法
获取一个实现 Unpacker 的新的类实例。
newUpdater(Class<U>, String) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的静态方法
使用给定字段为对象创建和返回一个更新器。
newUpdater(Class<U>, String) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的静态方法
为对象创建并返回一个具有给定字段的更新器。
newUpdater(Class<U>, Class<W>, String) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的静态方法
使用给定的字段为对象创建和返回一个更新器。
newValidator() - 类 javax.xml.validation.Schema 中的方法
创建此 Schema 的新 Validator。
newValidatorHandler() - 类 javax.xml.validation.Schema 中的方法
创建此 Schema 的新 ValidatorHandler。
newWriter(WritableByteChannel, CharsetEncoder, int) - 类 java.nio.channels.Channels 中的静态方法
构造一个 writer，它使用给定的编码器对字符进行编码，并将所得的字节写入给定的信道。
newWriter(WritableByteChannel, String) - 类 java.nio.channels.Channels 中的静态方法
构造一个 writer，它根据指定的 charset 对字符进行编码，并将所得的字节写入给定的信道。
newX509Data(List) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
创建包含指定的 X.509 内容列表的 X509Data。
newX509IssuerSerial(String, BigInteger) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的 X.500 发布方标识名和序列号创建 X509IssuerSerial。
newXMLFilter(Source) - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
创建使用给定 Source 作为转换指令的 XMLFilter。
newXMLFilter(Templates) - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
基于 Templates 参数，创建 XMLFilter。
newXMLGregorianCalendar() - 类 javax.xml.datatype.DatatypeFactory 中的方法
创建新的 XMLGregorianCalendar 实例。
newXMLGregorianCalendar(String) - 类 javax.xml.datatype.DatatypeFactory 中的方法
通过将字符串解析为词汇表示形式，创建新的 XMLGregorianCalendar。
newXMLGregorianCalendar(GregorianCalendar) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 GregorianCalendar 创建 XMLGregorianCalendar。
newXMLGregorianCalendar(BigInteger, int, int, int, int, int, BigDecimal, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
W3C XML 模式 1.0 推荐考虑完整值空间的构造方法，该方法用于 xsd:dateTime 和相关的内置数据类型。
newXMLGregorianCalendar(int, int, int, int, int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
java.util.GregorianCalendar 实例需要转换为 XMLGregorianCalendar 实例的值空间的构造方法。
newXMLGregorianCalendarDate(int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
创建 XML 模式内置数据类型 date 或 g* 的 Java 表示形式。
newXMLGregorianCalendarTime(int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
创建 XML 模式内置数据类型 time 的 Java 实例。
newXMLGregorianCalendarTime(int, int, int, BigDecimal, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
创建 XML 模式内置数据类型 time 的 Java 实例。
newXMLGregorianCalendarTime(int, int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
创建 XML 模式内置数据类型 time 的 Java 实例。
newXMLObject(List, String, String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
根据指定参数创建 XMLObject。
newXMLSignature(SignedInfo, KeyInfo) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建一个 XMLSignature，并使用指定的 SignedInfo 和 KeyInfo 对象的内容对其进行初始化。
newXMLSignature(SignedInfo, KeyInfo, List, String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建一个 XMLSignature，并使用指定的参数对其进行初始化。
newXPath() - 类 javax.xml.xpath.XPathFactory 中的方法
返回使用实例化 XPathFactory 时确定的底层对象模型的新 XPath。
next(Container) - 类 java.awt.CardLayout 中的方法
翻转到指定容器的下一张卡片。
next() - 类 java.awt.geom.FlatteningPathIterator 中的方法
只要最初的遍历方向上存在多个点，就沿该方向将迭代器移动到下一个路径段。
next() - 接口 java.awt.geom.PathIterator 中的方法
只要最初的遍历方向上还存在点，就沿该方向将迭代器移动到下一个路径段。
next() - 类 java.beans.beancontext.BeanContextSupport.BCSIterator 中的方法
next(int) - 类 java.security.SecureRandom 中的方法
生成一个包含用户指定伪随机位数的整数（右对齐，带前导零）。
next() - 接口 java.sql.ResultSet 中的方法
将光标从当前位置向前移一行。
next(int) - 类 java.text.BreakIterator 中的方法
返回从当前边界起第 n 个边界。
next() - 类 java.text.BreakIterator 中的方法
返回当前边界的后一个边界。
next() - 接口 java.text.CharacterIterator 中的方法
将迭代器的索引加一，并返回新索引处的字符。
next() - 类 java.text.CollationElementIterator 中的方法
获取字符串中的下一个 collation 元素。
next() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.next()。
next() - 接口 java.util.Iterator 中的方法
返回迭代的下一个元素。
next() - 接口 java.util.ListIterator 中的方法
返回列表中的下一个元素。
next(int) - 类 java.util.Random 中的方法
生成下一个伪随机数。
next() - 类 java.util.Scanner 中的方法
查找并返回来自此扫描器的下一个完整标记。
next(String) - 类 java.util.Scanner 中的方法
如果下一个标记与从指定字符串构造的模式匹配，则返回下一个标记。
next(Pattern) - 类 java.util.Scanner 中的方法
如果下一个标记与指定模式匹配，则返回下一个标记。
next() - 接口 javax.naming.NamingEnumeration 中的方法
检索枚举中的下一个元素。
next(int) - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
确定此整数集属性中的最小整数是否大于给定值。
next() - 接口 javax.print.MultiDoc 中的方法
转到包含 doc 对象序列中下一个 doc 对象的 multidoc 对象。
NEXT - 接口 javax.swing.SwingConstants 中的静态变量
标识序列中的下一个方向。
next() - 类 javax.swing.text.ElementIterator 中的方法
获取下一个 Element。
next() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
将迭代器向前移动到它所表示的下一个标记出现的位置。
next - 类 javax.swing.text.html.parser.AttributeList 中的变量
next - 类 javax.swing.text.html.parser.ContentModel 中的变量
下一个内容模式（使用 ','、'|' 或 '&' 表达式）。
next() - 类 javax.swing.text.Segment 中的方法
将迭代器的索引加一，并返回新索引处的字符。
next() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
next() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
next() - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取下一个解析事件??处理器可以用单个存储块返回所有连续的字符数据，它也可以将其分割成几个存储块。
next() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 移动到此 DynAny 对象的下一个组件。
next() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynStructStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynValueStub 中的方法
将当前位置推进到下一个组件。
next() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将当前位置推进到下一个组件。
next_n(int, BindingListHolder) - 类 org.omg.CosNaming._BindingIteratorStub 中的方法
此操作返回最多可以达到的请求绑定数。
next_n(int, BindingListHolder) - 接口 org.omg.CosNaming.BindingIteratorOperations 中的方法
此操作返回最多可以达到的请求绑定数。
next_one(BindingHolder) - 类 org.omg.CosNaming._BindingIteratorStub 中的方法
此操作返回下一个绑定。
next_one(BindingHolder) - 接口 org.omg.CosNaming.BindingIteratorOperations 中的方法
此操作返回下一个绑定。
nextAfter(double, double) - 类 java.lang.Math 中的静态方法
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
nextAfter(float, double) - 类 java.lang.Math 中的静态方法
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
nextAfter(double, double) - 类 java.lang.StrictMath 中的静态方法
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
nextAfter(float, double) - 类 java.lang.StrictMath 中的静态方法
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
nextBigDecimal() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 BigDecimal。
nextBigInteger() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 BigInteger。
nextBigInteger(int) - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 BigInteger。
nextBoolean() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是取自此随机数生成器序列的均匀分布的 boolean 值。
nextBoolean() - 类 java.util.Scanner 中的方法
扫描解释为一个布尔值的输入标记并返回该值。
nextByte() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 byte。
nextByte(int) - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 byte。
nextBytes(byte[]) - 类 java.security.SecureRandom 中的方法
生成用户指定的随机字节数。
nextBytes(byte[]) - 类 java.util.Random 中的方法
生成随机字节并将其置于用户提供的 byte 数组中。
nextClearBit(int) - 类 java.util.BitSet 中的方法
返回第一个设置为 false 的位的索引，这发生在指定的起始索引或之后的索引上。
nextConflict() - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
将指针从其当前位置移动到下一个包含冲突值的行。
nextDouble(double) - 类 java.text.ChoiceFormat 中的静态方法
查找大于 d 的最小 double 值。
nextDouble(double, boolean) - 类 java.text.ChoiceFormat 中的静态方法
查找大于 d 的最小 double 值（如果 positive == true），或者小于 d 的最大值（如果 positive == false）。
nextDouble() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是取自此随机数生成器序列的、在 0.0 和 1.0 之间均匀分布的 double 值。
nextDouble() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 double。
nextElement() - 接口 java.util.Enumeration 中的方法
如果此枚举对象至少还有一个可提供的元素，则返回此枚举的下一个元素。
nextElement() - 类 java.util.StringTokenizer 中的方法
除了其声明返回值是 Object 而不是 String 之外，它返回与 nextToken 方法相同的值。
nextEvent() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
nextEvent() - 接口 javax.xml.stream.XMLEventReader 中的方法
获取下一个 XMLEvent。
nextFloat() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是取自此随机数生成器序列的、在 0.0 和 1.0 之间均匀分布的 float 值。
nextFloat() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 float。
nextFocus() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 transferFocus() 取代。
nextGaussian() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是取自此随机数生成器序列的、呈高斯（“正态”）分布的 double 值，其平均值是 0.0，标准差是 1.0。
nextIndex() - 接口 java.util.ListIterator 中的方法
返回对 next 的后续调用所返回元素的索引。
nextInt() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是此随机数生成器的序列中均匀分布的 int 值。
nextInt(int) - 类 java.util.Random 中的方法
返回一个伪随机数，它是取自此随机数生成器序列的、在 0（包括）和指定值（不包括）之间均匀分布的 int 值。
nextInt() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 int。
nextInt(int) - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 int。
nextLayout(float) - 类 java.awt.font.LineBreakMeasurer 中的方法
返回下一个布局，并更新当前位置。
nextLayout(float, int, boolean) - 类 java.awt.font.LineBreakMeasurer 中的方法
返回下一个布局，并更新当前位置。
nextLine() - 类 java.util.Scanner 中的方法
此扫描器执行当前行，并返回跳过的输入信息。
nextLong() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是取自此随机数生成器序列的均匀分布的 long 值。
nextLong() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 long。
nextLong(int) - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 long。
nextOffset(float) - 类 java.awt.font.LineBreakMeasurer 中的方法
返回下一个布局结尾处的位置。
nextOffset(float, int, boolean) - 类 java.awt.font.LineBreakMeasurer 中的方法
返回下一个布局结尾处的位置。
nextPage() - 接口 javax.sql.rowset.CachedRowSet 中的方法
逐个增加 CachedRowSet 的当前页。
nextProbablePrime() - 类 java.math.BigInteger 中的方法
返回大于此 BigInteger 的可能为素数的第一个整数。
nextSetBit(int) - 类 java.util.BitSet 中的方法
返回第一个设置为 true 的位的索引，这发生在指定的起始索引或之后的索引上。
nextShort() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 short。
nextShort(int) - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 short。
nextTabStop(float, int) - 类 javax.swing.text.ParagraphView 中的方法
返回给定了参照位置的下一个制表符位位置。
nextTabStop(float, int) - 类 javax.swing.text.PlainView 中的方法
在给定引用位置之后，返回下一个制表符停靠位的位置。
nextTabStop(float, int) - 接口 javax.swing.text.TabExpander 中的方法
给定一个引用位置，返回下一个制表位 (tab stop) 位置。
nextTabStop(float, int) - 类 javax.swing.text.WrappedPlainView 中的方法
返回给定引用位置之后的下一个制表位位置。
nextTag() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
nextTag() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
nextTag() - 接口 javax.xml.stream.XMLEventReader 中的方法
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有无意义的空格事件。
nextTag() - 接口 javax.xml.stream.XMLStreamReader 中的方法
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有空格（isWhiteSpace() 返回 true）、COMMENT 或 PROCESSING_INSTRUCTION。
nextToken() - 类 java.io.StreamTokenizer 中的方法
从此标记生成器的输入流中解析下一个标记。
nextToken() - 类 java.util.StringTokenizer 中的方法
返回此 string tokenizer 的下一个标记。
nextToken(String) - 类 java.util.StringTokenizer 中的方法
返回此 string tokenizer 的字符串中的下一个标记。
nextUp(double) - 类 java.lang.Math 中的静态方法
返回 d 和正无穷大之间与 d 相邻的浮点值。
nextUp(float) - 类 java.lang.Math 中的静态方法
返回 f 和正无穷大之间与 f 相邻的浮点值。
nextUp(double) - 类 java.lang.StrictMath 中的静态方法
返回 d 和正无穷大之间与 d 相邻的浮点值。
nextUp(float) - 类 java.lang.StrictMath 中的静态方法
返回 f 和正无穷大之间与 f 相邻的浮点值。
nextWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到下一个字开头的 Action 名称。
nil - 类 javax.xml.bind.JAXBElement 中的变量
如果 xml 元素实例具有 xsi:nil="true" 属性，则 nil 为 true。
NMTOKEN - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
NMTOKENS - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
NNTP - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
使用网络新闻传输协议 (NNTP) 的 USENET 新闻。
NO - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
NO 选项。
NO_COMPRESSION - 类 java.util.zip.Deflater 中的静态变量
无压缩的压缩级别。
NO_CONTEXT - 异常 org.ietf.jgss.GSSException 中的静态变量
无效的安全上下文。
NO_CRED - 异常 org.ietf.jgss.GSSException 中的静态变量
无效的凭据。
NO_DATA_ALLOWED_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果为不支持数据的 Node 指定数据。
NO_DECOMPOSITION - 类 java.text.Collator 中的静态变量
Decomposition 模式值。
NO_FIELDS - 类 java.io.ObjectStreamClass 中的静态变量
指示不存在可序列化字段的 serialPersistentFields 值。
NO_GENERATED_KEYS - 接口 java.sql.Statement 中的静态变量
该常量指示生成的键应该不可用于获取。
NO_HIGHLIGHT - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的静态变量
NO_IMPLEMENT - org.omg.CORBA 中的 异常
此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
NO_IMPLEMENT() - 异常 org.omg.CORBA.NO_IMPLEMENT 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(String) - 异常 org.omg.CORBA.NO_IMPLEMENT 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(int, CompletionStatus) - 异常 org.omg.CORBA.NO_IMPLEMENT 的构造方法
使用指定次要代码和完成状态构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(String, int, CompletionStatus) - 异常 org.omg.CORBA.NO_IMPLEMENT 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 NO_IMPLEMENT 异常。
NO_IMPLICIT_ACTIVATION - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的静态变量
NO_MEMORY - org.omg.CORBA 中的 异常
如果 ORB 运行时出现内存不足，则抛出此异常。
NO_MEMORY() - 异常 org.omg.CORBA.NO_MEMORY 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_MEMORY 异常。
NO_MEMORY(String) - 异常 org.omg.CORBA.NO_MEMORY 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_MEMORY 异常。
NO_MEMORY(int, CompletionStatus) - 异常 org.omg.CORBA.NO_MEMORY 的构造方法
使用指定次要代码和完成状态构造一个 NO_MEMORY 异常。
NO_MEMORY(String, int, CompletionStatus) - 异常 org.omg.CORBA.NO_MEMORY 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 NO_MEMORY 异常。
NO_MODIFICATION_ALLOWED_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图在不允许修改的位置修改对象。
NO_MORE_EVENTS - 类 javax.print.event.PrintJobEvent 中的静态变量
并非所有的打印服务都能够提供所需的事件，甚至无法通知作业何时完成。
NO_OPTION - 类 javax.swing.JOptionPane 中的静态变量
选择 NO 时从类方法返回的值。
NO_ORIENTATION - 接口 java.awt.Adjustable 中的静态变量
指示 Adjustable 不具有方向。
NO_PERMISSION - org.omg.CORBA 中的 异常
当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
NO_PERMISSION() - 异常 org.omg.CORBA.NO_PERMISSION 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_PERMISSION 异常。
NO_PERMISSION(String) - 异常 org.omg.CORBA.NO_PERMISSION 的构造方法
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_PERMISSION 异常。
NO_PERMISSION(int, CompletionStatus) - 异常 org.omg.CORBA.NO_PERMISSION 的构造方法
使用指定次要代码和完成状态构造一个 NO_PERMISSION 异常。
NO_PERMISSION(String, int, CompletionStatus) - 异常 org.omg.CORBA.NO_PERMISSION 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 NO_PERMISSION 异常。
NO_PROXY - 类 java.net.Proxy 中的静态变量
表示 DIRECT 连接的代理设置，主要通知协议处理程序不使用任何代理。
NO_RESOURCES - org.omg.CORBA 中的 异常
当 ORB 遇到一些一般资源限制时，抛出此异常。
NO_RESOURCES() - 异常 org.omg.CORBA.NO_RESOURCES 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_RESOURCES 异常。
NO_RESOURCES(String) - 异常 org.omg.CORBA.NO_RESOURCES 的构造方法
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESOURCES 异常。
NO_RESOURCES(int, CompletionStatus) - 异常 org.omg.CORBA.NO_RESOURCES 的构造方法
使用指定次要代码和完成状态构造一个 NO_RESOURCES 异常。
NO_RESOURCES(String, int, CompletionStatus) - 异常 org.omg.CORBA.NO_RESOURCES 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 NO_RESOURCES 异常。
NO_RESPONSE - org.omg.CORBA 中的 异常
如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
NO_RESPONSE() - 异常 org.omg.CORBA.NO_RESPONSE 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_RESPONSE 异常。
NO_RESPONSE(String) - 异常 org.omg.CORBA.NO_RESPONSE 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESPONSE 异常。
NO_RESPONSE(int, CompletionStatus) - 异常 org.omg.CORBA.NO_RESPONSE 的构造方法
使用指定次要代码和完成状态构造一个 NO_RESPONSE 异常。
NO_RESPONSE(String, int, CompletionStatus) - 异常 org.omg.CORBA.NO_RESPONSE 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 NO_RESPONSE 异常。
NO_ROLE_WITH_NAME - 类 javax.management.relation.RoleStatus 中的静态变量
试图访问未知角色时的问题类型。
NO_ROW_CONFLICT - 接口 javax.sql.rowset.spi.SyncResolver 中的静态变量
指示在 RowSet 对象试图更新、删除或插入数据源中的行时不发生任何冲突。
NO_SUCH_PAGE - 接口 java.awt.print.Printable 中的静态变量
从 print 返回，表示 pageIndex 太大以及请求的页面不存在。
NO_SYNC - 类 javax.sound.midi.Sequencer.SyncMode 中的静态变量
辅同步模式，指示不应向接收者发送任何计时信息。
nobject - 类 org.omg.CosNaming.BindingType 中的静态变量
NOBUTTON - 类 java.awt.event.MouseEvent 中的静态变量
指示没有鼠标按键，由 MouseEvent.getButton() 使用。
NoClassDefFoundError - java.lang 中的 错误
当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
NoClassDefFoundError() - 错误 java.lang.NoClassDefFoundError 的构造方法
构造不带详细消息的 NoClassDefFoundError。
NoClassDefFoundError(String) - 错误 java.lang.NoClassDefFoundError 的构造方法
构造带指定详细消息的 NoClassDefFoundError。
NoConnectionPendingException - java.nio.channels 中的 异常
在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
NoConnectionPendingException() - 异常 java.nio.channels.NoConnectionPendingException 的构造方法
构造此类的一个实例。
NoContext - org.omg.PortableServer.CurrentPackage 中的 异常
org/omg/PortableServer/CurrentPackage/NoContext.java。
NoContext() - 异常 org.omg.PortableServer.CurrentPackage.NoContext 的构造方法
NoContext(String) - 异常 org.omg.PortableServer.CurrentPackage.NoContext 的构造方法
NoContextHelper - org.omg.PortableServer.CurrentPackage 中的 类
org/omg/PortableServer/CurrentPackage/NoContextHelper.java。
NoContextHelper() - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 的构造方法
node(String) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.node(String) 中的规范实现 node 方法。
node(String) - 类 java.util.prefs.Preferences 中的方法
将指定首选项节点返回到此节点所在的同一树中，如果此节点及其祖先已经不存在，则创建它们。
node() - 类 java.util.UUID 中的方法
与此 UUID 相关的节点值。
Node - javax.xml.soap 中的 接口
XML 文档中节点（元素）的表示形式。
NODE - 类 javax.xml.xpath.XPathConstants 中的静态变量
XPath 1.0 NodeSet 数据类型。
Node - org.w3c.dom 中的 接口
该 Node 接口是整个文档对象模型的主要数据类型。
NODE_ADOPTED - 接口 org.w3c.dom.UserDataHandler 中的静态变量
使用 Document.adoptNode() 采用节点。
NODE_CLONED - 接口 org.w3c.dom.UserDataHandler 中的静态变量
使用 Node.cloneNode() 克隆节点。
NODE_DELETED - 接口 org.w3c.dom.UserDataHandler 中的静态变量
删除节点。
NODE_IMPORTED - 接口 org.w3c.dom.UserDataHandler 中的静态变量
使用 Document.importNode() 导入节点。
NODE_RENAMED - 接口 org.w3c.dom.UserDataHandler 中的静态变量
使用 Document.renameNode() 重命名节点。
nodeChanged(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
更改节点在树中的表示方式之后，调用此方法。
NodeChangeEvent - java.util.prefs 中的 类
Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。
NodeChangeEvent(Preferences, Preferences) - 类 java.util.prefs.NodeChangeEvent 的构造方法
构造新的 NodeChangeEvent 实例。
NodeChangeListener - java.util.prefs 中的 接口
用于接收首选项节点更改事件的侦听器。
nodeDimensions - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
负责告知 TreeState 节点所需的大小。
nodeDimensions - 类 javax.swing.tree.AbstractLayoutCache 中的变量
负责获取节点大小的对象。
nodeExists(String) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.nodeExists(String) 中的规范实现 nodeExists 方法。
nodeExists(String) - 类 java.util.prefs.Preferences 中的方法
如果此节点所在的树中存在指定首选项节点，则返回 true。
NodeList - org.w3c.dom 中的 接口
NodeList 接口提供对节点的有序集合的抽象，没有定义或约束如何实现此集合。
nodesChanged(TreeNode, int[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
更改由 childIndicies 标识的子对象在树中的表示方式之后，调用此方法。
NODESET - 类 javax.xml.xpath.XPathConstants 中的静态变量
XPath 1.0 NodeSet 数据类型。
NodeSetData - javax.xml.crypto 中的 接口
包含节点集的 Data 类型的抽象表示。
nodeStructureChanged(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
如果完全更改了节点的子节点、子节点的子节点、依此类推，则调用此方法。
nodesWereInserted(TreeNode, int[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
将某些 TreeNodes 插入节点之后，调用此方法。
nodesWereRemoved(TreeNode, int[], Object[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
从节点移除一些 TreeNodes 之后，调用此方法。
noFocusBorder - 类 javax.swing.DefaultListCellRenderer 中的静态变量
一个空 Border。
noFocusBorder - 类 javax.swing.plaf.basic.BasicComboBoxRenderer 中的静态变量
空 Border。
noFocusBorder - 类 javax.swing.table.DefaultTableCellRenderer 中的静态变量
一个空 Border。
NOFRAMES - 类 javax.swing.text.html.HTML.Tag 中的静态变量
NOHREF - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
NoInitialContextException - javax.naming 中的 异常
当不能创建任何初始上下文实现时，抛出此异常。
NoInitialContextException() - 异常 javax.naming.NoInitialContextException 的构造方法
构造一个 NoInitialContextException 实例。
NoInitialContextException(String) - 异常 javax.naming.NoInitialContextException 的构造方法
使用解释构造一个 NoInitialContextException 实例。
NON_CONTINUOUS_DIVIDER - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的静态变量
用于非连续布局的分隔符通过此对象添加到拆分窗格。
non_existent(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
确定对象引用的服务器对象是否已经被销毁。
NON_EXISTENT - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/NON_EXISTENT.java。
non_existent(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
此操作用来检查 Object 是否存在。
NON_RETAIN - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的静态变量
NON_SPACING_MARK - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Mn”。
nonContinuousLayoutDivider - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
使用非连续布局时分隔符阴影的实例。
NONCRITICAL - 接口 javax.naming.ldap.Control 中的静态变量
指示非关键控件。
NONE - 类 java.awt.GridBagConstraints 中的静态变量
不重新调整组件大小。
NONE - 类 java.awt.JobAttributes.DialogType 中的静态变量
用于指定无打印对话框的 DialogType 实例。
NONE - 类 javax.print.attribute.standard.Compression 中的静态变量
不使用压缩。
NONE - 类 javax.print.attribute.standard.Finishings 中的静态变量
不执行绑定。
NONE - 类 javax.print.attribute.standard.JobSheets 中的静态变量
不打印作业页。
NONE - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
NONE - 类 javax.swing.TransferHandler 中的静态变量
表示无传输动作的 int 值。
NONE_OPTION - 类 javax.swing.DebugGraphics 中的静态变量
不要调试图形操作。
noneOf(Class<E>) - 类 java.util.EnumSet 中的静态方法
创建一个具有指定元素类型的空枚举 set。
NoninvertibleTransformException - java.awt.geom 中的 异常
NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。
NoninvertibleTransformException(String) - 异常 java.awt.geom.NoninvertibleTransformException 的构造方法
构造具有指定详细消息的 NoninvertibleTransformException 的实例。
NonReadableChannelException - java.nio.channels 中的 异常
试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
NonReadableChannelException() - 异常 java.nio.channels.NonReadableChannelException 的构造方法
构造此类的一个实例。
NONUPDATABLE_VIEW_SYNC - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示 SyncProvider 实现不支持 RowSet 对象和用于填充它的 SQL VIEW 之间的同步。
NonWritableChannelException - java.nio.channels 中的 异常
试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
NonWritableChannelException() - 异常 java.nio.channels.NonWritableChannelException 的构造方法
构造此类的一个实例。
NoPermissionException - javax.naming 中的 异常
当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
NoPermissionException(String) - 异常 javax.naming.NoPermissionException 的构造方法
使用解释构造一个新的 NoPermissionException 实例。
NoPermissionException() - 异常 javax.naming.NoPermissionException 的构造方法
构造一个新的 NoPermissionException 实例。
NOPOS - 接口 javax.tools.Diagnostic 中的静态变量
用于指示没有可用的位置。
NORESIZE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
NORM_PRIORITY - 类 java.lang.Thread 中的静态变量
分配给线程的默认优先级。
NORMAL - 类 java.awt.Frame 中的静态变量
窗体处于 "normal" 状态。
NORMAL - 类 java.awt.PageAttributes.PrintQualityType 中的静态变量
用于指定标准打印质量的 PrintQualityType 实例。
NORMAL - 类 javax.print.attribute.standard.PrintQuality 中的静态变量
打印机上的正常或中等质量。
normalize() - 类 java.net.URI 中的方法
规范化此 URI 的路径。
normalize(CharSequence, Normalizer.Form) - 类 java.text.Normalizer 中的静态方法
标准化 char 值序列。
normalize() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
不执行任何操作，因为 IIOMetadataNode 不包含 Text 子节点。
normalize() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将此实例标准化为 UTC。
normalize() - 接口 org.w3c.dom.Node 中的方法
将此 Node 之下完整的深层子树中所有 Text 节点（包括属性节点）放入只有结构（如元素、注释、处理指令、CDATA 节和实体引用）分隔 Text 节点的“常规”形式，也就是说，既没有相邻的 Text 节点，也没有空 Text 节点。
normalizeDocument() - 接口 org.w3c.dom.Document 中的方法
此方法的行为如同使文档通过一个保存和加载的过程，而将其置为 "normal（标准）" 形式。
NormalizedStringAdapter - javax.xml.bind.annotation.adapters 中的 类
处理 xs:normalizedString 的 XmlAdapter。
NormalizedStringAdapter() - 类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 的构造方法
normalizeMimeType(String) - 类 java.awt.datatransfer.DataFlavor 中的方法
已过时。
normalizeMimeType(String) - 类 javax.activation.ActivationDataFlavor 中的方法
已过时。
normalizeMimeTypeParameter(String, String) - 类 java.awt.datatransfer.DataFlavor 中的方法
已过时。
normalizeMimeTypeParameter(String, String) - 类 javax.activation.ActivationDataFlavor 中的方法
已过时。
Normalizer - java.text 中的 类
此类提供 normalize 方法，它把 Unicode 文本转换为等效的组合或分解形式，允许对文本进行更方便地分类和搜索。
Normalizer.Form - java.text 中的 枚举
此枚举提供在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的四个 Unicode 标准化形式的常量，以及访问这些常量的两个方法。
normalizeTabRuns(int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
normalizeTabRuns(int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 中的方法
normalizeWith(Calendar) - 类 javax.xml.datatype.Duration 中的方法
通过使用特定的时间点作为参考点，将 years 和 months 字段转换为 days 字段。
NoRouteToHostException - java.net 中的 异常
试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
NoRouteToHostException(String) - 异常 java.net.NoRouteToHostException 的构造方法
构造一个新的 NoRouteToHostException，使其具有关于无法到达远程主机的原因的指定详细消息。
NoRouteToHostException() - 异常 java.net.NoRouteToHostException 的构造方法
构造不带详细信息的新 NoRouteToHostException。
NORTH - 类 java.awt.BorderLayout 中的静态变量
北区域的布局约束（容器顶部）。
NORTH - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的顶部，并在水平方向上居中。
NORTH - 类 javax.swing.SpringLayout 中的静态变量
指定组件的边界矩形的顶边。
NORTH - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向北（上）。
NORTH_EAST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向东北（右上）。
NORTH_WEST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向西北（左上）。
NORTHEAST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的右上角。
northPane - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
NORTHWEST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的左上角。
NoServant - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/NoServant.java。
NoServant() - 异常 org.omg.PortableServer.POAPackage.NoServant 的构造方法
NoServant(String) - 异常 org.omg.PortableServer.POAPackage.NoServant 的构造方法
NoServantHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/NoServantHelper.java。
NoServantHelper() - 类 org.omg.PortableServer.POAPackage.NoServantHelper 的构造方法
NOSHADE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
NoSuchAlgorithmException - java.security 中的 异常
当请求特定的加密算法而它在该环境中不可用时抛出此异常。
NoSuchAlgorithmException() - 异常 java.security.NoSuchAlgorithmException 的构造方法
构造不带详细消息的 NoSuchAlgorithmException。
NoSuchAlgorithmException(String) - 异常 java.security.NoSuchAlgorithmException 的构造方法
构造带指定详细消息的 NoSuchAlgorithmException。
NoSuchAlgorithmException(String, Throwable) - 异常 java.security.NoSuchAlgorithmException 的构造方法
创建带指定详细消息和 cause 的 NoSuchAlgorithmException。
NoSuchAlgorithmException(Throwable) - 异常 java.security.NoSuchAlgorithmException 的构造方法
创建带指定 cause 和详细消息的 NoSuchAlgorithmException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
NoSuchAttributeException - javax.naming.directory 中的 异常
尝试访问不存在的属性时，抛出此异常。
NoSuchAttributeException(String) - 异常 javax.naming.directory.NoSuchAttributeException 的构造方法
使用解释构造一个新的 NoSuchAttributeException 实例。
NoSuchAttributeException() - 异常 javax.naming.directory.NoSuchAttributeException 的构造方法
构造一个新的 NoSuchAttributeException 实例。
NoSuchElementException - java.util 中的 异常
由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
NoSuchElementException() - 异常 java.util.NoSuchElementException 的构造方法
构造一个 NoSuchElementException，用 null 作为其错误消息字符串。
NoSuchElementException(String) - 异常 java.util.NoSuchElementException 的构造方法
构造一个 NoSuchElementException，保存对错误消息字符串 s 的引用，以便将来通过 getMessage 方法进行获取。
NoSuchFieldError - java.lang 中的 错误
如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
NoSuchFieldError() - 错误 java.lang.NoSuchFieldError 的构造方法
构造不带详细消息的 NoSuchFieldException。
NoSuchFieldError(String) - 错误 java.lang.NoSuchFieldError 的构造方法
构造带指定详细消息的 NoSuchFieldException。
NoSuchFieldException - java.lang 中的 异常
类不包含指定名称的字段时产生的信号。
NoSuchFieldException() - 异常 java.lang.NoSuchFieldException 的构造方法
构造方法。
NoSuchFieldException(String) - 异常 java.lang.NoSuchFieldException 的构造方法
带有详细消息的构造方法。
NoSuchMechanismException - javax.xml.crypto 中的 异常
当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。
NoSuchMechanismException() - 异常 javax.xml.crypto.NoSuchMechanismException 的构造方法
构造使用 null 作为其详细消息的新 NoSuchMechanismException。
NoSuchMechanismException(String) - 异常 javax.xml.crypto.NoSuchMechanismException 的构造方法
构造带指定详细消息的新 NoSuchMechanismException。
NoSuchMechanismException(String, Throwable) - 异常 javax.xml.crypto.NoSuchMechanismException 的构造方法
构造带指定详细消息和 cause 的新 NoSuchMechanismException。
NoSuchMechanismException(Throwable) - 异常 javax.xml.crypto.NoSuchMechanismException 的构造方法
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 NoSuchMechanismException（它通常包含 cause 的类和详细消息）。
NoSuchMethodError - java.lang 中的 错误
当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
NoSuchMethodError() - 错误 java.lang.NoSuchMethodError 的构造方法
构造不带详细消息的 NoSuchMethodError。
NoSuchMethodError(String) - 错误 java.lang.NoSuchMethodError 的构造方法
构造带指定详细消息的 NoSuchMethodError。
NoSuchMethodException - java.lang 中的 异常
无法找到某一特定方法时，抛出该异常。
NoSuchMethodException() - 异常 java.lang.NoSuchMethodException 的构造方法
构造不带详细消息的 NoSuchMethodException。
NoSuchMethodException(String) - 异常 java.lang.NoSuchMethodException 的构造方法
构造带指定详细消息的 NoSuchMethodException。
NoSuchObjectException - java.rmi 中的 异常
如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
NoSuchObjectException(String) - 异常 java.rmi.NoSuchObjectException 的构造方法
构造带指定详细消息的 NoSuchObjectException。
NoSuchPaddingException - javax.crypto 中的 异常
当请求特定填充机制但该环境中未提供时，抛出此异常。
NoSuchPaddingException() - 异常 javax.crypto.NoSuchPaddingException 的构造方法
构造不带详细消息的 NoSuchPaddingException。
NoSuchPaddingException(String) - 异常 javax.crypto.NoSuchPaddingException 的构造方法
构造带指定详细消息的 NoSuchPaddingException。
NoSuchProviderException - java.security 中的 异常
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
NoSuchProviderException() - 异常 java.security.NoSuchProviderException 的构造方法
构造不带详细消息的 NoSuchProviderException。
NoSuchProviderException(String) - 异常 java.security.NoSuchProviderException 的构造方法
构造带指定详细消息的 NoSuchProviderException。
not() - 类 java.math.BigInteger 中的方法
返回其值为 (~this) 的 BigInteger。
not(QueryExp) - 类 javax.management.Query 中的静态方法
返回一个与其参数相反的约束条件。
NOT_ACCEPTING_JOBS - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的静态变量
打印机当前拒绝发送给它的任何作业。
NOT_ATTEMPTED - 类 javax.print.attribute.standard.PDLOverrideSupported 中的静态变量
打印机不会尝试让外部的作业属性值优先于嵌入到文档打印数据中的指令。
not_context - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
NOT_FOUND_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图在它不存在的上下文中引用 Node。
not_object - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
NOT_SPECIFIED - 类 javax.sound.sampled.AudioSystem 中的静态变量
代表未知数字值的整数。
NOT_SUPPORTED - 类 javax.print.attribute.standard.ColorSupported 中的静态变量
该打印机不能进行任何类型的彩色打印。
NOT_SUPPORTED_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果实现不支持请求类型的对象或操作。
NotActiveException - java.io 中的 异常
当序列化和反序列化不活动时，抛出此异常。
NotActiveException(String) - 异常 java.io.NotActiveException 的构造方法
创建带给定原因的新 NotActiveException 的构造方法。
NotActiveException() - 异常 java.io.NotActiveException 的构造方法
创建不带原因的新 NotActiveException 的构造方法。
NOTATION - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Notation - org.w3c.dom 中的 接口
此接口表示在 DTD 中声明的表示法。
NOTATION_DECLARATION - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示一个 Notation
NOTATION_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Notation。
notationDecl(String, String, String) - 接口 org.xml.sax.DTDHandler 中的方法
接收注释声明事件的通知。
notationDecl(String, String, String) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收注释声明的通知。
notationDecl(String, String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收注释声明的通知。
notationDecl(String, String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个注释声明事件。
NotationDeclaration - javax.xml.stream.events 中的 接口
处理注释声明的接口。
NotBoundException - java.rmi 中的 异常
如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
NotBoundException() - 异常 java.rmi.NotBoundException 的构造方法
构造不带指定详细消息的 NotBoundException。
NotBoundException(String) - 异常 java.rmi.NotBoundException 的构造方法
构造带指定详细消息的 NotBoundException。
NotCompliantMBeanException - javax.management 中的 异常
尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
NotCompliantMBeanException() - 异常 javax.management.NotCompliantMBeanException 的构造方法
默认的构造方法。
NotCompliantMBeanException(String) - 异常 javax.management.NotCompliantMBeanException 的构造方法
允许指定具体错误消息的构造方法。
NotContextException - javax.naming 中的 异常
当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
NotContextException(String) - 异常 javax.naming.NotContextException 的构造方法
使用解释构造一个新的 NotContextException 实例。
NotContextException() - 异常 javax.naming.NotContextException 的构造方法
构造一个新的 NotContextException 实例。
NOTE - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_LETTER 的别名。
note - 类 javax.sound.midi.VoiceStatus 中的变量
此声音正在演奏的 MIDI 音符。
NOTE_OFF - 类 javax.sound.midi.ShortMessage 中的静态变量
NOTE_OFF 消息的命令值（0x80 或 128）
NOTE_ON - 类 javax.sound.midi.ShortMessage 中的静态变量
NOTE_ON 消息的命令值（0x90 或 144）
NotEmpty - org.omg.CosNaming.NamingContextPackage 中的 异常
org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
NotEmpty() - 异常 org.omg.CosNaming.NamingContextPackage.NotEmpty 的构造方法
NotEmpty(String) - 异常 org.omg.CosNaming.NamingContextPackage.NotEmpty 的构造方法
NotEmptyHelper - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java。
NotEmptyHelper() - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 的构造方法
NotEmptyHolder - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java。
NotEmptyHolder() - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 的构造方法
NotEmptyHolder(NotEmpty) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 的构造方法
noteOff(int, int) - 接口 javax.sound.midi.MidiChannel 中的方法
关闭指定的音符。
noteOff(int) - 接口 javax.sound.midi.MidiChannel 中的方法
关闭指定的音符。
noteOn(int, int) - 接口 javax.sound.midi.MidiChannel 中的方法
启动指定的音符发出声音。
notFilter(RowFilter<M, I>) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它包含提供的过滤器不包含的条目。
NotFound - org.omg.CosNaming.NamingContextPackage 中的 异常
org/omg/CosNaming/NamingContextPackage/NotFound.java。
NotFound() - 异常 org.omg.CosNaming.NamingContextPackage.NotFound 的构造方法
NotFound(NotFoundReason, NameComponent[]) - 异常 org.omg.CosNaming.NamingContextPackage.NotFound 的构造方法
NotFound(String, NotFoundReason, NameComponent[]) - 异常 org.omg.CosNaming.NamingContextPackage.NotFound 的构造方法
NotFoundHelper - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java。
NotFoundHelper() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 的构造方法
NotFoundHolder - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java。
NotFoundHolder() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 的构造方法
NotFoundHolder(NotFound) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 的构造方法
NotFoundReason - org.omg.CosNaming.NamingContextPackage 中的 类
指示未能解析的原因。
NotFoundReason(int) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 的构造方法
NotFoundReasonHelper - org.omg.CosNaming.NamingContextPackage 中的 类
指示未能解析的原因。
NotFoundReasonHelper() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 的构造方法
NotFoundReasonHolder - org.omg.CosNaming.NamingContextPackage 中的 类
指示未能解析的原因。
NotFoundReasonHolder() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 的构造方法
NotFoundReasonHolder(NotFoundReason) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 的构造方法
NotIdentifiableEvent - javax.xml.bind 中的 接口
此事件指示解析 ID/IDREF 时遇到一个问题。
NotIdentifiableEventImpl - javax.xml.bind.helpers 中的 类
NotIdentifiableEvent 接口的默认实现。
NotIdentifiableEventImpl(int, String, ValidationEventLocator) - 类 javax.xml.bind.helpers.NotIdentifiableEventImpl 的构造方法
创建新的 NotIdentifiableEventImpl。
NotIdentifiableEventImpl(int, String, ValidationEventLocator, Throwable) - 类 javax.xml.bind.helpers.NotIdentifiableEventImpl 的构造方法
创建新的 NotIdentifiableEventImpl。
Notification - javax.management 中的 类
Notification 类表示 MBean 所发出的通知。
Notification(String, Object, long) - 类 javax.management.Notification 的构造方法
创建一个 Notification 对象。
Notification(String, Object, long, String) - 类 javax.management.Notification 的构造方法
创建一个 Notification 对象。
Notification(String, Object, long, long) - 类 javax.management.Notification 的构造方法
创建一个 Notification 对象。
Notification(String, Object, long, long, String) - 类 javax.management.Notification 的构造方法
创建一个 Notification 对象。
NotificationBroadcaster - javax.management 中的 接口
由发出 Notifications 的 MBean 实现的接口。
NotificationBroadcasterSupport - javax.management 中的 类
提供 NotificationEmitter 接口的实现。
NotificationBroadcasterSupport() - 类 javax.management.NotificationBroadcasterSupport 的构造方法
构造一个 NotificationBroadcasterSupport，其中的每个侦听器都由发送通知的线程调用。
NotificationBroadcasterSupport(Executor) - 类 javax.management.NotificationBroadcasterSupport 的构造方法
构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。
NotificationBroadcasterSupport(MBeanNotificationInfo...) - 类 javax.management.NotificationBroadcasterSupport 的构造方法
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport。
NotificationBroadcasterSupport(Executor, MBeanNotificationInfo...) - 类 javax.management.NotificationBroadcasterSupport 的构造方法
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。
NotificationEmitter - javax.management 中的 接口
由发出 Notifications 的 MBean 实现的接口。
NotificationFilter - javax.management 中的 接口
可由作为通知过滤器的任何类来实现。
NotificationFilterSupport - javax.management 中的 类
提供 NotificationFilter 接口的实现。
NotificationFilterSupport() - 类 javax.management.NotificationFilterSupport 的构造方法
NotificationListener - javax.management 中的 接口
应该由想要接收通知的对象来实现。
notificationReceived(UnsolicitedNotificationEvent) - 接口 javax.naming.ldap.UnsolicitedNotificationListener 中的方法
当收到了未经请求的通知时调用。
NotificationResult - javax.management.remote 中的 类
缓存的通知的查询结果。
NotificationResult(long, long, TargetedNotification[]) - 类 javax.management.remote.NotificationResult 的构造方法
构造一个通知查询结果。
notifier - 类 java.awt.event.InvocationEvent 中的变量
在 Runnable.run() 方法返回之后立即调用其 notifyAll() 方法的对象（可能为 null）。
NOTIFS_LOST - 类 javax.management.remote.JMXConnectionNotification 中的静态变量
可能已丢失通知的连接的通知类型字符串。
notify() - 类 java.lang.Object 中的方法
唤醒在此对象监视器上等待的单个线程。
notifyAction - 类 javax.swing.JTextField 中的静态变量
发送通知（已接收字段内容）的动作名称。
notifyAction(Action, KeyStroke, KeyEvent, Object, int) - 类 javax.swing.SwingUtilities 中的静态方法
如果启用 action（且为非 null），则调用 action 上的 actionPerformed。
notifyAll() - 类 java.lang.Object 中的方法
唤醒在此对象监视器上等待的所有线程。
notifyClientWindowChange(Rectangle) - 接口 java.awt.im.spi.InputMethod 中的方法
通知此输入方法客户端窗口位置或状态的更改。
notifyCursorMoved() - 类 javax.sql.rowset.BaseRowSet 中的方法
通知向此 RowSet 对象注册的所有侦听器其光标已移动。
notifyObservers() - 类 java.util.Observable 中的方法
如果 hasChanged 方法指示对象已改变，则通知其所有观察者，并调用 clearChanged 方法来指示此对象不再改变。
notifyObservers(Object) - 类 java.util.Observable 中的方法
如果 hasChanged 方法指示对象已改变，则通知其所有观察者，并调用 clearChanged 方法来指示此对象不再改变。
notifyPathChange(Vector<PathPlaceHolder>, TreePath) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
通知侦听器路径中的更改。
notifyRowChanged() - 类 javax.sql.rowset.BaseRowSet 中的方法
通知向此 RowSet 对象注册的所有侦听器其行已更改。
notifyRowSetChanged() - 类 javax.sql.rowset.BaseRowSet 中的方法
通知向此 RowSet 对象注册的所有侦听器其整个内容已更改。
NotOwnerException - java.security.acl 中的 异常
当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。
NotOwnerException() - 异常 java.security.acl.NotOwnerException 的构造方法
构造一个 NotOwnerException。
notSelectedTextColor - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
notSelectedTitleColor - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
NotSerializableException - java.io 中的 异常
当实例需要具有序列化接口时，抛出此异常。
NotSerializableException(String) - 异常 java.io.NotSerializableException 的构造方法
构造带消息字符串的 NotSerializableException 对象。
NotSerializableException() - 异常 java.io.NotSerializableException 的构造方法
构造一个 NotSerializableException 对象。
NotYetBoundException - java.nio.channels 中的 异常
试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
NotYetBoundException() - 异常 java.nio.channels.NotYetBoundException 的构造方法
构造此类的一个实例。
NotYetConnectedException - java.nio.channels 中的 异常
试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
NotYetConnectedException() - 异常 java.nio.channels.NotYetConnectedException 的构造方法
构造此类的一个实例。
NoType - javax.lang.model.type 中的 接口
在实际类型不适合的地方使用的伪类型。
NOVEMBER - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第十一个月的 Calendar.MONTH 字段值。
NOVEMBER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第十一个月的值。
NOWRAP - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
npoints - 类 java.awt.Polygon 中的变量
点的总数。
NSDECL - 类 org.xml.sax.helpers.NamespaceSupport 中的静态变量
作为常量的名称空间声明 URI。
NT_ANONYMOUS - 接口 org.ietf.jgss.GSSName 中的静态变量
表示匿名实体的名称类型。
NT_EXPORT_NAME - 接口 org.ietf.jgss.GSSName 中的静态变量
用来表示通过导出方法产生的导出名称的名称类型。
NT_HOSTBASED_SERVICE - 接口 org.ietf.jgss.GSSName 中的静态变量
表示基于主机的服务名称格式的 Oid。
NT_MACHINE_UID_NAME - 接口 org.ietf.jgss.GSSName 中的静态变量
名称类型，表示与本地系统上的用户对应的数值型用户标识符。
NT_STRING_UID_NAME - 接口 org.ietf.jgss.GSSName 中的静态变量
名称类型，指示一个由数字组成的字符串，表示本地系统上用户的数值型用户标识符。
NT_USER_NAME - 接口 org.ietf.jgss.GSSName 中的静态变量
名称类型，表示在本地系统上指定的用户。
NULL - 类 java.sql.Types 中的静态变量
标识一般 SQL 值 NULL 的 Java 编程语言中的常量。
NULL_ATTRIBUTE_VALUE - 类 javax.swing.text.html.HTML 中的静态变量
NULL_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
用于表示不存在名称空间的名称空间 URI。
NullCipher - javax.crypto 中的 类
NullCipher 类是一个提供“标识密码”的类，其不转换纯文本。
NullCipher() - 类 javax.crypto.NullCipher 的构造方法
NULLORDER - 类 java.text.CollationElementIterator 中的静态变量
Null 顺序指示光标到达字符串末尾。
nullPlusNonNullIsNull() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 NULL 值与等于 NULL 的非 NULL 值之间的连接。
NullPointerException - java.lang 中的 异常
当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
NullPointerException() - 异常 java.lang.NullPointerException 的构造方法
构造不带详细消息的 NullPointerException。
NullPointerException(String) - 异常 java.lang.NullPointerException 的构造方法
构造带指定详细消息的 NullPointerException。
nullsAreSortedAtEnd() - 接口 java.sql.DatabaseMetaData 中的方法
获取 NULL 值是否始终排在末尾，不管排序顺序如何。
nullsAreSortedAtStart() - 接口 java.sql.DatabaseMetaData 中的方法
获取 NULL 值是否始终排在开头，不管排序顺序如何。
nullsAreSortedHigh() - 接口 java.sql.DatabaseMetaData 中的方法
获取 NULL 值是否被高排序。
nullsAreSortedLow() - 接口 java.sql.DatabaseMetaData 中的方法
获取 NULL 值是否被低排序。
NullType - javax.lang.model.type 中的 接口
表示 null 类型。
NUM_COLORS - 类 java.awt.SystemColor 中的静态变量
数组中系统颜色的数量。
NUM_LOCK - 类 java.awt.Event 中的静态变量
Num Lock 键，一个非 ASCII 操作键。
numBands - 类 java.awt.image.ComponentSampleModel 中的变量
此 ComponentSampleModel 中的 band 数量。
numBands - 类 java.awt.image.Raster 中的变量
Raster 中的 band 数。
numBands - 类 java.awt.image.SampleModel 中的变量
此 SampleModel 描述的图像数据的 band 数。
numBanks - 类 java.awt.image.ComponentSampleModel 中的变量
此 ComponentSampleModel 中的存储单元数量。
Number - java.lang 中的 类
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Number() - 类 java.lang.Number 的构造方法
NUMBER - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
NUMBER - 类 javax.xml.xpath.XPathConstants 中的静态变量
XPath 1.0 数字数据类型。
NUMBER_FORMS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Number Forms”Unicode 字符块的常量。
numberFilter(RowFilter.ComparisonType, Number, int...) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Number 值的条目。
numberFormat - 类 java.text.DateFormat 中的变量
数字格式器，DateFormat 用其来格式化日期和时间中的数字。
NumberFormat - java.text 中的 类
NumberFormat 是所有数值格式的抽象基类。
NumberFormat() - 类 java.text.NumberFormat 的构造方法
唯一的构造方法。
NumberFormat.Field - java.text 中的 类
定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。
NumberFormat.Field(String) - 类 java.text.NumberFormat.Field 的构造方法
创建具有指定名称的 Field 实例。
NumberFormatException - java.lang 中的 异常
当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
NumberFormatException() - 异常 java.lang.NumberFormatException 的构造方法
构造不带详细消息的 NumberFormatException。
NumberFormatException(String) - 异常 java.lang.NumberFormatException 的构造方法
构造带指定详细消息的 NumberFormatException。
NumberFormatProvider - java.text.spi 中的 类
提供 NumberFormat 类具体实现的服务提供者的抽象类。
NumberFormatProvider() - 类 java.text.spi.NumberFormatProvider 的构造方法
唯一的构造方法。
NumberFormatter - javax.swing.text 中的 类
添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。
NumberFormatter() - 类 javax.swing.text.NumberFormatter 的构造方法
创建具有默认 NumberFormat 实例的 NumberFormatter，该实例通过 NumberFormat.getNumberInstance() 获得。
NumberFormatter(NumberFormat) - 类 javax.swing.text.NumberFormatter 的构造方法
创建具有指定 Format 实例的 NumberFormatter。
NumberOfDocuments - javax.print.attribute.standard 中的 类
NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
NumberOfDocuments(int) - 类 javax.print.attribute.standard.NumberOfDocuments 的构造方法
构造具有给定整数值的新 NumberOfDocuments 属性。
NumberOfInterveningJobs - javax.print.attribute.standard 中的 类
NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
NumberOfInterveningJobs(int) - 类 javax.print.attribute.standard.NumberOfInterveningJobs 的构造方法
构造具有给定整数值的新的 NumberOfInterveningJobs 属性。
numberOfLeadingZeros(int) - 类 java.lang.Integer 中的静态方法
在指定 int 值的二进制补码表示形式中最高位（最左边）的 1 位之前，返回零位的数量。
numberOfLeadingZeros(long) - 类 java.lang.Long 中的静态方法
在指定 long 值的二进制补码表示形式中最高位（最左边）的 1 位之前，返回零位的数量。
numberOfTrailingZeros(int) - 类 java.lang.Integer 中的静态方法
返回指定的 int 值的二进制补码表示形式中最低（“最右边”）的为 1 的位后面的零位个数。
numberOfTrailingZeros(long) - 类 java.lang.Long 中的静态方法
返回在指定 long 值的二进制补码表示形式中最低位（最右边）的 1 位之后的零位的数量。
NUMBERS - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
NumberUp - javax.print.attribute.standard 中的 类
NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
NumberUp(int) - 类 javax.print.attribute.standard.NumberUp 的构造方法
构造具有给定整数值的新 NumberUp 属性。
NumberUpSupported - javax.print.attribute.standard 中的 类
NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。
NumberUpSupported(int[][]) - 类 javax.print.attribute.standard.NumberUpSupported 的构造方法
构造具有给定成员的新的 NumberUpSupported 属性。
NumberUpSupported(int) - 类 javax.print.attribute.standard.NumberUpSupported 的构造方法
构造一个包含单个整数的新的 NumberUpSupported 属性。
NumberUpSupported(int, int) - 类 javax.print.attribute.standard.NumberUpSupported 的构造方法
构造一个包含单个整数范围的新的 NumberUpSupported 属性。
numBuffers - 类 java.awt.Component.FlipBufferStrategy 中的变量
缓冲区的数目。
numDataElements - 类 java.awt.image.Raster 中的变量
每个像素的 DataBuffer 数据元素数。
NUMERIC - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 NUMERIC 的 Java 编程语言中的常量（有时称为类型代码）。
NUMERIC_SHAPING - 类 java.awt.font.TextAttribute 中的静态变量
将 ASCII 十进制数字转换为其他十进制范围数字的属性键。
NumericShaper - java.awt.font 中的 类
NumericShaper 类用于将 Latin-1（欧洲语）数字转换成其他 Unicode 十进制数字。
numProgressivePasses - 类 javax.imageio.ImageReadParam 中的变量
从源中读取的逐步传递的最大数量。
NUTOKEN - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
NUTOKENS - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
nval - 类 java.io.StreamTokenizer 中的变量
如果当前标记是一个数字，则此字段将包含该数字的值。
NVARCHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 NVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
NVList - org.omg.CORBA 中的 类
包含 NamedValue 对象所组成的可修改列表。
NVList() - 类 org.omg.CORBA.NVList 的构造方法
NW_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口左上角大小的光标类型。
NW_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.NW_RESIZE_CURSOR 取代。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


O - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

O

OAEPParameterSpec - javax.crypto.spec 中的 类
此类指定随同 OAEP 冗余使用的参数集合，OAEP 冗余在 PKCS #1 标准中定义。
OAEPParameterSpec(String, String, AlgorithmParameterSpec, PSource) - 类 javax.crypto.spec.OAEPParameterSpec 的构造方法
使用指定的信息摘要算法 mdName、掩码生成函数算法 mgfName、掩码生成函数参数 mgfSpec 以及编码输入 P 源 pSrc 来为 PKCS #1 标准中定义的 OAEP 冗余构造一个参数集合。
OBJ_ADAPTER - org.omg.CORBA 中的 异常
此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
OBJ_ADAPTER() - 异常 org.omg.CORBA.OBJ_ADAPTER 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(String) - 异常 org.omg.CORBA.OBJ_ADAPTER 的构造方法
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(int, CompletionStatus) - 异常 org.omg.CORBA.OBJ_ADAPTER 的构造方法
使用指定次要代码和完成状态构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(String, int, CompletionStatus) - 异常 org.omg.CORBA.OBJ_ADAPTER 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 OBJ_ADAPTER 异常。
Object - java.lang 中的 类
类 Object 是类层次结构的根类。
Object() - 类 java.lang.Object 的构造方法
OBJECT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
object - 类 javax.swing.undo.StateEdit 中的变量
被编辑的对象
Object - org.omg.CORBA 中的 接口
CORBA 对象引用的定义。
OBJECT_ADDED - 类 javax.naming.event.NamingEvent 中的静态变量
指示已经添加了新对象的命名事件类型。
OBJECT_CHANGED - 类 javax.naming.event.NamingEvent 中的静态变量
指示已经更改了某个对象的命名事件类型。
OBJECT_FACTORIES - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定要使用的对象工厂列表的环境属性名称。
object_id() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回描述该操作调用目标的不透明 object_id。
object_id(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
方法 _object_id() 等效于调用 PortableServer::Current::get_object_id。
OBJECT_NOT_EXIST - org.omg.CORBA 中的 异常
只要在已删除的对象上执行调用，就会引发此异常。
OBJECT_NOT_EXIST() - 异常 org.omg.CORBA.OBJECT_NOT_EXIST 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(String) - 异常 org.omg.CORBA.OBJECT_NOT_EXIST 的构造方法
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(int, CompletionStatus) - 异常 org.omg.CORBA.OBJECT_NOT_EXIST 的构造方法
使用指定次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(String, int, CompletionStatus) - 异常 org.omg.CORBA.OBJECT_NOT_EXIST 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_REMOVED - 类 javax.naming.event.NamingEvent 中的静态变量
指示已经移除了某个对象的命名事件类型。
OBJECT_RENAMED - 类 javax.naming.event.NamingEvent 中的静态变量
指示已经重命名了某个对象的命名事件类型。
OBJECT_SCOPE - 类 javax.naming.directory.SearchControls 中的静态变量
搜索命名的对象。
OBJECT_SCOPE - 接口 javax.naming.event.EventContext 中的静态变量
该常量用来表示对涉及目标指定对象的事件感兴趣。
object_to_string(Object) - 类 org.omg.CORBA.ORB 中的方法
将给定 CORBA 对象引用转换为字符串。
objectAdded(NamingEvent) - 接口 javax.naming.event.NamespaceChangeListener 中的方法
在已经添加了对象时调用此方法。
ObjectAlreadyActive - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
ObjectAlreadyActive() - 异常 org.omg.PortableServer.POAPackage.ObjectAlreadyActive 的构造方法
ObjectAlreadyActive(String) - 异常 org.omg.PortableServer.POAPackage.ObjectAlreadyActive 的构造方法
ObjectAlreadyActiveHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java。
ObjectAlreadyActiveHelper() - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 的构造方法
objectChanged(NamingEvent) - 接口 javax.naming.event.ObjectChangeListener 中的方法
在已经更改了对象时调用此方法。
ObjectChangeListener - javax.naming.event 中的 接口
指定事件类型为 OBJECT_CHANGED 的 NamingEvent 侦听器必须实现的方法。
ObjectFactory - javax.naming.spi 中的 接口
此类表示用于创建对象的工厂。
ObjectFactoryBuilder - javax.naming.spi 中的 接口
此接口表示创建对象工厂的生成器。
ObjectHelper - org.omg.CORBA 中的 类
ObjectHelper() - 类 org.omg.CORBA.ObjectHelper 的构造方法
ObjectHolder - org.omg.CORBA 中的 类
Object 的 Holder。
ObjectHolder() - 类 org.omg.CORBA.ObjectHolder 的构造方法
构造一个新的 ObjectHolder 对象，将其 value 字段初始化为 null。
ObjectHolder(Object) - 类 org.omg.CORBA.ObjectHolder 的构造方法
构造一个新的 ObjectHolder 对象，并使用给定 Object 初始化其 value 字段。
ObjectIdHelper - org.omg.PortableInterceptor 中的 类
对象 id 类型。
ObjectIdHelper() - 类 org.omg.PortableInterceptor.ObjectIdHelper 的构造方法
ObjectIdHelper - org.omg.PortableInterceptor.ORBInitInfoPackage 中的 类
表示为一个 String 的 Object id
ObjectIdHelper() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 的构造方法
ObjectImpl - org.omg.CORBA.portable 中的 类
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。
ObjectImpl() - 类 org.omg.CORBA.portable.ObjectImpl 的构造方法
ObjectImpl - org.omg.CORBA_2_3.portable 中的 类
ObjectImpl 类是所有 stub 的基类。
ObjectImpl() - 类 org.omg.CORBA_2_3.portable.ObjectImpl 的构造方法
ObjectInput - java.io 中的 接口
ObjectInput 扩展 DataInput 接口以包含对象的读操作。
ObjectInputStream - java.io 中的 类
ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
ObjectInputStream(InputStream) - 类 java.io.ObjectInputStream 的构造方法
创建从指定 InputStream 读取的 ObjectInputStream。
ObjectInputStream() - 类 java.io.ObjectInputStream 的构造方法
为完全重新实现 ObjectInputStream 的子类提供一种方式，让它不必分配仅由 ObjectInputStream 的实现使用的私有数据。
ObjectInputStream.GetField - java.io 中的 类
提供对从输入流读取的持久字段的访问权限。
ObjectInputStream.GetField() - 类 java.io.ObjectInputStream.GetField 的构造方法
ObjectInputValidation - java.io 中的 接口
允许验证图形中对象的回调接口。
ObjectInstance - javax.management 中的 类
用于表示 MBean 对象名及其类名。
ObjectInstance(String, String) - 类 javax.management.ObjectInstance 的构造方法
允许创建具有给定字符串表示形式的对象名和完整类名（包括包名）的ｏbjectInstance。
ObjectInstance(ObjectName, String) - 类 javax.management.ObjectInstance 的构造方法
允许创建具有给定对象名和完整类名（包括包名）的 ObjectInstance。
ObjectName - javax.management 中的 类
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。
ObjectName(String) - 类 javax.management.ObjectName 的构造方法
根据给定的字符串构造一个对象名。
ObjectName(String, String, String) - 类 javax.management.ObjectName 的构造方法
构造只具有一个键属性的对象名。
ObjectName(String, Hashtable<String, String>) - 类 javax.management.ObjectName 的构造方法
构造一个对象名，它具有根据哈希表获得的多个键属性。
OBJECTNAME - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 javax.management.ObjectName 的值。
ObjectNotActive - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/ObjectNotActive.java。
ObjectNotActive() - 异常 org.omg.PortableServer.POAPackage.ObjectNotActive 的构造方法
ObjectNotActive(String) - 异常 org.omg.PortableServer.POAPackage.ObjectNotActive 的构造方法
ObjectNotActiveHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java。
ObjectNotActiveHelper() - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 的构造方法
ObjectOutput - java.io 中的 接口
ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。
ObjectOutputStream - java.io 中的 类
ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
ObjectOutputStream(OutputStream) - 类 java.io.ObjectOutputStream 的构造方法
创建写入指定 OutputStream 的 ObjectOutputStream。
ObjectOutputStream() - 类 java.io.ObjectOutputStream 的构造方法
为完全重新实现 ObjectOutputStream 的子类提供一种方法，让它不必分配仅由 ObjectOutputStream 的实现使用的私有数据。
ObjectOutputStream.PutField - java.io 中的 类
提供对要写入 ObjectOutput 的持久字段的编程访问。
ObjectOutputStream.PutField() - 类 java.io.ObjectOutputStream.PutField 的构造方法
ObjectReferenceFactory - org.omg.PortableInterceptor 中的 接口
对象引用工厂。
ObjectReferenceFactoryHelper - org.omg.PortableInterceptor 中的 类
对象引用工厂。
ObjectReferenceFactoryHelper() - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 的构造方法
ObjectReferenceFactoryHolder - org.omg.PortableInterceptor 中的 类
对象引用工厂。
ObjectReferenceFactoryHolder() - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 的构造方法
ObjectReferenceFactoryHolder(ObjectReferenceFactory) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 的构造方法
ObjectReferenceTemplate - org.omg.PortableInterceptor 中的 接口
对象引用模板。
ObjectReferenceTemplateHelper - org.omg.PortableInterceptor 中的 类
对象引用模板。
ObjectReferenceTemplateHelper() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 的构造方法
ObjectReferenceTemplateHolder - org.omg.PortableInterceptor 中的 类
对象引用模板。
ObjectReferenceTemplateHolder() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 的构造方法
ObjectReferenceTemplateHolder(ObjectReferenceTemplate) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 的构造方法
ObjectReferenceTemplateSeqHelper - org.omg.PortableInterceptor 中的 类
对象引用模板序列用来报告不发生在适配器管理器的状态更改。
ObjectReferenceTemplateSeqHelper() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 的构造方法
ObjectReferenceTemplateSeqHolder - org.omg.PortableInterceptor 中的 类
对象引用模板序列用来报告不发生在适配器管理器的状态更改。
ObjectReferenceTemplateSeqHolder() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 的构造方法
ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[]) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 的构造方法
objectRemoved(NamingEvent) - 接口 javax.naming.event.NamespaceChangeListener 中的方法
在已经移除了对象时调用此方法。
objectRenamed(NamingEvent) - 接口 javax.naming.event.NamespaceChangeListener 中的方法
在已经重命名了对象时调用此方法。
ObjectStreamClass - java.io 中的 类
类的序列化描述符。
ObjectStreamConstants - java.io 中的 接口
写入 Object Serialization Stream 的常量。
ObjectStreamException - java.io 中的 异常
特定于 Object Stream 类的所有异常的超类。
ObjectStreamException(String) - 异常 java.io.ObjectStreamException 的构造方法
创建具有指定参数的 ObjectStreamException。
ObjectStreamException() - 异常 java.io.ObjectStreamException 的构造方法
创建一个 ObjectStreamException。
ObjectStreamField - java.io 中的 类
Serializable 类中 Serializable 字段的描述。
ObjectStreamField(String, Class<?>) - 类 java.io.ObjectStreamField 的构造方法
创建具有指定类型的 Serializable 字段。
ObjectStreamField(String, Class<?>, boolean) - 类 java.io.ObjectStreamField 的构造方法
创建一个 ObjectStreamField，表示给定名称和类型的可序列化字段。
ObjectView - javax.swing.text.html 中的 类
实现 <object> 元素视图接口的组件装饰符。
ObjectView(Element) - 类 javax.swing.text.html.ObjectView 的构造方法
创建新的 ObjectView 对象。
ObjID - java.rmi.server 中的 类
ObjID 是用于标识导出到 RMI 运行时的远程对象。
ObjID() - 类 java.rmi.server.ObjID 的构造方法
生成唯一的对象标识符。
ObjID(int) - 类 java.rmi.server.ObjID 的构造方法
创建“已知的”对象标识符。
Observable - java.util 中的 类
此类表示模型视图范例中的 observable 对象，或者说“数据”。
Observable() - 类 java.util.Observable 的构造方法
构造一个带有零个观察者的 Observable。
OBSERVED_ATTRIBUTE_ERROR - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性未包含在被观察对象中的通知类型。
OBSERVED_ATTRIBUTE_ERROR_NOTIFIED - 类 javax.management.monitor.Monitor 中的静态变量
表示已在更改被观察属性之后发出了通知的标志。
OBSERVED_ATTRIBUTE_TYPE_ERROR - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性的类型不正确的通知类型。
OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED - 类 javax.management.monitor.Monitor 中的静态变量
表示已在更改被观察对象或被观察属性之后发出了通知的标志。
OBSERVED_OBJECT_ERROR - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察对象未在 MBean 服务器中注册的通知类型。
OBSERVED_OBJECT_ERROR_NOTIFIED - 类 javax.management.monitor.Monitor 中的静态变量
表示在更改被观察对象之后已发出通知的标志。
Observer - java.util 中的 接口
一个可在观察者要得到 observable 对象更改通知时可实现 Observer 接口的类。
OceanTheme - javax.swing.plaf.metal 中的 类
MetalLookAndFeel 的默认主题。
OceanTheme() - 类 javax.swing.plaf.metal.OceanTheme 的构造方法
创建一个 OceanTheme 实例
OctetSeqHelper - org.omg.CORBA 中的 类
OctetSeq 的 Helper。
OctetSeqHelper() - 类 org.omg.CORBA.OctetSeqHelper 的构造方法
OctetSeqHolder - org.omg.CORBA 中的 类
OctetSeq 的 Holder。
OctetSeqHolder() - 类 org.omg.CORBA.OctetSeqHolder 的构造方法
OctetSeqHolder(byte[]) - 类 org.omg.CORBA.OctetSeqHolder 的构造方法
OctetStreamData - javax.xml.crypto 中的 类
包含一个八位组流的 Data 类型的表示形式。
OctetStreamData(InputStream) - 类 javax.xml.crypto.OctetStreamData 的构造方法
创建新的 SocketImpl。
OctetStreamData(InputStream, String, String) - 类 javax.xml.crypto.OctetStreamData 的构造方法
创建新的 OctetStreamData。
OCTOBER - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第十个月的 Calendar.MONTH 字段值。
OCTOBER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第十个月的值。
oEnd - 类 javax.swing.text.html.parser.Element 中的变量
of(char) - 类 java.lang.Character.UnicodeBlock 中的静态方法
返回表示包含给定字符的 Unicode 块的对象；如果该字符不是某个定义块的成员，则返回 null。
of(int) - 类 java.lang.Character.UnicodeBlock 中的静态方法
返回表示包含给定字符（Unicode 代码点）的 Unicode 块的对象；如果该字符不是定义块的成员，则返回 null。
of(E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(E, E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(E, E, E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(E, E, E, E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(E, E, E, E, E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(E, E...) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(String, String) - 类 javax.annotation.processing.Completions 中的静态方法
返回值和消息的 completion。
of(String) - 类 javax.annotation.processing.Completions 中的静态方法
返回值和空消息的 completion。
ofCalendarField(int) - 类 java.text.DateFormat.Field 中的静态方法
返回与此 Calendar 常量 calendarField 对应的 Field 常量。
OFF - 类 java.util.logging.Level 中的静态变量
OFF 是一个可用于关闭日志记录的特殊级别。
offendingNode - 异常 javax.imageio.metadata.IIOInvalidTreeException 中的变量
导致解析错误的 Node，或 null。
offer(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的末尾。
offer(E) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
将指定的元素插入到此队列的尾部（如果立即可行且不会超过该队列的容量），在成功时返回 true，如果此队列已满，则返回 false。
offer(E, long, TimeUnit) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
将指定的元素插入此队列的尾部，如果该队列已满，则在到达指定的等待时间之前等待可用的空间。
offer(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），并在成功时返回 true；如果当前没有空间可用，则返回 false。
offer(E, long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将在指定的等待时间内一直等待可用空间。
offer(E) - 接口 java.util.concurrent.BlockingQueue 中的方法
将指定元素插入此队列中（如果立即可行且不会违反容量限制），成功时返回 true，如果当前没有可用的空间，则返回 false。
offer(E, long, TimeUnit) - 接口 java.util.concurrent.BlockingQueue 中的方法
将指定元素插入此队列中，在到达指定的等待时间前等待可用的空间（如果有必要）。
offer(E) - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
将指定元素插入此队列的尾部。
offer(E) - 类 java.util.concurrent.DelayQueue 中的方法
将指定元素插入此延迟队列。
offer(E, long, TimeUnit) - 类 java.util.concurrent.DelayQueue 中的方法
将指定元素插入此延迟队列中。
offer(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offer(E, long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offer(E, long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
将指定元素插入到此队列的尾部，如有必要，则等待指定的时间以使空间变得可用。
offer(E) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
将指定元素插入到此队列的尾部（如果立即可行且不会超出此队列的容量），在成功时返回 true，如果此队列已满，则返回 false。
offer(E) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
将指定元素插入此优先级队列。
offer(E, long, TimeUnit) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
将指定元素插入此优先级队列。
offer(E, long, TimeUnit) - 类 java.util.concurrent.SynchronousQueue 中的方法
将指定元素插入到此队列，如有必要则等待指定的时间，以便另一个线程接收它。
offer(E) - 类 java.util.concurrent.SynchronousQueue 中的方法
如果另一个线程正在等待以便接收指定元素，则将指定元素插入到此队列。
offer(E) - 接口 java.util.Deque 中的方法
将指定元素插入此双端队列所表示的队列（换句话说，此双端队列的尾部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用的空间，则返回 false。
offer(E) - 类 java.util.LinkedList 中的方法
将指定元素添加到此列表的末尾（最后一个元素）。
offer(E) - 类 java.util.PriorityQueue 中的方法
将指定的元素插入此优先级队列。
offer(E) - 接口 java.util.Queue 中的方法
将指定的元素插入此队列（如果立即可行且不会违反容量限制），当使用有容量限制的队列时，此方法通常要优于 Queue.add(E)，后者可能无法插入元素，而只是抛出一个异常。
offerFirst(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的开头。
offerFirst(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头，并在成功时返回 true；如果当前没有空间可用，则返回 false。
offerFirst(E, long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列的开头，必要时将在指定的等待时间内等待可用空间。
offerFirst(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offerFirst(E, long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offerFirst(E) - 接口 java.util.Deque 中的方法
在不违反容量限制的情况下，将指定的元素插入此双端队列的开头。
offerFirst(E) - 类 java.util.LinkedList 中的方法
在此列表的开头插入指定的元素。
offerLast(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的末尾。
offerLast(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾，并在成功时返回 true；如果当前没有空间可用，则返回 false。
offerLast(E, long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列的末尾，必要时将在指定的等待时间内等待可用空间。
offerLast(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offerLast(E, long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offerLast(E) - 接口 java.util.Deque 中的方法
在不违反容量限制的情况下，将指定的元素插入此双端队列的末尾。
offerLast(E) - 类 java.util.LinkedList 中的方法
在此列表末尾插入指定的元素。
offset - 类 java.awt.image.DataBuffer 中的变量
默认（第一个）存储单元的偏移量，从中可获得第一个元素。
offset - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的变量
offset - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的变量
offset - 类 javax.swing.text.Segment 中的变量
这是所需文件开始处的数组偏移量。
offset - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
在编辑中使用。
offset - 异常 org.omg.CORBA.portable.IndirectionException 中的变量
指向流偏移量。
offsetByCodePoints(CharSequence, int, int) - 类 java.lang.Character 中的静态方法
返回给定字符序列中的索引，它是从给定 index 到 codePointOffset 代码点的偏移量。
offsetByCodePoints(char[], int, int, int, int) - 类 java.lang.Character 中的静态方法
返回给定 char 子数组中的索引，它是从给定 index 到 codePointOffset 代码点的偏移量。
offsetByCodePoints(int, int) - 类 java.lang.String 中的方法
返回此 String 中从给定的 index 处偏移 codePointOffset 个代码点的索引。
offsetByCodePoints(int, int) - 类 java.lang.StringBuffer 中的方法
offsetRequested() - 异常 javax.swing.text.BadLocationException 中的方法
返回文档中的非法偏移量。
offsets - 类 java.awt.image.DataBuffer 中的变量
所有存储单元的偏移量。
OGHAM - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Ogham”Unicode 字符块的常量。
OID - 类 javax.naming.ldap.ManageReferralControl 中的静态变量
ManageReferral 控件的分配对象标识符为 2.16.840.1.113730.3.4.2。
OID - 类 javax.naming.ldap.PagedResultsControl 中的静态变量
分页结果控件的分配对象标识符为 1.2.840.113556.1.4.319。
OID - 类 javax.naming.ldap.PagedResultsResponseControl 中的静态变量
分页结果响应控件的分配对象标识符为 1.2.840.113556.1.4.319。
OID - 类 javax.naming.ldap.SortControl 中的静态变量
服务器端排序控件的分配对象标识符为 1.2.840.113556.1.4.473。
OID - 类 javax.naming.ldap.SortResponseControl 中的静态变量
服务器端排序响应控件的分配对象标识符为 1.2.840.113556.1.4.474。
OID - 类 javax.naming.ldap.StartTlsRequest 中的静态变量
StartTLS 扩展请求的分配对象标识符为 1.3.6.1.4.1.1466.20037。
OID - 类 javax.naming.ldap.StartTlsResponse 中的静态变量
StartTLS 扩展响应的分配对象标识符为 1.3.6.1.4.1.1466.20037。
Oid - org.ietf.jgss 中的 类
此类表示 Universal Object Identifiers（通用对象标识符，即 Oid）及其相关的操作。
Oid(String) - 类 org.ietf.jgss.Oid 的构造方法
从其整数组件的字符串表示形式中构建 Oid 对象。
Oid(InputStream) - 类 org.ietf.jgss.Oid 的构造方法
从其 ASN.1 DER 编码中创建 Oid 对象。
Oid(byte[]) - 类 org.ietf.jgss.Oid 的构造方法
从其 ASN.1 DER 编码中创建 Oid 对象。
OK - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
OK 选项。
OK_CANCEL_OPTION - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
OK/CANCEL 确认选项。
OK_CANCEL_OPTION - 类 javax.swing.JOptionPane 中的静态变量
用于 showConfirmDialog 的类型。
OK_OPTION - 类 javax.swing.JOptionPane 中的静态变量
选择 OK 时从类方法返回的值。
okToUseGui - 类 java.beans.beancontext.BeanContextSupport 中的变量
指示此实例现在能否呈现 GUI 的 boolean 值。
okToUseGui() - 类 java.beans.beancontext.BeanContextSupport 中的方法
通知此实例它现在可以呈现一个 GUI。
okToUseGui() - 接口 java.beans.Visibility 中的方法
此方法指示可以使用 Gui 的 bean。
OL - 类 javax.swing.text.html.HTML.Tag 中的静态变量
OLD_ITALIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Old Italic”Unicode 字符块的常量。
OLD_TOKEN - 异常 org.ietf.jgss.GSSException 中的静态变量
该标记已无效。
oldBinding - 类 javax.naming.event.NamingEvent 中的变量
包含关于更改前对象的信息。
oldBorderPainted - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
oldLeadSelectionPath - 类 javax.swing.event.TreeSelectionEvent 中的变量
在路径被更改之前的 leadSelectionPath，可能为 null。
OMGVMCID - org.omg.CORBA 中的 接口
为 OMG 保留的供应商次要代码 (minor code) ID。
OMIT_XML_DECLARATION - 类 javax.xml.transform.OutputKeys 中的静态变量
omit-xml-declaration = "yes" | "no". omit-xml-declaration 指定了 XSLT 处理器是否应输出 XML 声明，其值必须为 yes 或 no。
omitEnd() - 类 javax.swing.text.html.parser.Element 中的方法
如果可以忽略结束标记，则返回 true。
omitStart() - 类 javax.swing.text.html.parser.Element 中的方法
如果可以忽略开始标记，则返回 true。
on(boolean) - 类 java.security.DigestInputStream 中的方法
开启或关闭摘要功能。
on(boolean) - 类 java.security.DigestOutputStream 中的方法
开启或关闭摘要功能。
onDeregistration(ServiceRegistry, Class<?>) - 类 javax.imageio.spi.IIOServiceProvider 中的方法
Spi 类一从 ServiceRegistry 中注销即执行的回调。
onDeregistration(ServiceRegistry, Class<?>) - 接口 javax.imageio.spi.RegisterableService 中的方法
将一个实现此接口的对象从给定的 registry 的给定 category 移除时调用此方法。
ONE - 类 java.math.BigDecimal 中的静态变量
值为 1，标度为 0。
ONE - 类 java.math.BigInteger 中的静态变量
BigInteger 的常量 1。
ONE_DAY - 类 javax.management.timer.Timer 中的静态变量
一天内的毫秒数。
ONE_HOUR - 类 javax.management.timer.Timer 中的静态变量
一小时内的毫秒数。
ONE_MINUTE - 类 javax.management.timer.Timer 中的静态变量
一分钟内的毫秒数。
ONE_SECOND - 类 javax.management.timer.Timer 中的静态变量
一秒钟内的毫秒数。
ONE_SIDED - 类 java.awt.JobAttributes.SidesType 中的静态变量
SidesType 实例用于指定应该在连续介质纸张的同一面打印连续作业页面。
ONE_SIDED - 类 javax.print.attribute.standard.Sides 中的静态变量
将每个连续的打印流页应用于连续介质纸张的相同面。
ONE_TOUCH_EXPANDABLE_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 oneTouchExpandable 属性。
ONE_TOUCH_OFFSET - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的静态变量
ONE_TOUCH_SIZE - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的静态变量
基于 BasicSplitPaneUI 添加到它的两个方向的分隔符宽度和高度。
ONE_WEEK - 类 javax.management.timer.Timer 中的静态变量
一周内的毫秒数。
ONELEVEL_SCOPE - 类 javax.naming.directory.SearchControls 中的静态变量
搜索一级命名对象。
ONELEVEL_SCOPE - 接口 javax.naming.event.EventContext 中的静态变量
该常量用来表示对涉及目标指定上下文中对象的事件感兴趣，不包括目标指定的上下文。
oneTouchExpandable - 类 javax.swing.JSplitPane 中的变量
是否要提供一个小部件来快速展开/折叠分隔窗格。
oneTouchExpandableChanged() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
当包含接收者的 JSplitPane 的 oneTouchExpandable 值发生更改时传递消息。
Oneway - javax.jws 中的 注释类型
指示给定 @WebMethod 只有一条输入消息并且没有输出。
onMalformedInput(CodingErrorAction) - 类 java.nio.charset.CharsetDecoder 中的方法
更改此解码器对错误输入错误的操作。
onMalformedInput(CodingErrorAction) - 类 java.nio.charset.CharsetEncoder 中的方法
更改此编码器对错误输入错误的操作。
onRegistration(ServiceRegistry, Class<?>) - 类 javax.imageio.spi.IIOServiceProvider 中的方法
在 ServiceRegistry 中实例化和注册 Spi 类后即执行的回调。
onRegistration(ServiceRegistry, Class<?>) - 接口 javax.imageio.spi.RegisterableService 中的方法
将一个实现此接口的对象添加到给定 registry 的给定 category 时调用此方法。
onUnmappableCharacter(CodingErrorAction) - 类 java.nio.charset.CharsetDecoder 中的方法
更改此解码器对不可映射的字符错误的操作。
onUnmappableCharacter(CodingErrorAction) - 类 java.nio.charset.CharsetEncoder 中的方法
更改此编码器对不可映射的字符错误的操作。
OP_ACCEPT - 类 java.nio.channels.SelectionKey 中的静态变量
用于套接字接受操作的操作集位。
OP_CONNECT - 类 java.nio.channels.SelectionKey 中的静态变量
用于套接字连接操作的操作集位。
op_name() - 类 org.omg.CORBA.ServerRequest 中的方法
已过时。 使用 operation()
OP_READ - 类 java.nio.channels.SelectionKey 中的静态变量
用于读取操作的操作集位。
OP_WRITE - 类 java.nio.channels.SelectionKey 中的静态变量
用于写入操作的操作集位。
OPAQUE - 接口 java.awt.Transparency 中的静态变量
表示保证完全不透明的图像数据，意味着所有像素 alpha 值都为 1.0。
OPAQUE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象在其矩形区域内绘制每个像素。
OPC_LIFE_OVER - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
光敏导电体已不再运行。
OPC_NEAR_EOL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
光敏导电体寿命将到期。
open(File) - 类 java.awt.Desktop 中的方法
启动关联应用程序来打开文件。
OPEN - 类 java.awt.geom.Arc2D 中的静态变量
闭合类型，用于不具有用来连接弧段两个端点的路径段的开弧。
open() - 类 java.nio.channels.DatagramChannel 中的静态方法
打开数据报通道。
open() - 类 java.nio.channels.Pipe 中的静态方法
打开一个管道。
open() - 类 java.nio.channels.Selector 中的静态方法
打开一个选择器。
open() - 类 java.nio.channels.ServerSocketChannel 中的静态方法
打开服务器套接字通道。
open() - 类 java.nio.channels.SocketChannel 中的静态方法
打开套接字通道。
open(SocketAddress) - 类 java.nio.channels.SocketChannel 中的静态方法
打开套接字通道并将其连接到远程地址。
open() - 接口 javax.sound.midi.MidiDevice 中的方法
打开设备，指示它现在应获取任何所需的系统资源然后开始运行。
open(AudioFormat, byte[], int, int) - 接口 javax.sound.sampled.Clip 中的方法
打开剪辑，意味着它应该获得所有所需的系统资源并变得可操作。
open(AudioInputStream) - 接口 javax.sound.sampled.Clip 中的方法
使用出现在所提供的音频输入流中的格式和音频数据打开剪辑。
open() - 接口 javax.sound.sampled.Line 中的方法
打开行，指示它应该获得所有所需系统资源并变得可操作。
OPEN - 类 javax.sound.sampled.LineEvent.Type 中的静态变量
行打开（为行本身保留系统资源）时发送的事件类型。
open(AudioFormat, int) - 接口 javax.sound.sampled.SourceDataLine 中的方法
打开具有指定格式和建议缓冲区大小的行，这样可使该行获得所有所需系统资源并变得可操作。
open(AudioFormat) - 接口 javax.sound.sampled.SourceDataLine 中的方法
打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
open(AudioFormat, int) - 接口 javax.sound.sampled.TargetDataLine 中的方法
打开具有指定格式和请求缓冲区大小的行，这样可使行获得所有所需的系统资源并变得可操作。
open(AudioFormat) - 接口 javax.sound.sampled.TargetDataLine 中的方法
打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
OPEN_DELETE - 类 java.util.zip.ZipFile 中的静态变量
打开 ZIP 文件并将其标记为删除的模式标志。
OPEN_DIALOG - 类 javax.swing.JFileChooser 中的静态变量
指示 JFileChooser 支持 "Open" 文件操作的类型值。
OPEN_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
OPEN_FAILURE 用于对输出流的打开失败时。
OPEN_READ - 类 java.util.zip.ZipFile 中的静态变量
打开 ZIP 文件进行阅读的模式标志。
OPEN_TYPE_FIELD - 类 javax.management.JMX 中的静态变量
openType 字段的名称。
openButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
openButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
openButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
openConnection() - 类 java.net.URL 中的方法
返回一个 URLConnection 对象，它表示到 URL 所引用的远程对象的连接。
openConnection(Proxy) - 类 java.net.URL 中的方法
与 openConnection() 类似，所不同是连接通过指定的代理建立；不支持代理方式的协议处理程序将忽略该代理参数并建立正常的连接。
openConnection(URL) - 类 java.net.URLStreamHandler 中的方法
打开一个到 URL 参数引用的对象的连接。
openConnection(URL, Proxy) - 类 java.net.URLStreamHandler 中的方法
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。
OpenDataException - javax.management.openmbean 中的 异常
因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。
OpenDataException() - 异常 javax.management.openmbean.OpenDataException 的构造方法
不带详细消息的 OpenDataException。
OpenDataException(String) - 异常 javax.management.openmbean.OpenDataException 的构造方法
带详细消息的 OpenDataException。
openDatagramChannel() - 类 java.nio.channels.spi.SelectorProvider 中的方法
打开数据报通道。
OPENED - 类 javax.management.remote.JMXConnectionNotification 中的静态变量
打开连接通知的通知类型字符串。
openFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
通常不调用此方法。
openFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
如有可能，在适当的位置显示此窗体。
openIcon - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
用于显示扩展的非叶节点的图标。
openInputStream() - 接口 javax.tools.FileObject 中的方法
获取此文件对象的 InputStream。
openInputStream() - 类 javax.tools.ForwardingFileObject 中的方法
openInputStream() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现总是抛出 UnsupportedOperationException。
OpenMBeanAttributeInfo - javax.management.openmbean 中的 接口
描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport - javax.management.openmbean 中的 类
描述 open MBean 的一个属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<?>, boolean, boolean, boolean) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的构造方法
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、<openType 和 description 以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<?>, boolean, boolean, boolean, Descriptor) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的构造方法
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、读/写访问属性和 Descriptor 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的构造方法
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue，以及制定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T, T[]) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的构造方法
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T, Comparable<T>, Comparable<T>) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的构造方法
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanConstructorInfo - javax.management.openmbean 中的 接口
描述 Open MBean 的构造方法。
OpenMBeanConstructorInfoSupport - javax.management.openmbean 中的 类
描述 Open MBean 的构造方法。
OpenMBeanConstructorInfoSupport(String, String, OpenMBeanParameterInfo[]) - 类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 的构造方法
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description 和 signature 描述 open MBeans 的类的构造方法。
OpenMBeanConstructorInfoSupport(String, String, OpenMBeanParameterInfo[], Descriptor) - 类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 的构造方法
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description、signature 和 descriptor 来描述 open MBean 类的构造方法。
OpenMBeanInfo - javax.management.openmbean 中的 接口
描述一个 Open MBean：Open MBean 的识别方式为，如果 Open MBean 的 getMBeanInfo() 方法返回实现 OpenMBeanInfo 接口（通常为 OpenMBeanInfoSupport）的类的实例，则可识别 Open MBean。
OpenMBeanInfoSupport - javax.management.openmbean 中的 类
OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。
OpenMBeanInfoSupport(String, String, OpenMBeanAttributeInfo[], OpenMBeanConstructorInfo[], OpenMBeanOperationInfo[], MBeanNotificationInfo[]) - 类 javax.management.openmbean.OpenMBeanInfoSupport 的构造方法
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String, String, OpenMBeanAttributeInfo[], OpenMBeanConstructorInfo[], OpenMBeanOperationInfo[], MBeanNotificationInfo[], Descriptor) - 类 javax.management.openmbean.OpenMBeanInfoSupport 的构造方法
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类
OpenMBeanOperationInfo - javax.management.openmbean 中的 接口
描述 Open MBean 的操作。
OpenMBeanOperationInfoSupport - javax.management.openmbean 中的 类
描述 Open MBean 的一个操作。
OpenMBeanOperationInfoSupport(String, String, OpenMBeanParameterInfo[], OpenType<?>, int) - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 的构造方法
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType 和 impact 描述 open MBeans 的类的操作。
OpenMBeanOperationInfoSupport(String, String, OpenMBeanParameterInfo[], OpenType<?>, int, Descriptor) - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 的构造方法
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。
OpenMBeanParameterInfo - javax.management.openmbean 中的 接口
描述用于 open MBean 的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport - javax.management.openmbean 中的 类
描述用于 open MBean 的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<?>) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的构造方法
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType 和 description 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<?>, Descriptor) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的构造方法
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 descriptor 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的构造方法
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 defaultValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T, T[]) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的构造方法
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T, Comparable<T>, Comparable<T>) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的构造方法
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
openMenuKey - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
openOutputStream() - 接口 javax.tools.FileObject 中的方法
获取此文件对象的 OutputStream。
openOutputStream() - 类 javax.tools.ForwardingFileObject 中的方法
openOutputStream() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现总是抛出 UnsupportedOperationException。
openPipe() - 类 java.nio.channels.spi.SelectorProvider 中的方法
打开一个管道。
openReader(boolean) - 接口 javax.tools.FileObject 中的方法
获取此对象的 reader。
openReader(boolean) - 类 javax.tools.ForwardingFileObject 中的方法
openReader(boolean) - 类 javax.tools.SimpleJavaFileObject 中的方法
在 Reader 中包装 SimpleJavaFileObject.getCharContent(boolean) 的结果。
openSelector() - 类 java.nio.channels.spi.SelectorProvider 中的方法
打开一个选择器。
openServerSocketChannel() - 类 java.nio.channels.spi.SelectorProvider 中的方法
打开服务器套接字通道。
openSocketChannel() - 类 java.nio.channels.spi.SelectorProvider 中的方法
打开套接字通道。
openStream() - 类 java.net.URL 中的方法
打开到此 URL 的连接并返回一个用于从该连接读入的 InputStream。
OpenType - java.awt.font 中的 接口
OpenType 接口表示 OpenType 和 TrueType 字体。
OpenType<T> - javax.management.openmbean 中的 类
OpenType 类是所有类的父抽象类，它描述开放数据值的实际开放类型。
OpenType(String, String, String) - 类 javax.management.openmbean.OpenType 的构造方法
构造一个 OpenType 实例（实际上是一个子类实例，因为 OpenType 是抽象的），检查给定参数的有效性。
openWriter() - 接口 javax.tools.FileObject 中的方法
获取此文件对象的 Writer。
openWriter() - 类 javax.tools.ForwardingFileObject 中的方法
openWriter() - 类 javax.tools.SimpleJavaFileObject 中的方法
在 Writer 中包装 openOutputStream 的结果。
OPERATING_SYSTEM_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
OperatingSystemMXBean 的 ObjectName 的字符串表示形式。
OperatingSystemMXBean - java.lang.management 中的 接口
用于操作系统的管理接口，Java 虚拟机在此操作系统上运行。
Operation - java.rmi.server 中的 类
已过时。 无替代版本
Operation(String) - 类 java.rmi.server.Operation 的构造方法
已过时。 无替代版本
operation() - 类 org.omg.CORBA.Request 中的方法
检索将被调用的方法的名称。
operation() - 类 org.omg.CORBA.ServerRequest 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
operation() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回将被调用的操作的名称。
operation_context() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回一个 String 对象数组，这些对象包含将在请求上发送上下文。
OperationNotSupportedException - javax.naming 中的 异常
当上下文实现不支持将调用的操作时，抛出此异常。
OperationNotSupportedException() - 异常 javax.naming.OperationNotSupportedException 的构造方法
构造一个新的 OperationNotSupportedException 实例。
OperationNotSupportedException(String) - 异常 javax.naming.OperationNotSupportedException 的构造方法
使用解释构造一个新的 OperationNotSupportedException 实例。
OperationsException - javax.management 中的 异常
表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
OperationsException() - 异常 javax.management.OperationsException 的构造方法
默认的构造方法。
OperationsException(String) - 异常 javax.management.OperationsException 的构造方法
允许指定具体错误消息的构造方法。
OPTICAL_CHARACTER_RECOGNITION - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Optical Character Recognition”Unicode 字符块的常量。
OPTION - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Option - javax.swing.text.html 中的 类
用来表示 <option> 元素的 ListModel 值。
Option(AttributeSet) - 类 javax.swing.text.html.Option 的构造方法
创建新的 Option 对象。
OPTION_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
主要用于 DIALOG 内部的专用窗格
OPTION_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
OptionPane 的 region。
OPTION_TYPE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
optionType 的绑定属性名。
OPTIONAL - 类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 中的静态变量
可供选择的 LoginModule。
OptionalDataException - java.io 中的 异常
指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
OptionChecker - javax.tools 中的 接口
识别选项的接口。
optionPane - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
接收者为其提供外观的 JOptionPane。
OptionPaneUI - javax.swing.plaf 中的 类
JOptionPane 的可插入外观界面。
OptionPaneUI() - 类 javax.swing.plaf.OptionPaneUI 的构造方法
options - 类 javax.swing.JOptionPane 中的变量
要向用户显示的选项。
OPTIONS_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
option 的绑定属性名。
optionType - 类 javax.swing.JOptionPane 中的变量
选项类型，DEFAULT_OPTION、YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION 之一。
or(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this | val) 的 BigInteger。
or(BitSet) - 类 java.util.BitSet 中的方法
对此位 set 和位 set 参数执行逻辑或操作。
or(QueryExp, QueryExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，它是其他两个查询表达式的“或”。
orange - 类 java.awt.Color 中的静态变量
桔黄色。
ORANGE - 类 java.awt.Color 中的静态变量
桔黄色。
orb() - 接口 javax.rmi.CORBA.Tie 中的方法
返回此 tie 的 ORB。
orb(ORB) - 接口 javax.rmi.CORBA.Tie 中的方法
设置此 tie 的 ORB。
ORB - org.omg.CORBA 中的 类
为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。
ORB() - 类 org.omg.CORBA.ORB 的构造方法
orb(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
提供对与其参数关联的 orb 的引用。
orb() - 类 org.omg.CORBA.portable.InputStream 中的方法
返回创建此 InputStream 的 ORB。
orb() - 类 org.omg.CORBA.portable.OutputStream 中的方法
返回创建此 OutputStream 的 ORB。
ORB - org.omg.CORBA_2_3 中的 类
扩展了 org.omg.CORBA.ORB 的类，使 ORB 在 OMG CORBA 规范 2.3 版下可移植。
ORB() - 类 org.omg.CORBA_2_3.ORB 的构造方法
orb(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
返回当前关联 Servant 的 ORB 实例的便捷方法。
ORB_CTRL_MODEL - 类 org.omg.PortableServer.ThreadPolicyValue 中的静态变量
orb_id() - 接口 org.omg.PortableInterceptor.ObjectReferenceTemplate 中的方法
orb_id() - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
返回将被初始化的 ORB 的 ID。
orb_id() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回用于创建 ORB 的 ID。
ORBIdHelper - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/ORBIdHelper.java。
ORBIdHelper() - 类 org.omg.PortableInterceptor.ORBIdHelper 的构造方法
ORBInitializer - org.omg.PortableInterceptor 中的 接口
便于注册 interceptor 和初始化 ORB。
ORBInitializerOperations - org.omg.PortableInterceptor 中的 接口
便于注册 interceptor 和初始化 ORB。
ORBInitInfo - org.omg.PortableInterceptor 中的 接口
传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
ORBInitInfoOperations - org.omg.PortableInterceptor 中的 接口
传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
order() - 类 java.nio.ByteBuffer 中的方法
获取此缓冲区的字节顺序。
order(ByteOrder) - 类 java.nio.ByteBuffer 中的方法
修改此缓冲区的字节顺序。
order() - 类 java.nio.CharBuffer 中的方法
获取此缓冲区的字节顺序。
order() - 类 java.nio.DoubleBuffer 中的方法
获取此缓冲区的字节顺序。
order() - 类 java.nio.FloatBuffer 中的方法
获取此缓冲区的字节顺序。
order() - 类 java.nio.IntBuffer 中的方法
获取此缓冲区的字节顺序。
order() - 类 java.nio.LongBuffer 中的方法
获取此缓冲区的字节顺序。
order() - 类 java.nio.ShortBuffer 中的方法
获取此缓冲区的字节顺序。
ordered - 类 javax.naming.directory.BasicAttribute 中的变量
记录此属性的值是否有序的标志。
ordinal() - 类 java.lang.Enum 中的方法
返回枚举常量的序数（它在枚举声明中的位置，其中初始常量序数为零）。
ordinaryChar(int) - 类 java.io.StreamTokenizer 中的方法
指定字符参数在此标记生成器中是“普通”字符。
ordinaryChars(int, int) - 类 java.io.StreamTokenizer 中的方法
指定 low <= c <= high 范围中的所有字符 c 在此标记生成器中都是“普通”字符。
orFilter(Iterable<? extends RowFilter<? super M, ? super I>>) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
org.ietf.jgss - 软件包 org.ietf.jgss
此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA - 软件包 org.omg.CORBA
提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage - 软件包 org.omg.CORBA.DynAnyPackage
提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage - 软件包 org.omg.CORBA.ORBPackage
提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable - 软件包 org.omg.CORBA.portable
提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage - 软件包 org.omg.CORBA.TypeCodePackage
提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CORBA_2_3 - 软件包 org.omg.CORBA_2_3
CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。
org.omg.CORBA_2_3.portable - 软件包 org.omg.CORBA_2_3.portable
提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CosNaming - 软件包 org.omg.CosNaming
为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage - 软件包 org.omg.CosNaming.NamingContextExtPackage
此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage - 软件包 org.omg.CosNaming.NamingContextPackage
此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic - 软件包 org.omg.Dynamic
此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny - 软件包 org.omg.DynamicAny
提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage - 软件包 org.omg.DynamicAny.DynAnyFactoryPackage
此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage - 软件包 org.omg.DynamicAny.DynAnyPackage
此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP - 软件包 org.omg.IOP
此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage - 软件包 org.omg.IOP.CodecFactoryPackage
此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage - 软件包 org.omg.IOP.CodecPackage
此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging - 软件包 org.omg.Messaging
此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor - 软件包 org.omg.PortableInterceptor
提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage - 软件包 org.omg.PortableInterceptor.ORBInitInfoPackage
此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer - 软件包 org.omg.PortableServer
提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage - 软件包 org.omg.PortableServer.CurrentPackage
提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage - 软件包 org.omg.PortableServer.POAManagerPackage
封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage - 软件包 org.omg.PortableServer.POAPackage
允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.portable - 软件包 org.omg.PortableServer.portable
提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.ServantLocatorPackage - 软件包 org.omg.PortableServer.ServantLocatorPackage
提供定位 servant 的类和接口。
org.omg.SendingContext - 软件包 org.omg.SendingContext
为值类型的编组提供支持。
org.omg.stub.java.rmi - 软件包 org.omg.stub.java.rmi
包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。
org.w3c.dom - 软件包 org.w3c.dom
为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.bootstrap - 软件包 org.w3c.dom.bootstrap
org.w3c.dom.events - 软件包 org.w3c.dom.events
org.w3c.dom.ls - 软件包 org.w3c.dom.ls
org.xml.sax - 软件包 org.xml.sax
此包提供了核心 SAX API。
org.xml.sax.ext - 软件包 org.xml.sax.ext
此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers - 软件包 org.xml.sax.helpers
此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。
orientation - 类 javax.swing.JProgressBar 中的变量
进度条是水平的还是垂直的。
orientation - 类 javax.swing.JScrollBar 中的变量
orientation - 类 javax.swing.JSlider 中的变量
滑块方向是水平还是垂直的。
orientation - 类 javax.swing.JSplitPane 中的变量
如何分割视图。
orientation - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
JSplitPane 的方向。
Orientation - 类 javax.swing.text.StyleConstants 中的静态变量
段落的方向。
ORIENTATION_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 orientation（水平或者垂直）属性名称。
OrientationRequested - javax.print.attribute.standard 中的 类
OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
OrientationRequested(int) - 类 javax.print.attribute.standard.OrientationRequested 的构造方法
构造具有给定整数值的新 OrientationRequested 枚举值。
origin - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的变量
ORIGINAL_TYPE_FIELD - 类 javax.management.JMX 中的静态变量
originalType 字段的名称。
originalEx - 异常 org.omg.CORBA.portable.UnknownException 中的变量
一个 throwable 对象，包装在 CORBA UnknownException 中的原始异常。
OriginateDirection - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getDirection 的可能值。
originatingProvider - 类 javax.imageio.ImageReader 中的变量
实例化此对象的 ImageReaderSpi，如果其身份未知或不存在，则为 null。
originatingProvider - 类 javax.imageio.ImageWriter 中的变量
实例化此对象的 ImageWriterSpi，如果 ImageWriterSpi 的标识是未知的或不存在，则将此对象实例化为 null。
origmodel - 类 java.awt.image.RGBImageFilter 中的变量
用户调用 substituteColorModel 时将由 newmodel 替换的 ColorModel。
ORIYA - 类 java.awt.font.NumericShaper 中的静态变量
标识 ORIYA 范围和十进制基数。
ORIYA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Oriya”Unicode 字符块的常量。
OSMANYA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Osmanya”Unicode 字符块的常量。
oStart - 类 javax.swing.text.html.parser.Element 中的变量
OTHER - 类 java.sql.Types 中的静态变量
Java 编程语言中的常量，该常量指示 SQL 类型是特定于数据库的并且被映射到可通过 getObject 和 setObject 方法访问的 Java 对象。
OTHER - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
打印机已经检测到了一个以下未列出的错误。
OTHER_LETTER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Lo”。
OTHER_NUMBER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“No”。
OTHER_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Po”。
OTHER_SYMBOL - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“So”。
othersDeletesAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取由其他结果集类型进行的删除是否可见。
othersInsertsAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取由其他结果集类型进行的插入是否可见。
othersUpdatesAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取由其他结果集类型进行的更新是否可见。
out - 类 java.io.FileDescriptor 中的静态变量
标准输出流的句柄。
out - 类 java.io.FilterOutputStream 中的变量
要过滤的基础输出流。
out - 类 java.io.FilterWriter 中的变量
底层字符输出流。
out - 类 java.io.PipedInputStream 中的变量
循环缓冲区中位置的索引，此管道输入流将从该位置读取下一个数据字节。
out - 类 java.io.PrintWriter 中的变量
此 PrintWriter 的底层字符输出流。
out - 类 java.lang.System 中的静态变量
“标准”输出流。
out() - 类 java.util.Formatter 中的方法
返回输出的目标文件。
OUT_BOTTOM - 类 java.awt.geom.Rectangle2D 中的静态变量
指示点位于此 Rectangle2D 下方的位掩码。
OUT_LEFT - 类 java.awt.geom.Rectangle2D 中的静态变量
指示点位于此 Rectangle2D 左边的位掩码。
OUT_RIGHT - 类 java.awt.geom.Rectangle2D 中的静态变量
指示点位于此 Rectangle2D 右边的位掩码。
OUT_TOP - 类 java.awt.geom.Rectangle2D 中的静态变量
指示点位于此 Rectangle2D 上方的位掩码。
OUTBOUND_MESSAGE_ATTACHMENTS - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性: 用于出站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。
outcode(double, double) - 类 java.awt.geom.Rectangle2D.Double 中的方法
确定指定坐标相对于此 Rectangle2D 的位置。
outcode(double, double) - 类 java.awt.geom.Rectangle2D.Float 中的方法
确定指定坐标相对于此 Rectangle2D 的位置。
outcode(double, double) - 类 java.awt.geom.Rectangle2D 中的方法
确定指定坐标相对于此 Rectangle2D 的位置。
outcode(Point2D) - 类 java.awt.geom.Rectangle2D 中的方法
确定指定 Point2D 相对于此 Rectangle2D 的位置。
outcode(double, double) - 类 java.awt.Rectangle 中的方法
确定指定坐标相对于此 Rectangle2D 的位置。
OUTLINE_DRAG_MODE - 类 javax.swing.JDesktopPane 中的静态变量
指示桌面窗格是否只应该出现正在被拖动项的轮廓。
OutOfMemoryError - java.lang 中的 错误
因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
OutOfMemoryError() - 错误 java.lang.OutOfMemoryError 的构造方法
构造不带详细消息的 OutOfMemoryError。
OutOfMemoryError(String) - 错误 java.lang.OutOfMemoryError 的构造方法
构造带指定详细消息的 OutOfMemoryError。
outpixbuf - 类 java.awt.image.ReplicateScaleFilter 中的变量
使用 ReplicateScaleFilter.destWidth 的大小初始化的 byte 数组，用于将像素数据行传递给 ImageConsumer。
output - 类 javax.imageio.ImageWriter 中的变量
由 setOutput 设置并由 getOutput 获取的 ImageOutputStream 或其他 Object。
output(char[], int, int) - 类 javax.swing.text.AbstractWriter 中的方法
写出内容过程的最后一步。
output(char[], int, int) - 类 javax.swing.text.html.HTMLWriter 中的方法
重写此方法来映射任何字符实体，例如 < 映射到 <。
OUTPUT_AREA_ALMOST_FULL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
一个或多个输出区域几乎已经填满（例如纸盒、装订器、整理器）。
OUTPUT_AREA_FULL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
一个或多个输出区域已经填满（例如纸盒、装订器、整理器）。
OUTPUT_TRAY_MISSING - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备中没有一个或多个输出纸盒。
outputClass - 类 javax.imageio.spi.ImageOutputStreamSpi 中的变量
指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
OutputDeviceAssigned - javax.print.attribute.standard 中的 类
OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
OutputDeviceAssigned(String, Locale) - 类 javax.print.attribute.standard.OutputDeviceAssigned 的构造方法
构造具有给定设备名称和语言环境的新 OutputDeviceAssigned 属性。
OutputKeys - javax.xml.transform 中的 类
提供可用于设置 Transformer 的输出属性或从 Transformer 或 Templates 对象检索输出属性的字符串常量。
OutputStream - java.io 中的 类
此抽象类是表示输出字节流的所有类的超类。
OutputStream() - 类 java.io.OutputStream 的构造方法
OutputStream - org.omg.CORBA.portable 中的 类
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
OutputStream() - 类 org.omg.CORBA.portable.OutputStream 的构造方法
OutputStream - org.omg.CORBA_2_3.portable 中的 类
OutputStream 提供将所有映射的 IDL 类型写入流的接口。
OutputStream() - 类 org.omg.CORBA_2_3.portable.OutputStream 的构造方法
OutputStreamWriter - java.io 中的 类
OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
OutputStreamWriter(OutputStream, String) - 类 java.io.OutputStreamWriter 的构造方法
创建使用指定字符集的 OutputStreamWriter。
OutputStreamWriter(OutputStream) - 类 java.io.OutputStreamWriter 的构造方法
创建使用默认字符编码的 OutputStreamWriter。
OutputStreamWriter(OutputStream, Charset) - 类 java.io.OutputStreamWriter 的构造方法
创建使用给定字符集的 OutputStreamWriter。
OutputStreamWriter(OutputStream, CharsetEncoder) - 类 java.io.OutputStreamWriter 的构造方法
创建使用给定字符集编码器的 OutputStreamWriter。
outputTypes - 类 javax.imageio.spi.ImageWriterSpi 中的变量
将从 getOutputTypes 返回的 Class 对象的数组，该数组最初为 null。
outsideBorder - 类 javax.swing.border.CompoundBorder 中的变量
OVER - 类 java.awt.dnd.DragSourceContext 中的静态变量
updateCurrentCursor() 使用的 int 值，指示 Cursor 处于 DropTarget 上。
OVERFLOW - 类 java.nio.charset.CoderResult 中的静态变量
指示溢出的结果对象，意味着输出缓冲区没有足够的空间。
OverlappingFileLockException - java.nio.channels 中的 异常
试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
OverlappingFileLockException() - 异常 java.nio.channels.OverlappingFileLockException 的构造方法
构造此类的一个实例。
overlaps(long, long) - 类 java.nio.channels.FileLock 中的方法
判断此锁定是否与给定的锁定区域重叠。
OverlayLayout - javax.swing 中的 类
要在彼此顶部安排组件的布局管理器。
OverlayLayout(Container) - 类 javax.swing.OverlayLayout 的构造方法
构造执行子容器的覆盖安排的布局管理器。
Override - java.lang 中的 注释类型
表示一个方法声明打算重写超类中的另一个方法声明。
overrides(ExecutableElement, ExecutableElement, TypeElement) - 接口 javax.lang.model.util.Elements 中的方法
测试一个方法（作为给定类型的成员）是否重写了另一个方法。
ownDeletesAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取结果集自身的删除是否可见。
owner - 类 java.awt.datatransfer.Clipboard 中的变量
Owner - java.security.acl 中的 接口
管理访问控制列表 (ACL) 的所有者或 ACL 配置的接口。
ownInsertsAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取结果集自身的插入是否可见。
owns(AbstractQueuedLongSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
查询给定 ConditionObject 是否使用此同步器作为它的锁。
owns(AbstractQueuedSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
查询给定的 ConditionObject 是否使用了此同步器作为其锁。
ownUpdatesAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取对于给定类型的 ResultSet 对象，结果集自身的更新是否可见。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


P - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

P

P - 类 javax.swing.text.html.HTML.Tag 中的静态变量
p - 类 javax.swing.text.html.parser.DTD 中的变量
pack() - 类 java.awt.Window 中的方法
调整此窗口的大小，以适合其子组件的首选大小和布局。
pack(JarFile, OutputStream) - 接口 java.util.jar.Pack200.Packer 中的方法
接收 JarFile 并将其转换为 Pack200 存档。
pack(JarInputStream, OutputStream) - 接口 java.util.jar.Pack200.Packer 中的方法
接收 JarInputStream 并将其转换成 Pack200 存档。
pack() - 类 javax.swing.JInternalFrame 中的方法
使此 JInternalFrame 的子组件按其首选大小进行布局。
pack() - 类 javax.swing.JPopupMenu 中的方法
布置容器，让它使用显示其内容所需的最小空间。
Pack200 - java.util.jar 中的 类
以 Pack200 格式在 JAR 文件和打包的流之间进行转换。
Pack200.Packer - java.util.jar 中的 接口
打包器引擎把各种转换应用到输入 JAR 文件，从而可以通过压缩器（如 gzip 或 zip）高度压缩打包流。
Pack200.Unpacker - java.util.jar 中的 接口
解包器引擎将打包的流转换为 JAR 文件。
Package - java.lang 中的 类
Package 对象包含有关 Java 包的实现和规范的版本信息。
PackageElement - javax.lang.model.element 中的 接口
表示一个包程序元素。
packagePrefix - 接口 java.rmi.server.LoaderHandler 中的静态变量
已过时。 系统 LoaderHandler 实现的包。
packagePrefix - 接口 java.rmi.server.RemoteRef 中的静态变量
初始化服务器包的前缀：假定服务器 ref 类（如 UnicastRef、UnicastServerRef）的实现位于由前缀定义的包中。
packagesIn(Iterable<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中包的列表。
packagesIn(Set<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中包的集合。
PackedColorModel - java.awt.image 中的 类
PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。
PackedColorModel(ColorSpace, int, int[], int, boolean, int, int) - 类 java.awt.image.PackedColorModel 的构造方法
根据颜色掩码数组（指定了 int 像素表示形式中哪些位包含每个颜色的采样）和 alpha 掩码来构造一个 PackedColorModel。
PackedColorModel(ColorSpace, int, int, int, int, int, boolean, int, int) - 类 java.awt.image.PackedColorModel 的构造方法
根据指定的掩码构造一个 PackedColorModel，该掩码指示 int 像素表示形式中的哪些位包含 alpha、红色、绿色和蓝色采样。
padding - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的变量
PADDING - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
PADDING_BOTTOM - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
PADDING_LEFT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
PADDING_RIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
PADDING_TOP - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
padSelectedTab(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
padSelectedTab(int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 中的方法
padSpaceBetweenStrings - 类 javax.swing.plaf.metal.MetalToolTipUI 中的静态变量
padTabRun(int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
PAGE_AXIS - 类 javax.swing.BoxLayout 中的静态变量
指定应该根据目标容器的 ComponentOrientation 属性确定的文本行在页面中的流向来放置组件。
PAGE_END - 类 java.awt.BorderLayout 中的静态变量
组件出现在最后一行布局内容之后。
PAGE_END - 类 java.awt.GridBagConstraints 中的静态变量
沿显示区域的边缘居中放置组件，该显示区域与当前 ComponentOrienation 的页面结束部分相关。
PAGE_EXISTS - 接口 java.awt.print.Printable 中的静态变量
从 Printable.print(Graphics, PageFormat, int) 返回，表示请求的页面被呈现。
PAGE_START - 类 java.awt.BorderLayout 中的静态变量
组件出现在第一行布局内容之前。
PAGE_START - 类 java.awt.GridBagConstraints 中的静态变量
沿显示区域的边缘居中放置组件，该显示区域与当前 ComponentOrienation 的页面开始部分相关。
PAGE_TAB - 类 javax.accessibility.AccessibleRole 中的静态变量
作为页选项卡列表子级的对象。
PAGE_TAB_LIST - 类 javax.accessibility.AccessibleRole 中的静态变量
通过所提供的某种机制一次可呈现一系列窗格（或页选项卡）的对象。
Pageable - java.awt.print 中的 接口
Pageable 实现表示要打印的页面集合。
PAGEABLE - 类 javax.print.DocFlavor.SERVICE_FORMATTED 中的静态变量
打印数据表示形式类名 = "java.awt.print.Pageable"（pageable 对象）的服务格式化打印数据 DocFlavor。
PageAttributes - java.awt 中的 类
用来控制打印页面输出的属性集。
PageAttributes() - 类 java.awt.PageAttributes 的构造方法
构造一个具有每个属性的默认值的 PageAttributes 实例。
PageAttributes(PageAttributes) - 类 java.awt.PageAttributes 的构造方法
构造一个 PageAttributes 实例，它是所提供的 PageAttributes 的副本。
PageAttributes(PageAttributes.ColorType, PageAttributes.MediaType, PageAttributes.OrientationRequestedType, PageAttributes.OriginType, PageAttributes.PrintQualityType, int[]) - 类 java.awt.PageAttributes 的构造方法
构造一个具有每个属性的指定值的 PageAttributes 实例。
PageAttributes.ColorType - java.awt 中的 类
可能颜色状态的类型安全的枚举。
PageAttributes.MediaType - java.awt 中的 类
可能的纸张大小的类型安全的枚举。
PageAttributes.OrientationRequestedType - java.awt 中的 类
可能打印方向的类型安全的枚举。
PageAttributes.OriginType - java.awt 中的 类
可能原点的类型安全的枚举。
PageAttributes.PrintQualityType - java.awt 中的 类
可能的打印质量的类型安全的枚举。
pageDialog(PageFormat) - 类 java.awt.print.PrinterJob 中的方法
显示允许修改 PageFormat 实例的对话框。
pageDialog(PrintRequestAttributeSet) - 类 java.awt.print.PrinterJob 中的方法
显示跨平台页面设置对话框的便捷方法。
pageDownAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
垂直向下翻页的动作名称。
PagedResultsControl - javax.naming.ldap 中的 类
请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。
PagedResultsControl(int, boolean) - 类 javax.naming.ldap.PagedResultsControl 的构造方法
构造一个控件来设置要在每页结果中返回的项数。
PagedResultsControl(int, byte[], boolean) - 类 javax.naming.ldap.PagedResultsControl 的构造方法
构造一个控件来设置要在每页结果中返回的项数。
PagedResultsResponseControl - javax.naming.ldap 中的 类
指示一批搜索结果的末尾。
PagedResultsResponseControl(String, boolean, byte[]) - 类 javax.naming.ldap.PagedResultsResponseControl 的构造方法
构造分页结果响应控件。
PageFormat - java.awt.print 中的 类
PageFormat 类描述要打印的页面大小和方向。
PageFormat() - 类 java.awt.print.PageFormat 的构造方法
创建默认的纵向 PageFormat。
PageRanges - javax.print.attribute.standard 中的 类
PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
PageRanges(int[][]) - 类 javax.print.attribute.standard.PageRanges 的构造方法
构造具有给定成员的新 PageRanges 属性。
PageRanges(String) - 类 javax.print.attribute.standard.PageRanges 的构造方法
构造具有给定成员（字符串形式）的新 PageRanges 属性。
PageRanges(int) - 类 javax.print.attribute.standard.PageRanges 的构造方法
构造一个包括单个整数的新 PageRanges 属性。
PageRanges(int, int) - 类 javax.print.attribute.standard.PageRanges 的构造方法
构造一个包括单一整数范围的新 PageRanges 属性。
PagesPerMinute - javax.print.attribute.standard 中的 类
PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
PagesPerMinute(int) - 类 javax.print.attribute.standard.PagesPerMinute 的构造方法
构造具有给定整数值的新 PagesPerMinute 属性。
PagesPerMinuteColor - javax.print.attribute.standard 中的 类
PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
PagesPerMinuteColor(int) - 类 javax.print.attribute.standard.PagesPerMinuteColor 的构造方法
构造具有给定整数值的新 PagesPerMinuteColor 属性。
pageUpAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
垂直向上翻页的动作名称。
paint(Graphics) - 类 java.awt.Canvas 中的方法
绘制此 canvas。
paint(Graphics) - 类 java.awt.Component 中的方法
绘制此组件。
paint(Graphics) - 类 java.awt.Container 中的方法
绘制容器。
PAINT - 类 java.awt.event.PaintEvent 中的静态变量
绘制事件类型。
Paint - java.awt 中的 接口
此 Paint 接口定义如何为 Graphics2D 操作生成颜色模式。
paint(Graphics) - 类 javax.swing.CellRendererPane 中的方法
不应调用。
paint(Graphics) - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
绘制面板。
paint(Graphics) - 类 javax.swing.JComponent 中的方法
由 Swing 调用，以绘制组件。
paint(Graphics) - 类 javax.swing.JLayeredPane 中的方法
在指定的图形上下文中绘制此 JLayeredPane。
paint(Graphics) - 类 javax.swing.JViewport 中的方法
通过后备存储绘制图像，或者使用后备存储“位图传送”剩余图像来仅绘制最新暴露的部分，这具体取决于是否启用 backingStore。
paint(Graphics) - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
paint(Graphics) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
使用前景色绘制标签文本，如果标签不透明，则利用背景色绘制整个背景。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
绘制与 Graphics 对象 clipRect 相交的行。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
将绘制委托给两种方法之一：paintDeterminate 和 paintIndeterminate。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法
绘制单选按钮
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paint(Graphics) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
绘制分隔符。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
传递消息以绘制外观。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
绘制用 installUI() 设置的 table 实例的表示形式。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
绘制界面。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicToggleButtonUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 中的方法
paint(Graphics) - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
绘制指定组件，使其适合外观。
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法
paint(Graphics) - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalSeparatorUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, Shape) - 类 javax.swing.text.AsyncBoxView 中的方法
使用给定的分配和呈现表面呈现该视图。
paint(Graphics, Shape) - 类 javax.swing.text.BoxView 中的方法
使用该面给定的呈现面和区域呈现 BoxView。
paint(Graphics) - 接口 javax.swing.text.Caret 中的方法
呈现插入符。
paint(Graphics, Shape) - 类 javax.swing.text.ComponentView 中的方法
真正的绘制行为自然来源于组件与其父容器（容纳此视图的同一容器）之间的关联。
paint(Graphics) - 类 javax.swing.text.DefaultCaret 中的方法
将插入符作为垂直线呈现。
paint(Graphics, int, int, Shape, JTextComponent) - 类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 中的方法
绘制高亮显示区域。
paint(Graphics) - 类 javax.swing.text.DefaultHighlighter 中的方法
呈现高亮显示区域。
paint(Graphics, Shape) - 类 javax.swing.text.FieldView 中的方法
使用给定呈现面和该表面的区域呈现。
paint(GlyphView, Graphics, Shape, int, int) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
绘制表示给定范围的字形。
paint(Graphics, Shape) - 类 javax.swing.text.GlyphView 中的方法
呈现一部分运行的文本样式。
paint(Graphics, int, int, Shape, JTextComponent) - 接口 javax.swing.text.Highlighter.HighlightPainter 中的方法
呈现高亮显示。
paint(Graphics) - 接口 javax.swing.text.Highlighter 中的方法
呈现高亮显示。
paint(Graphics, Shape) - 类 javax.swing.text.html.BlockView 中的方法
使用给定呈现面和该表面的区域呈现。
paint(Graphics, Shape) - 类 javax.swing.text.html.ImageView 中的方法
绘制 View。
paint(Graphics, Shape) - 类 javax.swing.text.html.ListView 中的方法
使用给定呈现面和该表面的区域呈现。
paint(Graphics, Shape) - 类 javax.swing.text.html.ParagraphView 中的方法
使用给定的呈现面和该面上的区域进行呈现。
paint(Graphics, float, float, float, float, View) - 类 javax.swing.text.html.StyleSheet.BoxPainter 中的方法
根据给定的属性绘制 CSS 框。
paint(Graphics, float, float, float, float, View, int) - 类 javax.swing.text.html.StyleSheet.ListPainter 中的方法
根据给定的属性绘制 CSS 列表装饰。
paint(Graphics, Shape) - 类 javax.swing.text.IconView 中的方法
绘制图标。
paint(Graphics, Shape) - 类 javax.swing.text.ParagraphView 中的方法
使用给定的呈现面和该面上的区域进行呈现。
paint(Graphics, Shape) - 类 javax.swing.text.PlainView 中的方法
使用给定呈现面和该表面的区域呈现。
paint(Graphics, Shape) - 类 javax.swing.text.View 中的方法
使用给定的呈现表面和该表面上的区域来呈现。
paint(Graphics, Shape) - 类 javax.swing.text.WrappedPlainView 中的方法
使用给定的呈现表面和表现上的区域来呈现。
paint(Graphics) - 类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 中的方法
重写 Container.paint 以绘制节点的图标，并使用选定的背景色。
paint(Graphics) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
绘制值。
PAINT_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择绘制事件的事件掩码。
PAINT_FIRST - 类 java.awt.event.PaintEvent 中的静态变量
标记绘制事件 id 范围中的首个整数 id。
PAINT_LAST - 类 java.awt.event.PaintEvent 中的静态变量
标记绘制事件 id 范围中的最后一个整数 id。
paintAll(Graphics) - 类 java.awt.Component 中的方法
绘制此组件及其所有子组件。
paintArrowButtonBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制箭头按钮的背景。
paintArrowButtonBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制箭头按钮的边框。
paintArrowButtonForeground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制箭头按钮的前景。
paintBackground(Graphics, JMenuItem, Color) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
绘制菜单项的背景。
paintBackground(Graphics) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
绘制视图的背景。
paintBorder(Graphics) - 类 javax.swing.AbstractButton 中的方法
如果 BorderPainted 属性为 true 并且按钮有边框，则绘制该按钮边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.AbstractBorder 中的方法
此默认实现不执行绘制操作。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.BevelBorder 中的方法
按指定的位置和尺寸绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - 接口 javax.swing.border.Border 中的方法
按指定的位置和尺寸绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.CompoundBorder 中的方法
绘制组合边框，方法是先按指定的位置和尺寸绘制外部边框，然后按照外部边框 insets 指定的位置和尺寸偏移量绘制内部边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.EmptyBorder 中的方法
默认情况下不执行绘制。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.EtchedBorder 中的方法
按照指定的位置和尺寸为指定的组件绘制边框
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.LineBorder 中的方法
按照指定的位置和尺寸为指定的组件绘制边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.MatteBorder 中的方法
绘制衬边边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.SoftBevelBorder 中的方法
按照指定的位置和尺寸绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.TitledBorder 中的方法
按照指定的位置和大小为指定的组件绘制边框。
paintBorder(Graphics) - 类 javax.swing.JComponent 中的方法
绘制组件的边框。
paintBorder(Graphics) - 类 javax.swing.JMenuBar 中的方法
如果 BorderPainted 属性为 true，则绘制菜单栏的边框。
paintBorder(Graphics) - 类 javax.swing.JPopupMenu 中的方法
如果 borderPainted 属性为 true，则绘制弹出菜单的边框。
paintBorder - 类 javax.swing.JProgressBar 中的变量
是否显示围绕进度条的边框。
paintBorder(Graphics) - 类 javax.swing.JProgressBar 中的方法
如果 borderPainted 属性为 true，则绘制进度条的边框。
paintBorder(Graphics) - 类 javax.swing.JToolBar 中的方法
如果 borderPainted 属性为 true，则绘制工具栏边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.BorderUIResource 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.PaletteBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.TextFieldBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 中的方法
paintBottomTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintButtonBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制按钮的背景。
paintButtonBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制按钮的边框。
paintButtonPressed(Graphics, AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
paintButtonPressed(Graphics, AbstractButton) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
paintButtonPressed(Graphics, AbstractButton) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
paintCell(Graphics, int, Rectangle, ListCellRenderer, ListModel, ListSelectionModel, int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。
paintCheckBoxBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制复选框的背景。
paintCheckBoxBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制复选框的边框。
paintCheckBoxMenuItemBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制复选框菜单项的背景。
paintCheckBoxMenuItemBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制复选框菜单项的边框。
paintChild(Graphics, Rectangle, int) - 类 javax.swing.text.BoxView 中的方法
绘制一个子级。
paintChild(Graphics, Rectangle, int) - 类 javax.swing.text.html.ListView 中的方法
通过调用 paint() 绘制其中的一个子级。
paintChildren(Graphics) - 类 javax.swing.JComponent 中的方法
绘制此组件的子组件。
paintChildren(Graphics) - 类 javax.swing.JSplitPane 中的方法
通知超类后，UI 通过 finishedPaintingChildren 通知子类，同时绘制边框。
paintChildren(Graphics) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
绘制与剪贴区域相交的子级。
paintColorChooserBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制颜色选择器的背景。
paintColorChooserBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制颜色选择器的边框。
paintComboBoxBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制组合框的背景。
paintComboBoxBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制组合框的边框。
paintComponent(Graphics) - 类 javax.swing.Box.Filler 中的方法
绘制此 Filler。
paintComponent(Graphics) - 类 javax.swing.Box 中的方法
绘制此 Box。
paintComponent(Graphics, Component, Container, int, int, int, int, boolean) - 类 javax.swing.CellRendererPane 中的方法
在图形对象 g 上绘制一个单元格渲染器组件 c。
paintComponent(Graphics, Component, Container, int, int, int, int) - 类 javax.swing.CellRendererPane 中的方法
调用 this.paintComponent(g, c, p, x, y, w, h, false)。
paintComponent(Graphics, Component, Container, Rectangle) - 类 javax.swing.CellRendererPane 中的方法
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
paintComponent(Graphics) - 类 javax.swing.JComponent 中的方法
如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。
paintComponent(Graphics) - 类 javax.swing.JInternalFrame 中的方法
重写此方法，以便在拖动内部窗体时允许进行优化的绘制。
paintComponent(Graphics) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
paintComponent(Graphics) - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
paintComponent(Graphics) - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
paintComponent(Graphics, Component, Container, int, int, int, int) - 类 javax.swing.SwingUtilities 中的静态方法
在指定的 Graphics 上绘制组件。
paintComponent(Graphics, Component, Container, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
在指定的 Graphics 上绘制组件。
paintComponents(Graphics) - 类 java.awt.Container 中的方法
绘制此容器中的每个组件。
paintContentBorder(Graphics, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintContentBorderBottomEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintContentBorderBottomEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintContentBorderLeftEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintContentBorderLeftEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintContentBorderRightEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintContentBorderRightEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintContentBorderTopEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintContentBorderTopEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
PaintContext - java.awt 中的 接口
PaintContext 接口定义了经过封装和优化的环境，使用此环境可以生成设备空间中的颜色模式，此模式用于在 Graphics2D 上进行填充操作或笔划操作。
paintCurrentValue(Graphics, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
绘制当前所选项。
paintCurrentValue(Graphics, Rectangle, boolean) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
如有必要，绘制当前所选项。
paintCurrentValueBackground(Graphics, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
绘制当前所选项的背景。
paintCurrentValueBackground(Graphics, Rectangle, boolean) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
如有必要，绘制当前所选项的背景。
paintDecreaseHighlight(Graphics) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
paintDesktopIconBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制桌面图标的背景。
paintDesktopIconBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制桌面图标的边框。
paintDesktopPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制桌面窗格的背景。
paintDesktopPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制桌面窗格的边框。
paintDeterminate(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
对几乎所有线性、确定进度条都能正确执行操作的多用途绘制方法。
paintDeterminate(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalProgressBarUI 中的方法
在进度条上绘制少量特殊的高亮显示。
paintDirtyRegions() - 类 javax.swing.RepaintManager 中的方法
绘制被标记为脏的所有组件。
paintDisabledText(JLabel, Graphics, String, int, int) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
利用 background.lighter() 将 clippedText 绘制在 textX、textY 处，然后利用 background.darker() 向右下移动一个像素。
paintDisabledText(JLabel, Graphics, String, int, int) - 类 javax.swing.plaf.metal.MetalLabelUI 中的方法
只绘制文本灰度 (Label.disabledForeground)，而不是使用标签前景色。
paintDragWindow(Graphics) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
绘制用于拖动的窗口的内容。
paintEditorPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制编辑器窗格的背景。
paintEditorPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制编辑器窗格的边框。
paintEnabledText(JLabel, Graphics, String, int, int) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
利用标签的前景色将 clippedText 绘制在 textX、textY 处。
PaintEvent - java.awt.event 中的 类
组件级绘制事件。
PaintEvent(Component, int, Rectangle) - 类 java.awt.event.PaintEvent 的构造方法
构造一个具有指定源组件和类型的 PaintEvent 对象。
paintExpandControl(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制 row 的展开（切换）部分。
paintFileChooserBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文件选择器的背景。
paintFileChooserBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文件选择器的边框。
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
paintFocus(Graphics, Rectangle, Dimension) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法
paintFocus(Graphics) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
paintFocus(Graphics, Rectangle, Dimension) - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法
paintFocus(Graphics) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
paintFocusIndicator(Graphics, int, Rectangle[], int, Rectangle, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintFocusIndicator(Graphics, int, Rectangle[], int, Rectangle, Rectangle, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintFormattedTextFieldBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制已格式化文本字段的背景。
paintFormattedTextFieldBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制已格式化文本字段的边框。
paintHighlightBelowTab() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintHorizontalLabel(Graphics, int, Component) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
为标签表中的每个标签调用此方法。
paintHorizontalLine(Graphics, JComponent, int, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制水平线。
paintHorizontalPartOfLeg(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制支路 (leg) 的水平部分。
paintHorizontalPartOfLeg(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
paintHorizontalSeparators(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
paintIcon(Component, Graphics, int, int) - 接口 javax.swing.Icon 中的方法
在指定位置上绘制图标。
paintIcon(Component, Graphics, int, int) - 类 javax.swing.ImageIcon 中的方法
绘制图标。
paintIcon(Graphics, JComponent, Rectangle) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
paintIcon(Graphics, int, int, Icon, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintIcon(Graphics, AbstractButton, Rectangle) - 类 javax.swing.plaf.basic.BasicToggleButtonUI 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.IconUIResource 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalComboBoxIcon 中的方法
绘制 MetalComboBox 的水平条
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 中的方法
paintIcon(Graphics, AbstractButton, Rectangle) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
在空间 iconRect 中绘制按钮 b 的适当图标。
paintImmediately(int, int, int, int) - 类 javax.swing.JComponent 中的方法
立即绘制此组件及其与该区域重叠的子代中的指定区域。
paintImmediately(Rectangle) - 类 javax.swing.JComponent 中的方法
立即绘制指定的区域。
paintIncreaseHighlight(Graphics) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
paintIndeterminate(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
对所有线性跳动框进度条都能正确执行操作的多用途绘制方法。
paintIndeterminate(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalProgressBarUI 中的方法
在进度条和跳动框上绘制少量特殊的高亮显示。
paintInternalFrameBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制内部窗体的背景。
paintInternalFrameBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制内部窗体的边框。
paintInternalFrameTitlePaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制内部窗体标题窗格的背景。
paintInternalFrameTitlePaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制内部窗体标题窗格的边框。
paintLabelBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制标签的背景。
paintLabelBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制标签的边框。
paintLabels(Graphics) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintLayer(Graphics, int, int, Shape, JTextComponent, View) - 类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 中的方法
绘制高亮显示的某一部分。
paintLayer(Graphics, int, int, Shape, JTextComponent, View) - 类 javax.swing.text.LayeredHighlighter.LayerPainter 中的方法
paintLayeredHighlights(Graphics, int, int, Shape, JTextComponent, View) - 类 javax.swing.text.DefaultHighlighter 中的方法
当要呈现叶 View （例如，LabelView）时，要调用此方法。
paintLayeredHighlights(Graphics, int, int, Shape, JTextComponent, View) - 类 javax.swing.text.LayeredHighlighter 中的方法
当叶 View（如 LabelView）呈现时，它们应调用此方法。
paintLeftTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintListBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制列表的背景。
paintListBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制列表的边框。
paintLoweredBevel(Component, Graphics, int, int, int, int) - 类 javax.swing.border.BevelBorder 中的方法
paintMajorTickForHorizSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintMajorTickForHorizSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintMajorTickForVertSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintMajorTickForVertSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintMe(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 中的方法
paintMenuBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单的背景。
paintMenuBarBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单栏的背景。
paintMenuBarBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单栏的边框。
paintMenuBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单的边框。
paintMenuItem(Graphics, JComponent, Icon, Icon, Color, Color, int) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
paintMenuItemBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单项的背景。
paintMenuItemBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单项的边框。
paintMinorTickForHorizSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintMinorTickForHorizSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintMinorTickForVertSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintMinorTickForVertSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintOptionPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项窗格的背景。
paintOptionPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项窗格的边框。
paintPalette(Graphics) - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
paintPanelBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制面板的背景。
paintPanelBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制面板的边框。
paintPasswordFieldBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制密码字段的背景。
paintPasswordFieldBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制密码字段的边框。
paintPopupMenuBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制弹出菜单的背景。
paintPopupMenuBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制弹出菜单的边框。
paintProgressBarBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制进度条的背景。
paintProgressBarBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制进度条的背景。
paintProgressBarBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制进度条的边框。
paintProgressBarBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制进度条的边框。
paintProgressBarForeground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制进度条的前景。
paintRadioButtonBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制单选钮的背景。
paintRadioButtonBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制单选钮的边框。
paintRadioButtonMenuItemBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制单选钮菜单项的背景。
paintRadioButtonMenuItemBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制单选钮菜单项的边框。
paintRaisedBevel(Component, Graphics, int, int, int, int) - 类 javax.swing.border.BevelBorder 中的方法
paintRightTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintRootPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制根窗体的背景。
paintRootPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制根窗体的边框。
paintRow(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制 row 的渲染器部分。
paintSafely(Graphics) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
安全地绘制界面，保证模型不会根据此线程的视图发生更改。
paintScrollBarBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的背景。
paintScrollBarBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的背景。
paintScrollBarBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的边框。
paintScrollBarBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的边框。
paintScrollBarThumbBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的 thumb 的背景。
paintScrollBarThumbBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的 thumb 的边框。
paintScrollBarTrackBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条滑道的背景。
paintScrollBarTrackBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条滑道的背景。
paintScrollBarTrackBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条滑道的边框。
paintScrollBarTrackBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条滑道的边框。
paintScrollPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动窗格的背景。
paintScrollPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动窗格的边框。
paintSeparatorBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔符的背景。
paintSeparatorBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔符的背景。
paintSeparatorBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔符的边框。
paintSeparatorBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔符的边框。
paintSeparatorForeground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔符的前景。
paintSliderBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的背景。
paintSliderBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的背景。
paintSliderBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的边框。
paintSliderBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的边框。
paintSliderThumbBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的 thumb 的背景。
paintSliderThumbBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的 thumb 的边框。
paintSliderTrackBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的滑道的背景。
paintSliderTrackBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的滑道的背景。
paintSliderTrackBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的滑道的边框。
paintSliderTrackBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的滑道的边框。
paintSpinnerBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制 spinner 的背景。
paintSpinnerBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制 spinner 的边框。
paintSplitPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔窗格的背景。
paintSplitPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔窗格的边框。
paintSplitPaneDividerBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔窗格的分隔栏的背景。
paintSplitPaneDividerBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔窗格的分隔栏的背景。
paintSplitPaneDividerForeground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔窗格的分隔栏的前景。
paintSplitPaneDragDivider(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
当用户拖动分隔符时，绘制分隔窗格的分隔栏。
paintString - 类 javax.swing.JProgressBar 中的变量
是否在进度条上显示文本的字符串。
paintString(Graphics, int, int, int, int, int, Insets) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
paintTab(Graphics, int, Rectangle[], int, Rectangle, Rectangle) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintTabArea(Graphics, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
在选项卡区域绘制选项卡。
paintTabBackground(Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintTabBackground(Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintTabbedPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的背景。
paintTabbedPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的边框。
paintTabbedPaneContentBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制包含选项卡窗格中所选选项卡内容的区域的背景。
paintTabbedPaneContentBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制包含选项卡窗格中所选选项卡内容的区域的边框。
paintTabbedPaneTabAreaBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡背后区域的背景。
paintTabbedPaneTabAreaBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡背后区域的背景。
paintTabbedPaneTabAreaBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡背后区域的边框。
paintTabbedPaneTabAreaBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡背后区域的边框。
paintTabbedPaneTabBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡的背景。
paintTabbedPaneTabBackground(SynthContext, Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡的背景。
paintTabbedPaneTabBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡的边框。
paintTabbedPaneTabBorder(SynthContext, Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡的边框。
paintTabBorder(Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
此方法围绕每个选项卡绘制边框。
paintTabBorder(Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintTableBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制表的背景。
paintTableBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制表的边框。
paintTableHeaderBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制表标题的背景。
paintTableHeaderBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制表标题的边框。
paintText(Graphics, JComponent, Rectangle, String) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
paintText(Graphics, AbstractButton, Rectangle, String) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
呈现当前按钮文本的方法。
paintText(Graphics, JMenuItem, Rectangle, String) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
呈现当前菜单项的文本。
paintText(Graphics, int, Font, FontMetrics, int, String, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintText(Graphics, JComponent, Rectangle, String) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
paintText(Graphics, JComponent, Rectangle, String) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
paintText(SynthContext, Graphics, String, Rectangle, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
在指定位置上绘制文本。
paintText(SynthContext, Graphics, String, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
在指定位置上绘制文本。
paintText(SynthContext, Graphics, String, Icon, int, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
绘制图标和文本。
paintTextAreaBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本区域的背景。
paintTextAreaBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本区域的边框。
paintTextFieldBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本字段的背景。
paintTextFieldBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本字段的边框。
paintTextPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本窗格的背景。
paintTextPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本窗格的边框。
paintThumb(Graphics, JComponent, Rectangle) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
paintThumb(Graphics) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintThumb(Graphics, JComponent, Rectangle) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
paintThumb(Graphics) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintTicks(Graphics) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintTitleBackground(Graphics) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
从 paintComponent 调用。
paintToggleButtonBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制切换按钮的背景。
paintToggleButtonBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制切换按钮的边框。
paintToolBarBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏的背景。
paintToolBarBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏的背景。
paintToolBarBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏的边框。
paintToolBarBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏的边框。
paintToolBarContentBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏内容区的背景。
paintToolBarContentBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏内容区的背景。
paintToolBarContentBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏内容区的边框。
paintToolBarContentBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏内容区的边框。
paintToolBarDragWindowBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
paintToolBarDragWindowBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
paintToolBarDragWindowBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
paintToolBarDragWindowBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
paintToolTipBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具提示的背景。
paintToolTipBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具提示的边框。
paintTopTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintTrack(Graphics, JComponent, Rectangle) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
paintTrack(Graphics) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintTrack(Graphics, JComponent, Rectangle) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
paintTrack(Graphics) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintTreeBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制树的背景。
paintTreeBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制树的边框。
paintTreeCellBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制包含树中某个单元格的行的背景。
paintTreeCellBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制包含树中某个单元格的行的边框。
paintTreeCellFocus(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
当树中某个单元格拥有焦点时，绘制该单元格的焦点指示器。
paintTriangle(Graphics, int, int, int, int, boolean) - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
绘制一个三角形。
paintValue(Graphics, Rectangle) - 接口 java.beans.PropertyEditor 中的方法
在屏幕实际状态给定区域中绘制值的表示形式。
paintValue(Graphics, Rectangle) - 类 java.beans.PropertyEditorSupport 中的方法
在屏幕实际状态给定区域中绘制值的表示形式。
paintVerticalLabel(Graphics, int, Component) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
为标签表中的每个标签调用此方法。
paintVerticalLine(Graphics, JComponent, int, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制垂直线。
paintVerticalPartOfLeg(Graphics, Rectangle, Insets, TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制支路的垂直部分。
paintVerticalPartOfLeg(Graphics, Rectangle, Insets, TreePath) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
paintViewportBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制视口的背景。
paintViewportBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制视口的边框。
PALETTE_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Palette 层的便捷对象。
paletteCloseIcon - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的变量
paletteTitleHeight - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的变量
PAN - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示信号的相对 pan（左右定位）的控件。
Panel - java.awt 中的 类
Panel 是最简单的容器类。
Panel() - 类 java.awt.Panel 的构造方法
使用默认的布局管理器创建新面板。
Panel(LayoutManager) - 类 java.awt.Panel 的构造方法
创建具有指定布局管理器的新面板。
PANEL - 类 javax.accessibility.AccessibleRole 中的静态变量
通常用于对对象进行分组的一般容器。
PANEL - 类 javax.swing.plaf.synth.Region 中的静态变量
Panel 的 region。
Panel.AccessibleAWTPanel - java.awt 中的 类
此类实现 Panel 类的可访问性支持。
Panel.AccessibleAWTPanel() - 类 java.awt.Panel.AccessibleAWTPanel 的构造方法
PANEL_UI - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个作为 AWT 面板实现的 UI。
PanelUI - javax.swing.plaf 中的 类
Panel 的可插入外观界面。
PanelUI() - 类 javax.swing.plaf.PanelUI 的构造方法
Paper - java.awt.print 中的 类
Paper 类描述一张纸的物理特征。
Paper() - 类 java.awt.print.Paper 的构造方法
创建信函大小的一张纸，页边空白为一英寸。
PARA_INDENT_LEFT - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
段落左缩进动作标识符
PARA_INDENT_RIGHT - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
段落右缩进动作标识符
PARAGRAPH - 类 javax.accessibility.AccessibleRole 中的静态变量
文本段落
PARAGRAPH_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Zp”。
ParagraphElementName - 类 javax.swing.text.AbstractDocument 中的静态变量
用于表示段落的元素名
ParagraphView - javax.swing.text.html 中的 类
显示段落，并使用 css 属性作为其配置。
ParagraphView(Element) - 类 javax.swing.text.html.ParagraphView 的构造方法
构造给定元素的 ParagraphView。
ParagraphView - javax.swing.text 中的 类
存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
ParagraphView(Element) - 类 javax.swing.text.ParagraphView 的构造方法
创建给定元素的 ParagraphView。
PARAM - 类 javax.swing.text.html.HTML.Tag 中的静态变量
param - 类 javax.swing.text.html.parser.DTD 中的变量
PARAM_IN - 类 org.omg.CORBA.ParameterMode 中的静态变量
PARAM_INOUT - 类 org.omg.CORBA.ParameterMode 中的静态变量
PARAM_OUT - 类 org.omg.CORBA.ParameterMode 中的静态变量
PARAMETER - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Parameter - org.omg.Dynamic 中的 类
org/omg/Dynamic/Parameter.java。
Parameter() - 类 org.omg.Dynamic.Parameter 的构造方法
Parameter(Any, ParameterMode) - 类 org.omg.Dynamic.Parameter 的构造方法
ParameterBlock - java.awt.image.renderable 中的 类
ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。
ParameterBlock() - 类 java.awt.image.renderable.ParameterBlock 的构造方法
一个 dummy 构造方法。
ParameterBlock(Vector<Object>) - 类 java.awt.image.renderable.ParameterBlock 的构造方法
使用源的给定 Vector 构造一个 ParameterBlock。
ParameterBlock(Vector<Object>, Vector<Object>) - 类 java.awt.image.renderable.ParameterBlock 的构造方法
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。
ParameterDescriptor - java.beans 中的 类
ParameterDescriptor 类允许 bean 实现者提供除 java.lang.reflect.Method 类提供的低级别信息之外的关于其每个参数的额外信息。
ParameterDescriptor() - 类 java.beans.ParameterDescriptor 的构造方法
公共默认构造方法。
ParameterizedType - java.lang.reflect 中的 接口
ParameterizedType 表示参数化类型，如 Collection<String>。
ParameterMetaData - java.sql 中的 接口
可用于获取关于 PreparedStatement 对象中每个参数标记的类型和属性信息的对象。
ParameterMode - org.omg.CORBA 中的 类
Parameter 参数模式的枚举。
ParameterMode(int) - 类 org.omg.CORBA.ParameterMode 的构造方法
ParameterModeHelper - org.omg.CORBA 中的 类
Parameter 参数模式的枚举。
ParameterModeHelper() - 类 org.omg.CORBA.ParameterModeHelper 的构造方法
ParameterModeHolder - org.omg.CORBA 中的 类
Parameter 参数模式的枚举。
ParameterModeHolder() - 类 org.omg.CORBA.ParameterModeHolder 的构造方法
ParameterModeHolder(ParameterMode) - 类 org.omg.CORBA.ParameterModeHolder 的构造方法
parameterModeIn - 接口 java.sql.ParameterMetaData 中的静态变量
指示参数模式为 IN 的常量。
parameterModeInOut - 接口 java.sql.ParameterMetaData 中的静态变量
指示参数模式为 INOUT 的常量。
parameterModeOut - 接口 java.sql.ParameterMetaData 中的静态变量
指示参数模式为 OUT 的常量。
parameterModeUnknown - 接口 java.sql.ParameterMetaData 中的静态变量
指示参数模式是未知的常量。
parameterNoNulls - 接口 java.sql.ParameterMetaData 中的静态变量
指示某一参数将不允许使用 NULL 值的常量。
parameterNullable - 接口 java.sql.ParameterMetaData 中的静态变量
指示某一参数将允许使用 NULL 值的常量。
parameterNullableUnknown - 接口 java.sql.ParameterMetaData 中的静态变量
指示不知道某一参数是否可为 null 的常量。
parameters - 类 java.awt.image.renderable.ParameterBlock 中的变量
一个非源参数的 Vector，存储为任意 Object。
params(NVList) - 类 org.omg.CORBA.ServerRequest 中的方法
已过时。 使用方法 arguments
paramString() - 类 java.awt.AWTEvent 中的方法
返回表示此 Event 状态的字符串。
paramString() - 类 java.awt.Button 中的方法
返回此 Button 状态的字符串表示形式。
paramString() - 类 java.awt.Checkbox 中的方法
返回表示此 Checkbox 的状态的字符串。
paramString() - 类 java.awt.CheckboxMenuItem 中的方法
返回表示此 CheckBoxMenuItem 状态的字符串。
paramString() - 类 java.awt.Choice 中的方法
返回表示此 Choice 菜单的状态的字符串。
paramString() - 类 java.awt.Component 中的方法
返回此组件状态的字符串表示形式。
paramString() - 类 java.awt.Container 中的方法
返回表示此 Container 的状态的字符串。
paramString() - 类 java.awt.Dialog 中的方法
返回表示此 dialog 状态的字符串。
paramString() - 类 java.awt.event.ActionEvent 中的方法
返回标识此动作事件的参数字符串。
paramString() - 类 java.awt.event.AdjustmentEvent 中的方法
paramString() - 类 java.awt.event.ComponentEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.ContainerEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.FocusEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.HierarchyEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.InputMethodEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.InvocationEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.ItemEvent 中的方法
返回标识此项事件的参数字符串。
paramString() - 类 java.awt.event.KeyEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.MouseEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.MouseWheelEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.PaintEvent 中的方法
paramString() - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
paramString() - 类 java.awt.event.TextEvent 中的方法
返回标识此文本事件的参数字符串。
paramString() - 类 java.awt.event.WindowEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.FileDialog 中的方法
返回表示此 FileDialog 窗口状态的字符串。
paramString() - 类 java.awt.Frame 中的方法
返回表示此 Frame 状态的字符串。
paramString() - 类 java.awt.Label 中的方法
返回一个表示此 Label 状态的字符串。
paramString() - 类 java.awt.List 中的方法
返回表示此滚动列表状态的参数字符串。
paramString() - 类 java.awt.Menu 中的方法
返回表示此 Menu 状态的字符串。
paramString() - 类 java.awt.MenuComponent 中的方法
返回表示此 MenuComponent 状态的字符串。
paramString() - 类 java.awt.MenuItem 中的方法
返回表示此 MenuItem 状态的字符串。
paramString() - 类 java.awt.MenuShortcut 中的方法
返回表示此 MenuShortcut 状态的参数字符串。
paramString() - 类 java.awt.Scrollbar 中的方法
返回表示此 Scrollbar 当前状态的字符串表示形式。
paramString() - 类 java.awt.ScrollPane 中的方法
返回表示此 ScrollPane 的状态的字符串。
paramString() - 类 java.awt.ScrollPaneAdjustable 中的方法
返回表示此滚动条的状态的字符串。
paramString() - 类 java.awt.TextArea 中的方法
返回表示此 TextArea 状态的字符串。
paramString() - 类 java.awt.TextComponent 中的方法
返回表示此 TextComponent 状态的字符串。
paramString() - 类 java.awt.TextField 中的方法
返回表示此 TextField 状态的字符串。
paramString() - 类 javax.swing.AbstractButton 中的方法
返回此 AbstractButton 的字符串表示形式。
paramString() - 类 javax.swing.event.InternalFrameEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 javax.swing.JApplet 中的方法
返回此 JApplet 的字符串表示形式。
paramString() - 类 javax.swing.JButton 中的方法
返回此 JButton 的字符串表示形式。
paramString() - 类 javax.swing.JCheckBox 中的方法
返回此 JCheckBox 的字符串表示形式。
paramString() - 类 javax.swing.JCheckBoxMenuItem 中的方法
返回此 JCheckBoxMenuItem 的字符串表示形式。
paramString() - 类 javax.swing.JColorChooser 中的方法
返回此 JColorChooser 的字符串表示形式。
paramString() - 类 javax.swing.JComboBox 中的方法
返回此 JComboBox 的字符串表示形式。
paramString() - 类 javax.swing.JComponent 中的方法
返回此 JComponent 的字符串表示形式。
paramString() - 类 javax.swing.JDesktopPane 中的方法
返回此 JDesktopPane 的字符串表示形式。
paramString() - 类 javax.swing.JDialog 中的方法
返回此 JDialog 的字符串表示形式。
paramString() - 类 javax.swing.JEditorPane 中的方法
返回此 JEditorPane 的字符串表示形式。
paramString() - 类 javax.swing.JFileChooser 中的方法
返回此 JFileChooser 的字符串表示形式。
paramString() - 类 javax.swing.JFrame 中的方法
返回此 JFrame 的字符串表示形式。
paramString() - 类 javax.swing.JInternalFrame 中的方法
返回此 JInternalFrame 的字符串表示形式。
paramString() - 类 javax.swing.JLabel 中的方法
返回此 JLabel 的字符串表示形式。
paramString() - 类 javax.swing.JLayeredPane 中的方法
返回此 JLayeredPane 的字符串表示形式。
paramString() - 类 javax.swing.JList 中的方法
返回此 JList 的 String 表示形式。
paramString() - 类 javax.swing.JMenu 中的方法
返回此 JMenu 的字符串表示形式。
paramString() - 类 javax.swing.JMenuBar 中的方法
返回此 JMenuBar 的字符串表示形式。
paramString() - 类 javax.swing.JMenuItem 中的方法
返回此 JMenuItem 的字符串表示形式。
paramString() - 类 javax.swing.JOptionPane 中的方法
返回此 JOptionPane 的字符串表示形式。
paramString() - 类 javax.swing.JPanel 中的方法
返回此 JPanel 的字符串表示形式。
paramString() - 类 javax.swing.JPasswordField 中的方法
返回此 JPasswordField 的字符串表示形式。
paramString() - 类 javax.swing.JPopupMenu 中的方法
返回此 JPopupMenu 的字符串表示形式。
paramString() - 类 javax.swing.JProgressBar 中的方法
返回此 JProgressBar 的字符串表示形式。
paramString() - 类 javax.swing.JRadioButton 中的方法
返回此 JRadioButton 的字符串表示形式。
paramString() - 类 javax.swing.JRadioButtonMenuItem 中的方法
返回此 JRadioButtonMenuItem 的字符串表示形式。
paramString() - 类 javax.swing.JRootPane 中的方法
返回此 JRootPane 的字符串表示形式。
paramString() - 类 javax.swing.JScrollBar 中的方法
返回此 JScrollBar 的字符串表示形式。
paramString() - 类 javax.swing.JScrollPane 中的方法
返回此 JScrollPane 的字符串表示形式。
paramString() - 类 javax.swing.JSeparator 中的方法
返回表示此 JSeparator 的一个字符串。
paramString() - 类 javax.swing.JSlider 中的方法
返回此 JSlider 的字符串表示形式。
paramString() - 类 javax.swing.JSplitPane 中的方法
返回此 JSplitPane 的字符串表示形式。
paramString() - 类 javax.swing.JTabbedPane 中的方法
返回此 JTabbedPane 的字符串表示。
paramString() - 类 javax.swing.JTable 中的方法
返回此表的字符串表示形式。
paramString() - 类 javax.swing.JTextArea 中的方法
返回此 JTextArea 的字符串表示形式。
paramString() - 类 javax.swing.JTextField 中的方法
返回此 JTextField 的字符串表示形式。
paramString() - 类 javax.swing.JTextPane 中的方法
返回此 JTextPane 的字符串表示形式。
paramString() - 类 javax.swing.JToggleButton 中的方法
返回此 JToggleButton 的字符串表示形式。
paramString() - 类 javax.swing.JToolBar 中的方法
返回此 JToolBar 的字符串表示形式。
paramString() - 类 javax.swing.JToolTip 中的方法
返回此 JToolTip 的字符串表示形式。
paramString() - 类 javax.swing.JTree 中的方法
返回此 JTree 的字符串表示形式。
paramString() - 类 javax.swing.JViewport 中的方法
返回此 JViewport 的字符串表示形式。
paramString() - 类 javax.swing.JWindow 中的方法
返回此 JWindow 的字符串表示形式。
paramString() - 类 javax.swing.table.JTableHeader 中的方法
返回此 JTableHeader 的字符串表示形式。
paramString() - 类 javax.swing.text.JTextComponent 中的方法
返回此 JTextComponent 的字符串表示形式。
parent - 类 java.awt.image.Raster 中的变量
此 Raster 的父 Raster，或者为 null。
parent() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.parent() 中的规范实现 parent 方法。
parent() - 类 java.util.prefs.Preferences 中的方法
返回此首选项节点的父节点；如果此为根，则返回 null。
parent - 类 java.util.ResourceBundle 中的变量
此包的父包。
parent - 类 javax.swing.tree.DefaultMutableTreeNode 中的变量
此节点的父节点，如果此节点没有父节点，则为 null
parent() - 类 org.omg.CORBA.Context 中的方法
检索此 Context 对象的父对象。
PARENT_CHANGED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示 HIERARCHY_CHANGED 事件是通过 reparenting 操作生成的。
PARENT_WINDOW_OF - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个对象的父窗口。
PARENT_WINDOW_OF_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个或多个对象之间的 PARENT_WINDOW_OF 关系已更改。
parentOf(ThreadGroup) - 类 java.lang.ThreadGroup 中的方法
测试此线程组是否为线程组参数或其祖先线程组之一。
parentTag - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的变量
要在文档中检查的 Tag。
park(Object) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度，在许可可用之前禁用当前线程。
park() - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度，禁用当前线程，除非许可可用。
parkNanos(Object, long) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度，在许可可用前禁用当前线程，并最多等待指定的等待时间。
parkNanos(long) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度禁用当前线程，最多等待指定的等待时间，除非许可可用。
parkUntil(Object, long) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度，在指定的时限前禁用当前线程，除非许可可用。
parkUntil(long) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度，在指定的时限前禁用当前线程，除非许可可用。
parse(String) - 类 java.net.HttpCookie 中的静态方法
根据 set-cookie 或 set-cookie2 头字符串构造 cookie。
parse(String, ParsePosition) - 类 java.text.ChoiceFormat 中的方法
解析输入文本中的一个 Number。
parse(String) - 类 java.text.DateFormat 中的方法
从给定字符串的开始解析文本，以生成一个日期。
parse(String, ParsePosition) - 类 java.text.DateFormat 中的方法
根据给定的解析位置开始解析日期/时间字符串。
parse(String, ParsePosition) - 类 java.text.DecimalFormat 中的方法
解析字符串中的文本，以生成一个 Number。
parse(String, ParsePosition) - 类 java.text.MessageFormat 中的方法
解析字符串。
parse(String) - 类 java.text.MessageFormat 中的方法
从给定字符串的开始位置解析文本，以生成一个对象数组。
parse(String, ParsePosition) - 类 java.text.NumberFormat 中的方法
如果可能则返回 Long （例如，在 [Long.MIN_VALUE, Long.MAX_VALUE] 范围内且没有小数），否则返回 Double。
parse(String) - 类 java.text.NumberFormat 中的方法
解析给定字符串开头的文本，生成一个数值。
parse(String, ParsePosition) - 类 java.text.SimpleDateFormat 中的方法
解析字符串的文本，生成 Date。
parse(String) - 类 java.util.Date 中的静态方法
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。
parse(String) - 类 java.util.logging.Level 中的静态方法
将级别名称字符串解析成 Level。
parse(String) - 类 javax.activation.MimeTypeParameterList 中的方法
将参数列表从一个 String 解析出来的例程。
parse(String) - 接口 javax.naming.NameParser 中的方法
将某一名称解析成其组件。
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - 类 javax.swing.text.html.HTMLEditorKit.Parser 中的方法
解析给定的流并通过解析的结果驱动给定的回调。
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
parse(Reader) - 类 javax.swing.text.html.parser.Parser 中的方法
在给定 DTD 的情况下，解析 HTML 流。
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - 类 javax.swing.text.html.parser.ParserDelegator 中的方法
parse(InputStream) - 类 javax.xml.parsers.DocumentBuilder 中的方法
将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
parse(InputStream, String) - 类 javax.xml.parsers.DocumentBuilder 中的方法
将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
parse(String) - 类 javax.xml.parsers.DocumentBuilder 中的方法
将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
parse(File) - 类 javax.xml.parsers.DocumentBuilder 中的方法
将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
parse(InputSource) - 类 javax.xml.parsers.DocumentBuilder 中的方法
将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
parse(InputStream, HandlerBase) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
parse(InputStream, HandlerBase, String) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
parse(InputStream, DefaultHandler) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
parse(InputStream, DefaultHandler, String) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
parse(String, HandlerBase) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。
parse(String, DefaultHandler) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。
parse(File, HandlerBase) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 HandlerBase 将指定文件的内容解析为 XML。
parse(File, DefaultHandler) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
parse(InputSource, HandlerBase) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。
parse(InputSource, DefaultHandler) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
parse(LSInput) - 接口 org.w3c.dom.ls.LSParser 中的方法
从通过 LSInput 标识的资源中解析 XML 文档。
parse(String) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
解析 XML 文档。
parse(InputSource) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
解析 XML 文档。
parse(InputSource) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
解析一个文档。
parse(String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
解析一个文档。
parse(String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
解析文档。
parse(InputSource) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
解析文档。
parse(InputSource) - 接口 org.xml.sax.Parser 中的方法
已过时。 解析 XML 文档。
parse(String) - 接口 org.xml.sax.Parser 中的方法
已过时。 从系统标识符 (URI) 解析 XML 文档。
parse(InputSource) - 接口 org.xml.sax.XMLReader 中的方法
解析 XML 文档。
parse(String) - 接口 org.xml.sax.XMLReader 中的方法
从系统标识符 (URI) 解析 XML 文档。
PARSE_ERR - 异常 org.w3c.dom.ls.LSException 中的静态变量
如果尝试使用 LSParser 加载文档或 XML 片段并且处理已经停止。
parseAnySimpleType(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
返回包含简单类型的词汇表示形式的字符串。
parseAnySimpleType(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
返回包含简单类型的词汇表示形式的字符串。
parseBase64Binary(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个字节数组。
parseBase64Binary(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个字节数组。
parseBoolean(String) - 类 java.lang.Boolean 中的静态方法
将字符串参数解析为 boolean 值。
parseBoolean(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 boolean 值。
parseBoolean(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 boolean 值。
parseBuffer - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的变量
parseByte(String) - 类 java.lang.Byte 中的静态方法
将 string 参数解析为有符号的十进制 byte。
parseByte(String, int) - 类 java.lang.Byte 中的静态方法
将 string 参数解析为一个有符号的 byte，其基数由第二个参数指定。
parseByte(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 byte 值。
parseByte(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 byte 值。
ParseConversionEvent - javax.xml.bind 中的 接口
此事件指示将 XML 数据中的字符串转换为目标 Java 数据类型的值时遇到一个问题。
ParseConversionEventImpl - javax.xml.bind.helpers 中的 类
ParseConversionEvent 接口的默认实现。
ParseConversionEventImpl(int, String, ValidationEventLocator) - 类 javax.xml.bind.helpers.ParseConversionEventImpl 的构造方法
创建新的 ParseConversionEventImpl。
ParseConversionEventImpl(int, String, ValidationEventLocator, Throwable) - 类 javax.xml.bind.helpers.ParseConversionEventImpl 的构造方法
创建新的 ParseConversionEventImpl。
parseDate(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 Calendar 值。
parseDate(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 Calendar 值。
parseDateTime(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 Calendar 值。
parseDateTime(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 Calendar 值。
parseDecimal(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 BigDecimal 值。
parseDecimal(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 BigDecimal 值。
parseDouble(String) - 类 java.lang.Double 中的静态方法
返回一个新的 double 值，该值被初始化为用指定 String 表示的值，这与 Double 类的 valueOf 方法一样。
parseDouble(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 double 值。
parseDouble(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 double 值。
parseDTDMarkup() - 类 javax.swing.text.html.parser.Parser 中的方法
解析 Document Type Declaration 标记声明。
ParseException - java.text 中的 异常
表示解析时出现意外错误。
ParseException(String, int) - 异常 java.text.ParseException 的构造方法
构造带指定详细消息和偏移量的 ParseException。
parseFloat(String) - 类 java.lang.Float 中的静态方法
返回一个新的 float 值，该值被初始化为用指定 String 表示的值，这与 Float 类的 valueOf 方法一样。
parseFloat(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 float 值。
parseFloat(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 float 值。
parseHexBinary(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个字节数组。
parseHexBinary(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个字节数组。
parseInt(String, int) - 类 java.lang.Integer 中的静态方法
使用第二个参数指定的基数，将字符串参数解析为有符号的整数。
parseInt(String) - 类 java.lang.Integer 中的静态方法
将字符串参数作为有符号的十进制整数进行解析。
parseInt(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 int 值。
parseInt(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 int 值。
parseInteger(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 BigInteger 值。
parseInteger(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 BigInteger 值。
parseLevel(String) - 类 java.rmi.server.LogStream 中的静态方法
已过时。 无替代版本
parseLong(String, int) - 类 java.lang.Long 中的静态方法
将 string 参数解析为有符号的 long，基数由第二个参数指定。
parseLong(String) - 类 java.lang.Long 中的静态方法
将 string 参数解析为有符号十进制 long。
parseLong(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 long 值。
parseLong(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 long 值。
parseMarkupDeclarations(StringBuffer) - 类 javax.swing.text.html.parser.Parser 中的方法
解析标记声明。
parseNumbers() - 类 java.io.StreamTokenizer 中的方法
指定此标记生成器应解析的数字。
parseObject(String, ParsePosition) - 类 java.text.DateFormat 中的方法
解析字符串中的文本，以生成一个 Date。
parseObject(String, ParsePosition) - 类 java.text.Format 中的方法
解析字符串文本，生成一个对象。
parseObject(String) - 类 java.text.Format 中的方法
从给定字符串的开始处解析文本以生成一个对象。
parseObject(String, ParsePosition) - 类 java.text.MessageFormat 中的方法
解析字符串文本，生成一个对象数组。
parseObject(String, ParsePosition) - 类 java.text.NumberFormat 中的方法
解析字符串中的文本，以生成一个 Number。
ParsePosition - java.text 中的 类
ParsePosition 是 Format 及其子类所使用的简单类，用来在解析过程中跟踪当前位置。
ParsePosition(int) - 类 java.text.ParsePosition 的构造方法
创建一个具有给定初始索引的新 ParsePosition。
parseQName(String, NamespaceContext) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 byte 值。
parseQName(String, NamespaceContext) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 QName 值。
Parser - javax.swing.text.html.parser 中的 类
一个简单的 DTD 驱动的 HTML 解析器。
Parser(DTD) - 类 javax.swing.text.html.parser.Parser 的构造方法
Parser - org.xml.sax 中的 接口
已过时。 此接口已经被 SAX2 XMLReader 接口取代，后者包括名称空间支持。
ParserAdapter - org.xml.sax.helpers 中的 类
将 SAX1 Parser 适配为 SAX2 XMLReader。
ParserAdapter() - 类 org.xml.sax.helpers.ParserAdapter 的构造方法
构造一个新解析器适配器。
ParserAdapter(Parser) - 类 org.xml.sax.helpers.ParserAdapter 的构造方法
构造一个新的解析器适配器。
ParserConfigurationException - javax.xml.parsers 中的 异常
指示一个严重的配置错误。
ParserConfigurationException() - 异常 javax.xml.parsers.ParserConfigurationException 的构造方法
创建一个新的不带详细消息的 ParserConfigurationException。
ParserConfigurationException(String) - 异常 javax.xml.parsers.ParserConfigurationException 的构造方法
创建一个新的 ParserConfigurationException，并将 String 指定为一个错误消息。
ParserDelegator - javax.swing.text.html.parser 中的 类
负责每次在调用其 parse 方法时启动一个新的 DocumentParser。
ParserDelegator() - 类 javax.swing.text.html.parser.ParserDelegator 的构造方法
ParserFactory - org.xml.sax.helpers 中的 类
已过时。 此类与不推荐使用的 Parser 接口一起使用。
parseServerAuthority() - 类 java.net.URI 中的方法
尝试将此 URI 的授权组成部分（如果已定义）解析为用户信息、主机和端口组成部分。
parseShort(String) - 类 java.lang.Short 中的静态方法
将字符串参数解析为有符号的十进制 short。
parseShort(String, int) - 类 java.lang.Short 中的静态方法
将字符串参数解析为由第二个参数指定的基数中的有符号的 short。
parseShort(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 short 值。
parseShort(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 short 值。
parseString(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将词汇 XSD 字符串参数转换为一个 String 值。
parseString(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个字符串。
parseTime(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 Calendar 值。
parseTime(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 Calendar 值。
parseUnsignedInt(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 long 值。
parseUnsignedInt(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 long 值。
parseUnsignedShort(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 int 值。
parseUnsignedShort(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 int 值。
parseURI(String) - 接口 org.w3c.dom.ls.LSParser 中的方法
从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。
parseURL(URL, String, int, int) - 类 java.net.URLStreamHandler 中的方法
将 URL 的字符表示形式解析为 URL 对象。
parseWithContext(LSInput, Node, short) - 接口 org.w3c.dom.ls.LSParser 中的方法
从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。
PartialResultException - javax.naming 中的 异常
抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
PartialResultException(String) - 异常 javax.naming.PartialResultException 的构造方法
使用指定的解释消息构造一个新的异常实例。
PartialResultException() - 异常 javax.naming.PartialResultException 的构造方法
构造一个新的 PartialResultException 实例。
PASS - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "pass"，某些属性的可能值。
PASS_FILE_PFX - 接口 java.util.jar.Pack200.Packer 中的静态变量
指出文件应该按字节传递（无压缩）。
passComplete(ImageReader, BufferedImage) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告当前读操作已经完成一个逐步传递。
passStarted(ImageReader, BufferedImage, int, int, int, int, int, int, int, int[]) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告当前的读操作将开始逐步传递 (progressive pass)。
PASSWORD_FIELD - 类 javax.swing.plaf.synth.Region 中的静态变量
PasswordField 的 region。
PASSWORD_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
标准属性：用于验证的密码。
PASSWORD_TEXT - 类 javax.accessibility.AccessibleRole 中的静态变量
用于密码或文本内容不显示给用户的其他地方的文本对象。
PasswordAuthentication - java.net 中的 类
PasswordAuthentication 类是供 Authenticator 使用的数据持有者。
PasswordAuthentication(String, char[]) - 类 java.net.PasswordAuthentication 的构造方法
根据给定用户名和密码创建新的 PasswordAuthentication 对象。
PasswordCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 PasswordCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取密码信息。
PasswordCallback(String, boolean) - 类 javax.security.auth.callback.PasswordCallback 的构造方法
构造带提示和布尔值的 PasswordCallback，该布尔值指定键入密码时是否应该显示该密码。
PasswordView - javax.swing.text 中的 类
实现适用于 JPasswordField UI 实现的视图。
PasswordView(Element) - 类 javax.swing.text.PasswordView 的构造方法
构造在元素上包装的新视图。
paste(int) - 接口 javax.accessibility.AccessibleEditableText 中的方法
将系统剪贴板中的文本粘贴到文本的指定索引开始处。
paste(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
将系统剪贴板中的文本粘贴到指定文本的文件开始处。
paste(int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
将系统剪贴板中的文本粘贴到指定索引的文本开始处。
paste() - 类 javax.swing.text.JTextComponent 中的方法
将系统剪贴板的内容传输到关联的文本模型中。
pasteAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
将系统剪贴板内容粘贴到选定区域、如果未选中任何内容，则粘贴到插入符之前的动作名称。
Patch - javax.sound.midi 中的 类
一个 Patch 对象，用于表示 MIDI 合成器上的某个位置，其中存储（加载）了单个乐器。
Patch(int, int) - 类 javax.sound.midi.Patch 的构造方法
从指定的库和程序号构造一个新的 patch 对象。
path - 类 javax.swing.event.TreeExpansionEvent 中的变量
到达此事件表示的值的路径。
path - 类 javax.swing.event.TreeModelEvent 中的变量
到达已更改节点的父节点的路径。
Path2D - java.awt.geom 中的 类
Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。
Path2D.Double - java.awt.geom 中的 类
Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
Path2D.Double() - 类 java.awt.geom.Path2D.Double 的构造方法
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的双精度空 Path2D 对象。
Path2D.Double(int) - 类 java.awt.geom.Path2D.Double 的构造方法
根据指定旋绕规则构造一个新的双精度空 Path2D 对象，以控制需要定义路径内部的操作。
Path2D.Double(int, int) - 类 java.awt.geom.Path2D.Double 的构造方法
根据指定旋绕规则和指定初始容量构造一个新的双精度空 Path2D 对象，以存储路径段。
Path2D.Double(Shape) - 类 java.awt.geom.Path2D.Double 的构造方法
根据任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Double(Shape, AffineTransform) - 类 java.awt.geom.Path2D.Double 的构造方法
根据由 AffineTransform 对象变换的任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Float - java.awt.geom 中的 类
Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
Path2D.Float() - 类 java.awt.geom.Path2D.Float 的构造方法
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的单精度空 Path2D 对象。
Path2D.Float(int) - 类 java.awt.geom.Path2D.Float 的构造方法
根据指定旋绕规则构造一个新的单精度空 Path2D 对象，以控制需要定义路径内部的操作。
Path2D.Float(int, int) - 类 java.awt.geom.Path2D.Float 的构造方法
根据指定旋绕规则和指定初始容量构造一个新的单精度空 Path2D 对象，以存储路径段。
Path2D.Float(Shape) - 类 java.awt.geom.Path2D.Float 的构造方法
根据任意 Shape 对象构造一个新的单精度 Path2D 对象。
Path2D.Float(Shape, AffineTransform) - 类 java.awt.geom.Path2D.Float 的构造方法
根据 AffineTransform 对象变换的任意 Shape 对象构造一个新的单精度 Path2D 对象。
PATH_INFO - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：请求路径信息
pathByAddingChild(Object) - 类 javax.swing.tree.TreePath 中的方法
返回包含此对象的所有元素加上 child 的新路径。
pathFromAncestorEnumeration(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回沿着从 ancestor 到此节点的路径的一个枚举。
PathIterator - java.awt.geom 中的 接口
PathIterator 接口通过允许调用者一次一段地获取边界的路径，为实现 Shape 接口的对象提供返回其边界几何形状的机制。
paths - 类 javax.swing.event.TreeSelectionEvent 中的变量
此事件表示的路径。
pathSeparator - 类 java.io.File 中的静态变量
与系统有关的路径分隔符，为了方便，它被表示为一个字符串。
pathSeparatorChar - 类 java.io.File 中的静态变量
与系统有关的路径分隔符。
pathToPoint(Point2D, boolean, Point2D) - 类 java.awt.font.LayoutPath 中的方法
将相对于路径的位置转换为用户坐标中的点。
pathWasCollapsed(TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
在折叠 VisibleTreeNode 后，从其传递消息。
pathWasExpanded(TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
在展开 VisibleTreeNode 后，从其传递消息。
pattern() - 类 java.util.regex.Matcher 中的方法
返回由此匹配器解释的模式。
Pattern - java.util.regex 中的 类
正则表达式的编译表示形式。
pattern() - 类 java.util.regex.Pattern 中的方法
返回在其中编译过此模式的正则表达式。
PatternSyntaxException - java.util.regex 中的 异常
抛出未经检查的异常，表明正则表达式模式中的语法错误。
PatternSyntaxException(String, String, int) - 异常 java.util.regex.PatternSyntaxException 的构造方法
构造此类的新实例。
PAUSE - 类 java.awt.Event 中的静态变量
Pause 键，一个非 ASCII 操作键。
PAUSED - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
已经暂停了打印机并且打印机的 PrinterState 为 STOPPED。
PBEKey - javax.crypto.interfaces 中的 接口
调用者 PBE 密钥接口。
PBEKeySpec - javax.crypto.spec 中的 类
可随同基于密码的加密法 (PBE) 使用的供用户选择的密码。
PBEKeySpec(char[]) - 类 javax.crypto.spec.PBEKeySpec 的构造方法
带有一个密码的构造方法。
PBEKeySpec(char[], byte[], int, int) - 类 javax.crypto.spec.PBEKeySpec 的构造方法
带有生成可变密钥大小的 PBE 密码的 PBEKey 时使用的一个密码、salt、迭代计数以及导出密钥长度的构造方法。
PBEKeySpec(char[], byte[], int) - 类 javax.crypto.spec.PBEKeySpec 的构造方法
带有生成固定密钥大小的 PBE 密码的 PBEKey 时使用的一个密码、salt、迭代数的构造方法。
PBEParameterSpec - javax.crypto.spec 中的 类
此类指定随同以密码为基础的加密法 (PBE) 使用的参数集合，该加密法在 PKCS #5 标准中定义。
PBEParameterSpec(byte[], int) - 类 javax.crypto.spec.PBEParameterSpec 的构造方法
为 PKCS #5 标准中所定义的基于密码的加密法构造一个参数集合。
pcdata - 类 javax.swing.text.html.parser.DTD 中的变量
PCL - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
PCL - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
PCL - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
PCM_SIGNED - 类 javax.sound.sampled.AudioFormat.Encoding 中的静态变量
指定有符号的线性 PCM 数据。
PCM_UNSIGNED - 类 javax.sound.sampled.AudioFormat.Encoding 中的静态变量
指定无符号的线性 PCM 数据。
pcSupport - 类 java.beans.beancontext.BeanContextChildSupport 中的变量
与此 BeanContextChildSupport 相关联的 PropertyChangeSupport。
PDF - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "application/pdf"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
PDF - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
PDF - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
PDLOverrideSupported - javax.print.attribute.standard 中的 类
PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
PDLOverrideSupported(int) - 类 javax.print.attribute.standard.PDLOverrideSupported 的构造方法
构造具有给定整数值的新 PDLOverrideSupported 枚举值。
peek(InetAddress) - 类 java.net.DatagramSocketImpl 中的方法
查看包来自哪里。
peek() - 类 java.util.ArrayDeque 中的方法
获取，但不移除此双端队列所表示的队列的头；如果此双端队列为空，则返回 null。
peek() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
peek() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取但不移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
peek() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
peek() - 类 java.util.concurrent.DelayQueue 中的方法
获取但不移除此队列的头部；如果此队列为空，则返回 null。
peek() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
peek() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
peek() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
peek() - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 null。
peek() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
peek() - 类 java.util.LinkedList 中的方法
获取但不移除此列表的头（第一个元素）。
peek() - 类 java.util.PriorityQueue 中的方法
peek() - 接口 java.util.Queue 中的方法
获取但不移除此队列的头；如果此队列为空，则返回 null。
peek() - 类 java.util.Stack 中的方法
查看堆栈顶部的对象，但不从堆栈中移除它。
peek() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
peek() - 接口 javax.xml.stream.XMLEventReader 中的方法
检查下一个 XMLEvent，但不从流中读取它。
peekData(DatagramPacket) - 类 java.net.DatagramSocketImpl 中的方法
查看包来自哪里。
peekEvent() - 类 java.awt.EventQueue 中的方法
返回 EventQueue 上的第一个事件，而不移除它。
peekEvent(int) - 类 java.awt.EventQueue 中的方法
返回指定 id（如果有） 的第一个事件。
peekFirst() - 类 java.util.ArrayDeque 中的方法
peekFirst() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
peekFirst() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。
peekFirst() - 类 java.util.LinkedList 中的方法
获取但不移除此列表的第一个元素；如果此列表为空，则返回 null。
peekLast() - 类 java.util.ArrayDeque 中的方法
peekLast() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
peekLast() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。
peekLast() - 类 java.util.LinkedList 中的方法
获取但不移除此列表的最后一个元素；如果此列表为空，则返回 null。
PENDING - 类 javax.print.attribute.standard.JobState 中的静态变量
作业为要开始处理的候选作业，但尚未开始处理。
PENDING_HELD - 类 javax.print.attribute.standard.JobState 中的静态变量
由于某些原因，作业不是要处理的候选作业，但当这些原因不再存在时，作业将返回 PENDING 状态。
PERCENT - 类 java.text.NumberFormat.Field 中的静态变量
标识百分数字段的常量。
perform_work() - 类 org.omg.CORBA.ORB 中的方法
如果该操作由主线程调用，则执行与实现有关的单元操作。
performDefaultLayout() - 类 java.awt.font.GlyphVector 中的方法
为此 GlyphVector 中的每个字形分配默认位置。
PERMILLE - 类 java.text.NumberFormat.Field 中的静态变量
标识千分数字段的常量。
Permission - java.security.acl 中的 接口
此接口表示一个权限，比如授予访问资源的特定类型的权限。
Permission - java.security 中的 类
表示访问系统资源的抽象类。
Permission(String) - 类 java.security.Permission 的构造方法
构造具有指定名称的权限。
PermissionCollection - java.security 中的 类
表示 Permission 对象集合的抽象类。
PermissionCollection() - 类 java.security.PermissionCollection 的构造方法
permissions() - 接口 java.security.acl.AclEntry 中的方法
返回此 ACL 项中各个权限的枚举。
Permissions - java.security 中的 类
此类表示一个不同种类的 Permission 集合。
Permissions() - 类 java.security.Permissions 的构造方法
创建一个不包含任何 PermissionCollection 的新 Permissions 对象。
PERSIST - 类 javax.swing.JFormattedTextField 中的静态变量
标识丢失焦点时，应该保留编辑值的常量。
PERSIST_STORE - org.omg.CORBA 中的 异常
此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
PERSIST_STORE() - 异常 org.omg.CORBA.PERSIST_STORE 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 PERSIST_STORE 异常。
PERSIST_STORE(String) - 异常 org.omg.CORBA.PERSIST_STORE 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 PERSIST_STORE 异常。
PERSIST_STORE(int, CompletionStatus) - 异常 org.omg.CORBA.PERSIST_STORE 的构造方法
使用指定次要代码和完成状态构造一个 PERSIST_STORE 异常。
PERSIST_STORE(String, int, CompletionStatus) - 异常 org.omg.CORBA.PERSIST_STORE 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 PERSIST_STORE 异常。
PersistenceDelegate - java.beans 中的 类
PersistenceDelegate 类负责根据类的公共 API 中的方法表示给定类的实例状态。
PersistenceDelegate() - 类 java.beans.PersistenceDelegate 的构造方法
PERSISTENT - 类 org.omg.PortableServer.LifespanPolicyValue 中的静态变量
PersistentMBean - javax.management 中的 接口
此类是一个由希望是持久性的 MBean 实现的接口。
PERSONAL - 类 java.awt.PageAttributes.MediaType 中的静态变量
PERSONAL_ENVELOPE 的别名。
PERSONAL_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
6 3/4 envelope (3 5/8 x 6 1/2 in) 的 MediaType 实例。
PERSONAL_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 Personal 信封尺寸，3.625 inch × 6.5 inch。
PERSONAL_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
私人信封尺寸。
PGDN - 类 java.awt.Event 中的静态变量
Page Down 键，一个非 ASCII 操作键。
PGPData - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML PGPData 元素的表示形式。
PGUP - 类 java.awt.Event 中的静态变量
Page Up 键，一个非 ASCII 操作键。
PhantomReference<T> - java.lang.ref 中的 类
虚引用对象，在回收器确定其指示对象可另外回收之后，被加入队列。
PhantomReference(T, ReferenceQueue<? super T>) - 类 java.lang.ref.PhantomReference 的构造方法
创建一个引用给定对象的新的虚引用，并向给定队列注册它。
PHONETIC_EXTENSIONS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Phonetic Extensions”Unicode 字符块的常量。
PHYSICAL - 类 java.awt.PageAttributes.OriginType 中的静态变量
用于指定物理原点的 OriginType 实例。
PI - 类 java.lang.Math 中的静态变量
比任何其他值都更接近 pi（即圆的周长与直径之比）的 double 值。
PI - 类 java.lang.StrictMath 中的静态变量
比任何其他值都更接近 pi（即圆的周长与直径之比）的 double 值。
PI - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
PI_DISABLE_OUTPUT_ESCAPING - 接口 javax.xml.transform.Result 中的静态变量
如果结果树禁用了输出转义，则为发送处理指令的名称。
PI_ENABLE_OUTPUT_ESCAPING - 接口 javax.xml.transform.Result 中的静态变量
如果结果树在已接收 PI_DISABLE_OUTPUT_ESCAPING 处理指令后的某时刻启用了输出转义，则发送处理指令的名称。
PIE - 类 java.awt.geom.Arc2D 中的静态变量
闭合类型，用于通过从弧段的起始点到完整椭圆的中心，再从圆心到弧段的结束点画直线来闭合的弧。
pink - 类 java.awt.Color 中的静态变量
粉红色。
PINK - 类 java.awt.Color 中的静态变量
粉红色。
Pipe - java.nio.channels 中的 类
实现单向管道传送的通道对。
Pipe() - 类 java.nio.channels.Pipe 的构造方法
初始化此类的一个新实例。
Pipe.SinkChannel - java.nio.channels 中的 类
表示 Pipe 的可写入结尾的通道。
Pipe.SinkChannel(SelectorProvider) - 类 java.nio.channels.Pipe.SinkChannel 的构造方法
初始化此类的一个新实例。
Pipe.SourceChannel - java.nio.channels 中的 类
表示 Pipe 的可读取结尾的通道。
Pipe.SourceChannel(SelectorProvider) - 类 java.nio.channels.Pipe.SourceChannel 的构造方法
构造此类的一个新实例。
PIPE_SIZE - 类 java.io.PipedInputStream 中的静态变量
管道循环输入缓冲区的默认大小。
PipedInputStream - java.io 中的 类
管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。
PipedInputStream(PipedOutputStream) - 类 java.io.PipedInputStream 的构造方法
创建 PipedInputStream，使其连接到管道输出流 src。
PipedInputStream(PipedOutputStream, int) - 类 java.io.PipedInputStream 的构造方法
创建一个 PipedInputStream，使其连接到管道输出流 src，并对管道缓冲区使用指定的管道大小。
PipedInputStream() - 类 java.io.PipedInputStream 的构造方法
创建尚未连接的 PipedInputStream。
PipedInputStream(int) - 类 java.io.PipedInputStream 的构造方法
创建一个尚未连接的 PipedInputStream，并对管道缓冲区使用指定的管道大小。
PipedOutputStream - java.io 中的 类
可以将管道输出流连接到管道输入流来创建通信管道。
PipedOutputStream(PipedInputStream) - 类 java.io.PipedOutputStream 的构造方法
创建连接到指定管道输入流的管道输出流。
PipedOutputStream() - 类 java.io.PipedOutputStream 的构造方法
创建尚未连接到管道输入流的管道输出流。
PipedReader - java.io 中的 类
传送的字符输入流。
PipedReader(PipedWriter) - 类 java.io.PipedReader 的构造方法
创建连接到传送 writer src 的 PipedReader。
PipedReader(PipedWriter, int) - 类 java.io.PipedReader 的构造方法
创建一个 PipedReader，使其连接到管道 writer src，并对管道缓冲区使用指定的管道大小。
PipedReader() - 类 java.io.PipedReader 的构造方法
创建尚未连接的 PipedReader。
PipedReader(int) - 类 java.io.PipedReader 的构造方法
创建一个尚未连接的 PipedReader，并对管道缓冲区使用指定的管道大小。
PipedWriter - java.io 中的 类
传送的字符输出流。
PipedWriter(PipedReader) - 类 java.io.PipedWriter 的构造方法
创建传送 writer，使其连接到指定的传送 reader。
PipedWriter() - 类 java.io.PipedWriter 的构造方法
创建一个尚未连接到传送 reader 的传送 writer。
PITCH_BEND - 类 javax.sound.midi.ShortMessage 中的静态变量
PITCH_BEND 消息的命令值（0xE0 或 224）
pixel_bits - 类 java.awt.image.ColorModel 中的变量
像素总位数。
PixelGrabber - java.awt.image 中的 类
PixelGrabber 类实现可以附加在 Image 或 ImageProducer 对象上获得图像像素子集的 ImageConsumer。
PixelGrabber(Image, int, int, int, int, int[], int, int) - 类 java.awt.image.PixelGrabber 的构造方法
创建一个 PixelGrabber 对象，以从指定图像将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。
PixelGrabber(ImageProducer, int, int, int, int, int[], int, int) - 类 java.awt.image.PixelGrabber 的构造方法
创建一个 PixelGrabber 对象，以从指定 ImageProducer 所生成的图像中将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。
PixelGrabber(Image, int, int, int, int, boolean) - 类 java.awt.image.PixelGrabber 的构造方法
创建一个 PixelGrabber 对象，以从指定的图像中抓取像素矩形部分 (x, y, w, h)。
PixelInterleavedSampleModel - java.awt.image 中的 类
此类表示以像素交替方式存储的图像数据，其中像素的每个采样占用 DataBuffer 的一个数据元素。
PixelInterleavedSampleModel(int, int, int, int, int, int[]) - 类 java.awt.image.PixelInterleavedSampleModel 的构造方法
构造一个带指定参数的 PixelInterleavedSampleModel。
pixelStride - 类 java.awt.image.ComponentSampleModel 中的变量
由此 ComponentSampleModel 所描述的图像数据区域的像素间距（以数据数组元素表示）。
PKCS8EncodedKeySpec - java.security.spec 中的 类
此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。
PKCS8EncodedKeySpec(byte[]) - 类 java.security.spec.PKCS8EncodedKeySpec 的构造方法
根据给定的编码密钥创建一个新的 PKCS8EncodedKeySpec。
PKIXBuilderParameters - java.security.cert 中的 类
用作 PKIX CertPathBuilder 算法的输入的参数。
PKIXBuilderParameters(Set<TrustAnchor>, CertSelector) - 类 java.security.cert.PKIXBuilderParameters 的构造方法
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。
PKIXBuilderParameters(KeyStore, CertSelector) - 类 java.security.cert.PKIXBuilderParameters 的构造方法
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXCertPathBuilderResult - java.security.cert 中的 类
此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。
PKIXCertPathBuilderResult(CertPath, TrustAnchor, PolicyNode, PublicKey) - 类 java.security.cert.PKIXCertPathBuilderResult 的构造方法
创建包含指定参数的 PKIXCertPathBuilderResult 实例。
PKIXCertPathChecker - java.security.cert 中的 类
对 X509Certificate 执行一种或多种检查的抽象类。
PKIXCertPathChecker() - 类 java.security.cert.PKIXCertPathChecker 的构造方法
默认的构造方法。
PKIXCertPathValidatorResult - java.security.cert 中的 类
此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。
PKIXCertPathValidatorResult(TrustAnchor, PolicyNode, PublicKey) - 类 java.security.cert.PKIXCertPathValidatorResult 的构造方法
创建包含指定参数的 PKIXCertPathValidatorResult 实例。
PKIXParameters - java.security.cert 中的 类
用作 PKIX CertPathValidator 算法的输入的参数。
PKIXParameters(Set<TrustAnchor>) - 类 java.security.cert.PKIXParameters 的构造方法
创建具有指定最受信任 CA Set 的 PKIXParameters 的实例。
PKIXParameters(KeyStore) - 类 java.security.cert.PKIXParameters 的构造方法
创建一个 PKIXParameters 实例，它根据指定 KeyStore 中所包含的受信证书项生成最受信任的 CA 集。
PLAIN - 类 java.awt.Font 中的静态变量
普通样式常量。
PLAIN_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
PLAIN_MESSAGE - 类 javax.swing.JOptionPane 中的静态变量
未使用图标。
PlainDocument - javax.swing.text 中的 类
维护无任何字符属性的普通文档。
PlainDocument() - 类 javax.swing.text.PlainDocument 的构造方法
构造一个纯文本文档。
PlainDocument(AbstractDocument.Content) - 类 javax.swing.text.PlainDocument 的构造方法
构造一个纯文本文档。
plainTextFlavor - 类 java.awt.datatransfer.DataFlavor 中的静态变量
已过时。 从 1.3 开始。使用 DataFlavor.getReaderForText(Transferable) 代替 Transferable.getTransferData(DataFlavor.plainTextFlavor)。
PlainView - javax.swing.text 中的 类
实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。
PlainView(Element) - 类 javax.swing.text.PlainView 的构造方法
构造在元素上包装的新 PlainView。
play(URL) - 类 java.applet.Applet 中的方法
播放指定绝对 URL 处的音频剪辑。
play(URL, String) - 类 java.applet.Applet 中的方法
播放音频剪辑，给定了 URL 及与之相对的说明符。
play() - 接口 java.applet.AudioClip 中的方法
开始播放此音频剪辑。
playSound(Action) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
如有必要，在 audioAction 上调用 actionPerformed 以播放声音。
pluginClassName - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含关联的插件类名称的 String，该字符串最初为 null。
plus() - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其值为 (+this)，其标度为 this.scale()。
plus(MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (+this) 的 BigDecimal（根据上下文设置进行舍入）。
PLUS - 类 javax.management.Query 中的静态变量
表示 Query.plus(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
plus(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个二进制表达式，表示两个数值的和，或者两个字符串值的串接。
PM - 类 java.util.Calendar 中的静态变量
指示从中午到午夜之前这段时间的 Calendar.AM_PM 字段值。
PNG - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "image/png"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
PNG - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "image/png"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
PNG - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "image/png"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
POA - org.omg.PortableServer 中的 接口
POA 对象管理对象集合的实现。
poa(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
method _poa() 等效于调用 PortableServer::Current:get_POA。
POAHelper - org.omg.PortableServer 中的 类
POA 对象管理对象集合的实现。
POAHelper() - 类 org.omg.PortableServer.POAHelper 的构造方法
POAManager - org.omg.PortableServer 中的 接口
每个 POA 对象都有一个关联的 POAManager 对象。
POAManagerOperations - org.omg.PortableServer 中的 接口
每个 POA 对象具有一个关联的 POAManager 对象。
POAOperations - org.omg.PortableServer 中的 接口
POA 对象管理对象集合的实现。
Point - java.awt 中的 类
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Point() - 类 java.awt.Point 的构造方法
在坐标空间的原点 (0,0) 构造并初始化一个点。
Point(Point) - 类 java.awt.Point 的构造方法
构造并初始化一个与指定的 Point 对象具有相同位置的点。
Point(int, int) - 类 java.awt.Point 的构造方法
在坐标空间中指定的 (x,y) 位置构造并初始化一个点。
Point2D - java.awt.geom 中的 类
Point2D 类定义表示 (x,y) 坐标空间中位置的点。
Point2D() - 类 java.awt.geom.Point2D 的构造方法
这是一个无法直接实例化的抽象类。
Point2D.Double - java.awt.geom 中的 类
Double 类以 double 精度定义指定的点。
Point2D.Double() - 类 java.awt.geom.Point2D.Double 的构造方法
使用坐标 (0,0) 构造并初始化一个 Point2D。
Point2D.Double(double, double) - 类 java.awt.geom.Point2D.Double 的构造方法
使用指定坐标构造并初始化一个 Point2D。
Point2D.Float - java.awt.geom 中的 类
Float 类以 float 精度定义指定的点。
Point2D.Float() - 类 java.awt.geom.Point2D.Float 的构造方法
使用坐标 (0,0) 构造并初始化一个 Point2D。
Point2D.Float(float, float) - 类 java.awt.geom.Point2D.Float 的构造方法
使用指定坐标构造并初始化一个 Point2D。
POINT_INFINITY - 类 java.security.spec.ECPoint 中的静态变量
这就将该点定义为无穷大。
PointerInfo - java.awt 中的 类
描述指针位置的类。
pointSize - 类 java.awt.Font 中的变量
以 float 形式表示的 Font 的磅值大小。
pointToPath(Point2D, Point2D) - 类 java.awt.font.LayoutPath 中的方法
将用户空间中的点转换为相对于路径的位置。
Policy - java.security 中的 类
Policy 对象负责确定在 Java 运行时环境中执行的代码是否有权执行安全敏感的操作。
Policy() - 类 java.security.Policy 的构造方法
Policy - javax.security.auth 中的 类
已过时。 从 JDK 1.4 版本开始，由 java.security.Policy 取代。java.security.Policy 有一个方法：
        public PermissionCollection getPermissions
            (java.security.ProtectionDomain pd)
ProtectionDomain 有一个构造方法：
        public ProtectionDomain
            (CodeSource cs,
             PermissionCollection permissions,
             ClassLoader loader,
             Principal[] principals)
这两个 API 为调用者提供向 Policy 查询基于 Principal 的 Permission 条目的方法。
Policy() - 类 javax.security.auth.Policy 的构造方法
已过时。 唯一的构造方法。
Policy - org.omg.CORBA 中的 接口
派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。
Policy.Parameters - java.security 中的 接口
此类表示用于 Policy 参数的标记接口。
POLICY_FORWARD_SECRECY - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否需要在会话间实现了转发安全性的机制。
POLICY_NOACTIVE - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否允许易受主动式攻击（非字典）的机制。
POLICY_NOANONYMOUS - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否允许接受匿名登录的机制。
POLICY_NODICTIONARY - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否允许易受被动式字典攻击的机制。
POLICY_NOPLAINTEXT - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否允许易受简单被动式攻击（例如 "PLAIN"）的机制。
POLICY_PASS_CREDENTIALS - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否需要传递客户端证书的机制。
policy_type() - 类 org.omg.CORBA._PolicyStub 中的方法
返回对应于策略对象类型的常量值。
policy_type() - 接口 org.omg.CORBA.PolicyOperations 中的方法
返回对应于策略对象类型的常量值。
PolicyError - org.omg.CORBA 中的 异常
发生策略错误时抛出的用户异常。
PolicyError() - 异常 org.omg.CORBA.PolicyError 的构造方法
使用空原因代码和空原因详细消息构造一个默认 PolicyError 用户异常。
PolicyError(short) - 异常 org.omg.CORBA.PolicyError 的构造方法
构造一个 PolicyError 用户异常，并使用给定原因代码和空原因详细消息初始化。
PolicyError(String, short) - 异常 org.omg.CORBA.PolicyError 的构造方法
构造一个 PolicyError 用户异常，并使用给定原因详细消息和原因代码初始化。
PolicyErrorCodeHelper - org.omg.CORBA 中的 类
封装 Policy 无效的原因。
PolicyErrorCodeHelper() - 类 org.omg.CORBA.PolicyErrorCodeHelper 的构造方法
PolicyErrorHelper - org.omg.CORBA 中的 类
抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。
PolicyErrorHelper() - 类 org.omg.CORBA.PolicyErrorHelper 的构造方法
PolicyErrorHolder - org.omg.CORBA 中的 类
抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。
PolicyErrorHolder() - 类 org.omg.CORBA.PolicyErrorHolder 的构造方法
PolicyErrorHolder(PolicyError) - 类 org.omg.CORBA.PolicyErrorHolder 的构造方法
PolicyFactory - org.omg.PortableInterceptor 中的 接口
使得策略类型能够使用 CORBA.ORB.create_policy 来构建。
PolicyFactoryOperations - org.omg.PortableInterceptor 中的 接口
使得策略类型能够通过 CORBA.ORB.create_policy 构建。
PolicyHelper - org.omg.CORBA 中的 类
Policy 的 Helper。
PolicyHelper() - 类 org.omg.CORBA.PolicyHelper 的构造方法
PolicyHolder - org.omg.CORBA 中的 类
Policy 的 Holder。
PolicyHolder() - 类 org.omg.CORBA.PolicyHolder 的构造方法
PolicyHolder(Policy) - 类 org.omg.CORBA.PolicyHolder 的构造方法
PolicyListHelper - org.omg.CORBA 中的 类
PolicyList 的 Helper。
PolicyListHelper() - 类 org.omg.CORBA.PolicyListHelper 的构造方法
PolicyListHolder - org.omg.CORBA 中的 类
PolicyList 的 Holder。
PolicyListHolder() - 类 org.omg.CORBA.PolicyListHolder 的构造方法
PolicyListHolder(Policy[]) - 类 org.omg.CORBA.PolicyListHolder 的构造方法
PolicyNode - java.security.cert 中的 接口
PKIX 证书路径验证算法所定义的、不可变的有效策略树节点。
PolicyOperations - org.omg.CORBA 中的 接口
提供针对某一 Policy 对象的操作。
PolicyQualifierInfo - java.security.cert 中的 类
由 ASN.1 PolicyQualifierInfo 结构所表示的、不可变的策略限定符。
PolicyQualifierInfo(byte[]) - 类 java.security.cert.PolicyQualifierInfo 的构造方法
根据已编码的字节创建一个 PolicyQualifierInfo 实例。
PolicySpi - java.security 中的 类
此类为 Policy 类定义服务提供者接口 (SPI)。
PolicySpi() - 类 java.security.PolicySpi 的构造方法
PolicyTypeHelper - org.omg.CORBA 中的 类
PolicyType 的 Helper。
PolicyTypeHelper() - 类 org.omg.CORBA.PolicyTypeHelper 的构造方法
poll() - 类 java.lang.ref.ReferenceQueue 中的方法
轮询此队列，查看是否存在可用的引用对象。
poll() - 类 java.util.ArrayDeque 中的方法
获取并移除此双端队列所表示的队列的头（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
poll() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
poll() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
poll(long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），如有必要将在指定的等待时间内等待可用元素。
poll(long, TimeUnit) - 接口 java.util.concurrent.BlockingQueue 中的方法
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。
poll() - 接口 java.util.concurrent.CompletionService 中的方法
获取并移除表示下一个已完成任务的 Future，如果不存在这样的任务，则返回 null。
poll(long, TimeUnit) - 接口 java.util.concurrent.CompletionService 中的方法
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。
poll() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
poll() - 类 java.util.concurrent.DelayQueue 中的方法
获取并移除此队列的头，如果此队列不包含具有已到期延迟时间的元素，则返回 null。
poll(long, TimeUnit) - 类 java.util.concurrent.DelayQueue 中的方法
获取并移除此队列的头部，在可从此队列获得到期延迟的元素，或者到达指定的等待时间之前一直等待（如有必要）。
poll() - 类 java.util.concurrent.ExecutorCompletionService 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.ExecutorCompletionService 中的方法
poll() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
poll() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
poll() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.SynchronousQueue 中的方法
获取并移除此队列的头，如有必要则等待指定的时间，以便另一个线程插入它。
poll() - 类 java.util.concurrent.SynchronousQueue 中的方法
如果另一个线程当前正要使用某个元素，则获取并移除此队列的头。
poll() - 接口 java.util.Deque 中的方法
获取并移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
poll() - 类 java.util.LinkedList 中的方法
获取并移除此列表的头（第一个元素）
poll() - 类 java.util.PriorityQueue 中的方法
poll() - 接口 java.util.Queue 中的方法
获取并移除此队列的头，如果此队列为空，则返回 null。
poll_next_response() - 类 org.omg.CORBA.ORB 中的方法
找出是否已经响应了延迟的（异步）调用。
poll_response() - 类 org.omg.CORBA.Request 中的方法
允许用户确定是否已接收到之前使用 send_deferred 方法所触发调用的响应。
pollFirst() - 类 java.util.ArrayDeque 中的方法
pollFirst(long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列的第一个元素，必要时将在指定的等待时间等待可用元素。
pollFirst() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
pollFirst() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
pollFirst(long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
pollFirst() - 接口 java.util.Deque 中的方法
获取并移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。
pollFirst() - 类 java.util.LinkedList 中的方法
获取并移除此列表的第一个元素；如果此列表为空，则返回 null。
pollFirst() - 接口 java.util.NavigableSet 中的方法
获取并移除第一个（最低）元素；如果此 set 为空，则返回 null。
pollFirst() - 类 java.util.TreeSet 中的方法
pollFirstEntry() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
移除并返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。
pollFirstEntry() - 接口 java.util.NavigableMap 中的方法
移除并返回与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
pollFirstEntry() - 类 java.util.TreeMap 中的方法
pollLast() - 类 java.util.ArrayDeque 中的方法
pollLast(long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列的最后一个元素，必要时将在指定的等待时间内等待可用元素。
pollLast() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
pollLast() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
pollLast(long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
pollLast() - 接口 java.util.Deque 中的方法
获取并移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。
pollLast() - 类 java.util.LinkedList 中的方法
获取并移除此列表的最后一个元素；如果此列表为空，则返回 null。
pollLast() - 接口 java.util.NavigableSet 中的方法
获取并移除最后一个（最高）元素；如果此 set 为空，则返回 null。
pollLast() - 类 java.util.TreeSet 中的方法
pollLastEntry() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
移除并返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。
pollLastEntry() - 接口 java.util.NavigableMap 中的方法
移除并返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。
pollLastEntry() - 类 java.util.TreeMap 中的方法
POLY_PRESSURE - 类 javax.sound.midi.ShortMessage 中的静态变量
Polyphonic Key Pressure (Aftertouch) 消息的命令值（0xA0 或 128）
Polygon - java.awt 中的 类
Polygon 类封装了坐标空间中封闭的二维区域的描述。
Polygon() - 类 java.awt.Polygon 的构造方法
创建空的多边形。
Polygon(int[], int[], int) - 类 java.awt.Polygon 的构造方法
根据指定的参数构造并初始化新的 Polygon。
PooledConnection - javax.sql 中的 接口
为连接池管理提供钩子 (hook) 的对象。
pop() - 类 java.awt.EventQueue 中的方法
停止使用此 EventQueue 指派事件。
pop() - 类 java.util.ArrayDeque 中的方法
从此双端队列所表示的堆栈中弹出一个元素。
pop() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
pop() - 接口 java.util.Deque 中的方法
从此双端队列所表示的堆栈中弹出一个元素。
pop() - 类 java.util.LinkedList 中的方法
从此列表所表示的堆栈处弹出一个元素。
pop() - 类 java.util.Stack 中的方法
移除堆栈顶部的对象，并作为此函数的值返回该对象。
popCharacterStyle() - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
将以前压入堆栈的字符样式弹出，以返回以前的样式。
popContext() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
恢复到以前的名称空间上下文。
populate(ResultSet) - 接口 javax.sql.rowset.CachedRowSet 中的方法
使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
populate(ResultSet, int) - 接口 javax.sql.rowset.CachedRowSet 中的方法
使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
popup - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
Popup - javax.swing 中的 类
Popup 用于向用户显示 Component，它通常位于特定包含层次结构中所有其他 Component 的顶部。
Popup(Component, Component, int, int) - 类 javax.swing.Popup 的构造方法
为包含 Component content 的 Component owner 创建 Popup。
Popup() - 类 javax.swing.Popup 的构造方法
创建 Popup。
POPUP_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Popup 层的便捷对象。
POPUP_MENU - 类 javax.accessibility.AccessibleRole 中的静态变量
一个临时窗口，通常用于为用户提供选项列表，当用户选中其中某个选项后，此窗口隐藏。
POPUP_MENU - 类 javax.swing.plaf.synth.Region 中的静态变量
PopupMenu 的 region。
POPUP_MENU_SEPARATOR - 类 javax.swing.plaf.synth.Region 中的静态变量
PopupMenuSeparator 的 region。
PopupFactory - javax.swing 中的 类
顾名思义，PopupFactory 用于获取 Popup 的实例。
PopupFactory() - 类 javax.swing.PopupFactory 的构造方法
popupKeyListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
popupListener - 类 javax.swing.JMenu 中的变量
弹出菜单的窗口关闭侦听器。
PopupMenu - java.awt 中的 类
此类实现能够在组件中的指定位置上动态弹出的菜单。
PopupMenu() - 类 java.awt.PopupMenu 的构造方法
创建具有空名称的新弹出式菜单。
PopupMenu(String) - 类 java.awt.PopupMenu 的构造方法
创建具有指定名称的新弹出式菜单。
popupMenu - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的变量
PopupMenu.AccessibleAWTPopupMenu - java.awt 中的 类
用于为可访问性提供默认支持的 PopupMenu 的内部类。
PopupMenu.AccessibleAWTPopupMenu() - 类 java.awt.PopupMenu.AccessibleAWTPopupMenu 的构造方法
popupMenuCanceled(PopupMenuEvent) - 接口 javax.swing.event.PopupMenuListener 中的方法
此方法在弹出菜单被取消时调用。
PopupMenuEvent - javax.swing.event 中的 类
PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
PopupMenuEvent(Object) - 类 javax.swing.event.PopupMenuEvent 的构造方法
构造一个 PopupMenuEvent 对象。
PopupMenuListener - javax.swing.event 中的 接口
弹出菜单侦听器
PopupMenuUI - javax.swing.plaf 中的 类
JPopupMenu 的可插入外观界面。
PopupMenuUI() - 类 javax.swing.plaf.PopupMenuUI 的构造方法
popupMenuWillBecomeInvisible(PopupMenuEvent) - 接口 javax.swing.event.PopupMenuListener 中的方法
此方法在弹出菜单变得不可见之前调用。
popupMenuWillBecomeVisible(PopupMenuEvent) - 接口 javax.swing.event.PopupMenuListener 中的方法
此方法在弹出菜单变得可见之前调用
popupMouseListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
popupMouseMotionListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
port - 类 java.net.SocketImpl 中的变量
此套接字连接到的远程主机的端口号。
Port - javax.sound.sampled 中的 接口
端口是往返于音频输入或输出线与音频设备之间的简单线路。
Port.Info - javax.sound.sampled 中的 类
该 Port.Info 类扩展了具有其他特定于端口的信息的 Line.Info，这些信息包括端口的名称以及该端口是否是其混频器的源或目标。
Port.Info(Class<?>, String, boolean) - 类 javax.sound.sampled.Port.Info 的构造方法
根据给定的信息构造端口的 info 对象。
PortableRemoteObject - javax.rmi 中的 类
服务器实现对象可以从 javax.rmi.PortableRemoteObject 继承，也可以实现一个远程接口，然后使用 exportObject 方法将其本身注册为服务器对象。
PortableRemoteObject() - 类 javax.rmi.PortableRemoteObject 的构造方法
通过调用 exportObject(this) 初始化该对象。
PortableRemoteObjectDelegate - javax.rmi.CORBA 中的 接口
支持 PortableRemoteObject 中方法实现的委托。
PortInfo - javax.xml.ws.handler 中的 接口
HandlerResolver 使用 PortInfo 接口查询有关要用来创建处理程序链的端口的信息。
PORTRAIT - 类 java.awt.PageAttributes.OrientationRequestedType 中的静态变量
用于指定纵向方向的 OrientationRequestedType 实例。
PORTRAIT - 类 java.awt.print.PageFormat 中的静态变量
原点在纸张的左上方，x 指向右方，y 指向下方。
PORTRAIT - 类 javax.print.attribute.standard.OrientationRequested 中的静态变量
沿介质的短边描绘内容。
PortUnreachableException - java.net 中的 异常
在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
PortUnreachableException(String) - 异常 java.net.PortUnreachableException 的构造方法
构造带详细消息的新 PortUnreachableException。
PortUnreachableException() - 异常 java.net.PortUnreachableException 的构造方法
构造不带详细消息的新 PortUnreachableException。
pos - 类 java.io.BufferedInputStream 中的变量
缓冲区中的当前位置。
pos - 类 java.io.ByteArrayInputStream 中的变量
要从输入流缓冲区中读取的下一个字符的索引。
pos - 类 java.io.CharArrayReader 中的变量
当前缓冲区位置。
pos - 类 java.io.PushbackInputStream 中的变量
推回缓冲区中的位置，将读取该位置的下一个字节。
pos - 类 java.io.StringBufferInputStream 中的变量
已过时。 要从输入流缓冲区中读取的下一个字符的索引。
position() - 类 java.nio.Buffer 中的方法
返回此缓冲区的位置。
position(int) - 类 java.nio.Buffer 中的方法
设置此缓冲区的位置。
position() - 类 java.nio.channels.FileChannel 中的方法
返回此通道的文件位置。
position(long) - 类 java.nio.channels.FileChannel 中的方法
设置此通道的文件位置。
position() - 类 java.nio.channels.FileLock 中的方法
返回文件内锁定区域中第一个字节的位置。
position(byte[], long) - 接口 java.sql.Blob 中的方法
获取此 Blob 对象表示的 BLOB 值中指定 byte 数组 pattern 开始处的字节位置。
position(Blob, long) - 接口 java.sql.Blob 中的方法
获取此 Blob 对象指定的 BLOB 值中 pattern 开始处的字节位置。
position(String, long) - 接口 java.sql.Clob 中的方法
获取此 Clob 对象表示的 SQL CLOB 值中指定子字符串 searchstr 出现的字符位置。
position(Clob, long) - 接口 java.sql.Clob 中的方法
获取此 Clob 对象中指定的 Clob 对象 searchstr 出现的字符位置。
position(byte[], long) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
返回在此 SerialBlob 对象中给定模式的字节开始的位置，搜索从指定的位置开始。
position(Blob, long) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
返回此 SerialBlob 对象中给定 Blob 对象开始的位置，搜索从指定位置开始。
position(String, long) - 类 javax.sql.rowset.serial.SerialClob 中的方法
返回此 SerialClob 对象中给定 String 对象开始的位置，搜索从指定位置开始。
position(Clob, long) - 类 javax.sql.rowset.serial.SerialClob 中的方法
返回此 SerialClob 对象中给定 Clob 签名开始的位置，搜索从指定位置开始。
Position - javax.swing.text 中的 接口
表示文档中的位置。
Position.Bias - javax.swing.text 中的 类
用来指示模型中位置偏差的类型安全的枚举。
positionCaret(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
试图使用 viewToModel() 从鼠标事件的坐标设置插入符的位置。
positionForMouseEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
返回基于传入的 MouseEvent 放置分隔器的新位置。
positionForMouseEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController 中的方法
返回基于传入的 MouseEvent 放置分隔器的新位置。
positionToElement(int) - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得包含给定模型位置的子元素。
POSITIVE_INFINITY - 类 java.lang.Double 中的静态变量
保存 double 类型的正无穷大值的常量。
POSITIVE_INFINITY - 类 java.lang.Float 中的静态变量
保存 float 类型的正无穷大值的常量。
POSITIVE_SCROLL - 类 javax.swing.plaf.basic.BasicSliderUI 中的静态变量
post_init(ORBInitInfo) - 接口 org.omg.PortableInterceptor.ORBInitializerOperations 中的方法
初始化 ORB 期间调用此方法。
postActionEvent() - 类 javax.swing.JTextField 中的方法
通过将其指派给所有已注册的 ActionListener 对象来处理发生在此文本字段上的操作事件。
postClosingEvent(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
将类似于 WINDOW_CLOSING 的事件发送到窗体，以便将其当作规则的 Frame 来对待。
PostConstruct - javax.annotation 中的 注释类型
PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
postDeregister() - 类 javax.management.loading.MLet 中的方法
允许 m-let 在已从 MBean 服务器注销之后执行任何所需要的操作。
postDeregister() - 接口 javax.management.MBeanRegistration 中的方法
允许 MBean 在已从 MBean 服务器注销之后执行所需要的任何操作。
postDeregister() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
允许 MBean 在已从 MBean 服务器注销之后执行任何所需要的操作。
postDeregister() - 类 javax.management.monitor.Monitor 中的方法
允许在 MBean 服务器注销监视器 MBean 之前执行所需的任何操作。
postDeregister() - 类 javax.management.relation.RelationService 中的方法
postDeregister() - 类 javax.management.relation.RelationSupport 中的方法
postDeregister() - 类 javax.management.remote.JMXConnectorServer 中的方法
postDeregister() - 类 javax.management.StandardMBean 中的方法
允许 MBean 在 MBean 服务器中取消注册后执行任何它所需要的操作。
postDeregister() - 类 javax.management.timer.Timer 中的方法
允许计时器 MBean 在 MBean 服务器注销它之后执行任何所需的操作。
postEdit(UndoableEdit) - 类 javax.swing.undo.UndoableEditSupport 中的方法
死锁警告：调用此方法可能调用所有侦听器中的 undoableEditHappened。
postEvent(Event) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
postEvent(AWTEvent) - 类 java.awt.EventQueue 中的方法
将一个 1.1 样式的事件发送到 EventQueue 中。
postEvent(Event) - 类 java.awt.MenuComponent 中的方法
已过时。 从 JDK version 1.1 开始，已由 dispatchEvent 取代。
postEvent(Event) - 接口 java.awt.MenuContainer 中的方法
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
postEvent(Event) - 类 java.awt.Window 中的方法
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
postinvoke(byte[], POA, String, Object, Servant) - 类 org.omg.PortableServer._ServantLocatorStub 中的方法
servant 完成请求时都将调用此操作。
postinvoke(byte[], POA, String, Object, Servant) - 接口 org.omg.PortableServer.ServantLocatorOperations 中的方法
servant 完成请求时都将调用此操作。
postorderEnumeration() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回按后序遍历以此节点为根的树的一个枚举。
postProcessKeyEvent(KeyEvent) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
由 dispatchKeyEvent 调用此方法。
postProcessKeyEvent(KeyEvent) - 类 java.awt.KeyboardFocusManager 中的方法
dispatchKeyEvent 将调用此方法。
postProcessKeyEvent(KeyEvent) - 接口 java.awt.KeyEventPostProcessor 中的方法
当前 KeyboardFocusManager 调用此方法，请求此 KeyEventPostProcessor 执行应该作为 KeyEvent 最终解析的一部分的所需后处理。
postRegister(Boolean) - 类 javax.management.loading.MLet 中的方法
允许 m-let 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。
postRegister(Boolean) - 接口 javax.management.MBeanRegistration 中的方法
允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。
postRegister(Boolean) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
允许 MBean 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。
postRegister(Boolean) - 类 javax.management.monitor.Monitor 中的方法
允许在 MBean 服务器中注册监视器 MBean 后或注册失败后执行所需的任何操作。
postRegister(Boolean) - 类 javax.management.relation.RelationService 中的方法
postRegister(Boolean) - 类 javax.management.relation.RelationSupport 中的方法
postRegister(Boolean) - 类 javax.management.remote.JMXConnectorServer 中的方法
postRegister(Boolean) - 类 javax.management.StandardMBean 中的方法
允许 MBean 在已注册到 MBean 服务器之后或注册已失败之后执行任何它所需要的操作。
postRegister(Boolean) - 类 javax.management.timer.Timer 中的方法
允许计时器 MBean 在 MBean 服务器中注册后或注册失败后执行任何所需的操作。
postRemoveUpdate(AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.AbstractDocument 中的方法
随文本的移除更新任何文档结构。
POSTSCRIPT - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "application/postscript"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
POSTSCRIPT - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
POSTSCRIPT - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
postState - 类 javax.swing.undo.StateEdit 中的变量
编辑之后的状态信息
POSTURE - 类 java.awt.font.TextAttribute 中的静态变量
字体形态的属性键。
POSTURE_OBLIQUE - 类 java.awt.font.TextAttribute 中的静态变量
标准斜体形态。
POSTURE_REGULAR - 类 java.awt.font.TextAttribute 中的静态变量
标准直立形态。
pow(double, double) - 类 java.lang.Math 中的静态方法
返回第一个参数的第二个参数次幂的值。
pow(double, double) - 类 java.lang.StrictMath 中的静态方法
返回第一个参数的第二个参数次幂的值。
pow(int) - 类 java.math.BigDecimal 中的方法
返回其值为 (thisn) 的 BigDecimal，准确计算该幂，使其具有无限精度。
pow(int, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (thisn) 的 BigDecimal。
pow(int) - 类 java.math.BigInteger 中的方法
返回其值为 (thisexponent) 的 BigInteger。
PPQ - 类 javax.sound.midi.Sequence 中的静态变量
基于速度的定时类型，其精度用每四分音符的拍子数（节拍）表示。
PRC - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
PRE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
pre_init(ORBInitInfo) - 接口 org.omg.PortableInterceptor.ORBInitializerOperations 中的方法
初始化 ORB 期间调用此方法。
preceding(int) - 类 java.text.BreakIterator 中的方法
返回指定字符偏移量前面的最后一个边界。
precision() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的精度。
preConcatenate(AffineTransform) - 类 java.awt.geom.AffineTransform 中的方法
以不常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，从而 Tx 相对于绝对像素空间（而非相对于现有用户空间）修改坐标变换。
preConcatenateTransform(AffineTransform) - 类 java.awt.image.renderable.RenderContext 中的方法
通过预先挂起另一变换修改当前的“用户到设备”变换。
preConcetenateTransform(AffineTransform) - 类 java.awt.image.renderable.RenderContext 中的方法
已过时。 由 preConcatenateTransform(AffineTransform) 所取代。
preContent(char[]) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
添加在 PRE 元素中遇到的给定内容。
predefined - 类 java.awt.Cursor 中的静态变量
preDeregister() - 类 javax.management.loading.MLet 中的方法
允许 m-let 在由 MBean 服务器注销之前执行任何所需要的操作。
preDeregister() - 接口 javax.management.MBeanRegistration 中的方法
允许该 MBean 在从 MBean 服务器注销之前执行它所需要的任何操作。
preDeregister() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
允许 MBean 在由 MBean 服务器注销之前执行任何所需要的操作。
preDeregister() - 类 javax.management.monitor.Monitor 中的方法
允许在 MBean 服务器注销监视器 MBean 之前执行监视器 MBean 所需要的任何操作。
preDeregister() - 类 javax.management.relation.RelationService 中的方法
preDeregister() - 类 javax.management.relation.RelationSupport 中的方法
preDeregister() - 类 javax.management.remote.JMXConnectorServer 中的方法
当此连接器服务器从 MBean 服务器上注销时，由该 MBean 服务器调用此方法。
preDeregister() - 类 javax.management.StandardMBean 中的方法
允许 MBean 由 MBean 服务器取消注册前执行任何它所需要的操作。
preDeregister() - 类 javax.management.timer.Timer 中的方法
允许计时器 MBean 在 MBean 服务器注销它之前执行任何所需的操作。
PreDestroy - javax.annotation 中的 注释类型
PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
Predicate - javax.sql.rowset 中的 接口
为所有 FilteredRowSet 对象提供框架以描述其过滤器的标准接口。
preferenceChange(PreferenceChangeEvent) - 接口 java.util.prefs.PreferenceChangeListener 中的方法
当添加、移除首选项或者更改首选项的值时，调用此方法。
preferenceChanged(boolean, boolean) - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
标记此子视图更改的首选项。
preferenceChanged(View, boolean, boolean) - 类 javax.swing.text.AsyncBoxView 中的方法
子视图可以在父级上调用此方法，以指示首选项已更改并且应该重新考虑布局。
preferenceChanged(View, boolean, boolean) - 类 javax.swing.text.BoxView 中的方法
这由子级来调用，以表明它的首选项区域已更改。
preferenceChanged(View, boolean, boolean) - 类 javax.swing.text.View 中的方法
子视图能在父级上调用此方法来指示首选项已经更改，并且应该重新考虑布局。
PreferenceChangeEvent - java.util.prefs 中的 类
Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。
PreferenceChangeEvent(Preferences, String, String) - 类 java.util.prefs.PreferenceChangeEvent 的构造方法
构造新的 PreferenceChangeEvent 实例。
PreferenceChangeListener - java.util.prefs 中的 接口
用于接收首选项节点更改事件的侦听器。
Preferences - java.util.prefs 中的 类
首选项数据的层次结构 collection 中的节点。
Preferences() - 类 java.util.prefs.Preferences 的构造方法
单独的构造方法。
PreferencesFactory - java.util.prefs 中的 接口
生成 Preferences 对象的 factory 对象。
preferLocaleFonts() - 类 java.awt.GraphicsEnvironment 中的方法
指示在逻辑字体到实际字体的映射关系中特定于语言环境的字体的首选项。
preferProportionalFonts() - 类 java.awt.GraphicsEnvironment 中的方法
指示在逻辑字体到实际字体的映射关系中用于均衡字体和非均衡字体（如双字节的中日韩字体）的首选项。
PREFERRED - 类 java.awt.GraphicsConfigTemplate 中的静态变量
用于“枚举”（整数）类型的值。
preferred - 类 javax.swing.SizeRequirements 中的变量
首选（自然）大小。
PREFERRED_SIZE - 类 javax.swing.GroupLayout 中的静态变量
指示组件或间隙的首选大小应该用于特定的范围值。
preferredLayoutSize(Container) - 类 java.awt.BorderLayout 中的方法
基于容器中的组件，使用此布局管理器确定 target 容器的首选大小。
preferredLayoutSize(Container) - 类 java.awt.CardLayout 中的方法
使用此卡片布局确定容器参数的首选大小。
preferredLayoutSize(Container) - 类 java.awt.FlowLayout 中的方法
给出指定目标容器中的 visible 组件，返回此布局的首选维数。
preferredLayoutSize(Container) - 类 java.awt.GridBagLayout 中的方法
使用此网络包布局确定 parent 容器的首选大小。
preferredLayoutSize(Container) - 类 java.awt.GridLayout 中的方法
使用此网格布局确定容器参数的首选大小。
preferredLayoutSize(Container) - 接口 java.awt.LayoutManager 中的方法
给定指定容器所包含的组件，计算该容器的首选大小维数。
preferredLayoutSize(Container) - 类 javax.swing.BoxLayout 中的方法
在给出指定目标容器中的组件的前提下，返回此布局的首选尺寸。
preferredLayoutSize(Container) - 类 javax.swing.GroupLayout 中的方法
返回指定容器的首选大小。
preferredLayoutSize(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法
返回布局要使用的空间量。
preferredLayoutSize(Container) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
返回第一个（并且是唯一）子级的首选大小与其父 insets 的大小和。
preferredLayoutSize(Container) - 类 javax.swing.OverlayLayout 中的方法
在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回包含子级所需的首选大小。
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.DefaultMenuLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.ScrollPaneLayout 中的方法
ScrollPane 的首选大小是 insets 的大小加上视口的首选大小、可见标题首选大小以及滚动条的首选大小，它按照给定的当前视图和当前滚动条策略显示。
preferredLayoutSize(Container) - 类 javax.swing.SpringLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.ViewportLayout 中的方法
在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
preferredMinSize - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
最小首选大小。
preferredSize() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
preferredSize() - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 getPreferredSize() 取代。
PREFERREDSIZE - 类 java.awt.GridBagLayout 中的静态变量
网格包布局可以布置的首选网格大小。
preferredSize(int) - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
preferredSize() - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
preferredSize(int, int) - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int, int) 取代。
preferredSize() - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
preferredSize(int) - 类 java.awt.TextField 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
preferredSize() - 类 java.awt.TextField 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
preferredSize - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
完全显示所有节点所需的大小。
preferredTabAreaHeight(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
preferredTabAreaWidth(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
preferredTileSizes - 类 javax.imageio.ImageWriteParam 中的变量
首选 tile 大小范围对组成的数组。
preferredViewportSize - 类 javax.swing.JTable 中的变量
Scrollable 接口使用它来确定初始的可见区域。
preinvoke(byte[], POA, String, CookieHolder) - 类 org.omg.PortableServer._ServantLocatorStub 中的方法
此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。
preinvoke(byte[], POA, String, CookieHolder) - 接口 org.omg.PortableServer.ServantLocatorOperations 中的方法
此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。
preorderEnumeration() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回按前序遍历以此节点为根的子树的一个枚举。
prepare(Xid) - 接口 javax.transaction.xa.XAResource 中的方法
请求资源管理器准备好 xid 中指定的事务的事务提交工作。
prepareCall(String) - 接口 java.sql.Connection 中的方法
创建一个 CallableStatement 对象来调用数据库存储过程。
prepareCall(String, int, int) - 接口 java.sql.Connection 中的方法
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
prepareCall(String, int, int, int) - 接口 java.sql.Connection 中的方法
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
PreparedStatement - java.sql 中的 接口
表示预编译的 SQL 语句的对象。
prepareEditor(TableCellEditor, int, int) - 类 javax.swing.JTable 中的方法
通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备编辑器。
prepareForDragging() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
传递消息以准备拖动操作。
prepareForEditing() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
仅在编辑启动之前调用。
prepareForUIInstall() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
在设置 tree 实例变量之后，但在安装任何默认值/侦听器之前调用此方法。
prepareForUIUninstall() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
prepareImage(Image, ImageObserver) - 类 java.awt.Component 中的方法
准备一幅在此组件上呈现的图像。
prepareImage(Image, int, int, ImageObserver) - 类 java.awt.Component 中的方法
以指定的宽度和高度准备一幅在此组件上呈现的图像。
prepareImage(Image, int, int, ImageObserver) - 类 java.awt.Toolkit 中的方法
准备一个用于呈现的图像。
prepareInsertEmpty(int, ImageTypeSpecifier, int, int, IIOMetadata, List<? extends BufferedImage>, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
从将带有不确定像素值的新图像插入现有图像流中开始。
prepareRenderer(TableCellRenderer, int, int) - 类 javax.swing.JTable 中的方法
通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备渲染器。
prepareReplacePixels(int, Rectangle) - 类 javax.imageio.ImageWriter 中的方法
准备好 writer，处理一系列对 replacePixels 方法的调用。
prepareStatement(String) - 接口 java.sql.Connection 中的方法
创建一个 PreparedStatement 对象来将参数化的 SQL 语句发送到数据库。
prepareStatement(String, int, int) - 接口 java.sql.Connection 中的方法
创建一个 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
prepareStatement(String, int, int, int) - 接口 java.sql.Connection 中的方法
创建一个 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
prepareStatement(String, int) - 接口 java.sql.Connection 中的方法
创建一个默认 PreparedStatement 对象，该对象能获取自动生成的键。
prepareStatement(String, int[]) - 接口 java.sql.Connection 中的方法
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
prepareStatement(String, String[]) - 接口 java.sql.Connection 中的方法
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
prepareWriteEmpty(IIOMetadata, ImageTypeSpecifier, int, int, IIOMetadata, List<? extends BufferedImage>, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
prepareWriteSequence(IIOMetadata) - 类 javax.imageio.ImageWriter 中的方法
使用提供的流元数据对象准备一个流，以接受一系列的后续 writeToSequence 调用。
preRegister(MBeanServer, ObjectName) - 类 javax.management.loading.MLet 中的方法
允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。
preRegister(MBeanServer, ObjectName) - 接口 javax.management.MBeanRegistration 中的方法
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
preRegister(MBeanServer, ObjectName) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。
preRegister(MBeanServer, ObjectName) - 类 javax.management.monitor.Monitor 中的方法
允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。
preRegister(MBeanServer, ObjectName) - 类 javax.management.relation.RelationService 中的方法
preRegister(MBeanServer, ObjectName) - 类 javax.management.relation.RelationSupport 中的方法
preRegister(MBeanServer, ObjectName) - 类 javax.management.remote.JMXConnectorServer 中的方法
当此连接器服务器在 MBean 服务器上注册时，由该 MBean 服务器调用此方法。
preRegister(MBeanServer, ObjectName) - 类 javax.management.StandardMBean 中的方法
允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。
preRegister(MBeanServer, ObjectName) - 类 javax.management.timer.Timer 中的方法
允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。
PresentationDirection - javax.print.attribute.standard 中的 类
PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
PRESSED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象当前是按下的。
PRESSED - 类 javax.swing.DefaultButtonModel 中的静态变量
标识位掩码中“按下的”位，该位指示按钮已经被按下。
PRESSED - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示 region 处于被按下状态的基本状态。
PRESSED_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对按下按钮时使用的图标的更改。
prestartAllCoreThreads() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
启动所有核心线程，使其处于等待工作的空闲状态。
prestartCoreThread() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
启动核心线程，使其处于等待工作的空闲状态。
preState - 类 javax.swing.undo.StateEdit 中的变量
编辑之前的状态信息
preventDefault() - 接口 org.w3c.dom.events.Event 中的方法
如果事件可取消，则 preventDefault 方法用于表示要取消该事件，意味着作为事件结果的、通常由该实现采取的任何默认操作将不出现。
PREVIEW_PANEL_PROPERTY - 类 javax.swing.JColorChooser 中的静态变量
预览面板属性名。
previewListener - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的变量
previous(Container) - 类 java.awt.CardLayout 中的方法
翻转到指定容器的前一张卡片。
previous() - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的上一行。
previous() - 类 java.text.BreakIterator 中的方法
返回当前边界的前一个边界。
previous() - 接口 java.text.CharacterIterator 中的方法
将迭代器的索引减一，并返回新索引处的字符。
previous() - 类 java.text.CollationElementIterator 中的方法
获取字符串中前一个 collation 元素。
previous() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.previous()。
previous() - 接口 java.util.ListIterator 中的方法
返回列表中的前一个元素。
PREVIOUS - 接口 javax.swing.SwingConstants 中的静态变量
标识序列中前一个方向。
previous() - 类 javax.swing.text.ElementIterator 中的方法
获取前一个 Element。
previous() - 类 javax.swing.text.Segment 中的方法
将迭代器的索引减一，并返回新索引处的字符。
previousConflict() - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
将指针从其当前位置移动到此 SyncResolver 对象中上一个冲突行。
previousDouble(double) - 类 java.text.ChoiceFormat 中的静态方法
查找小于 d 的最大 double 值。
previousIndex() - 接口 java.util.ListIterator 中的方法
返回对 previous 的后续调用所返回元素的索引。
previousPage() - 接口 javax.sql.rowset.CachedRowSet 中的方法
逐个减少 CachedRowSet 的当前页。
previousWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到前一个字开头的 Action 名称。
PRIMARY - 类 java.text.Collator 中的静态变量
Collator 的 strength 值。
primaryOrder(int) - 类 java.text.CollationElementIterator 中的静态方法
返回 collation 元素的主顺序。
PrimitiveType - javax.lang.model.type 中的 接口
表示一个基本类型。
Principal - java.security 中的 接口
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。
Principal - org.omg.CORBA 中的 类
已过时。 已由 CORBA 2.2 取代。
Principal() - 类 org.omg.CORBA.Principal 的构造方法
已过时。
PrincipalHolder - org.omg.CORBA 中的 类
已过时。 Deprecated by CORBA 2.2.
PrincipalHolder() - 类 org.omg.CORBA.PrincipalHolder 的构造方法
已过时。 构造一个新的 PrincipalHolder 对象，将其 value 字段初始化为 null。
PrincipalHolder(Principal) - 类 org.omg.CORBA.PrincipalHolder 的构造方法
已过时。 构造一个新的 PrincipalHolder 对象，并将其 value 字段初始化为给定的 Principal 对象。
print(Graphics) - 类 java.awt.Component 中的方法
打印此组件。
print(Graphics) - 类 java.awt.Container 中的方法
打印容器。
print(File) - 类 java.awt.Desktop 中的方法
使用关联应用程序的打印命令，用本机桌面打印设施来打印文件。
print(Graphics, PageFormat, int) - 接口 java.awt.print.Printable 中的方法
将指定索引处的页面用指定格式打印到指定的 Graphics 上下文。
print() - 类 java.awt.print.PrinterJob 中的方法
打印一组页面。
print(PrintRequestAttributeSet) - 类 java.awt.print.PrinterJob 中的方法
使用属性集中的设置打印一组页面。
print(boolean) - 类 java.io.PrintStream 中的方法
打印 boolean 值。
print(char) - 类 java.io.PrintStream 中的方法
打印字符。
print(int) - 类 java.io.PrintStream 中的方法
打印整数。
print(long) - 类 java.io.PrintStream 中的方法
打印 long 整数。
print(float) - 类 java.io.PrintStream 中的方法
打印浮点数。
print(double) - 类 java.io.PrintStream 中的方法
打印双精度浮点数。
print(char[]) - 类 java.io.PrintStream 中的方法
打印字符数组。
print(String) - 类 java.io.PrintStream 中的方法
打印字符串。
print(Object) - 类 java.io.PrintStream 中的方法
打印对象。
print(boolean) - 类 java.io.PrintWriter 中的方法
打印 boolean 值。
print(char) - 类 java.io.PrintWriter 中的方法
打印字符。
print(int) - 类 java.io.PrintWriter 中的方法
打印整数。
print(long) - 类 java.io.PrintWriter 中的方法
打印 long 整数。
print(float) - 类 java.io.PrintWriter 中的方法
打印一个浮点数。
print(double) - 类 java.io.PrintWriter 中的方法
打印 double 精度浮点数。
print(char[]) - 类 java.io.PrintWriter 中的方法
打印字符数组。
print(String) - 类 java.io.PrintWriter 中的方法
打印字符串。
print(Object) - 类 java.io.PrintWriter 中的方法
打印对象。
print(Doc, PrintRequestAttributeSet) - 接口 javax.print.DocPrintJob 中的方法
使用指定的作业属性打印文档。
print(MultiDoc, PrintRequestAttributeSet) - 接口 javax.print.MultiDocPrintJob 中的方法
使用指定的作业属性打印 MultiDoc。
print(Graphics) - 类 javax.swing.JComponent 中的方法
调用此方法打印指定 Graphics 的组件。
print() - 类 javax.swing.JTable 中的方法
一个便捷的方法，它显示一个打印对话框，然后以 PrintMode.FIT_WIDTH 模式打印此 JTable，不打印标题或脚注文本。
print(JTable.PrintMode) - 类 javax.swing.JTable 中的方法
一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，不打印标题或脚注文本。
print(JTable.PrintMode, MessageFormat, MessageFormat) - 类 javax.swing.JTable 中的方法
一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，打印指定的标题和脚注文本。
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean) - 类 javax.swing.JTable 中的方法
根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService) - 类 javax.swing.JTable 中的方法
打印此 JTable。
print() - 类 javax.swing.text.JTextComponent 中的方法
一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，不打印标题和脚注文本。
print(MessageFormat, MessageFormat) - 类 javax.swing.text.JTextComponent 中的方法
一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，打印指定的标题和脚注文本。
print(MessageFormat, MessageFormat, boolean, PrintService, PrintRequestAttributeSet, boolean) - 类 javax.swing.text.JTextComponent 中的方法
打印此 JTextComponent 的内容。
PRINT_SCREEN - 类 java.awt.Event 中的静态变量
Print Screen 键，一个非 ASCII 操作键。
PRINTABLE - 类 java.awt.PageAttributes.OriginType 中的静态变量
用于指定可打印原点的 OriginType 实例。
Printable - java.awt.print 中的 接口
Printable 接口由当前页面 painter 的 print 方法实现，该方法由打印系统调用，以呈现页面。
PRINTABLE - 类 javax.print.DocFlavor.SERVICE_FORMATTED 中的静态变量
打印数据表示形式类名 = "java.awt.print.Printable"（printable 对象）的服务格式化打印数据 DocFlavor。
printAll(Graphics) - 类 java.awt.Component 中的方法
打印此组件及其所有子组件。
printAll(Graphics) - 类 javax.swing.JComponent 中的方法
调用此方法打印组件。
printAnySimpleType(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串值转换为一个字符串。
printAnySimpleType(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串值转换为一个字符串。
printBase64Binary(byte[]) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字节数组转换为一个字符串。
printBase64Binary(byte[]) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字节数组转换为一个字符串。
printBoolean(boolean) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 boolean 值转换为一个字符串。
printBoolean(boolean) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 boolean 值转换为一个字符串。
printBorder(Graphics) - 类 javax.swing.JComponent 中的方法
打印组件的边框。
printByte(byte) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 byte 值转换为一个字符串。
printByte(byte) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 byte 值转换为一个字符串。
printChildren(Graphics) - 类 javax.swing.JComponent 中的方法
打印此组件的子组件。
printComponent(Graphics) - 类 javax.swing.JComponent 中的方法
在打印操作期间调用此方法。
printComponents(Graphics) - 类 java.awt.Container 中的方法
打印此容器中的每个组件。
printComponents(Graphics) - 类 java.awt.ScrollPane 中的方法
显示此滚动窗格中的组件。
PrintConversionEvent - javax.xml.bind 中的 接口
此事件指示将 Java 内容树中的数据转换为其词汇表示形式时遇到一个问题。
PrintConversionEventImpl - javax.xml.bind.helpers 中的 类
PrintConversionEvent 接口的默认实现。
PrintConversionEventImpl(int, String, ValidationEventLocator) - 类 javax.xml.bind.helpers.PrintConversionEventImpl 的构造方法
创建新的 PrintConversionEventImpl。
PrintConversionEventImpl(int, String, ValidationEventLocator, Throwable) - 类 javax.xml.bind.helpers.PrintConversionEventImpl 的构造方法
创建新的 PrintConversionEventImpl。
printDataTransferCompleted(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。
printDataTransferCompleted(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。
printDate(Calendar) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 Calendar 值转换为一个字符串。
printDate(Calendar) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 Calendar 值转换为一个字符串。
printDateTime(Calendar) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 Calendar 值转换为一个字符串。
printDateTime(Calendar) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 Calendar 值转换为一个字符串。
printDecimal(BigDecimal) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 BigDecimal 值转换为一个字符串。
printDecimal(BigDecimal) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 BigDecimal 值转换为一个字符串。
printDialog() - 类 java.awt.print.PrinterJob 中的方法
向用户呈现一个对话框，用来更改打印作业的属性。
printDialog(PrintRequestAttributeSet) - 类 java.awt.print.PrinterJob 中的方法
为所有服务显示跨平台打印对话框的便捷方法，这些服务能够使用 Pageable 接口打印 2D 图形。
printDialog(GraphicsConfiguration, int, int, PrintService[], PrintService, DocFlavor, PrintRequestAttributeSet) - 类 javax.print.ServiceUI 中的静态方法
为用户提供一个选择 PrintService（打印机）的对话框。
printDouble(double) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 double 值转换为一个字符串。
printDouble(double) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 double 值转换为一个字符串。
printElements(Writer, Element...) - 接口 javax.lang.model.util.Elements 中的方法
按指定顺序将元素的表示形式打印到给定 writer。
PRINTER - 类 java.awt.JobAttributes.DestinationType 中的静态变量
用于指定打印到打印机的 DestinationType 实例。
PRINTER_STOPPED - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机的 PrinterState 属性值为 STOPPED。
PRINTER_STOPPED_PARTLY - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机的 PrinterStateReasons 属性值包含 STOPPED_PARTLY 的 PrinterStateReason 值。
PrinterAbortException - java.awt.print 中的 异常
PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
PrinterAbortException() - 异常 java.awt.print.PrinterAbortException 的构造方法
构造不带详细信息的新 PrinterAbortException。
PrinterAbortException(String) - 异常 java.awt.print.PrinterAbortException 的构造方法
构造带指定详细信息的新 PrinterAbortException。
PrinterException - java.awt.print 中的 异常
PrinterException 类及其子类用于指示打印系统中发生的异常情况。
PrinterException() - 异常 java.awt.print.PrinterException 的构造方法
构造不带详细信息的新 PrinterException 对象。
PrinterException(String) - 异常 java.awt.print.PrinterException 的构造方法
构造带指定详细信息的新 PrinterException 对象。
PrinterGraphics - java.awt.print 中的 接口
PrinterGraphics 接口由被传递到 Printable 对象以呈现页面的 Graphics 对象实现。
PrinterInfo - javax.print.attribute.standard 中的 类
PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
PrinterInfo(String, Locale) - 类 javax.print.attribute.standard.PrinterInfo 的构造方法
构造具有给定信息字符串和语言环境的新 PrinterInfo 属性。
PrinterIOException - java.awt.print 中的 异常
PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。
PrinterIOException(IOException) - 异常 java.awt.print.PrinterIOException 的构造方法
构造具有指定 IOException 字符串表示形式的新 PrinterIOException。
PrinterIsAcceptingJobs - javax.print.attribute.standard 中的 类
PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
PrinterIsAcceptingJobs(int) - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 的构造方法
构造具有给定整数值的新 PrinterIsAcceptingJobs 枚举值。
PrinterJob - java.awt.print 中的 类
PrinterJob 类是控制打印的主要类。
PrinterJob() - 类 java.awt.print.PrinterJob 的构造方法
应使用静态 getPrinterJob 方法创建 PrinterJob 对象。
PrinterLocation - javax.print.attribute.standard 中的 类
PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
PrinterLocation(String, Locale) - 类 javax.print.attribute.standard.PrinterLocation 的构造方法
构造具有给定位置和语言环境的新 PrinterLocation 属性。
PrinterMakeAndModel - javax.print.attribute.standard 中的 类
PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
PrinterMakeAndModel(String, Locale) - 类 javax.print.attribute.standard.PrinterMakeAndModel 的构造方法
构造具有给定制造和型号字符串以及语言环境的新 PrinterMakeAndModel 属性。
PrinterMessageFromOperator - javax.print.attribute.standard 中的 类
PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
PrinterMessageFromOperator(String, Locale) - 类 javax.print.attribute.standard.PrinterMessageFromOperator 的构造方法
构造具有给定消息和语言环境的新 PrinterMessageFromOperator 属性。
PrinterMoreInfo - javax.print.attribute.standard 中的 类
PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
PrinterMoreInfo(URI) - 类 javax.print.attribute.standard.PrinterMoreInfo 的构造方法
构造具有指定 URI 的新 PrinterMoreInfo 属性。
PrinterMoreInfoManufacturer - javax.print.attribute.standard 中的 类
PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
PrinterMoreInfoManufacturer(URI) - 类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 的构造方法
构造具有指定 URI 的新 PrinterMoreInfoManufacturer 属性。
PrinterName - javax.print.attribute.standard 中的 类
PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
PrinterName(String, Locale) - 类 javax.print.attribute.standard.PrinterName 的构造方法
构造具有给定名称和语言环境的新 PrinterName 属性。
PrinterResolution - javax.print.attribute.standard 中的 类
PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
PrinterResolution(int, int, int) - 类 javax.print.attribute.standard.PrinterResolution 的构造方法
根据给定的项构造新的 PrinterResolution 属性。
PrinterState - javax.print.attribute.standard 中的 类
PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
PrinterState(int) - 类 javax.print.attribute.standard.PrinterState 的构造方法
构造具有给定整数值的新 PrinterState 枚举值。
PrinterStateReason - javax.print.attribute.standard 中的 类
PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
PrinterStateReason(int) - 类 javax.print.attribute.standard.PrinterStateReason 的构造方法
构造具有给定整数值的新 PrinterStateReason 枚举值。
PrinterStateReasons - javax.print.attribute.standard 中的 类
PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
PrinterStateReasons() - 类 javax.print.attribute.standard.PrinterStateReasons 的构造方法
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有默认的初始容量和加载因子。
PrinterStateReasons(int) - 类 javax.print.attribute.standard.PrinterStateReasons 的构造方法
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有给定的初始容量和默认的加载因子。
PrinterStateReasons(int, float) - 类 javax.print.attribute.standard.PrinterStateReasons 的构造方法
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有给定的初始容量和加载因子。
PrinterStateReasons(Map<PrinterStateReason, Severity>) - 类 javax.print.attribute.standard.PrinterStateReasons 的构造方法
构造一个新的 PrinterStateReasons 属性，它包括与给定映射相同的 PrinterStateReason 到 Severity 映射关系。
printerStateReasonSet(Severity) - 类 javax.print.attribute.standard.PrinterStateReasons 中的方法
在此 PrinterStateReasons 中，获得在给定的严重性级别每个 PrinterStateReasons 属性的不可修改的视图集。
PrinterURI - javax.print.attribute.standard 中的 类
PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。
PrinterURI(URI) - 类 javax.print.attribute.standard.PrinterURI 的构造方法
构建具有指定 URI 的新 PrinterURI 属性。
PrintEvent - javax.print.event 中的 类
类 PrintEvent 是所有 Print Service API 事件的超类。
PrintEvent(Object) - 类 javax.print.event.PrintEvent 的构造方法
构造一个 PrintEvent 对象。
PrintException - javax.print 中的 异常
类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。
PrintException() - 异常 javax.print.PrintException 的构造方法
构造不带详细消息的 print 异常。
PrintException(String) - 异常 javax.print.PrintException 的构造方法
构造带给定详细消息的 print 异常。
PrintException(Exception) - 异常 javax.print.PrintException 的构造方法
构造链接了所提供异常的 print 异常。
PrintException(String, Exception) - 异常 javax.print.PrintException 的构造方法
构造带给定详细消息和链异常的 print 异常。
printf(String, Object...) - 类 java.io.Console 中的方法
使用指定格式字符串和参数将格式化字符串写入此控制台输出流的便捷方法。
printf(String, Object...) - 类 java.io.PrintStream 中的方法
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。
printf(Locale, String, Object...) - 类 java.io.PrintStream 中的方法
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。
printf(String, Object...) - 类 java.io.PrintWriter 中的方法
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
printf(Locale, String, Object...) - 类 java.io.PrintWriter 中的方法
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
printFloat(float) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 float 值转换为一个字符串。
printFloat(float) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 float 值转换为一个字符串。
PrintGraphics - java.awt 中的 接口
提供页面的打印图形上下文的抽象类。
printHexBinary(byte[]) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字节数组转换为一个字符串。
printHexBinary(byte[]) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字节数组转换为一个字符串。
printInt(int) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 int 值转换为一个字符串。
printInt(int) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 int 值转换为一个字符串。
printInteger(BigInteger) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 BigInteger 值转换为一个字符串。
printInteger(BigInteger) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 BigInteger 值转换为一个字符串。
PrintJob - java.awt 中的 类
启动并执行打印作业的抽象类。
PrintJob() - 类 java.awt.PrintJob 的构造方法
PrintJobAdapter - javax.print.event 中的 类
接收打印作业事件的抽象适配器类。
PrintJobAdapter() - 类 javax.print.event.PrintJobAdapter 的构造方法
PrintJobAttribute - javax.print.attribute 中的 接口
PrintJobAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印作业”的状态或“打印作业”的一些其他特征。
PrintJobAttributeEvent - javax.print.event 中的 类
类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。
PrintJobAttributeEvent(DocPrintJob, PrintJobAttributeSet) - 类 javax.print.event.PrintJobAttributeEvent 的构造方法
构造一个 PrintJobAttributeEvent 对象。
PrintJobAttributeListener - javax.print.event 中的 接口
此接口的实现连接到 DocPrintJob，以监视与此打印作业关联的属性状态的更改。
PrintJobAttributeSet - javax.print.attribute 中的 接口
接口 PrintJobAttributeSet 为打印作业属性（即：实现接口 PrintJobAttribute 的打印属性）集指定接口。
printJobCanceled(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，作业已被用户或程序取消。
printJobCanceled(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，作业已被用户或程序取消。
printJobCompleted(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，作业已成功完成。
printJobCompleted(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，作业已成功完成。
PrintJobEvent - javax.print.event 中的 类
类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。
PrintJobEvent(DocPrintJob, int) - 类 javax.print.event.PrintJobEvent 的构造方法
构造一个 PrintJobEvent 对象。
printJobFailed(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。
printJobFailed(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。
PrintJobListener - javax.print.event 中的 接口
此侦听器接口的实现应该连接到 DocPrintJob，以监视打印机作业的状态。
printJobNoMoreEvents(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，不需要再提供事件。
printJobNoMoreEvents(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，不需要再提供事件。
printJobRequiresAttention(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，可能会发生一些用户可纠正的问题（例如打印机缺纸）。
printJobRequiresAttention(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，发生了一个用户也许能够修复的错误，可以生成此事件的一个错误示例是打印机用完了纸张。
println() - 类 java.io.PrintStream 中的方法
通过写入行分隔符字符串终止当前行。
println(boolean) - 类 java.io.PrintStream 中的方法
打印 boolean 值，然后终止行。
println(char) - 类 java.io.PrintStream 中的方法
打印字符，然后终止该行。
println(int) - 类 java.io.PrintStream 中的方法
打印整数，然后终止该行。
println(long) - 类 java.io.PrintStream 中的方法
打印 long，然后终止该行。
println(float) - 类 java.io.PrintStream 中的方法
打印 float，然后终止该行。
println(double) - 类 java.io.PrintStream 中的方法
打印 double，然后终止该行。
println(char[]) - 类 java.io.PrintStream 中的方法
打印字符数组，然后终止该行。
println(String) - 类 java.io.PrintStream 中的方法
打印 String，然后终止该行。
println(Object) - 类 java.io.PrintStream 中的方法
打印 Object，然后终止该行。
println() - 类 java.io.PrintWriter 中的方法
通过写入行分隔符字符串终止当前行。
println(boolean) - 类 java.io.PrintWriter 中的方法
打印 boolean 值，然后终止该行。
println(char) - 类 java.io.PrintWriter 中的方法
打印字符，然后终止该行。
println(int) - 类 java.io.PrintWriter 中的方法
打印整数，然后终止该行。
println(long) - 类 java.io.PrintWriter 中的方法
打印 long 整数，然后终止该行。
println(float) - 类 java.io.PrintWriter 中的方法
打印浮点数，然后终止该行。
println(double) - 类 java.io.PrintWriter 中的方法
打印双精度浮点数，然后终止该行。
println(char[]) - 类 java.io.PrintWriter 中的方法
打印字符数组，然后终止该行。
println(String) - 类 java.io.PrintWriter 中的方法
打印 String，然后终止该行。
println(Object) - 类 java.io.PrintWriter 中的方法
打印 Object，然后终止该行。
println(String) - 类 java.sql.DriverManager 中的静态方法
将一条消息打印到当前 JDBC 日志流中。
printLong(long) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 long 值转换为一个字符串。
printLong(long) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 long 值转换为一个字符串。
printMessage(Diagnostic.Kind, CharSequence) - 接口 javax.annotation.processing.Messager 中的方法
打印指定种类的消息。
printMessage(Diagnostic.Kind, CharSequence, Element) - 接口 javax.annotation.processing.Messager 中的方法
在元素的位置上打印指定种类的消息。
printMessage(Diagnostic.Kind, CharSequence, Element, AnnotationMirror) - 接口 javax.annotation.processing.Messager 中的方法
在已注释元素的注释镜像位置上打印指定种类的消息。
printMessage(Diagnostic.Kind, CharSequence, Element, AnnotationMirror, AnnotationValue) - 接口 javax.annotation.processing.Messager 中的方法
在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。
printQName(QName, NamespaceContext) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 QName 实例转换为一个字符串。
printQName(QName, NamespaceContext) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 QName 实例转换为一个字符串。
PrintQuality - javax.print.attribute.standard 中的 类
PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
PrintQuality(int) - 类 javax.print.attribute.standard.PrintQuality 的构造方法
构造具有给定整数值的新 PrintQuality 枚举值。
PrintRequestAttribute - javax.print.attribute 中的 接口
接口 PrintRequestAttribute 是打印属性类实现的标记接口，以指示属性表示用于打印作业的请求设置。
PrintRequestAttributeSet - javax.print.attribute 中的 接口
接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。
PrintService - javax.print 中的 接口
接口 PrintService 是 DocPrintJob 的工厂。
PrintServiceAttribute - javax.print.attribute 中的 接口
接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。
PrintServiceAttributeEvent - javax.print.event 中的 类
类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。
PrintServiceAttributeEvent(PrintService, PrintServiceAttributeSet) - 类 javax.print.event.PrintServiceAttributeEvent 的构造方法
构造一个 PrintServiceAttributeEvent 对象。
PrintServiceAttributeListener - javax.print.event 中的 接口
此侦听器接口的实现连接到 PrintService，以便监视打印服务的状态。
PrintServiceAttributeSet - javax.print.attribute 中的 接口
接口 PrintServiceAttributeSet 为打印作业属性（即：实现接口 PrintServiceAttribute 的打印属性）集指定接口。
PrintServiceLookup - javax.print 中的 类
此类的实现为特定类型的 PrintService（通常等效于打印机）提供查找服务。
PrintServiceLookup() - 类 javax.print.PrintServiceLookup 的构造方法
printShort(short) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 short 值转换为一个字符串。
printShort(short) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 short 值转换为一个字符串。
printStackTrace() - 类 java.lang.Throwable 中的方法
将此 throwable 及其追踪输出至标准错误流。
printStackTrace(PrintStream) - 类 java.lang.Throwable 中的方法
将此 throwable 及其追踪输出到指定的输出流。
printStackTrace(PrintWriter) - 类 java.lang.Throwable 中的方法
将此 throwable 及其追踪输出到指定的 PrintWriter。
printStackTrace(PrintStream) - 异常 javax.xml.bind.JAXBException 中的方法
打印此 JAXBException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
printStackTrace() - 异常 javax.xml.bind.JAXBException 中的方法
打印此 JAXBException 及其对 System.err 的堆栈跟踪（如果为非 null，则包括 linkedException 的堆栈跟踪）。
printStackTrace(PrintWriter) - 异常 javax.xml.bind.JAXBException 中的方法
打印此 JAXBException 及其对 PrintWriter 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
printStackTrace(PrintStream) - 异常 javax.xml.bind.TypeConstraintException 中的方法
打印此 TypeConstraintException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
printStackTrace() - 异常 javax.xml.bind.TypeConstraintException 中的方法
打印此 TypeConstraintException 及其对 System.err 的堆栈跟踪（如果为非 null，则包括 linkedException 的堆栈跟踪。
printStackTrace() - 异常 javax.xml.crypto.dsig.TransformException 中的方法
将此 TransformException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.dsig.TransformException 中的方法
将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印流中。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.dsig.TransformException 中的方法
将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印编写器。
printStackTrace() - 异常 javax.xml.crypto.dsig.XMLSignatureException 中的方法
将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.dsig.XMLSignatureException 中的方法
将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.dsig.XMLSignatureException 中的方法
将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。
printStackTrace() - 异常 javax.xml.crypto.KeySelectorException 中的方法
将此 KeySelectorException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.KeySelectorException 中的方法
将此 KeySelectorException、它的追踪和 cause 追踪打印到指定的打印流。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.KeySelectorException 中的方法
将此 KeySelectorException、它的追踪和 cause 追踪打印到指定打印编写器。
printStackTrace() - 异常 javax.xml.crypto.MarshalException 中的方法
将此 MarshalException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.MarshalException 中的方法
将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印流。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.MarshalException 中的方法
将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印编写器。
printStackTrace() - 异常 javax.xml.crypto.NoSuchMechanismException 中的方法
将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.NoSuchMechanismException 中的方法
将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定的打印流。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.NoSuchMechanismException 中的方法
将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定打印编写器。
printStackTrace() - 异常 javax.xml.crypto.URIReferenceException 中的方法
将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.URIReferenceException 中的方法
将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.URIReferenceException 中的方法
将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印编写器。
printStackTrace() - 异常 javax.xml.transform.TransformerException 中的方法
打印从中产生错误的方法跟踪。
printStackTrace(PrintStream) - 异常 javax.xml.transform.TransformerException 中的方法
打印从中产生错误的方法跟踪。
printStackTrace(PrintWriter) - 异常 javax.xml.transform.TransformerException 中的方法
打印从中产生错误的方法跟踪。
printStackTrace(PrintStream) - 异常 javax.xml.xpath.XPathException 中的方法
将堆栈跟踪打印到指定的 PrintStream。
printStackTrace() - 异常 javax.xml.xpath.XPathException 中的方法
将堆栈跟踪打印到 System.err。
printStackTrace(PrintWriter) - 异常 javax.xml.xpath.XPathException 中的方法
将堆栈跟踪打印到指定的 PrintWriter。
PrintStream - java.io 中的 类
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintStream(OutputStream) - 类 java.io.PrintStream 的构造方法
创建新的打印流。
PrintStream(OutputStream, boolean) - 类 java.io.PrintStream 的构造方法
创建新的打印流。
PrintStream(OutputStream, boolean, String) - 类 java.io.PrintStream 的构造方法
创建新的打印流。
PrintStream(String) - 类 java.io.PrintStream 的构造方法
创建具有指定文件名称且不带自动行刷新的新打印流。
PrintStream(String, String) - 类 java.io.PrintStream 的构造方法
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintStream(File) - 类 java.io.PrintStream 的构造方法
创建具有指定文件且不带自动行刷新的新打印流。
PrintStream(File, String) - 类 java.io.PrintStream 的构造方法
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
printString(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个字符串。
printString(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个字符串。
printTime(Calendar) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 Calendar 值转换为一个字符串。
printTime(Calendar) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 Calendar 值转换为一个字符串。
printUnsignedInt(long) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 long 值转换为一个字符串。
printUnsignedInt(long) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 long 值转换为一个字符串。
printUnsignedShort(int) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 int 值转换为一个字符串。
printUnsignedShort(int) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 int 值转换为一个字符串。
PrintWriter - java.io 中的 类
向文本输出流打印对象的格式化表示形式。
PrintWriter(Writer) - 类 java.io.PrintWriter 的构造方法
创建不带自动行刷新的新 PrintWriter。
PrintWriter(Writer, boolean) - 类 java.io.PrintWriter 的构造方法
创建新 PrintWriter。
PrintWriter(OutputStream) - 类 java.io.PrintWriter 的构造方法
根据现有的 OutputStream 创建不带自动行刷新的新 PrintWriter。
PrintWriter(OutputStream, boolean) - 类 java.io.PrintWriter 的构造方法
通过现有的 OutputStream 创建新的 PrintWriter。
PrintWriter(String) - 类 java.io.PrintWriter 的构造方法
创建具有指定文件名称且不带自动行刷新的新 PrintWriter。
PrintWriter(String, String) - 类 java.io.PrintWriter 的构造方法
创建具有指定文件名称和字符集且不带自动行刷新的新 PrintWriter。
PrintWriter(File) - 类 java.io.PrintWriter 的构造方法
使用指定文件创建不具有自动行刷新的新 PrintWriter。
PrintWriter(File, String) - 类 java.io.PrintWriter 的构造方法
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。
PRIOR - 类 java.awt.BufferCapabilities.FlipContents 中的静态变量
当翻转内容为 PRIOR 时，后台缓冲区的内容为前台缓冲区的先前内容（真实的页面翻转）。
PRIORITY_INTERCHAR - 类 java.awt.font.GlyphJustificationInfo 中的静态变量
次低调整 priority。
PRIORITY_KASHIDA - 类 java.awt.font.GlyphJustificationInfo 中的静态变量
最高调整 priority。
PRIORITY_NONE - 类 java.awt.font.GlyphJustificationInfo 中的静态变量
最低调整 priority。
PRIORITY_WHITESPACE - 类 java.awt.font.GlyphJustificationInfo 中的静态变量
次高调整 priority。
PriorityBlockingQueue<E> - java.util.concurrent 中的 类
一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
PriorityBlockingQueue() - 类 java.util.concurrent.PriorityBlockingQueue 的构造方法
用默认的初始容量 (11) 创建一个 PriorityBlockingQueue，并根据元素的自然顺序对其元素进行排序。
PriorityBlockingQueue(int) - 类 java.util.concurrent.PriorityBlockingQueue 的构造方法
使用指定的初始容量创建一个 PriorityBlockingQueue，并根据元素的自然顺序对其元素进行排序。
PriorityBlockingQueue(int, Comparator<? super E>) - 类 java.util.concurrent.PriorityBlockingQueue 的构造方法
使用指定的初始容量创建一个 PriorityBlockingQueue，并根据指定的比较器对其元素进行排序。
PriorityBlockingQueue(Collection<? extends E>) - 类 java.util.concurrent.PriorityBlockingQueue 的构造方法
创建一个包含指定 collection 元素的 PriorityBlockingQueue。
PriorityQueue<E> - java.util 中的 类
一个基于优先级堆的无界优先级队列。
PriorityQueue() - 类 java.util.PriorityQueue 的构造方法
使用默认的初始容量（11）创建一个 PriorityQueue，并根据其自然顺序对元素进行排序。
PriorityQueue(int) - 类 java.util.PriorityQueue 的构造方法
使用指定的初始容量创建一个 PriorityQueue，并根据其自然顺序对元素进行排序。
PriorityQueue(int, Comparator<? super E>) - 类 java.util.PriorityQueue 的构造方法
使用指定的初始容量创建一个 PriorityQueue，并根据指定的比较器对元素进行排序。
PriorityQueue(Collection<? extends E>) - 类 java.util.PriorityQueue 的构造方法
创建包含指定 collection 中元素的 PriorityQueue。
PriorityQueue(PriorityQueue<? extends E>) - 类 java.util.PriorityQueue 的构造方法
创建包含指定优先级队列元素的 PriorityQueue。
PriorityQueue(SortedSet<? extends E>) - 类 java.util.PriorityQueue 的构造方法
创建包含指定有序 set 元素的 PriorityQueue。
PRIVATE - 类 java.lang.reflect.Modifier 中的静态变量
表示 private 修饰符的 int 值。
PRIVATE - 类 java.nio.channels.FileChannel.MapMode 中的静态变量
专用（写入时拷贝）映射模式。
PRIVATE_KEY - 类 javax.crypto.Cipher 中的静态变量
用于表示要解包的密钥为“私钥”的常量。
PRIVATE_MEMBER - org.omg.CORBA 中的 接口
定义 ValueMember 类中私有成员的常量。
PRIVATE_USE - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Co”。
PRIVATE_USE_AREA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Private Use Area”Unicode 字符块的常量。
PrivateClassLoader - javax.management.loading 中的 接口
指示不应将某个 ClassLoader 添加到 ClassLoaderRepository 的标记接口。
PrivateCredentialPermission - javax.security.auth 中的 类
此类用来保护对属于特定 Subject 的私有 Credential 的访问。
PrivateCredentialPermission(String, String) - 类 javax.security.auth.PrivateCredentialPermission 的构造方法
创建具有指定 name 的新 PrivateCredentialPermission。
PrivateKey - java.security 中的 接口
私钥。
PrivateMLet - javax.management.loading 中的 类
不添加到 ClassLoaderRepository 的 MLet。
PrivateMLet(URL[], boolean) - 类 javax.management.loading.PrivateMLet 的构造方法
使用默认的委托父 ClassLoader 为指定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[], ClassLoader, boolean) - 类 javax.management.loading.PrivateMLet 的构造方法
为给定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[], ClassLoader, URLStreamHandlerFactory, boolean) - 类 javax.management.loading.PrivateMLet 的构造方法
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新 PrivateMLet。
PrivilegedAction<T> - java.security 中的 接口
启用特权的情况下要执行的计算。
PrivilegedActionException - java.security 中的 异常
doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
PrivilegedActionException(Exception) - 异常 java.security.PrivilegedActionException 的构造方法
构造一个新的“包装”指定 Exception 的 PrivilegedActionException。
privilegedCallable(Callable<T>) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可在当前的访问控制上下文中执行给定的 callable 对象。
privilegedCallableUsingCurrentClassLoader(Callable<T>) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可在当前的访问控制上下文中，使用当前上下文类加载器作为上下文类加载器来执行给定的 callable 对象。
PrivilegedExceptionAction<T> - java.security 中的 接口
在启用特权的情况下将要执行的计算，会抛出一个或多个经过检查的异常。
privilegedThreadFactory() - 类 java.util.concurrent.Executors 中的静态方法
返回用于创建新线程的线程工厂，这些新线程与当前线程具有相同的权限。
probablePrime(int, Random) - 类 java.math.BigInteger 中的静态方法
返回有可能是素数的、具有指定长度的正 BigInteger。
procedureColumnIn - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中存储了 IN 参数。
procedureColumnInOut - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中存储了 INOUT 参数。
procedureColumnOut - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中存储了 OUT 参数。
procedureColumnResult - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中存储了结果。
procedureColumnReturn - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中存储了返回值。
procedureColumnUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列的类型为未知。
procedureNoNulls - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不允许使用 NULL 值。
procedureNoResult - 接口 java.sql.DatabaseMetaData 中的静态变量
指示过程不返回结果。
procedureNullable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示允许使用 NULL 值。
procedureNullableUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道是否允许使用 NULL 值。
procedureResultUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道过程是否返回结果。
procedureReturnsResult - 接口 java.sql.DatabaseMetaData 中的静态变量
指示过程返回结果。
Process - java.lang 中的 类
ProcessBuilder.start() 和 Runtime.exec 方法创建一个本机进程，并返回 Process 子类的一个实例，该实例可用来控制进程并获得相关信息。
Process() - 类 java.lang.Process 的构造方法
process(Set<? extends TypeElement>, RoundEnvironment) - 类 javax.annotation.processing.AbstractProcessor 中的方法
处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
process(Set<? extends TypeElement>, RoundEnvironment) - 接口 javax.annotation.processing.Processor 中的方法
处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
process(List<V>) - 类 javax.swing.SwingWorker 中的方法
在事件指派线程 上异步地从 publish 方法接收数据块。
processActionEvent(ActionEvent) - 类 java.awt.Button 中的方法
处理发生在此按钮上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。
processActionEvent(ActionEvent) - 类 java.awt.List 中的方法
处理发生在此列表上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。
processActionEvent(ActionEvent) - 类 java.awt.MenuItem 中的方法
处理此菜单项上发生的动作事件，方法是将其指派给任何已注册的 ActionListener 对象。
processActionEvent(ActionEvent) - 类 java.awt.TextField 中的方法
处理发生在此文本字段上的操作事件：将这些事件指派给所有已注册的 ActionListener 对象。
processAdjustmentEvent(AdjustmentEvent) - 类 java.awt.Scrollbar 中的方法
处理此滚动条上发生的调整事件，方法是将其指派到任意已注册的 AdjustmentListener 对象。
ProcessBuilder - java.lang 中的 类
此类用于创建操作系统进程。
ProcessBuilder(List<String>) - 类 java.lang.ProcessBuilder 的构造方法
利用指定的操作系统程序和参数构造一个进程生成器。
ProcessBuilder(String...) - 类 java.lang.ProcessBuilder 的构造方法
利用指定的操作系统程序和参数构造一个进程生成器。
processComponentEvent(ComponentEvent) - 类 java.awt.Component 中的方法
处理组件上发生的组件事件，方法是将其指派到任意已注册的 ComponentListener 对象。
processComponentKeyEvent(KeyEvent) - 类 javax.swing.JComponent 中的方法
处理该组件本身可识别的所有键事件。
processContainerEvent(ContainerEvent) - 类 java.awt.Container 中的方法
通过将发生在此容器上的容器事件指派给所有已注册的 ContainerListener 对象来处理这些事件。
processEvent(AWTEvent) - 类 java.awt.Button 中的方法
处理此按钮上的事件。
processEvent(AWTEvent) - 类 java.awt.Checkbox 中的方法
处理关于此复选框的事件。
processEvent(AWTEvent) - 类 java.awt.CheckboxMenuItem 中的方法
处理此复选框菜单项上的事件。
processEvent(AWTEvent) - 类 java.awt.Choice 中的方法
处理关于此选择的事件。
processEvent(AWTEvent) - 类 java.awt.Component 中的方法
处理组件上发生的事件。
processEvent(AWTEvent) - 类 java.awt.Container 中的方法
处理关于此容器的事件。
processEvent(AWTEvent) - 类 java.awt.List 中的方法
此滚动列表的进程事件。
processEvent(AWTEvent) - 类 java.awt.MenuComponent 中的方法
处理发生在此菜单组件上的事件。
processEvent(AWTEvent) - 类 java.awt.MenuItem 中的方法
处理此菜单项上的事件。
processEvent(AWTEvent) - 类 java.awt.Scrollbar 中的方法
处理在滚动条上发生的事件。
processEvent(AWTEvent) - 类 java.awt.TextComponent 中的方法
处理此文本组件上发生的事件。
processEvent(AWTEvent) - 类 java.awt.TextField 中的方法
处理此文本字段上的事件。
processEvent(AWTEvent) - 类 java.awt.Window 中的方法
处理此窗口上的事件。
processFocusEvent(FocusEvent) - 类 java.awt.Component 中的方法
处理组件上发生的焦点事件，方法是将其指派到任意已注册的 FocusListener 对象。
processFocusEvent(FocusEvent) - 类 javax.swing.JFormattedTextField 中的方法
处理所有的焦点事件，如 FocusEvent.FOCUS_GAINED 或 FocusEvent.FOCUS_LOST。
processFocusEvent(FocusEvent) - 类 javax.swing.JPopupMenu 中的方法
processHierarchyBoundsEvent(HierarchyEvent) - 类 java.awt.Component 中的方法
处理组件上发生的层次结构边界事件，方法是将其指派到任意已注册的 HierarchyBoundsListener 对象。
processHierarchyEvent(HierarchyEvent) - 类 java.awt.Component 中的方法
处理组件上发生的层次结构事件，方法是将其指派到任意已注册的 HierarchyListener 对象。
processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent) - 类 javax.swing.text.html.HTMLDocument 中的方法
处理 HTML 框架中的文档所生成的 HyperlinkEvents。
processImageComplete() - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 imageComplete 方法向其广播图像读取的完成。
processImageComplete() - 类 javax.imageio.ImageWriter 中的方法
通过调用 imageComplete 方法向所有已注册 IIOWriteProgressListener 广播图像写入的完成。
processImageProgress(float) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 imageProgress 方法向其广播图像完成的当前百分比。
processImageProgress(float) - 类 javax.imageio.ImageWriter 中的方法
通过调用 imageProgress 方法向所有已注册 IIOWriteProgressListener 广播图像完成的当前百分比。
processImageStarted(int) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 imageStarted 方法向其广播图像读取起始处。
processImageStarted(int) - 类 javax.imageio.ImageWriter 中的方法
通过调用 imageStarted 方法向所有已注册 IIOWriteProgressListener 广播开始写入图像的起始处。
processImageUpdate(BufferedImage, int, int, int, int, int, int, int[]) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 imageUpdate 方法向其广播样本集合的更新。
PROCESSING - 类 javax.print.attribute.standard.JobState 中的静态变量
正在处理作业。
PROCESSING - 类 javax.print.attribute.standard.PrinterState 中的静态变量
指示正在处理作业；处理完成前新作业需等待。
PROCESSING_INSTRUCTION - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一条处理指令
PROCESSING_INSTRUCTION_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 ProcessingInstruction。
PROCESSING_STOPPED - 类 javax.print.attribute.standard.JobState 中的静态变量
由于某些原因，正在处理时作业已停止，且当这些原因不再存在时，作业返回到 PROCESSING 状态。
PROCESSING_TO_STOP_POINT - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
请求者已取消作业，或打印机已中止作业，但打印机仍在执行该作业的某些操作，直到遇到指定的停止点，或已完成作业终止/清除操作。
processingEnv - 类 javax.annotation.processing.AbstractProcessor 中的变量
工具框架提供的处理环境。
ProcessingEnvironment - javax.annotation.processing 中的 接口
注释处理工具框架将提供一个具有实现此接口的对象的注释 processor，因此 processor 可以使用该框架提供的设施来编写新文件、报告错误消息并查找其他实用工具。
ProcessingInstruction - javax.xml.stream.events 中的 接口
描述处理指令中的数据的接口。
ProcessingInstruction - org.w3c.dom 中的 接口
ProcessingInstruction 接口表示“处理指令”，该指令作为一种在文档的文本中保持特定于处理器的信息的方法在 XML 中使用。
processingInstruction(String, String) - 接口 org.xml.sax.ContentHandler 中的方法
接收处理指令的通知。
processingInstruction(String, String) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收处理指令的通知。
processingInstruction(String, String) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收处理指令的通知。
processingInstruction(String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收处理指令的通知。
processingInstruction(String, String) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
processingInstruction(String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个处理指令事件。
processingInstruction(String, String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 处理指令事件。
processingOver() - 接口 javax.annotation.processing.RoundEnvironment 中的方法
如果此 round 生成的类型不是以注释处理的后续 round 为准，则返回 true；否则返回 false。
processInputMethodEvent(InputMethodEvent) - 类 java.awt.Component 中的方法
处理组件上发生的输入方法事件，方法是将其指派到任意已注册的 InputMethodListener 对象。
processInputMethodEvent(InputMethodEvent) - 类 javax.swing.JFormattedTextField 中的方法
处理所有的输入法事件，如 InputMethodEvent.INPUT_METHOD_TEXT_CHANGED 或 InputMethodEvent.CARET_POSITION_CHANGED。
processInputMethodEvent(InputMethodEvent) - 类 javax.swing.text.JTextComponent 中的方法
processItemEvent(ItemEvent) - 类 java.awt.Checkbox 中的方法
处理发生在此复选框上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
processItemEvent(ItemEvent) - 类 java.awt.CheckboxMenuItem 中的方法
处理发生在此复选框菜单项上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
processItemEvent(ItemEvent) - 类 java.awt.Choice 中的方法
处理发生在此 Choice 菜单上的项事件，实现方式是将这些事件指派给所有已注册的 ItemListener 对象。
processItemEvent(ItemEvent) - 类 java.awt.List 中的方法
处理发生在此列表上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - 类 javax.swing.JComponent 中的方法
由于发生 KeyEvent e 而调用此方法处理 ks 的键绑定。
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - 类 javax.swing.JMenuBar 中的方法
子类化以检查所有子菜单。
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - 类 javax.swing.JTable 中的方法
processKeyBindings(KeyEvent) - 类 javax.swing.SwingUtilities 中的静态方法
处理与 event 关联的 Component 的键绑定。
processKeyEvent(KeyEvent) - 类 java.awt.Component 中的方法
处理组件上发生的按键事件，方法是将其指派到任意已注册的 KeyListener 对象。
processKeyEvent(Component, KeyEvent) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法才会启动一个焦点遍历操作。
processKeyEvent(Component, KeyEvent) - 类 java.awt.KeyboardFocusManager 中的方法
当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法启动焦点遍历操作。
processKeyEvent(KeyEvent) - 类 javax.swing.JComboBox 中的方法
处理 KeyEvent，查找 Tab 键。
processKeyEvent(KeyEvent) - 类 javax.swing.JComponent 中的方法
重写 processKeyEvent 以处理事件。
processKeyEvent(KeyEvent) - 类 javax.swing.JMenu 中的方法
处理键击事件，如助记符和加速器。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JMenuBar 中的方法
实现为 MenuElement（不执行任何操作）。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JMenuItem 中的方法
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
processKeyEvent(KeyEvent) - 类 javax.swing.JPopupMenu 中的方法
处理快捷键事件，如助记符和加速器。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JPopupMenu 中的方法
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - 接口 javax.swing.MenuElement 中的方法
处理键事件。
processKeyEvent(KeyEvent) - 类 javax.swing.MenuSelectionManager 中的方法
当 MenuElement 从 KeyListener 接收事件时，它决不应直接处理该事件。
processMenuDragMouseEvent(MenuDragMouseEvent) - 类 javax.swing.JMenuItem 中的方法
处理菜单中的鼠标拖动。
processMenuKeyEvent(MenuKeyEvent) - 类 javax.swing.JMenuItem 中的方法
处理菜单中的快捷键。
processMouseEvent(MouseEvent) - 类 java.awt.Component 中的方法
处理组件上发生的鼠标事件，方法是将其指派到任意已注册的 MouseListener 对象。
processMouseEvent(MouseEvent) - 类 javax.swing.JComponent 中的方法
处理此组件上发生的鼠标事件，通过将其指派到任意已注册的 MouseListener 对象来完成，有关此方法的完整描述，请参阅 Component.processMouseEvent(MouseEvent)。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JMenuBar 中的方法
实现为 MenuElement（不执行任何操作）。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JMenuItem 中的方法
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的鼠标事件并更改菜单选择。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JPopupMenu 中的方法
要求此方法遵守 MenuElement 接口，但它没有被实现。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - 接口 javax.swing.MenuElement 中的方法
处理鼠标事件。
processMouseEvent(MouseEvent) - 类 javax.swing.MenuSelectionManager 中的方法
当 MenuElement 从 MouseListener 接收事件时，它决不应直接处理该事件。
processMouseEvent(JMenuItem, MouseEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 中的方法
processMouseEvent(JMenuItem, MouseEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 中的方法
processMouseMotionEvent(MouseEvent) - 类 java.awt.Component 中的方法
处理组件上发生的鼠标移动事件，方法是将其指派到任意已注册的 MouseMotionListener 事件。
processMouseMotionEvent(MouseEvent) - 类 javax.swing.JComponent 中的方法
处理鼠标移动事件，如 MouseEvent.MOUSE_DRAGGED。
processMouseWheelEvent(MouseWheelEvent) - 类 java.awt.Component 中的方法
处理组件上发生的鼠标滚轮事件，方法是将其指派到任意已注册的 MouseWheelListener 对象。
processMouseWheelEvent(MouseWheelEvent) - 类 java.awt.ScrollPane 中的方法
处理通过滚动适当量而传递给此 ScrollPane 的鼠标滚轮事件。
processName(String, String[], boolean) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
declarePrefix() 处理完当前上下文中的所有声明之后，处理原始 XML 限定名称。
Processor - javax.annotation.processing 中的 接口
注释 Processor 的接口。
processPassComplete(BufferedImage) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 passComplete 方法向其广播逐步传递的结束。
processPassStarted(BufferedImage, int, int, int, int, int, int, int, int[]) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 passStarted 方法向其广播逐步传递的开始。
processReadAborted() - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 readAborted 方法向其广播读取已经中止。
processSequenceComplete() - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 sequenceComplete 方法向其广播图像读取序列的完成。
processSequenceStarted(int) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 sequenceStarted 方法向其广播图像读取序列的起始处。
processTextEvent(TextEvent) - 类 java.awt.TextComponent 中的方法
处理发生在此文本组件上的文本事件：将这些事件指派给所有已注册的 TextListener 对象。
processThumbnailComplete() - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 thumbnailComplete 方法向其广播缩略图读取的完成。
processThumbnailComplete() - 类 javax.imageio.ImageWriter 中的方法
通过调用 thumbnailComplete 方法向所有已注册 IIOWriteProgressListener 广播缩略图写入的完成。
processThumbnailPassComplete(BufferedImage) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassComplete 方法向其广播缩略图逐步传递的结束。
processThumbnailPassStarted(BufferedImage, int, int, int, int, int, int, int, int[]) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassStarted 方法向其广播缩略图逐步传递的开始。
processThumbnailProgress(float) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 thumbnailProgress 方法向其广播缩略图完成的当前百分比。
processThumbnailProgress(float) - 类 javax.imageio.ImageWriter 中的方法
通过调用 thumbnailProgress 方法向所有已注册 IIOWriteProgressListener 广播缩略图完成的当前百分比。
processThumbnailStarted(int, int) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 thumbnailStarted 方法向其广播缩略图读取的起始处。
processThumbnailStarted(int, int) - 类 javax.imageio.ImageWriter 中的方法
通过调用 thumbnailStarted 方法向所有已注册 IIOWriteProgressListener 广播缩略图写入的起始处。
processThumbnailUpdate(BufferedImage, int, int, int, int, int, int, int[]) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 thumbnailUpdate 方法向其广播缩略图图像中样本集合的更新。
processWarningOccurred(String) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播警告消息。
processWarningOccurred(String, String) - 类 javax.imageio.ImageReader 中的方法
通过使用取自 ResourceBundle 的字符串调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播本地化警告消息。
processWarningOccurred(int, String) - 类 javax.imageio.ImageWriter 中的方法
通过调用 warningOccurred 方法向所有已注册 IIOWriteWarningListener 广播一条警告消息。
processWarningOccurred(int, String, String) - 类 javax.imageio.ImageWriter 中的方法
通过使用取自 ResourceBundle 的字符串调用 warningOccurred 方法来向所有已注册 IIOWriteWarningListener 广播一条本地化警告消息。
processWindowEvent(WindowEvent) - 类 java.awt.Window 中的方法
处理此窗口上发生的窗口事件：将它们指派到任何注册的 WindowListener 对象。
processWindowEvent(WindowEvent) - 类 javax.swing.JDialog 中的方法
根据 defaultCloseOperation 属性的状态处理窗口事件。
processWindowEvent(WindowEvent) - 类 javax.swing.JFrame 中的方法
处理此组件上发生的窗口事件。
processWindowFocusEvent(WindowEvent) - 类 java.awt.Window 中的方法
处理此窗口上发生的窗口焦点事件：将它们指派到任何注册的 WindowFocusListener 对象。
processWindowStateEvent(WindowEvent) - 类 java.awt.Window 中的方法
处理此窗口上发生的窗口状态事件：将它们指派到任何注册的 WindowStateListener 对象。
processWriteAborted() - 类 javax.imageio.ImageWriter 中的方法
通过调用 readAborted 方法向对所有已注册 IIOWriteProgressListener 广播写入已经中止。
profile_data - 类 org.omg.IOP.TaggedProfile 中的变量
关联的配置文件数据。
ProfileDataException - java.awt.color 中的 异常
当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。
ProfileDataException(String) - 异常 java.awt.color.ProfileDataException 的构造方法
构造带指定详细消息的 ProfileDataException。
ProfileIdHelper - org.omg.IOP 中的 类
配置文件 ID
ProfileIdHelper() - 类 org.omg.IOP.ProfileIdHelper 的构造方法
profiles - 类 org.omg.IOP.IOR 中的变量
与此对象引用关联的一组有标记的配置文件。
program - 类 javax.sound.midi.VoiceStatus 中的变量
此声音当前正在使用的乐器的程序号。
PROGRAM_CHANGE - 类 javax.sound.midi.ShortMessage 中的静态变量
PROGRAM_CHANGE 消息的命令值（0xC0 或 192）
programChange(int) - 接口 javax.sound.midi.MidiChannel 中的方法
更改一个程序（包）。
programChange(int, int) - 接口 javax.sound.midi.MidiChannel 中的方法
使用库和程序（包）号更改程序。
PROGRESS - 接口 java.util.jar.Pack200.Packer 中的静态变量
解包器的百分比进度，由解包器定期更新。
PROGRESS - 接口 java.util.jar.Pack200.Unpacker 中的静态变量
解包器的百分比进度，由解包器定期更新。
PROGRESS_BAR - 类 javax.accessibility.AccessibleRole 中的静态变量
用于指示某项任务已完成多少的对象。
PROGRESS_BAR - 类 javax.swing.plaf.synth.Region 中的静态变量
ProgressBar 的 region。
PROGRESS_MONITOR - 类 javax.accessibility.AccessibleRole 中的静态变量
该职责表示监视某个操作进度的对象。
progressBar - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的变量
ProgressBarUI - javax.swing.plaf 中的 类
JProgressBar 的可插入外观界面。
ProgressBarUI() - 类 javax.swing.plaf.ProgressBarUI 的构造方法
progressiveMode - 类 javax.imageio.ImageWriteParam 中的变量
控制逐步编码的模式，必须将它设置为除 MODE_EXPLICIT 以外的四个 MODE_* 值之一。
progressListeners - 类 javax.imageio.ImageReader 中的变量
当前已注册 IIOReadProgressListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
progressListeners - 类 javax.imageio.ImageWriter 中的变量
当前已注册 IIOWriteProgressListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。
ProgressMonitor - javax.swing 中的 类
监视某个操作的进度的类。
ProgressMonitor(Component, Object, String, int, int) - 类 javax.swing.ProgressMonitor 的构造方法
构造一个图形对象，它一般会根据进程的完成情况通过填充矩形条来显示进度。
ProgressMonitor.AccessibleProgressMonitor - javax.swing 中的 类
AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。
ProgressMonitor.AccessibleProgressMonitor() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 的构造方法
AccessibleProgressMonitor 构造方法
ProgressMonitorInputStream - javax.swing 中的 类
监视读取某些 InputStream 的进度。
ProgressMonitorInputStream(Component, Object, InputStream) - 类 javax.swing.ProgressMonitorInputStream 的构造方法
构造一个对象，以监视输入流的进度。
progressString - 类 javax.swing.JProgressBar 中的变量
可以在进度条上显示的可选字符串。
PROMPT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
propagatedFrom - 类 java.beans.beancontext.BeanContextEvent 中的变量
作为此事件传播源的 BeanContext
PROPERTIES - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示该图像的属性现在可用。
properties() - 接口 java.util.jar.Pack200.Packer 中的方法
获取此引擎属性集。
properties() - 接口 java.util.jar.Pack200.Unpacker 中的方法
获取此引擎属性集。
Properties - java.util 中的 类
Properties 类表示了一个持久的属性集。
Properties() - 类 java.util.Properties 的构造方法
创建一个无默认值的空属性列表。
Properties(Properties) - 类 java.util.Properties 的构造方法
创建一个带有指定默认值的空属性列表。
properties() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得属性的一个不可修改的映射。
properties() - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得不可修改的属性映射。
properties() - 类 javax.sound.sampled.AudioFormat 中的方法
获取不可修改的属性映射。
PROPERTY - 类 org.w3c.dom.bootstrap.DOMImplementationRegistry 中的静态变量
指定 DOMImplementationSource 类名称的系统属性。
propertyChange(PropertyChangeEvent) - 类 java.beans.beancontext.BeanContextSupport 中的方法
子类可以封装此方法来监视子类属性的更改。
propertyChange(PropertyChangeEvent) - 接口 java.beans.PropertyChangeListener 中的方法
在绑定属性发生更改时调用此方法。
propertyChange(PropertyChangeEvent) - 类 java.beans.PropertyChangeListenerProxy 中的方法
将属性更改事件转发给侦听器代理。
propertyChange(PropertyChangeEvent) - 类 javax.swing.JList.AccessibleJList 中的方法
Property Change Listener 更改方法。
propertyChange(PropertyChangeEvent) - 类 javax.swing.JPopupMenu.AccessibleJPopupMenu 中的方法
更改绑定 (bound) 属性时调用此方法。
propertyChange(PropertyChangeEvent) - 类 javax.swing.JScrollPane.AccessibleJScrollPane 中的方法
当有一个绑定 (bound) 属性改变时，此方法被调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
由 JFormattedTextField 的 PropertyChangeListener 调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪选择模型、列模型等的变更，从而能够重新将侦听器放置这些模型上，以便把信息传递给 Accessibility PropertyChange 机制
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的方法
当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，调用此方法。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener 中的方法
从 JInternalFrame 检测状态更改并处理动作。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler 中的方法
如果 PropertyChangeEvent e 的源等于 optionPane 并且为 ICON_PROPERTY、MESSAGE_PROPERTY、OPTIONS_PROPERTY 或 INITIAL_VALUE_PROPERTY 之一，则调用 validateComponent。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
在根窗格上发生属性更改时调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
属性更改事件（假定发自 JSplitPane）将在必要时传递 updateOrientation 的消息。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler 中的方法
从包含接收者的 JSplitPane 传递消息。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTextPaneUI 中的方法
当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
当关联的 JTextComponent 上有一个绑定属性更改时，此方法被调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.PropertyListener 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalRootPaneUI 中的方法
属性更改时调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalTextFieldUI 中的方法
此方法在关联的 JTextComponent 上的绑定 (bound) 属性发生更改时调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
更改绑定 (bound) 属性时，调用此方法。
propertyChange(PropertyChangeEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
Property Change Listener 更改方法。
PropertyChangeEvent - java.beans 中的 类
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
PropertyChangeEvent(Object, String, Object, Object) - 类 java.beans.PropertyChangeEvent 的构造方法
构造一个新的 PropertyChangeEvent。
PropertyChangeListener - java.beans 中的 接口
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。
propertyChangeListener - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
propertyChangeListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
propertyChangeListener - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicListUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
从 createPropertyChangeListener 返回的 PropertyChangeListener。
propertyChangeListener - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
此 JSplitPane 的 PropertyChangeListener 的实例。
propertyChangeListener - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
PropertyChangeListenerProxy - java.beans 中的 类
扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。
PropertyChangeListenerProxy(String, PropertyChangeListener) - 类 java.beans.PropertyChangeListenerProxy 的构造方法
将 PropertyChangeListener 绑定到特定属性的构造方法。
PropertyChangeSupport - java.beans 中的 类
这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。
PropertyChangeSupport(Object) - 类 java.beans.PropertyChangeSupport 的构造方法
构造一个 PropertyChangeSupport 对象。
PropertyDescriptor - java.beans 中的 类
PropertyDescriptor 描述 Java Bean 通过一对存储器方法导出的一个属性。
PropertyDescriptor(String, Class<?>) - 类 java.beans.PropertyDescriptor 的构造方法
通过调用 getFoo 和 setFoo 存取方法，为符合标准 Java 约定的属性构造一个 PropertyDescriptor。
PropertyDescriptor(String, Class<?>, String, String) - 类 java.beans.PropertyDescriptor 的构造方法
此构造方法带有一个简单属性的名称和用于读写属性的方法名称。
PropertyDescriptor(String, Method, Method) - 类 java.beans.PropertyDescriptor 的构造方法
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。
PropertyEditor - java.beans 中的 接口
PropertyEditor 类为希望允许用户编辑某个给定类型的属性值的 GUI 提供支持。
PropertyEditorManager - java.beans 中的 类
PropertyEditorManager 可用于查找任何给定类型名称的属性编辑器。
PropertyEditorManager() - 类 java.beans.PropertyEditorManager 的构造方法
PropertyEditorSupport - java.beans 中的 类
这是一个帮助构建属性编辑器的支持类。
PropertyEditorSupport() - 类 java.beans.PropertyEditorSupport 的构造方法
构造一个 PropertyEditorSupport 对象。
PropertyEditorSupport(Object) - 类 java.beans.PropertyEditorSupport 的构造方法
构造一个 PropertyEditorSupport 对象。
PropertyException - javax.xml.bind 中的 异常
此异常指示在获取或设置属性时遇到一个错误。
PropertyException(String) - 异常 javax.xml.bind.PropertyException 的构造方法
构造带指定详细消息的 PropertyException。
PropertyException(String, String) - 异常 javax.xml.bind.PropertyException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 PropertyException。
PropertyException(Throwable) - 异常 javax.xml.bind.PropertyException 的构造方法
构造带有一个 linkedException 的 PropertyException。
PropertyException(String, Throwable) - 异常 javax.xml.bind.PropertyException 的构造方法
构造带指定详细消息和 linkedException 的 PropertyException。
PropertyException(String, String, Throwable) - 异常 javax.xml.bind.PropertyException 的构造方法
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 PropertyException。
PropertyException(String, Object) - 异常 javax.xml.bind.PropertyException 的构造方法
构造一个基于属性名称和 value.toString() 设置其消息字段的 PropertyException。
propertyKey - 类 javax.swing.plaf.basic.BasicHTML 中的静态变量
存储为 JComponent 的客户端属性时用于 html 渲染器的键。
propertyListener - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
PROPERTYNAME - 接口 java.beans.DesignMode 中的静态变量
从 BeanContext 或 PropertyChangeEvent 的其他源激发的 propertyName 的标准值。
propertyNames() - 类 java.util.Properties 中的方法
返回属性列表中所有键的枚举，如果在主属性列表中未找到同名的键，则包括默认属性列表中不同的键。
PropertyPermission - java.util 中的 类
此类用于属性权限。
PropertyPermission(String, String) - 类 java.util.PropertyPermission 的构造方法
创建带指定名称的新 PropertyPermission 对象。
PropertyResourceBundle - java.util 中的 类
PropertyResourceBundle 是 ResourceBundle 的一个具体子类，它使用属性文件中的静态字符串集来管理语言环境资源。
PropertyResourceBundle(InputStream) - 类 java.util.PropertyResourceBundle 的构造方法
根据 InputStream 创建属性资源包。
PropertyResourceBundle(Reader) - 类 java.util.PropertyResourceBundle 的构造方法
根据 Reader 创建属性资源包。
PropertyVetoException - java.beans 中的 异常
当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。
PropertyVetoException(String, PropertyChangeEvent) - 异常 java.beans.PropertyVetoException 的构造方法
构造带详细消息的 PropertyVetoException。
PROTECTED - 类 java.lang.reflect.Modifier 中的静态变量
表示 protected 修饰符的 int 值。
ProtectionDomain - java.security 中的 类
此 ProtectionDomain 类封装域的特征，域中包装一个类集合，在代表给定的主体集合执行这些类的实例时会授予它们一个权限集合。
ProtectionDomain(CodeSource, PermissionCollection) - 类 java.security.ProtectionDomain 的构造方法
创建具有给定 CodeSource 和 Permissions 的新 ProtectionDomain。
ProtectionDomain(CodeSource, PermissionCollection, ClassLoader, Principal[]) - 类 java.security.ProtectionDomain 的构造方法
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。
PROTOCOL_PROVIDER_CLASS_LOADER - 类 javax.management.remote.JMXConnectorFactory 中的静态变量
指定用于加载协议提供者的类加载器的属性名称。
PROTOCOL_PROVIDER_CLASS_LOADER - 类 javax.management.remote.JMXConnectorServerFactory 中的静态变量
指定用于加载协议提供者的类加载器的属性名称。
PROTOCOL_PROVIDER_PACKAGES - 类 javax.management.remote.JMXConnectorFactory 中的静态变量
指定查找协议的处理程序时需参考的提供者包的属性名称。
PROTOCOL_PROVIDER_PACKAGES - 类 javax.management.remote.JMXConnectorServerFactory 中的静态变量
指定查找协议的处理程序时需参考的提供者包的属性名称。
PROTOCOL_VERSION_1 - 接口 java.io.ObjectStreamConstants 中的静态变量
流协议的版本。
PROTOCOL_VERSION_2 - 接口 java.io.ObjectStreamConstants 中的静态变量
流协议的版本。
ProtocolException - java.net 中的 异常
抛出此异常指示在底层协议中存在错误，如 TCP 错误。
ProtocolException(String) - 异常 java.net.ProtocolException 的构造方法
构造带指定详细消息的新 ProtocolException。
ProtocolException() - 异常 java.net.ProtocolException 的构造方法
构造不带详细消息的新 ProtocolException。
ProtocolException - javax.xml.ws 中的 异常
ProtocolException 类是与特定协议绑定有关的异常的基类。
ProtocolException() - 异常 javax.xml.ws.ProtocolException 的构造方法
构造一个新的协议异常，将 null 作为它的详细消息。
ProtocolException(String) - 异常 javax.xml.ws.ProtocolException 的构造方法
构造一个具有指定详细消息的新协议异常。
ProtocolException(String, Throwable) - 异常 javax.xml.ws.ProtocolException 的构造方法
构造一个具有指定详细消息和 cause 的新运行时异常。
ProtocolException(Throwable) - 异常 javax.xml.ws.ProtocolException 的构造方法
构造具有指定 cause 和详细消息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新运行时异常。
prototypeCellValueChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
provideErrorFeedback(Component) - 类 javax.swing.LookAndFeel 中的方法
在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。
provideErrorFeedback(Component) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。
provider() - 类 java.nio.channels.SelectableChannel 中的方法
返回创建此通道的提供者。
provider() - 类 java.nio.channels.Selector 中的方法
返回创建此通道的提供者。
provider() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
返回创建此通道的提供者。
provider() - 类 java.nio.channels.spi.AbstractSelector 中的方法
返回创建此通道的提供者。
provider() - 类 java.nio.channels.spi.SelectorProvider 中的静态方法
返回此次调用 Java 虚拟机的系统级默认选择器提供者。
Provider - java.security 中的 类
此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。
Provider(String, double, String) - 类 java.security.Provider 的构造方法
用指定的名称、版本号和信息构造一个 provider。
Provider<T> - javax.xml.ws 中的 接口
服务端点可以将 Provider 接口作为 SEI 的动态替代方法实现。
Provider - javax.xml.ws.spi 中的 类
ServiceDelegate 和 Endpoint 对象的服务提供者。
Provider() - 类 javax.xml.ws.spi.Provider 的构造方法
创建一个新的 Provider 实例。
provider() - 类 javax.xml.ws.spi.Provider 中的静态方法
创建一个新的提供者对象。
Provider.Service - java.security 中的 类
安全服务的描述。
Provider.Service(Provider, String, String, String, List<String>, Map<String, String>) - 类 java.security.Provider.Service 的构造方法
构造新的服务。
PROVIDER_URL - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定要使用的服务提供者配置信息的环境属性名称。
ProviderException - java.security 中的 异常
用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。
ProviderException() - 异常 java.security.ProviderException 的构造方法
构造不带详细消息的 ProviderException。
ProviderException(String) - 异常 java.security.ProviderException 的构造方法
构造带指定详细消息的 ProviderException。
ProviderException(String, Throwable) - 异常 java.security.ProviderException 的构造方法
创建带指定的详细消息和 cause 的 ProviderException。
ProviderException(Throwable) - 异常 java.security.ProviderException 的构造方法
创建带指定的 cause 和详细消息的 ProviderException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
proxy - 类 java.beans.beancontext.BeanContextServicesSupport 中的变量
BeanContextServiceProvider 的委托。
Proxy - java.lang.reflect 中的 类
Proxy 提供用于创建动态代理类和实例的静态方法，它还是由这些方法创建的所有动态代理类的超类。
Proxy(InvocationHandler) - 类 java.lang.reflect.Proxy 的构造方法
使用其调用处理程序的指定值从子类（通常为动态代理类）构建新的 Proxy 实例。
Proxy - java.net 中的 类
此类表示代理设置，通常为类型（http、socks）和套接字地址。
Proxy(Proxy.Type, SocketAddress) - 类 java.net.Proxy 的构造方法
创建表示 PROXY 连接的条目。
Proxy.Type - java.net 中的 枚举
表示代理类型。
ProxySelector - java.net 中的 类
连接到 URL 引用的网络资源时选择要使用的代理服务器（如果有）。
ProxySelector() - 类 java.net.ProxySelector 的构造方法
PSource - javax.crypto.spec 中的 类
此类为在 OAEP 冗余中的编码输入 P 指定源，OAEP 冗余在 PKCS #1 标准中定义。
PSource(String) - 类 javax.crypto.spec.PSource 的构造方法
使用指定的 PSource 算法为 PKCS #1 标准中定义的 OAEP 冗余构造一个编码输入 P 的源。
PSource.PSpecified - javax.crypto.spec 中的 类
此类用于显式地指定 OAEP 冗余中编码输入 P 的值。
PSource.PSpecified(byte[]) - 类 javax.crypto.spec.PSource.PSpecified 的构造方法
将指定的值 p 作为编码输入 P 显式地构造源。
PSSParameterSpec - java.security.spec 中的 类
此类指定 RSA-PSS 签名方案的参数规范，如 PKCS#1 v2.1 标准中所定义的。
PSSParameterSpec(String, String, AlgorithmParameterSpec, int, int) - 类 java.security.spec.PSSParameterSpec 的构造方法
根据 PKCS #1 中的定义，使用指定的消息摘要、掩码生成函数、掩码生成函数的参数、salt 长度和尾部字段值，创建一个新的 PSSParameterSpec。
PSSParameterSpec(int) - 类 java.security.spec.PSSParameterSpec 的构造方法
使用指定的 salt 长度和 PKCS#1 定义的其他默认值创建一个新的 PSSParameterSpec。
ptLineDist(double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
返回从点到线的距离。
ptLineDist(double, double) - 类 java.awt.geom.Line2D 中的方法
返回从点到此线的距离。
ptLineDist(Point2D) - 类 java.awt.geom.Line2D 中的方法
返回从 Point2D 到此线的距离。
ptLineDistSq(double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
返回从点到线的距离的平方。
ptLineDistSq(double, double) - 类 java.awt.geom.Line2D 中的方法
返回从点到此线的距离的平方。
ptLineDistSq(Point2D) - 类 java.awt.geom.Line2D 中的方法
返回从指定 Point2D 到此线的距离的平方。
ptSegDist(double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
返回从点到线段的距离。
ptSegDist(double, double) - 类 java.awt.geom.Line2D 中的方法
返回从点到此线段的距离。
ptSegDist(Point2D) - 类 java.awt.geom.Line2D 中的方法
返回从 Point2D 到此线段的距离的平方。
ptSegDistSq(double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
返回从点到线段的距离的平方。
ptSegDistSq(double, double) - 类 java.awt.geom.Line2D 中的方法
返回从点到此线段的距离的平方。
ptSegDistSq(Point2D) - 类 java.awt.geom.Line2D 中的方法
返回从 Point2D 到此线段的距离的平方。
PUBLIC - 接口 java.lang.reflect.Member 中的静态变量
标识类或接口的所有公共成员（包括继承成员）的集合。
PUBLIC - 类 java.lang.reflect.Modifier 中的静态变量
表示 public 修饰符的 int 值。
PUBLIC - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
PUBLIC_KEY - 类 javax.crypto.Cipher 中的静态变量
用于表示要解包的密钥为“公钥”的常量。
PUBLIC_MEMBER - org.omg.CORBA 中的 接口
定义 ValueMember 类中公共成员的常量。
PUBLIC_XML_SCHEMA - 接口 javax.sql.rowset.WebRowSet 中的静态变量
为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的公共标识符。
PublicKey - java.security 中的 接口
公钥。
publish(LogRecord) - 类 java.util.logging.ConsoleHandler 中的方法
发布 LogRecord。
publish(LogRecord) - 类 java.util.logging.FileHandler 中的方法
格式化并发布 LogRecord。
publish(LogRecord) - 类 java.util.logging.Handler 中的方法
发布 LogRecord。
publish(LogRecord) - 类 java.util.logging.MemoryHandler 中的方法
将 LogRecord 存储在内部缓冲区。
publish(LogRecord) - 类 java.util.logging.SocketHandler 中的方法
格式化并发布 LogRecord。
publish(LogRecord) - 类 java.util.logging.StreamHandler 中的方法
格式化并发布 LogRecord。
publish(V...) - 类 javax.swing.SwingWorker 中的方法
将数据块发送给 SwingWorker.process(java.util.List) 方法。
publish(String) - 类 javax.xml.ws.Endpoint 中的方法
在给定地址处发布此端点。
publish(String, Object) - 类 javax.xml.ws.Endpoint 中的静态方法
在给定地址处针对指定的实现者对象创建并发布端点。
publish(Object) - 类 javax.xml.ws.Endpoint 中的方法
在提供的服务器上下文中发布此端点。
purge() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
尝试从工作队列移除所有已取消的 Future 任务。
purge() - 类 java.util.Timer 中的方法
从此计时器的任务队列中移除所有已取消的任务。
purgeRelations() - 类 javax.management.relation.RelationService 中的方法
肃清关系。
purgeRelations() - 接口 javax.management.relation.RelationServiceMBean 中的方法
肃清关系。
push(EventQueue) - 类 java.awt.EventQueue 中的方法
用指定的事件队列替换现有的 EventQueue。
push(E) - 类 java.util.ArrayDeque 中的方法
将元素推入此双端队列所表示的堆栈。
push(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
将元素推入此双端队列表示的栈。
push(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
push(E) - 接口 java.util.Deque 中的方法
将一个元素推入此双端队列所表示的堆栈（换句话说，此双端队列的头部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用空间，则抛出 IllegalStateException。
push(E) - 类 java.util.LinkedList 中的方法
将元素推入此列表所表示的堆栈。
push() - 类 java.util.logging.MemoryHandler 中的方法
将所有已缓冲的输出 push 到目标 Handler 中。
push(E) - 类 java.util.Stack 中的方法
把项压入堆栈顶部。
PUSH_BUTTON - 类 javax.accessibility.AccessibleRole 中的静态变量
用户可以操作以通知应用程序执行某任务的对象。
pushBack() - 类 java.io.StreamTokenizer 中的方法
导致对此标记生成器的 nextToken 方法的下一个调用返回 ttype 字段中的当前值，而不修改 nval 或 sval 字段中的值。
PushbackInputStream - java.io 中的 类
PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。
PushbackInputStream(InputStream, int) - 类 java.io.PushbackInputStream 的构造方法
使用指定 size 的推回缓冲区创建 PushbackInputStream，并保存其参数（即输入流 in），以供将来使用。
PushbackInputStream(InputStream) - 类 java.io.PushbackInputStream 的构造方法
创建 PushbackInputStream 并保存其参数（即输入流 in），以供将来使用。
PushbackReader - java.io 中的 类
允许将字符推回到流的字符流 reader。
PushbackReader(Reader, int) - 类 java.io.PushbackReader 的构造方法
创建具有给定大小推回缓冲区的新推回 reader。
PushbackReader(Reader) - 类 java.io.PushbackReader 的构造方法
创建具有单字符推回缓冲区的新推回 reader。
pushCharacterStyle() - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
将当前字符样式压入堆栈，以准备形成新的嵌套字符样式。
pushContext() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
开始新的名称空间上下文。
put(Object, Object) - 类 java.awt.RenderingHints 中的方法
将指定 key 映射到此 RenderingHints 对象中指定的 value。
put(String, boolean) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 boolean 字段的值置于持久字段中。
put(String, byte) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 byte 字段值置于持久字段中。
put(String, char) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 char 字段的值置于持久字段中。
put(String, short) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 short 字段的值置于持久字段中。
put(String, int) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 int 字段的值置于持久字段中。
put(String, long) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 long 字段的值置于持久字段中。
put(String, float) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 float 字段的值置于持久字段中。
put(String, double) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 double 字段的值置于持久字段中。
put(String, Object) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 Object 字段的值置于持久字段中。
put(URI, Map<String, List<String>>) - 类 java.net.CookieHandler 中的方法
将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
put(URI, Map<String, List<String>>) - 类 java.net.CookieManager 中的方法
put(URI, URLConnection) - 类 java.net.ResponseCache 中的方法
协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。
put(byte) - 类 java.nio.ByteBuffer 中的方法
相对 put 方法（可选操作）。
put(int, byte) - 类 java.nio.ByteBuffer 中的方法
绝对 put 方法（可选操作）。
put(ByteBuffer) - 类 java.nio.ByteBuffer 中的方法
相对批量 put 方法（可选操作）。
put(byte[], int, int) - 类 java.nio.ByteBuffer 中的方法
相对批量 put 方法（可选操作）。
put(byte[]) - 类 java.nio.ByteBuffer 中的方法
相对批量 put 方法（可选操作）。
put(char) - 类 java.nio.CharBuffer 中的方法
相对 put 方法（可选操作）。
put(int, char) - 类 java.nio.CharBuffer 中的方法
绝对 put 方法（可选操作）。
put(CharBuffer) - 类 java.nio.CharBuffer 中的方法
相对批量 put 方法（可选操作）。
put(char[], int, int) - 类 java.nio.CharBuffer 中的方法
相对批量 put 方法（可选操作）。
put(char[]) - 类 java.nio.CharBuffer 中的方法
相对批量 put 方法（可选操作）。
put(String, int, int) - 类 java.nio.CharBuffer 中的方法
相对批量 put 方法（可选操作）。
put(String) - 类 java.nio.CharBuffer 中的方法
相对批量 put 方法（可选操作）。
put(double) - 类 java.nio.DoubleBuffer 中的方法
相对 put 方法（可选操作）。
put(int, double) - 类 java.nio.DoubleBuffer 中的方法
绝对 put 方法（可选操作）。
put(DoubleBuffer) - 类 java.nio.DoubleBuffer 中的方法
相对批量 put 方法（可选操作）。
put(double[], int, int) - 类 java.nio.DoubleBuffer 中的方法
相对批量 put 方法（可选操作）。
put(double[]) - 类 java.nio.DoubleBuffer 中的方法
相对批量 put 方法（可选操作）。
put(float) - 类 java.nio.FloatBuffer 中的方法
相对 put 方法（可选操作）。
put(int, float) - 类 java.nio.FloatBuffer 中的方法
绝对 put 方法（可选操作）。
put(FloatBuffer) - 类 java.nio.FloatBuffer 中的方法
相对批量 put 方法（可选操作）。
put(float[], int, int) - 类 java.nio.FloatBuffer 中的方法
相对批量 put 方法（可选操作）。
put(float[]) - 类 java.nio.FloatBuffer 中的方法
相对批量 put 方法（可选操作）。
put(int) - 类 java.nio.IntBuffer 中的方法
相对 put 方法（可选操作）。
put(int, int) - 类 java.nio.IntBuffer 中的方法
绝对 put 方法（可选操作）。
put(IntBuffer) - 类 java.nio.IntBuffer 中的方法
相对批量 put 方法（可选操作）。
put(int[], int, int) - 类 java.nio.IntBuffer 中的方法
相对批量 put 方法（可选操作）。
put(int[]) - 类 java.nio.IntBuffer 中的方法
相对批量 put 方法（可选操作）。
put(long) - 类 java.nio.LongBuffer 中的方法
相对 put 方法（可选操作）。
put(int, long) - 类 java.nio.LongBuffer 中的方法
绝对 put 方法（可选操作）。
put(LongBuffer) - 类 java.nio.LongBuffer 中的方法
相对批量 put 方法（可选操作）。
put(long[], int, int) - 类 java.nio.LongBuffer 中的方法
相对批量 put 方法（可选操作）。
put(long[]) - 类 java.nio.LongBuffer 中的方法
相对批量 put 方法（可选操作）。
put(short) - 类 java.nio.ShortBuffer 中的方法
相对 put 方法（可选操作）。
put(int, short) - 类 java.nio.ShortBuffer 中的方法
绝对 put 方法（可选操作）。
put(ShortBuffer) - 类 java.nio.ShortBuffer 中的方法
相对批量 put 方法（可选操作）。
put(short[], int, int) - 类 java.nio.ShortBuffer 中的方法
相对批量 put 方法（可选操作）。
put(short[]) - 类 java.nio.ShortBuffer 中的方法
相对批量 put 方法（可选操作）。
put(Object, Object) - 类 java.security.Provider 中的方法
设置 key 属性，使其具有指定的 value。
put(K, V) - 类 java.util.AbstractMap 中的方法
将指定的值与此映射中的指定键关联（可选操作）。
put(E) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
将指定的元素插入此队列的尾部，如果该队列已满，则等待可用的空间。
put(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将一直等待可用空间。
put(E) - 接口 java.util.concurrent.BlockingQueue 中的方法
将指定元素插入此队列中，将等待可用的空间（如果有必要）。
put(K, V) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
将指定键映射到此表中的指定值。
put(K, V) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
将指定值与此映射中的指定键关联。
put(E) - 类 java.util.concurrent.DelayQueue 中的方法
将指定元素插入此延迟队列。
put(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
put(E) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
将指定元素插入到此队列的尾部，如有必要，则等待空间变得可用。
put(E) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
将指定元素插入此优先级队列。
put(E) - 类 java.util.concurrent.SynchronousQueue 中的方法
将指定元素添加到此队列，如有必要则等待另一个线程接收它。
put(K, V) - 类 java.util.Dictionary 中的方法
将指定 key 映射到此 dictionary 中指定 value。
put(K, V) - 类 java.util.EnumMap 中的方法
将指定值与此映射中指定键关联。
put(K, V) - 类 java.util.HashMap 中的方法
在此映射中关联指定值与指定键。
put(K, V) - 类 java.util.Hashtable 中的方法
将指定 key 映射到此哈希表中的指定 value。
put(K, V) - 类 java.util.IdentityHashMap 中的方法
在此标识哈希映射中关联指定值与指定键。
put(Object, Object) - 类 java.util.jar.Attributes 中的方法
在此 Map 中将指定的值关联到指定的属性名称（键）。
put(K, V) - 接口 java.util.Map 中的方法
将指定的值与此映射中的指定键关联（可选操作）。
put(String, String) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.put(String,String) 中的规范实现 put 方法。
put(String, String) - 类 java.util.prefs.Preferences 中的方法
将指定值与此首选项节点中的指定键相关联。
put(K, V) - 类 java.util.TreeMap 中的方法
将指定值与此映射中的指定键进行关联。
put(K, V) - 类 java.util.WeakHashMap 中的方法
关联此映射中的指定值与指定键。
put(CompositeData) - 接口 javax.management.openmbean.TabularData 中的方法
将 value 添加到此 TabularData 实例。
put(Object, Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
此方法仅调用 put((CompositeData) value)，因此忽略其可能为 null 的 key 参数。
put(CompositeData) - 类 javax.management.openmbean.TabularDataSupport 中的方法
put(String, Object) - 接口 javax.naming.directory.Attributes 中的方法
向属性集中添加新属性。
put(Attribute) - 接口 javax.naming.directory.Attributes 中的方法
向属性集中添加新属性。
put(String, Object) - 类 javax.naming.directory.BasicAttributes 中的方法
put(Attribute) - 类 javax.naming.directory.BasicAttributes 中的方法
put(PrinterStateReason, Severity) - 类 javax.print.attribute.standard.PrinterStateReasons 中的方法
根据给定的严重性级别，将给定的打印机状态原因添加到此 PrinterStateReasons 属性中。
put(String, Object) - 类 javax.script.AbstractScriptEngine 中的方法
使用受保护 context 字段的 ENGINE_SCOPE Bindings 中的指定键设置指定的值。
put(String, Object) - 接口 javax.script.Bindings 中的方法
设置指定的值。
put(String, Object) - 接口 javax.script.ScriptEngine 中的方法
设置 ScriptEngine 的状态中的键/值对，它创建一个将在脚本执行中使用或者以其他方式使用的 Java Language Binding，具体取决于该键是否被保留。
put(String, Object) - 类 javax.script.ScriptEngineManager 中的方法
设置 Global Scope 中指定的键/值对。
put(String, Object) - 类 javax.script.SimpleBindings 中的方法
设置底层 map 字段中的指定键/值。
put(Object, Action) - 类 javax.swing.ActionMap 中的方法
添加一个 key 到 action 的绑定。
put(KeyStroke, Object) - 类 javax.swing.ComponentInputMap 中的方法
将一个 keyStroke 的绑定添加到 actionMapKey。
put(KeyStroke, Object) - 类 javax.swing.InputMap 中的方法
将 keyStroke 的一个绑定添加到 actionMapKey。
put(Object, Object) - 类 javax.swing.UIDefaults 中的方法
将 key 值设置为所有语言环境的 value。
put(Object, Object) - 类 javax.swing.UIManager 中的静态方法
在开发人员默认值中存储一个对象。
put(Object, Object) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 将键映射到指定的对象。
put(Object, Object) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
将指定值与此上下文中的指定键关联。
putAll(Map<?, ?>) - 类 java.awt.RenderingHints 中的方法
将指定 Map 中所有映射关系复制到此 RenderingHints 中。
putAll(Map<?, ?>) - 类 java.security.Provider 中的方法
将指定 Map 中所有映射关系复制到此 provider 中。
putAll(Map<? extends K, ? extends V>) - 类 java.util.AbstractMap 中的方法
从指定映射中将所有映射关系复制到此映射中（可选操作）。
putAll(Map<? extends K, ? extends V>) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
将指定映射中所有映射关系复制到此映射中。
putAll(Map<? extends K, ? extends V>) - 类 java.util.EnumMap 中的方法
将指定映射中所有映射关系复制到此映射中。
putAll(Map<? extends K, ? extends V>) - 类 java.util.HashMap 中的方法
将指定映射的所有映射关系复制到此映射中，这些映射关系将替换此映射目前针对指定映射中所有键的所有映射关系。
putAll(Map<? extends K, ? extends V>) - 类 java.util.Hashtable 中的方法
将指定映射的所有映射关系复制到此哈希表中，这些映射关系将替换此哈希表拥有的、针对当前指定映射中所有键的所有映射关系。
putAll(Map<? extends K, ? extends V>) - 类 java.util.IdentityHashMap 中的方法
将指定映射的全部映射关系复制到此映射，这些映射关系将替换此映射目前针对指定映射的任何键的任何映射关系。
putAll(Map<?, ?>) - 类 java.util.jar.Attributes 中的方法
将所有的属性名称-值映射关系从指定的 Attributes 复制到此 Map。
putAll(Map<? extends K, ? extends V>) - 接口 java.util.Map 中的方法
从指定映射中将所有映射关系复制到此映射中（可选操作）。
putAll(Map<? extends K, ? extends V>) - 类 java.util.TreeMap 中的方法
将指定映射中的所有映射关系复制到此映射中。
putAll(Map<? extends K, ? extends V>) - 类 java.util.WeakHashMap 中的方法
将指定映射的全部映射关系复制到此映射。
putAll(CompositeData[]) - 接口 javax.management.openmbean.TabularData 中的方法
将 values 中的所有元素添加到此 TabularData 实例。
putAll(Map<?, ?>) - 类 javax.management.openmbean.TabularDataSupport 中的方法
将包含在指定映射 t 中的所有值添加到此 TabularData 实例。
putAll(CompositeData[]) - 类 javax.management.openmbean.TabularDataSupport 中的方法
将 values 中的所有元素添加到此 TabularData 实例。
putAll(Map<? extends String, ? extends Object>) - 接口 javax.script.Bindings 中的方法
将给定 Map 中的所有映射关系添加到此 Bindings 中。
putAll(Map<? extends String, ? extends Object>) - 类 javax.script.SimpleBindings 中的方法
putAll 是使用 Map.putAll 实现的。
putBoolean(String, boolean) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putBoolean(String,boolean) 中的规范实现 putBoolean 方法。
putBoolean(String, boolean) - 类 java.util.prefs.Preferences 中的方法
将表示指定 boolean 值的字符串与此首选项节点中的指定键相关联。
putByteArray(String, byte[]) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putByteArray(String,byte[]) 中的规范实现 putByteArray 方法。
putByteArray(String, byte[]) - 类 java.util.prefs.Preferences 中的方法
将表示指定字节数组的字符串与此首选项节点中的指定键相关联。
putChar(char) - 类 java.nio.ByteBuffer 中的方法
用来写入 char 值的相对 put 方法（可选操作）。
putChar(int, char) - 类 java.nio.ByteBuffer 中的方法
用于写入 char 值的绝对 put 方法（可选操作）。
putClientProperty(Object, Object) - 类 javax.swing.JComponent 中的方法
向此组件添加任意的键/值“客户端属性”。
putConstraint(String, Component, int, String, Component) - 类 javax.swing.SpringLayout 中的方法
将组件 c1 的边 e1 连接到组件 c2 的边 e2，边与边之间的距离固定。
putConstraint(String, Component, Spring, String, Component) - 类 javax.swing.SpringLayout 中的方法
将组件 c1 的边 e1 连接到组件 c2 的边 e2。
putDefaults(Object[]) - 类 javax.swing.UIDefaults 中的方法
将所有键/值对放入数据库中，并无条件地生成一个 PropertyChangeEvent。
putDouble(double) - 类 java.nio.ByteBuffer 中的方法
用于写入 double 值的相对 put 方法（可选操作）。
putDouble(int, double) - 类 java.nio.ByteBuffer 中的方法
用于写入 double 值的绝对 put 方法（可选操作）。
putDouble(String, double) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putDouble(String,double) 中的规范实现 putDouble 方法。
putDouble(String, double) - 类 java.util.prefs.Preferences 中的方法
将表示指定 double 值的字符串与此首选项节点中的指定键相关联。
putDTDHash(String, DTD) - 类 javax.swing.text.html.parser.DTD 中的静态方法
putFields() - 类 java.io.ObjectOutputStream 中的方法
获取用于缓冲写入流中的持久存储字段的对象。
putFirst(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列的开头，必要时将一直等待可用空间。
putFirst(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
putFloat(float) - 类 java.nio.ByteBuffer 中的方法
用于写入 float 值的相对 put 方法（可选操作）。
putFloat(int, float) - 类 java.nio.ByteBuffer 中的方法
用于写入 float 值的绝对 put 方法（可选操作）。
putFloat(String, float) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putFloat(String,float) 中的规范实现 putFloat 方法。
putFloat(String, float) - 类 java.util.prefs.Preferences 中的方法
将表示指定 float 值的字符串与此首选项节点中的指定键相关联。
putIfAbsent(K, V) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
如果指定键已经不再与某个值相关联，则将它与给定值关联。
putIfAbsent(K, V) - 接口 java.util.concurrent.ConcurrentMap 中的方法
如果指定键已经不再与某个值相关联，则将它与给定值关联。
putIfAbsent(K, V) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
如果指定键已经不再与某个值相关联，则将它与给定值关联。
putInt(int) - 类 java.nio.ByteBuffer 中的方法
用于写入 int 值的相对 put 方法（可选操作）。
putInt(int, int) - 类 java.nio.ByteBuffer 中的方法
用于写入 int 值的绝对 put 方法（可选操作）。
putInt(String, int) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putInt(String,int) 中的规范实现 putInt 方法。
putInt(String, int) - 类 java.util.prefs.Preferences 中的方法
将表示指定 int 值的字符串与此首选项节点中的指定键相关联。
putLast(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列的末尾，必要时将一直等待可用空间。
putLast(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
putLayer(JComponent, int) - 类 javax.swing.JLayeredPane 中的静态方法
设置 JComponent 上的 layer 属性。
putLong(long) - 类 java.nio.ByteBuffer 中的方法
用于写入 long 值（可先操作） 的相对 put 方法。
putLong(int, long) - 类 java.nio.ByteBuffer 中的方法
用于写入 long 值的绝对 put 方法（可选操作）。
putLong(String, long) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putLong(String,long) 中的规范实现 putLong 方法。
putLong(String, long) - 类 java.util.prefs.Preferences 中的方法
将表示指定 long 值的字符串与此首选项节点中的指定键相关联。
putNamespacePrefix(String, String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 将 URI 映射到指定的前缀。
putNamespacePrefix(String, String) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
将指定的名称空间 URI 映射到指定的前缀。
putNextEntry(ZipEntry) - 类 java.util.jar.JarOutputStream 中的方法
开始写入新的 JAR 文件条目，并将流定位到条目数据的开始处。
putNextEntry(ZipEntry) - 类 java.util.zip.ZipOutputStream 中的方法
开始写入新的 ZIP 文件条目并将流定位到条目数据的开始处。
putProperty(Object, Object) - 类 javax.swing.text.AbstractDocument 中的方法
存储属性值的便捷方法。
putProperty(Object, Object) - 接口 javax.swing.text.Document 中的方法
将属性与文档关联。
putService(Provider.Service) - 类 java.security.Provider 中的方法
添加服务。
putShort(short) - 类 java.nio.ByteBuffer 中的方法
用于写入 short 值的相对 put 方法（可选操作）。
putShort(int, short) - 类 java.nio.ByteBuffer 中的方法
用于写入 short 值的绝对 put 方法（可选操作）。
putSpi(String, String) - 类 java.util.prefs.AbstractPreferences 中的方法
将给定的键-值关联置于此首选项节点中。
putValue(String, String) - 类 java.util.jar.Attributes 中的方法
将指定的值作为一个 String 关联到指定的属性名称。
putValue(String, Object) - 接口 javax.net.ssl.SSLSession 中的方法
使用给定的 name 将指定的 value 对象绑定到会话的应用层数据中。
putValue(String, Object) - 类 javax.swing.AbstractAction 中的方法
设置与指定键关联的 Value。
putValue(String, Object) - 接口 javax.swing.Action 中的方法
使用关联的键设置此对象的一个属性。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


Q - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Q

QName - javax.xml.namespace 中的 类
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。
QName(String, String) - 类 javax.xml.namespace.QName 的构造方法
指定名称空间 URI 和本地部分的 QName 构造方法。
QName(String, String, String) - 类 javax.xml.namespace.QName 的构造方法
指定名称空间 URI、本地部分和前缀的 QName 构造方法。
QName(String) - 类 javax.xml.namespace.QName 的构造方法
指定本地部分的 QName 构造方法。
QOP - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定要使用的保护级别。
QuadCurve2D - java.awt.geom 中的 类
QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。
QuadCurve2D() - 类 java.awt.geom.QuadCurve2D 的构造方法
这是一个不可直接实例化的抽象类。
QuadCurve2D.Double - java.awt.geom 中的 类
使用 double 坐标指定的二次参数曲线段。
QuadCurve2D.Double() - 类 java.awt.geom.QuadCurve2D.Double 的构造方法
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 QuadCurve2D。
QuadCurve2D.Double(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D.Double 的构造方法
根据指定 double 坐标构造并初始化 QuadCurve2D。
QuadCurve2D.Float - java.awt.geom 中的 类
使用 float 坐标指定的二次参数曲线段。
QuadCurve2D.Float() - 类 java.awt.geom.QuadCurve2D.Float 的构造方法
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 QuadCurve2D。
QuadCurve2D.Float(float, float, float, float, float, float) - 类 java.awt.geom.QuadCurve2D.Float 的构造方法
根据指定 float 坐标构造并初始化一个 QuadCurve2D。
quadrantRotate(int) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与按照指定象限数旋转坐标的变换。
quadrantRotate(int, double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与按指定象限数绕指定锚点旋转坐标的变换。
quadTo(double, double, double, double) - 类 java.awt.geom.Path2D.Double 中的方法
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
quadTo(double, double, double, double) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
quadTo(float, float, float, float) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
quadTo(double, double, double, double) - 类 java.awt.geom.Path2D 中的方法
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
QUARTO - 类 java.awt.PageAttributes.MediaType 中的静态变量
Quarto (215 x 275 mm) 的 MediaType 实例。
QUARTO - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 quarto 尺寸，8.5 inch × 10.83 inch。
QUARTO - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
quarto 尺寸。
Query - javax.management 中的 类
构造查询对象约束。
Query() - 类 javax.management.Query 的构造方法
基本构造方法。
QUERY_STRING - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：请求的查询字符串。
QueryEval - javax.management 中的 类
允许在特定的 MBean 服务器上下文中执行查询。
QueryEval() - 类 javax.management.QueryEval 的构造方法
QueryExp - javax.management 中的 接口
表示可在数据库查询“where 子句”中使用的相关约束。
queryMBeans(ObjectName, QueryExp) - 接口 javax.management.MBeanServer 中的方法
queryMBeans(ObjectName, QueryExp) - 接口 javax.management.MBeanServerConnection 中的方法
获得该 MBean 服务器所控制的 MBean。
queryMBeans(ObjectName, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
queryMBeans(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
queryMBeans(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
queryNames(ObjectName, QueryExp) - 接口 javax.management.MBeanServer 中的方法
queryNames(ObjectName, QueryExp) - 接口 javax.management.MBeanServerConnection 中的方法
获得该 MBean 服务器所控制的 MBean 的名称。
queryNames(ObjectName, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
queryNames(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
queryNames(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
QUESTION_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
QUESTION_MESSAGE - 类 javax.swing.JOptionPane 中的静态变量
用于问题。
Queue<E> - java.util 中的 接口
在处理元素前用于保存元素的 collection。
QUEUED_IN_DEVICE - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业已被转发到某个不能发送回状态的设备或打印系统。
QueuedJobCount - javax.print.attribute.standard 中的 类
QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。
QueuedJobCount(int) - 类 javax.print.attribute.standard.QueuedJobCount 的构造方法
构造具有给定整数值的新 QueuedJobCount 属性。
quote(String) - 类 java.util.regex.Pattern 中的静态方法
返回指定 String 的字面值模式 String。
quote(String) - 类 javax.management.ObjectName 中的静态方法
返回给定 String 的有引号形式，使之适合包含在 ObjectName 中。
quoteChar(int) - 类 java.io.StreamTokenizer 中的方法
指定此字符的匹配对分隔此标记生成器中的字符串常量。
quoteReplacement(String) - 类 java.util.regex.Matcher 中的静态方法
返回指定 String 的字面值替换 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


R - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

R

RadialGradientPaint - java.awt 中的 类
RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。
RadialGradientPaint(float, float, float, float[], Color[]) - 类 java.awt.RadialGradientPaint 的构造方法
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D, float, float[], Color[]) - 类 java.awt.RadialGradientPaint 的构造方法
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.RadialGradientPaint 的构造方法
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D, float, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.RadialGradientPaint 的构造方法
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float, float, float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.RadialGradientPaint 的构造方法
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D, float, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.RadialGradientPaint 的构造方法
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D, float, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod, MultipleGradientPaint.ColorSpaceType, AffineTransform) - 类 java.awt.RadialGradientPaint 的构造方法
构造一个 RadialGradientPaint。
RadialGradientPaint(Rectangle2D, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.RadialGradientPaint 的构造方法
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RADIO_BUTTON - 类 javax.accessibility.AccessibleRole 中的静态变量
一个专用复选框，当选中此复选框时，将导致取消选中同一组中的其他单选按钮。
RADIO_BUTTON - 类 javax.swing.plaf.synth.Region 中的静态变量
RadioButton 的 region。
RADIO_BUTTON_MENU_ITEM - 类 javax.swing.plaf.synth.Region 中的静态变量
RegionButtonMenuItem 的 region。
radix() - 类 java.util.Scanner 中的方法
返回此扫描器的默认基数。
RAISED - 类 javax.swing.border.BevelBorder 中的静态变量
凸出斜面类型。
RAISED - 类 javax.swing.border.EtchedBorder 中的静态变量
阳刻浮雕化类型。
random() - 类 java.lang.Math 中的静态方法
返回带正号的 double 值，该值大于等于 0.0 且小于 1.0。
random() - 类 java.lang.StrictMath 中的静态方法
返回带有正号的 double 值，该值大于等于 0.0 且小于 1.0。
Random - java.util 中的 类
此类的实例用于生成伪随机数流。
Random() - 类 java.util.Random 的构造方法
创建一个新的随机数生成器。
Random(long) - 类 java.util.Random 的构造方法
使用单个 long 种子创建一个新的随机数生成器。
RandomAccess - java.util 中的 接口
List 实现所使用的标记接口，用来表明其支持快速（通常是固定时间）随机访问。
RandomAccessFile - java.io 中的 类
此类的实例支持对随机访问文件的读取和写入。
RandomAccessFile(String, String) - 类 java.io.RandomAccessFile 的构造方法
创建从中读取和向其中写入（可选）的随机访问文件流，该文件具有指定名称。
RandomAccessFile(File, String) - 类 java.io.RandomAccessFile 的构造方法
创建从中读取和向其中写入（可选）的随机访问文件流，该文件由 File 参数指定。
RANDOMPIXELORDER - 接口 java.awt.image.ImageConsumer 中的静态变量
按随机顺序传递像素。
randomUUID() - 类 java.util.UUID 中的静态方法
获取类型 4（伪随机生成的）UUID 的静态工厂。
RANGE - 类 java.awt.JobAttributes.DefaultSelectionType 中的静态变量
用于指定应该打印一定范围的作业页面的 DefaultSelectionType 实例。
range(E, E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含由两个指定端点所定义范围内的所有元素的枚举 set。
Raster - java.awt.image 中的 类
表示像素矩形数组的类。
Raster(SampleModel, Point) - 类 java.awt.image.Raster 的构造方法
构建具有给定 SampleModel 的 Raster。
Raster(SampleModel, DataBuffer, Point) - 类 java.awt.image.Raster 的构造方法
构建具有给定 SampleModel 和 DataBuffer 的 Raster。
Raster(SampleModel, DataBuffer, Rectangle, Point, Raster) - 类 java.awt.image.Raster 的构造方法
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
raster - 类 javax.imageio.IIOImage 中的变量
正被引用的 Raster。
RasterFormatException - java.awt.image 中的 异常
如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。
RasterFormatException(String) - 异常 java.awt.image.RasterFormatException 的构造方法
构造带指定消息的新 RasterFormatException。
RasterOp - java.awt.image 中的 接口
此接口描述对 Raster 对象执行的单输入/单输出操作。
RAW_SEND_SIZE - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定 SaslClient/SaslServer 初始发送缓冲区的最大大小（以字节为单位）。
RAW_TEXT - 类 java.awt.im.InputMethodHighlight 中的静态变量
原文本状态的常量。
RAW_X509_CERTIFICATE_TYPE - 接口 javax.xml.crypto.dsig.keyinfo.X509Data 中的静态变量
标识二进制 (ASN.1 DER) X.509 Certificate KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#rawX509Certificate。
RC2ParameterSpec - javax.crypto.spec 中的 类
此类指定随同 RC2 算法使用的参数。
RC2ParameterSpec(int) - 类 javax.crypto.spec.RC2ParameterSpec 的构造方法
根据给定的有效密钥大小（以位为单位）为 RC2 构造一个参数集合。
RC2ParameterSpec(int, byte[]) - 类 javax.crypto.spec.RC2ParameterSpec 的构造方法
根据给定的有效密钥大小（以位为单位）和一个 8 字节的 IV 为 RC2 构造一个参数集合。
RC2ParameterSpec(int, byte[], int) - 类 javax.crypto.spec.RC2ParameterSpec 的构造方法
根据给定的有效密钥大小（以位为单位）和 IV 为 RC2 构造一个参数集合。
RC5ParameterSpec - javax.crypto.spec 中的 类
此类指定随同 RC5 算法使用的参数。
RC5ParameterSpec(int, int, int) - 类 javax.crypto.spec.RC5ParameterSpec 的构造方法
根据给定的版本、round 的数量以及 word 大小（以位为单位）为 RC5 构造一个参数集合。
RC5ParameterSpec(int, int, int, byte[]) - 类 javax.crypto.spec.RC5ParameterSpec 的构造方法
根据给定的版本、round 的数量、word 大小（以位为单位）以及 IV 为 RC5 构造一个参数集合。
RC5ParameterSpec(int, int, int, byte[], int) - 类 javax.crypto.spec.RC5ParameterSpec 的构造方法
根据给定的版本、round 的数量、word 大小（以位为单位）以及 IV 为 RC5 构造一个参数集合。
RCDATA - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
RCSID - 类 javax.swing.undo.StateEdit 中的静态变量
RCSID - 接口 javax.swing.undo.StateEditable 中的静态变量
此类的资源 ID。
Rdn - javax.naming.ldap 中的 类
此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。
Rdn(Attributes) - 类 javax.naming.ldap.Rdn 的构造方法
根据给定属性集构造 Rdn。
Rdn(String) - 类 javax.naming.ldap.Rdn 的构造方法
根据给定字符串构造 Rdn。
Rdn(Rdn) - 类 javax.naming.ldap.Rdn 的构造方法
根据给定 rdn 构造 Rdn。
Rdn(String, Object) - 类 javax.naming.ldap.Rdn 的构造方法
根据给定属性类型和值构造 Rdn。
read() - 类 java.io.BufferedInputStream 中的方法
参见 InputStream 的 read 方法的常规协定。
read(byte[], int, int) - 类 java.io.BufferedInputStream 中的方法
从此字节输入流中给定偏移量处开始将各字节读取到指定的 byte 数组中。
read() - 类 java.io.BufferedReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.BufferedReader 中的方法
将字符读入数组的某一部分。
read() - 类 java.io.ByteArrayInputStream 中的方法
从此输入流中读取下一个数据字节。
read(byte[], int, int) - 类 java.io.ByteArrayInputStream 中的方法
将最多 len 个数据字节从此输入流读入 byte 数组。
read() - 类 java.io.CharArrayReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.CharArrayReader 中的方法
将字符读入数组的某一部分。
read(byte[]) - 类 java.io.DataInputStream 中的方法
从包含的输入流中读取一定数量的字节，并将它们存储到缓冲区数组 b 中。
read(byte[], int, int) - 类 java.io.DataInputStream 中的方法
从包含的输入流中将最多 len 个字节读入一个 byte 数组中。
read() - 类 java.io.FileInputStream 中的方法
从此输入流中读取一个数据字节。
read(byte[]) - 类 java.io.FileInputStream 中的方法
从此输入流中将最多 b.length 个字节的数据读入一个 byte 数组中。
read(byte[], int, int) - 类 java.io.FileInputStream 中的方法
从此输入流中将最多 len 个字节的数据读入一个 byte 数组中。
read() - 类 java.io.FilterInputStream 中的方法
从此输入流中读取下一个数据字节。
read(byte[]) - 类 java.io.FilterInputStream 中的方法
从此输入流中将 byte.length 个字节的数据读入一个 byte 数组中。
read(byte[], int, int) - 类 java.io.FilterInputStream 中的方法
从此输入流中将 len 个字节的数据读入一个 byte 数组中。
read() - 类 java.io.FilterReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.FilterReader 中的方法
将字符读入数组的某一部分。
read() - 类 java.io.InputStream 中的方法
从输入流中读取数据的下一个字节。
read(byte[]) - 类 java.io.InputStream 中的方法
从输入流中读取一定数量的字节，并将其存储在缓冲区数组 b 中。
read(byte[], int, int) - 类 java.io.InputStream 中的方法
将输入流中最多 len 个数据字节读入 byte 数组。
read() - 类 java.io.InputStreamReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.InputStreamReader 中的方法
将字符读入数组中的某一部分。
read() - 类 java.io.LineNumberInputStream 中的方法
已过时。 从此输入流读取下一个数据字节。
read(byte[], int, int) - 类 java.io.LineNumberInputStream 中的方法
已过时。 将最多 len 个数据字节从此输入流读入 byte 数组。
read() - 类 java.io.LineNumberReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.LineNumberReader 中的方法
将字符读入数组中的某一部分。
read() - 接口 java.io.ObjectInput 中的方法
读取数据字节。
read(byte[]) - 接口 java.io.ObjectInput 中的方法
读入 byte 数组。
read(byte[], int, int) - 接口 java.io.ObjectInput 中的方法
读入 byte 数组。
read() - 类 java.io.ObjectInputStream 中的方法
读取数据字节。
read(byte[], int, int) - 类 java.io.ObjectInputStream 中的方法
读入 byte 数组。
read() - 类 java.io.PipedInputStream 中的方法
读取此管道输入流中的下一个数据字节。
read(byte[], int, int) - 类 java.io.PipedInputStream 中的方法
将最多 len 个数据字节从此管道输入流读入 byte 数组。
read() - 类 java.io.PipedReader 中的方法
读取此传送流中的下一个数据字符。
read(char[], int, int) - 类 java.io.PipedReader 中的方法
将此传送流中最多 len 个数据字符读入字符数组。
read() - 类 java.io.PushbackInputStream 中的方法
从此输入流中读取下一个数据字节。
read(byte[], int, int) - 类 java.io.PushbackInputStream 中的方法
从此输入流将最多 len 个数据字节读入 byte 数组。
read() - 类 java.io.PushbackReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.PushbackReader 中的方法
将字符读入数组的某一部分。
read() - 类 java.io.RandomAccessFile 中的方法
从此文件中读取一个数据字节。
read(byte[], int, int) - 类 java.io.RandomAccessFile 中的方法
将最多 len 个数据字节从此文件读入 byte 数组。
read(byte[]) - 类 java.io.RandomAccessFile 中的方法
将最多 b.length 个数据字节从此文件读入 byte 数组。
read(CharBuffer) - 类 java.io.Reader 中的方法
试图将字符读入指定的字符缓冲区。
read() - 类 java.io.Reader 中的方法
读取单个字符。
read(char[]) - 类 java.io.Reader 中的方法
将字符读入数组。
read(char[], int, int) - 类 java.io.Reader 中的方法
将字符读入数组的某一部分。
read() - 类 java.io.SequenceInputStream 中的方法
从此输入流中读取下一个数据字节。
read(byte[], int, int) - 类 java.io.SequenceInputStream 中的方法
将最多 len 个数据字节从此输入流读入 byte 数组。
read() - 类 java.io.StringBufferInputStream 中的方法
已过时。 从此输入流中读取下一个数据的字节。
read(byte[], int, int) - 类 java.io.StringBufferInputStream 中的方法
已过时。 将最多 len 个数据字节从此输入流读入 byte 数组。
read() - 类 java.io.StringReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.StringReader 中的方法
将字符读入数组的某一部分。
read(CharBuffer) - 接口 java.lang.Readable 中的方法
试图将字符读入指定的字符缓冲区。
read(ByteBuffer) - 类 java.nio.channels.DatagramChannel 中的方法
从此通道读取数据报。
read(ByteBuffer[], int, int) - 类 java.nio.channels.DatagramChannel 中的方法
从此通道读取数据报。
read(ByteBuffer[]) - 类 java.nio.channels.DatagramChannel 中的方法
从此通道读取数据报。
read(ByteBuffer) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从此通道读入给定的缓冲区。
read(ByteBuffer[], int, int) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从此通道读入给定缓冲区的子序列中。
read(ByteBuffer[]) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从此通道读入给定的缓冲区。
read(ByteBuffer, long) - 类 java.nio.channels.FileChannel 中的方法
从给定的文件位置开始，从此通道读取字节序列,并写入给定的缓冲区。
read(ByteBuffer) - 接口 java.nio.channels.ReadableByteChannel 中的方法
将字节序列从此通道中读入给定的缓冲区。
read(ByteBuffer[], int, int) - 接口 java.nio.channels.ScatteringByteChannel 中的方法
将字节序列从此通道读入给定缓冲区的子序列中。
read(ByteBuffer[]) - 接口 java.nio.channels.ScatteringByteChannel 中的方法
将字节序列从此通道读入给定的缓冲区。
read(ByteBuffer) - 类 java.nio.channels.SocketChannel 中的方法
read(ByteBuffer[], int, int) - 类 java.nio.channels.SocketChannel 中的方法
read(ByteBuffer[]) - 类 java.nio.channels.SocketChannel 中的方法
read(CharBuffer) - 类 java.nio.CharBuffer 中的方法
试图将字符读入指定的字符缓冲区。
read(ObjectInput) - 类 java.rmi.server.ObjID 中的静态方法
通过从 ObjectInput 实例解组二进制表示形式来构造和返回一个新的 ObjID 实例。
read(DataInput) - 类 java.rmi.server.UID 中的静态方法
通过从 DataInput 实例解组二进制表示形式构造并返回一个新的 UID。
read() - 类 java.security.DigestInputStream 中的方法
读取字节并更新消息摘要（如果开启了摘要功能）。
read(byte[], int, int) - 类 java.security.DigestInputStream 中的方法
读入 byte 数组并更新消息摘要（如果开启了摘要功能）。
read(byte[], int, int) - 类 java.util.jar.JarInputStream 中的方法
从当前 JAR 文件条目读入字节数组。
read(InputStream) - 类 java.util.jar.Manifest 中的方法
从指定的 InputStream 读取 Manifest。
read() - 类 java.util.zip.CheckedInputStream 中的方法
读取字节。
read(byte[], int, int) - 类 java.util.zip.CheckedInputStream 中的方法
读入字节数组。
read() - 类 java.util.zip.DeflaterInputStream 中的方法
从输入流读取一个压缩数据的单个字节。
read(byte[], int, int) - 类 java.util.zip.DeflaterInputStream 中的方法
将压缩数据读入 byte 数组。
read(byte[], int, int) - 类 java.util.zip.GZIPInputStream 中的方法
将未压缩数据读入字节数组。
read() - 类 java.util.zip.InflaterInputStream 中的方法
读取未压缩数据的字节。
read(byte[], int, int) - 类 java.util.zip.InflaterInputStream 中的方法
将未压缩数据读入字节数组。
read(byte[], int, int) - 类 java.util.zip.ZipInputStream 中的方法
从当前 ZIP 条目读入字节数组。
read() - 类 javax.crypto.CipherInputStream 中的方法
从该输入流读取下一数据字节。
read(byte[]) - 类 javax.crypto.CipherInputStream 中的方法
从该输入流将 b.length 个数据字节读入到字节数组中。
read(byte[], int, int) - 类 javax.crypto.CipherInputStream 中的方法
从该输入流将 len 个字节数据读入到字节数组中。
read(File) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 File 的结果。
read(InputStream) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 InputStream 的结果。
read(URL) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 URL 的结果。
read(ImageInputStream) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 ImageInputStream 的结果。
read(int) - 类 javax.imageio.ImageReader 中的方法
使用默认 ImageReadParam 读取通过索引 imageIndex 指定的图像，并将其作为一个完整的 BufferedImage 返回。
read(int, ImageReadParam) - 类 javax.imageio.ImageReader 中的方法
使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的对象，并将它作为一个完整的 BufferedImage 返回。
read() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
read() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
read() - 类 javax.imageio.stream.FileImageInputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.FileImageInputStream 中的方法
read() - 类 javax.imageio.stream.FileImageOutputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.FileImageOutputStream 中的方法
read() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取单个字节，并以整数（0 到 255 之间）形式返回该字节。
read(byte[]) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取至多 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
read(byte[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取至多 len 个字节，并将其存储到 b 中（从索引 off 开始）。
read() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
read(byte[]) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
调用 read(b, 0, b.length) 的便捷方法。
read(byte[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
read() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
read() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
read() - 类 javax.sound.sampled.AudioInputStream 中的方法
从音频输入流读取数据下一个字节。
read(byte[]) - 类 javax.sound.sampled.AudioInputStream 中的方法
从音频输入流读取一定数量的字节，并将其存储在缓冲区数组 b 中。
read(byte[], int, int) - 类 javax.sound.sampled.AudioInputStream 中的方法
从音频流读取指定的最大数量的数据字节，并将其放入给定的字节数组中。
read(byte[], int, int) - 接口 javax.sound.sampled.TargetDataLine 中的方法
从数据行的输入缓冲区读取音频数据。
read(InputStream, Object) - 类 javax.swing.JEditorPane 中的方法
此方法根据流进行初始化。
read() - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.read，以便在读取之后更新进度监视器。
read(byte[]) - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.read，以读取之后更新进度监视器。
read(byte[], int, int) - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.read，以便在读取之后更新进度监视器。
read(InputStream, Document, int) - 类 javax.swing.text.DefaultEditorKit 中的方法
插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
read(Reader, Document, int) - 类 javax.swing.text.DefaultEditorKit 中的方法
插入取自给定流的内容，它将被视为纯文本。
read(InputStream, Document, int) - 类 javax.swing.text.EditorKit 中的方法
插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
read(Reader, Document, int) - 类 javax.swing.text.EditorKit 中的方法
插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
read(Reader, Document, int) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
插入来自给定流的内容。
read(DataInputStream) - 类 javax.swing.text.html.parser.DTD 中的方法
根据存档格式重新创建一个 DTD。
read(Reader, Object) - 类 javax.swing.text.JTextComponent 中的方法
根据流进行初始化。
read(InputStream, Document, int) - 类 javax.swing.text.rtf.RTFEditorKit 中的方法
插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。
read(Reader, Document, int) - 类 javax.swing.text.rtf.RTFEditorKit 中的方法
插入来自给定流的内容，该内容将被视为纯文本。
read(InputStream) - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.CurrentHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ObjectHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.PolicyHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
read() - 类 org.omg.CORBA.portable.InputStream 中的方法
read(InputStream) - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.StringValueHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.BindingHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.IstringHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NameHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.IORHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
read(InputStream) - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
read_Abstract() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL Abstract 接口。
read_abstract_interface() - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
解组值对象或适当的 stub 对象。
read_abstract_interface(Class) - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
解组与传递类型相对应的类对象或 stub 类。
read_any() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL Any 值。
read_any() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 Any。
read_any_array(AnySeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL Any 数组中从 offset 处开始的 length 个元素。
read_boolean() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL boolean 值。
read_boolean() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 boolean 值。
read_boolean_array(BooleanSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL boolean 数组中 offset 处开始的 length 个元素。
read_boolean_array(boolean[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 boolean 数组。
read_char() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 字符值。
read_char() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 char 值。
read_char_array(CharSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 字符数组中从 offset 处开始的 length 个元素。
read_char_array(char[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 char 数组。
read_Context() - 类 org.omg.CORBA.portable.InputStream 中的方法
从流中读取一个 CORBA 上下文。
read_double() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL double 值。
read_double() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 double 值。
read_double_array(DoubleSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL double 数组中从 offset 处开始的 length 个元素。
read_double_array(double[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 double 数组。
read_fixed() - 类 org.omg.CORBA.portable.InputStream 中的方法
读取一个 BigDecimal 数。
read_float() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL float 值。
read_float() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 float 值。
read_float_array(FloatSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL float 数组中从 offset 处开始的 length 个元素。
read_float_array(float[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 float 数组。
read_long() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL long 值。
read_long() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA long（即 Java int）值。
read_long_array(LongSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL long 数组中从 offset 处开始的 length 个元素。
read_long_array(int[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA long（即 Java int）数组。
read_longlong() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL long long 值。
read_longlong() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA longlong（即 Java long）值。
read_longlong_array(LongLongSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL long long 数组中从 offset 处开始的 length 个元素。
read_longlong_array(long[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA longlong（即 Java long）数组。
read_Object() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL CORBA::Object。
read_Object() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA 对象。
read_Object(Class) - 类 org.omg.CORBA.portable.InputStream 中的方法
取消对象的编组并返回一个 CORBA Object，该对象是作为参数传递的类的实例。
read_octet() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL octet 值。
read_octet() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个八位组（即 byte）值。
read_octet_array(OctetSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL octet 数组中从 offset 处开始的 length 个元素。
read_octet_array(byte[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个八位组（即 bytes）数组。
READ_ONLY - 类 java.nio.channels.FileChannel.MapMode 中的静态变量
只读映射模式。
read_Principal() - 类 org.omg.CORBA.portable.InputStream 中的方法
已过时。 已由 CORBA 2.2 取代。
read_short() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL short 值。
read_short() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 short 值。
read_short_array(ShortSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL short 数组中从 offset 处开始的 length 个元素。
read_short_array(short[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 short 数组。
read_string() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 字符串值。
read_string() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 string 值。
read_TypeCode() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL typecode 值。
read_TypeCode() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 TypeCode。
read_ulong() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL long 值。
read_ulong() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个无符号 CORBA long（即 Java int）值。
read_ulong_array(ULongSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL long 数组中从 offset 处开始的 length 个元素。
read_ulong_array(int[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个无符号 CORBA long（即 Java int）数组。
read_ulonglong() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL long long 值。
read_ulonglong() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA 无符号 longlong（即 Java long）值。
read_ulonglong_array(ULongLongSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL long long 数组中从 offset 处开始的 length 个元素。
read_ulonglong_array(long[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个无符号 CORBA longlong（即 Java long）数组。
read_ushort() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL short 值。
read_ushort() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个无符号 short 值。
read_ushort_array(UShortSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL short 数组中从 offset 处开始的 length 个元素。
read_ushort_array(short[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个无符号 short 数组。
read_value(InputStream, TypeCode) - 类 org.omg.CORBA.Any 中的方法
使用给定 typecode 读出（解组）给定输入流中某一 Any 对象的值。
read_Value() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 值类型。
read_value(InputStream) - 接口 org.omg.CORBA.portable.BoxedValueHelper 中的方法
read_value(InputStream) - 接口 org.omg.CORBA.portable.ValueFactory 中的方法
ORB 运行时在解组值类型的过程中调用此方法。
read_value(InputStream) - 类 org.omg.CORBA.StringValueHelper 中的方法
read_value(InputStream) - 类 org.omg.CORBA.WStringValueHelper 中的方法
read_value() - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
从输入流解组值类型。
read_value(Class) - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
从输入流解组值类型。
read_value(BoxedValueHelper) - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
从输入流解组值类型。
read_value(String) - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
从输入流解组值类型。
read_value(Serializable) - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
从输入流解组值类型。
read_wchar() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 宽字符值。
read_wchar() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 wide char 值。
read_wchar_array(WCharSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 宽字符数组中从 offset 处开始的 length 个元素。
read_wchar_array(char[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 wide char 数组。
READ_WRITE - 类 java.nio.channels.FileChannel.MapMode 中的静态变量
读取/写入映射模式。
read_wstring() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 宽字符串值。
read_wstring() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 wide string 值。
Readable - java.lang 中的 接口
Readable 是一个字符源。
ReadableByteChannel - java.nio.channels 中的 接口
可读取字节的通道。
readAborted(ImageReader) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告已通过 reader 的 abort 方法中止读操作。
readAll(int, ImageReadParam) - 类 javax.imageio.ImageReader 中的方法
使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的图像，并返回包含图像、缩略图和相关图像元数据的 IIOImage。
readAll(Iterator<? extends ImageReadParam>) - 类 javax.imageio.ImageReader 中的方法
以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。
readAny(InputStream) - 类 javax.rmi.CORBA.Util 中的静态方法
将 java.lang.Object 作为 CORBA any 读取。
readAny(InputStream) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.readAny(org.omg.CORBA.portable.InputStream) 的委托调用。
readArray() - 接口 java.sql.SQLInput 中的方法
从流中读取 SQL ARRAY 值并将其作为 Java 编程语言中的 Array 对象返回。
readArray() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
从流中读取 SQL ARRAY 值并以 Java 编程语言中 Array 对象的形式返回。
readAsciiStream() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 ASCII 字符流返回。
readAsciiStream() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 ASCII 字符流的形式返回此 SQLInputImpl 对象中的下一个属性。
readAsRenderedImage(int, ImageReadParam) - 类 javax.imageio.ImageReader 中的方法
返回一个 RenderedImage 对象，该对象包含通过索引 imageIndex 指定的图像的内容。
readAttributes(ObjectInputStream, MutableAttributeSet) - 类 javax.swing.text.StyleContext 中的方法
读入属性的特定于上下文的处理。
readAttributeSet(ObjectInputStream, MutableAttributeSet) - 类 javax.swing.text.StyleContext 中的静态方法
从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。
readBigDecimal() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 java.math.BigDecimal 对象返回。
readBigDecimal() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 java.math.BigDecimal 的形式获取此 SQLInputImpl 对象中的下一个属性。
readBinaryStream() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为未解释的字节流返回。
readBinaryStream() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以未解释字节流的形式返回此 SQLInputImpl 对象中的下一个属性。
readBit() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取单个字节，并以 int（0 或 1）的形式返回该字节。
readBit() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readBits(int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取位串 (bitstring) 并以 long 的形式返回，使第一个读取的位成为输出的最高有效位。
readBits(int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readBlob() - 接口 java.sql.SQLInput 中的方法
从流中读取 SQL BLOB 值并将其作为 Java 编程语言中的 Blob 对象返回。
readBlob() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 Blob 对象的形式获取此 SQLInputImpl 对象头部的 BLOB 值。
readBoolean() - 接口 java.io.DataInput 中的方法
读取一个输入字节，如果该字节不是零，则返回 true，如果是零，则返回 false。
readBoolean() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readBoolean 方法的常规协定。
readBoolean() - 类 java.io.ObjectInputStream 中的方法
读取一个 boolean 值。
readBoolean() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个 boolean。
readBoolean() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 boolean 返回。
readBoolean() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取一个字节，如果其不为 0，则返回 boolean 值 true；如果为 0，则返回 false。
readBoolean() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readBoolean() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 boolean 的形式获取此 SQLInputImpl 对象中的下一个属性。
readByte() - 接口 java.io.DataInput 中的方法
读取并返回一个输入字节。
readByte() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readByte 方法的常规协定。
readByte() - 类 java.io.ObjectInputStream 中的方法
读取一个 8 位的字节。
readByte() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个有符号的八位值。
readByte() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 byte 返回。
readByte() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取一个字节，并以 byte 值的形式返回该字节。
readByte() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readByte() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 byte 的形式获取此 SQLInputImpl 对象中的下一个属性。
readBytes() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的字节数组返回。
readBytes(IIOByteBuffer, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取至多 len 个字节，并修改提供的 IIOByteBuffer 以指示可以找到数据的 byte 数组、偏移量和长度。
readBytes(IIOByteBuffer, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readBytes() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以字节数组的形式获取此 SQLInputImpl 对象中的下一个属性。
readChar() - 接口 java.io.DataInput 中的方法
读取两个输入字节并返回一个 char 值。
readChar() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readChar 方法的常规协定。
readChar() - 类 java.io.ObjectInputStream 中的方法
读取一个 16 位的 char 值。
readChar() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个字符。
readChar() - 接口 javax.imageio.stream.ImageInputStream 中的方法
与 readUnsignedShort 等效，唯一的不同在于它的结果使用 char 数据类型返回。
readChar() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readCharacterStream() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Unicode 字符流返回。
readCharacterStream() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Unicode 字符流的形式获取此 SQLInputImpl 对象中的下一个属性。
readChildren(ObjectInputStream) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在将此类的实例用作 BeanContext 协议（及其子协议）实现的代理时，在反序列化期间存在一个“先有鸡还是先有蛋”的问题。
readClassDescriptor() - 类 java.io.ObjectInputStream 中的方法
从序列化流读取类描述符。
readClob() - 接口 java.sql.SQLInput 中的方法
从流中读取 SQL CLOB 值并将其作为 Java 编程语言中的 Clob 对象返回。
readClob() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 Clob 对象的形式获取此 SQLInputImpl 对象头部的 CLOB 值。
readConfiguration() - 类 java.util.logging.LogManager 中的方法
重新初始化日志属性并重新读取日志配置。
readConfiguration(InputStream) - 类 java.util.logging.LogManager 中的方法
从给定流重新初始化并重新读取日志配置，该配置为 java.util.Properties 格式。
readData(RowSetInternal) - 接口 javax.sql.RowSetReader 中的方法
读取调用 RowSet 对象的新内容。
readDate() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 java.sql.Date 对象返回。
readDate() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 java.sql.Date 对象的形式获取此 SQLInputImpl 中的下一个属性。
readDouble() - 接口 java.io.DataInput 中的方法
读取八个输入字节并返回一个 double 值。
readDouble() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readDouble 方法的常规协定。
readDouble() - 类 java.io.ObjectInputStream 中的方法
读取一个 64 位的 double 值。
readDouble() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个 double。
readDouble() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 double 返回。
readDouble() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 double 值的形式返回结果。
readDouble() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readDouble() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 double 的形式获取此 SQLInputImpl 对象中的下一个属性。
reader() - 类 java.io.Console 中的方法
获取与此控制台关联的唯一 Reader 对象。
Reader - java.io 中的 类
用于读取字符流的抽象类。
Reader() - 类 java.io.Reader 的构造方法
创建一个新的字符流 reader，其重要部分将同步其自身的 reader。
Reader(Object) - 类 java.io.Reader 的构造方法
创建一个新的字符流 reader，其重要部分将同步给定的对象。
reader - 类 javax.script.SimpleScriptContext 中的变量
此字段是用于脚本输入的 reader。
readerSpiNames - 类 javax.imageio.spi.ImageWriterSpi 中的变量
将从 getImageReaderSpiNames 返回的字符串数组，该数组最初为 null。
readerSupportsThumbnails() - 类 javax.imageio.ImageReader 中的方法
如果此 reader 所理解的图像格式支持与之关联的缩略图预览图像，则返回 true。
readExternal(ObjectInput) - 类 java.awt.datatransfer.DataFlavor 中的方法
根据 Serialized 状态还原此 DataFlavor。
readExternal(ObjectInput) - 接口 java.io.Externalizable 中的方法
对象实现 readExternal 方法来恢复其内容，它通过调用 DataInput 的方法来恢复其基础类型，调用 readObject 来恢复对象、字符串和数组。
readExternal(ObjectInput) - 类 javax.activation.MimeType 中的方法
对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。
readExternal(ObjectInput) - 类 javax.management.loading.MLet 中的方法
从给定的 ObjectInput 恢复此 MLet 的内容。
readFields() - 类 java.io.ObjectInputStream 中的方法
按名称从流中读取持久字段并使其可用。
readFloat() - 接口 java.io.DataInput 中的方法
读取四个输入字节并返回一个 float 值。
readFloat() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readFloat 方法的常规协定。
readFloat() - 类 java.io.ObjectInputStream 中的方法
读取一个 32 位的 float 值。
readFloat() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个 float。
readFloat() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 float 返回。
readFloat() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 float 值的形式返回结果。
readFloat() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFloat() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 float 的形式获取此 SQLInputImpl 对象中的下一个属性。
readFully(byte[]) - 接口 java.io.DataInput 中的方法
从输入流中读取一些字节，并将它们存储在缓冲区数组 b 中。
readFully(byte[], int, int) - 接口 java.io.DataInput 中的方法
从输入流中读取 len 个字节。
readFully(byte[]) - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readFully 方法的常规协定。
readFully(byte[], int, int) - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readFully 方法的常规协定。
readFully(byte[]) - 类 java.io.ObjectInputStream 中的方法
读取字节，同时阻塞直至读取所有字节。
readFully(byte[], int, int) - 类 java.io.ObjectInputStream 中的方法
读取字节，同时阻塞直至读取所有字节。
readFully(byte[]) - 类 java.io.RandomAccessFile 中的方法
将 b.length 个字节从此文件读入 byte 数组，并从当前文件指针开始。
readFully(byte[], int, int) - 类 java.io.RandomAccessFile 中的方法
将正好 len 个字节从此文件读入 byte 数组，并从当前文件指针开始。
readFully(byte[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 len 个字节，并将其存储到 b 中（从索引 off 开始）。
readFully(byte[]) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
readFully(short[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 short（有符号 16 位整数），并将其存储到 s 中（从索引 off 开始）。
readFully(char[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 char（无符号 16 位整数），并将其存储到 c 中（从索引 off 开始）。
readFully(int[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 int（有符号 32 位整数），并将其存储到 i 中（从索引 off 开始）。
readFully(long[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 long（有符号 64 位整数），并将其存储到 l 中（从索引 off 开始）。
readFully(float[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 float（32 位 IEEE 单精度浮点值），并将其存储到 f 中（从索引 off 开始）。
readFully(double[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 double（64 位 IEEE 双精度浮点值），并将其存储到 d 中（从索引 off 开始）。
readFully(byte[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(byte[]) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(short[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(char[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(int[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(long[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(float[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(double[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
READING - 类 java.text.AttributedCharacterIterator.Attribute 中的静态变量
某些文本的读法的属性键。
readInt() - 接口 java.io.DataInput 中的方法
读取四个输入字节并返回一个 int 值。
readInt() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readInt 方法的常规协定。
readInt() - 类 java.io.ObjectInputStream 中的方法
读取一个 32 位的 int 值。
readInt() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个有符号的 32 位整数。
readInt() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 int 返回。
readInt() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 int 值的形式返回结果。
readInt() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readInt() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 int 的形式获取此 SQLInputImpl 对象中的下一个属性。
readLine() - 类 java.io.BufferedReader 中的方法
读取一个文本行。
readLine(String, Object...) - 类 java.io.Console 中的方法
提供一个格式化提示，然后从控制台读取单行文本。
readLine() - 类 java.io.Console 中的方法
从控制台读取单行文本。
readLine() - 接口 java.io.DataInput 中的方法
从输入流中读取下一文本行。
readLine() - 类 java.io.DataInputStream 中的方法
已过时。 该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
readLine() - 类 java.io.LineNumberReader 中的方法
读取文本行。
readLine() - 类 java.io.ObjectInputStream 中的方法
已过时。 此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。
readLine() - 类 java.io.RandomAccessFile 中的方法
从此文件读取文本的下一行。
readLine() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从输入流中读取文本的下一行。
readLine() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readLock() - 接口 java.util.concurrent.locks.ReadWriteLock 中的方法
返回用于读取操作的锁。
readLock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
readLock() - 类 javax.swing.text.AbstractDocument 中的方法
获取一个锁定，以开始读取文档的某个状态。
readLong() - 接口 java.io.DataInput 中的方法
读取八个输入字节并返回一个 long 值。
readLong() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readLong 方法的常规协定。
readLong() - 类 java.io.ObjectInputStream 中的方法
读取一个 64 位的 long 值。
readLong() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个有符号的 64 位整数。
readLong() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 long 返回。
readLong() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 long 值的形式返回结果。
readLong() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readLong() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 long 的形式获取此 SQLInputImpl 对象中的下一个属性。
readNClob() - 接口 java.sql.SQLInput 中的方法
从流中读取一个 SQL NCLOB 值，并以 Java 编程语言中 NCLOB 对象的形式返回。
readNClob() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
从流中读取 SQL NCLOB 值并以 Java 编程语言中 Clob 对象的形式返回。
readNString() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性，并以 Java 编程语言中 String 的形式返回。
readNString() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
读取流中下一个属性并以 Java 编程语言中 String 的形式返回。
readObject() - 类 java.beans.XMLDecoder 中的方法
从基础输入流中读取下一个对象。
readObject() - 接口 java.io.ObjectInput 中的方法
读取并返回对象。
readObject() - 类 java.io.ObjectInputStream 中的方法
从 ObjectInputStream 读取对象。
readObject() - 接口 java.sql.SQLInput 中的方法
读取流头中的下一个属性并将其作为 Java 编程语言中的 Object 返回。
readObject(Stub, ObjectInputStream) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.readObject(java.io.ObjectInputStream) 的委托调用。
readObject() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 Object 的形式获取此 SQLInputImpl 对象的头部值。
readObjectOverride() - 类 java.io.ObjectInputStream 中的方法
此方法由 ObjectOutputStream 的受信任子类调用，这些子类使用受保护的无参数构造方法构造 ObjectOutputStream。
readOnlyAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
将编辑器设置为只读模式的动作名称。
ReadOnlyBufferException - java.nio 中的 异常
当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。
ReadOnlyBufferException() - 异常 java.nio.ReadOnlyBufferException 的构造方法
构造此类的一个实例。
readPassword(String, Object...) - 类 java.io.Console 中的方法
提供一个格式化提示，然后从控制台读取密码，禁用回显。
readPassword() - 类 java.io.Console 中的方法
从控制台读取密码，禁用回显。
readRaster(int, ImageReadParam) - 类 javax.imageio.ImageReader 中的方法
返回包含图像流中原始像素数据的新 Raster 对象，不应用任何颜色转换。
readRef() - 接口 java.sql.SQLInput 中的方法
从流读取 SQL REF 值并将其作为 Java 编程语言中的 Ref 对象返回。
readRef() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 Ref 对象的形式获取此 SQLInputImpl 对象的头部值。
readResolve() - 类 java.awt.AWTKeyStroke 中的方法
返回 AWTKeyStroke 的一个缓存实例（或 AWTKeyStroke 的子类），它与此实例相等。
readResolve() - 类 java.awt.color.ICC_Profile 中的方法
解析将被反序列化为用 CMM 注册的实例的实例。
readResolve() - 类 java.awt.font.TextAttribute 中的方法
将反序列化的实例解析为预定义常量。
readResolve() - 类 java.security.cert.Certificate.CertificateRep 中的方法
解析该 Certificate 对象。
readResolve() - 类 java.security.cert.CertPath.CertPathRep 中的方法
返回根据类型和数据所构造的 CertPath。
readResolve() - 类 java.security.KeyRep 中的方法
解析 Key 对象。
readResolve() - 类 java.text.AttributedCharacterIterator.Attribute 中的方法
解析将被反序列化为预定义常量的实例。
readResolve() - 类 java.text.DateFormat.Field 中的方法
将反序列化的实例解析成预定义的常量。
readResolve() - 类 java.text.MessageFormat.Field 中的方法
把正被反序列化的实例解析为预定义的常量。
readResolve() - 类 java.text.NumberFormat.Field 中的方法
将正被反序列化的实例解析为预定义的常量。
readResolve() - 类 javax.management.openmbean.SimpleType 中的方法
使用该值的唯一实例替换从 ObjectInputStream 读取的对象。
readResolve() - 类 javax.print.attribute.EnumSyntax 中的方法
在对象输入过程中，将此反序列化的枚举实例转换为枚举属性类中定义的适当枚举值。
readRowId() - 接口 java.sql.SQLInput 中的方法
从流中读取一个 SQL ROWID 值，并以 Java 编程语言中 RowId 对象的形式返回。
readRowId() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
从流中读取 SQL ROWID 值并以 Java 编程语言中 RowId 对象的形式返回。
readShort() - 接口 java.io.DataInput 中的方法
读取两个输入字节并返回一个 short 值。
readShort() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readShort 方法的常规协定。
readShort() - 类 java.io.ObjectInputStream 中的方法
读取一个 16 位的 short 值。
readShort() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个有符号的 16 位数。
readShort() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 short 返回。
readShort() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取两个字节，根据当前字节顺序将其连接（概念上），然后以 short 值的形式返回结果。
readShort() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readShort() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 short 的形式获取此 SQLInputImpl 对象中的下一个属性。
readSQL(SQLInput, String) - 接口 java.sql.SQLData 中的方法
用从数据库读取的数据填充此对象。
readSQLXML() - 接口 java.sql.SQLInput 中的方法
从流中读取一个 SQL XML 值，并以 Java 编程语言中 SQLXML 对象的形式返回。
readSQLXML() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
从流中读取 SQL XML 值并以 Java 编程语言中 SQLXML 对象的形式返回。
readStreamHeader() - 类 java.io.ObjectInputStream 中的方法
提供的 readStreamHeader 方法允许子类读取并验证它们自己的流头部。
readString() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 String 返回。
readString() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 String 的形式获取此 SQLInputImpl 对象中的下一个属性。
readThumbnail(int, int) - 类 javax.imageio.ImageReader 中的方法
以 BufferedImage 形式返回通过索引 thumbnailIndex 指定的缩略图预览图像，其与通过索引 ImageIndex 指定的图像关联。
readTile(int, int, int) - 类 javax.imageio.ImageReader 中的方法
读取由 tileX 和 tileY 参数指示的 tile，并以 BufferedImage 形式返回。
readTileRaster(int, int, int) - 类 javax.imageio.ImageReader 中的方法
返回包含 tile 中的原始像素数据的新 Raster 对象，不应用任何颜色转换。
readTime() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 java.sql.Time 对象返回。
readTime() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 java.sql.Time 对象的形式获取此 SQLInputImpl 对象中的下一个属性。
readTimestamp() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 java.sql.Timestamp 对象返回。
readTimestamp() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 java.sql.Timestamp 对象的形式获取此 SQLInputImpl 对象中的下一个属性。
readUnlock() - 类 javax.swing.text.AbstractDocument 中的方法
执行读取解除锁定。
readUnshared() - 类 java.io.ObjectInputStream 中的方法
从 ObjectInputStream 读取“非共享”对象。
readUnsignedByte() - 接口 java.io.DataInput 中的方法
读取一个输入字节，将它左侧补零 (zero-extend) 转变为 int 类型，并返回结果，所以结果的范围是 0 到 255。
readUnsignedByte() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readUnsignedByte 方法的常规协定。
readUnsignedByte() - 类 java.io.ObjectInputStream 中的方法
读取一个无符号的 8 位字节。
readUnsignedByte() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个无符号的八位数。
readUnsignedByte() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取一个字节，将其转换为 int（概念上），使用 0xff 屏蔽以便去掉所有符号扩展位，然后以 byte 值的形式返回。
readUnsignedByte() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readUnsignedInt() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 long，使用 0xffffffffL 屏蔽以便去掉所有符号扩展位，然后以无符号 long 值的形式返回结果。
readUnsignedInt() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readUnsignedShort() - 接口 java.io.DataInput 中的方法
读取两个输入字节，并返回 0 到 65535 范围内的一个 int 值。
readUnsignedShort() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readUnsignedShort 方法的常规协定。
readUnsignedShort() - 类 java.io.ObjectInputStream 中的方法
读取一个无符号的 16 位 short 值。
readUnsignedShort() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个无符号的 16 位数。
readUnsignedShort() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取两个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 int，使用 0xffff 屏蔽以便去掉所有符号扩展位，然后以无符号 int 值的形式返回结果。
readUnsignedShort() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readURL() - 接口 java.sql.SQLInput 中的方法
从流中读取 SQL DATALINK 值并将其作为 Java 编程语言中的 java.net.URL 对象返回。
readURL() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
从流中读取 SQL DATALINK 值并以 Java 编程语言中 URL 对象的形式返回。
readUTF() - 接口 java.io.DataInput 中的方法
读入一个已使用 UTF-8 修改版格式编码的字符串。
readUTF() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readUTF 方法的常规协定。
readUTF(DataInput) - 类 java.io.DataInputStream 中的静态方法
从流 in 中读取用 UTF-8 修改版格式编码的 Unicode 字符格式的字符串；然后以 String 形式返回此字符串。
readUTF() - 类 java.io.ObjectInputStream 中的方法
读取 UTF-8 修改版格式的 String。
readUTF() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个字符串。
readUTF() - 接口 javax.imageio.stream.ImageInputStream 中的方法
读入一个已使用 UTF-8 修改版格式编码的字符串。
readUTF() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readValue(InputStream, int, Class, String, RunTime) - 接口 javax.rmi.CORBA.ValueHandler 中的方法
使用 Java 语义从流中读取一个值。
ReadWriteLock - java.util.concurrent.locks 中的 接口
ReadWriteLock 维护了一对相关的锁，一个用于只读操作，另一个用于写入操作。
readXML(WebRowSet, Reader) - 接口 javax.sql.rowset.spi.XmlReader 中的方法
从给定的 XML 格式的输入流读取并解析给定的 WebRowSet 对象。
readXml(Reader) - 接口 javax.sql.rowset.WebRowSet 中的方法
从给定的 Reader 对象以其 XML 格式读取 WebRowSet 对象。
readXml(InputStream) - 接口 javax.sql.rowset.WebRowSet 中的方法
读取基于流的 XML 输入，以填充此 WebRowSet 对象。
ready() - 类 java.io.BufferedReader 中的方法
判断此流是否已准备好被读取。
ready() - 类 java.io.CharArrayReader 中的方法
判断此流是否已准备好被读取。
ready() - 类 java.io.FilterReader 中的方法
判断此流是否已经准备好用于读取。
ready() - 类 java.io.InputStreamReader 中的方法
判断此流是否已经准备好用于读取。
ready() - 类 java.io.PipedReader 中的方法
告知是否准备读取此流。
ready() - 类 java.io.PushbackReader 中的方法
判断是否准备读取此流。
ready() - 类 java.io.Reader 中的方法
判断是否准备读取此流。
ready() - 类 java.io.StringReader 中的方法
判断此流是否已经准备好用于读取。
readyOps() - 类 java.nio.channels.SelectionKey 中的方法
获取此键的 ready 操作集合。
REAL - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 REAL 的 Java 编程语言中的常量（有时称为类型代码）。
realEditor - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
处理该编辑的编辑器。
RealmCallback - javax.security.sasl 中的 类
SaslClient 和 SaslServer 使用此回调来获取领域信息。
RealmCallback(String) - 类 javax.security.sasl.RealmCallback 的构造方法
构造带提示的 RealmCallback。
RealmCallback(String, String) - 类 javax.security.sasl.RealmCallback 的构造方法
构造带提示和默认领域信息的 RealmCallback。
RealmChoiceCallback - javax.security.sasl 中的 类
SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。
RealmChoiceCallback(String, String[], int, boolean) - 类 javax.security.sasl.RealmChoiceCallback 的构造方法
构造带提示、选项列表和默认选项的 RealmChoiceCallback。
realSource - 类 javax.swing.undo.UndoableEditSupport 中的变量
reason - 异常 org.omg.CORBA.PolicyError 中的变量
抛出 PolicyError 异常的原因。
rebind(String, Remote) - 类 java.rmi.Naming 中的静态方法
将指定名称重新绑定到一个新的远程对象。
rebind(String, Remote) - 接口 java.rmi.registry.Registry 中的方法
用提供的远程引用替换此注册表中指定的 name 绑定。
rebind(Name, Object) - 接口 javax.naming.Context 中的方法
将名称绑定到对象，重写任何现有绑定。
rebind(String, Object) - 接口 javax.naming.Context 中的方法
将名称绑定到对象，重写所有现有绑定。
rebind(Name, Object, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
rebind(String, Object, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
rebind(String, Object, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
rebind(Name, Object, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
rebind(String, Object) - 类 javax.naming.InitialContext 中的方法
rebind(Name, Object) - 类 javax.naming.InitialContext 中的方法
REBIND - org.omg.CORBA 中的 异常
如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
REBIND() - 异常 org.omg.CORBA.REBIND 的构造方法
构造一个 REBIND 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。
REBIND(String) - 异常 org.omg.CORBA.REBIND 的构造方法
使用指定消息构造一个 REBIND 异常。
REBIND(int, CompletionStatus) - 异常 org.omg.CORBA.REBIND 的构造方法
使用指定次要代码和完成状态 (completion status) 构造一个 REBIND 异常。
REBIND(String, int, CompletionStatus) - 异常 org.omg.CORBA.REBIND 的构造方法
使用指定消息、次要代码和完成状态构造一个 REBIND 异常。
rebind(NameComponent[], Object) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
rebind(NameComponent[], Object) - 类 org.omg.CosNaming._NamingContextStub 中的方法
在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
rebind(NameComponent[], Object) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
rebind_context(NameComponent[], NamingContext) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
rebind_context(NameComponent[], NamingContext) - 类 org.omg.CosNaming._NamingContextStub 中的方法
在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
rebind_context(NameComponent[], NamingContext) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
recalculateIfInsetsChanged() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
recalculateIfOrientationChanged() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
recalcWidthCache() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
重新计算所有列的总宽度。
receive(int) - 类 java.io.PipedInputStream 中的方法
接收数据字节。
receive(DatagramPacket) - 类 java.net.DatagramSocket 中的方法
从此套接字接收数据报包。
receive(DatagramPacket) - 类 java.net.DatagramSocketImpl 中的方法
接收数据报包。
receive(ByteBuffer) - 类 java.nio.channels.DatagramChannel 中的方法
通过此通道接收数据报。
receive_exception(ClientRequestInfo) - 接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 中的方法
指示 interceptor 发生异常。
receive_other(ClientRequestInfo) - 接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 中的方法
允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
receive_reply(ClientRequestInfo) - 接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 中的方法
允许 Interceptor 在从服务器返回后但在向客户端返回控件前查询信息。
receive_request(ServerRequestInfo) - 接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 中的方法
允许 Interceptor 在所有信息（包括操作参数）可用后查询信息。
receive_request_service_contexts(ServerRequestInfo) - 接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 中的方法
允许 interceptor 处理服务上下文信息。
received_exception() - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回一个 any，它包含要向客户端返回的异常。
received_exception_id() - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回将向客户端返回的异常的存储库 id。
Receiver - javax.sound.midi 中的 接口
一个 Receiver，用于接收 MidiEvent 对象，并且通常执行一些响应性的操作，例如，解释该对象以生成声音或原始 MIDI 输出。
reclaim(AttributeSet) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
回收某个属性集。
reclaim(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
返回 MutableAttributeSet 实现不再需要的集合。
reconnect(Control[]) - 类 javax.naming.ldap.InitialLdapContext 中的方法
reconnect(Control[]) - 接口 javax.naming.ldap.LdapContext 中的方法
使用提供的控件和此上下文的环境重新连接到 LDAP 服务器。
reconvert() - 类 java.awt.im.InputContext 中的方法
让当前输入方法从当前客户端组件中恢复文本。
reconvert() - 接口 java.awt.im.spi.InputMethod 中的方法
启动恢复操作。
recordDisable(Track) - 接口 javax.sound.midi.Sequencer 中的方法
禁止向指定轨道的录制。
recordEnable(Track, int) - 接口 javax.sound.midi.Sequencer 中的方法
为录制特定通道上接收的事件准备指定的轨道。
recover(int) - 接口 javax.transaction.xa.XAResource 中的方法
从资源管理器获取准备的事务分支的列表。
Rectangle - java.awt 中的 类
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Rectangle() - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角的坐标为 (0,0)，宽度和高度均为 0。
Rectangle(Rectangle) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，并将其初始化，以与指定 Rectangle 的值匹配。
Rectangle(int, int, int, int) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角被指定为 (x,y)，其宽度和高度由同名的参数指定。
Rectangle(int, int) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角的坐标为 (0,0)，其宽度和高度由同名的参数指定。
Rectangle(Point, Dimension) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角由 Point 参数指定，其宽度和高度由 Dimension 参数指定。
Rectangle(Point) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角是指定的 Point，其宽度和高度均为 0。
Rectangle(Dimension) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角为 (0,0)，其宽度和高度由 Dimension 参数指定。
Rectangle2D - java.awt.geom 中的 类
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
Rectangle2D() - 类 java.awt.geom.Rectangle2D 的构造方法
这是一个不可直接实例化的抽象类。
Rectangle2D.Double - java.awt.geom 中的 类
Double 类定义一个在 double 坐标中指定的矩形。
Rectangle2D.Double() - 类 java.awt.geom.Rectangle2D.Double 的构造方法
构造一个新 Rectangle2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。
Rectangle2D.Double(double, double, double, double) - 类 java.awt.geom.Rectangle2D.Double 的构造方法
根据指定的 double 坐标构造和初始化 Rectangle2D。
Rectangle2D.Float - java.awt.geom 中的 类
Float 类定义一个在 float 坐标中指定的矩形。
Rectangle2D.Float() - 类 java.awt.geom.Rectangle2D.Float 的构造方法
构造一个新 Rectangle2D，并将其初始化为：位置 (0.0, 0.0)、大小 (0.0, 0.0)。
Rectangle2D.Float(float, float, float, float) - 类 java.awt.geom.Rectangle2D.Float 的构造方法
根据指定的 float 坐标构造和初始化 Rectangle2D。
rectangleForCurrentValue() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回为绘制当前所选项而保留的区域。
RectangularShape - java.awt.geom 中的 类
RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。
RectangularShape() - 类 java.awt.geom.RectangularShape 的构造方法
这是一个不可直接实例化的抽象类。
rects - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
recycleNode() - 接口 javax.xml.soap.Node 中的方法
通知实现此 Node 对象不再由应用程序使用，对于以后可能创建的节点，实现可以随意重用此对象。
red - 类 java.awt.Color 中的静态变量
红色。
RED - 类 java.awt.Color 中的静态变量
红色。
REDCOMPONENT - 类 java.awt.color.ICC_ProfileRGB 中的静态变量
用于获取红色分量的 gamma 值或 TRC。
redefineClasses(ClassDefinition...) - 接口 java.lang.instrument.Instrumentation 中的方法
使用提供的类文件重定义提供的类集。
redirectErrorStream() - 类 java.lang.ProcessBuilder 中的方法
通知进程生成器是否合并标准错误和标准输出。
redirectErrorStream(boolean) - 类 java.lang.ProcessBuilder 中的方法
设置此进程生成器的 redirectErrorStream 属性。
redispatchEvent(Component, AWTEvent) - 类 java.awt.KeyboardFocusManager 中的方法
重新指派 AWTEvent 的方式是，AWT 事件调度程序不会递归式请求 KeyboardFocusManager 或任何已安装的 KeyEventDispatcher 再次指派该事件。
redo() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
重复执行更改。
redo() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
重复执行更改。
redo() - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的方法
重复更改。
redo() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
如果 canRedo 返回 false，则抛出 CannotRedoException。
redo() - 类 javax.swing.undo.CompoundEdit 中的方法
按添加时的顺序将 redo 发送到所有包含的 UndoableEdit 中。
redo() - 类 javax.swing.undo.StateEdit 中的方法
通知编辑对象应用编辑之后的状态
redo() - 接口 javax.swing.undo.UndoableEdit 中的方法
重新应用编辑。
redo() - 类 javax.swing.undo.UndoManager 中的方法
恢复适当的编辑。
RedoName - 类 javax.swing.undo.AbstractUndoableEdit 中的静态变量
由 getRedoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此段落。
redoTo(UndoableEdit) - 类 javax.swing.undo.UndoManager 中的方法
恢复从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。
reducePermits(int) - 类 java.util.concurrent.Semaphore 中的方法
根据指定的缩减量减小可用许可的数目。
ReentrantLock - java.util.concurrent.locks 中的 类
一个可重入的互斥锁 Lock，它具有与使用 synchronized 方法和语句所访问的隐式监视器锁相同的一些基本行为和语义，但功能更强大。
ReentrantLock() - 类 java.util.concurrent.locks.ReentrantLock 的构造方法
创建一个 ReentrantLock 的实例。
ReentrantLock(boolean) - 类 java.util.concurrent.locks.ReentrantLock 的构造方法
创建一个具有给定公平策略的 ReentrantLock。
ReentrantReadWriteLock - java.util.concurrent.locks 中的 类
支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。
ReentrantReadWriteLock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 的构造方法
使用默认（非公平）的排序属性创建一个新的 ReentrantReadWriteLock。
ReentrantReadWriteLock(boolean) - 类 java.util.concurrent.locks.ReentrantReadWriteLock 的构造方法
使用给定的公平策略创建一个新的 ReentrantReadWriteLock。
ReentrantReadWriteLock.ReadLock - java.util.concurrent.locks 中的 类
ReentrantReadWriteLock.readLock() 方法返回的锁。
ReentrantReadWriteLock.ReadLock(ReentrantReadWriteLock) - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 的构造方法
子类使用的构造方法
ReentrantReadWriteLock.WriteLock - java.util.concurrent.locks 中的 类
ReentrantReadWriteLock.writeLock() 方法返回的锁。
ReentrantReadWriteLock.WriteLock(ReentrantReadWriteLock) - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 的构造方法
子类使用的构造方法
ref - 类 java.rmi.server.RemoteObject 中的变量
对象的远程引用。
Ref - java.sql 中的 接口
Java 编程语言中 SQL REF 值的映射关系，它是到数据库中的 SQL 结构类型值的引用。
REF - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 REF 的 Java 编程语言中的常量（有时称为类型代码）。
REF_MBEAN_NOT_REGISTERED - 类 javax.management.relation.RoleStatus 中的静态变量
试图设置角色值时的问题类型，包括未在 MBean Server 中注册的 MBean 的 ObjectName。
REF_MBEAN_OF_INCORRECT_CLASS - 类 javax.management.relation.RoleStatus 中的静态变量
试图设置角色值时的问题类型，包括不属于该角色所期望类的 MBean 的 ObjectName。
RefAddr - javax.naming 中的 类
此类表示通信端点的地址。
RefAddr(String) - 类 javax.naming.RefAddr 的构造方法
使用地址类型构造一个新的 RefAddr 实例。
Reference<T> - java.lang.ref 中的 类
引用对象的抽象基类。
Reference - javax.naming 中的 类
此类表示对存在于命名/目录系统以外的对象的引用。
Reference(String) - 类 javax.naming.Reference 的构造方法
使用类名称 'className' 构造对某个对象的新引用。
Reference(String, RefAddr) - 类 javax.naming.Reference 的构造方法
使用类名称 'className' 和一个地址构造对某个对象的新引用。
Reference(String, String, String) - 类 javax.naming.Reference 的构造方法
使用类名称 'className' 以及对象工厂的类名称和位置创建对某个对象的新引用。
Reference(String, RefAddr, String, String) - 类 javax.naming.Reference 的构造方法
使用类名称 'className'、对象工厂的类名称和位置以及对象的地址创建该对某个对象的新引用。
Reference - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Reference 元素的表示形式。
reference_to_id(Object) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作返回指定引用封装的 Object Id 值。
reference_to_servant(Object) - 接口 org.omg.PortableServer.POAOperations 中的方法
如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
Referenceable - javax.naming 中的 接口
此接口由可以为自身提供 Reference 的对象实现。
ReferenceQueue<T> - java.lang.ref 中的 类
引用队列，在检测到适当的可到达性更改后，垃圾回收器将已注册的引用对象添加到该队列中。
ReferenceQueue() - 类 java.lang.ref.ReferenceQueue 的构造方法
构造一个新的引用对象队列。
ReferenceType - javax.lang.model.type 中的 接口
表示一个引用类型。
ReferenceUriSchemesSupported - javax.print.attribute.standard 中的 类
ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。
ReferenceUriSchemesSupported(int) - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 的构造方法
构造具有给定整数值的新 ReferenceUriSchemesSupported 枚举值。
REFERRAL - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定将如何处理服务提供者遇到的引用的环境属性名称。
ReferralException - javax.naming 中的 异常
此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
ReferralException(String) - 异常 javax.naming.ReferralException 的构造方法
使用所提供的解释构造一个新的 ReferralException 实例。
ReferralException() - 异常 javax.naming.ReferralException 的构造方法
构造一个新的 ReferralException 实例。
ReflectionException - javax.management 中的 异常
表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
ReflectionException(Exception) - 异常 javax.management.ReflectionException 的构造方法
创建包装实际 java.lang.Exception 的 ReflectionException。
ReflectionException(Exception, String) - 异常 javax.management.ReflectionException 的构造方法
创建包装带有详细消息的实际 java.lang.Exception 的 ReflectionException。
ReflectPermission - java.lang.reflect 中的 类
反射操作的 Permission 类。
ReflectPermission(String) - 类 java.lang.reflect.ReflectPermission 的构造方法
构造不带指定名称的 ReflectPermission。
ReflectPermission(String, String) - 类 java.lang.reflect.ReflectPermission 的构造方法
构造带指定名称和动作的 ReflectPermission。
refresh() - 类 java.security.Policy 中的方法
刷新/重新加载策略配置。
refresh() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
延长此票据的有效期。
refresh() - 类 javax.security.auth.login.Configuration 中的方法
刷新和重新加载 Configuration。
refresh() - 类 javax.security.auth.Policy 中的方法
已过时。 刷新/重新加载 Policy。
refresh() - 接口 javax.security.auth.Refreshable 中的方法
更新或延长此 Object 的有效期。
REFRESH_RATE_UNKNOWN - 类 java.awt.DisplayMode 中的静态变量
刷新率的值（如果未知）。
Refreshable - javax.security.auth 中的 接口
诸如证书之类的对象可以选择实现此接口，以提供对自己进行刷新的功能。
RefreshFailedException - javax.security.auth 中的 异常
当 refresh 操作失败时，抛出此异常。
RefreshFailedException() - 异常 javax.security.auth.RefreshFailedException 的构造方法
构造不带详细消息的 RefreshFailedException。
RefreshFailedException(String) - 异常 javax.security.auth.RefreshFailedException 的构造方法
构造带指定详细消息的 RefreshFailedException。
refreshRow() - 接口 java.sql.ResultSet 中的方法
用数据库中的最近值刷新当前行。
regexFilter(String, int...) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它使用正则表达式确定要包含哪些条目。
region(int, int) - 类 java.util.regex.Matcher 中的方法
设置此匹配器的区域限制。
Region - javax.swing.plaf.synth 中的 类
Swing 组件的独特呈现区域。
Region(String, String, boolean) - 类 javax.swing.plaf.synth.Region 的构造方法
创建具有指定名称的 Region。
regionEnd() - 类 java.util.regex.Matcher 中的方法
报告此匹配器区域的结束索引（不包括）。
regionMatches(int, String, int, int) - 类 java.lang.String 中的方法
测试两个字符串区域是否相等。
regionMatches(boolean, int, String, int, int) - 类 java.lang.String 中的方法
测试两个字符串区域是否相等。
regionStart() - 类 java.util.regex.Matcher 中的方法
报告此匹配器区域的开始索引。
register(Selector, int, Object) - 类 java.nio.channels.SelectableChannel 中的方法
向给定的选择器注册此通道，返回一个选择键。
register(Selector, int) - 类 java.nio.channels.SelectableChannel 中的方法
向给定的选择器注册此通道，返回一个选择键。
register(Selector, int, Object) - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
向给定的选择器注册此通道，返回一个选择键。
register(AbstractSelectableChannel, int, Object) - 类 java.nio.channels.spi.AbstractSelector 中的方法
向此选择器注册给定的通道。
register(ActivationDesc) - 类 java.rmi.activation.Activatable 中的静态方法
为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
register_initial_reference(String, Object) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
等同于 ORB.register_initial_reference。
register_policy_factory(int, PolicyFactory) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
注册给定 PolicyType 的 PolicyFactory。
register_value_factory(String, ValueFactory) - 类 org.omg.CORBA_2_3.ORB 中的方法
RegisterableService - javax.imageio.spi 中的 接口
一个可选接口，它可能是由向 ServiceRegistry 注册的服务提供者对象提供的。
registerApplicationClasspathSpis() - 类 javax.imageio.spi.IIORegistry 中的方法
使用默认的 ClassLoader 注册应用程序类路径中找到的所有可用的服务提供者。
registerComponent(JComponent) - 类 javax.swing.ToolTipManager 中的方法
注册一个工具提示管理组件。
registerDriver(Driver) - 类 java.sql.DriverManager 中的静态方法
向 DriverManager 注册给定驱动程序。
registerEditor(Class<?>, Class<?>) - 类 java.beans.PropertyEditorManager 中的静态方法
注册一个将用来编辑给定目标类的值的编辑器类。
registerEditorKitForContentType(String, String) - 类 javax.swing.JEditorPane 中的静态方法
建立 type 到 classname 的默认绑定。
registerEditorKitForContentType(String, String, ClassLoader) - 类 javax.swing.JEditorPane 中的静态方法
建立 type 到 classname 的默认绑定。
registerEngineExtension(String, ScriptEngineFactory) - 类 javax.script.ScriptEngineManager 中的方法
注册一个 ScriptEngineFactory 来处理扩展。
registerEngineMimeType(String, ScriptEngineFactory) - 类 javax.script.ScriptEngineManager 中的方法
注册一个 ScriptEngineFactory 来处理 mime 类型。
registerEngineName(String, ScriptEngineFactory) - 类 javax.script.ScriptEngineManager 中的方法
注册一个 ScriptEngineFactory 来处理语言名称。
registerFont(Font) - 类 java.awt.GraphicsEnvironment 中的方法
在此 GraphicsEnvironment 中注册一个/已创建的 Font。
registerGroup(ActivationGroupDesc) - 接口 java.rmi.activation.ActivationSystem 中的方法
注册激活组。
registerKeyboardAction(ActionListener, String, KeyStroke, int) - 类 javax.swing.JComponent 中的方法
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
registerKeyboardAction(ActionListener, KeyStroke, int) - 类 javax.swing.JComponent 中的方法
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
registerKeyboardActions() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
registerListeners() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
向该 Component 注册此 DragGestureRecognizer 的 Listeners。
registerListeners() - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
注册此 DragGestureRecognizer 的 Listener 和 Component
registerMBean(Object, ObjectName) - 接口 javax.management.MBeanServer 中的方法
将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。
registerObject(ActivationDesc) - 接口 java.rmi.activation.ActivationSystem 中的方法
registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
registerOutParameter(int, int) - 接口 java.sql.CallableStatement 中的方法
按顺序位置 parameterIndex 将 OUT 参数注册为 JDBC 类型 sqlType。
registerOutParameter(int, int, int) - 接口 java.sql.CallableStatement 中的方法
按顺序位置 parameterIndex 将参数注册为 JDBC 类型 sqlType。
registerOutParameter(int, int, String) - 接口 java.sql.CallableStatement 中的方法
注册指定的输出参数。
registerOutParameter(String, int) - 接口 java.sql.CallableStatement 中的方法
将名为 parameterName 的 OUT 参数注册为 JDBC 类型 sqlType。
registerOutParameter(String, int, int) - 接口 java.sql.CallableStatement 中的方法
将名为 parameterName 的参数注册为 JDBC 类型 sqlType。
registerOutParameter(String, int, String) - 接口 java.sql.CallableStatement 中的方法
注册指定的输出参数。
registerProvider(String) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
将给定的同步提供者添加到工厂注册器。
registerService(PrintService) - 类 javax.print.PrintServiceLookup 中的静态方法
允许应用程序直接注册一个实现了 PrintService 的类的实例。
registerServiceProvider(T, Class<T>) - 类 javax.imageio.spi.ServiceRegistry 中的方法
将一个服务提供者对象添加到注册表。
registerServiceProvider(Object) - 类 javax.imageio.spi.ServiceRegistry 中的方法
将一个服务提供者对象添加到注册表。
registerServiceProvider(PrintServiceLookup) - 类 javax.print.PrintServiceLookup 中的静态方法
允许应用程序显式地注册一个实现了查找服务的类。
registerServiceProviders(Iterator<?>) - 类 javax.imageio.spi.ServiceRegistry 中的方法
将一组取自 Iterator 的服务提供者对象添加到注册表。
registerStaticAttributeKey(Object) - 类 javax.swing.text.StyleContext 中的静态方法
将一个对象注册为用作属性集中的一个键的静态对象。
registerSubclass(Class<?>) - 类 java.awt.AWTKeyStroke 中的静态方法
注册一个新类，AWTKeyStroke 中的工厂方法在生成 AWTKeyStroke 的新实例时将使用它。
registerTag(HTML.Tag, HTMLDocument.HTMLReader.TagAction) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
注册给定标记的处理程序。
registerTarget(Tie, Remote) - 类 javax.rmi.CORBA.Util 中的静态方法
为 tie 注册一个目标。
registerTarget(Tie, Remote) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 的委托调用。
registerValidation(ObjectInputValidation, int) - 类 java.io.ObjectInputStream 中的方法
在返回图形前注册要验证的对象。
REGISTRATION_NOTIFICATION - 类 javax.management.MBeanServerNotification 中的静态变量
表示已注册该 MBean 的通知类型。
Registry - java.rmi.registry 中的 接口
Registry 是简单远程对象注册表的一个远程接口，它提供存储和获取绑定了任意字符串名称的远程对象引用的方法。
REGISTRY_ID - 类 java.rmi.server.ObjID 中的静态变量
注册表的已知 ObjID 的对象数。
REGISTRY_PORT - 接口 java.rmi.registry.Registry 中的静态变量
已知的注册表端口。
RegistryHandler - java.rmi.registry 中的 接口
已过时。 无替代版本
registryImpl(int) - 接口 java.rmi.registry.RegistryHandler 中的方法
已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。
registryStub(String, int) - 接口 java.rmi.registry.RegistryHandler 中的方法
已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。
rehash() - 类 java.util.Hashtable 中的方法
增加此哈希表的容量并在内部对其进行重组，以便更有效地容纳和访问其元素。
rejectDrag() - 类 java.awt.dnd.DropTargetContext 中的方法
拒绝该 Drag。
rejectDrag() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
作为检查 dropAction 或可用的 DataFlavor 类型的结果，拒绝 drag。
rejectDrop() - 类 java.awt.dnd.DropTargetContext 中的方法
调用以指示放置操作是不可接受的。
rejectDrop() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
拒绝 Drop。
rejectedExecution(Runnable, ThreadPoolExecutor) - 接口 java.util.concurrent.RejectedExecutionHandler 中的方法
当 execute 不能接受某个任务时，可以由 ThreadPoolExecutor 调用的方法。
rejectedExecution(Runnable, ThreadPoolExecutor) - 类 java.util.concurrent.ThreadPoolExecutor.AbortPolicy 中的方法
总是抛出 RejectedExecutionException。
rejectedExecution(Runnable, ThreadPoolExecutor) - 类 java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy 中的方法
执行调用者线程中的任务 r；如果执行程序已关闭，则会丢弃该任务。
rejectedExecution(Runnable, ThreadPoolExecutor) - 类 java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy 中的方法
获取并忽略下一个任务，否则如果该任务立即可用，执行程序将执行该任务，然后再试图重新执行任务 r；如果执行程序已关闭，则会丢弃任务 r。
rejectedExecution(Runnable, ThreadPoolExecutor) - 类 java.util.concurrent.ThreadPoolExecutor.DiscardPolicy 中的方法
不执行任何操作，在这种情况下将放弃任务 r。
RejectedExecutionException - java.util.concurrent 中的 异常
当无法执行某个任务时,由 Executor 抛出的异常。
RejectedExecutionException() - 异常 java.util.concurrent.RejectedExecutionException 的构造方法
构造不带详细消息的 RejectedExecutionException。
RejectedExecutionException(String) - 异常 java.util.concurrent.RejectedExecutionException 的构造方法
构造带指定详细消息的 RejectedExecutionException。
RejectedExecutionException(String, Throwable) - 异常 java.util.concurrent.RejectedExecutionException 的构造方法
构造带指定详细消息和原因的 RejectedExecutionException。
RejectedExecutionException(Throwable) - 异常 java.util.concurrent.RejectedExecutionException 的构造方法
构造带指定原因的 RejectedExecutionException。
RejectedExecutionHandler - java.util.concurrent 中的 接口
无法由 ThreadPoolExecutor 执行的任务的处理程序。
rejectedSetBCOnce - 类 java.beans.beancontext.BeanContextChildSupport 中的变量
一个标志，指示在试图执行 setBeanContext 操作时，至少已经抛出了一个 PropertyChangeVetoException。
REL - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
Relation - javax.management.relation 中的 接口
此接口必须由任何 MBean 类（期望表示为一种使用 Relation Service 管理的关系）来实现。
RELATION_BASIC_CREATION - 类 javax.management.relation.RelationNotification 中的静态变量
内部关系的创建类型。
RELATION_BASIC_REMOVAL - 类 javax.management.relation.RelationNotification 中的静态变量
从内部关系的 Relation Service 中移除的类型。
RELATION_BASIC_UPDATE - 类 javax.management.relation.RelationNotification 中的静态变量
内部关系的更新类型。
RELATION_MBEAN_CREATION - 类 javax.management.relation.RelationNotification 中的静态变量
添加到 Relation Service 中的关系 MBean 的类型。
RELATION_MBEAN_REMOVAL - 类 javax.management.relation.RelationNotification 中的静态变量
从关系 MBean 的 Relation Service 中移除的类型。
RELATION_MBEAN_UPDATE - 类 javax.management.relation.RelationNotification 中的静态变量
关系 MBean 的更新类型。
RelationException - javax.management.relation 中的 异常
此类是关系管理过程中引发的任何异常的超类。
RelationException() - 异常 javax.management.relation.RelationException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RelationException(String) - 异常 javax.management.relation.RelationException 的构造方法
异常中放置了给定消息的构造方法。
RelationNotFoundException - javax.management.relation 中的 异常
Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
RelationNotFoundException() - 异常 javax.management.relation.RelationNotFoundException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RelationNotFoundException(String) - 异常 javax.management.relation.RelationNotFoundException 的构造方法
异常中放置了给定消息的构造方法。
RelationNotification - javax.management.relation 中的 类
Relation Service（关系服务）中的更改通知。
RelationNotification(String, Object, long, long, String, String, String, ObjectName, List<ObjectName>) - 类 javax.management.relation.RelationNotification 的构造方法
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String, Object, long, long, String, String, String, ObjectName, String, List<ObjectName>, List<ObjectName>) - 类 javax.management.relation.RelationNotification 的构造方法
为关系中的角色更新创建通知。
relations - 类 javax.accessibility.AccessibleRelationSet 中的变量
Vector 中的每个项表示一个 AccessibleRelation。
RelationService - javax.management.relation 中的 类
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。
RelationService(boolean) - 类 javax.management.relation.RelationService 的构造方法
构造方法。
RelationServiceMBean - javax.management.relation 中的 接口
Relation Service 负责创建和删除关系类型和关系，还负责处理一致性和提供查询机制。
RelationServiceNotRegisteredException - javax.management.relation 中的 异常
在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
RelationServiceNotRegisteredException() - 异常 javax.management.relation.RelationServiceNotRegisteredException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RelationServiceNotRegisteredException(String) - 异常 javax.management.relation.RelationServiceNotRegisteredException 的构造方法
异常中放置了给定消息的构造方法。
RelationSupport - javax.management.relation 中的 类
RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。
RelationSupport(String, ObjectName, String, RoleList) - 类 javax.management.relation.RelationSupport 的构造方法
创建一个 RelationSupport 对象。
RelationSupport(String, ObjectName, MBeanServer, String, RoleList) - 类 javax.management.relation.RelationSupport 的构造方法
创建一个 RelationSupport 对象。
RelationSupportMBean - javax.management.relation 中的 接口
RelationSupport 对象由 Relation Service 内部使用，表示任何关系类型的具有无限量角色的简单关系（只有角色，没有属性或方法）。
RelationType - javax.management.relation 中的 接口
该 RelationType 接口必须由期望表示关系类型的任何类来实现。
RelationTypeNotFoundException - javax.management.relation 中的 异常
Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
RelationTypeNotFoundException() - 异常 javax.management.relation.RelationTypeNotFoundException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RelationTypeNotFoundException(String) - 异常 javax.management.relation.RelationTypeNotFoundException 的构造方法
异常中放置了给定消息的构造方法。
RelationTypeSupport - javax.management.relation 中的 类
RelationTypeSupport 对象实现 RelationType 接口。
RelationTypeSupport(String, RoleInfo[]) - 类 javax.management.relation.RelationTypeSupport 的构造方法
所有角色定义在其中动态创建并作为参数传递的构造方法。
RelationTypeSupport(String) - 类 javax.management.relation.RelationTypeSupport 的构造方法
用于子类的构造方法。
RELATIVE - 类 java.awt.GridBagConstraints 中的静态变量
指定此组件为其行或列（gridwidth、gridheight）中的倒数第二个组件，或者让此组件紧跟在以前添加的组件（gridx、gridy）之后。
relative(int) - 接口 java.sql.ResultSet 中的方法
按相对行数（或正或负）移动光标。
relativeCCW(double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
返回一个指示符，指示指定点 (px,py) 相对于从 (x1,y1) 到 (x2,y2) 的线段的位置。
relativeCCW(double, double) - 类 java.awt.geom.Line2D 中的方法
返回一个指示符，指示指定点 (px,py) 相对于此线段的位置。
relativeCCW(Point2D) - 类 java.awt.geom.Line2D 中的方法
返回一个指示符，指示指定 Point2D 相对于此线段的位置。
relativize(URI) - 类 java.net.URI 中的方法
根据此 URI 将给定 URI 相对化。
RELAXNG_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
RELAX NG Namespace URI. 被定义为 "http://relaxng.org/ns/structure/1.0"。
release() - 类 java.nio.channels.FileLock 中的方法
释放此锁定。
release(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以独占模式释放。
release(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以独占模式释放对象。
release() - 类 java.util.concurrent.Semaphore 中的方法
释放一个许可，将其返回给信号量。
release(int) - 类 java.util.concurrent.Semaphore 中的方法
释放给定数目的许可，将其返回到信号量。
release() - 接口 javax.sql.rowset.CachedRowSet 中的方法
释放此 CachedRowSet 对象的当前内容并将 rowSetChanged 事件发送到所有已注册侦听器。
release(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
发布与所提供对象引用关联的资源。
releaseBeanContextResources() - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
子类可重写此方法来提供它们自己的释放行为。
releaseBeanContextResources() - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
从 setBeanContext 中调用，以通知 BeanContextChild 释放从嵌套 BeanContext 中获得的资源。
releaseInputStream() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
releaseMBeanServer(MBeanServer) - 类 javax.management.MBeanServerFactory 中的静态方法
移除对已创建 MBeanServer 的内部 MBeanServerFactory 引用。
releaseOutputStream() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
releaseReply(Object, InputStream) - 类 org.omg.CORBA.portable.Delegate 中的方法
releaseReply 可以由 stub 以可选方式调用，以在解组完成时将应答流释放回 ORB。
releaseSavepoint(Savepoint) - 接口 java.sql.Connection 中的方法
从当前事务中移除指定的 Savepoint 和后续 Savepoint 对象。
releaseService(BeanContextServices, Object, Object) - 接口 java.beans.beancontext.BeanContextServiceProvider 中的方法
由 BeanContextServices 调用，此方法释放一个对特定服务的嵌套 BeanContextChild（或与 BeanContextChild 关联的任意对象）的引用。
releaseService(BeanContextChild, Object, Object) - 接口 java.beans.beancontext.BeanContextServices 中的方法
通过在基础 BeanContextServiceProvider 上调用 releaseService() 释放 BeanContextChild（或与 BeanContextChild 关联的任意对象）对指定服务的引用。
releaseService(BeanContextServices, Object, Object) - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider 中的方法
releaseService(BeanContextChild, Object, Object) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
释放服务。
releaseShared(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以共享模式释放。
releaseShared(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以共享模式释放对象。
releaseWritableTile(int, int) - 类 java.awt.image.BufferedImage 中的方法
放弃写入一个 tile 的权限。
releaseWritableTile(int, int) - 接口 java.awt.image.WritableRenderedImage 中的方法
放弃写入一个 tile 的权力。
reload() - 类 java.util.ServiceLoader 中的方法
清除此加载器的服务者缓存，以重载所有服务者。
reload() - 类 javax.swing.tree.DefaultTreeModel 中的方法
如果已修改此模型依赖的 TreeNode，则调用此方法。
reload(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
如果已修改此模型依赖的 TreeNode，则调用此方法。
REMAINDER - 类 java.awt.GridBagConstraints 中的静态变量
指定此组件是其行或列中的最后一个组件。
remainder(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回其值为 (this % divisor) 的 BigDecimal。
remainder(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (this % divisor) 的 BigDecimal（根据上下文设置进行舍入）。
remainder(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this % val) 的 BigInteger。
remaining() - 类 java.nio.Buffer 中的方法
返回当前位置与限制之间的元素数。
remainingCapacity() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
返回在无阻塞的理想情况下（不存在内存或资源约束）此队列能接受的其他元素数量。
remainingCapacity() - 接口 java.util.concurrent.BlockingQueue 中的方法
返回在无阻塞的理想情况下（不存在内存或资源约束）此队列能接受的附加元素数量；如果没有内部限制，则返回 Integer.MAX_VALUE。
remainingCapacity() - 类 java.util.concurrent.DelayQueue 中的方法
因为 DelayQueue 没有容量限制，所以它总是返回 Integer.MAX_VALUE。
remainingCapacity() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回理想情况下（没有内存和资源约束）此双端队列可不受阻塞地接受的额外元素数。
remainingCapacity() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
返回理想情况下（没有内存和资源约束）此队列可接受并且不会被阻塞的附加元素数量。
remainingCapacity() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
总是返回 Integer.MAX_VALUE，因为 PriorityBlockingQueue 没有容量限制。
remainingCapacity() - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 0。
remainingName - 异常 javax.naming.NamingException 中的变量
包含尚未解析的剩余名称。
remainingName - 类 javax.naming.spi.ResolveResult 中的变量
该字段包含要解析的剩余名称。
remainingNewName - 异常 javax.naming.CannotProceedException 中的变量
包含 Context.rename() 第二个 "name" 参数的剩余未解析部分。
remapInstrument(Instrument, Instrument) - 接口 javax.sound.midi.Synthesizer 中的方法
重新映射一个乐器。
RemarshalException - org.omg.CORBA.portable 中的 异常
此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
RemarshalException() - 异常 org.omg.CORBA.portable.RemarshalException 的构造方法
构造一个 RemarshalException。
Remote - java.rmi 中的 接口
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。
RemoteCall - java.rmi.server 中的 接口
已过时。 无替代版本。
remoteEquals(RemoteRef) - 接口 java.rmi.server.RemoteRef 中的方法
比较两个远程对象是否相等。
RemoteException - java.rmi 中的 异常
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
RemoteException() - 异常 java.rmi.RemoteException 的构造方法
构造一个 RemoteException。
RemoteException(String) - 异常 java.rmi.RemoteException 的构造方法
构造带指定详细消息的 RemoteException。
RemoteException(String, Throwable) - 异常 java.rmi.RemoteException 的构造方法
构造带指定详细消息和原因的 RemoteException。
remoteHashCode() - 接口 java.rmi.server.RemoteRef 中的方法
返回远程对象的哈希码。
RemoteObject - java.rmi.server 中的 类
该 RemoteObject 类实现远程对象的 java.lang.Object 行为。
RemoteObject() - 类 java.rmi.server.RemoteObject 的构造方法
创建远程对象。
RemoteObject(RemoteRef) - 类 java.rmi.server.RemoteObject 的构造方法
创建一个用指定远程引用初始化的远程对象。
RemoteObjectInvocationHandler - java.rmi.server 中的 类
与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。
RemoteObjectInvocationHandler(RemoteRef) - 类 java.rmi.server.RemoteObjectInvocationHandler 的构造方法
创建一个用指定 RemoteRef 构造的新 RemoteObjectInvocationHandler。
RemoteRef - java.rmi.server 中的 接口
RemoteRef 表示远程对象的句柄。
RemoteServer - java.rmi.server 中的 类
该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
RemoteServer() - 类 java.rmi.server.RemoteServer 的构造方法
构造一个 RemoteServer。
RemoteServer(RemoteRef) - 类 java.rmi.server.RemoteServer 的构造方法
构造带指定引用类型的 RemoteServer。
RemoteStub - java.rmi.server 中的 类
该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
RemoteStub() - 类 java.rmi.server.RemoteStub 的构造方法
构造一个 RemoteStub。
RemoteStub(RemoteRef) - 类 java.rmi.server.RemoteStub 的构造方法
构造带指定远程引用的 RemoteStub。
remoteToString() - 接口 java.rmi.server.RemoteRef 中的方法
返回表示此远程对象的引用的 String。
REMOVAL - 接口 org.w3c.dom.events.MutationEvent 中的静态变量
只移除 Attr。
remove(EventListener) - 类 java.awt.AWTEventMulticaster 中的方法
从此多路广播器中移除一个侦听器。
remove(ComponentListener, ComponentListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从组件侦听器 l 中移除旧的组件侦听器，并返回得到的多路广播侦听器。
remove(ContainerListener, ContainerListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从容器侦听器 l 中移除旧的容器侦听器，并返回得到的多路广播侦听器。
remove(FocusListener, FocusListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从焦点侦听器 l 中移除旧的焦点侦听器，并返回得到的多路广播侦听器。
remove(KeyListener, KeyListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从键侦听器 l 中移除旧的键侦听器，并返回得到的多路广播侦听器。
remove(MouseListener, MouseListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从鼠标侦听器 l 中移除旧的鼠标侦听器，并返回得到的多路广播侦听器。
remove(MouseMotionListener, MouseMotionListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从鼠标移动侦听器 l 中移除旧的鼠标移动侦听器，并返回得到的多路广播侦听器。
remove(WindowListener, WindowListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从窗口侦听器 l 中移除旧的窗口侦听器，并返回得到的多路广播侦听器。
remove(WindowStateListener, WindowStateListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从窗口状态侦听器 l 中移除旧的窗口状态侦听器，并返回得到的多路广播侦听器。
remove(WindowFocusListener, WindowFocusListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从窗口焦点侦听器 l 中移除旧的窗口焦点侦听器，并返回得到的多路广播侦听器。
remove(ActionListener, ActionListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从操作侦听器 l 中移除旧的操作侦听器，并返回得到的多路广播侦听器。
remove(ItemListener, ItemListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从项侦听器 l 中移除旧的项侦听器，并返回得到的多路广播侦听器。
remove(AdjustmentListener, AdjustmentListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从调整侦听器 l 中移除旧的调整侦听器，并返回得到的多路广播侦听器。
remove(TextListener, TextListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
remove(InputMethodListener, InputMethodListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从输入方法侦听器 l 中移除旧的输入方法侦听器，并返回得到的多路广播侦听器。
remove(HierarchyListener, HierarchyListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从层次结构侦听器 l 中移除旧的层次结构侦听器，并返回得到的多路广播侦听器。
remove(HierarchyBoundsListener, HierarchyBoundsListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从层次结构边界侦听器 l 中移除旧的层次结构边界侦听器，并返回得到的多路广播侦听器。
remove(MouseWheelListener, MouseWheelListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从鼠标滚轮侦听器 l 中移除旧的鼠标滚轮侦听器，并返回得到的多路广播侦听器。
remove(String) - 类 java.awt.Choice 中的方法
移除 Choice 菜单中第一个出现的 item。
remove(int) - 类 java.awt.Choice 中的方法
从选择菜单的指定位置上移除一个项。
remove(MenuComponent) - 类 java.awt.Component 中的方法
从组件移除指定的弹出菜单。
remove(int) - 类 java.awt.Container 中的方法
从此容器中移除 index 指定的组件。
remove(Component) - 类 java.awt.Container 中的方法
从此容器中移除指定组件。
remove(MenuComponent) - 类 java.awt.Frame 中的方法
从此窗体移除指定的菜单栏。
remove(String) - 类 java.awt.List 中的方法
从列表中移除项的第一次出现。
remove(int) - 类 java.awt.List 中的方法
从此滚动列表中移除指定位置处的项。
remove(int) - 类 java.awt.Menu 中的方法
从此菜单移除指定索引处的菜单项。
remove(MenuComponent) - 类 java.awt.Menu 中的方法
从此菜单移除指定的菜单项。
remove(int) - 类 java.awt.MenuBar 中的方法
从此菜单栏移除指定索引处的菜单。
remove(MenuComponent) - 类 java.awt.MenuBar 中的方法
从此菜单栏移除指定的菜单组件。
remove(MenuComponent) - 接口 java.awt.MenuContainer 中的方法
remove(Object) - 类 java.awt.RenderingHints 中的方法
从此 RenderingHints 对象中移除键和它所对应的值。
remove(TrayIcon) - 类 java.awt.SystemTray 中的方法
从 SystemTray 中移除指定的 TrayIcon。
remove() - 类 java.beans.beancontext.BeanContextSupport.BCSIterator 中的方法
remove(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
从此 BeanContext 中移除一个子对象。
remove(Object, boolean) - 类 java.beans.beancontext.BeanContextSupport 中的方法
当由意外的 setBeanContext 或 remove() 调用导致移除时使用的内部移除方法。
remove(Object) - 类 java.beans.Encoder 中的方法
移除此实例的条目，返回旧条目。
remove(long) - 类 java.lang.ref.ReferenceQueue 中的方法
移除此队列中的下一个引用对象，阻塞到有一个对象变得可用或者给定的超时期满了为止。
remove() - 类 java.lang.ref.ReferenceQueue 中的方法
移除此队列中的下一个引用对象，阻塞到某个对象变得可用为止。
remove() - 类 java.lang.ThreadLocal 中的方法
移除此线程局部变量当前线程的值。
remove(URI, HttpCookie) - 接口 java.net.CookieStore 中的方法
从存储区中移除 cookie。
remove(Object) - 类 java.security.Provider 中的方法
移除 key 属性（及其相应的 value）。
remove(Object) - 类 java.util.AbstractCollection 中的方法
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。
remove(int) - 类 java.util.AbstractList 中的方法
移除列表中指定位置的元素（可选操作）。
remove(Object) - 类 java.util.AbstractMap 中的方法
如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。
remove() - 类 java.util.AbstractQueue 中的方法
获取并移除此队列的头。
remove(int) - 类 java.util.AbstractSequentialList 中的方法
移除此列表中指定位置上的元素（可选操作）。
remove() - 类 java.util.ArrayDeque 中的方法
获取并移除此双端队列所表示的队列的头。
remove(Object) - 类 java.util.ArrayDeque 中的方法
从此双端队列中移除指定元素的单个实例。
remove(int) - 类 java.util.ArrayList 中的方法
移除此列表中指定位置上的元素。
remove(Object) - 类 java.util.ArrayList 中的方法
移除此列表中首次出现的指定元素（如果存在）。
remove(Object) - 接口 java.util.Collection 中的方法
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。
remove(Object) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
从此队列中移除指定元素的单个实例（如果存在）。
remove() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素）。
remove(Object) - 接口 java.util.concurrent.BlockingDeque 中的方法
从此双端队列移除第一次出现的指定元素。
remove(Object) - 接口 java.util.concurrent.BlockingQueue 中的方法
从此队列中移除指定元素的单个实例（如果存在）。
remove(Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
从此映射中移除键（及其相应的值）。
remove(Object, Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
只有目前将键的条目映射到给定值时，才移除该键的条目。
remove(Object) - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
从队列中移除指定元素的单个实例（如果存在）。
remove(Object, Object) - 接口 java.util.concurrent.ConcurrentMap 中的方法
只有目前将键的条目映射到给定值时，才移除该键的条目。
remove(Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
从此映射中移除指定键的映射关系（如果存在）。
remove(Object, Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
只有目前将键的条目映射到给定值时，才移除该键的条目。
remove(Object) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
如果此 set 中存在指定的元素，则将其移除。
remove(int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
移除此列表指定位置上的元素。
remove(Object) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
从此列表移除第一次出现的指定元素（如果存在）。
remove(Object) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果指定元素存在于此 set 中，则将其移除。
remove(Object) - 类 java.util.concurrent.DelayQueue 中的方法
从此队列中移除指定元素的单个实例（如果存在），无论它是否到期。
remove() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
获取并移除此双端队列表示的队列的头部。
remove(Object) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
从此双端队列移除第一次出现的指定元素。
remove(Object) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
从此队列移除指定元素的单个实例（如果存在）。
remove(Object) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
从队列中移除指定元素的单个实例（如果存在）。
remove(Runnable) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
remove(Object) - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 false。
remove(Runnable) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
从执行程序的内部队列中移除此任务（如果存在），从而如果尚未开始，则其不再运行。
remove() - 接口 java.util.Deque 中的方法
获取并移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）。
remove(Object) - 接口 java.util.Deque 中的方法
从此双端队列中移除第一次出现的指定元素。
remove(Object) - 类 java.util.Dictionary 中的方法
从此 dictionary 中移除 key （及其相应的 value）。
remove(Object) - 类 java.util.EnumMap 中的方法
从此映射中移除该键的映射关系（如果存在）。
remove(Object) - 类 java.util.HashMap 中的方法
从此映射中移除指定键的映射关系（如果存在）。
remove(Object) - 类 java.util.HashSet 中的方法
如果指定元素存在于此 set 中，则将其移除。
remove(Object) - 类 java.util.Hashtable 中的方法
从哈希表中移除该键及其相应的值。
remove(Object) - 类 java.util.IdentityHashMap 中的方法
移除映射中此键的映射关系（如果存在的话）。
remove() - 接口 java.util.Iterator 中的方法
从迭代器指向的 collection 中移除迭代器返回的最后一个元素（可选操作）。
remove(Object) - 类 java.util.jar.Attributes 中的方法
从此 Map 中移除具有指定名称（键）的属性。
remove(Object) - 类 java.util.LinkedList 中的方法
从此列表中移除首次出现的指定元素（如果存在）。
remove(int) - 类 java.util.LinkedList 中的方法
移除此列表中指定位置处的元素。
remove() - 类 java.util.LinkedList 中的方法
获取并移除此列表的头（第一个元素）。
remove(Object) - 接口 java.util.List 中的方法
从此列表中移除第一次出现的指定元素（如果存在）（可选操作）。
remove(int) - 接口 java.util.List 中的方法
移除列表中指定位置的元素（可选操作）。
remove() - 接口 java.util.ListIterator 中的方法
从列表中移除由 next 或 previous 返回的最后一个元素（可选操作）。
remove(Object) - 接口 java.util.Map 中的方法
如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。
remove(String) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.remove(String) 中的规范实现 remove(String) 方法。
remove(String) - 类 java.util.prefs.Preferences 中的方法
移除与此首选项节点中与指定键相关联的值（如果有）。
remove(Object) - 类 java.util.PriorityQueue 中的方法
从此队列中移除指定元素的单个实例（如果存在）。
remove() - 接口 java.util.Queue 中的方法
获取并移除此队列的头。
remove() - 类 java.util.Scanner 中的方法
Iterator 的这种实现不支持移除操作。
remove(Object) - 接口 java.util.Set 中的方法
如果 set 中存在指定的元素，则将其移除（可选操作）。
remove(Object) - 类 java.util.TreeMap 中的方法
如果此 TreeMap 中存在该键的映射关系，则将其删除。
remove(Object) - 类 java.util.TreeSet 中的方法
将指定的元素从 set 中移除（如果该元素存在于此 set 中）。
remove(Object) - 类 java.util.Vector 中的方法
移除此向量中指定元素的第一个匹配项，如果向量不包含该元素，则元素保持不变。
remove(int) - 类 java.util.Vector 中的方法
移除此向量中指定位置的元素。
remove(Object) - 类 java.util.WeakHashMap 中的方法
从此弱哈希映射中移除键的映射关系（如果存在）。
remove(AccessibleRelation) - 类 javax.accessibility.AccessibleRelationSet 中的方法
从当前关系集中移除一个关系。
remove(AccessibleState) - 类 javax.accessibility.AccessibleStateSet 中的方法
从当前状态集中移除一个状态。
remove(String) - 类 javax.activation.MimeTypeParameterList 中的方法
移除与给定名称关联的所有值。
remove(Object[]) - 接口 javax.management.openmbean.TabularData 中的方法
从此 TabularData 实例中移除其索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。
remove(Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
此方法仅调用 remove((Object[]) key)。
remove(Object[]) - 类 javax.management.openmbean.TabularDataSupport 中的方法
从此 TabularData 实例中移除索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。
remove(int) - 类 javax.naming.CompositeName 中的方法
从此复合名称中删除一个组件。
remove(int) - 类 javax.naming.CompoundName 中的方法
从此组合名称中删除一个组件。
remove(Object) - 接口 javax.naming.directory.Attribute 中的方法
从属性中移除指定值。
remove(int) - 接口 javax.naming.directory.Attribute 中的方法
从属性值的有序列表中移除属性值。
remove(String) - 接口 javax.naming.directory.Attributes 中的方法
从属性集中移除属性 id 为 'attrID' 的属性。
remove(Object) - 类 javax.naming.directory.BasicAttribute 中的方法
从此属性中移除指定值。
remove(int) - 类 javax.naming.directory.BasicAttribute 中的方法
remove(String) - 类 javax.naming.directory.BasicAttributes 中的方法
remove(int) - 类 javax.naming.ldap.LdapName 中的方法
从此 LDAP 名称中移除一个组件。
remove(int) - 接口 javax.naming.Name 中的方法
从此名称中移除一个组件。
remove(int) - 类 javax.naming.Reference 中的方法
从地址列表中删除索引 posn 处的地址。
remove(Class<?>) - 接口 javax.print.attribute.AttributeSet 中的方法
从此属性集移除此类别的任何属性（如果存在）。
remove(Attribute) - 接口 javax.print.attribute.AttributeSet 中的方法
从此属性集移除指定的属性（如果存在）。
remove(Class<?>) - 类 javax.print.attribute.HashAttributeSet 中的方法
从此属性集移除此类别的任何属性（如果存在）。
remove(Attribute) - 类 javax.print.attribute.HashAttributeSet 中的方法
从此属性集移除指定的属性（如果存在）。
remove(Object) - 接口 javax.script.Bindings 中的方法
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。
remove(Object) - 类 javax.script.SimpleBindings 中的方法
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。
remove(MidiEvent) - 类 javax.sound.midi.Track 中的方法
从音轨中移除指定的事件。
remove(Object) - 类 javax.swing.ActionMap 中的方法
从此 ActionMap 中移除 key 的绑定。
remove(AbstractButton) - 类 javax.swing.ButtonGroup 中的方法
从组中移除按钮。
remove(KeyStroke) - 类 javax.swing.ComponentInputMap 中的方法
从此对象中移除 key 的绑定。
remove(int) - 类 javax.swing.DefaultListModel 中的方法
移除此列表中指定位置处的元素。
REMOVE - 类 javax.swing.event.DocumentEvent.EventType 中的静态变量
移除类型。
remove(Class<T>, T) - 类 javax.swing.event.EventListenerList 中的方法
将侦听器作为指定类型的侦听器进行移除。
remove(KeyStroke) - 类 javax.swing.InputMap 中的方法
从此 InputMap 中移除 key 的绑定。
remove(Component) - 类 javax.swing.JApplet 中的方法
从容器中移除指定的组件。
remove(int) - 类 javax.swing.JDesktopPane 中的方法
从此窗格中移除已索引的组件。
remove(Component) - 类 javax.swing.JDialog 中的方法
从该容器中移除指定组件。
remove(Component) - 类 javax.swing.JFrame 中的方法
从该容器中移除指定组件。
remove(Component) - 类 javax.swing.JInternalFrame 中的方法
从此容器中移除指定组件。
remove(int) - 类 javax.swing.JLayeredPane 中的方法
从此窗格中移除已索引的组件。
remove(JMenuItem) - 类 javax.swing.JMenu 中的方法
从此菜单移除指定的菜单项。
remove(int) - 类 javax.swing.JMenu 中的方法
从此菜单移除指定索引处的菜单项。
remove(Component) - 类 javax.swing.JMenu 中的方法
从此菜单移除组件 c。
remove(int) - 类 javax.swing.JPopupMenu 中的方法
从此弹出菜单移除指定索引处的组件。
remove(Component) - 类 javax.swing.JSplitPane 中的方法
移除窗格中的子组件 component。
remove(int) - 类 javax.swing.JSplitPane 中的方法
移除指定索引处的 Component。
remove(Component) - 类 javax.swing.JTabbedPane 中的方法
从 JTabbedPane 中移除指定 Component。
remove(int) - 类 javax.swing.JTabbedPane 中的方法
移除对应于指定索引的选项卡和组件。
remove(Component) - 类 javax.swing.JViewport 中的方法
移除 Viewport 的一个轻量子对象。
remove(Component) - 类 javax.swing.JWindow 中的方法
从该容器中移除指定组件。
remove(int, int) - 接口 javax.swing.text.AbstractDocument.Content 中的方法
移除该序列的某一部分。
remove(int, int) - 类 javax.swing.text.AbstractDocument 中的方法
从文档中移除某些内容。
remove(int, int, AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
移除内容。
remove(int, int) - 接口 javax.swing.text.Document 中的方法
移除文档的部分内容。
remove(int, int) - 类 javax.swing.text.DocumentFilter.FilterBypass 中的方法
移除指定的文本区域，绕过 DocumentFilter。
remove(DocumentFilter.FilterBypass, int, int) - 类 javax.swing.text.DocumentFilter 中的方法
移除指定 Document 中的指定区域之前调用。
remove(int, int) - 类 javax.swing.text.GapContent 中的方法
移除部分内容。
remove(int, int) - 类 javax.swing.text.StringContent 中的方法
移除部分内容，其中 where ＋ nitems 必须 < length()。
remove(int) - 类 javax.swing.text.View 中的方法
移除给定位置处的一个子级。
remove(int) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
从此节点的子节点中移除指定索引处的子节点，并将该节点的父节点设置为 null。
remove(MutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
通过向其提供一个 null 父节点，从此节点的子节点数组移除 aChild。
remove(int) - 接口 javax.swing.tree.MutableTreeNode 中的方法
从接收者移除 index 位置的子节点。
remove(MutableTreeNode) - 接口 javax.swing.tree.MutableTreeNode 中的方法
从接收者移除 node。
remove() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
remove(int) - 类 org.omg.CORBA.ContextList 中的方法
移除给定索引处的 String 对象。
remove(int) - 类 org.omg.CORBA.ExceptionList 中的方法
移除给定索引处的 TypeCode 对象。
remove(int) - 类 org.omg.CORBA.NVList 中的方法
移除位于给定索引处的 NamedValue 对象。
REMOVE_ATTRIBUTE - 接口 javax.naming.directory.DirContext 中的静态变量
此常量指定从属性中删除指定的属性值。
removeAccessibleSelection(int) - 类 java.awt.List.AccessibleAWTList 中的方法
从对象选择中移除对象中的指定选项。
removeAccessibleSelection(int) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
从对象的选择中移除该对象的指定子对象。
removeAccessibleSelection(int) - 接口 javax.accessibility.AccessibleSelection 中的方法
从对象的选项中移除该对象的指定子对象。
removeAccessibleSelection(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
从对象的选择中移除对象的指定子对象。
removeAccessibleSelection(int) - 类 javax.swing.JList.AccessibleJList 中的方法
从对象选择中移除对象中的指定选项。
removeAccessibleSelection(int) - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
从选择中移除第 n 个项。
removeAccessibleSelection(int) - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
从对象选择中移除对象中的第 n 个选项。
removeAccessibleSelection(int) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
removeAccessibleSelection(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
从对象的选择中移除该对象的指定子对象。
removeAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
将该对象中指定选择的项从该对象的选择中移除。
removeAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree 中的方法
将对象中指定选择项从对象的选择中移除。
removeActionListener(ActionListener) - 类 java.awt.Button 中的方法
移除指定的动作侦听器，以便它不再接收发自此按钮的动作事件。
removeActionListener(ActionListener) - 类 java.awt.List 中的方法
移除指定的动作侦听器，以便不再从此列表接收动作事件。
removeActionListener(ActionListener) - 类 java.awt.MenuItem 中的方法
移除指定的动作侦听器，使其不再从此菜单项中接收动作事件。
removeActionListener(ActionListener) - 类 java.awt.TextField 中的方法
移除指定的操作侦听器，不再从此文本字段接收操作事件。
removeActionListener(ActionListener) - 类 java.awt.TrayIcon 中的方法
移除指定的动作侦听器。
removeActionListener(ActionListener) - 类 javax.swing.AbstractButton 中的方法
从按钮中移除一个 ActionListener。
removeActionListener(ActionListener) - 接口 javax.swing.ButtonModel 中的方法
从模型中移除一个 ActionListener。
removeActionListener(ActionListener) - 接口 javax.swing.ComboBoxEditor 中的方法
移除一个 ActionListener
removeActionListener(ActionListener) - 类 javax.swing.DefaultButtonModel 中的方法
从模型中移除一个 ActionListener。
removeActionListener(ActionListener) - 类 javax.swing.JComboBox 中的方法
移除 ActionListener。
removeActionListener(ActionListener) - 类 javax.swing.JFileChooser 中的方法
从文件选择器中移除一个 ActionListener。
removeActionListener(ActionListener) - 类 javax.swing.JTextField 中的方法
移除指定的操作侦听器，以便不再从此文本字段接收操作事件。
removeActionListener(ActionListener) - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
removeActionListener(ActionListener) - 类 javax.swing.Timer 中的方法
从 Timer 移除指定的动作侦听器。
removeAdjustmentListener(AdjustmentListener) - 接口 java.awt.Adjustable 中的方法
移除一个调整侦听器。
removeAdjustmentListener(AdjustmentListener) - 类 java.awt.Scrollbar 中的方法
移除指定的调整侦听器，不再接收发自此滚动条的 AdjustmentEvent 实例。
removeAdjustmentListener(AdjustmentListener) - 类 java.awt.ScrollPaneAdjustable 中的方法
移除指定的调整侦听器，不再接收发自此 ScrollPaneAdjustable 的调整事件。
removeAdjustmentListener(AdjustmentListener) - 类 javax.swing.JScrollBar 中的方法
移除一个 AdjustmentEvent 侦听器。
removeAll() - 类 java.awt.Choice 中的方法
从选择菜单中移除所有的项。
removeAll() - 类 java.awt.Container 中的方法
从此容器中移除所有组件。
removeAll() - 类 java.awt.List 中的方法
从此列表中移除所有项。
removeAll() - 类 java.awt.Menu 中的方法
从此菜单移除所有项。
removeAll(Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
移除所有指定 Children（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
removeAll() - 接口 java.net.CookieStore 中的方法
移除此 cookie 存储区中的所有 cookie。
removeAll(Collection<?>) - 类 java.util.AbstractCollection 中的方法
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。
removeAll(Collection<?>) - 类 java.util.AbstractSet 中的方法
从此 set 中移除包含在指定 collection 中的所有元素（可选操作）。
removeAll(Collection<?>) - 接口 java.util.Collection 中的方法
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。
removeAll(Collection<?>) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
从此 set 中移除包含在指定 collection 中的所有元素。
removeAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
从此列表移除所有包含在指定 collection 中的元素。
removeAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
移除此 set 中包含在指定 collection 中的所有元素。
removeAll(Collection<?>) - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 false。
removeAll(Collection<?>) - 接口 java.util.List 中的方法
从列表中移除指定 collection 中包含的其所有元素（可选操作）。
removeAll(Collection<?>) - 接口 java.util.Set 中的方法
移除 set 中那些包含在指定 collection 中的元素（可选操作）。
removeAll(Collection<?>) - 类 java.util.Vector 中的方法
从此向量中移除包含在指定 Collection 中的所有元素。
removeAll() - 类 javax.swing.JDesktopPane 中的方法
从此容器中移除所有组件。
removeAll() - 类 javax.swing.JLayeredPane 中的方法
从此容器中移除所有组件。
removeAll() - 类 javax.swing.JMenu 中的方法
从此菜单移除所有菜单项。
removeAll() - 类 javax.swing.JSplitPane 中的方法
从分隔窗格中移除所有子组件。
removeAll() - 类 javax.swing.JTabbedPane 中的方法
从 tabbedpane 中移除所有选项卡及其相应组件。
removeAll() - 类 javax.swing.text.View 中的方法
移除所有子级。
removeAllAttachments() - 类 javax.xml.soap.SOAPMessage 中的方法
移除所有已经添加到此 SOAPMessage 对象的 AttachmentPart 对象。
removeAllChildren() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
通过将其父节点设置为 null，移除此节点的所有子节点。
removeAllElements() - 类 java.util.Vector 中的方法
从此向量中移除全部组件，并将其大小设置为零。
removeAllElements() - 类 javax.swing.DefaultComboBoxModel 中的方法
清空列表。
removeAllElements() - 类 javax.swing.DefaultListModel 中的方法
从此列表中移除所有组件，并将它们的大小设置为零。
removeAllFaultSubcodes() - 接口 javax.xml.soap.SOAPFault 中的方法
移除此 SOAPFault 可能包含的任何 Subcode。
removeAllHeaders() - 类 javax.xml.soap.MimeHeaders 中的方法
从此 MimeHeaders 对象中移除所有头条目。
removeAllHighlights() - 类 javax.swing.text.DefaultHighlighter 中的方法
移除所有的高亮显示。
removeAllHighlights() - 接口 javax.swing.text.Highlighter 中的方法
移除此轮廓色负责的所有高亮显示。
removeAllIIOReadProgressListeners() - 类 javax.imageio.ImageReader 中的方法
移除所有当前已注册的 IIOReadProgressListener 对象。
removeAllIIOReadUpdateListeners() - 类 javax.imageio.ImageReader 中的方法
移除所有当前已注册的 IIOReadUpdateListener 对象。
removeAllIIOReadWarningListeners() - 类 javax.imageio.ImageReader 中的方法
移除所有当前已注册的 IIOReadWarningListener 对象。
removeAllIIOWriteProgressListeners() - 类 javax.imageio.ImageWriter 中的方法
移除所有当前已注册的 IIOWriteProgressListener 对象。
removeAllIIOWriteWarningListeners() - 类 javax.imageio.ImageWriter 中的方法
移除所有当前已注册的 IIOWriteWarningListener 对象。
removeAllItems() - 类 javax.swing.JComboBox 中的方法
从项列表中移除所有项。
removeAllMimeHeaders() - 类 javax.xml.soap.AttachmentPart 中的方法
移除所有 MIME 头条目。
removeAllMimeHeaders() - 类 javax.xml.soap.SOAPPart 中的方法
移除此 SOAPEnvelope 对象的所有 MimeHeader 对象。
removeAllNotifications() - 类 javax.management.timer.Timer 中的方法
从通知列表中删除所有计时器通知并重置用来更新计时器通知标识符的计数器。
removeAllNotifications() - 接口 javax.management.timer.TimerMBean 中的方法
从通知列表中删除所有的计时器通知并重置用来更新计时器通知标识符的计数器。
removeAncestorListener(AncestorListener) - 类 javax.swing.JComponent 中的方法
注销 listener，使其不再接收 AncestorEvent。
removeAttachments(MimeHeaders) - 类 javax.xml.soap.SOAPMessage 中的方法
移除所有头条目匹配指定头的 AttachmentPart 对象。
removeAttribute(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
从以前定义的元素中移除属性。
removeAttribute(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
removeAttribute(String, int) - 接口 javax.script.ScriptContext 中的方法
移除给定范围中的某一属性。
removeAttribute(String, int) - 类 javax.script.SimpleScriptContext 中的方法
移除给定范围中的某一属性。
removeAttribute(Object) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
从该集合中移除一个属性。
removeAttribute(AttributeSet, Object) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
从属性集中移除某个属性。
removeAttribute(AttributeSet, Object) - 类 javax.swing.text.html.StyleSheet 中的方法
从集合中移除属性。
removeAttribute(Object) - 接口 javax.swing.text.MutableAttributeSet 中的方法
移除具有给定 name 的属性。
removeAttribute(Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
从列表中移除属性。
removeAttribute(Object) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
从集合中移除属性。
removeAttribute(AttributeSet, Object) - 类 javax.swing.text.StyleContext 中的方法
从集合中移除一个属性。
removeAttribute(Name) - 接口 javax.xml.soap.SOAPElement 中的方法
移除带有指定名称的属性。
removeAttribute(QName) - 接口 javax.xml.soap.SOAPElement 中的方法
移除带有指定 qname 的属性。
removeAttribute(String) - 接口 org.w3c.dom.Element 中的方法
通过名称移除一个属性。
removeAttribute(int) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
removeAttribute(String) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 从列表移除属性。
removeAttribute(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
从列表移除属性。
removeAttributeChangeNotificationListener(NotificationListener, String) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
removeAttributeChangeNotificationListener(NotificationListener, String) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
removeAttributeNode(Attr) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
removeAttributeNode(Attr) - 接口 org.w3c.dom.Element 中的方法
移除指定的属性节点。
removeAttributeNS(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 removeAttribute(localName)。
removeAttributeNS(String, String) - 接口 org.w3c.dom.Element 中的方法
通过本地名称和名称空间 URI 移除属性值。
removeAttributes(Enumeration<?>) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
移除该元素的属性集合。
removeAttributes(AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
移除该元素的属性集合。
removeAttributes(AttributeSet, Enumeration<?>) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
移除元素的一组属性。
removeAttributes(AttributeSet, AttributeSet) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
移除元素的一组属性。
removeAttributes(AttributeSet, Enumeration<?>) - 类 javax.swing.text.html.StyleSheet 中的方法
移除元素的属性集。
removeAttributes(AttributeSet, AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
移除属性集。
removeAttributes(Enumeration<?>) - 接口 javax.swing.text.MutableAttributeSet 中的方法
移除具有给定 name 的属性集。
removeAttributes(AttributeSet) - 接口 javax.swing.text.MutableAttributeSet 中的方法
移除具有给定 name 的属性集。
removeAttributes(Enumeration<?>) - 类 javax.swing.text.SimpleAttributeSet 中的方法
从列表中移除属性集。
removeAttributes(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 中的方法
从列表中移除属性集。
removeAttributes(Enumeration<?>) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
移除元素的属性集。
removeAttributes(AttributeSet) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
移除元素的属性集。
removeAttributes(AttributeSet, Enumeration<?>) - 类 javax.swing.text.StyleContext 中的方法
移除元素的一个属性集。
removeAttributes(AttributeSet, AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
移除元素的属性集。
removeAuxiliaryLookAndFeel(LookAndFeel) - 类 javax.swing.UIManager 中的静态方法
从辅助外观列表移除一个 LookAndFeel。
removeAWTEventListener(AWTEventListener) - 类 java.awt.Toolkit 中的方法
从正接收的指派 AWTEvent 中移除一个 AWTEventListener。
removeBeanContextMembershipListener(BeanContextMembershipListener) - 接口 java.beans.beancontext.BeanContext 中的方法
移除指定的 BeanContextMembershipListener，以便在添加或移除子 Component 时不再接收 BeanContextMembershipEvent。
removeBeanContextMembershipListener(BeanContextMembershipListener) - 类 java.beans.beancontext.BeanContextSupport 中的方法
移除一个 BeanContextMembershipListener。
removeBeanContextServicesListener(BeanContextServicesListener) - 接口 java.beans.beancontext.BeanContextServices 中的方法
从此 BeanContext 中移除一个 BeanContextServicesListener
removeBeanContextServicesListener(BeanContextServicesListener) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
移除一个 BeanContextServicesListener。
removeBindings() - 接口 javax.swing.text.Keymap 中的方法
从 keymap 移除所有绑定。
removeCaretListener(CaretListener) - 类 javax.swing.text.JTextComponent 中的方法
移除插入符侦听器。
removeCellEditorListener(CellEditorListener) - 类 javax.swing.AbstractCellEditor 中的方法
从侦听器列表中移除一个 CellEditorListener。
removeCellEditorListener(CellEditorListener) - 接口 javax.swing.CellEditor 中的方法
从被通知的列表中移除一个侦听器
removeCellEditorListener(CellEditorListener) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
移除以前添加的 CellEditorListener。
removeCertificate(Certificate) - 类 java.security.Identity 中的方法
已过时。 从此 Identity 中移除证书。
removeChangeListener(ChangeListener) - 类 javax.swing.AbstractButton 中的方法
从按钮中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.AbstractSpinnerModel 中的方法
从模型的侦听器列表中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 接口 javax.swing.BoundedRangeModel 中的方法
从模型的侦听器列表中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 接口 javax.swing.ButtonModel 中的方法
从模型中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 接口 javax.swing.colorchooser.ColorSelectionModel 中的方法
从模型中移除作为更改侦听器的 listener。
removeChangeListener(ChangeListener) - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
从模型中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.DefaultButtonModel 中的方法
从模型中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.DefaultSingleSelectionModel 中的方法
从按钮中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.JProgressBar 中的方法
从进度条移除 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.JSlider 中的方法
从滑块中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.JSpinner 中的方法
从此 spinne 中移除 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.JTabbedPane 中的方法
从此选项卡窗格中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.JViewport 中的方法
从每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表中移除 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.MenuSelectionManager 中的方法
从按钮中移除 ChangeListener。
removeChangeListener(ChangeListener) - 接口 javax.swing.SingleSelectionModel 中的方法
从模型中移除作为更改侦听器的 listener。
removeChangeListener(ChangeListener) - 接口 javax.swing.SpinnerModel 中的方法
从该模型的侦听器列表移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 接口 javax.swing.text.Caret 中的方法
移除跟踪插入符位置更改的侦听器。
removeChangeListener(ChangeListener) - 类 javax.swing.text.DefaultCaret 中的方法
移除跟踪位置更改的侦听器。
removeChangeListener(ChangeListener) - 接口 javax.swing.text.Style 中的方法
移除跟踪属性更改的侦听器。
removeChangeListener(ChangeListener) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
移除更改侦听器。
removeChangeListener(ChangeListener) - 类 javax.swing.text.StyleContext 中的方法
移除一个跟踪正被添加或移除样式的侦听器。
removeChild(Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
removeChild(Node) - 接口 org.w3c.dom.Node 中的方法
从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
removeChoosableFileFilter(FileFilter) - 类 javax.swing.JFileChooser 中的方法
从用户可选择的文件过滤器列表中移除一个过滤器。
removeChooserPanel(AbstractColorChooserPanel) - 类 javax.swing.JColorChooser 中的方法
移除指定的 Color Panel。
removeColumn(TableColumn) - 类 javax.swing.JTable 中的方法
从此 JTable 的列数组中移除 aColumn。
removeColumn(TableColumn) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
从 tableColumns 数组删除 column。
removeColumn(TableColumn) - 接口 javax.swing.table.TableColumnModel 中的方法
从 tableColumns 数组中删除 TableColumn column。
removeColumnModelListener(TableColumnModelListener) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
移除表列模型事件的侦听器。
removeColumnModelListener(TableColumnModelListener) - 接口 javax.swing.table.TableColumnModel 中的方法
移除表列模型事件的侦听器。
removeColumnSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
取消选中从 index0 到 index1 之间（包含两端）的列。
removeComponentListener(ComponentListener) - 类 java.awt.Component 中的方法
移除指定的组件侦听器，以便它不再接收发自此组件的组件事件。
removeConnectionEventListener(ConnectionEventListener) - 接口 javax.sql.PooledConnection 中的方法
从在此 PooledConnection 对象上发生事件时得到通知的组件所组成的列表中移除给定的事件侦听器。
removeConnectionNotificationListener(NotificationListener) - 接口 javax.management.remote.JMXConnector 中的方法
将一个用于接收状态更改通知的侦听器从列表中移除。
removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - 接口 javax.management.remote.JMXConnector 中的方法
将一个用于接收状态更改通知的侦听器从列表中移除。
removeConnectionNotificationListener(NotificationListener) - 类 javax.management.remote.rmi.RMIConnector 中的方法
removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.remote.rmi.RMIConnector 中的方法
removeConsumer(ImageConsumer) - 类 java.awt.image.FilteredImageSource 中的方法
从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。
removeConsumer(ImageConsumer) - 接口 java.awt.image.ImageProducer 中的方法
从目前已注册以接收图像数据的使用者列表中移除指定的 ImageConsumer 对象。
removeConsumer(ImageConsumer) - 类 java.awt.image.MemoryImageSource 中的方法
从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。
removeConsumer(ImageConsumer) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
从对此图像的数据感兴趣的使用者列表中删除一个 ImageConsumer。
removeContainerListener(ContainerListener) - 类 java.awt.Container 中的方法
移除指定容器的侦听器，从而不再接收来自此容器的容器事件。
removeContents() - 接口 javax.xml.soap.SOAPElement 中的方法
分离此 SOAPElement 的所有子级。
removeControlButtons() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
removeControllerEventListener(ControllerEventListener, int[]) - 接口 javax.sound.midi.Sequencer 中的方法
移除侦听一类或多类控件事件的控件事件侦听器。
removeDescendantSelectedPaths(TreePath, boolean) - 类 javax.swing.JTree 中的方法
移除选择中的任何路径（path 的子路径）。
removeDescendantToggledPaths(Enumeration<TreePath>) - 类 javax.swing.JTree 中的方法
移除已展开的 toRemove 中 TreePath 的所有子路径。
removeDocumentListener(DocumentListener) - 类 javax.swing.text.AbstractDocument 中的方法
移除文档侦听器。
removeDocumentListener(DocumentListener) - 类 javax.swing.text.DefaultStyledDocument 中的方法
移除文档侦听器。
removeDocumentListener(DocumentListener) - 接口 javax.swing.text.Document 中的方法
将给定的观察者从通知列表中撤消注册，这样就不再接收改动更新。
removeDragGestureListener(DragGestureListener) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
取消注册当前的 DragGestureListener
removeDragSourceListener(DragSourceListener) - 类 java.awt.dnd.DragSource 中的方法
从此 DragSource 移除指定的 DragSourceListener。
removeDragSourceListener(DragSourceListener) - 类 java.awt.dnd.DragSourceContext 中的方法
从此 DragSourceContext 移除指定的 DragSourceListener。
removeDragSourceMotionListener(DragSourceMotionListener) - 类 java.awt.dnd.DragSource 中的方法
从此 DragSource 移除指定的 DragSourceMotionListener。
removeDropTargetListener(DropTargetListener) - 类 java.awt.dnd.DropTarget 中的方法
移除当前的 DropTargetListener (UNICAST SOURCE)。
removeEditor() - 类 javax.swing.JTable 中的方法
丢弃编辑器对象并释放它用于单元格呈现的资源。
removeEditor() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此公共方法是特定于实现的，应该为私有，不要调用或重写。
removeEldestEntry(Map.Entry<K, V>) - 类 java.util.LinkedHashMap 中的方法
如果此映射移除其最旧的条目，则返回 true。
removeElement(Object) - 类 java.util.Vector 中的方法
从此向量中移除变量的第一个（索引最小的）匹配项。
removeElement(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
从格式中移除元素。
removeElement(Object) - 类 javax.swing.DefaultComboBoxModel 中的方法
removeElement(Object) - 类 javax.swing.DefaultListModel 中的方法
从此列表中移除参数的第一个（索引最小的）匹配项。
removeElement(Object) - 接口 javax.swing.MutableComboBoxModel 中的方法
从模型中移除项。
removeElementAt(int) - 类 java.util.Vector 中的方法
删除指定索引处的组件。
removeElementAt(int) - 类 javax.swing.DefaultComboBoxModel 中的方法
removeElementAt(int) - 类 javax.swing.DefaultListModel 中的方法
删除指定索引处的组件。
removeElementAt(int) - 接口 javax.swing.MutableComboBoxModel 中的方法
在指定索引处移除项。
removeEntries(int, int) - 类 javax.swing.SizeSequence 中的方法
从此 SizeSequence 中移除一组相邻的条目。
removeEntry(Principal, AclEntry) - 接口 java.security.acl.Acl 中的方法
从此 ACL 中移除 ACL 项。
removeEventListener(String, EventListener, boolean) - 接口 org.w3c.dom.events.EventTarget 中的方法
此方法允许从事件目标移除事件侦听器。
removeField(String) - 接口 javax.management.Descriptor 中的方法
从该 descriptor 中删除字段。
removeField(String) - 类 javax.management.ImmutableDescriptor 中的方法
从描述符移除字段。
removeField(String) - 类 javax.management.modelmbean.DescriptorSupport 中的方法
removeFirst() - 类 java.util.ArrayDeque 中的方法
removeFirst() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
removeFirst() - 接口 java.util.Deque 中的方法
获取并移除此双端队列第一个元素。
removeFirst() - 类 java.util.LinkedList 中的方法
移除并返回此列表的第一个元素。
removeFirstOccurrence(Object) - 类 java.util.ArrayDeque 中的方法
移除此双端队列中第一次出现的指定元素（当从头部到尾部遍历双端队列时）。
removeFirstOccurrence(Object) - 接口 java.util.concurrent.BlockingDeque 中的方法
从此双端队列移除第一次出现的指定元素。
removeFirstOccurrence(Object) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
removeFirstOccurrence(Object) - 接口 java.util.Deque 中的方法
从此双端队列移除第一次出现的指定元素。
removeFirstOccurrence(Object) - 类 java.util.LinkedList 中的方法
从此列表中移除第一次出现的指定元素（从头部到尾部遍历列表时）。
removeFlavorListener(FlavorListener) - 类 java.awt.datatransfer.Clipboard 中的方法
移除指定的 FlavorListener，使其不再从此 Clipboard 接收 FlavorEvent。
removeFocusListener(FocusListener) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。
removeFocusListener(FocusListener) - 类 java.awt.Component 中的方法
移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。
removeFocusListener(FocusListener) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
移除指定的焦点侦听器，使其不再从此组件接收焦点事件。
removeFocusListener(FocusListener) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
移除指定的焦点侦听器，使之不再从此组件接收焦点事件。
removeFocusListener(FocusListener) - 接口 javax.accessibility.AccessibleComponent 中的方法
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
removeFocusListener(FocusListener) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
removeFocusListener(FocusListener) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
removeFocusListener(FocusListener) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
removeFocusListener(FocusListener) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
removeFromEnvironment(String) - 接口 javax.naming.Context 中的方法
从此上下文的环境中移除一个环境属性。
removeFromEnvironment(String) - 类 javax.naming.InitialContext 中的方法
removeFromParent() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
通过向此节点提供一个 null 父节点，从树中移除以此节点为根的子树。
removeFromParent() - 接口 javax.swing.tree.MutableTreeNode 中的方法
从其父对象移除接收者。
removeFromSource() - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
removeHandler(Handler) - 类 java.util.logging.Logger 中的方法
移除一个日志 Handler。
removeHandshakeCompletedListener(HandshakeCompletedListener) - 类 javax.net.ssl.SSLSocket 中的方法
移除一个以前注册的握手完成侦听器。
removeHeader(String) - 类 javax.xml.soap.MimeHeaders 中的方法
移除其名称与给定名称匹配的所有 MimeHeader 对象。
removeHierarchyBoundsListener(HierarchyBoundsListener) - 类 java.awt.Component 中的方法
移除指定的层次结构边界侦听器，以便它不再接收发自此组件的层次结构边界事件。
removeHierarchyListener(HierarchyListener) - 类 java.awt.Component 中的方法
移除指定的层次结构侦听器，以便它不再接收发自此组件的层次结构变化事件。
removeHighlight(Object) - 类 javax.swing.text.DefaultHighlighter 中的方法
从视图中移除高亮显示。
removeHighlight(Object) - 接口 javax.swing.text.Highlighter 中的方法
从视图中移除高亮显示。
removeHyperlinkListener(HyperlinkListener) - 类 javax.swing.JEditorPane 中的方法
移除超链接侦听器。
removeIconFor(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
在需要时移除 f 的 desktopIcon 的便捷方法。
removeIdentity(Identity) - 类 java.security.IdentityScope 中的方法
已过时。 从此身份作用作用域移除一个身份。
removeIIOReadProgressListener(IIOReadProgressListener) - 类 javax.imageio.ImageReader 中的方法
从已注册的进度侦听器列表中移除 IIOReadProgressListener。
removeIIOReadUpdateListener(IIOReadUpdateListener) - 类 javax.imageio.ImageReader 中的方法
从已注册的更新侦听器列表中移除 IIOReadUpdateListener。
removeIIOReadWarningListener(IIOReadWarningListener) - 类 javax.imageio.ImageReader 中的方法
从已注册的错误侦听器列表中移除 IIOReadWarningListener。
removeIIOWriteProgressListener(IIOWriteProgressListener) - 类 javax.imageio.ImageWriter 中的方法
从已注册的进度侦听器列表中移除 IIOWriteProgressListener。
removeIIOWriteWarningListener(IIOWriteWarningListener) - 类 javax.imageio.ImageWriter 中的方法
从已注册的警告侦听器列表中移除 IIOWriteWarningListener。
removeImage(Image) - 类 java.awt.MediaTracker 中的方法
从此媒体跟踪器移除指定的图像。
removeImage(Image, int) - 类 java.awt.MediaTracker 中的方法
从此媒体跟踪器的指定跟踪 ID 中移除指定的图像。
removeImage(Image, int, int, int) - 类 java.awt.MediaTracker 中的方法
从此媒体跟踪器移除具有指定宽度、高度和 ID 的指定图像。
removeImage(int) - 类 javax.imageio.ImageWriter 中的方法
从流中移除图像。
removeIndexInterval(int, int) - 类 javax.swing.DefaultListSelectionModel 中的方法
从选择模型中移除 index0,index1 区间中（包括两端点）的索引。
removeIndexInterval(int, int) - 接口 javax.swing.ListSelectionModel 中的方法
从选择模型中移除区间 index0、index1（包括）中的索引。
removeInputMethodListener(InputMethodListener) - 类 java.awt.Component 中的方法
移除指定的输入方法侦听器，以便它不再接收发自此组件的输入方法事件。
removeInternal(EventListener, EventListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
在从侦听器 l 中移除旧的侦听器之后，返回得到的多路广播侦听器。
removeInternalFrameListener(InternalFrameListener) - 类 javax.swing.JInternalFrame 中的方法
移除指定的内部窗体侦听器，不再接收此内部窗体发出的内部窗体事件。
removeInvalidComponent(JComponent) - 类 javax.swing.RepaintManager 中的方法
从无效组件的列表移除组件。
removeItem(Object) - 类 javax.swing.JComboBox 中的方法
从项列表中移除项。
removeItemAt(int) - 类 javax.swing.JComboBox 中的方法
移除 anIndex 处的项。
removeItemListener(ItemListener) - 类 java.awt.Checkbox 中的方法
移除此项侦听器，这样项侦听器将不再接收发自此复选框的项事件。
removeItemListener(ItemListener) - 类 java.awt.CheckboxMenuItem 中的方法
移除指定的项侦听器，以便它不再接收发自此复选框菜单项的项事件。
removeItemListener(ItemListener) - 类 java.awt.Choice 中的方法
移除指定的项侦听器，以便它不再接收发自此 Choice 菜单的项事件。
removeItemListener(ItemListener) - 接口 java.awt.ItemSelectable 中的方法
移除项侦听器。
removeItemListener(ItemListener) - 类 java.awt.List 中的方法
移除指定的项侦听器，以便不再从此列表接收项事件。
removeItemListener(ItemListener) - 类 javax.swing.AbstractButton 中的方法
从按钮中移除一个 ItemListener。
removeItemListener(ItemListener) - 接口 javax.swing.ButtonModel 中的方法
从模型中移除一个 ItemListener。
removeItemListener(ItemListener) - 类 javax.swing.DefaultButtonModel 中的方法
从模型中移除一个 ItemListener。
removeItemListener(ItemListener) - 类 javax.swing.JComboBox 中的方法
移除 ItemListener。
removeKeyEventDispatcher(KeyEventDispatcher) - 类 java.awt.KeyboardFocusManager 中的方法
移除以前添加到此 KeyboardFocusManager 调度程序链中的 KeyEventDispatcher。
removeKeyEventPostProcessor(KeyEventPostProcessor) - 类 java.awt.KeyboardFocusManager 中的方法
从此 KeyboardFocusManager 的后处理器链中移除以前添加的 KeyEventPostProcessor。
removeKeyListener(KeyListener) - 类 java.awt.Component 中的方法
移除指定的按键侦听器，以便它不再接收发自此组件的按键事件。
removeKeymap(String) - 类 javax.swing.text.JTextComponent 中的静态方法
移除以前添加到文档中的已命名 keymap。
removeKeyStrokeBinding(KeyStroke) - 接口 javax.swing.text.Keymap 中的方法
从 keymap 移除绑定。
removeLast() - 类 java.util.ArrayDeque 中的方法
removeLast() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
removeLast() - 接口 java.util.Deque 中的方法
获取并移除此双端队列的最后一个元素。
removeLast() - 类 java.util.LinkedList 中的方法
移除并返回此列表的最后一个元素。
removeLastOccurrence(Object) - 类 java.util.ArrayDeque 中的方法
移除此双端队列中最后一次出现的指定元素（当从头部到尾部遍历双端队列时）。
removeLastOccurrence(Object) - 接口 java.util.concurrent.BlockingDeque 中的方法
从此双端队列移除最后一次出现的指定元素。
removeLastOccurrence(Object) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
removeLastOccurrence(Object) - 接口 java.util.Deque 中的方法
从此双端队列移除最后一次出现的指定元素。
removeLastOccurrence(Object) - 类 java.util.LinkedList 中的方法
从此列表中移除最后一次出现的指定元素（从头部到尾部遍历列表时）。
removeLayoutComponent(Component) - 类 java.awt.BorderLayout 中的方法
从此边框布局中移除指定组件。
removeLayoutComponent(Component) - 类 java.awt.CardLayout 中的方法
从布局中移除指定的组件。
removeLayoutComponent(Component) - 类 java.awt.FlowLayout 中的方法
从布局中移除指定的组件。
removeLayoutComponent(Component) - 类 java.awt.GridBagLayout 中的方法
从此布局移除指定组件。
removeLayoutComponent(Component) - 类 java.awt.GridLayout 中的方法
从布局移除指定组件。
removeLayoutComponent(Component) - 接口 java.awt.LayoutManager 中的方法
从布局移除指定组件。
removeLayoutComponent(Component) - 类 javax.swing.BoxLayout 中的方法
此类不使用。
removeLayoutComponent(Component) - 类 javax.swing.GroupLayout 中的方法
已从父容器中移除 Component 的通知。
removeLayoutComponent(Component) - 类 javax.swing.JRootPane.RootLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
此 LayoutManager 方法不执行任何操作。
removeLayoutComponent(Component) - 类 javax.swing.OverlayLayout 中的方法
从布局移除指定组件。
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
根据了解的情况移除指定的组件。
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.ScrollPaneLayout 中的方法
从布局中移除指定的组件。
removeLayoutComponent(Component) - 类 javax.swing.SpringLayout 中的方法
移除与指定组件相关的约束。
removeLayoutComponent(Component) - 类 javax.swing.ViewportLayout 中的方法
从布局中移除指定组件。
removeLineListener(LineListener) - 接口 javax.sound.sampled.Line 中的方法
从此行的侦听器列表中移除指定侦听器。
removeListDataListener(ListDataListener) - 类 javax.swing.AbstractListModel 中的方法
将某个侦听器从每次更改数据模型都要通知的列表中移除。
removeListDataListener(ListDataListener) - 接口 javax.swing.ListModel 中的方法
从每次在数据模型发生更改时都得到通知的列表中移除侦听器。
removeListeners() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
已过时。 从 Java 2 platform v1.4 开始。
removeListSelectionListener(ListSelectionListener) - 类 javax.swing.DefaultListSelectionModel 中的方法
将侦听器从每次在选择发生更改时都得到通知的列表中移除。
removeListSelectionListener(ListSelectionListener) - 类 javax.swing.JList 中的方法
从列表中移除一个选择侦听器。
removeListSelectionListener(ListSelectionListener) - 接口 javax.swing.ListSelectionModel 中的方法
将侦听器从每次在选择发生更改时都得到通知的列表中移除。
removeMember(Principal) - 接口 java.security.acl.Group 中的方法
从组中移除指定的成员。
removeMenuDragMouseListener(MenuDragMouseListener) - 类 javax.swing.JMenuItem 中的方法
从菜单项中移除 MenuDragMouseListener。
removeMenuKeyListener(MenuKeyListener) - 类 javax.swing.JMenuItem 中的方法
从菜单项中移除 MenuKeyListener。
removeMenuKeyListener(MenuKeyListener) - 类 javax.swing.JPopupMenu 中的方法
从弹出菜单移除 MenuKeyListener。
removeMenuListener(MenuListener) - 类 javax.swing.JMenu 中的方法
移除菜单事件的侦听器。
removeMetaEventListener(MetaEventListener) - 接口 javax.sound.midi.Sequencer 中的方法
从此 sequencer 的已注册侦听器列表中移除指定的元事件侦听器（如果实际上此侦听器已注册）。
removeMimeHeader(String) - 类 javax.xml.soap.AttachmentPart 中的方法
移除匹配给定名称的所有 MIME 头。
removeMimeHeader(String) - 类 javax.xml.soap.SOAPPart 中的方法
移除所有与给定名称匹配的 MIME 头。
removeMouseListener(MouseListener) - 类 java.awt.Component 中的方法
移除指定的鼠标侦听器，以便它不再接收发自此组件的鼠标事件。
removeMouseListener(MouseListener) - 类 java.awt.TrayIcon 中的方法
移除指定的鼠标侦听器。
removeMouseMotionListener(MouseMotionListener) - 类 java.awt.Component 中的方法
移除指定的鼠标移动侦听器，以便它不再接收发自此组件的鼠标移动事件。
removeMouseMotionListener(MouseMotionListener) - 类 java.awt.TrayIcon 中的方法
移除指定的鼠标移动侦听器。
removeMouseWheelListener(MouseWheelListener) - 类 java.awt.Component 中的方法
移除指定的鼠标滚轮侦听器，以便它不再接收发自此组件的鼠标滚轮事件。
removeNamedItem(String) - 接口 org.w3c.dom.NamedNodeMap 中的方法
移除通过名称指定的节点。
removeNamedItemNS(String, String) - 接口 org.w3c.dom.NamedNodeMap 中的方法
移除通过本地名称和名称空间 URI 指定的节点。
removeNamespaceDeclaration(String) - 接口 javax.xml.soap.SOAPElement 中的方法
移除对应于给定前缀的名称空间声明。
removeNamingListener(NamingListener) - 接口 javax.naming.event.EventContext 中的方法
从此 EventContext 触发的接收命名事件中移除一个侦听器。
removeNode() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.removeNode() 中的规范实现 removeNode() 方法。
removeNode() - 类 java.util.prefs.Preferences 中的方法
移除此首选项节点及其所有子节点，移除的节点中所包含的全部首选项都将失效。
removeNodeChangeListener(NodeChangeListener) - 类 java.util.prefs.AbstractPreferences 中的方法
removeNodeChangeListener(NodeChangeListener) - 类 java.util.prefs.Preferences 中的方法
移除指定 NodeChangeListener，使其不再接收更改事件。
removeNodeFromParent(MutableTreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通知它从其父节点中移除节点。
removeNodeSpi() - 类 java.util.prefs.AbstractPreferences 中的方法
移除此首选项节点，该首选项节点及其所包含的所有首选项都将失效。
removeNotification(Integer) - 类 javax.management.timer.Timer 中的方法
从通知列表中移除与指定标识符对应的计时器通知。
removeNotification(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
从通知列表中移除与指定的标识符对应的计时器通知。
removeNotificationListener(ObjectName, ObjectName) - 接口 javax.management.MBeanServer 中的方法
removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - 接口 javax.management.MBeanServer 中的方法
removeNotificationListener(ObjectName, NotificationListener) - 接口 javax.management.MBeanServer 中的方法
removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - 接口 javax.management.MBeanServer 中的方法
removeNotificationListener(ObjectName, ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
从已注册的 MBean 中移除一个侦听器。
removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - 接口 javax.management.MBeanServerConnection 中的方法
从已注册的 MBean 中移除一个侦听器。
removeNotificationListener(ObjectName, NotificationListener) - 接口 javax.management.MBeanServerConnection 中的方法
从已注册的 MBean 中移除一个侦听器。
removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - 接口 javax.management.MBeanServerConnection 中的方法
从已注册的 MBean 中移除一个侦听器。
removeNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.MBeanServerDelegate 中的方法
removeNotificationListener(NotificationListener) - 类 javax.management.MBeanServerDelegate 中的方法
removeNotificationListener(NotificationListener) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
从 RequiredModelMBean 移除一个 Notification 的侦听器。
removeNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
removeNotificationListener(NotificationListener) - 接口 javax.management.NotificationBroadcaster 中的方法
从此 MBean 移除一个侦听器。
removeNotificationListener(NotificationListener) - 类 javax.management.NotificationBroadcasterSupport 中的方法
removeNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.NotificationBroadcasterSupport 中的方法
removeNotificationListener(NotificationListener, NotificationFilter, Object) - 接口 javax.management.NotificationEmitter 中的方法
从此 MBean 移除一个侦听器。
removeNotificationListener(ObjectName, ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
removeNotificationListener(ObjectName, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
removeNotificationListener(ObjectName, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
removeNotificationListener(NotificationListener) - 类 javax.management.StandardEmitterMBean 中的方法
removeNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.StandardEmitterMBean 中的方法
removeNotificationListeners(ObjectName, Integer[], Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
removeNotificationListeners(ObjectName, Integer[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
removeNotificationListeners(ObjectName, Integer[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
removeNotifications(String) - 类 javax.management.timer.Timer 中的方法
从通知列表中移除与指定类型对应的所有计时器通知。
removeNotifications(String) - 接口 javax.management.timer.TimerMBean 中的方法
从通知列表中移除与指定的类型对应的所有计时器通知。
removeNotify() - 类 java.awt.Component 中的方法
通过销毁此 Component 的本机屏幕资源使其成为不可显示的。
removeNotify() - 类 java.awt.Container 中的方法
通过移除此 Container 到其本机屏幕资源的连接，使其不可显示。
removeNotify(ComponentPeer) - 类 java.awt.dnd.DropTarget 中的方法
通知 DropTarget 它已经与某个 Component 解除关联。
removeNotify() - 类 java.awt.dnd.DropTargetContext 中的方法
取消与 DropTargetContextPeer 的关联时调用。
removeNotify() - 类 java.awt.Frame 中的方法
通过移除与本机屏幕资源的连接，将此窗体设置为不可显示的。
removeNotify(Component) - 类 java.awt.im.InputContext 中的方法
通知输入上下文，客户端组件已从它的包含层次结构中移除，或该组件已禁用输入方法支持。
removeNotify() - 接口 java.awt.im.spi.InputMethod 中的方法
通知输入方法已从客户端组件所在容器层次结构中移除该客户端组件，或通知它该组件已禁用输入方法支持。
removeNotify() - 类 java.awt.List 中的方法
移除此列表的同位体。
removeNotify() - 类 java.awt.Menu 中的方法
移除该菜单的同位体。
removeNotify() - 类 java.awt.MenuBar 中的方法
移除该菜单栏的同位体。
removeNotify() - 类 java.awt.MenuComponent 中的方法
移除该菜单组件的同位体。
removeNotify() - 类 java.awt.TextComponent 中的方法
移除 TextComponent 的同位体。
removeNotify() - 类 java.awt.Window 中的方法
通过移除此 Container 到其本机屏幕资源的连接，使其不可显示。
removeNotify() - 类 javax.swing.AbstractButton 中的方法
通知此组件它不再有父组件。
removeNotify() - 类 javax.swing.JButton 中的方法
重写 JComponent.removeNotify 来检查此按钮当前是否被设置为 RootPane 上的默认按钮，如果是，则将 RootPane 的默认按钮设置为 null，以确保 RootPane 不继续停留在无效的按钮引用上。
removeNotify() - 类 javax.swing.JComponent 中的方法
通知此组件它不再有父组件。
removeNotify() - 类 javax.swing.JMenuBar 中的方法
重写 JComponent.removeNotify 以在当前键盘管理器中注销此菜单栏。
removeNotify() - 类 javax.swing.JRootPane 中的方法
将本身从 SystemEventQueueUtils 注销。
removeNotify() - 类 javax.swing.JTable 中的方法
调用 unconfigureEnclosingScrollPane 方法。
removeNotify() - 类 javax.swing.text.JTextComponent 中的方法
removeObjectValue(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
禁止将 Object 引用存储在实现指定元素的节点中。
removeObservedObject(ObjectName) - 类 javax.management.monitor.Monitor 中的方法
从所观察的 MBean 集中移除指定的对象。
removeObservedObject(ObjectName) - 接口 javax.management.monitor.MonitorMBean 中的方法
从所观察的 MBean 集中移除指定的对象。
removeParameter(String) - 类 javax.activation.MimeType 中的方法
移除与给定名称关联的所有值。
removeParameters() - 类 java.awt.image.renderable.ParameterBlock 中的方法
清除参数列表。
removePermission(Permission) - 接口 java.security.acl.AclEntry 中的方法
从此 ACL 项中移除指定的权限。
removePopupMenuListener(PopupMenuListener) - 类 javax.swing.JComboBox 中的方法
移除 PopupMenuListener。
removePopupMenuListener(PopupMenuListener) - 类 javax.swing.JPopupMenu 中的方法
移除 PopupMenu 侦听器。
removePreferenceChangeListener(PreferenceChangeListener) - 类 java.util.prefs.AbstractPreferences 中的方法
removePreferenceChangeListener(PreferenceChangeListener) - 类 java.util.prefs.Preferences 中的方法
移除指定首选项更改侦听器，使其不再接收首选项更改事件。
removePrintJobAttributeListener(PrintJobAttributeListener) - 接口 javax.print.DocPrintJob 中的方法
移除此 PrintJob 的属性侦听器。
removePrintJobListener(PrintJobListener) - 接口 javax.print.DocPrintJob 中的方法
移除此 PrintJob 的侦听器。
removePrintServiceAttributeListener(PrintServiceAttributeListener) - 接口 javax.print.PrintService 中的方法
移除此 PrintService 的 PrintService 侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
将 PropertyChangeListener 从侦听器列表中移除。
removePropertyChangeListener(PropertyChangeListener) - 类 java.awt.Component 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Component 中的方法
从指定属性的侦听器列表中移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
从侦听器列表移除 PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
从特定属性的侦听器列表移除 PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.SystemTray 中的方法
从特定属性的侦听器列表中移除 PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Toolkit 中的方法
为指定的桌面属性移除指定的属性更改侦听器。
removePropertyChangeListener(String, PropertyChangeListener) - 接口 java.beans.beancontext.BeanContextChild 中的方法
从此 BeanContextChild 中移除一个 PropertyChangeListener，以便指定属性发生更改时不再接收 PropertyChangeEvent。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
为特定属性移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 接口 java.beans.Customizer 中的方法
移除一个用于 PropertyChange 事件的侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 java.beans.PropertyChangeSupport 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.beans.PropertyChangeSupport 中的方法
为特定属性移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 接口 java.beans.PropertyEditor 中的方法
移除一个用于 PropertyChange 事件的侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 java.beans.PropertyEditorSupport 中的方法
移除一个用于 PropertyChange 事件的侦听器。
removePropertyChangeListener(PropertyChangeListener) - 接口 java.util.jar.Pack200.Packer 中的方法
移除由 Pack200.Packer.addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。
removePropertyChangeListener(PropertyChangeListener) - 接口 java.util.jar.Pack200.Unpacker 中的方法
移除由 Pack200.Unpacker.addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 java.util.logging.LogManager 中的方法
移除属性更改事件的事件侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.accessibility.AccessibleContext 中的方法
从侦听器列表移除 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.AbstractAction 中的方法
从侦听器列表中移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 接口 javax.swing.Action 中的方法
移除一个 PropertyChange 侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
从侦听器列表中移除 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.SwingWorker 中的方法
从侦听器列表中移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.table.TableColumn 中的方法
从侦听器列表中移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
从侦听器列表移除 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.UIDefaults 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.UIManager 中的静态方法
从侦听器列表移除 PropertyChangeListener。
removeProvider(String) - 类 java.security.Security 中的静态方法
移除带有指定名称的提供者。
removeRange(int, int) - 类 java.util.AbstractList 中的方法
从此列表中移除索引在 fromIndex（包括）和 toIndex（不包括）之间的所有元素。
removeRange(int, int) - 类 java.util.ArrayList 中的方法
移除列表中索引在 fromIndex（包括）和 toIndex（不包括）之间的所有元素。
removeRange(int, int) - 类 java.util.Vector 中的方法
从此 List 中移除其索引位于 fromIndex（包括）与 toIndex（不包括）之间的所有元素。
removeRange(int, int) - 类 javax.swing.DefaultListModel 中的方法
删除指定索引范围中的组件。
removeRedundantState() - 类 javax.swing.undo.StateEdit 中的方法
移除状态哈希表中多余的键/值。
removeRelation(String) - 类 javax.management.relation.RelationService 中的方法
从 Relation Service 移除给定的关系。
removeRelation(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
从 Relation Service 移除给定的关系。
removeRelationType(String) - 类 javax.management.relation.RelationService 中的方法
从 Relation Service 中移除给定的关系类型。
removeRelationType(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
从 Relation Service 中移除给定的关系类型。
removeResourceBundle(String) - 类 javax.swing.UIDefaults 中的方法
从在其中搜索本地化默认的资源包列表中移除一个资源包。
removeRow(int) - 类 javax.swing.table.DefaultTableModel 中的方法
移除模型中 row 位置的行。
removeRowSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
取消选中从 index0 到 index1 之间（包含两端）的行。
removeRowSetListener(RowSetListener) - 类 javax.sql.rowset.BaseRowSet 中的方法
从此 RowSet 对象的侦听器列表中移除指定的对象。
removeRowSetListener(RowSetListener) - 接口 javax.sql.RowSet 中的方法
从在此 RowSet 对象上发生事件时得到通知的组件所组成的列表中移除指定的侦听器。
removeRowSorterListener(RowSorterListener) - 类 javax.swing.RowSorter 中的方法
移除一个 RowSorterListener。
removeSelectionInterval(int, int) - 类 javax.swing.DefaultListSelectionModel 中的方法
将选择更改为当前选择与 index0 和 index1（包括）之间索引的差集。
removeSelectionInterval(int, int) - 类 javax.swing.JList 中的方法
将选择设置为指定间隔和当前选择的差集。
removeSelectionInterval(int, int) - 类 javax.swing.JTree 中的方法
从该选择中移除 index0 和 index1（包含）之间的节点。
removeSelectionInterval(int, int) - 接口 javax.swing.ListSelectionModel 中的方法
将选择更改为当前选择与 index0 和 index1 之间（包括两者）索引的差集。
removeSelectionPath(TreePath) - 类 javax.swing.JTree 中的方法
从当前选择中移除指定路径标识的节点。
removeSelectionPath(TreePath) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
从 selection 中移除路径。
removeSelectionPath(TreePath) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
从选择中移除路径。
removeSelectionPaths(TreePath[]) - 类 javax.swing.JTree.EmptySelectionModel 中的方法
一个未移除任何内容的 null 实现。
removeSelectionPaths(TreePath[]) - 类 javax.swing.JTree 中的方法
从当前选择移除指定路径标识的节点。
removeSelectionPaths(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
从 selection 中移除路径。
removeSelectionPaths(TreePath[]) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
从选择中移除路径。
removeSelectionRow(int) - 类 javax.swing.JTree 中的方法
从当前选择移除索引 row 处的行。
removeSelectionRows(int[]) - 类 javax.swing.JTree 中的方法
移除在每个指定行处选择的行。
removeService(Provider.Service) - 类 java.security.Provider 中的方法
移除以前用 putService() 添加的服务。
removeShutdownHook(Thread) - 类 java.lang.Runtime 中的方法
取消注册某个先前已注册的虚拟机关闭钩子。
removeSources() - 类 java.awt.image.renderable.ParameterBlock 中的方法
清除源图像的列表。
removeSpi(String) - 类 java.util.prefs.AbstractPreferences 中的方法
移除此首选项节点上指定键的关联值（如果有）。
removeStatementEventListener(StatementEventListener) - 接口 javax.sql.PooledConnection 中的方法
从一个组件列表中移除指定的 StatementEventListener，该列表由驱动程序检测到 PreparedStatement 已关闭或无效时将获得通知的组件组成。
removeStyle(String) - 类 javax.swing.JTextPane 中的方法
移除以前添加到文档中的已命名的非 null 样式。
removeStyle(String) - 类 javax.swing.text.DefaultStyledDocument 中的方法
移除以前添加到文档中的已命名样式。
removeStyle(String) - 类 javax.swing.text.html.StyleSheet 中的方法
移除以前添加到该文档中的指定样式。
removeStyle(String) - 类 javax.swing.text.StyleContext 中的方法
移除以前添加到文档中的已命名样式。
removeStyle(String) - 接口 javax.swing.text.StyledDocument 中的方法
移除以前添加到文档中的指定样式。
removeStyleSheet(StyleSheet) - 类 javax.swing.text.html.StyleSheet 中的方法
从接收者的规则中移除 StyleSheet ss。
removeTabAt(int) - 类 javax.swing.JTabbedPane 中的方法
移除 index 位置的选项卡。
removeTableModelListener(TableModelListener) - 类 javax.swing.table.AbstractTableModel 中的方法
每次数据模型发生更改时，就从被通知的列表移除一个侦听器。
removeTableModelListener(TableModelListener) - 接口 javax.swing.table.TableModel 中的方法
每当数据模型发生更改时，就从被通知的列表中移除一个侦听器。
removeTextListener(TextListener) - 类 java.awt.TextComponent 中的方法
移除指定的文本事件侦听器，不再接收此文本组件发出的文本事件。
removeTileObserver(TileObserver) - 类 java.awt.image.BufferedImage 中的方法
移除一个 tile observer。
removeTileObserver(TileObserver) - 接口 java.awt.image.WritableRenderedImage 中的方法
移除一个观察器。
removeTransformer(ClassFileTransformer) - 接口 java.lang.instrument.Instrumentation 中的方法
注销提供的转换器。
removeTreeExpansionListener(TreeExpansionListener) - 类 javax.swing.JTree 中的方法
移除 TreeExpansion 事件的侦听器。
removeTreeModelListener(TreeModelListener) - 类 javax.swing.tree.DefaultTreeModel 中的方法
移除以前使用 addTreeModelListener() 添加的侦听器。
removeTreeModelListener(TreeModelListener) - 接口 javax.swing.tree.TreeModel 中的方法
移除以前通过 addTreeModelListener 添加的侦听器。
removeTreeSelectionListener(TreeSelectionListener) - 类 javax.swing.JTree 中的方法
移除 TreeSelection 侦听器。
removeTreeSelectionListener(TreeSelectionListener) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
从每次已选的 TreePaths 集合发生更改时都会得到通知的侦听器列表中移除 x。
removeTreeSelectionListener(TreeSelectionListener) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
从每次已选的 TreePath 集合发生更改时都会得到通知的侦听器列表中移除 x。
removeTreeWillExpandListener(TreeWillExpandListener) - 类 javax.swing.JTree 中的方法
移除 TreeWillExpand 事件的侦听器。
removeUndoableEditListener(UndoableEditListener) - 类 javax.swing.text.AbstractDocument 中的方法
移除撤消侦听器。
removeUndoableEditListener(UndoableEditListener) - 接口 javax.swing.text.Document 中的方法
将给定的观察者从通知列表中撤消注册，这样就不再接收更新。
removeUndoableEditListener(UndoableEditListener) - 类 javax.swing.undo.UndoableEditSupport 中的方法
移除一个 UndoableEditListener。
removeUpdate(DocumentEvent) - 接口 javax.swing.event.DocumentListener 中的方法
给出移除了一部分文档的通知。
removeUpdate(AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.AbstractDocument 中的方法
随文本的移除更新任何文档结构。
removeUpdate() - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
更新元素结构，以响应对文档中关联序列的移除操作。
removeUpdate(AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.DefaultStyledDocument 中的方法
在文本移除后更新文档结构。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.FieldView 中的方法
通知在文档中此视图负责的某个位置已插入内容。
removeUpdate(FlowView, DocumentEvent, Rectangle) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
发出通知，通知已从文档中此给定流视图负责的某个位置移除某些内容。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.FlowView 中的方法
发出通知，通知从文档中此视图负责的某个位置已移除内容。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.GlyphView 中的方法
发出通知，通知文档中此视图负责的位置已移除内容。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.html.InlineView 中的方法
发出通知，通知文档中此视图负责的位置已移除内容。
removeUpdate(DocumentEvent) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
removeUpdate(AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.PlainDocument 中的方法
随文本的移除更新任何文档结构。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.PlainView 中的方法
通知在文档中此视图负责的某个位置已插入内容。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.View 中的方法
给出从文档中此视图负责的位置移除了某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.WrappedPlainView 中的方法
发出从文档中此视图负责的位置移除了某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.ZoneView 中的方法
给出从文档中此视图负责的位置移除了某些内容的通知。
removeValue(String) - 接口 javax.net.ssl.SSLSession 中的方法
移除会话的应用层数据中绑定到给定名称的对象。
removeVetoableChangeListener(VetoableChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
从侦听器列表移除 VetoableChangeListener。
removeVetoableChangeListener(String, VetoableChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
从特定属性的侦听器列表移除 VetoableChangeListener。
removeVetoableChangeListener(String, VetoableChangeListener) - 接口 java.beans.beancontext.BeanContextChild 中的方法
从此 BeanContextChild 中移除一个 VetoableChangeListener，以便指定属性发生更改时不再接收事件。
removeVetoableChangeListener(String, VetoableChangeListener) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
移除一个 VetoableChangeListener。
removeVetoableChangeListener(VetoableChangeListener) - 类 java.beans.VetoableChangeSupport 中的方法
从侦听器列表移除一个 VetoableChangeListener。
removeVetoableChangeListener(String, VetoableChangeListener) - 类 java.beans.VetoableChangeSupport 中的方法
为特定属性移除一个 VetoableChangeListener。
removeVetoableChangeListener(VetoableChangeListener) - 类 javax.swing.JComponent 中的方法
从侦听器列表移除一个 VetoableChangeListener。
removeWindowFocusListener(WindowFocusListener) - 类 java.awt.Window 中的方法
移除指定的窗口焦点侦听器，以便不再从此窗口接收窗口事件。
removeWindowListener(WindowListener) - 类 java.awt.Window 中的方法
移除指定的窗口侦听器，以便不再从此窗口接收窗口事件。
removeWindowStateListener(WindowStateListener) - 类 java.awt.Window 中的方法
移除指定的窗口状态侦听器，以便不再从此窗口接收窗口事件。
rename(Name, Name) - 接口 javax.naming.Context 中的方法
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
rename(String, String) - 接口 javax.naming.Context 中的方法
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
rename(String, String) - 类 javax.naming.InitialContext 中的方法
rename(Name, Name) - 类 javax.naming.InitialContext 中的方法
renameFile(File, File) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
重命名底层文件系统中的文件。
renameNode(Node, String, String) - 接口 org.w3c.dom.Document 中的方法
重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。
renameTo(File) - 类 java.io.File 中的方法
重新命名此抽象路径名表示的文件。
render(Runnable) - 类 javax.swing.text.AbstractDocument 中的方法
如果模型支持被异步更新，则此方法允许在并发情况下安全地呈现该模型。
render(Runnable) - 接口 javax.swing.text.Document 中的方法
如果模型支持异步更新，则允许在并发情况下安全呈现模型。
RENDERABLE_IMAGE - 类 javax.print.DocFlavor.SERVICE_FORMATTED 中的静态变量
打印数据表示形式类名 = "java.awt.image.renderable.RenderableImage"（RenderableImage 对象）的服务格式化打印数据 DocFlavor。
RenderableImage - java.awt.image.renderable 中的 接口
RenderableImage 是与呈现无关的图像（该概念包含与分辨率无关的意思）的公共接口。
RenderableImageOp - java.awt.image.renderable 中的 类
此类借助其相关的 ContextualRenderedImageFactory 实例处理某个操作的可呈现方面。
RenderableImageOp(ContextualRenderedImageFactory, ParameterBlock) - 类 java.awt.image.renderable.RenderableImageOp 的构造方法
根据给定 ContextualRenderedImageFactory 对象以及一个包含 RenderableImage 源和其他参数的 ParameterBlock 构造 RenderedImageOp。
RenderableImageProducer - java.awt.image.renderable 中的 类
实现 ImageProducer 以允许异步生成 RenderableImage 的适配器类。
RenderableImageProducer(RenderableImage, RenderContext) - 类 java.awt.image.renderable.RenderableImageProducer 的构造方法
根据 RenderableImage 和 RenderContext 构造新的 RenderableImageProducer。
RenderContext - java.awt.image.renderable 中的 类
RenderContext 封装从 enderableImage 生成特定呈现所需的信息。
RenderContext(AffineTransform, Shape, RenderingHints) - 类 java.awt.image.renderable.RenderContext 的构造方法
构造具有给定转换的 RenderContext。
RenderContext(AffineTransform) - 类 java.awt.image.renderable.RenderContext 的构造方法
构造具有给定变换的 RenderContext。
RenderContext(AffineTransform, RenderingHints) - 类 java.awt.image.renderable.RenderContext 的构造方法
构造具有给定转换和呈现提示的 RenderContext。
RenderContext(AffineTransform, Shape) - 类 java.awt.image.renderable.RenderContext 的构造方法
构造具有给定变换和感兴趣区域的 RenderContext。
RenderedImage - java.awt.image 中的 接口
RenderedImage 是一个通用接口，用于包含或生成 Raster 形式图像数据的对象。
RenderedImageFactory - java.awt.image.renderable 中的 接口
RenderedImageFactory 接口（通常简称为 RIF）由希望充当工厂以生成不同呈现的类实现，例如，根据一组特定的参数、属性和呈现提示集，通过对一组源执行一连串的 BufferedImageOp。
renderer - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
Renderer - javax.swing 中的 接口
为负责“呈现”（显示）值的对象定义需求。
renderer - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
用于从中获取边框和偏移量的呈现器。
rendererPane - 类 javax.swing.plaf.basic.BasicListUI 中的变量
rendererPane - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的变量
rendererPane - 类 javax.swing.plaf.basic.BasicTableUI 中的变量
rendererPane - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
用于绘制 TreeCellRenderer。
rendererPane - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的变量
RenderingHints - java.awt 中的 类
RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。
RenderingHints(Map<RenderingHints.Key, ?>) - 类 java.awt.RenderingHints 的构造方法
构造一个新对象，该对象具有根据指定 Map 对象（可以为 null）初始化的键和值。
RenderingHints(RenderingHints.Key, Object) - 类 java.awt.RenderingHints 的构造方法
构造一个具有指定键/值对的新对象。
RenderingHints.Key - java.awt 中的 类
定义与 RenderingHints 一起使用的、用来控制呈现和图像管线中各种算法选择的所有键的基本类型。
RenderingHints.Key(int) - 类 java.awt.RenderingHints.Key 的构造方法
使用指示的私有键构造一个键。
reorderingAllowed - 类 javax.swing.table.JTableHeader 中的变量
如果为 true，则允许用户重新排序各列；默认值为 true。
reorderVisually(byte[], int, Object[], int, int) - 类 java.text.Bidi 中的静态方法
根据对象的层次，在数组中将对象重新排序为可视顺序。
repaint() - 类 java.awt.Component 中的方法
重绘此组件。
repaint(long) - 类 java.awt.Component 中的方法
重绘组件。
repaint(int, int, int, int) - 类 java.awt.Component 中的方法
重绘组件的指定矩形区域。
repaint(long, int, int, int, int) - 类 java.awt.Component 中的方法
在 tm 毫秒内重绘组件的指定矩形区域。
repaint() - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
repaint(long, int, int, int, int) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
repaint(Rectangle) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
repaint(long, int, int, int, int) - 类 javax.swing.JApplet 中的方法
在 time 毫秒内重绘此组件的指定矩形区域。
repaint(long, int, int, int, int) - 类 javax.swing.JComponent 中的方法
如果要显示组件，则将指定的区域添加到脏区 (dirty region) 列表。
repaint(Rectangle) - 类 javax.swing.JComponent 中的方法
如果要显示该组件，则将指定的区域添加到脏区列表。
repaint(long, int, int, int, int) - 类 javax.swing.JDialog 中的方法
在 time 毫秒内重绘此组件的指定矩形区域。
repaint(long, int, int, int, int) - 类 javax.swing.JFrame 中的方法
在 time 毫秒内重绘此组件的指定矩形区域。
repaint(long, int, int, int, int) - 类 javax.swing.JViewport 中的方法
始终在父坐标系统中重绘，以确保 RepaintManager 仅执行一种绘制方法。
repaint(long, int, int, int, int) - 类 javax.swing.JWindow 中的方法
在 time 毫秒内重绘此组件的指定矩形区域。
repaint(long, int, int, int, int) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
repaint(Rectangle) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
repaint() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
repaint() - 类 javax.swing.text.DefaultCaret 中的方法
使得重绘插入符。
repaint(long, int, int, int, int) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
repaint(Rectangle) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
repaint() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
repaintCellFocus() - 类 javax.swing.plaf.basic.BasicListUI.FocusHandler 中的方法
RepaintManager - javax.swing 中的 类
此类管理重绘请求，以最大限度地降低重绘次数。
RepaintManager() - 类 javax.swing.RepaintManager 的构造方法
创建新的 RepaintManager 实例。
repeatKeyAction - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 中的变量
正在生成的键代码。
replace(char, char) - 类 java.lang.String 中的方法
返回一个新的字符串，它是通过用 newChar 替换此字符串中出现的所有 oldChar 得到的。
replace(CharSequence, CharSequence) - 类 java.lang.String 中的方法
使用指定的字面值替换序列替换此字符串所有匹配字面值目标序列的子字符串。
replace(int, int, String) - 类 java.lang.StringBuffer 中的方法
replace(int, int, String) - 类 java.lang.StringBuilder 中的方法
REPLACE - 类 java.nio.charset.CodingErrorAction 中的静态变量
指示通过删除错误输入、向输出缓冲区追加 coder 的替换值和恢复编码操作来处理编码错误的操作。
replace(K, V, V) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
只有目前将键的条目映射到给定值时，才替换该键的条目。
replace(K, V) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
只有目前将键的条目映射到某一值时，才替换该键的条目。
replace(K, V, V) - 接口 java.util.concurrent.ConcurrentMap 中的方法
只有目前将键的条目映射到给定值时，才替换该键的条目。
replace(K, V) - 接口 java.util.concurrent.ConcurrentMap 中的方法
只有目前将键的条目映射到某一值时，才替换该键的条目。
replace(K, V, V) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
只有目前将键的条目映射到给定值时，才替换该键的条目。
replace(K, V) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
只有目前将键的条目映射到某一值时，才替换该键的条目。
replace(Component, Component) - 类 javax.swing.GroupLayout 中的方法
使用新的组件替代现有组件。
replace(int, int, Element[]) - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
使用新的元素集替换该内容。
replace(int, int, String, AttributeSet) - 类 javax.swing.text.AbstractDocument 中的方法
删除从 offset 到 offset + length 的文本区域，并用 text 替换它。
replace(int, int, View[]) - 类 javax.swing.text.AsyncBoxView 中的方法
调用超类以更新子视图，并且更新子视图的状态记录。
replace(int, int, View[]) - 类 javax.swing.text.BoxView 中的方法
使布局变得无效并调整所需/分配的缓存大小。
replace(int, int, View[]) - 类 javax.swing.text.CompositeView 中的方法
替换子视图。
replace(int, int, String, AttributeSet) - 类 javax.swing.text.DocumentFilter.FilterBypass 中的方法
删除从 offset 到 offset + length 的文本区域，并用 text 替换。
replace(DocumentFilter.FilterBypass, int, int, String, AttributeSet) - 类 javax.swing.text.DocumentFilter 中的方法
在替换指定的 Document 中的文本区域之前调用。
replace(int, int, View[]) - 类 javax.swing.text.TableView 中的方法
更改子视图。
replace(int, int, View[]) - 类 javax.swing.text.TableView.TableRow 中的方法
更改子视图。
replace(int, int, View[]) - 类 javax.swing.text.View 中的方法
替代子视图。
REPLACE_ATTRIBUTE - 接口 javax.naming.directory.DirContext 中的静态变量
此常量指定使用指定值替换属性。
replaceAll(String, String) - 类 java.lang.String 中的方法
使用给定的 replacement 替换此字符串所有匹配给定的正则表达式的子字符串。
replaceAll(List<T>, T, T) - 类 java.util.Collections 中的静态方法
使用另一个值替换列表中出现的所有某一指定值。
replaceAll(String) - 类 java.util.regex.Matcher 中的方法
替换模式与给定替换字符串相匹配的输入序列的每个子序列。
replaceChild(Node, Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
将子节点 oldChild 替换为子节点列表中的 newChild，并返回 oldChild 节点。
replaceChild(Node, Node) - 接口 org.w3c.dom.Node 中的方法
将子节点列表中的子节点 oldChild 替换为 newChild，并返回 oldChild 节点。
replaceData(int, int, String) - 接口 org.w3c.dom.CharacterData 中的方法
用指定的字符串替换从指定 16 位单元偏移量起始的字符。
replaceEdit(UndoableEdit) - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
此默认实现返回 false。
replaceEdit(UndoableEdit) - 接口 javax.swing.undo.UndoableEdit 中的方法
如果此 UndoableEdit 应替换 anEdit，则返回 true。
replaceEditor(JComponent, JComponent) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
当 JSpinner 编辑器属性更改时，由 PropertyChangeListener 调用。
replaceFirst(String, String) - 类 java.lang.String 中的方法
使用给定的 replacement 替换此字符串匹配给定的正则表达式的第一个子字符串。
replaceFirst(String) - 类 java.util.regex.Matcher 中的方法
替换模式与给定替换字符串匹配的输入序列的第一个子序列。
replaceImageMetadata(int, IIOMetadata) - 类 javax.imageio.ImageWriter 中的方法
替换与现有图像有关的图像元数据。
replaceItem(String, int) - 类 java.awt.List 中的方法
使用新字符串替换滚动列表中指定索引处的项。
replacement() - 类 java.nio.charset.CharsetDecoder 中的方法
返回此解码器的替换值。
replacement() - 类 java.nio.charset.CharsetEncoder 中的方法
返回此编码器的替换值。
replaceObject(Object) - 类 java.io.ObjectOutputStream 中的方法
在序列化期间，此方法允许 ObjectOutputStream 的受信任子类使用一个对象替代另一个对象。
replacePane(JComponent, JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
将必需的鼠标处理程序安装在 newPane 上并将其添加到窗体。
replacePixels(RenderedImage, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
用给定图像部分替换已出现在输出中的图像部分。
replacePixels(Raster, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
用给定 Raster 部分替换已出现在输出中的图像部分。
replaceRange(String, int, int) - 类 java.awt.TextArea 中的方法
用指定替换文本替换指定开始位置与结束位置之间的文本。
replaceRange(String, int, int) - 类 javax.swing.JTextArea 中的方法
用给定的新文本替换从指示的起始位置到结尾位置的文本。
replaceSelection(String) - 类 javax.swing.JEditorPane 中的方法
用由给定字符串表示的新内容替换当前选中的内容。
replaceSelection(String) - 类 javax.swing.JTextPane 中的方法
用给定字符串所表示的新内容替换当前选择的内容。
replaceSelection(String) - 类 javax.swing.text.JTextComponent 中的方法
用给定字符串所表示的新内容替换当前选定的内容。
replaceStreamMetadata(IIOMetadata) - 类 javax.imageio.ImageWriter 中的方法
使用新信息替换输出中的流元数据。
replaceText(String, int, int) - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 replaceRange(String, int, int) 取代。
replaceText(int, int, String) - 接口 javax.accessibility.AccessibleEditableText 中的方法
用指定的字符串替换两个索引之间的文本。
replaceText(int, int, String) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
用指定的字符串替换两个索引之间的文本。
replaceText(int, int, String) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
使用指定字符串替换两个索引之间的文本。
replaceUIActionMap(JComponent, ActionMap) - 类 javax.swing.SwingUtilities 中的静态方法
将 component 的 UI ActionMap 更改为 uiActionMap 的便捷方法。
replaceUIInputMap(JComponent, int, InputMap) - 类 javax.swing.SwingUtilities 中的静态方法
将 component 的 UI InputMap 更改为 uiInputMap 的便捷方法。
replaceWholeText(String) - 接口 org.w3c.dom.Text 中的方法
将当前节点和所有逻辑上相邻的文本节点的文本替换为指定的文本。
replaceWith(String) - 类 java.nio.charset.CharsetDecoder 中的方法
更改此解码器的替换值。
replaceWith(byte[]) - 类 java.nio.charset.CharsetEncoder 中的方法
更改此编码器的替换值。
ReplicateScaleFilter - java.awt.image 中的 类
使用最简单的算法缩放图像的 ImageFilter 类。
ReplicateScaleFilter(int, int) - 类 java.awt.image.ReplicateScaleFilter 的构造方法
构造一个根据 width 和 height 参数指定的源 Image 来缩放像素的 ReplicateScaleFilter。
reply_status() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
描述操作调用结果的状态。
REPORT - 类 java.nio.charset.CodingErrorAction 中的静态变量
指示要报告编码错误的操作，报告的方式是通过返回 CoderResult 对象或抛出 CharacterCodingException，以上两者都适合实现编码过程的方法。
REPORT - 类 javax.print.attribute.standard.Severity 中的静态变量
指示 PrinterStateReason 是 "report"（不太严重）。
report(Diagnostic<? extends S>) - 类 javax.tools.DiagnosticCollector 中的方法
report(Diagnostic<? extends S>) - 接口 javax.tools.DiagnosticListener 中的方法
发现问题时调用此方法。
report(String, String, Object, Location) - 接口 javax.xml.stream.XMLReporter 中的方法
以特定于应用程序的格式报告所需消息。
REPORTER - 类 javax.xml.stream.XMLInputFactory 中的静态变量
用于设置/获取 XMLReporter 接口实现的属性。
reportError(String, Exception, int) - 类 java.util.logging.Handler 中的方法
用于向该 Handler 的 ErrorManager 报告错误的受保护便利方法。
RepositoryIdHelper - org.omg.CORBA 中的 类
RepositoryId 的 Helper。
RepositoryIdHelper() - 类 org.omg.CORBA.RepositoryIdHelper 的构造方法
request(Object, String) - 类 org.omg.CORBA.portable.Delegate 中的方法
创建在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。
request(Object, String, boolean) - 类 org.omg.CORBA.portable.Delegate 中的方法
request 由 stub 调用，以获取用于编组参数的 OutputStream。
Request - org.omg.CORBA 中的 类
包含调用某一方法所必需的信息的对象。
Request() - 类 org.omg.CORBA.Request 的构造方法
request_id() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回唯一地标识激活的请求/应答序列的 id。
REQUEST_PROCESSING_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java。
requestAnonymity(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求不要将初始端的身份泄露给接受端。
requestConf(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求针对 wrap 方法启用数据机密性。
requestCredDeleg(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求在上下文创建期间将初始端的凭据委托给接受端。
requestDefaultFocus() - 类 javax.swing.JComponent 中的方法
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy.getDefaultComponent(Container).requestFocus() 取代
requestFocus() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
请求使此对象拥有焦点。
requestFocus() - 类 java.awt.Component 中的方法
请求此 Component 获取输入焦点，并且此 Component 的顶层祖先成为获得焦点的 Window。
requestFocus(boolean) - 类 java.awt.Component 中的方法
请求此 Component 获取输入焦点，并且此 Component 的顶层祖先成为获得焦点的 Window。
requestFocus() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
请求聚焦此对象。
requestFocus() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
请求此对象的焦点。
requestFocus() - 接口 javax.accessibility.AccessibleComponent 中的方法
请求此对象的焦点。
requestFocus() - 类 javax.swing.JComponent 中的方法
请求此 Component 获取输入焦点。
requestFocus(boolean) - 类 javax.swing.JComponent 中的方法
请求此 Component 获取输入焦点。
requestFocus() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
requestFocus() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
requestFocus() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
requestFocus() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 中的方法
requestFocus() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
requestFocusInWindow() - 类 java.awt.Component 中的方法
如果此 Component 的顶层祖先已经是获得焦点的 Window，则请求此 Component 获取输入焦点。
requestFocusInWindow(boolean) - 类 java.awt.Component 中的方法
如果此 Component 的顶层祖先已经是获得焦点的 Window，则请求此 Component 获取输入焦点。
requestFocusInWindow() - 类 javax.swing.JComponent 中的方法
请求此 Component 获取输入焦点。
requestFocusInWindow(boolean) - 类 javax.swing.JComponent 中的方法
请求此 Component 获取输入焦点。
RequestInfo - org.omg.PortableInterceptor 中的 接口
Interceptor 可访问的请求信息。
RequestInfoOperations - org.omg.PortableInterceptor 中的 接口
Interceptor 可访问的请求信息。
RequestingUserName - javax.print.attribute.standard 中的 类
RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。
RequestingUserName(String, Locale) - 类 javax.print.attribute.standard.RequestingUserName 的构造方法
构造具有给定用户名称和语言环境的新 RequestingUserName 属性。
requestInteg(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求针对 wrap 和 getMIC 方法启用数据完整性。
requestLifetime(int) - 接口 org.ietf.jgss.GSSContext 中的方法
请求上下文以秒为单位的生存期。
requestMutualAuth(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
要求相互验证在上下文创建期间完成。
requestPasswordAuthentication(InetAddress, int, String, String, String) - 类 java.net.Authenticator 中的静态方法
要求已经向系统注册的 authenticator 提供密码。
requestPasswordAuthentication(String, InetAddress, int, String, String, String) - 类 java.net.Authenticator 中的静态方法
要求已经向系统注册的 authenticator 提供密码。
requestPasswordAuthentication(String, InetAddress, int, String, String, String, URL, Authenticator.RequestorType) - 类 java.net.Authenticator 中的静态方法
要求已经向系统注册的 authenticator 提供密码。
RequestProcessingPolicy - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 处理请求的方式。
RequestProcessingPolicyOperations - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 处理请求的方式。
RequestProcessingPolicyValue - org.omg.PortableServer 中的 类
RequestProcessingPolicyValue 可以具有以下值。
RequestProcessingPolicyValue(int) - 类 org.omg.PortableServer.RequestProcessingPolicyValue 的构造方法
requestReplayDet(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求在上下文创建之后针对 per-message 安全服务启用重放检测。
requestSequenceDet(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求在上下文创建之后针对 per-message 安全服务启用序列检查。
requestTopDownLeftRightResend(ImageConsumer) - 类 java.awt.image.FilteredImageSource 中的方法
请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。
requestTopDownLeftRightResend(ImageConsumer) - 接口 java.awt.image.ImageProducer 中的方法
代表 ImageConsumer 请求 ImageProducer 尝试再次以 TOPDOWNLEFTRIGHT 的顺序重新发送图像数据，从而可以使用依赖于按顺序接收像素的高质量转换算法以生成更佳的图像输出。
requestTopDownLeftRightResend(ImageConsumer) - 类 java.awt.image.MemoryImageSource 中的方法
请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。
requestTopDownLeftRightResend(ImageConsumer) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
请求给定 ImageConsumer 按从上到下、从左到右的顺序再次提交图像数据。
RequestWrapper - javax.xml.ws 中的 注释类型
此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
require(int, String, String) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
require(int, String, String) - 接口 javax.xml.stream.XMLStreamReader 中的方法
测试当前事件是否属于给定的类型，以及名称空间和名称是否与当前事件的当前名称空间和名称相匹配。
REQUIRED - 类 java.awt.GraphicsConfigTemplate 中的静态变量
用于“枚举”（整数）类型的值。
required - 类 java.sql.DriverPropertyInfo 中的变量
如果在 Driver.connect 期间必须为此属性提供一个值，则 required 字段为 true，否则为 false。
REQUIRED - 类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 中的静态变量
所需的 LoginModule。
REQUIRED - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
RequiredModelMBean - javax.management.modelmbean 中的 类
此类是 ModelMBean 的实现。
RequiredModelMBean() - 类 javax.management.modelmbean.RequiredModelMBean 的构造方法
构造带有空 ModelMBeanInfo 的 RequiredModelMBean。
RequiredModelMBean(ModelMBeanInfo) - 类 javax.management.modelmbean.RequiredModelMBean 的构造方法
使用传入的 ModelMBeanInfo 构造 RequiredModelMBean 对象。
requireEnd() - 类 java.util.regex.Matcher 中的方法
如果很多输入都可以将正匹配更改为负匹配，则返回 true。
REQUIRES_ATTENTION - 类 javax.print.event.PrintJobEvent 中的静态变量
打印服务指示可能发生需要外部干预的瞬态问题，然后打印服务才可以继续进行。
requiresBidi(char[], int, int) - 类 java.text.Bidi 中的静态方法
如果指定的文本需要双向解析，则返回 true。
REQUISITE - 类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 中的静态变量
必需的 LoginModule。
RescaleOp - java.awt.image 中的 类
通过将每个像素的样本值乘以一个缩放因子，然后加上一个偏移量，此类对源图像中数据进行逐像素重缩放。
RescaleOp(float[], float[], RenderingHints) - 类 java.awt.image.RescaleOp 的构造方法
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。
RescaleOp(float, float, RenderingHints) - 类 java.awt.image.RescaleOp 的构造方法
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。
rescanCurrentDirectory() - 类 javax.swing.JFileChooser 中的方法
通知 UI 重新扫描当前目录的文件列表。
rescanCurrentDirectory(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
rescanCurrentDirectory(JFileChooser) - 类 javax.swing.plaf.FileChooserUI 中的方法
rescanCurrentDirectory(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
rescanCurrentDirectory(JFileChooser) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 rescanCurrentDirectory 方法。
resendTopDownLeftRight(ImageProducer) - 类 java.awt.image.ImageFilter 中的方法
响应来自 ImageConsumer 的一个按 TopDownLeftRight (TDLR) 顺序将像素数据重新发送的请求。
RESERVED_ID_MAX - 类 java.awt.AWTEvent 中的静态变量
保留的 AWT 事件 ID 的最大值。
RESERVED_UIROLE - 类 javax.print.ServiceUIFactory 中的静态变量
不是有效的角色，但是可将大于此的角色 ID 用于服务支持的专用角色。
reset() - 类 java.awt.geom.Area 中的方法
从此 Area 删除所有几何形状，将其恢复为空区域。
reset() - 类 java.awt.geom.Path2D 中的方法
将路径重置为空。
reset() - 类 java.awt.Polygon 中的方法
将此 Polygon 对象重置为一个空多边形。
reset() - 类 java.io.BufferedInputStream 中的方法
参见 InputStream 的 reset 方法的常规协定。
reset() - 类 java.io.BufferedReader 中的方法
将流重置到最新的标记。
reset() - 类 java.io.ByteArrayInputStream 中的方法
将缓冲区的位置重置为标记位置。
reset() - 类 java.io.ByteArrayOutputStream 中的方法
将此 byte 数组输出流的 count 字段重置为零，从而丢弃输出流中目前已累积的所有输出。
reset() - 类 java.io.CharArrayReader 中的方法
将该流重置为最新的标记，如果从未标记过，则将其重置到开头。
reset() - 类 java.io.CharArrayWriter 中的方法
重置该缓冲区，以便再次使用它而无需丢弃已分配的缓冲区。
reset() - 类 java.io.FilterInputStream 中的方法
将此流重新定位到对此输入流最后调用 mark 方法时的位置。
reset() - 类 java.io.FilterReader 中的方法
重置该流。
reset() - 类 java.io.InputStream 中的方法
将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。
reset() - 类 java.io.LineNumberInputStream 中的方法
已过时。 将此流重新定位到对此输入流最后调用 mark 方法时的位置。
reset() - 类 java.io.LineNumberReader 中的方法
将该流重新设置为最新的标记。
reset() - 类 java.io.ObjectOutputStream 中的方法
重置将丢弃已写入流中的所有对象的状态。
reset() - 类 java.io.PushbackInputStream 中的方法
将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。
reset() - 类 java.io.PushbackReader 中的方法
重置该流。
reset() - 类 java.io.Reader 中的方法
重置该流。
reset() - 类 java.io.StringBufferInputStream 中的方法
已过时。 将输入流重置为开始读取此输入流的基础缓冲区的第一个字符处。
reset() - 类 java.io.StringReader 中的方法
将该流重置为最新的标记，如果从未标记过，则将其重置到该字符串的开头。
reset() - 类 java.nio.Buffer 中的方法
将此缓冲区的位置重置为以前标记的位置。
reset() - 类 java.nio.charset.CharsetDecoder 中的方法
重置此解码器，清除所有内部状态。
reset() - 类 java.nio.charset.CharsetEncoder 中的方法
重置此编码器，清除所有内部状态。
reset() - 类 java.security.MessageDigest 中的方法
重置摘要以供再次使用。
reset() - 类 java.text.CollationElementIterator 中的方法
将光标重置于字符串开始处。
reset() - 类 java.util.concurrent.CyclicBarrier 中的方法
将屏障重置为其初始状态。
reset() - 类 java.util.logging.LogManager 中的方法
重置日志配置。
reset() - 类 java.util.regex.Matcher 中的方法
重置匹配器。
reset(CharSequence) - 类 java.util.regex.Matcher 中的方法
重置此具有新输入序列的匹配器。
reset() - 类 java.util.Scanner 中的方法
重置此扫描器。
reset() - 类 java.util.zip.Adler32 中的方法
将校验和重置为初始值。
reset() - 接口 java.util.zip.Checksum 中的方法
将校验和重置为其初始值。
reset() - 类 java.util.zip.CRC32 中的方法
将 CRC-32 重置为初始值。
reset() - 类 java.util.zip.Deflater 中的方法
重置 deflater 以处理新的输入数据集。
reset() - 类 java.util.zip.DeflaterInputStream 中的方法
不支持此操作。
reset() - 类 java.util.zip.Inflater 中的方法
重置 inflater 以处理新的输入数据集。
reset() - 类 java.util.zip.InflaterInputStream 中的方法
将此流重新定位到对此输入流最后调用 mark 方法时的位置。
reset() - 类 javax.crypto.Mac 中的方法
重置此 Mac 对象。
reset() - 类 javax.imageio.ImageReader 中的方法
将 ImageReader 恢复到其初始状态。
reset() - 类 javax.imageio.ImageWriter 中的方法
将 ImageWriter 恢复到其初始状态。
reset() - 类 javax.imageio.metadata.IIOMetadata 中的方法
将此对象中存储的所有数据重置为默认值，通常为此对象构造后立即处于的状态，尽管精确的语义是特定于插件的。
reset() - 接口 javax.imageio.stream.ImageInputStream 中的方法
返回在最近一次非匹配地调用 mark 时指向上一个位置（包括位偏移量）的流指针。
reset() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
根据标记的堆栈重置当前流字节和位位置。
reset() - 类 javax.sound.sampled.AudioInputStream 中的方法
将此音频输入流重新定位到上一次调用其 mark 方法时的位置。
reset() - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.reset，以重置进度监视器以及流。
RESET - 类 javax.swing.text.html.FormView 中的静态变量
已过时。 从 1.3 开始，将使用来自 UIManager UIManager property FormView.resetButtonText 的值
reset() - 类 javax.xml.bind.util.ValidationEventCollector 中的方法
清除所有收集的错误和警告。
reset() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将此 XMLGregorianCalendar 重设为其原始值。
reset() - 类 javax.xml.parsers.DocumentBuilder 中的方法
将此 DocumentBuilder 重置为其原始配置。
reset() - 类 javax.xml.parsers.SAXParser 中的方法
将此 SAXParser 重置为其原始配置。
reset() - 类 javax.xml.transform.Transformer 中的方法
将此 Transformer 重置为其初始配置。
reset() - 类 javax.xml.validation.Validator 中的方法
将此 Validator 重置为其初始配置。
reset() - 接口 javax.xml.xpath.XPath 中的方法
将此 XPath 重置为其初始配置。
reset() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
重设此名称空间支持对象，以便重新使用。
RESET_FLAGS_ALREADY_NOTIFIED - 类 javax.management.monitor.Monitor 中的静态变量
此标志用来重新设置 alreadyNotifieds 监视器属性。
resetAllControllers() - 接口 javax.sound.midi.MidiChannel 中的方法
将所有实现的控件重置为其默认值。
resetChoosableFileFilters() - 类 javax.swing.JFileChooser 中的方法
将可选择文件过滤器列表重置为其开始状态。
resetInputValue() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
基于 inputComponent 中的值，设置接收者为其提供外观的选项窗格中的输入值。
resetKeyboardActions() - 类 javax.swing.JComponent 中的方法
注销首层 InputMaps 和 ActionMap 中的所有绑定。
resetLayoutManager() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
基于方向重置布局管理器，并利用 invalidateLayout 传递其消息以拉入适当的 Component。
resetMarksAtZero() - 类 javax.swing.text.GapContent 中的方法
重新设置具有 0 偏移量的所有标记，使其也有零索引。
resetPeakThreadCount() - 接口 java.lang.management.ThreadMXBean 中的方法
将峰值线程计数重置为当前活动线程的数量。
resetPeakUsage() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
将此内存池的峰值内存使用量统计重置为当前内存使用量。
resetRecognizer() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
重置 Recognizer，如果 Recognizer 当前正在识别一个动作，则忽略。
resetRowSelection() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
更新此对象从 TreePath 到行的映射关系。
resetRowSelection() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
更新此对象从 TreePath 到行的映射关系。
resetSizeAt(int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
在传入位置重置 Component 的大小。
resetSyntax() - 类 java.io.StreamTokenizer 中的方法
重置此标记生成器的语法表，使所有字符都成为“普通”字符。
resetToPreferredSizes() - 类 javax.swing.JSplitPane 中的方法
以子组件的首选大小为基础调整 JSplitPane 的布局。
resetToPreferredSizes() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
标记接收者，以便下一次布置此实例时它将请求首选大小。
resetToPreferredSizes(JSplitPane) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
传递消息以重置首选大小。
resetToPreferredSizes(JSplitPane) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 resetToPreferredSizes 方法。
resetToPreferredSizes(JSplitPane) - 类 javax.swing.plaf.SplitPaneUI 中的方法
传递消息，以便基于子组件的首选大小重新布置 JSplitPane。
resetViewPort() - 类 javax.swing.JScrollPane.AccessibleJScrollPane 中的方法
reshape(int, int, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
reshape(int, int, int, int) - 类 java.awt.Rectangle 中的方法
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
reshape(int, int, int, int) - 类 java.awt.Window 中的方法
已过时。 从 JDK 1.1 版开始，由 setBounds(int, int, int, int) 取代。
reshape(int, int, int, int) - 类 javax.swing.JComponent 中的方法
已过时。 从 JDK 5 开始，由 Component.setBounds(int, int, int, int) 取代。

移动此组件并调整其大小。

reshape(int, int, int, int) - 类 javax.swing.JInternalFrame 中的方法
移动此组件并调整其大小。
reshape(int, int, int, int) - 类 javax.swing.JViewport 中的方法
设置此视口的边界。
RESIZABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象的大小不固定。
resizable - 类 javax.swing.JInternalFrame 中的变量
可以更改窗体的大小。
resize(int, int) - 类 java.applet.Applet 中的方法
请求调整此 applet 的大小。
resize(Dimension) - 类 java.applet.Applet 中的方法
请求调整此 applet 的大小。
resize(int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。
resize(Dimension) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setSize(Dimension) 取代。
resize(int, int) - 类 java.awt.Rectangle 中的方法
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。
RESIZE_NONE - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的变量
RESIZE_WEIGHT_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 weight 属性。
resizeAndRepaint() - 类 javax.swing.JTable 中的方法
等效于先调用 revalidate 再调用 repaint。
resizeAndRepaint() - 类 javax.swing.table.JTableHeader 中的方法
确定头的大小并将其标记为需要显示。
resizedPostingDisableCount - 类 javax.swing.table.TableColumn 中的变量
已过时。 从 Java 2 platform v1.3 开始
resizeFrame(JComponent, int, int, int, int) - 类 javax.swing.DefaultDesktopManager 中的方法
使用新值调用 setBoundsForFrame。
resizeFrame(JComponent, int, int, int, int) - 接口 javax.swing.DesktopManager 中的方法
用户已经重新调整组件的大小。
resizingAllowed - 类 javax.swing.table.JTableHeader 中的变量
如果为 true，则允许用户调整各列的大小；默认值为 true。
resizingColumn - 类 javax.swing.table.JTableHeader 中的变量
进行大小调整的列的索引。
resolution - 类 javax.sound.midi.MidiFileFormat 中的变量
MIDI 文件的定时精度。
resolution - 类 javax.sound.midi.Sequence 中的变量
sequence 的定时精度。
ResolutionSyntax - javax.print.attribute 中的 类
类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。
ResolutionSyntax(int, int, int) - 类 javax.print.attribute.ResolutionSyntax 的构造方法
根据给定项构造一个新的分辨率属性。
resolve(URI) - 类 java.net.URI 中的方法
根据此 URI 解析给定的 URI。
resolve(String) - 类 java.net.URI 中的方法
解析给定的字符串，然后在此 URI 的基础上构造一个新的 URI。
resolve(String, String) - 接口 javax.xml.transform.URIResolver 中的方法
当遇到 xsl:include、xsl:import 或 document() 函数时，由处理器调用此方法。
resolve(NameComponent[]) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
解析操作是指检索绑定到给定上下文中名称的对象的过程。
resolve(NameComponent[]) - 类 org.omg.CosNaming._NamingContextStub 中的方法
解析操作是指检索绑定到给定上下文中名称的对象的过程。
resolve(NameComponent[]) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
解析操作是指检索绑定到给定上下文中名称的对象的过程。
resolve_initial_references(String) - 类 org.omg.CORBA.ORB 中的方法
根据可用初始服务名称集解析特定对象引用。
resolve_initial_references(String) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
等同于 ORB.resolve_initial_references。
resolve_str(String) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作将“字符串化的”名称解析为对象引用。
resolve_str(String) - 接口 org.omg.CosNaming.NamingContextExtOperations 中的方法
此操作将“字符串化的”名称解析为对象引用。
ResolveAttribute - 接口 javax.swing.text.AttributeSet 中的静态变量
用于标识解析父集合属性集（如果已定义）的属性名。
ResolveAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
用来标识属性的解析父集的属性名（如果定义了属性的解析父集）。
resolveClass(ObjectStreamClass) - 类 java.io.ObjectInputStream 中的方法
加载指定流类描述的本地等价类。
resolveClass(Class<?>) - 类 java.lang.ClassLoader 中的方法
链接指定的类。
resolvedName - 异常 javax.naming.NamingException 中的变量
包含已成功解析的名称部分。
resolvedObj - 异常 javax.naming.NamingException 中的变量
包含一个对象，已成功解析的名称部分进行到该对象。
resolvedObj - 类 javax.naming.spi.ResolveResult 中的变量
该字段包含已成功解析成的 Object。
resolveEntity(String, String, String, String) - 接口 javax.xml.stream.XMLResolver 中的方法
检索资源。
resolveEntity(String, String) - 接口 org.xml.sax.EntityResolver 中的方法
允许应用程序解析外部实体。
resolveEntity(String, String, String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。
resolveEntity(String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。
resolveEntity(String, String, String, String) - 接口 org.xml.sax.ext.EntityResolver2 中的方法
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。
resolveEntity(String, String) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 解析外部实体。
resolveEntity(String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
解析外部实体。
resolveEntity(String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个外部实体解析。
resolveFunction(QName, int) - 接口 javax.xml.xpath.XPathFunctionResolver 中的方法
在可用的函数集中查找函数。
resolveObject(Object) - 类 java.io.ObjectInputStream 中的方法
在反序列化期间，此方法允许 ObjectInputStream 的受信任子类使用一个对象替代另一个。
resolveProxyClass(String[]) - 类 java.io.ObjectInputStream 中的方法
返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。
Resolver - javax.naming.spi 中的 接口
此接口表示用于名称解析的“中间上下文”。
RESOLVER - 类 javax.xml.stream.XMLInputFactory 中的静态变量
用于设置/获取 XMLResolver 实现的属性。
resolveResource(String, String, String, String, String) - 接口 org.w3c.dom.ls.LSResourceResolver 中的方法
允许应用程序解析外部资源。
ResolveResult - javax.naming.spi 中的 类
此类表示解析某一名称的结果。
ResolveResult() - 类 javax.naming.spi.ResolveResult 的构造方法
构造一个 ResolveResult 实例，使已解析对象和剩余名称都被初始化为 null。
ResolveResult(Object, String) - 类 javax.naming.spi.ResolveResult 的构造方法
构造一个新的 ResolveResult 实例，该实例由已解析对象和剩余未解析组件组成。
ResolveResult(Object, Name) - 类 javax.naming.spi.ResolveResult 的构造方法
构造一个新的 ResolveResult 实例，该实例由已解析 Object 和剩余名称组成。
resolveToClass(Name, Class<? extends Context>) - 接口 javax.naming.spi.Resolver 中的方法
部分解析某一名称。
resolveToClass(String, Class<? extends Context>) - 接口 javax.naming.spi.Resolver 中的方法
部分解析某一名称。
resolveVariable(QName) - 接口 javax.xml.xpath.XPathVariableResolver 中的方法
在可用的变量集中查找变量。
Resource - javax.annotation 中的 注释类型
Resource 注释标记应用程序所需的资源。
Resource.AuthenticationType - javax.annotation 中的 枚举
资源的两种可能验证类型。
ResourceBundle - java.util 中的 类
资源包包含特定于语言环境的对象。
ResourceBundle() - 类 java.util.ResourceBundle 的构造方法
唯一的构造方法（由子类构造方法调用，通常是隐式的）。
ResourceBundle.Control - java.util 中的 类
ResourceBundle.Control 定义一个回调方法集，它在包加载进程中由 ResourceBundle.getBundle 工厂方法调用。
ResourceBundle.Control() - 类 java.util.ResourceBundle.Control 的构造方法
唯一的构造方法。
Resources - javax.annotation 中的 注释类型
此类用于允许多个资源声明。
RESOURCES_ARE_NOT_READY - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
在候选作业的任何物理打印机上，至少有一个该作业所需的资源（例如介质、字体、资源对象等）未就绪。
Response<T> - javax.xml.ws 中的 接口
Response 接口提供一些方法，用来获得为响应操作调用而发送的消息的净荷和上下文。
response_expected() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
指示是否希望响应。
ResponseCache - java.net 中的 类
表示 URLConnection 缓存的实现。
ResponseCache() - 类 java.net.ResponseCache 的构造方法
responseCode() - 异常 java.net.HttpRetryException 中的方法
返回 http 响应代码
responseCode - 类 java.net.HttpURLConnection 中的变量
表示三位字数的 HTTP 状态码 (Status-Code) 的 int。
ResponseHandler - org.omg.CORBA.portable 中的 接口
此接口由 ORB 在调用期间提供给 servant，允许 servant 稍后检索用来返回调用结果的 OutputStream。
responseMessage - 类 java.net.HttpURLConnection 中的变量
HTTP 响应消息。
ResponseWrapper - javax.xml.ws 中的 注释类型
此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
rest_of_name - 异常 org.omg.CosNaming.NamingContextPackage.CannotProceed 中的变量
rest_of_name - 异常 org.omg.CosNaming.NamingContextPackage.NotFound 中的变量
restart() - 类 javax.swing.Timer 中的方法
重新启动 Timer，取消所有挂起的触发并使它按初始延迟触发。
RESTORE_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
restoreAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
restoreOriginal() - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象还原成其原始值，即执行上一组更改前的值。
restoreState(Hashtable<?, ?>) - 接口 javax.swing.undo.StateEditable 中的方法
收到此消息时，接收者应从 state 中提取任何相关状态。
restoreSubcomponentFocus() - 类 javax.swing.JInternalFrame 中的方法
请求内部窗体将焦点还原到具有焦点的最后一个子组件。
Result - javax.xml.transform 中的 接口
实现此接口的对象包含构建转换结果树所需的信息。
result() - 类 org.omg.CORBA.Request 中的方法
检索包含该方法的返回值的 NamedValue 对象。
result(Any) - 类 org.omg.CORBA.ServerRequest 中的方法
已过时。 使用方法 set_result
result() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回一个 any，它包含该操作调用的结果。
ResultSet - java.sql 中的 接口
表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
ResultSetMetaData - java.sql 中的 接口
可用于获取关于 ResultSet 对象中列的类型和属性信息的对象。
resume() - 类 java.lang.Thread 中的方法
已过时。 该方法只与 Thread.suspend() 一起使用，但 Thread.suspend() 已经遭到反对，因为它具有死锁倾向。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
resume() - 类 java.lang.ThreadGroup 中的方法
已过时。 此方法只用于联合 Thread.suspend 和 ThreadGroup.suspend 时，因为它们所固有的容易导致死锁的特性，所以两者都已废弃。有关详细信息，请参阅 Thread.suspend()。
RETAIN - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的静态变量
retainAll(Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
仅保留指定子对象（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
retainAll(Collection<?>) - 类 java.util.AbstractCollection 中的方法
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。
retainAll(Collection<?>) - 接口 java.util.Collection 中的方法
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。
retainAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
只保留此列表中包含在指定 collection 中的元素。
retainAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
仅保留此 set 中那些包含在指定 collection 中的元素。
retainAll(Collection<?>) - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 false。
retainAll(Collection<?>) - 接口 java.util.List 中的方法
仅在列表中保留指定 collection 中所包含的元素（可选操作）。
retainAll(Collection<?>) - 接口 java.util.Set 中的方法
仅保留 set 中那些包含在指定 collection 中的元素（可选操作）。
retainAll(Collection<?>) - 类 java.util.Vector 中的方法
在此向量中仅保留包含在指定 Collection 中的元素。
Retention - java.lang.annotation 中的 注释类型
指示注释类型的注释要保留多久。
RetentionPolicy - java.lang.annotation 中的 枚举
注释保留策略。
retransformClasses(Class<?>...) - 接口 java.lang.instrument.Instrumentation 中的方法
重转换提供的类集。
RetrievalMethod - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML RetrievalMethod 元素的表示形式。
retrieveAllRoles() - 接口 javax.management.relation.Relation 中的方法
返回关系中的所有角色，不检查读取模式。
retrieveAllRoles() - 类 javax.management.relation.RelationSupport 中的方法
返回关系中的所有角色，不检查读取模式。
retryReferral() - 异常 javax.naming.ReferralException 中的方法
检索当前正被处理的引用。
RETURN_GENERATED_KEYS - 接口 java.sql.Statement 中的静态变量
该常量指示生成的键应该可用于获取。
return_value() - 类 org.omg.CORBA.Request 中的方法
返回包含方法结果值的 Any 对象。
REUSE - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否重用以前已验证过的会话信息。
REV - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
revalidate() - 类 java.awt.Component.BltBufferStrategy 中的方法
如果绘制缓冲区已经丢失，则恢复它
revalidate() - 类 java.awt.Component.FlipBufferStrategy 中的方法
如果绘制缓冲区已丢失，则将其还原。
revalidate() - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
revalidate() - 类 javax.swing.JComponent 中的方法
支持推迟的自动布局。
revalidate() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
revalidate() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
REVERB - 类 javax.sound.sampled.EnumControl.Type 中的静态变量
表示对一组可能的回响设置的控件。
REVERB_RETURN - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上后回响 (post-reverb) 音量的控件。
REVERB_SEND - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上预回响 (pre-reverb) 音量的控件。
ReverbType - javax.sound.sampled 中的 类
ReverbType 类提供用于访问应用于音频信号的各种回响设置的方法。
ReverbType(String, int, float, int, float, int) - 类 javax.sound.sampled.ReverbType 的构造方法
构造具有指定回响参数值的新回响类型。
reverse(int) - 类 java.lang.Integer 中的静态方法
返回通过反转指定 int 值的二进制补码表示形式中位的顺序而获得的值。
reverse(long) - 类 java.lang.Long 中的静态方法
返回通过反转指定 long 值的二进制补码表示形式中位的顺序而获得的值。
reverse() - 类 java.lang.StringBuffer 中的方法
reverse() - 类 java.lang.StringBuilder 中的方法
reverse(List<?>) - 类 java.util.Collections 中的静态方法
反转指定列表中元素的顺序。
REVERSE_LANDSCAPE - 类 java.awt.print.PageFormat 中的静态变量
原点位于纸张的右上方，x 的方向从上到下，y 的方向从右到左。
REVERSE_LANDSCAPE - 类 javax.print.attribute.standard.OrientationRequested 中的静态变量
沿介质的长边描绘内容，但方式正好与横向相反。
REVERSE_PORTRAIT - 类 javax.print.attribute.standard.OrientationRequested 中的静态变量
沿介质的短边描绘内容，但方式正好与纵向相反。
reverseBytes(char) - 类 java.lang.Character 中的静态方法
返回通过反转指定 char 值中的字节顺序而获得的值。
reverseBytes(int) - 类 java.lang.Integer 中的静态方法
返回通过反转指定 int 值的二进制补码表示形式中字节的顺序而获得的值。
reverseBytes(long) - 类 java.lang.Long 中的静态方法
返回通过反转指定 long 值的二进制补码表示形式中字节的顺序而获得的值。
reverseBytes(short) - 类 java.lang.Short 中的静态方法
返回通过反转指定 short 值的二进制补码表示形式中字节的顺序而获得的值。
reverseOrder() - 类 java.util.Collections 中的静态方法
返回一个比较器，它强行逆转实现了 Comparable 接口的对象 collection 的自然顺序。
reverseOrder(Comparator<T>) - 类 java.util.Collections 中的静态方法
返回一个比较器，它强行逆转指定比较器的顺序。
REVERT - 类 javax.swing.JFormattedTextField 中的静态变量
标识丢失焦点时，应该将编辑的值恢复为 JFormattedTextField 上所设当前值的常量。
revokeService(Class, BeanContextServiceProvider, boolean) - 接口 java.beans.beancontext.BeanContextServices 中的方法
希望从此上下文中移除当前已注册服务的 BeanContextServiceProvider 可以通过调用此方法实现移除。
revokeService(Class, BeanContextServiceProvider, boolean) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
移除服务。
rewind() - 类 java.nio.Buffer 中的方法
重绕此缓冲区。
rewind() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 将内部指针移动到第一个组件。
rewind() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynStructStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynValueStub 中的方法
等效于 seek(0)。
rewind() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
等效于 seek(0)。
RFC1779 - 类 javax.security.auth.x500.X500Principal 中的静态变量
标识名的 RFC 1779 字符串格式。
RFC2253 - 类 javax.security.auth.x500.X500Principal 中的静态变量
标识名的 RFC 2253 字符串格式。
RGBImageFilter - java.awt.image 中的 类
此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。
RGBImageFilter() - 类 java.awt.image.RGBImageFilter 的构造方法
RGBtoHSB(int, int, int, float[]) - 类 java.awt.Color 中的静态方法
将默认 RGB 模式指定的颜色分量转换为等价的色调、饱和度和亮度值的集合，这三个值是 HSB 模型的三个分量。
RIGHT - 类 java.awt.Event 中的静态变量
Right Arrow 键，一个非 ASCII 操作键。
RIGHT - 类 java.awt.FlowLayout 中的静态变量
此值指示每一行组件都应该是右对齐的。
right - 类 java.awt.Insets 中的变量
右边的 inset。
RIGHT - 类 java.awt.Label 中的静态变量
指示标签文本应右对齐。
right - 类 javax.swing.border.EmptyBorder 中的变量
RIGHT - 类 javax.swing.border.TitledBorder 中的静态变量
将标题文本置于边框线的右边。
RIGHT - 类 javax.swing.JSplitPane 中的静态变量
用于添加一个 Component 到另一个 Component 的右边。
RIGHT - 接口 javax.swing.SwingConstants 中的静态变量
用于指定框右侧位置的框方向常量。
RIGHT_ALIGNMENT - 类 java.awt.Component 中的静态变量
getAlignmentX 的易于使用的常量。
RIGHT_OUTER_JOIN - 接口 javax.sql.rowset.JoinRowSet 中的静态变量
ANSI 风格的 JOIN，提供两个表之间的右外联合 (right outer join)。
RIGHT_TO_LEFT - 类 java.awt.ComponentOrientation 中的静态变量
各项从右到左布局，各行从上到下，示例：阿拉伯语、希伯来语。
rightButton - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
用于快速切换右边组件的按钮。
rightChildIndent - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
添加到 leftChildIndent 以确定将绘制单元格内容的位置的距离。
rightComponent - 类 javax.swing.JSplitPane 中的变量
右边或者底部的组件。
RightIndent - 类 javax.swing.text.StyleConstants 中的静态变量
段落右边的缩进量。
rightKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
rightKey - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
rightKey - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
已过时。 从 Java 2 平台 v1.3 开始。
rint(double) - 类 java.lang.Math 中的静态方法
返回最接近参数并等于某一整数的 double 值。
rint(double) - 类 java.lang.StrictMath 中的静态方法
返回最接近参数并等于某一整数的 double 值。
RIPEMD160 - 接口 javax.xml.crypto.dsig.DigestMethod 中的静态变量
RIPEMD-160 摘要方法的算法 URI。
RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE - 类 javax.management.remote.rmi.RMIConnectorServer 中的静态变量
属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIClientSocketFactory。
RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE - 类 javax.management.remote.rmi.RMIConnectorServer 中的静态变量
属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIServerSocketFactory。
RMIClassLoader - java.rmi.server 中的 类
RMIClassLoader 包含支持用 RMI 进行动态类加载的静态方法。
RMIClassLoaderSpi - java.rmi.server 中的 类
RMIClassLoaderSpi 是 RMIClassLoader 的服务提供者接口。
RMIClassLoaderSpi() - 类 java.rmi.server.RMIClassLoaderSpi 的构造方法
RMIClientSocketFactory - java.rmi.server 中的 接口
RMIClientSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的客户机套接字。
RMIConnection - javax.management.remote.rmi 中的 接口
RMI 对象，用于将 MBeanServer 请求从客户端转发到其位于服务器端的 MBeanServer 实现。
RMIConnectionImpl - javax.management.remote.rmi 中的 类
RMIConnection 接口的实现。
RMIConnectionImpl(RMIServerImpl, String, ClassLoader, Subject, Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnectionImpl 的构造方法
构造新的 RMIConnection。
RMIConnectionImpl_Stub - javax.management.remote.rmi 中的 类
RMIConnectionImpl_Stub(RemoteRef) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 的构造方法
RMIConnector - javax.management.remote.rmi 中的 类
一个到远程 RMI 连接器的连接。
RMIConnector(JMXServiceURL, Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnector 的构造方法
构造一个将 RMI 连接器服务器连接到给定地址的 RMIConnector。
RMIConnector(RMIServer, Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnector 的构造方法
用给定的 RMI stub 构造一个 RMIConnector。
RMIConnectorServer - javax.management.remote.rmi 中的 类
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。
RMIConnectorServer(JMXServiceURL, Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnectorServer 的构造方法
建立 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - 类 javax.management.remote.rmi.RMIConnectorServer 的构造方法
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL, Map<String, ?>, RMIServerImpl, MBeanServer) - 类 javax.management.remote.rmi.RMIConnectorServer 的构造方法
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMICustomMaxStreamFormat - org.omg.IOP 中的 接口
org/omg/IOP/RMICustomMaxStreamFormat.java。
RMIFailureHandler - java.rmi.server 中的 接口
RMIFailureHandler 可以通过 RMISocketFactory.setFailureHandler 调用注册。
RMIIIOPServerImpl - javax.management.remote.rmi 中的 类
一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
RMIIIOPServerImpl(Map<String, ?>) - 类 javax.management.remote.rmi.RMIIIOPServerImpl 的构造方法
创建新的 RMIServerImpl。
RMIJRMPServerImpl - javax.management.remote.rmi 中的 类
一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。
RMIJRMPServerImpl(int, RMIClientSocketFactory, RMIServerSocketFactory, Map<String, ?>) - 类 javax.management.remote.rmi.RMIJRMPServerImpl 的构造方法
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。
RMISecurityException - java.rmi 中的 异常
已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
RMISecurityException(String) - 异常 java.rmi.RMISecurityException 的构造方法
已过时。 无替换版本
RMISecurityException(String, String) - 异常 java.rmi.RMISecurityException 的构造方法
已过时。 无替换版本
RMISecurityManager - java.rmi 中的 类
由使用下载的代码的 RMI 应用程序使用的 SecurityManager 的子类。
RMISecurityManager() - 类 java.rmi.RMISecurityManager 的构造方法
构造新的 RMISecurityManager。
RMIServer - javax.management.remote.rmi 中的 接口
用于建立到 RMI 连接器的连接的 RMI 对象。
RMIServerImpl - javax.management.remote.rmi 中的 类
表示连接器服务器的 RMI 对象。
RMIServerImpl(Map<String, ?>) - 类 javax.management.remote.rmi.RMIServerImpl 的构造方法
构造一个新的 RMIServerImpl。
RMIServerImpl_Stub - javax.management.remote.rmi 中的 类
RMIServerImpl_Stub(RemoteRef) - 类 javax.management.remote.rmi.RMIServerImpl_Stub 的构造方法
RMIServerSocketFactory - java.rmi.server 中的 接口
RMIServerSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的服务器套接字。
RMISocketFactory - java.rmi.server 中的 类
RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。
RMISocketFactory() - 类 java.rmi.server.RMISocketFactory 的构造方法
构造一个 RMISocketFactory。
Robot - java.awt 中的 类
此类用于为测试自动化、自运行演示程序和其他需要控制鼠标和键盘的应用程序生成本机系统输入事件。
Robot() - 类 java.awt.Robot 的构造方法
在基本屏幕坐标系中构造一个 Robot 对象。
Robot(GraphicsDevice) - 类 java.awt.Robot 的构造方法
为给定屏幕设备创建一个 Robot 。
Role - javax.management.relation 中的 类
表示角色：包括角色名称和引用的 MBean（通过其 ObjectName）。
Role(String, List<ObjectName>) - 类 javax.management.relation.Role 的构造方法
创建一个新的 Role 对象。
ROLE_CARDINALITY_INFINITY - 类 javax.management.relation.RoleInfo 中的静态变量
指定无限的容量。
ROLE_NOT_READABLE - 类 javax.management.relation.RoleStatus 中的静态变量
试图读取不可读属性时的问题类型。
ROLE_NOT_WRITABLE - 类 javax.management.relation.RoleStatus 中的静态变量
试图更新不可写属性时的问题类型。
RoleInfo - javax.management.relation 中的 类
RoleInfo 概括介绍关系类型中的角色。
RoleInfo(String, String, boolean, boolean, int, int, String) - 类 javax.management.relation.RoleInfo 的构造方法
构造方法。
RoleInfo(String, String, boolean, boolean) - 类 javax.management.relation.RoleInfo 的构造方法
构造方法。
RoleInfo(String, String) - 类 javax.management.relation.RoleInfo 的构造方法
构造方法。
RoleInfo(RoleInfo) - 类 javax.management.relation.RoleInfo 的构造方法
复制构造方法。
RoleInfoNotFoundException - javax.management.relation 中的 异常
给定的关系类型中不存在带指定名称的角色信息时引发此异常。
RoleInfoNotFoundException() - 异常 javax.management.relation.RoleInfoNotFoundException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RoleInfoNotFoundException(String) - 异常 javax.management.relation.RoleInfoNotFoundException 的构造方法
异常中放置了给定消息的构造方法。
RoleList - javax.management.relation 中的 类
RoleList 表示角色（Role 对象）的列表。
RoleList() - 类 javax.management.relation.RoleList 的构造方法
构造一个空的 RoleList。
RoleList(int) - 类 javax.management.relation.RoleList 的构造方法
构造一个具有指定初始容量的空 RoleList。
RoleList(List<Role>) - 类 javax.management.relation.RoleList 的构造方法
构造一个包含指定 List 元素的 RoleList，这些元素按 List 迭代器返回的顺序排列。
RoleNotFoundException - javax.management.relation 中的 异常
关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。
RoleNotFoundException() - 异常 javax.management.relation.RoleNotFoundException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RoleNotFoundException(String) - 异常 javax.management.relation.RoleNotFoundException 的构造方法
异常中放置了给定消息的构造方法。
RoleResult - javax.management.relation 中的 类
表示对一个关系的几个角色多个访问的结果（可以是读取，也可以是写入）。
RoleResult(RoleList, RoleUnresolvedList) - 类 javax.management.relation.RoleResult 的构造方法
构造方法。
RoleStatus - javax.management.relation 中的 类
此类描述访问某个角色时可能遇到的各种问题。
RoleStatus() - 类 javax.management.relation.RoleStatus 的构造方法
RoleUnresolved - javax.management.relation 中的 类
表示未解析的角色：由于存在问题而无法从关系中检索到的角色。
RoleUnresolved(String, List<ObjectName>, int) - 类 javax.management.relation.RoleUnresolved 的构造方法
构造方法。
RoleUnresolvedList - javax.management.relation 中的 类
RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。
RoleUnresolvedList() - 类 javax.management.relation.RoleUnresolvedList 的构造方法
构造一个空的 RoleUnresolvedList。
RoleUnresolvedList(int) - 类 javax.management.relation.RoleUnresolvedList 的构造方法
构造一个具有指定初始容量的空 RoleUnresolvedList。
RoleUnresolvedList(List<RoleUnresolved>) - 类 javax.management.relation.RoleUnresolvedList 的构造方法
构造一个包含指定 List 元素的 RoleUnresolvedList，这些元素按 List 迭代器返回的顺序排列。
roleValueToString(List<ObjectName>) - 类 javax.management.relation.Role 中的静态方法
返回给定角色值的字符串。
roll(int, boolean) - 类 java.util.Calendar 中的方法
在给定的时间字段上添加或减去（上/下）单个时间单元，不更改更大的字段。
roll(int, int) - 类 java.util.Calendar 中的方法
向指定日历字段添加指定（有符号的）时间量，不更改更大的字段。
roll(int, boolean) - 类 java.util.GregorianCalendar 中的方法
在给定的时间字段上添加或减去（上/下）单个时间单元，不更改更大的字段。
roll(int, int) - 类 java.util.GregorianCalendar 中的方法
向指定日历字段添加有符号的时间量，不更改更大的字段。
rollback() - 接口 java.sql.Connection 中的方法
取消在当前事务中进行的所有更改，并释放此 Connection 对象当前持有的所有数据库锁。
rollback(Savepoint) - 接口 java.sql.Connection 中的方法
取消所有设置给定 Savepoint 对象之后进行的更改。
rollback() - 接口 javax.sql.rowset.CachedRowSet 中的方法
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
rollback(Savepoint) - 接口 javax.sql.rowset.CachedRowSet 中的方法
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
rollback() - 接口 javax.sql.rowset.JdbcRowSet 中的方法
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
rollback(Savepoint) - 接口 javax.sql.rowset.JdbcRowSet 中的方法
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
rollback() - 接口 javax.sql.rowset.spi.TransactionalWriter 中的方法
撤消在当前事务中进行的所有更改。
rollback(Savepoint) - 接口 javax.sql.rowset.spi.TransactionalWriter 中的方法
撤消在给定 Savepoint 对象之前所进行的当前事务中的所有更改。
rollback(Xid) - 接口 javax.transaction.xa.XAResource 中的方法
通知资源管理器回滚代表事务分支执行的工作。
ROLLOVER - 类 javax.swing.DefaultButtonModel 中的静态变量
标识位掩码中“翻转的”位，该位指示鼠标位于按钮上。
ROLLOVER_ENABLED_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识从启用翻转到禁用翻转或者从禁用翻转到启用翻转的更改。
ROLLOVER_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对光标移动到按钮上时使用的图标的更改。
ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对光标移动到按钮上并选定该按钮时使用的图标的更改。
rolloverColumnUpdated(int, int) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
每次更新表标题中的翻转列时调用此方法。
rolloverListener - 类 javax.swing.plaf.metal.MetalToolBarUI 中的变量
此受保护的字段是特定于实现的。
ROMAN_BASELINE - 类 java.awt.font.GraphicAttribute 中的静态变量
将图形的原点与行的罗马字体基线对齐。
ROMAN_BASELINE - 类 java.awt.Font 中的静态变量
布置文本时，在大多数 Roman 脚本中使用的基线。
ROOT - 类 java.util.Locale 中的静态变量
用于表示根语言环境的有用常量。
root - 类 javax.swing.tree.DefaultTreeModel 中的变量
树的根。
ROOT_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
一个专用窗格，带有玻璃窗格和作为其子窗格的分层窗格。
ROOT_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
RootPane 的 region。
ROOT_PANE_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
ROOT_VISIBLE_PROPERTY - 类 javax.swing.JTree 中的静态变量
rootVisible 的绑定属性名称。
rootException - 异常 javax.naming.NamingException 中的变量
包含导致抛出此 NamingException 的原始异常。
rootPane - 类 javax.swing.JApplet 中的变量
rootPane - 类 javax.swing.JDialog 中的变量
rootPane - 类 javax.swing.JFrame 中的变量
JRootPane 实例管理此窗体的 contentPane 和可选的 menuBar，以及 glassPane。
rootPane - 类 javax.swing.JInternalFrame 中的变量
JRootPane 实例，它管理此内部窗体的内容窗格和可选菜单栏以及玻璃窗格（glass pane）。
rootPane - 类 javax.swing.JWindow 中的变量
管理此框架的 contentPane 和可选 menuBar 以及 glassPane 的 JRootPane 实例。
rootPaneCheckingEnabled - 类 javax.swing.JApplet 中的变量
如果为 true，则对 add 和 setLayout 的调用将转发给 contentPane。
rootPaneCheckingEnabled - 类 javax.swing.JDialog 中的变量
如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。
rootPaneCheckingEnabled - 类 javax.swing.JFrame 中的变量
如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。
rootPaneCheckingEnabled - 类 javax.swing.JInternalFrame 中的变量
如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。
rootPaneCheckingEnabled - 类 javax.swing.JWindow 中的变量
如果为 true，则对 add 和 setLayout 的调用将转发到 contentPane。
RootPaneContainer - javax.swing 中的 接口
此接口由具有单个 JRootPane 子组件的组件来实现，这些子组件包括：JDialog、JFrame、JWindow、JApplet、JInternalFrame。
RootPaneUI - javax.swing.plaf 中的 类
JRootPane 的可插入外观界面。
RootPaneUI() - 类 javax.swing.plaf.RootPaneUI 的构造方法
rootVisible - 类 javax.swing.JTree 中的变量
如果显示根节点，则为 true；如果其子节点为最高可见节点，则为 false。
rootVisible - 类 javax.swing.tree.AbstractLayoutCache 中的变量
如果显示根节点，则为 True，如果其子节点是最高可视节点，则为 false。
rotate(double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与旋转变换。
rotate(double, double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与绕锚点旋转坐标的变换。
rotate(double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与根据旋转向量旋转坐标的变换。
rotate(double, double, double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与根据旋转向量绕锚点旋转坐标的变换。
rotate(double) - 类 java.awt.Graphics2D 中的方法
将当前的 Graphics2D Transform 与旋转转换连接。
rotate(double, double, double) - 类 java.awt.Graphics2D 中的方法
将当前的 Graphics2D Transform 与平移后的旋转转换连接。
rotate(List<?>, int) - 类 java.util.Collections 中的静态方法
根据指定的距离轮换指定列表中的元素。
rotateInsets(Insets, Insets, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的静态方法
rotateLeft(int, int) - 类 java.lang.Integer 中的静态方法
返回根据指定的位数循环左移指定的 int 值的二进制补码表示形式而得到的值。
rotateLeft(long, int) - 类 java.lang.Long 中的静态方法
返回根据指定的位数循环左移指定的 long 值的二进制补码表示形式而得到的值。
rotateRight(int, int) - 类 java.lang.Integer 中的静态方法
返回根据指定的位数循环右移指定的 int 值的二进制补码表示形式而得到的值。
rotateRight(long, int) - 类 java.lang.Long 中的静态方法
返回根据指定的位数循环右移指定的 long 值的二进制补码表示形式而得到的值。
rotateTabRuns(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
rotateTabRuns(int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 中的方法
round(float) - 类 java.lang.Math 中的静态方法
返回最接近参数的 int。
round(double) - 类 java.lang.Math 中的静态方法
返回最接近参数的 long。
round(float) - 类 java.lang.StrictMath 中的静态方法
返回最接近参数的 int。
round(double) - 类 java.lang.StrictMath 中的静态方法
返回最接近参数的 long。
round(MathContext) - 类 java.math.BigDecimal 中的方法
返回根据 MathContext 设置进行舍入后的 BigDecimal。
ROUND_CEILING - 类 java.math.BigDecimal 中的静态变量
接近正无穷大的舍入模式。
ROUND_DOWN - 类 java.math.BigDecimal 中的静态变量
接近零的舍入模式。
ROUND_FLOOR - 类 java.math.BigDecimal 中的静态变量
接近负无穷大的舍入模式。
ROUND_HALF_DOWN - 类 java.math.BigDecimal 中的静态变量
向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则为上舍入的舍入模式。
ROUND_HALF_EVEN - 类 java.math.BigDecimal 中的静态变量
向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则向相邻的偶数舍入。
ROUND_HALF_UP - 类 java.math.BigDecimal 中的静态变量
向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则为向上舍入的舍入模式。
ROUND_UNNECESSARY - 类 java.math.BigDecimal 中的静态变量
断言请求的操作具有精确的结果，因此不需要舍入。
ROUND_UP - 类 java.math.BigDecimal 中的静态变量
舍入远离零的舍入模式。
roundedCorners - 类 javax.swing.border.LineBorder 中的变量
RoundEnvironment - javax.annotation.processing 中的 接口
注释处理工具框架将提供一个注释处理器和一个实现此接口的对象，这样处理器可以查询有关注释处理的 round 的信息。
RoundingMode - java.math 中的 枚举
为可能丢弃精度的数值操作指定一种舍入行为。
RoundRectangle2D - java.awt.geom 中的 类
RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。
RoundRectangle2D() - 类 java.awt.geom.RoundRectangle2D 的构造方法
这是一个无法直接实例化的抽象类。
RoundRectangle2D.Double - java.awt.geom 中的 类
Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
RoundRectangle2D.Double() - 类 java.awt.geom.RoundRectangle2D.Double 的构造方法
构造一个新 RoundRectangle2D，并将其初始化为：位置 (0.0,0)、大小 (0.0,0.0)、圆角弧半径 0.0。
RoundRectangle2D.Double(double, double, double, double, double, double) - 类 java.awt.geom.RoundRectangle2D.Double 的构造方法
根据指定 double 坐标构造并初始化 RoundRectangle2D。
RoundRectangle2D.Float - java.awt.geom 中的 类
Float 类定义一个所有圆角都使用 float 坐标指定的矩形。
RoundRectangle2D.Float() - 类 java.awt.geom.RoundRectangle2D.Float 的构造方法
构造一个新 RoundRectangle2D，并将其初始化为：位置 (0.0,0)、大小 (0.0,0.0)、圆角弧半径 0.0。
RoundRectangle2D.Float(float, float, float, float, float, float) - 类 java.awt.geom.RoundRectangle2D.Float 的构造方法
根据指定 float 坐标构造并初始化 RoundRectangle2D。
ROW_HEADER - 类 javax.accessibility.AccessibleRole 中的静态变量
数据行的头。
ROW_HEADER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识沿视口左边左上角和左下角之间的区域。
ROW_HEIGHT_PROPERTY - 类 javax.swing.JTree 中的静态变量
rowHeight 的绑定属性名称。
rowAtPoint(Point) - 类 javax.swing.JTable 中的方法
返回 point 所在的行索引；如果结果不在 [0, getRowCount()-1] 范围内，则返回 -1。
rowChanged(RowSetEvent) - 接口 javax.sql.RowSetListener 中的方法
通知已注册侦听器 RowSet 对象的其中一行发生了更改。
rowDeleted() - 接口 java.sql.ResultSet 中的方法
获取是否已删除某行。
RowFilter<M,I> - javax.swing 中的 类
RowFilter 用于从模型中过滤条目，使得这些条目不会在视图中显示。
RowFilter() - 类 javax.swing.RowFilter 的构造方法
RowFilter.ComparisonType - javax.swing 中的 枚举
由某些默认 RowFilter 支持的可能比较值的枚举。
RowFilter.Entry<M,I> - javax.swing 中的 类
一个传递给 RowFilter 实例的 Entry 对象，允许过滤器获取该条目的数据的值，以确定是否应该显示该条目。
RowFilter.Entry() - 类 javax.swing.RowFilter.Entry 的构造方法
创建一个 Entry。
rowHead - 类 javax.swing.ScrollPaneLayout 中的变量
子级行标题。
rowHeader - 类 javax.swing.JScrollPane 中的变量
行标题子级。
rowHeight - 类 javax.swing.JTable 中的变量
表中每一行的高度，以像素为单位。
rowHeight - 类 javax.swing.JTree 中的变量
用于每个显示行的高度。
rowHeight - 类 javax.swing.tree.AbstractLayoutCache 中的变量
每行的高度。
rowHeights - 类 java.awt.GridBagLayout 中的变量
此字段保持对行最小高度的重写。
RowId - java.sql 中的 接口
SQL ROWID 值在 Java 编程语言中的表示形式（映射）。
ROWID - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 ROWID 的 Java 编程语言中的常量（有时称为类型代码）。
RowIdLifetime - java.sql 中的 枚举
RowId 生存期值的枚举。
rowInserted() - 接口 java.sql.ResultSet 中的方法
获取当前行是否已有插入。
rowMapper - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
提供给定路径的行。
RowMapper - javax.swing.tree 中的 接口
定义针对将树中的路径转换为显示行的对象的要求。
rowMargin - 类 javax.swing.JTable 中的变量
每行中单元格之间间距的高度，以像素为单位。
ROWS - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
rowsDeleted(int, int) - 类 javax.swing.DefaultRowSorter 中的方法
当行已经从指定范围（包括）内的底层模型中被删除时，调用此方法。
rowsDeleted(int, int) - 类 javax.swing.RowSorter 中的方法
当行已经从指定范围（包括）内的底层模型中被删除时，调用此方法。
rowSelectionAllowed - 类 javax.swing.JTable 中的变量
如果行选择在此表中是允许的，则返回 true。
RowSet - javax.sql 中的 接口
该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。
ROWSET_SYNC_PROVIDER - 类 javax.sql.rowset.spi.SyncFactory 中的静态变量
用于同步提供者实现名称的标准属性 id。
ROWSET_SYNC_PROVIDER_VERSION - 类 javax.sql.rowset.spi.SyncFactory 中的静态变量
用于同步提供者实现版本标记的标准属性 id。
ROWSET_SYNC_VENDOR - 类 javax.sql.rowset.spi.SyncFactory 中的静态变量
用于同步提供者实现供应商名称的标准属性 id。
rowSetChanged(RowSetEvent) - 接口 javax.sql.RowSetListener 中的方法
通知已注册侦听器给定 RowSetEvent 对象中的 RowSet 对象已更改其全部内部。
RowSetEvent - javax.sql 中的 类
RowSet 对象发生事件时生成的 Event 对象。
RowSetEvent(RowSet) - 类 javax.sql.RowSetEvent 的构造方法
构造一个 RowSetEvent 对象，并使用给定的 RowSet 对象进行初始化。
RowSetInternal - javax.sql 中的 接口
为了将自身呈现给 RowSetReader 或 RowSetWriter 对象的 RowSet 对象实现应实现该接口。
RowSetListener - javax.sql 中的 接口
要在 RowSet 对象的生命周期内发生重要事件时得到通知的组件必须实现该接口。
RowSetMetaData - javax.sql 中的 接口
该对象包含关于 RowSet 对象的列的信息。
RowSetMetaDataImpl - javax.sql.rowset 中的 类
为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。
RowSetMetaDataImpl() - 类 javax.sql.rowset.RowSetMetaDataImpl 的构造方法
rowSetPopulated(RowSetEvent, int) - 接口 javax.sql.rowset.CachedRowSet 中的方法
通知已注册侦听器给定 RowSetEvent 对象中的某个 RowSet 对象已经填充了多个附加行。
RowSetReader - javax.sql 中的 接口
该设施供非连接 RowSet 对象调用以填充数据行。
RowSetWarning - javax.sql.rowset 中的 异常
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。
RowSetWarning(String) - 异常 javax.sql.rowset.RowSetWarning 的构造方法
用给定的 reason 值构造 RowSetWarning 对象；SQLState 默认为 null，vendorCode 默认为 0。
RowSetWarning() - 异常 javax.sql.rowset.RowSetWarning 的构造方法
构造一个默认的 RowSetWarning 对象。
RowSetWarning(String, String) - 异常 javax.sql.rowset.RowSetWarning 的构造方法
构造一个 RowSetWarning 对象，并使用给定的 reason 和 SQLState 值进行初始化。
RowSetWarning(String, String, int) - 异常 javax.sql.rowset.RowSetWarning 的构造方法
构造一个完全指定的 RowSetWarning 对象，并使用给定的 reason、SQLState 和 vendorCode 值进行初始化。
RowSetWriter - javax.sql 中的 接口
实现 RowSetWriter 接口的对象，称为 writer。
rowsInserted(int, int) - 类 javax.swing.DefaultRowSorter 中的方法
当行已经插入到指定范围（包括）内的底层模型时，调用此方法。
rowsInserted(int, int) - 类 javax.swing.RowSorter 中的方法
当行已经插入到指定范围（包括）内的底层模型时，调用此方法。
RowSorter<M> - javax.swing 中的 类
RowSorter 提供排序和过滤的基础。
RowSorter() - 类 javax.swing.RowSorter 的构造方法
创建一个RowSorter。
RowSorter.SortKey - javax.swing 中的 类
SortKey 描述特定列的排序顺序。
RowSorter.SortKey(int, SortOrder) - 类 javax.swing.RowSorter.SortKey 的构造方法
使用指定的排序顺序创建指定列的 SortKey。
RowSorterEvent - javax.swing.event 中的 类
RowSorterEvent 提供 RowSorter 的更改通知。
RowSorterEvent(RowSorter) - 类 javax.swing.event.RowSorterEvent 的构造方法
创建类型为 SORT_ORDER_CHANGED 的 RowSorterEvent。
RowSorterEvent(RowSorter, RowSorterEvent.Type, int[]) - 类 javax.swing.event.RowSorterEvent 的构造方法
创建一个 RowSorterEvent。
RowSorterEvent.Type - javax.swing.event 中的 枚举
RowSorterEvent 类型的枚举。
RowSorterListener - javax.swing.event 中的 接口
通知 RowSorterListener 对 RowSorter 的更改。
ROWSPAN - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
rowsRemoved(TableModelEvent) - 类 javax.swing.table.DefaultTableModel 中的方法
等效于 fireTableChanged。
rowsUpdated(int, int) - 类 javax.swing.DefaultRowSorter 中的方法
当行已经在指定范围（包括）内的底层模型中被更改时，调用此方法。
rowsUpdated(int, int, int) - 类 javax.swing.DefaultRowSorter 中的方法
当行中的列已经在指定范围内的底层模型中被更新时，调用此方法。
rowsUpdated(int, int) - 类 javax.swing.RowSorter 中的方法
当行已经在指定范围（包括）内的底层模型中被更改时，调用此方法。
rowsUpdated(int, int, int) - 类 javax.swing.RowSorter 中的方法
当行中的列已经在指定范围内的底层模型中被更新时，调用此方法。
rowUpdated() - 接口 java.sql.ResultSet 中的方法
获取是否已更新当前行。
rowWeights - 类 java.awt.GridBagLayout 中的变量
此字段保持对行权重的重写。
RSA_SHA1 - 接口 javax.xml.crypto.dsig.SignatureMethod 中的静态变量
RSAwithSHA1 (PKCS #1) 签名方法的算法 URI。
RSA_TYPE - 接口 javax.xml.crypto.dsig.keyinfo.KeyValue 中的静态变量
标识 RSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#RSAKeyValue。
RSAKey - java.security.interfaces 中的 接口
RSA 公用密钥或专用密钥的接口。
RSAKeyGenParameterSpec - java.security.spec 中的 类
此类指定用于生成 RSA 密钥对的参数集。
RSAKeyGenParameterSpec(int, BigInteger) - 类 java.security.spec.RSAKeyGenParameterSpec 的构造方法
构造一个具有给定密钥大小和公用指数值的新的 RSAParameterSpec 对象。
RSAMultiPrimePrivateCrtKey - java.security.interfaces 中的 接口
如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
RSAMultiPrimePrivateCrtKeySpec - java.security.spec 中的 类
如 PKCS#1 v2.1 中所定义的，此类为了提高效率，使用 Chinese Remainder Theorem (CRT) 信息值指定 RSA 多素数专用密钥。
RSAMultiPrimePrivateCrtKeySpec(BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, RSAOtherPrimeInfo[]) - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 的构造方法
给定系数、publicExponent、privateExponent、primeP、primeQ、primeExponentP、primeExponentQ、crtCoefficient 和如 PKCS#1 v2.1 中所定义的 otherPrimeInfo，创建一个新的 RSAMultiPrimePrivateCrtKeySpec。
RSAOtherPrimeInfo - java.security.spec 中的 类
此类表示 RSA 的 OtherPrimeInfo 结构中的三元组（素数、指数和素数），如 PKCS#1 v2.1 中所定义的。
RSAOtherPrimeInfo(BigInteger, BigInteger, BigInteger) - 类 java.security.spec.RSAOtherPrimeInfo 的构造方法
给定如 PKCS#1 中所定义的素数、primeExponent 和 crtCoefficient，创建一个新的 RSAOtherPrimeInfo。
RSAPrivateCrtKey - java.security.interfaces 中的 接口
如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
RSAPrivateCrtKeySpec - java.security.spec 中的 类
为了提高效率，此类根据 PKCS#1 标准所定义的，使用 Chinese Remainder Theorem（中国剩余定理，CRT）信息值指定一个 RSA 专用密钥。
RSAPrivateCrtKeySpec(BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger) - 类 java.security.spec.RSAPrivateCrtKeySpec 的构造方法
给定在 PKCS#1 v2.1 中所定义的系数、publicExponent、privateExponent、 primeP、primeQ、primeExponentP、primeExponentQ 和 crtCoefficient，创建一个新的 RSAPrivateCrtKeySpec。
RSAPrivateKey - java.security.interfaces 中的 接口
RSA 专用密钥的接口。
RSAPrivateKeySpec - java.security.spec 中的 类
此类指定 RSA 专用密钥。
RSAPrivateKeySpec(BigInteger, BigInteger) - 类 java.security.spec.RSAPrivateKeySpec 的构造方法
创建一个新的 RSAPrivateKeySpec。
RSAPublicKey - java.security.interfaces 中的 接口
RSA 公用密钥的接口。
RSAPublicKeySpec - java.security.spec 中的 类
此类指定 RSA 公用密钥。
RSAPublicKeySpec(BigInteger, BigInteger) - 类 java.security.spec.RSAPublicKeySpec 的构造方法
创建一个新的 RSAPublicKeySpec。
RTFEditorKit - javax.swing.text.rtf 中的 类
这是对 RTF 编辑功能的默认实现。
RTFEditorKit() - 类 javax.swing.text.rtf.RTFEditorKit 的构造方法
构造一个 RTFEditorKit。
RuleBasedCollator - java.text 中的 类
RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。
RuleBasedCollator(String) - 类 java.text.RuleBasedCollator 的构造方法
RuleBasedCollator 构造方法。
RULER - 类 javax.accessibility.AccessibleRole 中的静态变量
RULER 是用于测量距离的对象
run() - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
此类的 runnable 方法。
run() - 接口 java.lang.Runnable 中的方法
使用实现接口 Runnable 的对象创建一个线程时，启动该线程将导致在独立执行的线程中调用对象的 run 方法。
run() - 类 java.lang.Thread 中的方法
如果该线程是使用独立的 Runnable 运行对象构造的，则调用该 Runnable 对象的 run 方法；否则，该方法不执行任何操作并返回。
run() - 接口 java.security.PrivilegedAction 中的方法
执行计算。
run() - 接口 java.security.PrivilegedExceptionAction 中的方法
执行计算。
run() - 类 java.util.concurrent.FutureTask 中的方法
除非已将此 Future 取消，否则将其设置为其计算的结果。
run() - 接口 java.util.concurrent.RunnableFuture 中的方法
在未被取消的情况下，将此 Future 设置为计算的结果。
run() - 类 java.util.TimerTask 中的方法
此计时器任务要执行的操作。
run() - 类 javax.swing.SwingWorker 中的方法
将此 Future 设置为计算的结果，除非它已经被取消。
run() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
更新 ChildState。
run(InputStream, OutputStream, OutputStream, String...) - 接口 javax.tools.Tool 中的方法
使用给定 I/O 通道和参数运行工具。
run() - 类 org.omg.CORBA.ORB 中的方法
在 ORB 已完成关闭过程前（该过程始于某些线程调用 shutdown 时），此操作将一直阻塞当前线程。
RUN_DIRECTION - 类 java.awt.font.TextAttribute 中的静态变量
线条延伸方向的属性键。
RUN_DIRECTION_LTR - 类 java.awt.font.TextAttribute 中的静态变量
从左到右的延伸方向。
RUN_DIRECTION_RTL - 类 java.awt.font.TextAttribute 中的静态变量
从右到左的延伸方向。
runAndReset() - 类 java.util.concurrent.FutureTask 中的方法
执行计算而不设置其结果，然后将此 Future 重置为初始状态，如果计算遇到异常或已取消，则该操作失败。
runCount - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
runFinalization() - 类 java.lang.Runtime 中的方法
运行挂起 finalization 的所有对象的终止方法。
runFinalization() - 类 java.lang.System 中的静态方法
运行处于挂起终止状态的所有对象的终止方法。
runFinalizersOnExit(boolean) - 类 java.lang.Runtime 中的静态方法
已过时。 此方法本身具有不安全性。它可能对正在使用的对象调用终结方法，而其他线程正在操作这些对象，从而导致不正确的行为或死锁。
runFinalizersOnExit(boolean) - 类 java.lang.System 中的静态方法
已过时。 该方法具有固有的不安全性。它可能对正在使用的对象调用终结方法，而其他线程同时正在操作这些对象，从而导致不正确的行为或死锁。
RUNIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Runic”Unicode 字符块的常量。
runnable - 类 java.awt.event.InvocationEvent 中的变量
调用其 run() 方法的 Runnable。
Runnable - java.lang 中的 接口
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
RunnableFuture<V> - java.util.concurrent 中的 接口
作为 Runnable 的 Future。
RunnableScheduledFuture<V> - java.util.concurrent 中的 接口
作为 Runnable 的 ScheduledFuture。
Runtime - java.lang 中的 类
每个 Java 应用程序都有一个 Runtime 类实例，使应用程序能够与其运行的环境相连接。
RunTime - org.omg.SendingContext 中的 接口
定义表示请求的发送上下文的基类。
RUNTIME_ERROR - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示在尝试获取被观察属性的值时发生未预定义的错误类型的通知类型。
RUNTIME_ERROR_NOTIFIED - 类 javax.management.monitor.Monitor 中的静态变量
表示已在更改被观察对象或被观察属性之后发出了通知的标志。
RUNTIME_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
RuntimeMXBean 的 ObjectName 的字符串表示形式。
RuntimeErrorException - javax.management 中的 异常
当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
RuntimeErrorException(Error) - 异常 javax.management.RuntimeErrorException 的构造方法
默认的构造方法。
RuntimeErrorException(Error, String) - 异常 javax.management.RuntimeErrorException 的构造方法
允许指定特定错误消息的构造方法。
RuntimeException - java.lang 中的 异常
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
RuntimeException() - 异常 java.lang.RuntimeException 的构造方法
用 null 作为其详细消息构造一个新的运行时异常。
RuntimeException(String) - 异常 java.lang.RuntimeException 的构造方法
用指定的详细消息构造一个新的运行时异常。
RuntimeException(String, Throwable) - 异常 java.lang.RuntimeException 的构造方法
用指定的详细消息和原因构造一个新的运行时异常。
RuntimeException(Throwable) - 异常 java.lang.RuntimeException 的构造方法
用指定的原因和详细消息 (cause==null ? null :cause.toString()） 构造一个新的运行时异常（它通常包含类和 cause 的详细消息）。
RuntimeMBeanException - javax.management 中的 异常
表示由代理中的 MBean 方法抛出的运行时异常。
RuntimeMBeanException(RuntimeException) - 异常 javax.management.RuntimeMBeanException 的构造方法
创建包装实际 java.lang.RuntimeException 的 RuntimeMBeanException。
RuntimeMBeanException(RuntimeException, String) - 异常 javax.management.RuntimeMBeanException 的构造方法
创建带有详细信息的实际 java.lang.RuntimeException 的 RuntimeMBeanException。
RuntimeMXBean - java.lang.management 中的 接口
Java 虚拟机的运行时系统的管理接口。
RunTimeOperations - org.omg.SendingContext 中的 接口
定义在表示请求的发送上下文的基类上使用的操作。
RuntimeOperationsException - javax.management 中的 异常
表示在 MBean 上执行操作时代理中抛出的运行时异常。
RuntimeOperationsException(RuntimeException) - 异常 javax.management.RuntimeOperationsException 的构造方法
创建包装实际 java.lang.RuntimeException 的 RuntimeOperationsException。
RuntimeOperationsException(RuntimeException, String) - 异常 javax.management.RuntimeOperationsException 的构造方法
创建包装带有详细信息的实际 java.lang.RuntimeException 的 RuntimeOperationsException。
RuntimePermission - java.lang 中的 类
该类用于运行时权限。
RuntimePermission(String) - 类 java.lang.RuntimePermission 的构造方法
创建具有指定名称的新 RuntimePermission。
RuntimePermission(String, String) - 类 java.lang.RuntimePermission 的构造方法
创建具有指定名称的新 RuntimePermission 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


S - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

S

S - 类 javax.swing.text.html.HTML.Tag 中的静态变量
S_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口下边框大小的光标类型。
S_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.S_RESIZE_CURSOR 取代。
SAAJMetaFactory - javax.xml.soap 中的 类
SAAJ API 中定义的工厂实现类的访问点。
SAAJMetaFactory() - 类 javax.xml.soap.SAAJMetaFactory 的构造方法
SAAJResult - javax.xml.soap 中的 类
以 SAAJ 树的形式，充当 JAXP 转换或 JAXB 编组结果的持有者。
SAAJResult() - 类 javax.xml.soap.SAAJResult 的构造方法
创建一个 SAAJResult，此类将以支持默认 (SOAP 1.1) 协议的 SAAJ 树的形式显示结果。
SAAJResult(String) - 类 javax.xml.soap.SAAJResult 的构造方法
创建一个 SAAJResult，它将以支持指定协议的 SAAJ 树的形式显示结果。
SAAJResult(SOAPMessage) - 类 javax.xml.soap.SAAJResult 的构造方法
创建一个 SAAJResult，它会将结果写入提供的 SOAPMessage 的 SOAPPart 中。
SAAJResult(SOAPElement) - 类 javax.xml.soap.SAAJResult 的构造方法
创建一个 SAAJResult，它会将结果编写为指定 SOAPElement 的子节点。
SADDLE_STITCH - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿中折线的一个或多个装订点（金属针脚）绑定。
sameFile(URL) - 类 java.net.URL 中的方法
比较两个 URL，不包括片段部分。
sameFile(URL, URL) - 类 java.net.URLStreamHandler 中的方法
比较两个 url 以确定它们是否引用相同的文件（即具有相同的协议、主机、端口和路径）。
SAMP - 类 javax.swing.text.html.HTML.Tag 中的静态变量
SAMPLE_RATE - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示更改音频回放的样本频率的控件。
sampleModel - 类 java.awt.image.Raster 中的变量
描述此 Raster 的像素在 DataBuffer 中存储方式的 SampleModel。
SampleModel - java.awt.image 中的 类
此抽象类定义一个提取图像像素样本的接口。
SampleModel(int, int, int, int) - 类 java.awt.image.SampleModel 的构造方法
构造一个具有指定参数的 SampleModel。
sampleModel - 类 javax.imageio.ImageTypeSpecifier 中的变量
将用作原型的 SampleModel。
sampleModelTranslateX - 类 java.awt.image.Raster 中的变量
从 Raster 的 SampleModel 坐标空间到该 Raster 坐标空间的 X 平移。
sampleModelTranslateY - 类 java.awt.image.Raster 中的变量
从 Raster 的 SampleModel 坐标空间到该 Raster 坐标空间的 Y 平移。
sampleRate - 类 javax.sound.sampled.AudioFormat 中的变量
具有此格式的声音每秒播放或录制的样本数。
sampleSizeInBits - 类 javax.sound.sampled.AudioFormat 中的变量
每个具有此格式的声音样本中的位数。
SANS_SERIF - 类 java.awt.Font 中的静态变量
逻辑字体 "SansSerif" 的规范系列名称的 String 常量。
Sasl - javax.security.sasl 中的 类
用于创建 SASL 客户端和服务器的静态类。
SaslClient - javax.security.sasl 中的 接口
以客户端的身份执行 SASL 验证。
SaslClientFactory - javax.security.sasl 中的 接口
用于创建 SaslClient 实例的接口。
SaslException - javax.security.sasl 中的 异常
此类表示在使用 SASL 时所发生的错误。
SaslException() - 异常 javax.security.sasl.SaslException 的构造方法
构造一个新的 SaslException 实例。
SaslException(String) - 异常 javax.security.sasl.SaslException 的构造方法
构造带详细消息的新 SaslException 实例。
SaslException(String, Throwable) - 异常 javax.security.sasl.SaslException 的构造方法
构造带详细消息和根异常的新 SaslException 实例。
SaslServer - javax.security.sasl 中的 接口
以服务器的身份执行 SASL 验证。
SaslServerFactory - javax.security.sasl 中的 接口
用于创建 SaslServer 实例的接口。
SATURDAY - 类 java.util.Calendar 中的静态变量
指示 Saturday 的 Calendar.DAY_OF_WEEK 字段值。
save(ObjectOutputStream, String, EventListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
SAVE - 类 java.awt.FileDialog 中的静态变量
此常量值指示文件对话框窗口的作用是查找要写入的文件。
save(OutputStream, String) - 类 java.util.Properties 中的方法
已过时。 如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。
SAVE_DIALOG - 类 javax.swing.JFileChooser 中的静态变量
指示 JFileChooser 支持 "Save" 文件操作的类型值。
SAVE_FILE - 类 java.awt.Event 中的静态变量
文件保存事件。
saveButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
saveButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
saveButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
saveChanges() - 类 javax.xml.soap.SOAPMessage 中的方法
使用对其所作的所有更改更新此 SOAPMessage 对象。
saveInternal(ObjectOutputStream, String) - 类 java.awt.AWTEventMulticaster 中的方法
Savepoint - java.sql 中的 接口
保存点的表示形式，保存点是可以从 Connection.rollback 方法引用的当前事务中的点。
saveRequired() - 类 javax.xml.soap.SOAPMessage 中的方法
指示是否此 SOAPMessage 对象需要调用方法 saveChanges。
SAXException - org.xml.sax 中的 异常
封装一般的 SAX 错误或警告。
SAXException() - 异常 org.xml.sax.SAXException 的构造方法
创建一个新的 SAXException。
SAXException(String) - 异常 org.xml.sax.SAXException 的构造方法
创建一个新的 SAXException。
SAXException(Exception) - 异常 org.xml.sax.SAXException 的构造方法
创建一个包装现有异常的新的 SAXException。
SAXException(String, Exception) - 异常 org.xml.sax.SAXException 的构造方法
从现有的异常创建新的 SAXException。
SAXNotRecognizedException - org.xml.sax 中的 异常
用于未识别的标识符的 Exception 类。
SAXNotRecognizedException() - 异常 org.xml.sax.SAXNotRecognizedException 的构造方法
默认的构造方法。
SAXNotRecognizedException(String) - 异常 org.xml.sax.SAXNotRecognizedException 的构造方法
构造带指定的消息的新的异常。
SAXNotSupportedException - org.xml.sax 中的 异常
用于不被支持的操作的 Exception 类。
SAXNotSupportedException() - 异常 org.xml.sax.SAXNotSupportedException 的构造方法
构造不带任何消息的新异常。
SAXNotSupportedException(String) - 异常 org.xml.sax.SAXNotSupportedException 的构造方法
构造带指定消息的新的异常。
SAXParseException - org.xml.sax 中的 异常
封装 XML 解析错误或警告。
SAXParseException(String, Locator) - 异常 org.xml.sax.SAXParseException 的构造方法
从消息和 Locator 创建新的 SAXParseException。
SAXParseException(String, Locator, Exception) - 异常 org.xml.sax.SAXParseException 的构造方法
将现有的异常包装在 SAXParseException 中。
SAXParseException(String, String, String, int, int) - 异常 org.xml.sax.SAXParseException 的构造方法
创建新的 SAXParseException。
SAXParseException(String, String, String, int, int, Exception) - 异常 org.xml.sax.SAXParseException 的构造方法
创建带有嵌入异常的新 SAXParseException。
SAXParser - javax.xml.parsers 中的 类
定义包装 XMLReader 实现类的 API。
SAXParser() - 类 javax.xml.parsers.SAXParser 的构造方法
将阻止实例化的受保护构造方法。
SAXParserFactory - javax.xml.parsers 中的 类
定义工厂 API，使应用程序能够配置和获取基于 SAX 的解析器以解析 XML 文档。
SAXParserFactory() - 类 javax.xml.parsers.SAXParserFactory 的构造方法
受保护构造方法，以强制使用 SAXParserFactory.newInstance()。
SAXResult - javax.xml.transform.sax 中的 类
充当转换 Result 的持有者。
SAXResult() - 类 javax.xml.transform.sax.SAXResult 的构造方法
零参数的默认构造方法。
SAXResult(ContentHandler) - 类 javax.xml.transform.sax.SAXResult 的构造方法
创建以 SAX2 ContentHandler 为目标的 SAXResult。
SAXSource - javax.xml.transform.sax 中的 类
充当 SAX 样式 Source 的持有者。
SAXSource() - 类 javax.xml.transform.sax.SAXSource 的构造方法
零参数的默认构造方法。
SAXSource(XMLReader, InputSource) - 类 javax.xml.transform.sax.SAXSource 的构造方法
使用 XMLReader 和 SAX InputSource 创建 SAXSource。
SAXSource(InputSource) - 类 javax.xml.transform.sax.SAXSource 的构造方法
使用 SAX InputSource，创建 SAXSource。
SAXTransformerFactory - javax.xml.transform.sax 中的 类
此类扩展了 TransformerFactory 以提供特定于 SAX 的工厂方法。
SAXTransformerFactory() - 类 javax.xml.transform.sax.SAXTransformerFactory 的构造方法
默认构造方法受到有意保护。
SC_BLOCK_DATA - 接口 java.io.ObjectStreamConstants 中的静态变量
ObjectStreamClass 标志的位掩码。
SC_ENUM - 接口 java.io.ObjectStreamConstants 中的静态变量
ObjectStreamClass 标志的位掩码。
SC_EXTERNALIZABLE - 接口 java.io.ObjectStreamConstants 中的静态变量
ObjectStreamClass 标志的位掩码。
SC_SERIALIZABLE - 接口 java.io.ObjectStreamConstants 中的静态变量
ObjectStreamClass 标志的位掩码。
SC_WRITE_METHOD - 接口 java.io.ObjectStreamConstants 中的静态变量
ObjectStreamClass 标志的位掩码。
scalb(double, int) - 类 java.lang.Math 中的静态方法
返回 d × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘以 double 值集合中的一个值。
scalb(float, int) - 类 java.lang.Math 中的静态方法
返回 f × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘以 float 值集合中的一个值。
scalb(double, int) - 类 java.lang.StrictMath 中的静态方法
返回 d × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘到 double 值集合中的一个值。
scalb(float, int) - 类 java.lang.StrictMath 中的静态方法
返回 f × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘到 float 值集合中的一个值。
scale(double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与缩放变换。
scale(double, double) - 类 java.awt.Graphics2D 中的方法
将当前 Graphics2D Transform 与缩放转换连接。
scale() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的标度。
scale(Spring, float) - 类 javax.swing.Spring 中的静态方法
返回一个 spring，其 minimum、preferred、maximum 和 value 属性都是参数 spring s 的属性的倍数。
SCALE_AREA_AVERAGING - 类 java.awt.Image 中的静态变量
使用 Area Averaging 图像缩放算法。
SCALE_DEFAULT - 类 java.awt.Image 中的静态变量
使用默认的图像缩放算法。
SCALE_FAST - 类 java.awt.Image 中的静态变量
选择一种图像缩放算法，在这种缩放算法中，缩放速度比缩放平滑度具有更高的优先级。
SCALE_REPLICATE - 类 java.awt.Image 中的静态变量
使用 ReplicateScaleFilter 类中包含的图像缩放算法。
SCALE_SMOOTH - 类 java.awt.Image 中的静态变量
选择图像平滑度比缩放速度具有更高优先级的图像缩放算法。
scaleByPowerOfTen(int) - 类 java.math.BigDecimal 中的方法
返回其数值等于 (this * 10n) 的 BigDecimal。
scan(Iterable<? extends Element>, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
迭代给定元素并对每个元素调用 scan(Element, P)。
scan(Element, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
通过调用 e.accept(this, p) 处理元素；此方法可被子类重写。
scan(Element) - 类 javax.lang.model.util.ElementScanner6 中的方法
等效于 v.scan(e, null) 的便捷方法。
scanForPlugins() - 类 javax.imageio.ImageIO 中的静态方法
扫描应用程序类路径上的插件，加载其服务提供者类，并使用 IIORegistry 为每一个找到的插件注册一个服务提供者实例。
scanlineStride - 类 java.awt.image.ComponentSampleModel 中的变量
由此 ComponentSampleModel 所描述的图像数据区域的行间距（以数据数组元素表示）。
Scanner - java.util 中的 类
一个可以使用正则表达式来解析基本类型和字符串的简单文本扫描器。
Scanner(Readable) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定源扫描的。
Scanner(InputStream) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。
Scanner(InputStream, String) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。
Scanner(File) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定文件扫描的。
Scanner(File, String) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定文件扫描的。
Scanner(String) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定字符串扫描的。
Scanner(ReadableByteChannel) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定信道扫描的。
Scanner(ReadableByteChannel, String) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定信道扫描的。
ScatteringByteChannel - java.nio.channels 中的 接口
可将字节读入缓冲区序列的通道。
schedule(Runnable, long, TimeUnit) - 接口 java.util.concurrent.ScheduledExecutorService 中的方法
创建并执行在给定延迟后启用的一次性操作。
schedule(Callable<V>, long, TimeUnit) - 接口 java.util.concurrent.ScheduledExecutorService 中的方法
创建并执行在给定延迟后启用的 ScheduledFuture。
schedule(Runnable, long, TimeUnit) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
schedule(Callable<V>, long, TimeUnit) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
schedule(TimerTask, long) - 类 java.util.Timer 中的方法
安排在指定延迟后执行指定的任务。
schedule(TimerTask, Date) - 类 java.util.Timer 中的方法
安排在指定的时间执行指定的任务。
schedule(TimerTask, long, long) - 类 java.util.Timer 中的方法
安排指定的任务从指定的延迟后开始进行重复的固定延迟执行。
schedule(TimerTask, Date, long) - 类 java.util.Timer 中的方法
安排指定的任务在指定的时间开始进行重复的固定延迟执行。
scheduleAtFixedRate(Runnable, long, long, TimeUnit) - 接口 java.util.concurrent.ScheduledExecutorService 中的方法
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。
scheduleAtFixedRate(Runnable, long, long, TimeUnit) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
scheduleAtFixedRate(TimerTask, long, long) - 类 java.util.Timer 中的方法
安排指定的任务在指定的延迟后开始进行重复的固定速率执行。
scheduleAtFixedRate(TimerTask, Date, long) - 类 java.util.Timer 中的方法
安排指定的任务在指定的时间开始进行重复的固定速率执行。
scheduledExecutionTime() - 类 java.util.TimerTask 中的方法
返回此任务最近实际 执行的已安排 执行时间。
ScheduledExecutorService - java.util.concurrent 中的 接口
一个 ExecutorService，可安排在给定的延迟后运行或定期执行的命令。
ScheduledFuture<V> - java.util.concurrent 中的 接口
一个延迟的、结果可接受的操作，可将其取消。
ScheduledThreadPoolExecutor - java.util.concurrent 中的 类
ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。
ScheduledThreadPoolExecutor(int) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 的构造方法
使用给定核心池大小创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int, ThreadFactory) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 的构造方法
使用给定的初始参数创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int, RejectedExecutionHandler) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 的构造方法
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int, ThreadFactory, RejectedExecutionHandler) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 的构造方法
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
scheduleWithFixedDelay(Runnable, long, long, TimeUnit) - 接口 java.util.concurrent.ScheduledExecutorService 中的方法
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。
scheduleWithFixedDelay(Runnable, long, long, TimeUnit) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
Schema - javax.xml.validation 中的 类
不可变的语法存储表示形式。
Schema() - 类 javax.xml.validation.Schema 的构造方法
派生类的构造方法。
SCHEMA_SYSTEM_ID - 接口 javax.sql.rowset.WebRowSet 中的静态变量
为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的 URL。
SchemaFactory - javax.xml.validation 中的 类
创建 Schema 对象的工厂。
SchemaFactory() - 类 javax.xml.validation.SchemaFactory 的构造方法
派生类的构造方法。
SchemaFactoryLoader - javax.xml.validation 中的 类
创建 SchemaFactory 的工厂。
SchemaFactoryLoader() - 类 javax.xml.validation.SchemaFactoryLoader 的构造方法
不执行操作的构造方法。
SchemaOutputResolver - javax.xml.bind 中的 类
控制 JAXB 实现放置生成的模式文件的位置。
SchemaOutputResolver() - 类 javax.xml.bind.SchemaOutputResolver 的构造方法
SchemaViolationException - javax.naming.directory 中的 异常
当方法在某些方面违反模式时，抛出此异常。
SchemaViolationException() - 异常 javax.naming.directory.SchemaViolationException 的构造方法
构造一个新的 SchemaViolationException 实例。
SchemaViolationException(String) - 异常 javax.naming.directory.SchemaViolationException 的构造方法
使用所提供的解释构造一个新的 SchemaViolationException 实例。
scope - 类 javax.xml.bind.JAXBElement 中的变量
表示此 xml 元素实例的 xml 元素声明的作用域。
SCRIPT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
ScriptContext - javax.script 中的 接口
该接口的实现类被用来连接 Script Engines 和宿主应用程序中的对象（如有范围的 Bindings）。
ScriptEngine - javax.script 中的 接口
ScriptEngine 是基础接口，该接口的方法在此规范的每个实现中都必须具有完整的功能。
ScriptEngineFactory - javax.script 中的 接口
ScriptEngineFactory 用来描述和实例化 ScriptEngine。
ScriptEngineManager - javax.script 中的 类
ScriptEngineManager 为 ScriptEngine 类实现一个发现和实例化机制，还维护一个键/值对集合来存储所有 Manager 创建的引擎所共享的状态。
ScriptEngineManager() - 类 javax.script.ScriptEngineManager 的构造方法
如果调用者可访问线程上下文 ClassLoader，则调用此构造方法的效果与调用 ScriptEngineManager(Thread.currentThread().getContextClassLoader()) 相同。
ScriptEngineManager(ClassLoader) - 类 javax.script.ScriptEngineManager 的构造方法
此构造方法使用服务调用者机制加载对于给定 ClassLoader 可见的 ScriptEngineFactory 实现。
ScriptException - javax.script 中的 异常
脚本 API 的一般 Exception 类。
ScriptException(String) - 异常 javax.script.ScriptException 的构造方法
使用将在其消息中使用的 String 创建一个 ScriptException。
ScriptException(Exception) - 异常 javax.script.ScriptException 的构造方法
创建一个包装底层解释器抛出的 Exception 的 ScriptException。
ScriptException(String, String, int) - 异常 javax.script.ScriptException 的构造方法
使用将在错误消息中使用的消息、文件名和行号创建一个 ScriptException。
ScriptException(String, String, int, int) - 异常 javax.script.ScriptException 的构造方法
指定消息、文件名、行号和列号的 ScriptException 构造方法。
SCROLL_ABSOLUTE - 类 java.awt.Event 中的静态变量
用户已经将滚动条中的“气泡”（即翻阅标志）移到一个“绝对的”位置，而不是相对最后位置的偏移量。
SCROLL_BAR - 类 javax.accessibility.AccessibleRole 中的静态变量
通常用于允许用户逐渐查看大量数据的对象。
SCROLL_BAR - 类 javax.swing.plaf.synth.Region 中的静态变量
ScrollBar 的 region。
SCROLL_BAR_THUMB - 类 javax.swing.plaf.synth.Region 中的静态变量
ScrollBar 的 thumb。
SCROLL_BAR_TRACK - 类 javax.swing.plaf.synth.Region 中的静态变量
ScrollBar 的滑道。
SCROLL_BEGIN - 类 java.awt.Event 中的静态变量
滚动开始事件。
SCROLL_DOWN - 类 javax.swing.plaf.basic.BasicComboPopup 中的静态变量
SCROLL_END - 类 java.awt.Event 中的静态变量
滚动结束事件。
SCROLL_LINE_DOWN - 类 java.awt.Event 中的静态变量
用户已经激活了滚动条的 line down 区域。
SCROLL_LINE_UP - 类 java.awt.Event 中的静态变量
用户已经激活了滚动条的 line up 区域。
SCROLL_LOCK - 类 java.awt.Event 中的静态变量
Scroll Lock 键，一个非 ASCII 操作键。
SCROLL_PAGE_DOWN - 类 java.awt.Event 中的静态变量
用户已经激活了滚动条的 page down 区域。
SCROLL_PAGE_UP - 类 java.awt.Event 中的静态变量
用户已经激活了滚动条的 page up 区域。
SCROLL_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
允许用户逐渐查看大量信息的对象。
SCROLL_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
ScrollPane 的 region。
SCROLL_TAB_LAYOUT - 类 javax.swing.JTabbedPane 中的静态变量
当在一次运行中不能放入所有的选项卡时，用于提供可用选项卡子集的选项卡布局策略。
SCROLL_UP - 类 javax.swing.plaf.basic.BasicComboPopup 中的静态变量
Scrollable - javax.swing 中的 接口
为类似 JScrollPane 的滚动容器提供信息的接口。
Scrollbar - java.awt 中的 类
Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
Scrollbar() - 类 java.awt.Scrollbar 的构造方法
构造一个新的垂直滚动条。
Scrollbar(int) - 类 java.awt.Scrollbar 的构造方法
构造一个具有指定方向的新滚动条。
Scrollbar(int, int, int, int, int) - 类 java.awt.Scrollbar 的构造方法
构造一个新的滚动条，它具有指定的方向、初始值、可见量、最小值和最大值。
SCROLLBAR - 类 java.awt.SystemColor 中的静态变量
SystemColor.scrollbar 系统颜色的数组索引。
scrollbar - 类 java.awt.SystemColor 中的静态变量
为滚动条提供的背景色。
scrollbar - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
scrollBar - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的变量
正在调整的 scrollBar。
Scrollbar.AccessibleAWTScrollBar - java.awt 中的 类
此类实现 Scrollbar 类的可访问性支持。
Scrollbar.AccessibleAWTScrollBar() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 的构造方法
SCROLLBARS_ALWAYS - 类 java.awt.ScrollPane 中的静态变量
指定无论滚动窗格和子组件各自大小如何，总是显示水平/垂直滚动条。
SCROLLBARS_AS_NEEDED - 类 java.awt.ScrollPane 中的静态变量
指定只在子组件的大小超过了滚动窗格水平/垂直尺寸时显示水平/垂直滚动条。
SCROLLBARS_BOTH - 类 java.awt.TextArea 中的静态变量
创建并显示垂直和水平滚动条。
SCROLLBARS_HORIZONTAL_ONLY - 类 java.awt.TextArea 中的静态变量
只创建并显示水平滚动条。
SCROLLBARS_NEVER - 类 java.awt.ScrollPane 中的静态变量
指定无论滚动窗格和子组件各自大小如何，永不显示水平/垂直滚动条。
SCROLLBARS_NONE - 类 java.awt.TextArea 中的静态变量
不为文本区创建或显示任何滚动条。
SCROLLBARS_VERTICAL_ONLY - 类 java.awt.TextArea 中的静态变量
只创建并显示垂直滚动条。
ScrollBarUI - javax.swing.plaf 中的 类
JScrollBar 的可插入外观界面。
ScrollBarUI() - 类 javax.swing.plaf.ScrollBarUI 的构造方法
scrollBarWidth - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的变量
scrollByBlock(int) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
scrollByBlock(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
scrollByUnit(int) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
scrollByUnit(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
scrollDirection - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
scrollDueToClickInTrack(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
在滑道（而非 thumb）中检测到 mousePressed 时调用此方法。
scrollDueToClickInTrack(int) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
scroller - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
SCROLLING - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
scrollListener - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
scrollListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
ScrollPane - java.awt 中的 类
实现用于单个子组件的自动水平和/或垂直滚动的容器类。
ScrollPane() - 类 java.awt.ScrollPane 的构造方法
创建一个具有滚动条策略 "as needed" 的新滚动窗格容器。
ScrollPane(int) - 类 java.awt.ScrollPane 的构造方法
创建新的滚动窗格容器。
scrollpane - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的变量
ScrollPane.AccessibleAWTScrollPane - java.awt 中的 类
此类实现 ScrollPane 类的可访问性支持。
ScrollPane.AccessibleAWTScrollPane() - 类 java.awt.ScrollPane.AccessibleAWTScrollPane 的构造方法
ScrollPaneAdjustable - java.awt 中的 类
此类表示 ScrollPane 的水平或垂直滚动条的状态。
ScrollPaneConstants - javax.swing 中的 接口
与 JScrollPane 组件一起使用的常数。
ScrollPaneLayout - javax.swing 中的 类
JScrollPane 使用的布局管理器。
ScrollPaneLayout() - 类 javax.swing.ScrollPaneLayout 的构造方法
ScrollPaneLayout.UIResource - javax.swing 中的 类
ScrollPaneLayout 的 UI 资源版本。
ScrollPaneLayout.UIResource() - 类 javax.swing.ScrollPaneLayout.UIResource 的构造方法
ScrollPaneUI - javax.swing.plaf 中的 类
JScrollPane 的可插入外观界面。
ScrollPaneUI() - 类 javax.swing.plaf.ScrollPaneUI 的构造方法
scrollPathToVisible(TreePath) - 类 javax.swing.JTree 中的方法
确保路径中所有的路径组件均展开（最后一个路径组件除外）并滚动，以便显示该路径标识的节点。
scrollRectToVisible(Rectangle) - 类 javax.swing.JComponent 中的方法
将 scrollRectToVisible() 消息转发到 JComponent 的父组件。
scrollRectToVisible(Rectangle) - 类 javax.swing.JTextField 中的方法
将字段向左或向右滚动。
scrollRectToVisible(Rectangle) - 类 javax.swing.JViewport 中的方法
滚动该视图，使该视图中的 Rectangle 变得可见。
scrollRowToVisible(int) - 类 javax.swing.JTree 中的方法
滚动行标识的条目，直到显示出来。
SCROLLS_ON_EXPAND_PROPERTY - 类 javax.swing.JTree 中的静态变量
scrollsOnExpand 的绑定属性名称。
scrollsOnExpand - 类 javax.swing.JTree 中的变量
如果为 true，则当展开节点时，将滚动尽可能多的子节点，以便看到它们。
scrollTimer - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
scrollTimer - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
scrollToReference(String) - 类 javax.swing.JEditorPane 中的方法
将视图滚动到给定的参考位置（也就是正在显示的 URL 的 UL.getRef 方法所返回的值）。
scrollUnderway - 类 javax.swing.JViewport 中的变量
scrollUnderway 标志用于 JList 之类的组件。
SDATA - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
SE_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口右下角大小的光标类型。
SE_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.SE_RESIZE_CURSOR 取代。
SEALED - 类 java.util.jar.Attributes.Name 中的静态变量
Sealed 的 Name 对象给出了用于密封的属性。
SealedObject - javax.crypto 中的 类
此类使程序员能够用加密算法创建对象并保护其机密性。
SealedObject(Serializable, Cipher) - 类 javax.crypto.SealedObject 的构造方法
从任何 Serializable 对象构造一个 SealedObject。
SealedObject(SealedObject) - 类 javax.crypto.SealedObject 的构造方法
根据传入的 SealedObject 构造一个 SealedObject 对象。
search(Object) - 类 java.util.Stack 中的方法
返回对象在堆栈中的位置，以 1 为基数。
search(Name, Attributes, String[]) - 接口 javax.naming.directory.DirContext 中的方法
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
search(String, Attributes, String[]) - 接口 javax.naming.directory.DirContext 中的方法
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
search(Name, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
在单个上下文中搜索包含指定属性集的对象。
search(String, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
在单个上下文中搜索包含指定属性集的对象。
search(Name, String, SearchControls) - 接口 javax.naming.directory.DirContext 中的方法
在命名上下文或对象中搜索符合给定搜索过滤器的项。
search(String, String, SearchControls) - 接口 javax.naming.directory.DirContext 中的方法
在命名上下文或对象中搜索符合给定搜索过滤器的项。
search(Name, String, Object[], SearchControls) - 接口 javax.naming.directory.DirContext 中的方法
在命名上下文或对象中搜索符合给定搜索过滤器的项。
search(String, String, Object[], SearchControls) - 接口 javax.naming.directory.DirContext 中的方法
在命名上下文或对象中搜索符合给定搜索过滤器的项。
search(String, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
search(Name, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
search(String, Attributes, String[]) - 类 javax.naming.directory.InitialDirContext 中的方法
search(Name, Attributes, String[]) - 类 javax.naming.directory.InitialDirContext 中的方法
search(String, String, SearchControls) - 类 javax.naming.directory.InitialDirContext 中的方法
search(Name, String, SearchControls) - 类 javax.naming.directory.InitialDirContext 中的方法
search(String, String, Object[], SearchControls) - 类 javax.naming.directory.InitialDirContext 中的方法
search(Name, String, Object[], SearchControls) - 类 javax.naming.directory.InitialDirContext 中的方法
SearchControls - javax.naming.directory 中的 类
此类封装确定搜索范围和搜索返回结果的因子。
SearchControls() - 类 javax.naming.directory.SearchControls 的构造方法
使用默认值构造搜索约束。
SearchControls(int, long, int, String[], boolean, boolean) - 类 javax.naming.directory.SearchControls 的构造方法
使用参数构造搜索约束。
SearchResult - javax.naming.directory 中的 类
此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。
SearchResult(String, Object, Attributes) - 类 javax.naming.directory.SearchResult 的构造方法
使用结果的名称、绑定对象及其属性构造一个搜索结果。
SearchResult(String, Object, Attributes, boolean) - 类 javax.naming.directory.SearchResult 的构造方法
使用结果的名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。
SearchResult(String, String, Object, Attributes) - 类 javax.naming.directory.SearchResult 的构造方法
使用结果的名称、类名称、绑定对象及其属性构造一个搜索结果。
SearchResult(String, String, Object, Attributes, boolean) - 类 javax.naming.directory.SearchResult 的构造方法
使用结果的名称、类名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。
SECOND - 类 java.text.DateFormat.Field 中的静态变量
标识 SECOND 字段的常量。
SECOND - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一分钟中的秒。
SECOND_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 SECOND 字段的有用常量。
SECONDARY - 类 java.text.Collator 中的静态变量
Collator 的 strength 值。
secondaryOrder(int) - 类 java.text.CollationElementIterator 中的静态方法
返回 collation 元素的第二顺序。
SECONDS - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示秒字段的常量。
SECRET_KEY - 类 javax.crypto.Cipher 中的静态变量
用于表示要解包的密钥为“秘密密钥”的常量。
SecretKey - javax.crypto 中的 接口
秘密（对称）密钥。
SecretKeyFactory - javax.crypto 中的 类
此类表示秘密密钥的工厂。
SecretKeyFactory(SecretKeyFactorySpi, Provider, String) - 类 javax.crypto.SecretKeyFactory 的构造方法
创建一个 SecretKeyFactory 对象。
SecretKeyFactorySpi - javax.crypto 中的 类
此类定义 SecretKeyFactory 类的服务提供者接口 (SPI)。
SecretKeyFactorySpi() - 类 javax.crypto.SecretKeyFactorySpi 的构造方法
SecretKeySpec - javax.crypto.spec 中的 类
此类以与 provider 无关的方式指定一个密钥。
SecretKeySpec(byte[], String) - 类 javax.crypto.spec.SecretKeySpec 的构造方法
根据给定的字节数组构造一个密钥。
SecretKeySpec(byte[], int, int, String) - 类 javax.crypto.spec.SecretKeySpec 的构造方法
根据给定的字节数组构造一个密钥，使用 key 中的始于且包含 offset 的前 len 个字节。
SectionElementName - 类 javax.swing.text.AbstractDocument 中的静态变量
用于保存各节（行/段落）的元素名。
SecureCacheResponse - java.net 中的 类
表示最初通过安全方法（如 TLS）获得的缓存响应。
SecureCacheResponse() - 类 java.net.SecureCacheResponse 的构造方法
SecureClassLoader - java.security 中的 类
此类扩展了 ClassLoader，使它另外还支持使用相关的代码源和权限定义类，这些代码源和权限默认情况下可根据系统策略获取到。
SecureClassLoader(ClassLoader) - 类 java.security.SecureClassLoader 的构造方法
使用指定的父类加载器为委托创建新 SecureClassLoader。
SecureClassLoader() - 类 java.security.SecureClassLoader 的构造方法
使用默认的父类加载器为委托创建新 SecureClassLoader。
SecureRandom - java.security 中的 类
此类提供强加密随机数生成器 (RNG)。
SecureRandom() - 类 java.security.SecureRandom 的构造方法
构造一个实现默认随机数算法的安全随机数生成器 (RNG)。
SecureRandom(byte[]) - 类 java.security.SecureRandom 的构造方法
构造一个实现默认随机数算法的安全随机数生成器 (RNG)。
SecureRandom(SecureRandomSpi, Provider) - 类 java.security.SecureRandom 的构造方法
创建 SecureRandom 对象。
SecureRandomSpi - java.security 中的 类
此类为 SecureRandom 类定义了服务提供者接口 (SPI)。
SecureRandomSpi() - 类 java.security.SecureRandomSpi 的构造方法
Security - java.security 中的 类
此类集中了所有的安全属性和常见的安全方法。
SECURITY_AUTHENTICATION - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定将使用的安全级别的环境属性名称。
SECURITY_CREDENTIALS - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定用于验证服务调用者主体证书的环境属性名称。
SECURITY_PRINCIPAL - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定用于验证服务调用者主体身份的环境属性名称。
SECURITY_PROTOCOL - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定将使用的安全协议的环境属性名称。
SecurityException - java.lang 中的 异常
由安全管理器抛出的异常，指示存在安全侵犯。
SecurityException() - 异常 java.lang.SecurityException 的构造方法
构造不带详细消息的 SecurityException。
SecurityException(String) - 异常 java.lang.SecurityException 的构造方法
构造带指定详细消息的 SecurityException。
SecurityException(String, Throwable) - 异常 java.lang.SecurityException 的构造方法
创建带指定详细消息和原因的 SecurityException。
SecurityException(Throwable) - 异常 java.lang.SecurityException 的构造方法
创建一个 SecurityException，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含该类和 cause 的详细消息）。
SecurityManager - java.lang 中的 类
安全管理器是一个允许应用程序实现安全策略的类。
SecurityManager() - 类 java.lang.SecurityManager 的构造方法
构造一个新的 SecurityManager。
SecurityPermission - java.security 中的 类
此类用于安全权限。
SecurityPermission(String) - 类 java.security.SecurityPermission 的构造方法
创建具有指定名称的新 SecurityPermission。
SecurityPermission(String, String) - 类 java.security.SecurityPermission 的构造方法
创建具有指定名称的新 SecurityPermission 对象。
seek(long) - 类 java.io.RandomAccessFile 中的方法
设置到此文件开头测量到的文件指针偏移量，在该位置发生下一个读取或写入操作。
seek(long) - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
设置当前流位置并将位偏移量重置为 0。
seek(long) - 类 javax.imageio.stream.FileImageInputStream 中的方法
seek(long) - 类 javax.imageio.stream.FileImageOutputStream 中的方法
设置当前流位置并将位偏移量重置为 0。
seek(long) - 接口 javax.imageio.stream.ImageInputStream 中的方法
将当前流位置设置为所需的位置。
seek(long) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
seek(int) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 将内部指针移动到给定索引。
seek(int) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将当前位置设置为索引。
seek(int) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将当前位置设置为索引。
seekForwardOnly - 类 javax.imageio.ImageReader 中的变量
如果当前输入源已经被 setInput 标记为允许只向前搜索，则为 true。
SEG_CLOSE - 接口 java.awt.geom.PathIterator 中的静态变量
该段类型常量指定应该通过将线段追加到与最新 SEG_MOVETO 对应的点来关闭前面的子路径。
SEG_CUBICTO - 接口 java.awt.geom.PathIterator 中的静态变量
该段类型常量针对某个 3 个点的集合，指定要根据最新指定点绘制的三次参数曲线。
SEG_LINETO - 接口 java.awt.geom.PathIterator 中的静态变量
该段类型常量针对某个点，指定要根据最新指定点绘制的线的结束点。
SEG_MOVETO - 接口 java.awt.geom.PathIterator 中的静态变量
该段类型常量针对某个点，指定新子路径的起始位置。
SEG_QUADTO - 接口 java.awt.geom.PathIterator 中的静态变量
该段类型常量针对某对点，指定要根据最新指定点绘制的二次参数曲线。
Segment - javax.swing.text 中的 类
表示文本片段的字符数组的 segment。
Segment() - 类 javax.swing.text.Segment 的构造方法
创建一个新 segment。
Segment(char[], int, int) - 类 javax.swing.text.Segment 的构造方法
创建一个引用现有数组的新 segment。
SEGMENT_LIMIT - 接口 java.util.jar.Pack200.Packer 中的静态变量
此属性是一个数字，给出了每个存档段的估计目标大小 N（以字节为单位）。
select(int) - 类 java.awt.Choice 中的方法
将此 Choice 菜单中的选定项设置为指定位置上的项。
select(String) - 类 java.awt.Choice 中的方法
将此 Choice 菜单中的选定项设置为其名称等于指定字符串的项。
select(int) - 类 java.awt.List 中的方法
选择滚动列表中指定索引处的项。
select(int, int) - 类 java.awt.TextComponent 中的方法
选择指定开始位置和结束位置之间的文本。
select(URI) - 类 java.net.ProxySelector 中的方法
基于访问资源所需的协议和访问资源的目标地址选择所有可用的代理。
select(long) - 类 java.nio.channels.Selector 中的方法
选择一组键，其相应的通道已为 I/O 操作准备就绪。
select() - 类 java.nio.channels.Selector 中的方法
选择一组键，其相应的通道已为 I/O 操作准备就绪。
SELECT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
select(int, int) - 类 javax.swing.text.JTextComponent 中的方法
选定指定的开始和结束位置之间的文本。
select(KeyInfo, KeySelector.Purpose, AlgorithmMethod, XMLCryptoContext) - 类 javax.xml.crypto.KeySelector 中的方法
尝试查找满足指定约束的密钥。
SELECTABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是某个允许选择子级的对象的子对象，并且此子对象就是这些可以被选择的子对象之一。
SelectableChannel - java.nio.channels 中的 类
可通过 Selector 实现多路复用的通道。
SelectableChannel() - 类 java.nio.channels.SelectableChannel 的构造方法
初始化此类的一个新实例。
selectAdjacentRunTab(int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
selectAll() - 类 java.awt.TextComponent 中的方法
选择此文本组件中的所有文本。
selectAll() - 接口 javax.swing.ComboBoxEditor 中的方法
请求编辑器开始编辑并选定所有对象
selectAll() - 类 javax.swing.JTable 中的方法
选择表中的所有行、列和单元格。
selectAll() - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
selectAll() - 类 javax.swing.text.JTextComponent 中的方法
选择 TextComponent 中的所有文本。
selectAllAccessibleSelection() - 类 java.awt.List.AccessibleAWTList 中的方法
如果对象支持多种选择，则导致选择对象中的所有已选择项。
selectAllAccessibleSelection() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
如果该对象支持多个选择，则会导致该对象的每个子对象都被选择。
selectAllAccessibleSelection() - 接口 javax.accessibility.AccessibleSelection 中的方法
如果该对象支持多项选择，则会导致该对象的每个子对象都被选中。
selectAllAccessibleSelection() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
如果对象支持多个选择，则导致选定对象中的所有子对象。
selectAllAccessibleSelection() - 类 javax.swing.JList.AccessibleJList 中的方法
如果对象支持多种选择，则导致选择对象中的所有选择项。
selectAllAccessibleSelection() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
如果对象支持多种选择，则通常导致选择对象中的所有选择项。
selectAllAccessibleSelection() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
如果对象支持多种选择，则通常导致选择对象中的所有选择项。
selectAllAccessibleSelection() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
selectAllAccessibleSelection() - 类 javax.swing.JTable.AccessibleJTable 中的方法
只有 JTable 支持多个选择，并且单个单元格选择为启用状态时，才会导致该对象的每个子对象都被选择。
selectAllAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
导致该对象中的所有选择项都被选中，前提是该对象支持多个选择。
selectAllAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree 中的方法
导致对象中的所有选择项都被选中，前提是对象支持多个选择。
selectAllAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于选中整个文档的动作名称
selectBestTextFlavor(DataFlavor[]) - 类 java.awt.datatransfer.DataFlavor 中的静态方法
从 DataFlavor 数组中选择最佳文本 DataFlavor。
selectColor - 类 javax.swing.plaf.metal.MetalButtonUI 中的变量
selectColor - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的变量
selectColor - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的变量
selectColor - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的变量
selectContent(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出 SELECT 表单元素的内容。
SELECTED - 类 java.awt.event.ItemEvent 中的静态变量
此状态更改值指示项被选定。
SELECTED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是某个允许选择子级的对象的子对象，且此子对象是已被选定的子对象之一。
SELECTED - 类 javax.swing.DefaultButtonModel 中的静态变量
标识位掩码中“选定的”位，该位指示按纽已被选定。
SELECTED - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示 region 被选定。
SELECTED - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
selected - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
当前是否选择该值。
SELECTED_CONVERTED_TEXT_HIGHLIGHT - 类 java.awt.im.InputMethodHighlight 中的静态变量
已选定已转换文本的默认高亮显示常量。
SELECTED_FILE_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识用户单个文件选择的更改。
SELECTED_FILES_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识用户多个文件选择的更改。
SELECTED_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对选定按钮时使用的图标的更改。
SELECTED_KEY - 接口 javax.swing.Action 中的静态变量
用来存储对应于选定状态的 Boolean 值的键。
SELECTED_RAW_TEXT_HIGHLIGHT - 类 java.awt.im.InputMethodHighlight 中的静态变量
已选定原文本的默认高亮显示常量。
selectedItemChanged() - 类 javax.swing.JComboBox 中的方法
此受保护方法是特定于实现的。
selectedItemReminder - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
selectedKeys() - 类 java.nio.channels.Selector 中的方法
返回此选择器的已选择键集。
selectedRun - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
selectedTabPadInsets - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
selectedTextColor - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
selectedTitleColor - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
selectFrame(boolean) - 类 javax.swing.JDesktopPane 中的方法
选择此桌面窗格中的下一个 JInternalFrame。
selectHighlight - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的变量
selectInitialValue() - 类 javax.swing.JOptionPane 中的方法
请求选择初始值，该请求将焦点设置为初始值。
selectInitialValue(JOptionPane) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
如果 inputComponent 为非 null，则请求焦点位于其上；否则请求焦点位于默认值上
selectInitialValue(JOptionPane) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 selectInitialValue 方法。
selectInitialValue(JOptionPane) - 类 javax.swing.plaf.OptionPaneUI 中的方法
请求表示默认值的组件拥有焦点。
selectInputMethod(Locale) - 类 java.awt.im.InputContext 中的方法
试图选择一个支持给定语言环境的输入方法或键盘布局，并返回指示是否成功选定此类输入方法或键盘布局的值。
SELECTION - 类 java.awt.JobAttributes.DefaultSelectionType 中的静态变量
用于指定应该打印当前选择作业页面的 DefaultSelectionType 实例。
selection - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
当前选择的路径。
SELECTION_MODE_PROPERTY - 类 javax.swing.tree.DefaultTreeSelectionModel 中的静态变量
selectionMode 的属性名称。
SELECTION_MODEL_PROPERTY - 类 javax.swing.JColorChooser 中的静态变量
选择模型属性名。
SELECTION_MODEL_PROPERTY - 类 javax.swing.JTree 中的静态变量
selectionModel 的绑定属性名称。
SELECTION_VALUES_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
selectionValues 的绑定属性名。
selectionBackground - 类 javax.swing.JTable 中的变量
已选定单元格的背景色。
selectionBackground - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
selectionBackwardAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
通过将插入符在逻辑上向后移动一个位置来扩展选定内容的动作名称。
selectionBeginAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到文档开头的 Action 名称。
selectionBeginLineAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到行首并扩展选定内容的 Action 名称。
selectionBeginParagraphAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到段落开头并扩展选定内容的 Action 名称。
selectionBeginWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到字首并扩展选定内容的 Action 名称。
selectionDownAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符在逻辑上向下移动一个位置并扩展选定内容的动作名称。
selectionEndAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到文档末尾的 Action 名称。
selectionEndLineAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到行尾并扩展选定内容的 Action 名称。
selectionEndParagraphAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到段落末尾并扩展选定内容的 Action 名称。
selectionEndWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到字尾并扩展选定内容的动作名称。
selectionForeground - 类 javax.swing.JTable 中的变量
已选定单元格的前景色。
selectionForeground - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
selectionForKey(char, ComboBoxModel) - 接口 javax.swing.JComboBox.KeySelectionManager 中的方法
给定的 aKey 和模型返回应该被选择的行。
selectionForwardAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
通过将插入符在逻辑上向前移动一个位置来扩展选定内容的动作名称。
SelectionKey - java.nio.channels 中的 类
表示 SelectableChannel 在 Selector 中的注册的标记。
SelectionKey() - 类 java.nio.channels.SelectionKey 的构造方法
构造此类的一个实例。
selectionMode - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
用于 selection 的模式，将是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION。
selectionModel - 类 javax.swing.JTable 中的变量
表的 ListSelectionModel，用来追踪行选择。
selectionModel - 类 javax.swing.JTree 中的变量
对此树中选择的节点集建模。
selectionModel - 类 javax.swing.table.DefaultTableColumnModel 中的变量
跟踪列选择的模型
selectionModelChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
selectionNextWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将选定内容移动到下一个字的开头并扩展选定内容的 Action 名称。
selectionPreviousWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将选定内容移动到前一个字的开头并扩展选定内容的 Action 名称。
selectionRedirector - 类 javax.swing.JTree 中的变量
创建一个新事件，并将它传递给 selectionListeners。
selectionUpAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符在逻辑上向上移动一个位置并扩展选定内容的动作名称。
selectionValues - 类 javax.swing.JOptionPane 中的变量
用户可以从中选择值的数组。
selectLineAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于选中围绕插入符的某一行的 Action 名称。
selectNextIndex() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
选择下一行并强行使其可见。
selectNextPossibleValue() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
选择列表中的下一项。
selectNextTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
selectNextTabInRun(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
selectNow() - 类 java.nio.channels.Selector 中的方法
选择一组键，其相应的通道已为 I/O 操作准备就绪。
selector() - 类 java.nio.channels.SelectionKey 中的方法
返回为此选择器创建的键。
Selector - java.nio.channels 中的 类
SelectableChannel 对象的多路复用器。
Selector() - 类 java.nio.channels.Selector 的构造方法
初始化此类的一个新实例。
SelectorProvider - java.nio.channels.spi 中的 类
用于选择器和可选择通道的服务提供者类。
SelectorProvider() - 类 java.nio.channels.spi.SelectorProvider 的构造方法
初始化此类的一个新实例。
selectParagraphAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于选中围绕插入符的一个段落的动作名称。
selectPathForEvent(TreePath, MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
传递消息以基于特定行上的 MouseEvent 更新选择。
selectPreviousIndex() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
选择前一行并强行使其可见。
selectPreviousPossibleValue() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
选择列表中的上一项。
selectPreviousTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
selectPreviousTabInRun(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
selectText(int, int) - 接口 javax.accessibility.AccessibleEditableText 中的方法
选中两个索引之间的文本
selectText(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
选中两个索引之间的文本
selectText(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
选择两个索引之间的文本。
selectWithKeyChar(char) - 类 javax.swing.JComboBox 中的方法
如果存在与指定键盘字符相对应的项，则选择该列表项并返回 true。
selectWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于选中围绕插入符的某个字的 Action 名称。
Semaphore - java.util.concurrent 中的 类
一个计数信号量。
Semaphore(int) - 类 java.util.concurrent.Semaphore 的构造方法
创建具有给定的许可数和非公平的公平设置的 Semaphore。
Semaphore(int, boolean) - 类 java.util.concurrent.Semaphore 的构造方法
创建具有给定的许可数和给定的公平设置的 Semaphore。
send(DatagramPacket) - 类 java.net.DatagramSocket 中的方法
从此套接字发送数据报包。
send(DatagramPacket) - 类 java.net.DatagramSocketImpl 中的方法
发送数据报包。
send(DatagramPacket, byte) - 类 java.net.MulticastSocket 中的方法
已过时。 使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......
send(ByteBuffer, SocketAddress) - 类 java.nio.channels.DatagramChannel 中的方法
通过此通道发送数据报。
send(MidiMessage, long) - 接口 javax.sound.midi.Receiver 中的方法
向接收器发送一个 MIDI 消息和时间戳。
send_deferred() - 类 org.omg.CORBA.Request 中的方法
对请求进行异步调用。
send_exception(ServerRequestInfo) - 接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 中的方法
允许 Interceptor 在向客户端抛出异常前查询异常信息并修改应答服务上下文。
send_multiple_requests_deferred(Request[]) - 类 org.omg.CORBA.ORB 中的方法
异步发送多个动态 (DII) 请求。
send_multiple_requests_oneway(Request[]) - 类 org.omg.CORBA.ORB 中的方法
异步发送多个动态 (DII) 请求，并且不期望任何响应。
send_oneway() - 类 org.omg.CORBA.Request 中的方法
在请求上执行单向调用。
send_other(ServerRequestInfo) - 接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 中的方法
允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
send_poll(ClientRequestInfo) - 接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 中的方法
允许 Interceptor 在轮询获取应答序列的与时间无关的调用（Time-Independent Invocation，TII）时查询信息。
send_reply(ServerRequestInfo) - 接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 中的方法
允许 Interceptor 在已调用目标操作后、向客户端返回应答前查询应答信息并修改应答服务上下文。
send_request(ClientRequestInfo) - 接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 中的方法
允许 Interceptor 在请求被发送到服务器前查询请求信息并修改服务上下文。
sendAttributeChangeNotification(AttributeChangeNotification) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。
sendAttributeChangeNotification(Attribute, Attribute) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。
sendAttributeChangeNotification(AttributeChangeNotification) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
sendAttributeChangeNotification(Attribute, Attribute) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
sending_exception() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回一个 any，它包含将向客户端返回的异常。
sendNotification(Notification) - 类 javax.management.MBeanServerDelegate 中的方法
允许 MBean 服务器发送通知。
sendNotification(Notification) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
sendNotification(String) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
sendNotification(Notification) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
sendNotification(String) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
sendNotification(Notification) - 类 javax.management.NotificationBroadcasterSupport 中的方法
发送一个通知。
sendNotification(Notification) - 类 javax.management.StandardEmitterMBean 中的方法
发送通知。
sendRelationCreationNotification(String) - 类 javax.management.relation.RelationService 中的方法
发送关系创建通知 (RelationNotification)。
sendRelationCreationNotification(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
发送关系创建通知 (RelationNotification)。
sendRelationRemovalNotification(String, List<ObjectName>) - 类 javax.management.relation.RelationService 中的方法
发送关系移除通知 (RelationNotification)。
sendRelationRemovalNotification(String, List<ObjectName>) - 接口 javax.management.relation.RelationServiceMBean 中的方法
发送关系移除通知 (RelationNotification)。
sendRoleUpdateNotification(String, Role, List<ObjectName>) - 类 javax.management.relation.RelationService 中的方法
发送给定关系中的角色更新通知 (RelationNotification)。
sendRoleUpdateNotification(String, Role, List<ObjectName>) - 接口 javax.management.relation.RelationServiceMBean 中的方法
发送给定关系中的角色更新通知 (RelationNotification)。
sendUrgentData(int) - 类 java.net.Socket 中的方法
在套接字上发送一个紧急数据字节。
sendUrgentData(int) - 类 java.net.SocketImpl 中的方法
在套接字上发送一个紧急数据字节。
SENTENCE - 接口 javax.accessibility.AccessibleText 中的静态变量
用于指示应获取的文本部分是一个语句的常量。
SEPARATE_DOCUMENTS_COLLATED_COPIES - 类 java.awt.JobAttributes.MultipleDocumentHandlingType 中的静态变量
用于指定应该将作业分成单独的、已整理的副本的 MultipleDocumentHandlingType 实例。
SEPARATE_DOCUMENTS_COLLATED_COPIES - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的静态变量
独立文档逐份打印副本 －－ 有关更多信息，请参见上文。
SEPARATE_DOCUMENTS_UNCOLLATED_COPIES - 类 java.awt.JobAttributes.MultipleDocumentHandlingType 中的静态变量
用于指定应该将作业分成单独的、未整理的副本的 MultipleDocumentHandlingType 实例。
SEPARATE_DOCUMENTS_UNCOLLATED_COPIES - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的静态变量
独立文档非逐份打印副本 －－ 有关更多信息，请参见上文。
separator - 类 java.io.File 中的静态变量
与系统有关的默认名称分隔符，为了方便，它被表示为一个字符串。
SEPARATOR - 类 javax.accessibility.AccessibleRole 中的静态变量
通常包含在菜单中的对象，它对菜单中的内容进行可视和逻辑分离。
SEPARATOR - 类 javax.swing.plaf.synth.Region 中的静态变量
Separator 的 region。
separatorChar - 类 java.io.File 中的静态变量
与系统有关的默认名称分隔符。
SeparatorUI - javax.swing.plaf 中的 类
JSeparator 的可插入外观界面。
SeparatorUI() - 类 javax.swing.plaf.SeparatorUI 的构造方法
SEPTEMBER - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第九个月的 Calendar.MONTH 字段值。
SEPTEMBER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第九个月的值。
Sequence - javax.sound.midi 中的 类
Sequence 是一种数据结构，包含可由 Sequencer 对象回放的音乐信息（通常是整首歌曲或音乐作品）。
Sequence(float, int) - 类 javax.sound.midi.Sequence 的构造方法
构造具有指定的定时 division 类型和定时精度的新 MIDI Sequence。
Sequence(float, int, int) - 类 javax.sound.midi.Sequence 的构造方法
构造具有指定的定时 division 类型、定时精度和轨道数的新 MIDI Sequence。
sequenceComplete(ImageReader) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告读操作序列已经完成。
SequenceInputStream - java.io 中的 类
SequenceInputStream 表示其他输入流的逻辑串联。
SequenceInputStream(Enumeration<? extends InputStream>) - 类 java.io.SequenceInputStream 的构造方法
通过记住参数来初始化新创建的 SequenceInputStream，该参数必须是生成运行时类型为 InputStream 对象的 Enumeration 型参数。
SequenceInputStream(InputStream, InputStream) - 类 java.io.SequenceInputStream 的构造方法
通过记住这两个参数来初始化新创建的 SequenceInputStream（将按顺序读取这两个参数，先读取 s1，然后读取 s2），以提供从此 SequenceInputStream 读取的字节。
Sequencer - javax.sound.midi 中的 接口
回放 MIDI sequence 的硬件或软件设备就是所谓的 sequencer。
Sequencer.SyncMode - javax.sound.midi 中的 类
SyncMode 对象表示 MIDI sequencer 的时间标记可与主或从设备同步的方式之一。
Sequencer.SyncMode(String) - 类 javax.sound.midi.Sequencer.SyncMode 的构造方法
构造一个同步模式。
sequenceStarted(ImageReader, int) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告读操作序列将要开始。
SerialArray - javax.sql.rowset.serial 中的 类
序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。
SerialArray(Array, Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialArray 的构造方法
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
SerialArray(Array) - 类 javax.sql.rowset.serial.SerialArray 的构造方法
根据给定 Array 对象构造新的 SerialArray 对象。
SerialBlob - javax.sql.rowset.serial 中的 类
SQL BLOB 值在 Java 编程语言中的序列化映射关系。
SerialBlob(byte[]) - 类 javax.sql.rowset.serial.SerialBlob 的构造方法
按照给定 byte 数组的序列化形式构造一个 SerialBlob 对象。
SerialBlob(Blob) - 类 javax.sql.rowset.serial.SerialBlob 的构造方法
根据给定 Blob 对象的序列化形式构造一个 SerialBlob 对象。
SerialClob - javax.sql.rowset.serial 中的 类
SQL CLOB 值在 Java 编程语言中的序列化映射关系。
SerialClob(char[]) - 类 javax.sql.rowset.serial.SerialClob 的构造方法
按照给定 char 数组的序列化形式构造一个 SerialClob 对象。
SerialClob(Clob) - 类 javax.sql.rowset.serial.SerialClob 的构造方法
按照给定 Clob 对象的序列化形式构造一个 SerialClob 对象。
SerialDatalink - javax.sql.rowset.serial 中的 类
SQL DATALINK 值在 Java 编程语言中的序列化映射关系。
SerialDatalink(URL) - 类 javax.sql.rowset.serial.SerialDatalink 的构造方法
根据给定的 java.net.URL 对象构造新的 SerialDatalink 对象。
SerialException - javax.sql.rowset.serial 中的 异常
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。
SerialException() - 异常 javax.sql.rowset.serial.SerialException 的构造方法
创建不带消息的新 SerialException。
SerialException(String) - 异常 javax.sql.rowset.serial.SerialException 的构造方法
创建带有指定消息的新 SerialException。
serializable - 类 java.beans.beancontext.BeanContextServicesSupport 中的变量
可序列化 BeanContextServceProvider 的实例数。
Serializable - java.io 中的 接口
类通过实现 java.io.Serializable 接口以启用其序列化功能。
SerializablePermission - java.io 中的 类
此类用于可序列化权限。
SerializablePermission(String) - 类 java.io.SerializablePermission 的构造方法
创建具有指定名称的新 SerializablePermission。
SerializablePermission(String, String) - 类 java.io.SerializablePermission 的构造方法
创建具有指定名称的新 SerializablePermission 对象。
serialize(ObjectOutputStream, Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
writeObject 使用此方法来序列化一个 Collection。
SERIALIZE_ERR - 异常 org.w3c.dom.ls.LSException 中的静态变量
如果尝试使用 LSSerializer 序列化 Node 并且处理已经停止。
SerialJavaObject - javax.sql.rowset.serial 中的 类
SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。
SerialJavaObject(Object) - 类 javax.sql.rowset.serial.SerialJavaObject 的构造方法
SerialJavaObject 帮助器类的构造方法。
SerialRef - javax.sql.rowset.serial 中的 类
Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。
SerialRef(Ref) - 类 javax.sql.rowset.serial.SerialRef 的构造方法
根据给定 Ref 对象构造 SerialRef 对象。
SerialStruct - javax.sql.rowset.serial 中的 类
SQL 结构类型在 Java 编程语言中的序列化映射关系。
SerialStruct(Struct, Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialStruct 的构造方法
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。
SerialStruct(SQLData, Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialStruct 的构造方法
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。
serialVersionUID - 接口 java.rmi.server.RemoteRef 中的静态变量
指示与类的 JDK 1.1.x 版本的兼容性。
serialVersionUID - 接口 java.rmi.server.ServerRef 中的静态变量
指示与类的 JDK 1.1.x 版本的兼容性。
serialVersionUID - 接口 java.security.interfaces.DSAPrivateKey 中的静态变量
设置为指示与以前的类版本序列化兼容的类指纹。
serialVersionUID - 接口 java.security.interfaces.DSAPublicKey 中的静态变量
设置为指示与以前的类版本序列化兼容的类指纹。
serialVersionUID - 接口 java.security.interfaces.ECPrivateKey 中的静态变量
设置为指示序列化兼容性的类指纹。
serialVersionUID - 接口 java.security.interfaces.ECPublicKey 中的静态变量
设置为指示序列化兼容性的类指纹。
serialVersionUID - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的静态变量
serialVersionUID - 接口 java.security.interfaces.RSAPrivateCrtKey 中的静态变量
serialVersionUID - 接口 java.security.interfaces.RSAPrivateKey 中的静态变量
serialVersionUID - 接口 java.security.interfaces.RSAPublicKey 中的静态变量
serialVersionUID - 接口 java.security.Key 中的静态变量
设置为指示与以前的类版本序列化兼容的类指纹。
serialVersionUID - 接口 java.security.PrivateKey 中的静态变量
设置为指示与以前的类版本序列化兼容的类指纹。
serialVersionUID - 接口 java.security.PublicKey 中的静态变量
设置为指示与以前的类版本序列化兼容的类指纹。
serialVersionUID - 接口 javax.crypto.interfaces.DHPrivateKey 中的静态变量
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
serialVersionUID - 接口 javax.crypto.interfaces.DHPublicKey 中的静态变量
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
serialVersionUID - 接口 javax.crypto.interfaces.PBEKey 中的静态变量
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
serialVersionUID - 接口 javax.crypto.SecretKey 中的静态变量
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
serialVersionUID - 接口 javax.naming.directory.Attribute 中的静态变量
使用 JNDI 1.1.1 中的 serialVersionUID 获取互操作性。
serialVersionUID - 接口 javax.naming.Name 中的静态变量
为指示与以前的类版本序列化兼容而设置的类指纹。
SERIF - 类 java.awt.Font 中的静态变量
逻辑字体 "Serif" 的规范系列名称的 String 常量。
servant - 类 org.omg.CORBA.portable.ServantObject 中的变量
实际的 servant。
Servant - org.omg.PortableServer 中的 类
定义本机 Servant 类型。
Servant() - 类 org.omg.PortableServer.Servant 的构造方法
servant_postinvoke(Object, ServantObject) - 类 org.omg.CORBA.portable.Delegate 中的方法
servant_postinvoke() 由本地 stub 在已经对本地 servant 调用该操作之后调用。
servant_preinvoke(Object, String, Class) - 类 org.omg.CORBA.portable.Delegate 中的方法
返回对应该用作此请求的 servant 的 Java 引用。
SERVANT_RETENTION_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java。
servant_to_id(Servant) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作有四种可能的行为。
servant_to_reference(Servant) - 接口 org.omg.PortableServer.POAOperations 中的方法
如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。
ServantActivator - org.omg.PortableServer 中的 接口
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorHelper - org.omg.PortableServer 中的 类
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorHelper() - 类 org.omg.PortableServer.ServantActivatorHelper 的构造方法
ServantActivatorOperations - org.omg.PortableServer 中的 接口
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorPOA - org.omg.PortableServer 中的 类
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorPOA() - 类 org.omg.PortableServer.ServantActivatorPOA 的构造方法
ServantAlreadyActive - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
ServantAlreadyActive() - 异常 org.omg.PortableServer.POAPackage.ServantAlreadyActive 的构造方法
ServantAlreadyActive(String) - 异常 org.omg.PortableServer.POAPackage.ServantAlreadyActive 的构造方法
ServantAlreadyActiveHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java。
ServantAlreadyActiveHelper() - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 的构造方法
ServantLocator - org.omg.PortableServer 中的 接口
当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
ServantLocatorHelper - org.omg.PortableServer 中的 类
POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。
ServantLocatorHelper() - 类 org.omg.PortableServer.ServantLocatorHelper 的构造方法
ServantLocatorOperations - org.omg.PortableServer 中的 接口
当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
ServantLocatorPOA - org.omg.PortableServer 中的 类
POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。
ServantLocatorPOA() - 类 org.omg.PortableServer.ServantLocatorPOA 的构造方法
ServantManager - org.omg.PortableServer 中的 接口
servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
ServantManagerOperations - org.omg.PortableServer 中的 接口
servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
ServantNotActive - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/ServantNotActive.java。
ServantNotActive() - 异常 org.omg.PortableServer.POAPackage.ServantNotActive 的构造方法
ServantNotActive(String) - 异常 org.omg.PortableServer.POAPackage.ServantNotActive 的构造方法
ServantNotActiveHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java。
ServantNotActiveHelper() - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 的构造方法
ServantObject - org.omg.CORBA.portable 中的 类
此类是本地 stub API 的一部分，其目的是为配置的客户端和服务器（即驻留在同一 Java VM 上的客户端和服务器）提供高性能的调用。
ServantObject() - 类 org.omg.CORBA.portable.ServantObject 的构造方法
ServantRetentionPolicy - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
ServantRetentionPolicyOperations - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
ServantRetentionPolicyValue - org.omg.PortableServer 中的 类
ServantRetentionPolicyValue 可以具有以下值。
ServantRetentionPolicyValue(int) - 类 org.omg.PortableServer.ServantRetentionPolicyValue 的构造方法
server - 类 javax.management.monitor.Monitor 中的变量
对 MBean 服务器的引用。
SERVER_AUTH - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定服务器是否必须验证客户端。
server_id() - 接口 org.omg.PortableInterceptor.ObjectReferenceTemplate 中的方法
server_id() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回使用 -ORBServerId 参数的 ORB::init 上指定的服务器 ID。
ServerCloneException - java.rmi.server 中的 异常
如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。
ServerCloneException(String) - 异常 java.rmi.server.ServerCloneException 的构造方法
构造带指定详细消息的 ServerCloneException。
ServerCloneException(String, Exception) - 异常 java.rmi.server.ServerCloneException 的构造方法
构造带指定详细消息和原因的 ServerCloneException。
ServerError - java.rmi 中的 异常
当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
ServerError(String, Error) - 异常 java.rmi.ServerError 的构造方法
构造带指定详细消息和嵌入错误的 ServerError。
ServerException - java.rmi 中的 异常
在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
ServerException(String) - 异常 java.rmi.ServerException 的构造方法
构造带指定详细消息的 ServerException。
ServerException(String, Exception) - 异常 java.rmi.ServerException 的构造方法
构造带有指定详细消息和嵌入异常的 ServerException。
ServerIdHelper - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/ServerIdHelper.java。
ServerIdHelper() - 类 org.omg.PortableInterceptor.ServerIdHelper 的构造方法
ServerNotActiveException - java.rmi.server 中的 异常
如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。
ServerNotActiveException() - 异常 java.rmi.server.ServerNotActiveException 的构造方法
构造不带指定详细消息的 ServerNotActiveException。
ServerNotActiveException(String) - 异常 java.rmi.server.ServerNotActiveException 的构造方法
构造带指定详细消息的 ServerNotActiveException。
ServerRef - java.rmi.server 中的 接口
ServerRef 表示远程对象实现的服务器端句柄。
ServerRequest - org.omg.CORBA 中的 类
捕获对动态框架接口（Dynamic Skeleton Interface，DSI）请求的显式状态的对象。
ServerRequest() - 类 org.omg.CORBA.ServerRequest 的构造方法
ServerRequestInfo - org.omg.PortableInterceptor 中的 接口
服务器端请求 interceptor 可访问的请求信息。
ServerRequestInfoOperations - org.omg.PortableInterceptor 中的 接口
服务器端请求 interceptor 可访问的请求信息。
ServerRequestInterceptor - org.omg.PortableInterceptor 中的 接口
服务器端的请求 interceptor。
ServerRequestInterceptorOperations - org.omg.PortableInterceptor 中的 接口
服务器端的请求 interceptor。
ServerRuntimeException - java.rmi 中的 异常
已过时。 无替换版本
ServerRuntimeException(String, Exception) - 异常 java.rmi.ServerRuntimeException 的构造方法
已过时。 无替换版本
ServerSocket - java.net 中的 类
此类实现服务器套接字。
ServerSocket() - 类 java.net.ServerSocket 的构造方法
创建非绑定服务器套接字。
ServerSocket(int) - 类 java.net.ServerSocket 的构造方法
创建绑定到特定端口的服务器套接字。
ServerSocket(int, int) - 类 java.net.ServerSocket 的构造方法
利用指定的 backlog 创建服务器套接字并将其绑定到指定的本地端口号。
ServerSocket(int, int, InetAddress) - 类 java.net.ServerSocket 的构造方法
使用指定的端口、侦听 backlog 和要绑定到的本地 IP 地址创建服务器。
ServerSocketChannel - java.nio.channels 中的 类
针对面向流的侦听套接字的可选择通道。
ServerSocketChannel(SelectorProvider) - 类 java.nio.channels.ServerSocketChannel 的构造方法
初始化此类的一个新实例。
ServerSocketFactory - javax.net 中的 类
此类创建服务器套接字。
ServerSocketFactory() - 类 javax.net.ServerSocketFactory 的构造方法
创建服务器套接字工厂。
Service - javax.xml.ws 中的 类
Service 对象提供 Web 服务的客户端视图。
Service(URL, QName) - 类 javax.xml.ws.Service 的构造方法
Service.Mode - javax.xml.ws 中的 枚举
动态客户端或服务的方向。
service_detail - 类 org.omg.CORBA.ServiceDetail 中的变量
描述此 ServiceDetail 对象所表示的 ORB 服务的数据。
service_detail_type - 类 org.omg.CORBA.ServiceDetail 中的变量
此 ServiceDetail 对象表示的 ORB 服务的类型。
service_details - 类 org.omg.CORBA.ServiceInformation 中的变量
提供有关服务更多详细信息的 ServiceDetail 所组成的数组。
SERVICE_OFF_LINE - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机离线，不接受作业。
service_options - 类 org.omg.CORBA.ServiceInformation 中的变量
表示服务选项的 int 值所组成的数组。
serviceAvailable(BeanContextServiceAvailableEvent) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
可从嵌套 BeanContext 中获得新的服务。
serviceAvailable(BeanContextServiceAvailableEvent) - 接口 java.beans.beancontext.BeanContextServicesListener 中的方法
指定服务已被注册。
serviceAvailable(BeanContextServiceAvailableEvent) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。
serviceClass - 类 java.beans.beancontext.BeanContextServiceAvailableEvent 中的变量
新近可用服务的 Class 引用
serviceClass - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 中的变量
将被取消服务的 Class 引用。
ServiceConfigurationError - java.util 中的 错误
在加载服务提供者的过程中出错时抛出的错误。
ServiceConfigurationError(String) - 错误 java.util.ServiceConfigurationError 的构造方法
构造一个带有指定消息的新实例。
ServiceConfigurationError(String, Throwable) - 错误 java.util.ServiceConfigurationError 的构造方法
构造一个带有指定消息和 cause 的新实例。
ServiceContext - org.omg.IOP 中的 类
org/omg/IOP/ServiceContext.java。
ServiceContext() - 类 org.omg.IOP.ServiceContext 的构造方法
ServiceContext(int, byte[]) - 类 org.omg.IOP.ServiceContext 的构造方法
ServiceContextHelper - org.omg.IOP 中的 类
org/omg/IOP/ServiceContextHelper.java。
ServiceContextHelper() - 类 org.omg.IOP.ServiceContextHelper 的构造方法
ServiceContextHolder - org.omg.IOP 中的 类
org/omg/IOP/ServiceContextHolder.java。
ServiceContextHolder() - 类 org.omg.IOP.ServiceContextHolder 的构造方法
ServiceContextHolder(ServiceContext) - 类 org.omg.IOP.ServiceContextHolder 的构造方法
ServiceContextListHelper - org.omg.IOP 中的 类
形成服务上下文列表的一组服务上下文。
ServiceContextListHelper() - 类 org.omg.IOP.ServiceContextListHelper 的构造方法
ServiceContextListHolder - org.omg.IOP 中的 类
形成服务上下文列表的一组服务上下文。
ServiceContextListHolder() - 类 org.omg.IOP.ServiceContextListHolder 的构造方法
ServiceContextListHolder(ServiceContext[]) - 类 org.omg.IOP.ServiceContextListHolder 的构造方法
ServiceDelegate - javax.xml.ws.spi 中的 类
服务委托由 Service 对象内部使用，以允许插入 JAX-WS 实现。
ServiceDelegate() - 类 javax.xml.ws.spi.ServiceDelegate 的构造方法
ServiceDetail - org.omg.CORBA 中的 类
表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。
ServiceDetail() - 类 org.omg.CORBA.ServiceDetail 的构造方法
使用 0 作为 ORB 服务的类型并使用空描述构造一个 ServiceDetail 对象。
ServiceDetail(int, byte[]) - 类 org.omg.CORBA.ServiceDetail 的构造方法
使用给定 ORB 服务类型和给定描述构造一个 ServiceDetail 对象。
ServiceDetailHelper - org.omg.CORBA 中的 类
ServiceDetailHelper() - 类 org.omg.CORBA.ServiceDetailHelper 的构造方法
ServiceIdHelper - org.omg.IOP 中的 类
以 int 形式表示的服务 id
ServiceIdHelper() - 类 org.omg.IOP.ServiceIdHelper 的构造方法
ServiceInformation - org.omg.CORBA 中的 类
CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。
ServiceInformation() - 类 org.omg.CORBA.ServiceInformation 的构造方法
使用空 service_options 和 service_details 构造一个 ServiceInformation 对象。
ServiceInformation(int[], ServiceDetail[]) - 类 org.omg.CORBA.ServiceInformation 的构造方法
使用给定 service_options 和 service_details 构造一个 ServiceInformation 对象。
ServiceInformationHelper - org.omg.CORBA 中的 类
ServiceInformationHelper() - 类 org.omg.CORBA.ServiceInformationHelper 的构造方法
ServiceInformationHolder - org.omg.CORBA 中的 类
ServiceInformation 的 Holder。
ServiceInformationHolder() - 类 org.omg.CORBA.ServiceInformationHolder 的构造方法
构造一个新的 ServiceInformationHolder 对象，将其 value 字段初始化为 null。
ServiceInformationHolder(ServiceInformation) - 类 org.omg.CORBA.ServiceInformationHolder 的构造方法
构造一个新的 ServiceInformationHolder 对象，将其 value 字段初始化为给定的 ServiceInformation 对象。
ServiceLoader<S> - java.util 中的 类
一个简单的服务提供者加载设施。
ServiceMode - javax.xml.ws 中的 注释类型
用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
ServiceNotFoundException - javax.management 中的 异常
表示请求的服务不受支持时引发的异常。
ServiceNotFoundException() - 异常 javax.management.ServiceNotFoundException 的构造方法
默认的构造方法。
ServiceNotFoundException(String) - 异常 javax.management.ServiceNotFoundException 的构造方法
允许指定特定错误消息的构造方法。
ServicePermission - javax.security.auth.kerberos 中的 类
此类用于保护 Kerberos 服务和访问这些服务所必需的证书。
ServicePermission(String, String) - 类 javax.security.auth.kerberos.ServicePermission 的构造方法
创建带指定的 servicePrincipal 和 action 的新 ServicePermission。
serviceProvider - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider 中的变量
ServiceRegistry - javax.imageio.spi 中的 类
用于服务提供者实例的注册表。
ServiceRegistry(Iterator<Class<?>>) - 类 javax.imageio.spi.ServiceRegistry 的构造方法
使用取自 categories 参数的一组类别构造 ServiceRegistry 实例。
ServiceRegistry.Filter - javax.imageio.spi 中的 接口
ServiceRegistry.getServiceProviders 使用的一个简单过滤器接口，用来选择与任意条件匹配的提供者。
serviceRevoked(BeanContextServiceRevokedEvent) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
由嵌套 BeanContext 提供的服务已经被取消。
serviceRevoked(BeanContextServiceRevokedEvent) - 接口 java.beans.beancontext.BeanContextServiceRevokedListener 中的方法
指定服务已被取消。
serviceRevoked(BeanContextServiceRevokedEvent) - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider 中的方法
serviceRevoked(BeanContextServiceRevokedEvent) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。
services - 类 java.beans.beancontext.BeanContextServicesSupport 中的变量
protected transient HashMap services 字段的所有访问在该对象上都应该是同步的。
ServiceUI - javax.print 中的 类
此类是各种 UI 便捷方法的集合，这些方法为浏览那些通过 Java Print Service API 所查找的 PrintService 提供了图形用户对话框。
ServiceUI() - 类 javax.print.ServiceUI 的构造方法
ServiceUIFactory - javax.print 中的 类
服务可以可选地提供 UI，这些 UI 允许以不同的角色进行不同风格的交互。
ServiceUIFactory() - 类 javax.print.ServiceUIFactory 的构造方法
ServiceUnavailableException - javax.naming 中的 异常
当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
ServiceUnavailableException(String) - 异常 javax.naming.ServiceUnavailableException 的构造方法
使用解释构造一个新的 ServiceUnavailableException 实例。
ServiceUnavailableException() - 异常 javax.naming.ServiceUnavailableException 的构造方法
构造一个新的 ServiceUnavailableException 实例。
SERVLET_CONTEXT - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：servlet 上下文对象
SERVLET_REQUEST - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：servlet 请求对象。
SERVLET_RESPONSE - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：servlet 响应对象。
SESSION_MAINTAIN_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
标准属性：服务客户端使用此 boolean 属性指示它是否希望参与与服务端点的会话。
set(Object, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
替换此参数列表中的一个 Object。
set(byte, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Byte 替换参数列表中的一个 Object。
set(char, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Character 替换参数列表中的一个 Object。
set(short, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Short 替换参数列表中的一个 Object。
set(int, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Integer 替换参数列表中的一个 Object。
set(long, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Long 替换参数列表中的一个 Object。
set(float, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Float 替换参数列表中的一个 Object。
set(double, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Double 替换参数列表中的一个 Object。
set(int, int, int, int) - 类 java.awt.Insets 中的方法
将顶部、底部、左边和右边设置为指定值
set(JobAttributes) - 类 java.awt.JobAttributes 中的方法
将此 JobAttributes 的所有属性设置为与 obj 的属性相同的值。
set(PageAttributes) - 类 java.awt.PageAttributes 中的方法
将此 PageAttributes 的所有属性设置为与 obj 的属性相同的值。
set(Object, int, Object) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的新值。
set(Object, Object) - 类 java.lang.reflect.Field 中的方法
将指定对象变量上此 Field 对象表示的字段设置为指定的新值。
set(T) - 类 java.lang.ThreadLocal 中的方法
将此线程局部变量的当前线程副本中的值设置为指定值。
set(String, String, int, String, String) - 类 java.net.URL 中的方法
设置 URL 的字段。
set(String, String, int, String, String, String, String, String) - 类 java.net.URL 中的方法
设置 URL 的指定的 8 个字段。
set(int, E) - 类 java.util.AbstractList 中的方法
用指定元素替换列表中指定位置的元素（可选操作）。
set(int, E) - 类 java.util.AbstractSequentialList 中的方法
用指定的元素替代此列表中指定位置上的元素（可选操作）。
set(int, E) - 类 java.util.ArrayList 中的方法
用指定的元素替代此列表中指定位置上的元素。
set(int) - 类 java.util.BitSet 中的方法
将指定索引处的位设置为 true。
set(int, boolean) - 类 java.util.BitSet 中的方法
将指定索引处的位设置为指定的值。
set(int, int) - 类 java.util.BitSet 中的方法
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为 true。
set(int, int, boolean) - 类 java.util.BitSet 中的方法
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为指定的值。
set(int, int) - 类 java.util.Calendar 中的方法
将给定的日历字段设置为给定值。
set(int, int, int) - 类 java.util.Calendar 中的方法
设置日历字段 YEAR、MONTH 和 DAY_OF_MONTH 的值。
set(int, int, int, int, int) - 类 java.util.Calendar 中的方法
设置日历字段 YEAR、MONTH、DAY_OF_MONTH、HOUR_OF_DAY 和 MINUTE 的值。
set(int, int, int, int, int, int) - 类 java.util.Calendar 中的方法
设置字段 YEAR、MONTH、DAY_OF_MONTH、HOUR、MINUTE 和 SECOND 的值。
set(boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
无条件地设置为给定值。
set(int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
设置为给定值。
set(int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
将位置 i 的元素设置为给定值。
set(T, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
将此更新器管理的给定对象的字段设置为给定更新值。
set(long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
设置为给定值。
set(int, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
将位置 i 的元素设置为给定值。
set(T, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
将此更新器管理的给定对象的字段设置为给定更新值。
set(V, boolean) - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
无条件地同时设置该引用和标记的值。
set(V) - 类 java.util.concurrent.atomic.AtomicReference 中的方法
设置为给定值。
set(int, E) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
将位置 i 的元素设置为给定值。
set(T, V) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
将此更新器管理的给定对象的字段设置为给定更新值。
set(V, int) - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
无条件地同时设置该引用和标志的值。
set(int, E) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
用指定的元素替代此列表指定位置上的元素。
set(V) - 类 java.util.concurrent.FutureTask 中的方法
除非已经设置了此 Future 或已将其取消，否则将其结果设置为给定的值。
set(int, E) - 类 java.util.LinkedList 中的方法
将此列表中指定位置的元素替换为指定的元素。
set(int, E) - 接口 java.util.List 中的方法
用指定元素替换列表中指定位置的元素（可选操作）。
set(E) - 接口 java.util.ListIterator 中的方法
用指定元素替换 next 或 previous 返回的最后一个元素（可选操作）。
Set<E> - java.util 中的 接口
一个不包含重复元素的 collection。
set(int, E) - 类 java.util.Vector 中的方法
用指定的元素替换此向量中指定位置处的元素。
set(String, String) - 类 javax.activation.MimeTypeParameterList 中的方法
将值设置为与给定名称关联，替换以前的任何关联。
set(int, Attribute) - 类 javax.management.AttributeList 中的方法
将指定位置的元素设置为指定的属性。
set(int, Object) - 类 javax.management.AttributeList 中的方法
set(int, Role) - 类 javax.management.relation.RoleList 中的方法
将指定位置处的元素设置为指定角色。
set(int, Object) - 类 javax.management.relation.RoleList 中的方法
set(int, RoleUnresolved) - 类 javax.management.relation.RoleUnresolvedList 中的方法
将指定位置处的元素设置为指定的未解析角色。
set(int, Object) - 类 javax.management.relation.RoleUnresolvedList 中的方法
set(int, Object) - 接口 javax.naming.directory.Attribute 中的方法
设置属性值的有序列表中的属性值。
set(int, Object) - 类 javax.naming.directory.BasicAttribute 中的方法
set(int, Object) - 类 javax.swing.DefaultListModel 中的方法
使用指定元素替换此列表中指定位置上的元素。
set2DigitYearStart(Date) - 类 java.text.SimpleDateFormat 中的方法
设置 100 年周期的两位数年份，该年份将被解释为从用户指定的日期开始。
set_as_default() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 确定与此 union 关联的鉴别符是否已经分配了一个有效默认值。
set_as_default(boolean) - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 确定与此 union 关联的鉴别符是否被分配了一个有效默认值。
set_as_string(String) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。
set_as_string(String) - 接口 org.omg.DynamicAny.DynEnumOperations 中的方法
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。
set_as_ulong(int) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 DynEnum 的值设置为枚举值的序号。
set_as_ulong(int) - 接口 org.omg.DynamicAny.DynEnumOperations 中的方法
将 DynEnum 的值设置为枚举值的序号。
set_boxed_value(Any) - 接口 org.omg.DynamicAny.DynValueBoxOperations 中的方法
使用指定值取代已装箱值。
set_boxed_value_as_dyn_any(DynAny) - 接口 org.omg.DynamicAny.DynValueBoxOperations 中的方法
使用参数中包含的值取代已装箱值。
set_delegate(Object) - 类 org.omg.CORBA_2_3.ORB 中的方法
set_discriminator(DynAny) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 DynUnion 的鉴别符值设置为指定值。
set_discriminator(DynAny) - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
将 DynUnion 的鉴别符值设置为指定值。
set_elements(Any[]) - 接口 org.omg.CORBA.DynArray 中的方法
已过时。 将此 DynArray 对象的值设置为给定数组。
set_elements(Any[]) - 接口 org.omg.CORBA.DynSequence 中的方法
已过时。 使用给定数组设置此 sequence 中所有元素的值。
set_elements(Any[]) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
设置 DynArray 以包含传递的元素。
set_elements(Any[]) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
设置序列的元素。
set_elements(Any[]) - 接口 org.omg.DynamicAny.DynArrayOperations 中的方法
设置 DynArray 以包含传递的元素。
set_elements(Any[]) - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
设置序列的元素。
set_elements_as_dyn_any(DynAny[]) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
设置 DynArray 以包含传递的元素。
set_elements_as_dyn_any(DynAny[]) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
使用 DynAny 设置序列的元素。
set_elements_as_dyn_any(DynAny[]) - 接口 org.omg.DynamicAny.DynArrayOperations 中的方法
设置 DynArray 以包含传递的元素。
set_elements_as_dyn_any(DynAny[]) - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
使用 DynAny 设置序列的元素。
set_exception(Any) - 类 org.omg.CORBA.ServerRequest 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
set_length(int) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
设置序列的长度。
set_length(int) - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
设置序列的长度。
set_members(NameValuePair[]) - 接口 org.omg.CORBA.DynStruct 中的方法
已过时。 设置 struct 的成员。
set_members(NameValuePair[]) - 接口 org.omg.CORBA.DynValue 中的方法
已过时。 将此 DynValue 对象表示的 value 对象成员设置为给定的 NameValuePair 对象数组。
set_members(NameValuePair[]) - 类 org.omg.DynamicAny._DynStructStub 中的方法
初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
set_members(NameValuePair[]) - 类 org.omg.DynamicAny._DynValueStub 中的方法
根据 NameValuePair 序列初始化该值类型的成员。
set_members(NameValuePair[]) - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
set_members(NameValuePair[]) - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
根据 NameValuePair 序列初始化该值类型的成员。
set_members_as_dyn_any(NameDynAnyPair[]) - 类 org.omg.DynamicAny._DynStructStub 中的方法
初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
set_members_as_dyn_any(NameDynAnyPair[]) - 类 org.omg.DynamicAny._DynValueStub 中的方法
根据 NameDynAnyPair 序列初始化该值类型的成员。
set_members_as_dyn_any(NameDynAnyPair[]) - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
set_members_as_dyn_any(NameDynAnyPair[]) - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
根据 NameDynAnyPair 序列初始化该值类型的成员。
set_one_value(String, Any) - 类 org.omg.CORBA.Context 中的方法
创建一个 NamedValue 对象，并将它添加到此 Context 对象中。
SET_OVERRIDE - 类 org.omg.CORBA.SetOverrideType 中的静态变量
用于枚举值 SET_OVERRIDE 的 SetOverrideType 常量。
set_parameters(String[], Properties) - 类 org.omg.CORBA.ORB 中的方法
允许使用给定的参数和属性初始化 ORB 实现。
set_parameters(Applet, Properties) - 类 org.omg.CORBA.ORB 中的方法
允许使用给定 applet 和参数初始化 ORB 实现。
set_policy_override(Object, Policy[], SetOverrideType) - 类 org.omg.CORBA.portable.Delegate 中的方法
将传入的策略与它返回的新创建对象引用关联。
set_result(Any) - 类 org.omg.CORBA.ServerRequest 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
set_return_type(TypeCode) - 类 org.omg.CORBA.Request 中的方法
设置该方法返回值的 typecode。
set_servant(Servant) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作在 POA 中将指定的 servant 注册为默认 servant。
set_servant_manager(ServantManager) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作设置与 POA 关联的默认 servant 管理器。
set_slot(int, Any) - 接口 org.omg.PortableInterceptor.CurrentOperations 中的方法
在槽中设置数据。
set_slot(int, Any) - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
允许 Interceptor 在请求域中的 PortableInterceptor.Current 内设置槽 (slot)。
set_to_default_member() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将鉴别符设置为联合数据的默认 case 的值。
set_to_default_member() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
将鉴别符设置为联合数据的默认 case 的值。
set_to_no_active_member() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将鉴别符设置为与任何联合数据 case 标签都不相应的值。
set_to_no_active_member() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
将鉴别符设置为与任何联合数据 case 标签都不相应的值。
set_to_null() - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 DynValueCommon 的表示形式更改为 null 值类型。
set_to_null() - 接口 org.omg.DynamicAny.DynValueCommonOperations 中的方法
将 DynValueCommon 的表示形式更改为 null 值类型。
set_to_value() - 类 org.omg.DynamicAny._DynValueStub 中的方法
使用新构造的值取代 null 值类型。
set_to_value() - 接口 org.omg.DynamicAny.DynValueCommonOperations 中的方法
使用新构造的值取代 null 值类型。
set_value(byte[]) - 接口 org.omg.CORBA.DynFixed 中的方法
已过时。 将给定 fixed 类型的实例设置为此 DynFixed 对象的值。
set_value(String) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
设置 DynFixed 的值。
set_value(String) - 接口 org.omg.DynamicAny.DynFixedOperations 中的方法
设置 DynFixed 的值。
set_values(NVList) - 类 org.omg.CORBA.Context 中的方法
在此 Context 对象中设置一个或多个属性值。
setAccelerationPriority(float) - 类 java.awt.Image 中的方法
就加速的重要性设置此图像的提示。
setAccelerator(KeyStroke) - 类 javax.swing.JMenu 中的方法
没有为 JMenu 定义 setAccelerator。
setAccelerator(KeyStroke) - 类 javax.swing.JMenuItem 中的方法
设置修改键，它能直接调用菜单项的操作侦听器而不必显示菜单的层次结构。
setAcceptAllFileFilterUsed(boolean) - 类 javax.swing.JFileChooser 中的方法
确定是否将 AcceptAll FileFilter 用作可选择过滤器列表中一个可用选项。
setAccessible(AccessibleObject[], boolean) - 类 java.lang.reflect.AccessibleObject 中的静态方法
使用单一安全性检查（为了提高效率）为一组对象设置 accessible 标志的便捷方法。
setAccessible(boolean) - 类 java.lang.reflect.AccessibleObject 中的方法
将此对象的 accessible 标志设置为指示的布尔值。
setAccessibleCaption(Accessible) - 接口 javax.accessibility.AccessibleTable 中的方法
设置表的标题。
setAccessibleCaption(Accessible) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置表的标题。
setAccessibleColumnDescription(int, Accessible) - 接口 javax.accessibility.AccessibleTable 中的方法
设置表中指定列的描述文本。
setAccessibleColumnDescription(int, Accessible) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置表中指定列的描述文本。
setAccessibleColumnHeader(AccessibleTable) - 接口 javax.accessibility.AccessibleTable 中的方法
设置列标题。
setAccessibleColumnHeader(AccessibleTable) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置以 AccessibleTable 表示的列标题。
setAccessibleDescription(String) - 类 javax.accessibility.AccessibleContext 中的方法
设置此对象的可访问描述。
setAccessibleDescription(String) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setAccessibleDescription(String) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置此对象的可访问的描述。
setAccessibleDescription(String) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
设置此对象的可访问描述。
setAccessibleDescription(String) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setAccessibleIconDescription(String) - 接口 javax.accessibility.AccessibleIcon 中的方法
设置图标的描述。
setAccessibleIconDescription(String) - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
设置图标的描述。
setAccessibleName(String) - 类 javax.accessibility.AccessibleContext 中的方法
设置此对象的可访问的本地化名称。
setAccessibleName(String) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setAccessibleName(String) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的可访问的本地化名称。
setAccessibleName(String) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
设置此对象的本地化可访问名称。
setAccessibleName(String) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setAccessibleParent(Accessible) - 类 javax.accessibility.AccessibleContext 中的方法
设置此对象的 Accessible 父对象。
setAccessibleRowDescription(int, Accessible) - 接口 javax.accessibility.AccessibleTable 中的方法
设置表中指定行的描述文本。
setAccessibleRowDescription(int, Accessible) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置表中指定行的描述文本。
setAccessibleRowHeader(AccessibleTable) - 接口 javax.accessibility.AccessibleTable 中的方法
设置行标题。
setAccessibleRowHeader(AccessibleTable) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置以 AccessibleTable 表示的列标题。
setAccessibleSummary(Accessible) - 接口 javax.accessibility.AccessibleTable 中的方法
设置表的摘要描述。
setAccessibleSummary(Accessible) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置表的摘要描述。
setAccessory(JComponent) - 类 javax.swing.JFileChooser 中的方法
设置 accessory 组件。
setAction(Action) - 类 javax.swing.AbstractButton 中的方法
设置 Action。
setAction(Action) - 类 javax.swing.JComboBox 中的方法
设置 ActionEvent 源的 Action。
setAction(Action) - 类 javax.swing.JTextField 中的方法
设置 ActionEvent 源的 Action。
setActionCommand(String) - 类 java.awt.Button 中的方法
设置此按钮激发的动作事件的命令名称。
setActionCommand(String) - 类 java.awt.MenuItem 中的方法
设置由此菜单项引发的动作事件的命令名。
setActionCommand(String) - 类 java.awt.TrayIcon 中的方法
设置由此托盘图标触发的动作事件的命令名。
setActionCommand(String) - 类 javax.swing.AbstractButton 中的方法
设置此按钮的动作命令。
setActionCommand(String) - 接口 javax.swing.ButtonModel 中的方法
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。
setActionCommand(String) - 类 javax.swing.DefaultButtonModel 中的方法
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。
setActionCommand(String) - 类 javax.swing.JComboBox 中的方法
设置发送到动作侦听器的事件中应该包括的动作命令。
setActionCommand(String) - 类 javax.swing.JTextField 中的方法
设置用于操作事件的命令字符串。
setActionCommand(String) - 类 javax.swing.Timer 中的方法
设置将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。
setActionMap(ActionMap) - 类 javax.swing.JComponent 中的方法
将 ActionMap 设置为 am。
setActivationDesc(ActivationID, ActivationDesc) - 接口 java.rmi.activation.ActivationSystem 中的方法
为具有激活标识符 id 的对象设置激活描述符 desc。
setActivationGroupDesc(ActivationGroupID, ActivationGroupDesc) - 接口 java.rmi.activation.ActivationSystem 中的方法
为具有激活组标识符 id 的对象设置激活组描述符 desc。
setActive(boolean) - 类 java.awt.dnd.DropTarget 中的方法
如果为 true，则将 DropTarget 设置为激活状态；如果为 false，则将 DropTarget 设置为非激活状态。
setActor(String) - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
将与此 SOAPHeaderElement 对象关联的 actor 设置为指定 actor。
setAdapter(XmlAdapter) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setAdapter(Class<A>, A) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setAdapter(XmlAdapter) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
setAdapter(Class<A>, A) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
setAdapter(XmlAdapter) - 接口 javax.xml.bind.Marshaller 中的方法
将已配置的 XmlAdapter 实例与此 marshaller 关联。
setAdapter(Class<A>, A) - 接口 javax.xml.bind.Marshaller 中的方法
将已配置的 XmlAdapter 实例与此 marshaller 关联。
setAdapter(XmlAdapter) - 接口 javax.xml.bind.Unmarshaller 中的方法
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。
setAdapter(Class<A>, A) - 接口 javax.xml.bind.Unmarshaller 中的方法
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。
setAddress(InetAddress) - 类 java.net.DatagramPacket 中的方法
设置要将此数据报发往的那台机器的 IP 地址。
setAlignment(int) - 类 java.awt.FlowLayout 中的方法
设置此布局的对齐方式。
setAlignment(int) - 类 java.awt.Label 中的方法
将此标签的对齐方式设置为指定的方式。
setAlignment(MutableAttributeSet, int) - 类 javax.swing.text.StyleConstants 中的静态方法
设置对齐方式。
setAlignmentX(float) - 类 javax.swing.JComponent 中的方法
设置垂直对齐方式。
setAlignmentY(float) - 类 javax.swing.JComponent 中的方法
设置水平对齐方式。
setAlignOnBaseline(boolean) - 类 java.awt.FlowLayout 中的方法
设置组件是否应该沿着其基线垂直对齐。
setAllocation(Shape) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
将当前已分配的形状复制到用于存储当前分配区域的 Rectangle 中。
setAllowsChildren(boolean) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
确定是否允许此节点拥有子节点。
setAllowsInvalid(boolean) - 类 javax.swing.text.DefaultFormatter 中的方法
设置编辑的值在一段时间内是否允许为无效（也就是说，stringToValue 是否抛出 ParseException）。
setAllowUserInteraction(boolean) - 类 java.net.URLConnection 中的方法
设置此 URLConnection 的 allowUserInteraction 字段的值。
setAltName(Name) - 异常 javax.naming.CannotProceedException 中的方法
设置此异常的 altName 字段。
setAltNameCtx(Context) - 异常 javax.naming.CannotProceedException 中的方法
设置此异常的 altNameCtx 字段。
setAlwaysOnTop(boolean) - 类 java.awt.Window 中的方法
设置此窗口是否应该始终位于其他窗口上方。
setAmPmStrings(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置 ampm 字符串。
setAnchorSelectionIndex(int) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置 anchor 选择索引，并不作更改地保留所有选择值。
setAnchorSelectionIndex(int) - 接口 javax.swing.ListSelectionModel 中的方法
设置 anchor 选择索引。
setAnchorSelectionPath(TreePath) - 类 javax.swing.JTree 中的方法
将标识的路径设置为定位路径。
setAngleExtent(double) - 类 java.awt.geom.Arc2D.Double 中的方法
将此弧的角跨越设置为指定的 double 值。
setAngleExtent(double) - 类 java.awt.geom.Arc2D.Float 中的方法
将此弧的角跨越设置为指定的 double 值。
setAngleExtent(double) - 类 java.awt.geom.Arc2D 中的方法
将此弧的角跨越设置为指定的 double 值。
setAngles(double, double, double, double) - 类 java.awt.geom.Arc2D 中的方法
使用两组坐标设置此弧的起始角度和角跨越。
setAngles(Point2D, Point2D) - 类 java.awt.geom.Arc2D 中的方法
使用两个点设置此弧的起始角度和角跨越。
setAngleStart(double) - 类 java.awt.geom.Arc2D.Double 中的方法
将此弧的起始角度设置为指定的 double 值。
setAngleStart(double) - 类 java.awt.geom.Arc2D.Float 中的方法
将此弧的起始角度设置为指定的 double 值。
setAngleStart(double) - 类 java.awt.geom.Arc2D 中的方法
将此弧的起始角度设置为指定的 double 值。
setAngleStart(Point2D) - 类 java.awt.geom.Arc2D 中的方法
将此弧的起始角度设置为由指定点定义、相对于此弧中心的角度。
setAnimated(boolean) - 类 java.awt.image.MemoryImageSource 中的方法
根据 animated 参数将此内存图像更改为多帧动画或单帧静态图像。
setAnimationIndex(int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
将当前动画窗体的索引设置为指定的值，并请求重绘进度条。
setAnyPolicyInhibited(boolean) - 类 java.security.cert.PKIXParameters 中的方法
设置状态，以确定当证书中包括了策略 OID 时是否应该处理它。
setApproveButtonMnemonic(int) - 类 javax.swing.JFileChooser 中的方法
使用数值键代码设置确认按钮的助记符。
setApproveButtonMnemonic(char) - 类 javax.swing.JFileChooser 中的方法
使用字符设置确认按钮的助记符。
setApproveButtonText(String) - 类 javax.swing.JFileChooser 中的方法
设置 FileChooserUI 中的 ApproveButton 内使用的文本。
setApproveButtonToolTipText(String) - 类 javax.swing.JFileChooser 中的方法
设置 ApproveButton 中使用的工具提示文本。
setArc(double, double, double, double, double, double, int) - 类 java.awt.geom.Arc2D.Double 中的方法
将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。
setArc(double, double, double, double, double, double, int) - 类 java.awt.geom.Arc2D.Float 中的方法
将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。
setArc(double, double, double, double, double, double, int) - 类 java.awt.geom.Arc2D 中的方法
将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。
setArc(Point2D, Dimension2D, double, double, int) - 类 java.awt.geom.Arc2D 中的方法
将此弧的位置、大小、角跨越和闭合类型设置为指定值。
setArc(Rectangle2D, double, double, int) - 类 java.awt.geom.Arc2D 中的方法
将此弧的位置、大小、角跨越和闭合类型设置为指定值。
setArc(Arc2D) - 类 java.awt.geom.Arc2D 中的方法
将此弧设置为与指定弧相同。
setArcByCenter(double, double, double, double, double, int) - 类 java.awt.geom.Arc2D 中的方法
将此弧的位置、边界、角跨越和闭合类型设置为指定值。
setArcByTangent(Point2D, Point2D, Point2D, double) - 类 java.awt.geom.Arc2D 中的方法
将此弧的位置、边界和角跨越设置为指定值。
setArcType(int) - 类 java.awt.geom.Arc2D 中的方法
将此弧的闭合类型设置为指定值：OPEN、CHORD 或 PIE。
setAreaOfInterest(Shape) - 类 java.awt.image.renderable.RenderContext 中的方法
设置当前的感兴趣区域。
setArmed(boolean) - 接口 javax.swing.ButtonModel 中的方法
将此按钮标记为选中或未选中。
setArmed(boolean) - 类 javax.swing.DefaultButtonModel 中的方法
将此按钮标记为选中或未选中。
setArmed(boolean) - 类 javax.swing.JMenuItem 中的方法
将菜单项标识为“调出”。
setArray(int, Array) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.Array 对象。
setArray(int, Array) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的 Array 对象。
setArray(int, Array) - 接口 javax.sql.RowSet 中的方法
使用给定 Array 值设置此 RowSet 对象命令中的指定参数。
setAsciiStream(String, InputStream, int) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
setAsciiStream(String, InputStream, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
setAsciiStream(String, InputStream) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流。
setAsciiStream(long) - 接口 java.sql.Clob 中的方法
获取用于将 Ascii 字符写入此 Clob 对象表示的 Clob 值中的流，从位置 pos 处开始。
setAsciiStream(int, InputStream, int) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流，该输入流将具有给定字节数。
setAsciiStream(int, InputStream, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流，该输入流将具有指定字节数。
setAsciiStream(int, InputStream) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流。
setAsciiStream(int, InputStream, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.io.InputStream 对象，该对象将具有指定的字节数。
setAsciiStream(int, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定输入流。
setAsciiStream(String, InputStream, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定字节数。
setAsciiStream(String, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的输入流。
setAsciiStream(long) - 类 javax.sql.rowset.serial.SerialClob 中的方法
获取用于将 Ascii 字符写入此 SerialClob 对象所表示的 Clob 值的流，从位置 pos 处开始。
setAsciiStream(int, InputStream, int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
setAsciiStream(String, InputStream, int) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定字节数。
setAsciiStream(int, InputStream) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定输入流。
setAsciiStream(String, InputStream) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定输入流。
setAsksAllowsChildren(boolean) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通过向 TreeNodes 询问 getAllowsChildren() 或 isLeaf()，设置是否测试无叶性。
setAsText(String) - 接口 java.beans.PropertyEditor 中的方法
通过解析给定 String 设置属性值。
setAsText(String) - 类 java.beans.PropertyEditorSupport 中的方法
通过解析给定字符串设置属性值。
setAsynchronousLoadPriority(int) - 类 javax.swing.text.AbstractDocument 中的方法
设置异步加载优先级。
setAttachmentMarshaller(AttachmentMarshaller) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setAttachmentMarshaller(AttachmentMarshaller) - 接口 javax.xml.bind.Marshaller 中的方法
与上下文关联，使 XML 文档内的二进制数据能够以优化的 XML 二进制附件的形式传送。
setAttachmentUnmarshaller(AttachmentUnmarshaller) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
setAttachmentUnmarshaller(AttachmentUnmarshaller) - 接口 javax.xml.bind.Unmarshaller 中的方法
将解析 cid（内容 id URI）的上下文与作为附件传递的二进制数据关联。
setAttribute(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setAttribute(Attribute) - 接口 javax.management.DynamicMBean 中的方法
设置 Dynamic MBean 的特定属性的值。
setAttribute(ObjectName, Attribute) - 接口 javax.management.MBeanServer 中的方法
setAttribute(ObjectName, Attribute) - 接口 javax.management.MBeanServerConnection 中的方法
设置指定 MBean 的特定属性值。
setAttribute(Attribute) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
设置指定的 ModelMBean 的指定属性值。
setAttribute(ObjectName, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
setAttribute(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
setAttribute(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
setAttribute(Attribute) - 类 javax.management.StandardMBean 中的方法
setAttribute(String, Object, int) - 接口 javax.script.ScriptContext 中的方法
设置给定范围中某一属性的值。
setAttribute(String, Object, int) - 类 javax.script.SimpleScriptContext 中的方法
设置给定范围中某一属性的值。
setAttribute(String, Object) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
允许用户在底层实现上设置特定属性。
setAttribute(String, Object) - 类 javax.xml.transform.TransformerFactory 中的方法
允许用户设置底层实现上的指定属性。
setAttribute(String, String) - 接口 org.w3c.dom.Element 中的方法
添加一个新属性。
setAttribute(int, String, String, String, String, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
在列表中设置属性。
setAttributeList(AttributeList) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 设置属性列表，丢弃以前的内容。
setAttributeNode(Attr) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setAttributeNode(Attr) - 接口 org.w3c.dom.Element 中的方法
添加新的属性节点。
setAttributeNodeNS(Attr) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 setAttributeNode(newAttr)。
setAttributeNodeNS(Attr) - 接口 org.w3c.dom.Element 中的方法
添加新属性。
setAttributeNS(String, String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 setAttribute(qualifiedName, value)。
setAttributeNS(String, String, String) - 接口 org.w3c.dom.Element 中的方法
添加新属性。
setAttributes(int, int, AttributeSet) - 接口 javax.accessibility.AccessibleEditableText 中的方法
设置两个索引之间文本的属性。
setAttributes(AttributeList) - 接口 javax.management.DynamicMBean 中的方法
设置 Dynamic MBean 多个属性的值。
setAttributes(ObjectName, AttributeList) - 接口 javax.management.MBeanServer 中的方法
setAttributes(ObjectName, AttributeList) - 接口 javax.management.MBeanServerConnection 中的方法
设置指定 MBean 的多个属性值。
setAttributes(AttributeList) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
设置此 ModelMBean 的属性数组的值。
setAttributes(ObjectName, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
setAttributes(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
setAttributes(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
setAttributes(AttributeList) - 类 javax.management.StandardMBean 中的方法
setAttributes(Attributes) - 类 javax.naming.directory.SearchResult 中的方法
将此搜索结果的属性设置为 attrs。
setAttributes(int, int, AttributeSet) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
设置两个索引之间文本的属性。
setAttributes(int, int, AttributeSet) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
设置两个索引之间的文本的属性。
setAttributes(Attributes) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
复制整个属性对象。
setAttributes(Attributes) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
复制整个 Attributes 对象。
setAuthorityKeyIdentifier(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 authorityKeyIdentifier 扩展。
setAuthorized(boolean) - 类 javax.security.sasl.AuthorizeCallback 中的方法
设置是否允许授权。
setAuthorizedID(String) - 类 javax.security.sasl.AuthorizeCallback 中的方法
设置已授权实体的 id。
setAutoCommit(boolean) - 接口 java.sql.Connection 中的方法
将此连接的自动提交模式设置为给定状态。
setAutoCommit(boolean) - 接口 javax.sql.rowset.JdbcRowSet 中的方法
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
setAutoCreateColumnsFromModel(boolean) - 类 javax.swing.JTable 中的方法
设置此表的 autoCreateColumnsFromModel 标志。
setAutoCreateContainerGaps(boolean) - 类 javax.swing.GroupLayout 中的方法
设置是否应该自动创建容器与触到容器边框的组件之间的间隙。
setAutoCreateGaps(boolean) - 类 javax.swing.GroupLayout 中的方法
设置是否将自动创建组件之间的间隙。
setAutoCreateRowSorter(boolean) - 类 javax.swing.JTable 中的方法
指定其模型更改时是否应该为表创建一个 RowSorter。
setAutoDelay(int) - 类 java.awt.Robot 中的方法
设置此 Robot 在生成一个事件后睡眠的毫秒数。
setAutoFormSubmission(boolean) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
指定是否自动处理 html 表单提交，或只是激发 FormSubmitEvent。
setAutoIncrement(int, boolean) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为给定 boolean 值，以指示是否为该列自动编号，从而变为只读。
setAutoIncrement(int, boolean) - 接口 javax.sql.RowSetMetaData 中的方法
设置是否为指定列自动编号。
setAutoResizeMode(int) - 类 javax.swing.JTable 中的方法
当调整表的大小时，设置表的自动调整模式。
setAutoscrolls(boolean) - 类 javax.swing.JComponent 中的方法
设置 autoscrolls 属性。
setAutoWaitForIdle(boolean) - 类 java.awt.Robot 中的方法
设置此 Robot 在生成一个事件后是否自动调用 waitForIdle。
setAxis(int) - 类 javax.swing.text.BoxView 中的方法
设置平铺轴属性。
setBackground(Color) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的背景色。
setBackground(Color) - 类 java.awt.Component 中的方法
设置组件的背景色。
setBackground(Color) - 类 java.awt.Graphics2D 中的方法
设置 Graphics2D 上下文的背景色。
setBackground(Color) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置此对象的背景颜色。
setBackground(Color) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置此对象的背景色。
setBackground(Color) - 类 java.awt.TextComponent 中的方法
设置此文本组件的背景色。
setBackground(Color) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置此对象的背景色。
setBackground(Color) - 类 javax.swing.JComponent 中的方法
设置此组件的背景色。
setBackground(Color) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setBackground(Color) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置此对象的背景色。
setBackground(Color) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
设置此对象的背景色。
setBackground(Color) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
重写 JComponent.setBackground 将未选定单元格的背景色分配为指定颜色。
setBackground(Color) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setBackground(Color) - 类 javax.swing.text.LabelView 中的方法
设置视图的背景色。
setBackground(MutableAttributeSet, Color) - 类 javax.swing.text.StyleConstants 中的静态方法
设置背景色。
setBackground(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
创建子类，以便将 ColorUIResource 映射为 null。
setBackgroundAt(int, Color) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的背景色设置为 background，它可以为 null，在这种情况下选项卡的背景色默认为 tabbedpane 的背景色。
setBackgroundNonSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置用于非选定节点的背景色。
setBackgroundSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置在选定节点的情况下背景所使用的颜色。
setBackingStoreEnabled(boolean) - 类 javax.swing.JViewport 中的方法
已过时。 从 Java 2 平台 1.3 版开始，由 setScrollMode() 取代。
setBase(URL) - 类 javax.swing.text.html.HTMLDocument 中的方法
设置解析相对 URL 所根据的位置。
setBase(URL) - 类 javax.swing.text.html.StyleSheet 中的方法
设置 base。
setBase64Content(InputStream, String) - 类 javax.xml.soap.AttachmentPart 中的方法
根据 Base64 源 InputStream 设置此附件部分的内容，并将 Content-Type 头的值设置为 contentType 中包含的值，此方法将首先对 base64 输入流进行解码，然后将得到的原始字节写入附件。
setBaseFontSize(int) - 类 javax.swing.text.html.StyleSheet 中的方法
设置基本字体大小，其有效值范围为 1 到 7。
setBaseFontSize(String) - 类 javax.swing.text.html.StyleSheet 中的方法
根据传入的 String 设置基本字体大小。
setBaseURI(String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
setBaseURI(String) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
设置基本 URI。
setBaseURI(String) - 接口 org.w3c.dom.ls.LSInput 中的方法
基 URI（请参阅 [IETF RFC 2396])中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。
setBasicConstraints(int) - 类 java.security.cert.X509CertSelector 中的方法
设置 basicConstraints 限制。
setBasicSplitPaneUI(BasicSplitPaneUI) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
设置要使用接收者的 SplitPaneUI。
setBeanContext(BeanContext) - 接口 java.beans.beancontext.BeanContextChild 中的方法
实现此接口的对象应使用以下参数激活一个 java.beans.PropertyChangeEvent：propertyName "beanContext"、oldValue（以前的嵌套 BeanContext 实例，或 null）、newValue（当前的嵌套 BeanContext 实例，或 null）。
setBeanContext(BeanContext) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
设置此 BeanContextChildSupport 的 BeanContext。
setBeanInfoSearchPath(String[]) - 类 java.beans.Introspector 中的静态方法
更改将用来查找 BeanInfo 类的包名称的列表。
setBeginIndex(int) - 类 java.text.FieldPosition 中的方法
设置起始索引。
setBidiLevel(MutableAttributeSet, int) - 类 javax.swing.text.StyleConstants 中的静态方法
设置 BidiLevel。
setBigDecimal(String, BigDecimal) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.math.BigDecimal 值。
setBigDecimal(int, BigDecimal) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.math.BigDecimal 值。
setBigDecimal(int, BigDecimal) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.lang.BigDecimal 值。
setBigDecimal(String, BigDecimal) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.math.BigDecimal 值。
setBigDecimal(int, BigDecimal) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.math.BigDeciaml 值。
setBigDecimal(String, BigDecimal) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.math.BigDecimal 值。
setBinaryStream(long) - 接口 java.sql.Blob 中的方法
获取用于写入此 Blob 对象表示的 BLOB 值的流。
setBinaryStream(String, InputStream, int) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
setBinaryStream(String, InputStream, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定字节数。
setBinaryStream(String, InputStream) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流。
setBinaryStream(int, InputStream, int) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流，该输入流将具有给定字节数。
setBinaryStream(int, InputStream, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流，该输入流将具有指定字节数。
setBinaryStream(int, InputStream) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流。
setBinaryStream() - 接口 java.sql.SQLXML 中的方法
获取可用于写入此 SQLXML 实例表示的 XML 值的流。
setBinaryStream(int, InputStream, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.io.InputStream 对象，该对象具有指定的字节数。
setBinaryStream(int, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定输入流。
setBinaryStream(String, InputStream, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的输入流，该输入流将拥有指定的字节数。
setBinaryStream(String, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定输入流。
setBinaryStream(long) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
获取用于写入此 Blob 对象所表示的 BLOB 值的流。
setBinaryStream(int, InputStream, int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
setBinaryStream(String, InputStream, int) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定输入流，该输入流将拥有给定字节数。
setBinaryStream(int, InputStream) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定输入流。
setBinaryStream(String, InputStream) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定输入流。
setBindings(Bindings, int) - 类 javax.script.AbstractScriptEngine 中的方法
使用 context 字段中的相应范围值设置 Bindings。
setBindings(Bindings, int) - 接口 javax.script.ScriptContext 中的方法
将 Bindings 实例与此 ScriptContext 中的特定范围关联。
setBindings(Bindings, int) - 接口 javax.script.ScriptEngine 中的方法
设置将由脚本使用的指定值的范围。
setBindings(Bindings) - 类 javax.script.ScriptEngineManager 中的方法
setBindings 存储 globalScope 字段中的指定 Bindings。
setBindings(Bindings, int) - 类 javax.script.SimpleScriptContext 中的方法
针对给定范围设置属性的 Bindings。
setBit(int) - 类 java.math.BigInteger 中的方法
返回其值与设置了指定位的此 BigInteger 等效的 BigInteger。
setBitOffset(int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
将位偏移量设置为 0 到 7 之间（包含两者）的整数。
setBitOffset(int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
setBlinkRate(int) - 接口 javax.swing.text.Caret 中的方法
设置插入符的闪烁率。
setBlinkRate(int) - 类 javax.swing.text.DefaultCaret 中的方法
设置插入符闪烁率。
setBlob(String, InputStream, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 InputStream 对象。
setBlob(String, Blob) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定的 java.sql.Blob 对象。
setBlob(String, InputStream) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, Blob) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.Blob 对象。
setBlob(int, InputStream, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, InputStream) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, Blob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 Blob 对象。
setBlob(int, InputStream, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(String, InputStream, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(String, Blob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Blob 对象。
setBlob(String, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, Blob) - 接口 javax.sql.RowSet 中的方法
使用给定 Blob 值设置此 RowSet 对象命令中的指定参数。
setBlob(int, InputStream, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, InputStream) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(String, InputStream, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(String, Blob) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.Blob 对象。
setBlob(String, InputStream) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlockIncrement(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的块值增量。
setBlockIncrement(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的块增量。
setBlockIncrement(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
setBlockIncrement(int) - 类 javax.swing.JScrollBar 中的方法
设置 blockIncrement 属性。
setBlockIncrement(int) - 类 javax.swing.JScrollPane.ScrollBar 中的方法
通知超类来设定该值，并将 blockIncrementSet 实例变量重置为 true。
setBold(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置粗体属性。
setBoolean(Object, int, boolean) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 boolean 值。
setBoolean(Object, boolean) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 boolean 值。
setBoolean(String, boolean) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java boolean 值。
setBoolean(int, boolean) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java boolean 值。
setBoolean(int, boolean) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 boolean 值。
setBoolean(String, boolean) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java boolean 值。
setBoolean(int, boolean) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java boolean 值。
setBoolean(String, boolean) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java boolean 值。
setBorder(Border) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的边框。
setBorder(Border) - 类 javax.swing.JComponent 中的方法
设置此组件的边框。
setBorder(Border) - 类 javax.swing.JViewport 中的方法
视口通过常规父/子剪贴（一般该视图向滚动的相反方向移动）“滚动”其子视口（称为“视图”）。
setBorder(Border) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
设置此组件的边框。
setBorder(Border) - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 中的方法
设置此组件的边框。
setBorderColor(Color) - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法
setBorderPainted(boolean) - 类 javax.swing.AbstractButton 中的方法
设置 borderPainted 属性。
setBorderPainted(boolean) - 类 javax.swing.JMenuBar 中的方法
设置是否应该绘制边框。
setBorderPainted(boolean) - 类 javax.swing.JPopupMenu 中的方法
设置是否应该绘制边框。
setBorderPainted(boolean) - 类 javax.swing.JProgressBar 中的方法
设置 borderPainted 属性，如果进度条应该绘制其边框，则此属性为 true。
setBorderPainted(boolean) - 类 javax.swing.JToolBar 中的方法
设置 borderPainted 属性，如果需要绘制边框，则此属性为 true。
setBorderPaintedFlat(boolean) - 类 javax.swing.JCheckBox 中的方法
设置 borderPaintedFlat 属性，该属性为外观提供了关于复选框边框外观的提示。
setBorderSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
设置用于边框的颜色。
setBorderSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置用于边框的颜色。
setBorderToNonRollover(Component) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
将组件的边框设置为具有由 createNonRolloverBorder 创建的翻转边框。
setBorderToNonRollover(Component) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
setBorderToNormal(Component) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
将组件的边框设置为具有普通边框。
setBorderToRollover(Component) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
将组件的边框设置为具有由 createRolloverBorder 创建的翻转边框。
setBottomComponent(Component) - 类 javax.swing.JSplitPane 中的方法
将组件设置到分隔条的下面或者右边。
setBottomInset(float) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图四周底部的空白部分。
setBound(boolean) - 类 java.beans.PropertyDescriptor 中的方法
更新 "bound" 属性将导致更改该属性时激发 "PropertyChange" 事件。
setBounds(Rectangle) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的边界，用 Rectangle 对象的形式表示它。
setBounds(int, int, int, int) - 类 java.awt.Component 中的方法
移动组件并调整其大小。
setBounds(Rectangle) - 类 java.awt.Component 中的方法
移动组件并调整其大小，使其符合新的有界矩形 r。
setBounds(Rectangle) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
以 Rectangle 对象的形式设置此对象的界限。
setBounds(Rectangle) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
以 Rectangle 对象的形式设置此对象的边界。
setBounds(Rectangle) - 类 java.awt.Rectangle 中的方法
设置此 Rectangle 的边界 Rectangle，以匹配指定的 Rectangle。
setBounds(int, int, int, int) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 的边界 Rectangle 设置为指定的 x、y、width 和 height。
setBounds(int, int, int, int) - 类 java.awt.Window 中的方法
移动组件并调整其大小。
setBounds(Rectangle) - 类 java.awt.Window 中的方法
移动组件并调整其大小，使其符合新的有界矩形 r。
setBounds(Rectangle) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置 Rectangle 对象形式的此对象的边界。
setBounds(Rectangle) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setBounds(Rectangle) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
setBounds(Rectangle) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setBounds(Rectangle) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setBoundsForFrame(JComponent, int, int, int, int) - 类 javax.swing.DefaultDesktopManager 中的方法
此方法移动 JComponent 并重新绘制已毁坏的区域。
setBoundsForFrame(JComponent, int, int, int, int) - 接口 javax.swing.DesktopManager 中的方法
这是一个基本重塑方法。
setBroadcast(boolean) - 类 java.net.DatagramSocket 中的方法
启用/禁用 SO_BROADCAST。
setBuilder(DocumentBuilder) - 类 javax.xml.bind.annotation.W3CDomHandler 中的方法
setButtonIcons() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
setByte(Object, int, byte) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 byte 值。
setByte(Object, byte) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 byte 值。
setByte(String, byte) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java byte 值。
setByte(int, byte) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java byte 值。
setByte(int, byte) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 byte 值。
setByte(String, byte) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java byte 值。
setByte(int, byte) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值。
setByte(String, byte) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java byte 值。
setByteOrder(ByteOrder) - 接口 javax.imageio.stream.ImageInputStream 中的方法
设置希望以后从此流中读取数据值时使用的字节顺序。
setByteOrder(ByteOrder) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
setBytes(long, byte[]) - 接口 java.sql.Blob 中的方法
从位置 pos 处开始，将给定 byte 数组写入此 Blob 对象表示的 BLOB 值，并返回写入的字节数。
setBytes(long, byte[], int, int) - 接口 java.sql.Blob 中的方法
将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
setBytes(String, byte[]) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java byte 数组。
setBytes(int, byte[]) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java byte 数组。
setBytes(int, byte[]) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 byte 数组。
setBytes(String, byte[]) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java byte 数组。
setBytes(long, byte[]) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
将给定字节数组写入此 Blob 对象表示的 BLOB 值（从位置 pos 处开始），并返回写入的字节数。
setBytes(long, byte[], int, int) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
setBytes(int, byte[]) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值数组。
setBytes(String, byte[]) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java byte 数组。
setByteStream(InputStream) - 接口 org.w3c.dom.ls.LSInput 中的方法
依赖于语言和绑定类型的属性，表示字节流。
setByteStream(OutputStream) - 接口 org.w3c.dom.ls.LSOutput 中的方法
具有语言和绑定依赖性类型的属性，表示字节的可写流。
setByteStream(InputStream) - 类 org.xml.sax.InputSource 中的方法
设置此输入源的字节流。
setCacheDirectory(File) - 类 javax.imageio.ImageIO 中的静态方法
设置将在其中创建缓存文件的目录。
setCalendar(Calendar) - 类 java.text.DateFormat 中的方法
设置此日期格式所使用的日历。
setCalendarField(int) - 类 javax.swing.SpinnerDateModel 中的方法
更改由 nextValue 和 previousValue 方法计算的日期值更改的大小。
setCallbackHandler(CallbackHandler) - 类 java.security.AuthProvider 中的方法
设置 CallbackHandler。
setCanWrapLines(boolean) - 类 javax.swing.text.AbstractWriter 中的方法
设置是否可以换行。
setCaret(Caret) - 类 javax.swing.text.JTextComponent 中的方法
设置要使用的插入符。
setCaretColor(Color) - 类 javax.swing.text.JTextComponent 中的方法
设置用于呈现插入符的当前颜色。
setCaretPosition(int) - 类 java.awt.TextComponent 中的方法
设置文本插入符的位置。
setCaretPosition(int) - 类 javax.swing.text.JTextComponent 中的方法
设置 TextComponent 的文本插入符的位置。
setCaseSensitive(int, boolean) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为给定的 boolean 值，以指示该列的名称是否区分大小写。
setCaseSensitive(int, boolean) - 接口 javax.sql.RowSetMetaData 中的方法
设置指定列是否区分大小写。
setCatalog(String) - 接口 java.sql.Connection 中的方法
设置给定目录名称，以便选择要在其中进行工作的此 Connection 对象数据库的子空间。
setCatalogName(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将派生指定列的表名称设置为 catalogName。
setCatalogName(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的表的类别名称（如果有）设置为给定的 String。
setCellEditor(TableCellEditor) - 类 javax.swing.JTable 中的方法
设置活动单元格编辑器。
setCellEditor(TreeCellEditor) - 类 javax.swing.JTree 中的方法
设置单元格编辑器。
setCellEditor(TreeCellEditor) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
设置单元格编辑器。
setCellEditor(TableCellEditor) - 类 javax.swing.table.TableColumn 中的方法
设置编辑此列中单元格时所用的编辑器。
setCellLength(int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
setCellRenderer(ListCellRenderer) - 类 javax.swing.JList 中的方法
设置用于绘制列表中每个单元的委托。
setCellRenderer(TreeCellRenderer) - 类 javax.swing.JTree 中的方法
设置将用于绘制每个单元格的 TreeCellRenderer。
setCellRenderer(TreeCellRenderer) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
将 TreeCellRenderer 设置为 tcr。
setCellRenderer(TableCellRenderer) - 类 javax.swing.table.TableColumn 中的方法
设置 JTable 用于绘制此列各值的 TableCellRenderer。
setCellSelectionEnabled(boolean) - 类 javax.swing.JTable 中的方法
设置此表是否允许同时存在行选择和列选择。
setCellSpacing(int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
setCentersChildren(boolean) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
setCertificate(X509Certificate) - 类 java.security.cert.X509CertSelector 中的方法
设置 certificateEquals 标准。
setCertificateChecking(X509Certificate) - 类 java.security.cert.X509CRLSelector 中的方法
设置要检查的证书。
setCertificateEntry(String, Certificate) - 类 java.security.KeyStore 中的方法
将给定可信证书分配给给定别名。
setCertificateValid(Date) - 类 java.security.cert.X509CertSelector 中的方法
设置 certificateValid 标准。
setCertifiedText(boolean) - 接口 org.w3c.dom.ls.LSInput 中的方法
如果设置为 true，则假定解析 [XML 1.1] 时对输入进行验证（请参阅 [XML 1.1] 中的 2.13 节）。
setCertPathCheckers(List<PKIXCertPathChecker>) - 类 java.security.cert.PKIXParameters 中的方法
设置其他证书路径检查器的 List。
setCertStores(List<CertStore>) - 类 java.security.cert.PKIXParameters 中的方法
设置在查找证书和 CRL 时所使用的 CertStore 列表。
setChanged() - 类 java.util.Observable 中的方法
标记此 Observable 对象为已改变的对象；现在 hasChanged 方法将返回 true。
setChannelBinding(ChannelBinding) - 接口 org.ietf.jgss.GSSContext 中的方法
设置在上下文创建期间使用的通道绑定。
setChannelPressure(int) - 接口 javax.sound.midi.MidiChannel 中的方法
对键盘力度的更改作出反应。
setChar(Object, int, char) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 char 值。
setChar(Object, char) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 char 值。
setCharacterAttributes(AttributeSet, boolean) - 类 javax.swing.JTextPane 中的方法
将给定属性应用于字符内容。
setCharacterAttributes(int, int, AttributeSet, boolean) - 类 javax.swing.text.DefaultStyledDocument 中的方法
为文档某些部分设置属性。
setCharacterAttributes(int, int, AttributeSet, boolean) - 接口 javax.swing.text.StyledDocument 中的方法
更改内容元素属性，该属性是用来给定文档中现有内容范围的。
setCharacterAttributes(JEditorPane, AttributeSet, boolean) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 中的方法
对字符内容应用给定的属性。
setCharacterStream(String, Reader, int) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数。
setCharacterStream(String, Reader, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
setCharacterStream(String, Reader) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Reader 对象。
setCharacterStream(long) - 接口 java.sql.Clob 中的方法
获取用于将 Unicode 字符流写入此 Clob 对象表示的 CLOB 值中（位置 pos 处）的流。
setCharacterStream(int, Reader, int) - 接口 java.sql.PreparedStatement 中的方法
将给定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
setCharacterStream(int, Reader, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
setCharacterStream(int, Reader) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Reader 对象。
setCharacterStream() - 接口 java.sql.SQLXML 中的方法
获取用于写入此 SQLXML 实例表示的 XML 值的流。
setCharacterStream(int, Reader, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.io.Reader 对象，该对象具有指定的字符数。
setCharacterStream(int, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Reader 对象。
setCharacterStream(String, Reader, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Reader 对象，该对象是给定的字符长度数目。
setCharacterStream(String, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定 Reader 对象。
setCharacterStream(long) - 类 javax.sql.rowset.serial.SerialClob 中的方法
获取用于将 Unicode 字符流写入此 SerialClob 对象所表示的 CLOB 值（位置 pos 处）的流。
setCharacterStream(int, Reader, int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.io.Reader 值。
setCharacterStream(String, Reader, int) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数目。
setCharacterStream(int, Reader) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定 Reader 对象。
setCharacterStream(String, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定 Reader 对象。
setCharacterStream(Reader) - 接口 org.w3c.dom.ls.LSInput 中的方法
依赖于语言和绑定类型的属性，表示 16 位单元的流。
setCharacterStream(Writer) - 接口 org.w3c.dom.ls.LSOutput 中的方法
具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。
setCharacterStream(Reader) - 类 org.xml.sax.InputSource 中的方法
设置此输入源的字符流。
setCharacterSubsets(Character.Subset[]) - 类 java.awt.im.InputContext 中的方法
设置此输入上下文的输入方法应允许输入的 Unicode 字符集的子集。
setCharacterSubsets(Character.Subset[]) - 接口 java.awt.im.spi.InputMethod 中的方法
设置允许此输入方法进行输入的 Unicode 字符集的子集。
setCharAt(int, char) - 类 java.lang.StringBuffer 中的方法
setCheckboxGroup(CheckboxGroup) - 类 java.awt.Checkbox 中的方法
将此复选框的组设置为指定复选框组。
setChoices(double[], String[]) - 类 java.text.ChoiceFormat 中的方法
设置要在格式化中使用的 choice。
setChooserPanels(AbstractColorChooserPanel[]) - 类 javax.swing.JColorChooser 中的方法
指定用于选取颜色值的 Color Panel。
setChunkedStreamingMode(int) - 类 java.net.HttpURLConnection 中的方法
此方法用于在预先不知道内容长度时启用没有进行内部缓冲的 HTTP 请求正文的流。
setCipherSuites(String[]) - 类 javax.net.ssl.SSLParameters 中的方法
设置密码套件数组。
setClassAssertionStatus(String, boolean) - 类 java.lang.ClassLoader 中的方法
设置在此类加载器及其包含的嵌套类中指定的最高层类所需的断言状态。
setClassName(String) - 类 javax.naming.NameClassPair 中的方法
设置此绑定的类名称。
setClickCountToStart(int) - 类 javax.swing.DefaultCellEditor 中的方法
指定开始编辑所需的单击次数。
setClientInfo(String, String) - 接口 java.sql.Connection 中的方法
将 name 指定的客户端信息属性的值设置为 value 指定的值。
setClientInfo(Properties) - 接口 java.sql.Connection 中的方法
设置连接的客户端信息属性的值。
setClip(int, int, int, int) - 类 java.awt.Graphics 中的方法
将当前剪贴区设置为由给定坐标指定的矩形。
setClip(Shape) - 类 java.awt.Graphics 中的方法
将当前剪贴区域设置为任意的剪贴形状。
setClip(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.setClip。
setClip(Shape) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.setClip。
setClob(String, Reader, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setClob(String, Clob) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定的 java.sql.Clob 对象。
setClob(String, Reader) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Clob) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.Clob 对象。
setClob(int, Reader, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Reader) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Clob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 Clob 对象。
setClob(int, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(String, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(String, Clob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Clob 对象。
setClob(String, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Clob) - 接口 javax.sql.RowSet 中的方法
使用给定 Clob 值设置此 RowSet 对象命令中的指定参数。
setClob(int, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(String, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(String, Clob) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.Clob 对象。
setClob(String, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setClosable(boolean) - 类 javax.swing.JInternalFrame 中的方法
设置是否可以通过某个用户操作关闭此 JInternalFrame。
setClosed(boolean) - 类 javax.swing.JInternalFrame 中的方法
如果参数为 true，则关闭此内部窗体。
setClosedIcon(Icon) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置用于表示没有扩展的非叶节点的图标。
setCoalesce(boolean) - 类 javax.swing.Timer 中的方法
设置 Timer 是否组合多个挂起的 ActionEvent 触发。
setCoalescing(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此代码生成的解析器将把 CDATA 节点转换为 Text 节点，并将其附加到相邻（如果有）的 Text 节点。
setCollapsedIcon(Icon) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
setCollectionUsageThreshold(long) - 接口 java.lang.management.MemoryPoolMXBean 中的方法
将此内存池的回收使用量阈值设置为给定的 threshold 值。
setColor(Color) - 类 java.awt.Graphics 中的方法
将此图形上下文的当前颜色设置为指定颜色。
setColor(PageAttributes.ColorType) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面以彩色呈现，还是以单色呈现。
setColor(Color) - 类 javax.swing.DebugGraphics 中的方法
设置用于绘制和填充线条和图形的颜色。
setColor(Color) - 类 javax.swing.JColorChooser 中的方法
将颜色选取器的当前颜色设置为指定颜色。
setColor(int, int, int) - 类 javax.swing.JColorChooser 中的方法
将颜色选取器的当前颜色设置为指定的 RGB 颜色。
setColor(int) - 类 javax.swing.JColorChooser 中的方法
将颜色选取器的当前颜色设置为指定颜色。
setColorModel(ColorModel) - 类 java.awt.image.BufferedImageFilter 中的方法
过滤 ImageConsumer 接口的 setColorModel 方法提供的信息。
setColorModel(ColorModel) - 接口 java.awt.image.ImageConsumer 中的方法
设置用于大多数像素的 ColorModel 对象，这些像素使用 setPixels 方法调用进行报告。
setColorModel(ColorModel) - 类 java.awt.image.ImageFilter 中的方法
过滤 ImageConsumer 接口的 setColorModel 方法中所提供的信息。
setColorModel(ColorModel) - 类 java.awt.image.PixelGrabber 中的方法
setColorModel 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setColorModel(ColorModel) - 类 java.awt.image.RGBImageFilter 中的方法
如果 ColorModel 是 IndexColorModel 且子类将 canFilterIndexColorModel 标志设置为 true，则将此处及 setPixels 方法中任何出现原始 ColorModel 对象的地方替换为过滤后的颜色模型。
setColumnCount(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
在为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中，将列数设置为给定数。
setColumnCount(int) - 接口 javax.sql.RowSetMetaData 中的方法
将 RowSet 对象中的列数设置为给定数。
setColumnCount(int) - 类 javax.swing.table.DefaultTableModel 中的方法
设置模型中的列数。
setColumnDisplaySize(int, int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列中的正常最大 char 数设置为给定数。
setColumnDisplaySize(int, int) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的正常最大宽度（以 char 表示）设置为给定的 int。
setColumnHeader(JViewport) - 类 javax.swing.JScrollPane 中的方法
移除旧的 columnHeader，如果有的话；如果新的 columnHeader 不为 null，将其 viewPosition 的 x 坐标与视口（如果有）同步然后将其添加到滚动窗格。
setColumnHeaderView(Component) - 类 javax.swing.JScrollPane 中的方法
创建一个列标题视口（如果有必要），设置其视图然后将此列标题视口添加到滚动窗格。
setColumnIdentifiers(Vector) - 类 javax.swing.table.DefaultTableModel 中的方法
替换模型中的列标识符。
setColumnIdentifiers(Object[]) - 类 javax.swing.table.DefaultTableModel 中的方法
替换模型中的列标识符。
setColumnLabel(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将建议用于打印输出和显示的列标签（如果有）设置为给定的 label。
setColumnLabel(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将建议用于打印输出和显示的列标题（如果有）设置为给定的 String。
setColumnMargin(int) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
将列空白设置为 newMargin。
setColumnMargin(int) - 接口 javax.swing.table.TableColumnModel 中的方法
将 TableColumn 的列空白设置为 newMargin。
setColumnModel(TableColumnModel) - 类 javax.swing.JTable 中的方法
将此表的列模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
setColumnModel(TableColumnModel) - 类 javax.swing.table.JTableHeader 中的方法
将此表的列模型设置为 newModel，并向侦听器注册来自新列模型的通知。
setColumnName(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列的列名称设置为给定的名称。
setColumnName(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的名称设置为给定的 String。
setColumnNumber(int) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 columnNumber 字段。
setColumnNumber(int) - 类 org.xml.sax.helpers.LocatorImpl 中的方法
设置此定位器的列数（从 1 开始）。
setColumns(int) - 类 java.awt.GridLayout 中的方法
将此布局中的列数设置为指定值。
setColumns(int) - 类 java.awt.TextArea 中的方法
设置此文本区的列数。
setColumns(int) - 类 java.awt.TextField 中的方法
设置此文本字段中的列数。
setColumns(int) - 类 javax.swing.JTextArea 中的方法
设置此 TextArea 中的列数。
setColumns(int) - 类 javax.swing.JTextField 中的方法
设置此 TextField 中的列数，然后验证布局。
setColumnSelectionAllowed(boolean) - 类 javax.swing.JTable 中的方法
设置是否可以选择此模型中的列。
setColumnSelectionAllowed(boolean) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
设置是否允许列选择。
setColumnSelectionAllowed(boolean) - 接口 javax.swing.table.TableColumnModel 中的方法
设置是否可以选择此模型中的列。
setColumnSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
选择从 index0 到 index1 之间（包含两端）的列。
setColumnType(int, int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将存储在指定列中的值的 SQL 类型代码设置为 java.sql.Types 类中的给定类型代码。
setColumnType(int, int) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的 SQL 类型设置为给定的类型。
setColumnTypeName(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将供存储在指定列中的值的数据源使用的类型名称设置为给定类型名称。
setColumnTypeName(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的特定于数据源的类型名称（如果有）设置为给定的 String。
setComboBox(JComboBox) - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
setComboIcon(Icon) - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
setCommand(String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的 command 属性设置为给定的 String 对象，并清除为前一个命令设置的参数（如果有）。
setCommand(String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的命令属性设置为给定的 SQL 查询。
setCommandContext(String, DataHandler) - 接口 javax.activation.CommandObject 中的方法
用请求处理的动词和描述将要操作的数据的 DataHandler 来初始化 Command。
setCommandMap(CommandMap) - 类 javax.activation.DataHandler 中的方法
设置此 DataHandler 使用的 CommandMap。
setComment(String) - 类 java.net.HttpCookie 中的方法
指定一个描述 cookie 用途的注释。
setComment(String) - 类 java.util.zip.ZipEntry 中的方法
为条目设置可选的注释字符串。
setComment(String) - 类 java.util.zip.ZipOutputStream 中的方法
设置 ZIP 文件注释。
setCommentURL(String) - 类 java.net.HttpCookie 中的方法
指定一个描述 cookie 用途的注释 URL。
setCommitsOnValidEdit(boolean) - 类 javax.swing.text.DefaultFormatter 中的方法
设置何时将编辑内容发布回 JFormattedTextField。
setComparator(int, Comparator<?>) - 类 javax.swing.DefaultRowSorter 中的方法
设置对指定列进行排序时要使用的 Comparator。
setComparator(Comparator<? super Component>) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
设置将用于对焦点遍历循环中的 Components 排序的 Comparator。
setComponent(Component) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
设置与该 DragGestureRecognizer 关联的 Component 使用此方法时还会调用 registerListeners() 和 unregisterListeners()。
setComponent(Component) - 类 java.awt.dnd.DropTarget 中的方法
注意：要求此接口允许 DropTarget 以下面两种方式之一与 Component 安全关联：component.setDropTarget(droptarget) 或 droptarget.setComponent(component)。
setComponent(JComponent) - 类 javax.swing.JToolTip 中的方法
指定工具提示所描述的组件。
setComponent(MutableAttributeSet, Component) - 类 javax.swing.text.StyleConstants 中的静态方法
设置组件属性。
setComponentAt(int, Component) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的组件设置为 component。
setComponentOrientation(ComponentOrientation) - 类 java.awt.Component 中的方法
设置语言敏感的方向，用于排序此组件内的元素或文本。
setComponentOrientation(ComponentOrientation) - 类 javax.swing.JMenu 中的方法
setComponentOrientation(ComponentOrientation) - 类 javax.swing.JScrollPane 中的方法
设置由 ComponentOrientation 参数确定的垂直和水平滚动条方向。
setComponentOrientation(ComponentOrientation) - 类 javax.swing.text.JTextComponent 中的方法
setComponentPopupMenu(JPopupMenu) - 类 javax.swing.JComponent 中的方法
设置此 JComponent 的 JPopupMenu。
setComponentToSize(Component, int, int, Insets, Dimension) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
将组件 c 的宽度设置为 size（将其 x 的位置放置到 location），将 y 和高度分别设置为 insets.top 和 containersize.height 减去上下 insets。
setComponentZOrder(Component, int) - 类 java.awt.Container 中的方法
将指定组件移动到容器中指定的 z 顺序索引。
setComponentZOrder(Component, int) - 类 javax.swing.JDesktopPane 中的方法
将指定组件移动到容器中指定的 z 顺序索引。
setComposite(Composite) - 类 java.awt.Graphics2D 中的方法
为 Graphics2D 上下文设置 Composite。
setCompositionEnabled(boolean) - 类 java.awt.im.InputContext 中的方法
根据参数 enable 的值启用或禁用当前输入方法进行撰写。
setCompositionEnabled(boolean) - 接口 java.awt.im.spi.InputMethod 中的方法
启用或禁用输入方法的撰写功能，具体取决于参数 enable 的值。
setCompressedSize(long) - 类 java.util.zip.ZipEntry 中的方法
设置压缩条目数据的大小。
setCompressionMode(int) - 类 javax.imageio.ImageWriteParam 中的方法
指定是否执行压缩，如果执行压缩，将如何确定 compression 参数。
setCompressionQuality(float) - 类 javax.imageio.ImageWriteParam 中的方法
将压缩质量设置为 0 和 1 之间的某个值。
setCompressionType(String) - 类 javax.imageio.ImageWriteParam 中的方法
将压缩类型设置为 getCompressionTypes 指示的值之一。
setConcurrency(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的并发性设置为指定的并发性。
setConcurrency(int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的并发性设置为给定的并发级别。
setConfiguration(Configuration) - 类 javax.security.auth.login.Configuration 中的静态方法
设置登录 Configuration。
setConnectTimeout(int) - 类 java.net.URLConnection 中的方法
设置一个指定的超时值（以毫秒为单位），该值将在打开到此 URLConnection 引用的资源的通信链接时使用。
setConstrained(boolean) - 类 java.beans.PropertyDescriptor 中的方法
试图更新 "Constrained" 属性将导致更改该属性时激发 "VetoableChange" 事件。
setConstraint(String, Spring) - 类 javax.swing.SpringLayout.Constraints 中的方法
设置控制指定边的 spring。
setConstraints(Component, GridBagConstraints) - 类 java.awt.GridBagLayout 中的方法
设置此布局中指定组件的约束条件。
setContent(Object, String) - 类 javax.xml.soap.AttachmentPart 中的方法
将此附件部分的内容设置为给定 Object 的内容，并将 Content-Type 头的值设置为给定类型。
setContent(Source) - 类 javax.xml.soap.SOAPPart 中的方法
使用取自给定 Source 对象的数据设置 SOAPEnvelope 对象的内容。
setContentAreaFilled(boolean) - 类 javax.swing.AbstractButton 中的方法
设置 contentAreaFilled 属性。
setContentDescription(String) - 类 javax.xml.soap.SOAPMessage 中的方法
使用给定描述设置此 SOAPMessage 对象内容的描述。
setContentHandler(ContentHandler) - 类 javax.xml.validation.ValidatorHandler 中的方法
设置 ContentHandler，它接收扩充的验证结果。
setContentHandler(ContentHandler) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
设置内容处理程序。
setContentHandler(ContentHandler) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置内容事件处理程序。
setContentHandler(ContentHandler) - 接口 org.xml.sax.XMLReader 中的方法
允许应用程序注册内容事件处理程序。
setContentHandlerFactory(ContentHandlerFactory) - 类 java.net.URLConnection 中的静态方法
设置应用程序的 ContentHandlerFactory。
setContentId(String) - 类 javax.xml.soap.AttachmentPart 中的方法
使用给定值设置名为 "Content-ID" 的 MIME 头。
setContentId(String) - 类 javax.xml.soap.SOAPPart 中的方法
将名为 "Content-Id" 的 MIME 头的值设置为给定 String。
setContentLocation(String) - 类 javax.xml.soap.AttachmentPart 中的方法
使用给定值设置名为 "Content-Location" 的 MIME 头。
setContentLocation(String) - 类 javax.xml.soap.SOAPPart 中的方法
将 MIME 头 "Content-Location" 的值设置为给定 String。
setContentPane(Container) - 类 javax.swing.JApplet 中的方法
设置 contentPane 属性。
setContentPane(Container) - 类 javax.swing.JDialog 中的方法
设置 contentPane 属性。
setContentPane(Container) - 类 javax.swing.JFrame 中的方法
设置 contentPane 属性。
setContentPane(Container) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 contentPane 属性。
setContentPane(Container) - 类 javax.swing.JRootPane 中的方法
设置内容窗格，它是保存以根窗格为父级的组件的容器。
setContentPane(Container) - 类 javax.swing.JWindow 中的方法
设置此窗口的 contentPane 属性。
setContentPane(Container) - 接口 javax.swing.RootPaneContainer 中的方法
"contentPane" 是应用程序特定组件的主要容器。
setContents(Transferable, ClipboardOwner) - 类 java.awt.datatransfer.Clipboard 中的方法
将剪贴板的当前内容设置到指定的 transferable 对象，并将指定的剪贴板所有者作为新内容的所有者注册。
setContentType(String) - 类 javax.swing.JEditorPane 中的方法
设置此编辑器所处理的内容类型。
setContentType(String) - 类 javax.xml.soap.AttachmentPart 中的方法
使用给定值设置名为 "Content-Type" 的 MIME 头。
setContext(ScriptContext) - 类 javax.script.AbstractScriptEngine 中的方法
将受保护 context 字段的值设置为指定的 ScriptContext。
setContext(ScriptContext) - 接口 javax.script.ScriptEngine 中的方法
设置 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。
setContextClassLoader(ClassLoader) - 类 java.lang.Thread 中的方法
设置该线程的上下文 ClassLoader。
setContinueExistingPeriodicTasksAfterShutdownPolicy(boolean) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
设置有关在此执行程序已 shutdown 的情况下是否继续执行现有定期任务的策略。
setContinuousLayout(boolean) - 类 javax.swing.JSplitPane 中的方法
设置 continuousLayout 属性的值，在用户干预期要使子组件连续地重新显示和布局子组件，此值必须为 true。
setContinuousLayout(boolean) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
打开/关闭连续布局。
setControlButtonsAreShown(boolean) - 类 javax.swing.JFileChooser 中的方法
设置属性，指示在文件选择器中是否显示 approve 和 cancel 按钮。
setController(IIOParamController) - 类 javax.imageio.IIOParam 中的方法
设置在调用 activateController 方法时用来为 IIOParam 对象提供设置值的 IIOParamController，重写所有默认控制器。
setController(IIOMetadataController) - 类 javax.imageio.metadata.IIOMetadata 中的方法
设置在调用 activateController 方法时用来为此 IIOParam 对象提供设置值的 IIOMetadataController，重写任何默认控制器。
setCookiePolicy(CookiePolicy) - 类 java.net.CookieManager 中的方法
设置此 cookie 管理器的 cookie 策略。
setCopies(int) - 类 java.awt.JobAttributes 中的方法
指定应用程序应该使用这些属性呈现作业的份数。
setCopies(int) - 类 java.awt.print.PrinterJob 中的方法
设置要打印的副本数。
setCopiesToDefault() - 类 java.awt.JobAttributes 中的方法
将应用程序应该使用这些属性呈现作业的份数设置为默认值。
setCorePoolSize(int) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
设置核心线程数。
setCorner(String, Component) - 类 javax.swing.JScrollPane 中的方法
添加一个将显示在一个滚动窗格角中的子级，如果有空间的话。
setCountLimit(long) - 类 javax.naming.directory.SearchControls 中的方法
设置要作为搜索结果返回的最大项数。
setCrc(long) - 类 java.util.zip.ZipEntry 中的方法
设置未压缩条目数据的 CRC-32 校验和。
setCurrency(Currency) - 类 java.text.DecimalFormat 中的方法
设置格式化货币值时，此数字格式使用的货币。
setCurrency(Currency) - 类 java.text.DecimalFormatSymbols 中的方法
设置这些 DecimalFormatSymbols 的货币。
setCurrency(Currency) - 类 java.text.NumberFormat 中的方法
设置格式化货币值时此数值格式使用的货币。
setCurrency(int, boolean) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为给定的 boolean，以指示存储在该列中的值是否为缓存值。
setCurrency(int, boolean) - 接口 javax.sql.RowSetMetaData 中的方法
设置指定的列是否是现金值。
setCurrencySymbol(String) - 类 java.text.DecimalFormatSymbols 中的方法
设置这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。
setCurrent(Checkbox) - 类 java.awt.CheckboxGroup 中的方法
已过时。 从 JDK version 1.1 开始，由 setSelectedCheckbox(Checkbox) 取代。
setCurrentAccessibleValue(Number) - 类 java.awt.Button.AccessibleAWTButton 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
将此对象的值设置为数字。
setCurrentAccessibleValue(Number) - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 接口 javax.accessibility.AccessibleValue 中的方法
以 Number 形式设置此对象的值。
setCurrentAccessibleValue(Number) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
将此对象的值设置为数字。
setCurrentAccessibleValue(Number) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
将此对象的值设置为数字。
setCurrentAccessibleValue(Number) - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
将此对象的值设置为一个 Number。
setCurrentDirectory(File) - 类 javax.swing.JFileChooser 中的方法
设置当前目录。
setCurrentKeyboardFocusManager(KeyboardFocusManager) - 类 java.awt.KeyboardFocusManager 中的静态方法
设置调用线程上下文的当前 KeyboardFocusManager 实例。
setCurrentLineLength(int) - 类 javax.swing.text.AbstractWriter 中的方法
设置当前行的长度。
setCurrentManager(FocusManager) - 类 javax.swing.FocusManager 中的静态方法
设置调用线程上下文的当前 KeyboardFocusManager 实例。
setCurrentManager(RepaintManager) - 类 javax.swing.RepaintManager 中的静态方法
设置用于调用线程的 RepaintManager。
setCurrentTheme(MetalTheme) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
设置 MetalLookAndFeel 使用的主题。
setCursor(Cursor) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的 Cursor。
setCursor(Cursor) - 类 java.awt.Component 中的方法
为指定的光标设置光标图像。
setCursor(Cursor) - 类 java.awt.dnd.DragSourceContext 中的方法
将此拖动操作的光标设置为指定的 Cursor。
setCursor(int) - 类 java.awt.Frame 中的方法
已过时。 从 JDK version 1.1 开始，由 Component.setCursor(Cursor) 取代。
setCursor(Cursor) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置此对象的 Cursor。
setCursor(Cursor) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置此对象的 Cursor。
setCursor(Cursor) - 类 java.awt.Window 中的方法
设置指定光标的光标图像。
setCursor(Cursor) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置此对象的 Cursor。
setCursor(Cursor) - 类 javax.swing.JInternalFrame 中的方法
为指定的光标设置光标图像。
setCursor(Cursor) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setCursor(Cursor) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置此对象的 Cursor。
setCursor(Cursor) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setCursor(Cursor) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setCursorName(String) - 接口 java.sql.Statement 中的方法
将 SQL 指针名称设置为给定的 String，后续 Statement 对象的 execute 方法将使用此字符串。
setCurve(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D.Double 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D.Float 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(float, float, float, float, float, float, float, float) - 类 java.awt.geom.CubicCurve2D.Float 中的方法
将此曲线结束点和控制点的位置设置为指定的 float 坐标。
setCurve(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(double[], int) - 类 java.awt.geom.CubicCurve2D 中的方法
将此曲线端点和控制点的位置设置为指定数组中指定偏移量的 double 坐标。
setCurve(Point2D, Point2D, Point2D, Point2D) - 类 java.awt.geom.CubicCurve2D 中的方法
将此曲线端点和控制点的位置设置为指定的 Point2D 坐标。
setCurve(Point2D[], int) - 类 java.awt.geom.CubicCurve2D 中的方法
将此曲线端点和控制点的位置设置为指定数组中指定偏移量的 Point2D 对象的坐标。
setCurve(CubicCurve2D) - 类 java.awt.geom.CubicCurve2D 中的方法
将此曲线端点和控制点的位置设置为与指定的 CubicCurve2D 相同。
setCurve(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D.Double 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D.Float 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(float, float, float, float, float, float) - 类 java.awt.geom.QuadCurve2D.Float 中的方法
将此曲线端点和控制点的位置设置为指定的 float 坐标。
setCurve(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(double[], int) - 类 java.awt.geom.QuadCurve2D 中的方法
将此 QuadCurve2D 端点和控制点的位置设置为指定数组中指定偏移量处的 double 坐标。
setCurve(Point2D, Point2D, Point2D) - 类 java.awt.geom.QuadCurve2D 中的方法
将此 QuadCurve2D 端点和控制点的位置设置为指定的 Point2D 坐标。
setCurve(Point2D[], int) - 类 java.awt.geom.QuadCurve2D 中的方法
将此 QuadCurve2D 端点和控制点的位置设置为指定数组中指定偏移量处 Point2D 对象的坐标。
setCurve(QuadCurve2D) - 类 java.awt.geom.QuadCurve2D 中的方法
将此 QuadCurve2D 端点和控制点的位置设置为与指定的 QuadCurve2D 相同。
setDaemon(boolean) - 类 java.lang.Thread 中的方法
将该线程标记为守护线程或用户线程。
setDaemon(boolean) - 类 java.lang.ThreadGroup 中的方法
更改此线程组的后台程序状态。
setData(int, byte[]) - 类 java.awt.color.ICC_Profile 中的方法
从一个 byte 数组中设置配置文件中的特定标记数据元素。
setData(Raster) - 类 java.awt.image.BufferedImage 中的方法
将图像的矩形区域设置为指定 Raster r 的内容，假定该区域与 BufferedImage 处于相同的坐标空间。
setData(Raster) - 接口 java.awt.image.WritableRenderedImage 中的方法
将图像的 rect 设置为 Raster r 的内容，假定 r 位于与 WritableRenderedImage 相同的坐标空间。
setData(byte[], int, int) - 类 java.net.DatagramPacket 中的方法
为此包设置数据缓冲区。
setData(byte[]) - 类 java.net.DatagramPacket 中的方法
为此包设置数据缓冲区。
setData(byte[]) - 类 javax.imageio.stream.IIOByteBuffer 中的方法
更新对 getData 方法的后续调用将返回的数组引用。
setData(String) - 接口 org.w3c.dom.CharacterData 中的方法
实现此接口的节点的字符数据。
setData(String) - 接口 org.w3c.dom.ProcessingInstruction 中的方法
此处理指令的内容。
setDataContentHandlerFactory(DataContentHandlerFactory) - 类 javax.activation.DataHandler 中的静态方法
设置 DataContentHandlerFactory。
setDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
setDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
setDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
setDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
setDataElements(int, int, int, int, Object, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 TransferType 类型的基本数组设置指定 DataBuffer 中像素矩形的数据。
setDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
根据 TransferType 类型的基本数组设置指定 DataBuffer 中单个像素的数据。
setDataElements(int, int, Object) - 类 java.awt.image.WritableRaster 中的方法
为类型 TransferType 基本数组中的单个像素设置数据。
setDataElements(int, int, Raster) - 类 java.awt.image.WritableRaster 中的方法
为输入 Raster 中的像素矩形设置数据。
setDataElements(int, int, int, int, Object) - 类 java.awt.image.WritableRaster 中的方法
为类型 TransferType 基本数组中的像素矩形设置数据。
setDatagramSocketImplFactory(DatagramSocketImplFactory) - 类 java.net.DatagramSocket 中的静态方法
为应用程序设置数据报套接字实现工厂。
setDataHandler(DataHandler) - 类 javax.xml.soap.AttachmentPart 中的方法
将给定的 DataHandler 对象设置为此 AttachmentPart 对象的数据处理程序。
setDataSourceLock(int) - 类 javax.sql.rowset.spi.SyncProvider 中的方法
按照 datasource_lock 指示的级别在底层数据源上设置锁定。
setDataSourceName(String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的 DataSource 名称属性设置为给定的逻辑名，并将此 RowSet 对象的 Url 属性设置为 null。
setDataSourceName(String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的数据源名称属性设置为给定的 String。
setDatatypeConverter(DatatypeConverterInterface) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
此方法仅适用于 JAXB 提供者。
setDataVector(Vector, Vector) - 类 javax.swing.table.DefaultTableModel 中的方法
用新的行 Vector（dataVector）替换当前的 dataVector 实例变量。
setDataVector(Object[][], Object[]) - 类 javax.swing.table.DefaultTableModel 中的方法
用数组 dataVector 中的值替换 dataVector 实例变量中的值。
setDate(Date) - 类 java.security.cert.PKIXParameters 中的方法
设置应该确定证书路径有效性的时间。
setDate(String, Date) - 接口 java.sql.CallableStatement 中的方法
使用运行应用程序的虚拟机默认时区将指定参数设置为给定 java.sql.Date 值。
setDate(String, Date, Calendar) - 接口 java.sql.CallableStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
setDate(int, Date) - 接口 java.sql.PreparedStatement 中的方法
使用运行应用程序的虚拟机的默认时区将指定参数设置为给定 java.sql.Date 值。
setDate(int, Date, Calendar) - 接口 java.sql.PreparedStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
setDate(int) - 类 java.sql.Time 中的方法
已过时。
setDate(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.DAY_OF_MONTH, int date) 取代。
setDate(int, Date) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Date 值。
setDate(int, Date, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Date 对象。
setDate(String, Date) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
setDate(String, Date, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
setDate(int, Date) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Date 值。
setDate(int, Date, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 java.sql.Date 值设置此 RowSet 对象命令中的指定参数。
setDate(String, Date) - 接口 javax.sql.RowSet 中的方法
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
setDate(String, Date, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
setDateAndTime(Date) - 类 java.security.cert.X509CRLSelector 中的方法
设置 dateAndTime 标准。
setDateFormatSymbols(DateFormatSymbols) - 类 java.text.SimpleDateFormat 中的方法
设置此日期格式的日期和时间格式符号。
setDay(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置月中的日。
setDebugGraphicsOptions(int) - 类 javax.swing.JComponent 中的方法
启用或禁用与组件或其某个子组件内执行的每个图形操作有关的诊断信息。
setDebugOptions(int) - 类 javax.swing.DebugGraphics 中的方法
启用/禁用有关每个图形操作的诊断信息。
setDecimalFormatSymbols(DecimalFormatSymbols) - 类 java.text.DecimalFormat 中的方法
设置小数格式符号，通常程序员或用户不改变此符号。
setDecimalSeparator(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于十进制符号的字符。
setDecimalSeparatorAlwaysShown(boolean) - 类 java.text.DecimalFormat 中的方法
允许设置整数中小数分隔符的行为。
setDeclared(int, boolean) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
将值分配给特定属性的“声明的”标志。
setDecodeTables(JPEGQTable[], JPEGHuffmanTable[], JPEGHuffmanTable[]) - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
设置量化表和 Huffman 表以在解码简写流中使用。
setDecomposition(int) - 类 java.text.Collator 中的方法
设置此 Collator 的 decomposition 模式。
setDefault(Authenticator) - 类 java.net.Authenticator 中的静态方法
设置在代理或 HTTP 服务器请求验证时连网密码使用的 authenticator。
setDefault(CookieHandler) - 类 java.net.CookieHandler 中的静态方法
设置（或取消设置）系统级 cookie 处理程序。
setDefault(ProxySelector) - 类 java.net.ProxySelector 中的静态方法
设置（或取消设置）系统级代理选择器。
setDefault(ResponseCache) - 类 java.net.ResponseCache 中的静态方法
设置（或取消设置）系统级缓存。
setDefault(Locale) - 类 java.util.Locale 中的静态方法
为此 Java 虚拟机实例设置默认语言环境。
setDefault(TimeZone) - 类 java.util.TimeZone 中的静态方法
设置由 getDefault 方法返回的 TimeZone。
setDefault(SSLContext) - 类 javax.net.ssl.SSLContext 中的静态方法
设置默认的 SSL 上下文。
setDefaultAction(Action) - 接口 javax.swing.text.Keymap 中的方法
在进行击键的情况下设置要激发的默认操作。
setDefaultActions(int) - 类 java.awt.dnd.DropTarget 中的方法
为此 DropTarget 设置默认的可接受操作。
setDefaultAllowUserInteraction(boolean) - 类 java.net.URLConnection 中的静态方法
将未来的所有 URLConnection 对象的 allowUserInteraction 字段的默认值设置为指定的值。
setDefaultAssertionStatus(boolean) - 类 java.lang.ClassLoader 中的方法
设置此类加载器的默认断言状态。
setDefaultButton(JButton) - 类 javax.swing.JRootPane 中的方法
设置 defaultButton 属性，它确定此 JRootPane 的当前默认按钮。
setDefaultCapable(boolean) - 类 javax.swing.JButton 中的方法
设置 defaultCapable 属性，该属性确定此按钮是否可以是其根窗格的默认按钮。
setDefaultClassLoader(ClassLoader) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
设置此连接器服务器的默认 ClassLoader。
setDefaultCloseOperation(int) - 类 javax.swing.JDialog 中的方法
设置当用户在此对话框上启动 "close" 时默认执行的操作。
setDefaultCloseOperation(int) - 类 javax.swing.JFrame 中的方法
设置用户在此窗体上发起 "close" 时默认执行的操作。
setDefaultCloseOperation(int) - 类 javax.swing.JInternalFrame 中的方法
设置用户在此内部窗体上发起 "close" 时默认执行的操作。
setDefaultCommandMap(CommandMap) - 类 javax.activation.CommandMap 中的静态方法
设置默认的 CommandMap。
setDefaultCursor(Cursor) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
设置默认光标。
setDefaultDTD() - 类 javax.swing.text.html.parser.ParserDelegator 中的静态方法
setDefaultEditor(Class<?>, TableCellEditor) - 类 javax.swing.JTable 中的方法
如果尚未在 TableColumn 中设置编辑器，则设置要使用的默认单元格编辑器。
setDefaultFileTypeMap(FileTypeMap) - 类 javax.activation.FileTypeMap 中的静态方法
设置系统的默认 FileTypeMap。
setDefaultFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - 类 java.awt.KeyboardFocusManager 中的方法
设置给定遍历操作的默认焦点遍历键。
setDefaultFocusTraversalPolicy(FocusTraversalPolicy) - 类 java.awt.KeyboardFocusManager 中的方法
设置默认 FocusTraversalPolicy。
setDefaultFormatter(JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 中的方法
设置 JFormattedTextField.AbstractFormatter 供最后选择使用，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。
setDefaultHostnameVerifier(HostnameVerifier) - 类 javax.net.ssl.HttpsURLConnection 中的静态方法
设置此类的新实例所继承的默认 HostnameVerifier。
setDefaultLightWeightPopupEnabled(boolean) - 类 javax.swing.JPopupMenu 中的静态方法
设置 lightWeightPopupEnabled 属性的默认值。
setDefaultLocale(Locale) - 类 javax.swing.JComponent 中的静态方法
设置在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。
setDefaultLocale(Locale) - 类 javax.swing.UIDefaults 中的方法
设置默认语言环境。
setDefaultLookAndFeelDecorated(boolean) - 类 javax.swing.JDialog 中的静态方法
提供一个关于是否应该通过当前外观为新创建的 JDialog 提供其 Window 装饰（如边界、关闭窗口的小部件、标题……）的提示。
setDefaultLookAndFeelDecorated(boolean) - 类 javax.swing.JFrame 中的静态方法
提供一个关于新创建的 JFrame 是否应该具有当前外观为其提供的 Window 装饰（如边框、关闭窗口的小部件、标题等等）的提示。
setDefaultNamespace(String) - 接口 javax.xml.stream.XMLEventWriter 中的方法
将 URI 绑定到默认名称空间。
setDefaultNamespace(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
将 URI 绑定到默认名称空间。
setDefaultNamespacePrefix(String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
setDefaultNamespacePrefix(String) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
设置默认的名称空间前缀。
setDefaultQueue(LayoutQueue) - 类 javax.swing.text.LayoutQueue 中的静态方法
设置默认的布局队列。
setDefaultRenderer(Class<?>, TableCellRenderer) - 类 javax.swing.JTable 中的方法
如果没有在 TableColumn 中设置渲染器，则设置要使用的默认单元格渲染器。
setDefaultRenderer(TableCellRenderer) - 类 javax.swing.table.JTableHeader 中的方法
设置 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。
setDefaultRequestProperty(String, String) - 类 java.net.URLConnection 中的静态方法
已过时。 应在获得 URLConnection 的适当实例后使用特定 setRequestProperty 方法的实例。调用此方法没有任何作用。
setDefaultSelection(JobAttributes.DefaultSelectionType) - 类 java.awt.JobAttributes 中的方法
指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。
setDefaultSSLSocketFactory(SSLSocketFactory) - 类 javax.net.ssl.HttpsURLConnection 中的静态方法
设置此类的新实例所继承的默认 SSLSocketFactory。
setDefaultStream(PrintStream) - 类 java.rmi.server.LogStream 中的静态方法
已过时。 无替代版本
setDefaultUncaughtExceptionHandler(Thread.UncaughtExceptionHandler) - 类 java.lang.Thread 中的静态方法
设置当线程由于未捕获到异常而突然终止，并且没有为该线程定义其他处理程序时所调用的默认处理程序。
setDefaultUseCaches(boolean) - 类 java.net.URLConnection 中的方法
将 useCaches 字段的默认值设置为指定的值。
setDelay(int) - 类 javax.swing.JMenu 中的方法
设置菜单的 PopupMenu 向上或向下弹出前建议的延迟。
setDelay(int) - 类 javax.swing.Timer 中的方法
设置 Timer 的事件间延迟，两次连续的动作事件之间的毫秒数。
setDerefLinkFlag(boolean) - 类 javax.naming.directory.SearchControls 中的方法
启用/禁用在搜索期间取消对链接的引用。
setDescription(String) - 类 javax.swing.ImageIcon 中的方法
设置图像的描述。
setDescriptor(Descriptor) - 接口 javax.management.DescriptorAccess 中的方法
设置 Descriptor（完全替换）。
setDescriptor(Descriptor) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 中的方法
设置 ModelMBeanAttributeDescriptor 的关联 Descriptor（完全取代）。
setDescriptor(Descriptor) - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 中的方法
设置 ModelMBeanConstructorInfo 的关联 Descriptor（完全替换）。
setDescriptor(Descriptor, String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。
setDescriptor(Descriptor, String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
setDescriptor(Descriptor) - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 中的方法
设置 ModelMBeanNotificationInfo 的关联 Descriptor（完全替换）。
setDescriptor(Descriptor) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 中的方法
设置 ModelMBeanOperationInfo 的关联 Descriptor（完全取代）。
setDescriptors(Descriptor[]) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
添加或替换 ModelMBeanInfo 中的描述符。
setDescriptors(Descriptor[]) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
setDesignTime(boolean) - 类 java.beans.beancontext.BeanContextSupport 中的方法
为此 BeanContext 设置新的设计时间值。
setDesignTime(boolean) - 类 java.beans.Beans 中的静态方法
用于指示是否正运行在应用程序生成器环境中。
setDesignTime(boolean) - 接口 java.beans.DesignMode 中的方法
设置 "designTime" 属性的 "value"。
setDesktopIcon(JInternalFrame.JDesktopIcon) - 类 javax.swing.JInternalFrame 中的方法
设置与此 JInternalFrame 关联的 JDesktopIcon。
setDesktopManager(DesktopManager) - 类 javax.swing.JDesktopPane 中的方法
设置处理特定于桌面 UI 操作的 DesktopManger。
setDesktopProperty(String, Object) - 类 java.awt.Toolkit 中的方法
将指定桌面属性设置为指定值，并触发一个属性更改事件，以通知所有侦听器该值已更改。
setDestination(JobAttributes.DestinationType) - 类 java.awt.JobAttributes 中的方法
指定将输出到打印机还是使用这些属性的作业文件。
setDestination(BufferedImage) - 类 javax.imageio.ImageReadParam 中的方法
提供一个 BufferedImage，将其用作解码像素数据的目标。
setDestinationBands(int[]) - 类 javax.imageio.ImageReadParam 中的方法
设置将在其中放置数据的目标 band 的索引。
setDestinationOffset(Point) - 类 javax.imageio.IIOParam 中的方法
指定目标图像中的偏移量。
setDestinationType(ImageTypeSpecifier) - 类 javax.imageio.IIOParam 中的方法
使用 ImageTypeSpecifier 设置目标图像的所需图像类型。
setDestinationType(ImageTypeSpecifier) - 类 javax.imageio.ImageReadParam 中的方法
setDialog(JobAttributes.DialogType) - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。
setDialogTitle(String) - 类 javax.swing.JFileChooser 中的方法
设置显示在 JFileChooser 窗口标题栏的字符串。
setDialogType(int) - 类 javax.swing.JFileChooser 中的方法
设置此对话框的类型。
setDictionary(byte[], int, int) - 类 java.util.zip.Deflater 中的方法
为压缩设置预置字典。
setDictionary(byte[]) - 类 java.util.zip.Deflater 中的方法
为压缩预置字典。
setDictionary(byte[], int, int) - 类 java.util.zip.Inflater 中的方法
为给定的字节数组设置预置字典。
setDictionary(byte[]) - 类 java.util.zip.Inflater 中的方法
为给定字节的数组设置预置字典。
setDifferenceMode(boolean) - 类 javax.management.monitor.CounterMonitor 中的方法
设置所有观察到的 MBeans 的共同的差分模式标志值。
setDifferenceMode(boolean) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
设置差分模式标志值。
setDifferenceMode(boolean) - 类 javax.management.monitor.GaugeMonitor 中的方法
设置所有观察到的 MBean 的公共差分模式标志值。
setDifferenceMode(boolean) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
设置差分模式标志值。
setDigit(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于某种模式中数字的字符。
setDimensions(int, int) - 类 java.awt.image.BufferedImageFilter 中的方法
过滤 ImageConsumer 接口的 setDimensions 方法中提供的信息。
setDimensions(int, int) - 类 java.awt.image.CropImageFilter 中的方法
重写源图像的维度，并将矩形裁剪区域的维度传递给 ImageConsumer。
setDimensions(int, int) - 接口 java.awt.image.ImageConsumer 中的方法
使用 setDimensions 方法调用报告源图像尺寸。
setDimensions(int, int) - 类 java.awt.image.ImageFilter 中的方法
过滤 ImageConsumer 接口的 setDimensions 方法中所提供的信息。
setDimensions(int, int) - 类 java.awt.image.PixelGrabber 中的方法
setDimensions 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setDimensions(int, int) - 类 java.awt.image.ReplicateScaleFilter 中的方法
覆盖源像素的尺寸，并将缩放后的新尺寸传递给 ImageConsumer。
setDirection(int) - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
设置箭头的方向。
setDirection(int) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 中的方法
setDirection(int) - 类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 中的方法
setDirection(short) - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
设置方向。
setDirectory(String) - 类 java.awt.FileDialog 中的方法
将此文件对话框窗口的目录设置为指定目录。
setDirectory(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
记忆当前在 UI 中选择的目录的属性。
setDirectoryName(String) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
setDirectoryName(String) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
setDirectorySelected(boolean) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
记忆当前是否在 UI 中选择了目录的属性。
setDirectorySelected(boolean) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
记忆某个目录在 UI 中当前是否被选择的属性。
setDisabledIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的禁用图标。
setDisabledIcon(Icon) - 类 javax.swing.JLabel 中的方法
设置如果此 JLabel 是“禁用的”(JLabel.setEnabled(false))，则要显示的图标。
setDisabledIconAt(int, Icon) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的禁用图标设置为 icon，它可以为 null。
setDisabledSelectedIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的禁用选择图标。
setDisabledTextColor(Color) - 类 javax.swing.text.JTextComponent 中的方法
设置用于呈现禁用文本的当前颜色。
setDiscard(boolean) - 类 java.net.HttpCookie 中的方法
指定用户代理是否应该无条件丢弃 cookie。
setDismissDelay(int) - 类 javax.swing.ToolTipManager 中的方法
指定取消工具提示的延迟值。
setDisplayedMnemonic(int) - 类 javax.swing.JLabel 中的方法
指定一个指示助记符键的键代码。
setDisplayedMnemonic(char) - 类 javax.swing.JLabel 中的方法
指定 displayedMnemonic 为一个 char 值。
setDisplayedMnemonicIndex(int) - 类 javax.swing.AbstractButton 中的方法
提供关于应该装饰文本中哪一个字符来表示助记符的外观提示。
setDisplayedMnemonicIndex(int) - 类 javax.swing.JLabel 中的方法
关于应该装饰文本中的哪个字符以表示助记符，为外观提供一个提示。
setDisplayedMnemonicIndexAt(int, int) - 类 javax.swing.JTabbedPane 中的方法
提供一个外观的提示，此提示是关于文本中哪此字符必须被装饰用来表示助记符。
setDisplayFormatter(JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 中的方法
设置在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
setDisplayMode(DisplayMode) - 类 java.awt.GraphicsDevice 中的方法
设置此图形设备的显示模式。
setDisplayName(String) - 类 java.beans.FeatureDescriptor 中的方法
设置此特性的本地化显示名称。
setDividerLocation(double) - 类 javax.swing.JSplitPane 中的方法
设置分隔条的位置为 JSplitPane 大小的一个百分比。
setDividerLocation(int) - 类 javax.swing.JSplitPane 中的方法
设置分隔条的位置。
setDividerLocation(JSplitPane, int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
将分隔符的位置设置到 location。
setDividerLocation(JSplitPane, int) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 setDividerLocation 方法。
setDividerLocation(JSplitPane, int) - 类 javax.swing.plaf.SplitPaneUI 中的方法
将分隔符的位置设置到 location。
setDividerSize(int) - 类 javax.swing.JSplitPane 中的方法
设置分隔条的大小。
setDividerSize(int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
将分隔符的大小设置为 newSize。
setDockingColor(Color) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
设置在连接区域上时显示的颜色。
setDocument(Document) - 类 javax.swing.JFormattedTextField 中的方法
将该编辑器与某个文本文档关联。
setDocument(Document) - 类 javax.swing.JTextField 中的方法
将编辑器与一个文本文档关联。
setDocument(Document) - 类 javax.swing.JTextPane 中的方法
将编辑器与一个文本文档关联。
setDocument(Document) - 类 javax.swing.text.JTextComponent 中的方法
将编辑器与文本文档关联。
setDocumentFilter(DocumentFilter) - 类 javax.swing.text.AbstractDocument 中的方法
设置 DocumentFilter。
setDocumentHandler(DocumentHandler) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
注册 SAX1 文档事件处理程序。
setDocumentHandler(DocumentHandler) - 接口 org.xml.sax.Parser 中的方法
已过时。 允许应用程序注册文档事件处理程序。
setDocumentLocator(Locator) - 接口 org.xml.sax.ContentHandler 中的方法
接收用来查找 SAX 文档事件起源的对象。
setDocumentLocator(Locator) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收用来查找 SAX 文档事件起源的对象。
setDocumentLocator(Locator) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收文档事件的 Locator 对象。
setDocumentLocator(Locator) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收文档事件的 Locator 对象。
setDocumentLocator(Locator) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
setDocumentLocator(Locator) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个新的文档定位器事件。
setDocumentLocator(Locator) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
设置文档定位器。
setDocumentProperties(Dictionary<Object, Object>) - 类 javax.swing.text.AbstractDocument 中的方法
替换此文档的文档属性字典。
setDocumentURI(String) - 接口 org.w3c.dom.Document 中的方法
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。
setDoInput(boolean) - 类 java.net.URLConnection 中的方法
将此 URLConnection 的 doInput 字段的值设置为指定的值。
setDomain(String) - 类 java.net.HttpCookie 中的方法
指定应在其中显示此 cookie 的域。
setDoOutput(boolean) - 类 java.net.URLConnection 中的方法
将此 URLConnection 的 doOutput 字段的值设置为指定的值。
setDot(int) - 接口 javax.swing.text.Caret 中的方法
将插入符位置设置为其他某个位置。
setDot(int) - 类 javax.swing.text.DefaultCaret 中的方法
将插入符位置和标记设置为指定位置，存在向前偏差。
setDot(int, Position.Bias) - 类 javax.swing.text.DefaultCaret 中的方法
将插入符位置和标记设置为指定位置，存在指定偏差。
setDot(int, Position.Bias) - 类 javax.swing.text.NavigationFilter.FilterBypass 中的方法
设置插入符的位置，并跳过 NavigationFilter。
setDot(NavigationFilter.FilterBypass, int, Position.Bias) - 类 javax.swing.text.NavigationFilter 中的方法
在 Caret 设置点之前调用。
setDouble(Object, int, double) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 double 值。
setDouble(Object, double) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 double 值。
setDouble(String, double) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java double 值。
setDouble(int, double) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java double 值。
setDouble(int, double) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 double 值。
setDouble(String, double) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java double 值。
setDouble(int, double) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java double 值。
setDouble(String, double) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java double 值。
setDoubleBuffered(boolean) - 类 javax.swing.JComponent 中的方法
设置此组件是否应该使用缓冲区进行绘制。
setDoubleBuffered(boolean) - 类 javax.swing.JRootPane 中的方法
设置此组件是否应该使用缓冲区进行绘制。
setDoubleBufferingEnabled(boolean) - 类 javax.swing.RepaintManager 中的方法
在此 RepaintManager 中，启用或禁用双缓冲。
setDoubleBufferMaximumSize(Dimension) - 类 javax.swing.RepaintManager 中的方法
设置最大双缓冲区大小。
setDragEnabled(boolean) - 类 javax.swing.JColorChooser 中的方法
设置 dragEnabled 属性，该属性必须为 true 才能启用对此组件的自动拖动处理（拖放操作的第一部分）。
setDragEnabled(boolean) - 类 javax.swing.JFileChooser 中的方法
设置 dragEnabled 属性，要在此组件上启用自动拖动处理（drag 和 drop 的第一部分），此属性必须为 true。
setDragEnabled(boolean) - 类 javax.swing.JList 中的方法
打开或关闭自动拖动处理。
setDragEnabled(boolean) - 类 javax.swing.JTable 中的方法
打开或关闭自动拖动处理。
setDragEnabled(boolean) - 类 javax.swing.JTree 中的方法
打开或关闭自动拖动处理。
setDragEnabled(boolean) - 类 javax.swing.text.JTextComponent 中的方法
开启或关闭自动拖动处理。
setDraggedColumn(TableColumn) - 类 javax.swing.table.JTableHeader 中的方法
将头的 draggedColumn 设置为 aColumn。
setDraggedDistance(int) - 类 javax.swing.table.JTableHeader 中的方法
将头的 draggedDistance 设置为 distance。
setDragMode(int) - 类 javax.swing.JDesktopPane 中的方法
设置桌面窗格使用的“拖动样式”。
setDragOffset(Point) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
setDrawsLayeredHighlights(boolean) - 类 javax.swing.text.DefaultHighlighter 中的方法
如果为 true，则高亮显示将在视图绘制文本时绘制。
setDropAction(int) - 类 javax.swing.TransferHandler.TransferSupport 中的方法
将传输（必须表示一个放置操作）的放置动作设置为给定动作，而不是默认的用户放置动作。
setDropMode(DropMode) - 类 javax.swing.JList 中的方法
设置此组件的放置模式。
setDropMode(DropMode) - 类 javax.swing.JTable 中的方法
设置此组件的放置模式。
setDropMode(DropMode) - 类 javax.swing.JTree 中的方法
设置此组件的放置模式。
setDropMode(DropMode) - 类 javax.swing.text.JTextComponent 中的方法
设置此组件的放置模式，为了向后兼容性，此属性的默认值为 DropMode.USE_SELECTION。
setDropTarget(DropTarget) - 类 java.awt.Component 中的方法
将组件与 DropTarget 相关联。
setDSTSavings(int) - 类 java.util.SimpleTimeZone 中的方法
设置在夏令时期间时钟提前的时间量（以毫秒为单位）。
setDTDHandler(DTDHandler) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
设置 DTD 处理程序。
setDTDHandler(DTDHandler) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置 DTD 事件处理程序。
setDTDHandler(DTDHandler) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
注册 DTD 事件处理程序。
setDTDHandler(DTDHandler) - 接口 org.xml.sax.Parser 中的方法
已过时。 允许应用程序注册 DTD 事件处理程序。
setDTDHandler(DTDHandler) - 接口 org.xml.sax.XMLReader 中的方法
允许应用程序注册 DTD 事件处理程序。
setDynamicLayout(boolean) - 类 java.awt.Toolkit 中的方法
控制 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。
setEastPane(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setEchoChar(char) - 类 java.awt.TextField 中的方法
设置此文本字段的回显字符。
setEchoChar(char) - 类 javax.swing.JPasswordField 中的方法
设置此 JPasswordField 的回显字符。
setEchoCharacter(char) - 类 java.awt.TextField 中的方法
已过时。 从 JDK version 1.1 开始，由 setEchoChar(char) 取代。
setEditable(boolean) - 类 java.awt.TextComponent 中的方法
设置判断此文本组件是否可编辑的标志。
setEditable(boolean) - 类 javax.swing.JComboBox 中的方法
确定 JComboBox 字段是否可编辑。
setEditable(boolean) - 类 javax.swing.JTree 中的方法
确定树是否可编辑。
setEditable(boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
配置接收者以允许或不允许进行编辑。
setEditable(boolean) - 类 javax.swing.text.JTextComponent 中的方法
设置指定的 boolean 变量，以指示此 TextComponent 是否应该为可编辑的。
setEditFormatter(JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 中的方法
设置在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
setEditingColumn(int) - 类 javax.swing.JTable 中的方法
设置 editingColumn 变量。
setEditingRow(int) - 类 javax.swing.JTable 中的方法
设置 editingRow 变量。
setEditor(ComboBoxEditor) - 类 javax.swing.JComboBox 中的方法
设置用于绘制和编辑 JComboBox 字段中所选项的编辑器。
setEditor(JComponent) - 类 javax.swing.JSpinner 中的方法
更改显示 SpinnerModel 当前值的 JComponent。
setEditorKit(EditorKit) - 类 javax.swing.JEditorPane 中的方法
设置当前为处理内容而安装的工具包。
setEditorKit(EditorKit) - 类 javax.swing.JTextPane 中的方法
设置当前安装的用于内容处理的工具包。
setEditorKitForContentType(String, EditorKit) - 类 javax.swing.JEditorPane 中的方法
直接设置用于给定类型的编辑器工具包。
setEditorSearchPath(String[]) - 类 java.beans.PropertyEditorManager 中的静态方法
更改将用来查找属性编辑器的包名称的列表。
setEditValid(boolean) - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
调用此方法以更新 JFormattedTextField 的 editValid 属性。
setElem(int, int) - 类 java.awt.image.DataBuffer 中的方法
根据给定的整数设置第一个（默认）存储单元中所请求的数据数组元素。
setElem(int, int, int) - 类 java.awt.image.DataBuffer 中的方法
根据给定的整数设置指定存储单元中所请求的数据数组元素。
setElem(int, int) - 类 java.awt.image.DataBufferByte 中的方法
将第一个（默认）存储单元中所请求的数据数组设置为指定值。
setElem(int, int, int) - 类 java.awt.image.DataBufferByte 中的方法
根据给定的整数设置指定存储单元中所请求的数据数组元素。
setElem(int, int) - 类 java.awt.image.DataBufferDouble 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 int。
setElem(int, int, int) - 类 java.awt.image.DataBufferDouble 中的方法
将指定存储单元中所请求的数据数组元素设置为给定的 int。
setElem(int, int) - 类 java.awt.image.DataBufferFloat 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 int。
setElem(int, int, int) - 类 java.awt.image.DataBufferFloat 中的方法
将指定存储单元中所请求的数据数组元素设置为给定的 int。
setElem(int, int) - 类 java.awt.image.DataBufferInt 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。
setElem(int, int, int) - 类 java.awt.image.DataBufferInt 中的方法
将指定存储单元中所请求的数据数组元素设置为整数值 i。
setElem(int, int) - 类 java.awt.image.DataBufferShort 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。
setElem(int, int, int) - 类 java.awt.image.DataBufferShort 中的方法
根据给定的整数设置指定存储单元中所请求的数据数组元素。
setElem(int, int) - 类 java.awt.image.DataBufferUShort 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。
setElem(int, int, int) - 类 java.awt.image.DataBufferUShort 中的方法
根据给定的整数设置指定存储单元中所请求的数据数组元素。
setElemDouble(int, double) - 类 java.awt.image.DataBuffer 中的方法
根据给定的 double 设置第一个（默认）存储单元中所请求的数据数组元素。
setElemDouble(int, int, double) - 类 java.awt.image.DataBuffer 中的方法
根据给定的 double 设置指定存储单元中所请求的数据数组元素。
setElemDouble(int, double) - 类 java.awt.image.DataBufferDouble 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 double。
setElemDouble(int, int, double) - 类 java.awt.image.DataBufferDouble 中的方法
将指定存储单元中所请求的数据数组元素设置为给定的 double。
setElemDouble(int, double) - 类 java.awt.image.DataBufferFloat 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 double。
setElemDouble(int, int, double) - 类 java.awt.image.DataBufferFloat 中的方法
将指定存储单元中所请求的数据数组元素设置为 double。
setElementAt(E, int) - 类 java.util.Vector 中的方法
将此向量指定 index 处的组件设置为指定的对象。
setElementAt(Object, int) - 类 javax.swing.DefaultListModel 中的方法
将此列表指定 index 处的组件设置为指定的对象。
setElementQName(QName) - 接口 javax.xml.soap.SOAPElement 中的方法
如果可能，将此 Element 的名称更改为 newName。
setElemFloat(int, float) - 类 java.awt.image.DataBuffer 中的方法
根据给定的 float 设置第一个（默认）存储单元中所请求的数据数组元素。
setElemFloat(int, int, float) - 类 java.awt.image.DataBuffer 中的方法
根据给定的 float 设置指定存储单元中所请求的数据数组元素。
setElemFloat(int, float) - 类 java.awt.image.DataBufferDouble 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 float。
setElemFloat(int, int, float) - 类 java.awt.image.DataBufferDouble 中的方法
将指定存储单元中所请求的数据数组元素设置为给定的 float。
setElemFloat(int, float) - 类 java.awt.image.DataBufferFloat 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 float。
setElemFloat(int, int, float) - 类 java.awt.image.DataBufferFloat 中的方法
将指定存储单元中所请求的数据数组元素设置为给定的 float。
setEnabled(boolean) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的启用状态。
setEnabled(boolean) - 类 java.awt.Component 中的方法
根据参数 b 的值启用或禁用此组件。
setEnabled(boolean) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置对象的启用状态。
setEnabled(boolean) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置该对象的启用状态。
setEnabled(boolean) - 类 java.awt.MenuItem 中的方法
设置是否可以选择此菜单项。
setEnabled(boolean) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置对象的启用状态。
setEnabled(boolean) - 类 javax.swing.AbstractAction 中的方法
启用或禁用该操作。
setEnabled(boolean) - 类 javax.swing.AbstractButton 中的方法
启用（或禁用）按钮。
setEnabled(boolean) - 接口 javax.swing.Action 中的方法
设置 Action 的启用状态。
setEnabled(boolean) - 接口 javax.swing.ButtonModel 中的方法
启用或禁用该按钮。
setEnabled(boolean) - 类 javax.swing.DefaultButtonModel 中的方法
启用或禁用该按钮。
setEnabled(boolean) - 类 javax.swing.JComboBox 中的方法
启用组合框以便可以选择项。
setEnabled(boolean) - 类 javax.swing.JComponent 中的方法
设置是否启用此组件。
setEnabled(boolean) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setEnabled(boolean) - 类 javax.swing.JMenuItem 中的方法
启用或禁用菜单项。
setEnabled(boolean) - 类 javax.swing.JScrollBar 中的方法
启用该组件以便滑块位置能够改变。
setEnabled(boolean) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置该对象的启用状态。
setEnabled(boolean) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setEnabled(boolean) - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
setEnabled(boolean) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setEnabled(boolean) - 类 javax.swing.ToolTipManager 中的方法
启用或禁用工具提示。
setEnabledAt(int, boolean) - 类 javax.swing.JTabbedPane 中的方法
设置是否启用 index 位置的选项卡。
setEnabledCipherSuites(String[]) - 类 javax.naming.ldap.StartTlsResponse 中的方法
重写在 TLS 连接上启用的密码套件的默认列表。
setEnabledCipherSuites(String[]) - 类 javax.net.ssl.SSLEngine 中的方法
设置密码套件为启用，以便在此引擎上使用。
setEnabledCipherSuites(String[]) - 类 javax.net.ssl.SSLServerSocket 中的方法
把密码套件设置为启用的以供接受的连接使用。
setEnabledCipherSuites(String[]) - 类 javax.net.ssl.SSLSocket 中的方法
将密码套件设置为启用以供此连接使用。
setEnabledProtocols(String[]) - 类 javax.net.ssl.SSLEngine 中的方法
设置为了在此引擎上使用而启用的协议版本。
setEnabledProtocols(String[]) - 类 javax.net.ssl.SSLServerSocket 中的方法
控制启用哪些特定的协议以供接受的连接使用。
setEnabledProtocols(String[]) - 类 javax.net.ssl.SSLSocket 中的方法
设置启用以供此连接使用的协议版本。
setEnableSessionCreation(boolean) - 类 javax.net.ssl.SSLEngine 中的方法
控制是否可以由此引擎建立新的 SSL 会话。
setEnableSessionCreation(boolean) - 类 javax.net.ssl.SSLServerSocket 中的方法
控制新 SSL 会话是否可以通过此服务器套接字创建的套接字建立。
setEnableSessionCreation(boolean) - 类 javax.net.ssl.SSLSocket 中的方法
控制是否可以使用此套接字建立新的 SSL 会话。
setEncodeTables(JPEGQTable[], JPEGHuffmanTable[], JPEGHuffmanTable[]) - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
设置量化表和 Huffman 表以在编码简写流中使用。
setEncoding(String) - 类 java.util.logging.Handler 中的方法
设置该 Handler 所用的字符编码。
setEncoding(String) - 类 java.util.logging.StreamHandler 中的方法
设置（或更改）该 Handler 所用的字符编码。
setEncoding(String) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
设置输出编码的便捷方法。
setEncoding(String) - 接口 org.w3c.dom.ls.LSInput 中的方法
字符串编码（如果已知）。
setEncoding(String) - 接口 org.w3c.dom.ls.LSOutput 中的方法
用于输出的字符编码。
setEncoding(String) - 类 org.xml.sax.ext.Locator2Impl 中的方法
分配编码属性的当前值。
setEncoding(String) - 类 org.xml.sax.InputSource 中的方法
设置字符编码（如果已知）。
setEncodingStyle(String) - 接口 javax.xml.soap.SOAPElement 中的方法
将此 SOAPElement 对象的编码样式设置为指定样式。
setEnd(Comparable) - 类 javax.swing.SpinnerDateModel 中的方法
更改此序列中 Date 的上限。
setEndIndex(int) - 类 java.text.FieldPosition 中的方法
Sets the end index.由 Format 的子类使用。
setEndRule(int, int, int, int) - 类 java.util.SimpleTimeZone 中的方法
设置夏令时结束规则。
setEndRule(int, int, int) - 类 java.util.SimpleTimeZone 中的方法
将夏令时结束规则设置为某个月份的固定日期。
setEndRule(int, int, int, int, boolean) - 类 java.util.SimpleTimeZone 中的方法
将夏令时结束规则设置为某个月份给定日期之前或之后的星期几，例如，8 号或之后的第一个星期一。
setEntityResolver(EntityResolver) - 类 javax.xml.parsers.DocumentBuilder 中的方法
指定使用 EntityResolver 解析要解析的 XML 文档中存在的实体。
setEntityResolver(EntityResolver) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
设置实体解析器。
setEntityResolver(EntityResolver) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置实体解析器。
setEntityResolver(EntityResolver) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
注册实体解析器。
setEntityResolver(EntityResolver) - 接口 org.xml.sax.Parser 中的方法
已过时。 允许应用程序注册自定义的实体解析器。
setEntityResolver(EntityResolver) - 接口 org.xml.sax.XMLReader 中的方法
允许应用程序注册实体解析器。
setEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter) - 类 java.security.KeyStore 中的方法
用指定别名保存 keystore Entry。
setEnvironment(Hashtable<?, ?>) - 异常 javax.naming.CannotProceedException 中的方法
设置调用 getEnvironment() 时将返回的环境。
setEras(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置年代字符串。
setErr(PrintStream) - 类 java.lang.System 中的静态方法
重新分配“标准”错误输出流。
setError() - 类 java.io.PrintStream 中的方法
将该流的错误状态设置为 true。
setError() - 类 java.io.PrintWriter 中的方法
指示已发生错误。
setErrorHandler(ErrorHandler) - 类 javax.xml.parsers.DocumentBuilder 中的方法
指定解析器要使用的 ErrorHandler。
setErrorHandler(ErrorHandler) - 类 javax.xml.validation.SchemaFactory 中的方法
设置 ErrorHandler 以接收在 newSchema 方法调用期间遇到的错误。
setErrorHandler(ErrorHandler) - 类 javax.xml.validation.Validator 中的方法
设置 ErrorHandler 以接收在 validate 方法调用期间遇到的错误。
setErrorHandler(ErrorHandler) - 类 javax.xml.validation.ValidatorHandler 中的方法
设置 ErrorHandler 以接收验证期间遇到的错误。
setErrorHandler(ErrorHandler) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
设置错误处理程序。
setErrorHandler(ErrorHandler) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置错误事件处理程序。
setErrorHandler(ErrorHandler) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
注册错误事件处理程序。
setErrorHandler(ErrorHandler) - 接口 org.xml.sax.Parser 中的方法
已过时。 允许应用程序注册错误事件处理程序。
setErrorHandler(ErrorHandler) - 接口 org.xml.sax.XMLReader 中的方法
允许应用程序注册错误事件处理程序。
setErrorIndex(int) - 类 java.text.ParsePosition 中的方法
设置解析出错时的索引。
setErrorListener(ErrorListener) - 类 javax.xml.transform.Transformer 中的方法
设置转换的实际错误事件侦听器。
setErrorListener(ErrorListener) - 类 javax.xml.transform.TransformerFactory 中的方法
设置此 TransformerFactory 的错误事件侦听器，它将用于转换指令的处理，而不用于转换本身。
setErrorManager(ErrorManager) - 类 java.util.logging.Handler 中的方法
为该 Handler 定义一个 ErrorManager。
setErrorWriter(Writer) - 接口 javax.script.ScriptContext 中的方法
设置用来显示错误输出的 Writer。
setErrorWriter(Writer) - 类 javax.script.SimpleScriptContext 中的方法
设置用来显示错误输出的 Writer。
setEscapeProcessing(boolean) - 接口 java.sql.Statement 中的方法
将转义处理设置为开或关。
setEscapeProcessing(boolean) - 类 javax.sql.rowset.BaseRowSet 中的方法
设置为给定的 boolean 值，指示将 SQL 语句发送到数据库之前，驱动程序是否扫描转义语法并进行转义替换。
setEscapeProcessing(boolean) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的转义处理设置为开或关。
setEstimatedMajorSpan(boolean) - 类 javax.swing.text.AsyncBoxView 中的方法
设置 estimatedMajorSpan 属性，它确定是否应该将主跨距视为估计值。
setEventAllocator(XMLEventAllocator) - 类 javax.xml.stream.XMLInputFactory 中的方法
为事件设置一个用户定义的事件分配器。
setEventHandler(ValidationEventHandler) - 类 javax.xml.bind.Binder 中的方法
允许应用程序注册 ValidationEventHandler。
setEventHandler(ValidationEventHandler) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setEventHandler(ValidationEventHandler) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
允许应用程序注册一个验证事件处理程序。
setEventHandler(ValidationEventHandler) - 接口 javax.xml.bind.Marshaller 中的方法
允许应用程序注册一个验证事件处理程序。
setEventHandler(ValidationEventHandler) - 接口 javax.xml.bind.Unmarshaller 中的方法
允许应用程序注册 ValidationEventHandler。
setEventHandler(ValidationEventHandler) - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
setException(Throwable) - 类 java.util.concurrent.FutureTask 中的方法
除非已经设置了此 Future 或已将其取消，否则它将报告一个 ExecutionException，并将给定的 throwable 作为其原因。
setExceptionListener(ExceptionListener) - 类 java.beans.Encoder 中的方法
将此流的异常处理程序设置为 exceptionListener。
setExceptionListener(ExceptionListener) - 类 java.beans.XMLDecoder 中的方法
将此流的异常处理程序设置为 exceptionListener。
setExclusiveOwnerThread(Thread) - 类 java.util.concurrent.locks.AbstractOwnableSynchronizer 中的方法
设置当前拥有独占访问的线程。
setExecutable(boolean, boolean) - 类 java.io.File 中的方法
设置此抽象路径名的所有者或所有用户的执行权限。
setExecutable(boolean) - 类 java.io.File 中的方法
设置此抽象路径名所有者执行权限的一个便捷方法。
setExecuteExistingDelayedTasksAfterShutdownPolicy(boolean) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
设置有关在此执行程序已 shutdown 的情况下是否继续执行现有延迟任务的策略。
setExecutor(Executor) - 类 javax.xml.ws.Endpoint 中的方法
设置此 Endpoint 实例的执行程序。
setExecutor(Executor) - 类 javax.xml.ws.Service 中的方法
设置此 Service 实例的执行程序。
setExecutor(Executor) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
设置此 Service 实例的执行程序。
setExpandedIcon(Icon) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
setExpandedState(TreePath, boolean) - 类 javax.swing.JTree 中的方法
设置此 JTree 的展开状态。
setExpandedState(TreePath, boolean) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
将路径 path 的已扩展状态标记为 isExpanded。
setExpandedState(TreePath, boolean) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
将路径 path 的扩展状态标记为 isExpanded。
setExpandedState(TreePath, boolean) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
将路径 path 的扩展状态标记为 isExpanded。
setExpandEntityReferences(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此代码生成的解析器将扩展实体引用节点。
setExpandsSelectedPaths(boolean) - 类 javax.swing.JTree 中的方法
配置 expandsSelectedPaths 属性。
setExpert(boolean) - 类 java.beans.FeatureDescriptor 中的方法
"expert" 标志用于区分打算供高级用户使用的特性和那些打算供普通用户使用的特性。
setExplicitPolicyRequired(boolean) - 类 java.security.cert.PKIXParameters 中的方法
设置 ExplicitPolicyRequired 标志。
setExponentSeparator(String) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于分隔尾数和指数的字符串。
setExtendedKeyUsage(Set<String>) - 类 java.security.cert.X509CertSelector 中的方法
设置 extendedKeyUsage 标准。
setExtendedState(int) - 类 java.awt.Frame 中的方法
设置此窗体的状态。
setExtent(int) - 接口 javax.swing.BoundedRangeModel 中的方法
设置模型的 extent。
setExtent(int) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
在确保 n 大于或等于零，且落在以下模型约束范围内之后，将 extent 设置为 n：
setExtent(int) - 类 javax.swing.JSlider 中的方法
设置滑块所“覆盖”的范围的大小。
setExtentSize(Dimension) - 类 javax.swing.JViewport 中的方法
使用视图坐标设置该视图可见部分的大小。
setExtra(byte[]) - 类 java.util.zip.ZipEntry 中的方法
为条目设置可选的额外字段数据。
setFailureHandler(RMIFailureHandler) - 类 java.rmi.server.RMISocketFactory 中的静态方法
如果服务器套接字创建失败，则设置将由 RMI 运行时调用的 failure 处理程序。
setFaultActor(String) - 接口 javax.xml.soap.SOAPFault 中的方法
使用给定的错误参与者 (actor) 设置此 SOAPFault 对象。
setFaultCode(Name) - 接口 javax.xml.soap.SOAPFault 中的方法
使用给定的错误代码设置此 SOAPFault 对象。
setFaultCode(QName) - 接口 javax.xml.soap.SOAPFault 中的方法
使用给定的错误代码设置此 SOAPFault 对象。
setFaultCode(String) - 接口 javax.xml.soap.SOAPFault 中的方法
使用给定的错误代码设置此 SOAPFault 对象。
setFaultNode(String) - 接口 javax.xml.soap.SOAPFault 中的方法
创建或替换此 SOAPFault 对象的任何现有 Node 元素。
setFaultRole(String) - 接口 javax.xml.soap.SOAPFault 中的方法
创建或替换此 SOAPFault 对象的任何现有 Role 元素。
setFaultString(String) - 接口 javax.xml.soap.SOAPFault 中的方法
将此 SOAPFault 对象的错误字符串设定为给定字符串。
setFaultString(String, Locale) - 接口 javax.xml.soap.SOAPFault 中的方法
将此 SOAPFault 对象的错误字符串设定为给定字符串，并本地化为给定语言环境。
setFeature(String, boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
设置由此工厂创建的此 DocumentBuilderFactory 和 DocumentBuilder 的功能。
setFeature(String, boolean) - 类 javax.xml.parsers.SAXParserFactory 中的方法
在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。
setFeature(String, boolean) - 类 javax.xml.transform.TransformerFactory 中的方法
设置通过此工厂创建的此 TransformerFactory 和 Transformer 或 Template 的功能。
setFeature(String, boolean) - 类 javax.xml.validation.SchemaFactory 中的方法
设置此 SchemaFactory 的特性，Schema 由此工厂创建，更进一步说，Validator 和 ValidatorHandler 由这些 Schema 创建。
setFeature(String, boolean) - 类 javax.xml.validation.Validator 中的方法
设置功能标志的值。
setFeature(String, boolean) - 类 javax.xml.validation.ValidatorHandler 中的方法
设置此 ValidatorHandler 的特性。
setFeature(String, boolean) - 类 javax.xml.xpath.XPathFactory 中的方法
设置此工厂所创建的此 XPathFactory 和 XPath 的功能。
setFeature(String, boolean) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
为解析器设置功能标志。
setFeature(String, boolean) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置功能的值。
setFeature(String, boolean) - 接口 org.xml.sax.XMLReader 中的方法
设置功能标志的值。
setFetchDirection(int) - 接口 java.sql.ResultSet 中的方法
设置此 ResultSet 对象中行的处理方向。
setFetchDirection(int) - 接口 java.sql.Statement 中的方法
向驱动程序提供关于方向的提示，在使用此 Statement 对象创建的 ResultSet 对象中将按该方向处理行。
setFetchDirection(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
为驱动程序提供一个性能提示，该提示指示处理此 RowSet 对象中各行时使用的方向。
setFetchSize(int) - 接口 java.sql.ResultSet 中的方法
为 JDBC 驱动程序设置此 ResultSet 对象需要更多行时应该从数据库获取的行数。
setFetchSize(int) - 接口 java.sql.Statement 中的方法
为 JDBC 驱动程序提供一个提示，它提示此 Statement 生成的 ResultSet 对象需要更多行时应该从数据库获取的行数。
setFetchSize(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的获取大小设置为给定的行数。
setField(String, Object) - 接口 javax.management.Descriptor 中的方法
设置特定字段名的值。
setField(String, Object) - 类 javax.management.ImmutableDescriptor 中的方法
因为此类不可变，所以不支持此操作。
setField(String, Object) - 类 javax.management.modelmbean.DescriptorSupport 中的方法
setFields(String[], Object[]) - 接口 javax.management.Descriptor 中的方法
将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。
setFields(String[], Object[]) - 类 javax.management.ImmutableDescriptor 中的方法
因为此类不可变，所以不支持此操作。
setFields(String[], Object[]) - 类 javax.management.modelmbean.DescriptorSupport 中的方法
setFile(String) - 类 java.awt.FileDialog 中的方法
将此文件对话框窗口的选定文件设置为指定文件。
setFileFilter(FileFilter) - 类 javax.swing.JFileChooser 中的方法
设置当前文件过滤器。
setFileHidingEnabled(boolean) - 类 javax.swing.JFileChooser 中的方法
设置是否实现文件隐藏。
setFileName(String) - 类 java.awt.JobAttributes 中的方法
指定使用这些属性的作业的输出文件的文件名。
setFileName(String) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
setFileName(String) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
setFilenameFilter(FilenameFilter) - 类 java.awt.FileDialog 中的方法
将此文件对话框窗口的文件名过滤器设置为指定的过滤器。
setFileNameMap(FileNameMap) - 类 java.net.URLConnection 中的静态方法
设置 FileNameMap。
setFileSelectionMode(int) - 类 javax.swing.JFileChooser 中的方法
设置 JFileChooser，以允许用户只选择文件、只选择目录，或者可选择文件和目录。
setFileSystemView(FileSystemView) - 类 javax.swing.JFileChooser 中的方法
设置为访问和创建文件系统资源（如查找软驱和获得根驱动器列表），JFileChooser 所使用的文件系统视图。
setFileTypeMap(FileTypeMap) - 类 javax.activation.FileDataSource 中的方法
设置用于此 FileDataSource 的 FileTypeMap。
setFileView(FileView) - 类 javax.swing.JFileChooser 中的方法
设置用于检索 UI 信息的文件视图，如表示文件的图标或文件的类型描述。
setFillsViewportHeight(boolean) - 类 javax.swing.JTable 中的方法
设置此表是否始终大到足以填充封闭视口的高度。
setFilter(Filter) - 类 java.util.logging.Handler 中的方法
设置 Filter，以控制该 Handler 的输出。
setFilter(Filter) - 类 java.util.logging.Logger 中的方法
设置过滤器以控制此 Logger 的输出。
setFilter(Predicate) - 接口 javax.sql.rowset.FilteredRowSet 中的方法
将给定的 Predicate 对象应用到此 FilteredRowSet 对象。
setFilter(LSParserFilter) - 接口 org.w3c.dom.ls.LSParser 中的方法
当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。
setFilter(LSSerializerFilter) - 接口 org.w3c.dom.ls.LSSerializer 中的方法
当应用程序提供过滤器时，在序列化每个节点前串行器将先调出过滤器。
setFirstDayOfWeek(int) - 类 java.util.Calendar 中的方法
设置一星期的第一天是哪一天；例如，在美国，这一天是 SUNDAY，而在法国，这一天是 MONDAY。
setFirstLineIndent(float) - 类 javax.swing.text.ParagraphView 中的方法
设置第一行的行缩进量。
setFirstLineIndent(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置首行缩进。
setFixedCellHeight(int) - 类 javax.swing.JList 中的方法
设置一个固定值，将用于列表中每个单元的高度。
setFixedCellWidth(int) - 类 javax.swing.JList 中的方法
设置一个固定值，将用于列表中每个单元的宽度。
setFixedLengthStreamingMode(int) - 类 java.net.HttpURLConnection 中的方法
此方法用于在预先已知内容长度时启用没有进行内部缓冲的 HTTP 请求正文的流。
setFlashColor(Color) - 类 javax.swing.DebugGraphics 中的静态方法
设置用于 flash 绘制操作的 Color。
setFlashCount(int) - 类 javax.swing.DebugGraphics 中的静态方法
设置绘制操作将要 flash 的次数。
setFlashTime(int) - 类 javax.swing.DebugGraphics 中的静态方法
设置绘制操作 flash 的时间延迟。
setFlavorMap(FlavorMap) - 类 java.awt.dnd.DropTarget 中的方法
设置 FlavorMap 与此 DropTarget 关联。
setFlavorsForNative(String, DataFlavor[]) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
放弃指定 String native 的当前映射，而创建指定 DataFlavor 的新映射。
setFloat(Object, int, float) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 float 值。
setFloat(Object, float) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 float 值。
setFloat(String, float) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java float 值。
setFloat(int, float) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java REAL 值。
setFloat(int, float) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 float 值。
setFloat(String, float) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java float 值。
setFloat(int, float) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java float 值。
setFloat(String, float) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java float 值。
setFloatable(boolean) - 类 javax.swing.JToolBar 中的方法
设置 floatable 属性，如果要移动工具栏，此属性必须设置为 true。
setFloating(boolean, Point) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
setFloatingColor(Color) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
设置在浮动区域上时显示的颜色。
setFloatingLocation(int, int) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
setFocusable(boolean) - 类 java.awt.Component 中的方法
将此 Component 的焦点状态设置为指定值。
setFocusableWindowState(boolean) - 类 java.awt.Window 中的方法
设置如果此窗口满足 isFocusableWindow 中列出的其他要求，其是否可以成为焦点窗口。
setFocusAccelerator(char) - 类 javax.swing.text.JTextComponent 中的方法
设置将导致接收的文本组件获取焦点的加速键。
setFocusCycleRoot(boolean) - 类 java.awt.Container 中的方法
设置此 Container 是否是某个焦点遍历循环的根。
setFocusCycleRoot(boolean) - 类 java.awt.Window 中的方法
不执行任何操作，因为窗口必须始终是焦点遍历循环的根。
setFocusCycleRoot(boolean) - 类 javax.swing.JInternalFrame 中的方法
不执行任何操作，原因是 JInternalFrame 必须始终为焦点遍历循环的根。
setFocusLostBehavior(int) - 类 javax.swing.JFormattedTextField 中的方法
设置丢失焦点时的行为。
setFocusPainted(boolean) - 类 javax.swing.AbstractButton 中的方法
设置 paintFocus 属性，对于要绘制的焦点状态，该属性必须为 true。
setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - 类 java.awt.Component 中的方法
为此 Component 的给定遍历操作设置焦点遍历键。
setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - 类 java.awt.Container 中的方法
为此 Container 的给定遍历操作设置焦点遍历键。
setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - 类 javax.swing.JComponent 中的方法
设置针对此 Component 的给定遍历操作的焦点遍历键。
setFocusTraversalKeysEnabled(boolean) - 类 java.awt.Component 中的方法
设置是否为此 Component 启用焦点遍历键。
setFocusTraversalPolicy(FocusTraversalPolicy) - 类 java.awt.Container 中的方法
如果此 Container 是一个焦点循环根，则设置将管理此 Container 的子代的键盘遍历的焦点遍历策略。
setFocusTraversalPolicyProvider(boolean) - 类 java.awt.Container 中的方法
设置是否将用此容器提供焦点遍历策略。
setFollowRedirects(boolean) - 类 java.net.HttpURLConnection 中的静态方法
设置此类是否应该自动执行 HTTP 重定向（响应代码为 3xx 的请求）。
setFont(Font) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的 Font。
setFont(Font) - 类 java.awt.Component 中的方法
设置组件的字体。
setFont(Font) - 类 java.awt.Container 中的方法
设置此容器的字体。
setFont(Font) - 类 java.awt.Graphics 中的方法
将此图形上下文的字体设置为指定字体。
setFont(Font) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置此对象的 Font。
setFont(Font) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置此对象的 Font。
setFont(Font) - 类 java.awt.MenuComponent 中的方法
将用于此菜单组件的字体设置为指定字体。
setFont(Font) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置此对象的 Font。
setFont(Font) - 类 javax.swing.DebugGraphics 中的方法
设置用于文本绘制操作的 Font。
setFont(Font) - 类 javax.swing.JComponent 中的方法
设置此组件的字体。
setFont(Font) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setFont(Font) - 类 javax.swing.JSlider 中的方法
设置此组件的字体。
setFont(Font) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置此对象的 Font。
setFont(Font) - 类 javax.swing.JTextArea 中的方法
设置当前字体。
setFont(Font) - 类 javax.swing.JTextField 中的方法
设置当前字体。
setFont(Font) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setFont(Font) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setFont(Font) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
设置编辑使用的字体。
setFont(Font) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
创建子类，以便将 FontUIResource 映射为 null。
setFontFamily(MutableAttributeSet, String) - 类 javax.swing.text.StyleConstants 中的静态方法
设置字体属性。
setFontSize(MutableAttributeSet, int) - 类 javax.swing.text.StyleConstants 中的静态方法
设置字体大小属性。
setForeground(Color) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的前景色。
setForeground(Color) - 类 java.awt.Component 中的方法
设置组件的前景色。
setForeground(Color) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置此对象的前景颜色。
setForeground(Color) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置此对象的前景色。
setForeground(Color) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置此对象的前景色。
setForeground(Color) - 类 javax.swing.JComponent 中的方法
设置此组件的前景色。
setForeground(Color) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setForeground(Color) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置此对象的前景色。
setForeground(Color) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setForeground(Color) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
重写 JComponent.setForeground 将未选定单元格的前景色分配为指定颜色。
setForeground(Color) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setForeground(MutableAttributeSet, Color) - 类 javax.swing.text.StyleConstants 中的静态方法
设置前景色。
setForegroundAt(int, Color) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的前景色设置为 foreground，它可以为 null，在这种情况下选项卡的前景色默认为此 tabbedpane 的前景色。
setFormat(int, Format) - 类 java.text.MessageFormat 中的方法
使用在以前设置的模式字符串中给定的格式元素索引来设置格式元素使用的格式。
setFormat(DateFormat) - 类 javax.swing.text.DateFormatter 中的方法
设置用于指示可编辑和显示的合法值的格式。
setFormat(Format) - 类 javax.swing.text.InternationalFormatter 中的方法
设置指示可以编辑和显示的合法值的格式。
setFormat(Format) - 类 javax.swing.text.NumberFormatter 中的方法
设置指示可以编辑和显示的合法值的格式。
setFormatByArgumentIndex(int, Format) - 类 java.text.MessageFormat 中的方法
设置用于以前所设置的模式字符串中格式元素的格式，其中以前的模式字符串是用给定的参数索引设置的。
setFormats(Format[]) - 类 java.text.MessageFormat 中的方法
设置用于以前所设置的模式字符串中格式元素的格式。
setFormatsByArgumentIndex(Format[]) - 类 java.text.MessageFormat 中的方法
设置传递给 format 方法或从 parse 方法返回的值使用的格式。
setFormattedOutput(boolean) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
设置格式化输出标志的便捷方法。
setFormatter(Formatter) - 类 java.util.logging.Handler 中的方法
设置 Formatter。
setFormatter(JFormattedTextField.AbstractFormatter) - 类 javax.swing.JFormattedTextField 中的方法
设置当前的 AbstractFormatter。
setFormatterFactory(JFormattedTextField.AbstractFormatterFactory) - 类 javax.swing.JFormattedTextField 中的方法
设置 AbstractFormatterFactory。
setFractionalSecond(BigDecimal) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置小数秒。
setFragment(boolean) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
设置片段标志的便捷方法。
setFrame(double, double, double, double) - 类 java.awt.geom.Arc2D 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
setFrame(double, double, double, double) - 类 java.awt.geom.Ellipse2D.Double 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
setFrame(float, float, float, float) - 类 java.awt.geom.Ellipse2D.Float 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定矩形值。
setFrame(double, double, double, double) - 类 java.awt.geom.Ellipse2D.Float 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
setFrame(double, double, double, double) - 类 java.awt.geom.Rectangle2D 中的方法
将此 Rectangle2D 外部边界的位置和大小设置为指定矩形值。
setFrame(double, double, double, double) - 类 java.awt.geom.RectangularShape 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
setFrame(Point2D, Dimension2D) - 类 java.awt.geom.RectangularShape 中的方法
将此 Shape 窗体矩形的位置和大小分别设置为指定的 Point2D 和 Dimension2D。
setFrame(Rectangle2D) - 类 java.awt.geom.RectangularShape 中的方法
将此 Shape 窗体矩形设置为指定的 Rectangle2D。
setFrame(double, double, double, double) - 类 java.awt.geom.RoundRectangle2D 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
setFrameFromCenter(double, double, double, double) - 类 java.awt.geom.RectangularShape 中的方法
基于指定的中心点坐标和角点坐标设置此 Shape 的窗体矩形。
setFrameFromCenter(Point2D, Point2D) - 类 java.awt.geom.RectangularShape 中的方法
基于指定的中心 Point2D 和角 Point2D 设置此 Shape 的窗体矩形。
setFrameFromDiagonal(double, double, double, double) - 类 java.awt.geom.RectangularShape 中的方法
基于两个指定的坐标设置此 Shape 窗体矩形的对角线。
setFrameFromDiagonal(Point2D, Point2D) - 类 java.awt.geom.RectangularShape 中的方法
基于两个指定的 Point2D 对象设置此 Shape 窗体矩形的对角线。
setFrameIcon(Icon) - 类 javax.swing.JInternalFrame 中的方法
设置要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。
setFramePosition(int) - 接口 javax.sound.sampled.Clip 中的方法
设置介质位置（以示例帧为单位）。
setFreeStanding(boolean) - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法
setFromPage(int) - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的第一页。
setFromTree(String, Node) - 类 javax.imageio.metadata.IIOMetadata 中的方法
根据 XML DOM Node 的树（其语法由给定元数据格式定义）设置此 IIOMetadata 对象的内部状态。
setFullBufferUpdates(boolean) - 类 java.awt.image.MemoryImageSource 中的方法
指定在像素缓冲区发生变化时，是否总是通过发送像素的完整缓冲区来更新此动画内存图像。
setFullScreenWindow(Window) - 类 java.awt.GraphicsDevice 中的方法
进入全屏模式，或返回窗口化模式。
setGlassPane(Component) - 类 javax.swing.JApplet 中的方法
设置 glassPane 属性。
setGlassPane(Component) - 类 javax.swing.JDialog 中的方法
设置 glassPane 属性。
setGlassPane(Component) - 类 javax.swing.JFrame 中的方法
设置 glassPane 属性。
setGlassPane(Component) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 glassPane 属性。
setGlassPane(Component) - 类 javax.swing.JRootPane 中的方法
将指定的 Component 设置为此根窗格的玻璃窗格。
setGlassPane(Component) - 类 javax.swing.JWindow 中的方法
设置 glassPane 属性。
setGlassPane(Component) - 接口 javax.swing.RootPaneContainer 中的方法
glassPane 始终为 rootPane 的第一个子组件，rootPanes 布局管理器确保它始终与 rootPane 一样大。
setGlobalActiveWindow(Window) - 类 java.awt.KeyboardFocusManager 中的方法
设置活动 Window。
setGlobalCurrentFocusCycleRoot(Container) - 类 java.awt.KeyboardFocusManager 中的方法
设置当前焦点循环根。
setGlobalFocusedWindow(Window) - 类 java.awt.KeyboardFocusManager 中的方法
设置聚焦 Window。
setGlobalFocusOwner(Component) - 类 java.awt.KeyboardFocusManager 中的方法
设置焦点所有者。
setGlobalPermanentFocusOwner(Component) - 类 java.awt.KeyboardFocusManager 中的方法
设置持久焦点所有者。
setGlyphPainter(GlyphView.GlyphPainter) - 类 javax.swing.text.GlyphView 中的方法
设置用于呈现字形的 painter。
setGlyphPosition(int, Point2D) - 类 java.awt.font.GlyphVector 中的方法
设置此 GlyphVector 中的指定字形位置。
setGlyphTransform(int, AffineTransform) - 类 java.awt.font.GlyphVector 中的方法
设置此 GlyphVector 中指定字形的转换。
setGranularityPeriod(long) - 类 javax.management.monitor.Monitor 中的方法
设置粒度周期（以毫秒为单位）。
setGranularityPeriod(long) - 接口 javax.management.monitor.MonitorMBean 中的方法
设置粒度时段（以毫秒为单位）。
setGregorianChange(Date) - 类 java.util.GregorianCalendar 中的方法
设置 GregorianCalendar 的更改日期。
setGridColor(Color) - 类 javax.swing.JTable 中的方法
将用来绘制网格线的颜色设置为 gridColor 并重新显示它。
setGridLocation(int, int) - 类 javax.swing.text.TableView.TableCell 中的方法
已过时。 设置网格的位置。
setGroup(ButtonGroup) - 接口 javax.swing.ButtonModel 中的方法
标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。
setGroup(ButtonGroup) - 类 javax.swing.DefaultButtonModel 中的方法
标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。
setGroupingSeparator(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于千位分隔符的字符。
setGroupingSize(int) - 类 java.text.DecimalFormat 中的方法
设置分组大小。
setGroupingUsed(boolean) - 类 java.text.NumberFormat 中的方法
设置此格式中是否使用分组。
setGuiAvailable(boolean) - 类 java.beans.Beans 中的静态方法
用于指示是否正运行在可进行 GUI 交互的环境中。
setHandler(ContentHandler) - 类 javax.xml.transform.sax.SAXResult 中的方法
设置要作为 SAX2 ContentHandler 的目标。
setHandlerChain(List<Handler>) - 接口 javax.xml.ws.Binding 中的方法
设置协议绑定实例的处理程序链。
setHandlerResolver(HandlerResolver) - 类 javax.xml.ws.Service 中的方法
设置此 Service 实例的 HandlerResolver。
setHandlerResolver(HandlerResolver) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
为此 Service 实例设置 HandlerResolver。
setHashColor(Color) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
setHeader(String, String) - 类 javax.xml.soap.MimeHeaders 中的方法
将其名称与给定名称匹配的第一个头条目的当前值替换为给定值，如果现有的头名称都不匹配，则添加一个新的头。
setHeaderRenderer(TableCellRenderer) - 类 javax.swing.table.TableColumn 中的方法
将用于绘制 TableColumn 的标题的 TableCellRenderer 设置为 headerRenderer。
setHeaderValue(Object) - 类 javax.swing.table.TableColumn 中的方法
设置 Object，将使用其字符串表示形式作为 headerRenderer 的值。
setHeight(Spring) - 类 javax.swing.SpringLayout.Constraints 中的方法
设置 height 属性，该属性控制组件的高度。
setHelpMenu(Menu) - 类 java.awt.MenuBar 中的方法
将指定的菜单设置为此菜单栏的帮助菜单。
setHelpMenu(JMenu) - 类 javax.swing.JMenuBar 中的方法
设置用户选择菜单栏中的“帮助”选项时显示的帮助菜单。
setHgap(int) - 类 java.awt.BorderLayout 中的方法
设置组件之间的水平间距。
setHgap(int) - 类 java.awt.CardLayout 中的方法
设置组件之间的水平间距。
setHgap(int) - 类 java.awt.FlowLayout 中的方法
设置组件之间以及组件与 Container 的边之间的水平间隙。
setHgap(int) - 类 java.awt.GridLayout 中的方法
将组件之间的水平间距设置为指定值。
setHidden(boolean) - 类 java.beans.FeatureDescriptor 中的方法
"hidden" 标志用于标识只打算供工具使用、不应对人类开放的特性。
setHideActionText(boolean) - 类 javax.swing.AbstractButton 中的方法
设置 hideActionText 属性，该属性确定按钮是否显示 Action 的文本。
setHighlighter(Highlighter) - 类 javax.swing.text.JTextComponent 中的方法
设置要使用的 highlighter。
setHints(int) - 类 java.awt.image.AreaAveragingScaleFilter 中的方法
检测数据是否正使用必要的提示进行传送，从而允许平均算法执行其功能。
setHints(int) - 接口 java.awt.image.ImageConsumer 中的方法
设置 ImageConsumer 用于处理 ImageProducer 所传递像素的提示。
setHints(int) - 类 java.awt.image.ImageFilter 中的方法
过滤 ImageConsumer 接口的 setHints 方法中所提供的信息。
setHints(int) - 类 java.awt.image.PixelGrabber 中的方法
setHints 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setHoldability(int) - 接口 java.sql.Connection 中的方法
将使用此 Connection 对象创建的 ResultSet 对象的默认可保存性 (holdability) 更改为给定可保存性。
setHonorsVisibility(boolean) - 类 javax.swing.GroupLayout 中的方法
设置确定组件的大小和位置时是否要考虑组件的可见性。
setHonorsVisibility(Component, Boolean) - 类 javax.swing.GroupLayout 中的方法
设置确定组件的大小和位置时是否要考虑组件的可见性。
setHorizontalAlignment(int) - 类 javax.swing.AbstractButton 中的方法
设置图标和文本的水平对齐方式。
setHorizontalAlignment(int) - 类 javax.swing.JLabel 中的方法
设置标签内容沿 X 轴的对齐方式。
setHorizontalAlignment(int) - 类 javax.swing.JTextField 中的方法
设置文本的水平对齐方式。
setHorizontalGroup(GroupLayout.Group) - 类 javax.swing.GroupLayout 中的方法
设置沿水平轴确定组件位置和大小的 Group。
setHorizontalScrollBar(JScrollBar) - 类 javax.swing.JScrollPane 中的方法
将控制视口水平视图位置的水平滚动条添加到滚动窗格中。
setHorizontalScrollBarPolicy(int) - 类 javax.swing.JScrollPane 中的方法
确定水平滚动条何时显示在滚动窗格上。
setHorizontalScrollBarPolicy(int) - 类 javax.swing.ScrollPaneLayout 中的方法
设置水平滚动条显示策略。
setHorizontalTextPosition(int) - 类 javax.swing.AbstractButton 中的方法
设置文本相对于图标的水平位置。
setHorizontalTextPosition(int) - 类 javax.swing.JLabel 中的方法
设置标签的文本相对其图像的水平位置。
setHostnameVerifier(HostnameVerifier) - 类 javax.naming.ldap.StartTlsResponse 中的方法
设置在已完成 TLS 握手且默认主机名校验失败后供 negotiate() 使用的主机名校验器。
setHostnameVerifier(HostnameVerifier) - 类 javax.net.ssl.HttpsURLConnection 中的方法
设置此实例的 HostnameVerifier。
setHour(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置小时。
setHours(int) - 类 java.sql.Date 中的方法
已过时。
setHours(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.HOUR_OF_DAY, int hours) 取代。
setHumanPresentableName(String) - 类 java.awt.datatransfer.DataFlavor 中的方法
设置此 DataFlavor 表示的数据格式的得体的名称。
setHumanPresentableName(String) - 类 javax.activation.ActivationDataFlavor 中的方法
设置得体的名称。
setIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的默认图标。
setIcon(boolean) - 类 javax.swing.JInternalFrame 中的方法
如果外观支持图标化，则对此内部窗体执行图标化或取消图标化。
setIcon(Icon) - 类 javax.swing.JLabel 中的方法
定义此组件将要显示的图标。
setIcon(Icon) - 类 javax.swing.JOptionPane 中的方法
设置要显示的图标。
setIcon(MutableAttributeSet, Icon) - 类 javax.swing.text.StyleConstants 中的静态方法
设置图标属性。
setIconAt(int, Icon) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的图标设置为 icon，它可以为 null。
setIconifiable(boolean) - 类 javax.swing.JInternalFrame 中的方法
设置 iconable 属性，对于能够使 JInternalFrame 变成一个图标的用户而言，该属性必须为 true。
setIconImage(Image) - 类 java.awt.Frame 中的方法
设置要作为此窗口图标显示的图像。
setIconImage(Image) - 类 java.awt.Window 中的方法
设置要作为此窗口图标显示的图像。
setIconImage(Image) - 类 javax.swing.JFrame 中的方法
设置要作为此窗口图标显示的图像。
setIconImages(List<? extends Image>) - 类 java.awt.Window 中的方法
设置要作为此窗口的图标显示的图像序列。
setIconOnly(boolean) - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
setIconTextGap(int) - 类 javax.swing.AbstractButton 中的方法
如果图标和文本的属性都已设置，则此属性定义图标和文本之间的间隔。
setIconTextGap(int) - 类 javax.swing.JLabel 中的方法
如果同时设置了图标和文本属性，则此属性定义它们之间的间隔。
setID(String) - 类 java.util.TimeZone 中的方法
设置时区 ID。
setIdAttribute(String, boolean) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setIdAttribute(String, boolean) - 接口 org.w3c.dom.Element 中的方法
如果参数 isId 为 true，则此方法将指定的属性声明为用于确定用户的 ID 属性。
setIdAttributeNode(Attr, boolean) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setIdAttributeNode(Attr, boolean) - 接口 org.w3c.dom.Element 中的方法
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
setIdAttributeNS(String, String, boolean) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setIdAttributeNS(Element, String, String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
将名称空间 URI 和本地名称指定的元素属性注册为类型 ID。
setIdAttributeNS(String, String, boolean) - 接口 org.w3c.dom.Element 中的方法
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
setIdentifier(Object) - 类 javax.swing.table.TableColumn 中的方法
将 TableColumn 的标识符设置为 anIdentifier。
setIfModifiedSince(long) - 类 java.net.URLConnection 中的方法
将此 URLConnection 的 ifModifiedSince 字段的值设置为指定的值。
setIgnoreRepaint(boolean) - 类 java.awt.Component 中的方法
设置是否应该忽略从操作系统接受的绘制消息。
setIgnoringComments(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此代码生成的解析器将忽略注释。
setIgnoringElementContentWhitespace(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此工厂创建的解析器在解析 XML 文档时，必须删除元素内容中的空格（有时也可以称作“可忽略空格”，请参阅 XML Rec 2.10）。
setImage(Image) - 类 java.awt.TrayIcon 中的方法
设置此 TrayIcon 的图像。
setImage(Image) - 类 javax.swing.ImageIcon 中的方法
设置由此图标显示的图像。
setImageableArea(double, double, double, double) - 类 java.awt.print.Paper 中的方法
设置此 Paper 的可成像区域。
setImageAutoSize(boolean) - 类 java.awt.TrayIcon 中的方法
设置自动调整大小的属性。
setImageObserver(ImageObserver) - 类 javax.swing.ImageIcon 中的方法
设置图像的图像观察者。
setImageURL(URL) - 类 java.awt.SplashScreen 中的方法
更改闪现屏幕图像。
setImplementation(Object) - 类 javax.management.StandardMBean 中的方法
替换包装在此对象中的实现对象。
setImplicitDownCycleTraversal(boolean) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
设置此 ContainerOrderFocusTraversalPolicy 是否隐式将焦点传递给下一个循环。
setImplicitDownCycleTraversal(boolean) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
设置此 SortingFocusTraversalPolicy 是否隐式将焦点传输给下一个循环。
setIn(InputStream) - 类 java.lang.System 中的静态方法
重新分配“标准”输入流。
setInDefaultEventSet(boolean) - 类 java.beans.EventSetDescriptor 中的方法
将事件集标记为“默认”集合（或非默认集合）。
setIndentSpace(int) - 类 javax.swing.text.AbstractWriter 中的方法
允许子类指定缩进映射为多少空格。
setIndeterminate(boolean) - 类 javax.swing.JProgressBar 中的方法
设置进度条的 indeterminate 属性，该属性确定进度条处于确定模式中还是处于不确定模式中。
setIndex(int) - 接口 java.text.CharacterIterator 中的方法
将位置设置为文本中的指定位置，并返回该字符。
setIndex(int) - 类 java.text.ParsePosition 中的方法
设置当前解析位置。
setIndex(int) - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.setIndex()。
setIndex(int) - 类 javax.swing.text.Segment 中的方法
将位置设置为文本中的指定位置，并返回该字符。
setIndexedReadMethod(Method) - 类 java.beans.IndexedPropertyDescriptor 中的方法
设置应该用于读取索引属性值的方法。
setIndexedWriteMethod(Method) - 类 java.beans.IndexedPropertyDescriptor 中的方法
设置应该用于写入索引属性值的方法。
setInfinity(String) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于表示无穷大的字符串。
setInfo(String) - 类 java.security.Identity 中的方法
已过时。 为此 Identity 指定一个常规信息字符串。
setInheritsPopupMenu(boolean) - 类 javax.swing.JComponent 中的方法
设置如果此组件没有分配给它的 JPopupMenu，那么 getComponentPopupMenu 是否应该委托给其父组件。
setInitialContextFactoryBuilder(InitialContextFactoryBuilder) - 类 javax.naming.spi.NamingManager 中的静态方法
将 InitialContextFactory 生成器设置为生成器。
setInitialDelay(int) - 类 javax.swing.Timer 中的方法
设置 Timer 的初始延迟，即启动计时器后触发第一个事件之前要等待的时间（以毫秒为单位）。
setInitialDelay(int) - 类 javax.swing.ToolTipManager 中的方法
指定初始延迟值。
setInitialPolicies(Set<String>) - 类 java.security.cert.PKIXParameters 中的方法
设置初始策略标识符（OID 字符串）的 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。
setInitialSelectionValue(Object) - 类 javax.swing.JOptionPane 中的方法
设置（根据选择）最初向用户显示的输入值。
setInitialValue(Object) - 类 javax.swing.JOptionPane 中的方法
设置要启用的初始值，即最初显示窗格时处于焦点状态的 Component。
setInitThreshold(Number) - 类 javax.management.monitor.CounterMonitor 中的方法
设置所有观察对象的共同初始阈值。
setInitThreshold(Number) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
设置所有观察到的 MBeans 的公共初始阈值。
setInnerHTML(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
用指定为 HTML 字符串的内容替换给定元素的子元素。
setInput(byte[], int, int) - 类 java.util.zip.Deflater 中的方法
为压缩设置输入数据。
setInput(byte[]) - 类 java.util.zip.Deflater 中的方法
为压缩设置输入数据。
setInput(byte[], int, int) - 类 java.util.zip.Inflater 中的方法
为解压缩设置输入数据。
setInput(byte[]) - 类 java.util.zip.Inflater 中的方法
为解压缩设置输入数据。
setInput(Object, boolean, boolean) - 类 javax.imageio.ImageReader 中的方法
设置用于给定的 ImageInputStream 或其他 Object 的输入源。
setInput(Object, boolean) - 类 javax.imageio.ImageReader 中的方法
设置用于给定的 ImageInputStream 或其他 Object 的输入源。
setInput(Object) - 类 javax.imageio.ImageReader 中的方法
设置用于给定的 ImageInputStream 或其他 Object 的输入源。
setInputMap(int, InputMap) - 类 javax.swing.JComponent 中的方法
设置在 map 的 condition 条件下要使用的 InputMap。
setInputMethodContext(InputMethodContext) - 接口 java.awt.im.spi.InputMethod 中的方法
设置输入方法的上下文，这样可以将输入方法事件指派到客户端组件并能从客户端组件请求信息。
setInputSource(InputSource) - 类 javax.xml.transform.sax.SAXSource 中的方法
设置要用于 Source 的 SAX InputSource。
setInputStream(InputStream) - 类 javax.xml.transform.stream.StreamSource 中的方法
设置要用作输入的字节流。
setInputValue(Object) - 类 javax.swing.JOptionPane 中的方法
设置由用户选择或输入的输入值。
setInputVerifier(InputVerifier) - 类 javax.swing.JComponent 中的方法
设置此组件的输入校验器。
setInsets(short, short, short, short) - 类 javax.swing.text.CompositeView 中的方法
设置视图的 insets。
setInstalledLookAndFeels(UIManager.LookAndFeelInfo[]) - 类 javax.swing.UIManager 中的静态方法
设置可用外观的集合。
setInstance(LayoutStyle) - 类 javax.swing.LayoutStyle 中的静态方法
设置 LayoutStyle 的共享实例。
setInstanceFollowRedirects(boolean) - 类 java.net.HttpURLConnection 中的方法
设置此 HttpURLConnection 实例是否应该自动执行 HTTP 重定向（响应代码为 3xx 的请求）。
setInt(Object, int, int) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 int 值。
setInt(Object, int) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 int 值。
setInt(String, int) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java int 值。
setInt(int, int) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java int 值。
setInt(int, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的 int 值。
setInt(String, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java int 值。
setInt(int, int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java int 值。
setInt(String, int) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java int 值。
setIntercellSpacing(Dimension) - 类 javax.swing.JTable 中的方法
将 rowMargin 和 columnMargin（单元格之间间距的高度和宽度）设置为 intercellSpacing。
setInterface(InetAddress) - 类 java.net.MulticastSocket 中的方法
设置多播网络接口，供其行为将受网络接口值影响的方法使用。
setInternalFrame(JInternalFrame) - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
设置与此 DesktopIcon 关联的 JInternalFrame。
setInternationalCurrencySymbol(String) - 类 java.text.DecimalFormatSymbols 中的方法
设置这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。
setInvalidCharacters(String) - 类 javax.swing.text.MaskFormatter 中的方法
允许进一步限制可以输入的字符。
setInverted(boolean) - 类 javax.swing.JSlider 中的方法
指定为 true，则反转滑块显示的值范围，指定为 false 则将值范围置为正常顺序。
setInvoker(Component) - 类 javax.swing.JPopupMenu 中的方法
设置此弹出菜单的调用者，即弹出菜单在其中显示的组件。
setInvokesStopCellEditing(boolean) - 类 javax.swing.JTree 中的方法
通过选择树中的另一个节点、树的数据中的更改或通过其他方法来确定编辑被中断时发生了什么情况。
setIssuer(X500Principal) - 类 java.security.cert.X509CertSelector 中的方法
设置 issuer 标准。
setIssuer(String) - 类 java.security.cert.X509CertSelector 中的方法
已过时，使用 X509CertSelector.setIssuer(X500Principal) 或 X509CertSelector.setIssuer(byte[]) 替代。
setIssuer(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 issuer 标准。
setIssuerNames(Collection<?>) - 类 java.security.cert.X509CRLSelector 中的方法
注意：请使用 X509CRLSelector.setIssuers(Collection) 方法，或者使用此方法时仅指定 byte 数组形式的标识名。
setIssuers(Collection<X500Principal>) - 类 java.security.cert.X509CRLSelector 中的方法
设置 issuerNames 标准。
setItalic(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置斜体属性。
setItem(Object) - 接口 javax.swing.ComboBoxEditor 中的方法
设置应该编辑的项。
setItem(Object) - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
设置应该编辑的项。
setJMenuBar(JMenuBar) - 类 javax.swing.JApplet 中的方法
设置此 applet 的菜单栏。
setJMenuBar(JMenuBar) - 类 javax.swing.JDialog 中的方法
设置此对话框的菜单栏。
setJMenuBar(JMenuBar) - 类 javax.swing.JFrame 中的方法
设置此窗体的菜单栏。
setJMenuBar(JMenuBar) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 menuBar 属性。
setJMenuBar(JMenuBar) - 类 javax.swing.JRootPane 中的方法
添加或更改在分层窗格中使用的菜单栏。
setJNDIContext(Context) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
设置初始 JNDI 上下文，通过该上下文可以从 JNDI 名称空间获取 SyncProvider 实现
setJobName(String) - 类 java.awt.print.PrinterJob 中的方法
设置要打印的文档名称。
setJoinType(int) - 接口 javax.sql.rowset.JoinRowSet 中的方法
允许应用程序调整在 JoinRowSet 对象实例包含的表上强制应用的 JOIN 类型。
setJustification(int) - 类 javax.swing.text.ParagraphView 中的方法
设置对齐方式的类型。
setKeepAlive(boolean) - 类 java.net.Socket 中的方法
启用/禁用 SO_KEEPALIVE。
setKeepAliveTime(long, TimeUnit) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
设置线程在终止前可以保持空闲的时间限制。
setKeyBindingActive(boolean) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setKeyBindingRegistered(boolean) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setKeyChar(char) - 类 java.awt.event.KeyEvent 中的方法
设置 keyCode 值，以表示某个逻辑字符。
setKeyCode(int) - 类 java.awt.event.KeyEvent 中的方法
设置 keyCode 值，以表示某个物理键。
setKeyColumns(int[]) - 接口 javax.sql.rowset.CachedRowSet 中的方法
使用给定的列号数组设置此 CachedRowSet 对象的 keyCols 字段，它形成了唯一标识此 CachedRowSet 对象中某个行的键。
setKeyEntry(String, Key, char[], Certificate[]) - 类 java.security.KeyStore 中的方法
将给定的密钥分配给给定的别名，并用给定密码保护它。
setKeyEntry(String, byte[], Certificate[]) - 类 java.security.KeyStore 中的方法
将给定密钥（已经被保护）分配给给定别名。
setKeymap(Keymap) - 类 javax.swing.text.JTextComponent 中的方法
设置用于将事件绑定到操作的 keymap。
setKeyPair(KeyPair) - 类 java.security.Signer 中的方法
已过时。 为此签署人设置密钥对（公钥和私钥）。
setKeySelectionManager(JComboBox.KeySelectionManager) - 类 javax.swing.JComboBox 中的方法
设置将键盘字符转换为列表选择的对象。
setKeySelector(KeySelector) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
setKeySelector(KeySelector) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
设置用于查找某个密钥的密钥选择器。
setKeyUsage(boolean[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 keyUsage 标准。
setLabel(String) - 类 java.awt.Button 中的方法
将按钮的标签设置为指定的字符串。
setLabel(String) - 类 java.awt.Checkbox 中的方法
将此复选框的标签设置为字符串参数。
setLabel(String) - 类 java.awt.MenuItem 中的方法
将此菜单项的标签设置为指定标签。
setLabel(String) - 类 javax.swing.AbstractButton 中的方法
已过时。 - 由 setText(text) 取代
setLabel(String) - 类 javax.swing.JPopupMenu 中的方法
设置弹出菜单的标签。
setLabel(String) - 类 javax.swing.text.html.Option 中的方法
设置该选项使用的标签。
setLabelFor(Component) - 类 javax.swing.JLabel 中的方法
设置要添加标签的组件。
setLabelTable(Dictionary) - 类 javax.swing.JSlider 中的方法
用于指定将在给定值处绘制哪个标签。
setLargeModel(boolean) - 类 javax.swing.JTree 中的方法
指定 UI 是否使用大模型。
setLargeModel(boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果必要，则更新 componentListener。
setLastDividerLocation(int) - 类 javax.swing.JSplitPane 中的方法
将分隔条所处的最后位置设置为 newLastLocation。
setLastDragLocation(int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
设置 JSplitPane 的最后拖动位置。
setLastModified(long) - 类 java.io.File 中的方法
设置此抽象路径名指定的文件或目录的最后一次修改时间。
setLayer(Integer) - 类 javax.swing.JInternalFrame 中的方法
设置此组件 layer 属性的便捷方法。
setLayer(int) - 类 javax.swing.JInternalFrame 中的方法
设置此组件 layer 属性的便捷方法。
setLayer(Component, int) - 类 javax.swing.JLayeredPane 中的方法
设置指定组件的 layer 属性，使之成为该层中最底部的组件。
setLayer(Component, int, int) - 类 javax.swing.JLayeredPane 中的方法
为指定组件设置 layer 属性，并设置它在该层中的位置。
setLayeredPane(JLayeredPane) - 类 javax.swing.JApplet 中的方法
设置 layeredPane 属性。
setLayeredPane(JLayeredPane) - 类 javax.swing.JDialog 中的方法
设置 layeredPane 属性。
setLayeredPane(JLayeredPane) - 类 javax.swing.JFrame 中的方法
设置 layeredPane 属性。
setLayeredPane(JLayeredPane) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 layeredPane 属性。
setLayeredPane(JLayeredPane) - 类 javax.swing.JRootPane 中的方法
设置供根窗格使用的分层窗格。
setLayeredPane(JLayeredPane) - 类 javax.swing.JWindow 中的方法
设置 layeredPane 属性。
setLayeredPane(JLayeredPane) - 接口 javax.swing.RootPaneContainer 中的方法
管理 contentPane 的 Container，在某些情况下为菜单栏。
setLayout(LayoutManager) - 类 java.awt.Container 中的方法
设置此容器的布局管理器。
setLayout(LayoutManager) - 类 java.awt.ScrollPane 中的方法
设置此容器的布局管理器。
setLayout(LayoutManager) - 类 javax.swing.AbstractButton 中的方法
为此容器设置布局管理器，有关此方法的完整描述，请参阅 Container.setLayout(LayoutManager)。
setLayout(LayoutManager) - 类 javax.swing.Box 中的方法
抛出一个 AWTError，因为 Box 只能使用 BoxLayout。
setLayout(LayoutManager) - 类 javax.swing.JApplet 中的方法
设置 LayoutManager。
setLayout(LayoutManager) - 类 javax.swing.JDialog 中的方法
设置 LayoutManager。
setLayout(LayoutManager) - 类 javax.swing.JFrame 中的方法
设置 LayoutManager。
setLayout(LayoutManager) - 类 javax.swing.JInternalFrame 中的方法
确保默认情况下无法设置此组件的布局。
setLayout(LayoutManager) - 类 javax.swing.JScrollPane 中的方法
设置此 JScrollPane 的布局管理器。
setLayout(LayoutManager) - 类 javax.swing.JToolBar 中的方法
setLayout(LayoutManager) - 类 javax.swing.JWindow 中的方法
设置 LayoutManager。
setLayoutOrientation(int) - 类 javax.swing.JList 中的方法
定义布置列表单元的方式。
setLayoutStyle(LayoutStyle) - 类 javax.swing.GroupLayout 中的方法
设置用于计算组件之间首选间隙的 LayoutStyle。
setLeadAnchorNotificationEnabled(boolean) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置 leadAnchorNotificationEnabled 标志的值。
setLeadSelectionIndex(int) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置 lead 选择索引，确保 anchor 和新 lead 之间的值要么全部被选定，要么全部被取消选定。
setLeadSelectionIndex(int) - 接口 javax.swing.ListSelectionModel 中的方法
设置 lead 选择索引。
setLeadSelectionPath(TreePath) - 类 javax.swing.JTree 中的方法
将标识的路径设置为前导路径。
setLeafIcon(Icon) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置用于表示叶节点的图标。
setLeftChildIndent(int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
setLeftComponent(Component) - 类 javax.swing.JSplitPane 中的方法
将组件设置到分隔条的左边（或上面）。
setLeftIndent(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置左边缩进。
setLeftInset(float) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图四周左侧的空白部分。
setLength(long) - 类 java.io.RandomAccessFile 中的方法
设置此文件的长度。
setLength(int) - 类 java.lang.StringBuffer 中的方法
setLength(int) - 类 java.net.DatagramPacket 中的方法
为此包设置长度。
setLength(int) - 类 javax.imageio.stream.IIOByteBuffer 中的方法
更新对 getLength 方法的后续调用将返回的值。
setLenient(boolean) - 类 java.text.DateFormat 中的方法
指定日期/时间解析是否不严格。
setLenient(boolean) - 类 java.util.Calendar 中的方法
指定日期/时间解释是否是宽松的。
setLevel(Level) - 类 java.util.logging.Handler 中的方法
设置日志级别，指定该 Handler 所记录的信息级别。
setLevel(Level) - 类 java.util.logging.Logger 中的方法
设置日志级别，指定此 logger 记录的消息级别。
setLevel(Level) - 类 java.util.logging.LogRecord 中的方法
设置日志消息级别，例如 Level.SEVERE。
setLevel(int) - 类 java.util.zip.Deflater 中的方法
将当前压缩级别设置为指定值。
setLevel(int) - 类 java.util.zip.ZipOutputStream 中的方法
为后续的 DEFLATED 条目设置压缩级别。
setLexicalHandler(LexicalHandler) - 类 javax.xml.transform.sax.SAXResult 中的方法
设置输出的 SAX2 LexicalHandler。
setLibraryDirectory(String) - 类 javax.management.loading.MLet 中的方法
设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。
setLibraryDirectory(String) - 接口 javax.management.loading.MLetMBean 中的方法
设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。
setLightWeightPopupEnabled(boolean) - 类 javax.swing.JComboBox 中的方法
设置 lightWeightPopupEnabled 属性，该属性提供一个提示：是应该使用重量级 Component（如 Panel 或 Window）还是轻量级 Component 来包含 JComboBox。
setLightWeightPopupEnabled(boolean) - 类 javax.swing.JPopupMenu 中的方法
设置 lightWeightPopupEnabled 属性的值，默认情况下该值为 true。
setLightWeightPopupEnabled(boolean) - 类 javax.swing.ToolTipManager 中的方法
显示 JToolTip 时，该 ToolTipManager 会选择使用一个轻量级 JPanel（如果合适）。
setLimit(int) - 类 javax.swing.undo.UndoManager 中的方法
设置此 UndoManager 保持的最大编辑数。
setLine(double, double, double, double) - 类 java.awt.geom.Line2D.Double 中的方法
将此 Line2D 的端点位置设置为指定的 double 坐标。
setLine(double, double, double, double) - 类 java.awt.geom.Line2D.Float 中的方法
将此 Line2D 的端点位置设置为指定的 double 坐标。
setLine(float, float, float, float) - 类 java.awt.geom.Line2D.Float 中的方法
将此 Line2D 端点的位置设置为指定的 float 坐标。
setLine(double, double, double, double) - 类 java.awt.geom.Line2D 中的方法
将此 Line2D 的端点位置设置为指定的 double 坐标。
setLine(Point2D, Point2D) - 类 java.awt.geom.Line2D 中的方法
将此 Line2D 端点的位置设置为指定的 Point2D 坐标。
setLine(Line2D) - 类 java.awt.geom.Line2D 中的方法
将此 Line2D 端点的位置设置为与指定 Line2D 的这些端点相同。
setLineIncrement(int) - 类 java.awt.Scrollbar 中的方法
已过时。 从 JDK version 1.1 开始，由 setUnitIncrement(int) 取代。
setLineLength(int) - 类 javax.swing.text.AbstractWriter 中的方法
允许子类设置每行上要写入的字符数。
setLineNumber(int) - 类 java.io.LineNumberInputStream 中的方法
已过时。 将行号设置为指定参数。
setLineNumber(int) - 类 java.io.LineNumberReader 中的方法
设置当前行号。
setLineNumber(int) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 lineNumber 字段。
setLineNumber(int) - 类 org.xml.sax.helpers.LocatorImpl 中的方法
设置此定位器的行数（从 1 开始）。
setLineSeparator(String) - 类 javax.swing.text.AbstractWriter 中的方法
设置用于表示换行的 String。
setLineSpacing(float) - 类 javax.swing.text.ParagraphView 中的方法
设置行间距。
setLineSpacing(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置行间距。
setLineWrap(boolean) - 类 javax.swing.JTextArea 中的方法
设置文本区的换行策略。
setLinkCursor(Cursor) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
设置要在链接上使用的光标。
setLinkedException(Throwable) - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法
设置此事件的 linked exception 字段。
setLinkedException(Throwable) - 异常 javax.xml.bind.JAXBException 中的方法
添加链接的异常。
setLinkedException(Throwable) - 异常 javax.xml.bind.TypeConstraintException 中的方法
添加一个链接的异常。
setLinkExplanation(String) - 异常 javax.naming.LinkException 中的方法
设置与解析某一链接时所遇问题关联的解释。
setLinkRemainingName(Name) - 异常 javax.naming.LinkException 中的方法
设置此异常的剩余链接名称字段。
setLinkResolvedName(Name) - 异常 javax.naming.LinkException 中的方法
设置此异常的已解析链接名称字段。
setLinkResolvedObj(Object) - 异常 javax.naming.LinkException 中的方法
设置此异常的已解析链接对象字段。
setList(List<?>) - 类 javax.swing.SpinnerListModel 中的方法
更改定义此序列的列表，并将该模型 value 的索引重新设置为零。
setListData(Object[]) - 类 javax.swing.JList 中的方法
根据一个对象数组构造只读 ListModel，然后对此模型调用 setModel。
setListData(Vector<?>) - 类 javax.swing.JList 中的方法
根据一个 Vector 构造只读 ListModel，然后对此模型调用 setModel。
setListener(Marshaller.Listener) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setListener(Unmarshaller.Listener) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
setListener(Marshaller.Listener) - 接口 javax.xml.bind.Marshaller 中的方法
向此 Marshaller 注册编组事件回调 Marshaller.Listener。
setListener(Unmarshaller.Listener) - 接口 javax.xml.bind.Unmarshaller 中的方法
向此 Unmarshaller 注册解组事件回调 Unmarshaller.Listener。
setLoadsSynchronously(boolean) - 类 javax.swing.text.html.ImageView 中的方法
设置如何加载图像。
setLocale(Locale) - 类 java.awt.Component 中的方法
设置组件的语言环境。
setLocale(Locale) - 接口 java.awt.im.spi.InputMethod 中的方法
试图设置输入语言环境。
setLocale(Locale) - 类 java.beans.beancontext.BeanContextSupport 中的方法
设置此 BeanContext 的语言环境。
setLocale(Locale) - 类 java.text.MessageFormat 中的方法
设置创建或比较子格式时要使用的语言环境。
setLocale(Locale) - 类 javax.imageio.ImageReader 中的方法
将此 ImageReader 的当前 Locale 设置为给定值。
setLocale(Locale) - 类 javax.imageio.ImageWriter 中的方法
将此 ImageWriter 的当前 Locale 设置为给定值。
setLocale(Locale) - 类 javax.security.auth.callback.LanguageCallback 中的方法
设置获取到的 Locale。
setLocale(Locale) - 接口 javax.tools.JavaCompiler.CompilationTask 中的方法
设置格式化诊断和其他本地化数据时要应用的语言环境。
setLocale(Locale) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
设置错误报告的语言环境。
setLocale(Locale) - 接口 org.xml.sax.Parser 中的方法
已过时。 允许应用程序请求错误和警告的环境。
setLocalName(int, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
设置特定属性的本地名称。
setLocalPatternChars(String) - 类 java.text.DateFormatSymbols 中的方法
设置本地化的日期-时间模式字符。
setLocation(Point) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置对象相对父对象的位置。
setLocation(int, int) - 类 java.awt.Component 中的方法
将组件移到新位置。
setLocation(Point) - 类 java.awt.Component 中的方法
将组件移到新位置。
setLocation(double, double) - 类 java.awt.geom.Point2D.Double 中的方法
将此 Point2D 的位置设为指定的 double 坐标。
setLocation(double, double) - 类 java.awt.geom.Point2D.Float 中的方法
将此 Point2D 的位置设为指定的 double 坐标。
setLocation(float, float) - 类 java.awt.geom.Point2D.Float 中的方法
将此 Point2D 的位置设为指定的 float 坐标。
setLocation(double, double) - 类 java.awt.geom.Point2D 中的方法
将此 Point2D 的位置设为指定的 double 坐标。
setLocation(Point2D) - 类 java.awt.geom.Point2D 中的方法
将此 Point2D 的位置设为指定 Point2D 对象的坐标。
setLocation(Point) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置对象相对于父级的位置。
setLocation(Point) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置该对象相对于父对象的位置。
setLocation(Point) - 类 java.awt.Point 中的方法
将点的位置设为指定位置。
setLocation(int, int) - 类 java.awt.Point 中的方法
将此点更改为具有指定位置。
setLocation(double, double) - 类 java.awt.Point 中的方法
将此点的位置设为指定的双精度坐标。
setLocation(Point) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 移动到指定位置。
setLocation(int, int) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 移动到指定位置。
setLocation(Point) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置对象相对于父级的位置。
setLocation(Point) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setLocation(int, int) - 类 javax.swing.JPopupMenu 中的方法
使用 X、Y 坐标设置弹出菜单的左上角的位置。
setLocation(Point) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置该对象相对于父对象的位置。
setLocation(Point) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setLocation(Point) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setLocation(JavaFileManager.Location, Iterable<? extends File>) - 接口 javax.tools.StandardJavaFileManager 中的方法
将给定路径与给定位置关联。
setLocation(Location) - 类 javax.xml.stream.XMLEventFactory 中的方法
此方法允许对此工厂创建的每个事件设置 Location。
setLocationByPlatform(boolean) - 类 java.awt.Window 中的方法
设置窗口下次可见时应该出现的位置：本机窗口系统的默认位置，还是当前位置（由 getLocation 返回）。
setLocationRelativeTo(Component) - 类 java.awt.Window 中的方法
设置窗口相对于指定组件的位置。
setLocator(ValidationEventLocator) - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法
设置此事件的 Locator 对象。
setLocator(SourceLocator) - 异常 javax.xml.transform.TransformerException 中的方法
setLocator 方法设置 SourceLocator 对象的实例，此对象指定了错误发生的位置。
setLockingKeyState(int, boolean) - 类 java.awt.Toolkit 中的方法
设置键盘上给定锁定键的状态。
setLog(OutputStream) - 类 java.rmi.server.RemoteServer 中的静态方法
将 RMI 调用记录到输出流 out 中。
setLogger(Logger) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
设置 SyncFactory 提供的 SyncProvider 实现所使用的日志对象。
setLogger(Logger, Level) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
设置 SyncFactory SPI 提供的 SyncProvider 实现所使用的日志对象。
setLoggerLevel(String, String) - 接口 java.util.logging.LoggingMXBean 中的方法
将指定 logger 设置为指定的新级别。
setLoggerName(String) - 类 java.util.logging.LogRecord 中的方法
设置源 Logger 名称。
setLogicalStyle(Style) - 类 javax.swing.JTextPane 中的方法
设置在当前插入符号位置用于段落的逻辑样式。
setLogicalStyle(int, Style) - 类 javax.swing.text.DefaultStyledDocument 中的方法
设置给定位置处用于段落的逻辑样式。
setLogicalStyle(int, Style) - 接口 javax.swing.text.StyledDocument 中的方法
设置给定位置的段落所用的逻辑样式。
setLoginTimeout(int) - 类 java.sql.DriverManager 中的静态方法
设置驱动程序试图连接到某一数据库时将等待的最长时间，以秒为单位。
setLoginTimeout(int) - 接口 javax.sql.CommonDataSource 中的方法
设置此数据源试图连接到某一数据库时将等待的最长时间，以秒为单位。
setLogStream(PrintStream) - 类 java.sql.DriverManager 中的静态方法
已过时。
setLogStream(PrintStream) - 类 javax.swing.DebugGraphics 中的静态方法
设置 DebugGraphics 在其中记录绘制操作的流。
setLogTimers(boolean) - 类 javax.swing.Timer 中的静态方法
启用／禁用计时器日志。
setLogWriter(PrintWriter) - 类 java.sql.DriverManager 中的静态方法
设置由 DriverManager 和所有驱动程序使用的日志/追踪 PrintWriter 对象。
setLogWriter(PrintWriter) - 接口 javax.sql.CommonDataSource 中的方法
将此 DataSource 对象的日志 writer 设置为给定的 java.io.PrintWriter 对象。
setLong(Object, int, long) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 long 值。
setLong(Object, long) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 long 值。
setLong(String, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java long 值。
setLong(int, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java long 值。
setLong(int, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 long 值。
setLong(String, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java long 值。
setLong(int, long) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java long 值。
setLong(String, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java long 值。
setLookAndFeel(LookAndFeel) - 类 javax.swing.UIManager 中的静态方法
将当前外观设置为 newLookAndFeel。
setLookAndFeel(String) - 类 javax.swing.UIManager 中的静态方法
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。
setLoopbackMode(boolean) - 类 java.net.MulticastSocket 中的方法
启用/禁用多播数据报的本地回送。
setLoopCount(int) - 接口 javax.sound.midi.Sequencer 中的方法
设置循环回放的重复次数。
setLoopEndPoint(long) - 接口 javax.sound.midi.Sequencer 中的方法
设置在循环中播放的最后一个 MIDI 节拍。
setLoopPoints(int, int) - 接口 javax.sound.sampled.Clip 中的方法
设置将在循环中播放的第一个和最后一个示例帧。
setLoopStartPoint(long) - 接口 javax.sound.midi.Sequencer 中的方法
设置在循环中播放的第一个 MIDI 节拍。
setMagicCaretPosition(Point) - 接口 javax.swing.text.Caret 中的方法
设置当前插入符的可视位置。
setMagicCaretPosition(Point) - 类 javax.swing.text.DefaultCaret 中的方法
保存当前插入符位置。
setMajorOffset(float) - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
此方法应该仅由 ChildLocator 调用，它只是一个保存缓存位置的便捷场所。
setMajorTickSpacing(int) - 类 javax.swing.JSlider 中的方法
此方法设置主刻度标记的间隔。
setManagedResource(Object, String) - 接口 javax.management.modelmbean.ModelMBean 中的方法
设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
setManagedResource(Object, String) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。
setMargin(Insets) - 类 javax.swing.AbstractButton 中的方法
设置按钮边框和标签之间的空白。
setMargin(Insets) - 类 javax.swing.JMenuBar 中的方法
设置菜单栏的边框与其菜单之间的空白。
setMargin(Insets) - 类 javax.swing.JToolBar 中的方法
设置工具栏边框和它的按钮之间的空白。
setMargin(Insets) - 类 javax.swing.text.JTextComponent 中的方法
设置组件的边框和它的文本之间的空白。
setMask(String) - 类 javax.swing.text.MaskFormatter 中的方法
设置指示合法字符的掩码。
setMasterSyncMode(Sequencer.SyncMode) - 接口 javax.sound.midi.Sequencer 中的方法
设置此 sequencer 使用的定时信息源。
setMatchAllSubjectAltNames(boolean) - 类 java.security.cert.X509CertSelector 中的方法
允许/禁止匹配 setSubjectAlternativeNames 或 addSubjectAlternativeName 方法中所指定的所有 subjectAlternativeNames。
setMatchColumn(int) - 接口 javax.sql.rowset.Joinable 中的方法
将指定的列设置为此 RowSet 对象的匹配列。
setMatchColumn(int[]) - 接口 javax.sql.rowset.Joinable 中的方法
将指定的列设置为此 RowSet 对象的匹配列。
setMatchColumn(String) - 接口 javax.sql.rowset.Joinable 中的方法
将指定的列设置为此 RowSet 对象的匹配列。
setMatchColumn(String[]) - 接口 javax.sql.rowset.Joinable 中的方法
将指定的列设置为此 RowSet 对象的匹配列。
setMaxAge(long) - 类 java.net.HttpCookie 中的方法
设置 cookie 的最大生存时间，以秒为单位。
setMaxCRLNumber(BigInteger) - 类 java.security.cert.X509CRLSelector 中的方法
设置 maxCRLNumber 标准。
setMaxFieldSize(int) - 接口 java.sql.Statement 中的方法
设置此 Statement 对象生成的 ResultSet 对象中字符和二进制列值可以返回的最大字节数限制。
setMaxFieldSize(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将可用于此 RowSet 对象列值的最大字节数设置为给定数。
setMaxFieldSize(int) - 接口 javax.sql.RowSet 中的方法
将可以对列值返回的最大字节数设置为给定的字节数。
setMaximizable(boolean) - 类 javax.swing.JInternalFrame 中的方法
设置 maximizable 属性，该属性确定是否可以通过某个用户操作最大化此 JInternalFrame。
setMaximizedBounds(Rectangle) - 类 java.awt.Frame 中的方法
设置此窗体的最大化边界。
setMaximum(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的最大值。
setMaximum(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的最大值。
setMaximum(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
此方法不应由用户代码调用。
setMaximum(int) - 接口 javax.swing.BoundedRangeModel 中的方法
将模型的 maximum 设置为 newMaximum。
setMaximum(int) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
在确保 n 以及其他三个属性满足以下模型约束条件之后，将 maximum 设置为 n：
setMaximum(boolean) - 类 javax.swing.JInternalFrame 中的方法
最大化并还原此内部窗体。
setMaximum(int) - 类 javax.swing.JProgressBar 中的方法
将进度条的最大值（存储在进度条的数据模型中）设置为 n。
setMaximum(int) - 类 javax.swing.JScrollBar 中的方法
设置模型的 maximum 属性。
setMaximum(int) - 类 javax.swing.JSlider 中的方法
将滑块的最大值设置为 maximum。
setMaximum(int) - 类 javax.swing.ProgressMonitor 中的方法
指定最大值。
setMaximum(Comparable) - 类 javax.swing.SpinnerNumberModel 中的方法
更改此序列中数字的上边界。
setMaximum(Comparable) - 类 javax.swing.text.InternationalFormatter 中的方法
设置最大允许值。
setMaximumFractionDigits(int) - 类 java.text.DecimalFormat 中的方法
设置某个数的小数部分中所允许的最大数字位数。
setMaximumFractionDigits(int) - 类 java.text.NumberFormat 中的方法
设置数的小数部分所允许的最大位数。
setMaximumIntegerDigits(int) - 类 java.text.DecimalFormat 中的方法
设置某个数字的整数部分中所允许的最大数字位数。
setMaximumIntegerDigits(int) - 类 java.text.NumberFormat 中的方法
设置数的整数部分所允许的最大位数。
setMaximumPoolSize(int) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
设置允许的最大线程数。
setMaximumRowCount(int) - 类 javax.swing.JComboBox 中的方法
设置 JComboBox 显示的最大行数。
setMaximumSize(Dimension) - 类 java.awt.Component 中的方法
将组件的最大大小设置为常量值。
setMaximumSize(Dimension) - 类 javax.swing.JComponent 中的方法
将此组件的最大大小设置为一个常量值。
setMaximumZoneSize(int) - 类 javax.swing.text.ZoneView 中的方法
设置所需的最大分区大小。
setMaxPage(int) - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，用户可以指定为要打印的最后一页的最大值。
setMaxPathLength(int) - 类 java.security.cert.PKIXBuilderParameters 中的方法
设置证书路径中可能存在的非自发中间证书的最大数目值。
setMaxPriority(int) - 类 java.lang.ThreadGroup 中的方法
设置线程组的最高优先级。
setMaxRows(int) - 接口 java.sql.Statement 中的方法
将此 Statement 对象生成的所有 ResultSet 对象可以包含的最大行数限制设置为给定数。
setMaxRows(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象可以包含的最大行数设置为给定数。
setMaxRows(int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象可以包含的最大行数设置为指定数。
setMaxSortKeys(int) - 类 javax.swing.DefaultRowSorter 中的方法
设置排序键的最大数量。
setMaxWidth(int) - 类 javax.swing.table.TableColumn 中的方法
将 TableColumn 的最大宽度设置为 maxWidth；如果 maxWidth 小于最小宽度，则设置为最小宽度。
setMaxZonesLoaded(int) - 类 javax.swing.text.ZoneView 中的方法
设置当前设置的允许同时加载的分区数。
setMBeanDescriptor(Descriptor) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
设置 ModelMBean 的描述符。
setMBeanDescriptor(Descriptor) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
setMBeanServer(MBeanServer) - 类 javax.management.AttributeValueExp 中的方法
设置要在其上执行查询的 MBean 服务器。
setMBeanServer(MBeanServer) - 类 javax.management.ObjectName 中的方法
setMBeanServer(MBeanServer) - 类 javax.management.QueryEval 中的方法
设置将在其上执行查询的 MBean 服务器。
setMBeanServer(MBeanServer) - 接口 javax.management.QueryExp 中的方法
设置将在其上执行查询的 MBean 服务器。
setMBeanServer(MBeanServer) - 接口 javax.management.remote.MBeanServerForwarder 中的方法
设置 MBeanServer 对象，请求经此对象处理后将转发到其上。
setMBeanServer(MBeanServer) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
设置此连接器服务器所连接的 MBeanServer。
setMBeanServer(MBeanServer) - 类 javax.management.StringValueExp 中的方法
设置将在其上执行查询的 MBean 服务器。
setMBeanServer(MBeanServer) - 接口 javax.management.ValueExp 中的方法
已过时。 不再需要此方法，因为 ValueExp 可以通过使用 QueryEval.getMBeanServer() 来访问它将在其中进行计算的 MBean 服务器。
setMBeanServerForwarder(MBeanServerForwarder) - 类 javax.management.remote.JMXConnectorServer 中的方法
setMBeanServerForwarder(MBeanServerForwarder) - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
添加一个截取对 MBean 服务器请求的对象，该请求是通过此连接器服务器到达的。
setMBeanServerForwarder(MBeanServerForwarder) - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
setMedia(PageAttributes.MediaType) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面所需的纸张尺寸。
setMediaToDefault() - 类 java.awt.PageAttributes 中的方法
将使用这些属性的页面的纸张尺寸设置为默认地区的默认尺寸。
setMenuBar(MenuBar) - 类 java.awt.Frame 中的方法
将此窗体的菜单栏设置为指定的菜单栏。
setMenuBar(JMenuBar) - 类 javax.swing.JInternalFrame 中的方法
已过时。 从 Swing version 1.0.3 开始，由 setJMenuBar(JMenuBar m) 取代。
setMenuBar(JMenuBar) - 类 javax.swing.JRootPane 中的方法
已过时。 从 Swing 版本 1.0.3 开始，由 setJMenuBar(JMenuBar menu) 取代。
setMenuLocation(int, int) - 类 javax.swing.JMenu 中的方法
设置弹出组件的位置。
setMessage(String) - 类 java.util.logging.LogRecord 中的方法
设置本地化或格式化之前的“原始”日志消息。
setMessage(int, byte[], int) - 类 javax.sound.midi.MetaMessage 中的方法
为 MetaMessage 设置消息参数。
setMessage(byte[], int) - 类 javax.sound.midi.MidiMessage 中的方法
为 MIDI 消息设置数据。
setMessage(int) - 类 javax.sound.midi.ShortMessage 中的方法
为不带任何数据字节的 MIDI 消息设置参数。
setMessage(int, int, int) - 类 javax.sound.midi.ShortMessage 中的方法
为带一个或两个数据字节的 MIDI 消息设置参数。
setMessage(int, int, int, int) - 类 javax.sound.midi.ShortMessage 中的方法
为带两个数据字节的通道消息设置短消息参数。
setMessage(byte[], int) - 类 javax.sound.midi.SysexMessage 中的方法
为系统独占消息设置数据。
setMessage(int, byte[], int) - 类 javax.sound.midi.SysexMessage 中的方法
为系统独占消息设置数据。
setMessage(Object) - 类 javax.swing.JOptionPane 中的方法
设置选项窗格的消息对象。
setMessage(String) - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法
设置此事件的 message 字段。
setMessage(SOAPMessage) - 接口 javax.xml.ws.handler.soap.SOAPMessageContext 中的方法
在此消息上下文中设置 SOAPMessage。
setMessageDigest(MessageDigest) - 类 java.security.DigestInputStream 中的方法
将指定的消息摘要与此流相关联。
setMessageDigest(MessageDigest) - 类 java.security.DigestOutputStream 中的方法
将指定的消息摘要与此流相关联。
setMessageType(int) - 类 javax.swing.JOptionPane 中的方法
设置选项窗格的消息类型。
setMetadata(IIOMetadata) - 类 javax.imageio.IIOImage 中的方法
将 IIOMetadata 设置为一个新对象或 null。
setMetaData(RowSetMetaData) - 接口 javax.sql.rowset.CachedRowSet 中的方法
使用给定的 RowSetMetaData 对象设置此 CachedRowSet 对象的元数据。
setMetaData(RowSetMetaData) - 接口 javax.sql.RowSetInternal 中的方法
将给定的 RowSetMetaData 对象设置为此 RowSet 对象的 RowSetMetaData 对象。
setMetadata(List<Source>) - 类 javax.xml.ws.Endpoint 中的方法
设置此端点的元数据。
setMethod(int) - 类 java.util.zip.ZipEntry 中的方法
设置条目的压缩方法。
setMethod(int) - 类 java.util.zip.ZipOutputStream 中的方法
设置用于后续条目的默认压缩方法。
setMicrosecondPosition(long) - 接口 javax.sound.midi.Sequencer 中的方法
设置 sequence 中的当前位置，用微秒表示
setMicrosecondPosition(long) - 接口 javax.sound.sampled.Clip 中的方法
设置介质位置（以微秒为单位）。
setMillis(long) - 类 java.util.logging.LogRecord 中的方法
设置事件时间。
setMillisecond(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置毫秒。
setMillisToDecideToPopup(int) - 类 javax.swing.ProgressMonitor 中的方法
指定在确定是否弹出进度监视器之前要等待的时间量。
setMillisToPopup(int) - 类 javax.swing.ProgressMonitor 中的方法
指定显示弹出监视器花费的时间量。
setMimeHeader(String, String) - 类 javax.xml.soap.AttachmentPart 中的方法
将匹配给定名称的第一个头条目的值更改为给定值，如果现有的头都不匹配，则添加一个新的头。
setMimeHeader(String, String) - 类 javax.xml.soap.SOAPPart 中的方法
将与给定头名称匹配的第一个头条目的值更改为给定值，如果现有头都不匹配，则添加一个带有给定名称和值的新头。
setMinCRLNumber(BigInteger) - 类 java.security.cert.X509CRLSelector 中的方法
设置 minCRLNumber 标准。
setMinimalDaysInFirstWeek(int) - 类 java.util.Calendar 中的方法
设置一年中第一个星期所需的最少天数，例如，如果定义第一个星期包含一年第一个月的第一天，则使用值 1 调用此方法。
setMinimum(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的最小值。
setMinimum(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的最小值。
setMinimum(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
此方法不应由用户代码调用。
setMinimum(int) - 接口 javax.swing.BoundedRangeModel 中的方法
将模型的 minimum 设置为 newMinimum。
setMinimum(int) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
在确保 n 以及其他三个属性满足以下模型约束条件之后，将 minimum 设置为 n：
setMinimum(int) - 类 javax.swing.JProgressBar 中的方法
将进度条的最小值（存储在进度条的数据模型中）设置为 n。
setMinimum(int) - 类 javax.swing.JScrollBar 中的方法
设置模型的 minimum 属性。
setMinimum(int) - 类 javax.swing.JSlider 中的方法
将滑块的最小值设置为 minimum。
setMinimum(int) - 类 javax.swing.ProgressMonitor 中的方法
指定最小值。
setMinimum(Comparable) - 类 javax.swing.SpinnerNumberModel 中的方法
更改此序列中数字的下边界。
setMinimum(Comparable) - 类 javax.swing.text.InternationalFormatter 中的方法
设置最小允许值。
setMinimumFractionDigits(int) - 类 java.text.DecimalFormat 中的方法
设置某个数的小数部分中所允许的最小数字位数。
setMinimumFractionDigits(int) - 类 java.text.NumberFormat 中的方法
设置数的小数部分所允许的最小位数。
setMinimumIntegerDigits(int) - 类 java.text.DecimalFormat 中的方法
设置某个数字的整数部分中所允许的最小数字位数。
setMinimumIntegerDigits(int) - 类 java.text.NumberFormat 中的方法
设置数的整数部分所允许的最小位数。
setMinimumSize(Dimension) - 类 java.awt.Component 中的方法
将组件的最小大小设置为常量值。
setMinimumSize(Dimension) - 类 java.awt.Window 中的方法
将此窗口的最小大小设置为一个常量值。
setMinimumSize(Dimension) - 类 javax.swing.JComponent 中的方法
将此组件的最小大小设置为一个常量值。
setMinor(int, String) - 异常 org.ietf.jgss.GSSException 中的方法
由异常抛出器使用，以设置机制级的次要错误代码及其字符串解释。
setMinorTickSpacing(int) - 类 javax.swing.JSlider 中的方法
此方法设置次刻度标记的间隔。
setMinPage(int) - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，用户可以指定为要打印的第一页的最小值。
setMinusSign(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于表示减号的字符。
setMinute(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置分。
setMinutes(int) - 类 java.sql.Date 中的方法
已过时。
setMinutes(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MINUTE, int minutes) 取代。
setMinWidth(int) - 类 javax.swing.table.TableColumn 中的方法
将 TableColumn 的最小宽度设置为 minWidth，如有必要，调整新的最小宽度以确保 0 <= minWidth <= maxWidth。
setMnemonic(int) - 类 javax.swing.AbstractButton 中的方法
设置当前模型上的键盘助记符。
setMnemonic(char) - 类 javax.swing.AbstractButton 中的方法
此方法现在已废弃，请使用 setMnemonic(int) 来设置按钮的助记符。
setMnemonic(int) - 接口 javax.swing.ButtonModel 中的方法
设置该按钮的键盘助记符（快捷键或加速键）。
setMnemonic(int) - 类 javax.swing.DefaultButtonModel 中的方法
设置该按钮的键盘助记符（快捷键或加速键）。
setMnemonicAt(int, int) - 类 javax.swing.JTabbedPane 中的方法
设置用于访问指定选项卡的键盘助记符。
setModal(boolean) - 类 java.awt.Dialog 中的方法
指定此 dialog 是否应该是有模式的。
setModalExclusionType(Dialog.ModalExclusionType) - 类 java.awt.Window 中的方法
指定此窗口的模式排斥类型。
setModalityType(Dialog.ModalityType) - 类 java.awt.Dialog 中的方法
设置此 dialog 的模式类型。
setMode(int) - 类 java.awt.FileDialog 中的方法
设置文件对话框的模式。
setModel(ButtonModel) - 类 javax.swing.AbstractButton 中的方法
设置此按钮表示的模型。
setModel(ComboBoxModel) - 类 javax.swing.JComboBox 中的方法
设置 JComboBox 用于获取项列表的数据模型。
setModel(ListModel) - 类 javax.swing.JList 中的方法
设置表示列表内容或列表“值”的模型，通知属性更改侦听器，然后清除列表选择。
setModel(ButtonModel) - 类 javax.swing.JMenu 中的方法
设置“菜单按钮”的数据模型，即用户单击可以打开或关闭菜单的标签。
setModel(ButtonModel) - 类 javax.swing.JMenuItem 中的方法
设置此按钮表示的模型。
setModel(BoundedRangeModel) - 类 javax.swing.JProgressBar 中的方法
设置 JProgressBar 使用的数据模型。
setModel(BoundedRangeModel) - 类 javax.swing.JScrollBar 中的方法
设置处理滚动条的以下四个基本属性的模型：minimum、maximum、value 和 extent。
setModel(BoundedRangeModel) - 类 javax.swing.JSlider 中的方法
设置处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。
setModel(SpinnerModel) - 类 javax.swing.JSpinner 中的方法
更改表示此 spinner 值的模型。
setModel(SingleSelectionModel) - 类 javax.swing.JTabbedPane 中的方法
设置要用于此选项卡窗格的模型。
setModel(TableModel) - 类 javax.swing.JTable 中的方法
将此表的数据模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
setModel(TreeModel) - 类 javax.swing.JTree 中的方法
设置将提供数据的 TreeModel。
setModel(TreeModel) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
设置 TreeModel。
setModel(M) - 类 javax.swing.table.TableRowSorter 中的方法
将 TableModel 设置为此 TableRowSorter 要使用的底层模型。
setModel(TreeModel) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
设置将提供数据的 TreeModel。
setModel(TreeModel) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
设置将提供数据的 TreeModel。
setModel(TreeModel) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
设置将提供数据的 TreeModel。
setModelIndex(int) - 类 javax.swing.table.TableColumn 中的方法
设置此列的模型索引。
setModelMBeanInfo(ModelMBeanInfo) - 接口 javax.management.modelmbean.ModelMBean 中的方法
使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
setModelMBeanInfo(ModelMBeanInfo) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
setModelWrapper(DefaultRowSorter.ModelWrapper<M, I>) - 类 javax.swing.DefaultRowSorter 中的方法
设置模型包装器，它提供将要进行排序和过滤的数据。
setModifiers(int) - 类 java.awt.event.KeyEvent 中的方法
已过时。 从 JDK1.1.4 开始
setModulus(Number) - 类 javax.management.monitor.CounterMonitor 中的方法
设置所有观察到的 MBeans 共同的模值。
setModulus(Number) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
设置模值。
setMonetaryDecimalSeparator(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置货币小数点分隔符。
setMono(boolean) - 接口 javax.sound.midi.MidiChannel 中的方法
打开或关闭 mono 模式。
setMonth(int) - 类 java.sql.Time 中的方法
已过时。
setMonth(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MONTH, int month) 取代。
setMonth(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置月。
setMonths(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置月份字符串。
setMouseOver(boolean) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
设置鼠标当前是否位于分隔符上。
setMTOMEnabled(boolean) - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
启用或禁用 MTOM。
setMultiClickThreshhold(long) - 类 javax.swing.AbstractButton 中的方法
设置对按钮按下鼠标到生成相应动作事件所需的时间量（以毫秒为单位）。
setMultipleDocumentHandling(JobAttributes.MultipleDocumentHandlingType) - 类 java.awt.JobAttributes 中的方法
为使用这些属性的作业指定多份处理，包括整理。
setMultipleDocumentHandlingToDefault() - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，将多份处理（包括整理）设置为默认值。
setMultipleMode(boolean) - 类 java.awt.List 中的方法
设置确定此列表是否允许进行多项选择的标志。
setMultipleSelections(boolean) - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 setMultipleMode(boolean) 取代。
setMultiplier(int) - 类 java.text.DecimalFormat 中的方法
设置百分数、千分数和类似格式中使用的乘数。
setMultiSelectionEnabled(boolean) - 类 javax.swing.JFileChooser 中的方法
设置文件选择器，以允许选择多个文件。
setMustUnderstand(boolean) - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
将此 SOAPHeaderElement 对象的 mustUnderstand 属性设置为 true 或 false。
setMute(boolean) - 接口 javax.sound.midi.MidiChannel 中的方法
设置此通道的静音状态。
setName(String) - 类 java.awt.Component 中的方法
将组件的名称设置为指定的字符串。
setName(String) - 类 java.awt.MenuComponent 中的方法
将该组件的名称设置为指定字符串。
setName(String) - 类 java.beans.FeatureDescriptor 中的方法
设置此特性的编程名称。
setName(String) - 类 java.lang.Thread 中的方法
改变线程名称，使之与参数 name 相同。
setName(Principal, String) - 接口 java.security.acl.Acl 中的方法
设置此 ACL 的名称。
setName(String) - 类 javax.naming.NameClassPair 中的方法
设置此绑定的名称。
setName(String) - 类 javax.security.auth.callback.NameCallback 中的方法
设置检索到的名称。
setName(String) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
更改样式的名称。
setNameConstraints(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 NameConstraints 标准。
setNamedItem(Node) - 接口 org.w3c.dom.NamedNodeMap 中的方法
使用 nodeName 属性添加节点。
setNamedItemNS(Node) - 接口 org.w3c.dom.NamedNodeMap 中的方法
使用其 namespaceURI 和 localName 添加节点。
setNameInNamespace(String) - 类 javax.naming.NameClassPair 中的方法
设置此绑定的完全名称。
setNamespaceAware(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此代码生成的解析器将提供对 XML 名称空间的支持。
setNamespaceAware(boolean) - 类 javax.xml.parsers.SAXParserFactory 中的方法
指定由此代码生成的解析器将提供对 XML 名称空间的支持。
setNamespaceContext(NamespaceContext) - 接口 javax.xml.stream.XMLEventWriter 中的方法
设置前缀的当前名称空间上下文和 URI 绑定。
setNamespaceContext(NamespaceContext) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
设置前缀和 URI 绑定的当前名称空间上下文。
setNamespaceContext(NamespaceContext) - 接口 javax.xml.xpath.XPath 中的方法
建立名称空间上下文。
setNamespaceDeclUris(boolean) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
控制是否通过 processName() 将名称空间声明属性放置到 NSDECL 名称空间中。
setNaN(String) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于表示“非数字”的字符串。
setNanos(int) - 类 java.sql.Timestamp 中的方法
将此 Timestamp 对象的 nanos 字段设置为给定值。
setNativeMethodPrefix(ClassFileTransformer, String) - 接口 java.lang.instrument.Instrumentation 中的方法
通过允许重试，将前缀应用到名称，此方法修改本机方法解析的失败处理。
setNativesForFlavor(DataFlavor, String[]) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
放弃指定 DataFlavor 和等于指定 DataFlavor 的所有 DataFlavor 的当前映射，并创建到指定 String native 的新映射。
setNavigationFilter(NavigationFilter) - 类 javax.swing.text.JTextComponent 中的方法
设置 NavigationFilter。
setNCharacterStream(String, Reader, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(String, Reader) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(String, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(String, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(String, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(String, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, NClob) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(String, Reader, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, Reader) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, NClob) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(int, Reader, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, Reader) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, NClob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(String, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, NClob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(int, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, NClob) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(String, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, NClob) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(int, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNeedClientAuth(boolean) - 类 javax.net.ssl.SSLEngine 中的方法
配置引擎要求 客户端进行验证。
setNeedClientAuth(boolean) - 类 javax.net.ssl.SSLParameters 中的方法
设置是否应该要求客户机验证。
setNeedClientAuth(boolean) - 类 javax.net.ssl.SSLServerSocket 中的方法
控制接受的服务器模式 SSLSocket 是否将在开始时配置为要求 客户端验证。
setNeedClientAuth(boolean) - 类 javax.net.ssl.SSLSocket 中的方法
配置套接字要求 客户机验证。
setNegativePermissions() - 接口 java.security.acl.AclEntry 中的方法
将此 ACL 项设置为 negative 项。
setNegativePrefix(String) - 类 java.text.DecimalFormat 中的方法
设置负数前缀。
setNegativeSuffix(String) - 类 java.text.DecimalFormat 中的方法
设置负数后缀。
setNetworkInterface(NetworkInterface) - 类 java.net.MulticastSocket 中的方法
指定在此套接字上发送的输出多播数据报的网络接口。
setNewLine(String) - 接口 org.w3c.dom.ls.LSSerializer 中的方法
在所写出的 XML 中使用的字符的行尾序列。
setNextException(SQLException) - 异常 java.sql.SQLException 中的方法
将 SQLException 对象添加到链接的末尾。
setNextFocusableComponent(Component) - 类 javax.swing.JComponent 中的方法
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代
setNextSibling(Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 中的方法
设置下一个兄弟节点。
setNextSibling(Node) - 类 javax.xml.transform.dom.DOMResult 中的方法
设置将要插入的结果节点之后的子节点。
setNextWarning(SQLWarning) - 异常 java.sql.SQLWarning 中的方法
将 SQLWarning 对象添加到链接的末尾。
setNextWarning(RowSetWarning) - 异常 javax.sql.rowset.RowSetWarning 中的方法
将 warning 设置为下一个警告，即连接到此 RowSetWarning 对象的警告。
setNil(boolean) - 类 javax.xml.bind.JAXBElement 中的方法
设置此属性是否包含 nil 内容。
setNode(Node) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 Node 字段。
setNode(Node) - 类 javax.xml.crypto.dsig.dom.DOMValidateContext 中的方法
设置节点。
setNode(Node) - 类 javax.xml.transform.dom.DOMResult 中的方法
设置将包含结果 DOM 树的节点。
setNode(Node) - 类 javax.xml.transform.dom.DOMSource 中的方法
设置将表示 Source DOM 树的节点。
setNodeDimensions(AbstractLayoutCache.NodeDimensions) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
设置负责绘制树中节点的 renderer，因此，它还负责计算各个节点的尺寸。
setNodeDimensions(AbstractLayoutCache.NodeDimensions) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
设置负责绘制树中节点的渲染器。
setNodeValue(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setNodeValue(String) - 接口 org.w3c.dom.Node 中的方法
此节点的值，取决于其类型；参见上表。
setNonContinuousLayoutDivider(Component) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
设置要在将 splitPane 配置为非连续布局时使用的分隔符。
setNonContinuousLayoutDivider(Component, boolean) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
设置要使用的分隔符。
setNoNSSchemaLocation(String) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
设置 noNamespaceSchemaLocation 的便捷方法。
setNormalBounds(Rectangle) - 类 javax.swing.JInternalFrame 中的方法
设置此内部窗体的正常边界，即此内部窗体从其最大化状态还原后的边界。
setNorthPane(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setNote(String) - 类 javax.swing.ProgressMonitor 中的方法
指定与进度消息一起显示的其他注释。
setNotify(boolean) - 类 javax.management.monitor.CounterMonitor 中的方法
设置所有观察到的 MBeans 共同的通知的开/关切换值。
setNotify(boolean) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
设置通知的开/关切换值。
setNotifyDiffer(boolean) - 类 javax.management.monitor.StringMonitor 中的方法
设置所有观察到的 MBeans 共同的不同通知的开/关切换值。
setNotifyDiffer(boolean) - 接口 javax.management.monitor.StringMonitorMBean 中的方法
设置不同通知的开/关切换值。
setNotifyHigh(boolean) - 类 javax.management.monitor.GaugeMonitor 中的方法
设置所有观察到的 MBean 的公共高阈值通知的开/关切换值。
setNotifyHigh(boolean) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
设置高阈值通知的开/关切换值。
setNotifyLow(boolean) - 类 javax.management.monitor.GaugeMonitor 中的方法
设置所有观察到的 MBean 的公共低阈值通知的开/关切换值。
setNotifyLow(boolean) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
设置低阈值通知的开/关切换值。
setNotifyMatch(boolean) - 类 javax.management.monitor.StringMonitor 中的方法
设置所有观察到的 MBeans 共同的匹配通知的开/关切换值。
setNotifyMatch(boolean) - 接口 javax.management.monitor.StringMonitorMBean 中的方法
设置匹配的通知的开/关切换值。
setNString(String, String) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 String 对象。
setNString(int, String) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 String 对象。
setNString(int, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 String 对象。
setNString(String, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 String 对象。
setNString(int, String) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 String 对象。
setNString(String, String) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 String 对象。
setNull(String, int) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 SQL NULL。
setNull(String, int, String) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int, String) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 SQL NULL。
setNull(String, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 SQL NULL。
setNull(String, int, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。
setNull(String, int) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int, String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。
setNull(String, int, String) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 SQL NULL。
setNullable(int, int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为 ResultSetMetaData 接口中的给定常量，以指示是否可以将存储在该列中的值设置为 NULL。
setNullable(int, int) - 接口 javax.sql.RowSetMetaData 中的方法
设置是否可以将指定列的值设置为 NULL。
setNullFormatter(JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 中的方法
设置在 JFormattedTextField 值为 null 时使用的 formatter。
setNumberFormat(NumberFormat) - 类 java.text.DateFormat 中的方法
允许用户设置数字格式器。
setNumRows(int) - 类 javax.swing.table.DefaultTableModel 中的方法
从 Java 2 platform v1.3 开始已过时。
setObject(Object) - 接口 java.beans.Customizer 中的方法
设置将要自定义的对象。
setObject(String, Object, int, int) - 接口 java.sql.CallableStatement 中的方法
使用给定对象设置指定参数的值。
setObject(String, Object, int) - 接口 java.sql.CallableStatement 中的方法
使用给定对象设置指定参数的值。
setObject(String, Object) - 接口 java.sql.CallableStatement 中的方法
使用给定对象设置指定参数的值。
setObject(int, Object, int) - 接口 java.sql.PreparedStatement 中的方法
使用给定对象设置指定参数的值。
setObject(int, Object) - 接口 java.sql.PreparedStatement 中的方法
使用给定对象设置指定参数的值。
setObject(int, Object, int, int) - 接口 java.sql.PreparedStatement 中的方法
使用给定对象设置指定参数的值。
setObject(Object) - 接口 java.sql.Ref 中的方法
将此 Ref 对象引用的结构类型值设置为给定的 Object 实例。
setObject(Object) - 类 javax.naming.Binding 中的方法
设置与此绑定关联的对象。
setObject(int, Object, int, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的 Object。
setObject(int, Object, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定 Object 值设置指定参数的值。
setObject(int, Object) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的 Object。
setObject(String, Object, int, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定对象设置指定参数的值。
setObject(String, Object, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定对象设置指定参数的值。
setObject(String, Object) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定对象设置指定参数的值。
setObject(Object) - 类 javax.sql.rowset.serial.SerialRef 中的方法
将此 SerialRef 对象引用的 SQL 结构类型设置为给定的 Object 对象。
setObject(int, Object, int, int) - 接口 javax.sql.RowSet 中的方法
使用给定 Java Object 设置此 RowSet 对象命令中的指定参数。
setObject(String, Object, int, int) - 接口 javax.sql.RowSet 中的方法
使用给定对象设置指定参数的值。
setObject(int, Object, int) - 接口 javax.sql.RowSet 中的方法
使用 Java Object 设置此 RowSet 对象命令中的指定参数。
setObject(String, Object, int) - 接口 javax.sql.RowSet 中的方法
使用给定对象设置指定参数的值。
setObject(String, Object) - 接口 javax.sql.RowSet 中的方法
使用给定对象设置指定参数的值。
setObject(int, Object) - 接口 javax.sql.RowSet 中的方法
使用 Java Object 设置此 RowSet 对象命令中的指定参数。
setObject(Object) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 Object 字段。
setObjectFactoryBuilder(ObjectFactoryBuilder) - 类 javax.naming.spi.NamingManager 中的静态方法
ObjectFactoryBuilder 确定尝试加载对象工厂时使用的策略。
setObservedAttribute(String) - 类 javax.management.monitor.Monitor 中的方法
设置要观察的属性。
setObservedAttribute(String) - 接口 javax.management.monitor.MonitorMBean 中的方法
设置要观察的属性。
setObservedObject(ObjectName) - 类 javax.management.monitor.Monitor 中的方法
已过时。 从 JMX 1.2 开始，由 Monitor.addObservedObject(javax.management.ObjectName) 取代
setObservedObject(ObjectName) - 接口 javax.management.monitor.MonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 MonitorMBean.addObservedObject(javax.management.ObjectName) 取代
setOffset(int) - 类 java.io.ObjectStreamField 中的方法
实例数据中的偏移量。
setOffset(int) - 类 java.text.CollationElementIterator 中的方法
将迭代器设置为指向对应于指定字符的 collation 元素（参数是源字符串中的一个 CHARACTER 偏移量，而不是其对应 collation 元素序列的偏移量）。
setOffset(int) - 类 javax.imageio.stream.IIOByteBuffer 中的方法
更新对 getOffset 方法的后续调用将返回的值。
setOffset(Number) - 类 javax.management.monitor.CounterMonitor 中的方法
设置所有观察到的 MBeans 共同的偏移量值。
setOffset(Number) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
设置偏移量值。
setOffset(Point) - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法
setOffset(int) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 offset 字段。
SetOfIntegerSyntax - javax.print.attribute 中的 类
类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。
SetOfIntegerSyntax(String) - 类 javax.print.attribute.SetOfIntegerSyntax 的构造方法
使用以字符串形式给定的成员构造一个新的整数集属性。
SetOfIntegerSyntax(int[][]) - 类 javax.print.attribute.SetOfIntegerSyntax 的构造方法
使用以字符串形式给定的成员构造一个新的整数集属性。
SetOfIntegerSyntax(int) - 类 javax.print.attribute.SetOfIntegerSyntax 的构造方法
构造一个包含单个整数的新整数集属性。
SetOfIntegerSyntax(int, int) - 类 javax.print.attribute.SetOfIntegerSyntax 的构造方法
构造一个包含单一整数范围的新整数集属性。
setOmni(boolean) - 接口 javax.sound.midi.MidiChannel 中的方法
打开或关闭 omni 模式。
setOneTouchExpandable(boolean) - 类 javax.swing.JSplitPane 中的方法
设置 oneTouchExpandable 属性的值，要使 JSplitPane 在分隔条上提供一个 UI 小部件来快速展开/折叠分隔条，此属性必须为 true。
setOOBInline(boolean) - 类 java.net.Socket 中的方法
启用/禁用 OOBINLINE（TCP 紧急数据的接收者） 默认情况下，此选项是禁用的，即在套接字上接收的 TCP 紧急数据被静默丢弃。
setOpaque(boolean) - 类 javax.swing.JComponent 中的方法
如果为 true，则该组件绘制其边界内的所有像素。
setOpenIcon(Icon) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置用于表示扩展的非叶节点的图标。
setOptimizeHuffmanTables(boolean) - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
告知 writer 是否作为写入过程的一部分为图像生成最佳 Huffman 表。
setOption(int, Object) - 接口 java.net.SocketOptions 中的方法
启用/禁用 optID 指定的选项。
setOptions(Object[]) - 类 javax.swing.JOptionPane 中的方法
设置此窗格显示的选项。
setOptionType(int) - 类 javax.swing.JOptionPane 中的方法
设置要显示的选项。
setOrdering(Class<T>, T, T) - 类 javax.imageio.spi.ServiceRegistry 中的方法
为给定类别中的两个服务提供者对象设置配对排序。
setOrientation(int) - 类 java.awt.print.PageFormat 中的方法
设置页面方向。
setOrientation(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的方向。
setOrientation(int) - 类 javax.swing.JProgressBar 中的方法
将进度条的方向设置为 newOrientation（必须为 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL）。
setOrientation(int) - 类 javax.swing.JScrollBar 中的方法
将滚动条的方向设置为 VERTICAL 或 HORIZONTAL。
setOrientation(int) - 类 javax.swing.JSeparator 中的方法
设置此分隔符的方向。
setOrientation(int) - 类 javax.swing.JSlider 中的方法
将滑块的方向设置为 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。
setOrientation(int) - 类 javax.swing.JSplitPane 中的方法
设置方向，或者分隔窗格的方式。
setOrientation(int) - 类 javax.swing.JToolBar 中的方法
设置工具栏的方向。
setOrientation(int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
设置 JSplitPane 的方向。
setOrientation(int) - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法
setOrientation(int) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
setOrientationRequested(PageAttributes.OrientationRequestedType) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面的打印方向。
setOrientationRequested(int) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面的打印方向。
setOrientationRequestedToDefault() - 类 java.awt.PageAttributes 中的方法
将使用这些属性的页面的打印方向设置为默认值。
setOrigin(PageAttributes.OriginType) - 类 java.awt.PageAttributes 中的方法
指定在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。
setOriginalRow() - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象中的当前行设置为原始行。
setOut(PrintStream) - 类 java.lang.System 中的静态方法
重新分配“标准”输出流。
setOuterHTML(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
用指定为 HTML 字符串的内容替换父元素中的给定元素。
setOutput(Object) - 类 javax.imageio.ImageWriter 中的方法
将目标设置为给定 ImageOutputStream 或其他 Object。
setOutputProperties(Properties) - 类 javax.xml.transform.Transformer 中的方法
设置转换的输出属性。
setOutputProperty(String, String) - 类 javax.xml.transform.Transformer 中的方法
设置转换中实际的输出属性。
setOutputStream(OutputStream) - 类 java.rmi.server.LogStream 中的方法
已过时。 无替代版本
setOutputStream(OutputStream) - 类 java.util.logging.StreamHandler 中的方法
更改输出流。
setOutputStream(OutputStream) - 类 javax.xml.transform.stream.StreamResult 中的方法
设置要写入的 ByteStream。
SetOverrideType - org.omg.CORBA 中的 类
标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。
SetOverrideType(int) - 类 org.omg.CORBA.SetOverrideType 的构造方法
根据 int 值构造一个 SetOverrideType 实例。
SetOverrideTypeHelper - org.omg.CORBA 中的 类
SetOverrideType 的 Helper。
SetOverrideTypeHelper() - 类 org.omg.CORBA.SetOverrideTypeHelper 的构造方法
setOverwriteMode(boolean) - 类 javax.swing.text.DefaultFormatter 中的方法
配置插入字符时的行为。
setOwner(Object) - 类 java.beans.XMLDecoder 中的方法
将此解码器的所有者设置为 owner。
setOwner(Object) - 类 java.beans.XMLEncoder 中的方法
将此编码器的所有者设置为 owner。
setPackageAssertionStatus(String, boolean) - 类 java.lang.ClassLoader 中的方法
为指定包设置默认断言状态。
setPadding(int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
setPage(int, Printable, PageFormat) - 类 java.awt.print.Book 中的方法
为指定的页码设置 PageFormat 和 Painter。
setPage(URL) - 类 javax.swing.JEditorPane 中的方法
设置当前要显示的 URL。
setPage(String) - 类 javax.swing.JEditorPane 中的方法
设置当前要显示的 URL。
setPageable(Pageable) - 类 java.awt.print.PrinterJob 中的方法
查询 document，以获得页面数和 Pageable 实例 document 中保存的每个页面的 PageFormat 和 Printable。
setPageIncrement(int) - 类 java.awt.Scrollbar 中的方法
已过时。 从 JDK version 1.1 开始，由 setBlockIncrement() 取代。
setPageRanges(int[][]) - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的页面范围。
setPageSize(int) - 接口 javax.sql.rowset.CachedRowSet 中的方法
设置 CachedRowSet 对象的页大小。
setPaint(Paint) - 类 java.awt.Graphics2D 中的方法
为 Graphics2D 上下文设置 Paint 属性。
setPaintLabels(boolean) - 类 javax.swing.JSlider 中的方法
确定是否在滑块上绘制标签。
setPaintMode() - 类 java.awt.Graphics 中的方法
设置将此图形上下文的绘图模式，以便通过此图形上下文中的当前颜色来覆盖目标。
setPaintMode() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.setPaintMode。
setPaintTicks(boolean) - 类 javax.swing.JSlider 中的方法
确定是否在滑块上绘制刻度标记。
setPaintTrack(boolean) - 类 javax.swing.JSlider 中的方法
确定是否在滑块上绘制滑道。
setPalette(boolean) - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
setPalette(boolean) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
setPaper(Paper) - 类 java.awt.print.PageFormat 中的方法
为此 PageFormat 设置 Paper 对象。
setParagraphAttributes(AttributeSet, boolean) - 类 javax.swing.JTextPane 中的方法
将给定属性应用于段落。
setParagraphAttributes(int, int, AttributeSet, boolean) - 类 javax.swing.text.DefaultStyledDocument 中的方法
设置段落属性。
setParagraphAttributes(int, int, AttributeSet, boolean) - 类 javax.swing.text.html.HTMLDocument 中的方法
设置段落属性。
setParagraphAttributes(int, int, AttributeSet, boolean) - 接口 javax.swing.text.StyledDocument 中的方法
设置段落属性。
setParagraphAttributes(JEditorPane, AttributeSet, boolean) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 中的方法
对段落应用给定的属性。
setParagraphInsets(AttributeSet) - 类 javax.swing.text.CompositeView 中的方法
按照给定属性中指定的段落属性设置 insets。
setParameter(String, Object) - 类 java.security.Signature 中的方法
已过时。 使用 setParameter 取代。
setParameter(AlgorithmParameterSpec) - 类 java.security.Signature 中的方法
使用指定的参数集初始化此签名引擎。
setParameter(String, String) - 类 javax.activation.MimeType 中的方法
将值设置为与给定的名称关联，替换以前的任何关联。
setParameter(String, Object) - 类 javax.xml.transform.Transformer 中的方法
添加一个转换参数。
setParameter(String, Object) - 接口 org.w3c.dom.DOMConfiguration 中的方法
设置参数的值。
setParameterBlock(ParameterBlock) - 类 java.awt.image.renderable.RenderableImageOp 中的方法
更改操作的当前 ParameterBlock，允许编辑图像呈现链。
setParameters(Vector<Object>) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将参数的整个 Vector 设置为给定 Vector。
setParameters(Object[]) - 类 java.util.logging.LogRecord 中的方法
设置日志消息的参数。
setParent(Logger) - 类 java.util.logging.Logger 中的方法
设置此 Logger 的父 Logger。
setParent(ResourceBundle) - 类 java.util.ResourceBundle 中的方法
设置此包的父包。
setParent(ActionMap) - 类 javax.swing.ActionMap 中的方法
设置此 ActionMap 的父级。
setParent(InputMap) - 类 javax.swing.ComponentInputMap 中的方法
设置父组件，该组件必须是一个和与此 ComponentInputMap 相同的组件相关联的 ComponentInputMap。
setParent(InputMap) - 类 javax.swing.InputMap 中的方法
设置此 InputMap 的父级。
setParent(View) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图的父级。
setParent(View) - 类 javax.swing.text.ComponentView 中的方法
为子视图设置父级。
setParent(View) - 类 javax.swing.text.CompositeView 中的方法
设置此视图的父级。
setParent(View) - 类 javax.swing.text.FlowView 中的方法
设置此视图的父级。
setParent(View) - 类 javax.swing.text.html.BlockView 中的方法
建立此视图的父视图。
setParent(View) - 类 javax.swing.text.html.ImageView 中的方法
建立此视图的父视图。
setParent(View) - 类 javax.swing.text.html.ParagraphView 中的方法
建立此视图的父视图。
setParent(View) - 类 javax.swing.text.View 中的方法
为此视图建立父视图。
setParent(MutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
将此节点的父节点设置为 newParent，但不更改父节点的子节点数组。
setParent(MutableTreeNode) - 接口 javax.swing.tree.MutableTreeNode 中的方法
将接收者的父对象设置为 newParent。
setParent(Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 中的方法
设置父节点。
setParent(XMLEventReader) - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
设置此实例的父实例。
setParent(XMLStreamReader) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
设置此实例的父实例。
setParent(XMLReader) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置父读取器。
setParent(XMLReader) - 接口 org.xml.sax.XMLFilter 中的方法
设置父阅读器。
setParentElement(SOAPElement) - 接口 javax.xml.soap.Node 中的方法
将此 Node 对象的父节点设置为给定的 SOAPElement 对象。
setParseBigDecimal(boolean) - 类 java.text.DecimalFormat 中的方法
设置 DecimalFormat.parse(java.lang.String, java.text.ParsePosition) 方法是否返回 BigDecimal。
setParseIntegerOnly(boolean) - 类 java.text.NumberFormat 中的方法
设置数是否应该仅作为整数进行解析。
setParser(HTMLEditorKit.Parser) - 类 javax.swing.text.html.HTMLDocument 中的方法
设置将 html 插入现有文档的方法所使用的解析器，例如 setInnerHTML 和 setOuterHTML。
setPartialReturn(boolean) - 类 javax.swing.text.Segment 中的方法
指示部分返回有效的标记。
setPassword(char[]) - 类 javax.security.auth.callback.PasswordCallback 中的方法
设置获取到的密码。
setPassword(String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将用于创建此 RowSet 对象的数据库连接的密码设置为给定的 String 对象。
setPassword(String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的数据库密码设置为给定的 String。
setPath(String) - 类 java.net.HttpCookie 中的方法
指定客户机应该返回 cookie 的路径。
setPathToNames(Collection<List<?>>) - 类 java.security.cert.X509CertSelector 中的方法
设置 pathToNames 标准。
setPatternSeparator(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于在模式中分隔正数和负数子模式的字符。
setPayload(Source) - 接口 javax.xml.ws.LogicalMessage 中的方法
设置消息负载
setPayload(Object, JAXBContext) - 接口 javax.xml.ws.LogicalMessage 中的方法
设置消息负载
setPercent(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于百分数符号的字符。
setPerformancePreferences(int, int, int) - 类 java.net.ServerSocket 中的方法
设置此 ServerSocket 的性能首选项。
setPerformancePreferences(int, int, int) - 类 java.net.Socket 中的方法
设置此套接字的性能偏好。
setPerformancePreferences(int, int, int) - 类 java.net.SocketImpl 中的方法
设置此套接字的性能偏好 (performance preferences)。
setPerMill(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于千分数符号的字符。
setPersistenceDelegate(Class<?>, PersistenceDelegate) - 类 java.beans.Encoder 中的方法
将与此 type 相关联的持久委托设置为 persistenceDelegate。
setPitchBend(int) - 接口 javax.sound.midi.MidiChannel 中的方法
更改此通道上所有音符的音高偏移量。
setPixel(int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
使用输入样本的 int 数组设置 DataBuffer 中的像素。
setPixel(int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
使用输入样本的 int 数组设置 DataBuffer 中的像素。
setPixel(int, int, int[], DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
使用输入的 int 数组设置 DataBuffer 中的某个像素。
setPixel(int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 int 样本数组设置 DataBuffer 中的像素。
setPixel(int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 float 样本数组设置 DataBuffer 中的像素。
setPixel(int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 double 样本数组设置 DataBuffer 中的像素。
setPixel(int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
使用输入样本的 int 数组设置 DataBuffer 中的像素。
setPixel(int, int, int[]) - 类 java.awt.image.WritableRaster 中的方法
使用输入样本的 int 型数组设置 DataBuffer 中的像素。
setPixel(int, int, float[]) - 类 java.awt.image.WritableRaster 中的方法
使用输入样本的 float 型数组设置 DataBuffer 中的像素。
setPixel(int, int, double[]) - 类 java.awt.image.WritableRaster 中的方法
使用输入样本的 double 型数组设置 DataBuffer 中的像素。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.AreaAveragingScaleFilter 中的方法
将已传送 byte 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.AreaAveragingScaleFilter 中的方法
将已传送 int 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。
setPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
根据 int 数组设置对应于像素矩形的所有样本，int 数组中每个数组元素包含一个样本。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.BufferedImageFilter 中的方法
过滤 ImageConsumer 接口（采用字节数组）的 setPixels 方法中提供的信息。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.BufferedImageFilter 中的方法
过滤 ImageConsumer 接口（采用整数数组）的 setPixels 方法中提供的信息。
setPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
根据 int 数组（每个数组元素包含一个样本）设置对应于像素矩形区域的所有样本。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.CropImageFilter 中的方法
确定已传递的字节像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.CropImageFilter 中的方法
确定已传递的 int 像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 接口 java.awt.image.ImageConsumer 中的方法
一次或多次调用此方法来传递图像的像素。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 接口 java.awt.image.ImageConsumer 中的方法
一次或多次调用 setPixels 方法来传递图像的像素。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.ImageFilter 中的方法
过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以 byte 数组为参数。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.ImageFilter 中的方法
过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以整数数组为参数。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.PixelGrabber 中的方法
setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.PixelGrabber 中的方法
setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.ReplicateScaleFilter 中的方法
从传递的 byte pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.ReplicateScaleFilter 中的方法
从传递的 int pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.RGBImageFilter 中的方法
如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.RGBImageFilter 中的方法
如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素，否则，将整数像素的缓冲区转换为默认 RGB ColorModel，并将转换后的缓冲区传递给 filterRGBPixels 方法进行逐一转换。
setPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
setPixels(int, int, int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 float 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
setPixels(int, int, int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 double 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
setPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
setPixels(int, int, int, int, int[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 int 型数组中的像素矩形设置所有样本。
setPixels(int, int, int, int, float[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 float 型数组中的像素矩形设置所有样本。
setPixels(int, int, int, int, double[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 double 型数组中的像素矩形设置所有样本。
setPlaceholder(String) - 类 javax.swing.text.MaskFormatter 中的方法
设置值未完全填充掩码时要使用的字符串。
setPlaceholderCharacter(char) - 类 javax.swing.text.MaskFormatter 中的方法
设置一个字符，用来替代值中不存在的字符（即用户必须填充它们）。
setPolicy(Set<String>) - 类 java.security.cert.X509CertSelector 中的方法
设置策略限制。
setPolicy(Policy) - 类 java.security.Policy 中的静态方法
设置系统范围的 Policy 对象。
setPolicy(Policy) - 类 javax.security.auth.Policy 中的静态方法
已过时。 设置系统级 Policy 对象。
setPolicyMappingInhibited(boolean) - 类 java.security.cert.PKIXParameters 中的方法
设置 PolicyMappingInhibited 标志。
setPolicyQualifiersRejected(boolean) - 类 java.security.cert.PKIXParameters 中的方法
设置 PolicyQualifiersRejected 标志。
setPolyPressure(int, int) - 接口 javax.sound.midi.MidiChannel 中的方法
对指定音符键力度的更改作出反应。
setPoolable(boolean) - 接口 java.sql.Statement 中的方法
请求将 Statement 池化或非池化。
setPopupMenu(PopupMenu) - 类 java.awt.TrayIcon 中的方法
设置此 TrayIcon 的弹出菜单。
setPopupMenuVisible(boolean) - 类 javax.swing.JMenu 中的方法
设置菜单弹出的可见性。
setPopupSize(Dimension) - 类 javax.swing.JPopupMenu 中的方法
使用 Dimension 对象设置弹出窗口的大小。
setPopupSize(int, int) - 类 javax.swing.JPopupMenu 中的方法
将弹出窗口的大小设置为指定的宽度和高度。
setPopupVisible(boolean) - 类 javax.swing.JComboBox 中的方法
设置弹出窗口的可见性。
setPopupVisible(JComboBox, boolean) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
隐藏弹出部分。
setPopupVisible(JComboBox, boolean) - 类 javax.swing.plaf.ComboBoxUI 中的方法
设置弹出菜单的可见性
setPopupVisible(JComboBox, boolean) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 setPopupVisible 方法。
setPort(int) - 类 java.net.DatagramPacket 中的方法
设置要将此数据报发往的远程主机上的端口号。
setPortlist(String) - 类 java.net.HttpCookie 中的方法
指定 cookie 的端口列表，该列表在 Cookie 头中限制可能将 cookie 发送回的端口。
setPosition(int) - 类 java.awt.font.LineBreakMeasurer 中的方法
设置此 LineBreakMeasurer 的当前位置。
setPosition(Component, int) - 类 javax.swing.JLayeredPane 中的方法
将该组件移到当前层中的 position 处，其中 0 表示该层中的最顶层位置，-1 表示最底层位置。
setPositivePrefix(String) - 类 java.text.DecimalFormat 中的方法
设置正数前缀。
setPositiveSuffix(String) - 类 java.text.DecimalFormat 中的方法
设置正数后缀。
setPrecision(int, int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将存储在指定列中的值的小数位数的总数设置为给定数。
setPrecision(int, int) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的小数位数设置为给定的 int。
setPreferred(boolean) - 类 java.beans.FeatureDescriptor 中的方法
"preferred" 标志用于标识呈现给用户的特别重要的特性。
setPreferredMinSize(Dimension) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
设置首选最小大小。
setPreferredScrollableViewportSize(Dimension) - 类 javax.swing.JTable 中的方法
设置此表视口的首选大小。
setPreferredSize(Dimension) - 类 java.awt.Component 中的方法
将组件的首选大小设置为常量值。
setPreferredSize(Dimension) - 类 javax.swing.JComponent 中的方法
设置此组件的首选大小。
setPreferredWidth(int) - 类 javax.swing.table.TableColumn 中的方法
将此列的首选宽度设置为 preferredWidth。
setPrefix(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
不执行任何操作，因为不支持名称空间。
setPrefix(String, String) - 接口 javax.xml.stream.XMLEventWriter 中的方法
设置绑定 URI 的前缀。
setPrefix(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
设置绑定 URI 的前缀。
setPrefix(String) - 接口 org.w3c.dom.Node 中的方法
此节点的名称空间前缀；如果未指定，则为 null。
setPreservesUnknownTags(boolean) - 类 javax.swing.text.html.HTMLDocument 中的方法
确定解析器如何处理未知标记。
setPressed(boolean) - 接口 javax.swing.ButtonModel 中的方法
将按钮设置为按下或未被按下。
setPressed(boolean) - 类 javax.swing.DefaultButtonModel 中的方法
将按钮设置为按下或未被按下。
setPressed(boolean) - 类 javax.swing.JToggleButton.ToggleButtonModel 中的方法
设置切换按钮按下时的状态。
setPressedIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的按下图标。
setPreviewPanel(JComponent) - 类 javax.swing.JColorChooser 中的方法
设置当前预览面板。
setPreviousBounds(JInternalFrame, Rectangle) - 类 javax.swing.DefaultDesktopManager 中的方法
在进行 maximize 调用之前存储组件的边界。
setPrimaryType(String) - 类 javax.activation.MimeType 中的方法
将此对象的基本类型设置为给定的 String。
setPrincipal(Principal) - 接口 java.security.acl.AclEntry 中的方法
指定此 ACL 项要为其授予或拒绝权限的主体。
setPrintable(Printable) - 类 java.awt.print.PrinterJob 中的方法
调用 painter 以呈现页面。
setPrintable(Printable, PageFormat) - 类 java.awt.print.PrinterJob 中的方法
调用 painter，用指定的 format 呈现该页面。
setPrinter(String) - 类 java.awt.JobAttributes 中的方法
为使用这些属性的作业指定目标打印机。
setPrinterResolution(int[]) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面所需的打印分辨率。
setPrinterResolution(int) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面所需的反向进纸和进纸的打印分辨率，分辨率以每英寸的点数为单位。
setPrinterResolutionToDefault() - 类 java.awt.PageAttributes 中的方法
将使用这些属性的页面的打印机分辨率设置为默认值。
setPrintQuality(PageAttributes.PrintQualityType) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面的打印质量。
setPrintQuality(int) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面的打印质量。
setPrintQualityToDefault() - 类 java.awt.PageAttributes 中的方法
将使用这些属性的页面的打印质量设置为默认值。
setPrintService(PrintService) - 类 java.awt.print.PrinterJob 中的方法
将此 PrinterJob 与新的 PrintService 关联。
setPriority(int) - 类 java.lang.Thread 中的方法
更改线程的优先级。
setPrivacy(boolean) - 类 org.ietf.jgss.MessageProp 中的方法
设置私密状态。
setPrivateKeyValid(Date) - 类 java.security.cert.X509CertSelector 中的方法
设置 privateKeyValid 标准。
setProblemType(int) - 类 javax.management.relation.RoleUnresolved 中的方法
设置问题类型。
setProcessors(Iterable<? extends Processor>) - 接口 javax.tools.JavaCompiler.CompilationTask 中的方法
设置处理器（用于注释处理）。
setProgress(int) - 类 javax.swing.ProgressMonitor 中的方法
指示正被监视操作的进度。
setProgress(int) - 类 javax.swing.SwingWorker 中的方法
设置 progress 绑定属性。
setProgressiveMode(int) - 类 javax.imageio.ImageWriteParam 中的方法
指定 writer 使用逐步模式写出图像，从而输出流将包含一系列质量递增的扫描。
setPropagatedFrom(BeanContext) - 类 java.beans.beancontext.BeanContextEvent 中的方法
设置作为此事件传播源的 BeanContext。
setPropagationId(Object) - 类 java.beans.PropertyChangeEvent 中的方法
设置事件的 propagationId 对象。
setProperties(Hashtable<?, ?>) - 类 java.awt.image.CropImageFilter 中的方法
添加指示裁剪区域的属性后传递源对象的属性。
setProperties(Hashtable<?, ?>) - 接口 java.awt.image.ImageConsumer 中的方法
设置与此图像关联的可扩展属性列表。
setProperties(Hashtable<?, ?>) - 类 java.awt.image.ImageFilter 中的方法
添加一个属性，来指示已通过的过滤器流，并在这之后从源对象传递这些属性。
setProperties(Hashtable<?, ?>) - 类 java.awt.image.PixelGrabber 中的方法
setProperties 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setProperties(Hashtable<?, ?>) - 类 java.awt.image.ReplicateScaleFilter 中的方法
在添加一个指示所应用的缩放比例的属性后传递来自源对象的属性。
setProperties(Properties) - 类 java.lang.System 中的静态方法
将系统属性设置为 Properties 参数。
setProperties(Map<String, Object>) - 类 javax.xml.ws.Endpoint 中的方法
设置此 Endpoint 实例的属性包。
setPropertiesFromAttributes() - 类 javax.swing.text.html.BlockView 中的方法
更新来自属性的任何缓存的值。
setPropertiesFromAttributes() - 类 javax.swing.text.html.ImageView 中的方法
更新来自属性的任何缓存的值。
setPropertiesFromAttributes() - 类 javax.swing.text.html.InlineView 中的方法
从 attribute 设置缓存的属性。
setPropertiesFromAttributes() - 类 javax.swing.text.html.ListView 中的方法
setPropertiesFromAttributes() - 类 javax.swing.text.html.ParagraphView 中的方法
通过 css 属性设置段落，而不是根据 StyleConstants 中的值（即超类所使用的值）设置段落。
setPropertiesFromAttributes() - 类 javax.swing.text.LabelView 中的方法
从属性集设置缓存的属性。
setPropertiesFromAttributes() - 类 javax.swing.text.ParagraphView 中的方法
从属性集设置缓存的属性。
setProperty(String, String) - 类 java.lang.System 中的静态方法
设置指定键指示的系统属性。
setProperty(String, String) - 类 java.security.Security 中的静态方法
设置安全属性值。
setProperty(String, String) - 类 java.util.Properties 中的方法
调用 Hashtable 的方法 put。
setProperty(String, Object) - 类 javax.xml.bind.Binder 中的方法
设置 Binder 的基础实现中的特定属性。
setProperty(String, Object) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。
setProperty(String, Object) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
由于没有必需的属性，setProperty 方法的默认实现总是抛出 PropertyException。
setProperty(String, Object) - 接口 javax.xml.bind.Marshaller 中的方法
设置 Marshaller 底层实现中的特定属性。
setProperty(String, Object) - 接口 javax.xml.bind.Unmarshaller 中的方法
设置 Unmarshaller 底层实现中的特定属性。
setProperty(String, Object) - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
setProperty(String, Object) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 将名称映射到指定对象。
setProperty(String, Object) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
设置指定的属性。
setProperty(String, Object) - 类 javax.xml.parsers.SAXParser 中的方法
设置 XMLReader 的底层实现中的特定属性。
setProperty(String, Object) - 类 javax.xml.soap.SOAPMessage 中的方法
将指定值与指定属性关联。
setProperty(String, Object) - 类 javax.xml.stream.XMLInputFactory 中的方法
允许用户在底层实现上设置特定功能/属性。
setProperty(String, Object) - 类 javax.xml.stream.XMLOutputFactory 中的方法
允许用户在底层实现上设置特定功能/属性。
setProperty(String, Object) - 类 javax.xml.validation.SchemaFactory 中的方法
设置属性值。
setProperty(String, Object) - 类 javax.xml.validation.Validator 中的方法
设置属性值。
setProperty(String, Object) - 类 javax.xml.validation.ValidatorHandler 中的方法
设置属性值。
setProperty(String, Object) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
设置解析器属性。
setProperty(String, Object) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置属性值。
setProperty(String, Object) - 接口 org.xml.sax.XMLReader 中的方法
设置属性的值。
setPropertyEditorClass(Class<?>) - 类 java.beans.PropertyDescriptor 中的方法
通常 PropertyEditor 是使用 PropertyEditorManager 找到的。
setProtocols(String[]) - 类 javax.net.ssl.SSLParameters 中的方法
设置协议数组。
setPrototypeCellValue(Object) - 类 javax.swing.JList 中的方法
设置 prototypeCellValue 属性，然后（如果新值为非 null）计算 fixedCellWidth 和 fixedCellHeight 属性：请求单元渲染器组件提供单元渲染器的给定值（及索引 0），并使用该组件的首选大小。
setPrototypeDisplayValue(Object) - 类 javax.swing.JComboBox 中的方法
设置用于计算 UI 部分的显示大小的原型显示值。
setPublicId(String) - 类 javax.xml.transform.stream.StreamSource 中的方法
设置此 Source 的公共标识符。
setPublicId(String) - 接口 org.w3c.dom.ls.LSInput 中的方法
此输入源的公共标识符。
setPublicId(String) - 类 org.xml.sax.helpers.LocatorImpl 中的方法
设置此定位器的公开标识符。
setPublicId(String) - 类 org.xml.sax.InputSource 中的方法
设置此输入源的公共标识符。
setPublicKey(PublicKey) - 类 java.security.Identity 中的方法
已过时。 设置此 Identity 的公钥。
setPurgeFlag(boolean) - 类 javax.management.relation.RelationService 中的方法
设置一个标志，以指示注销关系中引用的 MBean 时是否接收通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。
setPurgeFlag(boolean) - 接口 javax.management.relation.RelationServiceMBean 中的方法
设置一个标志，以指示注销关系中引用的 MBean 时是否接收到通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。
setPushLevel(Level) - 类 java.util.logging.MemoryHandler 中的方法
设置 pushLevel。
setQName(int, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
设置特定属性的限定名称。
setQOP(int) - 类 org.ietf.jgss.MessageProp 中的方法
设置 QOP 值。
setQueryTimeout(int) - 接口 java.sql.Statement 中的方法
将驱动程序等待 Statement 对象执行的秒数设置为给定秒数。
setQueryTimeout(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将驱动程序等待查询执行的最大秒数设置为给定的数。
setQueryTimeout(int) - 接口 javax.sql.RowSet 中的方法
将驱动程序等待语句执行的最大秒数设置为给定的秒数。
setRangeProperties(int, int, int, int, boolean) - 接口 javax.swing.BoundedRangeModel 中的方法
此方法使用一个方法调用设置模型的所有数据。
setRangeProperties(int, int, int, int, boolean) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
在强行使参数满足以下常规约束条件之后，设置所有的 BoundedRangeModel 属性： minimum <= value <= value+extent <= maximum 至多生成一个 ChangeEvent。
setRaster(Raster) - 类 javax.imageio.IIOImage 中的方法
设置当前 Raster。
setRawContent(InputStream, String) - 类 javax.xml.soap.AttachmentPart 中的方法
将此附件部分的内容设置为 InputStream content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。
setRawContentBytes(byte[], int, int, String) - 类 javax.xml.soap.AttachmentPart 中的方法
将此附件部分的内容设置为 byte[] 数组 content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。
setRawOffset(int) - 类 java.util.SimpleTimeZone 中的方法
把基准时区偏移量设置到 GMT。
setRawOffset(int) - 类 java.util.TimeZone 中的方法
把基准时区偏移量设置到 GMT。
setReadable(boolean, boolean) - 类 java.io.File 中的方法
设置此抽象路径名的所有者或所有用户的读权限。
setReadable(boolean) - 类 java.io.File 中的方法
设置此抽象路径名所有者读权限的一个便捷方法。
setReader(Reader) - 接口 javax.script.ScriptContext 中的方法
设置脚本的 Reader，以读取输入。
setReader(Reader) - 类 javax.script.SimpleScriptContext 中的方法
设置脚本的 Reader，以读取输入。
setReader(Reader) - 类 javax.xml.transform.stream.StreamSource 中的方法
调用要作为字符 reader 的输入。
setReadMethod(Method) - 类 java.beans.PropertyDescriptor 中的方法
设置应该用于读取属性值的方法。
setReadOnly() - 类 java.io.File 中的方法
标记此抽象路径名指定的文件或目录，从而只能对其进行读操作。
setReadOnly() - 类 java.security.PermissionCollection 中的方法
将此 PermissionCollection 对象标记为 "readonly"。
setReadOnly(boolean) - 接口 java.sql.Connection 中的方法
将此连接设置为只读模式，作为驱动程序启用数据库优化的提示。
setReadOnly() - 类 javax.security.auth.Subject 中的方法
将此 Subject 设置为只读的。
setReadOnly(boolean) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的 readOnly 属性设置为给定的 boolean 值。
setReadOnly(boolean) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的只读性设置为给定的 boolean 值。
setReadTimeout(int) - 类 java.net.URLConnection 中的方法
将读超时设置为指定的超时值，以毫秒为单位。
setReceiveBufferSize(int) - 类 java.net.DatagramSocket 中的方法
将此 DatagramSocket 的 SO_RCVBUF 选项设置为指定的值。
setReceiveBufferSize(int) - 类 java.net.ServerSocket 中的方法
为从此 ServerSocket 接受的套接字的 SO_RCVBUF 选项设置默认建议值。
setReceiveBufferSize(int) - 类 java.net.Socket 中的方法
将此 Socket 的 SO_RCVBUF 选项设置为指定的值。
setReceiver(Receiver) - 接口 javax.sound.midi.Transmitter 中的方法
设置此传输器将向其传送 MIDI 消息的接收器。
setRect(double, double, double, double) - 类 java.awt.geom.Rectangle2D.Double 中的方法
将此 Rectangle2D 的位置和大小设置为指定的 double 值。
setRect(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Double 中的方法
将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
setRect(float, float, float, float) - 类 java.awt.geom.Rectangle2D.Float 中的方法
将此 Rectangle2D 的位置和大小设置为指定的 float 值。
setRect(double, double, double, double) - 类 java.awt.geom.Rectangle2D.Float 中的方法
将此 Rectangle2D 的位置和大小设置为指定的 double 值。
setRect(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Float 中的方法
将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
setRect(double, double, double, double) - 类 java.awt.geom.Rectangle2D 中的方法
将此 Rectangle2D 的位置和大小设置为指定的 double 值。
setRect(Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的方法
将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
setRect(Raster) - 类 java.awt.image.WritableRaster 中的方法
将像素从 Raster srcRaster 复制到此 WritableRaster。
setRect(int, int, Raster) - 类 java.awt.image.WritableRaster 中的方法
将像素从 Raster srcRaster 复制到此 WritableRaster。
setRect(double, double, double, double) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 的边界设置为整数边界，它包含指定的 x、y、width 和 height。
setRef(RemoteStub, RemoteRef) - 类 java.rmi.server.RemoteStub 中的静态方法
已过时。 无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。
setRef(int, Ref) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 REF(<structured-type>) 值。
setRef(int, Ref) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 Ref 对象。
setRef(int, Ref) - 接口 javax.sql.RowSet 中的方法
使用给定 Ref 值设置此 RowSet 对象命令中的指定参数。
setRejectedExecutionHandler(RejectedExecutionHandler) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
设置用于未执行任务的新处理程序。
setRelationServiceManagementFlag(Boolean) - 类 javax.management.relation.RelationSupport 中的方法
setRelationServiceManagementFlag(Boolean) - 接口 javax.management.relation.RelationSupportMBean 中的方法
指定此关系是否由 Relation Service 处理。
setRelative(boolean) - 类 javax.naming.NameClassPair 中的方法
设置此绑定的名称是否相对于目标上下文（由 list() 方法的第一个参数命名）。
setRelay(boolean) - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
将此 SOAPHeaderElement 的 relay 属性设置为 true 或 false。
setRemainingName(Name) - 异常 javax.naming.NamingException 中的方法
设置此异常的剩余名称字段。
setRemainingName(Name) - 类 javax.naming.spi.ResolveResult 中的方法
将此结果的剩余名称字段设置为 name。
setRemainingNewName(Name) - 异常 javax.naming.CannotProceedException 中的方法
设置此异常的 "remaining new name" 字段。
setRenderContext(RenderContext) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
设置下一次调用 startProduction() 要使用的新 RenderContext。
setRenderedImage(RenderedImage) - 类 javax.imageio.IIOImage 中的方法
设置当前 RenderedImage。
setRenderer(ListCellRenderer) - 类 javax.swing.JComboBox 中的方法
设置渲染器，该渲染器用于绘制列表项和从 JComboBox 字段的列表中选择的项。
setRenderingHint(RenderingHints.Key, Object) - 类 java.awt.Graphics2D 中的方法
为呈现算法设置单个首选项的值。
setRenderingHints(Map<?, ?>) - 类 java.awt.Graphics2D 中的方法
使用指定的 hints 替换用于所有呈现算法首选项的值。
setRenderingHints(RenderingHints) - 类 java.awt.image.renderable.RenderContext 中的方法
设置此 RenderContext 的呈现提示。
setReorderingAllowed(boolean) - 类 javax.swing.table.JTableHeader 中的方法
设置用户是否可以拖动列头，以重新排序各列。
setRepeats(boolean) - 类 javax.swing.Timer 中的方法
如果 flag 为 false，则指示 Timer 只向其侦听器发送一次动作事件。
setRequestControls(Control[]) - 类 javax.naming.ldap.InitialLdapContext 中的方法
setRequestControls(Control[]) - 接口 javax.naming.ldap.LdapContext 中的方法
为在此上下文上后续调用的方法设置请求控件。
setRequestFocusEnabled(boolean) - 类 javax.swing.JComponent 中的方法
提供一个关于此 JComponent 是否应该获得焦点的提示。
setRequestMethod(String) - 类 java.net.HttpURLConnection 中的方法
设置 URL 请求的方法， GET POST HEAD OPTIONS PUT DELETE TRACE 以上方法之一是合法的，具体取决于协议的限制。
setRequestProperty(String, String) - 类 java.net.URLConnection 中的方法
设置一般请求属性。
setReshowDelay(int) - 类 javax.swing.ToolTipManager 中的方法
在显示工具提示之前，用于指定用户必须等待 initialDelay 毫秒之前的时间。
setResizable(boolean) - 类 java.awt.Dialog 中的方法
设置此 dialog 是否可以由用户调整大小。
setResizable(boolean) - 类 java.awt.Frame 中的方法
设置此窗体是否可由用户调整大小。
setResizable(boolean) - 类 javax.swing.JInternalFrame 中的方法
设置是否可以通过某个用户操作调整 JInternalFrame 的大小。
setResizable(boolean) - 类 javax.swing.table.TableColumn 中的方法
设置是否可以调整此列的大小。
setResizeWeight(double) - 类 javax.swing.JSplitPane 中的方法
指定当分隔窗格的大小改变时如何分配额外空间。
setResizingAllowed(boolean) - 类 javax.swing.table.JTableHeader 中的方法
设置用户是否可以通过在头间拖动来调整各列的大小。
setResizingColumn(TableColumn) - 类 javax.swing.table.JTableHeader 中的方法
将头的 resizingColumn 设置为 aColumn。
setResolvedName(Name) - 异常 javax.naming.NamingException 中的方法
设置此异常的已解析名称字段。
setResolvedObj(Object) - 异常 javax.naming.NamingException 中的方法
设置此异常的已解析对象字段。
setResolvedObj(Object) - 类 javax.naming.spi.ResolveResult 中的方法
将此结果的已解析 Object 字段设置为 obj。
setResolvedValue(int, Object) - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
将 obj 设置为将同步的 RowSet 对象当前行中第 index 列的值。
setResolvedValue(String, Object) - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
将 obj 设置为将同步的 RowSet 对象当前行中列 columnName 的值。
setResolveParent(AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
设置要解析的父级。
setResolveParent(Keymap) - 接口 javax.swing.text.Keymap 中的方法
设置将用于解析键绑定的父级 keymap。
setResolveParent(AttributeSet) - 接口 javax.swing.text.MutableAttributeSet 中的方法
设置正解析的父级。
setResolveParent(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 中的方法
设置解析的父级。
setResolveParent(AttributeSet) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
设置解析的父级。
setResourceBaseName(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
设置用于查找包含此格式的元素和属性描述的 ResourceBundle 新基本名称。
setResourceBundle(ResourceBundle) - 类 java.util.logging.LogRecord 中的方法
设置本地化资源包。
setResourceBundleName(String) - 类 java.util.logging.LogRecord 中的方法
设置本地化资源包名称。
setResourceResolver(LSResourceResolver) - 类 javax.xml.validation.SchemaFactory 中的方法
设置 LSResourceResolver 以自定义解析模式时的资源解析。
setResourceResolver(LSResourceResolver) - 类 javax.xml.validation.Validator 中的方法
设置 LSResourceResolver 以自定义验证期间的资源解析。
setResourceResolver(LSResourceResolver) - 类 javax.xml.validation.ValidatorHandler 中的方法
设置 LSResourceResolver 以自定义验证期间的资源解析。
setResult(Class<T>) - 接口 java.sql.SQLXML 中的方法
返回设置此 SQLXML 实例指定的 XML 值的 Result。
setResult(Result) - 接口 javax.xml.transform.sax.TransformerHandler 中的方法
设置与用于转换的此 TransformerHandler 关联的 Result。
setReturningAttributes(String[]) - 类 javax.naming.directory.SearchControls 中的方法
指定将作为搜索的一部分返回的属性。
setReturningObjFlag(boolean) - 类 javax.naming.directory.SearchControls 中的方法
启用/禁用作为结果的一部分返回所返回对象。
setReuseAddress(boolean) - 类 java.net.DatagramSocket 中的方法
启用/禁用 SO_REUSEADDR 套接字选项。
setReuseAddress(boolean) - 类 java.net.ServerSocket 中的方法
启用/禁用 SO_REUSEADDR 套接字选项。
setReuseAddress(boolean) - 类 java.net.Socket 中的方法
启用/禁用 SO_REUSEADDR 套接字选项。
setRevocationEnabled(boolean) - 类 java.security.cert.PKIXParameters 中的方法
设置 RevocationEnabled 标志。
setRGB(int, int, int) - 类 java.awt.image.BufferedImage 中的方法
将此 BufferedImage 中的像素设置为指定的 RGB 值。
setRGB(int, int, int, int, int[], int, int) - 类 java.awt.image.BufferedImage 中的方法
将默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中的整数像素数组设置为图像数据的一部分。
setRightChildIndent(int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
setRightComponent(Component) - 类 javax.swing.JSplitPane 中的方法
将组件设置到分隔条的右边（或者下面）。
setRightIndent(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置右边缩进。
setRightInset(float) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图四周右侧的空白部分。
setRole(Role) - 接口 javax.management.relation.Relation 中的方法
设置给定角色。
setRole(String, Role) - 类 javax.management.relation.RelationService 中的方法
设置给定关系中的给定角色。
setRole(String, Role) - 接口 javax.management.relation.RelationServiceMBean 中的方法
以给定关系设置给定角色。
setRole(Role) - 类 javax.management.relation.RelationSupport 中的方法
设置给定的角色。
setRole(String) - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
将与此 SOAPHeaderElement 对象关联的 Role 设置为指定 Role。
setRoleName(String) - 类 javax.management.relation.Role 中的方法
设置角色名称。
setRoleName(String) - 类 javax.management.relation.RoleUnresolved 中的方法
设置角色名称。
setRoles(RoleList) - 接口 javax.management.relation.Relation 中的方法
设置给定的角色。
setRoles(String, RoleList) - 类 javax.management.relation.RelationService 中的方法
设置给定关系中的给定角色。
setRoles(String, RoleList) - 接口 javax.management.relation.RelationServiceMBean 中的方法
以给定关系设置给定角色。
setRoles(RoleList) - 类 javax.management.relation.RelationSupport 中的方法
设置给定的角色。
setRoles(RoleList) - 类 javax.management.relation.RoleResult 中的方法
设置成功访问的角色列表。
setRoles(Set<String>) - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
设置由 SOAP 绑定实例扮演的角色。
setRolesUnresolved(RoleUnresolvedList) - 类 javax.management.relation.RoleResult 中的方法
设置未成功访问的角色列表。
setRoleValue(List<ObjectName>) - 类 javax.management.relation.Role 中的方法
设置角色值。
setRoleValue(List<ObjectName>) - 类 javax.management.relation.RoleUnresolved 中的方法
设置角色值。
setRollover(boolean) - 接口 javax.swing.ButtonModel 中的方法
设置或清除该按钮的翻转状态
setRollover(boolean) - 类 javax.swing.DefaultButtonModel 中的方法
设置或清除该按钮的翻转状态
setRollover(boolean) - 类 javax.swing.JToolBar 中的方法
设置此工具栏的 rollover 状态。
setRolloverBorders(boolean) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
在工具栏上设置启用翻转边框的标志并根据标志的状态安装适当的边框。
setRolloverEnabled(boolean) - 类 javax.swing.AbstractButton 中的方法
设置 rolloverEnabled 属性，若需要翻转效果，该属性必须为 true。
setRolloverIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的翻转图标。
setRolloverSelectedIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的翻转选择图标。
setRolloverTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
将当前有鼠标位于其上方的选项卡设置为 index。
setRoot(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
将根设置为 root。
setRootCause(Throwable) - 异常 javax.naming.NamingException 中的方法
记录此 NamingException 的根 cause。
setRootFrame(Frame) - 类 javax.swing.JOptionPane 中的静态方法
设置窗体，以用于不提供窗体的类方法。
setRootPane(JRootPane) - 类 javax.swing.JApplet 中的方法
设置 rootPane 属性。
setRootPane(JRootPane) - 类 javax.swing.JDialog 中的方法
设置 rootPane 属性。
setRootPane(JRootPane) - 类 javax.swing.JFrame 中的方法
设置 rootPane 属性。
setRootPane(JRootPane) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 rootPane 属性。
setRootPane(JRootPane) - 类 javax.swing.JWindow 中的方法
设置此窗口的新 rootPane 对象。
setRootPaneCheckingEnabled(boolean) - 类 javax.swing.JApplet 中的方法
设置是否将对 add 和 setLayout 的调用转发给 contentPane。
setRootPaneCheckingEnabled(boolean) - 类 javax.swing.JDialog 中的方法
设置是否将对 add 和 setLayout 的调用转发到 contentPane。
setRootPaneCheckingEnabled(boolean) - 类 javax.swing.JFrame 中的方法
设置是否将对 add 和 setLayout 的调用转发到 contentPane。
setRootPaneCheckingEnabled(boolean) - 类 javax.swing.JInternalFrame 中的方法
设置是否将对 add 和 setLayout 的调用转发到 contentPane。
setRootPaneCheckingEnabled(boolean) - 类 javax.swing.JWindow 中的方法
设置对 add 和 setLayout 的调用是否转发到 contentPane。
setRootVisible(boolean) - 类 javax.swing.JTree 中的方法
确定 TreeModel 的根节点是否可见。
setRootVisible(boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
将根设置为可见。
setRootVisible(boolean) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
确定 TreeModel 的根节点是否可视。
setRootVisible(boolean) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
确定 TreeModel 的根节点是否可见。
setRootVisible(boolean) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
确定 TreeModel 的根节点是否可见。
setRoundingMode(RoundingMode) - 类 java.text.DecimalFormat 中的方法
设置在此 DecimalFormat 中使用的 RoundingMode。
setRoundingMode(RoundingMode) - 类 java.text.NumberFormat 中的方法
设置在此 NumberFormat 中使用的 RoundingMode。
setRoundRect(double, double, double, double, double, double) - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。
setRoundRect(RoundRectangle2D) - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
setRoundRect(float, float, float, float, float, float) - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 float 值。
setRoundRect(double, double, double, double, double, double) - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。
setRoundRect(RoundRectangle2D) - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
setRoundRect(double, double, double, double, double, double) - 类 java.awt.geom.RoundRectangle2D 中的方法
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。
setRoundRect(RoundRectangle2D) - 类 java.awt.geom.RoundRectangle2D 中的方法
将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
setRowCount(int) - 类 javax.swing.table.DefaultTableModel 中的方法
设置模型中的行数。
setRowFilter(RowFilter<? super M, ? super I>) - 类 javax.swing.DefaultRowSorter 中的方法
设置用于确定哪些行（如果有）应该在视图中隐藏的过滤器。
setRowHeader(JViewport) - 类 javax.swing.JScrollPane 中的方法
移除旧的 rowHeader，如果存在；如果新的 rowHeader 不为 null，将其 viewPosition 的 y 坐标与视口（如果有）同步然后将其添加到滚动窗格。
setRowHeaderView(Component) - 类 javax.swing.JScrollPane 中的方法
创建一个行标题视口（如果有必要），设置其视图然后将此行标题视口添加到滚动窗格。
setRowHeight(int) - 类 javax.swing.JTable 中的方法
将所有单元格的高度设置为 rowHeight（以像素为单位），重新验证并重新绘制它。
setRowHeight(int, int) - 类 javax.swing.JTable 中的方法
将 row 的高度设置为 rowHeight，重新验证并重新绘制它。
setRowHeight(int) - 类 javax.swing.JTree 中的方法
设置每个单元格的高度（以像素为单位）。
setRowHeight(int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
设置行高度，此方法将被转发到 treeState。
setRowHeight(int) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
设置每个单元的高度。
setRowHeight(int) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
设置每个单元格的高度。
setRowHeight(int) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
设置每个单元格的高度。
setRowId(String, RowId) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.sql.RowId 对象。
setRowId(int, RowId) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.RowId 对象。
setRowId(int, RowId) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.RowId 对象。
setRowId(String, RowId) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.RowId 对象。
setRowId(int, RowId) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.RowId 对象。
setRowId(String, RowId) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.RowId 对象。
setRowMapper(RowMapper) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
设置 RowMapper 实例。
setRowMapper(RowMapper) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
设置 RowMapper 实例。
setRowMargin(int) - 类 javax.swing.JTable 中的方法
设置相临行中单元格之间的间距。
setRows(int) - 类 java.awt.GridLayout 中的方法
将此布局中的行数设置为指定值。
setRows(int) - 类 java.awt.TextArea 中的方法
设置此文本区的行数。
setRows(int) - 类 javax.swing.JTextArea 中的方法
设置此 TextArea 的行数。
setRowSelectionAllowed(boolean) - 类 javax.swing.JTable 中的方法
设置是否可以选择此模型中的行。
setRowSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
选择从 index0 到 index1 之间（包含两端）的行。
setRowSorter(RowSorter<? extends TableModel>) - 类 javax.swing.JTable 中的方法
设置 RowSorter。
setSample(int, int, int, int, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
使用输入的 int 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, float, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
使用输入的 float 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, double, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
使用输入的 double 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, int, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
使用输入的 int 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, float, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
使用输入的 float 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, double, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
使用输入的 double 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, int, DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
使用输入的 int，设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
setSample(int, int, int, int, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
setSample(int, int, int, float, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 float 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
setSample(int, int, int, double, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 double 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
setSample(int, int, int, int, DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
setSample(int, int, int, int) - 类 java.awt.image.WritableRaster 中的方法
使用 int 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。
setSample(int, int, int, float) - 类 java.awt.image.WritableRaster 中的方法
使用 float 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。
setSample(int, int, int, double) - 类 java.awt.image.WritableRaster 中的方法
使用 double 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。
setSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
根据 int 数组设置指定 band 中对应于指定像素矩形的样本，int 数组中每个数据数组元素包含一个样本。
setSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
根据 int 数组（每个数据数组元素包含一个样本），在指定 band 中设置对应于指定像素矩形的样本。
setSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
setSamples(int, int, int, int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 float 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
setSamples(int, int, int, int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 double 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
setSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
setSamples(int, int, int, int, int, int[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 int 型数组中指定的像素矩形在指定 band 中设置样本。
setSamples(int, int, int, int, int, float[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 float 型数组中指定的像素矩形在指定 band 中设置样本。
setSamples(int, int, int, int, int, double[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 double 型数组中指定的像素矩形在指定 band 中设置样本。
setSavepoint() - 接口 java.sql.Connection 中的方法
在当前事务中创建一个未命名的保存点 (savepoint)，并返回表示它的新 Savepoint 对象。
setSavepoint(String) - 接口 java.sql.Connection 中的方法
在当前事务中创建一个具有给定名称的保存点，并返回表示它的新 Savepoint 对象。
setScale(int, RoundingMode) - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
setScale(int, int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
setScale(int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其标度为指定值，其值在数值上等于此 BigDecimal 的值。
setScale(int, int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将存储在指定列中的值的小数点右边的位数设置为给定数。
setScale(int, int) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的小数点右边的位数设置为给定的 int。
setSchema(Schema) - 类 javax.xml.bind.Binder 中的方法
指定 marshal、unmarshal 和 update 方法是否在其 XML 内容上执行验证。
setSchema(Schema) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setSchema(Schema) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
setSchema(Schema) - 接口 javax.xml.bind.Marshaller 中的方法
指定应该用作验证后续编组操作依据的 JAXP 1.3 Schema 对象。
setSchema(Schema) - 接口 javax.xml.bind.Unmarshaller 中的方法
指定应用作验证后续解组操作依据的 JAXP 1.3 Schema 对象。
setSchema(Schema) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
设置将由解析器使用的 Schema，该解析器从此工厂创建。
setSchema(Schema) - 类 javax.xml.parsers.SAXParserFactory 中的方法
设置将由解析器使用的 Schema，该解析器从此工厂创建。
setSchemaLocation(String) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
设置 schemaLocation 的便捷方法。
setSchemaName(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列的表的模式名称（如果有）设置为 schemaName。
setSchemaName(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的表模式的名称（如果有）设置为给定的 String。
setScope(String, MessageContext.Scope) - 接口 javax.xml.ws.handler.MessageContext 中的方法
设置属性的作用域。
setScrollByBlock(boolean) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 中的方法
setScrollByBlock(boolean) - 类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 中的方法
setScrollMode(int) - 类 javax.swing.JViewport 中的方法
用于控制滚动视口内容的方法。
setScrollOffset(int) - 类 javax.swing.JTextField 中的方法
获取滚动偏移量（以像素为单位）。
setScrollPosition(int, int) - 类 java.awt.ScrollPane 中的方法
滚动到子组件中的指定位置。
setScrollPosition(Point) - 类 java.awt.ScrollPane 中的方法
滚动到子组件中的指定位置。
setScrollsOnExpand(boolean) - 类 javax.swing.JTree 中的方法
设置 scrollsOnExpand 属性，它确定树是否可以滚动显示以前隐藏的子节点。
setSearchable(int, boolean) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否可以在 WHERE 子句中使用。
setSearchable(int, boolean) - 接口 javax.sql.RowSetMetaData 中的方法
设置是否可以在 where 子句中使用指定的列。
setSearchScope(int) - 类 javax.naming.directory.SearchControls 中的方法
将搜索范围设置为以下值之一：OBJECT_SCOPE、ONELEVEL_SCOPE 和 SUBTREE_SCOPE。
setSecond(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置秒。
setSeconds(int) - 类 java.sql.Date 中的方法
已过时。
setSeconds(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.SECOND, int seconds) 取代。
setSecure(boolean) - 类 java.net.HttpCookie 中的方法
指示浏览器是否只能使用安全协议（如 HTTPS 或 SSL）发送 cookie。
setSecurityManager(SecurityManager) - 类 java.lang.System 中的静态方法
设置系统安全性。
setSeed(byte[]) - 类 java.security.SecureRandom 中的方法
重新设置此随机对象的种子。
setSeed(long) - 类 java.security.SecureRandom 中的方法
使用给定 long seed 中包含的八个字节，重新设置此随机对象的种子。
setSeed(long) - 类 java.util.Random 中的方法
使用单个 long 种子设置此随机数生成器的种子。
setSelected(boolean) - 类 javax.swing.AbstractButton 中的方法
设置按钮的状态。
setSelected(ButtonModel, boolean) - 类 javax.swing.ButtonGroup 中的方法
为 ButtonModel 设置选择值。
setSelected(boolean) - 接口 javax.swing.ButtonModel 中的方法
选择或取消选择该按钮。
setSelected(boolean) - 类 javax.swing.DefaultButtonModel 中的方法
选择或取消选择该按钮。
setSelected(boolean) - 类 javax.swing.JInternalFrame 中的方法
如果要显示内部窗体，则选定或取消选定该窗体。
setSelected(boolean) - 类 javax.swing.JMenu 中的方法
设置菜单的选择状态。
setSelected(Component) - 类 javax.swing.JMenuBar 中的方法
设置当前选择的组件，更改选择模型。
setSelected(Component) - 类 javax.swing.JPopupMenu 中的方法
设置当前选择的组件，此方法将更改选择模型。
setSelected(boolean) - 类 javax.swing.JToggleButton.ToggleButtonModel 中的方法
设置按钮的选定状态。
setSelectedCheckbox(Checkbox) - 类 java.awt.CheckboxGroup 中的方法
将此组中当前选中的复选框设置为指定的复选框。
setSelectedColor(Color) - 接口 javax.swing.colorchooser.ColorSelectionModel 中的方法
将选取的颜色设置为 color。
setSelectedColor(Color) - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
将选取的颜色设置为 color。
setSelectedComponent(Component) - 类 javax.swing.JTabbedPane 中的方法
设置此选项卡窗格的已选组件。
setSelectedFile(File) - 类 javax.swing.JFileChooser 中的方法
设置选中的文件。
setSelectedFiles(File[]) - 类 javax.swing.JFileChooser 中的方法
如果将文件选择器设置为允许选择多个文件，则设置选中文件的列表。
setSelectedFrame(JInternalFrame) - 类 javax.swing.JDesktopPane 中的方法
设置此 JDesktopPane 中当前活动的 JInternalFrame。
setSelectedIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的选择图标。
setSelectedIndex(int) - 类 javax.security.auth.callback.ChoiceCallback 中的方法
设置选中的选项。
setSelectedIndex(int) - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
设置选中的确认选项。
setSelectedIndex(int) - 类 javax.swing.DefaultSingleSelectionModel 中的方法
setSelectedIndex(int) - 类 javax.swing.JComboBox 中的方法
选择索引 anIndex 处的项。
setSelectedIndex(int) - 类 javax.swing.JList 中的方法
选择单个单元。
setSelectedIndex(int) - 类 javax.swing.JTabbedPane 中的方法
设置所选择的此选项卡窗格的索引。
setSelectedIndex(int) - 接口 javax.swing.SingleSelectionModel 中的方法
将模型中选定的索引设置为 index。
setSelectedIndexes(int[]) - 类 javax.security.auth.callback.ChoiceCallback 中的方法
设置选中的选项。
setSelectedIndices(int[]) - 类 javax.swing.JList 中的方法
将选择更改为给定数组所指定的索引的集合。
setSelectedItem(Object) - 接口 javax.swing.ComboBoxModel 中的方法
设置选择项。
setSelectedItem(Object) - 类 javax.swing.DefaultComboBoxModel 中的方法
设置选择项的值。
setSelectedItem(Object) - 类 javax.swing.JComboBox 中的方法
将组合框显示区域中所选项设置为参数中的对象。
setSelectedItem(Object) - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 中的方法
setSelectedItem(Object) - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的方法
setSelectedPath(MenuElement[]) - 类 javax.swing.MenuSelectionManager 中的方法
更改菜单层次结构中的选项。
setSelectedTextColor(Color) - 类 javax.swing.text.JTextComponent 中的方法
设置用于呈现选定文本的当前颜色。
setSelectedValue(Object, boolean) - 类 javax.swing.JList 中的方法
从列表中选择指定的对象。
setSelection(boolean) - 类 javax.swing.text.html.Option 中的方法
设置选定的状态。
setSelectionBackground(Color) - 类 javax.swing.JList 中的方法
设置用于绘制选定项的背景的颜色，单元渲染器可以使用此颜色填充所选单元。
setSelectionBackground(Color) - 类 javax.swing.JTable 中的方法
设置选定单元格的背景色。
setSelectionColor(Color) - 类 javax.swing.text.JTextComponent 中的方法
设置用于呈现选定的当前颜色。
setSelectionEnd(int) - 类 java.awt.TextComponent 中的方法
将此文本组件的选定结束位置设置为指定位置。
setSelectionEnd(int) - 类 javax.swing.text.JTextComponent 中的方法
将选择结束点设置为指定的位置。
setSelectionForeground(Color) - 类 javax.swing.JList 中的方法
设置用于绘制选定项的前景的颜色，单元渲染器可以使用此颜色呈现文本和图形。
setSelectionForeground(Color) - 类 javax.swing.JTable 中的方法
设置选定单元格的前景色。
setSelectionInterval(int, int) - 类 javax.swing.DefaultListSelectionModel 中的方法
将选择更改为 index0 和 index1（包括）的范围之间。
setSelectionInterval(int, int) - 类 javax.swing.JList 中的方法
选择指定的间隔。
setSelectionInterval(int, int) - 类 javax.swing.JTree 中的方法
选择 index0 和 index1（包含）之间的节点。
setSelectionInterval(int, int) - 接口 javax.swing.ListSelectionModel 中的方法
将选择更改为在 index0 和 index1 之间（包括两者）。
setSelectionMode(int) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置选择模式。
setSelectionMode(int) - 类 javax.swing.JList 中的方法
设置列表的选择模式。
setSelectionMode(int) - 类 javax.swing.JTable 中的方法
将表的选择模式设置为只允许单个选择、单个连续间隔选择或多间隔选择。
setSelectionMode(int) - 接口 javax.swing.ListSelectionModel 中的方法
设置选择模式。
setSelectionMode(int) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
设置选择模式，它必须是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一。
setSelectionMode(int) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
设置选择模型，它必须是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一。
setSelectionModel(ColorSelectionModel) - 类 javax.swing.JColorChooser 中的方法
设置包含所选颜色的模型。
setSelectionModel(ListSelectionModel) - 类 javax.swing.JList 中的方法
将列表的 selectionModel 设置为非 null 的 ListSelectionModel 实现。
setSelectionModel(SingleSelectionModel) - 类 javax.swing.JMenuBar 中的方法
设置处理单个选择的模型对象。
setSelectionModel(SingleSelectionModel) - 类 javax.swing.JPopupMenu 中的方法
设置处理单个选择的模型对象。
setSelectionModel(ListSelectionModel) - 类 javax.swing.JTable 中的方法
将此表的行选择模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
setSelectionModel(TreeSelectionModel) - 类 javax.swing.JTree 中的方法
设置树的选择模型。
setSelectionModel(TreeSelectionModel) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
重置选择模型。
setSelectionModel(ListSelectionModel) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
将此 TableColumnModel 的选择模型设置为 newModel，并为来自新选择模型的侦听器通知注册它。
setSelectionModel(ListSelectionModel) - 接口 javax.swing.table.TableColumnModel 中的方法
设置选择模型。
setSelectionModel(TreeSelectionModel) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
将用于管理选择的 TreeSelectionModel 设置为新的 LSM。
setSelectionPath(TreePath) - 类 javax.swing.JTree 中的方法
选择指定路径标识的节点。
setSelectionPath(TreePath) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
为该选择设置路径。
setSelectionPath(TreePath) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
为该选择设置路径。
setSelectionPaths(TreePath[]) - 类 javax.swing.JTree.EmptySelectionModel 中的方法
一个未选择任何内容的 null 实现。
setSelectionPaths(TreePath[]) - 类 javax.swing.JTree 中的方法
选择由指定的路径数组标识的节点。
setSelectionPaths(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
为该选择设置路径中的路径。
setSelectionPaths(TreePath[]) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
为该选择设置路径。
setSelectionRow(int) - 类 javax.swing.JTree 中的方法
选择显示的指定行的节点。
setSelectionRows(int[]) - 类 javax.swing.JTree 中的方法
选择与显示的每个指定行对应的节点。
setSelectionStart(int) - 类 java.awt.TextComponent 中的方法
将此文本组件的选定开始位置设置为指定位置。
setSelectionStart(int) - 类 javax.swing.text.JTextComponent 中的方法
将选定起始点设置为指定的位置。
setSelectionValues(Object[]) - 类 javax.swing.JOptionPane 中的方法
设置窗格的输入选择值，该窗格向用户提供可以从中进行选择的项列表。
setSelectionVisible(boolean) - 接口 javax.swing.text.Caret 中的方法
设置选定项的可见性
setSelectionVisible(boolean) - 类 javax.swing.text.DefaultCaret 中的方法
更改选定的可见性。
setSendBufferSize(int) - 类 java.net.DatagramSocket 中的方法
将此 DatagramSocket 的 SO_SNDBUF 选项设置为指定的值。
setSendBufferSize(int) - 类 java.net.Socket 中的方法
将此 Socket 的 SO_SNDBUF 选项设置为指定的值。
setSendPastNotifications(boolean) - 类 javax.management.timer.Timer 中的方法
设置指示计时器是否发送过期通知的标志。
setSendPastNotifications(boolean) - 接口 javax.management.timer.TimerMBean 中的方法
设置指示计时器是否发送过期通知的标志。
setSeparatorSize(Dimension) - 类 javax.swing.JToolBar.Separator 中的方法
设置分隔符的大小。
setSequence(Sequence) - 接口 javax.sound.midi.Sequencer 中的方法
设置 sequencer 所操作的当前 sequence。
setSequence(InputStream) - 接口 javax.sound.midi.Sequencer 中的方法
设置 sequencer 所操作的当前 sequence。
setSequenceNumber(long) - 类 java.util.logging.LogRecord 中的方法
设置序列号。
setSequenceNumber(long) - 类 javax.management.Notification 中的方法
设置通知序列号。
setSerialNumber(BigInteger) - 类 java.security.cert.X509CertSelector 中的方法
设置 serialNumber 标准。
setSessionCacheSize(int) - 接口 javax.net.ssl.SSLSessionContext 中的方法
设置用来存储在此 SSLSessionContext 下分组的 SSLSession 对象的缓存大小。
setSessionTimeout(int) - 接口 javax.net.ssl.SSLSessionContext 中的方法
设置在此 SSLSessionContext 下分组的 SSLSession 对象的超时值限制。
setSeverity(int) - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法
设置此事件的 severity 字段。
setSharedInstance(PopupFactory) - 类 javax.swing.PopupFactory 中的静态方法
设置用于获取 Popup 的 PopupFactory。
setShort(Object, int, short) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 short 值。
setShort(Object, short) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 short 值。
setShort(String, short) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java short 值。
setShort(int, short) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java short 值。
setShort(int, short) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 short 值。
setShort(String, short) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java short 值。
setShort(int, short) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java short 值。
setShort(String, short) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java short 值。
setShortcut(MenuShortcut) - 类 java.awt.MenuItem 中的方法
设置与此菜单项关联的 MenuShortcut 对象。
setShortDescription(String) - 类 java.beans.FeatureDescriptor 中的方法
可以将简短描述性字符串与某一特性相关联。
setShortMonths(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置简短形式的月份字符串。
setShortWeekdays(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置简短形式的星期字符串。
setShowDeleted(boolean) - 类 javax.sql.rowset.BaseRowSet 中的方法
将属性 showDeleted 设置为给定的 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
setShowDeleted(boolean) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将属性 showDeleted 设置为给定的 boolean 值，它确定标记为删除的行是否会出现在当前行集合中。
setShowDeleted(boolean) - 接口 javax.sql.rowset.JdbcRowSet 中的方法
将属性 showDeleted 设置为给定的 boolean 值。
setShowDropLocation(boolean) - 类 javax.swing.TransferHandler.TransferSupport 中的方法
设置是否应该为传输（必须表示一个放置操作）可视地指出放置位置。
setShowGrid(boolean) - 类 javax.swing.JTable 中的方法
设置表是否绘制单元格周围的网格线。
setShowHorizontalLines(boolean) - 类 javax.swing.JTable 中的方法
设置表是否绘制单元格之间的水平线。
setShowsRootHandles(boolean) - 类 javax.swing.JTree 中的方法
设置 showsRootHandles 属性的值，它指定是否应显示节点句柄。
setShowsRootHandles(boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
确定是否显示节点句柄。
setShowVerticalLines(boolean) - 类 javax.swing.JTable 中的方法
设置表是否绘制单元格之间的垂直线。
setSides(JobAttributes.SidesType) - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。
setSidesToDefault() - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，将如何在打印介质的面上强制应用连续页设置为默认值。
setSigned(int, boolean) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否为有符号数。
setSigned(int, boolean) - 接口 javax.sql.RowSetMetaData 中的方法
设置指定列是否是有符号数字。
setSigners(Class<?>, Object[]) - 类 java.lang.ClassLoader 中的方法
设置类的签署者。
setSigProvider(String) - 类 java.security.cert.PKIXParameters 中的方法
设置签名提供者的名称。
setSize(Dimension) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
调整此对象的大小，使它具有宽度和高度。
setSize(int, int) - 类 java.awt.Component 中的方法
调整组件的大小，使其宽度为 width，高度为 height。
setSize(Dimension) - 类 java.awt.Component 中的方法
调整组件的大小，使其宽度为 d.width，高度为 d.height。
setSize(double, double) - 类 java.awt.Dimension 中的方法
将此 Dimension 对象的大小设置为指定的宽度和高度（以双精度表示）。
setSize(Dimension) - 类 java.awt.Dimension 中的方法
将 Dimension 对象的大小设置为指定大小。
setSize(int, int) - 类 java.awt.Dimension 中的方法
将此 Dimension 对象的大小设置为指定的宽度和高度。
setSize(double, double) - 类 java.awt.geom.Dimension2D 中的方法
将此 Dimension 对象的大小设置为指定的宽度和高度。
setSize(Dimension2D) - 类 java.awt.geom.Dimension2D 中的方法
将 Dimension2D 对象的大小设置为指定大小。
setSize(Dimension) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
调整此对象，使其具有高度和宽度。
setSize(Dimension) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
调整此对象的大小。
setSize(double, double) - 类 java.awt.print.Paper 中的方法
设置此 Paper 对象的宽和高，它表示要用来打印的页面的属性。
setSize(Dimension) - 类 java.awt.Rectangle 中的方法
设置此 Rectangle 的大小，以匹配指定的 Dimension。
setSize(int, int) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 的大小设置为指定的宽度和高度。
setSize(Dimension) - 类 java.awt.Window 中的方法
调整组件的大小，使其宽度为 d.width，高度为 d.height。
setSize(int, int) - 类 java.awt.Window 中的方法
调整组件的大小，使其宽度为 width，高度为 height。
setSize(int) - 类 java.util.Vector 中的方法
设置此向量的大小。
setSize(long) - 类 java.util.zip.ZipEntry 中的方法
设置条目数据的未压缩大小。
setSize(Dimension) - 接口 javax.accessibility.AccessibleComponent 中的方法
调整此对象，使其具有高度和宽度。
setSize(int) - 类 javax.swing.DefaultListModel 中的方法
设置此列表的大小。
setSize(Dimension) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setSize(Dimension) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
setSize(Dimension) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setSize(int, int) - 类 javax.swing.SizeSequence 中的方法
设置指定条目的大小。
setSize(Dimension) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setSize(float, float) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图的大小。
setSize(float, float) - 类 javax.swing.text.BoxView 中的方法
设置视图的大小。
setSize(float, float) - 类 javax.swing.text.html.ImageView 中的方法
设置视图的大小。
setSize(float, float) - 类 javax.swing.text.PlainView 中的方法
设置视图的大小。
setSize(float, float) - 类 javax.swing.text.View 中的方法
设置视图的大小。
setSize(float, float) - 类 javax.swing.text.WrappedPlainView 中的方法
设置视图的大小。
setSizes(int[]) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
将大小设置为 newSizes。
setSizes(int[]) - 类 javax.swing.SizeSequence 中的方法
用 sizes 参数中的数据重置此 SizeSequence 对象。
setSlaveSyncMode(Sequencer.SyncMode) - 接口 javax.sound.midi.Sequencer 中的方法
设置此 sequencer 的从同步模式。
setSnapToTicks(boolean) - 类 javax.swing.JSlider 中的方法
指定为 true，则滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值。
setSocketAddress(SocketAddress) - 类 java.net.DatagramPacket 中的方法
设置要将此数据报发往的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。
setSocketFactory(SocketImplFactory) - 类 java.net.ServerSocket 中的静态方法
为应用程序设置服务器套接字实现工厂。
setSocketFactory(RMISocketFactory) - 类 java.rmi.server.RMISocketFactory 中的静态方法
设置 RMI 从中获取套接字的全局套接字工厂（如果远程对象与指定客户机和/或服务器套接字工厂无关）。
setSocketImplFactory(SocketImplFactory) - 类 java.net.Socket 中的静态方法
为应用程序设置客户端套接字实现工厂。
setSoLinger(boolean, int) - 类 java.net.Socket 中的方法
启用/禁用具有指定逗留时间（以秒为单位）的 SO_LINGER。
setSolo(boolean) - 接口 javax.sound.midi.MidiChannel 中的方法
设置此通道的 solo 状态。
setSortable(int, boolean) - 类 javax.swing.DefaultRowSorter 中的方法
设置指定列是否可排序。
setSortKeys(List<? extends RowSorter.SortKey>) - 类 javax.swing.DefaultRowSorter 中的方法
设置排序键。
setSortKeys(List<? extends RowSorter.SortKey>) - 类 javax.swing.RowSorter 中的方法
设置当前排序键。
setSortsOnUpdates(boolean) - 类 javax.swing.DefaultRowSorter 中的方法
如果为 true，则指定应该在底层模型更新（调用了 rowsUpdated）时进行排序。
setSoTimeout(int) - 类 java.net.DatagramSocket 中的方法
启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。
setSoTimeout(int) - 类 java.net.ServerSocket 中的方法
通过指定超时值启用/禁用 SO_TIMEOUT，以毫秒为单位。
setSoTimeout(int) - 类 java.net.Socket 中的方法
启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。
setSource(Object) - 类 java.awt.AWTEvent 中的方法
将事件的目标更改为新的源。
setSource(Object, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将源列表中的某个项替换为一个新源。
setSource(Object) - 类 java.beans.PropertyEditorSupport 中的方法
设置源 bean。
setSource(Object) - 类 javax.management.Notification 中的方法
设置源。
setSourceActions(int) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
此方法设置此 Drag 和 Drop 操作允许的源拖动动作。
setSourceBands(int[]) - 类 javax.imageio.IIOParam 中的方法
设置将要使用的源 band 的索引。
setSourceClassName(String) - 类 java.util.logging.LogRecord 中的方法
设置（可能）发出日志请求的类的名称。
setSourceMethodName(String) - 类 java.util.logging.LogRecord 中的方法
设置（可能）发出日志请求的方法的名称。
setSourceProgressivePasses(int, int) - 类 javax.imageio.ImageReadParam 中的方法
设置将被解码的逐步传递的范围。
setSourceRegion(Rectangle) - 类 javax.imageio.IIOParam 中的方法
设置感兴趣的源区域。
setSourceRenderSize(Dimension) - 类 javax.imageio.ImageReadParam 中的方法
如果能够以任意大小呈现图像，则将源宽度和高度设置为所提供的值。
setSources(Vector<Object>) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将源的整个 Vector 设置为给定 Vector。
setSourceSubsampling(int, int, int, int) - 类 javax.imageio.IIOParam 中的方法
指定进行 I/O 时应用的抽取十分之一的二次取样。
setSouthPane(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setSpaceAbove(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置上部空间。
setSpaceBelow(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置下部空间。
setSpecified(int, boolean) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
将值分配给特定属性的“指定的”标志。
setSQLXML(String, SQLXML) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.sql.SQLXML 对象。
setSQLXML(int, SQLXML) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.SQLXML 对象。
setSQLXML(int, SQLXML) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定 java.sql.SQLXML 对象。
setSQLXML(String, SQLXML) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.SQLXML 对象。
setSQLXML(int, SQLXML) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定 java.sql.SQLXML 对象。
setSQLXML(String, SQLXML) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.SQLXML 对象。
setSSLParameters(SSLParameters) - 类 javax.net.ssl.SSLEngine 中的方法
对此引擎应用 SSLParameters。
setSSLParameters(SSLParameters) - 类 javax.net.ssl.SSLSocket 中的方法
对此套接字应用 SSLParameters。
setSSLSocketFactory(SSLSocketFactory) - 类 javax.net.ssl.HttpsURLConnection 中的方法
设置当此实例为安全 https URL 连接创建套接字时使用的 SSLSocketFactory。
setStackTrace(StackTraceElement[]) - 类 java.lang.Throwable 中的方法
设置将由 Throwable.getStackTrace() 返回，并由 Throwable.printStackTrace() 和相关方法输出的堆栈跟踪元素。
setStart(Comparable) - 类 javax.swing.SpinnerDateModel 中的方法
更改此序列中的日期下限。
setStartRule(int, int, int, int) - 类 java.util.SimpleTimeZone 中的方法
设置夏令时的开始规则。
setStartRule(int, int, int) - 类 java.util.SimpleTimeZone 中的方法
将夏令时开始规则设置为某个月份的固定日期。
setStartRule(int, int, int, int, boolean) - 类 java.util.SimpleTimeZone 中的方法
将夏令时开始规则设置为某个月份给定日期之前或之后的星期几，例如，8 号或之后的第一个星期一。
setStartYear(int) - 类 java.util.SimpleTimeZone 中的方法
设置夏令时的开始年份。
setState(boolean) - 类 java.awt.Checkbox 中的方法
将此复选框的状态设置为指定状态。
setState(boolean) - 类 java.awt.CheckboxMenuItem 中的方法
将此复选框菜单项设置为指定的状态。
setState(int) - 类 java.awt.Frame 中的方法
设置此窗体的状态（已废弃）。
setState(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
设置同步状态的值。
setState(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
设置同步状态的值。
setState(boolean) - 类 javax.swing.JCheckBoxMenuItem 中的方法
设置该项的选定状态。
setStepSize(Number) - 类 javax.swing.SpinnerNumberModel 中的方法
更改由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。
setStrategy(int) - 类 java.util.zip.Deflater 中的方法
将压缩策略设置为指定值。
setStream(String, InputStream) - 接口 java.applet.AppletContext 中的方法
在此 applet 上下文中用指定的键关联指定的流。
setStrength(int) - 类 java.text.Collator 中的方法
设置此 Collator 的 strength 属性。
setStrictErrorChecking(boolean) - 接口 org.w3c.dom.Document 中的方法
指定是否强制执行错误检查的属性。
setStrikeThrough(boolean) - 类 javax.swing.text.LabelView 中的方法
设置视图是否具有删除线。
setStrikeThrough(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置删除线属性。
setString(String, String) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java String 值。
setString(long, String) - 接口 java.sql.Clob 中的方法
在位置 pos 处将给定 Java String 写入此 Clob 对象指定的 CLOB 值中。
setString(long, String, int, int) - 接口 java.sql.Clob 中的方法
将 str 的 len 个字符（从字符 offset 开始）写入此 Clob 表示的 CLOB 值中。
setString(int, String) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java String 值。
setString(String) - 接口 java.sql.SQLXML 中的方法
将此 SQLXML 实例指定的 XML 值设置为给定的 String 表示形式。
setString(int, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 String 值。
setString(String, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java String 值。
setString(long, String) - 类 javax.sql.rowset.serial.SerialClob 中的方法
在位置 pos 处将给定 Java String 写入此 SerialClob 对象表示的 CLOB 值中。
setString(long, String, int, int) - 类 javax.sql.rowset.serial.SerialClob 中的方法
将 str 的 len 个字符写入此 Clob 表示的 CLOB 值中，从字符 offset 开始。
setString(int, String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java String 值。
setString(String, String) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java String 值。
setString(String) - 类 javax.swing.JProgressBar 中的方法
设置进度字符串的值。
setStringConverter(TableStringConverter) - 类 javax.swing.table.TableRowSorter 中的方法
设置负责将值从模型转换为字符串的对象。
setStringData(String) - 接口 org.w3c.dom.ls.LSInput 中的方法
要解析的字符串数据。
setStringPainted(boolean) - 类 javax.swing.JProgressBar 中的方法
设置 stringPainted 属性的值，该属性确定进度条是否应该呈现进度字符串。
setStringToCompare(String) - 类 javax.management.monitor.StringMonitor 中的方法
设置要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。
setStringToCompare(String) - 接口 javax.management.monitor.StringMonitorMBean 中的方法
设置要与 observed 属性进行比较的字符串。
setStroke(Stroke) - 类 java.awt.Graphics2D 中的方法
为 Graphics2D 上下文设置 Stroke
setStub(AppletStub) - 类 java.applet.Applet 中的方法
设置此 applet 的 stub。
setStyledDocument(StyledDocument) - 类 javax.swing.JTextPane 中的方法
将编辑器与一个文本文档关联。
setStyleFactory(SynthStyleFactory) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
设置 SynthStyleFactory，由 synth 提供的 UI 类将使用它来获取 SynthStyle。
setStyleSheet(StyleSheet) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
设置要用于呈现各种 HTML 元素的样式集。
setSubject(X500Principal) - 类 java.security.cert.X509CertSelector 中的方法
设置 subject 标准。
setSubject(String) - 类 java.security.cert.X509CertSelector 中的方法
已过时，使用 X509CertSelector.setSubject(X500Principal) 或 X509CertSelector.setSubject(byte[]) 替代。
setSubject(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 subject 标准。
setSubjectAlternativeNames(Collection<List<?>>) - 类 java.security.cert.X509CertSelector 中的方法
设置 subjectAlternativeNames 标准。
setSubjectKeyIdentifier(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 subjectKeyIdentifier 标准。
setSubjectPublicKey(PublicKey) - 类 java.security.cert.X509CertSelector 中的方法
设置 subjectPublicKey 标准。
setSubjectPublicKey(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 subjectPublicKey 标准。
setSubjectPublicKeyAlgID(String) - 类 java.security.cert.X509CertSelector 中的方法
设置 subjectPublicKeyAlgID 标准。
setSubscript(boolean) - 类 javax.swing.text.LabelView 中的方法
设置视图是否有下标。
setSubscript(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置下标属性。
setSubType(String) - 类 javax.activation.MimeType 中的方法
将此对象的子类型设置为给定的 String。
setSuperscript(boolean) - 类 javax.swing.text.LabelView 中的方法
设置视图是否有上标。
setSuperscript(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置上标属性。
setSupplementaryStates(boolean, boolean, boolean, boolean, int, String) - 类 org.ietf.jgss.MessageProp 中的方法
此方法将设置 MessageProp 中的增补信息标记的状态和次要状态。
setSurrendersFocusOnKeystroke(boolean) - 类 javax.swing.JTable 中的方法
设置由于 JTable 为某个单元格转发键盘事件而导致编辑器被激活时，此 JTable 中的编辑器是否获得键盘焦点。
setSyncAllWidths(boolean) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
setSyncProvider(String) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象的 SyncProvider 对象设置为指定的提供者。
setSyncResolver(SyncResolver) - 异常 javax.sql.rowset.spi.SyncProviderException 中的方法
将此 SyncProviderException 对象的 SyncResolver 对象设置为提供的对象。
setSystem(ActivationSystem) - 类 java.rmi.activation.ActivationGroup 中的静态方法
设置该 VM 的激活系统。
setSystemId(String) - 类 javax.xml.transform.dom.DOMResult 中的方法
设置可与此节点联合使用的 systemId。
setSystemId(String) - 类 javax.xml.transform.dom.DOMSource 中的方法
设置将从其解析 URL 的基本 ID（URL 或系统 ID）。
setSystemId(String) - 接口 javax.xml.transform.Result 中的方法
设置此 Result 的系统标识符。
setSystemId(String) - 类 javax.xml.transform.sax.SAXResult 中的方法
setSystemId 方法设置可与 ContentHandler 关联使用的 systemID。
setSystemId(String) - 类 javax.xml.transform.sax.SAXSource 中的方法
设置此 Source 的系统标识符。
setSystemId(String) - 接口 javax.xml.transform.sax.TemplatesHandler 中的方法
设置此生成器所创建的 Templates 对象的基本 ID（URI 或系统 ID）。
setSystemId(String) - 接口 javax.xml.transform.sax.TransformerHandler 中的方法
设置要从其解析相对 URL 的基本 ID（URI 或系统 ID）。
setSystemId(String) - 接口 javax.xml.transform.Source 中的方法
设置此 Source 的系统标识符。
setSystemId(String) - 类 javax.xml.transform.stax.StAXResult 中的方法
在 StAXResult 的上下文中，它不适合显示设置系统标识符。
setSystemId(String) - 类 javax.xml.transform.stax.StAXSource 中的方法
在 StAXSource 的上下文中，它不适合显示设置系统标识符。
setSystemId(String) - 类 javax.xml.transform.stream.StreamResult 中的方法
设置可以与字节流或字符流关联使用的 systemID，如果未设置，则使用此值作为 writeable URI（可能是文件名）。
setSystemId(File) - 类 javax.xml.transform.stream.StreamResult 中的方法
设置来自 File 引用的系统 ID。
setSystemId(String) - 类 javax.xml.transform.stream.StreamSource 中的方法
设置此 Source 的系统标识符。
setSystemId(File) - 类 javax.xml.transform.stream.StreamSource 中的方法
设置来自 File 引用的系统 ID。
setSystemId(String) - 接口 org.w3c.dom.ls.LSInput 中的方法
系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。
setSystemId(String) - 接口 org.w3c.dom.ls.LSOutput 中的方法
系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。
setSystemId(String) - 类 org.xml.sax.helpers.LocatorImpl 中的方法
设置此定位器的系统标识符。
setSystemId(String) - 类 org.xml.sax.InputSource 中的方法
设置此输入源的系统标识符。
setSystemScope(IdentityScope) - 类 java.security.IdentityScope 中的静态方法
已过时。 设置系统的身份作用域。
setTabComponentAt(int, Component) - 类 javax.swing.JTabbedPane 中的方法
设置负责呈现指定选项卡标题的组件。
setTabLayoutPolicy(int) - 类 javax.swing.JTabbedPane 中的方法
设置在一次运行中不能放入所有的选项卡时，选项卡窗格使用的对选项卡进行布局安排的策略。
setTable(JTable) - 类 javax.swing.table.JTableHeader 中的方法
设置与此头关联的表。
setTableHeader(JTableHeader) - 类 javax.swing.JTable 中的方法
将此 JTable 所使用的 tableHeader 设置为 newHeader。
setTableName(String) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将派生此 CachedRowSet 对象的表的标识符设置为给定的表名。
setTableName(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将派生指定列的表名称设置为给定的表名称。
setTableName(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的表名称（如果有）设置为给定的 String。
setTabPlacement(int) - 类 javax.swing.JTabbedPane 中的方法
设置此选项卡窗格的选项卡布局。
setTabSet(MutableAttributeSet, TabSet) - 类 javax.swing.text.StyleConstants 中的静态方法
设置 TabSet。
setTabSize(int) - 类 javax.swing.JTextArea 中的方法
设置选项卡要扩大到的字符数。
setTarget(Object) - 类 javax.accessibility.AccessibleRelation 中的方法
设置此关系的目标对象
setTarget(Object[]) - 类 javax.accessibility.AccessibleRelation 中的方法
设置此关系的目标对象
setTarget(Remote) - 接口 javax.rmi.CORBA.Tie 中的方法
由 Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 调用以设置此 tie 的目标。
setTargetActions(int) - 类 java.awt.dnd.DropTargetContext 中的方法
此方法设置此 DropTarget 可接受的当前操作。
setTargetCertConstraints(CertSelector) - 类 java.security.cert.PKIXParameters 中的方法
设置目标证书所需的限制。
setTcpNoDelay(boolean) - 类 java.net.Socket 中的方法
启用/禁用 TCP_NODELAY（启用/禁用 Nagle 算法）。
setTempoFactor(float) - 接口 javax.sound.midi.Sequencer 中的方法
根据所提供的 factor 按比例提高 sequencer 的实际回放速度。
setTempoInBPM(float) - 接口 javax.sound.midi.Sequencer 中的方法
设置速度，以每分钟的拍数为单位。
setTempoInMPQ(float) - 接口 javax.sound.midi.Sequencer 中的方法
设置速度，以每四分音符的微秒数为单位。
setText(String) - 类 java.awt.Label 中的方法
将此标签的文本设置为指定的文本。
setText(String) - 类 java.awt.TextComponent 中的方法
将此文本组件显示的文本设置为指定文本。
setText(String) - 类 java.awt.TextField 中的方法
将此文本组件显示的文本设置为指定文本。
setText(String) - 类 java.text.BreakIterator 中的方法
设置要被扫描的新文本字符串。
setText(CharacterIterator) - 类 java.text.BreakIterator 中的方法
设置一个新文本用于扫描。
setText(String) - 类 java.text.CollationElementIterator 中的方法
设置一个要迭代的新字符串。
setText(CharacterIterator) - 类 java.text.CollationElementIterator 中的方法
设置一个要迭代的新字符串。
setText(String) - 类 java.text.StringCharacterIterator 中的方法
将此迭代器重置为指向一个新的字符串。
setText(String) - 类 javax.security.auth.callback.TextInputCallback 中的方法
设置获取到的文本。
setText(String) - 类 javax.swing.AbstractButton 中的方法
设置按钮的文本。
setText(String) - 类 javax.swing.JEditorPane 中的方法
将此 TextComponent 的文本设置为指定内容，预期以此编辑器的内容类型格式提供该内容。
setText(String) - 类 javax.swing.JLabel 中的方法
定义此组件将要显示的单行文本。
setText(String) - 类 javax.swing.text.JTextComponent 中的方法
将此 TextComponent 文本设置为指定文本。
setTextContent(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setTextContent(String) - 接口 org.w3c.dom.Node 中的方法
此属性返回此节点及其后代的文本内容。
setTextContents(String) - 接口 javax.accessibility.AccessibleEditableText 中的方法
将文本内容设置为指定字符串。
setTextContents(String) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
将文本内容设置为指定字符串。
setTextContents(String) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
将文本内容设置为指定字符串。
setTextNonSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置选定节点时绘制文本所使用的颜色。
setTextSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置选定节点时绘制文本所使用的颜色。
setTextShiftOffset() - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
setThreadContentionMonitoringEnabled(boolean) - 接口 java.lang.management.ThreadMXBean 中的方法
启用或禁用线程争用监视。
setThreadCpuTimeEnabled(boolean) - 接口 java.lang.management.ThreadMXBean 中的方法
启用或禁用线程 CPU 时间测量。
setThreadFactory(ThreadFactory) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
设置用于创建新线程的线程工厂。
setThreadID(int) - 类 java.util.logging.LogRecord 中的方法
设置产生消息的线程的标识符。
setThreshold(Number) - 类 javax.management.monitor.CounterMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitor.setInitThreshold(java.lang.Number) 取代
setThreshold(Number) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.setInitThreshold(java.lang.Number) 取代
setThresholds(Number, Number) - 类 javax.management.monitor.GaugeMonitor 中的方法
设置所有观察到的 MBean 的公共高、低阈值。
setThresholds(Number, Number) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
设置高、低阈值。
setThrown(Throwable) - 类 java.util.logging.LogRecord 中的方法
设置与日志事件相关联的 throwable。
setThumbBounds(int, int, int, int) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
设置 thumb 的边界并强制进行包括新旧 thumbBounds 在内的重绘。
setThumbBounds(int, int, int, int) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
重写此方法只是为了增加无效区域。
setThumbLocation(int, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
setThumbnails(List<? extends BufferedImage>) - 类 javax.imageio.IIOImage 中的方法
将缩略图列表设置为 BufferedImage 的一个新 List 或 null。
setThumbRollover(boolean) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
设置鼠标当前是否位于 thumb 上。
setTick(long) - 类 javax.sound.midi.MidiEvent 中的方法
设置事件的用 MIDI 刻度表示的时间戳
setTickPosition(long) - 接口 javax.sound.midi.Sequencer 中的方法
设置当前 sequencer 位置，以 MIDI 节拍数为单位。
setTiling(int, int, int, int) - 类 javax.imageio.ImageWriteParam 中的方法
指定应该在输出流中平铺图像。
setTilingMode(int) - 类 javax.imageio.ImageWriteParam 中的方法
确定图像在输出流中是否将被平铺，如果将被平铺，将如何确定 tiling 参数。
setTime(String, Time) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.sql.Time 值。
setTime(String, Time, Calendar) - 接口 java.sql.CallableStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
setTime(long) - 类 java.sql.Date 中的方法
使用给定毫秒时间值设置现有 Date 对象。
setTime(int, Time) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.Time 值。
setTime(int, Time, Calendar) - 接口 java.sql.PreparedStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
setTime(long) - 类 java.sql.Time 中的方法
使用毫秒时间值设置 Time 对象。
setTime(long) - 类 java.sql.Timestamp 中的方法
设置此 Timestamp 对象，以表示 1970 年 1 月 1 日 00:00:00 GMT 以后 time 毫秒的时间点。
setTime(Date) - 类 java.util.Calendar 中的方法
使用给定的 Date 设置此 Calendar 的时间。
setTime(long) - 类 java.util.Date 中的方法
设置此 Date 对象，以表示 1970 年 1 月 1 日 00:00:00 GMT 以后 time 毫秒的时间点。
setTime(long) - 类 java.util.zip.ZipEntry 中的方法
设置条目的修改时间。
setTime(int, Time) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Time 值。
setTime(int, Time, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Time 对象。
setTime(String, Time) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Time 值。
setTime(String, Time, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
setTime(int, Time) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Time 值。
setTime(int, Time, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 java.sql.Time 值设置此 RowSet 对象命令中的指定参数。
setTime(String, Time) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.Time 值。
setTime(String, Time, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
setTime(int, int, int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将时间设置为一个单元。
setTime(int, int, int, BigDecimal) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将时间设置为一个单元，包括可选无限精度小数秒。
setTime(int, int, int, int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将时间设置为一个单元，包括可选的毫秒。
setTimeInMillis(long) - 类 java.util.Calendar 中的方法
用给定的 long 值设置此 Calendar 的当前时间值。
setTimeLimit(int) - 类 javax.naming.directory.SearchControls 中的方法
设置这些 SearchControls 以毫秒为单位的时间限制。
setTimestamp(String, Timestamp) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.sql.Timestamp 值。
setTimestamp(String, Timestamp, Calendar) - 接口 java.sql.CallableStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
setTimestamp(int, Timestamp) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.Timestamp 值。
setTimestamp(int, Timestamp, Calendar) - 接口 java.sql.PreparedStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
setTimeStamp(long) - 类 javax.management.Notification 中的方法
设置通知时间戳。
setTimestamp(int, Timestamp) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Timestamp 值。
setTimestamp(int, Timestamp, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Timestamp 对象。
setTimestamp(String, Timestamp) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Timestamp 值。
setTimestamp(String, Timestamp, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。
setTimestamp(int, Timestamp) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Timestamp 值。
setTimestamp(String, Timestamp) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.Timestamp 值。
setTimestamp(int, Timestamp, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 java.sql.Timestamp 值设置此 RowSet 对象命令中的指定参数。
setTimestamp(String, Timestamp, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。
setTimeToLive(int) - 类 java.net.DatagramSocketImpl 中的方法
设置 TTL （生存时间）选项。
setTimeToLive(int) - 类 java.net.MulticastSocket 中的方法
设置在此 MulticastSocket 上发出的多播数据包的默认生存时间，以便控制多播的范围。
setTimeZone(TimeZone) - 类 java.text.DateFormat 中的方法
为此 DateFormat 对象的日历设置时区。
setTimeZone(TimeZone) - 类 java.util.Calendar 中的方法
使用给定的时区值来设置时区。
setTimeZone(TimeZone) - 类 java.util.GregorianCalendar 中的方法
setTimezone(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置时区偏移量中的分钟数。
setTipText(String) - 类 javax.swing.JToolTip 中的方法
设置显示工具提示时要显示的文本。
setTitle(String) - 类 java.awt.Dialog 中的方法
设置 Dialog 的标题。
setTitle(String) - 类 java.awt.Frame 中的方法
将此窗体的标题设置为指定的字符串。
setTitle(String) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的标题。
setTitle(String) - 类 javax.swing.JInternalFrame 中的方法
设置 JInternalFrame 的标题。
setTitleAt(int, String) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的标题设置为 title，它可以为 null。
setTitleColor(Color) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的标题颜色。
setTitleFont(Font) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的标题字体。
setTitleJustification(int) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的标题对齐方式。
setTitlePosition(int) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的标题位置。
setToggleClickCount(int) - 类 javax.swing.JTree 中的方法
设置节点展开或关闭之前鼠标的单击数。
setToIdentity() - 类 java.awt.geom.AffineTransform 中的方法
将此变换重置为恒等变换。
setTokenThreshold(int) - 类 javax.swing.text.html.HTMLDocument 中的方法
设置在试图更新文档元素结构之前要缓冲的标记数。
setToolTip(String) - 类 java.awt.TrayIcon 中的方法
设置此 TrayIcon 的工具提示字符串。
setToolTipText(String) - 类 javax.swing.JComponent 中的方法
注册要在工具提示中显示的文本。
setToolTipTextAt(int, String) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的工具提示文本设置为 toolTipText，它可以为 null。
setToPage(int) - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的最后一页（包括该页）。
setTopComponent(Component) - 类 javax.swing.JSplitPane 中的方法
将组件设置到分隔条的上面或者左边。
setTopDown(boolean) - 类 javax.imageio.plugins.bmp.BMPImageWriteParam 中的方法
如果设置，则数据以从上到下的方式写出，首先写出第一个扫描行。
setTopInset(float) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图四周顶部的空白部分。
setToQuadrantRotation(int) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为按指定象限数旋转坐标的旋转变换。
setToQuadrantRotation(int, double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为按指定象限数绕指定锚点旋转坐标的平移旋转变换。
setToRotation(double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为旋转变换。
setToRotation(double, double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为平移的旋转变换。
setToRotation(double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为根据旋转向量旋转坐标的旋转变换。
setToRotation(double, double, double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为根据旋转向量绕锚点旋转坐标的旋转变换。
setToScale(double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为缩放变换。
setToShear(double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为错切变换。
setToTranslation(double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为平移变换。
setTrackMute(int, boolean) - 接口 javax.sound.midi.Sequencer 中的方法
设置轨道的静音状态。
setTrackSolo(int, boolean) - 接口 javax.sound.midi.Sequencer 中的方法
设置轨道的 solo 状态。
setTrafficClass(int) - 类 java.net.DatagramSocket 中的方法
为从此 DatagramSocket 上发送的数据报在 IP 数据报头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。
setTrafficClass(int) - 类 java.net.Socket 中的方法
为从此 Socket 上发送的包在 IP 头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。
setTransactionIsolation(int) - 接口 java.sql.Connection 中的方法
试图将此 Connection 对象的事务隔离级别更改为给定的级别。
setTransactionIsolation(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 JDBC RowSet 对象的事务隔离属性设置为给定的常量。
setTransactionIsolation(int) - 接口 javax.sql.RowSet 中的方法
设置此 RowSet 对象的事务隔离级别。
setTransactionTimeout(int) - 接口 javax.transaction.xa.XAResource 中的方法
为此 XAResource 实例设置当前事务超时值。
setTransferHandler(TransferHandler) - 类 javax.swing.JApplet 中的方法
设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。
setTransferHandler(TransferHandler) - 类 javax.swing.JComponent 中的方法
设置 transferHandler 属性；如果该组件不支持数据传输操作，则为 null。
setTransferHandler(TransferHandler) - 类 javax.swing.JDialog 中的方法
设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。
setTransferHandler(TransferHandler) - 类 javax.swing.JFrame 中的方法
设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。
setTransferHandler(TransferHandler) - 类 javax.swing.JWindow 中的方法
设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。
setTransform(AffineTransform) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为指定 AffineTransform 对象中变换的副本。
setTransform(double, double, double, double, double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为 6 个双精度值指定的矩阵。
setTransform(AffineTransform) - 类 java.awt.Graphics2D 中的方法
重写 Graphics2D 上下文中的 Transform。
setTransform(AffineTransform) - 类 java.awt.image.renderable.RenderContext 中的方法
将 RenderContext 中包含的当前“用户到设备”的 AffineTransform 设置为给定的变换。
setTree(JTree) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
设置当前正在为其编辑的树。
setTrustAnchors(Set<TrustAnchor>) - 类 java.security.cert.PKIXParameters 中的方法
设置最受信任的 CA Set。
setTTL(byte) - 类 java.net.DatagramSocketImpl 中的方法
已过时。 使用 setTimeToLive 代替。
setTTL(byte) - 类 java.net.MulticastSocket 中的方法
已过时。 使用 setTimeToLive 方法来代替，该方法使用 int（而不用 byte）作为 ttl 的类型。
setType(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的类型设置为指定类型。
setType(int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的类型设置为给定的类型。
setType(short) - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
设置元素类型。
setType(int, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
设置特定属性的类型。
setTypeMap(Map<String, Class<?>>) - 接口 java.sql.Connection 中的方法
将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。
setTypeMap(Map<String, Class<?>>) - 类 javax.sql.rowset.BaseRowSet 中的方法
将给定的 java.util.Map 对象安装为与此 RowSet 对象的 Connection 对象关联的类型映射表。
setTypeMap(Map<String, Class<?>>) - 接口 javax.sql.RowSet 中的方法
将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。
setUI(ButtonUI) - 类 javax.swing.AbstractButton 中的方法
设置呈现此组件的 L&F 对象。
setUI(ColorChooserUI) - 类 javax.swing.JColorChooser 中的方法
设置呈现此组件的 L&F 对象。
setUI(ComboBoxUI) - 类 javax.swing.JComboBox 中的方法
设置呈现此组件的 L&F 对象。
setUI(ComponentUI) - 类 javax.swing.JComponent 中的方法
设置此组件的外观委托。
setUI(DesktopPaneUI) - 类 javax.swing.JDesktopPane 中的方法
设置呈现此组件的 L&F 对象。
setUI(DesktopIconUI) - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
设置呈现此组件的外观对象。
setUI(InternalFrameUI) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 UI 委托。
setUI(LabelUI) - 类 javax.swing.JLabel 中的方法
设置呈现此组件的 L&F 对象。
setUI(ListUI) - 类 javax.swing.JList 中的方法
设置呈现此组件的外观对象 ListUI。
setUI(MenuBarUI) - 类 javax.swing.JMenuBar 中的方法
设置呈现此组件的 L&F 对象。
setUI(MenuItemUI) - 类 javax.swing.JMenuItem 中的方法
设置呈现此组件的外观对象。
setUI(OptionPaneUI) - 类 javax.swing.JOptionPane 中的方法
设置实现此组件 L&F 的 UI 对象。
setUI(PanelUI) - 类 javax.swing.JPanel 中的方法
设置呈现此组件的外观 (L&F) 对象。
setUI(PopupMenuUI) - 类 javax.swing.JPopupMenu 中的方法
设置呈现此组件的 L&F 对象。
setUI(ProgressBarUI) - 类 javax.swing.JProgressBar 中的方法
设置呈现此组件的外观对象。
setUI(RootPaneUI) - 类 javax.swing.JRootPane 中的方法
设置呈现此组件的 L&F 对象。
setUI(ScrollBarUI) - 类 javax.swing.JScrollBar 中的方法
设置呈现此组件的 L&F 对象。
setUI(ScrollPaneUI) - 类 javax.swing.JScrollPane 中的方法
设置 ScrollPaneUI 对象，它为此组件提供外观 (L&F)。
setUI(SeparatorUI) - 类 javax.swing.JSeparator 中的方法
设置呈现此组件的 L&F 对象。
setUI(SliderUI) - 类 javax.swing.JSlider 中的方法
设置实现此组件 L&F 的 UI 对象。
setUI(SpinnerUI) - 类 javax.swing.JSpinner 中的方法
设置呈现此组件的外观 (L&F) 对象。
setUI(SplitPaneUI) - 类 javax.swing.JSplitPane 中的方法
设置呈现此组件的 L&F 对象。
setUI(TabbedPaneUI) - 类 javax.swing.JTabbedPane 中的方法
设置实现此组件的 L&F 的 UI 对象。
setUI(TableUI) - 类 javax.swing.JTable 中的方法
设置呈现此组件并进行重新绘制的 L&F 对象。
setUI(ToolBarUI) - 类 javax.swing.JToolBar 中的方法
设置呈现此组件的 L&F 对象。
setUI(TreeUI) - 类 javax.swing.JTree 中的方法
设置呈现此组件的 L&F 对象。
setUI(ViewportUI) - 类 javax.swing.JViewport 中的方法
设置呈现此组件的 L&F 对象。
setUI(TableHeaderUI) - 类 javax.swing.table.JTableHeader 中的方法
设置渲染此组件的 (L&F) 对象。
setUI(TextUI) - 类 javax.swing.text.JTextComponent 中的方法
设置此面向文本的编辑器的用户界面工厂。
setUncaughtExceptionHandler(Thread.UncaughtExceptionHandler) - 类 java.lang.Thread 中的方法
设置该线程由于未捕获到异常而突然终止时调用的处理程序。
setUndecorated(boolean) - 类 java.awt.Dialog 中的方法
禁用或启用此 dialog 的装饰。
setUndecorated(boolean) - 类 java.awt.Frame 中的方法
禁用或启用此窗体的装饰。
setUnderline(boolean) - 类 javax.swing.text.LabelView 中的方法
设置视图是否加下划线。
setUnderline(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置下标属性。
setUnexecutedModifications(ModificationItem[]) - 异常 javax.naming.directory.AttributeModificationException 中的方法
将未执行的修改列表设置为 e。
setUnicast(boolean) - 类 java.beans.EventSetDescriptor 中的方法
将事件集标记为单播（或非单播）。
setUnicodeStream(int, InputStream, int) - 接口 java.sql.PreparedStatement 中的方法
已过时。
setUnicodeStream(int, InputStream, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
已过时。 应该使用 getCharacterStream 替代它
setUnitIncrement(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的单位值增量。
setUnitIncrement(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的单位增量。
setUnitIncrement(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
setUnitIncrement(int) - 类 javax.swing.JScrollBar 中的方法
设置 unitIncrement 属性。
setUnitIncrement(int) - 类 javax.swing.JScrollPane.ScrollBar 中的方法
通知超类来设定该值，并将 unitIncrementSet 实例变量重置为 true。
setup(FileSystemView) - 类 javax.swing.JFileChooser 中的方法
执行公共的构造方法初始化和设置。
setUpdatePolicy(int) - 类 javax.swing.text.DefaultCaret 中的方法
设置文档更新时的插入符移动策略。
setUpdateRect(Rectangle) - 类 java.awt.event.PaintEvent 中的方法
设置表示需要进行重绘区域以响应此事件的矩形。
setUpdateSelectionOnSort(boolean) - 类 javax.swing.JTable 中的方法
指定排序后是否应该更新选择。
setUpdateTableInRealTime(boolean) - 类 javax.swing.table.JTableHeader 中的方法
从 Java 2 platform v1.3 开始已过时。
setupMenuCloseKey() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setupMenuOpenKey() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setupPostTimer(JMenu) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
setURI(int, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
设置特定属性的名称空间 URI。
setURIDereferencer(URIDereferencer) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
setURIDereferencer(URIDereferencer) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
设置用来取消引用 URIReference 的 URIDereferencer。
setURIResolver(URIResolver) - 类 javax.xml.transform.Transformer 中的方法
设置将用于解析在 document() 中使用的 URI 的对象。
setURIResolver(URIResolver) - 类 javax.xml.transform.TransformerFactory 中的方法
设置在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。
setURL(URL, String, String, int, String, String, String, String, String) - 类 java.net.URLStreamHandler 中的方法
将 URL 参数的字段设置为指示的值。
setURL(URL, String, String, int, String, String) - 类 java.net.URLStreamHandler 中的方法
已过时。 使用 setURL(URL, String, String, int, String, String, String, String);
setURL(String, URL) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.net.URL 对象。
setURL(int, URL) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.net.URL 值。
setUrl(String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的 Url 属性设置为给定的 String 对象，并将 dataSource 名称属性设置为 null。
setURL(int, URL) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.net.URL 值。
setUrl(String) - 接口 javax.sql.RowSet 中的方法
设置此 RowSet 对象在使用 DriverManager 创建连接时将使用的 URL。
setURL(int, URL) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.net.URL 值。
setURL(URL) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 URL 字段。
setURLStreamHandlerFactory(URLStreamHandlerFactory) - 类 java.net.URL 中的静态方法
设置应用程序的 URLStreamHandlerFactory。
setUsageThreshold(long) - 接口 java.lang.management.MemoryPoolMXBean 中的方法
如果此内存池支持使用量阈值，则将此内存池的阈值设置为给定的 threshold 值。
setUseCache(boolean) - 类 javax.imageio.ImageIO 中的静态方法
设置一个标记，指示在创建 ImageInputStream 和 ImageOutputStream 时是否应该使用基于磁盘的缓存文件。
setUseCaches(boolean) - 类 java.net.URLConnection 中的方法
将此 URLConnection 的 useCaches 字段的值设置为指定的值。
setUseClientMode(boolean) - 类 javax.net.ssl.SSLEngine 中的方法
配置引擎在握手时使用客户端（或服务器）模式。
setUseClientMode(boolean) - 类 javax.net.ssl.SSLServerSocket 中的方法
控制接受的连接是以（默认的）SSL 服务器模式还是在 SSL 客户端模式工作。
setUseClientMode(boolean) - 类 javax.net.ssl.SSLSocket 中的方法
配置套接字在握手时使用客户机（或服务器）模式。
setUseParentHandlers(boolean) - 类 java.util.logging.Logger 中的方法
指定此 logger 是否应该将其输出发送到它的父 Logger。
setUserData(String, Object, UserDataHandler) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setUserData(Object) - 类 javax.management.Notification 中的方法
设置用户数据。
setUserData(String, Object, UserDataHandler) - 接口 org.w3c.dom.Node 中的方法
将对象与此节点上的键相关联。
setUsername(String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的 username 属性设置为给定的用户名。
setUsername(String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的用户名属性设置为给定的 String。
setUserObject(Object) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
设置与此节点关联的值。
setUserObject(Object) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
将此节点的用户对象设置为 userObject。
setUserObject(Object) - 接口 javax.swing.tree.MutableTreeNode 中的方法
将接收者的用户对象重新设置为 object。
setValidating(boolean) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
指定 Unmarshaller 是否应该在执行解组操作期间进行验证。
setValidating(boolean) - 接口 javax.xml.bind.Unmarshaller 中的方法
已过时。 从 JAXB2.0 开始，请参阅 Unmarshaller.setSchema(javax.xml.validation.Schema)
setValidating(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此代码生成的解析器将验证被解析的文档。
setValidating(boolean) - 类 javax.xml.parsers.SAXParserFactory 中的方法
指定由此代码生成的解析器将验证被解析的文档。
setValidCharacters(String) - 类 javax.swing.text.MaskFormatter 中的方法
允许进一步限制可以输入的字符。
setValue(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的当前值。
setValue(int) - 类 java.awt.Scrollbar 中的方法
将此滚动条的值设置为指定值。
setValue(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
将此滚动条的值设置为指定值。
setValue(Object) - 类 java.beans.Expression 中的方法
将此表达式的值设置为 value。
setValue(String, Object) - 类 java.beans.FeatureDescriptor 中的方法
将某一指定属性与此特性相关联。
setValue(Object) - 接口 java.beans.PropertyEditor 中的方法
设置（或更改）将编辑的对象。
setValue(Object) - 类 java.beans.PropertyEditorSupport 中的方法
设置（或更改）将被编辑的对象。
setValue(String) - 类 java.net.HttpCookie 中的方法
在创建 cookie 之后将新值分配给 cookie。
setValue(V) - 类 java.util.AbstractMap.SimpleEntry 中的方法
用指定值替换对应于此项的值。
setValue(V) - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
用指定值替换对应于此项的值（可选操作）。
setValue(V) - 接口 java.util.Map.Entry 中的方法
用指定的值替换与此项对应的值（可选操作）。
setValue(boolean) - 类 javax.sound.sampled.BooleanControl 中的方法
设置控件的当前值。
setValue(Object) - 类 javax.sound.sampled.EnumControl 中的方法
设置控件的当前值。
setValue(float) - 类 javax.sound.sampled.FloatControl 中的方法
设置控件的当前值。
setValue(int) - 接口 javax.swing.BoundedRangeModel 中的方法
如果 newValue 满足模型的约束限制，则将模型的当前值设置为 newValue。
setValue(int) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
设置模型的当前值。
setValue(Object) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
设置此单元格的值。
setValue(Object) - 类 javax.swing.JFormattedTextField 中的方法
设置值，该值由从当前 AbstractFormatterFactory 获得的 AbstractFormatter 进行格式化。
setValue(Object) - 类 javax.swing.JOptionPane 中的方法
设置用户所选值。
setValue(int) - 类 javax.swing.JProgressBar 中的方法
将进度条的当前值设置为 n。
setValue(int) - 类 javax.swing.JScrollBar 中的方法
设置滚动条的值。
setValue(int) - 类 javax.swing.JSlider 中的方法
将滑块的当前值设置为 n。
setValue(Object) - 类 javax.swing.JSpinner 中的方法
更改模型的当前值，通常此值是 editor 所显示的值。
setValue(Object, boolean) - 接口 javax.swing.Renderer 中的方法
指定要显示的值和是否应将该值描绘为“当前选定”。
setValue(Object) - 类 javax.swing.SpinnerDateModel 中的方法
设置此序列的当前 Date。
setValue(Object) - 类 javax.swing.SpinnerListModel 中的方法
改变该序列的当前元素并通知 ChangeListeners。
setValue(Object) - 接口 javax.swing.SpinnerModel 中的方法
改变该模型的当前值，通常此值由 JSpinner 的 editor 部分显示。
setValue(Object) - 类 javax.swing.SpinnerNumberModel 中的方法
设置此序列的当前元素。
setValue(int) - 类 javax.swing.Spring 中的方法
将此 Spring 的当前 value 设置为 value。
setValue(Object) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
将要呈现的单元格的 String 对象设置为 value。
setValue(T) - 类 javax.xml.bind.JAXBElement 中的方法
设置此 xml 元素的内容模式和属性。
setValue(String) - 接口 javax.xml.soap.Node 中的方法
如果这是一个 Text 节点，则此方法会设置它的值，否则该方法设置此节点的直接 (Text) 子节点值。
setValue(String) - 接口 org.w3c.dom.Attr 中的方法
检索时，该属性值以字符串形式返回。
setValue(int, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
设置特定属性的值。
setValueAt(Object, int, int) - 类 javax.swing.JTable 中的方法
设置表模型中 row 和 column 位置的单元格值。
setValueAt(Object, int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
由于提供了此空实现，因此，如果用户的数据模型是不可编辑的，则他们不必实现此方法。
setValueAt(Object, int, int) - 类 javax.swing.table.DefaultTableModel 中的方法
设置 column 和 row 处单元格的对象值。
setValueAt(Object, int, int) - 接口 javax.swing.table.TableModel 中的方法
将 columnIndex 和 rowIndex 位置的单元格中的值设置为 aValue。
setValueClass(Class<?>) - 类 javax.swing.text.DefaultFormatter 中的方法
设置用于创建新 Objects 的类。
setValueContainsLiteralCharacters(boolean) - 类 javax.swing.text.MaskFormatter 中的方法
如果为 true，则返回的值和设置的值还将包含掩码中的字面值字符。
setValueIsAdjusting(boolean) - 类 java.awt.Scrollbar 中的方法
设置 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 类 java.awt.ScrollPaneAdjustable 中的方法
设置 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 接口 javax.swing.BoundedRangeModel 中的方法
此属性指示，即将对模型值所做的任何更改都应被认为是一个单独的事件。
setValueIsAdjusting(boolean) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
设置 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置 valueIsAdjusting 属性，指示即将进行的选择更改是否应该被视为单个更改的一部分。
setValueIsAdjusting(boolean) - 类 javax.swing.JList 中的方法
设置选择模型的 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 类 javax.swing.JScrollBar 中的方法
设置模型的 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 类 javax.swing.JSlider 中的方法
设置模型的 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 接口 javax.swing.ListSelectionModel 中的方法
设置 valueIsAdjusting 属性，指示即将进行的选择更改是否应该被视为单个更改的一部分。
setValues(int, int, int, int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的四个属性值：value、visibleAmount、minimum 和 maximum。
setValues(int, int, int, int) - 类 javax.swing.JScrollBar 中的方法
强制参数满足以下常规约束后设置四个 BoundedRangeModel 属性：
setVerbose(boolean) - 接口 java.lang.management.ClassLoadingMXBean 中的方法
为类加载系统启用或禁用 verbose 输出。
setVerbose(boolean) - 接口 java.lang.management.MemoryMXBean 中的方法
启用或禁用内存系统的 verbose 输出。
setVerifyInputWhenFocusTarget(boolean) - 类 javax.swing.JComponent 中的方法
设置该值指示是否在此组件请求焦点前，为当前的焦点所有者调用输入校验器。
setVersion(int) - 类 java.net.HttpCookie 中的方法
设置此 cookie 遵守的 cookie 协议版本。
setVerticalAlignment(int) - 类 javax.swing.AbstractButton 中的方法
设置图标和文本的垂直对齐方式。
setVerticalAlignment(int) - 类 javax.swing.JLabel 中的方法
设置标签内容沿 Y 轴的对齐方式。
setVerticalGroup(GroupLayout.Group) - 类 javax.swing.GroupLayout 中的方法
设置沿垂直轴确定组件位置和大小的 Group。
setVerticalScrollBar(JScrollBar) - 类 javax.swing.JScrollPane 中的方法
将控制视口垂直视图位置的滚动条添加到滚动窗格中。
setVerticalScrollBarPolicy(int) - 类 javax.swing.JScrollPane 中的方法
确定垂直滚动条何时显示在滚动窗格上。
setVerticalScrollBarPolicy(int) - 类 javax.swing.ScrollPaneLayout 中的方法
设置垂直滚动条的显示策略。
setVerticalTextPosition(int) - 类 javax.swing.AbstractButton 中的方法
设置文本相对于图标的垂直位置。
setVerticalTextPosition(int) - 类 javax.swing.JLabel 中的方法
设置标签的文本相对其图像的垂直位置。
setVgap(int) - 类 java.awt.BorderLayout 中的方法
设置组件之间的垂直间距。
setVgap(int) - 类 java.awt.CardLayout 中的方法
设置组件之间的垂直间距。
setVgap(int) - 类 java.awt.FlowLayout 中的方法
设置组件之间以及组件与 Container 的边之间的垂直间隙。
setVgap(int) - 类 java.awt.GridLayout 中的方法
将组件之间的垂直间距设置为指定值。
setView(Component) - 类 javax.swing.JViewport 中的方法
设置 JViewport 的一个轻量子对象 (view)，可以为 null。
setView(View) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
设置视图层次结构的当前根并调用 invalidate()。
setViewport(JViewport) - 类 javax.swing.JScrollPane 中的方法
移除旧视口（如果有）；强制新视口的 viewPosition 位于 +x,+y 象限中；将行和列标题（如果有）与新视口同步；最后将滚动条和标题与新视口同步。
setViewportBorder(Border) - 类 javax.swing.JScrollPane 中的方法
围绕视口添加一个边界。
setViewportView(Component) - 类 javax.swing.JScrollPane 中的方法
创建一个视口（如果有必要）并设置其视图。
setViewPosition(Point) - 类 javax.swing.JViewport 中的方法
设置显示在视口左上角的视图坐标，如果不存在视图，则不执行任何操作。
setViewSize(Dimension) - 类 javax.swing.JViewport 中的方法
设置视图的大小。
setVisible(boolean) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的可见状态。
setVisible(boolean) - 类 java.awt.Component 中的方法
根据参数 b 的值显示或隐藏此组件。
setVisible(boolean) - 类 java.awt.Dialog 中的方法
根据参数 b 的值显示或隐藏此 Dialog。
setVisible(boolean) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置对象的可见状态。
setVisible(boolean) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置该对象的可见状态。
setVisible(boolean) - 类 java.awt.Window 中的方法
根据参数 b 的值显示或隐藏此 Window。
setVisible(boolean) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置对象的可见状态。
setVisible(boolean) - 类 javax.swing.JComponent 中的方法
使该组件可见或不可见。
setVisible(boolean) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setVisible(boolean) - 类 javax.swing.JPopupMenu 中的方法
设置弹出菜单的可见性。
setVisible(boolean) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置该对象的可见状态。
setVisible(boolean) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setVisible(boolean) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setVisible(boolean) - 接口 javax.swing.text.Caret 中的方法
设置插入符的可见性。
setVisible(boolean) - 类 javax.swing.text.DefaultCaret 中的方法
设置插入符可见性，并重绘插入符。
setVisibleAmount(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的比例指示器的长度。
setVisibleAmount(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的可见量。
setVisibleAmount(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
此方法不应由用户代码调用。
setVisibleAmount(int) - 类 javax.swing.JScrollBar 中的方法
设置模型的 extent 属性。
setVisibleComponent(Component) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
setVisibleRowCount(int) - 类 javax.swing.JList 中的方法
设置 visibleRowCount 属性，对于不同的布局方向，此方法有不同的含义：对于 VERTICAL 布局方向，此方法设置要显示的首选行数（不要求滚动）；对于其他方向，它影响单元的包装。
setVisibleRowCount(int) - 类 javax.swing.JTree 中的方法
设置要显示的行数。
setWantClientAuth(boolean) - 类 javax.net.ssl.SSLEngine 中的方法
配置引擎请求 客户端验证。
setWantClientAuth(boolean) - 类 javax.net.ssl.SSLParameters 中的方法
设置是否应该请求客户机验证。
setWantClientAuth(boolean) - 类 javax.net.ssl.SSLServerSocket 中的方法
控制 accept 服务器模式的 SSLSockets 是否将在开始时配置为请求 客户端验证。
setWantClientAuth(boolean) - 类 javax.net.ssl.SSLSocket 中的方法
配置套接字请求 客户机验证。
setWantsInput(boolean) - 类 javax.swing.JOptionPane 中的方法
设置 wantsInput 属性。
setWasIcon(JInternalFrame, Boolean) - 类 javax.swing.DefaultDesktopManager 中的方法
设定组件已被图标化并且 desktopIcon 的边界是有效的。
setWeekdays(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置星期字符串。
setWestPane(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setWheelScrollingEnabled(boolean) - 类 java.awt.ScrollPane 中的方法
启用/禁用对鼠标滚轮滚动的移动响应。
setWheelScrollingEnabled(boolean) - 类 javax.swing.JScrollPane 中的方法
启用/禁用对鼠标滚轮滚动的移动响应。
setWidth(Spring) - 类 javax.swing.SpringLayout.Constraints 中的方法
设置 width 属性，该属性控制组件的宽度。
setWidth(int) - 类 javax.swing.table.TableColumn 中的方法
不应使用此方法来设置 JTable 中列的宽度，而应使用 setPreferredWidth。
setWindingRule(int) - 类 java.awt.geom.Path2D 中的方法
将此路径的旋绕规则设置为指定值。
setWindowDecorationStyle(int) - 类 javax.swing.JRootPane 中的方法
设置 JRootPane 应提供的 Window 装饰类型（例如，边界、关闭 Window 的小部件、标题等）。
setWrapStyleWord(boolean) - 类 javax.swing.JTextArea 中的方法
设置换行方式（如果文本区要换行）。
setWritable(boolean, boolean) - 类 java.io.File 中的方法
设置此抽象路径名的所有者或所有用户的写权限。
setWritable(boolean) - 类 java.io.File 中的方法
设置此抽象路径名所有者写权限的一个便捷方法。
setWriteMethod(Method) - 类 java.beans.PropertyDescriptor 中的方法
设置应该用于写入属性值的方法。
setWriter(Writer) - 接口 javax.script.ScriptContext 中的方法
设置脚本的 Writer，以便在显示输出时使用。
setWriter(Writer) - 类 javax.script.SimpleScriptContext 中的方法
设置脚本的 Writer，以便在显示输出时使用。
setWriter(Writer) - 类 javax.xml.transform.stream.StreamResult 中的方法
设置要接收结果的 writer。
setX(Spring) - 类 javax.swing.SpringLayout.Constraints 中的方法
设置 x 属性，该属性控制组件位置的 x 值。
setXIncludeAware(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
设置 XInclude 处理的状态。
setXIncludeAware(boolean) - 类 javax.xml.parsers.SAXParserFactory 中的方法
设置 XInclude 处理的状态。
setXMLReader(XMLReader) - 类 javax.xml.transform.sax.SAXSource 中的方法
设置要用于 Source 的 XMLReader。
setXMLReporter(XMLReporter) - 类 javax.xml.stream.XMLInputFactory 中的方法
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。
setXMLResolver(XMLResolver) - 类 javax.xml.stream.XMLInputFactory 中的方法
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。
setXmlStandalone(boolean) - 接口 org.w3c.dom.Document 中的方法
作为 XML 声明 的一部分指定此文档是否是单独的的属性。
setXmlVersion(String) - 接口 org.w3c.dom.Document 中的方法
作为 XML 声明 的一部分指定此文档版本号的属性。
setXMLVersion(String) - 类 org.xml.sax.ext.Locator2Impl 中的方法
分配版本属性的当前值。
setXORMode(Color) - 类 java.awt.Graphics 中的方法
将此图形上下文的绘图模式设置为在此图形上下文的当前颜色和新的指定颜色之间交替。
setXORMode(Color) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.setXORMode。
setXPathFunctionResolver(XPathFunctionResolver) - 接口 javax.xml.xpath.XPath 中的方法
建立函数解析器。
setXPathFunctionResolver(XPathFunctionResolver) - 类 javax.xml.xpath.XPathFactory 中的方法
建立默认函数解析器。
setXPathVariableResolver(XPathVariableResolver) - 接口 javax.xml.xpath.XPath 中的方法
建立变量解析器。
setXPathVariableResolver(XPathVariableResolver) - 类 javax.xml.xpath.XPathFactory 中的方法
建立默认变量解析器。
setY(Spring) - 类 javax.swing.SpringLayout.Constraints 中的方法
设置 y 属性，该属性控制组件位置的 y 值。
setYear(int) - 类 java.sql.Time 中的方法
已过时。
setYear(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.YEAR, year + 1900) 取代。
setYear(BigInteger) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置 XSD dateTime year 字段的低和高顺序组件。
setYear(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置 XSD dateTime year 字段的年。
setZeroDigit(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于零的字符。
setZoneStrings(String[][]) - 类 java.text.DateFormatSymbols 中的方法
设置时区字符串。
SEVERE - 类 java.util.logging.Level 中的静态变量
SEVERE 是指示严重失败的消息级别。
severe(String) - 类 java.util.logging.Logger 中的方法
记录一条 SEVERE 消息。
Severity - javax.print.attribute.standard 中的 类
Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。
Severity(int) - 类 javax.print.attribute.standard.Severity 的构造方法
构造具有给定整数值的新 Severity 枚举值。
SEVERITY_ERROR - 接口 org.w3c.dom.DOMError 中的静态变量
DOMError 描述的错误的严重性为错误。
SEVERITY_FATAL_ERROR - 接口 org.w3c.dom.DOMError 中的静态变量
DOMError 描述的错误的严重性为严重错误。
SEVERITY_WARNING - 接口 org.w3c.dom.DOMError 中的静态变量
DOMError 描述的错误的严重性为警告。
SHA1 - 类 java.security.spec.MGF1ParameterSpec 中的静态变量
使用“SHA-1”消息摘要的 MGF1ParameterSpec。
SHA1 - 接口 javax.xml.crypto.dsig.DigestMethod 中的静态变量
SHA1 摘要方法的算法 URI。
SHA256 - 类 java.security.spec.MGF1ParameterSpec 中的静态变量
使用“SHA-256”消息摘要的 MGF1ParameterSpec。
SHA256 - 接口 javax.xml.crypto.dsig.DigestMethod 中的静态变量
SHA256 摘要方法的算法 URI。
SHA384 - 类 java.security.spec.MGF1ParameterSpec 中的静态变量
使用“SHA-384”消息摘要的 MGF1ParameterSpec。
SHA512 - 类 java.security.spec.MGF1ParameterSpec 中的静态变量
使用 SHA-512 消息摘要的 MGF1ParameterSpec。
SHA512 - 接口 javax.xml.crypto.dsig.DigestMethod 中的静态变量
SHA512 摘要方法的算法 URI。
shadow - 类 javax.swing.border.EtchedBorder 中的变量
shadow - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的变量
shadow - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的变量
shadow - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 中的变量
shadow - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的变量
shadow - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
shadowInner - 类 javax.swing.border.BevelBorder 中的变量
shadowOuter - 类 javax.swing.border.BevelBorder 中的变量
shallowClone() - 类 java.awt.image.renderable.ParameterBlock 中的方法
创建 ParameterBlock 的一个浅表副本。
shape(char[], int, int) - 类 java.awt.font.NumericShaper 中的方法
转换文本中在 start 和 start + count 之间出现的数字。
shape(char[], int, int, int) - 类 java.awt.font.NumericShaper 中的方法
使用提供的上下文，转换文本中在 start 和 start + count 之间出现的数字。
Shape - java.awt 中的 接口
Shape 接口提供了表示一些几何形状的对象的定义。
SHAPE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ShapeGraphicAttribute - java.awt.font 中的 类
ShapeGraphicAttribute 类是以 TextLayout 形式绘制形状的 GraphicAttribute 的实现。
ShapeGraphicAttribute(Shape, int, boolean) - 类 java.awt.font.ShapeGraphicAttribute 的构造方法
针对指定 Shape 构造 ShapeGraphicAttribute。
SHAPES - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
sharedInstance - 类 javax.swing.JTree.EmptySelectionModel 中的静态变量
独有的共享实例。
sharedInstance() - 类 javax.swing.JTree.EmptySelectionModel 中的静态方法
返回空选择模型的共享实例。
sharedInstance() - 类 javax.swing.ToolTipManager 中的静态方法
返回共享的 ToolTipManager 实例。
SHAVIAN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Shavian”Unicode 字符块的常量。
shear(double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与错切变换。
shear(double, double) - 类 java.awt.Graphics2D 中的方法
将当前 Graphics2D Transform 与剪裁转换连接。
SheetCollate - javax.print.attribute.standard 中的 类
SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
SheetCollate(int) - 类 javax.print.attribute.standard.SheetCollate 的构造方法
构造具有给定整数值的新 SheetCollate 枚举值。
shift(float, float, int) - 类 javax.sound.sampled.FloatControl 中的方法
在整个指定的时间内线性地将控件值从初始值更改为最终值，以微秒为单位进行指定。
SHIFT_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Shift 键的扩展修饰符常量。
SHIFT_MASK - 类 java.awt.event.ActionEvent 中的静态变量
shift 修饰符。
SHIFT_MASK - 类 java.awt.event.InputEvent 中的静态变量
Shift 键修饰符常量。
SHIFT_MASK - 类 java.awt.Event 中的静态变量
此标志指示当事件发生时按下 Shift 键。
shiftDown() - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
shiftEnd(int) - 类 javax.swing.text.GapContent 中的方法
扩大间隙、移动任何必要的数据和更新适当的标记。
shiftGap(int) - 类 javax.swing.text.GapContent 中的方法
将间隙的起始点移动到新位置，而不更改间隙的大小。
shiftGapEndUp(int) - 类 javax.swing.text.GapContent 中的方法
调整间隙，使其结尾向前扩展。
shiftGapStartDown(int) - 类 javax.swing.text.GapContent 中的方法
调整间隙，使其结尾向后扩展。
shiftLeft(int) - 类 java.math.BigInteger 中的方法
返回其值为 (this << n) 的 BigInteger。
shiftRight(int) - 类 java.math.BigInteger 中的方法
返回其值为 (this >> n) 的 BigInteger。
Short - java.lang 中的 类
Short 类在对象中包装基本类型 short 的值。
Short(short) - 类 java.lang.Short 的构造方法
构造一个新分配的 Short 对象，用来表示指定的 short 值。
Short(String) - 类 java.lang.Short 的构造方法
构造一个新分配的 Short 对象，用来表示 String 参数所指示的 short 值。
SHORT - 类 java.text.DateFormat 中的静态变量
用于 SHORT 模式的常量。
SHORT - 类 java.util.Calendar 中的静态变量
指示短名称的 getDisplayName 和 getDisplayNames 的风格说明符，比如 "Jan"。
SHORT - 类 java.util.TimeZone 中的静态变量
指出短名称（比如 "PST"）的 getDisplayName() 的风格说明符。
SHORT - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Short 的值。
SHORT_DESCRIPTION - 接口 javax.swing.Action 中的静态变量
用来存储动作的简短 String 描述的键，用于工具提示文本。
ShortBuffer - java.nio 中的 类
short 缓冲区。
ShortBufferException - javax.crypto 中的 异常
当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。
ShortBufferException() - 异常 javax.crypto.ShortBufferException 的构造方法
构造不带详细信息的 ShortBufferException。
ShortBufferException(String) - 异常 javax.crypto.ShortBufferException 的构造方法
构造带指定详细信息的 ShortBufferException。
shortcuts() - 类 java.awt.MenuBar 中的方法
获取此菜单栏正在管理的所有菜单快捷方式的枚举。
ShortHolder - org.omg.CORBA 中的 类
Short 的 Holder。
ShortHolder() - 类 org.omg.CORBA.ShortHolder 的构造方法
构造一个新的 ShortHolder 对象，将其 value 字段初始化为 0。
ShortHolder(short) - 类 org.omg.CORBA.ShortHolder 的构造方法
构造一个新的 ShortHolder 对象，并使用给定 short 值初始化其 value 字段。
ShortLookupTable - java.awt.image 中的 类
此类定义了一个查找表对象。
ShortLookupTable(int, short[][]) - 类 java.awt.image.ShortLookupTable 的构造方法
根据表示每个 band 的查找表的 short 型数组的数组构造 ShortLookupTable 对象。
ShortLookupTable(int, short[]) - 类 java.awt.image.ShortLookupTable 的构造方法
根据表示每个 band 的查找表的 short 型数组构造 ShortLookupTable 对象。
ShortMessage - javax.sound.midi 中的 类
ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。
ShortMessage() - 类 javax.sound.midi.ShortMessage 的构造方法
构造一个新的 ShortMessage。
ShortMessage(byte[]) - 类 javax.sound.midi.ShortMessage 的构造方法
构造一个新的 ShortMessage。
ShortSeqHelper - org.omg.CORBA 中的 类
ShortSeqHelper 的 Helper。
ShortSeqHelper() - 类 org.omg.CORBA.ShortSeqHelper 的构造方法
ShortSeqHolder - org.omg.CORBA 中的 类
ShortSeq 的 Holder。
ShortSeqHolder() - 类 org.omg.CORBA.ShortSeqHolder 的构造方法
ShortSeqHolder(short[]) - 类 org.omg.CORBA.ShortSeqHolder 的构造方法
shortValue() - 类 java.lang.Byte 中的方法
作为一个 short 返回此 Byte 的值。
shortValue() - 类 java.lang.Double 中的方法
以 short 形式返回此 Double 的值（通过强制转换为 short）。
shortValue() - 类 java.lang.Float 中的方法
将此 Float 值以 short 形式返回（强制转换为 short）。
shortValue() - 类 java.lang.Integer 中的方法
以 short 类型返回该 Integer 的值。
shortValue() - 类 java.lang.Long 中的方法
以 short 形式返回此 Long 的值。
shortValue() - 类 java.lang.Number 中的方法
以 short 形式返回指定的数值。
shortValue() - 类 java.lang.Short 中的方法
以 short 形式返回此 Short 的值。
shortValueExact() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 short，以检查丢失的信息。
shouldAccept(URI, HttpCookie) - 接口 java.net.CookiePolicy 中的方法
调用此方法查看此 cookie 是否应该被接受。
shouldFillGap(int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
shouldPadTabRun(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
shouldPadTabRun(int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
shouldPaintExpandControl(TreePath, int, boolean, boolean, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果应该为指定行绘制展开（切换）控件，则返回 true。
shouldRotateTabRuns(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
shouldRotateTabRuns(int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
shouldScroll(int) - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的方法
shouldSelectCell(EventObject) - 类 javax.swing.AbstractCellEditor 中的方法
返回 true。
shouldSelectCell(EventObject) - 接口 javax.swing.CellEditor 中的方法
如果应该选择正编辑的单元格，则返回 true，否则返回 false。
shouldSelectCell(EventObject) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
返回 true 指示可能选定正编辑的单元格。
shouldSelectCell(EventObject) - 类 javax.swing.DefaultCellEditor 中的方法
将消息从 CellEditor 转发到 delegate。
shouldSelectCell(EventObject) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
针对返回值，向 realEditor 发送消息。
shouldStartEditingTimer(EventObject) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果 event 为 MouseEvent，并且单击计数为 1，则返回 true。
shouldUpdateStyleOnAncestorChanged() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回在 JComponent 的祖先发生更改时，UI 是否应该更新 SynthStyleFactory 中的 SynthStyles。
shouldYieldFocus(JComponent) - 类 javax.swing.InputVerifier 中的方法
调用 verify(input) 来确保输入是有效的。
show(Container, String) - 类 java.awt.CardLayout 中的方法
翻转到使用 addLayoutComponent 添加到此布局的具有指定 name 的组件。
show() - 类 java.awt.Component.BltBufferStrategy 中的方法
使下一个有效缓冲区可见。
show() - 类 java.awt.Component.FlipBufferStrategy 中的方法
通过位图传送或翻转，使下一个可用的缓冲区可见。
show() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
show(boolean) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
show() - 类 java.awt.Dialog 中的方法
已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
show() - 类 java.awt.image.BufferStrategy 中的方法
通过复制内存（位图传输）或更改显示指针（翻转）使下一个可用缓冲区可见。
show(Component, int, int) - 类 java.awt.PopupMenu 中的方法
在相对于初始组件的 x、y 位置上显示弹出式菜单。
show() - 类 java.awt.Window 中的方法
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
show() - 类 javax.swing.JInternalFrame 中的方法
如果内部窗体不可见，则将该内部窗体置于前端，使其可见并尝试选定它。
show(Component, int, int) - 类 javax.swing.JPopupMenu 中的方法
在组件调用者的坐标空间中的位置 X、Y 显示弹出菜单。
show() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.show() 的实现。
show() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
显示弹出菜单
show() - 类 javax.swing.Popup 中的方法
使 Popup 可见。
showConfirmDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
调出带有选项 Yes、No 和 Cancel 的对话框；标题为 Select an Option。
showConfirmDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
调出一个由 optionType 参数确定其中选项数的对话框。
showConfirmDialog(Component, Object, String, int, int) - 类 javax.swing.JOptionPane 中的静态方法
调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。
showConfirmDialog(Component, Object, String, int, int, Icon) - 类 javax.swing.JOptionPane 中的静态方法
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。
showDialog(Component, String, Color) - 类 javax.swing.JColorChooser 中的静态方法
显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。
showDialog(Component, String) - 类 javax.swing.JFileChooser 中的方法
弹出具有自定义 approve 按钮的自定义文件选择器对话框。
showDocument(URL) - 接口 java.applet.AppletContext 中的方法
请求浏览器或 applet viewer 显示 url 参数指示的 Web 页面。
showDocument(URL, String) - 接口 java.applet.AppletContext 中的方法
请求浏览器或 applet viewer 显示由 url 参数所指示的 Web 页。
showHorizontalLines - 类 javax.swing.JTable 中的变量
如果 showHorizontalLines 为 true，则表在单元格之间绘制水平行。
SHOWING - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象、此对象的父对象、其父对象的父对象等都是可见的。
SHOWING_CHANGED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示 HIERARCHY_CHANGED 事件是因为层次结构的显示状态发生更改而生成的。
showInputDialog(Object) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入的问题消息对话框。
showInputDialog(Object, Object) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入的问题消息对话框，它带有已初始化为 initialSelectionValue 的输入值。
showInputDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
showInputDialog(Component, Object, Object) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
showInputDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。
showInputDialog(Component, Object, String, int, Icon, Object[], Object) - 类 javax.swing.JOptionPane 中的静态方法
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。
showInternalConfirmDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
调出带有选项 Yes、No 和 Cancel 的内部对话框面板；标题为 Select an Option。
showInternalConfirmDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
调出一个由 optionType 参数确定其中选项数的内部对话框面板。
showInternalConfirmDialog(Component, Object, String, int, int) - 类 javax.swing.JOptionPane 中的静态方法
调出一个由 optionType 参数确定其中选项数的内部对话框面板，messageType 参数确定要显示的图标。
showInternalConfirmDialog(Component, Object, String, int, int, Icon) - 类 javax.swing.JOptionPane 中的静态方法
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。
showInternalInputDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入内容的内部问题消息对话框，它以 parentComponent 为父级。
showInternalInputDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。
showInternalInputDialog(Component, Object, String, int, Icon, Object[], Object) - 类 javax.swing.JOptionPane 中的静态方法
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。
showInternalMessageDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
调出内部确认对话框面板。
showInternalMessageDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
调出一个显示消息的内部对话框面板，它使用由 messageType 参数确定的默认图标。
showInternalMessageDialog(Component, Object, String, int, Icon) - 类 javax.swing.JOptionPane 中的静态方法
调出一个显示消息的内部对话框面板，为其指定了所有参数。
showInternalOptionDialog(Component, Object, String, int, int, Icon, Object[], Object) - 类 javax.swing.JOptionPane 中的静态方法
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
showMessageDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
调出标题为 "Message" 的信息消息对话框。
showMessageDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。
showMessageDialog(Component, Object, String, int, Icon) - 类 javax.swing.JOptionPane 中的静态方法
调出一个显示信息的对话框，为其指定了所有参数。
showOpenDialog(Component) - 类 javax.swing.JFileChooser 中的方法
弹出一个 "Open File" 文件选择器对话框。
showOptionDialog(Component, Object, String, int, int, Icon, Object[], Object) - 类 javax.swing.JOptionPane 中的静态方法
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
showPopup() - 类 javax.swing.JComboBox 中的方法
促使组合框显示其弹出窗口。
SHOWS_ROOT_HANDLES_PROPERTY - 类 javax.swing.JTree 中的静态变量
showsRootHandles 的绑定属性名称。
showSaveDialog(Component) - 类 javax.swing.JFileChooser 中的方法
弹出一个 "Save File" 文件选择器对话框。
showsRootHandles - 类 javax.swing.JTree 中的变量
如果在树的最高层显示句柄，则为 True。
showStatus(String) - 类 java.applet.Applet 中的方法
请求将参数字符串显示在“状态窗口”中。
showStatus(String) - 接口 java.applet.AppletContext 中的方法
请求参数字符串显示在“状态窗口”中。
showSystemMenu() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
showSystemMenu() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
重写父级的方法，使其不执行任何操作。
showVerticalLines - 类 javax.swing.JTable 中的变量
如果 showVerticalLines 为 true，则表在单元格之间绘制垂直行。
shrinkAbsorb - 类 java.awt.font.GlyphJustificationInfo 中的变量
如果为 true，那么当此字形缩小时，它会占有此 priority 和更低 priority 的所有剩余收缩量。
shrinkLeftLimit - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形左边可以收缩的最大量（一个正数）。
shrinkPriority - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形缩小时的 priority 级别。
shrinkRightLimit - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形右边可以收缩的最大量（一个正数）。
shuffle(List<?>) - 类 java.util.Collections 中的静态方法
使用默认随机源对指定列表进行置换。
shuffle(List<?>, Random) - 类 java.util.Collections 中的静态方法
使用指定的随机源对指定列表进行置换。
shutdown() - 接口 java.rmi.activation.ActivationSystem 中的方法
关闭此激活系统。
shutdown() - 接口 java.util.concurrent.ExecutorService 中的方法
启动一次顺序关闭，执行以前提交的任务，但不接受新任务。
shutdown() - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
在以前已提交任务的执行中发起一个有序的关闭，但是不接受新任务。
shutdown() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
按过去执行已提交任务的顺序发起一个有序的关闭，但是不接受新任务。
SHUTDOWN - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
已经从服务中移除了打印机，并且可以给该打印机断电或者物理移除它。
shutdown(boolean) - 类 org.omg.CORBA.ORB 中的方法
指示关闭 ORB，这将导致关闭所有对象适配器，以准备销毁。
shutdownInput() - 类 java.net.Socket 中的方法
此套接字的输入流置于“流的末尾”。
shutdownInput() - 类 java.net.SocketImpl 中的方法
将此套接字的输入流置于“流的末尾”。
shutdownNow() - 接口 java.util.concurrent.ExecutorService 中的方法
试图停止所有正在执行的活动任务，暂停处理正在等待的任务，并返回等待执行的任务列表。
shutdownNow() - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
尝试停止所有正在执行的任务、暂停等待任务的处理，并返回等待执行的任务列表。
shutdownNow() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
尝试停止所有的活动执行任务、暂停等待任务的处理，并返回等待执行的任务列表。
shutdownOutput() - 类 java.net.Socket 中的方法
禁用此套接字的输出流。
shutdownOutput() - 类 java.net.SocketImpl 中的方法
禁用此套接字的输出流。
SIDE - 类 javax.print.attribute.standard.MediaTray 中的静态变量
侧面进纸托盘。
Sides - javax.print.attribute.standard 中的 类
Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。
Sides(int) - 类 javax.print.attribute.standard.Sides 的构造方法
构造具有给定整数值的新 sides 枚举值，
SIGN - 类 java.security.Signature 中的静态变量
可能的 Signature.state 值，表示此签名对象已经初始化签名。
sign() - 类 java.security.Signature 中的方法
返回所有已更新数据的签名字节。
sign(byte[], int, int) - 类 java.security.Signature 中的方法
完成签名操作并从 offset 开始，将得到的签名字节存储在提供的缓冲区 outbuf 中。
SIGN - 类 java.text.NumberFormat.Field 中的静态变量
标识符号字段的常量。
sign(XMLSignContext) - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
为此 XMLSignature 签名。
SIGN - 类 javax.xml.crypto.KeySelector.Purpose 中的静态变量
用于签名的密钥。
signal() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
将等待时间最长的线程（如果有）从此条件的等待队列移动到拥有锁的等待队列。
signal() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
将等待时间最长的线程（如果存在）从此条件的等待队列中移动到拥有锁的等待队列。
signal() - 接口 java.util.concurrent.locks.Condition 中的方法
唤醒一个等待线程。
signalAll() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
将所有线程从此条件的等待队列移动到拥有锁的等待队列。
signalAll() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
将所有线程从此条件的等待队列移动到拥有锁的等待队列中。
signalAll() - 接口 java.util.concurrent.locks.Condition 中的方法
唤醒所有等待线程。
Signature - java.security 中的 类
此 Signature 类用来为应用程序提供数字签名算法功能。
Signature(String) - 类 java.security.Signature 的构造方法
创建指定算法的 Signature 对象。
SIGNATURE_VERSION - 类 java.util.jar.Attributes.Name 中的静态变量
Signature-Version 的 Name 对象给出了签名 JAR 文件时所使用的属性。
SignatureException - java.security 中的 异常
这是一般的签名异常。
SignatureException() - 异常 java.security.SignatureException 的构造方法
构造不带详细消息的 SignatureException。
SignatureException(String) - 异常 java.security.SignatureException 的构造方法
构造带指定详细消息的 SignatureException。
SignatureException(String, Throwable) - 异常 java.security.SignatureException 的构造方法
创建带指定详细消息和原因的 SignatureException。
SignatureException(Throwable) - 异常 java.security.SignatureException 的构造方法
创建带指定的原因和详细消息的 SignatureException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
SignatureMethod - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureMethod 元素的表示形式。
SignatureMethodParameterSpec - javax.xml.crypto.dsig.spec 中的 接口
用于 XML SignatureMethod 算法的算法参数规范。
SignatureProperties - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperties 元素的表示形式。
SignatureProperty - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperty 元素的表示形式。
SignatureSpi - java.security 中的 类
此类为 Signature 类定义了服务提供者接口 (SPI)，可用来提供数字签名算法功能。
SignatureSpi() - 类 java.security.SignatureSpi 的构造方法
SignedInfo - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignedInfo 元素的表示形式。
SignedObject - java.security 中的 类
SignedObject 是一个用来创建实际运行时对象的类，在检测不到这些对象的情况下，其完整性不会遭受损害。
SignedObject(Serializable, PrivateKey, Signature) - 类 java.security.SignedObject 的构造方法
通过任何可序列化对象构造 SignedObject。
Signer - java.security 中的 类
已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。
Signer() - 类 java.security.Signer 的构造方法
已过时。 创建 signer。
Signer(String) - 类 java.security.Signer 的构造方法
已过时。 创建带有指定标识名称的 signer。
Signer(String, IdentityScope) - 类 java.security.Signer 的构造方法
已过时。 创建带有指定标识名称和范围的 signer。
signum(int) - 类 java.lang.Integer 中的静态方法
返回指定 int 值的符号函数。
signum(long) - 类 java.lang.Long 中的静态方法
返回指定 long 值的符号函数。
signum(double) - 类 java.lang.Math 中的静态方法
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。
signum(float) - 类 java.lang.Math 中的静态方法
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。
signum(double) - 类 java.lang.StrictMath 中的静态方法
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。
signum(float) - 类 java.lang.StrictMath 中的静态方法
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0f；如果参数小于 0，则返回 -1.0f。
signum() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的正负号函数。
signum() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的正负号函数。
SILENT - 类 java.rmi.server.LogStream 中的静态变量
已过时。 日志级别常量（无日志记录）。
SIMPLE_SCROLL_MODE - 类 javax.swing.JViewport 中的静态变量
此模式使用非常简单的方法，在 scrollpane 每次滚动时重绘它的整个内容。
SimpleAnnotationValueVisitor6<R,P> - javax.lang.model.util 中的 类
注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
SimpleAnnotationValueVisitor6() - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 的构造方法
具体子类的构造方法；使用 null 作为默认值。
SimpleAnnotationValueVisitor6(R) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 的构造方法
具体子类的构造方法；使用参数作为默认值。
SimpleAttributeSet - javax.swing.text 中的 类
使用哈希表的 MutableAttributeSet 的直接实现。
SimpleAttributeSet() - 类 javax.swing.text.SimpleAttributeSet 的构造方法
创建新属性集。
SimpleAttributeSet(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 的构造方法
根据提供的属性集创建新属性集。
SimpleBeanInfo - java.beans 中的 类
这是一个使得用户提供 BeanInfo 类更容易的支持类。
SimpleBeanInfo() - 类 java.beans.SimpleBeanInfo 的构造方法
SimpleBindings - javax.script 中的 类
一个受 HashMap 或其他某些指定 Map 支持的 Bindings 的简单实现。
SimpleBindings(Map<String, Object>) - 类 javax.script.SimpleBindings 的构造方法
构造方法使用现有 Map 来存储值。
SimpleBindings() - 类 javax.script.SimpleBindings 的构造方法
默认构造方法使用 HashMap。
SimpleDateFormat - java.text 中的 类
SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。
SimpleDateFormat() - 类 java.text.SimpleDateFormat 的构造方法
用默认的模式和默认语言环境的日期格式符号构造 SimpleDateFormat。
SimpleDateFormat(String) - 类 java.text.SimpleDateFormat 的构造方法
用给定的模式和默认语言环境的日期格式符号构造 SimpleDateFormat。
SimpleDateFormat(String, Locale) - 类 java.text.SimpleDateFormat 的构造方法
用给定的模式和给定语言环境的默认日期格式符号构造 SimpleDateFormat。
SimpleDateFormat(String, DateFormatSymbols) - 类 java.text.SimpleDateFormat 的构造方法
用给定的模式和日期符号构造 SimpleDateFormat。
SimpleDoc - javax.print 中的 类
此类是接口 Doc 的实现，可用于很多常见的打印请求中。
SimpleDoc(Object, DocFlavor, DocAttributeSet) - 类 javax.print.SimpleDoc 的构造方法
构造具有指定打印数据、doc flavor 和 doc 属性集的 SimpleDoc。
SimpleElementVisitor6<R,P> - javax.lang.model.util 中的 类
程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
SimpleElementVisitor6() - 类 javax.lang.model.util.SimpleElementVisitor6 的构造方法
具体子类的构造方法；使用 null 作为默认值。
SimpleElementVisitor6(R) - 类 javax.lang.model.util.SimpleElementVisitor6 的构造方法
具体子类的构造方法；使用参数作为默认值。
SimpleFormatter - java.util.logging 中的 类
以可读格式输出 LogRecord 的简单摘要。
SimpleFormatter() - 类 java.util.logging.SimpleFormatter 的构造方法
SimpleJavaFileObject - javax.tools 中的 类
为 JavaFileObject 中的大多数方法提供简单实现。
SimpleJavaFileObject(URI, JavaFileObject.Kind) - 类 javax.tools.SimpleJavaFileObject 的构造方法
使用给定 URI 构建给定种类的 SimpleJavaFileObject。
SimpleScriptContext - javax.script 中的 类
ScriptContext 的简单实现。
SimpleScriptContext() - 类 javax.script.SimpleScriptContext 的构造方法
SimpleTimeZone - java.util 中的 类
SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。
SimpleTimeZone(int, String) - 类 java.util.SimpleTimeZone 的构造方法
使用给定的相对于 GMT 的基准时区偏移量和不带夏令时安排的时区 ID 构造一个 SimpleTimeZone。
SimpleTimeZone(int, String, int, int, int, int, int, int, int, int) - 类 java.util.SimpleTimeZone 的构造方法
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。
SimpleTimeZone(int, String, int, int, int, int, int, int, int, int, int) - 类 java.util.SimpleTimeZone 的构造方法
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。
SimpleTimeZone(int, String, int, int, int, int, int, int, int, int, int, int, int) - 类 java.util.SimpleTimeZone 的构造方法
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。
SimpleType<T> - javax.management.openmbean 中的 类
SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。
SimpleTypeVisitor6<R,P> - javax.lang.model.util 中的 类
类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
SimpleTypeVisitor6() - 类 javax.lang.model.util.SimpleTypeVisitor6 的构造方法
具体子类的构造方法；使用 null 作为默认值。
SimpleTypeVisitor6(R) - 类 javax.lang.model.util.SimpleTypeVisitor6 的构造方法
具体子类的构造方法；使用参数作为默认值。
SIMPLIFIED_CHINESE - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
SIMPLIFIED_HANZI - 类 java.awt.im.InputSubset 中的静态变量
编写简体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的简体中文汉字字集。
sin(double) - 类 java.lang.Math 中的静态方法
返回角的三角正弦。
sin(double) - 类 java.lang.StrictMath 中的静态方法
返回角的三角正弦。
SINGLE_DOCUMENT - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的静态变量
单个文档 －－ 有关更多信息，请参见上文。
SINGLE_DOCUMENT_NEW_SHEET - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的静态变量
单个文档新纸张 －－ 有关更多信息，请参见上文。
SINGLE_INTERVAL_SELECTION - 接口 javax.swing.ListSelectionModel 中的静态变量
selectionMode 属性的值：一次选择一个连续的索引范围。
SINGLE_LINE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此（文本）对象只能包含单行文本
SINGLE_SELECTION - 接口 javax.swing.ListSelectionModel 中的静态变量
selectionMode 属性的值：一次选择一个列表索引。
SINGLE_THREAD_MODEL - 类 org.omg.PortableServer.ThreadPolicyValue 中的静态变量
SINGLE_TREE_SELECTION - 接口 javax.swing.tree.TreeSelectionModel 中的静态变量
一次只能选择一个路径。
SINGLEFRAME - 接口 java.awt.image.ImageConsumer 中的静态变量
该图像包含单幅静态图像。
SINGLEFRAMEDONE - 接口 java.awt.image.ImageConsumer 中的静态变量
图像的某一帧已完成，但还有更多的帧要传递。
SINGLEPASS - 接口 java.awt.image.ImageConsumer 中的静态变量
以单通道的方式传递像素。
SinglePixelPackedSampleModel - java.awt.image 中的 类
此类表示压缩的像素数据：将 N 个样本组成的单个像素存储在单个数据数组元素中，每个数据数组元素只保存一个像素的样本。
SinglePixelPackedSampleModel(int, int, int, int[]) - 类 java.awt.image.SinglePixelPackedSampleModel 的构造方法
构造一个具有 bitMasks.length band 的 SinglePixelPackedSampleModel。
SinglePixelPackedSampleModel(int, int, int, int, int[]) - 类 java.awt.image.SinglePixelPackedSampleModel 的构造方法
构造一个 SinglePixelPackedSampleModel，使其具有 bitMasks.length band，且扫描行间距等于 scanlineStride 数据数组元素。
SingleSelectionModel - javax.swing 中的 接口
最多支持一个索引选项的模型。
singleton(T) - 类 java.util.Collections 中的静态方法
返回一个只包含指定对象的不可变 set。
singletonKeySelector(Key) - 类 javax.xml.crypto.KeySelector 中的静态方法
返回一个总是选择指定密钥的 KeySelector，不管传递给它的 KeyInfo 是什么。
singletonList(T) - 类 java.util.Collections 中的静态方法
返回一个只包含指定对象的不可变列表。
singletonMap(K, V) - 类 java.util.Collections 中的静态方法
返回一个不可变的映射，它只将指定键映射到指定值。
sinh(double) - 类 java.lang.Math 中的静态方法
返回 double 值的双曲线正弦。
sinh(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的双曲线正弦。
SINHALA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Sinhala”Unicode 字符块的常量。
sink() - 类 java.nio.channels.Pipe 中的方法
返回此管道的接收器通道。
size() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getSize() 取代。
size - 类 java.awt.Font 中的变量
Font 的磅值大小，舍入为整数。
SIZE - 类 java.awt.font.TextAttribute 中的静态变量
字体大小的属性键。
size - 类 java.awt.image.DataBuffer 中的变量
所有存储单元的可用大小。
size() - 类 java.awt.RenderingHints 中的方法
返回此 RenderingHints 中的键-值映射关系数。
size() - 类 java.beans.beancontext.BeanContextMembershipEvent 中的方法
获得受通知影响的子级的数量。
size() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得当前嵌套在此 BeanContext 中的子级数。
size() - 类 java.io.ByteArrayOutputStream 中的方法
返回缓冲区的当前大小。
size() - 类 java.io.CharArrayWriter 中的方法
返回缓冲区的当前大小。
size() - 类 java.io.DataOutputStream 中的方法
返回计数器 written 的当前值，即到目前为止写入此数据输出流的字节数。
SIZE - 类 java.lang.Byte 中的静态变量
用于以二进制补码形式表示 byte 值的位数。
SIZE - 类 java.lang.Character 中的静态变量
用来以无符号二进制形式表示 char 值的位数。
SIZE - 类 java.lang.Double 中的静态变量
用于表示 double 值的位数。
SIZE - 类 java.lang.Float 中的静态变量
表示一个 float 值所使用的位数。
SIZE - 类 java.lang.Integer 中的静态变量
用来以二进制补码形式表示 int 值的比特位数。
SIZE - 类 java.lang.Long 中的静态变量
用来以二进制补码形式表示 long 值的位数。
SIZE - 类 java.lang.Short 中的静态变量
用来以二进制补码形式表示 short 值的位数。
size() - 类 java.nio.channels.FileChannel 中的方法
返回此通道的文件的当前大小。
size() - 类 java.nio.channels.FileLock 中的方法
返回锁定区域的大小，以字节为单位。
size() - 类 java.security.IdentityScope 中的方法
已过时。 返回此身份作用域内身份的数目。
size() - 类 java.security.KeyStore 中的方法
获取此 keystore 中条目数。
size() - 类 java.util.AbstractCollection 中的方法
size() - 类 java.util.AbstractMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.ArrayDeque 中的方法
返回此双端队列中的元素数。
size() - 类 java.util.ArrayList 中的方法
返回此列表中的元素数。
size() - 类 java.util.BitSet 中的方法
返回此 BitSet 表示位值时实际使用空间的位数。
size() - 接口 java.util.Collection 中的方法
返回此 collection 中的元素数。
size() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
返回此队列中元素的数量。
size() - 接口 java.util.concurrent.BlockingDeque 中的方法
返回此双端队列中的元素数。
size() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
返回此队列中的元素数量。
size() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
返回此 set 中的元素数目。
size() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表中的元素数。
size() - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
返回此 set 中的元素数目。
size() - 类 java.util.concurrent.DelayQueue 中的方法
size() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回此双端队列中的元素数。
size() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
返回队列中的元素个数。
size() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
size() - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 0。
size() - 接口 java.util.Deque 中的方法
返回此双端队列的元素数。
size() - 类 java.util.Dictionary 中的方法
返回此 dictionary 中条目（不同键）的数量。
size() - 类 java.util.EnumMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.HashMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.HashSet 中的方法
返回此 set 中的元素的数量（set 的容量）。
size() - 类 java.util.Hashtable 中的方法
返回此哈希表中的键的数量。
size() - 类 java.util.IdentityHashMap 中的方法
返回标识哈希映射中的键-值映射关系数。
size() - 类 java.util.jar.Attributes 中的方法
返回此 Map 中的属性数目。
size() - 类 java.util.LinkedList 中的方法
返回此列表的元素数。
size() - 接口 java.util.List 中的方法
返回列表中的元素数。
size() - 接口 java.util.Map 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.PriorityQueue 中的方法
size() - 接口 java.util.Set 中的方法
返回 set 中的元素数（其容量）。
size() - 类 java.util.TreeMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.TreeSet 中的方法
返回 set 中的元素数（set 的容量）。
size() - 类 java.util.Vector 中的方法
返回此向量中的组件数。
size() - 类 java.util.WeakHashMap 中的方法
返回该映射中的键-值映射关系的数目。
size() - 类 java.util.zip.ZipFile 中的方法
返回 ZIP 文件中的条目数。
size() - 类 javax.accessibility.AccessibleRelationSet 中的方法
返回关系集中的关系数。
size() - 类 javax.activation.MimeTypeParameterList 中的方法
返回此列表中名称-值对的数量。
size() - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例中包含的 CompositeData 值的数目（即行数）。
size() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularDataSupport 实例中的行数。
size() - 类 javax.naming.CompositeName 中的方法
检索此复合名称中的组件数。
size() - 类 javax.naming.CompoundName 中的方法
检索此组合名称中的组件数。
size() - 接口 javax.naming.directory.Attribute 中的方法
检索此属性中的值数。
size() - 接口 javax.naming.directory.Attributes 中的方法
在属性集中检索属性数。
size() - 类 javax.naming.directory.BasicAttribute 中的方法
size() - 类 javax.naming.directory.BasicAttributes 中的方法
size() - 类 javax.naming.ldap.LdapName 中的方法
检索此 LDAP 名称中的组件数。
size() - 类 javax.naming.ldap.Rdn 中的方法
检索此 Rdn 中的属性类型/值对的数目。
size() - 接口 javax.naming.Name 中的方法
返回此名称中的组件数。
size() - 类 javax.naming.Reference 中的方法
检索此引用中的地址数。
size() - 接口 javax.print.attribute.AttributeSet 中的方法
返回此属性集中属性的数量。
size() - 类 javax.print.attribute.HashAttributeSet 中的方法
返回此属性集中属性的数量。
size() - 类 javax.script.SimpleBindings 中的方法
返回此映射中的键-值映射关系数。
size() - 类 javax.sound.midi.Track 中的方法
获得此音轨中的事件数。
size() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回此 CachedRowSet 对象中的行数。
size() - 类 javax.swing.ActionMap 中的方法
返回 KeyStroke 绑定的数量。
size() - 类 javax.swing.DefaultListModel 中的方法
返回此列表中的组件数。
size() - 类 javax.swing.InputMap 中的方法
返回 KeyStroke 绑定的数量。
SIZE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
Size - 类 javax.swing.text.StyleConstants 中的静态变量
字体大小的名称。
Size2DSyntax - javax.print.attribute 中的 类
类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。
Size2DSyntax(float, float, int) - 类 javax.print.attribute.Size2DSyntax 的构造方法
根据给定的浮点值构造一个新的二维大小属性。
Size2DSyntax(int, int, int) - 类 javax.print.attribute.Size2DSyntax 的构造方法
根据给定的整数值构造一个新的二维大小属性。
SIZE_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
sizeAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
sizeColumnsToFit(boolean) - 类 javax.swing.JTable 中的方法
已过时。 从 Swing version 1.0.3 开始，由 doLayout() 取代。
sizeColumnsToFit(int) - 类 javax.swing.JTable 中的方法
从 Java 2 平台 v1.4 开始已过时。
SizeLimitExceededException - javax.naming 中的 异常
当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
SizeLimitExceededException() - 异常 javax.naming.SizeLimitExceededException 的构造方法
构造一个新的 SizeLimitExceededException 实例。
SizeLimitExceededException(String) - 异常 javax.naming.SizeLimitExceededException 的构造方法
使用解释构造一个新的 SizeLimitExceededException 实例。
SizeRequirements - javax.swing 中的 类
为方便布局管理器，计算组件的有关大小和位置信息。
SizeRequirements() - 类 javax.swing.SizeRequirements 的构造方法
创建 SizeRequirements 对象，其最小、首选和最大大小设置为零，对齐方式值为 0.5（居中）。
SizeRequirements(int, int, int, float) - 类 javax.swing.SizeRequirements 的构造方法
用指定的最小、首选和最大大小以及指定的对齐方式创建 SizeRequirements 对象。
sizes - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的变量
SizeSequence - javax.swing 中的 类
一个 SizeSequence 对象，它有效地维护一个包含大小和相应位置的顺序列表。
SizeSequence() - 类 javax.swing.SizeSequence 的构造方法
创建一个新的 SizeSequence 对象，它不包含任何条目。
SizeSequence(int) - 类 javax.swing.SizeSequence 的构造方法
创建一个新的 SizeSequence 对象，它包含指定的条目数，每个大小都已初始化为 0。
SizeSequence(int, int) - 类 javax.swing.SizeSequence 的构造方法
创建一个新的 SizeSequence 对象，它包含指定的条目数，每个大小都已初始化为 value。
SizeSequence(int[]) - 类 javax.swing.SizeSequence 的构造方法
创建一个新的 SizeSequence 对象，它包含指定的大小。
sizeWidthToFit() - 类 javax.swing.table.TableColumn 中的方法
调整 TableColumn 的大小，以适合其标题单元格的宽度。
Skeleton - java.rmi.server 中的 接口
已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
SkeletonMismatchException - java.rmi.server 中的 异常
已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
SkeletonMismatchException(String) - 异常 java.rmi.server.SkeletonMismatchException 的构造方法
已过时。 无替代版本
SkeletonNotFoundException - java.rmi.server 中的 异常
已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
SkeletonNotFoundException(String) - 异常 java.rmi.server.SkeletonNotFoundException 的构造方法
已过时。 构造带指定详细消息的 SkeletonNotFoundException。
SkeletonNotFoundException(String, Exception) - 异常 java.rmi.server.SkeletonNotFoundException 的构造方法
已过时。 构造带指定详细消息和嵌套异常的 SkeletonNotFoundException。
skip(long) - 类 java.io.BufferedInputStream 中的方法
参见 InputStream 的 skip 方法的常规协定。
skip(long) - 类 java.io.BufferedReader 中的方法
跳过字符。
skip(long) - 类 java.io.ByteArrayInputStream 中的方法
从此输入流中跳过 n 个输入字节。
skip(long) - 类 java.io.CharArrayReader 中的方法
跳过字符。
skip(long) - 类 java.io.FileInputStream 中的方法
从输入流中跳过并丢弃 n 个字节的数据。
skip(long) - 类 java.io.FilterInputStream 中的方法
跳过和丢弃此输入流中数据的 n 个字节。
skip(long) - 类 java.io.FilterReader 中的方法
跳过某些字符。
skip(long) - 类 java.io.InputStream 中的方法
跳过和丢弃此输入流中数据的 n 个字节。
skip(long) - 类 java.io.LineNumberInputStream 中的方法
已过时。 跳过和放弃此输入流中的 n 个数据字节。
skip(long) - 类 java.io.LineNumberReader 中的方法
跳过字符。
skip(long) - 接口 java.io.ObjectInput 中的方法
跳过输入的 n 个字节。
skip(long) - 类 java.io.PushbackInputStream 中的方法
从此输入流中跳过并丢弃 n 个数据字节。
skip(long) - 类 java.io.PushbackReader 中的方法
跳过字符。
skip(long) - 类 java.io.Reader 中的方法
跳过字符。
skip(long) - 类 java.io.StringBufferInputStream 中的方法
已过时。 从此输入流中跳过输入的 n 个字节。
skip(long) - 类 java.io.StringReader 中的方法
跳过流中指定数量的字符。
skip(Pattern) - 类 java.util.Scanner 中的方法
在忽略分隔符的情况下跳过与指定模式匹配的输入信息。
skip(String) - 类 java.util.Scanner 中的方法
跳过与从指定字符串构造的模式匹配的输入信息。
skip(long) - 类 java.util.zip.CheckedInputStream 中的方法
跳过指定的输入字节数。
skip(long) - 类 java.util.zip.DeflaterInputStream 中的方法
从输入流中跳过并丢弃数据。
skip(long) - 类 java.util.zip.InflaterInputStream 中的方法
跳过指定的未压缩数据的字节数。
skip(long) - 类 java.util.zip.ZipInputStream 中的方法
跳过当前 ZIP 条目中指定的字节数。
skip(long) - 类 javax.crypto.CipherInputStream 中的方法
跳过不发生阻塞地从该输入流读取的字节中的 n 个字节的输入。
skip(long) - 类 javax.sound.sampled.AudioInputStream 中的方法
跳过并丢弃此音频输入流中指定数量的字节。
skip(long) - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.skip，以便在跳过之后更新进度监视器。
skipBytes(int) - 接口 java.io.DataInput 中的方法
试图在输入流中跳过数据的 n 个字节，并丢弃跳过的字节。
skipBytes(int) - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 skipBytes 方法的常规协定。
skipBytes(int) - 类 java.io.ObjectInputStream 中的方法
跳过字节。
skipBytes(int) - 类 java.io.RandomAccessFile 中的方法
尝试跳过输入的 n 个字节以丢弃跳过的字节。
skipBytes(int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
将流位置向前移动给定的字节数。
skipBytes(long) - 接口 javax.imageio.stream.ImageInputStream 中的方法
将流位置向前移动给定的字节数。
skipBytes(int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
通过调用 seek(getStreamPosition() + n) 推进当前流位置。
skipBytes(long) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
通过调用 seek(getStreamPosition() + n) 推进当前流位置。
skippedEntity(String) - 接口 org.xml.sax.ContentHandler 中的方法
接收跳过的实体的通知。
skippedEntity(String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收跳过的实体的通知。
skippedEntity(String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个跳过的实体事件。
skippedEntity(String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 跳过的实体事件。
skipReferral() - 异常 javax.naming.ReferralException 中的方法
放弃将要处理的引用。
slashSlashComments(boolean) - 类 java.io.StreamTokenizer 中的方法
确定标记生成器是否识别 C++ 样式注释。
slashStarComments(boolean) - 类 java.io.StreamTokenizer 中的方法
确定标记生成器是否识别 C 样式注释。
sleep(long) - 类 java.lang.Thread 中的静态方法
在指定的毫秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。
sleep(long, int) - 类 java.lang.Thread 中的静态方法
在指定的毫秒数加指定的纳秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。
sleep(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
使用此单元执行 Thread.sleep.这是将时间参数转换为 Thread.sleep 方法所需格式的便捷方法。
slice() - 类 java.nio.ByteBuffer 中的方法
创建新的字节缓冲区，其内容是此缓冲区内容的共享子序列。
slice() - 类 java.nio.CharBuffer 中的方法
创建新的字符缓冲区，其内容为此缓冲区内容的共享子序列。
slice() - 类 java.nio.DoubleBuffer 中的方法
创建新的 double 缓冲区，其内容是此缓冲区内容的共享子序列。
slice() - 类 java.nio.FloatBuffer 中的方法
创建新的 float 缓冲区，其内容是此缓冲区内容的共享子序列。
slice() - 类 java.nio.IntBuffer 中的方法
创建新的 int 数组，其内容是此缓冲区内容的共享子序列。
slice() - 类 java.nio.LongBuffer 中的方法
创建新的 long 缓冲区，其内容是此缓冲区内容的共享子序列。
slice() - 类 java.nio.ShortBuffer 中的方法
创建新的 short 缓冲区，其内容是此缓冲区内容的共享子序列。
SLIDER - 类 javax.accessibility.AccessibleRole 中的静态变量
允许用户在有限范围内进行选择的对象。
slider - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
SLIDER - 类 javax.swing.plaf.synth.Region 中的静态变量
Slider 的 region。
SLIDER_FILL - 类 javax.swing.plaf.metal.MetalSliderUI 中的变量
SLIDER_THUMB - 类 javax.swing.plaf.synth.Region 中的静态变量
滑块的 thumb。
SLIDER_TRACK - 类 javax.swing.plaf.synth.Region 中的静态变量
Slider 的滑道。
sliderModel - 类 javax.swing.JSlider 中的变量
处理滑块的数字最大值、最小值和当前位置值的数据模型。
SliderUI - javax.swing.plaf 中的 类
JSlider 的可插入外观界面。
SliderUI() - 类 javax.swing.plaf.SliderUI 的构造方法
SMALL - 类 javax.swing.text.html.HTML.Tag 中的静态变量
SMALL_FORM_VARIANTS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Small Form Variants”Unicode 字符块的常量。
SMALL_ICON - 接口 javax.swing.Action 中的静态变量
用来存储小型 Icon（比如 ImageIcon）的键。
SMALLINT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 SMALLINT 的 Java 编程语言中的常量（有时称为类型代码）。
SMPTE_24 - 类 javax.sound.midi.Sequence 中的静态变量
基于 SMPTE 的定时类型，每秒 24 帧（精度用每帧的节拍数表示）。
SMPTE_25 - 类 javax.sound.midi.Sequence 中的静态变量
基于 SMPTE 的定时类型，每秒 25 帧（精度用每帧的节拍数表示）。
SMPTE_30 - 类 javax.sound.midi.Sequence 中的静态变量
基于 SMPTE 的定时类型，每秒 30 帧（精度用每帧的节拍数表示）。
SMPTE_30DROP - 类 javax.sound.midi.Sequence 中的静态变量
基于 SMPTE 的定时类型，每秒 29.97 帧（精度用每帧的节拍数表示）。
snapToTicks - 类 javax.swing.JSlider 中的变量
如果为 true，滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值。
SND - 类 javax.sound.sampled.AudioFileFormat.Type 中的静态变量
指定 SND 文件。
SO_BINDADDR - 接口 java.net.SocketOptions 中的静态变量
获取绑定套接字的本地地址（不能仅将此选项“设置”为“得到”，因为套接字是在创建时绑定的，所以本地绑定的地址不可更改）。
SO_BROADCAST - 接口 java.net.SocketOptions 中的静态变量
为套接字设置 SO_BROADCAST。
SO_KEEPALIVE - 接口 java.net.SocketOptions 中的静态变量
为 TCP 套接字设置 keepalive 选项时，如果在 2 个小时（注：实际值与实现有关）内在任意方向上都没有跨越套接字交换数据，则 TCP 会自动将 keepalive 探头发送到同位体。
SO_LINGER - 接口 java.net.SocketOptions 中的静态变量
指定关闭时逗留的超时值。
SO_OOBINLINE - 接口 java.net.SocketOptions 中的静态变量
设置 OOBINLINE 选项时，在套接字上接收的所有 TCP 紧急数据都将通过套接字输入流接收。
SO_RCVBUF - 接口 java.net.SocketOptions 中的静态变量
设置传入网络 I/O 的平台所使用基础缓冲区的大小的提示。
SO_REUSEADDR - 接口 java.net.SocketOptions 中的静态变量
设置套接字的 SO_REUSEADDR。
SO_SNDBUF - 接口 java.net.SocketOptions 中的静态变量
设置传出网络 I/O 的平台所使用的基础缓冲区大小的提示。
SO_TIMEOUT - 接口 java.net.SocketOptions 中的静态变量
设置阻塞 Socket 操作的超时值：

 ServerSocket.accept();
 SocketInputStream.read();
 DatagramSocket.receive();

 选项必须在进入阻塞操作前设置才能生效。
SOAP11HTTP_BINDING - 接口 javax.xml.ws.soap.SOAPBinding 中的静态变量
表示 HTTP 绑定上的 SOAP 1.1 标识的常量。
SOAP11HTTP_MTOM_BINDING - 接口 javax.xml.ws.soap.SOAPBinding 中的静态变量
表示 HTTP 绑定上的 SOAP 1.1 标识，且默认启用 MTOM 的常量。
SOAP12HTTP_BINDING - 接口 javax.xml.ws.soap.SOAPBinding 中的静态变量
表示 HTTP 绑定上的 SOAP 1.2 标识的常量。
SOAP12HTTP_MTOM_BINDING - 接口 javax.xml.ws.soap.SOAPBinding 中的静态变量
表示 HTTP 绑定上的 SOAP 1.2 标识，且默认启用 MTOM 的常量。
SOAP_1_1_CONTENT_TYPE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.1 中 Content-Type MIME 头的媒体类型。
SOAP_1_1_PROTOCOL - 接口 javax.xml.soap.SOAPConstants 中的静态变量
用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.1 规范的 SOAPMessages。
SOAP_1_2_CONTENT_TYPE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 中 Content-Type MIME 头的媒体类型。
SOAP_1_2_PROTOCOL - 接口 javax.xml.soap.SOAPConstants 中的静态变量
用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.2 规范的 SOAPMessages
SOAP_DATAENCODINGUNKNOWN_FAULT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 DataEncodingUnknown 错误。
SOAP_ENV_PREFIX - 接口 javax.xml.soap.SOAPConstants 中的静态变量
http://www.w3.org/2003/05/soap-envelope 的默认名称空间前缀。
SOAP_MUSTUNDERSTAND_FAULT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 MustUnderstand 错误。
SOAP_RECEIVER_FAULT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 Receiver 错误。
SOAP_SENDER_FAULT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 Sender 错误。
SOAP_VERSIONMISMATCH_FAULT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 VersionMismatch 错误。
SOAPACTION_URI_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
SOAPAction 的标准属性。
SOAPACTION_USE_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
SOAPAction 的标准属性。
SOAPBinding - javax.jws.soap 中的 注释类型
指定 Web Service 到 SOAP 消息协议的映射关系。
SOAPBinding - javax.xml.ws.soap 中的 接口
SOAPBinding 接口是 SOAP 绑定的抽象。
SOAPBinding.ParameterStyle - javax.jws.soap 中的 枚举
参数到 SOAP 消息的映射关系的样式。
SOAPBinding.Style - javax.jws.soap 中的 枚举
SOAP 绑定样式。
SOAPBinding.Use - javax.jws.soap 中的 枚举
SOAP 绑定的使用。
SOAPBody - javax.xml.soap 中的 接口
表示 SOAP 消息中 SOAP 正文元素内容的对象。
SOAPBodyElement - javax.xml.soap 中的 接口
表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
SOAPConnection - javax.xml.soap 中的 类
客户端可以用于直接将消息发送到（例如，用 URL 表示的）远程方的点对点连接。
SOAPConnection() - 类 javax.xml.soap.SOAPConnection 的构造方法
SOAPConnectionFactory - javax.xml.soap 中的 类
创建 SOAPConnection 对象的工厂。
SOAPConnectionFactory() - 类 javax.xml.soap.SOAPConnectionFactory 的构造方法
SOAPConstants - javax.xml.soap 中的 接口
与 SOAP 协议有关的常量的定义。
SOAPElement - javax.xml.soap 中的 接口
表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。
SOAPElementFactory - javax.xml.soap 中的 类
已过时。 - 使用 javax.xml.soap.SOAPFactory 创建 SOAPElements。
SOAPEnvelope - javax.xml.soap 中的 接口
SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
SOAPException - javax.xml.soap 中的 异常
当发生 SOAP 异常时，抛出此异常。
SOAPException() - 异常 javax.xml.soap.SOAPException 的构造方法
构造不带原因或内置 Throwable 对象的 SOAPException 对象。
SOAPException(String) - 异常 javax.xml.soap.SOAPException 的构造方法
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因。
SOAPException(String, Throwable) - 异常 javax.xml.soap.SOAPException 的构造方法
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因，使用给定 Throwable 对象作为嵌入的异常。
SOAPException(Throwable) - 异常 javax.xml.soap.SOAPException 的构造方法
构造使用给定 Throwable 对象初始化的 SOAPException 对象。
SOAPFactory - javax.xml.soap 中的 类
SOAPFactory 是用来创建存在于 SOAP XML 树中的各种对象的工厂。
SOAPFactory() - 类 javax.xml.soap.SOAPFactory 的构造方法
SOAPFault - javax.xml.soap 中的 接口
SOAPBody 对象中的元素，包含错误和/或状态信息。
SOAPFaultElement - javax.xml.soap 中的 接口
SOAPFault 对象内容的表示形式。
SOAPFaultException - javax.xml.ws.soap 中的 异常
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。
SOAPFaultException(SOAPFault) - 异常 javax.xml.ws.soap.SOAPFaultException 的构造方法
SOAPFaultException 的构造方法
SOAPHandler<T extends SOAPMessageContext> - javax.xml.ws.handler.soap 中的 接口
SOAPHandler 类扩展了 Handler，以便为消息上下文参数提供输入安全性，并添加了一个方法，以访问可能由该处理程序处理的头。
SOAPHeader - javax.xml.soap 中的 接口
SOAP 头元素的表示形式。
SOAPHeaderElement - javax.xml.soap 中的 接口
表示 SOAP 信封 SOAP 头部分的内容的对象。
SOAPMessage - javax.xml.soap 中的 类
所有 SOAP 消息的根类。
SOAPMessage() - 类 javax.xml.soap.SOAPMessage 的构造方法
SOAPMessageContext - javax.xml.ws.handler.soap 中的 接口
接口 SOAPMessageContext 提供对 RPC 请求或响应的 SOAP 消息的访问。
SOAPMessageHandler - javax.jws.soap 中的 注释类型
已过时。 从 JSR-181 2.0 开始，无替代版本。
SOAPMessageHandlers - javax.jws.soap 中的 注释类型
已过时。 从 JSR-181 2.0 开始，无替代版本。
SOAPPart - javax.xml.soap 中的 类
SOAPMessage 对象中特定于 SOAP 部分的容器。
SOAPPart() - 类 javax.xml.soap.SOAPPart 的构造方法
Socket - java.net 中的 类
此类实现客户端套接字（也可以就叫“套接字”）。
Socket() - 类 java.net.Socket 的构造方法
通过系统默认类型的 SocketImpl 创建未连接套接字
Socket(Proxy) - 类 java.net.Socket 的构造方法
创建一个未连接的套接字并指定代理类型（如果有），该代理不管其他设置如何都应被使用。
Socket(SocketImpl) - 类 java.net.Socket 的构造方法
使用用户指定的 SocketImpl 创建一个未连接 Socket。
Socket(String, int) - 类 java.net.Socket 的构造方法
创建一个流套接字并将其连接到指定主机上的指定端口号。
Socket(InetAddress, int) - 类 java.net.Socket 的构造方法
创建一个流套接字并将其连接到指定 IP 地址的指定端口号。
Socket(String, int, InetAddress, int) - 类 java.net.Socket 的构造方法
创建一个套接字并将其连接到指定远程主机上的指定远程端口。
Socket(InetAddress, int, InetAddress, int) - 类 java.net.Socket 的构造方法
创建一个套接字并将其连接到指定远程地址上的指定远程端口。
Socket(String, int, boolean) - 类 java.net.Socket 的构造方法
已过时。 使用 DatagramSocket 取代 UDP 传输。
Socket(InetAddress, int, boolean) - 类 java.net.Socket 的构造方法
已过时。 Use DatagramSocket instead for UDP transport.
socket() - 类 java.nio.channels.DatagramChannel 中的方法
获取与此通道关联的数据报套接字。
socket() - 类 java.nio.channels.ServerSocketChannel 中的方法
获取与此通道关联的服务器套接字。
socket() - 类 java.nio.channels.SocketChannel 中的方法
获取与此通道关联的套接字。
SocketAddress - java.net 中的 类
此类表示不带任何协议附件的 Socket Address。
SocketAddress() - 类 java.net.SocketAddress 的构造方法
SocketChannel - java.nio.channels 中的 类
针对面向流的连接套接字的可选择通道。
SocketChannel(SelectorProvider) - 类 java.nio.channels.SocketChannel 的构造方法
初始化此类的一个新实例。
SocketException - java.net 中的 异常
抛出此异常指示在底层协议中存在错误，如 TCP 错误。
SocketException(String) - 异常 java.net.SocketException 的构造方法
构造带指定详细消息的新 SocketException。
SocketException() - 异常 java.net.SocketException 的构造方法
构造不带详细消息的新 SocketException。
SocketFactory - javax.net 中的 类
此类创建套接字。
SocketFactory() - 类 javax.net.SocketFactory 的构造方法
创建一个 SocketFactory。
SocketHandler - java.util.logging 中的 类
简单的网络日志 Handler。
SocketHandler() - 类 java.util.logging.SocketHandler 的构造方法
仅使用 LogManager 属性（或其默认值）创建 SocketHandler。
SocketHandler(String, int) - 类 java.util.logging.SocketHandler 的构造方法
构造一个带有指定主机和端口的 SocketHandler。
SocketImpl - java.net 中的 类
抽象类 SocketImpl 是实际实现套接字的所有类的通用超类。
SocketImpl() - 类 java.net.SocketImpl 的构造方法
SocketImplFactory - java.net 中的 接口
此接口定义用于套接字实现的工厂。
SocketOptions - java.net 中的 接口
获取/设置套接字选项的方法的接口。
SocketPermission - java.net 中的 类
此类表示通过套接字对网络的访问。
SocketPermission(String, String) - 类 java.net.SocketPermission 的构造方法
创建带指定动作的新 SocketPermission 对象。
SocketSecurityException - java.rmi.server 中的 异常
已废弃的 ExportException 的子类。
SocketSecurityException(String) - 异常 java.rmi.server.SocketSecurityException 的构造方法
构造带指定详细消息的 SocketSecurityException。
SocketSecurityException(String, Exception) - 异常 java.rmi.server.SocketSecurityException 的构造方法
构造带指定详细消息和嵌入异常的 SocketSecurityIOException。
SocketTimeoutException - java.net 中的 异常
如果在读取或接受套接字时发生超时，则抛出此异常。
SocketTimeoutException(String) - 异常 java.net.SocketTimeoutException 的构造方法
构造带详细消息的新 SocketTimeoutException。
SocketTimeoutException() - 异常 java.net.SocketTimeoutException 的构造方法
构造不带详细信息的新 SocketTimeoutException。
SoftBevelBorder - javax.swing.border 中的 类
实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。
SoftBevelBorder(int) - 类 javax.swing.border.SoftBevelBorder 的构造方法
创建具有用指定类型的斜面边框，其颜色将从传递给 paintBorder 方法的组件背景色派生。
SoftBevelBorder(int, Color, Color) - 类 javax.swing.border.SoftBevelBorder 的构造方法
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
SoftBevelBorder(int, Color, Color, Color, Color) - 类 javax.swing.border.SoftBevelBorder 的构造方法
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
SoftReference<T> - java.lang.ref 中的 类
软引用对象，在响应内存需要时，由垃圾回收器决定是否清除此对象。
SoftReference(T) - 类 java.lang.ref.SoftReference 的构造方法
创建引用给定对象的新的软引用。
SoftReference(T, ReferenceQueue<? super T>) - 类 java.lang.ref.SoftReference 的构造方法
创建一个引用给定对象的新的软引用，并向给定队列注册该引用。
solveCubic(double[]) - 类 java.awt.geom.CubicCurve2D 中的静态方法
解系数位于 eqn 数组中的三次曲线，并将非复数的根放回该数组，同时返回根数。
solveCubic(double[], double[]) - 类 java.awt.geom.CubicCurve2D 中的静态方法
解系数位于 eqn 数组中的三次曲线，并将非复数的根放入 res 数组，同时返回根数。
solveQuadratic(double[]) - 类 java.awt.geom.QuadCurve2D 中的静态方法
解系数位于 eqn 数组中的二次曲线，并将非复数的根放回该数组，同时返回根数。
solveQuadratic(double[], double[]) - 类 java.awt.geom.QuadCurve2D 中的静态方法
解系数位于 eqn 数组中的二次曲线，并将非复数的根放入 res 数组，同时返回根数。
SOMEBITS - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示已提供了绘制图像缩放变体所需的更多像素。
SONG_POSITION_POINTER - 类 javax.sound.midi.ShortMessage 中的静态变量
SONG_POSITION_POINTER 消息的状态字节（0xF2 或 242）。
SONG_SELECT - 类 javax.sound.midi.ShortMessage 中的静态变量
MIDI SONG_SELECT 消息的状态字节（0xF3 或 243）。
sort(long[]) - 类 java.util.Arrays 中的静态方法
对指定的 long 型数组按数字升序进行排序。
sort(long[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 long 型数组的指定范围按数字升序进行排序。
sort(int[]) - 类 java.util.Arrays 中的静态方法
对指定的 int 型数组按数字升序进行排序。
sort(int[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 int 型数组的指定范围按数字升序进行排序。
sort(short[]) - 类 java.util.Arrays 中的静态方法
对指定的 short 型数组按数字升序进行排序。
sort(short[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 short 型数组的指定范围按数字升序进行排序。
sort(char[]) - 类 java.util.Arrays 中的静态方法
对指定的 char 型数组按数字升序进行排序。
sort(char[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 char 型数组的指定范围按数字升序进行排序。
sort(byte[]) - 类 java.util.Arrays 中的静态方法
对指定的 byte 型数组按数字升序进行排序。
sort(byte[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 byte 型数组的指定范围按数字升序进行排序。
sort(double[]) - 类 java.util.Arrays 中的静态方法
对指定的 double 型数组按数字升序进行排序。
sort(double[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 double 型数组的指定范围按数字升序进行排序。
sort(float[]) - 类 java.util.Arrays 中的静态方法
对指定的 float 型数组按数字升序进行排序。
sort(float[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 float 型数组的指定范围按数字升序进行排序。
sort(Object[]) - 类 java.util.Arrays 中的静态方法
根据元素的自然顺序对指定对象数组按升序进行排序。
sort(Object[], int, int) - 类 java.util.Arrays 中的静态方法
根据元素的自然顺序对指定对象数组的指定范围按升序进行排序。
sort(T[], Comparator<? super T>) - 类 java.util.Arrays 中的静态方法
根据指定比较器产生的顺序对指定对象数组进行排序。
sort(T[], int, int, Comparator<? super T>) - 类 java.util.Arrays 中的静态方法
根据指定比较器产生的顺序对指定对象数组的指定范围进行排序。
sort(List<T>) - 类 java.util.Collections 中的静态方法
根据元素的自然顺序 对指定列表按升序进行排序。
sort(List<T>, Comparator<? super T>) - 类 java.util.Collections 中的静态方法
根据指定比较器产生的顺序对指定列表进行排序。
sort() - 类 javax.swing.DefaultRowSorter 中的方法
根据当前正在排序的列的排序键以及与此排序器关联的过滤器（如果有）对视图中的行进行排序和过滤。
sort(Vector<? extends File>) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
SortControl - javax.naming.ldap 中的 类
请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。
SortControl(String, boolean) - 类 javax.naming.ldap.SortControl 的构造方法
构造一个控件来按升序对单个属性进行排序。
SortControl(String[], boolean) - 类 javax.naming.ldap.SortControl 的构造方法
构造一个控件来按升序对属性列表进行排序。
SortControl(SortKey[], boolean) - 类 javax.naming.ldap.SortControl 的构造方法
构造一个控件来对排序键列表进行排序。
SortedMap<K,V> - java.util 中的 接口
进一步提供关于键的总体排序 的 Map。
SortedSet<E> - java.util 中的 接口
进一步提供关于元素的总体排序 的 Set。
sorterChanged(RowSorterEvent) - 接口 javax.swing.event.RowSorterListener 中的方法
RowSorter 发生了更改的通知。
sorterChanged(RowSorterEvent) - 类 javax.swing.JTable 中的方法
RowSorter 以某种方式发生了更改的 RowSorterListener 通知。
SortingFocusTraversalPolicy - javax.swing 中的 类
通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。
SortingFocusTraversalPolicy() - 类 javax.swing.SortingFocusTraversalPolicy 的构造方法
构造一个不带 Comparator 的 SortingFocusTraversalPolicy。
SortingFocusTraversalPolicy(Comparator<? super Component>) - 类 javax.swing.SortingFocusTraversalPolicy 的构造方法
构造具有指定 Comparator 的 SortingFocusTraversalPolicy。
SortKey - javax.naming.ldap 中的 类
排序键及其关联的排序参数。
SortKey(String) - 类 javax.naming.ldap.SortKey 的构造方法
创建属性的默认排序键。
SortKey(String, boolean, String) - 类 javax.naming.ldap.SortKey 的构造方法
创建属性的排序键。
SortOrder - javax.swing 中的 枚举
SortOrder 是可能排序顺序的枚举。
SortResponseControl - javax.naming.ldap 中的 类
指示搜索结果的请求排序是否成功。
SortResponseControl(String, boolean, byte[]) - 类 javax.naming.ldap.SortResponseControl 的构造方法
构造一个控件来指示排序请求的结果。
Soundbank - javax.sound.midi 中的 接口
Soundbank 包含可加载到 Synthesizer 中的一组 Instruments。
SoundbankReader - javax.sound.midi.spi 中的 类
SoundbankReader 提供音库文件读取服务。
SoundbankReader() - 类 javax.sound.midi.spi.SoundbankReader 的构造方法
SoundbankResource - javax.sound.midi 中的 类
SoundbankResource 表示存储在 Soundbank 中的任何音频资源。
SoundbankResource(Soundbank, String, Class<?>) - 类 javax.sound.midi.SoundbankResource 的构造方法
根据给定的音库和波表索引构造一个新的 SoundbankResource。
source() - 类 java.nio.channels.Pipe 中的方法
返回此管道的源通道。
source - 类 java.util.EventObject 中的变量
最初发生 Event 的对象。
source - 类 javax.management.Notification 中的变量
此域隐藏了父类中的 EventObject.source 域，使其成为非 transient 的，并因此成为序列化形式的一部分。
source - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的变量
发起事件的源。
Source - javax.xml.transform 中的 接口
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息
sourceActions - 类 java.awt.dnd.DragGestureRecognizer 中的变量
此 Drag 和 Drop 操作中所用动作类型的 int 表示形式。
sourceBands - 类 javax.imageio.IIOParam 中的变量
指示将使用的源 band 的 int 数组，或为 null。
SourceDataLine - javax.sound.sampled 中的 接口
源数据行是可以写入数据的数据行。
SourceLocator - javax.xml.transform 中的 接口
此接口的主要目的是报告在 XML 源或转换指令中发生错误的位置。
sourceRegion - 类 javax.imageio.IIOParam 中的变量
源区域；如果没有设置源区域，则为 null。
sourceRenderSize - 类 javax.imageio.ImageReadParam 中的变量
如果 canSetSourceRenderSize 为 true，则为源的所需呈现宽度和高度；或者为 null。
sources - 类 java.awt.image.renderable.ParameterBlock 中的变量
源的 Vector，存储为任意 Objects。
sourceToInputSource(Source) - 类 javax.xml.transform.sax.SAXSource 中的静态方法
尝试从 Source 对象获取 SAX InputSource 对象。
SourceVersion - javax.lang.model 中的 枚举
Java™ 编程语言的源版本。
sourceXSubsampling - 类 javax.imageio.IIOParam 中的变量
在水平方向应用抽取十分之一的二次取样。
sourceYSubsampling - 类 javax.imageio.IIOParam 中的变量
在垂直方向应用抽取十分之一的二次取样。
SOUTH - 类 java.awt.BorderLayout 中的静态变量
南区域的布局约束（容器底部）。
SOUTH - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的底部，并在水平方向上居中。
SOUTH - 类 javax.swing.SpringLayout 中的静态变量
指定组件的边界矩形的底边。
SOUTH - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向南（下）。
SOUTH_EAST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向东南（右下）。
SOUTH_WEST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向西南（左下）。
SOUTHEAST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的右下角。
southPane - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
SOUTHWEST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的左下角。
SPACE - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
字符是空格（参阅 [XML], 2.10 "White Space Handling"）。
SPACE_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Zs”。
SpaceAbove - 类 javax.swing.text.StyleConstants 中的静态变量
段落上方的空间量。
SpaceBelow - 类 javax.swing.text.StyleConstants 中的静态变量
段落下方的空间量。
SPACING_MODIFIER_LETTERS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Spacing Modifier Letters”Unicode 字符块的常量。
SPAN - 类 javax.swing.text.html.HTML.Tag 中的静态变量
SPEAKER - 类 javax.sound.sampled.Port.Info 中的静态变量
向内置扬声器或扬声器插孔发送音频端口类型。
SPECIAL_SYSTEM_EXCLUSIVE - 类 javax.sound.midi.SysexMessage 中的静态变量
用于 SPECIAL_SYSTEM_EXCLUSIVE 消息的状态字节（0xF7 或 247），供在 MIDI 文件中使用。
SPECIALS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Specials”Unicode 字符块的常量。
SPECIFICATION_TITLE - 类 java.util.jar.Attributes.Name 中的静态变量
Specification-Title 的 Name 对象给出了用于包的版本控制的属性。
SPECIFICATION_VENDOR - 类 java.util.jar.Attributes.Name 中的静态变量
Specification-Vendor 的 Name 对象给出了用于包的版本控制的属性。
SPECIFICATION_VERSION - 类 java.util.jar.Attributes.Name 中的静态变量
Specification-Version 的 Name 对象给出了用于包的版本控制的属性。
SPIN_BOX - 类 javax.accessibility.AccessibleRole 中的静态变量
SPIN_BOX 是简单的微调器组件，它主要用于简单数字。
spinner - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的变量
作为 UI 委托的 spinner。
SPINNER - 类 javax.swing.plaf.synth.Region 中的静态变量
Spinner 的 region。
SpinnerDateModel - javax.swing 中的 类
Date 序列的一个 SpinnerModel。
SpinnerDateModel(Date, Comparable, Comparable, int) - 类 javax.swing.SpinnerDateModel 的构造方法
创建一个表示 start 和 end 之间的日期序列的 SpinnerDateModel。
SpinnerDateModel() - 类 javax.swing.SpinnerDateModel 的构造方法
构造一个 SpinnerDateModel，其初始 value 为当前日期，calendarField 等于 Calendar.DAY_OF_MONTH，且没有 start/end 限制。
SpinnerListModel - javax.swing 中的 类
其值由数组或 List 定义的 SpinnerModel 的简单实现。
SpinnerListModel(List<?>) - 类 javax.swing.SpinnerListModel 的构造方法
构造一个由指定 List 定义其值序列的 SpinnerModel。
SpinnerListModel(Object[]) - 类 javax.swing.SpinnerListModel 的构造方法
构造一个由指定数组定义其值序列的 SpinnerModel。
SpinnerListModel() - 类 javax.swing.SpinnerListModel 的构造方法
创建一个实际为空的 SpinnerListModel。
SpinnerModel - javax.swing 中的 接口
对象值的潜在无界序列的模型。
SpinnerNumberModel - javax.swing 中的 类
用于数字序列的 SpinnerModel。
SpinnerNumberModel(Number, Comparable, Comparable, Number) - 类 javax.swing.SpinnerNumberModel 的构造方法
构造一个表示从 minimum 到 maximum 的闭区间数字序列的 SpinnerModel。
SpinnerNumberModel(int, int, int, int) - 类 javax.swing.SpinnerNumberModel 的构造方法
构造一个具有指定 value、minimum/maximum 边界和 stepSize 的 SpinnerNumberModel。
SpinnerNumberModel(double, double, double, double) - 类 javax.swing.SpinnerNumberModel 的构造方法
构造一个具有指定 value、minimum/maximum 边界和 stepSize 的 SpinnerNumberModel。
SpinnerNumberModel() - 类 javax.swing.SpinnerNumberModel 的构造方法
构造一个没有 minimum 或 maximum 值、stepSize 等于 1 且初始值为零的 SpinnerNumberModel。
SpinnerUI - javax.swing.plaf 中的 类
JSpinner 的可插入外观界面
SpinnerUI() - 类 javax.swing.plaf.SpinnerUI 的构造方法
SplashScreen - java.awt 中的 类
在 Java 虚拟机 (JVM) 启动之前，可以在应用程序启动时创建闪现屏幕。
split(String, int) - 类 java.lang.String 中的方法
根据匹配给定的正则表达式来拆分此字符串。
split(String) - 类 java.lang.String 中的方法
根据给定正则表达式的匹配拆分此字符串。
split(CharSequence, int) - 类 java.util.regex.Pattern 中的方法
围绕此模式的匹配拆分给定输入序列。
split(CharSequence) - 类 java.util.regex.Pattern 中的方法
围绕此模式的匹配拆分给定输入序列。
SPLIT_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
同时呈现两个其他窗格的专用窗格。
SPLIT_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
SplitPane 的 region。
SPLIT_PANE_DIVIDER - 类 javax.swing.plaf.synth.Region 中的静态变量
SplitPane 的分隔器。
splitPane - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
其中包含接收者的 JSplitPane。
splitPane - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
此实例为其提供外观的 JSplitPane 实例。
splitPaneUI - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
从其创建此实例的 UI。
SplitPaneUI - javax.swing.plaf 中的 类
JSplitPane 的可插入外观界面。
SplitPaneUI() - 类 javax.swing.plaf.SplitPaneUI 的构造方法
splitText(int) - 接口 org.w3c.dom.Text 中的方法
在指定的 offset 处将此节点拆分为两个节点，并将二者作为兄弟节点保持在树中。
SPOOL_AREA_FULL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
已达到为后台打印分配的持久存储限制。
spPropertyChangeListener - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的变量
Spring - javax.swing 中的 类
该 Spring 类的实例将存储以下三个表示其行为特征的属性：minimum、preferred 和 maximum 值。
Spring() - 类 javax.swing.Spring 的构造方法
由工厂方法创建 Spring 时使用。
SpringLayout - javax.swing 中的 类
SpringLayout 根据一组约束布置其相关容器的子组件。
SpringLayout() - 类 javax.swing.SpringLayout 的构造方法
构造一个新 SpringLayout。
SpringLayout.Constraints - javax.swing 中的 类
Constraints 对象将管理组件大小和位置更改方式的约束存储在 SpringLayout 控制的容器中。
SpringLayout.Constraints() - 类 javax.swing.SpringLayout.Constraints 的构造方法
创建一个空 Constraints 对象。
SpringLayout.Constraints(Spring, Spring) - 类 javax.swing.SpringLayout.Constraints 的构造方法
创建一个指定了 x 和 y 属性值的 Constraints 对象。
SpringLayout.Constraints(Spring, Spring, Spring, Spring) - 类 javax.swing.SpringLayout.Constraints 的构造方法
创建一个指定了 x、y、width 和 height 属性值的 Constraints 对象。
SpringLayout.Constraints(Component) - 类 javax.swing.SpringLayout.Constraints 的构造方法
创建组件 c 的合适 x、y、width 和 height spring 的 Constraints 对象。
SQLClientInfoException - java.sql 中的 异常
当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
SQLClientInfoException() - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个 SQLClientInfoException 对象。
SQLClientInfoException(Map<String, ClientInfoStatus>) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(Map<String, ClientInfoStatus>, Throwable) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, Map<String, ClientInfoStatus>) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, Map<String, ClientInfoStatus>, Throwable) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, String, Map<String, ClientInfoStatus>) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, String, Map<String, ClientInfoStatus>, Throwable) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, String, int, Map<String, ClientInfoStatus>) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, String, int, Map<String, ClientInfoStatus>, Throwable) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLData - java.sql 中的 接口
该接口用于 SQL 用户定义类型 (UDT) 到 Java 编程语言中类的自定义映射关系。
SQLDataException - java.sql 中的 异常
当 SQLState 类值为“22”时抛出的 SQLException 子类。
SQLDataException() - 异常 java.sql.SQLDataException 的构造方法
构造一个 SQLDataException 对象。
SQLDataException(String) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason 的 SQLDataException 对象。
SQLDataException(String, String) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLDataException 对象。
SQLDataException(String, String, int) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLDataException 对象。
SQLDataException(Throwable) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 cause 的 SQLDataException 对象。
SQLDataException(String, Throwable) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLDataException 对象。
SQLDataException(String, String, Throwable) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLDataException 对象。
SQLDataException(String, String, int, Throwable) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLDataException 对象。
SQLException - java.sql 中的 异常
提供关于数据库访问错误或其他错误信息的异常。
SQLException(String, String, int) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLException 对象。
SQLException(String, String) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason 和 SQLState 的 SQLException 对象。
SQLException(String) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason 的 SQLException 对象。
SQLException() - 异常 java.sql.SQLException 的构造方法
构造一个 SQLException 对象。
SQLException(Throwable) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 cause 的 SQLException 对象。
SQLException(String, Throwable) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason 和 cause 的 SQLException 对象。
SQLException(String, String, Throwable) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason、SQLState 和 cause 的 SQLException 对象。
SQLException(String, String, int, Throwable) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLException 对象。
SQLFeatureNotSupportedException - java.sql 中的 异常
当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
SQLFeatureNotSupportedException() - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String, String) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String, String, int) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(Throwable) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String, Throwable) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String, String, Throwable) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String, String, int, Throwable) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLInput - java.sql 中的 接口
一个输入流，它包含表示 SQL 结构化类型或 SQL 不同类型的实例的值组成的流。
SQLInputImpl - javax.sql.rowset.serial 中的 类
用于自定义映射用户定义类型 (UDT) 的输入流。
SQLInputImpl(Object[], Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SQLInputImpl 的构造方法
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。
SQLIntegrityConstraintViolationException - java.sql 中的 异常
当 SQLState 类值为“23”时抛出的 SQLException 子类。
SQLIntegrityConstraintViolationException() - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason 的 SQLIntegrityConstraintViolationException。
SQLIntegrityConstraintViolationException(String, String) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String, String, int) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(Throwable) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String, Throwable) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String, String, Throwable) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String, String, int, Throwable) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLInvalidAuthorizationSpecException - java.sql 中的 异常
当 SQLState 类值为“28”时抛出的 SQLException 子类。
SQLInvalidAuthorizationSpecException() - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String, String) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String, String, int) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(Throwable) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String, Throwable) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String, String, Throwable) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String, String, int, Throwable) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLNonTransientConnectionException - java.sql 中的 异常
SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
SQLNonTransientConnectionException() - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String, String) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String, String, int) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(Throwable) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String, Throwable) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLNonTransientConnectionException(String, String, Throwable) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String, String, int, Throwable) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientException - java.sql 中的 异常
重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
SQLNonTransientException() - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个 SQLNonTransientException 对象。
SQLNonTransientException(String) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason 的 SQLNonTransientException 对象。
SQLNonTransientException(String, String) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientException 对象。
SQLNonTransientException(String, String, int) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientException 对象。
SQLNonTransientException(Throwable) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 cause 的 SQLNonTransientException 对象。
SQLNonTransientException(String, Throwable) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLNonTransientException(String, String, Throwable) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientException 对象。
SQLNonTransientException(String, String, int, Throwable) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientException 对象。
SQLOutput - java.sql 中的 接口
用于将用户定义类型的属性写回数据库的输出流。
SQLOutputImpl - javax.sql.rowset.serial 中的 类
用于将自定义映射的用户定义类型 (UDT) 的属性写回数据库的输出流。
SQLOutputImpl(Vector<?>, Map<String, ?>) - 类 javax.sql.rowset.serial.SQLOutputImpl 的构造方法
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。
SQLPermission - java.sql 中的 类
SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。
SQLPermission(String) - 类 java.sql.SQLPermission 的构造方法
创建具有指定名称的新 SQLPermission 对象。
SQLPermission(String, String) - 类 java.sql.SQLPermission 的构造方法
创建具有指定名称的新 SQLPermission 对象。
SQLRecoverableException - java.sql 中的 异常
应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
SQLRecoverableException() - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个 SQLRecoverableException 对象。
SQLRecoverableException(String) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason 的 SQLRecoverableException 对象。
SQLRecoverableException(String, String) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLRecoverableException 对象。
SQLRecoverableException(String, String, int) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLRecoverableException 对象。
SQLRecoverableException(Throwable) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String, Throwable) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String, String, Throwable) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String, String, int, Throwable) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLRecoverableException 对象。
sqlStateSQL - 接口 java.sql.DatabaseMetaData 中的静态变量
DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 方法返回的值是否是一个 SQLSTATE 值。
sqlStateSQL99 - 接口 java.sql.DatabaseMetaData 中的静态变量
DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 方法返回的值是否是一个 SQL99 SQLSTATE 值。
sqlStateXOpen - 接口 java.sql.DatabaseMetaData 中的静态变量
DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 返回的值是否是一个 X/Open（现在称为 Open Group）SQL CLI SQLSTATE 值。
SQLSyntaxErrorException - java.sql 中的 异常
当 SQLState 类值为“42”时抛出的 SQLException 子类。
SQLSyntaxErrorException() - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String, String) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String, String, int) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(Throwable) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String, Throwable) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String, String, Throwable) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String, String, int, Throwable) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLSyntaxErrorException 对象。
SQLTimeoutException - java.sql 中的 异常
Statement 指定的超时已到期时抛出的 SQLException 子类。
SQLTimeoutException() - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个 SQLTimeoutException 对象。
SQLTimeoutException(String) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason 的 SQLTimeoutException 对象。
SQLTimeoutException(String, String) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLTimeoutException 对象。
SQLTimeoutException(String, String, int) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTimeoutException 对象。
SQLTimeoutException(Throwable) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String, Throwable) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String, String, Throwable) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String, String, int, Throwable) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTimeoutException 对象。
SQLTransactionRollbackException - java.sql 中的 异常
当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
SQLTransactionRollbackException() - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String, String) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String, String, int) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(Throwable) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String, Throwable) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String, String, Throwable) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String, String, int, Throwable) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransientConnectionException - java.sql 中的 异常
SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
SQLTransientConnectionException() - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String, String) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String, String, int) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(Throwable) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String, Throwable) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String, String, Throwable) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String, String, int, Throwable) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientException - java.sql 中的 异常
没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
SQLTransientException() - 异常 java.sql.SQLTransientException 的构造方法
构造一个 SQLTransientException 对象。
SQLTransientException(String) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason 的 SQLTransientException 对象。
SQLTransientException(String, String) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLTransientException 对象。
SQLTransientException(String, String, int) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientException 对象。
SQLTransientException(Throwable) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 cause 的 SQLTransientException 对象。
SQLTransientException(String, Throwable) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLTransientException(String, String, Throwable) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientException 对象。
SQLTransientException(String, String, int, Throwable) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientException 对象。
SQLWarning - java.sql 中的 异常
提供关于数据库访问警告信息的异常。
SQLWarning(String, String, int) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLWarning 对象。
SQLWarning(String, String) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason 和 SQLState 的 SQLWarning 对象。
SQLWarning(String) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason 的 SQLWarning 对象。
SQLWarning() - 异常 java.sql.SQLWarning 的构造方法
构造一个 SQLWarning 对象。
SQLWarning(Throwable) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 cause 的 SQLWarning 对象。
SQLWarning(String, Throwable) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason 和 cause 的 SQLWarning 对象。
SQLWarning(String, String, Throwable) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason、SQLState 和 cause 的 SQLWarning 对象。
SQLWarning(String, String, int, Throwable) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLWarning 对象。
SQLXML - java.sql 中的 接口
SQL XML 类型在 JavaTM 编程语言中的映射关系。
SQLXML - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 XML 的 Java 编程语言中的常量（有时称为类型代码）。
sqrt(double) - 类 java.lang.Math 中的静态方法
返回正确舍入的 double 值的正平方根。
sqrt(double) - 类 java.lang.StrictMath 中的静态方法
返回正确舍入的 double 值的正平方根。
SRC - 类 java.awt.AlphaComposite 中的静态变量
将源色复制到目标色（Porter-Duff Source 规则）。
Src - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 SRC 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
SRC - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
SRC_ATOP - 类 java.awt.AlphaComposite 中的静态变量
目标色中的源色部分将被合成到目标色中（Porter-Duff Source Atop Destination 规则）。
SRC_IN - 类 java.awt.AlphaComposite 中的静态变量
目标色中的源色部分将替换目标色（Porter-Duff Source In Destination 规则）。
SRC_OUT - 类 java.awt.AlphaComposite 中的静态变量
目标色以外的源色部分将替换目标色（Porter-Duff Source Held Out By Destination 规则）。
SRC_OVER - 类 java.awt.AlphaComposite 中的静态变量
在目标色之上合成源色（Porter-Duff Source Over Destination 规则）。
SrcAtop - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 SRC_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
srccols - 类 java.awt.image.ReplicateScaleFilter 中的变量
包含关于像素列信息的 int 数组。
srcHeight - 类 java.awt.image.ReplicateScaleFilter 中的变量
源图像的高度。
SrcIn - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 SRC_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
SrcOut - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 SRC_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
SrcOver - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 SRC_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
srcrows - 类 java.awt.image.ReplicateScaleFilter 中的变量
包含关于像素行信息的 int 数组。
srcWidth - 类 java.awt.image.ReplicateScaleFilter 中的变量
源图像的宽度。
SSLContext - javax.net.ssl 中的 类
此类的实例表示安全套接字协议的实现，它充当用于安全套接字工厂或 SSLEngine 的工厂。
SSLContext(SSLContextSpi, Provider, String) - 类 javax.net.ssl.SSLContext 的构造方法
创建 SSLContext 对象。
SSLContextSpi - javax.net.ssl 中的 类
此类为 SSLContext 类定义了服务提供者接口 (SPI)。
SSLContextSpi() - 类 javax.net.ssl.SSLContextSpi 的构造方法
SSLEngine - javax.net.ssl 中的 类
此类允许使用安全套接字层 (SSL) 或 IETF RFC 2246 "Transport Layer Security" (TLS) 协议进行安全通信，但它与传输无关。
SSLEngine() - 类 javax.net.ssl.SSLEngine 的构造方法
SSLEngine 的构造方法，该构造方法不为内部会话重用策略提供提示。
SSLEngine(String, int) - 类 javax.net.ssl.SSLEngine 的构造方法
SSLEngine 的构造方法。
SSLEngineResult - javax.net.ssl 中的 类
SSLEngine I/O 调用所生成的结果状态的封装。
SSLEngineResult(SSLEngineResult.Status, SSLEngineResult.HandshakeStatus, int, int) - 类 javax.net.ssl.SSLEngineResult 的构造方法
初始化此类的一个新实例。
SSLEngineResult.HandshakeStatus - javax.net.ssl 中的 枚举
描述此 SSLEngine 的当前握手状态的 SSLEngineResult 枚举。
SSLEngineResult.Status - javax.net.ssl 中的 枚举
描述 SSLEngine 操作总体结果的 SSLEngineResult 枚举。
SSLException - javax.net.ssl 中的 异常
指示由 SSL 子系统检测到的某类错误。
SSLException(String) - 异常 javax.net.ssl.SSLException 的构造方法
构造一个异常，该异常报告由 SSL 子系统发现的错误。
SSLException(String, Throwable) - 异常 javax.net.ssl.SSLException 的构造方法
创建带指定详细消息和原因的 SSLException。
SSLException(Throwable) - 异常 javax.net.ssl.SSLException 的构造方法
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造异常 SSLException（它通常包含 cause 的类和详细消息）。
SSLHandshakeException - javax.net.ssl 中的 异常
指示客户端和服务器不能就所需安全级别进行协商。
SSLHandshakeException(String) - 异常 javax.net.ssl.SSLHandshakeException 的构造方法
构造一个报告由 SSL 子系统在握手期间发现的错误的异常。
SSLKeyException - javax.net.ssl 中的 异常
报告错误的 SSL 密钥。
SSLKeyException(String) - 异常 javax.net.ssl.SSLKeyException 的构造方法
构造一个报告由 SSL 子系统发现的密钥管理错误的异常。
SSLParameters - javax.net.ssl 中的 类
封装 SSL/TLS 连接的参数。
SSLParameters() - 类 javax.net.ssl.SSLParameters 的构造方法
构造 SSLParameters。
SSLParameters(String[]) - 类 javax.net.ssl.SSLParameters 的构造方法
根据指定的密码套件数组构造 SSLParameters。
SSLParameters(String[], String[]) - 类 javax.net.ssl.SSLParameters 的构造方法
根据指定的密码套件数组和协议数组构造 SSLParameters。
SSLPeerUnverifiedException - javax.net.ssl 中的 异常
指示还没有验证同位体的身份。
SSLPeerUnverifiedException(String) - 异常 javax.net.ssl.SSLPeerUnverifiedException 的构造方法
构造一个报告还没有验证 SSL 同位体的身份的异常。
SSLPermission - javax.net.ssl 中的 类
此类用于各种网络权限。
SSLPermission(String) - 类 javax.net.ssl.SSLPermission 的构造方法
用指定的名称创建一个新的 SSLPermission。
SSLPermission(String, String) - 类 javax.net.ssl.SSLPermission 的构造方法
用指定的名称创建一个新的 SSLPermission 对象。
SSLProtocolException - javax.net.ssl 中的 异常
报告在 SSL 协议的操作中的错误。
SSLProtocolException(String) - 异常 javax.net.ssl.SSLProtocolException 的构造方法
构造一个报告由 SSL 子系统检测到的 SSL 协议错误的异常。
SslRMIClientSocketFactory - javax.rmi.ssl 中的 类
SslRMIClientSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的客户端套接字。
SslRMIClientSocketFactory() - 类 javax.rmi.ssl.SslRMIClientSocketFactory 的构造方法
创建一个新的 SslRMIClientSocketFactory。
SslRMIServerSocketFactory - javax.rmi.ssl 中的 类
SslRMIServerSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的服务端套接字。
SslRMIServerSocketFactory() - 类 javax.rmi.ssl.SslRMIServerSocketFactory 的构造方法
使用默认的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。
SslRMIServerSocketFactory(String[], String[], boolean) - 类 javax.rmi.ssl.SslRMIServerSocketFactory 的构造方法
使用指定的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。
SSLServerSocket - javax.net.ssl 中的 类
此类扩展了 ServerSocket 并且提供使用像 Secure Sockets Layer (SSL) 或 Transport Layer Security (TLS) 协议的安全服务器套接字。
SSLServerSocket() - 类 javax.net.ssl.SSLServerSocket 的构造方法
仅供子类使用。
SSLServerSocket(int) - 类 javax.net.ssl.SSLServerSocket 的构造方法
仅供子类使用。
SSLServerSocket(int, int) - 类 javax.net.ssl.SSLServerSocket 的构造方法
仅供子类使用。
SSLServerSocket(int, int, InetAddress) - 类 javax.net.ssl.SSLServerSocket 的构造方法
仅供子类使用。
SSLServerSocketFactory - javax.net.ssl 中的 类
SSLServerSocketFactory 创建 SSLServerSocket。
SSLServerSocketFactory() - 类 javax.net.ssl.SSLServerSocketFactory 的构造方法
构造方法仅供子类使用。
SSLSession - javax.net.ssl 中的 接口
在 SSL 中，会话用来描述两个实体间正在发生的关系。
SSLSessionBindingEvent - javax.net.ssl 中的 类
此事件向 SSLSessionBindingListener 传播。
SSLSessionBindingEvent(SSLSession, String) - 类 javax.net.ssl.SSLSessionBindingEvent 的构造方法
构造一个新的 SSLSessionBindingEvent。
SSLSessionBindingListener - javax.net.ssl 中的 接口
想知道何时将它们绑定到 SSLSession 或从 SSLSession 解除绑定的对象实现此接口。
SSLSessionContext - javax.net.ssl 中的 接口
SSLSessionContext 表示与单个实体关联的 SSLSession。
SSLSocket - javax.net.ssl 中的 类
此类扩展 Socket 并提供使用诸如安全套接字层 (Secure Sockets Layer, SSL) 或 IETF 传输层安全性 (Transport Layer Security, TLS) 等协议的安全套接字。
SSLSocket() - 类 javax.net.ssl.SSLSocket 的构造方法
仅供子类使用。
SSLSocket(String, int) - 类 javax.net.ssl.SSLSocket 的构造方法
仅供子类使用。
SSLSocket(InetAddress, int) - 类 javax.net.ssl.SSLSocket 的构造方法
仅供子类使用。
SSLSocket(String, int, InetAddress, int) - 类 javax.net.ssl.SSLSocket 的构造方法
仅供子类使用。
SSLSocket(InetAddress, int, InetAddress, int) - 类 javax.net.ssl.SSLSocket 的构造方法
仅供子类使用。
SSLSocketFactory - javax.net.ssl 中的 类
SSLSocketFactory 创建 SSLSocket。
SSLSocketFactory() - 类 javax.net.ssl.SSLSocketFactory 的构造方法
构造方法仅供子类使用。
Stack<E> - java.util 中的 类
Stack 类表示后进先出（LIFO）的对象堆栈。
Stack() - 类 java.util.Stack 的构造方法
创建一个空堆栈。
StackOverflowError - java.lang 中的 错误
当应用程序递归太深而发生堆栈溢出时，抛出该错误。
StackOverflowError() - 错误 java.lang.StackOverflowError 的构造方法
构造不带详细消息的 StackOverflowError。
StackOverflowError(String) - 错误 java.lang.StackOverflowError 的构造方法
构造带指定详细消息的 StackOverflowError。
StackTraceElement - java.lang 中的 类
堆栈跟踪中的元素，它由 Throwable.getStackTrace() 返回。
StackTraceElement(String, String, String, int) - 类 java.lang.StackTraceElement 的构造方法
创建表示指定执行点的堆栈跟踪元素。
STANDALONE - 类 javax.xml.transform.OutputKeys 中的静态变量
standalone = "yes" | "no". standalone 指定了 Transformer 是否应输出单独的文档声明，其值必须为 yes 或 no。
standaloneSet() - 接口 javax.xml.stream.events.StartDocument 中的方法
如果在文档的编码声明中设置了单独属性，则返回 ture。
standaloneSet() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
standaloneSet() - 接口 javax.xml.stream.XMLStreamReader 中的方法
检查文档中是否设置了独立
STANDARD - 类 java.awt.font.GlyphMetrics 中的静态变量
指示表示单个标准字符的字形。
STANDARD - 类 javax.print.attribute.standard.JobSheets 中的静态变量
打印一个或多个指定位置的标准作业页，例如，打印单张开始页，或者打印开始页和结束页。
STANDARD_INPUT_TYPE - 类 javax.imageio.spi.ImageReaderSpi 中的静态变量
将从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。
STANDARD_OUTPUT_TYPE - 类 javax.imageio.spi.ImageWriterSpi 中的静态变量
从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。
STANDARD_TIME - 类 java.util.SimpleTimeZone 中的静态变量
指定为标准时间的开始或结束时间模式的常量。
StandardEmitterMBean - javax.management 中的 类
一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。
StandardEmitterMBean(T, Class<T>, NotificationEmitter) - 类 javax.management.StandardEmitterMBean 的构造方法
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(T, Class<T>, boolean, NotificationEmitter) - 类 javax.management.StandardEmitterMBean 的构造方法
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(Class<?>, NotificationEmitter) - 类 javax.management.StandardEmitterMBean 的构造方法
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(Class<?>, boolean, NotificationEmitter) - 类 javax.management.StandardEmitterMBean 的构造方法
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
standardFormatSupported - 类 javax.imageio.metadata.IIOMetadata 中的变量
指示具体子类是否支持标准元数据格式的 boolean 值，通过构造方法设置。
StandardJavaFileManager - javax.tools 中的 接口
基于 java.io.File 的文件管理器。
StandardLocation - javax.tools 中的 枚举
文件对象的标准位置。
StandardMBean - javax.management 中的 类
一个管理接口由 Java 接口上的反射确定的 MBean。
StandardMBean(T, Class<T>) - 类 javax.management.StandardMBean 的构造方法
使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。
StandardMBean(Class<?>) - 类 javax.management.StandardMBean 的构造方法
使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
StandardMBean(T, Class<T>, boolean) - 类 javax.management.StandardMBean 的构造方法
使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。
StandardMBean(Class<?>, boolean) - 类 javax.management.StandardMBean 的构造方法
使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
standardMetadataFormatName - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的静态变量
包含标准格式名称 "javax_imageio_1.0" 的 String 常量。
STANDBY - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
STAPLE - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与一个或多个装订点进行绑定。
STAPLE_BOTTOM_LEFT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与左下角中的一个或多个装订点绑定。
STAPLE_BOTTOM_RIGHT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档或多个文档与右下角中的一个或多个装订点绑定。
STAPLE_DUAL_BOTTOM - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿底边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
STAPLE_DUAL_LEFT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿左边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
STAPLE_DUAL_RIGHT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿右边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
STAPLE_DUAL_TOP - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿顶边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
STAPLE_TOP_LEFT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与左上角中的一个或多个装订点绑定。
STAPLE_TOP_RIGHT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档或多个文档与右上角中的一个或多个装订点绑定。
start() - 类 java.applet.Applet 中的方法
由浏览器或 applet viewer 调用，通知此 applet 它应该开始执行。
start - 类 java.awt.geom.Arc2D.Double 中的变量
弧的起始角度（以度数表示）。
start - 类 java.awt.geom.Arc2D.Float 中的变量
弧的起始角度（以度数表示）。
start() - 类 java.lang.ProcessBuilder 中的方法
使用此进程生成器的属性启动一个新进程。
start() - 类 java.lang.Thread 中的方法
使该线程开始执行；Java 虚拟机调用该线程的 run 方法。
start() - 类 java.util.regex.Matcher 中的方法
返回以前匹配的初始索引。
start(int) - 类 java.util.regex.Matcher 中的方法
返回在以前的匹配操作期间，由给定组所捕获的子序列的初始索引。
start() - 接口 java.util.regex.MatchResult 中的方法
返回匹配的初始索引。
start(int) - 接口 java.util.regex.MatchResult 中的方法
返回在匹配期间由给定组捕获的子序列的初始索引。
start() - 类 javax.management.monitor.CounterMonitor 中的方法
启动计数器监视器。
start() - 类 javax.management.monitor.GaugeMonitor 中的方法
启用尺度监视器。
start() - 类 javax.management.monitor.Monitor 中的方法
启动监视器。
start() - 接口 javax.management.monitor.MonitorMBean 中的方法
启动监视器。
start() - 类 javax.management.monitor.StringMonitor 中的方法
启动字符串监视器。
start() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
激活连接器服务器，即开始侦听客户端连接。
start() - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
激活连接器服务器，即启动对客户端连接的侦听。
start() - 类 javax.management.timer.Timer 中的方法
启动计时器。
start() - 接口 javax.management.timer.TimerMBean 中的方法
启动计时器。
start() - 接口 javax.sound.midi.Sequencer 中的方法
开始回放当前已加载 sequence 中的 MIDI 数据。
START - 类 javax.sound.midi.ShortMessage 中的静态变量
START 消息的状态字节（0xFA 或 250）。
start() - 接口 javax.sound.sampled.DataLine 中的方法
允许某一数据行执行数据 I/O。
START - 类 javax.sound.sampled.LineEvent.Type 中的静态变量
在行响应 start 请求而进行音频数据的活动输入或输出时发送的事件类型。
START - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 中的方法
当发现此动作所注册的标记类型的开始标记时调用。
start() - 类 javax.swing.Timer 中的方法
启动 Timer，使它开始向其侦听器发送动作事件。
start(Xid, int) - 接口 javax.transaction.xa.XAResource 中的方法
代表 xid 中指定的事务分支开始工作。
START_DOCUMENT - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个开始文档
START_ELEMENT - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个开始元素
START_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Ps”。
start_value() - 接口 org.omg.CORBA.portable.ValueInputStream 中的方法
start_value 方法读取嵌套自定义 valuetype 的 valuetype 头并将该 valuetype 的嵌套层次加 1。
start_value(String) - 接口 org.omg.CORBA.portable.ValueOutputStream 中的方法
start_value 方法结束任何当前开启的程序块，写入嵌套自定义 valuetype 的 valuetype 头（使用 null 代码基和指定的存储库 ID），并将 valuetype 嵌套层次加 1。
startAnimationTimer() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
启动动画线程，如果必要则创建并初始化它。
startAutoScrolling(int) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
startCDATA() - 类 org.xml.sax.ext.DefaultHandler2 中的方法
startCDATA() - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告 CDATA 节的开始。
startCellEditing(EventObject) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
返回 true 指示编辑已经开始。
StartDocument - javax.xml.stream.events 中的 接口
开始文档事件的接口。
startDocument() - 接口 org.xml.sax.ContentHandler 中的方法
接收文档的开始的通知。
startDocument() - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收文档的开始的通知。
startDocument() - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收文档开始的通知。
startDocument() - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收文档开始的通知。
startDocument() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
startDocument() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个开始文档事件。
startDocument() - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
开始文档事件。
startDrag(Cursor, Transferable) - 类 java.awt.dnd.DragGestureEvent 中的方法
在给定拖动操作的 Cursor 和表示拖动操作源数据的 Transferable 的情况下开始拖动此操作。
startDrag(Cursor, Transferable, DragSourceListener) - 类 java.awt.dnd.DragGestureEvent 中的方法
在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
startDrag(Cursor, Image, Point, Transferable, DragSourceListener) - 类 java.awt.dnd.DragGestureEvent 中的方法
在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
startDrag(DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener, FlavorMap) - 类 java.awt.dnd.DragSource 中的方法
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
startDrag(DragGestureEvent, Cursor, Transferable, DragSourceListener, FlavorMap) - 类 java.awt.dnd.DragSource 中的方法
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
startDrag(DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - 类 java.awt.dnd.DragSource 中的方法
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
startDrag(DragGestureEvent, Cursor, Transferable, DragSourceListener) - 类 java.awt.dnd.DragSource 中的方法
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
startDragging() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
应该在拖动会话开始、重置 lastDragLocation 和 dividerSize 之前传递消息。
startDTD(String, String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
startDTD(String, String, String) - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告 DTD 声明的开始（如果存在）。
startEditing(TreePath, MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果存在 cellEditor 并且 shouldSelectCell 返回 true，则启动节点的编辑操作。
startEditingAtPath(TreePath) - 类 javax.swing.JTree 中的方法
选择指定路径标识的节点，并开始编辑。
startEditingAtPath(JTree, TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
选择路径中的最后一个项并尝试对其进行编辑。
startEditingAtPath(JTree, TreePath) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 startEditingAtPath 方法。
startEditingAtPath(JTree, TreePath) - 类 javax.swing.plaf.TreeUI 中的方法
选择路径中的最后一个项并试着编辑它。
startEditingTimer() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
启动编辑计时器。
StartElement - javax.xml.stream.events 中的 接口
StartElement 接口提供对有关开始元素的信息的访问。
startElement(Element) - 接口 org.w3c.dom.ls.LSParserFilter 中的方法
解析器将在扫描完每个 Element 启动标记后，处理其余的 Element 之前调用此方法。
startElement(String, String, String, Attributes) - 接口 org.xml.sax.ContentHandler 中的方法
接收元素开始的通知。
startElement(String, AttributeList) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收元素开始的通知。
startElement(String, AttributeList) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收元素开始的通知。
startElement(String, String, String, Attributes) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收元素开始的通知。
startElement(String, AttributeList) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
startElement(String, String, String, Attributes) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个开始元素事件。
startElement(String, String, String, Attributes) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 开始元素事件。
startEntity(String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
startEntity(String) - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告一些内部和外部 XML 实体的开始。
startFontTag(String) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
此方法已不再使用，而用写出 <span> 来替换。
startGrabbing() - 类 java.awt.image.PixelGrabber 中的方法
请求 PixelGrabber 开始获取像素。
startHandshake() - 类 javax.net.ssl.SSLSocket 中的方法
在此连接上开始 SSL 握手。
startIndex - 类 javax.accessibility.AccessibleAttributeSequence 中的变量
文本序列的起始索引
startIndex - 类 javax.accessibility.AccessibleTextSequence 中的变量
startPrefixMapping(String, String) - 接口 org.xml.sax.ContentHandler 中的方法
开始前缀 URI 名称空间范围映射。
startPrefixMapping(String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收名称空间映射开始的通知。
startPrefixMapping(String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个开始名称空间前缀映射事件。
startPrefixMapping(String, String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 开始前缀映射事件。
startProduction(ImageConsumer) - 类 java.awt.image.FilteredImageSource 中的方法
开始生成过滤图像。
startProduction(ImageConsumer) - 接口 java.awt.image.ImageProducer 中的方法
将指定的 ImageConsumer 对象注册为使用者，并立即开始图像数据的重构，然后这些图像数据将传递到此使用者和已经向该生产者注册的所有其他使用者。
startProduction(ImageConsumer) - 类 java.awt.image.MemoryImageSource 中的方法
将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表中，并立即开始通过 ImageConsumer 接口传递图像数据。
startProduction(ImageConsumer) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表，并立即通过 ImageConsumer 接口开始提交该图像数据。
startRecording() - 接口 javax.sound.midi.Sequencer 中的方法
开始录制和回放 MIDI 数据。
startsWith(String, int) - 类 java.lang.String 中的方法
测试此字符串从指定索引开始的子字符串是否以指定前缀开始。
startsWith(String) - 类 java.lang.String 中的方法
测试此字符串是否以指定的前缀开始。
startsWith(Name) - 类 javax.naming.CompositeName 中的方法
确定某一复合名称是否是此复合名称的前缀。
startsWith(Name) - 类 javax.naming.CompoundName 中的方法
确定某一组合名称是否是此组合名称的前缀。
startsWith(Name) - 类 javax.naming.ldap.LdapName 中的方法
确定此 LDAP 名称是否从某一指定 LDAP 名称前缀开始。
startsWith(List<Rdn>) - 类 javax.naming.ldap.LdapName 中的方法
确定指定的 RDN 序列是否形成此 LDAP 名称的前缀。
startsWith(Name) - 接口 javax.naming.Name 中的方法
确定此名称是否从某一指定前缀开始。
startTag(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出元素的开始标记。
STARTTAG - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
startTag(TagElement) - 类 javax.swing.text.html.parser.Parser 中的方法
处理开始标记。
StartTagType - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getType 的可能值。
startTimer() - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的方法
在必要时，创建并启动 Timer 来检查是否需要调整边界的大小。
StartTlsRequest - javax.naming.ldap 中的 类
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展请求。
StartTlsRequest() - 类 javax.naming.ldap.StartTlsRequest 的构造方法
构造 StartTLS 扩展请求。
StartTlsResponse - javax.naming.ldap 中的 类
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展响应。
StartTlsResponse() - 类 javax.naming.ldap.StartTlsResponse 的构造方法
构造 StartTLS 扩展响应。
state - 类 java.security.Signature 中的变量
此签名对象的当前状态。
state() - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
返回刚创建并在 IOR interceptor 上运行的对象适配器的对象适配器状态。
State - org.omg.PortableServer.POAManagerPackage 中的 类
指定 POAManager 的状态。
State(int) - 类 org.omg.PortableServer.POAManagerPackage.State 的构造方法
STATE_FACTORIES - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定要使用的状态工厂列表的环境属性名称。
stateChanged(ChangeEvent) - 类 javax.swing.AbstractButton.ButtonChangeListener 中的方法
stateChanged(ChangeEvent) - 接口 javax.swing.event.ChangeListener 中的方法
当侦听器的目标已更改其状态时调用。
stateChanged(ChangeEvent) - 类 javax.swing.JMenuItem.AccessibleJMenuItem 中的方法
支持更改侦听器接口并激发属性更改。
stateChanged(ChangeEvent) - 类 javax.swing.JScrollPane.AccessibleJScrollPane 中的方法
当侦听器目标的状态改变时，此方法被调用。
stateChanged(ChangeEvent) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
侦听器的目标已更改其状态时调用。
stateChanged(ChangeEvent) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
当 spinner 的模型状态更改时调用此方法。
stateChanged(ChangeEvent) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.JTabbedPane.ModelListener 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ModelListener 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.ChangeHandler 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
在侦听器的目标已更改其状态时调用。
StateEdit - javax.swing.undo 中的 类
StateEdit 是更改状态的对象的通用编辑。
StateEdit(StateEditable) - 类 javax.swing.undo.StateEdit 的构造方法
创建并返回新的 StateEdit。
StateEdit(StateEditable, String) - 类 javax.swing.undo.StateEdit 的构造方法
创建并返回具有表示名称的新 StateEdit。
StateEditable - javax.swing.undo 中的 接口
StateEditable 定义可以由 StateEdit 撤消/恢复其状态的对象的接口。
StateFactory - javax.naming.spi 中的 接口
此接口表示一个工厂，该工厂用来获得用于绑定的对象状态。
stateMask - 类 javax.swing.DefaultButtonModel 中的变量
用于存储按钮状态的位掩码。
STATEMENT - 类 java.awt.PageAttributes.MediaType 中的静态变量
INVOICE 的别名。
Statement - java.beans 中的 类
Statement 对象表示基本语句，其中将单个方法应用于某一目标和一组参数，以返回结果，比如 "a.setFoo(b)"。
Statement(Object, String, Object[]) - 类 java.beans.Statement 的构造方法
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。
Statement - java.sql 中的 接口
用于执行静态 SQL 语句并返回它所生成结果的对象。
statementClosed(StatementEvent) - 接口 javax.sql.StatementEventListener 中的方法
检测到 PreparedStatement 关闭时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。
statementErrorOccurred(StatementEvent) - 接口 javax.sql.StatementEventListener 中的方法
检测到 PreparedStatement 无效时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。
StatementEvent - javax.sql 中的 类
StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。
StatementEvent(PooledConnection, PreparedStatement) - 类 javax.sql.StatementEvent 的构造方法
用指定的 PooledConnection 和 PreparedStatement 构造 StatementEvent。
StatementEvent(PooledConnection, PreparedStatement, SQLException) - 类 javax.sql.StatementEvent 的构造方法
用指定的 PooledConnection、PreparedStatement 和 SQLException 构造 StatementEvent。
StatementEventListener - javax.sql 中的 接口
注册为能获得 Statement 池中 PreparedStatement 上所发生事件的通知的对象。
states - 类 javax.accessibility.AccessibleStateSet 中的变量
Vector 中的每个项表示一个 AccessibleState。
STATIC - 类 java.lang.reflect.Modifier 中的静态变量
表示 static 修饰符的 int 值。
STATICIMAGEDONE - 接口 java.awt.image.ImageConsumer 中的静态变量
图像已完成，不再有像素或帧要传递。
status() - 类 java.awt.image.PixelGrabber 中的方法
返回像素的状态。
STATUS_BAR - 类 javax.accessibility.AccessibleRole 中的静态变量
STATUS_BAR 是可以包含多个用户状态信息标签的简单组件。
statusAll(boolean) - 类 java.awt.MediaTracker 中的方法
计算并返回此媒体跟踪器跟踪的所有媒体状态的按位或。
statusID(int, boolean) - 类 java.awt.MediaTracker 中的方法
计算或返回由此媒体跟踪器跟踪且具有指定标识符的所有媒体状态的按位或。
StAXResult - javax.xml.transform.stax 中的 类
以 StAX writer 的形式（即 XMLStreamWriter 或 XMLEventWriter）充当 XML Result 的持有者。
StAXResult(XMLEventWriter) - 类 javax.xml.transform.stax.StAXResult 的构造方法
通过提供 XMLEventWriter 创建 StAXResult 的一个新实例。
StAXResult(XMLStreamWriter) - 类 javax.xml.transform.stax.StAXResult 的构造方法
通过提供 XMLStreamWriter 创建 StAXResult 的一个新实例。
StAXSource - javax.xml.transform.stax 中的 类
以 StAX reader 的形式（即 XMLStreamReader 或 XMLEventReader）充当 XML Source 的持有者。
StAXSource(XMLEventReader) - 类 javax.xml.transform.stax.StAXSource 的构造方法
通过提供 XMLEventReader 创建 StAXSource 的一个新实例。
StAXSource(XMLStreamReader) - 类 javax.xml.transform.stax.StAXSource 的构造方法
通过 XMLStreamReader 创建 StAXSource 的一个新实例。
StdACChrominance - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的静态变量
标准 AC 色度 Huffman 表。
StdACLuminance - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的静态变量
标准 AC 亮度 Huffman 表。
StdDCChrominance - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的静态变量
标准 DC 色度 Huffman 表。
StdDCLuminance - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的静态变量
标准 DC 亮度 Huffman 表。
stop() - 类 java.applet.Applet 中的方法
由浏览器或 applet viewer 调用，通知此 applet 它应该终止执行。
stop() - 接口 java.applet.AudioClip 中的方法
停止播放此音频剪辑。
stop() - 类 java.awt.dnd.DropTarget.DropTargetAutoScroller 中的方法
导致停止自动滚动
stop() - 类 java.lang.Thread 中的方法
已过时。 该方法具有固有的不安全性。用 Thread.stop 来终止线程将释放它已经锁定的所有监视器（作为沿堆栈向上传播的未检查 ThreadDeath 异常的一个自然后果）。如果以前受这些监视器保护的任何对象都处于一种不一致的状态，则损坏的对象将对其他线程可见，这有可能导致任意的行为。stop 的许多使用都应由只修改某些变量以指示目标线程应该停止运行的代码来取代。目标线程应定期检查该变量，并且如果该变量指示它要停止运行，则从其运行方法依次返回。如果目标线程等待很长时间（例如基于一个条件变量），则应使用 interrupt 方法来中断该等待。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
stop(Throwable) - 类 java.lang.Thread 中的方法
已过时。 该方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。 该方法的附加危险是它可用于生成目标线程未准备处理的异常（包括若没有该方法该线程不太可能抛出的已检查的异常）。 有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
stop() - 类 java.lang.ThreadGroup 中的方法
已过时。 此方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。
stop() - 类 javax.management.monitor.CounterMonitor 中的方法
停止计数器监视器。
stop() - 类 javax.management.monitor.GaugeMonitor 中的方法
停止尺度监视器。
stop() - 类 javax.management.monitor.Monitor 中的方法
停止监视器。
stop() - 接口 javax.management.monitor.MonitorMBean 中的方法
停止监视器。
stop() - 类 javax.management.monitor.StringMonitor 中的方法
停止字符串监视器。
stop() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
取消激活连接器服务器，即停止对客户端连接的侦听。
stop() - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
取消激活连接器服务器，即停止对客户端连接的侦听。
stop() - 类 javax.management.timer.Timer 中的方法
停止计时器。
stop() - 接口 javax.management.timer.TimerMBean 中的方法
停止计时器。
stop() - 接口 javax.sound.midi.Sequencer 中的方法
停止录音（如果处于活动状态）及当前已加载 sequence（如果有）的回放。
STOP - 类 javax.sound.midi.ShortMessage 中的静态变量
STOP 消息的状态字节（0xFC 或 252）。
stop() - 接口 javax.sound.sampled.DataLine 中的方法
停止行。
STOP - 类 javax.sound.sampled.LineEvent.Type 中的静态变量
当行响应 stop 请求或者因为已到达介质的结尾处而终止音频数据的活动输入或输出时发送的事件类型。
stop() - 类 javax.swing.Timer 中的方法
停止 Timer，使它停止向其侦听器发送动作事件。
stop() - 类 javax.xml.ws.Endpoint 中的方法
停止发布此端点。
stopAnimationTimer() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
停止动画线程。
stopAutoScrolling() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
stopCellEditing() - 类 javax.swing.AbstractCellEditor 中的方法
调用 fireEditingStopped 并返回 true。
stopCellEditing() - 接口 javax.swing.CellEditor 中的方法
告知编辑器停止编辑并接受任何已部分编辑的值作为编辑器的值。
stopCellEditing() - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
停止编辑并返回 true，指示编辑已经停止。
stopCellEditing() - 类 javax.swing.DefaultCellEditor 中的方法
将消息从 CellEditor 转发到 delegate。
stopCellEditing() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果 realEditor 允许编辑停止，则移除 realEditor，并返回 true，否则返回 false。
stopEditing() - 类 javax.swing.JTree 中的方法
结束当前编辑会话。
stopEditing(JTree) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
停止当前编辑会话。
stopEditing(JTree) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 stopEditing 方法。
stopEditing(JTree) - 类 javax.swing.plaf.TreeUI 中的方法
停止当前编辑会话。
stopEditingInCompleteEditing - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
编辑时设置为 false，shouldSelectCell() 返回 true 表示应该在编辑前选中节点，在 completeEditing 中使用该字段。
STOPPED - 类 javax.print.attribute.standard.PrinterState 中的静态变量
指示没有作业可以处理，需要干预。
STOPPED_PARTLY - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
当打印机控制多个输出设备时，此原因指示一个或多个设备被停止。
STOPPING - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
打印机正在停止设备，并且打印机也将很快停下来。
stopPropagation() - 接口 org.w3c.dom.events.Event 中的方法
stopPropagation 方法用于阻止在事件流期间事件的进一步传播。
stopRecording() - 接口 javax.sound.midi.Sequencer 中的方法
停止录制（如果处于活动状态）。
store(OutputStream, char[]) - 类 java.security.KeyStore 中的方法
将此 keystore 存储到给定输出流，并用给定密码保护其完整性。
store(KeyStore.LoadStoreParameter) - 类 java.security.KeyStore 中的方法
使用给定 LoadStoreParameter 存储此 keystore。
store(Writer, String) - 类 java.util.Properties 中的方法
以适合使用 load(Reader) 方法的格式，将此 Properties 表中的属性列表（键和元素对）写入输出字符。
store(OutputStream, String) - 类 java.util.Properties 中的方法
以适合使用 load(InputStream) 方法加载到 Properties 表中的格式，将此 Properties 表中的属性列表（键和元素对）写入输出流。
store() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
捕获此 MBean 实例的当前状态，并将它写出到持久存储中。
store() - 接口 javax.management.PersistentMBean 中的方法
捕获此 MBean 实例的当前状态并将其写出到持久存储中。
STORED - 类 java.util.zip.ZipEntry 中的静态变量
用于未压缩条目的压缩方法。
STORED - 类 java.util.zip.ZipOutputStream 中的静态变量
用于未压缩 (STORED) 条目的压缩方法。
storesLowerCaseIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。
storesLowerCaseQuotedIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。
storesMixedCaseIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。
storesMixedCaseQuotedIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。
storeState(Hashtable<Object, Object>) - 接口 javax.swing.undo.StateEditable 中的方法
收到此消息时，接收者应把任何相关状态放置到 state 中。
storesUpperCaseIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。
storesUpperCaseQuotedIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。
storeToXML(OutputStream, String) - 类 java.util.Properties 中的方法
发出一个表示此表中包含的所有属性的 XML 文档。
storeToXML(OutputStream, String, String) - 类 java.util.Properties 中的方法
使用指定的编码发出一个表示此表中包含的所有属性的 XML 文档。
strategy - 类 javax.swing.text.FlowView 中的变量
保持流更新的行为。
STREAM_MAGIC - 接口 java.io.ObjectStreamConstants 中的静态变量
写入流头的幻数。
STREAM_VERSION - 接口 java.io.ObjectStreamConstants 中的静态变量
写入流头的版本号。
Streamable - org.omg.CORBA.portable 中的 接口
所有复杂 IDL 类型的 Holder 类的基类。
StreamableValue - org.omg.CORBA.portable 中的 接口
为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。
StreamCorruptedException - java.io 中的 异常
当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
StreamCorruptedException(String) - 异常 java.io.StreamCorruptedException 的构造方法
创建一个 StreamCorruptedException 并列出抛出异常的一个原因。
StreamCorruptedException() - 异常 java.io.StreamCorruptedException 的构造方法
创建一个 StreamCorruptedException，但不列出抛出异常的原因。
StreamDescriptionProperty - 接口 javax.swing.text.Document 中的静态变量
用于描述初始化文档的流的属性名。
StreamFilter - javax.xml.stream 中的 接口
此接口声明了一个简单的过滤器接口，用户可创建它来过滤 XMLStreamReader。
StreamHandler - java.util.logging 中的 类
基于流的日志 Handler。
StreamHandler() - 类 java.util.logging.StreamHandler 的构造方法
创建不带当前输出流的 StreamHandler。
StreamHandler(OutputStream, Formatter) - 类 java.util.logging.StreamHandler 的构造方法
创建带给定 Formatter 和输出流的 StreamHandler。
streamPos - 类 javax.imageio.stream.ImageInputStreamImpl 中的变量
流中的当前读取位置。
StreamPrintService - javax.print 中的 类
此类扩展了 PrintService 并表示这样一种 PrintService，即以不同的格式向客户端提供的输出流打印数据。
StreamPrintService(OutputStream) - 类 javax.print.StreamPrintService 的构造方法
构造一个 StreamPrintService 对象。
StreamPrintServiceFactory - javax.print 中的 类
StreamPrintServiceFactory 是 StreamPrintService 实例的工厂，StreamPrintService 可以 mime 类型所描述的特定文档格式向输出流中打印数据。
StreamPrintServiceFactory() - 类 javax.print.StreamPrintServiceFactory 的构造方法
StreamReaderDelegate - javax.xml.stream.util 中的 类
该类是用于派生 XMLStreamReader 过滤器的基类。
StreamReaderDelegate() - 类 javax.xml.stream.util.StreamReaderDelegate 的构造方法
构造没有父过滤器的空过滤器。
StreamReaderDelegate(XMLStreamReader) - 类 javax.xml.stream.util.StreamReaderDelegate 的构造方法
用指定的父过滤器来构造一个过滤器。
StreamResult - javax.xml.transform.stream 中的 类
充当转换结果的持有者，可以为 XML、纯文本、HTML 或某些其他格式的标记。
StreamResult() - 类 javax.xml.transform.stream.StreamResult 的构造方法
零参数的默认构造方法。
StreamResult(OutputStream) - 类 javax.xml.transform.stream.StreamResult 的构造方法
从字节流构造 StreamResult。
StreamResult(Writer) - 类 javax.xml.transform.stream.StreamResult 的构造方法
从字符流构造 StreamResult。
StreamResult(String) - 类 javax.xml.transform.stream.StreamResult 的构造方法
从 URL 构造 StreamResult。
StreamResult(File) - 类 javax.xml.transform.stream.StreamResult 的构造方法
从 File 构造 StreamResult。
StreamSource - javax.xml.transform.stream 中的 类
以 XML 标记流的形式充当转换 Source 的持有者。
StreamSource() - 类 javax.xml.transform.stream.StreamSource 的构造方法
零参数的默认构造方法。
StreamSource(InputStream) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从字节流构造 StreamSource。
StreamSource(InputStream, String) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从字节流构造 StreamSource。
StreamSource(Reader) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从字符 reader 构造 StreamSource。
StreamSource(Reader, String) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从字符 reader 构造 StreamSource。
StreamSource(String) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从 URL 构造 StreamSource。
StreamSource(File) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从 File 构造 StreamSource。
StreamTokenizer - java.io 中的 类
StreamTokenizer 类获取输入流并将其解析为“标记”，允许一次读取一个标记。
StreamTokenizer(InputStream) - 类 java.io.StreamTokenizer 的构造方法
已过时。 从 JDK 版本 1.1 开始，标记输入流的首选方法是将其转换为一个字符流，例如：
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
StreamTokenizer(Reader) - 类 java.io.StreamTokenizer 的构造方法
创建解析给定字符流的标记生成器。
STRENGTH - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定要使用的密码强度。
STRICT - 类 java.lang.reflect.Modifier 中的静态变量
表示 strictfp 修饰符的 int 的值。
strict - 类 javax.swing.text.html.parser.Parser 中的变量
此标记确定 Parser 在强制执行 SGML 兼容性方面是否严格。
StrictMath - java.lang 中的 类
StrictMath 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。
STRIKE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
STRIKETHROUGH - 类 java.awt.font.TextAttribute 中的静态变量
删除线的属性键。
StrikeThrough - 类 javax.swing.text.StyleConstants 中的静态变量
删除线属性的名称。
STRIKETHROUGH_ON - 类 java.awt.font.TextAttribute 中的静态变量
单删除线。
String - java.lang 中的 类
String 类代表字符串。
String() - 类 java.lang.String 的构造方法
初始化一个新创建的 String 对象，使其表示一个空字符序列。
String(String) - 类 java.lang.String 的构造方法
初始化一个新创建的 String 对象，使其表示一个与参数相同的字符序列；换句话说，新创建的字符串是该参数字符串的副本。
String(char[]) - 类 java.lang.String 的构造方法
分配一个新的 String，使其表示字符数组参数中当前包含的字符序列。
String(char[], int, int) - 类 java.lang.String 的构造方法
分配一个新的 String，它包含取自字符数组参数一个子数组的字符。
String(int[], int, int) - 类 java.lang.String 的构造方法
分配一个新的 String，它包含 Unicode 代码点数组参数一个子数组的字符。
String(byte[], int, int, int) - 类 java.lang.String 的构造方法
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。
String(byte[], int) - 类 java.lang.String 的构造方法
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。
String(byte[], int, int, String) - 类 java.lang.String 的构造方法
通过使用指定的字符集解码指定的 byte 子数组，构造一个新的 String。
String(byte[], int, int, Charset) - 类 java.lang.String 的构造方法
通过使用指定的 charset 解码指定的 byte 子数组，构造一个新的 String。
String(byte[], String) - 类 java.lang.String 的构造方法
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。
String(byte[], Charset) - 类 java.lang.String 的构造方法
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。
String(byte[], int, int) - 类 java.lang.String 的构造方法
通过使用平台的默认字符集解码指定的 byte 子数组，构造一个新的 String。
String(byte[]) - 类 java.lang.String 的构造方法
通过使用平台的默认字符集解码指定的 byte 数组，构造一个新的 String。
String(StringBuffer) - 类 java.lang.String 的构造方法
分配一个新的字符串，它包含字符串缓冲区参数中当前包含的字符序列。
String(StringBuilder) - 类 java.lang.String 的构造方法
分配一个新的字符串，它包含字符串生成器参数中当前包含的字符序列。
STRING - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.String 的值。
STRING - 类 javax.xml.xpath.XPathConstants 中的静态变量
XPath 1.0 字符串数据类型。
STRING_TO_COMPARE_VALUE_DIFFERED - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性与“要比较的字符串”值不同的通知类型。
STRING_TO_COMPARE_VALUE_MATCHED - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性与“要比较的字符串”值匹配的通知类型。
string_to_object(String) - 类 org.omg.CORBA.ORB 中的方法
将方法 object_to_string 生成的字符串转换回 CORBA 对象引用。
StringBuffer - java.lang 中的 类
线程安全的可变字符序列。
StringBuffer() - 类 java.lang.StringBuffer 的构造方法
构造一个其中不带字符的字符串缓冲区，初始容量为 16 个字符。
StringBuffer(int) - 类 java.lang.StringBuffer 的构造方法
构造一个不带字符，但具有指定初始容量的字符串缓冲区。
StringBuffer(String) - 类 java.lang.StringBuffer 的构造方法
构造一个字符串缓冲区，并将其内容初始化为指定的字符串内容。
StringBuffer(CharSequence) - 类 java.lang.StringBuffer 的构造方法
public java.lang.StringBuilder(CharSequence seq) 构造一个字符串缓冲区，它包含与指定的 CharSequence 相同的字符。
StringBufferInputStream - java.io 中的 类
已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。
StringBufferInputStream(String) - 类 java.io.StringBufferInputStream 的构造方法
已过时。 创建一个字符串输入流，以从指定字符串读取数据。
StringBuilder - java.lang 中的 类
一个可变的字符序列。
StringBuilder() - 类 java.lang.StringBuilder 的构造方法
构造一个其中不带字符的字符串生成器，初始容量为 16 个字符。
StringBuilder(int) - 类 java.lang.StringBuilder 的构造方法
构造一个其中不带字符的字符串生成器，初始容量由 capacity 参数指定。
StringBuilder(String) - 类 java.lang.StringBuilder 的构造方法
构造一个字符串生成器，并初始化为指定的字符串内容。
StringBuilder(CharSequence) - 类 java.lang.StringBuilder 的构造方法
构造一个字符串生成器，包含与指定的 CharSequence 相同的字符。
StringCharacterIterator - java.text 中的 类
StringCharacterIterator 为 String 实现 CharacterIterater 协议。
StringCharacterIterator(String) - 类 java.text.StringCharacterIterator 的构造方法
构造初始索引为 0 的迭代器。
StringCharacterIterator(String, int) - 类 java.text.StringCharacterIterator 的构造方法
构造具有指定的初始索引的迭代器。
StringCharacterIterator(String, int, int, int) - 类 java.text.StringCharacterIterator 的构造方法
构造对给定字符串的给定范围进行迭代的迭代器（其索引设置为指定位置）。
StringContent - javax.swing.text 中的 类
AbstractDocument.Content 接口的一个实现，这是一个对相对于较小的文档和/或调试很有用的强制实现。
StringContent() - 类 javax.swing.text.StringContent 的构造方法
创建新的 StringContent 对象。
StringContent(int) - 类 javax.swing.text.StringContent 的构造方法
创建具有指定初始大小的新 StringContent。
stringFlavor - 类 java.awt.datatransfer.DataFlavor 中的静态变量
DataFlavor 表示 Java Unicode String 类，其中：
StringHolder - org.omg.CORBA 中的 类
String 的 Holder。
StringHolder() - 类 org.omg.CORBA.StringHolder 的构造方法
构造一个新的 StringHolder 对象，将其 value 字段初始化为 null。
StringHolder(String) - 类 org.omg.CORBA.StringHolder 的构造方法
构造一个新的 StringHolder 对象，并使用给定 String 初始化其 value 字段。
StringIndexOutOfBoundsException - java.lang 中的 异常
此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
StringIndexOutOfBoundsException() - 异常 java.lang.StringIndexOutOfBoundsException 的构造方法
构造不带详细消息的 StringIndexOutOfBoundsException。
StringIndexOutOfBoundsException(String) - 异常 java.lang.StringIndexOutOfBoundsException 的构造方法
构造带指定详细消息的 StringIndexOutOfBoundsException。
StringIndexOutOfBoundsException(int) - 异常 java.lang.StringIndexOutOfBoundsException 的构造方法
构造一个新的 StringIndexOutOfBoundsException 类，该类带有一个指示非法索引的参数。
StringMonitor - javax.management.monitor 中的 类
定义设计用于观察字符串属性值的监视器 MBean。
StringMonitor() - 类 javax.management.monitor.StringMonitor 的构造方法
默认构造方法。
StringMonitorMBean - javax.management.monitor 中的 接口
公开字符串监视器 MBean 的远程管理接口。
StringNameHelper - org.omg.CosNaming.NamingContextExtPackage 中的 类
StringName 是以 String 形式表示的“字符串化的名称”和“名称组件数组”。
StringNameHelper() - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 的构造方法
stringPropertyNames() - 类 java.util.Properties 中的方法
返回此属性列表中的键集，其中该键及其对应值是字符串，如果在主属性列表中未找到同名的键，则还包括默认属性列表中不同的键。
StringReader - java.io 中的 类
其源为一个字符串的字符流。
StringReader(String) - 类 java.io.StringReader 的构造方法
创建一个新字符串 reader。
StringRefAddr - javax.naming 中的 类
此类表示通信终端地址的字符串形式。
StringRefAddr(String, String) - 类 javax.naming.StringRefAddr 的构造方法
使用地址类型和内容构造一个新的 StringRefAddr 实例。
StringSelection - java.awt.datatransfer 中的 类
实现传输 String 所需能力的 Transferable。
StringSelection(String) - 类 java.awt.datatransfer.StringSelection 的构造方法
创建能传输指定 String 的 Transferable。
StringSeqHelper - org.omg.CORBA 中的 类
String 数组
StringSeqHelper() - 类 org.omg.CORBA.StringSeqHelper 的构造方法
StringSeqHolder - org.omg.CORBA 中的 类
String 数组
StringSeqHolder() - 类 org.omg.CORBA.StringSeqHolder 的构造方法
StringSeqHolder(String[]) - 类 org.omg.CORBA.StringSeqHolder 的构造方法
stringToColor(String) - 类 javax.swing.text.html.StyleSheet 中的方法
将颜色字符串（如 "RED" 或 "#NNNNNN"）转换为 Color。
StringTokenizer - java.util 中的 类
string tokenizer 类允许应用程序将字符串分解为标记。
StringTokenizer(String, String, boolean) - 类 java.util.StringTokenizer 的构造方法
为指定字符串构造一个 string tokenizer。
StringTokenizer(String, String) - 类 java.util.StringTokenizer 的构造方法
为指定字符串构造一个 string tokenizer。
StringTokenizer(String) - 类 java.util.StringTokenizer 的构造方法
为指定字符串构造一个 string tokenizer。
stringToValue(String) - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
分析 text，返回任意 Object。
stringToValue(String) - 类 javax.swing.text.DefaultFormatter 中的方法
通过使用带 String 参数的构造方法将传入的 String 转换为 getValueClass 的一个实例。
stringToValue(String) - 类 javax.swing.text.InternationalFormatter 中的方法
返回 String text 的 Object 表示形式。
stringToValue(String) - 类 javax.swing.text.MaskFormatter 中的方法
解析文本，返回 String value 的适当 Object 表示形式。
StringValueExp - javax.management 中的 类
表示作为关系约束变量的字符串。
StringValueExp() - 类 javax.management.StringValueExp 的构造方法
基本构造方法。
StringValueExp(String) - 类 javax.management.StringValueExp 的构造方法
创建表示给定字符串的新 StringValueExp。
StringValueHelper - org.omg.CORBA 中的 类
StringValue 的 Helper。
StringValueHelper() - 类 org.omg.CORBA.StringValueHelper 的构造方法
stringWidth(String) - 类 java.awt.FontMetrics 中的方法
返回此 Font 中指定 String 的总 advance width。
StringWriter - java.io 中的 类
一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。
StringWriter() - 类 java.io.StringWriter 的构造方法
使用默认初始字符串缓冲区大小创建一个新字符串 writer。
StringWriter(int) - 类 java.io.StringWriter 的构造方法
使用指定初始字符串缓冲区大小创建一个新字符串 writer。
STRIP - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "strip"，某些属性的可能值。
stripTrailingZeros() - 类 java.math.BigDecimal 中的方法
返回数值上等于此小数，但从该表示形式移除所有尾部零的 BigDecimal。
STROKE - 类 java.awt.font.ShapeGraphicAttribute 中的静态变量
指示该形状应使用 1 像素宽的笔画进行勾画的键。
Stroke - java.awt 中的 接口
Stroke 接口允许 Graphics2D 对象获得一个 Shape，该 Shape 是指定 Shape 的装饰轮廓，或该轮廓的风格表示形式。
STRONG - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Struct - java.sql 中的 接口
用于 SQL 结构化类型的 Java 编程语言中的标准映射关系。
STRUCT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 STRUCT 的 Java 编程语言中的常量（有时称为类型代码）。
StructMember - org.omg.CORBA 中的 类
描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。
StructMember() - 类 org.omg.CORBA.StructMember 的构造方法
构造一个默认 StructMember 对象。
StructMember(String, TypeCode, IDLType) - 类 org.omg.CORBA.StructMember 的构造方法
构造一个 StructMember 对象，并使用给定值进行初始化。
StructMemberHelper - org.omg.CORBA 中的 类
StructMember 的 Helper。
StructMemberHelper() - 类 org.omg.CORBA.StructMemberHelper 的构造方法
Stub - javax.rmi.CORBA 中的 类
必须从其继承所有 RMI-IIOP stub 的基类。
Stub() - 类 javax.rmi.CORBA.Stub 的构造方法
StubDelegate - javax.rmi.CORBA 中的 接口
支持 Stub 中方法实现的委托。
StubNotFoundException - java.rmi 中的 异常
如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
StubNotFoundException(String) - 异常 java.rmi.StubNotFoundException 的构造方法
构造带指定详细消息的 StubNotFoundException。
StubNotFoundException(String, Exception) - 异常 java.rmi.StubNotFoundException 的构造方法
构造带指定详细消息和嵌入异常的 StubNotFoundException。
style - 类 java.awt.Font 中的变量
Font 的样式，它被传递到构造方法中。
STYLE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
STYLE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Style - javax.swing.text 中的 接口
与文档中某个元素相关的属性集合。
styleChanged(Style) - 类 javax.swing.text.DefaultStyledDocument 中的方法
此文档样式有任何改变时调用。
StyleConstants - javax.swing.text 中的 类
一个已知的 或常见的属性键和方法的集合，可通过应用 AttributeSet 或 MutableAttributeSet 方法以类型安全的方式获取/设置属性。
StyleConstants.CharacterConstants - javax.swing.text 中的 类
这是一个类型安全的已知 属性的枚举，它用于字符样式。
StyleConstants.ColorConstants - javax.swing.text 中的 类
这是一个类型安全的已知 属性的枚举，它用于颜色样式。
StyleConstants.FontConstants - javax.swing.text 中的 类
这是一个类型安全的已知 属性的枚举，它用于字体样式。
StyleConstants.ParagraphConstants - javax.swing.text 中的 类
这是一个类型安全的已知 属性的枚举，它用于段落样式。
StyleContext - javax.swing.text 中的 类
样式池及其关联的资源。
StyleContext() - 类 javax.swing.text.StyleContext 的构造方法
创建新的 StyleContext 对象。
StyleContext.NamedStyle - javax.swing.text 中的 类
通常用于表示字符和段落样式的属性集合。
StyleContext.NamedStyle(String, Style) - 类 javax.swing.text.StyleContext.NamedStyle 的构造方法
创建新的命名样式。
StyleContext.NamedStyle(Style) - 类 javax.swing.text.StyleContext.NamedStyle 的构造方法
创建新的命名样式。
StyleContext.NamedStyle() - 类 javax.swing.text.StyleContext.NamedStyle 的构造方法
利用 null 名称和父级创建新的命名样式。
StyleContext.SmallAttributeSet - javax.swing.text 中的 类
此类可在数组中存储少量的属性。
StyleContext.SmallAttributeSet(Object[]) - 类 javax.swing.text.StyleContext.SmallAttributeSet 的构造方法
StyleContext.SmallAttributeSet(AttributeSet) - 类 javax.swing.text.StyleContext.SmallAttributeSet 的构造方法
StyledDocument - javax.swing.text 中的 接口
用作通用样式化文档的接口。
StyledEditorKit - javax.swing.text 中的 类
这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。
StyledEditorKit() - 类 javax.swing.text.StyledEditorKit 的构造方法
创建供样式化文档使用新的 EditorKit。
StyledEditorKit.AlignmentAction - javax.swing.text 中的 类
设置段落对齐的操作。
StyledEditorKit.AlignmentAction(String, int) - 类 javax.swing.text.StyledEditorKit.AlignmentAction 的构造方法
创建新的 AlignmentAction。
StyledEditorKit.BoldAction - javax.swing.text 中的 类
切换粗体属性的操作。
StyledEditorKit.BoldAction() - 类 javax.swing.text.StyledEditorKit.BoldAction 的构造方法
构造新的 BoldAction。
StyledEditorKit.FontFamilyAction - javax.swing.text 中的 类
在相关的 JEditorPane 中设置字体系列的操作。
StyledEditorKit.FontFamilyAction(String, String) - 类 javax.swing.text.StyledEditorKit.FontFamilyAction 的构造方法
创建新的 FontFamilyAction。
StyledEditorKit.FontSizeAction - javax.swing.text 中的 类
设置关联的 JEditorPane 中字体大小的操作。
StyledEditorKit.FontSizeAction(String, int) - 类 javax.swing.text.StyledEditorKit.FontSizeAction 的构造方法
创建新 FontSizeAction。
StyledEditorKit.ForegroundAction - javax.swing.text 中的 类
设置前景色的操作。
StyledEditorKit.ForegroundAction(String, Color) - 类 javax.swing.text.StyledEditorKit.ForegroundAction 的构造方法
创建新的 ForegroundAction。
StyledEditorKit.ItalicAction - javax.swing.text 中的 类
切换斜体属性的一种操作。
StyledEditorKit.ItalicAction() - 类 javax.swing.text.StyledEditorKit.ItalicAction 的构造方法
构造新的 ItalicAction。
StyledEditorKit.StyledTextAction - javax.swing.text 中的 类
假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
StyledEditorKit.StyledTextAction(String) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 的构造方法
通过字符串操作名称创建新的 StyledTextAction。
StyledEditorKit.UnderlineAction - javax.swing.text 中的 类
切换下划线属性的操作。
StyledEditorKit.UnderlineAction() - 类 javax.swing.text.StyledEditorKit.UnderlineAction 的构造方法
创建新的 UnderlineAction。
StyleSheet - javax.swing.text.html 中的 类
支持定义要呈现的 HTML 视图的可视化特征。
StyleSheet() - 类 javax.swing.text.html.StyleSheet 的构造方法
构造 StyleSheet
StyleSheet.BoxPainter - javax.swing.text.html 中的 类
可以执行某些 CSS 格式化任务的类。
StyleSheet.ListPainter - javax.swing.text.html 中的 类
要执行某些 CSS 列表格式化任务的类。
SUB - 类 javax.swing.text.html.HTML.Tag 中的静态变量
SUBCLASS_IMPLEMENTATION_PERMISSION - 接口 java.io.ObjectStreamConstants 中的静态变量
允许重写 readObject 和 writeObject。
subdivide(CubicCurve2D, CubicCurve2D) - 类 java.awt.geom.CubicCurve2D 中的方法
细分此三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
subdivide(CubicCurve2D, CubicCurve2D, CubicCurve2D) - 类 java.awt.geom.CubicCurve2D 中的静态方法
细分由 src 参数指定的三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
subdivide(double[], int, double[], int, double[], int) - 类 java.awt.geom.CubicCurve2D 中的静态方法
细分由存储在 src 数组 srcoff 到 (srcoff + 7) 索引处的坐标指定的三次曲线，并将得到的两个细分曲线存储到所得数组的相应索引中。
subdivide(QuadCurve2D, QuadCurve2D) - 类 java.awt.geom.QuadCurve2D 中的方法
细分此 QuadCurve2D 并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
subdivide(QuadCurve2D, QuadCurve2D, QuadCurve2D) - 类 java.awt.geom.QuadCurve2D 中的静态方法
细分由 src 参数指定的二次曲线并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
subdivide(double[], int, double[], int, double[], int) - 类 java.awt.geom.QuadCurve2D 中的静态方法
细分由存储在 src 数组 srcoff 到 (srcoff + 5) 索引处的坐标指定的二次曲线，并将得到的两个细分曲线存储到所得数组的相应索引中。
Subject - javax.security.auth 中的 类
Subject 表示某一项（如一个人）的一组相关信息。
Subject() - 类 javax.security.auth.Subject 的构造方法
创建一个带有空的 Principal Set 和空的公开或私有证书 Set 的 Subject 的一个实例。
Subject(boolean, Set<? extends Principal>, Set<?>, Set<?>) - 类 javax.security.auth.Subject 的构造方法
创建带有 Principal 和证书的 Subject 的实例。
SubjectDelegationPermission - javax.management.remote 中的 类
授权标识表示验证标识执行操作所需的权限。
SubjectDelegationPermission(String) - 类 javax.management.remote.SubjectDelegationPermission 的构造方法
创建具有指定名称的新 SubjectDelegationPermission。
SubjectDelegationPermission(String, String) - 类 javax.management.remote.SubjectDelegationPermission 的构造方法
创建带指定名称的新 SubjectDelegationPermission 对象。
SubjectDomainCombiner - javax.security.auth 中的 类
SubjectDomainCombiner 通过与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新 ProtectionDomains。
SubjectDomainCombiner(Subject) - 类 javax.security.auth.SubjectDomainCombiner 的构造方法
将提供的 Subject 与此 SubjectDomainCombiner 关联。
subList(int, int) - 类 java.util.AbstractList 中的方法
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。
subList(int, int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表中 fromIndex（包括）和 toIndex（不包括）之间部分的视图。
subList(int, int) - 接口 java.util.List 中的方法
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。
subList(int, int) - 类 java.util.Vector 中的方法
返回此 List 的部分视图，元素范围为从 fromIndex（包括）到 toIndex（不包括）。
subMap(K, boolean, K, boolean) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
subMap(K, K) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
subMap(K, boolean, K, boolean) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
subMap(K, K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
subMap(K, boolean, K, boolean) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键的范围从 fromKey 到 toKey。
subMap(K, K) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
subMap(K, K) - 接口 java.util.SortedMap 中的方法
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
subMap(K, boolean, K, boolean) - 类 java.util.TreeMap 中的方法
subMap(K, K) - 类 java.util.TreeMap 中的方法
SUBMISSION_INTERRUPTED - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
由于某些不可预见的原因，作业未完成提交。
submit(Runnable) - 类 java.util.concurrent.AbstractExecutorService 中的方法
submit(Runnable, T) - 类 java.util.concurrent.AbstractExecutorService 中的方法
submit(Callable<T>) - 类 java.util.concurrent.AbstractExecutorService 中的方法
submit(Callable<V>) - 接口 java.util.concurrent.CompletionService 中的方法
提交要执行的值返回任务，并返回表示挂起的任务结果的 Future。
submit(Runnable, V) - 接口 java.util.concurrent.CompletionService 中的方法
提交要执行的 Runnable 任务，并返回一个表示任务完成的 Future，可以提取或轮询此任务。
submit(Callable<V>) - 类 java.util.concurrent.ExecutorCompletionService 中的方法
submit(Runnable, V) - 类 java.util.concurrent.ExecutorCompletionService 中的方法
submit(Callable<T>) - 接口 java.util.concurrent.ExecutorService 中的方法
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。
submit(Runnable, T) - 接口 java.util.concurrent.ExecutorService 中的方法
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
submit(Runnable) - 接口 java.util.concurrent.ExecutorService 中的方法
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
submit(Runnable) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
submit(Runnable, T) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
submit(Callable<T>) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
SUBMIT - 类 javax.swing.text.html.FormView 中的静态变量
已过时。 从 1.3 开始，将使用来自 UIManager property FormView.submitButtonText 的值
submitData(String) - 类 javax.swing.text.html.FormView 中的方法
此方法负责提交表单数据。
subsamplingXOffset - 类 javax.imageio.IIOParam 中的变量
在进行二次取样之前，将水平偏移量应用于二次取样网格。
subsamplingYOffset - 类 javax.imageio.IIOParam 中的变量
在进行二次取样之前，将垂直偏移量应用于二次取样网格。
Subscript - 类 javax.swing.text.StyleConstants 中的静态变量
下标属性的名称。
subSequence(int, int) - 接口 java.lang.CharSequence 中的方法
返回一个新的 CharSequence，它是此序列的子序列。
subSequence(int, int) - 类 java.lang.String 中的方法
返回一个新的字符序列，它是此序列的一个子序列。
subSequence(int, int) - 类 java.lang.StringBuffer 中的方法
subSequence(int, int) - 类 java.nio.CharBuffer 中的方法
创建表示此缓冲区的指定序列、相对于当前位置的新字符缓冲区。
subSequence(int, int) - 类 javax.swing.text.Segment 中的方法
返回一个新的 CharSequence，它是此序列的子序列。
subSet(E, boolean, E, boolean) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
subSet(E, E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
subSet(E, boolean, E, boolean) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素范围从 fromElement 到 toElement。
subSet(E, E) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
subSet(E, E) - 接口 java.util.SortedSet 中的方法
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
subSet(E, boolean, E, boolean) - 类 java.util.TreeSet 中的方法
subSet(E, E) - 类 java.util.TreeSet 中的方法
substituteColorModel(ColorModel, ColorModel) - 类 java.awt.image.RGBImageFilter 中的方法
注册两个用于替换的 ColorModel 对象。
SUBSTITUTION_PERMISSION - 接口 java.io.ObjectStreamConstants 中的静态变量
允许在序列化/反序列化期间使用一个对象取代另一个对象。
substring(int) - 类 java.lang.String 中的方法
返回一个新的字符串，它是此字符串的一个子字符串。
substring(int, int) - 类 java.lang.String 中的方法
返回一个新字符串，它是此字符串的一个子字符串。
substring(int) - 类 java.lang.StringBuffer 中的方法
substring(int, int) - 类 java.lang.StringBuffer 中的方法
substringData(int, int) - 接口 org.w3c.dom.CharacterData 中的方法
从该节点提取某个范围的数据。
subtract(Area) - 类 java.awt.geom.Area 中的方法
从此 Area 的形状中减去指定 Area 的形状。
subtract(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this - subtrahend)，其标度为 max(this.scale(), subtrahend.scale())。
subtract(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (this - subtrahend) 的 BigDecimal（根据上下文设置进行舍入）。
subtract(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this - val) 的 BigInteger。
SUBTRACT - 类 javax.xml.crypto.dsig.spec.XPathType.Filter 中的静态变量
减少过滤操作。
subtract(Duration) - 类 javax.xml.datatype.Duration 中的方法
计算值为 this-rhs 的新持续时间。
SUBTREE_SCOPE - 类 javax.naming.directory.SearchControls 中的静态变量
搜索以命名对象为根的整个子树。
SUBTREE_SCOPE - 接口 javax.naming.event.EventContext 中的静态变量
该常量用来表示对涉及目标指定对象的子树中对象的事件感兴趣，包括目标指定的对象。
SUBWINDOW_OF - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个对象的子窗口。
SUBWINDOW_OF_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个或多个对象之间的 SUBWINDOW_OF 关系已更改。
SUCCESS_NO_INFO - 接口 java.sql.Statement 中的静态变量
该常量指示批量语句执行成功但不存在受影响的可用行数计数。
SUCCESSFUL - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/SUCCESSFUL.java。
SUFFICIENT - 类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 中的静态变量
足够的 LoginModule。
suffixes - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
从 getFileSuffixes 返回的字符串数组，该数组最初为 null。
sum(Spring, Spring) - 类 javax.swing.Spring 中的静态方法
返回 s1+s2：一个连续表示 s1 和 s2 的 spring。
SUNDAY - 类 java.util.Calendar 中的静态变量
指示 Sunday 的 Calendar.DAY_OF_WEEK 字段值。
SUP - 类 javax.swing.text.html.HTML.Tag 中的静态变量
superLayout(Container) - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager 中的方法
SUPERSCRIPT - 类 java.awt.font.TextAttribute 中的静态变量
用于上标和下标的属性键。
Superscript - 类 javax.swing.text.StyleConstants 中的静态变量
上标属性的名称。
SUPERSCRIPT_SUB - 类 java.awt.font.TextAttribute 中的静态变量
标准下标。
SUPERSCRIPT_SUPER - 类 java.awt.font.TextAttribute 中的静态变量
标准上标。
SUPERSCRIPTS_AND_SUBSCRIPTS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Superscripts and Subscripts”Unicode 字符块的常量。
SUPPLEMENTAL_ARROWS_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Supplemental Arrows-A”Unicode 字符块的常量。
SUPPLEMENTAL_ARROWS_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Supplemental Arrows-B”Unicode 字符块的常量。
SUPPLEMENTAL_MATHEMATICAL_OPERATORS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Supplemental Mathematical Operators”Unicode 字符块的常量。
SUPPLEMENTARY_PRIVATE_USE_AREA_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Supplementary Private Use Area-A”Unicode 字符块的常量。
SUPPLEMENTARY_PRIVATE_USE_AREA_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Supplementary Private Use Area-B”Unicode 字符块的常量。
SUPPORT_DTD - 类 javax.xml.stream.XMLInputFactory 中的静态变量
要求解析器支持 DTD 的属性。
SUPPORTED - 类 javax.print.attribute.standard.ColorSupported 中的静态变量
该打印机能够进行某些类型的彩色打印，例如高亮颜色或全处理颜色。
SupportedAnnotationTypes - javax.annotation.processing 中的 注释类型
用来指示注释处理器支持哪些注释类型的注释。
SupportedOptions - javax.annotation.processing 中的 注释类型
用来指示注释处理器支持哪些选项的注释。
SupportedSourceVersion - javax.annotation.processing 中的 注释类型
用来指示注释处理器所支持的最新源版本的注释。
SupportedValuesAttribute - javax.print.attribute 中的 接口
接口 SupportedValuesAttribute 是打印属性类实现的标记接口，以指示该属性描述用于其他属性的支持值。
supportsAlterTableWithAddColumn() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持带有 add 列的 ALTER TABLE。
supportsAlterTableWithDropColumn() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持带有 drop 列的 ALTER TABLE。
supportsANSI92EntryLevelSQL() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 ANSI92 入门级 SQL 语法。
supportsANSI92FullSQL() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持受支持的 ANSI92 完全 SQL 语法。
supportsANSI92IntermediateSQL() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持受支持的 ANSI92 中间 SQL 语法。
supportsBatchUpdates() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持批量更新。
supportsCatalogsInDataManipulation() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别名称是否可以在数据操作语句中使用。
supportsCatalogsInIndexDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别名称是否可以在获取定义语句中使用。
supportsCatalogsInPrivilegeDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别名称是否可以在特权定义语句中使用。
supportsCatalogsInProcedureCalls() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别名称是否可以在过程调用语句中使用。
supportsCatalogsInTableDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别名称是否可以在表定义语句中使用。
supportsColumnAliasing() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持为列提供别名。
supportsConvert() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持用于 JDBC 类型之间转换的 JDBC 标量函数 CONVERT。
supportsConvert(int, int) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持用于 JDBC fromType 和 toType 类型之间转换的 JDBC 标量函数 CONVERT。
supportsCoreSQLGrammar() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 ODBC Core SQL 语法。
supportsCorrelatedSubqueries() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持相关子查询。
supportsCrossJoin() - 接口 javax.sql.rowset.JoinRowSet 中的方法
指示 JoinRowSet 实现是否支持 CROSS_JOIN。
supportsCustomEditor() - 接口 java.beans.PropertyEditor 中的方法
确定此属性编辑器是否支持自定义编辑器。
supportsCustomEditor() - 类 java.beans.PropertyEditorSupport 中的方法
确定 propertyEditor 是否可以提供自定义编辑器。
supportsDataDefinitionAndDataManipulationTransactions() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否同时支持事务中的数据定义和数据操作语句。
supportsDataManipulationTransactionsOnly() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否仅支持事务中的数据操作语句。
supportsDifferentTableCorrelationNames() - 接口 java.sql.DatabaseMetaData 中的方法
获取在表关联名称受支持时，是否要限制它们与表的名称不同。
supportsExpressionsInOrderBy() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 ORDER BY 列表中的表达式。
supportsExtendedSQLGrammar() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 ODBC Extended SQL 语法。
supportsFullJoin() - 接口 javax.sql.rowset.JoinRowSet 中的方法
指示 JoinRowSet 实现是否支持 FULL_JOIN。
supportsFullOuterJoins() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持完全嵌套的外连接。
supportsGetGeneratedKeys() - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以在执行语句后获取自动生成的键。
supportsGroupBy() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持某种形式的 GROUP BY 子句。
supportsGroupByBeyondSelect() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持使用不包含在 SELECT 语句中而包含在 GROUP BY 子句中的列，假设 SELECT 语句中的所有列都包含在 GROUP BY 子句中。
supportsGroupByUnrelated() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持使用不在 SELECT 语句中而在 GROUP BY 子句中的列。
supportsInnerJoin() - 接口 javax.sql.rowset.JoinRowSet 中的方法
指示 JoinRowSet 实现是否支持 INNER_JOIN。
supportsIntegrityEnhancementFacility() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 SQL Integrity Enhancement Facility。
supportsLeftOuterJoin() - 接口 javax.sql.rowset.JoinRowSet 中的方法
指示 JoinRowSet 实现是否支持 LEFT_OUTER_JOIN。
supportsLikeEscapeClause() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持指定 LIKE 转义子句。
supportsLimitedOuterJoins() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否为外连接提供受限制的支持。
supportsMinimumSQLGrammar() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 ODBC Minimum SQL 语法。
supportsMixedCaseIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。
supportsMixedCaseQuotedIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。
supportsMulticast() - 类 java.net.NetworkInterface 中的方法
返回网络接口是否支持多址广播。
supportsMultipleOpenResults() - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以同时拥有从 CallableStatement 对象中返回的多个 ResultSet 对象。
supportsMultipleResultSets() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持一次调用 execute 方法获得多个 ResultSet 对象。
supportsMultipleTransactions() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否允许一次打开多个事务（在不同的 connection 上）。
supportsNamedParameters() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持可调用语句的指定参数。
supportsNonNullableColumns() - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以将此数据库中的列定义为非 null。
supportsOpenCursorsAcrossCommit() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持在进行提交期间保持游标开放。
supportsOpenCursorsAcrossRollback() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持在回滚期间保持游标开放。
supportsOpenStatementsAcrossCommit() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持在进行提交期间保持语句开放。
supportsOpenStatementsAcrossRollback() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持在回滚期间保持语句开放。
supportsOrderByUnrelated() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持使用不在 SELECT 语句中而在 ORDER BY 子句中的列。
supportsOuterJoins() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持某种形式的外连接。
supportsParameter(Object) - 类 java.security.Provider.Service 中的方法
测试此 Service 是否能使用指定的参数。
supportsPositionedDelete() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持位置的 DELETE 语句。
supportsPositionedUpdate() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持位置的 UPDATE 语句。
supportsResultSetConcurrency(int, int) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持与给定结果集类型结合在一起的给定并发性类型。
supportsResultSetHoldability(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持给定结果集可保存性。
supportsResultSetType(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持给定结果集类型。
supportsRightOuterJoin() - 接口 javax.sql.rowset.JoinRowSet 中的方法
指示 JoinRowSet 实现是否支持 RIGHT_OUTER_JOIN。
supportsSavepoints() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持保存点 (savepoint)。
supportsSchemasInDataManipulation() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个模式名称是否可以数据操作语句中使用。
supportsSchemasInIndexDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个模式名称是否可以在获取定义语句中使用。
supportsSchemasInPrivilegeDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个模式名称是否可以在特权定义语句中使用。
supportsSchemasInProcedureCalls() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个模式名称是否可以在过程调用语句中使用。
supportsSchemasInTableDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个模式名称是否可以在表定义语句中使用。
supportsSelectForUpdate() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持位置的 SELECT FOR UPDATE 语句。
supportsStandardImageMetadataFormat - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
指示此插件是否支持图像元数据的标准元数据格式的 boolean 值，该值最初为 false。
supportsStandardStreamMetadataFormat - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
指示此插件是否支持流元数据的标准元数据格式的 boolean 值，该值最初为 false。
supportsStatementPooling() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持语句合并 (statement pooling)。
supportsStoredFunctionsUsingCallSyntax() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持使用存储过程转义语法调用用户定义的函数或供应商函数。
supportsStoredProcedures() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持使用存储过程转义语法的存储过程调用。
supportsSubqueriesInComparisons() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持比较表达式中的子查询。
supportsSubqueriesInExists() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 EXISTS 表达式中的子查询。
supportsSubqueriesInIns() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 IN 表达式中的子查询。
supportsSubqueriesInQuantifieds() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持量化表达式 (quantified expression) 中的子查询。
supportsTableCorrelationNames() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持表关联名称。
supportsTransactionIsolationLevel(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持给定事务隔离级别。
supportsTransactions() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持事务。
supportsUnion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 SQL UNION。
supportsUnionAll() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 SQL UNION ALL。
supportsUpdatableView() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回此 SyncProvider 实现是否可以执行 RowSet 对象和数据源（RowSet 从中获取其数据）中的 SQL VIEW 之间的同步。
supportsUrgentData() - 类 java.net.SocketImpl 中的方法
返回此 SocketImpl 是否支持发送紧急数据。
SuppressWarnings - java.lang 中的 注释类型
指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。
SURROGATE - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Cs”。
SURROGATES_AREA - 类 java.lang.Character.UnicodeBlock 中的静态变量
已过时。 从 J2SE 5 开始，使用 Character.UnicodeBlock.HIGH_SURROGATES、Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES 和 Character.UnicodeBlock.LOW_SURROGATES。这些新常量符合 Unicode 标准的块定义。Character.UnicodeBlock.of(char) 和 Character.UnicodeBlock.of(int) 方法返回新常量，而不是 SURROGATES_AREA。
suspend() - 类 java.lang.Thread 中的方法
已过时。 该方法已经遭到反对，因为它具有固有的死锁倾向。如果目标线程挂起时在保护关键系统资源的监视器上保持有锁，则在目标线程重新开始以前任何线程都不能访问该资源。如果重新开始目标线程的线程想在调用 resume 之前锁定该监视器，则会发生死锁。这类死锁通常会证明自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
suspend() - 类 java.lang.ThreadGroup 中的方法
已过时。 此方法容易导致死锁。有关详细信息，请参阅 Thread.suspend()。
sval - 类 java.io.StreamTokenizer 中的变量
如果当前标记是一个文字标记，则此字段包含一个给出该文字标记的字符的字符串。
SW_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口左下角大小的光标类型。
SW_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.SW_RESIZE_CURSOR 取代。
swap(List<?>, int, int) - 类 java.util.Collections 中的静态方法
在指定列表的指定位置处交换元素。
SWAP_COLORS - 类 java.awt.font.TextAttribute 中的静态变量
交换前景和背景 Paint 的属性键。
SWAP_COLORS_ON - 类 java.awt.font.TextAttribute 中的静态变量
交换前景和背景。
SWING_COMPONENT - 类 javax.accessibility.AccessibleRole 中的静态变量
一个 Swing 组件，但关于它的其他信息都是未知的。
SwingConstants - javax.swing 中的 接口
通常用于在屏幕上定位或定向组件的常量的集合。
SwingPropertyChangeSupport - javax.swing.event 中的 类
java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。
SwingPropertyChangeSupport(Object) - 类 javax.swing.event.SwingPropertyChangeSupport 的构造方法
构造一个 SwingPropertyChangeSupport 对象。
SwingPropertyChangeSupport(Object, boolean) - 类 javax.swing.event.SwingPropertyChangeSupport 的构造方法
构造一个 SwingPropertyChangeSupport 对象。
SwingUtilities - javax.swing 中的 类
Swing 实用方法的集合。
SwingWorker<T,V> - javax.swing 中的 类
在专用线程中执行长时间 GUI 交互任务的抽象类。
SwingWorker() - 类 javax.swing.SwingWorker 的构造方法
构造此 SwingWorker。
SwingWorker.StateValue - javax.swing 中的 枚举
state 绑定 (bound) 属性的值。
sync() - 类 java.awt.Toolkit 中的方法
同步此工具包的图形状态。
sync() - 类 java.io.FileDescriptor 中的方法
强制所有系统缓冲区与基础设备同步。
sync() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.sync() 中的规范实现 sync 方法。
sync() - 类 java.util.prefs.Preferences 中的方法
确保在调用 sync 之前从此首选项节点及其子节点进行的后续读取能反映出提交到持久存储（从任何 VM）的所有更改。
sync_scope() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
定义在控制信息返回到客户端前请求应前进的距离。
SYNC_WITH_TRANSPORT - org.omg.Messaging 中的 接口
org/omg/Messaging/SYNC_WITH_TRANSPORT.java。
syncAllWidths - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的变量
SyncFactory - javax.sql.rowset.spi 中的 类
该服务提供者接口 (SPI) 机制可以生成由非连接 RowSet 对象使用的 SyncProvider 实例。
SyncFactoryException - javax.sql.rowset.spi 中的 异常
指示 SyncFactory 机制发生的错误。
SyncFactoryException() - 异常 javax.sql.rowset.spi.SyncFactoryException 的构造方法
创建不带详细消息的新 SyncFactoryException。
SyncFactoryException(String) - 异常 javax.sql.rowset.spi.SyncFactoryException 的构造方法
构造带指定详细消息的 SyncFactoryException。
SyncFailedException - java.io 中的 异常
当 sync 操作失败时，抛出此异常。
SyncFailedException(String) - 异常 java.io.SyncFailedException 的构造方法
构造一个带详细消息的 SyncFailedException。
synchronize(Line[], boolean) - 接口 javax.sound.sampled.Mixer 中的方法
同步两个或多个行。
SYNCHRONIZED - 类 java.lang.reflect.Modifier 中的静态变量
表示 synchronized 修饰符的 int 值。
synchronizedCollection(Collection<T>) - 类 java.util.Collections 中的静态方法
返回指定 collection 支持的同步（线程安全的）collection。
synchronizedList(List<T>) - 类 java.util.Collections 中的静态方法
返回指定列表支持的同步（线程安全的）列表。
synchronizedMap(Map<K, V>) - 类 java.util.Collections 中的静态方法
返回由指定映射支持的同步（线程安全的）映射。
synchronizedSet(Set<T>) - 类 java.util.Collections 中的静态方法
返回指定 set 支持的同步（线程安全的）set。
synchronizedSortedMap(SortedMap<K, V>) - 类 java.util.Collections 中的静态方法
返回指定有序映射支持的同步（线程安全的）有序映射。
synchronizedSortedSet(SortedSet<T>) - 类 java.util.Collections 中的静态方法
返回指定有序 set 支持的同步（线程安全的）有序 set。
synchronizedView(AttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建给定属性集的同步视图。
synchronizedView(DocAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定文档属性集的同步视图。
synchronizedView(PrintRequestAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印请求属性集的同步视图。
synchronizedView(PrintJobAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印作业属性集的同步视图。
synchronizedView(PrintServiceAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印服务属性集的同步视图。
SynchronousQueue<E> - java.util.concurrent 中的 类
一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。
SynchronousQueue() - 类 java.util.concurrent.SynchronousQueue 的构造方法
创建一个具有非公平访问策略的 SynchronousQueue。
SynchronousQueue(boolean) - 类 java.util.concurrent.SynchronousQueue 的构造方法
创建一个具有指定公平策略的 SynchronousQueue。
SyncProvider - javax.sql.rowset.spi 中的 类
为非连接 RowSet 对象提供 reader/writer 功能的同步机制。
SyncProvider() - 类 javax.sql.rowset.spi.SyncProvider 的构造方法
创建默认的 SyncProvider 对象。
SyncProviderException - javax.sql.rowset.spi 中的 异常
指示 SyncProvider 机制发生的错误。
SyncProviderException() - 异常 javax.sql.rowset.spi.SyncProviderException 的构造方法
创建不带任何详细消息的新 SyncProviderException 对象。
SyncProviderException(String) - 异常 javax.sql.rowset.spi.SyncProviderException 的构造方法
构造带指定详细消息的 SyncProviderException 对象。
SyncProviderException(SyncResolver) - 异常 javax.sql.rowset.spi.SyncProviderException 的构造方法
构造带指定 SyncResolver 实例的 SyncProviderException 对象。
SyncResolver - javax.sql.rowset.spi 中的 接口
定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。
SyncScopeHelper - org.omg.Messaging 中的 类
Synchronization 作用域
SyncScopeHelper() - 类 org.omg.Messaging.SyncScopeHelper 的构造方法
syncScrollPaneWithViewport() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
syncSpi() - 类 java.util.prefs.AbstractPreferences 中的方法
此方法是在此节点被锁定的情况下调用的。
syncWithScrollPane(JScrollPane) - 类 javax.swing.ScrollPaneLayout 中的方法
在 ScrollPaneLayout 被设置为 JScrollPane 的 LayoutManager 后，此方法被调用。
SYNTAX_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果指定无效或非法字符串。
SynthConstants - javax.swing.plaf.synth 中的 接口
由 Synth 使用的常量。
SynthContext - javax.swing.plaf.synth 中的 类
一个不可变的瞬态对象，它包含有关 Region 的上下文信息。
SynthContext(JComponent, Region, SynthStyle, int) - 类 javax.swing.plaf.synth.SynthContext 的构造方法
创建一个具有指定值的 SynthContext。
synthesizedElement(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
如果元素是合成元素，则返回 true。
Synthesizer - javax.sound.midi 中的 接口
Synthesizer 生成声音。
SynthGraphicsUtils - javax.swing.plaf.synth 中的 类
用于基本图形调用的包装器。
SynthGraphicsUtils() - 类 javax.swing.plaf.synth.SynthGraphicsUtils 的构造方法
创建一个 SynthGraphicsUtils。
SynthLookAndFeel - javax.swing.plaf.synth 中的 类
SynthLookAndFeel 提供创建定制外观的基础。
SynthLookAndFeel() - 类 javax.swing.plaf.synth.SynthLookAndFeel 的构造方法
创建一个 SynthLookAndFeel。
SynthPainter - javax.swing.plaf.synth 中的 类
SynthPainter 用于绘制 JComponent 的某些部分。
SynthPainter() - 类 javax.swing.plaf.synth.SynthPainter 的构造方法
SynthStyle - javax.swing.plaf.synth 中的 类
SynthStyle 是一个样式属性集。
SynthStyle() - 类 javax.swing.plaf.synth.SynthStyle 的构造方法
构造一个 SynthStyle。
SynthStyleFactory - javax.swing.plaf.synth 中的 类
用于获得 SynthStyle 的工厂。
SynthStyleFactory() - 类 javax.swing.plaf.synth.SynthStyleFactory 的构造方法
创建一个 SynthStyleFactory。
SYRIAC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Syriac”Unicode 字符块的常量。
SysexMessage - javax.sound.midi 中的 类
表示 MIDI 系统独占消息 SysexMessage 对象。
SysexMessage() - 类 javax.sound.midi.SysexMessage 的构造方法
构造一个新的 SysexMessage。
SysexMessage(byte[]) - 类 javax.sound.midi.SysexMessage 的构造方法
构造一个新的 SysexMessage。
System - java.lang 中的 类
System 类包含一些有用的类字段和方法。
SYSTEM - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
SYSTEM_EXCEPTION - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java。
SYSTEM_EXCLUSIVE - 类 javax.sound.midi.SysexMessage 中的静态变量
用于 SYSTEM_EXCLUSIVE 消息的状态字节（0xF0 或 240）。
SYSTEM_ID - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的静态变量
SYSTEM_PORT - 接口 java.rmi.activation.ActivationSystem 中的静态变量
查找激活系统的端口。
SYSTEM_RESET - 类 javax.sound.midi.ShortMessage 中的静态变量
SYSTEM_RESET 消息的状态字节（0xFF 或 255）。
SystemColor - java.awt 中的 类
封装表示系统中本机 GUI 对象颜色的象征性颜色的类。
SystemException - org.omg.CORBA 中的 异常
所有 CORBA 标准异常的根类。
SystemException(String, int, CompletionStatus) - 异常 org.omg.CORBA.SystemException 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 SystemException 异常。
SystemFlavorMap - java.awt.datatransfer 中的 类
SystemFlavorMap 是 "native" (String)（对应于特定于平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的可配置映射。
systemNodeForPackage(Class<?>) - 类 java.util.prefs.Preferences 中的静态方法
从系统首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
systemRoot() - 类 java.util.prefs.Preferences 中的静态方法
返回系统的根首选项节点。
systemRoot() - 接口 java.util.prefs.PreferencesFactory 中的方法
返回系统根首选项节点。
SystemTray - java.awt 中的 类
SystemTray 类表示桌面的系统托盘。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


T - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

T

TAB - 类 java.awt.Event 中的静态变量
Tab 键。
TabableView - javax.swing.text 中的 接口
大小依赖于制表符的 View 的接口。
tabAreaBackground - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的变量
tabAreaInsets - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
TABBED_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
TabbedPane 的 region。
TABBED_PANE_CONTENT - 类 javax.swing.plaf.synth.Region 中的静态变量
包含内容的 TabbedPane 的 region。
TABBED_PANE_TAB - 类 javax.swing.plaf.synth.Region 中的静态变量
某一选项卡的 TabbedPane 的 region。
TABBED_PANE_TAB_AREA - 类 javax.swing.plaf.synth.Region 中的静态变量
包含选项卡的 TabbedPane 的 region。
TabbedPaneUI - javax.swing.plaf 中的 类
JTabbedPane 的可插入外观界面。
TabbedPaneUI() - 类 javax.swing.plaf.TabbedPaneUI 的构造方法
tabChangeListener - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
TabExpander - javax.swing.text 中的 接口
允许不同类型的制表符扩展实现的简单接口。
tabForCoordinate(JTabbedPane, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回与 JTabbedPane 的坐标空间中的指定点相交的选项卡索引。
tabForCoordinate(JTabbedPane, int, int) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 tabForCoordinate 方法。
tabForCoordinate(JTabbedPane, int, int) - 类 javax.swing.plaf.TabbedPaneUI 中的方法
tabInsets - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
TABLE - 类 javax.accessibility.AccessibleRole 中的静态变量
用于根据行和列来呈现信息的对象。
table - 类 javax.swing.plaf.basic.BasicTableUI 中的变量
TABLE - 类 javax.swing.plaf.synth.Region 中的静态变量
Table 的 region。
table - 类 javax.swing.table.JTableHeader 中的变量
将此对象作为其头的表，默认值为 null。
TABLE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
TABLE_HEADER - 类 javax.swing.plaf.synth.Region 中的静态变量
TableHeader 的 region。
TableCellEditor - javax.swing.table 中的 接口
此接口定义了要成为组件（如 JListBox、JComboBox、JTree 或 JTable）的值编辑器的任意对象需要实现的方法。
TableCellRenderer - javax.swing.table 中的 接口
此接口定义了要成为 JTable 中单元格渲染器的任意对象所需的方法。
tableChanged(TableModelEvent) - 接口 javax.swing.event.TableModelListener 中的方法
此细粒度通知告知侦听器单元格、行或列的哪些具体范围发生了更改。
tableChanged(TableModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表内容的变更
tableChanged(TableModelEvent) - 类 javax.swing.JTable 中的方法
当此表的 TableModel 生成 TableModelEvent 时调用。
TableColumn - javax.swing.table 中的 类
TableColumn 表示 JTable 中列的所有属性，如宽度、大小可调整性、最小和最大宽度。
TableColumn() - 类 javax.swing.table.TableColumn 的构造方法
覆盖方法，它使用的默认模型索引为 0、默认宽度为 75、渲染器为 null、编辑器为 null。
TableColumn(int) - 类 javax.swing.table.TableColumn 的构造方法
覆盖方法，它使用的默认宽度为 75、渲染器为 null、编辑器为 null。
TableColumn(int, int) - 类 javax.swing.table.TableColumn 的构造方法
覆盖方法，它使用的渲染器为 null、编辑器为 null 。
TableColumn(int, int, TableCellRenderer, TableCellEditor) - 类 javax.swing.table.TableColumn 的构造方法
使用指定的模型索引、宽度、单元格渲染器、单元格编辑器创建并初始化 TableColumn 实例；所有 TableColumn 构造方法都委托给此方法。
TableColumnModel - javax.swing.table 中的 接口
定义了适合用于 JTable 的表列模型对象的要求。
TableColumnModelEvent - javax.swing.event 中的 类
TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。
TableColumnModelEvent(TableColumnModel, int, int) - 类 javax.swing.event.TableColumnModelEvent 的构造方法
构造一个 TableColumnModelEvent 对象。
TableColumnModelListener - javax.swing.event 中的 接口
TableColumnModelListener 定义侦听 TableColumnModel 中更改的对象的接口。
tableColumns - 类 javax.swing.table.DefaultTableColumnModel 中的变量
此模型中 TableColumn 对象组成的数组
tableHeader - 类 javax.swing.JTable 中的变量
表所使用的 TableHeader。
TableHeaderUI - javax.swing.plaf 中的 类
JTableHeader 的可插入外观界面。
TableHeaderUI() - 类 javax.swing.plaf.TableHeaderUI 的构造方法
tableIndexClustered - 接口 java.sql.DatabaseMetaData 中的静态变量
指示此表索引是一个集群索引 (clustered index)。
tableIndexHashed - 接口 java.sql.DatabaseMetaData 中的静态变量
指示此表索引是一个散列索引。
tableIndexOther - 接口 java.sql.DatabaseMetaData 中的静态变量
指示此表索引不是集群索引、散列索引或表统计信息，它是其他某种东西。
tableIndexStatistic - 接口 java.sql.DatabaseMetaData 中的静态变量
指示此列包含与表的索引描述一起返回的表统计信息。
TableModel - javax.swing.table 中的 接口
TableModel 接口指定了 JTable 用于询问表格式数据模型的方法。
TableModelEvent - javax.swing.event 中的 类
TableModelEvent 用于通知侦听器某一表模型已发生更改。
TableModelEvent(TableModel) - 类 javax.swing.event.TableModelEvent 的构造方法
如果表中的所有行数据都发生更改，那么侦听器应该丢弃基于这些行的所有状态，并重新查询 TableModel 来获得新的行计数和所有恰当值。
TableModelEvent(TableModel, int) - 类 javax.swing.event.TableModelEvent 的构造方法
此数据行已被更新。
TableModelEvent(TableModel, int, int) - 类 javax.swing.event.TableModelEvent 的构造方法
行 [firstRow, lastRow] 中的数据已被更新。
TableModelEvent(TableModel, int, int, int) - 类 javax.swing.event.TableModelEvent 的构造方法
列 column 的 [firstRow, lastRow] 范围内的单元格已被更新。
TableModelEvent(TableModel, int, int, int, int) - 类 javax.swing.event.TableModelEvent 的构造方法
从 (firstRow, column) 到 (lastRow, column) 的单元格已被更改。
TableModelListener - javax.swing.event 中的 接口
TableModelListener 定义侦听 TableModel 中更改的对象的接口。
tableRowsDeleted(TableModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表内容的变更（行删除）
tableRowsInserted(TableModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表内容的变更（行插入）
TableRowSorter<M extends TableModel> - javax.swing.table 中的 类
RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。
TableRowSorter() - 类 javax.swing.table.TableRowSorter 的构造方法
使用空模型创建一个 TableRowSorter。
TableRowSorter(M) - 类 javax.swing.table.TableRowSorter 的构造方法
使用 model 作为底层 TableModel 创建一个 TableRowSorter。
TableStringConverter - javax.swing.table 中的 类
TableStringConverter 用于将对象从模型转换为字符串。
TableStringConverter() - 类 javax.swing.table.TableStringConverter 的构造方法
TableUI - javax.swing.plaf 中的 类
JTable 的可插入外观界面。
TableUI() - 类 javax.swing.plaf.TableUI 的构造方法
TableView - javax.swing.text 中的 类
为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
TableView(Element) - 类 javax.swing.text.TableView 的构造方法
针对给定的元素构造一个 TableView。
TableView.TableCell - javax.swing.text 中的 类
已过时。 表单元格如今可以是任何 View 实现。
TableView.TableCell(Element) - 类 javax.swing.text.TableView.TableCell 的构造方法
已过时。 构造给定元素的 TableCell。
TableView.TableRow - javax.swing.text 中的 类
以行为中心的表格中的行视图。
TableView.TableRow(Element) - 类 javax.swing.text.TableView.TableRow 的构造方法
构造给定元素的 TableView。
TABLOID - 类 java.awt.PageAttributes.MediaType 中的静态变量
LEDGER 的别名。
TABLOID - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 tabloid 尺寸，11 inch × 17 inch。
TABLOID - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
tabloid 尺寸。
tabPane - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
tabPlacement - 类 javax.swing.JTabbedPane 中的变量
选项卡的放置位置。
tabRunOverlay - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
tabRuns - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
TabSet - 类 javax.swing.text.StyleConstants 中的静态变量
段落的 TabSet，类型为包含了 TabStop 的 TabSet。
TabSet - javax.swing.text 中的 类
由许多 TabStop 组成的一个 TabSet。
TabSet(TabStop[]) - 类 javax.swing.text.TabSet 的构造方法
创建并且返回 TabSet 的一个实例。
tabSizeAttribute - 类 javax.swing.text.PlainDocument 中的静态变量
指定内容中包含的制表符大小的属性名称。
TabStop - javax.swing.text 中的 类
此类封装单个制表位 (tab stop)（基本上是由 RTF 认定的制表位）。
TabStop(float) - 类 javax.swing.text.TabStop 的构造方法
在给定位置 pos 创建一个具有默认对齐方式和默认前导字符的制表符。
TabStop(float, int, int) - 类 javax.swing.text.TabStop 的构造方法
创建一个具有指定位置 pos、对齐方式 align 和前导字符 leader 的制表符。
TabularData - javax.management.openmbean 中的 接口
TabularData 接口指定特定类型的复杂开放数据 对象的行为，该对象表示了表格数据 结构。
TabularDataSupport - javax.management.openmbean 中的 类
TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。
TabularDataSupport(TabularType) - 类 javax.management.openmbean.TabularDataSupport 的构造方法
创建一个空 TabularDataSupport 实例，其开放类型是 tabularType，并且它的基础 HashMap 具有默认初始容量 (101) 和默认加载因子 (0.75)。
TabularDataSupport(TabularType, int, float) - 类 javax.management.openmbean.TabularDataSupport 的构造方法
创建一个空 TabularDataSupport 实例，其开放类型为 tabularType，它的基础 HashMap 具有指定的初始容量和加载因子。
TabularType - javax.management.openmbean 中的 类
TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。
TabularType(String, String, CompositeType, String[]) - 类 javax.management.openmbean.TabularType 的构造方法
构造一个 TabularType 实例，检查给定参数的有效性。
tag - 类 org.omg.IOP.TaggedComponent 中的变量
以组件 id 形式表示的标记。
tag - 类 org.omg.IOP.TaggedProfile 中的变量
以配置文件 id 形式表示的标记。
TAG_ACNT - 接口 java.awt.font.OpenType 中的静态变量
重音符附件。
TAG_ALTERNATE_IIOP_ADDRESS - org.omg.IOP 中的 接口
org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java。
TAG_AVAR - 接口 java.awt.font.OpenType 中的静态变量
轴变体。
TAG_BASE - 接口 java.awt.font.OpenType 中的静态变量
基线数据。
TAG_BDAT - 接口 java.awt.font.OpenType 中的静态变量
位图数据。
TAG_BLOC - 接口 java.awt.font.OpenType 中的静态变量
位图位置。
TAG_BSLN - 接口 java.awt.font.OpenType 中的静态变量
基线表。
TAG_CFF - 接口 java.awt.font.OpenType 中的静态变量
紧凑字体格式（Type1 字体）。
TAG_CMAP - 接口 java.awt.font.OpenType 中的静态变量
字形映射的字符。
TAG_CODE_SETS - org.omg.IOP 中的 接口
org/omg/IOP/TAG_CODE_SETS.java。
TAG_CVAR - 接口 java.awt.font.OpenType 中的静态变量
CVT 变体。
TAG_CVT - 接口 java.awt.font.OpenType 中的静态变量
控制值表。
TAG_DSIG - 接口 java.awt.font.OpenType 中的静态变量
数字签名。
TAG_EBDT - 接口 java.awt.font.OpenType 中的静态变量
内嵌位图数据。
TAG_EBLC - 接口 java.awt.font.OpenType 中的静态变量
内嵌位图位置。
TAG_EBSC - 接口 java.awt.font.OpenType 中的静态变量
内嵌位图缩放。
TAG_FDSC - 接口 java.awt.font.OpenType 中的静态变量
字体描述符。
TAG_FEAT - 接口 java.awt.font.OpenType 中的静态变量
特性名称。
TAG_FMTX - 接口 java.awt.font.OpenType 中的静态变量
字体规格。
TAG_FPGM - 接口 java.awt.font.OpenType 中的静态变量
字体程序。
TAG_FVAR - 接口 java.awt.font.OpenType 中的静态变量
字体变体。
TAG_GASP - 接口 java.awt.font.OpenType 中的静态变量
网格适应和扫描转换过程。
TAG_GDEF - 接口 java.awt.font.OpenType 中的静态变量
字形定义。
TAG_GLYF - 接口 java.awt.font.OpenType 中的静态变量
字形数据。
TAG_GPOS - 接口 java.awt.font.OpenType 中的静态变量
字形定位。
TAG_GSUB - 接口 java.awt.font.OpenType 中的静态变量
字形替换。
TAG_GVAR - 接口 java.awt.font.OpenType 中的静态变量
字形变体。
TAG_HDMX - 接口 java.awt.font.OpenType 中的静态变量
水平设备规格。
TAG_HEAD - 接口 java.awt.font.OpenType 中的静态变量
字体头部。
TAG_HHEA - 接口 java.awt.font.OpenType 中的静态变量
水平规格头部。
TAG_HMTX - 接口 java.awt.font.OpenType 中的静态变量
水平规格。
TAG_INTERNET_IOP - org.omg.IOP 中的 接口
org/omg/IOP/TAG_INTERNET_IOP.java。
TAG_JAVA_CODEBASE - org.omg.IOP 中的 接口
org/omg/IOP/TAG_JAVA_CODEBASE.java。
TAG_JSTF - 接口 java.awt.font.OpenType 中的静态变量
调整。
TAG_JUST - 接口 java.awt.font.OpenType 中的静态变量
调整。
TAG_KERN - 接口 java.awt.font.OpenType 中的静态变量
字距调整。
TAG_LCAR - 接口 java.awt.font.OpenType 中的静态变量
连字插入符。
TAG_LOCA - 接口 java.awt.font.OpenType 中的静态变量
位置索引。
TAG_LTSH - 接口 java.awt.font.OpenType 中的静态变量
线性阈值。
TAG_MAXP - 接口 java.awt.font.OpenType 中的静态变量
最大轮廓。
TAG_MMFX - 接口 java.awt.font.OpenType 中的静态变量
Multiple Master 字体规格。
TAG_MMSD - 接口 java.awt.font.OpenType 中的静态变量
Multiple master 增补数据。
TAG_MORT - 接口 java.awt.font.OpenType 中的静态变量
字形变化。
TAG_MULTIPLE_COMPONENTS - org.omg.IOP 中的 接口
org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java。
TAG_NAME - 接口 java.awt.font.OpenType 中的静态变量
命名表。
TAG_OPBD - 接口 java.awt.font.OpenType 中的静态变量
视觉边界。
TAG_ORB_TYPE - org.omg.IOP 中的 接口
org/omg/IOP/TAG_ORB_TYPE.java。
TAG_OS2 - 接口 java.awt.font.OpenType 中的静态变量
OS/2 和 Windows 特定规格。
TAG_PCLT - 接口 java.awt.font.OpenType 中的静态变量
PCL 5 数据。
TAG_POLICIES - org.omg.IOP 中的 接口
org/omg/IOP/TAG_POLICIES.java。
TAG_POST - 接口 java.awt.font.OpenType 中的静态变量
PostScript 信息。
TAG_PREP - 接口 java.awt.font.OpenType 中的静态变量
CVT 预编程。
TAG_PROP - 接口 java.awt.font.OpenType 中的静态变量
字形属性。
TAG_RMI_CUSTOM_MAX_STREAM_FORMAT - org.omg.IOP 中的 接口
org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java。
TAG_TRAK - 接口 java.awt.font.OpenType 中的静态变量
跟踪。
TAG_TYP1 - 接口 java.awt.font.OpenType 中的静态变量
Adobe Type 1 字体数据。
TAG_VDMX - 接口 java.awt.font.OpenType 中的静态变量
垂直设备规格。
TAG_VHEA - 接口 java.awt.font.OpenType 中的静态变量
垂直规格头部。
TAG_VMTX - 接口 java.awt.font.OpenType 中的静态变量
垂直规格。
TAGALOG - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tagalog”Unicode 字符块的常量。
TAGBANWA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tagbanwa”Unicode 字符块的常量。
TagElement - javax.swing.text.html.parser 中的 类
一般的 HTML TagElement 类。
TagElement(Element) - 类 javax.swing.text.html.parser.TagElement 的构造方法
TagElement(Element, boolean) - 类 javax.swing.text.html.parser.TagElement 的构造方法
TaggedComponent - org.omg.IOP 中的 类
org/omg/IOP/TaggedComponent.java。
TaggedComponent() - 类 org.omg.IOP.TaggedComponent 的构造方法
TaggedComponent(int, byte[]) - 类 org.omg.IOP.TaggedComponent 的构造方法
TaggedComponentHelper - org.omg.IOP 中的 类
org/omg/IOP/TaggedComponentHelper.java。
TaggedComponentHelper() - 类 org.omg.IOP.TaggedComponentHelper 的构造方法
TaggedComponentHolder - org.omg.IOP 中的 类
org/omg/IOP/TaggedComponentHolder.java。
TaggedComponentHolder() - 类 org.omg.IOP.TaggedComponentHolder 的构造方法
TaggedComponentHolder(TaggedComponent) - 类 org.omg.IOP.TaggedComponentHolder 的构造方法
TaggedProfile - org.omg.IOP 中的 类
org/omg/IOP/TaggedProfile.java。
TaggedProfile() - 类 org.omg.IOP.TaggedProfile 的构造方法
TaggedProfile(int, byte[]) - 类 org.omg.IOP.TaggedProfile 的构造方法
TaggedProfileHelper - org.omg.IOP 中的 类
org/omg/IOP/TaggedProfileHelper.java。
TaggedProfileHelper() - 类 org.omg.IOP.TaggedProfileHelper 的构造方法
TaggedProfileHolder - org.omg.IOP 中的 类
org/omg/IOP/TaggedProfileHolder.java。
TaggedProfileHolder() - 类 org.omg.IOP.TaggedProfileHolder 的构造方法
TaggedProfileHolder(TaggedProfile) - 类 org.omg.IOP.TaggedProfileHolder 的构造方法
TAGS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tags”Unicode 字符块的常量。
TAI_LE - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tai Le”Unicode 字符块的常量。
TAI_XUAN_JING_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tai Xuan Jing Symbols”Unicode 字符块的常量。
tailMap(K, boolean) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
tailMap(K) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
tailMap(K, boolean) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
tailMap(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
tailMap(K, boolean) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。
tailMap(K) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键大于等于 fromKey。
tailMap(K) - 接口 java.util.SortedMap 中的方法
返回此映射的部分视图，其键大于等于 fromKey。
tailMap(K, boolean) - 类 java.util.TreeMap 中的方法
tailMap(K) - 类 java.util.TreeMap 中的方法
tailSet(E, boolean) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
tailSet(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
tailSet(E, boolean) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素大于（或等于，如果 inclusive 为 true）fromElement。
tailSet(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素大于等于 fromElement。
tailSet(E) - 接口 java.util.SortedSet 中的方法
返回此 set 的部分视图，其元素大于等于 fromElement。
tailSet(E, boolean) - 类 java.util.TreeSet 中的方法
tailSet(E) - 类 java.util.TreeSet 中的方法
TAIWAN - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
take() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
take() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），必要时将一直等待可用元素。
take() - 接口 java.util.concurrent.BlockingQueue 中的方法
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。
take() - 接口 java.util.concurrent.CompletionService 中的方法
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则等待。
take() - 类 java.util.concurrent.DelayQueue 中的方法
获取并移除此队列的头部，在可从此队列获得到期延迟的元素之前一直等待（如有必要）。
take() - 类 java.util.concurrent.ExecutorCompletionService 中的方法
take() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
take() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
take() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
take() - 类 java.util.concurrent.SynchronousQueue 中的方法
获取并移除此队列的头，如有必要则等待另一个线程插入它。
takeFirst() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列的第一个元素，必要时将一直等待可用元素。
takeFirst() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
takeLast() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列的最后一个元素，必要时将一直等待可用元素。
takeLast() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
TAMIL - 类 java.awt.font.NumericShaper 中的静态变量
标识 TAMIL 范围和十进制基数。
TAMIL - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tamil”Unicode 字符块的常量。
tan(double) - 类 java.lang.Math 中的静态方法
返回角的三角正切。
tan(double) - 类 java.lang.StrictMath 中的静态方法
返回角的三角正切。
tanh(double) - 类 java.lang.Math 中的静态方法
返回 double 值的双曲线余弦。
tanh(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的双曲线正切。
target - 类 java.awt.Event 中的变量
目标组件。
Target - java.lang.annotation 中的 注释类型
指示注释类型所适用的程序元素的种类。
TARGET - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
target() - 类 org.omg.CORBA.Request 中的方法
检索目标对象引用。
target() - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回客户端调用以执行操作的对象。
target_is_a(String) - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
如果 servant 是给定的存储库 id，则返回 true；若不是则返回 false。
target_most_derived_interface() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回 servant 最终派生接口的存储库 id。
TargetDataLine - javax.sound.sampled 中的 接口
目标数据行是可以从中读取音频数据的某种类型的 DataLine。
TargetedNotification - javax.management.remote 中的 类
一个 (Notification, Listener ID) 对。
TargetedNotification(Notification, Integer) - 类 javax.management.remote.TargetedNotification 的构造方法
构造一个 TargetedNotification 对象。
targetMustExist() - 接口 javax.naming.event.EventContext 中的方法
确定侦听器是否可以注册不存在的感兴趣目标。
TC_ARRAY - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 Array。
TC_BASE - 接口 java.io.ObjectStreamConstants 中的静态变量
第一个标记值。
TC_BLOCKDATA - 接口 java.io.ObjectStreamConstants 中的静态变量
可选数据块。
TC_BLOCKDATALONG - 接口 java.io.ObjectStreamConstants 中的静态变量
long Block 数据。
TC_CLASS - 接口 java.io.ObjectStreamConstants 中的静态变量
Class 的引用。
TC_CLASSDESC - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 Class Descriptor。
TC_ENDBLOCKDATA - 接口 java.io.ObjectStreamConstants 中的静态变量
可选块数据的末尾因对象而阻塞。
TC_ENUM - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 Enum 常量。
TC_EXCEPTION - 接口 java.io.ObjectStreamConstants 中的静态变量
写入过程中的异常。
TC_LONGSTRING - 接口 java.io.ObjectStreamConstants 中的静态变量
Long 字符串。
TC_MAX - 接口 java.io.ObjectStreamConstants 中的静态变量
最后一个标记值。
TC_NULL - 接口 java.io.ObjectStreamConstants 中的静态变量
Null 对象引用。
TC_OBJECT - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 Object。
TC_PROXYCLASSDESC - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 Proxy Class Descriptor。
TC_REFERENCE - 接口 java.io.ObjectStreamConstants 中的静态变量
已写入流的对象的引用。
TC_RESET - 接口 java.io.ObjectStreamConstants 中的静态变量
重置流上下文。
TC_STRING - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 String。
TCKind - org.omg.CORBA 中的 类
IDL enum TCKind 的 Java 映射，TCKind 指定 TypeCode 对象的种类。
TCKind(int) - 类 org.omg.CORBA.TCKind 的构造方法
已过时。 不要使用此构造方法，因为根据 OMG 规范，此方法应该是私有的。使用 TCKind.from_int(int) 代替。
TCP_NODELAY - 接口 java.net.SocketOptions 中的静态变量
对此连接禁用 Nagle 算法。
TD - 类 javax.swing.text.html.HTML.Tag 中的静态变量
TELUGU - 类 java.awt.font.NumericShaper 中的静态变量
标识 TELUGU 范围和十进制基数。
TELUGU - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Telugu”Unicode 字符块的常量。
Templates - javax.xml.transform 中的 接口
实现此接口的对象是处理后的转换指令的运行时表示形式。
TemplatesHandler - javax.xml.transform.sax 中的 接口
可用于将 SAX 解析事件（解析转换指令）处理为 Templates 对象的 SAX ContentHandler。
TEN - 类 java.math.BigDecimal 中的静态变量
值为 10，标度为 0。
TEN - 类 java.math.BigInteger 中的静态变量
BigInteger 的常量 10。
terminated() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
当 Executor 已经终止时调用的方法。
TERTIARY - 类 java.text.Collator 中的静态变量
Collator 的 strength 值。
tertiaryOrder(int) - 类 java.text.CollationElementIterator 中的静态方法
返回 collation 元素的第三顺序。
testBit(int) - 类 java.math.BigInteger 中的方法
当且仅当设置了指定的位时，返回 true。
TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.text 系统颜色的数组索引。
text - 类 java.awt.SystemColor 中的静态变量
为文本控制对象（比如文本字段和组合框）提供的背景色。
TEXT - 类 javax.accessibility.AccessibleRole 中的静态变量
将文本呈现给用户的对象。
text - 类 javax.accessibility.AccessibleTextSequence 中的变量
文本
text(Element) - 类 javax.swing.text.AbstractWriter 中的方法
写出文本。
TEXT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
text(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出文本。
text(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出文本。
Text - javax.xml.soap 中的 接口
值为文本的节点的表示形式。
Text - org.w3c.dom 中的 接口
该 Text 接口继承自 CharacterData，并且表示 Element 或 Attr 的文本内容（在 XML 中称为字符数据）。
TEXT_ALIGN - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
TEXT_AREA - 类 javax.swing.plaf.synth.Region 中的静态变量
TextArea 的 region。
TEXT_BACKGROUND - 类 javax.swing.plaf.synth.ColorType 中的静态变量
某一 region 背景的 ColorType。
TEXT_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的文本中的更改。
TEXT_CURSOR - 类 java.awt.Cursor 中的静态变量
文字光标类型。
TEXT_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.TEXT_CURSOR 取代。
TEXT_DECORATION - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
TEXT_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择文本事件的事件掩码。
TEXT_FIELD - 类 javax.swing.plaf.synth.Region 中的静态变量
TextField 的 region。
TEXT_FIRST - 类 java.awt.event.TextEvent 中的静态变量
用于文本事件的 id 范围的起始编号。
TEXT_FOREGROUND - 类 javax.swing.plaf.synth.ColorType 中的静态变量
某一 region 前景的 ColorType。
TEXT_HIGHLIGHT - 类 java.awt.SystemColor 中的静态变量
SystemColor.textHighlight 系统颜色的数组索引。
TEXT_HIGHLIGHT_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.textHighlightText 系统颜色的数组索引。
TEXT_HTML - 类 javax.print.DocFlavor.CHAR_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。
TEXT_HTML - 类 javax.print.DocFlavor.READER 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。
TEXT_HTML - 类 javax.print.DocFlavor.STRING 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。
TEXT_HTML_HOST - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
TEXT_HTML_HOST - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
TEXT_HTML_HOST - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
TEXT_HTML_US_ASCII - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_HTML_US_ASCII - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_HTML_US_ASCII - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16 - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_HTML_UTF_16 - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16 - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16BE - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_HTML_UTF_16BE - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16BE - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16LE - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_HTML_UTF_16LE - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16LE - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_8 - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_HTML_UTF_8 - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_8 - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_INACTIVE_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.textInactiveText 系统颜色的数组索引。
TEXT_INDENT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
TEXT_INSET_H - 类 javax.swing.border.TitledBorder 中的静态变量
TEXT_LAST - 类 java.awt.event.TextEvent 中的静态变量
用于文本事件的 id 范围的结束编号。
TEXT_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Text 节点。
TEXT_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
TextPane 的 region。
TEXT_PLAIN - 类 javax.print.DocFlavor.CHAR_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。
TEXT_PLAIN - 类 javax.print.DocFlavor.READER 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。
TEXT_PLAIN - 类 javax.print.DocFlavor.STRING 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。
TEXT_PLAIN_HOST - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
TEXT_PLAIN_HOST - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
TEXT_PLAIN_HOST - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
TEXT_PLAIN_US_ASCII - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_PLAIN_US_ASCII - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_PLAIN_US_ASCII - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16 - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_PLAIN_UTF_16 - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16 - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = java.net.URL""（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16BE - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_PLAIN_UTF_16BE - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16BE - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16LE - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_PLAIN_UTF_16LE - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16LE - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_8 - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_PLAIN_UTF_8 - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_8 - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_SPACING - 类 javax.swing.border.TitledBorder 中的静态变量
TEXT_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.textText 系统颜色的数组索引。
TEXT_TRANSFORM - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
TEXT_VALUE_CHANGED - 类 java.awt.event.TextEvent 中的静态变量
此事件 id 指示对象的文本已改变。
TextAction - javax.swing.text 中的 类
用于跨多个不同文本组件共享的键绑定的 Action 实现。
TextAction(String) - 类 javax.swing.text.TextAction 的构造方法
创建一个新的 JTextAction 对象。
TextArea - java.awt 中的 类
TextArea 对象是显示文本的多行区域。
TextArea() - 类 java.awt.TextArea 的构造方法
构造一个将空字符串作为文本的新文本区。
TextArea(String) - 类 java.awt.TextArea 的构造方法
构造具有指定文本的新文本区。
TextArea(int, int) - 类 java.awt.TextArea 的构造方法
构造一个新文本区，该文本区具有指定的行数和列数，并将空字符串作为文本。
TextArea(String, int, int) - 类 java.awt.TextArea 的构造方法
构造一个新文本区，该文本区具有指定的文本，以及指定的行数和列数。
TextArea(String, int, int, int) - 类 java.awt.TextArea 的构造方法
构造一个新文本区，该文本区具有指定的文本，以及指定的行数、列数和滚动条可见性。
TEXTAREA - 类 javax.swing.text.html.HTML.Tag 中的静态变量
TextArea.AccessibleAWTTextArea - java.awt 中的 类
此类实现 TextArea 类的可访问性支持。
TextArea.AccessibleAWTTextArea() - 类 java.awt.TextArea.AccessibleAWTTextArea 的构造方法
textAreaContent(char[]) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
将给定的内容添加到 textarea 文档。
textAreaContent(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出 TEXTAREA 表单元素中所包含的文本。
TextAttribute - java.awt.font 中的 类
TextAttribute 类定义用于呈现文本的属性键和属性值。
TextAttribute(String) - 类 java.awt.font.TextAttribute 的构造方法
构造一个具有指定名称的 TextAttribute。
TextComponent - java.awt 中的 类
TextComponent 类是所有允许编辑文本的组件的超类。
TextComponent.AccessibleAWTTextComponent - java.awt 中的 类
此类实现对 TextComponent 类的可访问性支持。
TextComponent.AccessibleAWTTextComponent() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 的构造方法
构造 AccessibleAWTTextComponent。
TextEvent - java.awt.event 中的 类
指示对象文本已改变的语义事件。
TextEvent(Object, int) - 类 java.awt.event.TextEvent 的构造方法
构造一个 TextEvent 对象。
TextField - java.awt 中的 类
TextField 对象是允许编辑单行文本的文本组件。
TextField() - 类 java.awt.TextField 的构造方法
构造新文本字段。
TextField(String) - 类 java.awt.TextField 的构造方法
构造使用指定文本初始化的新文本字段。
TextField(int) - 类 java.awt.TextField 的构造方法
构造具有指定列数的新空文本字段。
TextField(String, int) - 类 java.awt.TextField 的构造方法
构造使用要显示的指定文本初始化的新文本字段，宽度足够容纳指定列数。
TextField.AccessibleAWTTextField - java.awt 中的 类
此类实现 TextField 类的可访问性支持。
TextField.AccessibleAWTTextField() - 类 java.awt.TextField.AccessibleAWTTextField 的构造方法
textHighlight - 类 java.awt.SystemColor 中的静态变量
为选则项（比如菜单、组合框和文本）提供的背景色。
textHighlightText - 类 java.awt.SystemColor 中的静态变量
为选则项（比如菜单、组合框和文本）的文本提供的颜色。
TextHitInfo - java.awt.font 中的 类
TextHitInfo 类表示文本模型中的字符位置以及字符的斜线或“边”。
textIconGap - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
textInactiveText - 类 java.awt.SystemColor 中的静态变量
为非活动项（比如菜单中的项）的文本提供的颜色。
TextInputCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。
TextInputCallback(String) - 类 javax.security.auth.callback.TextInputCallback 的构造方法
构造一个带提示的 TextInputCallback。
TextInputCallback(String, String) - 类 javax.security.auth.callback.TextInputCallback 的构造方法
构造一个带提示和默认输入值的 TextInputCallback。
TextLayout - java.awt.font 中的 类
TextLayout 是样式字符数据的不可变图形表示形式。
TextLayout(String, Font, FontRenderContext) - 类 java.awt.font.TextLayout 的构造方法
根据 String 和 Font 构造一个 TextLayout。
TextLayout(String, Map<? extends AttributedCharacterIterator.Attribute, ?>, FontRenderContext) - 类 java.awt.font.TextLayout 的构造方法
根据 String 和属性集构造一个 TextLayout。
TextLayout(AttributedCharacterIterator, FontRenderContext) - 类 java.awt.font.TextLayout 的构造方法
根据样式文本上的迭代器构造一个 TextLayout。
TextLayout.CaretPolicy - java.awt.font 中的 类
定义确定强插入符位置的策略。
TextLayout.CaretPolicy() - 类 java.awt.font.TextLayout.CaretPolicy 的构造方法
构造一个 CaretPolicy。
TextListener - java.awt.event 中的 接口
用于接收文本事件的侦听器接口。
textListener - 类 java.awt.TextComponent 中的变量
TextMeasurer - java.awt.font 中的 类
TextMeasurer 类提供换行所需的基本操作：测量到给定的 advance，确定字符范围的 advance，并为字符范围生成一个 TextLayout。
TextMeasurer(AttributedCharacterIterator, FontRenderContext) - 类 java.awt.font.TextMeasurer 的构造方法
从源文本构造 TextMeasurer。
textNonSelectionColor - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
用于非选定节点的前景颜色。
TextOutputCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 TextOutputCallback 并将其传递给 CallbackHandler 的 handle 方法，以显示信息消息、警告消息和错误消息。
TextOutputCallback(int, String) - 类 javax.security.auth.callback.TextOutputCallback 的构造方法
构造一个带消息类型和将要显示的消息的 TextOutputCallback。
textSelectionColor - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
用于选定节点的前景颜色。
TextSyntax - javax.print.attribute 中的 类
类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。
TextSyntax(String, Locale) - 类 javax.print.attribute.TextSyntax 的构造方法
使用指定的字符串和语言环境构造 TextAttribute。
textText - 类 java.awt.SystemColor 中的静态变量
为文本控制对象（比如文本字段和组合框）的文本提供的颜色。
TextUI - javax.swing.plaf 中的 类
文本编辑器用户界面
TextUI() - 类 javax.swing.plaf.TextUI 的构造方法
TexturePaint - java.awt 中的 类
TexturePaint 类提供一种用被指定为 BufferedImage 的纹理填充 Shape 的方式。
TexturePaint(BufferedImage, Rectangle2D) - 类 java.awt.TexturePaint 的构造方法
构造 TexturePaint 对象。
textValueChanged(TextEvent) - 类 java.awt.AWTEventMulticaster 中的方法
textValueChanged(TextEvent) - 接口 java.awt.event.TextListener 中的方法
文本的值已改变时调用。
textValueChanged(TextEvent) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
文本值更改的 TextListener 通知。
TH - 类 javax.swing.text.html.HTML.Tag 中的静态变量
THAANA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Thaana”Unicode 字符块的常量。
THAI - 类 java.awt.font.NumericShaper 中的静态变量
标识 THAI 范围和十进制基数。
THAI - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Thai”Unicode 字符块的常量。
the_activator() - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识与 POA 关联的适配器激活器。
the_activator(AdapterActivator) - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识与 POA 关联的适配器激活器。
the_children() - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识 POA 的所有子 POA 的当前设置。
the_name() - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识相对于其父 POA 的 POA。
the_parent() - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识 POA 的父 POA。
the_POAManager() - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识与 POA 关联的 POA 管理器。
thickness - 类 javax.swing.border.LineBorder 中的变量
this_object(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
此方法允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
thisObject() - 接口 javax.rmi.CORBA.Tie 中的方法
返回此 tie 表示的目标对象的对象引用。
Thread - java.lang 中的 类
线程 是程序中的执行线程。
Thread() - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(Runnable) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(ThreadGroup, Runnable) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(String) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(ThreadGroup, String) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(Runnable, String) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(ThreadGroup, Runnable, String) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，并作为 group 所引用的线程组的一员。
Thread(ThreadGroup, Runnable, String, long) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，作为 group 所引用的线程组的一员，并具有指定的堆栈大小。
Thread.State - java.lang 中的 枚举
线程状态。
Thread.UncaughtExceptionHandler - java.lang 中的 接口
当 Thread 因未捕获的异常而突然终止时，调用处理程序的接口。
THREAD_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
ThreadMXBean 的 ObjectName 的字符串表示形式。
THREAD_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/THREAD_POLICY_ID.java。
ThreadDeath - java.lang 中的 错误
调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。
ThreadDeath() - 错误 java.lang.ThreadDeath 的构造方法
ThreadFactory - java.util.concurrent 中的 接口
根据需要创建新线程的对象。
ThreadGroup - java.lang 中的 类
线程组表示一个线程的集合。
ThreadGroup(String) - 类 java.lang.ThreadGroup 的构造方法
构造一个新线程组。
ThreadGroup(ThreadGroup, String) - 类 java.lang.ThreadGroup 的构造方法
创建一个新线程组。
ThreadInfo - java.lang.management 中的 类
线程信息。
ThreadLocal<T> - java.lang 中的 类
该类提供了线程局部 (thread-local) 变量。
ThreadLocal() - 类 java.lang.ThreadLocal 的构造方法
创建一个线程本地变量。
ThreadMXBean - java.lang.management 中的 接口
Java 虚拟机线程系统的管理接口。
ThreadPolicy - org.omg.PortableServer 中的 接口
ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。
ThreadPolicyOperations - org.omg.PortableServer 中的 接口
ThreadPolicy 指定与已创建的 POA 一起使用的线程模型 (threading model)。
ThreadPolicyValue - org.omg.PortableServer 中的 类
ThreadPolicyValue 可以具有以下值。
ThreadPolicyValue(int) - 类 org.omg.PortableServer.ThreadPolicyValue 的构造方法
ThreadPoolExecutor - java.util.concurrent 中的 类
一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>) - 类 java.util.concurrent.ThreadPoolExecutor 的构造方法
用给定的初始参数和默认的线程工厂及被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, ThreadFactory) - 类 java.util.concurrent.ThreadPoolExecutor 的构造方法
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, RejectedExecutionHandler) - 类 java.util.concurrent.ThreadPoolExecutor 的构造方法
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, ThreadFactory, RejectedExecutionHandler) - 类 java.util.concurrent.ThreadPoolExecutor 的构造方法
用给定的初始参数创建新的 ThreadPoolExecutor。
ThreadPoolExecutor.AbortPolicy - java.util.concurrent 中的 类
用于被拒绝任务的处理程序，它将抛出 RejectedExecutionException.
ThreadPoolExecutor.AbortPolicy() - 类 java.util.concurrent.ThreadPoolExecutor.AbortPolicy 的构造方法
创建一个 AbortPolicy。
ThreadPoolExecutor.CallerRunsPolicy - java.util.concurrent 中的 类
用于被拒绝任务的处理程序，它直接在 execute 方法的调用线程中运行被拒绝的任务；如果执行程序已关闭，则会丢弃该任务。
ThreadPoolExecutor.CallerRunsPolicy() - 类 java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy 的构造方法
创建一个 CallerRunsPolicy。
ThreadPoolExecutor.DiscardOldestPolicy - java.util.concurrent 中的 类
用于被拒绝任务的处理程序，它放弃最旧的未处理请求，然后重试 execute；如果执行程序已关闭，则会丢弃该任务。
ThreadPoolExecutor.DiscardOldestPolicy() - 类 java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy 的构造方法
为给定执行程序创建 DiscardOldestPolicy。
ThreadPoolExecutor.DiscardPolicy - java.util.concurrent 中的 类
用于被拒绝任务的处理程序，默认情况下它将丢弃被拒绝的任务。
ThreadPoolExecutor.DiscardPolicy() - 类 java.util.concurrent.ThreadPoolExecutor.DiscardPolicy 的构造方法
创建一个 DiscardPolicy。
THRESHOLD_ERROR - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示阈值类型、偏移量或模不正确的通知类型。
THRESHOLD_HIGH_VALUE_EXCEEDED - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性已超出高阈值的通知类型。
THRESHOLD_LOW_VALUE_EXCEEDED - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性已超出低阈值的通知类型。
THRESHOLD_VALUE_EXCEEDED - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性已达到阈值的通知类型。
Throwable - java.lang 中的 类
Throwable 类是 Java 语言中所有错误或异常的超类。
Throwable() - 类 java.lang.Throwable 的构造方法
构造一个将 null 作为其详细消息的新 throwable。
Throwable(String) - 类 java.lang.Throwable 的构造方法
构造带指定详细消息的新 throwable。
Throwable(String, Throwable) - 类 java.lang.Throwable 的构造方法
构造一个带指定详细消息和 cause 的新 throwable。
Throwable(Throwable) - 类 java.lang.Throwable 的构造方法
构造一个带指定 cause 和 (cause==null ? null :cause.toString())（它通常包含类和 cause 的详细消息）的详细消息的新 throwable。
throwException() - 类 java.nio.charset.CoderResult 中的方法
抛出相应于此对象描述的结果的异常。
throwing(String, String, Throwable) - 类 java.util.logging.Logger 中的方法
正抛出异常的记录。
thumbColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
thumbColor - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
thumbDarkShadowColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
thumbHighlightColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
thumbLightShadowColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
thumbnailComplete(ImageReader) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告缩略图读操作已经完成。
thumbnailComplete(ImageWriter) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告缩略图写操作已经完成。
thumbnailPassComplete(ImageReader, BufferedImage) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告当前缩略图读操作已经完成一个逐步传递。
thumbnailPassStarted(ImageReader, BufferedImage, int, int, int, int, int, int, int, int[]) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告当前的缩略图读操作将开始逐步传递。
thumbnailProgress(ImageReader, float) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告在关联的 ImageReader 中完成当前 getThumbnail 调用的近似程度。
thumbnailProgress(ImageWriter, float) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告在关联的 ImageWriter 中完成当前缩略图写操作的近似程度。
thumbnails - 类 javax.imageio.IIOImage 中的变量
BufferedImage 缩略图的 List，或为 null。
thumbnailStarted(ImageReader, int, int) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告缩略图读操作将要开始。
thumbnailStarted(ImageWriter, int, int) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告缩略图写操作将要开始。
thumbnailUpdate(ImageReader, BufferedImage, int, int, int, int, int, int, int[]) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告已更新缩略图图像的给定区域。
thumbRect - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
thumbRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
THURSDAY - 类 java.util.Calendar 中的静态变量
指示 Thursday 的 Calendar.DAY_OF_WEEK 字段值。
TIBETAN - 类 java.awt.font.NumericShaper 中的静态变量
标识 TIBETAN 范围和十进制基数。
TIBETAN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tibetan”Unicode 字符块的常量。
TICK_BUFFER - 类 javax.swing.plaf.metal.MetalSliderUI 中的变量
tickLength - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
tickRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
ticks() - 类 javax.sound.midi.Track 中的方法
获得音轨的长度，用 MIDI 刻度表示。
Tie - javax.rmi.CORBA 中的 接口
定义所有 RMI-IIOP 服务器端 tie 必须实现的方法。
tileGridXOffset - 类 javax.imageio.ImageWriteParam 中的变量
如果已经设置 tiling，则返回 tile 网格原点应该从图像原点水平偏移的量。
tileGridYOffset - 类 javax.imageio.ImageWriteParam 中的变量
如果已经设置 tiling，则返回 tile 网格原点应该从图像原点垂直偏移的量。
tileHeight - 类 javax.imageio.ImageWriteParam 中的变量
如果已经设置 tiling，则返回每个 tile 的高度，否则返回 0。
tileIcon - 类 javax.swing.border.MatteBorder 中的变量
TileObserver - java.awt.image 中的 接口
希望在出现以下情况时被通知的对象的接口：某个 writer 通过调用 getWritableTile 使 WritableRenderedImage 的 tile 变得可修改；通过最后调用 releaseWritableTile 使这些 tile 变得不可修改。
tileUpdate(WritableRenderedImage, int, int, boolean) - 接口 java.awt.image.TileObserver 中的方法
即将被更新的 tile（此 tile 或者即将被获取以写入，或者正在从写入释放）。
tileWidth - 类 javax.imageio.ImageWriteParam 中的变量
如果已经设置 tiling，则返回每个 tile 的宽度，否则返回 0。
tilingMode - 类 javax.imageio.ImageWriteParam 中的变量
控制 tiling 设置的模式，必须将它设置为以下四个 MODE_* 值之一。
tilingSet - 类 javax.imageio.ImageWriteParam 中的变量
如果已经指定 tiling 参数，则返回一个为 true 的 boolean 值。
Time - java.sql 中的 类
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
Time(int, int, int) - 类 java.sql.Time 的构造方法
已过时。 使用采用毫秒值的构造方法取代此构造方法
Time(long) - 类 java.sql.Time 的构造方法
使用毫秒时间值构造 Time 对象。
TIME - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 TIME 的 Java 编程语言中的常量（有时称为类型代码）。
time - 类 java.util.Calendar 中的变量
日历的当前设置时间，以毫秒为单位，表示自格林威治标准时间 1970 年 1月 1 日 0:00:00 后经过的时间。
TIME - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 time 的完全限定名称。
TIME_ZONE - 类 java.text.DateFormat.Field 中的静态变量
标识 TIME_ZONE 字段的常量。
TIMED_OUT - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
服务器能够连接到输出设备（或始终处于连接状态），但却无法获得输出设备的响应。
timedJoin(Thread, long) - 枚举 java.util.concurrent.TimeUnit 中的方法
使用此时间单元执行计时的 Thread.join。
timedWait(Object, long) - 枚举 java.util.concurrent.TimeUnit 中的方法
使用此时间单元执行计时的 Object.wait。
TimeLimitExceededException - javax.naming 中的 异常
当某一方法没有在指定的时间限制内终止时，抛出此异常。
TimeLimitExceededException() - 异常 javax.naming.TimeLimitExceededException 的构造方法
构造一个新的 TimeLimitExceededException 实例。
TimeLimitExceededException(String) - 异常 javax.naming.TimeLimitExceededException 的构造方法
使用所提供的参数构造一个新的 TimeLimitExceededException 实例。
TIMEOUT - org.omg.CORBA 中的 异常
当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
TIMEOUT() - 异常 org.omg.CORBA.TIMEOUT 的构造方法
构造一个 TIMEOUT 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。
TIMEOUT(String) - 异常 org.omg.CORBA.TIMEOUT 的构造方法
使用指定消息构造一个 TIMEOUT 异常。
TIMEOUT(int, CompletionStatus) - 异常 org.omg.CORBA.TIMEOUT 的构造方法
使用指定次要代码和完成状态构造一个 TIMEOUT 异常。
TIMEOUT(String, int, CompletionStatus) - 异常 org.omg.CORBA.TIMEOUT 的构造方法
使用指定消息、次要代码和完成状态构造一个 TIMEOUT 异常。
TimeoutException - java.util.concurrent 中的 异常
阻塞操作超时时，抛出该异常。
TimeoutException() - 异常 java.util.concurrent.TimeoutException 的构造方法
构造不带详细消息的 TimeoutException。
TimeoutException(String) - 异常 java.util.concurrent.TimeoutException 的构造方法
构造带指定详细消息的 TimeoutException。
Timer - java.util 中的 类
一种工具，线程用其安排以后在后台线程中执行的任务。
Timer() - 类 java.util.Timer 的构造方法
创建一个新计时器。
Timer(boolean) - 类 java.util.Timer 的构造方法
创建一个新计时器，可以指定其相关的线程作为守护程序运行。
Timer(String) - 类 java.util.Timer 的构造方法
创建一个新计时器，其相关的线程具有指定的名称。
Timer(String, boolean) - 类 java.util.Timer 的构造方法
创建一个新计时器，其相关的线程具有指定的名称，并且可以指定作为守护程序运行。
Timer - javax.management.timer 中的 类
提供对计时器 MBean 的实现。
Timer() - 类 javax.management.timer.Timer 的构造方法
默认的构造方法。
timer - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的变量
在滚动窗格中调整滚动条时使用的 Timer。
Timer - javax.swing 中的 类
在指定时间间隔触发一个或多个 ActionEvent。
Timer(int, ActionListener) - 类 javax.swing.Timer 的构造方法
创建一个 Timer 并将初始延迟和事件间延迟初始化为 delay 毫秒。
timer - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
在启动编辑会话之前使用。
TimerMBean - javax.management.timer 中的 接口
公开计时器 MBean 的管理接口。
TimerNotification - javax.management.timer 中的 类
此类定义了由计时器 MBean 发送的通知。
TimerNotification(String, Object, long, long, String, Integer) - 类 javax.management.timer.TimerNotification 的构造方法
创建计时器通知对象。
TimerTask - java.util 中的 类
由 Timer 安排为一次执行或重复执行的任务。
TimerTask() - 类 java.util.TimerTask 的构造方法
创建一个新的计时器任务。
TIMES - 类 javax.management.Query 中的静态变量
表示 Query.times(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
times(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个二进制表达式，表示两个数值的乘积。
Timestamp - java.security 中的 类
此类封装有关签署时间戳的信息。
Timestamp(Date, CertPath) - 类 java.security.Timestamp 的构造方法
构造一个时间戳。
Timestamp - java.sql 中的 类
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。
Timestamp(int, int, int, int, int, int, int) - 类 java.sql.Timestamp 的构造方法
已过时。 使用构造方法 Timestamp(long millis) 来代替
Timestamp(long) - 类 java.sql.Timestamp 的构造方法
使用毫秒时间值构造 Timestamp 对象。
TIMESTAMP - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 TIMESTAMP 的 Java 编程语言中的常量（有时称为类型代码）。
timestamp() - 类 java.util.UUID 中的方法
与此 UUID 相关联的时间戳值。
TimeUnit - java.util.concurrent 中的 枚举
TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。
TimeZone - java.util 中的 类
TimeZone 表示时区偏移量，也可以计算夏令时。
TimeZone() - 类 java.util.TimeZone 的构造方法
单独的构造方法。
TIMEZONE_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 TIMEZONE 字段的有用常量。
TimeZoneNameProvider - java.util.spi 中的 类
为 TimeZone 类提供本地化时区名称的服务提供者的抽象类。
TimeZoneNameProvider() - 类 java.util.spi.TimeZoneNameProvider 的构造方法
唯一的构造方法。
TIMING_CLOCK - 类 javax.sound.midi.ShortMessage 中的静态变量
TIMING_CLOCK 消息的状态字节（0xF8 或 248）。
TINYINT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 TINYINT 的 Java 编程语言中的常量（有时称为类型代码）。
title - 类 javax.swing.border.TitledBorder 中的变量
title - 类 javax.swing.JInternalFrame 中的变量
此内部窗体标题栏中所显示的标题。
TITLE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
TITLE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
title - 类 javax.swing.text.html.parser.DTD 中的变量
TITLE_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
TITLECASE_LETTER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Lt”。
titleColor - 类 javax.swing.border.TitledBorder 中的变量
TitledBorder - javax.swing.border 中的 类
该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。
TitledBorder(String) - 类 javax.swing.border.TitledBorder 的构造方法
创建 TitledBorder 实例。
TitledBorder(Border) - 类 javax.swing.border.TitledBorder 的构造方法
创建具有指定边框和空标题的 TitledBorder 实例。
TitledBorder(Border, String) - 类 javax.swing.border.TitledBorder 的构造方法
创建具有指定边框和标题的 TitledBorder 实例。
TitledBorder(Border, String, int, int) - 类 javax.swing.border.TitledBorder 的构造方法
用指定的边框、标题、标题对齐方式和标题位置创建 TitledBorder 实例。
TitledBorder(Border, String, int, int, Font) - 类 javax.swing.border.TitledBorder 的构造方法
用指定的边框、标题、标题对齐方式、标题位置和标题字体创建 TitledBorder 实例。
TitledBorder(Border, String, int, int, Font, Color) - 类 javax.swing.border.TitledBorder 的构造方法
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。
titleFont - 类 javax.swing.border.TitledBorder 中的变量
titleJustification - 类 javax.swing.border.TitledBorder 中的变量
titlePane - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
titlePosition - 类 javax.swing.border.TitledBorder 中的变量
TitleProperty - 接口 javax.swing.text.Document 中的静态变量
文档标题的属性名（如果有）。
tk_abstract_interface - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_abstract_interface 初始化其 value 字段。
tk_alias - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_alias 初始化其 value 字段。
tk_any - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_any 初始化其 value 字段。
tk_array - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_array 初始化其 value 字段。
tk_boolean - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_boolean 初始化其 value 字段。
tk_char - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_char 初始化其 value 字段。
tk_double - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_double 初始化其 value 字段。
tk_enum - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_enum 初始化其 value 字段。
tk_except - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_except 初始化其 value 字段。
tk_fixed - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_fixed 初始化其 value 字段。
tk_float - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_float 初始化其 value 字段。
tk_long - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_long 初始化其 value 字段。
tk_longdouble - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_longdouble 初始化其 value 字段。
tk_longlong - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_longlong 初始化其 value 字段。
tk_native - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_native 初始化其 value 字段。
tk_null - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_null 初始化其 value 字段。
tk_objref - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_objref 初始化其 value 字段。
tk_octet - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_octet 初始化其 value 字段。
tk_Principal - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_Principal 初始化其 value 字段。
tk_sequence - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_sequence 初始化其 value 字段。
tk_short - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_short 初始化其 value 字段。
tk_string - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_string 初始化其 value 字段。
tk_struct - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_struct 初始化其 value 字段。
tk_TypeCode - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_TypeCode 初始化其 value 字段。
tk_ulong - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_ulong 初始化其 value 字段。
tk_ulonglong - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_ulonglong 初始化其 value 字段。
tk_union - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_union 初始化其 value 字段。
tk_ushort - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_ushort 初始化其 value 字段。
tk_value - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_value 初始化其 value 字段。
tk_value_box - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_value_box 初始化其 value 字段。
tk_void - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_void 初始化其 value 字段。
tk_wchar - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_wchar 初始化其 value 字段。
tk_wstring - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_wstring 初始化其 value 字段。
TMENDRSCAN - 接口 javax.transaction.xa.XAResource 中的静态变量
终止恢复扫描。
TMFAIL - 接口 javax.transaction.xa.XAResource 中的静态变量
取消关联调用者，并将事务分支标记为只回滚。
TMJOIN - 接口 javax.transaction.xa.XAResource 中的静态变量
调用者正连接现有事务分支。
TMNOFLAGS - 接口 javax.transaction.xa.XAResource 中的静态变量
使用 TMNOFLAGS 指示不选择任何标志值。
TMONEPHASE - 接口 javax.transaction.xa.XAResource 中的静态变量
调用者正在使用一阶段优化。
TMRESUME - 接口 javax.transaction.xa.XAResource 中的静态变量
调用者正在恢复与挂起的事务分支的关联。
TMSTARTRSCAN - 接口 javax.transaction.xa.XAResource 中的静态变量
启动恢复扫描。
TMSUCCESS - 接口 javax.transaction.xa.XAResource 中的静态变量
取消调用者与事务分支的关联。
TMSUSPEND - 接口 javax.transaction.xa.XAResource 中的静态变量
调用者正挂起（不是终止）其与事务分支的关联。
to_any() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 将 DynAny 对象转换成 Any 对象。
to_any() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从 DynAny 对象中创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从 DynAny 对象创建 any 值。
to_name(String) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作将“字符串化的名称”转换为等效的“名称组件”数组。
to_name(String) - 接口 org.omg.CosNaming.NamingContextExtOperations 中的方法
此操作将“字符串化的名称”转换为等效的“名称组件”数组。
to_string(NameComponent[]) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作从 Name 组件数组创建字符串化的名称。
to_string(NameComponent[]) - 接口 org.omg.CosNaming.NamingContextExtOperations 中的方法
此操作根据 Name 组件数组创建字符串化的名称。
to_url(String, String) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
to_url(String, String) - 接口 org.omg.CosNaming.NamingContextExtOperations 中的方法
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
toArray() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回组成拖动动作的事件 Object 数组。
toArray(Object[]) - 类 java.awt.dnd.DragGestureEvent 中的方法
返回组成拖动动作的事件数组。
toArray() - 类 java.beans.beancontext.BeanContextMembershipEvent 中的方法
获得受此事件影响的子级的数组。
toArray() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。
toArray(Object[]) - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得包含与数组中所包含类型匹配的此 BeanContext 的所有子级的数组。
toArray() - 类 java.util.AbstractCollection 中的方法
返回包含此 collection 中所有元素的数组。
toArray(T[]) - 类 java.util.AbstractCollection 中的方法
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。
toArray() - 类 java.util.ArrayDeque 中的方法
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）。
toArray(T[]) - 类 java.util.ArrayDeque 中的方法
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.ArrayList 中的方法
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组。
toArray(T[]) - 类 java.util.ArrayList 中的方法
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 接口 java.util.Collection 中的方法
返回包含此 collection 中所有元素的数组。
toArray(T[]) - 接口 java.util.Collection 中的方法
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。
toArray() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
返回一个按适当顺序包含此队列中所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
返回一个按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
返回以恰当顺序包含此队列所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
返回以恰当顺序包含此队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回一个按恰当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回以恰当顺序（从第一个元素到最后一个元素）包含列表所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
返回一个包含此 set 所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
返回一个包含此 set 所有元素的数组；返回数组的运行时类型是指定数组的类型。
toArray() - 类 java.util.concurrent.DelayQueue 中的方法
返回包含此队列所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.DelayQueue 中的方法
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。
toArray() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回以恰当顺序（从第一个元素到最后一个元素）包含此双端队列所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回以恰当顺序包含此双端队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
返回按适当顺序包含此队列中所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
返回按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
返回包含此队列所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。
toArray() - 类 java.util.concurrent.SynchronousQueue 中的方法
返回一个 0 长度的数组。
toArray(T[]) - 类 java.util.concurrent.SynchronousQueue 中的方法
将指定数组的第 0 个元素设置为 null（如果该数组有非 0 的长度）并返回它。
toArray() - 类 java.util.LinkedList 中的方法
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。
toArray(T[]) - 类 java.util.LinkedList 中的方法
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组；返回数组的运行时类型为指定数组的类型。
toArray() - 接口 java.util.List 中的方法
返回按适当顺序包含列表中的所有元素的数组（从第一个元素到最后一个元素）。
toArray(T[]) - 接口 java.util.List 中的方法
返回按适当顺序（从第一个元素到最后一个元素）包含列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.PriorityQueue 中的方法
返回一个包含此队列所有元素的数组。
toArray(T[]) - 类 java.util.PriorityQueue 中的方法
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。
toArray() - 接口 java.util.Set 中的方法
返回一个包含 set 中所有元素的数组。
toArray(T[]) - 接口 java.util.Set 中的方法
返回一个包含此 set 中所有元素的数组；返回数组的运行时类型是指定数组的类型。
toArray() - 类 java.util.Vector 中的方法
返回一个数组，包含此向量中以恰当顺序存放的所有元素。
toArray(T[]) - 类 java.util.Vector 中的方法
返回一个数组，包含此向量中以恰当顺序存放的所有元素；返回数组的运行时类型为指定数组的类型。
toArray() - 类 javax.accessibility.AccessibleRelationSet 中的方法
返回作为 AccessibleRelation 数组的当前关系集
toArray() - 类 javax.accessibility.AccessibleStateSet 中的方法
以 AccessibleState 数组形式返回当前状态集
toArray() - 接口 javax.print.attribute.AttributeSet 中的方法
返回此集合中包含的属性的数组。
toArray() - 类 javax.print.attribute.HashAttributeSet 中的方法
toArray() - 类 javax.swing.DefaultListModel 中的方法
以正确顺序返回包含此列表中所有元素的数组。
toASCII(String, int) - 类 java.net.IDN 中的静态方法
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。
toASCII(String) - 类 java.net.IDN 中的静态方法
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。
toASCIIString() - 类 java.net.URI 中的方法
以 US-ASCII 字符串形式返回此 URI 的内容。
toAttributes() - 类 javax.naming.ldap.Rdn 中的方法
检索此 Rdn 中包含的类型/值映射关系的 Attributes 视图。
toBack() - 类 java.awt.Dialog 中的方法
如果此窗口是可视的，则将此窗口置于后方，如果它是焦点窗口或活动窗口，则会导致丢失焦点或活动状态。
toBack() - 类 java.awt.Window 中的方法
如果此窗口是可视的，则将此窗口置于后方，如果它是焦点窗口或活动窗口，则会导致丢失焦点或活动状态。
toBack() - 类 javax.swing.JInternalFrame 中的方法
将此内部窗体发送至后台。
toBigInteger() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 BigInteger。
toBigIntegerExact() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 BigInteger，以检查丢失的信息。
toBinaryString(int) - 类 java.lang.Integer 中的静态方法
以二进制（基数 2）无符号整数形式返回一个整数参数的字符串表示形式。
toBinaryString(long) - 类 java.lang.Long 中的静态方法
以二进制无符号整数形式返回 long 参数的字符串表示形式。
TOBOTTOM_TOLEFT - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从右上开始，按列布置各页，然后向左下部展开。
TOBOTTOM_TORIGHT - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从左上开始，按列布置各页，然后向右下部展开。
toBundleName(String, Locale) - 类 java.util.ResourceBundle.Control 中的方法
将给定 baseName 和 locale 转换为包名称。
toByteArray() - 类 java.io.ByteArrayOutputStream 中的方法
创建一个新分配的 byte 数组。
toByteArray() - 类 java.math.BigInteger 中的方法
返回一个 byte 数组，该数组包含此 BigInteger 的二进制补码表示形式。
toByteArray() - 类 java.text.CollationKey 中的方法
将 CollationKey 转换成位序列。
toCachedRowSet() - 接口 javax.sql.rowset.JoinRowSet 中的方法
创建一个包含此 JoinRowSet 对象中数据的新 CachedRowSet 对象，可以使用 CachedRowSet 对象的 SyncProvider 对象将此 JoinRowSet 对象保存到数据源。
toCharArray() - 类 java.io.CharArrayWriter 中的方法
返回输入数据的副本。
toCharArray() - 类 java.lang.String 中的方法
将此字符串转换为一个新的字符数组。
toChars(int, char[], int) - 类 java.lang.Character 中的静态方法
将指定字符（Unicode 代码点）转换为其 UTF-16 表示形式。
toChars(int) - 类 java.lang.Character 中的静态方法
将指定的字符（Unicode 代码点）转换成其存储在 char 数组中的 UTF-16 表示形式。
toCIEXYZ(float[]) - 类 java.awt.color.ColorSpace 中的方法
将假定为此 ColorSpace 中的颜色值转换成 CS_CIEXYZ 变换颜色空间中的值。
toCIEXYZ(float[]) - 类 java.awt.color.ICC_ColorSpace 中的方法
将假定为此 ColorSpace 中的颜色值转换成 CS_CIEXYZ 变换颜色空间中的值。
toCodePoint(char, char) - 类 java.lang.Character 中的静态方法
将指定的代理项对转换为其增补代码点值。
toCollection() - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象转换成一个 Collection 对象，它包含此 CachedRowSet 对象的所有数据。
toCollection(int) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
toCollection(String) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
toCompositeData(CompositeType) - 接口 javax.management.openmbean.CompositeDataView 中的方法
返回对应于此对象中的值的 CompositeData。
toDays(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 DAYS.convert(duration, this)。
toDegrees(double) - 类 java.lang.Math 中的静态方法
将用弧度表示的角转换为近似相等的用角度表示的角。
toDegrees(double) - 类 java.lang.StrictMath 中的静态方法
将用弧度表示的角转换为近似相等的用角度表示的角。
toDisplayString(String, Locale) - 类 javax.accessibility.AccessibleBundle 中的方法
获取本地化字符串形式的键。
toDisplayString(Locale) - 类 javax.accessibility.AccessibleBundle 中的方法
获取本地化字符串形式的键。
toDisplayString() - 类 javax.accessibility.AccessibleBundle 中的方法
获取使用默认语言环境来描述键的本地化字符串。
toEngineeringString() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的字符串表示形式，需要指数时，则使用工程计数法。
toExternalForm() - 类 java.net.URL 中的方法
构造此 URL 的字符串表示形式。
toExternalForm(URL) - 类 java.net.URLStreamHandler 中的方法
将特定协议的 URL 转换为 String。
toFront() - 类 java.awt.Window 中的方法
如果此窗口是可见的，则将此窗口置于前端，并可以将其设为焦点 Window。
toFront() - 类 javax.swing.JInternalFrame 中的方法
将此内部窗体置于前端。
toGenericString() - 类 java.lang.reflect.Constructor 中的方法
返回描述此 Constructor 的字符串，其中包括类型参数。
toGenericString() - 类 java.lang.reflect.Field 中的方法
返回一个描述此 Field（包括其一般类型）的字符串。
toGenericString() - 类 java.lang.reflect.Method 中的方法
返回描述此 Method 的字符串，包括类型参数。
TOGGLE_BUTTON - 类 javax.accessibility.AccessibleRole 中的静态变量
可以被选中或不被选中的专用按钮，但不针对当前状态提供单独的指示符。
TOGGLE_BUTTON - 类 javax.swing.plaf.synth.Region 中的静态变量
ToggleButton 的 region。
TOGGLE_CLICK_COUNT_PROPERTY - 类 javax.swing.JTree 中的静态变量
toggleClickCount 的绑定属性名称。
TOGGLE_EXPAND - 接口 javax.accessibility.AccessibleAction 中的静态变量
如果树节点是展开的，则此动作将折叠它，如果是折叠的则展开它。
TOGGLE_POPUP - 接口 javax.accessibility.AccessibleAction 中的静态变量
如果某个弹出菜单是隐藏的，则此动作将使其可见，如果是可见的则将其隐藏。
toggleClickCount - 类 javax.swing.JTree 中的变量
展开节点之前的鼠标单击数。
toggleExpandState(TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果路径不是展开的，则展开它；如果它是展开的，则折叠它。
toggleOpenClose() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
如果正在显示弹出部分，则隐藏它；如果它是隐藏的，则显示它。
togglePopup() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
如果弹出部分是隐藏的，则使其可见；如果它是可见的，则将其隐藏。
toggleSortOrder(int) - 类 javax.swing.DefaultRowSorter 中的方法
如果指定列已经是主要排序列，则反转排序顺序（将升序变为降序，或将降序变为升序）；否则，使指定列成为主要排序列，并使用升序排序顺序。
toggleSortOrder(int) - 类 javax.swing.RowSorter 中的方法
颠倒指定列的排序顺序。
toGMTString() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代，使用 GMT TimeZone。
toGregorianCalendar() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将此 XMLGregorianCalendar 转换为 GregorianCalendar。
toGregorianCalendar(TimeZone, Locale, XMLGregorianCalendar) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。
toHexString(double) - 类 java.lang.Double 中的静态方法
返回 double 参数的十六进制字符串表示形式。
toHexString(float) - 类 java.lang.Float 中的静态方法
返回 float 参数的十六进制字符串表示形式。
toHexString(int) - 类 java.lang.Integer 中的静态方法
以十六进制（基数 16）无符号整数形式返回一个整数参数的字符串表示形式。
toHexString(long) - 类 java.lang.Long 中的静态方法
以十六进制无符号整数形式返回 long 参数的字符串表示形式。
toHours(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 HOURS.convert(duration, this)。
toIndex - 类 javax.swing.event.TableColumnModelEvent 中的变量
列的索引，该索引处是移动或添加操作的目标位置
toJMXConnector(Map<String, ?>) - 类 javax.management.remote.JMXConnectorServer 中的方法
返回此连接器服务器的客户端 stub。
toJMXConnector(Map<String, ?>) - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
返回此连接器服务器的客户端 stub。
toJMXConnector(Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
返回此连接器服务器的客户端 stub。
TOLEFT_TOBOTTOM - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从右上部开始，按行布置各页，然后向左下部展开。
TOLEFT_TOTOP - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从右下部开始，按行布置各页，然后向左上部展开。
toLocaleString() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代。
toLocalizedPattern() - 类 java.text.DecimalFormat 中的方法
合成一个表示此 Format 对象当前状态的、已本地化的模式字符串。
toLocalizedPattern() - 类 java.text.SimpleDateFormat 中的方法
返回描述此日期格式的本地化模式字符串。
toLowerCase(char) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为小写。
toLowerCase(int) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为小写。
toLowerCase(Locale) - 类 java.lang.String 中的方法
使用给定 Locale 的规则将此 String 中的所有字符都转换为小写。
toLowerCase() - 类 java.lang.String 中的方法
使用默认语言环境的规则将此 String 中的所有字符都转换为小写。
toMatchResult() - 类 java.util.regex.Matcher 中的方法
作为 MatchResult 返回此匹配器的匹配状态。
toMicros(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 MICROSECONDS.convert(duration, this)。
toMillis(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 MILLISECONDS.convert(duration, this)。
toMinutes(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 MINUTES.convert(duration, this)。
toNanos(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 NANOSECONDS.convert(duration, this)。
TONER_EMPTY - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备的碳粉用完。
TONER_LOW - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备的碳粉不足。
toOctalString(int) - 类 java.lang.Integer 中的静态方法
以八进制（基数 8）无符号整数形式返回一个整数参数的字符串表示形式。
toOctalString(long) - 类 java.lang.Long 中的静态方法
以八进制无符号整数形式返回 long 参数的字符串表示形式。
Tool - javax.tools 中的 接口
可以从程序中调用的工具的公共接口。
TOOL_BAR - 类 javax.accessibility.AccessibleRole 中的静态变量
通常由普通按钮或切换按钮组成的工具栏或调色板。
TOOL_BAR - 类 javax.swing.plaf.synth.Region 中的静态变量
ToolBar 的 region。
TOOL_BAR_CONTENT - 类 javax.swing.plaf.synth.Region 中的静态变量
包含内容的 ToolBar 的 region。
TOOL_BAR_DRAG_WINDOW - 类 javax.swing.plaf.synth.Region 中的静态变量
包含 ToolBar 的 Window 的 region。
TOOL_BAR_SEPARATOR - 类 javax.swing.plaf.synth.Region 中的静态变量
ToolBar 分隔器的 region。
TOOL_TIP - 类 javax.accessibility.AccessibleRole 中的静态变量
提供关于另一个对象信息的对象。
TOOL_TIP - 类 javax.swing.plaf.synth.Region 中的静态变量
ToolTip 的 region。
TOOL_TIP_TEXT_KEY - 类 javax.swing.JComponent 中的静态变量
光标位于组件上方时显示的注释，也称为“值提示”、“相交提示 (flyover help)”或“相交标签 (flyover label)”。
toolBar - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的变量
toolBar - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
toolBarContListener - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
toolBarFocusListener - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
ToolBarUI - javax.swing.plaf 中的 类
JToolBar 的可插入外观界面。
ToolBarUI() - 类 javax.swing.plaf.ToolBarUI 的构造方法
Toolkit - java.awt 中的 类
此类是所有 Abstract Window Toolkit 实际实现的抽象超类。
Toolkit() - 类 java.awt.Toolkit 的构造方法
ToolProvider - javax.tools 中的 类
为查找工具提供者提供方法，例如，编译器的提供者。
ToolTipManager - javax.swing 中的 类
管理系统中的所有 ToolTips。
ToolTipManager.insideTimerAction - javax.swing 中的 类
ToolTipManager.insideTimerAction() - 类 javax.swing.ToolTipManager.insideTimerAction 的构造方法
ToolTipManager.outsideTimerAction - javax.swing 中的 类
ToolTipManager.outsideTimerAction() - 类 javax.swing.ToolTipManager.outsideTimerAction 的构造方法
ToolTipManager.stillInsideTimerAction - javax.swing 中的 类
ToolTipManager.stillInsideTimerAction() - 类 javax.swing.ToolTipManager.stillInsideTimerAction 的构造方法
ToolTipUI - javax.swing.plaf 中的 类
JToolTip 的可插入外观界面。
ToolTipUI() - 类 javax.swing.plaf.ToolTipUI 的构造方法
TooManyListenersException - java.util 中的 异常
TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。
TooManyListenersException() - 异常 java.util.TooManyListenersException 的构造方法
构造不带详细消息的 TooManyListenersException。
TooManyListenersException(String) - 异常 java.util.TooManyListenersException 的构造方法
构造带指定详细消息的 TooManyListenersException。
top - 类 java.awt.Insets 中的变量
顶部的 inset。
TOP - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的顶层进纸托盘。
top - 类 javax.swing.border.EmptyBorder 中的变量
TOP - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框顶端线的中部。
TOP - 类 javax.swing.JSplitPane 中的静态变量
用于添加一个 Component 到另一个 Component 的上面。
TOP - 接口 javax.swing.SwingConstants 中的静态变量
用于指定框顶部位置的框方向常量。
TOP_ALIGNMENT - 类 java.awt.Component 中的静态变量
getAlignmentY() 的易于使用的常量。
TOP_ALIGNMENT - 类 java.awt.font.GraphicAttribute 中的静态变量
将图形顶端与行的顶端对齐。
toPattern() - 类 java.text.ChoiceFormat 中的方法
获取模式。
toPattern() - 类 java.text.DecimalFormat 中的方法
合成一个表示此 Format 对象当前状态的模式字符串。
toPattern() - 类 java.text.MessageFormat 中的方法
返回表示消息格式当前状态的模式。
toPattern() - 类 java.text.SimpleDateFormat 中的方法
返回描述此日期格式的模式字符串。
TOPDOWNLEFTRIGHT - 接口 java.awt.image.ImageConsumer 中的静态变量
按从上到下、从左到右的顺序传递像素。
toPlainString() - 类 java.math.BigDecimal 中的方法
返回不带指数字段的此 BigDecimal 的字符串表示形式。
toRadians(double) - 类 java.lang.Math 中的静态方法
将用角度表示的角转换为近似相等的用弧度表示的角。
toRadians(double) - 类 java.lang.StrictMath 中的静态方法
将用角度表示的角转换为近似相等的用弧度表示的角。
toResourceName(String, String) - 类 java.util.ResourceBundle.Control 中的方法
将给定 bundleName 转换为 ClassLoader.getResource 方法要求的形式：用 '/' 替换 bundleName 中出现的所有 '.'，并添加一个 '.' 和给定的文件 suffix。
toRGB(float[]) - 类 java.awt.color.ColorSpace 中的方法
将假定为此 ColorSpace 中的颜色值转换成默认 CS_sRGB 颜色空间中的值。
toRGB(float[]) - 类 java.awt.color.ICC_ColorSpace 中的方法
将假定为此 ColorSpace 中的颜色值转换成默认 CS_sRGB 颜色空间中的值。
TORIGHT_TOBOTTOM - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从左上部开始，按行布置各页，然后向右下部展开。
TORIGHT_TOTOP - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从左下部开始，按行布置各页，然后向右上部展开。
toSeconds(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 SECONDS.convert(duration, this)。
toString() - 类 java.awt.AWTEvent 中的方法
返回此对象的字符串表示形式。
toString() - 类 java.awt.AWTKeyStroke 中的方法
返回一个显示并标识此对象属性的字符串。
toString() - 类 java.awt.BorderLayout 中的方法
返回此边框布局的状态的字符串表示形式。
toString() - 类 java.awt.CardLayout 中的方法
返回此卡片布局状态的字符串表示形式。
toString() - 类 java.awt.CheckboxGroup 中的方法
返回此复选框组的字符串表示形式，包含当前选中复选框的值。
toString() - 类 java.awt.Color 中的方法
返回此 Color 的字符串表示形式。
toString() - 类 java.awt.Component 中的方法
返回此组件及其值的字符串表示形式。
toString() - 类 java.awt.Cursor 中的方法
返回此光标的字符串表示形式。
toString() - 类 java.awt.datatransfer.DataFlavor 中的方法
此 DataFlavor 及其参数的字符串表示形式。
toString() - 类 java.awt.Dimension 中的方法
返回此 Dimension 对象的 height 和 width 字段的字符串表示形式。
toString() - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
toString() - 类 java.awt.FlowLayout 中的方法
返回此 FlowLayout 对象及其值的字符串表示形式。
toString() - 类 java.awt.font.NumericShaper 中的方法
返回描述此成形器的 String。
toString() - 类 java.awt.font.TextHitInfo 中的方法
返回表示此 TextHitInfo 的 String，只用于调试目的。
toString() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的调试信息。
toString() - 类 java.awt.Font 中的方法
将此 Font 对象转换为 String 表示形式。
toString() - 类 java.awt.FontMetrics 中的方法
返回此 FontMetrics 对象的值的 String 表示形式。
toString() - 类 java.awt.geom.AffineTransform 中的方法
返回表示此 Object 值的 String。
toString() - 类 java.awt.geom.Point2D.Double 中的方法
返回表示此 Point2D 值的 String。
toString() - 类 java.awt.geom.Point2D.Float 中的方法
返回表示此 Point2D 值的 String。
toString() - 类 java.awt.geom.Rectangle2D.Double 中的方法
返回此 Rectangle2D 的 String 表示形式。
toString() - 类 java.awt.geom.Rectangle2D.Float 中的方法
返回此 Rectangle2D 的 String 表示形式。
toString() - 类 java.awt.Graphics 中的方法
返回表示此 Graphics 对象值的 String 对象。
toString() - 类 java.awt.GridBagLayout 中的方法
返回此网格包布局的值的字符串表示形式。
toString() - 类 java.awt.GridLayout 中的方法
返回此网格布局的值的字符串表示形式。
toString() - 类 java.awt.image.BufferedImage 中的方法
返回此 BufferedImage 对象及其值的 String 表示形式。
toString() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 对象的内容的 String 表示形式。
toString() - 类 java.awt.image.DirectColorModel 中的方法
返回表示此 DirectColorModel 的 String。
toString() - 类 java.awt.image.IndexColorModel 中的方法
返回此 ColorModel 对象内容的 String 表示形式。
toString() - 类 java.awt.Insets 中的方法
返回此 Insets 对象的字符串表示形式。
toString() - 类 java.awt.JobAttributes 中的方法
返回此 JobAttributes 的字符串表示形式。
toString() - 类 java.awt.MenuComponent 中的方法
返回此菜单组件的表示形式。
toString() - 类 java.awt.MenuShortcut 中的方法
返回此菜单快捷方式的国际化描述。
toString() - 类 java.awt.PageAttributes 中的方法
返回此 PageAttributes 的字符串表示形式。
toString() - 类 java.awt.Point 中的方法
返回此点的字符串表示形式及其在 (x,y) 坐标空间中的位置。
toString() - 类 java.awt.Rectangle 中的方法
返回表示此 Rectangle 及其值的 String。
toString() - 类 java.awt.RenderingHints 中的方法
返回 hashmap 的一个相当长的字符串表示形式，该 hashmap 包含此 RenderingHints 对象的键或值的映射关系。
toString() - 类 java.awt.Robot 中的方法
返回此 Robot 的字符串表示形式。
toString() - 类 java.awt.ScrollPaneAdjustable 中的方法
返回此滚动条及其值的字符串表示形式。
toString() - 类 java.awt.SystemColor 中的方法
返回此 Color 值的字符串表示形式。
toString() - 类 java.beans.Expression 中的方法
使用 Java 风格的语法打印此表达式的值。
toString() - 类 java.beans.Statement 中的方法
使用 Java 风格的语法打印此语句的值。
toString() - 类 java.io.ByteArrayOutputStream 中的方法
使用平台默认的字符集，通过解码字节将缓冲区内容转换为字符串。
toString(String) - 类 java.io.ByteArrayOutputStream 中的方法
使用指定的 charsetName，通过解码字节将缓冲区内容转换为字符串。
toString(int) - 类 java.io.ByteArrayOutputStream 中的方法
已过时。 此方法无法将字节正确转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是通过 toString(String enc) 方法（使用一个编码名称参数），或 toString() 方法（使用平台的默认字符编码）。
toString() - 类 java.io.CharArrayWriter 中的方法
将输入数据转换为字符串。
toString() - 类 java.io.File 中的方法
返回此抽象路径名的路径名字符串。
toString() - 类 java.io.ObjectStreamClass 中的方法
返回描述此 ObjectStreamClass 的字符串。
toString() - 类 java.io.ObjectStreamField 中的方法
返回描述此字段的字符串。
toString() - 类 java.io.StreamTokenizer 中的方法
返回当前流标记和在其上发生的行号的字符串表示形式。
toString() - 类 java.io.StringWriter 中的方法
以字符串的形式返回该缓冲区的当前值。
toString() - 接口 java.lang.annotation.Annotation 中的方法
返回此 annotation 的字符串表示形式。
toString(boolean) - 类 java.lang.Boolean 中的静态方法
返回一个表示指定布尔值的 String 对象。
toString() - 类 java.lang.Boolean 中的方法
返回表示该布尔值的 String 对象。
toString(byte) - 类 java.lang.Byte 中的静态方法
返回表示指定 byte 的一个新 String 对象。
toString() - 类 java.lang.Byte 中的方法
返回表示此 Byte 的值的 String 对象。
toString() - 类 java.lang.Character.Subset 中的方法
返回该子集的名称。
toString() - 类 java.lang.Character 中的方法
返回表示此 Character 值的 String 对象。
toString(char) - 类 java.lang.Character 中的静态方法
返回一个表示指定 char 值的 String 对象。
toString() - 接口 java.lang.CharSequence 中的方法
返回一个包含此序列中字符的字符串，该字符串与此序列的顺序相同。
toString() - 类 java.lang.Class 中的方法
将对象转换为字符串。
toString(double) - 类 java.lang.Double 中的静态方法
返回 double 参数的字符串表示形式。
toString() - 类 java.lang.Double 中的方法
返回此 Double 对象的字符串表示形式。
toString() - 类 java.lang.Enum 中的方法
返回枚举常量的名称，它包含在声明中。
toString(float) - 类 java.lang.Float 中的静态方法
返回 float 参数的字符串表示形式。
toString() - 类 java.lang.Float 中的方法
返回此 Float 对象的字符串表示形式。
toString(int, int) - 类 java.lang.Integer 中的静态方法
返回用第二个参数指定基数表示的第一个参数的字符串表示形式。
toString(int) - 类 java.lang.Integer 中的静态方法
返回一个表示指定整数的 String 对象。
toString() - 类 java.lang.Integer 中的方法
返回一个表示该 Integer 值的 String 对象。
toString(long, int) - 类 java.lang.Long 中的静态方法
返回在使用第二个参数指定的基数时第一个参数的字符串表示形式。
toString(long) - 类 java.lang.Long 中的静态方法
返回表示指定 long 的 String 对象。
toString() - 类 java.lang.Long 中的方法
返回表示 Long 值的 String 对象。
toString() - 类 java.lang.management.LockInfo 中的方法
返回锁的字符串表示形式。
toString() - 枚举 java.lang.management.MemoryType 中的方法
返回该 MemoryType 的字符串表示形式。
toString() - 类 java.lang.management.MemoryUsage 中的方法
返回此内存使用量的描述性表示形式。
toString() - 类 java.lang.management.ThreadInfo 中的方法
返回此线程信息的字符串表示形式。
toString() - 类 java.lang.Object 中的方法
返回该对象的字符串表示。
toString() - 类 java.lang.Package 中的方法
返回此 Package 的字符串表示形式。
toString() - 类 java.lang.reflect.Constructor 中的方法
返回描述此 Constructor 的字符串。
toString() - 类 java.lang.reflect.Field 中的方法
返回一个描述此 Field 的字符串。
toString() - 类 java.lang.reflect.Method 中的方法
返回描述此 Method 的字符串。
toString(int) - 类 java.lang.reflect.Modifier 中的静态方法
返回描述指定修饰符中的访问修饰符标志的字符串。
toString(short) - 类 java.lang.Short 中的静态方法
返回表示指定 short 的一个新 String 对象。
toString() - 类 java.lang.Short 中的方法
返回表示此 Short 的值的 String 对象。
toString() - 类 java.lang.StackTraceElement 中的方法
返回表示该堆栈跟踪元素的字符串。
toString() - 类 java.lang.String 中的方法
返回此对象本身（它已经是一个字符串！）。
toString() - 类 java.lang.StringBuffer 中的方法
toString() - 类 java.lang.StringBuilder 中的方法
toString() - 类 java.lang.Thread 中的方法
返回该线程的字符串表示形式，包括线程名称、优先级和线程组。
toString() - 类 java.lang.ThreadGroup 中的方法
返回此线程组的字符串表示形式。
toString() - 类 java.lang.Throwable 中的方法
返回此 throwable 的简短描述。
toString() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的字符串表示形式，如果需要指数，则使用科学记数法。
toString(int) - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的给定基数的字符串表示形式。
toString() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的十进制字符串表示形式。
toString() - 类 java.math.MathContext 中的方法
返回此 MathContext 的字符串表示形式。
toString() - 类 java.net.HttpCookie 中的方法
构造此 cookie 的一个 cookie 头字符串表示形式，其格式为对应的 cookie 规范定义的格式，但没有前导 "Cookie:" 标记。
toString() - 类 java.net.InetAddress 中的方法
将此 IP 地址转换为 String。
toString() - 类 java.net.InetSocketAddress 中的方法
构造此 InetSocketAddress 的字符串表示形式。
toString() - 类 java.net.InterfaceAddress 中的方法
将此接口地址转换为 String。
toString() - 类 java.net.NetworkInterface 中的方法
toString() - 类 java.net.Proxy 中的方法
构造此代理的字符串表示形式。
toString() - 类 java.net.ServerSocket 中的方法
作为 String 返回此套接字的实现地址和实现端口。
toString() - 类 java.net.Socket 中的方法
将此套接字转换为 String。
toString() - 类 java.net.SocketImpl 中的方法
以 String 的形式返回此套接字的地址和端口。
toString() - 类 java.net.URI 中的方法
以字符串形式返回此 URI 的内容。
toString() - 类 java.net.URL 中的方法
构造此 URL 的字符串表示形式。
toString() - 类 java.net.URLConnection 中的方法
返回此 URL 连接的 String 表示形式。
toString() - 类 java.nio.ByteBuffer 中的方法
返回汇总了此缓冲区状态的字符串。
toString() - 类 java.nio.ByteOrder 中的方法
构造描述此对象的字符串。
toString() - 类 java.nio.channels.FileChannel.MapMode 中的方法
返回描述此文件映射模式的字符串。
toString() - 类 java.nio.channels.FileLock 中的方法
返回描述此锁定的范围、类型和有效性的字符串。
toString() - 类 java.nio.CharBuffer 中的方法
返回包含此缓冲区中字符的字符串。
toString() - 类 java.nio.charset.Charset 中的方法
返回描述此 charset 的字符串。
toString() - 类 java.nio.charset.CoderResult 中的方法
返回描述此 CoderResult 的字符串。
toString() - 类 java.nio.charset.CodingErrorAction 中的方法
返回描述此操作的字符串。
toString() - 类 java.nio.DoubleBuffer 中的方法
返回总结了此缓冲区状态的字符串。
toString() - 类 java.nio.FloatBuffer 中的方法
返回总结了此缓冲区状态的字符串。
toString() - 类 java.nio.IntBuffer 中的方法
返回总结了此缓冲区状态的字符串。
toString() - 类 java.nio.LongBuffer 中的方法
返回总结了此缓冲区状态的字符串。
toString() - 类 java.nio.ShortBuffer 中的方法
返回总结了此缓冲区状态的字符串。
toString() - 类 java.rmi.dgc.VMID 中的方法
返回此 VMID 的字符串表示形式。
toString() - 类 java.rmi.server.LogStream 中的方法
已过时。 无替代版本
toString() - 类 java.rmi.server.ObjID 中的方法
返回此对象标识符的字符串表示形式。
toString() - 类 java.rmi.server.Operation 中的方法
已过时。 无替代版本
toString() - 类 java.rmi.server.RemoteObject 中的方法
返回表示此远程对象的值的 String。
toString() - 类 java.rmi.server.UID 中的方法
返回此 UID 的字符串表示形式。
toString() - 接口 java.security.acl.Acl 中的方法
返回 ACL 内容的字符串表示形式。
toString() - 接口 java.security.acl.AclEntry 中的方法
返回此 ACL 项内容的字符串表示形式。
toString() - 接口 java.security.acl.Permission 中的方法
打印此权限的字符串表示形式。
toString() - 类 java.security.AlgorithmParameters 中的方法
返回描述参数的格式化字符串。
toString() - 类 java.security.cert.Certificate 中的方法
返回此证书的字符串表示形式。
toString() - 类 java.security.cert.CertPath 中的方法
返回此证书路径的字符串表示形式。
toString() - 类 java.security.cert.CollectionCertStoreParameters 中的方法
返回描述该参数的格式化字符串。
toString() - 类 java.security.cert.CRL 中的方法
返回此 CRL 的字符串表示形式。
toString() - 类 java.security.cert.LDAPCertStoreParameters 中的方法
返回描述该参数的格式化字符串。
toString() - 类 java.security.cert.PKIXBuilderParameters 中的方法
返回描述该参数的格式化字符串。
toString() - 类 java.security.cert.PKIXCertPathBuilderResult 中的方法
返回此 PKIXCertPathBuilderResult 的可打印表示形式。
toString() - 类 java.security.cert.PKIXCertPathValidatorResult 中的方法
返回此 PKIXCertPathValidatorResult 的可打印表示形式。
toString() - 类 java.security.cert.PKIXParameters 中的方法
返回描述该参数的格式化字符串。
toString() - 类 java.security.cert.PolicyQualifierInfo 中的方法
返回此 PolicyQualifierInfo 的可打印表示形式。
toString() - 类 java.security.cert.TrustAnchor 中的方法
返回描述此 TrustAnchor 的格式化字符串。
toString() - 类 java.security.cert.X509CertSelector 中的方法
返回该 CertSelector 的可打印表示形式。
toString() - 类 java.security.cert.X509CRLEntry 中的方法
返回此 CRL 项的字符串表示形式。
toString() - 类 java.security.cert.X509CRLSelector 中的方法
返回该 X509CRLSelector 的可打印表示形式。
toString(boolean) - 接口 java.security.Certificate 中的方法
已过时。 返回表示证书内容的字符串。
toString() - 类 java.security.CodeSigner 中的方法
返回描述此代码签名者的字符串。
toString() - 类 java.security.CodeSource 中的方法
返回描述此 CodeSource 的字符串，告知其 URL 和证书。
toString() - 类 java.security.DigestInputStream 中的方法
打印此摘要输入流及其关联的消息摘要对象的字符串表示形式。
toString() - 类 java.security.DigestOutputStream 中的方法
打印此摘要输出流及其关联的消息摘要对象的字符串表示形式。
toString() - 类 java.security.Identity 中的方法
已过时。 返回描述此 Identity 的短字符串，说明其名称和作用域（如果有的话）。
toString(boolean) - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 的字符串表示形式，可以选择比不带任何参数的 toString 方法带有更多的详细信息。
toString() - 类 java.security.IdentityScope 中的方法
已过时。 返回此身份作用域的字符串表示形式，包括其名称、作用域名称和此身份作用域中身份的数目。
toString() - 类 java.security.KeyStore.PrivateKeyEntry 中的方法
返回此 PrivateKeyEntry 的字符串表示形式。
toString() - 类 java.security.KeyStore.SecretKeyEntry 中的方法
返回此 SecretKeyEntry 的字符串表示形式。
toString() - 类 java.security.KeyStore.TrustedCertificateEntry 中的方法
返回此 TrustedCertificateEntry 的字符串表示形式。
toString() - 类 java.security.MessageDigest 中的方法
返回此信息摘要对象的字符串表示形式。
toString() - 类 java.security.Permission 中的方法
返回描述此 Permission 的字符串。
toString() - 类 java.security.PermissionCollection 中的方法
返回描述此 PermissionCollection 对象的字符串，提供该对象中包含的关于所有权限的信息。
toString() - 接口 java.security.Principal 中的方法
返回此主体的字符串表示形式。
toString() - 异常 java.security.PrivilegedActionException 中的方法
toString() - 类 java.security.ProtectionDomain 中的方法
将 ProtectionDomain 转换成为 String。
toString() - 类 java.security.Provider.Service 中的方法
返回此服务的字符串表示形式。
toString() - 类 java.security.Provider 中的方法
返回具有此 provider 名称和版本号的字符串。
toString() - 类 java.security.Signature 中的方法
返回此签名对象的字符串表示形式，以提供包括对象状态和所用算法名称在内的信息。
toString() - 类 java.security.Signer 中的方法
已过时。 返回有关该 signer 信息的字符串。
toString() - 类 java.security.Timestamp 中的方法
返回描述此时间戳的字符串。
toString() - 类 java.security.UnresolvedPermission 中的方法
返回描述此 UnresolvedPermission 的字符串。
toString() - 类 java.sql.Date 中的方法
格式化日期转义形式 yyyy-mm-dd 的日期。
toString() - 接口 java.sql.RowId 中的方法
返回表示此 java.sql.RowId 对象指定的 SQL ROWID 值的 String。
toString() - 类 java.sql.Time 中的方法
使用 JDBC 时间转义格式对时间进行格式化。
toString() - 类 java.sql.Timestamp 中的方法
使用 JDBC 时间戳转义格式编排时间戳。
toString() - 类 java.text.Annotation 中的方法
返回此 Annotation 的 String 表示形式。
toString() - 类 java.text.AttributedCharacterIterator.Attribute 中的方法
返回该对象的字符串表示形式。
toString() - 类 java.text.Bidi 中的方法
用于调试时显示双向算法的内部状态。
toString() - 类 java.text.FieldPosition 中的方法
返回此 FieldPosition 的字符串表示形式。
toString() - 类 java.text.ParsePosition 中的方法
返回此 ParsePosition 的字符串表示形式。
toString() - 类 java.util.AbstractCollection 中的方法
返回此 collection 的字符串表示形式。
toString() - 类 java.util.AbstractMap.SimpleEntry 中的方法
返回此映射项的 String 表示形式。
toString() - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
返回此映射项的 String 表示形式。
toString() - 类 java.util.AbstractMap 中的方法
返回此映射的字符串表示形式。
toString(long[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(int[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(short[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(char[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(byte[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(boolean[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(float[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(double[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(Object[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString() - 类 java.util.BitSet 中的方法
返回此位 set 的字符串表示形式。
toString() - 类 java.util.Calendar 中的方法
返回此日历的字符串表示形式。
toString() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
toString() - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
返回当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
返回当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
返回数组当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
返回当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
返回数组当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicReference 中的方法
返回当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
返回数组当前值的字符串表示形式。
toString() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表的字符串表示形式。
toString() - 类 java.util.concurrent.CountDownLatch 中的方法
返回标识此锁存器及其状态的字符串。
toString() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
toString() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
toString() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回标识此同步器及其状态的字符串。
toString() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回标识此同步器及其状态的字符串。
toString() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回标识此锁及其锁定状态的字符串。
toString() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
返回标识此锁及其锁状态的字符串。
toString() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回标识此锁及其锁状态的字符串。
toString() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
返回标识此锁及其锁状态的字符串。
toString() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
toString() - 类 java.util.concurrent.Semaphore 中的方法
返回标识此信号量的字符串，以及信号量的状态。
toString() - 类 java.util.Currency 中的方法
返回此货币的 ISO 4217 货币代码。
toString() - 类 java.util.Date 中的方法
把此 Date 对象转换为以下形式的 String： dow mon dd hh:mm:ss zzz yyyy 其中： dow 是一周中的某一天 (Sun, Mon, Tue, Wed, Thu, Fri, Sat)。
toString() - 类 java.util.EventObject 中的方法
返回此 EventObject 的 String 表示形式。
toString() - 类 java.util.Formatter 中的方法
返回对输出的目标文件调用 toString() 的结果。
toString() - 类 java.util.Hashtable 中的方法
返回此 Hashtable 对象的字符串表示形式，其形式为 ASCII 字符 ", " （逗号加空格）分隔开的、括在括号中的一组条目。
toString() - 类 java.util.jar.Attributes.Name 中的方法
返回字符串形式的属性名称。
toString() - 类 java.util.Locale 中的方法
使用由下划线分隔的语言、国家/地区和变量来获取整个语言环境的编程名称。
toString() - 类 java.util.logging.Level 中的方法
toString() - 类 java.util.prefs.AbstractPreferences 中的方法
返回此首选项节点的绝对路径名称。
toString() - 类 java.util.prefs.Preferences 中的方法
返回此首选项节点的字符串表示形式，与通过表达式：(this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath() 计算的结果一样。
toString() - 类 java.util.regex.Matcher 中的方法
返回匹配器的字符串表示形式。
toString() - 类 java.util.regex.Pattern 中的方法
返回此模式的字符串表示形式。
toString() - 类 java.util.Scanner 中的方法
返回此 Scanner 的字符串表示形式。
toString() - 类 java.util.ServiceLoader 中的方法
返回一个描述此服务的字符串。
toString() - 类 java.util.SimpleTimeZone 中的方法
返回此时区的字符串表示形式。
toString() - 类 java.util.UUID 中的方法
返回表示此 UUID 的 String 对象。
toString() - 类 java.util.Vector 中的方法
返回此向量的字符串表示形式，其中包含每个元素的 String 表示形式。
toString() - 类 java.util.zip.ZipEntry 中的方法
返回 ZIP 条目的字符串表示形式。
toString() - 类 javax.accessibility.AccessibleBundle 中的方法
获取使用默认语言环境来描述键的本地化字符串。
toString() - 类 javax.accessibility.AccessibleRelationSet 中的方法
使用默认语言环境创建表示关系集中所有关系的本地化 String。
toString() - 类 javax.accessibility.AccessibleStateSet 中的方法
使用默认语言环境创建表示状态集中所有状态的本地化 String。
toString() - 类 javax.activation.MimeType 中的方法
返回此对象的 String 表示形式。
toString() - 类 javax.activation.MimeTypeParameterList 中的方法
返回此对象的字符串表示形式。
toString() - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的方法
toString() - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的方法
toString() - 接口 javax.lang.model.element.AnnotationValue 中的方法
返回此值的字符串表示形式。
toString() - 枚举 javax.lang.model.element.Modifier 中的方法
返回此修饰符的小写名称。
toString() - 接口 javax.lang.model.type.TypeMirror 中的方法
返回包含此类型许多信息的字符串表示形式。
toString() - 类 javax.management.Attribute 中的方法
返回一个表示此 Attribute 值 String 对象。
toString() - 类 javax.management.AttributeValueExp 中的方法
返回表示其值的字符串。
toString() - 异常 javax.management.BadAttributeValueExpException 中的方法
返回该对象的字符串表示形式。
toString() - 异常 javax.management.BadBinaryOpValueExpException 中的方法
返回该对象的字符串表示形式。
toString() - 异常 javax.management.BadStringOperationException 中的方法
返回该对象的字符串表示形式。
toString() - 类 javax.management.ImmutableDescriptor 中的方法
toString() - 类 javax.management.MBeanAttributeInfo 中的方法
toString() - 类 javax.management.MBeanConstructorInfo 中的方法
toString() - 类 javax.management.MBeanInfo 中的方法
toString() - 类 javax.management.MBeanNotificationInfo 中的方法
toString() - 类 javax.management.MBeanOperationInfo 中的方法
toString() - 类 javax.management.MBeanParameterInfo 中的方法
toString() - 类 javax.management.modelmbean.DescriptorSupport 中的方法
返回表示描述符的可读字符串。
toString() - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 中的方法
返回 ModelMBeanAttributeInfo 实例的可读版本。
toString() - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 中的方法
以可读形式返回包含 ModelMBeanConstructorInfo 全部内容的字符串。
toString() - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 中的方法
返回包含 ModelMBeanNotificationInfo 的可读字符串。
toString() - 类 javax.management.modelmbean.ModelMBeanOperationInfo 中的方法
以可读形式返回包含 ModelMBeanOperationInfo 全部内容的字符串。
toString() - 类 javax.management.Notification 中的方法
返回此通知的字符串表示形式。
toString() - 类 javax.management.ObjectInstance 中的方法
返回表示此 ObjectInstance 对象字符串。
toString() - 类 javax.management.ObjectName 中的方法
返回该对象名的字符串表示形式。
toString() - 类 javax.management.openmbean.ArrayType 中的方法
返回此 ArrayType 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.CompositeData 中的方法
返回此 CompositeData 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回此 CompositeDataSupport 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.CompositeType 中的方法
返回此 CompositeType 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
返回此 OpenMBeanAttributeInfo 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
返回此 OpenMBeanConstructorInfo 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 中的方法
返回此 OpenMBeanConstructorInfoSupport 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回此 OpenMBeanInfo 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenMBeanInfoSupport 中的方法
返回此 OpenMBeanInfoSupport 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 中的方法
返回此 OpenMBeanOperationInfoSupport 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此 OpenMBeanParameterInfo 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenType 中的方法
返回此开放类型实例的字符串表示形式。
toString() - 类 javax.management.openmbean.SimpleType 中的方法
返回此 SimpleType 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularDataSupport 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.TabularType 中的方法
返回此 TabularType 实例的字符串表示形式。
toString() - 类 javax.management.relation.Role 中的方法
返回描述角色的字符串。
toString() - 类 javax.management.relation.RoleInfo 中的方法
返回描述角色信息的字符串。
toString() - 类 javax.management.relation.RoleUnresolved 中的方法
返回描述此对象的字符串。
toString() - 类 javax.management.remote.JMXPrincipal 中的方法
返回此 JMXPrincipal 的字符串表示形式。
toString() - 类 javax.management.remote.JMXServiceURL 中的方法
此 Service URL 的字符串表示形式。
toString() - 类 javax.management.remote.NotificationResult 中的方法
返回该对象的字符串表示形式。
toString() - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
返回此对象的字符串表示形式。
toString() - 类 javax.management.remote.rmi.RMIConnector 中的方法
返回此对象的字符串表示形式。
toString() - 类 javax.management.remote.TargetedNotification 中的方法
返回此定向通知的一个文本表示形式。
toString() - 类 javax.management.StringValueExp 中的方法
返回表示对象的字符串。
toString() - 类 javax.naming.BinaryRefAddr 中的方法
生成此地址的字符串表示形式。
toString() - 类 javax.naming.Binding 中的方法
生成此绑定的字符串表示形式。
toString() - 类 javax.naming.CompositeName 中的方法
生成此复合名称的字符串表示形式。
toString() - 类 javax.naming.CompoundName 中的方法
使用组合名称的语法规则生成此组合名称的字符串表示形式。
toString() - 异常 javax.naming.directory.AttributeModificationException 中的方法
此异常的字符串表示形式由关于发生错误的位置信息和第一个未执行的修改组成。
toString() - 类 javax.naming.directory.BasicAttribute 中的方法
生成此属性的字符串表示形式。
toString() - 类 javax.naming.directory.BasicAttributes 中的方法
生成此属性集的字符串表示形式。
toString() - 类 javax.naming.directory.ModificationItem 中的方法
生成此修改项的字符串表示形式，该表示形式由修改操作及其相关属性组成。
toString() - 类 javax.naming.directory.SearchResult 中的方法
生成此 SearchResult 的字符串表示形式。
toString() - 类 javax.naming.ldap.LdapName 中的方法
返回一个此 LDAP 名称的字符串表示形式，该表示形式使用 RFC 2253 定义并在类描述中描述的格式。
toString() - 类 javax.naming.ldap.Rdn 中的方法
以字符串形式返回此 Rdn，该字符串使用由 RFC 2253 定义并在 LdapName 类描述中描述的格式表示。
toString() - 异常 javax.naming.LinkException 中的方法
生成此异常的字符串表示形式。
toString(boolean) - 异常 javax.naming.LinkException 中的方法
生成此异常的字符串表示形式。
toString() - 类 javax.naming.NameClassPair 中的方法
生成此名称/类对的字符串表示形式。
toString() - 异常 javax.naming.NamingException 中的方法
生成此异常的字符串表示形式。
toString(boolean) - 异常 javax.naming.NamingException 中的方法
生成更详细的字符串表示形式。
toString() - 类 javax.naming.RefAddr 中的方法
生成此地址的字符串表示形式。
toString() - 类 javax.naming.Reference 中的方法
生成此引用的字符串表示形式。
toString() - 类 javax.net.ssl.SSLEngineResult 中的方法
返回此对象的字符串表示形式。
toString() - 类 javax.print.attribute.DateTimeSyntax 中的方法
返回对应于此日期-时间属性的字符串值。
toString() - 类 javax.print.attribute.EnumSyntax 中的方法
返回对应于此枚举值的字符串值。
toString() - 类 javax.print.attribute.IntegerSyntax 中的方法
返回对应于此整数属性的字符串值。
toString(int, String) - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回给定单位的此分辨率属性的字符串版本。
toString() - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回此分辨率属性的字符串版本。
toString() - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
返回对应于此整数集属性的字符串值。
toString(int, String) - 类 javax.print.attribute.Size2DSyntax 中的方法
返回给定单位的此二维大小属性的字符串版本。
toString() - 类 javax.print.attribute.Size2DSyntax 中的方法
返回此二维大小属性的字符串版本。
toString(int, String) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以给定单位返回此矩形大小属性的字符串版本。
toString() - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以 mm 为单位返回此矩形大小属性的字符串版本。
toString() - 类 javax.print.attribute.TextSyntax 中的方法
返回标识此文本属性的字符串。
toString() - 类 javax.print.attribute.URISyntax 中的方法
返回标识此 URI 属性的字符串。
toString() - 类 javax.print.DocFlavor 中的方法
将此 DocFlavor 转换为字符串。
toString() - 类 javax.print.event.PrintEvent 中的方法
toString() - 类 javax.rmi.CORBA.Stub 中的方法
返回此 stub 的字符串表示形式。
toString(Stub) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.toString() 的委托调用。
toString() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
toString() - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
toString() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
toString() - 类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 中的方法
返回此 controlFlag 的字符串表示形式。
toString() - 类 javax.security.auth.Subject 中的方法
返回此 Subject 的字符串表示形式。
toString() - 类 javax.security.auth.x500.X500Principal 中的方法
返回此 X500Principal 的用户友好的字符串表示形式。
toString() - 类 javax.security.cert.Certificate 中的方法
返回此证书的字符串表示形式。
toString() - 异常 javax.security.sasl.SaslException 中的方法
返回此异常的字符串表示形式。
toString() - 类 javax.sound.midi.MidiDevice.Info 中的方法
提供设备信息的字符串表示形式。
toString() - 类 javax.sound.midi.Sequencer.SyncMode 中的方法
以模式的字符串表示形式提供此同步模式的名称。
toString() - 类 javax.sound.sampled.AudioFileFormat 中的方法
提供文件格式的字符串表示形式。
toString() - 类 javax.sound.sampled.AudioFileFormat.Type 中的方法
按文件类型的 String 表示形式提供文件类型的名称。
toString() - 类 javax.sound.sampled.AudioFormat.Encoding 中的方法
提供编码的 String 表示形式。
toString() - 类 javax.sound.sampled.AudioFormat 中的方法
返回描述格式的字符串，如："PCM SIGNED 22050 Hz 16 bit mono big-endian"。
toString() - 类 javax.sound.sampled.BooleanControl 中的方法
提供控件的字符串表示形式
toString() - 类 javax.sound.sampled.CompoundControl 中的方法
提供控件的字符串表示形式
toString() - 类 javax.sound.sampled.Control 中的方法
获得描述控件类型及其当前状态的 String。
toString() - 类 javax.sound.sampled.Control.Type 中的方法
提供控件类型的 String 表示形式。
toString() - 类 javax.sound.sampled.DataLine.Info 中的方法
获得数据行信息的文本描述。
toString() - 类 javax.sound.sampled.EnumControl 中的方法
提供该控件的字符串表示形式。
toString() - 类 javax.sound.sampled.FloatControl 中的方法
提供控件的字符串表示形式
toString() - 类 javax.sound.sampled.Line.Info 中的方法
获得行信息的文本描述。
toString() - 类 javax.sound.sampled.LineEvent 中的方法
获得事件的字符串表示形式。
toString() - 类 javax.sound.sampled.LineEvent.Type 中的方法
以字符串形式返回类型名称。
toString() - 类 javax.sound.sampled.Mixer.Info 中的方法
提供混频器信息的字符串表示形式。
toString() - 类 javax.sound.sampled.Port.Info 中的方法
提供该端口的 String 表示形式。
toString() - 类 javax.sound.sampled.ReverbType 中的方法
提供回响类型的 String 表示形式，包括其名称和其参数设置。
toString() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回显示所有 BoundedRangeModel 属性的字符串。
toString() - 类 javax.swing.DefaultListModel 中的方法
返回显示并标识此对象的属性的字符串。
toString() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回显示并标识此对象的属性的字符串。
toString() - 类 javax.swing.event.DocumentEvent.EventType 中的方法
将类型转换成一个字符串。
toString() - 类 javax.swing.event.EventListenerList 中的方法
返回此 EventListenerList 的字符串表示形式。
toString() - 类 javax.swing.event.HyperlinkEvent.EventType 中的方法
将类型转换成一个字符串。
toString() - 类 javax.swing.event.ListDataEvent 中的方法
返回此 ListDataEvent 的字符串表示形式。
toString() - 类 javax.swing.event.ListSelectionEvent 中的方法
返回显示并标识此对象的属性的 String。
toString() - 类 javax.swing.event.TreeModelEvent 中的方法
返回显示和标识此对象属性的字符串。
toString() - 类 javax.swing.filechooser.FileNameExtensionFilter 中的方法
返回 FileNameExtensionFilter 的字符串表示形式。
toString() - 类 javax.swing.GroupLayout 中的方法
返回此 GroupLayout 的字符串表示形式。
toString() - 类 javax.swing.ImageIcon 中的方法
返回此图像的字符串表示形式。
toString() - 类 javax.swing.JList.DropLocation 中的方法
返回此放置位置的字符串表示形式。
toString() - 类 javax.swing.JTable.DropLocation 中的方法
返回此放置位置的字符串表示形式。
toString() - 类 javax.swing.JTree.DropLocation 中的方法
返回此放置位置的字符串表示形式。
toString() - 类 javax.swing.LookAndFeel 中的方法
返回显示和标识此对象属性的字符串。
toString() - 类 javax.swing.plaf.synth.ColorType 中的方法
返回此 ColorType 的文本描述。
toString() - 类 javax.swing.plaf.synth.Region 中的方法
返回 Region 的名称。
toString() - 类 javax.swing.RepaintManager 中的方法
返回一个显示并标记此对象属性的字符串。
toString() - 类 javax.swing.SizeRequirements 中的方法
返回一个描述最小、首选和最大大小以及对齐方式要求的字符串。
toString(TableModel, int, int) - 类 javax.swing.table.TableStringConverter 中的方法
返回指定位置处值的字符串表示形式。
toString() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
将该元素转换为字符串。
toString() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
返回更改事件的字符串表示形式。
toString() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
将该元素转换为字符串。
toString() - 类 javax.swing.text.DefaultCaret 中的方法
toString() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
将元素转换为字符串。
toString() - 类 javax.swing.text.html.CSS.Attribute 中的方法
属性的字符串表示形式。
toString() - 类 javax.swing.text.html.HTML.Attribute 中的方法
返回此属性的字符串表示形式。
toString() - 类 javax.swing.text.html.HTML.Tag 中的方法
返回该标记的字符串表示形式。
toString() - 类 javax.swing.text.html.Option 中的方法
String 的表示形式为 label。
toString() - 类 javax.swing.text.html.parser.AttributeList 中的方法
toString() - 类 javax.swing.text.html.parser.ContentModel 中的方法
转换为字符串。
toString() - 类 javax.swing.text.html.parser.DTD 中的方法
返回此 DTD 的字符串表示形式。
toString() - 类 javax.swing.text.html.parser.Element 中的方法
转换为字符串。
toString() - 类 javax.swing.text.JTextComponent.DropLocation 中的方法
返回此放置位置的字符串表示形式。
toString() - 类 javax.swing.text.Position.Bias 中的方法
字符串表示形式
toString() - 类 javax.swing.text.Segment 中的方法
将 segment 转换为 String。
toString() - 类 javax.swing.text.SimpleAttributeSet 中的方法
将属性集转换为 String。
toString() - 类 javax.swing.text.StyleConstants 中的方法
返回字符串表示形式。
toString() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
将样式转换成为字符串。
toString() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
返回表示键/值对的字符串
toString() - 类 javax.swing.text.StyleContext 中的方法
将 StyleContext 转换成为 String。
toString() - 类 javax.swing.text.TabSet 中的方法
返回此 tab 集合的字符串表示形式。
toString() - 类 javax.swing.text.TabStop 中的方法
toString() - 类 javax.swing.TransferHandler.DropLocation 中的方法
返回此放置位置的字符串表示形式。
toString() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回将 toString() 发送到此节点的用户对象的结果，如果此节点没有用户对象，则返回 null。
toString() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回显示并标识此对象属性的字符串。
toString() - 类 javax.swing.tree.TreePath 中的方法
返回一个显示并标识此对象属性的字符串。
toString() - 类 javax.swing.UIManager.LookAndFeelInfo 中的方法
返回一个显示并标识此对象属性的字符串。
toString() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
返回显示和标识此对象属性的字符串。
toString() - 类 javax.swing.undo.CompoundEdit 中的方法
返回一个显示并标识此对象属性的字符串。
toString() - 类 javax.swing.undo.UndoableEditSupport 中的方法
返回显示和标识此对象属性的字符串。
toString() - 类 javax.swing.undo.UndoManager 中的方法
返回显示和标识此对象属性的字符串。
toString() - 类 javax.tools.SimpleJavaFileObject 中的方法
toString() - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法
以有助于调试的格式返回此对象的字符串表示形式。
toString() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
以有助于调试的格式返回此对象的字符串表示形式。
toString() - 异常 javax.xml.bind.JAXBException 中的方法
返回此 JAXBException 的简短描述。
toString() - 异常 javax.xml.bind.TypeConstraintException 中的方法
返回此 TypeConstraintException 的简短描述。
toString() - 类 javax.xml.crypto.dsig.spec.XPathType.Filter 中的方法
返回操作的字符串形式。
toString() - 类 javax.xml.crypto.KeySelector.Purpose 中的方法
返回此用途的字符串表示形式（“sign”、“verify”、“encrypt”或“decrypt”）。
toString() - 类 javax.xml.datatype.DatatypeConstants.Field 中的方法
以英文返回字段名称。
toString() - 类 javax.xml.datatype.Duration 中的方法
返回此 Duration Object 的 String 表示形式。
toString() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回此 XMLGregorianCalendar Object 的 String 表示形式。
toString() - 类 javax.xml.namespace.QName 中的方法
此 QName 的 String 表示形式。
toString() - 异常 org.ietf.jgss.GSSException 中的方法
返回主要和次要状态码的文本表示形式。
toString() - 接口 org.ietf.jgss.GSSName 中的方法
返回 GSSName 对象的文本表示形式。
toString() - 类 org.ietf.jgss.Oid 中的方法
返回 oid 用句点符号分隔的整数组件的字符串表示形式。
toString(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
提供重写委托 CORBA 对象的 toString() 方法的实现。
toString() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回表示此 ObjectImpl 对象的 String 对象。
toString() - 异常 org.omg.CORBA.SystemException 中的方法
将此异常转换成有代表性的字符串。
toString() - 异常 org.xml.sax.SAXException 中的方法
重写 toString 以获取任何嵌入的异常。
toStub(Remote) - 类 java.rmi.server.RemoteObject 中的静态方法
返回作为参数传递的远程对象 obj 的 stub。
toStub() - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法
返回一个 IIOP stub。
toStub() - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法
返回此 RMIServer 对象的可序列化的 stub。
toStub() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
返回此服务器对象的可远程化的 stub。
toStub(Remote) - 接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 中的方法
PortableRemoteObject.toStub(java.rmi.Remote) 的委托调用。
toStub(Remote) - 类 javax.rmi.PortableRemoteObject 中的静态方法
返回给定服务器对象的 stub。
totalChildIndent - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
将缩进的总距离。
totalColumnWidth - 类 javax.swing.table.DefaultTableColumnModel 中的变量
所有列总宽度的本地缓存
totalMemory() - 类 java.lang.Runtime 中的方法
返回 Java 虚拟机中的内存总量。
toTitleCase(char) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为首字母大写。
toTitleCase(int) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为首字母大写。
TOTOP_TOLEFT - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从右下部开始，按列布置各页，然后向左上部展开。
TOTOP_TORIGHT - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从左下部开始，按列布置各页，然后向右上部展开。
toUnicode(String, int) - 类 java.net.IDN 中的静态方法
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 (ACE) 转换为 Unicode。
toUnicode(String) - 类 java.net.IDN 中的静态方法
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 ACE) 转换为 Unicode。
toUpperCase(char) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为大写。
toUpperCase(int) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为大写。
toUpperCase(Locale) - 类 java.lang.String 中的方法
使用给定 Locale 的规则将此 String 中的所有字符都转换为大写。
toUpperCase() - 类 java.lang.String 中的方法
使用默认语言环境的规则将此 String 中的所有字符都转换为大写。
toURI() - 类 java.io.File 中的方法
构造一个表示此抽象路径名的 file: URI。
toURI() - 类 java.net.URL 中的方法
返回与此 URL 等效的 URI。
toUri() - 接口 javax.tools.FileObject 中的方法
返回标识此文件对象的 URI。
toUri() - 类 javax.tools.ForwardingFileObject 中的方法
toUri() - 类 javax.tools.SimpleJavaFileObject 中的方法
toURL() - 类 java.io.File 中的方法
已过时。 此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。
toURL() - 类 java.net.URI 中的方法
根据此 URI 构造一个 URL。
toViewCoordinates(Dimension) - 类 javax.swing.JViewport 中的方法
将一个大小的像素坐标转换为视图坐标。
toViewCoordinates(Point) - 类 javax.swing.JViewport 中的方法
将一个点的像素坐标转换为视图坐标。
toXMLFormat() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回 this 实例的词汇表示形式。
toXMLString() - 类 javax.management.modelmbean.DescriptorSupport 中的方法
返回表示描述符的 XML 字符串。
TR - 类 javax.swing.text.html.HTML.Tag 中的静态变量
traceInstructions(boolean) - 类 java.lang.Runtime 中的方法
启用／禁用指令跟踪。
traceMethodCalls(boolean) - 类 java.lang.Runtime 中的方法
启用／禁用方法调用跟踪。
TRACK - 类 java.awt.event.AdjustmentEvent 中的静态变量
绝对跟踪调整类型。
Track - javax.sound.midi 中的 类
MIDI 音轨是一个可随其他音轨存储在标准 MIDI 文件中的独立的 MIDI 事件流（带时间戳的 MIDI 数据）。
trackBuffer - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
trackColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
tracker - 类 javax.swing.ImageIcon 中的静态变量
trackHighlight - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
trackHighlightColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
TRACKING - 类 java.awt.font.TextAttribute 中的静态变量
控制跟踪的属性键。
TRACKING_LOOSE - 类 java.awt.font.TextAttribute 中的静态变量
执行宽松跟踪。
TRACKING_TIGHT - 类 java.awt.font.TextAttribute 中的静态变量
执行紧密跟踪。
trackListener - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
trackListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
trackRect - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
trackRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
tracks - 类 javax.sound.midi.Sequence 中的变量
此 sequence 中的 MIDI 轨道。
trackWidth - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
TRADITIONAL_CHINESE - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
TRADITIONAL_HANZI - 类 java.awt.im.InputSubset 中的静态变量
编写繁体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的繁体中文汉字字集。
TRAILING - 类 java.awt.FlowLayout 中的静态变量
此值指示每行组件都应该与容器方向的结束边对齐，例如，对于从左到右的方向，则与右边对齐。
trailing(int) - 类 java.awt.font.TextHitInfo 中的静态方法
在指定 charIndex 处的字符的结尾边上创建一个 TextHitInfo。
TRAILING - 类 javax.swing.border.TitledBorder 中的静态变量
从左到右排列时将标题文本置于边框线的右边，从右到左排列时将标题文本置于边框线的左边。
TRAILING - 接口 javax.swing.SwingConstants 中的静态变量
标识使用从左到右和从右到左的语言的文本结束边。
TRANSACTION_MODE - org.omg.CORBA 中的 异常
如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
TRANSACTION_MODE() - 异常 org.omg.CORBA.TRANSACTION_MODE 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(String) - 异常 org.omg.CORBA.TRANSACTION_MODE 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_MODE 的构造方法
使用指定次要代码和完成状态构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(String, int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_MODE 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_MODE 异常。
TRANSACTION_NONE - 接口 java.sql.Connection 中的静态变量
指示事务不受支持的常量。
TRANSACTION_READ_COMMITTED - 接口 java.sql.Connection 中的静态变量
指示不可以发生脏读的常量；不可重复读和虚读可以发生。
TRANSACTION_READ_UNCOMMITTED - 接口 java.sql.Connection 中的静态变量
指示可以发生脏读 (dirty read)、不可重复读和虚读 (phantom read) 的常量。
TRANSACTION_REPEATABLE_READ - 接口 java.sql.Connection 中的静态变量
指示不可以发生脏读和不可重复读的常量；虚读可以发生。
TRANSACTION_REQUIRED - org.omg.CORBA 中的 异常
此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
TRANSACTION_REQUIRED() - 异常 org.omg.CORBA.TRANSACTION_REQUIRED 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(String) - 异常 org.omg.CORBA.TRANSACTION_REQUIRED 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_REQUIRED 的构造方法
使用指定次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(String, int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_REQUIRED 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_ROLLEDBACK - org.omg.CORBA 中的 异常
当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
TRANSACTION_ROLLEDBACK() - 异常 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(String) - 异常 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的构造方法
使用指定次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(String, int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_SERIALIZABLE - 接口 java.sql.Connection 中的静态变量
指示不可以发生脏读、不可重复读和虚读的常量。
TRANSACTION_UNAVAILABLE - org.omg.CORBA 中的 异常
当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE() - 异常 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(String) - 异常 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的构造方法
使用指定次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(String, int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。
TransactionalWriter - javax.sql.rowset.spi 中的 接口
一个专用接口，用来方便地扩展标准 SyncProvider 抽象类以便拥有细粒度的事务控制。
TransactionRequiredException - javax.transaction 中的 异常
此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
TransactionRequiredException() - 异常 javax.transaction.TransactionRequiredException 的构造方法
TransactionRequiredException(String) - 异常 javax.transaction.TransactionRequiredException 的构造方法
TransactionRolledbackException - javax.transaction 中的 异常
此异常指示与请求处理关联的事务已回滚，或已标记为回滚。
TransactionRolledbackException() - 异常 javax.transaction.TransactionRolledbackException 的构造方法
TransactionRolledbackException(String) - 异常 javax.transaction.TransactionRolledbackException 的构造方法
TransactionService - org.omg.IOP 中的 接口
org/omg/IOP/TransactionService.java。
Transferable - java.awt.datatransfer 中的 接口
定义为传输操作提供数据所使用的类的接口。
transferable - 类 java.awt.dnd.DropTargetContext.TransferableProxy 中的变量
封装的 Transferable 对象。
transferablesFlavorsChanged() - 类 java.awt.dnd.DragSourceContext 中的方法
通知同位体该 Transferable 的 DataFlavor 已改变。
transferFocus() - 类 java.awt.Component 中的方法
将焦点转移到下一个组件，就好像此 Component 曾是焦点所有者。
transferFocusBackward() - 类 java.awt.Component 中的方法
将焦点转移到前一个组件，就好像此 Component 曾是焦点所有者。
transferFocusBackward() - 类 java.awt.Container 中的方法
transferFocusDownCycle() - 类 java.awt.Container 中的方法
将焦点向下传输一个焦点遍历循环。
transferFocusUpCycle() - 类 java.awt.Component 中的方法
将焦点向上转移一个焦点遍历循环。
transferFrom(ReadableByteChannel, long, long) - 类 java.nio.channels.FileChannel 中的方法
将字节从给定的可读取字节通道传输到此通道的文件中。
TransferHandler - javax.swing 中的 类
此类用于处理往返于 Swing 组件的 Transferable 的传输。
TransferHandler(String) - 类 javax.swing.TransferHandler 的构造方法
构造一个通过剪贴板或拖放操作可以将 Java Bean 属性从一个组件传输到另一个组件的传输处理程序。
TransferHandler() - 类 javax.swing.TransferHandler 的构造方法
子类的便捷构造方法。
TransferHandler.DropLocation - javax.swing 中的 类
表示放置的数据 (dropped data) 应该插入的位置。
TransferHandler.DropLocation(Point) - 类 javax.swing.TransferHandler.DropLocation 的构造方法
构造给定点的放置位置。
TransferHandler.TransferSupport - javax.swing 中的 类
此类封装剪贴板或拖放传输的所有相关详细信息，并且还允许自定义拖放过程的各方面。
TransferHandler.TransferSupport(Component, Transferable) - 类 javax.swing.TransferHandler.TransferSupport 的构造方法
使用给定组件和 Transferable 创建一个 TransferSupport，对于该 TransferSupport isDrop() 返回 false。
transferTo(long, long, WritableByteChannel) - 类 java.nio.channels.FileChannel 中的方法
将字节从此通道的文件传输到给定的可写入字节通道。
transferType - 类 java.awt.image.ColorModel 中的变量
用于表示像素值的数组的数据类型。
TRANSFORM - 类 java.awt.font.TextAttribute 中的静态变量
字体转换的属性键。
transform(Point2D, Point2D) - 类 java.awt.geom.AffineTransform 中的方法
变换指定的 ptSrc 并将结果存储在 ptDst 中。
transform(Point2D[], int, Point2D[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换点对象数组。
transform(float[], int, float[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换浮点坐标数组。
transform(double[], int, double[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换双精度坐标数组。
transform(float[], int, double[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换浮点坐标数组，并将结果存储在 double 数组中。
transform(double[], int, float[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换双精度坐标数组，并将结果存储在 float 数组中。
transform(AffineTransform) - 类 java.awt.geom.Area 中的方法
使用指定的 AffineTransform 变换此 Area 的几何形状。
transform(AffineTransform) - 类 java.awt.geom.Path2D.Double 中的方法
使用指定的 AffineTransform 变换此路径的几何形状。
transform(AffineTransform) - 类 java.awt.geom.Path2D.Float 中的方法
使用指定的 AffineTransform 变换此路径的几何形状。
transform(AffineTransform) - 类 java.awt.geom.Path2D 中的方法
使用指定的 AffineTransform 变换此路径的几何形状。
transform(AffineTransform) - 类 java.awt.Graphics2D 中的方法
根据“最后指定首先应用”规则，使用此 Graphics2D 中的 Transform 组合 AffineTransform 对象。
transform(ClassLoader, String, Class<?>, ProtectionDomain, byte[]) - 接口 java.lang.instrument.ClassFileTransformer 中的方法
此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。
Transform - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Transform 元素的表示形式。
transform(Data, XMLCryptoContext) - 接口 javax.xml.crypto.dsig.Transform 中的方法
使用底层转换算法对指定数据进行转换。
transform(Data, XMLCryptoContext, OutputStream) - 接口 javax.xml.crypto.dsig.Transform 中的方法
使用底层转换算法对指定数据进行转换。
transform(Source, Result) - 类 javax.xml.transform.Transformer 中的方法
将 XML Source 转换为 Result。
TransformAttribute - java.awt.font 中的 类
TransformAttribute 类为转换提供一个不可变的包装器，使其可以安全地作为属性使用。
TransformAttribute(AffineTransform) - 类 java.awt.font.TransformAttribute 的构造方法
包装指定的转换。
Transformer - javax.xml.transform 中的 类
此抽象类的实例能够将源树转换为结果树。
Transformer() - 类 javax.xml.transform.Transformer 的构造方法
默认构造方法受到有意保护。
TransformerConfigurationException - javax.xml.transform 中的 异常
指示严重的配置错误。
TransformerConfigurationException() - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
创建不带详细消息的新 TransformerConfigurationException。
TransformerConfigurationException(String) - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
创建带有指定为错误消息的 String 的新 TransformerConfigurationException。
TransformerConfigurationException(Throwable) - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
创建带有错误的给定 Exception 基本原因的新 TransformerConfigurationException。
TransformerConfigurationException(String, Throwable) - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
创建带有给定 Exception 基本原因和详细消息的新 TransformerConfigurationException。
TransformerConfigurationException(String, SourceLocator) - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
从消息和 Locator 创建新 TransformerConfigurationException。
TransformerConfigurationException(String, SourceLocator, Throwable) - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
包装了 TransformerConfigurationException 中的现有异常。
TransformerException - javax.xml.transform 中的 异常
此类指定了转换过程中发生的异常条件。
TransformerException(String) - 异常 javax.xml.transform.TransformerException 的构造方法
创建一个新的 TransformerException。
TransformerException(Throwable) - 异常 javax.xml.transform.TransformerException 的构造方法
创建一个包装了现有异常的新 TransformerException。
TransformerException(String, Throwable) - 异常 javax.xml.transform.TransformerException 的构造方法
包装 TransformerException 中的一个现有异常。
TransformerException(String, SourceLocator) - 异常 javax.xml.transform.TransformerException 的构造方法
从消息和 Locator 创建一个新 TransformerException。
TransformerException(String, SourceLocator, Throwable) - 异常 javax.xml.transform.TransformerException 的构造方法
包装了 TransformerException 中的现有异常。
TransformerFactory - javax.xml.transform 中的 类
TransformerFactory 实例可用于创建 Transformer 和 Templates 对象。
TransformerFactory() - 类 javax.xml.transform.TransformerFactory 的构造方法
默认构造方法受到有意保护。
TransformerFactoryConfigurationError - javax.xml.transform 中的 错误
当通过 Transformer Factories 进行的配置存在问题时抛出此异常。
TransformerFactoryConfigurationError() - 错误 javax.xml.transform.TransformerFactoryConfigurationError 的构造方法
创建不带详细消息的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(String) - 错误 javax.xml.transform.TransformerFactoryConfigurationError 的构造方法
创建带有指定为错误消息的 String 的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(Exception) - 错误 javax.xml.transform.TransformerFactoryConfigurationError 的构造方法
创建带有错误的给定 Exception 基本原因的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(Exception, String) - 错误 javax.xml.transform.TransformerFactoryConfigurationError 的构造方法
创建带有给定 Exception 基本原因和详细消息的新 TransformerFactoryConfigurationError。
TransformerHandler - javax.xml.transform.sax 中的 接口
侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。
TransformException - javax.xml.crypto.dsig 中的 异常
指示执行转换算法时出现异常的异常条件。
TransformException() - 异常 javax.xml.crypto.dsig.TransformException 的构造方法
构造用 null 作为其详细消息的新 TransformException。
TransformException(String) - 异常 javax.xml.crypto.dsig.TransformException 的构造方法
构造带有指定详细消息的新 TransformException。
TransformException(String, Throwable) - 异常 javax.xml.crypto.dsig.TransformException 的构造方法
构造带指定详细消息和 cause 的新 TransformException。
TransformException(Throwable) - 异常 javax.xml.crypto.dsig.TransformException 的构造方法
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 TransformException（它通常包含 cause 的类和详细消息）。
TransformParameterSpec - javax.xml.crypto.dsig.spec 中的 接口
用于 Transform 算法的算法参数规范。
TransformService - javax.xml.crypto.dsig 中的 类
转换算法和规范算法的服务提供者接口。
TransformService() - 类 javax.xml.crypto.dsig.TransformService 的构造方法
默认的构造方法，由子类调用。
TRANSIENT - 类 java.lang.reflect.Modifier 中的静态变量
表示 transient 修饰符的 int 的值。
TRANSIENT - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是临时的。
TRANSIENT - org.omg.CORBA 中的 异常
当 ORB 试图到达某一对象但失败时，抛出此异常。
TRANSIENT() - 异常 org.omg.CORBA.TRANSIENT 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSIENT 异常。
TRANSIENT(String) - 异常 org.omg.CORBA.TRANSIENT 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSIENT 异常。
TRANSIENT(int, CompletionStatus) - 异常 org.omg.CORBA.TRANSIENT 的构造方法
使用指定次要代码和完成状态构造一个 TRANSIENT 异常。
TRANSIENT(String, int, CompletionStatus) - 异常 org.omg.CORBA.TRANSIENT 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 TRANSIENT 异常。
TRANSIENT - 类 org.omg.PortableServer.LifespanPolicyValue 中的静态变量
translate(int, int) - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
translate(double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与平移变换。
translate(int, int) - 类 java.awt.Graphics 中的方法
将图形上下文的原点平移到当前坐标系中的点 (x, y)。
translate(int, int) - 类 java.awt.Graphics2D 中的方法
将 Graphics2D 上下文的原点平移到当前坐标系中的点 (x, y)。
translate(double, double) - 类 java.awt.Graphics2D 中的方法
将当前 Graphics2D Transform 与平移转换连接。
translate(int, int) - 类 java.awt.Point 中的方法
平移 (x,y) 位置的点，沿 x 轴平移 dx，沿 y 轴平移 dy，移动后得到点 (x+dx,y+dy)。
translate(int, int) - 类 java.awt.Polygon 中的方法
对 Polygon 的顶点进行平移，沿 x 轴移动 deltaX，沿 y 移动 deltaY。
translate(int, int) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 沿 X 坐标轴向右，沿 Y 坐标轴向下平移指定距离。
translate(int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.translate。
translateHTMLToCSS(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
将 HTML 属性集合转换为对等的 CSS 属性集合。
translateKey(Key) - 类 java.security.KeyFactory 中的方法
将提供者可能未知或不受信任的密钥对象转换成此密钥工厂对应的密钥对象。
translateKey(SecretKey) - 类 javax.crypto.SecretKeyFactory 中的方法
将一个密钥对象（其提供者未知或可能不受信任）转换为此秘密密钥工厂的相应密钥对象。
translatePoint(int, int) - 类 java.awt.event.MouseEvent 中的方法
通过将事件坐标加上指定的 x（水平）和 y（垂直）偏移量，将事件的坐标平移到新位置。
TRANSLUCENT - 接口 java.awt.Transparency 中的静态变量
表示包含或可能包含位于 0.0 和 1.0（含两者）之间的任意 alpha 值的图像数据。
Transmitter - javax.sound.midi 中的 接口
一个 Transmitter，其将 MidiEvent 对象发送至一个或多个 Receivers。
transparency - 类 java.awt.image.VolatileImage 中的变量
创建此图像所使用的透明度值。
Transparency - java.awt 中的 接口
Transparency 接口定义用于实现类的通用透明模式。
TRANSPORT_RETRY - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/TRANSPORT_RETRY.java。
TrayIcon - java.awt 中的 类
TrayIcon 对象表示可以添加到系统托盘的托盘图标。
TrayIcon(Image) - 类 java.awt.TrayIcon 的构造方法
创建带有指定图像的 TrayIcon。
TrayIcon(Image, String) - 类 java.awt.TrayIcon 的构造方法
创建带有指定图像和工具提示文本的 TrayIcon。
TrayIcon(Image, String, PopupMenu) - 类 java.awt.TrayIcon 的构造方法
创建带指定图像、工具提示和弹出菜单的 TrayIcon。
TrayIcon.MessageType - java.awt 中的 枚举
MessageType 确定哪个图标将显示在消息标题中，以及消息根据显示生成的可能的系统声音。
TREE - 类 javax.accessibility.AccessibleRole 中的静态变量
用于将层次结构信息呈现给用户的对象。
tree - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
要在其中进行绘制的组件。
TREE - 类 javax.swing.plaf.synth.Region 中的静态变量
Tree 的 region。
tree - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
JTree 实例侦听。
TREE_CELL - 类 javax.swing.plaf.synth.Region 中的静态变量
用于某一单元格的 Tree 的 region。
TREE_MODEL_PROPERTY - 类 javax.swing.JTree 中的静态变量
treeModel 的绑定属性名称。
TreeCellEditor - javax.swing.tree 中的 接口
向 CellEditor 添加配置树中编辑器必需的扩展。
TreeCellRenderer - javax.swing.tree 中的 接口
定义针对显示树节点的对象的要求。
treeCollapsed(TreeExpansionEvent) - 接口 javax.swing.event.TreeExpansionListener 中的方法
每当树中的一个项被折叠时调用。
treeCollapsed(TreeExpansionEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树折叠通知。
treeCollapsed(TreeExpansionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler 中的方法
每当树中的项被折叠时调用。
treeDidChange() - 类 javax.swing.JTree 中的方法
当树被更改得足以需要调整边界大小，但还不足以需要移除展开的节点集（例如，展开或折叠节点，或者将节点插入到树）时发送。
treeExpanded(TreeExpansionEvent) - 接口 javax.swing.event.TreeExpansionListener 中的方法
每当树中的一个项被扩展时调用。
treeExpanded(TreeExpansionEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树模型展开通知。
treeExpanded(TreeExpansionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler 中的方法
每当树中的项被展开时调用。
TreeExpansionEvent - javax.swing.event 中的 类
用于标识树中的单个路径的事件。
TreeExpansionEvent(Object, TreePath) - 类 javax.swing.event.TreeExpansionEvent 的构造方法
构造一个 TreeExpansionEvent 对象。
TreeExpansionListener - javax.swing.event 中的 接口
当树扩展或折叠某一节点时获得通知的侦听器。
TreeMap<K,V> - java.util 中的 类
基于红黑树（Red-Black tree）的 NavigableMap 实现。
TreeMap() - 类 java.util.TreeMap 的构造方法
使用键的自然顺序构造一个新的、空的树映射。
TreeMap(Comparator<? super K>) - 类 java.util.TreeMap 的构造方法
构造一个新的、空的树映射，该映射根据给定比较器进行排序。
TreeMap(Map<? extends K, ? extends V>) - 类 java.util.TreeMap 的构造方法
构造一个与给定映射具有相同映射关系的新的树映射，该映射根据其键的自然顺序 进行排序。
TreeMap(SortedMap<K, ? extends V>) - 类 java.util.TreeMap 的构造方法
构造一个与指定有序映射具有相同映射关系和相同排序顺序的新的树映射。
treeModel - 类 javax.swing.JTree 中的变量
定义此对象显示的树的模型。
treeModel - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
用于确定要显示的内容。
treeModel - 类 javax.swing.tree.AbstractLayoutCache 中的变量
提供信息的模型。
TreeModel - javax.swing.tree 中的 接口
JTree 所使用的模型。
TreeModelEvent - javax.swing.event 中的 类
封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
TreeModelEvent(Object, Object[], int[], Object[]) - 类 javax.swing.event.TreeModelEvent 的构造方法
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 Object 数组。
TreeModelEvent(Object, TreePath, int[], Object[]) - 类 javax.swing.event.TreeModelEvent 的构造方法
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 TreePath 对象。
TreeModelEvent(Object, Object[]) - 类 javax.swing.event.TreeModelEvent 的构造方法
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 Object 数组。
TreeModelEvent(Object, TreePath) - 类 javax.swing.event.TreeModelEvent 的构造方法
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 TreePath 对象。
TreeModelListener - javax.swing.event 中的 接口
定义侦听 TreeModel 中更改的对象的接口。
treeModelListener - 类 javax.swing.JTree 中的变量
更新 expandedState。
TreeNode - javax.swing.tree 中的 接口
定义可以用作 JTree 中树节点的对象所需的要求。
treeNodesChanged(TreeModelEvent) - 接口 javax.swing.event.TreeModelListener 中的方法
在已经以某种方式更改节点（或同级节点集）后调用。
treeNodesChanged(TreeModelEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树模型节点更改通知。
treeNodesChanged(TreeModelEvent) - 类 javax.swing.JTree.TreeModelHandler 中的方法
treeNodesChanged(TreeModelEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 中的方法
treeNodesChanged(TreeModelEvent) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
在某个节点（或一组兄弟节点）以某种方式更改后进行调用。
treeNodesChanged(TreeModelEvent) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
在已经以某种方式更改节点（或同级节点集）后调用。
treeNodesChanged(TreeModelEvent) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
按某种方式更改节点（或兄弟节点集）后进行调用。
treeNodesInserted(TreeModelEvent) - 接口 javax.swing.event.TreeModelListener 中的方法
在已将节点插入树中以后调用。
treeNodesInserted(TreeModelEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树模型节点更改通知。
treeNodesInserted(TreeModelEvent) - 类 javax.swing.JTree.TreeModelHandler 中的方法
treeNodesInserted(TreeModelEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 中的方法
treeNodesInserted(TreeModelEvent) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
将节点插入树之后进行调用。
treeNodesInserted(TreeModelEvent) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
将节点插入树之后进行调用。
treeNodesInserted(TreeModelEvent) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
将节点插入树后进行调用。
treeNodesRemoved(TreeModelEvent) - 接口 javax.swing.event.TreeModelListener 中的方法
在已从树中移除节点后调用。
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树模型节点更改通知。
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.JTree.TreeModelHandler 中的方法
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 中的方法
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
将节点从树移除之后进行调用。
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
将节点从树移除之后进行调用。
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
将节点从树删除后进行调用。
TreePath - javax.swing.tree 中的 类
表示节点的路径。
TreePath(Object[]) - 类 javax.swing.tree.TreePath 的构造方法
根据 Objects 的数组构造路径，并根据树的数据模型的返回情况，唯一地标识树的根到指定节点的路径。
TreePath(Object) - 类 javax.swing.tree.TreePath 的构造方法
构造仅包含单个元素的 TreePath。
TreePath(TreePath, Object) - 类 javax.swing.tree.TreePath 的构造方法
构造一个新的 TreePath，它是以 lastElement 结束的 parent 标识的路径。
TreePath(Object[], int) - 类 javax.swing.tree.TreePath 的构造方法
构造一个具有长度为 length 的标识路径组件的新 TreePath。
TreePath() - 类 javax.swing.tree.TreePath 的构造方法
主要为以不同方式表示路径的子类提供。
TreeSelectionEvent - javax.swing.event 中的 类
描述当前选择中的更改的事件。
TreeSelectionEvent(Object, TreePath[], boolean[], TreePath, TreePath) - 类 javax.swing.event.TreeSelectionEvent 的构造方法
表示 TreeSelectionModel 选择中的更改。
TreeSelectionEvent(Object, TreePath, boolean, TreePath, TreePath) - 类 javax.swing.event.TreeSelectionEvent 的构造方法
表示 TreeSelectionModel 选择中的更改。
TreeSelectionListener - javax.swing.event 中的 接口
当 TreeSelectionModel 中的选择发生更改时收到通知的侦听器。
treeSelectionModel - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
维护选择的模型。
treeSelectionModel - 类 javax.swing.tree.AbstractLayoutCache 中的变量
选择模型。
TreeSelectionModel - javax.swing.tree 中的 接口
此接口表示树选择组件的当前状态。
TreeSet<E> - java.util 中的 类
基于 TreeMap 的 NavigableSet 实现。
TreeSet() - 类 java.util.TreeSet 的构造方法
构造一个新的空 set，该 set 根据其元素的自然顺序进行排序。
TreeSet(Comparator<? super E>) - 类 java.util.TreeSet 的构造方法
构造一个新的空 TreeSet，它根据指定比较器进行排序。
TreeSet(Collection<? extends E>) - 类 java.util.TreeSet 的构造方法
构造一个包含指定 collection 元素的新 TreeSet，它按照其元素的自然顺序进行排序。
TreeSet(SortedSet<E>) - 类 java.util.TreeSet 的构造方法
构造一个与指定有序 set 具有相同映射关系和相同排序的新 TreeSet。
treeState - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
负责处理大小和展开问题的对象。
treeStructureChanged(TreeModelEvent) - 接口 javax.swing.event.TreeModelListener 中的方法
在树结构中从某个给定节点开始向下的地方发生彻底更改之后调用。
treeStructureChanged(TreeModelEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树模型结构更改通知。
treeStructureChanged(TreeModelEvent) - 类 javax.swing.JTree.TreeModelHandler 中的方法
treeStructureChanged(TreeModelEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 中的方法
treeStructureChanged(TreeModelEvent) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
树彻底更改给定节点以下的结构之后进行调用。
treeStructureChanged(TreeModelEvent) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
树彻底更改给定节点以下的结构之后进行调用。
treeStructureChanged(TreeModelEvent) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
树彻底更改给定节点以下的结构之后进行调用。
TreeUI - javax.swing.plaf 中的 类
JTree 的可插入外观界面。
TreeUI() - 类 javax.swing.plaf.TreeUI 的构造方法
treeWillCollapse(TreeExpansionEvent) - 接口 javax.swing.event.TreeWillExpandListener 中的方法
每当树中的一个节点将被折叠时调用。
treeWillExpand(TreeExpansionEvent) - 接口 javax.swing.event.TreeWillExpandListener 中的方法
每当树中的一个节点将被扩展时调用。
TreeWillExpandListener - javax.swing.event 中的 接口
当树扩展或折叠某一节点时获得通知的侦听器。
trim() - 类 java.lang.String 中的方法
返回字符串的副本，忽略前导空白和尾部空白。
trimEdits(int, int) - 类 javax.swing.undo.UndoManager 中的方法
移除指定范围内的编辑。
trimForLimit() - 类 javax.swing.undo.UndoManager 中的方法
以下一个编辑的索引为中心，将已排队编辑的数量减少到限制的大小范围内。
trimToSize() - 类 java.lang.StringBuffer 中的方法
trimToSize() - 类 java.util.ArrayList 中的方法
将此 ArrayList 实例的容量调整为列表的当前大小。
trimToSize() - 类 java.util.Vector 中的方法
对此向量的容量进行微调，使其等于向量的当前大小。
trimToSize() - 类 javax.swing.DefaultListModel 中的方法
对此列表的容量进行裁剪，使其等于此列表的当前大小。
TRUE - 类 java.lang.Boolean 中的静态变量
对应基值 true 的 Boolean 对象。
TRUE - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "true"，某些属性的可能值。
TRUE - 接口 java.util.jar.Pack200.Unpacker 中的静态变量
字符串 "true"，某些属性的可能值。
TRUETYPE_FONT - 类 java.awt.Font 中的静态变量
标识 TRUETYPE 类型的字体资源。
truncate(long) - 类 java.nio.channels.FileChannel 中的方法
将此通道的文件截取为给定大小。
truncate(long) - 接口 java.sql.Blob 中的方法
截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。
truncate(long) - 接口 java.sql.Clob 中的方法
截取此 Clob 指定的 CLOB 值，使其长度为 len 个字符。
truncate(long) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。
truncate(long) - 类 javax.sql.rowset.serial.SerialClob 中的方法
截取此 SerialClob 对象所表示的 CLOB 值，使其长度为 len 个字符。
TRUNCATED - 类 javax.accessibility.AccessibleState 中的静态变量
该状态指示文本被边界矩形截取，并且有些文本不显示在屏幕上。
TrustAnchor - java.security.cert 中的 类
一个信任定位点或最受信任的证书颁发机构 (CA)。
TrustAnchor(X509Certificate, byte[]) - 类 java.security.cert.TrustAnchor 的构造方法
创建具有指定 X509Certificate 和可选 nameConstraints 的 TrustAnchor 实例，在验证 X.509 证书路径时，该 nameConstraints 用作额外的限制条件。
TrustAnchor(X500Principal, PublicKey, byte[]) - 类 java.security.cert.TrustAnchor 的构造方法
创建一个 TrustAnchor 实例，其中以 X500Principal 和公钥的形式指定最受信任的 CA。
TrustAnchor(String, PublicKey, byte[]) - 类 java.security.cert.TrustAnchor 的构造方法
创建一个 TrustAnchor 实例，其中以不同的名称和公钥的形式指定最受信任的 CA。
TrustManager - javax.net.ssl 中的 接口
这是用于 JSSE 信任管理器的基接口。
TrustManagerFactory - javax.net.ssl 中的 类
此类充当基于信任材料源的信任管理器的工厂。
TrustManagerFactory(TrustManagerFactorySpi, Provider, String) - 类 javax.net.ssl.TrustManagerFactory 的构造方法
创建 TrustManagerFactory 对象。
TrustManagerFactorySpi - javax.net.ssl 中的 类
此类为 TrustManagerFactory 类定义了服务提供者接口 (SPI)。
TrustManagerFactorySpi() - 类 javax.net.ssl.TrustManagerFactorySpi 的构造方法
tryAcquire(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试在独占模式下获取。
tryAcquire(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图在独占模式下获取对象状态。
tryAcquire() - 类 java.util.concurrent.Semaphore 中的方法
仅在调用时此信号量存在一个可用许可，才从信号量获取许可。
tryAcquire(long, TimeUnit) - 类 java.util.concurrent.Semaphore 中的方法
如果在给定的等待时间内，此信号量有可用的许可并且当前线程未被中断，则从此信号量获取一个许可。
tryAcquire(int) - 类 java.util.concurrent.Semaphore 中的方法
仅在调用时此信号量中有给定数目的许可时，才从此信号量中获取这些许可。
tryAcquire(int, long, TimeUnit) - 类 java.util.concurrent.Semaphore 中的方法
如果在给定的等待时间内此信号量有可用的所有许可，并且当前线程未被中断，则从此信号量获取给定数目的许可。
tryAcquireNanos(long, long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试以独占模式获取，如果被中断则中止，如果超过给定超时期则失败。
tryAcquireNanos(int, long) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图以独占模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。
tryAcquireShared(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试在共享模式下获取。
tryAcquireShared(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图在共享模式下获取对象状态。
tryAcquireSharedNanos(long, long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试以共享模式获取，如果被中断则中止，如果超过给定超时期则失败。
tryAcquireSharedNanos(int, long) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图以共享模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。
tryLock(long, long, boolean) - 类 java.nio.channels.FileChannel 中的方法
试图获取对此通道的文件给定区域的锁定。
tryLock() - 类 java.nio.channels.FileChannel 中的方法
试图获取对此通道的文件的独占锁定。
tryLock() - 接口 java.util.concurrent.locks.Lock 中的方法
仅在调用时锁为空闲状态才获取该锁。
tryLock(long, TimeUnit) - 接口 java.util.concurrent.locks.Lock 中的方法
如果锁在给定的等待时间内空闲，并且当前线程未被中断，则获取锁。
tryLock() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
仅在调用时锁未被另一个线程保持的情况下，才获取该锁。
tryLock(long, TimeUnit) - 类 java.util.concurrent.locks.ReentrantLock 中的方法
如果锁在给定等待时间内没有被另一个线程保持，且当前线程未被中断，则获取该锁。
tryLock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
仅当写入锁在调用期间未被另一个线程保持时获取读取锁。
tryLock(long, TimeUnit) - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取读取锁。
tryLock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
仅当写入锁在调用期间未被另一个线程保持时获取该锁。
tryLock(long, TimeUnit) - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取写入锁。
tryRelease(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试设置状态来反映独占模式下的释放。
tryRelease(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图设置状态来反映独占模式下的一个释放。
tryReleaseShared(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试设置状态来反映共享模式下的释放。
tryReleaseShared(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图设置状态来反映共享模式下的一个释放。
tryToLoadClass(String, ClassLoader) - 类 java.awt.datatransfer.DataFlavor 中的静态方法
试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。
TT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
TT_EOF - 类 java.io.StreamTokenizer 中的静态变量
指示已读到流末尾的常量。
TT_EOL - 类 java.io.StreamTokenizer 中的静态变量
指示已读到行末尾的常量。
TT_NUMBER - 类 java.io.StreamTokenizer 中的静态变量
指示已读到一个数字标记的常量。
TT_WORD - 类 java.io.StreamTokenizer 中的静态变量
指示已读到一个文字标记的常量。
TTL_DONT_CACHE - 类 java.util.ResourceBundle.Control 中的静态变量
不缓存已加载资源包实例的生存时间常量。
TTL_NO_EXPIRATION_CONTROL - 类 java.util.ResourceBundle.Control 中的静态变量
对缓存中已加载资源包实例禁用到期控制的生存时间常量。
ttype - 类 java.io.StreamTokenizer 中的变量
在调用 nextToken 方法之后，此字段将包含刚读取的标记的类型。
TUESDAY - 类 java.util.Calendar 中的静态变量
指示 Tuesday 的 Calendar.DAY_OF_WEEK 字段值。
TUMBLE - 类 javax.print.attribute.standard.Sides 中的静态变量
“双面短边”的别名（请参阅 TWO_SIDED_SHORT_EDGE）。
TUNE_REQUEST - 类 javax.sound.midi.ShortMessage 中的静态变量
TUNE_REQUEST 消息的状态字节（0xF6 或 246）。
TWO_SIDED_LONG_EDGE - 类 java.awt.JobAttributes.SidesType 中的静态变量
SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在长边上一样。
TWO_SIDED_LONG_EDGE - 类 javax.print.attribute.standard.Sides 中的静态变量
将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在长边上一样。
TWO_SIDED_SHORT_EDGE - 类 java.awt.JobAttributes.SidesType 中的静态变量
SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在短边上一样。
TWO_SIDED_SHORT_EDGE - 类 javax.print.attribute.standard.Sides 中的静态变量
将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在短边上一样。
TYPE - 类 java.lang.Boolean 中的静态变量
表示基本类型 boolean 的 Class 对象。
TYPE - 类 java.lang.Byte 中的静态变量
表示基本类型 byte 的 Class 实例。
TYPE - 类 java.lang.Character 中的静态变量
表示基本类型 char 的 Class 实例。
TYPE - 类 java.lang.Double 中的静态变量
表示基本类型 double 的 Class 实例。
TYPE - 类 java.lang.Float 中的静态变量
表示 float 基本类型的 Class 实例。
TYPE - 类 java.lang.Integer 中的静态变量
表示基本类型 int 的 Class 实例。
TYPE - 类 java.lang.Long 中的静态变量
表示基本类型 long 的 Class 实例。
Type - java.lang.reflect 中的 接口
Type 是 Java 编程语言中所有类型的公共高级接口。
TYPE - 类 java.lang.Short 中的静态变量
表示基本类型 short 的 Class 实例。
TYPE - 类 java.lang.Void 中的静态变量
表示对应于关键字 void 的伪类型的 Class 对象。
type() - 类 java.net.Proxy 中的方法
返回代理类型。
type - 类 javax.naming.event.NamingEvent 中的变量
包含此事件的类型。
type - 类 javax.sound.midi.MidiFileFormat 中的变量
MIDI 文件的类型。
type - 类 javax.swing.event.TableModelEvent 中的变量
type - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的变量
TYPE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
type - 类 javax.swing.text.html.parser.AttributeList 中的变量
type - 类 javax.swing.text.html.parser.ContentModel 中的变量
类型。
type - 类 javax.swing.text.html.parser.Element 中的变量
type - 类 javax.swing.text.html.parser.Entity 中的变量
TYPE - 接口 javax.xml.crypto.dsig.keyinfo.PGPData 中的静态变量
标识 PGPData KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#PGPData.可以将其指定为 RetrievalMethod 类的 type 参数值，以描述远程 PGPData 结构。
TYPE - 接口 javax.xml.crypto.dsig.keyinfo.X509Data 中的静态变量
标识 X509Data KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#X509Data。
TYPE - 接口 javax.xml.crypto.dsig.Manifest 中的静态变量
标识 Manifest 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。
TYPE - 接口 javax.xml.crypto.dsig.SignatureProperties 中的静态变量
标识 SignatureProperties 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。
TYPE - 接口 javax.xml.crypto.dsig.XMLObject 中的静态变量
标识 Object 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。
type() - 类 org.omg.CORBA._IDLTypeStub 中的方法
type() - 类 org.omg.CORBA.Any 中的方法
返回此 Any 对象中所包含元素的类型信息。
type(TypeCode) - 类 org.omg.CORBA.Any 中的方法
将此 Any 对象的 type 字段设置为给定的 TypeCode 对象，并清除其值。
type() - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
type() - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
type() - 类 org.omg.CORBA.CurrentHelper 中的静态方法
type() - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
type() - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
type() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 返回插入此 DynAny 对象的 TypeCode。
type() - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
type() - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
type() - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
type() - 接口 org.omg.CORBA.IDLTypeOperations 中的方法
type 属性描述源自 IDLType 的对象定义的类型。
type() - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
type() - 类 org.omg.CORBA.ObjectHelper 中的静态方法
type() - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
type() - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
type() - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
type() - 类 org.omg.CORBA.PolicyHelper 中的静态方法
type() - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
type() - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
type() - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
type() - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
type() - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
type() - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
type() - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.StringValueHelper 中的静态方法
type - 类 org.omg.CORBA.StructMember 中的变量
此 StructMember 对象所描述的 struct 成员的类型。
type() - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
type() - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
type - 类 org.omg.CORBA.UnionMember 中的变量
此 UnionMember 对象所描述的 union 成员的类型。
type() - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
type() - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
type() - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
type - 类 org.omg.CORBA.ValueMember 中的变量
此 value 成员的类型。
type() - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
type() - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
type() - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
type() - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
type() - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
type() - 类 org.omg.CosNaming.BindingHelper 中的静态方法
type() - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
type() - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
type() - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
type() - 类 org.omg.CosNaming.IstringHelper 中的静态方法
type() - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
type() - 类 org.omg.CosNaming.NameHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
type() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
返回与此 DynAny 对象关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回与此 DynAny 对象关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
type() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
type() - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
type() - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
type() - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
type() - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
type() - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
type() - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
type() - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
type() - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
type() - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
type() - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
type() - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
type() - 类 org.omg.IOP.IORHelper 中的静态方法
type() - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
type() - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
type() - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
type() - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
type() - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
type() - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
type() - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
type() - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
type() - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
type() - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
type() - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
type() - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
type() - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
TYPE1_FONT - 类 java.awt.Font 中的静态变量
标识 TYPE1 类型的字体资源。
type2name(int) - 类 javax.swing.text.html.parser.AttributeList 中的静态方法
TYPE_2CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 2 分量颜色空间。
TYPE_3BYTE_BGR - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 8 位 RGB 颜色分量的图像，对应于 Windows 风格的 BGR 颜色模型，具有用 3 字节存储的 Blue、Green 和 Red 三种颜色。
TYPE_3CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 3 分量颜色空间。
TYPE_4BYTE_ABGR - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 8 位 RGBA 颜色分量的图像，具有用 3 字节存储的 Blue、Green 和 Red 颜色以及 1 字节的 alpha。
TYPE_4BYTE_ABGR_PRE - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 8 位 RGBA 颜色分量的图像，具有用 3 字节存储的 Blue、Green 和 Red 颜色以及 1 字节的 alpha。
TYPE_4CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 4 分量颜色空间。
TYPE_5CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 5 分量颜色空间。
TYPE_6CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 6 分量颜色空间。
TYPE_7CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 7 分量颜色空间。
TYPE_8CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 8 分量颜色空间。
TYPE_9CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 9 分量颜色空间。
TYPE_ACLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 10 分量颜色空间。
TYPE_BCLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 11 分量颜色空间。
TYPE_BICUBIC - 类 java.awt.image.AffineTransformOp 中的静态变量
双三次插值类型。
TYPE_BILINEAR - 类 java.awt.image.AffineTransformOp 中的静态变量
双线性的插值类型。
TYPE_BYTE - 类 java.awt.image.DataBuffer 中的静态变量
无符号 byte 数据的标记
TYPE_BYTE_BINARY - 类 java.awt.image.BufferedImage 中的静态变量
表示一个不透明的以字节打包的 1、2 或 4 位图像。
TYPE_BYTE_GRAY - 类 java.awt.image.BufferedImage 中的静态变量
表示无符号 byte 灰度级图像（无索引）。
TYPE_BYTE_INDEXED - 类 java.awt.image.BufferedImage 中的静态变量
表示带索引的字节图像。
TYPE_CCLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 12 分量颜色空间。
TYPE_CMY - 类 java.awt.color.ColorSpace 中的静态变量
CMY 颜色空间的任意颜色系列。
TYPE_CMYK - 类 java.awt.color.ColorSpace 中的静态变量
CMYK 颜色空间的任意颜色系列。
TYPE_CUSTOM - 类 java.awt.image.BufferedImage 中的静态变量
没有识别出图像类型，因此它必定是一个自定义图像。
TYPE_DCLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 13 分量颜色空间。
type_def - 类 org.omg.CORBA.StructMember 中的变量
typedef，它表示此 StructMember 对象所描述的 struct 成员的 IDL 类型。
type_def - 类 org.omg.CORBA.UnionMember 中的变量
typedef，它表示此 UnionMember 对象描述的 union 成员的 IDL 类型。
type_def - 类 org.omg.CORBA.ValueMember 中的变量
typedef，它表示此 ValueMember 对象描述的 value 成员的 IDL 类型。
TYPE_DOUBLE - 类 java.awt.image.DataBuffer 中的静态变量
double 数据的标记。
TYPE_ECLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 14 分量颜色空间。
TYPE_FCLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 15 分量颜色空间。
TYPE_FLIP - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行关于某个坐标轴的镜像翻转操作，此操作将通常的右旋坐标系更改为左旋坐标系。
TYPE_FLOAT - 类 java.awt.image.DataBuffer 中的静态变量
float 数据的标记。
TYPE_FORWARD_ONLY - 接口 java.sql.ResultSet 中的静态变量
该常量指示光标只能向前移动的 ResultSet 对象的类型。
TYPE_GENERAL_ROTATION - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行任意角度的旋转操作。
TYPE_GENERAL_SCALE - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行常规缩放操作。
TYPE_GENERAL_TRANSFORM - 类 java.awt.geom.AffineTransform 中的静态变量
此常量指示此对象定义的变换执行输入坐标的任意转换操作。
TYPE_GRAY - 类 java.awt.color.ColorSpace 中的静态变量
GRAY 颜色空间的任意颜色系列。
TYPE_HLS - 类 java.awt.color.ColorSpace 中的静态变量
HLS 颜色空间的任意颜色系列。
TYPE_HSV - 类 java.awt.color.ColorSpace 中的静态变量
HSV 颜色空间的任意颜色系列。
type_id - 类 org.omg.IOP.IOR 中的变量
以 String 形式表示的类型 id。
TYPE_IDENTITY - 类 java.awt.geom.AffineTransform 中的静态变量
此常量指示此对象定义的变换是恒等变换。
TYPE_IMAGE_BUFFER - 类 java.awt.GraphicsDevice 中的静态变量
设备是图像缓冲区。
TYPE_INT - 类 java.awt.image.DataBuffer 中的静态变量
int 数据的标记。
TYPE_INT_ARGB - 类 java.awt.image.BufferedImage 中的静态变量
表示一个图像，它具有合成整数像素的 8 位 RGBA 颜色分量。
TYPE_INT_ARGB_PRE - 类 java.awt.image.BufferedImage 中的静态变量
表示一个图像，它具有合成整数像素的 8 位 RGBA 颜色分量。
TYPE_INT_BGR - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 8 位 RGB 颜色分量的图像，对应于 Windows 或 Solaris 风格的 BGR 颜色模型，具有打包为整数像素的 Blue、Green 和 Red 三种颜色。
TYPE_INT_RGB - 类 java.awt.image.BufferedImage 中的静态变量
表示一个图像，它具有合成整数像素的 8 位 RGB 颜色分量。
TYPE_Lab - 类 java.awt.color.ColorSpace 中的静态变量
Lab 颜色空间的任意颜色系列。
TYPE_Luv - 类 java.awt.color.ColorSpace 中的静态变量
Luv 颜色空间的任意颜色系列。
TYPE_MASK_ROTATION - 类 java.awt.geom.AffineTransform 中的静态变量
此常量是所有旋转标志位的位掩码。
TYPE_MASK_SCALE - 类 java.awt.geom.AffineTransform 中的静态变量
此常量是所有缩放标志位的位掩码。
TYPE_MISMATCH_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果对象的类型和与此对象相关联的参数的期望类型不兼容。
type_modifier() - 类 org.omg.CORBA.TypeCode 中的方法
返回一个常量，它指示此 TypeCode 对象所描述的 value 类型的修饰符。
TYPE_NEAREST_NEIGHBOR - 类 java.awt.image.AffineTransformOp 中的静态变量
最接近的邻插值类型。
TYPE_PRINTER - 类 java.awt.GraphicsDevice 中的静态变量
设备是打印机。
TYPE_QUADRANT_ROTATION - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还通过乘以 90 度的某个倍数执行象限旋转操作。
TYPE_RASTER_SCREEN - 类 java.awt.GraphicsDevice 中的静态变量
设备是光栅屏幕。
TYPE_RGB - 类 java.awt.color.ColorSpace 中的静态变量
RGB 颜色空间的任意颜色系列。
TYPE_SCROLL_INSENSITIVE - 接口 java.sql.ResultSet 中的静态变量
该常量指示可滚动但通常不受 ResultSet 底层数据更改影响的 ResultSet 对象的类型。
TYPE_SCROLL_SENSITIVE - 接口 java.sql.ResultSet 中的静态变量
该常量指示可滚动并且通常受 ResultSet 底层数据更改影响的 ResultSet 对象的类型。
TYPE_SHORT - 类 java.awt.image.DataBuffer 中的静态变量
有符号 short 数据的标记。
TYPE_TRANSLATION - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行平移操作。
TYPE_UNDEFINED - 类 java.awt.image.DataBuffer 中的静态变量
未定义数据的标记。
TYPE_UNIFORM_SCALE - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行统一缩放操作。
TYPE_USHORT - 类 java.awt.image.DataBuffer 中的静态变量
无符号 short 数据的标记
TYPE_USHORT_555_RGB - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 5-5-5 RGB 颜色分量（5 位 red、5 位 green、5 位 blue）的图像，不带 alpha。
TYPE_USHORT_565_RGB - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 5-6-5 RGB 颜色分量（5 位 red、6 位 green、5 位 blue）的图像，不带 alpha。
TYPE_USHORT_GRAY - 类 java.awt.image.BufferedImage 中的静态变量
表示一个无符号 short 灰度级图像（无索引）。
TYPE_XYZ - 类 java.awt.color.ColorSpace 中的静态变量
XYZ 颜色空间的任意颜色系列。
TYPE_YCbCr - 类 java.awt.color.ColorSpace 中的静态变量
YCbCr 颜色空间的任意颜色系列。
TYPE_Yxy - 类 java.awt.color.ColorSpace 中的静态变量
Yxy 颜色空间的任意颜色系列。
TypeCode - org.omg.CORBA 中的 类
用于有关特定 CORBA 数据类型的信息的容器。
TypeCode() - 类 org.omg.CORBA.TypeCode 的构造方法
TypeCodeHolder - org.omg.CORBA 中的 类
TypeCode 的 Holder。
TypeCodeHolder() - 类 org.omg.CORBA.TypeCodeHolder 的构造方法
构造一个新的 TypeCodeHolder 对象，将其 value 字段初始化为 null。
TypeCodeHolder(TypeCode) - 类 org.omg.CORBA.TypeCodeHolder 的构造方法
构造一个新的 TypeCodeHolder 对象，将其 value 字段初始化为给定的 TypeCode 对象。
TypeConstraintException - javax.xml.bind 中的 异常
此异常指示已检测到存在违反动态检查的类型约束的情况。
TypeConstraintException(String) - 异常 javax.xml.bind.TypeConstraintException 的构造方法
构造带指定详细消息的 TypeConstraintException。
TypeConstraintException(String, String) - 异常 javax.xml.bind.TypeConstraintException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 TypeConstraintException。
TypeConstraintException(Throwable) - 异常 javax.xml.bind.TypeConstraintException 的构造方法
构造带有一个 linkedException 的 TypeConstraintException。
TypeConstraintException(String, Throwable) - 异常 javax.xml.bind.TypeConstraintException 的构造方法
构造带指定详细消息和 linkedException 的 TypeConstraintException。
TypeConstraintException(String, String, Throwable) - 异常 javax.xml.bind.TypeConstraintException 的构造方法
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 TypeConstraintException。
TypeElement - javax.lang.model.element 中的 接口
表示一个类或接口程序元素。
TypeInfo - org.w3c.dom 中的 接口
TypeInfo 接口表示从 Element 或 Attr 节点引用的类型，用与文档相关的模式指定。
TypeInfoProvider - javax.xml.validation 中的 类
此类提供了对 ValidatorHandler 所确定的类型信息的访问。
TypeInfoProvider() - 类 javax.xml.validation.TypeInfoProvider 的构造方法
派生类的构造方法。
TypeKind - javax.lang.model.type 中的 枚举
类型镜像的种类。
TypeKindVisitor6<R,P> - javax.lang.model.util 中的 类
基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。
TypeKindVisitor6() - 类 javax.lang.model.util.TypeKindVisitor6 的构造方法
要调用的具体子类的构造方法；使用 null 作为默认值。
TypeKindVisitor6(R) - 类 javax.lang.model.util.TypeKindVisitor6 的构造方法
要调用的具体子类的构造方法；使用参数作为默认值。
TypeMirror - javax.lang.model.type 中的 接口
表示 Java 编程语言中的类型。
TypeMismatch - org.omg.CORBA.DynAnyPackage 中的 异常
动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。
TypeMismatch() - 异常 org.omg.CORBA.DynAnyPackage.TypeMismatch 的构造方法
构造一个 TypeMismatch 对象。
TypeMismatch(String) - 异常 org.omg.CORBA.DynAnyPackage.TypeMismatch 的构造方法
构造一个 TypeMismatch 对象。
TypeMismatch - org.omg.DynamicAny.DynAnyPackage 中的 异常
org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java。
TypeMismatch() - 异常 org.omg.DynamicAny.DynAnyPackage.TypeMismatch 的构造方法
TypeMismatch(String) - 异常 org.omg.DynamicAny.DynAnyPackage.TypeMismatch 的构造方法
TypeMismatch - org.omg.IOP.CodecPackage 中的 异常
org/omg/IOP/CodecPackage/TypeMismatch.java。
TypeMismatch() - 异常 org.omg.IOP.CodecPackage.TypeMismatch 的构造方法
TypeMismatch(String) - 异常 org.omg.IOP.CodecPackage.TypeMismatch 的构造方法
TypeMismatchHelper - org.omg.DynamicAny.DynAnyPackage 中的 类
org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java。
TypeMismatchHelper() - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 的构造方法
TypeMismatchHelper - org.omg.IOP.CodecPackage 中的 类
org/omg/IOP/CodecPackage/TypeMismatchHelper.java。
TypeMismatchHelper() - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 的构造方法
typeName() - 异常 java.lang.TypeNotPresentException 中的方法
返回不可用类型的完全限定名。
typeNoNulls - 接口 java.sql.DatabaseMetaData 中的静态变量
指示“不”允许对这种数据类型使用 NULL 值。
TypeNotPresentException - java.lang 中的 异常
当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
TypeNotPresentException(String, Throwable) - 异常 java.lang.TypeNotPresentException 的构造方法
为指定类型构造一个带指定原因的 TypeNotPresentException。
typeNullable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示允许对这种数据类型使用 NULL 值。
typeNullableUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道是否允许对这种数据类型使用 NULL 值。
TypeParameterElement - javax.lang.model.element 中的 接口
表示一般类、接口、方法或构造方法元素的形式类型参数。
typePredBasic - 接口 java.sql.DatabaseMetaData 中的静态变量
指示该数据类型只能用于不使用 LIKE 谓词的 WHERE 搜索子句中。
typePredChar - 接口 java.sql.DatabaseMetaData 中的静态变量
指示该数据类型只能用于使用 LIKE 谓词的 WHERE 搜索子句中。
typePredNone - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不支持将 WHERE 搜索子句用于这种类型。
Types - java.sql 中的 类
定义用于标识一般 SQL 类型（称为 JDBC 类型）的常量的类。
Types - javax.lang.model.util 中的 接口
用来对类型进行操作的实用工具方法。
typeSearchable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示在此类型上可以建立所有 WHERE 搜索子句。
typesIn(Iterable<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中类型的列表。
typesIn(Set<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中类型的集合。
TypeVariable<D extends GenericDeclaration> - java.lang.reflect 中的 接口
TypeVariable 是各种类型变量的公共高级接口。
TypeVariable - javax.lang.model.type 中的 接口
表示一个类型变量。
TypeVisitor<R,P> - javax.lang.model.type 中的 接口
类型的 visitor，使用 visitor 设计模式的样式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


U - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

U

U - 类 javax.swing.text.html.HTML.Tag 中的静态变量
UGARITIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Ugaritic”Unicode 字符块的常量。
ui - 类 javax.swing.JComponent 中的变量
此组件的外观委托。
ui - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 中的变量
UID - java.rmi.server 中的 类
UID 表示一个和生成它的主机的时间有关的唯一标识符，或者是 216 个“熟知”标识符之一。
UID() - 类 java.rmi.server.UID 的构造方法
生成一个 UID，它和生成它的主机的时间有关且具有唯一性。
UID(short) - 类 java.rmi.server.UID 的构造方法
创建一个“熟知”UID。
UIDefaults - javax.swing 中的 类
Swing 组件的默认值表。
UIDefaults() - 类 javax.swing.UIDefaults 的构造方法
创建一个空默认值表。
UIDefaults(int, float) - 类 javax.swing.UIDefaults 的构造方法
创建一个带有指定初始容量和加载因子的空默认值表。
UIDefaults(Object[]) - 类 javax.swing.UIDefaults 的构造方法
创建一个使用指定键/值对初始化的默认值表。
UIDefaults.ActiveValue - javax.swing 中的 接口
此类使用户能够在默认表中存储项，该默认表在每次使用某个 getXXX(key) 方法进行查找时创建。
UIDefaults.LazyInputMap - javax.swing 中的 类
LazyInputMap 将在其 createValue 方法中创建一个 InputMap。
UIDefaults.LazyInputMap(Object[]) - 类 javax.swing.UIDefaults.LazyInputMap 的构造方法
UIDefaults.LazyValue - javax.swing 中的 接口
此类使用户能够在默认表中存储项，该默认表只有在第一次使用某个 getXXX(key) 方法进行查找时才创建。
UIDefaults.ProxyLazyValue - javax.swing 中的 类
此类提供一个可用于延迟加载要创建实例类的 LazyValue 的实现。
UIDefaults.ProxyLazyValue(String) - 类 javax.swing.UIDefaults.ProxyLazyValue 的构造方法
创建一个将在请求时构造实例的 LazyValue。
UIDefaults.ProxyLazyValue(String, String) - 类 javax.swing.UIDefaults.ProxyLazyValue 的构造方法
创建一个将在请求时构造实例的 LazyValue。
UIDefaults.ProxyLazyValue(String, Object[]) - 类 javax.swing.UIDefaults.ProxyLazyValue 的构造方法
创建一个将在请求时构造实例的 LazyValue。
UIDefaults.ProxyLazyValue(String, String, Object[]) - 类 javax.swing.UIDefaults.ProxyLazyValue 的构造方法
创建一个将在请求时构造实例的 LazyValue。
UIEvent - org.w3c.dom.events 中的 接口
UIEvent 接口提供与用户界面事件相关联的特定上下文信息。
UIManager - javax.swing 中的 类
UIManager 管理当前外观、可用外观集合、外观更改时被通知的 PropertyChangeListeners、外观默认值以及获取各种默认值的便捷方法。
UIManager() - 类 javax.swing.UIManager 的构造方法
UIManager.LookAndFeelInfo - javax.swing 中的 类
为了配置菜单或为了初始应用程序设置而提供关于已安装的 LookAndFeel 的少量信息。
UIManager.LookAndFeelInfo(String, String) - 类 javax.swing.UIManager.LookAndFeelInfo 的构造方法
构造一个 UIManager LookAndFeelInfo 对象。
UIResource - javax.swing.plaf 中的 接口
此接口用于标记由 ComponentUI 委托创建的对象。
uis - 类 javax.swing.plaf.multi.MultiButtonUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiLabelUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiListUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiPanelUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiSliderUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiTableUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiTextUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiToolBarUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiToolTipUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiTreeUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiViewportUI 中的变量
包含实际 UI 的向量。
uisToArray(Vector) - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的静态方法
创建一个数组，使用来自传入向量的 UI 对象填充它并返回该数组。
UK - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
UL - 类 javax.swing.text.html.HTML.Tag 中的静态变量
ULAW - 类 javax.sound.sampled.AudioFormat.Encoding 中的静态变量
指定 u-law 编码数据。
ULongLongSeqHelper - org.omg.CORBA 中的 类
ULongLongSeq 的 Helper。
ULongLongSeqHelper() - 类 org.omg.CORBA.ULongLongSeqHelper 的构造方法
ULongLongSeqHolder - org.omg.CORBA 中的 类
ULongLongSeq 的 Holder。
ULongLongSeqHolder() - 类 org.omg.CORBA.ULongLongSeqHolder 的构造方法
ULongLongSeqHolder(long[]) - 类 org.omg.CORBA.ULongLongSeqHolder 的构造方法
ULongSeqHelper - org.omg.CORBA 中的 类
ULongSeq 的 Helper。
ULongSeqHelper() - 类 org.omg.CORBA.ULongSeqHelper 的构造方法
ULongSeqHolder - org.omg.CORBA 中的 类
ULongSeq 的 Holder。
ULongSeqHolder() - 类 org.omg.CORBA.ULongSeqHolder 的构造方法
ULongSeqHolder(int[]) - 类 org.omg.CORBA.ULongSeqHolder 的构造方法
ulp(double) - 类 java.lang.Math 中的静态方法
返回参数的 ulp 大小。
ulp(float) - 类 java.lang.Math 中的静态方法
返回参数的 ulp 大小。
ulp(double) - 类 java.lang.StrictMath 中的静态方法
返回参数的 ulp 大小。
ulp(float) - 类 java.lang.StrictMath 中的静态方法
返回参数的 ulp 大小。
ulp() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的 ulp（最后一位的单位）的大小。
UNASSIGNED - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Cn”。
UNAUTHORIZED - 异常 org.ietf.jgss.GSSException 中的静态变量
未授权的操作。
UNAVAILABLE - 异常 org.ietf.jgss.GSSException 中的静态变量
不可用的操作。
unbind(String) - 类 java.rmi.Naming 中的静态方法
销毁与远程对象关联的指定名称的绑定。
unbind(String) - 接口 java.rmi.registry.Registry 中的方法
移除此注册表中指定的 name 绑定。
unbind(Name) - 接口 javax.naming.Context 中的方法
取消对指定对象的绑定。
unbind(String) - 接口 javax.naming.Context 中的方法
取消对指定对象的绑定。
unbind(String) - 类 javax.naming.InitialContext 中的方法
unbind(Name) - 类 javax.naming.InitialContext 中的方法
unbind(NameComponent[]) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
unbind 操作从上下文移除名称绑定。
unbind(NameComponent[]) - 类 org.omg.CosNaming._NamingContextStub 中的方法
unbind 操作从上下文移除名称绑定。
unbind(NameComponent[]) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
unbind 操作从上下文移除名称绑定。
unboxedType(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回给定类型的拆箱 (unboxed) 值类型（基本类型）。
uncaughtException(Thread, Throwable) - 接口 java.lang.Thread.UncaughtExceptionHandler 中的方法
当给定线程因给定的未捕获异常而终止时，调用该方法。
uncaughtException(Thread, Throwable) - 类 java.lang.ThreadGroup 中的方法
当此线程组中的线程因为一个未捕获的异常而停止，并且线程没有安装特定 Thread.UncaughtExceptionHandler 时，由 Java Virtual Machine 调用此方法。
unchecked_narrow(Object) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
UNCOLLATED - 类 javax.print.attribute.standard.SheetCollate 中的静态变量
当打印多个副本时，文档中的纸张以非整理顺序出现。
unconfigurableExecutorService(ExecutorService) - 类 java.util.concurrent.Executors 中的静态方法
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。
unconfigurableScheduledExecutorService(ScheduledExecutorService) - 类 java.util.concurrent.Executors 中的静态方法
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。
unconfigureArrowButton() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此公共方法是特定于实现的，应该为私有。
unconfigureEditor() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此受保护方法是特定于实现的，应该为私有。
unconfigureEditor() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
unconfigureEnclosingScrollPane() - 类 javax.swing.JTable 中的方法
通过将封闭滚动窗格的 columnHeaderView 替换为 null，可以起到 configureEnclosingScrollPane 的相反作用。
UNDECIMBER - 类 java.util.Calendar 中的静态变量
指示一年中第十三个月的 Calendar.MONTH 字段值。
UndeclaredThrowableException - java.lang.reflect 中的 异常
如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。
UndeclaredThrowableException(Throwable) - 异常 java.lang.reflect.UndeclaredThrowableException 的构造方法
根据指定的 Throwable 构造一个 UndeclaredThrowableException。
UndeclaredThrowableException(Throwable, String) - 异常 java.lang.reflect.UndeclaredThrowableException 的构造方法
根据指定的 Throwable 和详细消息构造 UndeclaredThrowableException。
UNDEFINED - 类 java.awt.BufferCapabilities.FlipContents 中的静态变量
当翻转内容为 UNDEFINED 时，后台缓冲区的内容在翻转后是不明确的。
UNDEFINED_CONDITION - 类 javax.swing.JComponent 中的静态变量
某些 API 使用的常量，意味着没有定义任何条件。
UndefinedProperty - 类 java.awt.Image 中的静态变量
每当获得某个不是为特定图像定义的属性时，应返回 UndefinedProperty 对象。
UNDERFLOW - 类 java.nio.charset.CoderResult 中的静态变量
指示下溢的结果对象，意味着输入缓冲区中的输入被用完，或者如果输入缓冲区不是空的，但还需要其他的输入。
UNDERLINE - 类 java.awt.font.TextAttribute 中的静态变量
下划线的属性键。
Underline - 类 javax.swing.text.StyleConstants 中的静态变量
下划线属性的名称。
UNDERLINE_LOW_DASHED - 类 java.awt.font.TextAttribute 中的静态变量
单像素虚线低下划线。
UNDERLINE_LOW_DOTTED - 类 java.awt.font.TextAttribute 中的静态变量
单像素点线式低下划线。
UNDERLINE_LOW_GRAY - 类 java.awt.font.TextAttribute 中的静态变量
双像素灰色低下划线。
UNDERLINE_LOW_ONE_PIXEL - 类 java.awt.font.TextAttribute 中的静态变量
单像素实心低下划线。
UNDERLINE_LOW_TWO_PIXEL - 类 java.awt.font.TextAttribute 中的静态变量
双像素实心低下划线。
UNDERLINE_ON - 类 java.awt.font.TextAttribute 中的静态变量
标准下划线。
undo() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
撤消更改。
undo() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
撤消更改。
undo() - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的方法
撤消更改。
undo() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
如果 canUndo 返回 false，则抛出 CannotUndoException。
undo() - 类 javax.swing.undo.CompoundEdit 中的方法
按与添加时相反的顺序将 undo 发送到所有包含的 UndoableEdits 中。
undo() - 类 javax.swing.undo.StateEdit 中的方法
通知被编辑的对象应用编辑之前的状态
undo() - 接口 javax.swing.undo.UndoableEdit 中的方法
撤消编辑。
undo() - 类 javax.swing.undo.UndoManager 中的方法
撤消适当的编辑。
UndoableEdit - javax.swing.undo 中的 接口
UndoableEdit 表示一个编辑。
UndoableEditEvent - javax.swing.event 中的 类
指示发生了可撤消操作的事件。
UndoableEditEvent(Object, UndoableEdit) - 类 javax.swing.event.UndoableEditEvent 的构造方法
构造一个 UndoableEditEvent 对象。
undoableEditHappened(UndoableEditEvent) - 接口 javax.swing.event.UndoableEditListener 中的方法
发生了可撤消的编辑操作
undoableEditHappened(UndoableEditEvent) - 类 javax.swing.undo.UndoManager 中的方法
一个 UndoableEditListener 方法。
UndoableEditListener - javax.swing.event 中的 接口
该接口由某个对接收有关可撤消操作的消息感兴趣的类实现。
UndoableEditSupport - javax.swing.undo 中的 类
用于管理 UndoableEdit 侦听器的支持类。
UndoableEditSupport() - 类 javax.swing.undo.UndoableEditSupport 的构造方法
构造一个 UndoableEditSupport 对象。
UndoableEditSupport(Object) - 类 javax.swing.undo.UndoableEditSupport 的构造方法
构造一个 UndoableEditSupport 对象。
undoDelete() - 接口 javax.sql.rowset.CachedRowSet 中的方法
取消删除当前行并通知侦听器已更改了某个行。
undoInsert() - 接口 javax.sql.rowset.CachedRowSet 中的方法
如果已经插入了当前行，则立即将它从此 CachedRowSet 对象移除，同样要通知侦听器已更改了某个行。
UndoManager - javax.swing.undo 中的 类
UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。
UndoManager() - 类 javax.swing.undo.UndoManager 的构造方法
创建一个新的 UndoManager。
UndoName - 类 javax.swing.undo.AbstractUndoableEdit 中的静态变量
由 getUndoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此字段。
undoOrRedo() - 类 javax.swing.undo.UndoManager 中的方法
一个便捷方法，它调用 undo 或 redo。
undoRedoName - 类 javax.swing.undo.StateEdit 中的变量
撤消/恢复的表示名称
undoTo(UndoableEdit) - 类 javax.swing.undo.UndoManager 中的方法
撤消从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。
undoUpdate() - 接口 javax.sql.rowset.CachedRowSet 中的方法
如果已经修改了行，则立即逆转上一次更新操作。
unescapeValue(String) - 类 javax.naming.ldap.Rdn 中的静态方法
在给定根据 RFC 2253 中指定的规则进行格式化的属性值字符串的情况下，返回未格式化的值。
UnexpectedException - java.rmi 中的 异常
如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
UnexpectedException(String) - 异常 java.rmi.UnexpectedException 的构造方法
构造带指定详细消息的 UnexpectedException。
UnexpectedException(String, Exception) - 异常 java.rmi.UnexpectedException 的构造方法
构造带有指定详细消息和嵌入异常的 UnexpectedException。
unexportObject(Remote, boolean) - 类 java.rmi.activation.Activatable 中的静态方法
从 RMI 运行库中移除远程对象 obj。
unexportObject(Remote, boolean) - 类 java.rmi.server.UnicastRemoteObject 中的静态方法
从 RMI 运行时移除远程对象 obj。
unexportObject(Remote) - 接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 中的方法
PortableRemoteObject.unexportObject(java.rmi.Remote) 的委托调用。
unexportObject(Remote) - 类 javax.rmi.CORBA.Util 中的静态方法
从内部表中移除关联的 tie，并调用 Tie.deactivate() 以取消激活该对象。
unexportObject(Remote) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.unexportObject(java.rmi.Remote) 的委托调用。
unexportObject(Remote) - 类 javax.rmi.PortableRemoteObject 中的静态方法
从运行时注销服务器对象，允许对象用于垃圾回收。
UnicastRemoteObject - java.rmi.server 中的 类
用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。
UnicastRemoteObject() - 类 java.rmi.server.UnicastRemoteObject 的构造方法
使用匿名端口创建并导出一个新 UnicastRemoteObject 对象。
UnicastRemoteObject(int) - 类 java.rmi.server.UnicastRemoteObject 的构造方法
使用提供的特定端口创建并导出一个新 UnicastRemoteObject 对象。
UnicastRemoteObject(int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.server.UnicastRemoteObject 的构造方法
使用提供的特定端口和套接字工厂创建并导出一个新 UnicastRemoteObject 对象。
UNICODE_CASE - 类 java.util.regex.Pattern 中的静态变量
启用 Unicode 感知的大小写折叠。
UNICODE_STREAM_PARAM - 类 javax.sql.rowset.BaseRowSet 中的静态变量
该常量向 RowSetReaderImpl 对象指示给定的参数是一个 Unicode 流。
unicodeStream - 类 javax.sql.rowset.BaseRowSet 中的变量
将由方法 getUnicodeStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Unified Canadian Aboriginal Syllabics”Unicode 字符块的常量。
uninitialize() - 类 javax.swing.LookAndFeel 中的方法
取消初始化外观。
uninitialize() - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
取消初始化外观。
uninitialize() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
在卸载此外观时由 UIManager 调用。
UNINITIALIZED - 类 java.security.Signature 中的静态变量
可能的 Signature.state 值，表示尚未初始化此签名对象。
UNINITIALIZED_VALUE - 类 javax.swing.JOptionPane 中的静态变量
指示用户尚未选择值。
uninstall() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
卸载 AbstractFormatter 可能已在 JFormattedTextField 上安装的所有状态。
uninstallBorder(JComponent) - 类 javax.swing.LookAndFeel 中的静态方法
卸载边框的便捷方法。
uninstallChooserPanel(JColorChooser) - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
从选取器中移除面板时被调用。
uninstallComboBoxModelListeners(ComboBoxModel) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
从组合框模型中移除侦听器
uninstallComponents() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
注销并卸载组成组合框的聚合组件。
uninstallComponents() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
uninstallComponents(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
uninstallComponents(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
uninstallComponents(JMenuItem) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
uninstallComponents(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
从 JTabbedPane 移除所有已安装的子组件。
uninstallComponents() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
卸载渲染器窗格。
uninstallComponents() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法
uninstallComponents(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
uninstallDefaultChoosers() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
从 JComboBox 中卸载默认颜色、默认字体、默认渲染器和默认编辑器。
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
uninstallDefaults(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
uninstallDefaults(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
将尚未显式重写的 JList 属性设置为 null。
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
uninstallDefaults(JPanel) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法
uninstallDefaults(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
uninstallDefaults(JScrollPane) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
uninstallDefaults(JSeparator) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
将 JSpinner 的布局管理器设置为 null。
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
卸载 UI 默认值。
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
将尚未显式重写的组件属性设置为 null。
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
uninstallDefaults(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
uninstallDefaults(JComponent) - 类 javax.swing.plaf.basic.BasicViewportUI 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalCheckBoxUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
uninstallDefaults(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
卸载此样式在 context 的 JComponent 上安装的任何状态。
uninstallDesktopManager() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
uninstallIcons(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallingUI() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
卸载 UI 时调用。
uninstallingUI() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
调用以通知 ComboPopup 正在卸载 UI。
uninstallKeyboardActions(JComponent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
未注册的默认键动作
uninstallKeyboardActions(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
移除焦点 InputMap 和 ActionMap。
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
uninstallKeyboardActions(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
注销根据 installKeyboardActions 安装的键盘动作。
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
uninstallKeyboardActions(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
uninstallKeyboardActions(JScrollPane) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
uninstallKeyboardActions(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
卸载 UI 的键盘动作。
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
注销默认键动作。
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
uninstallListeners(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
从组合框及其模型中移除已安装的侦听器。
uninstallListeners() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
从 JDesktopPane 卸载从 createPropertyChangeListener 返回的 PropertyChangeListener。
uninstallListeners(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
uninstallListeners(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
移除 JList、其模型及其 selectionModel 的侦听器。
uninstallListeners() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
移除此对象安装的所有侦听器。
uninstallListeners(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
uninstallListeners(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
uninstallListeners(JSeparator) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
uninstallListeners(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
移除 installListeners 添加的 PropertyChangeListener。
uninstallListeners() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
卸载 UI 的事件侦听器。
uninstallListeners() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
卸载 UI 的侦听器。
uninstallListeners() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
uninstallListeners(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
uninstallListeners(JScrollPane) - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
uninstallStrings(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的方法
卸载组件的 UI。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
按顺序调用 uninstallListeners()、uninstallKeyboardActions() 和 uninstallDefaults() 来取消初始化 this.list。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
从传入拆分窗格的 L&F 控制器移除接收者。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
调用 uninstallDefaults、uninstallListeners，然后移除所有子 spinner。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
卸载 UI。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
卸载组件的 UI。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicViewportUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
在 installUI 期间，在指定组件上反向执行的配置操作。
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalMenuBarUI 中的方法
在 installUI 期间，在指定组件上反向执行的配置操作。
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalRootPaneUI 中的方法
调用超实现来卸载所有状态。
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
union(Rectangle2D, Rectangle2D, Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的静态方法
将一对源 Rectangle2D 对象合并，并将结果置于指定的目标 Rectangle2D 对象中。
union(Rectangle) - 类 java.awt.Rectangle 中的方法
计算此 Rectangle 与指定 Rectangle 的并集。
union(Descriptor...) - 类 javax.management.ImmutableDescriptor 中的静态方法
返回一个 ImmutableDescriptor，其内容是给定描述符的并集。
UNION - 类 javax.xml.crypto.dsig.spec.XPathType.Filter 中的静态变量
联合过滤操作。
UnionMember - org.omg.CORBA 中的 类
接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。
UnionMember() - 类 org.omg.CORBA.UnionMember 的构造方法
构造一个新的 UnionMember 对象，将其字段初始化为 null。
UnionMember(String, Any, TypeCode, IDLType) - 类 org.omg.CORBA.UnionMember 的构造方法
构造一个新的 UnionMember 对象，将其字段初始化为给定值。
UnionMemberHelper - org.omg.CORBA 中的 类
UnionMember 的 Helper。
UnionMemberHelper() - 类 org.omg.CORBA.UnionMemberHelper 的构造方法
UNIQUE_ID - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的静态变量
UNIT_DECREMENT - 类 java.awt.event.AdjustmentEvent 中的静态变量
单位减量调整类型。
UNIT_INCREMENT - 类 java.awt.event.AdjustmentEvent 中的静态变量
单位增量调整类型。
unitIncrement - 类 javax.swing.JScrollBar 中的变量
UNIX_LINES - 类 java.util.regex.Pattern 中的静态变量
启用 Unix 行模式。
UNKNOWN - 类 java.awt.ComponentOrientation 中的静态变量
表示尚未设置组件的方向。
UNKNOWN - 类 javax.accessibility.AccessibleRole 中的静态变量
该对象包含某些 Accessible 信息，但其职责是未知的。
UNKNOWN - 类 javax.management.MBeanOperationInfo 中的静态变量
指示操作具有“未知”的特性。
UNKNOWN - 类 javax.print.attribute.standard.JobState 中的静态变量
作业状态是未知的。
UNKNOWN - 类 javax.print.attribute.standard.PrinterState 中的静态变量
打印机状态未知。
UNKNOWN - org.omg.CORBA 中的 异常
如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。
UNKNOWN() - 异常 org.omg.CORBA.UNKNOWN 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 UNKNOWN 异常。
UNKNOWN(String) - 异常 org.omg.CORBA.UNKNOWN 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 UNKNOWN 异常。
UNKNOWN(int, CompletionStatus) - 异常 org.omg.CORBA.UNKNOWN 的构造方法
使用指定次要代码和完成状态构造一个 UNKNOWN 异常。
UNKNOWN(String, int, CompletionStatus) - 异常 org.omg.CORBA.UNKNOWN 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 UNKNOWN 异常。
UNKNOWN - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/UNKNOWN.java。
unknown_adapter(POA, String) - 接口 org.omg.PortableServer.AdapterActivatorOperations 中的方法
在 ORB 接收对象引用的请求时，如果该对象引用定义不存在的目标 POA，则将调用此操作。
UNKNOWN_ATTRIBUTE - 接口 java.util.jar.Pack200.Packer 中的静态变量
指出遇到包含有未知属性的类文件时所采取的行动。
UNKNOWN_LENGTH - 类 javax.sound.midi.MidiFileFormat 中的静态变量
表示未知长度。
UNKNOWN_NUMBER_OF_PAGES - 接口 java.awt.print.Pageable 中的静态变量
如果集合中的页面数对于 Pageable 实现是未知的，则从 getNumberOfPages 方法返回此常量。
UnknownAnnotationValueException - javax.lang.model.element 中的 异常
指示遇到一个未知种类的注释值。
UnknownAnnotationValueException(AnnotationValue, Object) - 异常 javax.lang.model.element.UnknownAnnotationValueException 的构造方法
创建一个新的 UnknownAnnotationValueException。
UnknownElementException - javax.lang.model.element 中的 异常
指示遇到一个未知种类的元素。
UnknownElementException(Element, Object) - 异常 javax.lang.model.element.UnknownElementException 的构造方法
创建一个新的 UnknownElementException。
UnknownEncoding - org.omg.IOP.CodecFactoryPackage 中的 异常
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。
UnknownEncoding() - 异常 org.omg.IOP.CodecFactoryPackage.UnknownEncoding 的构造方法
UnknownEncoding(String) - 异常 org.omg.IOP.CodecFactoryPackage.UnknownEncoding 的构造方法
UnknownEncodingHelper - org.omg.IOP.CodecFactoryPackage 中的 类
org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java。
UnknownEncodingHelper() - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 的构造方法
UnknownError - java.lang 中的 错误
当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。
UnknownError() - 错误 java.lang.UnknownError 的构造方法
构造不带详细消息的 UnknownError。
UnknownError(String) - 错误 java.lang.UnknownError 的构造方法
构造带指定详细消息的 UnknownError。
UnknownException - org.omg.CORBA.portable 中的 异常
org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。
UnknownException(Throwable) - 异常 org.omg.CORBA.portable.UnknownException 的构造方法
构造一个 UnknownException 对象。
UnknownFormatConversionException - java.util 中的 异常
给定未知的转换时所抛出的未经检查的异常。
UnknownFormatConversionException(String) - 异常 java.util.UnknownFormatConversionException 的构造方法
使用未知的转换构造此类的实例。
UnknownFormatFlagsException - java.util 中的 异常
给定未知标志时所抛出的未经检查的异常。
UnknownFormatFlagsException(String) - 异常 java.util.UnknownFormatFlagsException 的构造方法
使用指定的标志构造此类的实例。
UnknownGroupException - java.rmi.activation 中的 异常
当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
UnknownGroupException(String) - 异常 java.rmi.activation.UnknownGroupException 的构造方法
构造带指定详细消息的 UnknownGroupException。
UnknownHostException - java.net 中的 异常
指示主机 IP 地址无法确定而抛出的异常。
UnknownHostException(String) - 异常 java.net.UnknownHostException 的构造方法
构造带有指定详细消息的新 UnknownHostException。
UnknownHostException() - 异常 java.net.UnknownHostException 的构造方法
构造不带详细消息的新 UnknownHostException。
UnknownHostException - java.rmi 中的 异常
如果在创建到远程主机的连接以便进行远程方法调用时发生 java.net.UnknownHostException，则抛出 UnknownHostException。
UnknownHostException(String) - 异常 java.rmi.UnknownHostException 的构造方法
构造带指定详细消息的 UnknownHostException。
UnknownHostException(String, Exception) - 异常 java.rmi.UnknownHostException 的构造方法
构造带指定详细消息和嵌入异常的 UnknownHostException。
UnknownObjectException - java.rmi.activation 中的 异常
当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。
UnknownObjectException(String) - 异常 java.rmi.activation.UnknownObjectException 的构造方法
构造带指定详细消息的 UnknownObjectException。
UnknownServiceException - java.net 中的 异常
抛出这一异常指示出现了未知服务异常。
UnknownServiceException() - 异常 java.net.UnknownServiceException 的构造方法
构造不带详细消息的新 UnknownServiceException。
UnknownServiceException(String) - 异常 java.net.UnknownServiceException 的构造方法
构造带指定详细消息的新 UnknownServiceException。
UnknownTypeException - javax.lang.model.type 中的 异常
指示遇到未知种类的类型。
UnknownTypeException(TypeMirror, Object) - 异常 javax.lang.model.type.UnknownTypeException 的构造方法
创建一个新的 UnknownTypeException。
UnknownUserException - org.omg.CORBA 中的 异常
包含由服务器返回的用户异常的类。
UnknownUserException() - 异常 org.omg.CORBA.UnknownUserException 的构造方法
构造一个 UnknownUserException 对象。
UnknownUserException(Any) - 异常 org.omg.CORBA.UnknownUserException 的构造方法
构造一个包含给定 Any 对象的 UnknownUserException 对象。
UnknownUserExceptionHelper - org.omg.CORBA 中的 类
UnknownUserException 的 Helper。
UnknownUserExceptionHelper() - 类 org.omg.CORBA.UnknownUserExceptionHelper 的构造方法
UnknownUserExceptionHolder - org.omg.CORBA 中的 类
UnknownUserException 的 Holder。
UnknownUserExceptionHolder() - 类 org.omg.CORBA.UnknownUserExceptionHolder 的构造方法
UnknownUserExceptionHolder(UnknownUserException) - 类 org.omg.CORBA.UnknownUserExceptionHolder 的构造方法
UNLIMITED - 类 java.math.MathContext 中的静态变量
其设置具有无限精度算法所需值的 MathContext 对象。
unloadAllInstruments(Soundbank) - 接口 javax.sound.midi.Synthesizer 中的方法
卸载指定 Soundbank 中包含的所有乐器。
unloadInstrument(Instrument) - 接口 javax.sound.midi.Synthesizer 中的方法
卸载特定的乐器。
unloadInstruments(Soundbank, Patch[]) - 接口 javax.sound.midi.Synthesizer 中的方法
从指定的 MIDI 音库中卸载指定修补程序所引用的乐器。
unloadZone(View) - 类 javax.swing.text.ZoneView 中的方法
卸载一个分区（将分区转换到其内存节省状态）。
unlock() - 接口 java.util.concurrent.locks.Lock 中的方法
释放锁。
unlock() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
试图释放此锁。
unlock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
试图释放此锁。
unlock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
试图释放此锁。
unmappableCharacterAction() - 类 java.nio.charset.CharsetDecoder 中的方法
返回此解码器对不可映射的字符错误的当前操作。
unmappableCharacterAction() - 类 java.nio.charset.CharsetEncoder 中的方法
返回此编码器对不可映射的字符错误的当前操作。
UnmappableCharacterException - java.nio.charset 中的 异常
当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。
UnmappableCharacterException(int) - 异常 java.nio.charset.UnmappableCharacterException 的构造方法
unmappableForLength(int) - 类 java.nio.charset.CoderResult 中的静态方法
静态工厂方法，返回描述给定长度的不可映射的字符错误的唯一对象。
unmarshal(String) - 类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 中的方法
移除作为参数提供的字符串的前导空白和尾部空白，然后用单个空白字符“ ”截断任何制表符、CR、LF 和 SP 序列。
unmarshal(String) - 类 javax.xml.bind.annotation.adapters.HexBinaryAdapter 中的方法
unmarshal(String) - 类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 中的方法
移除作为参数给定的字符串的前导空白和尾部空白，然后用单个空白字符“ ”替换所有制表符、CR 和 LF。
unmarshal(ValueType) - 类 javax.xml.bind.annotation.adapters.XmlAdapter 中的方法
将 value 类型转换为 bound 类型。
unmarshal(XmlNode) - 类 javax.xml.bind.Binder 中的方法
将 XML 信息集视图解组为 JAXB 对象树。
unmarshal(XmlNode, Class<T>) - 类 javax.xml.bind.Binder 中的方法
根据提供的 declaredType 将 XML 根元素解组为 JAXB 对象树。
unmarshal(Source) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(XMLReader, InputSource) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
使用指定的 XMLReader 和 InputSource 解组对象。
unmarshal(InputSource) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(URL) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(File) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(InputStream) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(Reader) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(XMLEventReader) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(XMLStreamReader) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(Node, Class<T>) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(Source, Class<T>) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(XMLStreamReader, Class<T>) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(XMLEventReader, Class<T>) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(File) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的文件解组 XML 数据并返回得到的内容树。
unmarshal(InputStream) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 InputStream 解组 XML 数据并返回得到的内容树。
unmarshal(Reader) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 Reader 解组 XML 数据并返回得到的内容树。
unmarshal(URL) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 URL 解组 XML 数据并返回得到的内容树。
unmarshal(InputSource) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。
unmarshal(Node) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 DOM 树解组全局 XML 数据并返回得到的内容树。
unmarshal(Node, Class<T>) - 接口 javax.xml.bind.Unmarshaller 中的方法
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。
unmarshal(Source) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 XML Source 解组 XML 数据并返回得到的内容树。
unmarshal(Source, Class<T>) - 接口 javax.xml.bind.Unmarshaller 中的方法
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。
unmarshal(XMLStreamReader) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
unmarshal(XMLStreamReader, Class<T>) - 接口 javax.xml.bind.Unmarshaller 中的方法
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
unmarshal(XMLEventReader) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
unmarshal(XMLEventReader, Class<T>) - 接口 javax.xml.bind.Unmarshaller 中的方法
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
unmarshal(DataInputStream) - 接口 org.omg.CORBA.CustomMarshal 中的方法
必须通过自定义的 Marshal 类实现 unmarshal 方法。
UnmarshalException - java.rmi 中的 异常
在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。
UnmarshalException(String) - 异常 java.rmi.UnmarshalException 的构造方法
构造带指定详细消息的 UnmarshalException。
UnmarshalException(String, Exception) - 异常 java.rmi.UnmarshalException 的构造方法
构造带指定详细消息和嵌入异常的 UnmarshalException。
UnmarshalException - javax.xml.bind 中的 异常
此异常指示在执行阻止 JAXB 提供者完成操作的解组操作时遇到一个错误。
UnmarshalException(String) - 异常 javax.xml.bind.UnmarshalException 的构造方法
构造带指定详细消息的 UnmarshalException。
UnmarshalException(String, String) - 异常 javax.xml.bind.UnmarshalException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 UnmarshalException。
UnmarshalException(Throwable) - 异常 javax.xml.bind.UnmarshalException 的构造方法
构造带有一个 linkedException 的 UnmarshalException。
UnmarshalException(String, Throwable) - 异常 javax.xml.bind.UnmarshalException 的构造方法
构造带指定详细消息和 linkedException 的 UnmarshalException。
UnmarshalException(String, String, Throwable) - 异常 javax.xml.bind.UnmarshalException 的构造方法
构造带指定详细消息、特定于供应商的 errorCode 和 linkedException 的 UnmarshalException。
unmarshalKeyInfo(XMLStructure) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据特定于机制的 XMLStructure（比如：DOMStructure）实例解组新的 KeyInfo 实例。
Unmarshaller - javax.xml.bind 中的 接口
Unmarshaller 类管理将 XML 数据反序列化为新创建的 Java 内容树的过程，并可在解组时有选择地验证 XML 数据。
Unmarshaller.Listener - javax.xml.bind 中的 类

向 Unmarshaller 注册此类的一个实现的实例，以便外部侦听解组事件。

Unmarshaller.Listener() - 类 javax.xml.bind.Unmarshaller.Listener 的构造方法
UnmarshallerHandler - javax.xml.bind 中的 接口
作为 SAX ContentHandler 实现的 Unmarshaller。
unmarshalXMLSignature(XMLValidateContext) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
从特定于机制的 XMLValidateContext 实例解组新的 XMLSignature 实例。
unmarshalXMLSignature(XMLStructure) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
从特定于机制的 XMLStructure 实例解组新的 XMLSignature 实例。
UnmodifiableClassException - java.lang.instrument 中的 异常
在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。
UnmodifiableClassException() - 异常 java.lang.instrument.UnmodifiableClassException 的构造方法
构造不带详细消息的 UnmodifiableClassException。
UnmodifiableClassException(String) - 异常 java.lang.instrument.UnmodifiableClassException 的构造方法
构造具有指定详细消息的 UnmodifiableClassException。
unmodifiableCollection(Collection<? extends T>) - 类 java.util.Collections 中的静态方法
返回指定 collection 的不可修改视图。
unmodifiableList(List<? extends T>) - 类 java.util.Collections 中的静态方法
返回指定列表的不可修改视图。
unmodifiableMap(Map<? extends K, ? extends V>) - 类 java.util.Collections 中的静态方法
返回指定映射的不可修改视图。
unmodifiableSet(Set<? extends T>) - 类 java.util.Collections 中的静态方法
返回指定 set 的不可修改视图。
UnmodifiableSetException - javax.print.attribute 中的 异常
当由于设置不可修改而无法执行请求的操作时，抛出该异常。
UnmodifiableSetException() - 异常 javax.print.attribute.UnmodifiableSetException 的构造方法
构造不带详细消息的 UnsupportedOperationException。
UnmodifiableSetException(String) - 异常 javax.print.attribute.UnmodifiableSetException 的构造方法
构造带指定详细消息的 UnmodifiableSetException。
unmodifiableSortedMap(SortedMap<K, ? extends V>) - 类 java.util.Collections 中的静态方法
返回指定有序映射的不可修改视图。
unmodifiableSortedSet(SortedSet<T>) - 类 java.util.Collections 中的静态方法
返回指定有序 set 的不可修改视图。
unmodifiableView(AttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建给定属性集的不可修改的视图。
unmodifiableView(DocAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定文档属性集的不可修改的视图。
unmodifiableView(PrintRequestAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印请求属性集的不可修改的视图。
unmodifiableView(PrintJobAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印作业属性集的不可修改的视图。
unmodifiableView(PrintServiceAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印服务属性集的不可修改的视图。
UNNECESSARY - 类 java.awt.GraphicsConfigTemplate 中的静态变量
用于“枚举”（整数）类型的值。
unpack(InputStream, JarOutputStream) - 接口 java.util.jar.Pack200.Unpacker 中的方法
读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
unpack(File, JarOutputStream) - 接口 java.util.jar.Pack200.Unpacker 中的方法
读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
unpark(Thread) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
如果给定线程的许可尚不可用，则使其可用。
unparsedEntityDecl(String, String, String, String) - 接口 org.xml.sax.DTDHandler 中的方法
接收未解析的实体声明事件的通知。
unparsedEntityDecl(String, String, String, String) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收未解析的实体声明的通知。
unparsedEntityDecl(String, String, String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收未解析实体声明的通知。
unparsedEntityDecl(String, String, String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个未解析实体声明事件。
unquote(String) - 类 javax.management.ObjectName 中的静态方法
返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。
unread(int) - 类 java.io.PushbackInputStream 中的方法
推回一个字节：将其复制到推回缓冲区之前。
unread(byte[], int, int) - 类 java.io.PushbackInputStream 中的方法
推回 byte 数组的某一部分：将其复制到推回缓冲区之前。
unread(byte[]) - 类 java.io.PushbackInputStream 中的方法
推回一个 byte 数组：将其复制到推回缓冲区之前。
unread(int) - 类 java.io.PushbackReader 中的方法
推回单个字符：将其复制到推回缓冲区的前面。
unread(char[], int, int) - 类 java.io.PushbackReader 中的方法
推回字符数组的某一部分，方法是将其复制到推回缓冲区的前面。
unread(char[]) - 类 java.io.PushbackReader 中的方法
推回一个字符数组，方法是将其复制到推回缓冲区前面。
UnrecoverableEntryException - java.security 中的 异常
如果 keystore 中的某项无法恢复，则抛出此异常。
UnrecoverableEntryException() - 异常 java.security.UnrecoverableEntryException 的构造方法
构造不带详细消息的 UnrecoverableEntryException。
UnrecoverableEntryException(String) - 异常 java.security.UnrecoverableEntryException 的构造方法
构造具有指定详细消息的 UnrecoverableEntryException，其提供了有关为什么抛出此异常的更多信息。
UnrecoverableKeyException - java.security 中的 异常
如果 keystore 中的密钥无法恢复，则抛出此异常。
UnrecoverableKeyException() - 异常 java.security.UnrecoverableKeyException 的构造方法
构造不带详细消息的 UnrecoverableKeyException。
UnrecoverableKeyException(String) - 异常 java.security.UnrecoverableKeyException 的构造方法
构造具有指定详细消息的 UnrecoverableKeyException，其提供了有关为什么抛出此异常的更多信息。
Unreferenced - java.rmi.server 中的 接口
远程对象实现应该实现 Unreferenced 接口，以便在没有多个引用该对象的客户机时接收通知。
unreferenced() - 接口 java.rmi.server.Unreferenced 中的方法
在运行时确定引用列表（引用远程对象的客户机列表）变空之后的某个时候由 RMI 运行时调用。
unreferenced() - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
unregister(ActivationID) - 类 java.rmi.activation.Activatable 中的静态方法
为与 id 关联的激活描述符撤消前面的注册。
unregister_value_factory(String) - 类 org.omg.CORBA_2_3.ORB 中的方法
unregisterComponent(JComponent) - 类 javax.swing.ToolTipManager 中的方法
从工具提示控件中移除一个组件。
unregisterGroup(ActivationGroupID) - 接口 java.rmi.activation.ActivationSystem 中的方法
移除激活组。
unregisterKeyboardAction(KeyStroke) - 类 javax.swing.JComponent 中的方法
此方法现在已过时。
unregisterKeyboardActions() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
unregisterListeners() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
向该 Component 取消注册此 DragGestureRecognizer 的 Listeners。
unregisterListeners() - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
取消注册此 DragGestureRecognizer 的 Listener 和 Component 子类必须重写此方法：
unregisterMBean(ObjectName) - 接口 javax.management.MBeanServer 中的方法
unregisterMBean(ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
从 MBean 服务器中注销一个 MBean。
unregisterMBean(ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
unregisterMBean(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
unregisterMBean(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
unregisterObject(ActivationID) - 接口 java.rmi.activation.ActivationSystem 中的方法
移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。
unregisterProvider(String) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
从工厂 SPI 注册器移除指派的当前已注册同步提供者。
UNREGISTRATION_NOTIFICATION - 类 javax.management.MBeanServerNotification 中的静态变量
表示已注销该 MBean 的通知类型。
UnresolvedAddressException - java.nio.channels 中的 异常
试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
UnresolvedAddressException() - 异常 java.nio.channels.UnresolvedAddressException 的构造方法
构造此类的一个实例。
UnresolvedPermission - java.security 中的 类
UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。
UnresolvedPermission(String, String, String, Certificate[]) - 类 java.security.UnresolvedPermission 的构造方法
在解析权限时，创建一个新的 UnresolvedPermission，使之包含稍后实际创建指定类的 Permission 时所需的权限信息。
UnsatisfiedLinkError - java.lang 中的 错误
当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
UnsatisfiedLinkError() - 错误 java.lang.UnsatisfiedLinkError 的构造方法
构造不带详细消息的 UnsatisfiedLinkError。
UnsatisfiedLinkError(String) - 错误 java.lang.UnsatisfiedLinkError 的构造方法
构造带指定详细消息的 UnsatisfiedLinkError。
unscaledValue() - 类 java.math.BigDecimal 中的方法
返回其值为此 BigDecimal 的非标度值 的 BigInteger。
UNSELECTED_CONVERTED_TEXT_HIGHLIGHT - 类 java.awt.im.InputMethodHighlight 中的静态变量
未选定已转换文本的默认高亮显示常量。
UNSELECTED_RAW_TEXT_HIGHLIGHT - 类 java.awt.im.InputMethodHighlight 中的静态变量
未选定原文本的默认高亮显示常量。
UNSEQ_TOKEN - 异常 org.ietf.jgss.GSSException 中的静态变量
后面的标记已处理过。
UNSET - 类 javax.swing.Spring 中的静态变量
一个表示属性值尚未计算的整数值。
unsetCompression() - 类 javax.imageio.ImageWriteParam 中的方法
移除所有以前的压缩类型和质量设置。
unsetCompression() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
移除所有以前的压缩质量设置值。
unsetDecodeTables() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
移除当前设置的所有量化表和 Huffman 表。
unsetEncodeTables() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
移除当前设置的所有量化表和 Huffman 表。
unsetMatchColumn(int) - 接口 javax.sql.rowset.Joinable 中的方法
取消将指定的列设置为此 RowSet 对象的匹配列。
unsetMatchColumn(int[]) - 接口 javax.sql.rowset.Joinable 中的方法
取消将指定的列设置为此 RowSet 对象的匹配列。
unsetMatchColumn(String) - 接口 javax.sql.rowset.Joinable 中的方法
取消将指定的列设置为此 RowSet 对象的匹配列。
unsetMatchColumn(String[]) - 接口 javax.sql.rowset.Joinable 中的方法
取消将指定的列设置为此 RowSet 对象的匹配列。
unsetOrdering(Class<T>, T, T) - 类 javax.imageio.spi.ServiceRegistry 中的方法
为给定类别中的两个服务提供者对象设置配对排序。
unsetTiling() - 类 javax.imageio.ImageWriteParam 中的方法
移除通过调用 setTiling 指定的所有以前的 tile 网格参数。
UnsolicitedNotification - javax.naming.ldap 中的 接口
此接口表示在 RFC 2251 中定义的未经请求的通知。
UnsolicitedNotificationEvent - javax.naming.ldap 中的 类
此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。
UnsolicitedNotificationEvent(Object, UnsolicitedNotification) - 类 javax.naming.ldap.UnsolicitedNotificationEvent 的构造方法
构造一个新的 UnsolicitedNotificationEvent 实例。
UnsolicitedNotificationListener - javax.naming.ldap 中的 接口
此接口用于处理 UnsolicitedNotificationEvent。
UNSPECIFIED_EVENT_TYPE_ERR - 异常 org.w3c.dom.events.EventException 中的静态变量
如果 Event 的类型不是在调用该方法之前通过初始化该事件指定的。
UNSPECIFIED_OPTION - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
未指定的选项类型。
UNSUPPORTED_COMPRESSION - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
系统取消了作业，这是因为打印机尝试解压缩文档数据时确定该压缩实际上不在打印机所支持的文档数据中。
UNSUPPORTED_DOCUMENT_FORMAT - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
系统中止了作业，因为文档数据的文档格式（doc flavor）不在打印机所支持的格式中。
UNSUPPORTED_EMPTY_COLLECTION - 类 java.security.Policy 中的静态变量
一个空的只读 PermissionCollection 实例。
UNSUPPORTED_POLICY - org.omg.CORBA 中的 接口
在所请求的 Policy 被 ORB 认为是有效的，但目前不受支持时将被填充的一个 PolicyErrorCode。
UNSUPPORTED_POLICY_VALUE - org.omg.CORBA 中的 接口
当所请求的 Policy 值是有效类型并且在该类型的有效范围内，但该有效值目前不受支持时将被填充的 PolicyErrorCode。
UnsupportedAddressTypeException - java.nio.channels 中的 异常
试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。
UnsupportedAddressTypeException() - 异常 java.nio.channels.UnsupportedAddressTypeException 的构造方法
构造此类的一个实例。
UnsupportedAudioFileException - javax.sound.sampled 中的 异常
UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。
UnsupportedAudioFileException() - 异常 javax.sound.sampled.UnsupportedAudioFileException 的构造方法
构造将 null 作为其错误详细消息的 UnsupportedAudioFileException。
UnsupportedAudioFileException(String) - 异常 javax.sound.sampled.UnsupportedAudioFileException 的构造方法
构造具有指定详细消息的 UnsupportedAudioFileException。
UnsupportedCallbackException - javax.security.auth.callback 中的 异常
在 CallbackHandler 不能识别特定的 Callback 时发出的信号。
UnsupportedCallbackException(Callback) - 异常 javax.security.auth.callback.UnsupportedCallbackException 的构造方法
构造不带详细消息的 UnsupportedCallbackException。
UnsupportedCallbackException(Callback, String) - 异常 javax.security.auth.callback.UnsupportedCallbackException 的构造方法
构造带指定详细消息的 UnsupportedCallbackException。
UnsupportedCharsetException - java.nio.charset 中的 异常
当不支持请求的 charset 时，抛出此未经检查的异常。
UnsupportedCharsetException(String) - 异常 java.nio.charset.UnsupportedCharsetException 的构造方法
构造此类的一个实例。
UnsupportedClassVersionError - java.lang 中的 错误
当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
UnsupportedClassVersionError() - 错误 java.lang.UnsupportedClassVersionError 的构造方法
构造不带详细消息的 UnsupportedClassVersionError。
UnsupportedClassVersionError(String) - 错误 java.lang.UnsupportedClassVersionError 的构造方法
构造带指定详细消息的 UnsupportedClassVersionError。
UnsupportedDataTypeException - javax.activation 中的 异常
当请求操作不支持请求的数据类型时，抛出此异常。
UnsupportedDataTypeException() - 异常 javax.activation.UnsupportedDataTypeException 的构造方法
构造不带详细消息的 UnsupportedDataTypeException。
UnsupportedDataTypeException(String) - 异常 javax.activation.UnsupportedDataTypeException 的构造方法
构造带指定消息的 UnsupportedDataTypeException。
UnsupportedEncodingException - java.io 中的 异常
不支持字符编码。
UnsupportedEncodingException() - 异常 java.io.UnsupportedEncodingException 的构造方法
构造不带详细消息的 UnsupportedEncodingException。
UnsupportedEncodingException(String) - 异常 java.io.UnsupportedEncodingException 的构造方法
构造带详细消息的 UnsupportedEncodingException。
UnsupportedFlavorException - java.awt.datatransfer 中的 异常
在此 flavor 中不支持所请求的数据的信号。
UnsupportedFlavorException(DataFlavor) - 异常 java.awt.datatransfer.UnsupportedFlavorException 的构造方法
构造一个 UnsupportedFlavorException。
UnsupportedLookAndFeelException - javax.swing 中的 异常
指示在用户系统上不存在请求的外观管理类的异常。
UnsupportedLookAndFeelException(String) - 异常 javax.swing.UnsupportedLookAndFeelException 的构造方法
构造一个 UnsupportedLookAndFeelException 对象。
UnsupportedOperationException - java.lang 中的 异常
当不支持请求的操作时，抛出该异常。
UnsupportedOperationException() - 异常 java.lang.UnsupportedOperationException 的构造方法
构造不带详细消息的 UnsupportedOperationException。
UnsupportedOperationException(String) - 异常 java.lang.UnsupportedOperationException 的构造方法
构造带指定详细消息的 UnsupportedOperationException。
UnsupportedOperationException(String, Throwable) - 异常 java.lang.UnsupportedOperationException 的构造方法
根据指定的详细消息和原因，构造一个新异常。
UnsupportedOperationException(Throwable) - 异常 java.lang.UnsupportedOperationException 的构造方法
根据指定的原因和 (cause==null ? null :cause.toString())（它通常包含了 cause 的类和详细消息）的详细消息，构造一个新异常。
unsynchronize(Line[]) - 接口 javax.sound.sampled.Mixer 中的方法
释放指定行的同步。
unwrap(Class<T>) - 接口 java.sql.Wrapper 中的方法
返回一个对象，该对象实现给定接口，以允许访问非标准方法或代理未公开的标准方法。
unwrap(byte[], String, int) - 类 javax.crypto.Cipher 中的方法
解包一个以前包装的密钥。
unwrap(ByteBuffer, ByteBuffer) - 类 javax.net.ssl.SSLEngine 中的方法
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区中。
unwrap(ByteBuffer, ByteBuffer[]) - 类 javax.net.ssl.SSLEngine 中的方法
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
unwrap(ByteBuffer, ByteBuffer[], int, int) - 类 javax.net.ssl.SSLEngine 中的方法
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
unwrap(byte[], int, int) - 接口 javax.security.sasl.SaslClient 中的方法
解包接收自服务器的 byte 数组。
unwrap(byte[], int, int) - 接口 javax.security.sasl.SaslServer 中的方法
解包接收自客户端的 byte 数组。
unwrap(Class<T>) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
返回实现给定接口以允许访问非标准方法，或者代理未公开标准方法的的对象。
unwrap(byte[], int, int, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
用来处理在上下文的另一方由 wrap 方法生成的标记。
unwrap(InputStream, OutputStream, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
使用流来处理在上下文的另一方由 wrap 方法生成的标记。
UNWRAP_MODE - 类 javax.crypto.Cipher 中的静态变量
用于将 Cipher 初始化为密钥解包模式的常量。
UP - 类 java.awt.Event 中的静态变量
Up Arrow 键，一个非 ASCII 操作键。
UP_CYCLE_TRAVERSAL_KEYS - 类 java.awt.KeyboardFocusManager 中的静态变量
Up Cycle 焦点遍历键的标识符。
upAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符在逻辑上向上移动一个位置的动作名称。
UPDATABLE_VIEW_SYNC - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示 SyncProvider 实现支持 RowSet 对象和用于填充它的 SQL VIEW 之间的同步。
update(Graphics) - 类 java.awt.Canvas 中的方法
更新此 canvas。
update(Graphics) - 类 java.awt.Component 中的方法
更新组件。
update(Graphics) - 类 java.awt.Container 中的方法
更新容器。
UPDATE - 类 java.awt.event.PaintEvent 中的静态变量
更新事件类型。
update() - 类 java.awt.SplashScreen 中的方法
用当前叠加图像的上下文来更新闪现屏幕窗口。
update(byte) - 类 java.security.MessageDigest 中的方法
使用指定的字节更新摘要。
update(byte[], int, int) - 类 java.security.MessageDigest 中的方法
使用指定的 byte 数组，从指定的偏移量开始更新摘要。
update(byte[]) - 类 java.security.MessageDigest 中的方法
使用指定的 byte 数组更新摘要。
update(ByteBuffer) - 类 java.security.MessageDigest 中的方法
使用指定的 ByteBuffer 更新摘要。
update(byte) - 类 java.security.Signature 中的方法
更新要由字节签名或验证的数据。
update(byte[]) - 类 java.security.Signature 中的方法
使用指定的 byte 数组更新要签名或验证的数据。
update(byte[], int, int) - 类 java.security.Signature 中的方法
从指定的偏移量开始，使用指定的 byte 数组更新要签名或验证的数据。
update(ByteBuffer) - 类 java.security.Signature 中的方法
使用指定的 ByteBuffer 更新要签名或验证的数据。
update(Observable, Object) - 接口 java.util.Observer 中的方法
只要改变了 observable 对象就调用此方法。
update(int) - 类 java.util.zip.Adler32 中的方法
使用指定字节更新校验和。
update(byte[], int, int) - 类 java.util.zip.Adler32 中的方法
使用指定的字节数组更新校验和。
update(byte[]) - 类 java.util.zip.Adler32 中的方法
使用指定的字节数组更新校验和。
update(int) - 接口 java.util.zip.Checksum 中的方法
使用指定字节更新当前校验和。
update(byte[], int, int) - 接口 java.util.zip.Checksum 中的方法
使用指定的字节数组更新当前校验和。
update(int) - 类 java.util.zip.CRC32 中的方法
使用指定字节更新 CRC-32。
update(byte[], int, int) - 类 java.util.zip.CRC32 中的方法
使用指定的字节数组更新 CRC-32。
update(byte[]) - 类 java.util.zip.CRC32 中的方法
使用指定的字节数组更新校验和。
UPDATE - 接口 javax.accessibility.AccessibleTableModelChange 中的静态变量
标识现有数据的更改。
update(byte[]) - 类 javax.crypto.Cipher 中的方法
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
update(byte[], int, int) - 类 javax.crypto.Cipher 中的方法
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
update(byte[], int, int, byte[]) - 类 javax.crypto.Cipher 中的方法
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
update(byte[], int, int, byte[], int) - 类 javax.crypto.Cipher 中的方法
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
update(ByteBuffer, ByteBuffer) - 类 javax.crypto.Cipher 中的方法
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
update(byte) - 类 javax.crypto.Mac 中的方法
处理给定的字节。
update(byte[]) - 类 javax.crypto.Mac 中的方法
处理给定的 byte 数组。
update(byte[], int, int) - 类 javax.crypto.Mac 中的方法
从 offset（包含）开始，处理 input 中的前 len 个字节。
update(ByteBuffer) - 类 javax.crypto.Mac 中的方法
从 input.position() 开始，处理 ByteBuffer input 中的 input.remaining() 个字节。
update(LineEvent) - 接口 javax.sound.sampled.LineListener 中的方法
通知侦听器行的状态已发生更改。
update(Graphics) - 类 javax.swing.CellRendererPane 中的方法
不应调用。
UPDATE - 类 javax.swing.event.TableModelEvent 中的静态变量
标识现有数据的更改。
update(Graphics) - 类 javax.swing.JApplet 中的方法
调用 paint(g)。
update(Graphics) - 类 javax.swing.JComponent 中的方法
调用 paint。
update(Graphics) - 类 javax.swing.JDialog 中的方法
调用 paint(g)。
update(Graphics) - 类 javax.swing.JFrame 中的方法
只是调用 paint(g)。
update(Graphics) - 类 javax.swing.JWindow 中的方法
调用 paint(g)。
update(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
使用 paintMenuItem() 绘制背景，从而重写 update（默认情况下填充不透明组件的背景）以调用 paint()。
update(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
超类以无法控制的方式绘制背景（即有人可能希望将图像平铺在背景中）。
update(Graphics, JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
通知此 UI 委托开始绘制指定的组件。
update(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
如果必要，绘制组件的背景，然后调用 paint。
update(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalMenuBarUI 中的方法
如果必要，绘制组件的背景，然后调用 paint。
update(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
update(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
如果必要，绘制组件的背景，然后调用 paint。
update(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
如果必要，绘制组件的背景，然后调用 paint。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
UPDATE_ROW_CONFLICT - 接口 javax.sql.rowset.spi.SyncResolver 中的静态变量
指示在 RowSet 对象试图更新数据源中的行时发生冲突。
UPDATE_WHEN_ON_EDT - 类 javax.swing.text.DefaultCaret 中的静态变量
指示只有在事件调度线程中执行文档更改时，才更新插入符位置。
updateArray(int, Array) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Array 值更新指定列。
updateArray(String, Array) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Array 值更新指定列。
updateAsciiStream(int, InputStream, int) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定列，该列将具有指定字节数。
updateAsciiStream(String, InputStream, int) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定列，该列具有指定的字节数。
updateAsciiStream(int, InputStream, long) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定的列，该值将具有指定的字节数。
updateAsciiStream(String, InputStream, long) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定的列，该值将具有指定的字节数。
updateAsciiStream(int, InputStream) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定的列。
updateAsciiStream(String, InputStream) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定列。
updateAutoscroll(Point) - 类 java.awt.dnd.DropTarget 中的方法
使用当前的光标位置更新自动滚动
updateBigDecimal(int, BigDecimal) - 接口 java.sql.ResultSet 中的方法
用 java.math.BigDecimal 值更新指定列。
updateBigDecimal(String, BigDecimal) - 接口 java.sql.ResultSet 中的方法
用 java.sql.BigDecimal 值更新指定列。
updateBinaryStream(int, InputStream, int) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定列，该列将具有指定字节数。
updateBinaryStream(String, InputStream, int) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定列，该列具有指定的字节数。
updateBinaryStream(int, InputStream, long) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定的列，该值将具有指定的字节数。
updateBinaryStream(String, InputStream, long) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定的列，该值将具有指定的字节数。
updateBinaryStream(int, InputStream) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定的列。
updateBinaryStream(String, InputStream) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定列。
updateBlob(int, Blob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Blob 值更新指定列。
updateBlob(String, Blob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Blob 值更新指定列。
updateBlob(int, InputStream, long) - 接口 java.sql.ResultSet 中的方法
使用给定输入流更新指定的列，该流将具有指定的字节数。
updateBlob(String, InputStream, long) - 接口 java.sql.ResultSet 中的方法
使用给定输入流更新指定列，该流将具有指定的字节数。
updateBlob(int, InputStream) - 接口 java.sql.ResultSet 中的方法
使用给定输入流值更新指定列。
updateBlob(String, InputStream) - 接口 java.sql.ResultSet 中的方法
使用给定输入流值更新指定列。
updateBoolean(int, boolean) - 接口 java.sql.ResultSet 中的方法
用 boolean 值更新指定列。
updateBoolean(String, boolean) - 接口 java.sql.ResultSet 中的方法
用 boolean 值更新指定列。
updateButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
updateButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
updateButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
updateByte(int, byte) - 接口 java.sql.ResultSet 中的方法
用 byte 值更新指定列。
updateByte(String, byte) - 接口 java.sql.ResultSet 中的方法
用 byte 值更新指定列。
updateBytes(int, byte[]) - 接口 java.sql.ResultSet 中的方法
用 byte 数组值更新指定列。
updateBytes(String, byte[]) - 接口 java.sql.ResultSet 中的方法
用字节数组值更新指定列。
updateCachedPreferredSize() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
更新 preferredSize 实例变量，该变量从 getPreferredSize() 返回。
updateCellEditor() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
基于包含所在的 JTree 的可编辑性更新 cellEditor。
updateCharacterStream(int, Reader, int) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定列，该列将具有指定字节数。
updateCharacterStream(String, Reader, int) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定列，该列具有指定的字节数。
updateCharacterStream(int, Reader, long) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列，该值将具有指定的字节数。
updateCharacterStream(String, Reader, long) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列，该值将具有指定的字节数。
updateCharacterStream(int, Reader) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列。
updateCharacterStream(String, Reader) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定列。
updateChildren(DocumentEvent.ElementChange, DocumentEvent, ViewFactory) - 类 javax.swing.text.View 中的方法
更新子视图以响应接收模型变化的通知，并且有一条此视图负责的元素的变化记录。
updateChildren(DocumentEvent.ElementChange, DocumentEvent, ViewFactory) - 类 javax.swing.text.ZoneView 中的方法
超类行为将试图更新子视图，而在这种情况下并不需要这样做，因为子级是分区并且不受关联元素变化的直接影响。
updateChooser() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
在模型状态更改时自动调用。
updateClob(int, Clob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Clob 值更新指定列。
updateClob(String, Clob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Clob 值更新指定列。
updateClob(int, Reader, long) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
updateClob(String, Reader, long) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
updateClob(int, Reader) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列。
updateClob(String, Reader) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列。
updateColumnHeader(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
updateComponents() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
确定组件。
updateComponentTreeUI(Component) - 类 javax.swing.SwingUtilities 中的静态方法
简单的外观更改：将树结构中的每个节点转到 updateUI() -- 也就是说，通过当前外观初始化其 UI 属性。
updateCurrentCursor(int, int, int) - 类 java.awt.dnd.DragSourceContext 中的方法
如果默认拖动光标行为处于活动状态，则此方法将为默认拖动光标设置受拖动源、放置目标动作和状态支持的指定动作，否则此方法不执行任何操作。
updateDamage(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.PlainView 中的方法
重新绘制给定文档事件覆盖的更改区域。
updateDate(int, Date) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Date 值更新指定列。
updateDate(String, Date) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Date 值更新指定列。
updateDepthOffset() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
更新每次应该偏移的深度量。
updateDouble(int, double) - 接口 java.sql.ResultSet 中的方法
用 double 值更新指定列。
updateDouble(String, double) - 接口 java.sql.ResultSet 中的方法
用 double 值更新指定列。
updateExpandedDescendants(TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
通过从树获取展开的子代并将其转发到树状态来更新 path 的所有子代的展开状态。
updateFloat(int, float) - 接口 java.sql.ResultSet 中的方法
用 float 值更新指定列。
updateFloat(String, float) - 接口 java.sql.ResultSet 中的方法
用 float 值更新指定列。
updateInt(int, int) - 接口 java.sql.ResultSet 中的方法
用 int 值更新指定列。
updateInt(String, int) - 接口 java.sql.ResultSet 中的方法
用 int 值更新指定列。
updateJAXB(XmlNode) - 类 javax.xml.bind.Binder 中的方法
取一个 XML 节点，并更新与其关联的 JAXB 对象和该对象的子级。
updateLabelUIs() - 类 javax.swing.JSlider 中的方法
通过在每个标签上调用 updateUI 更新标签表中标签的 UI。
updateLayout(DocumentEvent.ElementChange, DocumentEvent, Shape) - 类 javax.swing.text.AsyncBoxView 中的方法
更新布局，以响应从模型接收的更改通知。
updateLayout(DocumentEvent.ElementChange, DocumentEvent, Shape) - 类 javax.swing.text.View 中的方法
更新布局，以响应从模型接受的更改通知。
updateLayoutCacheExpandedNodes() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
让在 JTree 中展开的所有节点在 LayoutCache 中展开。
updateLayoutState() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
基于当前字体和 fixedCellWidth、fixedCellHeight 和 prototypeCellValue 的当前值重新计算 cellHeight（一个或多个）和 cellWidth 的值。
updateLayoutStateNeeded - 类 javax.swing.plaf.basic.BasicListUI 中的变量
updateLeadIndex() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
更新 leadIndex 实例变量。
updateLevel - 类 javax.swing.undo.UndoableEditSupport 中的变量
updateListBoxSelectionForEvent(MouseEvent, boolean) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
供事件侦听器使用的实用程序方法。
updateListeners - 类 javax.imageio.ImageReader 中的变量
当前已注册 IIOReadUpdateListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
updateLocation(Point) - 类 java.awt.dnd.DropTarget.DropTargetAutoScroller 中的方法
导致发生自动滚动
updateLong(int, long) - 接口 java.sql.ResultSet 中的方法
用 long 值更新指定列。
updateLong(String, long) - 接口 java.sql.ResultSet 中的方法
用 long 值更新指定列。
updateMetrics() - 类 javax.swing.text.PlainView 中的方法
检查字体规格和最长行是否最新。
updateNCharacterStream(int, Reader, long) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列，该值将具有指定的字节数。
updateNCharacterStream(String, Reader, long) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列，该值将具有指定的字节数。
updateNCharacterStream(int, Reader) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列。
updateNCharacterStream(String, Reader) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列。
updateNClob(int, NClob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.NClob 值更新指定的列。
updateNClob(String, NClob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.NClob 值更新指定的列。
updateNClob(int, Reader, long) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
updateNClob(String, Reader, long) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
updateNClob(int, Reader) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列。
updateNClob(String, Reader) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列。
updateNString(int, String) - 接口 java.sql.ResultSet 中的方法
用 String 值更新指定的列。
updateNString(String, String) - 接口 java.sql.ResultSet 中的方法
用 String 值更新指定的列。
updateNull(int) - 接口 java.sql.ResultSet 中的方法
用 null 值更新指定列。
updateNull(String) - 接口 java.sql.ResultSet 中的方法
用 null 值更新指定列。
updateObject(int, Object, int) - 接口 java.sql.ResultSet 中的方法
用 Object 值更新指定列。
updateObject(int, Object) - 接口 java.sql.ResultSet 中的方法
用 Object 值更新指定列。
updateObject(String, Object, int) - 接口 java.sql.ResultSet 中的方法
用 Object 值更新指定列。
updateObject(String, Object) - 接口 java.sql.ResultSet 中的方法
用 Object 值更新指定列。
updateRef(int, Ref) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Ref 值更新指定列。
updateRef(String, Ref) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Ref 值更新指定列。
updateRenderer(JComponent, String) - 类 javax.swing.plaf.basic.BasicHTML 中的静态方法
将给定文本的 HTML 渲染器隐藏在给定 JComponent 的客户端属性中。
updateRenderer() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
当渲染器更改时从所处的树中传递消息。
updateRoleMap(String, Role, List<ObjectName>) - 类 javax.management.relation.RelationService 中的方法
针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
updateRoleMap(String, Role, List<ObjectName>) - 接口 javax.management.relation.RelationServiceMBean 中的方法
针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
updateRow() - 接口 java.sql.ResultSet 中的方法
用此 ResultSet 对象的当前行的新内容更新底层数据库。
updateRowHeader(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
updateRowId(int, RowId) - 接口 java.sql.ResultSet 中的方法
用 RowId 值更新指定列。
updateRowId(String, RowId) - 接口 java.sql.ResultSet 中的方法
用 RowId 值更新指定的列。
updatesAreDetected(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以通过调用 ResultSet.rowUpdated 方法检测可见行的更新。
updateScrollBarDisplayPolicy(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
updateShort(int, short) - 接口 java.sql.ResultSet 中的方法
用 short 值更新指定列。
updateShort(String, short) - 接口 java.sql.ResultSet 中的方法
用 short 值更新指定列。
updateSize() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
将缓存大小标记为无效并使用 treeDidChange 传递树的信息。
updateSQLXML(int, SQLXML) - 接口 java.sql.ResultSet 中的方法
用 java.sql.SQLXML 值更新指定列。
updateSQLXML(String, SQLXML) - 接口 java.sql.ResultSet 中的方法
用 java.sql.SQLXML 值更新指定的列。
updateString(int, String) - 接口 java.sql.ResultSet 中的方法
用 String 值更新指定列。
updateString(String, String) - 接口 java.sql.ResultSet 中的方法
用 String 值更新指定列。
updateStyles(Component) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
更新与 c 关联的样式以及其所有子样式。
updateTableInRealTime - 类 javax.swing.table.JTableHeader 中的变量
从 Java 2 platform v1.3 开始已过时。
updateTime(int, Time) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Time 值更新指定列。
updateTime(String, Time) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Time 值更新指定列。
updateTimestamp(int, Timestamp) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Timestamp 值更新指定列。
updateTimestamp(String, Timestamp) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Timestamp 值更新指定列。
updateUI() - 类 javax.swing.AbstractButton 中的方法
将 UI 属性重置为当前外观中的一个值。
updateUI() - 类 javax.swing.JButton 中的方法
根据当前外观的值重置 UI 属性。
updateUI() - 类 javax.swing.JCheckBox 中的方法
根据当前外观重置 UI 属性值。
updateUI() - 类 javax.swing.JColorChooser 中的方法
UIManager 发出的关于 L&F 已更改的通知。
updateUI() - 类 javax.swing.JComboBox 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.JComponent 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.JDesktopPane 中的方法
UIManager 发出的关于 L&F 已更改的通知。
updateUI() - 类 javax.swing.JFileChooser 中的方法
将 UI 属性重置为当前的外观值。
updateUI() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
来自 UIManager 的通知，告知外观已更改。
updateUI() - 类 javax.swing.JInternalFrame 中的方法
来自 UIManager 的通知，告知外观已更改。
updateUI() - 类 javax.swing.JLabel 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.JList 中的方法
重置 ListUI 属性，将其设置为当前外观所提供的值。
updateUI() - 类 javax.swing.JMenu 中的方法
利用当前外观的值重置 UI 属性。
updateUI() - 类 javax.swing.JMenuBar 中的方法
利用当前外观的值重置 UI 属性。
updateUI() - 类 javax.swing.JMenuItem 中的方法
利用当前外观的值重置 UI 属性。
updateUI() - 类 javax.swing.JOptionPane 中的方法
UIManager 发出的关于 L&F 已改变的通知。
updateUI() - 类 javax.swing.JPanel 中的方法
利用当前外观的值重置 UI 属性。
updateUI() - 类 javax.swing.JPasswordField 中的方法
重新加载可插入的 UI。
updateUI() - 类 javax.swing.JPopupMenu 中的方法
将 UI 属性重置为一个来自当前外观的值。
updateUI() - 类 javax.swing.JProgressBar 中的方法
将 UI 属性重置为当前外观对应的值。
updateUI() - 类 javax.swing.JRadioButton 中的方法
将 UI 属性重置为当前外观对应的值。
updateUI() - 类 javax.swing.JRootPane 中的方法
将 UI 属性重置为当前外观对应的值。
updateUI() - 类 javax.swing.JScrollBar 中的方法
重写 JComponent.updateUI。
updateUI() - 类 javax.swing.JScrollPane 中的方法
用一个来自当前默认外观的 ScrollPaneUI 替换当前的 ScrollPaneUI 对象。
updateUI() - 类 javax.swing.JSeparator 中的方法
根据当前外观将 UI 属性重设成某个值。
updateUI() - 类 javax.swing.JSlider 中的方法
根据当前外观将 UI 属性重设为某个值。
updateUI() - 类 javax.swing.JSpinner 中的方法
用取自当前外观的值重设 UI 属性。
updateUI() - 类 javax.swing.JSplitPane 中的方法
UIManager 发出的关于 L&F 已改变的通知。
updateUI() - 类 javax.swing.JTabbedPane 中的方法
从当前外观更新 UI 属性的值。
updateUI() - 类 javax.swing.JTable 中的方法
UIManager 发出的表明 L&F 已经更改的通知。
updateUI() - 类 javax.swing.JToggleButton 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.JToolBar 中的方法
UIFactory 发出的关于 L&F 已更改的通知。
updateUI() - 类 javax.swing.JToolTip 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.JTree 中的方法
UIManager 发出的关于 L&F 已经更改的通知。
updateUI() - 类 javax.swing.JViewport 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
取自 UIManager 的关于外观 [L&F] 已更改的通知。
updateUI() - 类 javax.swing.table.JTableHeader 中的方法
UIManager 发出的关于 L&F 已更改的通知。
updateUI() - 类 javax.swing.text.JTextComponent 中的方法
重新加载可插入的 UI。
updateUndoPositions(Vector, int, int) - 类 javax.swing.text.GapContent 中的方法
重新设置处在 positions 的所有 UndoPosRef 实例的位置。
updateUndoPositions(Vector) - 类 javax.swing.text.StringContent 中的方法
在 positions 处重新设置所有 UndoPosRef 实例的位置。
updateViewport(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
updateXML(Object) - 类 javax.xml.bind.Binder 中的方法
取一个 JAXB 对象，并更新与其关联的 XML 节点和该节点的子级。
updateXML(Object, XmlNode) - 类 javax.xml.bind.Binder 中的方法
JAXB 对象树中所做的更改在与其关联的 XML 解析树中得到更新。
upFocusCycle(Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
将焦点上移一个焦点遍历循环。
upFocusCycle(Component) - 类 java.awt.KeyboardFocusManager 中的方法
将焦点上移一个焦点遍历循环。
upFocusCycle() - 类 java.awt.KeyboardFocusManager 中的方法
从当前焦点所有者将焦点上移一个焦点遍历循环。
upFolderIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
upKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
upKey - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
upKey - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
已过时。 从 Java 2 平台 v1.3 开始。
UPPER_LEADING_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的顶端开始边角。
UPPER_LEFT_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的左上角。
UPPER_RIGHT_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的右上角。
UPPER_TRAILING_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的顶端结束边角。
UPPERCASE - 类 java.util.FormattableFlags 中的静态变量
根据创建 formatTo() 方法的 formatter 参数期间给出的 locale 规则，将输出转换为大写形式。
UPPERCASE_LETTER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Lu”。
upperLeft - 类 javax.swing.JScrollPane 中的变量
在左上角显示的组件。
upperLeft - 类 javax.swing.ScrollPaneLayout 中的变量
左上角显示的组件。
upperRight - 类 javax.swing.JScrollPane 中的变量
在右上角显示的组件。
upperRight - 类 javax.swing.ScrollPaneLayout 中的变量
右上角显示的组件。
URI - java.net 中的 类
表示一个统一资源标识符 (URI) 引用。
URI(String) - 类 java.net.URI 的构造方法
通过解析给定的字符串构造一个 URI。
URI(String, String, String, int, String, String, String) - 类 java.net.URI 的构造方法
根据给定的组成部分构造一个分层 URI。
URI(String, String, String, String, String) - 类 java.net.URI 的构造方法
根据给定的组成部分构造分层 URI。
URI(String, String, String, String) - 类 java.net.URI 的构造方法
根据给定的组成部分构造分层 URI。
URI(String, String, String) - 类 java.net.URI 的构造方法
根据给定的组成部分构造 URI。
uri - 类 javax.tools.SimpleJavaFileObject 中的变量
此文件对象的 URI。
URI_NS_SOAP_1_1_ENVELOPE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.1 信封的名称空间标识符。
URI_NS_SOAP_1_2_ENCODING - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 编码的名称空间标识符。
URI_NS_SOAP_1_2_ENVELOPE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 信封的名称空间标识符。
URI_NS_SOAP_ENCODING - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.1 编码的名称空间标识符。
URI_NS_SOAP_ENVELOPE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.1 信封的名称空间标识符，此名称空间中的所有 SOAPElements 是由 SOAP 1.1 规范定义的。
URI_SOAP_1_2_ROLE_NEXT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
该 URI 标识将 SOAP 请求处理为 SOAP 1.2 头条目预定角色 (intended role) 的下一个应用程序（请参阅 SOAP 1.2 规范第 1 部分第 2.2 节）。
URI_SOAP_1_2_ROLE_NONE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
该 URI 指定 SOAP 1.2 中的角色 None。
URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER - 接口 javax.xml.soap.SOAPConstants 中的静态变量
该 URI 标识 SOAP 1.2 消息的最终接收者。
URI_SOAP_ACTOR_NEXT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
该 URI 标识将 SOAP 请求处理为 SOAP 1.1 头条目预定参与者的下一个应用程序（请参阅 SOAP 1.1 规范的第 4.2.2 节）。
URIDereferencer - javax.xml.crypto 中的 接口
URIReference 的 dereferencer。
URIException - javax.print 中的 接口
接口 URIException 是一个混合接口，PrintException 的子类可实现它来报告有关 URI 地址的错误状况。
URIInaccessible - 接口 javax.print.URIException 中的静态变量
指示打印机无法访问该 URI 地址。
URIOtherProblem - 接口 javax.print.URIException 中的静态变量
指示出于所有其他原因未明确标识的问题类别。
URIParameter - java.security 中的 类
包含一个 URI 的参数，该 URI 指向用于 PolicySpi 或 ConfigurationSpi 实现的数据。
URIParameter(URI) - 类 java.security.URIParameter 的构造方法
使用指向数据的 URI 构造一个 URIParameter，指向的数据用于 SPI 实现。
URIReference - javax.xml.crypto 中的 接口
通过 URI-Reference 标识数据对象，正如 RFC 2396 所指定的。
URIReferenceException - javax.xml.crypto 中的 异常
指示取消引用 URIReference 时抛出的异常条件。
URIReferenceException() - 异常 javax.xml.crypto.URIReferenceException 的构造方法
构造使用 null 作为其详细消息的新 URIReferenceException。
URIReferenceException(String) - 异常 javax.xml.crypto.URIReferenceException 的构造方法
构造带指定详细消息的新 URIReferenceException。
URIReferenceException(String, Throwable) - 异常 javax.xml.crypto.URIReferenceException 的构造方法
构造带指定详细消息和 cause 的新 URIReferenceException。
URIReferenceException(String, Throwable, URIReference) - 异常 javax.xml.crypto.URIReferenceException 的构造方法
构造带指定详细消息、cause 和 URIReference 的新 URIReferenceException。
URIReferenceException(Throwable) - 异常 javax.xml.crypto.URIReferenceException 的构造方法
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 URIReferenceException（它通常包含 cause 的类和详细消息）。
URIResolver - javax.xml.transform 中的 接口
实现此接口的对象可由处理器进行调用，以将 document()、xsl:import 或 xsl:include 中使用的 URI 转换为 Source 对象。
URISchemeNotSupported - 接口 javax.print.URIException 中的静态变量
指示打印机不支持该 URI 地址中的 URI 方案（"http"、"ftp" 等等）。
URISyntax - javax.print.attribute 中的 类
类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。
URISyntax(URI) - 类 javax.print.attribute.URISyntax 的构造方法
构造带有指定 URI 的 URI 属性。
URISyntaxException - java.net 中的 异常
抛出经过检查的指示字符串不能解析为 URI 引用的异常。
URISyntaxException(String, String, int) - 异常 java.net.URISyntaxException 的构造方法
根据给定的输入字符串、原因和错误索引构造一个实例。
URISyntaxException(String, String) - 异常 java.net.URISyntaxException 的构造方法
根据给定的输入字符串和原因构造一个实例。
URL - java.net 中的 类
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。
URL(String, String, int, String) - 类 java.net.URL 的构造方法
根据指定 protocol、host、port 号和 file 创建 URL 对象。
URL(String, String, String) - 类 java.net.URL 的构造方法
根据指定的 protocol 名称、host 名称和 file 名称创建 URL。
URL(String, String, int, String, URLStreamHandler) - 类 java.net.URL 的构造方法
根据指定的 protocol、host、port 号、file 和 handler 创建 URL 对象。
URL(String) - 类 java.net.URL 的构造方法
根据 String 表示形式创建 URL 对象。
URL(URL, String) - 类 java.net.URL 的构造方法
通过在指定的上下文中对给定的 spec 进行解析创建 URL。
URL(URL, String, URLStreamHandler) - 类 java.net.URL 的构造方法
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。
url - 类 java.net.URLConnection 中的变量
URL 表示此连接要在互联网上打开的远程对象。
URL_PKG_PREFIXES - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定加载 URL 上下文工厂时要使用的包前缀列表的环境属性名称。
URLClassLoader - java.net 中的 类
该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。
URLClassLoader(URL[], ClassLoader) - 类 java.net.URLClassLoader 的构造方法
为给定的 URL 构造新 URLClassLoader。
URLClassLoader(URL[]) - 类 java.net.URLClassLoader 的构造方法
使用默认的委托父 ClassLoader 为指定的 URL 构造一个新 URLClassLoader。
URLClassLoader(URL[], ClassLoader, URLStreamHandlerFactory) - 类 java.net.URLClassLoader 的构造方法
为指定的 URL、父类加载器和 URLStreamHandlerFactory 创建新 URLClassLoader。
URLConnection - java.net 中的 类
抽象类 URLConnection 是所有类的超类，它代表应用程序和 URL 之间的通信链接。
URLConnection(URL) - 类 java.net.URLConnection 的构造方法
构造一个到指定 URL 的 URL 连接。
URLDataSource - javax.activation 中的 类
URLDataSource 类提供一个对象，此对象将 URL 对象包装在 DataSource 接口中。
URLDataSource(URL) - 类 javax.activation.URLDataSource 的构造方法
URLDataSource 构造方法。
URLDecoder - java.net 中的 类
HTML 格式解码的实用工具类。
URLDecoder() - 类 java.net.URLDecoder 的构造方法
URLEncoder - java.net 中的 类
HTML 格式编码的实用工具类。
URLStreamHandler - java.net 中的 类
抽象类 URLStreamHandler 是所有流协议处理程序的通用超类。
URLStreamHandler() - 类 java.net.URLStreamHandler 的构造方法
URLStreamHandlerFactory - java.net 中的 接口
该接口为 URL 流协议处理程序定义一个工厂。
URLStringHelper - org.omg.CosNaming.NamingContextExtPackage 中的 类
URLString 是以 String 形式表示的 URL 地址（corbaloc: 或 corbaname:）。
URLStringHelper() - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 的构造方法
US - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
USE_ACTIVE_OBJECT_MAP_ONLY - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
USE_ALL_BEANINFO - 类 java.beans.Introspector 中的静态变量
USE_DEFAULT_SERVANT - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
USE_SERVANT_MANAGER - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
USE_STD3_ASCII_RULES - 类 java.net.IDN 中的静态变量
根据 STD-3 ASCII 规则执行检查的标志。
useAnchoringBounds(boolean) - 类 java.util.regex.Matcher 中的方法
设置匹配器区域界限的定位。
useCaches - 类 java.net.URLConnection 中的变量
如果为 true，则只要有条件就允许协议使用缓存。
useDaylightTime() - 类 java.util.SimpleTimeZone 中的方法
如果此时区使用夏令时，则执行查询。
useDaylightTime() - 类 java.util.TimeZone 中的方法
查询此时区是否使用夏令时。
useDelimiter(Pattern) - 类 java.util.Scanner 中的方法
将此扫描器的分隔模式设置为指定模式。
useDelimiter(String) - 类 java.util.Scanner 中的方法
将此扫描器的分隔模式设置为从指定 String 构造的模式。
useLocale(Locale) - 类 java.util.Scanner 中的方法
将此扫描器的语言环境设置为指定的语言环境。
USEMAP - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
usePattern(Pattern) - 类 java.util.regex.Matcher 中的方法
更改此 Matcher 用于查找匹配项的 Pattern。
useProtocolVersion(int) - 类 java.io.ObjectOutputStream 中的方法
指定要在写入流时使用的流协议版本。
USER_EXCEPTION - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/USER_EXCEPTION.java。
USER_ID - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的静态变量
useRadix(int) - 类 java.util.Scanner 中的方法
将此扫描器的默认基数设置为指定基数。
UserDataHandler - org.w3c.dom 中的 接口
当使用 Node.setUserData() 将一个对象与节点上的键相关联时，当克隆、导入或重命名该对象关联的节点时应用程序可以提供调用的处理程序。
UserException - org.omg.CORBA 中的 异常
CORBA IDL 定义的用户异常的根类。
UserException() - 异常 org.omg.CORBA.UserException 的构造方法
构造一个 UserException 对象。
UserException(String) - 异常 org.omg.CORBA.UserException 的构造方法
构造带详细消息的 UserException 对象。
USERNAME_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
标准属性：用于验证的用户名。
userNodeForPackage(Class<?>) - 类 java.util.prefs.Preferences 中的静态方法
从调用用户首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
userObject - 类 javax.swing.tree.DefaultMutableTreeNode 中的变量
可选用户对象
userRoot() - 类 java.util.prefs.Preferences 中的静态方法
返回调用用户的根首选项节点。
userRoot() - 接口 java.util.prefs.PreferencesFactory 中的方法
返回与调用用户相对应的用户根首选项节点。
usesFractionalMetrics() - 类 java.awt.font.FontRenderContext 中的方法
返回一个 boolean 值，指示是否在此 FontRenderContext 中使用文本 fractional metrics 模式。
usesLocalFilePerTable() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否为每个表使用一个文件。
usesLocalFiles() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将表存储在本地文件中。
usesShiftModifier() - 类 java.awt.MenuShortcut 中的方法
返回是否此菜单快捷方式必须使用 SHIFT 键调用。
useToString(int) - 类 javax.swing.DefaultRowSorter 中的方法
返回排序过程中进行比较之前是否要将值转换为字符串。
useToString(int) - 类 javax.swing.table.TableRowSorter 中的方法
返回排序过程中进行比较之前是否要将值转换为字符串。
useTransparentBounds(boolean) - 类 java.util.regex.Matcher 中的方法
设置此匹配器区域边界的透明度。
UShortSeqHelper - org.omg.CORBA 中的 类
UShortSeq 的 Helper。
UShortSeqHelper() - 类 org.omg.CORBA.UShortSeqHelper 的构造方法
UShortSeqHolder - org.omg.CORBA 中的 类
UShortSeq 的 Holder。
UShortSeqHolder() - 类 org.omg.CORBA.UShortSeqHolder 的构造方法
UShortSeqHolder(short[]) - 类 org.omg.CORBA.UShortSeqHolder 的构造方法
usingProxy() - 类 java.net.HttpURLConnection 中的方法
指示连接是否通过代理。
UTC(int, int, int, int, int, int) - 类 java.util.Date 中的静态方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代，使用 UTC TimeZone，后跟 Calendar.getTime().getTime()。
UTC_TIME - 类 java.util.SimpleTimeZone 中的静态变量
指定为 UTC 的开始或结束时间模式的常量。
UTFDataFormatException - java.io 中的 异常
在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
UTFDataFormatException() - 异常 java.io.UTFDataFormatException 的构造方法
构造用 null 作为其错误详细消息的 UTFDataFormatException。
UTFDataFormatException(String) - 异常 java.io.UTFDataFormatException 的构造方法
构造带有指定详细消息的 UTFDataFormatException。
Util - javax.rmi.CORBA 中的 类
提供可以由 stub 和 tie 用于执行公共操作的实用方法。
UtilDelegate - javax.rmi.CORBA 中的 接口
支持 Util 中方法实现的委托。
Utilities - javax.swing.text 中的 类
处理各种文本相关活动的方法集合。
Utilities() - 类 javax.swing.text.Utilities 的构造方法
UUID - java.util 中的 类
表示通用唯一标识符 (UUID) 的类。
UUID(long, long) - 类 java.util.UUID 的构造方法
使用指定的数据构造新的 UUID。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


V - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

V

valid() - 类 java.io.FileDescriptor 中的方法
测试此文件描述符对象是否有效。
validate() - 类 java.awt.Component 中的方法
确保组件具有有效的布局。
validate() - 类 java.awt.Container 中的方法
验证此容器及其所有子组件。
validate(GraphicsConfiguration) - 类 java.awt.image.VolatileImage 中的方法
如果上次调用 validate 后绘制表面丢失，则试图恢复图像的绘制表面。
validate(CertPath, CertPathParameters) - 类 java.security.cert.CertPathValidator 中的方法
使用指定的算法参数集验证指定的证书路径。
validate() - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
validate() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
validate() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
validate(Object) - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
validate(XMLValidateContext) - 接口 javax.xml.crypto.dsig.Reference 中的方法
验证此引用。
validate(XMLValidateContext) - 接口 javax.xml.crypto.dsig.XMLSignature.SignatureValue 中的方法
验证签名值。
validate(XMLValidateContext) - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
根据核心验证处理规则来验证签名。
validate(Source) - 类 javax.xml.validation.Validator 中的方法
验证指定的输入。
validate(Source, Result) - 类 javax.xml.validation.Validator 中的方法
验证指定输入并将扩充的验证结果发送到指定输出。
validate_connection() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
validatedContents - 类 java.awt.Component.BltBufferStrategy 中的变量
绘制缓冲区最近是否已经从丢失状态中恢复。
validatedContents - 类 java.awt.Component.FlipBufferStrategy 中的变量
绘制缓冲区是否已从最近的丢失状态还原。
validateFileCache() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
validateInvalidComponents() - 类 javax.swing.RepaintManager 中的方法
验证被标记为无效的所有组件。
validateObject() - 接口 java.io.ObjectInputValidation 中的方法
验证对象。
validatePage(PageFormat) - 类 java.awt.print.PrinterJob 中的方法
返回 page 的副本，调整其设置，以与此 PrinterJob 的当前打印机兼容。
validatePendingAdd(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象添加到 BeanContext 之前立即检查它们。
validatePendingRemove(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象从 BeanContext 中移除之前立即检查它们。
validatePendingSetBeanContext(BeanContext) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
从 setBeanContext 调用，以验证（或相反）嵌套 BeanContext 属性值中的挂起更改。
validateRoot(Object) - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
validateTree() - 类 java.awt.Container 中的方法
递归继承容器树，对于所有被标记为需要重新计算布局的子树（标记为无效的那些子树）重新计算布局。
validating - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的变量
指示 Unmarshaller 是否将执行验证。
VALIDATION_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果调用诸如 insertBefore 或 removeChild 之类的方法使 Node 无效(和 "partial validity" 有关的），则引发此异常并且将不进行操作。
ValidationEvent - javax.xml.bind 中的 接口
此事件指示在执行解组操作期间验证传入的 XML 数据时、对 Java 内容树执行按需验证时或将 Java 内容树编组回 XML 数据时遇到问题。
ValidationEventCollector - javax.xml.bind.util 中的 类
收集所有事件的 ValidationEventHandler 实现。
ValidationEventCollector() - 类 javax.xml.bind.util.ValidationEventCollector 的构造方法
ValidationEventHandler - javax.xml.bind 中的 接口
用来验证错误的基本事件处理程序接口。
ValidationEventImpl - javax.xml.bind.helpers 中的 类
ValidationEvent 接口的默认实现。
ValidationEventImpl(int, String, ValidationEventLocator) - 类 javax.xml.bind.helpers.ValidationEventImpl 的构造方法
创建新的 ValidationEventImpl。
ValidationEventImpl(int, String, ValidationEventLocator, Throwable) - 类 javax.xml.bind.helpers.ValidationEventImpl 的构造方法
创建新的 ValidationEventImpl。
ValidationEventLocator - javax.xml.bind 中的 接口
封装 ValidationEvent 的位置。
ValidationEventLocatorImpl - javax.xml.bind.helpers 中的 类
ValidationEventLocator 接口的默认实现。
ValidationEventLocatorImpl() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的构造方法
创建所有字段都不可用的对象。
ValidationEventLocatorImpl(Locator) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的构造方法
根据 org.xml.sax.Locator 构造一个对象。
ValidationEventLocatorImpl(SAXParseException) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的构造方法
根据 SAXParseException 的位置信息构造一个对象。
ValidationEventLocatorImpl(Node) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的构造方法
构造一个指向 DOM Node 的对象。
ValidationEventLocatorImpl(Object) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的构造方法
构造一个指向 JAXB 内容对象的对象。
ValidationException - javax.xml.bind 中的 异常
此异常指示在执行验证操作时发生错误。
ValidationException(String) - 异常 javax.xml.bind.ValidationException 的构造方法
构造带指定详细消息的 ValidationException。
ValidationException(String, String) - 异常 javax.xml.bind.ValidationException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 ValidationException。
ValidationException(Throwable) - 异常 javax.xml.bind.ValidationException 的构造方法
构造带有一个 linkedException 的 ValidationException。
ValidationException(String, Throwable) - 异常 javax.xml.bind.ValidationException 的构造方法
构造带指定的详细消息和 linkedException 的 ValidationException。
ValidationException(String, String, Throwable) - 异常 javax.xml.bind.ValidationException 的构造方法
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 ValidationException。
Validator - javax.xml.bind 中的 接口
已过时。 从 JAXB 2.0 开始
Validator - javax.xml.validation 中的 类
根据 Schema 检查 XML 文档的处理器。
Validator() - 类 javax.xml.validation.Validator 的构造方法
派生类的构造方法。
ValidatorHandler - javax.xml.validation 中的 类
处理 SAX 流的流验证器。
ValidatorHandler() - 类 javax.xml.validation.ValidatorHandler 的构造方法
派生类的构造方法。
validCachedPreferredSize - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
preferredSize 是否有效？
validOps() - 类 java.nio.channels.DatagramChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
validOps() - 类 java.nio.channels.Pipe.SinkChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
validOps() - 类 java.nio.channels.Pipe.SourceChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
validOps() - 类 java.nio.channels.SelectableChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
validOps() - 类 java.nio.channels.ServerSocketChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
validOps() - 类 java.nio.channels.SocketChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
VALIGN - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
value - 类 java.sql.DriverPropertyInfo 中的变量
value 字段通过综合为 getPropertyInfo 方法提供的信息、Java 环境和驱动程序提供的默认值来指定当前属性值。
value(String) - 类 javax.management.Query 中的静态方法
返回一个新的字符串表达式。
value(Number) - 类 javax.management.Query 中的静态方法
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value(int) - 类 javax.management.Query 中的静态方法
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value(long) - 类 javax.management.Query 中的静态方法
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value(float) - 类 javax.management.Query 中的静态方法
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value(double) - 类 javax.management.Query 中的静态方法
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value(boolean) - 类 javax.management.Query 中的静态方法
返回一个 boolean 值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value - 类 javax.naming.ldap.BasicControl 中的变量
控件的 ASN.1 BER 编码值。
value - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的变量
此单元格的值。
value - 类 javax.swing.JOptionPane 中的变量
当前选择的值，该值将为有效选项或者 UNINITIALIZED_VALUE 或 null。
VALUE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
value - 类 javax.swing.text.html.parser.AttributeList 中的变量
value - 类 javax.xml.bind.JAXBElement 中的变量
xml 元素值。
value - 类 javax.xml.ws.Holder 中的变量
持有者中包含的值。
value - 类 org.omg.CORBA.AnyHolder 中的变量
此 AnyHolder 对象保存的 Any 值。
value - 类 org.omg.CORBA.AnySeqHolder 中的变量
value - 接口 org.omg.CORBA.ARG_IN 中的静态变量
指示 input 参数的值。
value - 接口 org.omg.CORBA.ARG_INOUT 中的静态变量
指示用于输入和输出的参数的常量值。
value - 接口 org.omg.CORBA.ARG_OUT 中的静态变量
指示 output 参数的常量值。
value - 接口 org.omg.CORBA.BAD_POLICY 中的静态变量
PolicyError 异常中的 Error 代码。
value - 接口 org.omg.CORBA.BAD_POLICY_TYPE 中的静态变量
PolicyError 异常中的 Error 代码。
value - 接口 org.omg.CORBA.BAD_POLICY_VALUE 中的静态变量
该值用于表示 PolicyError 异常中的严重策略值错误。
value - 类 org.omg.CORBA.BooleanHolder 中的变量
此 BooleanHolder 对象保存的 boolean 值。
value - 类 org.omg.CORBA.BooleanSeqHolder 中的变量
value - 类 org.omg.CORBA.ByteHolder 中的变量
此 ByteHolder 对象保存的 byte 值。
value - 类 org.omg.CORBA.CharHolder 中的变量
此 CharHolder 对象保存的 char 值。
value - 类 org.omg.CORBA.CharSeqHolder 中的变量
value() - 类 org.omg.CORBA.CompletionStatus 中的方法
检索此 CompletionStatus 对象的值。
value - 接口 org.omg.CORBA.CTX_RESTRICT_SCOPE 中的静态变量
该字段包含 CTX_RESTRICT_SCOPE 标志的 int 值。
value - 类 org.omg.CORBA.CurrentHolder 中的变量
value() - 类 org.omg.CORBA.DefinitionKind 中的方法
返回标识 IR 对象类型的 int 常量。
value - 类 org.omg.CORBA.DoubleHolder 中的变量
此 DoubleHolder 对象保存的 double 值。
value - 类 org.omg.CORBA.DoubleSeqHolder 中的变量
value - 类 org.omg.CORBA.FixedHolder 中的变量
FixedHolder 保存的值。
value - 类 org.omg.CORBA.FloatHolder 中的变量
此 FloatHolder 对象保存的 float 值。
value - 类 org.omg.CORBA.FloatSeqHolder 中的变量
value - 类 org.omg.CORBA.IntHolder 中的变量
此 IntHolder 对象在其 value 字段中保存的 int 值。
value - 类 org.omg.CORBA.LongHolder 中的变量
此 LongHolder 对象保存的 long 值。
value - 类 org.omg.CORBA.LongLongSeqHolder 中的变量
value - 类 org.omg.CORBA.LongSeqHolder 中的变量
value() - 类 org.omg.CORBA.NamedValue 中的方法
检索此 NamedValue 对象的值。
value - 类 org.omg.CORBA.NameValuePair 中的变量
将通过此 NameValuePair 对象与某一名称关联的值。
value - 类 org.omg.CORBA.ObjectHolder 中的变量
此 ObjectHolder 对象保存的 Object 值。
value - 类 org.omg.CORBA.OctetSeqHolder 中的变量
value - 接口 org.omg.CORBA.OMGVMCID 中的静态变量
为 OMG 保留的供应商次要代码 ID。
value() - 类 org.omg.CORBA.ParameterMode 中的方法
value - 类 org.omg.CORBA.ParameterModeHolder 中的变量
value - 类 org.omg.CORBA.PolicyErrorHolder 中的变量
value - 类 org.omg.CORBA.PolicyHolder 中的变量
value - 类 org.omg.CORBA.PolicyListHolder 中的变量
value - 类 org.omg.CORBA.PrincipalHolder 中的变量
已过时。 此 PrincipalHolder 对象保存的 Principal 值。
value - 接口 org.omg.CORBA.PRIVATE_MEMBER 中的静态变量
value - 接口 org.omg.CORBA.PUBLIC_MEMBER 中的静态变量
value - 类 org.omg.CORBA.ServiceInformationHolder 中的变量
此 ServiceInformationHolder 对象保存在其 value 字段中的 ServiceInformation 值。
value() - 类 org.omg.CORBA.SetOverrideType 中的方法
检索此 SetOverrideType 实例的值。
value - 类 org.omg.CORBA.ShortHolder 中的变量
此 ShortHolder 对象保存的 short 值。
value - 类 org.omg.CORBA.ShortSeqHolder 中的变量
value - 类 org.omg.CORBA.StringHolder 中的变量
此 StringHolder 对象保存的 String 值。
value - 类 org.omg.CORBA.StringSeqHolder 中的变量
value() - 类 org.omg.CORBA.TCKind 中的方法
检索此 TCKind 实例的值。
value - 类 org.omg.CORBA.TypeCodeHolder 中的变量
此 TypeCodeHolder 对象保存的 TypeCode 值。
value - 类 org.omg.CORBA.ULongLongSeqHolder 中的变量
value - 类 org.omg.CORBA.ULongSeqHolder 中的变量
value - 类 org.omg.CORBA.UnknownUserExceptionHolder 中的变量
value - 接口 org.omg.CORBA.UNSUPPORTED_POLICY 中的静态变量
PolicyError 异常的 Error 代码。
value - 接口 org.omg.CORBA.UNSUPPORTED_POLICY_VALUE 中的静态变量
PolicyError 异常的 Error 代码。
value - 类 org.omg.CORBA.UShortSeqHolder 中的变量
value - 类 org.omg.CORBA.ValueBaseHolder 中的变量
此 ValueBaseHolder 对象保存的 java.io.Serializable 值。
value - 接口 org.omg.CORBA.VM_ABSTRACT 中的静态变量
表示 typecode 中的抽象接口值类型的值。
value - 接口 org.omg.CORBA.VM_CUSTOM 中的静态变量
表示 typecode 中自定义编组值类型的值。
value - 接口 org.omg.CORBA.VM_NONE 中的静态变量
根据 CORBA 2.3 规范表示 typecode 中值类型的值。
value - 接口 org.omg.CORBA.VM_TRUNCATABLE 中的静态变量
表示 typecode 中可截断值类型的值。
value - 类 org.omg.CORBA.WCharSeqHolder 中的变量
value - 类 org.omg.CORBA.WrongTransactionHolder 中的变量
value - 类 org.omg.CORBA.WStringSeqHolder 中的变量
value - 类 org.omg.CosNaming.BindingHolder 中的变量
value - 类 org.omg.CosNaming.BindingIteratorHolder 中的变量
value - 类 org.omg.CosNaming.BindingListHolder 中的变量
value() - 类 org.omg.CosNaming.BindingType 中的方法
value - 类 org.omg.CosNaming.BindingTypeHolder 中的变量
value - 类 org.omg.CosNaming.NameComponentHolder 中的变量
value - 类 org.omg.CosNaming.NameHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextExtHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 中的变量
value() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的方法
value - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 中的变量
value - 类 org.omg.DynamicAny.NameDynAnyPair 中的变量
与名称关联的 DynAny 值。
value - 类 org.omg.DynamicAny.NameValuePair 中的变量
与名称关联的 Any 值。
value - 接口 org.omg.IOP.CodeSets 中的静态变量
标识在 "GIOP Code Set Service Context" 13-43 页，13.10.2.5 这一部分定义的 CONV_FRAME.CodeSetContext CDR 封装。
value - 接口 org.omg.IOP.ENCODING_CDR_ENCAPS 中的静态变量
CDR Encapsulation 编码。
value - 接口 org.omg.IOP.ExceptionDetailMessage 中的静态变量
CORBA formal/02-06-01:13.7.1: ExceptionDetailMessage，它标识 wstring 的 CDR 封装，使用 GIOP 1.2 与 UTF-16 的 TCS-W 编码。
value - 类 org.omg.IOP.IORHolder 中的变量
value - 类 org.omg.IOP.MultipleComponentProfileHolder 中的变量
value - 接口 org.omg.IOP.RMICustomMaxStreamFormat 中的静态变量
标识 RMICustomMaxStreamFormat 服务上下文的 CDR 封装，该封装中包含指示客户端最大 RMI-IIOP 流格式形式的单个字节。
value - 类 org.omg.IOP.ServiceContextHolder 中的变量
value - 类 org.omg.IOP.ServiceContextListHolder 中的变量
value - 接口 org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS 中的静态变量
在将同一个对象键 (object key) 用于多个互联网位置的情况下，定义了以下标准 IOR Component 来支持 IIOP 1.2 版。
value - 接口 org.omg.IOP.TAG_CODE_SETS 中的静态变量
IOR 多组件配置文件结构的代码集组件包括： 服务器的本机 char 代码集和变换码集，和 服务器的本机 wchar 代码集和变换码集。
value - 接口 org.omg.IOP.TAG_INTERNET_IOP 中的静态变量
标识支持网络 ORB 交换协议 (Internet Inter-ORB Protocol) 的配置文件。
value - 接口 org.omg.IOP.TAG_JAVA_CODEBASE 中的静态变量
支持 stub、tie、value 和 value helper 的类下载。
value - 接口 org.omg.IOP.TAG_MULTIPLE_COMPONENTS 中的静态变量
指示封装的值类型为 MultipleComponentProfile。
value - 接口 org.omg.IOP.TAG_ORB_TYPE 中的静态变量
它在实际应用中通常很有用，能够标识生成对象引用的特定 ORB 种类、解决该特定 ORB 的问题，或者充分利用共享效率。
value - 接口 org.omg.IOP.TAG_POLICIES 中的静态变量
一个包含 QoS 策略序列的配置文件组件，这些策略通过对象适配器与对象引用一起输出。
value - 接口 org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT 中的静态变量
RMI-IIOP 具有多个流格式形式。
value - 类 org.omg.IOP.TaggedComponentHolder 中的变量
value - 类 org.omg.IOP.TaggedProfileHolder 中的变量
value - 接口 org.omg.IOP.TransactionService 中的静态变量
标识一个定义在 CORBAservices: Common Object Services Specifications 中的 CosTSInteroperation.PropogationContext 的 CDR 封装。
value - 接口 org.omg.Messaging.SYNC_WITH_TRANSPORT 中的静态变量
Messaging 规范中定义的常量，定义请求在控件返回客户端前应传输的距离。
value - 接口 org.omg.PortableInterceptor.ACTIVE 中的静态变量
指示正常请求处理的对象适配器状态。
value - 接口 org.omg.PortableInterceptor.DISCARDING 中的静态变量
导致丢弃所有请求的对象适配器状态。
value - 接口 org.omg.PortableInterceptor.HOLDING 中的静态变量
在状态更改前暂时保持请求的对象适配器状态。
value - 接口 org.omg.PortableInterceptor.INACTIVE 中的静态变量
导致丢弃所有请求的对象适配器状态。
value - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 中的变量
value - 接口 org.omg.PortableInterceptor.LOCATION_FORWARD 中的静态变量
指示 LocationForward 应答状态。
value - 接口 org.omg.PortableInterceptor.NON_EXISTENT 中的静态变量
指示适配器已经被销毁的对象适配器状态。
value - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 中的变量
value - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 中的变量
value - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 中的变量
value - 接口 org.omg.PortableInterceptor.SUCCESSFUL 中的静态变量
指示一个成功的应答状态。
value - 接口 org.omg.PortableInterceptor.SYSTEM_EXCEPTION 中的静态变量
指示 SystemException 应答状态。
value - 接口 org.omg.PortableInterceptor.TRANSPORT_RETRY 中的静态变量
指示 Transport Retry 应答状态。
value - 接口 org.omg.PortableInterceptor.UNKNOWN 中的静态变量
XXX
value - 接口 org.omg.PortableInterceptor.USER_EXCEPTION 中的静态变量
指示 UserException 应答状态。
value - 接口 org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID 中的静态变量
表示 ID_ASSIGNMENT_POLICY_ID 的值。
value - 接口 org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID 中的静态变量
表示 ID_UNIQUENESS_POLICY_ID 的值。
value() - 接口 org.omg.PortableServer.IdAssignmentPolicyOperations 中的方法
指定策略值。
value() - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的方法
value() - 接口 org.omg.PortableServer.IdUniquenessPolicyOperations 中的方法
指定策略值
value() - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的方法
value - 接口 org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID 中的静态变量
表示 IMPLICIT_ACTIVATION_POLICY_ID 的值。
value() - 接口 org.omg.PortableServer.ImplicitActivationPolicyOperations 中的方法
指定策略值
value() - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的方法
value - 接口 org.omg.PortableServer.LIFESPAN_POLICY_ID 中的静态变量
表示 LIFESPAN_POLICY_ID 的值。
value() - 接口 org.omg.PortableServer.LifespanPolicyOperations 中的方法
指定策略值
value() - 类 org.omg.PortableServer.LifespanPolicyValue 中的方法
value() - 类 org.omg.PortableServer.POAManagerPackage.State 中的方法
value - 接口 org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID 中的静态变量
表示 REQUEST_PROCESSING_POLICY_ID 的值。
value() - 接口 org.omg.PortableServer.RequestProcessingPolicyOperations 中的方法
指定策略值
value() - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的方法
value - 接口 org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID 中的静态变量
表示 SERVANT_RETENTION_POLICY_ID 的值。
value - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 中的变量
value() - 接口 org.omg.PortableServer.ServantRetentionPolicyOperations 中的方法
指示策略值
value() - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的方法
value - 接口 org.omg.PortableServer.THREAD_POLICY_ID 中的静态变量
表示 THREAD_POLICY_ID 的值。
value() - 接口 org.omg.PortableServer.ThreadPolicyOperations 中的方法
指定策略值
value() - 类 org.omg.PortableServer.ThreadPolicyValue 中的方法
VALUE_ALPHA_INTERPOLATION_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
Alpha 插值提示值——由实现选择对性能和质量进行良好权衡的 alpha 混合算法
VALUE_ALPHA_INTERPOLATION_QUALITY - 类 java.awt.RenderingHints 中的静态变量
Alpha 插值提示值——选择偏重于精确度和视觉质量的 alpha 混合算法。
VALUE_ALPHA_INTERPOLATION_SPEED - 类 java.awt.RenderingHints 中的静态变量
Alpha 插值提示值——选择偏重于计算速度的 alpha 混合算法。
VALUE_ANTIALIAS_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
抗锯齿提示值——使用由实现选择的默认抗锯齿模式完成呈现。
VALUE_ANTIALIAS_OFF - 类 java.awt.RenderingHints 中的静态变量
抗锯齿提示值——在不使用抗锯齿模式的情况下完成呈现。
VALUE_ANTIALIAS_ON - 类 java.awt.RenderingHints 中的静态变量
抗锯齿提示值——使用抗锯齿模式完成呈现。
VALUE_ARBITRARY - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为单个任意值。
value_as_string() - 接口 org.omg.CORBA.DynEnum 中的方法
已过时。 以字符串形式返回此 DynEnum 中存储的 IDL enum 的值。
value_as_string(String) - 接口 org.omg.CORBA.DynEnum 中的方法
已过时。 设置此 DynEnum 中的特定 enum。
value_as_ulong() - 接口 org.omg.CORBA.DynEnum 中的方法
已过时。 以 Java int 值形式返回 IDL enum 的值。
value_as_ulong(int) - 接口 org.omg.CORBA.DynEnum 中的方法
已过时。 设置 IDL enum 的值。
VALUE_COLOR_RENDER_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
颜色呈现提示值——根据实现的选择执行颜色转换计算，以表示可用的性能和精确度之间的最佳权衡。
VALUE_COLOR_RENDER_QUALITY - 类 java.awt.RenderingHints 中的静态变量
颜色呈现提示值——用最高的精确度和视觉质量执行颜色转换计算。
VALUE_COLOR_RENDER_SPEED - 类 java.awt.RenderingHints 中的静态变量
颜色呈现提示值——最快地执行输出设备格式的颜色转换。
VALUE_DITHER_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
抖动提示值——对该实现选择的抖动使用默认值。
VALUE_DITHER_DISABLE - 类 java.awt.RenderingHints 中的静态变量
抖动提示值——呈现几何形状时不抖动。
VALUE_DITHER_ENABLE - 类 java.awt.RenderingHints 中的静态变量
抖动提示值——如果需要，在呈现几何形状时抖动。
VALUE_ENUMERATION - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为许多枚举值之一。
VALUE_FRACTIONALMETRICS_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
字体小数规格提示值——用实现选择的精度定位字符字形。
VALUE_FRACTIONALMETRICS_OFF - 类 java.awt.RenderingHints 中的静态变量
字体小数规格提示值——用舍入为像素边界的 advance width 定位字符字形。
VALUE_FRACTIONALMETRICS_ON - 类 java.awt.RenderingHints 中的静态变量
字体小数规格提示值——用子像素精确度定位字符字形。
VALUE_INTERPOLATION_BICUBIC - 类 java.awt.RenderingHints 中的静态变量
插值提示值—— 使用 X 和 Y 中的立方函数插入图像中整数坐标附近的 9 个样本，以生成一个颜色样本。
VALUE_INTERPOLATION_BILINEAR - 类 java.awt.RenderingHints 中的静态变量
插值提示值——图像中最接近整数坐标样本的 4 种颜色样本被线性地插入，以生成一个颜色样本。
VALUE_INTERPOLATION_NEAREST_NEIGHBOR - 类 java.awt.RenderingHints 中的静态变量
插值提示值——使用图像中最接近整数坐标样本的颜色样本。
VALUE_LIST - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为一个值的列表或数组。
VALUE_NONE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getObjectValueType 返回的常量，指示缺少用户对象。
VALUE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
value 的绑定属性名。
VALUE_RANGE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可能将属性或用户对象设置为某个值范围。
VALUE_RANGE_MAX_INCLUSIVE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可将属性或用户对象设置为某个值范围。
VALUE_RANGE_MAX_INCLUSIVE_MASK - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
该值可以与 VALUE_RANGE 进行“或”运算来获取 VALUE_RANGE_MAX_INCLUSIVE，可以与 VALUE_RANGE_MIN_INCLUSIVE 进行“或”运算来获取 VALUE_RANGE_MIN_MAX_INCLUSIVE。
VALUE_RANGE_MIN_INCLUSIVE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为某个值范围。
VALUE_RANGE_MIN_INCLUSIVE_MASK - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
该值可以与 VALUE_RANGE 进行“或”运算来获取 VALUE_RANGE_MIN_INCLUSIVE，可以与 VALUE_RANGE_MAX_INCLUSIVE 进行“或”运算来获取 VALUE_RANGE_MIN_MAX_INCLUSIVE。
VALUE_RANGE_MIN_MAX_INCLUSIVE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为某个值范围。
VALUE_RENDER_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
呈现提示值——由实现选择对性能和质量进行良好权衡的呈现算法。
VALUE_RENDER_QUALITY - 类 java.awt.RenderingHints 中的静态变量
呈现提示值——选择偏重输出质量的呈现算法。
VALUE_RENDER_SPEED - 类 java.awt.RenderingHints 中的静态变量
呈现提示值——选择偏重输出速度的呈现算法。
VALUE_STROKE_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
笔划规范化控制提示值——根据给定实现的权衡，可以修改几何形状或保留原来的几何形状。
VALUE_STROKE_NORMALIZE - 类 java.awt.RenderingHints 中的静态变量
笔划规范化控制提示值——几何形状应当规范化，以提高均匀性或直线间隔和整体美观。
VALUE_STROKE_PURE - 类 java.awt.RenderingHints 中的静态变量
笔划规范化控制提示值——几何形状应该保持不变并使用子像素精确度呈现。
VALUE_TEXT_ANTIALIAS_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——根据 RenderingHints.KEY_ANTIALIASING 提示或由实现选择的默认值完成文本呈现。
VALUE_TEXT_ANTIALIAS_GASP - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——文本呈现需要使用字体资源中的信息，这些信息指定了每个点大小是否适合应用 RenderingHints.VALUE_TEXT_ANTIALIAS_ON 或 RenderingHints.VALUE_TEXT_ANTIALIAS_OFF。
VALUE_TEXT_ANTIALIAS_LCD_HBGR - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素按从左到右为 B、G、R 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HBGR) 的三倍。
VALUE_TEXT_ANTIALIAS_LCD_HRGB - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，该 LCD 显示器子像素按从左到右为 R、G、B 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HRGB) 的三倍。
VALUE_TEXT_ANTIALIAS_LCD_VBGR - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VBGR) 的三倍。
VALUE_TEXT_ANTIALIAS_LCD_VRGB - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VRGB) 的三倍。
VALUE_TEXT_ANTIALIAS_OFF - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——不使用任何抗锯齿形式完成文本呈现。
VALUE_TEXT_ANTIALIAS_ON - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——使用某种抗锯齿形式完成文本呈现。
ValueBase - org.omg.CORBA.portable 中的 接口
所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。
ValueBaseHelper - org.omg.CORBA 中的 类
ValueBaseHelper() - 类 org.omg.CORBA.ValueBaseHelper 的构造方法
ValueBaseHolder - org.omg.CORBA 中的 类
ValueBase 的 Holder。
ValueBaseHolder() - 类 org.omg.CORBA.ValueBaseHolder 的构造方法
构造一个新的 ValueBaseHolder 对象，将其 value 字段初始化为 0。
ValueBaseHolder(Serializable) - 类 org.omg.CORBA.ValueBaseHolder 的构造方法
构造一个新的 ValueBaseHolder 对象，并将其 value 字段初始化为给定的 java.io.Serializable。
valueBound(SSLSessionBindingEvent) - 接口 javax.net.ssl.SSLSessionBindingListener 中的方法
调用此方法通知侦听器要将其绑定到 SSLSession 中。
valueChanged(ListSelectionEvent) - 接口 javax.swing.event.ListSelectionListener 中的方法
每当选择值发生更改时调用。
valueChanged(TreeSelectionEvent) - 接口 javax.swing.event.TreeSelectionListener 中的方法
每当选择值发生更改时调用。
valueChanged(ListSelectionEvent) - 类 javax.swing.JList.AccessibleJList 中的方法
List Selection Listener 值更改方法。
valueChanged(ListSelectionEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表单元格选择的变更
valueChanged(ListSelectionEvent) - 类 javax.swing.JTable 中的方法
行选择更改时调用，重新绘制来显示新的选择。
valueChanged(TreeSelectionEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树选择侦听器值更改方法。
valueChanged(TreeSelectionEvent) - 类 javax.swing.JTree.TreeSelectionRedirector 中的方法
在选择更改时由 TreeSelectionModel 调用。
valueChanged(ListSelectionEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler 中的方法
valueChanged(ListSelectionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener 中的方法
valueChanged(ListSelectionEvent) - 类 javax.swing.plaf.basic.BasicListUI.ListSelectionHandler 中的方法
valueChanged(TreeSelectionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler 中的方法
当显示的树中发生选择更改时传递消息。
valueChanged(ListSelectionEvent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
valueChanged(ListSelectionEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
列选择更改时转发 ListSelectionEvents 的 ListSelectionListener。
valueChanged(TreeSelectionEvent) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
重置 lastPath。
ValueExp - javax.management 中的 接口
表示可以作为参数传递给关系表达式的值。
ValueFactory - org.omg.CORBA.portable 中的 接口
ValueFactory 接口是 IDL 类型 CORBA::ValueFactory 的本地映射。
valueForPathChanged(TreePath, Object) - 类 javax.swing.tree.DefaultTreeModel 中的方法
此方法设置由路径标识的 TreeNode 的用户对象，并发送更改的节点。
valueForPathChanged(TreePath, Object) - 接口 javax.swing.tree.TreeModel 中的方法
用户已将 path 标识的项的值更改为 newValue 时，进行通知。
valueForXPosition(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回给出 x 位置的值。
valueForYPosition(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回给出 y 位置的值。
ValueHandler - javax.rmi.CORBA 中的 接口
定义允许序列化 Java 对象到 GIOP 流或从其序列化 Java 对象的方法。
ValueHandlerMultiFormat - javax.rmi.CORBA 中的 接口
Java 到 IDL ptc 02-01-12 1.5.1.5。
ValueInputStream - org.omg.CORBA.portable 中的 接口
Java 到 IDL ptc 02-01-12 1.5.1.4 ValueInputStream 用来实现第 2 版的 RMI-IIOP 流格式。
valueIsAdjusting - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
从 Java 2 平台 v1.4 开始，不再使用这种以前没有记录的字段。
ValueMember - org.omg.CORBA 中的 类
接口存储库 (Interface Repository) 中关于 value 对象成员的描述。
ValueMember() - 类 org.omg.CORBA.ValueMember 的构造方法
构造一个默认 ValueMember 对象。
ValueMember(String, String, String, String, TypeCode, IDLType, short) - 类 org.omg.CORBA.ValueMember 的构造方法
构造一个 ValueMember 对象，使用给定值进行初始化。
ValueMemberHelper - org.omg.CORBA 中的 类
ValueMember 的 Helper。
ValueMemberHelper() - 类 org.omg.CORBA.ValueMemberHelper 的构造方法
valueOf(String) - 枚举 java.awt.Component.BaselineResizeBehavior 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.Desktop.Action 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.Dialog.ModalExclusionType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.Dialog.ModalityType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.MultipleGradientPaint.ColorSpaceType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.MultipleGradientPaint.CycleMethod 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.TrayIcon.MessageType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.lang.annotation.ElementType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.lang.annotation.RetentionPolicy 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(boolean) - 类 java.lang.Boolean 中的静态方法
返回一个表示指定 boolean 值的 Boolean 实例。
valueOf(String) - 类 java.lang.Boolean 中的静态方法
返回一个用指定的字符串表示值的 Boolean 值。
valueOf(byte) - 类 java.lang.Byte 中的静态方法
返回表示指定 byte 值的一个 Byte 实例。
valueOf(String, int) - 类 java.lang.Byte 中的静态方法
返回一个 Byte 对象，该对象保持从指定的 String 中提取的值，该值是在用第二个参数所给定的基数对指定字符串进行解析时提取的。
valueOf(String) - 类 java.lang.Byte 中的静态方法
返回一个保持指定 String 所给出的值的 Byte 对象。
valueOf(char) - 类 java.lang.Character 中的静态方法
返回一个表示指定 char 值的 Character 实例。
valueOf(String) - 类 java.lang.Double 中的静态方法
返回保存用参数字符串 s 表示的 double 值的 Double 对象。
valueOf(double) - 类 java.lang.Double 中的静态方法
返回表示指定的 double 值的 Double 实例。
valueOf(Class<T>, String) - 类 java.lang.Enum 中的静态方法
返回带指定名称的指定枚举类型的枚举常量。
valueOf(String) - 类 java.lang.Float 中的静态方法
返回保存用参数字符串 s 表示的 float 值的 Float 对象。
valueOf(float) - 类 java.lang.Float 中的静态方法
返回表示指定的 float 值的 Float 实例。
valueOf(String, int) - 类 java.lang.Integer 中的静态方法
返回一个 Integer 对象，该对象中保存了用第二个参数提供的基数进行解析时从指定的 String 中提取的值。
valueOf(String) - 类 java.lang.Integer 中的静态方法
返回保存指定的 String 的值的 Integer 对象。
valueOf(int) - 类 java.lang.Integer 中的静态方法
返回一个表示指定的 int 值的 Integer 实例。
valueOf(String, int) - 类 java.lang.Long 中的静态方法
当使用第二个参数给出的基数进行解析时，返回保持从指定 String 中提取的值的 Long 对象。
valueOf(String) - 类 java.lang.Long 中的静态方法
返回保持指定 String 的值的 Long 对象。
valueOf(long) - 类 java.lang.Long 中的静态方法
返回表示指定 long 值的 Long 实例。
valueOf(String) - 枚举 java.lang.management.MemoryType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String, int) - 类 java.lang.Short 中的静态方法
返回一个 Short 对象，该对象保持从指定的 String 中提取的值，该值是在使用第二个参数给出的基数对指定字符串进行解析时提取的。
valueOf(String) - 类 java.lang.Short 中的静态方法
返回一个保持指定 String 所给出的值的 Short 对象。
valueOf(short) - 类 java.lang.Short 中的静态方法
返回表示指定 short 值的 Short 实例。
valueOf(Object) - 类 java.lang.String 中的静态方法
返回 Object 参数的字符串表示形式。
valueOf(char[]) - 类 java.lang.String 中的静态方法
返回 char 数组参数的字符串表示形式。
valueOf(char[], int, int) - 类 java.lang.String 中的静态方法
返回 char 数组参数的特定子数组的字符串表示形式。
valueOf(boolean) - 类 java.lang.String 中的静态方法
返回 boolean 参数的字符串表示形式。
valueOf(char) - 类 java.lang.String 中的静态方法
返回 char 参数的字符串表示形式。
valueOf(int) - 类 java.lang.String 中的静态方法
返回 int 参数的字符串表示形式。
valueOf(long) - 类 java.lang.String 中的静态方法
返回 long 参数的字符串表示形式。
valueOf(float) - 类 java.lang.String 中的静态方法
返回 float 参数的字符串表示形式。
valueOf(double) - 类 java.lang.String 中的静态方法
返回 double 参数的字符串表示形式。
valueOf(String) - 枚举 java.lang.Thread.State 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(long, int) - 类 java.math.BigDecimal 中的静态方法
将 long 非标度值和 int 标度转换为 BigDecimal。
valueOf(long) - 类 java.math.BigDecimal 中的静态方法
将 long 值转换为具有零标度的 BigDecimal。
valueOf(double) - 类 java.math.BigDecimal 中的静态方法
使用 Double.toString(double) 方法提供的 double 规范的字符串表示形式将 double 转换为 BigDecimal。
valueOf(long) - 类 java.math.BigInteger 中的静态方法
返回其值等于指定 long 的值的 BigInteger。
valueOf(String) - 枚举 java.math.RoundingMode 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(int) - 枚举 java.math.RoundingMode 中的静态方法
返回与 BigDecimal 中遗留整数舍入模式常量对应的 RoundingMode 对象。
valueOf(String) - 枚举 java.net.Authenticator.RequestorType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.net.Proxy.Type 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.security.KeyRep.Type 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.sql.ClientInfoStatus 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 类 java.sql.Date 中的静态方法
将 JDBC 日期转义形式的字符串转换成 Date 值。
valueOf(String) - 枚举 java.sql.RowIdLifetime 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 类 java.sql.Time 中的静态方法
将使用 JDBC 时间转义格式的字符串转换为 Time 值。
valueOf(String) - 类 java.sql.Timestamp 中的静态方法
将使用 JDBC 时间戳转义格式的 String 对象转换为 Timestamp 值。
valueOf(String) - 枚举 java.text.Normalizer.Form 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.util.concurrent.TimeUnit 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.util.Formatter.BigDecimalLayoutForm 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.annotation.Resource.AuthenticationType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.jws.soap.SOAPBinding.ParameterStyle 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.jws.soap.SOAPBinding.Style 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.jws.soap.SOAPBinding.Use 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.jws.WebParam.Mode 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.lang.model.element.ElementKind 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.lang.model.element.Modifier 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.lang.model.element.NestingKind 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.lang.model.type.TypeKind 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.net.ssl.SSLEngineResult.HandshakeStatus 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.net.ssl.SSLEngineResult.Status 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.DropMode 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.event.RowSorterEvent.Type 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.GroupLayout.Alignment 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.JTable.PrintMode 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.LayoutStyle.ComponentPlacement 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.RowFilter.ComparisonType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.SortOrder 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.SwingWorker.StateValue 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.text.html.FormSubmitEvent.MethodType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.tools.Diagnostic.Kind 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.tools.JavaFileObject.Kind 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.tools.StandardLocation 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.xml.bind.annotation.XmlAccessOrder 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.xml.bind.annotation.XmlAccessType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.xml.bind.annotation.XmlNsForm 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 类 javax.xml.namespace.QName 中的静态方法
从解析格式化 String 中派生的 QName。
valueOf(String) - 枚举 javax.xml.ws.handler.MessageContext.Scope 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.xml.ws.Service.Mode 中的静态方法
返回带有指定名称的该类型的枚举常量。
ValueOutputStream - org.omg.CORBA.portable 中的 接口
Java 到 IDL ptc 02-01-12 1.5.1.3 ValueOutputStream 用来实现第 2 版的 RMI-IIOP 流格式。
values() - 枚举 java.awt.Component.BaselineResizeBehavior 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.awt.Desktop.Action 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.awt.Dialog.ModalExclusionType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.awt.Dialog.ModalityType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.awt.MultipleGradientPaint.ColorSpaceType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.awt.MultipleGradientPaint.CycleMethod 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 java.awt.RenderingHints 中的方法
返回此 RenderinHints 中所包含键的 Collection 视图。
values() - 枚举 java.awt.TrayIcon.MessageType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.lang.annotation.ElementType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.lang.annotation.RetentionPolicy 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.lang.management.MemoryType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.lang.Thread.State 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.math.RoundingMode 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.net.Authenticator.RequestorType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.net.Proxy.Type 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.security.KeyRep.Type 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 java.security.Provider 中的方法
返回此 provider 中所包含的属性值的一个不可修改的 Collection 视图。
values() - 枚举 java.sql.ClientInfoStatus 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.sql.RowIdLifetime 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.text.Normalizer.Form 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 java.util.AbstractMap 中的方法
返回此映射中包含的值的 Collection 视图。
values() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此映射中包含的值的 Collection 视图。
values() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回此映射中所包含值的 Collection 视图。
values() - 枚举 java.util.concurrent.TimeUnit 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 java.util.EnumMap 中的方法
返回此映射中所包含值的 Collection 视图。
values() - 枚举 java.util.Formatter.BigDecimalLayoutForm 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 java.util.HashMap 中的方法
返回此映射所包含的值的 Collection 视图。
values() - 类 java.util.Hashtable 中的方法
返回此映射中包含的键的 Collection 视图。
values() - 类 java.util.IdentityHashMap 中的方法
返回映射所包含值的 Collection 视图。
values() - 类 java.util.jar.Attributes 中的方法
返回此 Map 所包含的属性值的 Collection 视图。
values() - 接口 java.util.Map 中的方法
返回此映射中包含的值的 Collection 视图。
values() - 接口 java.util.SortedMap 中的方法
返回在此映射中所包含值的 Collection 视图。
values() - 类 java.util.TreeMap 中的方法
返回此映射包含的值的 Collection 视图。
values() - 类 java.util.WeakHashMap 中的方法
返回此映射所包含的值的 Collection 视图。
values() - 枚举 javax.annotation.Resource.AuthenticationType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.jws.soap.SOAPBinding.ParameterStyle 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.jws.soap.SOAPBinding.Style 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.jws.soap.SOAPBinding.Use 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.jws.WebParam.Mode 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.lang.model.element.ElementKind 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.lang.model.element.Modifier 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.lang.model.element.NestingKind 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.lang.model.SourceVersion 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.lang.model.type.TypeKind 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 接口 javax.management.openmbean.CompositeData 中的方法
返回此 CompositeData 实例中所包含项值的不可修改的 Collection 视图。
values() - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回此 CompositeData 实例中包含的项值的不可修改的 Collection 视图。
values() - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例中包含的 CompositeData 值（即各行）的 collection 视图。
values() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回包含在此 TabularDataSupport 实例中的行的 collection 视图。
values - 类 javax.naming.directory.BasicAttribute 中的变量
保存属性的值。
values() - 枚举 javax.net.ssl.SSLEngineResult.HandshakeStatus 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.net.ssl.SSLEngineResult.Status 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 javax.script.SimpleBindings 中的方法
返回此映射中包含的值的 Collection 视图。
values() - 枚举 javax.swing.DropMode 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.event.RowSorterEvent.Type 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.GroupLayout.Alignment 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.JTable.PrintMode 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.LayoutStyle.ComponentPlacement 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.RowFilter.ComparisonType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.SortOrder 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.SwingWorker.StateValue 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.text.html.FormSubmitEvent.MethodType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values - 类 javax.swing.text.html.parser.AttributeList 中的变量
values() - 枚举 javax.tools.Diagnostic.Kind 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.tools.JavaFileObject.Kind 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.tools.StandardLocation 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.xml.bind.annotation.XmlAccessOrder 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.xml.bind.annotation.XmlAccessType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.xml.bind.annotation.XmlNsForm 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.xml.ws.handler.MessageContext.Scope 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.xml.ws.Service.Mode 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
valueToString(Object) - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
返回为 value 显示的 string 值。
valueToString(Object) - 类 javax.swing.text.DefaultFormatter 中的方法
使用 toString 方法将传入的 Object 转换为 String。
valueToString(Object) - 类 javax.swing.text.InternationalFormatter 中的方法
返回 Object value 的 String 表示形式。
valueToString(Object) - 类 javax.swing.text.MaskFormatter 中的方法
返回基于掩码的 Object value 的 String 表示形式。
VALUETYPE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
valueUnbound(SSLSessionBindingEvent) - 接口 javax.net.ssl.SSLSessionBindingListener 中的方法
调用此方法通知侦听器要从 SSLSession 中解除其绑定。
VAR - 类 javax.swing.text.html.HTML.Tag 中的静态变量
VARBINARY - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 VARBINARY 的 Java 编程语言中的常量（有时称为类型代码）。
VARCHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 VARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
VariableElement - javax.lang.model.element 中的 接口
表示一个字段、enum 常量、方法或构造方法参数、局部变量或异常参数。
VariableHeightLayoutCache - javax.swing.tree 中的 类
注：在以后的版本中，此类将变得更加开放。
VariableHeightLayoutCache() - 类 javax.swing.tree.VariableHeightLayoutCache 的构造方法
variant() - 类 java.util.UUID 中的方法
与此 UUID 相关联的变体号。
VARIATION_SELECTORS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Variation Selectors”Unicode 字符块的常量。
VARIATION_SELECTORS_SUPPLEMENT - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Variation Selectors Supplement”Unicode 字符块的常量。
vcSupport - 类 java.beans.beancontext.BeanContextChildSupport 中的变量
与此 BeanContextChildSupport 相关联的 VetoableChangeSupport。
Vector<E> - java.util 中的 类
Vector 类可以实现可增长的对象数组。
Vector(int, int) - 类 java.util.Vector 的构造方法
使用指定的初始容量和容量增量构造一个空的向量。
Vector(int) - 类 java.util.Vector 的构造方法
使用指定的初始容量和等于零的容量增量构造一个空向量。
Vector() - 类 java.util.Vector 的构造方法
构造一个空向量，使其内部数据数组的大小为 10，其标准容量增量为零。
Vector(Collection<? extends E>) - 类 java.util.Vector 的构造方法
构造一个包含指定 collection 中的元素的向量，这些元素按其 collection 的迭代器返回元素的顺序排列。
vendorName - 类 javax.imageio.spi.IIOServiceProvider 中的变量
将从 getVendorName 返回的一个 String，初始值为 null。
VERBOSE - 类 java.rmi.server.LogStream 中的静态变量
已过时。 日志级别常量（详细日志记录）。
verify(PublicKey) - 类 java.security.cert.Certificate 中的方法
验证是否已使用与指定公钥相应的私钥签署了此证书。
verify(PublicKey, String) - 类 java.security.cert.Certificate 中的方法
验证是否已使用与指定公钥相应的私钥签署了此证书。
verify(PublicKey) - 类 java.security.cert.X509CRL 中的方法
验证是否已使用与给定公钥相应的私钥签署了此 CRL。
verify(PublicKey, String) - 类 java.security.cert.X509CRL 中的方法
验证是否已使用与给定公钥相应的私钥签署了此 CRL。
VERIFY - 类 java.security.Signature 中的静态变量
可能的 Signature.state 值，表示此签名对象已经初始化验证。
verify(byte[]) - 类 java.security.Signature 中的方法
验证传入的签名。
verify(byte[], int, int) - 类 java.security.Signature 中的方法
从指定的偏移量开始，验证指定的 byte 数组中传入的签名。
verify(PublicKey, Signature) - 类 java.security.SignedObject 中的方法
使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。
verify(String, SSLSession) - 接口 javax.net.ssl.HostnameVerifier 中的方法
验证主机名和服务器验证方案的匹配是可接受的。
verify(PublicKey) - 类 javax.security.cert.Certificate 中的方法
验证是否已使用与指定公钥相对应的私钥签署了此证书。
verify(PublicKey, String) - 类 javax.security.cert.Certificate 中的方法
验证是否已使用与指定公钥相对应的私钥签署了此证书。
verify(JComponent) - 类 javax.swing.InputVerifier 中的方法
检查 JComponent 的输入是否有效。
VERIFY - 类 javax.xml.crypto.KeySelector.Purpose 中的静态变量
用于验证的密钥。
verifyAttributeCategory(Object, Class<?>) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
验证给定的对象是否为实现给定接口（假定为接口 Attribute 或其子接口）的 Class。
verifyAttributeValue(Object, Class<?>) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
验证给定的对象是否为给定接口（假定为接口 Attribute 或其子接口）的一个实例。
verifyCategoryForValue(Class<?>, Attribute) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
验证给定的属性类别对象是否等于给定属性值对象的类别。
VerifyError - java.lang 中的 错误
当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。
VerifyError() - 错误 java.lang.VerifyError 的构造方法
构造不带详细消息的 VerifyError。
VerifyError(String) - 错误 java.lang.VerifyError 的构造方法
构造带指定详细消息的 VerifyError。
verifyMIC(byte[], int, int, byte[], int, int, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
通过提供的消息，检查包含在标记参数中的加密的 MIC。
verifyMIC(InputStream, InputStream, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
通过提供的消息，使用流来验证包含在标记参数中的加密的 MIC。
version() - 类 java.util.UUID 中的方法
与此 UUID 相关联的版本号。
version - 类 javax.imageio.spi.IIOServiceProvider 中的变量
将从 getVersion 返回的一个 String，初始值为 null。
VERSION - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
VERSION - 类 javax.xml.transform.OutputKeys 中的静态变量
version = nmtoken. version 指定了输出方法的版本。
version - 类 org.omg.CORBA.ValueMember 中的变量
用来定义此成员的 value 的版本。
versionColumnNotPseudo - 接口 java.sql.DatabaseMetaData 中的静态变量
指示这种版本的列“不”是伪列。
versionColumnPseudo - 接口 java.sql.DatabaseMetaData 中的静态变量
指示这种版本的列是伪列。
versionColumnUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示这种版本的列可能是伪列，也可能不是。
VersionSpecHelper - org.omg.CORBA 中的 类
VersionSpec 的 Helper。
VersionSpecHelper() - 类 org.omg.CORBA.VersionSpecHelper 的构造方法
VERTICAL - 接口 java.awt.Adjustable 中的静态变量
指示 Adjustable 具有垂直方向。
VERTICAL - 类 java.awt.GridBagConstraints 中的静态变量
在垂直方向而不是水平方向上调整组件大小。
VERTICAL - 类 java.awt.Scrollbar 中的静态变量
指示一个垂直滚动条的常量。
VERTICAL - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象的方向为垂直方向。
VERTICAL - 类 javax.swing.JList 中的静态变量
指示单个列中单元的垂直布局；默认布局。
VERTICAL - 接口 javax.swing.SwingConstants 中的静态变量
垂直方向。
VERTICAL_ALIGN - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
VERTICAL_ALIGNMENT_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的垂直对齐方式的更改。
VERTICAL_CENTER - 类 javax.swing.SpringLayout 中的静态变量
指定组件的边界矩形的垂直中央位置。
VERTICAL_SCROLLBAR - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识垂直滚动条。
VERTICAL_SCROLLBAR_ALWAYS - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置垂直滚动条策略以使垂直滚动条一直显示。
VERTICAL_SCROLLBAR_AS_NEEDED - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置垂直滚动条策略以使垂直滚动条只在需要时显示。
VERTICAL_SCROLLBAR_NEVER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置垂直滚动条策略以使垂直滚动条从不显示。
VERTICAL_SCROLLBAR_POLICY - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识垂直滚动条策略属性。
VERTICAL_SPLIT - 类 javax.swing.JSplitPane 中的静态变量
垂直分割表示 Component 沿 y 轴分割。
VERTICAL_TEXT_POSITION_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的垂直文本位置的更改。
VERTICAL_WRAP - 类 javax.swing.JList 中的静态变量
指示“报纸样式”布局，单元按先垂直后水平排列。
verticalScrollBar - 类 javax.swing.JScrollPane 中的变量
滚动窗格的垂直滚动条子级。
verticalScrollBarPolicy - 类 javax.swing.JScrollPane 中的变量
用于垂直滚动条的显示策略。
vertThumbIcon - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
默认垂直 thumb Icon。
vetoableChange(PropertyChangeEvent) - 类 java.beans.beancontext.BeanContextSupport 中的方法
子类可以封装此方法来监视子类属性的更改。
vetoableChange(PropertyChangeEvent) - 接口 java.beans.VetoableChangeListener 中的方法
在约束属性发生更改时调用此方法。
vetoableChange(PropertyChangeEvent) - 类 java.beans.VetoableChangeListenerProxy 中的方法
将属性更改事件转发给侦听器代理。
VetoableChangeListener - java.beans 中的 接口
只要 bean 更改 "constrained" 属性，都将会激发一个 VetoableChange 事件。
VetoableChangeListenerProxy - java.beans 中的 类
扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。
VetoableChangeListenerProxy(String, VetoableChangeListener) - 类 java.beans.VetoableChangeListenerProxy 的构造方法
VetoableChangeSupport - java.beans 中的 类
这是一个实用工具类，支持约束 (constrained) 属性的 bean 可以使用此类。
VetoableChangeSupport(Object) - 类 java.beans.VetoableChangeSupport 的构造方法
构造一个 VetoableChangeSupport 对象。
View - javax.swing.text 中的 类
View 类是 text 包极为重要的一部分。
View(Element) - 类 javax.swing.text.View 的构造方法
创建一个新的 View 对象。
ViewFactory - javax.swing.text 中的 接口
创建文档专题某些部分的视图的工厂。
VIEWPORT - 类 javax.accessibility.AccessibleRole 中的静态变量
通常在滚动窗格中使用的对象。
viewPort - 类 javax.swing.JScrollPane.AccessibleJScrollPane 中的变量
viewport - 类 javax.swing.JScrollPane 中的变量
滚动窗格的视口子级。
VIEWPORT - 类 javax.swing.plaf.synth.Region 中的静态变量
Viewport 的 region。
VIEWPORT - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识一个“视口”或显示区域，在这个范围内能看到滚动的内容。
viewport - 类 javax.swing.ScrollPaneLayout 中的变量
滚动窗格的子级视口。
viewportChangeListener - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的变量
ViewportLayout - javax.swing 中的 类
JViewport 的默认布局管理器。
ViewportLayout() - 类 javax.swing.ViewportLayout 的构造方法
ViewportUI - javax.swing.plaf 中的 类
JViewport 的可插入外观界面。
ViewportUI() - 类 javax.swing.plaf.ViewportUI 的构造方法
viewToModel(JTextComponent, Point) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
viewToModel(JTextComponent, Point, Position.Bias[]) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
viewToModel(JTextComponent, Point) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 viewToModel 方法。
viewToModel(JTextComponent, Point, Position.Bias[]) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 viewToModel 方法。
viewToModel(JTextComponent, Point) - 类 javax.swing.plaf.TextUI 中的方法
将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
viewToModel(JTextComponent, Point, Position.Bias[]) - 类 javax.swing.plaf.TextUI 中的方法
提供从视图坐标空间到模型的逻辑坐标空间的映射关系。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.AsyncBoxView 中的方法
提供从视图坐标空间到模型逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.BoxView 中的方法
提供从视图坐标空间到模型逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.ComponentView 中的方法
提供从视图坐标空间到模型逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.CompositeView 中的方法
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.FieldView 中的方法
提供从视图坐标空间到该模型的逻辑坐标空间的映射。
viewToModel(GlyphView, float, float, Shape, Position.Bias[]) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
提供从视图坐标空间到模型逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.GlyphView 中的方法
提供从视图坐标空间到模型逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.html.ImageView 中的方法
提供从视图坐标空间到该模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.IconView 中的方法
提供从视图坐标空间到该模型的逻辑坐标空间的映射。
viewToModel(Point) - 类 javax.swing.text.JTextComponent 中的方法
将视图坐标系统中的给定位置转换为模型中最具代表性的位置。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.PasswordView 中的方法
提供从视图坐标空间到该模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.PlainView 中的方法
提供从视图坐标空间到该模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.View 中的方法
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape) - 类 javax.swing.text.View 中的方法
已过时。
VirtualMachineError - java.lang 中的 错误
当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。
VirtualMachineError() - 错误 java.lang.VirtualMachineError 的构造方法
构造不带详细消息的 VirtualMachineError。
VirtualMachineError(String) - 错误 java.lang.VirtualMachineError 的构造方法
构造带指定详细消息的 VirtualMachineError。
Visibility - java.beans 中的 接口
在某些情况下，bean 可能运行在 GUI 不可用的服务器上。
VisibilityHelper - org.omg.CORBA 中的 类
Visibility 的 Helper。
VisibilityHelper() - 类 org.omg.CORBA.VisibilityHelper 的构造方法
VISIBLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是可见的。
VISIBLE_ROW_COUNT_PROPERTY - 类 javax.swing.JTree 中的静态变量
visibleRowCount 的绑定属性名称。
visibleRowCount - 类 javax.swing.JTree 中的变量
一次可见的行数。
visit(AnnotationValue, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释值。
visit(AnnotationValue) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
等效于 v.visit(av, null) 的便捷方法。
visit(Element, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问一个元素。
visit(Element) - 接口 javax.lang.model.element.ElementVisitor 中的方法
等效于 v.visit(e, null) 的便捷方法。
visit(TypeMirror, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问一个类型。
visit(TypeMirror) - 接口 javax.lang.model.type.TypeVisitor 中的方法
等效于 v.visit(t, null) 的便捷方法。
visit(AnnotationValue, P) - 类 javax.lang.model.util.AbstractAnnotationValueVisitor6 中的方法
访问注释值，这与将自身传递给该值的 accept 方法一样。
visit(AnnotationValue) - 类 javax.lang.model.util.AbstractAnnotationValueVisitor6 中的方法
访问注释值，这与将自身传递给该值的 accept 方法，并为附加参数传递 null 一样。
visit(Element, P) - 类 javax.lang.model.util.AbstractElementVisitor6 中的方法
访问任何程序元素，这与将自身传递给该元素的 accept 方法一样。
visit(Element) - 类 javax.lang.model.util.AbstractElementVisitor6 中的方法
访问任何程序元素，这与将自身传递给该元素的 accept 方法，并为附加参数传递 null 一样。
visit(TypeMirror, P) - 类 javax.lang.model.util.AbstractTypeVisitor6 中的方法
访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法一样。
visit(TypeMirror) - 类 javax.lang.model.util.AbstractTypeVisitor6 中的方法
访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法，并为附加参数传递 null 一样。
visitAnnotation(AnnotationMirror, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 annotation 值。
visitAnnotation(AnnotationMirror, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 annotation 值。
visitArray(List<? extends AnnotationValue>, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 array 值。
visitArray(ArrayType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问数组类型。
visitArray(List<? extends AnnotationValue>, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 array 值。
visitArray(ArrayType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问数组类型。
visitBoolean(boolean, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 boolean 值。
visitBoolean(boolean, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 boolean 值。
visitByte(byte, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 byte 值。
visitByte(byte, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 byte 值。
visitChar(char, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 char 值。
visitChar(char, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 char 值。
visitDeclared(DeclaredType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问已声明的类型。
visitDeclared(DeclaredType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问已声明的类型。
visitDouble(double, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 double 值。
visitDouble(double, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 double 值。
visitEnumConstant(VariableElement, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 enum 值。
visitEnumConstant(VariableElement, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 enum 值。
visitError(ErrorType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问错误类型。
visitError(ErrorType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问错误类型。
visitExecutable(ExecutableElement, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问 executable 元素。
visitExecutable(ExecutableType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问 executable 类型。
visitExecutable(ExecutableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
访问 executable 元素，指派给用于特定的 executable 种类 CONSTRUCTOR、INSTANCE_INIT、METHOD 或 STATIC_INIT 的 visit 方法。
visitExecutable(ExecutableElement, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
访问 executable 元素。
visitExecutable(ExecutableElement, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
访问 executable 元素。
visitExecutable(ExecutableType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问 executable 类型。
visitExecutableAsConstructor(ExecutableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 CONSTRUCTOR executable 元素。
visitExecutableAsInstanceInit(ExecutableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 INSTANCE_INIT executable 元素。
visitExecutableAsMethod(ExecutableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 METHOD executable 元素。
visitExecutableAsStaticInit(ExecutableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 STATIC_INIT executable 元素。
visitFloat(float, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 float 值。
visitFloat(float, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 float 值。
visitInt(int, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 int 值。
visitInt(int, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 int 值。
visitLong(long, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 long 值。
visitLong(long, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 long 值。
visitNoType(NoType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问 NoType 实例。
visitNoType(NoType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问 NoType 实例。
visitNoType(NoType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
访问 NoType 实例，指派给用于以下特定的伪类型种类的 visit 方法：VOID、PACKAGE 或 NONE。
visitNoTypeAsNone(NoType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 NONE 伪类型。
visitNoTypeAsPackage(NoType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 PACKAGE 伪类型。
visitNoTypeAsVoid(NoType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 VOID 伪类型。
visitNull(NullType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问 null 类型。
visitNull(NullType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问 null 类型。
visitPackage(PackageElement, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问包元素。
visitPackage(PackageElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
访问包元素。
visitPackage(PackageElement, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
访问包元素。
visitPackage(PackageElement, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
访问包元素。
visitPrimitive(PrimitiveType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问基本类型。
visitPrimitive(PrimitiveType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问基本类型。
visitPrimitive(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
访问基本类型，指派给用于以下特定的基本类型种类的 visit 方法：BOOLEAN、BYTE 等。
visitPrimitiveAsBoolean(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 BOOLEAN 基本类型。
visitPrimitiveAsByte(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 BYTE 基本类型。
visitPrimitiveAsChar(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 CHAR 基本类型。
visitPrimitiveAsDouble(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 DOUBLE 基本类型。
visitPrimitiveAsFloat(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 FLOAT 基本类型。
visitPrimitiveAsInt(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 INT 基本类型。
visitPrimitiveAsLong(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 LONG 基本类型。
visitPrimitiveAsShort(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 SHORT 基本类型。
visitShort(short, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 short 值。
visitShort(short, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 short 值。
visitString(String, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 string 值。
visitString(String, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 string 值。
visitType(TypeMirror, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 type 值。
visitType(TypeElement, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问类型元素。
visitType(TypeElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
访问类型元素，指派给用于特定的类型种类 ANNOTATION_TYPE、CLASS、ENUM 或 INTERFACE 的 visit 方法。
visitType(TypeElement, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
访问类型元素。
visitType(TypeMirror, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 type 值。
visitType(TypeElement, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
访问类型元素。
visitTypeAsAnnotationType(TypeElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 ANNOTATION_TYPE 类型元素。
visitTypeAsClass(TypeElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 CLASS 类型元素。
visitTypeAsEnum(TypeElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 ENUM 类型元素。
visitTypeAsInterface(TypeElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 INTERFACE 类型元素。
visitTypeParameter(TypeParameterElement, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问类型参数元素。
visitTypeParameter(TypeParameterElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
访问类型参数元素。
visitTypeParameter(TypeParameterElement, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
访问类型参数元素。
visitTypeParameter(TypeParameterElement, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
访问类型参数元素。
visitTypeVariable(TypeVariable, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问类型变量。
visitTypeVariable(TypeVariable, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问类型变量。
visitUnknown(AnnotationValue, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问未知种类的注释值。
visitUnknown(Element, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问未知种类的元素。
visitUnknown(TypeMirror, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问未知种类的类型。
visitUnknown(AnnotationValue, P) - 类 javax.lang.model.util.AbstractAnnotationValueVisitor6 中的方法
访问未知种类的注释值。
visitUnknown(Element, P) - 类 javax.lang.model.util.AbstractElementVisitor6 中的方法
访问未知种类的元素。
visitUnknown(TypeMirror, P) - 类 javax.lang.model.util.AbstractTypeVisitor6 中的方法
访问未知种类的类型。
visitVariable(VariableElement, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问变量元素。
visitVariable(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
访问变量元素，指派给用于特定的变量种类 ENUM_CONSTANT、EXCEPTION_PARAMETER、FIELD、LOCAL_VARIABLE 或 PARAMETER 的 visit 方法。
visitVariable(VariableElement, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
访问变量元素。
visitVariable(VariableElement, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
访问变量元素。
visitVariableAsEnumConstant(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 ENUM_CONSTANT 变量元素。
visitVariableAsExceptionParameter(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 EXCEPTION_PARAMETER 变量元素。
visitVariableAsField(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 FIELD 变量元素。
visitVariableAsLocalVariable(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 LOCAL_VARIABLE 变量元素。
visitVariableAsParameter(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 PARAMETER 变量元素。
visitWildcard(WildcardType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问通配符类型。
visitWildcard(WildcardType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问通配符类型。
VK_0 - 类 java.awt.event.KeyEvent 中的静态变量
VK_0 到 VK_9 与 ASCII 的‘0’到‘9’(0x30 - 0x39) 相同
VK_1 - 类 java.awt.event.KeyEvent 中的静态变量
VK_2 - 类 java.awt.event.KeyEvent 中的静态变量
VK_3 - 类 java.awt.event.KeyEvent 中的静态变量
VK_4 - 类 java.awt.event.KeyEvent 中的静态变量
VK_5 - 类 java.awt.event.KeyEvent 中的静态变量
VK_6 - 类 java.awt.event.KeyEvent 中的静态变量
VK_7 - 类 java.awt.event.KeyEvent 中的静态变量
VK_8 - 类 java.awt.event.KeyEvent 中的静态变量
VK_9 - 类 java.awt.event.KeyEvent 中的静态变量
VK_A - 类 java.awt.event.KeyEvent 中的静态变量
VK_A 到 VK_Z 与 ASCII 的‘A’到‘Z’(0x41 - 0x5A) 相同
VK_ACCEPT - 类 java.awt.event.KeyEvent 中的静态变量
用于 Accept 或 Commit 功能键的常量。
VK_ADD - 类 java.awt.event.KeyEvent 中的静态变量
VK_AGAIN - 类 java.awt.event.KeyEvent 中的静态变量
VK_ALL_CANDIDATES - 类 java.awt.event.KeyEvent 中的静态变量
用于 All Candidates 功能键的常量。
VK_ALPHANUMERIC - 类 java.awt.event.KeyEvent 中的静态变量
用于 Alphanumeric 功能键的常量。
VK_ALT - 类 java.awt.event.KeyEvent 中的静态变量
VK_ALT_GRAPH - 类 java.awt.event.KeyEvent 中的静态变量
用于 AltGraph 功能键的常量。
VK_AMPERSAND - 类 java.awt.event.KeyEvent 中的静态变量
VK_ASTERISK - 类 java.awt.event.KeyEvent 中的静态变量
VK_AT - 类 java.awt.event.KeyEvent 中的静态变量
用于 "@" 键的常量。
VK_B - 类 java.awt.event.KeyEvent 中的静态变量
VK_BACK_QUOTE - 类 java.awt.event.KeyEvent 中的静态变量
VK_BACK_SLASH - 类 java.awt.event.KeyEvent 中的静态变量
用于反斜杠键 "\" 的常量。
VK_BACK_SPACE - 类 java.awt.event.KeyEvent 中的静态变量
VK_BEGIN - 类 java.awt.event.KeyEvent 中的静态变量
用于 Begin 键的常量。
VK_BRACELEFT - 类 java.awt.event.KeyEvent 中的静态变量
VK_BRACERIGHT - 类 java.awt.event.KeyEvent 中的静态变量
VK_C - 类 java.awt.event.KeyEvent 中的静态变量
VK_CANCEL - 类 java.awt.event.KeyEvent 中的静态变量
VK_CAPS_LOCK - 类 java.awt.event.KeyEvent 中的静态变量
VK_CIRCUMFLEX - 类 java.awt.event.KeyEvent 中的静态变量
用于 "^" 键的常量。
VK_CLEAR - 类 java.awt.event.KeyEvent 中的静态变量
VK_CLOSE_BRACKET - 类 java.awt.event.KeyEvent 中的静态变量
用于右方括号键 "]" 的常量。
VK_CODE_INPUT - 类 java.awt.event.KeyEvent 中的静态变量
用于 Code Input 功能键的常量。
VK_COLON - 类 java.awt.event.KeyEvent 中的静态变量
用于 ":" 键的常量。
VK_COMMA - 类 java.awt.event.KeyEvent 中的静态变量
用于逗号键 "," 的常量。
VK_COMPOSE - 类 java.awt.event.KeyEvent 中的静态变量
用于 Compose 功能键的常量。
VK_CONTEXT_MENU - 类 java.awt.event.KeyEvent 中的静态变量
用于 Microsoft Windows 上下文菜单键的常量。
VK_CONTROL - 类 java.awt.event.KeyEvent 中的静态变量
VK_CONVERT - 类 java.awt.event.KeyEvent 中的静态变量
用于 Convert 功能键的常量。
VK_COPY - 类 java.awt.event.KeyEvent 中的静态变量
VK_CUT - 类 java.awt.event.KeyEvent 中的静态变量
VK_D - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_ABOVEDOT - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_ABOVERING - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_ACUTE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_BREVE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_CARON - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_CEDILLA - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_CIRCUMFLEX - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_DIAERESIS - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_DOUBLEACUTE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_GRAVE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_IOTA - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_MACRON - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_OGONEK - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_SEMIVOICED_SOUND - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_TILDE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_VOICED_SOUND - 类 java.awt.event.KeyEvent 中的静态变量
VK_DECIMAL - 类 java.awt.event.KeyEvent 中的静态变量
VK_DELETE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DIVIDE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DOLLAR - 类 java.awt.event.KeyEvent 中的静态变量
用于 "$" 键的常量。
VK_DOWN - 类 java.awt.event.KeyEvent 中的静态变量
用于非数字键盘向下方向键的常量。
VK_E - 类 java.awt.event.KeyEvent 中的静态变量
VK_END - 类 java.awt.event.KeyEvent 中的静态变量
VK_ENTER - 类 java.awt.event.KeyEvent 中的静态变量
VK_EQUALS - 类 java.awt.event.KeyEvent 中的静态变量
用于等号键 "=" 的常量。
VK_ESCAPE - 类 java.awt.event.KeyEvent 中的静态变量
VK_EURO_SIGN - 类 java.awt.event.KeyEvent 中的静态变量
用于欧洲货币符号键的常量。
VK_EXCLAMATION_MARK - 类 java.awt.event.KeyEvent 中的静态变量
用于 "!" 键的常量。
VK_F - 类 java.awt.event.KeyEvent 中的静态变量
VK_F1 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F1 功能键的常量。
VK_F10 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F10 功能键的常量。
VK_F11 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F11 功能键的常量。
VK_F12 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F12 功能键的常量。
VK_F13 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F13 功能键的常量。
VK_F14 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F14 功能键的常量。
VK_F15 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F15 功能键的常量。
VK_F16 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F16 功能键的常量。
VK_F17 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F17 功能键的常量。
VK_F18 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F18 功能键的常量。
VK_F19 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F19 功能键的常量。
VK_F2 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F2 功能键的常量。
VK_F20 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F20 功能键的常量。
VK_F21 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F21 功能键的常量。
VK_F22 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F22 功能键的常量。
VK_F23 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F23 功能键的常量。
VK_F24 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F24 功能键的常量。
VK_F3 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F3 功能键的常量。
VK_F4 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F4 功能键的常量。
VK_F5 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F5 功能键的常量。
VK_F6 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F6 功能键的常量。
VK_F7 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F7 功能键的常量。
VK_F8 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F8 功能键的常量。
VK_F9 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F9 功能键的常量。
VK_FINAL - 类 java.awt.event.KeyEvent 中的静态变量
VK_FIND - 类 java.awt.event.KeyEvent 中的静态变量
VK_FULL_WIDTH - 类 java.awt.event.KeyEvent 中的静态变量
用于 Full-Width Characters 功能键的常量。
VK_G - 类 java.awt.event.KeyEvent 中的静态变量
VK_GREATER - 类 java.awt.event.KeyEvent 中的静态变量
VK_H - 类 java.awt.event.KeyEvent 中的静态变量
VK_HALF_WIDTH - 类 java.awt.event.KeyEvent 中的静态变量
用于 Half-Width Characters 功能键的常量。
VK_HELP - 类 java.awt.event.KeyEvent 中的静态变量
VK_HIRAGANA - 类 java.awt.event.KeyEvent 中的静态变量
用于 Hiragana 功能键的常量。
VK_HOME - 类 java.awt.event.KeyEvent 中的静态变量
VK_I - 类 java.awt.event.KeyEvent 中的静态变量
VK_INPUT_METHOD_ON_OFF - 类 java.awt.event.KeyEvent 中的静态变量
用于输入法开/关键的常量。
VK_INSERT - 类 java.awt.event.KeyEvent 中的静态变量
VK_INVERTED_EXCLAMATION_MARK - 类 java.awt.event.KeyEvent 中的静态变量
用于反向感叹号键的常量。
VK_J - 类 java.awt.event.KeyEvent 中的静态变量
VK_JAPANESE_HIRAGANA - 类 java.awt.event.KeyEvent 中的静态变量
用于 Japanese-Hiragana 功能键的常量。
VK_JAPANESE_KATAKANA - 类 java.awt.event.KeyEvent 中的静态变量
用于 Japanese-Katakana 功能键的常量。
VK_JAPANESE_ROMAN - 类 java.awt.event.KeyEvent 中的静态变量
用于 Japanese-Roman 功能键的常量。
VK_K - 类 java.awt.event.KeyEvent 中的静态变量
VK_KANA - 类 java.awt.event.KeyEvent 中的静态变量
VK_KANA_LOCK - 类 java.awt.event.KeyEvent 中的静态变量
用于锁定 Kana 功能键的常量。
VK_KANJI - 类 java.awt.event.KeyEvent 中的静态变量
VK_KATAKANA - 类 java.awt.event.KeyEvent 中的静态变量
用于 Katakana 功能键的常量。
VK_KP_DOWN - 类 java.awt.event.KeyEvent 中的静态变量
用于数字键盘向下方向键的常量。
VK_KP_LEFT - 类 java.awt.event.KeyEvent 中的静态变量
用于数字键盘向左方向键的常量。
VK_KP_RIGHT - 类 java.awt.event.KeyEvent 中的静态变量
用于数字键盘向右方向键的常量。
VK_KP_UP - 类 java.awt.event.KeyEvent 中的静态变量
用于数字键盘向上方向键的常量。
VK_L - 类 java.awt.event.KeyEvent 中的静态变量
VK_LEFT - 类 java.awt.event.KeyEvent 中的静态变量
用于非数字键盘向左方向键的常量。
VK_LEFT_PARENTHESIS - 类 java.awt.event.KeyEvent 中的静态变量
用于 "(" 键的常量。
VK_LESS - 类 java.awt.event.KeyEvent 中的静态变量
VK_M - 类 java.awt.event.KeyEvent 中的静态变量
VK_META - 类 java.awt.event.KeyEvent 中的静态变量
VK_MINUS - 类 java.awt.event.KeyEvent 中的静态变量
用于减号键 "-" 的常量
VK_MODECHANGE - 类 java.awt.event.KeyEvent 中的静态变量
VK_MULTIPLY - 类 java.awt.event.KeyEvent 中的静态变量
VK_N - 类 java.awt.event.KeyEvent 中的静态变量
VK_NONCONVERT - 类 java.awt.event.KeyEvent 中的静态变量
用于 Don't Convert 功能键的常量。
VK_NUM_LOCK - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMBER_SIGN - 类 java.awt.event.KeyEvent 中的静态变量
用于 "#" 键的常量。
VK_NUMPAD0 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD1 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD2 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD3 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD4 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD5 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD6 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD7 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD8 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD9 - 类 java.awt.event.KeyEvent 中的静态变量
VK_O - 类 java.awt.event.KeyEvent 中的静态变量
VK_OPEN_BRACKET - 类 java.awt.event.KeyEvent 中的静态变量
用于左方括号键 "[" 的常量。
VK_P - 类 java.awt.event.KeyEvent 中的静态变量
VK_PAGE_DOWN - 类 java.awt.event.KeyEvent 中的静态变量
VK_PAGE_UP - 类 java.awt.event.KeyEvent 中的静态变量
VK_PASTE - 类 java.awt.event.KeyEvent 中的静态变量
VK_PAUSE - 类 java.awt.event.KeyEvent 中的静态变量
VK_PERIOD - 类 java.awt.event.KeyEvent 中的静态变量
用于句点键 "." 的常量。
VK_PLUS - 类 java.awt.event.KeyEvent 中的静态变量
用于 "+" 键的常量。
VK_PREVIOUS_CANDIDATE - 类 java.awt.event.KeyEvent 中的静态变量
用于 Previous Candidate 功能键的常量。
VK_PRINTSCREEN - 类 java.awt.event.KeyEvent 中的静态变量
VK_PROPS - 类 java.awt.event.KeyEvent 中的静态变量
VK_Q - 类 java.awt.event.KeyEvent 中的静态变量
VK_QUOTE - 类 java.awt.event.KeyEvent 中的静态变量
VK_QUOTEDBL - 类 java.awt.event.KeyEvent 中的静态变量
VK_R - 类 java.awt.event.KeyEvent 中的静态变量
VK_RIGHT - 类 java.awt.event.KeyEvent 中的静态变量
用于非数字键盘向右方向键的常量。
VK_RIGHT_PARENTHESIS - 类 java.awt.event.KeyEvent 中的静态变量
用于 ")" 键的常量。
VK_ROMAN_CHARACTERS - 类 java.awt.event.KeyEvent 中的静态变量
用于 Roman Characters 功能键的常量。
VK_S - 类 java.awt.event.KeyEvent 中的静态变量
VK_SCROLL_LOCK - 类 java.awt.event.KeyEvent 中的静态变量
VK_SEMICOLON - 类 java.awt.event.KeyEvent 中的静态变量
用于分号键 ";" 的常量。
VK_SEPARATER - 类 java.awt.event.KeyEvent 中的静态变量
此常量已废弃，包括它仅为了向后兼容。
VK_SEPARATOR - 类 java.awt.event.KeyEvent 中的静态变量
用于数字键盘分隔符键的常量。
VK_SHIFT - 类 java.awt.event.KeyEvent 中的静态变量
VK_SLASH - 类 java.awt.event.KeyEvent 中的静态变量
用于正斜杠键 "/" 的常量。
VK_SPACE - 类 java.awt.event.KeyEvent 中的静态变量
VK_STOP - 类 java.awt.event.KeyEvent 中的静态变量
VK_SUBTRACT - 类 java.awt.event.KeyEvent 中的静态变量
VK_T - 类 java.awt.event.KeyEvent 中的静态变量
VK_TAB - 类 java.awt.event.KeyEvent 中的静态变量
VK_U - 类 java.awt.event.KeyEvent 中的静态变量
VK_UNDEFINED - 类 java.awt.event.KeyEvent 中的静态变量
此值用于指出 keyCode 是未知的。
VK_UNDERSCORE - 类 java.awt.event.KeyEvent 中的静态变量
用于 "_" 键的常量。
VK_UNDO - 类 java.awt.event.KeyEvent 中的静态变量
VK_UP - 类 java.awt.event.KeyEvent 中的静态变量
用于非数字键盘向上方向键的常量。
VK_V - 类 java.awt.event.KeyEvent 中的静态变量
VK_W - 类 java.awt.event.KeyEvent 中的静态变量
VK_WINDOWS - 类 java.awt.event.KeyEvent 中的静态变量
用于 Microsoft Windows 的 "Windows" 键的常量。
VK_X - 类 java.awt.event.KeyEvent 中的静态变量
VK_Y - 类 java.awt.event.KeyEvent 中的静态变量
VK_Z - 类 java.awt.event.KeyEvent 中的静态变量
VLINK - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
VM_ABSTRACT - org.omg.CORBA 中的 接口
定义用来表示 typecode 中的 Abstract 接口的代码。
VM_CUSTOM - org.omg.CORBA 中的 接口
定义用来表示类型代码中自定义编组值类型的代码。
VM_NONE - org.omg.CORBA 中的 接口
定义代码，用来表示一个 typecode 中值类型的值。
VM_TRUNCATABLE - org.omg.CORBA 中的 接口
定义用来表示 typecode 中可截断值类型的代码。
VMID - java.rmi.dgc 中的 类
VMID 是跨所有 Java 虚拟机都唯一的标识符。
VMID() - 类 java.rmi.dgc.VMID 的构造方法
创建一个新的 VMID。
VoiceStatus - javax.sound.midi 中的 类
VoiceStatus 对象包含有关由 Synthesizer 生成的某个声音当前状态的信息。
VoiceStatus() - 类 javax.sound.midi.VoiceStatus 的构造方法
Void - java.lang 中的 类
Void 类是一个不可实例化的占位符类，它持有对表示 Java 关键字 void 的 Class 对象的引用。
VOID - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例描述其 Java 类名称为 java.lang.Void 的值。
VOLATILE - 类 java.lang.reflect.Modifier 中的静态变量
表示 volatile 修饰符的 int 值。
VolatileImage - java.awt.image 中的 类
VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。
VolatileImage() - 类 java.awt.image.VolatileImage 的构造方法
volume - 类 javax.sound.midi.VoiceStatus 中的变量
声音的当前 MIDI 音量级。
VOLUME - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上的音量的控件。
vsb - 类 javax.swing.ScrollPaneLayout 中的变量
滚动窗格的子级垂直滚动条。
vsbChangeListener - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的变量
vsbPolicy - 类 javax.swing.ScrollPaneLayout 中的变量
垂直滚动条的显示策略。
VSPACE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


W - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

W

W3C_LENGTH_UNITS - 类 javax.swing.JEditorPane 中的静态变量
用于客户机属性的关键字，指示是否为 html 呈现使用 w3c 兼容的长度单位。
W3C_XML_SCHEMA_INSTANCE_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
W3C XML Schema Instance Namespace URI. 被定义为 "http://www.w3.org/2001/XMLSchema"。
W3C_XML_SCHEMA_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
W3C XML Schema Namespace URI. 被定义为 "http://www.w3.org/2001/XMLSchema"。
W3C_XPATH_DATATYPE_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
W3C XPath Datatype Namespace URI. 被定义为 "http://www.w3.org/2003/11/xpath-datatypes"。
W3CDomHandler - javax.xml.bind.annotation 中的 类
W3C DOM（org.w3c.dom 包）的 DomHandler 实现。
W3CDomHandler() - 类 javax.xml.bind.annotation.W3CDomHandler 的构造方法
默认的构造方法。
W3CDomHandler(DocumentBuilder) - 类 javax.xml.bind.annotation.W3CDomHandler 的构造方法
允许应用程序指定使用哪一个 DOM 实现的构造方法。
W_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口左边框大小的光标类型。
W_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.W_RESIZE_CURSOR 取代。
WAIS - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
广域信息服务器 (WAIS) 协议。
wait(long) - 类 java.lang.Object 中的方法
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法，或者超过指定的时间量前，导致当前线程等待。
wait(long, int) - 类 java.lang.Object 中的方法
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法，或者其他某个线程中断当前线程，或者已超过某个实际时间量前，导致当前线程等待。
wait() - 类 java.lang.Object 中的方法
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法前，导致当前线程等待。
WAIT_CURSOR - 类 java.awt.Cursor 中的静态变量
等待光标类型。
WAIT_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.WAIT_CURSOR 取代。
waitFor() - 类 java.lang.Process 中的方法
导致当前线程等待，如有必要，一直要等到由该 Process 对象表示的进程已经终止。
waitForAll() - 类 java.awt.MediaTracker 中的方法
开始加载由此媒体跟踪器跟踪的所有图像。
waitForAll(long) - 类 java.awt.MediaTracker 中的方法
开始加载由此媒体跟踪器跟踪的所有图像。
waitForID(int) - 类 java.awt.MediaTracker 中的方法
开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。
waitForID(int, long) - 类 java.awt.MediaTracker 中的方法
开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。
waitForIdle() - 类 java.awt.Robot 中的方法
在处理完当前事件队列中的所有事件之前，一直等待。
waitForWork() - 类 javax.swing.text.LayoutQueue 中的方法
由 worker 线程使用以获取一个要执行的新任务
wakeup() - 类 java.nio.channels.Selector 中的方法
使尚未返回的第一个选择操作立即返回。
WALL_TIME - 类 java.util.SimpleTimeZone 中的静态变量
指定为挂钟时间的开始或结束时间模式的常量。
WANTS_INPUT_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
wantsInput 的绑定属性名。
wantsInput - 类 javax.swing.JOptionPane 中的变量
如果为 true，则向用户提供 UI 窗口小部件以获取输入。
WARNING - 类 java.util.logging.Level 中的静态变量
WARNING 是指示潜在问题的消息级别。
warning(String) - 类 java.util.logging.Logger 中的方法
记录一条 WARNING 消息。
WARNING - 类 javax.print.attribute.standard.Severity 中的静态变量
指示 PrinterStateReason 是 "warning"。
WARNING - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
WARNING 消息类型。
WARNING - 类 javax.security.auth.callback.TextOutputCallback 中的静态变量
警告消息。
WARNING - 接口 javax.xml.bind.ValidationEvent 中的静态变量
根据 XML 1.0 Recommendation 的定义，不属于错误或致命错误的那些条件。
warning(TransformerException) - 接口 javax.xml.transform.ErrorListener 中的方法
接收警告通知。
warning(SAXParseException) - 接口 org.xml.sax.ErrorHandler 中的方法
接收警告的通知。
warning(SAXParseException) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收解析器警告的通知。
warning(SAXParseException) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收解析器警告的通知。
warning(SAXParseException) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个警告事件。
WARNING_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
WARNING_MESSAGE - 类 javax.swing.JOptionPane 中的静态变量
用于警告消息。
warningListeners - 类 javax.imageio.ImageReader 中的变量
当前已注册 IIOReadWarningListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
warningListeners - 类 javax.imageio.ImageWriter 中的变量
当前已注册 IIOWriteWarningListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。
warningLocales - 类 javax.imageio.ImageReader 中的变量
与每个当前已注册 IIOReadWarningListener 关联的 Locale 组成的 List，默认情况下初始化为 null，它与空 List 同义。
warningLocales - 类 javax.imageio.ImageWriter 中的变量
Locale 的 List，warningListeners 的每个元素都有一个 Locale 列表，默认情况下该列表被初始化为 null，它与空 List 同义。
warningOccurred(ImageReader, String) - 接口 javax.imageio.event.IIOReadWarningListener 中的方法
报告在解码中发生非严重错误。
warningOccurred(ImageWriter, int, String) - 接口 javax.imageio.event.IIOWriteWarningListener 中的方法
报告在编码中发生非严重错误。
wasFocused - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 中的变量
wasIcon(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
如果组件已被图标化并且 desktopIcon 的边界是有效的，则返回 true，否则返回 false。
wasNull() - 接口 java.sql.CallableStatement 中的方法
查询最后一个读取的 OUT 参数是否为 SQL NULL。
wasNull() - 接口 java.sql.ResultSet 中的方法
报告最后一个读取的列是否具有值 SQL NULL。
wasNull() - 接口 java.sql.SQLInput 中的方法
获取最后一个读取的值是否为 SQL NULL。
wasNull() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
确认从此 SQLInputImpl 对象读取的上一个值是否为 null。
WAVE - 类 javax.sound.sampled.AudioFileFormat.Type 中的静态变量
指定 WAVE 文件。
WCharSeqHelper - org.omg.CORBA 中的 类
WCharSeq 的 Helper。
WCharSeqHelper() - 类 org.omg.CORBA.WCharSeqHelper 的构造方法
WCharSeqHolder - org.omg.CORBA 中的 类
WCharSeq 的 Holder。
WCharSeqHolder() - 类 org.omg.CORBA.WCharSeqHolder 的构造方法
WCharSeqHolder(char[]) - 类 org.omg.CORBA.WCharSeqHolder 的构造方法
weakCompareAndSet(boolean, boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
weakCompareAndSet(int, int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
如果当前值 == 预期值，则以原子方式将该设置为给定的更新值。
weakCompareAndSet(int, int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
weakCompareAndSet(T, int, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段值设置为给定的更新值。
weakCompareAndSet(long, long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
weakCompareAndSet(int, long, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
weakCompareAndSet(T, long, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段设置为给定的更新值。
weakCompareAndSet(V, V, boolean, boolean) - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
如果当前引用 == 预期引用，并且当前标记等于预期标记，那么以原子方式将引用和标记的值设置为给定的更新值。
weakCompareAndSet(V, V) - 类 java.util.concurrent.atomic.AtomicReference 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
weakCompareAndSet(int, E, E) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
weakCompareAndSet(T, V, V) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器管理的给定对象的字段设置为给定的更新值。
weakCompareAndSet(V, V, int, int) - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
如果当前引用 == 预期引用，并且当前标志等于预期标志，则以原子方式将该引用和该标志的值设置为给定的更新值。
WeakHashMap<K,V> - java.util 中的 类
以弱键 实现的基于哈希表的 Map。
WeakHashMap(int, float) - 类 java.util.WeakHashMap 的构造方法
用给定的初始容量和加载因子构造一个新的空 WeakHashMap。
WeakHashMap(int) - 类 java.util.WeakHashMap 的构造方法
构造具有给定初始容量和默认加载因子 (0.75) 的新的空 WeakHashMap。
WeakHashMap() - 类 java.util.WeakHashMap 的构造方法
构造具有默认初始容量 (16) 和加载因子 (0.75) 的新的空 WeakHashMap。
WeakHashMap(Map<? extends K, ? extends V>) - 类 java.util.WeakHashMap 的构造方法
构造一个新 WeakHashMap，使其与指定的映射具有相同的映射关系。
WeakReference<T> - java.lang.ref 中的 类
弱引用对象，它们并不禁止其指示对象变得可终结，并被终结，然后被回收。
WeakReference(T) - 类 java.lang.ref.WeakReference 的构造方法
创建引用给定对象的新的弱引用。
WeakReference(T, ReferenceQueue<? super T>) - 类 java.lang.ref.WeakReference 的构造方法
创建引用给定对象的新的弱引用，并向给定队列注册该引用。
WebEndpoint - javax.xml.ws 中的 注释类型
此类用来注释所生成服务接口的 getPortName() 方法。
WebFault - javax.xml.ws 中的 注释类型
此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
WebMethod - javax.jws 中的 注释类型
定制一个公开为 Web Service 操作的方法。
WebParam - javax.jws 中的 注释类型
定制单个参数到 Web Service 消息部分和 XML 元素的映射关系。
WebParam.Mode - javax.jws 中的 枚举
参数的流向。
WebResult - javax.jws 中的 注释类型
定制返回值到 WSDL 部分和 XML 元素的映射关系。
WebRowSet - javax.sql.rowset 中的 接口
所有 WebRowSet 的实现都必须实现的标准接口。
WebService - javax.jws 中的 注释类型
将 Java 类标记为实现 Web Service，或者将 Java 接口标记为定义 Web Service 接口。
WebServiceClient - javax.xml.ws 中的 注释类型
此类用来注释生成的服务接口。
WebServiceContext - javax.xml.ws 中的 接口
WebServiceContext 能使 Web 服务端点实现类访问与服务的请求有关的消息上下文和安全信息。
WebServiceException - javax.xml.ws 中的 异常
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。
WebServiceException() - 异常 javax.xml.ws.WebServiceException 的构造方法
构造一个新异常，它的详细消息为 null。
WebServiceException(String) - 异常 javax.xml.ws.WebServiceException 的构造方法
构造具有指定详细消息的新异常。
WebServiceException(String, Throwable) - 异常 javax.xml.ws.WebServiceException 的构造方法
构造一个具有指定详细消息和 cause 的新异常。
WebServiceException(Throwable) - 异常 javax.xml.ws.WebServiceException 的构造方法
构造具有指定 cause 和详细信息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新 WebServiceException。
WebServicePermission - javax.xml.ws 中的 类
此类定义 Web 服务权限。
WebServicePermission(String) - 类 javax.xml.ws.WebServicePermission 的构造方法
创建具有指定名称的新权限。
WebServicePermission(String, String) - 类 javax.xml.ws.WebServicePermission 的构造方法
创建具有指定名称和操作的新权限。
WebServiceProvider - javax.xml.ws 中的 注释类型
此类用来注释 Provider 实现类。
WebServiceRef - javax.xml.ws 中的 注释类型
WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
WebServiceRefs - javax.xml.ws 中的 注释类型
WebServiceRefs 注释允许在类级别声明多个 web 服务引用。
WEDNESDAY - 类 java.util.Calendar 中的静态变量
指示 Wednesday 的 Calendar.DAY_OF_WEEK 字段值。
WEEK_OF_MONTH - 类 java.text.DateFormat.Field 中的静态变量
标识 WEEK_OF_MONTH 字段的常量。
WEEK_OF_MONTH - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示当前月中的星期数。
WEEK_OF_MONTH_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 WEEK_OF_MONTH 字段的有用常量。
WEEK_OF_YEAR - 类 java.text.DateFormat.Field 中的静态变量
标识 WEEK_OF_YEAR 字段的常量。
WEEK_OF_YEAR - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示当前年中的星期数。
WEEK_OF_YEAR_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 WEEK_OF_YEAR 字段的有用常量。
weight - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形的 weight。
WEIGHT - 类 java.awt.font.TextAttribute 中的静态变量
字体 weight 的属性键。
WEIGHT_BOLD - 类 java.awt.font.TextAttribute 中的静态变量
标准的粗体 weight。
WEIGHT_DEMIBOLD - 类 java.awt.font.TextAttribute 中的静态变量
比 WEIGHT_BOLD 稍轻的 weight。
WEIGHT_DEMILIGHT - 类 java.awt.font.TextAttribute 中的静态变量
WEIGHT_LIGHT 和 WEIGHT_STANDARD 之间的中间 weight。
WEIGHT_EXTRA_LIGHT - 类 java.awt.font.TextAttribute 中的静态变量
最轻的预定义 weight。
WEIGHT_EXTRABOLD - 类 java.awt.font.TextAttribute 中的静态变量
特别重的 weight。
WEIGHT_HEAVY - 类 java.awt.font.TextAttribute 中的静态变量
比 WEIGHT_BOLD 稍重的 weight。
WEIGHT_LIGHT - 类 java.awt.font.TextAttribute 中的静态变量
标准的轻 weight。
WEIGHT_MEDIUM - 类 java.awt.font.TextAttribute 中的静态变量
WEIGHT_REGULAR 和 WEIGHT_BOLD 之间的中间 weight。
WEIGHT_REGULAR - 类 java.awt.font.TextAttribute 中的静态变量
标准 weight。
WEIGHT_SEMIBOLD - 类 java.awt.font.TextAttribute 中的静态变量
比 WEIGHT_REGULAR 稍重的 weight。
WEIGHT_ULTRABOLD - 类 java.awt.font.TextAttribute 中的静态变量
最重的预定义 weight。
weightx - 类 java.awt.GridBagConstraints 中的变量
指定如何分布额外的水平空间。
weighty - 类 java.awt.GridBagConstraints 中的变量
指定如何分布额外的垂直空间。
WEST - 类 java.awt.BorderLayout 中的静态变量
西区域的布局约束（容器左边）。
WEST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的左部，并在垂直方向上居中。
WEST - 类 javax.swing.SpringLayout 中的静态变量
指定组件的边界矩形的左边。
WEST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向西（左）。
westPane - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
WHEEL_BLOCK_SCROLL - 类 java.awt.event.MouseWheelEvent 中的静态变量
表示按“块”进行滚动的常量（如使用 page-up、page-down 键进行滚动）
WHEEL_UNIT_SCROLL - 类 java.awt.event.MouseWheelEvent 中的静态变量
表示按“单位”进行滚动的常量（如使用方向键进行滚动）
when - 类 java.awt.Event 中的变量
时间戳。
WHEN_ANCESTOR_OF_FOCUSED_COMPONENT - 类 javax.swing.JComponent 中的静态变量
用于 registerKeyboardAction 的常量，意味着当接收组件是获得焦点的组件的祖先或者其本身就是获得焦点的组件时，应该调用命令。
WHEN_FOCUSED - 类 javax.swing.JComponent 中的静态变量
用于 registerKeyboardAction 的常量，意味着在组件获得焦点时应该调用命令。
WHEN_IN_FOCUSED_WINDOW - 类 javax.swing.JComponent 中的静态变量
用于 registerKeyboardAction 的常量，意味着当接收组件处于获得焦点的窗口内或者其本身就是获得焦点的组件时，应该调用命令。
white - 类 java.awt.Color 中的静态变量
白色。
WHITE - 类 java.awt.Color 中的静态变量
白色。
WHITE_SPACE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
WHITESPACE - 类 java.awt.font.GlyphMetrics 中的静态变量
指示一个无可视化表示形式的字形。
whitespaceChars(int, int) - 类 java.io.StreamTokenizer 中的方法
指定 low <= c <= high 范围中的所有字符 c 都是空白字符。
why - 异常 org.omg.CosNaming.NamingContextPackage.NotFound 中的变量
width - 类 java.awt.Component.BltBufferStrategy 中的变量
后台缓冲区的大小
width - 类 java.awt.Dimension 中的变量
dimension 的宽度，可以使用负值。
WIDTH - 类 java.awt.font.TextAttribute 中的静态变量
字体宽度的属性键。
width - 类 java.awt.geom.Arc2D.Double 中的变量
完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。
width - 类 java.awt.geom.Arc2D.Float 中的变量
完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。
width - 类 java.awt.geom.Ellipse2D.Double 中的变量
此 Ellipse2D 的总宽度。
width - 类 java.awt.geom.Ellipse2D.Float 中的变量
此 Ellipse2D 的总宽度。
width - 类 java.awt.geom.Rectangle2D.Double 中的变量
此 Rectangle2D 的宽度。
width - 类 java.awt.geom.Rectangle2D.Float 中的变量
此 Rectangle2D 的宽度。
width - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
此 RoundRectangle2D 的宽度。
width - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
此 RoundRectangle2D 的宽度。
WIDTH - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示基本图像的宽度现在可用，并且可从 width 参数中获取此宽度到 imageUpdate 回调方法。
width - 类 java.awt.image.Raster 中的变量
此 Raster 的宽度。
width - 类 java.awt.image.SampleModel 中的变量
此 SampleModel 描述的图像数据区域的宽度（以像素位单位）。
width - 类 java.awt.Rectangle 中的变量
Rectangle 的宽度。
width(Component) - 类 javax.swing.Spring 中的静态方法
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的宽度定义。
WIDTH - 类 javax.swing.SpringLayout 中的静态变量
指定组件边界矩形的宽度。
width - 类 javax.swing.table.TableColumn 中的变量
列的宽度。
WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
WIDTH - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
WIDTH_CONDENSED - 类 java.awt.font.TextAttribute 中的静态变量
最精简的预定义 width。
WIDTH_EXTENDED - 类 java.awt.font.TextAttribute 中的静态变量
最大扩展的预定义 width。
WIDTH_REGULAR - 类 java.awt.font.TextAttribute 中的静态变量
标准 width。
WIDTH_SEMI_CONDENSED - 类 java.awt.font.TextAttribute 中的静态变量
适度精简的 width。
WIDTH_SEMI_EXTENDED - 类 java.awt.font.TextAttribute 中的静态变量
适度扩展的 width。
WILDCARD - 类 javax.management.ObjectName 中的静态变量
定义通配符 "*:*" ObjectName。
WildcardType - java.lang.reflect 中的 接口
WildcardType 表示一个通配符类型表达式，如 ?、? extends Number 或 ? super Integer。
WildcardType - javax.lang.model.type 中的 接口
表示通配符类型参数。
WIND_EVEN_ODD - 类 java.awt.geom.Path2D 中的静态变量
用于确定路径内部的奇偶旋绕规则。
WIND_EVEN_ODD - 接口 java.awt.geom.PathIterator 中的静态变量
用于指定确定路径内部的奇偶规则的旋绕规则常量。
WIND_NON_ZERO - 类 java.awt.geom.Path2D 中的静态变量
用于确定路径内部的非零旋绕规则。
WIND_NON_ZERO - 接口 java.awt.geom.PathIterator 中的静态变量
用于指定确定路径内部的非零规则的旋绕规则常量。
WINDOW - 类 java.awt.SystemColor 中的静态变量
SystemColor.window 系统颜色的数组索引。
window - 类 java.awt.SystemColor 中的静态变量
为窗口的内部区域提供的背景色。
Window - java.awt 中的 类
Window 对象是一个没有边界和菜单栏的顶层窗口。
Window(Frame) - 类 java.awt.Window 的构造方法
构造一个新的、最初不可见的窗口，使用指定的 Frame 作为其所有者。
Window(Window) - 类 java.awt.Window 的构造方法
构造一个新的、最初不可见的窗口，使用指定 Window 作为其所有者。
Window(Window, GraphicsConfiguration) - 类 java.awt.Window 的构造方法
构造一个新的、最初不可见的窗口，使用指定的所有者 Window 和屏幕设备的 GraphicsConfiguration。
WINDOW - 类 javax.accessibility.AccessibleRole 中的静态变量
不带标题或边框的顶层窗口。
Window.AccessibleAWTWindow - java.awt 中的 类
此类实现对 Window 类的可访问性支持。
Window.AccessibleAWTWindow() - 类 java.awt.Window.AccessibleAWTWindow 的构造方法
WINDOW_ACTIVATED - 类 java.awt.event.WindowEvent 中的静态变量
窗口激活事件类型。
WINDOW_BORDER - 类 java.awt.SystemColor 中的静态变量
SystemColor.windowBorder 系统颜色的数组索引。
WINDOW_CLOSED - 类 java.awt.event.WindowEvent 中的静态变量
窗口关闭事件。
WINDOW_CLOSING - 类 java.awt.event.WindowEvent 中的静态变量
“窗口正在关闭”事件。
WINDOW_DEACTIVATED - 类 java.awt.event.WindowEvent 中的静态变量
窗口停用事件类型。
WINDOW_DEICONIFIED - 类 java.awt.event.WindowEvent 中的静态变量
窗口取消图标化事件类型。
WINDOW_DEICONIFY - 类 java.awt.Event 中的静态变量
用户要求窗口管理程序取消窗口图标化。
WINDOW_DESTROY - 类 java.awt.Event 中的静态变量
用户要求窗口管理程序关掉窗口。
WINDOW_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择窗口事件的事件掩码。
WINDOW_EXPOSE - 类 java.awt.Event 中的静态变量
用户要求窗口管理程序公开窗口。
WINDOW_FIRST - 类 java.awt.event.WindowEvent 中的静态变量
用于窗口事件的 id 范围的起始编号。
WINDOW_FOCUS_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择窗口焦点事件的事件掩码。
WINDOW_GAINED_FOCUS - 类 java.awt.event.WindowEvent 中的静态变量
窗口获得焦点事件类型。
WINDOW_ICONIFIED - 类 java.awt.event.WindowEvent 中的静态变量
窗口图标化事件。
WINDOW_ICONIFY - 类 java.awt.Event 中的静态变量
用户要求窗口管理程序图标化窗口。
WINDOW_LAST - 类 java.awt.event.WindowEvent 中的静态变量
用于窗口事件的 id 范围的结束编号。
WINDOW_LOST_FOCUS - 类 java.awt.event.WindowEvent 中的静态变量
窗口失去焦点事件类型。
WINDOW_MOVED - 类 java.awt.Event 中的静态变量
用户要求窗口管理程序移动窗口。
WINDOW_OPENED - 类 java.awt.event.WindowEvent 中的静态变量
窗口打开事件。
WINDOW_STATE_CHANGED - 类 java.awt.event.WindowEvent 中的静态变量
窗口状态改变事件类型。
WINDOW_STATE_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择窗口状态事件的事件掩码。
WINDOW_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.windowText 系统颜色的数组索引。
windowActivated(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowActivated 方法处理 windowActivated 事件。
windowActivated(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
激活窗口时调用。
windowActivated(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
将 Window 设置为活动 Window 时调用。
WindowAdapter - java.awt.event 中的 类
接收窗口事件的抽象适配器类。
WindowAdapter() - 类 java.awt.event.WindowAdapter 的构造方法
windowBorder - 类 java.awt.SystemColor 中的静态变量
为窗口内部区域的边框提供的颜色。
windowClosed(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowClosed 方法处理 windowClosed 事件。
windowClosed(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
当窗口已被关闭时调用。
windowClosed(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
因对窗口调用 dispose 而将其关闭时调用。
windowClosing(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowClosing 方法处理 windowClosing 事件。
windowClosing(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
窗口正处在关闭过程中时调用。
windowClosing(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
用户试图从窗口的系统菜单中关闭窗口时调用。
windowClosing(WindowEvent) - 类 javax.swing.JMenu.WinListener 中的方法
从外部关闭弹出菜单时取消选择该菜单。
windowClosing(WindowEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.FrameListener 中的方法
WindowConstants - javax.swing 中的 接口
用于控制窗口关闭操作的常量。
windowDeactivated(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowDeactivated 方法处理 windowDeactivated 事件。
windowDeactivated(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
停用窗口时调用。
windowDeactivated(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
当 Window 不再是活动 Window 时调用。
windowDeiconified(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowDeiconified 方法处理 windowDeiconified 事件。
windowDeiconified(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
取消图标化窗口时调用。
windowDeiconified(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
窗口从最小化状态变为正常状态时调用。
WindowEvent - java.awt.event 中的 类
指示窗口状态改变的低级别事件。
WindowEvent(Window, int, Window, int, int) - 类 java.awt.event.WindowEvent 的构造方法
构造一个 WindowEvent 对象。
WindowEvent(Window, int, Window) - 类 java.awt.event.WindowEvent 的构造方法
构造一个具有指定对应 Window 的 WindowEvent 对象。
WindowEvent(Window, int, int, int) - 类 java.awt.event.WindowEvent 的构造方法
构造一个具有指定的以前和新窗口状态的 WindowEvent 对象。
WindowEvent(Window, int) - 类 java.awt.event.WindowEvent 的构造方法
构造一个 WindowEvent 对象。
WindowFocusListener - java.awt.event 中的 接口
用于接收 WindowEvent（包括 WINDOW_GAINED_FOCUS 和 WINDOW_LOST_FOCUS 事件）的侦听器接口。
windowForComponent(Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
windowGainedFocus(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowGainedFocus 方法处理 windowGainedFocus 事件。
windowGainedFocus(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。
windowGainedFocus(WindowEvent) - 接口 java.awt.event.WindowFocusListener 中的方法
该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。
windowIconified(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowIconified 方法处理 windowIconified 事件。
windowIconified(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
图标化窗口时调用。
windowIconified(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
窗口从正常状态变为最小化状态时调用。
windowInit() - 类 javax.swing.JWindow 中的方法
由该构造方法调用以正确初始化 JWindow。
WindowListener - java.awt.event 中的 接口
用于接收窗口事件的侦听器接口。
windowLostFocus(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowLostFocus 方法处理 windowLostFocus 事件。
windowLostFocus(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
该 Window 不再为聚焦 Window 时调用，不再为聚焦 Window 意味着键盘事件不再传递到该 Window 或其任意子组件。
windowLostFocus(WindowEvent) - 接口 java.awt.event.WindowFocusListener 中的方法
该 Window 不再是聚焦 Window 时调用，不再是聚焦 Window 意味着不再传递键盘事件到该 Window 或其任意子组件。
windowMenu - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
windowOpened(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowOpened 方法处理 windowOpened 事件。
windowOpened(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
已打开窗口时调用。
windowOpened(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
窗口首次变为可见时调用。
windowStateChanged(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowStateChanged 方法处理 windowStateChanged 事件。
windowStateChanged(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
窗口状态改变时调用。
windowStateChanged(WindowEvent) - 接口 java.awt.event.WindowStateListener 中的方法
窗口状态改变时调用。
WindowStateListener - java.awt.event 中的 接口
用于接收窗口状态事件的侦听器接口。
windowText - 类 java.awt.SystemColor 中的静态变量
为窗口内部区域的文本提供的颜色。
WORD - 接口 javax.accessibility.AccessibleText 中的静态变量
用于指示应获取的文本部分是一个单词的常量。
WORD_SPACING - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
wordChars(int, int) - 类 java.io.StreamTokenizer 中的方法
指定 low <= c <= high 范围中的所有字符 c 都是文字成分。
work_pending() - 类 org.omg.CORBA.ORB 中的方法
如果 ORB 需要主线程来执行某些操作，则返回 true；如果 ORB 不需要主线程，则返回 false。
wrap(byte[], int, int) - 类 java.nio.ByteBuffer 中的静态方法
将 byte 数组包装到缓冲区中。
wrap(byte[]) - 类 java.nio.ByteBuffer 中的静态方法
将 byte 数组包装到缓冲区中。
wrap(char[], int, int) - 类 java.nio.CharBuffer 中的静态方法
将字符数组包装到缓冲区中。
wrap(char[]) - 类 java.nio.CharBuffer 中的静态方法
将字符数组包装到缓冲区中。
wrap(CharSequence, int, int) - 类 java.nio.CharBuffer 中的静态方法
将字符序列包装到缓冲区中。
wrap(CharSequence) - 类 java.nio.CharBuffer 中的静态方法
将字符序列包装到缓冲区中。
wrap(double[], int, int) - 类 java.nio.DoubleBuffer 中的静态方法
将 double 数组包装到缓冲区中。
wrap(double[]) - 类 java.nio.DoubleBuffer 中的静态方法
将 double 数组包装到缓冲区中。
wrap(float[], int, int) - 类 java.nio.FloatBuffer 中的静态方法
将 float 数组包装到缓冲区中。
wrap(float[]) - 类 java.nio.FloatBuffer 中的静态方法
将 float 数组包装到缓冲区中。
wrap(int[], int, int) - 类 java.nio.IntBuffer 中的静态方法
将 int 数组包装到缓冲区中。
wrap(int[]) - 类 java.nio.IntBuffer 中的静态方法
将 int 数组包装到缓冲区中。
wrap(long[], int, int) - 类 java.nio.LongBuffer 中的静态方法
将 long 数组包装到缓冲区中。
wrap(long[]) - 类 java.nio.LongBuffer 中的静态方法
将 long 数组包装到缓冲区中。
wrap(short[], int, int) - 类 java.nio.ShortBuffer 中的静态方法
将 short 数组包装到缓冲区中。
wrap(short[]) - 类 java.nio.ShortBuffer 中的静态方法
将 short 数组包装到缓冲区中。
wrap(Key) - 类 javax.crypto.Cipher 中的方法
包装密钥。
wrap(ByteBuffer, ByteBuffer) - 类 javax.net.ssl.SSLEngine 中的方法
试图把缓冲区的纯文本应用程序数据编码成 SSL/TLS 网络数据。
wrap(ByteBuffer[], ByteBuffer) - 类 javax.net.ssl.SSLEngine 中的方法
尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
wrap(ByteBuffer[], int, int, ByteBuffer) - 类 javax.net.ssl.SSLEngine 中的方法
尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
wrap(byte[], int, int) - 接口 javax.security.sasl.SaslClient 中的方法
包装要发送到服务器的 byte 数组。
wrap(byte[], int, int) - 接口 javax.security.sasl.SaslServer 中的方法
包装要发送到客户端的 byte 数组。
wrap(byte[], int, int, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
将 per-message 安全服务应用于已创建的安全上下文。
wrap(InputStream, OutputStream, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
将 per-message 安全服务应用于已创建的使用流的安全上下文。
WRAP_MODE - 类 javax.crypto.Cipher 中的静态变量
用于将 Cipher 初始化为密钥包装模式的常量。
WRAP_TAB_LAYOUT - 类 javax.swing.JTabbedPane 中的静态变量
当在一次运行中不能放入所有的选项卡时，在多次运行中包装选项卡的选项卡布局策略。
wrapException(Throwable) - 类 javax.rmi.CORBA.Util 中的静态方法
包装由实现方法抛出的异常。
wrapException(Throwable) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.wrapException(java.lang.Throwable) 的委托调用。
WrappedPlainView - javax.swing.text 中的 类
进行换行的纯文本（仅有一种字体和颜色的文本）视图。
WrappedPlainView(Element) - 类 javax.swing.text.WrappedPlainView 的构造方法
创建一个新的 WrappedPlainView。
WrappedPlainView(Element, boolean) - 类 javax.swing.text.WrappedPlainView 的构造方法
创建一个新的 WrappedPlainView。
Wrapper - java.sql 中的 接口
在相关实例实际上是代理类时提供获取委托实例能力的 JDBC 类的接口。
writableAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
将编辑器设置为可写入模式的动作名称。
WritableByteChannel - java.nio.channels 中的 接口
可写入字节的通道。
WritableRaster - java.awt.image 中的 类
此类扩展了 Raster 以提供像素写入功能。
WritableRaster(SampleModel, Point) - 类 java.awt.image.WritableRaster 的构造方法
构造具有给定 SampleModel 的 WritableRaster。
WritableRaster(SampleModel, DataBuffer, Point) - 类 java.awt.image.WritableRaster 的构造方法
构造具有给定 SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster(SampleModel, DataBuffer, Rectangle, Point, WritableRaster) - 类 java.awt.image.WritableRaster 的构造方法
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。
WritableRenderedImage - java.awt.image 中的 接口
WriteableRenderedImage 公共接口用于那些包含或者能够生成 Rasters 形式图像数据的对象，以及能够被修改和/或写入的对象。
write(String) - 类 java.awt.color.ICC_Profile 中的方法
将此 ICC_Profile 写入一个文件。
write(OutputStream) - 类 java.awt.color.ICC_Profile 中的方法
将 ICC_Profile 写入一个 OutputStream。
write(int) - 类 java.io.BufferedOutputStream 中的方法
将指定的字节写入此缓冲的输出流。
write(byte[], int, int) - 类 java.io.BufferedOutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此缓冲的输出流。
write(int) - 类 java.io.BufferedWriter 中的方法
写入单个字符。
write(char[], int, int) - 类 java.io.BufferedWriter 中的方法
写入字符数组的某一部分。
write(String, int, int) - 类 java.io.BufferedWriter 中的方法
写入字符串的某一部分。
write(int) - 类 java.io.ByteArrayOutputStream 中的方法
将指定的字节写入此 byte 数组输出流。
write(byte[], int, int) - 类 java.io.ByteArrayOutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此 byte 数组输出流。
write(int) - 类 java.io.CharArrayWriter 中的方法
将一个字符写入缓冲区。
write(char[], int, int) - 类 java.io.CharArrayWriter 中的方法
将字符写入缓冲区。
write(String, int, int) - 类 java.io.CharArrayWriter 中的方法
将字符串的某一部分写入缓冲区。
write(int) - 接口 java.io.DataOutput 中的方法
将参数 b 的八个低位写入输出流。
write(byte[]) - 接口 java.io.DataOutput 中的方法
将数组 b 中的所有字节写入输出流。
write(byte[], int, int) - 接口 java.io.DataOutput 中的方法
将数组 b 中的 len 个字节按顺序写入输出流。
write(int) - 类 java.io.DataOutputStream 中的方法
将指定字节（参数 b 的八个低位）写入基础输出流。
write(byte[], int, int) - 类 java.io.DataOutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入基础输出流。
write(int) - 类 java.io.FileOutputStream 中的方法
将指定字节写入此文件输出流。
write(byte[]) - 类 java.io.FileOutputStream 中的方法
将 b.length 个字节从指定 byte 数组写入此文件输出流中。
write(byte[], int, int) - 类 java.io.FileOutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此文件输出流。
write(int) - 类 java.io.FilterOutputStream 中的方法
将指定 byte 写入此输出流。
write(byte[]) - 类 java.io.FilterOutputStream 中的方法
将 b.length 个字节写入此输出流。
write(byte[], int, int) - 类 java.io.FilterOutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。
write(int) - 类 java.io.FilterWriter 中的方法
写入单个字符。
write(char[], int, int) - 类 java.io.FilterWriter 中的方法
将字符写入数组的某一部分。
write(String, int, int) - 类 java.io.FilterWriter 中的方法
写入一部分字符串。
write(int) - 接口 java.io.ObjectOutput 中的方法
写入字节。
write(byte[]) - 接口 java.io.ObjectOutput 中的方法
写入 byte 数组。
write(byte[], int, int) - 接口 java.io.ObjectOutput 中的方法
写入字节的子数组。
write(ObjectOutput) - 类 java.io.ObjectOutputStream.PutField 中的方法
已过时。 此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。
write(int) - 类 java.io.ObjectOutputStream 中的方法
写入一个字节。
write(byte[]) - 类 java.io.ObjectOutputStream 中的方法
写入一个 byte 数组。
write(byte[], int, int) - 类 java.io.ObjectOutputStream 中的方法
写入字节的子数组。
write(int) - 类 java.io.OutputStream 中的方法
将指定的字节写入此输出流。
write(byte[]) - 类 java.io.OutputStream 中的方法
将 b.length 个字节从指定的 byte 数组写入此输出流。
write(byte[], int, int) - 类 java.io.OutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。
write(int) - 类 java.io.OutputStreamWriter 中的方法
写入单个字符。
write(char[], int, int) - 类 java.io.OutputStreamWriter 中的方法
写入字符数组的某一部分。
write(String, int, int) - 类 java.io.OutputStreamWriter 中的方法
写入字符串的某一部分。
write(int) - 类 java.io.PipedOutputStream 中的方法
将指定 byte 写入传送的输出流。
write(byte[], int, int) - 类 java.io.PipedOutputStream 中的方法
将 len 字节从初始偏移量为 off 的指定 byte 数组写入该管道输出流。
write(int) - 类 java.io.PipedWriter 中的方法
将指定的 char 写入管道输出流。
write(char[], int, int) - 类 java.io.PipedWriter 中的方法
将 len 字符从指定初始偏移量为 off 的字符数组写入到此管道输出流。
write(int) - 类 java.io.PrintStream 中的方法
将指定的字节写入此流。
write(byte[], int, int) - 类 java.io.PrintStream 中的方法
将 len 字节从指定的初始偏移量为 off 的 byte 数组写入此流。
write(int) - 类 java.io.PrintWriter 中的方法
写入单个字符。
write(char[], int, int) - 类 java.io.PrintWriter 中的方法
写入字符数组的某一部分。
write(char[]) - 类 java.io.PrintWriter 中的方法
写入字符数组。
write(String, int, int) - 类 java.io.PrintWriter 中的方法
写入字符串的某一部分。
write(String) - 类 java.io.PrintWriter 中的方法
写入字符串。
write(int) - 类 java.io.RandomAccessFile 中的方法
向此文件写入指定的字节。
write(byte[]) - 类 java.io.RandomAccessFile 中的方法
将 b.length 个字节从指定 byte 数组写入到此文件，并从当前文件指针开始。
write(byte[], int, int) - 类 java.io.RandomAccessFile 中的方法
将 len 个字节从指定 byte 数组写入到此文件，并从偏移量 off 处开始。
write(int) - 类 java.io.StringWriter 中的方法
写入单个字符。
write(char[], int, int) - 类 java.io.StringWriter 中的方法
写入字符数组的某一部分。
write(String) - 类 java.io.StringWriter 中的方法
写入一个字符串。
write(String, int, int) - 类 java.io.StringWriter 中的方法
写入字符串的某一部分。
write(int) - 类 java.io.Writer 中的方法
写入单个字符。
write(char[]) - 类 java.io.Writer 中的方法
写入字符数组。
write(char[], int, int) - 类 java.io.Writer 中的方法
写入字符数组的某一部分。
write(String) - 类 java.io.Writer 中的方法
写入字符串。
write(String, int, int) - 类 java.io.Writer 中的方法
写入字符串的某一部分。
write(ByteBuffer) - 类 java.nio.channels.DatagramChannel 中的方法
将数据报写入此通道。
write(ByteBuffer[], int, int) - 类 java.nio.channels.DatagramChannel 中的方法
将数据报写入此通道。
write(ByteBuffer[]) - 类 java.nio.channels.DatagramChannel 中的方法
将数据报写入此通道。
write(ByteBuffer) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从给定的缓冲区写入此通道。
write(ByteBuffer[], int, int) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从给定缓冲区的子序列写入此通道。
write(ByteBuffer[]) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从给定的缓冲区写入此通道。
write(ByteBuffer, long) - 类 java.nio.channels.FileChannel 中的方法
从给定的文件位置开始，将字节序列从给定缓冲区写入此通道。
write(ByteBuffer[], int, int) - 接口 java.nio.channels.GatheringByteChannel 中的方法
将字节序列从给定缓冲区的子序列写入此通道。
write(ByteBuffer[]) - 接口 java.nio.channels.GatheringByteChannel 中的方法
将字节序列从给定的缓冲区写入此通道。
write(ByteBuffer) - 类 java.nio.channels.SocketChannel 中的方法
write(ByteBuffer[], int, int) - 类 java.nio.channels.SocketChannel 中的方法
write(ByteBuffer[]) - 类 java.nio.channels.SocketChannel 中的方法
write(ByteBuffer) - 接口 java.nio.channels.WritableByteChannel 中的方法
将字节序列从给定的缓冲区中写入此通道。
write(int) - 类 java.rmi.server.LogStream 中的方法
已过时。 无替代版本
write(byte[], int, int) - 类 java.rmi.server.LogStream 中的方法
已过时。 无替代版本
write(ObjectOutput) - 类 java.rmi.server.ObjID 中的方法
将此 ObjID 的二进制表示形式编组为一个 ObjectOutput 实例。
write(DataOutput) - 类 java.rmi.server.UID 中的方法
将此 UID 的二进制表示形式编组为一个 DataOutput 实例。
write(int) - 类 java.security.DigestOutputStream 中的方法
使用指定的字节更新消息摘要（如果开启了摘要功能），并将字节写入输出流（不管是否开启了摘要功能）。
write(byte[], int, int) - 类 java.security.DigestOutputStream 中的方法
使用指定的子数组更新消息摘要（如果开启了摘要功能），并将子数组写入输出流（不管是否开启了摘要功能）。
write(OutputStream) - 类 java.util.jar.Manifest 中的方法
将 Manifest 写入指定的 OutputStream。
write(int) - 类 java.util.zip.CheckedOutputStream 中的方法
写入字节。
write(byte[], int, int) - 类 java.util.zip.CheckedOutputStream 中的方法
写入字节数组。
write(int) - 类 java.util.zip.DeflaterOutputStream 中的方法
将字节写入压缩的输出流。
write(byte[], int, int) - 类 java.util.zip.DeflaterOutputStream 中的方法
将字节数组写入压缩的输出流。
write(byte[], int, int) - 类 java.util.zip.GZIPOutputStream 中的方法
将字节数组写入压缩输出流。
write(int) - 类 java.util.zip.InflaterOutputStream 中的方法
将字节写入未压缩输出流。
write(byte[], int, int) - 类 java.util.zip.InflaterOutputStream 中的方法
将 byte 数组写入未压缩输出流。
write(byte[], int, int) - 类 java.util.zip.ZipOutputStream 中的方法
将字节数组写入当前 ZIP 条目数据。
write(int) - 类 javax.crypto.CipherOutputStream 中的方法
将指定的字节写入此输出流。
write(byte[]) - 类 javax.crypto.CipherOutputStream 中的方法
从指定的字节数组中将 b.length 个字节写入此输出流。
write(byte[], int, int) - 类 javax.crypto.CipherOutputStream 中的方法
将指定的字节数组中从 off 偏移量开始的 len 个字节写入此输出流。
write(RenderedImage, String, ImageOutputStream) - 类 javax.imageio.ImageIO 中的静态方法
使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。
write(RenderedImage, String, File) - 类 javax.imageio.ImageIO 中的静态方法
使用支持给定格式的任意 ImageWriter 将一个图像写入 File。
write(RenderedImage, String, OutputStream) - 类 javax.imageio.ImageIO 中的静态方法
使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。
write(IIOMetadata, IIOImage, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。
write(IIOImage) - 类 javax.imageio.ImageWriter 中的方法
将包含带有默认元数据和缩略图的单个图像的完整图像流添加到输出中。
write(RenderedImage) - 类 javax.imageio.ImageWriter 中的方法
将由带有默认元数据和缩略图的单个图像组成的完整图像流添加到输出中。
write(int) - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
write(byte[], int, int) - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
write(int) - 类 javax.imageio.stream.FileImageOutputStream 中的方法
write(byte[], int, int) - 类 javax.imageio.stream.FileImageOutputStream 中的方法
write(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将单个字节写入到流中的当前位置。
write(byte[]) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将字节序列写入到流中的当前位置。
write(byte[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将字节序列写入到流中的当前位置。
write(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
write(byte[]) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
write(byte[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
write(int) - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
write(byte[], int, int) - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
write(Sequence, int, OutputStream) - 类 javax.sound.midi.MidiSystem 中的静态方法
将表示所指示 MIDI 文件类型的文件的字节流写入提供的输出流。
write(Sequence, int, File) - 类 javax.sound.midi.MidiSystem 中的静态方法
将表示所指示 MIDI 文件类型的文件的字节流写入提供的外部文件。
write(Sequence, int, OutputStream) - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
写入表示指示为所提供输出流的文件类型的 MIDI 文件的字节流。
write(Sequence, int, File) - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
写入表示指示为所提供外部文件的文件类型的 MIDI 文件的字节流。
write(AudioInputStream, AudioFileFormat.Type, OutputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
将表示指定文件类型的音频文件的字节流写入所提供的输出流。
write(AudioInputStream, AudioFileFormat.Type, File) - 类 javax.sound.sampled.AudioSystem 中的静态方法
将表示指定文件类型的音频文件的字节流写入所提供的外部文件。
write(byte[], int, int) - 接口 javax.sound.sampled.SourceDataLine 中的方法
通过此源数据行将音频数据写入混频器。
write(AudioInputStream, AudioFileFormat.Type, OutputStream) - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
将表示所指示文件类型的音频文件的字节流写入所提供的输出流。
write(AudioInputStream, AudioFileFormat.Type, File) - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。
write() - 类 javax.swing.text.AbstractWriter 中的方法
需要由子类实现此抽象方法。
write(char) - 类 javax.swing.text.AbstractWriter 中的方法
写出字符。
write(String) - 类 javax.swing.text.AbstractWriter 中的方法
写出字符串。
write(char[], int, int) - 类 javax.swing.text.AbstractWriter 中的方法
所有 write 方法都调用到此方法。
write(OutputStream, Document, int, int) - 类 javax.swing.text.DefaultEditorKit 中的方法
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
write(Writer, Document, int, int) - 类 javax.swing.text.DefaultEditorKit 中的方法
将取自文档的内容以纯文本格式写入给定流。
write(OutputStream, Document, int, int) - 类 javax.swing.text.EditorKit 中的方法
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
write(Writer, Document, int, int) - 类 javax.swing.text.EditorKit 中的方法
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
write(Writer, Document, int, int) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
以适合此类内容处理程序的格式，将文档中的内容写入给定流。
write() - 类 javax.swing.text.html.HTMLWriter 中的方法
对 Element 树进行迭代并控制所有标记及其属性的写出。
write() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
从 StyledDocument 生成 HTML 输出。
write(Writer) - 类 javax.swing.text.JTextComponent 中的方法
将模型的内容存储到给定的流中。
write(OutputStream, Document, int, int) - 类 javax.swing.text.rtf.RTFEditorKit 中的方法
以适合此类内容处理程序的格式，将文档中的内容写入给定流。
write(Writer, Document, int, int) - 类 javax.swing.text.rtf.RTFEditorKit 中的方法
将文档中的内容作为纯文本写入给定的流。
write(OutputStream, Any[]) - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
write(OutputStream, boolean[]) - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
write(OutputStream, char[]) - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
write(OutputStream, CompletionStatus) - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
write(OutputStream, Current) - 类 org.omg.CORBA.CurrentHelper 中的静态方法
write(OutputStream, DefinitionKind) - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
write(OutputStream, double[]) - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
write(OutputStream, float[]) - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
write(OutputStream, IDLType) - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
write(OutputStream, long[]) - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
write(OutputStream, int[]) - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
write(OutputStream, NameValuePair) - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
write(OutputStream, Object) - 类 org.omg.CORBA.ObjectHelper 中的静态方法
write(OutputStream, byte[]) - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
write(OutputStream, ParameterMode) - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
write(OutputStream, short) - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
write(OutputStream, PolicyError) - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
write(OutputStream, Policy) - 类 org.omg.CORBA.PolicyHelper 中的静态方法
write(OutputStream, Policy[]) - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
write(OutputStream, int) - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
write(int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 integer（数组长度）写入此流。
write(OutputStream, String) - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
write(OutputStream, ServiceDetail) - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
write(OutputStream, ServiceInformation) - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
write(OutputStream, SetOverrideType) - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
write(OutputStream, short[]) - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
write(OutputStream, String[]) - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CORBA.StringValueHelper 中的静态方法
write(OutputStream, StructMember) - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
write(OutputStream, long[]) - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
write(OutputStream, int[]) - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
write(OutputStream, UnionMember) - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
write(OutputStream, UnknownUserException) - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
write(OutputStream, short[]) - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
write(OutputStream, Serializable) - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
write(OutputStream, ValueMember) - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
write(OutputStream, short) - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
write(OutputStream, char[]) - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
write(OutputStream, WrongTransaction) - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
write(OutputStream, String[]) - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
write(OutputStream, Binding) - 类 org.omg.CosNaming.BindingHelper 中的静态方法
write(OutputStream, BindingIterator) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
write(OutputStream, Binding[]) - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
write(OutputStream, BindingType) - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CosNaming.IstringHelper 中的静态方法
write(OutputStream, NameComponent) - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
write(OutputStream, NameComponent[]) - 类 org.omg.CosNaming.NameHelper 中的静态方法
write(OutputStream, NamingContextExt) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
write(OutputStream, InvalidAddress) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
write(OutputStream, NamingContext) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
write(OutputStream, AlreadyBound) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
write(OutputStream, CannotProceed) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
write(OutputStream, InvalidName) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
write(OutputStream, NotEmpty) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
write(OutputStream, NotFound) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
write(OutputStream, NotFoundReason) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
write(OutputStream, Any[]) - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
write(OutputStream, DynAnyFactory) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
write(OutputStream, InconsistentTypeCode) - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
write(OutputStream, DynAny) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
write(OutputStream, InvalidValue) - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
write(OutputStream, TypeMismatch) - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
write(OutputStream, DynAny[]) - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
write(OutputStream, DynArray) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
write(OutputStream, DynEnum) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
write(OutputStream, DynFixed) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
write(OutputStream, DynSequence) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
write(OutputStream, DynStruct) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
write(OutputStream, DynUnion) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
write(OutputStream, DynValue) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
write(OutputStream, NameDynAnyPair) - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
write(OutputStream, NameDynAnyPair[]) - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
write(OutputStream, NameValuePair) - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
write(OutputStream, NameValuePair[]) - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
write(OutputStream, CodecFactory) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
write(OutputStream, UnknownEncoding) - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
write(OutputStream, FormatMismatch) - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
write(OutputStream, InvalidTypeForEncoding) - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
write(OutputStream, TypeMismatch) - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
write(OutputStream, int) - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
write(OutputStream, IOR) - 类 org.omg.IOP.IORHelper 中的静态方法
write(OutputStream, TaggedComponent[]) - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
write(OutputStream, int) - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
write(OutputStream, ServiceContext) - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
write(OutputStream, ServiceContext[]) - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
write(OutputStream, int) - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
write(OutputStream, TaggedComponent) - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
write(OutputStream, TaggedProfile) - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
write(OutputStream, short) - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
write(OutputStream, int) - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
write(OutputStream, String[]) - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
write(OutputStream, short) - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
write(OutputStream, Current) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
write(OutputStream, ForwardRequest) - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
write(OutputStream, InvalidSlot) - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
write(OutputStream, IORInterceptor_3_0) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
write(OutputStream, byte[]) - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
write(OutputStream, ObjectReferenceFactory) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
write(OutputStream, ObjectReferenceTemplate) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
write(OutputStream, ObjectReferenceTemplate[]) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
write(OutputStream, DuplicateName) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
write(OutputStream, InvalidName) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
write(OutputStream, Current) - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
write(OutputStream, NoContext) - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
write(OutputStream, ForwardRequest) - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
write(OutputStream, POA) - 类 org.omg.PortableServer.POAHelper 中的静态方法
write(OutputStream, AdapterInactive) - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
write(OutputStream, AdapterAlreadyExists) - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
write(OutputStream, AdapterNonExistent) - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
write(OutputStream, InvalidPolicy) - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
write(OutputStream, NoServant) - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
write(OutputStream, ObjectAlreadyActive) - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
write(OutputStream, ObjectNotActive) - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
write(OutputStream, ServantAlreadyActive) - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
write(OutputStream, ServantNotActive) - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
write(OutputStream, WrongAdapter) - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
write(OutputStream, WrongPolicy) - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
write(OutputStream, ServantActivator) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
write(OutputStream, ServantLocator) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
write(Node, LSOutput) - 接口 org.w3c.dom.ls.LSSerializer 中的方法
像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
write_Abstract(Object) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL Abstract 接口类型写入输出流。
write_abstract_interface(Object) - 类 org.omg.CORBA_2_3.portable.OutputStream 中的方法
编组值对象或 stub 对象。
write_any(Any) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 Any 值写入输出流。
write_any(Any) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 Any。
write_any_array(Any[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL Any 数组中从 offset 处开始的 length 个元素写入输出流。
write_boolean(boolean) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 boolean 值写入输出流。
write_boolean(boolean) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 boolean 值写入此流。
write_boolean_array(boolean[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL boolean 数组中从 offset 处开始的 length 个元素写入输出流。
write_boolean_array(boolean[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 boolean 数组。
write_char(char) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL 字符值写入输出流。
write_char(char) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 char 值写入此流。
write_char_array(char[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL 字符数组中从 offset 处开始的 length 个元素写入输出流。
write_char_array(char[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 char 数组。
write_Context(Context, ContextList) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此流上写入一个 CORBA 上下文。
write_double(double) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL double 值写入输出流。
write_double(double) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 double 值写入此流。
write_double_array(double[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL double 数组中从 offset 处开始的 length 个元素写入输出流。
write_double_array(double[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输入流上写入一个 double 数组。
WRITE_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
WRITE_FAILURE 用于对输出流的写入失败时。
write_fixed(BigDecimal) - 类 org.omg.CORBA.portable.OutputStream 中的方法
写入一个 BigDecimal 数。
write_float(float) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL float 值写入输出流。
write_float(float) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 float 值写入此流。
write_float_array(float[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL float 数组中从 offset 处开始的 length 个元素写入输出流。
write_float_array(float[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输入流上写入一个 float 数组。
write_long(int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL long 值（以 Java int 的形式表示）写入输出流。
write_long(int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 CORBA long（即 Java int）值写入此流。
write_long_array(int[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL long 数组中从 offset 处开始的 length 个元素写入输出流。
write_long_array(int[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 CORBA long（即 Java int）数组。
write_longlong(long) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL long long 值（以 Java long 的形式表示）写入输出流。
write_longlong(long) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 CORBA longlong（即 Java long）值写入此流。
write_longlong_array(long[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL long long 数组中从 offset 处开始的 length 个元素写入输出流。
write_longlong_array(long[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 CORBA longlong（即 Java int）数组。
write_Object(Object) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL CORBA::Object 值写入输出流。
write_Object(Object) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输入流上写入一个 CORBA Object。
write_octet(byte) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL octet 值（以一个 Java 字节的形式表示）写入输出流。
write_octet(byte) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 CORBA 八位组（即字节）写入此流。
write_octet_array(byte[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL octet 数组中从 offset 处开始的 length 个元素写入输出流。
write_octet_array(byte[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 CORBA 八位组 (byte) 数组。
write_Principal(Principal) - 类 org.omg.CORBA.portable.OutputStream 中的方法
已过时。 已由 CORBA 2.2 取代。
write_short(short) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL short 值写入输出流。
write_short(short) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 short 值写入此流。
write_short_array(short[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL short 数组中从 offset 处开始的 length 个元素写入输出流。
write_short_array(short[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 short 数组。
write_string(String) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL string 值写入输出流。
write_string(String) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 string 值写入此流。
write_TypeCode(TypeCode) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 typecode 写入输出流。
write_TypeCode(TypeCode) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 TypeCode。
write_ulong(int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL long 值（以 Java int 的形式表示）写入输出流。
write_ulong(int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个无符号 CORBA long（即 Java int）值写入此流。
write_ulong_array(int[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL long 数组中从 offset 处开始的 length 个元素（以 Java int 的形式表示）写入输出流。
write_ulong_array(int[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个无符号 CORBA long（即 Java int）数组。
write_ulonglong(long) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL long long 值（以 Java long 的形式表示）写入输出流。
write_ulonglong(long) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个无符号 CORBA longlong（即 Java long）值写入此流。
write_ulonglong_array(long[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL long long 数组中从 offset 处开始的 length 个元素（以 Java long 的形式表示）写入输出流。
write_ulonglong_array(long[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个无符号 CORBA longlong（即 Java int）数组。
write_ushort(short) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL short 值（以 Java short 值的形式表示）写入输出流。
write_ushort(short) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个无符号 short 值写入此流。
write_ushort_array(short[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL short 数组中从 offset 处开始的 length 个元素（以 Java short 的形式表示）写入输出流。
write_ushort_array(short[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个无符号 short 数组。
write_value(OutputStream) - 类 org.omg.CORBA.Any 中的方法
将此 Any 对象的值写出到给定输出流。
write_Value(Serializable) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL value 类型值写入输出流。
write_value(OutputStream, Serializable) - 接口 org.omg.CORBA.portable.BoxedValueHelper 中的方法
write_value(OutputStream, Serializable) - 类 org.omg.CORBA.StringValueHelper 中的方法
write_value(OutputStream, Serializable) - 类 org.omg.CORBA.WStringValueHelper 中的方法
write_value(Serializable) - 类 org.omg.CORBA_2_3.portable.OutputStream 中的方法
将值类型编组到输出流中。
write_value(Serializable, Class) - 类 org.omg.CORBA_2_3.portable.OutputStream 中的方法
将值类型编组到输出流中。
write_value(Serializable, String) - 类 org.omg.CORBA_2_3.portable.OutputStream 中的方法
将值类型编组到输出流中。
write_value(Serializable, BoxedValueHelper) - 类 org.omg.CORBA_2_3.portable.OutputStream 中的方法
将值类型编组到输出流中。
write_wchar(char) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL 宽字符值写入输出流。
write_wchar(char) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 wide char 值写入此流。
write_wchar_array(char[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL 宽字符数组中从 offset 处开始的 length 个元素写入输出流。
write_wchar_array(char[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 wide char 数组。
write_wstring(String) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL 宽字符串值（以 Java String 的形式表示）写入输出流。
write_wstring(String) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 wide string 值写入此流。
WRITE_XML_DECLARATION - 类 javax.xml.soap.SOAPMessage 中的静态变量
指定 SOAP Message 在发送时是否包含 XML 声明。
writeAborted(ImageWriter) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告已通过 writer 的 abort 方法中止写操作。
WriteAbortedException - java.io 中的 异常
在写入操作过程中抛出 ObjectStreamException 之一的信号。
WriteAbortedException(String, Exception) - 异常 java.io.WriteAbortedException 的构造方法
使用描述该异常的字符串和导致中止的异常构造一个 WriteAbortedException。
writeAbstractObject(OutputStream, Object) - 类 javax.rmi.CORBA.Util 中的静态方法
将 java.lang.Object 作为一个值或 CORBA Object 写入。
writeAbstractObject(OutputStream, Object) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
writeAny(OutputStream, Object) - 类 javax.rmi.CORBA.Util 中的静态方法
将 any java.lang.Object 作为 CORBA any 写入。
writeAny(OutputStream, Object) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
writeArray(Array) - 接口 java.sql.SQLOutput 中的方法
将 SQL ARRAY 值写入流中。
writeArray(Array) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 Array 对象写入此 SQLOutputImpl 对象。
writeAsciiStream(InputStream) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 ASCII 字符流写入流中。
writeAsciiStream(InputStream) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 ASCII 字符流写入此 SQLOutputImpl 对象。
writeAsEncodedUnicode(Writer) - 接口 javax.xml.stream.events.XMLEvent 中的方法
此方法根据 XML 1.0 规范将 XMLEvent 编写为 Unicode 字符。
writeAttribute(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出流写入一个不带前缀的属性。
writeAttribute(String, String, String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出流写入一个属性
writeAttribute(String, String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出流写入一个属性
writeAttributes(AttributeSet) - 类 javax.swing.text.AbstractWriter 中的方法
以 " =" 对的形式写出属性集。
writeAttributes(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出属性集。
writeAttributes(AttributeSet) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出以下类型的所有属性：StyleConstants.ParagraphConstants、StyleConstants.CharacterConstants、StyleConstants.FontConstants、StyleConstants.ColorConstants。
writeAttributes(ObjectOutputStream, AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
写出属性的特定于上下文的处理。
writeAttributeSet(ObjectOutputStream, AttributeSet) - 类 javax.swing.text.StyleContext 中的静态方法
将属性集写入到给定的对象流以便序列化。
writeBigDecimal(BigDecimal) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 java.math.BigDecimal 对象写入流中。
writeBigDecimal(BigDecimal) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 java.math.BigDecimal 对象写入此 SQLOutputImpl 对象。
writeBinaryStream(InputStream) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为未解释字节流写入流中。
writeBinaryStream(InputStream) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将未解释字节流写入此 SQLOutputImpl 对象。
writeBit(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将单个位（由参数的最低有效位给定）写入到流的当前字节位置中的当前位偏移量。
writeBit(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeBits(long, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个位序列（由 bits 参数的 numBits 个最低有效位按从左到右的顺序给定）写入到流的当前字节位置中的当前位偏移量。
writeBits(long, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeBlob(Blob) - 接口 java.sql.SQLOutput 中的方法
将 SQL BLOB 值写入流中。
writeBlob(Blob) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 Blob 对象写入此 SQLOutputImpl 对象。
writeBody() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
对文档中的元素进行迭代，并基于元素是分支元素还是叶元素来处理它们。
writeBoolean(boolean) - 接口 java.io.DataOutput 中的方法
将一个 boolean 值写入输出流。
writeBoolean(boolean) - 类 java.io.DataOutputStream 中的方法
将一个 boolean 值以 1-byte 值形式写入基础输出流。
writeBoolean(boolean) - 类 java.io.ObjectOutputStream 中的方法
写入一个 boolean 值。
writeBoolean(boolean) - 类 java.io.RandomAccessFile 中的方法
按单字节值将 boolean 写入该文件。
writeBoolean(boolean) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java boolean 值写入流。
writeBoolean(boolean) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个 boolean 值写入到流中。
writeBoolean(boolean) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeBoolean(boolean) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 boolean 写入此 SQLOutputImpl 对象。
writeByte(int) - 接口 java.io.DataOutput 中的方法
将参数 v 的八个低位写入输出流。
writeByte(int) - 类 java.io.DataOutputStream 中的方法
将一个 byte 值以 1-byte 值形式写出到基础输出流中。
writeByte(int) - 类 java.io.ObjectOutputStream 中的方法
写入一个 8 位字节。
writeByte(int) - 类 java.io.RandomAccessFile 中的方法
按单字节值将 byte 写入该文件。
writeByte(byte) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java byte 值写入流中。
writeByte(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 v 的 8 个低位写入到流中。
writeByte(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeByte(byte) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 byte 写入此 SQLOutputImpl 对象。
writeBytes(String) - 接口 java.io.DataOutput 中的方法
将一个字符串写入输出流。
writeBytes(String) - 类 java.io.DataOutputStream 中的方法
将字符串按字节顺序写出到基础输出流中。
writeBytes(String) - 类 java.io.ObjectOutputStream 中的方法
以字节序列形式写入一个 String。
writeBytes(String) - 类 java.io.RandomAccessFile 中的方法
按字节序列将该字符串写入该文件。
writeBytes(byte[]) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为字节数组写入流中。
writeBytes(String) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个字符串写入输出流。
writeBytes(String) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeBytes(byte[]) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 byte 数组写入此 SQLOutputImpl 对象。
writeCData(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写 CData 节
writeChar(int) - 接口 java.io.DataOutput 中的方法
将一个 char 值写入输出流，该值由两个字节组成。
writeChar(int) - 类 java.io.DataOutputStream 中的方法
将一个 char 值以 2-byte 值形式写入基础输出流中，先写入高字节。
writeChar(int) - 类 java.io.ObjectOutputStream 中的方法
写入一个 16 位的 char 值。
writeChar(int) - 类 java.io.RandomAccessFile 中的方法
按双字节值将 char 写入该文件，先写高字节。
writeChar(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
此方法与 writeShort 同义。
writeChar(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeCharacters(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入文本
writeCharacters(char[], int, int) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入文本
writeCharacterStream(Reader) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Unicode 字符的流写入流中。
writeCharacterStream(Reader) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Unicode 字符流写入此 SQLOutputImpl 对象。
writeChars(String) - 接口 java.io.DataOutput 中的方法
将字符串 s 中的所有字符按顺序写入输出流，每个字符用两个字节表示。
writeChars(String) - 类 java.io.DataOutputStream 中的方法
将字符串按字符顺序写入基础输出流。
writeChars(String) - 类 java.io.ObjectOutputStream 中的方法
以 char 序列形式写入一个 String。
writeChars(String) - 类 java.io.RandomAccessFile 中的方法
按字符序列将一个字符串写入该文件。
writeChars(String) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个字符串写入输出流。
writeChars(char[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 char 序列写入到流中的当前位置。
writeChars(String) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeChars(char[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeChildren(ObjectOutputStream) - 类 java.beans.beancontext.BeanContextSupport 中的方法
用于序列化此 BeanContext 的所有子级。
writeClassDescriptor(ObjectStreamClass) - 类 java.io.ObjectOutputStream 中的方法
将指定的类描述符写入 ObjectOutputStream。
writeClob(Clob) - 接口 java.sql.SQLOutput 中的方法
将 SQL CLOB 值写入流中。
writeClob(Clob) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 Clob 对象写入此 SQLOutputImpl 对象。
writeComment(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写一个包含数据的 XML 注释
writeComponent(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
负责处理 Component Elements；有意不实现它。
writeContent(Element, boolean) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
以与 HTML 兼容的方式写出属性集。
writeData(RowSetInternal) - 接口 javax.sql.RowSetWriter 中的方法
将此 RowSetWriter 对象的 rowset 中的更改写回它从中获取数据的数据源。
writeDate(Date) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 java.sql.Date 对象写入流中。
writeDate(Date) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 java.sql.Date 对象写入此 SQLOutputImpl 对象。
writeDefaultNamespace(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向流写入默认名称空间
writeDouble(double) - 接口 java.io.DataOutput 中的方法
将一个 double 值写入输出流，该值由八个字节组成。
writeDouble(double) - 类 java.io.DataOutputStream 中的方法
使用 Double 类中的 doubleToLongBits 方法将 double 参数转换为一个 long 值，然后将该 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。
writeDouble(double) - 类 java.io.ObjectOutputStream 中的方法
写入一个 64 位的 double 值。
writeDouble(double) - 类 java.io.RandomAccessFile 中的方法
使用 Double 类中的 doubleToLongBits 方法将双精度参数转换为一个 long，然后按八字节数量将该 long 值写入该文件，先定高字节。
writeDouble(double) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java double 值写入流中。
writeDouble(double) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个 double 值写入输出流，该值由四个字节组成。
writeDouble(double) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeDouble(double) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 double 写入此 SQLOutputImpl 对象。
writeDoubles(double[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 double 序列写入到流中的当前位置。
writeDoubles(double[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeDTD(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写 DTD 节。
writeEmbeddedTags(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
搜索 AttributeSet 中的嵌入式标记并写出它们。
writeEmptyElement(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个空元素标记
writeEmptyElement(String, String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个空元素标记
writeEmptyElement(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个空元素标记
writeEndDocument() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
关闭所有开始标记并写入相应的结束标记。
writeEndElement() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向依赖于 writer 内部状态的输出写入一个结束标记，以此确定事件的前缀和本地名称。
writeEndParagraph() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
发出 <p> 标记的结束标记。
writeEndTag(String) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出适当缩进的结束标记。
writeEntityRef(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写一个实体引用
writeExpression(Expression) - 类 java.beans.Encoder 中的方法
该实现首先查看使用此值的表达式是否已经被写入。
writeExpression(Expression) - 类 java.beans.XMLEncoder 中的方法
记录 Expression，以便 Encoder 在刷新流的缓存时产生实际输出。
writeExternal(ObjectOutput) - 类 java.awt.datatransfer.DataFlavor 中的方法
序列化此 DataFlavor。
writeExternal(ObjectOutput) - 接口 java.io.Externalizable 中的方法
该对象可实现 writeExternal 方法来保存其内容，它可以通过调用 DataOutput 的方法来保存其基本值，或调用 ObjectOutput 的 writeObject 方法来保存对象、字符串和数组。
writeExternal(ObjectOutput) - 类 javax.activation.MimeType 中的方法
对象可实现 writeExternal 方法来保存其内容：对于其基本值，调用 DataOutput 的方法；对于对象、字符串和数组，调用 ObjectOutput 的 writeObject 方法。
writeExternal(ObjectOutput) - 类 javax.management.loading.MLet 中的方法
将此 MLet 的内容保存到给定的 ObjectOutput。
writeFields() - 类 java.io.ObjectOutputStream 中的方法
将已缓冲的字段写入流中。
writeFloat(float) - 接口 java.io.DataOutput 中的方法
将一个 float 值写入输出流，该值由四个字节组成。
writeFloat(float) - 类 java.io.DataOutputStream 中的方法
使用 Float 类中的 floatToIntBits 方法将 float 参数转换为一个 int 值，然后将该 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。
writeFloat(float) - 类 java.io.ObjectOutputStream 中的方法
写入一个 32 位的 float 值。
writeFloat(float) - 类 java.io.RandomAccessFile 中的方法
使用 Float 类中的 floatToIntBits 方法将浮点参数转换为一个 int，然后按四字节数量将该 int 值写入该文件，先写高字节。
writeFloat(float) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java float 值写入流中。
writeFloat(float) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个 float 值（由四个字节组成）写入输出流。
writeFloat(float) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeFloat(float) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 float 写入此 SQLOutputImpl 对象。
writeFloats(float[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 float 序列写入到流中的当前位置。
writeFloats(float[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeHeader() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出 <head> 和 <style> 标记，然后调用 writeStyles()，以写出所有命名的样式，这些样式作为 <style> 标记的内容。
writeHTMLTags(AttributeSet) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
基于文本的属性设置生成文本的 bold <b>、italic <i> 和 <u> 标记。
writeImage(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
负责处理 Icon Elements；有意不实现它。
writeInsert(int, IIOImage, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
将新的图像插入现有图像流。
writeInt(int) - 接口 java.io.DataOutput 中的方法
将一个 int 值写入输出流，该值由四个字节组成。
writeInt(int) - 类 java.io.DataOutputStream 中的方法
将一个 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。
writeInt(int) - 类 java.io.ObjectOutputStream 中的方法
写入一个 32 位的 int 值。
writeInt(int) - 类 java.io.RandomAccessFile 中的方法
按四个字节将 int 写入该文件，先写高字节。
writeInt(int) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java int 值写入流中。
writeInt(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 v 的 32 个位写入到流中。
writeInt(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeInt(int) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 int 写入此 SQLOutputImpl 对象。
writeInts(int[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 int 序列写入到流中的当前位置。
writeInts(int[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeLeaf(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
负责写出其他非文本叶元素。
writeLineSeparator() - 类 javax.swing.text.AbstractWriter 中的方法
写入行分隔符。
writeLineSeparator() - 类 javax.swing.text.html.HTMLWriter 中的方法
写出行分隔符。
writeLock() - 接口 java.util.concurrent.locks.ReadWriteLock 中的方法
返回用于写入操作的锁。
writeLock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
writeLock() - 类 javax.swing.text.AbstractDocument 中的方法
获取一个锁定，以开始改变此锁定保护的文档。
writeLong(long) - 接口 java.io.DataOutput 中的方法
将一个 long 值写入输出流，该值由八个字节组成。
writeLong(long) - 类 java.io.DataOutputStream 中的方法
将一个 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。
writeLong(long) - 类 java.io.ObjectOutputStream 中的方法
写入一个 64 位的 long 值。
writeLong(long) - 类 java.io.RandomAccessFile 中的方法
按八个字节将 long 写入该文件，先写高字节。
writeLong(long) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java long 值写入流中。
writeLong(long) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 v 的 64 个位写入到流中。
writeLong(long) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeLong(long) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 long 写入此 SQLOutputImpl 对象。
writeLongs(long[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 long 序列写入到流中的当前位置。
writeLongs(long[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeNamespace(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出流写入一个名称空间。
writeNClob(NClob) - 接口 java.sql.SQLOutput 中的方法
将 SQL NCLOB 值写入流中。
writeNClob(NClob) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 SQL NCLOB 值写入流中。
writeNonHTMLAttributes(AttributeSet) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
以与 HTML 兼容的方式写出其余的字符级属性（bold、italic 和 underline 之外的属性）。
writeNString(String) - 接口 java.sql.SQLOutput 中的方法
将下一个属性以 Java 编程语言中 String 的形式写入流中。
writeNString(String) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将下一个属性以 Java 编程语言中 String 的形式写入流中。
writeObject(Object) - 类 java.beans.Encoder 中的方法
将指定对象写入输出流中。
writeObject(Object, Encoder) - 类 java.beans.PersistenceDelegate 中的方法
writeObject 是持久性的一个入口点，由传统委托模式中的 Encoder 使用。
writeObject(Object) - 类 java.beans.XMLEncoder 中的方法
将指定对象的 XML 表示形式写入输出中。
writeObject(Object) - 接口 java.io.ObjectOutput 中的方法
将对象写入底层存储或流。
writeObject(Object) - 类 java.io.ObjectOutputStream 中的方法
将指定的对象写入 ObjectOutputStream。
writeObject(SQLData) - 接口 java.sql.SQLOutput 中的方法
将给定 SQLData 对象中包含的数据写入流中。
writeObject(Stub, ObjectOutputStream) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.writeObject(java.io.ObjectOutputStream) 的委托调用。
writeObject(SQLData) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将包含在给定 SQLData 对象中的数据写入流中。
writeObjectOverride(Object) - 类 java.io.ObjectOutputStream 中的方法
子类用于重写默认 writeObject 方法的方法。
writeOption(Option) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出 Option 表单元素的内容。
writeProcessingInstruction(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写一条处理指令
writeProcessingInstruction(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写一条处理指令
writer() - 类 java.io.Console 中的方法
获取与此控制台关联的唯一 PrintWriter 对象。
Writer - java.io 中的 类
写入字符流的抽象类。
Writer() - 类 java.io.Writer 的构造方法
创建一个新的字符流 writer，其关键部分将同步 writer 自身。
Writer(Object) - 类 java.io.Writer 的构造方法
创建一个新的字符流 writer，其关键部分将同步给定的对象。
writer - 类 javax.script.SimpleScriptContext 中的变量
此字段是用于脚本输出的 writer。
writeRef(Ref) - 接口 java.sql.SQLOutput 中的方法
将 SQL REF 值写入流中。
writeRef(Ref) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 Ref 对象写入此 SQLOutputImpl 对象。
writeRemoteObject(OutputStream, Object) - 类 javax.rmi.CORBA.Util 中的静态方法
将 java.lang.Object 作为 CORBA Object 写入。
writeRemoteObject(OutputStream, Object) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
writeReplace() - 类 java.security.cert.Certificate 中的方法
替换要被序列化的 Certificate。
writeReplace() - 类 java.security.cert.CertPath 中的方法
使用 CertPathRep 对象替换要被序列化的 CertPath。
writeReplace(Serializable) - 接口 javax.rmi.CORBA.ValueHandler 中的方法
如果该值包含 writeReplace 方法，则返回该结果。
writeRowId(RowId) - 接口 java.sql.SQLOutput 中的方法
将 SQL ROWID 值写入流中。
writeRowId(RowId) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 SQL ROWID 值写入流中。
writerSpiNames - 类 javax.imageio.spi.ImageReaderSpi 中的变量
将从 getImageWriterSpiNames 返回的字符串数组，该数组最初为 null。
writeShort(int) - 接口 java.io.DataOutput 中的方法
将两个字节写入输出流，用它们表示参数值。
writeShort(int) - 类 java.io.DataOutputStream 中的方法
将一个 short 值以 2-byte 值形式写入基础输出流中，先写入高字节。
writeShort(int) - 类 java.io.ObjectOutputStream 中的方法
写入一个 16 位的 short 值。
writeShort(int) - 类 java.io.RandomAccessFile 中的方法
按两个字节将 short 写入该文件，先写高字节。
writeShort(short) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java short 值写入流中。
writeShort(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 v 的 16 个低位写入到流中。
writeShort(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeShort(short) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 short 写入此 SQLOutputImpl 对象。
writeShorts(short[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 short 序列写入到流中的当前位置。
writeShorts(short[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeSQL(SQLOutput) - 接口 java.sql.SQLData 中的方法
将此对象写入给定的 SQL 数据流，同时将其转换回数据源中它的 SQL 值。
writeSQLXML(SQLXML) - 接口 java.sql.SQLOutput 中的方法
将 SQL XML 值写入流中。
writeSQLXML(SQLXML) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 SQL XML 值写入流中。
writeStartDocument() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写 XML 声明。
writeStartDocument(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写 XML 声明。
writeStartDocument(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写 XML 声明。
writeStartElement(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个开始标记。
writeStartElement(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个开始标记
writeStartElement(String, String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个开始标记
writeStartParagraph(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
发出段落的开始标记。
writeStartTag(String) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出适当缩进的开始标记。
writeStatement(Statement) - 类 java.beans.Encoder 中的方法
将语句 oldStm 写入流中。
writeStatement(Statement) - 类 java.beans.XMLEncoder 中的方法
记录 Statement，以便 Encoder 在刷新流的缓存时产生实际输出。
writeStreamHeader() - 类 java.io.ObjectOutputStream 中的方法
提供 writeStreamHeader 方法，这样子类可以将其自身的头部添加或预加到流中。
writeString(String) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java 编程语言中的 String 写入流中。
writeString(String) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 String 写入此 SQLOutputImpl 对象。
writeStruct(Struct) - 接口 java.sql.SQLOutput 中的方法
将 SQL 结构类型值写入流中。
writeStruct(Struct) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 Struct 对象写入此 SQLOutputImpl 对象。
writeStyles() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出所有命名的样式，这些样式作为 <style> 标记的内容。
writeTime(Time) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 java.sql.Time 对象写入流中。
writeTime(Time) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 java.sql.Time 对象写入此 SQLOutputImpl 对象。
writeTimestamp(Timestamp) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 java.sql.Timestamp 对象写入流中。
writeTimestamp(Timestamp) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 java.sql.Timestamp 对象写入此 SQLOutputImpl 对象。
writeTo(OutputStream) - 类 java.io.ByteArrayOutputStream 中的方法
将此 byte 数组输出流的全部内容写入到指定的输出流参数中，这与使用 out.write(buf, 0, count) 调用该输出流的 write 方法效果一样。
writeTo(Writer) - 类 java.io.CharArrayWriter 中的方法
将缓冲区的内容写入另一个字符流。
writeTo(Object, String, OutputStream) - 接口 javax.activation.DataContentHandler 中的方法
将对象转换为指定 MIME 类型的字节流，并将其写入输出流。
writeTo(OutputStream) - 类 javax.activation.DataHandler 中的方法
将数据写入 OutputStream。
writeTo(OutputStream) - 类 javax.xml.soap.SOAPMessage 中的方法
将此 SOAPMessage 对象写入给定输出流。
writeToSequence(IIOImage, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
将单幅图像、可能相关的元数据和缩略图添加到输出中。
writeToString(Node) - 接口 org.w3c.dom.ls.LSSerializer 中的方法
像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
writeToURI(Node, String) - 接口 org.w3c.dom.ls.LSSerializer 中的方法
这是一种简便方法，其作用就像使用没有指定编码的 LSOutput 调用 LSSerializer.write，并且 LSOutput.systemId 被设置为 uri 参数。
writeUnlock() - 类 javax.swing.text.AbstractDocument 中的方法
释放以前通过 writeLock 所获得的写入锁定。
writeUnshared(Object) - 类 java.io.ObjectOutputStream 中的方法
将“未共享”对象写入 ObjectOutputStream。
writeURL(URL) - 接口 java.sql.SQLOutput 中的方法
将 SQL DATALINK 值写入流中。
writeURL(URL) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 java.sql.Type.DATALINK 对象写入此 SQLOutputImpl 对象。
writeUTF(String) - 接口 java.io.DataOutput 中的方法
将表示长度信息的两个字节写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。
writeUTF(String) - 类 java.io.DataOutputStream 中的方法
以与机器无关方式使用 UTF-8 修改版编码将一个字符串写入基础输出流。
writeUTF(String) - 类 java.io.ObjectOutputStream 中的方法
以 UTF-8 修改版格式写入此 String 的基本数据。
writeUTF(String) - 类 java.io.RandomAccessFile 中的方法
使用 modified UTF-8 编码以与机器无关的方式将一个字符串写入该文件。
writeUTF(String) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将表示长度信息的两个字节按网络字节顺序写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。
writeUTF(String) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeValue(OutputStream, Serializable) - 接口 javax.rmi.CORBA.ValueHandler 中的方法
使用 Java 语义将一个值写入流。
writeValue(OutputStream, Serializable, byte) - 接口 javax.rmi.CORBA.ValueHandlerMultiFormat 中的方法
允许 ORB 为 RMI/IDL 自定义值类型传递流格式版本。
writeXML(WebRowSet, Writer) - 接口 javax.sql.rowset.spi.XmlWriter 中的方法
将给定的 WebRowSet 对象以 XML 文档的形式编写到指定的 java.io.Writer 输出流。
writeXml(ResultSet, Writer) - 接口 javax.sql.rowset.WebRowSet 中的方法
使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 Writer 对象。
writeXml(ResultSet, OutputStream) - 接口 javax.sql.rowset.WebRowSet 中的方法
使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。
writeXml(Writer) - 接口 javax.sql.rowset.WebRowSet 中的方法
以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 Writer 对象。
writeXml(OutputStream) - 接口 javax.sql.rowset.WebRowSet 中的方法
以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 OutputStream 对象。
written - 类 java.io.DataOutputStream 中的变量
到目前为止写入数据输出流的字节数。
WRONG_DOCUMENT_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果 Node 用于不同的文档而不是创建它的文档（该文档不支持它）。
WrongAdapter - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/WrongAdapter.java。
WrongAdapter() - 异常 org.omg.PortableServer.POAPackage.WrongAdapter 的构造方法
WrongAdapter(String) - 异常 org.omg.PortableServer.POAPackage.WrongAdapter 的构造方法
WrongAdapterHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/WrongAdapterHelper.java。
WrongAdapterHelper() - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 的构造方法
WrongPolicy - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/WrongPolicy.java。
WrongPolicy() - 异常 org.omg.PortableServer.POAPackage.WrongPolicy 的构造方法
WrongPolicy(String) - 异常 org.omg.PortableServer.POAPackage.WrongPolicy 的构造方法
WrongPolicyHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/WrongPolicyHelper.java。
WrongPolicyHelper() - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 的构造方法
WrongTransaction - org.omg.CORBA 中的 异常
CORBA WrongTransaction 用户定义异常。
WrongTransaction() - 异常 org.omg.CORBA.WrongTransaction 的构造方法
使用空详细消息构造一个 WrongTransaction 对象。
WrongTransaction(String) - 异常 org.omg.CORBA.WrongTransaction 的构造方法
使用给定详细消息构造一个 WrongTransaction 对象。
WrongTransactionHelper - org.omg.CORBA 中的 类
WrongTransaction 的 Helper。
WrongTransactionHelper() - 类 org.omg.CORBA.WrongTransactionHelper 的构造方法
WrongTransactionHolder - org.omg.CORBA 中的 类
WrongTransaction 的 Holder。
WrongTransactionHolder() - 类 org.omg.CORBA.WrongTransactionHolder 的构造方法
WrongTransactionHolder(WrongTransaction) - 类 org.omg.CORBA.WrongTransactionHolder 的构造方法
WSDL_DESCRIPTION - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：WSDL 文档的输入源。
WSDL_INTERFACE - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：wsdl 接口 (2.0) 或端口类型 (1.1) 的名称。
WSDL_OPERATION - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：WSDL 操作的名称。
WSDL_PORT - 类 javax.xml.ws.Endpoint 中的静态变量
标准属性：WSDL 端口的名称。
WSDL_PORT - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：WSDL 端口的名称。
WSDL_SERVICE - 类 javax.xml.ws.Endpoint 中的静态变量
标准属性：WSDL 服务的名称。
WSDL_SERVICE - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：WSDL 服务的名称。
WStringSeqHelper - org.omg.CORBA 中的 类
WString 数组
WStringSeqHelper() - 类 org.omg.CORBA.WStringSeqHelper 的构造方法
WStringSeqHolder - org.omg.CORBA 中的 类
WString 数组
WStringSeqHolder() - 类 org.omg.CORBA.WStringSeqHolder 的构造方法
WStringSeqHolder(String[]) - 类 org.omg.CORBA.WStringSeqHolder 的构造方法
WStringValueHelper - org.omg.CORBA 中的 类
org/omg/CORBA/WStringValueHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 orb.idl 中生成，生成时间为 1999 年 5 月 31 日 22:27:30 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范： 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07) ptc/00-01-08 中定义的 IDL/Java 语言映射
WStringValueHelper() - 类 org.omg.CORBA.WStringValueHelper 的构造方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


X - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

X

x - 类 java.awt.Event 中的变量
事件的 x 坐标。
x - 类 java.awt.geom.Arc2D.Double 中的变量
弧的窗体矩形左上角的 X 坐标。
x - 类 java.awt.geom.Arc2D.Float 中的变量
弧的窗体矩形左上角的 X 坐标。
x - 类 java.awt.geom.Ellipse2D.Double 中的变量
此 Ellipse2D 的窗体矩形左上角的 X 坐标。
x - 类 java.awt.geom.Ellipse2D.Float 中的变量
此 Ellipse2D 窗体矩形左上角的 X 坐标。
x - 类 java.awt.geom.Point2D.Double 中的变量
此 Point2D 的 X 坐标。
x - 类 java.awt.geom.Point2D.Float 中的变量
此 Point2D 的 X 坐标。
x - 类 java.awt.geom.Rectangle2D.Double 中的变量
此 Rectangle2D 的 X 坐标。
x - 类 java.awt.geom.Rectangle2D.Float 中的变量
此 Rectangle2D 的 X 坐标。
x - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
此 RoundRectangle2D 的 X 坐标。
x - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
此 RoundRectangle2D 的 X 坐标。
x - 类 java.awt.Point 中的变量
此 Point 的 X 坐标。
x - 类 java.awt.Rectangle 中的变量
Rectangle 左上角的 X 坐标。
x1 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段起始点的 X 坐标。
x1 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段起始点的 X 坐标。
x1 - 类 java.awt.geom.Line2D.Double 中的变量
线段起始点的 X 坐标。
x1 - 类 java.awt.geom.Line2D.Float 中的变量
线段起始点的 X 坐标。
x1 - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段起始点的 X 坐标。
x1 - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段起始点的 X 坐标。
x2 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段结束点的 X 坐标。
x2 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段结束点的 X 坐标。
x2 - 类 java.awt.geom.Line2D.Double 中的变量
线段结束点的 X 坐标。
x2 - 类 java.awt.geom.Line2D.Float 中的变量
线段结束点的 X 坐标。
x2 - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段结束点的 X 坐标。
x2 - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段结束点的 X 坐标。
X500Principal - javax.security.auth.x500 中的 类
此类表示一个 X.500 Principal。
X500Principal(String) - 类 javax.security.auth.x500.X500Principal 的构造方法
根据 X.500 标识名（例："CN=Duke、 OU=JavaSoft、 O=Sun Microsystems、 C=US"）的字符串表示形式创建 X500Principal。
X500Principal(String, Map<String, String>) - 类 javax.security.auth.x500.X500Principal 的构造方法
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。
X500Principal(byte[]) - 类 javax.security.auth.x500.X500Principal 的构造方法
根据 ASN.1 DER 编码格式的标识名创建 X500Principal。
X500Principal(InputStream) - 类 javax.security.auth.x500.X500Principal 的构造方法
根据包含 ASN.1 DER 编码格式的标识名的 InputStream 创建 X500Principal。
X500PrivateCredential - javax.security.auth.x500 中的 类
此类表示一个 X500PrivateCredential。
X500PrivateCredential(X509Certificate, PrivateKey) - 类 javax.security.auth.x500.X500PrivateCredential 的构造方法
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。
X500PrivateCredential(X509Certificate, PrivateKey, String) - 类 javax.security.auth.x500.X500PrivateCredential 的构造方法
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。
X509Certificate - java.security.cert 中的 类
X.509 证书的抽象类。
X509Certificate() - 类 java.security.cert.X509Certificate 的构造方法
X.509 证书的构造方法。
X509Certificate - javax.security.cert 中的 类
X.509 v1 证书的抽象类。
X509Certificate() - 类 javax.security.cert.X509Certificate 的构造方法
X509CertSelector - java.security.cert 中的 类
选择与所有指定标准匹配的 X509Certificates 的 CertSelector。
X509CertSelector() - 类 java.security.cert.X509CertSelector 的构造方法
创建一个 X509CertSelector。
X509CRL - java.security.cert 中的 类
X.509 证书撤消列表 (CRL) 的抽象类。
X509CRL() - 类 java.security.cert.X509CRL 的构造方法
X.509 CRL 的构造方法。
X509CRLEntry - java.security.cert 中的 类
用于 CRL（证书撤消列表）中已撤消证书的抽象类。
X509CRLEntry() - 类 java.security.cert.X509CRLEntry 的构造方法
X509CRLSelector - java.security.cert 中的 类
选择与所有指定标准相匹配的 X509CRL 的 CRLSelector。
X509CRLSelector() - 类 java.security.cert.X509CRLSelector 的构造方法
创建一个 X509CRLSelector。
X509Data - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509Data 元素的表示形式。
X509EncodedKeySpec - java.security.spec 中的 类
此类表示根据 ASN.1 类型 SubjectPublicKeyInfo 进行编码的公用密钥的 ASN.1 编码。
X509EncodedKeySpec(byte[]) - 类 java.security.spec.X509EncodedKeySpec 的构造方法
根据给定的编码密钥创建一个新的 X509EncodedKeySpec。
X509ExtendedKeyManager - javax.net.ssl 中的 类
提供 X509KeyManager 接口的扩展的抽象类。
X509ExtendedKeyManager() - 类 javax.net.ssl.X509ExtendedKeyManager 的构造方法
仅供子类使用的构造方法。
X509Extension - java.security.cert 中的 接口
X.509 扩展的接口。
X509IssuerSerial - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509IssuerSerial 元素的表示形式。
X509KeyManager - javax.net.ssl 中的 接口
此接口的实例管理使用哪一个基于 X509 证书的密钥对来验证本地的安全套接字。
X509TrustManager - javax.net.ssl 中的 接口
此接口的实例管理使用哪一个 X509 证书来验证远端的安全套接字。
X_AXIS - 类 javax.swing.BoxLayout 中的静态变量
指定组件应该从左到右放置。
X_AXIS - 类 javax.swing.text.View 中的静态变量
用于格式化/拆分操作的轴。
XA_HEURCOM - 异常 javax.transaction.xa.XAException 中的静态变量
以启发式方式提交事务分支。
XA_HEURHAZ - 异常 javax.transaction.xa.XAException 中的静态变量
以启发式方式完成事务分支。
XA_HEURMIX - 异常 javax.transaction.xa.XAException 中的静态变量
以启发式方式提交并回滚事务分支。
XA_HEURRB - 异常 javax.transaction.xa.XAException 中的静态变量
以启发式方式回滚事务分支。
XA_NOMIGRATE - 异常 javax.transaction.xa.XAException 中的静态变量
必须在发生挂起的地方发生恢复。
XA_OK - 接口 javax.transaction.xa.XAResource 中的静态变量
事务工作正常准备就绪。
XA_RBBASE - 异常 javax.transaction.xa.XAException 中的静态变量
回滚代码包含的下边界。
XA_RBCOMMFAIL - 异常 javax.transaction.xa.XAException 中的静态变量
指示通讯失败导致该回滚。
XA_RBDEADLOCK - 异常 javax.transaction.xa.XAException 中的静态变量
检测死锁。
XA_RBEND - 异常 javax.transaction.xa.XAException 中的静态变量
回滚错误代码包含的上边界。
XA_RBINTEGRITY - 异常 javax.transaction.xa.XAException 中的静态变量
检测违反资源完整性的条件。
XA_RBOTHER - 异常 javax.transaction.xa.XAException 中的静态变量
由于一个不在此列表上的原因，资源管理器回滚事务分支。
XA_RBPROTO - 异常 javax.transaction.xa.XAException 中的静态变量
在资源管理器中发生协议错误。
XA_RBROLLBACK - 异常 javax.transaction.xa.XAException 中的静态变量
指示未指定的原因导致该回滚。
XA_RBTIMEOUT - 异常 javax.transaction.xa.XAException 中的静态变量
事务分支占用时间太长。
XA_RBTRANSIENT - 异常 javax.transaction.xa.XAException 中的静态变量
可以重试事务分支。
XA_RDONLY - 异常 javax.transaction.xa.XAException 中的静态变量
事务分支是只读的，并且已提交。
XA_RDONLY - 接口 javax.transaction.xa.XAResource 中的静态变量
事务分支是只读的，并且已提交。
XA_RETRY - 异常 javax.transaction.xa.XAException 中的静态变量
返回的例程无效，可以重新发布。
XAConnection - javax.sql 中的 接口
为分布式事务提供支持的对象。
XADataSource - javax.sql 中的 接口
在内部使用的 XAConnection 对象的工厂。
XAER_ASYNC - 异常 javax.transaction.xa.XAException 中的静态变量
已存在明显的异步操作。
XAER_DUPID - 异常 javax.transaction.xa.XAException 中的静态变量
XID 已存在。
XAER_INVAL - 异常 javax.transaction.xa.XAException 中的静态变量
提供了无效的参数。
XAER_NOTA - 异常 javax.transaction.xa.XAException 中的静态变量
XID 无效。
XAER_OUTSIDE - 异常 javax.transaction.xa.XAException 中的静态变量
资源管理器进行全局事务之外的工作。
XAER_PROTO - 异常 javax.transaction.xa.XAException 中的静态变量
在不合适的上下文中调用例程。
XAER_RMERR - 异常 javax.transaction.xa.XAException 中的静态变量
在事务分支中发生资源管理器错误。
XAER_RMFAIL - 异常 javax.transaction.xa.XAException 中的静态变量
资源管理器不可用。
XAException - javax.transaction.xa 中的 异常
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。
XAException() - 异常 javax.transaction.xa.XAException 的构造方法
创建一个 XAException。
XAException(String) - 异常 javax.transaction.xa.XAException 的构造方法
创建一个具有给定字符串的 XAException。
XAException(int) - 异常 javax.transaction.xa.XAException 的构造方法
创建一个具有给定错误代码的 XAException。
XAResource - javax.transaction.xa 中的 接口
XAResource 接口是基于 X/Open CAE 规范（分布式事务处理：XA 规范）的工业标准 XA 接口的 Java 映射。
Xid - javax.transaction.xa 中的 接口
Xid 接口是 X/Open 事务标识符 XID 结构的 Java 映射。
XML_DTD_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
作为属性值的 XML 文档类型声明名称空间 URI。
XML_NS_PREFIX - 类 javax.xml.XMLConstants 中的静态变量
正式的 XML 名称空间前缀。
XML_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
正式的 XML 名称空间名称 URI。
XmlAccessOrder - javax.xml.bind.annotation 中的 枚举
由 XmlAccessorOrder 使用，用于控制 JAXB 绑定类中属性和字段的排序。
XmlAccessorOrder - javax.xml.bind.annotation 中的 注释类型
控制类中字段和属性的排序。
XmlAccessorType - javax.xml.bind.annotation 中的 注释类型
控制默认情况下是否对字段或 Javabean 属性进行系列化。
XmlAccessType - javax.xml.bind.annotation 中的 枚举
由 XmlAccessorType 使用，用于控制字段或属性的序列化。
XmlAdapter<ValueType,BoundType> - javax.xml.bind.annotation.adapters 中的 类
修改 Java 类型以适应自定义编组。
XmlAdapter() - 类 javax.xml.bind.annotation.adapters.XmlAdapter 的构造方法
派生类的构造方法，不执行任何操作。
XmlAnyAttribute - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到通配符属性的映射表中。
XmlAnyElement - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到 XML 信息集表示形式和/或 JAXB 元素。
XmlAttachmentRef - javax.xml.bind.annotation 中的 注释类型
标记字段/属性，其 XML 形式是对 MIME 内容的 URI 引用。
XmlAttribute - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到 XML 属性。
XMLConstants - javax.xml 中的 类
包含基本 XML 值作为常量的实用工具类。
XMLCryptoContext - javax.xml.crypto 中的 接口
包含用于 XML 加密操作的通用上下文信息。
XMLDecoder - java.beans 中的 类
XMLDecoder 类用于读取使用 XMLEncoder 创建的 XML 文档，用途类似于 ObjectInputStream。
XMLDecoder(InputStream) - 类 java.beans.XMLDecoder 的构造方法
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream, Object) - 类 java.beans.XMLDecoder 的构造方法
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream, Object, ExceptionListener) - 类 java.beans.XMLDecoder 的构造方法
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream, Object, ExceptionListener, ClassLoader) - 类 java.beans.XMLDecoder 的构造方法
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XmlElement - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到派生于属性名称的 XML 元素。
XmlElement.DEFAULT - javax.xml.bind.annotation 中的 类
在 XmlElement.type() 中使用，用于表示根据属性签名推断出来的类型。
XmlElement.DEFAULT() - 类 javax.xml.bind.annotation.XmlElement.DEFAULT 的构造方法
XmlElementDecl - javax.xml.bind.annotation 中的 注释类型
将工厂方法映射到 XML 元素。
XmlElementDecl.GLOBAL - javax.xml.bind.annotation 中的 类
在 XmlElementDecl.scope() 中使用，指示声明是全局范围的。
XmlElementDecl.GLOBAL() - 类 javax.xml.bind.annotation.XmlElementDecl.GLOBAL 的构造方法
XmlElementRef - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到派生于属性类型的 XML 元素。
XmlElementRef.DEFAULT - javax.xml.bind.annotation 中的 类
在 XmlElementRef.type() 中使用，用于表示根据属性签名推断出来的类型。
XmlElementRef.DEFAULT() - 类 javax.xml.bind.annotation.XmlElementRef.DEFAULT 的构造方法
XmlElementRefs - javax.xml.bind.annotation 中的 注释类型
标记一个属性，该属性引用带有 XmlElement 或 JAXBElement 的类。
XmlElements - javax.xml.bind.annotation 中的 注释类型
多个 @XmlElement 注释的容器。
XmlElementWrapper - javax.xml.bind.annotation 中的 注释类型
生成一个包装 XML 表示形式的包装器元素。
XMLEncoder - java.beans 中的 类
XMLEncoder 类是 ObjectOutputStream 的互补替换，可用于生成 JavaBean 的文本表示形式，所使用方式与用 ObjectOutputStream 创建 Serializable 对象的二进制表示形式的方式相同。
XMLEncoder(OutputStream) - 类 java.beans.XMLEncoder 的构造方法
使用 XML 编码创建一个新的输出流，将 JavaBeans 发送给流 out。
XmlEnum - javax.xml.bind.annotation 中的 注释类型
将枚举类型 Enum 映射到 XML 表示形式。
XmlEnumValue - javax.xml.bind.annotation 中的 注释类型
将 Enum 类型中的枚举常量映射到 XML 表示形式。
XMLEvent - javax.xml.stream.events 中的 接口
处理标记事件的基础事件接口。
XMLEventAllocator - javax.xml.stream.util 中的 接口
此接口定义了一个类，该类允许用户注册给定 XMLStreamReader 的情况下分配事件的方式。
XMLEventConsumer - javax.xml.stream.util 中的 接口
此接口定义了一个事件使用者接口。
XMLEventFactory - javax.xml.stream 中的 类
此接口定义一个创建 XMLEvent 实例的实用工具类。
XMLEventFactory() - 类 javax.xml.stream.XMLEventFactory 的构造方法
XMLEventReader - javax.xml.stream 中的 接口
此类是用于解析 XML 事件的顶层接口。
XMLEventWriter - javax.xml.stream 中的 接口
此类是用于编写 XML 文档的顶层接口。
XMLFilter - org.xml.sax 中的 接口
用于 XML 过滤器的接口。
XMLFilterImpl - org.xml.sax.helpers 中的 类
派生 XML 过滤器的基类。
XMLFilterImpl() - 类 org.xml.sax.helpers.XMLFilterImpl 的构造方法
构造一个不带父过滤器的空 XML 过滤器。
XMLFilterImpl(XMLReader) - 类 org.xml.sax.helpers.XMLFilterImpl 的构造方法
构造一个带有特定父过滤器的 XML 过滤器。
XMLFormatter - java.util.logging 中的 类
将 LogRecord 格式化为标准 XML 格式。
XMLFormatter() - 类 java.util.logging.XMLFormatter 的构造方法
XMLGregorianCalendar - javax.xml.datatype 中的 类
W3C XML 模式 1.0 日期/时间数据类型的表示形式。
XMLGregorianCalendar() - 类 javax.xml.datatype.XMLGregorianCalendar 的构造方法
默认的无参数构造方法。
XmlID - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到 XML ID。
XmlIDREF - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到 XML IDREF。
XmlInlineBinaryData - javax.xml.bind.annotation 中的 注释类型
禁止对绑定到 XML 中 base64-encoded 二进制数据的数据类型进行 XOP 编码。
XMLInputFactory - javax.xml.stream 中的 类
定义用于获取流的工厂的抽象实现。
XMLInputFactory() - 类 javax.xml.stream.XMLInputFactory 的构造方法
XmlJavaTypeAdapter - javax.xml.bind.annotation.adapters 中的 注释类型
对自定义编组使用实现 XmlAdapter 的适配器。
XmlJavaTypeAdapter.DEFAULT - javax.xml.bind.annotation.adapters 中的 类
此类在 XmlJavaTypeAdapter.type() 中使用，用来表示从字段、属性、参数或类的签名推导出的类型。
XmlJavaTypeAdapter.DEFAULT() - 类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT 的构造方法
XmlJavaTypeAdapters - javax.xml.bind.annotation.adapters 中的 注释类型
多个 @XmlJavaTypeAdapter 注释的容器。
XmlList - javax.xml.bind.annotation 中的 注释类型
用来将属性映射到列表简单类型。
XmlMimeType - javax.xml.bind.annotation 中的 注释类型
关联控制属性 XML 表示形式的 MIME 类型。
XmlMixed - javax.xml.bind.annotation 中的 注释类型
注释 JavaBean 多值属性，以支持混合内容。
XmlNs - javax.xml.bind.annotation 中的 注释类型
关联名称空间前缀与 XML 名称空间 URI。
XMLNS - 接口 javax.xml.crypto.dsig.XMLSignature 中的静态变量
W3C Recommendation for XML-Signature Syntax and Processing 的 XML 名称空间 URI。
XMLNS - 类 org.xml.sax.helpers.NamespaceSupport 中的静态变量
作为常量的 XML 名称空间 URI。
XMLNS_ATTRIBUTE - 类 javax.xml.XMLConstants 中的静态变量
用于指定 XML 名称空间声明的正式 XML 属性。
XMLNS_ATTRIBUTE_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
用于指定 XML 名称空间声明、XMLConstants.XMLNS_ATTRIBUTE、名称空间名称 URI 的正式 XML 属性。
XmlNsForm - javax.xml.bind.annotation 中的 枚举
XML 模式名称空间限定的枚举。
XMLObject - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Object 元素的表示形式。
XMLOutputFactory - javax.xml.stream 中的 类
定义用于获取 XMLEventWriter 和 XMLStreamWriter 的工厂抽象实现。
XMLOutputFactory() - 类 javax.xml.stream.XMLOutputFactory 的构造方法
XMLParseException - javax.management.modelmbean 中的 异常
当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。
XMLParseException() - 异常 javax.management.modelmbean.XMLParseException 的构造方法
默认构造方法。
XMLParseException(String) - 异常 javax.management.modelmbean.XMLParseException 的构造方法
带有字符串的构造方法。
XMLParseException(Exception, String) - 异常 javax.management.modelmbean.XMLParseException 的构造方法
带有字符串和异常的构造方法。
XmlReader - javax.sql.rowset.spi 中的 接口
一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。
XMLReader - org.xml.sax 中的 接口
用于使用回调读取 XML 文档的接口。
XMLReaderAdapter - org.xml.sax.helpers 中的 类
将 SAX2 XMLReader 适配为 SAX1 解析器。
XMLReaderAdapter() - 类 org.xml.sax.helpers.XMLReaderAdapter 的构造方法
创建一个新的适配器。
XMLReaderAdapter(XMLReader) - 类 org.xml.sax.helpers.XMLReaderAdapter 的构造方法
创建一个新的适配器。
XMLReaderFactory - org.xml.sax.helpers 中的 类
创建 XML 阅读器的工厂。
XmlRegistry - javax.xml.bind.annotation 中的 注释类型
标记具有 XmlElementDecl 的类。
XMLReporter - javax.xml.stream 中的 接口
此接口用于报告非严重错误。
XMLResolver - javax.xml.stream 中的 接口
此接口用于在 XML 解析过程中解析资源。
XmlRootElement - javax.xml.bind.annotation 中的 注释类型
将类或枚举类型映射到 XML 元素。
XmlSchema - javax.xml.bind.annotation 中的 注释类型
将包名称映射到 XML 名称空间。
XmlSchemaType - javax.xml.bind.annotation 中的 注释类型
将 Java 类型映射到一个简单的模式内置类型。
XmlSchemaType.DEFAULT - javax.xml.bind.annotation 中的 类
在 XmlSchemaType.type() 中使用，用于表示根据属性签名推断出来的类型。
XmlSchemaType.DEFAULT() - 类 javax.xml.bind.annotation.XmlSchemaType.DEFAULT 的构造方法
XmlSchemaTypes - javax.xml.bind.annotation 中的 注释类型
多个 @XmlSchemaType 注释的容器。
XMLSignature - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Signature 元素的表示形式。
XMLSignature.SignatureValue - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureValue 元素的表示形式。
XMLSignatureException - javax.xml.crypto.dsig 中的 异常
指示生成或验证 XML 签名过程中发生的异常条件。
XMLSignatureException() - 异常 javax.xml.crypto.dsig.XMLSignatureException 的构造方法
构造用 null 作为其详细消息的新 XMLSignatureException。
XMLSignatureException(String) - 异常 javax.xml.crypto.dsig.XMLSignatureException 的构造方法
构造带指定详细消息的新 XMLSignatureException。
XMLSignatureException(String, Throwable) - 异常 javax.xml.crypto.dsig.XMLSignatureException 的构造方法
构造一个带指定详细消息和 cause 的新 XMLSignatureException。
XMLSignatureException(Throwable) - 异常 javax.xml.crypto.dsig.XMLSignatureException 的构造方法
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 XMLSignatureException（它通常包含 cause 的类和详细消息）。
XMLSignatureFactory - javax.xml.crypto.dsig 中的 类
用于从头创建 XMLSignature 对象或从相应的 XML 表示形式解组 XMLSignature 对象的工厂。
XMLSignatureFactory() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 的构造方法
默认的构造方法，由子类调用。
XMLSignContext - javax.xml.crypto.dsig 中的 接口
包含用于生成 XML Signature 的上下文信息。
XMLStreamConstants - javax.xml.stream 中的 接口
此接口声明此 API 中所使用的常量。
XMLStreamException - javax.xml.stream 中的 异常
用于不可预料处理错误的基本异常。
XMLStreamException() - 异常 javax.xml.stream.XMLStreamException 的构造方法
默认构造方法
XMLStreamException(String) - 异常 javax.xml.stream.XMLStreamException 的构造方法
构造具有关联消息的异常。
XMLStreamException(Throwable) - 异常 javax.xml.stream.XMLStreamException 的构造方法
构造具有关联异常的异常
XMLStreamException(String, Throwable) - 异常 javax.xml.stream.XMLStreamException 的构造方法
构造具有关联消息和异常的异常
XMLStreamException(String, Location, Throwable) - 异常 javax.xml.stream.XMLStreamException 的构造方法
构造具有关联消息、异常和位置的异常。
XMLStreamException(String, Location) - 异常 javax.xml.stream.XMLStreamException 的构造方法
构造具有关联消息、异常和位置的异常。
XMLStreamReader - javax.xml.stream 中的 接口
XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。
XMLStreamWriter - javax.xml.stream 中的 接口
XMLStreamWriter 接口指定如何编写 XML。
XMLStructure - javax.xml.crypto 中的 接口
任何名称空间的 XML 结构的表示形式。
XmlTransient - javax.xml.bind.annotation 中的 注释类型
阻止将 JavaBean 属性映射到 XML 表示形式。
XmlType - javax.xml.bind.annotation 中的 注释类型
将类或枚举类型映射到 XML 模式类型。
XmlType.DEFAULT - javax.xml.bind.annotation 中的 类
在 XmlType.factoryClass() 中使用，指示工厂方法未被使用或者在具有此 XmlType 的类中。
XmlType.DEFAULT() - 类 javax.xml.bind.annotation.XmlType.DEFAULT 的构造方法
XMLValidateContext - javax.xml.crypto.dsig 中的 接口
包含用于验证 XML Signature 的上下文信息。
XmlValue - javax.xml.bind.annotation 中的 注释类型
支持将类映射到带有 simpleContent 的 XML 模式复杂类型或 XML 模式简单类型。
XmlWriter - javax.sql.rowset.spi 中的 接口
一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。
XOR - 类 java.awt.AlphaComposite 中的静态变量
将目标色之外的源色部分与源色之外的目标色部分结合到一起（Porter-Duff Source Xor Destination 规则）。
Xor - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 XOR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
xor(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this ^ val) 的 BigInteger。
xor(BitSet) - 类 java.util.BitSet 中的方法
对此位 set 和位 set 参数执行逻辑异或操作。
XPATH - 接口 javax.xml.crypto.dsig.Transform 中的静态变量
XPath 转换算法 URI。
XPath - javax.xml.xpath 中的 接口
XPath 提供了对 XPath 计算环境和表达式的访问。
XPATH2 - 接口 javax.xml.crypto.dsig.Transform 中的静态变量
XPath Filter 2 转换算法 URI。
XPathConstants - javax.xml.xpath 中的 类
XPath 常量。
XPathException - javax.xml.xpath 中的 异常
XPathException 表示通用 XPath 异常。
XPathException(String) - 异常 javax.xml.xpath.XPathException 的构造方法
构造带指定详细 message 的新 XPathException。
XPathException(Throwable) - 异常 javax.xml.xpath.XPathException 的构造方法
构造带指定 cause 的新 XPathException。
XPathExpression - javax.xml.xpath 中的 接口
XPathExpression 提供了对编译后的 XPath 表达式的访问。
XPathExpressionException - javax.xml.xpath 中的 异常
XPathExpressionException 表示 XPath 表达式中的错误。
XPathExpressionException(String) - 异常 javax.xml.xpath.XPathExpressionException 的构造方法
构造带指定详细 message 的新 XPathExpressionException。
XPathExpressionException(Throwable) - 异常 javax.xml.xpath.XPathExpressionException 的构造方法
构造带指定 cause 的新 XPathExpressionException。
XPathFactory - javax.xml.xpath 中的 类
XPathFactory 实例可用于创建 XPath 对象。
XPathFactory() - 类 javax.xml.xpath.XPathFactory 的构造方法
应使用 XPathFactory.newInstance()、XPathFactory.newInstance(String uri) 或 XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader) 之类的受保护构造方法创建 XPathFactory 的新实例。
XPathFactoryConfigurationException - javax.xml.xpath 中的 异常
XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
XPathFactoryConfigurationException(String) - 异常 javax.xml.xpath.XPathFactoryConfigurationException 的构造方法
构造带指定详细 message 的新 XPathFactoryConfigurationException。
XPathFactoryConfigurationException(Throwable) - 异常 javax.xml.xpath.XPathFactoryConfigurationException 的构造方法
构造带指定 cause 的新 XPathFactoryConfigurationException。
XPathFilter2ParameterSpec - javax.xml.crypto.dsig.spec 中的 类
W3C Recommendation XPath Filter 2.0 Transform Algorithm 的参数。
XPathFilter2ParameterSpec(List) - 类 javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec 的构造方法
创建一个 XPathFilter2ParameterSpec。
XPathFilterParameterSpec - javax.xml.crypto.dsig.spec 中的 类
XPath Filtering Transform Algorithm 的参数。
XPathFilterParameterSpec(String) - 类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 的构造方法
创建带有指定 XPath 表达式的 XPathFilterParameterSpec。
XPathFilterParameterSpec(String, Map) - 类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 的构造方法
创建带有指定 XPath 表达式和名称空间映射表的 XPathFilterParameterSpec。
XPathFunction - javax.xml.xpath 中的 接口
XPathFunction 提供了对 XPath 函数的访问。
XPathFunctionException - javax.xml.xpath 中的 异常
XPathFunctionException 表示 XPath 函数的错误。
XPathFunctionException(String) - 异常 javax.xml.xpath.XPathFunctionException 的构造方法
构造带指定详细 message 的新 XPathFunctionException。
XPathFunctionException(Throwable) - 异常 javax.xml.xpath.XPathFunctionException 的构造方法
构造带指定 cause 的新 XPathFunctionException。
XPathFunctionResolver - javax.xml.xpath 中的 接口
XPathFunctionResolver 提供了对用户定义的 XPathFunction 集的访问。
XPathType - javax.xml.crypto.dsig.spec 中的 类
W3C Recommendation for XML-Signature XPath Filter 2.0 中所定义的 XPath 元素的 XML 模式定义：
XPathType(String, XPathType.Filter) - 类 javax.xml.crypto.dsig.spec.XPathType 的构造方法
创建带有指定 XPath 表达式和过滤器的 XPathType 实例。
XPathType(String, XPathType.Filter, Map) - 类 javax.xml.crypto.dsig.spec.XPathType 的构造方法
创建带有指定 XPath 表达式、过滤器和名称空间映射表的 XPathType 实例。
XPathType.Filter - javax.xml.crypto.dsig.spec 中的 类
表示过滤器设置操作。
XPathVariableResolver - javax.xml.xpath 中的 接口
XPathVariableResolver 提供了对用户定义的 XPath 变量集的访问。
xpoints - 类 java.awt.Polygon 中的变量
X 坐标的数组。
xPositionForValue(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
XSLT - 接口 javax.xml.crypto.dsig.Transform 中的静态变量
XSLT 转换算法 URI。
XSLTTransformParameterSpec - javax.xml.crypto.dsig.spec 中的 类
XSLT Transform Algorithm 的参数。
XSLTTransformParameterSpec(XMLStructure) - 类 javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec 的构造方法
创建带有指定样式表的 XSLTTransformParameterSpec。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


Y - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Y

y - 类 java.awt.Event 中的变量
事件的 y 坐标。
y - 类 java.awt.geom.Arc2D.Double 中的变量
弧的窗体矩形左上角的 Y 坐标。
y - 类 java.awt.geom.Arc2D.Float 中的变量
弧的窗体矩形左上角的 Y 坐标。
y - 类 java.awt.geom.Ellipse2D.Double 中的变量
此 Ellipse2D 的窗体矩形左上角的 Y 坐标。
y - 类 java.awt.geom.Ellipse2D.Float 中的变量
此 Ellipse2D 窗体矩形左上角的 Y 坐标。
y - 类 java.awt.geom.Point2D.Double 中的变量
此 Point2D 的 Y 坐标。
y - 类 java.awt.geom.Point2D.Float 中的变量
此 Point2D 的 Y 坐标。
y - 类 java.awt.geom.Rectangle2D.Double 中的变量
此 Rectangle2D 的 Y 坐标。
y - 类 java.awt.geom.Rectangle2D.Float 中的变量
此 Rectangle2D 的 Y 坐标。
y - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
此 RoundRectangle2D 的 Y 坐标。
y - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
此 RoundRectangle2D 的 Y 坐标。
y - 类 java.awt.Point 中的变量
此 Point 的 Y 坐标。
y - 类 java.awt.Rectangle 中的变量
Rectangle 左上角的 Y 坐标。
y1 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段起始点的 Y 坐标。
y1 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段起始点的 Y 坐标。
y1 - 类 java.awt.geom.Line2D.Double 中的变量
线段起始点的 Y 坐标。
y1 - 类 java.awt.geom.Line2D.Float 中的变量
线段起始点的 Y 坐标。
y1 - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段起始点的 Y 坐标。
y1 - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段起始点的 Y 坐标。
y2 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段结束点的 Y 坐标。
y2 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段结束点的 Y 坐标。
y2 - 类 java.awt.geom.Line2D.Double 中的变量
线段结束点的 Y 坐标。
y2 - 类 java.awt.geom.Line2D.Float 中的变量
线段结束点的 Y 坐标。
y2 - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段结束点的 Y 坐标。
y2 - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段结束点的 Y 坐标。
Y_AXIS - 类 javax.swing.BoxLayout 中的静态变量
指定组件应该从上到下放置。
Y_AXIS - 类 javax.swing.text.View 中的静态变量
用于格式化/拆分操作的轴。
YEAR - 类 java.text.DateFormat.Field 中的静态变量
标识 YEAR 字段的常量。
YEAR - 类 java.util.Calendar 中的静态变量
指示年的 get 和 set 的字段数字。
YEAR_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 YEAR 字段的有用常量。
YEARS - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示年字段的常量。
yellow - 类 java.awt.Color 中的静态变量
黄色。
YELLOW - 类 java.awt.Color 中的静态变量
黄色。
YES - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
YES 选项。
YES_NO_CANCEL_OPTION - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
YES/NO/CANCEL 确认选项。
YES_NO_CANCEL_OPTION - 类 javax.swing.JOptionPane 中的静态变量
用于 showConfirmDialog 的类型。
YES_NO_OPTION - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
YES/NO 确认选项。
YES_NO_OPTION - 类 javax.swing.JOptionPane 中的静态变量
用于 showConfirmDialog 的类型。
YES_OPTION - 类 javax.swing.JOptionPane 中的静态变量
选择 YES 时从类方法返回的值。
YI_RADICALS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Yi Radicals”Unicode 字符块的常量。
YI_SYLLABLES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Yi Syllables”Unicode 字符块的常量。
yield() - 类 java.lang.Thread 中的静态方法
暂停当前正在执行的线程对象，并执行其他线程。
YIJING_HEXAGRAM_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Yijing Hexagram Symbols”Unicode 字符块的常量。
YOU_1 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #1 信封尺寸，120 mm × 176 mm。
YOU_2 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #2 信封尺寸，114 mm × 162 mm。
YOU_3 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #3 信封尺寸，98 mm × 148 mm。
YOU_4 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #4 信封尺寸，105 mm × 235 mm。
YOU_5 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #5 信封尺寸，95 mm × 217 mm。
YOU_6 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #6 信封尺寸，98 mm × 190 mm。
YOU_7 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #7 信封尺寸，92 mm × 165 mm。
ypoints - 类 java.awt.Polygon 中的变量
Y 坐标的数组。
yPositionForValue(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
yPositionForValue(int, int, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回指定值的 y 位置。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


Z - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Z

ZERO - 类 java.math.BigDecimal 中的静态变量
值为 0，标度为 0。
ZERO - 类 java.math.BigInteger 中的静态变量
BigInteger 的常量 0。
ZipEntry - java.util.zip 中的 类
此类用于表示 ZIP 文件条目。
ZipEntry(String) - 类 java.util.zip.ZipEntry 的构造方法
使用指定名称创建新的 ZIP 条目。
ZipEntry(ZipEntry) - 类 java.util.zip.ZipEntry 的构造方法
使用从指定 ZIP 条目获取的字段创建新的 ZIP 条目。
ZipError - java.util.zip 中的 错误
发生不可恢复的错误时抛出。
ZipError(String) - 错误 java.util.zip.ZipError 的构造方法
构造带有给定详细消息的 ZipError。
ZipException - java.util.zip 中的 异常
如果某种 ZIP 异常发生，则抛出此错误。
ZipException() - 异常 java.util.zip.ZipException 的构造方法
使用 null 作为错误详细消息构造 ZipException。
ZipException(String) - 异常 java.util.zip.ZipException 的构造方法
构建带指定详细消息的 ZipException。
ZipFile - java.util.zip 中的 类
此类用于从 ZIP 文件读取条目。
ZipFile(String) - 类 java.util.zip.ZipFile 的构造方法
打开 ZIP 文件进行阅读。
ZipFile(File, int) - 类 java.util.zip.ZipFile 的构造方法
打开新的 ZipFile 以使用指定模式从指定 File 对象读取。
ZipFile(File) - 类 java.util.zip.ZipFile 的构造方法
打开供阅读的 ZIP 文件，由指定的 File 对象给出。
ZipInputStream - java.util.zip 中的 类
此类为读取 ZIP 文件格式的文件实现输入流过滤器。
ZipInputStream(InputStream) - 类 java.util.zip.ZipInputStream 的构造方法
创建新的 ZIP 输入流。
ZipOutputStream - java.util.zip 中的 类
此类为以 ZIP 文件格式写入文件实现输出流过滤器。
ZipOutputStream(OutputStream) - 类 java.util.zip.ZipOutputStream 的构造方法
创建新的 ZIP 输出流。
ZONE_OFFSET - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，以毫秒为单位指示距 GMT 的大致偏移量。
ZoneView - javax.swing.text 中的 类
ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。
ZoneView(Element, int) - 类 javax.swing.text.ZoneView 的构造方法
构造一个 ZoneView。
zoneWasLoaded(View) - 类 javax.swing.text.ZoneView 中的方法
当加载某个分区后由该分区调用。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


_ - 索引 (Java 2 Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

_

_ACTIVE - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
_ADD_OVERRIDE - 类 org.omg.CORBA.SetOverrideType 中的静态变量
用于枚举值 ADD_OVERRIDE 的 int 常量。
_all_interfaces(POA, byte[]) - 类 org.omg.CosNaming.BindingIteratorPOA 中的方法
_all_interfaces(POA, byte[]) - 类 org.omg.CosNaming.NamingContextExtPOA 中的方法
_all_interfaces(POA, byte[]) - 类 org.omg.CosNaming.NamingContextPOA 中的方法
_all_interfaces(POA, byte[]) - 类 org.omg.PortableServer.Servant 中的方法
ORB 使用此操作从 servant 获取完整的类型信息。
_all_interfaces(POA, byte[]) - 类 org.omg.PortableServer.ServantActivatorPOA 中的方法
_all_interfaces(POA, byte[]) - 类 org.omg.PortableServer.ServantLocatorPOA 中的方法
_BindingIteratorImplBase - org.omg.CosNaming 中的 类
_BindingIteratorImplBase() - 类 org.omg.CosNaming._BindingIteratorImplBase 的构造方法
_BindingIteratorStub - org.omg.CosNaming 中的 类
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
_BindingIteratorStub() - 类 org.omg.CosNaming._BindingIteratorStub 的构造方法
_COMPLETED_MAYBE - 类 org.omg.CORBA.CompletionStatus 中的静态变量
指示某一方法在抛出 SystemException 之前已结束运行的常量。
_COMPLETED_NO - 类 org.omg.CORBA.CompletionStatus 中的静态变量
指示某一方法在抛出 SystemException 之前已结束运行的常量。
_COMPLETED_YES - 类 org.omg.CORBA.CompletionStatus 中的静态变量
指示某一方法在抛出 SystemException 之前已结束运行的常量。
_create_request(Context, String, NVList, NamedValue) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_create_request(Context, String, NVList, NamedValue) - 接口 org.omg.CORBA.Object 中的方法
创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - 接口 org.omg.CORBA.Object 中的方法
创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。
_create_request(Context, String, NVList, NamedValue) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
_default_POA() - 类 org.omg.PortableServer.Servant 中的方法
从与 servant 关联的 ORB 实例返回根 POA。
_DISCARDING - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
_dk_AbstractInterface - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Alias - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_all - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Array - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Attribute - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Constant - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Enum - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Exception - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Fixed - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Interface - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Module - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Native - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_none - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有定义种类的常量。
_dk_Operation - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Primitive - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Repository - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Sequence - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_String - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Struct - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Typedef - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Union - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Value - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_ValueBox - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_ValueMember - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Wstring - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_duplicate() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_duplicate() - 接口 org.omg.CORBA.Object 中的方法
返回此 CORBA 对象引用的副本。
_duplicate() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回此 ObjectImpl 对象的一个副本。
_DynAnyFactoryStub - org.omg.DynamicAny 中的 类
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
_DynAnyFactoryStub() - 类 org.omg.DynamicAny._DynAnyFactoryStub 的构造方法
_DynAnyStub - org.omg.DynamicAny 中的 类
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
_DynAnyStub() - 类 org.omg.DynamicAny._DynAnyStub 的构造方法
_DynArrayStub - org.omg.DynamicAny 中的 类
DynArray 对象支持对 IDL 数组 (array) 的操作。
_DynArrayStub() - 类 org.omg.DynamicAny._DynArrayStub 的构造方法
_DynEnumStub - org.omg.DynamicAny 中的 类
DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
_DynEnumStub() - 类 org.omg.DynamicAny._DynEnumStub 的构造方法
_DynFixedStub - org.omg.DynamicAny 中的 类
DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
_DynFixedStub() - 类 org.omg.DynamicAny._DynFixedStub 的构造方法
_DynSequenceStub - org.omg.DynamicAny 中的 类
DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
_DynSequenceStub() - 类 org.omg.DynamicAny._DynSequenceStub 的构造方法
_DynStructStub - org.omg.DynamicAny 中的 类
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
_DynStructStub() - 类 org.omg.DynamicAny._DynStructStub 的构造方法
_DynUnionStub - org.omg.DynamicAny 中的 类
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
_DynUnionStub() - 类 org.omg.DynamicAny._DynUnionStub 的构造方法
_DynValueStub - org.omg.DynamicAny 中的 类
DynValue 对象支持 IDL non-boxed value 类型的操作。
_DynValueStub() - 类 org.omg.DynamicAny._DynValueStub 的构造方法
_get_codebase() - 类 org.omg.CORBA_2_3.portable.ObjectImpl 中的方法
返回此对象引用的代码基。
_get_delegate() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得对特定于供应商的 Delegate 对象的引用，此 ObjectImpl 对象将对其调用的所有方法委托给该对象。
_get_delegate() - 类 org.omg.PortableServer.Servant 中的方法
获取 PortableServer::Servant 特定于供应商的 ORB 实现。
_get_domain_managers() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_get_domain_managers() - 接口 org.omg.CORBA.Object 中的方法
检索此对象的 DomainManager。
_get_domain_managers() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得此 ObjectImpl 对象的域管理程序所组成的列表。
_get_interface() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_get_interface_def() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_get_interface_def() - 接口 org.omg.CORBA.Object 中的方法
获取此对象引用所引用的对象实现的 InterfaceDef。
_get_interface_def() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得此 ObjectImpl 对象的接口定义。
_get_interface_def() - 类 org.omg.PortableServer.Servant 中的方法
以 CORBA::Object 的形式返回 InterfaceDef 对象，该对象定义由 Servant 实现的 CORBA::Object 的运行时类型。
_get_policy(int) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_get_policy(int) - 接口 org.omg.CORBA.Object 中的方法
返回应用于此对象的指定类型的 Policy 对象。
_get_policy(int) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得此 ObjectImpl 对象具有给定策略类型的 Policy 对象。
_hash(int) - 类 org.omg.CORBA.LocalObject 中的方法
返回与对象的生命周期一致的哈希值，使用给定数字作为最大值。
_hash(int) - 接口 org.omg.CORBA.Object 中的方法
返回此对象引用的 ORB 内部标识符。
_hash(int) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得充当此 ObjectImpl 对象内部 ORB 标识符的哈希码。
_HOLDING - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
_IDLTypeStub - org.omg.CORBA 中的 类
IDLType 的 Stub。
_IDLTypeStub() - 类 org.omg.CORBA._IDLTypeStub 的构造方法
构造一个默认 _IDLTypeStub 对象。
_IDLTypeStub(Delegate) - 类 org.omg.CORBA._IDLTypeStub 的构造方法
构造一个 _IDLTypeStub 对象，并使用给定 Delegate 对象初始化。
_ids() - 类 org.omg.CORBA._IDLTypeStub 中的方法
_ids() - 类 org.omg.CORBA._PolicyStub 中的方法
_ids() - 类 org.omg.CORBA.DynamicImplementation 中的方法
已过时。
_ids() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
_ids() - 类 org.omg.CosNaming._BindingIteratorImplBase 中的方法
_ids() - 类 org.omg.CosNaming._BindingIteratorStub 中的方法
_ids() - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
_ids() - 类 org.omg.CosNaming._NamingContextImplBase 中的方法
_ids() - 类 org.omg.CosNaming._NamingContextStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynAnyFactoryStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynStructStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynValueStub 中的方法
_ids() - 类 org.omg.PortableServer._ServantActivatorStub 中的方法
_ids() - 类 org.omg.PortableServer._ServantLocatorStub 中的方法
_ids() - 类 org.omg.stub.java.rmi._Remote_Stub 中的方法
返回对象实现的存储库 id 数组。
_IMPLICIT_ACTIVATION - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的静态变量
_INACTIVE - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
_invoke(OutputStream) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_invoke(String, InputStream, ResponseHandler) - 接口 org.omg.CORBA.portable.InvokeHandler 中的方法
由 ORB 调用来调度对 servant 的请求。
_invoke(OutputStream) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
调用某个操作并返回用来读取响应的 InputStream 对象。
_invoke(String, InputStream, ResponseHandler) - 类 org.omg.CosNaming.BindingIteratorPOA 中的方法
_invoke(String, InputStream, ResponseHandler) - 类 org.omg.CosNaming.NamingContextExtPOA 中的方法
_invoke(String, InputStream, ResponseHandler) - 类 org.omg.CosNaming.NamingContextPOA 中的方法
_invoke(String, InputStream, ResponseHandler) - 类 org.omg.PortableServer.ServantActivatorPOA 中的方法
_invoke(String, InputStream, ResponseHandler) - 类 org.omg.PortableServer.ServantLocatorPOA 中的方法
_is_a(String) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_is_a(String) - 接口 org.omg.CORBA.Object 中的方法
检查此对象是否是实现给定接口的类的实例。
_is_a(String) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
检查给定存储库标识符标识的对象是否是 ObjectImpl 对象。
_is_a(String) - 类 org.omg.PortableServer.Servant 中的方法
查看指定的 repository_id 是否存在于 _all_interfaces() 返回的列表，或者其是否是一般 CORBA 对象的 repository_id。
_is_equivalent(Object) - 类 org.omg.CORBA.LocalObject 中的方法
在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。
_is_equivalent(Object) - 接口 org.omg.CORBA.Object 中的方法
在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。
_is_equivalent(Object) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
检查给定的 ObjectImpl 对象是否等于此 ObjectImpl 对象。
_is_local() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_is_local() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
检查此 ObjectImpl 对象是否是由本地 servant 实现的。
_missing_node - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
_MULTIPLE_ID - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的静态变量
_NamingContextExtStub - org.omg.CosNaming 中的 类
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
_NamingContextExtStub() - 类 org.omg.CosNaming._NamingContextExtStub 的构造方法
_NamingContextImplBase - org.omg.CosNaming 中的 类
_NamingContextImplBase() - 类 org.omg.CosNaming._NamingContextImplBase 的构造方法
_NamingContextStub - org.omg.CosNaming 中的 类
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
_NamingContextStub() - 类 org.omg.CosNaming._NamingContextStub 的构造方法
_ncontext - 类 org.omg.CosNaming.BindingType 中的静态变量
_NO_IMPLICIT_ACTIVATION - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的静态变量
_nobject - 类 org.omg.CosNaming.BindingType 中的静态变量
_non_existent() - 类 org.omg.CORBA.LocalObject 中的方法
总是返回 false。
_non_existent() - 接口 org.omg.CORBA.Object 中的方法
确定此对象引用的 server 对象是否已经被销毁。
_non_existent() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
检查此 ObjectImpl 对象的 server 对象是否已经被销毁。
_non_existent() - 类 org.omg.PortableServer.Servant 中的方法
检查 Object 是否存在。
_NON_RETAIN - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的静态变量
_not_context - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
_not_object - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
_object_id() - 类 org.omg.PortableServer.Servant 中的方法
允许便捷地执行公共方法，等效于调用 PortableServer::Current::get_object_id。
_opsClass - 类 org.omg.DynamicAny._DynAnyFactoryStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynAnyStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynArrayStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynEnumStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynFixedStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynSequenceStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynStructStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynUnionStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynValueStub 中的静态变量
_opsClass - 类 org.omg.PortableServer._ServantActivatorStub 中的静态变量
_opsClass - 类 org.omg.PortableServer._ServantLocatorStub 中的静态变量
_orb() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_orb() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回对与此对象及其委托相关的 ORB 的引用。
_orb() - 类 org.omg.PortableServer.Servant 中的方法
返回当前与 Servant 关联的 ORB 实例（便捷方法）。
_ORB_CTRL_MODEL - 类 org.omg.PortableServer.ThreadPolicyValue 中的静态变量
_PARAM_IN - 类 org.omg.CORBA.ParameterMode 中的静态变量
_PARAM_INOUT - 类 org.omg.CORBA.ParameterMode 中的静态变量
_PARAM_OUT - 类 org.omg.CORBA.ParameterMode 中的静态变量
_PERSISTENT - 类 org.omg.PortableServer.LifespanPolicyValue 中的静态变量
_poa() - 类 org.omg.PortableServer.Servant 中的方法
允许便捷地执行共用方法，等效于 PortableServer::Current:get_POA。
_PolicyStub - org.omg.CORBA 中的 类
Policy 的 Stub。
_PolicyStub() - 类 org.omg.CORBA._PolicyStub 的构造方法
构造方法注意事项：如果使用默认构造方法，则该对象在调用 _set_delegate (...) 方法前没有用。
_PolicyStub(Delegate) - 类 org.omg.CORBA._PolicyStub 的构造方法
构造一个 _PolicyStub 对象，并使用给定 Delegate 对象初始化。
_postEdit(UndoableEdit) - 类 javax.swing.undo.UndoableEditSupport 中的方法
仅从 postEdit 和 endUpdate 调用。
_read(InputStream) - 类 org.omg.CORBA.AnyHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
_read(InputStream) - 类 org.omg.CORBA.AnySeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.BooleanHolder 中的方法
从 input 中读取已解组的数据，并将它们分配给此 BooleanHolder 对象的 value 字段。
_read(InputStream) - 类 org.omg.CORBA.BooleanSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.ByteHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化此 ByteHolder 对象中的值。
_read(InputStream) - 类 org.omg.CORBA.CharHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化此 CharHolder 对象中的值。
_read(InputStream) - 类 org.omg.CORBA.CharSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.CurrentHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.DoubleHolder 中的方法
从输入流读取一个 double 值，并将其存储在值成员中。
_read(InputStream) - 类 org.omg.CORBA.DoubleSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.FixedHolder 中的方法
从输入流读取定点值，并将其存储在值成员中。
_read(InputStream) - 类 org.omg.CORBA.FloatHolder 中的方法
从输入流读取一个 float 值，并使用该 float 值初始化值成员。
_read(InputStream) - 类 org.omg.CORBA.FloatSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.IntHolder 中的方法
从 input 中读取已解组数据，并将其分配给此 IntHolder 对象的 value 字段。
_read(InputStream) - 类 org.omg.CORBA.LongHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
_read(InputStream) - 类 org.omg.CORBA.LongLongSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.LongSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.ObjectHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化此 ObjectHolder 对象中的值。
_read(InputStream) - 类 org.omg.CORBA.OctetSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.ParameterModeHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.PolicyErrorHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.PolicyHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.PolicyListHolder 中的方法
_read(InputStream) - 接口 org.omg.CORBA.portable.Streamable 中的方法
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
_read(InputStream) - 类 org.omg.CORBA.PrincipalHolder 中的方法
已过时。
_read(InputStream) - 类 org.omg.CORBA.ServiceInformationHolder 中的方法
从输入流 in 中读取已解组数据，并将它赋予此 ServiceInformationHolder 对象的 value 字段。
_read(InputStream) - 类 org.omg.CORBA.ShortHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化此 ShortHolder 对象中的值。
_read(InputStream) - 类 org.omg.CORBA.ShortSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.StringHolder 中的方法
从 input 中读取已解组的数据，并将它赋予此 StringHolder 对象的 value 字段。
_read(InputStream) - 类 org.omg.CORBA.StringSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.TypeCodeHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化此 TypeCodeHolder 对象中的值。
_read(InputStream) - 类 org.omg.CORBA.ULongLongSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.ULongSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.UnknownUserExceptionHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.UShortSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.ValueBaseHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
_read(InputStream) - 类 org.omg.CORBA.WCharSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.WrongTransactionHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.WStringSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.BindingHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.BindingIteratorHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.BindingListHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.BindingTypeHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NameComponentHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NameHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextExtHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.IORHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.MultipleComponentProfileHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.ServiceContextHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.ServiceContextListHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.TaggedComponentHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.TaggedProfileHolder 中的方法
_read(InputStream) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 中的方法
_read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 中的方法
_read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 中的方法
_read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 中的方法
_read(InputStream) - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 中的方法
_release() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_release() - 接口 org.omg.CORBA.Object 中的方法
发出信号，指示此对象引用调用者已经使用完毕，因而可以释放与此对象引用关联的内部 ORB 资源。
_release() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
释放与此 ObjectImpl 对象关联的资源。
_releaseReply(InputStream) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_releaseReply(InputStream) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
调用 _invoke 方法并且解组完成后，将给定的应答流释放回 ORB。
_Remote_Stub - org.omg.stub.java.rmi 中的 类
此类为 Remote 类型提供 Stub。
_Remote_Stub() - 类 org.omg.stub.java.rmi._Remote_Stub 的构造方法
_request(String) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_request(String, boolean) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_request(String) - 接口 org.omg.CORBA.Object 中的方法
创建一个在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。
_request(String) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
创建一个 Request 对象，使其包含可用于动态调用接口 (Dynamic Invocation Interface) 的给定方法。
_request(String, boolean) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回一个 OutputStream 对象，该对象用于编组给定方法的参数。
_RETAIN - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的静态变量
_servant_postinvoke(ServantObject) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_servant_postinvoke(ServantObject) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
本地 stub 在发起了对本地 servant（通过对 _servant_preinvoke 方法的调用得到）的一次操作后，再调用此方法。
_servant_preinvoke(String, Class) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_servant_preinvoke(String, Class) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回对本地 servant 的 Java 引用，该引用应该被用来发送对指定方法的请求。
_ServantActivatorStub - org.omg.PortableServer 中的 类
当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
_ServantActivatorStub() - 类 org.omg.PortableServer._ServantActivatorStub 的构造方法
_ServantLocatorStub - org.omg.PortableServer 中的 类
POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
_ServantLocatorStub() - 类 org.omg.PortableServer._ServantLocatorStub 的构造方法
_set_delegate(Delegate) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
将此 ObjectImpl 实例的 Delegate 设置为给定的 Delegate 对象。
_set_delegate(Delegate) - 类 org.omg.PortableServer.Servant 中的方法
此操作支持 Java ORB 可移植性接口，它向通过代理支持 ORB 可移植性的类提供一个设置其委托的方法。
_SET_OVERRIDE - 类 org.omg.CORBA.SetOverrideType 中的静态变量
用于枚举值 SET_OVERRIDE 的 int 常量。
_set_policy_override(Policy[], SetOverrideType) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_set_policy_override(Policy[], SetOverrideType) - 接口 org.omg.CORBA.Object 中的方法
返回一个新的 Object，使用给定策略替换此 Object 中的所有现有策略，或者根据给定 SetOverrideType 对象的值将给定策略添加到现有策略。
_set_policy_override(Policy[], SetOverrideType) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
将此 ObjectImpl 对象给定策略的重写类型设置为给定的 SetOverrideType 实例。
_SINGLE_THREAD_MODEL - 类 org.omg.PortableServer.ThreadPolicyValue 中的静态变量
_SYSTEM_ID - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的静态变量
_this() - 类 org.omg.CosNaming.BindingIteratorPOA 中的方法
_this(ORB) - 类 org.omg.CosNaming.BindingIteratorPOA 中的方法
_this() - 类 org.omg.CosNaming.NamingContextExtPOA 中的方法
_this(ORB) - 类 org.omg.CosNaming.NamingContextExtPOA 中的方法
_this() - 类 org.omg.CosNaming.NamingContextPOA 中的方法
_this(ORB) - 类 org.omg.CosNaming.NamingContextPOA 中的方法
_this() - 类 org.omg.PortableServer.ServantActivatorPOA 中的方法
_this(ORB) - 类 org.omg.PortableServer.ServantActivatorPOA 中的方法
_this() - 类 org.omg.PortableServer.ServantLocatorPOA 中的方法
_this(ORB) - 类 org.omg.PortableServer.ServantLocatorPOA 中的方法
_this_object() - 类 org.omg.PortableServer.Servant 中的方法
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
_this_object(ORB) - 类 org.omg.PortableServer.Servant 中的方法
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
_tk_abstract_interface - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 abstract interface 的 int 常量。
_tk_alias - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 alias 的 int 常量。
_tk_any - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 any 的 int 常量。
_tk_array - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 array 的 int 常量。
_tk_boolean - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 boolean 的 int 常量。
_tk_char - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 char 的 int 常量。
_tk_double - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 double 的 int 常量。
_tk_enum - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 enum 的 int 常量。
_tk_except - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 except 的 int 常量。
_tk_fixed - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 fixed 的 int 常量。
_tk_float - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 float 的 int 常量。
_tk_long - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 long 的 int 常量。
_tk_longdouble - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 longdouble 的 int 常量。
_tk_longlong - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 longlong 的 int 常量。
_tk_native - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 native 的 int 常量。
_tk_null - 类 org.omg.CORBA.TCKind 中的静态变量
用于 null IDL 数据类型的 int 常量。
_tk_objref - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 objref 的 int 常量。
_tk_octet - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 octet 的 int 常量。
_tk_Principal - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 Principal 的 int 常量。
_tk_sequence - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 sequence 的 int 常量。
_tk_short - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 short 的 int 常量。
_tk_string - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 string 的 int 常量。
_tk_struct - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 struct 的 int 常量。
_tk_TypeCode - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 TypeCode 的 int 常量。
_tk_ulong - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 ulong 的 int 常量。
_tk_ulonglong - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 ulonglong 的 int 常量。
_tk_union - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 union 的 int 常量。
_tk_ushort - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 ushort 的 int 常量。
_tk_value - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 value 的 int 常量。
_tk_value_box - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 value_box 的 int 常量。
_tk_void - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 void 的 int 常量。
_tk_wchar - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 wchar 的 int 常量。
_tk_wstring - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 wstring 的 int 常量。
_TRANSIENT - 类 org.omg.PortableServer.LifespanPolicyValue 中的静态变量
_truncatable_ids() - 接口 org.omg.CORBA.portable.ValueBase 中的方法
提供可截断的存储库 id。
_type() - 类 org.omg.CORBA.AnyHolder 中的方法
返回对应于此 AnyHolder 对象中保存值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.AnySeqHolder 中的方法
_type() - 类 org.omg.CORBA.BooleanHolder 中的方法
检索对应于此 BooleanHolder 对象中所保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.BooleanSeqHolder 中的方法
_type() - 类 org.omg.CORBA.ByteHolder 中的方法
返回对应于此 ByteHolder 对象中所保存的值的 TypeCode。
_type() - 类 org.omg.CORBA.CharHolder 中的方法
返回对应于此 CharHolder 对象中所保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.CharSeqHolder 中的方法
_type() - 类 org.omg.CORBA.CurrentHolder 中的方法
_type() - 类 org.omg.CORBA.DoubleHolder 中的方法
返回此 holder 对象的 TypeCode。
_type() - 类 org.omg.CORBA.DoubleSeqHolder 中的方法
_type() - 类 org.omg.CORBA.FixedHolder 中的方法
返回此 holder 对象的 TypeCode。
_type() - 类 org.omg.CORBA.FloatHolder 中的方法
返回此 Streamable 的 TypeCode。
_type() - 类 org.omg.CORBA.FloatSeqHolder 中的方法
_type() - 类 org.omg.CORBA.IntHolder 中的方法
检索对应于此 IntHolder 对象 value 字段的 TypeCode 对象。
_type() - 类 org.omg.CORBA.LongHolder 中的方法
返回对应于此 Holder 中所保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.LongLongSeqHolder 中的方法
_type() - 类 org.omg.CORBA.LongSeqHolder 中的方法
_type() - 类 org.omg.CORBA.ObjectHolder 中的方法
返回对应于此 ObjectHolder 对象中所保存的值的 TypeCode
_type() - 类 org.omg.CORBA.OctetSeqHolder 中的方法
_type() - 类 org.omg.CORBA.ParameterModeHolder 中的方法
_type() - 类 org.omg.CORBA.PolicyErrorHolder 中的方法
_type() - 类 org.omg.CORBA.PolicyHolder 中的方法
_type() - 类 org.omg.CORBA.PolicyListHolder 中的方法
_type() - 接口 org.omg.CORBA.portable.Streamable 中的方法
检索对应于 Holder 中 value 字段值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.PrincipalHolder 中的方法
已过时。
_type() - 类 org.omg.CORBA.ServiceInformationHolder 中的方法
检索对应于此 ServiceInformationHolder 对象的 value 字段中所保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.ShortHolder 中的方法
返回对应于此 ShortHolder 对象中所保存的值的 TypeCode。
_type() - 类 org.omg.CORBA.ShortSeqHolder 中的方法
_type() - 类 org.omg.CORBA.StringHolder 中的方法
检索对应于此 StringHolder 对象中所保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.StringSeqHolder 中的方法
_type() - 类 org.omg.CORBA.TypeCodeHolder 中的方法
返回对应于此 TypeCodeHolder 对象中所保存的值的 TypeCode。
_type() - 类 org.omg.CORBA.ULongLongSeqHolder 中的方法
_type() - 类 org.omg.CORBA.ULongSeqHolder 中的方法
_type() - 类 org.omg.CORBA.UnknownUserExceptionHolder 中的方法
_type() - 类 org.omg.CORBA.UShortSeqHolder 中的方法
_type() - 类 org.omg.CORBA.ValueBaseHolder 中的方法
返回对应于此 Holder 中保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.WCharSeqHolder 中的方法
_type() - 类 org.omg.CORBA.WrongTransactionHolder 中的方法
_type() - 类 org.omg.CORBA.WStringSeqHolder 中的方法
_type() - 类 org.omg.CosNaming.BindingHolder 中的方法
_type() - 类 org.omg.CosNaming.BindingIteratorHolder 中的方法
_type() - 类 org.omg.CosNaming.BindingListHolder 中的方法
_type() - 类 org.omg.CosNaming.BindingTypeHolder 中的方法
_type() - 类 org.omg.CosNaming.NameComponentHolder 中的方法
_type() - 类 org.omg.CosNaming.NameHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextExtHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 中的方法
_type() - 类 org.omg.IOP.IORHolder 中的方法
_type() - 类 org.omg.IOP.MultipleComponentProfileHolder 中的方法
_type() - 类 org.omg.IOP.ServiceContextHolder 中的方法
_type() - 类 org.omg.IOP.ServiceContextListHolder 中的方法
_type() - 类 org.omg.IOP.TaggedComponentHolder 中的方法
_type() - 类 org.omg.IOP.TaggedProfileHolder 中的方法
_type() - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 中的方法
_type() - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 中的方法
_type() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 中的方法
_type() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 中的方法
_type() - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 中的方法
_UNIQUE_ID - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的静态变量
_USE_ACTIVE_OBJECT_MAP_ONLY - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
_USE_DEFAULT_SERVANT - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
_USE_SERVANT_MANAGER - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
_USER_ID - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的静态变量
_write(OutputStream) - 类 org.omg.CORBA.AnyHolder 中的方法
将此 AnyHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.AnySeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.BooleanHolder 中的方法
将此 BooleanHolder 对象 value 字段中的值编组到输出流 output。
_write(OutputStream) - 类 org.omg.CORBA.BooleanSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.ByteHolder 中的方法
将此 ByteHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.CharHolder 中的方法
将此 CharHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.CharSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.CurrentHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.DoubleHolder 中的方法
将存储在此 holder 中的 double 值写入 OutputStream。
_write(OutputStream) - 类 org.omg.CORBA.DoubleSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.FixedHolder 中的方法
将存储在此 holder 中的定点值写入 OutputStream。
_write(OutputStream) - 类 org.omg.CORBA.FloatHolder 中的方法
将 float 值写入输出流。
_write(OutputStream) - 类 org.omg.CORBA.FloatSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.IntHolder 中的方法
将此 IntHolder 对象 value 字段中的值编组到输出流 output 中。
_write(OutputStream) - 类 org.omg.CORBA.LongHolder 中的方法
将此 Holder 中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.LongLongSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.LongSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.ObjectHolder 中的方法
将此 ObjectHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.OctetSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.ParameterModeHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.PolicyErrorHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.PolicyHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.PolicyListHolder 中的方法
_write(OutputStream) - 接口 org.omg.CORBA.portable.Streamable 中的方法
将 Holder 中 value 字段的值编组到 ostream。
_write(OutputStream) - 类 org.omg.CORBA.PrincipalHolder 中的方法
已过时。
_write(OutputStream) - 类 org.omg.CORBA.ServiceInformationHolder 中的方法
将此 ServiceInformationHolder 对象的 value 字段中的值编组到输出流 out。
_write(OutputStream) - 类 org.omg.CORBA.ShortHolder 中的方法
将此 ShortHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.ShortSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.StringHolder 中的方法
将此 StringHolder 对象所保存的值编组到输出流 output。
_write(OutputStream) - 类 org.omg.CORBA.StringSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.TypeCodeHolder 中的方法
将此 TypeCodeHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.ULongLongSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.ULongSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.UnknownUserExceptionHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.UShortSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.ValueBaseHolder 中的方法
将此 Holder 中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.WCharSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.WrongTransactionHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.WStringSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.BindingHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.BindingIteratorHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.BindingListHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.BindingTypeHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NameComponentHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NameHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextExtHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.IORHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.MultipleComponentProfileHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.ServiceContextHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.ServiceContextListHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.TaggedComponentHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.TaggedProfileHolder 中的方法
_write(OutputStream) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 中的方法
_write(OutputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 中的方法
_write(OutputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 中的方法
_write(OutputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 中的方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


java.applet (Java 2 Platform SE 6)

 java.applet
接口
AppletContext
AppletStub
AudioClip
类
Applet


类 java.applet.Applet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.applet.Applet
的使用

使用 Applet 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

java.applet 中 Applet 的使用

返回 Applet 的 java.applet 中的方法
 Applet AppletContext.getApplet(String name)
通过给定名称找到并返回此 applet 上下文表示的文档中的 applet。

返回变量类型为 Applet 的类型的 java.applet 中的方法
 Enumeration<Applet> AppletContext.getApplets()
找到此 applet 上下文表示的文档中的所有 applet。

java.beans 中 Applet 的使用

参数类型为 Applet 的 java.beans 中的方法
void | AppletInitializer.activate(Applet newApplet) 激活和/或将 Applet 标记为激活。
void | AppletInitializer.initialize(Applet newAppletBean, BeanContext bCtxt) 如果传递给 java.beans.Beans.instantiate 的适当变体，将调用此方法来将新近实例化的 Applet (JavaBean) 与其 AppletContext、AppletStub 和 Container 相关联。

javax.swing 中 Applet 的使用

javax.swing 中 Applet 的子类
 class JApplet
java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。

参数类型为 Applet 的 javax.swing 中的方法
 void RepaintManager.addDirtyRegion(Applet applet, int x, int y, int w, int h)
将 applet 添加到需要重绘的 Component 列表。

org.omg.CORBA 中 Applet 的使用

参数类型为 Applet 的 org.omg.CORBA 中的方法
static ORB | ORB.init(Applet app, Properties props) 为 applet 创建一个新的 ORB 实例。
protected abstract void | ORB.set_parameters(Applet app, Properties props) 允许使用给定 applet 和参数初始化 ORB 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.applet.Applet.AccessibleApplet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.applet.Applet.AccessibleApplet
的使用

使用 Applet.AccessibleApplet 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 Applet.AccessibleApplet 的使用

javax.swing 中 Applet.AccessibleApplet 的子类
protected  class JApplet.AccessibleJApplet
此类实现对 JApplet 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.applet.AppletContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.applet.AppletContext
的使用

使用 AppletContext 的软件包
java.applet 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

java.applet 中 AppletContext 的使用

返回 AppletContext 的 java.applet 中的方法
AppletContext | AppletStub.getAppletContext() 返回 applet 的上下文。
AppletContext | Applet.getAppletContext() 确定此 applet 的上下文，上下文允许 applet 查询和影响它所运行的环境。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.applet.AppletStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.applet.AppletStub
的使用

使用 AppletStub 的软件包
java.applet 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

java.applet 中 AppletStub 的使用

参数类型为 AppletStub 的 java.applet 中的方法
 void Applet.setStub(AppletStub stub)
设置此 applet 的 stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.applet.AudioClip 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.applet.AudioClip
的使用

使用 AudioClip 的软件包
java.applet 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

java.applet 中 AudioClip 的使用

返回 AudioClip 的 java.applet 中的方法
AudioClip | AppletContext.getAudioClip(URL url) 创建音频剪辑。
AudioClip | Applet.getAudioClip(URL url) 返回 URL 参数指定的 AudioClip 对象。
AudioClip | Applet.getAudioClip(URL url, String name) 返回 URL 和 name 参数指定的 AudioClip 对象。
static AudioClip | Applet.newAudioClip(URL url) 从给定 URL 处获取音频剪辑。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


Component.AccessibleAWTComponent.AccessibleAWTComponentHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

java.lang.Object
    继承者  java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
所有已实现的接口：
ComponentListener, EventListener
正在封闭类：
Component.AccessibleAWTComponent
protected class Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
extends Object
implements ComponentListener

当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）

从以下版本开始：
1.3

构造方法摘要
protected Component.AccessibleAWTComponent.AccessibleAWTComponentHandler()
方法摘要
void | componentHidden(ComponentEvent e) 组件变得不可见时调用。
void | componentMoved(ComponentEvent e) 组件位置更改时调用。
void | componentResized(ComponentEvent e) 组件大小更改时调用。
void | componentShown(ComponentEvent e) 组件变得可见时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

protected Component.AccessibleAWTComponent.AccessibleAWTComponentHandler()
方法详细信息

componentHidden

public void componentHidden(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件变得不可见时调用。

指定者：
接口 ComponentListener 中的 componentHidden

componentShown

public void componentShown(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件变得可见时调用。

指定者：
接口 ComponentListener 中的 componentShown

componentMoved

public void componentMoved(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件位置更改时调用。

指定者：
接口 ComponentListener 中的 componentMoved

componentResized

public void componentResized(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件大小更改时调用。

指定者：
接口 ComponentListener 中的 componentResized
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Component.AccessibleAWTComponent.AccessibleAWTFocusHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

java.lang.Object
    继承者  java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
Component.AccessibleAWTComponent
protected class Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
extends Object
implements FocusListener

当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）

从以下版本开始：
1.3

构造方法摘要
protected Component.AccessibleAWTComponent.AccessibleAWTFocusHandler()
方法摘要
void | focusGained(FocusEvent event) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent event) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

protected Component.AccessibleAWTComponent.AccessibleAWTFocusHandler()
方法详细信息

focusGained

public void focusGained(FocusEvent event)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent event)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Container.AccessibleAWTContainer.AccessibleContainerHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Container.AccessibleAWTContainer.AccessibleContainerHandler

java.lang.Object
    继承者  java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
所有已实现的接口：
ContainerListener, EventListener
正在封闭类：
Container.AccessibleAWTContainer
protected class Container.AccessibleAWTContainer.AccessibleContainerHandler
extends Object
implements ContainerListener

添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

从以下版本开始：
1.3

构造方法摘要
protected Container.AccessibleAWTContainer.AccessibleContainerHandler()
方法摘要
void | componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Container.AccessibleAWTContainer.AccessibleContainerHandler

protected Container.AccessibleAWTContainer.AccessibleContainerHandler()
方法详细信息

componentAdded

public void componentAdded(ContainerEvent e)
从接口 ContainerListener 复制的描述
已将组件添加到容器中时调用。

指定者：
接口 ContainerListener 中的 componentAdded

componentRemoved

public void componentRemoved(ContainerEvent e)
从接口 ContainerListener 复制的描述
已从容器中移除组件时调用。

指定者：
接口 ContainerListener 中的 componentRemoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


List.AccessibleAWTList.AccessibleAWTListChild (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 List.AccessibleAWTList.AccessibleAWTListChild

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.List.AccessibleAWTList.AccessibleAWTListChild
所有已实现的接口：
Serializable, Accessible, AccessibleComponent
正在封闭类：
List.AccessibleAWTList
protected class List.AccessibleAWTList.AccessibleAWTListChild
extends Component.AccessibleAWTComponent
implements Accessible

此类实现 List 子级的可访问性支持。它提供适合列表子级用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
List.AccessibleAWTList.AccessibleAWTListChild(List parent, int indexInParent)
方法摘要
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以从此组件接收焦点事件。
boolean | contains(Point p) 检查指定点是否位于此对象的界限中，其中该点的 X 坐标和 Y 坐标是相对于对象的定义的。
Accessible | getAccessibleAt(Point p) 如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回该子级。
Accessible | getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
int | getAccessibleChildrenCount() 返回对象的可访问子级数。
AccessibleContext | getAccessibleContext() 获取此对象的 AccessibleContext。
int | getAccessibleIndexInParent() 获取此对象的可访问父级中基于 0 的索引。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
Color | getBackground() 获取此对象的背景颜色。
Rectangle | getBounds() 以 Rectangle 对象的形式获取此对象的界限。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 设置此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景颜色。
Locale | getLocale() 获取组件的区域设置。
Point | getLocation() 获取此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isEnabled() 确定是否已启用对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定是否正显示对象。
boolean | isVisible() 确定对象是否可见。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再从此组件接收焦点事件。
void | requestFocus() 请求聚焦此对象。
void | setBackground(Color c) 设置此对象的背景颜色。
void | setBounds(Rectangle r) 以 Rectangle 对象的形式设置此对象的界限。
void | setCursor(Cursor cursor) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景颜色。
void | setLocation(Point p) 设置对象相对于父级的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置对象的可见状态。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addPropertyChangeListener, getAccessibleComponent, getAccessibleDescription, getAccessibleName, getAccessibleParent, removePropertyChangeListener
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

List.AccessibleAWTList.AccessibleAWTListChild

public List.AccessibleAWTList.AccessibleAWTListChild(List parent,
                                                     int indexInParent)
方法详细信息

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取此对象的 AccessibleContext。在此类的 Java Accessibility API 的实现中，返回的是此对象，它是其自身的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
此对象

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。对象的 AccessibleStateSet 是由唯一的 AccessibleState 的集合组成的。对象的 AccessibleStateSet 中的更改将导致为 ACCESSIBLE_STATE_PROPERTY 属性激发 PropertyChangeEvent。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleStateSet
返回：
包含对象的当前状态设置的 AccessibleStateSet 的实例
另请参见：
AccessibleStateSet, AccessibleState, Component.AccessibleAWTComponent.addPropertyChangeListener(java.beans.PropertyChangeListener)

getLocale

public Locale getLocale()
获取组件的区域设置。如果该组件没有区域，则返回其父级的区域。

覆盖：
类 Component.AccessibleAWTComponent 中的 getLocale
返回：
此组件的区域。如果此组件没有区域，则返回其父级的区域。
抛出：
IllegalComponentStateException - 如果该 Component 没有它自己的区域，并且尚未被添加到包含层次结构（那样可以从包含父级确定其区域）。

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获取此对象的可访问父级中基于 0 的索引。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleIndexInParent
返回：
返回此对象父级中基于 0 的索引；如果此对象没有可访问父级，则返回 -1。
另请参见：
Component.AccessibleAWTComponent.getAccessibleParent(),
getAccessibleChildrenCount(),
getAccessibleChild(int)

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象的可访问子级数。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的指定 Accessible 子级。Accessible 对象的 Accessible 子级是基于零的，因此 Accessible 第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleChild
参数：
i - 子级基于零的索引
返回：
对象的 Accessible 子级
另请参见：
getAccessibleChildrenCount()

getBackground

public Color getBackground()
获取此对象的背景颜色。

指定者：
接口 AccessibleComponent 中的 getBackground
覆盖：
类 Component.AccessibleAWTComponent 中的 getBackground
返回：
对象的背景颜色，如果支持的话；否则返回 null
另请参见：
setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
设置此对象的背景颜色。

指定者：
接口 AccessibleComponent 中的 setBackground
覆盖：
类 Component.AccessibleAWTComponent 中的 setBackground
参数：
c - 背景的新 Color
另请参见：
setBackground(java.awt.Color)

getForeground

public Color getForeground()
获取此对象的前景颜色。

指定者：
接口 AccessibleComponent 中的 getForeground
覆盖：
类 Component.AccessibleAWTComponent 中的 getForeground
返回：
对象的前景颜色，如果支持的话；否则返回 null
另请参见：
setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
设置此对象的前景颜色。

指定者：
接口 AccessibleComponent 中的 setForeground
覆盖：
类 Component.AccessibleAWTComponent 中的 setForeground
参数：
c - 前景的新 Color
另请参见：
getForeground()

getCursor

public Cursor getCursor()
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
覆盖：
类 Component.AccessibleAWTComponent 中的 getCursor
返回：
对象的 Cursor，如果支持的话；否则返回 null
另请参见：
setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor cursor)
设置此对象的 Cursor。

如果 Java 平台实现和/或本机系统不支持更改鼠标光标形状，则该方法可能不会产生任何视觉效果。

指定者：
接口 AccessibleComponent 中的 setCursor
覆盖：
类 Component.AccessibleAWTComponent 中的 setCursor
参数：
cursor - 对象的新 Cursor
另请参见：
getCursor()

getFont

public Font getFont()
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
覆盖：
类 Component.AccessibleAWTComponent 中的 getFont
返回：
对象的 Font，如果支持的话；否则返回 null
另请参见：
setFont(java.awt.Font)

setFont

public void setFont(Font f)
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
覆盖：
类 Component.AccessibleAWTComponent 中的 setFont
参数：
f - 对象的新 Font
另请参见：
getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
设置此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
覆盖：
类 Component.AccessibleAWTComponent 中的 getFontMetrics
参数：
f - Font
返回：
对象的 FontMetrics，如果支持的话；否则返回 null
另请参见：
getFont()

isEnabled

public boolean isEnabled()
确定是否已启用对象。启用的对象在其 AccessibleStateSet 中也将具有 AccessibleState.ENABLED 状态设置。

指定者：
接口 AccessibleComponent 中的 isEnabled
覆盖：
类 Component.AccessibleAWTComponent 中的 isEnabled
返回：
如果已启用对象，则返回 true；否则返回 false
另请参见：
setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
设置对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
覆盖：
类 Component.AccessibleAWTComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则禁用它
另请参见：
isEnabled()

isVisible

public boolean isVisible()
确定对象是否可见。注：这意味着该对象多半是可见的；但是因为包含此对象的对象之一目前不可见，所以可能在屏幕上不显示它。要确定对象是否在屏幕上显示，需要使用 isShowing()。

可见的对象在其 AccessibleStateSet 中也将具有 AccessibleState.VISIBLE 状态设置。

指定者：
接口 AccessibleComponent 中的 isVisible
覆盖：
类 Component.AccessibleAWTComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则返回 false
另请参见：
setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
设置对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
覆盖：
类 Component.AccessibleAWTComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则隐藏它
另请参见：
isVisible()

isShowing

public boolean isShowing()
确定是否正显示对象。通过检查对象的可见性及其祖先的可见性可以确定这一点。注：即使该对象被另一对象屏蔽（例如，该对象为下拉菜单的下级），仍然返回 true。

指定者：
接口 AccessibleComponent 中的 isShowing
覆盖：
类 Component.AccessibleAWTComponent 中的 isShowing
返回：
如果正显示对象，则返回 true；否则返回 false

contains

public boolean contains(Point p)
检查指定点是否位于此对象的界限中，其中该点的 X 坐标和 Y 坐标是相对于对象的定义的。

指定者：
接口 AccessibleComponent 中的 contains
覆盖：
类 Component.AccessibleAWTComponent 中的 contains
参数：
p - 相对于对象的的 Point
返回：
如果对象包含 Point，则返回 true；否则返回 false
另请参见：
getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
覆盖：
类 Component.AccessibleAWTComponent 中的 getLocationOnScreen
返回：
返回对象在屏幕上的位置；如果此对象不在屏幕上，则返回 null
另请参见：
getBounds(), getLocation()

getLocation

public Point getLocation()
获取此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
覆盖：
类 Component.AccessibleAWTComponent 中的 getLocation
返回：
表示对象界限左上角在屏幕坐标空间中的 Point 的实例；如果此对象或其父级不在屏幕上，则返回 null
另请参见：
getBounds(), getLocationOnScreen()

setLocation

public void setLocation(Point p)
设置对象相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
覆盖：
类 Component.AccessibleAWTComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
getLocation()

getBounds

public Rectangle getBounds()
以 Rectangle 对象的形式获取此对象的界限。这些界限指定此对象的宽度、高度和相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
覆盖：
类 Component.AccessibleAWTComponent 中的 getBounds
返回：
返回指示此组件的界限的长方形；如果此对象不在屏幕上，则返回 null。
另请参见：
contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
以 Rectangle 对象的形式设置此对象的界限。这些界限指定此对象的宽度、高度和相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
覆盖：
类 Component.AccessibleAWTComponent 中的 setBounds
参数：
r - 指示此组件界限的长方形
另请参见：
getBounds()

getSize

public Dimension getSize()
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的高度字段包含此对象的高度，Dimension 对象的宽度字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
覆盖：
类 Component.AccessibleAWTComponent 中的 getSize
返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
调整此对象，使其具有高度和宽度。

指定者：
接口 AccessibleComponent 中的 setSize
覆盖：
类 Component.AccessibleAWTComponent 中的 setSize
参数：
d - - 指定对象新大小的维数。
另请参见：
getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回该子级。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleAt
参数：
p - 相对于此对象的的点
返回：
如果 Accessible 存在，并且位于指定位置，则返回它；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
返回此对象是否可以接受焦点。可以接受焦点的对象在其 AccessibleStateSet 中也将具有 AccessibleState.FOCUSABLE 状态设置。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
覆盖：
类 Component.AccessibleAWTComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
请求聚焦此对象。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
覆盖：
类 Component.AccessibleAWTComponent 中的 requestFocus
另请参见：
isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
添加指定的焦点侦听器，以从此组件接收焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
覆盖：
类 Component.AccessibleAWTComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
移除指定的焦点侦听器，使其不再从此组件接收焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
覆盖：
类 Component.AccessibleAWTComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
addFocusListener(java.awt.event.FocusListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


java.awt (Java 2 Platform SE 6)

 java.awt
接口
ActiveEvent
Adjustable
Composite
CompositeContext
ItemSelectable
KeyEventDispatcher
KeyEventPostProcessor
LayoutManager
LayoutManager2
MenuContainer
Paint
PaintContext
PrintGraphics
Shape
Stroke
Transparency
类
AlphaComposite
AWTEvent
AWTEventMulticaster
AWTKeyStroke
AWTPermission
BasicStroke
BorderLayout
BufferCapabilities
BufferCapabilities.FlipContents
Button
Canvas
CardLayout
Checkbox
CheckboxGroup
CheckboxMenuItem
Choice
Color
Component
ComponentOrientation
Container
ContainerOrderFocusTraversalPolicy
Cursor
DefaultFocusTraversalPolicy
DefaultKeyboardFocusManager
Desktop
Dialog
Dimension
DisplayMode
Event
EventQueue
FileDialog
FlowLayout
FocusTraversalPolicy
Font
FontMetrics
Frame
GradientPaint
Graphics
Graphics2D
GraphicsConfigTemplate
GraphicsConfiguration
GraphicsDevice
GraphicsEnvironment
GridBagConstraints
GridBagLayout
GridBagLayoutInfo
GridLayout
Image
ImageCapabilities
Insets
JobAttributes
JobAttributes.DefaultSelectionType
JobAttributes.DestinationType
JobAttributes.DialogType
JobAttributes.MultipleDocumentHandlingType
JobAttributes.SidesType
KeyboardFocusManager
Label
LinearGradientPaint
List
MediaTracker
Menu
MenuBar
MenuComponent
MenuItem
MenuShortcut
MouseInfo
MultipleGradientPaint
PageAttributes
PageAttributes.ColorType
PageAttributes.MediaType
PageAttributes.OrientationRequestedType
PageAttributes.OriginType
PageAttributes.PrintQualityType
Panel
Point
PointerInfo
Polygon
PopupMenu
PrintJob
RadialGradientPaint
Rectangle
RenderingHints
RenderingHints.Key
Robot
Scrollbar
ScrollPane
ScrollPaneAdjustable
SplashScreen
SystemColor
SystemTray
TextArea
TextComponent
TextField
TexturePaint
Toolkit
TrayIcon
Window
枚举
Component.BaselineResizeBehavior
Desktop.Action
Dialog.ModalExclusionType
Dialog.ModalityType
MultipleGradientPaint.ColorSpaceType
MultipleGradientPaint.CycleMethod
TrayIcon.MessageType
异常
AWTException
FontFormatException
HeadlessException
IllegalComponentStateException
错误
AWTError


接口 java.awt.ActiveEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.ActiveEvent
的使用

使用 ActiveEvent 的软件包
java.awt.event 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt.event 中 ActiveEvent 的使用

实现 ActiveEvent 的 java.awt.event 中的类
 class InvocationEvent
当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.Adjustable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Adjustable
的使用

使用 Adjustable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Adjustable 的使用

实现 Adjustable 的 java.awt 中的类
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
class | ScrollPaneAdjustable 此类表示 ScrollPane 的水平或垂直滚动条的状态。

返回 Adjustable 的 java.awt 中的方法
Adjustable | ScrollPane.getHAdjustable() 返回表示水平滚动条状态的 ScrollPaneAdjustable 对象。
Adjustable | ScrollPane.getVAdjustable() 返回表示垂直滚动条状态的 ScrollPaneAdjustable 对象。

java.awt.event 中 Adjustable 的使用

返回 Adjustable 的 java.awt.event 中的方法
 Adjustable AdjustmentEvent.getAdjustable()
返回发起此事件的 Adjustable 对象。

参数类型为 Adjustable 的 java.awt.event 中的构造方法
AdjustmentEvent(Adjustable source, int id, int type, int value)
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。
AdjustmentEvent(Adjustable source, int id, int type, int value, boolean isAdjusting)
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。

javax.swing 中 Adjustable 的使用

实现 Adjustable 的 javax.swing 中的类
class | JScrollBar 滚动条的实现。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.AlphaComposite 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AlphaComposite
的使用

使用 AlphaComposite 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 AlphaComposite 的使用

声明为 AlphaComposite 的 java.awt 中的字段
static AlphaComposite | AlphaComposite.Clear 实现不透明 CLEAR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.Dst 实现不透明 DST 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.DstAtop 实现不透明 DST_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.DstIn 实现不透明 DST_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.DstOut 实现不透明 DST_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.DstOver 实现不透明 DST_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.Src 实现不透明 SRC 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.SrcAtop 实现不透明 SRC_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.SrcIn 实现不透明 SRC_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.SrcOut 实现不透明 SRC_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.SrcOver 实现不透明 SRC_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.Xor 实现不透明 XOR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

返回 AlphaComposite 的 java.awt 中的方法
AlphaComposite | AlphaComposite.derive(float alpha) 返回一个类似的 AlphaComposite 对象，该对象使用指定的 alpha 值。
AlphaComposite | AlphaComposite.derive(int rule) 返回一个类似的 AlphaComposite 对象，该对象使用指定的复合规则。
static AlphaComposite | AlphaComposite.getInstance(int rule) 创建一个具有指定规则的 AlphaComposite 对象。
static AlphaComposite | AlphaComposite.getInstance(int rule, float alpha) 创建一个 AlphaComposite 对象，它具有指定的规则和用来乘源色 alpha 值的常量 alpha 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.AWTError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTError
的使用

没有 java.awt.AWTError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.AWTEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTEvent
的使用

使用 AWTEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
javax.swing.event | 供 Swing 组件触发的事件使用。

java.awt 中 AWTEvent 的使用

返回 AWTEvent 的 java.awt 中的方法
protected AWTEvent | Component.coalesceEvents(AWTEvent existingEvent, AWTEvent newEvent) 将正发送的事件与现有事件组合在一起。
static AWTEvent | EventQueue.getCurrentEvent() 返回当前正在被 EventQueue（它与正在调用的线程相关）指派的事件。
AWTEvent | EventQueue.getNextEvent() 从 EventQueue 中移除一个事件，并返回该事件。
AWTEvent | EventQueue.peekEvent() 返回 EventQueue 上的第一个事件，而不移除它。
AWTEvent | EventQueue.peekEvent(int id) 返回指定 id（如果有） 的第一个事件。

参数类型为 AWTEvent 的 java.awt 中的方法
protected AWTEvent | Component.coalesceEvents(AWTEvent existingEvent, AWTEvent newEvent) 将正发送的事件与现有事件组合在一起。
void | MenuComponent.dispatchEvent(AWTEvent e) 将事件传递给此组件或其子组件之一。
boolean | DefaultKeyboardFocusManager.dispatchEvent(AWTEvent e) 此方法由 AWT 事件调度程序调用，该调度程序请求当前的 KeyboardFocusManager 以它的名义指派指定的事件。
abstract boolean | KeyboardFocusManager.dispatchEvent(AWTEvent e) AWT 事件调度程序可以调用此方法，请求当前的 KeyboardFocusManager 为其指派指定的事件。
protected void | EventQueue.dispatchEvent(AWTEvent event) 指派一个事件。
void | Component.dispatchEvent(AWTEvent e) 为组件或其子组件之一指派事件。
void | EventQueue.postEvent(AWTEvent theEvent) 将一个 1.1 样式的事件发送到 EventQueue 中。
protected void | Button.processEvent(AWTEvent e) 处理此按钮上的事件。
protected void | Checkbox.processEvent(AWTEvent e) 处理关于此复选框的事件。
protected void | CheckboxMenuItem.processEvent(AWTEvent e) 处理此复选框菜单项上的事件。
protected void | Choice.processEvent(AWTEvent e) 处理关于此选择的事件。
protected void | List.processEvent(AWTEvent e) 此滚动列表的进程事件。
protected void | Scrollbar.processEvent(AWTEvent e) 处理在滚动条上发生的事件。
protected void | TextComponent.processEvent(AWTEvent e) 处理此文本组件上发生的事件。
protected void | TextField.processEvent(AWTEvent e) 处理此文本字段上的事件。
protected void | MenuItem.processEvent(AWTEvent e) 处理此菜单项上的事件。
protected void | MenuComponent.processEvent(AWTEvent e) 处理发生在此菜单组件上的事件。
protected void | Window.processEvent(AWTEvent e) 处理此窗口上的事件。
protected void | Container.processEvent(AWTEvent e) 处理关于此容器的事件。
protected void | Component.processEvent(AWTEvent e) 处理组件上发生的事件。
void | KeyboardFocusManager.redispatchEvent(Component target, AWTEvent e) 重新指派 AWTEvent 的方式是，AWT 事件调度程序不会递归式请求 KeyboardFocusManager 或任何已安装的 KeyEventDispatcher 再次指派该事件。

java.awt.event 中 AWTEvent 的使用

java.awt.event 中 AWTEvent 的子类
class | ActionEvent 指示发生了组件定义的动作的语义事件。
class | AdjustmentEvent 由 Adjustable 对象所发出的调整事件。
class | ComponentEvent 指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
class | ContainerEvent 指示容器内容因为添加或移除组件而更改的低级别事件。
class | FocusEvent 指示 Component 已获得或失去输入焦点的低级别事件。
class | HierarchyEvent 指示 Component 所属的 Component 层次结构发生更改的事件。
class | InputEvent 所有组件级别输入事件的根事件类。
class | InputMethodEvent 输入方法事件包含有关使用输入方法进行撰写的文本的信息。
class | InvocationEvent 当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。
class | ItemEvent 指示项被选定或取消选定的语义事件。
class | KeyEvent 表示组件中发生键击的事件。
class | MouseEvent 指示组件中发生鼠标动作的事件。
class | MouseWheelEvent 表示鼠标滚轮在组件中滚动的事件。
class | PaintEvent 组件级绘制事件。
class | TextEvent 指示对象文本已改变的语义事件。
class | WindowEvent 指示窗口状态改变的低级别事件。

参数类型为 AWTEvent 的 java.awt.event 中的方法
void | AWTEventListenerProxy.eventDispatched(AWTEvent evt) 将属性更改事件转发给侦听器代理。
void | AWTEventListener.eventDispatched(AWTEvent event) 在 AWT 中指派事件时调用。

java.awt.im 中 AWTEvent 的使用

参数类型为 AWTEvent 的 java.awt.im 中的方法
 void InputContext.dispatchEvent(AWTEvent event)
将事件指派到处于活动状态的输入方法。

java.awt.im.spi 中 AWTEvent 的使用

参数类型为 AWTEvent 的 java.awt.im.spi 中的方法
 void InputMethod.dispatchEvent(AWTEvent event)
将事件指派到输入方法。

javax.swing.event 中 AWTEvent 的使用

javax.swing.event 中 AWTEvent 的子类
class | AncestorEvent 报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。
class | InternalFrameEvent 以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
class | MenuDragMouseEvent MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
class | MenuKeyEvent MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.AWTEventMulticaster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTEventMulticaster
的使用

没有 java.awt.AWTEventMulticaster 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.AWTException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTException
的使用

使用 AWTException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt 中 AWTException 的使用

抛出 AWTException 的 java.awt 中的方法
void | SystemTray.add(TrayIcon trayIcon) 将 TrayIcon 添加到 SystemTray。
protected void | Component.FlipBufferStrategy.createBuffers(int numBuffers, BufferCapabilities caps) 创建一个或多个具有给定能力的、复杂的翻转缓冲区。
void | Canvas.createBufferStrategy(int numBuffers, BufferCapabilities caps) 创建一个新的策略，使用所需的缓冲区能力对此组件进行多次缓冲。
void | Window.createBufferStrategy(int numBuffers, BufferCapabilities caps) 根据所需缓冲区能力为此组件上的多缓冲创建新策略。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力的 VolatileImage。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps, int transparency) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力和透明度值的 VolatileImage。
VolatileImage | Component.createVolatileImage(int width, int height, ImageCapabilities caps) 创建一幅具有给定能力的、可变的、可在屏幕外绘制的图像。
static Cursor | Cursor.getSystemCustomCursor(String name) 返回与指定名称匹配的特定于系统的定制光标对象。

抛出 AWTException 的 java.awt 中的构造方法
Component.FlipBufferStrategy(int numBuffers, BufferCapabilities caps)
为此组件创建新的翻转缓冲区策略。
Robot()
在基本屏幕坐标系中构造一个 Robot 对象。
Robot(GraphicsDevice screen)
为给定屏幕设备创建一个 Robot 。

java.awt.im.spi 中 AWTException 的使用

抛出 AWTException 的 java.awt.im.spi 中的方法
 Locale[] InputMethodDescriptor.getAvailableLocales()
返回相应输入方法支持的语言环境。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.AWTKeyStroke 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTKeyStroke
的使用

使用 AWTKeyStroke 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 AWTKeyStroke 的使用

返回 AWTKeyStroke 的 java.awt 中的方法
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStroke(char keyChar) 返回表示指定字符的 KEY_TYPED 事件的 AWTKeyStroke 的一个共享实例。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStroke(Character keyChar, int modifiers) 返回一个共享的 AWTKeyStroke 实例，它表示针对指定 Character 对象和一组组合键的 KEY_TYPED 事件。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStroke(int keyCode, int modifiers) 在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStroke(int keyCode, int modifiers, boolean onKeyRelease) 在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例，指定该键在按下或释放时是否是被激活。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStroke(String s) 分析字符串并返回一个 AWTKeyStroke。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStrokeForEvent(KeyEvent anEvent) 返回一个 AWTKeyStroke，它表示生成给定 KeyEvent 的键击事件。

返回变量类型为 AWTKeyStroke 的类型的 java.awt 中的方法
Set<AWTKeyStroke> | KeyboardFocusManager.getDefaultFocusTraversalKeys(int id) 返回给定遍历操作的默认焦点遍历键的 Set。
Set<AWTKeyStroke> | Window.getFocusTraversalKeys(int id) 获取此窗口的焦点遍历键。
Set<AWTKeyStroke> | Container.getFocusTraversalKeys(int id) 为此 Container 的给定遍历操作返回焦点遍历键的 Set。
Set<AWTKeyStroke> | Component.getFocusTraversalKeys(int id) 返回此 Component 的给定遍历操作的焦点遍历键 Set。

类型变量类型为 AWTKeyStroke 的 java.awt 中的方法参数
void | KeyboardFocusManager.setDefaultFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 设置给定遍历操作的默认焦点遍历键。
void | Container.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 为此 Container 的给定遍历操作设置焦点遍历键。
void | Component.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 为此 Component 的给定遍历操作设置焦点遍历键。

javax.swing 中 AWTKeyStroke 的使用

javax.swing 中 AWTKeyStroke 的子类
 class KeyStroke
表示键盘或等效输入设置上的键操作的 KeyStroke。

类型变量类型为 AWTKeyStroke 的 javax.swing 中的方法参数
 void JComponent.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes)
设置针对此 Component 的给定遍历操作的焦点遍历键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.AWTPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTPermission
的使用

没有 java.awt.AWTPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.BasicStroke 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.BasicStroke
的使用

没有 java.awt.BasicStroke 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.BorderLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.BorderLayout
的使用

没有 java.awt.BorderLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.BufferCapabilities 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.BufferCapabilities
的使用

使用 BufferCapabilities 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 BufferCapabilities 的使用

声明为 BufferCapabilities 的 java.awt 中的字段
protected BufferCapabilities | Component.FlipBufferStrategy.caps 缓冲能力。
protected BufferCapabilities | Component.BltBufferStrategy.caps 缓冲区能力

返回 BufferCapabilities 的 java.awt 中的方法
BufferCapabilities | GraphicsConfiguration.getBufferCapabilities() 返回此 GraphicsConfiguration 的缓冲区能力。
BufferCapabilities | Component.FlipBufferStrategy.getCapabilities()
BufferCapabilities | Component.BltBufferStrategy.getCapabilities()

参数类型为 BufferCapabilities 的 java.awt 中的方法
protected void | Component.FlipBufferStrategy.createBuffers(int numBuffers, BufferCapabilities caps) 创建一个或多个具有给定能力的、复杂的翻转缓冲区。
void | Canvas.createBufferStrategy(int numBuffers, BufferCapabilities caps) 创建一个新的策略，使用所需的缓冲区能力对此组件进行多次缓冲。
void | Window.createBufferStrategy(int numBuffers, BufferCapabilities caps) 根据所需缓冲区能力为此组件上的多缓冲创建新策略。

参数类型为 BufferCapabilities 的 java.awt 中的构造方法
Component.BltBufferStrategy(int numBuffers, BufferCapabilities caps)
围绕组件创建一个新的 blt 缓冲区策略
Component.FlipBufferStrategy(int numBuffers, BufferCapabilities caps)
为此组件创建新的翻转缓冲区策略。

java.awt.image 中 BufferCapabilities 的使用

返回 BufferCapabilities 的 java.awt.image 中的方法
abstract  BufferCapabilities BufferStrategy.getCapabilities()
返回此 BufferStrategy 的 BufferCapabilities。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.BufferCapabilities.FlipContents 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.BufferCapabilities.FlipContents
的使用

使用 BufferCapabilities.FlipContents 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 BufferCapabilities.FlipContents 的使用

声明为 BufferCapabilities.FlipContents 的 java.awt 中的字段
static BufferCapabilities.FlipContents | BufferCapabilities.FlipContents.BACKGROUND 当翻转内容为 BACKGROUND 时，后台缓冲区的内容在翻转后使用背景颜色清除。
static BufferCapabilities.FlipContents | BufferCapabilities.FlipContents.COPIED 当翻转内容为 COPIED 时，翻转时将后台缓冲区的内容复制到前台缓冲区。
static BufferCapabilities.FlipContents | BufferCapabilities.FlipContents.PRIOR 当翻转内容为 PRIOR 时，后台缓冲区的内容为前台缓冲区的先前内容（真实的页面翻转）。
static BufferCapabilities.FlipContents | BufferCapabilities.FlipContents.UNDEFINED 当翻转内容为 UNDEFINED 时，后台缓冲区的内容在翻转后是不明确的。

返回 BufferCapabilities.FlipContents 的 java.awt 中的方法
 BufferCapabilities.FlipContents BufferCapabilities.getFlipContents()

参数类型为 BufferCapabilities.FlipContents 的 java.awt 中的方法
protected  void Component.FlipBufferStrategy.flip(BufferCapabilities.FlipContents flipAction)
将底层缓冲区的内容翻转移动到前台缓冲区，可通过复制或移动视频指针来执行。

参数类型为 BufferCapabilities.FlipContents 的 java.awt 中的构造方法
BufferCapabilities(ImageCapabilities frontCaps, ImageCapabilities backCaps, BufferCapabilities.FlipContents flipContents)
创建一个指定缓冲区能力的新对象

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Button 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Button
的使用

使用 Button 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Button 的使用

参数类型为 Button 的 java.awt 中的方法
protected abstract  java.awt.peer.ButtonPeer Toolkit.createButton(Button target)
使用指定同位体接口创建此工具包的 Button 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Button.AccessibleAWTButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Button.AccessibleAWTButton
的使用

没有 java.awt.Button.AccessibleAWTButton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Canvas 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Canvas
的使用

使用 Canvas 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Canvas 的使用

参数类型为 Canvas 的 java.awt 中的方法
protected abstract  java.awt.peer.CanvasPeer Toolkit.createCanvas(Canvas target)
使用指定同位体接口创建此工具包的 Canvas 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Canvas.AccessibleAWTCanvas 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Canvas.AccessibleAWTCanvas
的使用

没有 java.awt.Canvas.AccessibleAWTCanvas 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.CardLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.CardLayout
的使用

没有 java.awt.CardLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Checkbox 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Checkbox
的使用

使用 Checkbox 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Checkbox 的使用

返回 Checkbox 的 java.awt 中的方法
 Checkbox CheckboxGroup.getCurrent()
已过时。 从 JDK version 1.1 开始，由 getSelectedCheckbox() 取代。
 Checkbox CheckboxGroup.getSelectedCheckbox()
从此复选框组中获取当前选择。

参数类型为 Checkbox 的 java.awt 中的方法
protected abstract java.awt.peer.CheckboxPeer | Toolkit.createCheckbox(Checkbox target) 使用指定同位体接口创建此工具包的 Checkbox 实现。
void | CheckboxGroup.setCurrent(Checkbox box) 已过时。 从 JDK version 1.1 开始，由 setSelectedCheckbox(Checkbox) 取代。
void | CheckboxGroup.setSelectedCheckbox(Checkbox box) 将此组中当前选中的复选框设置为指定的复选框。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Checkbox.AccessibleAWTCheckbox 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Checkbox.AccessibleAWTCheckbox
的使用

没有 java.awt.Checkbox.AccessibleAWTCheckbox 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.CheckboxGroup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.CheckboxGroup
的使用

使用 CheckboxGroup 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 CheckboxGroup 的使用

返回 CheckboxGroup 的 java.awt 中的方法
 CheckboxGroup Checkbox.getCheckboxGroup()
确定此复选框的组。

参数类型为 CheckboxGroup 的 java.awt 中的方法
 void Checkbox.setCheckboxGroup(CheckboxGroup g)
将此复选框的组设置为指定复选框组。

参数类型为 CheckboxGroup 的 java.awt 中的构造方法
Checkbox(String label, boolean state, CheckboxGroup group)
构造具有指定标签的 Checkbox，并将它设置为指定状态，使它处于指定复选框组中。
Checkbox(String label, CheckboxGroup group, boolean state)
创建具有指定标签的 Checkbox，并使它处于指定复选框组内，将它设置为指定状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.CheckboxMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.CheckboxMenuItem
的使用

使用 CheckboxMenuItem 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 CheckboxMenuItem 的使用

参数类型为 CheckboxMenuItem 的 java.awt 中的方法
protected abstract  java.awt.peer.CheckboxMenuItemPeer Toolkit.createCheckboxMenuItem(CheckboxMenuItem target)
使用指定同位体接口创建此工具包的 CheckboxMenuItem 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
的使用

没有 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Choice 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Choice
的使用

使用 Choice 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Choice 的使用

参数类型为 Choice 的 java.awt 中的方法
protected abstract  java.awt.peer.ChoicePeer Toolkit.createChoice(Choice target)
使用指定同位体接口创建此工具包的 Choice 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Choice.AccessibleAWTChoice 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Choice.AccessibleAWTChoice
的使用

没有 java.awt.Choice.AccessibleAWTChoice 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Color 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Color
的使用

使用 Color 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 Color 的使用

java.awt 中 Color 的子类
 class SystemColor
封装表示系统中本机 GUI 对象颜色的象征性颜色的类。

声明为 Color 的 java.awt 中的字段
static Color | Color.black 黑色。
static Color | Color.BLACK 黑色。
static Color | Color.blue 蓝色。
static Color | Color.BLUE 蓝色。
static Color | Color.cyan 青色。
static Color | Color.CYAN 青色。
static Color | Color.DARK_GRAY 深灰色。
static Color | Color.darkGray 深灰色。
static Color | Color.gray 灰色。
static Color | Color.GRAY 灰色。
static Color | Color.green 绿色。
static Color | Color.GREEN 绿色。
static Color | Color.LIGHT_GRAY 浅灰色。
static Color | Color.lightGray 浅灰色。
static Color | Color.magenta 洋红色。
static Color | Color.MAGENTA 洋红色。
static Color | Color.orange 桔黄色。
static Color | Color.ORANGE 桔黄色。
static Color | Color.pink 粉红色。
static Color | Color.PINK 粉红色。
static Color | Color.red 红色。
static Color | Color.RED 红色。
static Color | Color.white 白色。
static Color | Color.WHITE 白色。
static Color | Color.yellow 黄色。
static Color | Color.YELLOW 黄色。

返回 Color 的 java.awt 中的方法
Color | Color.brighter() 创建一个新 Color，它具有比此 Color 更亮的颜色。
Color | Color.darker() 创建一个新 Color，它具有比此 Color 更暗的颜色。
static Color | Color.decode(String nm) 将 String 转换成整数，并返回指定的不透明 Color。
Color | List.AccessibleAWTList.AccessibleAWTListChild.getBackground() 获取此对象的背景颜色。
Color | TextComponent.getBackground() 获得此文本组件的背景色。
Color | MenuComponent.AccessibleAWTMenuComponent.getBackground() 获取此对象的背景色。
abstract Color | Graphics2D.getBackground() 返回用于清除区域的背景色。
Color | Component.getBackground() 获取组件的背景色。
Color | Component.AccessibleAWTComponent.getBackground() 获取此对象的背景色。
abstract Color | Graphics.getColor() 获取此图形上下文的当前颜色。
static Color | Color.getColor(String nm) 查找系统属性中的一种颜色。
static Color | Color.getColor(String nm, Color v) 查找系统属性中的一种颜色。
static Color | Color.getColor(String nm, int v) 查找系统属性中的一种颜色。
Color | GradientPaint.getColor1() 返回点 P1 的颜色 C1。
Color | GradientPaint.getColor2() 返回点 P2 的颜色 C2。
Color[] | MultipleGradientPaint.getColors() 返回此渐变所使用的颜色数组的副本。
Color | List.AccessibleAWTList.AccessibleAWTListChild.getForeground() 获取此对象的前景颜色。
Color | MenuComponent.AccessibleAWTMenuComponent.getForeground() 获取此对象的前景色。
Color | Component.getForeground() 获取组件的前景色。
Color | Component.AccessibleAWTComponent.getForeground() 获取此对象的前景色。
static Color | Color.getHSBColor(float h, float s, float b) 根据所指定的数值，创建一个基于 HSB 颜色模型的 Color 对象。
Color | Robot.getPixelColor(int x, int y) 返回给定屏幕坐标处的像素颜色。

参数类型为 Color 的 java.awt 中的方法
abstract boolean | Graphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 绘制指定图像中当前可用的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract boolean | Graphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
static Color | Color.getColor(String nm, Color v) 查找系统属性中的一种颜色。
void | List.AccessibleAWTList.AccessibleAWTListChild.setBackground(Color c) 设置此对象的背景颜色。
void | TextComponent.setBackground(Color c) 设置此文本组件的背景色。
void | MenuComponent.AccessibleAWTMenuComponent.setBackground(Color c) 设置此对象的背景色。
abstract void | Graphics2D.setBackground(Color color) 设置 Graphics2D 上下文的背景色。
void | Component.setBackground(Color c) 设置组件的背景色。
void | Component.AccessibleAWTComponent.setBackground(Color c) 设置此对象的背景色。
abstract void | Graphics.setColor(Color c) 将此图形上下文的当前颜色设置为指定颜色。
void | List.AccessibleAWTList.AccessibleAWTListChild.setForeground(Color c) 设置此对象的前景颜色。
void | MenuComponent.AccessibleAWTMenuComponent.setForeground(Color c) 设置此对象的前景色。
void | Component.setForeground(Color c) 设置组件的前景色。
void | Component.AccessibleAWTComponent.setForeground(Color c) 设置此对象的前景色。
abstract void | Graphics.setXORMode(Color c1) 将此图形上下文的绘图模式设置为在此图形上下文的当前颜色和新的指定颜色之间交替。

参数类型为 Color 的 java.awt 中的构造方法
GradientPaint(float x1, float y1, Color color1, float x2, float y2, Color color2)
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(float x1, float y1, Color color1, float x2, float y2, Color color2, boolean cyclic)
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
GradientPaint(Point2D pt1, Color color1, Point2D pt2, Color color2)
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(Point2D pt1, Color color1, Point2D pt2, Color color2, boolean cyclic)
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
LinearGradientPaint(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors)
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors)
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float[] fractions, Color[] colors)
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float fx, float fy, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors)
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。
RadialGradientPaint(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。

javax.accessibility 中 Color 的使用

返回 Color 的 javax.accessibility 中的方法
Color | AccessibleComponent.getBackground() 获取此对象的背景色。
Color | AccessibleComponent.getForeground() 获取此对象的前景色。

参数类型为 Color 的 javax.accessibility 中的方法
void | AccessibleComponent.setBackground(Color c) 设置此对象的背景色。
void | AccessibleComponent.setForeground(Color c) 设置此对象的前景色。

javax.swing 中 Color 的使用

声明为 Color 的 javax.swing 中的字段
protected Color | JTable.gridColor 网格的颜色。
protected Color | JTable.selectionBackground 已选定单元格的背景色。
protected Color | JTable.selectionForeground 已选定单元格的前景色。

返回 Color 的 javax.swing 中的方法
static Color | DebugGraphics.flashColor() 返回用于 flash 绘制操作的 Color。
Color | JTree.AccessibleJTree.AccessibleJTreeNode.getBackground() 获取此对象的背景色。
Color | JTable.AccessibleJTable.AccessibleJTableCell.getBackground() 获取此对象的背景色。
Color | JList.AccessibleJList.AccessibleJListChild.getBackground()
Color | JTabbedPane.getBackgroundAt(int index) 返回 index 位置的选项卡背景色。
Color | DebugGraphics.getColor() 返回用于文本绘制操作的 Color。
Color | JColorChooser.getColor() 获取颜色选取器的当前颜色值。
Color | UIDefaults.getColor(Object key) 如果 key 值为一个 Color，则返回它，否则返回 null。
static Color | UIManager.getColor(Object key) 从默认值返回一种颜色。
Color | UIDefaults.getColor(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Color，则返回它，否则返回 null。
static Color | UIManager.getColor(Object key, Locale l) 从适合给定语言环境的默认值中返回一种颜色。
Color | JTree.AccessibleJTree.AccessibleJTreeNode.getForeground() 获取此对象的前景色。
Color | JTable.AccessibleJTable.AccessibleJTableCell.getForeground() 获取此对象的前景色。
Color | JList.AccessibleJList.AccessibleJListChild.getForeground()
Color | JTabbedPane.getForegroundAt(int index) 返回 index 位置的选项卡背景色。
Color | JTable.getGridColor() 返回用来绘制网格线的颜色。
Color | JTable.getSelectionBackground() 返回选定单元格的背景色。
Color | JList.getSelectionBackground() 返回用于绘制选定项的背景的颜色。
Color | JTable.getSelectionForeground() 返回选定单元格的前景色。
Color | JList.getSelectionForeground() 返回用于绘制选定项的前景的颜色。
static Color | JColorChooser.showDialog(Component component, String title, Color initialColor) 显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。

参数类型为 Color 的 javax.swing 中的方法
static Border | BorderFactory.createBevelBorder(int type, Color highlight, Color shadow) 使用指定高亮显示和阴影显示方式来创建一个指定类型的斜面边框。
static Border | BorderFactory.createBevelBorder(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner) 创建一个指定类型的斜面边框，使用内部和外部高亮显示区域及阴影区域的指定颜色。
static Border | BorderFactory.createEtchedBorder(Color highlight, Color shadow) 使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
static Border | BorderFactory.createEtchedBorder(int type, Color highlight, Color shadow) 使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
static Border | BorderFactory.createLineBorder(Color color) 创建一个具有指定颜色的线边框。
static Border | BorderFactory.createLineBorder(Color color, int thickness) 创建一个具有指定颜色和宽度的线边框。
static MatteBorder | BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Color color) 使用纯色创建一个类似衬边的边框。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor) 向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
boolean | DebugGraphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
void | JTree.AccessibleJTree.AccessibleJTreeNode.setBackground(Color c) 设置此对象的背景色。
void | JTable.AccessibleJTable.AccessibleJTableCell.setBackground(Color c) 设置此对象的背景色。
void | JList.AccessibleJList.AccessibleJListChild.setBackground(Color c)
void | JComponent.setBackground(Color bg) 设置此组件的背景色。
void | JTabbedPane.setBackgroundAt(int index, Color background) 将 index 位置的背景色设置为 background，它可以为 null，在这种情况下选项卡的背景色默认为 tabbedpane 的背景色。
void | DebugGraphics.setColor(Color aColor) 设置用于绘制和填充线条和图形的颜色。
void | JColorChooser.setColor(Color color) 将颜色选取器的当前颜色设置为指定颜色。
static void | DebugGraphics.setFlashColor(Color flashColor) 设置用于 flash 绘制操作的 Color。
void | JTree.AccessibleJTree.AccessibleJTreeNode.setForeground(Color c)
void | JTable.AccessibleJTable.AccessibleJTableCell.setForeground(Color c) 设置此对象的前景色。
void | JList.AccessibleJList.AccessibleJListChild.setForeground(Color c)
void | JComponent.setForeground(Color fg) 设置此组件的前景色。
void | JTabbedPane.setForegroundAt(int index, Color foreground) 将 index 位置的前景色设置为 foreground，它可以为 null，在这种情况下选项卡的前景色默认为此 tabbedpane 的前景色。
void | JTable.setGridColor(Color gridColor) 将用来绘制网格线的颜色设置为 gridColor 并重新显示它。
void | JTable.setSelectionBackground(Color selectionBackground) 设置选定单元格的背景色。
void | JList.setSelectionBackground(Color selectionBackground) 设置用于绘制选定项的背景的颜色，单元渲染器可以使用此颜色填充所选单元。
void | JTable.setSelectionForeground(Color selectionForeground) 设置选定单元格的前景色。
void | JList.setSelectionForeground(Color selectionForeground) 设置用于绘制选定项的前景的颜色，单元渲染器可以使用此颜色呈现文本和图形。
void | DebugGraphics.setXORMode(Color aColor) 重写 Graphics.setXORMode。
static Color | JColorChooser.showDialog(Component component, String title, Color initialColor) 显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。

参数类型为 Color 的 javax.swing 中的构造方法
JColorChooser(Color initialColor)
创建具有指定初始颜色的颜色选取器窗格。

javax.swing.border 中 Color 的使用

声明为 Color 的 javax.swing.border 中的字段
protected Color | MatteBorder.color
protected Color | EtchedBorder.highlight
protected Color | BevelBorder.highlightInner
protected Color | BevelBorder.highlightOuter
protected Color | LineBorder.lineColor
protected Color | EtchedBorder.shadow
protected Color | BevelBorder.shadowInner
protected Color | BevelBorder.shadowOuter
protected Color | TitledBorder.titleColor

返回 Color 的 javax.swing.border 中的方法
Color | EtchedBorder.getHighlightColor() 返回浮雕化边框的高亮显示颜色。
Color | EtchedBorder.getHighlightColor(Component c) 返回浮雕化边框在指定组件上呈现的高亮显示颜色。
Color | BevelBorder.getHighlightInnerColor() 返回斜面边框内部的高亮显示颜色。
Color | BevelBorder.getHighlightInnerColor(Component c) 返回斜面边框在指定组件上呈现的内部高亮显示颜色。
Color | BevelBorder.getHighlightOuterColor() 返回斜面边框外部的高亮显示颜色。
Color | BevelBorder.getHighlightOuterColor(Component c) 返回斜面边框在指定组件上呈现的外部高亮显示颜色。
Color | LineBorder.getLineColor() 返回边框的颜色。
Color | MatteBorder.getMatteColor() 返回平铺边框的颜色，如果使用了平铺图标，则返回 null。
Color | EtchedBorder.getShadowColor() 返回浮雕化边框的阴影颜色。
Color | EtchedBorder.getShadowColor(Component c) 返回浮雕化边框在指定组件上呈现的阴影颜色。
Color | BevelBorder.getShadowInnerColor() 返回斜面边框内部的阴影颜色。
Color | BevelBorder.getShadowInnerColor(Component c) 返回斜面边框在指定组件上呈现的内部阴影颜色。
Color | BevelBorder.getShadowOuterColor() 返回斜面边框的外部阴影颜色。
Color | BevelBorder.getShadowOuterColor(Component c) 返回斜面边框在指定组件上呈现的外部阴影颜色。
Color | TitledBorder.getTitleColor() 返回带标题边框的标题颜色。

参数类型为 Color 的 javax.swing.border 中的方法
 void TitledBorder.setTitleColor(Color titleColor)
设置带标题边框的标题颜色。

参数类型为 Color 的 javax.swing.border 中的构造方法
BevelBorder(int bevelType, Color highlight, Color shadow)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
BevelBorder(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
EtchedBorder(Color highlight, Color shadow)
创建具有指定高亮显示和阴影颜色的阴刻浮雕化边框
EtchedBorder(int etchType, Color highlight, Color shadow)
创建具有指定蚀刻类型、高亮显示和阴影颜色的浮雕化边框
LineBorder(Color color)
创建具有指定颜色、厚度为 1（thickness = 1）的线边框。
LineBorder(Color color, int thickness)
创建具有指定颜色和厚度的线边框。
LineBorder(Color color, int thickness, boolean roundedCorners)
创建具有指定颜色、厚度和拐角形状的线条边框。
MatteBorder(Insets borderInsets, Color matteColor)
创建具有指定 insets 和颜色的衬边边框。
MatteBorder(int top, int left, int bottom, int right, Color matteColor)
创建具有指定 insets 和颜色的衬边边框。
SoftBevelBorder(int bevelType, Color highlight, Color shadow)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
SoftBevelBorder(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。

javax.swing.colorchooser 中 Color 的使用

返回 Color 的 javax.swing.colorchooser 中的方法
protected Color | AbstractColorChooserPanel.getColorFromModel() 返回当前所选取的颜色。
Color | ColorSelectionModel.getSelectedColor() 返回所选取的 Color，它不应为 null。
Color | DefaultColorSelectionModel.getSelectedColor() 返回所选取的 Color，它不应为 null。

参数类型为 Color 的 javax.swing.colorchooser 中的方法
void | ColorSelectionModel.setSelectedColor(Color color) 将选取的颜色设置为 color。
void | DefaultColorSelectionModel.setSelectedColor(Color color) 将选取的颜色设置为 color。

参数类型为 Color 的 javax.swing.colorchooser 中的构造方法
DefaultColorSelectionModel(Color color)
创建一个 DefaultColorSelectionModel，其当前颜色被设置为 color，该颜色不应为 null。

javax.swing.plaf 中 Color 的使用

javax.swing.plaf 中 Color 的子类
 class ColorUIResource

参数类型为 Color 的 javax.swing.plaf 中的构造方法
BorderUIResource.BevelBorderUIResource(int bevelType, Color highlight, Color shadow)
BorderUIResource.BevelBorderUIResource(int bevelType, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
BorderUIResource.EtchedBorderUIResource(Color highlight, Color shadow)
BorderUIResource.EtchedBorderUIResource(int etchType, Color highlight, Color shadow)
BorderUIResource.LineBorderUIResource(Color color)
BorderUIResource.LineBorderUIResource(Color color, int thickness)
BorderUIResource.MatteBorderUIResource(int top, int left, int bottom, int right, Color color)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
ColorUIResource(Color c)

javax.swing.plaf.basic 中 Color 的使用

声明为 Color 的 javax.swing.plaf.basic 中的字段
protected Color | BasicMenuItemUI.acceleratorForeground
protected Color | BasicMenuItemUI.acceleratorSelectionForeground
protected Color | BasicBorders.ButtonBorder.darkShadow
protected Color | BasicBorders.FieldBorder.darkShadow
protected Color | BasicTabbedPaneUI.darkShadow
protected Color | BasicMenuItemUI.disabledForeground
protected Color | BasicToolBarUI.dockingBorderColor
protected Color | BasicToolBarUI.dockingColor
protected Color | BasicToolBarUI.floatingBorderColor
protected Color | BasicToolBarUI.floatingColor
protected Color | BasicTabbedPaneUI.focus
protected Color | BasicBorders.ButtonBorder.highlight
protected Color | BasicBorders.FieldBorder.highlight
protected Color | BasicBorders.SplitPaneBorder.highlight
protected Color | BasicTabbedPaneUI.highlight
protected Color | BasicSeparatorUI.highlight
protected Color | BasicBorders.ButtonBorder.lightHighlight
protected Color | BasicBorders.FieldBorder.lightHighlight
protected Color | BasicTabbedPaneUI.lightHighlight
protected Color | BasicInternalFrameTitlePane.notSelectedTextColor
protected Color | BasicInternalFrameTitlePane.notSelectedTitleColor
protected Color | BasicInternalFrameTitlePane.selectedTextColor
protected Color | BasicInternalFrameTitlePane.selectedTitleColor
protected Color | BasicMenuItemUI.selectionBackground
protected Color | BasicMenuItemUI.selectionForeground
protected Color | BasicBorders.ButtonBorder.shadow
protected Color | BasicBorders.FieldBorder.shadow
protected Color | BasicBorders.SplitPaneBorder.shadow
protected Color | BasicTabbedPaneUI.shadow
protected Color | BasicSeparatorUI.shadow
protected Color | BasicScrollBarUI.thumbColor
protected Color | BasicScrollBarUI.thumbDarkShadowColor
protected Color | BasicScrollBarUI.thumbHighlightColor
protected Color | BasicScrollBarUI.thumbLightShadowColor
protected Color | BasicScrollBarUI.trackColor
protected Color | BasicScrollBarUI.trackHighlightColor

返回 Color 的 javax.swing.plaf.basic 中的方法
Color | BasicToolBarUI.DragWindow.getBorderColor()
Color | BasicToolBarUI.getDockingColor() 获取在连接 (docking) 区域上时显示的颜色。
Color | BasicToolBarUI.getFloatingColor() 获取在浮动区域上时显示的颜色。
protected Color | BasicSliderUI.getFocusColor()
protected Color | BasicTreeUI.getHashColor()
protected Color | BasicSliderUI.getHighlightColor()
protected Color | BasicProgressBarUI.getSelectionBackground() 如果在进度条的未填充区域上绘制文本，则文本的颜色为 "selectionBackground"。
protected Color | BasicProgressBarUI.getSelectionForeground() 如果在进度条的填充区域上绘制文本，文本的颜色为 "selectionForeground"。
protected Color | BasicSliderUI.getShadowColor()

参数类型为 Color 的 javax.swing.plaf.basic 中的方法
static void | BasicGraphicsUtils.drawBezel(Graphics g, int x, int y, int w, int h, boolean isPressed, boolean isDefault, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void | BasicGraphicsUtils.drawEtchedRect(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void | BasicGraphicsUtils.drawGroove(Graphics g, int x, int y, int w, int h, Color shadow, Color highlight)
static void | BasicGraphicsUtils.drawLoweredBezel(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
protected void | BasicMenuItemUI.paintBackground(Graphics g, JMenuItem menuItem, Color bgColor) 绘制菜单项的背景。
protected void | BasicMenuItemUI.paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
void | BasicToolBarUI.DragWindow.setBorderColor(Color c)
void | BasicToolBarUI.setDockingColor(Color c) 设置在连接区域上时显示的颜色。
void | BasicToolBarUI.setFloatingColor(Color c) 设置在浮动区域上时显示的颜色。
protected void | BasicTreeUI.setHashColor(Color color)

参数类型为 Color 的 javax.swing.plaf.basic 中的构造方法
BasicArrowButton(int direction, Color background, Color shadow, Color darkShadow, Color highlight)
创建一个在指定方向上绘制其箭头并具有指定颜色的 BasicArrowButton。
BasicBorders.ButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
BasicBorders.FieldBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
BasicBorders.MenuBarBorder(Color shadow, Color highlight)
BasicBorders.RadioButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
BasicBorders.RolloverButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
BasicBorders.SplitPaneBorder(Color highlight, Color shadow)
BasicBorders.ToggleButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)

javax.swing.plaf.metal 中 Color 的使用

声明为 Color 的 javax.swing.plaf.metal 中的字段
protected static Color | MetalSliderUI.darkShadowColor
protected Color | MetalRadioButtonUI.disabledTextColor
protected Color | MetalToggleButtonUI.disabledTextColor
protected Color | MetalButtonUI.disabledTextColor
protected Color | MetalRadioButtonUI.focusColor
protected Color | MetalToggleButtonUI.focusColor
protected Color | MetalButtonUI.focusColor
protected static Color | MetalSliderUI.highlightColor
protected Color | MetalRadioButtonUI.selectColor
protected Color | MetalTabbedPaneUI.selectColor
protected Color | MetalToggleButtonUI.selectColor
protected Color | MetalButtonUI.selectColor
protected Color | MetalTabbedPaneUI.selectHighlight
protected Color | MetalTabbedPaneUI.tabAreaBackground
protected static Color | MetalSliderUI.thumbColor

返回 Color 的 javax.swing.plaf.metal 中的方法
protected Color | MetalTabbedPaneUI.getColorForGap(int currentRun, int x, int y)
protected Color | MetalRadioButtonUI.getDisabledTextColor()
protected Color | MetalToggleButtonUI.getDisabledTextColor()
protected Color | MetalButtonUI.getDisabledTextColor()
protected Color | MetalRadioButtonUI.getFocusColor()
protected Color | MetalToggleButtonUI.getFocusColor()
protected Color | MetalButtonUI.getFocusColor()
protected Color | MetalRadioButtonUI.getSelectColor()
protected Color | MetalToggleButtonUI.getSelectColor()
protected Color | MetalButtonUI.getSelectColor()

javax.swing.plaf.synth 中 Color 的使用

返回 Color 的 javax.swing.plaf.synth 中的方法
Color | SynthStyle.getColor(SynthContext context, ColorType type) 返回指定状态的颜色。
protected abstract Color | SynthStyle.getColorForState(SynthContext context, ColorType type) 返回指定状态的颜色。

javax.swing.table 中 Color 的使用

返回 Color 的 javax.swing.table 中的方法
Color | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getBackground()
Color | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getForeground()

参数类型为 Color 的 javax.swing.table 中的方法
void | DefaultTableCellRenderer.setBackground(Color c) 重写 JComponent.setBackground 将未选定单元格的背景色分配为指定颜色。
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setBackground(Color c)
void | DefaultTableCellRenderer.setForeground(Color c) 重写 JComponent.setForeground 将未选定单元格的前景色分配为指定颜色。
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setForeground(Color c)

javax.swing.text 中 Color 的使用

返回 Color 的 javax.swing.text 中的方法
Color | GlyphView.getBackground() 获取用于呈现字形的背景色。
Color | LabelView.getBackground() 获取用于呈现字形的背景色。
Color | DefaultStyledDocument.getBackground(AttributeSet attr) 从属性集获得背景颜色。
Color | StyledDocument.getBackground(AttributeSet attr) 使用一个属性集并将其转换为一个背景色规范。
static Color | StyleConstants.getBackground(AttributeSet a) 从属性列表中获取背景色设置。
Color | StyleContext.getBackground(AttributeSet attr) 使用一个属性集并将其转换成为一个背景色规范。
Color | JTextComponent.getCaretColor() 获取用于呈现插入符的当前颜色。
Color | DefaultHighlighter.DefaultHighlightPainter.getColor() 返回高亮显示的颜色。
Color | JTextComponent.getDisabledTextColor() 获取用于呈现禁用文本的当前颜色。
Color | GlyphView.getForeground() 获取用于呈现字形的前景色。
Color | LabelView.getForeground() 获取用于呈现字形的前景色。
Color | DefaultStyledDocument.getForeground(AttributeSet attr) 从属性集获得前景色。
Color | StyledDocument.getForeground(AttributeSet attr) 使用一个属性集并将其转换成为一个前景色规范。
static Color | StyleConstants.getForeground(AttributeSet a) 从属性列表中获取前景色设置。
Color | StyleContext.getForeground(AttributeSet attr) 使用一个属性集并将其转换成为一个前景色规范。
Color | JTextComponent.getSelectedTextColor() 获取用于呈现选定文本的当前颜色。
Color | JTextComponent.getSelectionColor() 获取用于呈现选定的当前颜色。

参数类型为 Color 的 javax.swing.text 中的方法
protected void | LabelView.setBackground(Color bg) 设置视图的背景色。
static void | StyleConstants.setBackground(MutableAttributeSet a, Color fg) 设置背景色。
void | JTextComponent.setCaretColor(Color c) 设置用于呈现插入符的当前颜色。
void | JTextComponent.setDisabledTextColor(Color c) 设置用于呈现禁用文本的当前颜色。
static void | StyleConstants.setForeground(MutableAttributeSet a, Color fg) 设置前景色。
void | JTextComponent.setSelectedTextColor(Color c) 设置用于呈现选定文本的当前颜色。
void | JTextComponent.setSelectionColor(Color c) 设置用于呈现选定的当前颜色。

参数类型为 Color 的 javax.swing.text 中的构造方法
DefaultHighlighter.DefaultHighlightPainter(Color c)
构造新的高亮显示 painter。
StyledEditorKit.ForegroundAction(String nm, Color fg)
创建新的 ForegroundAction。

javax.swing.text.html 中 Color 的使用

返回 Color 的 javax.swing.text.html 中的方法
Color | StyleSheet.getBackground(AttributeSet a) 获取一个属性集并将其转换为背景色规范。
Color | StyleSheet.getForeground(AttributeSet a) 获取一个属性集并将其转换为前景色规范。
Color | StyleSheet.stringToColor(String string) 将颜色字符串（如 "RED" 或 "#NNNNNN"）转换为 Color。

javax.swing.tree 中 Color 的使用

声明为 Color 的 javax.swing.tree 中的字段
protected Color | DefaultTreeCellRenderer.backgroundNonSelectionColor 不选定节点时用于背景的颜色。
protected Color | DefaultTreeCellRenderer.backgroundSelectionColor 选定节点时用于背景的颜色。
protected Color | DefaultTreeCellEditor.borderSelectionColor 如果应绘制边框选择色，则为 true。
protected Color | DefaultTreeCellRenderer.borderSelectionColor 节点具有焦点时，用于焦点指示符的颜色。
protected Color | DefaultTreeCellRenderer.textNonSelectionColor 用于非选定节点的前景颜色。
protected Color | DefaultTreeCellRenderer.textSelectionColor 用于选定节点的前景颜色。

返回 Color 的 javax.swing.tree 中的方法
Color | DefaultTreeCellRenderer.getBackgroundNonSelectionColor() 返回用于非选定节点的背景色。
Color | DefaultTreeCellRenderer.getBackgroundSelectionColor() 返回在选定节点的情况下背景所使用的颜色。
Color | DefaultTreeCellEditor.getBorderSelectionColor() 返回绘制边框的颜色。
Color | DefaultTreeCellRenderer.getBorderSelectionColor() 返回绘制边框时所使用的颜色。
Color | DefaultTreeCellRenderer.getTextNonSelectionColor() 返回未选定节点时绘制文本所使用的颜色。
Color | DefaultTreeCellRenderer.getTextSelectionColor() 返回选定节点时绘制文本所使用的颜色。

参数类型为 Color 的 javax.swing.tree 中的方法
void | DefaultTreeCellRenderer.setBackground(Color color) 创建子类，以便将 ColorUIResource 映射为 null。
void | DefaultTreeCellRenderer.setBackgroundNonSelectionColor(Color newColor) 设置用于非选定节点的背景色。
void | DefaultTreeCellRenderer.setBackgroundSelectionColor(Color newColor) 设置在选定节点的情况下背景所使用的颜色。
void | DefaultTreeCellEditor.setBorderSelectionColor(Color newColor) 设置用于边框的颜色。
void | DefaultTreeCellRenderer.setBorderSelectionColor(Color newColor) 设置用于边框的颜色。
void | DefaultTreeCellRenderer.setTextNonSelectionColor(Color newColor) 设置选定节点时绘制文本所使用的颜色。
void | DefaultTreeCellRenderer.setTextSelectionColor(Color newColor) 设置选定节点时绘制文本所使用的颜色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Component 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component
的使用

使用 Component 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 Component 的使用

java.applet 中 Component 的子类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 Component 的使用

java.awt 中 Component 的子类
class | Button 此类创建一个标签按钮。
class | Canvas Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
class | Choice Choice 类表示一个弹出式选择菜单。
class | Container 一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。
class | Label Label 对象是一个可在容器中放置文本的组件。
class | List List 组件为用户提供了一个可滚动的文本项列表。
class | Panel Panel 是最简单的容器类。
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
class | TextArea TextArea 对象是显示文本的多行区域。
class | TextComponent TextComponent 类是所有允许编辑文本的组件的超类。
class | TextField TextField 对象是允许编辑单行文本的文本组件。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。

类型参数类型为 Component 的 java.awt 中的字段
protected  Hashtable<Component,GridBagConstraints> GridBagLayout.comptable
此哈希表维持组件与其网格包约束之间的关联。

返回 Component 的 java.awt 中的方法
 Component Container.add(Component comp)
将指定组件追加到此容器的尾部。
 Component Container.add(Component comp, int index)
将指定组件添加到此容器的给定位置上。
 Component Container.add(String name, Component comp)
将指定组件添加到此容器中。
 Component Container.findComponentAt(int x, int y)
对包含指定位置的可视子组件进行定位。
 Component Container.findComponentAt(Point p)
对包含指定点的可视子组件进行定位。
 Component Container.getComponent(int n)
获取此容器中的第 n 个组件。
 Component ContainerOrderFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。
abstract  Component FocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 之后的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或者焦点遍历策略提供者。
 Component Container.getComponentAt(int x, int y)
对包含 x，y 位置的组件进行定位。
 Component Component.getComponentAt(int x, int y)
确定此组件或其直接子组件之一是否包含（x，y）位置，并且如果是，则返回包含该位置的组件。
 Component Container.getComponentAt(Point p)
获取包含指定点的组件。
 Component Component.getComponentAt(Point p)
返回包含指定点的组件或子组件。
 Component ContainerOrderFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。
abstract  Component FocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 之前的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或焦点遍历策略提供者。
 Component[] Container.getComponents()
获取此容器中的所有组件。
 Component ContainerOrderFocusTraversalPolicy.getDefaultComponent(Container aContainer)
返回默认拥有焦点的 Component。
abstract  Component FocusTraversalPolicy.getDefaultComponent(Container aContainer)
返回要聚焦的默认 Component。
 Component ContainerOrderFocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
abstract  Component FocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
 Component KeyboardFocusManager.getFocusOwner()
如果焦点所有者与调用线程位于同一个上下文中，则返回该焦点所有者。
 Component Window.getFocusOwner()
如果此窗口为焦点窗口，则返回是焦点窗口的子组件；否则返回 null。
protected  Component KeyboardFocusManager.getGlobalFocusOwner()
返回焦点所有者，即使调用线程处于焦点所有者之外的上下文中。
protected  Component KeyboardFocusManager.getGlobalPermanentFocusOwner()
返回持久焦点所有者，即使调用线程处于该持久焦点所有者之外的上下文中。
 Component FocusTraversalPolicy.getInitialComponent(Window window)
返回第一次将窗口设置为可见时，应该接收焦点的 Component。
 Component ContainerOrderFocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
abstract  Component FocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
 Component BorderLayout.getLayoutComponent(Container target, Object constraints)
基于目标 Container 的组件方向，返回给定约束位置对应的组件。
 Component BorderLayout.getLayoutComponent(Object constraints)
获取使用给定约束添加的组件。
 Component Window.getMostRecentFocusOwner()
返回此窗口的子组件，该子组件在此窗口为焦点窗口时将接收焦点。
 Component KeyboardFocusManager.getPermanentFocusOwner()
如果持久焦点所有者与调用线程位于同一个上下文中，则返回持久焦点所有者。
 Component Container.locate(int x, int y)
已过时。 从 JDK version 1.1 开始，用 getComponentAt(int, int) 取代。
 Component Component.locate(int x, int y)
已过时。 从 JDK version 1.1 开始，由 getComponentAt(int, int) 取代。

参数类型为 Component 的 java.awt 中的方法
protected  boolean DefaultFocusTraversalPolicy.accept(Component aComponent)
确定是否可以接受选择某个 Component 作为新的焦点所有者。
protected  boolean ContainerOrderFocusTraversalPolicy.accept(Component aComponent)
确定是否可以接受选择某个 Component 作为新的焦点拥有者。
 Component Container.add(Component comp)
将指定组件追加到此容器的尾部。
 Component Container.add(Component comp, int index)
将指定组件添加到此容器的给定位置上。
 void Container.add(Component comp, Object constraints)
将指定的组件添加到此容器的尾部。
 void Container.add(Component comp, Object constraints, int index)
使用指定约束，将指定组件添加到此容器的指定索引所在的位置上。
 Component Container.add(String name, Component comp)
将指定组件添加到此容器中。
protected  void ScrollPane.addImpl(Component comp, Object constraints, int index)
将指定的组件添加到此滚动窗格容器。
protected  void Container.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上。
 void GridBagLayout.addLayoutComponent(Component comp, Object constraints)
使用指定 constraints 对象将指定组件添加到布局中。
 void CardLayout.addLayoutComponent(Component comp, Object constraints)
将指定的组件添加到此卡片布局的内部名称表。
 void BorderLayout.addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。
 void LayoutManager2.addLayoutComponent(Component comp, Object constraints)
使用指定约束对象，将指定组件添加到布局。
 void GridBagLayout.addLayoutComponent(String name, Component comp)
无效，因为此布局管理器不使用每组件字符串。
 void GridLayout.addLayoutComponent(String name, Component comp)
将具有指定名称的指定组件添加到布局。
 void CardLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。
 void FlowLayout.addLayoutComponent(String name, Component comp)
将指定的组件添加到布局中。
 void BorderLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。
 void LayoutManager.addLayoutComponent(String name, Component comp)
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
protected  java.awt.peer.LightweightPeer Toolkit.createComponent(Component target)
创建组件或容器的同位体。
<T extends DragGestureRecognizer>
T
Toolkit.createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。
protected  void DefaultKeyboardFocusManager.dequeueKeyEvents(long after, Component untilFocused)
释放正常指派到当前焦点所有者的所有 KeyEvent，这些 KeyEvent 因为调用了具有相同时间戳和 Component 的 enqueueKeyEvents 而被加入队列。
protected abstract  void KeyboardFocusManager.dequeueKeyEvents(long after, Component untilFocused)
由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。
protected  void DefaultKeyboardFocusManager.discardKeyEvents(Component comp)
放弃因为一次或多次调用具有指定 Component 或其子代之一的 enqueueKeyEvents 而加入队列的所有 KeyEvent。
protected abstract  void KeyboardFocusManager.discardKeyEvents(Component comp)
由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。
protected  void DefaultKeyboardFocusManager.enqueueKeyEvents(long after, Component untilFocused)
延迟对 KeyEvent 的指派，直到指定的 Component 成为焦点所有者。
protected abstract  void KeyboardFocusManager.enqueueKeyEvents(long after, Component untilFocused)
在指定的 Component 成为焦点所有者以前由 AWT 调用，以通知 KeyboardFocusManager 延迟指派 KeyEvent。
 void DefaultKeyboardFocusManager.focusNextComponent(Component aComponent)
使 aComponent 后面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。
abstract  void KeyboardFocusManager.focusNextComponent(Component aComponent)
聚焦 aComponent 之后的 Component，通常基于 FocusTraversalPolicy。
 void DefaultKeyboardFocusManager.focusPreviousComponent(Component aComponent)
使 aComponent 前面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。
abstract  void KeyboardFocusManager.focusPreviousComponent(Component aComponent)
聚焦 aComponent 之前的 Component，通常基于 FocusTraversalPolicy。
 Component ContainerOrderFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。
abstract  Component FocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 之后的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或者焦点遍历策略提供者。
 Component ContainerOrderFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。
abstract  Component FocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 之前的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或焦点遍历策略提供者。
 int Container.getComponentZOrder(Component comp)
返回容器内组件的 z 顺序索引。
 GridBagConstraints GridBagLayout.getConstraints(Component comp)
获取指定组件的约束。
 Object BorderLayout.getConstraints(Component comp)
获取指定组件的约束
protected static Container Toolkit.getNativeContainer(Component c)
使本机同位体能够查询给定本机组件的本机容器（例如，直接父组件可以是轻量级的）。
 boolean Container.isAncestorOf(Component c)
检查该组件是否包含在此容器的组件层次结构中。
protected  GridBagConstraints GridBagLayout.lookupConstraints(Component comp)
检索指定组件的约束。
 void DefaultKeyboardFocusManager.processKeyEvent(Component focusedComponent, KeyEvent e)
当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法才会启动一个焦点遍历操作。
abstract  void KeyboardFocusManager.processKeyEvent(Component focusedComponent, KeyEvent e)
当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法启动焦点遍历操作。
 void KeyboardFocusManager.redispatchEvent(Component target, AWTEvent e)
重新指派 AWTEvent 的方式是，AWT 事件调度程序不会递归式请求 KeyboardFocusManager 或任何已安装的 KeyEventDispatcher 再次指派该事件。
 void Container.remove(Component comp)
从此容器中移除指定组件。
 void GridBagLayout.removeLayoutComponent(Component comp)
从此布局移除指定组件。
 void GridLayout.removeLayoutComponent(Component comp)
从布局移除指定组件。
 void CardLayout.removeLayoutComponent(Component comp)
从布局中移除指定的组件。
 void FlowLayout.removeLayoutComponent(Component comp)
从布局中移除指定的组件。
 void BorderLayout.removeLayoutComponent(Component comp)
从此边框布局中移除指定组件。
 void LayoutManager.removeLayoutComponent(Component comp)
从布局移除指定组件。
 void Container.setComponentZOrder(Component comp, int index)
将指定组件移动到容器中指定的 z 顺序索引。
 void GridBagLayout.setConstraints(Component comp, GridBagConstraints constraints)
设置此布局中指定组件的约束条件。
protected  void KeyboardFocusManager.setGlobalFocusOwner(Component focusOwner)
设置焦点所有者。
protected  void KeyboardFocusManager.setGlobalPermanentFocusOwner(Component permanentFocusOwner)
设置持久焦点所有者。
 void Window.setLocationRelativeTo(Component c)
设置窗口相对于指定组件的位置。
 void PopupMenu.show(Component origin, int x, int y)
在相对于初始组件的 x、y 位置上显示弹出式菜单。
 void DefaultKeyboardFocusManager.upFocusCycle(Component aComponent)
将焦点上移一个焦点遍历循环。
abstract  void KeyboardFocusManager.upFocusCycle(Component aComponent)
将焦点上移一个焦点遍历循环。

参数类型为 Component 的 java.awt 中的构造方法
MediaTracker(Component comp)
创建媒体跟踪器以跟踪给定组件的图像。

java.awt.dnd 中 Component 的使用

声明为 Component 的 java.awt.dnd 中的字段
protected  Component DragGestureRecognizer.component
与此 DragGestureRecognizer 关联的 Component。

返回 Component 的 java.awt.dnd 中的方法
Component | DragGestureEvent.getComponent() 返回与此 DragGestureEvent 关联的 Component。
Component | DragGestureRecognizer.getComponent() 此方法返回 DragGestureRecognizer 所“观察”的 Component，以便了解拖动开始动作。
Component | DragSourceContext.getComponent() 返回与此 DragSourceContext 关联的 Component。
Component | DropTargetContext.getComponent() 此方法返回与此 DropTargetContext 相关的 Component。
Component | DropTarget.getComponent() 获取与此 DropTarget 关联的 Component。

参数类型为 Component 的 java.awt.dnd 中的方法
 DragGestureRecognizer DragSource.createDefaultDragGestureRecognizer(Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，为此 DragSource 实现 DragGestureRecognizer 的默认抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
<T extends DragGestureRecognizer>
T
DragSource.createDragGestureRecognizer(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
protected  DropTarget.DropTargetAutoScroller DropTarget.createDropTargetAutoScroller(Component c, Point p)
创建一个嵌入式自动滚动条
 void DragGestureRecognizer.setComponent(Component c)
设置与该 DragGestureRecognizer 关联的 Component 使用此方法时还会调用 registerListeners() 和 unregisterListeners()。
 void DropTarget.setComponent(Component c)
注意：要求此接口允许 DropTarget 以下面两种方式之一与 Component 安全关联：component.setDropTarget(droptarget) 或 droptarget.setComponent(component)。

参数类型为 Component 的 java.awt.dnd 中的构造方法
DragGestureRecognizer(DragSource ds, Component c)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource 和此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component。
DragGestureRecognizer(DragSource ds, Component c, int sa)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component 和此 Drag 和 Drop 操作所支持的动作。
DragGestureRecognizer(DragSource ds, Component c, int sa, DragGestureListener dgl)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component、此 Drag 和 Drop 操作所支持的操作和一旦检测到拖动开始动作要通知的 DragGestureListener。
DropTarget.DropTargetAutoScroller(Component c, Point p)
构造一个 DropTargetAutoScroller
DropTarget(Component c, DropTargetListener dtl)
在给出与之关联的 Component 和执行事件处理的 DropTargetListener 的情况下创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值和执行事件处理的 DropTargetListener 的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener 和表示 DropTarget 当前是否接受 drop 的 boolean 值的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。
MouseDragGestureRecognizer(DragSource ds, Component c)
给出 Component c 的 DragSource、要观察的 Component，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource ds, Component c, int act)
给出 Component c 的 DragSource、要观察的 Component，以及此拖动操作允许的操作，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource ds, Component c, int act, DragGestureListener dgl)
给出 Component c 的 DragSource、要观察的 Component、此拖动操作允许的操作，以及检测到拖动动作时发出通知的 DragGestureListener，构造一个新的 MouseDragGestureRecognizer。

java.awt.event 中 Component 的使用

返回 Component 的 java.awt.event 中的方法
Component | HierarchyEvent.getChanged() 返回位于被更改层次结构顶部的 Component。
Component | ContainerEvent.getChild() 返回受事件影响的组件。
Component | HierarchyEvent.getComponent() 返回事件的始发者。
Component | ComponentEvent.getComponent() 返回事件的始发者。
Component | FocusEvent.getOppositeComponent() 返回此焦点更改中涉及的另一个 Component。

参数类型为 Component 的 java.awt.event 中的构造方法
ComponentEvent(Component source, int id)
构造一个 ComponentEvent 对象。
ContainerEvent(Component source, int id, Component child)
构造一个 ContainerEvent 对象。
FocusEvent(Component source, int id)
构造一个 FocusEvent 对象，并将它标识为一个持久性焦点更改。
FocusEvent(Component source, int id, boolean temporary)
构造一个 FocusEvent 对象，并将标识更改是否为暂时的。
FocusEvent(Component source, int id, boolean temporary, Component opposite)
构造一个 FocusEvent 对象，它具有指定的暂时状态和对立 Component。
HierarchyEvent(Component source, int id, Component changed, Container changedParent)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
HierarchyEvent(Component source, int id, Component changed, Container changedParent, long changeFlags)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
InputMethodEvent(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、时间、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、插入符和 visiblePosition 来构造 InputMethodEvent。
KeyEvent(Component source, int id, long when, int modifiers, int keyCode)
已过时。 从 JDK1.1 开始
KeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar)
构造一个 KeyEvent 对象。
KeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, int keyLocation)
MouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger)
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。
MouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int button)
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。
MouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int button)
构造一个具有指定源组件、类型、修饰符、相对坐标、绝对坐标和单击计数的 MouseEvent 对象。
MouseWheelEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation)
构造一个具有指定源组件、类型、修改键、坐标、滚动类型、滚动量和滚轮旋转的 MouseWheelEvent。
MouseWheelEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation)
构造一个具有指定源组件、类型、修改键、坐标、绝对坐标、滚动类型、滚动量和滚轮滚动的 MouseWheelEvent 对象。
PaintEvent(Component source, int id, Rectangle updateRect)
构造一个具有指定源组件和类型的 PaintEvent 对象。

java.awt.im 中 Component 的使用

参数类型为 Component 的 java.awt.im 中的方法
 void InputContext.removeNotify(Component client)
通知输入上下文，客户端组件已从它的包含层次结构中移除，或该组件已禁用输入方法支持。

java.beans 中 Component 的使用

返回 Component 的 java.beans 中的方法
Component | PropertyEditor.getCustomEditor() PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。
Component | PropertyEditorSupport.getCustomEditor() PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。

java.beans.beancontext 中 Component 的使用

返回 Component 的 java.beans.beancontext 中的方法
 Component BeanContextChildComponentProxy.getComponent()
获得与此 BeanContextChild 相关联的 java.awt.Component。

javax.swing 中 Component 的使用

javax.swing 中 Component 的子类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JComponent 该类是除顶层容器外所有 Swing 组件的基类。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JDialog 创建对话框窗口的主要类。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

声明为 Component 的 javax.swing 中的字段
protected static Component | ImageIcon.component
protected Component | JTable.editorComp 在编辑时处理编辑的 Component。
protected Component | JRootPane.glassPane 覆盖菜单栏和内容窗格的玻璃窗格，便于截取鼠标移动等操作。
protected Component | JLabel.labelFor
protected Component | JSplitPane.leftComponent 左边或者顶部的组件。
protected Component | ScrollPaneLayout.lowerLeft 左下角显示的组件。
protected Component | JScrollPane.lowerLeft 在左下角显示的组件。
protected Component | ScrollPaneLayout.lowerRight 右下角显示的组件。
protected Component | JScrollPane.lowerRight 在右下角显示的组件。
protected Component | JSplitPane.rightComponent 右边或者底部的组件。
protected Component | ScrollPaneLayout.upperLeft 左上角显示的组件。
protected Component | JScrollPane.upperLeft 在左上角显示的组件。
protected Component | ScrollPaneLayout.upperRight 右上角显示的组件。
protected Component | JScrollPane.upperRight 在右上角显示的组件。

返回 Component 的 javax.swing 中的方法
 Component JTabbedPane.add(Component component)
添加一个 component，其选项卡的默认值为调用 component.getName 返回的组件的名称。
 Component JMenu.add(Component c)
将某个组件追加到此菜单的末尾。
 Component JTabbedPane.add(Component component, int index)
在指定的选项卡索引位置添加一个 component，默认的选项卡标题为组件名称。
 Component JMenu.add(Component c, int index)
将指定组件添加到此容器的给定位置上。
 Component JTabbedPane.add(String title, Component component)
添加具有指定选项卡标题的 component。
protected  Component ScrollPaneLayout.addSingletonComponent(Component oldC, Component newC)
移除现有组件。
 Component MenuSelectionManager.componentForPoint(Component source, Point sourcePoint)
返回包含 sourcePoint 的当前选择路径的组件。
protected  Component JRootPane.createGlassPane()
由构造方法调用以便创建默认的 glassPane。
static Component Box.createGlue()
创建一个不可见的 "glue" 组件，其可见组件有一个最大宽度（对于横向 box）或高度（对于纵向 box）的 Box，该组件可能很有用。
static Component Box.createHorizontalGlue()
创建一个横向 glue 组件。
static Component Box.createHorizontalStrut(int width)
创建一个不可见的、固定宽度的组件。
static Component Box.createRigidArea(Dimension d)
创建一个总是具有指定大小的不可见组件。
static Component Box.createVerticalGlue()
创建一个纵向 glue 组件。
static Component Box.createVerticalStrut(int height)
创建一个不可见的、固定高度的组件。
static Component SwingUtilities.findFocusOwner(Component c)
已过时。 从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。
 Component JSplitPane.getBottomComponent()
返回分隔条下面或者右边的组件。
 Component Renderer.getComponent()
返回用于呈现该值的组件。
 Component DefaultCellEditor.getComponent()
返回对编辑器组件的引用。
 Component TransferHandler.TransferSupport.getComponent()
返回此传输的目标组件。
 Component JPopupMenu.getComponent()
返回此 JPopupMenu 组件。
 Component JMenuBar.getComponent()
实现为 MenuElement。
 Component JMenu.getComponent()
返回用于绘制此 MenuElement 的 java.awt.Component。
 Component JMenuItem.getComponent()
返回用于绘制此对象的 java.awt.Component。
 Component MenuElement.getComponent()
此方法应返回用于绘制接收元素的 java.awt.Component。
 Component DefaultFocusManager.getComponentAfter(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应在 aComponent 之后接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。
 Component JTabbedPane.getComponentAt(int index)
返回 index 位置的组件。
 Component JPopupMenu.getComponentAtIndex(int i)
已过时。 由 Container.getComponent(int) 取代
 Component JMenuBar.getComponentAtIndex(int i)
已过时。 由 getComponent(int i) 取代
 Component JToolBar.getComponentAtIndex(int i)
返回指定索引位置的组件。
 Component DefaultFocusManager.getComponentBefore(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应在 aComponent 之前接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。
 Component[] JLayeredPane.getComponentsInLayer(int layer)
返回指定层中组件的数组。
 Component ScrollPaneLayout.getCorner(String key)
返回位于指定角的 Component。
 Component JScrollPane.getCorner(String key)
返回位于指定角的组件。
protected  Component JTable.AccessibleJTable.AccessibleJTableCell.getCurrentComponent()
获取表单元格渲染器组件。
static Component SwingUtilities.getDeepestComponentAt(Component parent, int x, int y)
返回包含位置 x、y 的 parent 的最深可见后代组件。
 Component SortingFocusTraversalPolicy.getDefaultComponent(Container aContainer)
返回默认拥有焦点的 Component。
 Component JTable.getEditorComponent()
返回处理编辑会话的组件。
 Component ComboBoxEditor.getEditorComponent()
返回应该添加到此编辑器的树层次结构中的组件。
 Component DefaultFocusManager.getFirstComponent(Container aContainer)
 Component LayoutFocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
 Component SortingFocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
 Component JInternalFrame.getFocusOwner()
如果此 JInternalFrame 处于激活状态，则返回具有焦点的子组件。
 Component JApplet.getGlassPane()
返回此 applet 的 glassPane 对象。
 Component JWindow.getGlassPane()
返回此窗口的 glassPane Component。
 Component JDialog.getGlassPane()
返回此对话框的 glassPane 对象。
 Component JInternalFrame.getGlassPane()
返回此内部窗体的玻璃窗格。
 Component JRootPane.getGlassPane()
返回此 JRootPane 的当前玻璃窗格。
 Component JFrame.getGlassPane()
返回此窗体的 glassPane 对象。
 Component RootPaneContainer.getGlassPane()
返回 glassPane。
 Component InternalFrameFocusTraversalPolicy.getInitialComponent(JInternalFrame frame)
返回第一次选择 JInternalFrame 时应该接收焦点的 Component。
 Component JPopupMenu.getInvoker()
返回作为此弹出菜单的“调用者”的组件。
 Component JLabel.getLabelFor()
获取要添加标签的组件。
 Component DefaultFocusManager.getLastComponent(Container aContainer)
 Component LayoutFocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
 Component SortingFocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
 Component JSplitPane.getLeftComponent()
返回分隔条左边（或者上面）的组件。
 Component DefaultListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
 Component ListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
返回已配置用于显示指定值的组件。
 Component JMenu.getMenuComponent(int n)
返回位于位置 n 的组件。
 Component[] JMenu.getMenuComponents()
返回菜单子组件的 Component 数组。
 Component JInternalFrame.getMostRecentFocusOwner()
返回选定此 JInternalFrame 时，将接收焦点的 JInternalFrame 子组件。
 Component JComponent.getNextFocusableComponent()
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代。
 Component JSplitPane.getRightComponent()
返回分隔条右边（或者下面）的组件。
static Component SwingUtilities.getRoot(Component c)
返回当前组件树结构的根组件。
 Component JTabbedPane.getSelectedComponent()
返回此选项卡窗格当前选择的组件。
 Component JTabbedPane.getTabComponentAt(int index)
返回 index 位置上的选项卡组件。
 Component DefaultCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
实现 TableCellEditor 接口。
 Component JSplitPane.getTopComponent()
返回分隔条上面或者左边的组件。
 Component DefaultCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
实现 TreeCellEditor 接口。
 Component JViewport.getView()
返回 JViewport 的一个子对象或 null。
 Component JTable.prepareEditor(TableCellEditor editor, int row, int column)
通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备编辑器。
 Component JTable.prepareRenderer(TableCellRenderer renderer, int row, int column)
通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备渲染器。

返回变量类型为 Component 的类型的 javax.swing 中的方法
protected Comparator<? super Component> | SortingFocusTraversalPolicy.getComparator() 返回将用于对焦点遍历循环中的 Components 排序的 Comparator。
protected Hashtable<Component,Integer> | JLayeredPane.getComponentToLayer() 返回将组件映射到层的哈希表。

参数类型为 Component 的 javax.swing 中的方法
protected  boolean LayoutFocusTraversalPolicy.accept(Component aComponent)
确定是否可以接受选择指定的 Component 作为新的焦点所有者。
protected  boolean SortingFocusTraversalPolicy.accept(Component aComponent)
确定是否可以接受选择某个 Component 作为新的焦点拥有者。
 Component JTabbedPane.add(Component component)
添加一个 component，其选项卡的默认值为调用 component.getName 返回的组件的名称。
 Component JMenu.add(Component c)
将某个组件追加到此菜单的末尾。
 Component JTabbedPane.add(Component component, int index)
在指定的选项卡索引位置添加一个 component，默认的选项卡标题为组件名称。
 Component JMenu.add(Component c, int index)
将指定组件添加到此容器的给定位置上。
 void JTabbedPane.add(Component component, Object constraints)
将一个 component 添加到选项卡窗格中。
 void JTabbedPane.add(Component component, Object constraints, int index)
在指定的选项卡索引位置添加一个 component。
 Component JTabbedPane.add(String title, Component component)
添加具有指定选项卡标题的 component。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(boolean useAsBaseline, Component component)
将 Component 添加到此 Group。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(boolean useAsBaseline, Component component, int min, int pref, int max)
使用指定大小将 Component 添加到此 Group。
 GroupLayout.Group GroupLayout.Group.addComponent(Component component)
将 Component 添加到此 Group。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(Component component)
将 Component 添加到此 Group。
 GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component)
将 Component 添加到此 Group。
 GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment)
使用指定的对齐方式将 Component 添加到此 ParallelGroup。
 GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment, int min, int pref, int max)
使用指定的对齐方式和大小将 Component 添加到此 ParallelGroup。
 GroupLayout.Group GroupLayout.Group.addComponent(Component component, int min, int pref, int max)
使用指定大小将 Component 添加到此 Group。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(Component component, int min, int pref, int max)
使用指定大小将 Component 添加到此 Group。
 GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, int min, int pref, int max)
使用指定大小将 Component 添加到此 Group。
protected  void JDesktopPane.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上。
protected  void JApplet.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
protected  void JWindow.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
protected  void JViewport.addImpl(Component child, Object constraints, int index)
设置 JViewport 的轻量子对象，可以为 null。
protected  void CellRendererPane.addImpl(Component x, Object constraints, int index)
如果指定组件已经是此组件的子组件，则不必再操心去做任何事，堆栈顺序对于单元格渲染器组件而言无关紧要（CellRendererPane 不管怎样都不进行绘制）。
protected  void JSplitPane.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此分隔窗格。
protected  void JToolBar.addImpl(Component comp, Object constraints, int index)
在添加 JButton 时，它最初被设置为 disabled。
protected  void JDialog.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
protected  void AbstractButton.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上，有关此方法的完整描述，请参阅 Container.addImpl(Component, Object, int)。
protected  void JInternalFrame.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
protected  void JLayeredPane.addImpl(Component comp, Object constraints, int index)
protected  void JRootPane.addImpl(Component comp, Object constraints, int index)
重写以便将玻璃组件的位置强行设置成零位子级。
protected  void JFrame.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
 void GroupLayout.addLayoutComponent(Component component, Object constraints)
已将 Component 添加到父容器的通知。
 void OverlayLayout.addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。
 void SpringLayout.addLayoutComponent(Component component, Object constraints)
如果 constraints 是 SpringLayout.Constraints 的一个实例，则将该约束与指定组件相关联。
 void BoxLayout.addLayoutComponent(Component comp, Object constraints)
此类不使用。
 void JRootPane.RootLayout.addLayoutComponent(Component comp, Object constraints)
 void GroupLayout.addLayoutComponent(String name, Component component)
已将 Component 添加到父容器的通知。
 void JSpinner.DefaultEditor.addLayoutComponent(String name, Component child)
此 LayoutManager 方法不执行任何操作。
 void OverlayLayout.addLayoutComponent(String name, Component comp)
将指定的组件添加到布局中。
 void SpringLayout.addLayoutComponent(String name, Component c)
无效，因为此布局管理器不使用每组件字符串。
 void ViewportLayout.addLayoutComponent(String name, Component c)
将指定的组件添加到布局中。
 void ScrollPaneLayout.addLayoutComponent(String s, Component c)
将指定的组件添加到布局中。
 void BoxLayout.addLayoutComponent(String name, Component comp)
此类不使用。
 void JRootPane.RootLayout.addLayoutComponent(String name, Component comp)
protected  Component ScrollPaneLayout.addSingletonComponent(Component oldC, Component newC)
移除现有组件。
 void JTabbedPane.addTab(String title, Component component)
添加一个由 title 表示，且没有图标的 component。
 void JTabbedPane.addTab(String title, Icon icon, Component component)
添加一个由 title 和/或 icon 表示的 component，其任意一个都可以为 null。
 void JTabbedPane.addTab(String title, Icon icon, Component component, String tip)
添加由 title 和/或 icon 表示的 component 和 tip，其中任意一个都可以为 null。
 boolean DefaultFocusManager.compareTabOrder(Component a, Component b)
 Component MenuSelectionManager.componentForPoint(Component source, Point sourcePoint)
返回包含 sourcePoint 的当前选择路径的组件。
static MouseEvent SwingUtilities.convertMouseEvent(Component source, MouseEvent sourceEvent, Component destination)
返回类似于 sourceEvent 的 MouseEvent，除了其 x 和 y 成员已转换到 destination 的坐标系统。
static Point SwingUtilities.convertPoint(Component source, int x, int y, Component destination)
将 source 坐标系统中的点 (x,y) 转换到 destination 坐标系统。
static Point SwingUtilities.convertPoint(Component source, Point aPoint, Component destination)
将 source 坐标系统中的 aPoint 转换到 destination 坐标系统。
static void SwingUtilities.convertPointFromScreen(Point p, Component c)
将一个点从屏幕坐标转换到组件的坐标系统
static void SwingUtilities.convertPointToScreen(Point p, Component c)
将一个点从组件的坐标系统转换到屏幕坐标。
static Rectangle SwingUtilities.convertRectangle(Component source, Rectangle aRectangle, Component destination)
将 source 坐标系统中的矩形 aRectangle 转换到 destination 坐标系统。
protected  JDialog JFileChooser.createDialog(Component parent)
创建并返回包含 this 的新 JDialog，在 parent 窗体中的 parent 上居中。
 JDialog JOptionPane.createDialog(Component parentComponent, String title)
创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。
static JDialog JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
 JInternalFrame JOptionPane.createInternalFrame(Component parentComponent, String title)
创建并返回 JInternalFrame 的实例。
static RepaintManager RepaintManager.currentManager(Component c)
在给定 Component 的情况下，返回调用线程的 RepaintManager。
static Component SwingUtilities.findFocusOwner(Component c)
已过时。 从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。
static Accessible SwingUtilities.getAccessibleAt(Component c, Point p)
如果存在，则返回本地坐标 Point 处包含的 Accessible 子对象。
static Accessible SwingUtilities.getAccessibleChild(Component c, int i)
返回对象的第 n 个可访问子对象。
static int SwingUtilities.getAccessibleChildrenCount(Component c)
返回对象中可访问的子对象数。
static int SwingUtilities.getAccessibleIndexInParent(Component c)
获取此对象在其可访问的父对象中的索引。
static AccessibleStateSet SwingUtilities.getAccessibleStateSet(Component c)
获取此对象的状态。
static Container SwingUtilities.getAncestorNamed(String name, Component comp)
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的 name 第一个对象。
static Container SwingUtilities.getAncestorOfClass(Class<?> c, Component comp)
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的类 c 的第一个对象。
 Component DefaultFocusManager.getComponentAfter(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应在 aComponent 之后接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。
 Component DefaultFocusManager.getComponentBefore(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应在 aComponent 之前接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。
 int JPopupMenu.getComponentIndex(Component c)
返回指定组件的索引。
 int JMenuBar.getComponentIndex(Component c)
返回指定组件的索引。
 int JToolBar.getComponentIndex(Component c)
返回指定组件的索引。
 Spring SpringLayout.getConstraint(String edgeName, Component c)
返回控制该组件指定边及其父级的顶边或左边之间距离的 spring。
 SpringLayout.Constraints SpringLayout.getConstraints(Component c)
返回指定组件的约束。
static Component SwingUtilities.getDeepestComponentAt(Component parent, int x, int y)
返回包含位置 x、y 的 parent 的最深可见后代组件。
static JDesktopPane JOptionPane.getDesktopPaneForComponent(Component parentComponent)
返回指定组件的桌面窗格。
static Frame JOptionPane.getFrameForComponent(Component parentComponent)
返回指定组件的 Frame。
 int JLayeredPane.getIndexOf(Component c)
返回指定 Component 的索引。
 int JLayeredPane.getLayer(Component c)
返回指定 Component 的 layer 属性。
static JLayeredPane JLayeredPane.getLayeredPaneAbove(Component c)
一个便捷方法，它返回包含指定组件的第一个 JLayeredPane。
static Rectangle SwingUtilities.getLocalBounds(Component aComponent)
返回组件 aComponent 的矩形 (0,0,bounds.width,bounds.height)。
 Image RepaintManager.getOffscreenBuffer(Component c, int proposedWidth, int proposedHeight)
返回屏幕外缓冲区，它应用作带有组件 c 的双缓冲区。
 Popup PopupFactory.getPopup(Component owner, Component contents, int x, int y)
为包含 Component contents 的 Component owner 创建 Popup。
 int JLayeredPane.getPosition(Component c)
获得该组件在其所在层中的相对位置。
static Component SwingUtilities.getRoot(Component c)
返回当前组件树结构的根组件。
static JRootPane SwingUtilities.getRootPane(Component c)
如果 c 是一个 JRootPane 后代，则返回其 JRootPane 祖先。
 Image RepaintManager.getVolatileOffscreenBuffer(Component c, int proposedWidth, int proposedHeight)
返回可变屏幕外缓冲区，它应用作带有指定组件 c 的双缓冲区。
static Window SwingUtilities.getWindowAncestor(Component c)
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
static Spring Spring.height(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的高度定义。
 int JTabbedPane.indexOfComponent(Component component)
返回指定组件的选项卡索引。
 int JTabbedPane.indexOfTabComponent(Component tabComponent)
返回指定选项卡组件的选项卡索引。
 void JPopupMenu.insert(Component component, int index)
将指定组件插入到菜单的给定位置。
 void JTextPane.insertComponent(Component c)
将一个组件插入到文档中，以替换当前选择的内容。
 void JTabbedPane.insertTab(String title, Icon icon, Component component, String tip, int index)
在 index 位置插入一个 component，该组件通过 title 和/或 icon（任意一个都可以为 null）来表示。
 boolean MenuSelectionManager.isComponentPartOfCurrentMenu(Component c)
如果 c 是当前使用菜单的一部分，则返回 true
static boolean SwingUtilities.isDescendingFrom(Component a, Component b)
如果组件 a 从组件 b 继承，则返回 true。
static boolean JComponent.isLightweightComponent(Component c)
如果此组件是轻量的，也就是说，如果它没有本机窗口系统同位体，则返回 true。
 boolean JMenu.isMenuComponent(Component c)
如果在子菜单层次结构中存在指定的组件，则返回 true。
 void GroupLayout.linkSize(Component... components)
将指定组件强制调整为具有相同的大小，而不管其首选大小、最小大小或最大大小如何。
 void GroupLayout.linkSize(int axis, Component... components)
将指定组件强制调整为沿指定轴具有相同的大小，而不管其首选大小、最小大小或最大大小如何。
 void JLayeredPane.moveToBack(Component c)
将该组件移到当前层中所有组件的底层（位置 -1）。
 void JLayeredPane.moveToFront(Component c)
将该组件移到当前层中所有组件的顶层（位置 0）。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
调用 this.paintComponent(g, c, p, x, y, w, h, false)。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
在指定的 Graphics 上绘制组件。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
在图形对象 g 上绘制一个单元格渲染器组件 c。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, Rectangle r)
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, Rectangle r)
在指定的 Graphics 上绘制组件。
 void ImageIcon.paintIcon(Component c, Graphics g, int x, int y)
绘制图标。
 void Icon.paintIcon(Component c, Graphics g, int x, int y)
在指定位置上绘制图标。
 void LookAndFeel.provideErrorFeedback(Component component)
在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。
 void SpringLayout.putConstraint(String e1, Component c1, int pad, String e2, Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2，边与边之间的距离固定。
 void SpringLayout.putConstraint(String e1, Component c1, Spring s, String e2, Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2。
 void JApplet.remove(Component comp)
从容器中移除指定的组件。
 void JTabbedPane.remove(Component component)
从 JTabbedPane 中移除指定 Component。
 void JWindow.remove(Component comp)
从该容器中移除指定组件。
 void JViewport.remove(Component child)
移除 Viewport 的一个轻量子对象。
 void JSplitPane.remove(Component component)
移除窗格中的子组件 component。
 void JDialog.remove(Component comp)
从该容器中移除指定组件。
 void JMenu.remove(Component c)
从此菜单移除组件 c。
 void JInternalFrame.remove(Component comp)
从此容器中移除指定组件。
 void JFrame.remove(Component comp)
从该容器中移除指定组件。
 void GroupLayout.removeLayoutComponent(Component component)
已从父容器中移除 Component 的通知。
 void JSpinner.DefaultEditor.removeLayoutComponent(Component child)
此 LayoutManager 方法不执行任何操作。
 void OverlayLayout.removeLayoutComponent(Component comp)
从布局移除指定组件。
 void SpringLayout.removeLayoutComponent(Component c)
移除与指定组件相关的约束。
 void ViewportLayout.removeLayoutComponent(Component c)
从布局中移除指定组件。
 void ScrollPaneLayout.removeLayoutComponent(Component c)
从布局中移除指定的组件。
 void BoxLayout.removeLayoutComponent(Component comp)
此类不使用。
 void JRootPane.RootLayout.removeLayoutComponent(Component comp)
 void GroupLayout.replace(Component existingComponent, Component newComponent)
使用新的组件替代现有组件。
 void JSplitPane.setBottomComponent(Component comp)
将组件设置到分隔条的下面或者右边。
 void JScrollPane.setColumnHeaderView(Component view)
创建一个列标题视口（如果有必要），设置其视图然后将此列标题视口添加到滚动窗格。
 void JTabbedPane.setComponentAt(int index, Component component)
将 index 位置的组件设置为 component。
 void JDesktopPane.setComponentZOrder(Component comp, int index)
将指定组件移动到容器中指定的 z 顺序索引。
 void JScrollPane.setCorner(String key, Component corner)
添加一个将显示在一个滚动窗格角中的子级，如果有空间的话。
 void JApplet.setGlassPane(Component glassPane)
设置 glassPane 属性。
 void JWindow.setGlassPane(Component glassPane)
设置 glassPane 属性。
 void JDialog.setGlassPane(Component glassPane)
设置 glassPane 属性。
 void JInternalFrame.setGlassPane(Component glass)
设置此 JInternalFrame 的 glassPane 属性。
 void JRootPane.setGlassPane(Component glass)
将指定的 Component 设置为此根窗格的玻璃窗格。
 void JFrame.setGlassPane(Component glassPane)
设置 glassPane 属性。
 void RootPaneContainer.setGlassPane(Component glassPane)
glassPane 始终为 rootPane 的第一个子组件，rootPanes 布局管理器确保它始终与 rootPane 一样大。
 void GroupLayout.setHonorsVisibility(Component component, Boolean honorsVisibility)
设置确定组件的大小和位置时是否要考虑组件的可见性。
 void JPopupMenu.setInvoker(Component invoker)
设置此弹出菜单的调用者，即弹出菜单在其中显示的组件。
 void JLabel.setLabelFor(Component c)
设置要添加标签的组件。
 void JLayeredPane.setLayer(Component c, int layer)
设置指定组件的 layer 属性，使之成为该层中最底部的组件。
 void JLayeredPane.setLayer(Component c, int layer, int position)
为指定组件设置 layer 属性，并设置它在该层中的位置。
 void JSplitPane.setLeftComponent(Component comp)
将组件设置到分隔条的左边（或上面）。
 void JComponent.setNextFocusableComponent(Component aComponent)
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代
 void JLayeredPane.setPosition(Component c, int position)
将该组件移到当前层中的 position 处，其中 0 表示该层中的最顶层位置，-1 表示最底层位置。
 void JSplitPane.setRightComponent(Component comp)
将组件设置到分隔条的右边（或者下面）。
 void JScrollPane.setRowHeaderView(Component view)
创建一个行标题视口（如果有必要），设置其视图然后将此行标题视口添加到滚动窗格。
 void JPopupMenu.setSelected(Component sel)
设置当前选择的组件，此方法将更改选择模型。
 void JMenuBar.setSelected(Component sel)
设置当前选择的组件，更改选择模型。
 void JTabbedPane.setSelectedComponent(Component c)
设置此选项卡窗格的已选组件。
 void JTabbedPane.setTabComponentAt(int index, Component component)
设置负责呈现指定选项卡标题的组件。
 void JSplitPane.setTopComponent(Component comp)
将组件设置到分隔条的上面或者左边。
 void JViewport.setView(Component view)
设置 JViewport 的一个轻量子对象 (view)，可以为 null。
 void JScrollPane.setViewportView(Component view)
创建一个视口（如果有必要）并设置其视图。
 void JPopupMenu.show(Component invoker, int x, int y)
在组件调用者的坐标空间中的位置 X、Y 显示弹出菜单。
static int JOptionPane.showConfirmDialog(Component parentComponent, Object message)
调出带有选项 Yes、No 和 Cancel 的对话框；标题为 Select an Option。
static int JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的对话框。
static int JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。
static int JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。
 int JFileChooser.showDialog(Component parent, String approveButtonText)
弹出具有自定义 approve 按钮的自定义文件选择器对话框。
static Color JColorChooser.showDialog(Component component, String title, Color initialColor)
显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。
static String JOptionPane.showInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
static String JOptionPane.showInputDialog(Component parentComponent, Object message, Object initialSelectionValue)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
static String JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。
static Object JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。
static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message)
调出带有选项 Yes、No 和 Cancel 的内部对话框面板；标题为 Select an Option。
static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板。
static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板，messageType 参数确定要显示的图标。
static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。
static String JOptionPane.showInternalInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的内部问题消息对话框，它以 parentComponent 为父级。
static String JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。
static Object JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。
static void JOptionPane.showInternalMessageDialog(Component parentComponent, Object message)
调出内部确认对话框面板。
static void JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出一个显示消息的内部对话框面板，它使用由 messageType 参数确定的默认图标。
static void JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示消息的内部对话框面板，为其指定了所有参数。
static int JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
static void JOptionPane.showMessageDialog(Component parentComponent, Object message)
调出标题为 "Message" 的信息消息对话框。
static void JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。
static void JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示信息的对话框，为其指定了所有参数。
 int JFileChooser.showOpenDialog(Component parent)
弹出一个 "Open File" 文件选择器对话框。
static int JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
 int JFileChooser.showSaveDialog(Component parent)
弹出一个 "Save File" 文件选择器对话框。
static void SwingUtilities.updateComponentTreeUI(Component c)
简单的外观更改：将树结构中的每个节点转到 updateUI() -- 也就是说，通过当前外观初始化其 UI 属性。
static Spring Spring.width(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的宽度定义。
static Window SwingUtilities.windowForComponent(Component c)
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。

类型变量类型为 Component 的 javax.swing 中的方法参数
protected  void SortingFocusTraversalPolicy.setComparator(Comparator<? super Component> comparator)
设置将用于对焦点遍历循环中的 Components 排序的 Comparator。

参数类型为 Component 的 javax.swing 中的构造方法
JScrollPane(Component view)
创建一个显示指定组件内容的 JScrollPane，只要组件的内容超过视图大小就会显示水平和垂直滚动条。
JScrollPane(Component view, int vsbPolicy, int hsbPolicy)
创建一个 JScrollPane，它将视图组件显示在一个视口中，视图位置可使用一对滚动条控制。
JSplitPane(int newOrientation, boolean newContinuousLayout, Component newLeftComponent, Component newRightComponent)
创建一个具有指定方向、重绘方式和指定组件的新 JSplitPane。
JSplitPane(int newOrientation, Component newLeftComponent, Component newRightComponent)
创建一个具有指定方向和不连续重绘的指定组件的新 JSplitPane。
Popup(Component owner, Component contents, int x, int y)
为包含 Component content 的 Component owner 创建 Popup。
ProgressMonitor(Component parentComponent, Object message, String note, int min, int max)
构造一个图形对象，它一般会根据进程的完成情况通过填充矩形条来显示进度。
ProgressMonitorInputStream(Component parentComponent, Object message, InputStream in)
构造一个对象，以监视输入流的进度。
SpringLayout.Constraints(Component c)
创建组件 c 的合适 x、y、width 和 height spring 的 Constraints 对象。
TransferHandler.TransferSupport(Component component, Transferable transferable)
使用给定组件和 Transferable 创建一个 TransferSupport，对于该 TransferSupport isDrop() 返回 false。

类型变量类型为 Component 的 javax.swing 中的构造方法参数
SortingFocusTraversalPolicy(Comparator<? super Component> comparator)
构造具有指定 Comparator 的 SortingFocusTraversalPolicy。

javax.swing.border 中 Component 的使用

参数类型为 Component 的 javax.swing.border 中的方法
int | TitledBorder.getBaseline(Component c, int width, int height) 返回基线。
int | AbstractBorder.getBaseline(Component c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | TitledBorder.getBaselineResizeBehavior(Component c) 返回一个枚举，指示该边框的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | AbstractBorder.getBaselineResizeBehavior(Component c) 返回一个枚举，指示组件的基线如何随大小的改变而发生更改。
Insets | SoftBevelBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | TitledBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | BevelBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | EtchedBorder.getBorderInsets(Component c) 返回边框的 insets
Insets | LineBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | MatteBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | CompoundBorder.getBorderInsets(Component c) 返回复合边框的 insets，它是外部边框的 insets 与内部边框的 insets 相加所得的结果。
Insets | EmptyBorder.getBorderInsets(Component c) 返回此边框的 insets
Insets | AbstractBorder.getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | Border.getBorderInsets(Component c) 返回该边框的 insets。
Insets | SoftBevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | TitledBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | BevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EtchedBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | LineBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | MatteBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | CompoundBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EmptyBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | AbstractBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
protected Font | TitledBorder.getFont(Component c)
Color | EtchedBorder.getHighlightColor(Component c) 返回浮雕化边框在指定组件上呈现的高亮显示颜色。
Color | BevelBorder.getHighlightInnerColor(Component c) 返回斜面边框在指定组件上呈现的内部高亮显示颜色。
Color | BevelBorder.getHighlightOuterColor(Component c) 返回斜面边框在指定组件上呈现的外部高亮显示颜色。
static Rectangle | AbstractBorder.getInteriorRectangle(Component c, Border b, int x, int y, int width, int height) 返回一个用所给的参数减去边框 insets 得到的矩形。
Rectangle | AbstractBorder.getInteriorRectangle(Component c, int x, int y, int width, int height) 此便捷方法调用静态方法。
Dimension | TitledBorder.getMinimumSize(Component c) 返回此边框完全显示边框和标题所需的最小大小。
Color | EtchedBorder.getShadowColor(Component c) 返回浮雕化边框在指定组件上呈现的阴影颜色。
Color | BevelBorder.getShadowInnerColor(Component c) 返回斜面边框在指定组件上呈现的内部阴影颜色。
Color | BevelBorder.getShadowOuterColor(Component c) 返回斜面边框在指定组件上呈现的外部阴影颜色。
void | SoftBevelBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸绘制指定组件的边框。
void | TitledBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和大小为指定的组件绘制边框。
void | BevelBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
void | EtchedBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸为指定的组件绘制边框
void | LineBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸为指定的组件绘制边框。
void | MatteBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 绘制衬边边框。
void | CompoundBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 绘制组合边框，方法是先按指定的位置和尺寸绘制外部边框，然后按照外部边框 insets 指定的位置和尺寸偏移量绘制内部边框。
void | EmptyBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 默认情况下不执行绘制。
void | AbstractBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 此默认实现不执行绘制操作。
void | Border.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
protected void | BevelBorder.paintLoweredBevel(Component c, Graphics g, int x, int y, int width, int height)
protected void | BevelBorder.paintRaisedBevel(Component c, Graphics g, int x, int y, int width, int height)

javax.swing.colorchooser 中 Component 的使用

javax.swing.colorchooser 中 Component 的子类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.event 中 Component 的使用

参数类型为 Component 的 javax.swing.event 中的构造方法
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuKeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuKeyEvent 对象。

javax.swing.plaf 中 Component 的使用

参数类型为 Component 的 javax.swing.plaf 中的方法
Insets | BorderUIResource.getBorderInsets(Component c)
void | BorderUIResource.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | IconUIResource.paintIcon(Component c, Graphics g, int x, int y)

javax.swing.plaf.basic 中 Component 的使用

javax.swing.plaf.basic 中 Component 的子类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
protected class | BasicToolBarUI.DragWindow

声明为 Component 的 javax.swing.plaf.basic 中的字段
protected Component[] | BasicSplitPaneUI.BasicHorizontalLayoutManager.components
protected Component | BasicTreeUI.MouseInputHandler.destination 接收所有事件的目的地。
protected Component | BasicTreeUI.editingComponent 编辑时，它将是进行实际编辑的 Component。
protected Component | BasicComboBoxUI.editor
protected Component | BasicSplitPaneDivider.hiddenDivider 用于非连续布局模式的分隔符。
protected Component | BasicOptionPaneUI.initialFocusComponent 利用 selectInitialValue 传递消息时接收焦点的组件。
protected Component | BasicSplitPaneUI.nonContinuousLayoutDivider 使用非连续布局时分隔符阴影的实例。
protected Component | BasicTreeUI.MouseInputHandler.source 发起事件的源。
Component | BasicMenuUI.ChangeHandler.wasFocused

返回 Component 的 javax.swing.plaf.basic 中的方法
protected Component | BasicSplitPaneUI.createDefaultNonContinuousLayoutDivider() 返回默认的非连续布局分隔符，该分隔符是使用深灰色填充背景的 Canvas 的实例。
protected Component | BasicSpinnerUI.createNextButton() 创建将用 spinner.getNextValue 返回的对象取代 spinner 模型值的组件。
protected Component | BasicSpinnerUI.createPreviousButton() 创建将用 spinner.getPreviousValue 返回的对象取代 spinner 模型值的组件。
Component | BasicComboBoxEditor.getEditorComponent()
protected Component | BasicSliderUI.getHighestValueLabel() 返回与标签表中的最低滑块值相对应的标签。
Component | BasicComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
protected Component | BasicSliderUI.getLowestValueLabel() 返回与标签表中的最高滑块值相对应的标签。
Component | BasicSplitPaneUI.getNonContinuousLayoutDivider() 返回要在将 splitPane 配置为非连续布局时使用的分隔符。
protected Component | BasicTabbedPaneUI.getVisibleComponent()

参数类型为 Component 的 javax.swing.plaf.basic 中的方法
void | BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent(Component comp, Object constraints) 使用指定的约束对象将指定组件添加到布局中。
void | BasicInternalFrameTitlePane.TitlePaneLayout.addLayoutComponent(String name, Component c)
void | BasicInternalFrameUI.InternalFrameLayout.addLayoutComponent(String name, Component c)
void | BasicOptionPaneUI.ButtonAreaLayout.addLayoutComponent(String string, Component comp)
void | BasicSplitPaneDivider.DividerLayout.addLayoutComponent(String string, Component c)
void | BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent(String place, Component component) 在 place 位置添加组件。
void | BasicTabbedPaneUI.TabbedPaneLayout.addLayoutComponent(String name, Component comp)
void | BasicComboBoxUI.ComboBoxLayoutManager.addLayoutComponent(String name, Component comp)
void | BasicScrollBarUI.addLayoutComponent(String name, Component child)
boolean | BasicToolBarUI.canDock(Component c, Point p)
protected void | BasicTreeUI.drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
Insets | BasicBorders.ButtonBorder.getBorderInsets(Component c)
Insets | BasicBorders.ToggleButtonBorder.getBorderInsets(Component c)
Insets | BasicBorders.RadioButtonBorder.getBorderInsets(Component c)
Insets | BasicBorders.MenuBarBorder.getBorderInsets(Component c)
Insets | BasicBorders.MarginBorder.getBorderInsets(Component c)
Insets | BasicBorders.FieldBorder.getBorderInsets(Component c)
Insets | BasicBorders.SplitPaneBorder.getBorderInsets(Component c)
Insets | BasicBorders.ButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.ToggleButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.RadioButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.MenuBarBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.MarginBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.FieldBorder.getBorderInsets(Component c, Insets insets)
protected int | BasicSplitPaneUI.BasicHorizontalLayoutManager.getPreferredSizeOfComponent(Component c) 返回传入 Component 的首选大小的宽度。
protected int | BasicSplitPaneUI.BasicHorizontalLayoutManager.getSizeOfComponent(Component c) 返回传入组件的宽度。
protected void | BasicSpinnerUI.installNextButtonListeners(Component c) 在下一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。
protected void | BasicSpinnerUI.installPreviousButtonListeners(Component c) 在上一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。
void | BasicBorders.RolloverButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | BasicBorders.ButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | BasicBorders.ToggleButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | BasicBorders.RadioButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | BasicBorders.MenuBarBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | BasicBorders.FieldBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | BasicBorders.SplitPaneBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
protected void | BasicSliderUI.paintHorizontalLabel(Graphics g, int value, Component label) 为标签表中的每个标签调用此方法。
protected void | BasicSliderUI.paintVerticalLabel(Graphics g, int value, Component label) 为标签表中的每个标签调用此方法。
void | BasicInternalFrameTitlePane.TitlePaneLayout.removeLayoutComponent(Component c)
void | BasicInternalFrameUI.InternalFrameLayout.removeLayoutComponent(Component c)
void | BasicOptionPaneUI.ButtonAreaLayout.removeLayoutComponent(Component c)
void | BasicSplitPaneDivider.DividerLayout.removeLayoutComponent(Component c)
void | BasicSplitPaneUI.BasicHorizontalLayoutManager.removeLayoutComponent(Component component) 根据了解的情况移除指定的组件。
void | BasicTabbedPaneUI.TabbedPaneLayout.removeLayoutComponent(Component comp)
void | BasicComboBoxUI.ComboBoxLayoutManager.removeLayoutComponent(Component comp)
void | BasicScrollBarUI.removeLayoutComponent(Component child)
protected void | BasicToolBarUI.setBorderToNonRollover(Component c) 将组件的边框设置为具有由 createNonRolloverBorder 创建的翻转边框。
protected void | BasicToolBarUI.setBorderToNormal(Component c) 将组件的边框设置为具有普通边框。
protected void | BasicToolBarUI.setBorderToRollover(Component c) 将组件的边框设置为具有由 createRolloverBorder 创建的翻转边框。
protected void | BasicSplitPaneUI.BasicHorizontalLayoutManager.setComponentToSize(Component c, int size, int location, Insets insets, Dimension containerSize) 将组件 c 的宽度设置为 size（将其 x 的位置放置到 location），将 y 和高度分别设置为 insets.top 和 containersize.height 减去上下 insets。
protected void | BasicSplitPaneUI.setNonContinuousLayoutDivider(Component newDivider) 设置要在将 splitPane 配置为非连续布局时使用的分隔符。
protected void | BasicSplitPaneUI.setNonContinuousLayoutDivider(Component newDivider, boolean rememberSizes) 设置要使用的分隔符。
protected void | BasicTabbedPaneUI.setVisibleComponent(Component component)

参数类型为 Component 的 javax.swing.plaf.basic 中的构造方法
BasicTreeUI.MouseInputHandler(Component source, Component destination, MouseEvent event)

javax.swing.plaf.metal 中 Component 的使用

javax.swing.plaf.metal 中 Component 的子类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

返回 Component 的 javax.swing.plaf.metal 中的方法
 Component MetalFileChooserUI.FilterComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)

参数类型为 Component 的 javax.swing.plaf.metal 中的方法
protected void | MetalCheckBoxIcon.drawCheck(Component c, Graphics g, int x, int y)
Insets | MetalBorders.Flush3DBorder.getBorderInsets(Component c)
Insets | MetalBorders.ButtonBorder.getBorderInsets(Component c)
Insets | MetalBorders.InternalFrameBorder.getBorderInsets(Component c)
Insets | MetalBorders.PaletteBorder.getBorderInsets(Component c)
Insets | MetalBorders.OptionDialogBorder.getBorderInsets(Component c)
Insets | MetalBorders.MenuBarBorder.getBorderInsets(Component c)
Insets | MetalBorders.MenuItemBorder.getBorderInsets(Component c)
Insets | MetalBorders.PopupMenuBorder.getBorderInsets(Component c)
Insets | MetalBorders.ToolBarBorder.getBorderInsets(Component c)
Insets | MetalBorders.ScrollPaneBorder.getBorderInsets(Component c)
Insets | MetalBorders.TableHeaderBorder.getBorderInsets(Component c)
Insets | MetalBorders.Flush3DBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ButtonBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.InternalFrameBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PaletteBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.OptionDialogBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuBarBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuItemBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PopupMenuBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ToolBarBorder.getBorderInsets(Component c, Insets newInsets)
void | MetalBorders.Flush3DBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.InternalFrameBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.PaletteBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.OptionDialogBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.MenuBarBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.MenuItemBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.PopupMenuBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.RolloverButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ToolBarBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.TextFieldBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ScrollPaneBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ToggleButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.TableHeaderBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalCheckBoxIcon.paintIcon(Component c, Graphics g, int x, int y)
void | MetalComboBoxIcon.paintIcon(Component c, Graphics g, int x, int y) 绘制 MetalComboBox 的水平条
void | MetalIconFactory.PaletteCloseIcon.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.FolderIcon16.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.FileIcon16.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.TreeControlIcon.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.TreeControlIcon.paintMe(Component c, Graphics g, int x, int y)
void | MetalLookAndFeel.provideErrorFeedback(Component component) 在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。
protected void | MetalToolBarUI.setBorderToNonRollover(Component c)

javax.swing.plaf.synth 中 Component 的使用

参数类型为 Component 的 javax.swing.plaf.synth 中的方法
static void SynthLookAndFeel.updateStyles(Component c)
更新与 c 关联的样式以及其所有子样式。

javax.swing.table 中 Component 的使用

javax.swing.table 中 Component 的子类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。

返回 Component 的 javax.swing.table 中的方法
Component | TableCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column) 为编辑器设置初始 value。
Component | DefaultTableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column) 返回默认的表单元格渲染器。
Component | TableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column) 返回用于绘制单元格的组件。

javax.swing.text 中 Component 的使用

javax.swing.text 中 Component 的子类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

返回 Component 的 javax.swing.text 中的方法
protected Component | ComponentView.createComponent() 创建与此视图关联的组件。
Component | ComponentView.getComponent() 获取与此视图关联的组件。
static Component | StyleConstants.getComponent(AttributeSet a) 从属性列表中获取组件设置。

参数类型为 Component 的 javax.swing.text 中的方法
protected void | PlainView.damageLineRange(int line0, int line1, Shape a, Component host) 重新绘制给定的行范围。
static void | StyleConstants.setComponent(MutableAttributeSet a, Component c) 设置组件属性。

javax.swing.text.html 中 Component 的使用

返回 Component 的 javax.swing.text.html 中的方法
protected Component | FormView.createComponent() 创建组件。
protected Component | ObjectView.createComponent() 创建组件。

javax.swing.tree 中 Component 的使用

javax.swing.tree 中 Component 的子类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
class | DefaultTreeCellRenderer 显示树中的条目。

声明为 Component 的 javax.swing.tree 中的字段
protected  Component DefaultTreeCellEditor.editingComponent
用于编辑的组件，从 editingContainer 获取。

返回 Component 的 javax.swing.tree 中的方法
Component | DefaultTreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row) 配置编辑器。
Component | TreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row) 设置编辑器的初始值。
Component | DefaultTreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus) 配置基于传入组件的渲染器。
Component | TreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus) 将当前树单元格的值设置为 value。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Component.AccessibleAWTComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.AccessibleAWTComponent
的使用

使用 Component.AccessibleAWTComponent 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 Component.AccessibleAWTComponent 的使用

java.applet 中 Component.AccessibleAWTComponent 的子类
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

java.awt 中 Component.AccessibleAWTComponent 的使用

java.awt 中 Component.AccessibleAWTComponent 的子类
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
protected class | Canvas.AccessibleAWTCanvas 此类实现对 Canvas 类的可访问性支持。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | Choice.AccessibleAWTChoice 此类实现对 Choice 类的可访问性支持。
protected class | Container.AccessibleAWTContainer 用于对可访问性提供默认支持的 Container 内部类。
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。
protected class | Label.AccessibleAWTLabel 此类实现对 Label 类的可访问性支持。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | List.AccessibleAWTList.AccessibleAWTListChild 此类实现 List 子级的可访问性支持。
protected class | Panel.AccessibleAWTPanel 此类实现 Panel 类的可访问性支持。
protected class | Scrollbar.AccessibleAWTScrollBar 此类实现 Scrollbar 类的可访问性支持。
protected class | ScrollPane.AccessibleAWTScrollPane 此类实现 ScrollPane 类的可访问性支持。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。
protected class | Window.AccessibleAWTWindow 此类实现对 Window 类的可访问性支持。

javax.swing 中 Component.AccessibleAWTComponent 的使用

javax.swing 中 Component.AccessibleAWTComponent 的子类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
protected class | Box.Filler.AccessibleBoxFiller 此类实现 Box.Filler 类的可访问性支持。
protected class | CellRendererPane.AccessibleCellRendererPane 此类实现 Panel 类的可访问性支持。
protected class | JApplet.AccessibleJApplet 此类实现对 JApplet 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。

javax.swing.table 中 Component.AccessibleAWTComponent 的使用

javax.swing.table 中 Component.AccessibleAWTComponent 的子类
protected  class JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。

javax.swing.text 中 Component.AccessibleAWTComponent 的使用

javax.swing.text 中 Component.AccessibleAWTComponent 的子类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
的使用

没有 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
的使用

没有 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Component.BaselineResizeBehavior 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.BaselineResizeBehavior
的使用

使用 Component.BaselineResizeBehavior 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 Component.BaselineResizeBehavior 的使用

返回 Component.BaselineResizeBehavior 的 java.awt 中的方法
Component.BaselineResizeBehavior | Component.getBaselineResizeBehavior() 返回一个指示组件的基线如何随大小发生更改的枚举。
static Component.BaselineResizeBehavior | Component.BaselineResizeBehavior.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Component.BaselineResizeBehavior[] | Component.BaselineResizeBehavior.values() Returns an array containing the constants of this enum type, in the order they are declared.

javax.swing 中 Component.BaselineResizeBehavior 的使用

返回 Component.BaselineResizeBehavior 的 javax.swing 中的方法
Component.BaselineResizeBehavior | JSpinner.DefaultEditor.getBaselineResizeBehavior() 返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | JComponent.getBaselineResizeBehavior() 返回一个枚举，指示组件的基线如何随大小更改而发生更改。

javax.swing.border 中 Component.BaselineResizeBehavior 的使用

返回 Component.BaselineResizeBehavior 的 javax.swing.border 中的方法
Component.BaselineResizeBehavior | TitledBorder.getBaselineResizeBehavior(Component c) 返回一个枚举，指示该边框的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | AbstractBorder.getBaselineResizeBehavior(Component c) 返回一个枚举，指示组件的基线如何随大小的改变而发生更改。

javax.swing.plaf 中 Component.BaselineResizeBehavior 的使用

返回 Component.BaselineResizeBehavior 的 javax.swing.plaf 中的方法
 Component.BaselineResizeBehavior ComponentUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，指示组件的基线如何随大小的改变而发生更改。

javax.swing.plaf.basic 中 Component.BaselineResizeBehavior 的使用

返回 Component.BaselineResizeBehavior 的 javax.swing.plaf.basic 中的方法
Component.BaselineResizeBehavior | BasicSpinnerUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicSliderUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicTextAreaUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicTreeUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicTableUI.getBaselineResizeBehavior(JComponent c) 返回指示该组件的基线如何随大小的改变而发生更改的枚举。
Component.BaselineResizeBehavior | BasicProgressBarUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicTabbedPaneUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicTextFieldUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicScrollPaneUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicListUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicComboBoxUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicButtonUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicLabelUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicPanelUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Component.BltBufferStrategy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.BltBufferStrategy
的使用

没有 java.awt.Component.BltBufferStrategy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Component.FlipBufferStrategy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.FlipBufferStrategy
的使用

没有 java.awt.Component.FlipBufferStrategy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.ComponentOrientation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ComponentOrientation
的使用

使用 ComponentOrientation 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 ComponentOrientation 的使用

声明为 ComponentOrientation 的 java.awt 中的字段
static ComponentOrientation | ComponentOrientation.LEFT_TO_RIGHT 各项从左到右布局，各行从上到下，示例：英语、法语。
static ComponentOrientation | ComponentOrientation.RIGHT_TO_LEFT 各项从右到左布局，各行从上到下，示例：阿拉伯语、希伯来语。
static ComponentOrientation | ComponentOrientation.UNKNOWN 表示尚未设置组件的方向。

返回 ComponentOrientation 的 java.awt 中的方法
 ComponentOrientation Component.getComponentOrientation()
检索将用于排序此组件内的元素或文本的语言敏感的方向。
static ComponentOrientation ComponentOrientation.getOrientation(Locale locale)
返回适合于给定区域的方向。
static ComponentOrientation ComponentOrientation.getOrientation(ResourceBundle bdl)
已过时。 在 J2SE 1.4 中，使用 getOrientation(java.util.Locale)。

参数类型为 ComponentOrientation 的 java.awt 中的方法
void | Container.applyComponentOrientation(ComponentOrientation o) 设置此容器和其中包含的所有组件的 ComponentOrientation 属性。
void | Component.applyComponentOrientation(ComponentOrientation orientation) 设置此组件及其包含的所有组件的 ComponentOrientation 属性。
void | Component.setComponentOrientation(ComponentOrientation o) 设置语言敏感的方向，用于排序此组件内的元素或文本。

javax.swing 中 ComponentOrientation 的使用

参数类型为 ComponentOrientation 的 javax.swing 中的方法
void | JMenu.applyComponentOrientation(ComponentOrientation o) 设置此菜单及其中包含的所有组件的 ComponentOrientation 属性。
void | JScrollPane.setComponentOrientation(ComponentOrientation co) 设置由 ComponentOrientation 参数确定的垂直和水平滚动条方向。
void | JMenu.setComponentOrientation(ComponentOrientation o)

javax.swing.text 中 ComponentOrientation 的使用

参数类型为 ComponentOrientation 的 javax.swing.text 中的方法
 void JTextComponent.setComponentOrientation(ComponentOrientation o)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.Composite 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Composite
的使用

使用 Composite 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Composite 的使用

实现 Composite 的 java.awt 中的类
 class AlphaComposite
AlphaComposite 类实现一些基本的 alpha 合成规则，将源色与目标色组合，在图形和图像中实现混合和透明效果。

返回 Composite 的 java.awt 中的方法
abstract  Composite Graphics2D.getComposite()
返回 Graphics2D 上下文中的当前 Composite

参数类型为 Composite 的 java.awt 中的方法
abstract  void Graphics2D.setComposite(Composite comp)
为 Graphics2D 上下文设置 Composite。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.CompositeContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.CompositeContext
的使用

使用 CompositeContext 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 CompositeContext 的使用

返回 CompositeContext 的 java.awt 中的方法
CompositeContext | AlphaComposite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 为合成操作创建一个上下文。
CompositeContext | Composite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 创建一个上下文，其中包含用于执行复合操作的状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Container 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Container
的使用

使用 Container 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 Container 的使用

java.applet 中 Container 的子类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 Container 的使用

java.awt 中 Container 的子类
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。
class | Panel Panel 是最简单的容器类。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。

返回 Container 的 java.awt 中的方法
Container | KeyboardFocusManager.getCurrentFocusCycleRoot() 如果当前焦点循环根与调用线程位于相同的上下文中，则返回当前焦点循环根。
Container | Window.getFocusCycleRootAncestor() 始终返回 null，因为窗口没有祖先；它们表示组件层次结构的顶层。
Container | Component.getFocusCycleRootAncestor() 返回作为此 Component 焦点遍历循环的焦点循环根的 Container。
protected Container | KeyboardFocusManager.getGlobalCurrentFocusCycleRoot() 返回当前焦点循环根，即使调用线程处于当前焦点循环根之外的上下文中。
protected static Container | Toolkit.getNativeContainer(Component c) 使本机同位体能够查询给定本机组件的本机容器（例如，直接父组件可以是轻量级的）。
Container | Component.getParent() 获取此组件的父级。

参数类型为 Container 的 java.awt 中的方法
protected void | GridBagLayout.arrangeGrid(Container parent) 布置网格。
protected void | GridBagLayout.ArrangeGrid(Container parent) 此方法已过时，仅为提供向后兼容性；新代码应该调用 arrangeGrid 来代替。
void | DefaultKeyboardFocusManager.downFocusCycle(Container aContainer) 将焦点下移一个焦点遍历循环。
abstract void | KeyboardFocusManager.downFocusCycle(Container aContainer) 将焦点下移一个焦点遍历循环。
void | CardLayout.first(Container parent) 翻转到容器的第一张卡片。
Component | ContainerOrderFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent) 返回应该接收 aComponent 后面的焦点的 Component。
abstract Component | FocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent) 返回应该接收 aComponent 之后的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或者焦点遍历策略提供者。
Component | ContainerOrderFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent) 返回应该接收 aComponent 前面的焦点的 Component。
abstract Component | FocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent) 返回应该接收 aComponent 之前的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或焦点遍历策略提供者。
Component | ContainerOrderFocusTraversalPolicy.getDefaultComponent(Container aContainer) 返回默认拥有焦点的 Component。
abstract Component | FocusTraversalPolicy.getDefaultComponent(Container aContainer) 返回要聚焦的默认 Component。
Component | ContainerOrderFocusTraversalPolicy.getFirstComponent(Container aContainer) 返回遍历循环中的第一个 Component。
abstract Component | FocusTraversalPolicy.getFirstComponent(Container aContainer) 返回遍历循环中的第一个 Component。
Component | ContainerOrderFocusTraversalPolicy.getLastComponent(Container aContainer) 返回遍历循环中的最后一个 Component。
abstract Component | FocusTraversalPolicy.getLastComponent(Container aContainer) 返回遍历循环中的最后一个 Component。
float | GridBagLayout.getLayoutAlignmentX(Container parent) 返回沿 X 轴的对齐方式。
float | CardLayout.getLayoutAlignmentX(Container parent) 返回沿 x 轴的对齐方式。
float | BorderLayout.getLayoutAlignmentX(Container parent) 返回沿 x 轴的对齐方式。
float | LayoutManager2.getLayoutAlignmentX(Container target) 返回沿 X 轴的对齐方式。
float | GridBagLayout.getLayoutAlignmentY(Container parent) 返回沿 y 轴的对齐方式。
float | CardLayout.getLayoutAlignmentY(Container parent) 返回沿 y 轴的对齐方式。
float | BorderLayout.getLayoutAlignmentY(Container parent) 返回沿 y 轴的对齐方式。
float | LayoutManager2.getLayoutAlignmentY(Container target) 返回沿 Y 轴的对齐方式。
Component | BorderLayout.getLayoutComponent(Container target, Object constraints) 基于目标 Container 的组件方向，返回给定约束位置对应的组件。
protected GridBagLayoutInfo | GridBagLayout.getLayoutInfo(Container parent, int sizeflag) 为当前受管子级的集合填充 GridBagLayoutInfo 的实例。
protected GridBagLayoutInfo | GridBagLayout.GetLayoutInfo(Container parent, int sizeflag) 此方法已过时，仅为提供向后兼容性；新代码应该调用 getLayoutInfo 来代替。
protected Dimension | GridBagLayout.getMinSize(Container parent, GridBagLayoutInfo info) 基于 getLayoutInfo 中的信息计算其所有者的最小大小。
protected Dimension | GridBagLayout.GetMinSize(Container parent, GridBagLayoutInfo info) 此方法已过时，仅为提供向后兼容性；新代码应该调用 getMinSize 来代替。
void | GridBagLayout.invalidateLayout(Container target) 使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
void | CardLayout.invalidateLayout(Container target) 使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。
void | BorderLayout.invalidateLayout(Container target) 使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。
void | LayoutManager2.invalidateLayout(Container target) 使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
boolean | Container.isFocusCycleRoot(Container container) 返回指定的 Container 是否是此 Container 的焦点遍历循环的焦点循环根。
boolean | Component.isFocusCycleRoot(Container container) 返回指定的 Container 是否为此 Component 焦点遍历循环的焦点循环根。
void | CardLayout.last(Container parent) 翻转到容器的最后一张卡片。
void | GridBagLayout.layoutContainer(Container parent) 使用此网格包布局布置指定容器。
void | GridLayout.layoutContainer(Container parent) 使用此布局布置指定容器。
void | CardLayout.layoutContainer(Container parent) 使用此卡片布局布置指定的容器。
void | FlowLayout.layoutContainer(Container target) 布置该容器。
void | BorderLayout.layoutContainer(Container target) 使用此边框布局对容器参数进行布局。
void | LayoutManager.layoutContainer(Container parent) 布置指定容器。
Dimension | GridBagLayout.maximumLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的最大维数
Dimension | CardLayout.maximumLayoutSize(Container target) 给出指定目标容器中的组件，返回此布局的最大尺寸。
Dimension | BorderLayout.maximumLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的最大尺寸。
Dimension | LayoutManager2.maximumLayoutSize(Container target) 给定指定容器的组件，计算该容器的最大大小维数。
Dimension | GridBagLayout.minimumLayoutSize(Container parent) 使用此网格包布局确定 parent 容器的最小大小。
Dimension | GridLayout.minimumLayoutSize(Container parent) 使用此网络布局确定最小大小的容器参数。
Dimension | CardLayout.minimumLayoutSize(Container parent) 计算指定面板大小的最小值。
Dimension | FlowLayout.minimumLayoutSize(Container target) 返回需要布置 visible 组件的最小维数，该组件包含在指定的目标容器中。
Dimension | BorderLayout.minimumLayoutSize(Container target) 使用此布局管理器确定 target 容器的最小大小。
Dimension | LayoutManager.minimumLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的最小大小维数。
void | CardLayout.next(Container parent) 翻转到指定容器的下一张卡片。
Dimension | GridBagLayout.preferredLayoutSize(Container parent) 使用此网络包布局确定 parent 容器的首选大小。
Dimension | GridLayout.preferredLayoutSize(Container parent) 使用此网格布局确定容器参数的首选大小。
Dimension | CardLayout.preferredLayoutSize(Container parent) 使用此卡片布局确定容器参数的首选大小。
Dimension | FlowLayout.preferredLayoutSize(Container target) 给出指定目标容器中的 visible 组件，返回此布局的首选维数。
Dimension | BorderLayout.preferredLayoutSize(Container target) 基于容器中的组件，使用此布局管理器确定 target 容器的首选大小。
Dimension | LayoutManager.preferredLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的首选大小维数。
void | CardLayout.previous(Container parent) 翻转到指定容器的前一张卡片。
void | KeyboardFocusManager.setGlobalCurrentFocusCycleRoot(Container newFocusCycleRoot) 设置当前焦点循环根。
void | CardLayout.show(Container parent, String name) 翻转到使用 addLayoutComponent 添加到此布局的具有指定 name 的组件。

java.awt.event 中 Container 的使用

返回 Container 的 java.awt.event 中的方法
 Container HierarchyEvent.getChangedParent()
返回由 getChanged() 返回的 Component 的父级。
 Container ContainerEvent.getContainer()
返回事件的始发者。

参数类型为 Container 的 java.awt.event 中的构造方法
HierarchyEvent(Component source, int id, Component changed, Container changedParent)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
HierarchyEvent(Component source, int id, Component changed, Container changedParent, long changeFlags)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。

java.beans.beancontext 中 Container 的使用

返回 Container 的 java.beans.beancontext 中的方法
 Container BeanContextContainerProxy.getContainer()
获得与此 BeanContext 相关联的 java.awt.Container。

javax.swing 中 Container 的使用

javax.swing 中 Container 的子类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JComponent 该类是除顶层容器外所有 Swing 组件的基类。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JDialog 创建对话框窗口的主要类。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

声明为 Container 的 javax.swing 中的字段
protected  Container JRootPane.contentPane
内容窗格。

返回 Container 的 javax.swing 中的方法
protected Container | JRootPane.createContentPane() 由构造方法调用以便创建默认的 contentPane。
static Container | SwingUtilities.getAncestorNamed(String name, Component comp) 在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的 name 第一个对象。
static Container | SwingUtilities.getAncestorOfClass(Class<?> c, Component comp) 在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的类 c 的第一个对象。
Container | JApplet.getContentPane() 返回此 applet 的 contentPane 对象。
Container | JWindow.getContentPane() 返回作为此窗口的 contentPane 的 Container。
Container | JDialog.getContentPane() 返回此对话框的 contentPane 对象。
Container | JInternalFrame.getContentPane() 返回此内部窗体的内容窗格。
Container | JRootPane.getContentPane() 返回内容窗格，它是保存以根窗格为父级的组件的容器。
Container | JFrame.getContentPane() 返回此窗体的 contentPane 对象
Container | RootPaneContainer.getContentPane() 返回 contentPane。
Container | JInternalFrame.getFocusCycleRootAncestor() 始终返回 null，原因是 JInternalFrame 必须始终为焦点遍历循环的根。
Container | OverlayLayout.getTarget() 返回使用此布局管理器的容器。
Container | BoxLayout.getTarget() 返回使用此布局管理器的容器。
Container | JComponent.getTopLevelAncestor() 返回此组件的顶层祖先（包含的 Window 或 Applet）；如果尚未将此组件添加到任意容器中，则返回 null。

参数类型为 Container 的 javax.swing 中的方法
 Component DefaultFocusManager.getComponentAfter(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应在 aComponent 之后接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。
 Component DefaultFocusManager.getComponentBefore(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应在 aComponent 之前接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。
abstract  int LayoutStyle.getContainerGap(JComponent component, int position, Container parent)
返回组件与其父容器的指定边缘之间放置的空格数量。
 Component SortingFocusTraversalPolicy.getDefaultComponent(Container aContainer)
返回默认拥有焦点的 Component。
 Component DefaultFocusManager.getFirstComponent(Container aContainer)
 Component LayoutFocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
 Component SortingFocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
 Component DefaultFocusManager.getLastComponent(Container aContainer)
 Component LayoutFocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
 Component SortingFocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
 float GroupLayout.getLayoutAlignmentX(Container parent)
返回沿 x 轴的对齐方式。
 float OverlayLayout.getLayoutAlignmentX(Container target)
返回容器沿 X 轴的对齐方式。
 float SpringLayout.getLayoutAlignmentX(Container p)
返回 0.5f（居中）。
 float BoxLayout.getLayoutAlignmentX(Container target)
返回容器沿 X 轴的对齐方式。
 float JRootPane.RootLayout.getLayoutAlignmentX(Container target)
 float GroupLayout.getLayoutAlignmentY(Container parent)
返回沿 y 轴的对齐方式。
 float OverlayLayout.getLayoutAlignmentY(Container target)
返回容器沿 Y 轴的对齐方式。
 float SpringLayout.getLayoutAlignmentY(Container p)
返回 0.5f（居中）。
 float BoxLayout.getLayoutAlignmentY(Container target)
返回容器沿 Y 轴的对齐方式。
 float JRootPane.RootLayout.getLayoutAlignmentY(Container target)
abstract  int LayoutStyle.getPreferredGap(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent)
返回两个组件之间使用的空格的数量。
 void GroupLayout.invalidateLayout(Container parent)
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
 void OverlayLayout.invalidateLayout(Container target)
指示子容器已更改其布局相关信息，这会导致刷新所有缓存计算。
 void SpringLayout.invalidateLayout(Container p)
 void BoxLayout.invalidateLayout(Container target)
指示一个子容器已经更改其布局相关信息，因此应该刷新所有已缓存的计算结果。
 void JRootPane.RootLayout.invalidateLayout(Container target)
 void GroupLayout.layoutContainer(Container parent)
布置指定的容器。
 void JSpinner.DefaultEditor.layoutContainer(Container parent)
调整一个（并且是唯一）子级的大小，以完全填充父 insets 中的区域。
 void OverlayLayout.layoutContainer(Container target)
当需要布置指定的容器时，由 AWT 调用。
 void SpringLayout.layoutContainer(Container parent)
 void ViewportLayout.layoutContainer(Container parent)
在需要布置指定容器时由 AWT 调用。
 void ScrollPaneLayout.layoutContainer(Container parent)
布置滚动窗格。
 void BoxLayout.layoutContainer(Container target)
在需要布置指定容器时，由 AWT 调用 。
 void JRootPane.RootLayout.layoutContainer(Container parent)
指示布局管理器为指定的容器执行布局。
 Dimension GroupLayout.maximumLayoutSize(Container parent)
返回指定容器的最大大小。
 Dimension OverlayLayout.maximumLayoutSize(Container target)
返回需要布置组件的最大维数，该组件包含在指定的目标容器中。
 Dimension SpringLayout.maximumLayoutSize(Container parent)
 Dimension BoxLayout.maximumLayoutSize(Container target)
返回目标容器布置其所包含的组件时可使用的最大尺寸。
 Dimension JRootPane.RootLayout.maximumLayoutSize(Container target)
返回布局能够使用的最大空间量。
 Dimension GroupLayout.minimumLayoutSize(Container parent)
返回指定容器的最小大小。
 Dimension JSpinner.DefaultEditor.minimumLayoutSize(Container parent)
返回第一个（并且是唯一）的子级最小大小与其父 insets 的大小和。
 Dimension OverlayLayout.minimumLayoutSize(Container target)
返回需要布置组件的最小维数，该组件包含在指定的目标容器中。
 Dimension SpringLayout.minimumLayoutSize(Container parent)
 Dimension ViewportLayout.minimumLayoutSize(Container parent)
返回需要布置指定目标容器中包含的组件的最小维数。
 Dimension ScrollPaneLayout.minimumLayoutSize(Container parent)
ScrollPane 的最小大小是 insets 加上视口最小大小，加上可见标题的最小大小，加上 displayPolicy 不为 NEVER 的滚动条的最小大小。
 Dimension BoxLayout.minimumLayoutSize(Container target)
返回布置包含在指定目标容器中的组件所需的最小尺寸。
 Dimension JRootPane.RootLayout.minimumLayoutSize(Container parent)
返回布局需要的最小空间量。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
调用 this.paintComponent(g, c, p, x, y, w, h, false)。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
在指定的 Graphics 上绘制组件。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
在图形对象 g 上绘制一个单元格渲染器组件 c。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, Rectangle r)
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, Rectangle r)
在指定的 Graphics 上绘制组件。
 Dimension GroupLayout.preferredLayoutSize(Container parent)
返回指定容器的首选大小。
 Dimension JSpinner.DefaultEditor.preferredLayoutSize(Container parent)
返回第一个（并且是唯一）子级的首选大小与其父 insets 的大小和。
 Dimension OverlayLayout.preferredLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
 Dimension SpringLayout.preferredLayoutSize(Container parent)
 Dimension ViewportLayout.preferredLayoutSize(Container parent)
在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
 Dimension ScrollPaneLayout.preferredLayoutSize(Container parent)
ScrollPane 的首选大小是 insets 的大小加上视口的首选大小、可见标题首选大小以及滚动条的首选大小，它按照给定的当前视图和当前滚动条策略显示。
 Dimension BoxLayout.preferredLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的首选尺寸。
 Dimension JRootPane.RootLayout.preferredLayoutSize(Container parent)
返回布局要使用的空间量。
 void JApplet.setContentPane(Container contentPane)
设置 contentPane 属性。
 void JWindow.setContentPane(Container contentPane)
设置此窗口的 contentPane 属性。
 void JDialog.setContentPane(Container contentPane)
设置 contentPane 属性。
 void JInternalFrame.setContentPane(Container c)
设置此 JInternalFrame 的 contentPane 属性。
 void JRootPane.setContentPane(Container content)
设置内容窗格，它是保存以根窗格为父级的组件的容器。
 void JFrame.setContentPane(Container contentPane)
设置 contentPane 属性。
 void RootPaneContainer.setContentPane(Container contentPane)
"contentPane" 是应用程序特定组件的主要容器。

参数类型为 Container 的 javax.swing 中的构造方法
BoxLayout(Container target, int axis)
创建一个将沿给定轴放置组件的布局管理器。
GroupLayout(Container host)
为指定的 Container 创建 GroupLayout。
OverlayLayout(Container target)
构造执行子容器的覆盖安排的布局管理器。

javax.swing.colorchooser 中 Container 的使用

javax.swing.colorchooser 中 Container 的子类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.event 中 Container 的使用

返回 Container 的 javax.swing.event 中的方法
Container | AncestorEvent.getAncestor() 返回实际发生事件的祖先组件。
Container | AncestorEvent.getAncestorParent() 返回实际发生事件的祖先组件的父组件。

参数类型为 Container 的 javax.swing.event 中的构造方法
AncestorEvent(JComponent source, int id, Container ancestor, Container ancestorParent)
构造一个 AncestorEvent 对象，以标识祖先组件显示状态的更改。

javax.swing.plaf.basic 中 Container 的使用

javax.swing.plaf.basic 中 Container 的子类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
protected class | BasicToolBarUI.DragWindow

返回 Container 的 javax.swing.plaf.basic 中的方法
protected Container | BasicOptionPaneUI.createButtonArea() 创建并返回包含按钮的 Container。
protected Container | BasicOptionPaneUI.createMessageArea() 从 installComponents 获取消息以创建包含消息正文的 Container。
protected Container | BasicOptionPaneUI.createSeparator()

参数类型为 Container 的 javax.swing.plaf.basic 中的方法
protected void | BasicOptionPaneUI.addButtonComponents(Container container, Object[] buttons, int initialIndex) 创建表示 buttons 中每个对象的适当对象并将其添加到 container。
protected void | BasicOptionPaneUI.addIcon(Container top) 创建并添加 JLabel，它表示对 top 调用 getIcon 所返回的图标。
protected void | BasicOptionPaneUI.addMessageComponents(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated) 创建表示 msg 的适当对象并将其置于 container 中。
protected void | BasicOptionPaneUI.burstStringInto(Container c, String d, int maxll) 递归式创建表示 d 的新 JLabel 实例每个 JLabel 实例都将被添加到 c。
float | BasicSplitPaneUI.BasicHorizontalLayoutManager.getLayoutAlignmentX(Container target) 返回容器沿 X 轴的对齐方式。
float | BasicSplitPaneUI.BasicHorizontalLayoutManager.getLayoutAlignmentY(Container target) 返回容器沿 Y 轴的对齐方式。
void | BasicSplitPaneUI.BasicHorizontalLayoutManager.invalidateLayout(Container c) 不执行任何操作。
void | BasicInternalFrameTitlePane.TitlePaneLayout.layoutContainer(Container c)
void | BasicInternalFrameUI.InternalFrameLayout.layoutContainer(Container c)
void | BasicOptionPaneUI.ButtonAreaLayout.layoutContainer(Container container)
void | BasicSplitPaneDivider.DividerLayout.layoutContainer(Container c)
void | BasicSplitPaneUI.BasicHorizontalLayoutManager.layoutContainer(Container container) 进行实际布局。
void | BasicTabbedPaneUI.TabbedPaneLayout.layoutContainer(Container parent)
void | BasicComboBoxUI.ComboBoxLayoutManager.layoutContainer(Container parent)
void | BasicScrollBarUI.layoutContainer(Container scrollbarContainer)
Dimension | BasicSplitPaneUI.BasicHorizontalLayoutManager.maximumLayoutSize(Container target) 返回最大布局大小，该大小在两个方向上都是 Integer.MAX_VALUE。
Dimension | BasicInternalFrameTitlePane.TitlePaneLayout.minimumLayoutSize(Container c)
Dimension | BasicInternalFrameUI.InternalFrameLayout.minimumLayoutSize(Container c)
Dimension | BasicOptionPaneUI.ButtonAreaLayout.minimumLayoutSize(Container c)
Dimension | BasicSplitPaneDivider.DividerLayout.minimumLayoutSize(Container c)
Dimension | BasicSplitPaneUI.BasicHorizontalLayoutManager.minimumLayoutSize(Container container) 返回包含子级所需的最小大小。
Dimension | BasicTabbedPaneUI.TabbedPaneLayout.minimumLayoutSize(Container parent)
Dimension | BasicComboBoxUI.ComboBoxLayoutManager.minimumLayoutSize(Container parent)
Dimension | BasicScrollBarUI.minimumLayoutSize(Container scrollbarContainer)
Dimension | BasicInternalFrameTitlePane.TitlePaneLayout.preferredLayoutSize(Container c)
Dimension | BasicInternalFrameUI.InternalFrameLayout.preferredLayoutSize(Container c)
Dimension | BasicOptionPaneUI.ButtonAreaLayout.preferredLayoutSize(Container c)
Dimension | BasicSplitPaneDivider.DividerLayout.preferredLayoutSize(Container c)
Dimension | BasicSplitPaneUI.BasicHorizontalLayoutManager.preferredLayoutSize(Container container) 返回包含子级所需的首选大小。
Dimension | BasicTabbedPaneUI.TabbedPaneLayout.preferredLayoutSize(Container parent)
Dimension | BasicComboBoxUI.ComboBoxLayoutManager.preferredLayoutSize(Container parent)
Dimension | BasicScrollBarUI.preferredLayoutSize(Container scrollbarContainer)
Dimension | DefaultMenuLayout.preferredLayoutSize(Container target)

参数类型为 Container 的 javax.swing.plaf.basic 中的构造方法
DefaultMenuLayout(Container target, int axis)

javax.swing.plaf.metal 中 Container 的使用

javax.swing.plaf.metal 中 Container 的子类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

参数类型为 Container 的 javax.swing.plaf.metal 中的方法
void | MetalComboBoxUI.layoutComboBox(Container parent, MetalComboBoxUI.MetalComboBoxLayoutManager manager)
void | MetalComboBoxUI.MetalComboBoxLayoutManager.layoutContainer(Container parent)
void | MetalComboBoxUI.MetalComboBoxLayoutManager.superLayout(Container parent)

javax.swing.table 中 Container 的使用

javax.swing.table 中 Container 的子类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。

javax.swing.text 中 Container 的使用

javax.swing.text 中 Container 的子类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

返回 Container 的 javax.swing.text 中的方法
 Container View.getContainer()
获取承载视图的容器。

javax.swing.tree 中 Container 的使用

javax.swing.tree 中 Container 的子类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
class | DefaultTreeCellRenderer 显示树中的条目。

声明为 Container 的 javax.swing.tree 中的字段
protected  Container DefaultTreeCellEditor.editingContainer
将包含 editorComponent 的编辑容器。

返回 Container 的 javax.swing.tree 中的方法
protected  Container DefaultTreeCellEditor.createContainer()
创建管理 editingComponent 放置的容器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Container.AccessibleAWTContainer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Container.AccessibleAWTContainer
的使用

使用 Container.AccessibleAWTContainer 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 Container.AccessibleAWTContainer 的使用

java.applet 中 Container.AccessibleAWTContainer 的子类
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

java.awt 中 Container.AccessibleAWTContainer 的使用

java.awt 中 Container.AccessibleAWTContainer 的子类
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。
protected class | Panel.AccessibleAWTPanel 此类实现 Panel 类的可访问性支持。
protected class | ScrollPane.AccessibleAWTScrollPane 此类实现 ScrollPane 类的可访问性支持。
protected class | Window.AccessibleAWTWindow 此类实现对 Window 类的可访问性支持。

javax.swing 中 Container.AccessibleAWTContainer 的使用

javax.swing 中 Container.AccessibleAWTContainer 的子类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
protected class | CellRendererPane.AccessibleCellRendererPane 此类实现 Panel 类的可访问性支持。
protected class | JApplet.AccessibleJApplet 此类实现对 JApplet 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。

javax.swing.table 中 Container.AccessibleAWTContainer 的使用

javax.swing.table 中 Container.AccessibleAWTContainer 的子类
protected  class JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。

javax.swing.text 中 Container.AccessibleAWTContainer 的使用

javax.swing.text 中 Container.AccessibleAWTContainer 的子类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
的使用

没有 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.ContainerOrderFocusTraversalPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ContainerOrderFocusTraversalPolicy
的使用

使用 ContainerOrderFocusTraversalPolicy 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 ContainerOrderFocusTraversalPolicy 的使用

java.awt 中 ContainerOrderFocusTraversalPolicy 的子类
 class DefaultFocusTraversalPolicy
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Cursor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Cursor
的使用

使用 Cursor 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Cursor 的使用

声明为 Cursor 的 java.awt 中的字段
protected static Cursor[] Cursor.predefined

返回 Cursor 的 java.awt 中的方法
Cursor | Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name) 创建一个新的自定义光标对象。
Cursor | List.AccessibleAWTList.AccessibleAWTListChild.getCursor() 获取此对象的 Cursor。
Cursor | MenuComponent.AccessibleAWTMenuComponent.getCursor() 获取此对象的 Cursor。
Cursor | Component.getCursor() 获取组件中的光标集合。
Cursor | Component.AccessibleAWTComponent.getCursor() 获取此对象的 Cursor。
static Cursor | Cursor.getDefaultCursor() 返回系统默认光标。
static Cursor | Cursor.getPredefinedCursor(int type) 返回一个具有指定预定义类型的光标对象。
static Cursor | Cursor.getSystemCustomCursor(String name) 返回与指定名称匹配的特定于系统的定制光标对象。

参数类型为 Cursor 的 java.awt 中的方法
void | List.AccessibleAWTList.AccessibleAWTListChild.setCursor(Cursor cursor) 设置此对象的 Cursor。
void | MenuComponent.AccessibleAWTMenuComponent.setCursor(Cursor cursor) 设置此对象的 Cursor。
void | Window.setCursor(Cursor cursor) 设置指定光标的光标图像。
void | Component.setCursor(Cursor cursor) 为指定的光标设置光标图像。
void | Component.AccessibleAWTComponent.setCursor(Cursor cursor) 设置此对象的 Cursor。

java.awt.dnd 中 Cursor 的使用

声明为 Cursor 的 java.awt.dnd 中的字段
static Cursor | DragSource.DefaultCopyDrop 用于复制操作的默认 Cursor，指示当前允许放置。
static Cursor | DragSource.DefaultCopyNoDrop 用于复制操作的默认 Cursor，指示当前不允许放置。
static Cursor | DragSource.DefaultLinkDrop 用于链接操作的默认 Cursor，指示当前允许放置。
static Cursor | DragSource.DefaultLinkNoDrop 用于链接操作的默认 Cursor，指示当前不允许放置。
static Cursor | DragSource.DefaultMoveDrop 用于移动操作的默认 Cursor，指示当前允许放置。
static Cursor | DragSource.DefaultMoveNoDrop 用于移动操作的默认 Cursor，指示当前不允许放置。

返回 Cursor 的 java.awt.dnd 中的方法
 Cursor DragSourceContext.getCursor()
返回当前的拖动 Cursor

参数类型为 Cursor 的 java.awt.dnd 中的方法
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
void | DragSourceContext.setCursor(Cursor c) 将此拖动操作的光标设置为指定的 Cursor。
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable) 在给定拖动操作的 Cursor 和表示拖动操作源数据的 Transferable 的情况下开始拖动此操作。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 Cursor 的 java.awt.dnd 中的构造方法
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。

javax.accessibility 中 Cursor 的使用

返回 Cursor 的 javax.accessibility 中的方法
 Cursor AccessibleComponent.getCursor()
获取此对象的 Cursor。

参数类型为 Cursor 的 javax.accessibility 中的方法
 void AccessibleComponent.setCursor(Cursor cursor)
设置此对象的 Cursor。

javax.swing 中 Cursor 的使用

返回 Cursor 的 javax.swing 中的方法
Cursor | JTree.AccessibleJTree.AccessibleJTreeNode.getCursor()
Cursor | JTable.AccessibleJTable.AccessibleJTableCell.getCursor() 获取此对象的 Cursor。
Cursor | JList.AccessibleJList.AccessibleJListChild.getCursor()
Cursor | JInternalFrame.getLastCursor() 返回通过 setCursor 方法设置的最后一个 Cursor，它是不可调整大小的 Cursor。

参数类型为 Cursor 的 javax.swing 中的方法
void | JTree.AccessibleJTree.AccessibleJTreeNode.setCursor(Cursor c)
void | JTable.AccessibleJTable.AccessibleJTableCell.setCursor(Cursor c) 设置此对象的 Cursor。
void | JList.AccessibleJList.AccessibleJListChild.setCursor(Cursor c)
void | JInternalFrame.setCursor(Cursor cursor) 为指定的光标设置光标图像。

javax.swing.table 中 Cursor 的使用

返回 Cursor 的 javax.swing.table 中的方法
 Cursor JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getCursor()

参数类型为 Cursor 的 javax.swing.table 中的方法
 void JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setCursor(Cursor c)

javax.swing.text.html 中 Cursor 的使用

返回 Cursor 的 javax.swing.text.html 中的方法
Cursor | HTMLEditorKit.getDefaultCursor() 返回默认光标。
Cursor | HTMLEditorKit.getLinkCursor() 返回要在超链接上使用的光标。

参数类型为 Cursor 的 javax.swing.text.html 中的方法
void | HTMLEditorKit.setDefaultCursor(Cursor cursor) 设置默认光标。
void | HTMLEditorKit.setLinkCursor(Cursor cursor) 设置要在链接上使用的光标。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.DefaultFocusTraversalPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.DefaultFocusTraversalPolicy
的使用

没有 java.awt.DefaultFocusTraversalPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.DefaultKeyboardFocusManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.DefaultKeyboardFocusManager
的使用

使用 DefaultKeyboardFocusManager 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DefaultKeyboardFocusManager 的使用

javax.swing 中 DefaultKeyboardFocusManager 的子类
class | DefaultFocusManager 此类已被废弃，用 1.4 focus API 取代。
class | FocusManager 从 1.4 focus API 开始，此类已被废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Desktop 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Desktop
的使用

使用 Desktop 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Desktop 的使用

返回 Desktop 的 java.awt 中的方法
static Desktop Desktop.getDesktop()
返回当前浏览器上下文的 Desktop 实例。

参数类型为 Desktop 的 java.awt 中的方法
protected abstract  java.awt.peer.DesktopPeer Toolkit.createDesktopPeer(Desktop target)
使用指定的同位体接口创建此工具包的 Desktop 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Desktop.Action 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Desktop.Action
的使用

使用 Desktop.Action 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Desktop.Action 的使用

返回 Desktop.Action 的 java.awt 中的方法
static Desktop.Action | Desktop.Action.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Desktop.Action[] | Desktop.Action.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Desktop.Action 的 java.awt 中的方法
 boolean Desktop.isSupported(Desktop.Action action)
测试当前平台是否支持某一动作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Dialog 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Dialog
的使用

使用 Dialog 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Dialog 的使用

java.awt 中 Dialog 的子类
 class FileDialog
FileDialog 类显示一个对话框窗口，用户可以从中选择文件。

参数类型为 Dialog 的 java.awt 中的方法
protected abstract  java.awt.peer.DialogPeer Toolkit.createDialog(Dialog target)
使用指定同位体接口创建此工具包的 Dialog 实现。

参数类型为 Dialog 的 java.awt 中的构造方法
Dialog(Dialog owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Dialog 和一个空标题。
Dialog(Dialog owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Dialog 和标题。
Dialog(Dialog owner, String title, boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题和模式。
Dialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题、模式和 GraphicsConfiguration。
FileDialog(Dialog parent)
创建一个文件对话框，用于加载文件。
FileDialog(Dialog parent, String title)
创建一个具有指定标题的文件对话框，用于加载文件。
FileDialog(Dialog parent, String title, int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。

javax.swing 中 Dialog 的使用

javax.swing 中 Dialog 的子类
 class JDialog
创建对话框窗口的主要类。

参数类型为 Dialog 的 javax.swing 中的构造方法
JDialog(Dialog owner)
创建一个没有标题但将指定的 Dialog 作为其所有者的无模式对话框。
JDialog(Dialog owner, boolean modal)
创建一个具有指定所有者 Dialog 和模式的对话框。
JDialog(Dialog owner, String title)
创建一个具有指定标题和指定所有者对话框的无模式对话框。
JDialog(Dialog owner, String title, boolean modal)
创建一个具有指定标题、模式和指定所有者 Dialog 的对话框。
JDialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Dialog、模式和 GraphicsConfiguration 的对话框。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Dialog.AccessibleAWTDialog 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Dialog.AccessibleAWTDialog
的使用

使用 Dialog.AccessibleAWTDialog 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 Dialog.AccessibleAWTDialog 的使用

javax.swing 中 Dialog.AccessibleAWTDialog 的子类
protected  class JDialog.AccessibleJDialog
此类实现对 JDialog 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Dialog.ModalExclusionType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Dialog.ModalExclusionType
的使用

使用 Dialog.ModalExclusionType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Dialog.ModalExclusionType 的使用

返回 Dialog.ModalExclusionType 的 java.awt 中的方法
Dialog.ModalExclusionType | Window.getModalExclusionType() 返回此窗口的模式排斥类型。
static Dialog.ModalExclusionType | Dialog.ModalExclusionType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Dialog.ModalExclusionType[] | Dialog.ModalExclusionType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Dialog.ModalExclusionType 的 java.awt 中的方法
abstract boolean | Toolkit.isModalExclusionTypeSupported(Dialog.ModalExclusionType modalExclusionType) 返回此工具包是否支持给定的模式排斥类型。
void | Window.setModalExclusionType(Dialog.ModalExclusionType exclusionType) 指定此窗口的模式排斥类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Dialog.ModalityType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Dialog.ModalityType
的使用

使用 Dialog.ModalityType 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Dialog.ModalityType 的使用

声明为 Dialog.ModalityType 的 java.awt 中的字段
static Dialog.ModalityType Dialog.DEFAULT_MODALITY_TYPE
有模式 dialog 的默认模式类型。

返回 Dialog.ModalityType 的 java.awt 中的方法
Dialog.ModalityType | Dialog.getModalityType() 返回此 dialog 的模式类型。
static Dialog.ModalityType | Dialog.ModalityType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Dialog.ModalityType[] | Dialog.ModalityType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Dialog.ModalityType 的 java.awt 中的方法
abstract boolean | Toolkit.isModalityTypeSupported(Dialog.ModalityType modalityType) 返回此工具包是否支持给定的模式类型。
void | Dialog.setModalityType(Dialog.ModalityType type) 设置此 dialog 的模式类型。

参数类型为 Dialog.ModalityType 的 java.awt 中的构造方法
Dialog(Window owner, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定所有者 Window、模式和一个空标题。
Dialog(Window owner, String title, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题和模式。
Dialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。

javax.swing 中 Dialog.ModalityType 的使用

参数类型为 Dialog.ModalityType 的 javax.swing 中的构造方法
JDialog(Window owner, Dialog.ModalityType modalityType)
创建一个具有指定所有者 Window、模式和空标题的对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType)
创建一个具有指定标题、所有者 Window 和模式的对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Dimension 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Dimension
的使用

使用 Dimension 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.imageio | Java Image I/O API 的主要包。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 Dimension 的使用

参数类型为 Dimension 的 java.applet 中的方法
 void Applet.resize(Dimension d)
请求调整此 applet 的大小。

java.awt 中 Dimension 的使用

返回 Dimension 的 java.awt 中的方法
 Dimension Toolkit.getBestCursorSize(int preferredWidth, int preferredHeight)
返回最接近所需大小的受支持光标尺寸。
 Dimension Container.getMaximumSize()
返回此容器的最大大小。
 Dimension Component.getMaximumSize()
获取组件的最大大小。
 Dimension List.getMinimumSize()
确定此滚动列表的最小大小。
 Dimension TextArea.getMinimumSize()
确定此文本区的最小大小。
 Dimension TextField.getMinimumSize()
获取此文本字段的最小尺寸。
 Dimension Container.getMinimumSize()
返回此容器的最小大小。
 Dimension Component.getMinimumSize()
获取组件的最小大小。
 Dimension List.getMinimumSize(int rows)
获取具有指定行数的列表的最少维数。
 Dimension TextField.getMinimumSize(int columns)
获取具有指定列数的文本字段的最小尺寸。
 Dimension TextArea.getMinimumSize(int rows, int columns)
确定具有指定行数和列数的文本区的最小大小。
protected  Dimension GridBagLayout.getMinSize(Container parent, GridBagLayoutInfo info)
基于 getLayoutInfo 中的信息计算其所有者的最小大小。
protected  Dimension GridBagLayout.GetMinSize(Container parent, GridBagLayoutInfo info)
此方法已过时，仅为提供向后兼容性；新代码应该调用 getMinSize 来代替。
abstract  Dimension PrintJob.getPageDimension()
返回页面的维数，以像素为单位。
 Dimension List.getPreferredSize()
获取此滚动列表的首选大小。
 Dimension TextArea.getPreferredSize()
确定此文本区的首选大小。
 Dimension TextField.getPreferredSize()
获取此文本字段的首选大小。
 Dimension Container.getPreferredSize()
返回此容器的首选大小。
 Dimension Component.getPreferredSize()
获取组件的首选大小。
 Dimension List.getPreferredSize(int rows)
获取具有指定行数的列表的首选维数。
 Dimension TextField.getPreferredSize(int columns)
获取具有指定列数的文本字段的首选大小。
 Dimension TextArea.getPreferredSize(int rows, int columns)
确定具有指定行数和列数的文本区的首选大小。
abstract  Dimension Toolkit.getScreenSize()
获取屏幕的大小。
 Dimension List.AccessibleAWTList.AccessibleAWTListChild.getSize()
以 Dimension 对象的形式返回此对象的大小。
 Dimension SplashScreen.getSize()
以 Dimension 形式返回闪现屏幕窗口的大小。
 Dimension TrayIcon.getSize()
返回托盘图标在系统托盘上占用的空间大小（以像素为单位）。
 Dimension MenuComponent.AccessibleAWTMenuComponent.getSize()
以 Dimension 对象的形式返回此对象的大小。
 Dimension Rectangle.getSize()
获取此 Rectangle 的大小，用返回的 Dimension 表示。
 Dimension Dimension.getSize()
获取此 Dimension 对象的大小。
 Dimension Component.getSize()
以 Dimension 对象的形式返回组件的大小。
 Dimension Component.AccessibleAWTComponent.getSize()
返回此对象的大小，用 Dimension 对象的形式表示它。
 Dimension Component.getSize(Dimension rv)
将组件的宽度/高度存储到“返回值”rv 中并返回 rv。
 Dimension SystemTray.getTrayIconSize()
返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。
 Dimension ScrollPane.getViewportSize()
返回滚动条窗格视口的当前大小。
 Dimension GridBagLayout.maximumLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的最大维数
 Dimension CardLayout.maximumLayoutSize(Container target)
给出指定目标容器中的组件，返回此布局的最大尺寸。
 Dimension BorderLayout.maximumLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的最大尺寸。
 Dimension LayoutManager2.maximumLayoutSize(Container target)
给定指定容器的组件，计算该容器的最大大小维数。
 Dimension GridBagLayout.minimumLayoutSize(Container parent)
使用此网格包布局确定 parent 容器的最小大小。
 Dimension GridLayout.minimumLayoutSize(Container parent)
使用此网络布局确定最小大小的容器参数。
 Dimension CardLayout.minimumLayoutSize(Container parent)
计算指定面板大小的最小值。
 Dimension FlowLayout.minimumLayoutSize(Container target)
返回需要布置 visible 组件的最小维数，该组件包含在指定的目标容器中。
 Dimension BorderLayout.minimumLayoutSize(Container target)
使用此布局管理器确定 target 容器的最小大小。
 Dimension LayoutManager.minimumLayoutSize(Container parent)
给定指定容器所包含的组件，计算该容器的最小大小维数。
 Dimension List.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension TextArea.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension TextField.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension Container.minimumSize()
已过时。 从 JDK version 1.1 开始，用 getMinimumSize() 取代。
 Dimension Component.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension List.minimumSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
 Dimension TextField.minimumSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
 Dimension TextArea.minimumSize(int rows, int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int, int) 取代。
 Dimension GridBagLayout.preferredLayoutSize(Container parent)
使用此网络包布局确定 parent 容器的首选大小。
 Dimension GridLayout.preferredLayoutSize(Container parent)
使用此网格布局确定容器参数的首选大小。
 Dimension CardLayout.preferredLayoutSize(Container parent)
使用此卡片布局确定容器参数的首选大小。
 Dimension FlowLayout.preferredLayoutSize(Container target)
给出指定目标容器中的 visible 组件，返回此布局的首选维数。
 Dimension BorderLayout.preferredLayoutSize(Container target)
基于容器中的组件，使用此布局管理器确定 target 容器的首选大小。
 Dimension LayoutManager.preferredLayoutSize(Container parent)
给定指定容器所包含的组件，计算该容器的首选大小维数。
 Dimension List.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension TextArea.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension TextField.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension Container.preferredSize()
已过时。 从 JDK version 1.1 开始，用 getPreferredSize() 取代。
 Dimension Component.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension List.preferredSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
 Dimension TextField.preferredSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
 Dimension TextArea.preferredSize(int rows, int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int, int) 取代。
 Dimension Component.size()
已过时。 从 JDK version 1.1 开始，由 getSize() 取代。

参数类型为 Dimension 的 java.awt 中的方法
Dimension | Component.getSize(Dimension rv) 将组件的宽度/高度存储到“返回值”rv 中并返回 rv。
void | Component.resize(Dimension d) 已过时。 从 JDK version 1.1 开始，由 setSize(Dimension) 取代。
void | Component.setMaximumSize(Dimension maximumSize) 将组件的最大大小设置为常量值。
void | Window.setMinimumSize(Dimension minimumSize) 将此窗口的最小大小设置为一个常量值。
void | Component.setMinimumSize(Dimension minimumSize) 将组件的最小大小设置为常量值。
void | Component.setPreferredSize(Dimension preferredSize) 将组件的首选大小设置为常量值。
void | List.AccessibleAWTList.AccessibleAWTListChild.setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | MenuComponent.AccessibleAWTMenuComponent.setSize(Dimension d) 调整此对象的大小。
void | Rectangle.setSize(Dimension d) 设置此 Rectangle 的大小，以匹配指定的 Dimension。
void | Dimension.setSize(Dimension d) 将 Dimension 对象的大小设置为指定大小。
void | Window.setSize(Dimension d) 调整组件的大小，使其宽度为 d.width，高度为 d.height。
void | Component.setSize(Dimension d) 调整组件的大小，使其宽度为 d.width，高度为 d.height。
void | Component.AccessibleAWTComponent.setSize(Dimension d) 调整此对象的大小，使它具有宽度和高度。

参数类型为 Dimension 的 java.awt 中的构造方法
Dimension(Dimension d)
创建 Dimension 的一个实例（宽度和高度与指定的 dimension 相同）。
Rectangle(Dimension d)
构造一个新的 Rectangle，其左上角为 (0,0)，其宽度和高度由 Dimension 参数指定。
Rectangle(Point p, Dimension d)
构造一个新的 Rectangle，其左上角由 Point 参数指定，其宽度和高度由 Dimension 参数指定。

javax.accessibility 中 Dimension 的使用

返回 Dimension 的 javax.accessibility 中的方法
 Dimension AccessibleComponent.getSize()
以 Dimension 对象的形式返回此对象的大小。

参数类型为 Dimension 的 javax.accessibility 中的方法
 void AccessibleComponent.setSize(Dimension d)
调整此对象，使其具有高度和宽度。

javax.imageio 中 Dimension 的使用

声明为 Dimension 的 javax.imageio 中的字段
protected Dimension[] | ImageWriteParam.preferredTileSizes 首选 tile 大小范围对组成的数组。
protected Dimension | ImageReadParam.sourceRenderSize 如果 canSetSourceRenderSize 为 true，则为源的所需呈现宽度和高度；或者为 null。

返回 Dimension 的 javax.imageio 中的方法
Dimension[] | ImageWriter.getPreferredThumbnailSizes(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
Dimension[] | ImageWriteParam.getPreferredTileSizes() 返回一个 Dimension 数组，指示在输出文件或流中进行编码时 tile 的合法大小范围。
Dimension | ImageReadParam.getSourceRenderSize() 返回解码期间将呈现的源图像的宽度和高度，如果已经通过 setSourceRenderSize 方法设置了的话。

参数类型为 Dimension 的 javax.imageio 中的方法
 void ImageReadParam.setSourceRenderSize(Dimension size)
如果能够以任意大小呈现图像，则将源宽度和高度设置为所提供的值。

javax.swing 中 Dimension 的使用

声明为 Dimension 的 javax.swing 中的字段
protected  Dimension JTable.preferredViewportSize
Scrollable 接口使用它来确定初始的可见区域。

返回 Dimension 的 javax.swing 中的方法
Dimension | UIDefaults.getDimension(Object key) 如果 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
static Dimension | UIManager.getDimension(Object key) 从默认值中返回一个维数。
Dimension | UIDefaults.getDimension(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
static Dimension | UIManager.getDimension(Object key, Locale l) 从适合给定语言环境的默认值中返回一个维数。
Dimension | RepaintManager.getDoubleBufferMaximumSize() 返回最大双缓冲区大小。
Dimension | JViewport.getExtentSize() 返回视图坐标中视图的可见部分的大小。
Dimension | JTable.getIntercellSpacing() 返回单元格之间的水平间距和垂直间距。
Dimension | JScrollBar.getMaximumSize() 滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。
Dimension | JToolBar.Separator.getMaximumSize() 返回分隔符的最小大小。
Dimension | JComponent.getMaximumSize() 如果已将最大大小设置为一个非 null 值，则返回该值。
Dimension | JScrollBar.getMinimumSize() 滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。
Dimension | JToolBar.Separator.getMinimumSize() 返回分隔符的最小大小。
Dimension | JComponent.getMinimumSize() 如果已将最小大小设置为一个非 null 值，则返回该值。
Dimension | JTree.getPreferredScrollableViewportSize() 返回 JTree 的首选显示大小。
Dimension | JTable.getPreferredScrollableViewportSize() 返回此表视口的首选大小。
Dimension | JTextArea.getPreferredScrollableViewportSize() 如果此组件被嵌入 JScrollPane 中，则返回 viewport 的首选大小。
Dimension | JList.getPreferredScrollableViewportSize() 计算显示 visibleRowCount 行所需的视口的大小。
Dimension | Scrollable.getPreferredScrollableViewportSize() 返回视图组件视口的首选大小。
Dimension | JEditorPane.getPreferredSize() 返回该 JEditorPane 的首选大小。
Dimension | JTextArea.getPreferredSize() 返回 TextArea 的首选大小。
Dimension | JTextField.getPreferredSize() 返回此 TextField 所需的首选大小 Dimensions。
Dimension | JToolBar.Separator.getPreferredSize() 返回分隔符的首选大小。
Dimension | JComponent.getPreferredSize() 如果 preferredSize 已设置为一个非 null 值，则返回该值。
Dimension | JToolBar.Separator.getSeparatorSize() 返回分隔符的大小
Dimension | JTree.AccessibleJTree.AccessibleJTreeNode.getSize()
Dimension | JTable.AccessibleJTable.AccessibleJTableCell.getSize()
Dimension | JList.AccessibleJList.AccessibleJListChild.getSize()
Dimension | JComponent.getSize(Dimension rv) 将此组件的宽度/高度存储到“返回值”rv 中并返回 rv。
Dimension | JViewport.getViewSize() 如果未显式设置视图的大小，则返回首选大小，否则返回该视图的当前大小。
Dimension | GroupLayout.maximumLayoutSize(Container parent) 返回指定容器的最大大小。
Dimension | OverlayLayout.maximumLayoutSize(Container target) 返回需要布置组件的最大维数，该组件包含在指定的目标容器中。
Dimension | SpringLayout.maximumLayoutSize(Container parent)
Dimension | BoxLayout.maximumLayoutSize(Container target) 返回目标容器布置其所包含的组件时可使用的最大尺寸。
Dimension | JRootPane.RootLayout.maximumLayoutSize(Container target) 返回布局能够使用的最大空间量。
Dimension | GroupLayout.minimumLayoutSize(Container parent) 返回指定容器的最小大小。
Dimension | JSpinner.DefaultEditor.minimumLayoutSize(Container parent) 返回第一个（并且是唯一）的子级最小大小与其父 insets 的大小和。
Dimension | OverlayLayout.minimumLayoutSize(Container target) 返回需要布置组件的最小维数，该组件包含在指定的目标容器中。
Dimension | SpringLayout.minimumLayoutSize(Container parent)
Dimension | ViewportLayout.minimumLayoutSize(Container parent) 返回需要布置指定目标容器中包含的组件的最小维数。
Dimension | ScrollPaneLayout.minimumLayoutSize(Container parent) ScrollPane 的最小大小是 insets 加上视口最小大小，加上可见标题的最小大小，加上 displayPolicy 不为 NEVER 的滚动条的最小大小。
Dimension | BoxLayout.minimumLayoutSize(Container target) 返回布置包含在指定目标容器中的组件所需的最小尺寸。
Dimension | JRootPane.RootLayout.minimumLayoutSize(Container parent) 返回布局需要的最小空间量。
Dimension | GroupLayout.preferredLayoutSize(Container parent) 返回指定容器的首选大小。
Dimension | JSpinner.DefaultEditor.preferredLayoutSize(Container parent) 返回第一个（并且是唯一）子级的首选大小与其父 insets 的大小和。
Dimension | OverlayLayout.preferredLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
Dimension | SpringLayout.preferredLayoutSize(Container parent)
Dimension | ViewportLayout.preferredLayoutSize(Container parent) 在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
Dimension | ScrollPaneLayout.preferredLayoutSize(Container parent) ScrollPane 的首选大小是 insets 的大小加上视口的首选大小、可见标题首选大小以及滚动条的首选大小，它按照给定的当前视图和当前滚动条策略显示。
Dimension | BoxLayout.preferredLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的首选尺寸。
Dimension | JRootPane.RootLayout.preferredLayoutSize(Container parent) 返回布局要使用的空间量。
Dimension | JViewport.toViewCoordinates(Dimension size) 将一个大小的像素坐标转换为视图坐标。

参数类型为 Dimension 的 javax.swing 中的方法
void | JToolBar.addSeparator(Dimension size) 将指定大小的分隔符添加到工具栏的末尾。
void | Box.Filler.changeShape(Dimension min, Dimension pref, Dimension max) 更改此形状的大小请求。
protected boolean | JViewport.computeBlit(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint) 计算 blit 的参数，其中后备存储图像当前在左上角包含 oldLoc，并且我们滚动到 newLoc。
static Component | Box.createRigidArea(Dimension d) 创建一个总是具有指定大小的不可见组件。
Dimension | JComponent.getSize(Dimension rv) 将此组件的宽度/高度存储到“返回值”rv 中并返回 rv。
void | RepaintManager.setDoubleBufferMaximumSize(Dimension d) 设置最大双缓冲区大小。
void | JViewport.setExtentSize(Dimension newExtent) 使用视图坐标设置该视图可见部分的大小。
void | JTable.setIntercellSpacing(Dimension intercellSpacing) 将 rowMargin 和 columnMargin（单元格之间间距的高度和宽度）设置为 intercellSpacing。
void | JComponent.setMaximumSize(Dimension maximumSize) 将此组件的最大大小设置为一个常量值。
void | JComponent.setMinimumSize(Dimension minimumSize) 将此组件的最小大小设置为一个常量值。
void | JPopupMenu.setPopupSize(Dimension d) 使用 Dimension 对象设置弹出窗口的大小。
void | JTable.setPreferredScrollableViewportSize(Dimension size) 设置此表视口的首选大小。
void | JComponent.setPreferredSize(Dimension preferredSize) 设置此组件的首选大小。
void | JToolBar.Separator.setSeparatorSize(Dimension size) 设置分隔符的大小。
void | JTree.AccessibleJTree.AccessibleJTreeNode.setSize(Dimension d)
void | JTable.AccessibleJTable.AccessibleJTableCell.setSize(Dimension d)
void | JList.AccessibleJList.AccessibleJListChild.setSize(Dimension d)
void | JViewport.setViewSize(Dimension newSize) 设置视图的大小。
Dimension | JViewport.toViewCoordinates(Dimension size) 将一个大小的像素坐标转换为视图坐标。

参数类型为 Dimension 的 javax.swing 中的构造方法
Box.Filler(Dimension min, Dimension pref, Dimension max)
使用给定的大小范围创建形状的构造方法。
JToolBar.Separator(Dimension size)
创建具有指定大小的新的工具栏分隔符。

javax.swing.border 中 Dimension 的使用

返回 Dimension 的 javax.swing.border 中的方法
 Dimension TitledBorder.getMinimumSize(Component c)
返回此边框完全显示边框和标题所需的最小大小。

javax.swing.plaf 中 Dimension 的使用

javax.swing.plaf 中 Dimension 的子类
 class DimensionUIResource

返回 Dimension 的 javax.swing.plaf 中的方法
Dimension | ComponentUI.getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | ComponentUI.getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | ComponentUI.getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。

javax.swing.plaf.basic 中 Dimension 的使用

声明为 Dimension 的 javax.swing.plaf.basic 中的字段
protected Dimension | BasicComboBoxUI.cachedMinimumSize
protected Dimension | BasicScrollBarUI.maximumThumbSize
protected Dimension | BasicOptionPaneUI.minimumSize
protected Dimension | BasicScrollBarUI.minimumThumbSize
protected Dimension | BasicTreeUI.preferredMinSize 最小首选大小。
protected Dimension | BasicTreeUI.preferredSize 完全显示所有节点所需的大小。

返回 Dimension 的 javax.swing.plaf.basic 中的方法
protected  Dimension BasicTabbedPaneUI.TabbedPaneLayout.calculateSize(boolean minimum)
protected  Dimension BasicComboBoxUI.getDefaultSize()
返回使用当前渲染器和字体的组合框的空显示区域的默认大小。
protected  Dimension BasicComboBoxUI.getDisplaySize()
返回显示区域的计算大小。
 Dimension BasicArrowButton.getMaximumSize()
返回 BasicArrowButton 的最大大小。
 Dimension BasicDesktopIconUI.getMaximumSize(JComponent c)
不能调整桌面图标的大小。
 Dimension BasicDesktopPaneUI.getMaximumSize(JComponent c)
 Dimension BasicInternalFrameUI.getMaximumSize(JComponent x)
 Dimension BasicToolTipUI.getMaximumSize(JComponent c)
 Dimension BasicSliderUI.getMaximumSize(JComponent c)
 Dimension BasicSplitPaneUI.getMaximumSize(JComponent jc)
返回传入组件的最大大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getMaximumSize(JComponent c)
返回此组件的最大大小，如果实例当前位于 JTree 中或 0, 0 处，则该大小将为首选大小。
 Dimension BasicTableUI.getMaximumSize(JComponent c)
返回表的最大大小。
 Dimension BasicTableHeaderUI.getMaximumSize(JComponent c)
返回标题的最大大小。
 Dimension BasicProgressBarUI.getMaximumSize(JComponent c)
 Dimension BasicTabbedPaneUI.getMaximumSize(JComponent c)
 Dimension BasicTextUI.getMaximumSize(JComponent c)
获取编辑器组件的最大大小。
 Dimension BasicScrollPaneUI.getMaximumSize(JComponent c)
 Dimension BasicComboBoxUI.getMaximumSize(JComponent c)
 Dimension BasicScrollBarUI.getMaximumSize(JComponent c)
 Dimension BasicSeparatorUI.getMaximumSize(JComponent c)
 Dimension BasicMenuUI.getMaximumSize(JComponent c)
 Dimension BasicMenuItemUI.getMaximumSize(JComponent c)
 Dimension BasicMenuBarUI.getMaximumSize(JComponent c)
 Dimension BasicButtonUI.getMaximumSize(JComponent c)
 Dimension BasicLabelUI.getMaximumSize(JComponent c)
protected  Dimension BasicScrollBarUI.getMaximumThumbSize()
返回 thumb 的最大可接受大小。
 Dimension BasicSliderUI.getMinimumHorizontalSize()
 Dimension BasicOptionPaneUI.getMinimumOptionPaneSize()
返回选项窗格应该具有的最小大小。
 Dimension BasicSplitPaneDivider.getMinimumSize()
返回 dividerSize x dividerSize
 Dimension BasicArrowButton.getMinimumSize()
返回 BasicArrowButton 的最小大小。
 Dimension BasicDesktopIconUI.getMinimumSize(JComponent c)
 Dimension BasicDesktopPaneUI.getMinimumSize(JComponent c)
 Dimension BasicInternalFrameUI.getMinimumSize(JComponent x)
 Dimension BasicToolTipUI.getMinimumSize(JComponent c)
 Dimension BasicSliderUI.getMinimumSize(JComponent c)
 Dimension BasicTextAreaUI.getMinimumSize(JComponent c)
重写此方法以将插入符的宽度考虑在内。
 Dimension BasicSplitPaneUI.getMinimumSize(JComponent jc)
返回传入组件的最小大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getMinimumSize(JComponent c)
返回此组件的最小大小。
 Dimension BasicTableUI.getMinimumSize(JComponent c)
返回表的最小大小。
 Dimension BasicTableHeaderUI.getMinimumSize(JComponent c)
返回标题的最小大小。
 Dimension BasicProgressBarUI.getMinimumSize(JComponent c)
此组件的最小大小为 10。
 Dimension BasicTabbedPaneUI.getMinimumSize(JComponent c)
 Dimension BasicTextUI.getMinimumSize(JComponent c)
获取编辑器组件的最小大小。
 Dimension BasicComboBoxUI.getMinimumSize(JComponent c)
最小大小为显示区域加上 insets 再加上按钮的大小。
 Dimension BasicSeparatorUI.getMinimumSize(JComponent c)
 Dimension BasicMenuItemUI.getMinimumSize(JComponent c)
 Dimension BasicMenuBarUI.getMinimumSize(JComponent c)
 Dimension BasicButtonUI.getMinimumSize(JComponent c)
 Dimension BasicLabelUI.getMinimumSize(JComponent c)
protected  Dimension BasicScrollBarUI.getMinimumThumbSize()
返回 thumb 的最小可接受大小。
 Dimension BasicSliderUI.getMinimumVerticalSize()
static Dimension BasicGraphicsUtils.getPreferredButtonSize(AbstractButton b, int textIconGap)
 Dimension BasicSliderUI.getPreferredHorizontalSize()
protected  Dimension BasicProgressBarUI.getPreferredInnerHorizontal()
protected  Dimension BasicProgressBarUI.getPreferredInnerVertical()
protected  Dimension BasicMenuItemUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
 Dimension BasicTreeUI.getPreferredMinSize()
返回最小首选大小。
 Dimension BasicSplitPaneDivider.getPreferredSize()
返回 dividerSize x dividerSize
 Dimension BasicComboBoxRenderer.getPreferredSize()
 Dimension BasicArrowButton.getPreferredSize()
返回 BasicArrowButton 的首选大小。
 Dimension BasicDesktopIconUI.getPreferredSize(JComponent c)
 Dimension BasicDesktopPaneUI.getPreferredSize(JComponent c)
 Dimension BasicInternalFrameUI.getPreferredSize(JComponent x)
 Dimension BasicOptionPaneUI.getPreferredSize(JComponent c)
如果 c 为包含接收者的 JOptionPane，则返回的首选大小为 JOptionPane 的 LayoutManager 的最大首选大小和 getMinimumOptionPaneSize。
 Dimension BasicPopupMenuSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicToolTipUI.getPreferredSize(JComponent c)
 Dimension BasicSliderUI.getPreferredSize(JComponent c)
 Dimension BasicTextAreaUI.getPreferredSize(JComponent c)
重写此方法以将插入符的宽度考虑在内。
 Dimension BasicSplitPaneUI.getPreferredSize(JComponent jc)
返回传入组件的首选大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getPreferredSize(JComponent c)
返回首选大小以正确显示树，这是一种 getPreferredSize(c, false) 的替代方法。
 Dimension BasicTableUI.getPreferredSize(JComponent c)
返回表的首选大小。
 Dimension BasicTableHeaderUI.getPreferredSize(JComponent c)
返回标题的首选大小。
 Dimension BasicProgressBarUI.getPreferredSize(JComponent c)
 Dimension BasicRadioButtonUI.getPreferredSize(JComponent c)
单选按钮的首选大小。
 Dimension BasicToolBarSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicTextUI.getPreferredSize(JComponent c)
获取编辑器组件的首选大小。
 Dimension BasicListUI.getPreferredSize(JComponent c)
列表的 preferredSize 依赖于布局方向。
 Dimension BasicComboBoxUI.getPreferredSize(JComponent c)
 Dimension BasicScrollBarUI.getPreferredSize(JComponent c)
垂直滚动条的首选宽度是（非 null）递增/递减按钮的首选宽度的最大值，也是 thumb 的最小宽度。
 Dimension BasicSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicMenuItemUI.getPreferredSize(JComponent c)
 Dimension BasicButtonUI.getPreferredSize(JComponent c)
 Dimension BasicLabelUI.getPreferredSize(JComponent c)
 Dimension BasicTreeUI.getPreferredSize(JComponent c, boolean checkConsistancy)
返回首选大小以表示 c 中的树。
 Dimension BasicSliderUI.getPreferredVerticalSize()
protected  Dimension BasicSliderUI.getThumbSize()
 Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.maximumLayoutSize(Container target)
返回最大布局大小，该大小在两个方向上都是 Integer.MAX_VALUE。
 Dimension BasicInternalFrameTitlePane.TitlePaneLayout.minimumLayoutSize(Container c)
 Dimension BasicInternalFrameUI.InternalFrameLayout.minimumLayoutSize(Container c)
 Dimension BasicOptionPaneUI.ButtonAreaLayout.minimumLayoutSize(Container c)
 Dimension BasicSplitPaneDivider.DividerLayout.minimumLayoutSize(Container c)
 Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.minimumLayoutSize(Container container)
返回包含子级所需的最小大小。
 Dimension BasicTabbedPaneUI.TabbedPaneLayout.minimumLayoutSize(Container parent)
 Dimension BasicComboBoxUI.ComboBoxLayoutManager.minimumLayoutSize(Container parent)
 Dimension BasicScrollBarUI.minimumLayoutSize(Container scrollbarContainer)
 Dimension BasicInternalFrameTitlePane.TitlePaneLayout.preferredLayoutSize(Container c)
 Dimension BasicInternalFrameUI.InternalFrameLayout.preferredLayoutSize(Container c)
 Dimension BasicOptionPaneUI.ButtonAreaLayout.preferredLayoutSize(Container c)
 Dimension BasicSplitPaneDivider.DividerLayout.preferredLayoutSize(Container c)
 Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.preferredLayoutSize(Container container)
返回包含子级所需的首选大小。
 Dimension BasicTabbedPaneUI.TabbedPaneLayout.preferredLayoutSize(Container parent)
 Dimension BasicComboBoxUI.ComboBoxLayoutManager.preferredLayoutSize(Container parent)
 Dimension BasicScrollBarUI.preferredLayoutSize(Container scrollbarContainer)
 Dimension DefaultMenuLayout.preferredLayoutSize(Container target)

参数类型为 Dimension 的 javax.swing.plaf.basic 中的方法
protected int | BasicSplitPaneUI.BasicHorizontalLayoutManager.getAvailableSize(Dimension containerSize, Insets insets) 返回基于容器大小和 Insets 的可用宽度。
protected void | BasicRadioButtonUI.paintFocus(Graphics g, Rectangle textRect, Dimension size)
protected void | BasicSplitPaneUI.BasicHorizontalLayoutManager.setComponentToSize(Component c, int size, int location, Insets insets, Dimension containerSize) 将组件 c 的宽度设置为 size（将其 x 的位置放置到 location），将 y 和高度分别设置为 insets.top 和 containersize.height 减去上下 insets。
void | BasicTreeUI.setPreferredMinSize(Dimension newSize) 设置首选最小大小。

javax.swing.plaf.metal 中 Dimension 的使用

返回 Dimension 的 javax.swing.plaf.metal 中的方法
Dimension | MetalScrollButton.getMaximumSize()
Dimension | MetalDesktopIconUI.getMaximumSize(JComponent c)
Dimension | MetalFileChooserUI.getMaximumSize(JComponent c) 返回 JFileChooser 的最大大小。
Dimension | MetalComboBoxButton.getMinimumSize()
Dimension | MetalScrollButton.getMinimumSize()
Dimension | MetalDesktopIconUI.getMinimumSize(JComponent c)
Dimension | MetalFileChooserUI.getMinimumSize(JComponent c) 返回 JFileChooser 的最小大小。
Dimension | MetalComboBoxUI.getMinimumSize(JComponent c)
protected Dimension | MetalScrollBarUI.getMinimumThumbSize()
Dimension | MetalScrollButton.getPreferredSize()
Dimension | MetalDesktopIconUI.getPreferredSize(JComponent c)
Dimension | MetalFileChooserUI.getPreferredSize(JComponent c) 返回指定 JFileChooser 的首选大小。
Dimension | MetalToolTipUI.getPreferredSize(JComponent c)
Dimension | MetalScrollBarUI.getPreferredSize(JComponent c)
Dimension | MetalPopupMenuSeparatorUI.getPreferredSize(JComponent c)
Dimension | MetalSeparatorUI.getPreferredSize(JComponent c)
protected Dimension | MetalSliderUI.getThumbSize()

参数类型为 Dimension 的 javax.swing.plaf.metal 中的方法
protected  void MetalRadioButtonUI.paintFocus(Graphics g, Rectangle t, Dimension d)

javax.swing.plaf.multi 中 Dimension 的使用

返回 Dimension 的 javax.swing.plaf.multi 中的方法
Dimension | MultiButtonUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiColorChooserUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiComboBoxUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiDesktopIconUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiDesktopPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiFileChooserUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法
Dimension | MultiInternalFrameUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiLabelUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiListUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiMenuBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiMenuItemUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiOptionPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiPanelUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiPopupMenuUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiProgressBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiRootPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiScrollBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiScrollPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSeparatorUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSliderUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSpinnerUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSplitPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTabbedPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTableHeaderUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTableUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTextUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiToolBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiToolTipUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTreeUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiViewportUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiButtonUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiColorChooserUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiComboBoxUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiDesktopIconUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiDesktopPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiFileChooserUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiInternalFrameUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiLabelUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiListUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiMenuBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiMenuItemUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiOptionPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiPanelUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiPopupMenuUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiProgressBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiRootPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiScrollBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiScrollPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSeparatorUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSliderUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSpinnerUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSplitPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTabbedPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTableHeaderUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTableUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTextUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiToolBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiToolTipUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTreeUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiViewportUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiButtonUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiColorChooserUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiComboBoxUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiDesktopIconUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiDesktopPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiFileChooserUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiInternalFrameUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiLabelUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiListUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiMenuBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiMenuItemUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiOptionPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiPanelUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiPopupMenuUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiProgressBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiRootPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiScrollBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiScrollPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSeparatorUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSliderUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSpinnerUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSplitPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTabbedPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTableHeaderUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTableUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTextUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiToolBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiToolTipUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTreeUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiViewportUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

javax.swing.plaf.synth 中 Dimension 的使用

返回 Dimension 的 javax.swing.plaf.synth 中的方法
Dimension | SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最大大小。
Dimension | SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最小大小。
Dimension | SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的首选大小。

javax.swing.table 中 Dimension 的使用

返回 Dimension 的 javax.swing.table 中的方法
 Dimension JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getSize()

参数类型为 Dimension 的 javax.swing.table 中的方法
 void JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setSize(Dimension d)

javax.swing.text 中 Dimension 的使用

返回 Dimension 的 javax.swing.text 中的方法
 Dimension JTextComponent.getPreferredScrollableViewportSize()
返回视图组件视口的首选大小。

javax.swing.tree 中 Dimension 的使用

返回 Dimension 的 javax.swing.tree 中的方法
Dimension | DefaultTreeCellEditor.DefaultTextField.getPreferredSize() 重写 JTextField.getPreferredSize，以根据当前字体（如果设置）返回首选大小，否则使用 renderer 的字体。
Dimension | DefaultTreeCellEditor.EditorContainer.getPreferredSize() 返回 Container 的首选大小。
Dimension | DefaultTreeCellRenderer.getPreferredSize() 重写 JComponent.getPreferredSize，以返回稍宽的首选大小值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.DisplayMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.DisplayMode
的使用

使用 DisplayMode 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 DisplayMode 的使用

返回 DisplayMode 的 java.awt 中的方法
DisplayMode | GraphicsDevice.getDisplayMode() 返回此 GraphicsDevice 的当前显示模式。
DisplayMode[] | GraphicsDevice.getDisplayModes() 返回可用于此 GraphicsDevice 的所有显示模式。

参数类型为 DisplayMode 的 java.awt 中的方法
boolean | DisplayMode.equals(DisplayMode dm) 返回对两个显示模式是否相同的判断。
void | GraphicsDevice.setDisplayMode(DisplayMode dm) 设置此图形设备的显示模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Event 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Event
的使用

使用 Event 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Event 的使用

声明为 Event 的 java.awt 中的字段
 Event Event.evt
下一事件。

参数类型为 Event 的 java.awt 中的方法
boolean | Component.action(Event evt, Object what) 已过时。 从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。
void | Container.deliverEvent(Event e) 已过时。 从 JDK version 1.1 开始，用 dispatchEvent(AWTEvent e) 取代
void | Component.deliverEvent(Event e) 已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent e) 取代。
boolean | Component.gotFocus(Event evt, Object what) 已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
boolean | Component.handleEvent(Event evt) 已过时。 从 JDK version 1.1 开始，由 processEvent(AWTEvent) 取代。
boolean | Component.keyDown(Event evt, int key) 已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
boolean | Component.keyUp(Event evt, int key) 已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
boolean | Component.lostFocus(Event evt, Object what) 已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
boolean | Component.mouseDown(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
boolean | Component.mouseDrag(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
boolean | Component.mouseEnter(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
boolean | Component.mouseExit(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
boolean | Component.mouseMove(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
boolean | Component.mouseUp(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
boolean | MenuComponent.postEvent(Event evt) 已过时。 从 JDK version 1.1 开始，已由 dispatchEvent 取代。
boolean | Window.postEvent(Event e) 已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
boolean | Component.postEvent(Event e) 已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
boolean | MenuContainer.postEvent(Event evt) 已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。

参数类型为 Event 的 java.awt 中的构造方法
AWTEvent(Event event)
从 1.0 样式的事件参数构造一个 AWTEvent 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.EventQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.EventQueue
的使用

使用 EventQueue 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 EventQueue 的使用

返回 EventQueue 的 java.awt 中的方法
EventQueue | Toolkit.getSystemEventQueue() 获取应用程序或 applet 的 EventQueue 实例。
protected abstract EventQueue | Toolkit.getSystemEventQueueImpl() 获取应用程序或 applet 的 EventQueue 实例，不检查访问权。

参数类型为 EventQueue 的 java.awt 中的方法
 void EventQueue.push(EventQueue newEventQueue)
用指定的事件队列替换现有的 EventQueue。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.FileDialog 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.FileDialog
的使用

使用 FileDialog 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 FileDialog 的使用

参数类型为 FileDialog 的 java.awt 中的方法
protected abstract  java.awt.peer.FileDialogPeer Toolkit.createFileDialog(FileDialog target)
使用指定同位体接口创建此工具包的 FileDialog 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.FlowLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.FlowLayout
的使用

没有 java.awt.FlowLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.FocusTraversalPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.FocusTraversalPolicy
的使用

使用 FocusTraversalPolicy 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 FocusTraversalPolicy 的使用

java.awt 中 FocusTraversalPolicy 的子类
class | ContainerOrderFocusTraversalPolicy 根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
class | DefaultFocusTraversalPolicy 根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。

返回 FocusTraversalPolicy 的 java.awt 中的方法
FocusTraversalPolicy | KeyboardFocusManager.getDefaultFocusTraversalPolicy() 返回默认 FocusTraversalPolicy。
FocusTraversalPolicy | Container.getFocusTraversalPolicy() 返回焦点遍历策略，用于管理此 Container 子组件的键盘遍历；如果此 Container 不是一个焦点循环根，则返回 null。

参数类型为 FocusTraversalPolicy 的 java.awt 中的方法
void | KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy defaultPolicy) 设置默认 FocusTraversalPolicy。
void | Container.setFocusTraversalPolicy(FocusTraversalPolicy policy) 如果此 Container 是一个焦点循环根，则设置将管理此 Container 的子代的键盘遍历的焦点遍历策略。

javax.swing 中 FocusTraversalPolicy 的使用

javax.swing 中 FocusTraversalPolicy 的子类
class | InternalFrameFocusTraversalPolicy 该 FocusTraversalPolicy 可以有选择地提供确定 JInternalFrame 初始 Component 的算法。
class | LayoutFocusTraversalPolicy 根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。
class | SortingFocusTraversalPolicy 通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Font 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Font
的使用

使用 Font 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 Font 的使用

声明为 Font 的 java.awt 中的字段
protected  Font FontMetrics.font
实际的 Font，字体规格是由此创建的。

返回 Font 的 java.awt 中的方法
static Font | Font.createFont(int fontFormat, File fontFile) 返回一个使用指定字体类型和指定字体文件的新 Font。
static Font | Font.createFont(int fontFormat, InputStream fontStream) 返回一个使用指定字体类型和输入数据的新 Font。
static Font | Font.decode(String str) 返回 str 参数所描述的 Font。
Font | Font.deriveFont(AffineTransform trans) 通过复制当前 Font 对象并应用新的变换，创建一个新 Font 对象。
Font | Font.deriveFont(float size) 通过复制当前 Font 对象并应用新的大小，创建一个新 Font 对象。
Font | Font.deriveFont(int style) 通过复制当前的 Font 对象，并应用新的样式，创建一个新 Font 对象。
Font | Font.deriveFont(int style, AffineTransform trans) 通过复制此 Font 对象并应用新样式和变换，创建一个新 Font 对象。
Font | Font.deriveFont(int style, float size) 通过复制此 Font 对象并应用新样式和大小，创建一个新 Font 对象。
Font | Font.deriveFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 通过复制当前 Font 对象并应用新的字体属性集，创建一个新 Font 对象。
abstract Font[] | GraphicsEnvironment.getAllFonts() 返回一个数组，它包含此 GraphicsEnvironment 中所有可用字体的像素级实例。
Font | List.AccessibleAWTList.AccessibleAWTListChild.getFont() 获取此对象的 Font。
Font | FontMetrics.getFont() 获取此 FontMetrics 对象所描述的 Font。
Font | MenuComponent.getFont() 获取用于此菜单组件的字体。
Font | MenuComponent.AccessibleAWTMenuComponent.getFont() 获取此对象的 Font。
abstract Font | Graphics.getFont() 获取当前字体。
Font | Component.getFont() 获取组件的字体。
Font | Component.AccessibleAWTComponent.getFont() 获取此对象的 Font。
Font | MenuContainer.getFont()
static Font | Font.getFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 返回适合于这些属性的 Font。
static Font | Font.getFont(String nm) 从系统属性列表返回一个 Font 对象。
static Font | Font.getFont(String nm, Font font) 从系统属性列表获取指定的 Font。

参数类型为 Font 的 java.awt 中的方法
static Font | Font.getFont(String nm, Font font) 从系统属性列表获取指定的 Font。
FontMetrics | List.AccessibleAWTList.AccessibleAWTListChild.getFontMetrics(Font f) 设置此对象的 FontMetrics。
FontMetrics | MenuComponent.AccessibleAWTMenuComponent.getFontMetrics(Font f) 获取此对象的 FontMetrics。
abstract FontMetrics | Graphics.getFontMetrics(Font f) 获取指定字体的字体规格。
abstract FontMetrics | Toolkit.getFontMetrics(Font font) 已过时。 从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。
FontMetrics | Component.getFontMetrics(Font font) 获取指定字体的字体规格。
FontMetrics | Component.AccessibleAWTComponent.getFontMetrics(Font f) 获取此对象的 FontMetrics。
boolean | GraphicsEnvironment.registerFont(Font font) 在此 GraphicsEnvironment 中注册一个/已创建的 Font。
void | List.AccessibleAWTList.AccessibleAWTListChild.setFont(Font f) 设置此对象的 Font。
void | MenuComponent.setFont(Font f) 将用于此菜单组件的字体设置为指定字体。
void | MenuComponent.AccessibleAWTMenuComponent.setFont(Font f) 设置此对象的 Font。
abstract void | Graphics.setFont(Font font) 将此图形上下文的字体设置为指定字体。
void | Container.setFont(Font f) 设置此容器的字体。
void | Component.setFont(Font f) 设置组件的字体。
void | Component.AccessibleAWTComponent.setFont(Font f) 设置此对象的 Font。

参数类型为 Font 的 java.awt 中的构造方法
Font(Font font)
根据指定 font 创建一个新 Font。
FontMetrics(Font font)
创建一个新 FontMetrics 对象，用于查找该 Font 中关于指定 Font 和特定字符字形的 height 和 width 信息。

java.awt.font 中 Font 的使用

返回 Font 的 java.awt.font 中的方法
Font | MultipleMaster.deriveMMFont(float[] axes) 根据指定数组中包含的设计轴值，创建 multiple master 字体的新实例。
Font | MultipleMaster.deriveMMFont(float[] glyphWidths, float avgStemWidth, float typicalCapHeight, float typicalXHeight, float italicAngle) 根据详细的规格信息，创建 multiple master 字体的新实例。
abstract Font | GlyphVector.getFont() 返回与此 GlyphVector 关联的 Font。

参数类型为 Font 的 java.awt.font 中的构造方法
TextLayout(String string, Font font, FontRenderContext frc)
根据 String 和 Font 构造一个 TextLayout。

javax.accessibility 中 Font 的使用

返回 Font 的 javax.accessibility 中的方法
 Font AccessibleComponent.getFont()
获取此对象的 Font。

参数类型为 Font 的 javax.accessibility 中的方法
FontMetrics | AccessibleComponent.getFontMetrics(Font f) 获取此对象的 FontMetrics。
void | AccessibleComponent.setFont(Font f) 设置此对象的 Font。

javax.swing 中 Font 的使用

返回 Font 的 javax.swing 中的方法
Font | DebugGraphics.getFont() 返回用于文本绘制操作的 Font。
Font | JTree.AccessibleJTree.AccessibleJTreeNode.getFont()
Font | JTable.AccessibleJTable.AccessibleJTableCell.getFont() 获取此对象的 Font。
Font | JList.AccessibleJList.AccessibleJListChild.getFont()
Font | UIDefaults.getFont(Object key) 如果 key 值为一个 Font，则返回该 Font，否则返回 null。
static Font | UIManager.getFont(Object key) 从默认值返回一种字体。
Font | UIDefaults.getFont(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Font，则返回它，否则返回 null。
static Font | UIManager.getFont(Object key, Locale l) 从适合给定语言环境的默认值中返回一种字体。

参数类型为 Font 的 javax.swing 中的方法
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont) 向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor) 向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
FontMetrics | DebugGraphics.getFontMetrics(Font f) 重写 Graphics.getFontMetrics。
FontMetrics | JTree.AccessibleJTree.AccessibleJTreeNode.getFontMetrics(Font f)
FontMetrics | JTable.AccessibleJTable.AccessibleJTableCell.getFontMetrics(Font f) 获取此对象的 FontMetrics。
FontMetrics | JList.AccessibleJList.AccessibleJListChild.getFontMetrics(Font f)
FontMetrics | JComponent.getFontMetrics(Font font) 获取指定 Font 的 FontMetrics。
void | DebugGraphics.setFont(Font aFont) 设置用于文本绘制操作的 Font。
void | JSlider.setFont(Font font) 设置此组件的字体。
void | JTree.AccessibleJTree.AccessibleJTreeNode.setFont(Font f)
void | JTable.AccessibleJTable.AccessibleJTableCell.setFont(Font f) 设置此对象的 Font。
void | JTextArea.setFont(Font f) 设置当前字体。
void | JTextField.setFont(Font f) 设置当前字体。
void | JList.AccessibleJList.AccessibleJListChild.setFont(Font f)
void | JComponent.setFont(Font font) 设置此组件的字体。

javax.swing.border 中 Font 的使用

声明为 Font 的 javax.swing.border 中的字段
protected  Font TitledBorder.titleFont

返回 Font 的 javax.swing.border 中的方法
protected Font | TitledBorder.getFont(Component c)
Font | TitledBorder.getTitleFont() 返回带标题边框的标题字体。

参数类型为 Font 的 javax.swing.border 中的方法
 void TitledBorder.setTitleFont(Font titleFont)
设置带标题边框的标题字体。

参数类型为 Font 的 javax.swing.border 中的构造方法
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
用指定的边框、标题、标题对齐方式、标题位置和标题字体创建 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。

javax.swing.plaf 中 Font 的使用

javax.swing.plaf 中 Font 的子类
 class FontUIResource
实现 UIResource 的 java.awt.Font 的子类。

参数类型为 Font 的 javax.swing.plaf 中的构造方法
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
FontUIResource(Font font)

javax.swing.plaf.basic 中 Font 的使用

声明为 Font 的 javax.swing.plaf.basic 中的字段
protected  Font BasicMenuItemUI.acceleratorFont

参数类型为 Font 的 javax.swing.plaf.basic 中的方法
protected  void BasicTabbedPaneUI.paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)

javax.swing.plaf.synth 中 Font 的使用

返回 Font 的 javax.swing.plaf.synth 中的方法
Font | SynthStyle.getFont(SynthContext context) 返回指定状态的 Font。
protected abstract Font | SynthStyle.getFontForState(SynthContext context) 返回指定状态的字体。

参数类型为 Font 的 javax.swing.plaf.synth 中的方法
int | SynthGraphicsUtils.computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text) 返回传入字符串的大小。
Dimension | SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最大大小。
Dimension | SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最小大小。
Dimension | SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的首选大小。

javax.swing.table 中 Font 的使用

返回 Font 的 javax.swing.table 中的方法
 Font JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFont()

参数类型为 Font 的 javax.swing.table 中的方法
FontMetrics | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFontMetrics(Font f)
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setFont(Font f)

javax.swing.text 中 Font 的使用

返回 Font 的 javax.swing.text 中的方法
Font | GlyphView.getFont() 获取字形应该以其为依据的字体。
Font | LabelView.getFont() 获取字形应该以其为依据的字体。
Font | DefaultStyledDocument.getFont(AttributeSet attr) 从属性集获得字体。
Font | StyledDocument.getFont(AttributeSet attr) 使用一个属性集并将其转换为字体规范。
Font | StyleContext.getFont(AttributeSet attr) 从属性集中获取字体。
Font | StyleContext.getFont(String family, int style, int size) 获取新字体。

参数类型为 Font 的 javax.swing.text 中的方法
 FontMetrics StyleContext.getFontMetrics(Font f)
获取某种字体的字体规格。

javax.swing.text.html 中 Font 的使用

返回 Font 的 javax.swing.text.html 中的方法
 Font StyleSheet.getFont(AttributeSet a)
获取给定属性集使用的字体。

javax.swing.tree 中 Font 的使用

声明为 Font 的 javax.swing.tree 中的字段
protected  Font DefaultTreeCellEditor.font
用以绘制的字体，null 指示将使用呈现器的字体。

返回 Font 的 javax.swing.tree 中的方法
Font | DefaultTreeCellEditor.getFont() 获取用于编辑的字体。
Font | DefaultTreeCellEditor.DefaultTextField.getFont()
Font | DefaultTreeCellRenderer.getFont() 获取此组件的字体。

参数类型为 Font 的 javax.swing.tree 中的方法
void | DefaultTreeCellEditor.setFont(Font font) 设置编辑使用的字体。
void | DefaultTreeCellRenderer.setFont(Font font) 创建子类，以便将 FontUIResource 映射为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.FontFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.FontFormatException
的使用

使用 FontFormatException 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 FontFormatException 的使用

抛出 FontFormatException 的 java.awt 中的方法
static Font | Font.createFont(int fontFormat, File fontFile) 返回一个使用指定字体类型和指定字体文件的新 Font。
static Font | Font.createFont(int fontFormat, InputStream fontStream) 返回一个使用指定字体类型和输入数据的新 Font。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.FontMetrics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.FontMetrics
的使用

使用 FontMetrics 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 FontMetrics 的使用

返回 FontMetrics 的 java.awt 中的方法
FontMetrics | Graphics.getFontMetrics() 获取当前字体的字体规格。
FontMetrics | List.AccessibleAWTList.AccessibleAWTListChild.getFontMetrics(Font f) 设置此对象的 FontMetrics。
FontMetrics | MenuComponent.AccessibleAWTMenuComponent.getFontMetrics(Font f) 获取此对象的 FontMetrics。
abstract FontMetrics | Graphics.getFontMetrics(Font f) 获取指定字体的字体规格。
abstract FontMetrics | Toolkit.getFontMetrics(Font font) 已过时。 从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。
FontMetrics | Component.getFontMetrics(Font font) 获取指定字体的字体规格。
FontMetrics | Component.AccessibleAWTComponent.getFontMetrics(Font f) 获取此对象的 FontMetrics。

javax.accessibility 中 FontMetrics 的使用

返回 FontMetrics 的 javax.accessibility 中的方法
 FontMetrics AccessibleComponent.getFontMetrics(Font f)
获取此对象的 FontMetrics。

javax.swing 中 FontMetrics 的使用

返回 FontMetrics 的 javax.swing 中的方法
FontMetrics | DebugGraphics.getFontMetrics() 重写 Graphics.getFontMetrics。
FontMetrics | DebugGraphics.getFontMetrics(Font f) 重写 Graphics.getFontMetrics。
FontMetrics | JTree.AccessibleJTree.AccessibleJTreeNode.getFontMetrics(Font f)
FontMetrics | JTable.AccessibleJTable.AccessibleJTableCell.getFontMetrics(Font f) 获取此对象的 FontMetrics。
FontMetrics | JList.AccessibleJList.AccessibleJListChild.getFontMetrics(Font f)
FontMetrics | JComponent.getFontMetrics(Font font) 获取指定 Font 的 FontMetrics。

参数类型为 FontMetrics 的 javax.swing 中的方法
static int | SwingUtilities.computeStringWidth(FontMetrics fm, String str) 使用具有指定“规格”（大小）的字体计算字符串的宽度。
static String | SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap) 计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
static String | SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap) 计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。

javax.swing.plaf.basic 中 FontMetrics 的使用

返回 FontMetrics 的 javax.swing.plaf.basic 中的方法
protected  FontMetrics BasicTabbedPaneUI.getFontMetrics()

参数类型为 FontMetrics 的 javax.swing.plaf.basic 中的方法
protected  int BasicTabbedPaneUI.calculateTabWidth(int tabPlacement, int tabIndex, FontMetrics metrics)
protected  String BasicInternalFrameTitlePane.getTitle(String text, FontMetrics fm, int availTextWidth)
protected  String BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。
protected  void BasicTabbedPaneUI.layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicTabbedPaneUI.paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)

javax.swing.plaf.synth 中 FontMetrics 的使用

参数类型为 FontMetrics 的 javax.swing.plaf.synth 中的方法
int | SynthGraphicsUtils.computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text) 返回传入字符串的大小。
String | SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap) 根据通过引用返回的放置图标和文本的位置，布局文本和图标。

javax.swing.table 中 FontMetrics 的使用

返回 FontMetrics 的 javax.swing.table 中的方法
 FontMetrics JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFontMetrics(Font f)

javax.swing.text 中 FontMetrics 的使用

声明为 FontMetrics 的 javax.swing.text 中的字段
protected  FontMetrics PlainView.metrics
当前字体的字体规格。

返回 FontMetrics 的 javax.swing.text 中的方法
protected FontMetrics | LabelView.getFontMetrics() 已过时。 FontMetrics 不用于在 JDK 中运行时的字形呈现。
protected FontMetrics | FieldView.getFontMetrics() 获取与承载此视图组件相关的字体规格。
FontMetrics | StyleContext.getFontMetrics(Font f) 获取某种字体的字体规格。

参数类型为 FontMetrics 的 javax.swing.text 中的方法
static int | Utilities.getBreakLocation(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset) 确定对给定文本进行拆分的位置，以符合给定的跨距。
static int | Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset) 确定给定文本中的某个相对偏移量，使其能最好的表示视图坐标系统中的给定跨距。
static int | Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
static int | Utilities.getTabbedTextWidth(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset) 确定给定的考虑制表符的文本段的宽度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Frame 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Frame
的使用

使用 Frame 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Frame 的使用

返回 Frame 的 java.awt 中的方法
static Frame[] Frame.getFrames()
返回一个此应用程序创建的所有 Frame 所组成的数组。

参数类型为 Frame 的 java.awt 中的方法
protected abstract java.awt.peer.FramePeer | Toolkit.createFrame(Frame target) 使用指定同位体接口创建此工具包的 Frame 实现。
PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
abstract PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, Properties props) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

参数类型为 Frame 的 java.awt 中的构造方法
Dialog(Frame owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Frame 和一个空标题。
Dialog(Frame owner, boolean modal)
构造一个最初不可见的 Dialog，它带有指定所有者 Frame、模式和一个空标题。
Dialog(Frame owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Frame 和标题。
Dialog(Frame owner, String title, boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题和模式。
Dialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题、模式和 GraphicsConfiguration。
FileDialog(Frame parent)
创建一个文件对话框，用于加载文件。
FileDialog(Frame parent, String title)
创建一个具有指定标题的文件对话框窗口，用于加载文件。
FileDialog(Frame parent, String title, int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。
Window(Frame owner)
构造一个新的、最初不可见的窗口，使用指定的 Frame 作为其所有者。

javax.swing 中 Frame 的使用

javax.swing 中 Frame 的子类
 class JFrame
java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。

返回 Frame 的 javax.swing 中的方法
static Frame | JOptionPane.getFrameForComponent(Component parentComponent) 返回指定组件的 Frame。
static Frame | JOptionPane.getRootFrame() 返回用于不提供窗体的类方法中的 Frame。

参数类型为 Frame 的 javax.swing 中的方法
static void JOptionPane.setRootFrame(Frame newRootFrame)
设置窗体，以用于不提供窗体的类方法。

参数类型为 Frame 的 javax.swing 中的构造方法
JDialog(Frame owner)
创建一个没有标题但将指定的 Frame 作为其所有者的无模式对话框。
JDialog(Frame owner, boolean modal)
创建一个具有指定所有者 Frame、模式和空标题的对话框。
JDialog(Frame owner, String title)
创建一个具有指定标题和指定所有者窗体的无模式对话框。
JDialog(Frame owner, String title, boolean modal)
创建一个具有指定标题、所有者 Frame 和模式的对话框。
JDialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Frame、模式和 GraphicsConfiguration 的对话框。
JWindow(Frame owner)
使用指定的所有者框架创建窗口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Frame.AccessibleAWTFrame 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Frame.AccessibleAWTFrame
的使用

使用 Frame.AccessibleAWTFrame 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 Frame.AccessibleAWTFrame 的使用

javax.swing 中 Frame.AccessibleAWTFrame 的子类
protected  class JFrame.AccessibleJFrame
此类实现对 JFrame 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.GradientPaint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GradientPaint
的使用

没有 java.awt.GradientPaint 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Graphics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Graphics
的使用

使用 Graphics 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 Graphics 的使用

java.awt 中 Graphics 的子类
 class Graphics2D
此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。

返回 Graphics 的 java.awt 中的方法
abstract Graphics | Graphics.create() 创建一个新的 Graphics 对象，它是此 Graphics 对象的副本。
Graphics | Graphics.create(int x, int y, int width, int height) 基于此 Graphics 对象创建一个新的 Graphics 对象，但是使用新的转换和剪贴区域。
Graphics | Component.FlipBufferStrategy.getDrawGraphics()
Graphics | Component.BltBufferStrategy.getDrawGraphics()
abstract Graphics | PrintJob.getGraphics() 获取将绘制到下一页的 Graphics 对象。
abstract Graphics | Image.getGraphics() 创建供绘制闭屏图像（off-screen image）使用的图形上下文。
Graphics | Component.getGraphics() 为组件创建一个图形上下文。

参数类型为 Graphics 的 java.awt 中的方法
LineMetrics | FontMetrics.getLineMetrics(char[] chars, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定字符数组的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 CharacterIterator 的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(String str, Graphics context) 返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(String str, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
Rectangle2D | FontMetrics.getMaxCharBounds(Graphics context) 返回指定 Graphics 上下文中具有最大边界的字符的边界。
Rectangle2D | FontMetrics.getStringBounds(char[] chars, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定字符数组的边界。
Rectangle2D | FontMetrics.getStringBounds(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回用指定 Graphics 上下文中指定 CharacterIterator 进行索引的字符的边界。
Rectangle2D | FontMetrics.getStringBounds(String str, Graphics context) 返回指定 Graphics 上下文中指定 String 的边界。
Rectangle2D | FontMetrics.getStringBounds(String str, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 String 的边界。
void | Canvas.paint(Graphics g) 绘制此 canvas。
void | Container.paint(Graphics g) 绘制容器。
void | Component.paint(Graphics g) 绘制此组件。
void | Component.paintAll(Graphics g) 绘制此组件及其所有子组件。
void | Container.paintComponents(Graphics g) 绘制此容器中的每个组件。
void | Container.print(Graphics g) 打印容器。
void | Component.print(Graphics g) 打印此组件。
void | Component.printAll(Graphics g) 打印此组件及其所有子组件。
void | ScrollPane.printComponents(Graphics g) 显示此滚动窗格中的组件。
void | Container.printComponents(Graphics g) 打印此容器中的每个组件。
void | Canvas.update(Graphics g) 更新此 canvas。
void | Container.update(Graphics g) 更新容器。
void | Component.update(Graphics g) 更新组件。

java.awt.image 中 Graphics 的使用

返回 Graphics 的 java.awt.image 中的方法
abstract Graphics | BufferStrategy.getDrawGraphics() 创建用于绘制缓冲区的图形上下文。
Graphics | BufferedImage.getGraphics() 此方法返回 Graphics2D，但此处是出于向后兼容性的考虑。
Graphics | VolatileImage.getGraphics() 此方法返回 Graphics2D，但它存在于此处是出于向后兼容性的考虑。

java.awt.print 中 Graphics 的使用

参数类型为 Graphics 的 java.awt.print 中的方法
 int Printable.print(Graphics graphics, PageFormat pageFormat, int pageIndex)
将指定索引处的页面用指定格式打印到指定的 Graphics 上下文。

java.beans 中 Graphics 的使用

参数类型为 Graphics 的 java.beans 中的方法
void | PropertyEditor.paintValue(Graphics gfx, Rectangle box) 在屏幕实际状态给定区域中绘制值的表示形式。
void | PropertyEditorSupport.paintValue(Graphics gfx, Rectangle box) 在屏幕实际状态给定区域中绘制值的表示形式。

javax.swing 中 Graphics 的使用

javax.swing 中 Graphics 的子类
 class DebugGraphics
支持图形调试的图形子类。

返回 Graphics 的 javax.swing 中的方法
Graphics | DebugGraphics.create() 重写 Graphics.create 来返回一个 DebugGraphics 对象。
Graphics | DebugGraphics.create(int x, int y, int width, int height) 重写 Graphics.create 来返回一个 DebugGraphics 对象。
protected Graphics | JComponent.getComponentGraphics(Graphics g) 返回用于绘制此组件的图形对象。
Graphics | JApplet.getGraphics() 为组件创建一个图形上下文。
Graphics | JWindow.getGraphics() 为组件创建一个图形上下文。
Graphics | JDialog.getGraphics() 为组件创建一个图形上下文。
Graphics | JComponent.getGraphics() 返回此组件的图形上下文，该上下文允许您绘制组件。
Graphics | JFrame.getGraphics() 为组件创建一个图形上下文。

参数类型为 Graphics 的 javax.swing 中的方法
protected  Graphics JComponent.getComponentGraphics(Graphics g)
返回用于绘制此组件的图形对象。
 void JViewport.paint(Graphics g)
通过后备存储绘制图像，或者使用后备存储“位图传送”剩余图像来仅绘制最新暴露的部分，这具体取决于是否启用 backingStore。
 void CellRendererPane.paint(Graphics g)
不应调用。
 void JLayeredPane.paint(Graphics g)
在指定的图形上下文中绘制此 JLayeredPane。
 void JComponent.paint(Graphics g)
由 Swing 调用，以绘制组件。
protected  void JProgressBar.paintBorder(Graphics g)
如果 borderPainted 属性为 true，则绘制进度条的边框。
protected  void JPopupMenu.paintBorder(Graphics g)
如果 borderPainted 属性为 true，则绘制弹出菜单的边框。
protected  void JMenuBar.paintBorder(Graphics g)
如果 BorderPainted 属性为 true，则绘制菜单栏的边框。
protected  void JToolBar.paintBorder(Graphics g)
如果 borderPainted 属性为 true，则绘制工具栏边框。
protected  void AbstractButton.paintBorder(Graphics g)
如果 BorderPainted 属性为 true 并且按钮有边框，则绘制该按钮边框。
protected  void JComponent.paintBorder(Graphics g)
绘制组件的边框。
protected  void JSplitPane.paintChildren(Graphics g)
通知超类后，UI 通过 finishedPaintingChildren 通知子类，同时绘制边框。
protected  void JComponent.paintChildren(Graphics g)
绘制此组件的子组件。
protected  void Box.paintComponent(Graphics g)
绘制此 Box。
protected  void Box.Filler.paintComponent(Graphics g)
绘制此 Filler。
protected  void JInternalFrame.paintComponent(Graphics g)
重写此方法，以便在拖动内部窗体时允许进行优化的绘制。
protected  void JComponent.paintComponent(Graphics g)
如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
调用 this.paintComponent(g, c, p, x, y, w, h, false)。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
在指定的 Graphics 上绘制组件。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
在图形对象 g 上绘制一个单元格渲染器组件 c。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, Rectangle r)
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, Rectangle r)
在指定的 Graphics 上绘制组件。
 void ImageIcon.paintIcon(Component c, Graphics g, int x, int y)
绘制图标。
 void Icon.paintIcon(Component c, Graphics g, int x, int y)
在指定位置上绘制图标。
 void JComponent.print(Graphics g)
调用此方法打印指定 Graphics 的组件。
 void JComponent.printAll(Graphics g)
调用此方法打印组件。
protected  void JComponent.printBorder(Graphics g)
打印组件的边框。
protected  void JComponent.printChildren(Graphics g)
打印此组件的子组件。
protected  void JComponent.printComponent(Graphics g)
在打印操作期间调用此方法。
 void JApplet.update(Graphics g)
调用 paint(g)。
 void JWindow.update(Graphics g)
调用 paint(g)。
 void CellRendererPane.update(Graphics g)
不应调用。
 void JDialog.update(Graphics g)
调用 paint(g)。
 void JComponent.update(Graphics g)
调用 paint。
 void JFrame.update(Graphics g)
只是调用 paint(g)。

参数类型为 Graphics 的 javax.swing 中的构造方法
DebugGraphics(Graphics graphics)
根据现有图形上下文构造一个调试图形上下文，该上下文支持减慢绘制。
DebugGraphics(Graphics graphics, JComponent component)
根据现有图形上下文构造一个调试图形上下文，该上下文可以减慢指定组件的绘制。

javax.swing.border 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.border 中的方法
void | SoftBevelBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸绘制指定组件的边框。
void | TitledBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和大小为指定的组件绘制边框。
void | BevelBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
void | EtchedBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸为指定的组件绘制边框
void | LineBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸为指定的组件绘制边框。
void | MatteBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 绘制衬边边框。
void | CompoundBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 绘制组合边框，方法是先按指定的位置和尺寸绘制外部边框，然后按照外部边框 insets 指定的位置和尺寸偏移量绘制内部边框。
void | EmptyBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 默认情况下不执行绘制。
void | AbstractBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 此默认实现不执行绘制操作。
void | Border.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
protected void | BevelBorder.paintLoweredBevel(Component c, Graphics g, int x, int y, int width, int height)
protected void | BevelBorder.paintRaisedBevel(Component c, Graphics g, int x, int y, int width, int height)

javax.swing.colorchooser 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.colorchooser 中的方法
 void AbstractColorChooserPanel.paint(Graphics g)
绘制面板。

javax.swing.plaf 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.plaf 中的方法
abstract void | SplitPaneUI.finishedPaintingChildren(JSplitPane jc, Graphics g) 在 JSplitPane 接收方提供外观来绘制其子组件之后传递消息。
void | ComponentUI.paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
void | BorderUIResource.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | IconUIResource.paintIcon(Component c, Graphics g, int x, int y)
void | ComponentUI.update(Graphics g, JComponent c) 通知此 UI 委托开始绘制指定的组件。

javax.swing.plaf.basic 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.plaf.basic 中的方法
static void BasicGraphicsUtils.drawBezel(Graphics g, int x, int y, int w, int h, boolean isPressed, boolean isDefault, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
protected  void BasicTreeUI.drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
protected  void BasicTreeUI.drawDashedHorizontalLine(Graphics g, int y, int x1, int x2)
static void BasicGraphicsUtils.drawDashedRect(Graphics g, int x, int y, int width, int height)
protected  void BasicTreeUI.drawDashedVerticalLine(Graphics g, int x, int y1, int y2)
static void BasicGraphicsUtils.drawEtchedRect(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void BasicGraphicsUtils.drawGroove(Graphics g, int x, int y, int w, int h, Color shadow, Color highlight)
static void BasicGraphicsUtils.drawLoweredBezel(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void BasicGraphicsUtils.drawString(Graphics g, String text, int underlinedChar, int x, int y)
像 g.drawString 那样利用图形 g 在位置 (x,y) 绘制字符串。
static void BasicGraphicsUtils.drawStringUnderlineCharAt(Graphics g, String text, int underlinedIndex, int x, int y)
像 g.drawString 那样利用图形 g 在位置 (x, y) 绘制字符串。
 void BasicSplitPaneUI.finishedPaintingChildren(JSplitPane jc, Graphics g)
在 JSplitPane 接收者将为绘制其子级提供外观后传递消息。
protected  Point BasicProgressBarUI.getStringPlacement(Graphics g, String progressString, int x, int y, int width, int height)
指定将绘制进度字符串的位置。
 void BasicInternalFrameTitlePane.SystemMenuBar.paint(Graphics g)
 void BasicSplitPaneDivider.paint(Graphics g)
绘制分隔符。
 void BasicArrowButton.paint(Graphics g)
 void BasicToolBarUI.DragWindow.paint(Graphics g)
 void BasicDesktopPaneUI.paint(Graphics g, JComponent c)
 void BasicPopupMenuSeparatorUI.paint(Graphics g, JComponent c)
 void BasicToolTipUI.paint(Graphics g, JComponent c)
 void BasicSliderUI.paint(Graphics g, JComponent c)
 void BasicSplitPaneUI.paint(Graphics g, JComponent jc)
传递消息以绘制外观。
 void BasicTreeUI.paint(Graphics g, JComponent c)
 void BasicTableUI.paint(Graphics g, JComponent c)
绘制用 installUI() 设置的 table 实例的表示形式。
 void BasicTableHeaderUI.paint(Graphics g, JComponent c)
 void BasicProgressBarUI.paint(Graphics g, JComponent c)
将绘制委托给两种方法之一：paintDeterminate 和 paintIndeterminate。
 void BasicRadioButtonUI.paint(Graphics g, JComponent c)
绘制单选按钮
 void BasicTabbedPaneUI.paint(Graphics g, JComponent c)
 void BasicToolBarSeparatorUI.paint(Graphics g, JComponent c)
 void BasicTextUI.paint(Graphics g, JComponent c)
绘制界面。
 void BasicScrollPaneUI.paint(Graphics g, JComponent c)
 void BasicListUI.paint(Graphics g, JComponent c)
绘制与 Graphics 对象 clipRect 相交的行。
 void BasicComboBoxUI.paint(Graphics g, JComponent c)
 void BasicScrollBarUI.paint(Graphics g, JComponent c)
 void BasicSeparatorUI.paint(Graphics g, JComponent c)
 void BasicMenuItemUI.paint(Graphics g, JComponent c)
 void BasicToggleButtonUI.paint(Graphics g, JComponent c)
 void BasicButtonUI.paint(Graphics g, JComponent c)
 void BasicLabelUI.paint(Graphics g, JComponent c)
使用前景色绘制标签文本，如果标签不透明，则利用背景色绘制整个背景。
protected  void BasicTextUI.paintBackground(Graphics g)
绘制视图的背景。
protected  void BasicMenuItemUI.paintBackground(Graphics g, JMenuItem menuItem, Color bgColor)
绘制菜单项的背景。
 void BasicBorders.RolloverButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
 void BasicBorders.ButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
 void BasicBorders.ToggleButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
 void BasicBorders.RadioButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
 void BasicBorders.MenuBarBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
 void BasicBorders.FieldBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
 void BasicBorders.SplitPaneBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
protected  void BasicButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
protected  void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。
 void BasicInternalFrameTitlePane.paintComponent(Graphics g)
protected  void BasicTabbedPaneUI.paintContentBorder(Graphics g, int tabPlacement, int selectedIndex)
protected  void BasicTabbedPaneUI.paintContentBorderBottomEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected  void BasicTabbedPaneUI.paintContentBorderLeftEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected  void BasicTabbedPaneUI.paintContentBorderRightEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected  void BasicTabbedPaneUI.paintContentBorderTopEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
 void BasicComboBoxUI.paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus)
绘制当前所选项。
 void BasicComboBoxUI.paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus)
绘制当前所选项的背景。
protected  void BasicScrollBarUI.paintDecreaseHighlight(Graphics g)
protected  void BasicProgressBarUI.paintDeterminate(Graphics g, JComponent c)
对几乎所有线性、确定进度条都能正确执行操作的多用途绘制方法。
protected  void BasicLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用 background.lighter() 将 clippedText 绘制在 textX、textY 处，然后利用 background.darker() 向右下移动一个像素。
protected  void BasicToolBarUI.paintDragWindow(Graphics g)
绘制用于拖动的窗口的内容。
protected  void BasicLabelUI.paintEnabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用标签的前景色将 clippedText 绘制在 textX、textY 处。
protected  void BasicTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制 row 的展开（切换）部分。
 void BasicSliderUI.paintFocus(Graphics g)
protected  void BasicButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected  void BasicRadioButtonUI.paintFocus(Graphics g, Rectangle textRect, Dimension size)
protected  void BasicTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicSliderUI.paintHorizontalLabel(Graphics g, int value, Component label)
为标签表中的每个标签调用此方法。
protected  void BasicTreeUI.paintHorizontalLine(Graphics g, JComponent c, int y, int left, int right)
绘制水平线。
protected  void BasicTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制支路 (leg) 的水平部分。
protected  void BasicToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)
protected  void BasicTabbedPaneUI.paintIcon(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
protected  void BasicButtonUI.paintIcon(Graphics g, JComponent c, Rectangle iconRect)
protected  void BasicScrollBarUI.paintIncreaseHighlight(Graphics g)
protected  void BasicProgressBarUI.paintIndeterminate(Graphics g, JComponent c)
对所有线性跳动框进度条都能正确执行操作的多用途绘制方法。
 void BasicSliderUI.paintLabels(Graphics g)
protected  void BasicSliderUI.paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected  void BasicSliderUI.paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected  void BasicMenuItemUI.paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
protected  void BasicSliderUI.paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected  void BasicSliderUI.paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected  void BasicTreeUI.paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制 row 的渲染器部分。
protected  void BasicTextUI.paintSafely(Graphics g)
安全地绘制界面，保证模型不会根据此线程的视图发生更改。
protected  void BasicProgressBarUI.paintString(Graphics g, int x, int y, int width, int height, int amountFull, Insets b)
protected  void BasicTabbedPaneUI.paintTab(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect)
protected  void BasicTabbedPaneUI.paintTabArea(Graphics g, int tabPlacement, int selectedIndex)
在选项卡区域绘制选项卡。
protected  void BasicTabbedPaneUI.paintTabBackground(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
protected  void BasicTabbedPaneUI.paintTabBorder(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
此方法围绕每个选项卡绘制边框。
protected  void BasicButtonUI.paintText(Graphics g, AbstractButton b, Rectangle textRect, String text)
呈现当前按钮文本的方法。
protected  void BasicTabbedPaneUI.paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)
protected  void BasicButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
protected  void BasicMenuItemUI.paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
呈现当前菜单项的文本。
 void BasicSliderUI.paintThumb(Graphics g)
protected  void BasicScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
 void BasicSliderUI.paintTicks(Graphics g)
protected  void BasicInternalFrameTitlePane.paintTitleBackground(Graphics g)
从 paintComponent 调用。
 void BasicSliderUI.paintTrack(Graphics g)
protected  void BasicScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
 void BasicArrowButton.paintTriangle(Graphics g, int x, int y, int size, int direction, boolean isEnabled)
绘制一个三角形。
protected  void BasicSliderUI.paintVerticalLabel(Graphics g, int value, Component label)
为标签表中的每个标签调用此方法。
protected  void BasicTreeUI.paintVerticalLine(Graphics g, JComponent c, int x, int top, int bottom)
绘制垂直线。
protected  void BasicTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
绘制支路的垂直部分。
 void BasicTextUI.update(Graphics g, JComponent c)
超类以无法控制的方式绘制背景（即有人可能希望将图像平铺在背景中）。
 void BasicMenuItemUI.update(Graphics g, JComponent c)
使用 paintMenuItem() 绘制背景，从而重写 update（默认情况下填充不透明组件的背景）以调用 paint()。

javax.swing.plaf.metal 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.plaf.metal 中的方法
protected void | MetalCheckBoxIcon.drawCheck(Component c, Graphics g, int x, int y)
void | MetalScrollButton.paint(Graphics g)
void | MetalToolTipUI.paint(Graphics g, JComponent c)
void | MetalTreeUI.paint(Graphics g, JComponent c)
void | MetalRadioButtonUI.paint(Graphics g, JComponent c)
void | MetalTabbedPaneUI.paint(Graphics g, JComponent c)
void | MetalComboBoxUI.paint(Graphics g, JComponent c)
void | MetalPopupMenuSeparatorUI.paint(Graphics g, JComponent c)
void | MetalSeparatorUI.paint(Graphics g, JComponent c)
void | MetalBorders.Flush3DBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.InternalFrameBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.PaletteBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.OptionDialogBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.MenuBarBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.MenuItemBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.PopupMenuBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.RolloverButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ToolBarBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.TextFieldBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ScrollPaneBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ToggleButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.TableHeaderBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
protected void | MetalTabbedPaneUI.paintBottomTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
protected void | MetalToggleButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
protected void | MetalButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
void | MetalInternalFrameTitlePane.paintComponent(Graphics g)
void | MetalComboBoxButton.paintComponent(Graphics g)
protected void | MetalTabbedPaneUI.paintContentBorderBottomEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | MetalTabbedPaneUI.paintContentBorderLeftEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | MetalTabbedPaneUI.paintContentBorderRightEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | MetalTabbedPaneUI.paintContentBorderTopEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
void | MetalComboBoxUI.paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus) 如有必要，绘制当前所选项。
void | MetalComboBoxUI.paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus) 如有必要，绘制当前所选项的背景。
void | MetalProgressBarUI.paintDeterminate(Graphics g, JComponent c) 在进度条上绘制少量特殊的高亮显示。
protected void | MetalLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY) 只绘制文本灰度 (Label.disabledForeground)，而不是使用标签前景色。
void | MetalSliderUI.paintFocus(Graphics g)
protected void | MetalToggleButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalRadioButtonUI.paintFocus(Graphics g, Rectangle t, Dimension d)
protected void | MetalTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected void | MetalTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
protected void | MetalTreeUI.paintHorizontalSeparators(Graphics g, JComponent c)
void | MetalCheckBoxIcon.paintIcon(Component c, Graphics g, int x, int y)
void | MetalComboBoxIcon.paintIcon(Component c, Graphics g, int x, int y) 绘制 MetalComboBox 的水平条
void | MetalIconFactory.PaletteCloseIcon.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.FolderIcon16.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.FileIcon16.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.TreeControlIcon.paintIcon(Component c, Graphics g, int x, int y)
protected void | MetalToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect) 在空间 iconRect 中绘制按钮 b 的适当图标。
void | MetalProgressBarUI.paintIndeterminate(Graphics g, JComponent c) 在进度条和跳动框上绘制少量特殊的高亮显示。
protected void | MetalTabbedPaneUI.paintLeftTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
protected void | MetalSliderUI.paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | MetalSliderUI.paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
void | MetalIconFactory.TreeControlIcon.paintMe(Component c, Graphics g, int x, int y)
protected void | MetalSliderUI.paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | MetalSliderUI.paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
void | MetalInternalFrameTitlePane.paintPalette(Graphics g)
protected void | MetalTabbedPaneUI.paintRightTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
protected void | MetalTabbedPaneUI.paintTabBackground(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
protected void | MetalTabbedPaneUI.paintTabBorder(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
protected void | MetalToggleButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
protected void | MetalButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
void | MetalSliderUI.paintThumb(Graphics g)
protected void | MetalScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected void | MetalTabbedPaneUI.paintTopTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
void | MetalSliderUI.paintTrack(Graphics g)
protected void | MetalScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
protected void | MetalTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
void | MetalTabbedPaneUI.update(Graphics g, JComponent c)
void | MetalToolBarUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalMenuBarUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalToggleButtonUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalButtonUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。

javax.swing.plaf.multi 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.plaf.multi 中的方法
void | MultiSplitPaneUI.finishedPaintingChildren(JSplitPane a, Graphics b) 在由此对象处理的每个 UI 上调用 finishedPaintingChildren 方法。
void | MultiButtonUI.paint(Graphics a, JComponent b) 在此对象处理的每个 UI 上调用 paint 方法。
void | MultiColorChooserUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法
void | MultiComboBoxUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiDesktopIconUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiDesktopPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiFileChooserUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiInternalFrameUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiLabelUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiListUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiMenuBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiMenuItemUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiOptionPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiPanelUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiPopupMenuUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiProgressBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiRootPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiScrollBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiScrollPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSeparatorUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSliderUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSpinnerUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSplitPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTabbedPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTableHeaderUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTableUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTextUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiToolBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiToolTipUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTreeUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiViewportUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiButtonUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiColorChooserUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiComboBoxUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiDesktopIconUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiDesktopPaneUI.update(Graphics a, JComponent b) 在此对象处理的每个 UI 上调用 update 方法。
void | MultiFileChooserUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiInternalFrameUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiLabelUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiListUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiMenuBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiMenuItemUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiOptionPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiPanelUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiPopupMenuUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiProgressBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiRootPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiScrollBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiScrollPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSeparatorUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSliderUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSpinnerUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSplitPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTabbedPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTableHeaderUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTableUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTextUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiToolBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiToolTipUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTreeUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiViewportUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。

javax.swing.plaf.synth 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.plaf.synth 中的方法
void | SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2) 在两个端点之间绘制一条线。
void | SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey) 在两个端点之间绘制一条线。
void | SynthPainter.paintArrowButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制箭头按钮的背景。
void | SynthPainter.paintArrowButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制箭头按钮的边框。
void | SynthPainter.paintArrowButtonForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int direction) 绘制箭头按钮的前景。
void | SynthPainter.paintButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制按钮的背景。
void | SynthPainter.paintButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制按钮的边框。
void | SynthPainter.paintCheckBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框的背景。
void | SynthPainter.paintCheckBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框的边框。
void | SynthPainter.paintCheckBoxMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框菜单项的背景。
void | SynthPainter.paintCheckBoxMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框菜单项的边框。
void | SynthPainter.paintColorChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制颜色选择器的背景。
void | SynthPainter.paintColorChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制颜色选择器的边框。
void | SynthPainter.paintComboBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制组合框的背景。
void | SynthPainter.paintComboBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制组合框的边框。
void | SynthPainter.paintDesktopIconBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面图标的背景。
void | SynthPainter.paintDesktopIconBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面图标的边框。
void | SynthPainter.paintDesktopPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面窗格的背景。
void | SynthPainter.paintDesktopPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面窗格的边框。
void | SynthPainter.paintEditorPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制编辑器窗格的背景。
void | SynthPainter.paintEditorPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制编辑器窗格的边框。
void | SynthPainter.paintFileChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文件选择器的背景。
void | SynthPainter.paintFileChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文件选择器的边框。
void | SynthPainter.paintFormattedTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制已格式化文本字段的背景。
void | SynthPainter.paintFormattedTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制已格式化文本字段的边框。
void | SynthPainter.paintInternalFrameBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体的背景。
void | SynthPainter.paintInternalFrameBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体的边框。
void | SynthPainter.paintInternalFrameTitlePaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体标题窗格的背景。
void | SynthPainter.paintInternalFrameTitlePaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体标题窗格的边框。
void | SynthPainter.paintLabelBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制标签的背景。
void | SynthPainter.paintLabelBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制标签的边框。
void | SynthPainter.paintListBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制列表的背景。
void | SynthPainter.paintListBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制列表的边框。
void | SynthPainter.paintMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单的背景。
void | SynthPainter.paintMenuBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单栏的背景。
void | SynthPainter.paintMenuBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单栏的边框。
void | SynthPainter.paintMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单的边框。
void | SynthPainter.paintMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单项的背景。
void | SynthPainter.paintMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单项的边框。
void | SynthPainter.paintOptionPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项窗格的背景。
void | SynthPainter.paintOptionPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项窗格的边框。
void | SynthPainter.paintPanelBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制面板的背景。
void | SynthPainter.paintPanelBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制面板的边框。
void | SynthPainter.paintPasswordFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制密码字段的背景。
void | SynthPainter.paintPasswordFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制密码字段的边框。
void | SynthPainter.paintPopupMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制弹出菜单的背景。
void | SynthPainter.paintPopupMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制弹出菜单的边框。
void | SynthPainter.paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制进度条的背景。
void | SynthPainter.paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的背景。
void | SynthPainter.paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制进度条的边框。
void | SynthPainter.paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的边框。
void | SynthPainter.paintProgressBarForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的前景。
void | SynthPainter.paintRadioButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮的背景。
void | SynthPainter.paintRadioButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮的边框。
void | SynthPainter.paintRadioButtonMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮菜单项的背景。
void | SynthPainter.paintRadioButtonMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮菜单项的边框。
void | SynthPainter.paintRootPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制根窗体的背景。
void | SynthPainter.paintRootPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制根窗体的边框。
void | SynthPainter.paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条的背景。
void | SynthPainter.paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的背景。
void | SynthPainter.paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条的边框。
void | SynthPainter.paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的边框。
void | SynthPainter.paintScrollBarThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的 thumb 的背景。
void | SynthPainter.paintScrollBarThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的 thumb 的边框。
void | SynthPainter.paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条滑道的背景。
void | SynthPainter.paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条滑道的背景。
void | SynthPainter.paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条滑道的边框。
void | SynthPainter.paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条滑道的边框。
void | SynthPainter.paintScrollPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动窗格的背景。
void | SynthPainter.paintScrollPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动窗格的边框。
void | SynthPainter.paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔符的背景。
void | SynthPainter.paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的背景。
void | SynthPainter.paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔符的边框。
void | SynthPainter.paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的边框。
void | SynthPainter.paintSeparatorForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的前景。
void | SynthPainter.paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的背景。
void | SynthPainter.paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的背景。
void | SynthPainter.paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的边框。
void | SynthPainter.paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的边框。
void | SynthPainter.paintSliderThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的 thumb 的背景。
void | SynthPainter.paintSliderThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的 thumb 的边框。
void | SynthPainter.paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的滑道的背景。
void | SynthPainter.paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的滑道的背景。
void | SynthPainter.paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的滑道的边框。
void | SynthPainter.paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的滑道的边框。
void | SynthPainter.paintSpinnerBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制 spinner 的背景。
void | SynthPainter.paintSpinnerBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制 spinner 的边框。
void | SynthPainter.paintSplitPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的背景。
void | SynthPainter.paintSplitPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的边框。
void | SynthPainter.paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的分隔栏的背景。
void | SynthPainter.paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔窗格的分隔栏的背景。
void | SynthPainter.paintSplitPaneDividerForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔窗格的分隔栏的前景。
void | SynthPainter.paintSplitPaneDragDivider(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 当用户拖动分隔符时，绘制分隔窗格的分隔栏。
void | SynthPainter.paintTabbedPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的背景。
void | SynthPainter.paintTabbedPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的边框。
void | SynthPainter.paintTabbedPaneContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含选项卡窗格中所选选项卡内容的区域的背景。
void | SynthPainter.paintTabbedPaneContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含选项卡窗格中所选选项卡内容的区域的边框。
void | SynthPainter.paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的选项卡背后区域的背景。
void | SynthPainter.paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制选项卡窗格的选项卡背后区域的背景。
void | SynthPainter.paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的选项卡背后区域的边框。
void | SynthPainter.paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制选项卡窗格的选项卡背后区域的边框。
void | SynthPainter.paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex) 绘制选项卡窗格的选项卡的背景。
void | SynthPainter.paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation) 绘制选项卡窗格的选项卡的背景。
void | SynthPainter.paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex) 绘制选项卡窗格的选项卡的边框。
void | SynthPainter.paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation) 绘制选项卡窗格的选项卡的边框。
void | SynthPainter.paintTableBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表的背景。
void | SynthPainter.paintTableBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表的边框。
void | SynthPainter.paintTableHeaderBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表标题的背景。
void | SynthPainter.paintTableHeaderBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表标题的边框。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset) 绘制图标和文本。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex) 在指定位置上绘制文本。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex) 在指定位置上绘制文本。
void | SynthPainter.paintTextAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本区域的背景。
void | SynthPainter.paintTextAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本区域的边框。
void | SynthPainter.paintTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本字段的背景。
void | SynthPainter.paintTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本字段的边框。
void | SynthPainter.paintTextPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本窗格的背景。
void | SynthPainter.paintTextPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本窗格的边框。
void | SynthPainter.paintToggleButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制切换按钮的背景。
void | SynthPainter.paintToggleButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制切换按钮的边框。
void | SynthPainter.paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏的背景。
void | SynthPainter.paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏的背景。
void | SynthPainter.paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏的边框。
void | SynthPainter.paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏的边框。
void | SynthPainter.paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏内容区的背景。
void | SynthPainter.paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏内容区的背景。
void | SynthPainter.paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏内容区的边框。
void | SynthPainter.paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏内容区的边框。
void | SynthPainter.paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
void | SynthPainter.paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
void | SynthPainter.paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
void | SynthPainter.paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
void | SynthPainter.paintToolTipBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具提示的背景。
void | SynthPainter.paintToolTipBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具提示的边框。
void | SynthPainter.paintTreeBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制树的背景。
void | SynthPainter.paintTreeBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制树的边框。
void | SynthPainter.paintTreeCellBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含树中某个单元格的行的背景。
void | SynthPainter.paintTreeCellBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含树中某个单元格的行的边框。
void | SynthPainter.paintTreeCellFocus(SynthContext context, Graphics g, int x, int y, int w, int h) 当树中某个单元格拥有焦点时，绘制该单元格的焦点指示器。
void | SynthPainter.paintViewportBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制视口的背景。
void | SynthPainter.paintViewportBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制视口的边框。

javax.swing.text 中 Graphics 的使用

返回 Graphics 的 javax.swing.text 中的方法
 Graphics View.getGraphics()
获取用于呈现的 Graphics。

参数类型为 Graphics 的 javax.swing.text 中的方法
protected int | PasswordView.drawEchoCharacter(Graphics g, int x, int y, char c) 呈现回显字符，或呈现用来显示密码字符的图形。
protected void | PlainView.drawLine(int lineIndex, Graphics g, int x, int y) 呈现文本的某一行，取消末尾的空白并扩展所有的制表符。
protected void | WrappedPlainView.drawLine(int p0, int p1, Graphics g, int x, int y) 取消结尾空格并扩展所有制表符，从而呈现一行文本。
protected int | PasswordView.drawSelectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为选定文本。
protected int | WrappedPlainView.drawSelectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为所选文本。
protected int | PlainView.drawSelectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为选定文本。
static int | Utilities.drawTabbedText(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset) 使用给定的制表符扩展方式来扩展给定文本所包含的任何制表符，从而绘制给定的文本。
protected int | PasswordView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为正常的未选定文本。
protected int | WrappedPlainView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1) 将模型中的给定范围呈现为普通未选择的文本。
protected int | PlainView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为正常的未选定文本。
abstract void | GlyphView.GlyphPainter.paint(GlyphView v, Graphics g, Shape a, int p0, int p1) 绘制表示给定范围的字形。
void | DefaultHighlighter.paint(Graphics g) 呈现高亮显示区域。
void | Highlighter.paint(Graphics g) 呈现高亮显示。
void | DefaultCaret.paint(Graphics g) 将插入符作为垂直线呈现。
void | Caret.paint(Graphics g) 呈现插入符。
void | DefaultHighlighter.DefaultHighlightPainter.paint(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c) 绘制高亮显示区域。
void | Highlighter.HighlightPainter.paint(Graphics g, int p0, int p1, Shape bounds, JTextComponent c) 呈现高亮显示。
void | AsyncBoxView.paint(Graphics g, Shape alloc) 使用给定的分配和呈现表面呈现该视图。
void | BoxView.paint(Graphics g, Shape allocation) 使用该面给定的呈现面和区域呈现 BoxView。
void | ComponentView.paint(Graphics g, Shape a) 真正的绘制行为自然来源于组件与其父容器（容纳此视图的同一容器）之间的关联。
void | GlyphView.paint(Graphics g, Shape a) 呈现一部分运行的文本样式。
void | IconView.paint(Graphics g, Shape a) 绘制图标。
void | ParagraphView.paint(Graphics g, Shape a) 使用给定的呈现面和该面上的区域进行呈现。
void | WrappedPlainView.paint(Graphics g, Shape a) 使用给定的呈现表面和表现上的区域来呈现。
void | FieldView.paint(Graphics g, Shape a) 使用给定呈现面和该表面的区域呈现。
void | PlainView.paint(Graphics g, Shape a) 使用给定呈现面和该表面的区域呈现。
abstract void | View.paint(Graphics g, Shape allocation) 使用给定的呈现表面和该表面上的区域来呈现。
protected void | BoxView.paintChild(Graphics g, Rectangle alloc, int index) 绘制一个子级。
void | AsyncBoxView.ChildLocator.paintChildren(Graphics g) 绘制与剪贴区域相交的子级。
Shape | DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
void | DefaultHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当要呈现叶 View （例如，LabelView）时，要调用此方法。
abstract void | LayeredHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当叶 View（如 LabelView）呈现时，它们应调用此方法。

javax.swing.text.html 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.text.html 中的方法
 void StyleSheet.BoxPainter.paint(Graphics g, float x, float y, float w, float h, View v)
根据给定的属性绘制 CSS 框。
 void StyleSheet.ListPainter.paint(Graphics g, float x, float y, float w, float h, View v, int item)
根据给定的属性绘制 CSS 列表装饰。
 void BlockView.paint(Graphics g, Shape allocation)
使用给定呈现面和该表面的区域呈现。
 void ImageView.paint(Graphics g, Shape a)
绘制 View。
 void ListView.paint(Graphics g, Shape allocation)
使用给定呈现面和该表面的区域呈现。
 void ParagraphView.paint(Graphics g, Shape a)
使用给定的呈现面和该面上的区域进行呈现。
protected  void ListView.paintChild(Graphics g, Rectangle alloc, int index)
通过调用 paint() 绘制其中的一个子级。

javax.swing.tree 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.tree 中的方法
void | DefaultTreeCellEditor.EditorContainer.paint(Graphics g) 重写 Container.paint 以绘制节点的图标，并使用选定的背景色。
void | DefaultTreeCellRenderer.paint(Graphics g) 绘制值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Graphics2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Graphics2D
的使用

使用 Graphics2D 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 Graphics2D 的使用

返回 Graphics2D 的 java.awt 中的方法
Graphics2D | SplashScreen.createGraphics() 创建闪现屏幕叠加图像的图形上下文（Graphics2D 形式），它允许在闪现屏幕上进行绘制。
abstract Graphics2D | GraphicsEnvironment.createGraphics(BufferedImage img) 返回一个呈现指定 BufferedImage 的 Graphics2D 对象。

java.awt.font 中 Graphics2D 的使用

参数类型为 Graphics2D 的 java.awt.font 中的方法
abstract void | GraphicAttribute.draw(Graphics2D graphics, float x, float y) 在指定的位置呈现此 GraphicAttribute。
void | ImageGraphicAttribute.draw(Graphics2D graphics, float x, float y) 在指定的位置呈现此 GraphicAttribute。
void | ShapeGraphicAttribute.draw(Graphics2D graphics, float x, float y) 在指定的位置呈现此 GraphicAttribute。
void | TextLayout.draw(Graphics2D g2, float x, float y) 在指定的 Graphics2D 上下文中的指定位置上呈现此 TextLayout。

java.awt.image 中 Graphics2D 的使用

返回 Graphics2D 的 java.awt.image 中的方法
Graphics2D | BufferedImage.createGraphics() 创建一个 Graphics2D，可以将它绘制到此 BufferedImage 中。
abstract Graphics2D | VolatileImage.createGraphics() 创建一个 Graphics2D，可以将它绘制到此 VolatileImage 中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.GraphicsConfigTemplate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GraphicsConfigTemplate
的使用

使用 GraphicsConfigTemplate 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 GraphicsConfigTemplate 的使用

参数类型为 GraphicsConfigTemplate 的 java.awt 中的方法
 GraphicsConfiguration GraphicsDevice.getBestConfiguration(GraphicsConfigTemplate gct)
返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.GraphicsConfiguration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GraphicsConfiguration
的使用

使用 GraphicsConfiguration 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 GraphicsConfiguration 的使用

返回 GraphicsConfiguration 的 java.awt 中的方法
GraphicsConfiguration | GraphicsDevice.getBestConfiguration(GraphicsConfigTemplate gct) 返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
abstract GraphicsConfiguration | GraphicsConfigTemplate.getBestConfiguration(GraphicsConfiguration[] gc) 返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
abstract GraphicsConfiguration[] | GraphicsDevice.getConfigurations() 返回与此 GraphicsDevice 关联的所有 GraphicsConfiguration 对象。
abstract GraphicsConfiguration | GraphicsDevice.getDefaultConfiguration() 返回与此 GraphicsDevice 关联的默认 GraphicsConfiguration。
abstract GraphicsConfiguration | Graphics2D.getDeviceConfiguration() 返回与此 Graphics2D 关联的设备配置。
GraphicsConfiguration | Window.getGraphicsConfiguration() 此方法返回由此窗口使用的 GraphicsConfiguration。
GraphicsConfiguration | Component.getGraphicsConfiguration() 获取与此 Component 相关的 GraphicsConfiguration。

参数类型为 GraphicsConfiguration 的 java.awt 中的方法
abstract GraphicsConfiguration | GraphicsConfigTemplate.getBestConfiguration(GraphicsConfiguration[] gc) 返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
ImageCapabilities | Image.getCapabilities(GraphicsConfiguration gc) 返回 ImageCapabilities 对象，查询该对象便可以了解使用指定 GraphicsConfiguration 时此 Image 的功能。
Insets | Toolkit.getScreenInsets(GraphicsConfiguration gc) 获得屏幕的 insets。
abstract boolean | GraphicsConfigTemplate.isGraphicsConfigSupported(GraphicsConfiguration gc) 返回一个 boolean，它指示指定的 GraphicsConfiguration 是否可用于创建支持指定功能的绘图面。

参数类型为 GraphicsConfiguration 的 java.awt 中的构造方法
Canvas(GraphicsConfiguration config)
根据给定 GraphicsConfiguration 对象构造一个新的 Canvas。
Dialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题、模式和 GraphicsConfiguration。
Dialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题、模式和 GraphicsConfiguration。
Dialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。
Frame(GraphicsConfiguration gc)
使用指定的 GraphicsConfiguration 构造一个最初不可见的新 Frame。
Frame(String title, GraphicsConfiguration gc)
构造一个新的、初始不可见的、具有指定标题和 GraphicsConfiguration 的 Frame 对象。
Window(Window owner, GraphicsConfiguration gc)
构造一个新的、最初不可见的窗口，使用指定的所有者 Window 和屏幕设备的 GraphicsConfiguration。

java.awt.image 中 GraphicsConfiguration 的使用

参数类型为 GraphicsConfiguration 的 java.awt.image 中的方法
abstract  int VolatileImage.validate(GraphicsConfiguration gc)
如果上次调用 validate 后绘制表面丢失，则试图恢复图像的绘制表面。

javax.print 中 GraphicsConfiguration 的使用

参数类型为 GraphicsConfiguration 的 javax.print 中的方法
static PrintService ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
为用户提供一个选择 PrintService（打印机）的对话框。

javax.swing 中 GraphicsConfiguration 的使用

参数类型为 GraphicsConfiguration 的 javax.swing 中的构造方法
JDialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Dialog、模式和 GraphicsConfiguration 的对话框。
JDialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Frame、模式和 GraphicsConfiguration 的对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。
JFrame(GraphicsConfiguration gc)
以屏幕设备的指定 GraphicsConfiguration 和空白标题创建一个 Frame。
JFrame(String title, GraphicsConfiguration gc)
创建一个具有指定标题和指定屏幕设备的 GraphicsConfiguration 的 JFrame。
JWindow(GraphicsConfiguration gc)
使用屏幕设备的指定 GraphicsConfiguration 创建窗口。
JWindow(Window owner, GraphicsConfiguration gc)
使用屏幕设备的指定所有者窗口和 GraphicsConfiguration 创建窗口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.GraphicsDevice 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GraphicsDevice
的使用

使用 GraphicsDevice 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 GraphicsDevice 的使用

返回 GraphicsDevice 的 java.awt 中的方法
abstract GraphicsDevice | GraphicsEnvironment.getDefaultScreenDevice() 返回默认的屏幕 GraphicsDevice。
GraphicsDevice | PointerInfo.getDevice() 返回在创建此 PointerInfo 时鼠标指针所在的 GraphicsDevice。
abstract GraphicsDevice | GraphicsConfiguration.getDevice() 返回与此 GraphicsConfiguration 关联的 GraphicsDevice。
abstract GraphicsDevice[] | GraphicsEnvironment.getScreenDevices() 返回所有屏幕 GraphicsDevice 对象组成的数组。

参数类型为 GraphicsDevice 的 java.awt 中的构造方法
Robot(GraphicsDevice screen)
为给定屏幕设备创建一个 Robot 。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.GraphicsEnvironment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GraphicsEnvironment
的使用

使用 GraphicsEnvironment 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 GraphicsEnvironment 的使用

返回 GraphicsEnvironment 的 java.awt 中的方法
static GraphicsEnvironment GraphicsEnvironment.getLocalGraphicsEnvironment()
返回本地 GraphicsEnvironment。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.GridBagConstraints 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GridBagConstraints
的使用

使用 GridBagConstraints 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 GridBagConstraints 的使用

声明为 GridBagConstraints 的 java.awt 中的字段
protected  GridBagConstraints GridBagLayout.defaultConstraints
此字段保持包含默认值的网格包约束实例，因此如果某个组件没有与其相关联的网格包约束，则会分配给该组件一个 defaultConstraints 的副本。

类型参数类型为 GridBagConstraints 的 java.awt 中的字段
protected  Hashtable<Component,GridBagConstraints> GridBagLayout.comptable
此哈希表维持组件与其网格包约束之间的关联。

返回 GridBagConstraints 的 java.awt 中的方法
GridBagConstraints | GridBagLayout.getConstraints(Component comp) 获取指定组件的约束。
protected GridBagConstraints | GridBagLayout.lookupConstraints(Component comp) 检索指定组件的约束。

参数类型为 GridBagConstraints 的 java.awt 中的方法
protected void | GridBagLayout.adjustForGravity(GridBagConstraints constraints, Rectangle r) 根据约束几何结构和填充将 x、y、宽度和高度四个字段调整为正确值。
protected void | GridBagLayout.AdjustForGravity(GridBagConstraints constraints, Rectangle r) 此方法已过时，仅为提供向后兼容性；新代码应该调用 adjustForGravity 来代替。
void | GridBagLayout.setConstraints(Component comp, GridBagConstraints constraints) 设置此布局中指定组件的约束条件。

javax.swing.plaf.basic 中 GridBagConstraints 的使用

参数类型为 GridBagConstraints 的 javax.swing.plaf.basic 中的方法
protected  void BasicOptionPaneUI.addMessageComponents(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated)
创建表示 msg 的适当对象并将其置于 container 中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.GridBagLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GridBagLayout
的使用

没有 java.awt.GridBagLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.GridBagLayoutInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GridBagLayoutInfo
的使用

使用 GridBagLayoutInfo 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 GridBagLayoutInfo 的使用

声明为 GridBagLayoutInfo 的 java.awt 中的字段
protected  GridBagLayoutInfo GridBagLayout.layoutInfo
此字段保持网格包的布局信息。

返回 GridBagLayoutInfo 的 java.awt 中的方法
protected GridBagLayoutInfo | GridBagLayout.getLayoutInfo(Container parent, int sizeflag) 为当前受管子级的集合填充 GridBagLayoutInfo 的实例。
protected GridBagLayoutInfo | GridBagLayout.GetLayoutInfo(Container parent, int sizeflag) 此方法已过时，仅为提供向后兼容性；新代码应该调用 getLayoutInfo 来代替。

参数类型为 GridBagLayoutInfo 的 java.awt 中的方法
protected Dimension | GridBagLayout.getMinSize(Container parent, GridBagLayoutInfo info) 基于 getLayoutInfo 中的信息计算其所有者的最小大小。
protected Dimension | GridBagLayout.GetMinSize(Container parent, GridBagLayoutInfo info) 此方法已过时，仅为提供向后兼容性；新代码应该调用 getMinSize 来代替。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.GridLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GridLayout
的使用

没有 java.awt.GridLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.HeadlessException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.HeadlessException
的使用

使用 HeadlessException 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.print | 为通用的打印 API 提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.applet 中 HeadlessException 的使用

抛出 HeadlessException 的 java.applet 中的构造方法
Applet()
构造一个新 Applet。

java.awt 中 HeadlessException 的使用

抛出 HeadlessException 的 java.awt 中的方法
protected abstract java.awt.peer.ButtonPeer | Toolkit.createButton(Button target) 使用指定同位体接口创建此工具包的 Button 实现。
protected abstract java.awt.peer.CheckboxPeer | Toolkit.createCheckbox(Checkbox target) 使用指定同位体接口创建此工具包的 Checkbox 实现。
protected abstract java.awt.peer.CheckboxMenuItemPeer | Toolkit.createCheckboxMenuItem(CheckboxMenuItem target) 使用指定同位体接口创建此工具包的 CheckboxMenuItem 实现。
protected abstract java.awt.peer.ChoicePeer | Toolkit.createChoice(Choice target) 使用指定同位体接口创建此工具包的 Choice 实现。
Cursor | Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name) 创建一个新的自定义光标对象。
protected abstract java.awt.peer.DesktopPeer | Toolkit.createDesktopPeer(Desktop target) 使用指定的同位体接口创建此工具包的 Desktop 实现。
protected abstract java.awt.peer.DialogPeer | Toolkit.createDialog(Dialog target) 使用指定同位体接口创建此工具包的 Dialog 实现。
protected abstract java.awt.peer.FileDialogPeer | Toolkit.createFileDialog(FileDialog target) 使用指定同位体接口创建此工具包的 FileDialog 实现。
protected abstract java.awt.peer.FramePeer | Toolkit.createFrame(Frame target) 使用指定同位体接口创建此工具包的 Frame 实现。
protected abstract java.awt.peer.LabelPeer | Toolkit.createLabel(Label target) 使用指定同位体接口创建此工具包的 Label 实现。
protected abstract java.awt.peer.ListPeer | Toolkit.createList(List target) 使用指定同位体接口创建此工具包的 List 实现。
protected abstract java.awt.peer.MenuPeer | Toolkit.createMenu(Menu target) 使用指定同位体接口创建此工具包的 Menu 实现。
protected abstract java.awt.peer.MenuBarPeer | Toolkit.createMenuBar(MenuBar target) 使用指定同位体接口创建此工具包的 MenuBar 实现。
protected abstract java.awt.peer.MenuItemPeer | Toolkit.createMenuItem(MenuItem target) 使用指定同位体接口创建此工具包的 MenuItem 实现。
protected abstract java.awt.peer.PopupMenuPeer | Toolkit.createPopupMenu(PopupMenu target) 使用指定同位体接口创建此工具包的 PopupMenu 实现。
protected abstract java.awt.peer.ScrollbarPeer | Toolkit.createScrollbar(Scrollbar target) 使用指定同位体接口创建此工具包的 Scrollbar 实现。
protected abstract java.awt.peer.ScrollPanePeer | Toolkit.createScrollPane(ScrollPane target) 使用指定同位体接口创建此工具包的 ScrollPane 实现。
protected abstract java.awt.peer.TextAreaPeer | Toolkit.createTextArea(TextArea target) 使用指定同位体接口创建此工具包的 TextArea 实现。
protected abstract java.awt.peer.TextFieldPeer | Toolkit.createTextField(TextField target) 使用指定同位体接口创建此工具包的 TextField 实现。
protected abstract java.awt.peer.WindowPeer | Toolkit.createWindow(Window target) 使用指定同位体接口创建此工具包的 Window 实现。
Dimension | Toolkit.getBestCursorSize(int preferredWidth, int preferredHeight) 返回最接近所需大小的受支持光标尺寸。
Point | GraphicsEnvironment.getCenterPoint() 返回 Windows 应居中的点。
abstract ColorModel | Toolkit.getColorModel() 确定此工具包屏幕的颜色模型。
abstract GraphicsDevice | GraphicsEnvironment.getDefaultScreenDevice() 返回默认的屏幕 GraphicsDevice。
int | Toolkit.getMaximumCursorColors() 返回自定义光标调色板中 Toolkit 支持的最大颜色数。
Rectangle | GraphicsEnvironment.getMaximumWindowBounds() 返回居中 Windows 的最大边界。
int | Toolkit.getMenuShortcutKeyMask() 确定哪一个修改键是菜单快捷方式的适当加速键。
Point | Component.getMousePosition() 如果此 Component 正好位于鼠标指针下，则返回鼠标指针在该 Component 的坐标空间中的位置；否则返回 null。
Point | Container.getMousePosition(boolean allowChildren) 如果 Container 位于鼠标指针下，则返回鼠标指针在此 Container 的坐标中的位置，否则返回 null。
static int | MouseInfo.getNumberOfButtons() 返回鼠标上的按钮数。
static PointerInfo | MouseInfo.getPointerInfo() 返回表示鼠标指针当前位置的 PointerInfo 实例。
abstract GraphicsDevice[] | GraphicsEnvironment.getScreenDevices() 返回所有屏幕 GraphicsDevice 对象组成的数组。
Insets | Toolkit.getScreenInsets(GraphicsConfiguration gc) 获得屏幕的 insets。
abstract int | Toolkit.getScreenResolution() 返回屏幕分辨率，以每英寸的点数为单位。
abstract Dimension | Toolkit.getScreenSize() 获取屏幕的大小。
abstract Clipboard | Toolkit.getSystemClipboard() 获取系统 Clipboard 的一个实例，该 Clipboard 可作为本机平台提供的剪贴板工具的接口。
static Cursor | Cursor.getSystemCustomCursor(String name) 返回与指定名称匹配的特定于系统的定制光标对象。
Clipboard | Toolkit.getSystemSelection() 以 Clipboard 对象的形式获取系统选择的一个实例。
boolean | Toolkit.isDynamicLayoutActive() 返回当前是否激活了调整大小时的动态布局（以编程方式设置，并受底层操作系统和/或窗口管理器支持）。
protected boolean | Toolkit.isDynamicLayoutSet() 返回 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。
boolean | Toolkit.isFrameStateSupported(int state) 返回 Toolkit 是否支持 Frame 状态。
protected void | Toolkit.loadSystemColors(int[] systemColors) 使用当前系统颜色值填充作为参数提供的整数数组。
abstract Map<TextAttribute,?> | Toolkit.mapInputMethodHighlight(InputMethodHighlight highlight) 返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。
void | Toolkit.setDynamicLayout(boolean dynamic) 控制 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。

抛出 HeadlessException 的 java.awt 中的构造方法
Button()
构造一个标签字符串为空的按钮。
Button(String label)
构造一个带指定标签的按钮。
Checkbox()
使用空字符串标签创建一个复选框。
Checkbox(String label)
使用指定标签创建一个复选框。
Checkbox(String label, boolean state)
使用指定标签创建一个复选框，并将它设置为指定状态。
Checkbox(String label, boolean state, CheckboxGroup group)
构造具有指定标签的 Checkbox，并将它设置为指定状态，使它处于指定复选框组中。
Checkbox(String label, CheckboxGroup group, boolean state)
创建具有指定标签的 Checkbox，并使它处于指定复选框组内，将它设置为指定状态。
CheckboxMenuItem()
创建具有空标签的复选框菜单项。
CheckboxMenuItem(String label)
创建具有指定标签的复选框菜单项。
CheckboxMenuItem(String label, boolean state)
创建 具有指定标签和状态的复选框菜单项。
Choice()
创建一个新的选择菜单。
Frame()
构造一个最初不可见的 Frame 新实例（）。
Frame(String title)
构造一个新的、最初不可见的、具有指定标题的 Frame 对象。
Label()
构造一个空标签。
Label(String text)
使用指定的文本字符串构造一个新的标签，其文本对齐方式为左对齐。
Label(String text, int alignment)
构造一个显示指定的文本字符串的新标签，其文本对齐方式为指定的方式。
List()
创建新的滚动列表。
List(int rows)
创建一个用指定可视行数初始化的新滚动列表。
List(int rows, boolean multipleMode)
创建一个初始化为显示指定行数的新滚动列表。
Menu()
构造具有空标签的新菜单。
Menu(String label)
构造具有指定标签的新菜单。
Menu(String label, boolean tearOff)
构造具有指定标签的新菜单，指示该菜单是否可以分离。
MenuBar()
创建新的菜单栏。
MenuComponent()
创建 MenuComponent。
MenuItem()
构造具有空标签且没有键盘快捷方式的新菜单项。
MenuItem(String label)
构造具有指定的标签且没有键盘快捷方式的新菜单项。
MenuItem(String label, MenuShortcut s)
创建具有关联的键盘快捷方式的菜单项。
PopupMenu()
创建具有空名称的新弹出式菜单。
PopupMenu(String label)
创建具有指定名称的新弹出式菜单。
Scrollbar()
构造一个新的垂直滚动条。
Scrollbar(int orientation)
构造一个具有指定方向的新滚动条。
Scrollbar(int orientation, int value, int visible, int minimum, int maximum)
构造一个新的滚动条，它具有指定的方向、初始值、可见量、最小值和最大值。
ScrollPane()
创建一个具有滚动条策略 "as needed" 的新滚动窗格容器。
ScrollPane(int scrollbarDisplayPolicy)
创建新的滚动窗格容器。
TextArea()
构造一个将空字符串作为文本的新文本区。
TextArea(int rows, int columns)
构造一个新文本区，该文本区具有指定的行数和列数，并将空字符串作为文本。
TextArea(String text)
构造具有指定文本的新文本区。
TextArea(String text, int rows, int columns)
构造一个新文本区，该文本区具有指定的文本，以及指定的行数和列数。
TextArea(String text, int rows, int columns, int scrollbars)
构造一个新文本区，该文本区具有指定的文本，以及指定的行数、列数和滚动条可见性。
TextField()
构造新文本字段。
TextField(int columns)
构造具有指定列数的新空文本字段。
TextField(String text)
构造使用指定文本初始化的新文本字段。
TextField(String text, int columns)
构造使用要显示的指定文本初始化的新文本字段，宽度足够容纳指定列数。

java.awt.dnd 中 HeadlessException 的使用

抛出 HeadlessException 的 java.awt.dnd 中的构造方法
DragSource()
创建一个新的 DragSource。
DropTarget()
创建一个 DropTarget
DropTarget(Component c, DropTargetListener dtl)
在给出与之关联的 Component 和执行事件处理的 DropTargetListener 的情况下创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值和执行事件处理的 DropTargetListener 的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener 和表示 DropTarget 当前是否接受 drop 的 boolean 值的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。

java.awt.print 中 HeadlessException 的使用

抛出 HeadlessException 的 java.awt.print 中的方法
abstract PageFormat | PrinterJob.pageDialog(PageFormat page) 显示允许修改 PageFormat 实例的对话框。
PageFormat | PrinterJob.pageDialog(PrintRequestAttributeSet attributes) 显示跨平台页面设置对话框的便捷方法。
abstract boolean | PrinterJob.printDialog() 向用户呈现一个对话框，用来更改打印作业的属性。
boolean | PrinterJob.printDialog(PrintRequestAttributeSet attributes) 为所有服务显示跨平台打印对话框的便捷方法，这些服务能够使用 Pageable 接口打印 2D 图形。

javax.print 中 HeadlessException 的使用

抛出 HeadlessException 的 javax.print 中的方法
static PrintService ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
为用户提供一个选择 PrintService（打印机）的对话框。

javax.swing 中 HeadlessException 的使用

抛出 HeadlessException 的 javax.swing 中的方法
protected JDialog | JFileChooser.createDialog(Component parent) 创建并返回包含 this 的新 JDialog，在 parent 窗体中的 parent 上居中。
JDialog | JOptionPane.createDialog(Component parentComponent, String title) 创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。
static JDialog | JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener) 创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
JDialog | JOptionPane.createDialog(String title) 创建并返回一个新的带有指定标题的无父 JDialog。
static Frame | JOptionPane.getFrameForComponent(Component parentComponent) 返回指定组件的 Frame。
static Frame | JOptionPane.getRootFrame() 返回用于不提供窗体的类方法中的 Frame。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。
static int | JOptionPane.showConfirmDialog(Component parentComponent, Object message) 调出带有选项 Yes、No 和 Cancel 的对话框；标题为 Select an Option。
static int | JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType) 调出一个由 optionType 参数确定其中选项数的对话框。
static int | JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType) 调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。
static int | JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon) 调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。
int | JFileChooser.showDialog(Component parent, String approveButtonText) 弹出具有自定义 approve 按钮的自定义文件选择器对话框。
static Color | JColorChooser.showDialog(Component component, String title, Color initialColor) 显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。
static String | JOptionPane.showInputDialog(Component parentComponent, Object message) 显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
static String | JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType) 显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。
static Object | JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue) 提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。
static String | JOptionPane.showInputDialog(Object message) 显示请求用户输入的问题消息对话框。
static void | JOptionPane.showMessageDialog(Component parentComponent, Object message) 调出标题为 "Message" 的信息消息对话框。
static void | JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType) 调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。
static void | JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon) 调出一个显示信息的对话框，为其指定了所有参数。
int | JFileChooser.showOpenDialog(Component parent) 弹出一个 "Open File" 文件选择器对话框。
static int | JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue) 调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
int | JFileChooser.showSaveDialog(Component parent) 弹出一个 "Save File" 文件选择器对话框。

抛出 HeadlessException 的 javax.swing 中的构造方法
JApplet()
创建一个 swing applet 实例。
JFrame()
构造一个初始时不可见的新窗体。
JFrame(String title)
创建一个新的、初始不可见的、具有指定标题的 Frame。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.IllegalComponentStateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.IllegalComponentStateException
的使用

使用 IllegalComponentStateException 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 IllegalComponentStateException 的使用

抛出 IllegalComponentStateException 的 javax.accessibility 中的方法
abstract  Locale AccessibleContext.getLocale()
获取该组件的语言环境。

javax.swing 中 IllegalComponentStateException 的使用

抛出 IllegalComponentStateException 的 javax.swing 中的方法
Locale | ProgressMonitor.AccessibleProgressMonitor.getLocale() 获取该组件的语言环境。
Locale | ImageIcon.AccessibleImageIcon.getLocale() 返回此对象的区域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Image 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Image
的使用

使用 Image 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image | 提供创建和修改图像的各种类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 Image 的使用

返回 Image 的 java.applet 中的方法
Image | AppletContext.getImage(URL url) 返回能被绘制到屏幕上的 Image 对象。
Image | Applet.getImage(URL url) 返回能被绘制到屏幕上的 Image 对象。
Image | Applet.getImage(URL url, String name) 返回能被绘制到屏幕上的 Image 对象。

java.awt 中 Image 的使用

声明为 Image 的 java.awt 中的字段
protected  Image Component.FlipBufferStrategy.drawBuffer
绘制缓冲区。

返回 Image 的 java.awt 中的方法
Image | Toolkit.createImage(byte[] imagedata) 创建一幅图像，该图像对存储在指定字节数组中的图像进行解码。
abstract Image | Toolkit.createImage(byte[] imagedata, int imageoffset, int imagelength) 创建一幅图像，该图像对存储在指定字节数组中指定偏移量和长度处的图像进行解码。
abstract Image | Toolkit.createImage(ImageProducer producer) 使用指定的图像生成器创建一幅图像。
Image | Component.createImage(ImageProducer producer) 根据指定的图像生成器创建一幅图像。
Image | Component.createImage(int width, int height) 创建一幅用于双缓冲的、可在屏幕外绘制的图像。
abstract Image | Toolkit.createImage(String filename) 返回从指定文件获取像素数据的图像。
abstract Image | Toolkit.createImage(URL url) 返回一幅图像，该图像从指定 URL 获取像素数据。
protected Image | Component.FlipBufferStrategy.getBackBuffer()
Image | Frame.getIconImage() 返回要作为此窗体图标显示的图像。
Image | TrayIcon.getImage() 返回用于此 TrayIcon 的当前图像。
abstract Image | Toolkit.getImage(String filename) 返回一幅图像，该图像从指定文件中获取像素数据，图像格式可以是 GIF、JPEG 或 PNG。
abstract Image | Toolkit.getImage(URL url) 返回一幅图像，该图像从指定 URL 获取像素数据。
Image | Image.getScaledInstance(int width, int height, int hints) 创建此图像的缩放版本。

返回变量类型为 Image 的类型的 java.awt 中的方法
 List<Image> Window.getIconImages()
返回要作为此窗口的图标显示的图像序列。

参数类型为 Image 的 java.awt 中的方法
void | MediaTracker.addImage(Image image, int id) 向此媒体跟踪器正在跟踪的图像列表添加一个图像。
void | MediaTracker.addImage(Image image, int id, int w, int h) 向此媒体跟踪器正在跟踪的图像列表添加一个经过缩放的图像。
int | Component.checkImage(Image image, ImageObserver observer) 返回指定图像屏幕表示的构造状态。
abstract int | Toolkit.checkImage(Image image, int width, int height, ImageObserver observer) 指示正准备显示的指定图像的构造状态。
int | Component.checkImage(Image image, int width, int height, ImageObserver observer) 返回指定图像屏幕表示的构造状态。
Cursor | Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name) 创建一个新的自定义光标对象。
abstract boolean | Graphics2D.drawImage(Image img, AffineTransform xform, ImageObserver obs) 呈现一个图像，在绘制前进行从图像空间到用户空间的转换。
abstract boolean | Graphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 绘制指定图像中当前可用的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, ImageObserver observer) 绘制指定图像中当前可用的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, int width, int height, ImageObserver observer) 绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract boolean | Graphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
abstract boolean | Graphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer) 绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
boolean | Component.imageUpdate(Image img, int infoflags, int x, int y, int w, int h) 图像已改变时重绘组件。
boolean | Component.prepareImage(Image image, ImageObserver observer) 准备一幅在此组件上呈现的图像。
abstract boolean | Toolkit.prepareImage(Image image, int width, int height, ImageObserver observer) 准备一个用于呈现的图像。
boolean | Component.prepareImage(Image image, int width, int height, ImageObserver observer) 以指定的宽度和高度准备一幅在此组件上呈现的图像。
void | MediaTracker.removeImage(Image image) 从此媒体跟踪器移除指定的图像。
void | MediaTracker.removeImage(Image image, int id) 从此媒体跟踪器的指定跟踪 ID 中移除指定的图像。
void | MediaTracker.removeImage(Image image, int id, int width, int height) 从此媒体跟踪器移除具有指定宽度、高度和 ID 的指定图像。
void | Frame.setIconImage(Image image) 设置要作为此窗口图标显示的图像。
void | Window.setIconImage(Image image) 设置要作为此窗口图标显示的图像。
void | TrayIcon.setImage(Image image) 设置此 TrayIcon 的图像。

类型变量类型为 Image 的 java.awt 中的方法参数
 void Window.setIconImages(List<? extends Image> icons)
设置要作为此窗口的图标显示的图像序列。

参数类型为 Image 的 java.awt 中的构造方法
TrayIcon(Image image)
创建带有指定图像的 TrayIcon。
TrayIcon(Image image, String tooltip)
创建带有指定图像和工具提示文本的 TrayIcon。
TrayIcon(Image image, String tooltip, PopupMenu popup)
创建带指定图像、工具提示和弹出菜单的 TrayIcon。

java.awt.dnd 中 Image 的使用

参数类型为 Image 的 java.awt.dnd 中的方法
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 Image 的 java.awt.dnd 中的构造方法
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。

java.awt.font 中 Image 的使用

参数类型为 Image 的 java.awt.font 中的构造方法
ImageGraphicAttribute(Image image, int alignment)
根据指定的 Image 构造一个 ImageGraphicAttribute。
ImageGraphicAttribute(Image image, int alignment, float originX, float originY)
根据指定的 Image 构造一个 ImageGraphicAttribute。

java.awt.im.spi 中 Image 的使用

返回 Image 的 java.awt.im.spi 中的方法
 Image InputMethodDescriptor.getInputMethodIcon(Locale inputLocale)
返回相应输入方法的图标。

java.awt.image 中 Image 的使用

java.awt.image 中 Image 的子类
class | BufferedImage BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。
class | VolatileImage VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。

参数类型为 Image 的 java.awt.image 中的方法
 boolean ImageObserver.imageUpdate(Image img, int infoflags, int x, int y, int width, int height)
当以前使用异步接口所请求的图像的信息变得可用时就调用此方法。

参数类型为 Image 的 java.awt.image 中的构造方法
PixelGrabber(Image img, int x, int y, int w, int h, boolean forceRGB)
创建一个 PixelGrabber 对象，以从指定的图像中抓取像素矩形部分 (x, y, w, h)。
PixelGrabber(Image img, int x, int y, int w, int h, int[] pix, int off, int scansize)
创建一个 PixelGrabber 对象，以从指定图像将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。

java.beans 中 Image 的使用

返回 Image 的 java.beans 中的方法
Image | BeanInfo.getIcon(int iconKind) 此方法返回一个图像对象，可用该对象表示工具框、工具栏等中的 bean。
Image | SimpleBeanInfo.getIcon(int iconKind) 声明没有可用的图标。
Image | SimpleBeanInfo.loadImage(String resourceName) 这是帮助加载图标图像的实用工具方法。

javax.swing 中 Image 的使用

声明为 Image 的 javax.swing 中的字段
protected  Image JViewport.backingStoreImage
用于后备存储的视图图像。

返回 Image 的 javax.swing 中的方法
static Image | GrayFilter.createDisabledImage(Image i) 创建一个禁用图像
Image | ImageIcon.getImage() 返回此图标的 Image。
Image | RepaintManager.getOffscreenBuffer(Component c, int proposedWidth, int proposedHeight) 返回屏幕外缓冲区，它应用作带有组件 c 的双缓冲区。
Image | RepaintManager.getVolatileOffscreenBuffer(Component c, int proposedWidth, int proposedHeight) 返回可变屏幕外缓冲区，它应用作带有指定组件 c 的双缓冲区。

参数类型为 Image 的 javax.swing 中的方法
static Image | GrayFilter.createDisabledImage(Image i) 创建一个禁用图像
boolean | DebugGraphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, int width, int height, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer) 重写 Graphics.drawImage。
boolean | AbstractButton.imageUpdate(Image img, int infoflags, int x, int y, int w, int h) 重写的此方法在当前 Icon 的 Image 不等于传入的 Image img 时返回 false。
boolean | JLabel.imageUpdate(Image img, int infoflags, int x, int y, int w, int h) 如果当前图标的图像不等于传入的图像 img，则重写此方法以返回 false。
protected void | ImageIcon.loadImage(Image image) 加载图像，并且只在图像已加载时返回。
void | JFrame.setIconImage(Image image) 设置要作为此窗口图标显示的图像。
void | ImageIcon.setImage(Image image) 设置由此图标显示的图像。

参数类型为 Image 的 javax.swing 中的构造方法
ImageIcon(Image image)
根据图像对象创建一个 ImageIcon。
ImageIcon(Image image, String description)
根据图像创建一个 ImageIcon。

javax.swing.text.html 中 Image 的使用

返回 Image 的 javax.swing.text.html 中的方法
 Image ImageView.getImage()
返回要呈现的图像。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.ImageCapabilities 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ImageCapabilities
的使用

使用 ImageCapabilities 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 ImageCapabilities 的使用

返回 ImageCapabilities 的 java.awt 中的方法
ImageCapabilities | BufferCapabilities.getBackBufferCapabilities()
ImageCapabilities | Image.getCapabilities(GraphicsConfiguration gc) 返回 ImageCapabilities 对象，查询该对象便可以了解使用指定 GraphicsConfiguration 时此 Image 的功能。
ImageCapabilities | BufferCapabilities.getFrontBufferCapabilities()
ImageCapabilities | GraphicsConfiguration.getImageCapabilities() 返回此 GraphicsConfiguration 的图像能力。

参数类型为 ImageCapabilities 的 java.awt 中的方法
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力的 VolatileImage。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps, int transparency) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力和透明度值的 VolatileImage。
VolatileImage | Component.createVolatileImage(int width, int height, ImageCapabilities caps) 创建一幅具有给定能力的、可变的、可在屏幕外绘制的图像。

参数类型为 ImageCapabilities 的 java.awt 中的构造方法
BufferCapabilities(ImageCapabilities frontCaps, ImageCapabilities backCaps, BufferCapabilities.FlipContents flipContents)
创建一个指定缓冲区能力的新对象

java.awt.image 中 ImageCapabilities 的使用

返回 ImageCapabilities 的 java.awt.image 中的方法
abstract  ImageCapabilities VolatileImage.getCapabilities()
返回 ImageCapabilities 对象，查询此对象即可了解此 VolatileImage 的特定功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Insets 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Insets
的使用

使用 Insets 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Insets 的使用

声明为 Insets 的 java.awt 中的字段
 Insets GridBagConstraints.insets
此字段指定组件的外部填充，即组件与其显示区域边缘之间间距的最小量。

返回 Insets 的 java.awt 中的方法
 Insets Container.getInsets()
确定此容器的 insets，它指示容器边框的大小。
 Insets Toolkit.getScreenInsets(GraphicsConfiguration gc)
获得屏幕的 insets。
 Insets Container.insets()
已过时。 从 JDK version 1.1 开始，用 getInsets() 取代。

参数类型为 Insets 的 java.awt 中的构造方法
GridBagConstraints(int gridx, int gridy, int gridwidth, int gridheight, double weightx, double weighty, int anchor, int fill, Insets insets, int ipadx, int ipady)
创建一个 GridBagConstraints 对象，将其所有字段都设置为传入参数。

java.awt.dnd 中 Insets 的使用

返回 Insets 的 java.awt.dnd 中的方法
 Insets Autoscroll.getAutoscrollInsets()
此方法返回 Insets，用于描述相对于实现 Component 几何形状的自动滚动区域或边界。

javax.swing 中 Insets 的使用

返回 Insets 的 javax.swing 中的方法
Insets | JViewport.getInsets() 返回 inset（边框）维数 (0,0,0,0)，因为在 JViewport 上不支持边框。
Insets | JComponent.getInsets() 如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。
Insets | JViewport.getInsets(Insets insets) 返回包含此 JViewport 的 inset 值的 inset 对象。
Insets | JComponent.getInsets(Insets insets) 返回包含此组件 inset 值的 Insets 对象。
Insets | UIDefaults.getInsets(Object key) 如果 key 值为一个 Insets，则返回它，否则返回 null。
static Insets | UIManager.getInsets(Object key) 从默认值中返回一个 Insets 对象。
Insets | UIDefaults.getInsets(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Insets，则返回该 Insets，否则返回 null。
static Insets | UIManager.getInsets(Object key, Locale l) 从适合给定语言环境的默认值中返回一个 Insets 对象。
Insets | JPopupMenu.getMargin() 返回弹出菜单的边框与其包含内容之间的空白（以像素表示）。
Insets | JMenuBar.getMargin() 返回菜单栏的边框与其菜单之间的空白。
Insets | JToolBar.getMargin() 返回工具栏边框和它的按钮之间的空白。
Insets | AbstractButton.getMargin() 返回按钮边框和标签之间的空白。

参数类型为 Insets 的 javax.swing 中的方法
Insets | JViewport.getInsets(Insets insets) 返回包含此 JViewport 的 inset 值的 inset 对象。
Insets | JComponent.getInsets(Insets insets) 返回包含此组件 inset 值的 Insets 对象。
void | JMenuBar.setMargin(Insets m) 设置菜单栏的边框与其菜单之间的空白。
void | JToolBar.setMargin(Insets m) 设置工具栏边框和它的按钮之间的空白。
void | AbstractButton.setMargin(Insets m) 设置按钮边框和标签之间的空白。

javax.swing.border 中 Insets 的使用

返回 Insets 的 javax.swing.border 中的方法
Insets | MatteBorder.getBorderInsets() 返回此边框的 insets。
Insets | EmptyBorder.getBorderInsets() 返回此边框的 insets。
Insets | SoftBevelBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | TitledBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | BevelBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | EtchedBorder.getBorderInsets(Component c) 返回边框的 insets
Insets | LineBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | MatteBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | CompoundBorder.getBorderInsets(Component c) 返回复合边框的 insets，它是外部边框的 insets 与内部边框的 insets 相加所得的结果。
Insets | EmptyBorder.getBorderInsets(Component c) 返回此边框的 insets
Insets | AbstractBorder.getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | Border.getBorderInsets(Component c) 返回该边框的 insets。
Insets | SoftBevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | TitledBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | BevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EtchedBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | LineBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | MatteBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | CompoundBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EmptyBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | AbstractBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。

参数类型为 Insets 的 javax.swing.border 中的方法
Insets | SoftBevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | TitledBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | BevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EtchedBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | LineBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | MatteBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | CompoundBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EmptyBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | AbstractBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。

参数类型为 Insets 的 javax.swing.border 中的构造方法
EmptyBorder(Insets borderInsets)
创建具有指定 insets 的空边框
MatteBorder(Insets borderInsets, Color matteColor)
创建具有指定 insets 和颜色的衬边边框。
MatteBorder(Insets borderInsets, Icon tileIcon)
创建具有指定 insets 和平铺图标的衬边边框。

javax.swing.plaf 中 Insets 的使用

javax.swing.plaf 中 Insets 的子类
 class InsetsUIResource

返回 Insets 的 javax.swing.plaf 中的方法
 Insets BorderUIResource.getBorderInsets(Component c)

参数类型为 Insets 的 javax.swing.plaf 中的构造方法
BorderUIResource.EmptyBorderUIResource(Insets insets)

javax.swing.plaf.basic 中 Insets 的使用

声明为 Insets 的 javax.swing.plaf.basic 中的字段
protected Insets | BasicTabbedPaneUI.contentBorderInsets
protected Insets | BasicSliderUI.focusInsets
protected Insets | BasicSliderUI.insetCache
protected Insets | BasicTabbedPaneUI.selectedTabPadInsets
protected Insets | BasicTabbedPaneUI.tabAreaInsets
protected Insets | BasicTabbedPaneUI.tabInsets

返回 Insets 的 javax.swing.plaf.basic 中的方法
 Insets BasicBorders.ButtonBorder.getBorderInsets(Component c)
 Insets BasicBorders.ToggleButtonBorder.getBorderInsets(Component c)
 Insets BasicBorders.RadioButtonBorder.getBorderInsets(Component c)
 Insets BasicBorders.MenuBarBorder.getBorderInsets(Component c)
 Insets BasicBorders.MarginBorder.getBorderInsets(Component c)
 Insets BasicBorders.FieldBorder.getBorderInsets(Component c)
 Insets BasicBorders.SplitPaneBorder.getBorderInsets(Component c)
 Insets BasicBorders.ButtonBorder.getBorderInsets(Component c, Insets insets)
 Insets BasicBorders.ToggleButtonBorder.getBorderInsets(Component c, Insets insets)
 Insets BasicBorders.RadioButtonBorder.getBorderInsets(Component c, Insets insets)
 Insets BasicBorders.MenuBarBorder.getBorderInsets(Component c, Insets insets)
 Insets BasicBorders.MarginBorder.getBorderInsets(Component c, Insets insets)
 Insets BasicBorders.FieldBorder.getBorderInsets(Component c, Insets insets)
protected  Insets BasicTabbedPaneUI.getContentBorderInsets(int tabPlacement)
static Insets BasicGraphicsUtils.getEtchedInsets()
返回 drawEtchedRect() 绘制边框占用的空间量。
static Insets BasicGraphicsUtils.getGrooveInsets()
返回 drawGroove() 绘制边框占用的空间量。
 Insets BasicSplitPaneDivider.getInsets()
如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。
protected  Insets BasicComboBoxUI.getInsets()
获取 JComboBox 的 insets。
 Insets BasicToolBarUI.DragWindow.getInsets()
 Insets BasicDesktopIconUI.getInsets(JComponent c)
 Insets BasicSplitPaneUI.getInsets(JComponent jc)
返回 insets。
protected  Insets BasicTabbedPaneUI.getSelectedTabPadInsets(int tabPlacement)
protected  Insets BasicTabbedPaneUI.getTabAreaInsets(int tabPlacement)
protected  Insets BasicTabbedPaneUI.getTabInsets(int tabPlacement, int tabIndex)

参数类型为 Insets 的 javax.swing.plaf.basic 中的方法
protected int | BasicProgressBarUI.getAmountFull(Insets b, int width, int height) 此方法确定进度条的量，该量应该基于从模型搜集的完成百分比填充。
protected int | BasicSplitPaneUI.BasicHorizontalLayoutManager.getAvailableSize(Dimension containerSize, Insets insets) 返回基于容器大小和 Insets 的可用宽度。
Insets | BasicBorders.ButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.ToggleButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.RadioButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.MenuBarBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.MarginBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.FieldBorder.getBorderInsets(Component c, Insets insets)
protected int | BasicSplitPaneUI.BasicHorizontalLayoutManager.getInitialLocation(Insets insets) 如果 Insets 不为 null，则返回左边 inset；如果其为 null，则返回 0。
protected void | BasicTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制 row 的展开（切换）部分。
protected void | BasicTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制支路 (leg) 的水平部分。
protected void | BasicTreeUI.paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制 row 的渲染器部分。
protected void | BasicProgressBarUI.paintString(Graphics g, int x, int y, int width, int height, int amountFull, Insets b)
protected void | BasicTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path) 绘制支路的垂直部分。
protected static void | BasicTabbedPaneUI.rotateInsets(Insets topInsets, Insets targetInsets, int targetPlacement)
protected void | BasicSplitPaneUI.BasicHorizontalLayoutManager.setComponentToSize(Component c, int size, int location, Insets insets, Dimension containerSize) 将组件 c 的宽度设置为 size（将其 x 的位置放置到 location），将 y 和高度分别设置为 insets.top 和 containersize.height 减去上下 insets。

javax.swing.plaf.metal 中 Insets 的使用

声明为 Insets 的 javax.swing.plaf.metal 中的字段
protected static Insets | MetalBorders.ButtonBorder.borderInsets
protected static Insets | MetalBorders.MenuBarBorder.borderInsets
protected static Insets | MetalBorders.MenuItemBorder.borderInsets
protected static Insets | MetalBorders.PopupMenuBorder.borderInsets
protected static Insets | MetalComboBoxEditor.editorBorderInsets 默认编辑器边框 Insets。
protected Insets | MetalBorders.TableHeaderBorder.editorBorderInsets

返回 Insets 的 javax.swing.plaf.metal 中的方法
Insets | MetalBorders.Flush3DBorder.getBorderInsets(Component c)
Insets | MetalBorders.ButtonBorder.getBorderInsets(Component c)
Insets | MetalBorders.InternalFrameBorder.getBorderInsets(Component c)
Insets | MetalBorders.PaletteBorder.getBorderInsets(Component c)
Insets | MetalBorders.OptionDialogBorder.getBorderInsets(Component c)
Insets | MetalBorders.MenuBarBorder.getBorderInsets(Component c)
Insets | MetalBorders.MenuItemBorder.getBorderInsets(Component c)
Insets | MetalBorders.PopupMenuBorder.getBorderInsets(Component c)
Insets | MetalBorders.ToolBarBorder.getBorderInsets(Component c)
Insets | MetalBorders.ScrollPaneBorder.getBorderInsets(Component c)
Insets | MetalBorders.TableHeaderBorder.getBorderInsets(Component c)
Insets | MetalBorders.Flush3DBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ButtonBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.InternalFrameBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PaletteBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.OptionDialogBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuBarBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuItemBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PopupMenuBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ToolBarBorder.getBorderInsets(Component c, Insets newInsets)

参数类型为 Insets 的 javax.swing.plaf.metal 中的方法
Insets | MetalBorders.Flush3DBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ButtonBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.InternalFrameBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PaletteBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.OptionDialogBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuBarBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuItemBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PopupMenuBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ToolBarBorder.getBorderInsets(Component c, Insets newInsets)
protected void | MetalTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
protected void | MetalTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

javax.swing.plaf.synth 中 Insets 的使用

返回 Insets 的 javax.swing.plaf.synth 中的方法
 Insets SynthStyle.getInsets(SynthContext context, Insets insets)
返回用来计算大小调整信息的 Insets。

参数类型为 Insets 的 javax.swing.plaf.synth 中的方法
 Insets SynthStyle.getInsets(SynthContext context, Insets insets)
返回用来计算大小调整信息的 Insets。

javax.swing.text 中 Insets 的使用

返回 Insets 的 javax.swing.text 中的方法
 Insets JTextComponent.getMargin()
返回文本组件的边框和它的文本之间的空白。

参数类型为 Insets 的 javax.swing.text 中的方法
 void JTextComponent.setMargin(Insets m)
设置组件的边框和它的文本之间的空白。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.ItemSelectable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.ItemSelectable
的使用

使用 ItemSelectable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

java.awt 中 ItemSelectable 的使用

实现 ItemSelectable 的 java.awt 中的类
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
class | CheckboxMenuItem 此类表示一个可包括在菜单中的复选框。
class | Choice Choice 类表示一个弹出式选择菜单。
class | List List 组件为用户提供了一个可滚动的文本项列表。

java.awt.event 中 ItemSelectable 的使用

返回 ItemSelectable 的 java.awt.event 中的方法
 ItemSelectable ItemEvent.getItemSelectable()
返回事件的产生程序。

参数类型为 ItemSelectable 的 java.awt.event 中的构造方法
ItemEvent(ItemSelectable source, int id, Object item, int stateChange)
构造一个 ItemEvent 对象。

javax.swing 中 ItemSelectable 的使用

javax.swing 中 ItemSelectable 的子接口
 interface ButtonModel
按钮的状态模型。

实现 ItemSelectable 的 javax.swing 中的类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | DefaultButtonModel Button 组件的数据模型的默认实现。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuItem 菜单中的项的实现。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
static class | JToggleButton.ToggleButtonModel ToggleButton 模型。

javax.swing.plaf.basic 中 ItemSelectable 的使用

实现 ItemSelectable 的 javax.swing.plaf.basic 中的类
 class BasicArrowButton
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。

javax.swing.plaf.metal 中 ItemSelectable 的使用

实现 ItemSelectable 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.JobAttributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes
的使用

使用 JobAttributes 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes 的使用

参数类型为 JobAttributes 的 java.awt 中的方法
PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
void | JobAttributes.set(JobAttributes obj) 将此 JobAttributes 的所有属性设置为与 obj 的属性相同的值。

参数类型为 JobAttributes 的 java.awt 中的构造方法
JobAttributes(JobAttributes obj)
构造一个 JobAttributes 实例，作为所提供的 JobAttributes 的副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.JobAttributes.DefaultSelectionType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes.DefaultSelectionType
的使用

使用 JobAttributes.DefaultSelectionType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes.DefaultSelectionType 的使用

声明为 JobAttributes.DefaultSelectionType 的 java.awt 中的字段
static JobAttributes.DefaultSelectionType | JobAttributes.DefaultSelectionType.ALL 用于指定应该打印全部作业页面的 DefaultSelectionType 实例。
static JobAttributes.DefaultSelectionType | JobAttributes.DefaultSelectionType.RANGE 用于指定应该打印一定范围的作业页面的 DefaultSelectionType 实例。
static JobAttributes.DefaultSelectionType | JobAttributes.DefaultSelectionType.SELECTION 用于指定应该打印当前选择作业页面的 DefaultSelectionType 实例。

返回 JobAttributes.DefaultSelectionType 的 java.awt 中的方法
 JobAttributes.DefaultSelectionType JobAttributes.getDefaultSelection()
指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。

参数类型为 JobAttributes.DefaultSelectionType 的 java.awt 中的方法
 void JobAttributes.setDefaultSelection(JobAttributes.DefaultSelectionType defaultSelection)
指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。

参数类型为 JobAttributes.DefaultSelectionType 的 java.awt 中的构造方法
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.JobAttributes.DestinationType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes.DestinationType
的使用

使用 JobAttributes.DestinationType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes.DestinationType 的使用

声明为 JobAttributes.DestinationType 的 java.awt 中的字段
static JobAttributes.DestinationType | JobAttributes.DestinationType.FILE 用于指定打印到文件的 DestinationType 实例。
static JobAttributes.DestinationType | JobAttributes.DestinationType.PRINTER 用于指定打印到打印机的 DestinationType 实例。

返回 JobAttributes.DestinationType 的 java.awt 中的方法
 JobAttributes.DestinationType JobAttributes.getDestination()
指定将输出到打印机还是使用这些属性的作业文件。

参数类型为 JobAttributes.DestinationType 的 java.awt 中的方法
 void JobAttributes.setDestination(JobAttributes.DestinationType destination)
指定将输出到打印机还是使用这些属性的作业文件。

参数类型为 JobAttributes.DestinationType 的 java.awt 中的构造方法
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.JobAttributes.DialogType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes.DialogType
的使用

使用 JobAttributes.DialogType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes.DialogType 的使用

声明为 JobAttributes.DialogType 的 java.awt 中的字段
static JobAttributes.DialogType | JobAttributes.DialogType.COMMON 用于指定跨平台的纯 Java 打印对话框的 DialogType 实例。
static JobAttributes.DialogType | JobAttributes.DialogType.NATIVE 用于指定平台的本机打印对话框的 DialogType 实例。
static JobAttributes.DialogType | JobAttributes.DialogType.NONE 用于指定无打印对话框的 DialogType 实例。

返回 JobAttributes.DialogType 的 java.awt 中的方法
 JobAttributes.DialogType JobAttributes.getDialog()
返回对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。

参数类型为 JobAttributes.DialogType 的 java.awt 中的方法
 void JobAttributes.setDialog(JobAttributes.DialogType dialog)
指定对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。

参数类型为 JobAttributes.DialogType 的 java.awt 中的构造方法
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.JobAttributes.MultipleDocumentHandlingType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes.MultipleDocumentHandlingType
的使用

使用 JobAttributes.MultipleDocumentHandlingType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes.MultipleDocumentHandlingType 的使用

声明为 JobAttributes.MultipleDocumentHandlingType 的 java.awt 中的字段
static JobAttributes.MultipleDocumentHandlingType | JobAttributes.MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_COLLATED_COPIES 用于指定应该将作业分成单独的、已整理的副本的 MultipleDocumentHandlingType 实例。
static JobAttributes.MultipleDocumentHandlingType | JobAttributes.MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES 用于指定应该将作业分成单独的、未整理的副本的 MultipleDocumentHandlingType 实例。

返回 JobAttributes.MultipleDocumentHandlingType 的 java.awt 中的方法
 JobAttributes.MultipleDocumentHandlingType JobAttributes.getMultipleDocumentHandling()
为使用这些属性的作业指定多份处理，包括整理。

参数类型为 JobAttributes.MultipleDocumentHandlingType 的 java.awt 中的方法
 void JobAttributes.setMultipleDocumentHandling(JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling)
为使用这些属性的作业指定多份处理，包括整理。

参数类型为 JobAttributes.MultipleDocumentHandlingType 的 java.awt 中的构造方法
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.JobAttributes.SidesType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes.SidesType
的使用

使用 JobAttributes.SidesType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes.SidesType 的使用

声明为 JobAttributes.SidesType 的 java.awt 中的字段
static JobAttributes.SidesType | JobAttributes.SidesType.ONE_SIDED SidesType 实例用于指定应该在连续介质纸张的同一面打印连续作业页面。
static JobAttributes.SidesType | JobAttributes.SidesType.TWO_SIDED_LONG_EDGE SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在长边上一样。
static JobAttributes.SidesType | JobAttributes.SidesType.TWO_SIDED_SHORT_EDGE SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在短边上一样。

返回 JobAttributes.SidesType 的 java.awt 中的方法
 JobAttributes.SidesType JobAttributes.getSides()
返回对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。

参数类型为 JobAttributes.SidesType 的 java.awt 中的方法
 void JobAttributes.setSides(JobAttributes.SidesType sides)
指定对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。

参数类型为 JobAttributes.SidesType 的 java.awt 中的构造方法
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.KeyboardFocusManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.KeyboardFocusManager
的使用

使用 KeyboardFocusManager 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 KeyboardFocusManager 的使用

java.awt 中 KeyboardFocusManager 的子类
 class DefaultKeyboardFocusManager
AWT 应用程序的默认 KeyboardFocusManager。

返回 KeyboardFocusManager 的 java.awt 中的方法
static KeyboardFocusManager KeyboardFocusManager.getCurrentKeyboardFocusManager()
返回调用线程上下文的当前 KeyboardFocusManager 实例。

参数类型为 KeyboardFocusManager 的 java.awt 中的方法
static void KeyboardFocusManager.setCurrentKeyboardFocusManager(KeyboardFocusManager newManager)
设置调用线程上下文的当前 KeyboardFocusManager 实例。

javax.swing 中 KeyboardFocusManager 的使用

javax.swing 中 KeyboardFocusManager 的子类
class | DefaultFocusManager 此类已被废弃，用 1.4 focus API 取代。
class | FocusManager 从 1.4 focus API 开始，此类已被废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.KeyEventDispatcher 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.KeyEventDispatcher
的使用

使用 KeyEventDispatcher 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 KeyEventDispatcher 的使用

实现 KeyEventDispatcher 的 java.awt 中的类
class | DefaultKeyboardFocusManager AWT 应用程序的默认 KeyboardFocusManager。
class | KeyboardFocusManager KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。

返回变量类型为 KeyEventDispatcher 的类型的 java.awt 中的方法
protected  List<KeyEventDispatcher> KeyboardFocusManager.getKeyEventDispatchers()
作为 List 返回此 KeyboardFocusManager 的 KeyEventDispatcher 链。

参数类型为 KeyEventDispatcher 的 java.awt 中的方法
void | KeyboardFocusManager.addKeyEventDispatcher(KeyEventDispatcher dispatcher) 将 KeyEventDispatcher 添加到此 KeyboardFocusManager 的调度程序链中。
void | KeyboardFocusManager.removeKeyEventDispatcher(KeyEventDispatcher dispatcher) 移除以前添加到此 KeyboardFocusManager 调度程序链中的 KeyEventDispatcher。

javax.swing 中 KeyEventDispatcher 的使用

实现 KeyEventDispatcher 的 javax.swing 中的类
class | DefaultFocusManager 此类已被废弃，用 1.4 focus API 取代。
class | FocusManager 从 1.4 focus API 开始，此类已被废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.KeyEventPostProcessor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.KeyEventPostProcessor
的使用

使用 KeyEventPostProcessor 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 KeyEventPostProcessor 的使用

实现 KeyEventPostProcessor 的 java.awt 中的类
class | DefaultKeyboardFocusManager AWT 应用程序的默认 KeyboardFocusManager。
class | KeyboardFocusManager KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。

返回变量类型为 KeyEventPostProcessor 的类型的 java.awt 中的方法
protected  List<KeyEventPostProcessor> KeyboardFocusManager.getKeyEventPostProcessors()
作为 List 返回此 KeyboardFocusManager 的 KeyEventPostProcessor 链。

参数类型为 KeyEventPostProcessor 的 java.awt 中的方法
void | KeyboardFocusManager.addKeyEventPostProcessor(KeyEventPostProcessor processor) 将 KeyEventPostProcessor 添加到此 KeyboardFocusManager 的后处理器链中。
void | KeyboardFocusManager.removeKeyEventPostProcessor(KeyEventPostProcessor processor) 从此 KeyboardFocusManager 的后处理器链中移除以前添加的 KeyEventPostProcessor。

javax.swing 中 KeyEventPostProcessor 的使用

实现 KeyEventPostProcessor 的 javax.swing 中的类
class | DefaultFocusManager 此类已被废弃，用 1.4 focus API 取代。
class | FocusManager 从 1.4 focus API 开始，此类已被废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Label 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Label
的使用

使用 Label 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Label 的使用

参数类型为 Label 的 java.awt 中的方法
protected abstract  java.awt.peer.LabelPeer Toolkit.createLabel(Label target)
使用指定同位体接口创建此工具包的 Label 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Label.AccessibleAWTLabel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Label.AccessibleAWTLabel
的使用

没有 java.awt.Label.AccessibleAWTLabel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.LayoutManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.LayoutManager
的使用

使用 LayoutManager 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

java.awt 中 LayoutManager 的使用

java.awt 中 LayoutManager 的子接口
 interface LayoutManager2
为类定义接口，该类知道如何根据布局约束对象来布置 Container。

实现 LayoutManager 的 java.awt 中的类
class | BorderLayout 这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。
class | CardLayout CardLayout 对象是容器的布局管理器。
class | FlowLayout 流布局用于安排有向流中的组件，这非常类似于段落中的文本行。
class | GridBagLayout GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。
class | GridLayout GridLayout 类是一个布局处理器，它以矩形网格形式对容器的组件进行布置。

返回 LayoutManager 的 java.awt 中的方法
 LayoutManager Container.getLayout()
获取此容器的布局管理器。

参数类型为 LayoutManager 的 java.awt 中的方法
void | ScrollPane.setLayout(LayoutManager mgr) 设置此容器的布局管理器。
void | Container.setLayout(LayoutManager mgr) 设置此容器的布局管理器。

参数类型为 LayoutManager 的 java.awt 中的构造方法
Panel(LayoutManager layout)
创建具有指定布局管理器的新面板。

javax.swing 中 LayoutManager 的使用

实现 LayoutManager 的 javax.swing 中的类
class | BoxLayout 允许垂直或水平布置多个组件的布局管理器。
class | GroupLayout GroupLayout 是一个 LayoutManager，它将组件按层次分组，以决定它们在 Container 中的位置。
protected class | JRootPane.RootLayout 该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | OverlayLayout 要在彼此顶部安排组件的布局管理器。
class | ScrollPaneLayout JScrollPane 使用的布局管理器。
static class | ScrollPaneLayout.UIResource ScrollPaneLayout 的 UI 资源版本。
class | SpringLayout SpringLayout 根据一组约束布置其相关容器的子组件。
class | ViewportLayout JViewport 的默认布局管理器。

返回 LayoutManager 的 javax.swing 中的方法
protected LayoutManager | JViewport.createLayoutManager() 子类可以重写此方法以在该构造方法中安装一个不同布局的管理器（或者为 null）。
protected LayoutManager | JRootPane.createRootLayout() 由构造方法调用以便创建默认的 layoutManager。

参数类型为 LayoutManager 的 javax.swing 中的方法
 void JApplet.setLayout(LayoutManager manager)
设置 LayoutManager。
 void JWindow.setLayout(LayoutManager manager)
设置 LayoutManager。
 void JScrollPane.setLayout(LayoutManager layout)
设置此 JScrollPane 的布局管理器。
 void Box.setLayout(LayoutManager l)
抛出一个 AWTError，因为 Box 只能使用 BoxLayout。
 void JToolBar.setLayout(LayoutManager mgr)
 void JDialog.setLayout(LayoutManager manager)
设置 LayoutManager。
 void AbstractButton.setLayout(LayoutManager mgr)
为此容器设置布局管理器，有关此方法的完整描述，请参阅 Container.setLayout(LayoutManager)。
 void JInternalFrame.setLayout(LayoutManager manager)
确保默认情况下无法设置此组件的布局。
 void JFrame.setLayout(LayoutManager manager)
设置 LayoutManager。

参数类型为 LayoutManager 的 javax.swing 中的构造方法
JPanel(LayoutManager layout)
创建具有指定布局管理器的新缓冲 JPanel。
JPanel(LayoutManager layout, boolean isDoubleBuffered)
创建具有指定布局管理器和缓冲策略的新 JPanel。

javax.swing.plaf.basic 中 LayoutManager 的使用

实现 LayoutManager 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxUI.ComboBoxLayoutManager 此布局管理器处理组合框的“标准”布局。
class | BasicInternalFrameTitlePane.TitlePaneLayout 此类应视为“受保护”内部类。
class | BasicInternalFrameUI.InternalFrameLayout
static class | BasicOptionPaneUI.ButtonAreaLayout ButtonAreaLayout 的行为方式类似于 FlowLayout。
class | BasicScrollBarUI 基本外观的 ScrollBarUI 的实现
protected class | BasicSplitPaneDivider.DividerLayout 用于布置 BasicSplitPaneDivider。
class | BasicSplitPaneUI.BasicHorizontalLayoutManager 具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。
class | BasicSplitPaneUI.BasicVerticalLayoutManager 用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。
class | BasicTabbedPaneUI.TabbedPaneLayout 此类应视为“受保护”内部类。
class | DefaultMenuLayout Popup 菜单和菜单栏的默认布局管理器。

声明为 LayoutManager 的 javax.swing.plaf.basic 中的字段
protected  LayoutManager BasicInternalFrameUI.internalFrameLayout

返回 LayoutManager 的 javax.swing.plaf.basic 中的方法
protected LayoutManager | BasicInternalFrameTitlePane.createLayout()
protected LayoutManager | BasicSpinnerUI.createLayout() 创建管理 JSpinner 的 editor、nextButton 和 previousButton 子级的 LayoutManager。
protected LayoutManager | BasicInternalFrameUI.createLayoutManager()
protected LayoutManager | BasicOptionPaneUI.createLayoutManager()
protected LayoutManager | BasicTabbedPaneUI.createLayoutManager() 由 installUI 调用，用于创建布局管理器对象以管理 JTabbedPane。
protected LayoutManager | BasicComboBoxUI.createLayoutManager() 创建用于管理构成组合框的组件的布局管理器。

javax.swing.plaf.metal 中 LayoutManager 的使用

实现 LayoutManager 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxUI.MetalComboBoxLayoutManager 此内部类因编译器故障而被标记为 "public"。
class | MetalScrollBarUI ScrollBarUI 的 Metal 外观实现
class | MetalTabbedPaneUI.TabbedPaneLayout 此内部类由于编译器故障而被标记为 "public"。

返回 LayoutManager 的 javax.swing.plaf.metal 中的方法
protected LayoutManager | MetalInternalFrameTitlePane.createLayout()
protected LayoutManager | MetalTabbedPaneUI.createLayoutManager()
protected LayoutManager | MetalComboBoxUI.createLayoutManager()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.LayoutManager2 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.LayoutManager2
的使用

使用 LayoutManager2 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 LayoutManager2 的使用

实现 LayoutManager2 的 java.awt 中的类
class | BorderLayout 这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。
class | CardLayout CardLayout 对象是容器的布局管理器。
class | GridBagLayout GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。

javax.swing 中 LayoutManager2 的使用

实现 LayoutManager2 的 javax.swing 中的类
class | BoxLayout 允许垂直或水平布置多个组件的布局管理器。
class | GroupLayout GroupLayout 是一个 LayoutManager，它将组件按层次分组，以决定它们在 Container 中的位置。
protected class | JRootPane.RootLayout 该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。
class | OverlayLayout 要在彼此顶部安排组件的布局管理器。
class | SpringLayout SpringLayout 根据一组约束布置其相关容器的子组件。

javax.swing.plaf.basic 中 LayoutManager2 的使用

实现 LayoutManager2 的 javax.swing.plaf.basic 中的类
class | BasicSplitPaneUI.BasicHorizontalLayoutManager 具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。
class | BasicSplitPaneUI.BasicVerticalLayoutManager 用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。
class | DefaultMenuLayout Popup 菜单和菜单栏的默认布局管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.LinearGradientPaint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.LinearGradientPaint
的使用

没有 java.awt.LinearGradientPaint 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.List 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.List
的使用

使用 List 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 List 的使用

参数类型为 List 的 java.awt 中的方法
protected abstract  java.awt.peer.ListPeer Toolkit.createList(List target)
使用指定同位体接口创建此工具包的 List 实现。

参数类型为 List 的 java.awt 中的构造方法
List.AccessibleAWTList.AccessibleAWTListChild(List parent, int indexInParent)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.List.AccessibleAWTList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.List.AccessibleAWTList
的使用

没有 java.awt.List.AccessibleAWTList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild
的使用

没有 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MediaTracker 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MediaTracker
的使用

使用 MediaTracker 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 MediaTracker 的使用

声明为 MediaTracker 的 javax.swing 中的字段
protected static MediaTracker ImageIcon.tracker

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Menu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Menu
的使用

使用 Menu 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Menu 的使用

java.awt 中 Menu 的子类
 class PopupMenu
此类实现能够在组件中的指定位置上动态弹出的菜单。

返回 Menu 的 java.awt 中的方法
Menu | MenuBar.add(Menu m) 将指定的菜单添加到菜单栏。
Menu | MenuBar.getHelpMenu() 获取该菜单栏上的帮助菜单。
Menu | MenuBar.getMenu(int i) 获取指定的菜单。

参数类型为 Menu 的 java.awt 中的方法
Menu | MenuBar.add(Menu m) 将指定的菜单添加到菜单栏。
protected abstract java.awt.peer.MenuPeer | Toolkit.createMenu(Menu target) 使用指定同位体接口创建此工具包的 Menu 实现。
void | MenuBar.setHelpMenu(Menu m) 将指定的菜单设置为此菜单栏的帮助菜单。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Menu.AccessibleAWTMenu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Menu.AccessibleAWTMenu
的使用

使用 Menu.AccessibleAWTMenu 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Menu.AccessibleAWTMenu 的使用

java.awt 中 Menu.AccessibleAWTMenu 的子类
protected  class PopupMenu.AccessibleAWTPopupMenu
用于为可访问性提供默认支持的 PopupMenu 的内部类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MenuBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuBar
的使用

使用 MenuBar 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuBar 的使用

返回 MenuBar 的 java.awt 中的方法
 MenuBar Frame.getMenuBar()
获取此窗体的菜单栏。

参数类型为 MenuBar 的 java.awt 中的方法
protected abstract java.awt.peer.MenuBarPeer | Toolkit.createMenuBar(MenuBar target) 使用指定同位体接口创建此工具包的 MenuBar 实现。
void | Frame.setMenuBar(MenuBar mb) 将此窗体的菜单栏设置为指定的菜单栏。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MenuBar.AccessibleAWTMenuBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuBar.AccessibleAWTMenuBar
的使用

没有 java.awt.MenuBar.AccessibleAWTMenuBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MenuComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuComponent
的使用

使用 MenuComponent 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuComponent 的使用

java.awt 中 MenuComponent 的子类
class | CheckboxMenuItem 此类表示一个可包括在菜单中的复选框。
class | Menu Menu 对象是从菜单栏部署的下拉式菜单组件。
class | MenuBar MenuBar 类封装绑定到框架的菜单栏的平台概念。
class | MenuItem 菜单中的所有项必须属于类 MenuItem 或其子类之一。
class | PopupMenu 此类实现能够在组件中的指定位置上动态弹出的菜单。

参数类型为 MenuComponent 的 java.awt 中的方法
void | MenuBar.remove(MenuComponent m) 从此菜单栏移除指定的菜单组件。
void | Menu.remove(MenuComponent item) 从此菜单移除指定的菜单项。
void | Frame.remove(MenuComponent m) 从此窗体移除指定的菜单栏。
void | Component.remove(MenuComponent popup) 从组件移除指定的弹出菜单。
void | MenuContainer.remove(MenuComponent comp)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MenuComponent.AccessibleAWTMenuComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuComponent.AccessibleAWTMenuComponent
的使用

使用 MenuComponent.AccessibleAWTMenuComponent 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuComponent.AccessibleAWTMenuComponent 的使用

java.awt 中 MenuComponent.AccessibleAWTMenuComponent 的子类
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuBar.AccessibleAWTMenuBar 菜单栏的内部类，用于为可访问性提供默认支持。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.MenuContainer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.MenuContainer
的使用

使用 MenuContainer 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 MenuContainer 的使用

实现 MenuContainer 的 java.applet 中的类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 MenuContainer 的使用

实现 MenuContainer 的 java.awt 中的类
class | Button 此类创建一个标签按钮。
class | Canvas Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
class | Choice Choice 类表示一个弹出式选择菜单。
class | Component component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
class | Container 一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。
class | Label Label 对象是一个可在容器中放置文本的组件。
class | List List 组件为用户提供了一个可滚动的文本项列表。
class | Menu Menu 对象是从菜单栏部署的下拉式菜单组件。
class | MenuBar MenuBar 类封装绑定到框架的菜单栏的平台概念。
class | Panel Panel 是最简单的容器类。
class | PopupMenu 此类实现能够在组件中的指定位置上动态弹出的菜单。
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
class | TextArea TextArea 对象是显示文本的多行区域。
class | TextComponent TextComponent 类是所有允许编辑文本的组件的超类。
class | TextField TextField 对象是允许编辑单行文本的文本组件。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。

返回 MenuContainer 的 java.awt 中的方法
MenuContainer | PopupMenu.getParent() 返回此菜单组件的父容器。
MenuContainer | MenuComponent.getParent() 返回此菜单组件的父容器。

javax.swing 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing 中的类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JComponent 该类是除顶层容器外所有 Swing 组件的基类。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JDialog 创建对话框窗口的主要类。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

javax.swing.colorchooser 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.colorchooser 中的类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.plaf.basic 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.plaf.basic 中的类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
protected class | BasicToolBarUI.DragWindow

javax.swing.plaf.metal 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

javax.swing.table 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.table 中的类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。

javax.swing.text 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.text 中的类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

javax.swing.tree 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.tree 中的类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
class | DefaultTreeCellRenderer 显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuItem
的使用

使用 MenuItem 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuItem 的使用

java.awt 中 MenuItem 的子类
class | CheckboxMenuItem 此类表示一个可包括在菜单中的复选框。
class | Menu Menu 对象是从菜单栏部署的下拉式菜单组件。
class | PopupMenu 此类实现能够在组件中的指定位置上动态弹出的菜单。

返回 MenuItem 的 java.awt 中的方法
MenuItem | Menu.add(MenuItem mi) 将指定的菜单项添加到此菜单。
MenuItem | Menu.getItem(int index) 获取此菜单的指定索引处的项。
MenuItem | MenuBar.getShortcutMenuItem(MenuShortcut s) 获取与指定 MenuShortcut 对象关联的 MenuItem 的实例，如果此菜单栏正在管理的菜单项均与指定的菜单快捷方式无关联，则为 null。

参数类型为 MenuItem 的 java.awt 中的方法
MenuItem | Menu.add(MenuItem mi) 将指定的菜单项添加到此菜单。
protected abstract java.awt.peer.MenuItemPeer | Toolkit.createMenuItem(MenuItem target) 使用指定同位体接口创建此工具包的 MenuItem 实现。
void | Menu.insert(MenuItem menuitem, int index) 将菜单项插入到此菜单的指定位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MenuItem.AccessibleAWTMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuItem.AccessibleAWTMenuItem
的使用

使用 MenuItem.AccessibleAWTMenuItem 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuItem.AccessibleAWTMenuItem 的使用

java.awt 中 MenuItem.AccessibleAWTMenuItem 的子类
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MenuShortcut 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuShortcut
的使用

使用 MenuShortcut 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuShortcut 的使用

返回 MenuShortcut 的 java.awt 中的方法
 MenuShortcut MenuItem.getShortcut()
获取与此菜单项关联的 MenuShortcut 对象。

返回变量类型为 MenuShortcut 的类型的 java.awt 中的方法
 Enumeration<MenuShortcut> MenuBar.shortcuts()
获取此菜单栏正在管理的所有菜单快捷方式的枚举。

参数类型为 MenuShortcut 的 java.awt 中的方法
void | MenuBar.deleteShortcut(MenuShortcut s) 删除指定的菜单快捷方式。
boolean | MenuShortcut.equals(MenuShortcut s) 返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。
MenuItem | MenuBar.getShortcutMenuItem(MenuShortcut s) 获取与指定 MenuShortcut 对象关联的 MenuItem 的实例，如果此菜单栏正在管理的菜单项均与指定的菜单快捷方式无关联，则为 null。
void | MenuItem.setShortcut(MenuShortcut s) 设置与此菜单项关联的 MenuShortcut 对象。

参数类型为 MenuShortcut 的 java.awt 中的构造方法
MenuItem(String label, MenuShortcut s)
创建具有关联的键盘快捷方式的菜单项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MouseInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MouseInfo
的使用

没有 java.awt.MouseInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MultipleGradientPaint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MultipleGradientPaint
的使用

使用 MultipleGradientPaint 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MultipleGradientPaint 的使用

java.awt 中 MultipleGradientPaint 的子类
class | LinearGradientPaint LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。
class | RadialGradientPaint RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MultipleGradientPaint.ColorSpaceType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MultipleGradientPaint.ColorSpaceType
的使用

使用 MultipleGradientPaint.ColorSpaceType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MultipleGradientPaint.ColorSpaceType 的使用

返回 MultipleGradientPaint.ColorSpaceType 的 java.awt 中的方法
MultipleGradientPaint.ColorSpaceType | MultipleGradientPaint.getColorSpace() 返回指定用于插值的颜色空间的枚举类型。
static MultipleGradientPaint.ColorSpaceType | MultipleGradientPaint.ColorSpaceType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MultipleGradientPaint.ColorSpaceType[] | MultipleGradientPaint.ColorSpaceType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 MultipleGradientPaint.ColorSpaceType 的 java.awt 中的构造方法
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.MultipleGradientPaint.CycleMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MultipleGradientPaint.CycleMethod
的使用

使用 MultipleGradientPaint.CycleMethod 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MultipleGradientPaint.CycleMethod 的使用

返回 MultipleGradientPaint.CycleMethod 的 java.awt 中的方法
MultipleGradientPaint.CycleMethod | MultipleGradientPaint.getCycleMethod() 返回指定循环行为的枚举类型。
static MultipleGradientPaint.CycleMethod | MultipleGradientPaint.CycleMethod.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MultipleGradientPaint.CycleMethod[] | MultipleGradientPaint.CycleMethod.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 MultipleGradientPaint.CycleMethod 的 java.awt 中的构造方法
LinearGradientPaint(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float fx, float fy, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。
RadialGradientPaint(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.PageAttributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes
的使用

使用 PageAttributes 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes 的使用

参数类型为 PageAttributes 的 java.awt 中的方法
PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
void | PageAttributes.set(PageAttributes obj) 将此 PageAttributes 的所有属性设置为与 obj 的属性相同的值。

参数类型为 PageAttributes 的 java.awt 中的构造方法
PageAttributes(PageAttributes obj)
构造一个 PageAttributes 实例，它是所提供的 PageAttributes 的副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.PageAttributes.ColorType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes.ColorType
的使用

使用 PageAttributes.ColorType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes.ColorType 的使用

声明为 PageAttributes.ColorType 的 java.awt 中的字段
static PageAttributes.ColorType | PageAttributes.ColorType.COLOR 用来指定颜色打印的 ColorType 实例。
static PageAttributes.ColorType | PageAttributes.ColorType.MONOCHROME 用来指定单色打印的 ColorType 实例。

返回 PageAttributes.ColorType 的 java.awt 中的方法
 PageAttributes.ColorType PageAttributes.getColor()
返回使用这些属性的页面是以彩色呈现，还是以单色呈现。

参数类型为 PageAttributes.ColorType 的 java.awt 中的方法
 void PageAttributes.setColor(PageAttributes.ColorType color)
指定使用这些属性的页面以彩色呈现，还是以单色呈现。

参数类型为 PageAttributes.ColorType 的 java.awt 中的构造方法
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.PageAttributes.MediaType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes.MediaType
的使用

使用 PageAttributes.MediaType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes.MediaType 的使用

声明为 PageAttributes.MediaType 的 java.awt 中的字段
static PageAttributes.MediaType | PageAttributes.MediaType.A Engineering A (8 1/2 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.A0 ISO_A0 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A1 ISO_A1 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A10 ISO_A10 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A2 ISO_A2 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A3 ISO_A3 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A4 ISO_A4 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A5 ISO_A5 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A6 ISO_A6 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A7 ISO_A7 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A8 ISO_A8 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A9 ISO_A9 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B Engineering B (11 x 17 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.B0 ISO_B0 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B1 ISO_B1 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B10 ISO_B10 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B2 ISO_B2 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B3 ISO_B3 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B4 ISO_B4 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B5 ISO_B5 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B6 ISO_B6 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B7 ISO_B7 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B8 ISO_B8 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B9 ISO_B9 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C Engineering C (17 x 22 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.C0 ISO_C0 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C1 ISO_C1 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C10 ISO_C10 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C2 ISO_C2 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C3 ISO_C3 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C4 ISO_C4 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C5 ISO_C5 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C6 ISO_C6 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C7 ISO_C7 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C8 ISO_C8 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C9 ISO_C9 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.D Engineering D (22 x 34 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.E Engineering E (34 x 44 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_10 NA_NUMBER_10_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_10X13 NA_10X13_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_10X14 NA_10X14_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_10X15 NA_10X15_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_11 NA_NUMBER_11_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_12 NA_NUMBER_12_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_14 NA_NUMBER_14_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_6X9 NA_6X9_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_7X9 NA_7X9_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_9 NA_NUMBER_9_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_9X11 NA_9X11_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_9X12 NA_9X12_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_INVITE INVITE_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_ITALY ITALY_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_MONARCH MONARCH_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_PERSONAL PERSONAL_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.EXECUTIVE Executive (7 1/4 x 10 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.FOLIO Folio (8 1/2 x 13 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.INVITE INVITE_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.INVITE_ENVELOPE Invitation Envelope (220 x 220 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.INVOICE Invoice (5 1/2 x 8 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_2A0 ISO/DIN & JIS 2A0 (1189 x 1682 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_4A0 ISO/DIN & JIS 4A0 ( 1682 x 2378 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A0 ISO/DIN & JIS A0 (841 x 1189 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A1 ISO/DIN & JIS A1 (594 x 841 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A10 ISO/DIN & JIS A10 (26 x 37 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A2 ISO/DIN & JIS A2 (420 x 594 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A3 ISO/DIN & JIS A3 (297 x 420 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A4 ISO/DIN & JIS A4 (210 x 297 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A5 ISO/DIN & JIS A5 (148 x 210 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A6 ISO/DIN & JIS A6 (105 x 148 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A7 ISO/DIN & JIS A7 (74 x 105 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A8 ISO/DIN & JIS A8 (52 x 74 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A9 ISO/DIN & JIS A9 (37 x 52 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B0 ISO/DIN B0 (1000 x 1414 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B1 ISO/DIN B1 ( 707 x 1000 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B10 ISO/DIN B10 (31 x 44 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B2 ISO/DIN B2 (500 x 707 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B3 ISO/DIN B3 (353 x 500 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B4 ISO/DIN B4 (250 x 353 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B4_ENVELOPE ISO_B4 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B5 ISO/DIN B5 (176 x 250 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B5_ENVELOPE ISO_B5 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B6 ISO/DIN B6 (125 x 176 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B7 ISO/DIN B7 (88 x 125 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B8 ISO/DIN B8 (62 x 88 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B9 ISO/DIN B9 (44 x 62 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C0 ISO/DIN C0 (917 x 1297 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C0_ENVELOPE ISO_C0 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C1 ISO/DIN C1 (648 x 917 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C1_ENVELOPE ISO_C1 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C10 ISO/DIN C10 (28 x 40 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C10_ENVELOPE ISO_C10 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C2 ISO/DIN C2 (458 x 648 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C2_ENVELOPE ISO_C2 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C3 ISO/DIN C3 (324 x 458 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C3_ENVELOPE ISO_C3 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C4 ISO/DIN C4 (229 x 324 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C4_ENVELOPE ISO_C4 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C5 ISO/DIN C5 (162 x 229 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C5_ENVELOPE ISO_C5 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C6 ISO/DIN C6 (114 x 162 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C6_ENVELOPE ISO_C6 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C7 ISO/DIN C7 (81 x 114 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C7_ENVELOPE ISO_C7 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C8 ISO/DIN C8 (57 x 81 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C8_ENVELOPE ISO_C8 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C9 ISO/DIN C9 (40 x 57 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C9_ENVELOPE ISO_C9 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_DESIGNATED_LONG ISO Designated Long (110 x 220 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_DESIGNATED_LONG_ENVELOPE ISO_DESIGNATED_LONG 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ITALY ITALY_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ITALY_ENVELOPE Italy Envelope (110 x 230 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B0 JIS B0 (1030 x 1456 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B1 JIS B1 (728 x 1030 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B10 JIS B10 (32 x 45 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B2 JIS B2 (515 x 728 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B3 JIS B3 (364 x 515 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B4 JIS B4 (257 x 364 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B5 JIS B5 (182 x 257 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B6 JIS B6 (128 x 182 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B7 JIS B7 (91 x 128 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B8 JIS B8 (64 x 91 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B9 JIS B9 (45 x 64 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.LEDGER Ledger (11 x 17 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.LEGAL NA_LEGAL 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.LETTER NA_LETTER 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.MONARCH MONARCH_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.MONARCH_ENVELOPE Monarch Envelope (3 7/8 x 7 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_10X13_ENVELOPE North American (10 x 13 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_10X14_ENVELOPE North American (10 x 14 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_10X15_ENVELOPE North American (10 x 15 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_6X9_ENVELOPE North American (6 x 9 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_7X9_ENVELOPE North American (7 x 9 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_9X11_ENVELOPE North American (9 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_9X12_ENVELOPE North American (9 x 12 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_LEGAL North American Legal (8 1/2 x 14 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_LETTER North American Letter (8 1/2 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_NUMBER_10_ENVELOPE North American #10 Business Envelope (4 1/8 x 9 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_NUMBER_11_ENVELOPE North American #11 Business Envelope (4 1/2 x 10 3/8 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_NUMBER_12_ENVELOPE North American #12 Business Envelope (4 3/4 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_NUMBER_14_ENVELOPE North American #14 Business Envelope (5 x 11 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_NUMBER_9_ENVELOPE North American #9 Business Envelope (3 7/8 x 8 7/8 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NOTE NA_LETTER 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.PERSONAL PERSONAL_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.PERSONAL_ENVELOPE 6 3/4 envelope (3 5/8 x 6 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.QUARTO Quarto (215 x 275 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.STATEMENT INVOICE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.TABLOID LEDGER 的别名。

返回 PageAttributes.MediaType 的 java.awt 中的方法
 PageAttributes.MediaType PageAttributes.getMedia()
返回使用这些属性的页面的纸张尺寸。

参数类型为 PageAttributes.MediaType 的 java.awt 中的方法
 void PageAttributes.setMedia(PageAttributes.MediaType media)
指定使用这些属性的页面所需的纸张尺寸。

参数类型为 PageAttributes.MediaType 的 java.awt 中的构造方法
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.PageAttributes.OrientationRequestedType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes.OrientationRequestedType
的使用

使用 PageAttributes.OrientationRequestedType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes.OrientationRequestedType 的使用

声明为 PageAttributes.OrientationRequestedType 的 java.awt 中的字段
static PageAttributes.OrientationRequestedType | PageAttributes.OrientationRequestedType.LANDSCAPE 用于指定横向方向的 OrientationRequestedType 实例。
static PageAttributes.OrientationRequestedType | PageAttributes.OrientationRequestedType.PORTRAIT 用于指定纵向方向的 OrientationRequestedType 实例。

返回 PageAttributes.OrientationRequestedType 的 java.awt 中的方法
 PageAttributes.OrientationRequestedType PageAttributes.getOrientationRequested()
返回使用这些属性的页面的打印方向。

参数类型为 PageAttributes.OrientationRequestedType 的 java.awt 中的方法
 void PageAttributes.setOrientationRequested(PageAttributes.OrientationRequestedType orientationRequested)
指定使用这些属性的页面的打印方向。

参数类型为 PageAttributes.OrientationRequestedType 的 java.awt 中的构造方法
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.PageAttributes.OriginType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes.OriginType
的使用

使用 PageAttributes.OriginType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes.OriginType 的使用

声明为 PageAttributes.OriginType 的 java.awt 中的字段
static PageAttributes.OriginType | PageAttributes.OriginType.PHYSICAL 用于指定物理原点的 OriginType 实例。
static PageAttributes.OriginType | PageAttributes.OriginType.PRINTABLE 用于指定可打印原点的 OriginType 实例。

返回 PageAttributes.OriginType 的 java.awt 中的方法
 PageAttributes.OriginType PageAttributes.getOrigin()
返回在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。

参数类型为 PageAttributes.OriginType 的 java.awt 中的方法
 void PageAttributes.setOrigin(PageAttributes.OriginType origin)
指定在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。

参数类型为 PageAttributes.OriginType 的 java.awt 中的构造方法
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.PageAttributes.PrintQualityType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes.PrintQualityType
的使用

使用 PageAttributes.PrintQualityType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes.PrintQualityType 的使用

声明为 PageAttributes.PrintQualityType 的 java.awt 中的字段
static PageAttributes.PrintQualityType | PageAttributes.PrintQualityType.DRAFT 用于指定草稿打印质量的 PrintQualityType 实例。
static PageAttributes.PrintQualityType | PageAttributes.PrintQualityType.HIGH 用于指定高打印质量的 PrintQualityType 实例。
static PageAttributes.PrintQualityType | PageAttributes.PrintQualityType.NORMAL 用于指定标准打印质量的 PrintQualityType 实例。

返回 PageAttributes.PrintQualityType 的 java.awt 中的方法
 PageAttributes.PrintQualityType PageAttributes.getPrintQuality()
返回使用这些属性的页面的打印质量。

参数类型为 PageAttributes.PrintQualityType 的 java.awt 中的方法
 void PageAttributes.setPrintQuality(PageAttributes.PrintQualityType printQuality)
指定使用这些属性的页面的打印质量。

参数类型为 PageAttributes.PrintQualityType 的 java.awt 中的构造方法
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.Paint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Paint
的使用

使用 Paint 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

java.awt 中 Paint 的使用

实现 Paint 的 java.awt 中的类
class | Color Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
class | GradientPaint GradientPaint 类提供了使用线性颜色渐变模式填充 Shape 的方法。
class | LinearGradientPaint LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。
class | MultipleGradientPaint 这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。
class | RadialGradientPaint RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。
class | SystemColor 封装表示系统中本机 GUI 对象颜色的象征性颜色的类。
class | TexturePaint TexturePaint 类提供一种用被指定为 BufferedImage 的纹理填充 Shape 的方式。

返回 Paint 的 java.awt 中的方法
abstract  Paint Graphics2D.getPaint()
返回 Graphics2D 上下文中的当前 Paint

参数类型为 Paint 的 java.awt 中的方法
abstract  void Graphics2D.setPaint(Paint paint)
为 Graphics2D 上下文设置 Paint 属性。

javax.swing.plaf 中 Paint 的使用

实现 Paint 的 javax.swing.plaf 中的类
 class ColorUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.PaintContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.PaintContext
的使用

使用 PaintContext 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PaintContext 的使用

返回 PaintContext 的 java.awt 中的方法
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Panel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Panel
的使用

使用 Panel 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.applet 中 Panel 的使用

java.applet 中 Panel 的子类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 Panel 的使用

参数类型为 Panel 的 java.awt 中的方法
protected abstract  java.awt.peer.PanelPeer Toolkit.createPanel(Panel target)
使用指定同位体接口创建此工具包的 Panel 实现。

javax.swing 中 Panel 的使用

javax.swing 中 Panel 的子类
 class JApplet
java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Panel.AccessibleAWTPanel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Panel.AccessibleAWTPanel
的使用

使用 Panel.AccessibleAWTPanel 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.applet 中 Panel.AccessibleAWTPanel 的使用

java.applet 中 Panel.AccessibleAWTPanel 的子类
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

javax.swing 中 Panel.AccessibleAWTPanel 的使用

javax.swing 中 Panel.AccessibleAWTPanel 的子类
protected  class JApplet.AccessibleJApplet
此类实现对 JApplet 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Point 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Point
的使用

使用 Point 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.image | 提供创建和修改图像的各种类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.imageio | Java Image I/O API 的主要包。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Point 的使用

返回 Point 的 java.awt 中的方法
 Point GraphicsEnvironment.getCenterPoint()
返回 Windows 应居中的点。
 Point GridBagLayout.getLayoutOrigin()
在目标容器的图形坐标空间确定布局区域的原点。
 Point List.AccessibleAWTList.AccessibleAWTListChild.getLocation()
获取此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
 Point PointerInfo.getLocation()
返回在屏幕上表示指针坐标的 Point。
 Point MenuComponent.AccessibleAWTMenuComponent.getLocation()
以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
 Point Point.getLocation()
返回此点的位置。
 Point Rectangle.getLocation()
返回此 Rectangle 的位置。
 Point Component.getLocation()
获取组件的位置，形式是指定组件左上角的一个点。
 Point Component.AccessibleAWTComponent.getLocation()
通过用一个点指定该对象的左上角在屏幕坐标空间中的位置的形式，获取此对象相对于父对象的位置。
 Point Component.getLocation(Point rv)
将组件的 x，y 原点存储到“返回值” rv 中并返回 rv。
 Point List.AccessibleAWTList.AccessibleAWTListChild.getLocationOnScreen()
返回对象在屏幕上的位置。
 Point MenuComponent.AccessibleAWTMenuComponent.getLocationOnScreen()
返回对象在屏幕上的位置。
 Point Component.getLocationOnScreen()
获取组件的位置，形式是一个指定屏幕坐标空间中组件左上角的一个点。
 Point Component.AccessibleAWTComponent.getLocationOnScreen()
返回对象在屏幕上的位置。
 Point Component.getMousePosition()
如果此 Component 正好位于鼠标指针下，则返回鼠标指针在该 Component 的坐标空间中的位置；否则返回 null。
 Point Container.getMousePosition(boolean allowChildren)
如果 Container 位于鼠标指针下，则返回鼠标指针在此 Container 的坐标中的位置，否则返回 null。
 Point ScrollPane.getScrollPosition()
返回子组件中的当前 x,y 位置，子组件显示在滚动窗格视口的 0,0 位置。
 Point Component.location()
已过时。 从 JDK version 1.1 开始，由 getLocation() 取代。
 Point GridBagLayout.location(int x, int y)
确定在布局网格中哪个单元包含由 (x, y) 指定的点。

参数类型为 Point 的 java.awt 中的方法
void | Rectangle.add(Point pt) 将指定的 Point 添加到此 Rectangle 的边界。
boolean | List.AccessibleAWTList.AccessibleAWTListChild.contains(Point p) 检查指定点是否位于此对象的界限中，其中该点的 X 坐标和 Y 坐标是相对于对象的定义的。
boolean | Polygon.contains(Point p) 确定指定的 Point 是否位于此 Polygon 的内部。
boolean | MenuComponent.AccessibleAWTMenuComponent.contains(Point p) 检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系相关。
boolean | Rectangle.contains(Point p) 检查此 Rectangle 是否包含指定的 Point。
boolean | Component.contains(Point p) 检查组件是否“包含”指定的点，其中该点的 x 和 y 坐标是相对于此组件的坐标系定义的。
boolean | Component.AccessibleAWTComponent.contains(Point p) 检查指定的点是否在此对象的边界内，该点的 x 坐标和 y 坐标是相对于该对象的坐标系来定义的。
Cursor | Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name) 创建一个新的自定义光标对象。
Component | Container.findComponentAt(Point p) 对包含指定点的可视子组件进行定位。
Accessible | List.AccessibleAWTList.getAccessibleAt(Point p) 返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
Accessible | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleAt(Point p) 如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回该子级。
Accessible | MenuComponent.AccessibleAWTMenuComponent.getAccessibleAt(Point p) 返回本地坐标 Point 包含的 Accessible 子对象（如果存在）。
Accessible | Container.AccessibleAWTContainer.getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | Component.AccessibleAWTComponent.getAccessibleAt(Point p) 返回包含在局部坐标 Point 上的 Accessible 子对象（如果存在这样的对象）。
Component | Container.getComponentAt(Point p) 获取包含指定点的组件。
Component | Component.getComponentAt(Point p) 返回包含指定点的组件或子组件。
int | TextComponent.AccessibleAWTTextComponent.getIndexAtPoint(Point p) 给出本地坐标中的一个点，返回该 Point 下的、从零开始的字符索引。
Point | Component.getLocation(Point rv) 将组件的 x，y 原点存储到“返回值” rv 中并返回 rv。
void | List.AccessibleAWTList.AccessibleAWTListChild.setLocation(Point p) 设置对象相对于父级的位置。
void | MenuComponent.AccessibleAWTMenuComponent.setLocation(Point p) 设置该对象相对于父对象的位置。
void | Point.setLocation(Point p) 将点的位置设为指定位置。
void | Rectangle.setLocation(Point p) 将此 Rectangle 移动到指定位置。
void | Component.setLocation(Point p) 将组件移到新位置。
void | Component.AccessibleAWTComponent.setLocation(Point p) 设置对象相对父对象的位置。
void | ScrollPane.setScrollPosition(Point p) 滚动到子组件中的指定位置。

参数类型为 Point 的 java.awt 中的构造方法
Point(Point p)
构造并初始化一个与指定的 Point 对象具有相同位置的点。
Rectangle(Point p)
构造一个新的 Rectangle，其左上角是指定的 Point，其宽度和高度均为 0。
Rectangle(Point p, Dimension d)
构造一个新的 Rectangle，其左上角由 Point 参数指定，其宽度和高度由 Dimension 参数指定。

java.awt.dnd 中 Point 的使用

返回 Point 的 java.awt.dnd 中的方法
Point | DragGestureEvent.getDragOrigin() 返回 Component 坐标中开始拖动位置的 Point。
Point | DragSourceEvent.getLocation() 此方法返回一个 Point，指示事件发生时光标在屏幕坐标中的位置，如果没有为此事件指定光标位置，则返回 null。
Point | DropTargetDragEvent.getLocation() 此方法返回一个指示 Component 坐标中 Cursor 当前位置的 Point。
Point | DropTargetDropEvent.getLocation() 此方法返回一个 Point，指示 Component 坐标中 Cursor 的当前位置。

参数类型为 Point 的 java.awt.dnd 中的方法
void | Autoscroll.autoscroll(Point cursorLocn) 通知 Component 自动滚动
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
protected DropTarget.DropTargetAutoScroller | DropTarget.createDropTargetAutoScroller(Component c, Point p) 创建一个嵌入式自动滚动条
protected void | DragGestureRecognizer.fireDragGestureRecognized(int dragAction, Point p) 通知 DragGestureListener 已发生了 Drag 和 Drop 开始动作。
protected void | DropTarget.initializeAutoscrolling(Point p) 初始化自动滚动
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
protected void | DropTarget.updateAutoscroll(Point dragCursorLocn) 使用当前的光标位置更新自动滚动
protected void | DropTarget.DropTargetAutoScroller.updateLocation(Point newLocn) 导致发生自动滚动

参数类型为 Point 的 java.awt.dnd 中的构造方法
DragGestureEvent(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。
DropTarget.DropTargetAutoScroller(Component c, Point p)
构造一个 DropTargetAutoScroller
DropTargetDragEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 "Drag" Cursor 热点的位置、用户 drop 操作和源 drop 操作的情况下，构造一个 DropTargetDragEvent。
DropTargetDropEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作和当前受源对象支持的操作集合的情况下，构造一个 DropTargetDropEvent。
DropTargetDropEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions, boolean isLocal)
在给出此操作的 DropTargetContext、Component 的坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作、当前受源对象支持的操作集合，以及一个指示源对象与目标对象是否在同一 JVM 中的 boolean 值的情况下，构造一个 DropTargetEvent。

java.awt.event 中 Point 的使用

返回 Point 的 java.awt.event 中的方法
Point | MouseEvent.getLocationOnScreen() 返回事件的绝对 x, y 坐标。
Point | MouseEvent.getPoint() 返回事件相对于源组件的 x, y 坐标。

java.awt.image 中 Point 的使用

返回 Point 的 java.awt.image 中的方法
Point[] | BufferedImage.getWritableTileIndices() 返回 Point 对象的数组，它指示为写入签出了哪些 tile。
Point[] | WritableRenderedImage.getWritableTileIndices() 返回 Point 对象的数组，它指示为写入签出了哪些 tile。

参数类型为 Point 的 java.awt.image 中的方法
static WritableRaster | Raster.createBandedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | Raster.createBandedRaster(int dataType, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | Raster.createBandedRaster(int dataType, int w, int h, int bands, Point location) 根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
static WritableRaster | Raster.createInterleavedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | Raster.createInterleavedRaster(int dataType, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | Raster.createInterleavedRaster(int dataType, int w, int h, int bands, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location) 根据 MultiPixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度和每像素位数的 Raster。
static WritableRaster | Raster.createPackedRaster(int dataType, int w, int h, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 掩码的 Raster。
static WritableRaster | Raster.createPackedRaster(int dataType, int w, int h, int bands, int bitsPerBand, Point location) 根据打包的 SampleModel 创建一个具有指定数据类型、宽度、高度、band 数和每 band 位数的 Raster。
static Raster | Raster.createRaster(SampleModel sm, DataBuffer db, Point location) 创建具有指定 SampleModel 和 DataBuffer 的 Raster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, DataBuffer db, Point location) 创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, Point location) 创建一个具有指定 SampleModel 的 WritableRaster。

参数类型为 Point 的 java.awt.image 中的构造方法
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构建具有给定 SampleModel 和 DataBuffer 的 Raster。
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
Raster(SampleModel sampleModel, Point origin)
构建具有给定 SampleModel 的 Raster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构造具有给定 SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。
WritableRaster(SampleModel sampleModel, Point origin)
构造具有给定 SampleModel 的 WritableRaster。

javax.accessibility 中 Point 的使用

返回 Point 的 javax.accessibility 中的方法
Point | AccessibleComponent.getLocation() 获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
Point | AccessibleComponent.getLocationOnScreen() 返回对象在屏幕上的位置。

参数类型为 Point 的 javax.accessibility 中的方法
boolean | AccessibleComponent.contains(Point p) 检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
Accessible | AccessibleComponent.getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
int | AccessibleText.getIndexAtPoint(Point p) 给定本地坐标中的一点，返回在该点下的字符从 0 开始的索引。
void | AccessibleComponent.setLocation(Point p) 设置对象相对于父级的位置。

javax.imageio 中 Point 的使用

声明为 Point 的 javax.imageio 中的字段
protected  Point IIOParam.destinationOffset
目标区域中的偏移量，应将左上部解码像素置于此处。

返回 Point 的 javax.imageio 中的方法
 Point IIOParam.getDestinationOffset()
返回目标图像中的偏移量，像素将置于该处。

参数类型为 Point 的 javax.imageio 中的方法
 void IIOParam.setDestinationOffset(Point destinationOffset)
指定目标图像中的偏移量。

javax.swing 中 Point 的使用

声明为 Point 的 javax.swing 中的字段
protected  Point JViewport.lastPaintPosition
我们绘制的最后一个 viewPosition，因此我们知道有多少有效的后备存储图像。

返回 Point 的 javax.swing 中的方法
static Point | SwingUtilities.convertPoint(Component source, int x, int y, Component destination) 将 source 坐标系统中的点 (x,y) 转换到 destination 坐标系统。
static Point | SwingUtilities.convertPoint(Component source, Point aPoint, Component destination) 将 source 坐标系统中的 aPoint 转换到 destination 坐标系统。
Point | TransferHandler.DropLocation.getDropPoint() 返回放置点，表示组件内鼠标的当前位置。
Point | JTree.AccessibleJTree.AccessibleJTreeNode.getLocation()
Point | JTable.AccessibleJTable.AccessibleJTableCell.getLocation() 以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
Point | JList.AccessibleJList.AccessibleJListChild.getLocation()
Point | JComponent.getLocation(Point rv) 将此组件的 x，y 原点存储到“返回值”rv 中并返回 rv。
protected Point | JTree.AccessibleJTree.AccessibleJTreeNode.getLocationInJTree()
Point | JTree.AccessibleJTree.AccessibleJTreeNode.getLocationOnScreen()
Point | JTable.AccessibleJTable.AccessibleJTableCell.getLocationOnScreen() 返回对象在屏幕上的位置。
Point | JList.AccessibleJList.AccessibleJListChild.getLocationOnScreen()
Point | JComponent.getPopupLocation(MouseEvent event) 返回在此组件坐标系统中显示弹出式菜单的首选位置。
protected Point | JMenu.getPopupMenuOrigin() 计算 JMenu 的弹出菜单的原点。
Point | JComponent.getToolTipLocation(MouseEvent event) 返回工具提示在此组件坐标系统中的位置。
Point | JViewport.getViewPosition() 返回显示在视口左上角的视图坐标，如果不存在视图，则返回（0,0）。
Point | JList.indexToLocation(int index) 返回列表的坐标系统中指定项的原点。
Point | JViewport.toViewCoordinates(Point p) 将一个点的像素坐标转换为视图坐标。

参数类型为 Point 的 javax.swing 中的方法
 int JTable.columnAtPoint(Point point)
返回 point 所在的列索引；如果结果不在 [0, getColumnCount()-1] 范围内，则返回 -1。
 Component MenuSelectionManager.componentForPoint(Component source, Point sourcePoint)
返回包含 sourcePoint 的当前选择路径的组件。
protected  boolean JViewport.computeBlit(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint)
计算 blit 的参数，其中后备存储图像当前在左上角包含 oldLoc，并且我们滚动到 newLoc。
 boolean JTree.AccessibleJTree.AccessibleJTreeNode.contains(Point p)
 boolean JTable.AccessibleJTable.AccessibleJTableCell.contains(Point p)
检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系统相关。
 boolean JList.AccessibleJList.AccessibleJListChild.contains(Point p)
static Point SwingUtilities.convertPoint(Component source, Point aPoint, Component destination)
将 source 坐标系统中的 aPoint 转换到 destination 坐标系统。
static void SwingUtilities.convertPointFromScreen(Point p, Component c)
将一个点从屏幕坐标转换到组件的坐标系统
static void SwingUtilities.convertPointToScreen(Point p, Component c)
将一个点从组件的坐标系统转换到屏幕坐标。
static Accessible SwingUtilities.getAccessibleAt(Component c, Point p)
如果存在，则返回本地坐标 Point 处包含的 Accessible 子对象。
 Accessible JEditorPane.AccessibleJEditorPaneHTML.getAccessibleAt(Point p)
返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
 Accessible JTree.AccessibleJTree.getAccessibleAt(Point p)
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
 Accessible JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAt(Point p)
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
 Accessible JTable.AccessibleJTable.getAccessibleAt(Point p)
如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回 Accessible 子级。
 Accessible JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAt(Point p)
 Accessible JTabbedPane.AccessibleJTabbedPane.getAccessibleAt(Point p)
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
 Accessible JList.AccessibleJList.getAccessibleAt(Point p)
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
 Accessible JList.AccessibleJList.AccessibleJListChild.getAccessibleAt(Point p)
 int JSpinner.AccessibleJSpinner.getIndexAtPoint(Point p)
以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。
 int ProgressMonitor.AccessibleProgressMonitor.getIndexAtPoint(Point p)
在本地坐标中给定一个点，返回该 Point 下字符的从零开始的索引。
 int AbstractButton.AccessibleAbstractButton.getIndexAtPoint(Point p)
在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。
 int JLabel.AccessibleJLabel.getIndexAtPoint(Point p)
以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。
 Point JComponent.getLocation(Point rv)
将此组件的 x，y 原点存储到“返回值”rv 中并返回 rv。
 int JList.locationToIndex(Point location)
返回最接近列表的坐标系统中给定位置的单元索引。
 int JTable.rowAtPoint(Point point)
返回 point 所在的行索引；如果结果不在 [0, getRowCount()-1] 范围内，则返回 -1。
 void JTree.AccessibleJTree.AccessibleJTreeNode.setLocation(Point p)
 void JTable.AccessibleJTable.AccessibleJTableCell.setLocation(Point p)
设置该对象相对于父对象的位置。
 void JList.AccessibleJList.AccessibleJListChild.setLocation(Point p)
 void JViewport.setViewPosition(Point p)
设置显示在视口左上角的视图坐标，如果不存在视图，则不执行任何操作。
 Point JViewport.toViewCoordinates(Point p)
将一个点的像素坐标转换为视图坐标。

参数类型为 Point 的 javax.swing 中的构造方法
TransferHandler.DropLocation(Point dropPoint)
构造给定点的放置位置。

javax.swing.plaf 中 Point 的使用

返回 Point 的 javax.swing.plaf 中的方法
abstract  Point ListUI.indexToLocation(JList list, int index)
返回列表坐标系统中给定 JList 中指定项的原点。

参数类型为 Point 的 javax.swing.plaf 中的方法
String | TextUI.getToolTipText(JTextComponent t, Point pt) 返回在传入位置上用作工具提示的字符串。
abstract int | ListUI.locationToIndex(JList list, Point location) 返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。
abstract int | TextUI.viewToModel(JTextComponent t, Point pt) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
abstract int | TextUI.viewToModel(JTextComponent t, Point pt, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射关系。

javax.swing.plaf.basic 中 Point 的使用

声明为 Point 的 javax.swing.plaf.basic 中的字段
protected  Point BasicToolBarUI.DockingListener.origin

返回 Point 的 javax.swing.plaf.basic 中的方法
Point | BasicToolBarUI.DragWindow.getOffset()
protected Point | BasicProgressBarUI.getStringPlacement(Graphics g, String progressString, int x, int y, int width, int height) 指定将绘制进度字符串的位置。
Point | BasicListUI.indexToLocation(JList list, int index) 返回列表坐标系统中给定 JList 中指定项的原点。

参数类型为 Point 的 javax.swing.plaf.basic 中的方法
boolean | BasicToolBarUI.canDock(Component c, Point p)
protected void | BasicToolBarUI.dragTo(Point position, Point origin)
protected void | BasicToolBarUI.floatAt(Point position, Point origin)
String | BasicTextUI.getToolTipText(JTextComponent t, Point pt) 返回在传入位置上用作工具提示的字符串。
int | BasicListUI.locationToIndex(JList list, Point location) 返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。
void | BasicToolBarUI.setFloating(boolean b, Point p)
void | BasicToolBarUI.DragWindow.setOffset(Point p)
int | BasicTextUI.viewToModel(JTextComponent tc, Point pt) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
int | BasicTextUI.viewToModel(JTextComponent tc, Point pt, Position.Bias[] biasReturn) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。

javax.swing.plaf.metal 中 Point 的使用

参数类型为 Point 的 javax.swing.plaf.metal 中的方法
protected  void MetalToolBarUI.setDragOffset(Point p)

javax.swing.plaf.multi 中 Point 的使用

返回 Point 的 javax.swing.plaf.multi 中的方法
 Point MultiListUI.indexToLocation(JList a, int b)
在由此对象处理的每个 UI 上调用 indexToLocation 方法。

参数类型为 Point 的 javax.swing.plaf.multi 中的方法
String | MultiTextUI.getToolTipText(JTextComponent a, Point b) 在由此对象处理的每个 UI 上调用 getToolTipText 方法。
int | MultiListUI.locationToIndex(JList a, Point b) 在由此对象处理的每个 UI 上调用 locationToIndex 方法。
int | MultiTextUI.viewToModel(JTextComponent a, Point b) 在由此对象处理的每个 UI 上调用 viewToModel 方法。
int | MultiTextUI.viewToModel(JTextComponent a, Point b, Position.Bias[] c) 在由此对象处理的每个 UI 上调用 viewToModel 方法。

javax.swing.table 中 Point 的使用

返回 Point 的 javax.swing.table 中的方法
Point | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocation()
Point | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocationOnScreen()

参数类型为 Point 的 javax.swing.table 中的方法
int | JTableHeader.columnAtPoint(Point point) 返回该 point 所处列的索引，如果列位于边界外，则返回 -1。
boolean | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.contains(Point p)
Accessible | JTableHeader.AccessibleJTableHeader.getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAt(Point p)
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setLocation(Point p)

javax.swing.text 中 Point 的使用

返回 Point 的 javax.swing.text 中的方法
Point | DefaultCaret.getMagicCaretPosition() 获取保存的插入符位置。
Point | Caret.getMagicCaretPosition() 获取当前插入符可见位置。

参数类型为 Point 的 javax.swing.text 中的方法
int | JTextComponent.AccessibleJTextComponent.getIndexAtPoint(Point p) 在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。
void | DefaultCaret.setMagicCaretPosition(Point p) 保存当前插入符位置。
void | Caret.setMagicCaretPosition(Point p) 设置当前插入符的可视位置。
int | JTextComponent.viewToModel(Point pt) 将视图坐标系统中的给定位置转换为模型中最具代表性的位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.PointerInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PointerInfo
的使用

使用 PointerInfo 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PointerInfo 的使用

返回 PointerInfo 的 java.awt 中的方法
static PointerInfo MouseInfo.getPointerInfo()
返回表示鼠标指针当前位置的 PointerInfo 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Polygon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Polygon
的使用

使用 Polygon 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Polygon 的使用

参数类型为 Polygon 的 java.awt 中的方法
void | Graphics.drawPolygon(Polygon p) 绘制由指定的 Polygon 对象定义的多边形边框。
void | Graphics.fillPolygon(Polygon p) 用图形上下文的当前颜色填充指定 Polygon 对象定义的多边形。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.PopupMenu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PopupMenu
的使用

使用 PopupMenu 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PopupMenu 的使用

返回 PopupMenu 的 java.awt 中的方法
 PopupMenu TrayIcon.getPopupMenu()
返回与此 TrayIcon 关联的弹出菜单。

参数类型为 PopupMenu 的 java.awt 中的方法
void | Component.add(PopupMenu popup) 向组件添加指定的弹出菜单。
protected abstract java.awt.peer.PopupMenuPeer | Toolkit.createPopupMenu(PopupMenu target) 使用指定同位体接口创建此工具包的 PopupMenu 实现。
void | TrayIcon.setPopupMenu(PopupMenu popup) 设置此 TrayIcon 的弹出菜单。

参数类型为 PopupMenu 的 java.awt 中的构造方法
TrayIcon(Image image, String tooltip, PopupMenu popup)
创建带指定图像、工具提示和弹出菜单的 TrayIcon。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.PopupMenu.AccessibleAWTPopupMenu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PopupMenu.AccessibleAWTPopupMenu
的使用

没有 java.awt.PopupMenu.AccessibleAWTPopupMenu 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.PrintGraphics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.PrintGraphics
的使用

没有 java.awt.PrintGraphics 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.PrintJob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PrintJob
的使用

使用 PrintJob 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PrintJob 的使用

返回 PrintJob 的 java.awt 中的方法
PrintJob | PrintGraphics.getPrintJob() 返回从其产生 PrintGraphics 对象的 PrintJob 对象。
PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
abstract PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, Properties props) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.RadialGradientPaint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.RadialGradientPaint
的使用

没有 java.awt.RadialGradientPaint 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Rectangle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Rectangle
的使用

使用 Rectangle 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image | 提供创建和修改图像的各种类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.imageio | Java Image I/O API 的主要包。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 Rectangle 的使用

声明为 Rectangle 的 java.awt 中的字段
protected  Rectangle Polygon.bounds
此 Polygon 的边界。

返回 Rectangle 的 java.awt 中的方法
 Rectangle Component.bounds()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
 Rectangle Polygon.getBoundingBox()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
 Rectangle List.AccessibleAWTList.AccessibleAWTListChild.getBounds()
以 Rectangle 对象的形式获取此对象的界限。
 Rectangle Polygon.getBounds()
获取此 Polygon 的边界框。
 Rectangle SplashScreen.getBounds()
以 Rectangle 形式返回闪现屏幕窗口的边界。
 Rectangle MenuComponent.AccessibleAWTMenuComponent.getBounds()
以 Rectangle 对象的形式获取此对象的边界。
 Rectangle Rectangle.getBounds()
获取此 Rectangle 的边界 Rectangle。
abstract  Rectangle GraphicsConfiguration.getBounds()
返回 GraphicsConfiguration 在设备坐标中的边界。
 Rectangle Shape.getBounds()
返回一个完全包围 Shape 的整型 Rectangle。
 Rectangle Component.getBounds()
以 Rectangle 对象的形式获取组件的边界。
 Rectangle Component.AccessibleAWTComponent.getBounds()
获取此对象的边界，用 Rectangle 对象的形式表示它。
 Rectangle Component.getBounds(Rectangle rv)
将组件的边界存储到“返回值”rv 中并返回 rv。
 Rectangle TextComponent.AccessibleAWTTextComponent.getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。
abstract  Rectangle Graphics.getClipBounds()
返回当前剪贴区域的边界矩形。
 Rectangle Graphics.getClipBounds(Rectangle r)
返回当前剪贴区域的边界矩形。
 Rectangle Graphics.getClipRect()
已过时。 从 JDK version 1.1 开始，由 getClipBounds() 取代。
 Rectangle Frame.getMaximizedBounds()
获取此窗体的最大化边界。
 Rectangle GraphicsEnvironment.getMaximumWindowBounds()
返回居中 Windows 的最大边界。
 Rectangle Rectangle.intersection(Rectangle r)
计算此 Rectangle 与指定 Rectangle 的交集。
 Rectangle Rectangle.union(Rectangle r)
计算此 Rectangle 与指定 Rectangle 的并集。

参数类型为 Rectangle 的 java.awt 中的方法
void | Rectangle.add(Rectangle r) 将一个 Rectangle 添加到此 Rectangle 中。
protected void | GridBagLayout.adjustForGravity(GridBagConstraints constraints, Rectangle r) 根据约束几何结构和填充将 x、y、宽度和高度四个字段调整为正确值。
protected void | GridBagLayout.AdjustForGravity(GridBagConstraints constraints, Rectangle r) 此方法已过时，仅为提供向后兼容性；新代码应该调用 adjustForGravity 来代替。
boolean | Rectangle.contains(Rectangle r) 检查此 Rectangle 是否完全包含指定的 Rectangle。
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
BufferedImage | Robot.createScreenCapture(Rectangle screenRect) 创建包含从屏幕中读取的像素的图像。
Rectangle | Component.getBounds(Rectangle rv) 将组件的边界存储到“返回值”rv 中并返回 rv。
Rectangle | Graphics.getClipBounds(Rectangle r) 返回当前剪贴区域的边界矩形。
abstract boolean | Graphics2D.hit(Rectangle rect, Shape s, boolean onStroke) 检查指定的 Shape 是否与设备空间中的指定 Rectangle 相交。
Rectangle | Rectangle.intersection(Rectangle r) 计算此 Rectangle 与指定 Rectangle 的交集。
boolean | Rectangle.intersects(Rectangle r) 确定此 Rectangle 是否与指定的 Rectangle 相交。
void | List.AccessibleAWTList.AccessibleAWTListChild.setBounds(Rectangle r) 以 Rectangle 对象的形式设置此对象的界限。
void | MenuComponent.AccessibleAWTMenuComponent.setBounds(Rectangle r) 以 Rectangle 对象的形式设置此对象的边界。
void | Rectangle.setBounds(Rectangle r) 设置此 Rectangle 的边界 Rectangle，以匹配指定的 Rectangle。
void | Window.setBounds(Rectangle r) 移动组件并调整其大小，使其符合新的有界矩形 r。
void | Component.setBounds(Rectangle r) 移动组件并调整其大小，使其符合新的有界矩形 r。
void | Component.AccessibleAWTComponent.setBounds(Rectangle r) 设置此对象的边界，用 Rectangle 对象的形式表示它。
void | Frame.setMaximizedBounds(Rectangle bounds) 设置此窗体的最大化边界。
Rectangle | Rectangle.union(Rectangle r) 计算此 Rectangle 与指定 Rectangle 的并集。

参数类型为 Rectangle 的 java.awt 中的构造方法
Rectangle(Rectangle r)
构造一个新的 Rectangle，并将其初始化，以与指定 Rectangle 的值匹配。

java.awt.event 中 Rectangle 的使用

返回 Rectangle 的 java.awt.event 中的方法
 Rectangle PaintEvent.getUpdateRect()
返回表示需要重绘区域以响应此事件的矩形。

参数类型为 Rectangle 的 java.awt.event 中的方法
 void PaintEvent.setUpdateRect(Rectangle updateRect)
设置表示需要进行重绘区域以响应此事件的矩形。

参数类型为 Rectangle 的 java.awt.event 中的构造方法
PaintEvent(Component source, int id, Rectangle updateRect)
构造一个具有指定源组件和类型的 PaintEvent 对象。

java.awt.font 中 Rectangle 的使用

返回 Rectangle 的 java.awt.font 中的方法
Rectangle | GlyphVector.getGlyphPixelBounds(int index, FontRenderContext renderFRC, float x, float y) 返回当此 GlyphVector 在 Graphics 中以给定 FontRenderContext 在给定位置呈现时，index 处字形的像素边界。
Rectangle | TextLayout.getPixelBounds(FontRenderContext frc, float x, float y) 返回在图形中使用给定 FontRenderContext 在给定位置处呈现 TextLayout 时的像素边界。
Rectangle | GlyphVector.getPixelBounds(FontRenderContext renderFRC, float x, float y) 返回此 GlyphVector 在图形中以给定 FontRenderContext 在给定位置处呈现时的像素边界。

java.awt.geom 中 Rectangle 的使用

返回 Rectangle 的 java.awt.geom 中的方法
Rectangle | Area.getBounds() 返回完全包围此 Area 的边界 Rectangle。
Rectangle | CubicCurve2D.getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
Rectangle | Line2D.getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
Rectangle | Path2D.getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
Rectangle | QuadCurve2D.getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
Rectangle | RectangularShape.getBounds() 返回一个完全包围 Shape 的整型 Rectangle。

java.awt.im 中 Rectangle 的使用

返回 Rectangle 的 java.awt.im 中的方法
 Rectangle InputMethodRequests.getTextLocation(TextHitInfo offset)
获取当前撰写文本中指定偏移量的位置，或已提交文本中的选择位置。

java.awt.im.spi 中 Rectangle 的使用

参数类型为 Rectangle 的 java.awt.im.spi 中的方法
 void InputMethod.notifyClientWindowChange(Rectangle bounds)
通知此输入方法客户端窗口位置或状态的更改。

java.awt.image 中 Rectangle 的使用

返回 Rectangle 的 java.awt.image 中的方法
 Rectangle Raster.getBounds()
返回此 Raster 的边界 Rectangle。

参数类型为 Rectangle 的 java.awt.image 中的方法
WritableRaster | Raster.createCompatibleWritableRaster(Rectangle rect) 创建一个兼容的 WritableRaster，使其具有由 rect 指定的位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
Raster | BufferedImage.getData(Rectangle rect) 计算并返回 BufferedImage 的一个任意区域。
Raster | RenderedImage.getData(Rectangle rect) 计算并返回 RenderedImage 的任意区域。

参数类型为 Rectangle 的 java.awt.image 中的构造方法
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。

java.beans 中 Rectangle 的使用

参数类型为 Rectangle 的 java.beans 中的方法
void | PropertyEditor.paintValue(Graphics gfx, Rectangle box) 在屏幕实际状态给定区域中绘制值的表示形式。
void | PropertyEditorSupport.paintValue(Graphics gfx, Rectangle box) 在屏幕实际状态给定区域中绘制值的表示形式。

javax.accessibility 中 Rectangle 的使用

返回 Rectangle 的 javax.accessibility 中的方法
Rectangle | AccessibleComponent.getBounds() 获取 Rectangle 对象形式的此对象的边界。
Rectangle | AccessibleText.getCharacterBounds(int i) 确定字符串中给定索引处的字符的边界框。
Rectangle | AccessibleExtendedText.getTextBounds(int startIndex, int endIndex) 返回两个索引之间文本的边界矩形。

参数类型为 Rectangle 的 javax.accessibility 中的方法
 void AccessibleComponent.setBounds(Rectangle r)
设置 Rectangle 对象形式的此对象的边界。

javax.imageio 中 Rectangle 的使用

声明为 Rectangle 的 javax.imageio 中的字段
protected  Rectangle IIOParam.sourceRegion
源区域；如果没有设置源区域，则为 null。

返回 Rectangle 的 javax.imageio 中的方法
Rectangle | IIOParam.getSourceRegion() 返回将使用的源区域。
protected static Rectangle | ImageReader.getSourceRegion(ImageReadParam param, int srcWidth, int srcHeight) reader 可用来计算应该读取的源图像区域的一个实用方法，计算时考虑任何源区域，并在所提供的 ImageReadParam 中对偏移量设置进行二次取样。

参数类型为 Rectangle 的 javax.imageio 中的方法
protected static void | ImageReader.computeRegions(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion) 计算感兴趣的源区域和目标区域，将源图像的宽度和高度、可选目标图像和可选 ImageReadParam 都考虑在内。
void | ImageWriter.prepareReplacePixels(int imageIndex, Rectangle region) 准备好 writer，处理一系列对 replacePixels 方法的调用。
void | IIOParam.setSourceRegion(Rectangle sourceRegion) 设置感兴趣的源区域。

javax.swing 中 Rectangle 的使用

返回 Rectangle 的 javax.swing 中的方法
static Rectangle SwingUtilities.calculateInnerArea(JComponent c, Rectangle r)
将指定组件的内部绘制区域的位置和大小存储在 r 中，然后返回 r。
static Rectangle[] SwingUtilities.computeDifference(Rectangle rectA, Rectangle rectB)
返回矩形数组的便捷方法，该矩形表示不与 rectB 重叠的 rectA 内的区域。
static Rectangle SwingUtilities.computeIntersection(int x, int y, int width, int height, Rectangle dest)
在未分配新矩形的情况下计算两个矩形的交集的便捷方法。
static Rectangle SwingUtilities.computeUnion(int x, int y, int width, int height, Rectangle dest)
在未分配新矩形的情况下计算两个矩形的并集的便捷方法。
static Rectangle SwingUtilities.convertRectangle(Component source, Rectangle aRectangle, Component destination)
将 source 坐标系统中的矩形 aRectangle 转换到 destination 坐标系统。
 Rectangle JTree.AccessibleJTree.AccessibleJTreeNode.getBounds()
 Rectangle JTable.AccessibleJTable.AccessibleJTableCell.getBounds()
 Rectangle JList.AccessibleJList.AccessibleJListChild.getBounds()
 Rectangle JComponent.getBounds(Rectangle rv)
将此组件的边界存储到“返回值”rv 中并返回 rv。
 Rectangle JTabbedPane.getBoundsAt(int index)
返回 index 位置的选项卡边界。
protected  Rectangle DefaultDesktopManager.getBoundsForIconOf(JInternalFrame f)
iconifyFrame() 代码调用此方法来确定 desktopIcon 的适当边界。
 Rectangle JList.getCellBounds(int index0, int index1)
返回列表的坐标系统中两个索引所指定单元范围内的边界矩形。
 Rectangle JTable.getCellRect(int row, int column, boolean includeSpacing)
返回位于 row 和 column 相交位置的单元格矩形。
 Rectangle JSpinner.AccessibleJSpinner.getCharacterBounds(int i)
确定给定字符串索引处字符的边界。
 Rectangle ProgressMonitor.AccessibleProgressMonitor.getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。
 Rectangle AbstractButton.AccessibleAbstractButton.getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。
 Rectangle JLabel.AccessibleJLabel.getCharacterBounds(int i)
确定给定字符串索引处字符的边界框。
 Rectangle DebugGraphics.getClipBounds()
重写 Graphics.getClipBounds。
 Rectangle RepaintManager.getDirtyRegion(JComponent aComponent)
返回组件的当前脏区。
static Rectangle SwingUtilities.getLocalBounds(Component aComponent)
返回组件 aComponent 的矩形 (0,0,bounds.width,bounds.height)。
 Rectangle JInternalFrame.getNormalBounds()
如果 JInternalFrame 未处于最大化状态，则返回 getBounds()；否则返回还原 JInternalFrame 后的边界。
 Rectangle JTree.getPathBounds(TreePath path)
返回将指定节点绘入的 Rectangle。
protected  Rectangle DefaultDesktopManager.getPreviousBounds(JInternalFrame f)
在将组件最大化之前，获得该组件的普通边界。
 Rectangle JTree.getRowBounds(int row)
返回将指定行处的节点绘入的 Rectangle。
 Rectangle JScrollPane.getViewportBorderBounds()
返回视口边界的范围。
 Rectangle ScrollPaneLayout.getViewportBorderBounds(JScrollPane scrollpane)
已过时。 从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。
 Rectangle JViewport.getViewRect()
返回一个矩形，其原位置在 getViewPosition，大小为 getExtentSize。
 Rectangle JComponent.getVisibleRect()
返回该 Component 的“可见矩形”，即此组件的可见矩形 new Rectangle(0, 0, getWidth(), getHeight()) 及其所有祖先的可见矩形的交集。

参数类型为 Rectangle 的 javax.swing 中的方法
static Rectangle SwingUtilities.calculateInnerArea(JComponent c, Rectangle r)
将指定组件的内部绘制区域的位置和大小存储在 r 中，然后返回 r。
protected  boolean JViewport.computeBlit(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint)
计算 blit 的参数，其中后备存储图像当前在左上角包含 oldLoc，并且我们滚动到 newLoc。
static Rectangle[] SwingUtilities.computeDifference(Rectangle rectA, Rectangle rectB)
返回矩形数组的便捷方法，该矩形表示不与 rectB 重叠的 rectA 内的区域。
static Rectangle SwingUtilities.computeIntersection(int x, int y, int width, int height, Rectangle dest)
在未分配新矩形的情况下计算两个矩形的交集的便捷方法。
static Rectangle SwingUtilities.computeUnion(int x, int y, int width, int height, Rectangle dest)
在未分配新矩形的情况下计算两个矩形的并集的便捷方法。
 void JComponent.computeVisibleRect(Rectangle visibleRect)
返回该 Component 的“可见 rect 矩形”，即此组件及其所有祖先的可见矩形的交集。
static Rectangle SwingUtilities.convertRectangle(Component source, Rectangle aRectangle, Component destination)
将 source 坐标系统中的矩形 aRectangle 转换到 destination 坐标系统。
 Rectangle JComponent.getBounds(Rectangle rv)
将此组件的边界存储到“返回值”rv 中并返回 rv。
 int JTree.getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
返回块增量的数量，它是基于 orientation 的 visibleRect 高度或宽度。
 int JTable.getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
返回 visibleRect.height 或 visibleRect.width，这取决于此表的方向。
 int JList.getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
返回为显露上一个或下一个块而滚动的距离。
 int Scrollable.getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。
 int JTree.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
返回滚动时增加的数量。
 int JTable.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
返回完全呈现出一个新行或新列（取决于方向）的滚动增量（以像素为单位）。
 int JTextArea.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
显示逻辑行或列的组件应根据方向的值计算滚动增量，此滚动增量将完全显示一个新行或新列。
 int JList.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
返回为显露上一个或下一个行（垂直滚动）或列（水平滚动）而滚动的距离。
 int Scrollable.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。
static boolean SwingUtilities.isRectangleContainingRectangle(Rectangle a, Rectangle b)
如果 a 包含 b，则返回 true。
static String SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
static String SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, Rectangle r)
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, Rectangle r)
在指定的 Graphics 上绘制组件。
 void JComponent.paintImmediately(Rectangle r)
立即绘制指定的区域。
 void DefaultListCellRenderer.repaint(Rectangle r)
因为性能原因而被重写。
 void JComponent.repaint(Rectangle r)
如果要显示该组件，则将指定的区域添加到脏区列表。
 void JTextField.scrollRectToVisible(Rectangle r)
将字段向左或向右滚动。
 void JViewport.scrollRectToVisible(Rectangle contentRect)
滚动该视图，使该视图中的 Rectangle 变得可见。
 void JComponent.scrollRectToVisible(Rectangle aRect)
将 scrollRectToVisible() 消息转发到 JComponent 的父组件。
 void JTree.AccessibleJTree.AccessibleJTreeNode.setBounds(Rectangle r)
 void JTable.AccessibleJTable.AccessibleJTableCell.setBounds(Rectangle r)
 void JList.AccessibleJList.AccessibleJListChild.setBounds(Rectangle r)
 void JInternalFrame.setNormalBounds(Rectangle r)
设置此内部窗体的正常边界，即此内部窗体从其最大化状态还原后的边界。
protected  void DefaultDesktopManager.setPreviousBounds(JInternalFrame f, Rectangle r)
在进行 maximize 调用之前存储组件的边界。

javax.swing.border 中 Rectangle 的使用

返回 Rectangle 的 javax.swing.border 中的方法
static Rectangle | AbstractBorder.getInteriorRectangle(Component c, Border b, int x, int y, int width, int height) 返回一个用所给的参数减去边框 insets 得到的矩形。
Rectangle | AbstractBorder.getInteriorRectangle(Component c, int x, int y, int width, int height) 此便捷方法调用静态方法。

javax.swing.plaf 中 Rectangle 的使用

返回 Rectangle 的 javax.swing.plaf 中的方法
abstract Rectangle | ListUI.getCellBounds(JList list, int index1, int index2) 返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
abstract Rectangle | TreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
abstract Rectangle | TabbedPaneUI.getTabBounds(JTabbedPane pane, int index)
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。

javax.swing.plaf.basic 中 Rectangle 的使用

javax.swing.plaf.basic 中 Rectangle 的子类
static class BasicTextUI.BasicCaret

声明为 Rectangle 的 javax.swing.plaf.basic 中的字段
protected Rectangle | BasicProgressBarUI.boxRect 用于保存要绘制的跳动框（由 getBox 返回）的位置和大小。
protected Rectangle | BasicTabbedPaneUI.calcRect 用于通用布局计算以避免运行中构造多个新 Rectangle 的矩形。
protected Rectangle | BasicSliderUI.contentRect
protected Rectangle | BasicSliderUI.focusRect
protected Rectangle | BasicSliderUI.labelRect
protected Rectangle[] | BasicTabbedPaneUI.rects
protected Rectangle | BasicSliderUI.thumbRect
protected Rectangle | BasicScrollBarUI.thumbRect
protected Rectangle | BasicSliderUI.tickRect
protected Rectangle | BasicSliderUI.trackRect
protected Rectangle | BasicScrollBarUI.trackRect

返回 Rectangle 的 javax.swing.plaf.basic 中的方法
protected Rectangle | BasicComboPopup.computePopupBounds(int px, int py, int pw, int ph) 基于组合框的位置和封闭的屏幕界限计算组合框的弹出部分的位置和大小。
protected Rectangle | BasicProgressBarUI.getBox(Rectangle r) 存储将为 r 中的当前动画索引绘制并返回 r 的跳动框中位置和大小。
Rectangle | BasicListUI.getCellBounds(JList list, int index1, int index2) 返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
Rectangle | BasicTreeUI.NodeDimensionsHandler.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle size) 负责获取特定节点的大小。
Rectangle | BasicTreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
protected Rectangle | BasicTabbedPaneUI.getTabBounds(int tabIndex, Rectangle dest) 返回 JTabbedPane 组件的坐标空间中指定选项卡的边界。
Rectangle | BasicTabbedPaneUI.getTabBounds(JTabbedPane pane, int i) 返回指定选项卡索引的边界。
protected Rectangle | BasicScrollBarUI.getThumbBounds() 返回 thumb 的当前大小/位置。
protected Rectangle | BasicScrollBarUI.getTrackBounds() 返回滑道的当前边界，即递增和递减按钮之间的空间（减去 insets）。
protected Rectangle | BasicTextUI.getVisibleEditorRect() 获取给出根 View 的分配。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
protected Rectangle | BasicComboBoxUI.rectangleForCurrentValue() 返回为绘制当前所选项而保留的区域。

参数类型为 Rectangle 的 javax.swing.plaf.basic 中的方法
protected  Rectangle BasicProgressBarUI.getBox(Rectangle r)
存储将为 r 中的当前动画索引绘制并返回 r 的跳动框中位置和大小。
 Rectangle BasicTreeUI.NodeDimensionsHandler.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle size)
负责获取特定节点的大小。
protected  Rectangle BasicTabbedPaneUI.getTabBounds(int tabIndex, Rectangle dest)
返回 JTabbedPane 组件的坐标空间中指定选项卡的边界。
protected  String BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。
protected  void BasicTabbedPaneUI.layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。
 void BasicComboBoxUI.paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus)
绘制当前所选项。
 void BasicComboBoxUI.paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus)
绘制当前所选项的背景。
protected  void BasicTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制 row 的展开（切换）部分。
protected  void BasicButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected  void BasicRadioButtonUI.paintFocus(Graphics g, Rectangle textRect, Dimension size)
protected  void BasicTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制支路 (leg) 的水平部分。
protected  void BasicToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)
protected  void BasicTabbedPaneUI.paintIcon(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
protected  void BasicButtonUI.paintIcon(Graphics g, JComponent c, Rectangle iconRect)
protected  void BasicSliderUI.paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected  void BasicSliderUI.paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected  void BasicSliderUI.paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected  void BasicSliderUI.paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected  void BasicTreeUI.paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制 row 的渲染器部分。
protected  void BasicTabbedPaneUI.paintTab(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect)
protected  void BasicTabbedPaneUI.paintTab(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect)
protected  void BasicButtonUI.paintText(Graphics g, AbstractButton b, Rectangle textRect, String text)
呈现当前按钮文本的方法。
protected  void BasicTabbedPaneUI.paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)
protected  void BasicButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
protected  void BasicMenuItemUI.paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
呈现当前菜单项的文本。
protected  void BasicScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected  void BasicScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
protected  void BasicTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
绘制支路的垂直部分。

javax.swing.plaf.metal 中 Rectangle 的使用

参数类型为 Rectangle 的 javax.swing.plaf.metal 中的方法
void | MetalComboBoxUI.paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus) 如有必要，绘制当前所选项。
void | MetalComboBoxUI.paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus) 如有必要，绘制当前所选项的背景。
protected void | MetalToggleButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalRadioButtonUI.paintFocus(Graphics g, Rectangle t, Dimension d)
protected void | MetalTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected void | MetalTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected void | MetalTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
protected void | MetalToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect) 在空间 iconRect 中绘制按钮 b 的适当图标。
protected void | MetalSliderUI.paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | MetalSliderUI.paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected void | MetalSliderUI.paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | MetalSliderUI.paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected void | MetalToggleButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
protected void | MetalButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
protected void | MetalScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected void | MetalScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
protected void | MetalTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

javax.swing.plaf.multi 中 Rectangle 的使用

返回 Rectangle 的 javax.swing.plaf.multi 中的方法
Rectangle | MultiListUI.getCellBounds(JList a, int b, int c) 在由此对象处理的每个 UI 上调用 getCellBounds 方法。
Rectangle | MultiTreeUI.getPathBounds(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getPathBounds 方法。
Rectangle | MultiTabbedPaneUI.getTabBounds(JTabbedPane a, int b) 在由此对象处理的每个 UI 上调用 getTabBounds 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b) 在由此对象处理的每个 UI 上调用 modelToView 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c) 在由此对象处理的每个 UI 上调用 modelToView 方法。

javax.swing.plaf.synth 中 Rectangle 的使用

参数类型为 Rectangle 的 javax.swing.plaf.synth 中的方法
String | SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap) 根据通过引用返回的放置图标和文本的位置，布局文本和图标。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex) 在指定位置上绘制文本。

javax.swing.table 中 Rectangle 的使用

返回 Rectangle 的 javax.swing.table 中的方法
Rectangle | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getBounds()
Rectangle | JTableHeader.getHeaderRect(int column) 返回包含 column 处头 tile 的矩形。

参数类型为 Rectangle 的 javax.swing.table 中的方法
void | DefaultTableCellRenderer.repaint(Rectangle r) 因为性能原因而被重写。
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setBounds(Rectangle r)

javax.swing.text 中 Rectangle 的使用

javax.swing.text 中 Rectangle 的子类
 class DefaultCaret
插入符的默认实现。

声明为 Rectangle 的 javax.swing.text 中的字段
protected Rectangle | AsyncBoxView.ChildLocator.childAlloc 用于子级分配区域以避免创建大量垃圾的形状。
protected Rectangle | AsyncBoxView.ChildLocator.lastAlloc 最后的可见分配区域（用于向上刷新更改时进行重新绘制）。

返回 Rectangle 的 javax.swing.text 中的方法
Rectangle | JTextComponent.AccessibleJTextComponent.getCharacterBounds(int i) 确定字符串中给定索引处的字符的边界框。
protected Rectangle | CompositeView.getInsideAllocation(Shape a) 将分配给视图的不可变分配区域转换为表示内部分配区域的可变分配区域（即给定分配区域的边界，其顶部、左部、底部和右部的 insets 已移除）。
Rectangle | JTextComponent.AccessibleJTextComponent.getTextBounds(int startIndex, int endIndex) 返回包围两个索引之间文本的 Rectangle。
protected Rectangle | PlainView.lineToRect(Shape a, int line) 确定表示给定行的矩形。
Rectangle | JTextComponent.modelToView(int pos) 将模型中给定位置转换为视图坐标系统中的位置。

参数类型为 Rectangle 的 javax.swing.text 中的方法
protected void | DefaultCaret.adjustVisibility(Rectangle nloc) 滚动关联的视图（如果有）以使插入符可见。
void | FlowView.FlowStrategy.changedUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
protected void | BoxView.childAllocation(int index, Rectangle alloc) 为子视图分配一个区域。
protected abstract void | CompositeView.childAllocation(int index, Rectangle a) 返回给定子级的分配区域。
protected void | DefaultCaret.damage(Rectangle r) 毁坏围绕插入符的区域以使该区域在新的位置重绘。
int | JTextComponent.getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction) 显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。
int | JTextComponent.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction) 显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。
protected View | BoxView.getViewAtPoint(int x, int y, Rectangle alloc) 获取给定坐标处的子视图。
protected abstract View | CompositeView.getViewAtPoint(int x, int y, Rectangle alloc) 获取位于给定坐标的子视图。
protected View | CompositeView.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
protected View | TableView.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
protected View | TableView.TableRow.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
void | FlowView.FlowStrategy.insertUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
protected boolean | BoxView.isAfter(int x, int y, Rectangle innerAlloc) 确定一个点是否位于分配区域的后面。
protected abstract boolean | CompositeView.isAfter(int x, int y, Rectangle alloc) 测试一个点是否位于矩形范围之后。
protected boolean | BoxView.isBefore(int x, int y, Rectangle innerAlloc) 确定一个点是否位于分配区域的前面。
protected abstract boolean | CompositeView.isBefore(int x, int y, Rectangle alloc) 测试一个点是否位于矩形范围之前。
protected void | BoxView.paintChild(Graphics g, Rectangle alloc, int index) 绘制一个子级。
void | FlowView.FlowStrategy.removeUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知已从文档中此给定流视图负责的某个位置移除某些内容。

javax.swing.text.html 中 Rectangle 的使用

参数类型为 Rectangle 的 javax.swing.text.html 中的方法
protected  void ListView.paintChild(Graphics g, Rectangle alloc, int index)
通过调用 paint() 绘制其中的一个子级。

javax.swing.tree 中 Rectangle 的使用

返回 Rectangle 的 javax.swing.tree 中的方法
Rectangle | FixedHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回给出绘制路径所需边界的矩形。
Rectangle | VariableHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回 Rectangle，它包围在其中绘制 path 标识的项的标签部分。
abstract Rectangle | AbstractLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回一个矩形，该矩形给出了绘制路径所需的 bounds。
protected Rectangle | AbstractLayoutCache.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle placeIn) 返回通过 placeIn 中的引用，表示 value 所需的大小。
abstract Rectangle | AbstractLayoutCache.NodeDimensions.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle bounds) 通过对 bounds 的引用，返回用于保存值的节点的大小和其在 x 轴上的起点。

参数类型为 Rectangle 的 javax.swing.tree 中的方法
Rectangle | FixedHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回给出绘制路径所需边界的矩形。
Rectangle | VariableHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回 Rectangle，它包围在其中绘制 path 标识的项的标签部分。
abstract Rectangle | AbstractLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回一个矩形，该矩形给出了绘制路径所需的 bounds。
protected Rectangle | AbstractLayoutCache.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle placeIn) 返回通过 placeIn 中的引用，表示 value 所需的大小。
abstract Rectangle | AbstractLayoutCache.NodeDimensions.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle bounds) 通过对 bounds 的引用，返回用于保存值的节点的大小和其在 x 轴上的起点。
int | VariableHeightLayoutCache.getPreferredWidth(Rectangle bounds) 返回 visibleRegion 中区域的首选宽度和高度。
int | AbstractLayoutCache.getPreferredWidth(Rectangle bounds) 返回传入区域的首选宽度。
void | DefaultTreeCellRenderer.repaint(Rectangle r) 因为性能原因而被重写。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.RenderingHints 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.RenderingHints
的使用

使用 RenderingHints 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。

java.awt 中 RenderingHints 的使用

返回 RenderingHints 的 java.awt 中的方法
abstract  RenderingHints Graphics2D.getRenderingHints()
获取呈现算法的首选项。

参数类型为 RenderingHints 的 java.awt 中的方法
void | RenderingHints.add(RenderingHints hints) 将指定 RenderingHints 对象中的所有键和相应的值添加到此 RenderingHints 对象中。
CompositeContext | AlphaComposite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 为合成操作创建一个上下文。
CompositeContext | Composite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 创建一个上下文，其中包含用于执行复合操作的状态。
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。

java.awt.image 中 RenderingHints 的使用

返回 RenderingHints 的 java.awt.image 中的方法
RenderingHints | AffineTransformOp.getRenderingHints() 返回此转换操作使用的呈现提示。
RenderingHints | BandCombineOp.getRenderingHints() 返回针对此操作呈现的提示。
RenderingHints | BufferedImageOp.getRenderingHints() 返回针对此操作所呈现的提示。
RenderingHints | ColorConvertOp.getRenderingHints() 此操作使用的呈现提示。
RenderingHints | ConvolveOp.getRenderingHints() 返回此 op 的呈现提示。
RenderingHints | LookupOp.getRenderingHints() 返回此操作的呈现提示。
RenderingHints | RasterOp.getRenderingHints() 返回此 RasterOp 的呈现提示。
RenderingHints | RescaleOp.getRenderingHints() 返回此操作的呈现提示。

参数类型为 RenderingHints 的 java.awt.image 中的构造方法
AffineTransformOp(AffineTransform xform, RenderingHints hints)
根据仿射转换构造 AffineTransformOp。
BandCombineOp(float[][] matrix, RenderingHints hints)
构造一个具有指定矩阵的 BandCombineOp。
ColorConvertOp(ColorSpace srcCspace, ColorSpace dstCspace, RenderingHints hints)
根据两个 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ColorSpace cspace, RenderingHints hints)
根据 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ICC_Profile[] profiles, RenderingHints hints)
根据 ICC_Profiles 的数组构造新的 ColorConvertOp。
ColorConvertOp(RenderingHints hints)
构造从源颜色空间到目标颜色空间转换的新 ColorConvertOp。
ConvolveOp(Kernel kernel, int edgeCondition, RenderingHints hints)
构造给定 Kernel、边缘条件和 RenderingHint 对象（可以为 null）的 ConvolveOp。
LookupOp(LookupTable lookup, RenderingHints hints)
在给定查找表和 RenderingHints 对象（可能为 null）的情况下，构造一个 LookupOp 对象。
RescaleOp(float[] scaleFactors, float[] offsets, RenderingHints hints)
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。
RescaleOp(float scaleFactor, float offset, RenderingHints hints)
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。

java.awt.image.renderable 中 RenderingHints 的使用

返回 RenderingHints 的 java.awt.image.renderable 中的方法
 RenderingHints RenderContext.getRenderingHints()
获取此 RenderContext 的呈现提示。

参数类型为 RenderingHints 的 java.awt.image.renderable 中的方法
RenderedImage | RenderedImageFactory.create(ParameterBlock paramBlock, RenderingHints hints) 针对给定的 ParameterBlock 和 RenderingHints 创建表示成像操作（或操作链）结果的 RenderedImage。
RenderedImage | RenderableImage.createScaledRendering(int w, int h, RenderingHints hints) 创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
RenderedImage | RenderableImageOp.createScaledRendering(int w, int h, RenderingHints hints) 创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
void | RenderContext.setRenderingHints(RenderingHints hints) 设置此 RenderContext 的呈现提示。

参数类型为 RenderingHints 的 java.awt.image.renderable 中的构造方法
RenderContext(AffineTransform usr2dev, RenderingHints hints)
构造具有给定转换和呈现提示的 RenderContext。
RenderContext(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
构造具有给定转换的 RenderContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.RenderingHints.Key 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.RenderingHints.Key
的使用

使用 RenderingHints.Key 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 RenderingHints.Key 的使用

声明为 RenderingHints.Key 的 java.awt 中的字段
static RenderingHints.Key | RenderingHints.KEY_ALPHA_INTERPOLATION Alpha 插值提示键。
static RenderingHints.Key | RenderingHints.KEY_ANTIALIASING 抗锯齿提示键。
static RenderingHints.Key | RenderingHints.KEY_COLOR_RENDERING 颜色呈现提示键。
static RenderingHints.Key | RenderingHints.KEY_DITHERING 抖动提示键。
static RenderingHints.Key | RenderingHints.KEY_FRACTIONALMETRICS 字体小数规格提示键。
static RenderingHints.Key | RenderingHints.KEY_INTERPOLATION 插值提示键。
static RenderingHints.Key | RenderingHints.KEY_RENDERING 呈现提示键。
static RenderingHints.Key | RenderingHints.KEY_STROKE_CONTROL 笔划规范化控制提示键。
static RenderingHints.Key | RenderingHints.KEY_TEXT_ANTIALIASING 文本抗锯齿提示键。
static RenderingHints.Key | RenderingHints.KEY_TEXT_LCD_CONTRAST LCD 文本对比呈现提示键。

参数类型为 RenderingHints.Key 的 java.awt 中的方法
abstract Object | Graphics2D.getRenderingHint(RenderingHints.Key hintKey) 返回呈现算法的单个首选项的值。
abstract void | Graphics2D.setRenderingHint(RenderingHints.Key hintKey, Object hintValue) 为呈现算法设置单个首选项的值。

参数类型为 RenderingHints.Key 的 java.awt 中的构造方法
RenderingHints(RenderingHints.Key key, Object value)
构造一个具有指定键/值对的新对象。

类型变量类型为 RenderingHints.Key 的 java.awt 中的构造方法参数
RenderingHints(Map<RenderingHints.Key,?> init)
构造一个新对象，该对象具有根据指定 Map 对象（可以为 null）初始化的键和值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Robot 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Robot
的使用

没有 java.awt.Robot 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Scrollbar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Scrollbar
的使用

使用 Scrollbar 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Scrollbar 的使用

参数类型为 Scrollbar 的 java.awt 中的方法
protected abstract  java.awt.peer.ScrollbarPeer Toolkit.createScrollbar(Scrollbar target)
使用指定同位体接口创建此工具包的 Scrollbar 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Scrollbar.AccessibleAWTScrollBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Scrollbar.AccessibleAWTScrollBar
的使用

没有 java.awt.Scrollbar.AccessibleAWTScrollBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.ScrollPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ScrollPane
的使用

使用 ScrollPane 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 ScrollPane 的使用

参数类型为 ScrollPane 的 java.awt 中的方法
protected abstract  java.awt.peer.ScrollPanePeer Toolkit.createScrollPane(ScrollPane target)
使用指定同位体接口创建此工具包的 ScrollPane 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.ScrollPane.AccessibleAWTScrollPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ScrollPane.AccessibleAWTScrollPane
的使用

没有 java.awt.ScrollPane.AccessibleAWTScrollPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.ScrollPaneAdjustable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ScrollPaneAdjustable
的使用

没有 java.awt.ScrollPaneAdjustable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.Shape 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Shape
的使用

使用 Shape 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Shape 的使用

实现 Shape 的 java.awt 中的类
class | Polygon Polygon 类封装了坐标空间中封闭的二维区域的描述。
class | Rectangle Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

返回 Shape 的 java.awt 中的方法
Shape | BasicStroke.createStrokedShape(Shape s) 返回一个 Shape，它在内部定义了指定 Shape 的笔划轮廓。
Shape | Stroke.createStrokedShape(Shape p) 返回一个轮廓 Shape，它封闭了应该在根据规则描绘 Shape 时绘制的区域，这些规则是由实现 Stroke 接口的对象定义的。
abstract Shape | Graphics.getClip() 获取当前剪贴区域。

参数类型为 Shape 的 java.awt 中的方法
abstract void | Graphics2D.clip(Shape s) 将当前 Clip 与指定 Shape 的内部区域相交，并将 Clip 设置为所得的交集。
Shape | BasicStroke.createStrokedShape(Shape s) 返回一个 Shape，它在内部定义了指定 Shape 的笔划轮廓。
Shape | Stroke.createStrokedShape(Shape p) 返回一个轮廓 Shape，它封闭了应该在根据规则描绘 Shape 时绘制的区域，这些规则是由实现 Stroke 接口的对象定义的。
abstract void | Graphics2D.draw(Shape s) 使用当前 Graphics2D 上下文的设置勾画 Shape 的轮廓。
abstract void | Graphics2D.fill(Shape s) 使用 Graphics2D 上下文的设置，填充 Shape 的内部区域。
abstract boolean | Graphics2D.hit(Rectangle rect, Shape s, boolean onStroke) 检查指定的 Shape 是否与设备空间中的指定 Rectangle 相交。
abstract void | Graphics.setClip(Shape clip) 将当前剪贴区域设置为任意的剪贴形状。

java.awt.font 中 Shape 的使用

返回 Shape 的 java.awt.font 中的方法
Shape | TextLayout.getBlackBoxBounds(int firstEndpoint, int secondEndpoint) 返回指定范围中字符的黑框边界。
Shape | TextLayout.getCaretShape(TextHitInfo hit) 返回表示此 TextLayout 的自然边界中指定目标字符处插入符的 Shape。
Shape | TextLayout.getCaretShape(TextHitInfo hit, Rectangle2D bounds) 返回表示指定边界内指定目标字符处插入符的 Shape。
Shape[] | TextLayout.getCaretShapes(int offset) 返回对应于强插入符和弱插入符的两条路径。
Shape[] | TextLayout.getCaretShapes(int offset, Rectangle2D bounds) 返回对应于强插入符和弱插入符的两条路径。
Shape[] | TextLayout.getCaretShapes(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy) 返回对应于强插入符和弱插入符的两条路径。
abstract Shape | GlyphVector.getGlyphLogicalBounds(int glyphIndex) 返回此 GlyphVector 中指定字形的逻辑边界。
abstract Shape | GlyphVector.getGlyphOutline(int glyphIndex) 返回其内部区域与此 GlyphVector 中指定字形的可视表示形式对应的 Shape。
Shape | GlyphVector.getGlyphOutline(int glyphIndex, float x, float y) 返回一个 Shape，其内部区域与此 GlyphVector 中指定字形的可视表示形式对应，并偏移到 x、y。
abstract Shape | GlyphVector.getGlyphVisualBounds(int glyphIndex) 返回 GlyphVector 中指定字形的可视边界。
Shape | TextLayout.getLogicalHighlightShape(int firstEndpoint, int secondEndpoint) 返回封装指定范围中逻辑选择范围的 Shape，它扩展到此 TextLayout 的自然边界。
Shape | TextLayout.getLogicalHighlightShape(int firstEndpoint, int secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到指定 bounds 的逻辑选择范围的 Shape。
abstract Shape | GlyphVector.getOutline() 返回其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。
Shape | GraphicAttribute.getOutline(AffineTransform tx) 返回表示此 GraphicAttribute 呈现区域的 Shape。
Shape | ShapeGraphicAttribute.getOutline(AffineTransform tx) 返回一个表示此 ShapeGraphicAttribute 呈现区域的 Shape。
Shape | TextLayout.getOutline(AffineTransform tx) 返回表示此 TextLayout 的轮廓的 Shape。
abstract Shape | GlyphVector.getOutline(float x, float y) 返回在 x、y 处呈现时，其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。
Shape | TextLayout.getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint) 返回封闭指定范围中扩展到指定边界的可视选择范围的 Shape。
Shape | TextLayout.getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到 bounds 的可视选择范围的路径。

参数类型为 Shape 的 java.awt.font 中的构造方法
ShapeGraphicAttribute(Shape shape, int alignment, boolean stroke)
针对指定 Shape 构造 ShapeGraphicAttribute。

java.awt.geom 中 Shape 的使用

实现 Shape 的 java.awt.geom 中的类
class | Arc2D Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。
class | Area Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。
class | CubicCurve2D CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。
static class | CubicCurve2D.Double 使用 double 坐标指定的三次参数曲线段。
static class | CubicCurve2D.Float 使用 float 坐标指定的三次参数曲线段。
class | Ellipse2D Ellipse2D 类描述窗体矩形定义的椭圆。
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。
class | GeneralPath GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
class | Line2D Line2D 表示 (x,y) 坐标空间中的线段。
static class | Line2D.Double 使用 double 坐标指定的线段。
static class | Line2D.Float 使用 float 坐标指定的线段。
class | Path2D Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。
static class | Path2D.Double Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
static class | Path2D.Float Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
class | QuadCurve2D QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。
static class | QuadCurve2D.Double 使用 double 坐标指定的二次参数曲线段。
static class | QuadCurve2D.Float 使用 float 坐标指定的二次参数曲线段。
class | Rectangle2D Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。
class | RectangularShape RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。
class | RoundRectangle2D RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

返回 Shape 的 java.awt.geom 中的方法
Shape | Path2D.createTransformedShape(AffineTransform at) 返回一个表示此 Path2D 变换形式的新 Shape。
Shape | AffineTransform.createTransformedShape(Shape pSrc) 返回新的 Shape 对象，它在通过此变换之后，由指定 Shape 的几何形状定义。

参数类型为 Shape 的 java.awt.geom 中的方法
void | Path2D.append(Shape s, boolean connect) 将指定 Shape 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
Shape | AffineTransform.createTransformedShape(Shape pSrc) 返回新的 Shape 对象，它在通过此变换之后，由指定 Shape 的几何形状定义。

参数类型为 Shape 的 java.awt.geom 中的构造方法
Area(Shape s)
Area 类可以根据指定的 Shape 对象创建区域几何形状。
GeneralPath(Shape s)
根据任意 Shape 对象构造一个新 GeneralPath 对象。
Path2D.Double(Shape s)
根据任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Double(Shape s, AffineTransform at)
根据由 AffineTransform 对象变换的任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Float(Shape s)
根据任意 Shape 对象构造一个新的单精度 Path2D 对象。
Path2D.Float(Shape s, AffineTransform at)
根据 AffineTransform 对象变换的任意 Shape 对象构造一个新的单精度 Path2D 对象。

java.awt.image.renderable 中 Shape 的使用

返回 Shape 的 java.awt.image.renderable 中的方法
 Shape RenderContext.getAreaOfInterest()
获取当前包含在 RenderContext 中的感兴趣区域。

参数类型为 Shape 的 java.awt.image.renderable 中的方法
 void RenderContext.setAreaOfInterest(Shape newAoi)
设置当前的感兴趣区域。

参数类型为 Shape 的 java.awt.image.renderable 中的构造方法
RenderContext(AffineTransform usr2dev, Shape aoi)
构造具有给定变换和感兴趣区域的 RenderContext。
RenderContext(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
构造具有给定转换的 RenderContext。

javax.swing 中 Shape 的使用

返回 Shape 的 javax.swing 中的方法
 Shape DebugGraphics.getClip()
重写 Graphics.getClip。

参数类型为 Shape 的 javax.swing 中的方法
 void DebugGraphics.setClip(Shape clip)
重写 Graphics.setClip。

javax.swing.plaf.basic 中 Shape 的使用

实现 Shape 的 javax.swing.plaf.basic 中的类
static class BasicTextUI.BasicCaret

javax.swing.text 中 Shape 的使用

实现 Shape 的 javax.swing.text 中的类
 class DefaultCaret
插入符的默认实现。

返回 Shape 的 javax.swing.text 中的方法
protected Shape | FieldView.adjustAllocation(Shape a) 调整给定视图的分配区域，使其适合文本字段的分配区域。
protected Shape | AsyncBoxView.ChildLocator.getChildAllocation(int index) 获取用于子视图的分配区域。
Shape | AsyncBoxView.getChildAllocation(int index, Shape a) 获取给定子视图的分配区域。
Shape | AsyncBoxView.ChildLocator.getChildAllocation(int index, Shape a) 获取用于子视图的分配区域。
Shape | BoxView.getChildAllocation(int index, Shape a) 获取给定子视图的分配。
Shape | CompositeView.getChildAllocation(int index, Shape a) 获取要在其中呈现的给定子视图的分配区域。
Shape | View.getChildAllocation(int index, Shape a) 获取给定子视图的分配。
abstract Shape | GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | CompositeView.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | View.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
Shape | View.modelToView(int pos, Shape a) 已过时。
Shape | AsyncBoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | BoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
Shape | ComponentView.modelToView(int pos, Shape a, Position.Bias b) 提供模型坐标空间到视图坐标空间的映射。
Shape | CompositeView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | GlyphView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | IconView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PasswordView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | FieldView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PlainView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract Shape | View.modelToView(int pos, Shape a, Position.Bias b) 为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
Shape | DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)

参数类型为 Shape 的 javax.swing.text 中的方法
protected Shape | FieldView.adjustAllocation(Shape a) 调整给定视图的分配区域，使其适合文本字段的分配区域。
View | ParagraphView.breakView(int axis, float len, Shape a) 以给定的长度在给定的轴上拆分此视图。
void | FlowView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | GlyphView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | LabelView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | ParagraphView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | WrappedPlainView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出文档中此视图负责的位置上的属性已发生更改的通知。
void | PlainView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | View.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
protected void | PlainView.damageLineRange(int line0, int line1, Shape a, Component host) 重新绘制给定的行范围。
protected void | BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
protected void | View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
protected void | View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f) 将 DocumentEvent 转发到给定的子视图。
Shape | AsyncBoxView.getChildAllocation(int index, Shape a) 获取给定子视图的分配区域。
Shape | AsyncBoxView.ChildLocator.getChildAllocation(int index, Shape a) 获取用于子视图的分配区域。
Shape | BoxView.getChildAllocation(int index, Shape a) 获取给定子视图的分配。
Shape | CompositeView.getChildAllocation(int index, Shape a) 获取要在其中呈现的给定子视图的分配区域。
Shape | View.getChildAllocation(int index, Shape a) 获取给定子视图的分配。
protected int | ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x) 返回最接近 x 处的模型位置。
protected Rectangle | CompositeView.getInsideAllocation(Shape a) 将分配给视图的不可变分配区域转换为表示内部分配区域的可变分配区域（即给定分配区域的边界，其顶部、左部、底部和右部的 insets 已移除）。
protected int | CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在东或在西。
protected int | CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在北也可以在南。
protected int | ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 在东或西方向返回光标的下一个可视位置。
int | GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
String | View.getToolTipText(float x, float y, Shape allocation) 返回提定位置的工具提示文本。
int | View.getViewIndex(float x, float y, Shape allocation) 返回表示视图中给定位置的子视图索引。
int | AsyncBoxView.ChildLocator.getViewIndexAtPoint(float x, float y, Shape a) 获取位于给定点的子视图索引。
void | FlowView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | GlyphView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | WrappedPlainView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出在文档中此视图负责的位置插入了某些内容的通知。
void | ZoneView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出在文档中此视图负责的位置插入了某些内容的通知。
void | FieldView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | View.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
protected Rectangle | PlainView.lineToRect(Shape a, int line) 确定表示给定行的矩形。
abstract Shape | GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | CompositeView.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | View.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
Shape | View.modelToView(int pos, Shape a) 已过时。
Shape | AsyncBoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | BoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
Shape | ComponentView.modelToView(int pos, Shape a, Position.Bias b) 提供模型坐标空间到视图坐标空间的映射。
Shape | CompositeView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | GlyphView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | IconView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PasswordView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | FieldView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PlainView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract Shape | View.modelToView(int pos, Shape a, Position.Bias b) 为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
abstract void | GlyphView.GlyphPainter.paint(GlyphView v, Graphics g, Shape a, int p0, int p1) 绘制表示给定范围的字形。
void | DefaultHighlighter.DefaultHighlightPainter.paint(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c) 绘制高亮显示区域。
void | Highlighter.HighlightPainter.paint(Graphics g, int p0, int p1, Shape bounds, JTextComponent c) 呈现高亮显示。
void | AsyncBoxView.paint(Graphics g, Shape alloc) 使用给定的分配和呈现表面呈现该视图。
void | BoxView.paint(Graphics g, Shape allocation) 使用该面给定的呈现面和区域呈现 BoxView。
void | ComponentView.paint(Graphics g, Shape a) 真正的绘制行为自然来源于组件与其父容器（容纳此视图的同一容器）之间的关联。
void | GlyphView.paint(Graphics g, Shape a) 呈现一部分运行的文本样式。
void | IconView.paint(Graphics g, Shape a) 绘制图标。
void | ParagraphView.paint(Graphics g, Shape a) 使用给定的呈现面和该面上的区域进行呈现。
void | WrappedPlainView.paint(Graphics g, Shape a) 使用给定的呈现表面和表现上的区域来呈现。
void | FieldView.paint(Graphics g, Shape a) 使用给定呈现面和该表面的区域呈现。
void | PlainView.paint(Graphics g, Shape a) 使用给定呈现面和该表面的区域呈现。
abstract void | View.paint(Graphics g, Shape allocation) 使用给定的呈现表面和该表面上的区域来呈现。
Shape | DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
void | DefaultHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当要呈现叶 View （例如，LabelView）时，要调用此方法。
abstract void | LayeredHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当叶 View（如 LabelView）呈现时，它们应调用此方法。
void | FlowView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知从文档中此视图负责的某个位置已移除内容。
void | GlyphView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。
void | WrappedPlainView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出从文档中此视图负责的位置移除了某些内容的通知。
void | ZoneView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
void | FieldView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | View.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
protected void | AsyncBoxView.ChildLocator.setAllocation(Shape a) 将当前已分配的形状复制到用于存储当前分配区域的 Rectangle 中。
protected void | PlainView.updateDamage(DocumentEvent changes, Shape a, ViewFactory f) 重新绘制给定文档事件覆盖的更改区域。
protected void | AsyncBoxView.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接收的更改通知。
protected void | View.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接受的更改通知。
int | View.viewToModel(float x, float y, Shape a) 已过时。
int | AsyncBoxView.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | BoxView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | ComponentView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | CompositeView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型的逻辑坐标空间的映射。
int | GlyphView.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | IconView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | PasswordView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | FieldView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | PlainView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
abstract int | View.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射。
abstract int | GlyphView.GlyphPainter.viewToModel(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。

javax.swing.text.html 中 Shape 的使用

返回 Shape 的 javax.swing.text.html 中的方法
 Shape ImageView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

参数类型为 Shape 的 javax.swing.text.html 中的方法
void | BlockView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
void | ImageView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 当 Elements 属性已更改时调用。
void | InlineView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
String | ImageView.getToolTipText(float x, float y, Shape allocation) 对于图像，工具提示文本来自于 ALT 属性指定的文本。
void | InlineView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
Shape | ImageView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
void | BlockView.paint(Graphics g, Shape allocation) 使用给定呈现面和该表面的区域呈现。
void | ImageView.paint(Graphics g, Shape a) 绘制 View。
void | ListView.paint(Graphics g, Shape allocation) 使用给定呈现面和该表面的区域呈现。
void | ParagraphView.paint(Graphics g, Shape a) 使用给定的呈现面和该面上的区域进行呈现。
void | InlineView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。
int | ImageView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.SplashScreen 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.SplashScreen
的使用

使用 SplashScreen 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 SplashScreen 的使用

返回 SplashScreen 的 java.awt 中的方法
static SplashScreen SplashScreen.getSplashScreen()
返回用于 Java 启动闪现屏幕控制的 SplashScreen 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.Stroke 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Stroke
的使用

使用 Stroke 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Stroke 的使用

实现 Stroke 的 java.awt 中的类
 class BasicStroke
BasicStroke 类定义针对图形图元轮廓呈现属性的一个基本集合，这些图元使用 Graphics2D 对象呈现，而该对象的 Stroke 属性设置为此 BasicStroke。

返回 Stroke 的 java.awt 中的方法
abstract  Stroke Graphics2D.getStroke()
返回 Graphics2D 上下文中的当前 Stroke

参数类型为 Stroke 的 java.awt 中的方法
abstract  void Graphics2D.setStroke(Stroke s)
为 Graphics2D 上下文设置 Stroke

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.SystemColor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.SystemColor
的使用

使用 SystemColor 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 SystemColor 的使用

声明为 SystemColor 的 java.awt 中的字段
static SystemColor | SystemColor.activeCaption 为当前活动窗口的窗口标题提供的背景色。
static SystemColor | SystemColor.activeCaptionBorder 为当前活动窗口的边框提供的颜色。
static SystemColor | SystemColor.activeCaptionText 为当前活动窗口的窗口标题文本提供的颜色。
static SystemColor | SystemColor.control 为控制面板和控制对象（比如按钮）提供的颜色。
static SystemColor | SystemColor.controlDkShadow 为 3D 控制对象（比如按钮）的加黑阴影区域提供的颜色。
static SystemColor | SystemColor.controlHighlight 为 3D 控制对象（比如按钮）的亮区提供的颜色。
static SystemColor | SystemColor.controlLtHighlight 为 3D 控制对象（比如按钮）的高亮区域提供的颜色。
static SystemColor | SystemColor.controlShadow 为 3D 控制对象（比如按钮）的阴影区域提供的颜色。
static SystemColor | SystemColor.controlText 为控制面板和控制对象（比如按钮）的文本提供的颜色。
static SystemColor | SystemColor.desktop 为桌面背景提供的颜色。
static SystemColor | SystemColor.inactiveCaption 为非活动窗口的窗口标题提供的背景色。
static SystemColor | SystemColor.inactiveCaptionBorder 为非活动窗口的边框提供的颜色。
static SystemColor | SystemColor.inactiveCaptionText 为非活动窗口的窗口标题文本提供的颜色。
static SystemColor | SystemColor.info 为工具栏提示或定点帮助提供的背景色。
static SystemColor | SystemColor.infoText 为工具栏提示或定点帮助的文本提供的颜色。
static SystemColor | SystemColor.menu 为菜单提供的背景色。
static SystemColor | SystemColor.menuText 为菜单文本提供的颜色。
static SystemColor | SystemColor.scrollbar 为滚动条提供的背景色。
static SystemColor | SystemColor.text 为文本控制对象（比如文本字段和组合框）提供的背景色。
static SystemColor | SystemColor.textHighlight 为选则项（比如菜单、组合框和文本）提供的背景色。
static SystemColor | SystemColor.textHighlightText 为选则项（比如菜单、组合框和文本）的文本提供的颜色。
static SystemColor | SystemColor.textInactiveText 为非活动项（比如菜单中的项）的文本提供的颜色。
static SystemColor | SystemColor.textText 为文本控制对象（比如文本字段和组合框）的文本提供的颜色。
static SystemColor | SystemColor.window 为窗口的内部区域提供的背景色。
static SystemColor | SystemColor.windowBorder 为窗口内部区域的边框提供的颜色。
static SystemColor | SystemColor.windowText 为窗口内部区域的文本提供的颜色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.SystemTray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.SystemTray
的使用

使用 SystemTray 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 SystemTray 的使用

返回 SystemTray 的 java.awt 中的方法
static SystemTray SystemTray.getSystemTray()
获取表示桌面托盘区的 SystemTray 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.TextArea 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextArea
的使用

使用 TextArea 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TextArea 的使用

参数类型为 TextArea 的 java.awt 中的方法
protected abstract  java.awt.peer.TextAreaPeer Toolkit.createTextArea(TextArea target)
使用指定同位体接口创建此工具包的 TextArea 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.TextArea.AccessibleAWTTextArea 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextArea.AccessibleAWTTextArea
的使用

没有 java.awt.TextArea.AccessibleAWTTextArea 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.TextComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextComponent
的使用

使用 TextComponent 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TextComponent 的使用

java.awt 中 TextComponent 的子类
class | TextArea TextArea 对象是显示文本的多行区域。
class | TextField TextField 对象是允许编辑单行文本的文本组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.TextComponent.AccessibleAWTTextComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextComponent.AccessibleAWTTextComponent
的使用

使用 TextComponent.AccessibleAWTTextComponent 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TextComponent.AccessibleAWTTextComponent 的使用

java.awt 中 TextComponent.AccessibleAWTTextComponent 的子类
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.TextField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextField
的使用

使用 TextField 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TextField 的使用

参数类型为 TextField 的 java.awt 中的方法
protected abstract  java.awt.peer.TextFieldPeer Toolkit.createTextField(TextField target)
使用指定同位体接口创建此工具包的 TextField 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.TextField.AccessibleAWTTextField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextField.AccessibleAWTTextField
的使用

没有 java.awt.TextField.AccessibleAWTTextField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.TexturePaint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TexturePaint
的使用

没有 java.awt.TexturePaint 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Toolkit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Toolkit
的使用

使用 Toolkit 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Toolkit 的使用

返回 Toolkit 的 java.awt 中的方法
static Toolkit | Toolkit.getDefaultToolkit() 获取默认工具包。
Toolkit | Window.getToolkit() 返回此窗体的工具包。
Toolkit | Component.getToolkit() 获取此组件的工具包。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.Transparency 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Transparency
的使用

使用 Transparency 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

java.awt 中 Transparency 的使用

java.awt 中 Transparency 的子接口
 interface Paint
此 Paint 接口定义如何为 Graphics2D 操作生成颜色模式。

实现 Transparency 的 java.awt 中的类
class | Color Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
class | GradientPaint GradientPaint 类提供了使用线性颜色渐变模式填充 Shape 的方法。
class | LinearGradientPaint LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。
class | MultipleGradientPaint 这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。
class | RadialGradientPaint RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。
class | SystemColor 封装表示系统中本机 GUI 对象颜色的象征性颜色的类。
class | TexturePaint TexturePaint 类提供一种用被指定为 BufferedImage 的纹理填充 Shape 的方式。

java.awt.image 中 Transparency 的使用

实现 Transparency 的 java.awt.image 中的类
class | BufferedImage BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。
class | ColorModel 此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。
class | ComponentColorModel 使用像素值将颜色和 alpha 信息表示为独立样本的 ColorModel 类，该类以独立的数据元素存储每个样本。
class | DirectColorModel DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。
class | IndexColorModel IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。
class | PackedColorModel PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。
class | VolatileImage VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。

javax.swing.plaf 中 Transparency 的使用

实现 Transparency 的 javax.swing.plaf 中的类
 class ColorUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.TrayIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TrayIcon
的使用

使用 TrayIcon 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TrayIcon 的使用

返回 TrayIcon 的 java.awt 中的方法
 TrayIcon[] SystemTray.getTrayIcons()
返回由此应用程序添加到托盘中的所有图标的数组。

参数类型为 TrayIcon 的 java.awt 中的方法
void | SystemTray.add(TrayIcon trayIcon) 将 TrayIcon 添加到 SystemTray。
void | SystemTray.remove(TrayIcon trayIcon) 从 SystemTray 中移除指定的 TrayIcon。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.TrayIcon.MessageType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TrayIcon.MessageType
的使用

使用 TrayIcon.MessageType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TrayIcon.MessageType 的使用

返回 TrayIcon.MessageType 的 java.awt 中的方法
static TrayIcon.MessageType | TrayIcon.MessageType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static TrayIcon.MessageType[] | TrayIcon.MessageType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 TrayIcon.MessageType 的 java.awt 中的方法
 void TrayIcon.displayMessage(String caption, String text, TrayIcon.MessageType messageType)
在托盘图标附近显示弹出消息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Window 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Window
的使用

使用 Window 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 Window 的使用

java.awt 中 Window 的子类
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。

返回 Window 的 java.awt 中的方法
Window | KeyboardFocusManager.getActiveWindow() 如果活动 Window 与调用线程位于同一个上下文中，则返回活动 Window。
Window | KeyboardFocusManager.getFocusedWindow() 如果聚焦窗口与调用线程位于同一个上下文中，则返回聚焦窗口。
Window | GraphicsDevice.getFullScreenWindow() 如果设备处于全屏模式，则返回表示全屏窗口的 Window 对象。
protected Window | KeyboardFocusManager.getGlobalActiveWindow() 返回活动 Window，即使调用线程处于活动 Window 之外的上下文中。
protected Window | KeyboardFocusManager.getGlobalFocusedWindow() 返回聚焦 Window，即使调用线程处于聚焦 Window 之外的上下文中。
Window[] | Window.getOwnedWindows() 返回包含此窗口当前拥有的所有窗口的数组。
Window | Window.getOwner() 返回此窗口的所有者。
static Window[] | Window.getOwnerlessWindows() 返回一个数组，该数组由此应用程序创建的所有没有所有者的 Window 组成。
static Window[] | Window.getWindows() 返回一个数组，该数组由此应用程序创建的所有 Window（包括被拥有的和不被拥有的）组成。

参数类型为 Window 的 java.awt 中的方法
protected abstract java.awt.peer.WindowPeer | Toolkit.createWindow(Window target) 使用指定同位体接口创建此工具包的 Window 实现。
Component | FocusTraversalPolicy.getInitialComponent(Window window) 返回第一次将窗口设置为可见时，应该接收焦点的 Component。
void | GraphicsDevice.setFullScreenWindow(Window w) 进入全屏模式，或返回窗口化模式。
protected void | KeyboardFocusManager.setGlobalActiveWindow(Window activeWindow) 设置活动 Window。
protected void | KeyboardFocusManager.setGlobalFocusedWindow(Window focusedWindow) 设置聚焦 Window。

参数类型为 Window 的 java.awt 中的构造方法
Dialog(Window owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Window 和一个空标题。
Dialog(Window owner, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定所有者 Window、模式和一个空标题。
Dialog(Window owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Window 和标题。
Dialog(Window owner, String title, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题和模式。
Dialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。
Window(Window owner)
构造一个新的、最初不可见的窗口，使用指定 Window 作为其所有者。
Window(Window owner, GraphicsConfiguration gc)
构造一个新的、最初不可见的窗口，使用指定的所有者 Window 和屏幕设备的 GraphicsConfiguration。

java.awt.event 中 Window 的使用

返回 Window 的 java.awt.event 中的方法
Window | WindowEvent.getOppositeWindow() 返回在此焦点或活动性变化中所涉及的其他 Window。
Window | WindowEvent.getWindow() 返回事件的发起方。

参数类型为 Window 的 java.awt.event 中的构造方法
WindowEvent(Window source, int id)
构造一个 WindowEvent 对象。
WindowEvent(Window source, int id, int oldState, int newState)
构造一个具有指定的以前和新窗口状态的 WindowEvent 对象。
WindowEvent(Window source, int id, Window opposite)
构造一个具有指定对应 Window 的 WindowEvent 对象。
WindowEvent(Window source, int id, Window opposite, int oldState, int newState)
构造一个 WindowEvent 对象。

java.awt.im.spi 中 Window 的使用

返回 Window 的 java.awt.im.spi 中的方法
 Window InputMethodContext.createInputMethodWindow(String title, boolean attachToInputContext)
创建输入方法使用的顶层窗口。

javax.swing 中 Window 的使用

javax.swing 中 Window 的子类
class | JDialog 创建对话框窗口的主要类。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

返回 Window 的 javax.swing 中的方法
static Window | SwingUtilities.getWindowAncestor(Component c) 返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
static Window | SwingUtilities.windowForComponent(Component c) 返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。

参数类型为 Window 的 javax.swing 中的方法
 void RepaintManager.addDirtyRegion(Window window, int x, int y, int w, int h)
将 window 添加到需要重绘的 Component 列表。

参数类型为 Window 的 javax.swing 中的构造方法
JDialog(Window owner)
创建一个具有指定所有者 Window 和空标题的无模式对话框。
JDialog(Window owner, Dialog.ModalityType modalityType)
创建一个具有指定所有者 Window、模式和空标题的对话框。
JDialog(Window owner, String title)
创建一个具有指定标题和所有者 Window 的无模式对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType)
创建一个具有指定标题、所有者 Window 和模式的对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。
JWindow(Window owner)
使用指定的所有者窗口创建窗口。
JWindow(Window owner, GraphicsConfiguration gc)
使用屏幕设备的指定所有者窗口和 GraphicsConfiguration 创建窗口。

javax.swing.plaf.basic 中 Window 的使用

javax.swing.plaf.basic 中 Window 的子类
protected  class BasicToolBarUI.DragWindow

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.Window.AccessibleAWTWindow 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Window.AccessibleAWTWindow
的使用

使用 Window.AccessibleAWTWindow 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Window.AccessibleAWTWindow 的使用

java.awt 中 Window.AccessibleAWTWindow 的子类
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。

javax.swing 中 Window.AccessibleAWTWindow 的使用

javax.swing 中 Window.AccessibleAWTWindow 的子类
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.awt.color (Java 2 Platform SE 6)

 java.awt.color
类
ColorSpace
ICC_ColorSpace
ICC_Profile
ICC_ProfileGray
ICC_ProfileRGB
异常
CMMException
ProfileDataException


类 java.awt.color.CMMException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.CMMException
的使用

没有 java.awt.color.CMMException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.color.ColorSpace 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ColorSpace
的使用

使用 ColorSpace 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。

java.awt 中 ColorSpace 的使用

返回 ColorSpace 的 java.awt 中的方法
 ColorSpace Color.getColorSpace()
返回此 Color 的 ColorSpace。

参数类型为 ColorSpace 的 java.awt 中的方法
float[] | Color.getColorComponents(ColorSpace cspace, float[] compArray) 根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的颜色分量。
float[] | Color.getComponents(ColorSpace cspace, float[] compArray) 根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的 alpha 分量。

参数类型为 ColorSpace 的 java.awt 中的构造方法
Color(ColorSpace cspace, float[] components, float alpha)
创建具有 float 数组中指定的颜色分量和指定的 alpha 值的指定 ColorSpace 中的颜色。

java.awt.color 中 ColorSpace 的使用

java.awt.color 中 ColorSpace 的子类
 class ICC_ColorSpace
ICC_ColorSpace 类是抽象 ColorSpace 类的实现。

返回 ColorSpace 的 java.awt.color 中的方法
static ColorSpace ColorSpace.getInstance(int colorspace)
返回表示特定于预定义颜色空间之一的 ColorSpace。

java.awt.image 中 ColorSpace 的使用

返回 ColorSpace 的 java.awt.image 中的方法
 ColorSpace ColorModel.getColorSpace()
返回与此 ColorModel 相关的 ColorSpace。

参数类型为 ColorSpace 的 java.awt.image 中的构造方法
ColorConvertOp(ColorSpace srcCspace, ColorSpace dstCspace, RenderingHints hints)
根据两个 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ColorSpace cspace, RenderingHints hints)
根据 ColorSpace 对象构造新的 ColorConvertOp。
ColorModel(int pixel_bits, int[] bits, ColorSpace cspace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
构造将像素值转换为颜色/alpha 分量的 ColorModel。
ComponentColorModel(ColorSpace colorSpace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
根据指定参数构造 ComponentColorModel。
ComponentColorModel(ColorSpace colorSpace, int[] bits, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
根据指定参数构造 ComponentColorModel。
DirectColorModel(ColorSpace space, int bits, int rmask, int gmask, int bmask, int amask, boolean isAlphaPremultiplied, int transferType)
根据指定参数构造 DirectColorModel。
PackedColorModel(ColorSpace space, int bits, int[] colorMaskArray, int alphaMask, boolean isAlphaPremultiplied, int trans, int transferType)
根据颜色掩码数组（指定了 int 像素表示形式中哪些位包含每个颜色的采样）和 alpha 掩码来构造一个 PackedColorModel。
PackedColorModel(ColorSpace space, int bits, int rmask, int gmask, int bmask, int amask, boolean isAlphaPremultiplied, int trans, int transferType)
根据指定的掩码构造一个 PackedColorModel，该掩码指示 int 像素表示形式中的哪些位包含 alpha、红色、绿色和蓝色采样。

javax.imageio 中 ColorSpace 的使用

参数类型为 ColorSpace 的 javax.imageio 中的方法
static ImageTypeSpecifier | ImageTypeSpecifier.createBanded(ColorSpace colorSpace, int[] bankIndices, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied) 返回带状图像格式的说明符，它将使用 ComponentColorModel 和 BandedSampleModel 来存储单独数组中的每个通道。
static ImageTypeSpecifier | ImageTypeSpecifier.createInterleaved(ColorSpace colorSpace, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied) 返回交错图像格式的说明符，它将使用 ComponentColorModel 和 PixelInterleavedSampleModel 来存储单个 byte、short 或 int 值形式的每个像素组件。
static ImageTypeSpecifier | ImageTypeSpecifier.createPacked(ColorSpace colorSpace, int redMask, int greenMask, int blueMask, int alphaMask, int transferType, boolean isAlphaPremultiplied) 返回压缩图像格式的说明符，它将使用 DirectColorModel 和一个压缩的 SampleModel 来存储压缩成单个 byte、short 或 int 值的像素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.color.ICC_ColorSpace 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ICC_ColorSpace
的使用

没有 java.awt.color.ICC_ColorSpace 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.color.ICC_Profile 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ICC_Profile
的使用

使用 ICC_Profile 的软件包
java.awt.color | 提供用于颜色空间的类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt.color 中 ICC_Profile 的使用

java.awt.color 中 ICC_Profile 的子类
class | ICC_ProfileGray ICC_Profile 类的子类，表示满足以下标准的配置文件：配置文件的颜色空间类型是 TYPE_GRAY，并且配置文件包括 grayTRCTag 和 mediaWhitePointTag 标记。
class | ICC_ProfileRGB ICC_ProfileRGB 类是 ICC_Profile 类的子类，它表示满足以下标准的配置文件： 配置文件的颜色空间类型是 RGB。

返回 ICC_Profile 的 java.awt.color 中的方法
static ICC_Profile | ICC_Profile.getInstance(byte[] data) 构造一个与 byte 数组中的数据相对应的 ICC_Profile 对象。
static ICC_Profile | ICC_Profile.getInstance(InputStream s) 构造一个与 InputStream 中的数据相对应的 ICC_Profile。
static ICC_Profile | ICC_Profile.getInstance(int cspace) 构造一个与 ColorSpace 类所定义的指定颜色空间之一（如 CS_sRGB）相对应的 ICC_Profile。
static ICC_Profile | ICC_Profile.getInstance(String fileName) 构造一个与文件中的数据相对应的 ICC_Profile。
ICC_Profile | ICC_ColorSpace.getProfile() 返回此 ICC_ColorSpace 的 ICC_Profile。

参数类型为 ICC_Profile 的 java.awt.color 中的构造方法
ICC_ColorSpace(ICC_Profile profile)
由 ICC_Profile 对象构造一个新的 ICC_ColorSpace。

java.awt.image 中 ICC_Profile 的使用

返回 ICC_Profile 的 java.awt.image 中的方法
 ICC_Profile[] ColorConvertOp.getICC_Profiles()
返回用于构造此 ColorConvertOp 的 ICC_Profiles 的数组。

参数类型为 ICC_Profile 的 java.awt.image 中的构造方法
ColorConvertOp(ICC_Profile[] profiles, RenderingHints hints)
根据 ICC_Profiles 的数组构造新的 ColorConvertOp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.color.ICC_ProfileGray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ICC_ProfileGray
的使用

没有 java.awt.color.ICC_ProfileGray 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.color.ICC_ProfileRGB 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ICC_ProfileRGB
的使用

没有 java.awt.color.ICC_ProfileRGB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.color.ProfileDataException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ProfileDataException
的使用

没有 java.awt.color.ProfileDataException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.awt.datatransfer (Java 2 Platform SE 6)

 java.awt.datatransfer
接口
ClipboardOwner
FlavorListener
FlavorMap
FlavorTable
Transferable
类
Clipboard
DataFlavor
FlavorEvent
StringSelection
SystemFlavorMap
异常
MimeTypeParseException
UnsupportedFlavorException


类 java.awt.datatransfer.Clipboard 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.Clipboard
的使用

使用 Clipboard 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Clipboard 的使用

返回 Clipboard 的 java.awt 中的方法
abstract Clipboard | Toolkit.getSystemClipboard() 获取系统 Clipboard 的一个实例，该 Clipboard 可作为本机平台提供的剪贴板工具的接口。
Clipboard | Toolkit.getSystemSelection() 以 Clipboard 对象的形式获取系统选择的一个实例。

java.awt.datatransfer 中 Clipboard 的使用

参数类型为 Clipboard 的 java.awt.datatransfer 中的方法
void | StringSelection.lostOwnership(Clipboard clipboard, Transferable contents)
void | ClipboardOwner.lostOwnership(Clipboard clipboard, Transferable contents) 通知此对象，它已不再是剪贴板所有者。

参数类型为 Clipboard 的 java.awt.datatransfer 中的构造方法
FlavorEvent(Clipboard source)
构造一个 FlavorEvent 对象。

javax.swing 中 Clipboard 的使用

参数类型为 Clipboard 的 javax.swing 中的方法
 void TransferHandler.exportToClipboard(JComponent comp, Clipboard clip, int action)
导致从给定组件到给定剪贴板的传输。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.datatransfer.ClipboardOwner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.datatransfer.ClipboardOwner
的使用

使用 ClipboardOwner 的软件包
java.awt.datatransfer 提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.datatransfer 中 ClipboardOwner 的使用

实现 ClipboardOwner 的 java.awt.datatransfer 中的类
 class StringSelection
实现传输 String 所需能力的 Transferable。

声明为 ClipboardOwner 的 java.awt.datatransfer 中的字段
protected  ClipboardOwner Clipboard.owner

参数类型为 ClipboardOwner 的 java.awt.datatransfer 中的方法
 void Clipboard.setContents(Transferable contents, ClipboardOwner owner)
将剪贴板的当前内容设置到指定的 transferable 对象，并将指定的剪贴板所有者作为新内容的所有者注册。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.datatransfer.DataFlavor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.DataFlavor
的使用

使用 DataFlavor 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.activation |
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt.datatransfer 中 DataFlavor 的使用

声明为 DataFlavor 的 java.awt.datatransfer 中的字段
static DataFlavor | DataFlavor.imageFlavor DataFlavor 表示 Java Image 类，其中：
static DataFlavor | DataFlavor.javaFileListFlavor 要将文件列表传入 Java（及底层平台）或从中传出，需要使用此类型/子类型的 DataFlavor 和 java.util.List 的表示形式类。
static DataFlavor | DataFlavor.plainTextFlavor 已过时。 从 1.3 开始。使用 DataFlavor.getReaderForText(Transferable) 代替 Transferable.getTransferData(DataFlavor.plainTextFlavor)。
static DataFlavor | DataFlavor.stringFlavor DataFlavor 表示 Java Unicode String 类，其中：

返回 DataFlavor 的 java.awt.datatransfer 中的方法
static DataFlavor SystemFlavorMap.decodeDataFlavor(String nat)
解码 String native 以用作 DataFlavor。
 DataFlavor[] Clipboard.getAvailableDataFlavors()
返回 DataFlavor 的数组，其中提供了此剪贴板的当前内容。
static DataFlavor DataFlavor.getTextPlainUnicodeFlavor()
返回表示具有 Unicode 编码的纯文本的 DataFlavor，其中： representationClass = java.io.InputStream mimeType = "text/plain; charset=<platform default Unicode encoding>" Sun 的 Microsoft Windows 实现使用编码 utf-16le。
 DataFlavor[] StringSelection.getTransferDataFlavors()
返回 flavor 的数组，Transferable 可用该 flavor 提供数据。
 DataFlavor[] Transferable.getTransferDataFlavors()
返回 DataFlavor 对象的数组，指示可用于提供数据的 flavor。
static DataFlavor DataFlavor.selectBestTextFlavor(DataFlavor[] availableFlavors)
从 DataFlavor 数组中选择最佳文本 DataFlavor。

返回变量类型为 DataFlavor 的类型的 java.awt.datatransfer 中的方法
List<DataFlavor> | SystemFlavorMap.getFlavorsForNative(String nat) 返回数据传输子系统可以将指定 String native 转换成的 DataFlavor 的 List。
List<DataFlavor> | FlavorTable.getFlavorsForNative(String nat) 返回与指定 String 对应的 DataFlavor 的 List。
Map<String,DataFlavor> | SystemFlavorMap.getFlavorsForNatives(String[] natives) 返回指定 String native 到其大多数首选 DataFlavor 的 Map。
Map<String,DataFlavor> | FlavorMap.getFlavorsForNatives(String[] natives) 返回指定 String native 到其相应 DataFlavor 的 Map。
Map<DataFlavor,String> | SystemFlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其大多数首选的 String native 的 Map。
Map<DataFlavor,String> | FlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其对应的 String native 的 Map。

参数类型为 DataFlavor 的 java.awt.datatransfer 中的方法
void | SystemFlavorMap.addFlavorForUnencodedNative(String nat, DataFlavor flav) 添加从单个 String native 到单个 DataFlavor 的映射。
void | SystemFlavorMap.addUnencodedNativeForFlavor(DataFlavor flav, String nat) 添加从指定的 DataFlavor（和等于指定 DataFlavor 的所有 DataFlavor）到指定 String native 的映射。
static String | SystemFlavorMap.encodeDataFlavor(DataFlavor flav) 编码 DataFlavor 以用作 String native。
boolean | DataFlavor.equals(DataFlavor that) 测试 DataFlavor 与此 DataFlavor 的相等性。
Object | Clipboard.getData(DataFlavor flavor) 返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。
List<String> | SystemFlavorMap.getNativesForFlavor(DataFlavor flav) 返回数据传输子系统可以将指定 DataFlavor 转换成的 String native 的 List。
List<String> | FlavorTable.getNativesForFlavor(DataFlavor flav) 返回与指定 DataFlavor 对应的 String native 的 List。
Map<DataFlavor,String> | SystemFlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其大多数首选的 String native 的 Map。
Map<DataFlavor,String> | FlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其对应的 String native 的 Map。
Object | StringSelection.getTransferData(DataFlavor flavor) 如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。
Object | Transferable.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示将要被传输的数据。
boolean | Clipboard.isDataFlavorAvailable(DataFlavor flavor) 返回是否能够以指定的 DataFlavor 形式提供此剪贴板的当前内容。
boolean | StringSelection.isDataFlavorSupported(DataFlavor flavor) 返回所请求的 flavor 是否受此 Transferable 支持。
boolean | Transferable.isDataFlavorSupported(DataFlavor flavor) 返回此对象是否支持指定的数据 flavor。
boolean | DataFlavor.isMimeTypeEqual(DataFlavor dataFlavor) 比较两个 DataFlavor 对象的 mimeType。
boolean | DataFlavor.match(DataFlavor that) 测试 DataFlavor 与此 DataFlavor 的相等性。
static DataFlavor | DataFlavor.selectBestTextFlavor(DataFlavor[] availableFlavors) 从 DataFlavor 数组中选择最佳文本 DataFlavor。
void | SystemFlavorMap.setFlavorsForNative(String nat, DataFlavor[] flavors) 放弃指定 String native 的当前映射，而创建指定 DataFlavor 的新映射。
void | SystemFlavorMap.setNativesForFlavor(DataFlavor flav, String[] natives) 放弃指定 DataFlavor 和等于指定 DataFlavor 的所有 DataFlavor 的当前映射，并创建到指定 String native 的新映射。

参数类型为 DataFlavor 的 java.awt.datatransfer 中的构造方法
UnsupportedFlavorException(DataFlavor flavor)
构造一个 UnsupportedFlavorException。

java.awt.dnd 中 DataFlavor 的使用

返回 DataFlavor 的 java.awt.dnd 中的方法
DataFlavor[] | DropTargetDragEvent.getCurrentDataFlavors() 此方法返回来自 DropTargetContext 的当前 DataFlavor。
DataFlavor[] | DropTargetDropEvent.getCurrentDataFlavors() 此方法返回当前的 DataFlavor。
protected DataFlavor[] | DropTargetContext.getCurrentDataFlavors() 获取此操作的 Transferable 操作数的可用 DataFlavor。
DataFlavor[] | DropTargetContext.TransferableProxy.getTransferDataFlavors() 返回一个 DataFlavor 对象数组，指示该数据的 flavor 是否可由封装的 transferable 提供。

返回变量类型为 DataFlavor 的类型的 java.awt.dnd 中的方法
List<DataFlavor> | DropTargetDragEvent.getCurrentDataFlavorsAsList() 此方法以 java.util.List 形式返回当前的 DataFlavor
List<DataFlavor> | DropTargetDropEvent.getCurrentDataFlavorsAsList() 此方法以 java.util.List 形式返回当前可用的 DataFlavor。
protected List<DataFlavor> | DropTargetContext.getCurrentDataFlavorsAsList() 此方法返回 Transferable 操作数当前可用的 DataFlavor，作为一个 java.util.List。

参数类型为 DataFlavor 的 java.awt.dnd 中的方法
Object | DropTargetContext.TransferableProxy.getTransferData(DataFlavor df) 返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。
boolean | DropTargetDragEvent.isDataFlavorSupported(DataFlavor df) 此方法返回一个指示指定的 DataFlavor 是否受支持 boolean 值。
boolean | DropTargetDropEvent.isDataFlavorSupported(DataFlavor df) 此方法返回一个指示指定的 DataFlavor 是否可在源对象中使用的 boolean 值。
protected boolean | DropTargetContext.isDataFlavorSupported(DataFlavor df) 此方法返回一个 boolean 值，指示给定的 DataFlavor 是否受此 DropTargetContext 支持。
boolean | DropTargetContext.TransferableProxy.isDataFlavorSupported(DataFlavor flavor) 返回指定的数据 flavor 是否受封装的 transferable 支持。

javax.accessibility 中 DataFlavor 的使用

返回 DataFlavor 的 javax.accessibility 中的方法
 DataFlavor[] AccessibleStreamable.getMimeTypes()
返回此对象所支持的 MIME 类型的 DataFlavor 对象数组。

参数类型为 DataFlavor 的 javax.accessibility 中的方法
 InputStream AccessibleStreamable.getStream(DataFlavor flavor)
返回 DataFlavor 的 InputStream

javax.activation 中 DataFlavor 的使用

javax.activation 中 DataFlavor 的子类
 class ActivationDataFlavor
ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。

返回 DataFlavor 的 javax.activation 中的方法
DataFlavor[] | DataContentHandler.getTransferDataFlavors() 返回一个 DataFlavor 对象数组，这些对象指示可用于提供数据的 flavor。
DataFlavor[] | DataHandler.getTransferDataFlavors() 返回此数据在其中可用的 DataFlavor。

参数类型为 DataFlavor 的 javax.activation 中的方法
boolean | ActivationDataFlavor.equals(DataFlavor dataFlavor) 将传入的 DataFlavor 与此 DataFlavor 进行比较；调用 isMimeTypeEqual 方法。
Object | DataHandler.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示要传输的数据。
Object | DataContentHandler.getTransferData(DataFlavor df, DataSource ds) 返回一个对象，该对象表示将要传输的数据。
boolean | DataHandler.isDataFlavorSupported(DataFlavor flavor) 返回此对象是否支持指定的数据 flavor。

javax.swing 中 DataFlavor 的使用

返回 DataFlavor 的 javax.swing 中的方法
 DataFlavor[] TransferHandler.TransferSupport.getDataFlavors()
返回此传输的数据 flavor。

参数类型为 DataFlavor 的 javax.swing 中的方法
boolean | TransferHandler.canImport(JComponent comp, DataFlavor[] transferFlavors) 指示一个组件在实际尝试导入给定数据 flavor 的集合之前是否接受其导入。
boolean | TransferHandler.TransferSupport.isDataFlavorSupported(DataFlavor df) 返回是否支持给定的数据 flavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.datatransfer.FlavorEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.FlavorEvent
的使用

使用 FlavorEvent 的软件包
java.awt.datatransfer 提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.datatransfer 中 FlavorEvent 的使用

参数类型为 FlavorEvent 的 java.awt.datatransfer 中的方法
 void FlavorListener.flavorsChanged(FlavorEvent e)
当侦听器的目标 Clipboard 已更改其可用的 DataFlavor 时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.datatransfer.FlavorListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.datatransfer.FlavorListener
的使用

使用 FlavorListener 的软件包
java.awt.datatransfer 提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.datatransfer 中 FlavorListener 的使用

返回 FlavorListener 的 java.awt.datatransfer 中的方法
 FlavorListener[] Clipboard.getFlavorListeners()
返回一组目前在此 Clipboard 上注册的所有 FlavorListener。

参数类型为 FlavorListener 的 java.awt.datatransfer 中的方法
void | Clipboard.addFlavorListener(FlavorListener listener) 注册指定的 FlavorListener，以从此剪贴板接收 FlavorEvent。
void | Clipboard.removeFlavorListener(FlavorListener listener) 移除指定的 FlavorListener，使其不再从此 Clipboard 接收 FlavorEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.datatransfer.FlavorMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.datatransfer.FlavorMap
的使用

使用 FlavorMap 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.datatransfer 中 FlavorMap 的使用

java.awt.datatransfer 中 FlavorMap 的子接口
 interface FlavorTable
放宽传统一对一 Map 限制的 FlavorMap。

实现 FlavorMap 的 java.awt.datatransfer 中的类
 class SystemFlavorMap
SystemFlavorMap 是 "native" (String)（对应于特定于平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的可配置映射。

返回 FlavorMap 的 java.awt.datatransfer 中的方法
static FlavorMap SystemFlavorMap.getDefaultFlavorMap()
返回此线程的 ClassLoader 的默认 FlavorMap。

java.awt.dnd 中 FlavorMap 的使用

返回 FlavorMap 的 java.awt.dnd 中的方法
FlavorMap | DragSource.getFlavorMap() 此方法返回此 DragSource 的 FlavorMap。
FlavorMap | DropTarget.getFlavorMap() 获取与此 DropTarget 关联的 FlavorMap。

参数类型为 FlavorMap 的 java.awt.dnd 中的方法
void | DropTarget.setFlavorMap(FlavorMap fm) 设置 FlavorMap 与此 DropTarget 关联。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 FlavorMap 的 java.awt.dnd 中的构造方法
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.datatransfer.FlavorTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.datatransfer.FlavorTable
的使用

使用 FlavorTable 的软件包
java.awt.datatransfer 提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.datatransfer 中 FlavorTable 的使用

实现 FlavorTable 的 java.awt.datatransfer 中的类
 class SystemFlavorMap
SystemFlavorMap 是 "native" (String)（对应于特定于平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的可配置映射。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.datatransfer.MimeTypeParseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.MimeTypeParseException
的使用

没有 java.awt.datatransfer.MimeTypeParseException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.datatransfer.StringSelection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.StringSelection
的使用

没有 java.awt.datatransfer.StringSelection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.datatransfer.SystemFlavorMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.SystemFlavorMap
的使用

没有 java.awt.datatransfer.SystemFlavorMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.datatransfer.Transferable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.datatransfer.Transferable
的使用

使用 Transferable 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.activation |
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt.datatransfer 中 Transferable 的使用

实现 Transferable 的 java.awt.datatransfer 中的类
 class StringSelection
实现传输 String 所需能力的 Transferable。

声明为 Transferable 的 java.awt.datatransfer 中的字段
protected  Transferable Clipboard.contents

返回 Transferable 的 java.awt.datatransfer 中的方法
 Transferable Clipboard.getContents(Object requestor)
返回表示剪贴板当前内容的 transferable 对象。

参数类型为 Transferable 的 java.awt.datatransfer 中的方法
Reader | DataFlavor.getReaderForText(Transferable transferable) 获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。
void | StringSelection.lostOwnership(Clipboard clipboard, Transferable contents)
void | ClipboardOwner.lostOwnership(Clipboard clipboard, Transferable contents) 通知此对象，它已不再是剪贴板所有者。
void | Clipboard.setContents(Transferable contents, ClipboardOwner owner) 将剪贴板的当前内容设置到指定的 transferable 对象，并将指定的剪贴板所有者作为新内容的所有者注册。

java.awt.dnd 中 Transferable 的使用

实现 Transferable 的 java.awt.dnd 中的类
protected  class DropTargetContext.TransferableProxy
TransferableProxy 是一个帮助器内部类，它实现 Transferable 接口，并用作另一个表示特定 drag-n-drop（拖放）操作数据转换的 Transferable 对象的代理。

声明为 Transferable 的 java.awt.dnd 中的字段
protected  Transferable DropTargetContext.TransferableProxy.transferable
封装的 Transferable 对象。

返回 Transferable 的 java.awt.dnd 中的方法
protected Transferable | DropTargetContext.createTransferableProxy(Transferable t, boolean local) 创建一个代理指定 Transferable 的 TransferableProxy。
Transferable | DragSourceContext.getTransferable() 返回与此 DragSourceContext 关联的 Transferable。
Transferable | DropTargetDragEvent.getTransferable() 此方法返回 Transferable 对象，该对象表示与当前的 drag 操作有关的数据。
Transferable | DropTargetDropEvent.getTransferable() 此方法返回与 drop 相关的 Transferable 对象。
protected Transferable | DropTargetContext.getTransferable() 获取此操作的 Transferable（代理）操作数

参数类型为 Transferable 的 java.awt.dnd 中的方法
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
protected Transferable | DropTargetContext.createTransferableProxy(Transferable t, boolean local) 创建一个代理指定 Transferable 的 TransferableProxy。
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable) 在给定拖动操作的 Cursor 和表示拖动操作源数据的 Transferable 的情况下开始拖动此操作。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 Transferable 的 java.awt.dnd 中的构造方法
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。

javax.activation 中 Transferable 的使用

实现 Transferable 的 javax.activation 中的类
 class DataHandler
DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。

javax.swing 中 Transferable 的使用

返回 Transferable 的 javax.swing 中的方法
protected Transferable | TransferHandler.createTransferable(JComponent c) 创建一个要用作数据传输源的 Transferable。
Transferable | TransferHandler.TransferSupport.getTransferable() 返回与此传输关联的 Transferable。

参数类型为 Transferable 的 javax.swing 中的方法
protected void | TransferHandler.exportDone(JComponent source, Transferable data, int action) 在导出数据之后调用。
Icon | TransferHandler.getVisualRepresentation(Transferable t) 返回一个建立传输外观的对象。
boolean | TransferHandler.importData(JComponent comp, Transferable t) 导致从剪贴板或 DND 放置操作向组件的传输。

参数类型为 Transferable 的 javax.swing 中的构造方法
TransferHandler.TransferSupport(Component component, Transferable transferable)
使用给定组件和 Transferable 创建一个 TransferSupport，对于该 TransferSupport isDrop() 返回 false。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.datatransfer.UnsupportedFlavorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.UnsupportedFlavorException
的使用

使用 UnsupportedFlavorException 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.activation |

java.awt.datatransfer 中 UnsupportedFlavorException 的使用

抛出 UnsupportedFlavorException 的 java.awt.datatransfer 中的方法
Object | Clipboard.getData(DataFlavor flavor) 返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。
Reader | DataFlavor.getReaderForText(Transferable transferable) 获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。
Object | StringSelection.getTransferData(DataFlavor flavor) 如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。
Object | Transferable.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示将要被传输的数据。

java.awt.dnd 中 UnsupportedFlavorException 的使用

抛出 UnsupportedFlavorException 的 java.awt.dnd 中的方法
 Object DropTargetContext.TransferableProxy.getTransferData(DataFlavor df)
返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。

javax.activation 中 UnsupportedFlavorException 的使用

抛出 UnsupportedFlavorException 的 javax.activation 中的方法
Object | DataHandler.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示要传输的数据。
Object | DataContentHandler.getTransferData(DataFlavor df, DataSource ds) 返回一个对象，该对象表示将要传输的数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.awt.dnd (Java 2 Platform SE 6)

 java.awt.dnd
接口
Autoscroll
DragGestureListener
DragSourceListener
DragSourceMotionListener
DropTargetListener
类
DnDConstants
DragGestureEvent
DragGestureRecognizer
DragSource
DragSourceAdapter
DragSourceContext
DragSourceDragEvent
DragSourceDropEvent
DragSourceEvent
DropTarget
DropTarget.DropTargetAutoScroller
DropTargetAdapter
DropTargetContext
DropTargetDragEvent
DropTargetDropEvent
DropTargetEvent
MouseDragGestureRecognizer
异常
InvalidDnDOperationException


接口 java.awt.dnd.Autoscroll 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.dnd.Autoscroll
的使用

没有 java.awt.dnd.Autoscroll 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DnDConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DnDConstants
的使用

没有 java.awt.dnd.DnDConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DragGestureEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragGestureEvent
的使用

使用 DragGestureEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 DragGestureEvent 的使用

参数类型为 DragGestureEvent 的 java.awt 中的方法
abstract  java.awt.dnd.peer.DragSourceContextPeer Toolkit.createDragSourceContextPeer(DragGestureEvent dge)
创建 DragSourceContext 的同位体。

java.awt.dnd 中 DragGestureEvent 的使用

返回 DragGestureEvent 的 java.awt.dnd 中的方法
 DragGestureEvent DragSourceContext.getTrigger()
返回最初触发该拖动的 DragGestureEvent。

参数类型为 DragGestureEvent 的 java.awt.dnd 中的方法
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
void | DragGestureListener.dragGestureRecognized(DragGestureEvent dge) DragGestureRecognizer 已经检测到与平台有关的拖动启动动作，并且正通知此侦听器，以便启动用户操作。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 DragGestureEvent 的 java.awt.dnd 中的构造方法
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.dnd.DragGestureListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.dnd.DragGestureListener
的使用

使用 DragGestureListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 DragGestureListener 的使用

参数类型为 DragGestureListener 的 java.awt 中的方法
<T extends DragGestureRecognizer>
T
Toolkit.createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。

java.awt.dnd 中 DragGestureListener 的使用

声明为 DragGestureListener 的 java.awt.dnd 中的字段
protected  DragGestureListener DragGestureRecognizer.dragGestureListener
与此 DragGestureRecognizer 关联的 DragGestureListener。

参数类型为 DragGestureListener 的 java.awt.dnd 中的方法
 void DragGestureRecognizer.addDragGestureListener(DragGestureListener dgl)
注册一个新的 DragGestureListener。
 DragGestureRecognizer DragSource.createDefaultDragGestureRecognizer(Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，为此 DragSource 实现 DragGestureRecognizer 的默认抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
<T extends DragGestureRecognizer>
T
DragSource.createDragGestureRecognizer(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
 void DragGestureRecognizer.removeDragGestureListener(DragGestureListener dgl)
取消注册当前的 DragGestureListener

参数类型为 DragGestureListener 的 java.awt.dnd 中的构造方法
DragGestureRecognizer(DragSource ds, Component c, int sa, DragGestureListener dgl)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component、此 Drag 和 Drop 操作所支持的操作和一旦检测到拖动开始动作要通知的 DragGestureListener。
MouseDragGestureRecognizer(DragSource ds, Component c, int act, DragGestureListener dgl)
给出 Component c 的 DragSource、要观察的 Component、此拖动操作允许的操作，以及检测到拖动动作时发出通知的 DragGestureListener，构造一个新的 MouseDragGestureRecognizer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DragGestureRecognizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragGestureRecognizer
的使用

使用 DragGestureRecognizer 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 DragGestureRecognizer 的使用

类型参数类型为 DragGestureRecognizer 的 java.awt 中的方法
<T extends DragGestureRecognizer>
T
Toolkit.createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。

java.awt.dnd 中 DragGestureRecognizer 的使用

java.awt.dnd 中 DragGestureRecognizer 的子类
 class MouseDragGestureRecognizer
DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

类型参数类型为 DragGestureRecognizer 的 java.awt.dnd 中的方法
<T extends DragGestureRecognizer>
T
DragSource.createDragGestureRecognizer(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。

返回 DragGestureRecognizer 的 java.awt.dnd 中的方法
DragGestureRecognizer | DragSource.createDefaultDragGestureRecognizer(Component c, int actions, DragGestureListener dgl) 创建一个新的 DragGestureRecognizer，为此 DragSource 实现 DragGestureRecognizer 的默认抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
DragGestureRecognizer | DragGestureEvent.getSourceAsDragGestureRecognizer() 以 DragGestureRecognizer 的形式返回源。

参数类型为 DragGestureRecognizer 的 java.awt.dnd 中的构造方法
DragGestureEvent(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DragSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSource
的使用

使用 DragSource 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 DragSource 的使用

参数类型为 DragSource 的 java.awt 中的方法
<T extends DragGestureRecognizer>
T
Toolkit.createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。

java.awt.dnd 中 DragSource 的使用

声明为 DragSource 的 java.awt.dnd 中的字段
protected  DragSource DragGestureRecognizer.dragSource
与此 DragGestureRecognizer 关联的 DragSource。

返回 DragSource 的 java.awt.dnd 中的方法
static DragSource | DragSource.getDefaultDragSource() 获取与基础平台关联的 DragSource 对象。
DragSource | DragGestureEvent.getDragSource() 返回 DragSource。
DragSource | DragGestureRecognizer.getDragSource() 此方法返回 DragSource，为了进行 Drag 和 Drop 操作，将使用此 DragGestureRecognizer。
DragSource | DragSourceContext.getDragSource() 返回实例化此 DragSourceContext 的 DragSource。

参数类型为 DragSource 的 java.awt.dnd 中的构造方法
DragGestureRecognizer(DragSource ds)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource。
DragGestureRecognizer(DragSource ds, Component c)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource 和此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component。
DragGestureRecognizer(DragSource ds, Component c, int sa)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component 和此 Drag 和 Drop 操作所支持的动作。
DragGestureRecognizer(DragSource ds, Component c, int sa, DragGestureListener dgl)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component、此 Drag 和 Drop 操作所支持的操作和一旦检测到拖动开始动作要通知的 DragGestureListener。
MouseDragGestureRecognizer(DragSource ds)
给出 Component 的 DragSource，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource ds, Component c)
给出 Component c 的 DragSource、要观察的 Component，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource ds, Component c, int act)
给出 Component c 的 DragSource、要观察的 Component，以及此拖动操作允许的操作，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource ds, Component c, int act, DragGestureListener dgl)
给出 Component c 的 DragSource、要观察的 Component、此拖动操作允许的操作，以及检测到拖动动作时发出通知的 DragGestureListener，构造一个新的 MouseDragGestureRecognizer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DragSourceAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSourceAdapter
的使用

没有 java.awt.dnd.DragSourceAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DragSourceContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSourceContext
的使用

使用 DragSourceContext 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceContext 的使用

返回 DragSourceContext 的 java.awt.dnd 中的方法
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
DragSourceContext | DragSourceEvent.getDragSourceContext() 此方法返回引起事件的 DragSourceContext。

参数类型为 DragSourceContext 的 java.awt.dnd 中的构造方法
DragSourceDragEvent(DragSourceContext dsc, int dropAction, int action, int modifiers)
构造一个 DragSourceDragEvent。
DragSourceDragEvent(DragSourceContext dsc, int dropAction, int action, int modifiers, int x, int y)
构造一个具有指定 DragSourceContext、用户放置动作、目标放置动作、修改键和坐标的 DragSourceDragEvent。
DragSourceDropEvent(DragSourceContext dsc)
针对没有引起放置的拖动构造一个 DragSourceDropEvent。
DragSourceDropEvent(DragSourceContext dsc, int action, boolean success)
放置构造一个具有给定 DragSourceContext、放置操作和指示放置是否成功的 boolean 值的 DragSourceDropEvent。
DragSourceDropEvent(DragSourceContext dsc, int action, boolean success, int x, int y)
针对放置构造一个具有给定 DragSourceContext、放置操作、表示放置是否成功的 boolean 值和坐标的 DragSourceDropEvent。
DragSourceEvent(DragSourceContext dsc)
根据一个指定的 DragSourceContext 来构造一个 DragSourceEvent。
DragSourceEvent(DragSourceContext dsc, int x, int y)
根据指定的 DragSourceContext 和光标位置坐标构造一个 DragSourceEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DragSourceDragEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSourceDragEvent
的使用

使用 DragSourceDragEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceDragEvent 的使用

参数类型为 DragSourceDragEvent 的 java.awt.dnd 中的方法
void | DragSourceAdapter.dragEnter(DragSourceDragEvent dsde) 光标的热点进入放置点（与平台相关）时调用该方法。
void | DragSourceContext.dragEnter(DragSourceDragEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragEnter，并将指定的 DragSourceDragEvent 传递给它们。
void | DragSourceListener.dragEnter(DragSourceDragEvent dsde) 光标的热点进入放置点（与平台相关）时调用该方法。
void | DragSourceAdapter.dragMouseMoved(DragSourceDragEvent dsde) 在拖动操作期间，只要移动了鼠标就调用该方法。
void | DragSourceContext.dragMouseMoved(DragSourceDragEvent dsde) 对向与此 DragSourceContext 关联的 DragSource 注册的 DragSourceMotionListener 调用 dragMouseMoved，并将指定的 DragSourceDragEvent 传递给它们。
void | DragSourceMotionListener.dragMouseMoved(DragSourceDragEvent dsde) 只要在拖动操作期间鼠标移动了，就调用该方法。
void | DragSourceAdapter.dragOver(DragSourceDragEvent dsde) 光标的热点在放置点（与平台相关）上移动时调用该方法。
void | DragSourceContext.dragOver(DragSourceDragEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceContext 调用 dragOver，并将指定的 DragSourceDragEvent 传递给它们。
void | DragSourceListener.dragOver(DragSourceDragEvent dsde) 光标的热点在放置点（与平台相关）上移动时调用该方法。
void | DragSourceAdapter.dropActionChanged(DragSourceDragEvent dsde) 当用户修改放置操作时调用该方法。
void | DragSourceContext.dropActionChanged(DragSourceDragEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dropActionChanged，并将指定的 DragSourceDragEvent 传递给它们。
void | DragSourceListener.dropActionChanged(DragSourceDragEvent dsde) 当用户修改放置操作时调用该方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DragSourceDropEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSourceDropEvent
的使用

使用 DragSourceDropEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceDropEvent 的使用

参数类型为 DragSourceDropEvent 的 java.awt.dnd 中的方法
void | DragSourceAdapter.dragDropEnd(DragSourceDropEvent dsde) 调用此方法来通知 Drag 和 Drop 操作已完成。
void | DragSourceContext.dragDropEnd(DragSourceDropEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragDropEnd，并将指定的 DragSourceDropEvent 传递给它们。
void | DragSourceListener.dragDropEnd(DragSourceDropEvent dsde) 调用此方法来通知 Drag 和 Drop 操作已完成。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DragSourceEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSourceEvent
的使用

使用 DragSourceEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceEvent 的使用

java.awt.dnd 中 DragSourceEvent 的子类
class | DragSourceDragEvent 通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。
class | DragSourceDropEvent 通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。

参数类型为 DragSourceEvent 的 java.awt.dnd 中的方法
void | DragSourceAdapter.dragExit(DragSourceEvent dse) 光标的热点离开放置点（与平台相关）时调用该方法。
void | DragSourceContext.dragExit(DragSourceEvent dse) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragExit，并将指定的 DragSourceEvent 传递给它们。
void | DragSourceListener.dragExit(DragSourceEvent dse) 光标的热点离开放置点（与平台相关）时调用该方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.dnd.DragSourceListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.dnd.DragSourceListener
的使用

使用 DragSourceListener 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceListener 的使用

实现 DragSourceListener 的 java.awt.dnd 中的类
class | DragSourceAdapter 用于接收拖动源事件的抽象适配器类。
class | DragSourceContext DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。

返回 DragSourceListener 的 java.awt.dnd 中的方法
 DragSourceListener[] DragSource.getDragSourceListeners()
获得向此 DragSource 注册的所有 DragSourceListener。

参数类型为 DragSourceListener 的 java.awt.dnd 中的方法
void | DragSource.addDragSourceListener(DragSourceListener dsl) 将指定的 DragSourceListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动源事件。
void | DragSourceContext.addDragSourceListener(DragSourceListener dsl) 如果尚未将 DragSourceListener 添加到此 DragSourceContext，则添加一个。
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
void | DragSource.removeDragSourceListener(DragSourceListener dsl) 从此 DragSource 移除指定的 DragSourceListener。
void | DragSourceContext.removeDragSourceListener(DragSourceListener dsl) 从此 DragSourceContext 移除指定的 DragSourceListener。
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 DragSourceListener 的 java.awt.dnd 中的构造方法
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.dnd.DragSourceMotionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.dnd.DragSourceMotionListener
的使用

使用 DragSourceMotionListener 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceMotionListener 的使用

实现 DragSourceMotionListener 的 java.awt.dnd 中的类
class | DragSourceAdapter 用于接收拖动源事件的抽象适配器类。
class | DragSourceContext DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。

返回 DragSourceMotionListener 的 java.awt.dnd 中的方法
 DragSourceMotionListener[] DragSource.getDragSourceMotionListeners()
获得向此 DragSource 注册的所有 DragSourceMotionListener。

参数类型为 DragSourceMotionListener 的 java.awt.dnd 中的方法
void | DragSource.addDragSourceMotionListener(DragSourceMotionListener dsml) 将指定的 DragSourceMotionListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动移动事件。
void | DragSource.removeDragSourceMotionListener(DragSourceMotionListener dsml) 从此 DragSource 移除指定的 DragSourceMotionListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DropTarget 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTarget
的使用

使用 DropTarget 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 DropTarget 的使用

返回 DropTarget 的 java.awt 中的方法
 DropTarget Component.getDropTarget()
获取与此 Component 相关的 DropTarget。

参数类型为 DropTarget 的 java.awt 中的方法
 void Component.setDropTarget(DropTarget dt)
将组件与 DropTarget 相关联。

java.awt.dnd 中 DropTarget 的使用

返回 DropTarget 的 java.awt.dnd 中的方法
 DropTarget DropTargetContext.getDropTarget()
此方法返回与此 DropTargetContext 相关的 DropTarget。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DropTarget.DropTargetAutoScroller 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTarget.DropTargetAutoScroller
的使用

使用 DropTarget.DropTargetAutoScroller 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTarget.DropTargetAutoScroller 的使用

返回 DropTarget.DropTargetAutoScroller 的 java.awt.dnd 中的方法
protected  DropTarget.DropTargetAutoScroller DropTarget.createDropTargetAutoScroller(Component c, Point p)
创建一个嵌入式自动滚动条

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DropTargetAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetAdapter
的使用

没有 java.awt.dnd.DropTargetAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DropTargetContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetContext
的使用

使用 DropTargetContext 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTargetContext 的使用

声明为 DropTargetContext 的 java.awt.dnd 中的字段
protected  DropTargetContext DropTargetEvent.context
与此 DropTargetEvent 相关的 DropTargetContext。

返回 DropTargetContext 的 java.awt.dnd 中的方法
protected DropTargetContext | DropTarget.createDropTargetContext() 创建与此 DropTarget 关联的 DropTargetContext。
DropTargetContext | DropTargetEvent.getDropTargetContext() 此方法返回与该 DropTargetEvent 相关的 DropTargetContext。
DropTargetContext | DropTarget.getDropTargetContext() 获取与此 DropTarget 关联的 DropTargetContext。

参数类型为 DropTargetContext 的 java.awt.dnd 中的构造方法
DropTargetDragEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 "Drag" Cursor 热点的位置、用户 drop 操作和源 drop 操作的情况下，构造一个 DropTargetDragEvent。
DropTargetDropEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作和当前受源对象支持的操作集合的情况下，构造一个 DropTargetDropEvent。
DropTargetDropEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions, boolean isLocal)
在给出此操作的 DropTargetContext、Component 的坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作、当前受源对象支持的操作集合，以及一个指示源对象与目标对象是否在同一 JVM 中的 boolean 值的情况下，构造一个 DropTargetEvent。
DropTargetEvent(DropTargetContext dtc)
构造一个具有指定 DropTargetContext 的 DropTargetEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DropTargetContext.TransferableProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetContext.TransferableProxy
的使用

没有 java.awt.dnd.DropTargetContext.TransferableProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DropTargetDragEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetDragEvent
的使用

使用 DropTargetDragEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTargetDragEvent 的使用

参数类型为 DropTargetDragEvent 的 java.awt.dnd 中的方法
void | DropTargetAdapter.dragEnter(DropTargetDragEvent dtde) 当鼠标指针进入向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行的同时调用该方法。
void | DropTarget.dragEnter(DropTargetDragEvent dtde) 在已注册的 DropTargetListener 上调用 dragEnter，并将其传递给指定的 DropTargetDragEvent。
void | DropTargetListener.dragEnter(DropTargetDragEvent dtde) 正在进行 drag 操作时调用，此时鼠标指针进入 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
void | DropTargetAdapter.dragOver(DropTargetDragEvent dtde) 当鼠标指针仍旧处于向此侦听器注册的 DropTarget 放置点可操作部分上时，则在拖动操作正在进行时调用该方法。
void | DropTarget.dragOver(DropTargetDragEvent dtde) 在已注册的 DropTargetListener 上调用 dragOver，并将其传递给指定的 DropTargetDragEvent。
void | DropTargetListener.dragOver(DropTargetDragEvent dtde) 正在进行 drag 操作时调用，此时鼠标指针仍然处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
void | DropTargetAdapter.dropActionChanged(DropTargetDragEvent dtde) 如果用户已经修改了当前的放置操作，则调用该方法。
void | DropTarget.dropActionChanged(DropTargetDragEvent dtde) 在已注册的 DropTargetListener 上调用 dropActionChanged，并将其传递给指定的 DropTargetDragEvent。
void | DropTargetListener.dropActionChanged(DropTargetDragEvent dtde) 在用户已经修改了当前 drop 操作后调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DropTargetDropEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetDropEvent
的使用

使用 DropTargetDropEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTargetDropEvent 的使用

参数类型为 DropTargetDropEvent 的 java.awt.dnd 中的方法
void | DropTarget.drop(DropTargetDropEvent dtde) 如果此 DropTarget 处于激活状态，则在已注册的 DropTargetListener 上调用 drop，并将其传递给指定的 DropTargetDropEvent。
void | DropTargetListener.drop(DropTargetDropEvent dtde) 在 drag 操作已终止时调用，此时 drop 处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.DropTargetEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetEvent
的使用

使用 DropTargetEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTargetEvent 的使用

java.awt.dnd 中 DropTargetEvent 的子类
class | DropTargetDragEvent 通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。
class | DropTargetDropEvent 通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。

参数类型为 DropTargetEvent 的 java.awt.dnd 中的方法
void | DropTargetAdapter.dragExit(DropTargetEvent dte) 当鼠标指针已经离开向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行时调用该方法。
void | DropTarget.dragExit(DropTargetEvent dte) 在已注册的 DropTargetListener 上调用 dragExit，并将其传递给指定的 DropTargetEvent。
void | DropTargetListener.dragExit(DropTargetEvent dte) 正在进行 drag 操作时调用，此时鼠标指针已退出 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.dnd.DropTargetListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.dnd.DropTargetListener
的使用

使用 DropTargetListener 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTargetListener 的使用

实现 DropTargetListener 的 java.awt.dnd 中的类
class | DropTarget 在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
class | DropTargetAdapter 接收放置目标事件的抽象适配器类。

参数类型为 DropTargetListener 的 java.awt.dnd 中的方法
void | DropTarget.addDropTargetListener(DropTargetListener dtl) 添加一个新的 DropTargetListener (UNICAST SOURCE)。
void | DropTarget.removeDropTargetListener(DropTargetListener dtl) 移除当前的 DropTargetListener (UNICAST SOURCE)。

参数类型为 DropTargetListener 的 java.awt.dnd 中的构造方法
DropTarget(Component c, DropTargetListener dtl)
在给出与之关联的 Component 和执行事件处理的 DropTargetListener 的情况下创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值和执行事件处理的 DropTargetListener 的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener 和表示 DropTarget 当前是否接受 drop 的 boolean 值的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.InvalidDnDOperationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.InvalidDnDOperationException
的使用

使用 InvalidDnDOperationException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 InvalidDnDOperationException 的使用

抛出 InvalidDnDOperationException 的 java.awt 中的方法
abstract  java.awt.dnd.peer.DragSourceContextPeer Toolkit.createDragSourceContextPeer(DragGestureEvent dge)
创建 DragSourceContext 的同位体。

java.awt.dnd 中 InvalidDnDOperationException 的使用

抛出 InvalidDnDOperationException 的 java.awt.dnd 中的方法
void | DropTargetContext.dropComplete(boolean success) 此方法指示放置操作完成以及成功与否。
protected Transferable | DropTargetContext.getTransferable() 获取此操作的 Transferable（代理）操作数
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable) 在给定拖动操作的 Cursor 和表示拖动操作源数据的 Transferable 的情况下开始拖动此操作。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.dnd.MouseDragGestureRecognizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.MouseDragGestureRecognizer
的使用

没有 java.awt.dnd.MouseDragGestureRecognizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


AWT Threading Issues

Listeners and threads

Unless otherwise noted all AWT listeners are notified on the event dispatch thread. It is safe to remove/add listeners from any thread during dispatching, but the changes only effect subsequent notification.
For example, if a key listeners is added from another key listener, the newly added listener is only notified on subsequent key events.

Auto-shutdown

According to The JavaTM Virtual Machine Specification, Second edition (see �2.17.9 and �2.19), the Java virtual machine (JVM) initially starts up with a single non-daemon thread, which typically calls the main method of some class. The virtual machine terminates all its activity and exits when one of two things happens:
  • All the threads that are not daemon threads terminate.
  • Some thread invokes the exit method of class Runtime or class System, and the exit operation is permitted by the security manager.

This implies that if an application doesn't start any threads itself, the JVM will exit as soon as main terminates. This is not the case, however, for a simple application that creates and displays a java.awt.Frame:

        public static void main(String[] args) {
            Frame frame = new Frame();
            frame.setVisible(true);
         }
The reason is that AWT encapsulates asynchronous event dispatch machinery to process events AWT or Swing components can fire. The exact behavior of this machinery is implementation-dependent. In particular, it can start non-daemon helper threads for its internal purposes. In fact, these are the threads that prevent the example above from exiting. The only restrictions imposed on the behavior of this machinery are as follows:
  • EventQueue.isDispatchThread returns true if and only if the calling thread is the event dispatch thread started by the machinery;
  • AWTEvents which were actually enqueued to a particular EventQueue (note that events being posted to the EventQueue can be coalesced) are dispatched:
    • Sequentially.
      That is, it is not permitted that several events from this queue are dispatched simultaneously.
    • In the same order as they are enqueued.
      That is, if AWTEvent A is enqueued to the EventQueue before AWTEvent B then event B will not be dispatched before event A.
  • There is at least one alive non-daemon thread while there is at least one displayable AWT or Swing component within the application (see Component.isDisplayable).
The implications of the third restriction are as follows:
  • The JVM will exit if some thread invokes the exit method of class Runtime or class System regardless of the presence of displayable components;
  • Even if the application terminates all non-daemon threads it started, the JVM will not exit while there is at least one displayable component.
It depends on the implementation if and when the non-daemon helper threads are terminated once all components are made undisplayable. The implementation-specific details are given below.

Implementation-dependent behavior.

Prior to 1.4, the helper threads were never terminated.

Starting with 1.4, the behavior has changed as a result of the fix for 4030718. With the current implementation, AWT terminates all its helper threads allowing the application to exit cleanly when the following three conditions are true:

  • There are no displayable AWT or Swing components.
  • There are no native events in the native event queue.
  • There are no AWT events in java EventQueues.
Therefore, a stand-alone AWT application that wishes to exit cleanly without calling System.exit must:
  • Make sure that all AWT or Swing components are made undisplayable when the application finishes. This can be done by calling Window.dispose on all top-level Windows. See Frame.getFrames.
  • Make sure that no method of AWT event listeners registered by the application with any AWT or Swing component can run into an infinite loop or hang indefinitely. For example, an AWT listener method triggered by some AWT event can post a new AWT event of the same type to the EventQueue. The argument is that methods of AWT event listeners are typically executed on helper threads.
Note, that while an application following these recommendations will exit cleanly under normal conditions, it is not guaranteed that it will exit cleanly in all cases. Two examples:
  • Other packages can create displayable components for internal needs and never make them undisplayable. See 4515058, 4671025, and 4465537.
  • Both Microsoft Windows and X11 allow an application to send native events to windows that belong to another application. With this feature it is possible to write a malicious program that will continuously send events to all available windows preventing any AWT application from exiting cleanly.
On the other hand, if you require the JVM to continue running even after the application has made all components undisplayable you should start a non-daemon thread that blocks forever.
        <...>
        Runnable r = new Runnable() {
            public void run() {
                Object o = new Object();
                try {
                    synchronized (o) {
                        o.wait();
                    }
                } catch (InterruptedException ie) {
                }
            }
        };
        Thread t = new Thread(r);
        t.setDaemon(false);
        t.start();
        <...>
The Java Virtual Machine Specification guarantees that the JVM doesn't exit until this thread terminates.


AWT Desktop Properties

The following refers to standard AWT desktop properties that may be obtained via the Toolkit.getDesktopProperty method.

Each desktop property is named by a unique string, which is the "name" of that property.

Desktop properties supported by the AWT but not documented elsewhere - typically because there is no suitable method or class - are documented here.

Desktop properties documented elsewhere are those which are tightly coupled with a method or class which documents them.

Since desktop properties abstract an underlying platform setting, they may not be available in environments that do not support them. In the event that a desktop property is unavailable for any reason, the implementation will return null.

The following table summarizes the desktop properties documented here, and their value types.

Property Name | Value Type | Summary Description
awt.font.desktophints | java.util.Map | Font smoothing (text antialiasing) settings.

Desktop Font Rendering Hints

Desktop Property: "awt.font.desktophints"

Modern desktops support various forms of text antialiasing (font smoothing).

These are applied by platform-specific heavyweight components. However an application may want to render text using the same text antialiasing on a drawing surface or lightweight (non-platform) component using Graphics2D methods. This is particularly important when creating Swing components which are required to appear consistent with native desktop components or other Swing components.

Basic Usage

The standard desktop property named "awt.font.desktophints" can be used to obtain the rendering hints that best match the desktop settings. The return value is a Map of RenderingHints which can be directly applied to a Graphics2D.

It is a Map as more than one hint may be needed. If non-null this can be directly applied to the Graphics2D.

Toolkit tk = Toolkit.getDefaultToolkit();
Map map = (Map)(tk.getDesktopProperty("awt.font.desktophints"));
if (map != null) {
    graphics2D.addRenderingHints(map);
}

Advanced Usage Tips

Listening for changes

An application can listen for changes in the property using a PropertyChangeListener :

tk.addPropertyChangeListener("awt.font.desktophints", pcl);
Listening for changes is recommended as users can, on rare occasions, reconfigure a desktop environment whilst applications are running in a way that may affect the selection of these hints, and furthermore many desktop environments support dynamic reconfiguration of these running applications to conform to the new settings.

There is no direct way to discover if dynamic reconfiguration is expected of running applications but the default assumption should be that it is expected, since most modern desktop environments do provide this capability.

Text Measurement

Text always needs to be measured using the same FontRenderContext as used for rendering. The text anti-aliasing hint is a component of the FontRenderContext. A FontMetrics obtained from the Graphics object on which the hint has been set will measure text appropriately. This is not a unique requirement for clients that specify this hint directly, since the value of the FontRenderContext should never be assumed, so is discussed here principally as a reminder.

Saving and restoring Graphics State

Sometimes an application may need to apply these hints on a shared Graphics only temporarily, restoring the previous values after they have been applied to text rendering operations. The following sample code shows one way to do this.

/**
  * Get rendering hints from a Graphics instance.
  * "hintsToSave" is a Map of RenderingHint key-values.
  * For each hint key present in that map, the value of that
  * hint is obtained from the Graphics and stored as the value
  * for the key in savedHints.
  */
RenderingHints getRenderingHints(Graphics2D g2d,
                                  RenderingHints hintsToSave,
                                  RenderingHints savedHints) {
     if (savedHints == null) {
         savedHints = new RenderingHints(null);
     } else {
         savedHints.clear();
     }
     if (hintsToSave.size() == 0) {
         return savedHints;
     }
     /* RenderingHints.keySet() returns Set  */
     for (Object o : hintsToSave.keySet()) {
         RenderingHints.Key key = (RenderingHints.Key)o;
         Object value = g2d.getRenderingHint(key);
         savedHints.put(key, value);
     }
     return savedHints;
}

Toolkit tk = Toolkit.getDefaultToolkit();
Map map = (Map)(tk.getDesktopProperty("awt.font.desktophints"));
Map oldHints;
if (map != null) {
     oldHints = getRenderingHints(graphic2D, map, null);
     graphics2D.addRenderingHints(map);
     ..
     graphics2D.addRenderingHints(oldHints);
}

Details

  • The return value will always be null or a Map

  • If the return value is null, then no desktop properties are available,
and dynamic updates will not be available. This is a typical behaviour if
the JDK does not recognise the desktop environment, or it is one which
has no such settings. The Headless toolkit is one such example.
Therefore it is important to test against null before using the map.

  • If non-null the value will be a Map of
RenderingHints such that every key is an instance of
RenderingHints.Key and the value is a legal value for that key.

  • The map may contain the default value for a hint. This is
needed in the event there is a previously a non-default value for the hint
set on the Graphics2D. If the map did not contain
the default value, then addRenderingHints(Map) would leave
the previous hint which may not correspond to the desktop setting.

An application can use setRenderingHints(Map) to reinitialise
all hints, but this would affect unrelated hints too.

  • A multi-screen desktop may support per-screen device settings in which
case the returned value is for the default screen of the desktop.
An application may want to use the settings for the screen on
which they will be applied.
The per-screen device hints may be obtained by per-device property names
which are constructed as the String concatenation

"awt.font.desktophints" + "." + GraphicsDevice.getIDstring();

An application can also listen for changes on these properties.

However this is an extremely unlikely configuration, so to help
ease of development, if only a single, desktop-wide setting is supported,
then querying each of these per-device settings will return null.
So to determine if there are per-device settings it is sufficient to
determine that there is a non-null return for any screen device using
the per-device property name.


The AWT Focus Subsystem

Prior to Java 2 Standard Edition, JDK 1.4, the AWT focus subsystem was inadequate. It suffered from major design and API problems, as well as over a hundred open bugs. Many of these bugs were caused by platform inconsistencies, or incompatibilities between the native focus system for heavyweights and the Java focus system for lightweights.

The single worst problem with the AWT focus implementation was the inability to query for the currently focused Component. Not only was there no API for such a query, but also, because of an insufficient architecture, such information was not even maintained by the code.

Almost as bad was the inability of lightweight children of a Window (not a Frame or a Dialog) to receive keyboard input. This problem existed because Windows never received WINDOW_ACTIVATED events and thus could never be activated, and only active Windows could contain focused Components.

In addition, many developers noted that the APIs for FocusEvent and WindowEvent were insufficient because they did not provide a way for determining the "opposite" Component involved in the focus or activation change. For example, when a Component received a FOCUS_LOST event, it had no way of knowing which Component was gaining focus. Since Microsoft Windows provides this functionality for free, developers migrating from Microsoft Windows C/C++ or Visual Basic to Java had been frustrated by the omission.

To address these and other deficiencies, we have designed a new focus model for the AWT in JDK 1.4. The primary design changes were the construction of a new centralized KeyboardFocusManager class, and a lightweight focus architecture. The amount of focus-related, platform-dependent code has been minimized and replaced by fully pluggable and extensible public APIs in the AWT. While we have attempted to remain backward compatible with the existing implementation, we were forced to make minor incompatible changes in order to reach an elegant and workable conclusion. We anticipate that these incompatibilities will have only a trivial impact on existing applications.

This document is a formal specification both of the new APIs and of existing APIs which remain relevant in the new model. Combined with the javadoc for focus-related classes and methods, this document should enable developers to create substantial AWT and Swing applications with a focus behavior that is customized yet consistent across platforms. This document has the following sections:

  • Overview of KeyboardFocusManager
  • KeyboardFocusManager and Browser Contexts
  • KeyEventDispatcher
  • FocusEvent and WindowEvent
  • Event Delivery
  • Opposite Components and Windows
  • Temporary FocusEvents
  • Focus Traversal
  • Focus Traversal Policy
  • Focus Traversal Policy Providers
  • Programmatic Traversal
  • Focusability
  • Focusable Windows
  • Requesting Focus
  • Focus and PropertyChangeListener
  • Focus and VetoableChangeListener
  • Z-Order
  • Replacing DefaultKeyboardFocusManager
  • Incompatibilities with Previous Releases

Overview of KeyboardFocusManager

The focus model is centralized around a single class, KeyboardFocusManager, that provides a set of APIs for client code to inquire about the current focus state, initiate focus changes, and replace default focus event dispatching with a custom dispatcher. Clients can inquire about the focus state directly, or can register a PropertyChangeListener that will receive PropertyChangeEvents when a change to the focus state occurs.

KeyboardFocusManager introduces seven main concepts and their terminology:

  1. The "focus owner" -- the Component which typically receives keyboard input.
  2. The "permanent focus owner" -- the last Component to receive focus permanently. The "focus owner" and the "permanent focus owner" are equivalent unless a temporary focus change is currently in effect. In such a situation, the "permanent focus owner" will again be the "focus owner" when the temporary focus change ends.
  3. The "focused Window" -- the Window which contains the "focus owner".
  4. The "active Window" -- the Frame or Dialog that is either the "focused Window", or the first Frame or Dialog that is an owner of the "focused Window".
  5. "Focus traversal" -- the user's ability to change the "focus owner" without moving the cursor. Typically, this is done using the keyboard (for example, by using the TAB key), or an equivalent device in an accessible environment. Client code can also initiate traversal programmatically. Normal focus traversal can be either "forward" to the "next" Component, or "backward" to the "previous" Component.
  6. "Focus traversal cycle" -- a portion of the Component hierarchy, such that normal focus traversal "forward" (or "backward") will traverse through all of the Components in the focus cycle, but no other Components. This cycle provides a mapping from an arbitrary Component in the cycle to its "next" (forward traversal) and "previous" (backward traversal) Components.
  7. "Focus cycle root" -- Container that is the root of the Component hierarchy for a particular "focus traversal cycle". When the "focus owner" is a Component inside a particular cycle, normal forward and backward focus traversal cannot move the "focus owner" above the focus cycle root in the Component hierarchy. Instead, two additional traversal operations, "up cycle" and "down cycle", are defined to allow keyboard and programmatic navigation up and down the focus traversal cycle hierarchy.
  8. "Focus traversal policy provider" - Container which has "FocusTraversalPolicyProvider" property as true. This Container will be used to acquire focus traversal policy. This container doesn't define new focus cycle but only modifies the order by which its children are traversed "forward" and "backward". Focus traversal policy provider can be set using setFocusTraversalPolicyProvider on the Container.

Every Window and JInternalFrame is, by default, a "focus cycle root". If it's the only focus cycle root, then all of its focusable descendants should be in its focus cycle, and its focus traversal policy should enforce that they are by making sure that all will be reached during normal forward (or backward) traversal. If, on the other hand, the Window or JInternalFrame has descendants that are also focus cycle roots, then each such descendant is a member of two focus cycles: the one that it is the root of, and the one of its nearest focus-cycle-root ancestor. In order to traverse the focusable components belonging to the focus cycle of such a "descendant" focus cycle root, one first traverses (forward or backward) to reach the descendant, and then uses the "down cycle" operation to reach, in turn, its descendants.

Here is an example:
Three groups as described below: ABCF BDE and DGH.

Assume the following:

  • A is a Window, which means that it must be a focus cycle root.
  • B and D are Containers that are focus cycle roots.
  • C is a Container that is not a focus cycle root.
  • G, H, E, and F are all Components.
There are a total of three focus cycle roots in this example:
  1. A is a root, and A, B, C, and F are members of A's cycle.
  2. B is a root, and B, D, and E are members of B's cycle.
  3. D is a root, and D, G, and H are members of D's cycle.
Windows are the only Containers which, by default, are focus cycle roots. KeyboardFocusManager is an abstract class. AWT provides a default implementation in the DefaultKeyboardFocusManager class.

KeyboardFocusManager and Browser Contexts

Some browsers partition applets in different code bases into separate contexts, and establish walls between these contexts. Each thread and each Component is associated with a particular context and cannot interfere with threads or access Components in other contexts. In such a scenario, there will be one KeyboardFocusManager per context. Other browsers place all applets into the same context, implying that there will be only a single, global KeyboardFocusManager for all applets. This behavior is implementation-dependent. Consult your browser's documentation for more information. No matter how many contexts there may be, however, there can never be more than one focus owner, focused Window, or active Window, per ClassLoader.

KeyEventDispatcher and KeyEventPostProcessor

While the user's KeyEvents should generally be delivered to the focus owner, there are rare cases where this is not desirable. An input method is an example of a specialized Component that should receive KeyEvents even though its associated text Component is and should remain the focus owner.

A KeyEventDispatcher is a lightweight interface that allows client code to pre-listen to all KeyEvents in a particular context. Instances of classes that implement the interface and are registered with the current KeyboardFocusManager will receive KeyEvents before they are dispatched to the focus owner, allowing the KeyEventDispatcher to retarget the event, consume it, dispatch it itself, or make other changes.

For consistency, KeyboardFocusManager itself is a KeyEventDispatcher. By default, the current KeyboardFocusManager will be the sink for all KeyEvents not dispatched by the registered KeyEventDispatchers. The current KeyboardFocusManager cannot be completely deregistered as a KeyEventDispatcher. However, if a KeyEventDispatcher reports that it dispatched the KeyEvent, regardless of whether it actually did so, the KeyboardFocusManager will take no further action with regard to the KeyEvent. (While it is possible for client code to register the current KeyboardFocusManager as a KeyEventDispatcher one or more times, there is no obvious reason why this would be necessary, and therefore it is not recommended.)

Client-code may also post-listen to KeyEvents in a particular context using the KeyEventPostProcessor interface. KeyEventPostProcessors registered with the current KeyboardFocusManager will receive KeyEvents after the KeyEvents have been dispatched to and handled by the focus owner. The KeyEventPostProcessors will also receive KeyEvents that would have been otherwise discarded because no Component in the application currently owns the focus. This will allow applications to implement features that require global KeyEvent post- handling, such as menu shortcuts.

Like KeyEventDispatcher, KeyboardFocusManager also implements KeyEventPostProcessor, and similar restrictions apply to its use in that capacity.

FocusEvent and WindowEvent

The AWT defines the following six event types central to the focus model in two different java.awt.event classes:

  1. WindowEvent.WINDOW_ACTIVATED: This event is dispatched to a Frame or Dialog (but never a Window which is not a Frame or Dialog) when it becomes the active Window.
  2. WindowEvent.WINDOW_GAINED_FOCUS: This event is dispatched to a Window when it becomes the focused Window. Only focusable Windows can receive this event.
  3. FocusEvent.FOCUS_GAINED: This event is dispatched to a Component when it becomes the focus owner. Only focusable Components can receive this event.
  4. FocusEvent.FOCUS_LOST: This event is dispatched to a Component when it is no longer the focus owner.
  5. WindowEvent.WINDOW_LOST_FOCUS: This event is dispatched to a Window when it is no longer the focused Window.
  6. WindowEvent.WINDOW_DEACTIVATED: This event is dispatched to a Frame or Dialog (but never a Window which is not a Frame or Dialog) when it is no longer the active Window.

Event Delivery

If the focus is not in java application and the user clicks on a focusable child Componenta of an inactive Frame b, the following events will be dispatched and handled in order:

  1. b will receive a WINDOW_ACTIVATED event.
  2. Next, b will receive a WINDOW_GAINED_FOCUS event.
  3. Finally, a will receive a FOCUS_GAINED event.
If the user later clicks on a focusable child Component c of another Frame d, the following events will be dispatched and handled in order:
  1. a will receive a FOCUS_LOST event.
  2. b will receive a WINDOW_LOST_FOCUS event.
  3. b will receive a WINDOW_DEACTIVATED event.
  4. d will receive a WINDOW_ACTIVATED event.
  5. d will receive a WINDOW_GAINED_FOCUS event.
  6. c will receive a FOCUS_GAINED event.
Note that each event will be fully handled before the next event is dispatched. This restriction will be enforced even if the Components are in different contexts and are handled on different event dispatching threads.

In addition, each event type will be dispatched in 1-to-1 correspondence with its opposite event type. For example, if a Component receives a FOCUS_GAINED event, under no circumstances can it ever receive another FOCUS_GAINED event without an intervening FOCUS_LOST event.

Finally, it is important to note that these events are delivered for informational purposes only. It is impossible, for example, to prevent the delivery of a pending FOCUS_GAINED event by requesting focus back to the Component losing focus while handling the preceding FOCUS_LOST event. While client code may make such a request, the pending FOCUS_GAINED will still be delivered, followed later by the events transferring focus back to the original focus owner.

If it is absolutely necessary to suppress the FOCUS_GAINED event, client code can install a VetoableChangeListener which rejects the focus change. See Focus and VetoableChangeListener.

Opposite Components and Windows

Each event includes information about the "opposite" Component or Window involved in the focus or activation change. For example, for a FOCUS_GAINED event, the opposite Component is the Component that lost focus. If the focus or activation change occurs with a native application, with a Java application in a different VM or context, or with no other Component, then the opposite Component or Window is null. This information is accessible using FocusEvent.getOppositeComponent or WindowEvent.getOppositeWindow.

On some platforms, it is not possible to discern the opposite Component or Window when the focus or activation change occurs between two different heavyweight Components. In these cases, the opposite Component or Window may be set to null on some platforms, and to a valid non-null value on other platforms. However, for a focus change between two lightweight Components which share the same heavyweight Container, the opposite Component will always be set correctly. Thus, a pure Swing application can ignore this platform restriction when using the opposite Component of a focus change that occurred within a top-level Window.

Temporary FocusEvents

FOCUS_GAINED and FOCUS_LOST events are marked as either temporary or permanent.

Temporary FOCUS_LOST events are sent when a Component is losing the focus, but will regain the focus shortly. These events can be useful when focus changes are used as triggers for validation of data. For instance, a text Component may want to commit its contents when the user begins interacting with another Component, and can accomplish this by responding to FOCUS_LOST events. However, if the FocusEvent received is temporary, the commit should not be done, since the text field will be receiving the focus again shortly.

A permanent focus transfer typically occurs as the result of a user clicking on a selectable, heavyweight Component, focus traversal with the keyboard or an equivalent input device, or from a call to requestFocus() or requestFocusInWindow().

A temporary focus transfer typically occurs as the result of showing a Menu or PopupMenu, clicking or dragging a Scrollbar, moving a Window by dragging the title bar, or making another Window the focused Window. Note that on some platforms, these actions may not generate any FocusEvents at all. On others, temporary focus transfers will occur.

When a Component receives a temporary FOCUS_LOST event, the event's opposite Component (if any) may receive a temporary FOCUS_GAINED event, but could also receive a permanent FOCUS_GAINED event. Showing a Menu or PopupMenu, or clicking or dragging a Scrollbar, should generate a temporary FOCUS_GAINED event. Changing the focused Window, however, will yield a permanent FOCUS_GAINED event for the new focus owner.

The Component class includes variants of requestFocus and requestFocusInWindow which take a desired temporary state as a parameter. However, because specifying an arbitrary temporary state may not be implementable on all native windowing systems, correct behavior for this method can be guaranteed only for lightweight Components. This method is not intended for general use, but exists instead as a hook for lightweight Component libraries, such as Swing.

Focus Traversal

Each Component defines its own Set of focus traversal keys for a given focus traversal operation. Components support separate Sets of keys for forward and backward traversal, and also for traversal up one focus traversal cycle. Containers which are focus cycle roots also support a Set of keys for traversal down one focus traversal cycle. If a Set is not explicitly defined for a Component, that Component recursively inherits a Set from its parent, and ultimately from a context-wide default set on the current KeyboardFocusManager.

Using the AWTKeyStroke API, client code can specify on which of two specific KeyEvents, KEY_PRESSED or KEY_RELEASED, the focus traversal operation will occur. Regardless of which KeyEvent is specified, however, all KeyEvents related to the focus traversal key, including the associated KEY_TYPED event, will be consumed, and will not be dispatched to any Component. It is a runtime error to specify a KEY_TYPED event as mapping to a focus traversal operation, or to map the same event to multiple focus traversal operations for any particular Component or for a KeyboardFocusManager's defaults.

The default focus traversal keys are implementation-dependent. Sun recommends that the all implementations for a particular native platform use the same keys. For Windows and Unix, the recommendations are:

  • traverse forward to the next Component:
    TextAreas: CTRL-TAB on KEY_PRESSED
    All others: TAB on KEY_PRESSED and CTRL-TAB on KEY_PRESSED
  • traverse backward to the previous Component:
    TextAreas: CTRL-SHIFT-TAB on KEY_PRESSED
    All others: SHIFT-TAB on KEY_PRESSED and CTRL-SHIFT-TAB on KEY_PRESSED
  • traverse up one focus traversal cycle : <none>
  • traverse down one focus traversal cycle : <none>

Components can enable and disable all of their focus traversal keys en masse using Component.setFocusTraversalKeysEnabled. When focus traversal keys are disabled, the Component receives all KeyEvents for those keys. When focus traversal keys are enabled, the Component never receives KeyEvents for traversal keys; instead, the KeyEvents are automatically mapped to focus traversal operations.

For normal forward and backward traversal, the AWT focus implementation determines which Component to focus next based on the FocusTraversalPolicy of the focus owner's focus cycle root or focus traversal policy provider. If the focus owner is a focus cycle root, then it may be ambiguous as to which Components represent the next and previous Components to focus during normal focus traversal. Thus, the current KeyboardFocusManager maintains a reference to the "current" focus cycle root, which is global across all contexts. The current focus cycle root is used to resolve the ambiguity.

For up-cycle traversal, the focus owner is set to the current focus owner's focus cycle root, and the current focus cycle root is set to the new focus owner's focus cycle root. If, however, the current focus owner's focus cycle root is a top-level window, then the focus owner is set to the focus cycle root's default component to focus, and the current focus cycle root is unchanged.

For down-cycle traversal, if the current focus owner is a focus cycle root, then the focus owner is set to the current focus owner's default component to focus, and the current focus cycle root is set to the current focus owner. If the current focus owner is not a focus cycle root, then no focus traversal operation occurs.

FocusTraversalPolicy

A FocusTraversalPolicy defines the order in which Components within a particular focus cycle root or focus traversal policy provider are traversed. Instances of FocusTraversalPolicy can be shared across Containers, allowing those Containers to implement the same traversal policy. FocusTraversalPolicies do not need to be reinitialized when the focus-traversal-cycle hierarchy changes.

Each FocusTraversalPolicy must define the following five algorithms:

  1. Given a focus cycle root and a Component a in that cycle, the next Component after a.
  2. Given a focus cycle root and a Component a in that cycle, the previous Component before a.
  3. Given a focus cycle root, the "first" Component in that cycle. The "first" Component is the Component to focus when traversal wraps in the forward direction.
  4. Given a focus cycle root, the "last" Component in that cycle. The "last" Component is the Component to focus when traversal wraps in the reverse direction.
  5. Given a focus cycle root, the "default" Component in that cycle. The "default" Component will be the first to receive focus when traversing down into a new focus traversal cycle. This may be the same as the "first" Component, but need not be.

A FocusTraversalPolicy may optionally provide an algorithm for the following:

Given a Window, the "initial" Component in that Window. The initial Component will be the first to receive focus when the Window is first made visible. By default, this is the same as the "default" Component.
In addition, Swing provides a subclass of FocusTraversalPolicy, InternalFrameFocusTraversalPolicy, which allows developers to provide an algorithm for the following:
Given a JInternalFrame, the "initial" Component in that JInternalFrame. The initial Component is the first to receive focus when the JInternalFrame is first selected. By default, this is the same as the JInternalFrame's default Component to focus.
A FocusTraversalPolicy is installed on a Container using Container.setFocusTraversalPolicy. If a policy is not explicitly set, then a Container inherits its policy from its nearest focus-cycle-root ancestor. Top-levels initialize their focus traversal policies using the context default policy. The context default policy is established by using KeyboardFocusManager. setDefaultFocusTraversalPolicy.

AWT provides two standard FocusTraversalPolicy implementations for use by client code.

  1. ContainerOrderFocusTraversalPolicy: Iterates across the Components in a focus traversal cycle in the order they were added to their Containers. Each Component is tested for fitness using the accept(Component) method. By default, a Component is fit only if it is visible, displayable, enabled, and focusable.
    By default, ContainerOrderFocusTraversalPolicy implicitly transfers focus down-cycle. That is, during normal forward focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus. This provides backward compatibility with applications designed without the concepts of up- and down-cycle traversal.
  2. DefaultFocusTraversalPolicy: A subclass of ContainerOrderFocusTraversalPolicy which redefines the fitness test. If client code has explicitly set the focusability of a Component by either overriding Component.isFocusTraversable() or Component.isFocusable(), or by calling Component.setFocusable(boolean), then a DefaultFocusTraversalPolicy behaves exactly like a ContainerOrderFocusTraversalPolicy. If, however, the Component is relying on default focusability, then a DefaultFocusTraversalPolicy will reject all Components with non-focusable peers.
    The focusability of a peer is implementation-dependent. Sun recommends that all implementations for a particular native platform construct peers with the same focusability. The recommendations for Windows and Unix are that Canvases, Labels, Panels, Scrollbars, ScrollPanes, Windows, and lightweight Components have non-focusable peers, and all other Components have focusable peers. These recommendations are used in the Sun AWT implementations. Note that the focusability of a Component's peer is different from, and does not impact, the focusability of the Component itself.

Swing provides two additional, standard FocusTraversalPolicy implementations for use by client code. Each implementation is an InternalFrameFocusTraversalPolicy.

  1. SortingFocusTraversalPolicy: Determines traversal order by sorting the Components of a focus traversal cycle based on a given Comparator. Each Component is tested for fitness using the accept(Component) method. By default, a Component is fit only if it is visible, displayable, enabled, and focusable.
  2. By default, SortingFocusTraversalPolicy implicitly transfers focus down-cycle. That is, during normal forward focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus. This provides backward compatibility with applications designed without the concepts of up- and down-cycle traversal.
  3. LayoutFocusTraversalPolicy: A subclass of SortingFocusTraversalPolicy which sorts Components based on their size, position, and orientation. Based on their size and position, Components are roughly categorized into rows and columns. For a Container with horizontal orientation, columns run left-to-right or right-to-left, and rows run top-to-bottom. For a Container with vertical orientation, columns run top-to-bottom and rows run left-to-right or right-to-left. All columns in a row are fully traversed before proceeding to the next row.
    In addition, the fitness test is extended to exclude JComponents that have or inherit empty InputMaps.

Swing applications, or mixed Swing/AWT applications, that use one of the standard look and feels, or any other look and feel derived from BasicLookAndFeel, will use LayoutFocusTraversalPolicy for all Containers by default.

All other applications, including pure AWT applications, will use DefaultFocusTraversalPolicy by default.

Focus Traversal Policy Providers

A Container that isn't a focus cycle root has an option to provide a FocusTraversalPolicy of its own. To do so, one needs to set Container's focus traversal policy provider property to true with the call to

    Container.setFocusTraversalPolicyProvider(boolean)
To determine whether a Container is a focus traversal policy provider, the following method should be used:
    Container.isFocusTraversalPolicyProvider()
If focus traversal policy provider property is set on a focus cycle root, it isn't considered a focus traversal policy provider and behaves just like any other focus cycle root.

The main difference between focus cycle roots and focus traversal policy providers is that the latter allow focus to enter and leave them just as all other Containers. However, children inside focus traversal policy provider are traversed in the order determined by provider's FocusTraversalPolicy. In order to enable focus traversal policy providers to behave this way, FocusTraversalPolicies treat them in the following manner:

  • Focus traversal policy providers can be passed to FocusTraversalPolicy methods instead of focus cycle roots.
  • When calculating next or previous Component in FocusTraversalPolicy.getComponentAfter or FocusTraversalPolicy.getComponentBefore,
    • if obtained Component is a Container and a focus traversal policy provider, that Container's FocusTraversalPolicy is inquired for the default Component, and that default Component is returned as the result
    • if a Component is a child of a focus traversal policy provider, the next and previous for this Component are determined using this focus traversal policy provider's FocusTraversalPolicy. However, in order for focus to leave the provider, the following rules are applied:
      • if at some point the next found Component is the first Component of focus traversal policy provider, the Component after the focus traversal policy provider is returned
      • if at some point the previous found Component is the last Component of focus traversal policy provider, the Component before the focus traversal policy provider is returned
  • When calculating the first or the last Component in FocusTraversalPolicy.getFirstComponent or FocusTraversalPolicy.getLastComponent,
    • if obtained Component is a Container and a focus traversal policy provider, that Container's FocusTraversalPolicy is inquired for the default Component, and that default Component is returned as the result

Programmatic Traversal

In addition to user-initiated focus traversal, client code can initiate a focus traversal operation programmatically. To client code, programmatic traversals are indistinguishable from user-initiated traversals. The preferred way to initiate a programmatic traversal is to use one of the following methods on KeyboardFocusManager:

    KeyboardFocusManager.focusNextComponent() KeyboardFocusManager.focusPreviousComponent() KeyboardFocusManager.upFocusCycle() KeyboardFocusManager.downFocusCycle()

Each of these methods initiates the traversal operation with the current focus owner. If there is currently no focus owner, then no traversal operation occurs. In addition, if the focus owner is not a focus cycle root, then downFocusCycle() performs no traversal operation.

KeyboardFocusManager also supports the following variants of these methods:

  • KeyboardFocusManager.focusNextComponent(Component)
  • KeyboardFocusManager.focusPreviousComponent(Component)
  • KeyboardFocusManager.upFocusCycle(Component)
  • KeyboardFocusManager.downFocusCycle(Container)
Each of these methods initiates the traversal operation with the specified Component rather than the focus owner. That is, the traversal occurs as though the specified Component is the focus owner, though it need not be.

Alternate, but equivalent, APIs are defined on the Component and Container classes themselves:

  • Component.transferFocus()
  • Component.transferFocusBackward()
  • Component.transferFocusUpCycle()
  • Container.transferFocusDownCycle()
As with the KeyboardFocusManager variants, each of these methods initiates the traversal operation as though the Component is the focus owner, though it need not be.

Also note that hiding or disabling the focus owner, directly or indirectly via an ancestor, or making the focus owner non-displayable or non-focusable, initiates an automatic, forward focus traversal. While hiding any ancestor, lightweight or heavyweight, will always indirectly hide its children, only disabling a heavyweight ancestor will disable its children. Thus, disabling a lightweight ancestor of the focus owner does not automatically initiate a focus traversal.

If client code initiates a focus traversal, and there is no other Component to focus, then the focus owner remains unchanged. If client code initiates an automatic focus traversal by hiding the focus owner, directly or indirectly, or by making the focus owner non-displayable or non-focusable, and there is no other Component to focus, then the global focus owner is cleared. If client code initiates an automatic focus traversal by disabling the focus owner, directly or indirectly, and there is no other Component to focus, then the focus owner remains unchanged.

Focusability

A focusable Component can become the focus owner ("focusability") and participates in keyboard focus traversal ("focus traversability") with a FocusTraversalPolicy. There is no separation of these two concepts; a Component must either be both focusable and focus traversable, or neither. A Component expresses this state via the isFocusable() method. By default, all Components return true from this method. Client code can change this default by calling Component.setFocusable(boolean).

Focusable Windows

To support palette windows and input methods, client code can prevent a Window from becoming the focused Window. By transitivity, this prevents the Window or any of its descendants from becoming the focus owner. Non-focusable Windows may still own Windows that are focusable. By default, every Frame and Dialog is focusable. Every Window which is not a Frame or Dialog, but whose nearest owning Frame or Dialog is showing on the screen, and which has at least one Component in its focus traversal cycle, is also focusable by default. To make a Window non-focusable, use Window.setFocusableWindowState(false).

If a Window is non-focusable, this restriction is enforced when the KeyboardFocusManager sees a WINDOW_GAINED_FOCUS event for the Window. At this point, the focus change is rejected and focus is reset to a different Window. The rejection recovery scheme is the same as if a VetoableChangeListener rejected the focus change. See Focus and VetoableChangeListener.

Because the new focus implementation requires that KeyEvents intended for a Window or its descendants be proxied through a child of the Window's owner, and because this proxy must be mapped on X11 in order to receive events, a Window whose nearest owning Frame or Dialog is not showing could never receive KeyEvents on X11. To support this restriction, we have made a distinction between a Window's "window focusability" and its "window focusability state". A Window's focusability state is combined with the showing state of the Window's nearest owning Frame or Dialog to determine the Window's focusability. By default, all Windows have a focusability state of true. Setting a Window's focusability state to false ensures that it will not become the focused Window regardless of the showing state of its nearest owning Frame or Dialog.

Swing allows applications to create JWindows with null owners. Swing constructs all such JWindows so that they are owned by a private, hidden Frame. Because the showing state of this Frame will always be false, a JWindow constructed will a null owner can never be the focused Window, even if it has a Window focusability state of true.

If the focused Window is made non-focusable, then the AWT will attempt to focus the most recently focused Component of the Window's owner. The Window's owner will thus become the new focused Window. If the Window's owner is also a non-focusable Window, then the focus change request will proceed up the ownership hierarchy recursively. Since not all platforms support cross-Window focus changes (see Requesting Focus), it is possible that all such focus change requests will fail. In this case, the global focus owner will be cleared and the focused Window will remain unchanged.

Requesting Focus

A Component can request that it become the focus owner by calling Component.requestFocus(). This initiates a permanent focus transfer to the Component only if the Component is displayable, focusable, visible and all of its ancestors (with the exception of the top-level Window) are visible. The request will be immediately denied if any of these conditions is not met. A disabled Component may be the focus owner; however, in this case, all KeyEvents will be discarded.

The request will also be denied if the Component's top-level Window is not the focused Window and the platform does not support requesting focus across Windows. If the request is denied for this reason, the request is remembered and will be granted when the Window is later focused by the user. Otherwise, the focus change request changes the focused Window as well. Currently, Microsoft Windows supports cross-Window focus transfers while Solaris does not.

There is no way to determine synchronously whether a focus change request has been granted. Instead, client code must install a FocusListener on the Component and watch for the delivery of a FOCUS_GAINED event. Client code must not assume that the Component is the focus owner until it receives this event. The event may or may not be delivered before requestFocus() returns. Developers must not assume one behavior or the other.

The AWT supports type-ahead if all focus change requests are made on the EventDispatchThread. If client code requests a focus change, and the AWT determines that this request might be granted by the native windowing system, then the AWT will notify the current KeyboardFocusManager that is should enqueue all KeyEvents with a timestamp later than the that of the event currently being handled. These KeyEvents will not be dispatched until the new Component becomes the focus owner. The AWT will cancel the delayed dispatching request if the focus change does not succeed at the native level, if the Component's peer is disposed, or if the focus change is vetoed by a VetoableChangeListener. KeyboardFocusManagers are not required to support type-ahead if a focus change request is made from a thread other than the EventDispatchThread.

Because Component.requestFocus() cannot be implemented consistently across platforms, developers are encouraged to use Component.requestFocusInWindow() instead. This method denies cross-Window focus transfers on all platforms automatically. By eliminating the only platform-specific element of the focus transfer, this method achieves consistent cross-platform behavior.

In addition, requestFocusInWindow() returns a boolean value. If 'false' is returned, the request is guaranteed to fail. If 'true' is returned, the request will succeed unless it is vetoed, or an extraordinary event, such as disposal of the Component's peer, occurs before the request can be granted by the native windowing system. Again, while a return value of 'true' indicates that the request is likely to succeed, developers must never assume that this Component is the focus owner until this Component receives a FOCUS_GAINED event.

If client code wants no Component in the application to be the focus owner, it can call the method KeyboardFocusManager. clearGlobalFocusOwner() on the current KeyboardFocusManager. If there exists a focus owner when this method is called, the focus owner will receive a permanent FOCUS_LOST event. After this point, the AWT focus implementation will discard all KeyEvents until the user or client code explicitly sets focus to a Component.

The Component class also supports variants of requestFocus and requestFocusInWindow that allow client code to specify a temporary state. See Temporary FocusEvents

Focus and PropertyChangeListener

Client code can listen to changes in context-wide focus state, or to changes in focus-related state in Components, via PropertyChangeListeners.

The KeyboardFocusManager supports the following properties:

  1. focusOwner: the focus owner
  2. focusedWindow: the focused Window
  3. activeWindow: the active Window
  4. defaultFocusTraversalPolicy: the default focus traversal policy
  5. forwardDefaultFocusTraversalKeys: the Set of default FORWARD_TRAVERSAL_KEYS
  6. backwardDefaultFocusTraversalKeys: the Set of default BACKWARD_TRAVERSAL_KEYS
  7. upCycleDefaultFocusTraversalKeys: the Set of default UP_CYCLE_TRAVERSAL_KEYS
  8. downCycleDefaultFocusTraversalKeys: the Set of default DOWN_CYCLE_TRAVERSAL_KEYS
  9. currentFocusCycleRoot: the current focus cycle root

A PropertyChangeListener installed on the current KeyboardFocusManager will only see these changes within the KeyboardFocusManager's context, even though the focus owner, focused Window, active Window, and current focus cycle root comprise the global focus state shared by all contexts. We believe this is less intrusive than requiring client code to pass a security check before installing a PropertyChangeListener.

Component supports the following focus-related properties:

  1. focusable: the Component's focusability
  2. focusTraversalKeysEnabled: the Component's focus traversal keys enabled state
  3. forwardFocusTraversalKeys: the Component's Set of FORWARD_TRAVERSAL_KEYS
  4. backwardFocusTraversalKeys: the Component's Set of BACKWARD_TRAVERSAL_KEYS
  5. upCycleFocusTraversalKeys: the Component's Set of UP_CYCLE_TRAVERSAL_KEYS

In addition to the Component properties, Container supports the following focus-related properties:

  1. downCycleFocusTraversalKeys: the Container's Set of DOWN_CYCLE_TRAVERSAL_KEYS
  2. focusTraversalPolicy: the Container's focus traversal policy
  3. focusCycleRoot: the Container's focus-cycle-root state

In addition to the Container properties, Window supports the following focus-related property:

  1. focusableWindow: the Window's focusable Window state

Also note that a PropertyChangeListener installed on a Window will never see a PropertyChangeEvent for the focusCycleRoot property. A Window is always a focus cycle root; this property cannot change.

Focus and VetoableChangeListener

The KeyboardFocusManager also supports VetoableChangeListeners for the following properties:

  1. "focusOwner": the focus owner
  2. "focusedWindow": the focused Window
  3. "activeWindow": the active Window
If a VetoableChangeListener vetoes a focus or activation change by throwing a PropertyVetoException, the change is aborted. Any VetoableChangeListeners which had already approved the change will asynchronously receive PropertyChangeEvents indicating a reversion of state to the previous value.

VetoableChangeListeners are notified of the state change before the change is reflected in the KeyboardFocusManager. Conversely, PropertyChangeListeners are notified after the change is reflected. It follows that all VetoableChangeListeners will be notified before any PropertyChangeListener.

VetoableChangeListeners must be idempotent, and must veto both loss and gain events for a particular focus change (e.g., both FOCUS_LOST and FOCUS_GAINED). For example, if a VetoableChangeListener vetoes a FOCUS_LOST event, a KeyboardFocusManager is not required to search the EventQueue and remove the associated pending FOCUS_GAINED event. Instead, the KeyboardFocusManager is free to attempt to dispatch this event and it is the responsibility of the VetoableChangeListener to veto it as well. In addition, during processing of the FOCUS_GAINED event, the KeyboardFocusManager may attempt to resync the global focus state by synthesizing another FOCUS_LOST event. This event must be vetoed just as the first FOCUS_LOST event was.

A KeyboardFocusManager may not hold any locks while notifying PropertyChangeListeners of a state change. This requirement is relaxed for VetoableChangeListeners, however. Therefore, client-definied VetoableChangeListeners should avoid acquiring additional locks inside vetoableChange(PropertyChangeEvent) as this may lead to deadlock. If a focus or activation change is rejected, the KeyboardFocusManager will initiate rejection recovery as follows:

  • If a focused or active Window change was rejected, then the focused or active Window will be reset to the Window which was previously the focused or active Window. If there is no such Window, then the KeyboardFocusManager will clear the global focus owner.
  • If a focus owner change was rejected, then the focus owner will be reset to the Component which was previously the focus owner. If that is not possible, then it will be reset to the next Component in the focus traversal cycle after the previous focus owner. If that is also not possible, then the KeyboardFocusManager will clear the global focus owner.
VetoableChangeListeners must be careful to avoid vetoing focus changes initiated as a result of veto rejection recovery. Failure to anticipate this situation could lead to an infinite cycle of vetoed focus changes and recovery attempts.

Z-Order

On some native windowing systems, the Z-order of a Window can affect its focused or active (if applicable) state. On Microsoft Windows, the top-most Window is naturally the focused Window as well. However, on Solaris, many window managers use a point-to-focus model that ignores Z-order in determining the focused Window. When focusing or activating Windows, the AWT adheres to the UI requirements of the native platform. Therefore, the focus behavior of Z-order-related methods such as:

  • Window.toFront()
  • Window.toBack()
  • Window.show()
  • Window.hide()
  • Window.setVisible(boolean)
  • Window.dispose()
  • Frame.setState(int)
is platform-dependent. In JDK 1.4, the behavior of these methods on Microsoft Windows and Solaris is as follows:
  • Window.toFront():
    Microsoft Windows: The Window is moved to front, if possible. While we will always be able to move this Window in front of other Windows in the same VM, Windows 98 and Windows 2000 do not allow an application to bring any of its windows to the front unless one of that application's windows is already in the foreground. In this case, Windows will instead flash the Window's icon in the taskbar. If the Window is moved to the front, it will be made the focused and (if applicable) active Window.
    Solaris: The Window is moved to front. In a point-to-focus window manager, the Window will become the focused Window if it is the top-most Window underneath the cursor. In a click-to-focus window manager, the focused Window will remain unchanged.
  • Window.toBack():
    Microsoft Windows: The Window is moved to back. Note however that Microsoft Windows insists that an owned Window always be in front of all of its recursive owners. Thus, after the completion of this operation, the Window may not be the lowest Java Window in the Z-order. If the Window, or any of its owners, was the focused Window, then the focused Window is reset to the top-most Window in the VM.
    Solaris: The Window is moved to back. Like Microsoft Windows, some window managers insist than an owned Window always be in front of all of its recursive owners. Thus, after the completion of this operation, the Window may not be the lowest Java Window in the Z-order. If the Window was the focused Window, it will lose focus in a point-to-focus window manager if it is no longer the top-most Window under the cursor. In a click-to-focus window manager, the focused Window will remain unchanged.
  • Window.show()/Window.setVisible(true)/Frame.setState(NORMAL):
    Microsoft Windows: The Window is moved to front and becomes the focused Window.
    Solaris: The Window is moved to front. In a point-to-focus focus window manager, the Window will be focused if it is now the top-most Window under the cursor. In a click-to-focus window manager, the Window will become the focused Window.
  • Window.hide()/Window.setVisible(false)/Window.dispose()/ Frame.setState(ICONIFIED):
    Microsoft Windows: If the Window was the focused Window, the focused Window is reset to a window chosen by the OS, or to no window. The window may be in a native application, or a Java application in another VM.
    Solaris: If the Window was the focused Window, in a point-to- focus window manager, the top-most Window under the cursor will become the focused Window. In a click-to-focus window manager, the focused Window is reset to a window chosen by the window manager. The window may be in a native application, or a Java application in another VM.

Replacing DefaultKeyboardFocusManager

KeyboardFocusManagers are pluggable at the browser context level. Client code can subclass KeyboardFocusManager or DefaultKeyboardFocusManager to modify the way that WindowEvents related to focus, FocusEvents, and KeyEvents are handled and dispatched, and to examine and modify the global focus state. A custom KeyboardFocusManager can also reject focus changes at a more fundamental level then a FocusListener or WindowListener ever could.

While giving a developer ultimate control over the focus model, replacing the entire KeyboardFocusManager is a difficult process requiring a thorough understanding of the peer focus layer. Fortunately, most applications do not need this much control. Developers are encouraged to use KeyEventDispatchers, KeyEventPostProcessors, FocusTraversalPolicies, VetoableChangeListeners, and other concepts discussed in this document before resorting to a full replacement of the KeyboardFocusManager.

First note that, because unhindered access to Components in other contexts represents a security hole, the SecurityManager must grant a new permission, "replaceKeyboardFocusManager", before client code is permitted to replace the KeyboardFocusManager with an arbitrary subclass instance. Because of the security check, replacing the KeyboardFocusManager is not an option for applications that will be deployed in environments with a SecurityManager, such as applets in a browser.

Once installed, a KeyboardFocusManager instance has access to the global focus state via a set of protected functions. The KeyboardFocusManager can only call these functions if it is installed in the calling thread's context. This ensures that malicious code cannot circumvent the security check in KeyboardFocusManager.setCurrentFocusManager. A KeyboardFocusManager should always work with the global focus state instead of the context focus state. Failure to do this will lead to incorrect behavior of the KeyboardFocusManager.

The primary responsibility of a KeyboardFocusManager is the dispatch of the following events:

  • all KeyEvents
  • all FocusEvents
  • WindowEvent.WINDOW_GAINED_FOCUS
  • WindowEvent.WINDOW_LOST_FOCUS
  • WindowEvent.WINDOW_ACTIVATED
  • WindowEvent.WINDOW_DEACTIVATED
The peer layer will provide the KeyboardFocusManager with all of the above events except WINDOW_ACTIVATED and WINDOW_DEACTIVATED. The KeyboardFocusManager must synthesize WINDOW_ACTIVATED and WINDOW_DEACTIVATED events when appropriate and target them accordingly.

The KeyboardFocusManager may need to retarget the events provided by the peer layer to its own notion of the focus owner or focused Window:

  • A KeyEvent must be retargeted to the focus owner. Because the peer layer is unaware of any lightweight Components, KeyEvents will arrive from the peer layer targeted to the focus owner's heavyweight Container, not the focus owner.
  • A FOCUS_LOST event must be retargeted to the focus owner. Again, this is necessary because the peer layer is unaware of lightweight Components.
  • A WINDOW_LOST_FOCUS event must be retargeted to the focused Window. The implementation of the Window class may cause the native focused Window to differ from the Java focused Window.

A KeyboardFocusManager must ensure proper event ordering, and a 1-to-1 correspondence between an event and its opposite event type. The peer layer does not make any of these guarantees. For example, it is possible for the peer layer to send a FOCUS_GAINED event before a WINDOW_GAINED_FOCUS event. The KeyboardFocusManager is responsible for ensuring that the WINDOW_GAINED_FOCUS event is dispatched before the FOCUS_GAINED event.

Before redispatching an event via KeyboardFocusManager. redispatchEvent, a KeyboardFocusManager must attempt to update the global focus state. Typically, this is done using one of the KeyboardFocusManager.setGlobal* methods; however, an implementation is free to implement its own methods. After attempting an update, the KeyboardFocusManager must verify that the global focus state change was not rejected. A rejection is detected when a call to the corresponding getGlobal* method returns a value different than the value just set. Rejections occur in three standard cases:

  • If the KeyboardFocusManager attempts to set the global focus owner to a non-focusable Component.
  • If the KeyboardFocusManager attempts to set the global focused Window to a non-focusable Window.
  • If the change is rejected by an installed VetoableChangeListener.

Client-defined implementations of KeyboardFocusManager can adjust the set of focus transfers which are rejected by overriding the accessor and mutator methods for the global focus state.

If a request to change the global focus state is rejected, the KeyboardFocusManager must discard the event which prompted the focus change request. The Component to which the event was targeted must not receive the event.

The KeyboardFocusManager is also expected to initiate rejection recovery as outlined in Focus and VetoableChangeListener.

Finally, a KeyboardFocusManager must handle the following set of special cases:

  • When handling a WINDOW_GAINED_FOCUS event, the KeyboardFocusManager must set focus to the appropriate child Component of the Window. If a child Component of the Window previously requested focus, but the focus change was rejected because the platform does not support cross-Window focus change requests, then focus should be set to that child Component. Otherwise, if the Window has never been focused, focus should be set to the Window's initial Component to focus. If the Window was previously focused, focus should be set to the Window's most recent focus owner.
  • The KeyboardFocusManager must ensure that the opposite Component or Window are as accurate as the native windowing platform permits. For example, the KeyboardFocusManager may need to retarget the opposite Component to a lightweight child of the heavyweight initially specified by the peer layer.
    If the peer layer states that the opposite Component or Window is null, it is acceptable for the KeyboardFocusManager to propagate this value. null indicates that it is highly probably that no other Component or Window was involved in the focus or activation change. Because of platform limitations, this computation may be subject to a heuristic and could be incorrect. Nevertheless, this heuristic will be the best possible guess which the peer layer could make.
  • Focus and activation changes in which a Component or Window loses focus or activation to itself must be discarded.
  • Events posted by the peer layer claiming that the active Window has lost focus to the focused Window must be discarded. The peer implementation of the Window class may generate these spurious events.

Incompatibilities with Previous Releases

Cross-platform changes:

  1. The default focus traversability for all Components is now 'true'. Previously, some Components (in particular, all lightweights), had a default focus traversability of 'false'. Note that despite this change, however, the DefaultFocusTraversalPolicy for all AWT Containers will preserve the traversal order of previous releases.
  2. A request to focus a non-focus traversable (i.e., non-focusable) Component will be denied. Previously, such requests were granted.
  3. Window.toFront() and Window.toBack() now perform no operation if the Window is not visible. Previously, the behavior was platform-dependent.
  4. KeyListeners installed on Components will no longer see KeyEvents that map to focus traversal operations, and Component.handleEvent() will no longer be invoked for such events. Previously, AWT Components saw these events and had an opportunity to consume them before AWT initiated focus traversal. Code that requires this functionality should instead disable focus traversal keys on its Components and handle focus traversal itself. Alternately, the code can use an AWTEventListener or KeyEventDispatcher to pre-listen to all KeyEvents.

Changes specific to Microsoft Windows:

  1. Window.toBack() changes the focused Window to the top-most Window after the Z-order change.
  2. requestFocus() now allows cross-Window focus change requests in all cases. Previously, requests were granted for heavyweights, but denied for lightweights.


The AWT Modality

This document, together with the API documentation for modality-related classes (such as java.awt.Dialog), briefly describes the new modality features and how to use them. It contains the following sections:

  • Definitions
  • Modality types
  • Show/hide blocking
  • Modal exclusion
  • Related AWT features
  • Security
  • Platform support
  • Compatibility
  • Examples

Definitions

Document - a window without an owner that, together with all its child hierarchy, may be operated on as a single self-contained document. Every window belongs to some document — its root can be found as the closest ancestor window without an owner.

Modal blocked window - a window, that:

  • doesn't receive any user input events
  • doesn't receive input focus
  • keeps its Z-order below the modal dialog that blocks it
Warning! Some window managers allow users to change the window Z-order in an arbitrary way — in that case the last requirement may not be met.

Modal dialog - a dialog that blocks some windows while it is visible. The blocked windows are determined according to the dialog's scope of blocking.

Modal excluded window - a window that stays unblocked while the modal dialog is visible. If a window is modal excluded then all its owned windows and child components are also excluded.

Scope of blocking (SB) - the set of windows (instances of java.awt.Window and all derived classes) that are blocked by the modal dialog while it is visible.

Note: Everywhere in this document the notion of "window" is equal to a top-level window in the Java programming language — in other words an instance of java.awt.Window or any descendant class.

Modality types

There are four supported modality types :

  • toolkit
  • application
  • document
  • modeless
A dialog is, by default, modeless. A modal dialog is, by default, application-modal.

  1. Modeless dialogs
    A modeless dialog doesn't block any windows while visible.
  2. Document-modal dialogs
    A document-modal dialog blocks all windows from the same document except those from its child hierarchy. The document root is determined as the closest ancestor window without an owner.
  3. Application-modal dialogs
    An application-modal dialog blocks all windows from the same application except for those from its child hierarchy. If there are several applets launched in a browser, they can be treated either as separate applications or a single application. This behavior is implementation-dependent.
  4. Toolkit-modal dialogs
    A toolkit-modal dialog blocks all windows that run in the same toolkit except those from its child hierarchy. If there are several applets launched all of them run with the same toolkit, so a toolkit-modal dialog shown from an applet may affect other applets and all windows of the browser instance which embeds the Java runtime environment for this toolkit. See the security section below.

Modality priority is arranged by the strength of blocking: modeless, document-modal, application-modal and toolkit-modal. This arrangement is used when determining what dialog should remain unblocked if two are visible and block each other. It naturally reflects the nesting of a dialog's scope of blocking (SB): a modeless dialog has an empty SB, a document-modal dialog's SB is complete in some applications, and all the applications are run in one toolkit.

Notes about owners:

  • Creating a document-modal dialog without an owner:
    Since Dialog is a class derived from Window, a Dialog instance automatically becomes the root of the document if it has no owner. Thus, if such a dialog is document-modal, its scope of blocking is empty and it behaves the same way as a modeless dialog.
  • Creating an application-modal or toolkit-modal dialog with an owner:
    The scope of blocking for an application- or toolkit-modal dialog, as opposed to a document-modal dialog, doesn't depend on its owner. Thus, in this case the only thing that the owner affects is the Z-order: the dialog always stays on top of its owner.

Implementation note: Changing the modality type for a visible dialog may have no effect until it is hidden and then shown again.

Show/hide blocking

Showing the window or modeless dialog: "F"
All the visible modal dialogs are looked through — if F is from the SB of one of them, it becomes blocked by it. If there are several such dialogs, the first shown is used. If no such dialogs exist, F remains unblocked.

Showing the modal dialog: "M"
When modal dialog M is shown, all the visible windows fall into one of three distinct groups:

  • Blockers of M (modal dialogs that block M and either are in M's child hierarchy, or are not blocked by M, or have a greater mode of modality, or block some other blocker of M)
  • Blocked by M (windows from M's SB that are not blockers and are not in child hierarchy of any blocker)
  • All other windows (windows or modeless dialogs outside M's SB and modal dialogs outside M's SB that do not block M).

After the modal dialog M is shown, it becomes blocked by the first shown dialog from the first group (if there are any), all the windows from the second one become blocked by M, and all the windows from the third group remain untouched.

In typical cases, when no child dialogs are shown before their owners, this rule can be simplified. (The following, simplified case, may leave out some details).

Showing the document-modal dialog: "M"
All the visible application- and toolkit-modal dialogs are looked through — if M is from the SB of one of them, it becomes blocked by it. If there are several such dialogs, the first shown is used. If no such dialogs exist, M remains unblocked.

Showing the application-modal dialog: "M"
All the visible toolkit-modal dialogs are looked through — if M is from the SB of one of them, it becomes blocked by it. If there are several such dialogs, the first shown is used. If no such dialogs exist, M remains unblocked.

Showing the toolkit-modal dialog: "M"
M remains unblocked.

The Standard Blocking Matrix
current/shown | frame & modeless | document | application | toolkit
- | - | - | - | -
document | blocked | - | - | -
application | blocked | blocked | - | -
toolkit | blocked | blocked | blocked | -

After the modal dialog is shown, all the windows from its SB are blocked, except those that block this modal dialog.

Hiding the window or modeless dialog: "F"
If F was blocked by any modal dialog M, it becomes unblocked and is removed from M's blocked windows list.

Hiding the modal dialog: "M"
If M was blocked by any other modal dialog, for example, "N", it becomes unblocked and is removed from N's blocked windows list. Then, all the windows and dialogs blocked by M become unblocked, and after that the same checks (as in Showing the modal dialog: "M") are performed for each of them in the order they were initially shown.

Modal exclusion

There are two modal exclusion types introduced as of JDK 6

  • Exclusion from blocking of toolkit-modal dialogs
  • Exclusion from blocking of application-modal dialogs
By default, a window's modal exclusion property is turned off.

  1. Application-modal exclusion
    If a window is application-modal excluded, it is not blocked by any application-modal dialogs. Also, it is not blocked by document-modal dialogs from outside of its child hierarchy.
  2. Toolkit-modal exclusion
    If a window is toolkit-modal excluded, it is not blocked by any application- or toolkit-modal dialogs. Also, it is not blocked by document-modal dialogs from outside of their child hierarchy.

Implementation note: Changing the modal exclusion type for a visible window may have no effect until it is hidden and then shown again.

Related AWT features

Always-On-Top
When a modal dialog that is not always-on-top blocks an always-on-top window, their relative Z-order is unspecified and platform-dependent.

The toFront() and toBack() methods
A modal dialog should always be above all its blocked windows. Thus, if a blocked window is brought to the front, its blocking dialog, if any, is also brought to the front and remains above the blocked window. Likewise, if a modal dialog is sent to the back, all of its blocked windows are sent to the back to keep them below the blocking dialog.

Minimizing, maximizing and closing blocked windows
When a modal dialog blocks a window, the user may not be able to maximize or minimize the blocked window— however, the actual behavior is unspecified and platform-dependent. In any case, the user can't close the blocked window interactively— but it can be closed programmatically by calling the setVisible(false) or dispose() methods on the blocked window.

Blocked windows activations
When the user selects a blocked window, it may be brought to the front, along with the blocking modal dialog which would then become the active window— however, the actual behavior is unspecified and platform-dependent.

Hiding a modal dialog
When the modal dialog that currently has focus is hidden, it is unspecified and platform-dependent, which other window will become the active window. Any of the following may become the active window:

  1. The owner of the modal dialog - if the owner is unblocked.
  2. The Window, which was active before this modal dialog gained focus - if the owner of the modal dialog is absent or is blocked.
If the modal dialog to be hidden does not have focus, the active window remains unchanged.

Security

A special AWTPermission, "toolkitModality", is required to show toolkit-modal dialogs. This would prevent, for example, blocking a browser or Java Web Start (JWS) by modal dialogs shown from applets.

The same permission is required to exclude a window from toolkit modality. This would prevent, for example, a dialog shown from an applet not to be blocked by a browser's or JWS's modal dialog.

Platform support

Two java.awt.Toolkit methods allow you to check whether the current platform supports specific modality features:

  • isModalityTypeSupported(modalityType)
    Returns whether the specified modality type is supported on the current platform. If mode "M" is not supported and a dialog is set to M-modal, it behaves as modeless.
  • isModalExclusionTypeSupported(modalExclusionType)
    Returns whether the given modal exclusion type is supported on the current platform. If exclusion type "E" is not supported and a window is marked as E-excluded, this has no effect.

Compatibility

The default modality type is application-modal. It is used by the API calls: Dialog.setModal(true), Dialog(owner, true), etc. Prior to JDK 6 the default type was toolkit-modal, but the only distinction between application- and toolkit-modality is for applets and applications launched from Java Web Start.

Examples

  1. Frame "F" is shown
  2. Document-modal dialog "Di" is shown
  3. F becomes blocked by Di — it's in the same document
  4. Document-modal dialog "Dii" is shown
  5. Di becomes blocked by Dii — it's in the same document
  1. Frame "F" is shown
  2. Document-modal dialog "Di" is shown
  3. F becomes blocked by Di — it's in the same document
  4. Document-modal dialog "Dii" is shown
  5. Di becomes blocked by Dii — it's in the same document
  6. Di is hidden
  7. F becomes blocked by Dii — it's in the same document
  1. Frame "F" is shown
  2. Toolkit-modal dialog "Di" is created, but not shown
  3. Document-modal dialog "Dii" is shown
  4. F becomes blocked by Dii — it's in the same document
  5. Application-modal dialog "Diii" is shown
  6. Dii becomes blocked by Diii — it's in the same application
  7. Di is shown
  8. Di becomes blocked by Dii — it's its owner
  9. Diii remains unblocked — it blocks Dii and Dii blocks Di
  1. Frame "F" is shown
  2. Toolkit-modal dialog "Di" is created, but not shown
  3. Document-modal dialog "Dii" is shown
  4. F becomes blocked by Dii — it's in the same document
  5. Application-modal dialog "Diii" is shown
  6. Dii becomes blocked by Diii — it's in the same application
  7. Di is shown
  8. Diii becomes blocked by Di — Di is not blocked
  9. Di remains unblocked


java.awt.event (Java 2 Platform SE 6)

 java.awt.event
接口
ActionListener
AdjustmentListener
AWTEventListener
ComponentListener
ContainerListener
FocusListener
HierarchyBoundsListener
HierarchyListener
InputMethodListener
ItemListener
KeyListener
MouseListener
MouseMotionListener
MouseWheelListener
TextListener
WindowFocusListener
WindowListener
WindowStateListener
类
ActionEvent
AdjustmentEvent
AWTEventListenerProxy
ComponentAdapter
ComponentEvent
ContainerAdapter
ContainerEvent
FocusAdapter
FocusEvent
HierarchyBoundsAdapter
HierarchyEvent
InputEvent
InputMethodEvent
InvocationEvent
ItemEvent
KeyAdapter
KeyEvent
MouseAdapter
MouseEvent
MouseMotionAdapter
MouseWheelEvent
PaintEvent
TextEvent
WindowAdapter
WindowEvent


类 java.awt.event.ActionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ActionEvent
的使用

使用 ActionEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 ActionEvent 的使用

参数类型为 ActionEvent 的 java.awt 中的方法
void | List.AccessibleAWTList.actionPerformed(ActionEvent event)
void | AWTEventMulticaster.actionPerformed(ActionEvent e) 通过在侦听器 a 和侦听器 b 上调用 actionPerformed 方法处理 actionPerformed 事件。
protected void | Button.processActionEvent(ActionEvent e) 处理发生在此按钮上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。
protected void | List.processActionEvent(ActionEvent e) 处理发生在此列表上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。
protected void | TextField.processActionEvent(ActionEvent e) 处理发生在此文本字段上的操作事件：将这些事件指派给所有已注册的 ActionListener 对象。
protected void | MenuItem.processActionEvent(ActionEvent e) 处理此菜单项上发生的动作事件，方法是将其指派给任何已注册的 ActionListener 对象。

java.awt.dnd 中 ActionEvent 的使用

参数类型为 ActionEvent 的 java.awt.dnd 中的方法
 void DropTarget.DropTargetAutoScroller.actionPerformed(ActionEvent e)
导致发生自动滚动

java.awt.event 中 ActionEvent 的使用

参数类型为 ActionEvent 的 java.awt.event 中的方法
 void ActionListener.actionPerformed(ActionEvent e)
发生操作时调用。

javax.swing 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing 中的方法
void | DefaultCellEditor.EditorDelegate.actionPerformed(ActionEvent e) 在执行操作时，编辑被终止。
void | JComboBox.actionPerformed(ActionEvent e) 此方法由于实现的副作用而存在的公共方法。
void | ToolTipManager.insideTimerAction.actionPerformed(ActionEvent e)
void | ToolTipManager.outsideTimerAction.actionPerformed(ActionEvent e)
void | ToolTipManager.stillInsideTimerAction.actionPerformed(ActionEvent e)
protected void | DefaultButtonModel.fireActionPerformed(ActionEvent e) 通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected void | Timer.fireActionPerformed(ActionEvent e) 通知为此事件类型的通知而注册的所有侦听器。
protected void | AbstractButton.fireActionPerformed(ActionEvent event) 通知所有需要此事件类型的通知的已注册侦听器。

javax.swing.plaf.basic 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing.plaf.basic 中的方法
void | BasicDesktopPaneUI.OpenAction.actionPerformed(ActionEvent evt)
void | BasicDesktopPaneUI.CloseAction.actionPerformed(ActionEvent evt)
void | BasicDesktopPaneUI.MinimizeAction.actionPerformed(ActionEvent evt)
void | BasicDesktopPaneUI.MaximizeAction.actionPerformed(ActionEvent evt)
void | BasicDesktopPaneUI.NavigateAction.actionPerformed(ActionEvent evt)
void | BasicFileChooserUI.NewFolderAction.actionPerformed(ActionEvent e)
void | BasicFileChooserUI.GoHomeAction.actionPerformed(ActionEvent e)
void | BasicFileChooserUI.ChangeToParentDirectoryAction.actionPerformed(ActionEvent e)
void | BasicFileChooserUI.ApproveSelectionAction.actionPerformed(ActionEvent e)
void | BasicFileChooserUI.CancelSelectionAction.actionPerformed(ActionEvent e)
void | BasicFileChooserUI.UpdateAction.actionPerformed(ActionEvent e)
void | BasicInternalFrameTitlePane.CloseAction.actionPerformed(ActionEvent e)
void | BasicInternalFrameTitlePane.MaximizeAction.actionPerformed(ActionEvent evt)
void | BasicInternalFrameTitlePane.IconifyAction.actionPerformed(ActionEvent e)
void | BasicInternalFrameTitlePane.RestoreAction.actionPerformed(ActionEvent evt)
void | BasicInternalFrameTitlePane.MoveAction.actionPerformed(ActionEvent e)
void | BasicInternalFrameTitlePane.SizeAction.actionPerformed(ActionEvent e)
void | BasicOptionPaneUI.ButtonActionListener.actionPerformed(ActionEvent e)
void | BasicSliderUI.ScrollListener.actionPerformed(ActionEvent e)
void | BasicSliderUI.ActionScroller.actionPerformed(ActionEvent e)
void | BasicSplitPaneUI.KeyboardUpLeftHandler.actionPerformed(ActionEvent ev)
void | BasicSplitPaneUI.KeyboardDownRightHandler.actionPerformed(ActionEvent ev)
void | BasicSplitPaneUI.KeyboardHomeHandler.actionPerformed(ActionEvent ev)
void | BasicSplitPaneUI.KeyboardEndHandler.actionPerformed(ActionEvent ev)
void | BasicSplitPaneUI.KeyboardResizeToggleHandler.actionPerformed(ActionEvent ev)
void | BasicTreeUI.ComponentHandler.actionPerformed(ActionEvent ae) 因 Timer 而将此方法作为公共方法。
void | BasicTreeUI.TreeTraverseAction.actionPerformed(ActionEvent e)
void | BasicTreeUI.TreePageAction.actionPerformed(ActionEvent e)
void | BasicTreeUI.TreeIncrementAction.actionPerformed(ActionEvent e)
void | BasicTreeUI.TreeHomeAction.actionPerformed(ActionEvent e)
void | BasicTreeUI.TreeToggleAction.actionPerformed(ActionEvent e)
void | BasicTreeUI.TreeCancelEditingAction.actionPerformed(ActionEvent e)
void | BasicScrollBarUI.ScrollListener.actionPerformed(ActionEvent e)

javax.swing.plaf.metal 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing.plaf.metal 中的方法
 void MetalFileChooserUI.DirectoryComboBoxAction.actionPerformed(ActionEvent e)

javax.swing.text 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing.text 中的方法
void | StyledEditorKit.FontFamilyAction.actionPerformed(ActionEvent e) 设置字体系列。
void | StyledEditorKit.FontSizeAction.actionPerformed(ActionEvent e) 设置字体大小。
void | StyledEditorKit.ForegroundAction.actionPerformed(ActionEvent e) 设置前景色。
void | StyledEditorKit.AlignmentAction.actionPerformed(ActionEvent e) 设置对齐方式。
void | StyledEditorKit.BoldAction.actionPerformed(ActionEvent e) 切换粗体属性。
void | StyledEditorKit.ItalicAction.actionPerformed(ActionEvent e) 切换斜体属性。
void | StyledEditorKit.UnderlineAction.actionPerformed(ActionEvent e) 切换下划线属性。
void | DefaultEditorKit.DefaultKeyTypedAction.actionPerformed(ActionEvent e) 动作触发时执行的操作。
void | DefaultEditorKit.InsertContentAction.actionPerformed(ActionEvent e) 此动作触发时执行的操作。
void | DefaultEditorKit.InsertBreakAction.actionPerformed(ActionEvent e) 触发此动作时执行该操作。
void | DefaultEditorKit.InsertTabAction.actionPerformed(ActionEvent e) 此动作触发时执行的操作。
void | DefaultEditorKit.CutAction.actionPerformed(ActionEvent e) 触发此动作时执行的操作。
void | DefaultEditorKit.CopyAction.actionPerformed(ActionEvent e) 触发此动作时执行的操作。
void | DefaultEditorKit.PasteAction.actionPerformed(ActionEvent e) 触发此动作时执行的操作。
void | DefaultEditorKit.BeepAction.actionPerformed(ActionEvent e) 触发此动作时执行的操作。
protected JEditorPane | StyledEditorKit.StyledTextAction.getEditor(ActionEvent e) 获得操作的目标编辑器。
protected JTextComponent | TextAction.getTextComponent(ActionEvent e) 确定动作所使用的组件。

javax.swing.text.html 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing.text.html 中的方法
void | FormView.actionPerformed(ActionEvent evt) 负责处理 ActionEvent。
void | HTMLEditorKit.InsertHTMLTextAction.actionPerformed(ActionEvent ae) 将 HTML 插入文档。

javax.swing.tree 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing.tree 中的方法
 void DefaultTreeCellEditor.actionPerformed(ActionEvent e)
计时器被激发时传递消息，这将启动编辑会话。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.ActionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.ActionListener
的使用

使用 ActionListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 ActionListener 的使用

实现 ActionListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。

返回 ActionListener 的 java.awt 中的方法
static ActionListener | AWTEventMulticaster.add(ActionListener a, ActionListener b) 添加操作侦听器 a 和操作侦听器 b，并返回得到的多路广播侦听器。
ActionListener[] | Button.getActionListeners() 返回在此按钮上注册的所有动作侦听器的一个数组。
ActionListener[] | List.getActionListeners() 返回已在此列表上注册的所有动作侦听器的数组。
ActionListener[] | TextField.getActionListeners() 返回此文本字段上已注册的所有操作侦听器的数组。
ActionListener[] | TrayIcon.getActionListeners() 返回在已此 TrayIcon 上注册的所有动作侦听器的数组。
ActionListener[] | MenuItem.getActionListeners() 返回在此菜单项上注册的所有动作侦听器组成的数组。
static ActionListener | AWTEventMulticaster.remove(ActionListener l, ActionListener oldl) 从操作侦听器 l 中移除旧的操作侦听器，并返回得到的多路广播侦听器。

参数类型为 ActionListener 的 java.awt 中的方法
static ActionListener | AWTEventMulticaster.add(ActionListener a, ActionListener b) 添加操作侦听器 a 和操作侦听器 b，并返回得到的多路广播侦听器。
void | Button.addActionListener(ActionListener l) 添加指定的动作侦听器，以接收发自此按钮的动作事件。
void | List.addActionListener(ActionListener l) 添加指定的动作侦听器以从此列表接收动作事件。
void | TextField.addActionListener(ActionListener l) 添加指定的操作侦听器，以从此文本字段接收操作事件。
void | TrayIcon.addActionListener(ActionListener listener) 添加指定的动作侦听器，以接收发自此 TrayIcon 的 ActionEvent。
void | MenuItem.addActionListener(ActionListener l) 添加指定的动作侦听器，以从此菜单项接收动作事件。
static ActionListener | AWTEventMulticaster.remove(ActionListener l, ActionListener oldl) 从操作侦听器 l 中移除旧的操作侦听器，并返回得到的多路广播侦听器。
void | Button.removeActionListener(ActionListener l) 移除指定的动作侦听器，以便它不再接收发自此按钮的动作事件。
void | List.removeActionListener(ActionListener l) 移除指定的动作侦听器，以便不再从此列表接收动作事件。
void | TextField.removeActionListener(ActionListener l) 移除指定的操作侦听器，不再从此文本字段接收操作事件。
void | TrayIcon.removeActionListener(ActionListener listener) 移除指定的动作侦听器。
void | MenuItem.removeActionListener(ActionListener l) 移除指定的动作侦听器，使其不再从此菜单项中接收动作事件。

java.awt.dnd 中 ActionListener 的使用

实现 ActionListener 的 java.awt.dnd 中的类
protected static class DropTarget.DropTargetAutoScroller
此受保护的嵌套类实现自动滚动

javax.swing 中 ActionListener 的使用

javax.swing 中 ActionListener 的子接口
 interface Action
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。

实现 ActionListener 的 javax.swing 中的类
class | AbstractAction 此类提供 JFC Action 接口的默认实现。
protected class | DefaultCellEditor.EditorDelegate 受保护的 (protected) EditorDelegate 类。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
protected class | ToolTipManager.insideTimerAction
protected class | ToolTipManager.outsideTimerAction
protected class | ToolTipManager.stillInsideTimerAction

声明为 ActionListener 的 javax.swing 中的字段
protected  ActionListener AbstractButton.actionListener
按钮模型的 ActionListener。

返回 ActionListener 的 javax.swing 中的方法
protected  ActionListener AbstractButton.createActionListener()
 ActionListener JComponent.getActionForKeyStroke(KeyStroke aKeyStroke)
返回执行针对给定键击而注册的操作的对象。
 ActionListener[] JFileChooser.getActionListeners()
返回在此文件选择器上注册的所有操作侦听器的数组。
 ActionListener[] JTextField.getActionListeners()
返回通过 addActionListener() 添加到此 JTextField 中的所有 ActionListener 的数组。
 ActionListener[] JComboBox.getActionListeners()
返回使用 addActionListener() 添加到此 JComboBox 的所有 ActionListener 组成的数组。
 ActionListener[] DefaultButtonModel.getActionListeners()
返回此 DefaultButtonModel 上所有已注册的操作侦听器组成的数组。
 ActionListener[] Timer.getActionListeners()
返回已在此计时器上注册的所有动作侦听器所组成的数组。
 ActionListener[] AbstractButton.getActionListeners()
返回使用 addActionListener() 添加到此 AbstractButton 的所有 ActionListener 组成的数组。

参数类型为 ActionListener 的 javax.swing 中的方法
 void JFileChooser.addActionListener(ActionListener l)
向文件选择器添加一个 ActionListener。
 void JTextField.addActionListener(ActionListener l)
添加指定的操作侦听器以从此文本字段接收操作事件。
 void ComboBoxEditor.addActionListener(ActionListener l)
添加一个 ActionListener。
 void JComboBox.addActionListener(ActionListener l)
添加 ActionListener。
 void DefaultButtonModel.addActionListener(ActionListener l)
向模型添加一个 ActionListener。
 void ButtonModel.addActionListener(ActionListener l)
向模型添加一个 ActionListener。
 void Timer.addActionListener(ActionListener listener)
将一个动作侦听器添加到 Timer。
 void AbstractButton.addActionListener(ActionListener l)
将一个 ActionListener 添加到按钮中。
static JDialog JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
 void JComponent.registerKeyboardAction(ActionListener anAction, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
 void JComponent.registerKeyboardAction(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
 void JFileChooser.removeActionListener(ActionListener l)
从文件选择器中移除一个 ActionListener。
 void JTextField.removeActionListener(ActionListener l)
移除指定的操作侦听器，以便不再从此文本字段接收操作事件。
 void ComboBoxEditor.removeActionListener(ActionListener l)
移除一个 ActionListener
 void JComboBox.removeActionListener(ActionListener l)
移除 ActionListener。
 void DefaultButtonModel.removeActionListener(ActionListener l)
从模型中移除一个 ActionListener。
 void ButtonModel.removeActionListener(ActionListener l)
从模型中移除一个 ActionListener。
 void Timer.removeActionListener(ActionListener listener)
从 Timer 移除指定的动作侦听器。
 void AbstractButton.removeActionListener(ActionListener l)
从按钮中移除一个 ActionListener。

参数类型为 ActionListener 的 javax.swing 中的构造方法
Timer(int delay, ActionListener listener)
创建一个 Timer 并将初始延迟和事件间延迟初始化为 delay 毫秒。

javax.swing.plaf.basic 中 ActionListener 的使用

实现 ActionListener 的 javax.swing.plaf.basic 中的类
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicOptionPaneUI.ButtonActionListener 此内部类因编译器故障而被标记为“公开”。
protected class | BasicScrollBarUI.ScrollListener 在 ScrollPane 中发起的滚动事件的侦听器。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicSliderUI.ScrollListener 滚动事件侦听器。
class | BasicSplitPaneUI.KeyboardDownRightHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardEndHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardHomeHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardResizeToggleHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardUpLeftHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicTreeUI.ComponentHandler 滚动时更新首选大小（如果需要）。
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。

声明为 ActionListener 的 javax.swing.plaf.basic 中的字段
protected ActionListener | BasicSplitPaneUI.keyboardDownRightListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardEndListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardHomeListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardResizeToggleListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardUpLeftListener 已过时。 从 Java 2 platform v1.3 开始。

返回 ActionListener 的 javax.swing.plaf.basic 中的方法
protected ActionListener | BasicOptionPaneUI.createButtonActionListener(int buttonIndex)
protected ActionListener | BasicSplitPaneUI.createKeyboardDownRightListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardEndListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardHomeListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardResizeToggleListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardUpLeftListener() 已过时。 从 Java 2 platform v1.3 开始。

参数类型为 ActionListener 的 javax.swing.plaf.basic 中的方法
void | BasicComboBoxEditor.addActionListener(ActionListener l)
void | BasicComboBoxEditor.removeActionListener(ActionListener l)

javax.swing.plaf.metal 中 ActionListener 的使用

实现 ActionListener 的 javax.swing.plaf.metal 中的类
protected  class MetalFileChooserUI.DirectoryComboBoxAction
当 DirectoryComboBox 已更改所选项时调用。

javax.swing.text 中 ActionListener 的使用

实现 ActionListener 的 javax.swing.text 中的类
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

javax.swing.text.html 中 ActionListener 的使用

实现 ActionListener 的 javax.swing.text.html 中的类
class | FormView 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

javax.swing.tree 中 ActionListener 的使用

实现 ActionListener 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor
TreeCellEditor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.AdjustmentEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.AdjustmentEvent
的使用

使用 AdjustmentEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt 中 AdjustmentEvent 的使用

参数类型为 AdjustmentEvent 的 java.awt 中的方法
void | AWTEventMulticaster.adjustmentValueChanged(AdjustmentEvent e) 通过在侦听器 a 和侦听器 b 上调用 adjustmentValueChanged 方法处理 adjustmentValueChanged 事件。
protected void | Scrollbar.processAdjustmentEvent(AdjustmentEvent e) 处理此滚动条上发生的调整事件，方法是将其指派到任意已注册的 AdjustmentListener 对象。

java.awt.event 中 AdjustmentEvent 的使用

参数类型为 AdjustmentEvent 的 java.awt.event 中的方法
 void AdjustmentListener.adjustmentValueChanged(AdjustmentEvent e)
在可调整的值发生更改时调用该方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.AdjustmentListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.AdjustmentListener
的使用

使用 AdjustmentListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 AdjustmentListener 的使用

实现 AdjustmentListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 AdjustmentListener 的 java.awt 中的方法
static AdjustmentListener | AWTEventMulticaster.add(AdjustmentListener a, AdjustmentListener b) 添加调整侦听器 a 和调整侦听器 b，并返回得到的多路广播侦听器。
AdjustmentListener[] | ScrollPaneAdjustable.getAdjustmentListeners() 返回在此 ScrollPaneAdjustable 上所有已注册调整侦听器组成的数组。
AdjustmentListener[] | Scrollbar.getAdjustmentListeners() 返回在此滚动条上所有已注册调整侦听器组成的数组。
static AdjustmentListener | AWTEventMulticaster.remove(AdjustmentListener l, AdjustmentListener oldl) 从调整侦听器 l 中移除旧的调整侦听器，并返回得到的多路广播侦听器。

参数类型为 AdjustmentListener 的 java.awt 中的方法
static AdjustmentListener | AWTEventMulticaster.add(AdjustmentListener a, AdjustmentListener b) 添加调整侦听器 a 和调整侦听器 b，并返回得到的多路广播侦听器。
void | ScrollPaneAdjustable.addAdjustmentListener(AdjustmentListener l) 添加指定的调整侦听器，以接收发自此 ScrollPaneAdjustable 的调整事件。
void | Scrollbar.addAdjustmentListener(AdjustmentListener l) 添加指定的调整侦听器，以接收发自此滚动条的 AdjustmentEvent 实例。
void | Adjustable.addAdjustmentListener(AdjustmentListener l) 添加侦听器，以便在可调整对象的值更改时接收调整事件。
static AdjustmentListener | AWTEventMulticaster.remove(AdjustmentListener l, AdjustmentListener oldl) 从调整侦听器 l 中移除旧的调整侦听器，并返回得到的多路广播侦听器。
void | ScrollPaneAdjustable.removeAdjustmentListener(AdjustmentListener l) 移除指定的调整侦听器，不再接收发自此 ScrollPaneAdjustable 的调整事件。
void | Scrollbar.removeAdjustmentListener(AdjustmentListener l) 移除指定的调整侦听器，不再接收发自此滚动条的 AdjustmentEvent 实例。
void | Adjustable.removeAdjustmentListener(AdjustmentListener l) 移除一个调整侦听器。

javax.swing 中 AdjustmentListener 的使用

返回 AdjustmentListener 的 javax.swing 中的方法
 AdjustmentListener[] JScrollBar.getAdjustmentListeners()
返回使用 addAdjustmentListener() 添加到此 JScrollBar 中的 AdjustmentListener 组成的数组。

参数类型为 AdjustmentListener 的 javax.swing 中的方法
void | JScrollBar.addAdjustmentListener(AdjustmentListener l) 添加一个 AdjustmentListener。
void | JScrollBar.removeAdjustmentListener(AdjustmentListener l) 移除一个 AdjustmentEvent 侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.AWTEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.AWTEventListener
的使用

使用 AWTEventListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt 中 AWTEventListener 的使用

返回 AWTEventListener 的 java.awt 中的方法
AWTEventListener[] | Toolkit.getAWTEventListeners() 返回在此工具包上所有已注册 AWTEventListener 所组成的数组。
AWTEventListener[] | Toolkit.getAWTEventListeners(long eventMask) 返回已在此工具包上注册的所有 AWTEventListener 所组成的数组，这些侦听器侦听用 eventMask 参数指定的所有事件类型。

参数类型为 AWTEventListener 的 java.awt 中的方法
void | Toolkit.addAWTEventListener(AWTEventListener listener, long eventMask) 添加一个 AWTEventListener，以接收与给定 eventMask 一致的系统范围内指派的所有 AWTEvent。
void | Toolkit.removeAWTEventListener(AWTEventListener listener) 从正接收的指派 AWTEvent 中移除一个 AWTEventListener。

java.awt.event 中 AWTEventListener 的使用

实现 AWTEventListener 的 java.awt.event 中的类
 class AWTEventListenerProxy
扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。

参数类型为 AWTEventListener 的 java.awt.event 中的构造方法
AWTEventListenerProxy(long eventMask, AWTEventListener listener)
将 AWTEventListener 绑定到特定事件掩码的构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.AWTEventListenerProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.AWTEventListenerProxy
的使用

没有 java.awt.event.AWTEventListenerProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.ComponentAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ComponentAdapter
的使用

使用 ComponentAdapter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 ComponentAdapter 的使用

javax.swing 中 ComponentAdapter 的子类
protected  class JViewport.ViewListener
视图的侦听器。

javax.swing.plaf.basic 中 ComponentAdapter 的使用

javax.swing.plaf.basic 中 ComponentAdapter 的子类
class | BasicSliderUI.ComponentHandler 调整事件大小的侦听器。
class | BasicTreeUI.ComponentHandler 滚动时更新首选大小（如果需要）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.ComponentEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ComponentEvent
的使用

使用 ComponentEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 ComponentEvent 的使用

参数类型为 ComponentEvent 的 java.awt 中的方法
void | AWTEventMulticaster.componentHidden(ComponentEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentHidden 方法处理 componentHidden 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentHidden(ComponentEvent e)
void | AWTEventMulticaster.componentMoved(ComponentEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentMoved 方法处理 componentMoved 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentMoved(ComponentEvent e)
void | AWTEventMulticaster.componentResized(ComponentEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentResized 方法处理 componentResized 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentResized(ComponentEvent e)
void | AWTEventMulticaster.componentShown(ComponentEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentShown 方法处理 componentShown 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentShown(ComponentEvent e)
protected void | Component.processComponentEvent(ComponentEvent e) 处理组件上发生的组件事件，方法是将其指派到任意已注册的 ComponentListener 对象。

java.awt.event 中 ComponentEvent 的使用

java.awt.event 中 ComponentEvent 的子类
class | ContainerEvent 指示容器内容因为添加或移除组件而更改的低级别事件。
class | FocusEvent 指示 Component 已获得或失去输入焦点的低级别事件。
class | InputEvent 所有组件级别输入事件的根事件类。
class | KeyEvent 表示组件中发生键击的事件。
class | MouseEvent 指示组件中发生鼠标动作的事件。
class | MouseWheelEvent 表示鼠标滚轮在组件中滚动的事件。
class | PaintEvent 组件级绘制事件。
class | WindowEvent 指示窗口状态改变的低级别事件。

参数类型为 ComponentEvent 的 java.awt.event 中的方法
void | ComponentAdapter.componentHidden(ComponentEvent e) 组件变得不可见时调用。
void | ComponentListener.componentHidden(ComponentEvent e) 组件变得不可见时调用。
void | ComponentAdapter.componentMoved(ComponentEvent e) 组件位置更改时调用。
void | ComponentListener.componentMoved(ComponentEvent e) 组件位置更改时调用。
void | ComponentAdapter.componentResized(ComponentEvent e) 组件大小更改时调用。
void | ComponentListener.componentResized(ComponentEvent e) 组件大小更改时调用。
void | ComponentAdapter.componentShown(ComponentEvent e) 组件变得可见时调用。
void | ComponentListener.componentShown(ComponentEvent e) 组件变得可见时调用。

javax.swing 中 ComponentEvent 的使用

参数类型为 ComponentEvent 的 javax.swing 中的方法
 void JViewport.ViewListener.componentResized(ComponentEvent e)

javax.swing.event 中 ComponentEvent 的使用

javax.swing.event 中 ComponentEvent 的子类
class | MenuDragMouseEvent MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
class | MenuKeyEvent MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

javax.swing.plaf.basic 中 ComponentEvent 的使用

参数类型为 ComponentEvent 的 javax.swing.plaf.basic 中的方法
void | BasicInternalFrameUI.ComponentHandler.componentHidden(ComponentEvent e)
void | BasicInternalFrameUI.ComponentHandler.componentMoved(ComponentEvent e)
void | BasicTreeUI.ComponentHandler.componentMoved(ComponentEvent e)
void | BasicInternalFrameUI.ComponentHandler.componentResized(ComponentEvent e) 当 JInternalFrame 的父级大小更改时调用。
void | BasicSliderUI.ComponentHandler.componentResized(ComponentEvent e)
void | BasicInternalFrameUI.ComponentHandler.componentShown(ComponentEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.ComponentListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.ComponentListener
的使用

使用 ComponentListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 ComponentListener 的使用

实现 ComponentListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）

声明为 ComponentListener 的 java.awt 中的字段
protected  ComponentListener Component.AccessibleAWTComponent.accessibleAWTComponentHandler

返回 ComponentListener 的 java.awt 中的方法
static ComponentListener | AWTEventMulticaster.add(ComponentListener a, ComponentListener b) 添加组件侦听器 a 和组件侦听器 b，并返回得到的多路广播侦听器。
ComponentListener[] | Component.getComponentListeners() 返回在此组件上所有已注册的组件侦听器的数组。
static ComponentListener | AWTEventMulticaster.remove(ComponentListener l, ComponentListener oldl) 从组件侦听器 l 中移除旧的组件侦听器，并返回得到的多路广播侦听器。

参数类型为 ComponentListener 的 java.awt 中的方法
static ComponentListener | AWTEventMulticaster.add(ComponentListener a, ComponentListener b) 添加组件侦听器 a 和组件侦听器 b，并返回得到的多路广播侦听器。
void | Component.addComponentListener(ComponentListener l) 添加指定的组件侦听器，以接收发自此组件的组件事件。
static ComponentListener | AWTEventMulticaster.remove(ComponentListener l, ComponentListener oldl) 从组件侦听器 l 中移除旧的组件侦听器，并返回得到的多路广播侦听器。
void | Component.removeComponentListener(ComponentListener l) 移除指定的组件侦听器，以便它不再接收发自此组件的组件事件。

java.awt.event 中 ComponentListener 的使用

实现 ComponentListener 的 java.awt.event 中的类
 class ComponentAdapter
用于接收组件事件的抽象适配器类。

javax.swing 中 ComponentListener 的使用

实现 ComponentListener 的 javax.swing 中的类
protected  class JViewport.ViewListener
视图的侦听器。

javax.swing.plaf.basic 中 ComponentListener 的使用

实现 ComponentListener 的 javax.swing.plaf.basic 中的类
protected class | BasicInternalFrameUI.ComponentHandler
class | BasicSliderUI.ComponentHandler 调整事件大小的侦听器。
class | BasicTreeUI.ComponentHandler 滚动时更新首选大小（如果需要）。

声明为 ComponentListener 的 javax.swing.plaf.basic 中的字段
protected ComponentListener | BasicInternalFrameUI.componentListener
protected ComponentListener | BasicSliderUI.componentListener

返回 ComponentListener 的 javax.swing.plaf.basic 中的方法
protected ComponentListener | BasicInternalFrameUI.createComponentListener()
protected ComponentListener | BasicTreeUI.createComponentListener() 创建并返回新的 ComponentHandler。
protected ComponentListener | BasicSliderUI.createComponentListener(JSlider slider)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.ContainerAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ContainerAdapter
的使用

没有 java.awt.event.ContainerAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.ContainerEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ContainerEvent
的使用

使用 ContainerEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 ContainerEvent 的使用

参数类型为 ContainerEvent 的 java.awt 中的方法
void | AWTEventMulticaster.componentAdded(ContainerEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentAdded 方法处理 componentAdded 容器事件。
void | Container.AccessibleAWTContainer.AccessibleContainerHandler.componentAdded(ContainerEvent e)
void | AWTEventMulticaster.componentRemoved(ContainerEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentRemoved 方法处理 componentRemoved 容器事件。
void | Container.AccessibleAWTContainer.AccessibleContainerHandler.componentRemoved(ContainerEvent e)
protected void | Container.processContainerEvent(ContainerEvent e) 通过将发生在此容器上的容器事件指派给所有已注册的 ContainerListener 对象来处理这些事件。

java.awt.event 中 ContainerEvent 的使用

参数类型为 ContainerEvent 的 java.awt.event 中的方法
void | ContainerAdapter.componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | ContainerListener.componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | ContainerAdapter.componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。
void | ContainerListener.componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。

javax.swing 中 ContainerEvent 的使用

参数类型为 ContainerEvent 的 javax.swing 中的方法
void | JComponent.AccessibleJComponent.AccessibleContainerHandler.componentAdded(ContainerEvent e)
void | JComponent.AccessibleJComponent.AccessibleContainerHandler.componentRemoved(ContainerEvent e)

javax.swing.plaf.basic 中 ContainerEvent 的使用

参数类型为 ContainerEvent 的 javax.swing.plaf.basic 中的方法
void | BasicToolBarUI.ToolBarContListener.componentAdded(ContainerEvent e)
void | BasicToolBarUI.ToolBarContListener.componentRemoved(ContainerEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.ContainerListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.ContainerListener
的使用

使用 ContainerListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

java.awt 中 ContainerListener 的使用

实现 ContainerListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | Container.AccessibleAWTContainer.AccessibleContainerHandler 添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

声明为 ContainerListener 的 java.awt 中的字段
protected  ContainerListener Container.AccessibleAWTContainer.accessibleContainerHandler

返回 ContainerListener 的 java.awt 中的方法
static ContainerListener | AWTEventMulticaster.add(ContainerListener a, ContainerListener b) 添加容器侦听器 a 和容器侦听器 b，并返回得到的多路广播侦听器。
ContainerListener[] | Container.getContainerListeners() 返回已在此容器上注册的所有容器侦听器的数组。
static ContainerListener | AWTEventMulticaster.remove(ContainerListener l, ContainerListener oldl) 从容器侦听器 l 中移除旧的容器侦听器，并返回得到的多路广播侦听器。

参数类型为 ContainerListener 的 java.awt 中的方法
static ContainerListener | AWTEventMulticaster.add(ContainerListener a, ContainerListener b) 添加容器侦听器 a 和容器侦听器 b，并返回得到的多路广播侦听器。
void | Container.addContainerListener(ContainerListener l) 添加指定容器的侦听器，以接收来自此容器的容器事件。
static ContainerListener | AWTEventMulticaster.remove(ContainerListener l, ContainerListener oldl) 从容器侦听器 l 中移除旧的容器侦听器，并返回得到的多路广播侦听器。
void | Container.removeContainerListener(ContainerListener l) 移除指定容器的侦听器，从而不再接收来自此容器的容器事件。

java.awt.event 中 ContainerListener 的使用

实现 ContainerListener 的 java.awt.event 中的类
 class ContainerAdapter
用于接收容器事件的抽象适配器类。

javax.swing 中 ContainerListener 的使用

实现 ContainerListener 的 javax.swing 中的类
protected  class JComponent.AccessibleJComponent.AccessibleContainerHandler
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

声明为 ContainerListener 的 javax.swing 中的字段
protected  ContainerListener JComponent.AccessibleJComponent.accessibleContainerHandler

javax.swing.plaf.basic 中 ContainerListener 的使用

实现 ContainerListener 的 javax.swing.plaf.basic 中的类
protected  class BasicToolBarUI.ToolBarContListener

声明为 ContainerListener 的 javax.swing.plaf.basic 中的字段
protected ContainerListener | BasicMenuBarUI.containerListener
protected ContainerListener | BasicToolBarUI.toolBarContListener

返回 ContainerListener 的 javax.swing.plaf.basic 中的方法
protected ContainerListener | BasicMenuBarUI.createContainerListener()
protected ContainerListener | BasicToolBarUI.createToolBarContListener()

javax.swing.plaf.metal 中 ContainerListener 的使用

实现 ContainerListener 的 javax.swing.plaf.metal 中的类
protected  class MetalToolBarUI.MetalContainerListener

声明为 ContainerListener 的 javax.swing.plaf.metal 中的字段
protected  ContainerListener MetalToolBarUI.contListener
此受保护的字段是特定于实现的。

返回 ContainerListener 的 javax.swing.plaf.metal 中的方法
protected  ContainerListener MetalToolBarUI.createContainerListener()
创建一个将添加到 JToolBar 中的容器侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.FocusAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.FocusAdapter
的使用

使用 FocusAdapter 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 FocusAdapter 的使用

javax.swing.plaf.basic 中 FocusAdapter 的子类
class | BasicSplitPaneUI.FocusHandler JSplitPane UI 使用的 FocusListener 的实现。
class | BasicTabbedPaneUI.FocusHandler 此类应视为“受保护”内部类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.FocusEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.FocusEvent
的使用

使用 FocusEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 FocusEvent 的使用

参数类型为 FocusEvent 的 java.awt 中的方法
void | AWTEventMulticaster.focusGained(FocusEvent e) 通过在侦听器 a 和侦听器 b 上调用 focusGained 方法处理 focusGained 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler.focusGained(FocusEvent event)
void | AWTEventMulticaster.focusLost(FocusEvent e) 通过在侦听器 a 和侦听器 b 上调用 focusLost 方法处理 focusLost 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler.focusLost(FocusEvent event)
protected void | Component.processFocusEvent(FocusEvent e) 处理组件上发生的焦点事件，方法是将其指派到任意已注册的 FocusListener 对象。

java.awt.event 中 FocusEvent 的使用

参数类型为 FocusEvent 的 java.awt.event 中的方法
void | FocusAdapter.focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | FocusListener.focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | FocusAdapter.focusLost(FocusEvent e) 组件失去键盘焦点时调用。
void | FocusListener.focusLost(FocusEvent e) 组件失去键盘焦点时调用。

javax.swing 中 FocusEvent 的使用

参数类型为 FocusEvent 的 javax.swing 中的方法
void | JComponent.AccessibleJComponent.AccessibleFocusHandler.focusGained(FocusEvent event)
void | JComponent.AccessibleJComponent.AccessibleFocusHandler.focusLost(FocusEvent event)
protected void | JFormattedTextField.processFocusEvent(FocusEvent e) 处理所有的焦点事件，如 FocusEvent.FOCUS_GAINED 或 FocusEvent.FOCUS_LOST。
protected void | JPopupMenu.processFocusEvent(FocusEvent evt)

javax.swing.plaf.basic 中 FocusEvent 的使用

参数类型为 FocusEvent 的 javax.swing.plaf.basic 中的方法
void | BasicSliderUI.FocusHandler.focusGained(FocusEvent e)
void | BasicSplitPaneUI.FocusHandler.focusGained(FocusEvent ev)
void | BasicTreeUI.FocusHandler.focusGained(FocusEvent e) 在当前树上激活焦点、重绘前导行时调用。
void | BasicTableUI.FocusHandler.focusGained(FocusEvent e)
void | BasicTabbedPaneUI.FocusHandler.focusGained(FocusEvent e)
void | BasicComboBoxEditor.focusGained(FocusEvent e)
void | BasicListUI.FocusHandler.focusGained(FocusEvent e)
void | BasicComboBoxUI.FocusHandler.focusGained(FocusEvent e)
void | BasicToolBarUI.ToolBarFocusListener.focusGained(FocusEvent e)
void | BasicButtonListener.focusGained(FocusEvent e)
void | BasicSliderUI.FocusHandler.focusLost(FocusEvent e)
void | BasicSplitPaneUI.FocusHandler.focusLost(FocusEvent ev)
void | BasicTreeUI.FocusHandler.focusLost(FocusEvent e) 在当前树上激活焦点、重绘前导行时调用。
void | BasicTableUI.FocusHandler.focusLost(FocusEvent e)
void | BasicTabbedPaneUI.FocusHandler.focusLost(FocusEvent e)
void | BasicComboBoxEditor.focusLost(FocusEvent e)
void | BasicListUI.FocusHandler.focusLost(FocusEvent e)
void | BasicComboBoxUI.FocusHandler.focusLost(FocusEvent e)
void | BasicToolBarUI.ToolBarFocusListener.focusLost(FocusEvent e)
void | BasicButtonListener.focusLost(FocusEvent e)

javax.swing.text 中 FocusEvent 的使用

参数类型为 FocusEvent 的 javax.swing.text 中的方法
void | DefaultCaret.focusGained(FocusEvent e) 在包含插入符的组件获得焦点时调用。
void | DefaultCaret.focusLost(FocusEvent e) 在包含插入符的组件失去焦点时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.FocusListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.FocusListener
的使用

使用 FocusListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 FocusListener 的使用

实现 FocusListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）

声明为 FocusListener 的 java.awt 中的字段
protected  FocusListener Component.AccessibleAWTComponent.accessibleAWTFocusHandler

返回 FocusListener 的 java.awt 中的方法
static FocusListener | AWTEventMulticaster.add(FocusListener a, FocusListener b) 添加焦点侦听器 a 和焦点侦听器 b，并返回得到的多路广播侦听器。
FocusListener[] | Component.getFocusListeners() 返回在此组件上所有已注册的焦点侦听器的数组。
static FocusListener | AWTEventMulticaster.remove(FocusListener l, FocusListener oldl) 从焦点侦听器 l 中移除旧的焦点侦听器，并返回得到的多路广播侦听器。

参数类型为 FocusListener 的 java.awt 中的方法
static FocusListener | AWTEventMulticaster.add(FocusListener a, FocusListener b) 添加焦点侦听器 a 和焦点侦听器 b，并返回得到的多路广播侦听器。
void | List.AccessibleAWTList.AccessibleAWTListChild.addFocusListener(FocusListener l) 添加指定的焦点侦听器，以从此组件接收焦点事件。
void | MenuComponent.AccessibleAWTMenuComponent.addFocusListener(FocusListener l) 添加指定的焦点侦听器，以从此组件接收焦点事件。
void | Component.addFocusListener(FocusListener l) 添加指定的焦点侦听器，以便当此组件获得输入焦点时能够接收发自此组件的焦点事件。
void | Component.AccessibleAWTComponent.addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收发自此组件的焦点事件。
static FocusListener | AWTEventMulticaster.remove(FocusListener l, FocusListener oldl) 从焦点侦听器 l 中移除旧的焦点侦听器，并返回得到的多路广播侦听器。
void | List.AccessibleAWTList.AccessibleAWTListChild.removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再从此组件接收焦点事件。
void | MenuComponent.AccessibleAWTMenuComponent.removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使之不再从此组件接收焦点事件。
void | Component.removeFocusListener(FocusListener l) 移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。
void | Component.AccessibleAWTComponent.removeFocusListener(FocusListener l) 移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。

java.awt.event 中 FocusListener 的使用

实现 FocusListener 的 java.awt.event 中的类
 class FocusAdapter
用于接收键盘焦点事件的抽象适配器类。

javax.accessibility 中 FocusListener 的使用

参数类型为 FocusListener 的 javax.accessibility 中的方法
void | AccessibleComponent.addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
void | AccessibleComponent.removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

javax.swing 中 FocusListener 的使用

实现 FocusListener 的 javax.swing 中的类
protected  class JComponent.AccessibleJComponent.AccessibleFocusHandler
发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

声明为 FocusListener 的 javax.swing 中的字段
protected  FocusListener JComponent.AccessibleJComponent.accessibleFocusHandler

参数类型为 FocusListener 的 javax.swing 中的方法
void | JTree.AccessibleJTree.AccessibleJTreeNode.addFocusListener(FocusListener l)
void | JTable.AccessibleJTable.AccessibleJTableCell.addFocusListener(FocusListener l)
void | JList.AccessibleJList.AccessibleJListChild.addFocusListener(FocusListener l)
void | JTree.AccessibleJTree.AccessibleJTreeNode.removeFocusListener(FocusListener l)
void | JTable.AccessibleJTable.AccessibleJTableCell.removeFocusListener(FocusListener l)
void | JList.AccessibleJList.AccessibleJListChild.removeFocusListener(FocusListener l)

javax.swing.plaf.basic 中 FocusListener 的使用

实现 FocusListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
class | BasicComboBoxEditor 用于可编辑组合框的默认编辑器。
static class | BasicComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的子类。
class | BasicComboBoxUI.FocusHandler 失去焦点时，此侦听器将隐藏弹出部分。
class | BasicListUI.FocusHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicSliderUI.FocusHandler 焦点更改侦听器。
class | BasicSplitPaneUI.FocusHandler JSplitPane UI 使用的 FocusListener 的实现。
class | BasicTabbedPaneUI.FocusHandler 此类应视为“受保护”内部类。
class | BasicTableUI.FocusHandler 此内部类因编译器故障而被标记为“公开”。
static class | BasicTextUI.BasicCaret
protected class | BasicToolBarUI.ToolBarFocusListener
class | BasicTreeUI.FocusHandler 失去/获得焦点时重绘前导选择行。

声明为 FocusListener 的 javax.swing.plaf.basic 中的字段
protected FocusListener | BasicSliderUI.focusListener
protected FocusListener | BasicSplitPaneUI.focusListener 此 JSplitPane 的 FocusListener 的实例。
protected FocusListener | BasicTableUI.focusListener
protected FocusListener | BasicTabbedPaneUI.focusListener
protected FocusListener | BasicListUI.focusListener
protected FocusListener | BasicComboBoxUI.focusListener 此受保护字段是特定于实现的。
protected FocusListener | BasicToolBarUI.toolBarFocusListener

返回 FocusListener 的 javax.swing.plaf.basic 中的方法
protected FocusListener | BasicSplitPaneUI.createFocusListener() 创建 JSplitPane UI 的 FocusListener。
protected FocusListener | BasicTreeUI.createFocusListener() 创建失去/获取焦点时负责更新显示的侦听器。
protected FocusListener | BasicTableUI.createFocusListener() 创建在 JTable 中处理键盘导航的焦点侦听器。
protected FocusListener | BasicTabbedPaneUI.createFocusListener()
protected FocusListener | BasicListUI.createFocusListener()
protected FocusListener | BasicComboBoxUI.createFocusListener() 创建将添加到组合框的 FocusListener。
protected FocusListener | BasicSliderUI.createFocusListener(JSlider slider)
protected FocusListener | BasicToolBarUI.createToolBarFocusListener()

javax.swing.plaf.metal 中 FocusListener 的使用

实现 FocusListener 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxEditor Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的一个子类。

javax.swing.table 中 FocusListener 的使用

参数类型为 FocusListener 的 javax.swing.table 中的方法
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.addFocusListener(FocusListener l)
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.removeFocusListener(FocusListener l)

javax.swing.text 中 FocusListener 的使用

实现 FocusListener 的 javax.swing.text 中的类
 class DefaultCaret
插入符的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.HierarchyBoundsAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.HierarchyBoundsAdapter
的使用

没有 java.awt.event.HierarchyBoundsAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.HierarchyBoundsListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.HierarchyBoundsListener
的使用

使用 HierarchyBoundsListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt 中 HierarchyBoundsListener 的使用

实现 HierarchyBoundsListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 HierarchyBoundsListener 的 java.awt 中的方法
static HierarchyBoundsListener | AWTEventMulticaster.add(HierarchyBoundsListener a, HierarchyBoundsListener b) 添加层次结构边界侦听器 a 和层次结构边界侦听器 b，并返回得到的多路广播侦听器。
HierarchyBoundsListener[] | Component.getHierarchyBoundsListeners() 返回在此组件上所有已注册的层次结构边界侦听器的数组。
static HierarchyBoundsListener | AWTEventMulticaster.remove(HierarchyBoundsListener l, HierarchyBoundsListener oldl) 从层次结构边界侦听器 l 中移除旧的层次结构边界侦听器，并返回得到的多路广播侦听器。

参数类型为 HierarchyBoundsListener 的 java.awt 中的方法
static HierarchyBoundsListener | AWTEventMulticaster.add(HierarchyBoundsListener a, HierarchyBoundsListener b) 添加层次结构边界侦听器 a 和层次结构边界侦听器 b，并返回得到的多路广播侦听器。
void | Component.addHierarchyBoundsListener(HierarchyBoundsListener l) 添加指定的层次结构边界侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构边界事件。
static HierarchyBoundsListener | AWTEventMulticaster.remove(HierarchyBoundsListener l, HierarchyBoundsListener oldl) 从层次结构边界侦听器 l 中移除旧的层次结构边界侦听器，并返回得到的多路广播侦听器。
void | Component.removeHierarchyBoundsListener(HierarchyBoundsListener l) 移除指定的层次结构边界侦听器，以便它不再接收发自此组件的层次结构边界事件。

java.awt.event 中 HierarchyBoundsListener 的使用

实现 HierarchyBoundsListener 的 java.awt.event 中的类
 class HierarchyBoundsAdapter
用于接收祖先的移动和大小重调事件的抽象适配器类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.HierarchyEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.HierarchyEvent
的使用

使用 HierarchyEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt 中 HierarchyEvent 的使用

参数类型为 HierarchyEvent 的 java.awt 中的方法
void | AWTEventMulticaster.ancestorMoved(HierarchyEvent e) 通过在侦听器 a 和侦听器 b 上调用 ancestorMoved 方法处理 ancestorMoved 事件。
void | AWTEventMulticaster.ancestorResized(HierarchyEvent e) 通过在侦听器 a 和侦听器 b 上调用 ancestorResized 方法处理 ancestorResized 事件。
void | AWTEventMulticaster.hierarchyChanged(HierarchyEvent e) 通过在侦听器 a 和侦听器 b 上调用 hierarchyChanged 方法处理 hierarchyChanged 事件。
protected void | Component.processHierarchyBoundsEvent(HierarchyEvent e) 处理组件上发生的层次结构边界事件，方法是将其指派到任意已注册的 HierarchyBoundsListener 对象。
protected void | Component.processHierarchyEvent(HierarchyEvent e) 处理组件上发生的层次结构事件，方法是将其指派到任意已注册的 HierarchyListener 对象。

java.awt.event 中 HierarchyEvent 的使用

参数类型为 HierarchyEvent 的 java.awt.event 中的方法
void | HierarchyBoundsAdapter.ancestorMoved(HierarchyEvent e) 移动源的祖先时调用。
void | HierarchyBoundsListener.ancestorMoved(HierarchyEvent e) 移动源的祖先时调用。
void | HierarchyBoundsAdapter.ancestorResized(HierarchyEvent e) 调整源的祖先的大小时调用。
void | HierarchyBoundsListener.ancestorResized(HierarchyEvent e) 调整源的祖先的大小时调用。
void | HierarchyListener.hierarchyChanged(HierarchyEvent e) 层次结构已更改时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.HierarchyListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.HierarchyListener
的使用

使用 HierarchyListener 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 HierarchyListener 的使用

实现 HierarchyListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 HierarchyListener 的 java.awt 中的方法
static HierarchyListener | AWTEventMulticaster.add(HierarchyListener a, HierarchyListener b) 添加层次结构侦听器 a 和层次结构侦听器 b，并返回得到的多路广播侦听器。
HierarchyListener[] | Component.getHierarchyListeners() 返回在此组件上所有已注册的层次结构侦听器的数组。
static HierarchyListener | AWTEventMulticaster.remove(HierarchyListener l, HierarchyListener oldl) 从层次结构侦听器 l 中移除旧的层次结构侦听器，并返回得到的多路广播侦听器。

参数类型为 HierarchyListener 的 java.awt 中的方法
static HierarchyListener | AWTEventMulticaster.add(HierarchyListener a, HierarchyListener b) 添加层次结构侦听器 a 和层次结构侦听器 b，并返回得到的多路广播侦听器。
void | Component.addHierarchyListener(HierarchyListener l) 添加指定的层次结构侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构变化事件。
static HierarchyListener | AWTEventMulticaster.remove(HierarchyListener l, HierarchyListener oldl) 从层次结构侦听器 l 中移除旧的层次结构侦听器，并返回得到的多路广播侦听器。
void | Component.removeHierarchyListener(HierarchyListener l) 移除指定的层次结构侦听器，以便它不再接收发自此组件的层次结构变化事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.InputEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.InputEvent
的使用

使用 InputEvent 的软件包
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

java.awt.dnd 中 InputEvent 的使用

类型参数类型为 InputEvent 的 java.awt.dnd 中的字段
protected  ArrayList<InputEvent> DragGestureRecognizer.events
DragGestureRecognizer“识别”为触发拖动的“动作”事件列表（按顺序）。

返回 InputEvent 的 java.awt.dnd 中的方法
InputEvent | DragGestureEvent.getTriggerEvent() 返回触发动作的初始事件。
InputEvent | DragGestureRecognizer.getTriggerEvent() 此方法返回发起 Drag 和 Drop 操作的系列事件中的首个事件。

返回变量类型为 InputEvent 的类型的 java.awt.dnd 中的方法
 Iterator<InputEvent> DragGestureEvent.iterator()
返回组成动作的事件 Iterator。

参数类型为 InputEvent 的 java.awt.dnd 中的方法
protected  void DragGestureRecognizer.appendEvent(InputEvent awtie)
Recognizer 在 Component 上注册的侦听器将通过此 API 记录所有识别的 Event，识别的 Event 是组成 Drag 和 Drop 开始动作的系列 Event 的一部分。

类型变量类型为 InputEvent 的 java.awt.dnd 中的构造方法参数
DragGestureEvent(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。

java.awt.event 中 InputEvent 的使用

java.awt.event 中 InputEvent 的子类
class | KeyEvent 表示组件中发生键击的事件。
class | MouseEvent 指示组件中发生鼠标动作的事件。
class | MouseWheelEvent 表示鼠标滚轮在组件中滚动的事件。

javax.swing 中 InputEvent 的使用

参数类型为 InputEvent 的 javax.swing 中的方法
 void TransferHandler.exportAsDrag(JComponent comp, InputEvent e, int action)
导致 Swing 拖动支持的启用。

javax.swing.event 中 InputEvent 的使用

javax.swing.event 中 InputEvent 的子类
class | MenuDragMouseEvent MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
class | MenuKeyEvent MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.InputMethodEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.InputMethodEvent
的使用

使用 InputMethodEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 InputMethodEvent 的使用

参数类型为 InputMethodEvent 的 java.awt 中的方法
void | AWTEventMulticaster.caretPositionChanged(InputMethodEvent e) 通过在侦听器 a 和侦听器 b 上调用 caretPositionChanged 方法处理 caretPositionChanged 事件。
void | AWTEventMulticaster.inputMethodTextChanged(InputMethodEvent e) 通过在侦听器 a 和侦听器 b 上调用 inputMethodTextChanged 方法处理 inputMethodTextChanged 事件。
protected void | Component.processInputMethodEvent(InputMethodEvent e) 处理组件上发生的输入方法事件，方法是将其指派到任意已注册的 InputMethodListener 对象。

java.awt.event 中 InputMethodEvent 的使用

参数类型为 InputMethodEvent 的 java.awt.event 中的方法
void | InputMethodListener.caretPositionChanged(InputMethodEvent event) 当撰写文本中的 caret 发生变化时调用。
void | InputMethodListener.inputMethodTextChanged(InputMethodEvent event) 当通过输入方法输入的文本发生变化时调用。

javax.swing 中 InputMethodEvent 的使用

参数类型为 InputMethodEvent 的 javax.swing 中的方法
protected  void JFormattedTextField.processInputMethodEvent(InputMethodEvent e)
处理所有的输入法事件，如 InputMethodEvent.INPUT_METHOD_TEXT_CHANGED 或 InputMethodEvent.CARET_POSITION_CHANGED。

javax.swing.text 中 InputMethodEvent 的使用

参数类型为 InputMethodEvent 的 javax.swing.text 中的方法
protected  void JTextComponent.processInputMethodEvent(InputMethodEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.InputMethodListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.InputMethodListener
的使用

使用 InputMethodListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 InputMethodListener 的使用

实现 InputMethodListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 InputMethodListener 的 java.awt 中的方法
static InputMethodListener | AWTEventMulticaster.add(InputMethodListener a, InputMethodListener b) 添加输入方法侦听器 a 和输入方法侦听器 b，并返回得到的多路广播侦听器。
InputMethodListener[] | Component.getInputMethodListeners() 返回在此组件上所有已注册的输入方法侦听器的数组。
static InputMethodListener | AWTEventMulticaster.remove(InputMethodListener l, InputMethodListener oldl) 从输入方法侦听器 l 中移除旧的输入方法侦听器，并返回得到的多路广播侦听器。

参数类型为 InputMethodListener 的 java.awt 中的方法
static InputMethodListener | AWTEventMulticaster.add(InputMethodListener a, InputMethodListener b) 添加输入方法侦听器 a 和输入方法侦听器 b，并返回得到的多路广播侦听器。
void | Component.addInputMethodListener(InputMethodListener l) 添加指定的输入方法侦听器，以接收发自此组件的输入方法事件。
static InputMethodListener | AWTEventMulticaster.remove(InputMethodListener l, InputMethodListener oldl) 从输入方法侦听器 l 中移除旧的输入方法侦听器，并返回得到的多路广播侦听器。
void | Component.removeInputMethodListener(InputMethodListener l) 移除指定的输入方法侦听器，以便它不再接收发自此组件的输入方法事件。

javax.swing.text 中 InputMethodListener 的使用

参数类型为 InputMethodListener 的 javax.swing.text 中的方法
 void JTextComponent.addInputMethodListener(InputMethodListener l)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.InvocationEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.InvocationEvent
的使用

没有 java.awt.event.InvocationEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.ItemEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ItemEvent
的使用

使用 ItemEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 ItemEvent 的使用

参数类型为 ItemEvent 的 java.awt 中的方法
void | Checkbox.AccessibleAWTCheckbox.itemStateChanged(ItemEvent e) 当切换按钮的状态变化时，激发可访问的属性更改事件。
void | List.AccessibleAWTList.itemStateChanged(ItemEvent event)
void | AWTEventMulticaster.itemStateChanged(ItemEvent e) 通过在侦听器 a 和侦听器 b 上调用 itemStateChanged 方法处理 itemStateChanged 事件。
protected void | Checkbox.processItemEvent(ItemEvent e) 处理发生在此复选框上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
protected void | CheckboxMenuItem.processItemEvent(ItemEvent e) 处理发生在此复选框菜单项上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
protected void | Choice.processItemEvent(ItemEvent e) 处理发生在此 Choice 菜单上的项事件，实现方式是将这些事件指派给所有已注册的 ItemListener 对象。
protected void | List.processItemEvent(ItemEvent e) 处理发生在此列表上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。

java.awt.event 中 ItemEvent 的使用

参数类型为 ItemEvent 的 java.awt.event 中的方法
 void ItemListener.itemStateChanged(ItemEvent e)
在用户已选定或取消选定某项时调用。

javax.swing 中 ItemEvent 的使用

参数类型为 ItemEvent 的 javax.swing 中的方法
protected void | JComboBox.fireItemStateChanged(ItemEvent e) 通知所有需要此事件类型的通知的已注册侦听器。
protected void | DefaultButtonModel.fireItemStateChanged(ItemEvent e) 通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected void | AbstractButton.fireItemStateChanged(ItemEvent event) 通知所有需要此事件类型的通知的已注册侦听器。
void | DefaultCellEditor.EditorDelegate.itemStateChanged(ItemEvent e) 在项的状态发生更改时，编辑被终止。
void | JToggleButton.AccessibleJToggleButton.itemStateChanged(ItemEvent e) 当切换按钮的状态变化时，激发可访问的属性变更事件。

javax.swing.plaf.basic 中 ItemEvent 的使用

参数类型为 ItemEvent 的 javax.swing.plaf.basic 中的方法
void | BasicComboPopup.ItemHandler.itemStateChanged(ItemEvent e)
void | BasicComboBoxUI.ItemHandler.itemStateChanged(ItemEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.ItemListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.ItemListener
的使用

使用 ItemListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 ItemListener 的使用

实现 ItemListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。

返回 ItemListener 的 java.awt 中的方法
static ItemListener | AWTEventMulticaster.add(ItemListener a, ItemListener b) 添加项侦听器 a 和项侦听器 b，并返回得到的多路广播侦听器。
ItemListener[] | Checkbox.getItemListeners() 返回已在此复选框上注册的所有项侦听器所组成的数组。
ItemListener[] | CheckboxMenuItem.getItemListeners() 返回在此复选框菜单项上注册的所有项侦听器组成的数组。
ItemListener[] | Choice.getItemListeners() 返回已在此选择上注册的所有项侦听器组成的数组。
ItemListener[] | List.getItemListeners() 返回已在此列表上注册的所有项侦听器的数组。
static ItemListener | AWTEventMulticaster.remove(ItemListener l, ItemListener oldl) 从项侦听器 l 中移除旧的项侦听器，并返回得到的多路广播侦听器。

参数类型为 ItemListener 的 java.awt 中的方法
static ItemListener | AWTEventMulticaster.add(ItemListener a, ItemListener b) 添加项侦听器 a 和项侦听器 b，并返回得到的多路广播侦听器。
void | Checkbox.addItemListener(ItemListener l) 添加指定的项侦听器，以接收来自此复选框的项事件。
void | CheckboxMenuItem.addItemListener(ItemListener l) 添加指定的项侦听器，以接收发自此复选框菜单项的项事件。
void | Choice.addItemListener(ItemListener l) 添加指定的项侦听器，以接收发自此 Choice 菜单的项事件。
void | List.addItemListener(ItemListener l) 添加指定的项侦听器以接收此列表的项事件。
void | ItemSelectable.addItemListener(ItemListener l) 添加侦听器，以接收用户更改项状态时的项事件。
static ItemListener | AWTEventMulticaster.remove(ItemListener l, ItemListener oldl) 从项侦听器 l 中移除旧的项侦听器，并返回得到的多路广播侦听器。
void | Checkbox.removeItemListener(ItemListener l) 移除此项侦听器，这样项侦听器将不再接收发自此复选框的项事件。
void | CheckboxMenuItem.removeItemListener(ItemListener l) 移除指定的项侦听器，以便它不再接收发自此复选框菜单项的项事件。
void | Choice.removeItemListener(ItemListener l) 移除指定的项侦听器，以便它不再接收发自此 Choice 菜单的项事件。
void | List.removeItemListener(ItemListener l) 移除指定的项侦听器，以便不再从此列表接收项事件。
void | ItemSelectable.removeItemListener(ItemListener l) 移除项侦听器。

javax.swing 中 ItemListener 的使用

实现 ItemListener 的 javax.swing 中的类
protected class | DefaultCellEditor.EditorDelegate 受保护的 (protected) EditorDelegate 类。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。

声明为 ItemListener 的 javax.swing 中的字段
protected  ItemListener AbstractButton.itemListener
按钮模型的 ItemListener。

返回 ItemListener 的 javax.swing 中的方法
protected  ItemListener AbstractButton.createItemListener()
 ItemListener[] JComboBox.getItemListeners()
返回使用 addItemListener() 添加到此 JComboBox 中的所有 ItemListener 组成的数组。
 ItemListener[] DefaultButtonModel.getItemListeners()
返回此 DefaultButtonModel 上所有已注册的项侦听器组成的数组。
 ItemListener[] AbstractButton.getItemListeners()
返回使用 addItemListener() 添加到此 AbstractButton 中的所有 ItemListener 组成的数组。

参数类型为 ItemListener 的 javax.swing 中的方法
void | JComboBox.addItemListener(ItemListener aListener) 添加 ItemListener。
void | DefaultButtonModel.addItemListener(ItemListener l) 向模型添加一个 ItemListener。
void | ButtonModel.addItemListener(ItemListener l) 向模型添加一个 ItemListener。
void | AbstractButton.addItemListener(ItemListener l) 将一个 ItemListener 添加到 checkbox 中。
void | JComboBox.removeItemListener(ItemListener aListener) 移除 ItemListener。
void | DefaultButtonModel.removeItemListener(ItemListener l) 从模型中移除一个 ItemListener。
void | ButtonModel.removeItemListener(ItemListener l) 从模型中移除一个 ItemListener。
void | AbstractButton.removeItemListener(ItemListener l) 从按钮中移除一个 ItemListener。

javax.swing.plaf.basic 中 ItemListener 的使用

实现 ItemListener 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxUI.ItemHandler 此侦听器观察组合框中选择的更改。
protected class | BasicComboPopup.ItemHandler 此侦听器观察组合框中选择的更改。

声明为 ItemListener 的 javax.swing.plaf.basic 中的字段
protected ItemListener | BasicComboPopup.itemListener 此受保护字段是特定于实现的。
protected ItemListener | BasicComboBoxUI.itemListener 此受保护字段是特定于实现的。

返回 ItemListener 的 javax.swing.plaf.basic 中的方法
protected ItemListener | BasicComboPopup.createItemListener() 创建将添加到组合框的 ItemListener。
protected ItemListener | BasicComboBoxUI.createItemListener() 创建将添加到组合框的 ItemListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.KeyAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.KeyAdapter
的使用

使用 KeyAdapter 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 KeyAdapter 的使用

javax.swing.plaf.basic 中 KeyAdapter 的子类
class | BasicComboBoxUI.KeyHandler 此侦听器检查键事件是否不是导航键。
class | BasicComboPopup.InvocationKeyHandler 从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。
class | BasicTreeUI.KeyHandler 用于获取多个按键事件以适当生成事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.KeyEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.KeyEvent
的使用

使用 KeyEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 KeyEvent 的使用

参数类型为 KeyEvent 的 java.awt 中的方法
boolean | DefaultKeyboardFocusManager.dispatchKeyEvent(KeyEvent e) 如果调度程序链中其他 KeyEventDispatcher 都没有调度 KeyEvent，或者没有注册其他 KeyEventDispatcher，则由 dispatchEvent 调用此方法。
abstract boolean | KeyboardFocusManager.dispatchKeyEvent(KeyEvent e) 通常情况下，如果该指派程序链中的其他 KeyEventDispatcher 没有指派 KeyEvent 或者没有注册其他 KeyEventDispatcher，则 dispatchEvent 将调用此方法。
boolean | KeyEventDispatcher.dispatchKeyEvent(KeyEvent e) 当前 KeyboardFocusManager 调用此方法，请求此 KeyEventDispatcher 为其指派指定的事件。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStrokeForEvent(KeyEvent anEvent) 返回一个 AWTKeyStroke，它表示生成给定 KeyEvent 的键击事件。
void | AWTEventMulticaster.keyPressed(KeyEvent e) 通过在侦听器 a 和侦听器 b 上调用 keyPressed 方法处理 keyPressed 事件。
void | AWTEventMulticaster.keyReleased(KeyEvent e) 通过在侦听器 a 和侦听器 b 上调用 keyReleased 方法处理 keyReleased 事件。
void | AWTEventMulticaster.keyTyped(KeyEvent e) 通过在侦听器 a 和侦听器 b 上调用 keyTyped 方法处理 keyTyped 事件。
boolean | DefaultKeyboardFocusManager.postProcessKeyEvent(KeyEvent e) 由 dispatchKeyEvent 调用此方法。
abstract boolean | KeyboardFocusManager.postProcessKeyEvent(KeyEvent e) dispatchKeyEvent 将调用此方法。
boolean | KeyEventPostProcessor.postProcessKeyEvent(KeyEvent e) 当前 KeyboardFocusManager 调用此方法，请求此 KeyEventPostProcessor 执行应该作为 KeyEvent 最终解析的一部分的所需后处理。
void | DefaultKeyboardFocusManager.processKeyEvent(Component focusedComponent, KeyEvent e) 当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法才会启动一个焦点遍历操作。
abstract void | KeyboardFocusManager.processKeyEvent(Component focusedComponent, KeyEvent e) 当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法启动焦点遍历操作。
protected void | Component.processKeyEvent(KeyEvent e) 处理组件上发生的按键事件，方法是将其指派到任意已注册的 KeyListener 对象。

java.awt.event 中 KeyEvent 的使用

参数类型为 KeyEvent 的 java.awt.event 中的方法
void | KeyAdapter.keyPressed(KeyEvent e) 按下某个键时调用此方法。
void | KeyListener.keyPressed(KeyEvent e) 按下某个键时调用此方法。
void | KeyAdapter.keyReleased(KeyEvent e) 释放某个键时调用此方法。
void | KeyListener.keyReleased(KeyEvent e) 释放某个键时调用此方法。
void | KeyAdapter.keyTyped(KeyEvent e) 键入某个键时调用此方法。
void | KeyListener.keyTyped(KeyEvent e) 键入某个键时调用此方法。

javax.swing 中 KeyEvent 的使用

参数类型为 KeyEvent 的 javax.swing 中的方法
static KeyStroke | KeyStroke.getKeyStrokeForEvent(KeyEvent anEvent) 返回一个 KeyStroke，它表示生成给定 KeyEvent 的快捷键事件。
static boolean | SwingUtilities.notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers) 如果启用 action（且为非 null），则调用 action 上的 actionPerformed。
protected void | JComponent.processComponentKeyEvent(KeyEvent e) 处理该组件本身可识别的所有键事件。
protected boolean | JTable.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
protected boolean | JMenuBar.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed) 子类化以检查所有子菜单。
protected boolean | JComponent.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed) 由于发生 KeyEvent e 而调用此方法处理 ks 的键绑定。
static boolean | SwingUtilities.processKeyBindings(KeyEvent event) 处理与 event 关联的 Component 的键绑定。
void | JComboBox.processKeyEvent(KeyEvent e) 处理 KeyEvent，查找 Tab 键。
void | MenuSelectionManager.processKeyEvent(KeyEvent e) 当 MenuElement 从 KeyListener 接收事件时，它决不应直接处理该事件。
protected void | JPopupMenu.processKeyEvent(KeyEvent evt) 处理快捷键事件，如助记符和加速器。
protected void | JMenu.processKeyEvent(KeyEvent evt) 处理键击事件，如助记符和加速器。
protected void | JComponent.processKeyEvent(KeyEvent e) 重写 processKeyEvent 以处理事件。
void | JPopupMenu.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | JMenuBar.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | JMenuItem.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | MenuElement.processKeyEvent(KeyEvent event, MenuElement[] path, MenuSelectionManager manager) 处理键事件。

javax.swing.event 中 KeyEvent 的使用

javax.swing.event 中 KeyEvent 的子类
 class MenuKeyEvent
MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

javax.swing.plaf.basic 中 KeyEvent 的使用

参数类型为 KeyEvent 的 javax.swing.plaf.basic 中的方法
void | BasicTreeUI.KeyHandler.keyPressed(KeyEvent e)
void | BasicTableUI.KeyHandler.keyPressed(KeyEvent e)
void | BasicComboBoxUI.KeyHandler.keyPressed(KeyEvent e)
void | BasicTreeUI.KeyHandler.keyReleased(KeyEvent e)
void | BasicTableUI.KeyHandler.keyReleased(KeyEvent e)
void | BasicComboPopup.InvocationKeyHandler.keyReleased(KeyEvent e)
void | BasicTreeUI.KeyHandler.keyTyped(KeyEvent e) 键入键时调用。
void | BasicTableUI.KeyHandler.keyTyped(KeyEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.KeyListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.KeyListener
的使用

使用 KeyListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 KeyListener 的使用

实现 KeyListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 KeyListener 的 java.awt 中的方法
static KeyListener | AWTEventMulticaster.add(KeyListener a, KeyListener b) 添加键侦听器 a 和键侦听器 b，并返回得到的多路广播侦听器。
KeyListener[] | Component.getKeyListeners() 返回在此组件上所有已注册的按键侦听器的数组。
static KeyListener | AWTEventMulticaster.remove(KeyListener l, KeyListener oldl) 从键侦听器 l 中移除旧的键侦听器，并返回得到的多路广播侦听器。

参数类型为 KeyListener 的 java.awt 中的方法
static KeyListener | AWTEventMulticaster.add(KeyListener a, KeyListener b) 添加键侦听器 a 和键侦听器 b，并返回得到的多路广播侦听器。
void | Component.addKeyListener(KeyListener l) 添加指定的按键侦听器，以接收发自此组件的按键事件。
static KeyListener | AWTEventMulticaster.remove(KeyListener l, KeyListener oldl) 从键侦听器 l 中移除旧的键侦听器，并返回得到的多路广播侦听器。
void | Component.removeKeyListener(KeyListener l) 移除指定的按键侦听器，以便它不再接收发自此组件的按键事件。

java.awt.event 中 KeyListener 的使用

实现 KeyListener 的 java.awt.event 中的类
 class KeyAdapter
接收键盘事件的抽象适配器类。

javax.swing.plaf.basic 中 KeyListener 的使用

实现 KeyListener 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxUI.KeyHandler 此侦听器检查键事件是否不是导航键。
class | BasicComboPopup.InvocationKeyHandler 从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。
class | BasicTableUI.KeyHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTreeUI.KeyHandler 用于获取多个按键事件以适当生成事件。

声明为 KeyListener 的 javax.swing.plaf.basic 中的字段
protected KeyListener | BasicTableUI.keyListener
protected KeyListener | BasicComboPopup.keyListener 此受保护字段是特定于实现的。
protected KeyListener | BasicComboBoxUI.keyListener 此受保护字段是特定于实现的。
protected KeyListener | BasicComboBoxUI.popupKeyListener

返回 KeyListener 的 javax.swing.plaf.basic 中的方法
protected  KeyListener BasicTreeUI.createKeyListener()
创建负责从树获取键事件的侦听器。
protected  KeyListener BasicTableUI.createKeyListener()
创建在 JTable 中处理键盘导航的键侦听器。
protected  KeyListener BasicComboPopup.createKeyListener()
创建将添加到组合框的键侦听器。
protected  KeyListener BasicComboBoxUI.createKeyListener()
创建将添加到组合框的 KeyListener。
 KeyListener BasicComboPopup.getKeyListener()
ComboPopup.getKeyListener() 的实现。
 KeyListener ComboPopup.getKeyListener()
返回将添加到组合框的键侦听器或 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.MouseAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.MouseAdapter
的使用

使用 MouseAdapter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 MouseAdapter 的使用

javax.swing 中 MouseAdapter 的子类
 class ToolTipManager
管理系统中的所有 ToolTips。

javax.swing.event 中 MouseAdapter 的使用

javax.swing.event 中 MouseAdapter 的子类
 class MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

javax.swing.plaf.basic 中 MouseAdapter 的使用

javax.swing.plaf.basic 中 MouseAdapter 的子类
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。

javax.swing.plaf.metal 中 MouseAdapter 的使用

javax.swing.plaf.metal 中 MouseAdapter 的子类
protected  class MetalFileChooserUI.SingleClickListener

javax.swing.text.html 中 MouseAdapter 的使用

javax.swing.text.html 中 MouseAdapter 的子类
protected class | FormView.MouseEventListener 当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.MouseEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.MouseEvent
的使用

使用 MouseEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 MouseEvent 的使用

参数类型为 MouseEvent 的 java.awt 中的方法
void | AWTEventMulticaster.mouseClicked(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseClicked 方法处理 mouseClicked 事件。
void | AWTEventMulticaster.mouseDragged(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseDragged 方法处理 mouseDragged 事件。
void | AWTEventMulticaster.mouseEntered(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseEntered 方法处理 mouseEntered 事件。
void | AWTEventMulticaster.mouseExited(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseExited 方法处理 mouseExited 事件。
void | AWTEventMulticaster.mouseMoved(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseMoved 方法处理 mouseMoved 事件。
void | AWTEventMulticaster.mousePressed(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mousePressed 方法处理 mousePressed 事件。
void | AWTEventMulticaster.mouseReleased(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseReleased 方法处理 mouseReleased 事件。
protected void | Component.processMouseEvent(MouseEvent e) 处理组件上发生的鼠标事件，方法是将其指派到任意已注册的 MouseListener 对象。
protected void | Component.processMouseMotionEvent(MouseEvent e) 处理组件上发生的鼠标移动事件，方法是将其指派到任意已注册的 MouseMotionListener 事件。

java.awt.dnd 中 MouseEvent 的使用

参数类型为 MouseEvent 的 java.awt.dnd 中的方法
void | MouseDragGestureRecognizer.mouseClicked(MouseEvent e) 鼠标在组件上单击时调用。
void | MouseDragGestureRecognizer.mouseDragged(MouseEvent e) 鼠标按钮在组件上按下时调用。
void | MouseDragGestureRecognizer.mouseEntered(MouseEvent e) 鼠标移动到组件上时调用。
void | MouseDragGestureRecognizer.mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | MouseDragGestureRecognizer.mouseMoved(MouseEvent e) 鼠标按钮在组件上移动（无按钮按下）时调用。
void | MouseDragGestureRecognizer.mousePressed(MouseEvent e) 鼠标按钮在 Component 上按下时调用。
void | MouseDragGestureRecognizer.mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。

java.awt.event 中 MouseEvent 的使用

java.awt.event 中 MouseEvent 的子类
 class MouseWheelEvent
表示鼠标滚轮在组件中滚动的事件。

参数类型为 MouseEvent 的 java.awt.event 中的方法
void | MouseAdapter.mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | MouseListener.mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | MouseMotionAdapter.mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | MouseAdapter.mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | MouseMotionListener.mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | MouseAdapter.mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | MouseListener.mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | MouseAdapter.mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | MouseListener.mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | MouseMotionAdapter.mouseMoved(MouseEvent e) 鼠标按键在组件上移动（无按键按下）时调用。
void | MouseAdapter.mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | MouseMotionListener.mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | MouseAdapter.mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | MouseListener.mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | MouseAdapter.mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
void | MouseListener.mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。

javax.swing 中 MouseEvent 的使用

返回 MouseEvent 的 javax.swing 中的方法
static MouseEvent SwingUtilities.convertMouseEvent(Component source, MouseEvent sourceEvent, Component destination)
返回类似于 sourceEvent 的 MouseEvent，除了其 x 和 y 成员已转换到 destination 的坐标系统。

参数类型为 MouseEvent 的 javax.swing 中的方法
static MouseEvent SwingUtilities.convertMouseEvent(Component source, MouseEvent sourceEvent, Component destination)
返回类似于 sourceEvent 的 MouseEvent，除了其 x 和 y 成员已转换到 destination 的坐标系统。
 Point JComponent.getPopupLocation(MouseEvent event)
返回在此组件坐标系统中显示弹出式菜单的首选位置。
 Point JComponent.getToolTipLocation(MouseEvent event)
返回工具提示在此组件坐标系统中的位置。
 String JTree.getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，以允许使用渲染器的提示（如果渲染器设置了文本）。
 String JTable.getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，从而允许使用渲染器的提示（如果设置了文本）。
 String JTabbedPane.getToolTipText(MouseEvent event)
返回由鼠标事件位置确定的组件的工具提示文本。
 String JList.getToolTipText(MouseEvent event)
返回用于给定事件的工具提示文本。
 String JComponent.getToolTipText(MouseEvent event)
返回用作 event 工具提示的字符串。
static boolean SwingUtilities.isLeftMouseButton(MouseEvent anEvent)
如果鼠标事件指定左边鼠标按键，则返回 true。
static boolean SwingUtilities.isMiddleMouseButton(MouseEvent anEvent)
如果鼠标事件指定中间鼠标按键，则返回 true。
 boolean JPopupMenu.isPopupTrigger(MouseEvent e)
如果 JPopupMenu 的当前安装 UI 将 MouseEvent 视为弹出菜单触发器，则返回 true。
static boolean SwingUtilities.isRightMouseButton(MouseEvent anEvent)
如果鼠标事件指定右边鼠标按键，则返回 true。
 void ToolTipManager.mouseDragged(MouseEvent event)
按下和拖动鼠标时调用。
 void ToolTipManager.mouseEntered(MouseEvent event)
鼠标进入组件区域时调用。
 void ToolTipManager.mouseExited(MouseEvent event)
鼠标退出组件区域时调用。
 void ToolTipManager.mouseMoved(MouseEvent event)
移动鼠标时调用。
 void ToolTipManager.mousePressed(MouseEvent event)
当按下鼠标时调用。
 void MenuSelectionManager.processMouseEvent(MouseEvent event)
当 MenuElement 从 MouseListener 接收事件时，它决不应直接处理该事件。
protected  void JComponent.processMouseEvent(MouseEvent e)
处理此组件上发生的鼠标事件，通过将其指派到任意已注册的 MouseListener 对象来完成，有关此方法的完整描述，请参阅 Component.processMouseEvent(MouseEvent)。
 void JPopupMenu.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
要求此方法遵守 MenuElement 接口，但它没有被实现。
 void JMenuBar.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
实现为 MenuElement（不执行任何操作）。
 void JMenuItem.processMouseEvent(MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的鼠标事件并更改菜单选择。
 void MenuElement.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
处理鼠标事件。
protected  void JComponent.processMouseMotionEvent(MouseEvent e)
处理鼠标移动事件，如 MouseEvent.MOUSE_DRAGGED。

javax.swing.event 中 MouseEvent 的使用

javax.swing.event 中 MouseEvent 的子类
 class MenuDragMouseEvent
MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。

javax.swing.plaf 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.plaf 中的方法
 boolean PopupMenuUI.isPopupTrigger(MouseEvent e)

javax.swing.plaf.basic 中 MouseEvent 的使用

返回 MouseEvent 的 javax.swing.plaf.basic 中的方法
protected  MouseEvent BasicComboPopup.convertMouseEvent(MouseEvent e)

参数类型为 MouseEvent 的 javax.swing.plaf.basic 中的方法
protected void | BasicSplitPaneDivider.DragController.completeDrag(MouseEvent e) 用鼠标事件的新位置传递 finishDraggingTo 的消息。
protected void | BasicSplitPaneDivider.DragController.continueDrag(MouseEvent e) 用鼠标事件的新位置传递 dragDividerTo 的消息。
protected MouseEvent | BasicComboPopup.convertMouseEvent(MouseEvent e)
protected void | BasicComboPopup.delegateFocus(MouseEvent e) 此为一种实用程序方法，用于帮助事件处理程序计算出在调出弹出控件时将焦点发送到的位置。
protected boolean | BasicTreeUI.isMultiSelectEvent(MouseEvent event) 返回 true 表示节点上的鼠标事件应该根据锚点作出选择。
boolean | BasicPopupMenuUI.isPopupTrigger(MouseEvent e)
protected boolean | BasicTreeUI.isToggleEvent(MouseEvent event) 返回 true 指示应该基于事件切换鼠标下的行。
protected boolean | BasicTreeUI.isToggleSelectionEvent(MouseEvent event) 返回 true 表示节点上的鼠标事件应该仅切换鼠标下的行的选择。
void | BasicFileChooserUI.DoubleClickListener.mouseClicked(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mouseClicked(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseClicked(MouseEvent e)
void | BasicTreeUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicMenuUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicMenuItemUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseClicked(MouseEvent e)
void | BasicButtonListener.mouseClicked(MouseEvent e)
void | BasicDesktopIconUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mouseDragged(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseDragged(MouseEvent e)
void | BasicSliderUI.TrackListener.mouseDragged(MouseEvent e) 将模型值设置为相对于滑道原点的 thumb 顶部/左部位置。
void | BasicSplitPaneDivider.MouseHandler.mouseDragged(MouseEvent e) 如果拖动器不为 null，则此方法利用 continueDrag 传递消息。
void | BasicTreeUI.MouseHandler.mouseDragged(MouseEvent e)
void | BasicTreeUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicComboPopup.InvocationMouseMotionHandler.mouseDragged(MouseEvent e)
void | BasicScrollBarUI.TrackListener.mouseDragged(MouseEvent e) 将模型值设置为 thumb 的 Vertical 滚动条顶部的位置，或者相对于滑道原点的从左到右/从右到左滚动条中 Horizontal 滚动条的左部/右部位置。
void | BasicMenuUI.MouseInputHandler.mouseDragged(MouseEvent e) 在菜单上按下鼠标按键并随后拖动鼠标时调用。
void | BasicMenuItemUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseDragged(MouseEvent e)
void | BasicButtonListener.mouseDragged(MouseEvent e)
void | BasicFileChooserUI.DoubleClickListener.mouseEntered(MouseEvent e) 用于表示文件的 JList 由子类创建，但是在此类中监视选择。
void | BasicInternalFrameUI.BorderListener.mouseEntered(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseEntered(MouseEvent e)
void | BasicSplitPaneDivider.MouseHandler.mouseEntered(MouseEvent e) 鼠标进入组件时调用。
void | BasicTreeUI.MouseInputHandler.mouseEntered(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseEntered(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseEntered(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseEntered(MouseEvent e)
void | BasicMenuUI.MouseInputHandler.mouseEntered(MouseEvent e) 在指针进入菜单时调用。
void | BasicMenuItemUI.MouseInputHandler.mouseEntered(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseEntered(MouseEvent e)
void | BasicButtonListener.mouseEntered(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mouseExited(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseExited(MouseEvent e)
void | BasicSplitPaneDivider.MouseHandler.mouseExited(MouseEvent e) 鼠标退出组件时调用。
void | BasicTreeUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicScrollBarUI.TrackListener.mouseExited(MouseEvent e) 当鼠标退出滚动条时调用。
void | BasicMenuUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicMenuItemUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseExited(MouseEvent e)
void | BasicButtonListener.mouseExited(MouseEvent e)
void | BasicDesktopIconUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mouseMoved(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseMoved(MouseEvent e)
void | BasicSliderUI.TrackListener.mouseMoved(MouseEvent e)
void | BasicSplitPaneDivider.MouseHandler.mouseMoved(MouseEvent e) 基于方向重置光标。
void | BasicTreeUI.MouseHandler.mouseMoved(MouseEvent e) 已将鼠标按键移动到组件上（但没有按下任何一个按键）时调用。
void | BasicTreeUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicComboPopup.ListMouseMotionHandler.mouseMoved(MouseEvent anEvent)
void | BasicScrollBarUI.TrackListener.mouseMoved(MouseEvent e)
void | BasicMenuUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicMenuItemUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseMoved(MouseEvent e)
void | BasicButtonListener.mouseMoved(MouseEvent e)
void | BasicDesktopIconUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mousePressed(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mousePressed(MouseEvent e)
void | BasicSliderUI.TrackListener.mousePressed(MouseEvent e) 如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按鼠标则将滚动条值增加一页。
void | BasicSplitPaneDivider.MouseHandler.mousePressed(MouseEvent e) 通过创建 DragController 的适当实例启动拖动会话。
void | BasicTreeUI.MouseHandler.mousePressed(MouseEvent e) 在组件上按下鼠标按键时调用。
void | BasicTreeUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicTabbedPaneUI.MouseHandler.mousePressed(MouseEvent e)
void | BasicListUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicComboPopup.InvocationMouseHandler.mousePressed(MouseEvent e) 响应组合框上的鼠标按下事件。
void | BasicComboPopup.ListMouseHandler.mousePressed(MouseEvent e)
void | BasicScrollBarUI.TrackListener.mousePressed(MouseEvent e) 如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按下鼠标则将滚动条值增加一页。
void | BasicScrollBarUI.ArrowButtonListener.mousePressed(MouseEvent e)
void | BasicMenuUI.MouseInputHandler.mousePressed(MouseEvent e) 在菜单上单击鼠标时调用。
void | BasicMenuItemUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicToolBarUI.DockingListener.mousePressed(MouseEvent e)
void | BasicButtonListener.mousePressed(MouseEvent e)
void | BasicDesktopIconUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mouseReleased(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseReleased(MouseEvent e)
void | BasicSliderUI.TrackListener.mouseReleased(MouseEvent e)
void | BasicSplitPaneDivider.MouseHandler.mouseReleased(MouseEvent e) 如果拖动器不为 null，则此方法利用 completeDrag 传递消息。
void | BasicTreeUI.MouseHandler.mouseReleased(MouseEvent e)
void | BasicTreeUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicComboPopup.InvocationMouseHandler.mouseReleased(MouseEvent e) 响应用户终止从组合框开始的单击或拖动操作。
void | BasicComboPopup.ListMouseHandler.mouseReleased(MouseEvent anEvent)
void | BasicScrollBarUI.TrackListener.mouseReleased(MouseEvent e)
void | BasicScrollBarUI.ArrowButtonListener.mouseReleased(MouseEvent e)
void | BasicMenuUI.MouseInputHandler.mouseReleased(MouseEvent e) 在菜单上释放鼠标时调用。
void | BasicMenuItemUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseReleased(MouseEvent e)
void | BasicButtonListener.mouseReleased(MouseEvent e)
protected int | BasicSplitPaneDivider.DragController.positionForMouseEvent(MouseEvent e) 返回基于传入的 MouseEvent 放置分隔器的新位置。
protected int | BasicSplitPaneDivider.VerticalDragController.positionForMouseEvent(MouseEvent e) 返回基于传入的 MouseEvent 放置分隔器的新位置。
void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
protected void | BasicTreeUI.selectPathForEvent(TreePath path, MouseEvent event) 传递消息以基于特定行上的 MouseEvent 更新选择。
protected boolean | BasicTreeUI.startEditing(TreePath path, MouseEvent event) 如果存在 cellEditor 并且 shouldSelectCell 返回 true，则启动节点的编辑操作。
protected void | BasicComboPopup.updateListBoxSelectionForEvent(MouseEvent anEvent, boolean shouldScroll) 供事件侦听器使用的实用程序方法。

参数类型为 MouseEvent 的 javax.swing.plaf.basic 中的构造方法
BasicSplitPaneDivider.DragController(MouseEvent e)
BasicSplitPaneDivider.VerticalDragController(MouseEvent e)
BasicTreeUI.MouseInputHandler(Component source, Component destination, MouseEvent event)

javax.swing.plaf.metal 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.plaf.metal 中的方法
void | MetalComboBoxUI.MetalComboPopup.delegateFocus(MouseEvent e) 已过时。
void | MetalToolBarUI.MetalDockingListener.mouseDragged(MouseEvent e)
void | MetalToolBarUI.MetalDockingListener.mousePressed(MouseEvent e)

javax.swing.plaf.multi 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.plaf.multi 中的方法
 boolean MultiPopupMenuUI.isPopupTrigger(MouseEvent a)
在由此对象处理的每个 UI 上调用 isPopupTrigger 方法。

javax.swing.table 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.table 中的方法
 String JTableHeader.getToolTipText(MouseEvent event)
如果设置了提示文本，则允许使用渲染器的提示。

javax.swing.text 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.text 中的方法
 String JTextComponent.getToolTipText(MouseEvent event)
返回用作 event 的工具提示的字符串。
 void DefaultCaret.mouseClicked(MouseEvent e)
单击鼠标时调用。
 void DefaultCaret.mouseDragged(MouseEvent e)
根据鼠标指针当前位置移动插入符位置。
 void DefaultCaret.mouseEntered(MouseEvent e)
鼠标进入某个区域时调用。
 void DefaultCaret.mouseExited(MouseEvent e)
鼠标退出某个区域时调用。
 void DefaultCaret.mouseMoved(MouseEvent e)
移动鼠标时调用。
 void DefaultCaret.mousePressed(MouseEvent e)
如果按下 button 1，实现它可请求将焦点置于关联的文本组件上，并设置插入符位置。
 void DefaultCaret.mouseReleased(MouseEvent e)
释放鼠标时调用。
protected  void DefaultCaret.moveCaret(MouseEvent e)
试图使用 viewToModel() 从鼠标事件的坐标移动插入符的位置。
protected  void DefaultCaret.positionCaret(MouseEvent e)
试图使用 viewToModel() 从鼠标事件的坐标设置插入符的位置。

javax.swing.text.html 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.text.html 中的方法
void | HTMLEditorKit.LinkController.mouseClicked(MouseEvent e) 鼠标单击事件时调用。
void | HTMLEditorKit.LinkController.mouseDragged(MouseEvent e)
void | HTMLEditorKit.LinkController.mouseMoved(MouseEvent e)
void | FormView.MouseEventListener.mouseReleased(MouseEvent evt)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.MouseListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.MouseListener
的使用

使用 MouseListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 MouseListener 的使用

实现 MouseListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 MouseListener 的 java.awt 中的方法
static MouseListener | AWTEventMulticaster.add(MouseListener a, MouseListener b) 添加鼠标侦听器 a 和鼠标侦听器 b，并返回得到的多路广播侦听器。
MouseListener[] | TrayIcon.getMouseListeners() 返回已在此 TrayIcon 上注册的所有鼠标侦听器的数组。
MouseListener[] | Component.getMouseListeners() 返回在此组件上所有已注册的鼠标侦听器的数组。
static MouseListener | AWTEventMulticaster.remove(MouseListener l, MouseListener oldl) 从鼠标侦听器 l 中移除旧的鼠标侦听器，并返回得到的多路广播侦听器。

参数类型为 MouseListener 的 java.awt 中的方法
static MouseListener | AWTEventMulticaster.add(MouseListener a, MouseListener b) 添加鼠标侦听器 a 和鼠标侦听器 b，并返回得到的多路广播侦听器。
void | TrayIcon.addMouseListener(MouseListener listener) 添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标事件。
void | Component.addMouseListener(MouseListener l) 添加指定的鼠标侦听器，以接收发自此组件的鼠标事件。
static MouseListener | AWTEventMulticaster.remove(MouseListener l, MouseListener oldl) 从鼠标侦听器 l 中移除旧的鼠标侦听器，并返回得到的多路广播侦听器。
void | TrayIcon.removeMouseListener(MouseListener listener) 移除指定的鼠标侦听器。
void | Component.removeMouseListener(MouseListener l) 移除指定的鼠标侦听器，以便它不再接收发自此组件的鼠标事件。

java.awt.dnd 中 MouseListener 的使用

实现 MouseListener 的 java.awt.dnd 中的类
 class MouseDragGestureRecognizer
DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

java.awt.event 中 MouseListener 的使用

实现 MouseListener 的 java.awt.event 中的类
 class MouseAdapter
接收鼠标事件的抽象适配器类。

javax.swing 中 MouseListener 的使用

实现 MouseListener 的 javax.swing 中的类
 class ToolTipManager
管理系统中的所有 ToolTips。

javax.swing.event 中 MouseListener 的使用

javax.swing.event 中 MouseListener 的子接口
 interface MouseInputListener
实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。

实现 MouseListener 的 javax.swing.event 中的类
 class MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

javax.swing.plaf.basic 中 MouseListener 的使用

实现 MouseListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicInternalFrameUI.GlassPaneDispatcher
class | BasicListUI.MouseInputHandler 鼠标输入和 JList 的焦点处理。
protected class | BasicMenuItemUI.MouseInputHandler
protected class | BasicMenuUI.MouseInputHandler 实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTableHeaderUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
static class | BasicTextUI.BasicCaret
class | BasicToolBarUI.DockingListener 此类应视为“受保护”内部类。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。
class | BasicTreeUI.MouseInputHandler 在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。

声明为 MouseListener 的 javax.swing.plaf.basic 中的字段
protected MouseListener | BasicComboPopup.listMouseListener 此受保护字段是特定于实现的。
protected MouseListener | BasicTabbedPaneUI.mouseListener
protected MouseListener | BasicComboPopup.mouseListener 此受保护字段是特定于实现的。
protected MouseListener | BasicComboBoxUI.popupMouseListener

返回 MouseListener 的 javax.swing.plaf.basic 中的方法
protected  MouseListener BasicFileChooserUI.createDoubleClickListener(JFileChooser fc, JList list)
protected  MouseListener BasicComboPopup.createListMouseListener()
创建观察弹出列表中的鼠标事件的鼠标侦听器。
protected  MouseListener BasicTreeUI.createMouseListener()
创建负责基于鼠标事件更新选择的侦听器。
protected  MouseListener BasicTabbedPaneUI.createMouseListener()
protected  MouseListener BasicComboPopup.createMouseListener()
创建将观察组合框上的鼠标按下和释放事件的侦听器。
 MouseListener BasicComboPopup.getMouseListener()
ComboPopup.getMouseListener() 的实现。
 MouseListener ComboPopup.getMouseListener()
返回将添加到组合框的鼠标侦听器或 null。

javax.swing.plaf.metal 中 MouseListener 的使用

实现 MouseListener 的 javax.swing.plaf.metal 中的类
protected class | MetalFileChooserUI.SingleClickListener
protected class | MetalToolBarUI.MetalDockingListener

javax.swing.text 中 MouseListener 的使用

实现 MouseListener 的 javax.swing.text 中的类
 class DefaultCaret
插入符的默认实现。

javax.swing.text.html 中 MouseListener 的使用

实现 MouseListener 的 javax.swing.text.html 中的类
protected class | FormView.MouseEventListener 当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.MouseMotionAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.MouseMotionAdapter
的使用

使用 MouseMotionAdapter 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 MouseMotionAdapter 的使用

javax.swing.plaf.basic 中 MouseMotionAdapter 的子类
protected class | BasicComboPopup.InvocationMouseMotionHandler 此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。
protected class | BasicComboPopup.ListMouseMotionHandler 在列表上移动鼠标时，此侦听器更改所选项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.MouseMotionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.MouseMotionListener
的使用

使用 MouseMotionListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 MouseMotionListener 的 java.awt 中的方法
static MouseMotionListener | AWTEventMulticaster.add(MouseMotionListener a, MouseMotionListener b) 添加鼠标移动侦听器 a 和鼠标移动侦听器 b，并返回得到的多路广播侦听器。
MouseMotionListener[] | TrayIcon.getMouseMotionListeners() 返回已在此 TrayIcon 上注册的所有鼠标移动侦听器的数组。
MouseMotionListener[] | Component.getMouseMotionListeners() 返回在此组件上所有已注册的鼠标移动侦听器的数组。
static MouseMotionListener | AWTEventMulticaster.remove(MouseMotionListener l, MouseMotionListener oldl) 从鼠标移动侦听器 l 中移除旧的鼠标移动侦听器，并返回得到的多路广播侦听器。

参数类型为 MouseMotionListener 的 java.awt 中的方法
static MouseMotionListener | AWTEventMulticaster.add(MouseMotionListener a, MouseMotionListener b) 添加鼠标移动侦听器 a 和鼠标移动侦听器 b，并返回得到的多路广播侦听器。
void | TrayIcon.addMouseMotionListener(MouseMotionListener listener) 添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标移动事件。
void | Component.addMouseMotionListener(MouseMotionListener l) 添加指定的鼠标移动侦听器，以接收发自此组件的鼠标移动事件。
static MouseMotionListener | AWTEventMulticaster.remove(MouseMotionListener l, MouseMotionListener oldl) 从鼠标移动侦听器 l 中移除旧的鼠标移动侦听器，并返回得到的多路广播侦听器。
void | TrayIcon.removeMouseMotionListener(MouseMotionListener listener) 移除指定的鼠标移动侦听器。
void | Component.removeMouseMotionListener(MouseMotionListener l) 移除指定的鼠标移动侦听器，以便它不再接收发自此组件的鼠标移动事件。

java.awt.dnd 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 java.awt.dnd 中的类
 class MouseDragGestureRecognizer
DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

java.awt.event 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 java.awt.event 中的类
class | MouseAdapter 接收鼠标事件的抽象适配器类。
class | MouseMotionAdapter 接收鼠标移动事件的抽象适配器类。

javax.swing 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 javax.swing 中的类
 class ToolTipManager
管理系统中的所有 ToolTips。

javax.swing.event 中 MouseMotionListener 的使用

javax.swing.event 中 MouseMotionListener 的子接口
 interface MouseInputListener
实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。

实现 MouseMotionListener 的 javax.swing.event 中的类
 class MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

javax.swing.plaf.basic 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.InvocationMouseMotionHandler 此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
protected class | BasicComboPopup.ListMouseMotionHandler 在列表上移动鼠标时，此侦听器更改所选项。
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicInternalFrameUI.GlassPaneDispatcher
class | BasicListUI.MouseInputHandler 鼠标输入和 JList 的焦点处理。
protected class | BasicMenuItemUI.MouseInputHandler
protected class | BasicMenuUI.MouseInputHandler 实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTableHeaderUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
static class | BasicTextUI.BasicCaret
class | BasicToolBarUI.DockingListener 此类应视为“受保护”内部类。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。
class | BasicTreeUI.MouseInputHandler 在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。

声明为 MouseMotionListener 的 javax.swing.plaf.basic 中的字段
protected MouseMotionListener | BasicComboPopup.listMouseMotionListener 此受保护字段是特定于实现的。
protected MouseMotionListener | BasicComboPopup.mouseMotionListener 此受保护字段是特定于实现的。
protected MouseMotionListener | BasicComboBoxUI.popupMouseMotionListener

返回 MouseMotionListener 的 javax.swing.plaf.basic 中的方法
protected  MouseMotionListener BasicComboPopup.createListMouseMotionListener()
创建观察弹出列表中的鼠标移动事件的鼠标移动侦听器。
protected  MouseMotionListener BasicComboPopup.createMouseMotionListener()
创建将添加到组合框的鼠标移动侦听器。
 MouseMotionListener BasicComboPopup.getMouseMotionListener()
ComboPopup.getMouseMotionListener() 的实现。
 MouseMotionListener ComboPopup.getMouseMotionListener()
返回将添加到组合框的鼠标移动侦听器或 null。

javax.swing.plaf.metal 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 javax.swing.plaf.metal 中的类
protected class | MetalFileChooserUI.SingleClickListener
protected class | MetalToolBarUI.MetalDockingListener

javax.swing.text 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 javax.swing.text 中的类
 class DefaultCaret
插入符的默认实现。

javax.swing.text.html 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 javax.swing.text.html 中的类
protected class | FormView.MouseEventListener 当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.MouseWheelEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.MouseWheelEvent
的使用

使用 MouseWheelEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 MouseWheelEvent 的使用

参数类型为 MouseWheelEvent 的 java.awt 中的方法
void | AWTEventMulticaster.mouseWheelMoved(MouseWheelEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseWheelMoved 方法处理 mouseWheelMoved 事件。
protected void | ScrollPane.processMouseWheelEvent(MouseWheelEvent e) 处理通过滚动适当量而传递给此 ScrollPane 的鼠标滚轮事件。
protected void | Component.processMouseWheelEvent(MouseWheelEvent e) 处理组件上发生的鼠标滚轮事件，方法是将其指派到任意已注册的 MouseWheelListener 对象。

java.awt.event 中 MouseWheelEvent 的使用

参数类型为 MouseWheelEvent 的 java.awt.event 中的方法
void | MouseAdapter.mouseWheelMoved(MouseWheelEvent e) 鼠标滚轮旋转时调用。
void | MouseWheelListener.mouseWheelMoved(MouseWheelEvent e) 鼠标滚轮旋转时调用。

javax.swing.plaf.basic 中 MouseWheelEvent 的使用

参数类型为 MouseWheelEvent 的 javax.swing.plaf.basic 中的方法
 void BasicScrollPaneUI.MouseWheelHandler.mouseWheelMoved(MouseWheelEvent e)
当鼠标滚轮在 JScrollPane 上转动时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.MouseWheelListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.MouseWheelListener
的使用

使用 MouseWheelListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 MouseWheelListener 的 java.awt 中的方法
static MouseWheelListener | AWTEventMulticaster.add(MouseWheelListener a, MouseWheelListener b) 添加鼠标滚轮侦听器 a 和鼠标滚轮侦听器 b，并返回得到的多路广播侦听器。
MouseWheelListener[] | Component.getMouseWheelListeners() 返回在此组件上所有已注册的鼠标滚轮侦听器的数组。
static MouseWheelListener | AWTEventMulticaster.remove(MouseWheelListener l, MouseWheelListener oldl) 从鼠标滚轮侦听器 l 中移除旧的鼠标滚轮侦听器，并返回得到的多路广播侦听器。

参数类型为 MouseWheelListener 的 java.awt 中的方法
static MouseWheelListener | AWTEventMulticaster.add(MouseWheelListener a, MouseWheelListener b) 添加鼠标滚轮侦听器 a 和鼠标滚轮侦听器 b，并返回得到的多路广播侦听器。
void | Component.addMouseWheelListener(MouseWheelListener l) 添加指定的鼠标滚轮侦听器，以接收发自此组件的鼠标滚轮事件。
static MouseWheelListener | AWTEventMulticaster.remove(MouseWheelListener l, MouseWheelListener oldl) 从鼠标滚轮侦听器 l 中移除旧的鼠标滚轮侦听器，并返回得到的多路广播侦听器。
void | Component.removeMouseWheelListener(MouseWheelListener l) 移除指定的鼠标滚轮侦听器，以便它不再接收发自此组件的鼠标滚轮事件。

java.awt.event 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 java.awt.event 中的类
 class MouseAdapter
接收鼠标事件的抽象适配器类。

javax.swing 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 javax.swing 中的类
 class ToolTipManager
管理系统中的所有 ToolTips。

javax.swing.event 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 javax.swing.event 中的类
 class MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

javax.swing.plaf.basic 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 javax.swing.plaf.basic 中的类
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
protected class | BasicScrollPaneUI.MouseWheelHandler MouseWheelHandler 是实现 MouseWheelListener 接口的内部类。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。

返回 MouseWheelListener 的 javax.swing.plaf.basic 中的方法
protected  MouseWheelListener BasicScrollPaneUI.createMouseWheelListener()
创建一个 MouseWheelListener 的实例，该实例由 installUI() 添加到 JScrollPane。

javax.swing.plaf.metal 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 javax.swing.plaf.metal 中的类
protected  class MetalFileChooserUI.SingleClickListener

javax.swing.text.html 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 javax.swing.text.html 中的类
protected class | FormView.MouseEventListener 当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.PaintEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.PaintEvent
的使用

没有 java.awt.event.PaintEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.TextEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.TextEvent
的使用

使用 TextEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt 中 TextEvent 的使用

参数类型为 TextEvent 的 java.awt 中的方法
protected void | TextComponent.processTextEvent(TextEvent e) 处理发生在此文本组件上的文本事件：将这些事件指派给所有已注册的 TextListener 对象。
void | TextComponent.AccessibleAWTTextComponent.textValueChanged(TextEvent textEvent) 文本值更改的 TextListener 通知。
void | AWTEventMulticaster.textValueChanged(TextEvent e)

java.awt.event 中 TextEvent 的使用

参数类型为 TextEvent 的 java.awt.event 中的方法
 void TextListener.textValueChanged(TextEvent e)
文本的值已改变时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.TextListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.TextListener
的使用

使用 TextListener 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TextListener 的使用

实现 TextListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。

声明为 TextListener 的 java.awt 中的字段
protected  TextListener TextComponent.textListener

返回 TextListener 的 java.awt 中的方法
static TextListener | AWTEventMulticaster.add(TextListener a, TextListener b)
TextListener[] | TextComponent.getTextListeners() 返回在此文本组件上所有已注册文本侦听器的数组。
static TextListener | AWTEventMulticaster.remove(TextListener l, TextListener oldl)

参数类型为 TextListener 的 java.awt 中的方法
static TextListener | AWTEventMulticaster.add(TextListener a, TextListener b)
void | TextComponent.addTextListener(TextListener l) 添加指定的文本事件侦听器，以接收此文本组件发出的文本事件。
static TextListener | AWTEventMulticaster.remove(TextListener l, TextListener oldl)
void | TextComponent.removeTextListener(TextListener l) 移除指定的文本事件侦听器，不再接收此文本组件发出的文本事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.WindowAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.WindowAdapter
的使用

使用 WindowAdapter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 WindowAdapter 的使用

javax.swing 中 WindowAdapter 的子类
protected  class JMenu.WinListener
观察弹出窗口关闭的侦听器类。

javax.swing.plaf.basic 中 WindowAdapter 的使用

javax.swing.plaf.basic 中 WindowAdapter 的子类
protected  class BasicToolBarUI.FrameListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.event.WindowEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.WindowEvent
的使用

使用 WindowEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 WindowEvent 的使用

参数类型为 WindowEvent 的 java.awt 中的方法
protected void | Window.processWindowEvent(WindowEvent e) 处理此窗口上发生的窗口事件：将它们指派到任何注册的 WindowListener 对象。
protected void | Window.processWindowFocusEvent(WindowEvent e) 处理此窗口上发生的窗口焦点事件：将它们指派到任何注册的 WindowFocusListener 对象。
protected void | Window.processWindowStateEvent(WindowEvent e) 处理此窗口上发生的窗口状态事件：将它们指派到任何注册的 WindowStateListener 对象。
void | AWTEventMulticaster.windowActivated(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowActivated 方法处理 windowActivated 事件。
void | AWTEventMulticaster.windowClosed(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowClosed 方法处理 windowClosed 事件。
void | AWTEventMulticaster.windowClosing(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowClosing 方法处理 windowClosing 事件。
void | AWTEventMulticaster.windowDeactivated(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowDeactivated 方法处理 windowDeactivated 事件。
void | AWTEventMulticaster.windowDeiconified(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowDeiconified 方法处理 windowDeiconified 事件。
void | AWTEventMulticaster.windowGainedFocus(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowGainedFocus 方法处理 windowGainedFocus 事件。
void | AWTEventMulticaster.windowIconified(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowIconified 方法处理 windowIconified 事件。
void | AWTEventMulticaster.windowLostFocus(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowLostFocus 方法处理 windowLostFocus 事件。
void | AWTEventMulticaster.windowOpened(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowOpened 方法处理 windowOpened 事件。
void | AWTEventMulticaster.windowStateChanged(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowStateChanged 方法处理 windowStateChanged 事件。

java.awt.event 中 WindowEvent 的使用

参数类型为 WindowEvent 的 java.awt.event 中的方法
void | WindowAdapter.windowActivated(WindowEvent e) 激活窗口时调用。
void | WindowListener.windowActivated(WindowEvent e) 将 Window 设置为活动 Window 时调用。
void | WindowAdapter.windowClosed(WindowEvent e) 当窗口已被关闭时调用。
void | WindowListener.windowClosed(WindowEvent e) 因对窗口调用 dispose 而将其关闭时调用。
void | WindowAdapter.windowClosing(WindowEvent e) 窗口正处在关闭过程中时调用。
void | WindowListener.windowClosing(WindowEvent e) 用户试图从窗口的系统菜单中关闭窗口时调用。
void | WindowAdapter.windowDeactivated(WindowEvent e) 停用窗口时调用。
void | WindowListener.windowDeactivated(WindowEvent e) 当 Window 不再是活动 Window 时调用。
void | WindowAdapter.windowDeiconified(WindowEvent e) 取消图标化窗口时调用。
void | WindowListener.windowDeiconified(WindowEvent e) 窗口从最小化状态变为正常状态时调用。
void | WindowAdapter.windowGainedFocus(WindowEvent e) 该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。
void | WindowFocusListener.windowGainedFocus(WindowEvent e) 该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。
void | WindowAdapter.windowIconified(WindowEvent e) 图标化窗口时调用。
void | WindowListener.windowIconified(WindowEvent e) 窗口从正常状态变为最小化状态时调用。
void | WindowAdapter.windowLostFocus(WindowEvent e) 该 Window 不再为聚焦 Window 时调用，不再为聚焦 Window 意味着键盘事件不再传递到该 Window 或其任意子组件。
void | WindowFocusListener.windowLostFocus(WindowEvent e) 该 Window 不再是聚焦 Window 时调用，不再是聚焦 Window 意味着不再传递键盘事件到该 Window 或其任意子组件。
void | WindowAdapter.windowOpened(WindowEvent e) 已打开窗口时调用。
void | WindowListener.windowOpened(WindowEvent e) 窗口首次变为可见时调用。
void | WindowAdapter.windowStateChanged(WindowEvent e) 窗口状态改变时调用。
void | WindowStateListener.windowStateChanged(WindowEvent e) 窗口状态改变时调用。

javax.swing 中 WindowEvent 的使用

参数类型为 WindowEvent 的 javax.swing 中的方法
protected void | JDialog.processWindowEvent(WindowEvent e) 根据 defaultCloseOperation 属性的状态处理窗口事件。
protected void | JFrame.processWindowEvent(WindowEvent e) 处理此组件上发生的窗口事件。
void | JMenu.WinListener.windowClosing(WindowEvent e) 从外部关闭弹出菜单时取消选择该菜单。

javax.swing.plaf.basic 中 WindowEvent 的使用

参数类型为 WindowEvent 的 javax.swing.plaf.basic 中的方法
 void BasicToolBarUI.FrameListener.windowClosing(WindowEvent w)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.WindowFocusListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.WindowFocusListener
的使用

使用 WindowFocusListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 WindowFocusListener 的使用

实现 WindowFocusListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 WindowFocusListener 的 java.awt 中的方法
static WindowFocusListener | AWTEventMulticaster.add(WindowFocusListener a, WindowFocusListener b) 添加窗口焦点侦听器 a 和窗口焦点侦听器 b，并返回得到的多路广播侦听器。
WindowFocusListener[] | Window.getWindowFocusListeners() 返回在此窗口注册的所有窗口焦点侦听器所组成的数组。
static WindowFocusListener | AWTEventMulticaster.remove(WindowFocusListener l, WindowFocusListener oldl) 从窗口焦点侦听器 l 中移除旧的窗口焦点侦听器，并返回得到的多路广播侦听器。

参数类型为 WindowFocusListener 的 java.awt 中的方法
static WindowFocusListener | AWTEventMulticaster.add(WindowFocusListener a, WindowFocusListener b) 添加窗口焦点侦听器 a 和窗口焦点侦听器 b，并返回得到的多路广播侦听器。
void | Window.addWindowFocusListener(WindowFocusListener l) 添加指定的窗口焦点侦听器，以从此窗口接收窗口事件。
static WindowFocusListener | AWTEventMulticaster.remove(WindowFocusListener l, WindowFocusListener oldl) 从窗口焦点侦听器 l 中移除旧的窗口焦点侦听器，并返回得到的多路广播侦听器。
void | Window.removeWindowFocusListener(WindowFocusListener l) 移除指定的窗口焦点侦听器，以便不再从此窗口接收窗口事件。

java.awt.event 中 WindowFocusListener 的使用

实现 WindowFocusListener 的 java.awt.event 中的类
 class WindowAdapter
接收窗口事件的抽象适配器类。

javax.swing 中 WindowFocusListener 的使用

实现 WindowFocusListener 的 javax.swing 中的类
protected  class JMenu.WinListener
观察弹出窗口关闭的侦听器类。

javax.swing.plaf.basic 中 WindowFocusListener 的使用

实现 WindowFocusListener 的 javax.swing.plaf.basic 中的类
protected  class BasicToolBarUI.FrameListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.WindowListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.WindowListener
的使用

使用 WindowListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 WindowListener 的使用

实现 WindowListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 WindowListener 的 java.awt 中的方法
static WindowListener | AWTEventMulticaster.add(WindowListener a, WindowListener b) 添加窗口侦听器 a 和窗口侦听器 b，并返回得到的多路广播侦听器。
WindowListener[] | Window.getWindowListeners() 返回在此窗口注册的所有窗口侦听器所组成的数组。
static WindowListener | AWTEventMulticaster.remove(WindowListener l, WindowListener oldl) 从窗口侦听器 l 中移除旧的窗口侦听器，并返回得到的多路广播侦听器。

参数类型为 WindowListener 的 java.awt 中的方法
static WindowListener | AWTEventMulticaster.add(WindowListener a, WindowListener b) 添加窗口侦听器 a 和窗口侦听器 b，并返回得到的多路广播侦听器。
void | Window.addWindowListener(WindowListener l) 添加指定的窗口侦听器，以从此窗口接收窗口事件。
static WindowListener | AWTEventMulticaster.remove(WindowListener l, WindowListener oldl) 从窗口侦听器 l 中移除旧的窗口侦听器，并返回得到的多路广播侦听器。
void | Window.removeWindowListener(WindowListener l) 移除指定的窗口侦听器，以便不再从此窗口接收窗口事件。

java.awt.event 中 WindowListener 的使用

实现 WindowListener 的 java.awt.event 中的类
 class WindowAdapter
接收窗口事件的抽象适配器类。

javax.swing 中 WindowListener 的使用

实现 WindowListener 的 javax.swing 中的类
protected  class JMenu.WinListener
观察弹出窗口关闭的侦听器类。

javax.swing.plaf.basic 中 WindowListener 的使用

实现 WindowListener 的 javax.swing.plaf.basic 中的类
protected  class BasicToolBarUI.FrameListener

返回 WindowListener 的 javax.swing.plaf.basic 中的方法
protected  WindowListener BasicToolBarUI.createFrameListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.event.WindowStateListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.WindowStateListener
的使用

使用 WindowStateListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 WindowStateListener 的使用

实现 WindowStateListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 WindowStateListener 的 java.awt 中的方法
static WindowStateListener | AWTEventMulticaster.add(WindowStateListener a, WindowStateListener b) 添加窗口状态侦听器 a 和窗口状态侦听器 b，并返回得到的多路广播侦听器。
WindowStateListener[] | Window.getWindowStateListeners() 返回在此窗口注册的所有窗口状态侦听器所组成的数组。
static WindowStateListener | AWTEventMulticaster.remove(WindowStateListener l, WindowStateListener oldl) 从窗口状态侦听器 l 中移除旧的窗口状态侦听器，并返回得到的多路广播侦听器。

参数类型为 WindowStateListener 的 java.awt 中的方法
static WindowStateListener | AWTEventMulticaster.add(WindowStateListener a, WindowStateListener b) 添加窗口状态侦听器 a 和窗口状态侦听器 b，并返回得到的多路广播侦听器。
void | Window.addWindowStateListener(WindowStateListener l) 添加指定的窗口状态侦听器，以从此窗口接收窗口事件。
static WindowStateListener | AWTEventMulticaster.remove(WindowStateListener l, WindowStateListener oldl) 从窗口状态侦听器 l 中移除旧的窗口状态侦听器，并返回得到的多路广播侦听器。
void | Window.removeWindowStateListener(WindowStateListener l) 移除指定的窗口状态侦听器，以便不再从此窗口接收窗口事件。

java.awt.event 中 WindowStateListener 的使用

实现 WindowStateListener 的 java.awt.event 中的类
 class WindowAdapter
接收窗口事件的抽象适配器类。

javax.swing 中 WindowStateListener 的使用

实现 WindowStateListener 的 javax.swing 中的类
protected  class JMenu.WinListener
观察弹出窗口关闭的侦听器类。

javax.swing.plaf.basic 中 WindowStateListener 的使用

实现 WindowStateListener 的 javax.swing.plaf.basic 中的类
protected  class BasicToolBarUI.FrameListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.awt.font (Java 2 Platform SE 6)

 java.awt.font
接口
MultipleMaster
OpenType
类
FontRenderContext
GlyphJustificationInfo
GlyphMetrics
GlyphVector
GraphicAttribute
ImageGraphicAttribute
LayoutPath
LineBreakMeasurer
LineMetrics
NumericShaper
ShapeGraphicAttribute
TextAttribute
TextHitInfo
TextLayout
TextLayout.CaretPolicy
TextMeasurer
TransformAttribute


类 java.awt.font.FontRenderContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.FontRenderContext
的使用

使用 FontRenderContext 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。

java.awt 中 FontRenderContext 的使用

返回 FontRenderContext 的 java.awt 中的方法
FontRenderContext | FontMetrics.getFontRenderContext() 获取此 FontMetrics 对象用来测量文本的 FontRenderContext。
abstract FontRenderContext | Graphics2D.getFontRenderContext() 获取此 Graphics2D 上下文中 Font 的呈现上下文。

参数类型为 FontRenderContext 的 java.awt 中的方法
GlyphVector | Font.createGlyphVector(FontRenderContext frc, char[] chars) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, CharacterIterator ci) 根据此 Font 中的 Unicode cmap 将指定字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, int[] glyphCodes) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, String str) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
LineMetrics | Font.getLineMetrics(char[] chars, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(String str, FontRenderContext frc) 返回一个使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(String str, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
Rectangle2D | Font.getMaxCharBounds(FontRenderContext frc) 返回最大边界定义在 FontRenderContext 中的字符的边界。
Rectangle2D | Font.getStringBounds(char[] chars, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 指定字符数组的逻辑边界。
Rectangle2D | Font.getStringBounds(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的逻辑边界。
Rectangle2D | Font.getStringBounds(String str, FontRenderContext frc) 返回指定 FontRenderContext 中指定 String 的逻辑边界。
Rectangle2D | Font.getStringBounds(String str, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中指定 String 的逻辑边界。
GlyphVector | Font.layoutGlyphVector(FontRenderContext frc, char[] text, int start, int limit, int flags) 返回一个新 GlyphVector 对象，执行完整的文本布局（如有可能）。

java.awt.font 中 FontRenderContext 的使用

返回 FontRenderContext 的 java.awt.font 中的方法
abstract  FontRenderContext GlyphVector.getFontRenderContext()
返回与此 GlyphVector 关联的 FontRenderContext。

参数类型为 FontRenderContext 的 java.awt.font 中的方法
boolean | FontRenderContext.equals(FontRenderContext rhs) 如果 rhs 具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。
Rectangle | GlyphVector.getGlyphPixelBounds(int index, FontRenderContext renderFRC, float x, float y) 返回当此 GlyphVector 在 Graphics 中以给定 FontRenderContext 在给定位置呈现时，index 处字形的像素边界。
Rectangle | TextLayout.getPixelBounds(FontRenderContext frc, float x, float y) 返回在图形中使用给定 FontRenderContext 在给定位置处呈现 TextLayout 时的像素边界。
Rectangle | GlyphVector.getPixelBounds(FontRenderContext renderFRC, float x, float y) 返回此 GlyphVector 在图形中以给定 FontRenderContext 在给定位置处呈现时的像素边界。

参数类型为 FontRenderContext 的 java.awt.font 中的构造方法
LineBreakMeasurer(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。
LineBreakMeasurer(AttributedCharacterIterator text, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。
TextLayout(AttributedCharacterIterator text, FontRenderContext frc)
根据样式文本上的迭代器构造一个 TextLayout。
TextLayout(String string, Font font, FontRenderContext frc)
根据 String 和 Font 构造一个 TextLayout。
TextLayout(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
根据 String 和属性集构造一个 TextLayout。
TextMeasurer(AttributedCharacterIterator text, FontRenderContext frc)
从源文本构造 TextMeasurer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.GlyphJustificationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.GlyphJustificationInfo
的使用

使用 GlyphJustificationInfo 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 GlyphJustificationInfo 的使用

返回 GlyphJustificationInfo 的 java.awt.font 中的方法
abstract GlyphJustificationInfo | GlyphVector.getGlyphJustificationInfo(int glyphIndex) 返回此 GlyphVector 中指定索引处的字形调整信息。
GlyphJustificationInfo | GraphicAttribute.getJustificationInfo() 返回此 GraphicAttribute 的调整信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.GlyphMetrics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.GlyphMetrics
的使用

使用 GlyphMetrics 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 GlyphMetrics 的使用

返回 GlyphMetrics 的 java.awt.font 中的方法
abstract  GlyphMetrics GlyphVector.getGlyphMetrics(int glyphIndex)
返回此 GlyphVector 中指定索引处的字形规格。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.GlyphVector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.GlyphVector
的使用

使用 GlyphVector 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。

java.awt 中 GlyphVector 的使用

返回 GlyphVector 的 java.awt 中的方法
GlyphVector | Font.createGlyphVector(FontRenderContext frc, char[] chars) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, CharacterIterator ci) 根据此 Font 中的 Unicode cmap 将指定字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, int[] glyphCodes) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, String str) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.layoutGlyphVector(FontRenderContext frc, char[] text, int start, int limit, int flags) 返回一个新 GlyphVector 对象，执行完整的文本布局（如有可能）。

参数类型为 GlyphVector 的 java.awt 中的方法
abstract  void Graphics2D.drawGlyphVector(GlyphVector g, float x, float y)
使用 Graphics2D 上下文的呈现属性，呈现指定 GlyphVector 的文本。

java.awt.font 中 GlyphVector 的使用

参数类型为 GlyphVector 的 java.awt.font 中的方法
abstract  boolean GlyphVector.equals(GlyphVector set)
测试指定的 GlyphVector 是否恰好等于此 GlyphVector。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.GraphicAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.GraphicAttribute
的使用

使用 GraphicAttribute 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 GraphicAttribute 的使用

java.awt.font 中 GraphicAttribute 的子类
class | ImageGraphicAttribute ImageGraphicAttribute 类是在 TextLayout 中绘制图像的 GraphicAttribute 实现。
class | ShapeGraphicAttribute ShapeGraphicAttribute 类是以 TextLayout 形式绘制形状的 GraphicAttribute 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.ImageGraphicAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.ImageGraphicAttribute
的使用

使用 ImageGraphicAttribute 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 ImageGraphicAttribute 的使用

参数类型为 ImageGraphicAttribute 的 java.awt.font 中的方法
 boolean ImageGraphicAttribute.equals(ImageGraphicAttribute rhs)
比较此 ImageGraphicAttribute 与指定的 ImageGraphicAttribute。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.LayoutPath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.LayoutPath
的使用

使用 LayoutPath 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 LayoutPath 的使用

返回 LayoutPath 的 java.awt.font 中的方法
 LayoutPath TextLayout.getLayoutPath()
返回 LayoutPath，如果布局路径是默认路径（x 映射到 advance，y 映射到 offset），则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.LineBreakMeasurer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.LineBreakMeasurer
的使用

没有 java.awt.font.LineBreakMeasurer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.LineMetrics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.LineMetrics
的使用

使用 LineMetrics 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 LineMetrics 的使用

返回 LineMetrics 的 java.awt 中的方法
LineMetrics | Font.getLineMetrics(char[] chars, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(char[] chars, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定字符数组的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 CharacterIterator 的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(String str, FontRenderContext frc) 返回一个使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(String str, Graphics context) 返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(String str, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(String str, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.font.MultipleMaster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.font.MultipleMaster
的使用

没有 java.awt.font.MultipleMaster 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.NumericShaper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.NumericShaper
的使用

使用 NumericShaper 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 NumericShaper 的使用

返回 NumericShaper 的 java.awt.font 中的方法
static NumericShaper | NumericShaper.getContextualShaper(int ranges) 返回提供的 unicode 范围的上下文成形器。
static NumericShaper | NumericShaper.getContextualShaper(int ranges, int defaultContext) 返回提供的 unicode 范围的上下文成形器。
static NumericShaper | NumericShaper.getShaper(int singleRange) 返回所提供的 unicode 范围的成形器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.font.OpenType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.font.OpenType
的使用

没有 java.awt.font.OpenType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.ShapeGraphicAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.ShapeGraphicAttribute
的使用

使用 ShapeGraphicAttribute 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 ShapeGraphicAttribute 的使用

参数类型为 ShapeGraphicAttribute 的 java.awt.font 中的方法
 boolean ShapeGraphicAttribute.equals(ShapeGraphicAttribute rhs)
将此 ShapeGraphicAttribute 与指定的 ShapeGraphicAttribute 进行比较。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.TextAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TextAttribute
的使用

使用 TextAttribute 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。

java.awt 中 TextAttribute 的使用

返回变量类型为 TextAttribute 的类型的 java.awt 中的方法
Map<TextAttribute,?> | Font.getAttributes() 返回此 Font 中可用的字体属性的映射。
abstract Map<TextAttribute,?> | Toolkit.mapInputMethodHighlight(InputMethodHighlight highlight) 返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。

java.awt.font 中 TextAttribute 的使用

声明为 TextAttribute 的 java.awt.font 中的字段
static TextAttribute | TextAttribute.BACKGROUND 用于呈现文本背景的 paint 的属性键。
static TextAttribute | TextAttribute.BIDI_EMBEDDING 文本嵌入级别的属性键。
static TextAttribute | TextAttribute.CHAR_REPLACEMENT 用于取代字符的字体标准字型显示的用户定义字形的属性键。
static TextAttribute | TextAttribute.FAMILY 字体名称的属性键。
static TextAttribute | TextAttribute.FONT 用于提供呈现文本字体的属性键。
static TextAttribute | TextAttribute.FOREGROUND 用于呈现文本的 paint 的属性键。
static TextAttribute | TextAttribute.INPUT_METHOD_HIGHLIGHT 用于输入法高亮显示样式的属性键。
static TextAttribute | TextAttribute.INPUT_METHOD_UNDERLINE 输入法下划线的属性键。
static TextAttribute | TextAttribute.JUSTIFICATION 段落调整的属性键。
static TextAttribute | TextAttribute.KERNING 请求进行字距调整的属性键。
static TextAttribute | TextAttribute.LIGATURES 启用可选连字的属性键。
static TextAttribute | TextAttribute.NUMERIC_SHAPING 将 ASCII 十进制数字转换为其他十进制范围数字的属性键。
static TextAttribute | TextAttribute.POSTURE 字体形态的属性键。
static TextAttribute | TextAttribute.RUN_DIRECTION 线条延伸方向的属性键。
static TextAttribute | TextAttribute.SIZE 字体大小的属性键。
static TextAttribute | TextAttribute.STRIKETHROUGH 删除线的属性键。
static TextAttribute | TextAttribute.SUPERSCRIPT 用于上标和下标的属性键。
static TextAttribute | TextAttribute.SWAP_COLORS 交换前景和背景 Paint 的属性键。
static TextAttribute | TextAttribute.TRACKING 控制跟踪的属性键。
static TextAttribute | TextAttribute.TRANSFORM 字体转换的属性键。
static TextAttribute | TextAttribute.UNDERLINE 下划线的属性键。
static TextAttribute | TextAttribute.WEIGHT 字体 weight 的属性键。
static TextAttribute | TextAttribute.WIDTH 字体宽度的属性键。

java.awt.im 中 TextAttribute 的使用

返回变量类型为 TextAttribute 的类型的 java.awt.im 中的方法
 Map<TextAttribute,?> InputMethodHighlight.getStyle()
返回文本范围的呈现样式属性，或 null。

类型变量类型为 TextAttribute 的 java.awt.im 中的构造方法参数
InputMethodHighlight(boolean selected, int state, int variation, Map<TextAttribute,?> style)
构造输入方法高亮显示记录。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.TextHitInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TextHitInfo
的使用

使用 TextHitInfo 的软件包
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.event 中 TextHitInfo 的使用

返回 TextHitInfo 的 java.awt.event 中的方法
TextHitInfo | InputMethodEvent.getCaret() 获取插入符。
TextHitInfo | InputMethodEvent.getVisiblePosition() 获取对于可见性至关重要的位置。

参数类型为 TextHitInfo 的 java.awt.event 中的构造方法
InputMethodEvent(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、时间、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、插入符和 visiblePosition 来构造 InputMethodEvent。

java.awt.font 中 TextHitInfo 的使用

返回 TextHitInfo 的 java.awt.font 中的方法
static TextHitInfo | TextHitInfo.afterOffset(int offset) 在指定偏移量处创建一个与偏移量之后的字符关联的 TextHitInfo。
static TextHitInfo | TextHitInfo.beforeOffset(int offset) 在指定偏移量处创建一个与偏移量之前的字符关联的 TextHitInfo。
TextHitInfo | TextLayout.getNextLeftHit(int offset) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextLeftHit(int offset, TextLayout.CaretPolicy policy) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextLeftHit(TextHitInfo hit) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextRightHit(int offset) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextRightHit(int offset, TextLayout.CaretPolicy policy) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextRightHit(TextHitInfo hit) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextHitInfo.getOffsetHit(int delta) 创建一个 TextHitInfo，其字符索引从此 TextHitInfo 的 charIndex 偏移 delta。
TextHitInfo | TextHitInfo.getOtherHit() 在插入点的另一侧创建一个 TextHitInfo。
TextHitInfo | TextLayout.CaretPolicy.getStrongCaret(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout) 选择一个指定的 TextHitInfo 实例作为指定 TextLayout 中的强插入符。
TextHitInfo | TextLayout.getVisualOtherHit(TextHitInfo hit) 返回位于指定目标字符插入符另一侧的目标字符。
TextHitInfo | TextLayout.hitTestChar(float x, float y) 返回对应于指定点的 TextHitInfo。
TextHitInfo | TextLayout.hitTestChar(float x, float y, Rectangle2D bounds) 返回对应于指定点的 TextHitInfo。
static TextHitInfo | TextHitInfo.leading(int charIndex) 在指定 charIndex 处的字符开始边上创建一个 TextHitInfo。
static TextHitInfo | TextHitInfo.trailing(int charIndex) 在指定 charIndex 处的字符的结尾边上创建一个 TextHitInfo。

参数类型为 TextHitInfo 的 java.awt.font 中的方法
boolean | TextHitInfo.equals(TextHitInfo hitInfo) 如果指定的 TextHitInfo 具有与此 TextHitInfo 相同的 charIndex 和 isLeadingEdge，则返回 true。
float[] | TextLayout.getCaretInfo(TextHitInfo hit) 返回与对应于 hit 的插入符有关的信息。
float[] | TextLayout.getCaretInfo(TextHitInfo hit, Rectangle2D bounds) 返回与对应于 hit 的插入符有关的信息。
Shape | TextLayout.getCaretShape(TextHitInfo hit) 返回表示此 TextLayout 的自然边界中指定目标字符处插入符的 Shape。
Shape | TextLayout.getCaretShape(TextHitInfo hit, Rectangle2D bounds) 返回表示指定边界内指定目标字符处插入符的 Shape。
int[] | TextLayout.getLogicalRangesForVisualSelection(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint) 返回对应于可视选择范围的逻辑文本范围。
TextHitInfo | TextLayout.getNextLeftHit(TextHitInfo hit) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextRightHit(TextHitInfo hit) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.CaretPolicy.getStrongCaret(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout) 选择一个指定的 TextHitInfo 实例作为指定 TextLayout 中的强插入符。
Shape | TextLayout.getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint) 返回封闭指定范围中扩展到指定边界的可视选择范围的 Shape。
Shape | TextLayout.getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到 bounds 的可视选择范围的路径。
TextHitInfo | TextLayout.getVisualOtherHit(TextHitInfo hit) 返回位于指定目标字符插入符另一侧的目标字符。
void | TextLayout.hitToPoint(TextHitInfo hit, Point2D point) 将一个命中点转换为标准坐标中的一个点。

java.awt.im 中 TextHitInfo 的使用

返回 TextHitInfo 的 java.awt.im 中的方法
 TextHitInfo InputMethodRequests.getLocationOffset(int x, int y)
获取撰写文本相对于屏幕上指定 x 和 y 绝对坐标的偏移量。

参数类型为 TextHitInfo 的 java.awt.im 中的方法
 Rectangle InputMethodRequests.getTextLocation(TextHitInfo offset)
获取当前撰写文本中指定偏移量的位置，或已提交文本中的选择位置。

java.awt.im.spi 中 TextHitInfo 的使用

参数类型为 TextHitInfo 的 java.awt.im.spi 中的方法
 void InputMethodContext.dispatchInputMethodEvent(int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
根据给定的参数创建输入方法事件并将其指派到客户端组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.TextLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TextLayout
的使用

使用 TextLayout 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 TextLayout 的使用

返回 TextLayout 的 java.awt.font 中的方法
TextLayout | TextLayout.getJustifiedLayout(float justificationWidth) 创建调整到指定宽度的此 TextLayout 的一个副本。
TextLayout | TextMeasurer.getLayout(int start, int limit) 返回给定字符范围上的 TextLayout。
TextLayout | LineBreakMeasurer.nextLayout(float wrappingWidth) 返回下一个布局，并更新当前位置。
TextLayout | LineBreakMeasurer.nextLayout(float wrappingWidth, int offsetLimit, boolean requireNextWord) 返回下一个布局，并更新当前位置。

参数类型为 TextLayout 的 java.awt.font 中的方法
boolean | TextLayout.equals(TextLayout rhs) 如果两个布局相等，则返回 true。
TextHitInfo | TextLayout.CaretPolicy.getStrongCaret(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout) 选择一个指定的 TextHitInfo 实例作为指定 TextLayout 中的强插入符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.TextLayout.CaretPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TextLayout.CaretPolicy
的使用

使用 TextLayout.CaretPolicy 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 TextLayout.CaretPolicy 的使用

声明为 TextLayout.CaretPolicy 的 java.awt.font 中的字段
static TextLayout.CaretPolicy TextLayout.DEFAULT_CARET_POLICY
客户端未指定策略时使用此 CaretPolicy。

参数类型为 TextLayout.CaretPolicy 的 java.awt.font 中的方法
Shape[] | TextLayout.getCaretShapes(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy) 返回对应于强插入符和弱插入符的两条路径。
TextHitInfo | TextLayout.getNextLeftHit(int offset, TextLayout.CaretPolicy policy) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextRightHit(int offset, TextLayout.CaretPolicy policy) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.TextMeasurer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TextMeasurer
的使用

没有 java.awt.font.TextMeasurer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.font.TransformAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TransformAttribute
的使用

使用 TransformAttribute 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 TransformAttribute 的使用

声明为 TransformAttribute 的 java.awt.font 中的字段
static TransformAttribute TransformAttribute.IDENTITY
表示恒等变换的 TransformAttribute。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.awt.geom (Java 2 Platform SE 6)

 java.awt.geom
接口
PathIterator
类
AffineTransform
Arc2D
Arc2D.Double
Arc2D.Float
Area
CubicCurve2D
CubicCurve2D.Double
CubicCurve2D.Float
Dimension2D
Ellipse2D
Ellipse2D.Double
Ellipse2D.Float
FlatteningPathIterator
GeneralPath
Line2D
Line2D.Double
Line2D.Float
Path2D
Path2D.Double
Path2D.Float
Point2D
Point2D.Double
Point2D.Float
QuadCurve2D
QuadCurve2D.Double
QuadCurve2D.Float
Rectangle2D
Rectangle2D.Double
Rectangle2D.Float
RectangularShape
RoundRectangle2D
RoundRectangle2D.Double
RoundRectangle2D.Float
异常
IllegalPathStateException
NoninvertibleTransformException


类 java.awt.geom.AffineTransform 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.AffineTransform
的使用

使用 AffineTransform 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。

java.awt 中 AffineTransform 的使用

返回 AffineTransform 的 java.awt 中的方法
abstract AffineTransform | GraphicsConfiguration.getDefaultTransform() 返回此 GraphicsConfiguration 的默认 AffineTransform。
abstract AffineTransform | GraphicsConfiguration.getNormalizingTransform() 返回可与 GraphicsConfiguration 的默认 AffineTransform 连接的 AffineTransform，从而用户空间的 72 单位等于设备空间的 1 英寸。
AffineTransform | MultipleGradientPaint.getTransform() 返回应用于渐变的变换的副本。
abstract AffineTransform | Graphics2D.getTransform() 返回 Graphics2D 上下文中当前 Transform 的副本。
AffineTransform | Font.getTransform() 返回与此 Font 相关的变换的副本。

参数类型为 AffineTransform 的 java.awt 中的方法
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
Font | Font.deriveFont(AffineTransform trans) 通过复制当前 Font 对象并应用新的变换，创建一个新 Font 对象。
Font | Font.deriveFont(int style, AffineTransform trans) 通过复制此 Font 对象并应用新样式和变换，创建一个新 Font 对象。
abstract boolean | Graphics2D.drawImage(Image img, AffineTransform xform, ImageObserver obs) 呈现一个图像，在绘制前进行从图像空间到用户空间的转换。
abstract void | Graphics2D.drawRenderableImage(RenderableImage img, AffineTransform xform) 呈现 RenderableImage，在绘制前进行从图像空间到用户空间的转换。
abstract void | Graphics2D.drawRenderedImage(RenderedImage img, AffineTransform xform) 呈现 RenderedImage，在绘制前进行从图像空间到用户空间的转换。
PathIterator | Polygon.getPathIterator(AffineTransform at) 返回迭代器对象，此对象沿此 Polygon 的边界进行迭代，并且提供对此 Polygon 轮廓的几何形状的访问。
PathIterator | Shape.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | Polygon.getPathIterator(AffineTransform at, double flatness) 返回迭代器对象，此对象沿 Shape 的边界进行迭代，并且提供了对 Shape 轮廓的几何形状的访问。
PathIterator | Shape.getPathIterator(AffineTransform at, double flatness) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
abstract void | Graphics2D.setTransform(AffineTransform Tx) 重写 Graphics2D 上下文中的 Transform。
abstract void | Graphics2D.transform(AffineTransform Tx) 根据“最后指定首先应用”规则，使用此 Graphics2D 中的 Transform 组合 AffineTransform 对象。

参数类型为 AffineTransform 的 java.awt 中的构造方法
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。

java.awt.font 中 AffineTransform 的使用

返回 AffineTransform 的 java.awt.font 中的方法
abstract AffineTransform | GlyphVector.getGlyphTransform(int glyphIndex) 返回此 GlyphVector 中指定字形的转换。
AffineTransform | TransformAttribute.getTransform() 返回包装转换的一个副本。
AffineTransform | FontRenderContext.getTransform() 获取用于在此 FontRenderContext 中将印刷点缩放为像素的转换。

参数类型为 AffineTransform 的 java.awt.font 中的方法
Shape | GraphicAttribute.getOutline(AffineTransform tx) 返回表示此 GraphicAttribute 呈现区域的 Shape。
Shape | ShapeGraphicAttribute.getOutline(AffineTransform tx) 返回一个表示此 ShapeGraphicAttribute 呈现区域的 Shape。
Shape | TextLayout.getOutline(AffineTransform tx) 返回表示此 TextLayout 的轮廓的 Shape。
abstract void | GlyphVector.setGlyphTransform(int glyphIndex, AffineTransform newTX) 设置此 GlyphVector 中指定字形的转换。

参数类型为 AffineTransform 的 java.awt.font 中的构造方法
FontRenderContext(AffineTransform tx, boolean isAntiAliased, boolean usesFractionalMetrics)
根据可选的 AffineTransform 和两个 boolean 值构造一个 FontRenderContext 对象，这两个 boolean 值确定新构造的对象是否具有 anti-aliasing 或 fractional metrics 属性。
FontRenderContext(AffineTransform tx, Object aaHint, Object fmHint)
根据一个可选 AffineTransform 和两个 Object 值构造一个 FontRenderContext 对象，这两个值决定了新创建的对象是具有 anti-aliasing 属性，还是具有 fractional metrics 属性。
TransformAttribute(AffineTransform transform)
包装指定的转换。

java.awt.geom 中 AffineTransform 的使用

返回 AffineTransform 的 java.awt.geom 中的方法
AffineTransform | AffineTransform.createInverse() 返回表示逆向变换的 AffineTransform 对象。
static AffineTransform | AffineTransform.getQuadrantRotateInstance(int numquadrants) 返回按指定象限数旋转坐标的变换。
static AffineTransform | AffineTransform.getQuadrantRotateInstance(int numquadrants, double anchorx, double anchory) 返回按指定象限数绕指定锚点旋转坐标的变换。
static AffineTransform | AffineTransform.getRotateInstance(double theta) 返回表示旋转变换的变换。
static AffineTransform | AffineTransform.getRotateInstance(double vecx, double vecy) 返回根据旋转向量旋转坐标的变换。
static AffineTransform | AffineTransform.getRotateInstance(double theta, double anchorx, double anchory) 返回绕锚点旋转坐标的变换。
static AffineTransform | AffineTransform.getRotateInstance(double vecx, double vecy, double anchorx, double anchory) 返回根据旋转向量绕锚点坐标旋转坐标的变换。
static AffineTransform | AffineTransform.getScaleInstance(double sx, double sy) 返回表示缩放变换的变换。
static AffineTransform | AffineTransform.getShearInstance(double shx, double shy) 返回表示错切变换的变换。
static AffineTransform | AffineTransform.getTranslateInstance(double tx, double ty) 返回表示平移变换的变换。

参数类型为 AffineTransform 的 java.awt.geom 中的方法
void | AffineTransform.concatenate(AffineTransform Tx) 以最常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，以提供由 Tx 映射到以前用户空间的新用户空间。
Area | Area.createTransformedArea(AffineTransform t) 创建一个新 Area 对象，使它与由指定 AffineTransform 变换的 Area 包含相同的几何形状。
Shape | Path2D.createTransformedShape(AffineTransform at) 返回一个表示此 Path2D 变换形式的新 Shape。
PathIterator | Arc2D.getPathIterator(AffineTransform at) 返回定义弧边界的迭代对象。
PathIterator | Area.getPathIterator(AffineTransform at) 为此 Area 对象的轮廓创建一个 PathIterator。
PathIterator | CubicCurve2D.getPathIterator(AffineTransform at) 返回定义形状边界的迭代对象。
PathIterator | Ellipse2D.getPathIterator(AffineTransform at) 返回定义此 Ellipse2D 边界的迭代对象。
PathIterator | Line2D.getPathIterator(AffineTransform at) 返回定义此 Line2D 边界的迭代对象。
PathIterator | Path2D.Float.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | Path2D.Double.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | QuadCurve2D.getPathIterator(AffineTransform at) 返回定义此 QuadCurve2D 的形状边界的迭代对象。
PathIterator | RoundRectangle2D.getPathIterator(AffineTransform at) 返回定义此 RoundRectangle2D 边界的迭代对象。
PathIterator | Rectangle2D.getPathIterator(AffineTransform at) 返回定义此 Rectangle2D 边界的迭代对象。
PathIterator | Area.getPathIterator(AffineTransform at, double flatness) 为此 Area 对象的变平轮廓创建 PathIterator。
PathIterator | CubicCurve2D.getPathIterator(AffineTransform at, double flatness) 返回定义变平形状边界的迭代对象。
PathIterator | Line2D.getPathIterator(AffineTransform at, double flatness) 返回定义此变平的 Line2D 边界的迭代对象。
PathIterator | Path2D.getPathIterator(AffineTransform at, double flatness) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
PathIterator | QuadCurve2D.getPathIterator(AffineTransform at, double flatness) 返回定义此 QuadCurve2D 的变平形状边界的迭代对象。
PathIterator | Rectangle2D.getPathIterator(AffineTransform at, double flatness) 返回定义变平的 Rectangle2D 边界的迭代对象。
PathIterator | RectangularShape.getPathIterator(AffineTransform at, double flatness) 返回一个迭代器对象，它可沿 Shape 对象的边界进行迭代，并提供对 Shape 对象轮廓几何形状平面视图的访问。
void | AffineTransform.preConcatenate(AffineTransform Tx) 以不常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，从而 Tx 相对于绝对像素空间（而非相对于现有用户空间）修改坐标变换。
void | AffineTransform.setTransform(AffineTransform Tx) 将此变换设置为指定 AffineTransform 对象中变换的副本。
void | Area.transform(AffineTransform t) 使用指定的 AffineTransform 变换此 Area 的几何形状。
abstract void | Path2D.transform(AffineTransform at) 使用指定的 AffineTransform 变换此路径的几何形状。
void | Path2D.Float.transform(AffineTransform at) 使用指定的 AffineTransform 变换此路径的几何形状。
void | Path2D.Double.transform(AffineTransform at) 使用指定的 AffineTransform 变换此路径的几何形状。

参数类型为 AffineTransform 的 java.awt.geom 中的构造方法
AffineTransform(AffineTransform Tx)
构造一个新 AffineTransform，让它作为指定 AffineTransform 对象的副本。
Path2D.Double(Shape s, AffineTransform at)
根据由 AffineTransform 对象变换的任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Float(Shape s, AffineTransform at)
根据 AffineTransform 对象变换的任意 Shape 对象构造一个新的单精度 Path2D 对象。

java.awt.image 中 AffineTransform 的使用

返回 AffineTransform 的 java.awt.image 中的方法
 AffineTransform AffineTransformOp.getTransform()
返回此转换操作使用的仿射转换。

参数类型为 AffineTransform 的 java.awt.image 中的构造方法
AffineTransformOp(AffineTransform xform, int interpolationType)
根据仿射转换和插值类型构造一个 AffineTransformOp。
AffineTransformOp(AffineTransform xform, RenderingHints hints)
根据仿射转换构造 AffineTransformOp。

java.awt.image.renderable 中 AffineTransform 的使用

返回 AffineTransform 的 java.awt.image.renderable 中的方法
 AffineTransform RenderContext.getTransform()
获取当前“用户到设备”的 AffineTransform。

参数类型为 AffineTransform 的 java.awt.image.renderable 中的方法
void | RenderContext.concatenateTransform(AffineTransform modTransform) 通过追加另一变换修改当前的“用户到设备”变换。
void | RenderContext.concetenateTransform(AffineTransform modTransform) 已过时。 由 concatenateTransform(AffineTransform) 所替代。
void | RenderContext.preConcatenateTransform(AffineTransform modTransform) 通过预先挂起另一变换修改当前的“用户到设备”变换。
void | RenderContext.preConcetenateTransform(AffineTransform modTransform) 已过时。 由 preConcatenateTransform(AffineTransform) 所取代。
void | RenderContext.setTransform(AffineTransform newTransform) 将 RenderContext 中包含的当前“用户到设备”的 AffineTransform 设置为给定的变换。

参数类型为 AffineTransform 的 java.awt.image.renderable 中的构造方法
RenderContext(AffineTransform usr2dev)
构造具有给定变换的 RenderContext。
RenderContext(AffineTransform usr2dev, RenderingHints hints)
构造具有给定转换和呈现提示的 RenderContext。
RenderContext(AffineTransform usr2dev, Shape aoi)
构造具有给定变换和感兴趣区域的 RenderContext。
RenderContext(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
构造具有给定转换的 RenderContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Arc2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Arc2D
的使用

使用 Arc2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Arc2D 的使用

java.awt.geom 中 Arc2D 的子类
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。

参数类型为 Arc2D 的 java.awt.geom 中的方法
 void Arc2D.setArc(Arc2D a)
将此弧设置为与指定弧相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Arc2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Arc2D.Double
的使用

没有 java.awt.geom.Arc2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Arc2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Arc2D.Float
的使用

没有 java.awt.geom.Arc2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Area 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Area
的使用

使用 Area 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Area 的使用

返回 Area 的 java.awt.geom 中的方法
 Area Area.createTransformedArea(AffineTransform t)
创建一个新 Area 对象，使它与由指定 AffineTransform 变换的 Area 包含相同的几何形状。

参数类型为 Area 的 java.awt.geom 中的方法
void | Area.add(Area rhs) 将指定 Area 的形状添加到此 Area 的形状中。
boolean | Area.equals(Area other) 测试两个 Area 对象的几何形状是否相等。
void | Area.exclusiveOr(Area rhs) 将此 Area 的形状设置为其当前形状与指定 Area 形状的组合区域，并减去其交集。
void | Area.intersect(Area rhs) 将此 Area 的形状设置为其当前形状与指定 Area 形状的交集。
void | Area.subtract(Area rhs) 从此 Area 的形状中减去指定 Area 的形状。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.CubicCurve2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.CubicCurve2D
的使用

使用 CubicCurve2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 CubicCurve2D 的使用

java.awt.geom 中 CubicCurve2D 的子类
static class | CubicCurve2D.Double 使用 double 坐标指定的三次参数曲线段。
static class | CubicCurve2D.Float 使用 float 坐标指定的三次参数曲线段。

参数类型为 CubicCurve2D 的 java.awt.geom 中的方法
void | CubicCurve2D.setCurve(CubicCurve2D c) 将此曲线端点和控制点的位置设置为与指定的 CubicCurve2D 相同。
void | CubicCurve2D.subdivide(CubicCurve2D left, CubicCurve2D right) 细分此三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
static void | CubicCurve2D.subdivide(CubicCurve2D src, CubicCurve2D left, CubicCurve2D right) 细分由 src 参数指定的三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.CubicCurve2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.CubicCurve2D.Double
的使用

没有 java.awt.geom.CubicCurve2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.CubicCurve2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.CubicCurve2D.Float
的使用

没有 java.awt.geom.CubicCurve2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Dimension2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Dimension2D
的使用

使用 Dimension2D 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

java.awt 中 Dimension2D 的使用

java.awt 中 Dimension2D 的子类
 class Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。

java.awt.geom 中 Dimension2D 的使用

参数类型为 Dimension2D 的 java.awt.geom 中的方法
void | Arc2D.setArc(Point2D loc, Dimension2D size, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定值。
void | RectangularShape.setFrame(Point2D loc, Dimension2D size) 将此 Shape 窗体矩形的位置和大小分别设置为指定的 Point2D 和 Dimension2D。
void | Dimension2D.setSize(Dimension2D d) 将 Dimension2D 对象的大小设置为指定大小。

javax.swing.plaf 中 Dimension2D 的使用

javax.swing.plaf 中 Dimension2D 的子类
 class DimensionUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Ellipse2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Ellipse2D
的使用

使用 Ellipse2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Ellipse2D 的使用

java.awt.geom 中 Ellipse2D 的子类
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Ellipse2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Ellipse2D.Double
的使用

没有 java.awt.geom.Ellipse2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Ellipse2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Ellipse2D.Float
的使用

没有 java.awt.geom.Ellipse2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.FlatteningPathIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.FlatteningPathIterator
的使用

没有 java.awt.geom.FlatteningPathIterator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.GeneralPath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.GeneralPath
的使用

没有 java.awt.geom.GeneralPath 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.IllegalPathStateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.IllegalPathStateException
的使用

没有 java.awt.geom.IllegalPathStateException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Line2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Line2D
的使用

使用 Line2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Line2D 的使用

java.awt.geom 中 Line2D 的子类
static class | Line2D.Double 使用 double 坐标指定的线段。
static class | Line2D.Float 使用 float 坐标指定的线段。

参数类型为 Line2D 的 java.awt.geom 中的方法
boolean | Line2D.intersectsLine(Line2D l) 测试指定的线段是否与此线段相交。
boolean | Rectangle2D.intersectsLine(Line2D l) 测试指定的线段是否与此 Rectangle2D 的内部相交。
void | Line2D.setLine(Line2D l) 将此 Line2D 端点的位置设置为与指定 Line2D 的这些端点相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Line2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Line2D.Double
的使用

没有 java.awt.geom.Line2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Line2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Line2D.Float
的使用

没有 java.awt.geom.Line2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.NoninvertibleTransformException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.NoninvertibleTransformException
的使用

使用 NoninvertibleTransformException 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 NoninvertibleTransformException 的使用

抛出 NoninvertibleTransformException 的 java.awt.geom 中的方法
AffineTransform | AffineTransform.createInverse() 返回表示逆向变换的 AffineTransform 对象。
void | AffineTransform.inverseTransform(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts) 通过此变换来逆向变换双精度坐标数组。
Point2D | AffineTransform.inverseTransform(Point2D ptSrc, Point2D ptDst) 逆向变换指定的 ptSrc 并将结果存储在 ptDst 中。
void | AffineTransform.invert() 将此变换设置为它自身的逆变换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Path2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Path2D
的使用

使用 Path2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Path2D 的使用

java.awt.geom 中 Path2D 的子类
class | GeneralPath GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
static class | Path2D.Double Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
static class | Path2D.Float Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Path2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Path2D.Double
的使用

没有 java.awt.geom.Path2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Path2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Path2D.Float
的使用

使用 Path2D.Float 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Path2D.Float 的使用

java.awt.geom 中 Path2D.Float 的子类
 class GeneralPath
GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.geom.PathIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.geom.PathIterator
的使用

使用 PathIterator 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt 中 PathIterator 的使用

返回 PathIterator 的 java.awt 中的方法
PathIterator | Polygon.getPathIterator(AffineTransform at) 返回迭代器对象，此对象沿此 Polygon 的边界进行迭代，并且提供对此 Polygon 轮廓的几何形状的访问。
PathIterator | Shape.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | Polygon.getPathIterator(AffineTransform at, double flatness) 返回迭代器对象，此对象沿 Shape 的边界进行迭代，并且提供了对 Shape 轮廓的几何形状的访问。
PathIterator | Shape.getPathIterator(AffineTransform at, double flatness) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。

java.awt.geom 中 PathIterator 的使用

实现 PathIterator 的 java.awt.geom 中的类
 class FlatteningPathIterator
FlatteningPathIterator 类返回另一个 PathIterator 对象的变平视图。

返回 PathIterator 的 java.awt.geom 中的方法
PathIterator | Arc2D.getPathIterator(AffineTransform at) 返回定义弧边界的迭代对象。
PathIterator | Area.getPathIterator(AffineTransform at) 为此 Area 对象的轮廓创建一个 PathIterator。
PathIterator | CubicCurve2D.getPathIterator(AffineTransform at) 返回定义形状边界的迭代对象。
PathIterator | Ellipse2D.getPathIterator(AffineTransform at) 返回定义此 Ellipse2D 边界的迭代对象。
PathIterator | Line2D.getPathIterator(AffineTransform at) 返回定义此 Line2D 边界的迭代对象。
PathIterator | Path2D.Float.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | Path2D.Double.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | QuadCurve2D.getPathIterator(AffineTransform at) 返回定义此 QuadCurve2D 的形状边界的迭代对象。
PathIterator | RoundRectangle2D.getPathIterator(AffineTransform at) 返回定义此 RoundRectangle2D 边界的迭代对象。
PathIterator | Rectangle2D.getPathIterator(AffineTransform at) 返回定义此 Rectangle2D 边界的迭代对象。
PathIterator | Area.getPathIterator(AffineTransform at, double flatness) 为此 Area 对象的变平轮廓创建 PathIterator。
PathIterator | CubicCurve2D.getPathIterator(AffineTransform at, double flatness) 返回定义变平形状边界的迭代对象。
PathIterator | Line2D.getPathIterator(AffineTransform at, double flatness) 返回定义此变平的 Line2D 边界的迭代对象。
PathIterator | Path2D.getPathIterator(AffineTransform at, double flatness) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
PathIterator | QuadCurve2D.getPathIterator(AffineTransform at, double flatness) 返回定义此 QuadCurve2D 的变平形状边界的迭代对象。
PathIterator | Rectangle2D.getPathIterator(AffineTransform at, double flatness) 返回定义变平的 Rectangle2D 边界的迭代对象。
PathIterator | RectangularShape.getPathIterator(AffineTransform at, double flatness) 返回一个迭代器对象，它可沿 Shape 对象的边界进行迭代，并提供对 Shape 对象轮廓几何形状平面视图的访问。

参数类型为 PathIterator 的 java.awt.geom 中的方法
abstract void | Path2D.append(PathIterator pi, boolean connect) 将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
void | Path2D.Float.append(PathIterator pi, boolean connect) 将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
void | Path2D.Double.append(PathIterator pi, boolean connect) 将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
static boolean | Path2D.contains(PathIterator pi, double x, double y) 测试指定的坐标是否在指定 PathIterator 的封闭边界内。
static boolean | Path2D.contains(PathIterator pi, double x, double y, double w, double h) 测试指定矩形区域是否完全在指定 PathIterator 的封闭边界内。
static boolean | Path2D.contains(PathIterator pi, Point2D p) 测试指定的 Point2D 是否在指定 PathIterator 的封闭边界内。
static boolean | Path2D.contains(PathIterator pi, Rectangle2D r) 测试指定的 Rectangle2D 是否完全在指定 PathIterator 的封闭区域内。
static boolean | Path2D.intersects(PathIterator pi, double x, double y, double w, double h) 测试指定 PathIterator 的内部是否与指定直角坐标集的内部相交。
static boolean | Path2D.intersects(PathIterator pi, Rectangle2D r) 测试指定 PathIterator 的内部是否与指定 Rectangle2D 的内部相交。

参数类型为 PathIterator 的 java.awt.geom 中的构造方法
FlatteningPathIterator(PathIterator src, double flatness)
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。
FlatteningPathIterator(PathIterator src, double flatness, int limit)
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Point2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Point2D
的使用

使用 Point2D 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 Point2D 的使用

java.awt 中 Point2D 的子类
 class Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。

返回 Point2D 的 java.awt 中的方法
Point2D | RadialGradientPaint.getCenterPoint() 返回辐射状渐变中心点的副本。
Point2D | LinearGradientPaint.getEndPoint() 返回渐变轴结束点的副本。
Point2D | RadialGradientPaint.getFocusPoint() 返回渐变轴结束点的副本。
Point2D | GradientPaint.getPoint1() 返回着第一种颜色的点 P1 的副本。
Point2D | GradientPaint.getPoint2() 返回着第二种颜色的点 P2 的副本。
Point2D | LinearGradientPaint.getStartPoint() 返回渐变轴起始点的副本。

参数类型为 Point2D 的 java.awt 中的方法
boolean | Polygon.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | Shape.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。

参数类型为 Point2D 的 java.awt 中的构造方法
GradientPaint(Point2D pt1, Color color1, Point2D pt2, Color color2)
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(Point2D pt1, Color color1, Point2D pt2, Color color2, boolean cyclic)
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors)
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors)
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。

java.awt.font 中 Point2D 的使用

返回 Point2D 的 java.awt.font 中的方法
abstract  Point2D GlyphVector.getGlyphPosition(int glyphIndex)
返回与此 GlyphVector 原点对应的指定字形的位置。

参数类型为 Point2D 的 java.awt.font 中的方法
void | TextLayout.hitToPoint(TextHitInfo hit, Point2D point) 将一个命中点转换为标准坐标中的一个点。
abstract void | LayoutPath.pathToPoint(Point2D location, boolean preceding, Point2D point) 将相对于路径的位置转换为用户坐标中的点。
abstract boolean | LayoutPath.pointToPath(Point2D point, Point2D location) 将用户空间中的点转换为相对于路径的位置。
abstract void | GlyphVector.setGlyphPosition(int glyphIndex, Point2D newPos) 设置此 GlyphVector 中的指定字形位置。

java.awt.geom 中 Point2D 的使用

java.awt.geom 中 Point2D 的子类
static class | Point2D.Double Double 类以 double 精度定义指定的点。
static class | Point2D.Float Float 类以 float 精度定义指定的点。

返回 Point2D 的 java.awt.geom 中的方法
Point2D | AffineTransform.deltaTransform(Point2D ptSrc, Point2D ptDst) 变换由 ptSrc 指定的相对距离向量，并将结果存储在 ptDst 中。
abstract Point2D | CubicCurve2D.getCtrlP1() 返回第一个控制点。
Point2D | CubicCurve2D.Float.getCtrlP1() 返回第一个控制点。
Point2D | CubicCurve2D.Double.getCtrlP1() 返回第一个控制点。
abstract Point2D | CubicCurve2D.getCtrlP2() 返回第二个控制点。
Point2D | CubicCurve2D.Float.getCtrlP2() 返回第二个控制点。
Point2D | CubicCurve2D.Double.getCtrlP2() 返回第二个控制点。
abstract Point2D | QuadCurve2D.getCtrlPt() 返回控制点。
Point2D | QuadCurve2D.Float.getCtrlPt() 返回控制点。
Point2D | QuadCurve2D.Double.getCtrlPt() 返回控制点。
Point2D | Path2D.getCurrentPoint() 返回最近添加到路径尾部的坐标（以 Point2D 对象形式）。
Point2D | Arc2D.getEndPoint() 返回弧的结束点。
abstract Point2D | CubicCurve2D.getP1() 返回起始点。
Point2D | CubicCurve2D.Float.getP1() 返回起始点。
Point2D | CubicCurve2D.Double.getP1() 返回起始点。
abstract Point2D | Line2D.getP1() 返回此 Line2D 的起始 Point2D。
Point2D | Line2D.Float.getP1() 返回此 Line2D 的起始 Point2D。
Point2D | Line2D.Double.getP1() 返回此 Line2D 的起始 Point2D。
abstract Point2D | QuadCurve2D.getP1() 返回起始点。
Point2D | QuadCurve2D.Float.getP1() 返回起始点。
Point2D | QuadCurve2D.Double.getP1() 返回起始点。
abstract Point2D | CubicCurve2D.getP2() 返回结束点。
Point2D | CubicCurve2D.Float.getP2() 返回结束点。
Point2D | CubicCurve2D.Double.getP2() 返回结束点。
abstract Point2D | Line2D.getP2() 返回此 Line2D 的结束 Point2D。
Point2D | Line2D.Float.getP2() 返回此 Line2D 的结束 Point2D。
Point2D | Line2D.Double.getP2() 返回此 Line2D 的结束 Point2D。
abstract Point2D | QuadCurve2D.getP2() 返回结束点。
Point2D | QuadCurve2D.Float.getP2() 返回结束点。
Point2D | QuadCurve2D.Double.getP2() 返回结束点。
Point2D | Arc2D.getStartPoint() 返回弧的起始点。
Point2D | AffineTransform.inverseTransform(Point2D ptSrc, Point2D ptDst) 逆向变换指定的 ptSrc 并将结果存储在 ptDst 中。
Point2D | AffineTransform.transform(Point2D ptSrc, Point2D ptDst) 变换指定的 ptSrc 并将结果存储在 ptDst 中。

参数类型为 Point2D 的 java.awt.geom 中的方法
void | Rectangle2D.add(Point2D pt) 将 Point2D 对象 pt 添加到此 Rectangle2D 中。
static boolean | Path2D.contains(PathIterator pi, Point2D p) 测试指定的 Point2D 是否在指定 PathIterator 的封闭边界内。
boolean | Area.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | CubicCurve2D.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | Line2D.contains(Point2D p) 测试给定 Point2D 是否在此 Line2D 的边界内。
boolean | Path2D.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | QuadCurve2D.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | RectangularShape.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
Point2D | AffineTransform.deltaTransform(Point2D ptSrc, Point2D ptDst) 变换由 ptSrc 指定的相对距离向量，并将结果存储在 ptDst 中。
double | Point2D.distance(Point2D pt) 返回从此 Point2D 到指定 Point2D 的距离。
double | Point2D.distanceSq(Point2D pt) 返回从此 Point2D 到指定 Point2D 的距离的平方。
Point2D | AffineTransform.inverseTransform(Point2D ptSrc, Point2D ptDst) 逆向变换指定的 ptSrc 并将结果存储在 ptDst 中。
int | Rectangle2D.outcode(Point2D p) 确定指定 Point2D 相对于此 Rectangle2D 的位置。
double | Line2D.ptLineDist(Point2D pt) 返回从 Point2D 到此线的距离。
double | Line2D.ptLineDistSq(Point2D pt) 返回从指定 Point2D 到此线的距离的平方。
double | Line2D.ptSegDist(Point2D pt) 返回从 Point2D 到此线段的距离的平方。
double | Line2D.ptSegDistSq(Point2D pt) 返回从 Point2D 到此线段的距离的平方。
int | Line2D.relativeCCW(Point2D p) 返回一个指示符，指示指定 Point2D 相对于此线段的位置。
void | Arc2D.setAngles(Point2D p1, Point2D p2) 使用两个点设置此弧的起始角度和角跨越。
void | Arc2D.setAngleStart(Point2D p) 将此弧的起始角度设置为由指定点定义、相对于此弧中心的角度。
void | Arc2D.setArc(Point2D loc, Dimension2D size, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定值。
void | Arc2D.setArcByTangent(Point2D p1, Point2D p2, Point2D p3, double radius) 将此弧的位置、边界和角跨越设置为指定值。
void | CubicCurve2D.setCurve(Point2D[] pts, int offset) 将此曲线端点和控制点的位置设置为指定数组中指定偏移量的 Point2D 对象的坐标。
void | QuadCurve2D.setCurve(Point2D[] pts, int offset) 将此 QuadCurve2D 端点和控制点的位置设置为指定数组中指定偏移量处 Point2D 对象的坐标。
void | QuadCurve2D.setCurve(Point2D p1, Point2D cp, Point2D p2) 将此 QuadCurve2D 端点和控制点的位置设置为指定的 Point2D 坐标。
void | CubicCurve2D.setCurve(Point2D p1, Point2D cp1, Point2D cp2, Point2D p2) 将此曲线端点和控制点的位置设置为指定的 Point2D 坐标。
void | RectangularShape.setFrame(Point2D loc, Dimension2D size) 将此 Shape 窗体矩形的位置和大小分别设置为指定的 Point2D 和 Dimension2D。
void | RectangularShape.setFrameFromCenter(Point2D center, Point2D corner) 基于指定的中心 Point2D 和角 Point2D 设置此 Shape 的窗体矩形。
void | RectangularShape.setFrameFromDiagonal(Point2D p1, Point2D p2) 基于两个指定的 Point2D 对象设置此 Shape 窗体矩形的对角线。
void | Line2D.setLine(Point2D p1, Point2D p2) 将此 Line2D 端点的位置设置为指定的 Point2D 坐标。
void | Point2D.setLocation(Point2D p) 将此 Point2D 的位置设为指定 Point2D 对象的坐标。
void | AffineTransform.transform(Point2D[] ptSrc, int srcOff, Point2D[] ptDst, int dstOff, int numPts) 通过此变换来变换点对象数组。
void | AffineTransform.transform(Point2D[] ptSrc, int srcOff, Point2D[] ptDst, int dstOff, int numPts) 通过此变换来变换点对象数组。
Point2D | AffineTransform.transform(Point2D ptSrc, Point2D ptDst) 变换指定的 ptSrc 并将结果存储在 ptDst 中。

参数类型为 Point2D 的 java.awt.geom 中的构造方法
Line2D.Double(Point2D p1, Point2D p2)
根据指定的 Point2D 对象构造并初始化 Line2D。
Line2D.Float(Point2D p1, Point2D p2)
根据指定的 Point2D 对象构造并初始化 Line2D。

java.awt.image 中 Point2D 的使用

返回 Point2D 的 java.awt.image 中的方法
Point2D | AffineTransformOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源图像中给定点对应的目标点的位置。
Point2D | BandCombineOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源 Raster 中给定点对应的目标点的位置。
Point2D | BufferedImageOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源图像中给定点对应的目标点的位置。
Point2D | ColorConvertOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回源中给定点的目标点的位置。
Point2D | ConvolveOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回源中给定点的目标点位置。
Point2D | LookupOp.getPoint2D(Point2D srcPt, Point2D dstPt) 在给定源图像中某个点的情况下，返回目标点的位置。
Point2D | RasterOp.getPoint2D(Point2D srcPt, Point2D dstPt) 在给定源 Raster 中一个点的情况下，返回目标点的位置。
Point2D | RescaleOp.getPoint2D(Point2D srcPt, Point2D dstPt) 给定源中的一个点，返回对应目标点的位置。

参数类型为 Point2D 的 java.awt.image 中的方法
Point2D | AffineTransformOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源图像中给定点对应的目标点的位置。
Point2D | BandCombineOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源 Raster 中给定点对应的目标点的位置。
Point2D | BufferedImageOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源图像中给定点对应的目标点的位置。
Point2D | ColorConvertOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回源中给定点的目标点的位置。
Point2D | ConvolveOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回源中给定点的目标点位置。
Point2D | LookupOp.getPoint2D(Point2D srcPt, Point2D dstPt) 在给定源图像中某个点的情况下，返回目标点的位置。
Point2D | RasterOp.getPoint2D(Point2D srcPt, Point2D dstPt) 在给定源 Raster 中一个点的情况下，返回目标点的位置。
Point2D | RescaleOp.getPoint2D(Point2D srcPt, Point2D dstPt) 给定源中的一个点，返回对应目标点的位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Point2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Point2D.Double
的使用

没有 java.awt.geom.Point2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Point2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Point2D.Float
的使用

没有 java.awt.geom.Point2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.QuadCurve2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.QuadCurve2D
的使用

使用 QuadCurve2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 QuadCurve2D 的使用

java.awt.geom 中 QuadCurve2D 的子类
static class | QuadCurve2D.Double 使用 double 坐标指定的二次参数曲线段。
static class | QuadCurve2D.Float 使用 float 坐标指定的二次参数曲线段。

参数类型为 QuadCurve2D 的 java.awt.geom 中的方法
void | QuadCurve2D.setCurve(QuadCurve2D c) 将此 QuadCurve2D 端点和控制点的位置设置为与指定的 QuadCurve2D 相同。
void | QuadCurve2D.subdivide(QuadCurve2D left, QuadCurve2D right) 细分此 QuadCurve2D 并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
static void | QuadCurve2D.subdivide(QuadCurve2D src, QuadCurve2D left, QuadCurve2D right) 细分由 src 参数指定的二次曲线并将得到的两个细分曲线存储到 left 和 right 曲线参数中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.QuadCurve2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.QuadCurve2D.Double
的使用

没有 java.awt.geom.QuadCurve2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.QuadCurve2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.QuadCurve2D.Float
的使用

没有 java.awt.geom.QuadCurve2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Rectangle2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Rectangle2D
的使用

使用 Rectangle2D 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Rectangle2D 的使用

java.awt 中 Rectangle2D 的子类
 class Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

返回 Rectangle2D 的 java.awt 中的方法
Rectangle2D | Rectangle.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | TexturePaint.getAnchorRect() 返回定位纹理图像并设置其大小的固定矩形的副本。
Rectangle2D | Polygon.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Rectangle.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Shape.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Font.getMaxCharBounds(FontRenderContext frc) 返回最大边界定义在 FontRenderContext 中的字符的边界。
Rectangle2D | FontMetrics.getMaxCharBounds(Graphics context) 返回指定 Graphics 上下文中具有最大边界的字符的边界。
Rectangle2D | Font.getStringBounds(char[] chars, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 指定字符数组的逻辑边界。
Rectangle2D | FontMetrics.getStringBounds(char[] chars, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定字符数组的边界。
Rectangle2D | Font.getStringBounds(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的逻辑边界。
Rectangle2D | FontMetrics.getStringBounds(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回用指定 Graphics 上下文中指定 CharacterIterator 进行索引的字符的边界。
Rectangle2D | Font.getStringBounds(String str, FontRenderContext frc) 返回指定 FontRenderContext 中指定 String 的逻辑边界。
Rectangle2D | FontMetrics.getStringBounds(String str, Graphics context) 返回指定 Graphics 上下文中指定 String 的边界。
Rectangle2D | Font.getStringBounds(String str, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中指定 String 的逻辑边界。
Rectangle2D | FontMetrics.getStringBounds(String str, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 String 的边界。

参数类型为 Rectangle2D 的 java.awt 中的方法
boolean | Polygon.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
boolean | Shape.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
Rectangle2D | Rectangle.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
boolean | Polygon.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | Shape.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。

参数类型为 Rectangle2D 的 java.awt 中的构造方法
RadialGradientPaint(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
TexturePaint(BufferedImage txtr, Rectangle2D anchor)
构造 TexturePaint 对象。

java.awt.font 中 Rectangle2D 的使用

返回 Rectangle2D 的 java.awt.font 中的方法
Rectangle2D | GraphicAttribute.getBounds() 返回包括所有位的 Rectangle2D，这些位由与呈现位置相关的 GraphicAttribute 绘制。
Rectangle2D | ImageGraphicAttribute.getBounds() 返回一个 Rectangle2D，它封装此 ImageGraphicAttribute 相对于呈现位置呈现的所有位。
Rectangle2D | ShapeGraphicAttribute.getBounds() 返回一个 Rectangle2D，它封装此 ShapeGraphicAttribute 相对于呈现位置绘制的所有位。
Rectangle2D | TextLayout.getBounds() 返回此 TextLayout 的边界。
Rectangle2D | GlyphMetrics.getBounds2D() 返回该字形的边界。
abstract Rectangle2D | GlyphVector.getLogicalBounds() 返回此 GlyphVector 的逻辑边界。
abstract Rectangle2D | GlyphVector.getVisualBounds() 返回此 GlyphVector 的可视边界，可视边界是此 GlyphVector 轮廓的边界框。

参数类型为 Rectangle2D 的 java.awt.font 中的方法
float[] | TextLayout.getCaretInfo(TextHitInfo hit, Rectangle2D bounds) 返回与对应于 hit 的插入符有关的信息。
Shape | TextLayout.getCaretShape(TextHitInfo hit, Rectangle2D bounds) 返回表示指定边界内指定目标字符处插入符的 Shape。
Shape[] | TextLayout.getCaretShapes(int offset, Rectangle2D bounds) 返回对应于强插入符和弱插入符的两条路径。
Shape[] | TextLayout.getCaretShapes(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy) 返回对应于强插入符和弱插入符的两条路径。
Shape | TextLayout.getLogicalHighlightShape(int firstEndpoint, int secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到指定 bounds 的逻辑选择范围的 Shape。
Shape | TextLayout.getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到 bounds 的可视选择范围的路径。
TextHitInfo | TextLayout.hitTestChar(float x, float y, Rectangle2D bounds) 返回对应于指定点的 TextHitInfo。

参数类型为 Rectangle2D 的 java.awt.font 中的构造方法
GlyphMetrics(boolean horizontal, float advanceX, float advanceY, Rectangle2D bounds, byte glyphType)
构造一个 GlyphMetrics 对象。
GlyphMetrics(float advance, Rectangle2D bounds, byte glyphType)
构造一个 GlyphMetrics 对象。

java.awt.geom 中 Rectangle2D 的使用

java.awt.geom 中 Rectangle2D 的子类
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。

返回 Rectangle2D 的 java.awt.geom 中的方法
abstract Rectangle2D | Rectangle2D.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle2D.Float.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle2D.Double.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
abstract Rectangle2D | Rectangle2D.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | Rectangle2D.Float.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | Rectangle2D.Double.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | Arc2D.getBounds2D() 返回弧的高精度窗体矩形。
Rectangle2D | Area.getBounds2D() 返回完全包围此 Area 的高精度边界 Rectangle2D。
Rectangle2D | CubicCurve2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | CubicCurve2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Ellipse2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Ellipse2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Line2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Line2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Path2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Path2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | QuadCurve2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | QuadCurve2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | RoundRectangle2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | RoundRectangle2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Rectangle2D.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Rectangle2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Rectangle2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | RectangularShape.getFrame() 返回定义此对象的总体形状的窗体 Rectangle2D。
protected abstract Rectangle2D | Arc2D.makeBounds(double x, double y, double w, double h) 构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
protected Rectangle2D | Arc2D.Float.makeBounds(double x, double y, double w, double h) 构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
protected Rectangle2D | Arc2D.Double.makeBounds(double x, double y, double w, double h) 构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。

参数类型为 Rectangle2D 的 java.awt.geom 中的方法
void | Rectangle2D.add(Rectangle2D r) 将 Rectangle2D 对象添加到此 Rectangle2D 中。
static boolean | Path2D.contains(PathIterator pi, Rectangle2D r) 测试指定的 Rectangle2D 是否完全在指定 PathIterator 的封闭区域内。
boolean | Arc2D.contains(Rectangle2D r) 确定弧的内部是否完全包含指定的矩形。
boolean | Area.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
boolean | CubicCurve2D.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
boolean | Line2D.contains(Rectangle2D r) 测试此 Line2D 内部是否完全包含指定的 Rectangle2D。
boolean | Path2D.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
boolean | QuadCurve2D.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
boolean | RectangularShape.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
abstract Rectangle2D | Rectangle2D.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle2D.Float.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle2D.Double.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
abstract Rectangle2D | Rectangle2D.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | Rectangle2D.Float.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | Rectangle2D.Double.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
static void | Rectangle2D.intersect(Rectangle2D src1, Rectangle2D src2, Rectangle2D dest) 将指定的一对源 Rectangle2D 对象相交，并将结果置于指定的目标 Rectangle2D 对象中。
static boolean | Path2D.intersects(PathIterator pi, Rectangle2D r) 测试指定 PathIterator 的内部是否与指定 Rectangle2D 的内部相交。
boolean | Area.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | CubicCurve2D.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | Line2D.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | Path2D.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | QuadCurve2D.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | RectangularShape.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
void | Arc2D.setArc(Rectangle2D rect, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定值。
void | RectangularShape.setFrame(Rectangle2D r) 将此 Shape 窗体矩形设置为指定的 Rectangle2D。
void | Rectangle2D.setRect(Rectangle2D r) 将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
void | Rectangle2D.Float.setRect(Rectangle2D r) 将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
void | Rectangle2D.Double.setRect(Rectangle2D r) 将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
static void | Rectangle2D.union(Rectangle2D src1, Rectangle2D src2, Rectangle2D dest) 将一对源 Rectangle2D 对象合并，并将结果置于指定的目标 Rectangle2D 对象中。

参数类型为 Rectangle2D 的 java.awt.geom 中的构造方法
Arc2D.Double(Rectangle2D ellipseBounds, double start, double extent, int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
Arc2D.Float(Rectangle2D ellipseBounds, float start, float extent, int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。

java.awt.image 中 Rectangle2D 的使用

返回 Rectangle2D 的 java.awt.image 中的方法
Rectangle2D | AffineTransformOp.getBounds2D(BufferedImage src) 返回转换后的目标图像的边界框。
Rectangle2D | BufferedImageOp.getBounds2D(BufferedImage src) 返回已过滤目标图像的边界框。
Rectangle2D | ColorConvertOp.getBounds2D(BufferedImage src) 返回给定源的目标边界框。
Rectangle2D | ConvolveOp.getBounds2D(BufferedImage src) 返回已过滤目标图像的边界框。
Rectangle2D | LookupOp.getBounds2D(BufferedImage src) 返回过滤后的目标图像的边界框。
Rectangle2D | RescaleOp.getBounds2D(BufferedImage src) 返回重缩放后的目标图像的边界框。
Rectangle2D | AffineTransformOp.getBounds2D(Raster src) 返回转换后的目标图像的边界框。
Rectangle2D | BandCombineOp.getBounds2D(Raster src) 返回变换后目标图像的边界框。
Rectangle2D | ColorConvertOp.getBounds2D(Raster src) 返回给定源的目标边界框。
Rectangle2D | ConvolveOp.getBounds2D(Raster src) 返回已过滤目标 Raster 的边界框。
Rectangle2D | LookupOp.getBounds2D(Raster src) 返回过滤后目标 Raster 的边界框。
Rectangle2D | RasterOp.getBounds2D(Raster src) 返回过滤后目标 Raster 的边界框。
Rectangle2D | RescaleOp.getBounds2D(Raster src) 返回重缩放后的目标 Raster 的边界框。

java.awt.image.renderable 中 Rectangle2D 的使用

返回 Rectangle2D 的 java.awt.image.renderable 中的方法
 Rectangle2D ContextualRenderedImageFactory.getBounds2D(ParameterBlock paramBlock)
返回操作的输出的边界框，该操作在与呈现无关的空间中给定的一组源上执行。

javax.swing.plaf.basic 中 Rectangle2D 的使用

javax.swing.plaf.basic 中 Rectangle2D 的子类
static class BasicTextUI.BasicCaret

javax.swing.text 中 Rectangle2D 的使用

javax.swing.text 中 Rectangle2D 的子类
 class DefaultCaret
插入符的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Rectangle2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Rectangle2D.Double
的使用

没有 java.awt.geom.Rectangle2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.Rectangle2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Rectangle2D.Float
的使用

没有 java.awt.geom.Rectangle2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.RectangularShape 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.RectangularShape
的使用

使用 RectangularShape 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 RectangularShape 的使用

java.awt 中 RectangularShape 的子类
 class Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

java.awt.geom 中 RectangularShape 的使用

java.awt.geom 中 RectangularShape 的子类
class | Arc2D Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。
class | Ellipse2D Ellipse2D 类描述窗体矩形定义的椭圆。
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。
class | Rectangle2D Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。
class | RoundRectangle2D RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

javax.swing.plaf.basic 中 RectangularShape 的使用

javax.swing.plaf.basic 中 RectangularShape 的子类
static class BasicTextUI.BasicCaret

javax.swing.text 中 RectangularShape 的使用

javax.swing.text 中 RectangularShape 的子类
 class DefaultCaret
插入符的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.RoundRectangle2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.RoundRectangle2D
的使用

使用 RoundRectangle2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 RoundRectangle2D 的使用

java.awt.geom 中 RoundRectangle2D 的子类
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

参数类型为 RoundRectangle2D 的 java.awt.geom 中的方法
void | RoundRectangle2D.setRoundRect(RoundRectangle2D rr) 将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
void | RoundRectangle2D.Float.setRoundRect(RoundRectangle2D rr) 将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
void | RoundRectangle2D.Double.setRoundRect(RoundRectangle2D rr) 将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.RoundRectangle2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.RoundRectangle2D.Double
的使用

没有 java.awt.geom.RoundRectangle2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.geom.RoundRectangle2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.RoundRectangle2D.Float
的使用

没有 java.awt.geom.RoundRectangle2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.awt.im (Java 2 Platform SE 6)

 java.awt.im
接口
InputMethodRequests
类
InputContext
InputMethodHighlight
InputSubset


类 java.awt.im.InputContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.im.InputContext
的使用

使用 InputContext 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im | 提供输入方法框架所需的类和接口。

java.awt 中 InputContext 的使用

返回 InputContext 的 java.awt 中的方法
InputContext | Window.getInputContext() 获取此窗口的输入上下文。
InputContext | Component.getInputContext() 获取此组件使用的输入上下文，用于处理在此组件中输入文本时与输入方法的通信。

java.awt.im 中 InputContext 的使用

返回 InputContext 的 java.awt.im 中的方法
static InputContext InputContext.getInstance()
返回新 InputContext 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.im.InputMethodHighlight 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.im.InputMethodHighlight
的使用

使用 InputMethodHighlight 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im | 提供输入方法框架所需的类和接口。

java.awt 中 InputMethodHighlight 的使用

参数类型为 InputMethodHighlight 的 java.awt 中的方法
abstract  Map<TextAttribute,?> Toolkit.mapInputMethodHighlight(InputMethodHighlight highlight)
返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。

java.awt.im 中 InputMethodHighlight 的使用

声明为 InputMethodHighlight 的 java.awt.im 中的字段
static InputMethodHighlight | InputMethodHighlight.SELECTED_CONVERTED_TEXT_HIGHLIGHT 已选定已转换文本的默认高亮显示常量。
static InputMethodHighlight | InputMethodHighlight.SELECTED_RAW_TEXT_HIGHLIGHT 已选定原文本的默认高亮显示常量。
static InputMethodHighlight | InputMethodHighlight.UNSELECTED_CONVERTED_TEXT_HIGHLIGHT 未选定已转换文本的默认高亮显示常量。
static InputMethodHighlight | InputMethodHighlight.UNSELECTED_RAW_TEXT_HIGHLIGHT 未选定原文本的默认高亮显示常量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.im.InputMethodRequests 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.im.InputMethodRequests
的使用

使用 InputMethodRequests 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 InputMethodRequests 的使用

返回 InputMethodRequests 的 java.awt 中的方法
InputMethodRequests | TextComponent.getInputMethodRequests()
InputMethodRequests | Component.getInputMethodRequests() 获取输入方法请求处理程序，该处理程序支持此组件输入方法发出的请求。

java.awt.im.spi 中 InputMethodRequests 的使用

java.awt.im.spi 中 InputMethodRequests 的子接口
 interface InputMethodContext
提供输入方法可以用来与其客户端组件通信或用来请求其他服务的方法。

javax.swing.text 中 InputMethodRequests 的使用

返回 InputMethodRequests 的 javax.swing.text 中的方法
 InputMethodRequests JTextComponent.getInputMethodRequests()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.im.InputSubset 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.im.InputSubset
的使用

使用 InputSubset 的软件包
java.awt.im 提供输入方法框架所需的类和接口。

java.awt.im 中 InputSubset 的使用

声明为 InputSubset 的 java.awt.im 中的字段
static InputSubset | InputSubset.FULLWIDTH_DIGITS Unicode 半角和全角字符块中包括的全角数字常量。
static InputSubset | InputSubset.FULLWIDTH_LATIN Unicode 半角和全角字符块的全角 ASCII 变体子集常量。
static InputSubset | InputSubset.HALFWIDTH_KATAKANA Unicode 半角和全角字符块的半角片假名子集常量。
static InputSubset | InputSubset.HANJA 编写韩语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项的韩语汉字字集。
static InputSubset | InputSubset.KANJI 编写日语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的日语汉字字集。
static InputSubset | InputSubset.LATIN 所有拉丁字符常量，包括 BASIC_LATIN、LATIN_1_SUPPLEMENT、LATIN_EXTENDED_A、LATIN_EXTENDED_B Unicode 字符块中的字符。
static InputSubset | InputSubset.LATIN_DIGITS BASIC_LATIN Unicode 字符块中包括的数字常量。
static InputSubset | InputSubset.SIMPLIFIED_HANZI 编写简体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的简体中文汉字字集。
static InputSubset | InputSubset.TRADITIONAL_HANZI 编写繁体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的繁体中文汉字字集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.awt.im.spi (Java 2 Platform SE 6)

 java.awt.im.spi
接口
InputMethod
InputMethodContext
InputMethodDescriptor


接口 java.awt.im.spi.InputMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.im.spi.InputMethod
的使用

使用 InputMethod 的软件包
java.awt.im.spi 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.im.spi 中 InputMethod 的使用

返回 InputMethod 的 java.awt.im.spi 中的方法
 InputMethod InputMethodDescriptor.createInputMethod()
创建相应输入方法的新实例。

参数类型为 InputMethod 的 java.awt.im.spi 中的方法
 void InputMethodContext.enableClientWindowNotification(InputMethod inputMethod, boolean enable)
启用或禁用指定输入方法的当前客户端窗口位置或状态的通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.im.spi.InputMethodContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.im.spi.InputMethodContext
的使用

使用 InputMethodContext 的软件包
java.awt.im.spi 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.im.spi 中 InputMethodContext 的使用

参数类型为 InputMethodContext 的 java.awt.im.spi 中的方法
 void InputMethod.setInputMethodContext(InputMethodContext context)
设置输入方法的上下文，这样可以将输入方法事件指派到客户端组件并能从客户端组件请求信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.im.spi.InputMethodDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.im.spi.InputMethodDescriptor
的使用

没有 java.awt.im.spi.InputMethodDescriptor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.awt.image (Java 2 Platform SE 6)

 java.awt.image
接口
BufferedImageOp
ImageConsumer
ImageObserver
ImageProducer
RasterOp
RenderedImage
TileObserver
WritableRenderedImage
类
AffineTransformOp
AreaAveragingScaleFilter
BandCombineOp
BandedSampleModel
BufferedImage
BufferedImageFilter
BufferStrategy
ByteLookupTable
ColorConvertOp
ColorModel
ComponentColorModel
ComponentSampleModel
ConvolveOp
CropImageFilter
DataBuffer
DataBufferByte
DataBufferDouble
DataBufferFloat
DataBufferInt
DataBufferShort
DataBufferUShort
DirectColorModel
FilteredImageSource
ImageFilter
IndexColorModel
Kernel
LookupOp
LookupTable
MemoryImageSource
MultiPixelPackedSampleModel
PackedColorModel
PixelGrabber
PixelInterleavedSampleModel
Raster
ReplicateScaleFilter
RescaleOp
RGBImageFilter
SampleModel
ShortLookupTable
SinglePixelPackedSampleModel
VolatileImage
WritableRaster
异常
ImagingOpException
RasterFormatException


类 java.awt.image.AffineTransformOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.AffineTransformOp
的使用

没有 java.awt.image.AffineTransformOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.AreaAveragingScaleFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.AreaAveragingScaleFilter
的使用

没有 java.awt.image.AreaAveragingScaleFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.BandCombineOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.BandCombineOp
的使用

没有 java.awt.image.BandCombineOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.BandedSampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.BandedSampleModel
的使用

没有 java.awt.image.BandedSampleModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.BufferedImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.BufferedImage
的使用

使用 BufferedImage 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。

java.awt 中 BufferedImage 的使用

返回 BufferedImage 的 java.awt 中的方法
abstract BufferedImage | GraphicsConfiguration.createCompatibleImage(int width, int height) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。
BufferedImage | GraphicsConfiguration.createCompatibleImage(int width, int height, int transparency) 返回一个支持指定透明度，并且数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。
BufferedImage | Robot.createScreenCapture(Rectangle screenRect) 创建包含从屏幕中读取的像素的图像。
BufferedImage | TexturePaint.getImage() 返回用于填充形状的 BufferedImage 纹理。

参数类型为 BufferedImage 的 java.awt 中的方法
abstract Graphics2D | GraphicsEnvironment.createGraphics(BufferedImage img) 返回一个呈现指定 BufferedImage 的 Graphics2D 对象。
abstract void | Graphics2D.drawImage(BufferedImage img, BufferedImageOp op, int x, int y) 呈现使用 BufferedImageOp 过滤的 BufferedImage。

参数类型为 BufferedImage 的 java.awt 中的构造方法
TexturePaint(BufferedImage txtr, Rectangle2D anchor)
构造 TexturePaint 对象。

java.awt.image 中 BufferedImage 的使用

返回 BufferedImage 的 java.awt.image 中的方法
BufferedImage | IndexColorModel.convertToIntDiscrete(Raster raster, boolean forceARGB) 返回一个 TYPE_INT_ARGB 或 TYPE_INT_RGB 的新 BufferedImage，其 Raster 的像素数据是通过使用此 ColorModel 的颜色/alpha 分量数组扩展源 Raster 中的各索引来计算的。
BufferedImage | AffineTransformOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | BufferedImageOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | ColorConvertOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建给定源的具有正确大小和 band 数量的归零目标图像。
BufferedImage | ConvolveOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建具有正确 band 大小和数量的归零目标图像。
BufferedImage | LookupOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一幅具有正确大小和 band 数的、经过检查的目标图像。
BufferedImage | RescaleOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经检查的目标图像。
BufferedImage | AffineTransformOp.filter(BufferedImage src, BufferedImage dst) 转换源 BufferedImage 并将结果存储在目标 BufferedImage 中。
BufferedImage | BufferedImageOp.filter(BufferedImage src, BufferedImage dest) 对 BufferedImage 执行单输入/单输出操作。
BufferedImage | ColorConvertOp.filter(BufferedImage src, BufferedImage dest) 对源 BufferedImage 进行颜色转换。
BufferedImage | ConvolveOp.filter(BufferedImage src, BufferedImage dst) 对 BufferedImage 执行卷积运算。
BufferedImage | LookupOp.filter(BufferedImage src, BufferedImage dst) 对 BufferedImage 执行查找操作。
BufferedImage | RescaleOp.filter(BufferedImage src, BufferedImage dst) 对源 BufferedImage 进行重缩放。
abstract BufferedImage | VolatileImage.getSnapshot() 返回此对象的静态快照图像。
BufferedImage | BufferedImage.getSubimage(int x, int y, int w, int h) 返回由指定矩形区域定义的子图像。

参数类型为 BufferedImage 的 java.awt.image 中的方法
BufferedImage | AffineTransformOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | BufferedImageOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | ColorConvertOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建给定源的具有正确大小和 band 数量的归零目标图像。
BufferedImage | ConvolveOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建具有正确 band 大小和数量的归零目标图像。
BufferedImage | LookupOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一幅具有正确大小和 band 数的、经过检查的目标图像。
BufferedImage | RescaleOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经检查的目标图像。
BufferedImage | AffineTransformOp.filter(BufferedImage src, BufferedImage dst) 转换源 BufferedImage 并将结果存储在目标 BufferedImage 中。
BufferedImage | BufferedImageOp.filter(BufferedImage src, BufferedImage dest) 对 BufferedImage 执行单输入/单输出操作。
BufferedImage | ColorConvertOp.filter(BufferedImage src, BufferedImage dest) 对源 BufferedImage 进行颜色转换。
BufferedImage | ConvolveOp.filter(BufferedImage src, BufferedImage dst) 对 BufferedImage 执行卷积运算。
BufferedImage | LookupOp.filter(BufferedImage src, BufferedImage dst) 对 BufferedImage 执行查找操作。
BufferedImage | RescaleOp.filter(BufferedImage src, BufferedImage dst) 对源 BufferedImage 进行重缩放。
Rectangle2D | AffineTransformOp.getBounds2D(BufferedImage src) 返回转换后的目标图像的边界框。
Rectangle2D | BufferedImageOp.getBounds2D(BufferedImage src) 返回已过滤目标图像的边界框。
Rectangle2D | ColorConvertOp.getBounds2D(BufferedImage src) 返回给定源的目标边界框。
Rectangle2D | ConvolveOp.getBounds2D(BufferedImage src) 返回已过滤目标图像的边界框。
Rectangle2D | LookupOp.getBounds2D(BufferedImage src) 返回过滤后的目标图像的边界框。
Rectangle2D | RescaleOp.getBounds2D(BufferedImage src) 返回重缩放后的目标图像的边界框。

javax.imageio 中 BufferedImage 的使用

声明为 BufferedImage 的 javax.imageio 中的字段
protected  BufferedImage ImageReadParam.destination
当前目标 BufferedImage；如果没有设置目标图像，则为 null。

类型参数类型为 BufferedImage 的 javax.imageio 中的字段
protected  List<? extends BufferedImage> IIOImage.thumbnails
BufferedImage 缩略图的 List，或为 null。

返回 BufferedImage 的 javax.imageio 中的方法
BufferedImage | ImageTypeSpecifier.createBufferedImage(int width, int height) 根据此对象中包含的规范创建一个具有给定宽度和高度的 BufferedImage。
BufferedImage | ImageReadParam.getDestination() 返回当前由 setDestination 方法设置的 BufferedImage，如果没有设置，则返回 null。
protected static BufferedImage | ImageReader.getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height) 返回应该在其中写入解码的像素数据的 BufferedImage。
BufferedImage | IIOImage.getThumbnail(int index) 返回与主图像关联的缩略图。
static BufferedImage | ImageIO.read(File input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 File 的结果。
static BufferedImage | ImageIO.read(ImageInputStream stream) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 ImageInputStream 的结果。
static BufferedImage | ImageIO.read(InputStream input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 InputStream 的结果。
BufferedImage | ImageReader.read(int imageIndex) 使用默认 ImageReadParam 读取通过索引 imageIndex 指定的图像，并将其作为一个完整的 BufferedImage 返回。
abstract BufferedImage | ImageReader.read(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的对象，并将它作为一个完整的 BufferedImage 返回。
static BufferedImage | ImageIO.read(URL input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 URL 的结果。
BufferedImage | ImageReader.readThumbnail(int imageIndex, int thumbnailIndex) 以 BufferedImage 形式返回通过索引 thumbnailIndex 指定的缩略图预览图像，其与通过索引 ImageIndex 指定的图像关联。
BufferedImage | ImageReader.readTile(int imageIndex, int tileX, int tileY) 读取由 tileX 和 tileY 参数指示的 tile，并以 BufferedImage 形式返回。

返回变量类型为 BufferedImage 的类型的 javax.imageio 中的方法
 List<? extends BufferedImage> IIOImage.getThumbnails()
返回缩略图 BufferedImage 的当前 List，如果没有设置任何缩略图，则返回 null。

参数类型为 BufferedImage 的 javax.imageio 中的方法
protected static void | ImageReader.computeRegions(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion) 计算感兴趣的源区域和目标区域，将源图像的宽度和高度、可选目标图像和可选 ImageReadParam 都考虑在内。
protected void | ImageReader.processImageUpdate(BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 imageUpdate 方法向其广播样本集合的更新。
protected void | ImageReader.processPassComplete(BufferedImage theImage) 通过调用所有已注册 IIOReadUpdateListener 的 passComplete 方法向其广播逐步传递的结束。
protected void | ImageReader.processPassStarted(BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 passStarted 方法向其广播逐步传递的开始。
protected void | ImageReader.processThumbnailPassComplete(BufferedImage theThumbnail) 通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassComplete 方法向其广播缩略图逐步传递的结束。
protected void | ImageReader.processThumbnailPassStarted(BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassStarted 方法向其广播缩略图逐步传递的开始。
protected void | ImageReader.processThumbnailUpdate(BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 thumbnailUpdate 方法向其广播缩略图图像中样本集合的更新。
void | ImageReadParam.setDestination(BufferedImage destination) 提供一个 BufferedImage，将其用作解码像素数据的目标。

类型变量类型为 BufferedImage 的 javax.imageio 中的方法参数
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | IIOImage.setThumbnails(List<? extends BufferedImage> thumbnails) 将缩略图列表设置为 BufferedImage 的一个新 List 或 null。

类型变量类型为 BufferedImage 的 javax.imageio 中的构造方法参数
IIOImage(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。
IIOImage(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。

javax.imageio.event 中 BufferedImage 的使用

参数类型为 BufferedImage 的 javax.imageio.event 中的方法
void | IIOReadUpdateListener.imageUpdate(ImageReader source, BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 报告已更新图像的给定区域。
void | IIOReadUpdateListener.passComplete(ImageReader source, BufferedImage theImage) 报告当前读操作已经完成一个逐步传递。
void | IIOReadUpdateListener.passStarted(ImageReader source, BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 报告当前的读操作将开始逐步传递 (progressive pass)。
void | IIOReadUpdateListener.thumbnailPassComplete(ImageReader source, BufferedImage theThumbnail) 报告当前缩略图读操作已经完成一个逐步传递。
void | IIOReadUpdateListener.thumbnailPassStarted(ImageReader source, BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 报告当前的缩略图读操作将开始逐步传递。
void | IIOReadUpdateListener.thumbnailUpdate(ImageReader source, BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 报告已更新缩略图图像的给定区域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.BufferedImageFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.BufferedImageFilter
的使用

没有 java.awt.image.BufferedImageFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.image.BufferedImageOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.BufferedImageOp
的使用

使用 BufferedImageOp 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 BufferedImageOp 的使用

参数类型为 BufferedImageOp 的 java.awt 中的方法
abstract  void Graphics2D.drawImage(BufferedImage img, BufferedImageOp op, int x, int y)
呈现使用 BufferedImageOp 过滤的 BufferedImage。

java.awt.image 中 BufferedImageOp 的使用

实现 BufferedImageOp 的 java.awt.image 中的类
class | AffineTransformOp 此类使用仿射转换来执行从源图像或 Raster 中 2D 坐标到目标图像或 Raster 中 2D 坐标的线性映射。
class | ColorConvertOp 此类对源图像中的数据执行逐像素的颜色转换。
class | ConvolveOp 此类实现从源到目标的卷积。
class | LookupOp 此类实现从源到目标的查找操作。
class | RescaleOp 通过将每个像素的样本值乘以一个缩放因子，然后加上一个偏移量，此类对源图像中数据进行逐像素重缩放。

返回 BufferedImageOp 的 java.awt.image 中的方法
 BufferedImageOp BufferedImageFilter.getBufferedImageOp()
返回 BufferedImageOp。

参数类型为 BufferedImageOp 的 java.awt.image 中的构造方法
BufferedImageFilter(BufferedImageOp op)
构造具有指定单一源图像/单一目标图像操作符的 BufferedImageFilter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.BufferStrategy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.BufferStrategy
的使用

使用 BufferStrategy 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 BufferStrategy 的使用

java.awt 中 BufferStrategy 的子类
protected class | Component.BltBufferStrategy 用于将屏幕外的画面以位图传输方式传输到一个组件的内部类。
protected class | Component.FlipBufferStrategy 在组件上翻转缓冲区的内部类。

返回 BufferStrategy 的 java.awt 中的方法
BufferStrategy | Canvas.getBufferStrategy() 返回由此组件使用的 BufferStrategy。
BufferStrategy | Window.getBufferStrategy() 返回此组件使用的 BufferStrategy。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.ByteLookupTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ByteLookupTable
的使用

没有 java.awt.image.ByteLookupTable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.ColorConvertOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ColorConvertOp
的使用

没有 java.awt.image.ColorConvertOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.ColorModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ColorModel
的使用

使用 ColorModel 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。

java.awt 中 ColorModel 的使用

返回 ColorModel 的 java.awt 中的方法
ColorModel | PaintContext.getColorModel() 返回输出的 ColorModel。
abstract ColorModel | GraphicsConfiguration.getColorModel() 返回与此 GraphicsConfiguration 关联的 ColorModel。
abstract ColorModel | Toolkit.getColorModel() 确定此工具包屏幕的颜色模型。
ColorModel | Component.getColorModel() 获取用于在输出设备上显示组件的 ColorModel 实例。
abstract ColorModel | GraphicsConfiguration.getColorModel(int transparency) 返回与此 GraphicsConfiguration 关联并支持指定透明度的 ColorModel。

参数类型为 ColorModel 的 java.awt 中的方法
CompositeContext | AlphaComposite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 为合成操作创建一个上下文。
CompositeContext | Composite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 创建一个上下文，其中包含用于执行复合操作的状态。
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。

java.awt.image 中 ColorModel 的使用

java.awt.image 中 ColorModel 的子类
class | ComponentColorModel 使用像素值将颜色和 alpha 信息表示为独立样本的 ColorModel 类，该类以独立的数据元素存储每个样本。
class | DirectColorModel DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。
class | IndexColorModel IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。
class | PackedColorModel PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。

声明为 ColorModel 的 java.awt.image 中的字段
protected ColorModel | RGBImageFilter.newmodel 用户调用 substituteColorModel 时替换 origmodel 的 ColorModel。
protected ColorModel | RGBImageFilter.origmodel 用户调用 substituteColorModel 时将由 newmodel 替换的 ColorModel。

返回 ColorModel 的 java.awt.image 中的方法
ColorModel | ComponentColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
ColorModel | DirectColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定此 ColorModel 现在已对该数据进行正确描述。
ColorModel | ColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
ColorModel | PixelGrabber.getColorModel() 获取该数组中所存储像素的 ColorModel。
ColorModel | BufferedImage.getColorModel() 返回 ColorModel。
ColorModel | RenderedImage.getColorModel() 返回与此图像相关的 ColorModel。
static ColorModel | ColorModel.getRGBdefault() 返回描述整数 RGB 值的默认格式的 DirectColorModel，该整数 RGB 值可以在便于程序员使用的 AWT 图像接口中的许多方法中使用。

参数类型为 ColorModel 的 java.awt.image 中的方法
BufferedImage | AffineTransformOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | BufferedImageOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | ColorConvertOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建给定源的具有正确大小和 band 数量的归零目标图像。
BufferedImage | ConvolveOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建具有正确 band 大小和数量的归零目标图像。
BufferedImage | LookupOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一幅具有正确大小和 band 数的、经过检查的目标图像。
BufferedImage | RescaleOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经检查的目标图像。
void | MemoryImageSource.newPixels(byte[] newpix, ColorModel newmodel, int offset, int scansize) 改用一个新的 byte 数组以保存此图像的像素。
void | MemoryImageSource.newPixels(int[] newpix, ColorModel newmodel, int offset, int scansize) 改用一个新的 int 数组以保存此图像的像素。
void | BufferedImageFilter.setColorModel(ColorModel model) 过滤 ImageConsumer 接口的 setColorModel 方法提供的信息。
void | PixelGrabber.setColorModel(ColorModel model) setColorModel 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | RGBImageFilter.setColorModel(ColorModel model) 如果 ColorModel 是 IndexColorModel 且子类将 canFilterIndexColorModel 标志设置为 true，则将此处及 setPixels 方法中任何出现原始 ColorModel 对象的地方替换为过滤后的颜色模型。
void | ImageFilter.setColorModel(ColorModel model) 过滤 ImageConsumer 接口的 setColorModel 方法中所提供的信息。
void | ImageConsumer.setColorModel(ColorModel model) 设置用于大多数像素的 ColorModel 对象，这些像素使用 setPixels 方法调用进行报告。
void | AreaAveragingScaleFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 将已传送 byte 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。
void | BufferedImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 过滤 ImageConsumer 接口（采用字节数组）的 setPixels 方法中提供的信息。
void | CropImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 确定已传递的字节像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。
void | PixelGrabber.setPixels(int srcX, int srcY, int srcW, int srcH, ColorModel model, byte[] pixels, int srcOff, int srcScan) setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | ReplicateScaleFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 从传递的 byte pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。
void | RGBImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素。
void | ImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以 byte 数组为参数。
void | ImageConsumer.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 一次或多次调用此方法来传递图像的像素。
void | AreaAveragingScaleFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 将已传送 int 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。
void | BufferedImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 过滤 ImageConsumer 接口（采用整数数组）的 setPixels 方法中提供的信息。
void | CropImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 确定已传递的 int 像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。
void | PixelGrabber.setPixels(int srcX, int srcY, int srcW, int srcH, ColorModel model, int[] pixels, int srcOff, int srcScan) setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | ReplicateScaleFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 从传递的 int pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。
void | RGBImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素，否则，将整数像素的缓冲区转换为默认 RGB ColorModel，并将转换后的缓冲区传递给 filterRGBPixels 方法进行逐一转换。
void | ImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以整数数组为参数。
void | ImageConsumer.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 一次或多次调用 setPixels 方法来传递图像的像素。
void | RGBImageFilter.substituteColorModel(ColorModel oldcm, ColorModel newcm) 注册两个用于替换的 ColorModel 对象。

参数类型为 ColorModel 的 java.awt.image 中的构造方法
BufferedImage(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
构造一个具有指定 ColorModel 和 Raster 的新 BufferedImage。
MemoryImageSource(int w, int h, ColorModel cm, byte[] pix, int off, int scan)
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, byte[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, int[] pix, int off, int scan)
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, int[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。

javax.imageio 中 ColorModel 的使用

声明为 ColorModel 的 javax.imageio 中的字段
protected  ColorModel ImageTypeSpecifier.colorModel
将用作原型的 ColorModel。

返回 ColorModel 的 javax.imageio 中的方法
 ColorModel ImageTypeSpecifier.getColorModel()
返回此对象指定的 ColorModel。

参数类型为 ColorModel 的 javax.imageio 中的构造方法
ImageTypeSpecifier(ColorModel colorModel, SampleModel sampleModel)
直接根据 ColorModel 和 SampleModel 构造一个 ImageTypeSpecifier。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.ComponentColorModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ComponentColorModel
的使用

没有 java.awt.image.ComponentColorModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.ComponentSampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ComponentSampleModel
的使用

使用 ComponentSampleModel 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 ComponentSampleModel 的使用

java.awt.image 中 ComponentSampleModel 的子类
class | BandedSampleModel 此类表示以 band 交错方式存储的图像数据，像素的每个样本都占用 DataBuffer 的一个数据元素。
class | PixelInterleavedSampleModel 此类表示以像素交替方式存储的图像数据，其中像素的每个采样占用 DataBuffer 的一个数据元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.ConvolveOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ConvolveOp
的使用

没有 java.awt.image.ConvolveOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.CropImageFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.CropImageFilter
的使用

没有 java.awt.image.CropImageFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.DataBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBuffer
的使用

使用 DataBuffer 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 DataBuffer 的使用

java.awt.image 中 DataBuffer 的子类
class | DataBufferByte 此类扩展了 DataBuffer，并在内部按字节存储数据。
class | DataBufferDouble 此类扩展了 DataBuffer，并在内部以 double 形式存储数据。
class | DataBufferFloat 此类扩展了 DataBuffer，并在内部以 float 形式存储数据。
class | DataBufferInt 此类扩展了 DataBuffer，并在内部以整数形式存储数据。
class | DataBufferShort 此类扩展了 DataBuffer，并在内部以 short 类型存储数据。
class | DataBufferUShort 此类扩展了 DataBuffer，并在内部以 short 类型存储数据。

声明为 DataBuffer 的 java.awt.image 中的字段
protected  DataBuffer Raster.dataBuffer
存储图像数据的 DataBuffer。

返回 DataBuffer 的 java.awt.image 中的方法
DataBuffer | BandedSampleModel.createDataBuffer() 创建一个与此 BandedSampleModel 对应的 DataBuffer，该 DataBuffer 的数据类型、存储单元数和大小都将与此 BandedSampleModel 一致。
DataBuffer | MultiPixelPackedSampleModel.createDataBuffer() 创建一个与此 MultiPixelPackedSampleModel 对应的 DataBuffer。
DataBuffer | SinglePixelPackedSampleModel.createDataBuffer() 创建一个对应于此 SinglePixelPackedSampleModel 的 DataBuffer。
DataBuffer | ComponentSampleModel.createDataBuffer() 创建对应于此 ComponentSampleModel 的 DataBuffer。
abstract DataBuffer | SampleModel.createDataBuffer() 创建一个对应于此 SampleModel 的 DataBuffer。
DataBuffer | Raster.getDataBuffer() 返回与此 Raster 关联的 DataBuffer。

参数类型为 DataBuffer 的 java.awt.image 中的方法
static WritableRaster | Raster.createBandedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | Raster.createInterleavedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location) 根据 MultiPixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度和每像素位数的 Raster。
static Raster | Raster.createRaster(SampleModel sm, DataBuffer db, Point location) 创建具有指定 SampleModel 和 DataBuffer 的 Raster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, DataBuffer db, Point location) 创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
Object | SampleModel.getDataElements(int x, int y, int w, int h, Object obj, DataBuffer data) 在 TransferType 类型基本数组中返回指定像素矩形的像素数据。
Object | BandedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data) 在 TransferType 类型基本数组中返回单个像素的数据。
Object | MultiPixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data) 返回 TransferType 类型基本数组中单个像素的数据。
Object | SinglePixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data) 返回 TransferType 类型基本数组中单个像素的数据。
Object | ComponentSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data) 以 TransferType 类型基本数组形式返回单个像素的数据。
abstract Object | SampleModel.getDataElements(int x, int y, Object obj, DataBuffer data) 在 TransferType 类型的基本数组中返回单个像素的数据。
double[] | SampleModel.getPixel(int x, int y, double[] dArray, DataBuffer data) 在一个 double 数组中返回指定像素的样本。
float[] | SampleModel.getPixel(int x, int y, float[] fArray, DataBuffer data) 在一个 float 数组中返回指定像素的样本。
int[] | BandedSampleModel.getPixel(int x, int y, int[] iArray, DataBuffer data) 在 int 数组中返回指定像素的所有样本。
int[] | MultiPixelPackedSampleModel.getPixel(int x, int y, int[] iArray, DataBuffer data) 返回 int 数组第一个元素中的指定单个 band 像素。
int[] | SinglePixelPackedSampleModel.getPixel(int x, int y, int[] iArray, DataBuffer data) 在一个 int 数组中返回对应于指定像素的所有样本。
int[] | ComponentSampleModel.getPixel(int x, int y, int[] iArray, DataBuffer data) 返回对应 int 数组中指定像素的所有样本，每个数组元素对应一个样本。
int[] | SampleModel.getPixel(int x, int y, int[] iArray, DataBuffer data) 在一个 int 数组中返回指定像素的样本，每个数组元素对应一个样本。
double[] | SampleModel.getPixels(int x, int y, int w, int h, double[] dArray, DataBuffer data) 在一个 double 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
float[] | SampleModel.getPixels(int x, int y, int w, int h, float[] fArray, DataBuffer data) 在一个 float 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
int[] | BandedSampleModel.getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 在 int 数组中返回指定像素矩形的所有样本，每个数据数组元素对应一个样本。
int[] | SinglePixelPackedSampleModel.getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 在一个 int 数组中返回对应于指定像素矩形的所有样本，每个数组元素对应一个样本。
int[] | ComponentSampleModel.getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 返回对应 int 数组中像素指定矩形区域的所有样本（每个数组元素对应一个样本）。
int[] | SampleModel.getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 在一个 int 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
int | BandedSampleModel.getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
int | MultiPixelPackedSampleModel.getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x, y) 处像素的样本。
int | SinglePixelPackedSampleModel.getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
int | ComponentSampleModel.getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
abstract int | SampleModel.getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double | BandedSampleModel.getSampleDouble(int x, int y, int b, DataBuffer data) 以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double | ComponentSampleModel.getSampleDouble(int x, int y, int b, DataBuffer data) 以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double | SampleModel.getSampleDouble(int x, int y, int b, DataBuffer data) 以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
float | BandedSampleModel.getSampleFloat(int x, int y, int b, DataBuffer data) 以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
float | ComponentSampleModel.getSampleFloat(int x, int y, int b, DataBuffer data) 以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
float | SampleModel.getSampleFloat(int x, int y, int b, DataBuffer data) 以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double[] | SampleModel.getSamples(int x, int y, int w, int h, int b, double[] dArray, DataBuffer data) 在一个 double 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
float[] | SampleModel.getSamples(int x, int y, int w, int h, int b, float[] fArray, DataBuffer data) 在一个 float 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
int[] | BandedSampleModel.getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 在 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数据数组元素对应一个样本。
int[] | SinglePixelPackedSampleModel.getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
int[] | ComponentSampleModel.getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 返回指定 band 中对应于 int 数组中指定像素矩形的样本，每个数据数组元素一个样本。
int[] | SampleModel.getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
void | SampleModel.setDataElements(int x, int y, int w, int h, Object obj, DataBuffer data) 根据 TransferType 类型的基本数组设置指定 DataBuffer 中像素矩形的数据。
void | BandedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
void | MultiPixelPackedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
void | SinglePixelPackedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型的基本数组设置指定 DataBuffer 中单个像素的数据。
void | ComponentSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
abstract void | SampleModel.setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
void | SampleModel.setPixel(int x, int y, double[] dArray, DataBuffer data) 使用输入的 double 样本数组设置 DataBuffer 中的像素。
void | SampleModel.setPixel(int x, int y, float[] fArray, DataBuffer data) 使用输入的 float 样本数组设置 DataBuffer 中的像素。
void | BandedSampleModel.setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入样本的 int 数组设置 DataBuffer 中的像素。
void | MultiPixelPackedSampleModel.setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入的 int 数组设置 DataBuffer 中的某个像素。
void | SinglePixelPackedSampleModel.setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入样本的 int 数组设置 DataBuffer 中的像素。
void | ComponentSampleModel.setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入样本的 int 数组设置 DataBuffer 中的像素。
void | SampleModel.setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入的 int 样本数组设置 DataBuffer 中的像素。
void | SampleModel.setPixels(int x, int y, int w, int h, double[] dArray, DataBuffer data) 根据 double 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | SampleModel.setPixels(int x, int y, int w, int h, float[] fArray, DataBuffer data) 根据 float 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | BandedSampleModel.setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组设置对应于像素矩形的所有样本，int 数组中每个数组元素包含一个样本。
void | SinglePixelPackedSampleModel.setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | ComponentSampleModel.setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组（每个数组元素包含一个样本）设置对应于像素矩形区域的所有样本。
void | SampleModel.setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | BandedSampleModel.setSample(int x, int y, int b, double s, DataBuffer data) 使用输入的 double 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
void | ComponentSampleModel.setSample(int x, int y, int b, double s, DataBuffer data) 使用输入的 double 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
void | SampleModel.setSample(int x, int y, int b, double s, DataBuffer data) 使用输入的 double 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | BandedSampleModel.setSample(int x, int y, int b, float s, DataBuffer data) 使用输入的 float 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
void | ComponentSampleModel.setSample(int x, int y, int b, float s, DataBuffer data) 使用输入的 float 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
void | SampleModel.setSample(int x, int y, int b, float s, DataBuffer data) 使用输入的 float 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | BandedSampleModel.setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
void | MultiPixelPackedSampleModel.setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int，设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | SinglePixelPackedSampleModel.setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | ComponentSampleModel.setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
abstract void | SampleModel.setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | SampleModel.setSamples(int x, int y, int w, int h, int b, double[] dArray, DataBuffer data) 根据 double 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
void | SampleModel.setSamples(int x, int y, int w, int h, int b, float[] fArray, DataBuffer data) 根据 float 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
void | BandedSampleModel.setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组设置指定 band 中对应于指定像素矩形的样本，int 数组中每个数据数组元素包含一个样本。
void | SinglePixelPackedSampleModel.setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
void | ComponentSampleModel.setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组（每个数据数组元素包含一个样本），在指定 band 中设置对应于指定像素矩形的样本。
void | SampleModel.setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。

参数类型为 DataBuffer 的 java.awt.image 中的构造方法
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构建具有给定 SampleModel 和 DataBuffer 的 Raster。
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构造具有给定 SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.DataBufferByte 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferByte
的使用

没有 java.awt.image.DataBufferByte 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.DataBufferDouble 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferDouble
的使用

没有 java.awt.image.DataBufferDouble 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.DataBufferFloat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferFloat
的使用

没有 java.awt.image.DataBufferFloat 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.DataBufferInt 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferInt
的使用

没有 java.awt.image.DataBufferInt 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.DataBufferShort 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferShort
的使用

没有 java.awt.image.DataBufferShort 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.DataBufferUShort 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferUShort
的使用

没有 java.awt.image.DataBufferUShort 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.DirectColorModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DirectColorModel
的使用

没有 java.awt.image.DirectColorModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.FilteredImageSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.FilteredImageSource
的使用

没有 java.awt.image.FilteredImageSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.image.ImageConsumer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.ImageConsumer
的使用

使用 ImageConsumer 的软件包
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt.image 中 ImageConsumer 的使用

实现 ImageConsumer 的 java.awt.image 中的类
class | AreaAveragingScaleFilter 这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。
class | BufferedImageFilter BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。
class | CropImageFilter 用于裁剪图像的 ImageFilter 类。
class | ImageFilter 此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。
class | PixelGrabber PixelGrabber 类实现可以附加在 Image 或 ImageProducer 对象上获得图像像素子集的 ImageConsumer。
class | ReplicateScaleFilter 使用最简单的算法缩放图像的 ImageFilter 类。
class | RGBImageFilter 此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。

声明为 ImageConsumer 的 java.awt.image 中的字段
protected  ImageConsumer ImageFilter.consumer
特定图像数据流的使用者，而此 ImageFilter 实例也是为这个使用者来过滤数据的。

参数类型为 ImageConsumer 的 java.awt.image 中的方法
void | MemoryImageSource.addConsumer(ImageConsumer ic) 将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表。
void | FilteredImageSource.addConsumer(ImageConsumer ic) 将指定的 ImageConsumer 添加到对过滤图像的数据感兴趣的使用者列表。
void | ImageProducer.addConsumer(ImageConsumer ic) 为了在稍后的 Image 重构期间访问图像数据，向 ImageProducer 注册一个 ImageConsumer。
ImageFilter | ImageFilter.getFilterInstance(ImageConsumer ic) 返回为指定 ImageConsumer 实际执行过滤的 ImageFilter 对象的惟一实例。
boolean | MemoryImageSource.isConsumer(ImageConsumer ic) 确定某个 ImageConsumer 目前是否处于对此图像数据感兴趣的使用者列表中。
boolean | FilteredImageSource.isConsumer(ImageConsumer ic) 确定一个 ImageConsumer 是否在对此图像数据感兴趣的使用者列表中。
boolean | ImageProducer.isConsumer(ImageConsumer ic) 确定指定的 ImageConsumer 对象目前是否已向此 ImageProducer 注册为其使用者之一。
void | MemoryImageSource.removeConsumer(ImageConsumer ic) 从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。
void | FilteredImageSource.removeConsumer(ImageConsumer ic) 从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。
void | ImageProducer.removeConsumer(ImageConsumer ic) 从目前已注册以接收图像数据的使用者列表中移除指定的 ImageConsumer 对象。
void | MemoryImageSource.requestTopDownLeftRightResend(ImageConsumer ic) 请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。
void | FilteredImageSource.requestTopDownLeftRightResend(ImageConsumer ic) 请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。
void | ImageProducer.requestTopDownLeftRightResend(ImageConsumer ic) 代表 ImageConsumer 请求 ImageProducer 尝试再次以 TOPDOWNLEFTRIGHT 的顺序重新发送图像数据，从而可以使用依赖于按顺序接收像素的高质量转换算法以生成更佳的图像输出。
void | MemoryImageSource.startProduction(ImageConsumer ic) 将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表中，并立即开始通过 ImageConsumer 接口传递图像数据。
void | FilteredImageSource.startProduction(ImageConsumer ic) 开始生成过滤图像。
void | ImageProducer.startProduction(ImageConsumer ic) 将指定的 ImageConsumer 对象注册为使用者，并立即开始图像数据的重构，然后这些图像数据将传递到此使用者和已经向该生产者注册的所有其他使用者。

java.awt.image.renderable 中 ImageConsumer 的使用

参数类型为 ImageConsumer 的 java.awt.image.renderable 中的方法
void | RenderableImageProducer.addConsumer(ImageConsumer ic) 将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表。
boolean | RenderableImageProducer.isConsumer(ImageConsumer ic) 确定某个 ImageConsumer 是否在当前对此图像的数据感兴趣的使用者列表。
void | RenderableImageProducer.removeConsumer(ImageConsumer ic) 从对此图像的数据感兴趣的使用者列表中删除一个 ImageConsumer。
void | RenderableImageProducer.requestTopDownLeftRightResend(ImageConsumer ic) 请求给定 ImageConsumer 按从上到下、从左到右的顺序再次提交图像数据。
void | RenderableImageProducer.startProduction(ImageConsumer ic) 将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表，并立即通过 ImageConsumer 接口开始提交该图像数据。

javax.swing 中 ImageConsumer 的使用

实现 ImageConsumer 的 javax.swing 中的类
 class GrayFilter
一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.ImageFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ImageFilter
的使用

使用 ImageFilter 的软件包
java.awt.image | 提供创建和修改图像的各种类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt.image 中 ImageFilter 的使用

java.awt.image 中 ImageFilter 的子类
class | AreaAveragingScaleFilter 这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。
class | BufferedImageFilter BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。
class | CropImageFilter 用于裁剪图像的 ImageFilter 类。
class | ReplicateScaleFilter 使用最简单的算法缩放图像的 ImageFilter 类。
class | RGBImageFilter 此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。

返回 ImageFilter 的 java.awt.image 中的方法
 ImageFilter ImageFilter.getFilterInstance(ImageConsumer ic)
返回为指定 ImageConsumer 实际执行过滤的 ImageFilter 对象的惟一实例。

参数类型为 ImageFilter 的 java.awt.image 中的构造方法
FilteredImageSource(ImageProducer orig, ImageFilter imgf)
根据现有的 ImageProducer 和过滤器对象构造一个 ImageProducer 对象。

javax.swing 中 ImageFilter 的使用

javax.swing 中 ImageFilter 的子类
 class GrayFilter
一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.image.ImageObserver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.ImageObserver
的使用

使用 ImageObserver 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 ImageObserver 的使用

实现 ImageObserver 的 java.applet 中的类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 ImageObserver 的使用

实现 ImageObserver 的 java.awt 中的类
class | Button 此类创建一个标签按钮。
class | Canvas Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
class | Choice Choice 类表示一个弹出式选择菜单。
class | Component component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
class | Container 一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。
class | Label Label 对象是一个可在容器中放置文本的组件。
class | List List 组件为用户提供了一个可滚动的文本项列表。
class | Panel Panel 是最简单的容器类。
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
class | TextArea TextArea 对象是显示文本的多行区域。
class | TextComponent TextComponent 类是所有允许编辑文本的组件的超类。
class | TextField TextField 对象是允许编辑单行文本的文本组件。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。

参数类型为 ImageObserver 的 java.awt 中的方法
int | Component.checkImage(Image image, ImageObserver observer) 返回指定图像屏幕表示的构造状态。
abstract int | Toolkit.checkImage(Image image, int width, int height, ImageObserver observer) 指示正准备显示的指定图像的构造状态。
int | Component.checkImage(Image image, int width, int height, ImageObserver observer) 返回指定图像屏幕表示的构造状态。
abstract boolean | Graphics2D.drawImage(Image img, AffineTransform xform, ImageObserver obs) 呈现一个图像，在绘制前进行从图像空间到用户空间的转换。
abstract boolean | Graphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 绘制指定图像中当前可用的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, ImageObserver observer) 绘制指定图像中当前可用的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, int width, int height, ImageObserver observer) 绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract boolean | Graphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
abstract boolean | Graphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer) 绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
abstract int | Image.getHeight(ImageObserver observer) 确定图像的高度。
abstract Object | Image.getProperty(String name, ImageObserver observer) 通过名称获取此图像的属性。
abstract int | Image.getWidth(ImageObserver observer) 确定图像的宽度。
boolean | Component.prepareImage(Image image, ImageObserver observer) 准备一幅在此组件上呈现的图像。
abstract boolean | Toolkit.prepareImage(Image image, int width, int height, ImageObserver observer) 准备一个用于呈现的图像。
boolean | Component.prepareImage(Image image, int width, int height, ImageObserver observer) 以指定的宽度和高度准备一幅在此组件上呈现的图像。

java.awt.image 中 ImageObserver 的使用

参数类型为 ImageObserver 的 java.awt.image 中的方法
int | BufferedImage.getHeight(ImageObserver observer) 返回 BufferedImage 的高度。
Object | BufferedImage.getProperty(String name, ImageObserver observer) 按名称返回图像的属性。
int | BufferedImage.getWidth(ImageObserver observer) 返回 BufferedImage 的宽度。

javax.swing 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing 中的类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JComponent 该类是除顶层容器外所有 Swing 组件的基类。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JDialog 创建对话框窗口的主要类。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

返回 ImageObserver 的 javax.swing 中的方法
 ImageObserver ImageIcon.getImageObserver()
返回图像的图像观察者。

参数类型为 ImageObserver 的 javax.swing 中的方法
boolean | DebugGraphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, int width, int height, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer) 重写 Graphics.drawImage。
void | ImageIcon.setImageObserver(ImageObserver observer) 设置图像的图像观察者。

javax.swing.colorchooser 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.colorchooser 中的类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.plaf.basic 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.plaf.basic 中的类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
protected class | BasicToolBarUI.DragWindow

javax.swing.plaf.metal 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

javax.swing.table 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.table 中的类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。

javax.swing.text 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.text 中的类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

javax.swing.tree 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.tree 中的类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
class | DefaultTreeCellRenderer 显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.image.ImageProducer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.ImageProducer
的使用

使用 ImageProducer 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。

java.awt 中 ImageProducer 的使用

返回 ImageProducer 的 java.awt 中的方法
abstract  ImageProducer Image.getSource()
获取生成图像像素的对象。

参数类型为 ImageProducer 的 java.awt 中的方法
abstract Image | Toolkit.createImage(ImageProducer producer) 使用指定的图像生成器创建一幅图像。
Image | Component.createImage(ImageProducer producer) 根据指定的图像生成器创建一幅图像。

java.awt.image 中 ImageProducer 的使用

实现 ImageProducer 的 java.awt.image 中的类
class | FilteredImageSource 此类是 ImageProducer 接口的一个实现，该接口使用现有的图像和过滤器对象作为参数，并使用它们为原图像的新过滤版本产生图像数据。
class | MemoryImageSource 此类是 ImageProducer 接口的一个实现，该接口使用一个数组为 Image 生成像素值。

返回 ImageProducer 的 java.awt.image 中的方法
ImageProducer | BufferedImage.getSource() 返回生成该图像像素的对象。
ImageProducer | VolatileImage.getSource() 此方法返回此 VolatileImage 的 ImageProducer。

参数类型为 ImageProducer 的 java.awt.image 中的方法
 void ImageFilter.resendTopDownLeftRight(ImageProducer ip)
响应来自 ImageConsumer 的一个按 TopDownLeftRight (TDLR) 顺序将像素数据重新发送的请求。

参数类型为 ImageProducer 的 java.awt.image 中的构造方法
FilteredImageSource(ImageProducer orig, ImageFilter imgf)
根据现有的 ImageProducer 和过滤器对象构造一个 ImageProducer 对象。
PixelGrabber(ImageProducer ip, int x, int y, int w, int h, int[] pix, int off, int scansize)
创建一个 PixelGrabber 对象，以从指定 ImageProducer 所生成的图像中将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。

java.awt.image.renderable 中 ImageProducer 的使用

实现 ImageProducer 的 java.awt.image.renderable 中的类
 class RenderableImageProducer
实现 ImageProducer 以允许异步生成 RenderableImage 的适配器类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.ImagingOpException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ImagingOpException
的使用

没有 java.awt.image.ImagingOpException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.IndexColorModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.IndexColorModel
的使用

使用 IndexColorModel 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 IndexColorModel 的使用

返回 IndexColorModel 的 java.awt.image 中的方法
 IndexColorModel RGBImageFilter.filterIndexColorModel(IndexColorModel icm)
过滤 IndexColorModel 对象：通过 filterRGB 函数（RGBImageFilter 子类必须提供该函数）运行该对象颜色表中的每一项。

参数类型为 IndexColorModel 的 java.awt.image 中的方法
 IndexColorModel RGBImageFilter.filterIndexColorModel(IndexColorModel icm)
过滤 IndexColorModel 对象：通过 filterRGB 函数（RGBImageFilter 子类必须提供该函数）运行该对象颜色表中的每一项。

参数类型为 IndexColorModel 的 java.awt.image 中的构造方法
BufferedImage(int width, int height, int imageType, IndexColorModel cm)
构造一个类型为预定义图像类型之一的 BufferedImage：TYPE_BYTE_BINARY 或 TYPE_BYTE_INDEXED。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.Kernel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.Kernel
的使用

使用 Kernel 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 Kernel 的使用

返回 Kernel 的 java.awt.image 中的方法
 Kernel ConvolveOp.getKernel()
返回 Kernel。

参数类型为 Kernel 的 java.awt.image 中的构造方法
ConvolveOp(Kernel kernel)
构造给定了 Kernel 的 ConvolveOp。
ConvolveOp(Kernel kernel, int edgeCondition, RenderingHints hints)
构造给定 Kernel、边缘条件和 RenderingHint 对象（可以为 null）的 ConvolveOp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.LookupOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.LookupOp
的使用

没有 java.awt.image.LookupOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.LookupTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.LookupTable
的使用

使用 LookupTable 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 LookupTable 的使用

java.awt.image 中 LookupTable 的子类
class | ByteLookupTable 此类定义一个 lookup table 对象。
class | ShortLookupTable 此类定义了一个查找表对象。

返回 LookupTable 的 java.awt.image 中的方法
 LookupTable LookupOp.getTable()
返回 LookupTable。

参数类型为 LookupTable 的 java.awt.image 中的构造方法
LookupOp(LookupTable lookup, RenderingHints hints)
在给定查找表和 RenderingHints 对象（可能为 null）的情况下，构造一个 LookupOp 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.MemoryImageSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.MemoryImageSource
的使用

没有 java.awt.image.MemoryImageSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.MultiPixelPackedSampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.MultiPixelPackedSampleModel
的使用

没有 java.awt.image.MultiPixelPackedSampleModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.PackedColorModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.PackedColorModel
的使用

使用 PackedColorModel 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 PackedColorModel 的使用

java.awt.image 中 PackedColorModel 的子类
 class DirectColorModel
DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.PixelGrabber 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.PixelGrabber
的使用

没有 java.awt.image.PixelGrabber 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.PixelInterleavedSampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.PixelInterleavedSampleModel
的使用

没有 java.awt.image.PixelInterleavedSampleModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.Raster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.Raster
的使用

使用 Raster 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。

java.awt 中 Raster 的使用

返回 Raster 的 java.awt 中的方法
 Raster PaintContext.getRaster(int x, int y, int w, int h)
返回包含为图形操作生成的颜色的 Raster。

参数类型为 Raster 的 java.awt 中的方法
 void CompositeContext.compose(Raster src, Raster dstIn, WritableRaster dstOut)
组合两个源 Raster 对象并将结果置于目标 WritableRaster 中。

java.awt.image 中 Raster 的使用

java.awt.image 中 Raster 的子类
 class WritableRaster
此类扩展了 Raster 以提供像素写入功能。

声明为 Raster 的 java.awt.image 中的字段
protected  Raster Raster.parent
此 Raster 的父 Raster，或者为 null。

返回 Raster 的 java.awt.image 中的方法
Raster | Raster.createChild(int parentX, int parentY, int width, int height, int childMinX, int childMinY, int[] bandList) 返回共享此 Raster 全部或部分 DataBuffer 的新 Raster。
static Raster | Raster.createRaster(SampleModel sm, DataBuffer db, Point location) 创建具有指定 SampleModel 和 DataBuffer 的 Raster。
Raster | Raster.createTranslatedChild(int childMinX, int childMinY) 创建一个 Raster，使其大小、SampleModel 和 DataBuffer 与此 Raster 相同，但是位置不同。
Raster | BufferedImage.getData() 以一个大 tile 的形式返回图像。
Raster | RenderedImage.getData() 以一个大 tile 的形式返回图像（对于基于 tile 的图像，此方法需要获取整个图像并复制全部图像数据）。
Raster | BufferedImage.getData(Rectangle rect) 计算并返回 BufferedImage 的一个任意区域。
Raster | RenderedImage.getData(Rectangle rect) 计算并返回 RenderedImage 的任意区域。
Raster | Raster.getParent() 返回此 Raster 的父 Raster（如果有），或者 null。
Raster | BufferedImage.getTile(int tileX, int tileY) 返回 tile (tileX, tileY)。
Raster | RenderedImage.getTile(int tileX, int tileY) 返回 tile (tileX, tileY)。

参数类型为 Raster 的 java.awt.image 中的方法
BufferedImage | IndexColorModel.convertToIntDiscrete(Raster raster, boolean forceARGB) 返回一个 TYPE_INT_ARGB 或 TYPE_INT_RGB 的新 BufferedImage，其 Raster 的像素数据是通过使用此 ColorModel 的颜色/alpha 分量数组扩展源 Raster 中的各索引来计算的。
WritableRaster | AffineTransformOp.createCompatibleDestRaster(Raster src) 创建一个具有正确大小和 band 数的经过检查的目标 Raster。
WritableRaster | BandCombineOp.createCompatibleDestRaster(Raster src) 创建一个经过检查的目标 Raster，它具有正确大小和 band 数。
WritableRaster | ColorConvertOp.createCompatibleDestRaster(Raster src) 创建给定源且具有正确 band 大小和数量的归零目标 Raster。
WritableRaster | ConvolveOp.createCompatibleDestRaster(Raster src) 创建给定源且具有正确 band 大小和数量的归零目标 Raster。
WritableRaster | LookupOp.createCompatibleDestRaster(Raster src) 在给定源 Raster 的情况下，创建一幅具有正确大小和 band 数的、经过检查的目标 Raster。
WritableRaster | RasterOp.createCompatibleDestRaster(Raster src) 创建一个具有正确大小和 band 数的归零目标 Raster。
WritableRaster | RescaleOp.createCompatibleDestRaster(Raster src) 在给出源的情况下，创建一个具有正确大小和 band 数的经检查的目标 Raster。
WritableRaster | AffineTransformOp.filter(Raster src, WritableRaster dst) 转换源 Raster 并将结果存储在目标 Raster 中。
WritableRaster | BandCombineOp.filter(Raster src, WritableRaster dst) 使用构造方法中指定的矩阵变换该 Raster。
WritableRaster | ColorConvertOp.filter(Raster src, WritableRaster dest) 对源 Raster 中的图像数据进行颜色转换。
WritableRaster | ConvolveOp.filter(Raster src, WritableRaster dst) 对 Raster 执行卷积运算。
WritableRaster | LookupOp.filter(Raster src, WritableRaster dst) 在 Raster 上执行查找操作。
WritableRaster | RasterOp.filter(Raster src, WritableRaster dest) 执行从源 Raster 到目标 Raster 的单输入/单输出操作。
WritableRaster | RescaleOp.filter(Raster src, WritableRaster dst) 对源 Raster 中的像素数据进行重缩放。
Rectangle2D | AffineTransformOp.getBounds2D(Raster src) 返回转换后的目标图像的边界框。
Rectangle2D | BandCombineOp.getBounds2D(Raster src) 返回变换后目标图像的边界框。
Rectangle2D | ColorConvertOp.getBounds2D(Raster src) 返回给定源的目标边界框。
Rectangle2D | ConvolveOp.getBounds2D(Raster src) 返回已过滤目标 Raster 的边界框。
Rectangle2D | LookupOp.getBounds2D(Raster src) 返回过滤后目标 Raster 的边界框。
Rectangle2D | RasterOp.getBounds2D(Raster src) 返回过滤后目标 Raster 的边界框。
Rectangle2D | RescaleOp.getBounds2D(Raster src) 返回重缩放后的目标 Raster 的边界框。
boolean | ComponentColorModel.isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true；如果不兼容，则返回 false。
boolean | IndexColorModel.isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true；如果不与此 ColorModel 兼容，则返回 false。
boolean | DirectColorModel.isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。
boolean | ColorModel.isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。
void | BufferedImage.setData(Raster r) 将图像的矩形区域设置为指定 Raster r 的内容，假定该区域与 BufferedImage 处于相同的坐标空间。
void | WritableRenderedImage.setData(Raster r) 将图像的 rect 设置为 Raster r 的内容，假定 r 位于与 WritableRenderedImage 相同的坐标空间。
void | WritableRaster.setDataElements(int x, int y, Raster inRaster) 为输入 Raster 中的像素矩形设置数据。
void | WritableRaster.setRect(int dx, int dy, Raster srcRaster) 将像素从 Raster srcRaster 复制到此 WritableRaster。
void | WritableRaster.setRect(Raster srcRaster) 将像素从 Raster srcRaster 复制到此 WritableRaster。

参数类型为 Raster 的 java.awt.image 中的构造方法
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。

javax.imageio 中 Raster 的使用

声明为 Raster 的 javax.imageio 中的字段
protected  Raster IIOImage.raster
正被引用的 Raster。

返回 Raster 的 javax.imageio 中的方法
Raster | IIOImage.getRaster() 返回当前设置好的 Raster，如果只有一个 RenderedImage 可用，则返回 null。
Raster | ImageReader.readRaster(int imageIndex, ImageReadParam param) 返回包含图像流中原始像素数据的新 Raster 对象，不应用任何颜色转换。
Raster | ImageReader.readTileRaster(int imageIndex, int tileX, int tileY) 返回包含 tile 中的原始像素数据的新 Raster 对象，不应用任何颜色转换。

参数类型为 Raster 的 javax.imageio 中的方法
void | ImageWriter.replacePixels(Raster raster, ImageWriteParam param) 用给定 Raster 部分替换已出现在输出中的图像部分。
void | IIOImage.setRaster(Raster raster) 设置当前 Raster。

参数类型为 Raster 的 javax.imageio 中的构造方法
IIOImage(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.RasterFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.RasterFormatException
的使用

没有 java.awt.image.RasterFormatException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.image.RasterOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.RasterOp
的使用

使用 RasterOp 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 RasterOp 的使用

实现 RasterOp 的 java.awt.image 中的类
class | AffineTransformOp 此类使用仿射转换来执行从源图像或 Raster 中 2D 坐标到目标图像或 Raster 中 2D 坐标的线性映射。
class | BandCombineOp 此类使用一个指定矩阵对 Raster 中的 band 进行任意线性组合。
class | ColorConvertOp 此类对源图像中的数据执行逐像素的颜色转换。
class | ConvolveOp 此类实现从源到目标的卷积。
class | LookupOp 此类实现从源到目标的查找操作。
class | RescaleOp 通过将每个像素的样本值乘以一个缩放因子，然后加上一个偏移量，此类对源图像中数据进行逐像素重缩放。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.image.RenderedImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.RenderedImage
的使用

使用 RenderedImage 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

java.awt 中 RenderedImage 的使用

参数类型为 RenderedImage 的 java.awt 中的方法
abstract  void Graphics2D.drawRenderedImage(RenderedImage img, AffineTransform xform)
呈现 RenderedImage，在绘制前进行从图像空间到用户空间的转换。

java.awt.image 中 RenderedImage 的使用

java.awt.image 中 RenderedImage 的子接口
 interface WritableRenderedImage
WriteableRenderedImage 公共接口用于那些包含或者能够生成 Rasters 形式图像数据的对象，以及能够被修改和/或写入的对象。

实现 RenderedImage 的 java.awt.image 中的类
 class BufferedImage
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。

返回变量类型为 RenderedImage 的类型的 java.awt.image 中的方法
Vector<RenderedImage> | BufferedImage.getSources() 返回 RenderedImage 对象的 Vector，该对象是此 BufferedImage 图像数据的直接来源，而不是这些直接来源的来源。
Vector<RenderedImage> | RenderedImage.getSources() 返回作为此 RenderedImage 直接图像数据源的 RenderedImage 向量。

java.awt.image.renderable 中 RenderedImage 的使用

返回 RenderedImage 的 java.awt.image.renderable 中的方法
RenderedImage | RenderedImageFactory.create(ParameterBlock paramBlock, RenderingHints hints) 针对给定的 ParameterBlock 和 RenderingHints 创建表示成像操作（或操作链）结果的 RenderedImage。
RenderedImage | ContextualRenderedImageFactory.create(RenderContext renderContext, ParameterBlock paramBlock) 根据给定包含操作的源和参数的 RenderContext 和 ParameterBlock 创建一个呈现。
RenderedImage | RenderableImage.createDefaultRendering() 返回此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。
RenderedImage | RenderableImageOp.createDefaultRendering() 获取此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。
RenderedImage | RenderableImage.createRendering(RenderContext renderContext) 使用给定的 RenderContext 创建表示此图像一个呈现的 RenderedImage。
RenderedImage | RenderableImageOp.createRendering(RenderContext renderContext) 创建一个表示根据给定 RenderContext 呈现的 RenderableImageOp（包括其 Renderable 源）的 RenderedImage。
RenderedImage | RenderableImage.createScaledRendering(int w, int h, RenderingHints hints) 创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
RenderedImage | RenderableImageOp.createScaledRendering(int w, int h, RenderingHints hints) 创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
RenderedImage | ParameterBlock.getRenderedSource(int index) 返回作为 RenderedImage 的源。

javax.imageio 中 RenderedImage 的使用

声明为 RenderedImage 的 javax.imageio 中的字段
protected  RenderedImage IIOImage.image
正被引用的 RenderedImage。

返回 RenderedImage 的 javax.imageio 中的方法
RenderedImage | IIOImage.getRenderedImage() 返回当前设置好的 RenderedImage，如果只有一个 Raster 可用，则返回 null。
RenderedImage | ImageReader.readAsRenderedImage(int imageIndex, ImageReadParam param) 返回一个 RenderedImage 对象，该对象包含通过索引 imageIndex 指定的图像的内容。

参数类型为 RenderedImage 的 javax.imageio 中的方法
static ImageTypeSpecifier | ImageTypeSpecifier.createFromRenderedImage(RenderedImage image) 返回一个 ImageTypeSpecifier，它将对 RenderedImage（可能是 BufferedImage）的布局进行编码。
void | ImageWriter.replacePixels(RenderedImage image, ImageWriteParam param) 用给定图像部分替换已出现在输出中的图像部分。
void | IIOImage.setRenderedImage(RenderedImage image) 设置当前 RenderedImage。
void | ImageWriter.write(RenderedImage image) 将由带有默认元数据和缩略图的单个图像组成的完整图像流添加到输出中。
static boolean | ImageIO.write(RenderedImage im, String formatName, File output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 File。
static boolean | ImageIO.write(RenderedImage im, String formatName, ImageOutputStream output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。
static boolean | ImageIO.write(RenderedImage im, String formatName, OutputStream output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。

参数类型为 RenderedImage 的 javax.imageio 中的构造方法
IIOImage(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。
ImageTypeSpecifier(RenderedImage image)
根据 RenderedImage 构造一个 ImageTypeSpecifier。

javax.imageio.spi 中 RenderedImage 的使用

参数类型为 RenderedImage 的 javax.imageio.spi 中的方法
 boolean ImageWriterSpi.canEncodeImage(RenderedImage im)
如果与此服务提供者关联的 ImageWriter 实现能够编码给定的 RenderedImage 实例，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.ReplicateScaleFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ReplicateScaleFilter
的使用

使用 ReplicateScaleFilter 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 ReplicateScaleFilter 的使用

java.awt.image 中 ReplicateScaleFilter 的子类
 class AreaAveragingScaleFilter
这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.RescaleOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.RescaleOp
的使用

没有 java.awt.image.RescaleOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.RGBImageFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.RGBImageFilter
的使用

使用 RGBImageFilter 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RGBImageFilter 的使用

javax.swing 中 RGBImageFilter 的子类
 class GrayFilter
一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.SampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.SampleModel
的使用

使用 SampleModel 的软件包
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。

java.awt.image 中 SampleModel 的使用

java.awt.image 中 SampleModel 的子类
class | BandedSampleModel 此类表示以 band 交错方式存储的图像数据，像素的每个样本都占用 DataBuffer 的一个数据元素。
class | ComponentSampleModel 此类表示按每个像素样本占用 DataBuffer 中一个数据元素的方式存储的图像数据。
class | MultiPixelPackedSampleModel MultiPixelPackedSampleModel 类表示单 band 图像，能够将多个单样本像素打包到一个数据元素中。
class | PixelInterleavedSampleModel 此类表示以像素交替方式存储的图像数据，其中像素的每个采样占用 DataBuffer 的一个数据元素。
class | SinglePixelPackedSampleModel 此类表示压缩的像素数据：将 N 个样本组成的单个像素存储在单个数据数组元素中，每个数据数组元素只保存一个像素的样本。

声明为 SampleModel 的 java.awt.image 中的字段
protected  SampleModel Raster.sampleModel
描述此 Raster 的像素在 DataBuffer 中存储方式的 SampleModel。

返回 SampleModel 的 java.awt.image 中的方法
SampleModel | BandedSampleModel.createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度的新的 BandedSampleModel。
SampleModel | ComponentColorModel.createCompatibleSampleModel(int w, int h) 用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。
SampleModel | MultiPixelPackedSampleModel.createCompatibleSampleModel(int w, int h) 构造一个具有指定宽度和高度的新 MultiPixelPackedSampleModel。
SampleModel | SinglePixelPackedSampleModel.createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度的新 SinglePixelPackedSampleModel。
SampleModel | PixelInterleavedSampleModel.createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度的 PixelInterleavedSampleModel。
SampleModel | ComponentSampleModel.createCompatibleSampleModel(int w, int h) 创建具有指定宽度和高度的 ComponentSampleModel。
abstract SampleModel | SampleModel.createCompatibleSampleModel(int w, int h) 创建一个用此 SampleModel 的格式描述数据，但宽度和高度不同的 SampleModel。
SampleModel | IndexColorModel.createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。
SampleModel | PackedColorModel.createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。
SampleModel | ColorModel.createCompatibleSampleModel(int w, int h) 用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。
SampleModel | BandedSampleModel.createSubsetSampleModel(int[] bands) 创建一个具有此 BandedSampleModel 的 band 子集的新 BandedSampleModel。
SampleModel | MultiPixelPackedSampleModel.createSubsetSampleModel(int[] bands) 创建一个具有此 MultiPixelPackedSampleModel band 子集的新 MultiPixelPackedSampleModel。
SampleModel | SinglePixelPackedSampleModel.createSubsetSampleModel(int[] bands) 创建一个新 SinglePixelPackedSampleModel，使其具有此 SinglePixelPackedSampleModel 的 band 子集。
SampleModel | PixelInterleavedSampleModel.createSubsetSampleModel(int[] bands) 创建一个具有此 PixelInterleavedSampleModel 的 band 子集的 PixelInterleavedSampleModel。
SampleModel | ComponentSampleModel.createSubsetSampleModel(int[] bands) 创建具有此 ComponentSampleModel 的 band 子集的新 ComponentSampleModel。
abstract SampleModel | SampleModel.createSubsetSampleModel(int[] bands) 创建一个新 SampleModel，它具有此 SampleModel 的 band 子集。
SampleModel | BufferedImage.getSampleModel() 返回与此 BufferedImage 关联的 SampleModel。
SampleModel | RenderedImage.getSampleModel() 返回与此图像相关的 SampleModel。
SampleModel | Raster.getSampleModel() 返回描述图像数据布局的 SampleModel。

参数类型为 SampleModel 的 java.awt.image 中的方法
static Raster | Raster.createRaster(SampleModel sm, DataBuffer db, Point location) 创建具有指定 SampleModel 和 DataBuffer 的 Raster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, DataBuffer db, Point location) 创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, Point location) 创建一个具有指定 SampleModel 的 WritableRaster。
boolean | ComponentColorModel.isCompatibleSampleModel(SampleModel sm) 检查指定 SampleModel 是否与此 ColorModel 兼容。
boolean | IndexColorModel.isCompatibleSampleModel(SampleModel sm) 检查指定的 SampleModel 是否与此 ColorModel 兼容。
boolean | PackedColorModel.isCompatibleSampleModel(SampleModel sm) 检查指定的 SampleModel 是否与此 ColorModel 兼容。
boolean | ColorModel.isCompatibleSampleModel(SampleModel sm) 检查 SampleModel 是否与此 ColorModel 兼容。

参数类型为 SampleModel 的 java.awt.image 中的构造方法
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构建具有给定 SampleModel 和 DataBuffer 的 Raster。
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
Raster(SampleModel sampleModel, Point origin)
构建具有给定 SampleModel 的 Raster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构造具有给定 SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。
WritableRaster(SampleModel sampleModel, Point origin)
构造具有给定 SampleModel 的 WritableRaster。

javax.imageio 中 SampleModel 的使用

声明为 SampleModel 的 javax.imageio 中的字段
protected  SampleModel ImageTypeSpecifier.sampleModel
将用作原型的 SampleModel。

返回 SampleModel 的 javax.imageio 中的方法
SampleModel | ImageTypeSpecifier.getSampleModel() 根据此对象中封装的设置返回一个 SampleModel。
SampleModel | ImageTypeSpecifier.getSampleModel(int width, int height) 根据此对象中封装的设置值返回一个 SampleModel。

参数类型为 SampleModel 的 javax.imageio 中的构造方法
ImageTypeSpecifier(ColorModel colorModel, SampleModel sampleModel)
直接根据 ColorModel 和 SampleModel 构造一个 ImageTypeSpecifier。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.ShortLookupTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ShortLookupTable
的使用

没有 java.awt.image.ShortLookupTable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.SinglePixelPackedSampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.SinglePixelPackedSampleModel
的使用

没有 java.awt.image.SinglePixelPackedSampleModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.image.TileObserver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.TileObserver
的使用

使用 TileObserver 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 TileObserver 的使用

参数类型为 TileObserver 的 java.awt.image 中的方法
void | BufferedImage.addTileObserver(TileObserver to) 添加一个 tile observer。
void | WritableRenderedImage.addTileObserver(TileObserver to) 添加一个观察器。
void | BufferedImage.removeTileObserver(TileObserver to) 移除一个 tile observer。
void | WritableRenderedImage.removeTileObserver(TileObserver to) 移除一个观察器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.VolatileImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.VolatileImage
的使用

使用 VolatileImage 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 VolatileImage 的使用

声明为 VolatileImage 的 java.awt 中的字段
protected VolatileImage[] | Component.BltBufferStrategy.backBuffers 后台缓冲区
protected VolatileImage | Component.FlipBufferStrategy.drawVBuffer 作为可变图像的绘制缓冲区。

返回 VolatileImage 的 java.awt 中的方法
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力的 VolatileImage。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps, int transparency) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力和透明度值的 VolatileImage。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, int transparency) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
VolatileImage | Component.createVolatileImage(int width, int height) 创建一幅用于双缓冲的、可变的、可在屏幕外绘制的图像。
VolatileImage | Component.createVolatileImage(int width, int height, ImageCapabilities caps) 创建一幅具有给定能力的、可变的、可在屏幕外绘制的图像。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.WritableRaster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.WritableRaster
的使用

使用 WritableRaster 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 WritableRaster 的使用

参数类型为 WritableRaster 的 java.awt 中的方法
 void CompositeContext.compose(Raster src, Raster dstIn, WritableRaster dstOut)
组合两个源 Raster 对象并将结果置于目标 WritableRaster 中。

java.awt.image 中 WritableRaster 的使用

返回 WritableRaster 的 java.awt.image 中的方法
WritableRaster | BufferedImage.copyData(WritableRaster outRaster) 计算 BufferedImage 的一个任意矩形区域，并将其复制到指定的 WritableRaster。
WritableRaster | RenderedImage.copyData(WritableRaster raster) 计算 RenderedImage 的任意矩形区域，并将其复制到调用者提供的 WritableRaster 中。
static WritableRaster | Raster.createBandedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | Raster.createBandedRaster(int dataType, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | Raster.createBandedRaster(int dataType, int w, int h, int bands, Point location) 根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
WritableRaster | AffineTransformOp.createCompatibleDestRaster(Raster src) 创建一个具有正确大小和 band 数的经过检查的目标 Raster。
WritableRaster | BandCombineOp.createCompatibleDestRaster(Raster src) 创建一个经过检查的目标 Raster，它具有正确大小和 band 数。
WritableRaster | ColorConvertOp.createCompatibleDestRaster(Raster src) 创建给定源且具有正确 band 大小和数量的归零目标 Raster。
WritableRaster | ConvolveOp.createCompatibleDestRaster(Raster src) 创建给定源且具有正确 band 大小和数量的归零目标 Raster。
WritableRaster | LookupOp.createCompatibleDestRaster(Raster src) 在给定源 Raster 的情况下，创建一幅具有正确大小和 band 数的、经过检查的目标 Raster。
WritableRaster | RasterOp.createCompatibleDestRaster(Raster src) 创建一个具有正确大小和 band 数的归零目标 Raster。
WritableRaster | RescaleOp.createCompatibleDestRaster(Raster src) 在给出源的情况下，创建一个具有正确大小和 band 数的经检查的目标 Raster。
WritableRaster | Raster.createCompatibleWritableRaster() 创建一个兼容的 WritableRaster，使其具有与此 Raster 相同的大小、SampleModel，以及一个新初始化的 DataBuffer。
WritableRaster | ComponentColorModel.createCompatibleWritableRaster(int w, int h) 用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。
WritableRaster | Raster.createCompatibleWritableRaster(int w, int h) 创建一个兼容的 WritableRaster，使其具有指定大小、新 SampleModel 和新初始化的 DataBuffer。
WritableRaster | IndexColorModel.createCompatibleWritableRaster(int w, int h) 创建一个具有指定宽度和高度、数据布局 (SampleModel) 与此 ColorModel 兼容的 WritableRaster。
WritableRaster | DirectColorModel.createCompatibleWritableRaster(int w, int h) 创建具有指定宽度和高度、拥有与此 ColorModel 兼容的数据布局 (SampleModel) 的 WritableRaster。
WritableRaster | ColorModel.createCompatibleWritableRaster(int w, int h) 用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。
WritableRaster | Raster.createCompatibleWritableRaster(int x, int y, int w, int h) 创建一个兼容的 WritableRaster，使其具有指定位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
WritableRaster | Raster.createCompatibleWritableRaster(Rectangle rect) 创建一个兼容的 WritableRaster，使其具有由 rect 指定的位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
static WritableRaster | Raster.createInterleavedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | Raster.createInterleavedRaster(int dataType, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | Raster.createInterleavedRaster(int dataType, int w, int h, int bands, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location) 根据 MultiPixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度和每像素位数的 Raster。
static WritableRaster | Raster.createPackedRaster(int dataType, int w, int h, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 掩码的 Raster。
static WritableRaster | Raster.createPackedRaster(int dataType, int w, int h, int bands, int bitsPerBand, Point location) 根据打包的 SampleModel 创建一个具有指定数据类型、宽度、高度、band 数和每 band 位数的 Raster。
WritableRaster | WritableRaster.createWritableChild(int parentX, int parentY, int w, int h, int childMinX, int childMinY, int[] bandList) 返回新的 WritableRaster，它共享此 WritableRaster 的全部或部分 DataBuffer。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, DataBuffer db, Point location) 创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, Point location) 创建一个具有指定 SampleModel 的 WritableRaster。
WritableRaster | WritableRaster.createWritableTranslatedChild(int childMinX, int childMinY) 在不同的位置上创建一个与此 WritableRaster 具有相同大小、SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster | AffineTransformOp.filter(Raster src, WritableRaster dst) 转换源 Raster 并将结果存储在目标 Raster 中。
WritableRaster | BandCombineOp.filter(Raster src, WritableRaster dst) 使用构造方法中指定的矩阵变换该 Raster。
WritableRaster | ColorConvertOp.filter(Raster src, WritableRaster dest) 对源 Raster 中的图像数据进行颜色转换。
WritableRaster | ConvolveOp.filter(Raster src, WritableRaster dst) 对 Raster 执行卷积运算。
WritableRaster | LookupOp.filter(Raster src, WritableRaster dst) 在 Raster 上执行查找操作。
WritableRaster | RasterOp.filter(Raster src, WritableRaster dest) 执行从源 Raster 到目标 Raster 的单输入/单输出操作。
WritableRaster | RescaleOp.filter(Raster src, WritableRaster dst) 对源 Raster 中的像素数据进行重缩放。
WritableRaster | BufferedImage.getAlphaRaster() 返回一个 WritableRaster，它使用支持单独空间 alpha 通道的 ColorModel 对象（比如 ComponentColorModel 和 DirectColorModel）表示 BufferedImage 对象的 alpha 通道。
WritableRaster | ComponentColorModel.getAlphaRaster(WritableRaster raster) 返回表示某图像（从输入 Raster 提取）的 alpha 通道的 Raster。
WritableRaster | PackedColorModel.getAlphaRaster(WritableRaster raster) 返回从输入 WritableRaster 提取，并且表示图像 alpha 通道的 WritableRaster。
WritableRaster | ColorModel.getAlphaRaster(WritableRaster raster) 返回表示图像（从输入 Raster 中提取）的 alpha 通道的 Raster，除非此 ColorModel 的像素值将颜色和 alpha 信息表示为独立的空间 band（如 ComponentColorModel 和 DirectColorModel）。
WritableRaster | BufferedImage.getRaster() 返回 WritableRaster。
WritableRaster | WritableRaster.getWritableParent() 返回此 WritableRaster 的父 WritableRaster（如果有），否则返回 null。
WritableRaster | BufferedImage.getWritableTile(int tileX, int tileY) 为写入签出一个 tile。
WritableRaster | WritableRenderedImage.getWritableTile(int tileX, int tileY) 为写入签出一个 tile。

参数类型为 WritableRaster 的 java.awt.image 中的方法
ColorModel | ComponentColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
ColorModel | DirectColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定此 ColorModel 现在已对该数据进行正确描述。
ColorModel | ColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
WritableRaster | BufferedImage.copyData(WritableRaster outRaster) 计算 BufferedImage 的一个任意矩形区域，并将其复制到指定的 WritableRaster。
WritableRaster | RenderedImage.copyData(WritableRaster raster) 计算 RenderedImage 的任意矩形区域，并将其复制到调用者提供的 WritableRaster 中。
WritableRaster | AffineTransformOp.filter(Raster src, WritableRaster dst) 转换源 Raster 并将结果存储在目标 Raster 中。
WritableRaster | BandCombineOp.filter(Raster src, WritableRaster dst) 使用构造方法中指定的矩阵变换该 Raster。
WritableRaster | ColorConvertOp.filter(Raster src, WritableRaster dest) 对源 Raster 中的图像数据进行颜色转换。
WritableRaster | ConvolveOp.filter(Raster src, WritableRaster dst) 对 Raster 执行卷积运算。
WritableRaster | LookupOp.filter(Raster src, WritableRaster dst) 在 Raster 上执行查找操作。
WritableRaster | RasterOp.filter(Raster src, WritableRaster dest) 执行从源 Raster 到目标 Raster 的单输入/单输出操作。
WritableRaster | RescaleOp.filter(Raster src, WritableRaster dst) 对源 Raster 中的像素数据进行重缩放。
WritableRaster | ComponentColorModel.getAlphaRaster(WritableRaster raster) 返回表示某图像（从输入 Raster 提取）的 alpha 通道的 Raster。
WritableRaster | PackedColorModel.getAlphaRaster(WritableRaster raster) 返回从输入 WritableRaster 提取，并且表示图像 alpha 通道的 WritableRaster。
WritableRaster | ColorModel.getAlphaRaster(WritableRaster raster) 返回表示图像（从输入 Raster 中提取）的 alpha 通道的 Raster，除非此 ColorModel 的像素值将颜色和 alpha 信息表示为独立的空间 band（如 ComponentColorModel 和 DirectColorModel）。

参数类型为 WritableRaster 的 java.awt.image 中的构造方法
BufferedImage(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
构造一个具有指定 ColorModel 和 Raster 的新 BufferedImage。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.image.WritableRenderedImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.WritableRenderedImage
的使用

使用 WritableRenderedImage 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 WritableRenderedImage 的使用

实现 WritableRenderedImage 的 java.awt.image 中的类
 class BufferedImage
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。

参数类型为 WritableRenderedImage 的 java.awt.image 中的方法
 void TileObserver.tileUpdate(WritableRenderedImage source, int tileX, int tileY, boolean willBeWritable)
即将被更新的 tile（此 tile 或者即将被获取以写入，或者正在从写入释放）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.awt.image.renderable (Java 2 Platform SE 6)

 java.awt.image.renderable
接口
ContextualRenderedImageFactory
RenderableImage
RenderedImageFactory
类
ParameterBlock
RenderableImageOp
RenderableImageProducer
RenderContext


接口 java.awt.image.renderable.ContextualRenderedImageFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.renderable.ContextualRenderedImageFactory
的使用

使用 ContextualRenderedImageFactory 的软件包
java.awt.image.renderable 提供用于生成与呈现无关的图像的类和接口。

java.awt.image.renderable 中 ContextualRenderedImageFactory 的使用

参数类型为 ContextualRenderedImageFactory 的 java.awt.image.renderable 中的构造方法
RenderableImageOp(ContextualRenderedImageFactory CRIF, ParameterBlock paramBlock)
根据给定 ContextualRenderedImageFactory 对象以及一个包含 RenderableImage 源和其他参数的 ParameterBlock 构造 RenderedImageOp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.renderable.ParameterBlock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.renderable.ParameterBlock
的使用

使用 ParameterBlock 的软件包
java.awt.image.renderable 提供用于生成与呈现无关的图像的类和接口。

java.awt.image.renderable 中 ParameterBlock 的使用

返回 ParameterBlock 的 java.awt.image.renderable 中的方法
ParameterBlock | ParameterBlock.add(byte b) 将一个 Byte 添加到此参数列表。
ParameterBlock | ParameterBlock.add(char c) 将一个 Character 添加到此参数列表。
ParameterBlock | ParameterBlock.add(double d) 将一个 Double 添加到此参数列表。
ParameterBlock | ParameterBlock.add(float f) 将一个 Float 添加到此参数列表。
ParameterBlock | ParameterBlock.add(int i) 将一个 Integer 添加到此参数列表。
ParameterBlock | ParameterBlock.add(long l) 将一个 Long 添加到此参数列表。
ParameterBlock | ParameterBlock.add(Object obj) 将一个 Object 添加到此参数列表。
ParameterBlock | ParameterBlock.add(short s) 将一个 Short 添加到此参数列表。
ParameterBlock | ParameterBlock.addSource(Object source) 将一个图像添加到源列表的末尾。
ParameterBlock | RenderableImageOp.getParameterBlock() 返回到对当前参数块的一个引用。
ParameterBlock | ParameterBlock.set(byte b, int index) 使用 Byte 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(char c, int index) 使用 Character 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(double d, int index) 使用 Double 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(float f, int index) 使用 Float 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(int i, int index) 使用 Integer 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(long l, int index) 使用 Long 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(Object obj, int index) 替换此参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(short s, int index) 使用 Short 替换参数列表中的一个 Object。
ParameterBlock | RenderableImageOp.setParameterBlock(ParameterBlock paramBlock) 更改操作的当前 ParameterBlock，允许编辑图像呈现链。
ParameterBlock | ParameterBlock.setSource(Object source, int index) 将源列表中的某个项替换为一个新源。

参数类型为 ParameterBlock 的 java.awt.image.renderable 中的方法
RenderedImage | RenderedImageFactory.create(ParameterBlock paramBlock, RenderingHints hints) 针对给定的 ParameterBlock 和 RenderingHints 创建表示成像操作（或操作链）结果的 RenderedImage。
RenderedImage | ContextualRenderedImageFactory.create(RenderContext renderContext, ParameterBlock paramBlock) 根据给定包含操作的源和参数的 RenderContext 和 ParameterBlock 创建一个呈现。
Rectangle2D | ContextualRenderedImageFactory.getBounds2D(ParameterBlock paramBlock) 返回操作的输出的边界框，该操作在与呈现无关的空间中给定的一组源上执行。
Object | ContextualRenderedImageFactory.getProperty(ParameterBlock paramBlock, String name) 获取由 name 参数指定的属性的适当实例。
RenderContext | ContextualRenderedImageFactory.mapRenderContext(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image) 将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。
ParameterBlock | RenderableImageOp.setParameterBlock(ParameterBlock paramBlock) 更改操作的当前 ParameterBlock，允许编辑图像呈现链。

参数类型为 ParameterBlock 的 java.awt.image.renderable 中的构造方法
RenderableImageOp(ContextualRenderedImageFactory CRIF, ParameterBlock paramBlock)
根据给定 ContextualRenderedImageFactory 对象以及一个包含 RenderableImage 源和其他参数的 ParameterBlock 构造 RenderedImageOp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.image.renderable.RenderableImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.renderable.RenderableImage
的使用

使用 RenderableImage 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。

java.awt 中 RenderableImage 的使用

参数类型为 RenderableImage 的 java.awt 中的方法
abstract  void Graphics2D.drawRenderableImage(RenderableImage img, AffineTransform xform)
呈现 RenderableImage，在绘制前进行从图像空间到用户空间的转换。

java.awt.image.renderable 中 RenderableImage 的使用

实现 RenderableImage 的 java.awt.image.renderable 中的类
 class RenderableImageOp
此类借助其相关的 ContextualRenderedImageFactory 实例处理某个操作的可呈现方面。

返回 RenderableImage 的 java.awt.image.renderable 中的方法
 RenderableImage ParameterBlock.getRenderableSource(int index)
返回作为 RenderableImage 的源。

返回变量类型为 RenderableImage 的类型的 java.awt.image.renderable 中的方法
Vector<RenderableImage> | RenderableImage.getSources() 返回作为此 RenderableImage 的图像数据源的 RenderableImage 的向量。
Vector<RenderableImage> | RenderableImageOp.getSources() 返回作为此 RenderableImage 图像数据源的 RenderableImage 的向量。

参数类型为 RenderableImage 的 java.awt.image.renderable 中的方法
 RenderContext ContextualRenderedImageFactory.mapRenderContext(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。

参数类型为 RenderableImage 的 java.awt.image.renderable 中的构造方法
RenderableImageProducer(RenderableImage rdblImage, RenderContext rc)
根据 RenderableImage 和 RenderContext 构造新的 RenderableImageProducer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.renderable.RenderableImageOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.renderable.RenderableImageOp
的使用

没有 java.awt.image.renderable.RenderableImageOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.renderable.RenderableImageProducer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.renderable.RenderableImageProducer
的使用

没有 java.awt.image.renderable.RenderableImageProducer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.image.renderable.RenderContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.renderable.RenderContext
的使用

使用 RenderContext 的软件包
java.awt.image.renderable 提供用于生成与呈现无关的图像的类和接口。

java.awt.image.renderable 中 RenderContext 的使用

返回 RenderContext 的 java.awt.image.renderable 中的方法
 RenderContext ContextualRenderedImageFactory.mapRenderContext(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。

参数类型为 RenderContext 的 java.awt.image.renderable 中的方法
 RenderedImage ContextualRenderedImageFactory.create(RenderContext renderContext, ParameterBlock paramBlock)
根据给定包含操作的源和参数的 RenderContext 和 ParameterBlock 创建一个呈现。
 RenderedImage RenderableImage.createRendering(RenderContext renderContext)
使用给定的 RenderContext 创建表示此图像一个呈现的 RenderedImage。
 RenderedImage RenderableImageOp.createRendering(RenderContext renderContext)
创建一个表示根据给定 RenderContext 呈现的 RenderableImageOp（包括其 Renderable 源）的 RenderedImage。
 RenderContext ContextualRenderedImageFactory.mapRenderContext(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。
 void RenderableImageProducer.setRenderContext(RenderContext rc)
设置下一次调用 startProduction() 要使用的新 RenderContext。

参数类型为 RenderContext 的 java.awt.image.renderable 中的构造方法
RenderableImageProducer(RenderableImage rdblImage, RenderContext rc)
根据 RenderableImage 和 RenderContext 构造新的 RenderableImageProducer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.image.renderable.RenderedImageFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.renderable.RenderedImageFactory
的使用

使用 RenderedImageFactory 的软件包
java.awt.image.renderable 提供用于生成与呈现无关的图像的类和接口。

java.awt.image.renderable 中 RenderedImageFactory 的使用

java.awt.image.renderable 中 RenderedImageFactory 的子接口
 interface ContextualRenderedImageFactory
ContextualRenderedImageFactory 为在 RenderableImageOp 实例之间可能不同的功能提供接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.awt.print (Java 2 Platform SE 6)

 java.awt.print
接口
Pageable
Printable
PrinterGraphics
类
Book
PageFormat
Paper
PrinterJob
异常
PrinterAbortException
PrinterException
PrinterIOException


类 java.awt.print.Book 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.Book
的使用

没有 java.awt.print.Book 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.print.Pageable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.print.Pageable
的使用

使用 Pageable 的软件包
java.awt.print 为通用的打印 API 提供类和接口。

java.awt.print 中 Pageable 的使用

实现 Pageable 的 java.awt.print 中的类
 class Book
Book 类提供文档的表示形式，该文档的页面可以使用不同的页面格式和页面 painter。

参数类型为 Pageable 的 java.awt.print 中的方法
abstract  void PrinterJob.setPageable(Pageable document)
查询 document，以获得页面数和 Pageable 实例 document 中保存的每个页面的 PageFormat 和 Printable。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.print.PageFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.PageFormat
的使用

使用 PageFormat 的软件包
java.awt.print 为通用的打印 API 提供类和接口。

java.awt.print 中 PageFormat 的使用

返回 PageFormat 的 java.awt.print 中的方法
 PageFormat PrinterJob.defaultPage()
创建新的 PageFormat 实例，并将它设置为默认大小和方向。
abstract  PageFormat PrinterJob.defaultPage(PageFormat page)
复制 PageFormat 参数，并更改该副本，以描述默认页面的大小和方向。
 PageFormat Book.getPageFormat(int pageIndex)
返回 pageIndex 指定的页面的 PageFormat。
 PageFormat Pageable.getPageFormat(int pageIndex)
返回 pageIndex 指定的页面的 PageFormat。
 PageFormat PrinterJob.getPageFormat(PrintRequestAttributeSet attributes)
使用与受此作业 PrintService 支持的那些值一致的值（即由 getPrintService() 返回的值），以及 attributes 中包含的介质、可打印区域和方向计算 PageFormat。
abstract  PageFormat PrinterJob.pageDialog(PageFormat page)
显示允许修改 PageFormat 实例的对话框。
 PageFormat PrinterJob.pageDialog(PrintRequestAttributeSet attributes)
显示跨平台页面设置对话框的便捷方法。
abstract  PageFormat PrinterJob.validatePage(PageFormat page)
返回 page 的副本，调整其设置，以与此 PrinterJob 的当前打印机兼容。

参数类型为 PageFormat 的 java.awt.print 中的方法
void | Book.append(Printable painter, PageFormat page) 将单个页面追加到此 Book 的尾部。
void | Book.append(Printable painter, PageFormat page, int numPages) 将 numPages 个页面追加到此 Book 的尾部。
abstract PageFormat | PrinterJob.defaultPage(PageFormat page) 复制 PageFormat 参数，并更改该副本，以描述默认页面的大小和方向。
abstract PageFormat | PrinterJob.pageDialog(PageFormat page) 显示允许修改 PageFormat 实例的对话框。
int | Printable.print(Graphics graphics, PageFormat pageFormat, int pageIndex) 将指定索引处的页面用指定格式打印到指定的 Graphics 上下文。
void | Book.setPage(int pageIndex, Printable painter, PageFormat page) 为指定的页码设置 PageFormat 和 Painter。
abstract void | PrinterJob.setPrintable(Printable painter, PageFormat format) 调用 painter，用指定的 format 呈现该页面。
abstract PageFormat | PrinterJob.validatePage(PageFormat page) 返回 page 的副本，调整其设置，以与此 PrinterJob 的当前打印机兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.print.Paper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.Paper
的使用

使用 Paper 的软件包
java.awt.print 为通用的打印 API 提供类和接口。

java.awt.print 中 Paper 的使用

返回 Paper 的 java.awt.print 中的方法
 Paper PageFormat.getPaper()
返回与此 PageFormat 相关的 Paper 对象的一个副本。

参数类型为 Paper 的 java.awt.print 中的方法
 void PageFormat.setPaper(Paper paper)
为此 PageFormat 设置 Paper 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.print.Printable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.print.Printable
的使用

使用 Printable 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 中 Printable 的使用

返回 Printable 的 java.awt.print 中的方法
Printable | Book.getPrintable(int pageIndex) 返回 Printable 实例，该实例负责呈现 pageIndex 指定的页面。
Printable | Pageable.getPrintable(int pageIndex) 返回负责呈现 pageIndex 指定的页面的 Printable 实例。

参数类型为 Printable 的 java.awt.print 中的方法
void | Book.append(Printable painter, PageFormat page) 将单个页面追加到此 Book 的尾部。
void | Book.append(Printable painter, PageFormat page, int numPages) 将 numPages 个页面追加到此 Book 的尾部。
void | Book.setPage(int pageIndex, Printable painter, PageFormat page) 为指定的页码设置 PageFormat 和 Painter。
abstract void | PrinterJob.setPrintable(Printable painter) 调用 painter 以呈现页面。
abstract void | PrinterJob.setPrintable(Printable painter, PageFormat format) 调用 painter，用指定的 format 呈现该页面。

javax.swing 中 Printable 的使用

返回 Printable 的 javax.swing 中的方法
 Printable JTable.getPrintable(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat)
返回打印此 JTable 中所使用的 Printable。

javax.swing.text 中 Printable 的使用

返回 Printable 的 javax.swing.text 中的方法
 Printable JTextComponent.getPrintable(MessageFormat headerFormat, MessageFormat footerFormat)
返回一个 Printable，用于打印此 JTextComponent 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.print.PrinterAbortException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.PrinterAbortException
的使用

没有 java.awt.print.PrinterAbortException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.print.PrinterException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.PrinterException
的使用

使用 PrinterException 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 中 PrinterException 的使用

java.awt.print 中 PrinterException 的子类
class | PrinterAbortException PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
class | PrinterIOException PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

抛出 PrinterException 的 java.awt.print 中的方法
abstract void | PrinterJob.print() 打印一组页面。
int | Printable.print(Graphics graphics, PageFormat pageFormat, int pageIndex) 将指定索引处的页面用指定格式打印到指定的 Graphics 上下文。
void | PrinterJob.print(PrintRequestAttributeSet attributes) 使用属性集中的设置打印一组页面。
void | PrinterJob.setPrintService(PrintService service) 将此 PrinterJob 与新的 PrintService 关联。

javax.swing 中 PrinterException 的使用

抛出 PrinterException 的 javax.swing 中的方法
boolean | JTable.print() 一个便捷的方法，它显示一个打印对话框，然后以 PrintMode.FIT_WIDTH 模式打印此 JTable，不打印标题或脚注文本。
boolean | JTable.print(JTable.PrintMode printMode) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，不打印标题或脚注文本。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，打印指定的标题和脚注文本。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。

javax.swing.text 中 PrinterException 的使用

抛出 PrinterException 的 javax.swing.text 中的方法
boolean | JTextComponent.print() 一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，不打印标题和脚注文本。
boolean | JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，打印指定的标题和脚注文本。
boolean | JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive) 打印此 JTextComponent 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.awt.print.PrinterGraphics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.print.PrinterGraphics
的使用

没有 java.awt.print.PrinterGraphics 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.print.PrinterIOException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.PrinterIOException
的使用

没有 java.awt.print.PrinterIOException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.awt.print.PrinterJob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.PrinterJob
的使用

使用 PrinterJob 的软件包
java.awt.print 为通用的打印 API 提供类和接口。

java.awt.print 中 PrinterJob 的使用

返回 PrinterJob 的 java.awt.print 中的方法
PrinterJob | PrinterGraphics.getPrinterJob() 返回正在控制当前呈现请求的 PrinterJob。
static PrinterJob | PrinterJob.getPrinterJob() 创建并返回初始化时与默认打印机关联的 PrinterJob。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.beans (Java 2 Platform SE 6)

 java.beans
接口
AppletInitializer
BeanInfo
Customizer
DesignMode
ExceptionListener
PropertyChangeListener
PropertyEditor
VetoableChangeListener
Visibility
类
BeanDescriptor
Beans
DefaultPersistenceDelegate
Encoder
EventHandler
EventSetDescriptor
Expression
FeatureDescriptor
IndexedPropertyChangeEvent
IndexedPropertyDescriptor
Introspector
MethodDescriptor
ParameterDescriptor
PersistenceDelegate
PropertyChangeEvent
PropertyChangeListenerProxy
PropertyChangeSupport
PropertyDescriptor
PropertyEditorManager
PropertyEditorSupport
SimpleBeanInfo
Statement
VetoableChangeListenerProxy
VetoableChangeSupport
XMLDecoder
XMLEncoder
异常
IntrospectionException
PropertyVetoException
注释类型
ConstructorProperties


java.beans.beancontext (Java 2 Platform SE 6)

 java.beans.beancontext
接口
BeanContext
BeanContextChild
BeanContextChildComponentProxy
BeanContextContainerProxy
BeanContextMembershipListener
BeanContextProxy
BeanContextServiceProvider
BeanContextServiceProviderBeanInfo
BeanContextServiceRevokedListener
BeanContextServices
BeanContextServicesListener
类
BeanContextChildSupport
BeanContextEvent
BeanContextMembershipEvent
BeanContextServiceAvailableEvent
BeanContextServiceRevokedEvent
BeanContextServicesSupport
BeanContextServicesSupport.BCSSServiceProvider
BeanContextSupport
BeanContextSupport.BCSIterator


接口 java.beans.beancontext.BeanContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContext
的使用

使用 BeanContext 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。

java.beans 中 BeanContext 的使用

参数类型为 BeanContext 的 java.beans 中的方法
void | AppletInitializer.initialize(Applet newAppletBean, BeanContext bCtxt) 如果传递给 java.beans.Beans.instantiate 的适当变体，将调用此方法来将新近实例化的 Applet (JavaBean) 与其 AppletContext、AppletStub 和 Container 相关联。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer) 实例化 bean。

java.beans.beancontext 中 BeanContext 的使用

java.beans.beancontext 中 BeanContext 的子接口
 interface BeanContextServices
BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 BeanContext 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

声明为 BeanContext 的 java.beans.beancontext 中的字段
protected BeanContext | BeanContextChildSupport.beanContext
protected BeanContext | BeanContextEvent.propagatedFrom 作为此事件传播源的 BeanContext

返回 BeanContext 的 java.beans.beancontext 中的方法
BeanContext | BeanContextChild.getBeanContext() 获得与此 BeanContextChild 相关联的 BeanContext。
BeanContext | BeanContextChildSupport.getBeanContext() 获得此 BeanContextChildSupport 的嵌套 BeanContext。
BeanContext | BeanContextEvent.getBeanContext() 获得与此事件相关联的 BeanContext。
BeanContext | BeanContextSupport.getBeanContextPeer() 获得 BeanContext 的实例，此对象将为其提供实现。
BeanContext | BeanContextEvent.getPropagatedFrom() 获得作为此事件传播源的 BeanContext。

参数类型为 BeanContext 的 java.beans.beancontext 中的方法
void | BeanContextChild.setBeanContext(BeanContext bc) 实现此接口的对象应使用以下参数激活一个 java.beans.PropertyChangeEvent：propertyName "beanContext"、oldValue（以前的嵌套 BeanContext 实例，或 null）、newValue（当前的嵌套 BeanContext 实例，或 null）。
void | BeanContextChildSupport.setBeanContext(BeanContext bc) 设置此 BeanContextChildSupport 的 BeanContext。
void | BeanContextEvent.setPropagatedFrom(BeanContext bc) 设置作为此事件传播源的 BeanContext。
boolean | BeanContextChildSupport.validatePendingSetBeanContext(BeanContext newValue) 从 setBeanContext 调用，以验证（或相反）嵌套 BeanContext 属性值中的挂起更改。

参数类型为 BeanContext 的 java.beans.beancontext 中的构造方法
BeanContextEvent(BeanContext bc)
构造一个 BeanContextEvent
BeanContextMembershipEvent(BeanContext bc, Collection changes)
构造一个 BeanContextMembershipEvent
BeanContextMembershipEvent(BeanContext bc, Object[] changes)
构造一个 BeanContextMembershipEvent
BeanContextSupport(BeanContext peer)
使用默认语言环境创建一个实例
BeanContextSupport(BeanContext peer, Locale lcle)
使用指定语言环境创建一个实例。
BeanContextSupport(BeanContext peer, Locale lcle, boolean dtime)
使用指定 Locale 和设计模式创建一个实例。
BeanContextSupport(BeanContext peer, Locale lcle, boolean dTime, boolean visible)
构造一个 BeanContextSupport 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.beancontext.BeanContextChild 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextChild
的使用

使用 BeanContextChild 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextChild 的使用

java.beans.beancontext 中 BeanContextChild 的子接口
interface | BeanContext BeanContext 是 JavaBean 的逻辑层次容器。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 BeanContextChild 的 java.beans.beancontext 中的类
class | BeanContextChildSupport 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

声明为 BeanContextChild 的 java.beans.beancontext 中的字段
 BeanContextChild BeanContextChildSupport.beanContextChildPeer
在其中嵌套此 BeanContextChild 的 BeanContext。

返回 BeanContextChild 的 java.beans.beancontext 中的方法
BeanContextChild | BeanContextChildSupport.getBeanContextChildPeer() 获得与此 BeanContextChildSupport 相关联的 BeanContextChild。
BeanContextChild | BeanContextProxy.getBeanContextProxy() 获得与此对象相关联的 BeanContextChild（或子接口）。
protected static BeanContextChild | BeanContextSupport.getChildBeanContextChild(Object child) 与指定 Child 相关联的 BeanContextChild（如果有）。

参数类型为 BeanContextChild 的 java.beans.beancontext 中的方法
 URL BeanContext.getResource(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 URL BeanContextSupport.getResource(String name, BeanContextChild bcc)
 InputStream BeanContext.getResourceAsStream(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 InputStream BeanContextSupport.getResourceAsStream(String name, BeanContextChild bcc)
 Object BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
 Object BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
获得一个可被委托的服务。
 void BeanContextServices.releaseService(BeanContextChild child, Object requestor, Object service)
通过在基础 BeanContextServiceProvider 上调用 releaseService() 释放 BeanContextChild（或与 BeanContextChild 关联的任意对象）对指定服务的引用。
 void BeanContextServicesSupport.releaseService(BeanContextChild child, Object requestor, Object service)
释放服务。

参数类型为 BeanContextChild 的 java.beans.beancontext 中的构造方法
BeanContextChildSupport(BeanContextChild bcc)
构造一个 BeanContextChildSupport，其中 JavaBean 组件自身实现 BeanContextChild 并封装它，并将该接口委托给此实现

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.beancontext.BeanContextChildComponentProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextChildComponentProxy
的使用

没有 java.beans.beancontext.BeanContextChildComponentProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextChildSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextChildSupport
的使用

使用 BeanContextChildSupport 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextChildSupport 的使用

java.beans.beancontext 中 BeanContextChildSupport 的子类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.beancontext.BeanContextContainerProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextContainerProxy
的使用

没有 java.beans.beancontext.BeanContextContainerProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextEvent
的使用

使用 BeanContextEvent 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextEvent 的使用

java.beans.beancontext 中 BeanContextEvent 的子类
class | BeanContextMembershipEvent BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。
class | BeanContextServiceAvailableEvent BeanContextServicesListener 使用此事件类型来标识将被注册的服务。
class | BeanContextServiceRevokedEvent BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextMembershipEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextMembershipEvent
的使用

使用 BeanContextMembershipEvent 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextMembershipEvent 的使用

参数类型为 BeanContextMembershipEvent 的 java.beans.beancontext 中的方法
void | BeanContextMembershipListener.childrenAdded(BeanContextMembershipEvent bcme) 在将一个子级或子级列表添加到此侦听器在其中注册的 BeanContext 中时调用。
void | BeanContextMembershipListener.childrenRemoved(BeanContextMembershipEvent bcme) 在将一个子级或子级列表从此侦听器在其中注册的 BeanContext 中移除时调用。
protected void | BeanContextSupport.fireChildrenAdded(BeanContextMembershipEvent bcme) 在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。
protected void | BeanContextSupport.fireChildrenRemoved(BeanContextMembershipEvent bcme) 在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.beancontext.BeanContextMembershipListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextMembershipListener
的使用

使用 BeanContextMembershipListener 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextMembershipListener 的使用

返回 BeanContextMembershipListener 的 java.beans.beancontext 中的方法
protected static BeanContextMembershipListener BeanContextSupport.getChildBeanContextMembershipListener(Object child)
与指定 Child 相关联的 BeanContextMembershipListener（如果有）。

参数类型为 BeanContextMembershipListener 的 java.beans.beancontext 中的方法
void | BeanContext.addBeanContextMembershipListener(BeanContextMembershipListener bcml) 添加指定的 BeanContextMembershipListener，以便无论何时添加或移除一个子 Component，都可以接收来自此 BeanContext 的 BeanContextMembershipEvents。
void | BeanContextSupport.addBeanContextMembershipListener(BeanContextMembershipListener bcml) 添加一个 BeanContextMembershipListener。
void | BeanContext.removeBeanContextMembershipListener(BeanContextMembershipListener bcml) 移除指定的 BeanContextMembershipListener，以便在添加或移除子 Component 时不再接收 BeanContextMembershipEvent。
void | BeanContextSupport.removeBeanContextMembershipListener(BeanContextMembershipListener bcml) 移除一个 BeanContextMembershipListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.beancontext.BeanContextProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextProxy
的使用

没有 java.beans.beancontext.BeanContextProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextServiceAvailableEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServiceAvailableEvent
的使用

使用 BeanContextServiceAvailableEvent 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServiceAvailableEvent 的使用

参数类型为 BeanContextServiceAvailableEvent 的 java.beans.beancontext 中的方法
protected void | BeanContextServicesSupport.fireServiceAdded(BeanContextServiceAvailableEvent bcssae) 触发一个指示新服务已变得可用的 BeanContextServiceAvailableEvent。
void | BeanContextChildSupport.serviceAvailable(BeanContextServiceAvailableEvent bcsae) 可从嵌套 BeanContext 中获得新的服务。
void | BeanContextServicesListener.serviceAvailable(BeanContextServiceAvailableEvent bcsae) 指定服务已被注册。
void | BeanContextServicesSupport.serviceAvailable(BeanContextServiceAvailableEvent bcssae) BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.beancontext.BeanContextServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextServiceProvider
的使用

使用 BeanContextServiceProvider 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServiceProvider 的使用

实现 BeanContextServiceProvider 的 java.beans.beancontext 中的类
protected  class BeanContextServicesSupport.BCSSProxyServiceProvider

声明为 BeanContextServiceProvider 的 java.beans.beancontext 中的字段
protected  BeanContextServiceProvider BeanContextServicesSupport.BCSSServiceProvider.serviceProvider

返回 BeanContextServiceProvider 的 java.beans.beancontext 中的方法
protected  BeanContextServiceProvider BeanContextServicesSupport.BCSSServiceProvider.getServiceProvider()

参数类型为 BeanContextServiceProvider 的 java.beans.beancontext 中的方法
 boolean BeanContextServices.addService(Class serviceClass, BeanContextServiceProvider serviceProvider)
向此 BeanContext 添加服务。
 boolean BeanContextServicesSupport.addService(Class serviceClass, BeanContextServiceProvider bcsp)
添加服务。
protected  boolean BeanContextServicesSupport.addService(Class serviceClass, BeanContextServiceProvider bcsp, boolean fireEvent)
添加服务。
protected  BeanContextServicesSupport.BCSSServiceProvider BeanContextServicesSupport.createBCSSServiceProvider(Class sc, BeanContextServiceProvider bcsp)
子类可以重写此方法来创建 BCSSServiceProvider 的新子类，而不必为了实例化而重写 addService()。
 void BeanContextServices.revokeService(Class serviceClass, BeanContextServiceProvider serviceProvider, boolean revokeCurrentServicesNow)
希望从此上下文中移除当前已注册服务的 BeanContextServiceProvider 可以通过调用此方法实现移除。
 void BeanContextServicesSupport.revokeService(Class serviceClass, BeanContextServiceProvider bcsp, boolean revokeCurrentServicesNow)
移除服务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.beancontext.BeanContextServiceProviderBeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextServiceProviderBeanInfo
的使用

没有 java.beans.beancontext.BeanContextServiceProviderBeanInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextServiceRevokedEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServiceRevokedEvent
的使用

使用 BeanContextServiceRevokedEvent 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServiceRevokedEvent 的使用

参数类型为 BeanContextServiceRevokedEvent 的 java.beans.beancontext 中的方法
protected void | BeanContextServicesSupport.fireServiceRevoked(BeanContextServiceRevokedEvent bcsre) 触发一个通知将被取消的服务的 BeanContextServiceEvent。
void | BeanContextChildSupport.serviceRevoked(BeanContextServiceRevokedEvent bcsre) 由嵌套 BeanContext 提供的服务已经被取消。
void | BeanContextServiceRevokedListener.serviceRevoked(BeanContextServiceRevokedEvent bcsre) 指定服务已被取消。
void | BeanContextServicesSupport.serviceRevoked(BeanContextServiceRevokedEvent bcssre) BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。
void | BeanContextServicesSupport.BCSSProxyServiceProvider.serviceRevoked(BeanContextServiceRevokedEvent bcsre)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.beancontext.BeanContextServiceRevokedListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextServiceRevokedListener
的使用

使用 BeanContextServiceRevokedListener 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServiceRevokedListener 的使用

java.beans.beancontext 中 BeanContextServiceRevokedListener 的子接口
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。
interface | BeanContextServicesListener 用于接收 BeanContextServiceAvailableEvent 对象的侦听器接口。

实现 BeanContextServiceRevokedListener 的 java.beans.beancontext 中的类
class | BeanContextChildSupport 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
protected class | BeanContextServicesSupport.BCSSProxyServiceProvider
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

参数类型为 BeanContextServiceRevokedListener 的 java.beans.beancontext 中的方法
Object | BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl) BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
Object | BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl) 获得一个可被委托的服务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.beancontext.BeanContextServices 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextServices
的使用

使用 BeanContextServices 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServices 的使用

实现 BeanContextServices 的 java.beans.beancontext 中的类
 class BeanContextServicesSupport
此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。

返回 BeanContextServices 的 java.beans.beancontext 中的方法
BeanContextServices | BeanContextServicesSupport.getBeanContextServicesPeer() 获得与此 BeanContextServicesSupport 相关联的 BeanContextServices。
BeanContextServices | BeanContextServiceAvailableEvent.getSourceAsBeanContextServices() 获得作为 BeanContextServices 类型引用的源。
BeanContextServices | BeanContextServiceRevokedEvent.getSourceAsBeanContextServices() 获得作为 BeanContextServices 类型引用的源

参数类型为 BeanContextServices 的 java.beans.beancontext 中的方法
Iterator | BeanContextServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass) 由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。
Iterator | BeanContextServicesSupport.BCSSProxyServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass)
Object | BeanContextServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector) 由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。
Object | BeanContextServicesSupport.BCSSProxyServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)
void | BeanContextServiceProvider.releaseService(BeanContextServices bcs, Object requestor, Object service) 由 BeanContextServices 调用，此方法释放一个对特定服务的嵌套 BeanContextChild（或与 BeanContextChild 关联的任意对象）的引用。
void | BeanContextServicesSupport.BCSSProxyServiceProvider.releaseService(BeanContextServices bcs, Object requestor, Object service)

参数类型为 BeanContextServices 的 java.beans.beancontext 中的构造方法
BeanContextServiceAvailableEvent(BeanContextServices bcs, Class sc)
构造一个 BeanContextAvailableServiceEvent。
BeanContextServiceRevokedEvent(BeanContextServices bcs, Class sc, boolean invalidate)
构造一个 BeanContextServiceEvent。
BeanContextServicesSupport(BeanContextServices peer)
创建一个具有同位体的实例
BeanContextServicesSupport(BeanContextServices peer, Locale lcle)
使用指定语言环境创建一个实例。
BeanContextServicesSupport(BeanContextServices peer, Locale lcle, boolean dtime)
使用指定 Locale 和设计模式创建一个实例。
BeanContextServicesSupport(BeanContextServices peer, Locale lcle, boolean dTime, boolean visible)
构造一个 BeanContextServicesSupport 实例

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.beancontext.BeanContextServicesListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextServicesListener
的使用

使用 BeanContextServicesListener 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServicesListener 的使用

java.beans.beancontext 中 BeanContextServicesListener 的子接口
 interface BeanContextServices
BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 BeanContextServicesListener 的 java.beans.beancontext 中的类
class | BeanContextChildSupport 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

返回 BeanContextServicesListener 的 java.beans.beancontext 中的方法
protected static BeanContextServicesListener BeanContextServicesSupport.getChildBeanContextServicesListener(Object child)
获得指定子级的 BeanContextServicesListener（如果有）。

参数类型为 BeanContextServicesListener 的 java.beans.beancontext 中的方法
void | BeanContextServices.addBeanContextServicesListener(BeanContextServicesListener bcsl) 将一个 BeanContextServicesListener 添加到此 BeanContext
void | BeanContextServicesSupport.addBeanContextServicesListener(BeanContextServicesListener bcsl) 添加一个 BeanContextServicesListener。
void | BeanContextServices.removeBeanContextServicesListener(BeanContextServicesListener bcsl) 从此 BeanContext 中移除一个 BeanContextServicesListener
void | BeanContextServicesSupport.removeBeanContextServicesListener(BeanContextServicesListener bcsl) 移除一个 BeanContextServicesListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextServicesSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServicesSupport
的使用

没有 java.beans.beancontext.BeanContextServicesSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextServicesSupport.BCSSChild 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServicesSupport.BCSSChild
的使用

没有 java.beans.beancontext.BeanContextServicesSupport.BCSSChild 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider
的使用

使用 BeanContextServicesSupport.BCSSProxyServiceProvider 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServicesSupport.BCSSProxyServiceProvider 的使用

声明为 BeanContextServicesSupport.BCSSProxyServiceProvider 的 java.beans.beancontext 中的字段
protected  BeanContextServicesSupport.BCSSProxyServiceProvider BeanContextServicesSupport.proxy
BeanContextServiceProvider 的委托。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider
的使用

使用 BeanContextServicesSupport.BCSSServiceProvider 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServicesSupport.BCSSServiceProvider 的使用

返回 BeanContextServicesSupport.BCSSServiceProvider 的 java.beans.beancontext 中的方法
protected  BeanContextServicesSupport.BCSSServiceProvider BeanContextServicesSupport.createBCSSServiceProvider(Class sc, BeanContextServiceProvider bcsp)
子类可以重写此方法来创建 BCSSServiceProvider 的新子类，而不必为了实例化而重写 addService()。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextSupport
的使用

使用 BeanContextSupport 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextSupport 的使用

java.beans.beancontext 中 BeanContextSupport 的子类
 class BeanContextServicesSupport
此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextSupport.BCSChild 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextSupport.BCSChild
的使用

使用 BeanContextSupport.BCSChild 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextSupport.BCSChild 的使用

java.beans.beancontext 中 BeanContextSupport.BCSChild 的子类
protected  class BeanContextServicesSupport.BCSSChild

返回 BeanContextSupport.BCSChild 的 java.beans.beancontext 中的方法
protected  BeanContextSupport.BCSChild BeanContextServicesSupport.createBCSChild(Object targetChild, Object peer)
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。
protected  BeanContextSupport.BCSChild BeanContextSupport.createBCSChild(Object targetChild, Object peer)
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。

参数类型为 BeanContextSupport.BCSChild 的 java.beans.beancontext 中的方法
protected  void BeanContextSupport.childDeserializedHook(Object child, BeanContextSupport.BCSChild bcsc)
由 readObject 利用新近反序列化的子级和 BCSChild 调用。
protected  void BeanContextSupport.childJustAddedHook(Object child, BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经添加子对象之后，且在发生事件通知之前，只扩展 add() 语义。
protected  void BeanContextServicesSupport.childJustRemovedHook(Object child, BeanContextSupport.BCSChild bcsc)
在已成功移除子级之后，从超类的子级移除操作中调用。
protected  void BeanContextSupport.childJustRemovedHook(Object child, BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经移除子对象之后，且在发生事件通知之前，只扩展 remove() 语义。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.beancontext.BeanContextSupport.BCSIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextSupport.BCSIterator
的使用

没有 java.beans.beancontext.BeanContextSupport.BCSIterator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.AppletInitializer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.AppletInitializer
的使用

使用 AppletInitializer 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 AppletInitializer 的使用

参数类型为 AppletInitializer 的 java.beans 中的方法
static Object Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
实例化 bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.BeanDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.BeanDescriptor
的使用

使用 BeanDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 BeanDescriptor 的使用

返回 BeanDescriptor 的 java.beans 中的方法
BeanDescriptor | BeanInfo.getBeanDescriptor() 获得 beans BeanDescriptor。
BeanDescriptor | SimpleBeanInfo.getBeanDescriptor() 拒绝关于 bean 的类和 customizer 的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.BeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.BeanInfo
的使用

使用 BeanInfo 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。

java.beans 中 BeanInfo 的使用

实现 BeanInfo 的 java.beans 中的类
 class SimpleBeanInfo
这是一个使得用户提供 BeanInfo 类更容易的支持类。

返回 BeanInfo 的 java.beans 中的方法
BeanInfo[] | BeanInfo.getAdditionalBeanInfo() 此方法允许 BeanInfo 对象返回提供关于当前 bean 额外信息的 BeanInfo 对象组成的任意集合。
BeanInfo[] | SimpleBeanInfo.getAdditionalBeanInfo() 声明没有其他有关的 BeanInfo 对象。
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass) 在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件。
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass, Class<?> stopClass) 在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass, int flags) 在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件，并将结果用一些控制标记表示。

java.beans.beancontext 中 BeanInfo 的使用

java.beans.beancontext 中 BeanInfo 的子接口
 interface BeanContextServiceProviderBeanInfo
希望提供关于其 bean 可能提供服务的显式消息的 BeanContextServiceProvider 实现者应实现某个 BeanInfo 类，该类实现此 BeanInfo 的子接口并提供有关其服务的方法、属性、事件等显式信息。

返回 BeanInfo 的 java.beans.beancontext 中的方法
 BeanInfo[] BeanContextServiceProviderBeanInfo.getServicesBeanInfo()
获得一个 BeanInfo 数组，为每个可从此 ServiceProvider 中静态得到的类或接口返回一个数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.Beans 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.Beans
的使用

没有 java.beans.Beans 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.ConstructorProperties 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.ConstructorProperties
的使用

使用 ConstructorProperties 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 ConstructorProperties 的使用

注释类型为 ConstructorProperties 的 java.lang.management 中的构造方法
LockInfo(String className, int identityHashCode)
构造一个 LockInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.Customizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.Customizer
的使用

没有 java.beans.Customizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.DefaultPersistenceDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.DefaultPersistenceDelegate
的使用

没有 java.beans.DefaultPersistenceDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.DesignMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.DesignMode
的使用

使用 DesignMode 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 DesignMode 的使用

java.beans.beancontext 中 DesignMode 的子接口
interface | BeanContext BeanContext 是 JavaBean 的逻辑层次容器。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 DesignMode 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.Encoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.Encoder
的使用

使用 Encoder 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 Encoder 的使用

java.beans 中 Encoder 的子类
 class XMLEncoder
XMLEncoder 类是 ObjectOutputStream 的互补替换，可用于生成 JavaBean 的文本表示形式，所使用方式与用 ObjectOutputStream 创建 Serializable 对象的二进制表示形式的方式相同。

参数类型为 Encoder 的 java.beans 中的方法
protected void | DefaultPersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out) initialize 方法的此默认实现假设保存在此类型对象中的所有状态都是通过匹配 "setter" 和 "getter" 方法对来公开的，公开的顺序是 Introspector 返回它们的顺序。
protected void | PersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out) 产生一系列对 newInstance 有副作用的语句，使得新实例等于 oldInstance。
protected Expression | DefaultPersistenceDelegate.instantiate(Object oldInstance, Encoder out) instantiate 方法的此默认实现返回一个表达式，该表达式包含预先定义的方法名称 "new"，该名称表示调用带有参数（在 DefaultPersistenceDelegate 的构造方法中指定）的构造方法。
protected abstract Expression | PersistenceDelegate.instantiate(Object oldInstance, Encoder out) 返回其值为 oldInstance 的表达式。
void | PersistenceDelegate.writeObject(Object oldInstance, Encoder out) writeObject 是持久性的一个入口点，由传统委托模式中的 Encoder 使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.EventHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.EventHandler
的使用

没有 java.beans.EventHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.EventSetDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.EventSetDescriptor
的使用

使用 EventSetDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 EventSetDescriptor 的使用

返回 EventSetDescriptor 的 java.beans 中的方法
EventSetDescriptor[] | BeanInfo.getEventSetDescriptors() 获得 beans EventSetDescriptor。
EventSetDescriptor[] | SimpleBeanInfo.getEventSetDescriptors() 拒绝事件集的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.ExceptionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.ExceptionListener
的使用

使用 ExceptionListener 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 ExceptionListener 的使用

返回 ExceptionListener 的 java.beans 中的方法
ExceptionListener | Encoder.getExceptionListener() 获得此流的异常处理程序。
ExceptionListener | XMLDecoder.getExceptionListener() 获得此流的异常处理程序。

参数类型为 ExceptionListener 的 java.beans 中的方法
void | Encoder.setExceptionListener(ExceptionListener exceptionListener) 将此流的异常处理程序设置为 exceptionListener。
void | XMLDecoder.setExceptionListener(ExceptionListener exceptionListener) 将此流的异常处理程序设置为 exceptionListener。

参数类型为 ExceptionListener 的 java.beans 中的构造方法
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.Expression 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.Expression
的使用

使用 Expression 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 Expression 的使用

返回 Expression 的 java.beans 中的方法
protected Expression | DefaultPersistenceDelegate.instantiate(Object oldInstance, Encoder out) instantiate 方法的此默认实现返回一个表达式，该表达式包含预先定义的方法名称 "new"，该名称表示调用带有参数（在 DefaultPersistenceDelegate 的构造方法中指定）的构造方法。
protected abstract Expression | PersistenceDelegate.instantiate(Object oldInstance, Encoder out) 返回其值为 oldInstance 的表达式。

参数类型为 Expression 的 java.beans 中的方法
void | Encoder.writeExpression(Expression oldExp) 该实现首先查看使用此值的表达式是否已经被写入。
void | XMLEncoder.writeExpression(Expression oldExp) 记录 Expression，以便 Encoder 在刷新流的缓存时产生实际输出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.FeatureDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.FeatureDescriptor
的使用

使用 FeatureDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 FeatureDescriptor 的使用

java.beans 中 FeatureDescriptor 的子类
class | BeanDescriptor BeanDescriptor 提供有关 "bean" 的全局信息，其中包括其 Java 类、其 displayName 等等。
class | EventSetDescriptor 描述给定 Java bean 激发的一组事件的 EventSetDescriptor。
class | IndexedPropertyDescriptor IndexedPropertyDescriptor 描述了类似数组行为的属性，且有一种访问数组特定元素的索引读和/或索引写方法。
class | MethodDescriptor MethodDescriptor 描述了一种特殊方法，即 Java Bean 支持从其他组件对其进行外部访问。
class | ParameterDescriptor ParameterDescriptor 类允许 bean 实现者提供除 java.lang.reflect.Method 类提供的低级别信息之外的关于其每个参数的额外信息。
class | PropertyDescriptor PropertyDescriptor 描述 Java Bean 通过一对存储器方法导出的一个属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.IndexedPropertyChangeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.IndexedPropertyChangeEvent
的使用

没有 java.beans.IndexedPropertyChangeEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.IndexedPropertyDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.IndexedPropertyDescriptor
的使用

没有 java.beans.IndexedPropertyDescriptor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.IntrospectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.IntrospectionException
的使用

使用 IntrospectionException 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 IntrospectionException 的使用

抛出 IntrospectionException 的 java.beans 中的方法
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass) 在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件。
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass, Class<?> stopClass) 在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass, int flags) 在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件，并将结果用一些控制标记表示。
void | IndexedPropertyDescriptor.setIndexedReadMethod(Method readMethod) 设置应该用于读取索引属性值的方法。
void | IndexedPropertyDescriptor.setIndexedWriteMethod(Method writeMethod) 设置应该用于写入索引属性值的方法。
void | PropertyDescriptor.setReadMethod(Method readMethod) 设置应该用于读取属性值的方法。
void | PropertyDescriptor.setWriteMethod(Method writeMethod) 设置应该用于写入属性值的方法。

抛出 IntrospectionException 的 java.beans 中的构造方法
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
IndexedPropertyDescriptor(String propertyName, Class<?> beanClass)
此构造方法通过 getFoo 和 setFoo 存取方法为符合标准 Java 约定的属性构造 IndexedPropertyDescriptor，将其用于索引访问和数组访问。
IndexedPropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称，它们都是带索引的或不带索引的。
IndexedPropertyDescriptor(String propertyName, Method readMethod, Method writeMethod, Method indexedReadMethod, Method indexedWriteMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。
PropertyDescriptor(String propertyName, Class<?> beanClass)
通过调用 getFoo 和 setFoo 存取方法，为符合标准 Java 约定的属性构造一个 PropertyDescriptor。
PropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称。
PropertyDescriptor(String propertyName, Method readMethod, Method writeMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.Introspector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.Introspector
的使用

没有 java.beans.Introspector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.MethodDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.MethodDescriptor
的使用

使用 MethodDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 MethodDescriptor 的使用

返回 MethodDescriptor 的 java.beans 中的方法
MethodDescriptor[] | EventSetDescriptor.getListenerMethodDescriptors() 获得目标侦听器接口的 MethodDescriptor。
MethodDescriptor[] | BeanInfo.getMethodDescriptors() 获得 beans MethodDescriptor。
MethodDescriptor[] | SimpleBeanInfo.getMethodDescriptors() 拒绝方法的信息。

参数类型为 MethodDescriptor 的 java.beans 中的构造方法
EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.ParameterDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.ParameterDescriptor
的使用

使用 ParameterDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 ParameterDescriptor 的使用

返回 ParameterDescriptor 的 java.beans 中的方法
 ParameterDescriptor[] MethodDescriptor.getParameterDescriptors()
获得此 MethodDescriptor 每个方法参数的 ParameterDescriptor。

参数类型为 ParameterDescriptor 的 java.beans 中的构造方法
MethodDescriptor(Method method, ParameterDescriptor[] parameterDescriptors)
根据为每个方法参数提供描述性信息的 Method 构造一个 MethodDescriptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.PersistenceDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PersistenceDelegate
的使用

使用 PersistenceDelegate 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 PersistenceDelegate 的使用

java.beans 中 PersistenceDelegate 的子类
 class DefaultPersistenceDelegate
DefaultPersistenceDelegate 是 PersistenceDelegate 抽象类的具体实现，是没有关于其可用信息的类在默认情况下使用的委托。

返回 PersistenceDelegate 的 java.beans 中的方法
 PersistenceDelegate Encoder.getPersistenceDelegate(Class<?> type)
返回给定类型的持久委托。

参数类型为 PersistenceDelegate 的 java.beans 中的方法
 void Encoder.setPersistenceDelegate(Class<?> type, PersistenceDelegate persistenceDelegate)
将与此 type 相关联的持久委托设置为 persistenceDelegate。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.PropertyChangeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyChangeEvent
的使用

使用 PropertyChangeEvent 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

java.beans 中 PropertyChangeEvent 的使用

java.beans 中 PropertyChangeEvent 的子类
 class IndexedPropertyChangeEvent
无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。

返回 PropertyChangeEvent 的 java.beans 中的方法
 PropertyChangeEvent PropertyVetoException.getPropertyChangeEvent()
获得禁止的 PropertyChangeEvent。

参数类型为 PropertyChangeEvent 的 java.beans 中的方法
void | PropertyChangeSupport.firePropertyChange(PropertyChangeEvent evt) 对所有已注册侦听器激发一个现有 PropertyChangeEvent。
void | VetoableChangeSupport.fireVetoableChange(PropertyChangeEvent evt) 对所有已注册侦听器激发一个 vetoable 属性更新。
void | PropertyChangeListenerProxy.propertyChange(PropertyChangeEvent evt) 将属性更改事件转发给侦听器代理。
void | PropertyChangeListener.propertyChange(PropertyChangeEvent evt) 在绑定属性发生更改时调用此方法。
void | VetoableChangeListenerProxy.vetoableChange(PropertyChangeEvent evt) 将属性更改事件转发给侦听器代理。
void | VetoableChangeListener.vetoableChange(PropertyChangeEvent evt) 在约束属性发生更改时调用此方法。

参数类型为 PropertyChangeEvent 的 java.beans 中的构造方法
PropertyVetoException(String mess, PropertyChangeEvent evt)
构造带详细消息的 PropertyVetoException。

java.beans.beancontext 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 java.beans.beancontext 中的方法
void | BeanContextSupport.propertyChange(PropertyChangeEvent pce) 子类可以封装此方法来监视子类属性的更改。
void | BeanContextSupport.vetoableChange(PropertyChangeEvent pce) 子类可以封装此方法来监视子类属性的更改。

javax.swing 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 javax.swing 中的方法
void | JSpinner.DefaultEditor.propertyChange(PropertyChangeEvent e) 由 JFormattedTextField 的 PropertyChangeListener 调用。
void | ProgressMonitor.AccessibleProgressMonitor.propertyChange(PropertyChangeEvent e) 更改绑定 (bound) 属性时，调用此方法。
void | JTable.AccessibleJTable.propertyChange(PropertyChangeEvent e) 跟踪选择模型、列模型等的变更，从而能够重新将侦听器放置这些模型上，以便把信息传递给 Accessibility PropertyChange 机制
void | JScrollPane.AccessibleJScrollPane.propertyChange(PropertyChangeEvent e) 当有一个绑定 (bound) 属性改变时，此方法被调用。
void | JList.AccessibleJList.propertyChange(PropertyChangeEvent e) Property Change Listener 更改方法。
void | JPopupMenu.AccessibleJPopupMenu.propertyChange(PropertyChangeEvent e) 更改绑定 (bound) 属性时调用此方法。

javax.swing.event 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 javax.swing.event 中的方法
 void SwingPropertyChangeSupport.firePropertyChange(PropertyChangeEvent evt)
对所有已注册侦听器激发一个现有 PropertyChangeEvent。

javax.swing.plaf.basic 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 javax.swing.plaf.basic 中的方法
void | BasicColorChooserUI.PropertyHandler.propertyChange(PropertyChangeEvent e)
void | BasicDirectoryModel.propertyChange(PropertyChangeEvent e)
protected void | BasicEditorPaneUI.propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，调用此方法。
void | BasicInternalFrameTitlePane.PropertyChangeHandler.propertyChange(PropertyChangeEvent evt)
void | BasicInternalFrameUI.InternalFramePropertyChangeListener.propertyChange(PropertyChangeEvent evt) 从 JInternalFrame 检测状态更改并处理动作。
void | BasicOptionPaneUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e) 如果 PropertyChangeEvent e 的源等于 optionPane 并且为 ICON_PROPERTY、MESSAGE_PROPERTY、OPTIONS_PROPERTY 或 INITIAL_VALUE_PROPERTY 之一，则调用 validateComponent。
protected void | BasicTextPaneUI.propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。
void | BasicSliderUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
protected void | BasicTextAreaUI.propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。
void | BasicSplitPaneDivider.propertyChange(PropertyChangeEvent e) 属性更改事件（假定发自 JSplitPane）将在必要时传递 updateOrientation 的消息。
void | BasicSplitPaneUI.PropertyHandler.propertyChange(PropertyChangeEvent e) 从包含接收者的 JSplitPane 传递消息。
void | BasicTreeUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent event)
void | BasicTreeUI.SelectionModelPropertyChangeHandler.propertyChange(PropertyChangeEvent event)
void | BasicTabbedPaneUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
protected void | BasicTextUI.propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定属性更改时，此方法被调用。
void | BasicScrollPaneUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
void | BasicListUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
void | BasicComboPopup.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
void | BasicComboBoxUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
void | BasicScrollBarUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
void | BasicToolBarUI.PropertyListener.propertyChange(PropertyChangeEvent e)
void | BasicButtonListener.propertyChange(PropertyChangeEvent e)
void | BasicLabelUI.propertyChange(PropertyChangeEvent e)
void | BasicRootPaneUI.propertyChange(PropertyChangeEvent e) 在根窗格上发生属性更改时调用。
protected void | BasicScrollPaneUI.updateColumnHeader(PropertyChangeEvent e)
protected void | BasicScrollPaneUI.updateRowHeader(PropertyChangeEvent e)
protected void | BasicScrollPaneUI.updateScrollBarDisplayPolicy(PropertyChangeEvent e)
protected void | BasicScrollPaneUI.updateViewport(PropertyChangeEvent e)

javax.swing.plaf.metal 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 javax.swing.plaf.metal 中的方法
protected void | MetalComboBoxUI.editablePropertyChanged(PropertyChangeEvent e) 已过时。 从 Java 2 platform v1.4 开始。
void | MetalFileChooserUI.FilterComboBoxModel.propertyChange(PropertyChangeEvent e)
void | MetalSliderUI.MetalPropertyListener.propertyChange(PropertyChangeEvent e)
void | MetalTextFieldUI.propertyChange(PropertyChangeEvent evt) 此方法在关联的 JTextComponent 上的绑定 (bound) 属性发生更改时调用。
void | MetalComboBoxUI.MetalPropertyChangeListener.propertyChange(PropertyChangeEvent e)
void | MetalRootPaneUI.propertyChange(PropertyChangeEvent e) 属性更改时调用。

javax.swing.table 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 javax.swing.table 中的方法
 void DefaultTableColumnModel.propertyChange(PropertyChangeEvent evt)
Property Change Listener 更改方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.PropertyChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.PropertyChangeListener
的使用

使用 PropertyChangeListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 PropertyChangeListener 的使用

返回 PropertyChangeListener 的 java.awt 中的方法
PropertyChangeListener[] | KeyboardFocusManager.getPropertyChangeListeners() 返回在此键盘焦点管理器上注册的所有属性更改侦听器组成的数组。
PropertyChangeListener[] | Toolkit.getPropertyChangeListeners() 返回在此工具包上所有已注册的属性更改侦听器所组成的数组。
PropertyChangeListener[] | Component.getPropertyChangeListeners() 返回在此组件上所有已注册的属性更改侦听器的数组。
PropertyChangeListener[] | SystemTray.getPropertyChangeListeners(String propertyName) 返回与指定属性关联的所有侦听器的数组。
PropertyChangeListener[] | KeyboardFocusManager.getPropertyChangeListeners(String propertyName) 返回与指定属性相关联的所有 PropertyChangeListener 组成的数组。
PropertyChangeListener[] | Toolkit.getPropertyChangeListeners(String propertyName) 返回与指定属性关联的所有 PropertyChangeListener 所组成的数组。
PropertyChangeListener[] | Component.getPropertyChangeListeners(String propertyName) 返回与指定属性相关联的所有侦听器的数组。

参数类型为 PropertyChangeListener 的 java.awt 中的方法
void | KeyboardFocusManager.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | Window.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | Container.addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表中。
void | Container.AccessibleAWTContainer.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
void | Component.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
void | Component.AccessibleAWTComponent.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表中。
void | SystemTray.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 将 PropertyChangeListener 添加到特定属性的侦听器列表中。
void | KeyboardFocusManager.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 将 PropertyChangeListener 添加到特定属性的侦听器列表。
void | Toolkit.addPropertyChangeListener(String name, PropertyChangeListener pcl) 为指定的桌面属性添加指定的属性更改侦听器。
void | Window.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 将 PropertyChangeListener 添加到某个特定属性的侦听器列表。
void | Container.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到某个指定属性的侦听器列表中。
void | Component.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 向指定属性的侦听器列表添加一个 PropertyChangeListener。
void | KeyboardFocusManager.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除 PropertyChangeListener。
void | Component.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。
void | Component.AccessibleAWTComponent.removePropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 从侦听器列表中移除。
void | SystemTray.removePropertyChangeListener(String propertyName, PropertyChangeListener listener) 从特定属性的侦听器列表中移除 PropertyChangeListener。
void | KeyboardFocusManager.removePropertyChangeListener(String propertyName, PropertyChangeListener listener) 从特定属性的侦听器列表移除 PropertyChangeListener。
void | Toolkit.removePropertyChangeListener(String name, PropertyChangeListener pcl) 为指定的桌面属性移除指定的属性更改侦听器。
void | Component.removePropertyChangeListener(String propertyName, PropertyChangeListener listener) 从指定属性的侦听器列表中移除一个 PropertyChangeListener。

java.beans 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 java.beans 中的类
 class PropertyChangeListenerProxy
扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。

返回 PropertyChangeListener 的 java.beans 中的方法
 PropertyChangeListener[] PropertyChangeSupport.getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 PropertyChangeSupport 对象中的所有侦听器组成的数组。
 PropertyChangeListener[] PropertyChangeSupport.getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器的列表。

参数类型为 PropertyChangeListener 的 java.beans 中的方法
void | Customizer.addPropertyChangeListener(PropertyChangeListener listener) 注册一个用于 PropertyChange 事件的侦听器。
void | PropertyEditor.addPropertyChangeListener(PropertyChangeListener listener) 注册一个用于 PropertyChange 事件的侦听器。
void | PropertyEditorSupport.addPropertyChangeListener(PropertyChangeListener listener) 注册一个用于 PropertyChange 事件的侦听器。
void | PropertyChangeSupport.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
void | PropertyChangeSupport.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 为指定的属性向侦听器列表中添加一个 PropertyChangeListener。
void | Customizer.removePropertyChangeListener(PropertyChangeListener listener) 移除一个用于 PropertyChange 事件的侦听器。
void | PropertyEditor.removePropertyChangeListener(PropertyChangeListener listener) 移除一个用于 PropertyChange 事件的侦听器。
void | PropertyEditorSupport.removePropertyChangeListener(PropertyChangeListener listener) 移除一个用于 PropertyChange 事件的侦听器。
void | PropertyChangeSupport.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。
void | PropertyChangeSupport.removePropertyChangeListener(String propertyName, PropertyChangeListener listener) 为特定属性移除一个 PropertyChangeListener。

参数类型为 PropertyChangeListener 的 java.beans 中的构造方法
PropertyChangeListenerProxy(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 绑定到特定属性的构造方法。

java.beans.beancontext 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

返回 PropertyChangeListener 的 java.beans.beancontext 中的方法
protected static PropertyChangeListener BeanContextSupport.getChildPropertyChangeListener(Object child)
与指定 Child 相关联的 PropertyChangeListener（如果有）

参数类型为 PropertyChangeListener 的 java.beans.beancontext 中的方法
void | BeanContextChild.addPropertyChangeListener(String name, PropertyChangeListener pcl) 将一个 PropertyChangeListener 添加到此 BeanContextChild 中，以便无论指定属性何时发生更改都可以接收一个 PropertyChangeEvent。
void | BeanContextChildSupport.addPropertyChangeListener(String name, PropertyChangeListener pcl) 为特定属性添加一个 PropertyChangeListener。
void | BeanContextChild.removePropertyChangeListener(String name, PropertyChangeListener pcl) 从此 BeanContextChild 中移除一个 PropertyChangeListener，以便指定属性发生更改时不再接收 PropertyChangeEvent。
void | BeanContextChildSupport.removePropertyChangeListener(String name, PropertyChangeListener pcl) 为特定属性移除一个 PropertyChangeListener。

java.util.jar 中 PropertyChangeListener 的使用

参数类型为 PropertyChangeListener 的 java.util.jar 中的方法
 void Pack200.Packer.addPropertyChangeListener(PropertyChangeListener listener)
为属性映射上的 PropertyChange 事件注册一个侦听器。
 void Pack200.Unpacker.addPropertyChangeListener(PropertyChangeListener listener)
为属性映射上的 PropertyChange 事件注册一个侦听器。
 void Pack200.Packer.removePropertyChangeListener(PropertyChangeListener listener)
移除由 Pack200.Packer.addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。
 void Pack200.Unpacker.removePropertyChangeListener(PropertyChangeListener listener)
移除由 Pack200.Unpacker.addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。

java.util.logging 中 PropertyChangeListener 的使用

参数类型为 PropertyChangeListener 的 java.util.logging 中的方法
void | LogManager.addPropertyChangeListener(PropertyChangeListener l) 添加重读日志属性时调用的事件侦听器。
void | LogManager.removePropertyChangeListener(PropertyChangeListener l) 移除属性更改事件的事件侦听器。

javax.accessibility 中 PropertyChangeListener 的使用

参数类型为 PropertyChangeListener 的 javax.accessibility 中的方法
void | AccessibleContext.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | AccessibleContext.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除 PropertyChangeListener。

javax.swing 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 javax.swing 中的类
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | ProgressMonitor.AccessibleProgressMonitor AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

返回 PropertyChangeListener 的 javax.swing 中的方法
protected  PropertyChangeListener JToolBar.createActionChangeListener(JButton b)
返回正确配置的 PropertyChangeListener，它根据 Action 的更改对控件进行更新，如果需要使用默认的属性更改侦听器，则为 null。
protected  PropertyChangeListener JPopupMenu.createActionChangeListener(JMenuItem b)
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
protected  PropertyChangeListener JMenu.createActionChangeListener(JMenuItem b)
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
protected  PropertyChangeListener JTextField.createActionPropertyChangeListener(Action a)
创建并返回一个负责侦听指定 Action 的更改以及更新适当属性的 PropertyChangeListener。
protected  PropertyChangeListener JComboBox.createActionPropertyChangeListener(Action a)
创建并返回一个 PropertyChangeListener，它负责侦听指定 Action 的更改并更新适当属性。
protected  PropertyChangeListener AbstractButton.createActionPropertyChangeListener(Action a)
创建并返回 PropertyChangeListener，它负责侦听指定 Action 的更改以及更新适当的属性。
 PropertyChangeListener[] AbstractAction.getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 AbstractAction 中的所有 PropertyChangeListener 组成的数组。
 PropertyChangeListener[] UIDefaults.getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 UIDefaults 的所有 PropertyChangeListener 组成的数组。
static PropertyChangeListener[] UIManager.getPropertyChangeListeners()
返回添加到此 UIManager（具有 addPropertyChangeListener()）的所有 PropertyChangeListener 的数组。

参数类型为 PropertyChangeListener 的 javax.swing 中的方法
void | SwingWorker.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | JTree.AccessibleJTree.AccessibleJTreeNode.addPropertyChangeListener(PropertyChangeListener l) 将 PropertyChangeListener 添加到侦听器列表。
void | JTable.AccessibleJTable.AccessibleJTableCell.addPropertyChangeListener(PropertyChangeListener l) 将一个 PropertyChangeListener 添加到侦听器列表中。
void | AbstractAction.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
void | JList.AccessibleJList.AccessibleJListChild.addPropertyChangeListener(PropertyChangeListener l)
void | Action.addPropertyChangeListener(PropertyChangeListener listener) 添加一个 PropertyChange 侦听器。
void | UIDefaults.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
static void | UIManager.addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表。
void | JComponent.AccessibleJComponent.addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表中。
void | SwingWorker.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表中移除一个 PropertyChangeListener。
void | JTree.AccessibleJTree.AccessibleJTreeNode.removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表中移除 PropertyChangeListener。
void | JTable.AccessibleJTable.AccessibleJTableCell.removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表移除一个 PropertyChangeListener。
void | AbstractAction.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表中移除一个 PropertyChangeListener。
void | JList.AccessibleJList.AccessibleJListChild.removePropertyChangeListener(PropertyChangeListener l)
void | Action.removePropertyChangeListener(PropertyChangeListener listener) 移除一个 PropertyChange 侦听器。
void | UIDefaults.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。
static void | UIManager.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除 PropertyChangeListener。
void | JComponent.AccessibleJComponent.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。

javax.swing.plaf.basic 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
class | BasicColorChooserUI.PropertyHandler 因编译器故障而被标记为 "public" 的内部类。
class | BasicComboBoxUI.PropertyChangeHandler 此侦听器观察在组合框中发生更改的绑定 (bound) 属性。
protected class | BasicComboPopup.PropertyChangeHandler 此侦听器观察已在组合框中更改的绑定 (bound) 属性 希望侦听组合框属性更改的子类应该调用超类方法来确保组合框弹出部分正确处理属性更改。
class | BasicDirectoryModel 文件列表的基本实现。
class | BasicInternalFrameTitlePane.PropertyChangeHandler 此类应视为“受保护”内部类。
class | BasicInternalFrameUI.InternalFramePropertyChangeListener
class | BasicLabelUI LabelUI 的 Windows L&F 实现。
class | BasicListUI.PropertyChangeHandler 在 installUI 时添加到 JList 的 PropertyChangeListener。
class | BasicOptionPaneUI.PropertyChangeHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicRootPaneUI RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。
class | BasicScrollBarUI.PropertyChangeHandler
class | BasicScrollPaneUI.PropertyChangeHandler
class | BasicSliderUI.PropertyChangeHandler
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
class | BasicSplitPaneUI.PropertyHandler JSplitPane UI 使用的 PropertyChangeListener 的实现。
class | BasicTabbedPaneUI.PropertyChangeHandler 此类应视为“受保护”内部类。
protected class | BasicToolBarUI.PropertyListener
class | BasicTreeUI.PropertyChangeHandler 树的 PropertyChangeListener。
class | BasicTreeUI.SelectionModelPropertyChangeHandler TreeSelectionModel 上的侦听器，如果模型的任何属性发生更改，则重置行选择。

声明为 PropertyChangeListener 的 javax.swing.plaf.basic 中的字段
protected PropertyChangeListener | BasicColorChooserUI.propertyChangeListener
protected PropertyChangeListener | BasicInternalFrameTitlePane.propertyChangeListener
protected PropertyChangeListener | BasicInternalFrameUI.propertyChangeListener
protected PropertyChangeListener | BasicOptionPaneUI.propertyChangeListener
protected PropertyChangeListener | BasicSliderUI.propertyChangeListener
protected PropertyChangeListener | BasicSplitPaneUI.propertyChangeListener 此 JSplitPane 的 PropertyChangeListener 的实例。
protected PropertyChangeListener | BasicTabbedPaneUI.propertyChangeListener
protected PropertyChangeListener | BasicListUI.propertyChangeListener
protected PropertyChangeListener | BasicComboPopup.propertyChangeListener 此受保护字段是特定于实现的。
protected PropertyChangeListener | BasicComboBoxUI.propertyChangeListener 此受保护字段是特定于实现的。
protected PropertyChangeListener | BasicScrollBarUI.propertyChangeListener
protected PropertyChangeListener | BasicMenuItemUI.propertyChangeListener 从 createPropertyChangeListener 返回的 PropertyChangeListener。
protected PropertyChangeListener | BasicToolBarUI.propertyListener
protected PropertyChangeListener | BasicScrollPaneUI.spPropertyChangeListener

返回 PropertyChangeListener 的 javax.swing.plaf.basic 中的方法
protected  PropertyChangeListener BasicColorChooserUI.createPropertyChangeListener()
protected  PropertyChangeListener BasicDesktopPaneUI.createPropertyChangeListener()
返回要安装到 JDesktopPane 上的 PropertyChangeListener。
protected  PropertyChangeListener BasicInternalFrameTitlePane.createPropertyChangeListener()
protected  PropertyChangeListener BasicInternalFrameUI.createPropertyChangeListener()
protected  PropertyChangeListener BasicOptionPaneUI.createPropertyChangeListener()
protected  PropertyChangeListener BasicSpinnerUI.createPropertyChangeListener()
创建一个可以添加到 JSpinner 本身的 PropertyChangeListener。
protected  PropertyChangeListener BasicSplitPaneUI.createPropertyChangeListener()
创建 JSplitPane UI 的 PropertyChangeListener。
protected  PropertyChangeListener BasicTreeUI.createPropertyChangeListener()
创建负责基于树的更改方式更新 UI 的侦听器。
protected  PropertyChangeListener BasicTabbedPaneUI.createPropertyChangeListener()
protected  PropertyChangeListener BasicScrollPaneUI.createPropertyChangeListener()
创建由 installUI() 添加到 JScrollPane 的 PropertyChangeListener 的实例。
protected  PropertyChangeListener BasicListUI.createPropertyChangeListener()
创建由 installUI() 添加到 JList 的 PropertyChangeHandler 的实例。
protected  PropertyChangeListener BasicComboPopup.createPropertyChangeListener()
创建将添加到组合框的 PropertyChangeListener。
protected  PropertyChangeListener BasicComboBoxUI.createPropertyChangeListener()
创建将添加到组合框的 PropertyChangeListener。
protected  PropertyChangeListener BasicScrollBarUI.createPropertyChangeListener()
protected  PropertyChangeListener BasicMenuUI.createPropertyChangeListener(JComponent c)
protected  PropertyChangeListener BasicMenuItemUI.createPropertyChangeListener(JComponent c)
创建一个将被添加到菜单项的 PropertyChangeListener。
 PropertyChangeListener BasicFileChooserUI.createPropertyChangeListener(JFileChooser fc)
protected  PropertyChangeListener BasicSliderUI.createPropertyChangeListener(JSlider slider)
protected  PropertyChangeListener BasicToolBarUI.createPropertyListener()
protected  PropertyChangeListener BasicTreeUI.createSelectionModelPropertyChangeListener()
创建负责从选择模型获取属性更改事件的侦听器。
 PropertyChangeListener[] BasicDirectoryModel.getPropertyChangeListeners()
返回一个在此组件上注册的所有属性更改侦听器的数组。

参数类型为 PropertyChangeListener 的 javax.swing.plaf.basic 中的方法
void | BasicDirectoryModel.addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表。
void | BasicDirectoryModel.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。

javax.swing.plaf.metal 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxUI.MetalPropertyChangeListener 此内部类由于编译器故障而被标记为 "public"。
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。
class | MetalLabelUI LabelUI 的 Windows L&F 实现。
class | MetalRootPaneUI 提供 RootPaneUI 的 metal 外观实现。
protected class | MetalSliderUI.MetalPropertyListener
protected class | MetalToolBarUI.MetalRolloverListener

声明为 PropertyChangeListener 的 javax.swing.plaf.metal 中的字段
protected  PropertyChangeListener MetalToolBarUI.rolloverListener
此受保护的字段是特定于实现的。

返回 PropertyChangeListener 的 javax.swing.plaf.metal 中的方法
protected PropertyChangeListener | MetalInternalFrameTitlePane.createPropertyChangeListener()
PropertyChangeListener | MetalComboBoxUI.createPropertyChangeListener()
protected PropertyChangeListener | MetalScrollBarUI.createPropertyChangeListener()
PropertyChangeListener | MetalFileChooserUI.createPropertyChangeListener(JFileChooser fc)
protected PropertyChangeListener | MetalSliderUI.createPropertyChangeListener(JSlider slider)
protected PropertyChangeListener | MetalToolBarUI.createRolloverListener() 创建一个将添加到 JToolBar 中的属性更改侦听器。
protected PropertyChangeListener | MetalScrollPaneUI.createScrollBarSwapListener()

javax.swing.table 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 javax.swing.table 中的类
 class DefaultTableColumnModel
JTable 的标准列处理程序。

返回 PropertyChangeListener 的 javax.swing.table 中的方法
 PropertyChangeListener[] TableColumn.getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 TableColumn 的所有 PropertyChangeListener 组成的数组。

参数类型为 PropertyChangeListener 的 javax.swing.table 中的方法
void | TableColumn.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表中添加一个 PropertyChangeListener。
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.addPropertyChangeListener(PropertyChangeListener l)
void | TableColumn.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表中移除一个 PropertyChangeListener。
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.removePropertyChangeListener(PropertyChangeListener l)

javax.swing.tree 中 PropertyChangeListener 的使用

返回 PropertyChangeListener 的 javax.swing.tree 中的方法
 PropertyChangeListener[] DefaultTreeSelectionModel.getPropertyChangeListeners()
返回此 DefaultTreeSelectionModel 上注册的所有属性更改侦听器组成的数组。

参数类型为 PropertyChangeListener 的 javax.swing.tree 中的方法
void | DefaultTreeSelectionModel.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | TreeSelectionModel.addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表中。
void | DefaultTreeSelectionModel.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除 PropertyChangeListener。
void | TreeSelectionModel.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.PropertyChangeListenerProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyChangeListenerProxy
的使用

没有 java.beans.PropertyChangeListenerProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.PropertyChangeSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyChangeSupport
的使用

使用 PropertyChangeSupport 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

java.awt 中 PropertyChangeSupport 的使用

声明为 PropertyChangeSupport 的 java.awt 中的字段
protected  PropertyChangeSupport Toolkit.desktopPropsSupport

java.beans.beancontext 中 PropertyChangeSupport 的使用

声明为 PropertyChangeSupport 的 java.beans.beancontext 中的字段
protected  PropertyChangeSupport BeanContextChildSupport.pcSupport
与此 BeanContextChildSupport 相关联的 PropertyChangeSupport。

javax.swing 中 PropertyChangeSupport 的使用

返回 PropertyChangeSupport 的 javax.swing 中的方法
 PropertyChangeSupport SwingWorker.getPropertyChangeSupport()
返回此 SwingWorker 的 PropertyChangeSupport。

javax.swing.event 中 PropertyChangeSupport 的使用

javax.swing.event 中 PropertyChangeSupport 的子类
 class SwingPropertyChangeSupport
java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.PropertyDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyDescriptor
的使用

使用 PropertyDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 PropertyDescriptor 的使用

java.beans 中 PropertyDescriptor 的子类
 class IndexedPropertyDescriptor
IndexedPropertyDescriptor 描述了类似数组行为的属性，且有一种访问数组特定元素的索引读和/或索引写方法。

返回 PropertyDescriptor 的 java.beans 中的方法
PropertyDescriptor[] | BeanInfo.getPropertyDescriptors() 获得 beans PropertyDescriptor。
PropertyDescriptor[] | SimpleBeanInfo.getPropertyDescriptors() 拒绝属性的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.PropertyEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.PropertyEditor
的使用

使用 PropertyEditor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 PropertyEditor 的使用

实现 PropertyEditor 的 java.beans 中的类
 class PropertyEditorSupport
这是一个帮助构建属性编辑器的支持类。

返回 PropertyEditor 的 java.beans 中的方法
PropertyEditor | PropertyDescriptor.createPropertyEditor(Object bean) 使用当前属性编辑器类构造一个属性编辑器实例。
static PropertyEditor | PropertyEditorManager.findEditor(Class<?> targetType) 查找给定目标类型的值编辑器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.PropertyEditorManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyEditorManager
的使用

没有 java.beans.PropertyEditorManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.PropertyEditorSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyEditorSupport
的使用

没有 java.beans.PropertyEditorSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.PropertyVetoException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyVetoException
的使用

使用 PropertyVetoException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 PropertyVetoException 的使用

抛出 PropertyVetoException 的 java.awt 中的方法
protected  void KeyboardFocusManager.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
激发 PropertyChangeEvent 以响应可否决属性中的更改。

java.beans 中 PropertyVetoException 的使用

抛出 PropertyVetoException 的 java.beans 中的方法
void | VetoableChangeSupport.fireVetoableChange(PropertyChangeEvent evt) 对所有已注册侦听器激发一个 vetoable 属性更新。
void | VetoableChangeSupport.fireVetoableChange(String propertyName, boolean oldValue, boolean newValue) 向所有已注册的侦听器报告一个 boolean vetoable 属性更新。
void | VetoableChangeSupport.fireVetoableChange(String propertyName, int oldValue, int newValue) 向所有已注册的侦听器报告一个 int vetoable 属性更新。
void | VetoableChangeSupport.fireVetoableChange(String propertyName, Object oldValue, Object newValue) 向所有已注册的侦听器报告 vetoable 属性更新。
void | VetoableChangeListenerProxy.vetoableChange(PropertyChangeEvent evt) 将属性更改事件转发给侦听器代理。
void | VetoableChangeListener.vetoableChange(PropertyChangeEvent evt) 在约束属性发生更改时调用此方法。

java.beans.beancontext 中 PropertyVetoException 的使用

抛出 PropertyVetoException 的 java.beans.beancontext 中的方法
void | BeanContextChildSupport.fireVetoableChange(String name, Object oldValue, Object newValue) 向所有已注册的侦听器报告 vetoable 属性更新。
void | BeanContextChild.setBeanContext(BeanContext bc) 实现此接口的对象应使用以下参数激活一个 java.beans.PropertyChangeEvent：propertyName "beanContext"、oldValue（以前的嵌套 BeanContext 实例，或 null）、newValue（当前的嵌套 BeanContext 实例，或 null）。
void | BeanContextChildSupport.setBeanContext(BeanContext bc) 设置此 BeanContextChildSupport 的 BeanContext。
void | BeanContextSupport.setLocale(Locale newLocale) 设置此 BeanContext 的语言环境。
void | BeanContextSupport.vetoableChange(PropertyChangeEvent pce) 子类可以封装此方法来监视子类属性的更改。

javax.swing 中 PropertyVetoException 的使用

抛出 PropertyVetoException 的 javax.swing 中的方法
protected void | JComponent.fireVetoableChange(String propertyName, Object oldValue, Object newValue) 支持报告约束 (constrained) 属性的更改。
void | JInternalFrame.setClosed(boolean b) 如果参数为 true，则关闭此内部窗体。
void | JInternalFrame.setIcon(boolean b) 如果外观支持图标化，则对此内部窗体执行图标化或取消图标化。
void | JInternalFrame.setMaximum(boolean b) 最大化并还原此内部窗体。
void | JInternalFrame.setSelected(boolean selected) 如果要显示内部窗体，则选定或取消选定该窗体。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.SimpleBeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.SimpleBeanInfo
的使用

没有 java.beans.SimpleBeanInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.Statement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.Statement
的使用

使用 Statement 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 Statement 的使用

java.beans 中 Statement 的子类
 class Expression
Expression 对象表示基本表达式，其中将单个方法应用于某一目标和一组参数，以返回结果，与在 "a.getFoo()" 中一样。

参数类型为 Statement 的 java.beans 中的方法
void | Encoder.writeStatement(Statement oldStm) 将语句 oldStm 写入流中。
void | XMLEncoder.writeStatement(Statement oldStm) 记录 Statement，以便 Encoder 在刷新流的缓存时产生实际输出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.VetoableChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.VetoableChangeListener
的使用

使用 VetoableChangeListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 VetoableChangeListener 的使用

返回 VetoableChangeListener 的 java.awt 中的方法
VetoableChangeListener[] | KeyboardFocusManager.getVetoableChangeListeners() 返回在此键盘焦点管理器上注册的所有可否决更改侦听器组成的数组。
VetoableChangeListener[] | KeyboardFocusManager.getVetoableChangeListeners(String propertyName) 返回与指定属性相关联的所有 VetoableChangeListener 组成的数组。

参数类型为 VetoableChangeListener 的 java.awt 中的方法
void | KeyboardFocusManager.addVetoableChangeListener(String propertyName, VetoableChangeListener listener) 将 VetoableChangeListener 添加到特定属性的侦听器列表。
void | KeyboardFocusManager.addVetoableChangeListener(VetoableChangeListener listener) 将 VetoableChangeListener 添加到侦听器列表。
void | KeyboardFocusManager.removeVetoableChangeListener(String propertyName, VetoableChangeListener listener) 从特定属性的侦听器列表移除 VetoableChangeListener。
void | KeyboardFocusManager.removeVetoableChangeListener(VetoableChangeListener listener) 从侦听器列表移除 VetoableChangeListener。

java.beans 中 VetoableChangeListener 的使用

实现 VetoableChangeListener 的 java.beans 中的类
 class VetoableChangeListenerProxy
扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。

返回 VetoableChangeListener 的 java.beans 中的方法
VetoableChangeListener[] | VetoableChangeSupport.getVetoableChangeListeners() 返回 VetoableChangeListener 的列表。
VetoableChangeListener[] | VetoableChangeSupport.getVetoableChangeListeners(String propertyName) 返回与指定属性相关联的所有侦听器组成的数组。

参数类型为 VetoableChangeListener 的 java.beans 中的方法
void | VetoableChangeSupport.addVetoableChangeListener(String propertyName, VetoableChangeListener listener) 为特定属性添加一个 VetoableChangeListener。
void | VetoableChangeSupport.addVetoableChangeListener(VetoableChangeListener listener) 向侦听器列表添加一个 VetoableListener。
void | VetoableChangeSupport.removeVetoableChangeListener(String propertyName, VetoableChangeListener listener) 为特定属性移除一个 VetoableChangeListener。
void | VetoableChangeSupport.removeVetoableChangeListener(VetoableChangeListener listener) 从侦听器列表移除一个 VetoableChangeListener。

参数类型为 VetoableChangeListener 的 java.beans 中的构造方法
VetoableChangeListenerProxy(String propertyName, VetoableChangeListener listener)

java.beans.beancontext 中 VetoableChangeListener 的使用

实现 VetoableChangeListener 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

返回 VetoableChangeListener 的 java.beans.beancontext 中的方法
protected static VetoableChangeListener BeanContextSupport.getChildVetoableChangeListener(Object child)
与指定 Child 相关联的 VetoableChangeListener（如果有）。

参数类型为 VetoableChangeListener 的 java.beans.beancontext 中的方法
void | BeanContextChild.addVetoableChangeListener(String name, VetoableChangeListener vcl) 将一个 VetoableChangeListener 添加到此 BeanContextChild，以便无论指定属性何时发生更改都可以接收事件。
void | BeanContextChildSupport.addVetoableChangeListener(String name, VetoableChangeListener vcl) 为特定属性添加一个 VetoableChangeListener。
void | BeanContextChild.removeVetoableChangeListener(String name, VetoableChangeListener vcl) 从此 BeanContextChild 中移除一个 VetoableChangeListener，以便指定属性发生更改时不再接收事件。
void | BeanContextChildSupport.removeVetoableChangeListener(String name, VetoableChangeListener vcl) 移除一个 VetoableChangeListener。

javax.swing 中 VetoableChangeListener 的使用

返回 VetoableChangeListener 的 javax.swing 中的方法
 VetoableChangeListener[] JComponent.getVetoableChangeListeners()
返回在此组件上注册的所有可否决更改侦听器所组成的数组。

参数类型为 VetoableChangeListener 的 javax.swing 中的方法
void | JComponent.addVetoableChangeListener(VetoableChangeListener listener) 向侦听器列表添加一个 VetoableChangeListener。
void | JComponent.removeVetoableChangeListener(VetoableChangeListener listener) 从侦听器列表移除一个 VetoableChangeListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.VetoableChangeListenerProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.VetoableChangeListenerProxy
的使用

没有 java.beans.VetoableChangeListenerProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.VetoableChangeSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.VetoableChangeSupport
的使用

使用 VetoableChangeSupport 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 VetoableChangeSupport 的使用

声明为 VetoableChangeSupport 的 java.beans.beancontext 中的字段
protected  VetoableChangeSupport BeanContextChildSupport.vcSupport
与此 BeanContextChildSupport 相关联的 VetoableChangeSupport。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.beans.Visibility 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.Visibility
的使用

使用 Visibility 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 Visibility 的使用

java.beans.beancontext 中 Visibility 的子接口
interface | BeanContext BeanContext 是 JavaBean 的逻辑层次容器。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 Visibility 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

返回 Visibility 的 java.beans.beancontext 中的方法
protected static Visibility BeanContextSupport.getChildVisibility(Object child)
获得与指定子级相关联的 Component（如果有）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.XMLDecoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.XMLDecoder
的使用

没有 java.beans.XMLDecoder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.beans.XMLEncoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.XMLEncoder
的使用

没有 java.beans.XMLEncoder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.io (Java 2 Platform SE 6)

 java.io
接口
Closeable
DataInput
DataOutput
Externalizable
FileFilter
FilenameFilter
Flushable
ObjectInput
ObjectInputValidation
ObjectOutput
ObjectStreamConstants
Serializable
类
BufferedInputStream
BufferedOutputStream
BufferedReader
BufferedWriter
ByteArrayInputStream
ByteArrayOutputStream
CharArrayReader
CharArrayWriter
Console
DataInputStream
DataOutputStream
File
FileDescriptor
FileInputStream
FileOutputStream
FilePermission
FileReader
FileWriter
FilterInputStream
FilterOutputStream
FilterReader
FilterWriter
InputStream
InputStreamReader
LineNumberInputStream
LineNumberReader
ObjectInputStream
ObjectInputStream.GetField
ObjectOutputStream
ObjectOutputStream.PutField
ObjectStreamClass
ObjectStreamField
OutputStream
OutputStreamWriter
PipedInputStream
PipedOutputStream
PipedReader
PipedWriter
PrintStream
PrintWriter
PushbackInputStream
PushbackReader
RandomAccessFile
Reader
SequenceInputStream
SerializablePermission
StreamTokenizer
StringBufferInputStream
StringReader
StringWriter
Writer
异常
CharConversionException
EOFException
FileNotFoundException
InterruptedIOException
InvalidClassException
InvalidObjectException
IOException
NotActiveException
NotSerializableException
ObjectStreamException
OptionalDataException
StreamCorruptedException
SyncFailedException
UnsupportedEncodingException
UTFDataFormatException
WriteAbortedException
错误
IOError


类 java.io.BufferedInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.BufferedInputStream
的使用

没有 java.io.BufferedInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.BufferedOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.BufferedOutputStream
的使用

没有 java.io.BufferedOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.BufferedReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.BufferedReader
的使用

使用 BufferedReader 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 BufferedReader 的使用

java.io 中 BufferedReader 的子类
 class LineNumberReader
跟踪行号的缓冲字符输入流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.BufferedWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.BufferedWriter
的使用

没有 java.io.BufferedWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.ByteArrayInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ByteArrayInputStream
的使用

没有 java.io.ByteArrayInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.ByteArrayOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ByteArrayOutputStream
的使用

没有 java.io.ByteArrayOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.CharArrayReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.CharArrayReader
的使用

没有 java.io.CharArrayReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.CharArrayWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.CharArrayWriter
的使用

使用 CharArrayWriter 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 CharArrayWriter 的使用

返回 CharArrayWriter 的 java.io 中的方法
CharArrayWriter | CharArrayWriter.append(char c) 将指定字符添加到此 writer。
CharArrayWriter | CharArrayWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
CharArrayWriter | CharArrayWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.CharConversionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.CharConversionException
的使用

没有 java.io.CharConversionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.Closeable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.Closeable
的使用

使用 Closeable 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.crypto | 为加密操作提供类和接口。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.io 中 Closeable 的使用

实现 Closeable 的 java.io 中的类
class | BufferedInputStream BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。
class | BufferedOutputStream 该类实现缓冲的输出流。
class | BufferedReader 从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。
class | BufferedWriter 将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
class | ByteArrayInputStream ByteArrayInputStream 包含一个内部缓冲区，该缓冲区包含从流中读取的字节。
class | ByteArrayOutputStream 此类实现了一个输出流，其中的数据被写入一个 byte 数组。
class | CharArrayReader 此类实现一个可用作字符输入流的字符缓冲区。
class | CharArrayWriter 此类实现一个可用作 Writer 的字符缓冲区。
class | DataInputStream 数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
class | DataOutputStream 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
class | FileInputStream FileInputStream 从文件系统中的某个文件中获得输入字节。
class | FileOutputStream 文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。
class | FileReader 用来读取字符文件的便捷类。
class | FileWriter 用来写入字符文件的便捷类。
class | FilterInputStream FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
class | FilterOutputStream 此类是过滤输出流的所有类的超类。
class | FilterReader 用于读取已过滤的字符流的抽象类。
class | FilterWriter 用于写入已过滤的字符流的抽象类。
class | InputStream 此抽象类是表示字节输入流的所有类的超类。
class | InputStreamReader InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。
class | LineNumberInputStream 已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
class | LineNumberReader 跟踪行号的缓冲字符输入流。
class | ObjectInputStream ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
class | ObjectOutputStream ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
class | OutputStream 此抽象类是表示输出字节流的所有类的超类。
class | OutputStreamWriter OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
class | PipedInputStream 管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。
class | PipedOutputStream 可以将管道输出流连接到管道输入流来创建通信管道。
class | PipedReader 传送的字符输入流。
class | PipedWriter 传送的字符输出流。
class | PrintStream PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
class | PrintWriter 向文本输出流打印对象的格式化表示形式。
class | PushbackInputStream PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。
class | PushbackReader 允许将字符推回到流的字符流 reader。
class | RandomAccessFile 此类的实例支持对随机访问文件的读取和写入。
class | Reader 用于读取字符流的抽象类。
class | SequenceInputStream SequenceInputStream 表示其他输入流的逻辑串联。
class | StringBufferInputStream 已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。
class | StringReader 其源为一个字符串的字符流。
class | StringWriter 一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。
class | Writer 写入字符流的抽象类。

java.nio.channels 中 Closeable 的使用

java.nio.channels 中 Closeable 的子接口
interface | ByteChannel 可读取和写入字节的信道。
interface | Channel 用于 I/O 操作的连接。
interface | GatheringByteChannel 可从缓冲区序列写入字节的通道。
interface | InterruptibleChannel 可被异步关闭和中断的通道。
interface | ReadableByteChannel 可读取字节的通道。
interface | ScatteringByteChannel 可将字节读入缓冲区序列的通道。
interface | WritableByteChannel 可写入字节的通道。

实现 Closeable 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SelectableChannel 可通过 Selector 实现多路复用的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

java.nio.channels.spi 中 Closeable 的使用

实现 Closeable 的 java.nio.channels.spi 中的类
class | AbstractInterruptibleChannel 可中断通道的基本实现类。
class | AbstractSelectableChannel 可选择通道的基本实现类。

java.rmi.server 中 Closeable 的使用

实现 Closeable 的 java.rmi.server 中的类
 class LogStream
已过时。 无替代版本

java.security 中 Closeable 的使用

实现 Closeable 的 java.security 中的类
class | DigestInputStream 使用通过流的位更新关联消息摘要的透明流。
class | DigestOutputStream 使用通过流的位更新关联消息摘要的透明流。

java.util 中 Closeable 的使用

实现 Closeable 的 java.util 中的类
 class Formatter
printf 风格的格式字符串的解释程序。

java.util.jar 中 Closeable 的使用

实现 Closeable 的 java.util.jar 中的类
class | JarInputStream JarInputStream 类用于从任何输入流读取 JAR 文件内容。
class | JarOutputStream JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

java.util.zip 中 Closeable 的使用

实现 Closeable 的 java.util.zip 中的类
class | CheckedInputStream 需要维护所读取数据校验和的输入流。
class | CheckedOutputStream 需要维护写入数据校验和的输出流。
class | DeflaterInputStream 为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。
class | DeflaterOutputStream 此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
class | GZIPInputStream 此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
class | GZIPOutputStream 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
class | InflaterInputStream 此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
class | InflaterOutputStream 为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
class | ZipInputStream 此类为读取 ZIP 文件格式的文件实现输入流过滤器。
class | ZipOutputStream 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

javax.crypto 中 Closeable 的使用

实现 Closeable 的 javax.crypto 中的类
class | CipherInputStream CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。
class | CipherOutputStream CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。

javax.management.remote 中 Closeable 的使用

javax.management.remote 中 Closeable 的子接口
 interface JMXConnector
JMX API 连接器的客户端。

javax.management.remote.rmi 中 Closeable 的使用

javax.management.remote.rmi 中 Closeable 的子接口
 interface RMIConnection
RMI 对象，用于将 MBeanServer 请求从客户端转发到其位于服务器端的 MBeanServer 实现。

实现 Closeable 的 javax.management.remote.rmi 中的类
class | RMIConnectionImpl RMIConnection 接口的实现。
class | RMIConnectionImpl_Stub
class | RMIConnector 一个到远程 RMI 连接器的连接。
class | RMIIIOPServerImpl 一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
class | RMIJRMPServerImpl 一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。
class | RMIServerImpl 表示连接器服务器的 RMI 对象。

javax.sound.sampled 中 Closeable 的使用

实现 Closeable 的 javax.sound.sampled 中的类
 class AudioInputStream
音频输入流是具有指定音频格式和长度的输入流。

javax.swing 中 Closeable 的使用

实现 Closeable 的 javax.swing 中的类
 class ProgressMonitorInputStream
监视读取某些 InputStream 的进度。

javax.tools 中 Closeable 的使用

javax.tools 中 Closeable 的子接口
interface | JavaFileManager 在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。
interface | StandardJavaFileManager 基于 java.io.File 的文件管理器。

实现 Closeable 的 javax.tools 中的类
 class ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.Console 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.Console
的使用

使用 Console 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。

java.io 中 Console 的使用

返回 Console 的 java.io 中的方法
Console | Console.format(String fmt, Object... args) 使用指定格式字符串和参数将格式化字符串写入此控制台的输出流中。
Console | Console.printf(String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此控制台输出流的便捷方法。

java.lang 中 Console 的使用

返回 Console 的 java.lang 中的方法
static Console System.console()
返回与当前 Java 虚拟机关联的唯一 Console 对象（如果有）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.DataInput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.DataInput
的使用

使用 DataInput 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

java.io 中 DataInput 的使用

java.io 中 DataInput 的子接口
 interface ObjectInput
ObjectInput 扩展 DataInput 接口以包含对象的读操作。

实现 DataInput 的 java.io 中的类
class | DataInputStream 数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
class | ObjectInputStream ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
class | RandomAccessFile 此类的实例支持对随机访问文件的读取和写入。

参数类型为 DataInput 的 java.io 中的方法
static String DataInputStream.readUTF(DataInput in)
从流 in 中读取用 UTF-8 修改版格式编码的 Unicode 字符格式的字符串；然后以 String 形式返回此字符串。

java.rmi.server 中 DataInput 的使用

参数类型为 DataInput 的 java.rmi.server 中的方法
static UID UID.read(DataInput in)
通过从 DataInput 实例解组二进制表示形式构造并返回一个新的 UID。

javax.imageio.stream 中 DataInput 的使用

javax.imageio.stream 中 DataInput 的子接口
interface | ImageInputStream 供 ImageReader 使用的可查找输入流接口。
interface | ImageOutputStream 供 ImageWriter 使用的可查找输出流接口。

实现 DataInput 的 javax.imageio.stream 中的类
class | FileCacheImageInputStream 从常规 InputStream 获取其输入的 ImageInputStream 的实现。
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageInputStream 从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | ImageInputStreamImpl 实现 ImageInputStream 接口的抽象类。
class | ImageOutputStreamImpl 实现 ImageOutputStream 接口的抽象类。
class | MemoryCacheImageInputStream 从常规 InputStream 获取输入的 ImageInputStream 的实现。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.DataInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.DataInputStream
的使用

使用 DataInputStream 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 DataInputStream 的使用

参数类型为 DataInputStream 的 javax.swing.text.html.parser 中的方法
 void DTD.read(DataInputStream in)
根据存档格式重新创建一个 DTD。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.DataOutput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.DataOutput
的使用

使用 DataOutput 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

java.io 中 DataOutput 的使用

java.io 中 DataOutput 的子接口
 interface ObjectOutput
ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。

实现 DataOutput 的 java.io 中的类
class | DataOutputStream 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
class | ObjectOutputStream ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
class | RandomAccessFile 此类的实例支持对随机访问文件的读取和写入。

java.rmi.server 中 DataOutput 的使用

参数类型为 DataOutput 的 java.rmi.server 中的方法
 void UID.write(DataOutput out)
将此 UID 的二进制表示形式编组为一个 DataOutput 实例。

javax.imageio.stream 中 DataOutput 的使用

javax.imageio.stream 中 DataOutput 的子接口
 interface ImageOutputStream
供 ImageWriter 使用的可查找输出流接口。

实现 DataOutput 的 javax.imageio.stream 中的类
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | ImageOutputStreamImpl 实现 ImageOutputStream 接口的抽象类。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.DataOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.DataOutputStream
的使用

没有 java.io.DataOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.EOFException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.EOFException
的使用

没有 java.io.EOFException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.Externalizable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.Externalizable
的使用

使用 Externalizable 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.activation |
javax.management.loading | 提供实现高级动态加载的类。

java.awt.datatransfer 中 Externalizable 的使用

实现 Externalizable 的 java.awt.datatransfer 中的类
 class DataFlavor
DataFlavor 提供有关数据的元信息。

java.rmi.server 中 Externalizable 的使用

java.rmi.server 中 Externalizable 的子接口
interface | RemoteRef RemoteRef 表示远程对象的句柄。
interface | ServerRef ServerRef 表示远程对象实现的服务器端句柄。

javax.activation 中 Externalizable 的使用

实现 Externalizable 的 javax.activation 中的类
class | ActivationDataFlavor ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。
class | MimeType RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。

javax.management.loading 中 Externalizable 的使用

实现 Externalizable 的 javax.management.loading 中的类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.File 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.File
的使用

使用 File 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。

java.awt 中 File 的使用

参数类型为 File 的 java.awt 中的方法
static Font | Font.createFont(int fontFormat, File fontFile) 返回一个使用指定字体类型和指定字体文件的新 Font。
void | Desktop.edit(File file) 启动关联编辑器应用程序并打开用于编辑的文件。
void | Desktop.open(File file) 启动关联应用程序来打开文件。
void | Desktop.print(File file) 使用关联应用程序的打印命令，用本机桌面打印设施来打印文件。

java.io 中 File 的使用

返回 File 的 java.io 中的方法
static File | File.createTempFile(String prefix, String suffix) 在默认临时文件目录中创建一个空文件，使用给定前缀和后缀生成其名称。
static File | File.createTempFile(String prefix, String suffix, File directory) 在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
File | File.getAbsoluteFile() 返回此抽象路径名的绝对路径名形式。
File | File.getCanonicalFile() 返回此抽象路径名的规范形式。
File | File.getParentFile() 返回此抽象路径名父目录的抽象路径名；如果此路径名没有指定父目录，则返回 null。
File[] | File.listFiles() 返回一个抽象路径名数组，这些路径名表示此抽象路径名表示的目录中的文件。
File[] | File.listFiles(FileFilter filter) 返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。
File[] | File.listFiles(FilenameFilter filter) 返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。
static File[] | File.listRoots() 列出可用的文件系统根。

参数类型为 File 的 java.io 中的方法
boolean | FileFilter.accept(File pathname) 测试指定抽象路径名是否应该包含在某个路径名列表中。
boolean | FilenameFilter.accept(File dir, String name) 测试指定文件是否应该包含在某一文件列表中。
int | File.compareTo(File pathname) 按字母顺序比较两个抽象路径名。
static File | File.createTempFile(String prefix, String suffix, File directory) 在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
boolean | File.renameTo(File dest) 重新命名此抽象路径名表示的文件。

参数类型为 File 的 java.io 中的构造方法
File(File parent, String child)
根据 parent 抽象路径名和 child 路径名字符串创建一个新 File 实例。
FileInputStream(File file)
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的 File 对象 file 指定。
FileOutputStream(File file)
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(File file, boolean append)
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileReader(File file)
在给定从中读取数据的 File 的情况下创建一个新 FileReader。
FileWriter(File file)
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(File file, boolean append)
根据给定的 File 对象构造一个 FileWriter 对象。
PrintStream(File file)
创建具有指定文件且不带自动行刷新的新打印流。
PrintStream(File file, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintWriter(File file)
使用指定文件创建不具有自动行刷新的新 PrintWriter。
PrintWriter(File file, String csn)
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。
RandomAccessFile(File file, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件由 File 参数指定。

java.lang 中 File 的使用

返回 File 的 java.lang 中的方法
 File ProcessBuilder.directory()
返回此进程生成器的工作目录。

参数类型为 File 的 java.lang 中的方法
ProcessBuilder | ProcessBuilder.directory(File directory) 设置此进程生成器的工作目录。
Process | Runtime.exec(String[] cmdarray, String[] envp, File dir) 在指定环境和工作目录的独立进程中执行指定的命令和变量。
Process | Runtime.exec(String command, String[] envp, File dir) 在有指定环境和工作目录的独立进程中执行指定的字符串命令。

java.security 中 File 的使用

参数类型为 File 的 java.security 中的方法
static KeyStore.Builder KeyStore.Builder.newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection)
返回新的 Builder 对象。

java.util 中 File 的使用

参数类型为 File 的 java.util 中的构造方法
Formatter(File file)
构造一个带指定文件的新 formatter。
Formatter(File file, String csn)
构造一个带指定文件和字符集的新 formatter。
Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。
Scanner(File source)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。
Scanner(File source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。

java.util.jar 中 File 的使用

参数类型为 File 的 java.util.jar 中的方法
 void Pack200.Unpacker.unpack(File in, JarOutputStream out)
读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。

参数类型为 File 的 java.util.jar 中的构造方法
JarFile(File file)
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File file, boolean verify)
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File file, boolean verify, int mode)
创建一个要从指定的 File 对象中以指定模式读取的新的 JarFile。

java.util.zip 中 File 的使用

参数类型为 File 的 java.util.zip 中的构造方法
ZipFile(File file)
打开供阅读的 ZIP 文件，由指定的 File 对象给出。
ZipFile(File file, int mode)
打开新的 ZipFile 以使用指定模式从指定 File 对象读取。

javax.activation 中 File 的使用

返回 File 的 javax.activation 中的方法
 File FileDataSource.getFile()
返回与此 FileDataSource 对应的 File 对象。

参数类型为 File 的 javax.activation 中的方法
abstract String | FileTypeMap.getContentType(File file) 返回文件对象的类型。
String | MimetypesFileTypeMap.getContentType(File f) 返回该文件对象的 MIME 类型。

参数类型为 File 的 javax.activation 中的构造方法
FileDataSource(File file)
根据 File 对象创建 FileDataSource。

javax.imageio 中 File 的使用

返回 File 的 javax.imageio 中的方法
static File ImageIO.getCacheDirectory()
返回由 setCacheDirectory 设置的当前值；如果没有显式设置该值，则返回 null。

参数类型为 File 的 javax.imageio 中的方法
static BufferedImage | ImageIO.read(File input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 File 的结果。
static void | ImageIO.setCacheDirectory(File cacheDirectory) 设置将在其中创建缓存文件的目录。
static boolean | ImageIO.write(RenderedImage im, String formatName, File output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 File。

javax.imageio.spi 中 File 的使用

参数类型为 File 的 javax.imageio.spi 中的方法
abstract ImageInputStream | ImageInputStreamSpi.createInputStreamInstance(Object input, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageInputStream 实现的实例。
abstract ImageOutputStream | ImageOutputStreamSpi.createOutputStreamInstance(Object output, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。

javax.imageio.stream 中 File 的使用

参数类型为 File 的 javax.imageio.stream 中的构造方法
FileCacheImageInputStream(InputStream stream, File cacheDir)
构造一个将从给定 InputStream 进行读取的 FileCacheImageInputStream。
FileCacheImageOutputStream(OutputStream stream, File cacheDir)
构造一个将向给定 outputStream 进行写入的 FileCacheImageOutputStream。
FileImageInputStream(File f)
构造一个将从给定 File 进行读取的 FileImageInputStream。
FileImageOutputStream(File f)
构造一个将向给定 File 进行写入的 FileImageOutputStream。

javax.sound.midi 中 File 的使用

参数类型为 File 的 javax.sound.midi 中的方法
static MidiFileFormat | MidiSystem.getMidiFileFormat(File file) 获得指定 File 的 MIDI 文件格式。
static Sequence | MidiSystem.getSequence(File file) 从指定的 File 获得 MIDI 序列。
static Soundbank | MidiSystem.getSoundbank(File file) 通过从指定的 File 读取来构造一个 Soundbank。
static int | MidiSystem.write(Sequence in, int type, File out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的外部文件。

javax.sound.midi.spi 中 File 的使用

参数类型为 File 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(File file) 获得提供的 File 的 MIDI 文件格式。
abstract Sequence | MidiFileReader.getSequence(File file) 从提供的 File 获得 MIDI 序列。
abstract Soundbank | SoundbankReader.getSoundbank(File file) 从提供的 File 获得音库对象。
abstract int | MidiFileWriter.write(Sequence in, int fileType, File out) 写入表示指示为所提供外部文件的文件类型的 MIDI 文件的字节流。

javax.sound.sampled 中 File 的使用

参数类型为 File 的 javax.sound.sampled 中的方法
static AudioFileFormat | AudioSystem.getAudioFileFormat(File file) 获得指定 File 的音频文件格式。
static AudioInputStream | AudioSystem.getAudioInputStream(File file) 从提供的 File 获得音频输入流。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示指定文件类型的音频文件的字节流写入所提供的外部文件。

javax.sound.sampled.spi 中 File 的使用

参数类型为 File 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(File file) 获得所提供 File 的音频文件格式。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(File file) 从所提供的 File 获得音频输入流。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。

javax.swing 中 File 的使用

返回 File 的 javax.swing 中的方法
File | JFileChooser.getCurrentDirectory() 返回当前目录。
File | JFileChooser.getSelectedFile() 返回选中的文件。
File[] | JFileChooser.getSelectedFiles() 如果将文件选择器设置为允许选择多个文件，则返回选中文件的列表。

参数类型为 File 的 javax.swing 中的方法
boolean | JFileChooser.accept(File f) 如果应该显示该文件，则返回 true。
void | JFileChooser.ensureFileIsVisible(File f) 确保指定的文件是可见的，不是隐藏的。
String | JFileChooser.getDescription(File f) 返回文件描述。
Icon | JFileChooser.getIcon(File f) 返回此文件或文件类型的图标，这取决于系统。
String | JFileChooser.getName(File f) 返回文件名。
String | JFileChooser.getTypeDescription(File f) 返回文件类型。
boolean | JFileChooser.isTraversable(File f) 如果可以返回该文件（目录），则返回 true。
void | JFileChooser.setCurrentDirectory(File dir) 设置当前目录。
void | JFileChooser.setSelectedFile(File file) 设置选中的文件。
void | JFileChooser.setSelectedFiles(File[] selectedFiles) 如果将文件选择器设置为允许选择多个文件，则设置选中文件的列表。

参数类型为 File 的 javax.swing 中的构造方法
JFileChooser(File currentDirectory)
使用给定的 File 作为路径来构造一个 JFileChooser。
JFileChooser(File currentDirectory, FileSystemView fsv)
使用给定的当前目录和 FileSystemView 构造一个 JFileChooser。

javax.swing.filechooser 中 File 的使用

返回 File 的 javax.swing.filechooser 中的方法
File | FileSystemView.createFileObject(File dir, String filename) 返回根据给定的 filename 在 dir 中构造的 File 对象。
File | FileSystemView.createFileObject(String path) 返回根据给定路径字符串构造的 File 对象。
protected File | FileSystemView.createFileSystemRoot(File f) 创建针对 f 的新 File 对象，使其对于文件系统根目录而言具有正确的行为。
abstract File | FileSystemView.createNewFolder(File containingDir) 创建具有默认文件夹名称的新文件夹。
File | FileSystemView.getChild(File parent, String fileName)
File | FileSystemView.getDefaultDirectory() 返回文件选择器的用户默认起始目录。
File[] | FileSystemView.getFiles(File dir, boolean useFileHiding) 获取显示的（即未隐藏）文件的列表。
File | FileSystemView.getHomeDirectory()
File | FileSystemView.getParentDirectory(File dir) 返回 dir 的父目录。
File[] | FileSystemView.getRoots() 返回此系统的所有根分区。

参数类型为 File 的 javax.swing.filechooser 中的方法
boolean | FileNameExtensionFilter.accept(File f) 测试指定的文件，如果该文件被接受，则返回 true，否则返回 false。
abstract boolean | FileFilter.accept(File f) 此过滤器是否接受给定的文件。
File | FileSystemView.createFileObject(File dir, String filename) 返回根据给定的 filename 在 dir 中构造的 File 对象。
protected File | FileSystemView.createFileSystemRoot(File f) 创建针对 f 的新 File 对象，使其对于文件系统根目录而言具有正确的行为。
abstract File | FileSystemView.createNewFolder(File containingDir) 创建具有默认文件夹名称的新文件夹。
File | FileSystemView.getChild(File parent, String fileName)
String | FileView.getDescription(File f) 文件的可读描述。
File[] | FileSystemView.getFiles(File dir, boolean useFileHiding) 获取显示的（即未隐藏）文件的列表。
Icon | FileView.getIcon(File f) 表示 JFileChooser 中此文件的图标。
String | FileView.getName(File f) 文件名称。
File | FileSystemView.getParentDirectory(File dir) 返回 dir 的父目录。
String | FileSystemView.getSystemDisplayName(File f) 在系统文件浏览器中显示的文件、目录或文件夹名。
Icon | FileSystemView.getSystemIcon(File f) 在系统文件浏览器中显示的文件、目录或文件夹的图标。
String | FileSystemView.getSystemTypeDescription(File f) 在系统文件浏览器中显示的文件、目录或文件夹类型描述。
String | FileView.getTypeDescription(File f) 文件类型的可读描述。
boolean | FileSystemView.isComputerNode(File dir) UI 类使用此方法来决定是否为计算机节点显示特殊图标，例如，“我的电脑”或网络服务器。
boolean | FileSystemView.isDrive(File dir) UI 类使用此方法来决定是否为驱动器或分区显示特殊图标，例如，“硬盘”图标。
boolean | FileSystemView.isFileSystem(File f) 检查 f 是否表示一个相对于特殊文件夹（如 "Desktop"）的实际目录或文件。
boolean | FileSystemView.isFileSystemRoot(File dir) 判断 dir 是否是文件系统（如驱动器或分区）中的树的根。
boolean | FileSystemView.isFloppyDrive(File dir) UI 类使用此方法来决定是否为软盘显示特殊图标。
boolean | FileSystemView.isHiddenFile(File f) 返回某个文件是否被隐藏。
boolean | FileSystemView.isParent(File folder, File file) 在 Windows 中，一个文件可以出现在多个文件夹，但在文件系统中的父目录中除外。
boolean | FileSystemView.isRoot(File f) 确定给定文件是否是导航树中的根。
Boolean | FileSystemView.isTraversable(File f) 如果可以访问文件（目录），则返回 true。
Boolean | FileView.isTraversable(File f) 目录是否是可遍历的。

javax.swing.plaf 中 File 的使用

参数类型为 File 的 javax.swing.plaf 中的方法
abstract  void FileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)

javax.swing.plaf.basic 中 File 的使用

类型参数类型为 File 的 javax.swing.plaf.basic 中的字段
protected  Hashtable<File,Icon> BasicFileChooserUI.BasicFileView.iconCache

返回 File 的 javax.swing.plaf.basic 中的方法
protected  File BasicFileChooserUI.getDirectory()
记忆当前在 UI 中选择的目录的属性。

返回变量类型为 File 的类型的 javax.swing.plaf.basic 中的方法
Vector<File> | BasicDirectoryModel.getDirectories()
Vector<File> | BasicDirectoryModel.getFiles()

参数类型为 File 的 javax.swing.plaf.basic 中的方法
boolean | BasicFileChooserUI.AcceptAllFileFilter.accept(File f)
void | BasicFileChooserUI.BasicFileView.cacheIcon(File f, Icon i)
void | BasicFileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
Icon | BasicFileChooserUI.BasicFileView.getCachedIcon(File f)
String | BasicFileChooserUI.BasicFileView.getDescription(File f)
Icon | BasicFileChooserUI.BasicFileView.getIcon(File f)
String | BasicFileChooserUI.BasicFileView.getName(File f)
String | BasicFileChooserUI.BasicFileView.getTypeDescription(File f)
Boolean | BasicFileChooserUI.BasicFileView.isHidden(File f)
protected boolean | BasicDirectoryModel.lt(File a, File b)
boolean | BasicDirectoryModel.renameFile(File oldFile, File newFile) 重命名底层文件系统中的文件。
protected void | BasicFileChooserUI.setDirectory(File f) 记忆当前在 UI 中选择的目录的属性。

类型变量类型为 File 的 javax.swing.plaf.basic 中的方法参数
protected  void BasicDirectoryModel.sort(Vector<? extends File> v)

javax.swing.plaf.metal 中 File 的使用

参数类型为 File 的 javax.swing.plaf.metal 中的方法
 void MetalFileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)

javax.swing.plaf.multi 中 File 的使用

参数类型为 File 的 javax.swing.plaf.multi 中的方法
 void MultiFileChooserUI.ensureFileIsVisible(JFileChooser a, File b)
在由此对象处理的每个 UI 上调用 ensureFileIsVisible 方法。

javax.tools 中 File 的使用

返回变量类型为 File 的类型的 javax.tools 中的方法
 Iterable<? extends File> StandardJavaFileManager.getLocation(JavaFileManager.Location location)
获取与给定位置关联的路径。

参数类型为 File 的 javax.tools 中的方法
 Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects(File... files)
获取表示给定文件的文件对象。

类型变量类型为 File 的 javax.tools 中的方法参数
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File> files) 获取表示给定文件的文件对象。
void | StandardJavaFileManager.setLocation(JavaFileManager.Location location, Iterable<? extends File> path) 将给定路径与给定位置关联。

javax.xml.bind 中 File 的使用

参数类型为 File 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(File f)
从指定的文件解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 File 的使用

参数类型为 File 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(File f)

javax.xml.parsers 中 File 的使用

参数类型为 File 的 javax.xml.parsers 中的方法
Document | DocumentBuilder.parse(File f) 将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(File f, DefaultHandler dh) 使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
void | SAXParser.parse(File f, HandlerBase hb) 使用指定的 HandlerBase 将指定文件的内容解析为 XML。

javax.xml.transform.stream 中 File 的使用

参数类型为 File 的 javax.xml.transform.stream 中的方法
void | StreamResult.setSystemId(File f) 设置来自 File 引用的系统 ID。
void | StreamSource.setSystemId(File f) 设置来自 File 引用的系统 ID。

参数类型为 File 的 javax.xml.transform.stream 中的构造方法
StreamResult(File f)
从 File 构造 StreamResult。
StreamSource(File f)
从 File 构造 StreamSource。

javax.xml.validation 中 File 的使用

参数类型为 File 的 javax.xml.validation 中的方法
 Schema SchemaFactory.newSchema(File schema)
解析作为模式的指定 File 并以 Schema 的形式返回它。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FileDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileDescriptor
的使用

使用 FileDescriptor 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。

java.io 中 FileDescriptor 的使用

声明为 FileDescriptor 的 java.io 中的字段
static FileDescriptor | FileDescriptor.err 标准错误流的句柄。
static FileDescriptor | FileDescriptor.in 标准输入流的句柄。
static FileDescriptor | FileDescriptor.out 标准输出流的句柄。

返回 FileDescriptor 的 java.io 中的方法
FileDescriptor | RandomAccessFile.getFD() 返回与此流关联的不透明文件描述符对象。
FileDescriptor | FileOutputStream.getFD() 返回与此流有关的文件描述符。
FileDescriptor | FileInputStream.getFD() 返回表示到文件系统中实际文件的连接的 FileDescriptor 对象，该文件系统正被此 FileInputStream 使用。

参数类型为 FileDescriptor 的 java.io 中的构造方法
FileInputStream(FileDescriptor fdObj)
通过使用文件描述符 fdObj 创建一个 FileInputStream，该文件描述符表示到文件系统中某个实际文件的现有连接。
FileOutputStream(FileDescriptor fdObj)
创建一个向指定文件描述符处写入数据的输出文件流，该文件描述符表示一个到文件系统中的某个实际文件的现有连接。
FileReader(FileDescriptor fd)
在给定从中读取数据的 FileDescriptor 的情况下创建一个新 FileReader。
FileWriter(FileDescriptor fd)
构造与某个文件描述符相关联的 FileWriter 对象。

java.lang 中 FileDescriptor 的使用

参数类型为 FileDescriptor 的 java.lang 中的方法
void | SecurityManager.checkRead(FileDescriptor fd) 如果不允许调用线程从指定的文件描述符进行读取，则抛出 SecurityException。
void | SecurityManager.checkWrite(FileDescriptor fd) 如果不允许调用线程写入指定的文件描述符，则抛出 SecurityException。

java.net 中 FileDescriptor 的使用

声明为 FileDescriptor 的 java.net 中的字段
protected FileDescriptor | DatagramSocketImpl.fd 文件描述符对象。
protected FileDescriptor | SocketImpl.fd 此套接字的文件描述符对象。

返回 FileDescriptor 的 java.net 中的方法
protected FileDescriptor | DatagramSocketImpl.getFileDescriptor() 获取数据报套接字文件描述符。
protected FileDescriptor | SocketImpl.getFileDescriptor() 返回此套接字的 fd 字段的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.FileFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.FileFilter
的使用

使用 FileFilter 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 FileFilter 的使用

参数类型为 FileFilter 的 java.io 中的方法
 File[] File.listFiles(FileFilter filter)
返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FileInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileInputStream
的使用

没有 java.io.FileInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.FilenameFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.FilenameFilter
的使用

使用 FilenameFilter 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。

java.awt 中 FilenameFilter 的使用

返回 FilenameFilter 的 java.awt 中的方法
 FilenameFilter FileDialog.getFilenameFilter()
确定此文件对话框的文件名过滤器。

参数类型为 FilenameFilter 的 java.awt 中的方法
 void FileDialog.setFilenameFilter(FilenameFilter filter)
将此文件对话框窗口的文件名过滤器设置为指定的过滤器。

java.io 中 FilenameFilter 的使用

参数类型为 FilenameFilter 的 java.io 中的方法
String[] | File.list(FilenameFilter filter) 返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中满足指定过滤器的文件和目录。
File[] | File.listFiles(FilenameFilter filter) 返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FileNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileNotFoundException
的使用

使用 FileNotFoundException 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

java.io 中 FileNotFoundException 的使用

抛出 FileNotFoundException 的 java.io 中的构造方法
FileInputStream(File file)
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的 File 对象 file 指定。
FileInputStream(String name)
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的路径名 name 指定。
FileOutputStream(File file)
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(File file, boolean append)
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(String name)
创建一个向具有指定名称的文件中写入数据的输出文件流。
FileOutputStream(String name, boolean append)
创建一个向具有指定 name 的文件中写入数据的输出文件流。
FileReader(File file)
在给定从中读取数据的 File 的情况下创建一个新 FileReader。
FileReader(String fileName)
在给定从中读取数据的文件名的情况下创建一个新 FileReader。
PrintStream(File file)
创建具有指定文件且不带自动行刷新的新打印流。
PrintStream(File file, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintStream(String fileName)
创建具有指定文件名称且不带自动行刷新的新打印流。
PrintStream(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintWriter(File file)
使用指定文件创建不具有自动行刷新的新 PrintWriter。
PrintWriter(File file, String csn)
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。
PrintWriter(String fileName)
创建具有指定文件名称且不带自动行刷新的新 PrintWriter。
PrintWriter(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新 PrintWriter。
RandomAccessFile(File file, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件由 File 参数指定。
RandomAccessFile(String name, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件具有指定名称。

java.util 中 FileNotFoundException 的使用

抛出 FileNotFoundException 的 java.util 中的构造方法
Formatter(File file)
构造一个带指定文件的新 formatter。
Formatter(File file, String csn)
构造一个带指定文件和字符集的新 formatter。
Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。
Formatter(String fileName)
构造一个带指定文件名的新 formatter。
Formatter(String fileName, String csn)
构造一个带指定文件名和字符集的新 formatter。
Formatter(String fileName, String csn, Locale l)
构造一个带指定文件名、字符集和语言环境的新 formatter。
Scanner(File source)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。
Scanner(File source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。

javax.imageio.stream 中 FileNotFoundException 的使用

抛出 FileNotFoundException 的 javax.imageio.stream 中的构造方法
FileImageInputStream(File f)
构造一个将从给定 File 进行读取的 FileImageInputStream。
FileImageOutputStream(File f)
构造一个将向给定 File 进行写入的 FileImageOutputStream。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FileOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileOutputStream
的使用

没有 java.io.FileOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FilePermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FilePermission
的使用

没有 java.io.FilePermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FileReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileReader
的使用

没有 java.io.FileReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FileWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileWriter
的使用

没有 java.io.FileWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FilterInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FilterInputStream
的使用

使用 FilterInputStream 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.security | 为安全框架提供类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.crypto | 为加密操作提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.io 中 FilterInputStream 的使用

java.io 中 FilterInputStream 的子类
class | BufferedInputStream BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。
class | DataInputStream 数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
class | LineNumberInputStream 已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
class | PushbackInputStream PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。

java.security 中 FilterInputStream 的使用

java.security 中 FilterInputStream 的子类
 class DigestInputStream
使用通过流的位更新关联消息摘要的透明流。

java.util.jar 中 FilterInputStream 的使用

java.util.jar 中 FilterInputStream 的子类
 class JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。

java.util.zip 中 FilterInputStream 的使用

java.util.zip 中 FilterInputStream 的子类
class | CheckedInputStream 需要维护所读取数据校验和的输入流。
class | DeflaterInputStream 为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。
class | GZIPInputStream 此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
class | InflaterInputStream 此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
class | ZipInputStream 此类为读取 ZIP 文件格式的文件实现输入流过滤器。

javax.crypto 中 FilterInputStream 的使用

javax.crypto 中 FilterInputStream 的子类
 class CipherInputStream
CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。

javax.swing 中 FilterInputStream 的使用

javax.swing 中 FilterInputStream 的子类
 class ProgressMonitorInputStream
监视读取某些 InputStream 的进度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FilterOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FilterOutputStream
的使用

使用 FilterOutputStream 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.crypto | 为加密操作提供类和接口。

java.io 中 FilterOutputStream 的使用

java.io 中 FilterOutputStream 的子类
class | BufferedOutputStream 该类实现缓冲的输出流。
class | DataOutputStream 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
class | PrintStream PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。

java.rmi.server 中 FilterOutputStream 的使用

java.rmi.server 中 FilterOutputStream 的子类
 class LogStream
已过时。 无替代版本

java.security 中 FilterOutputStream 的使用

java.security 中 FilterOutputStream 的子类
 class DigestOutputStream
使用通过流的位更新关联消息摘要的透明流。

java.util.jar 中 FilterOutputStream 的使用

java.util.jar 中 FilterOutputStream 的子类
 class JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

java.util.zip 中 FilterOutputStream 的使用

java.util.zip 中 FilterOutputStream 的子类
class | CheckedOutputStream 需要维护写入数据校验和的输出流。
class | DeflaterOutputStream 此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
class | GZIPOutputStream 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
class | InflaterOutputStream 为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
class | ZipOutputStream 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

javax.crypto 中 FilterOutputStream 的使用

javax.crypto 中 FilterOutputStream 的子类
 class CipherOutputStream
CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FilterReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FilterReader
的使用

使用 FilterReader 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 FilterReader 的使用

java.io 中 FilterReader 的子类
 class PushbackReader
允许将字符推回到流的字符流 reader。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.FilterWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FilterWriter
的使用

没有 java.io.FilterWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.Flushable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.Flushable
的使用

使用 Flushable 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.crypto | 为加密操作提供类和接口。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.io 中 Flushable 的使用

实现 Flushable 的 java.io 中的类
class | BufferedOutputStream 该类实现缓冲的输出流。
class | BufferedWriter 将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
class | ByteArrayOutputStream 此类实现了一个输出流，其中的数据被写入一个 byte 数组。
class | CharArrayWriter 此类实现一个可用作 Writer 的字符缓冲区。
class | Console 此类包含多个方法，可访问与当前 Java 虚拟机关联的基于字符的控制台设备（如果有）。
class | DataOutputStream 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
class | FileOutputStream 文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。
class | FileWriter 用来写入字符文件的便捷类。
class | FilterOutputStream 此类是过滤输出流的所有类的超类。
class | FilterWriter 用于写入已过滤的字符流的抽象类。
class | ObjectOutputStream ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
class | OutputStream 此抽象类是表示输出字节流的所有类的超类。
class | OutputStreamWriter OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
class | PipedOutputStream 可以将管道输出流连接到管道输入流来创建通信管道。
class | PipedWriter 传送的字符输出流。
class | PrintStream PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
class | PrintWriter 向文本输出流打印对象的格式化表示形式。
class | StringWriter 一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。
class | Writer 写入字符流的抽象类。

java.rmi.server 中 Flushable 的使用

实现 Flushable 的 java.rmi.server 中的类
 class LogStream
已过时。 无替代版本

java.security 中 Flushable 的使用

实现 Flushable 的 java.security 中的类
 class DigestOutputStream
使用通过流的位更新关联消息摘要的透明流。

java.util 中 Flushable 的使用

实现 Flushable 的 java.util 中的类
 class Formatter
printf 风格的格式字符串的解释程序。

java.util.jar 中 Flushable 的使用

实现 Flushable 的 java.util.jar 中的类
 class JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

java.util.zip 中 Flushable 的使用

实现 Flushable 的 java.util.zip 中的类
class | CheckedOutputStream 需要维护写入数据校验和的输出流。
class | DeflaterOutputStream 此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
class | GZIPOutputStream 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
class | InflaterOutputStream 为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
class | ZipOutputStream 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

javax.crypto 中 Flushable 的使用

实现 Flushable 的 javax.crypto 中的类
 class CipherOutputStream
CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。

javax.tools 中 Flushable 的使用

javax.tools 中 Flushable 的子接口
interface | JavaFileManager 在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。
interface | StandardJavaFileManager 基于 java.io.File 的文件管理器。

实现 Flushable 的 javax.tools 中的类
 class ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.InputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.InputStream
的使用

使用 InputStream 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.activation |
javax.crypto | 为加密操作提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.management.loading | 提供实现高级动态加载的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.cert | 为公钥证书提供类。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。

java.applet 中 InputStream 的使用

返回 InputStream 的 java.applet 中的方法
 InputStream AppletContext.getStream(String key)
返回此 applet 上下文中指定键所关联的流。

参数类型为 InputStream 的 java.applet 中的方法
 void AppletContext.setStream(String key, InputStream stream)
在此 applet 上下文中用指定的键关联指定的流。

java.awt 中 InputStream 的使用

参数类型为 InputStream 的 java.awt 中的方法
static Font Font.createFont(int fontFormat, InputStream fontStream)
返回一个使用指定字体类型和输入数据的新 Font。

java.awt.color 中 InputStream 的使用

参数类型为 InputStream 的 java.awt.color 中的方法
static ICC_Profile ICC_Profile.getInstance(InputStream s)
构造一个与 InputStream 中的数据相对应的 ICC_Profile。

java.beans 中 InputStream 的使用

参数类型为 InputStream 的 java.beans 中的构造方法
XMLDecoder(InputStream in)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

java.beans.beancontext 中 InputStream 的使用

返回 InputStream 的 java.beans.beancontext 中的方法
 InputStream BeanContext.getResourceAsStream(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 InputStream BeanContextSupport.getResourceAsStream(String name, BeanContextChild bcc)

java.io 中 InputStream 的使用

java.io 中 InputStream 的子类
class | BufferedInputStream BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。
class | ByteArrayInputStream ByteArrayInputStream 包含一个内部缓冲区，该缓冲区包含从流中读取的字节。
class | DataInputStream 数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
class | FileInputStream FileInputStream 从文件系统中的某个文件中获得输入字节。
class | FilterInputStream FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
class | LineNumberInputStream 已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
class | ObjectInputStream ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
class | PipedInputStream 管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。
class | PushbackInputStream PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。
class | SequenceInputStream SequenceInputStream 表示其他输入流的逻辑串联。
class | StringBufferInputStream 已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。

声明为 InputStream 的 java.io 中的字段
protected  InputStream FilterInputStream.in
要过滤的输入流。

参数类型为 InputStream 的 java.io 中的构造方法
BufferedInputStream(InputStream in)
创建一个 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。
BufferedInputStream(InputStream in, int size)
创建具有指定缓冲区大小的 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。
DataInputStream(InputStream in)
使用指定的底层 InputStream 创建一个 DataInputStream。
FilterInputStream(InputStream in)
将参数 in 分配给字段 this.in，以便记住它供以后使用，通过这种方式创建一个 FilterInputStream。
InputStreamReader(InputStream in)
创建一个使用默认字符集的 InputStreamReader。
InputStreamReader(InputStream in, Charset cs)
创建使用给定字符集的 InputStreamReader。
InputStreamReader(InputStream in, CharsetDecoder dec)
创建使用给定字符集解码器的 InputStreamReader。
InputStreamReader(InputStream in, String charsetName)
创建使用指定字符集的 InputStreamReader。
LineNumberInputStream(InputStream in)
已过时。 构造从指定输入流读取其输入的新行号输入流。
ObjectInputStream(InputStream in)
创建从指定 InputStream 读取的 ObjectInputStream。
PushbackInputStream(InputStream in)
创建 PushbackInputStream 并保存其参数（即输入流 in），以供将来使用。
PushbackInputStream(InputStream in, int size)
使用指定 size 的推回缓冲区创建 PushbackInputStream，并保存其参数（即输入流 in），以供将来使用。
SequenceInputStream(InputStream s1, InputStream s2)
通过记住这两个参数来初始化新创建的 SequenceInputStream（将按顺序读取这两个参数，先读取 s1，然后读取 s2），以提供从此 SequenceInputStream 读取的字节。
StreamTokenizer(InputStream is)
已过时。 从 JDK 版本 1.1 开始，标记输入流的首选方法是将其转换为一个字符流，例如：
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);

类型变量类型为 InputStream 的 java.io 中的构造方法参数
SequenceInputStream(Enumeration<? extends InputStream> e)
通过记住参数来初始化新创建的 SequenceInputStream，该参数必须是生成运行时类型为 InputStream 对象的 Enumeration 型参数。

java.lang 中 InputStream 的使用

声明为 InputStream 的 java.lang 中的字段
static InputStream System.in
“标准”输入流。

返回 InputStream 的 java.lang 中的方法
abstract InputStream | Process.getErrorStream() 获取子进程的错误流。
abstract InputStream | Process.getInputStream() 获取子进程的输入流。
InputStream | Runtime.getLocalizedInputStream(InputStream in) 已过时。 从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。
InputStream | ClassLoader.getResourceAsStream(String name) 返回读取指定资源的输入流。
InputStream | Class.getResourceAsStream(String name) 查找具有给定名称的资源。
static InputStream | ClassLoader.getSystemResourceAsStream(String name) 从用来加载类的搜索路径打开具有指定名称的资源，以读取该资源。

参数类型为 InputStream 的 java.lang 中的方法
InputStream | Runtime.getLocalizedInputStream(InputStream in) 已过时。 从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。
static void | System.setIn(InputStream in) 重新分配“标准”输入流。

java.net 中 InputStream 的使用

返回 InputStream 的 java.net 中的方法
abstract InputStream | CacheResponse.getBody() 以 InputStream 的形式返回响应正文。
InputStream | HttpURLConnection.getErrorStream() 如果连接失败但服务器仍然发送了有用数据，则返回错误流。
protected abstract InputStream | SocketImpl.getInputStream() 返回此套接字的输入流。
InputStream | Socket.getInputStream() 返回此套接字的输入流。
InputStream | URLConnection.getInputStream() 返回从此打开的连接读取的输入流。
InputStream | URL.openStream() 打开到此 URL 的连接并返回一个用于从该连接读入的 InputStream。

参数类型为 InputStream 的 java.net 中的方法
static String URLConnection.guessContentTypeFromStream(InputStream is)
根据输入流的开始字符尝试确定输入流的类型。

java.nio.channels 中 InputStream 的使用

返回 InputStream 的 java.nio.channels 中的方法
static InputStream Channels.newInputStream(ReadableByteChannel ch)
构造从给定信道读取字节的流。

参数类型为 InputStream 的 java.nio.channels 中的方法
static ReadableByteChannel Channels.newChannel(InputStream in)
构造从给定流读取字节的信道。

java.security 中 InputStream 的使用

java.security 中 InputStream 的子类
 class DigestInputStream
使用通过流的位更新关联消息摘要的透明流。

参数类型为 InputStream 的 java.security 中的方法
void | Certificate.decode(InputStream stream) 已过时。 从输入流解码证书。
abstract void | KeyStoreSpi.engineLoad(InputStream stream, char[] password) 从给定的输入流中加载此 KeyStore。
void | Provider.load(InputStream inStream) 从输入流中读取属性列表（键和元素对）。
void | KeyStore.load(InputStream stream, char[] password) 从给定输入流中加载此 KeyStore。

参数类型为 InputStream 的 java.security 中的构造方法
DigestInputStream(InputStream stream, MessageDigest digest)
使用指定的输入流和消息摘要创建一个摘要输入流。

java.security.cert 中 InputStream 的使用

参数类型为 InputStream 的 java.security.cert 中的方法
abstract Certificate | CertificateFactorySpi.engineGenerateCertificate(InputStream inStream) 生成一个证书对象并使用从输入流 inStream 中读取的数据对它进行初始化。
abstract Collection<? extends Certificate> | CertificateFactorySpi.engineGenerateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
abstract CRL | CertificateFactorySpi.engineGenerateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
abstract Collection<? extends CRL> | CertificateFactorySpi.engineGenerateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
Certificate | CertificateFactory.generateCertificate(InputStream inStream) 生成一个证书对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
Collection<? extends Certificate> | CertificateFactory.generateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
CertPath | CertificateFactory.generateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactory.generateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CRL | CertificateFactory.generateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
Collection<? extends CRL> | CertificateFactory.generateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。

java.sql 中 InputStream 的使用

返回 InputStream 的 java.sql 中的方法
InputStream | Clob.getAsciiStream() 以 ascii 流形式获取此 Clob 对象指定的 CLOB 值。
InputStream | ResultSet.getAsciiStream(int columnIndex) 以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | ResultSet.getAsciiStream(String columnLabel) 以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | Blob.getBinaryStream() 以流的形式获取此 Blob 实例指定的 BLOB 值。
InputStream | SQLXML.getBinaryStream() 以流的形式获取此 SQLXML 实例指定的 XML 值。
InputStream | ResultSet.getBinaryStream(int columnIndex) 以未解释字节的流的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | Blob.getBinaryStream(long pos, long length) 返回包含部分 Blob 值的 InputStream 对象，该值从 pos 指定的字节开始，长度为 length 个字节。
InputStream | ResultSet.getBinaryStream(String columnLabel) 以未解释的 byte 流的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | ResultSet.getUnicodeStream(int columnIndex) 已过时。 使用 getCharacterStream 取代 getUnicodeStream
InputStream | ResultSet.getUnicodeStream(String columnLabel) 已过时。 使用 getCharacterStream 代替
InputStream | SQLInput.readAsciiStream() 读取流中的下一个属性并将其作为 ASCII 字符流返回。
InputStream | SQLInput.readBinaryStream() 读取流中的下一个属性并将其作为未解释的字节流返回。

参数类型为 InputStream 的 java.sql 中的方法
void | PreparedStatement.setAsciiStream(int parameterIndex, InputStream x) 将指定参数设置为给定输入流。
void | PreparedStatement.setAsciiStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将具有给定字节数。
void | PreparedStatement.setAsciiStream(int parameterIndex, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将具有指定字节数。
void | CallableStatement.setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | CallableStatement.setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
void | CallableStatement.setAsciiStream(String parameterName, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
void | PreparedStatement.setBinaryStream(int parameterIndex, InputStream x) 将指定参数设置为给定输入流。
void | PreparedStatement.setBinaryStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将具有给定字节数。
void | PreparedStatement.setBinaryStream(int parameterIndex, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将具有指定字节数。
void | CallableStatement.setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | CallableStatement.setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
void | CallableStatement.setBinaryStream(String parameterName, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | PreparedStatement.setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | PreparedStatement.setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | CallableStatement.setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | CallableStatement.setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | PreparedStatement.setUnicodeStream(int parameterIndex, InputStream x, int length) 已过时。
void | ResultSet.updateAsciiStream(int columnIndex, InputStream x) 用 ascii 流值更新指定的列。
void | ResultSet.updateAsciiStream(int columnIndex, InputStream x, int length) 用 ascii 流值更新指定列，该列将具有指定字节数。
void | ResultSet.updateAsciiStream(int columnIndex, InputStream x, long length) 用 ascii 流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateAsciiStream(String columnLabel, InputStream x) 用 ascii 流值更新指定列。
void | ResultSet.updateAsciiStream(String columnLabel, InputStream x, int length) 用 ascii 流值更新指定列，该列具有指定的字节数。
void | ResultSet.updateAsciiStream(String columnLabel, InputStream x, long length) 用 ascii 流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateBinaryStream(int columnIndex, InputStream x) 用二进制流值更新指定的列。
void | ResultSet.updateBinaryStream(int columnIndex, InputStream x, int length) 用二进制流值更新指定列，该列将具有指定字节数。
void | ResultSet.updateBinaryStream(int columnIndex, InputStream x, long length) 用二进制流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateBinaryStream(String columnLabel, InputStream x) 用二进制流值更新指定列。
void | ResultSet.updateBinaryStream(String columnLabel, InputStream x, int length) 用二进制流值更新指定列，该列具有指定的字节数。
void | ResultSet.updateBinaryStream(String columnLabel, InputStream x, long length) 用二进制流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateBlob(int columnIndex, InputStream inputStream) 使用给定输入流值更新指定列。
void | ResultSet.updateBlob(int columnIndex, InputStream inputStream, long length) 使用给定输入流更新指定的列，该流将具有指定的字节数。
void | ResultSet.updateBlob(String columnLabel, InputStream inputStream) 使用给定输入流值更新指定列。
void | ResultSet.updateBlob(String columnLabel, InputStream inputStream, long length) 使用给定输入流更新指定列，该流将具有指定的字节数。
void | SQLOutput.writeAsciiStream(InputStream x) 将下一个属性作为 ASCII 字符流写入流中。
void | SQLOutput.writeBinaryStream(InputStream x) 将下一个属性作为未解释字节流写入流中。

java.util 中 InputStream 的使用

参数类型为 InputStream 的 java.util 中的方法
void | Properties.load(InputStream inStream) 从输入流中读取属性列表（键和元素对）。
void | Properties.loadFromXML(InputStream in) 将指定输入流中由 XML 文档所表示的所有属性加载到此属性表中。

参数类型为 InputStream 的 java.util 中的构造方法
PropertyResourceBundle(InputStream stream)
根据 InputStream 创建属性资源包。
Scanner(InputStream source)
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。
Scanner(InputStream source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。

java.util.jar 中 InputStream 的使用

java.util.jar 中 InputStream 的子类
 class JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。

返回 InputStream 的 java.util.jar 中的方法
 InputStream JarFile.getInputStream(ZipEntry ze)
返回用于读取指定 zip 文件条目内容的输入流。

参数类型为 InputStream 的 java.util.jar 中的方法
void | Manifest.read(InputStream is) 从指定的 InputStream 读取 Manifest。
void | Pack200.Unpacker.unpack(InputStream in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。

参数类型为 InputStream 的 java.util.jar 中的构造方法
JarInputStream(InputStream in)
创建新的 JarInputStream 并读取可选的清单。
JarInputStream(InputStream in, boolean verify)
创建新的 JarInputStream 并读取可选的清单。
Manifest(InputStream is)
从指定的输入流构造新的 Manifest。

java.util.logging 中 InputStream 的使用

参数类型为 InputStream 的 java.util.logging 中的方法
 void LogManager.readConfiguration(InputStream ins)
从给定流重新初始化并重新读取日志配置，该配置为 java.util.Properties 格式。

java.util.prefs 中 InputStream 的使用

参数类型为 InputStream 的 java.util.prefs 中的方法
static void Preferences.importPreferences(InputStream is)
导入指定输入流中由 XML 文档表示的所有首选项。

java.util.zip 中 InputStream 的使用

java.util.zip 中 InputStream 的子类
class | CheckedInputStream 需要维护所读取数据校验和的输入流。
class | DeflaterInputStream 为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。
class | GZIPInputStream 此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
class | InflaterInputStream 此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
class | ZipInputStream 此类为读取 ZIP 文件格式的文件实现输入流过滤器。

返回 InputStream 的 java.util.zip 中的方法
 InputStream ZipFile.getInputStream(ZipEntry entry)
返回输入流以读取指定 ZIP 文件条目的内容。

参数类型为 InputStream 的 java.util.zip 中的构造方法
CheckedInputStream(InputStream in, Checksum cksum)
使用指定校验和创建输入流。
DeflaterInputStream(InputStream in)
创建一个带有默认压缩器和缓冲区大小的新输入流。
DeflaterInputStream(InputStream in, Deflater defl)
创建一个带有指定压缩器和默认缓冲区大小的新输入流。
DeflaterInputStream(InputStream in, Deflater defl, int bufLen)
创建一个带有指定压缩器和缓冲区大小的新输入流。
GZIPInputStream(InputStream in)
使用默认缓冲区大小创建新的输入流。
GZIPInputStream(InputStream in, int size)
使用指定缓冲区大小创建新的输入流。
InflaterInputStream(InputStream in)
使用默认解压缩器和缓冲区大小创建一个新输入流。
InflaterInputStream(InputStream in, Inflater inf)
创建一个带有指定解压缩器和默认缓冲区大小的新输入流。
InflaterInputStream(InputStream in, Inflater inf, int size)
使用指定解压缩器和缓冲区大小创建一个新输入流。
ZipInputStream(InputStream in)
创建新的 ZIP 输入流。

javax.accessibility 中 InputStream 的使用

返回 InputStream 的 javax.accessibility 中的方法
 InputStream AccessibleStreamable.getStream(DataFlavor flavor)
返回 DataFlavor 的 InputStream

javax.activation 中 InputStream 的使用

返回 InputStream 的 javax.activation 中的方法
InputStream | DataHandler.getInputStream() 获取此对象的 InputSteam。
InputStream | DataSource.getInputStream() 此方法返回一个表示数据的 InputStream；如果无法提供，则抛出适当的异常。
InputStream | FileDataSource.getInputStream() 此方法将返回一个表示数据的 InputStream；如果不能返回，则抛出 IOException。
InputStream | URLDataSource.getInputStream() URL 的 getInputStream 方法。

参数类型为 InputStream 的 javax.activation 中的构造方法
MailcapCommandMap(InputStream is)
允许调用者指定一个包含 mailcap 文件的 InputStream 的构造方法。
MimetypesFileTypeMap(InputStream is)
用从 InputStream 中添加的编程条目构造 MimetypesFileTypeMap。

javax.crypto 中 InputStream 的使用

javax.crypto 中 InputStream 的子类
 class CipherInputStream
CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。

参数类型为 InputStream 的 javax.crypto 中的构造方法
CipherInputStream(InputStream is)
根据 InputStream 构造 CipherInputStream，不指定 Cipher。
CipherInputStream(InputStream is, Cipher c)
根据 InputStream 和 Cipher 构造 CipherInputStream。

javax.imageio 中 InputStream 的使用

参数类型为 InputStream 的 javax.imageio 中的方法
static BufferedImage ImageIO.read(InputStream input)
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 InputStream 的结果。

javax.imageio.stream 中 InputStream 的使用

参数类型为 InputStream 的 javax.imageio.stream 中的构造方法
FileCacheImageInputStream(InputStream stream, File cacheDir)
构造一个将从给定 InputStream 进行读取的 FileCacheImageInputStream。
MemoryCacheImageInputStream(InputStream stream)
构造一个将从给定 InputStream 进行读取的 MemoryCacheImageInputStream。

javax.management.loading 中 InputStream 的使用

返回 InputStream 的 javax.management.loading 中的方法
 InputStream MLetMBean.getResourceAsStream(String name)
返回读取指定资源的输入流。

javax.print 中 InputStream 的使用

返回 InputStream 的 javax.print 中的方法
InputStream | Doc.getStreamForBytes() 获得一个从此 doc 中提取 byte 打印数据的输入流。
InputStream | SimpleDoc.getStreamForBytes() 获得一个从此 doc 中提取 byte 打印数据的输入流。

javax.security.auth.x500 中 InputStream 的使用

参数类型为 InputStream 的 javax.security.auth.x500 中的构造方法
X500Principal(InputStream is)
根据包含 ASN.1 DER 编码格式的标识名的 InputStream 创建 X500Principal。

javax.security.cert 中 InputStream 的使用

参数类型为 InputStream 的 javax.security.cert 中的方法
static X509Certificate X509Certificate.getInstance(InputStream inStream)
实例化一个 X509Certificate 对象，并使用从输入流 inStream 读取的数据初始化它。

javax.sound.midi 中 InputStream 的使用

参数类型为 InputStream 的 javax.sound.midi 中的方法
static MidiFileFormat | MidiSystem.getMidiFileFormat(InputStream stream) 获得指定的输入流中数据的 MIDI 文件格式。
static Sequence | MidiSystem.getSequence(InputStream stream) 从指定的输入流获得 MIDI 序列。
static Soundbank | MidiSystem.getSoundbank(InputStream stream) 通过从指定的流读取来构造一个 MIDI 音库。
void | Sequencer.setSequence(InputStream stream) 设置 sequencer 所操作的当前 sequence。

javax.sound.midi.spi 中 InputStream 的使用

参数类型为 InputStream 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(InputStream stream) 获得所提供的输入流的 MIDI 文件格式。
abstract Sequence | MidiFileReader.getSequence(InputStream stream) 从提供的输入流获得 MIDI 序列。
abstract Soundbank | SoundbankReader.getSoundbank(InputStream stream) 从提供的 InputStream 获得音库对象。

javax.sound.sampled 中 InputStream 的使用

javax.sound.sampled 中 InputStream 的子类
 class AudioInputStream
音频输入流是具有指定音频格式和长度的输入流。

参数类型为 InputStream 的 javax.sound.sampled 中的方法
static AudioFileFormat | AudioSystem.getAudioFileFormat(InputStream stream) 获得提供的音频输入流的音频文件格式。
static AudioInputStream | AudioSystem.getAudioInputStream(InputStream stream) 从提供的输入流获得音频输入流。

参数类型为 InputStream 的 javax.sound.sampled 中的构造方法
AudioInputStream(InputStream stream, AudioFormat format, long length)
使用指定输入流中的音频数据构造具有请求的格式和长度（以示例帧为单位）的音频输入流。

javax.sound.sampled.spi 中 InputStream 的使用

参数类型为 InputStream 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(InputStream stream) 获得所提供输入流的音频文件格式。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(InputStream stream) 从所提供的输入流中获得音频输入流。

javax.sql 中 InputStream 的使用

参数类型为 InputStream 的 javax.sql 中的方法
void | RowSet.setAsciiStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | RowSet.setAsciiStream(int parameterIndex, InputStream x, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
void | RowSet.setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | RowSet.setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | RowSet.setBinaryStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | RowSet.setBinaryStream(int parameterIndex, InputStream x, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
void | RowSet.setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | RowSet.setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有给定字节数。
void | RowSet.setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。

javax.sql.rowset 中 InputStream 的使用

声明为 InputStream 的 javax.sql.rowset 中的字段
protected InputStream | BaseRowSet.asciiStream 将由方法 getAsciiStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
protected InputStream | BaseRowSet.binaryStream 将由方法 getBinaryStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
protected InputStream | BaseRowSet.unicodeStream 将由方法 getUnicodeStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

参数类型为 InputStream 的 javax.sql.rowset 中的方法
void | WebRowSet.readXml(InputStream iStream) 读取基于流的 XML 输入，以填充此 WebRowSet 对象。
void | BaseRowSet.setAsciiStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | BaseRowSet.setAsciiStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定的 java.io.InputStream 对象，该对象将具有指定的字节数。
void | BaseRowSet.setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定的输入流。
void | BaseRowSet.setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | BaseRowSet.setBinaryStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | BaseRowSet.setBinaryStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定的 java.io.InputStream 对象，该对象具有指定的字节数。
void | BaseRowSet.setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | BaseRowSet.setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定的输入流，该输入流将拥有指定的字节数。
void | BaseRowSet.setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | BaseRowSet.setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | BaseRowSet.setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | BaseRowSet.setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | BaseRowSet.setUnicodeStream(int parameterIndex, InputStream x, int length) 已过时。 应该使用 getCharacterStream 替代它

javax.sql.rowset.serial 中 InputStream 的使用

返回 InputStream 的 javax.sql.rowset.serial 中的方法
InputStream | SerialClob.getAsciiStream() 以 ascii 流的形式获取此 SerialClob 对象指定的 CLOB 值。
InputStream | SerialBlob.getBinaryStream() 以输入流的形式返回此 SerialBlob 对象。
InputStream | SerialBlob.getBinaryStream(long pos, long length) 返回一个包含部分 Blob 值的 InputStream 对象，它从 pos 指定的字节开始，具有 length 个字节长度。
InputStream | SQLInputImpl.readAsciiStream() 以 ASCII 字符流的形式返回此 SQLInputImpl 对象中的下一个属性。
InputStream | SQLInputImpl.readBinaryStream() 以未解释字节流的形式返回此 SQLInputImpl 对象中的下一个属性。

参数类型为 InputStream 的 javax.sql.rowset.serial 中的方法
void | SQLOutputImpl.writeAsciiStream(InputStream x) 将 ASCII 字符流写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBinaryStream(InputStream x) 将未解释字节流写入此 SQLOutputImpl 对象。

javax.swing 中 InputStream 的使用

javax.swing 中 InputStream 的子类
 class ProgressMonitorInputStream
监视读取某些 InputStream 的进度。

返回 InputStream 的 javax.swing 中的方法
protected  InputStream JEditorPane.getStream(URL page)
获取给定 URL 的流，该 URL 是将要由 setPage 方法加载的。

参数类型为 InputStream 的 javax.swing 中的方法
 void JEditorPane.read(InputStream in, Object desc)
此方法根据流进行初始化。

参数类型为 InputStream 的 javax.swing 中的构造方法
ProgressMonitorInputStream(Component parentComponent, Object message, InputStream in)
构造一个对象，以监视输入流的进度。

javax.swing.plaf.synth 中 InputStream 的使用

参数类型为 InputStream 的 javax.swing.plaf.synth 中的方法
 void SynthLookAndFeel.load(InputStream input, Class<?> resourceBase)
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。

javax.swing.text 中 InputStream 的使用

参数类型为 InputStream 的 javax.swing.text 中的方法
void | DefaultEditorKit.read(InputStream in, Document doc, int pos) 插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
abstract void | EditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。

javax.swing.text.rtf 中 InputStream 的使用

参数类型为 InputStream 的 javax.swing.text.rtf 中的方法
 void RTFEditorKit.read(InputStream in, Document doc, int pos)
插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。

javax.tools 中 InputStream 的使用

返回 InputStream 的 javax.tools 中的方法
InputStream | FileObject.openInputStream() 获取此文件对象的 InputStream。
InputStream | ForwardingFileObject.openInputStream()
InputStream | SimpleJavaFileObject.openInputStream() 此实现总是抛出 UnsupportedOperationException。

参数类型为 InputStream 的 javax.tools 中的方法
 int Tool.run(InputStream in, OutputStream out, OutputStream err, String... arguments)
使用给定 I/O 通道和参数运行工具。

javax.xml.bind 中 InputStream 的使用

参数类型为 InputStream 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(InputStream is)
从指定的 InputStream 解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 InputStream 的使用

参数类型为 InputStream 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(InputStream is)

javax.xml.crypto 中 InputStream 的使用

返回 InputStream 的 javax.xml.crypto 中的方法
 InputStream OctetStreamData.getOctetStream()
返回此 OctetStreamData 的输入流。

参数类型为 InputStream 的 javax.xml.crypto 中的构造方法
OctetStreamData(InputStream octetStream)
创建新的 SocketImpl。
OctetStreamData(InputStream octetStream, String uri, String mimeType)
创建新的 OctetStreamData。

javax.xml.crypto.dsig 中 InputStream 的使用

返回 InputStream 的 javax.xml.crypto.dsig 中的方法
InputStream | SignedInfo.getCanonicalizedData() 在执行签名或验证操作后，返回规范化的签名信息字节。
InputStream | Reference.getDigestInputStream() 如果已启用引用缓存，则返回预整理的输入流。

javax.xml.parsers 中 InputStream 的使用

参数类型为 InputStream 的 javax.xml.parsers 中的方法
Document | DocumentBuilder.parse(InputStream is) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputStream is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, DefaultHandler dh, String systemId) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb, String systemId) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
Document | DocumentBuilder.parse(InputStream is, String systemId) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。

javax.xml.soap 中 InputStream 的使用

返回 InputStream 的 javax.xml.soap 中的方法
abstract InputStream | AttachmentPart.getBase64Content() 以 Base64 编码字符数据的形式返回可用于获取 AttachmentPart 内容的 InputStream，此方法将对附件的原始字节进行 Base64 编码，然后返回该内容。
abstract InputStream | AttachmentPart.getRawContent() 以 InputStream 的形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。

参数类型为 InputStream 的 javax.xml.soap 中的方法
abstract SOAPMessage | MessageFactory.createMessage(MimeHeaders headers, InputStream in) 将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
abstract void | AttachmentPart.setBase64Content(InputStream content, String contentType) 根据 Base64 源 InputStream 设置此附件部分的内容，并将 Content-Type 头的值设置为 contentType 中包含的值，此方法将首先对 base64 输入流进行解码，然后将得到的原始字节写入附件。
abstract void | AttachmentPart.setRawContent(InputStream content, String contentType) 将此附件部分的内容设置为 InputStream content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。

javax.xml.stream 中 InputStream 的使用

参数类型为 InputStream 的 javax.xml.stream 中的方法
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(InputStream stream) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(InputStream stream, String encoding) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(String systemId, InputStream stream) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(InputStream stream) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream) 根据 java.io.InputStream 创建一个新 XMLStreamReader。

javax.xml.transform.stream 中 InputStream 的使用

返回 InputStream 的 javax.xml.transform.stream 中的方法
 InputStream StreamSource.getInputStream()
获取通过 setByteStream 设置的字节流。

参数类型为 InputStream 的 javax.xml.transform.stream 中的方法
 void StreamSource.setInputStream(InputStream inputStream)
设置要用作输入的字节流。

参数类型为 InputStream 的 javax.xml.transform.stream 中的构造方法
StreamSource(InputStream inputStream)
从字节流构造 StreamSource。
StreamSource(InputStream inputStream, String systemId)
从字节流构造 StreamSource。

org.ietf.jgss 中 InputStream 的使用

参数类型为 InputStream 的 org.ietf.jgss 中的方法
void | GSSContext.acceptSecContext(InputStream inStream, OutputStream outStream) 由上下文接受端调用，以处理来自使用流的同位体的标记。
void | GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
int | GSSContext.initSecContext(InputStream inStream, OutputStream outStream) 由上下文初始端调用，以启动上下文的创建阶段，处理由使用流的同位体的 acceptSecContext 方法生成的任何标记。
void | GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp) 通过提供的消息，使用流来验证包含在标记参数中的加密的 MIC。
void | GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 将 per-message 安全服务应用于已创建的使用流的安全上下文。

参数类型为 InputStream 的 org.ietf.jgss 中的构造方法
Oid(InputStream derOid)
从其 ASN.1 DER 编码中创建 Oid 对象。

org.omg.CORBA.portable 中 InputStream 的使用

org.omg.CORBA.portable 中 InputStream 的子类
 class InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。

org.w3c.dom.ls 中 InputStream 的使用

返回 InputStream 的 org.w3c.dom.ls 中的方法
 InputStream LSInput.getByteStream()
依赖于语言和绑定类型的属性，表示字节的流。

参数类型为 InputStream 的 org.w3c.dom.ls 中的方法
 void LSInput.setByteStream(InputStream byteStream)
依赖于语言和绑定类型的属性，表示字节流。

org.xml.sax 中 InputStream 的使用

返回 InputStream 的 org.xml.sax 中的方法
 InputStream InputSource.getByteStream()
获取此输入源的字节流。

参数类型为 InputStream 的 org.xml.sax 中的方法
 void InputSource.setByteStream(InputStream byteStream)
设置此输入源的字节流。

参数类型为 InputStream 的 org.xml.sax 中的构造方法
InputSource(InputStream byteStream)
使用字节流创建新的输入源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.InputStreamReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.InputStreamReader
的使用

使用 InputStreamReader 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 InputStreamReader 的使用

java.io 中 InputStreamReader 的子类
 class FileReader
用来读取字符文件的便捷类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.InterruptedIOException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.InterruptedIOException
的使用

使用 InterruptedIOException 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 InterruptedIOException 的使用

java.net 中 InterruptedIOException 的子类
 class SocketTimeoutException
如果在读取或接受套接字时发生超时，则抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.InvalidClassException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.InvalidClassException
的使用

没有 java.io.InvalidClassException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.InvalidObjectException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.InvalidObjectException
的使用

使用 InvalidObjectException 的软件包
java.awt.font | 提供与字体相关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.awt.font 中 InvalidObjectException 的使用

抛出 InvalidObjectException 的 java.awt.font 中的方法
protected  Object TextAttribute.readResolve()
将反序列化的实例解析为预定义常量。

java.io 中 InvalidObjectException 的使用

抛出 InvalidObjectException 的 java.io 中的方法
void | ObjectInputStream.registerValidation(ObjectInputValidation obj, int prio) 在返回图形前注册要验证的对象。
void | ObjectInputValidation.validateObject() 验证对象。

java.text 中 InvalidObjectException 的使用

抛出 InvalidObjectException 的 java.text 中的方法
protected Object | AttributedCharacterIterator.Attribute.readResolve() 解析将被反序列化为预定义常量的实例。
protected Object | NumberFormat.Field.readResolve() 将正被反序列化的实例解析为预定义的常量。
protected Object | DateFormat.Field.readResolve() 将反序列化的实例解析成预定义的常量。
protected Object | MessageFormat.Field.readResolve() 把正被反序列化的实例解析为预定义的常量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.IOError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.IOError
的使用

没有 java.io.IOError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.IOException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.IOException
的使用

使用 IOException 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 中 IOException 的使用

抛出 IOException 的 java.applet 中的方法
 void AppletContext.setStream(String key, InputStream stream)
在此 applet 上下文中用指定的键关联指定的流。

java.awt 中 IOException 的使用

抛出 IOException 的 java.awt 中的方法
void | Desktop.browse(URI uri) 启动默认浏览器来显示 URI。
static Font | Font.createFont(int fontFormat, File fontFile) 返回一个使用指定字体类型和指定字体文件的新 Font。
static Font | Font.createFont(int fontFormat, InputStream fontStream) 返回一个使用指定字体类型和输入数据的新 Font。
void | Desktop.edit(File file) 启动关联编辑器应用程序并打开用于编辑的文件。
void | Desktop.mail() 启动用户默认邮件客户端的邮件组合窗口。
void | Desktop.mail(URI mailtoURI) 启动用户默认邮件客户端的邮件组合窗口，填充由 mailto: URI 指定的消息字段。
void | Desktop.open(File file) 启动关联应用程序来打开文件。
void | Desktop.print(File file) 使用关联应用程序的打印命令，用本机桌面打印设施来打印文件。
protected static void | AWTEventMulticaster.save(ObjectOutputStream s, String k, EventListener l)
protected void | AWTEventMulticaster.saveInternal(ObjectOutputStream s, String k)
void | SplashScreen.setImageURL(URL imageURL) 更改闪现屏幕图像。

java.awt.color 中 IOException 的使用

抛出 IOException 的 java.awt.color 中的方法
static ICC_Profile | ICC_Profile.getInstance(InputStream s) 构造一个与 InputStream 中的数据相对应的 ICC_Profile。
static ICC_Profile | ICC_Profile.getInstance(String fileName) 构造一个与文件中的数据相对应的 ICC_Profile。
void | ICC_Profile.write(OutputStream s) 将 ICC_Profile 写入一个 OutputStream。
void | ICC_Profile.write(String fileName) 将此 ICC_Profile 写入一个文件。

java.awt.datatransfer 中 IOException 的使用

抛出 IOException 的 java.awt.datatransfer 中的方法
Object | Clipboard.getData(DataFlavor flavor) 返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。
Reader | DataFlavor.getReaderForText(Transferable transferable) 获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。
Object | StringSelection.getTransferData(DataFlavor flavor) 如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。
Object | Transferable.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示将要被传输的数据。
void | DataFlavor.readExternal(ObjectInput is) 根据 Serialized 状态还原此 DataFlavor。
void | DataFlavor.writeExternal(ObjectOutput os) 序列化此 DataFlavor。

java.awt.dnd 中 IOException 的使用

抛出 IOException 的 java.awt.dnd 中的方法
 Object DropTargetContext.TransferableProxy.getTransferData(DataFlavor df)
返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。

java.awt.print 中 IOException 的使用

返回 IOException 的 java.awt.print 中的方法
 IOException PrinterIOException.getIOException()
返回终止打印作业的 IOException。

参数类型为 IOException 的 java.awt.print 中的构造方法
PrinterIOException(IOException exception)
构造具有指定 IOException 字符串表示形式的新 PrinterIOException。

java.beans 中 IOException 的使用

抛出 IOException 的 java.beans 中的方法
static Object | Beans.instantiate(ClassLoader cls, String beanName) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer) 实例化 bean。

java.beans.beancontext 中 IOException 的使用

抛出 IOException 的 java.beans.beancontext 中的方法
protected  void BeanContextServicesSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在反序列化子级之前，从 BeanContextSupport readObject 中调用。
protected  void BeanContextSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在调用 defaultReadObject() 之后，但在反序列化任意子级之前，由 readObject 调用。
protected  void BeanContextServicesSupport.bcsPreSerializationHook(ObjectOutputStream oos)
在序列化子级之前，从 BeanContextSupport writeObject 中调用。
protected  void BeanContextSupport.bcsPreSerializationHook(ObjectOutputStream oos)
在调用 defaultWriteObject() 之后，但在序列化当前可序列化子级之前，由 writeObject 调用。
protected  void BeanContextSupport.deserialize(ObjectInputStream ois, Collection coll)
readObject 使用此方法来反序列化一个 collection。
 Object BeanContext.instantiateChild(String beanName)
实例化指定为此 BeanContext 的一个子级的 javaBean。
 Object BeanContextSupport.instantiateChild(String beanName)
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。
 void BeanContextSupport.readChildren(ObjectInputStream ois)
在将此类的实例用作 BeanContext 协议（及其子协议）实现的代理时，在反序列化期间存在一个“先有鸡还是先有蛋”的问题。
protected  void BeanContextSupport.serialize(ObjectOutputStream oos, Collection coll)
writeObject 使用此方法来序列化一个 Collection。
 void BeanContextSupport.writeChildren(ObjectOutputStream oos)
用于序列化此 BeanContext 的所有子级。

java.io 中 IOException 的使用

java.io 中 IOException 的子类
class | CharConversionException 用于字符转换异常的基类。
class | EOFException 当输入过程中意外到达文件或流的末尾时，抛出此异常。
class | FileNotFoundException 当试图打开指定路径名表示的文件失败时，抛出此异常。
class | InterruptedIOException I/O 操作已中断信号，抛出此异常。
class | InvalidClassException 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
class | InvalidObjectException 指示一个或多个反序列化对象未通过验证测试。
class | NotActiveException 当序列化和反序列化不活动时，抛出此异常。
class | NotSerializableException 当实例需要具有序列化接口时，抛出此异常。
class | ObjectStreamException 特定于 Object Stream 类的所有异常的超类。
class | OptionalDataException 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
class | StreamCorruptedException 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
class | SyncFailedException 当 sync 操作失败时，抛出此异常。
class | UnsupportedEncodingException 不支持字符编码。
class | UTFDataFormatException 在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
class | WriteAbortedException 在写入操作过程中抛出 ObjectStreamException 之一的信号。

抛出 IOException 的 java.io 中的方法
protected  void ObjectOutputStream.annotateClass(Class<?> cl)
子类可以实现此方法，从而允许在流中存储类数据。
protected  void ObjectOutputStream.annotateProxyClass(Class<?> cl)
子类可以实现此方法，从而在流中存储定制数据和动态代理类的描述符。
 Writer Writer.append(char c)
将指定字符添加到此 writer。
 Writer Writer.append(CharSequence csq)
将指定字符序列添加到此 writer。
 Writer Writer.append(CharSequence csq, int start, int end)
将指定字符序列的子序列添加到此 writer.Appendable。
 int LineNumberInputStream.available()
已过时。 无阻塞情况下返回可以从此输入流中读取的字节数。
 int PipedInputStream.available()
返回可以不受阻塞地从此输入流中读取的字节数。
 int SequenceInputStream.available()
返回不受阻塞地从当前底层输入流读取（或跳过）的字节数的估计值，方法是通过下一次调用当前底层输入流的方法。
 int PushbackInputStream.available()
返回可以不受下一次调用此输入流的方法阻塞地从此输入流读取（或跳过）的估计字节数。
 int ObjectInputStream.available()
返回可以不受阻塞地读取的字节数。
 int ObjectInput.available()
返回可以无阻塞地读取的字节数。
 int BufferedInputStream.available()
返回可以从此输入流读取（或跳过）、且不受此输入流接下来的方法调用阻塞的估计字节数。
 int FilterInputStream.available()
返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。
 int FileInputStream.available()
返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。
 int InputStream.available()
返回此输入流下一个方法调用可以不受阻塞地从此输入流读取（或跳过）的估计字节数。
 void FilterWriter.close()
 void PipedInputStream.close()
关闭此管道输入流并释放与该流相关的所有系统资源。
 void PipedOutputStream.close()
关闭此管道输出流并释放与此流有关的所有系统资源。
 void PipedReader.close()
关闭此传送流并释放与该流相关的所有系统资源。
 void PipedWriter.close()
关闭此管道输出流并释放与此流相关的所有系统资源。
 void PushbackReader.close()
关闭该流并释放与之关联的所有系统资源。
 void SequenceInputStream.close()
关闭此输入流并释放与此流关联的所有系统资源。
 void PushbackInputStream.close()
关闭此输入流并释放与该流关联的所有系统资源。
 void StringWriter.close()
关闭 StringWriter 无效。
 void FilterReader.close()
 void RandomAccessFile.close()
关闭此随机访问文件流并释放与该流关联的所有系统资源。
 void ByteArrayOutputStream.close()
关闭 ByteArrayOutputStream 无效。
 void ByteArrayInputStream.close()
关闭 ByteArrayInputStream 无效。
 void ObjectInputStream.close()
关闭输入流。
 void ObjectInput.close()
关闭输入流。
 void ObjectOutputStream.close()
关闭流。
 void ObjectOutput.close()
关闭该流。
 void InputStreamReader.close()
 void BufferedReader.close()
abstract  void Reader.close()
关闭该流并释放与之关联的所有资源。
 void BufferedWriter.close()
 void OutputStreamWriter.close()
abstract  void Writer.close()
关闭此流，但要先刷新它。
 void FilterOutputStream.close()
关闭此输出流并释放与此流有关的所有系统资源。
 void BufferedInputStream.close()
关闭此输入流并释放与该流关联的所有系统资源。
 void FilterInputStream.close()
关闭此输入流并释放与此流关联的所有系统资源。
 void FileOutputStream.close()
关闭此文件输出流并释放与此流有关的所有系统资源。
 void OutputStream.close()
关闭此输出流并释放与此流有关的所有系统资源。
 void FileInputStream.close()
关闭此文件输入流并释放与此流有关的所有系统资源。
 void InputStream.close()
关闭此输入流并释放与该流关联的所有系统资源。
 void Closeable.close()
关闭此流并释放与此流关联的所有系统资源。
 void PipedOutputStream.connect(PipedInputStream snk)
将此管道输出流连接到接收者。
 void PipedInputStream.connect(PipedOutputStream src)
使此管道输入流连接到管道输出流 src。
 void PipedWriter.connect(PipedReader snk)
将此传送 writer 连接到接收方。
 void PipedReader.connect(PipedWriter src)
使此传送 reader 连接到传送 writer src。
 boolean File.createNewFile()
当且仅当不存在具有此抽象路径名指定名称的文件时，不可分地创建一个新的空文件。
static File File.createTempFile(String prefix, String suffix)
在默认临时文件目录中创建一个空文件，使用给定前缀和后缀生成其名称。
static File File.createTempFile(String prefix, String suffix, File directory)
在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
abstract  boolean ObjectInputStream.GetField.defaulted(String name)
如果指定的字段是默认字段并且在此流中不存在任何值，则返回 true。
 void ObjectInputStream.defaultReadObject()
从此流读取当前类的非静态和非瞬态字段。
 void ObjectOutputStream.defaultWriteObject()
将当前类的非静态和非瞬态字段写入此流。
protected  void ObjectOutputStream.drain()
排空 ObjectOutputStream 中的所有已缓冲数据。
protected  void FileOutputStream.finalize()
清理到文件的连接，并确保在不再引用此文件输出流时调用此流的 close 方法。
protected  void FileInputStream.finalize()
确保在不再引用文件输入流时调用其 close 方法。
 void FilterWriter.flush()
刷新该流的缓冲。
 void PipedOutputStream.flush()
刷新此输出流并强制写出所有缓冲的输出字节。
 void PipedWriter.flush()
刷新此输出流并强制写出所有缓冲的输出字符。
 void DataOutputStream.flush()
清空此数据输出流。
 void ObjectOutputStream.flush()
刷新该流的缓冲。
 void ObjectOutput.flush()
刷新该流的缓冲。
 void BufferedWriter.flush()
刷新该流的缓冲。
 void OutputStreamWriter.flush()
刷新该流的缓冲。
abstract  void Writer.flush()
刷新该流的缓冲。
 void BufferedOutputStream.flush()
刷新此缓冲的输出流。
 void FilterOutputStream.flush()
刷新此输出流，并强制将所有已缓冲的输出字节写入该流中。
 void OutputStream.flush()
刷新此输出流并强制写出所有缓冲的输出字节。
 void Flushable.flush()
通过将所有已缓冲输出写入底层流来刷新此流。
abstract  boolean ObjectInputStream.GetField.get(String name, boolean val)
从持久字段获取指定的 boolean 字段值。
abstract  byte ObjectInputStream.GetField.get(String name, byte val)
从持久字段获取指定字节字段的值。
abstract  char ObjectInputStream.GetField.get(String name, char val)
从持久字段获取指定 char 字段的值。
abstract  double ObjectInputStream.GetField.get(String name, double val)
从持久字段获取指定 double 字段的值。
abstract  float ObjectInputStream.GetField.get(String name, float val)
从持久字段获取指定 float 字段的值。
abstract  int ObjectInputStream.GetField.get(String name, int val)
从持久字段获取指定的 int 字段值。
abstract  long ObjectInputStream.GetField.get(String name, long val)
从持久字段获取指定 long 字段的值。
abstract  Object ObjectInputStream.GetField.get(String name, Object val)
从持久字段获取指定 Object 字段的值。
abstract  short ObjectInputStream.GetField.get(String name, short val)
从持久字段获取指定的 short 字段值。
 File File.getCanonicalFile()
返回此抽象路径名的规范形式。
 String File.getCanonicalPath()
返回此抽象路径名的规范路径名字符串。
 FileDescriptor RandomAccessFile.getFD()
返回与此流关联的不透明文件描述符对象。
 FileDescriptor FileOutputStream.getFD()
返回与此流有关的文件描述符。
 FileDescriptor FileInputStream.getFD()
返回表示到文件系统中实际文件的连接的 FileDescriptor 对象，该文件系统正被此 FileInputStream 使用。
 long RandomAccessFile.getFilePointer()
返回此文件中的当前偏移量。
 long RandomAccessFile.length()
返回此文件的长度。
 void CharArrayReader.mark(int readAheadLimit)
标记流中的当前位置。
 void LineNumberReader.mark(int readAheadLimit)
标记该流中的当前位置。
 void PushbackReader.mark(int readAheadLimit)
标记流中的当前位置。
 void FilterReader.mark(int readAheadLimit)
在流中的当前位置上作标记。
 void StringReader.mark(int readAheadLimit)
标记流中的当前位置。
 void BufferedReader.mark(int readAheadLimit)
标记流中的当前位置。
 void Reader.mark(int readAheadLimit)
标记流中的当前位置。
 void BufferedWriter.newLine()
写入一个行分隔符。
 int StreamTokenizer.nextToken()
从此标记生成器的输入流中解析下一个标记。
 ObjectOutputStream.PutField ObjectOutputStream.putFields()
获取用于缓冲写入流中的持久存储字段的对象。
 int CharArrayReader.read()
读取单个字符。
 int LineNumberInputStream.read()
已过时。 从此输入流读取下一个数据字节。
 int LineNumberReader.read()
读取单个字符。
 int PipedInputStream.read()
读取此管道输入流中的下一个数据字节。
 int PipedReader.read()
读取此传送流中的下一个数据字符。
 int PushbackReader.read()
读取单个字符。
 int SequenceInputStream.read()
从此输入流中读取下一个数据字节。
 int PushbackInputStream.read()
从此输入流中读取下一个数据字节。
 int FilterReader.read()
读取单个字符。
 int StringReader.read()
读取单个字符。
 int RandomAccessFile.read()
从此文件中读取一个数据字节。
 int ObjectInputStream.read()
读取数据字节。
 int ObjectInput.read()
读取数据字节。
 int InputStreamReader.read()
读取单个字符。
 int BufferedReader.read()
读取单个字符。
 int Reader.read()
读取单个字符。
 int BufferedInputStream.read()
参见 InputStream 的 read 方法的常规协定。
 int FilterInputStream.read()
从此输入流中读取下一个数据字节。
 int FileInputStream.read()
从此输入流中读取一个数据字节。
abstract  int InputStream.read()
从输入流中读取数据的下一个字节。
 int RandomAccessFile.read(byte[] b)
将最多 b.length 个数据字节从此文件读入 byte 数组。
 int ObjectInput.read(byte[] b)
读入 byte 数组。
 int DataInputStream.read(byte[] b)
从包含的输入流中读取一定数量的字节，并将它们存储到缓冲区数组 b 中。
 int FilterInputStream.read(byte[] b)
从此输入流中将 byte.length 个字节的数据读入一个 byte 数组中。
 int FileInputStream.read(byte[] b)
从此输入流中将最多 b.length 个字节的数据读入一个 byte 数组中。
 int InputStream.read(byte[] b)
从输入流中读取一定数量的字节，并将其存储在缓冲区数组 b 中。
 int LineNumberInputStream.read(byte[] b, int off, int len)
已过时。 将最多 len 个数据字节从此输入流读入 byte 数组。
 int PipedInputStream.read(byte[] b, int off, int len)
将最多 len 个数据字节从此管道输入流读入 byte 数组。
 int SequenceInputStream.read(byte[] b, int off, int len)
将最多 len 个数据字节从此输入流读入 byte 数组。
 int PushbackInputStream.read(byte[] b, int off, int len)
从此输入流将最多 len 个数据字节读入 byte 数组。
 int RandomAccessFile.read(byte[] b, int off, int len)
将最多 len 个数据字节从此文件读入 byte 数组。
 int ObjectInputStream.read(byte[] buf, int off, int len)
读入 byte 数组。
 int ObjectInput.read(byte[] b, int off, int len)
读入 byte 数组。
 int DataInputStream.read(byte[] b, int off, int len)
从包含的输入流中将最多 len 个字节读入一个 byte 数组中。
 int BufferedInputStream.read(byte[] b, int off, int len)
从此字节输入流中给定偏移量处开始将各字节读取到指定的 byte 数组中。
 int FilterInputStream.read(byte[] b, int off, int len)
从此输入流中将 len 个字节的数据读入一个 byte 数组中。
 int FileInputStream.read(byte[] b, int off, int len)
从此输入流中将最多 len 个字节的数据读入一个 byte 数组中。
 int InputStream.read(byte[] b, int off, int len)
将输入流中最多 len 个数据字节读入 byte 数组。
 int Reader.read(char[] cbuf)
将字符读入数组。
 int CharArrayReader.read(char[] b, int off, int len)
将字符读入数组的某一部分。
 int LineNumberReader.read(char[] cbuf, int off, int len)
将字符读入数组中的某一部分。
 int PipedReader.read(char[] cbuf, int off, int len)
将此传送流中最多 len 个数据字符读入字符数组。
 int PushbackReader.read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 int FilterReader.read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 int StringReader.read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 int InputStreamReader.read(char[] cbuf, int offset, int length)
将字符读入数组中的某一部分。
 int BufferedReader.read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
abstract  int Reader.read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 int Reader.read(CharBuffer target)
试图将字符读入指定的字符缓冲区。
 boolean RandomAccessFile.readBoolean()
从此文件读取一个 boolean。
 boolean ObjectInputStream.readBoolean()
读取一个 boolean 值。
 boolean DataInputStream.readBoolean()
参见 DataInput 的 readBoolean 方法的常规协定。
 boolean DataInput.readBoolean()
读取一个输入字节，如果该字节不是零，则返回 true，如果是零，则返回 false。
 byte RandomAccessFile.readByte()
从此文件读取一个有符号的八位值。
 byte ObjectInputStream.readByte()
读取一个 8 位的字节。
 byte DataInputStream.readByte()
参见 DataInput 的 readByte 方法的常规协定。
 byte DataInput.readByte()
读取并返回一个输入字节。
 char RandomAccessFile.readChar()
从此文件读取一个字符。
 char ObjectInputStream.readChar()
读取一个 16 位的 char 值。
 char DataInputStream.readChar()
参见 DataInput 的 readChar 方法的常规协定。
 char DataInput.readChar()
读取两个输入字节并返回一个 char 值。
protected  ObjectStreamClass ObjectInputStream.readClassDescriptor()
从序列化流读取类描述符。
 double RandomAccessFile.readDouble()
从此文件读取一个 double。
 double ObjectInputStream.readDouble()
读取一个 64 位的 double 值。
 double DataInputStream.readDouble()
参见 DataInput 的 readDouble 方法的常规协定。
 double DataInput.readDouble()
读取八个输入字节并返回一个 double 值。
 void Externalizable.readExternal(ObjectInput in)
对象实现 readExternal 方法来恢复其内容，它通过调用 DataInput 的方法来恢复其基础类型，调用 readObject 来恢复对象、字符串和数组。
 ObjectInputStream.GetField ObjectInputStream.readFields()
按名称从流中读取持久字段并使其可用。
 float RandomAccessFile.readFloat()
从此文件读取一个 float。
 float ObjectInputStream.readFloat()
读取一个 32 位的 float 值。
 float DataInputStream.readFloat()
参见 DataInput 的 readFloat 方法的常规协定。
 float DataInput.readFloat()
读取四个输入字节并返回一个 float 值。
 void RandomAccessFile.readFully(byte[] b)
将 b.length 个字节从此文件读入 byte 数组，并从当前文件指针开始。
 void ObjectInputStream.readFully(byte[] buf)
读取字节，同时阻塞直至读取所有字节。
 void DataInputStream.readFully(byte[] b)
参见 DataInput 的 readFully 方法的常规协定。
 void DataInput.readFully(byte[] b)
从输入流中读取一些字节，并将它们存储在缓冲区数组 b 中。
 void RandomAccessFile.readFully(byte[] b, int off, int len)
将正好 len 个字节从此文件读入 byte 数组，并从当前文件指针开始。
 void ObjectInputStream.readFully(byte[] buf, int off, int len)
读取字节，同时阻塞直至读取所有字节。
 void DataInputStream.readFully(byte[] b, int off, int len)
参见 DataInput 的 readFully 方法的常规协定。
 void DataInput.readFully(byte[] b, int off, int len)
从输入流中读取 len 个字节。
 int RandomAccessFile.readInt()
从此文件读取一个有符号的 32 位整数。
 int ObjectInputStream.readInt()
读取一个 32 位的 int 值。
 int DataInputStream.readInt()
参见 DataInput 的 readInt 方法的常规协定。
 int DataInput.readInt()
读取四个输入字节并返回一个 int 值。
 String LineNumberReader.readLine()
读取文本行。
 String RandomAccessFile.readLine()
从此文件读取文本的下一行。
 String ObjectInputStream.readLine()
已过时。 此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。
 String DataInputStream.readLine()
已过时。 该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
 String DataInput.readLine()
从输入流中读取下一文本行。
 String BufferedReader.readLine()
读取一个文本行。
 long RandomAccessFile.readLong()
从此文件读取一个有符号的 64 位整数。
 long ObjectInputStream.readLong()
读取一个 64 位的 long 值。
 long DataInputStream.readLong()
参见 DataInput 的 readLong 方法的常规协定。
 long DataInput.readLong()
读取八个输入字节并返回一个 long 值。
 Object ObjectInputStream.readObject()
从 ObjectInputStream 读取对象。
 Object ObjectInput.readObject()
读取并返回对象。
protected  Object ObjectInputStream.readObjectOverride()
此方法由 ObjectOutputStream 的受信任子类调用，这些子类使用受保护的无参数构造方法构造 ObjectOutputStream。
 short RandomAccessFile.readShort()
从此文件读取一个有符号的 16 位数。
 short ObjectInputStream.readShort()
读取一个 16 位的 short 值。
 short DataInputStream.readShort()
参见 DataInput 的 readShort 方法的常规协定。
 short DataInput.readShort()
读取两个输入字节并返回一个 short 值。
protected  void ObjectInputStream.readStreamHeader()
提供的 readStreamHeader 方法允许子类读取并验证它们自己的流头部。
 Object ObjectInputStream.readUnshared()
从 ObjectInputStream 读取“非共享”对象。
 int RandomAccessFile.readUnsignedByte()
从此文件读取一个无符号的八位数。
 int ObjectInputStream.readUnsignedByte()
读取一个无符号的 8 位字节。
 int DataInputStream.readUnsignedByte()
参见 DataInput 的 readUnsignedByte 方法的常规协定。
 int DataInput.readUnsignedByte()
读取一个输入字节，将它左侧补零 (zero-extend) 转变为 int 类型，并返回结果，所以结果的范围是 0 到 255。
 int RandomAccessFile.readUnsignedShort()
从此文件读取一个无符号的 16 位数。
 int ObjectInputStream.readUnsignedShort()
读取一个无符号的 16 位 short 值。
 int DataInputStream.readUnsignedShort()
参见 DataInput 的 readUnsignedShort 方法的常规协定。
 int DataInput.readUnsignedShort()
读取两个输入字节，并返回 0 到 65535 范围内的一个 int 值。
 String RandomAccessFile.readUTF()
从此文件读取一个字符串。
 String ObjectInputStream.readUTF()
读取 UTF-8 修改版格式的 String。
 String DataInputStream.readUTF()
参见 DataInput 的 readUTF 方法的常规协定。
 String DataInput.readUTF()
读入一个已使用 UTF-8 修改版格式编码的字符串。
static String DataInputStream.readUTF(DataInput in)
从流 in 中读取用 UTF-8 修改版格式编码的 Unicode 字符格式的字符串；然后以 String 形式返回此字符串。
 boolean CharArrayReader.ready()
判断此流是否已准备好被读取。
 boolean PipedReader.ready()
告知是否准备读取此流。
 boolean PushbackReader.ready()
判断是否准备读取此流。
 boolean FilterReader.ready()
判断此流是否已经准备好用于读取。
 boolean StringReader.ready()
判断此流是否已经准备好用于读取。
 boolean InputStreamReader.ready()
判断此流是否已经准备好用于读取。
 boolean BufferedReader.ready()
判断此流是否已准备好被读取。
 boolean Reader.ready()
判断是否准备读取此流。
protected  void PipedInputStream.receive(int b)
接收数据字节。
protected  Object ObjectOutputStream.replaceObject(Object obj)
在序列化期间，此方法允许 ObjectOutputStream 的受信任子类使用一个对象替代另一个对象。
 void CharArrayReader.reset()
将该流重置为最新的标记，如果从未标记过，则将其重置到开头。
 void LineNumberInputStream.reset()
已过时。 将此流重新定位到对此输入流最后调用 mark 方法时的位置。
 void LineNumberReader.reset()
将该流重新设置为最新的标记。
 void PushbackReader.reset()
重置该流。
 void PushbackInputStream.reset()
将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。
 void FilterReader.reset()
重置该流。
 void StringReader.reset()
将该流重置为最新的标记，如果从未标记过，则将其重置到该字符串的开头。
 void ObjectOutputStream.reset()
重置将丢弃已写入流中的所有对象的状态。
 void BufferedReader.reset()
将流重置到最新的标记。
 void Reader.reset()
重置该流。
 void BufferedInputStream.reset()
参见 InputStream 的 reset 方法的常规协定。
 void FilterInputStream.reset()
将此流重新定位到对此输入流最后调用 mark 方法时的位置。
 void InputStream.reset()
将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。
protected  Class<?> ObjectInputStream.resolveClass(ObjectStreamClass desc)
加载指定流类描述的本地等价类。
protected  Object ObjectInputStream.resolveObject(Object obj)
在反序列化期间，此方法允许 ObjectInputStream 的受信任子类使用一个对象替代另一个。
protected  Class<?> ObjectInputStream.resolveProxyClass(String[] interfaces)
返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。
 void RandomAccessFile.seek(long pos)
设置到此文件开头测量到的文件指针偏移量，在该位置发生下一个读取或写入操作。
 void RandomAccessFile.setLength(long newLength)
设置此文件的长度。
 long CharArrayReader.skip(long n)
跳过字符。
 long LineNumberInputStream.skip(long n)
已过时。 跳过和放弃此输入流中的 n 个数据字节。
 long LineNumberReader.skip(long n)
跳过字符。
 long PushbackReader.skip(long n)
跳过字符。
 long PushbackInputStream.skip(long n)
从此输入流中跳过并丢弃 n 个数据字节。
 long FilterReader.skip(long n)
跳过某些字符。
 long StringReader.skip(long ns)
跳过流中指定数量的字符。
 long ObjectInput.skip(long n)
跳过输入的 n 个字节。
 long BufferedReader.skip(long n)
跳过字符。
 long Reader.skip(long n)
跳过字符。
 long BufferedInputStream.skip(long n)
参见 InputStream 的 skip 方法的常规协定。
 long FilterInputStream.skip(long n)
跳过和丢弃此输入流中数据的 n 个字节。
 long FileInputStream.skip(long n)
从输入流中跳过并丢弃 n 个字节的数据。
 long InputStream.skip(long n)
跳过和丢弃此输入流中数据的 n 个字节。
 int RandomAccessFile.skipBytes(int n)
尝试跳过输入的 n 个字节以丢弃跳过的字节。
 int ObjectInputStream.skipBytes(int len)
跳过字节。
 int DataInputStream.skipBytes(int n)
参见 DataInput 的 skipBytes 方法的常规协定。
 int DataInput.skipBytes(int n)
试图在输入流中跳过数据的 n 个字节，并丢弃跳过的字节。
 void PushbackInputStream.unread(byte[] b)
推回一个 byte 数组：将其复制到推回缓冲区之前。
 void PushbackInputStream.unread(byte[] b, int off, int len)
推回 byte 数组的某一部分：将其复制到推回缓冲区之前。
 void PushbackReader.unread(char[] cbuf)
推回一个字符数组，方法是将其复制到推回缓冲区前面。
 void PushbackReader.unread(char[] cbuf, int off, int len)
推回字符数组的某一部分，方法是将其复制到推回缓冲区的前面。
 void PushbackReader.unread(int c)
推回单个字符：将其复制到推回缓冲区的前面。
 void PushbackInputStream.unread(int b)
推回一个字节：将其复制到推回缓冲区之前。
 void ObjectOutputStream.useProtocolVersion(int version)
指定要在写入流时使用的流协议版本。
 void RandomAccessFile.write(byte[] b)
将 b.length 个字节从指定 byte 数组写入到此文件，并从当前文件指针开始。
 void ObjectOutputStream.write(byte[] buf)
写入一个 byte 数组。
 void ObjectOutput.write(byte[] b)
写入 byte 数组。
 void DataOutput.write(byte[] b)
将数组 b 中的所有字节写入输出流。
 void FilterOutputStream.write(byte[] b)
将 b.length 个字节写入此输出流。
 void FileOutputStream.write(byte[] b)
将 b.length 个字节从指定 byte 数组写入此文件输出流中。
 void OutputStream.write(byte[] b)
将 b.length 个字节从指定的 byte 数组写入此输出流。
 void PipedOutputStream.write(byte[] b, int off, int len)
将 len 字节从初始偏移量为 off 的指定 byte 数组写入该管道输出流。
 void DataOutputStream.write(byte[] b, int off, int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入基础输出流。
 void RandomAccessFile.write(byte[] b, int off, int len)
将 len 个字节从指定 byte 数组写入到此文件，并从偏移量 off 处开始。
 void ObjectOutputStream.write(byte[] buf, int off, int len)
写入字节的子数组。
 void ObjectOutput.write(byte[] b, int off, int len)
写入字节的子数组。
 void DataOutput.write(byte[] b, int off, int len)
将数组 b 中的 len 个字节按顺序写入输出流。
 void BufferedOutputStream.write(byte[] b, int off, int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此缓冲的输出流。
 void FilterOutputStream.write(byte[] b, int off, int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。
 void FileOutputStream.write(byte[] b, int off, int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此文件输出流。
 void OutputStream.write(byte[] b, int off, int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。
 void Writer.write(char[] cbuf)
写入字符数组。
 void FilterWriter.write(char[] cbuf, int off, int len)
将字符写入数组的某一部分。
 void PipedWriter.write(char[] cbuf, int off, int len)
将 len 字符从指定初始偏移量为 off 的字符数组写入到此管道输出流。
 void BufferedWriter.write(char[] cbuf, int off, int len)
写入字符数组的某一部分。
 void OutputStreamWriter.write(char[] cbuf, int off, int len)
写入字符数组的某一部分。
abstract  void Writer.write(char[] cbuf, int off, int len)
写入字符数组的某一部分。
 void FilterWriter.write(int c)
写入单个字符。
 void PipedOutputStream.write(int b)
将指定 byte 写入传送的输出流。
 void PipedWriter.write(int c)
将指定的 char 写入管道输出流。
 void DataOutputStream.write(int b)
将指定字节（参数 b 的八个低位）写入基础输出流。
 void RandomAccessFile.write(int b)
向此文件写入指定的字节。
 void ObjectOutputStream.write(int val)
写入一个字节。
 void ObjectOutput.write(int b)
写入字节。
 void DataOutput.write(int b)
将参数 b 的八个低位写入输出流。
 void BufferedWriter.write(int c)
写入单个字符。
 void OutputStreamWriter.write(int c)
写入单个字符。
 void Writer.write(int c)
写入单个字符。
 void BufferedOutputStream.write(int b)
将指定的字节写入此缓冲的输出流。
 void FilterOutputStream.write(int b)
将指定 byte 写入此输出流。
 void FileOutputStream.write(int b)
将指定字节写入此文件输出流。
abstract  void OutputStream.write(int b)
将指定的字节写入此输出流。
abstract  void ObjectOutputStream.PutField.write(ObjectOutput out)
已过时。 此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。
 void Writer.write(String str)
写入字符串。
 void FilterWriter.write(String str, int off, int len)
写入一部分字符串。
 void BufferedWriter.write(String s, int off, int len)
写入字符串的某一部分。
 void OutputStreamWriter.write(String str, int off, int len)
写入字符串的某一部分。
 void Writer.write(String str, int off, int len)
写入字符串的某一部分。
 void DataOutputStream.writeBoolean(boolean v)
将一个 boolean 值以 1-byte 值形式写入基础输出流。
 void RandomAccessFile.writeBoolean(boolean v)
按单字节值将 boolean 写入该文件。
 void ObjectOutputStream.writeBoolean(boolean val)
写入一个 boolean 值。
 void DataOutput.writeBoolean(boolean v)
将一个 boolean 值写入输出流。
 void DataOutputStream.writeByte(int v)
将一个 byte 值以 1-byte 值形式写出到基础输出流中。
 void RandomAccessFile.writeByte(int v)
按单字节值将 byte 写入该文件。
 void ObjectOutputStream.writeByte(int val)
写入一个 8 位字节。
 void DataOutput.writeByte(int v)
将参数 v 的八个低位写入输出流。
 void DataOutputStream.writeBytes(String s)
将字符串按字节顺序写出到基础输出流中。
 void RandomAccessFile.writeBytes(String s)
按字节序列将该字符串写入该文件。
 void ObjectOutputStream.writeBytes(String str)
以字节序列形式写入一个 String。
 void DataOutput.writeBytes(String s)
将一个字符串写入输出流。
 void DataOutputStream.writeChar(int v)
将一个 char 值以 2-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeChar(int v)
按双字节值将 char 写入该文件，先写高字节。
 void ObjectOutputStream.writeChar(int val)
写入一个 16 位的 char 值。
 void DataOutput.writeChar(int v)
将一个 char 值写入输出流，该值由两个字节组成。
 void DataOutputStream.writeChars(String s)
将字符串按字符顺序写入基础输出流。
 void RandomAccessFile.writeChars(String s)
按字符序列将一个字符串写入该文件。
 void ObjectOutputStream.writeChars(String str)
以 char 序列形式写入一个 String。
 void DataOutput.writeChars(String s)
将字符串 s 中的所有字符按顺序写入输出流，每个字符用两个字节表示。
protected  void ObjectOutputStream.writeClassDescriptor(ObjectStreamClass desc)
将指定的类描述符写入 ObjectOutputStream。
 void DataOutputStream.writeDouble(double v)
使用 Double 类中的 doubleToLongBits 方法将 double 参数转换为一个 long 值，然后将该 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeDouble(double v)
使用 Double 类中的 doubleToLongBits 方法将双精度参数转换为一个 long，然后按八字节数量将该 long 值写入该文件，先定高字节。
 void ObjectOutputStream.writeDouble(double val)
写入一个 64 位的 double 值。
 void DataOutput.writeDouble(double v)
将一个 double 值写入输出流，该值由八个字节组成。
 void Externalizable.writeExternal(ObjectOutput out)
该对象可实现 writeExternal 方法来保存其内容，它可以通过调用 DataOutput 的方法来保存其基本值，或调用 ObjectOutput 的 writeObject 方法来保存对象、字符串和数组。
 void ObjectOutputStream.writeFields()
将已缓冲的字段写入流中。
 void DataOutputStream.writeFloat(float v)
使用 Float 类中的 floatToIntBits 方法将 float 参数转换为一个 int 值，然后将该 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeFloat(float v)
使用 Float 类中的 floatToIntBits 方法将浮点参数转换为一个 int，然后按四字节数量将该 int 值写入该文件，先写高字节。
 void ObjectOutputStream.writeFloat(float val)
写入一个 32 位的 float 值。
 void DataOutput.writeFloat(float v)
将一个 float 值写入输出流，该值由四个字节组成。
 void DataOutputStream.writeInt(int v)
将一个 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeInt(int v)
按四个字节将 int 写入该文件，先写高字节。
 void ObjectOutputStream.writeInt(int val)
写入一个 32 位的 int 值。
 void DataOutput.writeInt(int v)
将一个 int 值写入输出流，该值由四个字节组成。
 void DataOutputStream.writeLong(long v)
将一个 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeLong(long v)
按八个字节将 long 写入该文件，先写高字节。
 void ObjectOutputStream.writeLong(long val)
写入一个 64 位的 long 值。
 void DataOutput.writeLong(long v)
将一个 long 值写入输出流，该值由八个字节组成。
 void ObjectOutputStream.writeObject(Object obj)
将指定的对象写入 ObjectOutputStream。
 void ObjectOutput.writeObject(Object obj)
将对象写入底层存储或流。
protected  void ObjectOutputStream.writeObjectOverride(Object obj)
子类用于重写默认 writeObject 方法的方法。
 void DataOutputStream.writeShort(int v)
将一个 short 值以 2-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeShort(int v)
按两个字节将 short 写入该文件，先写高字节。
 void ObjectOutputStream.writeShort(int val)
写入一个 16 位的 short 值。
 void DataOutput.writeShort(int v)
将两个字节写入输出流，用它们表示参数值。
protected  void ObjectOutputStream.writeStreamHeader()
提供 writeStreamHeader 方法，这样子类可以将其自身的头部添加或预加到流中。
 void ByteArrayOutputStream.writeTo(OutputStream out)
将此 byte 数组输出流的全部内容写入到指定的输出流参数中，这与使用 out.write(buf, 0, count) 调用该输出流的 write 方法效果一样。
 void CharArrayWriter.writeTo(Writer out)
将缓冲区的内容写入另一个字符流。
 void ObjectOutputStream.writeUnshared(Object obj)
将“未共享”对象写入 ObjectOutputStream。
 void DataOutputStream.writeUTF(String str)
以与机器无关方式使用 UTF-8 修改版编码将一个字符串写入基础输出流。
 void RandomAccessFile.writeUTF(String str)
使用 modified UTF-8 编码以与机器无关的方式将一个字符串写入该文件。
 void ObjectOutputStream.writeUTF(String str)
以 UTF-8 修改版格式写入此 String 的基本数据。
 void DataOutput.writeUTF(String s)
将表示长度信息的两个字节写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。

抛出 IOException 的 java.io 中的构造方法
FileWriter(File file)
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(File file, boolean append)
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(String fileName)
根据给定的文件名构造一个 FileWriter 对象。
FileWriter(String fileName, boolean append)
根据给定的文件名以及指示是否附加写入数据的 boolean 值来构造 FileWriter 对象。
ObjectInputStream()
为完全重新实现 ObjectInputStream 的子类提供一种方式，让它不必分配仅由 ObjectInputStream 的实现使用的私有数据。
ObjectInputStream(InputStream in)
创建从指定 InputStream 读取的 ObjectInputStream。
ObjectOutputStream()
为完全重新实现 ObjectOutputStream 的子类提供一种方法，让它不必分配仅由 ObjectOutputStream 的实现使用的私有数据。
ObjectOutputStream(OutputStream out)
创建写入指定 OutputStream 的 ObjectOutputStream。
PipedInputStream(PipedOutputStream src)
创建 PipedInputStream，使其连接到管道输出流 src。
PipedInputStream(PipedOutputStream src, int pipeSize)
创建一个 PipedInputStream，使其连接到管道输出流 src，并对管道缓冲区使用指定的管道大小。
PipedOutputStream(PipedInputStream snk)
创建连接到指定管道输入流的管道输出流。
PipedReader(PipedWriter src)
创建连接到传送 writer src 的 PipedReader。
PipedReader(PipedWriter src, int pipeSize)
创建一个 PipedReader，使其连接到管道 writer src，并对管道缓冲区使用指定的管道大小。
PipedWriter(PipedReader snk)
创建传送 writer，使其连接到指定的传送 reader。

java.lang 中 IOException 的使用

抛出 IOException 的 java.lang 中的方法
Appendable | Appendable.append(char c) 向此 Appendable 添加指定字符。
Appendable | Appendable.append(CharSequence csq) 向此 Appendable 添加指定的字符序列。
Appendable | Appendable.append(CharSequence csq, int start, int end) 向此 Appendable 添加指定字符序列的子序列。
Process | Runtime.exec(String command) 在单独的进程中执行指定的字符串命令。
Process | Runtime.exec(String[] cmdarray) 在单独的进程中执行指定命令和变量。
Process | Runtime.exec(String[] cmdarray, String[] envp) 在指定环境的独立进程中执行指定命令和变量。
Process | Runtime.exec(String[] cmdarray, String[] envp, File dir) 在指定环境和工作目录的独立进程中执行指定的命令和变量。
Process | Runtime.exec(String command, String[] envp) 在指定环境的单独进程中执行指定的字符串命令。
Process | Runtime.exec(String command, String[] envp, File dir) 在有指定环境和工作目录的独立进程中执行指定的字符串命令。
protected Enumeration<URL> | ClassLoader.findResources(String name) 返回表示所有具有给定名称的资源的 URL 对象的枚举。
Enumeration<URL> | ClassLoader.getResources(String name) 查找所有给定名称的资源。
static Enumeration<URL> | ClassLoader.getSystemResources(String name) 从用来加载类的搜索路径中查找所有具有指定名称的资源。
static Channel | System.inheritedChannel() 返回从创建此 Java 虚拟机的实体中继承的信道。
int | Readable.read(CharBuffer cb) 试图将字符读入指定的字符缓冲区。
Process | ProcessBuilder.start() 使用此进程生成器的属性启动一个新进程。

java.lang.management 中 IOException 的使用

抛出 IOException 的 java.lang.management 中的方法
static
<T> T
ManagementFactory.newPlatformMXBeanProxy(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。

java.net 中 IOException 的使用

java.net 中 IOException 的子类
class | BindException 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
class | HttpRetryException 抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
class | MalformedURLException 抛出这一异常指示出现了错误的 URL。
class | NoRouteToHostException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | PortUnreachableException 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
class | ProtocolException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketTimeoutException 如果在读取或接受套接字时发生超时，则抛出此异常。
class | UnknownHostException 指示主机 IP 地址无法确定而抛出的异常。
class | UnknownServiceException 抛出这一异常指示出现了未知服务异常。

参数类型为 IOException 的 java.net 中的方法
abstract  void ProxySelector.connectFailed(URI uri, SocketAddress sa, IOException ioe)
调用此方法来指示无法建立到代理/socks 服务器的连接。

抛出 IOException 的 java.net 中的方法
 Socket ServerSocket.accept()
侦听并接受到此套接字的连接。
protected abstract  void SocketImpl.accept(SocketImpl s)
接受连接。
protected abstract  int SocketImpl.available()
返回可以不受阻塞地从此套接字中读取的字节数。
protected abstract  void SocketImpl.bind(InetAddress host, int port)
将此套接字绑定到指定的本地 IP 地址和端口号。
 void ServerSocket.bind(SocketAddress endpoint)
将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
 void Socket.bind(SocketAddress bindpoint)
将套接字绑定到本地地址。
 void ServerSocket.bind(SocketAddress endpoint, int backlog)
将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
 void ServerSocket.close()
关闭此套接字。
protected abstract  void SocketImpl.close()
关闭此套接字。
 void Socket.close()
关闭此套接字。
abstract  void URLConnection.connect()
打开到此 URL 引用的资源的通信链接（如果尚未建立这样的连接）。
protected abstract  void SocketImpl.connect(InetAddress address, int port)
将此套接字连接到指定主机上的指定端口号。
 void Socket.connect(SocketAddress endpoint)
将此套接字连接到服务器。
protected abstract  void SocketImpl.connect(SocketAddress address, int timeout)
将此套接字连接到指定主机上的指定端口号。
 void Socket.connect(SocketAddress endpoint, int timeout)
将此套接字连接到服务器，并指定一个超时值。
protected abstract  void SocketImpl.connect(String host, int port)
将此套接字连接到指定主机上的指定端口。
protected abstract  void SocketImpl.create(boolean stream)
创建一个流或数据报套接字。
 Enumeration<URL> URLClassLoader.findResources(String name)
返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。
abstract  Map<String,List<String>> CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders)
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
 Map<String,List<String>> CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
abstract  CacheResponse ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
根据请求的 uri、请求方法和请求头获取缓存的响应。
 Attributes JarURLConnection.getAttributes()
如果此连接的 URL 指向 JAR 文件条目，则返回其 Attribute 对象；否则返回 null。
abstract  OutputStream CacheRequest.getBody()
返回可以将响应正文写入其中的 OutputStream。
abstract  InputStream CacheResponse.getBody()
以 InputStream 的形式返回响应正文。
 Certificate[] JarURLConnection.getCertificates()
如果此连接的 URL 指向 JAR 文件条目，则返回其 Certificate 对象；否则返回 null。
 Object URLConnection.getContent()
获取此 URL 连接的内容。
 Object URL.getContent()
获取此 URL 的内容。
 Object URLConnection.getContent(Class[] classes)
获取此 URL 连接的内容。
 Object URL.getContent(Class[] classes)
获取此 URL 的内容。
abstract  Object ContentHandler.getContent(URLConnection urlc)
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并根据其创建对象。
 Object ContentHandler.getContent(URLConnection urlc, Class[] classes)
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。
abstract  Map<String,List<String>> CacheResponse.getHeaders()
以 Map 的形式返回响应头。
protected abstract  InputStream SocketImpl.getInputStream()
返回此套接字的输入流。
 InputStream Socket.getInputStream()
返回此套接字的输入流。
 InputStream URLConnection.getInputStream()
返回从此打开的连接读取的输入流。
 JarEntry JarURLConnection.getJarEntry()
返回此连接的 JAR 条目对象（如果有）。
abstract  JarFile JarURLConnection.getJarFile()
返回此连接的 JAR 文件。
 Attributes JarURLConnection.getMainAttributes()
返回此连接的 JAR 文件的主要 Attribute。
 Manifest JarURLConnection.getManifest()
返回此连接的 Manifest；如果没有，则返回 null。
protected abstract  OutputStream SocketImpl.getOutputStream()
返回此套接字的输出流。
 OutputStream Socket.getOutputStream()
返回此套接字的输出流。
 OutputStream URLConnection.getOutputStream()
返回写入到此连接的输出流。
 Permission HttpURLConnection.getPermission()
 Permission URLConnection.getPermission()
返回一个权限对象，其代表建立此对象表示的连接所需的权限。
 int HttpURLConnection.getResponseCode()
从 HTTP 响应消息获取状态码。
 String HttpURLConnection.getResponseMessage()
获取与来自服务器的响应代码一起返回的 HTTP 响应消息（如果有）。
 int ServerSocket.getSoTimeout()
获取 SO_TIMEOUT 的设置。
protected abstract  int DatagramSocketImpl.getTimeToLive()
获取 TTL （生存时间）选项。
 int MulticastSocket.getTimeToLive()
获取在套接字上发出的多播数据包的默认生存时间。
protected abstract  byte DatagramSocketImpl.getTTL()
已过时。 使用 getTimeToLive 代替。
 byte MulticastSocket.getTTL()
已过时。 使用 getTimeToLive 方法来代替，该方法返回 int（而不是 byte）。
static String URLConnection.guessContentTypeFromStream(InputStream is)
根据输入流的开始字符尝试确定输入流的类型。
protected  void ServerSocket.implAccept(Socket s)
ServerSocket 的子类使用此方法重写 accept() 以返回它们自己的套接字子类。
 boolean InetAddress.isReachable(int timeout)
测试是否可以达到该地址。
 boolean InetAddress.isReachable(NetworkInterface netif, int ttl, int timeout)
测试是否可以达到该地址。
protected abstract  void DatagramSocketImpl.join(InetAddress inetaddr)
加入多播组。
 void MulticastSocket.joinGroup(InetAddress mcastaddr)
加入多播组。
protected abstract  void DatagramSocketImpl.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf)
加入多播组。
 void MulticastSocket.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf)
加入指定接口上的指定多播组。
protected abstract  void DatagramSocketImpl.leave(InetAddress inetaddr)
退出多播组。
 void MulticastSocket.leaveGroup(InetAddress mcastaddr)
离开多播组。
protected abstract  void DatagramSocketImpl.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf)
退出多播组。
 void MulticastSocket.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf)
离开指定本地接口上的多播组。
protected abstract  void SocketImpl.listen(int backlog)
将传入连接指示（连接请求）的最大队列长度设置为 count 参数。
 URLConnection URL.openConnection()
返回一个 URLConnection 对象，它表示到 URL 所引用的远程对象的连接。
 URLConnection URL.openConnection(Proxy proxy)
与 openConnection() 类似，所不同是连接通过指定的代理建立；不支持代理方式的协议处理程序将忽略该代理参数并建立正常的连接。
protected abstract  URLConnection URLStreamHandler.openConnection(URL u)
打开一个到 URL 参数引用的对象的连接。
protected  URLConnection URLStreamHandler.openConnection(URL u, Proxy p)
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。
 InputStream URL.openStream()
打开到此 URL 的连接并返回一个用于从该连接读入的 InputStream。
protected abstract  int DatagramSocketImpl.peek(InetAddress i)
查看包来自哪里。
protected abstract  int DatagramSocketImpl.peekData(DatagramPacket p)
查看包来自哪里。
abstract  void CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders)
将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
 void CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)
abstract  CacheRequest ResponseCache.put(URI uri, URLConnection conn)
协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。
protected abstract  void DatagramSocketImpl.receive(DatagramPacket p)
接收数据报包。
 void DatagramSocket.receive(DatagramPacket p)
从此套接字接收数据报包。
protected abstract  void DatagramSocketImpl.send(DatagramPacket p)
发送数据报包。
 void DatagramSocket.send(DatagramPacket p)
从此套接字发送数据报包。
 void MulticastSocket.send(DatagramPacket p, byte ttl)
已过时。 使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......
protected abstract  void SocketImpl.sendUrgentData(int data)
在套接字上发送一个紧急数据字节。
 void Socket.sendUrgentData(int data)
在套接字上发送一个紧急数据字节。
static void DatagramSocket.setDatagramSocketImplFactory(DatagramSocketImplFactory fac)
为应用程序设置数据报套接字实现工厂。
static void ServerSocket.setSocketFactory(SocketImplFactory fac)
为应用程序设置服务器套接字实现工厂。
static void Socket.setSocketImplFactory(SocketImplFactory fac)
为应用程序设置客户端套接字实现工厂。
protected abstract  void DatagramSocketImpl.setTimeToLive(int ttl)
设置 TTL （生存时间）选项。
 void MulticastSocket.setTimeToLive(int ttl)
设置在此 MulticastSocket 上发出的多播数据包的默认生存时间，以便控制多播的范围。
protected abstract  void DatagramSocketImpl.setTTL(byte ttl)
已过时。 使用 setTimeToLive 代替。
 void MulticastSocket.setTTL(byte ttl)
已过时。 使用 setTimeToLive 方法来代替，该方法使用 int（而不用 byte）作为 ttl 的类型。
protected  void SocketImpl.shutdownInput()
将此套接字的输入流置于“流的末尾”。
 void Socket.shutdownInput()
此套接字的输入流置于“流的末尾”。
protected  void SocketImpl.shutdownOutput()
禁用此套接字的输出流。
 void Socket.shutdownOutput()
禁用此套接字的输出流。

抛出 IOException 的 java.net 中的构造方法
MulticastSocket()
创建多播套接字。
MulticastSocket(int port)
创建多播套接字并将其绑定到特定端口。
MulticastSocket(SocketAddress bindaddr)
创建绑定到指定套接字地址的 MulticastSocket。
ServerSocket()
创建非绑定服务器套接字。
ServerSocket(int port)
创建绑定到特定端口的服务器套接字。
ServerSocket(int port, int backlog)
利用指定的 backlog 创建服务器套接字并将其绑定到指定的本地端口号。
ServerSocket(int port, int backlog, InetAddress bindAddr)
使用指定的端口、侦听 backlog 和要绑定到的本地 IP 地址创建服务器。
Socket(InetAddress address, int port)
创建一个流套接字并将其连接到指定 IP 地址的指定端口号。
Socket(InetAddress host, int port, boolean stream)
已过时。 Use DatagramSocket instead for UDP transport.
Socket(InetAddress address, int port, InetAddress localAddr, int localPort)
创建一个套接字并将其连接到指定远程地址上的指定远程端口。
Socket(String host, int port)
创建一个流套接字并将其连接到指定主机上的指定端口号。
Socket(String host, int port, boolean stream)
已过时。 使用 DatagramSocket 取代 UDP 传输。
Socket(String host, int port, InetAddress localAddr, int localPort)
创建一个套接字并将其连接到指定远程主机上的指定远程端口。

java.nio 中 IOException 的使用

抛出 IOException 的 java.nio 中的方法
 int CharBuffer.read(CharBuffer target)
试图将字符读入指定的字符缓冲区。

java.nio.channels 中 IOException 的使用

java.nio.channels 中 IOException 的子类
class | AsynchronousCloseException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
class | ClosedByInterruptException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
class | ClosedChannelException 当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
class | FileLockInterruptionException 当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。

抛出 IOException 的 java.nio.channels 中的方法
abstract SocketChannel | ServerSocketChannel.accept() 接受到此通道套接字的连接。
abstract void | Selector.close() 关闭此选择器。
void | InterruptibleChannel.close() 关闭此通道。
void | Channel.close() 关闭此通道。
abstract SelectableChannel | SelectableChannel.configureBlocking(boolean block) 调整此通道的阻塞模式。
abstract DatagramChannel | DatagramChannel.connect(SocketAddress remote) 连接此通道的套接字。
abstract boolean | SocketChannel.connect(SocketAddress remote) 连接此通道的套接字。
abstract DatagramChannel | DatagramChannel.disconnect() 断开此通道套接字的连接。
abstract boolean | SocketChannel.finishConnect() 完成套接字通道的连接过程。
abstract void | FileChannel.force(boolean metaData) 强制将所有对此通道的文件更新写入包含该文件的存储设备中。
FileLock | FileChannel.lock() 获取对此通道的文件的独占锁定。
abstract FileLock | FileChannel.lock(long position, long size, boolean shared) 获取此通道的文件给定区域上的锁定。
abstract MappedByteBuffer | FileChannel.map(FileChannel.MapMode mode, long position, long size) 将此通道的文件区域直接映射到内存中。
static DatagramChannel | DatagramChannel.open() 打开数据报通道。
static Pipe | Pipe.open() 打开一个管道。
static Selector | Selector.open() 打开一个选择器。
static ServerSocketChannel | ServerSocketChannel.open() 打开服务器套接字通道。
static SocketChannel | SocketChannel.open() 打开套接字通道。
static SocketChannel | SocketChannel.open(SocketAddress remote) 打开套接字通道并将其连接到远程地址。
abstract long | FileChannel.position() 返回此通道的文件位置。
abstract FileChannel | FileChannel.position(long newPosition) 设置此通道的文件位置。
abstract int | DatagramChannel.read(ByteBuffer dst) 从此通道读取数据报。
abstract int | SocketChannel.read(ByteBuffer dst)
abstract int | FileChannel.read(ByteBuffer dst) 将字节序列从此通道读入给定的缓冲区。
int | ReadableByteChannel.read(ByteBuffer dst) 将字节序列从此通道中读入给定的缓冲区。
long | DatagramChannel.read(ByteBuffer[] dsts) 从此通道读取数据报。
long | SocketChannel.read(ByteBuffer[] dsts)
long | FileChannel.read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
long | ScatteringByteChannel.read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
abstract long | DatagramChannel.read(ByteBuffer[] dsts, int offset, int length) 从此通道读取数据报。
abstract long | SocketChannel.read(ByteBuffer[] dsts, int offset, int length)
abstract long | FileChannel.read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
long | ScatteringByteChannel.read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
abstract int | FileChannel.read(ByteBuffer dst, long position) 从给定的文件位置开始，从此通道读取字节序列,并写入给定的缓冲区。
abstract SocketAddress | DatagramChannel.receive(ByteBuffer dst) 通过此通道接收数据报。
abstract void | FileLock.release() 释放此锁定。
abstract int | Selector.select() 选择一组键，其相应的通道已为 I/O 操作准备就绪。
abstract int | Selector.select(long timeout) 选择一组键，其相应的通道已为 I/O 操作准备就绪。
abstract int | Selector.selectNow() 选择一组键，其相应的通道已为 I/O 操作准备就绪。
abstract int | DatagramChannel.send(ByteBuffer src, SocketAddress target) 通过此通道发送数据报。
abstract long | FileChannel.size() 返回此通道的文件的当前大小。
abstract long | FileChannel.transferFrom(ReadableByteChannel src, long position, long count) 将字节从给定的可读取字节通道传输到此通道的文件中。
abstract long | FileChannel.transferTo(long position, long count, WritableByteChannel target) 将字节从此通道的文件传输到给定的可写入字节通道。
abstract FileChannel | FileChannel.truncate(long size) 将此通道的文件截取为给定大小。
FileLock | FileChannel.tryLock() 试图获取对此通道的文件的独占锁定。
abstract FileLock | FileChannel.tryLock(long position, long size, boolean shared) 试图获取对此通道的文件给定区域的锁定。
abstract int | DatagramChannel.write(ByteBuffer src) 将数据报写入此通道。
abstract int | SocketChannel.write(ByteBuffer src)
abstract int | FileChannel.write(ByteBuffer src) 将字节序列从给定的缓冲区写入此通道。
int | WritableByteChannel.write(ByteBuffer src) 将字节序列从给定的缓冲区中写入此通道。
long | DatagramChannel.write(ByteBuffer[] srcs) 将数据报写入此通道。
long | SocketChannel.write(ByteBuffer[] srcs)
long | FileChannel.write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
long | GatheringByteChannel.write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
abstract long | DatagramChannel.write(ByteBuffer[] srcs, int offset, int length) 将数据报写入此通道。
abstract long | SocketChannel.write(ByteBuffer[] srcs, int offset, int length)
abstract long | FileChannel.write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
long | GatheringByteChannel.write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
abstract int | FileChannel.write(ByteBuffer src, long position) 从给定的文件位置开始，将字节序列从给定缓冲区写入此通道。

java.nio.channels.spi 中 IOException 的使用

抛出 IOException 的 java.nio.channels.spi 中的方法
void | AbstractSelector.close() 关闭此选择器。
void | AbstractInterruptibleChannel.close() 关闭此通道。
SelectableChannel | AbstractSelectableChannel.configureBlocking(boolean block) 调整此通道的阻塞模式。
protected void | AbstractSelectableChannel.implCloseChannel() 关闭此通道。
protected abstract void | AbstractInterruptibleChannel.implCloseChannel() 关闭此通道。
protected abstract void | AbstractSelectableChannel.implCloseSelectableChannel() 关闭此可选择通道。
protected abstract void | AbstractSelector.implCloseSelector() 关闭此选择器。
protected abstract void | AbstractSelectableChannel.implConfigureBlocking(boolean block) 调整此通道的阻塞模式。
Channel | SelectorProvider.inheritedChannel() 返回从创建此 Java 虚拟机的实体中继承的通道。
abstract DatagramChannel | SelectorProvider.openDatagramChannel() 打开数据报通道。
abstract Pipe | SelectorProvider.openPipe() 打开一个管道。
abstract AbstractSelector | SelectorProvider.openSelector() 打开一个选择器。
abstract ServerSocketChannel | SelectorProvider.openServerSocketChannel() 打开服务器套接字通道。
abstract SocketChannel | SelectorProvider.openSocketChannel() 打开套接字通道。

java.nio.charset 中 IOException 的使用

java.nio.charset 中 IOException 的子类
class | CharacterCodingException 出现字符编码或解码错误时，抛出此经过检查的异常。
class | MalformedInputException 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
class | UnmappableCharacterException 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。

java.rmi 中 IOException 的使用

java.rmi 中 IOException 的子类
class | AccessException AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
class | ConnectException 如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
class | ConnectIOException 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
class | MarshalException 如果在编组远程调用标题、参数或远程方法调用的返回值时发生 java.io.IOException，则抛出 MarshalException。
class | NoSuchObjectException 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
class | RemoteException RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
class | ServerError 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
class | ServerException 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
class | ServerRuntimeException 已过时。 无替换版本
class | StubNotFoundException 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
class | UnexpectedException 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
class | UnmarshalException 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

抛出 IOException 的 java.rmi 中的方法
 T MarshalledObject.get()
返回所包含的 marshalledobject 的新副本。

抛出 IOException 的 java.rmi 中的构造方法
MarshalledObject(T obj)
创建一个新的 MarshalledObject，它包含所提供对象的当前状态的序列化表示形式。

java.rmi.activation 中 IOException 的使用

java.rmi.activation 中 IOException 的子类
 class ActivateFailedException
在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。

java.rmi.server 中 IOException 的使用

java.rmi.server 中 IOException 的子类
class | ExportException ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SocketSecurityException 已废弃的 ExportException 的子类。

抛出 IOException 的 java.rmi.server 中的方法
ServerSocket | RMIServerSocketFactory.createServerSocket(int port) 在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
abstract ServerSocket | RMISocketFactory.createServerSocket(int port) 在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
Socket | RMIClientSocketFactory.createSocket(String host, int port) 创建连接到指定主机和端口的客户机套接字。
abstract Socket | RMISocketFactory.createSocket(String host, int port) 创建连接到指定主机和端口的客户机套接字。
void | RemoteCall.done() 已过时。 无替代版本
ObjectInput | RemoteCall.getInputStream() 已过时。 无替代版本
ObjectOutput | RemoteCall.getOutputStream() 已过时。 无替代版本
ObjectOutput | RemoteCall.getResultStream(boolean success) 已过时。 无替代版本
static UID | UID.read(DataInput in) 通过从 DataInput 实例解组二进制表示形式构造并返回一个新的 UID。
static ObjID | ObjID.read(ObjectInput in) 通过从 ObjectInput 实例解组二进制表示形式来构造和返回一个新的 ObjID 实例。
void | RemoteCall.releaseInputStream() 已过时。 无替代版本
void | RemoteCall.releaseOutputStream() 已过时。 无替代版本
static void | RMISocketFactory.setSocketFactory(RMISocketFactory fac) 设置 RMI 从中获取套接字的全局套接字工厂（如果远程对象与指定客户机和/或服务器套接字工厂无关）。
void | UID.write(DataOutput out) 将此 UID 的二进制表示形式编组为一个 DataOutput 实例。
void | ObjID.write(ObjectOutput out) 将此 ObjID 的二进制表示形式编组为一个 ObjectOutput 实例。

java.security 中 IOException 的使用

抛出 IOException 的 java.security 中的方法
void | Certificate.decode(InputStream stream) 已过时。 从输入流解码证书。
void | Certificate.encode(OutputStream stream) 已过时。 以 decode 方法可以解码的格式将证书编码到输出流。
protected abstract byte[] | AlgorithmParametersSpi.engineGetEncoded() 返回基本编码格式的参数。
protected abstract byte[] | AlgorithmParametersSpi.engineGetEncoded(String format) 返回以指定格式编码的参数。
protected abstract void | AlgorithmParametersSpi.engineInit(byte[] params) 根据参数的基本解码格式导入指定的参数并对其解码。
protected abstract void | AlgorithmParametersSpi.engineInit(byte[] params, String format) 根据指定的解码格式从 params 导入参数并对其解码。
abstract void | KeyStoreSpi.engineLoad(InputStream stream, char[] password) 从给定的输入流中加载此 KeyStore。
void | KeyStoreSpi.engineLoad(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
void | KeyStoreSpi.engineStore(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
abstract void | KeyStoreSpi.engineStore(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
byte[] | AlgorithmParameters.getEncoded() 返回基本编码格式的参数。
byte[] | AlgorithmParameters.getEncoded(String format) 返回以指定方案编码的参数。
Object | SignedObject.getObject() 获取已封装的对象。
void | AlgorithmParameters.init(byte[] params) 根据参数的基本解码格式导入指定的参数并对其解码。
void | AlgorithmParameters.init(byte[] params, String format) 根据指定的解码方案从 params 导入参数并对其解码。
void | Provider.load(InputStream inStream) 从输入流中读取属性列表（键和元素对）。
void | KeyStore.load(InputStream stream, char[] password) 从给定输入流中加载此 KeyStore。
void | KeyStore.load(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 加载此 keystore。
int | DigestInputStream.read() 读取字节并更新消息摘要（如果开启了摘要功能）。
int | DigestInputStream.read(byte[] b, int off, int len) 读入 byte 数组并更新消息摘要（如果开启了摘要功能）。
void | KeyStore.store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。
void | KeyStore.store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。
void | DigestOutputStream.write(byte[] b, int off, int len) 使用指定的子数组更新消息摘要（如果开启了摘要功能），并将子数组写入输出流（不管是否开启了摘要功能）。
void | DigestOutputStream.write(int b) 使用指定的字节更新消息摘要（如果开启了摘要功能），并将字节写入输出流（不管是否开启了摘要功能）。

抛出 IOException 的 java.security 中的构造方法
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

java.security.cert 中 IOException 的使用

抛出 IOException 的 java.security.cert 中的方法
 void X509CRLSelector.addIssuerName(byte[] name)
向 issuerNames 标准中添加名称。
 void X509CRLSelector.addIssuerName(String name)
已过时，使用 X509CRLSelector.addIssuer(X500Principal) 或 X509CRLSelector.addIssuerName(byte[]) 替代。
 void X509CertSelector.addPathToName(int type, byte[] name)
向 pathToNames 标准中添加一个名称。
 void X509CertSelector.addPathToName(int type, String name)
向 pathToNames 标准中添加一个名称。
 void X509CertSelector.addSubjectAlternativeName(int type, byte[] name)
向 subjectAlternativeNames 标准中添加一个名称。
 void X509CertSelector.addSubjectAlternativeName(int type, String name)
向 subjectAlternativeNames 标准中添加一个名称。
 byte[] X509CertSelector.getIssuerAsBytes()
返回以 byte 数组表示的 issuer 标准。
 byte[] X509CertSelector.getSubjectAsBytes()
以 byte 数组的形式返回 subject 标准。
 void X509CertSelector.setExtendedKeyUsage(Set<String> keyPurposeSet)
设置 extendedKeyUsage 标准。
 void X509CertSelector.setIssuer(byte[] issuerDN)
设置 issuer 标准。
 void X509CertSelector.setIssuer(String issuerDN)
已过时，使用 X509CertSelector.setIssuer(X500Principal) 或 X509CertSelector.setIssuer(byte[]) 替代。
 void X509CRLSelector.setIssuerNames(Collection<?> names)
注意：请使用 X509CRLSelector.setIssuers(Collection) 方法，或者使用此方法时仅指定 byte 数组形式的标识名。
 void X509CertSelector.setNameConstraints(byte[] bytes)
设置 NameConstraints 标准。
 void X509CertSelector.setPathToNames(Collection<List<?>> names)
设置 pathToNames 标准。
 void X509CertSelector.setPolicy(Set<String> certPolicySet)
设置策略限制。
 void X509CertSelector.setSubject(byte[] subjectDN)
设置 subject 标准。
 void X509CertSelector.setSubject(String subjectDN)
已过时，使用 X509CertSelector.setSubject(X500Principal) 或 X509CertSelector.setSubject(byte[]) 替代。
 void X509CertSelector.setSubjectAlternativeNames(Collection<List<?>> names)
设置 subjectAlternativeNames 标准。
 void X509CertSelector.setSubjectPublicKey(byte[] key)
设置 subjectPublicKey 标准。
 void X509CertSelector.setSubjectPublicKeyAlgID(String oid)
设置 subjectPublicKeyAlgID 标准。

抛出 IOException 的 java.security.cert 中的构造方法
PolicyQualifierInfo(byte[] encoded)
根据已编码的字节创建一个 PolicyQualifierInfo 实例。

java.util 中 IOException 的使用

java.util 中 IOException 的子类
 class InvalidPropertiesFormatException
当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。

返回 IOException 的 java.util 中的方法
IOException | Formatter.ioException() 返回由此 formatter 的 Appendable 方法上次抛出的 IOException 异常。
IOException | Scanner.ioException() 返回此 Scanner 的底层 Readable 最后抛出的 IOException。

抛出 IOException 的 java.util 中的方法
void | Properties.load(InputStream inStream) 从输入流中读取属性列表（键和元素对）。
void | Properties.load(Reader reader) 按简单的面向行的格式从输入字符流中读取属性列表（键和元素对）。
void | Properties.loadFromXML(InputStream in) 将指定输入流中由 XML 文档所表示的所有属性加载到此属性表中。
ResourceBundle | ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload) 针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。
void | Properties.store(OutputStream out, String comments) 以适合使用 load(InputStream) 方法加载到 Properties 表中的格式，将此 Properties 表中的属性列表（键和元素对）写入输出流。
void | Properties.store(Writer writer, String comments) 以适合使用 load(Reader) 方法的格式，将此 Properties 表中的属性列表（键和元素对）写入输出字符。
void | Properties.storeToXML(OutputStream os, String comment) 发出一个表示此表中包含的所有属性的 XML 文档。
void | Properties.storeToXML(OutputStream os, String comment, String encoding) 使用指定的编码发出一个表示此表中包含的所有属性的 XML 文档。

抛出 IOException 的 java.util 中的构造方法
PropertyResourceBundle(InputStream stream)
根据 InputStream 创建属性资源包。
PropertyResourceBundle(Reader reader)
根据 Reader 创建属性资源包。

java.util.jar 中 IOException 的使用

java.util.jar 中 IOException 的子类
 class JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

抛出 IOException 的 java.util.jar 中的方法
Attributes | JarEntry.getAttributes() 返回此条目的 Manifest Attributes；如果没有，则返回 null。
InputStream | JarFile.getInputStream(ZipEntry ze) 返回用于读取指定 zip 文件条目内容的输入流。
Manifest | JarFile.getManifest() 返回 jar 文件清单；如果没有，则返回 null。
ZipEntry | JarInputStream.getNextEntry() 读取下一个 ZIP 文件条目，并将流定位于此条目数据的开始处。
JarEntry | JarInputStream.getNextJarEntry() 读取下一个 JAR 文件条目，并将流定位于此条目数据的开始处。
void | Pack200.Packer.pack(JarFile in, OutputStream out) 接收 JarFile 并将其转换为 Pack200 存档。
void | Pack200.Packer.pack(JarInputStream in, OutputStream out) 接收 JarInputStream 并将其转换成 Pack200 存档。
void | JarOutputStream.putNextEntry(ZipEntry ze) 开始写入新的 JAR 文件条目，并将流定位到条目数据的开始处。
int | JarInputStream.read(byte[] b, int off, int len) 从当前 JAR 文件条目读入字节数组。
void | Manifest.read(InputStream is) 从指定的 InputStream 读取 Manifest。
void | Pack200.Unpacker.unpack(File in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
void | Pack200.Unpacker.unpack(InputStream in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
void | Manifest.write(OutputStream out) 将 Manifest 写入指定的 OutputStream。

抛出 IOException 的 java.util.jar 中的构造方法
JarFile(File file)
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File file, boolean verify)
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File file, boolean verify, int mode)
创建一个要从指定的 File 对象中以指定模式读取的新的 JarFile。
JarFile(String name)
创建一个要从指定的文件 name 读取的新的 JarFile。
JarFile(String name, boolean verify)
创建一个要从指定的文件 name 读取的新的 JarFile。
JarInputStream(InputStream in)
创建新的 JarInputStream 并读取可选的清单。
JarInputStream(InputStream in, boolean verify)
创建新的 JarInputStream 并读取可选的清单。
JarOutputStream(OutputStream out)
创建不带清单的新的 JarOutputStream。
JarOutputStream(OutputStream out, Manifest man)
使用指定的 Manifest 创建新的 JarOutputStream。
Manifest(InputStream is)
从指定的输入流构造新的 Manifest。

java.util.logging 中 IOException 的使用

抛出 IOException 的 java.util.logging 中的方法
void | LogManager.readConfiguration() 重新初始化日志属性并重新读取日志配置。
void | LogManager.readConfiguration(InputStream ins) 从给定流重新初始化并重新读取日志配置，该配置为 java.util.Properties 格式。

抛出 IOException 的 java.util.logging 中的构造方法
FileHandler()
构造一个默认的 FileHandler。
FileHandler(String pattern)
初始化要写入给定文件名的 FileHandler 。
FileHandler(String pattern, boolean append)
初始化要写入给定文件名的 FileHandler（使用可选的 append）。
FileHandler(String pattern, int limit, int count)
初始化要写入文件集的 FileHandler。
FileHandler(String pattern, int limit, int count, boolean append)
初始化要写入文件集的 FileHandler（使用可选的 append）。
SocketHandler()
仅使用 LogManager 属性（或其默认值）创建 SocketHandler。
SocketHandler(String host, int port)
构造一个带有指定主机和端口的 SocketHandler。

java.util.prefs 中 IOException 的使用

抛出 IOException 的 java.util.prefs 中的方法
 void AbstractPreferences.exportNode(OutputStream os)
根据 Preferences.exportNode(OutputStream) 中的规范实现 exportNode 方法。
abstract  void Preferences.exportNode(OutputStream os)
在指定输出流上发出表示此节点（不是其子节点）中包含的所有首选项的 XML 文档。
 void AbstractPreferences.exportSubtree(OutputStream os)
根据 Preferences.exportSubtree(OutputStream) 中的规范实现 exportSubtree 方法。
abstract  void Preferences.exportSubtree(OutputStream os)
发出表示此节点及其所有子节点中包含的全部首选项的 XML 文档。
static void Preferences.importPreferences(InputStream is)
导入指定输入流中由 XML 文档表示的所有首选项。

java.util.zip 中 IOException 的使用

java.util.zip 中 IOException 的子类
 class ZipException
如果某种 ZIP 异常发生，则抛出此错误。

抛出 IOException 的 java.util.zip 中的方法
int | DeflaterInputStream.available() 在到达 EOF 后返回 0；否则始终返回 1。
int | ZipInputStream.available() 在 EOF 到达当前条目数据后，返回 0；否则，始终返回 1。
int | InflaterInputStream.available() 在到达 EOF 后返回 0；否则始终返回 1。
void | DeflaterInputStream.close() 关闭此输入流和它的底层输入流，丢弃挂起的未压缩数据。
void | InflaterOutputStream.close() 将剩余未压缩数据写入输出流并关闭底层输出流。
void | ZipOutputStream.close() 关闭 ZIP 输出流和正在过滤的流。
void | DeflaterOutputStream.close() 将剩余压缩数据写入输出流并关闭底层流。
void | GZIPInputStream.close() 关闭此输入流并释放与该流关联的所有系统资源。
void | ZipInputStream.close() 关闭此输入流并释放与此流关联的所有系统资源。
void | InflaterInputStream.close() 关闭此输入流并释放与该流关联的所有系统资源。
void | ZipFile.close() 关闭 ZIP 文件。
void | ZipOutputStream.closeEntry() 关闭当前 ZIP 条目并定位流以写入下一个条目。
void | ZipInputStream.closeEntry() 关闭当前 ZIP 条目并定位流以读取下一个条目。
protected void | DeflaterOutputStream.deflate() 将下一个压缩数据块写入输出流。
protected void | InflaterInputStream.fill() 使用更多要解压缩的数据填充输入缓冲区。
protected void | ZipFile.finalize() 确保不再引用此 ZIP 文件时调用它的 close 方法。
void | GZIPOutputStream.finish() 完成将压缩数据写入输出流的操作，无需关闭底层流。
void | InflaterOutputStream.finish() 完成将未压缩数据写入输出流的操作，无需关闭底层流。
void | ZipOutputStream.finish() 完成写入 ZIP 输出流的内容，无需关闭底层流。
void | DeflaterOutputStream.finish() 完成将压缩数据写入输出流的操作，无需关闭底层流。
void | InflaterOutputStream.flush() 刷新此输出流，并强制写出挂起的所有缓冲输出字节。
InputStream | ZipFile.getInputStream(ZipEntry entry) 返回输入流以读取指定 ZIP 文件条目的内容。
ZipEntry | ZipInputStream.getNextEntry() 读取下一个 ZIP 文件条目并将流定位到该条目数据的开始处。
void | ZipOutputStream.putNextEntry(ZipEntry e) 开始写入新的 ZIP 文件条目并将流定位到条目数据的开始处。
int | CheckedInputStream.read() 读取字节。
int | DeflaterInputStream.read() 从输入流读取一个压缩数据的单个字节。
int | InflaterInputStream.read() 读取未压缩数据的字节。
int | CheckedInputStream.read(byte[] buf, int off, int len) 读入字节数组。
int | DeflaterInputStream.read(byte[] b, int off, int len) 将压缩数据读入 byte 数组。
int | GZIPInputStream.read(byte[] buf, int off, int len) 将未压缩数据读入字节数组。
int | ZipInputStream.read(byte[] b, int off, int len) 从当前 ZIP 条目读入字节数组。
int | InflaterInputStream.read(byte[] b, int off, int len) 将未压缩数据读入字节数组。
void | DeflaterInputStream.reset() 不支持此操作。
void | InflaterInputStream.reset() 将此流重新定位到对此输入流最后调用 mark 方法时的位置。
long | CheckedInputStream.skip(long n) 跳过指定的输入字节数。
long | DeflaterInputStream.skip(long n) 从输入流中跳过并丢弃数据。
long | ZipInputStream.skip(long n) 跳过当前 ZIP 条目中指定的字节数。
long | InflaterInputStream.skip(long n) 跳过指定的未压缩数据的字节数。
void | CheckedOutputStream.write(byte[] b, int off, int len) 写入字节数组。
void | GZIPOutputStream.write(byte[] buf, int off, int len) 将字节数组写入压缩输出流。
void | InflaterOutputStream.write(byte[] b, int off, int len) 将 byte 数组写入未压缩输出流。
void | ZipOutputStream.write(byte[] b, int off, int len) 将字节数组写入当前 ZIP 条目数据。
void | DeflaterOutputStream.write(byte[] b, int off, int len) 将字节数组写入压缩的输出流。
void | CheckedOutputStream.write(int b) 写入字节。
void | InflaterOutputStream.write(int b) 将字节写入未压缩输出流。
void | DeflaterOutputStream.write(int b) 将字节写入压缩的输出流。

抛出 IOException 的 java.util.zip 中的构造方法
GZIPInputStream(InputStream in)
使用默认缓冲区大小创建新的输入流。
GZIPInputStream(InputStream in, int size)
使用指定缓冲区大小创建新的输入流。
GZIPOutputStream(OutputStream out)
使用默认缓冲区大小创建新的输出流。
GZIPOutputStream(OutputStream out, int size)
使用指定缓冲区大小创建新的输出流。
ZipFile(File file)
打开供阅读的 ZIP 文件，由指定的 File 对象给出。
ZipFile(File file, int mode)
打开新的 ZipFile 以使用指定模式从指定 File 对象读取。
ZipFile(String name)
打开 ZIP 文件进行阅读。

javax.activation 中 IOException 的使用

javax.activation 中 IOException 的子类
 class UnsupportedDataTypeException
当请求操作不支持请求的数据类型时，抛出此异常。

抛出 IOException 的 javax.activation 中的方法
Object | CommandInfo.getCommandObject(DataHandler dh, ClassLoader loader) 返回已实例化的 JavaBean 组件。
Object | DataHandler.getContent() 以其首选 Object 的形式返回数据。
Object | DataContentHandler.getContent(DataSource ds) 返回一个对象，该对象表示其首选形式的数据。
InputStream | DataHandler.getInputStream() 获取此对象的 InputSteam。
InputStream | DataSource.getInputStream() 此方法返回一个表示数据的 InputStream；如果无法提供，则抛出适当的异常。
InputStream | FileDataSource.getInputStream() 此方法将返回一个表示数据的 InputStream；如果不能返回，则抛出 IOException。
InputStream | URLDataSource.getInputStream() URL 的 getInputStream 方法。
OutputStream | DataHandler.getOutputStream() 获取此 DataHandler 的 OutputStream，以允许重写底层数据。
OutputStream | DataSource.getOutputStream() 此方法返回一个可以写入数据的 OutputStream，如果无法返回，则抛出适当的异常。
OutputStream | FileDataSource.getOutputStream() 此方法将返回一个表示数据的 OutputStream；如果不能返回，则抛出 IOException。
OutputStream | URLDataSource.getOutputStream() URL 的 getOutputStream 方法。
Object | DataHandler.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示要传输的数据。
Object | DataContentHandler.getTransferData(DataFlavor df, DataSource ds) 返回一个对象，该对象表示将要传输的数据。
void | MimeType.readExternal(ObjectInput in) 对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。
void | CommandObject.setCommandContext(String verb, DataHandler dh) 用请求处理的动词和描述将要操作的数据的 DataHandler 来初始化 Command。
void | MimeType.writeExternal(ObjectOutput out) 对象可实现 writeExternal 方法来保存其内容：对于其基本值，调用 DataOutput 的方法；对于对象、字符串和数组，调用 ObjectOutput 的 writeObject 方法。
void | DataContentHandler.writeTo(Object obj, String mimeType, OutputStream os) 将对象转换为指定 MIME 类型的字节流，并将其写入输出流。
void | DataHandler.writeTo(OutputStream os) 将数据写入 OutputStream。

抛出 IOException 的 javax.activation 中的构造方法
MailcapCommandMap(String fileName)
允许调用者指定 mailcap 文件路径的构造方法。
MimetypesFileTypeMap(String mimeTypeFileName)
用从指定文件中添加的编程条目构造 MimetypesFileTypeMap。

javax.activity 中 IOException 的使用

javax.activity 中 IOException 的子类
class | ActivityCompletedException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
class | ActivityRequiredException 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
class | InvalidActivityException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

javax.annotation.processing 中 IOException 的使用

javax.annotation.processing 中 IOException 的子类
 class FilerException
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

抛出 IOException 的 javax.annotation.processing 中的方法
JavaFileObject | Filer.createClassFile(CharSequence name, Element... originatingElements) 创建一个新的类文件，并返回一个对象以允许写入它。
FileObject | Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
JavaFileObject | Filer.createSourceFile(CharSequence name, Element... originatingElements) 创建一个新的源文件，并返回一个对象以允许写入它。
FileObject | Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName) 返回一个用于读取现有资源的对象。

javax.crypto 中 IOException 的使用

抛出 IOException 的 javax.crypto 中的方法
int | CipherInputStream.available() 返回不发生阻塞地从此输入流读取的字节数。
void | CipherInputStream.close() 关闭该输入流并释放任何与该流关联的系统资源。
void | CipherOutputStream.close() 关闭此输出流并释放任何与此流关联的系统资源。
void | CipherOutputStream.flush() 强制写出已由封装的密码对象处理的任何缓存输出字节来刷新此输出流。
byte[] | EncryptedPrivateKeyInfo.getEncoded() 返回此对象的 ASN.1 编码。
Object | SealedObject.getObject(Cipher c) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。
int | CipherInputStream.read() 从该输入流读取下一数据字节。
int | CipherInputStream.read(byte[] b) 从该输入流将 b.length 个数据字节读入到字节数组中。
int | CipherInputStream.read(byte[] b, int off, int len) 从该输入流将 len 个字节数据读入到字节数组中。
long | CipherInputStream.skip(long n) 跳过不发生阻塞地从该输入流读取的字节中的 n 个字节的输入。
void | CipherOutputStream.write(byte[] b) 从指定的字节数组中将 b.length 个字节写入此输出流。
void | CipherOutputStream.write(byte[] b, int off, int len) 将指定的字节数组中从 off 偏移量开始的 len 个字节写入此输出流。
void | CipherOutputStream.write(int b) 将指定的字节写入此输出流。

抛出 IOException 的 javax.crypto 中的构造方法
EncryptedPrivateKeyInfo(byte[] encoded)
根据其 ASN.1 编码构造（即解析）EncryptedPrivateKeyInfo。
SealedObject(Serializable object, Cipher c)
从任何 Serializable 对象构造一个 SealedObject。

javax.imageio 中 IOException 的使用

javax.imageio 中 IOException 的子类
 class IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。

抛出 IOException 的 javax.imageio 中的方法
boolean | ImageWriter.canInsertEmpty(int imageIndex) 如果 writer 支持在给定索引处插入新的空图像，则返回 true。
boolean | ImageWriter.canInsertImage(int imageIndex) 如果 writer 支持在给定索引处插入新图像，则返回 true。
boolean | ImageWriter.canRemoveImage(int imageIndex) 如果 writer 支持在给定索引处移除现有图像，则返回 true。
boolean | ImageWriter.canReplaceImageMetadata(int imageIndex) 如果有可能使用索引 imageIndex 替换与现有图像有关的图像元数据，则返回 true。
boolean | ImageWriter.canReplacePixels(int imageIndex) 如果 writer 允许使用 replacePixels 方法替换给定图像的索引，则返回 true。
boolean | ImageWriter.canReplaceStreamMetadata() 如果有可能替换已存在于输出中的流元数据，则返回 true。
boolean | ImageWriter.canWriteEmpty() 如果 writer 支持写入由单个图像组成的完整图像流，则返回 true，这些对象带有要输出的不确定像素值、有关元数据和缩略图。
static ImageInputStream | ImageIO.createImageInputStream(Object input) 返回一个 ImageInputStream，它将从给定 Object 中获取输入。
static ImageOutputStream | ImageIO.createImageOutputStream(Object output) 返回一个 ImageOutputStream，它将其输出发送到给定 Object。
void | ImageWriter.endInsertEmpty() 完成对新图像的插入，该操作是从以前调用 prepareInsertEmpty 开始的。
void | ImageWriter.endReplacePixels() 终止调用 replacePixels 的序列。
void | ImageWriter.endWriteEmpty() 完成对新图像的写入，该操作是从优先调用 prepareWriteEmpty 开始的。
void | ImageWriter.endWriteSequence() 完成以 prepareWriteSequence 开头的一系列图像的写入。
float | ImageReader.getAspectRatio(int imageIndex) 以 float 的形式返回给定图像的高宽比（即宽度除以高度）。
String | ImageReader.getFormatName() 返回一个标识输入源格式的 String。
abstract int | ImageReader.getHeight(int imageIndex) 返回输入源中的给定图像的高度，以像素为单位。
abstract IIOMetadata | ImageReader.getImageMetadata(int imageIndex) 返回包含与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
IIOMetadata | ImageReader.getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames) 返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。
abstract Iterator<ImageTypeSpecifier> | ImageReader.getImageTypes(int imageIndex) 以 ImageTypeSpecifier 形式返回包含可能的图像类型的 Iterator，给定图像可能被解码成这些类型。
abstract int | ImageReader.getNumImages(boolean allowSearch) 返回当前输入源中可用的图像数，不包括缩略图。
int | ImageReader.getNumThumbnails(int imageIndex) 返回与给定图像关联的缩略图预览图像的数量。
ImageTypeSpecifier | ImageReader.getRawImageType(int imageIndex) 返回一个 ImageTypeSpecifier，指示最能代表图像“原始”内部格式的 SampleModel 和 ColorModel。
abstract IIOMetadata | ImageReader.getStreamMetadata() 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）；如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
IIOMetadata | ImageReader.getStreamMetadata(String formatName, Set<String> nodeNames) 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。
int | ImageReader.getThumbnailHeight(int imageIndex, int thumbnailIndex) 返回通过索引 thumbnailIndex 指定的缩略图预览图像的高度，其与通过索引 ImageIndex 指定的图像关联。
int | ImageReader.getThumbnailWidth(int imageIndex, int thumbnailIndex) 返回通过索引 thumbnailIndex 指定的缩略图预览图像的宽度，其与通过索引 ImageIndex 指定的图像关联。
int | ImageReader.getTileGridXOffset(int imageIndex) 返回给定图像中 tile (0, 0) 的左上角的 X 坐标。
int | ImageReader.getTileGridYOffset(int imageIndex) 返回给定图像中 tile (0, 0) 的左上角的 Y 坐标。
int | ImageReader.getTileHeight(int imageIndex) 返回给定图像中 tile 的高度。
int | ImageReader.getTileWidth(int imageIndex) 返回给定图像中 tile 的宽度。
abstract int | ImageReader.getWidth(int imageIndex) 返回输入源中的给定图像的宽度，以像素为单位。
boolean | ImageReader.hasThumbnails(int imageIndex) 如果给定图像具有与之关联的缩略图预览图像，则返回 true。
boolean | ImageReader.isImageTiled(int imageIndex) 如果图像被组织成 tile（即等大小的非重叠矩形），则返回 true。
boolean | ImageReader.isRandomAccessEasy(int imageIndex) 如果给定图像的存储格式不会给像素的随机访问带来内在妨碍，则返回 true。
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareReplacePixels(int imageIndex, Rectangle region) 准备好 writer，处理一系列对 replacePixels 方法的调用。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | ImageWriter.prepareWriteSequence(IIOMetadata streamMetadata) 使用提供的流元数据对象准备一个流，以接受一系列的后续 writeToSequence 调用。
static BufferedImage | ImageIO.read(File input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 File 的结果。
static BufferedImage | ImageIO.read(ImageInputStream stream) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 ImageInputStream 的结果。
static BufferedImage | ImageIO.read(InputStream input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 InputStream 的结果。
BufferedImage | ImageReader.read(int imageIndex) 使用默认 ImageReadParam 读取通过索引 imageIndex 指定的图像，并将其作为一个完整的 BufferedImage 返回。
abstract BufferedImage | ImageReader.read(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的对象，并将它作为一个完整的 BufferedImage 返回。
static BufferedImage | ImageIO.read(URL input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 URL 的结果。
IIOImage | ImageReader.readAll(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的图像，并返回包含图像、缩略图和相关图像元数据的 IIOImage。
Iterator<IIOImage> | ImageReader.readAll(Iterator<? extends ImageReadParam> params) 以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。
RenderedImage | ImageReader.readAsRenderedImage(int imageIndex, ImageReadParam param) 返回一个 RenderedImage 对象，该对象包含通过索引 imageIndex 指定的图像的内容。
Raster | ImageReader.readRaster(int imageIndex, ImageReadParam param) 返回包含图像流中原始像素数据的新 Raster 对象，不应用任何颜色转换。
BufferedImage | ImageReader.readThumbnail(int imageIndex, int thumbnailIndex) 以 BufferedImage 形式返回通过索引 thumbnailIndex 指定的缩略图预览图像，其与通过索引 ImageIndex 指定的图像关联。
BufferedImage | ImageReader.readTile(int imageIndex, int tileX, int tileY) 读取由 tileX 和 tileY 参数指示的 tile，并以 BufferedImage 形式返回。
Raster | ImageReader.readTileRaster(int imageIndex, int tileX, int tileY) 返回包含 tile 中的原始像素数据的新 Raster 对象，不应用任何颜色转换。
void | ImageWriter.removeImage(int imageIndex) 从流中移除图像。
void | ImageWriter.replaceImageMetadata(int imageIndex, IIOMetadata imageMetadata) 替换与现有图像有关的图像元数据。
void | ImageWriter.replacePixels(Raster raster, ImageWriteParam param) 用给定 Raster 部分替换已出现在输出中的图像部分。
void | ImageWriter.replacePixels(RenderedImage image, ImageWriteParam param) 用给定图像部分替换已出现在输出中的图像部分。
void | ImageWriter.replaceStreamMetadata(IIOMetadata streamMetadata) 使用新信息替换输出中的流元数据。
void | ImageWriter.write(IIOImage image) 将包含带有默认元数据和缩略图的单个图像的完整图像流添加到输出中。
abstract void | ImageWriter.write(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param) 添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。
void | ImageWriter.write(RenderedImage image) 将由带有默认元数据和缩略图的单个图像组成的完整图像流添加到输出中。
static boolean | ImageIO.write(RenderedImage im, String formatName, File output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 File。
static boolean | ImageIO.write(RenderedImage im, String formatName, ImageOutputStream output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。
static boolean | ImageIO.write(RenderedImage im, String formatName, OutputStream output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。
void | ImageWriter.writeInsert(int imageIndex, IIOImage image, ImageWriteParam param) 将新的图像插入现有图像流。
void | ImageWriter.writeToSequence(IIOImage image, ImageWriteParam param) 将单幅图像、可能相关的元数据和缩略图添加到输出中。

javax.imageio.metadata 中 IOException 的使用

javax.imageio.metadata 中 IOException 的子类
 class IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

javax.imageio.spi 中 IOException 的使用

抛出 IOException 的 javax.imageio.spi 中的方法
abstract boolean | ImageReaderSpi.canDecodeInput(Object source) 如果给定的源对象看起来是此 reader 支持的格式，则返回 true。
ImageInputStream | ImageInputStreamSpi.createInputStreamInstance(Object input) 返回与此服务提供者关联的 ImageInputStream 实现的实例。
abstract ImageInputStream | ImageInputStreamSpi.createInputStreamInstance(Object input, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageInputStream 实现的实例。
ImageOutputStream | ImageOutputStreamSpi.createOutputStreamInstance(Object output) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。
abstract ImageOutputStream | ImageOutputStreamSpi.createOutputStreamInstance(Object output, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。
ImageReader | ImageReaderSpi.createReaderInstance() 返回与此服务提供者关联的 ImageReader 实现的实例。
abstract ImageReader | ImageReaderSpi.createReaderInstance(Object extension) 返回与此服务提供者关联的 ImageReader 实现的实例。
ImageWriter | ImageWriterSpi.createWriterInstance() 返回与此服务提供者关联的 ImageWriter 实现的实例。
abstract ImageWriter | ImageWriterSpi.createWriterInstance(Object extension) 返回与此服务提供者关联的 ImageWriter 实现的实例。

javax.imageio.stream 中 IOException 的使用

抛出 IOException 的 javax.imageio.stream 中的方法
protected  void ImageInputStreamImpl.checkClosed()
如果已经关闭流，则抛出 IOException。
 void FileCacheImageInputStream.close()
关闭此 FileCacheImageInputStream，关闭并移除缓存文件。
 void FileCacheImageOutputStream.close()
关闭此 FileCacheImageOututStream。
 void FileImageInputStream.close()
 void FileImageOutputStream.close()
 void ImageInputStream.close()
关闭流。
 void ImageInputStreamImpl.close()
 void MemoryCacheImageInputStream.close()
关闭此 MemoryCacheImageInputStream，释放缓存。
 void MemoryCacheImageOutputStream.close()
关闭此 MemoryCacheImageOutputStream。
 void ImageInputStream.flush()
丢弃当前流位置之前的流初始部分。
 void ImageInputStreamImpl.flush()
 void FileCacheImageOutputStream.flushBefore(long pos)
 void ImageInputStream.flushBefore(long pos)
丢弃所指示位置之前的流初始部分。
 void ImageInputStreamImpl.flushBefore(long pos)
 void ImageOutputStream.flushBefore(long pos)
刷新给定位置之前所有数据的缓冲并转到底层目标（如 OutputStream 或 File）。
 void MemoryCacheImageInputStream.flushBefore(long pos)
 void MemoryCacheImageOutputStream.flushBefore(long pos)
protected  void ImageOutputStreamImpl.flushBits()
如果位偏移量为非零，则将当前字节中的剩余位强制归 0，并将流位置前移一个字节。
 int ImageInputStream.getBitOffset()
以整数的形式返回当前位偏移量，该整数在 0 到 7 之间（包含两者）。
 int ImageInputStreamImpl.getBitOffset()
 long ImageInputStream.getStreamPosition()
返回流的当前字节位置。
 long ImageInputStreamImpl.getStreamPosition()
 long ImageInputStream.length()
返回流的总长度（如果已知）。
 int FileCacheImageInputStream.read()
 int FileCacheImageOutputStream.read()
 int FileImageInputStream.read()
 int FileImageOutputStream.read()
 int ImageInputStream.read()
从流中读取单个字节，并以整数（0 到 255 之间）形式返回该字节。
abstract  int ImageInputStreamImpl.read()
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
 int MemoryCacheImageInputStream.read()
 int MemoryCacheImageOutputStream.read()
 int ImageInputStream.read(byte[] b)
从流中读取至多 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
 int ImageInputStreamImpl.read(byte[] b)
调用 read(b, 0, b.length) 的便捷方法。
 int FileCacheImageInputStream.read(byte[] b, int off, int len)
 int FileCacheImageOutputStream.read(byte[] b, int off, int len)
 int FileImageInputStream.read(byte[] b, int off, int len)
 int FileImageOutputStream.read(byte[] b, int off, int len)
 int ImageInputStream.read(byte[] b, int off, int len)
从流中读取至多 len 个字节，并将其存储到 b 中（从索引 off 开始）。
abstract  int ImageInputStreamImpl.read(byte[] b, int off, int len)
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
 int MemoryCacheImageInputStream.read(byte[] b, int off, int len)
 int MemoryCacheImageOutputStream.read(byte[] b, int off, int len)
 int ImageInputStream.readBit()
从流中读取单个字节，并以 int（0 或 1）的形式返回该字节。
 int ImageInputStreamImpl.readBit()
 long ImageInputStream.readBits(int numBits)
从流中读取位串 (bitstring) 并以 long 的形式返回，使第一个读取的位成为输出的最高有效位。
 long ImageInputStreamImpl.readBits(int numBits)
 boolean ImageInputStream.readBoolean()
从流中读取一个字节，如果其不为 0，则返回 boolean 值 true；如果为 0，则返回 false。
 boolean ImageInputStreamImpl.readBoolean()
 byte ImageInputStream.readByte()
从流中读取一个字节，并以 byte 值的形式返回该字节。
 byte ImageInputStreamImpl.readByte()
 void ImageInputStream.readBytes(IIOByteBuffer buf, int len)
从流中读取至多 len 个字节，并修改提供的 IIOByteBuffer 以指示可以找到数据的 byte 数组、偏移量和长度。
 void ImageInputStreamImpl.readBytes(IIOByteBuffer buf, int len)
 char ImageInputStream.readChar()
与 readUnsignedShort 等效，唯一的不同在于它的结果使用 char 数据类型返回。
 char ImageInputStreamImpl.readChar()
 double ImageInputStream.readDouble()
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 double 值的形式返回结果。
 double ImageInputStreamImpl.readDouble()
 float ImageInputStream.readFloat()
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 float 值的形式返回结果。
 float ImageInputStreamImpl.readFloat()
 void ImageInputStream.readFully(byte[] b)
从流中读取 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
 void ImageInputStreamImpl.readFully(byte[] b)
 void ImageInputStream.readFully(byte[] b, int off, int len)
从流中读取 len 个字节，并将其存储到 b 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(byte[] b, int off, int len)
 void ImageInputStream.readFully(char[] c, int off, int len)
根据当前字节顺序从流中读取 len 个 char（无符号 16 位整数），并将其存储到 c 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(char[] c, int off, int len)
 void ImageInputStream.readFully(double[] d, int off, int len)
根据当前字节顺序从流中读取 len 个 double（64 位 IEEE 双精度浮点值），并将其存储到 d 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(double[] d, int off, int len)
 void ImageInputStream.readFully(float[] f, int off, int len)
根据当前字节顺序从流中读取 len 个 float（32 位 IEEE 单精度浮点值），并将其存储到 f 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(float[] f, int off, int len)
 void ImageInputStream.readFully(int[] i, int off, int len)
根据当前字节顺序从流中读取 len 个 int（有符号 32 位整数），并将其存储到 i 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(int[] i, int off, int len)
 void ImageInputStream.readFully(long[] l, int off, int len)
根据当前字节顺序从流中读取 len 个 long（有符号 64 位整数），并将其存储到 l 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(long[] l, int off, int len)
 void ImageInputStream.readFully(short[] s, int off, int len)
根据当前字节顺序从流中读取 len 个 short（有符号 16 位整数），并将其存储到 s 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(short[] s, int off, int len)
 int ImageInputStream.readInt()
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 int 值的形式返回结果。
 int ImageInputStreamImpl.readInt()
 String ImageInputStream.readLine()
从输入流中读取文本的下一行。
 String ImageInputStreamImpl.readLine()
 long ImageInputStream.readLong()
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 long 值的形式返回结果。
 long ImageInputStreamImpl.readLong()
 short ImageInputStream.readShort()
从流中读取两个字节，根据当前字节顺序将其连接（概念上），然后以 short 值的形式返回结果。
 short ImageInputStreamImpl.readShort()
 int ImageInputStream.readUnsignedByte()
从流中读取一个字节，将其转换为 int（概念上），使用 0xff 屏蔽以便去掉所有符号扩展位，然后以 byte 值的形式返回。
 int ImageInputStreamImpl.readUnsignedByte()
 long ImageInputStream.readUnsignedInt()
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 long，使用 0xffffffffL 屏蔽以便去掉所有符号扩展位，然后以无符号 long 值的形式返回结果。
 long ImageInputStreamImpl.readUnsignedInt()
 int ImageInputStream.readUnsignedShort()
从流中读取两个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 int，使用 0xffff 屏蔽以便去掉所有符号扩展位，然后以无符号 int 值的形式返回结果。
 int ImageInputStreamImpl.readUnsignedShort()
 String ImageInputStream.readUTF()
读入一个已使用 UTF-8 修改版格式编码的字符串。
 String ImageInputStreamImpl.readUTF()
 void ImageInputStream.reset()
返回在最近一次非匹配地调用 mark 时指向上一个位置（包括位偏移量）的流指针。
 void ImageInputStreamImpl.reset()
根据标记的堆栈重置当前流字节和位位置。
 void FileCacheImageOutputStream.seek(long pos)
设置当前流位置并将位偏移量重置为 0。
 void FileImageInputStream.seek(long pos)
 void FileImageOutputStream.seek(long pos)
设置当前流位置并将位偏移量重置为 0。
 void ImageInputStream.seek(long pos)
将当前流位置设置为所需的位置。
 void ImageInputStreamImpl.seek(long pos)
 void ImageInputStream.setBitOffset(int bitOffset)
将位偏移量设置为 0 到 7 之间（包含两者）的整数。
 void ImageInputStreamImpl.setBitOffset(int bitOffset)
 int ImageInputStream.skipBytes(int n)
将流位置向前移动给定的字节数。
 int ImageInputStreamImpl.skipBytes(int n)
通过调用 seek(getStreamPosition() + n) 推进当前流位置。
 long ImageInputStream.skipBytes(long n)
将流位置向前移动给定的字节数。
 long ImageInputStreamImpl.skipBytes(long n)
通过调用 seek(getStreamPosition() + n) 推进当前流位置。
 void ImageOutputStream.write(byte[] b)
将字节序列写入到流中的当前位置。
 void ImageOutputStreamImpl.write(byte[] b)
 void FileCacheImageOutputStream.write(byte[] b, int off, int len)
 void FileImageOutputStream.write(byte[] b, int off, int len)
 void ImageOutputStream.write(byte[] b, int off, int len)
将字节序列写入到流中的当前位置。
abstract  void ImageOutputStreamImpl.write(byte[] b, int off, int len)
 void MemoryCacheImageOutputStream.write(byte[] b, int off, int len)
 void FileCacheImageOutputStream.write(int b)
 void FileImageOutputStream.write(int b)
 void ImageOutputStream.write(int b)
将单个字节写入到流中的当前位置。
abstract  void ImageOutputStreamImpl.write(int b)
 void MemoryCacheImageOutputStream.write(int b)
 void ImageOutputStream.writeBit(int bit)
将单个位（由参数的最低有效位给定）写入到流的当前字节位置中的当前位偏移量。
 void ImageOutputStreamImpl.writeBit(int bit)
 void ImageOutputStream.writeBits(long bits, int numBits)
将一个位序列（由 bits 参数的 numBits 个最低有效位按从左到右的顺序给定）写入到流的当前字节位置中的当前位偏移量。
 void ImageOutputStreamImpl.writeBits(long bits, int numBits)
 void ImageOutputStream.writeBoolean(boolean v)
将一个 boolean 值写入到流中。
 void ImageOutputStreamImpl.writeBoolean(boolean v)
 void ImageOutputStream.writeByte(int v)
将 v 的 8 个低位写入到流中。
 void ImageOutputStreamImpl.writeByte(int v)
 void ImageOutputStream.writeBytes(String s)
将一个字符串写入输出流。
 void ImageOutputStreamImpl.writeBytes(String s)
 void ImageOutputStream.writeChar(int v)
此方法与 writeShort 同义。
 void ImageOutputStreamImpl.writeChar(int v)
 void ImageOutputStream.writeChars(char[] c, int off, int len)
将 char 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeChars(char[] c, int off, int len)
 void ImageOutputStream.writeChars(String s)
将一个字符串写入输出流。
 void ImageOutputStreamImpl.writeChars(String s)
 void ImageOutputStream.writeDouble(double v)
将一个 double 值写入输出流，该值由四个字节组成。
 void ImageOutputStreamImpl.writeDouble(double v)
 void ImageOutputStream.writeDoubles(double[] d, int off, int len)
将 double 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeDoubles(double[] d, int off, int len)
 void ImageOutputStream.writeFloat(float v)
将一个 float 值（由四个字节组成）写入输出流。
 void ImageOutputStreamImpl.writeFloat(float v)
 void ImageOutputStream.writeFloats(float[] f, int off, int len)
将 float 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeFloats(float[] f, int off, int len)
 void ImageOutputStream.writeInt(int v)
将 v 的 32 个位写入到流中。
 void ImageOutputStreamImpl.writeInt(int v)
 void ImageOutputStream.writeInts(int[] i, int off, int len)
将 int 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeInts(int[] i, int off, int len)
 void ImageOutputStream.writeLong(long v)
将 v 的 64 个位写入到流中。
 void ImageOutputStreamImpl.writeLong(long v)
 void ImageOutputStream.writeLongs(long[] l, int off, int len)
将 long 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeLongs(long[] l, int off, int len)
 void ImageOutputStream.writeShort(int v)
将 v 的 16 个低位写入到流中。
 void ImageOutputStreamImpl.writeShort(int v)
 void ImageOutputStream.writeShorts(short[] s, int off, int len)
将 short 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeShorts(short[] s, int off, int len)
 void ImageOutputStream.writeUTF(String s)
将表示长度信息的两个字节按网络字节顺序写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。
 void ImageOutputStreamImpl.writeUTF(String s)

抛出 IOException 的 javax.imageio.stream 中的构造方法
FileCacheImageInputStream(InputStream stream, File cacheDir)
构造一个将从给定 InputStream 进行读取的 FileCacheImageInputStream。
FileCacheImageOutputStream(OutputStream stream, File cacheDir)
构造一个将向给定 outputStream 进行写入的 FileCacheImageOutputStream。
FileImageInputStream(File f)
构造一个将从给定 File 进行读取的 FileImageInputStream。
FileImageOutputStream(File f)
构造一个将向给定 File 进行写入的 FileImageOutputStream。

javax.management 中 IOException 的使用

抛出 IOException 的 javax.management 中的方法
void | MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
void | MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
Object | MBeanServerConnection.getAttribute(ObjectName name, String attribute) 获得指定 MBean 的特定属性值。
AttributeList | MBeanServerConnection.getAttributes(ObjectName name, String[] attributes) 获得指定 MBean 的多个属性值。
String | MBeanServerConnection.getDefaultDomain() 返回对 MBean 命名时使用的默认域。
String[] | MBeanServerConnection.getDomains() 返回其中所有 MBean 当前已注册的域的列表。
Integer | MBeanServerConnection.getMBeanCount() 返回 MBean 服务器中已注册的 MBean 数目。
MBeanInfo | MBeanServerConnection.getMBeanInfo(ObjectName name) 此方法发现了 MBean 为管理而公开的属性和操作。
ObjectInstance | MBeanServerConnection.getObjectInstance(ObjectName name) 获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
Object | MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature) 在 MBean 上调用某个操作。
boolean | MBeanServerConnection.isInstanceOf(ObjectName name, String className) 如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。
boolean | MBeanServerConnection.isRegistered(ObjectName name) 检查某个 MBean（通过其对象名标识）是否已向 MBean 服务器注册。
Set<ObjectInstance> | MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean。
Set<ObjectName> | MBeanServerConnection.queryNames(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean 的名称。
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。
AttributeList | MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes) 设置指定 MBean 的多个属性值。
void | MBeanServerConnection.unregisterMBean(ObjectName name) 从 MBean 服务器中注销一个 MBean。

javax.management.loading 中 IOException 的使用

抛出 IOException 的 javax.management.loading 中的方法
Enumeration<URL> | MLetMBean.getResources(String name) 查找所有具有给定名称的资源。
void | MLet.readExternal(ObjectInput in) 从给定的 ObjectInput 恢复此 MLet 的内容。
void | MLet.writeExternal(ObjectOutput out) 将此 MLet 的内容保存到给定的 ObjectOutput。

javax.management.remote 中 IOException 的使用

javax.management.remote 中 IOException 的子类
class | JMXProviderException 当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
class | JMXServerErrorException 在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。

抛出 IOException 的 javax.management.remote 中的方法
void | JMXConnector.close() 关闭客户端到其服务器的连接。
void | JMXConnector.connect() 建立到连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment) 创建到位于给定地址的连接器服务器的连接。
void | JMXConnector.connect(Map<String,?> env) 建立到连接器服务器的连接。
String | JMXConnector.getConnectionId() 获得来自连接器服务器的连接 ID。
MBeanServerConnection | JMXConnector.getMBeanServerConnection() 返回一个代表远程 MBean 服务器的 MBeanServerConnection 对象。
MBeanServerConnection | JMXConnector.getMBeanServerConnection(Subject delegationSubject) 返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。
static JMXConnector | JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 为位于给定地址的连接器服务器创建一个连接器客户端。
JMXConnector | JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。
static JMXConnectorServer | JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的连接器服务器。
JMXConnectorServer | JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的新连接器服务器。
void | JMXConnectorServerMBean.start() 激活连接器服务器，即开始侦听客户端连接。
void | JMXConnectorServerMBean.stop() 取消激活连接器服务器，即停止对客户端连接的侦听。
JMXConnector | JMXConnectorServer.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。
JMXConnector | JMXConnectorServerMBean.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。

javax.management.remote.rmi 中 IOException 的使用

抛出 IOException 的 javax.management.remote.rmi 中的方法
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
protected  void RMIServerImpl.clientClosed(RMIConnection client)
关闭由 makeClient 创建的客户端连接时调用的方法。
 void RMIConnection.close()
关闭此连接。
 void RMIConnectionImpl.close()
 void RMIConnectionImpl_Stub.close()
 void RMIConnector.close()
 void RMIServerImpl.close()
关闭此连接服务器。
protected  void RMIIIOPServerImpl.closeClient(RMIConnection client)
protected  void RMIJRMPServerImpl.closeClient(RMIConnection client)
protected abstract  void RMIServerImpl.closeClient(RMIConnection client)
关闭由 makeClient 建立的客户端连接。
protected  void RMIIIOPServerImpl.closeServer()
由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。
protected  void RMIJRMPServerImpl.closeServer()
由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。
protected abstract  void RMIServerImpl.closeServer()
由 RMIServerImpl.close() 调用以关闭连接器服务器。
 void RMIConnector.connect()
 void RMIConnector.connect(Map<String,?> environment)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
protected  void RMIIIOPServerImpl.export()
protected  void RMIJRMPServerImpl.export()
protected abstract  void RMIServerImpl.export()
导出此 RMI 对象。
 NotificationResult RMIConnection.fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
检索来自连接器服务器的通知。
 NotificationResult RMIConnectionImpl.fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
 NotificationResult RMIConnectionImpl_Stub.fetchNotifications(long $param_long_1, int $param_int_2, long $param_long_3)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 String RMIConnection.getConnectionId()
返回连接 ID。
 String RMIConnectionImpl.getConnectionId()
 String RMIConnectionImpl_Stub.getConnectionId()
 String RMIConnector.getConnectionId()
 String RMIConnection.getDefaultDomain(Subject delegationSubject)
处理 MBeanServerConnection.getDefaultDomain() 方法。
 String RMIConnectionImpl.getDefaultDomain(Subject delegationSubject)
 String RMIConnectionImpl_Stub.getDefaultDomain(Subject $param_Subject_1)
 String[] RMIConnection.getDomains(Subject delegationSubject)
处理 MBeanServerConnection.getDomains() 方法。
 String[] RMIConnectionImpl.getDomains(Subject delegationSubject)
 String[] RMIConnectionImpl_Stub.getDomains(Subject $param_Subject_1)
 Integer RMIConnection.getMBeanCount(Subject delegationSubject)
处理 MBeanServerConnection.getMBeanCount() 方法。
 Integer RMIConnectionImpl.getMBeanCount(Subject delegationSubject)
 Integer RMIConnectionImpl_Stub.getMBeanCount(Subject $param_Subject_1)
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 MBeanServerConnection RMIConnector.getMBeanServerConnection()
 MBeanServerConnection RMIConnector.getMBeanServerConnection(Subject delegationSubject)
 ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 boolean RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 boolean RMIConnection.isRegistered(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
 boolean RMIConnectionImpl.isRegistered(ObjectName name, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isRegistered(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
protected  RMIConnection RMIIIOPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。
protected  RMIConnection RMIJRMPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。
protected abstract  RMIConnection RMIServerImpl.makeClient(String connectionId, Subject subject)
创建一个新的客户端连接。
 RMIConnection RMIServer.newClient(Object credentials)
建立一个使用该 RMI 连接器的新连接。
 RMIConnection RMIServerImpl.newClient(Object credentials)
创建一个新的客户端连接。
 RMIConnection RMIServerImpl_Stub.newClient(Object $param_Object_1)
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnectorServer.start()
激活连接器服务器，即启动对客户端连接的侦听。
 void RMIConnectorServer.stop()
取消激活连接器服务器，即停止对客户端连接的侦听。
 JMXConnector RMIConnectorServer.toJMXConnector(Map<String,?> env)
返回此连接器服务器的客户端 stub。
 Remote RMIIIOPServerImpl.toStub()
返回一个 IIOP stub。
 Remote RMIJRMPServerImpl.toStub()
返回此 RMIServer 对象的可序列化的 stub。
abstract  Remote RMIServerImpl.toStub()
返回此服务器对象的可远程化的 stub。
 void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
 void RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
 void RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

抛出 IOException 的 javax.management.remote.rmi 中的构造方法
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
建立 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIIIOPServerImpl(Map<String,?> env)
创建新的 RMIServerImpl。
RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。

javax.naming.ldap 中 IOException 的使用

抛出 IOException 的 javax.naming.ldap 中的方法
abstract void | StartTlsResponse.close() 妥善地关闭 TLS 连接并转换回底层连接。
abstract SSLSession | StartTlsResponse.negotiate() 使用默认的 SSL 套接字工厂协商 TLS 会话。
abstract SSLSession | StartTlsResponse.negotiate(SSLSocketFactory factory) 使用 SSL 套接字工厂协商 TLS 会话。

抛出 IOException 的 javax.naming.ldap 中的构造方法
PagedResultsControl(int pageSize, boolean criticality)
构造一个控件来设置要在每页结果中返回的项数。
PagedResultsControl(int pageSize, byte[] cookie, boolean criticality)
构造一个控件来设置要在每页结果中返回的项数。
PagedResultsResponseControl(String id, boolean criticality, byte[] value)
构造分页结果响应控件。
SortControl(SortKey[] sortBy, boolean criticality)
构造一个控件来对排序键列表进行排序。
SortControl(String[] sortBy, boolean criticality)
构造一个控件来按升序对属性列表进行排序。
SortControl(String sortBy, boolean criticality)
构造一个控件来按升序对单个属性进行排序。
SortResponseControl(String id, boolean criticality, byte[] value)
构造一个控件来指示排序请求的结果。

javax.net 中 IOException 的使用

抛出 IOException 的 javax.net 中的方法
ServerSocket | ServerSocketFactory.createServerSocket() 返回未绑定的服务器套接字。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port) 返回绑定到指定端口的服务器套接字。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port, int backlog) 返回绑定到指定端口的服务器套接字，并且使用指定的连接 backlog。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port, int backlog, InetAddress ifAddress) 返回绑定到指定端口的服务器套接字，该套接字带有指定的侦听 backlog 和本地 IP。
Socket | SocketFactory.createSocket() 创建一个未连接的套接字。
abstract Socket | SocketFactory.createSocket(InetAddress host, int port) 创建一个套接字并把它连接到指定地址上的指定端口号。
abstract Socket | SocketFactory.createSocket(InetAddress address, int port, InetAddress localAddress, int localPort) 创建一个套接字并把它连接到指定远程端口上的指定远程地址。
abstract Socket | SocketFactory.createSocket(String host, int port) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。
abstract Socket | SocketFactory.createSocket(String host, int port, InetAddress localHost, int localPort) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。

javax.net.ssl 中 IOException 的使用

javax.net.ssl 中 IOException 的子类
class | SSLException 指示由 SSL 子系统检测到的某类错误。
class | SSLHandshakeException 指示客户端和服务器不能就所需安全级别进行协商。
class | SSLKeyException 报告错误的 SSL 密钥。
class | SSLPeerUnverifiedException 指示还没有验证同位体的身份。
class | SSLProtocolException 报告在 SSL 协议的操作中的错误。

抛出 IOException 的 javax.net.ssl 中的方法
abstract Socket | SSLSocketFactory.createSocket(Socket s, String host, int port, boolean autoClose) 返回在连接到指定主机的给定端口的现有套接字上分层的套接字。
abstract void | SSLSocket.startHandshake() 在此连接上开始 SSL 握手。

抛出 IOException 的 javax.net.ssl 中的构造方法
SSLServerSocket()
仅供子类使用。
SSLServerSocket(int port)
仅供子类使用。
SSLServerSocket(int port, int backlog)
仅供子类使用。
SSLServerSocket(int port, int backlog, InetAddress address)
仅供子类使用。
SSLSocket(InetAddress address, int port)
仅供子类使用。
SSLSocket(InetAddress address, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。
SSLSocket(String host, int port)
仅供子类使用。
SSLSocket(String host, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。

javax.print 中 IOException 的使用

抛出 IOException 的 javax.print 中的方法
Doc | MultiDoc.getDoc() 获取当前的 doc 对象。
Object | Doc.getPrintData() 获得打印数据表示形式对象，该对象包含此 doc 对象的部分打印数据，其格式对应于受支持的 DocFlavor。
Object | SimpleDoc.getPrintData()
Reader | Doc.getReaderForText() 获得一个从此 doc 中提取字符打印数据的 reader。
Reader | SimpleDoc.getReaderForText() 获得一个从此 doc 中提取字符打印数据的 reader。
InputStream | Doc.getStreamForBytes() 获得一个从此 doc 中提取 byte 打印数据的输入流。
InputStream | SimpleDoc.getStreamForBytes() 获得一个从此 doc 中提取 byte 打印数据的输入流。
MultiDoc | MultiDoc.next() 转到包含 doc 对象序列中下一个 doc 对象的 multidoc 对象。

javax.rmi.CORBA 中 IOException 的使用

抛出 IOException 的 javax.rmi.CORBA 中的方法
 void StubDelegate.readObject(Stub self, ObjectInputStream s)
Stub.readObject(java.io.ObjectInputStream) 的委托调用。
 void StubDelegate.writeObject(Stub self, ObjectOutputStream s)
Stub.writeObject(java.io.ObjectOutputStream) 的委托调用。

javax.rmi.ssl 中 IOException 的使用

抛出 IOException 的 javax.rmi.ssl 中的方法
ServerSocket | SslRMIServerSocketFactory.createServerSocket(int port) 创建一个服务器套接字，该套接字接受根据此工厂的 SSL 套接字配置参数配置的 SSL 连接。
Socket | SslRMIClientSocketFactory.createSocket(String host, int port) 创建一个 SSL 套接字。

javax.security.auth.callback 中 IOException 的使用

抛出 IOException 的 javax.security.auth.callback 中的方法
 void CallbackHandler.handle(Callback[] callbacks)
获取或显示在提供的 Callback 中请求的信息。

javax.security.sasl 中 IOException 的使用

javax.security.sasl 中 IOException 的子类
class | AuthenticationException 此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。
class | SaslException 此类表示在使用 SASL 时所发生的错误。

javax.sound.midi 中 IOException 的使用

抛出 IOException 的 javax.sound.midi 中的方法
static MidiFileFormat | MidiSystem.getMidiFileFormat(File file) 获得指定 File 的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(InputStream stream) 获得指定的输入流中数据的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(URL url) 获得指定 URL 中数据的 MIDI 文件格式。
static Sequence | MidiSystem.getSequence(File file) 从指定的 File 获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(InputStream stream) 从指定的输入流获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(URL url) 从指定的 URL 获得 MIDI 序列。
static Soundbank | MidiSystem.getSoundbank(File file) 通过从指定的 File 读取来构造一个 Soundbank。
static Soundbank | MidiSystem.getSoundbank(InputStream stream) 通过从指定的流读取来构造一个 MIDI 音库。
static Soundbank | MidiSystem.getSoundbank(URL url) 通过从指定的 URL 处读取来构造一个 Soundbank。
void | Sequencer.setSequence(InputStream stream) 设置 sequencer 所操作的当前 sequence。
static int | MidiSystem.write(Sequence in, int type, File out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的外部文件。
static int | MidiSystem.write(Sequence in, int fileType, OutputStream out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的输出流。

javax.sound.midi.spi 中 IOException 的使用

抛出 IOException 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(File file) 获得提供的 File 的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(InputStream stream) 获得所提供的输入流的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(URL url) 获得提供的 URL 的 MIDI 文件格式。
abstract Sequence | MidiFileReader.getSequence(File file) 从提供的 File 获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(InputStream stream) 从提供的输入流获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(URL url) 从提供的 URL 获得 MIDI 序列。
abstract Soundbank | SoundbankReader.getSoundbank(File file) 从提供的 File 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(InputStream stream) 从提供的 InputStream 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(URL url) 从提供的 URL 获得音库对象。
abstract int | MidiFileWriter.write(Sequence in, int fileType, File out) 写入表示指示为所提供外部文件的文件类型的 MIDI 文件的字节流。
abstract int | MidiFileWriter.write(Sequence in, int fileType, OutputStream out) 写入表示指示为所提供输出流的文件类型的 MIDI 文件的字节流。

javax.sound.sampled 中 IOException 的使用

抛出 IOException 的 javax.sound.sampled 中的方法
int | AudioInputStream.available() 返回可不受阻塞地从此音频输入流中读取（或跳过）的最大字节数。
void | AudioInputStream.close() 关闭此音频输入流并释放与该流关联的所有系统资源。
static AudioFileFormat | AudioSystem.getAudioFileFormat(File file) 获得指定 File 的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(InputStream stream) 获得提供的音频输入流的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(URL url) 获得指定 URL 的音频文件格式。
static AudioInputStream | AudioSystem.getAudioInputStream(File file) 从提供的 File 获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(InputStream stream) 从提供的输入流获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(URL url) 从提供的 URL 获得音频输入流。
void | Clip.open(AudioInputStream stream) 使用出现在所提供的音频输入流中的格式和音频数据打开剪辑。
int | AudioInputStream.read() 从音频输入流读取数据下一个字节。
int | AudioInputStream.read(byte[] b) 从音频输入流读取一定数量的字节，并将其存储在缓冲区数组 b 中。
int | AudioInputStream.read(byte[] b, int off, int len) 从音频流读取指定的最大数量的数据字节，并将其放入给定的字节数组中。
void | AudioInputStream.reset() 将此音频输入流重新定位到上一次调用其 mark 方法时的位置。
long | AudioInputStream.skip(long n) 跳过并丢弃此音频输入流中指定数量的字节。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示指定文件类型的音频文件的字节流写入所提供的外部文件。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示指定文件类型的音频文件的字节流写入所提供的输出流。

javax.sound.sampled.spi 中 IOException 的使用

抛出 IOException 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(File file) 获得所提供 File 的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(InputStream stream) 获得所提供输入流的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(URL url) 获得所提供 URL 的音频文件格式。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(File file) 从所提供的 File 获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(InputStream stream) 从所提供的输入流中获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(URL url) 从所提供的 URL 获得音频输入流。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示所指示文件类型的音频文件的字节流写入所提供的输出流。

javax.sql.rowset 中 IOException 的使用

抛出 IOException 的 javax.sql.rowset 中的方法
void | WebRowSet.readXml(InputStream iStream) 读取基于流的 XML 输入，以填充此 WebRowSet 对象。
void | WebRowSet.writeXml(OutputStream oStream) 以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 OutputStream 对象。
void | WebRowSet.writeXml(ResultSet rs, OutputStream oStream) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。

javax.swing 中 IOException 的使用

抛出 IOException 的 javax.swing 中的方法
void | ProgressMonitorInputStream.close() 重写 FilterInputStream.close，以便关闭进度监视器以及流。
protected InputStream | JEditorPane.getStream(URL page) 获取给定 URL 的流，该 URL 是将要由 setPage 方法加载的。
int | ProgressMonitorInputStream.read() 重写 FilterInputStream.read，以便在读取之后更新进度监视器。
int | ProgressMonitorInputStream.read(byte[] b) 重写 FilterInputStream.read，以读取之后更新进度监视器。
int | ProgressMonitorInputStream.read(byte[] b, int off, int len) 重写 FilterInputStream.read，以便在读取之后更新进度监视器。
void | JEditorPane.read(InputStream in, Object desc) 此方法根据流进行初始化。
void | ProgressMonitorInputStream.reset() 重写 FilterInputStream.reset，以重置进度监视器以及流。
void | JEditorPane.setPage(String url) 设置当前要显示的 URL。
void | JEditorPane.setPage(URL page) 设置当前要显示的 URL。
long | ProgressMonitorInputStream.skip(long n) 重写 FilterInputStream.skip，以便在跳过之后更新进度监视器。

抛出 IOException 的 javax.swing 中的构造方法
JEditorPane(String url)
根据包含 URL 规范的字符串创建一个 JEditorPane。
JEditorPane(URL initialPage)
根据用作输入的指定 URL 创建一个 JEditorPane。

javax.swing.filechooser 中 IOException 的使用

抛出 IOException 的 javax.swing.filechooser 中的方法
abstract  File FileSystemView.createNewFolder(File containingDir)
创建具有默认文件夹名称的新文件夹。

javax.swing.plaf.synth 中 IOException 的使用

抛出 IOException 的 javax.swing.plaf.synth 中的方法
 void SynthLookAndFeel.load(URL url)
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。

javax.swing.text 中 IOException 的使用

javax.swing.text 中 IOException 的子类
 class ChangedCharSetException
顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。

抛出 IOException 的 javax.swing.text 中的方法
protected void | AbstractWriter.indent() 执行缩进。
protected void | AbstractWriter.output(char[] content, int start, int length) 写出内容过程的最后一步。
void | DefaultEditorKit.read(InputStream in, Document doc, int pos) 插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
abstract void | EditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
void | DefaultEditorKit.read(Reader in, Document doc, int pos) 插入取自给定流的内容，它将被视为纯文本。
abstract void | EditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
void | JTextComponent.read(Reader in, Object desc) 根据流进行初始化。
void | StyleContext.readAttributes(ObjectInputStream in, MutableAttributeSet a) 读入属性的特定于上下文的处理。
static void | StyleContext.readAttributeSet(ObjectInputStream in, MutableAttributeSet a) 从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。
protected void | AbstractWriter.text(Element elem) 写出文本。
protected abstract void | AbstractWriter.write() 需要由子类实现此抽象方法。
protected void | AbstractWriter.write(char ch) 写出字符。
protected void | AbstractWriter.write(char[] chars, int startIndex, int length) 所有 write 方法都调用到此方法。
void | DefaultEditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
abstract void | EditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
protected void | AbstractWriter.write(String content) 写出字符串。
void | JTextComponent.write(Writer out) 将模型的内容存储到给定的流中。
void | DefaultEditorKit.write(Writer out, Document doc, int pos, int len) 将取自文档的内容以纯文本格式写入给定流。
abstract void | EditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
protected void | AbstractWriter.writeAttributes(AttributeSet attr) 以 " =" 对的形式写出属性集。
void | StyleContext.writeAttributes(ObjectOutputStream out, AttributeSet a) 写出属性的特定于上下文的处理。
static void | StyleContext.writeAttributeSet(ObjectOutputStream out, AttributeSet a) 将属性集写入到给定的对象流以便序列化。
protected void | AbstractWriter.writeLineSeparator() 写入行分隔符。

javax.swing.text.html 中 IOException 的使用

抛出 IOException 的 javax.swing.text.html 中的方法
protected  void HTMLWriter.closeOutUnwantedEmbeddedTags(AttributeSet attr)
搜索属性集和存储在标记向量中的每个标记。
protected  void HTMLWriter.comment(Element elem)
写出注释。
protected  void HTMLWriter.emptyTag(Element elem)
写出所有空元素（没有对应结束标记的所有标记）。
protected  void MinimalHTMLWriter.endFontTag()
此方法已不再使用，而用写出 <span> 来替换。
protected  void HTMLWriter.endTag(Element elem)
写出元素的结束标记。
 void HTMLDocument.insertAfterEnd(Element elem, String htmlText)
将指定为字符串的 HTML 插入给定元素的起始处之后。
 void HTMLDocument.insertAfterStart(Element elem, String htmlText)
将指定为字符串的 HTML 插入元素的起始处。
 void HTMLDocument.insertBeforeEnd(Element elem, String htmlText)
将指定为字符串的 HTML 插入元素的结尾处。
 void HTMLDocument.insertBeforeStart(Element elem, String htmlText)
将指定为字符串的 HTML 插入给定元素的起始处之前。
 void HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
将 HTML 插入现有文档。
 void StyleSheet.loadRules(Reader in, URL ref)
加载 CSS1 语法中指定的规则集合。
protected  void HTMLWriter.output(char[] chars, int start, int length)
重写此方法来映射任何字符实体，例如 < 映射到 <。
abstract  void HTMLEditorKit.Parser.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
解析给定的流并通过解析的结果驱动给定的回调。
 void HTMLEditorKit.read(Reader in, Document doc, int pos)
插入来自给定流的内容。
protected  void HTMLWriter.selectContent(AttributeSet attr)
写出 SELECT 表单元素的内容。
 void HTMLDocument.setInnerHTML(Element elem, String htmlText)
用指定为 HTML 字符串的内容替换给定元素的子元素。
 void HTMLDocument.setOuterHTML(Element elem, String htmlText)
用指定为 HTML 字符串的内容替换父元素中的给定元素。
protected  void MinimalHTMLWriter.startFontTag(String style)
此方法已不再使用，而用写出 <span> 来替换。
protected  void HTMLWriter.startTag(Element elem)
写出元素的开始标记。
protected  void HTMLWriter.text(Element elem)
写出文本。
protected  void MinimalHTMLWriter.text(Element elem)
写出文本。
protected  void HTMLWriter.textAreaContent(AttributeSet attr)
写出 TEXTAREA 表单元素中所包含的文本。
 void HTMLWriter.write()
对 Element 树进行迭代并控制所有标记及其属性的写出。
 void MinimalHTMLWriter.write()
从 StyledDocument 生成 HTML 输出。
 void HTMLEditorKit.write(Writer out, Document doc, int pos, int len)
以适合此类内容处理程序的格式，将文档中的内容写入给定流。
protected  void HTMLWriter.writeAttributes(AttributeSet attr)
写出属性集。
protected  void MinimalHTMLWriter.writeAttributes(AttributeSet attr)
写出以下类型的所有属性：StyleConstants.ParagraphConstants、StyleConstants.CharacterConstants、StyleConstants.FontConstants、StyleConstants.ColorConstants。
protected  void MinimalHTMLWriter.writeBody()
对文档中的元素进行迭代，并基于元素是分支元素还是叶元素来处理它们。
protected  void MinimalHTMLWriter.writeComponent(Element elem)
负责处理 Component Elements；有意不实现它。
protected  void MinimalHTMLWriter.writeContent(Element elem, boolean needsIndenting)
以与 HTML 兼容的方式写出属性集。
protected  void HTMLWriter.writeEmbeddedTags(AttributeSet attr)
搜索 AttributeSet 中的嵌入式标记并写出它们。
protected  void MinimalHTMLWriter.writeEndParagraph()
发出 <p> 标记的结束标记。
protected  void MinimalHTMLWriter.writeEndTag(String endTag)
写出适当缩进的结束标记。
protected  void MinimalHTMLWriter.writeHeader()
写出 <head> 和 <style> 标记，然后调用 writeStyles()，以写出所有命名的样式，这些样式作为 <style> 标记的内容。
protected  void MinimalHTMLWriter.writeHTMLTags(AttributeSet attr)
基于文本的属性设置生成文本的 bold <b>、italic <i> 和 <u> 标记。
protected  void MinimalHTMLWriter.writeImage(Element elem)
负责处理 Icon Elements；有意不实现它。
protected  void MinimalHTMLWriter.writeLeaf(Element elem)
负责写出其他非文本叶元素。
protected  void HTMLWriter.writeLineSeparator()
写出行分隔符。
protected  void MinimalHTMLWriter.writeNonHTMLAttributes(AttributeSet attr)
以与 HTML 兼容的方式写出其余的字符级属性（bold、italic 和 underline 之外的属性）。
protected  void HTMLWriter.writeOption(Option option)
写出 Option 表单元素的内容。
protected  void MinimalHTMLWriter.writeStartParagraph(Element elem)
发出段落的开始标记。
protected  void MinimalHTMLWriter.writeStartTag(String tag)
写出适当缩进的开始标记。
protected  void MinimalHTMLWriter.writeStyles()
写出所有命名的样式，这些样式作为 <style> 标记的内容。

javax.swing.text.html.parser 中 IOException 的使用

抛出 IOException 的 javax.swing.text.html.parser 中的方法
static DTD | DTD.getDTD(String name) 返回具有指定 name 的 DTD。
void | Parser.parse(Reader in) 在给定 DTD 的情况下，解析 HTML 流。
void | DocumentParser.parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
void | ParserDelegator.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
String | Parser.parseDTDMarkup() 解析 Document Type Declaration 标记声明。
protected boolean | Parser.parseMarkupDeclarations(StringBuffer strBuff) 解析标记声明。
void | DTD.read(DataInputStream in) 根据存档格式重新创建一个 DTD。

javax.swing.text.rtf 中 IOException 的使用

抛出 IOException 的 javax.swing.text.rtf 中的方法
void | RTFEditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。
void | RTFEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，该内容将被视为纯文本。
void | RTFEditorKit.write(OutputStream out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。
void | RTFEditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容作为纯文本写入给定的流。

javax.tools 中 IOException 的使用

抛出 IOException 的 javax.tools 中的方法
 void ForwardingJavaFileManager.close()
 void JavaFileManager.close()
释放此文件管理器直接或间接打开的所有资源。
 void ForwardingJavaFileManager.flush()
 void JavaFileManager.flush()
刷新此文件管理器直接或间接为输出打开的所有资源。
 CharSequence FileObject.getCharContent(boolean ignoreEncodingErrors)
返回此文件对象的字符内容（如果有）。
 CharSequence ForwardingFileObject.getCharContent(boolean ignoreEncodingErrors)
 CharSequence SimpleJavaFileObject.getCharContent(boolean ignoreEncodingErrors)
此实现总是抛出 UnsupportedOperationException。
 FileObject ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
 FileObject JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。
 FileObject ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
 FileObject JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。
 JavaFileObject ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
 JavaFileObject JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
获取输入的文件对象，它表示给定位置处指定类型的指定类。
 JavaFileObject ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
 JavaFileObject JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
获取输出的文件对象，它表示给定位置处指定类型的指定类。
 Iterable<JavaFileObject> ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
 Iterable<JavaFileObject> JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
列出给定位置处符合给定标准的所有文件对象。
 InputStream FileObject.openInputStream()
获取此文件对象的 InputStream。
 InputStream ForwardingFileObject.openInputStream()
 InputStream SimpleJavaFileObject.openInputStream()
此实现总是抛出 UnsupportedOperationException。
 OutputStream FileObject.openOutputStream()
获取此文件对象的 OutputStream。
 OutputStream ForwardingFileObject.openOutputStream()
 OutputStream SimpleJavaFileObject.openOutputStream()
此实现总是抛出 UnsupportedOperationException。
 Reader FileObject.openReader(boolean ignoreEncodingErrors)
获取此对象的 reader。
 Reader ForwardingFileObject.openReader(boolean ignoreEncodingErrors)
 Reader SimpleJavaFileObject.openReader(boolean ignoreEncodingErrors)
在 Reader 中包装 SimpleJavaFileObject.getCharContent(boolean) 的结果。
 Writer FileObject.openWriter()
获取此文件对象的 Writer。
 Writer ForwardingFileObject.openWriter()
 Writer SimpleJavaFileObject.openWriter()
在 Writer 中包装 openOutputStream 的结果。
 void StandardJavaFileManager.setLocation(JavaFileManager.Location location, Iterable<? extends File> path)
将给定路径与给定位置关联。

javax.transaction 中 IOException 的使用

javax.transaction 中 IOException 的子类
class | InvalidTransactionException 此异常指示该请求带来了无效的事务上下文。
class | TransactionRequiredException 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
class | TransactionRolledbackException 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

javax.xml.bind 中 IOException 的使用

抛出 IOException 的 javax.xml.bind 中的方法
abstract Result | SchemaOutputResolver.createOutput(String namespaceUri, String suggestedFileName) 确定写入模式文件（由给定名称空间 URI 指定）的位置，并以 Result 对象的形式返回它。
void | JAXBContext.generateSchema(SchemaOutputResolver outputResolver) 生成此上下文的模式文档。

javax.xml.parsers 中 IOException 的使用

抛出 IOException 的 javax.xml.parsers 中的方法
Document | DocumentBuilder.parse(File f) 将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(File f, DefaultHandler dh) 使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
void | SAXParser.parse(File f, HandlerBase hb) 使用指定的 HandlerBase 将指定文件的内容解析为 XML。
abstract Document | DocumentBuilder.parse(InputSource is) 将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputSource is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
void | SAXParser.parse(InputSource is, HandlerBase hb) 使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。
Document | DocumentBuilder.parse(InputStream is) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputStream is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, DefaultHandler dh, String systemId) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb, String systemId) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
Document | DocumentBuilder.parse(InputStream is, String systemId) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | DocumentBuilder.parse(String uri) 将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(String uri, DefaultHandler dh) 使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。
void | SAXParser.parse(String uri, HandlerBase hb) 使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

javax.xml.soap 中 IOException 的使用

抛出 IOException 的 javax.xml.soap 中的方法
abstract SOAPMessage | MessageFactory.createMessage(MimeHeaders headers, InputStream in) 将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
abstract void | SOAPMessage.writeTo(OutputStream out) 将此 SOAPMessage 对象写入给定输出流。

javax.xml.validation 中 IOException 的使用

抛出 IOException 的 javax.xml.validation 中的方法
void | Validator.validate(Source source) 验证指定的输入。
abstract void | Validator.validate(Source source, Result result) 验证指定输入并将扩充的验证结果发送到指定输出。

org.omg.CORBA.portable 中 IOException 的使用

抛出 IOException 的 org.omg.CORBA.portable 中的方法
int | InputStream.read()
void | OutputStream.write(int b) 将一个 integer（数组长度）写入此流。

org.xml.sax 中 IOException 的使用

抛出 IOException 的 org.xml.sax 中的方法
void | Parser.parse(InputSource source) 已过时。 解析 XML 文档。
void | XMLReader.parse(InputSource input) 解析 XML 文档。
void | Parser.parse(String systemId) 已过时。 从系统标识符 (URI) 解析 XML 文档。
void | XMLReader.parse(String systemId) 从系统标识符 (URI) 解析 XML 文档。
InputSource | EntityResolver.resolveEntity(String publicId, String systemId) 允许应用程序解析外部实体。

org.xml.sax.ext 中 IOException 的使用

抛出 IOException 的 org.xml.sax.ext 中的方法
 InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。
 InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
允许应用程序为不能显式定义外部子集的文档提供外部子集。
 InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。
 InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。
 InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。

org.xml.sax.helpers 中 IOException 的使用

抛出 IOException 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.parse(InputSource input) 解析 XML 文档。
void | XMLFilterImpl.parse(InputSource input) 解析一个文档。
void | XMLReaderAdapter.parse(InputSource input) 解析文档。
void | ParserAdapter.parse(String systemId) 解析 XML 文档。
void | XMLFilterImpl.parse(String systemId) 解析一个文档。
void | XMLReaderAdapter.parse(String systemId) 解析文档。
InputSource | DefaultHandler.resolveEntity(String publicId, String systemId) 解析外部实体。
InputSource | XMLFilterImpl.resolveEntity(String publicId, String systemId) 过滤一个外部实体解析。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.LineNumberInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.LineNumberInputStream
的使用

没有 java.io.LineNumberInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.LineNumberReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.LineNumberReader
的使用

没有 java.io.LineNumberReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.NotActiveException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.NotActiveException
的使用

使用 NotActiveException 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 NotActiveException 的使用

抛出 NotActiveException 的 java.io 中的方法
 void ObjectInputStream.registerValidation(ObjectInputValidation obj, int prio)
在返回图形前注册要验证的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.NotSerializableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.NotSerializableException
的使用

没有 java.io.NotSerializableException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.ObjectInput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.ObjectInput
的使用

使用 ObjectInput 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.activation |
javax.management.loading | 提供实现高级动态加载的类。

java.awt.datatransfer 中 ObjectInput 的使用

参数类型为 ObjectInput 的 java.awt.datatransfer 中的方法
 void DataFlavor.readExternal(ObjectInput is)
根据 Serialized 状态还原此 DataFlavor。

java.io 中 ObjectInput 的使用

实现 ObjectInput 的 java.io 中的类
 class ObjectInputStream
ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。

参数类型为 ObjectInput 的 java.io 中的方法
 void Externalizable.readExternal(ObjectInput in)
对象实现 readExternal 方法来恢复其内容，它通过调用 DataInput 的方法来恢复其基础类型，调用 readObject 来恢复对象、字符串和数组。

java.rmi.server 中 ObjectInput 的使用

返回 ObjectInput 的 java.rmi.server 中的方法
 ObjectInput RemoteCall.getInputStream()
已过时。 无替代版本

参数类型为 ObjectInput 的 java.rmi.server 中的方法
static ObjID ObjID.read(ObjectInput in)
通过从 ObjectInput 实例解组二进制表示形式来构造和返回一个新的 ObjID 实例。

javax.activation 中 ObjectInput 的使用

参数类型为 ObjectInput 的 javax.activation 中的方法
 void MimeType.readExternal(ObjectInput in)
对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。

javax.management.loading 中 ObjectInput 的使用

参数类型为 ObjectInput 的 javax.management.loading 中的方法
 void MLet.readExternal(ObjectInput in)
从给定的 ObjectInput 恢复此 MLet 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.ObjectInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectInputStream
的使用

使用 ObjectInputStream 的软件包
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.beans.beancontext 中 ObjectInputStream 的使用

参数类型为 ObjectInputStream 的 java.beans.beancontext 中的方法
protected  void BeanContextServicesSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在反序列化子级之前，从 BeanContextSupport readObject 中调用。
protected  void BeanContextSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在调用 defaultReadObject() 之后，但在反序列化任意子级之前，由 readObject 调用。
protected  void BeanContextSupport.deserialize(ObjectInputStream ois, Collection coll)
readObject 使用此方法来反序列化一个 collection。
 void BeanContextSupport.readChildren(ObjectInputStream ois)
在将此类的实例用作 BeanContext 协议（及其子协议）实现的代理时，在反序列化期间存在一个“先有鸡还是先有蛋”的问题。

javax.management 中 ObjectInputStream 的使用

返回 ObjectInputStream 的 javax.management 中的方法
 ObjectInputStream MBeanServer.deserialize(ObjectName name, byte[] data)
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
 ObjectInputStream MBeanServer.deserialize(String className, byte[] data)
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
 ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。

javax.rmi.CORBA 中 ObjectInputStream 的使用

参数类型为 ObjectInputStream 的 javax.rmi.CORBA 中的方法
 void StubDelegate.readObject(Stub self, ObjectInputStream s)
Stub.readObject(java.io.ObjectInputStream) 的委托调用。

javax.swing.text 中 ObjectInputStream 的使用

参数类型为 ObjectInputStream 的 javax.swing.text 中的方法
void | StyleContext.readAttributes(ObjectInputStream in, MutableAttributeSet a) 读入属性的特定于上下文的处理。
static void | StyleContext.readAttributeSet(ObjectInputStream in, MutableAttributeSet a) 从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.ObjectInputStream.GetField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectInputStream.GetField
的使用

使用 ObjectInputStream.GetField 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectInputStream.GetField 的使用

返回 ObjectInputStream.GetField 的 java.io 中的方法
 ObjectInputStream.GetField ObjectInputStream.readFields()
按名称从流中读取持久字段并使其可用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.ObjectInputValidation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.ObjectInputValidation
的使用

使用 ObjectInputValidation 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectInputValidation 的使用

参数类型为 ObjectInputValidation 的 java.io 中的方法
 void ObjectInputStream.registerValidation(ObjectInputValidation obj, int prio)
在返回图形前注册要验证的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.ObjectOutput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.ObjectOutput
的使用

使用 ObjectOutput 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.activation |
javax.management.loading | 提供实现高级动态加载的类。

java.awt.datatransfer 中 ObjectOutput 的使用

参数类型为 ObjectOutput 的 java.awt.datatransfer 中的方法
 void DataFlavor.writeExternal(ObjectOutput os)
序列化此 DataFlavor。

java.io 中 ObjectOutput 的使用

实现 ObjectOutput 的 java.io 中的类
 class ObjectOutputStream
ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。

参数类型为 ObjectOutput 的 java.io 中的方法
abstract  void ObjectOutputStream.PutField.write(ObjectOutput out)
已过时。 此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。
 void Externalizable.writeExternal(ObjectOutput out)
该对象可实现 writeExternal 方法来保存其内容，它可以通过调用 DataOutput 的方法来保存其基本值，或调用 ObjectOutput 的 writeObject 方法来保存对象、字符串和数组。

java.rmi.server 中 ObjectOutput 的使用

返回 ObjectOutput 的 java.rmi.server 中的方法
ObjectOutput | RemoteCall.getOutputStream() 已过时。 无替代版本
ObjectOutput | RemoteCall.getResultStream(boolean success) 已过时。 无替代版本

参数类型为 ObjectOutput 的 java.rmi.server 中的方法
String | RemoteRef.getRefClass(ObjectOutput out) 返回要在流 'out' 上序列化的 ref 类型的类名称。
void | ObjID.write(ObjectOutput out) 将此 ObjID 的二进制表示形式编组为一个 ObjectOutput 实例。

javax.activation 中 ObjectOutput 的使用

参数类型为 ObjectOutput 的 javax.activation 中的方法
 void MimeType.writeExternal(ObjectOutput out)
对象可实现 writeExternal 方法来保存其内容：对于其基本值，调用 DataOutput 的方法；对于对象、字符串和数组，调用 ObjectOutput 的 writeObject 方法。

javax.management.loading 中 ObjectOutput 的使用

参数类型为 ObjectOutput 的 javax.management.loading 中的方法
 void MLet.writeExternal(ObjectOutput out)
将此 MLet 的内容保存到给定的 ObjectOutput。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.ObjectOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectOutputStream
的使用

使用 ObjectOutputStream 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 ObjectOutputStream 的使用

参数类型为 ObjectOutputStream 的 java.awt 中的方法
protected static void | AWTEventMulticaster.save(ObjectOutputStream s, String k, EventListener l)
protected void | AWTEventMulticaster.saveInternal(ObjectOutputStream s, String k)

java.beans.beancontext 中 ObjectOutputStream 的使用

参数类型为 ObjectOutputStream 的 java.beans.beancontext 中的方法
protected  void BeanContextServicesSupport.bcsPreSerializationHook(ObjectOutputStream oos)
在序列化子级之前，从 BeanContextSupport writeObject 中调用。
protected  void BeanContextSupport.bcsPreSerializationHook(ObjectOutputStream oos)
在调用 defaultWriteObject() 之后，但在序列化当前可序列化子级之前，由 writeObject 调用。
protected  void BeanContextSupport.serialize(ObjectOutputStream oos, Collection coll)
writeObject 使用此方法来序列化一个 Collection。
 void BeanContextSupport.writeChildren(ObjectOutputStream oos)
用于序列化此 BeanContext 的所有子级。

javax.rmi.CORBA 中 ObjectOutputStream 的使用

参数类型为 ObjectOutputStream 的 javax.rmi.CORBA 中的方法
 void StubDelegate.writeObject(Stub self, ObjectOutputStream s)
Stub.writeObject(java.io.ObjectOutputStream) 的委托调用。

javax.swing.text 中 ObjectOutputStream 的使用

参数类型为 ObjectOutputStream 的 javax.swing.text 中的方法
void | StyleContext.writeAttributes(ObjectOutputStream out, AttributeSet a) 写出属性的特定于上下文的处理。
static void | StyleContext.writeAttributeSet(ObjectOutputStream out, AttributeSet a) 将属性集写入到给定的对象流以便序列化。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.ObjectOutputStream.PutField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectOutputStream.PutField
的使用

使用 ObjectOutputStream.PutField 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectOutputStream.PutField 的使用

返回 ObjectOutputStream.PutField 的 java.io 中的方法
 ObjectOutputStream.PutField ObjectOutputStream.putFields()
获取用于缓冲写入流中的持久存储字段的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.ObjectStreamClass 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectStreamClass
的使用

使用 ObjectStreamClass 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectStreamClass 的使用

返回 ObjectStreamClass 的 java.io 中的方法
abstract ObjectStreamClass | ObjectInputStream.GetField.getObjectStreamClass() 获取描述流中字段的 ObjectStreamClass。
static ObjectStreamClass | ObjectStreamClass.lookup(Class<?> cl) 查找可序列化类的描述符。
static ObjectStreamClass | ObjectStreamClass.lookupAny(Class<?> cl) 返回任意类的描述符，不考虑它是否实现 Serializable。
protected ObjectStreamClass | ObjectInputStream.readClassDescriptor() 从序列化流读取类描述符。

参数类型为 ObjectStreamClass 的 java.io 中的方法
protected Class<?> | ObjectInputStream.resolveClass(ObjectStreamClass desc) 加载指定流类描述的本地等价类。
protected void | ObjectOutputStream.writeClassDescriptor(ObjectStreamClass desc) 将指定的类描述符写入 ObjectOutputStream。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.ObjectStreamConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.ObjectStreamConstants
的使用

使用 ObjectStreamConstants 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectStreamConstants 的使用

实现 ObjectStreamConstants 的 java.io 中的类
class | ObjectInputStream ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
class | ObjectOutputStream ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.ObjectStreamException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectStreamException
的使用

使用 ObjectStreamException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

java.awt 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 java.awt 中的方法
protected  Object AWTKeyStroke.readResolve()
返回 AWTKeyStroke 的一个缓存实例（或 AWTKeyStroke 的子类），它与此实例相等。

java.awt.color 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 java.awt.color 中的方法
protected  Object ICC_Profile.readResolve()
解析将被反序列化为用 CMM 注册的实例的实例。

java.io 中 ObjectStreamException 的使用

java.io 中 ObjectStreamException 的子类
class | InvalidClassException 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
class | InvalidObjectException 指示一个或多个反序列化对象未通过验证测试。
class | NotActiveException 当序列化和反序列化不活动时，抛出此异常。
class | NotSerializableException 当实例需要具有序列化接口时，抛出此异常。
class | OptionalDataException 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
class | StreamCorruptedException 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
class | WriteAbortedException 在写入操作过程中抛出 ObjectStreamException 之一的信号。

java.security 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 java.security 中的方法
protected  Object KeyRep.readResolve()
解析 Key 对象。

java.security.cert 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 java.security.cert 中的方法
protected Object | CertPath.CertPathRep.readResolve() 返回根据类型和数据所构造的 CertPath。
protected Object | Certificate.CertificateRep.readResolve() 解析该 Certificate 对象。
protected Object | CertPath.writeReplace() 使用 CertPathRep 对象替换要被序列化的 CertPath。
protected Object | Certificate.writeReplace() 替换要被序列化的 Certificate。

javax.management.openmbean 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 javax.management.openmbean 中的方法
 Object SimpleType.readResolve()
使用该值的唯一实例替换从 ObjectInputStream 读取的对象。

javax.print.attribute 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 javax.print.attribute 中的方法
protected  Object EnumSyntax.readResolve()
在对象输入过程中，将此反序列化的枚举实例转换为枚举属性类中定义的适当枚举值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.ObjectStreamField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectStreamField
的使用

使用 ObjectStreamField 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectStreamField 的使用

声明为 ObjectStreamField 的 java.io 中的字段
static ObjectStreamField[] ObjectStreamClass.NO_FIELDS
指示不存在可序列化字段的 serialPersistentFields 值。

返回 ObjectStreamField 的 java.io 中的方法
ObjectStreamField | ObjectStreamClass.getField(String name) 按名称获取此类的字段。
ObjectStreamField[] | ObjectStreamClass.getFields() 返回此可序列化类的字段组成的数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.OptionalDataException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.OptionalDataException
的使用

没有 java.io.OptionalDataException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.OutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.OutputStream
的使用

使用 OutputStream 的软件包
java.awt.color | 提供用于颜色空间的类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.crypto | 为加密操作提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.w3c.dom.ls |

java.awt.color 中 OutputStream 的使用

参数类型为 OutputStream 的 java.awt.color 中的方法
 void ICC_Profile.write(OutputStream s)
将 ICC_Profile 写入一个 OutputStream。

java.beans 中 OutputStream 的使用

参数类型为 OutputStream 的 java.beans 中的构造方法
XMLEncoder(OutputStream out)
使用 XML 编码创建一个新的输出流，将 JavaBeans 发送给流 out。

java.io 中 OutputStream 的使用

java.io 中 OutputStream 的子类
class | BufferedOutputStream 该类实现缓冲的输出流。
class | ByteArrayOutputStream 此类实现了一个输出流，其中的数据被写入一个 byte 数组。
class | DataOutputStream 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
class | FileOutputStream 文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。
class | FilterOutputStream 此类是过滤输出流的所有类的超类。
class | ObjectOutputStream ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
class | PipedOutputStream 可以将管道输出流连接到管道输入流来创建通信管道。
class | PrintStream PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。

声明为 OutputStream 的 java.io 中的字段
protected  OutputStream FilterOutputStream.out
要过滤的基础输出流。

参数类型为 OutputStream 的 java.io 中的方法
 void ByteArrayOutputStream.writeTo(OutputStream out)
将此 byte 数组输出流的全部内容写入到指定的输出流参数中，这与使用 out.write(buf, 0, count) 调用该输出流的 write 方法效果一样。

参数类型为 OutputStream 的 java.io 中的构造方法
BufferedOutputStream(OutputStream out)
创建一个新的缓冲输出流，以将数据写入指定的底层输出流。
BufferedOutputStream(OutputStream out, int size)
创建一个新的缓冲输出流，以将具有指定缓冲区大小的数据写入指定的底层输出流。
DataOutputStream(OutputStream out)
创建一个新的数据输出流，将数据写入指定基础输出流。
FilterOutputStream(OutputStream out)
创建一个构建在指定基础输出流之上的输出流过滤器。
ObjectOutputStream(OutputStream out)
创建写入指定 OutputStream 的 ObjectOutputStream。
OutputStreamWriter(OutputStream out)
创建使用默认字符编码的 OutputStreamWriter。
OutputStreamWriter(OutputStream out, Charset cs)
创建使用给定字符集的 OutputStreamWriter。
OutputStreamWriter(OutputStream out, CharsetEncoder enc)
创建使用给定字符集编码器的 OutputStreamWriter。
OutputStreamWriter(OutputStream out, String charsetName)
创建使用指定字符集的 OutputStreamWriter。
PrintStream(OutputStream out)
创建新的打印流。
PrintStream(OutputStream out, boolean autoFlush)
创建新的打印流。
PrintStream(OutputStream out, boolean autoFlush, String encoding)
创建新的打印流。
PrintWriter(OutputStream out)
根据现有的 OutputStream 创建不带自动行刷新的新 PrintWriter。
PrintWriter(OutputStream out, boolean autoFlush)
通过现有的 OutputStream 创建新的 PrintWriter。

java.lang 中 OutputStream 的使用

返回 OutputStream 的 java.lang 中的方法
OutputStream | Runtime.getLocalizedOutputStream(OutputStream out) 已过时。 从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。
abstract OutputStream | Process.getOutputStream() 获取子进程的输出流。

参数类型为 OutputStream 的 java.lang 中的方法
 OutputStream Runtime.getLocalizedOutputStream(OutputStream out)
已过时。 从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。

java.net 中 OutputStream 的使用

返回 OutputStream 的 java.net 中的方法
abstract OutputStream | CacheRequest.getBody() 返回可以将响应正文写入其中的 OutputStream。
protected abstract OutputStream | SocketImpl.getOutputStream() 返回此套接字的输出流。
OutputStream | Socket.getOutputStream() 返回此套接字的输出流。
OutputStream | URLConnection.getOutputStream() 返回写入到此连接的输出流。

java.nio.channels 中 OutputStream 的使用

返回 OutputStream 的 java.nio.channels 中的方法
static OutputStream Channels.newOutputStream(WritableByteChannel ch)
构造向给定信道写入字节的流。

参数类型为 OutputStream 的 java.nio.channels 中的方法
static WritableByteChannel Channels.newChannel(OutputStream out)
构造向给定流写入字节的信道。

java.rmi.server 中 OutputStream 的使用

java.rmi.server 中 OutputStream 的子类
 class LogStream
已过时。 无替代版本

返回 OutputStream 的 java.rmi.server 中的方法
 OutputStream LogStream.getOutputStream()
已过时。 无替代版本

参数类型为 OutputStream 的 java.rmi.server 中的方法
static void | RemoteServer.setLog(OutputStream out) 将 RMI 调用记录到输出流 out 中。
void | LogStream.setOutputStream(OutputStream out) 已过时。 无替代版本

java.security 中 OutputStream 的使用

java.security 中 OutputStream 的子类
 class DigestOutputStream
使用通过流的位更新关联消息摘要的透明流。

参数类型为 OutputStream 的 java.security 中的方法
void | Certificate.encode(OutputStream stream) 已过时。 以 decode 方法可以解码的格式将证书编码到输出流。
abstract void | KeyStoreSpi.engineStore(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
void | KeyStore.store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。

参数类型为 OutputStream 的 java.security 中的构造方法
DigestOutputStream(OutputStream stream, MessageDigest digest)
使用指定的输出流和消息摘要创建一个摘要输出流。

java.sql 中 OutputStream 的使用

返回 OutputStream 的 java.sql 中的方法
OutputStream | Clob.setAsciiStream(long pos) 获取用于将 Ascii 字符写入此 Clob 对象表示的 Clob 值中的流，从位置 pos 处开始。
OutputStream | SQLXML.setBinaryStream() 获取可用于写入此 SQLXML 实例表示的 XML 值的流。
OutputStream | Blob.setBinaryStream(long pos) 获取用于写入此 Blob 对象表示的 BLOB 值的流。

java.util 中 OutputStream 的使用

参数类型为 OutputStream 的 java.util 中的方法
 void Properties.save(OutputStream out, String comments)
已过时。 如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。
 void Properties.store(OutputStream out, String comments)
以适合使用 load(InputStream) 方法加载到 Properties 表中的格式，将此 Properties 表中的属性列表（键和元素对）写入输出流。
 void Properties.storeToXML(OutputStream os, String comment)
发出一个表示此表中包含的所有属性的 XML 文档。
 void Properties.storeToXML(OutputStream os, String comment, String encoding)
使用指定的编码发出一个表示此表中包含的所有属性的 XML 文档。

参数类型为 OutputStream 的 java.util 中的构造方法
Formatter(OutputStream os)
构造一个带指定输出流的新 formatter。
Formatter(OutputStream os, String csn)
构造一个带指定输出流和字符集的新 formatter。
Formatter(OutputStream os, String csn, Locale l)
构造一个带指定输出流、字符集和语言环境的新 formatter。

java.util.jar 中 OutputStream 的使用

java.util.jar 中 OutputStream 的子类
 class JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

参数类型为 OutputStream 的 java.util.jar 中的方法
void | Pack200.Packer.pack(JarFile in, OutputStream out) 接收 JarFile 并将其转换为 Pack200 存档。
void | Pack200.Packer.pack(JarInputStream in, OutputStream out) 接收 JarInputStream 并将其转换成 Pack200 存档。
void | Manifest.write(OutputStream out) 将 Manifest 写入指定的 OutputStream。

参数类型为 OutputStream 的 java.util.jar 中的构造方法
JarOutputStream(OutputStream out)
创建不带清单的新的 JarOutputStream。
JarOutputStream(OutputStream out, Manifest man)
使用指定的 Manifest 创建新的 JarOutputStream。

java.util.logging 中 OutputStream 的使用

参数类型为 OutputStream 的 java.util.logging 中的方法
protected  void StreamHandler.setOutputStream(OutputStream out)
更改输出流。

参数类型为 OutputStream 的 java.util.logging 中的构造方法
StreamHandler(OutputStream out, Formatter formatter)
创建带给定 Formatter 和输出流的 StreamHandler。

java.util.prefs 中 OutputStream 的使用

参数类型为 OutputStream 的 java.util.prefs 中的方法
 void AbstractPreferences.exportNode(OutputStream os)
根据 Preferences.exportNode(OutputStream) 中的规范实现 exportNode 方法。
abstract  void Preferences.exportNode(OutputStream os)
在指定输出流上发出表示此节点（不是其子节点）中包含的所有首选项的 XML 文档。
 void AbstractPreferences.exportSubtree(OutputStream os)
根据 Preferences.exportSubtree(OutputStream) 中的规范实现 exportSubtree 方法。
abstract  void Preferences.exportSubtree(OutputStream os)
发出表示此节点及其所有子节点中包含的全部首选项的 XML 文档。

java.util.zip 中 OutputStream 的使用

java.util.zip 中 OutputStream 的子类
class | CheckedOutputStream 需要维护写入数据校验和的输出流。
class | DeflaterOutputStream 此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
class | GZIPOutputStream 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
class | InflaterOutputStream 为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
class | ZipOutputStream 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

参数类型为 OutputStream 的 java.util.zip 中的构造方法
CheckedOutputStream(OutputStream out, Checksum cksum)
使用指定校验和创建输出流。
DeflaterOutputStream(OutputStream out)
使用默认压缩器和缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream out, Deflater def)
使用指定压缩器和默认缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream out, Deflater def, int size)
使用指定压缩器和缓冲区大小创建一个新输出流。
GZIPOutputStream(OutputStream out)
使用默认缓冲区大小创建新的输出流。
GZIPOutputStream(OutputStream out, int size)
使用指定缓冲区大小创建新的输出流。
InflaterOutputStream(OutputStream out)
创建一个带有默认解压缩器和缓冲区大小的新输出流。
InflaterOutputStream(OutputStream out, Inflater infl)
创建一个带有指定解压缩器和默认缓冲区大小的新输出流。
InflaterOutputStream(OutputStream out, Inflater infl, int bufLen)
创建一个带有指定解压缩器和缓冲区大小的新输出流。
ZipOutputStream(OutputStream out)
创建新的 ZIP 输出流。

javax.activation 中 OutputStream 的使用

返回 OutputStream 的 javax.activation 中的方法
OutputStream | DataHandler.getOutputStream() 获取此 DataHandler 的 OutputStream，以允许重写底层数据。
OutputStream | DataSource.getOutputStream() 此方法返回一个可以写入数据的 OutputStream，如果无法返回，则抛出适当的异常。
OutputStream | FileDataSource.getOutputStream() 此方法将返回一个表示数据的 OutputStream；如果不能返回，则抛出 IOException。
OutputStream | URLDataSource.getOutputStream() URL 的 getOutputStream 方法。

参数类型为 OutputStream 的 javax.activation 中的方法
void | DataContentHandler.writeTo(Object obj, String mimeType, OutputStream os) 将对象转换为指定 MIME 类型的字节流，并将其写入输出流。
void | DataHandler.writeTo(OutputStream os) 将数据写入 OutputStream。

javax.crypto 中 OutputStream 的使用

javax.crypto 中 OutputStream 的子类
 class CipherOutputStream
CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。

参数类型为 OutputStream 的 javax.crypto 中的构造方法
CipherOutputStream(OutputStream os)
从 OutputStream 构造 CipherOutputStream，不指定 Cipher。
CipherOutputStream(OutputStream os, Cipher c)
从 OutputStream 和 Cipher 构造 CipherOutputStream。

javax.imageio 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.imageio 中的方法
static boolean ImageIO.write(RenderedImage im, String formatName, OutputStream output)
使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。

javax.imageio.stream 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.imageio.stream 中的构造方法
FileCacheImageOutputStream(OutputStream stream, File cacheDir)
构造一个将向给定 outputStream 进行写入的 FileCacheImageOutputStream。
MemoryCacheImageOutputStream(OutputStream stream)
构造将向给定 OutputStream 进行写入的 MemoryCacheImageOutputStream。

javax.print 中 OutputStream 的使用

返回 OutputStream 的 javax.print 中的方法
 OutputStream StreamPrintService.getOutputStream()
获得输出流。

参数类型为 OutputStream 的 javax.print 中的方法
abstract  StreamPrintService StreamPrintServiceFactory.getPrintService(OutputStream out)
返回可打印到指定输出流的 StreamPrintService。

参数类型为 OutputStream 的 javax.print 中的构造方法
StreamPrintService(OutputStream out)
构造一个 StreamPrintService 对象。

javax.sound.midi 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.sound.midi 中的方法
static int MidiSystem.write(Sequence in, int fileType, OutputStream out)
将表示所指示 MIDI 文件类型的文件的字节流写入提供的输出流。

javax.sound.midi.spi 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.sound.midi.spi 中的方法
abstract  int MidiFileWriter.write(Sequence in, int fileType, OutputStream out)
写入表示指示为所提供输出流的文件类型的 MIDI 文件的字节流。

javax.sound.sampled 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.sound.sampled 中的方法
static int AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
将表示指定文件类型的音频文件的字节流写入所提供的输出流。

javax.sound.sampled.spi 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.sound.sampled.spi 中的方法
abstract  int AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
将表示所指示文件类型的音频文件的字节流写入所提供的输出流。

javax.sql.rowset 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.sql.rowset 中的方法
void | WebRowSet.writeXml(OutputStream oStream) 以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 OutputStream 对象。
void | WebRowSet.writeXml(ResultSet rs, OutputStream oStream) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。

javax.sql.rowset.serial 中 OutputStream 的使用

返回 OutputStream 的 javax.sql.rowset.serial 中的方法
OutputStream | SerialClob.setAsciiStream(long pos) 获取用于将 Ascii 字符写入此 SerialClob 对象所表示的 Clob 值的流，从位置 pos 处开始。
OutputStream | SerialBlob.setBinaryStream(long pos) 获取用于写入此 Blob 对象所表示的 BLOB 值的流。

javax.swing.text 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.swing.text 中的方法
void | DefaultEditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
abstract void | EditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

javax.swing.text.rtf 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.swing.text.rtf 中的方法
 void RTFEditorKit.write(OutputStream out, Document doc, int pos, int len)
以适合此类内容处理程序的格式，将文档中的内容写入给定流。

javax.tools 中 OutputStream 的使用

返回 OutputStream 的 javax.tools 中的方法
OutputStream | FileObject.openOutputStream() 获取此文件对象的 OutputStream。
OutputStream | ForwardingFileObject.openOutputStream()
OutputStream | SimpleJavaFileObject.openOutputStream() 此实现总是抛出 UnsupportedOperationException。

参数类型为 OutputStream 的 javax.tools 中的方法
 int Tool.run(InputStream in, OutputStream out, OutputStream err, String... arguments)
使用给定 I/O 通道和参数运行工具。

javax.xml.bind 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, OutputStream os)
将以 jaxbElement 为根的内容树编组到输出流中。

javax.xml.bind.helpers 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, OutputStream os)

javax.xml.crypto.dsig 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.xml.crypto.dsig 中的方法
 Data Transform.transform(Data data, XMLCryptoContext context, OutputStream os)
使用底层转换算法对指定数据进行转换。

javax.xml.soap 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.xml.soap 中的方法
abstract  void SOAPMessage.writeTo(OutputStream out)
将此 SOAPMessage 对象写入给定输出流。

javax.xml.stream 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.xml.stream 中的方法
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(OutputStream stream) 创建一个写入到流的新 XMLEventWriter。
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding) 创建一个写入到流的新 XMLEventWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(OutputStream stream) 创建一个写入到流的新 XMLStreamWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding) 创建一个写入到流的新 XMLStreamWriter。

javax.xml.transform.stream 中 OutputStream 的使用

返回 OutputStream 的 javax.xml.transform.stream 中的方法
 OutputStream StreamResult.getOutputStream()
获取通过 setOutputStream 设置的字节流。

参数类型为 OutputStream 的 javax.xml.transform.stream 中的方法
 void StreamResult.setOutputStream(OutputStream outputStream)
设置要写入的 ByteStream。

参数类型为 OutputStream 的 javax.xml.transform.stream 中的构造方法
StreamResult(OutputStream outputStream)
从字节流构造 StreamResult。

org.ietf.jgss 中 OutputStream 的使用

参数类型为 OutputStream 的 org.ietf.jgss 中的方法
void | GSSContext.acceptSecContext(InputStream inStream, OutputStream outStream) 由上下文接受端调用，以处理来自使用流的同位体的标记。
void | GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
int | GSSContext.initSecContext(InputStream inStream, OutputStream outStream) 由上下文初始端调用，以启动上下文的创建阶段，处理由使用流的同位体的 acceptSecContext 方法生成的任何标记。
void | GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 将 per-message 安全服务应用于已创建的使用流的安全上下文。

org.omg.CORBA.portable 中 OutputStream 的使用

org.omg.CORBA.portable 中 OutputStream 的子类
 class OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.w3c.dom.ls 中 OutputStream 的使用

返回 OutputStream 的 org.w3c.dom.ls 中的方法
 OutputStream LSOutput.getByteStream()
具有语言和绑定依赖性类型的属性，表示字节的可写流。

参数类型为 OutputStream 的 org.w3c.dom.ls 中的方法
 void LSOutput.setByteStream(OutputStream byteStream)
具有语言和绑定依赖性类型的属性，表示字节的可写流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.OutputStreamWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.OutputStreamWriter
的使用

使用 OutputStreamWriter 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 OutputStreamWriter 的使用

java.io 中 OutputStreamWriter 的子类
 class FileWriter
用来写入字符文件的便捷类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.PipedInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PipedInputStream
的使用

使用 PipedInputStream 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 PipedInputStream 的使用

参数类型为 PipedInputStream 的 java.io 中的方法
 void PipedOutputStream.connect(PipedInputStream snk)
将此管道输出流连接到接收者。

参数类型为 PipedInputStream 的 java.io 中的构造方法
PipedOutputStream(PipedInputStream snk)
创建连接到指定管道输入流的管道输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.PipedOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PipedOutputStream
的使用

使用 PipedOutputStream 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 PipedOutputStream 的使用

参数类型为 PipedOutputStream 的 java.io 中的方法
 void PipedInputStream.connect(PipedOutputStream src)
使此管道输入流连接到管道输出流 src。

参数类型为 PipedOutputStream 的 java.io 中的构造方法
PipedInputStream(PipedOutputStream src)
创建 PipedInputStream，使其连接到管道输出流 src。
PipedInputStream(PipedOutputStream src, int pipeSize)
创建一个 PipedInputStream，使其连接到管道输出流 src，并对管道缓冲区使用指定的管道大小。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.PipedReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PipedReader
的使用

使用 PipedReader 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 PipedReader 的使用

参数类型为 PipedReader 的 java.io 中的方法
 void PipedWriter.connect(PipedReader snk)
将此传送 writer 连接到接收方。

参数类型为 PipedReader 的 java.io 中的构造方法
PipedWriter(PipedReader snk)
创建传送 writer，使其连接到指定的传送 reader。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.PipedWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PipedWriter
的使用

使用 PipedWriter 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 PipedWriter 的使用

参数类型为 PipedWriter 的 java.io 中的方法
 void PipedReader.connect(PipedWriter src)
使此传送 reader 连接到传送 writer src。

参数类型为 PipedWriter 的 java.io 中的构造方法
PipedReader(PipedWriter src)
创建连接到传送 writer src 的 PipedReader。
PipedReader(PipedWriter src, int pipeSize)
创建一个 PipedReader，使其连接到管道 writer src，并对管道缓冲区使用指定的管道大小。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.PrintStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PrintStream
的使用

使用 PrintStream 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

java.awt 中 PrintStream 的使用

参数类型为 PrintStream 的 java.awt 中的方法
void | Component.list(PrintStream out) 将组件列表打印到指定的输出流。
void | Container.list(PrintStream out, int indent) 将此容器的清单打印到指定输出流。
void | Component.list(PrintStream out, int indent) 将列表从指定的缩排开始打印到指定的打印流。

java.io 中 PrintStream 的使用

返回 PrintStream 的 java.io 中的方法
PrintStream | PrintStream.append(char c) 将指定字符添加到此输出流。
PrintStream | PrintStream.append(CharSequence csq) 将指定字符序列添加到此输出流。
PrintStream | PrintStream.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此输出流。
PrintStream | PrintStream.format(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此输出流中。
PrintStream | PrintStream.format(String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此输出流中。
PrintStream | PrintStream.printf(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。
PrintStream | PrintStream.printf(String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

java.lang 中 PrintStream 的使用

声明为 PrintStream 的 java.lang 中的字段
static PrintStream | System.err “标准”错误输出流。
static PrintStream | System.out “标准”输出流。

参数类型为 PrintStream 的 java.lang 中的方法
void | Throwable.printStackTrace(PrintStream s) 将此 throwable 及其追踪输出到指定的输出流。
static void | System.setErr(PrintStream err) 重新分配“标准”错误输出流。
static void | System.setOut(PrintStream out) 重新分配“标准”输出流。

java.rmi.server 中 PrintStream 的使用

java.rmi.server 中 PrintStream 的子类
 class LogStream
已过时。 无替代版本

返回 PrintStream 的 java.rmi.server 中的方法
static PrintStream | LogStream.getDefaultStream() 已过时。 无替代版本
static PrintStream | RemoteServer.getLog() 返回用于 RMI 调用日志的流。

参数类型为 PrintStream 的 java.rmi.server 中的方法
static void LogStream.setDefaultStream(PrintStream newDefault)
已过时。 无替代版本

java.sql 中 PrintStream 的使用

返回 PrintStream 的 java.sql 中的方法
static PrintStream DriverManager.getLogStream()
已过时。

参数类型为 PrintStream 的 java.sql 中的方法
static void DriverManager.setLogStream(PrintStream out)
已过时。

java.util 中 PrintStream 的使用

参数类型为 PrintStream 的 java.util 中的方法
 void Properties.list(PrintStream out)
将属性列表输出到指定的输出流。

参数类型为 PrintStream 的 java.util 中的构造方法
Formatter(PrintStream ps)
构造一个带指定输出流的新 formatter。

javax.swing 中 PrintStream 的使用

返回 PrintStream 的 javax.swing 中的方法
static PrintStream DebugGraphics.logStream()
返回 DebugGraphics 在其中记录绘制操作的流。

参数类型为 PrintStream 的 javax.swing 中的方法
static void DebugGraphics.setLogStream(PrintStream stream)
设置 DebugGraphics 在其中记录绘制操作的流。

javax.swing.text 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.swing.text 中的方法
void | AbstractDocument.dump(PrintStream out) 提供诊断转储 (dump)。
void | AbstractDocument.AbstractElement.dump(PrintStream psOut, int indentAmount) 转储该元素层次结构的调试表示形式。

javax.xml.bind 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.xml.bind 中的方法
void | JAXBException.printStackTrace(PrintStream s) 打印此 JAXBException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
void | TypeConstraintException.printStackTrace(PrintStream s) 打印此 TypeConstraintException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。

javax.xml.crypto 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.xml.crypto 中的方法
void | KeySelectorException.printStackTrace(PrintStream s) 将此 KeySelectorException、它的追踪和 cause 追踪打印到指定的打印流。
void | MarshalException.printStackTrace(PrintStream s) 将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印流。
void | NoSuchMechanismException.printStackTrace(PrintStream s) 将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定的打印流。
void | URIReferenceException.printStackTrace(PrintStream s) 将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流。

javax.xml.crypto.dsig 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.xml.crypto.dsig 中的方法
void | TransformException.printStackTrace(PrintStream s) 将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印流中。
void | XMLSignatureException.printStackTrace(PrintStream s) 将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。

javax.xml.transform 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.xml.transform 中的方法
 void TransformerException.printStackTrace(PrintStream s)
打印从中产生错误的方法跟踪。

javax.xml.xpath 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.xml.xpath 中的方法
 void XPathException.printStackTrace(PrintStream s)
将堆栈跟踪打印到指定的 PrintStream。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.PrintWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PrintWriter
的使用

使用 PrintWriter 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

java.awt 中 PrintWriter 的使用

参数类型为 PrintWriter 的 java.awt 中的方法
void | Component.list(PrintWriter out) 将列表打印到指定的打印编写器。
void | Container.list(PrintWriter out, int indent) 将一个列表打印到指定打印编写器，从指定缩排位置开始。
void | Component.list(PrintWriter out, int indent) 将列表从指定的缩排开始打印到指定的打印编写器。

java.io 中 PrintWriter 的使用

返回 PrintWriter 的 java.io 中的方法
PrintWriter | PrintWriter.append(char c) 将指定字符添加到此 writer。
PrintWriter | PrintWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
PrintWriter | PrintWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
PrintWriter | PrintWriter.format(Locale l, String format, Object... args) 使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
PrintWriter | PrintWriter.format(String format, Object... args) 使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
PrintWriter | PrintWriter.printf(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
PrintWriter | PrintWriter.printf(String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
PrintWriter | Console.writer() 获取与此控制台关联的唯一 PrintWriter 对象。

java.lang 中 PrintWriter 的使用

参数类型为 PrintWriter 的 java.lang 中的方法
 void Throwable.printStackTrace(PrintWriter s)
将此 throwable 及其追踪输出到指定的 PrintWriter。

java.sql 中 PrintWriter 的使用

返回 PrintWriter 的 java.sql 中的方法
static PrintWriter DriverManager.getLogWriter()
获取日志 writer。

参数类型为 PrintWriter 的 java.sql 中的方法
static void DriverManager.setLogWriter(PrintWriter out)
设置由 DriverManager 和所有驱动程序使用的日志/追踪 PrintWriter 对象。

java.util 中 PrintWriter 的使用

参数类型为 PrintWriter 的 java.util 中的方法
 void Properties.list(PrintWriter out)
将属性列表输出到指定的输出流。

javax.sql 中 PrintWriter 的使用

返回 PrintWriter 的 javax.sql 中的方法
 PrintWriter CommonDataSource.getLogWriter()
获取此 DataSource 对象的日志 writer。

参数类型为 PrintWriter 的 javax.sql 中的方法
 void CommonDataSource.setLogWriter(PrintWriter out)
将此 DataSource 对象的日志 writer 设置为给定的 java.io.PrintWriter 对象。

javax.xml.bind 中 PrintWriter 的使用

参数类型为 PrintWriter 的 javax.xml.bind 中的方法
 void JAXBException.printStackTrace(PrintWriter s)
打印此 JAXBException 及其对 PrintWriter 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。

javax.xml.crypto 中 PrintWriter 的使用

参数类型为 PrintWriter 的 javax.xml.crypto 中的方法
void | KeySelectorException.printStackTrace(PrintWriter s) 将此 KeySelectorException、它的追踪和 cause 追踪打印到指定打印编写器。
void | MarshalException.printStackTrace(PrintWriter s) 将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印编写器。
void | NoSuchMechanismException.printStackTrace(PrintWriter s) 将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定打印编写器。
void | URIReferenceException.printStackTrace(PrintWriter s) 将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印编写器。

javax.xml.crypto.dsig 中 PrintWriter 的使用

参数类型为 PrintWriter 的 javax.xml.crypto.dsig 中的方法
void | TransformException.printStackTrace(PrintWriter s) 将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印编写器。
void | XMLSignatureException.printStackTrace(PrintWriter s) 将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。

javax.xml.transform 中 PrintWriter 的使用

参数类型为 PrintWriter 的 javax.xml.transform 中的方法
 void TransformerException.printStackTrace(PrintWriter s)
打印从中产生错误的方法跟踪。

javax.xml.xpath 中 PrintWriter 的使用

参数类型为 PrintWriter 的 javax.xml.xpath 中的方法
 void XPathException.printStackTrace(PrintWriter s)
将堆栈跟踪打印到指定的 PrintWriter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.PushbackInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PushbackInputStream
的使用

没有 java.io.PushbackInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.PushbackReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PushbackReader
的使用

没有 java.io.PushbackReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.RandomAccessFile 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.RandomAccessFile
的使用

使用 RandomAccessFile 的软件包
javax.imageio.stream Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio.stream 中 RandomAccessFile 的使用

参数类型为 RandomAccessFile 的 javax.imageio.stream 中的构造方法
FileImageInputStream(RandomAccessFile raf)
构造一个将从给定 RandomAccessFile 进行读取的 FileImageInputStream。
FileImageOutputStream(RandomAccessFile raf)
构造一个向给定 FileImageOutputStream 进行写入的 RandomAccessFile。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.Reader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.Reader
的使用

使用 Reader 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。

java.awt.datatransfer 中 Reader 的使用

返回 Reader 的 java.awt.datatransfer 中的方法
 Reader DataFlavor.getReaderForText(Transferable transferable)
获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。

java.io 中 Reader 的使用

java.io 中 Reader 的子类
class | BufferedReader 从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。
class | CharArrayReader 此类实现一个可用作字符输入流的字符缓冲区。
class | FileReader 用来读取字符文件的便捷类。
class | FilterReader 用于读取已过滤的字符流的抽象类。
class | InputStreamReader InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。
class | LineNumberReader 跟踪行号的缓冲字符输入流。
class | PipedReader 传送的字符输入流。
class | PushbackReader 允许将字符推回到流的字符流 reader。
class | StringReader 其源为一个字符串的字符流。

声明为 Reader 的 java.io 中的字段
protected  Reader FilterReader.in
底层字符输入流。

返回 Reader 的 java.io 中的方法
 Reader Console.reader()
获取与此控制台关联的唯一 Reader 对象。

参数类型为 Reader 的 java.io 中的构造方法
BufferedReader(Reader in)
创建一个使用默认大小输入缓冲区的缓冲字符输入流。
BufferedReader(Reader in, int sz)
创建一个使用指定大小输入缓冲区的缓冲字符输入流。
FilterReader(Reader in)
创建一个新的 filtered reader。
LineNumberReader(Reader in)
使用默认输入缓冲区的大小创建新的行编号 reader。
LineNumberReader(Reader in, int sz)
创建新的行编号 reader，将字符读入给定大小的缓冲区。
PushbackReader(Reader in)
创建具有单字符推回缓冲区的新推回 reader。
PushbackReader(Reader in, int size)
创建具有给定大小推回缓冲区的新推回 reader。
StreamTokenizer(Reader r)
创建解析给定字符流的标记生成器。

java.nio.channels 中 Reader 的使用

返回 Reader 的 java.nio.channels 中的方法
static Reader | Channels.newReader(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap) 构造一个 reader，它用给定的解码器对取自给定信道的字节进行解码。
static Reader | Channels.newReader(ReadableByteChannel ch, String csName) 构造一个 reader，它根据命名的 charset 对取自给定信道的字节进行解码。

java.sql 中 Reader 的使用

返回 Reader 的 java.sql 中的方法
Reader | Clob.getCharacterStream() 以 java.io.Reader 对象形式（或字符流形式）获取此 Clob 对象指定的 CLOB 值。
Reader | SQLXML.getCharacterStream() 以 java.io.Reader 对象的形式获取此 SQLXML 实例指定的 XML 值。
Reader | CallableStatement.getCharacterStream(int parameterIndex) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Reader | ResultSet.getCharacterStream(int columnIndex) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | Clob.getCharacterStream(long pos, long length) 返回包含部分 Clob 值的 Reader 对象，该值从 pos 指定的字符开始，长度为 length 个字符。
Reader | CallableStatement.getCharacterStream(String parameterName) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Reader | ResultSet.getCharacterStream(String columnLabel) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | CallableStatement.getNCharacterStream(int parameterIndex) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Reader | ResultSet.getNCharacterStream(int columnIndex) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | CallableStatement.getNCharacterStream(String parameterName) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Reader | ResultSet.getNCharacterStream(String columnLabel) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | SQLInput.readCharacterStream() 读取流中的下一个属性并将其作为 Unicode 字符流返回。

参数类型为 Reader 的 java.sql 中的方法
void | PreparedStatement.setCharacterStream(int parameterIndex, Reader reader) 将指定参数设置为给定 Reader 对象。
void | PreparedStatement.setCharacterStream(int parameterIndex, Reader reader, int length) 将给定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
void | PreparedStatement.setCharacterStream(int parameterIndex, Reader reader, long length) 将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
void | CallableStatement.setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | CallableStatement.setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数。
void | CallableStatement.setCharacterStream(String parameterName, Reader reader, long length) 将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
void | PreparedStatement.setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | PreparedStatement.setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | CallableStatement.setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | CallableStatement.setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | PreparedStatement.setNCharacterStream(int parameterIndex, Reader value) 将指定参数设置为 Reader 对象。
void | PreparedStatement.setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | CallableStatement.setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | CallableStatement.setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | PreparedStatement.setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | PreparedStatement.setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | CallableStatement.setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | CallableStatement.setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | ResultSet.updateCharacterStream(int columnIndex, Reader x) 用字符流值更新指定的列。
void | ResultSet.updateCharacterStream(int columnIndex, Reader x, int length) 用字符流值更新指定列，该列将具有指定字节数。
void | ResultSet.updateCharacterStream(int columnIndex, Reader x, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateCharacterStream(String columnLabel, Reader reader) 用字符流值更新指定列。
void | ResultSet.updateCharacterStream(String columnLabel, Reader reader, int length) 用字符流值更新指定列，该列具有指定的字节数。
void | ResultSet.updateCharacterStream(String columnLabel, Reader reader, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateClob(int columnIndex, Reader reader) 使用给定的 Reader 对象更新指定列。
void | ResultSet.updateClob(int columnIndex, Reader reader, long length) 使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
void | ResultSet.updateClob(String columnLabel, Reader reader) 使用给定的 Reader 对象更新指定列。
void | ResultSet.updateClob(String columnLabel, Reader reader, long length) 使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
void | ResultSet.updateNCharacterStream(int columnIndex, Reader x) 用字符流值更新指定的列。
void | ResultSet.updateNCharacterStream(int columnIndex, Reader x, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateNCharacterStream(String columnLabel, Reader reader) 用字符流值更新指定的列。
void | ResultSet.updateNCharacterStream(String columnLabel, Reader reader, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateNClob(int columnIndex, Reader reader) 使用给定的 Reader 对象更新指定列。
void | ResultSet.updateNClob(int columnIndex, Reader reader, long length) 使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
void | ResultSet.updateNClob(String columnLabel, Reader reader) 使用给定的 Reader 对象更新指定列。
void | ResultSet.updateNClob(String columnLabel, Reader reader, long length) 使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
void | SQLOutput.writeCharacterStream(Reader x) 将下一个属性作为 Unicode 字符的流写入流中。

java.util 中 Reader 的使用

参数类型为 Reader 的 java.util 中的方法
 void Properties.load(Reader reader)
按简单的面向行的格式从输入字符流中读取属性列表（键和元素对）。

参数类型为 Reader 的 java.util 中的构造方法
PropertyResourceBundle(Reader reader)
根据 Reader 创建属性资源包。

javax.print 中 Reader 的使用

返回 Reader 的 javax.print 中的方法
Reader | Doc.getReaderForText() 获得一个从此 doc 中提取字符打印数据的 reader。
Reader | SimpleDoc.getReaderForText() 获得一个从此 doc 中提取字符打印数据的 reader。

javax.script 中 Reader 的使用

声明为 Reader 的 javax.script 中的字段
protected  Reader SimpleScriptContext.reader
此字段是用于脚本输入的 reader。

返回 Reader 的 javax.script 中的方法
Reader | ScriptContext.getReader() 返回脚本用来读取输入的 Reader。
Reader | SimpleScriptContext.getReader() 返回脚本用来读取输入的 Reader。

参数类型为 Reader 的 javax.script 中的方法
 CompiledScript Compilable.compile(Reader script)
编译脚本（从 Reader 读取的源），以便以后执行。
 Object AbstractScriptEngine.eval(Reader reader)
eval(Reader) 调用抽象 eval(Reader, ScriptContext)，并传递 context 字段的值给它。
 Object ScriptEngine.eval(Reader reader)
除了脚本的源是以 Reader 形式提供的外，与 eval(String) 相同。
 Object AbstractScriptEngine.eval(Reader reader, Bindings bindings)
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。
 Object ScriptEngine.eval(Reader reader, Bindings n)
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。
 Object ScriptEngine.eval(Reader reader, ScriptContext context)
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。
 void ScriptContext.setReader(Reader reader)
设置脚本的 Reader，以读取输入。
 void SimpleScriptContext.setReader(Reader reader)
设置脚本的 Reader，以读取输入。

javax.sql 中 Reader 的使用

参数类型为 Reader 的 javax.sql 中的方法
void | RowSet.setCharacterStream(int parameterIndex, Reader reader) 将此 RowSet 对象命令中的指定参数设置为给定 Reader 对象。
void | RowSet.setCharacterStream(int parameterIndex, Reader reader, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.Reader 值。
void | RowSet.setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | RowSet.setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数目。
void | RowSet.setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(int parameterIndex, Reader value) 将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。

javax.sql.rowset 中 Reader 的使用

声明为 Reader 的 javax.sql.rowset 中的字段
protected  Reader BaseRowSet.charStream
将由方法 getCharacterStream 返回的 Reader 对象，该方法在 ResultSet 接口中指定。

参数类型为 Reader 的 javax.sql.rowset 中的方法
void | WebRowSet.readXml(Reader reader) 从给定的 Reader 对象以其 XML 格式读取 WebRowSet 对象。
void | BaseRowSet.setCharacterStream(int parameterIndex, Reader reader) 将此 RowSet 对象命令中的指定参数设置为给定的 Reader 对象。
void | BaseRowSet.setCharacterStream(int parameterIndex, Reader reader, int length) 将指定参数设置为给定的 java.io.Reader 对象，该对象具有指定的字符数。
void | BaseRowSet.setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | BaseRowSet.setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定的 Reader 对象，该对象是给定的字符长度数目。
void | BaseRowSet.setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNCharacterStream(int parameterIndex, Reader value) 将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
void | BaseRowSet.setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。

javax.sql.rowset.serial 中 Reader 的使用

返回 Reader 的 javax.sql.rowset.serial 中的方法
Reader | SerialClob.getCharacterStream() 以 Unicode 字符流的形式返回此 SerialClob 对象的数据。
Reader | SerialClob.getCharacterStream(long pos, long length)
Reader | SQLInputImpl.readCharacterStream() 以 Unicode 字符流的形式获取此 SQLInputImpl 对象中的下一个属性。

参数类型为 Reader 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeCharacterStream(Reader x)
将 Unicode 字符流写入此 SQLOutputImpl 对象。

javax.sql.rowset.spi 中 Reader 的使用

参数类型为 Reader 的 javax.sql.rowset.spi 中的方法
 void XmlReader.readXML(WebRowSet caller, Reader reader)
从给定的 XML 格式的输入流读取并解析给定的 WebRowSet 对象。

javax.swing.text 中 Reader 的使用

参数类型为 Reader 的 javax.swing.text 中的方法
void | DefaultEditorKit.read(Reader in, Document doc, int pos) 插入取自给定流的内容，它将被视为纯文本。
abstract void | EditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
void | JTextComponent.read(Reader in, Object desc) 根据流进行初始化。

javax.swing.text.html 中 Reader 的使用

参数类型为 Reader 的 javax.swing.text.html 中的方法
void | StyleSheet.loadRules(Reader in, URL ref) 加载 CSS1 语法中指定的规则集合。
abstract void | HTMLEditorKit.Parser.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet) 解析给定的流并通过解析的结果驱动给定的回调。
void | HTMLEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容。

javax.swing.text.html.parser 中 Reader 的使用

参数类型为 Reader 的 javax.swing.text.html.parser 中的方法
void | Parser.parse(Reader in) 在给定 DTD 的情况下，解析 HTML 流。
void | DocumentParser.parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
void | ParserDelegator.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)

javax.swing.text.rtf 中 Reader 的使用

参数类型为 Reader 的 javax.swing.text.rtf 中的方法
 void RTFEditorKit.read(Reader in, Document doc, int pos)
插入来自给定流的内容，该内容将被视为纯文本。

javax.tools 中 Reader 的使用

返回 Reader 的 javax.tools 中的方法
 Reader FileObject.openReader(boolean ignoreEncodingErrors)
获取此对象的 reader。
 Reader ForwardingFileObject.openReader(boolean ignoreEncodingErrors)
 Reader SimpleJavaFileObject.openReader(boolean ignoreEncodingErrors)
在 Reader 中包装 SimpleJavaFileObject.getCharContent(boolean) 的结果。

javax.xml.bind 中 Reader 的使用

参数类型为 Reader 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(Reader reader)
从指定的 Reader 解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 Reader 的使用

参数类型为 Reader 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(Reader reader)

javax.xml.stream 中 Reader 的使用

参数类型为 Reader 的 javax.xml.stream 中的方法
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(Reader reader) 根据 reader 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(String systemId, Reader reader) 根据 reader 创建一个新 XMLEventReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(Reader reader) 根据 reader 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(String systemId, Reader reader) 根据 java.io.InputStream 创建一个新 XMLStreamReader。

javax.xml.transform.stream 中 Reader 的使用

返回 Reader 的 javax.xml.transform.stream 中的方法
 Reader StreamSource.getReader()
获取通过 setReader 设置的字符流。

参数类型为 Reader 的 javax.xml.transform.stream 中的方法
 void StreamSource.setReader(Reader reader)
调用要作为字符 reader 的输入。

参数类型为 Reader 的 javax.xml.transform.stream 中的构造方法
StreamSource(Reader reader)
从字符 reader 构造 StreamSource。
StreamSource(Reader reader, String systemId)
从字符 reader 构造 StreamSource。

org.w3c.dom.ls 中 Reader 的使用

返回 Reader 的 org.w3c.dom.ls 中的方法
 Reader LSInput.getCharacterStream()
依赖于语言和绑定类型的属性，表示 16 位单元流。

参数类型为 Reader 的 org.w3c.dom.ls 中的方法
 void LSInput.setCharacterStream(Reader characterStream)
依赖于语言和绑定类型的属性，表示 16 位单元的流。

org.xml.sax 中 Reader 的使用

返回 Reader 的 org.xml.sax 中的方法
 Reader InputSource.getCharacterStream()
获取此输入源的字符流。

参数类型为 Reader 的 org.xml.sax 中的方法
 void InputSource.setCharacterStream(Reader characterStream)
设置此输入源的字符流。

参数类型为 Reader 的 org.xml.sax 中的构造方法
InputSource(Reader characterStream)
使用字符流创建新的输入源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.SequenceInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.SequenceInputStream
的使用

没有 java.io.SequenceInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.io.Serializable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.Serializable
的使用

使用 Serializable 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.atomic | 类的小工具包，支持在单个变量上解除锁的线程安全编程。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.jws |
javax.jws.soap |
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.namespace | XML 名称空间处理。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.SendingContext | 为值类型的编组提供支持。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。

java.applet 中 Serializable 的使用

实现 Serializable 的 java.applet 中的类
class | Applet applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。
protected class | Applet.AccessibleApplet 此类实现对 Applet 类的可访问性支持。

java.awt 中 Serializable 的使用

实现 Serializable 的 java.awt 中的类
class | AWTError 当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。
class | AWTEvent 所有 AWT 事件的根事件类。
class | AWTException 表示发生了 Absract Window Toolkit 异常。
class | AWTKeyStroke AWTKeyStroke 表示键盘（或等效输入设备）上的键操作。
class | AWTPermission 此类用于 AWT 权限。
class | BorderLayout 这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。
class | Button 此类创建一个标签按钮。
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
class | Canvas Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
protected class | Canvas.AccessibleAWTCanvas 此类实现对 Canvas 类的可访问性支持。
class | CardLayout CardLayout 对象是容器的布局管理器。
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
class | CheckboxGroup CheckboxGroup 类用于集合 Checkbox 按钮集。
class | CheckboxMenuItem 此类表示一个可包括在菜单中的复选框。
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
class | Choice Choice 类表示一个弹出式选择菜单。
protected class | Choice.AccessibleAWTChoice 此类实现对 Choice 类的可访问性支持。
class | Color Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
class | Component component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
protected class | Component.AccessibleAWTComponent 用来为可访问性提供默认支持的 Component 的内部类。
static class | Component.BaselineResizeBehavior 常见方式的枚举，指示组件的基线可以随大小的更改而更改。
class | ComponentOrientation ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。
class | Container 一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
protected class | Container.AccessibleAWTContainer 用于对可访问性提供默认支持的 Container 内部类。
class | ContainerOrderFocusTraversalPolicy 根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
class | Cursor 封装鼠标光标的位图表示形式的类。
class | DefaultFocusTraversalPolicy 根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
static class | Desktop.Action 表示动作类型。
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
static class | Dialog.ModalExclusionType 任何顶层窗口都可以标记为不受模式对话框阻塞。
static class | Dialog.ModalityType 模式对话框阻塞对某些顶层窗口的所有输入。
class | Dimension Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
class | Event 注：Event 类已废弃，只可用于向后兼容。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | FlowLayout 流布局用于安排有向流中的组件，这非常类似于段落中的文本行。
class | Font Font 类表示字体，可以使用它以可见方式呈现文本。
class | FontFormatException 此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。
class | FontMetrics FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
class | Frame Frame 是带有标题和边框的顶层窗口。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。
class | GraphicsConfigTemplate GraphicsConfigTemplate 类用于获得有效的 GraphicsConfiguration。
class | GridBagConstraints GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。
class | GridBagLayout GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。
class | GridBagLayoutInfo GridBagLayoutInfo 是 GridBagLayout 布局管理器的一个实用工具类。
class | GridLayout GridLayout 类是一个布局处理器，它以矩形网格形式对容器的组件进行布置。
class | HeadlessException 在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
class | IllegalComponentStateException 当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。
class | Insets Insets 对象是容器边界的表示形式。
class | Label Label 对象是一个可在容器中放置文本的组件。
protected class | Label.AccessibleAWTLabel 此类实现对 Label 类的可访问性支持。
class | List List 组件为用户提供了一个可滚动的文本项列表。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | List.AccessibleAWTList.AccessibleAWTListChild 此类实现 List 子级的可访问性支持。
class | MediaTracker MediaTracker 类是一个跟踪多种媒体对象状态的实用工具类。
class | Menu Menu 对象是从菜单栏部署的下拉式菜单组件。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
class | MenuBar MenuBar 类封装绑定到框架的菜单栏的平台概念。
protected class | MenuBar.AccessibleAWTMenuBar 菜单栏的内部类，用于为可访问性提供默认支持。
class | MenuComponent 抽象类 MenuComponent 是所有与菜单相关的组件的超类。
protected class | MenuComponent.AccessibleAWTMenuComponent 用于为可访问性提供默认支持的 MenuComponent 的内部类。
class | MenuItem 菜单中的所有项必须属于类 MenuItem 或其子类之一。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
class | MenuShortcut 表示 MenuItem 键盘加速器的 MenuShortcut 类。
static class | MultipleGradientPaint.ColorSpaceType 在其中执行渐变插值操作的颜色空间。
static class | MultipleGradientPaint.CycleMethod 在渐变边界以外进行绘制时使用的方法。
class | Panel Panel 是最简单的容器类。
protected class | Panel.AccessibleAWTPanel 此类实现 Panel 类的可访问性支持。
class | Point 表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
class | Polygon Polygon 类封装了坐标空间中封闭的二维区域的描述。
class | PopupMenu 此类实现能够在组件中的指定位置上动态弹出的菜单。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。
class | Rectangle Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
protected class | Scrollbar.AccessibleAWTScrollBar 此类实现 Scrollbar 类的可访问性支持。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
protected class | ScrollPane.AccessibleAWTScrollPane 此类实现 ScrollPane 类的可访问性支持。
class | ScrollPaneAdjustable 此类表示 ScrollPane 的水平或垂直滚动条的状态。
class | SystemColor 封装表示系统中本机 GUI 对象颜色的象征性颜色的类。
class | TextArea TextArea 对象是显示文本的多行区域。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
class | TextComponent TextComponent 类是所有允许编辑文本的组件的超类。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
class | TextField TextField 对象是允许编辑单行文本的文本组件。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。
static class | TrayIcon.MessageType MessageType 确定哪个图标将显示在消息标题中，以及消息根据显示生成的可能的系统声音。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。
protected class | Window.AccessibleAWTWindow 此类实现对 Window 类的可访问性支持。

java.awt.color 中 Serializable 的使用

实现 Serializable 的 java.awt.color 中的类
class | CMMException 如果本机 CMM 返回一个错误，则抛出此异常。
class | ColorSpace 此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。
class | ICC_ColorSpace ICC_ColorSpace 类是抽象 ColorSpace 类的实现。
class | ICC_Profile 与设备无关和设备相关颜色空间的颜色配置文件数据表示形式，该表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。
class | ICC_ProfileGray ICC_Profile 类的子类，表示满足以下标准的配置文件：配置文件的颜色空间类型是 TYPE_GRAY，并且配置文件包括 grayTRCTag 和 mediaWhitePointTag 标记。
class | ICC_ProfileRGB ICC_ProfileRGB 类是 ICC_Profile 类的子类，它表示满足以下标准的配置文件： 配置文件的颜色空间类型是 RGB。
class | ProfileDataException 当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

java.awt.datatransfer 中 Serializable 的使用

实现 Serializable 的 java.awt.datatransfer 中的类
class | DataFlavor DataFlavor 提供有关数据的元信息。
class | FlavorEvent FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。
class | MimeTypeParseException 对分析相关异常的 MimeType 进行封装的类
class | UnsupportedFlavorException 在此 flavor 中不支持所请求的数据的信号。

java.awt.dnd 中 Serializable 的使用

实现 Serializable 的 java.awt.dnd 中的类
class | DragGestureEvent 当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。
class | DragGestureRecognizer DragGestureRecognizer 是一个针对与平台相关的侦听器规范的抽象基类，它可以与特定 Component 关联以标识与平台相关的拖动开始动作。
class | DragSource DragSource 是负责开始 Drag 和 Drop 操作的实体，可以用在如下场景中： JVM 生命周期中每个 JVM 的一个默认实例。
class | DragSourceContext DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。
class | DragSourceDragEvent 通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。
class | DragSourceDropEvent 通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。
class | DragSourceEvent 此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。
class | DropTarget 在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
class | DropTargetContext 每当与 Drag 和 Drop 操作相关的逻辑光标和与 DropTarget 相关的 Component 的可见几何结构重合时，就创建一个 DropTargetContext。
class | DropTargetDragEvent 通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。
class | DropTargetDropEvent 通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。
class | DropTargetEvent DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。
class | InvalidDnDOperationException java.awt.dnd 包中的各种方法都会抛出此异常。
class | MouseDragGestureRecognizer DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

java.awt.event 中 Serializable 的使用

实现 Serializable 的 java.awt.event 中的类
class | ActionEvent 指示发生了组件定义的动作的语义事件。
class | AdjustmentEvent 由 Adjustable 对象所发出的调整事件。
class | ComponentEvent 指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
class | ContainerEvent 指示容器内容因为添加或移除组件而更改的低级别事件。
class | FocusEvent 指示 Component 已获得或失去输入焦点的低级别事件。
class | HierarchyEvent 指示 Component 所属的 Component 层次结构发生更改的事件。
class | InputEvent 所有组件级别输入事件的根事件类。
class | InputMethodEvent 输入方法事件包含有关使用输入方法进行撰写的文本的信息。
class | InvocationEvent 当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。
class | ItemEvent 指示项被选定或取消选定的语义事件。
class | KeyEvent 表示组件中发生键击的事件。
class | MouseEvent 指示组件中发生鼠标动作的事件。
class | MouseWheelEvent 表示鼠标滚轮在组件中滚动的事件。
class | PaintEvent 组件级绘制事件。
class | TextEvent 指示对象文本已改变的语义事件。
class | WindowEvent 指示窗口状态改变的低级别事件。

java.awt.font 中 Serializable 的使用

实现 Serializable 的 java.awt.font 中的类
class | NumericShaper NumericShaper 类用于将 Latin-1（欧洲语）数字转换成其他 Unicode 十进制数字。
class | TextAttribute TextAttribute 类定义用于呈现文本的属性键和属性值。
class | TransformAttribute TransformAttribute 类为转换提供一个不可变的包装器，使其可以安全地作为属性使用。

java.awt.geom 中 Serializable 的使用

实现 Serializable 的 java.awt.geom 中的类
class | AffineTransform AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。
static class | CubicCurve2D.Double 使用 double 坐标指定的三次参数曲线段。
static class | CubicCurve2D.Float 使用 float 坐标指定的三次参数曲线段。
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。
class | GeneralPath GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
class | IllegalPathStateException 对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。
static class | Line2D.Double 使用 double 坐标指定的线段。
static class | Line2D.Float 使用 float 坐标指定的线段。
class | NoninvertibleTransformException NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。
static class | Path2D.Double Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
static class | Path2D.Float Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
static class | Point2D.Double Double 类以 double 精度定义指定的点。
static class | Point2D.Float Float 类以 float 精度定义指定的点。
static class | QuadCurve2D.Double 使用 double 坐标指定的二次参数曲线段。
static class | QuadCurve2D.Float 使用 float 坐标指定的二次参数曲线段。
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

java.awt.image 中 Serializable 的使用

实现 Serializable 的 java.awt.image 中的类
class | ImagingOpException 如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
class | RasterFormatException 如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

java.awt.image.renderable 中 Serializable 的使用

实现 Serializable 的 java.awt.image.renderable 中的类
 class ParameterBlock
ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。

java.awt.print 中 Serializable 的使用

实现 Serializable 的 java.awt.print 中的类
class | PrinterAbortException PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
class | PrinterException PrinterException 类及其子类用于指示打印系统中发生的异常情况。
class | PrinterIOException PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

java.beans 中 Serializable 的使用

实现 Serializable 的 java.beans 中的类
class | IndexedPropertyChangeEvent 无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。
class | IntrospectionException 在 Introspection 期间发生异常时抛出异常。
class | PropertyChangeEvent 无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
class | PropertyChangeSupport 这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。
class | PropertyVetoException 当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。
class | VetoableChangeSupport 这是一个实用工具类，支持约束 (constrained) 属性的 bean 可以使用此类。

java.beans.beancontext 中 Serializable 的使用

实现 Serializable 的 java.beans.beancontext 中的类
class | BeanContextChildSupport 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
class | BeanContextEvent BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。
class | BeanContextMembershipEvent BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。
class | BeanContextServiceAvailableEvent BeanContextServicesListener 使用此事件类型来标识将被注册的服务。
class | BeanContextServiceRevokedEvent BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
protected class | BeanContextServicesSupport.BCSSChild
protected static class | BeanContextServicesSupport.BCSSServiceProvider 子类可以为此嵌套类创建子类，以便为每个 BeanContextServicesProvider 添加行为。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。
protected class | BeanContextSupport.BCSChild

返回 Serializable 的 java.beans.beancontext 中的方法
protected static Serializable BeanContextSupport.getChildSerializable(Object child)
获得与指定 Child 相关联的 Serializable（如果有）

java.io 中 Serializable 的使用

java.io 中 Serializable 的子接口
 interface Externalizable
Externalizable 实例类的唯一特性是可以被写入序列化流中，该类负责保存和恢复实例内容。

实现 Serializable 的 java.io 中的类
class | CharConversionException 用于字符转换异常的基类。
class | EOFException 当输入过程中意外到达文件或流的末尾时，抛出此异常。
class | File 文件和目录路径名的抽象表示形式。
class | FileNotFoundException 当试图打开指定路径名表示的文件失败时，抛出此异常。
class | FilePermission 此类表示对文件和目录的访问。
class | InterruptedIOException I/O 操作已中断信号，抛出此异常。
class | InvalidClassException 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
class | InvalidObjectException 指示一个或多个反序列化对象未通过验证测试。
class | IOError 当发生严重的 I/O 错误时，抛出此错误。
class | IOException 当发生某种 I/O 异常时，抛出此异常。
class | NotActiveException 当序列化和反序列化不活动时，抛出此异常。
class | NotSerializableException 当实例需要具有序列化接口时，抛出此异常。
class | ObjectStreamClass 类的序列化描述符。
class | ObjectStreamException 特定于 Object Stream 类的所有异常的超类。
class | OptionalDataException 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
class | SerializablePermission 此类用于可序列化权限。
class | StreamCorruptedException 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
class | SyncFailedException 当 sync 操作失败时，抛出此异常。
class | UnsupportedEncodingException 不支持字符编码。
class | UTFDataFormatException 在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
class | WriteAbortedException 在写入操作过程中抛出 ObjectStreamException 之一的信号。

java.lang 中 Serializable 的使用

实现 Serializable 的 java.lang 中的类
class | AbstractMethodError 当应用程序试图调用一个抽象方法时，抛出此错误。
class | ArithmeticException 当出现异常的运算条件时，抛出此异常。
class | ArrayIndexOutOfBoundsException 用非法索引访问数组时抛出的异常。
class | ArrayStoreException 试图将错误类型的对象存储到一个对象数组时抛出的异常。
class | AssertionError 抛出该异常指示某个断言失败。
class | Boolean Boolean 类将基本类型为 boolean 的值包装在一个对象中。
class | Byte Byte 类将基本类型 byte 的值包装在一个对象中。
class | Character Character 类在对象中包装一个基本类型 char 的值。
class | Class<T> Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
class | ClassCastException 当试图将对象强制转换为不是实例的子类时，抛出该异常。
class | ClassCircularityError 当初始化类时检测到类的循环调用的时候，抛出该错误。
class | ClassFormatError 当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
class | ClassNotFoundException 当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
class | CloneNotSupportedException 当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
class | Double Double 类在对象中包装一个基本类型 double 的值。
class | Enum<E extends Enum<E>> 这是所有 Java 语言枚举类型的公共基本类。
class | EnumConstantNotPresentException 当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
class | Error Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
class | Exception Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
class | ExceptionInInitializerError 静态初始化程序中发生意外异常的信号。
class | Float Float 类在对象中包装一个基本类型 float 的值。
class | IllegalAccessError 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
class | IllegalAccessException 当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
class | IllegalArgumentException 抛出的异常表明向方法传递了一个不合法或不正确的参数。
class | IllegalMonitorStateException 抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
class | IllegalStateException 在非法或不适当的时间调用方法时产生的信号。
class | IllegalThreadStateException 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
class | IncompatibleClassChangeError 在某些类定义中出现不兼容的类更改时抛出该异常。
class | IndexOutOfBoundsException 指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
class | InstantiationError 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
class | InstantiationException 当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
class | Integer Integer 类在对象中包装了一个基本类型 int 的值。
class | InternalError 该异常指示 Java 虚拟机中出现一些意外的内部错误。
class | InterruptedException 当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
class | LinkageError LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
class | Long Long 类在对象中包装了基本类型 long 的值。
class | NegativeArraySizeException 如果应用程序试图创建大小为负的数组，则抛出该异常。
class | NoClassDefFoundError 当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
class | NoSuchFieldError 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
class | NoSuchFieldException 类不包含指定名称的字段时产生的信号。
class | NoSuchMethodError 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
class | NoSuchMethodException 无法找到某一特定方法时，抛出该异常。
class | NullPointerException 当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
class | Number 抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
class | NumberFormatException 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
class | OutOfMemoryError 因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
class | RuntimeException RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
class | RuntimePermission 该类用于运行时权限。
class | SecurityException 由安全管理器抛出的异常，指示存在安全侵犯。
class | Short Short 类在对象中包装基本类型 short 的值。
class | StackOverflowError 当应用程序递归太深而发生堆栈溢出时，抛出该错误。
class | StackTraceElement 堆栈跟踪中的元素，它由 Throwable.getStackTrace() 返回。
class | String String 类代表字符串。
class | StringBuffer 线程安全的可变字符序列。
class | StringBuilder 一个可变的字符序列。
class | StringIndexOutOfBoundsException 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
static class | Thread.State 线程状态。
class | ThreadDeath 调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。
class | Throwable Throwable 类是 Java 语言中所有错误或异常的超类。
class | TypeNotPresentException 当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
class | UnknownError 当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。
class | UnsatisfiedLinkError 当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
class | UnsupportedClassVersionError 当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
class | UnsupportedOperationException 当不支持请求的操作时，抛出该异常。
class | VerifyError 当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。
class | VirtualMachineError 当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

java.lang.annotation 中 Serializable 的使用

实现 Serializable 的 java.lang.annotation 中的类
class | AnnotationFormatError 当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。
class | AnnotationTypeMismatchException 若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
class | ElementType 程序元素类型。
class | IncompleteAnnotationException 若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。
class | RetentionPolicy 注释保留策略。

java.lang.instrument 中 Serializable 的使用

实现 Serializable 的 java.lang.instrument 中的类
class | IllegalClassFormatException 当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。
class | UnmodifiableClassException 在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

java.lang.management 中 Serializable 的使用

实现 Serializable 的 java.lang.management 中的类
class | ManagementPermission 使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。
class | MemoryType 内存池的类型。

java.lang.reflect 中 Serializable 的使用

实现 Serializable 的 java.lang.reflect 中的类
class | GenericSignatureFormatError 当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。
class | InvocationTargetException InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。
class | MalformedParameterizedTypeException 当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
class | Proxy Proxy 提供用于创建动态代理类和实例的静态方法，它还是由这些方法创建的所有动态代理类的超类。
class | ReflectPermission 反射操作的 Permission 类。
class | UndeclaredThrowableException 如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

java.math 中 Serializable 的使用

实现 Serializable 的 java.math 中的类
class | BigDecimal 不可变的、任意精度的有符号十进制数。
class | BigInteger 不可变的任意精度的整数。
class | MathContext 该对象是封装上下文设置的不可变对象，它描述数字运算符的某些规则，例如由 BigDecimal 类实现的规则。
class | RoundingMode 为可能丢弃精度的数值操作指定一种舍入行为。

java.net 中 Serializable 的使用

实现 Serializable 的 java.net 中的类
static class | Authenticator.RequestorType 请求验证的实体的类型。
class | BindException 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
class | ConnectException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | HttpRetryException 抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
class | Inet4Address 此类表示 Internet Protocol version 4 (IPv4) 地址。
class | Inet6Address 此类表示互联网协议第 6 版 (IPv6) 地址。
class | InetAddress 此类表示互联网协议 (IP) 地址。
class | InetSocketAddress 此类实现 IP 套接字地址（IP 地址 + 端口号）。
class | MalformedURLException 抛出这一异常指示出现了错误的 URL。
class | NetPermission 此类可用于各种网络权限。
class | NoRouteToHostException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | PortUnreachableException 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
class | ProtocolException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
static class | Proxy.Type 表示代理类型。
class | SocketAddress 此类表示不带任何协议附件的 Socket Address。
class | SocketException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketPermission 此类表示通过套接字对网络的访问。
class | SocketTimeoutException 如果在读取或接受套接字时发生超时，则抛出此异常。
class | UnknownHostException 指示主机 IP 地址无法确定而抛出的异常。
class | UnknownServiceException 抛出这一异常指示出现了未知服务异常。
class | URI 表示一个统一资源标识符 (URI) 引用。
class | URISyntaxException 抛出经过检查的指示字符串不能解析为 URI 引用的异常。
class | URL 类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

java.nio 中 Serializable 的使用

实现 Serializable 的 java.nio 中的类
class | BufferOverflowException 当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
class | BufferUnderflowException 当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
class | InvalidMarkException 当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
class | ReadOnlyBufferException 当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

java.nio.channels 中 Serializable 的使用

实现 Serializable 的 java.nio.channels 中的类
class | AlreadyConnectedException 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
class | AsynchronousCloseException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
class | CancelledKeyException 当试图使用不再有效的选择键时，抛出此未经检查的异常。
class | ClosedByInterruptException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
class | ClosedChannelException 当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
class | ClosedSelectorException 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
class | ConnectionPendingException 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
class | FileLockInterruptionException 当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。
class | IllegalBlockingModeException 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
class | IllegalSelectorException 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
class | NoConnectionPendingException 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
class | NonReadableChannelException 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
class | NonWritableChannelException 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
class | NotYetBoundException 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | NotYetConnectedException 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | OverlappingFileLockException 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
class | UnresolvedAddressException 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
class | UnsupportedAddressTypeException 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

java.nio.charset 中 Serializable 的使用

实现 Serializable 的 java.nio.charset 中的类
class | CharacterCodingException 出现字符编码或解码错误时，抛出此经过检查的异常。
class | CoderMalfunctionError 当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。
class | IllegalCharsetNameException 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
class | MalformedInputException 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
class | UnmappableCharacterException 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。
class | UnsupportedCharsetException 当不支持请求的 charset 时，抛出此未经检查的异常。

java.rmi 中 Serializable 的使用

实现 Serializable 的 java.rmi 中的类
class | AccessException AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
class | AlreadyBoundException 如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
class | ConnectIOException 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
class | MarshalException 如果在编组远程调用标题、参数或远程方法调用的返回值时发生 java.io.IOException，则抛出 MarshalException。
class | MarshalledObject<T> MarshalledObject 包含一个字节流，该流具有给定了其构造方法的对象的序列化表示形式。
class | NoSuchObjectException 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
class | NotBoundException 如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
class | RemoteException RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
class | RMISecurityException 已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
class | ServerError 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
class | ServerException 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
class | ServerRuntimeException 已过时。 无替换版本
class | StubNotFoundException 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
class | UnexpectedException 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
class | UnmarshalException 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

java.rmi.activation 中 Serializable 的使用

实现 Serializable 的 java.rmi.activation 中的类
class | Activatable Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
class | ActivateFailedException 在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。
class | ActivationDesc 激活描述符包含激活对象所必需的信息： 对象的组标识符， 对象的完全限定的类名， 对象的代码基（类中的位置），一个代码基 URL 路径， 对象的重启“模式”，以及 一个可包含特定于对象的初始化数据的“编组”对象。
class | ActivationException 激活接口所使用的一般异常。
class | ActivationGroup ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
class | ActivationGroup_Stub ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。
class | ActivationGroupDesc 激活组描述符包含了创建/重建在其中激活对象的一个激活组所必需的信息。
static class | ActivationGroupDesc.CommandEnvironment ActivationGroup 实现的启动选项。
class | ActivationGroupID 针对一个注册激活组的标识符，它完成几个目标： 在激活系统中唯一地标识该组，以及 包含指向该组的激活系统的引用，以便该组在必要时能够联络上其激活系统。
class | ActivationID 激活利用特定的标识符来表示远程对象，对象能随着时间被激活。
class | UnknownGroupException 当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
class | UnknownObjectException 当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

java.rmi.dgc 中 Serializable 的使用

实现 Serializable 的 java.rmi.dgc 中的类
class | Lease 一个 lease 包含了一个唯一的 VM 标识符和一个租借期限。
class | VMID VMID 是跨所有 Java 虚拟机都唯一的标识符。

java.rmi.server 中 Serializable 的使用

java.rmi.server 中 Serializable 的子接口
interface | RemoteRef RemoteRef 表示远程对象的句柄。
interface | ServerRef ServerRef 表示远程对象实现的服务器端句柄。

实现 Serializable 的 java.rmi.server 中的类
class | ExportException ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
class | ObjID ObjID 是用于标识导出到 RMI 运行时的远程对象。
class | RemoteObject 该 RemoteObject 类实现远程对象的 java.lang.Object 行为。
class | RemoteObjectInvocationHandler 与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。
class | RemoteServer 该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
class | RemoteStub 该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
class | ServerCloneException 如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。
class | ServerNotActiveException 如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SocketSecurityException 已废弃的 ExportException 的子类。
class | UID UID 表示一个和生成它的主机的时间有关的唯一标识符，或者是 216 个“熟知”标识符之一。
class | UnicastRemoteObject 用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

java.security 中 Serializable 的使用

java.security 中 Serializable 的子接口
interface | Key Key 是所有密钥的顶层接口。
interface | PrivateKey 私钥。
interface | PublicKey 公钥。

实现 Serializable 的 java.security 中的类
class | AccessControlException 此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
class | AllPermission AllPermission 是暗含所有其他权限的权限。
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | BasicPermission BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
class | CodeSigner 此类封装关于代码签名者的信息。
class | CodeSource 此类扩展 codebase 的概念，不仅可以封装位置 (URL) 而且可以封装用于验证起源于该位置的签名代码的证书链。
class | DigestException 此为一般 Message Digest 异常。
class | GeneralSecurityException GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
class | GuardedObject GuardedObject 是一个用来保护对另一个对象的访问的对象。
class | Identity 已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | IdentityScope 已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | InvalidAlgorithmParameterException 用于无效或不合适的算法参数的异常。
class | InvalidKeyException 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
class | InvalidParameterException 当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
class | KeyException 此异常是基本的密钥异常。
class | KeyManagementException 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
class | KeyPair 此类是简单的密钥对（公钥和私钥）持有者。
class | KeyRep 已序列化的 Key 对象的标准表示形式。
static class | KeyRep.Type Key 类型。
class | KeyStoreException 这是一般的 KeyStore 异常。
class | NoSuchAlgorithmException 当请求特定的加密算法而它在该环境中不可用时抛出此异常。
class | NoSuchProviderException 当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
class | Permission 表示访问系统资源的抽象类。
class | PermissionCollection 表示 Permission 对象集合的抽象类。
class | Permissions 此类表示一个不同种类的 Permission 集合。
class | PrivilegedActionException doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。
class | ProviderException 用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。
class | SecureRandom 此类提供强加密随机数生成器 (RNG)。
class | SecureRandomSpi 此类为 SecureRandom 类定义了服务提供者接口 (SPI)。
class | SecurityPermission 此类用于安全权限。
class | SignatureException 这是一般的签名异常。
class | SignedObject SignedObject 是一个用来创建实际运行时对象的类，在检测不到这些对象的情况下，其完整性不会遭受损害。
class | Signer 已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。
class | Timestamp 此类封装有关签署时间戳的信息。
class | UnrecoverableEntryException 如果 keystore 中的某项无法恢复，则抛出此异常。
class | UnrecoverableKeyException 如果 keystore 中的密钥无法恢复，则抛出此异常。
class | UnresolvedPermission UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。

参数类型为 Serializable 的 java.security 中的构造方法
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

java.security.acl 中 Serializable 的使用

实现 Serializable 的 java.security.acl 中的类
class | AclNotFoundException 如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。
class | LastOwnerException 如果试图删除访问控制列表的最后一个所有者，则抛出此异常。
class | NotOwnerException 当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。

java.security.cert 中 Serializable 的使用

实现 Serializable 的 java.security.cert 中的类
class | Certificate 管理各种身份证书的抽象类。
protected static class | Certificate.CertificateRep 用于序列化的替换 Certificate 类。
class | CertificateEncodingException 证书编码异常。
class | CertificateException 此异常指示各种证书问题中的一种。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书尚无效异常。
class | CertificateParsingException 证书解析异常。
class | CertPath 不可变的证书序列（证书路径）。
protected static class | CertPath.CertPathRep 用于序列化的替换 CertPath 类。
class | CertPathBuilderException 指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
class | CertPathValidatorException 指示在验证一个证书路径时遇到了某种问题的异常。
class | CertStoreException 指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
class | CRLException CRL（证书撤消列表）异常。
class | X509Certificate X.509 证书的抽象类。

java.security.interfaces 中 Serializable 的使用

java.security.interfaces 中 Serializable 的子接口
interface | DSAPrivateKey DSA 专用密钥的标准接口。
interface | DSAPublicKey DSA 公用密钥的接口。
interface | ECPrivateKey 椭圆曲线 (EC) 专用密钥的接口。
interface | ECPublicKey 椭圆曲线 (EC) 公用密钥的接口。
interface | RSAMultiPrimePrivateCrtKey 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
interface | RSAPrivateCrtKey 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
interface | RSAPrivateKey RSA 专用密钥的接口。
interface | RSAPublicKey RSA 公用密钥的接口。

java.security.spec 中 Serializable 的使用

实现 Serializable 的 java.security.spec 中的类
class | InvalidKeySpecException 这是针对无效密钥规范的异常。
class | InvalidParameterSpecException 这是针对无效参数规范的异常。

java.sql 中 Serializable 的使用

实现 Serializable 的 java.sql 中的类
class | BatchUpdateException 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
class | ClientInfoStatus 无法通过调用 Connection.setClientInfo 设置属性的原因状态的枚举。
class | DataTruncation 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
class | RowIdLifetime RowId 生存期值的枚举。
class | SQLClientInfoException 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLException 提供关于数据库访问错误或其他错误信息的异常。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLNonTransientException 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
class | SQLPermission SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。
class | SQLRecoverableException 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
class | SQLTransientException 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
class | SQLWarning 提供关于数据库访问警告信息的异常。
class | Time 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。

java.text 中 Serializable 的使用

实现 Serializable 的 java.text 中的类
static class | AttributedCharacterIterator.Attribute 定义用于标识文本属性的属性键。
class | ChoiceFormat ChoiceFormat 允许将格式应用到某个范围的数。
class | DateFormat DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
static class | DateFormat.Field 定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
class | DateFormatSymbols DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。
class | DecimalFormat DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。
class | DecimalFormatSymbols 此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。
class | Format Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。
static class | Format.Field 定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。
class | MessageFormat MessageFormat 提供了以与语言无关方式生成连接消息的方式。
static class | MessageFormat.Field 在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
static class | Normalizer.Form 此枚举提供在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的四个 Unicode 标准化形式的常量，以及访问这些常量的两个方法。
class | NumberFormat NumberFormat 是所有数值格式的抽象基类。
static class | NumberFormat.Field 定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。
class | ParseException 表示解析时出现意外错误。
class | SimpleDateFormat SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。

java.util 中 Serializable 的使用

实现 Serializable 的 java.util 中的类
static class | AbstractMap.SimpleEntry<K,V> 维护键和值的 Entry。
static class | AbstractMap.SimpleImmutableEntry<K,V> 维护不可变的键和值的 Entry。
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | BitSet 此类实现了一个按需增长的位向量。
class | Calendar Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
class | ConcurrentModificationException 当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
class | Currency 表示货币。
class | Date 类 Date 表示特定的瞬间，精确到毫秒。
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | EmptyStackException 该异常由 Stack 类中的方法抛出，以表明堆栈为空。
class | EnumMap<K extends Enum<K>,V> 与枚举类型键一起使用的专用 Map 实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | EventObject 所有事件状态对象都将从其派生的根类。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
static class | Formatter.BigDecimalLayoutForm
class | FormatterClosedException 格式器已关闭时抛出的未经检查的异常。
class | GregorianCalendar GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。
class | HashMap<K,V> 基于哈希表的 Map 接口的实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | Hashtable<K,V> 此类实现一个哈希表，该哈希表将键映射到相应的值。
class | IdentityHashMap<K,V> 此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatException 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | InputMismatchException 由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
class | InvalidPropertiesFormatException 当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。
class | LinkedHashMap<K,V> Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | LinkedList<E> List 接口的链接列表实现。
class | Locale Locale 对象表示了特定的地理、政治和文化地区。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | MissingResourceException 缺少资源时抛出此异常。
class | NoSuchElementException 由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
class | PriorityQueue<E> 一个基于优先级堆的无界优先级队列。
class | Properties Properties 类表示了一个持久的属性集。
class | PropertyPermission 此类用于属性权限。
class | Random 此类的实例用于生成伪随机数流。
class | ServiceConfigurationError 在加载服务提供者的过程中出错时抛出的错误。
class | SimpleTimeZone SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | TimeZone TimeZone 表示时区偏移量，也可以计算夏令时。
class | TooManyListenersException TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。
class | TreeMap<K,V> 基于红黑树（Red-Black tree）的 NavigableMap 实现。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。
class | UUID 表示通用唯一标识符 (UUID) 的类。
class | Vector<E> Vector 类可以实现可增长的对象数组。

java.util.concurrent 中 Serializable 的使用

实现 Serializable 的 java.util.concurrent 中的类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | BrokenBarrierException 当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。
class | CancellationException 如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
class | ConcurrentHashMap<K,V> 支持获取的完全并发和更新的所期望可调整并发的哈希表。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | ConcurrentSkipListMap<K,V> 可缩放的并发 ConcurrentNavigableMap 实现。
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArrayList<E> ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
class | ExecutionException 当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | RejectedExecutionException 当无法执行某个任务时,由 Executor 抛出的异常。
class | Semaphore 一个计数信号量。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。
class | TimeoutException 阻塞操作超时时，抛出该异常。
class | TimeUnit TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。

java.util.concurrent.atomic 中 Serializable 的使用

实现 Serializable 的 java.util.concurrent.atomic 中的类
class | AtomicBoolean 可以用原子方式更新的 boolean 值。
class | AtomicInteger 可以用原子方式更新的 int 值。
class | AtomicIntegerArray 可以用原子方式更新其元素的 int 数组。
class | AtomicLong 可以用原子方式更新的 long 值。
class | AtomicLongArray 可以用原子方式更新其元素的 long 数组。
class | AtomicReference<V> 可以用原子方式更新的对象引用。
class | AtomicReferenceArray<E> 可以用原子方式更新其元素的对象引用数组。

java.util.concurrent.locks 中 Serializable 的使用

实现 Serializable 的 java.util.concurrent.locks 中的类
class | AbstractOwnableSynchronizer 可以由线程以独占方式拥有的同步器。
class | AbstractQueuedLongSynchronizer 以 long 形式维护同步状态的一个 AbstractQueuedSynchronizer 版本。
class | AbstractQueuedLongSynchronizer.ConditionObject 作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。
class | AbstractQueuedSynchronizer 为实现依赖于先进先出 (FIFO) 等待队列的阻塞锁和相关同步器（信号量、事件，等等）提供一个框架。
class | AbstractQueuedSynchronizer.ConditionObject AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。
class | ReentrantLock 一个可重入的互斥锁 Lock，它具有与使用 synchronized 方法和语句所访问的隐式监视器锁相同的一些基本行为和语义，但功能更强大。
class | ReentrantReadWriteLock 支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。
static class | ReentrantReadWriteLock.ReadLock ReentrantReadWriteLock.readLock() 方法返回的锁。
static class | ReentrantReadWriteLock.WriteLock ReentrantReadWriteLock.writeLock() 方法返回的锁。

java.util.jar 中 Serializable 的使用

实现 Serializable 的 java.util.jar 中的类
 class JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

java.util.logging 中 Serializable 的使用

实现 Serializable 的 java.util.logging 中的类
class | Level Level 类定义了一组可用来控制日志输出的标准日志级别。
class | LoggingPermission 当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。
class | LogRecord LogRecord 对象用于在日志框架和单个日志 Handler 之间传递日志请求。

java.util.prefs 中 Serializable 的使用

实现 Serializable 的 java.util.prefs 中的类
class | BackingStoreException 抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。
class | InvalidPreferencesFormatException 抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。
class | NodeChangeEvent Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。
class | PreferenceChangeEvent Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。

java.util.regex 中 Serializable 的使用

实现 Serializable 的 java.util.regex 中的类
class | Pattern 正则表达式的编译表示形式。
class | PatternSyntaxException 抛出未经检查的异常，表明正则表达式模式中的语法错误。

java.util.zip 中 Serializable 的使用

实现 Serializable 的 java.util.zip 中的类
class | DataFormatException 当数据格式发生错误时，抛出此异常。
class | ZipError 发生不可恢复的错误时抛出。
class | ZipException 如果某种 ZIP 异常发生，则抛出此错误。

javax.activation 中 Serializable 的使用

实现 Serializable 的 javax.activation 中的类
class | ActivationDataFlavor ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。
class | MimeType RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。
class | UnsupportedDataTypeException 当请求操作不支持请求的数据类型时，抛出此异常。

javax.activity 中 Serializable 的使用

实现 Serializable 的 javax.activity 中的类
class | ActivityCompletedException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
class | ActivityRequiredException 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
class | InvalidActivityException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

javax.annotation 中 Serializable 的使用

实现 Serializable 的 javax.annotation 中的类
static class Resource.AuthenticationType
资源的两种可能验证类型。

javax.annotation.processing 中 Serializable 的使用

实现 Serializable 的 javax.annotation.processing 中的类
 class FilerException
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

javax.crypto 中 Serializable 的使用

javax.crypto 中 Serializable 的子接口
 interface SecretKey
秘密（对称）密钥。

实现 Serializable 的 javax.crypto 中的类
class | BadPaddingException 当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
class | ExemptionMechanismException 此为一般 ExemptionMechanism 异常。
class | IllegalBlockSizeException 如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
class | NoSuchPaddingException 当请求特定填充机制但该环境中未提供时，抛出此异常。
class | SealedObject 此类使程序员能够用加密算法创建对象并保护其机密性。
class | ShortBufferException 当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

参数类型为 Serializable 的 javax.crypto 中的构造方法
SealedObject(Serializable object, Cipher c)
从任何 Serializable 对象构造一个 SealedObject。

javax.crypto.interfaces 中 Serializable 的使用

javax.crypto.interfaces 中 Serializable 的子接口
interface | DHPrivateKey Diffie-Hellman 私钥接口。
interface | DHPublicKey Diffie-Hellman 公钥接口。
interface | PBEKey 调用者 PBE 密钥接口。

javax.crypto.spec 中 Serializable 的使用

实现 Serializable 的 javax.crypto.spec 中的类
 class SecretKeySpec
此类以与 provider 无关的方式指定一个密钥。

javax.imageio 中 Serializable 的使用

实现 Serializable 的 javax.imageio 中的类
 class IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。

javax.imageio.metadata 中 Serializable 的使用

实现 Serializable 的 javax.imageio.metadata 中的类
 class IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

javax.jws 中 Serializable 的使用

实现 Serializable 的 javax.jws 中的类
static class WebParam.Mode
参数的流向。

javax.jws.soap 中 Serializable 的使用

实现 Serializable 的 javax.jws.soap 中的类
static class | SOAPBinding.ParameterStyle 参数到 SOAP 消息的映射关系的样式。
static class | SOAPBinding.Style SOAP 绑定样式。
static class | SOAPBinding.Use SOAP 绑定的使用。

javax.lang.model 中 Serializable 的使用

实现 Serializable 的 javax.lang.model 中的类
 class SourceVersion
Java™ 编程语言的源版本。

javax.lang.model.element 中 Serializable 的使用

实现 Serializable 的 javax.lang.model.element 中的类
class | ElementKind 元素的 kind。
class | Modifier 表示程序元素（如类、方法或字段）上的修饰符。
class | NestingKind 某一类型元素的嵌套种类 (nesting kind)。
class | UnknownAnnotationValueException 指示遇到一个未知种类的注释值。
class | UnknownElementException 指示遇到一个未知种类的元素。

javax.lang.model.type 中 Serializable 的使用

实现 Serializable 的 javax.lang.model.type 中的类
class | MirroredTypeException 当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
class | MirroredTypesException 当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
class | TypeKind 类型镜像的种类。
class | UnknownTypeException 指示遇到未知种类的类型。

javax.management 中 Serializable 的使用

javax.management 中 Serializable 的子接口
interface | Descriptor JMX 元素的附加元数据。
interface | NotificationFilter 可由作为通知过滤器的任何类来实现。
interface | QueryExp 表示可在数据库查询“where 子句”中使用的相关约束。
interface | ValueExp 表示可以作为参数传递给关系表达式的值。

实现 Serializable 的 javax.management 中的类
class | Attribute 通过将 MBean 属性名与其值相关联来表示 MBean 属性。
class | AttributeChangeNotification 提供 MBean 所发送的属性更改通知的定义。
class | AttributeChangeNotificationFilter 此类实现 attribute change notification 的 NotificationFilter 接口。
class | AttributeList 表示 MBean 属性值的列表。
class | AttributeNotFoundException 指定的属性不存在或无法检索。
class | AttributeValueExp 表示用作关系约束参数的属性。
class | BadAttributeValueExpException 向构造的查询方法传递无效的 MBean 属性时，抛出此异常。
class | BadBinaryOpValueExpException 向构造查询的方法传递无效的表达式时，抛出此异常。
class | BadStringOperationException 向构造查询的方法传递无效的字符串操作时，抛出此异常。
class | ImmutableDescriptor 不可变的描述符。
class | InstanceAlreadyExistsException 已经在存储库中注册了 MBean。
class | InstanceNotFoundException 存储库中不存在指定的 MBean。
class | InvalidApplicationException 试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。
class | InvalidAttributeValueException 指定的值对该属性无效。
class | JMException 由 JMX 实现所抛出的异常。
class | JMRuntimeException 由 JMX 实现所发出的运行时异常。
class | ListenerNotFoundException 存储库中不存在指定的 MBean 侦听器。
class | MalformedObjectNameException 字符串的格式不对应于有效的 ObjectName。
class | MBeanAttributeInfo 描述出于管理目的而公开的 MBean 属性。
class | MBeanConstructorInfo 描述 MBean 所公开的构造方法。
class | MBeanException 表示由代理的 MBean 方法所抛出的“用户定义的”异常。
class | MBeanFeatureInfo 提供 MBean 描述符对象的常规信息。
class | MBeanInfo 描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
class | MBeanNotificationInfo MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
class | MBeanOperationInfo 描述由 MBean 公开的管理操作。
class | MBeanParameterInfo 描述由 MBean 公开的操作的参数。
class | MBeanPermission 权限控制对 MBeanServer 操作的访问。
class | MBeanRegistrationException 包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
class | MBeanServerNotification 表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。
class | MBeanServerPermission 执行与 MBeanServer 关联的操作的 Permission。
class | MBeanTrustPermission 此权限表示“信任”签名者或代码基。
class | NotCompliantMBeanException 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
class | Notification Notification 类表示 MBean 所发出的通知。
class | NotificationFilterSupport 提供 NotificationFilter 接口的实现。
class | ObjectInstance 用于表示 MBean 对象名及其类名。
class | ObjectName 表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。
class | OperationsException 表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
class | QueryEval 允许在特定的 MBean 服务器上下文中执行查询。
class | ReflectionException 表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
class | RuntimeErrorException 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
class | RuntimeMBeanException 表示由代理中的 MBean 方法抛出的运行时异常。
class | RuntimeOperationsException 表示在 MBean 上执行操作时代理中抛出的运行时异常。
class | ServiceNotFoundException 表示请求的服务不受支持时引发的异常。
class | StringValueExp 表示作为关系约束变量的字符串。

javax.management.loading 中 Serializable 的使用

实现 Serializable 的 javax.management.loading 中的类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

javax.management.modelmbean 中 Serializable 的使用

实现 Serializable 的 javax.management.modelmbean 中的类
class | DescriptorSupport 此类表示 ModelMBean 元素的元数据集。
class | InvalidTargetObjectTypeException 当指定了无效的目标对象类型时，抛出此异常。
class | ModelMBeanAttributeInfo ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
class | ModelMBeanConstructorInfo ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
class | ModelMBeanInfoSupport 此类表示 ModelMBean 的元数据。
class | ModelMBeanNotificationInfo ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
class | ModelMBeanOperationInfo ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。
class | XMLParseException 当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。

javax.management.monitor 中 Serializable 的使用

实现 Serializable 的 javax.management.monitor 中的类
class | MonitorNotification 提供对监视器 MBean 发送的通知的定义。
class | MonitorSettingException 当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

javax.management.openmbean 中 Serializable 的使用

实现 Serializable 的 javax.management.openmbean 中的类
class | ArrayType<T> ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。
class | CompositeDataSupport CompositeDataSupport 类是实现 CompositeData 接口的开放数据 类。
class | CompositeType CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。
class | InvalidOpenTypeException 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
class | KeyAlreadyExistsException 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。
class | OpenDataException 因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。
class | OpenMBeanAttributeInfoSupport 描述 open MBean 的一个属性。
class | OpenMBeanConstructorInfoSupport 描述 Open MBean 的构造方法。
class | OpenMBeanInfoSupport OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。
class | OpenMBeanOperationInfoSupport 描述 Open MBean 的一个操作。
class | OpenMBeanParameterInfoSupport 描述用于 open MBean 的一个或多个操作或构造方法的参数。
class | OpenType<T> OpenType 类是所有类的父抽象类，它描述开放数据值的实际开放类型。
class | SimpleType<T> SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。
class | TabularDataSupport TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。
class | TabularType TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。

javax.management.relation 中 Serializable 的使用

javax.management.relation 中 Serializable 的子接口
 interface RelationType
该 RelationType 接口必须由期望表示关系类型的任何类来实现。

实现 Serializable 的 javax.management.relation 中的类
class | InvalidRelationIdException 为关系提供的关系 id 已使用时引发此异常。
class | InvalidRelationServiceException 提供无效 Relation Service（关系服务）时引发此异常。
class | InvalidRelationTypeException 无效的关系类型。
class | InvalidRoleInfoException 在角色信息中，其最小程度大于其最大程度时，引发此异常。
class | InvalidRoleValueException 角色值无效。
class | MBeanServerNotificationFilter MBeanServerNotification 的过滤器。
class | RelationException 此类是关系管理过程中引发的任何异常的超类。
class | RelationNotFoundException Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
class | RelationNotification Relation Service（关系服务）中的更改通知。
class | RelationServiceNotRegisteredException 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
class | RelationTypeNotFoundException Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
class | RelationTypeSupport RelationTypeSupport 对象实现 RelationType 接口。
class | Role 表示角色：包括角色名称和引用的 MBean（通过其 ObjectName）。
class | RoleInfo RoleInfo 概括介绍关系类型中的角色。
class | RoleInfoNotFoundException 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleNotFoundException 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。
class | RoleResult 表示对一个关系的几个角色多个访问的结果（可以是读取，也可以是写入）。
class | RoleUnresolved 表示未解析的角色：由于存在问题而无法从关系中检索到的角色。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

javax.management.remote 中 Serializable 的使用

实现 Serializable 的 javax.management.remote 中的类
class | JMXConnectionNotification 在客户端连接打开或关闭时，或者当通知丢失时发出的通知。
class | JMXPrincipal JMX Remote API 的远程客户端的身份。
class | JMXProviderException 当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
class | JMXServerErrorException 在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。
class | JMXServiceURL JMX API 连接器服务器的地址。
class | NotificationResult 缓存的通知的查询结果。
class | SubjectDelegationPermission 授权标识表示验证标识执行操作所需的权限。
class | TargetedNotification 一个 (Notification, Listener ID) 对。

javax.management.remote.rmi 中 Serializable 的使用

实现 Serializable 的 javax.management.remote.rmi 中的类
class | RMIConnectionImpl_Stub
class | RMIConnector 一个到远程 RMI 连接器的连接。
class | RMIServerImpl_Stub

javax.management.timer 中 Serializable 的使用

实现 Serializable 的 javax.management.timer 中的类
 class TimerNotification
此类定义了由计时器 MBean 发送的通知。

javax.naming 中 Serializable 的使用

javax.naming 中 Serializable 的子接口
 interface Name
Name 接口表示一个一般名称，即一个有序的组件序列。

实现 Serializable 的 javax.naming 中的类
class | AuthenticationException 当访问命名或目录服务发生验证错误时，抛出此异常。
class | AuthenticationNotSupportedException 当所请求验证的特定 flavor 不受支持时，抛出此异常。
class | BinaryRefAddr 此类表示通信终端地址的二进制形式。
class | Binding 此类表示上下文中一个名称到对象的绑定。
class | CannotProceedException 抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
class | CommunicationException 当客户端无法与目录或命名服务通信时，抛出此异常。
class | CompositeName 此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
class | CompoundName 此类表示一个组合名称，即一个取自层次名称空间的名称。
class | ConfigurationException 当存在配置问题时，抛出此异常。
class | ContextNotEmptyException 当试图销毁一个不为空的上下文时，抛出此异常。
class | InsufficientResourcesException 当无法使用资源完成所请求的操作时，抛出此异常。
class | InterruptedNamingException 当正被调用的命名操作已经被中断时，抛出此异常。
class | InvalidNameException 此异常指示被指定的名称不符合命名系统的命名语法。
class | LimitExceededException 当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
class | LinkException 此异常用于描述解析链接时遇到的问题。
class | LinkLoopException 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
class | LinkRef 此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。
class | MalformedLinkException 如果在解析或构造链接时遇到错误链接，则抛出此异常。
class | NameAlreadyBoundException 一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
class | NameClassPair 此类表示存在于上下文中的某一绑定的对象名称和类名称对。
class | NameNotFoundException 当名称的组件由于没有被绑定而无法解析时，抛出此异常。
class | NamingException 此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
class | NamingSecurityException 此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
class | NoInitialContextException 当不能创建任何初始上下文实现时，抛出此异常。
class | NoPermissionException 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
class | NotContextException 当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
class | OperationNotSupportedException 当上下文实现不支持将调用的操作时，抛出此异常。
class | PartialResultException 抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
class | RefAddr 此类表示通信端点的地址。
class | Reference 此类表示对存在于命名/目录系统以外的对象的引用。
class | ReferralException 此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
class | ServiceUnavailableException 当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
class | SizeLimitExceededException 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
class | StringRefAddr 此类表示通信终端地址的字符串形式。
class | TimeLimitExceededException 当某一方法没有在指定的时间限制内终止时，抛出此异常。

javax.naming.directory 中 Serializable 的使用

javax.naming.directory 中 Serializable 的子接口
interface | Attribute 此接口表示与命名对象关联的属性。
interface | Attributes 此接口表示属性的集合。

实现 Serializable 的 javax.naming.directory 中的类
class | AttributeInUseException 当操作试图添加已经存在的属性时抛出此异常。
class | AttributeModificationException 当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
class | BasicAttribute 此类提供 Attribute 接口的基本实现。
class | BasicAttributes 此类提供 Attributes 接口的基本实现。
class | InvalidAttributeIdentifierException 在试图用无效的属性标识符创建属性时，抛出此异常。
class | InvalidAttributesException 在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
class | InvalidSearchControlsException 在为搜索操作指定的 SearchControls 无效时，抛出此异常。
class | InvalidSearchFilterException 当指定的搜索过滤器无效时，抛出此异常。
class | ModificationItem 此类表示修改项。
class | NoSuchAttributeException 尝试访问不存在的属性时，抛出此异常。
class | SchemaViolationException 当方法在某些方面违反模式时，抛出此异常。
class | SearchControls 此类封装确定搜索范围和搜索返回结果的因子。
class | SearchResult 此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

javax.naming.event 中 Serializable 的使用

实现 Serializable 的 javax.naming.event 中的类
class | NamingEvent 此类表示命名/目录服务触发的事件。
class | NamingExceptionEvent 此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。

javax.naming.ldap 中 Serializable 的使用

javax.naming.ldap 中 Serializable 的子接口
interface | Control 此接口表示在 RFC 2251 中定义的 LDAPv3 控件。
interface | ExtendedRequest 此接口表示在 RFC 2251 中定义的 LDAPv3 扩展操作请求。
interface | ExtendedResponse 此接口表示在 RFC 2251 中定义的 LDAP 扩展操作响应。
interface | UnsolicitedNotification 此接口表示在 RFC 2251 中定义的未经请求的通知。

实现 Serializable 的 javax.naming.ldap 中的类
class | BasicControl 此类提供 Control 接口的基本实现。
class | LdapName 此类表示 RFC 2253 指定的标识名。
class | LdapReferralException 此抽象类用于表示 LDAP 引用异常。
class | ManageReferralControl 将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。
class | PagedResultsControl 请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。
class | PagedResultsResponseControl 指示一批搜索结果的末尾。
class | Rdn 此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。
class | SortControl 请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。
class | SortResponseControl 指示搜索结果的请求排序是否成功。
class | StartTlsRequest 此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展请求。
class | StartTlsResponse 此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展响应。
class | UnsolicitedNotificationEvent 此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。

javax.naming.spi 中 Serializable 的使用

实现 Serializable 的 javax.naming.spi 中的类
 class ResolveResult
此类表示解析某一名称的结果。

javax.net.ssl 中 Serializable 的使用

实现 Serializable 的 javax.net.ssl 中的类
class | HandshakeCompletedEvent 此事件指示在给定的 SSL 连接上 SSL 握手结束。
static class | SSLEngineResult.HandshakeStatus 描述此 SSLEngine 的当前握手状态的 SSLEngineResult 枚举。
static class | SSLEngineResult.Status 描述 SSLEngine 操作总体结果的 SSLEngineResult 枚举。
class | SSLException 指示由 SSL 子系统检测到的某类错误。
class | SSLHandshakeException 指示客户端和服务器不能就所需安全级别进行协商。
class | SSLKeyException 报告错误的 SSL 密钥。
class | SSLPeerUnverifiedException 指示还没有验证同位体的身份。
class | SSLPermission 此类用于各种网络权限。
class | SSLProtocolException 报告在 SSL 协议的操作中的错误。
class | SSLSessionBindingEvent 此事件向 SSLSessionBindingListener 传播。

javax.print 中 Serializable 的使用

实现 Serializable 的 javax.print 中的类
class | DocFlavor 类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。
static class | DocFlavor.BYTE_ARRAY 类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.CHAR_ARRAY 类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.INPUT_STREAM 类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.READER 类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.SERVICE_FORMATTED 类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
static class | DocFlavor.STRING 类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.URL 类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。
class | PrintException 类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。

javax.print.attribute 中 Serializable 的使用

javax.print.attribute 中 Serializable 的子接口
interface | DocAttribute 接口 DocAttribute 是打印属性类实现的一个标记接口，用于指示属性表示文档 (doc) 的设置（“Doc”是一个简短的、容易发音的术语，指“打印数据的片段”。
interface | PrintJobAttribute PrintJobAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印作业”的状态或“打印作业”的一些其他特征。
interface | PrintRequestAttribute 接口 PrintRequestAttribute 是打印属性类实现的标记接口，以指示属性表示用于打印作业的请求设置。
interface | PrintServiceAttribute 接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。
interface | SupportedValuesAttribute 接口 SupportedValuesAttribute 是打印属性类实现的标记接口，以指示该属性描述用于其他属性的支持值。

实现 Serializable 的 javax.print.attribute 中的类
class | DateTimeSyntax 类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。
class | EnumSyntax 类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。
class | HashAttributeSet 类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。
class | HashDocAttributeSet 类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。
class | HashPrintJobAttributeSet 类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。
class | HashPrintRequestAttributeSet 类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。
class | HashPrintServiceAttributeSet 类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。
class | IntegerSyntax 类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。
class | ResolutionSyntax 类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。
class | SetOfIntegerSyntax 类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。
class | Size2DSyntax 类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。
class | TextSyntax 类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。
class | UnmodifiableSetException 当由于设置不可修改而无法执行请求的操作时，抛出该异常。
class | URISyntax 类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。

javax.print.attribute.standard 中 Serializable 的使用

实现 Serializable 的 javax.print.attribute.standard 中的类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | ColorSupported ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
class | Compression Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
class | Copies Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
class | CopiesSupported CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
class | DateTimeAtCompleted DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
class | DateTimeAtCreation DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
class | DateTimeAtProcessing DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
class | Destination Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
class | DocumentName DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
class | Fidelity Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | JobHoldUntil JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
class | JobImpressions JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
class | JobImpressionsCompleted JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
class | JobImpressionsSupported JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
class | JobKOctets JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
class | JobKOctetsProcessed JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
class | JobKOctetsSupported JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
class | JobMediaSheets JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
class | JobMediaSheetsCompleted JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
class | JobMediaSheetsSupported Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
class | JobMessageFromOperator JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
class | JobName JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
class | JobOriginatingUserName JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
class | JobPriority JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
class | JobPrioritySupported JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
class | JobSheets JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
class | JobState JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
class | JobStateReason JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。
class | JobStateReasons JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaPrintableArea MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
class | MediaSize MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | MultipleDocumentHandling MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
class | NumberOfDocuments NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
class | NumberOfInterveningJobs NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | NumberUpSupported NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | OutputDeviceAssigned OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
class | PagesPerMinute PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PagesPerMinuteColor PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PDLOverrideSupported PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
class | PresentationDirection PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
class | PrinterInfo PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
class | PrinterIsAcceptingJobs PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
class | PrinterLocation PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
class | PrinterMakeAndModel PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
class | PrinterMessageFromOperator PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
class | PrinterMoreInfo PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
class | PrinterMoreInfoManufacturer PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
class | PrinterName PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
class | PrinterResolution PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
class | PrinterState PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
class | PrinterStateReason PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrinterStateReasons PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrinterURI PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | QueuedJobCount QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。
class | ReferenceUriSchemesSupported ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。
class | RequestingUserName RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。
class | Severity Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

javax.print.event 中 Serializable 的使用

实现 Serializable 的 javax.print.event 中的类
class | PrintEvent 类 PrintEvent 是所有 Print Service API 事件的超类。
class | PrintJobAttributeEvent 类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。
class | PrintJobEvent 类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。
class | PrintServiceAttributeEvent 类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

javax.rmi.CORBA 中 Serializable 的使用

实现 Serializable 的 javax.rmi.CORBA 中的类
class | ClassDesc 此类用于对 IIOP 上的 java.lang.Class 对象进行编组。
class | Stub 必须从其继承所有 RMI-IIOP stub 的基类。

返回 Serializable 的 javax.rmi.CORBA 中的方法
Serializable | ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender) 使用 Java 语义从流中读取一个值。
Serializable | ValueHandler.writeReplace(Serializable value) 如果该值包含 writeReplace 方法，则返回该结果。

参数类型为 Serializable 的 javax.rmi.CORBA 中的方法
Serializable | ValueHandler.writeReplace(Serializable value) 如果该值包含 writeReplace 方法，则返回该结果。
void | ValueHandler.writeValue(OutputStream out, Serializable value) 使用 Java 语义将一个值写入流。
void | ValueHandlerMultiFormat.writeValue(OutputStream out, Serializable value, byte streamFormatVersion) 允许 ORB 为 RMI/IDL 自定义值类型传递流格式版本。

javax.rmi.ssl 中 Serializable 的使用

实现 Serializable 的 javax.rmi.ssl 中的类
 class SslRMIClientSocketFactory
SslRMIClientSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的客户端套接字。

javax.script 中 Serializable 的使用

实现 Serializable 的 javax.script 中的类
 class ScriptException
脚本 API 的一般 Exception 类。

javax.security.auth 中 Serializable 的使用

实现 Serializable 的 javax.security.auth 中的类
class | AuthPermission 此类用于验证权限。
class | DestroyFailedException 当 destroy 操作失败时，抛出此异常。
class | PrivateCredentialPermission 此类用来保护对属于特定 Subject 的私有 Credential 的访问。
class | RefreshFailedException 当 refresh 操作失败时，抛出此异常。
class | Subject Subject 表示某一项（如一个人）的一组相关信息。

javax.security.auth.callback 中 Serializable 的使用

实现 Serializable 的 javax.security.auth.callback 中的类
class | ChoiceCallback 底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。
class | ConfirmationCallback 底层安全服务实例化 ConfirmationCallback，并将其传递到 CallbackHandler 的 handle 方法，以请求 YES/NO、OK/CANCEL、YES/NO/CANCEL 或其他类似的确认信息。
class | LanguageCallback 底层安全服务实例化一个 LanguageCallback, 并将其传递给 CallbackHandler 的 handle 方法，以获取用于本地化文本的 Locale。
class | NameCallback 底层安全服务实例化一个 NameCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取名称信息。
class | PasswordCallback 底层安全服务实例化一个 PasswordCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取密码信息。
class | TextInputCallback 底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。
class | TextOutputCallback 底层安全服务实例化一个 TextOutputCallback 并将其传递给 CallbackHandler 的 handle 方法，以显示信息消息、警告消息和错误消息。
class | UnsupportedCallbackException 在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

javax.security.auth.kerberos 中 Serializable 的使用

实现 Serializable 的 javax.security.auth.kerberos 中的类
class | DelegationPermission 此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。
class | KerberosKey 此类为 Kerberos 主体封装一个长期秘密密钥。
class | KerberosPrincipal 此类封装 Kerberos 主体。
class | KerberosTicket 此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。
class | ServicePermission 此类用于保护 Kerberos 服务和访问这些服务所必需的证书。

javax.security.auth.login 中 Serializable 的使用

实现 Serializable 的 javax.security.auth.login 中的类
class | AccountException 一般的帐户异常。
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。
class | CredentialException 一般证书异常。
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。
class | FailedLoginException 当用户验证失败时抛出此异常。
class | LoginException 此异常是基本的登录异常。

javax.security.auth.x500 中 Serializable 的使用

实现 Serializable 的 javax.security.auth.x500 中的类
 class X500Principal
此类表示一个 X.500 Principal。

javax.security.sasl 中 Serializable 的使用

实现 Serializable 的 javax.security.sasl 中的类
class | AuthorizeCallback 此回调由 SaslServer 使用，以确定某个实体（由已验证的验证 id 所标识）能否代表另一个实体（由授权 id 所标识）。
class | RealmCallback SaslClient 和 SaslServer 使用此回调来获取领域信息。
class | RealmChoiceCallback SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。
class | SaslException 此类表示在使用 SASL 时所发生的错误。

javax.sound.midi 中 Serializable 的使用

实现 Serializable 的 javax.sound.midi 中的类
class | InvalidMidiDataException 一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
class | MidiUnavailableException 当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。

javax.sound.sampled 中 Serializable 的使用

实现 Serializable 的 javax.sound.sampled 中的类
class | AudioPermission AudioPermission 类表示对音频系统资源的访问权限。
class | LineEvent LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。
class | LineUnavailableException LineUnavailableException 是指示某一行因为不可用而无法打开的异常。
class | UnsupportedAudioFileException UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

javax.sql 中 Serializable 的使用

实现 Serializable 的 javax.sql 中的类
class | ConnectionEvent 提供关于连接相关事件的源信息的 Event 对象。
class | RowSetEvent RowSet 对象发生事件时生成的 Event 对象。
class | StatementEvent StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。

javax.sql.rowset 中 Serializable 的使用

实现 Serializable 的 javax.sql.rowset 中的类
class | BaseRowSet 提供一个具有基本功能的 RowSet 对象的抽象类。
class | RowSetMetaDataImpl 为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。
class | RowSetWarning SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

javax.sql.rowset.serial 中 Serializable 的使用

实现 Serializable 的 javax.sql.rowset.serial 中的类
class | SerialArray 序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。
class | SerialBlob SQL BLOB 值在 Java 编程语言中的序列化映射关系。
class | SerialClob SQL CLOB 值在 Java 编程语言中的序列化映射关系。
class | SerialDatalink SQL DATALINK 值在 Java 编程语言中的序列化映射关系。
class | SerialException 指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。
class | SerialJavaObject SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。
class | SerialRef Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。
class | SerialStruct SQL 结构类型在 Java 编程语言中的序列化映射关系。

javax.sql.rowset.spi 中 Serializable 的使用

实现 Serializable 的 javax.sql.rowset.spi 中的类
class | SyncFactoryException 指示 SyncFactory 机制发生的错误。
class | SyncProviderException 指示 SyncProvider 机制发生的错误。

javax.swing 中 Serializable 的使用

实现 Serializable 的 javax.swing 中的类
class | AbstractAction 此类提供 JFC Action 接口的默认实现。
class | AbstractButton 定义按钮和菜单项的一般行为。
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | AbstractButton.ButtonChangeListener 将 ChangeListener 扩展为可序列化的。
class | AbstractCellEditor
class | AbstractListModel 该数据模型的抽象定义提供一个带内容的 List。
class | ActionMap ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
protected class | Box.Filler.AccessibleBoxFiller 此类实现 Box.Filler 类的可访问性支持。
class | BoxLayout 允许垂直或水平布置多个组件的布局管理器。
class | ButtonGroup 此类用于为一组按钮创建一个多斥（multiple-exclusion）作用域。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
protected class | CellRendererPane.AccessibleCellRendererPane 此类实现 Panel 类的可访问性支持。
class | ComponentInputMap ComponentInputMap 是与特定 JComponent 相关联的 InputMap。
class | DefaultBoundedRangeModel BoundedRangeModel 的一般实现。
class | DefaultButtonModel Button 组件的数据模型的默认实现。
class | DefaultCellEditor 表单元格和树单元格的默认编辑器。
protected class | DefaultCellEditor.EditorDelegate 受保护的 (protected) EditorDelegate 类。
class | DefaultComboBoxModel 组合框的默认模型。
class | DefaultDesktopManager 此类是 DesktopManager 的实现。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | DefaultListModel 此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。
class | DefaultListSelectionModel 列表选择的默认数据模型。
class | DefaultSingleSelectionModel SingleSelectionModel 的一般实现。
class | DropMode 放置模式，用于确定组件在拖放过程中跟踪和指示放置位置 (drop location) 的方法。
static class | GroupLayout.Alignment ParallelGroup 能够对齐其子元素的可能方式的枚举。
class | ImageIcon 一个 Icon 接口的实现，它根据 Image 绘制 Icon。
protected class | ImageIcon.AccessibleImageIcon 此类实现 ImageIcon 类的可访问性支持。
class | InputMap InputMap 提供输入事件（目前只使用 KeyStroke）和 Object 之间的绑定。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
protected class | JApplet.AccessibleJApplet 此类实现对 JApplet 类的可访问性支持。
class | JButton "push" 按钮的实现。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent 该类是除顶层容器外所有 Swing 组件的基类。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
class | JDialog 创建对话框窗口的主要类。
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
class | JEditorPane 可编辑各种内容的文本组件。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
static class | JFormattedTextField.AbstractFormatter JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
class | JLabel 用于短文本字符串或图像或二者的显示区。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenu.WinListener 观察弹出窗口关闭的侦听器类。
class | JMenuBar 菜单栏的实现。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
class | JMenuItem 菜单中的项的实现。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
class | JPanel JPanel 是一般轻量级容器。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JRootPane.RootLayout 该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。
class | JScrollBar 滚动条的实现。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTabbedPane.ModelListener 将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。
class | JTable JTable 用来显示和编辑常规二维单元表。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
static class | JTable.PrintMode 用于打印 JTable 的打印模式。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
static class | JToggleButton.ToggleButtonModel ToggleButton 模型。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
class | JTree 将分层数据集显示为轮廓的控件。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
static class | JTree.DynamicUtilTreeNode DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。
protected static class | JTree.EmptySelectionModel EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。
protected class | JTree.TreeSelectionRedirector 使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JViewport.ViewListener 视图的侦听器。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。
class | KeyStroke 表示键盘或等效输入设置上的键操作的 KeyStroke。
class | LayoutFocusTraversalPolicy 根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。
static class | LayoutStyle.ComponentPlacement ComponentPlacement 是两个组件相对于彼此的可能放置方式的枚举。
class | OverlayLayout 要在彼此顶部安排组件的布局管理器。
static class | RowFilter.ComparisonType 由某些默认 RowFilter 支持的可能比较值的枚举。
class | ScrollPaneLayout JScrollPane 使用的布局管理器。
static class | ScrollPaneLayout.UIResource ScrollPaneLayout 的 UI 资源版本。
class | SizeRequirements 为方便布局管理器，计算组件的有关大小和位置信息。
class | SortOrder SortOrder 是可能排序顺序的枚举。
class | SpinnerDateModel Date 序列的一个 SpinnerModel。
class | SpinnerListModel 其值由数组或 List 定义的 SpinnerModel 的简单实现。
class | SpinnerNumberModel 用于数字序列的 SpinnerModel。
static class | SwingWorker.StateValue state 绑定 (bound) 属性的值。
class | Timer 在指定时间间隔触发一个或多个 ActionEvent。
class | TransferHandler 此类用于处理往返于 Swing 组件的 Transferable 的传输。
class | UIDefaults Swing 组件的默认值表。
class | UIManager UIManager 管理当前外观、可用外观集合、外观更改时被通知的 PropertyChangeListeners、外观默认值以及获取各种默认值的便捷方法。
class | UnsupportedLookAndFeelException 指示在用户系统上不存在请求的外观管理类的异常。
class | ViewportLayout JViewport 的默认布局管理器。

javax.swing.border 中 Serializable 的使用

实现 Serializable 的 javax.swing.border 中的类
class | AbstractBorder 实现无大小限制的空边框类。
class | BevelBorder 该类实现简单的双线斜面边框。
class | CompoundBorder 一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
class | EmptyBorder 该类提供了一个占用空间但不执行绘制的空透明边框。
class | EtchedBorder 该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。
class | LineBorder 实现单色、任意厚度线边框的类。
class | MatteBorder 该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
class | SoftBevelBorder 实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。
class | TitledBorder 该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

javax.swing.colorchooser 中 Serializable 的使用

实现 Serializable 的 javax.swing.colorchooser 中的类
class | AbstractColorChooserPanel 这是用于颜色选取器的抽象超类。
class | DefaultColorSelectionModel ColorSelectionModel 的一般实现。

javax.swing.event 中 Serializable 的使用

实现 Serializable 的 javax.swing.event 中的类
class | AncestorEvent 报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。
class | CaretEvent CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。
class | ChangeEvent ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
class | EventListenerList 保存 EventListener 列表的类。
class | HyperlinkEvent HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。
class | InternalFrameEvent 以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
class | ListDataEvent 定义一个封装列表更改的事件。
class | ListSelectionEvent 表现选择中更改的特征的事件。
class | MenuDragMouseEvent MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
class | MenuEvent MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。
class | MenuKeyEvent MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。
class | PopupMenuEvent PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | RowSorterEvent RowSorterEvent 提供 RowSorter 的更改通知。
static class | RowSorterEvent.Type RowSorterEvent 类型的枚举。
class | SwingPropertyChangeSupport java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。
class | TableColumnModelEvent TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。
class | TableModelEvent TableModelEvent 用于通知侦听器某一表模型已发生更改。
class | TreeExpansionEvent 用于标识树中的单个路径的事件。
class | TreeModelEvent 封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
class | TreeSelectionEvent 描述当前选择中的更改的事件。
class | UndoableEditEvent 指示发生了可撤消操作的事件。

javax.swing.plaf 中 Serializable 的使用

实现 Serializable 的 javax.swing.plaf 中的类
class | ActionMapUIResource 实现 UIResource 的 javax.swing.ActionMap 的子类。
class | BorderUIResource
static class | BorderUIResource.BevelBorderUIResource
static class | BorderUIResource.CompoundBorderUIResource
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.EtchedBorderUIResource
static class | BorderUIResource.LineBorderUIResource
static class | BorderUIResource.MatteBorderUIResource
static class | BorderUIResource.TitledBorderUIResource
class | ColorUIResource
class | ComponentInputMapUIResource 实现 UIResource 的 javax.swing.ComponentInputMap 的子类。
class | DimensionUIResource
class | FontUIResource 实现 UIResource 的 java.awt.Font 的子类。
class | IconUIResource 实现 UIResource 的 Icon 包装类。
class | InputMapUIResource 实现 UIResource 的 javax.swing.InputMap 的子类。
class | InsetsUIResource

javax.swing.plaf.basic 中 Serializable 的使用

实现 Serializable 的 javax.swing.plaf.basic 中的类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
static class | BasicBorders.ButtonBorder
static class | BasicBorders.FieldBorder
static class | BasicBorders.MarginBorder
static class | BasicBorders.MenuBarBorder
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.ToggleButtonBorder
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
class | BasicDirectoryModel 文件列表的基本实现。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicIconFactory 提供适于基本 L & F 使用的 Icon 的工厂对象。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicLookAndFeel 为 Swing 创建外观时要使用的基类。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
static class | BasicTextUI.BasicCaret
protected class | BasicToolBarUI.DragWindow
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。
class | DefaultMenuLayout Popup 菜单和菜单栏的默认布局管理器。

javax.swing.plaf.metal 中 Serializable 的使用

实现 Serializable 的 javax.swing.plaf.metal 中的类
static class | MetalBorders.ButtonBorder
static class | MetalBorders.Flush3DBorder
static class | MetalBorders.InternalFrameBorder
static class | MetalBorders.MenuBarBorder
static class | MetalBorders.MenuItemBorder
static class | MetalBorders.OptionDialogBorder
static class | MetalBorders.PaletteBorder Palette 的边框。
static class | MetalBorders.PopupMenuBorder
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ScrollPaneBorder
static class | MetalBorders.TableHeaderBorder Table Header 的边框
static class | MetalBorders.TextFieldBorder
static class | MetalBorders.ToggleButtonBorder
static class | MetalBorders.ToolBarBorder
class | MetalCheckBoxIcon OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxIcon 此实用工具类绘制指示 MetalComboBox 的水平条
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.DirectoryComboBoxAction 当 DirectoryComboBox 已更改所选项时调用。
protected class | MetalFileChooserUI.DirectoryComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.FileRenderer
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalIconFactory 为 JavaTM 外观 (Metal) 提供 Icon 的工厂对象。
static class | MetalIconFactory.FileIcon16 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.FolderIcon16 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.PaletteCloseIcon 定义一个用于 Palette 关闭的图标
static class | MetalIconFactory.TreeControlIcon 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.TreeFolderIcon 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.TreeLeafIcon
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalLookAndFeel Java 外观，也称为 Metal。
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

javax.swing.plaf.synth 中 Serializable 的使用

实现 Serializable 的 javax.swing.plaf.synth 中的类
 class SynthLookAndFeel
SynthLookAndFeel 提供创建定制外观的基础。

javax.swing.table 中 Serializable 的使用

实现 Serializable 的 javax.swing.table 中的类
class | AbstractTableModel 此抽象类为 TableModel 接口中的大多数方法提供默认实现。
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | DefaultTableColumnModel JTable 的标准列处理程序。
class | DefaultTableModel 这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。
class | JTableHeader 这是管理 JTable 的头的对象。
protected class | JTableHeader.AccessibleJTableHeader 此类实现对 JTableHeader 类的可访问性支持。
class | TableColumn TableColumn 表示 JTable 中列的所有属性，如宽度、大小可调整性、最小和最大宽度。

javax.swing.text 中 Serializable 的使用

实现 Serializable 的 javax.swing.text 中的类
class | AbstractDocument 文档接口的实现，可作为实现各种文档的基础。
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.DefaultDocumentEvent 存储修改文档时发生的文档更改。
static class | AbstractDocument.ElementEdit 一个 ElementChange 实现，可将其添加到文档事件中。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
class | BadLocationException 此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
class | ChangedCharSetException 顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。
class | DateFormatter DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
class | DefaultCaret 插入符的默认实现。
class | DefaultEditorKit 这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
class | DefaultFormatter DefaultFormatter 格式化任意对象。
class | DefaultFormatterFactory JFormattedTextField.AbstractFormatterFactory 的一个实现。
class | DefaultStyledDocument 能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。
static class | DefaultStyledDocument.AttributeUndoableEdit 用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。
class | DefaultStyledDocument.ElementBuffer 管理对元素层次结构更改的类。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。
class | EditorKit 针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
class | GapContent AbstractDocument.Content 接口的一个实现，使用类似于 emacs 使用的间隙缓冲区来实现。
class | InternationalFormatter InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
class | JTextComponent JTextComponent 是 swing 文本组件的基类。
class | JTextComponent.AccessibleJTextComponent 此类实现 JTextComponent 类的可访问性支持。
class | MaskFormatter MaskFormatter 用于格式化和编辑字符串。
class | NumberFormatter 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。
class | PlainDocument 维护无任何字符属性的普通文档。
class | SimpleAttributeSet 使用哈希表的 MutableAttributeSet 的直接实现。
class | StringContent AbstractDocument.Content 接口的一个实现，这是一个对相对于较小的文档和/或调试很有用的强制实现。
class | StyleContext 样式池及其关联的资源。
class | StyleContext.NamedStyle 通常用于表示字符和段落样式的属性集合。
class | StyledEditorKit 这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TabSet 由许多 TabStop 组成的一个 TabSet。
class | TabStop 此类封装单个制表位 (tab stop)（基本上是由 RTF 认定的制表位）。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

javax.swing.text.html 中 Serializable 的使用

实现 Serializable 的 javax.swing.text.html 中的类
class | CSS 将 CSS attributes 集定义为类型安全的枚举。
class | FormSubmitEvent FormSubmitEvent 用于通知提交表单所需的参与者。
static class | FormSubmitEvent.MethodType 表示 HTML 表单方法类型。
static class | HTML.UnknownTag
class | HTMLDocument 对 HTML 进行建模的文档。
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。
class | HTMLEditorKit Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。
class | HTMLFrameHyperlinkEvent HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。
class | Option 用来表示 <option> 元素的 ListModel 值。
class | StyleSheet 支持定义要呈现的 HTML 视图的可视化特征。
static class | StyleSheet.BoxPainter 可以执行某些 CSS 格式化任务的类。
static class | StyleSheet.ListPainter 要执行某些 CSS 列表格式化任务的类。

javax.swing.text.html.parser 中 Serializable 的使用

实现 Serializable 的 javax.swing.text.html.parser 中的类
class | ContentModel 内容模式的表示形式。
class | Element 使用 ELEMENT 构造在 DTD 中描述的一个元素。
class | ParserDelegator 负责每次在调用其 parse 方法时启动一个新的 DocumentParser。

javax.swing.text.rtf 中 Serializable 的使用

实现 Serializable 的 javax.swing.text.rtf 中的类
 class RTFEditorKit
这是对 RTF 编辑功能的默认实现。

javax.swing.tree 中 Serializable 的使用

实现 Serializable 的 javax.swing.tree 中的类
class | DefaultMutableTreeNode DefaultMutableTreeNode 是树数据结构中的通用节点。
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
class | DefaultTreeCellRenderer 显示树中的条目。
class | DefaultTreeModel 使用 TreeNodes 的简单树数据模型。
class | DefaultTreeSelectionModel TreeSelectionModel 的默认实现。
class | ExpandVetoException 用于阻止扩展/折叠发生的异常。
class | TreePath 表示节点的路径。

javax.swing.undo 中 Serializable 的使用

实现 Serializable 的 javax.swing.undo 中的类
class | AbstractUndoableEdit UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。
class | CannotRedoException 当 UndoableEdit 被通知 redo() 但无法执行时抛出。
class | CannotUndoException 当 UndoableEdit 被通知 undo() 但无法执行时抛出。
class | CompoundEdit AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
class | StateEdit StateEdit 是更改状态的对象的通用编辑。
class | UndoManager UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

javax.tools 中 Serializable 的使用

实现 Serializable 的 javax.tools 中的类
static class | Diagnostic.Kind 诊断的种类，例如，错误或者警告。
static class | JavaFileObject.Kind JavaFileObject 的种类。
class | StandardLocation 文件对象的标准位置。

javax.transaction 中 Serializable 的使用

实现 Serializable 的 javax.transaction 中的类
class | InvalidTransactionException 此异常指示该请求带来了无效的事务上下文。
class | TransactionRequiredException 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
class | TransactionRolledbackException 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

javax.transaction.xa 中 Serializable 的使用

实现 Serializable 的 javax.transaction.xa 中的类
 class XAException
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。

javax.xml.bind 中 Serializable 的使用

实现 Serializable 的 javax.xml.bind 中的类
class | JAXBElement<T> Xml 元素的 JAXB 表示形式。
class | JAXBException 这是所有 JAXB 异常的根异常类。
class | PropertyException 此异常指示在获取或设置属性时遇到一个错误。
class | TypeConstraintException 此异常指示已检测到存在违反动态检查的类型约束的情况。
class | ValidationException 此异常指示在执行验证操作时发生错误。

javax.xml.bind.annotation 中 Serializable 的使用

实现 Serializable 的 javax.xml.bind.annotation 中的类
class | XmlAccessOrder 由 XmlAccessorOrder 使用，用于控制 JAXB 绑定类中属性和字段的排序。
class | XmlAccessType 由 XmlAccessorType 使用，用于控制字段或属性的序列化。
class | XmlNsForm XML 模式名称空间限定的枚举。

javax.xml.crypto 中 Serializable 的使用

实现 Serializable 的 javax.xml.crypto 中的类
class | KeySelectorException 指示由 KeySelector 抛出的异常条件。
class | NoSuchMechanismException 当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。
class | URIReferenceException 指示取消引用 URIReference 时抛出的异常条件。

javax.xml.crypto.dsig 中 Serializable 的使用

实现 Serializable 的 javax.xml.crypto.dsig 中的类
class | TransformException 指示执行转换算法时出现异常的异常条件。
class | XMLSignatureException 指示生成或验证 XML 签名过程中发生的异常条件。

javax.xml.datatype 中 Serializable 的使用

实现 Serializable 的 javax.xml.datatype 中的类
 class DatatypeConfigurationException
指示严重的配置错误。

javax.xml.namespace 中 Serializable 的使用

实现 Serializable 的 javax.xml.namespace 中的类
 class QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.parsers 中 Serializable 的使用

实现 Serializable 的 javax.xml.parsers 中的类
class | FactoryConfigurationError 当解析器工厂的配置存在问题时抛出该异常。
class | ParserConfigurationException 指示一个严重的配置错误。

javax.xml.soap 中 Serializable 的使用

实现 Serializable 的 javax.xml.soap 中的类
 class SOAPException
当发生 SOAP 异常时，抛出此异常。

javax.xml.stream 中 Serializable 的使用

实现 Serializable 的 javax.xml.stream 中的类
 class XMLStreamException
用于不可预料处理错误的基本异常。

javax.xml.transform 中 Serializable 的使用

实现 Serializable 的 javax.xml.transform 中的类
class | TransformerConfigurationException 指示严重的配置错误。
class | TransformerException 此类指定了转换过程中发生的异常条件。
class | TransformerFactoryConfigurationError 当通过 Transformer Factories 进行的配置存在问题时抛出此异常。

javax.xml.ws 中 Serializable 的使用

实现 Serializable 的 javax.xml.ws 中的类
static class | Service.Mode 动态客户端或服务的方向。
class | WebServiceException WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。
class | WebServicePermission 此类定义 Web 服务权限。

javax.xml.ws.handler 中 Serializable 的使用

实现 Serializable 的 javax.xml.ws.handler 中的类
static class MessageContext.Scope
属性作用域。

javax.xml.ws.http 中 Serializable 的使用

实现 Serializable 的 javax.xml.ws.http 中的类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 Serializable 的使用

实现 Serializable 的 javax.xml.ws.soap 中的类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

javax.xml.xpath 中 Serializable 的使用

实现 Serializable 的 javax.xml.xpath 中的类
class | XPathException XPathException 表示通用 XPath 异常。
class | XPathExpressionException XPathExpressionException 表示 XPath 表达式中的错误。
class | XPathFactoryConfigurationException XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
class | XPathFunctionException XPathFunctionException 表示 XPath 函数的错误。

org.ietf.jgss 中 Serializable 的使用

实现 Serializable 的 org.ietf.jgss 中的类
 class GSSException
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。

org.omg.CORBA 中 Serializable 的使用

org.omg.CORBA 中 Serializable 的子接口
interface | Current 从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
interface | DataInputStream 定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。
interface | DataOutputStream 定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。
interface | DomainManager 提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
interface | IDLType 由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
interface | IRObject IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。
interface | Policy 派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。

实现 Serializable 的 org.omg.CORBA 中的类
class | _IDLTypeStub IDLType 的 Stub。
class | _PolicyStub Policy 的 Stub。
class | ACTIVITY_COMPLETED ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
class | ACTIVITY_REQUIRED ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
class | Any 充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
class | BAD_CONTEXT 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
class | BAD_INV_ORDER 此异常指示调用者按错误顺序调用了操作。
class | BAD_OPERATION 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
class | BAD_PARAM 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
class | BAD_QOS 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
class | BAD_TYPECODE 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
class | Bounds 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
class | CODESET_INCOMPATIBLE 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
class | COMM_FAILURE 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
class | CompletionStatus 指示某一方法抛出 SystemException 时是否已结束运行的对象。
class | DATA_CONVERSION 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
class | DefinitionKind 该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。
class | FREE_MEM 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
class | IMP_LIMIT 此异常指示在 OBR 运行时超过了某一项实现限制。
class | INITIALIZE ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
class | INTERNAL 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
class | INTF_REPOS 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
class | INV_FLAG 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
class | INV_IDENT 此异常指示 IDL 标识符在语法上是无效的。
class | INV_OBJREF 此异常指示对象引用存在内部错误。
class | INV_POLICY 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
class | INVALID_ACTIVITY 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
class | INVALID_TRANSACTION 当请求带有无效的事务上下文时，抛出此异常。
class | MARSHAL 表示网络中传来的请求或应答在结构上无效。
class | NameValuePair 将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。
class | NO_IMPLEMENT 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
class | NO_MEMORY 如果 ORB 运行时出现内存不足，则抛出此异常。
class | NO_PERMISSION 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
class | NO_RESOURCES 当 ORB 遇到一些一般资源限制时，抛出此异常。
class | NO_RESPONSE 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
class | OBJ_ADAPTER 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
class | OBJECT_NOT_EXIST 只要在已删除的对象上执行调用，就会引发此异常。
class | ParameterMode Parameter 参数模式的枚举。
class | PERSIST_STORE 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
class | PolicyError 发生策略错误时抛出的用户异常。
class | REBIND 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
class | ServiceDetail 表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。
class | ServiceInformation CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。
class | SetOverrideType 标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。
class | StructMember 描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。
class | SystemException 所有 CORBA 标准异常的根类。
class | TIMEOUT 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
class | TRANSACTION_MODE 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
class | TRANSACTION_REQUIRED 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
class | TRANSACTION_ROLLEDBACK 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
class | TRANSACTION_UNAVAILABLE 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
class | TRANSIENT 当 ORB 试图到达某一对象但失败时，抛出此异常。
class | TypeCode 用于有关特定 CORBA 数据类型的信息的容器。
class | UnionMember 接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。
class | UNKNOWN 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。
class | UnknownUserException 包含由服务器返回的用户异常的类。
class | UserException CORBA IDL 定义的用户异常的根类。
class | ValueMember 接口存储库 (Interface Repository) 中关于 value 对象成员的描述。
class | WrongTransaction CORBA WrongTransaction 用户定义异常。

声明为 Serializable 的 org.omg.CORBA 中的字段
 Serializable ValueBaseHolder.value
此 ValueBaseHolder 对象保存的 java.io.Serializable 值。

返回 Serializable 的 org.omg.CORBA 中的方法
abstract Serializable | Any.extract_Value() 提取此 Any 对象 value 字段中的 java.io.Serializable 对象。
static Serializable | ValueBaseHelper.extract(Any a)
Serializable | DynAny.get_val() 已过时。 检索此 DynAny 对象中包含的 java.io.Serializable 对象。
Serializable | DataInputStream.read_Value() 从输入流读取 IDL 值类型。
Serializable | StringValueHelper.read_value(InputStream istream)
Serializable | WStringValueHelper.read_value(InputStream istream)
static Serializable | ValueBaseHelper.read(InputStream istream)

参数类型为 Serializable 的 org.omg.CORBA 中的方法
void | DynAny.insert_val(Serializable value) 已过时。 插入给定 java.io.Serializable 对象作为此 DynAny 对象的值。
abstract void | Any.insert_Value(Serializable v) 将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
abstract void | Any.insert_Value(Serializable v, TypeCode t) 将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
static void | ValueBaseHelper.insert(Any a, Serializable that)
void | StringValueHelper.write_value(OutputStream ostream, Serializable value)
void | WStringValueHelper.write_value(OutputStream ostream, Serializable value)
void | DataOutputStream.write_Value(Serializable value) 将 IDL value 类型值写入输出流。
static void | ValueBaseHelper.write(OutputStream ostream, Serializable value)

参数类型为 Serializable 的 org.omg.CORBA 中的构造方法
ValueBaseHolder(Serializable initial)
构造一个新的 ValueBaseHolder 对象，并将其 value 字段初始化为给定的 java.io.Serializable。

org.omg.CORBA_2_3.portable 中 Serializable 的使用

返回 Serializable 的 org.omg.CORBA_2_3.portable 中的方法
Serializable | InputStream.read_value() 从输入流解组值类型。
Serializable | InputStream.read_value(BoxedValueHelper factory) 从输入流解组值类型。
Serializable | InputStream.read_value(Class clz) 从输入流解组值类型。
Serializable | InputStream.read_value(Serializable value) 从输入流解组值类型。
Serializable | InputStream.read_value(String rep_id) 从输入流解组值类型。

参数类型为 Serializable 的 org.omg.CORBA_2_3.portable 中的方法
Serializable | InputStream.read_value(Serializable value) 从输入流解组值类型。
void | OutputStream.write_value(Serializable value) 将值类型编组到输出流中。
void | OutputStream.write_value(Serializable value, BoxedValueHelper factory) 将值类型编组到输出流中。
void | OutputStream.write_value(Serializable value, Class clz) 将值类型编组到输出流中。
void | OutputStream.write_value(Serializable value, String repository_id) 将值类型编组到输出流中。

org.omg.CORBA.DynAnyPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.CORBA.DynAnyPackage 中的类
class | Invalid 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
class | InvalidSeq 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
class | InvalidValue
class | TypeMismatch 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.CORBA.ORBPackage 中的类
class | InconsistentTypeCode 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
class | InvalidName 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.portable 中 Serializable 的使用

org.omg.CORBA.portable 中 Serializable 的子接口
interface | CustomValue 通过自定义值类型实现的 ValueBase 扩展。
interface | IDLEntity 一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
interface | StreamableValue 为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。
interface | ValueBase 所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。

实现 Serializable 的 org.omg.CORBA.portable 中的类
class | ApplicationException 此类用来报告 ORB 和 stub 之间的应用程序级异常。
class | IndirectionException Indirection 异常是一个特定于 Java 的系统异常。
class | RemarshalException 此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
class | UnknownException org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

返回 Serializable 的 org.omg.CORBA.portable 中的方法
Serializable | BoxedValueHelper.read_value(InputStream is)
Serializable | ValueFactory.read_value(InputStream is) ORB 运行时在解组值类型的过程中调用此方法。

参数类型为 Serializable 的 org.omg.CORBA.portable 中的方法
 void BoxedValueHelper.write_value(OutputStream os, Serializable value)

org.omg.CORBA.TypeCodePackage 中 Serializable 的使用

实现 Serializable 的 org.omg.CORBA.TypeCodePackage 中的类
 class BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming 中 Serializable 的使用

org.omg.CosNaming 中 Serializable 的子接口
interface | BindingIterator BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
interface | NamingContext 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
interface | NamingContextExt NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 Serializable 的 org.omg.CosNaming 中的类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
class | BindingType 指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
class | NameComponent org/omg/CosNaming/NameComponent.java。

org.omg.CosNaming.NamingContextExtPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.CosNaming.NamingContextExtPackage 中的类
 class InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.CosNaming.NamingContextPackage 中的类
class | AlreadyBound org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
class | CannotProceed org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
class | NotEmpty org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
class | NotFound org/omg/CosNaming/NamingContextPackage/NotFound.java。
class | NotFoundReason 指示未能解析的原因。

org.omg.Dynamic 中 Serializable 的使用

实现 Serializable 的 org.omg.Dynamic 中的类
 class Parameter
org/omg/Dynamic/Parameter.java。

org.omg.DynamicAny 中 Serializable 的使用

org.omg.DynamicAny 中 Serializable 的子接口
interface | DynAny 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
interface | DynAnyFactory DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
interface | DynArray DynArray 对象支持对 IDL 数组的操作。
interface | DynEnum DynEnum 对象支持对 IDL 枚举值的操作。
interface | DynFixed DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
interface | DynSequence DynSequence 对象支持对 IDL 序列的操作。
interface | DynStruct DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
interface | DynUnion DynUnion 对象支持对 IDL 联合 (union) 的操作。
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。

实现 Serializable 的 org.omg.DynamicAny 中的类
class | _DynAnyFactoryStub DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。
class | NameDynAnyPair org/omg/DynamicAny/NameDynAnyPair.java。

返回 Serializable 的 org.omg.DynamicAny 中的方法
Serializable | DynAnyOperations.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynAnyStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynArrayStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynEnumStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynFixedStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynSequenceStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynStructStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynUnionStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynValueStub.get_val() 从此 DynAny 中提取 Serializable 对象。

参数类型为 Serializable 的 org.omg.DynamicAny 中的方法
void | DynAnyOperations.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynAnyStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynArrayStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynEnumStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynFixedStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynSequenceStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynStructStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynUnionStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynValueStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。

org.omg.IOP 中 Serializable 的使用

org.omg.IOP 中 Serializable 的子接口
interface | Codec IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。
interface | CodecFactory Codec 可从 CodecFactory 中获得。

实现 Serializable 的 org.omg.IOP 中的类
class | Encoding org/omg/IOP/Encoding.java。
class | IOR org/omg/IOP/IOR.java。
class | ServiceContext org/omg/IOP/ServiceContext.java。
class | TaggedComponent org/omg/IOP/TaggedComponent.java。
class | TaggedProfile org/omg/IOP/TaggedProfile.java。

org.omg.IOP.CodecFactoryPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.IOP.CodecFactoryPackage 中的类
 class UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.IOP.CodecPackage 中的类
class | FormatMismatch org/omg/IOP/CodecPackage/FormatMismatch.java。
class | InvalidTypeForEncoding org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

org.omg.PortableInterceptor 中 Serializable 的使用

org.omg.PortableInterceptor 中 Serializable 的子接口
interface | ClientRequestInfo 客户端请求 interceptor 可访问的请求信息。
interface | ClientRequestInterceptor 客户端 interceptor。
interface | Interceptor 所有 Portable Interceptor 实现 Interceptor。
interface | IORInfo 提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | ObjectReferenceFactory 对象引用工厂。
interface | ObjectReferenceTemplate 对象引用模板。
interface | ORBInitializer 便于注册 interceptor 和初始化 ORB。
interface | ORBInitInfo 传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
interface | PolicyFactory 使得策略类型能够使用 CORBA.ORB.create_policy 来构建。
interface | RequestInfo Interceptor 可访问的请求信息。
interface | ServerRequestInfo 服务器端请求 interceptor 可访问的请求信息。
interface | ServerRequestInterceptor 服务器端的请求 interceptor。

实现 Serializable 的 org.omg.PortableInterceptor 中的类
 class InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的类
 class DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

org.omg.PortableServer 中 Serializable 的使用

org.omg.PortableServer 中 Serializable 的子接口
interface | AdapterActivator 一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
interface | IdAssignmentPolicy IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdUniquenessPolicy IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | ImplicitActivationPolicy 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | LifespanPolicy LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | POA POA 对象管理对象集合的实现。
interface | POAManager 每个 POA 对象都有一个关联的 POAManager 对象。
interface | RequestProcessingPolicy 此策略指定已创建的 POA 处理请求的方式。
interface | ServantActivator POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantLocator 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
interface | ServantManager servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
interface | ServantRetentionPolicy 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ThreadPolicy ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。

实现 Serializable 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
class | ForwardRequest org/omg/PortableServer/ForwardRequest.java。
class | IdAssignmentPolicyValue IdAssignmentPolicyValue 可以具有以下值。
class | IdUniquenessPolicyValue IdUniquenessPolicyValue 可以具有以下值。
class | ImplicitActivationPolicyValue ImplicitActivationPolicyValue 具有以下语义。
class | LifespanPolicyValue LifespanPolicyValue 可以具有以下值。
class | RequestProcessingPolicyValue RequestProcessingPolicyValue 可以具有以下值。
class | ServantRetentionPolicyValue ServantRetentionPolicyValue 可以具有以下值。
class | ThreadPolicyValue ThreadPolicyValue 可以具有以下值。

org.omg.PortableServer.CurrentPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.PortableServer.CurrentPackage 中的类
 class NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.POAManagerPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.PortableServer.POAManagerPackage 中的类
class | AdapterInactive org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。
class | State 指定 POAManager 的状态。

org.omg.PortableServer.POAPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.PortableServer.POAPackage 中的类
class | AdapterAlreadyExists org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
class | AdapterNonExistent org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
class | InvalidPolicy org/omg/PortableServer/POAPackage/InvalidPolicy.java。
class | NoServant org/omg/PortableServer/POAPackage/NoServant.java。
class | ObjectAlreadyActive org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
class | ObjectNotActive org/omg/PortableServer/POAPackage/ObjectNotActive.java。
class | ServantAlreadyActive org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
class | ServantNotActive org/omg/PortableServer/POAPackage/ServantNotActive.java。
class | WrongAdapter org/omg/PortableServer/POAPackage/WrongAdapter.java。
class | WrongPolicy org/omg/PortableServer/POAPackage/WrongPolicy.java。

org.omg.SendingContext 中 Serializable 的使用

org.omg.SendingContext 中 Serializable 的子接口
 interface RunTime
定义表示请求的发送上下文的基类。

org.omg.stub.java.rmi 中 Serializable 的使用

实现 Serializable 的 org.omg.stub.java.rmi 中的类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

org.w3c.dom 中 Serializable 的使用

实现 Serializable 的 org.w3c.dom 中的类
 class DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

org.w3c.dom.events 中 Serializable 的使用

实现 Serializable 的 org.w3c.dom.events 中的类
 class EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。

org.w3c.dom.ls 中 Serializable 的使用

实现 Serializable 的 org.w3c.dom.ls 中的类
 class LSException
如果处理停止，解析或写操作可以抛出 LSException。

org.xml.sax 中 Serializable 的使用

实现 Serializable 的 org.xml.sax 中的类
class | SAXException 封装一般的 SAX 错误或警告。
class | SAXNotRecognizedException 用于未识别的标识符的 Exception 类。
class | SAXNotSupportedException 用于不被支持的操作的 Exception 类。
class | SAXParseException 封装 XML 解析错误或警告。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.SerializablePermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.SerializablePermission
的使用

使用 SerializablePermission 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 SerializablePermission 的使用

声明为 SerializablePermission 的 java.io 中的字段
static SerializablePermission | ObjectStreamConstants.SUBCLASS_IMPLEMENTATION_PERMISSION 允许重写 readObject 和 writeObject。
static SerializablePermission | ObjectStreamConstants.SUBSTITUTION_PERMISSION 允许在序列化/反序列化期间使用一个对象取代另一个对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.StreamCorruptedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.StreamCorruptedException
的使用

使用 StreamCorruptedException 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。

java.io 中 StreamCorruptedException 的使用

抛出 StreamCorruptedException 的 java.io 中的方法
protected  void ObjectInputStream.readStreamHeader()
提供的 readStreamHeader 方法允许子类读取并验证它们自己的流头部。

java.rmi.server 中 StreamCorruptedException 的使用

抛出 StreamCorruptedException 的 java.rmi.server 中的方法
 ObjectOutput RemoteCall.getResultStream(boolean success)
已过时。 无替代版本

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.StreamTokenizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.StreamTokenizer
的使用

没有 java.io.StreamTokenizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.StringBufferInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.StringBufferInputStream
的使用

没有 java.io.StringBufferInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.StringReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.StringReader
的使用

没有 java.io.StringReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.StringWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.StringWriter
的使用

使用 StringWriter 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 StringWriter 的使用

返回 StringWriter 的 java.io 中的方法
StringWriter | StringWriter.append(char c) 将指定字符添加到此 writer。
StringWriter | StringWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
StringWriter | StringWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.SyncFailedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.SyncFailedException
的使用

使用 SyncFailedException 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 SyncFailedException 的使用

抛出 SyncFailedException 的 java.io 中的方法
 void FileDescriptor.sync()
强制所有系统缓冲区与基础设备同步。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.UnsupportedEncodingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.UnsupportedEncodingException
的使用

使用 UnsupportedEncodingException 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

java.io 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 java.io 中的方法
 String ByteArrayOutputStream.toString(String charsetName)
使用指定的 charsetName，通过解码字节将缓冲区内容转换为字符串。

抛出 UnsupportedEncodingException 的 java.io 中的构造方法
InputStreamReader(InputStream in, String charsetName)
创建使用指定字符集的 InputStreamReader。
OutputStreamWriter(OutputStream out, String charsetName)
创建使用指定字符集的 OutputStreamWriter。
PrintStream(File file, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintStream(OutputStream out, boolean autoFlush, String encoding)
创建新的打印流。
PrintStream(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintWriter(File file, String csn)
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。
PrintWriter(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新 PrintWriter。

java.lang 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 java.lang 中的方法
 byte[] String.getBytes(String charsetName)
使用指定的字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。

抛出 UnsupportedEncodingException 的 java.lang 中的构造方法
String(byte[] bytes, int offset, int length, String charsetName)
通过使用指定的字符集解码指定的 byte 子数组，构造一个新的 String。
String(byte[] bytes, String charsetName)
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。

java.net 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 java.net 中的方法
static String | URLDecoder.decode(String s, String enc) 使用指定的编码机制对 application/x-www-form-urlencoded 字符串解码。
static String | URLEncoder.encode(String s, String enc) 使用指定的编码机制将字符串转换为 application/x-www-form-urlencoded 格式。

java.util 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 java.util 中的构造方法
Formatter(File file, String csn)
构造一个带指定文件和字符集的新 formatter。
Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。
Formatter(OutputStream os, String csn)
构造一个带指定输出流和字符集的新 formatter。
Formatter(OutputStream os, String csn, Locale l)
构造一个带指定输出流、字符集和语言环境的新 formatter。
Formatter(String fileName, String csn)
构造一个带指定文件名和字符集的新 formatter。
Formatter(String fileName, String csn, Locale l)
构造一个带指定文件名、字符集和语言环境的新 formatter。

java.util.logging 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 java.util.logging 中的方法
void | StreamHandler.setEncoding(String encoding) 设置（或更改）该 Handler 所用的字符编码。
void | Handler.setEncoding(String encoding) 设置该 Handler 所用的字符编码。

javax.xml.bind.helpers 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 javax.xml.bind.helpers 中的方法
protected  String AbstractMarshallerImpl.getJavaEncoding(String encoding)
从 IANA 名称获取相应的 Java 编码名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.UTFDataFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.UTFDataFormatException
的使用

没有 java.io.UTFDataFormatException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.WriteAbortedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.WriteAbortedException
的使用

没有 java.io.WriteAbortedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.io.Writer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.Writer
的使用

使用 Writer 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
org.w3c.dom.ls |

java.io 中 Writer 的使用

java.io 中 Writer 的子类
class | BufferedWriter 将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
class | CharArrayWriter 此类实现一个可用作 Writer 的字符缓冲区。
class | FileWriter 用来写入字符文件的便捷类。
class | FilterWriter 用于写入已过滤的字符流的抽象类。
class | OutputStreamWriter OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
class | PipedWriter 传送的字符输出流。
class | PrintWriter 向文本输出流打印对象的格式化表示形式。
class | StringWriter 一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。

声明为 Writer 的 java.io 中的字段
protected Writer | FilterWriter.out 底层字符输出流。
protected Writer | PrintWriter.out 此 PrintWriter 的底层字符输出流。

返回 Writer 的 java.io 中的方法
Writer | Writer.append(char c) 将指定字符添加到此 writer。
Writer | Writer.append(CharSequence csq) 将指定字符序列添加到此 writer。
Writer | Writer.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer.Appendable。

参数类型为 Writer 的 java.io 中的方法
 void CharArrayWriter.writeTo(Writer out)
将缓冲区的内容写入另一个字符流。

参数类型为 Writer 的 java.io 中的构造方法
BufferedWriter(Writer out)
创建一个使用默认大小输出缓冲区的缓冲字符输出流。
BufferedWriter(Writer out, int sz)
创建一个使用给定大小输出缓冲区的新缓冲字符输出流。
FilterWriter(Writer out)
创建一个新的 filtered writer。
PrintWriter(Writer out)
创建不带自动行刷新的新 PrintWriter。
PrintWriter(Writer out, boolean autoFlush)
创建新 PrintWriter。

java.nio.channels 中 Writer 的使用

返回 Writer 的 java.nio.channels 中的方法
static Writer | Channels.newWriter(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap) 构造一个 writer，它使用给定的编码器对字符进行编码，并将所得的字节写入给定的信道。
static Writer | Channels.newWriter(WritableByteChannel ch, String csName) 构造一个 writer，它根据指定的 charset 对字符进行编码，并将所得的字节写入给定的信道。

java.sql 中 Writer 的使用

返回 Writer 的 java.sql 中的方法
Writer | SQLXML.setCharacterStream() 获取用于写入此 SQLXML 实例表示的 XML 值的流。
Writer | Clob.setCharacterStream(long pos) 获取用于将 Unicode 字符流写入此 Clob 对象表示的 CLOB 值中（位置 pos 处）的流。

java.util 中 Writer 的使用

参数类型为 Writer 的 java.util 中的方法
 void Properties.store(Writer writer, String comments)
以适合使用 load(Reader) 方法的格式，将此 Properties 表中的属性列表（键和元素对）写入输出字符。

javax.lang.model.util 中 Writer 的使用

参数类型为 Writer 的 javax.lang.model.util 中的方法
 void Elements.printElements(Writer w, Element... elements)
按指定顺序将元素的表示形式打印到给定 writer。

javax.script 中 Writer 的使用

声明为 Writer 的 javax.script 中的字段
protected Writer | SimpleScriptContext.errorWriter 此字段是用于脚本输出错误的 writer。
protected Writer | SimpleScriptContext.writer 此字段是用于脚本输出的 writer。

返回 Writer 的 javax.script 中的方法
Writer | ScriptContext.getErrorWriter() 返回用来显示错误输出的 Writer。
Writer | SimpleScriptContext.getErrorWriter() 返回用来显示错误输出的 Writer。
Writer | ScriptContext.getWriter() 返回脚本的 Writer，以便在显示输出时使用。
Writer | SimpleScriptContext.getWriter() 返回脚本的 Writer，以便在显示输出时使用。

参数类型为 Writer 的 javax.script 中的方法
void | ScriptContext.setErrorWriter(Writer writer) 设置用来显示错误输出的 Writer。
void | SimpleScriptContext.setErrorWriter(Writer writer) 设置用来显示错误输出的 Writer。
void | ScriptContext.setWriter(Writer writer) 设置脚本的 Writer，以便在显示输出时使用。
void | SimpleScriptContext.setWriter(Writer writer) 设置脚本的 Writer，以便在显示输出时使用。

javax.sql.rowset 中 Writer 的使用

参数类型为 Writer 的 javax.sql.rowset 中的方法
void | WebRowSet.writeXml(ResultSet rs, Writer writer) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 Writer 对象。
void | WebRowSet.writeXml(Writer writer) 以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 Writer 对象。

javax.sql.rowset.serial 中 Writer 的使用

返回 Writer 的 javax.sql.rowset.serial 中的方法
 Writer SerialClob.setCharacterStream(long pos)
获取用于将 Unicode 字符流写入此 SerialClob 对象所表示的 CLOB 值（位置 pos 处）的流。

javax.sql.rowset.spi 中 Writer 的使用

参数类型为 Writer 的 javax.sql.rowset.spi 中的方法
 void XmlWriter.writeXML(WebRowSet caller, Writer writer)
将给定的 WebRowSet 对象以 XML 文档的形式编写到指定的 java.io.Writer 输出流。

javax.swing.text 中 Writer 的使用

返回 Writer 的 javax.swing.text 中的方法
protected  Writer AbstractWriter.getWriter()
返回用于输出内容的 Writer。

参数类型为 Writer 的 javax.swing.text 中的方法
void | JTextComponent.write(Writer out) 将模型的内容存储到给定的流中。
void | DefaultEditorKit.write(Writer out, Document doc, int pos, int len) 将取自文档的内容以纯文本格式写入给定流。
abstract void | EditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

参数类型为 Writer 的 javax.swing.text 中的构造方法
AbstractWriter(Writer w, Document doc)
创建新的 AbstractWriter。
AbstractWriter(Writer w, Document doc, int pos, int len)
创建新的 AbstractWriter。
AbstractWriter(Writer w, Element root)
创建新的 AbstractWriter。
AbstractWriter(Writer w, Element root, int pos, int len)
创建新的 AbstractWriter。

javax.swing.text.html 中 Writer 的使用

参数类型为 Writer 的 javax.swing.text.html 中的方法
 void HTMLEditorKit.write(Writer out, Document doc, int pos, int len)
以适合此类内容处理程序的格式，将文档中的内容写入给定流。

参数类型为 Writer 的 javax.swing.text.html 中的构造方法
HTMLWriter(Writer w, HTMLDocument doc)
创建新的 HTMLWriter。
HTMLWriter(Writer w, HTMLDocument doc, int pos, int len)
创建新的 HTMLWriter。
MinimalHTMLWriter(Writer w, StyledDocument doc)
创建一个新的 MinimalHTMLWriter。
MinimalHTMLWriter(Writer w, StyledDocument doc, int pos, int len)
创建一个新的 MinimalHTMLWriter。

javax.swing.text.rtf 中 Writer 的使用

参数类型为 Writer 的 javax.swing.text.rtf 中的方法
 void RTFEditorKit.write(Writer out, Document doc, int pos, int len)
将文档中的内容作为纯文本写入给定的流。

javax.tools 中 Writer 的使用

返回 Writer 的 javax.tools 中的方法
Writer | FileObject.openWriter() 获取此文件对象的 Writer。
Writer | ForwardingFileObject.openWriter()
Writer | SimpleJavaFileObject.openWriter() 在 Writer 中包装 openOutputStream 的结果。

参数类型为 Writer 的 javax.tools 中的方法
 JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。

javax.xml.bind 中 Writer 的使用

参数类型为 Writer 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, Writer writer)
将以 jaxbElement 为根的内容树编组到 Writer 中。

javax.xml.bind.helpers 中 Writer 的使用

参数类型为 Writer 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, Writer w)

javax.xml.stream 中 Writer 的使用

参数类型为 Writer 的 javax.xml.stream 中的方法
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(Writer stream) 创建一个写入到 writer 的新 XMLEventWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(Writer stream) 创建一个写入到 writer 的新 XMLStreamWriter。

javax.xml.stream.events 中 Writer 的使用

参数类型为 Writer 的 javax.xml.stream.events 中的方法
 void XMLEvent.writeAsEncodedUnicode(Writer writer)
此方法根据 XML 1.0 规范将 XMLEvent 编写为 Unicode 字符。

javax.xml.transform.stream 中 Writer 的使用

返回 Writer 的 javax.xml.transform.stream 中的方法
 Writer StreamResult.getWriter()
获取通过 setWriter 设置的字符流。

参数类型为 Writer 的 javax.xml.transform.stream 中的方法
 void StreamResult.setWriter(Writer writer)
设置要接收结果的 writer。

参数类型为 Writer 的 javax.xml.transform.stream 中的构造方法
StreamResult(Writer writer)
从字符流构造 StreamResult。

org.w3c.dom.ls 中 Writer 的使用

返回 Writer 的 org.w3c.dom.ls 中的方法
 Writer LSOutput.getCharacterStream()
具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。

参数类型为 Writer 的 org.w3c.dom.ls 中的方法
 void LSOutput.setCharacterStream(Writer characterStream)
具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.lang (Java 2 Platform SE 6)

 java.lang
接口
Appendable
CharSequence
Cloneable
Comparable
Iterable
Readable
Runnable
Thread.UncaughtExceptionHandler
类
Boolean
Byte
Character
Character.Subset
Character.UnicodeBlock
Class
ClassLoader
Compiler
Double
Enum
Float
InheritableThreadLocal
Integer
Long
Math
Number
Object
Package
Process
ProcessBuilder
Runtime
RuntimePermission
SecurityManager
Short
StackTraceElement
StrictMath
String
StringBuffer
StringBuilder
System
Thread
ThreadGroup
ThreadLocal
Throwable
Void
枚举
Thread.State
异常
ArithmeticException
ArrayIndexOutOfBoundsException
ArrayStoreException
ClassCastException
ClassNotFoundException
CloneNotSupportedException
EnumConstantNotPresentException
Exception
IllegalAccessException
IllegalArgumentException
IllegalMonitorStateException
IllegalStateException
IllegalThreadStateException
IndexOutOfBoundsException
InstantiationException
InterruptedException
NegativeArraySizeException
NoSuchFieldException
NoSuchMethodException
NullPointerException
NumberFormatException
RuntimeException
SecurityException
StringIndexOutOfBoundsException
TypeNotPresentException
UnsupportedOperationException
错误
AbstractMethodError
AssertionError
ClassCircularityError
ClassFormatError
Error
ExceptionInInitializerError
IllegalAccessError
IncompatibleClassChangeError
InstantiationError
InternalError
LinkageError
NoClassDefFoundError
NoSuchFieldError
NoSuchMethodError
OutOfMemoryError
StackOverflowError
ThreadDeath
UnknownError
UnsatisfiedLinkError
UnsupportedClassVersionError
VerifyError
VirtualMachineError
注释类型
Deprecated
Override
SuppressWarnings


java.lang.annotation (Java 2 Platform SE 6)

 java.lang.annotation
接口
Annotation
枚举
ElementType
RetentionPolicy
异常
AnnotationTypeMismatchException
IncompleteAnnotationException
错误
AnnotationFormatError
注释类型
Documented
Inherited
Retention
Target


接口 java.lang.annotation.Annotation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.annotation.Annotation
的使用

使用 Annotation 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.jws |
javax.jws.soap |
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.beans 中 Annotation 的使用

实现 Annotation 的 java.beans 中的类
 interface ConstructorProperties
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。

java.lang 中 Annotation 的使用

实现 Annotation 的 java.lang 中的类
interface | Deprecated 用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
interface | Override 表示一个方法声明打算重写超类中的另一个方法声明。
interface | SuppressWarnings 指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。

类型参数类型为 Annotation 的 java.lang 中的方法
<A extends Annotation>
A
Package.getAnnotation(Class<A> annotationClass)
<A extends Annotation>
A
Class.getAnnotation(Class<A> annotationClass)

返回 Annotation 的 java.lang 中的方法
Annotation[] | Package.getAnnotations()
Annotation[] | Class.getAnnotations()
Annotation[] | Package.getDeclaredAnnotations()
Annotation[] | Class.getDeclaredAnnotations()

类型变量类型为 Annotation 的 java.lang 中的方法参数
boolean | Package.isAnnotationPresent(Class<? extends Annotation> annotationClass)
boolean | Class.isAnnotationPresent(Class<? extends Annotation> annotationClass)

java.lang.annotation 中 Annotation 的使用

实现 Annotation 的 java.lang.annotation 中的类
interface | Documented 指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
interface | Inherited 指示注释类型被自动继承。
interface | Retention 指示注释类型的注释要保留多久。
interface | Target 指示注释类型所适用的程序元素的种类。

返回变量类型为 Annotation 的类型的 java.lang.annotation 中的方法
Class<? extends Annotation> | IncompleteAnnotationException.annotationType() 返回带有缺少元素的注释类型的 Class 对象。
Class<? extends Annotation> | Annotation.annotationType() 返回此 annotation 的注释类型。

类型变量类型为 Annotation 的 java.lang.annotation 中的构造方法参数
IncompleteAnnotationException(Class<? extends Annotation> annotationType, String elementName)
构造一个指示指定注释类型中缺少指定元素的 IncompleteAnnotationException。

java.lang.reflect 中 Annotation 的使用

类型参数类型为 Annotation 的 java.lang.reflect 中的方法
<T extends Annotation>
T
Constructor.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
Method.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
Field.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
AccessibleObject.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
AnnotatedElement.getAnnotation(Class<T> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。

返回 Annotation 的 java.lang.reflect 中的方法
Annotation[] | AccessibleObject.getAnnotations()
Annotation[] | AnnotatedElement.getAnnotations() 返回此元素上存在的所有注释。
Annotation[] | Constructor.getDeclaredAnnotations()
Annotation[] | Method.getDeclaredAnnotations()
Annotation[] | Field.getDeclaredAnnotations()
Annotation[] | AccessibleObject.getDeclaredAnnotations()
Annotation[] | AnnotatedElement.getDeclaredAnnotations() 返回直接存在于此元素上的所有注释。
Annotation[][] | Constructor.getParameterAnnotations() 按照声明顺序返回一组数组，这些数组表示通过此 Constructor 对象表示的方法的形参上的注释。
Annotation[][] | Method.getParameterAnnotations() 返回表示按照声明顺序对此 Method 对象所表示方法的形参进行注释的那个数组的数组。

类型变量类型为 Annotation 的 java.lang.reflect 中的方法参数
boolean | AccessibleObject.isAnnotationPresent(Class<? extends Annotation> annotationClass)
boolean | AnnotatedElement.isAnnotationPresent(Class<? extends Annotation> annotationClass) 如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。

javax.annotation 中 Annotation 的使用

实现 Annotation 的 javax.annotation 中的类
interface | Generated Generated 注释用于标记已生成的源代码。
interface | PostConstruct PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
interface | PreDestroy PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
interface | Resource Resource 注释标记应用程序所需的资源。
interface | Resources 此类用于允许多个资源声明。

javax.annotation.processing 中 Annotation 的使用

实现 Annotation 的 javax.annotation.processing 中的类
interface | SupportedAnnotationTypes 用来指示注释处理器支持哪些注释类型的注释。
interface | SupportedOptions 用来指示注释处理器支持哪些选项的注释。
interface | SupportedSourceVersion 用来指示注释处理器所支持的最新源版本的注释。

类型变量类型为 Annotation 的 javax.annotation.processing 中的方法参数
 Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith(Class<? extends Annotation> a)
返回使用给定注释类型注释的元素。

javax.jws 中 Annotation 的使用

实现 Annotation 的 javax.jws 中的类
interface | HandlerChain 将 Web Service 与外部定义的处理程序链关联。
interface | Oneway 指示给定 @WebMethod 只有一条输入消息并且没有输出。
interface | WebMethod 定制一个公开为 Web Service 操作的方法。
interface | WebParam 定制单个参数到 Web Service 消息部分和 XML 元素的映射关系。
interface | WebResult 定制返回值到 WSDL 部分和 XML 元素的映射关系。
interface | WebService 将 Java 类标记为实现 Web Service，或者将 Java 接口标记为定义 Web Service 接口。

javax.jws.soap 中 Annotation 的使用

实现 Annotation 的 javax.jws.soap 中的类
interface | InitParam 已过时。 从 JSR-181 2.0 开始，无替代版本。
interface | SOAPBinding 指定 Web Service 到 SOAP 消息协议的映射关系。
interface | SOAPMessageHandler 已过时。 从 JSR-181 2.0 开始，无替代版本。
interface | SOAPMessageHandlers 已过时。 从 JSR-181 2.0 开始，无替代版本。

javax.lang.model.element 中 Annotation 的使用

类型参数类型为 Annotation 的 javax.lang.model.element 中的方法
<A extends Annotation>
A
Element.getAnnotation(Class<A> annotationType)
返回此元素针对指定类型的注释（如果存在这样的注释），否则返回 null。

javax.management 中 Annotation 的使用

实现 Annotation 的 javax.management 中的类
interface | DescriptorKey 描述注释元素与 Descriptor 中字段之间关联方式的元注释。
interface | MXBean 显式地标记某一接口是否为 MXBean 接口的注释。

javax.xml.bind.annotation 中 Annotation 的使用

实现 Annotation 的 javax.xml.bind.annotation 中的类
interface | XmlAccessorOrder 控制类中字段和属性的排序。
interface | XmlAccessorType 控制默认情况下是否对字段或 Javabean 属性进行系列化。
interface | XmlAnyAttribute 将 JavaBean 属性映射到通配符属性的映射表中。
interface | XmlAnyElement 将 JavaBean 属性映射到 XML 信息集表示形式和/或 JAXB 元素。
interface | XmlAttachmentRef 标记字段/属性，其 XML 形式是对 MIME 内容的 URI 引用。
interface | XmlAttribute 将 JavaBean 属性映射到 XML 属性。
interface | XmlElement 将 JavaBean 属性映射到派生于属性名称的 XML 元素。
interface | XmlElementDecl 将工厂方法映射到 XML 元素。
interface | XmlElementRef 将 JavaBean 属性映射到派生于属性类型的 XML 元素。
interface | XmlElementRefs 标记一个属性，该属性引用带有 XmlElement 或 JAXBElement 的类。
interface | XmlElements 多个 @XmlElement 注释的容器。
interface | XmlElementWrapper 生成一个包装 XML 表示形式的包装器元素。
interface | XmlEnum 将枚举类型 Enum 映射到 XML 表示形式。
interface | XmlEnumValue 将 Enum 类型中的枚举常量映射到 XML 表示形式。
interface | XmlID 将 JavaBean 属性映射到 XML ID。
interface | XmlIDREF 将 JavaBean 属性映射到 XML IDREF。
interface | XmlInlineBinaryData 禁止对绑定到 XML 中 base64-encoded 二进制数据的数据类型进行 XOP 编码。
interface | XmlList 用来将属性映射到列表简单类型。
interface | XmlMimeType 关联控制属性 XML 表示形式的 MIME 类型。
interface | XmlMixed 注释 JavaBean 多值属性，以支持混合内容。
interface | XmlNs 关联名称空间前缀与 XML 名称空间 URI。
interface | XmlRegistry 标记具有 XmlElementDecl 的类。
interface | XmlRootElement 将类或枚举类型映射到 XML 元素。
interface | XmlSchema 将包名称映射到 XML 名称空间。
interface | XmlSchemaType 将 Java 类型映射到一个简单的模式内置类型。
interface | XmlSchemaTypes 多个 @XmlSchemaType 注释的容器。
interface | XmlTransient 阻止将 JavaBean 属性映射到 XML 表示形式。
interface | XmlType 将类或枚举类型映射到 XML 模式类型。
interface | XmlValue 支持将类映射到带有 simpleContent 的 XML 模式复杂类型或 XML 模式简单类型。

javax.xml.bind.annotation.adapters 中 Annotation 的使用

实现 Annotation 的 javax.xml.bind.annotation.adapters 中的类
interface | XmlJavaTypeAdapter 对自定义编组使用实现 XmlAdapter 的适配器。
interface | XmlJavaTypeAdapters 多个 @XmlJavaTypeAdapter 注释的容器。

javax.xml.ws 中 Annotation 的使用

实现 Annotation 的 javax.xml.ws 中的类
interface | BindingType BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
interface | RequestWrapper 此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
interface | ResponseWrapper 此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
interface | ServiceMode 用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
interface | WebEndpoint 此类用来注释所生成服务接口的 getPortName() 方法。
interface | WebFault 此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
interface | WebServiceClient 此类用来注释生成的服务接口。
interface | WebServiceProvider 此类用来注释 Provider 实现类。
interface | WebServiceRef WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
interface | WebServiceRefs WebServiceRefs 注释允许在类级别声明多个 web 服务引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.annotation.AnnotationFormatError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.AnnotationFormatError
的使用

没有 java.lang.annotation.AnnotationFormatError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.annotation.AnnotationTypeMismatchException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.AnnotationTypeMismatchException
的使用

没有 java.lang.annotation.AnnotationTypeMismatchException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.annotation.Documented 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.Documented
的使用

使用 Documented 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.beans 中 Documented 的使用

注释类型为 Documented 的 java.beans 中的类
 interface ConstructorProperties
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。

java.lang 中 Documented 的使用

注释类型为 Documented 的 java.lang 中的类
 interface Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。

java.lang.annotation 中 Documented 的使用

注释类型为 Documented 的 java.lang.annotation 中的类
interface | Documented 指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
interface | Inherited 指示注释类型被自动继承。
interface | Retention 指示注释类型的注释要保留多久。
interface | Target 指示注释类型所适用的程序元素的种类。

javax.annotation 中 Documented 的使用

注释类型为 Documented 的 javax.annotation 中的类
interface | Generated Generated 注释用于标记已生成的源代码。
interface | PostConstruct PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
interface | PreDestroy PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
interface | Resources 此类用于允许多个资源声明。

javax.annotation.processing 中 Documented 的使用

注释类型为 Documented 的 javax.annotation.processing 中的类
interface | SupportedAnnotationTypes 用来指示注释处理器支持哪些注释类型的注释。
interface | SupportedOptions 用来指示注释处理器支持哪些选项的注释。
interface | SupportedSourceVersion 用来指示注释处理器所支持的最新源版本的注释。

javax.management 中 Documented 的使用

注释类型为 Documented 的 javax.management 中的类
interface | DescriptorKey 描述注释元素与 Descriptor 中字段之间关联方式的元注释。
interface | MXBean 显式地标记某一接口是否为 MXBean 接口的注释。

javax.xml.ws 中 Documented 的使用

注释类型为 Documented 的 javax.xml.ws 中的类
interface | BindingType BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
interface | RequestWrapper 此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
interface | ResponseWrapper 此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
interface | ServiceMode 用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
interface | WebEndpoint 此类用来注释所生成服务接口的 getPortName() 方法。
interface | WebFault 此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
interface | WebServiceClient 此类用来注释生成的服务接口。
interface | WebServiceProvider 此类用来注释 Provider 实现类。
interface | WebServiceRef WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
interface | WebServiceRefs WebServiceRefs 注释允许在类级别声明多个 web 服务引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.annotation.ElementType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.ElementType
的使用

使用 ElementType 的软件包
java.lang.annotation 为 Java 编程语言注释设施提供库支持。

java.lang.annotation 中 ElementType 的使用

返回 ElementType 的 java.lang.annotation 中的方法
static ElementType | ElementType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static ElementType[] | ElementType.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.annotation.IncompleteAnnotationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.IncompleteAnnotationException
的使用

没有 java.lang.annotation.IncompleteAnnotationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.annotation.Inherited 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.Inherited
的使用

使用 Inherited 的软件包
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.ws | 此包包含核心 JAX-WS API。

javax.xml.bind.annotation 中 Inherited 的使用

注释类型为 Inherited 的 javax.xml.bind.annotation 中的类
interface | XmlAccessorOrder 控制类中字段和属性的排序。
interface | XmlAccessorType 控制默认情况下是否对字段或 Javabean 属性进行系列化。

javax.xml.ws 中 Inherited 的使用

注释类型为 Inherited 的 javax.xml.ws 中的类
 interface ServiceMode
用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.annotation.Retention 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.Retention
的使用

使用 Retention 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.jws |
javax.jws.soap |
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.beans 中 Retention 的使用

注释类型为 Retention 的 java.beans 中的类
 interface ConstructorProperties
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。

java.lang 中 Retention 的使用

注释类型为 Retention 的 java.lang 中的类
interface | Deprecated 用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
interface | Override 表示一个方法声明打算重写超类中的另一个方法声明。
interface | SuppressWarnings 指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。

java.lang.annotation 中 Retention 的使用

注释类型为 Retention 的 java.lang.annotation 中的类
interface | Documented 指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
interface | Inherited 指示注释类型被自动继承。
interface | Retention 指示注释类型的注释要保留多久。
interface | Target 指示注释类型所适用的程序元素的种类。

javax.annotation 中 Retention 的使用

注释类型为 Retention 的 javax.annotation 中的类
interface | Generated Generated 注释用于标记已生成的源代码。
interface | PostConstruct PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
interface | PreDestroy PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
interface | Resource Resource 注释标记应用程序所需的资源。
interface | Resources 此类用于允许多个资源声明。

javax.annotation.processing 中 Retention 的使用

注释类型为 Retention 的 javax.annotation.processing 中的类
interface | SupportedAnnotationTypes 用来指示注释处理器支持哪些注释类型的注释。
interface | SupportedOptions 用来指示注释处理器支持哪些选项的注释。
interface | SupportedSourceVersion 用来指示注释处理器所支持的最新源版本的注释。

javax.jws 中 Retention 的使用

注释类型为 Retention 的 javax.jws 中的类
interface | HandlerChain 将 Web Service 与外部定义的处理程序链关联。
interface | Oneway 指示给定 @WebMethod 只有一条输入消息并且没有输出。
interface | WebMethod 定制一个公开为 Web Service 操作的方法。
interface | WebParam 定制单个参数到 Web Service 消息部分和 XML 元素的映射关系。
interface | WebResult 定制返回值到 WSDL 部分和 XML 元素的映射关系。
interface | WebService 将 Java 类标记为实现 Web Service，或者将 Java 接口标记为定义 Web Service 接口。

javax.jws.soap 中 Retention 的使用

注释类型为 Retention 的 javax.jws.soap 中的类
interface | SOAPBinding 指定 Web Service 到 SOAP 消息协议的映射关系。
interface | SOAPMessageHandlers 已过时。 从 JSR-181 2.0 开始，无替代版本。

javax.management 中 Retention 的使用

注释类型为 Retention 的 javax.management 中的类
interface | DescriptorKey 描述注释元素与 Descriptor 中字段之间关联方式的元注释。
interface | MXBean 显式地标记某一接口是否为 MXBean 接口的注释。

javax.xml.bind.annotation 中 Retention 的使用

注释类型为 Retention 的 javax.xml.bind.annotation 中的类
interface | XmlAccessorOrder 控制类中字段和属性的排序。
interface | XmlAccessorType 控制默认情况下是否对字段或 Javabean 属性进行系列化。
interface | XmlAnyAttribute 将 JavaBean 属性映射到通配符属性的映射表中。
interface | XmlAnyElement 将 JavaBean 属性映射到 XML 信息集表示形式和/或 JAXB 元素。
interface | XmlAttachmentRef 标记字段/属性，其 XML 形式是对 MIME 内容的 URI 引用。
interface | XmlAttribute 将 JavaBean 属性映射到 XML 属性。
interface | XmlElement 将 JavaBean 属性映射到派生于属性名称的 XML 元素。
interface | XmlElementDecl 将工厂方法映射到 XML 元素。
interface | XmlElementRef 将 JavaBean 属性映射到派生于属性类型的 XML 元素。
interface | XmlElementRefs 标记一个属性，该属性引用带有 XmlElement 或 JAXBElement 的类。
interface | XmlElements 多个 @XmlElement 注释的容器。
interface | XmlElementWrapper 生成一个包装 XML 表示形式的包装器元素。
interface | XmlEnum 将枚举类型 Enum 映射到 XML 表示形式。
interface | XmlEnumValue 将 Enum 类型中的枚举常量映射到 XML 表示形式。
interface | XmlID 将 JavaBean 属性映射到 XML ID。
interface | XmlIDREF 将 JavaBean 属性映射到 XML IDREF。
interface | XmlInlineBinaryData 禁止对绑定到 XML 中 base64-encoded 二进制数据的数据类型进行 XOP 编码。
interface | XmlList 用来将属性映射到列表简单类型。
interface | XmlMimeType 关联控制属性 XML 表示形式的 MIME 类型。
interface | XmlMixed 注释 JavaBean 多值属性，以支持混合内容。
interface | XmlNs 关联名称空间前缀与 XML 名称空间 URI。
interface | XmlRegistry 标记具有 XmlElementDecl 的类。
interface | XmlRootElement 将类或枚举类型映射到 XML 元素。
interface | XmlSchema 将包名称映射到 XML 名称空间。
interface | XmlSchemaType 将 Java 类型映射到一个简单的模式内置类型。
interface | XmlSchemaTypes 多个 @XmlSchemaType 注释的容器。
interface | XmlTransient 阻止将 JavaBean 属性映射到 XML 表示形式。
interface | XmlType 将类或枚举类型映射到 XML 模式类型。
interface | XmlValue 支持将类映射到带有 simpleContent 的 XML 模式复杂类型或 XML 模式简单类型。

javax.xml.bind.annotation.adapters 中 Retention 的使用

注释类型为 Retention 的 javax.xml.bind.annotation.adapters 中的类
interface | XmlJavaTypeAdapter 对自定义编组使用实现 XmlAdapter 的适配器。
interface | XmlJavaTypeAdapters 多个 @XmlJavaTypeAdapter 注释的容器。

javax.xml.ws 中 Retention 的使用

注释类型为 Retention 的 javax.xml.ws 中的类
interface | BindingType BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
interface | RequestWrapper 此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
interface | ResponseWrapper 此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
interface | ServiceMode 用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
interface | WebEndpoint 此类用来注释所生成服务接口的 getPortName() 方法。
interface | WebFault 此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
interface | WebServiceClient 此类用来注释生成的服务接口。
interface | WebServiceProvider 此类用来注释 Provider 实现类。
interface | WebServiceRef WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
interface | WebServiceRefs WebServiceRefs 注释允许在类级别声明多个 web 服务引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.annotation.RetentionPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.RetentionPolicy
的使用

使用 RetentionPolicy 的软件包
java.lang.annotation 为 Java 编程语言注释设施提供库支持。

java.lang.annotation 中 RetentionPolicy 的使用

返回 RetentionPolicy 的 java.lang.annotation 中的方法
static RetentionPolicy | RetentionPolicy.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RetentionPolicy[] | RetentionPolicy.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.annotation.Target 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.Target
的使用

使用 Target 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.jws |
javax.jws.soap |
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.beans 中 Target 的使用

注释类型为 Target 的 java.beans 中的类
 interface ConstructorProperties
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。

java.lang 中 Target 的使用

注释类型为 Target 的 java.lang 中的类
interface | Override 表示一个方法声明打算重写超类中的另一个方法声明。
interface | SuppressWarnings 指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。

java.lang.annotation 中 Target 的使用

注释类型为 Target 的 java.lang.annotation 中的类
interface | Documented 指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
interface | Inherited 指示注释类型被自动继承。
interface | Retention 指示注释类型的注释要保留多久。
interface | Target 指示注释类型所适用的程序元素的种类。

javax.annotation 中 Target 的使用

注释类型为 Target 的 javax.annotation 中的类
interface | Generated Generated 注释用于标记已生成的源代码。
interface | PostConstruct PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
interface | PreDestroy PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
interface | Resource Resource 注释标记应用程序所需的资源。
interface | Resources 此类用于允许多个资源声明。

javax.annotation.processing 中 Target 的使用

注释类型为 Target 的 javax.annotation.processing 中的类
interface | SupportedAnnotationTypes 用来指示注释处理器支持哪些注释类型的注释。
interface | SupportedOptions 用来指示注释处理器支持哪些选项的注释。
interface | SupportedSourceVersion 用来指示注释处理器所支持的最新源版本的注释。

javax.jws 中 Target 的使用

注释类型为 Target 的 javax.jws 中的类
interface | HandlerChain 将 Web Service 与外部定义的处理程序链关联。
interface | Oneway 指示给定 @WebMethod 只有一条输入消息并且没有输出。
interface | WebMethod 定制一个公开为 Web Service 操作的方法。
interface | WebParam 定制单个参数到 Web Service 消息部分和 XML 元素的映射关系。
interface | WebResult 定制返回值到 WSDL 部分和 XML 元素的映射关系。
interface | WebService 将 Java 类标记为实现 Web Service，或者将 Java 接口标记为定义 Web Service 接口。

javax.jws.soap 中 Target 的使用

注释类型为 Target 的 javax.jws.soap 中的类
interface | SOAPBinding 指定 Web Service 到 SOAP 消息协议的映射关系。
interface | SOAPMessageHandlers 已过时。 从 JSR-181 2.0 开始，无替代版本。

javax.management 中 Target 的使用

注释类型为 Target 的 javax.management 中的类
interface | DescriptorKey 描述注释元素与 Descriptor 中字段之间关联方式的元注释。
interface | MXBean 显式地标记某一接口是否为 MXBean 接口的注释。

javax.xml.bind.annotation 中 Target 的使用

注释类型为 Target 的 javax.xml.bind.annotation 中的类
interface | XmlAccessorOrder 控制类中字段和属性的排序。
interface | XmlAccessorType 控制默认情况下是否对字段或 Javabean 属性进行系列化。
interface | XmlAnyAttribute 将 JavaBean 属性映射到通配符属性的映射表中。
interface | XmlAnyElement 将 JavaBean 属性映射到 XML 信息集表示形式和/或 JAXB 元素。
interface | XmlAttachmentRef 标记字段/属性，其 XML 形式是对 MIME 内容的 URI 引用。
interface | XmlAttribute 将 JavaBean 属性映射到 XML 属性。
interface | XmlElement 将 JavaBean 属性映射到派生于属性名称的 XML 元素。
interface | XmlElementDecl 将工厂方法映射到 XML 元素。
interface | XmlElementRef 将 JavaBean 属性映射到派生于属性类型的 XML 元素。
interface | XmlElementRefs 标记一个属性，该属性引用带有 XmlElement 或 JAXBElement 的类。
interface | XmlElements 多个 @XmlElement 注释的容器。
interface | XmlElementWrapper 生成一个包装 XML 表示形式的包装器元素。
interface | XmlEnum 将枚举类型 Enum 映射到 XML 表示形式。
interface | XmlEnumValue 将 Enum 类型中的枚举常量映射到 XML 表示形式。
interface | XmlID 将 JavaBean 属性映射到 XML ID。
interface | XmlIDREF 将 JavaBean 属性映射到 XML IDREF。
interface | XmlInlineBinaryData 禁止对绑定到 XML 中 base64-encoded 二进制数据的数据类型进行 XOP 编码。
interface | XmlList 用来将属性映射到列表简单类型。
interface | XmlMimeType 关联控制属性 XML 表示形式的 MIME 类型。
interface | XmlMixed 注释 JavaBean 多值属性，以支持混合内容。
interface | XmlNs 关联名称空间前缀与 XML 名称空间 URI。
interface | XmlRegistry 标记具有 XmlElementDecl 的类。
interface | XmlRootElement 将类或枚举类型映射到 XML 元素。
interface | XmlSchema 将包名称映射到 XML 名称空间。
interface | XmlSchemaType 将 Java 类型映射到一个简单的模式内置类型。
interface | XmlSchemaTypes 多个 @XmlSchemaType 注释的容器。
interface | XmlTransient 阻止将 JavaBean 属性映射到 XML 表示形式。
interface | XmlType 将类或枚举类型映射到 XML 模式类型。
interface | XmlValue 支持将类映射到带有 simpleContent 的 XML 模式复杂类型或 XML 模式简单类型。

javax.xml.bind.annotation.adapters 中 Target 的使用

注释类型为 Target 的 javax.xml.bind.annotation.adapters 中的类
interface | XmlJavaTypeAdapter 对自定义编组使用实现 XmlAdapter 的适配器。
interface | XmlJavaTypeAdapters 多个 @XmlJavaTypeAdapter 注释的容器。

javax.xml.ws 中 Target 的使用

注释类型为 Target 的 javax.xml.ws 中的类
interface | BindingType BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
interface | RequestWrapper 此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
interface | ResponseWrapper 此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
interface | ServiceMode 用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
interface | WebEndpoint 此类用来注释所生成服务接口的 getPortName() 方法。
interface | WebFault 此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
interface | WebServiceClient 此类用来注释生成的服务接口。
interface | WebServiceProvider 此类用来注释 Provider 实现类。
interface | WebServiceRef WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
interface | WebServiceRefs WebServiceRefs 注释允许在类级别声明多个 web 服务引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.AbstractMethodError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.AbstractMethodError
的使用

没有 java.lang.AbstractMethodError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.Appendable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Appendable
的使用

使用 Appendable 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.io 中 Appendable 的使用

实现 Appendable 的 java.io 中的类
class | BufferedWriter 将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
class | CharArrayWriter 此类实现一个可用作 Writer 的字符缓冲区。
class | FileWriter 用来写入字符文件的便捷类。
class | FilterWriter 用于写入已过滤的字符流的抽象类。
class | OutputStreamWriter OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
class | PipedWriter 传送的字符输出流。
class | PrintStream PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
class | PrintWriter 向文本输出流打印对象的格式化表示形式。
class | StringWriter 一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。
class | Writer 写入字符流的抽象类。

java.lang 中 Appendable 的使用

实现 Appendable 的 java.lang 中的类
class | StringBuffer 线程安全的可变字符序列。
class | StringBuilder 一个可变的字符序列。

返回 Appendable 的 java.lang 中的方法
Appendable | Appendable.append(char c) 向此 Appendable 添加指定字符。
Appendable | Appendable.append(CharSequence csq) 向此 Appendable 添加指定的字符序列。
Appendable | Appendable.append(CharSequence csq, int start, int end) 向此 Appendable 添加指定字符序列的子序列。

java.nio 中 Appendable 的使用

实现 Appendable 的 java.nio 中的类
 class CharBuffer
字符缓冲区。

java.rmi.server 中 Appendable 的使用

实现 Appendable 的 java.rmi.server 中的类
 class LogStream
已过时。 无替代版本

java.util 中 Appendable 的使用

返回 Appendable 的 java.util 中的方法
 Appendable Formatter.out()
返回输出的目标文件。

参数类型为 Appendable 的 java.util 中的构造方法
Formatter(Appendable a)
构造一个带指定目标文件的新 formatter。
Formatter(Appendable a, Locale l)
构造一个带指定目标文件和语言环境的新 formatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ArithmeticException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ArithmeticException
的使用

没有 java.lang.ArithmeticException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ArrayIndexOutOfBoundsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ArrayIndexOutOfBoundsException
的使用

使用 ArrayIndexOutOfBoundsException 的软件包
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

java.lang.reflect 中 ArrayIndexOutOfBoundsException 的使用

抛出 ArrayIndexOutOfBoundsException 的 java.lang.reflect 中的方法
static Object | Array.get(Object array, int index) 返回指定数组对象中索引组件的值。
static boolean | Array.getBoolean(Object array, int index) 以 boolean 形式返回指定数组对象中索引组件的值。
static byte | Array.getByte(Object array, int index) 以 byte 形式返回指定数组对象中索引组件的值。
static char | Array.getChar(Object array, int index) 以 char 形式返回指定数组对象中索引组件的值。
static double | Array.getDouble(Object array, int index) 以 double 形式返回指定数组对象中索引组件的值。
static float | Array.getFloat(Object array, int index) 以 float 形式返回指定数组对象中索引组件的值。
static int | Array.getInt(Object array, int index) 以 int 形式返回指定数组对象中索引组件的值。
static long | Array.getLong(Object array, int index) 以 long 形式返回指定数组对象中索引组件的值。
static short | Array.getShort(Object array, int index) 以 short 形式返回指定数组对象中索引组件的值。
static void | Array.set(Object array, int index, Object value) 将指定数组对象中索引组件的值设置为指定的新值。
static void | Array.setBoolean(Object array, int index, boolean z) 将指定数组对象中索引组件的值设置为指定的 boolean 值。
static void | Array.setByte(Object array, int index, byte b) 将指定数组对象中索引组件的值设置为指定的 byte 值。
static void | Array.setChar(Object array, int index, char c) 将指定数组对象中索引组件的值设置为指定的 char 值。
static void | Array.setDouble(Object array, int index, double d) 将指定数组对象中索引组件的值设置为指定的 double 值。
static void | Array.setFloat(Object array, int index, float f) 将指定数组对象中索引组件的值设置为指定的 float 值。
static void | Array.setInt(Object array, int index, int i) 将指定数组对象中索引组件的值设置为指定的 int 值。
static void | Array.setLong(Object array, int index, long l) 将指定数组对象中索引组件的值设置为指定的 long 值。
static void | Array.setShort(Object array, int index, short s) 将指定数组对象中索引组件的值设置为指定的 short 值。

javax.sound.midi 中 ArrayIndexOutOfBoundsException 的使用

抛出 ArrayIndexOutOfBoundsException 的 javax.sound.midi 中的方法
 MidiEvent Track.get(int index)
获得位于指定索引处的事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ArrayStoreException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ArrayStoreException
的使用

没有 java.lang.ArrayStoreException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.AssertionError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.AssertionError
的使用

没有 java.lang.AssertionError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Boolean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Boolean
的使用

使用 Boolean 的软件包
java.awt.font | 提供与字体相关的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.awt.font 中 Boolean 的使用

声明为 Boolean 的 java.awt.font 中的字段
static Boolean | TextAttribute.RUN_DIRECTION_LTR 从左到右的延伸方向。
static Boolean | TextAttribute.RUN_DIRECTION_RTL 从右到左的延伸方向。
static Boolean | TextAttribute.STRIKETHROUGH_ON 单删除线。
static Boolean | TextAttribute.SWAP_COLORS_ON 交换前景和背景。

java.lang 中 Boolean 的使用

声明为 Boolean 的 java.lang 中的字段
static Boolean | Boolean.FALSE 对应基值 false 的 Boolean 对象。
static Boolean | Boolean.TRUE 对应基值 true 的 Boolean 对象。

类型参数类型为 Boolean 的 java.lang 中的字段
static Class<Boolean> Boolean.TYPE
表示基本类型 boolean 的 Class 对象。

返回 Boolean 的 java.lang 中的方法
static Boolean | Boolean.valueOf(boolean b) 返回一个表示指定 boolean 值的 Boolean 实例。
static Boolean | Boolean.valueOf(String s) 返回一个用指定的字符串表示值的 Boolean 值。

参数类型为 Boolean 的 java.lang 中的方法
 int Boolean.compareTo(Boolean b)
将此 Boolean 实例与其他实例进行比较。

java.util 中 Boolean 的使用

类型变量类型为 Boolean 的 java.util 中的方法参数
static
<E> Set<E>
Collections.newSetFromMap(Map<E,Boolean> map)
返回指定映射支持的 set。

javax.management 中 Boolean 的使用

参数类型为 Boolean 的 javax.management 中的方法
void | MBeanRegistration.postRegister(Boolean registrationDone) 允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。
void | StandardMBean.postRegister(Boolean registrationDone) 允许 MBean 在已注册到 MBean 服务器之后或注册已失败之后执行任何它所需要的操作。

javax.management.loading 中 Boolean 的使用

参数类型为 Boolean 的 javax.management.loading 中的方法
 void MLet.postRegister(Boolean registrationDone)
允许 m-let 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。

javax.management.modelmbean 中 Boolean 的使用

参数类型为 Boolean 的 javax.management.modelmbean 中的方法
 void RequiredModelMBean.postRegister(Boolean registrationDone)
允许 MBean 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。

javax.management.monitor 中 Boolean 的使用

参数类型为 Boolean 的 javax.management.monitor 中的方法
 void Monitor.postRegister(Boolean registrationDone)
允许在 MBean 服务器中注册监视器 MBean 后或注册失败后执行所需的任何操作。

javax.management.openmbean 中 Boolean 的使用

类型参数类型为 Boolean 的 javax.management.openmbean 中的字段
static SimpleType<Boolean> SimpleType.BOOLEAN
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Boolean 的值。

javax.management.relation 中 Boolean 的使用

返回 Boolean 的 javax.management.relation 中的方法
Boolean | RelationService.hasRelation(String relationId) 用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
Boolean | RelationServiceMBean.hasRelation(String relationId) 用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
Boolean | RelationSupport.isInRelationService() 返回指定该对象是否仍然由 Relation Service 处理的内部标志。
Boolean | RelationSupportMBean.isInRelationService() 返回指定该对象是否仍然由 Relation Service 处理的内部标志。

参数类型为 Boolean 的 javax.management.relation 中的方法
Integer | RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
Integer | RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
void | RelationService.postRegister(Boolean registrationDone)
void | RelationSupport.postRegister(Boolean registrationDone)
void | RelationSupport.setRelationServiceManagementFlag(Boolean flag)
void | RelationSupportMBean.setRelationServiceManagementFlag(Boolean flag) 指定此关系是否由 Relation Service 处理。

javax.management.remote 中 Boolean 的使用

参数类型为 Boolean 的 javax.management.remote 中的方法
 void JMXConnectorServer.postRegister(Boolean registrationDone)

javax.management.timer 中 Boolean 的使用

返回 Boolean 的 javax.management.timer 中的方法
Boolean | Timer.getFixedRate(Integer id) 获得此种标志的一个副本：该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
Boolean | TimerMBean.getFixedRate(Integer id) 获得此种标志的一个副本，该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。

参数类型为 Boolean 的 javax.management.timer 中的方法
 void Timer.postRegister(Boolean registrationDone)
允许计时器 MBean 在 MBean 服务器中注册后或注册失败后执行任何所需的操作。

javax.swing 中 Boolean 的使用

参数类型为 Boolean 的 javax.swing 中的方法
void | GroupLayout.setHonorsVisibility(Component component, Boolean honorsVisibility) 设置确定组件的大小和位置时是否要考虑组件的可见性。
protected void | DefaultDesktopManager.setWasIcon(JInternalFrame f, Boolean value) 设定组件已被图标化并且 desktopIcon 的边界是有效的。

javax.swing.filechooser 中 Boolean 的使用

返回 Boolean 的 javax.swing.filechooser 中的方法
Boolean | FileSystemView.isTraversable(File f) 如果可以访问文件（目录），则返回 true。
Boolean | FileView.isTraversable(File f) 目录是否是可遍历的。

javax.swing.plaf.basic 中 Boolean 的使用

类型参数类型为 Boolean 的 javax.swing.plaf.basic 中的字段
protected  Hashtable<TreePath,Boolean> BasicTreeUI.drawingCache
用于最小化垂直线的绘制。

返回 Boolean 的 javax.swing.plaf.basic 中的方法
 Boolean BasicFileChooserUI.BasicFileView.isHidden(File f)

javax.tools 中 Boolean 的使用

返回 Boolean 的 javax.tools 中的方法
 Boolean JavaCompiler.CompilationTask.call()
执行此编译任务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Byte 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Byte
的使用

使用 Byte 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang 中 Byte 的使用

类型参数类型为 Byte 的 java.lang 中的字段
static Class<Byte> Byte.TYPE
表示基本类型 byte 的 Class 实例。

返回 Byte 的 java.lang 中的方法
static Byte | Byte.decode(String nm) 将 String 解码为 Byte。
static Byte | Byte.valueOf(byte b) 返回表示指定 byte 值的一个 Byte 实例。
static Byte | Byte.valueOf(String s) 返回一个保持指定 String 所给出的值的 Byte 对象。
static Byte | Byte.valueOf(String s, int radix) 返回一个 Byte 对象，该对象保持从指定的 String 中提取的值，该值是在用第二个参数所给定的基数对指定字符串进行解析时提取的。

参数类型为 Byte 的 java.lang 中的方法
 int Byte.compareTo(Byte anotherByte)
在数字上比较两个 Byte 对象。

javax.management.openmbean 中 Byte 的使用

类型参数类型为 Byte 的 javax.management.openmbean 中的字段
static SimpleType<Byte> SimpleType.BYTE
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Byte 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Character 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Character
的使用

使用 Character 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Character 的使用

参数类型为 Character 的 java.awt 中的方法
static AWTKeyStroke AWTKeyStroke.getAWTKeyStroke(Character keyChar, int modifiers)
返回一个共享的 AWTKeyStroke 实例，它表示针对指定 Character 对象和一组组合键的 KEY_TYPED 事件。

java.lang 中 Character 的使用

类型参数类型为 Character 的 java.lang 中的字段
static Class<Character> Character.TYPE
表示基本类型 char 的 Class 实例。

返回 Character 的 java.lang 中的方法
static Character Character.valueOf(char c)
返回一个表示指定 char 值的 Character 实例。

参数类型为 Character 的 java.lang 中的方法
 int Character.compareTo(Character anotherCharacter)
根据数字比较两个 Character 对象。

javax.management.openmbean 中 Character 的使用

类型参数类型为 Character 的 javax.management.openmbean 中的字段
static SimpleType<Character> SimpleType.CHARACTER
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Character 的值。

javax.swing 中 Character 的使用

参数类型为 Character 的 javax.swing 中的方法
static KeyStroke KeyStroke.getKeyStroke(Character keyChar, int modifiers)
返回 KeyStroke 的一个共享实例，它表示指定 Character 对象和一组修饰符的 KEY_TYPED 事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Character.Subset 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Character.Subset
的使用

使用 Character.Subset 的软件包
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。

java.awt.im 中 Character.Subset 的使用

java.awt.im 中 Character.Subset 的子类
 class InputSubset
定义输入方法使用的其他 Unicode 子集。

参数类型为 Character.Subset 的 java.awt.im 中的方法
 void InputContext.setCharacterSubsets(Character.Subset[] subsets)
设置此输入上下文的输入方法应允许输入的 Unicode 字符集的子集。

java.awt.im.spi 中 Character.Subset 的使用

参数类型为 Character.Subset 的 java.awt.im.spi 中的方法
 void InputMethod.setCharacterSubsets(Character.Subset[] subsets)
设置允许此输入方法进行输入的 Unicode 字符集的子集。

java.lang 中 Character.Subset 的使用

java.lang 中 Character.Subset 的子类
static class Character.UnicodeBlock
表示 Unicode 规范中字符块的一系列字符子集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Character.UnicodeBlock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Character.UnicodeBlock
的使用

使用 Character.UnicodeBlock 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 Character.UnicodeBlock 的使用

声明为 Character.UnicodeBlock 的 java.lang 中的字段
static Character.UnicodeBlock | Character.UnicodeBlock.AEGEAN_NUMBERS “Aegean Numbers”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ALPHABETIC_PRESENTATION_FORMS “Alphabetic Presentation Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ARABIC “Arabic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ARABIC_PRESENTATION_FORMS_A “Arabic Presentation Forms-A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ARABIC_PRESENTATION_FORMS_B “Arabic Presentation Forms-B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ARMENIAN “Armenian”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ARROWS “Arrows”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BASIC_LATIN “Basic Latin”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BENGALI “Bengali”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BLOCK_ELEMENTS “Block Elements”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BOPOMOFO “Bopomofo”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BOPOMOFO_EXTENDED “Bopomofo Extended”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BOX_DRAWING “Box Drawing”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BRAILLE_PATTERNS “Braille Patterns”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BUHID “Buhid”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BYZANTINE_MUSICAL_SYMBOLS “Byzantine Musical Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CHEROKEE “Cherokee”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_COMPATIBILITY “CJK Compatibility”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_COMPATIBILITY_FORMS “CJK Compatibility Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_COMPATIBILITY_IDEOGRAPHS “CJK Compatibility Ideographs”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT “CJK Compatibility Ideographs Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_RADICALS_SUPPLEMENT “CJK Radicals Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_SYMBOLS_AND_PUNCTUATION “CJK Symbols and Punctuation”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS “CJK Unified Ideographs”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A “CJK Unified Ideographs Extension A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B “CJK Unified Ideographs Extension B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.COMBINING_DIACRITICAL_MARKS “Combining Diacritical Marks”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.COMBINING_HALF_MARKS “Combining Half Marks”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.COMBINING_MARKS_FOR_SYMBOLS “Combining Diacritical Marks for Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CONTROL_PICTURES “Control Pictures”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CURRENCY_SYMBOLS “Currency Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CYPRIOT_SYLLABARY “Cypriot Syllabary”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CYRILLIC “Cyrillic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CYRILLIC_SUPPLEMENTARY “Cyrillic Supplementary”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.DESERET “Deseret”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.DEVANAGARI “Devanagari”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.DINGBATS “Dingbats”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ENCLOSED_ALPHANUMERICS “Enclosed Alphanumerics”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ENCLOSED_CJK_LETTERS_AND_MONTHS “Enclosed CJK Letters and Months”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ETHIOPIC “Ethiopic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GENERAL_PUNCTUATION “General Punctuation”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GEOMETRIC_SHAPES “Geometric Shapes”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GEORGIAN “Georgian”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GOTHIC “Gothic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GREEK “Greek and Coptic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GREEK_EXTENDED “Greek Extended”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GUJARATI “Gujarati”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GURMUKHI “Gurmukhi”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HALFWIDTH_AND_FULLWIDTH_FORMS “Halfwidth and Fullwidth Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HANGUL_COMPATIBILITY_JAMO “Hangul Compatibility Jamo”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HANGUL_JAMO “Hangul Jamo”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HANGUL_SYLLABLES “Hangul Syllables”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HANUNOO “Hanunoo”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HEBREW “Hebrew”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES “High Private Use Surrogates”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HIGH_SURROGATES “High Surrogates”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HIRAGANA “Hiragana”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.IDEOGRAPHIC_DESCRIPTION_CHARACTERS “Ideographic Description Characters”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.IPA_EXTENSIONS “IPA Extensions”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KANBUN “Kanbun”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KANGXI_RADICALS “Kangxi Radicals”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KANNADA “Kannada”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KATAKANA “Katakana”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KATAKANA_PHONETIC_EXTENSIONS “Katakana Phonetic Extensions”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KHMER “Khmer”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KHMER_SYMBOLS “Khmer Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LAO “Lao”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LATIN_1_SUPPLEMENT “Latin-1 Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LATIN_EXTENDED_A “Latin Extended-A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LATIN_EXTENDED_ADDITIONAL “Latin Extended Additional”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LATIN_EXTENDED_B “Latin Extended-B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LETTERLIKE_SYMBOLS “Letterlike Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LIMBU “Limbu”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LINEAR_B_IDEOGRAMS “Linear B Ideograms”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LINEAR_B_SYLLABARY “Linear B Syllabary”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LOW_SURROGATES “Low Surrogates”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MALAYALAM “Malayalam”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MATHEMATICAL_ALPHANUMERIC_SYMBOLS “Mathematical Alphanumeric Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MATHEMATICAL_OPERATORS “Mathematical Operators”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A “Miscellaneous Mathematical Symbols-A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B “Miscellaneous Mathematical Symbols-B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MISCELLANEOUS_SYMBOLS “Miscellaneous Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MISCELLANEOUS_SYMBOLS_AND_ARROWS “Miscellaneous Symbols and Arrows”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MISCELLANEOUS_TECHNICAL “Miscellaneous Technical”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MONGOLIAN “Mongolian”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MUSICAL_SYMBOLS “Musical Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MYANMAR “Myanmar”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.NUMBER_FORMS “Number Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.OGHAM “Ogham”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.OLD_ITALIC “Old Italic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.OPTICAL_CHARACTER_RECOGNITION “Optical Character Recognition”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ORIYA “Oriya”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.OSMANYA “Osmanya”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.PHONETIC_EXTENSIONS “Phonetic Extensions”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.PRIVATE_USE_AREA “Private Use Area”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.RUNIC “Runic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SHAVIAN “Shavian”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SINHALA “Sinhala”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SMALL_FORM_VARIANTS “Small Form Variants”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SPACING_MODIFIER_LETTERS “Spacing Modifier Letters”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SPECIALS “Specials”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPERSCRIPTS_AND_SUBSCRIPTS “Superscripts and Subscripts”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPPLEMENTAL_ARROWS_A “Supplemental Arrows-A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPPLEMENTAL_ARROWS_B “Supplemental Arrows-B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPPLEMENTAL_MATHEMATICAL_OPERATORS “Supplemental Mathematical Operators”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPPLEMENTARY_PRIVATE_USE_AREA_A “Supplementary Private Use Area-A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPPLEMENTARY_PRIVATE_USE_AREA_B “Supplementary Private Use Area-B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SURROGATES_AREA 已过时。 从 J2SE 5 开始，使用 HIGH_SURROGATES、HIGH_PRIVATE_USE_SURROGATES 和 LOW_SURROGATES。这些新常量符合 Unicode 标准的块定义。of(char) 和 of(int) 方法返回新常量，而不是 SURROGATES_AREA。
static Character.UnicodeBlock | Character.UnicodeBlock.SYRIAC “Syriac”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAGALOG “Tagalog”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAGBANWA “Tagbanwa”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAGS “Tags”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAI_LE “Tai Le”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAI_XUAN_JING_SYMBOLS “Tai Xuan Jing Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAMIL “Tamil”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TELUGU “Telugu”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.THAANA “Thaana”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.THAI “Thai”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TIBETAN “Tibetan”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.UGARITIC “Ugaritic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS “Unified Canadian Aboriginal Syllabics”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.VARIATION_SELECTORS “Variation Selectors”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.VARIATION_SELECTORS_SUPPLEMENT “Variation Selectors Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.YI_RADICALS “Yi Radicals”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.YI_SYLLABLES “Yi Syllables”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.YIJING_HEXAGRAM_SYMBOLS “Yijing Hexagram Symbols”Unicode 字符块的常量。

返回 Character.UnicodeBlock 的 java.lang 中的方法
static Character.UnicodeBlock | Character.UnicodeBlock.forName(String blockName) 返回带有给定名称的 UnicodeBlock。
static Character.UnicodeBlock | Character.UnicodeBlock.of(char c) 返回表示包含给定字符的 Unicode 块的对象；如果该字符不是某个定义块的成员，则返回 null。
static Character.UnicodeBlock | Character.UnicodeBlock.of(int codePoint) 返回表示包含给定字符（Unicode 代码点）的 Unicode 块的对象；如果该字符不是定义块的成员，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.CharSequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.CharSequence
的使用

使用 CharSequence 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.io 中 CharSequence 的使用

参数类型为 CharSequence 的 java.io 中的方法
CharArrayWriter | CharArrayWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
StringWriter | StringWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
PrintWriter | PrintWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
Writer | Writer.append(CharSequence csq) 将指定字符序列添加到此 writer。
PrintStream | PrintStream.append(CharSequence csq) 将指定字符序列添加到此输出流。
CharArrayWriter | CharArrayWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
StringWriter | StringWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
PrintWriter | PrintWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
Writer | Writer.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer.Appendable。
PrintStream | PrintStream.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此输出流。

java.lang 中 CharSequence 的使用

实现 CharSequence 的 java.lang 中的类
class | String String 类代表字符串。
class | StringBuffer 线程安全的可变字符序列。
class | StringBuilder 一个可变的字符序列。

返回 CharSequence 的 java.lang 中的方法
CharSequence | StringBuffer.subSequence(int start, int end)
CharSequence | String.subSequence(int beginIndex, int endIndex) 返回一个新的字符序列，它是此序列的一个子序列。
CharSequence | CharSequence.subSequence(int start, int end) 返回一个新的 CharSequence，它是此序列的子序列。

参数类型为 CharSequence 的 java.lang 中的方法
StringBuilder | StringBuilder.append(CharSequence s)
StringBuffer | StringBuffer.append(CharSequence s) 将指定的 CharSequence 添加到该序列。
Appendable | Appendable.append(CharSequence csq) 向此 Appendable 添加指定的字符序列。
StringBuilder | StringBuilder.append(CharSequence s, int start, int end)
StringBuffer | StringBuffer.append(CharSequence s, int start, int end)
Appendable | Appendable.append(CharSequence csq, int start, int end) 向此 Appendable 添加指定字符序列的子序列。
static int | Character.codePointAt(CharSequence seq, int index) 返回 CharSequence 的给定索引上的代码点。
static int | Character.codePointBefore(CharSequence seq, int index) 返回 CharSequence 的给定索引前面的代码点。
static int | Character.codePointCount(CharSequence seq, int beginIndex, int endIndex) 返回指定字符序列的文本范围内的 Unicode 代码点数量。
boolean | String.contains(CharSequence s) 当且仅当此字符串包含指定的 char 值序列时，返回 true。
boolean | String.contentEquals(CharSequence cs) 将此字符串与指定的 CharSequence 比较。
StringBuilder | StringBuilder.insert(int dstOffset, CharSequence s)
StringBuffer | StringBuffer.insert(int dstOffset, CharSequence s)
StringBuilder | StringBuilder.insert(int dstOffset, CharSequence s, int start, int end)
StringBuffer | StringBuffer.insert(int dstOffset, CharSequence s, int start, int end)
static int | Character.offsetByCodePoints(CharSequence seq, int index, int codePointOffset) 返回给定字符序列中的索引，它是从给定 index 到 codePointOffset 代码点的偏移量。
String | String.replace(CharSequence target, CharSequence replacement) 使用指定的字面值替换序列替换此字符串所有匹配字面值目标序列的子字符串。

参数类型为 CharSequence 的 java.lang 中的构造方法
StringBuffer(CharSequence seq)
public java.lang.StringBuilder(CharSequence seq) 构造一个字符串缓冲区，它包含与指定的 CharSequence 相同的字符。
StringBuilder(CharSequence seq)
构造一个字符串生成器，包含与指定的 CharSequence 相同的字符。

java.nio 中 CharSequence 的使用

实现 CharSequence 的 java.nio 中的类
 class CharBuffer
字符缓冲区。

返回 CharSequence 的 java.nio 中的方法
abstract  CharSequence CharBuffer.subSequence(int start, int end)
创建表示此缓冲区的指定序列、相对于当前位置的新字符缓冲区。

参数类型为 CharSequence 的 java.nio 中的方法
CharBuffer | CharBuffer.append(CharSequence csq) 将指定的字符序列添加到此缓冲区（可选操作）。
CharBuffer | CharBuffer.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此缓冲区（可选操作）。
static CharBuffer | CharBuffer.wrap(CharSequence csq) 将字符序列包装到缓冲区中。
static CharBuffer | CharBuffer.wrap(CharSequence csq, int start, int end) 将字符序列包装到缓冲区中。

java.nio.charset 中 CharSequence 的使用

参数类型为 CharSequence 的 java.nio.charset 中的方法
 boolean CharsetEncoder.canEncode(CharSequence cs)
通过此编码器是否能够编码给定的字符序列。

java.text 中 CharSequence 的使用

参数类型为 CharSequence 的 java.text 中的方法
static boolean | Normalizer.isNormalized(CharSequence src, Normalizer.Form form) 确定给定的 char 值序列是否被标准化。
static String | Normalizer.normalize(CharSequence src, Normalizer.Form form) 标准化 char 值序列。

java.util.regex 中 CharSequence 的使用

参数类型为 CharSequence 的 java.util.regex 中的方法
Matcher | Pattern.matcher(CharSequence input) 创建匹配给定输入与此模式的匹配器。
static boolean | Pattern.matches(String regex, CharSequence input) 编译给定正则表达式并尝试将给定输入与其匹配。
Matcher | Matcher.reset(CharSequence input) 重置此具有新输入序列的匹配器。
String[] | Pattern.split(CharSequence input) 围绕此模式的匹配拆分给定输入序列。
String[] | Pattern.split(CharSequence input, int limit) 围绕此模式的匹配拆分给定输入序列。

javax.annotation.processing 中 CharSequence 的使用

参数类型为 CharSequence 的 javax.annotation.processing 中的方法
JavaFileObject | Filer.createClassFile(CharSequence name, Element... originatingElements) 创建一个新的类文件，并返回一个对象以允许写入它。
FileObject | Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
JavaFileObject | Filer.createSourceFile(CharSequence name, Element... originatingElements) 创建一个新的源文件，并返回一个对象以允许写入它。
FileObject | Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName) 返回一个用于读取现有资源的对象。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg) 打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e) 在元素的位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a) 在已注释元素的注释镜像位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v) 在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

javax.lang.model 中 CharSequence 的使用

参数类型为 CharSequence 的 javax.lang.model 中的方法
static boolean | SourceVersion.isIdentifier(CharSequence name) 返回 name 是否是语法上有效的标识符（简单名称）或最新源版本中的关键字。
static boolean | SourceVersion.isKeyword(CharSequence s) 返回 s 是否是最新源版本中的关键字或字面值。
static boolean | SourceVersion.isName(CharSequence name) 返回 name 是否是最新源版本中语法上有效的限定名称。

javax.lang.model.element 中 CharSequence 的使用

javax.lang.model.element 中 CharSequence 的子接口
 interface Name
字符的不可变序列。

参数类型为 CharSequence 的 javax.lang.model.element 中的方法
 boolean Name.contentEquals(CharSequence cs)
将此名称与指定的 CharSequence 进行比较。

javax.lang.model.util 中 CharSequence 的使用

参数类型为 CharSequence 的 javax.lang.model.util 中的方法
Name | Elements.getName(CharSequence cs) 返回与参数具有相同字符序列的名称。
PackageElement | Elements.getPackageElement(CharSequence name) 返回已给出其完全限定名称的包。
TypeElement | Elements.getTypeElement(CharSequence name) 返回已给出其规范名称的类型元素。

javax.swing.text 中 CharSequence 的使用

实现 CharSequence 的 javax.swing.text 中的类
 class Segment
表示文本片段的字符数组的 segment。

返回 CharSequence 的 javax.swing.text 中的方法
 CharSequence Segment.subSequence(int start, int end)
返回一个新的 CharSequence，它是此序列的子序列。

javax.tools 中 CharSequence 的使用

返回 CharSequence 的 javax.tools 中的方法
CharSequence | FileObject.getCharContent(boolean ignoreEncodingErrors) 返回此文件对象的字符内容（如果有）。
CharSequence | ForwardingFileObject.getCharContent(boolean ignoreEncodingErrors)
CharSequence | SimpleJavaFileObject.getCharContent(boolean ignoreEncodingErrors) 此实现总是抛出 UnsupportedOperationException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Class 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Class
的使用

使用 Class 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent.atomic | 类的小工具包，支持在单个变量上解除锁的线程安全编程。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
javax.activation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

java.awt 中 Class 的使用

参数类型为 Class 的 java.awt 中的方法
<T extends DragGestureRecognizer>
T
Toolkit.createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。
<T extends EventListener>
T[]
Button.getListeners(Class<T> listenerType)
返回当前在此 Button 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Checkbox.getListeners(Class<T> listenerType)
返回目前已在此 Checkbox 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
CheckboxMenuItem.getListeners(Class<T> listenerType)
返回当前在此 CheckboxMenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Choice.getListeners(Class<T> listenerType)
返回目前已在此 Choice 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
List.getListeners(Class<T> listenerType)
返回目前已在此 List 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Scrollbar.getListeners(Class<T> listenerType)
返回目前已在此 Scrollbar 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
TextComponent.getListeners(Class<T> listenerType)
返回当前已在此 TextComponent 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
TextField.getListeners(Class<T> listenerType)
返回当前已在此 TextField 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
MenuItem.getListeners(Class<T> listenerType)
返回当前在此 MenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Window.getListeners(Class<T> listenerType)
返回当前在此 Window 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
Container.getListeners(Class<T> listenerType)
返回当前已在此 Container 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Component.getListeners(Class<T> listenerType)
返回一个当前在此 Component 上作为 FooListener 注册的所有对象的数组。
static
<T extends EventListener>
T[]
AWTEventMulticaster.getListeners(EventListener l, Class<T> listenerType)
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。
protected static void AWTKeyStroke.registerSubclass(Class<?> subclass)
注册一个新类，AWTKeyStroke 中的工厂方法在生成 AWTKeyStroke 的新实例时将使用它。

java.awt.datatransfer 中 Class 的使用

返回 Class 的 java.awt.datatransfer 中的方法
Class<?> | DataFlavor.getDefaultRepresentationClass()
Class<?> | DataFlavor.getRepresentationClass() 返回请求此 DataFlavor 时，支持此 DataFlavor 的对象将返回的 Class。
protected static Class<?> | DataFlavor.tryToLoadClass(String className, ClassLoader fallback) 试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。

参数类型为 Class 的 java.awt.datatransfer 中的构造方法
DataFlavor(Class<?> representationClass, String humanPresentableName)
构造一个表示 Java 类的 DataFlavor。

java.awt.dnd 中 Class 的使用

参数类型为 Class 的 java.awt.dnd 中的方法
<T extends DragGestureRecognizer>
T
DragSource.createDragGestureRecognizer(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
<T extends EventListener>
T[]
DragSource.getListeners(Class<T> listenerType)
获得目前已在此 DragSource 上注册为 FooListener 的所有对象。

java.awt.image.renderable 中 Class 的使用

返回 Class 的 java.awt.image.renderable 中的方法
 Class[] ParameterBlock.getParamClasses()
返回描述该参数的 Class 对象的数组。

java.beans 中 Class 的使用

返回 Class 的 java.beans 中的方法
Class<?> | BeanDescriptor.getBeanClass() 获得 bean 的 Class 对象。
Class<?> | BeanDescriptor.getCustomizerClass() 获得 bean 的 customizer 的 Class 对象。
Class<?> | IndexedPropertyDescriptor.getIndexedPropertyType() 获得索引属性类型的 Class 对象。
Class<?> | EventSetDescriptor.getListenerType() 获得目标接口的 Class 对象。
Class<?> | PropertyDescriptor.getPropertyEditorClass() 获得已为此属性注册的任何显式 PropertyEditor Class。
Class<?> | PropertyDescriptor.getPropertyType() 获得属性的 Class 对象。

参数类型为 Class 的 java.beans 中的方法
static
<T> T
EventHandler.create(Class<T> listenerInterface, Object target, String action)
创建 listenerInterface 的实现，在该实现中，侦听器接口中的所有 方法都会将处理程序的 action 应用到 target。
static
<T> T
EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName)
创建 listenerInterface 的实现，在该实现中，所有 方法都会将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。
static
<T> T
EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)
创建 listenerInterface 的实现，在该实现中，名为 listenerMethodName 的方法将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。
static PropertyEditor PropertyEditorManager.findEditor(Class<?> targetType)
查找给定目标类型的值编辑器。
static void Introspector.flushFromCaches(Class<?> clz)
刷新给定类的 Introspector 的内部缓存信息。
static BeanInfo Introspector.getBeanInfo(Class<?> beanClass)
在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件。
static BeanInfo Introspector.getBeanInfo(Class<?> beanClass, Class<?> stopClass)
在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
static BeanInfo Introspector.getBeanInfo(Class<?> beanClass, Class<?> stopClass)
在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
static BeanInfo Introspector.getBeanInfo(Class<?> beanClass, int flags)
在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件，并将结果用一些控制标记表示。
static Object Beans.getInstanceOf(Object bean, Class<?> targetType)
从给定 bean 中获得表示源对象的指定类型视图的对象。
 PersistenceDelegate Encoder.getPersistenceDelegate(Class<?> type)
返回给定类型的持久委托。
protected  void DefaultPersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
initialize 方法的此默认实现假设保存在此类型对象中的所有状态都是通过匹配 "setter" 和 "getter" 方法对来公开的，公开的顺序是 Introspector 返回它们的顺序。
protected  void PersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
产生一系列对 newInstance 有副作用的语句，使得新实例等于 oldInstance。
static boolean Beans.isInstanceOf(Object bean, Class<?> targetType)
检查是否可以将 bean 视为给定目标类型。
static void PropertyEditorManager.registerEditor(Class<?> targetType, Class<?> editorClass)
注册一个将用来编辑给定目标类的值的编辑器类。
static void PropertyEditorManager.registerEditor(Class<?> targetType, Class<?> editorClass)
注册一个将用来编辑给定目标类的值的编辑器类。
 void Encoder.setPersistenceDelegate(Class<?> type, PersistenceDelegate persistenceDelegate)
将与此 type 相关联的持久委托设置为 persistenceDelegate。
 void PropertyDescriptor.setPropertyEditorClass(Class<?> propertyEditorClass)
通常 PropertyEditor 是使用 PropertyEditorManager 找到的。

参数类型为 Class 的 java.beans 中的构造方法
BeanDescriptor(Class<?> beanClass)
为没有 customizer 的 bean 创建一个 BeanDescriptor。
BeanDescriptor(Class<?> beanClass, Class<?> customizerClass)
为有 customizer 的 bean 创建一个 BeanDescriptor。
BeanDescriptor(Class<?> beanClass, Class<?> customizerClass)
为有 customizer 的 bean 创建一个 BeanDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
IndexedPropertyDescriptor(String propertyName, Class<?> beanClass)
此构造方法通过 getFoo 和 setFoo 存取方法为符合标准 Java 约定的属性构造 IndexedPropertyDescriptor，将其用于索引访问和数组访问。
IndexedPropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称，它们都是带索引的或不带索引的。
PropertyDescriptor(String propertyName, Class<?> beanClass)
通过调用 getFoo 和 setFoo 存取方法，为符合标准 Java 约定的属性构造一个 PropertyDescriptor。
PropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称。

java.beans.beancontext 中 Class 的使用

声明为 Class 的 java.beans.beancontext 中的字段
protected Class | BeanContextServiceAvailableEvent.serviceClass 新近可用服务的 Class 引用
protected Class | BeanContextServiceRevokedEvent.serviceClass 将被取消服务的 Class 引用。

返回 Class 的 java.beans.beancontext 中的方法
Class | BeanContextServiceAvailableEvent.getServiceClass() 获得作为此通知主题的服务类。
Class | BeanContextServiceRevokedEvent.getServiceClass() 获得作为此通知主题的服务类

参数类型为 Class 的 java.beans.beancontext 中的方法
 boolean BeanContextServices.addService(Class serviceClass, BeanContextServiceProvider serviceProvider)
向此 BeanContext 添加服务。
 boolean BeanContextServicesSupport.addService(Class serviceClass, BeanContextServiceProvider bcsp)
添加服务。
protected  boolean BeanContextServicesSupport.addService(Class serviceClass, BeanContextServiceProvider bcsp, boolean fireEvent)
添加服务。
protected static boolean BeanContextSupport.classEquals(Class first, Class second)
测试以查看两个类对象或其名称是否相等。
protected static boolean BeanContextSupport.classEquals(Class first, Class second)
测试以查看两个类对象或其名称是否相等。
protected  BeanContextServicesSupport.BCSSServiceProvider BeanContextServicesSupport.createBCSSServiceProvider(Class sc, BeanContextServiceProvider bcsp)
子类可以重写此方法来创建 BCSSServiceProvider 的新子类，而不必为了实例化而重写 addService()。
protected  void BeanContextServicesSupport.fireServiceAdded(Class serviceClass)
触发一个通知新服务的 BeanContextServiceEvent。
protected  void BeanContextServicesSupport.fireServiceRevoked(Class serviceClass, boolean revokeNow)
触发一个指示某一特定服务不再可用的 BeanContextServiceRevokedEvent。
 Iterator BeanContextServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass)
由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。
 Iterator BeanContextServicesSupport.BCSSProxyServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass)
 Iterator BeanContextServices.getCurrentServiceSelectors(Class serviceClass)
通过在基础 BeanContextServiceProvider 上调用 getCurrentServiceSelectors() 获得指定服务的与服务有关的服务参数列表（服务选择器）。
 Iterator BeanContextServicesSupport.getCurrentServiceSelectors(Class serviceClass)
 Object BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
 Object BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
获得一个可被委托的服务。
 Object BeanContextServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)
由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。
 Object BeanContextServicesSupport.BCSSProxyServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)
 boolean BeanContextServices.hasService(Class serviceClass)
报告是否可以从此上下文中得到给定服务。
 boolean BeanContextServicesSupport.hasService(Class serviceClass)
具有一个可被委托的服务。
 boolean BeanContextServiceRevokedEvent.isServiceClass(Class service)
检查此事件，以确定将被取消的服务是否属于某个特定类。
 void BeanContextServices.revokeService(Class serviceClass, BeanContextServiceProvider serviceProvider, boolean revokeCurrentServicesNow)
希望从此上下文中移除当前已注册服务的 BeanContextServiceProvider 可以通过调用此方法实现移除。
 void BeanContextServicesSupport.revokeService(Class serviceClass, BeanContextServiceProvider bcsp, boolean revokeCurrentServicesNow)
移除服务。

参数类型为 Class 的 java.beans.beancontext 中的构造方法
BeanContextServiceAvailableEvent(BeanContextServices bcs, Class sc)
构造一个 BeanContextAvailableServiceEvent。
BeanContextServiceRevokedEvent(BeanContextServices bcs, Class sc, boolean invalidate)
构造一个 BeanContextServiceEvent。

java.io 中 Class 的使用

返回 Class 的 java.io 中的方法
Class<?> | ObjectStreamClass.forClass() 返回此版本所映射的本地 VM 中的类。
Class<?> | ObjectStreamField.getType() 获取字段的类型。
protected Class<?> | ObjectInputStream.resolveClass(ObjectStreamClass desc) 加载指定流类描述的本地等价类。
protected Class<?> | ObjectInputStream.resolveProxyClass(String[] interfaces) 返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。

参数类型为 Class 的 java.io 中的方法
protected void | ObjectOutputStream.annotateClass(Class<?> cl) 子类可以实现此方法，从而允许在流中存储类数据。
protected void | ObjectOutputStream.annotateProxyClass(Class<?> cl) 子类可以实现此方法，从而在流中存储定制数据和动态代理类的描述符。
static ObjectStreamClass | ObjectStreamClass.lookup(Class<?> cl) 查找可序列化类的描述符。
static ObjectStreamClass | ObjectStreamClass.lookupAny(Class<?> cl) 返回任意类的描述符，不考虑它是否实现 Serializable。

参数类型为 Class 的 java.io 中的构造方法
ObjectStreamField(String name, Class<?> type)
创建具有指定类型的 Serializable 字段。
ObjectStreamField(String name, Class<?> type, boolean unshared)
创建一个 ObjectStreamField，表示给定名称和类型的可序列化字段。

java.lang 中 Class 的使用

声明为 Class 的 java.lang 中的字段
static Class<Void> | Void.TYPE 表示对应于关键字 void 的伪类型的 Class 对象。
static Class<Long> | Long.TYPE 表示基本类型 long 的 Class 实例。
static Class<Integer> | Integer.TYPE 表示基本类型 int 的 Class 实例。
static Class<Short> | Short.TYPE 表示基本类型 short 的 Class 实例。
static Class<Byte> | Byte.TYPE 表示基本类型 byte 的 Class 实例。
static Class<Double> | Double.TYPE 表示基本类型 double 的 Class 实例。
static Class<Float> | Float.TYPE 表示 float 基本类型的 Class 实例。
static Class<Character> | Character.TYPE 表示基本类型 char 的 Class 实例。
static Class<Boolean> | Boolean.TYPE 表示基本类型 boolean 的 Class 对象。

返回 Class 的 java.lang 中的方法
<U> Class<? extends U>
Class.asSubclass(Class<U> clazz)
强制转换该 Class 对象，以表示指定的 class 对象所表示的类的一个子类。
protected  Class<?> SecurityManager.currentLoadedClass()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  Class<?> ClassLoader.defineClass(byte[] b, int off, int len)
已过时。 由 defineClass(String, byte[], int, int) 取代
protected  Class<?> ClassLoader.defineClass(String name, byte[] b, int off, int len)
将一个 byte 数组转换为 Class 类的实例。
protected  Class<?> ClassLoader.defineClass(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。
protected  Class<?> ClassLoader.defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。
 Class<? extends Enum> EnumConstantNotPresentException.enumType()
返回缺少的枚举常量的类型。
protected  Class<?> ClassLoader.findClass(String name)
使用指定的二进制名称查找类。
protected  Class<?> ClassLoader.findLoadedClass(String name)
如果 Java 虚拟机已将此加载器记录为具有给定二进制名称的某个类的启动加载器，则返回该二进制名称的类。
protected  Class<?> ClassLoader.findSystemClass(String name)
查找具有指定的二进制名称的类，必要时加载它。
static Class<?> Class.forName(String className)
返回与带有给定字符串名的类或接口相关联的 Class 对象。
static Class<?> Class.forName(String name, boolean initialize, ClassLoader loader)
使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。
 Class<?> Object.getClass()
返回此 Object 的运行时类。
protected  Class[] SecurityManager.getClassContext()
以类数组的形式返回当前执行堆栈。
 Class<?>[] Class.getClasses()
返回一个包含某些 Class 对象的数组，这些对象表示属于此 Class 对象所表示的类的成员的所有公共类和接口。
 Class<?> Class.getComponentType()
返回表示数组组件类型的 Class。
 Class<?>[] Class.getDeclaredClasses()
返回 Class 对象的一个数组，这些对象反映声明为此 Class 对象所表示的类的成员的所有类和接口。
 Class<E> Enum.getDeclaringClass()
返回与此枚举常量的枚举类型相对应的 Class 对象。
 Class<?> Class.getDeclaringClass()
如果此 Class 对象所表示的类或接口是另一个类的成员，则返回的 Class 对象表示该对象的声明类。
 Class<?> Class.getEnclosingClass()
返回底层类的立即封闭类。
 Class<?>[] Class.getInterfaces()
确定此对象所表示的类或接口实现的接口。
 Class<? super T> Class.getSuperclass()
返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的超类的 Class。
 Class<?> ClassLoader.loadClass(String name)
使用指定的二进制名称来加载类。
protected  Class<?> ClassLoader.loadClass(String name, boolean resolve)
使用指定的二进制名称来加载类。

参数类型为 Class 的 java.lang 中的方法
<U> Class<? extends U>
Class.asSubclass(Class<U> clazz)
强制转换该 Class 对象，以表示指定的 class 对象所表示的类的一个子类。
 void SecurityManager.checkMemberAccess(Class<?> clazz, int which)
如果不允许调用线程访问程序，则抛出 SecurityException。
static boolean Compiler.compileClass(Class<?> clazz)
编译指定的类。
<A extends Annotation>
A
Package.getAnnotation(Class<A> annotationClass)
<A extends Annotation>
A
Class.getAnnotation(Class<A> annotationClass)
 Constructor<T> Class.getConstructor(Class<?>... parameterTypes)
返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
 Constructor<T> Class.getDeclaredConstructor(Class<?>... parameterTypes)
返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
 Method Class.getDeclaredMethod(String name, Class<?>... parameterTypes)
返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
 Method Class.getMethod(String name, Class<?>... parameterTypes)
返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。
 boolean Package.isAnnotationPresent(Class<? extends Annotation> annotationClass)
 boolean Class.isAnnotationPresent(Class<? extends Annotation> annotationClass)
 boolean Class.isAssignableFrom(Class<?> cls)
判定此 Class 对象所表示的类或接口与指定的 Class 参数所表示的类或接口是否相同，或是否是其超类或超接口。
protected  void ClassLoader.resolveClass(Class<?> c)
链接指定的类。
protected  void ClassLoader.setSigners(Class<?> c, Object[] signers)
设置类的签署者。
static
<T extends Enum<T>>
T
Enum.valueOf(Class<T> enumType, String name)
返回带指定名称的指定枚举类型的枚举常量。

参数类型为 Class 的 java.lang 中的构造方法
EnumConstantNotPresentException(Class<? extends Enum> enumType, String constantName)
为指定常量构造一个 EnumConstantNotPresentException。

java.lang.annotation 中 Class 的使用

返回 Class 的 java.lang.annotation 中的方法
Class<? extends Annotation> | IncompleteAnnotationException.annotationType() 返回带有缺少元素的注释类型的 Class 对象。
Class<? extends Annotation> | Annotation.annotationType() 返回此 annotation 的注释类型。

参数类型为 Class 的 java.lang.annotation 中的构造方法
IncompleteAnnotationException(Class<? extends Annotation> annotationType, String elementName)
构造一个指示指定注释类型中缺少指定元素的 IncompleteAnnotationException。

java.lang.instrument 中 Class 的使用

返回 Class 的 java.lang.instrument 中的方法
Class[] | Instrumentation.getAllLoadedClasses() 返回 JVM 当前加载的所有类的数组。
Class<?> | ClassDefinition.getDefinitionClass() 返回该类。
Class[] | Instrumentation.getInitiatedClasses(ClassLoader loader) 返回所有初始化加载器是 loader 的类的数组。

参数类型为 Class 的 java.lang.instrument 中的方法
boolean | Instrumentation.isModifiableClass(Class<?> theClass) 确定一个类是否可以被 retransformation 或 redefinition 修改。
void | Instrumentation.retransformClasses(Class<?>... classes) 重转换提供的类集。
byte[] | ClassFileTransformer.transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer) 此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

参数类型为 Class 的 java.lang.instrument 中的构造方法
ClassDefinition(Class<?> theClass, byte[] theClassFile)
使用提供的类和类文件字节创建一个新的 ClassDefinition 绑定。

java.lang.management 中 Class 的使用

参数类型为 Class 的 java.lang.management 中的方法
static
<T> T
ManagementFactory.newPlatformMXBeanProxy(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。

java.lang.reflect 中 Class 的使用

返回 Class 的 java.lang.reflect 中的方法
Class<T> | Constructor.getDeclaringClass() 返回 Class 对象，该对象表示声明由此 Constructor 对象表示的构造方法的类。
Class<?> | Method.getDeclaringClass() 返回表示声明由此 Method 对象表示的方法的类或接口的 Class 对象。
Class<?> | Field.getDeclaringClass() 返回表示类或接口的 Class 对象，该类或接口声明由此 Field 对象表示的字段。
Class<?> | Member.getDeclaringClass() 返回表示声明由此 Member 表示的成员或构造方法的类或接口的 Class 对象。
Class<?>[] | Constructor.getExceptionTypes() 返回一组表示声明要抛出的异常类型的 Class 对象，这些异常是由此 Constructor 对象表示的底层构造方法抛出的。
Class<?>[] | Method.getExceptionTypes() 返回 Class 对象的数组，这些对象描述了声明将此 Method 对象表示的底层方法抛出的异常类型。
Class<?>[] | Constructor.getParameterTypes() 按照声明顺序返回一组 Class 对象，这些对象表示此 Constructor 对象所表示构造方法的形参类型。
Class<?>[] | Method.getParameterTypes() 按照声明顺序返回 Class 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型。
static Class<?> | Proxy.getProxyClass(ClassLoader loader, Class<?>... interfaces) 返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
Class<?> | Method.getReturnType() 返回一个 Class 对象，该对象描述了此 Method 对象所表示的方法的正式返回类型。
Class<?> | Field.getType() 返回一个 Class 对象，它标识了此 Field 对象所表示字段的声明类型。

参数类型为 Class 的 java.lang.reflect 中的方法
<T extends Annotation>
T
Constructor.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
Method.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
Field.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
AccessibleObject.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
AnnotatedElement.getAnnotation(Class<T> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
static Class<?> Proxy.getProxyClass(ClassLoader loader, Class<?>... interfaces)
返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
 boolean AccessibleObject.isAnnotationPresent(Class<? extends Annotation> annotationClass)
 boolean AnnotatedElement.isAnnotationPresent(Class<? extends Annotation> annotationClass)
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。
static boolean Proxy.isProxyClass(Class<?> cl)
当且仅当指定的类通过 getProxyClass 方法或 newProxyInstance 方法动态生成为代理类时，返回 true。
static Object Array.newInstance(Class<?> componentType, int... dimensions)
创建一个具有指定的组件类型和维度的新数组。
static Object Array.newInstance(Class<?> componentType, int length)
创建一个具有指定的组件类型和长度的新数组。
static Object Proxy.newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)
返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。

java.net 中 Class 的使用

返回 Class 的 java.net 中的方法
protected  Class<?> URLClassLoader.findClass(String name)
通过 URL 搜索路径查找并加载具有指定名称的类。

参数类型为 Class 的 java.net 中的方法
Object | URLConnection.getContent(Class[] classes) 获取此 URL 连接的内容。
Object | URL.getContent(Class[] classes) 获取此 URL 的内容。
Object | ContentHandler.getContent(URLConnection urlc, Class[] classes) 如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。

java.rmi.server 中 Class 的使用

返回 Class 的 java.rmi.server 中的方法
 Class<?> LoaderHandler.loadClass(String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(String name)
已过时。 由 loadClass(String,String) 方法取代
static Class<?> RMIClassLoader.loadClass(String codebase, String name)
从基本代码 URL 路径加载类。
static Class<?> RMIClassLoader.loadClass(String codebase, String name, ClassLoader defaultLoader)
有选择地使用提供的加载器从基本代码 URL 路径加载类。
abstract  Class<?> RMIClassLoaderSpi.loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
 Class<?> LoaderHandler.loadClass(URL codebase, String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(URL codebase, String name)
从基本代码 URL 加载类。
static Class<?> RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
abstract  Class<?> RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

参数类型为 Class 的 java.rmi.server 中的方法
static String RMIClassLoader.getClassAnnotation(Class<?> cl)
返回表示类定义位置的注释字符串，RMI 将在编组给定类的对象时用其注释类描述符。
abstract  String RMIClassLoaderSpi.getClassAnnotation(Class<?> cl)
提供 RMIClassLoader.getClassAnnotation(Class) 的实现。

java.security 中 Class 的使用

返回 Class 的 java.security 中的方法
protected Class<?> | SecureClassLoader.defineClass(String name, byte[] b, int off, int len, CodeSource cs) 使用可选的 CodeSource 将 byte 数组转换为 Class 类的实例。
protected Class<?> | SecureClassLoader.defineClass(String name, ByteBuffer b, CodeSource cs) 使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。

参数类型为 Class 的 java.security 中的方法
 boolean KeyStoreSpi.engineEntryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass)
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
protected abstract
<T extends KeySpec>
T
KeyFactorySpi.engineGetKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
protected abstract
<T extends AlgorithmParameterSpec>
T
AlgorithmParametersSpi.engineGetParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。
 boolean KeyStore.entryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass)
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
<T extends KeySpec>
T
KeyFactory.getKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
<T extends AlgorithmParameterSpec>
T
AlgorithmParameters.getParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。

java.sql 中 Class 的使用

返回变量类型为 Class 的类型的 java.sql 中的方法
 Map<String,Class<?>> Connection.getTypeMap()
获取与此 Connection 对象关联的 Map 对象。

参数类型为 Class 的 java.sql 中的方法
<T extends Source>
T
SQLXML.getSource(Class<T> sourceClass)
返回读取此 SQLXML 实例指定的 XML 值的 Source。
 boolean Wrapper.isWrapperFor(Class<?> iface)
如果调用此方法的对象实现接口参数，或者是实现接口参数的对象的直接或间接包装器，则返回 true。
<T extends Result>
T
SQLXML.setResult(Class<T> resultClass)
返回设置此 SQLXML 实例指定的 XML 值的 Result。
<T> T
Wrapper.unwrap(Class<T> iface)
返回一个对象，该对象实现给定接口，以允许访问非标准方法或代理未公开的标准方法。

类型变量类型为 Class 的 java.sql 中的方法参数
Object | Array.getArray(long index, int count, Map<String,Class<?>> map) 获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
Object | Array.getArray(Map<String,Class<?>> map) 获取由此 Array 对象指定的 SQL ARRAY 值的内容。
Object[] | Struct.getAttributes(Map<String,Class<?>> map) 生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。
Object | CallableStatement.getObject(int parameterIndex, Map<String,Class<?>> map) 返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。
Object | ResultSet.getObject(int columnIndex, Map<String,Class<?>> map) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
Object | Ref.getObject(Map<String,Class<?>> map) 获取引用对象并使用给定类型映射表将其映射到 Java 类型。
Object | CallableStatement.getObject(String parameterName, Map<String,Class<?>> map) 返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。
Object | ResultSet.getObject(String columnLabel, Map<String,Class<?>> map) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
ResultSet | Array.getResultSet(long index, int count, Map<String,Class<?>> map) 获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
ResultSet | Array.getResultSet(Map<String,Class<?>> map) 获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
void | Connection.setTypeMap(Map<String,Class<?>> map) 将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。

java.util 中 Class 的使用

返回 Class 的 java.util 中的方法
 Class<?> IllegalFormatConversionException.getArgumentClass()
返回不匹配参数的类。

参数类型为 Class 的 java.util 中的方法
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.allOf(Class<E> elementType)
创建一个包含指定元素类型的所有元素的枚举 set。
static
<E> Collection<E>
Collections.checkedCollection(Collection<E> c, Class<E> type)
返回指定 collection 的一个动态类型安全视图。
static
<E> List<E>
Collections.checkedList(List<E> list, Class<E> type)
返回指定列表的一个动态类型安全视图。
static
<K,V> Map<K,V>
Collections.checkedMap(Map<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定映射的一个动态类型安全视图。
static
<K,V> Map<K,V>
Collections.checkedMap(Map<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定映射的一个动态类型安全视图。
static
<E> Set<E>
Collections.checkedSet(Set<E> s, Class<E> type)
返回指定 set 的一个动态类型安全视图。
static
<K,V> SortedMap<K,V>
Collections.checkedSortedMap(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定有序映射的一个动态类型安全视图。
static
<K,V> SortedMap<K,V>
Collections.checkedSortedMap(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定有序映射的一个动态类型安全视图。
static
<E> SortedSet<E>
Collections.checkedSortedSet(SortedSet<E> s, Class<E> type)
返回指定有序 set 的一个动态类型安全视图。
static
<T,U> T[]
Arrays.copyOf(U[] original, int newLength, Class<? extends T[]> newType)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。
static
<T,U> T[]
Arrays.copyOfRange(U[] original, int from, int to, Class<? extends T[]> newType)
将指定数组的指定范围复制到一个新数组。
static
<S> ServiceLoader<S>
ServiceLoader.load(Class<S> service)
针对给定服务类型创建新的服务加载器，使用当前线程的上下文类加载器。
static
<S> ServiceLoader<S>
ServiceLoader.load(Class<S> service, ClassLoader loader)
针对给定服务类型和类加载器创建新的服务加载器。
static
<S> ServiceLoader<S>
ServiceLoader.loadInstalled(Class<S> service)
针对给定服务类型创建新的服务加载器，使用扩展类加载器。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.noneOf(Class<E> elementType)
创建一个具有指定元素类型的空枚举 set。

参数类型为 Class 的 java.util 中的构造方法
EnumMap(Class<K> keyType)
创建一个具有指定键类型的空枚举映射。
IllegalFormatConversionException(char c, Class<?> arg)
使用不匹配转换和相应参数类构造此类的实例。

java.util.concurrent.atomic 中 Class 的使用

参数类型为 Class 的 java.util.concurrent.atomic 中的方法
static
<U,W> AtomicReferenceFieldUpdater<U,W>
AtomicReferenceFieldUpdater.newUpdater(Class<U> tclass, Class<W> vclass, String fieldName)
使用给定的字段为对象创建和返回一个更新器。
static
<U,W> AtomicReferenceFieldUpdater<U,W>
AtomicReferenceFieldUpdater.newUpdater(Class<U> tclass, Class<W> vclass, String fieldName)
使用给定的字段为对象创建和返回一个更新器。
static
<U> AtomicIntegerFieldUpdater<U>
AtomicIntegerFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
使用给定字段为对象创建和返回一个更新器。
static
<U> AtomicLongFieldUpdater<U>
AtomicLongFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
为对象创建并返回一个具有给定字段的更新器。

java.util.prefs 中 Class 的使用

参数类型为 Class 的 java.util.prefs 中的方法
static Preferences | Preferences.systemNodeForPackage(Class<?> c) 从系统首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
static Preferences | Preferences.userNodeForPackage(Class<?> c) 从调用用户首选项树（根据约定，它与指定类的包相关联）返回首选项节点。

javax.activation 中 Class 的使用

返回 Class 的 javax.activation 中的方法
 Class ActivationDataFlavor.getRepresentationClass()
返回表示形式类。

参数类型为 Class 的 javax.activation 中的构造方法
ActivationDataFlavor(Class representationClass, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。
ActivationDataFlavor(Class representationClass, String mimeType, String humanPresentableName)
构造一个表示任意 Java 对象的 DataFlavor。

javax.annotation.processing 中 Class 的使用

参数类型为 Class 的 javax.annotation.processing 中的方法
 Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith(Class<? extends Annotation> a)
返回使用给定注释类型注释的元素。

javax.crypto 中 Class 的使用

参数类型为 Class 的 javax.crypto 中的方法
protected abstract KeySpec | SecretKeyFactorySpi.engineGetKeySpec(SecretKey key, Class keySpec) 以所需格式返回给定密钥对象的规范（密钥材料）。
KeySpec | SecretKeyFactory.getKeySpec(SecretKey key, Class keySpec) 以请求的格式返回给定密钥对象的规范（密钥材料）。

javax.imageio.metadata 中 Class 的使用

返回 Class 的 javax.imageio.metadata 中的方法
Class<?> | IIOMetadataFormat.getObjectClass(String elementName) 返回存储在元素中的 Class 类型的 Object 引用。
Class<?> | IIOMetadataFormatImpl.getObjectClass(String elementName)

参数类型为 Class 的 javax.imageio.metadata 中的方法
protected  void IIOMetadataFormatImpl.addObjectValue(String elementName, Class<?> classType, int arrayMinLength, int arrayMaxLength)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T> void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T> void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T extends Object & Comparable<? super T>>
void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

javax.imageio.spi 中 Class 的使用

声明为 Class 的 javax.imageio.spi 中的字段
protected Class<?> | ImageInputStreamSpi.inputClass 指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
protected Class[] | ImageReaderSpi.inputTypes 将从 getInputTypes 返回的 Class 对象数组，该数组最初为 null。
protected Class<?> | ImageOutputStreamSpi.outputClass 指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
protected Class[] | ImageWriterSpi.outputTypes 将从 getOutputTypes 返回的 Class 对象的数组，该数组最初为 null。
static Class[] | ImageReaderSpi.STANDARD_INPUT_TYPE 将从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。
static Class[] | ImageWriterSpi.STANDARD_OUTPUT_TYPE 从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。

返回 Class 的 javax.imageio.spi 中的方法
Class<?> | ImageInputStreamSpi.getInputClass() 返回表示必须由输入源实现（以便使用 createInputStreamInstance 方法在 ImageInputStream 中“包装”）的类或接口的类型的 Class 对象。
Class[] | ImageReaderSpi.getInputTypes() 返回 Class 对象数组，指示可用作 reader 的 setInput 方法参数的对象类型。
Class<?> | ImageOutputStreamSpi.getOutputClass() 返回表示必须由输出目标位置实现（以便使用 createOutputStreamInstance 方法在 ImageOutputStream 中“包装”）的类或接口的类型的 Class 对象。
Class[] | ImageWriterSpi.getOutputTypes() 返回 Class 对象数组，指示可用作 setOutput 方法参数的对象类型。

返回变量类型为 Class 的类型的 javax.imageio.spi 中的方法
 Iterator<Class<?>> ServiceRegistry.getCategories()
返回指示当前类别集的 Class 对象的 Iterator。

参数类型为 Class 的 javax.imageio.spi 中的方法
 void ServiceRegistry.deregisterAll(Class<?> category)
注销给定类别下当前注册的所有服务提供者对象。
<T> boolean
ServiceRegistry.deregisterServiceProvider(T provider, Class<T> category)
从给定的类别中移除服务提供者对象。
<T> T
ServiceRegistry.getServiceProviderByClass(Class<T> providerClass)
返回当前注册的属于给定类类型的服务提供者对象。
<T> Iterator<T>
ServiceRegistry.getServiceProviders(Class<T> category, boolean useOrdering)
返回一个包含给定类别中的所有已注册的服务提供者的 Iterator。
<T> Iterator<T>
ServiceRegistry.getServiceProviders(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
返回一个 Iterator，其包含给定类别中满足由指定的 ServiceRegistry.Filter 对象的 filter 方法定义的条件的服务提供者对象。
static
<T> Iterator<T>
ServiceRegistry.lookupProviders(Class<T> providerClass)
使用上下文类加载器定位和递增地实例化给定服务的可用的提供者。
static
<T> Iterator<T>
ServiceRegistry.lookupProviders(Class<T> providerClass, ClassLoader loader)
使用给定的类加载器搜索特定服务类的实现。
 void IIOServiceProvider.onDeregistration(ServiceRegistry registry, Class<?> category)
Spi 类一从 ServiceRegistry 中注销即执行的回调。
 void RegisterableService.onDeregistration(ServiceRegistry registry, Class<?> category)
将一个实现此接口的对象从给定的 registry 的给定 category 移除时调用此方法。
 void IIOServiceProvider.onRegistration(ServiceRegistry registry, Class<?> category)
在 ServiceRegistry 中实例化和注册 Spi 类后即执行的回调。
 void RegisterableService.onRegistration(ServiceRegistry registry, Class<?> category)
将一个实现此接口的对象添加到给定 registry 的给定 category 时调用此方法。
<T> boolean
ServiceRegistry.registerServiceProvider(T provider, Class<T> category)
将一个服务提供者对象添加到注册表。
<T> boolean
ServiceRegistry.setOrdering(Class<T> category, T firstProvider, T secondProvider)
为给定类别中的两个服务提供者对象设置配对排序。
<T> boolean
ServiceRegistry.unsetOrdering(Class<T> category, T firstProvider, T secondProvider)
为给定类别中的两个服务提供者对象设置配对排序。

参数类型为 Class 的 javax.imageio.spi 中的构造方法
ImageInputStreamSpi(String vendorName, String version, Class<?> inputClass)
用给定的一组值构造 ImageInputStreamSpi。
ImageOutputStreamSpi(String vendorName, String version, Class<?> outputClass)
用给定的一组值构造 ImageOutputStreamSpi。
ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。
ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

类型变量类型为 Class 的 javax.imageio.spi 中的构造方法参数
ServiceRegistry(Iterator<Class<?>> categories)
使用取自 categories 参数的一组类别构造 ServiceRegistry 实例。

javax.lang.model.element 中 Class 的使用

参数类型为 Class 的 javax.lang.model.element 中的方法
<A extends Annotation>
A
Element.getAnnotation(Class<A> annotationType)
返回此元素针对指定类型的注释（如果存在这样的注释），否则返回 null。

javax.management 中 Class 的使用

返回 Class 的 javax.management 中的方法
Class<?> | StandardMBean.getImplementationClass() 获取此 Standard MBean（或 MXBean）的实现类。
Class<?> | StandardMBean.getMBeanInterface() 获取此 Standard MBean（或 MXBean）的管理接口。
static Class | DefaultLoaderRepository.loadClass(String className) 已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
static Class | DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。

参数类型为 Class 的 javax.management 中的方法
static boolean JMX.isMXBeanInterface(Class<?> interfaceClass)
测试某接口是否是 MXBean 接口。
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
MBeanServerInvocationHandler.newProxyInstance(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
返回一个代理，该代理通过将其方法从给定 MBean 服务器转发到指定 MBean 来实现给定的接口。

参数类型为 Class 的 javax.management 中的构造方法
StandardEmitterMBean(Class<?> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(Class<?> mbeanInterface, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(T implementation, Class<T> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(T implementation, Class<T> mbeanInterface, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardMBean(Class<?> mbeanInterface)
使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
StandardMBean(Class<?> mbeanInterface, boolean isMXBean)
使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
StandardMBean(T implementation, Class<T> mbeanInterface)
使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。
StandardMBean(T implementation, Class<T> mbeanInterface, boolean isMXBean)
使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。

javax.management.loading 中 Class 的使用

返回 Class 的 javax.management.loading 中的方法
protected Class<?> | MLet.findClass(String name) 这是要重新定义的类加载器的主要方法。
Class<?> | ClassLoaderRepository.loadClass(String className) 通过类加载器列表加载给定的类名称。
static Class | DefaultLoaderRepository.loadClass(String className) 已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
Class<?> | MLet.loadClass(String name, ClassLoaderRepository clr) 如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。
Class<?> | ClassLoaderRepository.loadClassBefore(ClassLoader stop, String className) 通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。
Class<?> | ClassLoaderRepository.loadClassWithout(ClassLoader exclude, String className) 通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。
static Class | DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。

javax.management.openmbean 中 Class 的使用

参数类型为 Class 的 javax.management.openmbean 中的方法
static
<T> ArrayType<T>
ArrayType.getPrimitiveArrayType(Class<T> arrayClass)
以类型安全的方式创建一个 ArrayType 实例。

javax.naming.spi 中 Class 的使用

参数类型为 Class 的 javax.naming.spi 中的方法
ResolveResult | Resolver.resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
ResolveResult | Resolver.resolveToClass(String name, Class<? extends Context> contextType) 部分解析某一名称。

javax.print 中 Class 的使用

返回 Class 的 javax.print 中的方法
Class<?>[] | PrintService.getSupportedAttributeCategories() 确定客户端在设置此 PrintService 的作业时，可以指定的打印属性类别。
Class[] | AttributeException.getUnsupportedAttributes() 返回其 PrintService 实例根本不支持该属性的打印属性类数组，如果没有这种属性，则返回 null。

参数类型为 Class 的 javax.print 中的方法
<T extends PrintServiceAttribute>
T
PrintService.getAttribute(Class<T> category)
获取单个指定服务属性的值。
 Object PrintService.getDefaultAttributeValue(Class<? extends Attribute> category)
确定给定类别中此 PrintService 的默认打印属性值。
 Object PrintService.getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
 boolean PrintService.isAttributeCategorySupported(Class<? extends Attribute> category)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定打印属性类别。

javax.print.attribute 中 Class 的使用

返回 Class 的 javax.print.attribute 中的方法
Class<? extends Attribute> | Attribute.getCategory() 将此打印属性值添加到属性集时，为它获取用作“类别”的打印属性类。
static Class<?> | AttributeSetUtilities.verifyAttributeCategory(Object object, Class<?> interfaceName) 验证给定的对象是否为实现给定接口（假定为接口 Attribute 或其子接口）的 Class。

参数类型为 Class 的 javax.print.attribute 中的方法
boolean | AttributeSet.containsKey(Class<?> category) 如果此属性集包含指定类别的一个属性，则返回 true。
boolean | HashAttributeSet.containsKey(Class<?> category) 如果此属性集包含指定类别的属性，则返回 true。
Attribute | AttributeSet.get(Class<?> category) 返回此属性集在给定的属性类别中包含的属性值。
Attribute | HashAttributeSet.get(Class<?> category) 返回此属性集在给定的属性类别中包含的属性值。
boolean | AttributeSet.remove(Class<?> category) 从此属性集移除此类别的任何属性（如果存在）。
boolean | HashAttributeSet.remove(Class<?> category) 从此属性集移除此类别的任何属性（如果存在）。
static Class<?> | AttributeSetUtilities.verifyAttributeCategory(Object object, Class<?> interfaceName) 验证给定的对象是否为实现给定接口（假定为接口 Attribute 或其子接口）的 Class。
static Attribute | AttributeSetUtilities.verifyAttributeValue(Object object, Class<?> interfaceName) 验证给定的对象是否为给定接口（假定为接口 Attribute 或其子接口）的一个实例。
static void | AttributeSetUtilities.verifyCategoryForValue(Class<?> category, Attribute attribute) 验证给定的属性类别对象是否等于给定属性值对象的类别。

参数类型为 Class 的 javax.print.attribute 中的构造方法
HashAttributeSet(Attribute[] attributes, Class<?> interfaceName)
构造一个新的属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(Attribute attribute, Class<?> interfaceName)
构造一个最初使用给定属性填充的新属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(AttributeSet attributes, Class<?> interfaceName)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(Class<?> interfaceName)
构造一个新的空属性集，其中该属性集的成员限于给定的接口。

javax.print.attribute.standard 中 Class 的使用

返回 Class 的 javax.print.attribute.standard 中的方法
Class<? extends Attribute> | Chromaticity.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | ColorSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Compression.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Copies.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | CopiesSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtCompleted.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtCreation.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtProcessing.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Destination.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DocumentName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Fidelity.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Finishings.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobHoldUntil.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressions.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressionsCompleted.getCategory() 获取被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressionsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctetsProcessed.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctetsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheetsCompleted.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheetsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMessageFromOperator.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobOriginatingUserName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobPriority.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobPrioritySupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobSheets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobState.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobStateReason.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobStateReasons.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Media.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MediaPrintableArea.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MediaSize.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MultipleDocumentHandling.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberOfDocuments.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberOfInterveningJobs.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberUp.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberUpSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | OrientationRequested.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | OutputDeviceAssigned.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PDLOverrideSupported.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PageRanges.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PagesPerMinute.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PagesPerMinuteColor.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PresentationDirection.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrintQuality.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterInfo.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterIsAcceptingJobs.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterLocation.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMakeAndModel.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMessageFromOperator.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMoreInfo.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMoreInfoManufacturer.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterName.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterResolution.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterState.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterStateReason.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterStateReasons.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterURI.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | QueuedJobCount.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | ReferenceUriSchemesSupported.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | RequestingUserName.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Severity.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | SheetCollate.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Sides.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。

javax.rmi 中 Class 的使用

参数类型为 Class 的 javax.rmi 中的方法
static Object PortableRemoteObject.narrow(Object narrowFrom, Class narrowTo)
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。

javax.rmi.CORBA 中 Class 的使用

返回 Class 的 javax.rmi.CORBA 中的方法
static Class Util.loadClass(String className, String remoteCodebase, ClassLoader loader)
为指定的类返回一个类实例。
 Class UtilDelegate.loadClass(String className, String remoteCodebase, ClassLoader loader)
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。

参数类型为 Class 的 javax.rmi.CORBA 中的方法
static String Util.getCodebase(Class clz)
返回给定类的代码基（如果存在）。
 String UtilDelegate.getCodebase(Class clz)
Util.getCodebase(java.lang.Class) 的委托调用。
 String ValueHandler.getRMIRepositoryID(Class clz)
返回给定 Java 类的 CORBA RepositoryId。
 boolean ValueHandler.isCustomMarshaled(Class clz)
指示给定的类是执行自定义编组还是默认编组。
 Object PortableRemoteObjectDelegate.narrow(Object narrowFrom, Class narrowTo)
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。
 Serializable ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
使用 Java 语义从流中读取一个值。

javax.script 中 Class 的使用

参数类型为 Class 的 javax.script 中的方法
<T> T
Invocable.getInterface(Class<T> clasz)
返回一个接口的实现，该接口使用解释器中编译的函数。
<T> T
Invocable.getInterface(Object thiz, Class<T> clasz)
返回一个接口的实现，该接口使用解释器中已编译脚本对象的成员函数。

javax.security.auth 中 Class 的使用

参数类型为 Class 的 javax.security.auth 中的方法
<T extends Principal>
Set<T>
Subject.getPrincipals(Class<T> c)
返回与此 Subject 关联的 Principal Set，它是指定的 Class 的实例或子类。
<T> Set<T>
Subject.getPrivateCredentials(Class<T> c)
返回与此 Subject关联的私有证书 Set，它是指定的 Class 的实例或子类。
<T> Set<T>
Subject.getPublicCredentials(Class<T> c)
返回与此 Subject 关联的公开证书 Set，它是指定的 Class 的实例或子类。

javax.sound.midi 中 Class 的使用

返回 Class 的 javax.sound.midi 中的方法
 Class<?> SoundbankResource.getDataClass()
获得此采样所使用的表示其数据的类。

参数类型为 Class 的 javax.sound.midi 中的构造方法
Instrument(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)
从指定的 Patch 构造一个新的 MIDI 乐器。
SoundbankResource(Soundbank soundBank, String name, Class<?> dataClass)
根据给定的音库和波表索引构造一个新的 SoundbankResource。

javax.sound.sampled 中 Class 的使用

返回 Class 的 javax.sound.sampled 中的方法
 Class<?> Line.Info.getLineClass()
获得此 Line.Info 对象所描述的行的类。

参数类型为 Class 的 javax.sound.sampled 中的构造方法
DataLine.Info(Class<?> lineClass, AudioFormat format)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式。
DataLine.Info(Class<?> lineClass, AudioFormat[] formats, int minBufferSize, int maxBufferSize)
根据指定信息构造数据行的信息对象，这些包括受支持音频格式的集合和缓冲区大小的范围。
DataLine.Info(Class<?> lineClass, AudioFormat format, int bufferSize)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式和所需的缓冲区大小。
Line.Info(Class<?> lineClass)
构造描述指定类的行的 info 对象。
Port.Info(Class<?> lineClass, String name, boolean isSource)
根据给定的信息构造端口的 info 对象。

javax.sql 中 Class 的使用

返回变量类型为 Class 的类型的 javax.sql 中的方法
 Map<String,Class<?>> RowSet.getTypeMap()
获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。

类型变量类型为 Class 的 javax.sql 中的方法参数
 void RowSet.setTypeMap(Map<String,Class<?>> map)
将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。

javax.sql.rowset 中 Class 的使用

返回变量类型为 Class 的类型的 javax.sql.rowset 中的方法
 Map<String,Class<?>> BaseRowSet.getTypeMap()
获取与此 RowSet 对象的 Connection 对象关联的类型映射表。

参数类型为 Class 的 javax.sql.rowset 中的方法
 boolean RowSetMetaDataImpl.isWrapperFor(Class<?> interfaces)
如果调用者实现接口参数或者是实现接口参数的对象的直接或间接包装器，则返回 true。
<T> T
RowSetMetaDataImpl.unwrap(Class<T> iface)
返回实现给定接口以允许访问非标准方法，或者代理未公开标准方法的的对象。

类型变量类型为 Class 的 javax.sql.rowset 中的方法参数
 void BaseRowSet.setTypeMap(Map<String,Class<?>> map)
将给定的 java.util.Map 对象安装为与此 RowSet 对象的 Connection 对象关联的类型映射表。

javax.sql.rowset.serial 中 Class 的使用

类型变量类型为 Class 的 javax.sql.rowset.serial 中的方法参数
Object | SerialArray.getArray(long index, int count, Map<String,Class<?>> map) 返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
Object | SerialArray.getArray(Map<String,Class<?>> map) 返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。
Object[] | SerialStruct.getAttributes(Map<String,Class<?>> map) 获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。
Object | SerialRef.getObject(Map<String,Class<?>> map) 返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
ResultSet | SerialArray.getResultSet(long index, int count, Map<String,Class<?>> map) 获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(Map<String,Class<?>> map) 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。

类型变量类型为 Class 的 javax.sql.rowset.serial 中的构造方法参数
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。
SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。
SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。

javax.swing 中 Class 的使用

返回 Class 的 javax.swing 中的方法
Class<?> | JTable.getColumnClass(int column) 返回出现在视图中 column 列位置处的列类型。
Class<? extends ComponentUI> | UIDefaults.getUIClass(String uiClassID) 返回呈现此组件的 L&F 类。
Class<? extends ComponentUI> | UIDefaults.getUIClass(String uiClassID, ClassLoader uiClassLoader) get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。

参数类型为 Class 的 javax.swing 中的方法
static Container SwingUtilities.getAncestorOfClass(Class<?> c, Component comp)
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的类 c 的第一个对象。
 TableCellEditor JTable.getDefaultEditor(Class<?> columnClass)
尚未在 TableColumn 中设置编辑器时，返回要使用的编辑器。
 TableCellRenderer JTable.getDefaultRenderer(Class<?> columnClass)
尚未在 TableColumn 中设置渲染器时，返回要使用的单元格渲染器。
<T extends EventListener>
T[]
AbstractSpinnerModel.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
DefaultListSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractListModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultBoundedRangeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultSingleSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultButtonModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Timer.getListeners(Class<T> listenerType)
返回目前已在此 Timer 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
JComponent.getListeners(Class<T> listenerType)
返回当前在此 JComponent 上注册为 FooListener 的所有对象所组成的数组。
static Object LookAndFeel.makeIcon(Class<?> baseClass, String gifFile)
创建并返回一个加载图像的 UIDefault.LazyValue。
 void JTable.setDefaultEditor(Class<?> columnClass, TableCellEditor editor)
如果尚未在 TableColumn 中设置编辑器，则设置要使用的默认单元格编辑器。
 void JTable.setDefaultRenderer(Class<?> columnClass, TableCellRenderer renderer)
如果没有在 TableColumn 中设置渲染器，则设置要使用的默认单元格渲染器。

javax.swing.event 中 Class 的使用

参数类型为 Class 的 javax.swing.event 中的方法
<T extends EventListener>
void
EventListenerList.add(Class<T> t, T l)
将侦听器作为指定类型的侦听器进行添加。
 int EventListenerList.getListenerCount(Class<?> t)
返回此侦听器列表中所提供类型的侦听器的总数。
<T extends EventListener>
T[]
EventListenerList.getListeners(Class<T> t)
返回给定类型的所有侦听器组成的数组。
<T extends EventListener>
void
EventListenerList.remove(Class<T> t, T l)
将侦听器作为指定类型的侦听器进行移除。

javax.swing.plaf.synth 中 Class 的使用

参数类型为 Class 的 javax.swing.plaf.synth 中的方法
 void SynthLookAndFeel.load(InputStream input, Class<?> resourceBase)
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。

javax.swing.table 中 Class 的使用

返回 Class 的 javax.swing.table 中的方法
Class<?> | AbstractTableModel.getColumnClass(int columnIndex) 返回 Object.class 而不管 columnIndex 是多少。
Class<?> | TableModel.getColumnClass(int columnIndex) 针对列中所有的单元格值，返回最具体的超类。

参数类型为 Class 的 javax.swing.table 中的方法
<T extends EventListener>
T[]
DefaultTableColumnModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractTableModel.getListeners(Class<T> listenerType)
返回一个包含当前注册为此 AbstractTableModel 上的 FooListener 的所有对象的数组。

javax.swing.text 中 Class 的使用

返回 Class 的 javax.swing.text 中的方法
 Class<?> DefaultFormatter.getValueClass()
返回用于创建新 Objects 的类。

参数类型为 Class 的 javax.swing.text 中的方法
<T extends EventListener>
T[]
DefaultCaret.getListeners(Class<T> listenerType)
返回目前已在此插入符上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
StyleContext.NamedStyle.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
AbstractDocument.getListeners(Class<T> listenerType)
返回目前已在此文档上注册为 FooListener 的所有对象组成的数组。
 void DefaultFormatter.setValueClass(Class<?> valueClass)
设置用于创建新 Objects 的类。

javax.swing.tree 中 Class 的使用

参数类型为 Class 的 javax.swing.tree 中的方法
<T extends EventListener>
T[]
DefaultTreeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultTreeSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。

javax.xml.bind 中 Class 的使用

声明为 Class 的 javax.xml.bind 中的字段
protected Class<T> | JAXBElement.declaredType xml 元素声明类型的 Java 数据类型绑定。
protected Class | JAXBElement.scope 表示此 xml 元素实例的 xml 元素声明的作用域。

返回 Class 的 javax.xml.bind 中的方法
Class<T> | JAXBElement.getDeclaredType() 返回 xml 元素声明的类型属性的 Java 绑定。
Class | JAXBElement.getScope() 返回 xml 元素声明的作用域。

参数类型为 Class 的 javax.xml.bind 中的方法
<T> Binder<T>
JAXBContext.createBinder(Class<T> domType)
创建一个可用于关联/原地解组/编组操作的 Binder 对象。
<A extends XmlAdapter>
A
Marshaller.getAdapter(Class<A> type)
获取与指定类型关联的适配器。
<A extends XmlAdapter>
A
Unmarshaller.getAdapter(Class<A> type)
获取与指定类型关联的适配器。
static JAXBContext JAXBContext.newInstance(Class... classesToBeBound)
获得 JAXBContext 类的新实例。
static JAXBContext JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties)
获得 JAXBContext 类的新实例。
<A extends XmlAdapter>
void
Marshaller.setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 marshaller 关联。
<A extends XmlAdapter>
void
Unmarshaller.setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Node node, Class<T> declaredType)
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Source source, Class<T> declaredType)
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
abstract
<T> JAXBElement<T>
Binder.unmarshal(XmlNode xmlNode, Class<T> declaredType)
根据提供的 declaredType 将 XML 根元素解组为 JAXB 对象树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

参数类型为 Class 的 javax.xml.bind 中的构造方法
JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
构造一个 xml 元素实例。
JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
构造一个 xml 元素实例。
JAXBElement(QName name, Class<T> declaredType, T value)
构造一个 xml 元素实例。

javax.xml.bind.helpers 中 Class 的使用

参数类型为 Class 的 javax.xml.bind.helpers 中的方法
<A extends XmlAdapter>
A
AbstractMarshallerImpl.getAdapter(Class<A> type)
<A extends XmlAdapter>
A
AbstractUnmarshallerImpl.getAdapter(Class<A> type)
<A extends XmlAdapter>
void
AbstractMarshallerImpl.setAdapter(Class<A> type, A adapter)
<A extends XmlAdapter>
void
AbstractUnmarshallerImpl.setAdapter(Class<A> type, A adapter)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

javax.xml.ws 中 Class 的使用

参数类型为 Class 的 javax.xml.ws 中的方法
<T> Dispatch<T>
Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
<T> T
Service.getPort(Class<T> serviceEndpointInterface)
getPort 返回 stub。
<T> T
Service.getPort(QName portName, Class<T> serviceEndpointInterface)
getPort 方法返回 stub。

javax.xml.ws.spi 中 Class 的使用

参数类型为 Class 的 javax.xml.ws.spi 中的方法
abstract
<T> Dispatch<T>
ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
abstract  ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class serviceClass)
创建一个服务委托对象。
abstract
<T> T
ServiceDelegate.getPort(Class<T> serviceEndpointInterface)
getPort 方法返回一个桩模块。
abstract
<T> T
ServiceDelegate.getPort(QName portName, Class<T> serviceEndpointInterface)
getPort 方法返回一个桩模块 (stub)。

org.omg.CORBA 中 Class 的使用

参数类型为 Class 的 org.omg.CORBA 中的方法
 ServantObject LocalObject._servant_preinvoke(String operation, Class expectedType)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

org.omg.CORBA_2_3.portable 中 Class 的使用

参数类型为 Class 的 org.omg.CORBA_2_3.portable 中的方法
Object | InputStream.read_abstract_interface(Class clz) 解组与传递类型相对应的类对象或 stub 类。
Serializable | InputStream.read_value(Class clz) 从输入流解组值类型。
void | OutputStream.write_value(Serializable value, Class clz) 将值类型编组到输出流中。

org.omg.CORBA.portable 中 Class 的使用

参数类型为 Class 的 org.omg.CORBA.portable 中的方法
ServantObject | ObjectImpl._servant_preinvoke(String operation, Class expectedType) 返回对本地 servant 的 Java 引用，该引用应该被用来发送对指定方法的请求。
Object | InputStream.read_Object(Class clz) 取消对象的编组并返回一个 CORBA Object，该对象是作为参数传递的类的实例。
ServantObject | Delegate.servant_preinvoke(Object self, String operation, Class expectedType) 返回对应该用作此请求的 servant 的 Java 引用。

org.omg.DynamicAny 中 Class 的使用

声明为 Class 的 org.omg.DynamicAny 中的字段
static Class | _DynAnyFactoryStub._opsClass
static Class | _DynAnyStub._opsClass
static Class | _DynArrayStub._opsClass
static Class | _DynEnumStub._opsClass
static Class | _DynFixedStub._opsClass
static Class | _DynSequenceStub._opsClass
static Class | _DynStructStub._opsClass
static Class | _DynUnionStub._opsClass
static Class | _DynValueStub._opsClass

org.omg.PortableServer 中 Class 的使用

声明为 Class 的 org.omg.PortableServer 中的字段
static Class | _ServantActivatorStub._opsClass
static Class | _ServantLocatorStub._opsClass

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ClassCastException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ClassCastException
的使用

使用 ClassCastException 的软件包
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.w3c.dom.bootstrap |
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.rmi 中 ClassCastException 的使用

抛出 ClassCastException 的 javax.rmi 中的方法
static Object PortableRemoteObject.narrow(Object narrowFrom, Class narrowTo)
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。

javax.rmi.CORBA 中 ClassCastException 的使用

抛出 ClassCastException 的 javax.rmi.CORBA 中的方法
 Object PortableRemoteObjectDelegate.narrow(Object narrowFrom, Class narrowTo)
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。

org.w3c.dom.bootstrap 中 ClassCastException 的使用

抛出 ClassCastException 的 org.w3c.dom.bootstrap 中的方法
static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
获得 DOMImplementationRegistry 的新实例。

org.xml.sax.helpers 中 ClassCastException 的使用

抛出 ClassCastException 的 org.xml.sax.helpers 中的方法
static Parser | ParserFactory.makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | ParserFactory.makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ClassCircularityError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ClassCircularityError
的使用

没有 java.lang.ClassCircularityError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ClassFormatError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ClassFormatError
的使用

使用 ClassFormatError 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 ClassFormatError 的使用

java.lang 中 ClassFormatError 的子类
 class UnsupportedClassVersionError
当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。

抛出 ClassFormatError 的 java.lang 中的方法
protected  Class<?> ClassLoader.defineClass(byte[] b, int off, int len)
已过时。 由 defineClass(String, byte[], int, int) 取代
protected  Class<?> ClassLoader.defineClass(String name, byte[] b, int off, int len)
将一个 byte 数组转换为 Class 类的实例。
protected  Class<?> ClassLoader.defineClass(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。
protected  Class<?> ClassLoader.defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。

java.lang.reflect 中 ClassFormatError 的使用

java.lang.reflect 中 ClassFormatError 的子类
 class GenericSignatureFormatError
当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ClassLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ClassLoader
的使用

使用 ClassLoader 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.activation |
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

java.awt.datatransfer 中 ClassLoader 的使用

参数类型为 ClassLoader 的 java.awt.datatransfer 中的方法
protected static Class<?> DataFlavor.tryToLoadClass(String className, ClassLoader fallback)
试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。

参数类型为 ClassLoader 的 java.awt.datatransfer 中的构造方法
DataFlavor(String mimeType, String humanPresentableName, ClassLoader classLoader)
构造一个表示 MimeType 的 DataFlavor。

java.beans 中 ClassLoader 的使用

参数类型为 ClassLoader 的 java.beans 中的方法
static Object | Beans.instantiate(ClassLoader cls, String beanName) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer) 实例化 bean。

参数类型为 ClassLoader 的 java.beans 中的构造方法
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

java.lang 中 ClassLoader 的使用

返回 ClassLoader 的 java.lang 中的方法
protected ClassLoader | SecurityManager.currentClassLoader() 已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
ClassLoader | Class.getClassLoader() 返回该类的类加载器。
ClassLoader | Thread.getContextClassLoader() 返回该线程的上下文 ClassLoader。
ClassLoader | ClassLoader.getParent() 返回委托的父类加载器。
static ClassLoader | ClassLoader.getSystemClassLoader() 返回委托的系统类加载器。

参数类型为 ClassLoader 的 java.lang 中的方法
static Class<?> | Class.forName(String name, boolean initialize, ClassLoader loader) 使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。
void | Thread.setContextClassLoader(ClassLoader cl) 设置该线程的上下文 ClassLoader。

参数类型为 ClassLoader 的 java.lang 中的构造方法
ClassLoader(ClassLoader parent)
使用指定的、用于委托操作的父类加载器创建新的类加载器。

java.lang.instrument 中 ClassLoader 的使用

参数类型为 ClassLoader 的 java.lang.instrument 中的方法
Class[] | Instrumentation.getInitiatedClasses(ClassLoader loader) 返回所有初始化加载器是 loader 的类的数组。
byte[] | ClassFileTransformer.transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer) 此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

java.lang.reflect 中 ClassLoader 的使用

参数类型为 ClassLoader 的 java.lang.reflect 中的方法
static Class<?> | Proxy.getProxyClass(ClassLoader loader, Class<?>... interfaces) 返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
static Object | Proxy.newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h) 返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。

java.net 中 ClassLoader 的使用

java.net 中 ClassLoader 的子类
 class URLClassLoader
该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。

参数类型为 ClassLoader 的 java.net 中的方法
static URLClassLoader URLClassLoader.newInstance(URL[] urls, ClassLoader parent)
为指定的 URL 和父类加载器创建新 URLClassLoader 实例。

参数类型为 ClassLoader 的 java.net 中的构造方法
URLClassLoader(URL[] urls, ClassLoader parent)
为给定的 URL 构造新 URLClassLoader。
URLClassLoader(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 创建新 URLClassLoader。

java.rmi.server 中 ClassLoader 的使用

返回 ClassLoader 的 java.rmi.server 中的方法
static ClassLoader RMIClassLoader.getClassLoader(String codebase)
返回从给定的基本代码 URL 路径加载类的类加载器。
abstract  ClassLoader RMIClassLoaderSpi.getClassLoader(String codebase)
提供 RMIClassLoader.getClassLoader(String) 的实现。

参数类型为 ClassLoader 的 java.rmi.server 中的方法
 Object LoaderHandler.getSecurityContext(ClassLoader loader)
已过时。 无替代版本
static Object RMIClassLoader.getSecurityContext(ClassLoader loader)
已过时。 无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。
static Class<?> RMIClassLoader.loadClass(String codebase, String name, ClassLoader defaultLoader)
有选择地使用提供的加载器从基本代码 URL 路径加载类。
abstract  Class<?> RMIClassLoaderSpi.loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
static Class<?> RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
abstract  Class<?> RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

java.security 中 ClassLoader 的使用

java.security 中 ClassLoader 的子类
 class SecureClassLoader
此类扩展了 ClassLoader，使它另外还支持使用相关的代码源和权限定义类，这些代码源和权限默认情况下可根据系统策略获取到。

返回 ClassLoader 的 java.security 中的方法
 ClassLoader ProtectionDomain.getClassLoader()
返回此域的 ClassLoader。

参数类型为 ClassLoader 的 java.security 中的构造方法
ProtectionDomain(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。
SecureClassLoader(ClassLoader parent)
使用指定的父类加载器为委托创建新 SecureClassLoader。

java.util 中 ClassLoader 的使用

参数类型为 ClassLoader 的 java.util 中的方法
static void ResourceBundle.clearCache(ClassLoader loader)
从已经使用给定类加载器加载的缓存中移除所有资源包。
static ResourceBundle ResourceBundle.getBundle(String baseName, Locale locale, ClassLoader loader)
使用指定的基本名称、语言环境和类加载器获取资源包。
static ResourceBundle ResourceBundle.getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control)
使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
static
<S> ServiceLoader<S>
ServiceLoader.load(Class<S> service, ClassLoader loader)
针对给定服务类型和类加载器创建新的服务加载器。
 boolean ResourceBundle.Control.needsReload(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime)
确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。
 ResourceBundle ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。

javax.activation 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.activation 中的方法
 Object CommandInfo.getCommandObject(DataHandler dh, ClassLoader loader)
返回已实例化的 JavaBean 组件。

javax.imageio.spi 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.imageio.spi 中的方法
static
<T> Iterator<T>
ServiceRegistry.lookupProviders(Class<T> providerClass, ClassLoader loader)
使用给定的类加载器搜索特定服务类的实现。

javax.management 中 ClassLoader 的使用

返回 ClassLoader 的 javax.management 中的方法
ClassLoader | MBeanServer.getClassLoader(ObjectName loaderName) 返回指定的 ClassLoader。
ClassLoader | MBeanServer.getClassLoaderFor(ObjectName mbeanName) 返回用于加载指定 MBean 的类的 ClassLoader。

参数类型为 ClassLoader 的 javax.management 中的方法
static Class DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className)
已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。

javax.management.loading 中 ClassLoader 的使用

javax.management.loading 中 ClassLoader 的子类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

参数类型为 ClassLoader 的 javax.management.loading 中的方法
Class<?> | ClassLoaderRepository.loadClassBefore(ClassLoader stop, String className) 通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。
Class<?> | ClassLoaderRepository.loadClassWithout(ClassLoader exclude, String className) 通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。
static Class | DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。

参数类型为 ClassLoader 的 javax.management.loading 中的构造方法
MLet(URL[] urls, ClassLoader parent)
为给定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
为给定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
PrivateMLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
为给定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新 PrivateMLet。

javax.management.remote.rmi 中 ClassLoader 的使用

返回 ClassLoader 的 javax.management.remote.rmi 中的方法
 ClassLoader RMIServerImpl.getDefaultClassLoader()
获得此连接器服务器使用的默认 ClassLoader。

参数类型为 ClassLoader 的 javax.management.remote.rmi 中的方法
 void RMIServerImpl.setDefaultClassLoader(ClassLoader cl)
设置此连接器服务器的默认 ClassLoader。

参数类型为 ClassLoader 的 javax.management.remote.rmi 中的构造方法
RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。

javax.rmi.CORBA 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.rmi.CORBA 中的方法
static Class Util.loadClass(String className, String remoteCodebase, ClassLoader loader)
为指定的类返回一个类实例。
 Class UtilDelegate.loadClass(String className, String remoteCodebase, ClassLoader loader)
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。

javax.script 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.script 中的构造方法
ScriptEngineManager(ClassLoader loader)
此构造方法使用服务调用者机制加载对于给定 ClassLoader 可见的 ScriptEngineFactory 实现。

javax.swing 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.swing 中的方法
Class<? extends ComponentUI> | UIDefaults.getUIClass(String uiClassID, ClassLoader uiClassLoader) get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。
static void | JEditorPane.registerEditorKitForContentType(String type, String classname, ClassLoader loader) 建立 type 到 classname 的默认绑定。

javax.tools 中 ClassLoader 的使用

返回 ClassLoader 的 javax.tools 中的方法
ClassLoader | ForwardingJavaFileManager.getClassLoader(JavaFileManager.Location location)
ClassLoader | JavaFileManager.getClassLoader(JavaFileManager.Location location) 获取可从给定位置加载插件的类加载器。
static ClassLoader | ToolProvider.getSystemToolClassLoader() 返回此平台提供的工具的类加载器。

javax.xml.bind 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.bind 中的方法
static JAXBContext | JAXBContext.newInstance(String contextPath, ClassLoader classLoader) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties) 获得 JAXBContext 类的新实例。

javax.xml.datatype 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.datatype 中的方法
static DatatypeFactory DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader)
从类名称中获取新的 DatatypeFactory 实例。

javax.xml.parsers 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.parsers 中的方法
static SAXParserFactory | SAXParserFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 SAXParserFactory 实例。
static DocumentBuilderFactory | DocumentBuilderFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 DocumentBuilderFactory 实例。

javax.xml.stream 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.stream 中的方法
static XMLEventFactory | XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
static XMLInputFactory | XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
static XMLInputFactory | XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个的新工厂实例。

javax.xml.transform 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.transform 中的方法
static TransformerFactory TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader)
根据类名称获得一个新 TransformerFactory 实例。

javax.xml.validation 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.validation 中的方法
static SchemaFactory SchemaFactory.newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)
根据类名称获得一个新 SchemaFactory 实例。

javax.xml.xpath 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.xpath 中的方法
static XPathFactory XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader)
根据工厂类名称获取一个新 XPathFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ClassNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ClassNotFoundException
的使用

使用 ClassNotFoundException 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.net | 为实现网络应用程序提供类。
java.rmi | 提供 RMI 包。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
javax.activation |
javax.crypto | 为加密操作提供类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.relation | 提供 Relation Service 的定义。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
org.w3c.dom.bootstrap |
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.awt.datatransfer 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.awt.datatransfer 中的方法
static DataFlavor | SystemFlavorMap.decodeDataFlavor(String nat) 解码 String native 以用作 DataFlavor。
void | DataFlavor.readExternal(ObjectInput is) 根据 Serialized 状态还原此 DataFlavor。
protected static Class<?> | DataFlavor.tryToLoadClass(String className, ClassLoader fallback) 试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。

抛出 ClassNotFoundException 的 java.awt.datatransfer 中的构造方法
DataFlavor(String mimeType)
根据 mimeType 字符串构造 DataFlavor。
DataFlavor(String mimeType, String humanPresentableName, ClassLoader classLoader)
构造一个表示 MimeType 的 DataFlavor。

java.beans 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.beans 中的方法
static Object | Beans.instantiate(ClassLoader cls, String beanName) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer) 实例化 bean。

java.beans.beancontext 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.beans.beancontext 中的方法
protected  void BeanContextServicesSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在反序列化子级之前，从 BeanContextSupport readObject 中调用。
protected  void BeanContextSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在调用 defaultReadObject() 之后，但在反序列化任意子级之前，由 readObject 调用。
protected  void BeanContextSupport.deserialize(ObjectInputStream ois, Collection coll)
readObject 使用此方法来反序列化一个 collection。
 Object BeanContext.instantiateChild(String beanName)
实例化指定为此 BeanContext 的一个子级的 javaBean。
 Object BeanContextSupport.instantiateChild(String beanName)
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。
 void BeanContextSupport.readChildren(ObjectInputStream ois)
在将此类的实例用作 BeanContext 协议（及其子协议）实现的代理时，在反序列化期间存在一个“先有鸡还是先有蛋”的问题。

java.io 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.io 中的方法
void | ObjectInputStream.defaultReadObject() 从此流读取当前类的非静态和非瞬态字段。
protected ObjectStreamClass | ObjectInputStream.readClassDescriptor() 从序列化流读取类描述符。
void | Externalizable.readExternal(ObjectInput in) 对象实现 readExternal 方法来恢复其内容，它通过调用 DataInput 的方法来恢复其基础类型，调用 readObject 来恢复对象、字符串和数组。
ObjectInputStream.GetField | ObjectInputStream.readFields() 按名称从流中读取持久字段并使其可用。
Object | ObjectInputStream.readObject() 从 ObjectInputStream 读取对象。
Object | ObjectInput.readObject() 读取并返回对象。
protected Object | ObjectInputStream.readObjectOverride() 此方法由 ObjectOutputStream 的受信任子类调用，这些子类使用受保护的无参数构造方法构造 ObjectOutputStream。
Object | ObjectInputStream.readUnshared() 从 ObjectInputStream 读取“非共享”对象。
protected Class<?> | ObjectInputStream.resolveClass(ObjectStreamClass desc) 加载指定流类描述的本地等价类。
protected Class<?> | ObjectInputStream.resolveProxyClass(String[] interfaces) 返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。

java.lang 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.lang 中的方法
protected Class<?> | ClassLoader.findClass(String name) 使用指定的二进制名称查找类。
protected Class<?> | ClassLoader.findSystemClass(String name) 查找具有指定的二进制名称的类，必要时加载它。
static Class<?> | Class.forName(String className) 返回与带有给定字符串名的类或接口相关联的 Class 对象。
static Class<?> | Class.forName(String name, boolean initialize, ClassLoader loader) 使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。
Class<?> | ClassLoader.loadClass(String name) 使用指定的二进制名称来加载类。
protected Class<?> | ClassLoader.loadClass(String name, boolean resolve) 使用指定的二进制名称来加载类。

java.lang.instrument 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.lang.instrument 中的方法
 void Instrumentation.redefineClasses(ClassDefinition... definitions)
使用提供的类文件重定义提供的类集。

java.net 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.net 中的方法
protected  Class<?> URLClassLoader.findClass(String name)
通过 URL 搜索路径查找并加载具有指定名称的类。

java.rmi 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.rmi 中的方法
 T MarshalledObject.get()
返回所包含的 marshalledobject 的新副本。

java.rmi.server 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.rmi.server 中的方法
 Class<?> LoaderHandler.loadClass(String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(String name)
已过时。 由 loadClass(String,String) 方法取代
static Class<?> RMIClassLoader.loadClass(String codebase, String name)
从基本代码 URL 路径加载类。
static Class<?> RMIClassLoader.loadClass(String codebase, String name, ClassLoader defaultLoader)
有选择地使用提供的加载器从基本代码 URL 路径加载类。
abstract  Class<?> RMIClassLoaderSpi.loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
 Class<?> LoaderHandler.loadClass(URL codebase, String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(URL codebase, String name)
从基本代码 URL 加载类。
static Class<?> RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
abstract  Class<?> RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

java.security 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.security 中的方法
 Object SignedObject.getObject()
获取已封装的对象。

javax.activation 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.activation 中的方法
Object | CommandInfo.getCommandObject(DataHandler dh, ClassLoader loader) 返回已实例化的 JavaBean 组件。
void | MimeType.readExternal(ObjectInput in) 对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。

javax.crypto 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.crypto 中的方法
Object | SealedObject.getObject(Cipher c) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。

javax.management 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.management 中的方法
static Class | DefaultLoaderRepository.loadClass(String className) 已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
static Class | DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。

javax.management.loading 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.management.loading 中的方法
protected Class<?> | MLet.findClass(String name) 这是要重新定义的类加载器的主要方法。
Class<?> | ClassLoaderRepository.loadClass(String className) 通过类加载器列表加载给定的类名称。
static Class | DefaultLoaderRepository.loadClass(String className) 已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
Class<?> | MLet.loadClass(String name, ClassLoaderRepository clr) 如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。
Class<?> | ClassLoaderRepository.loadClassBefore(ClassLoader stop, String className) 通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。
Class<?> | ClassLoaderRepository.loadClassWithout(ClassLoader exclude, String className) 通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。
static Class | DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。
void | MLet.readExternal(ObjectInput in) 从给定的 ObjectInput 恢复此 MLet 的内容。

javax.management.relation 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.management.relation 中的构造方法
RoleInfo(String roleName, String mbeanClassName)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。

javax.rmi.CORBA 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.rmi.CORBA 中的方法
static Class Util.loadClass(String className, String remoteCodebase, ClassLoader loader)
为指定的类返回一个类实例。
 Class UtilDelegate.loadClass(String className, String remoteCodebase, ClassLoader loader)
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。
 void StubDelegate.readObject(Stub self, ObjectInputStream s)
Stub.readObject(java.io.ObjectInputStream) 的委托调用。

javax.swing 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.swing 中的方法
static void UIManager.setLookAndFeel(String className)
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

javax.swing.text 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.swing.text 中的方法
void | StyleContext.readAttributes(ObjectInputStream in, MutableAttributeSet a) 读入属性的特定于上下文的处理。
static void | StyleContext.readAttributeSet(ObjectInputStream in, MutableAttributeSet a) 从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。

org.w3c.dom.bootstrap 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 org.w3c.dom.bootstrap 中的方法
static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
获得 DOMImplementationRegistry 的新实例。

org.xml.sax.helpers 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 org.xml.sax.helpers 中的方法
static Parser | ParserFactory.makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | ParserFactory.makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.Cloneable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Cloneable
的使用

使用 Cloneable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.awt.print | 为通用的打印 API 提供类和接口。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.crypto | 为加密操作提供类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.xml.datatype | XML/Java 类型映射关系。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

java.awt 中 Cloneable 的使用

实现 Cloneable 的 java.awt 中的类
class | BufferCapabilities 缓冲区的能力和属性。
class | Dimension Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
class | GridBagConstraints GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。
class | ImageCapabilities 图像的功能和属性。
class | Insets Insets 对象是容器边界的表示形式。
class | JobAttributes 控制打印作业的属性集合。
class | PageAttributes 用来控制打印页面输出的属性集。
class | Point 表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
class | Rectangle Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
class | RenderingHints RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。

java.awt.datatransfer 中 Cloneable 的使用

实现 Cloneable 的 java.awt.datatransfer 中的类
 class DataFlavor
DataFlavor 提供有关数据的元信息。

java.awt.font 中 Cloneable 的使用

实现 Cloneable 的 java.awt.font 中的类
class | GlyphVector GlyphVector 对象是一个字形的集合，包含在转换坐标空间中放置每个字形的几何信息，该坐标空间对应于最终要显示 GlyphVector 的设备。
class | TextLayout TextLayout 是样式字符数据的不可变图形表示形式。
class | TextMeasurer TextMeasurer 类提供换行所需的基本操作：测量到给定的 advance，确定字符范围的 advance，并为字符范围生成一个 TextLayout。

java.awt.geom 中 Cloneable 的使用

实现 Cloneable 的 java.awt.geom 中的类
class | AffineTransform AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
class | Arc2D Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。
class | Area Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。
class | CubicCurve2D CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。
static class | CubicCurve2D.Double 使用 double 坐标指定的三次参数曲线段。
static class | CubicCurve2D.Float 使用 float 坐标指定的三次参数曲线段。
class | Dimension2D Dimension2D 类用于封装宽度和高度尺寸。
class | Ellipse2D Ellipse2D 类描述窗体矩形定义的椭圆。
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。
class | GeneralPath GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
class | Line2D Line2D 表示 (x,y) 坐标空间中的线段。
static class | Line2D.Double 使用 double 坐标指定的线段。
static class | Line2D.Float 使用 float 坐标指定的线段。
class | Path2D Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。
static class | Path2D.Double Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
static class | Path2D.Float Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
class | Point2D Point2D 类定义表示 (x,y) 坐标空间中位置的点。
static class | Point2D.Double Double 类以 double 精度定义指定的点。
static class | Point2D.Float Float 类以 float 精度定义指定的点。
class | QuadCurve2D QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。
static class | QuadCurve2D.Double 使用 double 坐标指定的二次参数曲线段。
static class | QuadCurve2D.Float 使用 float 坐标指定的二次参数曲线段。
class | Rectangle2D Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。
class | RectangularShape RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。
class | RoundRectangle2D RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

java.awt.image 中 Cloneable 的使用

实现 Cloneable 的 java.awt.image 中的类
class | AreaAveragingScaleFilter 这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。
class | BufferedImageFilter BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。
class | CropImageFilter 用于裁剪图像的 ImageFilter 类。
class | ImageFilter 此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。
class | Kernel Kernel 类定义了一个矩阵，描述指定的像素及其周围像素如何影响过滤操作输出图像中像素位置的计算值。
class | ReplicateScaleFilter 使用最简单的算法缩放图像的 ImageFilter 类。
class | RGBImageFilter 此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。

java.awt.image.renderable 中 Cloneable 的使用

实现 Cloneable 的 java.awt.image.renderable 中的类
class | ParameterBlock ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。
class | RenderContext RenderContext 封装从 enderableImage 生成特定呈现所需的信息。

java.awt.print 中 Cloneable 的使用

实现 Cloneable 的 java.awt.print 中的类
class | PageFormat PageFormat 类描述要打印的页面大小和方向。
class | Paper Paper 类描述一张纸的物理特征。

java.net 中 Cloneable 的使用

实现 Cloneable 的 java.net 中的类
 class HttpCookie
HttpCookie 对象表示一个 http cookie，该 cookie 带有服务器和用户代理之间的状态信息。

java.security 中 Cloneable 的使用

实现 Cloneable 的 java.security 中的类
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

java.security.acl 中 Cloneable 的使用

java.security.acl 中 Cloneable 的子接口
 interface AclEntry
这是用于表示访问控制列表 (ACL) 中某个项的接口。

java.security.cert 中 Cloneable 的使用

java.security.cert 中 Cloneable 的子接口
interface | CertPathBuilderResult 证书路径生成器算法的结果的规范。
interface | CertPathParameters 证书路径算法参数的规范。
interface | CertPathValidatorResult 证书路径验证器算法的结果的规范。
interface | CertSelector 一个定义了一套选择 Certificate 的标准的选择器。
interface | CertStoreParameters CertStore 参数的规范。
interface | CRLSelector 一个定义了一套选择 CRL 的标准的选择器。

实现 Cloneable 的 java.security.cert 中的类
class | CollectionCertStoreParameters 用作 Collection CertStore 算法输入的参数。
class | LDAPCertStoreParameters 用作 LDAP CertStore 算法的输入的参数。
class | PKIXBuilderParameters 用作 PKIX CertPathBuilder 算法的输入的参数。
class | PKIXCertPathBuilderResult 此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。
class | PKIXCertPathChecker 对 X509Certificate 执行一种或多种检查的抽象类。
class | PKIXCertPathValidatorResult 此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。
class | PKIXParameters 用作 PKIX CertPathValidator 算法的输入的参数。
class | X509CertSelector 选择与所有指定标准匹配的 X509Certificates 的 CertSelector。
class | X509CRLSelector 选择与所有指定标准相匹配的 X509CRL 的 CRLSelector。

java.sql 中 Cloneable 的使用

实现 Cloneable 的 java.sql 中的类
class | Time 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
class | Timestamp 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。

java.text 中 Cloneable 的使用

java.text 中 Cloneable 的子接口
interface | AttributedCharacterIterator AttributedCharacterIterator 允许对文本和相关属性信息的迭代。
interface | CharacterIterator 此接口定义了对文本进行双向迭代的协议。

实现 Cloneable 的 java.text 中的类
class | BreakIterator BreakIterator 类实现用于查找文本中边界位置的方法。
class | ChoiceFormat ChoiceFormat 允许将格式应用到某个范围的数。
class | Collator Collator 类执行区分语言环境的 String 比较。
class | DateFormat DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
class | DateFormatSymbols DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。
class | DecimalFormat DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。
class | DecimalFormatSymbols 此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。
class | Format Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。
class | MessageFormat MessageFormat 提供了以与语言无关方式生成连接消息的方式。
class | NumberFormat NumberFormat 是所有数值格式的抽象基类。
class | RuleBasedCollator RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。
class | SimpleDateFormat SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。
class | StringCharacterIterator StringCharacterIterator 为 String 实现 CharacterIterater 协议。

java.util 中 Cloneable 的使用

实现 Cloneable 的 java.util 中的类
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | BitSet 此类实现了一个按需增长的位向量。
class | Calendar Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
class | Date 类 Date 表示特定的瞬间，精确到毫秒。
class | EnumMap<K extends Enum<K>,V> 与枚举类型键一起使用的专用 Map 实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | GregorianCalendar GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。
class | HashMap<K,V> 基于哈希表的 Map 接口的实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | Hashtable<K,V> 此类实现一个哈希表，该哈希表将键映射到相应的值。
class | IdentityHashMap<K,V> 此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
class | LinkedHashMap<K,V> Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | LinkedList<E> List 接口的链接列表实现。
class | Locale Locale 对象表示了特定的地理、政治和文化地区。
class | Properties Properties 类表示了一个持久的属性集。
class | SimpleTimeZone SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | TimeZone TimeZone 表示时区偏移量，也可以计算夏令时。
class | TreeMap<K,V> 基于红黑树（Red-Black tree）的 NavigableMap 实现。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。
class | Vector<E> Vector 类可以实现可增长的对象数组。

java.util.concurrent 中 Cloneable 的使用

实现 Cloneable 的 java.util.concurrent 中的类
class | ConcurrentSkipListMap<K,V> 可缩放的并发 ConcurrentNavigableMap 实现。
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArrayList<E> ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。

java.util.jar 中 Cloneable 的使用

实现 Cloneable 的 java.util.jar 中的类
class | Attributes Attributes 类将 Manifest 属性名称映射到关联的字符串值。
class | JarEntry 此类用于表示 JAR 文件条目。
class | Manifest Manifest 类用于维护 Manifest 条目名称及其相关的 Attributes。

java.util.zip 中 Cloneable 的使用

实现 Cloneable 的 java.util.zip 中的类
 class ZipEntry
此类用于表示 ZIP 文件条目。

javax.activation 中 Cloneable 的使用

实现 Cloneable 的 javax.activation 中的类
 class ActivationDataFlavor
ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。

javax.crypto 中 Cloneable 的使用

实现 Cloneable 的 javax.crypto 中的类
 class Mac
此类提供“消息验证码”（Message Authentication Code，MAC）算法的功能。

javax.management 中 Cloneable 的使用

javax.management 中 Cloneable 的子接口
 interface Descriptor
JMX 元素的附加元数据。

实现 Cloneable 的 javax.management 中的类
class | AttributeList 表示 MBean 属性值的列表。
class | ImmutableDescriptor 不可变的描述符。
class | MBeanAttributeInfo 描述出于管理目的而公开的 MBean 属性。
class | MBeanConstructorInfo 描述 MBean 所公开的构造方法。
class | MBeanInfo 描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
class | MBeanNotificationInfo MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
class | MBeanOperationInfo 描述由 MBean 公开的管理操作。
class | MBeanParameterInfo 描述由 MBean 公开的操作的参数。

javax.management.modelmbean 中 Cloneable 的使用

实现 Cloneable 的 javax.management.modelmbean 中的类
class | DescriptorSupport 此类表示 ModelMBean 元素的元数据集。
class | ModelMBeanAttributeInfo ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
class | ModelMBeanConstructorInfo ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
class | ModelMBeanInfoSupport 此类表示 ModelMBean 的元数据。
class | ModelMBeanNotificationInfo ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
class | ModelMBeanOperationInfo ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

javax.management.openmbean 中 Cloneable 的使用

实现 Cloneable 的 javax.management.openmbean 中的类
class | OpenMBeanAttributeInfoSupport 描述 open MBean 的一个属性。
class | OpenMBeanConstructorInfoSupport 描述 Open MBean 的构造方法。
class | OpenMBeanInfoSupport OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。
class | OpenMBeanOperationInfoSupport 描述 Open MBean 的一个操作。
class | OpenMBeanParameterInfoSupport 描述用于 open MBean 的一个或多个操作或构造方法的参数。
class | TabularDataSupport TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。

javax.management.relation 中 Cloneable 的使用

实现 Cloneable 的 javax.management.relation 中的类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

javax.naming 中 Cloneable 的使用

javax.naming 中 Cloneable 的子接口
 interface Name
Name 接口表示一个一般名称，即一个有序的组件序列。

实现 Cloneable 的 javax.naming 中的类
class | CompositeName 此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
class | CompoundName 此类表示一个组合名称，即一个取自层次名称空间的名称。
class | LinkRef 此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。
class | Reference 此类表示对存在于命名/目录系统以外的对象的引用。

javax.naming.directory 中 Cloneable 的使用

javax.naming.directory 中 Cloneable 的子接口
interface | Attribute 此接口表示与命名对象关联的属性。
interface | Attributes 此接口表示属性的集合。

实现 Cloneable 的 javax.naming.directory 中的类
class | BasicAttribute 此类提供 Attribute 接口的基本实现。
class | BasicAttributes 此类提供 Attributes 接口的基本实现。

javax.naming.ldap 中 Cloneable 的使用

实现 Cloneable 的 javax.naming.ldap 中的类
 class LdapName
此类表示 RFC 2253 指定的标识名。

javax.print 中 Cloneable 的使用

实现 Cloneable 的 javax.print 中的类
class | DocFlavor 类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。
static class | DocFlavor.BYTE_ARRAY 类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.CHAR_ARRAY 类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.INPUT_STREAM 类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.READER 类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.SERVICE_FORMATTED 类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
static class | DocFlavor.STRING 类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.URL 类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。

javax.print.attribute 中 Cloneable 的使用

实现 Cloneable 的 javax.print.attribute 中的类
class | DateTimeSyntax 类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。
class | EnumSyntax 类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。
class | IntegerSyntax 类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。
class | ResolutionSyntax 类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。
class | SetOfIntegerSyntax 类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。
class | Size2DSyntax 类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。
class | TextSyntax 类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。
class | URISyntax 类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。

javax.print.attribute.standard 中 Cloneable 的使用

实现 Cloneable 的 javax.print.attribute.standard 中的类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | ColorSupported ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
class | Compression Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
class | Copies Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
class | CopiesSupported CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
class | DateTimeAtCompleted DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
class | DateTimeAtCreation DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
class | DateTimeAtProcessing DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
class | Destination Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
class | DocumentName DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
class | Fidelity Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | JobHoldUntil JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
class | JobImpressions JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
class | JobImpressionsCompleted JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
class | JobImpressionsSupported JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
class | JobKOctets JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
class | JobKOctetsProcessed JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
class | JobKOctetsSupported JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
class | JobMediaSheets JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
class | JobMediaSheetsCompleted JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
class | JobMediaSheetsSupported Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
class | JobMessageFromOperator JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
class | JobName JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
class | JobOriginatingUserName JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
class | JobPriority JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
class | JobPrioritySupported JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
class | JobSheets JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
class | JobState JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
class | JobStateReason JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。
class | JobStateReasons JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaSize MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | MultipleDocumentHandling MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
class | NumberOfDocuments NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
class | NumberOfInterveningJobs NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | NumberUpSupported NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | OutputDeviceAssigned OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
class | PagesPerMinute PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PagesPerMinuteColor PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PDLOverrideSupported PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
class | PresentationDirection PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
class | PrinterInfo PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
class | PrinterIsAcceptingJobs PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
class | PrinterLocation PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
class | PrinterMakeAndModel PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
class | PrinterMessageFromOperator PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
class | PrinterMoreInfo PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
class | PrinterMoreInfoManufacturer PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
class | PrinterName PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
class | PrinterResolution PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
class | PrinterState PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
class | PrinterStateReason PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrinterStateReasons PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrinterURI PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | QueuedJobCount QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。
class | ReferenceUriSchemesSupported ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。
class | RequestingUserName RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。
class | Severity Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

javax.sound.midi 中 Cloneable 的使用

实现 Cloneable 的 javax.sound.midi 中的类
class | MetaMessage MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。
class | MidiMessage MidiMessage 是 MIDI 消息的基类。
class | ShortMessage ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。
class | SysexMessage 表示 MIDI 系统独占消息 SysexMessage 对象。

javax.sql.rowset 中 Cloneable 的使用

实现 Cloneable 的 javax.sql.rowset 中的类
 class BaseRowSet
提供一个具有基本功能的 RowSet 对象的抽象类。

javax.sql.rowset.serial 中 Cloneable 的使用

实现 Cloneable 的 javax.sql.rowset.serial 中的类
class | SerialArray 序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。
class | SerialBlob SQL BLOB 值在 Java 编程语言中的序列化映射关系。
class | SerialClob SQL CLOB 值在 Java 编程语言中的序列化映射关系。
class | SerialDatalink SQL DATALINK 值在 Java 编程语言中的序列化映射关系。
class | SerialJavaObject SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。
class | SerialRef Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。
class | SerialStruct SQL 结构类型在 Java 编程语言中的序列化映射关系。

javax.swing 中 Cloneable 的使用

实现 Cloneable 的 javax.swing 中的类
class | AbstractAction 此类提供 JFC Action 接口的默认实现。
class | DefaultListSelectionModel 列表选择的默认数据模型。
class | GrayFilter 一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。
static class | JTree.DynamicUtilTreeNode DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。
protected static class | JTree.EmptySelectionModel EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。
class | UIDefaults Swing 组件的默认值表。

javax.swing.plaf 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.plaf 中的类
class | DimensionUIResource
class | InsetsUIResource

javax.swing.plaf.basic 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.plaf.basic 中的类
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
static class | BasicTextUI.BasicCaret
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。

javax.swing.plaf.metal 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.plaf.metal 中的类
protected  class MetalFileChooserUI.DirectoryComboBoxAction
当 DirectoryComboBox 已更改所选项时调用。

javax.swing.text 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.text 中的类
class | DateFormatter DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
class | DefaultCaret 插入符的默认实现。
class | DefaultEditorKit 这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
class | DefaultFormatter DefaultFormatter 格式化任意对象。
class | EditorKit 针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
class | ElementIterator ElementIterator，顾名思义，沿 Element 树进行迭代。
class | GlyphView GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
class | InternationalFormatter InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
class | LabelView LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。
class | MaskFormatter MaskFormatter 用于格式化和编辑字符串。
class | NumberFormatter 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。
class | Segment 表示文本片段的字符数组的 segment。
class | SimpleAttributeSet 使用哈希表的 MutableAttributeSet 的直接实现。
class | StyledEditorKit 这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

javax.swing.text.html 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.text.html 中的类
class | HTMLEditorKit Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。
class | InlineView 显示基于 css 属性的 inline element 样式。

javax.swing.text.rtf 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.text.rtf 中的类
 class RTFEditorKit
这是对 RTF 编辑功能的默认实现。

javax.swing.tree 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.tree 中的类
class | DefaultMutableTreeNode DefaultMutableTreeNode 是树数据结构中的通用节点。
class | DefaultTreeSelectionModel TreeSelectionModel 的默认实现。

javax.xml.datatype 中 Cloneable 的使用

实现 Cloneable 的 javax.xml.datatype 中的类
 class XMLGregorianCalendar
W3C XML 模式 1.0 日期/时间数据类型的表示形式。

org.ietf.jgss 中 Cloneable 的使用

org.ietf.jgss 中 Cloneable 的子接口
 interface GSSCredential
此接口将为实体封装 GSS-API 凭据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.CloneNotSupportedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.CloneNotSupportedException
的使用

使用 CloneNotSupportedException 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.crypto | 为加密操作提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt.datatransfer 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 java.awt.datatransfer 中的方法
 Object DataFlavor.clone()
返回此 DataFlavor 的副本。

java.lang 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 java.lang 中的方法
protected Object | Enum.clone() 抛出 CloneNotSupportedException。
protected Object | Object.clone() 创建并返回此对象的一个副本。

java.rmi.server 中 CloneNotSupportedException 的使用

java.rmi.server 中 CloneNotSupportedException 的子类
 class ServerCloneException
如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。

抛出 CloneNotSupportedException 的 java.rmi.server 中的方法
 Object UnicastRemoteObject.clone()
返回与初始对象不同的远程对象的副本。

java.security 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 java.security 中的方法
Object | Signature.clone() 如果此实现可以复制，则返回副本。
Object | SignatureSpi.clone() 如果此实现可以复制，则返回一个副本。
Object | MessageDigest.clone() 如果实现是可复制的，则返回一个副本。
Object | MessageDigestSpi.clone() 如果实现是可复制的，则返回一个副本。

java.util 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 java.util 中的方法
protected  Object AbstractMap.clone()
返回此 AbstractMap 实例的浅表副本：不复制键和值本身。

javax.crypto 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 javax.crypto 中的方法
Object | Mac.clone() 如果提供者实现可以复制，则返回一个副本。
Object | MacSpi.clone() 如果此实现可以复制，则返回一个副本。

javax.swing 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 javax.swing 中的方法
protected Object | JFormattedTextField.AbstractFormatter.clone() 复制 AbstractFormatter。
protected Object | AbstractAction.clone() 复制抽象操作。
Object | DefaultListSelectionModel.clone() 返回此选择模型的具有相同选择的副本。

javax.swing.text 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 javax.swing.text 中的方法
Object | DefaultFormatter.clone() 创建此 DefaultFormatter 的副本。
Object | InternationalFormatter.clone() 创建该 DefaultFormatter 的一个副本。

javax.swing.tree 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 javax.swing.tree 中的方法
 Object DefaultTreeSelectionModel.clone()
返回具有相同 selection 的此对象的副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.Comparable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Comparable
的使用

使用 Comparable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.annotation |
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.jws |
javax.jws.soap |
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。

java.awt 中 Comparable 的使用

实现 Comparable 的 java.awt 中的类
static class | Component.BaselineResizeBehavior 常见方式的枚举，指示组件的基线可以随大小的更改而更改。
static class | Desktop.Action 表示动作类型。
static class | Dialog.ModalExclusionType 任何顶层窗口都可以标记为不受模式对话框阻塞。
static class | Dialog.ModalityType 模式对话框阻塞对某些顶层窗口的所有输入。
static class | MultipleGradientPaint.ColorSpaceType 在其中执行渐变插值操作的颜色空间。
static class | MultipleGradientPaint.CycleMethod 在渐变边界以外进行绘制时使用的方法。
static class | TrayIcon.MessageType MessageType 确定哪个图标将显示在消息标题中，以及消息根据显示生成的可能的系统声音。

java.io 中 Comparable 的使用

实现 Comparable 的 java.io 中的类
class | File 文件和目录路径名的抽象表示形式。
class | ObjectStreamField Serializable 类中 Serializable 字段的描述。

java.lang 中 Comparable 的使用

实现 Comparable 的 java.lang 中的类
class | Boolean Boolean 类将基本类型为 boolean 的值包装在一个对象中。
class | Byte Byte 类将基本类型 byte 的值包装在一个对象中。
class | Character Character 类在对象中包装一个基本类型 char 的值。
class | Double Double 类在对象中包装一个基本类型 double 的值。
class | Enum<E extends Enum<E>> 这是所有 Java 语言枚举类型的公共基本类。
class | Float Float 类在对象中包装一个基本类型 float 的值。
class | Integer Integer 类在对象中包装了一个基本类型 int 的值。
class | Long Long 类在对象中包装了基本类型 long 的值。
class | Short Short 类在对象中包装基本类型 short 的值。
class | String String 类代表字符串。
static class | Thread.State 线程状态。

java.lang.annotation 中 Comparable 的使用

实现 Comparable 的 java.lang.annotation 中的类
class | ElementType 程序元素类型。
class | RetentionPolicy 注释保留策略。

java.lang.management 中 Comparable 的使用

实现 Comparable 的 java.lang.management 中的类
 class MemoryType
内存池的类型。

java.math 中 Comparable 的使用

实现 Comparable 的 java.math 中的类
class | BigDecimal 不可变的、任意精度的有符号十进制数。
class | BigInteger 不可变的任意精度的整数。
class | RoundingMode 为可能丢弃精度的数值操作指定一种舍入行为。

java.net 中 Comparable 的使用

实现 Comparable 的 java.net 中的类
static class | Authenticator.RequestorType 请求验证的实体的类型。
static class | Proxy.Type 表示代理类型。
class | URI 表示一个统一资源标识符 (URI) 引用。

java.nio 中 Comparable 的使用

实现 Comparable 的 java.nio 中的类
class | ByteBuffer 字节缓冲区。
class | CharBuffer 字符缓冲区。
class | DoubleBuffer double 缓冲区。
class | FloatBuffer float 缓冲区。
class | IntBuffer int 缓冲区。
class | LongBuffer long 缓冲区。
class | MappedByteBuffer 直接字节缓冲区，其内容是文件的内存映射区域。
class | ShortBuffer short 缓冲区。

java.nio.charset 中 Comparable 的使用

实现 Comparable 的 java.nio.charset 中的类
 class Charset
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。

java.security 中 Comparable 的使用

实现 Comparable 的 java.security 中的类
static class KeyRep.Type
Key 类型。

java.sql 中 Comparable 的使用

实现 Comparable 的 java.sql 中的类
class | ClientInfoStatus 无法通过调用 Connection.setClientInfo 设置属性的原因状态的枚举。
class | RowIdLifetime RowId 生存期值的枚举。
class | Time 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
class | Timestamp 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。

java.text 中 Comparable 的使用

实现 Comparable 的 java.text 中的类
class | CollationKey CollationKey 表示遵守特定 Collator 对象规则的 String。
static class | Normalizer.Form 此枚举提供在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的四个 Unicode 标准化形式的常量，以及访问这些常量的两个方法。

java.util 中 Comparable 的使用

实现 Comparable 的 java.util 中的类
class | Calendar Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
class | Date 类 Date 表示特定的瞬间，精确到毫秒。
static class | Formatter.BigDecimalLayoutForm
class | GregorianCalendar GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。
class | UUID 表示通用唯一标识符 (UUID) 的类。

类型参数类型为 Comparable 的 java.util 中的方法
static
<T extends Object & Comparable<? super T>>
T
Collections.max(Collection<? extends T> coll)
根据元素的自然顺序，返回给定 collection 的最大元素。
static
<T extends Object & Comparable<? super T>>
T
Collections.min(Collection<? extends T> coll)
根据元素的自然顺序 返回给定 collection 的最小元素。
static
<T extends Comparable<? super T>>
void
Collections.sort(List<T> list)
根据元素的自然顺序 对指定列表按升序进行排序。

类型变量类型为 Comparable 的 java.util 中的方法参数
static
<T> int
Collections.binarySearch(List<? extends Comparable<? super T>> list, T key)
使用二分搜索法搜索指定列表，以获得指定对象。

java.util.concurrent 中 Comparable 的使用

java.util.concurrent 中 Comparable 的子接口
interface | Delayed 一种混合风格的接口，用来标记那些应该在给定延迟时间之后执行的对象。
interface | RunnableScheduledFuture<V> 作为 Runnable 的 ScheduledFuture。
interface | ScheduledFuture<V> 一个延迟的、结果可接受的操作，可将其取消。

实现 Comparable 的 java.util.concurrent 中的类
 class TimeUnit
TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。

javax.annotation 中 Comparable 的使用

实现 Comparable 的 javax.annotation 中的类
static class Resource.AuthenticationType
资源的两种可能验证类型。

javax.imageio.metadata 中 Comparable 的使用

类型参数类型为 Comparable 的 javax.imageio.metadata 中的方法
protected
<T extends Object & Comparable<? super T>>
void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

返回 Comparable 的 javax.imageio.metadata 中的方法
Comparable<?> | IIOMetadataFormat.getObjectMaxValue(String elementName) 返回指定元素中 Object 引用的最大合法值。
Comparable<?> | IIOMetadataFormatImpl.getObjectMaxValue(String elementName)
Comparable<?> | IIOMetadataFormat.getObjectMinValue(String elementName) 返回指定元素中 Object 引用的最小合法值。
Comparable<?> | IIOMetadataFormatImpl.getObjectMinValue(String elementName)

参数类型为 Comparable 的 javax.imageio.metadata 中的方法
protected
<T extends Object & Comparable<? super T>>
void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T extends Object & Comparable<? super T>>
void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

javax.jws 中 Comparable 的使用

实现 Comparable 的 javax.jws 中的类
static class WebParam.Mode
参数的流向。

javax.jws.soap 中 Comparable 的使用

实现 Comparable 的 javax.jws.soap 中的类
static class | SOAPBinding.ParameterStyle 参数到 SOAP 消息的映射关系的样式。
static class | SOAPBinding.Style SOAP 绑定样式。
static class | SOAPBinding.Use SOAP 绑定的使用。

javax.lang.model 中 Comparable 的使用

实现 Comparable 的 javax.lang.model 中的类
 class SourceVersion
Java™ 编程语言的源版本。

javax.lang.model.element 中 Comparable 的使用

实现 Comparable 的 javax.lang.model.element 中的类
class | ElementKind 元素的 kind。
class | Modifier 表示程序元素（如类、方法或字段）上的修饰符。
class | NestingKind 某一类型元素的嵌套种类 (nesting kind)。

javax.lang.model.type 中 Comparable 的使用

实现 Comparable 的 javax.lang.model.type 中的类
 class TypeKind
类型镜像的种类。

javax.management 中 Comparable 的使用

实现 Comparable 的 javax.management 中的类
 class ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

javax.management.openmbean 中 Comparable 的使用

返回 Comparable 的 javax.management.openmbean 中的方法
Comparable<?> | OpenMBeanAttributeInfoSupport.getMaxValue() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最大值（如果已指定），否则返回 null。
Comparable<?> | OpenMBeanParameterInfo.getMaxValue() 返回此参数的最大值（如果存在），否则返回 null。
Comparable<?> | OpenMBeanParameterInfoSupport.getMaxValue() 返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最大值（如果指定），否则返回 null。
Comparable<?> | OpenMBeanAttributeInfoSupport.getMinValue() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最小值（如果已指定），否则返回 null。
Comparable<?> | OpenMBeanParameterInfo.getMinValue() 返回此参数的最小值（如果存在），否则返回 null。
Comparable<?> | OpenMBeanParameterInfoSupport.getMinValue() 返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最小值（如果指定），否则返回 null。

参数类型为 Comparable 的 javax.management.openmbean 中的构造方法
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

javax.naming 中 Comparable 的使用

javax.naming 中 Comparable 的子接口
 interface Name
Name 接口表示一个一般名称，即一个有序的组件序列。

实现 Comparable 的 javax.naming 中的类
class | CompositeName 此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
class | CompoundName 此类表示一个组合名称，即一个取自层次名称空间的名称。

javax.naming.ldap 中 Comparable 的使用

实现 Comparable 的 javax.naming.ldap 中的类
class | LdapName 此类表示 RFC 2253 指定的标识名。
class | Rdn 此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。

javax.net.ssl 中 Comparable 的使用

实现 Comparable 的 javax.net.ssl 中的类
static class | SSLEngineResult.HandshakeStatus 描述此 SSLEngine 的当前握手状态的 SSLEngineResult 枚举。
static class | SSLEngineResult.Status 描述 SSLEngine 操作总体结果的 SSLEngineResult 枚举。

javax.swing 中 Comparable 的使用

实现 Comparable 的 javax.swing 中的类
class | DropMode 放置模式，用于确定组件在拖放过程中跟踪和指示放置位置 (drop location) 的方法。
static class | GroupLayout.Alignment ParallelGroup 能够对齐其子元素的可能方式的枚举。
static class | JTable.PrintMode 用于打印 JTable 的打印模式。
static class | LayoutStyle.ComponentPlacement ComponentPlacement 是两个组件相对于彼此的可能放置方式的枚举。
static class | RowFilter.ComparisonType 由某些默认 RowFilter 支持的可能比较值的枚举。
class | SortOrder SortOrder 是可能排序顺序的枚举。
static class | SwingWorker.StateValue state 绑定 (bound) 属性的值。

返回 Comparable 的 javax.swing 中的方法
Comparable | SpinnerDateModel.getEnd() 返回序列中的最后一个 Date。
Comparable | SpinnerNumberModel.getMaximum() 返回该序列中的最后一个数字。
Comparable | SpinnerNumberModel.getMinimum() 返回此序列中的第一个数字。
Comparable | SpinnerDateModel.getStart() 返回序列中的第一个 Date。

参数类型为 Comparable 的 javax.swing 中的方法
void | SpinnerDateModel.setEnd(Comparable end) 更改此序列中 Date 的上限。
void | SpinnerNumberModel.setMaximum(Comparable maximum) 更改此序列中数字的上边界。
void | SpinnerNumberModel.setMinimum(Comparable minimum) 更改此序列中数字的下边界。
void | SpinnerDateModel.setStart(Comparable start) 更改此序列中的日期下限。

参数类型为 Comparable 的 javax.swing 中的构造方法
SpinnerDateModel(Date value, Comparable start, Comparable end, int calendarField)
创建一个表示 start 和 end 之间的日期序列的 SpinnerDateModel。
SpinnerDateModel(Date value, Comparable start, Comparable end, int calendarField)
创建一个表示 start 和 end 之间的日期序列的 SpinnerDateModel。
SpinnerNumberModel(Number value, Comparable minimum, Comparable maximum, Number stepSize)
构造一个表示从 minimum 到 maximum 的闭区间数字序列的 SpinnerModel。
SpinnerNumberModel(Number value, Comparable minimum, Comparable maximum, Number stepSize)
构造一个表示从 minimum 到 maximum 的闭区间数字序列的 SpinnerModel。

javax.swing.event 中 Comparable 的使用

实现 Comparable 的 javax.swing.event 中的类
static class RowSorterEvent.Type
RowSorterEvent 类型的枚举。

javax.swing.text 中 Comparable 的使用

返回 Comparable 的 javax.swing.text 中的方法
Comparable | InternationalFormatter.getMaximum() 返回最大允许值。
Comparable | InternationalFormatter.getMinimum() 返回最小允许值。

参数类型为 Comparable 的 javax.swing.text 中的方法
void | InternationalFormatter.setMaximum(Comparable max) 设置最大允许值。
void | InternationalFormatter.setMinimum(Comparable minimum) 设置最小允许值。

javax.swing.text.html 中 Comparable 的使用

实现 Comparable 的 javax.swing.text.html 中的类
static class FormSubmitEvent.MethodType
表示 HTML 表单方法类型。

javax.tools 中 Comparable 的使用

实现 Comparable 的 javax.tools 中的类
static class | Diagnostic.Kind 诊断的种类，例如，错误或者警告。
static class | JavaFileObject.Kind JavaFileObject 的种类。
class | StandardLocation 文件对象的标准位置。

javax.xml.bind.annotation 中 Comparable 的使用

实现 Comparable 的 javax.xml.bind.annotation 中的类
class | XmlAccessOrder 由 XmlAccessorOrder 使用，用于控制 JAXB 绑定类中属性和字段的排序。
class | XmlAccessType 由 XmlAccessorType 使用，用于控制字段或属性的序列化。
class | XmlNsForm XML 模式名称空间限定的枚举。

javax.xml.ws 中 Comparable 的使用

实现 Comparable 的 javax.xml.ws 中的类
static class Service.Mode
动态客户端或服务的方向。

javax.xml.ws.handler 中 Comparable 的使用

实现 Comparable 的 javax.xml.ws.handler 中的类
static class MessageContext.Scope
属性作用域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Compiler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Compiler
的使用

没有 java.lang.Compiler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Deprecated 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Deprecated
的使用

使用 Deprecated 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.rmi | 提供 RMI 包。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.jws.soap |
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

java.awt 中 Deprecated 的使用

注释类型为 Deprecated 的 java.awt 中的字段
static int | Frame.CROSSHAIR_CURSOR 已过时。 由 Cursor.CROSSHAIR_CURSOR 取代。
static int | Frame.DEFAULT_CURSOR 已过时。 由 Cursor.DEFAULT_CURSOR 取代。
static int | Frame.E_RESIZE_CURSOR 已过时。 由 Cursor.E_RESIZE_CURSOR 取代。
static int | Frame.HAND_CURSOR 已过时。 由 Cursor.HAND_CURSOR 取代。
static int | Frame.MOVE_CURSOR 已过时。 由 Cursor.MOVE_CURSOR 取代。
static int | Frame.N_RESIZE_CURSOR 已过时。 由 Cursor.N_RESIZE_CURSOR 取代。
static int | Frame.NE_RESIZE_CURSOR 已过时。 由 Cursor.NE_RESIZE_CURSOR 取代。
static int | Frame.NW_RESIZE_CURSOR 已过时。 由 Cursor.NW_RESIZE_CURSOR 取代。
static int | Frame.S_RESIZE_CURSOR 已过时。 由 Cursor.S_RESIZE_CURSOR 取代。
static int | Frame.SE_RESIZE_CURSOR 已过时。 由 Cursor.SE_RESIZE_CURSOR 取代。
static int | Frame.SW_RESIZE_CURSOR 已过时。 由 Cursor.SW_RESIZE_CURSOR 取代。
static int | Frame.TEXT_CURSOR 已过时。 由 Cursor.TEXT_CURSOR 取代。
static int | Frame.W_RESIZE_CURSOR 已过时。 由 Cursor.W_RESIZE_CURSOR 取代。
static int | Frame.WAIT_CURSOR 已过时。 由 Cursor.WAIT_CURSOR 取代。

注释类型为 Deprecated 的 java.awt 中的方法
 boolean Component.action(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。
 void List.addItem(String item)
已过时。 由 add(String) 取代。
 void List.addItem(String item, int index)
已过时。 由 add(String, int) 取代。
 void CardLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。
 void BorderLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。
 boolean List.allowsMultipleSelections()
已过时。 从 JDK version 1.1 开始，由 isMultipleMode() 取代。
 void TextArea.appendText(String str)
已过时。 从 JDK version 1.1 开始，由 append(String) 取代。
 void Window.applyResourceBundle(ResourceBundle rb)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
 void Window.applyResourceBundle(String rbName)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
 Rectangle Component.bounds()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
 void List.clear()
已过时。 从 JDK version 1.1 开始，由 removeAll() 取代。
 int Container.countComponents()
已过时。 从 JDK version 1.1 开始，用 etComponentCount() 取代。
 int Choice.countItems()
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。
 int List.countItems()
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。
 int Menu.countItems()
已过时。 从 JDK version 1.1 开始，已由 getItemCount() 取代。
 int MenuBar.countMenus()
已过时。 从 JDK version 1.1 开始，由 getMenuCount() 取代。
 void List.delItem(int position)
已过时。 由 remove(String) 和 remove(int) 取代。
 void List.delItems(int start, int end)
已过时。 从 JDK version 1.1 开始，后来不再公开使用。只希望作为包私有方法时保留此方法。
 void Container.deliverEvent(Event e)
已过时。 从 JDK version 1.1 开始，用 dispatchEvent(AWTEvent e) 取代
 void Component.deliverEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent e) 取代。
 void MenuItem.disable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void Component.disable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void MenuItem.enable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void Component.enable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void MenuItem.enable(boolean b)
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void Component.enable(boolean b)
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 Rectangle Polygon.getBoundingBox()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
 Rectangle Graphics.getClipRect()
已过时。 从 JDK version 1.1 开始，由 getClipBounds() 取代。
 Checkbox CheckboxGroup.getCurrent()
已过时。 从 JDK version 1.1 开始，由 getSelectedCheckbox() 取代。
 int Frame.getCursorType()
已过时。 从 JDK version 1.1 开始，由 Component.getCursor() 取代。
abstract  String[] Toolkit.getFontList()
已过时。 请参阅 GraphicsEnvironment.getAvailableFontFamilyNames()
abstract  FontMetrics Toolkit.getFontMetrics(Font font)
已过时。 从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。
protected abstract  java.awt.peer.FontPeer Toolkit.getFontPeer(String name, int style)
已过时。 请参阅 java.awt.GraphicsEnvironment#getAllFonts
 int Scrollbar.getLineIncrement()
已过时。 从 JDK version 1.1 开始，由 getUnitIncrement() 取代。
 int FontMetrics.getMaxDecent()
已过时。 从 JDK version 1.1.1 开始，由 getMaxDescent() 取代。
static ComponentOrientation ComponentOrientation.getOrientation(ResourceBundle bdl)
已过时。 在 J2SE 1.4 中，使用 ComponentOrientation.getOrientation(java.util.Locale)。
 int Scrollbar.getPageIncrement()
已过时。 从 JDK version 1.1 开始，由 getBlockIncrement() 取代。
 java.awt.peer.MenuComponentPeer MenuComponent.getPeer()
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体。
 java.awt.peer.FontPeer Font.getPeer()
已过时。 现在，字体呈现与平台无关。
 java.awt.peer.ComponentPeer Component.getPeer()
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体；由 boolean isDisplayable() 取代。
 int Scrollbar.getVisible()
已过时。 从 JDK version 1.1 开始，由 getVisibleAmount() 取代。
 boolean Component.gotFocus(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
 boolean Component.handleEvent(Event evt)
已过时。 从 JDK version 1.1 开始，由 processEvent(AWTEvent) 取代。
 void Dialog.hide()
已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
 void Window.hide()
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
 void Component.hide()
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
 void TextArea.insertText(String str, int pos)
已过时。 从 JDK version 1.1 开始，由 insert(String, int) 取代。
 Insets Container.insets()
已过时。 从 JDK version 1.1 开始，用 getInsets() 取代。
 boolean Polygon.inside(int x, int y)
已过时。 从 JDK version 1.1 开始, 此函数为 contains(int, int)。
 boolean Rectangle.inside(int X, int Y)
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。
 boolean Component.inside(int x, int y)
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。
 boolean Component.isFocusTraversable()
已过时。 从 1.4 开始，由 isFocusable() 取代。
 boolean List.isSelected(int index)
已过时。 从 JDK version 1.1 开始，由 isIndexSelected(int) 取代。
 boolean Component.keyDown(Event evt, int key)
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
 boolean Component.keyUp(Event evt, int key)
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
 void ScrollPane.layout()
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。
 void Container.layout()
已过时。 从 JDK version 1.1，用 doLayout() 取代。
 void Component.layout()
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。
 Component Container.locate(int x, int y)
已过时。 从 JDK version 1.1 开始，用 getComponentAt(int, int) 取代。
 Component Component.locate(int x, int y)
已过时。 从 JDK version 1.1 开始，由 getComponentAt(int, int) 取代。
 Point Component.location()
已过时。 从 JDK version 1.1 开始，由 getLocation() 取代。
 boolean Component.lostFocus(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
 Dimension List.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension TextArea.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension TextField.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension Container.minimumSize()
已过时。 从 JDK version 1.1 开始，用 getMinimumSize() 取代。
 Dimension Component.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension List.minimumSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
 Dimension TextField.minimumSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
 Dimension TextArea.minimumSize(int rows, int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int, int) 取代。
 boolean Component.mouseDown(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 boolean Component.mouseDrag(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
 boolean Component.mouseEnter(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 boolean Component.mouseExit(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 boolean Component.mouseMove(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
 boolean Component.mouseUp(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 void Rectangle.move(int x, int y)
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
 void Component.move(int x, int y)
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
 void Component.nextFocus()
已过时。 从 JDK version 1.1 开始，由 transferFocus() 取代。
 boolean MenuComponent.postEvent(Event evt)
已过时。 从 JDK version 1.1 开始，已由 dispatchEvent 取代。
 boolean Window.postEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
 boolean Component.postEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
 boolean MenuContainer.postEvent(Event evt)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
 Dimension List.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension TextArea.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension TextField.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension Container.preferredSize()
已过时。 从 JDK version 1.1 开始，用 getPreferredSize() 取代。
 Dimension Component.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension List.preferredSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
 Dimension TextField.preferredSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
 Dimension TextArea.preferredSize(int rows, int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int, int) 取代。
 void TextArea.replaceText(String str, int start, int end)
已过时。 从 JDK version 1.1 开始，由 replaceRange(String, int, int) 取代。
 void Rectangle.reshape(int x, int y, int width, int height)
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
 void Window.reshape(int x, int y, int width, int height)
已过时。 从 JDK 1.1 版开始，由 setBounds(int, int, int, int) 取代。
 void Component.reshape(int x, int y, int width, int height)
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
 void Component.resize(Dimension d)
已过时。 从 JDK version 1.1 开始，由 setSize(Dimension) 取代。
 void Rectangle.resize(int width, int height)
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。
 void Component.resize(int width, int height)
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。
 void CheckboxGroup.setCurrent(Checkbox box)
已过时。 从 JDK version 1.1 开始，由 setSelectedCheckbox(Checkbox) 取代。
 void Frame.setCursor(int cursorType)
已过时。 从 JDK version 1.1 开始，由 Component.setCursor(Cursor) 取代。
 void TextField.setEchoCharacter(char c)
已过时。 从 JDK version 1.1 开始，由 setEchoChar(char) 取代。
 void Scrollbar.setLineIncrement(int v)
已过时。 从 JDK version 1.1 开始，由 setUnitIncrement(int) 取代。
 void List.setMultipleSelections(boolean b)
已过时。 从 JDK version 1.1 开始，由 setMultipleMode(boolean) 取代。
 void Scrollbar.setPageIncrement(int v)
已过时。 从 JDK version 1.1 开始，由 setBlockIncrement() 取代。
 void Dialog.show()
已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
 void Window.show()
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
 void Component.show()
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
 void Component.show(boolean b)
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
 Dimension Component.size()
已过时。 从 JDK version 1.1 开始，由 getSize() 取代。

java.awt.datatransfer 中 Deprecated 的使用

注释类型为 Deprecated 的 java.awt.datatransfer 中的字段
static DataFlavor DataFlavor.plainTextFlavor
已过时。 从 1.3 开始。使用 DataFlavor.getReaderForText(Transferable) 代替 Transferable.getTransferData(DataFlavor.plainTextFlavor)。

注释类型为 Deprecated 的 java.awt.datatransfer 中的方法
 boolean DataFlavor.equals(String s)
已过时。 与 hashCode() 协定不一致，使用 isMimeTypeEqual(String) 代替。
protected  String DataFlavor.normalizeMimeType(String mimeType)
已过时。
protected  String DataFlavor.normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。

java.awt.event 中 Deprecated 的使用

注释类型为 Deprecated 的 java.awt.event 中的方法
 void KeyEvent.setModifiers(int modifiers)
已过时。 从 JDK1.1.4 开始

注释类型为 Deprecated 的 java.awt.event 中的构造方法
KeyEvent(Component source, int id, long when, int modifiers, int keyCode)
已过时。 从 JDK1.1 开始

java.awt.image.renderable 中 Deprecated 的使用

注释类型为 Deprecated 的 java.awt.image.renderable 中的方法
void | RenderContext.concetenateTransform(AffineTransform modTransform) 已过时。 由 concatenateTransform(AffineTransform) 所替代。
void | RenderContext.preConcetenateTransform(AffineTransform modTransform) 已过时。 由 preConcatenateTransform(AffineTransform) 所取代。

java.io 中 Deprecated 的使用

注释类型为 Deprecated 的 java.io 中的类
class | LineNumberInputStream 已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
class | StringBufferInputStream 已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。

注释类型为 Deprecated 的 java.io 中的方法
 String ObjectInputStream.readLine()
已过时。 此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。
 String DataInputStream.readLine()
已过时。 该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
 String ByteArrayOutputStream.toString(int hibyte)
已过时。 此方法无法将字节正确转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是通过 toString(String enc) 方法（使用一个编码名称参数），或 toString() 方法（使用平台的默认字符编码）。
 URL File.toURL()
已过时。 此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。
abstract  void ObjectOutputStream.PutField.write(ObjectOutput out)
已过时。 此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。

注释类型为 Deprecated 的 java.io 中的构造方法
StreamTokenizer(InputStream is)
已过时。 从 JDK 版本 1.1 开始，标记输入流的首选方法是将其转换为一个字符流，例如：
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);

java.lang 中 Deprecated 的使用

注释类型为 Deprecated 的 java.lang 中的字段
protected boolean | SecurityManager.inCheck 已过时。 建议不使用该类型的安全检查。建议使用 checkPermission 调用。
static Character.UnicodeBlock | Character.UnicodeBlock.SURROGATES_AREA 已过时。 从 J2SE 5 开始，使用 Character.UnicodeBlock.HIGH_SURROGATES、Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES 和 Character.UnicodeBlock.LOW_SURROGATES。这些新常量符合 Unicode 标准的块定义。Character.UnicodeBlock.of(char) 和 Character.UnicodeBlock.of(int) 方法返回新常量，而不是 SURROGATES_AREA。

注释类型为 Deprecated 的 java.lang 中的方法
 boolean ThreadGroup.allowThreadSuspension(boolean b)
已过时。 此调用的定义取决于 ThreadGroup.suspend()，它被废弃了。更进一步地说，此调用的行为从不被指定。
 void SecurityManager.checkMulticast(InetAddress maddr, byte ttl)
已过时。 由 #checkPermission(java.security.Permission) 取代
protected  int SecurityManager.classDepth(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  int SecurityManager.classLoaderDepth()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
 int Thread.countStackFrames()
已过时。 该调用的定义依赖于 Thread.suspend()，但它遭到了反对。此外，该调用的结果从来都不是意义明确的。
protected  ClassLoader SecurityManager.currentClassLoader()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  Class<?> SecurityManager.currentLoadedClass()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  Class<?> ClassLoader.defineClass(byte[] b, int off, int len)
已过时。 由 defineClass(String, byte[], int, int) 取代
 void Thread.destroy()
已过时。 该方法最初用于破坏该线程，但不作任何清除。它所保持的任何监视器都会保持锁定状态。不过，该方法决不会被实现。即使要实现，它也极有可能以 Thread.suspend() 方式被死锁。如果目标线程被破坏时保持一个保护关键系统资源的锁，则任何线程在任何时候都无法再次访问该资源。如果另一个线程曾试图锁定该资源，则会出现死锁。这类死锁通常会证明它们自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void String.getBytes(int srcBegin, int srcEnd, byte[] dst, int dstBegin)
已过时。 该方法无法将字符正确转换为字节。从 JDK 1.1 起，完成该转换的首选方法是通过 String.getBytes() 方法，该方法使用平台的默认字符集。
 boolean SecurityManager.getInCheck()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
 InputStream Runtime.getLocalizedInputStream(InputStream in)
已过时。 从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。
 OutputStream Runtime.getLocalizedOutputStream(OutputStream out)
已过时。 从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。
protected  boolean SecurityManager.inClass(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  boolean SecurityManager.inClassLoader()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
static boolean Character.isJavaLetter(char ch)
已过时。 由 isJavaIdentifierStart(char) 取代。
static boolean Character.isJavaLetterOrDigit(char ch)
已过时。 由 isJavaIdentifierPart(char) 取代。
static boolean Character.isSpace(char ch)
已过时。 由 isWhitespace(char) 取代。
 void ThreadGroup.resume()
已过时。 此方法只用于联合 Thread.suspend 和 ThreadGroup.suspend 时，因为它们所固有的容易导致死锁的特性，所以两者都已废弃。有关详细信息，请参阅 Thread.suspend()。
 void Thread.resume()
已过时。 该方法只与 Thread.suspend() 一起使用，但 Thread.suspend() 已经遭到反对，因为它具有死锁倾向。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
static void Runtime.runFinalizersOnExit(boolean value)
已过时。 此方法本身具有不安全性。它可能对正在使用的对象调用终结方法，而其他线程正在操作这些对象，从而导致不正确的行为或死锁。
static void System.runFinalizersOnExit(boolean value)
已过时。 该方法具有固有的不安全性。它可能对正在使用的对象调用终结方法，而其他线程同时正在操作这些对象，从而导致不正确的行为或死锁。
 void ThreadGroup.stop()
已过时。 此方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。
 void Thread.stop()
已过时。 该方法具有固有的不安全性。用 Thread.stop 来终止线程将释放它已经锁定的所有监视器（作为沿堆栈向上传播的未检查 ThreadDeath 异常的一个自然后果）。如果以前受这些监视器保护的任何对象都处于一种不一致的状态，则损坏的对象将对其他线程可见，这有可能导致任意的行为。stop 的许多使用都应由只修改某些变量以指示目标线程应该停止运行的代码来取代。目标线程应定期检查该变量，并且如果该变量指示它要停止运行，则从其运行方法依次返回。如果目标线程等待很长时间（例如基于一个条件变量），则应使用 interrupt 方法来中断该等待。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void Thread.stop(Throwable obj)
已过时。 该方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。 该方法的附加危险是它可用于生成目标线程未准备处理的异常（包括若没有该方法该线程不太可能抛出的已检查的异常）。 有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void ThreadGroup.suspend()
已过时。 此方法容易导致死锁。有关详细信息，请参阅 Thread.suspend()。
 void Thread.suspend()
已过时。 该方法已经遭到反对，因为它具有固有的死锁倾向。如果目标线程挂起时在保护关键系统资源的监视器上保持有锁，则在目标线程重新开始以前任何线程都不能访问该资源。如果重新开始目标线程的线程想在调用 resume 之前锁定该监视器，则会发生死锁。这类死锁通常会证明自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。

注释类型为 Deprecated 的 java.lang 中的构造方法
String(byte[] ascii, int hibyte)
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。
String(byte[] ascii, int hibyte, int offset, int count)
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。

java.net 中 Deprecated 的使用

注释类型为 Deprecated 的 java.net 中的字段
static int HttpURLConnection.HTTP_SERVER_ERROR
已过时。 放错了位置，它不应该存在。

注释类型为 Deprecated 的 java.net 中的方法
static String URLDecoder.decode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。
static String URLEncoder.encode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。
static String URLConnection.getDefaultRequestProperty(String key)
已过时。 应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。
protected abstract  byte DatagramSocketImpl.getTTL()
已过时。 使用 getTimeToLive 代替。
 byte MulticastSocket.getTTL()
已过时。 使用 getTimeToLive 方法来代替，该方法返回 int（而不是 byte）。
 void MulticastSocket.send(DatagramPacket p, byte ttl)
已过时。 使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......
static void URLConnection.setDefaultRequestProperty(String key, String value)
已过时。 应在获得 URLConnection 的适当实例后使用特定 setRequestProperty 方法的实例。调用此方法没有任何作用。
protected abstract  void DatagramSocketImpl.setTTL(byte ttl)
已过时。 使用 setTimeToLive 代替。
 void MulticastSocket.setTTL(byte ttl)
已过时。 使用 setTimeToLive 方法来代替，该方法使用 int（而不用 byte）作为 ttl 的类型。
protected  void URLStreamHandler.setURL(URL u, String protocol, String host, int port, String file, String ref)
已过时。 使用 setURL(URL, String, String, int, String, String, String, String);

注释类型为 Deprecated 的 java.net 中的构造方法
Socket(InetAddress host, int port, boolean stream)
已过时。 Use DatagramSocket instead for UDP transport.
Socket(String host, int port, boolean stream)
已过时。 使用 DatagramSocket 取代 UDP 传输。

java.rmi 中 Deprecated 的使用

注释类型为 Deprecated 的 java.rmi 中的类
class | RMISecurityException 已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
class | ServerRuntimeException 已过时。 无替换版本

注释类型为 Deprecated 的 java.rmi 中的构造方法
RMISecurityException(String name)
已过时。 无替换版本
RMISecurityException(String name, String arg)
已过时。 无替换版本
ServerRuntimeException(String s, Exception ex)
已过时。 无替换版本

java.rmi.dgc 中 Deprecated 的使用

注释类型为 Deprecated 的 java.rmi.dgc 中的方法
static boolean VMID.isUnique()
已过时。

java.rmi.registry 中 Deprecated 的使用

注释类型为 Deprecated 的 java.rmi.registry 中的类
 interface RegistryHandler
已过时。 无替代版本

注释类型为 Deprecated 的 java.rmi.registry 中的方法
Registry | RegistryHandler.registryImpl(int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。
Registry | RegistryHandler.registryStub(String host, int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。

java.rmi.server 中 Deprecated 的使用

注释类型为 Deprecated 的 java.rmi.server 中的类
interface | LoaderHandler 已过时。 无替代版本
class | LogStream 已过时。 无替代版本
class | Operation 已过时。 无替代版本
interface | RemoteCall 已过时。 无替代版本。
interface | Skeleton 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。

注释类型为 Deprecated 的 java.rmi.server 中的方法
 void Skeleton.dispatch(Remote obj, RemoteCall theCall, int opnum, long hash)
已过时。 无替代版本
 void RemoteCall.done()
已过时。 无替代版本
 void RemoteRef.done(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
 void RemoteCall.executeCall()
已过时。 无替代版本
static PrintStream LogStream.getDefaultStream()
已过时。 无替代版本
 ObjectInput RemoteCall.getInputStream()
已过时。 无替代版本
 String Operation.getOperation()
已过时。 无替代版本
 Operation[] Skeleton.getOperations()
已过时。 无替代版本
 OutputStream LogStream.getOutputStream()
已过时。 无替代版本
 ObjectOutput RemoteCall.getOutputStream()
已过时。 无替代版本
 ObjectOutput RemoteCall.getResultStream(boolean success)
已过时。 无替代版本
 Object LoaderHandler.getSecurityContext(ClassLoader loader)
已过时。 无替代版本
static Object RMIClassLoader.getSecurityContext(ClassLoader loader)
已过时。 无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。
 void RemoteRef.invoke(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
 Class<?> LoaderHandler.loadClass(String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(String name)
已过时。 由 loadClass(String,String) 方法取代
 Class<?> LoaderHandler.loadClass(URL codebase, String name)
已过时。 无替代版本
static LogStream LogStream.log(String name)
已过时。 无替代版本
 RemoteCall RemoteRef.newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。
static int LogStream.parseLevel(String s)
已过时。 无替代版本
 void RemoteCall.releaseInputStream()
已过时。 无替代版本
 void RemoteCall.releaseOutputStream()
已过时。 无替代版本
static void LogStream.setDefaultStream(PrintStream newDefault)
已过时。 无替代版本
 void LogStream.setOutputStream(OutputStream out)
已过时。 无替代版本
protected static void RemoteStub.setRef(RemoteStub stub, RemoteRef ref)
已过时。 无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。
 String LogStream.toString()
已过时。 无替代版本
 String Operation.toString()
已过时。 无替代版本
 void LogStream.write(byte[] b, int off, int len)
已过时。 无替代版本
 void LogStream.write(int b)
已过时。 无替代版本

注释类型为 Deprecated 的 java.rmi.server 中的构造方法
Operation(String op)
已过时。 无替代版本
SkeletonMismatchException(String s)
已过时。 无替代版本

java.security 中 Deprecated 的使用

注释类型为 Deprecated 的 java.security 中的类
interface | Certificate 已过时。 在 Java 平台中创建了新的证书处理包。此 Certificate 接口已完全废弃，其仍存在是为了能平稳地过渡到新包。
class | Identity 已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | IdentityScope 已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | Signer 已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。

注释类型为 Deprecated 的 java.security 中的方法
protected abstract Object | SignatureSpi.engineGetParameter(String param) 已过时。
protected abstract void | SignatureSpi.engineSetParameter(String param, Object value) 已过时。 由 engineSetParameter 取代。
static String | Security.getAlgorithmProperty(String algName, String propName) 已过时。 此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。
Object | Signature.getParameter(String param) 已过时。
void | Signature.setParameter(String param, Object value) 已过时。 使用 setParameter 取代。

java.sql 中 Deprecated 的使用

注释类型为 Deprecated 的 java.sql 中的方法
int | Time.getDate() 已过时。
int | Time.getDay() 已过时。
int | Time.getMonth() 已过时。
int | Time.getYear() 已过时。
void | Time.setDate(int i) 已过时。
void | Time.setMonth(int i) 已过时。
void | Time.setYear(int i) 已过时。

注释类型为 Deprecated 的 java.sql 中的构造方法
Time(int hour, int minute, int second)
已过时。 使用采用毫秒值的构造方法取代此构造方法
Timestamp(int year, int month, int date, int hour, int minute, int second, int nano)
已过时。 使用构造方法 Timestamp(long millis) 来代替

java.util 中 Deprecated 的使用

注释类型为 Deprecated 的 java.util 中的方法
 int Date.getDate()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_MONTH) 取代。
 int Date.getDay()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_WEEK) 取代。
 int Date.getHours()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.HOUR_OF_DAY) 取代。
 int Date.getMinutes()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MINUTE) 取代。
 int Date.getMonth()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MONTH) 取代。
 int Date.getSeconds()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.SECOND) 取代。
 int Date.getTimezoneOffset()
已过时。 从 JDK 1.1 开始，由 -(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000) 取代。
 int Date.getYear()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.YEAR) - 1900 取代。
static long Date.parse(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。
 void Properties.save(OutputStream out, String comments)
已过时。 如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。
 void Date.setDate(int date)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.DAY_OF_MONTH, int date) 取代。
 void Date.setHours(int hours)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.HOUR_OF_DAY, int hours) 取代。
 void Date.setMinutes(int minutes)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MINUTE, int minutes) 取代。
 void Date.setMonth(int month)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MONTH, int month) 取代。
 void Date.setSeconds(int seconds)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.SECOND, int seconds) 取代。
 void Date.setYear(int year)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.YEAR, year + 1900) 取代。
 String Date.toGMTString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代，使用 GMT TimeZone。
 String Date.toLocaleString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代。
static long Date.UTC(int year, int month, int date, int hrs, int min, int sec)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代，使用 UTC TimeZone，后跟 Calendar.getTime().getTime()。

注释类型为 Deprecated 的 java.util 中的构造方法
Date(int year, int month, int date)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date) 或 GregorianCalendar(year + 1900, month, date) 取代。
Date(int year, int month, int date, int hrs, int min)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min) 或 GregorianCalendar(year + 1900, month, date, hrs, min) 取代。
Date(int year, int month, int date, int hrs, int min, int sec)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代。
Date(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。

java.util.logging 中 Deprecated 的使用

注释类型为 Deprecated 的 java.util.logging 中的字段
static Logger Logger.global
已过时。 此字段的初始化会容易出现死锁。必须由 Logger 类初始化来初始化字段，这可能会导致 LogManager 类初始化的死锁。在这种情况下，两个类初始化都要等待对方完成。从 JDK version 1.6 开始，获取全局 logger 对象的首选方法是通过调用 Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)。

javax.accessibility 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.accessibility 中的类
 class AccessibleResourceBundle
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。

javax.jws.soap 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.jws.soap 中的类
interface | InitParam 已过时。 从 JSR-181 2.0 开始，无替代版本。
interface | SOAPMessageHandler 已过时。 从 JSR-181 2.0 开始，无替代版本。
interface | SOAPMessageHandlers 已过时。 从 JSR-181 2.0 开始，无替代版本。

javax.management 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.management 中的类
 class DefaultLoaderRepository
已过时。 使用 MBeanServer.getClassLoaderRepository() 取代。

注释类型为 Deprecated 的 javax.management 中的方法
 ObjectInputStream MBeanServer.deserialize(ObjectName name, byte[] data)
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
 ObjectInputStream MBeanServer.deserialize(String className, byte[] data)
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
 ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。
 void ValueExp.setMBeanServer(MBeanServer s)
已过时。 不再需要此方法，因为 ValueExp 可以通过使用 QueryEval.getMBeanServer() 来访问它将在其中进行计算的 MBean 服务器。

注释类型为 Deprecated 的 javax.management 中的构造方法
AttributeValueExp()
已过时。 在查询中不能使用此构造方法所创建的实例。

javax.management.loading 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.management.loading 中的类
 class DefaultLoaderRepository
已过时。 使用 MBeanServer.getClassLoaderRepository()} 替代。

javax.management.monitor 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.management.monitor 中的字段
protected int | Monitor.alreadyNotified 已过时。 等效于 Monitor.alreadyNotifieds[0]。
protected String | Monitor.dbgTag 已过时。 无替代版本。

注释类型为 Deprecated 的 javax.management.monitor 中的方法
 Number CounterMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getDerivedGauge(ObjectName) 取代
 Number CounterMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGauge(ObjectName) 取代
 Number GaugeMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGauge(ObjectName) 取代
 Number GaugeMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGauge(ObjectName) 取代
 String StringMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 StringMonitor.getDerivedGauge(ObjectName) 取代
 String StringMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGauge(ObjectName) 取代
 long CounterMonitor.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
 long CounterMonitorMBean.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
 long GaugeMonitor.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
 long GaugeMonitorMBean.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
 long StringMonitor.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 StringMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
 long StringMonitorMBean.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
 ObjectName Monitor.getObservedObject()
已过时。 从 JMX 1.2 开始，由 Monitor.getObservedObjects() 取代
 ObjectName MonitorMBean.getObservedObject()
已过时。 从 JMX 1.2 开始，由 MonitorMBean.getObservedObjects() 取代
 Number CounterMonitor.getThreshold()
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getThreshold(ObjectName) 取代
 Number CounterMonitorMBean.getThreshold()
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getThreshold(ObjectName) 取代
 void Monitor.setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 Monitor.addObservedObject(javax.management.ObjectName) 取代
 void MonitorMBean.setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 MonitorMBean.addObservedObject(javax.management.ObjectName) 取代
 void CounterMonitor.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitor.setInitThreshold(java.lang.Number) 取代
 void CounterMonitorMBean.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.setInitThreshold(java.lang.Number) 取代

javax.management.openmbean 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.management.openmbean 中的字段
static String[] OpenType.ALLOWED_CLASSNAMES
已过时。 使用 ALLOWED_CLASSNAMES_LIST 取代。

javax.security.auth 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.security.auth 中的类
 class Policy
已过时。 从 JDK 1.4 版本开始，由 java.security.Policy 取代。java.security.Policy 有一个方法：
        public PermissionCollection getPermissions
            (java.security.ProtectionDomain pd)
ProtectionDomain 有一个构造方法：
        public ProtectionDomain
            (CodeSource cs,
             PermissionCollection permissions,
             ClassLoader loader,
             Principal[] principals)
这两个 API 为调用者提供向 Policy 查询基于 Principal 的 Permission 条目的方法。

javax.swing 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing 中的字段
protected boolean | JViewport.backingStore 已过时。 从 Java 2 平台 v1.3 开始
protected javax.swing.JRootPane.DefaultAction | JRootPane.defaultPressAction 已过时。 从 Java 2 platform v1.3 开始
protected javax.swing.JRootPane.DefaultAction | JRootPane.defaultReleaseAction 已过时。 从 Java 2 platform v1.3 开始

注释类型为 Deprecated 的 javax.swing 中的方法
static JScrollPane JTable.createScrollPaneForTable(JTable aTable)
已过时。 从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。
 void JComponent.disable()
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
static void FocusManager.disableSwingFocusManager()
已过时。 从 1.4 开始，由 KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy) 取代
 void JComponent.enable()
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
static Component SwingUtilities.findFocusOwner(Component c)
已过时。 从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。
 Component JPopupMenu.getComponentAtIndex(int i)
已过时。 由 Container.getComponent(int) 取代
 Component JMenuBar.getComponentAtIndex(int i)
已过时。 由 getComponent(int i) 取代
static KeyStroke KeyStroke.getKeyStroke(char keyChar, boolean onKeyRelease)
已过时。 使用 getKeyStroke(char)
 String AbstractButton.getLabel()
已过时。 - 由 getText 取代
 JMenuBar JInternalFrame.getMenuBar()
已过时。 从 Swing version 1.0.3 开始，由 getJMenuBar() 取代。
 JMenuBar JRootPane.getMenuBar()
已过时。 从 Swing 版本 1.0.3 开始，由 getJMenuBar() 取代。
 Component JComponent.getNextFocusableComponent()
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代。
 String JPasswordField.getText()
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。
 String JPasswordField.getText(int offs, int len)
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。
 Rectangle ScrollPaneLayout.getViewportBorderBounds(JScrollPane scrollpane)
已过时。 从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。
 boolean JViewport.isBackingStoreEnabled()
已过时。 从 Java 2 平台 1.3 版开始，由 getScrollMode() 取代。
static boolean FocusManager.isFocusManagerEnabled()
已过时。 从 1.4 开始，由 KeyboardFocusManager.getDefaultFocusTraversalPolicy() 取代
 boolean JComponent.isManagingFocus()
已过时。 从 1.4 版本开始，由 Component.setFocusTraversalKeys(int, Set) 和 Container.setFocusCycleRoot(boolean) 取代。
 boolean JComponent.requestDefaultFocus()
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy.getDefaultComponent(Container).requestFocus() 取代
 void JComponent.reshape(int x, int y, int w, int h)
已过时。 从 JDK 5 开始，由 Component.setBounds(int, int, int, int) 取代。

移动此组件并调整其大小。

 void JViewport.setBackingStoreEnabled(boolean enabled)
已过时。 从 Java 2 平台 1.3 版开始，由 setScrollMode() 取代。
 void AbstractButton.setLabel(String label)
已过时。 - 由 setText(text) 取代
 void JInternalFrame.setMenuBar(JMenuBar m)
已过时。 从 Swing version 1.0.3 开始，由 setJMenuBar(JMenuBar m) 取代。
 void JRootPane.setMenuBar(JMenuBar menu)
已过时。 从 Swing 版本 1.0.3 开始，由 setJMenuBar(JMenuBar menu) 取代。
 void JComponent.setNextFocusableComponent(Component aComponent)
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代
 void JTable.sizeColumnsToFit(boolean lastColumnOnly)
已过时。 从 Swing version 1.0.3 开始，由 doLayout() 取代。

javax.swing.plaf.basic 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing.plaf.basic 中的字段
protected KeyStroke | BasicDesktopPaneUI.closeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicSplitPaneUI.dividerResizeToggleKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.downKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.downKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.downKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.endKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.homeKey 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardDownRightListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardEndListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardHomeListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardResizeToggleListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardUpLeftListener 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.leftKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.leftKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.leftKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.maximizeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.minimizeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.navigateKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.navigateKey2 已过时。 从 1.3 开始。
protected KeyStroke | BasicInternalFrameUI.openMenuKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.rightKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.rightKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.rightKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.upKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.upKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.upKey 已过时。 从 Java 2 平台 v1.3 开始。

注释类型为 Deprecated 的 javax.swing.plaf.basic 中的方法
protected ActionListener | BasicSplitPaneUI.createKeyboardDownRightListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardEndListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardHomeListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardResizeToggleListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardUpLeftListener() 已过时。 从 Java 2 platform v1.3 开始。
protected int | BasicSplitPaneUI.getDividerBorderSize() 已过时。 从 Java 2 平台 v1.3 开始，由在分隔符上设置边框取代。

javax.swing.plaf.metal 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing.plaf.metal 中的类
 class MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

注释类型为 Deprecated 的 javax.swing.plaf.metal 中的方法
protected void | MetalComboBoxUI.editablePropertyChanged(PropertyChangeEvent e) 已过时。 从 Java 2 platform v1.4 开始。
protected void | MetalComboBoxUI.removeListeners() 已过时。 从 Java 2 platform v1.4 开始。

javax.swing.table 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing.table 中的字段
protected  int TableColumn.resizedPostingDisableCount
已过时。 从 Java 2 platform v1.3 开始

注释类型为 Deprecated 的 javax.swing.table 中的方法
void | TableColumn.disableResizedPosting() 已过时。 从 Java 2 platform v1.3 开始
void | TableColumn.enableResizedPosting() 已过时。 从 Java 2 platform v1.3 开始

javax.swing.text 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing.text 中的类
class | DefaultTextUI 已过时。
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。

注释类型为 Deprecated 的 javax.swing.text 中的方法
protected TableView.TableCell | TableView.createTableCell(Element elem) 已过时。 现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。
protected FontMetrics | LabelView.getFontMetrics() 已过时。 FontMetrics 不用于在 JDK 中运行时的字形呈现。
Shape | View.modelToView(int pos, Shape a) 已过时。
int | View.viewToModel(float x, float y, Shape a) 已过时。

javax.swing.text.html 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing.text.html 中的字段
static String | FormView.RESET 已过时。 从 1.3 开始，将使用来自 UIManager UIManager property FormView.resetButtonText 的值
static String | FormView.SUBMIT 已过时。 从 1.3 开始，将使用来自 UIManager property FormView.submitButtonText 的值

注释类型为 Deprecated 的 javax.swing.text.html 中的方法
protected  void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary

org.omg.CORBA 中 Deprecated 的使用

注释类型为 Deprecated 的 org.omg.CORBA 中的类
class | DynamicImplementation 已过时。 org.omg.CORBA.DynamicImplementation
interface | DynAny 已过时。 使用新的 DynAny 替代
interface | DynArray 已过时。 使用新的 DynArray 替代
interface | DynEnum 已过时。 使用新的 DynEnum 替代
interface | DynFixed 已过时。 使用新的 DynFixed 替代
interface | DynSequence 已过时。 使用新的 DynSequence 替代
interface | DynStruct 已过时。 使用新的 DynStruct 替代
interface | DynUnion 已过时。 使用新的 DynUnion 替代
interface | DynValue 已过时。 使用新的 DynValue 替代
class | Principal 已过时。 已由 CORBA 2.2 取代。
class | PrincipalHolder 已过时。 Deprecated by CORBA 2.2.

注释类型为 Deprecated 的 org.omg.CORBA 中的方法
 DynAny ORB.create_basic_dyn_any(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
 DynAny ORB.create_dyn_any(Any value)
已过时。 使用新的 DynAnyFactory API 代替
 DynArray ORB.create_dyn_array(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
 DynEnum ORB.create_dyn_enum(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
 DynSequence ORB.create_dyn_sequence(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
 DynStruct ORB.create_dyn_struct(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
 DynUnion ORB.create_dyn_union(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
abstract  TypeCode ORB.create_recursive_sequence_tc(int bound, int offset)
已过时。 使用 create_recursive_tc 和 create_sequence_tc 的组合替代它
 void ServerRequest.except(Any any)
已过时。 使用 set_exception()
 Principal Any.extract_Principal()
已过时。 由 CORBA 2.2 取代。
 Current ORB.get_current()
已过时。 使用 resolve_initial_references。
 void Any.insert_Principal(Principal p)
已过时。 由 CORBA 2.2 取代。
 void DynamicImplementation.invoke(ServerRequest request)
已过时。 由 Portable Object Adapter 取代
 byte[] Principal.name()
已过时。 已由 CORBA 2.2 取代。
 void Principal.name(byte[] value)
已过时。 已由 CORBA 2.2 取代。
 String ServerRequest.op_name()
已过时。 使用 operation()
 void ServerRequest.params(NVList params)
已过时。 使用方法 arguments
 void ServerRequest.result(Any any)
已过时。 使用方法 set_result

注释类型为 Deprecated 的 org.omg.CORBA 中的构造方法
TCKind(int _value)
已过时。 不要使用此构造方法，因为根据 OMG 规范，此方法应该是私有的。使用 TCKind.from_int(int) 代替。

org.omg.CORBA.portable 中 Deprecated 的使用

注释类型为 Deprecated 的 org.omg.CORBA.portable 中的方法
Principal | InputStream.read_Principal() 已过时。 已由 CORBA 2.2 取代。
void | OutputStream.write_Principal(Principal value) 已过时。 已由 CORBA 2.2 取代。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Double
的使用

使用 Double 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang 中 Double 的使用

类型参数类型为 Double 的 java.lang 中的字段
static Class<Double> Double.TYPE
表示基本类型 double 的 Class 实例。

返回 Double 的 java.lang 中的方法
static Double | Double.valueOf(double d) 返回表示指定的 double 值的 Double 实例。
static Double | Double.valueOf(String s) 返回保存用参数字符串 s 表示的 double 值的 Double 对象。

参数类型为 Double 的 java.lang 中的方法
 int Double.compareTo(Double anotherDouble)
对两个 Double 对象所表示的数值进行比较。

javax.management.openmbean 中 Double 的使用

类型参数类型为 Double 的 javax.management.openmbean 中的字段
static SimpleType<Double> SimpleType.DOUBLE
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Double 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Enum 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Enum
的使用

使用 Enum 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.lang 中 Enum 的使用

类型参数类型为 Enum 的 java.lang 中的类
 class Enum<E extends Enum<E>>
这是所有 Java 语言枚举类型的公共基本类。

类型参数类型为 Enum 的 java.lang 中的方法
static
<T extends Enum<T>>
T
Enum.valueOf(Class<T> enumType, String name)
返回带指定名称的指定枚举类型的枚举常量。

返回变量类型为 Enum 的类型的 java.lang 中的方法
 Class<? extends Enum> EnumConstantNotPresentException.enumType()
返回缺少的枚举常量的类型。

类型变量类型为 Enum 的 java.lang 中的构造方法参数
EnumConstantNotPresentException(Class<? extends Enum> enumType, String constantName)
为指定常量构造一个 EnumConstantNotPresentException。

java.util 中 Enum 的使用

类型参数类型为 Enum 的 java.util 中的类
class | EnumMap<K extends Enum<K>,V> 与枚举类型键一起使用的专用 Map 实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。

类型参数类型为 Enum 的 java.util 中的方法
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.allOf(Class<E> elementType)
创建一个包含指定元素类型的所有元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.complementOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含指定 set 中所不 包含的此类型的所有元素。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(Collection<E> c)
创建一个从指定 collection 初始化的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含相同的元素（如果有的话）。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.noneOf(Class<E> elementType)
创建一个具有指定元素类型的空枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E first, E... rest)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3, E e4)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3, E e4, E e5)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.range(E from, E to)
创建一个最初包含由两个指定端点所定义范围内的所有元素的枚举 set。

参数类型为 Enum 的 java.util 中的方法
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E first, E... rest)
创建一个最初包含指定元素的枚举 set。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.EnumConstantNotPresentException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.EnumConstantNotPresentException
的使用

没有 java.lang.EnumConstantNotPresentException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Error 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Error
的使用

使用 Error 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

java.awt 中 Error 的使用

java.awt 中 Error 的子类
 class AWTError
当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。

java.io 中 Error 的使用

java.io 中 Error 的子类
 class IOError
当发生严重的 I/O 错误时，抛出此错误。

java.lang 中 Error 的使用

java.lang 中 Error 的子类
class | AbstractMethodError 当应用程序试图调用一个抽象方法时，抛出此错误。
class | AssertionError 抛出该异常指示某个断言失败。
class | ClassCircularityError 当初始化类时检测到类的循环调用的时候，抛出该错误。
class | ClassFormatError 当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
class | ExceptionInInitializerError 静态初始化程序中发生意外异常的信号。
class | IllegalAccessError 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
class | IncompatibleClassChangeError 在某些类定义中出现不兼容的类更改时抛出该异常。
class | InstantiationError 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
class | InternalError 该异常指示 Java 虚拟机中出现一些意外的内部错误。
class | LinkageError LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
class | NoClassDefFoundError 当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
class | NoSuchFieldError 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
class | NoSuchMethodError 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
class | OutOfMemoryError 因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
class | StackOverflowError 当应用程序递归太深而发生堆栈溢出时，抛出该错误。
class | ThreadDeath 调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。
class | UnknownError 当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。
class | UnsatisfiedLinkError 当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
class | UnsupportedClassVersionError 当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
class | VerifyError 当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。
class | VirtualMachineError 当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

java.lang.annotation 中 Error 的使用

java.lang.annotation 中 Error 的子类
 class AnnotationFormatError
当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。

java.lang.reflect 中 Error 的使用

java.lang.reflect 中 Error 的子类
 class GenericSignatureFormatError
当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。

java.nio.charset 中 Error 的使用

java.nio.charset 中 Error 的子类
 class CoderMalfunctionError
当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。

java.rmi 中 Error 的使用

参数类型为 Error 的 java.rmi 中的构造方法
ServerError(String s, Error err)
构造带指定详细消息和嵌入错误的 ServerError。

java.util 中 Error 的使用

java.util 中 Error 的子类
 class ServiceConfigurationError
在加载服务提供者的过程中出错时抛出的错误。

java.util.zip 中 Error 的使用

java.util.zip 中 Error 的子类
 class ZipError
发生不可恢复的错误时抛出。

javax.management 中 Error 的使用

返回 Error 的 javax.management 中的方法
 Error RuntimeErrorException.getTargetError()
返回抛出的实际 Error。

参数类型为 Error 的 javax.management 中的构造方法
RuntimeErrorException(Error e)
默认的构造方法。
RuntimeErrorException(Error e, String message)
允许指定特定错误消息的构造方法。

javax.management.remote 中 Error 的使用

参数类型为 Error 的 javax.management.remote 中的构造方法
JMXServerErrorException(String s, Error err)
构造带指定详细消息和嵌套错误的 JMXServerErrorException。

javax.xml.parsers 中 Error 的使用

javax.xml.parsers 中 Error 的子类
 class FactoryConfigurationError
当解析器工厂的配置存在问题时抛出该异常。

javax.xml.transform 中 Error 的使用

javax.xml.transform 中 Error 的子类
 class TransformerFactoryConfigurationError
当通过 Transformer Factories 进行的配置存在问题时抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Exception 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Exception
的使用

使用 Exception 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.cert | 为公钥证书提供类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。

java.awt 中 Exception 的使用

java.awt 中 Exception 的子类
class | AWTException 表示发生了 Absract Window Toolkit 异常。
class | FontFormatException 此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。
class | HeadlessException 在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
class | IllegalComponentStateException 当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

java.awt.color 中 Exception 的使用

java.awt.color 中 Exception 的子类
class | CMMException 如果本机 CMM 返回一个错误，则抛出此异常。
class | ProfileDataException 当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

java.awt.datatransfer 中 Exception 的使用

java.awt.datatransfer 中 Exception 的子类
class | MimeTypeParseException 对分析相关异常的 MimeType 进行封装的类
class | UnsupportedFlavorException 在此 flavor 中不支持所请求的数据的信号。

java.awt.dnd 中 Exception 的使用

java.awt.dnd 中 Exception 的子类
 class InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

java.awt.event 中 Exception 的使用

返回 Exception 的 java.awt.event 中的方法
 Exception InvocationEvent.getException()
返回在执行 Runnable 的 run() 方法时捕获的任何 Exception。

java.awt.geom 中 Exception 的使用

java.awt.geom 中 Exception 的子类
class | IllegalPathStateException 对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。
class | NoninvertibleTransformException NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。

java.awt.im.spi 中 Exception 的使用

抛出 Exception 的 java.awt.im.spi 中的方法
 InputMethod InputMethodDescriptor.createInputMethod()
创建相应输入方法的新实例。

java.awt.image 中 Exception 的使用

java.awt.image 中 Exception 的子类
class | ImagingOpException 如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
class | RasterFormatException 如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

java.awt.print 中 Exception 的使用

java.awt.print 中 Exception 的子类
class | PrinterAbortException PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
class | PrinterException PrinterException 类及其子类用于指示打印系统中发生的异常情况。
class | PrinterIOException PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

java.beans 中 Exception 的使用

java.beans 中 Exception 的子类
class | IntrospectionException 在 Introspection 期间发生异常时抛出异常。
class | PropertyVetoException 当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。

参数类型为 Exception 的 java.beans 中的方法
 void ExceptionListener.exceptionThrown(Exception e)
此方法在捕获可恢复的异常时调用。

抛出 Exception 的 java.beans 中的方法
void | Statement.execute() 执行方法找到一个与 methodName 属性同名的方法，并在目标上调用该方法。
Object | Expression.getValue() 如果此实例的 value 属性尚未设置，则此方法利用这些参数，在此目标上动态查找具有指定 methodName 的方法，并调用该方法。

java.io 中 Exception 的使用

java.io 中 Exception 的子类
class | CharConversionException 用于字符转换异常的基类。
class | EOFException 当输入过程中意外到达文件或流的末尾时，抛出此异常。
class | FileNotFoundException 当试图打开指定路径名表示的文件失败时，抛出此异常。
class | InterruptedIOException I/O 操作已中断信号，抛出此异常。
class | InvalidClassException 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
class | InvalidObjectException 指示一个或多个反序列化对象未通过验证测试。
class | IOException 当发生某种 I/O 异常时，抛出此异常。
class | NotActiveException 当序列化和反序列化不活动时，抛出此异常。
class | NotSerializableException 当实例需要具有序列化接口时，抛出此异常。
class | ObjectStreamException 特定于 Object Stream 类的所有异常的超类。
class | OptionalDataException 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
class | StreamCorruptedException 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
class | SyncFailedException 当 sync 操作失败时，抛出此异常。
class | UnsupportedEncodingException 不支持字符编码。
class | UTFDataFormatException 在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
class | WriteAbortedException 在写入操作过程中抛出 ObjectStreamException 之一的信号。

声明为 Exception 的 java.io 中的字段
 Exception WriteAbortedException.detail
在写入 ObjectStream 时捕获的异常。

参数类型为 Exception 的 java.io 中的构造方法
WriteAbortedException(String s, Exception ex)
使用描述该异常的字符串和导致中止的异常构造一个 WriteAbortedException。

java.lang 中 Exception 的使用

java.lang 中 Exception 的子类
class | ArithmeticException 当出现异常的运算条件时，抛出此异常。
class | ArrayIndexOutOfBoundsException 用非法索引访问数组时抛出的异常。
class | ArrayStoreException 试图将错误类型的对象存储到一个对象数组时抛出的异常。
class | ClassCastException 当试图将对象强制转换为不是实例的子类时，抛出该异常。
class | ClassNotFoundException 当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
class | CloneNotSupportedException 当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
class | EnumConstantNotPresentException 当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
class | IllegalAccessException 当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
class | IllegalArgumentException 抛出的异常表明向方法传递了一个不合法或不正确的参数。
class | IllegalMonitorStateException 抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
class | IllegalStateException 在非法或不适当的时间调用方法时产生的信号。
class | IllegalThreadStateException 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
class | IndexOutOfBoundsException 指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
class | InstantiationException 当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
class | InterruptedException 当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
class | NegativeArraySizeException 如果应用程序试图创建大小为负的数组，则抛出该异常。
class | NoSuchFieldException 类不包含指定名称的字段时产生的信号。
class | NoSuchMethodException 无法找到某一特定方法时，抛出该异常。
class | NullPointerException 当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
class | NumberFormatException 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
class | RuntimeException RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
class | SecurityException 由安全管理器抛出的异常，指示存在安全侵犯。
class | StringIndexOutOfBoundsException 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
class | TypeNotPresentException 当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
class | UnsupportedOperationException 当不支持请求的操作时，抛出该异常。

java.lang.annotation 中 Exception 的使用

java.lang.annotation 中 Exception 的子类
class | AnnotationTypeMismatchException 若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
class | IncompleteAnnotationException 若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。

java.lang.instrument 中 Exception 的使用

java.lang.instrument 中 Exception 的子类
class | IllegalClassFormatException 当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。
class | UnmodifiableClassException 在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

java.lang.reflect 中 Exception 的使用

java.lang.reflect 中 Exception 的子类
class | InvocationTargetException InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。
class | MalformedParameterizedTypeException 当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
class | UndeclaredThrowableException 如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

java.net 中 Exception 的使用

java.net 中 Exception 的子类
class | BindException 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
class | HttpRetryException 抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
class | MalformedURLException 抛出这一异常指示出现了错误的 URL。
class | NoRouteToHostException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | PortUnreachableException 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
class | ProtocolException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketTimeoutException 如果在读取或接受套接字时发生超时，则抛出此异常。
class | UnknownHostException 指示主机 IP 地址无法确定而抛出的异常。
class | UnknownServiceException 抛出这一异常指示出现了未知服务异常。
class | URISyntaxException 抛出经过检查的指示字符串不能解析为 URI 引用的异常。

java.nio 中 Exception 的使用

java.nio 中 Exception 的子类
class | BufferOverflowException 当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
class | BufferUnderflowException 当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
class | InvalidMarkException 当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
class | ReadOnlyBufferException 当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

java.nio.channels 中 Exception 的使用

java.nio.channels 中 Exception 的子类
class | AlreadyConnectedException 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
class | AsynchronousCloseException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
class | CancelledKeyException 当试图使用不再有效的选择键时，抛出此未经检查的异常。
class | ClosedByInterruptException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
class | ClosedChannelException 当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
class | ClosedSelectorException 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
class | ConnectionPendingException 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
class | FileLockInterruptionException 当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。
class | IllegalBlockingModeException 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
class | IllegalSelectorException 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
class | NoConnectionPendingException 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
class | NonReadableChannelException 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
class | NonWritableChannelException 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
class | NotYetBoundException 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | NotYetConnectedException 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | OverlappingFileLockException 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
class | UnresolvedAddressException 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
class | UnsupportedAddressTypeException 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

java.nio.charset 中 Exception 的使用

java.nio.charset 中 Exception 的子类
class | CharacterCodingException 出现字符编码或解码错误时，抛出此经过检查的异常。
class | IllegalCharsetNameException 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
class | MalformedInputException 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
class | UnmappableCharacterException 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。
class | UnsupportedCharsetException 当不支持请求的 charset 时，抛出此未经检查的异常。

参数类型为 Exception 的 java.nio.charset 中的构造方法
CoderMalfunctionError(Exception cause)
初始化此类的一个实例。

java.rmi 中 Exception 的使用

java.rmi 中 Exception 的子类
class | AccessException AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
class | AlreadyBoundException 如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
class | ConnectException 如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
class | ConnectIOException 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
class | NoSuchObjectException 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
class | NotBoundException 如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
class | RemoteException RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
class | RMISecurityException 已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
class | ServerError 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
class | ServerException 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
class | ServerRuntimeException 已过时。 无替换版本
class | StubNotFoundException 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
class | UnexpectedException 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
class | UnmarshalException 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

参数类型为 Exception 的 java.rmi 中的构造方法
AccessException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 AccessException。
ConnectException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ConnectException。
ConnectIOException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ConnectIOException。
MarshalException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 MarshalException。
ServerException(String s, Exception ex)
构造带有指定详细消息和嵌入异常的 ServerException。
ServerRuntimeException(String s, Exception ex)
已过时。 无替换版本
StubNotFoundException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 StubNotFoundException。
UnexpectedException(String s, Exception ex)
构造带有指定详细消息和嵌入异常的 UnexpectedException。
UnknownHostException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 UnknownHostException。
UnmarshalException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 UnmarshalException。

java.rmi.activation 中 Exception 的使用

java.rmi.activation 中 Exception 的子类
class | ActivateFailedException 在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。
class | ActivationException 激活接口所使用的一般异常。
class | UnknownGroupException 当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
class | UnknownObjectException 当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

参数类型为 Exception 的 java.rmi.activation 中的构造方法
ActivateFailedException(String s, Exception ex)
构造带指定详细消息和嵌套异常的 ActivateFailedException。

java.rmi.server 中 Exception 的使用

java.rmi.server 中 Exception 的子类
class | ExportException ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
class | ServerCloneException 如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。
class | ServerNotActiveException 如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SocketSecurityException 已废弃的 ExportException 的子类。

声明为 Exception 的 java.rmi.server 中的字段
 Exception ServerCloneException.detail
异常原因。

参数类型为 Exception 的 java.rmi.server 中的方法
 boolean RMIFailureHandler.failure(Exception ex)
在 RMI 运行时无法通过 RMISocketFactory 创建 ServerSocket 时调用该 failure 回调。

抛出 Exception 的 java.rmi.server 中的方法
 void Skeleton.dispatch(Remote obj, RemoteCall theCall, int opnum, long hash)
已过时。 无替代版本
 void RemoteCall.executeCall()
已过时。 无替代版本
 void RemoteRef.invoke(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
 Object RemoteRef.invoke(Remote obj, Method method, Object[] params, long opnum)
调用某个方法。

参数类型为 Exception 的 java.rmi.server 中的构造方法
ExportException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ExportException。
ServerCloneException(String s, Exception cause)
构造带指定详细消息和原因的 ServerCloneException。
SkeletonNotFoundException(String s, Exception ex)
已过时。 构造带指定详细消息和嵌套异常的 SkeletonNotFoundException。
SocketSecurityException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 SocketSecurityIOException。

java.security 中 Exception 的使用

java.security 中 Exception 的子类
class | AccessControlException 此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
class | DigestException 此为一般 Message Digest 异常。
class | GeneralSecurityException GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
class | InvalidAlgorithmParameterException 用于无效或不合适的算法参数的异常。
class | InvalidKeyException 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
class | InvalidParameterException 当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
class | KeyException 此异常是基本的密钥异常。
class | KeyManagementException 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
class | KeyStoreException 这是一般的 KeyStore 异常。
class | NoSuchAlgorithmException 当请求特定的加密算法而它在该环境中不可用时抛出此异常。
class | NoSuchProviderException 当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
class | PrivilegedActionException doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
class | ProviderException 用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。
class | SignatureException 这是一般的签名异常。
class | UnrecoverableEntryException 如果 keystore 中的某项无法恢复，则抛出此异常。
class | UnrecoverableKeyException 如果 keystore 中的密钥无法恢复，则抛出此异常。

返回 Exception 的 java.security 中的方法
 Exception PrivilegedActionException.getException()
返回特权计算抛出的异常，该异常导致此 PrivilegedActionException。

抛出 Exception 的 java.security 中的方法
 T PrivilegedExceptionAction.run()
执行计算。

参数类型为 Exception 的 java.security 中的构造方法
PrivilegedActionException(Exception exception)
构造一个新的“包装”指定 Exception 的 PrivilegedActionException。

java.security.acl 中 Exception 的使用

java.security.acl 中 Exception 的子类
class | AclNotFoundException 如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。
class | LastOwnerException 如果试图删除访问控制列表的最后一个所有者，则抛出此异常。
class | NotOwnerException 当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。

java.security.cert 中 Exception 的使用

java.security.cert 中 Exception 的子类
class | CertPathBuilderException 指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
class | CertPathValidatorException 指示在验证一个证书路径时遇到了某种问题的异常。
class | CertStoreException 指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
class | CRLException CRL（证书撤消列表）异常。

java.security.spec 中 Exception 的使用

java.security.spec 中 Exception 的子类
class | InvalidKeySpecException 这是针对无效密钥规范的异常。
class | InvalidParameterSpecException 这是针对无效参数规范的异常。

java.sql 中 Exception 的使用

java.sql 中 Exception 的子类
class | BatchUpdateException 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
class | DataTruncation 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
class | SQLClientInfoException 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLException 提供关于数据库访问错误或其他错误信息的异常。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLNonTransientException 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
class | SQLRecoverableException 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
class | SQLTransientException 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
class | SQLWarning 提供关于数据库访问警告信息的异常。

java.text 中 Exception 的使用

java.text 中 Exception 的子类
 class ParseException
表示解析时出现意外错误。

java.util 中 Exception 的使用

java.util 中 Exception 的子类
class | ConcurrentModificationException 当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | EmptyStackException 该异常由 Stack 类中的方法抛出，以表明堆栈为空。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
class | FormatterClosedException 格式器已关闭时抛出的未经检查的异常。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatException 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | InputMismatchException 由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
class | InvalidPropertiesFormatException 当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | MissingResourceException 缺少资源时抛出此异常。
class | NoSuchElementException 由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
class | TooManyListenersException TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。

java.util.concurrent 中 Exception 的使用

java.util.concurrent 中 Exception 的子类
class | BrokenBarrierException 当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。
class | CancellationException 如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
class | ExecutionException 当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
class | RejectedExecutionException 当无法执行某个任务时,由 Executor 抛出的异常。
class | TimeoutException 阻塞操作超时时，抛出该异常。

抛出 Exception 的 java.util.concurrent 中的方法
 V Callable.call()
计算结果，如果无法计算结果，则抛出一个异常。

java.util.jar 中 Exception 的使用

java.util.jar 中 Exception 的子类
 class JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

java.util.logging 中 Exception 的使用

参数类型为 Exception 的 java.util.logging 中的方法
void | ErrorManager.error(String msg, Exception ex, int code) 在发生 Handler 失败时调用 error 方法。
protected void | Handler.reportError(String msg, Exception ex, int code) 用于向该 Handler 的 ErrorManager 报告错误的受保护便利方法。

java.util.prefs 中 Exception 的使用

java.util.prefs 中 Exception 的子类
class | BackingStoreException 抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。
class | InvalidPreferencesFormatException 抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。

java.util.regex 中 Exception 的使用

java.util.regex 中 Exception 的子类
 class PatternSyntaxException
抛出未经检查的异常，表明正则表达式模式中的语法错误。

java.util.zip 中 Exception 的使用

java.util.zip 中 Exception 的子类
class | DataFormatException 当数据格式发生错误时，抛出此异常。
class | ZipException 如果某种 ZIP 异常发生，则抛出此错误。

javax.activation 中 Exception 的使用

javax.activation 中 Exception 的子类
 class UnsupportedDataTypeException
当请求操作不支持请求的数据类型时，抛出此异常。

javax.activity 中 Exception 的使用

javax.activity 中 Exception 的子类
class | ActivityCompletedException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
class | ActivityRequiredException 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
class | InvalidActivityException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

javax.annotation.processing 中 Exception 的使用

javax.annotation.processing 中 Exception 的子类
 class FilerException
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

javax.crypto 中 Exception 的使用

javax.crypto 中 Exception 的子类
class | BadPaddingException 当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
class | ExemptionMechanismException 此为一般 ExemptionMechanism 异常。
class | IllegalBlockSizeException 如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
class | NoSuchPaddingException 当请求特定填充机制但该环境中未提供时，抛出此异常。
class | ShortBufferException 当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

javax.imageio 中 Exception 的使用

javax.imageio 中 Exception 的子类
 class IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。

javax.imageio.metadata 中 Exception 的使用

javax.imageio.metadata 中 Exception 的子类
 class IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

javax.lang.model.element 中 Exception 的使用

javax.lang.model.element 中 Exception 的子类
class | UnknownAnnotationValueException 指示遇到一个未知种类的注释值。
class | UnknownElementException 指示遇到一个未知种类的元素。

javax.lang.model.type 中 Exception 的使用

javax.lang.model.type 中 Exception 的子类
class | MirroredTypeException 当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
class | MirroredTypesException 当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
class | UnknownTypeException 指示遇到未知种类的类型。

javax.management 中 Exception 的使用

javax.management 中 Exception 的子类
class | AttributeNotFoundException 指定的属性不存在或无法检索。
class | BadAttributeValueExpException 向构造的查询方法传递无效的 MBean 属性时，抛出此异常。
class | BadBinaryOpValueExpException 向构造查询的方法传递无效的表达式时，抛出此异常。
class | BadStringOperationException 向构造查询的方法传递无效的字符串操作时，抛出此异常。
class | InstanceAlreadyExistsException 已经在存储库中注册了 MBean。
class | InstanceNotFoundException 存储库中不存在指定的 MBean。
class | InvalidApplicationException 试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。
class | InvalidAttributeValueException 指定的值对该属性无效。
class | JMException 由 JMX 实现所抛出的异常。
class | JMRuntimeException 由 JMX 实现所发出的运行时异常。
class | ListenerNotFoundException 存储库中不存在指定的 MBean 侦听器。
class | MalformedObjectNameException 字符串的格式不对应于有效的 ObjectName。
class | MBeanException 表示由代理的 MBean 方法所抛出的“用户定义的”异常。
class | MBeanRegistrationException 包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
class | NotCompliantMBeanException 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
class | OperationsException 表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
class | ReflectionException 表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
class | RuntimeErrorException 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
class | RuntimeMBeanException 表示由代理中的 MBean 方法抛出的运行时异常。
class | RuntimeOperationsException 表示在 MBean 上执行操作时代理中抛出的运行时异常。
class | ServiceNotFoundException 表示请求的服务不受支持时引发的异常。

返回 Exception 的 javax.management 中的方法
Exception | MBeanException.getTargetException() 返回实际抛出的 Exception。
Exception | ReflectionException.getTargetException() 返回抛出的实际 Exception。

抛出 Exception 的 javax.management 中的方法
void | MBeanRegistration.preDeregister() 允许该 MBean 在从 MBean 服务器注销之前执行它所需要的任何操作。
void | StandardMBean.preDeregister() 允许 MBean 由 MBean 服务器取消注册前执行任何它所需要的操作。
ObjectName | MBeanRegistration.preRegister(MBeanServer server, ObjectName name) 允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
ObjectName | StandardMBean.preRegister(MBeanServer server, ObjectName name) 允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。

参数类型为 Exception 的 javax.management 中的构造方法
MBeanException(Exception e)
创建一个包装实际 java.lang.Exception 的 MBeanException。
MBeanException(Exception e, String message)
创建一个包装实际 java.lang.Exception 的 MBeanException（带有详细消息）。
MBeanRegistrationException(Exception e)
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException。
MBeanRegistrationException(Exception e, String message)
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException（带有详细消息）。
ReflectionException(Exception e)
创建包装实际 java.lang.Exception 的 ReflectionException。
ReflectionException(Exception e, String message)
创建包装带有详细消息的实际 java.lang.Exception 的 ReflectionException。

javax.management.loading 中 Exception 的使用

抛出 Exception 的 javax.management.loading 中的方法
protected URL | MLet.check(String version, URL codebase, String jarfile, MLetContent mlet) 当扩展此服务来支持缓存和版本控制时，要重写此方法。
void | MLet.preDeregister() 允许 m-let 在由 MBean 服务器注销之前执行任何所需要的操作。
ObjectName | MLet.preRegister(MBeanServer server, ObjectName name) 允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。

javax.management.modelmbean 中 Exception 的使用

javax.management.modelmbean 中 Exception 的子类
class | InvalidTargetObjectTypeException 当指定了无效的目标对象类型时，抛出此异常。
class | XMLParseException 当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。

抛出 Exception 的 javax.management.modelmbean 中的方法
void | RequiredModelMBean.preDeregister() 允许 MBean 在由 MBean 服务器注销之前执行任何所需要的操作。
ObjectName | RequiredModelMBean.preRegister(MBeanServer server, ObjectName name) 允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。

参数类型为 Exception 的 javax.management.modelmbean 中的构造方法
InvalidTargetObjectTypeException(Exception e, String s)
带有异常和字符串的构造方法。
XMLParseException(Exception e, String s)
带有字符串和异常的构造方法。

javax.management.monitor 中 Exception 的使用

javax.management.monitor 中 Exception 的子类
 class MonitorSettingException
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

抛出 Exception 的 javax.management.monitor 中的方法
void | Monitor.preDeregister() 允许在 MBean 服务器注销监视器 MBean 之前执行监视器 MBean 所需要的任何操作。
ObjectName | Monitor.preRegister(MBeanServer server, ObjectName name) 允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。

javax.management.openmbean 中 Exception 的使用

javax.management.openmbean 中 Exception 的子类
class | InvalidOpenTypeException 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
class | KeyAlreadyExistsException 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。
class | OpenDataException 因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。

javax.management.relation 中 Exception 的使用

javax.management.relation 中 Exception 的子类
class | InvalidRelationIdException 为关系提供的关系 id 已使用时引发此异常。
class | InvalidRelationServiceException 提供无效 Relation Service（关系服务）时引发此异常。
class | InvalidRelationTypeException 无效的关系类型。
class | InvalidRoleInfoException 在角色信息中，其最小程度大于其最大程度时，引发此异常。
class | InvalidRoleValueException 角色值无效。
class | RelationException 此类是关系管理过程中引发的任何异常的超类。
class | RelationNotFoundException Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
class | RelationServiceNotRegisteredException 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
class | RelationTypeNotFoundException Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
class | RoleInfoNotFoundException 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
class | RoleNotFoundException 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

抛出 Exception 的 javax.management.relation 中的方法
void | RelationService.preDeregister()
void | RelationSupport.preDeregister()
ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)

javax.management.remote 中 Exception 的使用

javax.management.remote 中 Exception 的子类
class | JMXProviderException 当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
class | JMXServerErrorException 在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。

抛出 Exception 的 javax.management.remote 中的方法
 void JMXConnectorServer.preDeregister()
当此连接器服务器从 MBean 服务器上注销时，由该 MBean 服务器调用此方法。

javax.management.timer 中 Exception 的使用

抛出 Exception 的 javax.management.timer 中的方法
void | Timer.preDeregister() 允许计时器 MBean 在 MBean 服务器注销它之前执行任何所需的操作。
ObjectName | Timer.preRegister(MBeanServer server, ObjectName name) 允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。

javax.naming 中 Exception 的使用

javax.naming 中 Exception 的子类
class | AuthenticationNotSupportedException 当所请求验证的特定 flavor 不受支持时，抛出此异常。
class | CannotProceedException 抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
class | CommunicationException 当客户端无法与目录或命名服务通信时，抛出此异常。
class | ConfigurationException 当存在配置问题时，抛出此异常。
class | ContextNotEmptyException 当试图销毁一个不为空的上下文时，抛出此异常。
class | InsufficientResourcesException 当无法使用资源完成所请求的操作时，抛出此异常。
class | InterruptedNamingException 当正被调用的命名操作已经被中断时，抛出此异常。
class | InvalidNameException 此异常指示被指定的名称不符合命名系统的命名语法。
class | LimitExceededException 当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
class | LinkException 此异常用于描述解析链接时遇到的问题。
class | LinkLoopException 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
class | MalformedLinkException 如果在解析或构造链接时遇到错误链接，则抛出此异常。
class | NameAlreadyBoundException 一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
class | NameNotFoundException 当名称的组件由于没有被绑定而无法解析时，抛出此异常。
class | NamingException 此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
class | NamingSecurityException 此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
class | NoInitialContextException 当不能创建任何初始上下文实现时，抛出此异常。
class | NoPermissionException 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
class | NotContextException 当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
class | OperationNotSupportedException 当上下文实现不支持将调用的操作时，抛出此异常。
class | PartialResultException 抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
class | ReferralException 此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
class | ServiceUnavailableException 当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
class | SizeLimitExceededException 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
class | TimeLimitExceededException 当某一方法没有在指定的时间限制内终止时，抛出此异常。

javax.naming.directory 中 Exception 的使用

javax.naming.directory 中 Exception 的子类
class | AttributeInUseException 当操作试图添加已经存在的属性时抛出此异常。
class | AttributeModificationException 当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
class | InvalidAttributeIdentifierException 在试图用无效的属性标识符创建属性时，抛出此异常。
class | InvalidAttributesException 在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
class | InvalidSearchControlsException 在为搜索操作指定的 SearchControls 无效时，抛出此异常。
class | InvalidSearchFilterException 当指定的搜索过滤器无效时，抛出此异常。
class | NoSuchAttributeException 尝试访问不存在的属性时，抛出此异常。
class | SchemaViolationException 当方法在某些方面违反模式时，抛出此异常。

javax.naming.ldap 中 Exception 的使用

javax.naming.ldap 中 Exception 的子类
 class LdapReferralException
此抽象类用于表示 LDAP 引用异常。

javax.naming.spi 中 Exception 的使用

抛出 Exception 的 javax.naming.spi 中的方法
static Object | NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment) 为指定对象和环境创建一个对象实例。
Object | ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 使用指定的位置或引用信息创建一个对象。
Object | DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 使用位置或引用信息以及指定的属性创建一个对象。
static Object | DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。

javax.net.ssl 中 Exception 的使用

javax.net.ssl 中 Exception 的子类
class | SSLException 指示由 SSL 子系统检测到的某类错误。
class | SSLHandshakeException 指示客户端和服务器不能就所需安全级别进行协商。
class | SSLKeyException 报告错误的 SSL 密钥。
class | SSLPeerUnverifiedException 指示还没有验证同位体的身份。
class | SSLProtocolException 报告在 SSL 协议的操作中的错误。

javax.print 中 Exception 的使用

javax.print 中 Exception 的子类
 class PrintException
类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。

参数类型为 Exception 的 javax.print 中的构造方法
PrintException(Exception e)
构造链接了所提供异常的 print 异常。
PrintException(String s, Exception e)
构造带给定详细消息和链异常的 print 异常。

javax.print.attribute 中 Exception 的使用

javax.print.attribute 中 Exception 的子类
 class UnmodifiableSetException
当由于设置不可修改而无法执行请求的操作时，抛出该异常。

javax.script 中 Exception 的使用

javax.script 中 Exception 的子类
 class ScriptException
脚本 API 的一般 Exception 类。

参数类型为 Exception 的 javax.script 中的构造方法
ScriptException(Exception e)
创建一个包装底层解释器抛出的 Exception 的 ScriptException。

javax.security.auth 中 Exception 的使用

javax.security.auth 中 Exception 的子类
class | DestroyFailedException 当 destroy 操作失败时，抛出此异常。
class | RefreshFailedException 当 refresh 操作失败时，抛出此异常。

javax.security.auth.callback 中 Exception 的使用

javax.security.auth.callback 中 Exception 的子类
 class UnsupportedCallbackException
在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

javax.security.auth.login 中 Exception 的使用

javax.security.auth.login 中 Exception 的子类
class | AccountException 一般的帐户异常。
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。
class | CredentialException 一般证书异常。
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。
class | FailedLoginException 当用户验证失败时抛出此异常。
class | LoginException 此异常是基本的登录异常。

javax.security.cert 中 Exception 的使用

javax.security.cert 中 Exception 的子类
class | CertificateEncodingException 证书编码异常。
class | CertificateException 此异常指示各种证书问题之一。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书不再有效异常。
class | CertificateParsingException 证书解析异常。

javax.security.sasl 中 Exception 的使用

javax.security.sasl 中 Exception 的子类
class | AuthenticationException 此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。
class | SaslException 此类表示在使用 SASL 时所发生的错误。

javax.sound.midi 中 Exception 的使用

javax.sound.midi 中 Exception 的子类
class | InvalidMidiDataException 一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
class | MidiUnavailableException 当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。

javax.sound.sampled 中 Exception 的使用

javax.sound.sampled 中 Exception 的子类
class | LineUnavailableException LineUnavailableException 是指示某一行因为不可用而无法打开的异常。
class | UnsupportedAudioFileException UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

javax.sql.rowset 中 Exception 的使用

javax.sql.rowset 中 Exception 的子类
 class RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

javax.sql.rowset.serial 中 Exception 的使用

javax.sql.rowset.serial 中 Exception 的子类
 class SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

javax.sql.rowset.spi 中 Exception 的使用

javax.sql.rowset.spi 中 Exception 的子类
class | SyncFactoryException 指示 SyncFactory 机制发生的错误。
class | SyncProviderException 指示 SyncProvider 机制发生的错误。

javax.swing 中 Exception 的使用

javax.swing 中 Exception 的子类
 class UnsupportedLookAndFeelException
指示在用户系统上不存在请求的外观管理类的异常。

抛出 Exception 的 javax.swing 中的方法
protected abstract  T SwingWorker.doInBackground()
计算结果；如果无法计算结果，则抛出异常。

javax.swing.text 中 Exception 的使用

javax.swing.text 中 Exception 的子类
class | BadLocationException 此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
class | ChangedCharSetException 顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。

javax.swing.tree 中 Exception 的使用

javax.swing.tree 中 Exception 的子类
 class ExpandVetoException
用于阻止扩展/折叠发生的异常。

javax.swing.undo 中 Exception 的使用

javax.swing.undo 中 Exception 的子类
class | CannotRedoException 当 UndoableEdit 被通知 redo() 但无法执行时抛出。
class | CannotUndoException 当 UndoableEdit 被通知 undo() 但无法执行时抛出。

javax.transaction 中 Exception 的使用

javax.transaction 中 Exception 的子类
class | InvalidTransactionException 此异常指示该请求带来了无效的事务上下文。
class | TransactionRequiredException 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
class | TransactionRolledbackException 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

javax.transaction.xa 中 Exception 的使用

javax.transaction.xa 中 Exception 的子类
 class XAException
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。

javax.xml.bind 中 Exception 的使用

javax.xml.bind 中 Exception 的子类
class | JAXBException 这是所有 JAXB 异常的根异常类。
class | PropertyException 此异常指示在获取或设置属性时遇到一个错误。
class | TypeConstraintException 此异常指示已检测到存在违反动态检查的类型约束的情况。
class | ValidationException 此异常指示在执行验证操作时发生错误。

javax.xml.bind.annotation.adapters 中 Exception 的使用

抛出 Exception 的 javax.xml.bind.annotation.adapters 中的方法
abstract ValueType | XmlAdapter.marshal(BoundType v) 将 bound 类型转换为 value 类型。
abstract BoundType | XmlAdapter.unmarshal(ValueType v) 将 value 类型转换为 bound 类型。

javax.xml.crypto 中 Exception 的使用

javax.xml.crypto 中 Exception 的子类
class | KeySelectorException 指示由 KeySelector 抛出的异常条件。
class | MarshalException 指示 XML 编组或解组过程中发生的异常条件。
class | NoSuchMechanismException 当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。
class | URIReferenceException 指示取消引用 URIReference 时抛出的异常条件。

javax.xml.crypto.dsig 中 Exception 的使用

javax.xml.crypto.dsig 中 Exception 的子类
class | TransformException 指示执行转换算法时出现异常的异常条件。
class | XMLSignatureException 指示生成或验证 XML 签名过程中发生的异常条件。

javax.xml.datatype 中 Exception 的使用

javax.xml.datatype 中 Exception 的子类
 class DatatypeConfigurationException
指示严重的配置错误。

javax.xml.parsers 中 Exception 的使用

javax.xml.parsers 中 Exception 的子类
 class ParserConfigurationException
指示一个严重的配置错误。

返回 Exception 的 javax.xml.parsers 中的方法
 Exception FactoryConfigurationError.getException()
返回引发此异常的实际异常（如果有）。

参数类型为 Exception 的 javax.xml.parsers 中的构造方法
FactoryConfigurationError(Exception e)
使用错误的给定 Exception 基本原因创建一个新的 FactoryConfigurationError。
FactoryConfigurationError(Exception e, String msg)
使用给定 Exception 的基本原因和详细消息创建一个新的 FactoryConfigurationError。

javax.xml.soap 中 Exception 的使用

javax.xml.soap 中 Exception 的子类
 class SOAPException
当发生 SOAP 异常时，抛出此异常。

javax.xml.stream 中 Exception 的使用

javax.xml.stream 中 Exception 的子类
 class XMLStreamException
用于不可预料处理错误的基本异常。

返回 Exception 的 javax.xml.stream 中的方法
 Exception FactoryConfigurationError.getException()
返回嵌套异常（如果有）。

参数类型为 Exception 的 javax.xml.stream 中的构造方法
FactoryConfigurationError(Exception e)
构造具有嵌套内部异常的异常。
FactoryConfigurationError(Exception e, String msg)
构造具有嵌套内部异常和消息的异常。
FactoryConfigurationError(String msg, Exception e)
构造具有嵌套内部异常和消息的异常。

javax.xml.transform 中 Exception 的使用

javax.xml.transform 中 Exception 的子类
class | TransformerConfigurationException 指示严重的配置错误。
class | TransformerException 此类指定了转换过程中发生的异常条件。

返回 Exception 的 javax.xml.transform 中的方法
 Exception TransformerFactoryConfigurationError.getException()
返回引发此异常的实际异常（如果有）。

参数类型为 Exception 的 javax.xml.transform 中的构造方法
TransformerFactoryConfigurationError(Exception e)
创建带有错误的给定 Exception 基本原因的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(Exception e, String msg)
创建带有给定 Exception 基本原因和详细消息的新 TransformerFactoryConfigurationError。

javax.xml.ws 中 Exception 的使用

javax.xml.ws 中 Exception 的子类
 class WebServiceException
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

javax.xml.ws.http 中 Exception 的使用

javax.xml.ws.http 中 Exception 的子类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 Exception 的使用

javax.xml.ws.soap 中 Exception 的子类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

javax.xml.xpath 中 Exception 的使用

javax.xml.xpath 中 Exception 的子类
class | XPathException XPathException 表示通用 XPath 异常。
class | XPathExpressionException XPathExpressionException 表示 XPath 表达式中的错误。
class | XPathFactoryConfigurationException XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
class | XPathFunctionException XPathFunctionException 表示 XPath 函数的错误。

org.ietf.jgss 中 Exception 的使用

org.ietf.jgss 中 Exception 的子类
 class GSSException
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。

org.omg.CORBA 中 Exception 的使用

org.omg.CORBA 中 Exception 的子类
class | ACTIVITY_COMPLETED ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
class | ACTIVITY_REQUIRED ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
class | BAD_CONTEXT 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
class | BAD_INV_ORDER 此异常指示调用者按错误顺序调用了操作。
class | BAD_OPERATION 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
class | BAD_PARAM 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
class | BAD_QOS 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
class | BAD_TYPECODE 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
class | Bounds 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
class | CODESET_INCOMPATIBLE 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
class | COMM_FAILURE 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
class | DATA_CONVERSION 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
class | FREE_MEM 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
class | IMP_LIMIT 此异常指示在 OBR 运行时超过了某一项实现限制。
class | INITIALIZE ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
class | INTERNAL 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
class | INTF_REPOS 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
class | INV_FLAG 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
class | INV_IDENT 此异常指示 IDL 标识符在语法上是无效的。
class | INV_OBJREF 此异常指示对象引用存在内部错误。
class | INV_POLICY 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
class | INVALID_ACTIVITY 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
class | INVALID_TRANSACTION 当请求带有无效的事务上下文时，抛出此异常。
class | MARSHAL 表示网络中传来的请求或应答在结构上无效。
class | NO_IMPLEMENT 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
class | NO_MEMORY 如果 ORB 运行时出现内存不足，则抛出此异常。
class | NO_PERMISSION 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
class | NO_RESOURCES 当 ORB 遇到一些一般资源限制时，抛出此异常。
class | NO_RESPONSE 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
class | OBJ_ADAPTER 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
class | OBJECT_NOT_EXIST 只要在已删除的对象上执行调用，就会引发此异常。
class | PERSIST_STORE 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
class | PolicyError 发生策略错误时抛出的用户异常。
class | REBIND 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
class | SystemException 所有 CORBA 标准异常的根类。
class | TIMEOUT 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
class | TRANSACTION_MODE 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
class | TRANSACTION_REQUIRED 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
class | TRANSACTION_ROLLEDBACK 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
class | TRANSACTION_UNAVAILABLE 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
class | TRANSIENT 当 ORB 试图到达某一对象但失败时，抛出此异常。
class | UNKNOWN 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。
class | UnknownUserException 包含由服务器返回的用户异常的类。
class | UserException CORBA IDL 定义的用户异常的根类。
class | WrongTransaction CORBA WrongTransaction 用户定义异常。

返回 Exception 的 org.omg.CORBA 中的方法
abstract  Exception Environment.exception()
检索此 Environment 对象中的异常。

参数类型为 Exception 的 org.omg.CORBA 中的方法
abstract  void Environment.exception(Exception except)
将给定异常插入此 Environment 对象。

org.omg.CORBA.DynAnyPackage 中 Exception 的使用

org.omg.CORBA.DynAnyPackage 中 Exception 的子类
class | Invalid 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
class | InvalidSeq 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
class | InvalidValue
class | TypeMismatch 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 Exception 的使用

org.omg.CORBA.ORBPackage 中 Exception 的子类
class | InconsistentTypeCode 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
class | InvalidName 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.portable 中 Exception 的使用

org.omg.CORBA.portable 中 Exception 的子类
class | ApplicationException 此类用来报告 ORB 和 stub 之间的应用程序级异常。
class | IndirectionException Indirection 异常是一个特定于 Java 的系统异常。
class | RemarshalException 此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
class | UnknownException org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

org.omg.CORBA.TypeCodePackage 中 Exception 的使用

org.omg.CORBA.TypeCodePackage 中 Exception 的子类
 class BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming.NamingContextExtPackage 中 Exception 的使用

org.omg.CosNaming.NamingContextExtPackage 中 Exception 的子类
 class InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextPackage 中 Exception 的使用

org.omg.CosNaming.NamingContextPackage 中 Exception 的子类
class | AlreadyBound org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
class | CannotProceed org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
class | NotEmpty org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
class | NotFound org/omg/CosNaming/NamingContextPackage/NotFound.java。

org.omg.IOP.CodecFactoryPackage 中 Exception 的使用

org.omg.IOP.CodecFactoryPackage 中 Exception 的子类
 class UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecPackage 中 Exception 的使用

org.omg.IOP.CodecPackage 中 Exception 的子类
class | FormatMismatch org/omg/IOP/CodecPackage/FormatMismatch.java。
class | InvalidTypeForEncoding org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

org.omg.PortableInterceptor 中 Exception 的使用

org.omg.PortableInterceptor 中 Exception 的子类
 class InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Exception 的使用

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Exception 的子类
 class DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

org.omg.PortableServer 中 Exception 的使用

org.omg.PortableServer 中 Exception 的子类
 class ForwardRequest
org/omg/PortableServer/ForwardRequest.java。

org.omg.PortableServer.CurrentPackage 中 Exception 的使用

org.omg.PortableServer.CurrentPackage 中 Exception 的子类
 class NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.POAManagerPackage 中 Exception 的使用

org.omg.PortableServer.POAManagerPackage 中 Exception 的子类
 class AdapterInactive
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。

org.omg.PortableServer.POAPackage 中 Exception 的使用

org.omg.PortableServer.POAPackage 中 Exception 的子类
class | AdapterAlreadyExists org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
class | AdapterNonExistent org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
class | InvalidPolicy org/omg/PortableServer/POAPackage/InvalidPolicy.java。
class | NoServant org/omg/PortableServer/POAPackage/NoServant.java。
class | ObjectAlreadyActive org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
class | ObjectNotActive org/omg/PortableServer/POAPackage/ObjectNotActive.java。
class | ServantAlreadyActive org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
class | ServantNotActive org/omg/PortableServer/POAPackage/ServantNotActive.java。
class | WrongAdapter org/omg/PortableServer/POAPackage/WrongAdapter.java。
class | WrongPolicy org/omg/PortableServer/POAPackage/WrongPolicy.java。

org.w3c.dom 中 Exception 的使用

org.w3c.dom 中 Exception 的子类
 class DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

org.w3c.dom.events 中 Exception 的使用

org.w3c.dom.events 中 Exception 的子类
 class EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。

org.w3c.dom.ls 中 Exception 的使用

org.w3c.dom.ls 中 Exception 的子类
 class LSException
如果处理停止，解析或写操作可以抛出 LSException。

org.xml.sax 中 Exception 的使用

org.xml.sax 中 Exception 的子类
class | SAXException 封装一般的 SAX 错误或警告。
class | SAXNotRecognizedException 用于未识别的标识符的 Exception 类。
class | SAXNotSupportedException 用于不被支持的操作的 Exception 类。
class | SAXParseException 封装 XML 解析错误或警告。

返回 Exception 的 org.xml.sax 中的方法
 Exception SAXException.getException()
返回嵌入的异常（如果有）。

参数类型为 Exception 的 org.xml.sax 中的构造方法
SAXException(Exception e)
创建一个包装现有异常的新的 SAXException。
SAXException(String message, Exception e)
从现有的异常创建新的 SAXException。
SAXParseException(String message, Locator locator, Exception e)
将现有的异常包装在 SAXParseException 中。
SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber, Exception e)
创建带有嵌入异常的新 SAXParseException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ExceptionInInitializerError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ExceptionInInitializerError
的使用

没有 java.lang.ExceptionInInitializerError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Float
的使用

使用 Float 的软件包
java.awt.font | 提供与字体相关的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.awt.font 中 Float 的使用

声明为 Float 的 java.awt.font 中的字段
static Float | TextAttribute.JUSTIFICATION_FULL 将线条调整到完整的请求宽度。
static Float | TextAttribute.JUSTIFICATION_NONE 不允许调整线条。
static Float | TextAttribute.POSTURE_OBLIQUE 标准斜体形态。
static Float | TextAttribute.POSTURE_REGULAR 标准直立形态。
static Float | TextAttribute.TRACKING_LOOSE 执行宽松跟踪。
static Float | TextAttribute.TRACKING_TIGHT 执行紧密跟踪。
static Float | TextAttribute.WEIGHT_BOLD 标准的粗体 weight。
static Float | TextAttribute.WEIGHT_DEMIBOLD 比 WEIGHT_BOLD 稍轻的 weight。
static Float | TextAttribute.WEIGHT_DEMILIGHT WEIGHT_LIGHT 和 WEIGHT_STANDARD 之间的中间 weight。
static Float | TextAttribute.WEIGHT_EXTRA_LIGHT 最轻的预定义 weight。
static Float | TextAttribute.WEIGHT_EXTRABOLD 特别重的 weight。
static Float | TextAttribute.WEIGHT_HEAVY 比 WEIGHT_BOLD 稍重的 weight。
static Float | TextAttribute.WEIGHT_LIGHT 标准的轻 weight。
static Float | TextAttribute.WEIGHT_MEDIUM WEIGHT_REGULAR 和 WEIGHT_BOLD 之间的中间 weight。
static Float | TextAttribute.WEIGHT_REGULAR 标准 weight。
static Float | TextAttribute.WEIGHT_SEMIBOLD 比 WEIGHT_REGULAR 稍重的 weight。
static Float | TextAttribute.WEIGHT_ULTRABOLD 最重的预定义 weight。
static Float | TextAttribute.WIDTH_CONDENSED 最精简的预定义 width。
static Float | TextAttribute.WIDTH_EXTENDED 最大扩展的预定义 width。
static Float | TextAttribute.WIDTH_REGULAR 标准 width。
static Float | TextAttribute.WIDTH_SEMI_CONDENSED 适度精简的 width。
static Float | TextAttribute.WIDTH_SEMI_EXTENDED 适度扩展的 width。

java.lang 中 Float 的使用

类型参数类型为 Float 的 java.lang 中的字段
static Class<Float> Float.TYPE
表示 float 基本类型的 Class 实例。

返回 Float 的 java.lang 中的方法
static Float | Float.valueOf(float f) 返回表示指定的 float 值的 Float 实例。
static Float | Float.valueOf(String s) 返回保存用参数字符串 s 表示的 float 值的 Float 对象。

参数类型为 Float 的 java.lang 中的方法
 int Float.compareTo(Float anotherFloat)
比较两个 Float 对象所表示的数值。

javax.management.openmbean 中 Float 的使用

类型参数类型为 Float 的 javax.management.openmbean 中的字段
static SimpleType<Float> SimpleType.FLOAT
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Float 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.IllegalAccessError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalAccessError
的使用

没有 java.lang.IllegalAccessError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.IllegalAccessException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalAccessException
的使用

使用 IllegalAccessException 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
org.w3c.dom.bootstrap |
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.lang 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 java.lang 中的方法
 T Class.newInstance()
创建此 Class 对象所表示的类的一个新实例。

java.lang.reflect 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 java.lang.reflect 中的方法
Object | Field.get(Object obj) 返回指定对象上此 Field 表示的字段的值。
boolean | Field.getBoolean(Object obj) 获取一个静态或实例 boolean 字段的值。
byte | Field.getByte(Object obj) 获取一个静态或实例 byte 字段的值。
char | Field.getChar(Object obj) 获取 char 类型或另一个通过扩展转换可以转换为 char 类型的基本类型的静态或实例字段的值。
double | Field.getDouble(Object obj) 获取 double 类型或另一个通过扩展转换可以转换为 double 类型的基本类型的静态或实例字段的值。
float | Field.getFloat(Object obj) 获取 float 类型或另一个通过扩展转换可以转换为 float 类型的基本类型的静态或实例字段的值。
int | Field.getInt(Object obj) 获取 int 类型或另一个通过扩展转换可以转换为 int 类型的基本类型的静态或实例字段的值。
long | Field.getLong(Object obj) 获取 long 类型或另一个通过扩展转换可以转换为 long 类型的基本类型的静态或实例字段的值。
short | Field.getShort(Object obj) 获取 short 类型或另一个通过扩展转换可以转换为 short 类型的基本类型的静态或实例字段的值。
Object | Method.invoke(Object obj, Object... args) 对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。
T | Constructor.newInstance(Object... initargs) 使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。
void | Field.set(Object obj, Object value) 将指定对象变量上此 Field 对象表示的字段设置为指定的新值。
void | Field.setBoolean(Object obj, boolean z) 将字段的值设置为指定对象上的一个 boolean 值。
void | Field.setByte(Object obj, byte b) 将字段的值设置为指定对象上的一个 byte 值。
void | Field.setChar(Object obj, char c) 将字段的值设置为指定对象上的一个 char 值。
void | Field.setDouble(Object obj, double d) 将字段的值设置为指定对象上的一个 double 值。
void | Field.setFloat(Object obj, float f) 将字段的值设置为指定对象上的一个 float 值。
void | Field.setInt(Object obj, int i) 将字段的值设置为指定对象上的一个 int 值。
void | Field.setLong(Object obj, long l) 将字段的值设置为指定对象上的一个 long 值。
void | Field.setShort(Object obj, short s) 将字段的值设置为指定对象上的一个 short 值。

java.util 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 java.util 中的方法
 ResourceBundle ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。

javax.swing 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 javax.swing 中的方法
static void UIManager.setLookAndFeel(String className)
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

org.w3c.dom.bootstrap 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 org.w3c.dom.bootstrap 中的方法
static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
获得 DOMImplementationRegistry 的新实例。

org.xml.sax.helpers 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 org.xml.sax.helpers 中的方法
static Parser | ParserFactory.makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | ParserFactory.makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.IllegalArgumentException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalArgumentException
的使用

使用 IllegalArgumentException 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.ref | 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.net.ssl | 提供用于安全套接字包的类。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.stream |
javax.xml.stream.util |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

java.awt.print 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.awt.print 中的方法
 void PageFormat.setOrientation(int orientation)
设置页面方向。

java.beans 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.beans 中的方法
void | PropertyEditor.setAsText(String text) 通过解析给定 String 设置属性值。
void | PropertyEditorSupport.setAsText(String text) 通过解析给定字符串设置属性值。

java.beans.beancontext 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.beans.beancontext 中的方法
 URL BeanContext.getResource(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 InputStream BeanContext.getResourceAsStream(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。

java.lang 中 IllegalArgumentException 的使用

java.lang 中 IllegalArgumentException 的子类
class | IllegalThreadStateException 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
class | NumberFormatException 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。

抛出 IllegalArgumentException 的 java.lang 中的方法
protected  Package ClassLoader.definePackage(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase)
根据 name 在此 ClassLoader 中定义包。

java.lang.management 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.lang.management 中的构造方法
ManagementPermission(String name, String actions)
构造新的 ManagementPermission 对象。

java.lang.ref 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.lang.ref 中的方法
 Reference<? extends T> ReferenceQueue.remove(long timeout)
移除此队列中的下一个引用对象，阻塞到有一个对象变得可用或者给定的超时期满了为止。

java.lang.reflect 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.lang.reflect 中的方法
Object | Field.get(Object obj) 返回指定对象上此 Field 表示的字段的值。
static Object | Array.get(Object array, int index) 返回指定数组对象中索引组件的值。
boolean | Field.getBoolean(Object obj) 获取一个静态或实例 boolean 字段的值。
static boolean | Array.getBoolean(Object array, int index) 以 boolean 形式返回指定数组对象中索引组件的值。
byte | Field.getByte(Object obj) 获取一个静态或实例 byte 字段的值。
static byte | Array.getByte(Object array, int index) 以 byte 形式返回指定数组对象中索引组件的值。
char | Field.getChar(Object obj) 获取 char 类型或另一个通过扩展转换可以转换为 char 类型的基本类型的静态或实例字段的值。
static char | Array.getChar(Object array, int index) 以 char 形式返回指定数组对象中索引组件的值。
double | Field.getDouble(Object obj) 获取 double 类型或另一个通过扩展转换可以转换为 double 类型的基本类型的静态或实例字段的值。
static double | Array.getDouble(Object array, int index) 以 double 形式返回指定数组对象中索引组件的值。
float | Field.getFloat(Object obj) 获取 float 类型或另一个通过扩展转换可以转换为 float 类型的基本类型的静态或实例字段的值。
static float | Array.getFloat(Object array, int index) 以 float 形式返回指定数组对象中索引组件的值。
int | Field.getInt(Object obj) 获取 int 类型或另一个通过扩展转换可以转换为 int 类型的基本类型的静态或实例字段的值。
static int | Array.getInt(Object array, int index) 以 int 形式返回指定数组对象中索引组件的值。
static InvocationHandler | Proxy.getInvocationHandler(Object proxy) 返回指定代理实例的调用处理程序。
static int | Array.getLength(Object array) 以 int 形式返回指定数组对象的长度。
long | Field.getLong(Object obj) 获取 long 类型或另一个通过扩展转换可以转换为 long 类型的基本类型的静态或实例字段的值。
static long | Array.getLong(Object array, int index) 以 long 形式返回指定数组对象中索引组件的值。
static Class<?> | Proxy.getProxyClass(ClassLoader loader, Class<?>... interfaces) 返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
short | Field.getShort(Object obj) 获取 short 类型或另一个通过扩展转换可以转换为 short 类型的基本类型的静态或实例字段的值。
static short | Array.getShort(Object array, int index) 以 short 形式返回指定数组对象中索引组件的值。
Object | Method.invoke(Object obj, Object... args) 对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。
static Object | Array.newInstance(Class<?> componentType, int... dimensions) 创建一个具有指定的组件类型和维度的新数组。
T | Constructor.newInstance(Object... initargs) 使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。
static Object | Proxy.newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h) 返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。
static void | Array.set(Object array, int index, Object value) 将指定数组对象中索引组件的值设置为指定的新值。
void | Field.set(Object obj, Object value) 将指定对象变量上此 Field 对象表示的字段设置为指定的新值。
void | Field.setBoolean(Object obj, boolean z) 将字段的值设置为指定对象上的一个 boolean 值。
static void | Array.setBoolean(Object array, int index, boolean z) 将指定数组对象中索引组件的值设置为指定的 boolean 值。
void | Field.setByte(Object obj, byte b) 将字段的值设置为指定对象上的一个 byte 值。
static void | Array.setByte(Object array, int index, byte b) 将指定数组对象中索引组件的值设置为指定的 byte 值。
void | Field.setChar(Object obj, char c) 将字段的值设置为指定对象上的一个 char 值。
static void | Array.setChar(Object array, int index, char c) 将指定数组对象中索引组件的值设置为指定的 char 值。
void | Field.setDouble(Object obj, double d) 将字段的值设置为指定对象上的一个 double 值。
static void | Array.setDouble(Object array, int index, double d) 将指定数组对象中索引组件的值设置为指定的 double 值。
void | Field.setFloat(Object obj, float f) 将字段的值设置为指定对象上的一个 float 值。
static void | Array.setFloat(Object array, int index, float f) 将指定数组对象中索引组件的值设置为指定的 float 值。
void | Field.setInt(Object obj, int i) 将字段的值设置为指定对象上的一个 int 值。
static void | Array.setInt(Object array, int index, int i) 将指定数组对象中索引组件的值设置为指定的 int 值。
static void | Array.setLong(Object array, int index, long l) 将指定数组对象中索引组件的值设置为指定的 long 值。
void | Field.setLong(Object obj, long l) 将字段的值设置为指定对象上的一个 long 值。
static void | Array.setShort(Object array, int index, short s) 将指定数组对象中索引组件的值设置为指定的 short 值。
void | Field.setShort(Object obj, short s) 将字段的值设置为指定对象上的一个 short 值。

java.net 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.net 中的方法
protected  Package URLClassLoader.definePackage(String name, Manifest man, URL url)
用该 ClassLoader 中的名称定义一个新包。

java.nio.channels 中 IllegalArgumentException 的使用

java.nio.channels 中 IllegalArgumentException 的子类
class | IllegalSelectorException 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
class | UnresolvedAddressException 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
class | UnsupportedAddressTypeException 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

java.nio.charset 中 IllegalArgumentException 的使用

java.nio.charset 中 IllegalArgumentException 的子类
class | IllegalCharsetNameException 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
class | UnsupportedCharsetException 当不支持请求的 charset 时，抛出此未经检查的异常。

java.security 中 IllegalArgumentException 的使用

java.security 中 IllegalArgumentException 的子类
 class InvalidParameterException
当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。

java.util 中 IllegalArgumentException 的使用

java.util 中 IllegalArgumentException 的子类
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatException 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。

java.util.logging 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.util.logging 中的方法
static Level Level.parse(String name)
将级别名称字符串解析成 Level。

抛出 IllegalArgumentException 的 java.util.logging 中的构造方法
LoggingPermission(String name, String actions)
创建一个新的 LoggingPermission 对象。

java.util.regex 中 IllegalArgumentException 的使用

java.util.regex 中 IllegalArgumentException 的子类
 class PatternSyntaxException
抛出未经检查的异常，表明正则表达式模式中的语法错误。

javax.management 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.management 中的方法
void | MBeanServerDelegate.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcaster.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 在此 MBean 中添加一个侦听器。
void | AttributeChangeNotificationFilter.enableAttribute(String name) 启用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定名称。
void | NotificationFilterSupport.enableType(String prefix) 允许将其类型以指定前缀开始的所有通知发送到该侦听器。
boolean | ObjectName.isPropertyValuePattern(String property) 检查键属性中与值关联的值是否为一个模式。
static String | ObjectName.unquote(String q) 返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。

抛出 IllegalArgumentException 的 javax.management 中的构造方法
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。

javax.management.modelmbean 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
void | RequiredModelMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。

javax.management.monitor 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.management.monitor 中的方法
 void Monitor.addObservedObject(ObjectName object)
如果尚未显示此对象，则在观察到的 MBean 集中添加指定的对象。
 void MonitorMBean.addObservedObject(ObjectName object)
将指定的对象添加到所观察的 MBean 集中。
 void Monitor.setGranularityPeriod(long period)
设置粒度周期（以毫秒为单位）。
 void MonitorMBean.setGranularityPeriod(long period)
设置粒度时段（以毫秒为单位）。
 void CounterMonitor.setInitThreshold(Number value)
设置所有观察对象的共同初始阈值。
 void CounterMonitorMBean.setInitThreshold(Number value)
设置所有观察到的 MBeans 的公共初始阈值。
 void CounterMonitor.setModulus(Number value)
设置所有观察到的 MBeans 共同的模值。
 void CounterMonitorMBean.setModulus(Number value)
设置模值。
 void Monitor.setObservedAttribute(String attribute)
设置要观察的属性。
 void Monitor.setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 Monitor.addObservedObject(javax.management.ObjectName) 取代
 void CounterMonitor.setOffset(Number value)
设置所有观察到的 MBeans 共同的偏移量值。
 void CounterMonitorMBean.setOffset(Number value)
设置偏移量值。
 void StringMonitor.setStringToCompare(String value)
设置要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。
 void StringMonitorMBean.setStringToCompare(String value)
设置要与 observed 属性进行比较的字符串。
 void CounterMonitor.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitor.setInitThreshold(java.lang.Number) 取代
 void CounterMonitorMBean.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.setInitThreshold(java.lang.Number) 取代
 void GaugeMonitor.setThresholds(Number highValue, Number lowValue)
设置所有观察到的 MBean 的公共高、低阈值。
 void GaugeMonitorMBean.setThresholds(Number highValue, Number lowValue)
设置高、低阈值。

javax.management.openmbean 中 IllegalArgumentException 的使用

javax.management.openmbean 中 IllegalArgumentException 的子类
class | InvalidKeyException 当方法参数作为复合数据 的项名称或表格数据 的行索引时，如果其无效，则抛出此运行时异常。
class | InvalidOpenTypeException 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
class | KeyAlreadyExistsException 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。

javax.management.relation 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.management.relation 中的方法
void | RoleList.add(int index, Role role) 插入指定为指定位置处的元素的角色。
void | RoleUnresolvedList.add(int index, RoleUnresolved role) 在指定位置处插入指定为元素的未解析角色。
void | RoleList.add(Role role) 添加指定为列表中最后一个元素的 Role。
void | RoleUnresolvedList.add(RoleUnresolved role) 添加指定为列表中最后一个元素的 RoleUnresolved。
boolean | RoleList.addAll(int index, RoleList roleList) 从指定位置开始，将指定 RoleList 中的所有元素插入此列表，这些元素按指定 RoleList 的迭代器返回的顺序排列。
boolean | RoleUnresolvedList.addAll(int index, RoleUnresolvedList roleList) 从指定位置开始，将指定 RoleUnresolvedList 中的所有元素插入此列表，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationService.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
void | RelationServiceMBean.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
protected void | RelationTypeSupport.addRoleInfo(RoleInfo roleInfo) 添加角色信息。
Integer | RelationService.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否以给定类型的关系进行读取。
Integer | RelationServiceMBean.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否在给定类型的关系中读取。
Integer | RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
Integer | RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationService.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
void | MBeanServerNotificationFilter.disableObjectName(ObjectName objectName) 禁用与给定 ObjectName 有关的 MBeanServerNotification。
void | MBeanServerNotificationFilter.enableObjectName(ObjectName objectName) 启用与给定 ObjectName 有关的 MBeanServerNotification。
Map<ObjectName,List<String>> | RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<String,List<String>> | RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在引用给定 MBean 的引用关系。
Map<String,List<String>> | RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在其中引用给定 MBean 的关系。
List<String> | RelationService.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
List<String> | RelationServiceMBean.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
RoleResult | RelationService.getAllRoles(String relationId) 返回关系中存在的所有角色。
RoleResult | RelationServiceMBean.getAllRoles(String relationId) 返回关系中存在的所有角色。
Map<ObjectName,List<String>> | RelationService.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
String | RelationService.getRelationTypeName(String relationId) 返回给定关系的相关关系类型的名称。
String | RelationServiceMBean.getRelationTypeName(String relationId) 返回给定关系的相关关系类型的名称。
List<ObjectName> | Relation.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationSupport.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
Integer | Relation.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationSupport.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationService.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
Integer | RelationServiceMBean.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
RoleInfo | RelationType.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。
RoleInfo | RelationTypeSupport.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。
RoleInfo | RelationService.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色名称的角色信息。
RoleInfo | RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色的角色信息。
List<RoleInfo> | RelationService.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
List<RoleInfo> | RelationServiceMBean.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
RoleResult | Relation.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationSupport.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationService.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
RoleResult | RelationServiceMBean.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
Boolean | RelationService.hasRelation(String relationId) 用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
Boolean | RelationServiceMBean.hasRelation(String relationId) 用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
boolean | MBeanServerNotificationFilter.isNotificationEnabled(Notification notif) 向侦听器发送指定通知之前调用。
String | RelationService.isRelation(ObjectName objectName) 如果已经将 MBean 作为关系添加在 Relation Service 中，则返回与给定 ObjectName 相关的关系 id。
String | RelationServiceMBean.isRelation(ObjectName objectName) 如果 Relation Service 中作为关系添加 MBean，则返回与给定 ObjectName 相关的关系 id。
ObjectName | RelationService.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
ObjectName | RelationServiceMBean.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
void | RelationService.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationServiceMBean.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationService.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | RelationServiceMBean.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
static String | Role.roleValueToString(List<ObjectName> roleValue) 返回给定角色值的字符串。
void | RelationService.sendRelationCreationNotification(String relationId) 发送关系创建通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationCreationNotification(String relationId) 发送关系创建通知 (RelationNotification)。
void | RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RoleList.set(int index, Role role) 将指定位置处的元素设置为指定角色。
void | RoleUnresolvedList.set(int index, RoleUnresolved role) 将指定位置处的元素设置为指定的未解析角色。
void | RoleUnresolved.setProblemType(int pbType) 设置问题类型。
void | RelationSupport.setRelationServiceManagementFlag(Boolean flag)
void | RelationSupportMBean.setRelationServiceManagementFlag(Boolean flag) 指定此关系是否由 Relation Service 处理。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。
void | Role.setRoleName(String roleName) 设置角色名称。
void | RoleUnresolved.setRoleName(String name) 设置角色名称。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。
RoleResult | RelationService.setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
RoleResult | RelationServiceMBean.setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。
void | Role.setRoleValue(List<ObjectName> roleValue) 设置角色值。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

抛出 IllegalArgumentException 的 javax.management.relation 中的构造方法
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
所有角色定义在其中动态创建并作为参数传递的构造方法。
Role(String roleName, List<ObjectName> roleValue)
创建一个新的 Role 对象。
RoleInfo(RoleInfo roleInfo)
复制构造方法。
RoleInfo(String roleName, String mbeanClassName)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。
RoleList(List<Role> list)
构造一个包含指定 List 元素的 RoleList，这些元素按 List 迭代器返回的顺序排列。
RoleUnresolved(String name, List<ObjectName> value, int pbType)
构造方法。
RoleUnresolvedList(List<RoleUnresolved> list)
构造一个包含指定 List 元素的 RoleUnresolvedList，这些元素按 List 迭代器返回的顺序排列。

javax.management.timer 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.management.timer 中的方法
Integer | Timer.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

javax.net.ssl 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.net.ssl 中的方法
void | SSLSessionContext.setSessionCacheSize(int size) 设置用来存储在此 SSLSessionContext 下分组的 SSLSession 对象的缓存大小。
void | SSLSessionContext.setSessionTimeout(int seconds) 设置在此 SSLSessionContext 下分组的 SSLSession 对象的超时值限制。

javax.rmi.ssl 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.rmi.ssl 中的构造方法
SslRMIServerSocketFactory(String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
使用指定的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。

javax.swing 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.swing 中的方法
Popup | PopupFactory.getPopup(Component owner, Component contents, int x, int y) 为包含 Component contents 的 Component owner 创建 Popup。
void | AbstractButton.setDisplayedMnemonicIndex(int index) 提供关于应该装饰文本中哪一个字符来表示助记符的外观提示。
void | JLabel.setDisplayedMnemonicIndex(int index) 关于应该装饰文本中的哪个字符以表示助记符，为外观提供一个提示。

javax.xml.parsers 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.xml.parsers 中的方法
abstract Object | DocumentBuilderFactory.getAttribute(String name) 允许用户在底层实现上检索特定属性。
abstract void | DocumentBuilderFactory.setAttribute(String name, Object value) 允许用户在底层实现上设置特定属性。

javax.xml.stream 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.xml.stream 中的方法
Object | XMLEventReader.getProperty(String name) 从底层实现获取功能/属性值。
abstract Object | XMLInputFactory.getProperty(String name) 从底层实现获取功能/属性的值。
abstract Object | XMLOutputFactory.getProperty(String name) 获取底层实现上的功能/属性
Object | XMLStreamReader.getProperty(String name) 从底层实现获取功能/属性的值
Object | XMLStreamWriter.getProperty(String name) 从底层实现获取功能/属性值
abstract void | XMLInputFactory.setProperty(String name, Object value) 允许用户在底层实现上设置特定功能/属性。
abstract void | XMLOutputFactory.setProperty(String name, Object value) 允许用户在底层实现上设置特定功能/属性。

javax.xml.stream.util 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.xml.stream.util 中的方法
 Object EventReaderDelegate.getProperty(String name)

javax.xml.transform 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.xml.transform 中的方法
abstract String | Transformer.getOutputProperty(String name) 获取对转换器有效的输出属性。
abstract void | Transformer.setErrorListener(ErrorListener listener) 设置转换的实际错误事件侦听器。
abstract void | Transformer.setOutputProperty(String name, String value) 设置转换中实际的输出属性。

javax.xml.transform.sax 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.xml.transform.sax 中的方法
 void TransformerHandler.setResult(Result result)
设置与用于转换的此 TransformerHandler 关联的 Result。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.IllegalMonitorStateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalMonitorStateException
的使用

没有 java.lang.IllegalMonitorStateException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.IllegalStateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalStateException
的使用

使用 IllegalStateException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.crypto | 为加密操作提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

java.awt 中 IllegalStateException 的使用

java.awt 中 IllegalStateException 的子类
 class IllegalComponentStateException
当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

抛出 IllegalStateException 的 java.awt 中的方法
void | SplashScreen.close() 隐藏闪现屏幕、关闭窗口并释放所有相关资源。
Graphics2D | SplashScreen.createGraphics() 创建闪现屏幕叠加图像的图形上下文（Graphics2D 形式），它允许在闪现屏幕上进行绘制。
Rectangle | SplashScreen.getBounds() 以 Rectangle 形式返回闪现屏幕窗口的边界。
URL | SplashScreen.getImageURL() 返回当前闪现屏幕图像。
Dimension | SplashScreen.getSize() 以 Dimension 形式返回闪现屏幕窗口的大小。
void | SplashScreen.setImageURL(URL imageURL) 更改闪现屏幕图像。
void | SplashScreen.update() 用当前叠加图像的上下文来更新闪现屏幕窗口。

java.awt.dnd 中 IllegalStateException 的使用

java.awt.dnd 中 IllegalStateException 的子类
 class InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

java.nio 中 IllegalStateException 的使用

java.nio 中 IllegalStateException 的子类
 class InvalidMarkException
当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。

java.nio.channels 中 IllegalStateException 的使用

java.nio.channels 中 IllegalStateException 的子类
class | AlreadyConnectedException 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
class | CancelledKeyException 当试图使用不再有效的选择键时，抛出此未经检查的异常。
class | ClosedSelectorException 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
class | ConnectionPendingException 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
class | IllegalBlockingModeException 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
class | NoConnectionPendingException 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
class | NonReadableChannelException 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
class | NonWritableChannelException 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
class | NotYetBoundException 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | NotYetConnectedException 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | OverlappingFileLockException 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。

java.util 中 IllegalStateException 的使用

java.util 中 IllegalStateException 的子类
 class FormatterClosedException
格式器已关闭时抛出的未经检查的异常。

java.util.concurrent 中 IllegalStateException 的使用

java.util.concurrent 中 IllegalStateException 的子类
 class CancellationException
如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。

javax.crypto 中 IllegalStateException 的使用

抛出 IllegalStateException 的 javax.crypto 中的方法
byte[] | Mac.doFinal() 完成 MAC 操作。
byte[] | Mac.doFinal(byte[] input) 处理给定的 byte 数组并完成 MAC 操作。
void | Mac.doFinal(byte[] output, int outOffset) 完成 MAC 操作。
Key | KeyAgreement.doPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
protected abstract Key | KeyAgreementSpi.engineDoPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
protected abstract byte[] | KeyAgreementSpi.engineGenerateSecret() 生成共享秘密密钥并在新的缓冲区中返回它。
protected abstract int | KeyAgreementSpi.engineGenerateSecret(byte[] sharedSecret, int offset) 生成共享秘密密钥，并将从 offset 开始（包括）的部分放入缓冲区 sharedSecret。
protected abstract SecretKey | KeyAgreementSpi.engineGenerateSecret(String algorithm) 创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
byte[] | KeyAgreement.generateSecret() 生成共享秘密并在新的缓冲区中返回它。
int | KeyAgreement.generateSecret(byte[] sharedSecret, int offset) 生成共享秘密，并将其放入缓冲区 sharedSecret，从 offset（包括）开始。
SecretKey | KeyAgreement.generateSecret(String algorithm) 创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
byte[] | ExemptionMechanism.genExemptionBlob() 生成豁免机制密钥 blob。
int | ExemptionMechanism.genExemptionBlob(byte[] output) 生成豁免机制密钥 blob，并将结果存储在 output 缓冲区中。
int | ExemptionMechanism.genExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob，并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
int | ExemptionMechanism.getOutputSize(int inputLen) 根据给定的输入长度 inputLen（以字节为单位），返回保存下一个 genExemptionBlob 操作结果所需的输出缓冲区长度（以字节为单位）。
void | Mac.update(byte input) 处理给定的字节。
void | Mac.update(byte[] input) 处理给定的 byte 数组。
void | Mac.update(byte[] input, int offset, int len) 从 offset（包含）开始，处理 input 中的前 len 个字节。

javax.swing 中 IllegalStateException 的使用

抛出 IllegalStateException 的 javax.swing 中的方法
 void TransferHandler.exportToClipboard(JComponent comp, Clipboard clip, int action)
导致从给定组件到给定剪贴板的传输。

javax.xml.bind 中 IllegalStateException 的使用

抛出 IllegalStateException 的 javax.xml.bind 中的方法
 Object UnmarshallerHandler.getResult()
获得解组的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.IllegalThreadStateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalThreadStateException
的使用

没有 java.lang.IllegalThreadStateException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.IncompatibleClassChangeError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IncompatibleClassChangeError
的使用

使用 IncompatibleClassChangeError 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 IncompatibleClassChangeError 的使用

java.lang 中 IncompatibleClassChangeError 的子类
class | AbstractMethodError 当应用程序试图调用一个抽象方法时，抛出此错误。
class | IllegalAccessError 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
class | InstantiationError 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
class | NoSuchFieldError 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
class | NoSuchMethodError 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.IndexOutOfBoundsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IndexOutOfBoundsException
的使用

使用 IndexOutOfBoundsException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.print | 为通用的打印 API 提供类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.relation | 提供 Relation Service 的定义。

java.awt 中 IndexOutOfBoundsException 的使用

抛出 IndexOutOfBoundsException 的 java.awt 中的方法
 Cursor Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name)
创建一个新的自定义光标对象。

java.awt.print 中 IndexOutOfBoundsException 的使用

抛出 IndexOutOfBoundsException 的 java.awt.print 中的方法
PageFormat | Book.getPageFormat(int pageIndex) 返回 pageIndex 指定的页面的 PageFormat。
PageFormat | Pageable.getPageFormat(int pageIndex) 返回 pageIndex 指定的页面的 PageFormat。
Printable | Book.getPrintable(int pageIndex) 返回 Printable 实例，该实例负责呈现 pageIndex 指定的页面。
Printable | Pageable.getPrintable(int pageIndex) 返回负责呈现 pageIndex 指定的页面的 Printable 实例。
void | Book.setPage(int pageIndex, Printable painter, PageFormat page) 为指定的页码设置 PageFormat 和 Painter。

java.lang 中 IndexOutOfBoundsException 的使用

java.lang 中 IndexOutOfBoundsException 的子类
class | ArrayIndexOutOfBoundsException 用非法索引访问数组时抛出的异常。
class | StringIndexOutOfBoundsException 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。

javax.management.relation 中 IndexOutOfBoundsException 的使用

抛出 IndexOutOfBoundsException 的 javax.management.relation 中的方法
void | RoleList.add(int index, Role role) 插入指定为指定位置处的元素的角色。
void | RoleUnresolvedList.add(int index, RoleUnresolved role) 在指定位置处插入指定为元素的未解析角色。
boolean | RoleList.addAll(int index, RoleList roleList) 从指定位置开始，将指定 RoleList 中的所有元素插入此列表，这些元素按指定 RoleList 的迭代器返回的顺序排列。
boolean | RoleUnresolvedList.addAll(int index, RoleUnresolvedList roleList) 从指定位置开始，将指定 RoleUnresolvedList 中的所有元素插入此列表，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
boolean | RoleList.addAll(RoleList roleList) 将指定 RoleList 中的所有元素追加到列表末尾，这些元素按指定 RoleList 的迭代器返回的顺序排列。
boolean | RoleUnresolvedList.addAll(RoleUnresolvedList roleList) 将指定 RoleUnresolvedList 中的所有元素追加到列表末尾，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
void | RoleList.set(int index, Role role) 将指定位置处的元素设置为指定角色。
void | RoleUnresolvedList.set(int index, RoleUnresolved role) 将指定位置处的元素设置为指定的未解析角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.InheritableThreadLocal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.InheritableThreadLocal
的使用

没有 java.lang.InheritableThreadLocal 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.InstantiationError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.InstantiationError
的使用

没有 java.lang.InstantiationError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.InstantiationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.InstantiationException
的使用

使用 InstantiationException 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
org.w3c.dom.bootstrap |
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.lang 中 InstantiationException 的使用

抛出 InstantiationException 的 java.lang 中的方法
 T Class.newInstance()
创建此 Class 对象所表示的类的一个新实例。

java.lang.reflect 中 InstantiationException 的使用

抛出 InstantiationException 的 java.lang.reflect 中的方法
 T Constructor.newInstance(Object... initargs)
使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。

java.util 中 InstantiationException 的使用

抛出 InstantiationException 的 java.util 中的方法
 ResourceBundle ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。

javax.swing 中 InstantiationException 的使用

抛出 InstantiationException 的 javax.swing 中的方法
static void UIManager.setLookAndFeel(String className)
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

org.w3c.dom.bootstrap 中 InstantiationException 的使用

抛出 InstantiationException 的 org.w3c.dom.bootstrap 中的方法
static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
获得 DOMImplementationRegistry 的新实例。

org.xml.sax.helpers 中 InstantiationException 的使用

抛出 InstantiationException 的 org.xml.sax.helpers 中的方法
static Parser | ParserFactory.makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | ParserFactory.makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Integer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Integer
的使用

使用 Integer 的软件包
java.awt.font | 提供与字体相关的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt.font 中 Integer 的使用

声明为 Integer 的 java.awt.font 中的字段
static Integer | TextAttribute.KERNING_ON 请求标准字距调整。
static Integer | TextAttribute.LIGATURES_ON 请求标准可选连字。
static Integer | TextAttribute.SUPERSCRIPT_SUB 标准下标。
static Integer | TextAttribute.SUPERSCRIPT_SUPER 标准上标。
static Integer | TextAttribute.UNDERLINE_LOW_DASHED 单像素虚线低下划线。
static Integer | TextAttribute.UNDERLINE_LOW_DOTTED 单像素点线式低下划线。
static Integer | TextAttribute.UNDERLINE_LOW_GRAY 双像素灰色低下划线。
static Integer | TextAttribute.UNDERLINE_LOW_ONE_PIXEL 单像素实心低下划线。
static Integer | TextAttribute.UNDERLINE_LOW_TWO_PIXEL 双像素实心低下划线。
static Integer | TextAttribute.UNDERLINE_ON 标准下划线。

java.lang 中 Integer 的使用

类型参数类型为 Integer 的 java.lang 中的字段
static Class<Integer> Integer.TYPE
表示基本类型 int 的 Class 实例。

返回 Integer 的 java.lang 中的方法
static Integer | Integer.decode(String nm) 将 String 解码为 Integer。
static Integer | Integer.getInteger(String nm) 确定具有指定名称的系统属性的整数值。
static Integer | Integer.getInteger(String nm, int val) 确定具有指定名称的系统属性的整数值。
static Integer | Integer.getInteger(String nm, Integer val) 返回具有指定名称的系统属性的整数值。
static Integer | Integer.valueOf(int i) 返回一个表示指定的 int 值的 Integer 实例。
static Integer | Integer.valueOf(String s) 返回保存指定的 String 的值的 Integer 对象。
static Integer | Integer.valueOf(String s, int radix) 返回一个 Integer 对象，该对象中保存了用第二个参数提供的基数进行解析时从指定的 String 中提取的值。

参数类型为 Integer 的 java.lang 中的方法
int | Integer.compareTo(Integer anotherInteger) 在数字上比较两个 Integer 对象。
static Integer | Integer.getInteger(String nm, Integer val) 返回具有指定名称的系统属性的整数值。

java.util 中 Integer 的使用

返回变量类型为 Integer 的类型的 java.util 中的方法
 Map<String,Integer> Calendar.getDisplayNames(int field, int style, Locale locale)
返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。

javax.management 中 Integer 的使用

返回 Integer 的 javax.management 中的方法
Integer | MBeanServer.getMBeanCount() 返回 MBean 服务器中已注册的 MBean 的数目。
Integer | MBeanServerConnection.getMBeanCount() 返回 MBean 服务器中已注册的 MBean 数目。

javax.management.openmbean 中 Integer 的使用

类型参数类型为 Integer 的 javax.management.openmbean 中的字段
static SimpleType<Integer> SimpleType.INTEGER
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Integer 的值。

javax.management.relation 中 Integer 的使用

返回 Integer 的 javax.management.relation 中的方法
Integer | RelationService.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否以给定类型的关系进行读取。
Integer | RelationServiceMBean.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否在给定类型的关系中读取。
Integer | RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
Integer | RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
Integer | Relation.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationSupport.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationService.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
Integer | RelationServiceMBean.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。

javax.management.remote 中 Integer 的使用

返回 Integer 的 javax.management.remote 中的方法
 Integer TargetedNotification.getListenerID()
此通知所定向的侦听器的 ID。

参数类型为 Integer 的 javax.management.remote 中的构造方法
TargetedNotification(Notification notification, Integer listenerID)
构造一个 TargetedNotification 对象。

javax.management.remote.rmi 中 Integer 的使用

返回 Integer 的 javax.management.remote.rmi 中的方法
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
 Integer RMIConnection.getMBeanCount(Subject delegationSubject)
处理 MBeanServerConnection.getMBeanCount() 方法。
 Integer RMIConnectionImpl.getMBeanCount(Subject delegationSubject)
 Integer RMIConnectionImpl_Stub.getMBeanCount(Subject $param_Subject_1)

参数类型为 Integer 的 javax.management.remote.rmi 中的方法
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)

javax.management.timer 中 Integer 的使用

返回 Integer 的 javax.management.timer 中的方法
Integer | Timer.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerNotification.getNotificationID() 获取此计时器通知的标识符。

返回变量类型为 Integer 的类型的 javax.management.timer 中的方法
Vector<Integer> | Timer.getAllNotificationIDs() 获得所有在通知列表中注册的计时器通知标识符。
Vector<Integer> | TimerMBean.getAllNotificationIDs() 获得所有在通知的列表中注册的计时器通知标识符。
Vector<Integer> | Timer.getNotificationIDs(String type) 获得所有与指定类型对应的计时器通知的标识符。
Vector<Integer> | TimerMBean.getNotificationIDs(String type) 获得所有与指定类型对应的计时器通知的标识符。

参数类型为 Integer 的 javax.management.timer 中的方法
Date | Timer.getDate(Integer id) 获得与计时器通知关联的日期的一个副本。
Date | TimerMBean.getDate(Integer id) 获得与计时器通知关联的日期的一个副本。
Boolean | Timer.getFixedRate(Integer id) 获得此种标志的一个副本：该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
Boolean | TimerMBean.getFixedRate(Integer id) 获得此种标志的一个副本，该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
Long | Timer.getNbOccurences(Integer id) 获得与计时器通知关联的剩余出现数量的一个副本。
Long | TimerMBean.getNbOccurences(Integer id) 获得与计时器通知关联的剩余出现数量的一个副本。
String | Timer.getNotificationMessage(Integer id) 获得与指定标识符对应的计时器通知的详细消息。
String | TimerMBean.getNotificationMessage(Integer id) 获得与指定的标识符对应的计时器通知的详细消息。
String | Timer.getNotificationType(Integer id) 获得与指定标识符对应的计时器通知类型。
String | TimerMBean.getNotificationType(Integer id) 获得与指定标识符对应的计时器通知类型。
Object | Timer.getNotificationUserData(Integer id) 获得与指定标识符对应的计时器通知用户数据对象。
Object | TimerMBean.getNotificationUserData(Integer id) 获得与指定的标识符对应的计时器通知用户数据对象。
Long | Timer.getPeriod(Integer id) 获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
Long | TimerMBean.getPeriod(Integer id) 获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
void | Timer.removeNotification(Integer id) 从通知列表中移除与指定标识符对应的计时器通知。
void | TimerMBean.removeNotification(Integer id) 从通知列表中移除与指定的标识符对应的计时器通知。

参数类型为 Integer 的 javax.management.timer 中的构造方法
TimerNotification(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)
创建计时器通知对象。

javax.script 中 Integer 的使用

返回变量类型为 Integer 的类型的 javax.script 中的方法
List<Integer> | ScriptContext.getScopes() 返回 ScriptContext 中所有有效范围值的不可变 List。
List<Integer> | SimpleScriptContext.getScopes() 返回 ScriptContext 中所有有效范围值的不可变 List。

javax.swing 中 Integer 的使用

声明为 Integer 的 javax.swing 中的字段
static Integer | JLayeredPane.DEFAULT_LAYER 定义 Default 层的便捷对象。
static Integer | JLayeredPane.DRAG_LAYER 定义 Drag 层的便捷对象。
static Integer | JLayeredPane.FRAME_CONTENT_LAYER 定义 Frame Content 层的便捷对象。
static Integer | JLayeredPane.MODAL_LAYER 定义 Modal 层的便捷对象。
static Integer | JLayeredPane.PALETTE_LAYER 定义 Palette 层的便捷对象。
static Integer | JLayeredPane.POPUP_LAYER 定义 Popup 层的便捷对象。

返回 Integer 的 javax.swing 中的方法
protected  Integer JLayeredPane.getObjectForLayer(int layer)
返回与指定层关联的 Integer 对象。

返回变量类型为 Integer 的类型的 javax.swing 中的方法
protected  Hashtable<Component,Integer> JLayeredPane.getComponentToLayer()
返回将组件映射到层的哈希表。

参数类型为 Integer 的 javax.swing 中的方法
 void JInternalFrame.setLayer(Integer layer)
设置此组件 layer 属性的便捷方法。

javax.swing.plaf.basic 中 Integer 的使用

返回 Integer 的 javax.swing.plaf.basic 中的方法
protected Integer | BasicSliderUI.getHighestValue() 返回在标签表中有一个项的最大值。
protected Integer | BasicSliderUI.getLowestValue() 返回在标签表中有一个项的最小值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.InternalError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.InternalError
的使用

使用 InternalError 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 InternalError 的使用

java.util.zip 中 InternalError 的子类
 class ZipError
发生不可恢复的错误时抛出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.InterruptedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.InterruptedException
的使用

使用 InterruptedException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.ref | 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 InterruptedException 的使用

抛出 InterruptedException 的 java.awt 中的方法
AWTEvent | EventQueue.getNextEvent() 从 EventQueue 中移除一个事件，并返回该事件。
static void | EventQueue.invokeAndWait(Runnable runnable) 导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。
void | MediaTracker.waitForAll() 开始加载由此媒体跟踪器跟踪的所有图像。
boolean | MediaTracker.waitForAll(long ms) 开始加载由此媒体跟踪器跟踪的所有图像。
void | MediaTracker.waitForID(int id) 开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。
boolean | MediaTracker.waitForID(int id, long ms) 开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。

java.awt.image 中 InterruptedException 的使用

抛出 InterruptedException 的 java.awt.image 中的方法
boolean | PixelGrabber.grabPixels() 请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素。
boolean | PixelGrabber.grabPixels(long ms) 请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素，或者等待到用完超时期。

java.lang 中 InterruptedException 的使用

抛出 InterruptedException 的 java.lang 中的方法
 void Thread.join()
等待该线程终止。
 void Thread.join(long millis)
等待该线程终止的时间最长为 millis 毫秒。
 void Thread.join(long millis, int nanos)
等待该线程终止的时间最长为 millis 毫秒 + nanos 纳秒。
static void Thread.sleep(long millis)
在指定的毫秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。
static void Thread.sleep(long millis, int nanos)
在指定的毫秒数加指定的纳秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。
 void Object.wait()
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法前，导致当前线程等待。
 void Object.wait(long timeout)
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法，或者超过指定的时间量前，导致当前线程等待。
 void Object.wait(long timeout, int nanos)
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法，或者其他某个线程中断当前线程，或者已超过某个实际时间量前，导致当前线程等待。
abstract  int Process.waitFor()
导致当前线程等待，如有必要，一直要等到由该 Process 对象表示的进程已经终止。

java.lang.ref 中 InterruptedException 的使用

抛出 InterruptedException 的 java.lang.ref 中的方法
Reference<? extends T> | ReferenceQueue.remove() 移除此队列中的下一个引用对象，阻塞到某个对象变得可用为止。
Reference<? extends T> | ReferenceQueue.remove(long timeout) 移除此队列中的下一个引用对象，阻塞到有一个对象变得可用或者给定的超时期满了为止。

java.util.concurrent 中 InterruptedException 的使用

抛出 InterruptedException 的 java.util.concurrent 中的方法
 void Semaphore.acquire()
从此信号量获取一个许可，在提供一个许可前一直将线程阻塞，否则线程被中断。
 void Semaphore.acquire(int permits)
从此信号量获取给定数目的许可，在提供这些许可前一直将线程阻塞，或者线程已被中断。
 void CountDownLatch.await()
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断。
 int CyclicBarrier.await()
在所有参与者都已经在此 barrier 上调用 await 方法之前，将一直等待。
 boolean CountDownLatch.await(long timeout, TimeUnit unit)
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断或超出了指定的等待时间。
 int CyclicBarrier.await(long timeout, TimeUnit unit)
在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。
 boolean ExecutorService.awaitTermination(long timeout, TimeUnit unit)
请求关闭、发生超时或者当前线程中断，无论哪一个首先发生之后，都将导致阻塞，直到所有任务完成执行。
 boolean ThreadPoolExecutor.awaitTermination(long timeout, TimeUnit unit)
 V Exchanger.exchange(V x)
等待另一个线程到达此交换点（除非当前线程被中断），然后将给定的对象传送给该线程，并接收该线程的对象。
 V Exchanger.exchange(V x, long timeout, TimeUnit unit)
等待另一个线程到达此交换点（除非当前线程被中断，或者超出了指定的等待时间），然后将给定的对象传送给该线程，同时接收该线程的对象。
 V Future.get()
如有必要，等待计算完成，然后获取其结果。
 V FutureTask.get()
 V Future.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
 V FutureTask.get(long timeout, TimeUnit unit)
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。
 boolean ArrayBlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定的元素插入此队列的尾部，如果该队列已满，则在到达指定的等待时间之前等待可用的空间。
 boolean BlockingDeque.offer(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将在指定的等待时间内一直等待可用空间。
 boolean BlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入此队列中，在到达指定的等待时间前等待可用的空间（如果有必要）。
 boolean LinkedBlockingDeque.offer(E e, long timeout, TimeUnit unit)
 boolean LinkedBlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入到此队列的尾部，如有必要，则等待指定的时间以使空间变得可用。
 boolean SynchronousQueue.offer(E o, long timeout, TimeUnit unit)
将指定元素插入到此队列，如有必要则等待指定的时间，以便另一个线程接收它。
 boolean BlockingDeque.offerFirst(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列的开头，必要时将在指定的等待时间内等待可用空间。
 boolean LinkedBlockingDeque.offerFirst(E e, long timeout, TimeUnit unit)
 boolean BlockingDeque.offerLast(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列的末尾，必要时将在指定的等待时间内等待可用空间。
 boolean LinkedBlockingDeque.offerLast(E e, long timeout, TimeUnit unit)
 E ArrayBlockingQueue.poll(long timeout, TimeUnit unit)
 E BlockingDeque.poll(long timeout, TimeUnit unit)
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），如有必要将在指定的等待时间内等待可用元素。
 E BlockingQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。
 Future<V> CompletionService.poll(long timeout, TimeUnit unit)
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。
 E DelayQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在可从此队列获得到期延迟的元素，或者到达指定的等待时间之前一直等待（如有必要）。
 Future<V> ExecutorCompletionService.poll(long timeout, TimeUnit unit)
 E LinkedBlockingDeque.poll(long timeout, TimeUnit unit)
 E LinkedBlockingQueue.poll(long timeout, TimeUnit unit)
 E PriorityBlockingQueue.poll(long timeout, TimeUnit unit)
 E SynchronousQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头，如有必要则等待指定的时间，以便另一个线程插入它。
 E BlockingDeque.pollFirst(long timeout, TimeUnit unit)
获取并移除此双端队列的第一个元素，必要时将在指定的等待时间等待可用元素。
 E LinkedBlockingDeque.pollFirst(long timeout, TimeUnit unit)
 E BlockingDeque.pollLast(long timeout, TimeUnit unit)
获取并移除此双端队列的最后一个元素，必要时将在指定的等待时间内等待可用元素。
 E LinkedBlockingDeque.pollLast(long timeout, TimeUnit unit)
 void ArrayBlockingQueue.put(E e)
将指定的元素插入此队列的尾部，如果该队列已满，则等待可用的空间。
 void BlockingDeque.put(E e)
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将一直等待可用空间。
 void BlockingQueue.put(E e)
将指定元素插入此队列中，将等待可用的空间（如果有必要）。
 void LinkedBlockingDeque.put(E e)
 void LinkedBlockingQueue.put(E e)
将指定元素插入到此队列的尾部，如有必要，则等待空间变得可用。
 void SynchronousQueue.put(E o)
将指定元素添加到此队列，如有必要则等待另一个线程接收它。
 void BlockingDeque.putFirst(E e)
将指定的元素插入此双端队列的开头，必要时将一直等待可用空间。
 void LinkedBlockingDeque.putFirst(E e)
 void BlockingDeque.putLast(E e)
将指定的元素插入此双端队列的末尾，必要时将一直等待可用空间。
 void LinkedBlockingDeque.putLast(E e)
 void TimeUnit.sleep(long timeout)
使用此单元执行 Thread.sleep.这是将时间参数转换为 Thread.sleep 方法所需格式的便捷方法。
 E ArrayBlockingQueue.take()
 E BlockingDeque.take()
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），必要时将一直等待可用元素。
 E BlockingQueue.take()
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。
 Future<V> CompletionService.take()
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则等待。
 E DelayQueue.take()
获取并移除此队列的头部，在可从此队列获得到期延迟的元素之前一直等待（如有必要）。
 Future<V> ExecutorCompletionService.take()
 E LinkedBlockingDeque.take()
 E LinkedBlockingQueue.take()
 E PriorityBlockingQueue.take()
 E SynchronousQueue.take()
获取并移除此队列的头，如有必要则等待另一个线程插入它。
 E BlockingDeque.takeFirst()
获取并移除此双端队列的第一个元素，必要时将一直等待可用元素。
 E LinkedBlockingDeque.takeFirst()
 E BlockingDeque.takeLast()
获取并移除此双端队列的最后一个元素，必要时将一直等待可用元素。
 E LinkedBlockingDeque.takeLast()
 void TimeUnit.timedJoin(Thread thread, long timeout)
使用此时间单元执行计时的 Thread.join。
 void TimeUnit.timedWait(Object obj, long timeout)
使用此时间单元执行计时的 Object.wait。
 boolean Semaphore.tryAcquire(int permits, long timeout, TimeUnit unit)
如果在给定的等待时间内此信号量有可用的所有许可，并且当前线程未被中断，则从此信号量获取给定数目的许可。
 boolean Semaphore.tryAcquire(long timeout, TimeUnit unit)
如果在给定的等待时间内，此信号量有可用的许可并且当前线程未被中断，则从此信号量获取一个许可。

java.util.concurrent.locks 中 InterruptedException 的使用

抛出 InterruptedException 的 java.util.concurrent.locks 中的方法
void | AbstractQueuedSynchronizer.acquireInterruptibly(int arg) 以独占模式获取对象，如果被中断则中止。
void | AbstractQueuedLongSynchronizer.acquireInterruptibly(long arg) 以独占模式获取，如果被中断则中止。
void | AbstractQueuedSynchronizer.acquireSharedInterruptibly(int arg) 以共享模式获取对象，如果被中断则中止。
void | AbstractQueuedLongSynchronizer.acquireSharedInterruptibly(long arg) 以共享模式获取，如果被中断则中止。
void | AbstractQueuedLongSynchronizer.ConditionObject.await() 实现可中断的条件等待。
void | Condition.await() 造成当前线程在接到信号或被中断之前一直处于等待状态。
void | AbstractQueuedSynchronizer.ConditionObject.await() 实现不可中断的条件等待。
boolean | AbstractQueuedLongSynchronizer.ConditionObject.await(long time, TimeUnit unit) 实现定时条件等待。
boolean | Condition.await(long time, TimeUnit unit) 造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
boolean | AbstractQueuedSynchronizer.ConditionObject.await(long time, TimeUnit unit) 实现定时的条件等待。
long | AbstractQueuedLongSynchronizer.ConditionObject.awaitNanos(long nanosTimeout) 实现定时条件等待。
long | Condition.awaitNanos(long nanosTimeout) 造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
long | AbstractQueuedSynchronizer.ConditionObject.awaitNanos(long nanosTimeout) 实现定时的条件等待。
boolean | AbstractQueuedLongSynchronizer.ConditionObject.awaitUntil(Date deadline) 实现绝对定时条件等待。
boolean | Condition.awaitUntil(Date deadline) 造成当前线程在接到信号、被中断或到达指定最后期限之前一直处于等待状态。
boolean | AbstractQueuedSynchronizer.ConditionObject.awaitUntil(Date deadline) 实现绝对定时条件等待。
void | ReentrantReadWriteLock.ReadLock.lockInterruptibly() 获取读取锁，除非当前线程被中断。
void | ReentrantReadWriteLock.WriteLock.lockInterruptibly() 获取写入锁，除非当前线程被中断。
void | ReentrantLock.lockInterruptibly() 如果当前线程未被中断，则获取锁。
void | Lock.lockInterruptibly() 如果当前线程未被中断，则获取锁。
boolean | AbstractQueuedSynchronizer.tryAcquireNanos(int arg, long nanosTimeout) 试图以独占模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。
boolean | AbstractQueuedLongSynchronizer.tryAcquireNanos(long arg, long nanosTimeout) 尝试以独占模式获取，如果被中断则中止，如果超过给定超时期则失败。
boolean | AbstractQueuedSynchronizer.tryAcquireSharedNanos(int arg, long nanosTimeout) 试图以共享模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。
boolean | AbstractQueuedLongSynchronizer.tryAcquireSharedNanos(long arg, long nanosTimeout) 尝试以共享模式获取，如果被中断则中止，如果超过给定超时期则失败。
boolean | ReentrantReadWriteLock.ReadLock.tryLock(long timeout, TimeUnit unit) 如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取读取锁。
boolean | ReentrantReadWriteLock.WriteLock.tryLock(long timeout, TimeUnit unit) 如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取写入锁。
boolean | ReentrantLock.tryLock(long timeout, TimeUnit unit) 如果锁在给定等待时间内没有被另一个线程保持，且当前线程未被中断，则获取该锁。
boolean | Lock.tryLock(long time, TimeUnit unit) 如果锁在给定的等待时间内空闲，并且当前线程未被中断，则获取锁。

javax.swing 中 InterruptedException 的使用

抛出 InterruptedException 的 javax.swing 中的方法
 T SwingWorker.get()
如有必要，等待计算完成，然后获取其结果。
 T SwingWorker.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
static void SwingUtilities.invokeAndWait(Runnable doRun)
导致 doRun.run() 在 AWT 事件指派线程上同步执行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.Iterable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Iterable
的使用

使用 Iterable 的软件包
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.beans.beancontext 中 Iterable 的使用

java.beans.beancontext 中 Iterable 的子接口
interface | BeanContext BeanContext 是 JavaBean 的逻辑层次容器。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 Iterable 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

java.sql 中 Iterable 的使用

实现 Iterable 的 java.sql 中的类
class | BatchUpdateException 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
class | DataTruncation 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
class | SQLClientInfoException 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLException 提供关于数据库访问错误或其他错误信息的异常。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLNonTransientException 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
class | SQLRecoverableException 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
class | SQLTransientException 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
class | SQLWarning 提供关于数据库访问警告信息的异常。

java.util 中 Iterable 的使用

java.util 中 Iterable 的子接口
interface | Collection<E> Collection 层次结构 中的根接口。
interface | Deque<E> 一个线性 collection，支持在两端插入和移除元素。
interface | List<E> 有序的 collection（也称为序列）。
interface | NavigableSet<E> 扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
interface | Queue<E> 在处理元素前用于保存元素的 collection。
interface | Set<E> 一个不包含重复元素的 collection。
interface | SortedSet<E> 进一步提供关于元素的总体排序 的 Set。

实现 Iterable 的 java.util 中的类
class | AbstractCollection<E> 此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
class | AbstractList<E> 此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
class | AbstractQueue<E> 此类提供某些 Queue 操作的骨干实现。
class | AbstractSequentialList<E> 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
class | AbstractSet<E> 此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | LinkedList<E> List 接口的链接列表实现。
class | PriorityQueue<E> 一个基于优先级堆的无界优先级队列。
class | ServiceLoader<S> 一个简单的服务提供者加载设施。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。
class | Vector<E> Vector 类可以实现可增长的对象数组。

java.util.concurrent 中 Iterable 的使用

java.util.concurrent 中 Iterable 的子接口
interface | BlockingDeque<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。
interface | BlockingQueue<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。

实现 Iterable 的 java.util.concurrent 中的类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArrayList<E> ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

javax.annotation.processing 中 Iterable 的使用

返回 Iterable 的 javax.annotation.processing 中的方法
Iterable<? extends Completion> | AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Iterable<? extends Completion> | Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。

javax.lang.model.util 中 Iterable 的使用

参数类型为 Iterable 的 javax.lang.model.util 中的方法
static List<ExecutableElement> ElementFilter.constructorsIn(Iterable<? extends Element> elements)
elements 中构造方法的列表。
static List<VariableElement> ElementFilter.fieldsIn(Iterable<? extends Element> elements)
返回 elements 中字段的列表。
static List<ExecutableElement> ElementFilter.methodsIn(Iterable<? extends Element> elements)
返回 elements 中方法的列表。
static List<PackageElement> ElementFilter.packagesIn(Iterable<? extends Element> elements)
返回 elements 中包的列表。
 R ElementScanner6.scan(Iterable<? extends Element> iterable, P p)
迭代给定元素并对每个元素调用 scan(Element, P)。
static List<TypeElement> ElementFilter.typesIn(Iterable<? extends Element> elements)
返回 elements 中类型的列表。

javax.management 中 Iterable 的使用

实现 Iterable 的 javax.management 中的类
 class AttributeList
表示 MBean 属性值的列表。

javax.management.relation 中 Iterable 的使用

实现 Iterable 的 javax.management.relation 中的类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

javax.print.attribute.standard 中 Iterable 的使用

实现 Iterable 的 javax.print.attribute.standard 中的类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

javax.sql.rowset 中 Iterable 的使用

实现 Iterable 的 javax.sql.rowset 中的类
 class RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

javax.sql.rowset.serial 中 Iterable 的使用

实现 Iterable 的 javax.sql.rowset.serial 中的类
 class SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

javax.sql.rowset.spi 中 Iterable 的使用

实现 Iterable 的 javax.sql.rowset.spi 中的类
class | SyncFactoryException 指示 SyncFactory 机制发生的错误。
class | SyncProviderException 指示 SyncProvider 机制发生的错误。

javax.swing 中 Iterable 的使用

参数类型为 Iterable 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
static
<M,I> RowFilter<M,I>
RowFilter.orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。

javax.tools 中 Iterable 的使用

返回 Iterable 的 javax.tools 中的方法
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjects(File... files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjects(String... names) 获取表示给定文件名称的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File> files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String> names) 获取表示给定文件名称的文件对象。
Iterable<? extends File> | StandardJavaFileManager.getLocation(JavaFileManager.Location location) 获取与给定位置关联的路径。
Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
Iterable<JavaFileObject> | JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。

参数类型为 Iterable 的 javax.tools 中的方法
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File> files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String> names) 获取表示给定文件名称的文件对象。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。
void | StandardJavaFileManager.setLocation(JavaFileManager.Location location, Iterable<? extends File> path) 将给定路径与给定位置关联。
void | JavaCompiler.CompilationTask.setProcessors(Iterable<? extends Processor> processors) 设置处理器（用于注释处理）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.LinkageError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.LinkageError
的使用

使用 LinkageError 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 LinkageError 的使用

java.lang 中 LinkageError 的子类
class | AbstractMethodError 当应用程序试图调用一个抽象方法时，抛出此错误。
class | ClassCircularityError 当初始化类时检测到类的循环调用的时候，抛出该错误。
class | ClassFormatError 当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
class | ExceptionInInitializerError 静态初始化程序中发生意外异常的信号。
class | IllegalAccessError 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
class | IncompatibleClassChangeError 在某些类定义中出现不兼容的类更改时抛出该异常。
class | InstantiationError 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
class | NoClassDefFoundError 当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
class | NoSuchFieldError 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
class | NoSuchMethodError 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
class | UnsatisfiedLinkError 当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
class | UnsupportedClassVersionError 当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
class | VerifyError 当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。

java.lang.reflect 中 LinkageError 的使用

java.lang.reflect 中 LinkageError 的子类
 class GenericSignatureFormatError
当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Long 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Long
的使用

使用 Long 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

java.lang 中 Long 的使用

类型参数类型为 Long 的 java.lang 中的字段
static Class<Long> Long.TYPE
表示基本类型 long 的 Class 实例。

返回 Long 的 java.lang 中的方法
static Long | Long.decode(String nm) 将 String 解码成 Long。
static Long | Long.getLong(String nm) 确定具有指定名称的系统属性的 long 值。
static Long | Long.getLong(String nm, long val) 使用指定名称确定系统属性的 long 值。
static Long | Long.getLong(String nm, Long val) 使用指定名称返回系统属性的 long 值。
static Long | Long.valueOf(long l) 返回表示指定 long 值的 Long 实例。
static Long | Long.valueOf(String s) 返回保持指定 String 的值的 Long 对象。
static Long | Long.valueOf(String s, int radix) 当使用第二个参数给出的基数进行解析时，返回保持从指定 String 中提取的值的 Long 对象。

参数类型为 Long 的 java.lang 中的方法
int | Long.compareTo(Long anotherLong) 在数字上比较两个 Long 对象。
static Long | Long.getLong(String nm, Long val) 使用指定名称返回系统属性的 long 值。

javax.management.openmbean 中 Long 的使用

类型参数类型为 Long 的 javax.management.openmbean 中的字段
static SimpleType<Long> SimpleType.LONG
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Long 的值。

javax.management.timer 中 Long 的使用

返回 Long 的 javax.management.timer 中的方法
Long | Timer.getNbOccurences(Integer id) 获得与计时器通知关联的剩余出现数量的一个副本。
Long | TimerMBean.getNbOccurences(Integer id) 获得与计时器通知关联的剩余出现数量的一个副本。
Long | Timer.getPeriod(Integer id) 获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
Long | TimerMBean.getPeriod(Integer id) 获得与计时器通知关联的时段（以毫秒为单位）的一个副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Math 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Math
的使用

没有 java.lang.Math 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.NegativeArraySizeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NegativeArraySizeException
的使用

使用 NegativeArraySizeException 的软件包
java.lang.reflect 提供类和接口，以获得关于类和对象的反射信息。

java.lang.reflect 中 NegativeArraySizeException 的使用

抛出 NegativeArraySizeException 的 java.lang.reflect 中的方法
static Object | Array.newInstance(Class<?> componentType, int... dimensions) 创建一个具有指定的组件类型和维度的新数组。
static Object | Array.newInstance(Class<?> componentType, int length) 创建一个具有指定的组件类型和长度的新数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.NoClassDefFoundError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NoClassDefFoundError
的使用

没有 java.lang.NoClassDefFoundError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.NoSuchFieldError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NoSuchFieldError
的使用

没有 java.lang.NoSuchFieldError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.NoSuchFieldException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NoSuchFieldException
的使用

使用 NoSuchFieldException 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 NoSuchFieldException 的使用

抛出 NoSuchFieldException 的 java.lang 中的方法
Field | Class.getDeclaredField(String name) 返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。
Field | Class.getField(String name) 返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.NoSuchMethodError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NoSuchMethodError
的使用

没有 java.lang.NoSuchMethodError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.NoSuchMethodException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NoSuchMethodException
的使用

使用 NoSuchMethodException 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.relation | 提供 Relation Service 的定义。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

java.lang 中 NoSuchMethodException 的使用

抛出 NoSuchMethodException 的 java.lang 中的方法
Constructor<T> | Class.getConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
Constructor<T> | Class.getDeclaredConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
Method | Class.getDeclaredMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
Method | Class.getMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。

javax.management.relation 中 NoSuchMethodException 的使用

抛出 NoSuchMethodException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。

javax.script 中 NoSuchMethodException 的使用

抛出 NoSuchMethodException 的 javax.script 中的方法
Object | Invocable.invokeFunction(String name, Object... args) 用于调用脚本中定义的顶层程序和函数。
Object | Invocable.invokeMethod(Object thiz, String name, Object... args) 对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.NullPointerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NullPointerException
的使用

使用 NullPointerException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.print | 为通用的打印 API 提供类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.awt 中 NullPointerException 的使用

抛出 NullPointerException 的 java.awt 中的方法
 void SplashScreen.setImageURL(URL imageURL)
更改闪现屏幕图像。

java.awt.print 中 NullPointerException 的使用

抛出 NullPointerException 的 java.awt.print 中的方法
abstract  void PrinterJob.setPageable(Pageable document)
查询 document，以获得页面数和 Pageable 实例 document 中保存的每个页面的 PageFormat 和 Printable。

javax.management 中 NullPointerException 的使用

抛出 NullPointerException 的 javax.management 中的方法
 boolean ObjectName.apply(ObjectName name)
测试此 ObjectName（可以是一个模式）是否与另一个 ObjectName 匹配。
static ObjectName ObjectName.getInstance(ObjectName name)
返回 ObjectName 的实例，该 ObjectName 可用于任何可使用给定对象的地方。
static ObjectName ObjectName.getInstance(String name)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, String key, String value)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。
 String ObjectName.getKeyProperty(String property)
获得与键属性中某个键相关联的值。
 boolean ObjectName.isPropertyValuePattern(String property)
检查键属性中与值关联的值是否为一个模式。
static String ObjectName.quote(String s)
返回给定 String 的有引号形式，使之适合包含在 ObjectName 中。
static String ObjectName.unquote(String q)
返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。

抛出 NullPointerException 的 javax.management 中的构造方法
ObjectName(String name)
根据给定的字符串构造一个对象名。
ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。
ObjectName(String domain, String key, String value)
构造只具有一个键属性的对象名。

org.xml.sax.helpers 中 NullPointerException 的使用

抛出 NullPointerException 的 org.xml.sax.helpers 中的方法
static Parser ParserFactory.makeParser()
已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Number 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Number
的使用

使用 Number 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util.concurrent.atomic | 类的小工具包，支持在单个变量上解除锁的线程安全编程。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.monitor | 提供 monitor 类的定义。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.datatype | XML/Java 类型映射关系。

java.awt 中 Number 的使用

返回 Number 的 java.awt 中的方法
Number | Button.AccessibleAWTButton.getCurrentAccessibleValue() 获取此对象的值，它是一个 Number。
Number | Checkbox.AccessibleAWTCheckbox.getCurrentAccessibleValue() 获取此对象的值，它是一个 Number。
Number | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getCurrentAccessibleValue() 获取此对象的值，它是一个 Number。
Number | Scrollbar.AccessibleAWTScrollBar.getCurrentAccessibleValue() 获取此对象的可访问值。
Number | MenuItem.AccessibleAWTMenuItem.getCurrentAccessibleValue() 以数字形式获取此对象的值。
Number | Button.AccessibleAWTButton.getMaximumAccessibleValue() 获取此对象的最大值，它是一个 Number。
Number | Checkbox.AccessibleAWTCheckbox.getMaximumAccessibleValue() 获取此对象的最大值，它是一个 Number。
Number | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getMaximumAccessibleValue() 获取此对象的最大值，它是一个 Number。
Number | Scrollbar.AccessibleAWTScrollBar.getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | MenuItem.AccessibleAWTMenuItem.getMaximumAccessibleValue() 以数字形式获取此对象的最大值。
Number | Button.AccessibleAWTButton.getMinimumAccessibleValue() 获取此对象的最小值，它是一个 Number。
Number | Checkbox.AccessibleAWTCheckbox.getMinimumAccessibleValue() 获取此对象的最小值，它是一个 Number。
Number | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getMinimumAccessibleValue() 获取此对象的最小值，它是一个 Number。
Number | Scrollbar.AccessibleAWTScrollBar.getMinimumAccessibleValue() 获取此对象的最小可访问值。
Number | MenuItem.AccessibleAWTMenuItem.getMinimumAccessibleValue() 以数字形式获取此对象的最小值。

参数类型为 Number 的 java.awt 中的方法
boolean | Button.AccessibleAWTButton.setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
boolean | Checkbox.AccessibleAWTCheckbox.setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
boolean | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
boolean | Scrollbar.AccessibleAWTScrollBar.setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
boolean | MenuItem.AccessibleAWTMenuItem.setCurrentAccessibleValue(Number n) 将此对象的值设置为数字。

java.lang 中 Number 的使用

java.lang 中 Number 的子类
class | Byte Byte 类将基本类型 byte 的值包装在一个对象中。
class | Double Double 类在对象中包装一个基本类型 double 的值。
class | Float Float 类在对象中包装一个基本类型 float 的值。
class | Integer Integer 类在对象中包装了一个基本类型 int 的值。
class | Long Long 类在对象中包装了基本类型 long 的值。
class | Short Short 类在对象中包装基本类型 short 的值。

java.math 中 Number 的使用

java.math 中 Number 的子类
class | BigDecimal 不可变的、任意精度的有符号十进制数。
class | BigInteger 不可变的任意精度的整数。

java.text 中 Number 的使用

返回 Number 的 java.text 中的方法
Number | NumberFormat.parse(String source) 解析给定字符串开头的文本，生成一个数值。
Number | ChoiceFormat.parse(String text, ParsePosition status) 解析输入文本中的一个 Number。
Number | DecimalFormat.parse(String text, ParsePosition pos) 解析字符串中的文本，以生成一个 Number。
abstract Number | NumberFormat.parse(String source, ParsePosition parsePosition) 如果可能则返回 Long （例如，在 [Long.MIN_VALUE, Long.MAX_VALUE] 范围内且没有小数），否则返回 Double。

java.util.concurrent.atomic 中 Number 的使用

java.util.concurrent.atomic 中 Number 的子类
class | AtomicInteger 可以用原子方式更新的 int 值。
class | AtomicLong 可以用原子方式更新的 long 值。

javax.accessibility 中 Number 的使用

返回 Number 的 javax.accessibility 中的方法
Number | AccessibleValue.getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | AccessibleValue.getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | AccessibleValue.getMinimumAccessibleValue() 以 Number 形式设置此对象的最小值。

参数类型为 Number 的 javax.accessibility 中的方法
 boolean AccessibleValue.setCurrentAccessibleValue(Number n)
以 Number 形式设置此对象的值。

javax.management 中 Number 的使用

参数类型为 Number 的 javax.management 中的方法
static ValueExp Query.value(Number val)
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

javax.management.monitor 中 Number 的使用

返回 Number 的 javax.management.monitor 中的方法
 Number CounterMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getDerivedGauge(ObjectName) 取代
 Number CounterMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGauge(ObjectName) 取代
 Number GaugeMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGauge(ObjectName) 取代
 Number GaugeMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGauge(ObjectName) 取代
 Number CounterMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
 Number CounterMonitorMBean.getDerivedGauge(ObjectName object)
获取指定的 MBean 的派生尺度。
 Number GaugeMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
 Number GaugeMonitorMBean.getDerivedGauge(ObjectName object)
获取指定的 MBean 的派生尺度。
 Number GaugeMonitor.getHighThreshold()
获取所有所观察的 MBean 的公共高阈值。
 Number GaugeMonitorMBean.getHighThreshold()
获取高阈值。
 Number CounterMonitor.getInitThreshold()
获取所有观察对象的公共初始阈值。
 Number CounterMonitorMBean.getInitThreshold()
获取所有 observed 对象的公共初始阈值。
 Number GaugeMonitor.getLowThreshold()
获取所有观察到的 MBean 的公共低阈值。
 Number GaugeMonitorMBean.getLowThreshold()
获取低阈值。
 Number CounterMonitor.getModulus()
获取所有观察到的 MBeans 共同的模值。
 Number CounterMonitorMBean.getModulus()
获取模值。
 Number CounterMonitor.getOffset()
获取所有观察到的 MBeans 共同的偏移量值。
 Number CounterMonitorMBean.getOffset()
获取偏移值。
 Number CounterMonitor.getThreshold()
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getThreshold(ObjectName) 取代
 Number CounterMonitorMBean.getThreshold()
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getThreshold(ObjectName) 取代
 Number CounterMonitor.getThreshold(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取指定对象的当前阈值，否则将为 null。
 Number CounterMonitorMBean.getThreshold(ObjectName object)
获取指定 MBean 的阈值。

参数类型为 Number 的 javax.management.monitor 中的方法
 void CounterMonitor.setInitThreshold(Number value)
设置所有观察对象的共同初始阈值。
 void CounterMonitorMBean.setInitThreshold(Number value)
设置所有观察到的 MBeans 的公共初始阈值。
 void CounterMonitor.setModulus(Number value)
设置所有观察到的 MBeans 共同的模值。
 void CounterMonitorMBean.setModulus(Number value)
设置模值。
 void CounterMonitor.setOffset(Number value)
设置所有观察到的 MBeans 共同的偏移量值。
 void CounterMonitorMBean.setOffset(Number value)
设置偏移量值。
 void CounterMonitor.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitor.setInitThreshold(java.lang.Number) 取代
 void CounterMonitorMBean.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.setInitThreshold(java.lang.Number) 取代
 void GaugeMonitor.setThresholds(Number highValue, Number lowValue)
设置所有观察到的 MBean 的公共高、低阈值。
 void GaugeMonitorMBean.setThresholds(Number highValue, Number lowValue)
设置高、低阈值。

javax.swing 中 Number 的使用

返回 Number 的 javax.swing 中的方法
Number | JSpinner.AccessibleJSpinner.getCurrentAccessibleValue() 获取此对象数字形式的值。
Number | JSlider.AccessibleJSlider.getCurrentAccessibleValue() 获取此对象的可访问值。
Number | JProgressBar.AccessibleJProgressBar.getCurrentAccessibleValue() 获取此对象的可访问值。
Number | JScrollBar.AccessibleJScrollBar.getCurrentAccessibleValue() 获取此对象的可访问值。
Number | JSplitPane.AccessibleJSplitPane.getCurrentAccessibleValue() 获取此对象的可访问值。
Number | AbstractButton.AccessibleAbstractButton.getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | JInternalFrame.AccessibleJInternalFrame.getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | JSpinner.AccessibleJSpinner.getMaximumAccessibleValue() 获取此对象数字形式的最大值。
Number | JSlider.AccessibleJSlider.getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | JProgressBar.AccessibleJProgressBar.getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | JScrollBar.AccessibleJScrollBar.getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | JSplitPane.AccessibleJSplitPane.getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | AbstractButton.AccessibleAbstractButton.getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | JInternalFrame.AccessibleJInternalFrame.getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | JSpinner.AccessibleJSpinner.getMinimumAccessibleValue() 获取此对象数字形式的最小值。
Number | JSlider.AccessibleJSlider.getMinimumAccessibleValue() 获取此对象的最小可访问值。
Number | JProgressBar.AccessibleJProgressBar.getMinimumAccessibleValue() 获取此对象的最小可访问值。
Number | JScrollBar.AccessibleJScrollBar.getMinimumAccessibleValue() 获取此对象的最小可访问值。
Number | JSplitPane.AccessibleJSplitPane.getMinimumAccessibleValue() 获取此对象的最小可访问值。
Number | AbstractButton.AccessibleAbstractButton.getMinimumAccessibleValue() 以 Number 形式获取此对象的最小值。
Number | JInternalFrame.AccessibleJInternalFrame.getMinimumAccessibleValue() 以 Number 形式获取此对象的最小值。
Number | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getMinimumAccessibleValue() 以 Number 形式获取此对象的最小值。
Number | SpinnerNumberModel.getNumber() 返回该序列的当前元素的值。
Number | SpinnerNumberModel.getStepSize() 返回由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。

参数类型为 Number 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.numberFilter(RowFilter.ComparisonType type, Number number, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Number 值的条目。
 boolean JSpinner.AccessibleJSpinner.setCurrentAccessibleValue(Number n)
将此对象的值设置为数字。
 boolean JSlider.AccessibleJSlider.setCurrentAccessibleValue(Number n)
将此对象的值设置为数字。
 boolean JProgressBar.AccessibleJProgressBar.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 boolean JScrollBar.AccessibleJScrollBar.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 boolean JSplitPane.AccessibleJSplitPane.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 boolean AbstractButton.AccessibleAbstractButton.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 boolean JInternalFrame.AccessibleJInternalFrame.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 boolean JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 void SpinnerNumberModel.setStepSize(Number stepSize)
更改由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。

参数类型为 Number 的 javax.swing 中的构造方法
SpinnerNumberModel(Number value, Comparable minimum, Comparable maximum, Number stepSize)
构造一个表示从 minimum 到 maximum 的闭区间数字序列的 SpinnerModel。

javax.xml.datatype 中 Number 的使用

返回 Number 的 javax.xml.datatype 中的方法
abstract  Number Duration.getField(DatatypeConstants.Field field)
获取字段的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.NumberFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NumberFormatException
的使用

使用 NumberFormatException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。

java.awt 中 NumberFormatException 的使用

抛出 NumberFormatException 的 java.awt 中的方法
static Color Color.decode(String nm)
将 String 转换成整数，并返回指定的不透明 Color。

java.lang 中 NumberFormatException 的使用

抛出 NumberFormatException 的 java.lang 中的方法
static Long | Long.decode(String nm) 将 String 解码成 Long。
static Integer | Integer.decode(String nm) 将 String 解码为 Integer。
static Short | Short.decode(String nm) 将 String 解码为 Short。
static Byte | Byte.decode(String nm) 将 String 解码为 Byte。
boolean | Package.isCompatibleWith(String desired) 比较此包的规范版本和所需版本。
static byte | Byte.parseByte(String s) 将 string 参数解析为有符号的十进制 byte。
static byte | Byte.parseByte(String s, int radix) 将 string 参数解析为一个有符号的 byte，其基数由第二个参数指定。
static double | Double.parseDouble(String s) 返回一个新的 double 值，该值被初始化为用指定 String 表示的值，这与 Double 类的 valueOf 方法一样。
static float | Float.parseFloat(String s) 返回一个新的 float 值，该值被初始化为用指定 String 表示的值，这与 Float 类的 valueOf 方法一样。
static int | Integer.parseInt(String s) 将字符串参数作为有符号的十进制整数进行解析。
static int | Integer.parseInt(String s, int radix) 使用第二个参数指定的基数，将字符串参数解析为有符号的整数。
static long | Long.parseLong(String s) 将 string 参数解析为有符号十进制 long。
static long | Long.parseLong(String s, int radix) 将 string 参数解析为有符号的 long，基数由第二个参数指定。
static short | Short.parseShort(String s) 将字符串参数解析为有符号的十进制 short。
static short | Short.parseShort(String s, int radix) 将字符串参数解析为由第二个参数指定的基数中的有符号的 short。
static Long | Long.valueOf(String s) 返回保持指定 String 的值的 Long 对象。
static Integer | Integer.valueOf(String s) 返回保存指定的 String 的值的 Integer 对象。
static Short | Short.valueOf(String s) 返回一个保持指定 String 所给出的值的 Short 对象。
static Byte | Byte.valueOf(String s) 返回一个保持指定 String 所给出的值的 Byte 对象。
static Double | Double.valueOf(String s) 返回保存用参数字符串 s 表示的 double 值的 Double 对象。
static Float | Float.valueOf(String s) 返回保存用参数字符串 s 表示的 float 值的 Float 对象。
static Long | Long.valueOf(String s, int radix) 当使用第二个参数给出的基数进行解析时，返回保持从指定 String 中提取的值的 Long 对象。
static Integer | Integer.valueOf(String s, int radix) 返回一个 Integer 对象，该对象中保存了用第二个参数提供的基数进行解析时从指定的 String 中提取的值。
static Short | Short.valueOf(String s, int radix) 返回一个 Short 对象，该对象保持从指定的 String 中提取的值，该值是在使用第二个参数给出的基数对指定字符串进行解析时提取的。
static Byte | Byte.valueOf(String s, int radix) 返回一个 Byte 对象，该对象保持从指定的 String 中提取的值，该值是在用第二个参数所给定的基数对指定字符串进行解析时提取的。

抛出 NumberFormatException 的 java.lang 中的构造方法
Byte(String s)
构造一个新分配的 Byte 对象，以表示 String 参数所指示的 byte 值。
Double(String s)
构造一个新分配的 Double 对象，表示用字符串表示的 double 类型的浮点值。
Float(String s)
构造一个新分配的 Float 对象，它表示用字符串表示的 float 类型的浮点值。
Integer(String s)
构造一个新分配的 Integer 对象，它表示 String 参数所指示的 int 值。
Long(String s)
构造新分配的 Long 对象，表示由 String 参数指示的 long 值。
Short(String s)
构造一个新分配的 Short 对象，用来表示 String 参数所指示的 short 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Object 的使用 (Java 2 Platform SE 6)

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM 2 Platform
Standard Ed. 6

上一个 下一个

框架 无框架

类 java.lang.Object
的使用

使用 Object 的软件包

java.applet

提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

java.awt

包含用于创建用户界面和绘制图形图像的所有类。

java.awt.color

提供用于颜色空间的类。

java.awt.datatransfer

提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.dnd

Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.event

提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt.font

提供与字体相关的类和接口。

java.awt.geom

提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.im

提供输入方法框架所需的类和接口。

java.awt.im.spi

提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.image

提供创建和修改图像的各种类。

java.awt.image.renderable

提供用于生成与呈现无关的图像的类和接口。

java.awt.print

为通用的打印 API 提供类和接口。

java.beans

包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans.beancontext

提供与 bean 上下文有关的类和接口。

java.io

通过数据流、序列化和文件系统提供系统输入和输出。

java.lang

提供利用 Java 编程语言进行程序设计的基础类。

java.lang.annotation

为 Java 编程语言注释设施提供库支持。

java.lang.instrument

提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.management

提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.ref

提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。

java.lang.reflect

提供类和接口，以获得关于类和对象的反射信息。

java.math

提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。

java.net

为实现网络应用程序提供类。

java.nio

定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio.channels

定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels.spi

用于 java.nio.channels 包的服务提供者类。

java.nio.charset

定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.nio.charset.spi

java.nio.charset 包的服务提供者类。

java.rmi

提供 RMI 包。

java.rmi.activation

为 RMI 对象激活提供支持。

java.rmi.dgc

为 RMI 分布式垃圾回收提供了类和接口。

java.rmi.registry

提供 RMI 注册表的一个类和两个接口。

java.rmi.server

提供支持服务器端 RMI 的类和接口。

java.security

为安全框架提供类和接口。

java.security.acl

此包中的类和接口已经被 java.security 包中的类取代。

java.security.cert

提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.spec

提供密钥规范和算法参数规范的类和接口。

java.sql

提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.text

提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text.spi

java.text 包中类的服务提供者类。

java.util

包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util.concurrent

在并发编程中很常用的实用工具类。

java.util.concurrent.atomic

类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.locks

为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.jar

提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.logging

提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.prefs

此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.regex

用于匹配字符序列与正则表达式指定模式的类。

java.util.spi

java.util 包中类的服务提供者类。

java.util.zip

提供用于读写标准 ZIP 和 GZIP 文件格式的类。

javax.accessibility

定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.activation

javax.activity

包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。

javax.annotation.processing

用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.crypto

为加密操作提供类和接口。

javax.crypto.spec

为密钥规范和算法参数规范提供类和接口。

javax.imageio

Java Image I/O API 的主要包。

javax.imageio.metadata

用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio.plugins.bmp

包含供内置 BMP 插件使用的公共类的包。

javax.imageio.plugins.jpeg

支持内置 JPEG 插件的类。

javax.imageio.spi

包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.stream

Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.lang.model.element

用于 Java 编程语言的模型元素的接口。

javax.lang.model.type

用来为 Java 编程语言类型建立模型的接口。

javax.lang.model.util

用来帮助处理程序元素和类型的实用工具。

javax.management

提供 Java Management Extensions 的核心类。

javax.management.loading

提供实现高级动态加载的类。

javax.management.modelmbean

提供了 ModelMBean 类的定义。

javax.management.monitor

提供 monitor 类的定义。

javax.management.openmbean

提供开放数据类型和 Open MBean 描述符类。

javax.management.relation

提供 Relation Service 的定义。

javax.management.remote

对 JMX MBean 服务器进行远程访问使用的接口。

javax.management.remote.rmi

RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.timer

提供对 Timer MBean（计时器 MBean）的定义。

javax.naming

为访问命名服务提供类和接口。

javax.naming.directory

扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming.event

在访问命名和目录服务时提供对事件通知的支持。

javax.naming.ldap

提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.spi

提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.net

提供用于网络应用程序的类。

javax.net.ssl

提供用于安全套接字包的类。

javax.print

为 JavaTM Print Service API 提供了主要类和接口。

javax.print.attribute

提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

javax.print.attribute.standard

包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.event

包 javax.print.event 包含事件类和侦听器接口。

javax.rmi

包含 RMI-IIOP 的用户 API。

javax.rmi.CORBA

包含用于 RMI-IIOP 的可移植性 API。

javax.rmi.ssl

通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

javax.script

脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.security.auth

此包提供用于进行验证和授权的框架。

javax.security.auth.callback

此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。

javax.security.auth.kerberos

此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth.login

此包提供可插入的验证框架。

javax.security.auth.x500

此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

javax.security.cert

为公钥证书提供类。

javax.security.sasl

包含用于支持 SASL 的类和接口。

javax.sound.midi

提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi.spi

在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.sampled

提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled.spi

在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sql

为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql.rowset

JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset.serial

提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

javax.sql.rowset.spi

第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.swing

提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing.border

提供围绕 Swing 组件绘制特殊边框的类和接口。

javax.swing.colorchooser

包含供 JColorChooser 组件使用的类和接口。

javax.swing.event

供 Swing 组件触发的事件使用。

javax.swing.filechooser

包含 JFileChooser 组件使用的类和接口。

javax.swing.plaf

提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.plaf.basic

提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.metal

提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.multi

提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf.synth

Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.table

提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.text

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html.parser

提供默认的 HTML 解析器以及支持类。

javax.swing.text.rtf

提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing.tree

提供处理 javax.swing.JTree 的类和接口。

javax.swing.undo

允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.tools

为能够从程序（例如，编译器）中调用的工具提供接口。

javax.transaction

包含解组期间通过 ORB 机制抛出的三个异常。

javax.transaction.xa

提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.xml

根据 XML 规范定义核心 XML 常量和功能。

javax.xml.bind

为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind.annotation

定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation.adapters

XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。

javax.xml.bind.attachment

此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。

javax.xml.bind.helpers

仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.util

有用的客户端实用工具类。

javax.xml.crypto

用于 XML 加密的通用类。

javax.xml.crypto.dom

javax.xml.crypto 包的特定于 DOM 的类。

javax.xml.crypto.dsig

用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig.dom

javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto.dsig.keyinfo

用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.spec

XML 数字签名的参数类。

javax.xml.datatype

XML/Java 类型映射关系。

javax.xml.namespace

XML 名称空间处理。

javax.xml.parsers

提供允许处理 XML 文档的类。

javax.xml.soap

提供用于创建和构建 SOAP 消息的 API。

javax.xml.stream

javax.xml.stream.events

javax.xml.stream.util

javax.xml.transform

此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform.dom

此包实现特定于 DOM 的转换 API。

javax.xml.transform.sax

此包实现特定于 SAX2 的转换 API。

javax.xml.transform.stax

提供特定于 StAX 的转换 API。

javax.xml.transform.stream

此包实现特定于流和 URI 的转换 API。

javax.xml.validation

此包提供了用于 XML 文档验证的 API。

javax.xml.ws

此包包含核心 JAX-WS API。

javax.xml.ws.handler.soap

该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws.http

该包定义特定于 HTTP 绑定的 API。

javax.xml.ws.soap

该包定义特定于 SOAP 绑定的 API。

javax.xml.ws.spi

该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.xpath

此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

org.ietf.jgss

此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.omg.CORBA

提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA_2_3

CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。

org.omg.CORBA_2_3.portable

提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。

org.omg.CORBA.DynAnyPackage

提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。

org.omg.CORBA.ORBPackage

提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。

org.omg.CORBA.portable

提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA.TypeCodePackage

提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。

org.omg.CosNaming

为 Java IDL 提供命名服务。

org.omg.CosNaming.NamingContextExtPackage

此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

org.omg.CosNaming.NamingContextPackage

此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.Dynamic

此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。

org.omg.DynamicAny

提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny.DynAnyFactoryPackage

此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。

org.omg.DynamicAny.DynAnyPackage

此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。

org.omg.IOP

此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP.CodecFactoryPackage

此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。

org.omg.IOP.CodecPackage

此包根据 IOP::Codec IDL 接口定义生成。

org.omg.Messaging

此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。

org.omg.PortableInterceptor

提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor.ORBInitInfoPackage

此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。

org.omg.PortableServer

提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer.CurrentPackage

提供各种方法实现，这些实现能够访问调用方法的对象的身份。

org.omg.PortableServer.POAManagerPackage

封装 POA 关联的处理状态。

org.omg.PortableServer.POAPackage

允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer.ServantLocatorPackage

提供定位 servant 的类和接口。

org.omg.stub.java.rmi

包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

org.w3c.dom

为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom.bootstrap

org.w3c.dom.events

org.w3c.dom.ls

org.xml.sax

此包提供了核心 SAX API。

org.xml.sax.ext

此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.helpers

此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 中 Object 的使用

java.applet 中 Object 的子类

class

Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

protected  class

Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

java.awt 中 Object 的使用

java.awt 中 Object 的子类

class

AlphaComposite
AlphaComposite 类实现一些基本的 alpha 合成规则，将源色与目标色组合，在图形和图像中实现混合和透明效果。

class

AWTError
当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。

class

AWTEvent
所有 AWT 事件的根事件类。

class

AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

class

AWTException
表示发生了 Absract Window Toolkit 异常。

class

AWTKeyStroke
AWTKeyStroke 表示键盘（或等效输入设备）上的键操作。

class

AWTPermission
此类用于 AWT 权限。

class

BasicStroke
BasicStroke 类定义针对图形图元轮廓呈现属性的一个基本集合，这些图元使用 Graphics2D 对象呈现，而该对象的 Stroke 属性设置为此 BasicStroke。

class

BorderLayout
这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。

class

BufferCapabilities
缓冲区的能力和属性。

static class

BufferCapabilities.FlipContents
页面翻转后可能的后台缓冲区内容的一个类型安全的枚举

class

Button
此类创建一个标签按钮。

protected  class

Button.AccessibleAWTButton
此类实现对 Button 类的可访问性支持。

class

Canvas
Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。

protected  class

Canvas.AccessibleAWTCanvas
此类实现对 Canvas 类的可访问性支持。

class

CardLayout
CardLayout 对象是容器的布局管理器。

class

Checkbox
复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。

protected  class

Checkbox.AccessibleAWTCheckbox
此类实现对 Checkbox 类的可访问性支持。

class

CheckboxGroup
CheckboxGroup 类用于集合 Checkbox 按钮集。

class

CheckboxMenuItem
此类表示一个可包括在菜单中的复选框。

protected  class

CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。

class

Choice
Choice 类表示一个弹出式选择菜单。

protected  class

Choice.AccessibleAWTChoice
此类实现对 Choice 类的可访问性支持。

class

Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。

class

Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。

protected  class

Component.AccessibleAWTComponent
用来为可访问性提供默认支持的 Component 的内部类。

protected  class

Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）

protected  class

Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）

protected  class

Component.BltBufferStrategy
用于将屏幕外的画面以位图传输方式传输到一个组件的内部类。

protected  class

Component.FlipBufferStrategy
在组件上翻转缓冲区的内部类。

class

ComponentOrientation
ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。

class

Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。

protected  class

Container.AccessibleAWTContainer
用于对可访问性提供默认支持的 Container 内部类。

protected  class

Container.AccessibleAWTContainer.AccessibleContainerHandler
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

class

ContainerOrderFocusTraversalPolicy
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。

class

Cursor
封装鼠标光标的位图表示形式的类。

class

DefaultFocusTraversalPolicy
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。

class

DefaultKeyboardFocusManager
AWT 应用程序的默认 KeyboardFocusManager。

class

Desktop
Desktop 类允许 Java 应用程序启动已在本机桌面上注册的关联应用程序，以处理 URI 或文件。

class

Dialog
Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。

protected  class

Dialog.AccessibleAWTDialog
此类实现对 Dialog 类的可访问性支持。

class

Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。

class

DisplayMode
DisplayMode 类封装 GraphicsDevice 的位深、高度、宽度和刷新率。

class

Event
注：Event 类已废弃，只可用于向后兼容。

class

EventQueue
EventQueue 是一个与平台无关的类，它将来自于底层同位体类和受信任的应用程序类的事件列入队列。

class

FileDialog
FileDialog 类显示一个对话框窗口，用户可以从中选择文件。

class

FlowLayout
流布局用于安排有向流中的组件，这非常类似于段落中的文本行。

class

FocusTraversalPolicy
FocusTraversalPolicy 定义一种顺序，按此顺序遍历具有特定焦点循环根的 Component。

class

Font
Font 类表示字体，可以使用它以可见方式呈现文本。

class

FontFormatException
此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。

class

FontMetrics
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。

class

Frame
Frame 是带有标题和边框的顶层窗口。

protected  class

Frame.AccessibleAWTFrame
此类实现对 Frame 类的可访问性支持。

class

GradientPaint
GradientPaint 类提供了使用线性颜色渐变模式填充 Shape 的方法。

class

Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。

class

Graphics2D
此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。

class

GraphicsConfigTemplate
GraphicsConfigTemplate 类用于获得有效的 GraphicsConfiguration。

class

GraphicsConfiguration
GraphicsConfiguration 类描述图形目标（如打印机或监视器）的特征。

class

GraphicsDevice
GraphicsDevice 类描述可以在特定图形环境中使用的图形设备。

class

GraphicsEnvironment
GraphicsEnvironment 类描述了 Java(tm) 应用程序在特定平台上可用的 GraphicsDevice 对象和 Font 对象的集合。

class

GridBagConstraints
GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。

class

GridBagLayout
GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。

class

GridBagLayoutInfo
GridBagLayoutInfo 是 GridBagLayout 布局管理器的一个实用工具类。

class

GridLayout
GridLayout 类是一个布局处理器，它以矩形网格形式对容器的组件进行布置。

class

HeadlessException
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。

class

IllegalComponentStateException
当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

class

Image
抽象类 Image 是表示图形图像的所有类的超类。

class

ImageCapabilities
图像的功能和属性。

class

Insets
Insets 对象是容器边界的表示形式。

class

JobAttributes
控制打印作业的属性集合。

static class

JobAttributes.DefaultSelectionType
可能的默认选择状态的类型安全的枚举。

static class

JobAttributes.DestinationType
可能的作业目标的类型安全枚举。

static class

JobAttributes.DialogType
显示给用户的可能对话框的类型安全枚举。

static class

JobAttributes.MultipleDocumentHandlingType
可能的多副本处理状态的类型安全枚举。

static class

JobAttributes.SidesType
可能的多页整版的类型安全枚举。

class

KeyboardFocusManager
KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。

class

Label
Label 对象是一个可在容器中放置文本的组件。

protected  class

Label.AccessibleAWTLabel
此类实现对 Label 类的可访问性支持。

class

LinearGradientPaint
LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。

class

List
List 组件为用户提供了一个可滚动的文本项列表。

protected  class

List.AccessibleAWTList
此类实现 List 类的可访问性支持。

protected  class

List.AccessibleAWTList.AccessibleAWTListChild
此类实现 List 子级的可访问性支持。

class

MediaTracker
MediaTracker 类是一个跟踪多种媒体对象状态的实用工具类。

class

Menu
Menu 对象是从菜单栏部署的下拉式菜单组件。

protected  class

Menu.AccessibleAWTMenu
菜单的内部类，用于为可访问性提供默认支持。

class

MenuBar
MenuBar 类封装绑定到框架的菜单栏的平台概念。

protected  class

MenuBar.AccessibleAWTMenuBar
菜单栏的内部类，用于为可访问性提供默认支持。

class

MenuComponent
抽象类 MenuComponent 是所有与菜单相关的组件的超类。

protected  class

MenuComponent.AccessibleAWTMenuComponent
用于为可访问性提供默认支持的 MenuComponent 的内部类。

class

MenuItem
菜单中的所有项必须属于类 MenuItem 或其子类之一。

protected  class

MenuItem.AccessibleAWTMenuItem
用于为可访问性提供默认支持的 MenuItem 的内部类。

class

MenuShortcut
表示 MenuItem 键盘加速器的 MenuShortcut 类。

class

MouseInfo
MouseInfo 提供获取有关鼠标信息的方法，如鼠标指针位置和鼠标按钮数。

class

MultipleGradientPaint
这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。

class

PageAttributes
用来控制打印页面输出的属性集。

static class

PageAttributes.ColorType
可能颜色状态的类型安全的枚举。

static class

PageAttributes.MediaType
可能的纸张大小的类型安全的枚举。

static class

PageAttributes.OrientationRequestedType
可能打印方向的类型安全的枚举。

static class

PageAttributes.OriginType
可能原点的类型安全的枚举。

static class

PageAttributes.PrintQualityType
可能的打印质量的类型安全的枚举。

class

Panel
Panel 是最简单的容器类。

protected  class

Panel.AccessibleAWTPanel
此类实现 Panel 类的可访问性支持。

class

Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。

class

PointerInfo
描述指针位置的类。

class

Polygon
Polygon 类封装了坐标空间中封闭的二维区域的描述。

class

PopupMenu
此类实现能够在组件中的指定位置上动态弹出的菜单。

protected  class

PopupMenu.AccessibleAWTPopupMenu
用于为可访问性提供默认支持的 PopupMenu 的内部类。

class

PrintJob
启动并执行打印作业的抽象类。

class

RadialGradientPaint
RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。

class

Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

class

RenderingHints
RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。

static class

RenderingHints.Key
定义与 RenderingHints 一起使用的、用来控制呈现和图像管线中各种算法选择的所有键的基本类型。

class

Robot
此类用于为测试自动化、自运行演示程序和其他需要控制鼠标和键盘的应用程序生成本机系统输入事件。

class

Scrollbar
Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。

protected  class

Scrollbar.AccessibleAWTScrollBar
此类实现 Scrollbar 类的可访问性支持。

class

ScrollPane
实现用于单个子组件的自动水平和/或垂直滚动的容器类。

protected  class

ScrollPane.AccessibleAWTScrollPane
此类实现 ScrollPane 类的可访问性支持。

class

ScrollPaneAdjustable
此类表示 ScrollPane 的水平或垂直滚动条的状态。

class

SplashScreen
在 Java 虚拟机 (JVM) 启动之前，可以在应用程序启动时创建闪现屏幕。

class

SystemColor
封装表示系统中本机 GUI 对象颜色的象征性颜色的类。

class

SystemTray
SystemTray 类表示桌面的系统托盘。

class

TextArea
TextArea 对象是显示文本的多行区域。

protected  class

TextArea.AccessibleAWTTextArea
此类实现 TextArea 类的可访问性支持。

class

TextComponent
TextComponent 类是所有允许编辑文本的组件的超类。

protected  class

TextComponent.AccessibleAWTTextComponent
此类实现对 TextComponent 类的可访问性支持。

class

TextField
TextField 对象是允许编辑单行文本的文本组件。

protected  class

TextField.AccessibleAWTTextField
此类实现 TextField 类的可访问性支持。

class

TexturePaint
TexturePaint 类提供一种用被指定为 BufferedImage 的纹理填充 Shape 的方式。

class

Toolkit
此类是所有 Abstract Window Toolkit 实际实现的抽象超类。

class

TrayIcon
TrayIcon 对象表示可以添加到系统托盘的托盘图标。

class

Window
Window 对象是一个没有边界和菜单栏的顶层窗口。

protected  class

Window.AccessibleAWTWindow
此类实现对 Window 类的可访问性支持。

声明为 Object 的 java.awt 中的字段

Object

Event.arg
事件的任意参数。

Object

Event.target
目标组件。

static Object

Image.UndefinedProperty
每当获得某个不是为特定图像定义的属性时，应返回 UndefinedProperty 对象。

static Object

RenderingHints.VALUE_ALPHA_INTERPOLATION_DEFAULT
Alpha 插值提示值——由实现选择对性能和质量进行良好权衡的 alpha 混合算法

static Object

RenderingHints.VALUE_ALPHA_INTERPOLATION_QUALITY
Alpha 插值提示值——选择偏重于精确度和视觉质量的 alpha 混合算法。

static Object

RenderingHints.VALUE_ALPHA_INTERPOLATION_SPEED
Alpha 插值提示值——选择偏重于计算速度的 alpha 混合算法。

static Object

RenderingHints.VALUE_ANTIALIAS_DEFAULT
抗锯齿提示值——使用由实现选择的默认抗锯齿模式完成呈现。

static Object

RenderingHints.VALUE_ANTIALIAS_OFF
抗锯齿提示值——在不使用抗锯齿模式的情况下完成呈现。

static Object

RenderingHints.VALUE_ANTIALIAS_ON
抗锯齿提示值——使用抗锯齿模式完成呈现。

static Object

RenderingHints.VALUE_COLOR_RENDER_DEFAULT
颜色呈现提示值——根据实现的选择执行颜色转换计算，以表示可用的性能和精确度之间的最佳权衡。

static Object

RenderingHints.VALUE_COLOR_RENDER_QUALITY
颜色呈现提示值——用最高的精确度和视觉质量执行颜色转换计算。

static Object

RenderingHints.VALUE_COLOR_RENDER_SPEED
颜色呈现提示值——最快地执行输出设备格式的颜色转换。

static Object

RenderingHints.VALUE_DITHER_DEFAULT
抖动提示值——对该实现选择的抖动使用默认值。

static Object

RenderingHints.VALUE_DITHER_DISABLE
抖动提示值——呈现几何形状时不抖动。

static Object

RenderingHints.VALUE_DITHER_ENABLE
抖动提示值——如果需要，在呈现几何形状时抖动。

static Object

RenderingHints.VALUE_FRACTIONALMETRICS_DEFAULT
字体小数规格提示值——用实现选择的精度定位字符字形。

static Object

RenderingHints.VALUE_FRACTIONALMETRICS_OFF
字体小数规格提示值——用舍入为像素边界的 advance width 定位字符字形。

static Object

RenderingHints.VALUE_FRACTIONALMETRICS_ON
字体小数规格提示值——用子像素精确度定位字符字形。

static Object

RenderingHints.VALUE_INTERPOLATION_BICUBIC
插值提示值—— 使用 X 和 Y 中的立方函数插入图像中整数坐标附近的 9 个样本，以生成一个颜色样本。

static Object

RenderingHints.VALUE_INTERPOLATION_BILINEAR
插值提示值——图像中最接近整数坐标样本的 4 种颜色样本被线性地插入，以生成一个颜色样本。

static Object

RenderingHints.VALUE_INTERPOLATION_NEAREST_NEIGHBOR
插值提示值——使用图像中最接近整数坐标样本的颜色样本。

static Object

RenderingHints.VALUE_RENDER_DEFAULT
呈现提示值——由实现选择对性能和质量进行良好权衡的呈现算法。

static Object

RenderingHints.VALUE_RENDER_QUALITY
呈现提示值——选择偏重输出质量的呈现算法。

static Object

RenderingHints.VALUE_RENDER_SPEED
呈现提示值——选择偏重输出速度的呈现算法。

static Object

RenderingHints.VALUE_STROKE_DEFAULT
笔划规范化控制提示值——根据给定实现的权衡，可以修改几何形状或保留原来的几何形状。

static Object

RenderingHints.VALUE_STROKE_NORMALIZE
笔划规范化控制提示值——几何形状应当规范化，以提高均匀性或直线间隔和整体美观。

static Object

RenderingHints.VALUE_STROKE_PURE
笔划规范化控制提示值——几何形状应该保持不变并使用子像素精确度呈现。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_DEFAULT
文本抗锯齿提示值——根据 RenderingHints.KEY_ANTIALIASING 提示或由实现选择的默认值完成文本呈现。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_GASP
文本抗锯齿提示值——文本呈现需要使用字体资源中的信息，这些信息指定了每个点大小是否适合应用 RenderingHints.VALUE_TEXT_ANTIALIAS_ON 或 RenderingHints.VALUE_TEXT_ANTIALIAS_OFF。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_HBGR
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素按从左到右为 B、G、R 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HBGR) 的三倍。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_HRGB
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，该 LCD 显示器子像素按从左到右为 R、G、B 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HRGB) 的三倍。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_VBGR
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VBGR) 的三倍。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_VRGB
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VRGB) 的三倍。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_OFF
文本抗锯齿提示值——不使用任何抗锯齿形式完成文本呈现。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_ON
文本抗锯齿提示值——使用某种抗锯齿形式完成文本呈现。

类型参数类型为 Object 的 java.awt 中的字段

protected  Map<String,Object>

Toolkit.desktopProperties

返回 Object 的 java.awt 中的方法

Object

GridBagConstraints.clone()
创建此网格包约束（grid bag constraint）的副本。

Object

JobAttributes.clone()
创建并返回此 JobAttributes 的一个副本。

Object

PageAttributes.clone()
创建并返回此 PageAttributes 的一个副本。

Object

BufferCapabilities.clone()

Object

Insets.clone()
创建此对象的副本。

Object

ImageCapabilities.clone()

Object

RenderingHints.clone()
创建此 RenderingHints 对象的一个副本，它与此 RenderingHints 对象具有相同的内容。

Object

RenderingHints.get(Object key)
返回指定键所映射的值。

Object

BorderLayout.getConstraints(Component comp)
获取指定组件的约束

Object

Toolkit.getDesktopProperty(String propertyName)
获取指定桌面属性的值。

Object[]

MediaTracker.getErrorsAny()
返回所有出错媒体的列表。

Object[]

MediaTracker.getErrorsID(int id)
返回具有出错的指定 ID 的媒体列表。

abstract  Object

Image.getProperty(String name, ImageObserver observer)
通过名称获取此图像的属性。

abstract  Object

Graphics2D.getRenderingHint(RenderingHints.Key hintKey)
返回呈现算法的单个首选项的值。

Object[]

Checkbox.getSelectedObjects()
返回包含复选框标签的数组 (length 1)，如果没有选定复选框，则返回 null。

Object[]

CheckboxMenuItem.getSelectedObjects()
返回一个数组（长度为 1)，它包含复选框菜单项的标签，如果没有选中复选框，则返回 null。

Object[]

Choice.getSelectedObjects()
返回包含当前选定项的数组（长度为 1）。

Object[]

List.getSelectedObjects()
获取对象数组中此滚动列表的选中项。

Object[]

ItemSelectable.getSelectedObjects()
返回选定项；如果没有选定的项，则返回 null。

protected  Object

MenuComponent.getTreeLock()
获取此组件的锁定对象（拥有该线程同步监视器的对象），该对象可用于 AWT 组件树和布局操作。

Object

Component.getTreeLock()
获取此组件用于 AWT 组件树和布局操作的锁定对象（拥有线程同步监视器的对象）。

protected  Object

Toolkit.lazilyLoadDesktopProperty(String name)
一个对桌面属性值延迟计算的机会。

Object

RenderingHints.put(Object key, Object value)
将指定 key 映射到此 RenderingHints 对象中指定的 value。

protected  Object

AWTKeyStroke.readResolve()
返回 AWTKeyStroke 的一个缓存实例（或 AWTKeyStroke 的子类），它与此实例相等。

Object

RenderingHints.remove(Object key)
从此 RenderingHints 对象中移除键和它所对应的值。

返回变量类型为 Object 的类型的 java.awt 中的方法

Set<Map.Entry<Object,Object>>

RenderingHints.entrySet()
返回此 RenderingHints 中所包含映射关系的 Set 视图。

Set<Map.Entry<Object,Object>>

RenderingHints.entrySet()
返回此 RenderingHints 中所包含映射关系的 Set 视图。

Set<Object>

RenderingHints.keySet()
返回此 RenderingHints 中所包含键的 Set 视图。

Collection<Object>

RenderingHints.values()
返回此 RenderinHints 中所包含键的 Collection 视图。

参数类型为 Object 的 java.awt 中的方法

boolean

Component.action(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。

void

Container.add(Component comp, Object constraints)
将指定的组件添加到此容器的尾部。

void

Container.add(Component comp, Object constraints, int index)
使用指定约束，将指定组件添加到此容器的指定索引所在的位置上。

protected  void

ScrollPane.addImpl(Component comp, Object constraints, int index)
将指定的组件添加到此滚动窗格容器。

protected  void

Container.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上。

void

GridBagLayout.addLayoutComponent(Component comp, Object constraints)
使用指定 constraints 对象将指定组件添加到布局中。

void

CardLayout.addLayoutComponent(Component comp, Object constraints)
将指定的组件添加到此卡片布局的内部名称表。

void

BorderLayout.addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。

void

LayoutManager2.addLayoutComponent(Component comp, Object constraints)
使用指定约束对象，将指定组件添加到布局。

boolean

RenderingHints.containsKey(Object key)
如果此 RenderingHints 包含指定键的映射关系，则返回 true。

boolean

RenderingHints.containsValue(Object value)
如果此 RenderingHints 将一个或多个键映射到指定值，则返回 true。

boolean

DisplayMode.equals(Object dm)
指示其他某个对象是否与此对象“相等”。

boolean

JobAttributes.equals(Object obj)
确定两个 JobAttributes 是否相等。

boolean

PageAttributes.equals(Object obj)
确定两个 PageAttributes 是否相等。

boolean

MenuShortcut.equals(Object obj)
返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。

boolean

Point.equals(Object obj)
确定两个点是否相等。

boolean

AWTKeyStroke.equals(Object anObject)
如果此对象与指定对象相同，则返回 true。

boolean

Insets.equals(Object obj)
检查两个 insets 对象是否等价。

boolean

Rectangle.equals(Object obj)
检查两个矩形是否相等。

boolean

BasicStroke.equals(Object obj)
测试指定对象与此 BasicStroke 是否相等，首先测试指定对象是否是一个 BasicStroke，然后将其宽度、连接、cap、斜接限制、虚线和虚线相位属性与 BasicStroke 的那些属性进行比较。

boolean

AlphaComposite.equals(Object obj)
确定指定的对象是否等于此 AlphaComposite。

boolean

Color.equals(Object obj)
确定另一个对象是否与此 Color 相同。

boolean

RenderingHints.equals(Object o)
对指定的 Object 与此 RenderingHints 进行相等性比较。

boolean

RenderingHints.Key.equals(Object o)
用于所有 Key 对象的 equals 方法将返回与等号运算符 '==' 相同的结果。

boolean

Font.equals(Object obj)
将此 Font 对象与指定 Object 进行比较。

boolean

Dimension.equals(Object obj)
检查两个 dimension 对象是否具有相同的值。

protected  void

KeyboardFocusManager.firePropertyChange(String propertyName, Object oldValue, Object newValue)
激发 PropertyChangeEvent 以响应绑定属性中的更改。

protected  void

Component.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告 Object 属性的绑定属性改变。

protected  void

KeyboardFocusManager.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
激发 PropertyChangeEvent 以响应可否决属性中的更改。

Object

RenderingHints.get(Object key)
返回指定键所映射的值。

Component

BorderLayout.getLayoutComponent(Container target, Object constraints)
基于目标 Container 的组件方向，返回给定约束位置对应的组件。

Component

BorderLayout.getLayoutComponent(Object constraints)
获取使用给定约束添加的组件。

boolean

Component.gotFocus(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。

abstract  boolean

RenderingHints.Key.isCompatibleValue(Object val)
如果指定对象是此 Key 的有效值，则返回 true。

boolean

Component.lostFocus(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。

Object

RenderingHints.put(Object key, Object value)
将指定 key 映射到此 RenderingHints 对象中指定的 value。

Object

RenderingHints.remove(Object key)
从此 RenderingHints 对象中移除键和它所对应的值。

protected  void

Toolkit.setDesktopProperty(String name, Object newValue)
将指定桌面属性设置为指定值，并触发一个属性更改事件，以通知所有侦听器该值已更改。

abstract  void

Graphics2D.setRenderingHint(RenderingHints.Key hintKey, Object hintValue)
为呈现算法设置单个首选项的值。

void

AWTEvent.setSource(Object newSource)
将事件的目标更改为新的源。

参数类型为 Object 的 java.awt 中的构造方法

AWTEvent(Object source, int id)
使用指定的源对象和类型构造一个 AWTEvent 对象。

Event(Object target, int id, Object arg)
注：Event 类已废弃，只可用于向后兼容。

Event(Object target, long when, int id, int x, int y, int key, int modifiers)
注：Event 类已废弃，只可用于向后兼容。

Event(Object target, long when, int id, int x, int y, int key, int modifiers, Object arg)
注：Event 类已废弃，只可用于向后兼容。

RenderingHints(RenderingHints.Key key, Object value)
构造一个具有指定键/值对的新对象。

java.awt.color 中 Object 的使用

java.awt.color 中 Object 的子类

class

CMMException
如果本机 CMM 返回一个错误，则抛出此异常。

class

ColorSpace
此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。

class

ICC_ColorSpace
ICC_ColorSpace 类是抽象 ColorSpace 类的实现。

class

ICC_Profile
与设备无关和设备相关颜色空间的颜色配置文件数据表示形式，该表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。

class

ICC_ProfileGray
ICC_Profile 类的子类，表示满足以下标准的配置文件：配置文件的颜色空间类型是 TYPE_GRAY，并且配置文件包括 grayTRCTag 和 mediaWhitePointTag 标记。

class

ICC_ProfileRGB
ICC_ProfileRGB 类是 ICC_Profile 类的子类，它表示满足以下标准的配置文件： 配置文件的颜色空间类型是 RGB。

class

ProfileDataException
当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

返回 Object 的 java.awt.color 中的方法

protected  Object

ICC_Profile.readResolve()
解析将被反序列化为用 CMM 注册的实例的实例。

java.awt.datatransfer 中 Object 的使用

java.awt.datatransfer 中 Object 的子类

class

Clipboard
此类实现一种使用剪切/复制/粘贴操作传输数据的机制。

class

DataFlavor
DataFlavor 提供有关数据的元信息。

class

FlavorEvent
FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。

class

MimeTypeParseException
对分析相关异常的 MimeType 进行封装的类

class

StringSelection
实现传输 String 所需能力的 Transferable。

class

SystemFlavorMap
SystemFlavorMap 是 "native" (String)（对应于特定于平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的可配置映射。

class

UnsupportedFlavorException
在此 flavor 中不支持所请求的数据的信号。

返回 Object 的 java.awt.datatransfer 中的方法

Object

DataFlavor.clone()
返回此 DataFlavor 的副本。

Object

Clipboard.getData(DataFlavor flavor)
返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。

Object

StringSelection.getTransferData(DataFlavor flavor)
如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。

Object

Transferable.getTransferData(DataFlavor flavor)
返回一个对象，该对象表示将要被传输的数据。

参数类型为 Object 的 java.awt.datatransfer 中的方法

boolean

DataFlavor.equals(Object o)
测试任意 Object 与此 DataFlavor 的相等性。

Transferable

Clipboard.getContents(Object requestor)
返回表示剪贴板当前内容的 transferable 对象。

java.awt.dnd 中 Object 的使用

java.awt.dnd 中 Object 的子类

class

DnDConstants
此类包含了表示 Drag 和 Drop 操作所执行的操作类型的常量值。

class

DragGestureEvent
当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。

class

DragGestureRecognizer
DragGestureRecognizer 是一个针对与平台相关的侦听器规范的抽象基类，它可以与特定 Component 关联以标识与平台相关的拖动开始动作。

class

DragSource
DragSource 是负责开始 Drag 和 Drop 操作的实体，可以用在如下场景中： JVM 生命周期中每个 JVM 的一个默认实例。

class

DragSourceAdapter
用于接收拖动源事件的抽象适配器类。

class

DragSourceContext
DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。

class

DragSourceDragEvent
通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。

class

DragSourceDropEvent
通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。

class

DragSourceEvent
此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。

class

DropTarget
在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。

protected static class

DropTarget.DropTargetAutoScroller
此受保护的嵌套类实现自动滚动

class

DropTargetAdapter
接收放置目标事件的抽象适配器类。

class

DropTargetContext
每当与 Drag 和 Drop 操作相关的逻辑光标和与 DropTarget 相关的 Component 的可见几何结构重合时，就创建一个 DropTargetContext。

protected  class

DropTargetContext.TransferableProxy
TransferableProxy 是一个帮助器内部类，它实现 Transferable 接口，并用作另一个表示特定 drag-n-drop（拖放）操作数据转换的 Transferable 对象的代理。

class

DropTargetDragEvent
通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。

class

DropTargetDropEvent
通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。

class

DropTargetEvent
DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。

class

InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

class

MouseDragGestureRecognizer
DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

返回 Object 的 java.awt.dnd 中的方法

Object

DropTargetContext.TransferableProxy.getTransferData(DataFlavor df)
返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。

Object[]

DragGestureEvent.toArray()
返回组成拖动动作的事件 Object 数组。

Object[]

DragGestureEvent.toArray(Object[] array)
返回组成拖动动作的事件数组。

参数类型为 Object 的 java.awt.dnd 中的方法

Object[]

DragGestureEvent.toArray(Object[] array)
返回组成拖动动作的事件数组。

java.awt.event 中 Object 的使用

java.awt.event 中 Object 的子类

class

ActionEvent
指示发生了组件定义的动作的语义事件。

class

AdjustmentEvent
由 Adjustable 对象所发出的调整事件。

class

AWTEventListenerProxy
扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。

class

ComponentAdapter
用于接收组件事件的抽象适配器类。

class

ComponentEvent
指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。

class

ContainerAdapter
用于接收容器事件的抽象适配器类。

class

ContainerEvent
指示容器内容因为添加或移除组件而更改的低级别事件。

class

FocusAdapter
用于接收键盘焦点事件的抽象适配器类。

class

FocusEvent
指示 Component 已获得或失去输入焦点的低级别事件。

class

HierarchyBoundsAdapter
用于接收祖先的移动和大小重调事件的抽象适配器类。

class

HierarchyEvent
指示 Component 所属的 Component 层次结构发生更改的事件。

class

InputEvent
所有组件级别输入事件的根事件类。

class

InputMethodEvent
输入方法事件包含有关使用输入方法进行撰写的文本的信息。

class

InvocationEvent
当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。

class

ItemEvent
指示项被选定或取消选定的语义事件。

class

KeyAdapter
接收键盘事件的抽象适配器类。

class

KeyEvent
表示组件中发生键击的事件。

class

MouseAdapter
接收鼠标事件的抽象适配器类。

class

MouseEvent
指示组件中发生鼠标动作的事件。

class

MouseMotionAdapter
接收鼠标移动事件的抽象适配器类。

class

MouseWheelEvent
表示鼠标滚轮在组件中滚动的事件。

class

PaintEvent
组件级绘制事件。

class

TextEvent
指示对象文本已改变的语义事件。

class

WindowAdapter
接收窗口事件的抽象适配器类。

class

WindowEvent
指示窗口状态改变的低级别事件。

声明为 Object 的 java.awt.event 中的字段

protected  Object

InvocationEvent.notifier
在 Runnable.run() 方法返回之后立即调用其 notifyAll() 方法的对象（可能为 null）。

返回 Object 的 java.awt.event 中的方法

Object

ItemEvent.getItem()
返回受事件影响的项。

参数类型为 Object 的 java.awt.event 中的构造方法

ActionEvent(Object source, int id, String command)
构造一个 ActionEvent 对象。

ActionEvent(Object source, int id, String command, int modifiers)
使用修改键构造一个 ActionEvent 对象。

ActionEvent(Object source, int id, String command, long when, int modifiers)
使用指定修改键和时间戳构造一个 ActionEvent 对象。

InvocationEvent(Object source, int id, Runnable runnable, Object notifier, boolean catchThrowables)
构造一个具有指定源和 ID 的 InvocationEvent，此源和 ID 将在被指派时执行 runnable 的 run 方法。

InvocationEvent(Object source, Runnable runnable)
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。

InvocationEvent(Object source, Runnable runnable, Object notifier, boolean catchThrowables)
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。

ItemEvent(ItemSelectable source, int id, Object item, int stateChange)
构造一个 ItemEvent 对象。

TextEvent(Object source, int id)
构造一个 TextEvent 对象。

java.awt.font 中 Object 的使用

java.awt.font 中 Object 的子类

class

FontRenderContext
FontRenderContext 类是正确测量文本所需的信息容器。

class

GlyphJustificationInfo
GlyphJustificationInfo 类表示关于字形调整属性的信息。

class

GlyphMetrics
GlyphMetrics 类表示单个字形的信息。

class

GlyphVector
GlyphVector 对象是一个字形的集合，包含在转换坐标空间中放置每个字形的几何信息，该坐标空间对应于最终要显示 GlyphVector 的设备。

class

GraphicAttribute
此类与 CHAR_REPLACEMENT 属性一起使用。

class

ImageGraphicAttribute
ImageGraphicAttribute 类是在 TextLayout 中绘制图像的 GraphicAttribute 实现。

class

LayoutPath
LayoutPath 提供相对于基线的位置与用户空间中的点之间的映射。

class

LineBreakMeasurer
LineBreakMeasurer 类允许将样式化的文本断为行（或段），以符合特定的可视 advance。

class

LineMetrics
LineMetrics 类允许访问沿着一行布局字符和多行布局所需要的规格。

class

NumericShaper
NumericShaper 类用于将 Latin-1（欧洲语）数字转换成其他 Unicode 十进制数字。

class

ShapeGraphicAttribute
ShapeGraphicAttribute 类是以 TextLayout 形式绘制形状的 GraphicAttribute 的实现。

class

TextAttribute
TextAttribute 类定义用于呈现文本的属性键和属性值。

class

TextHitInfo
TextHitInfo 类表示文本模型中的字符位置以及字符的斜线或“边”。

class

TextLayout
TextLayout 是样式字符数据的不可变图形表示形式。

static class

TextLayout.CaretPolicy
定义确定强插入符位置的策略。

class

TextMeasurer
TextMeasurer 类提供换行所需的基本操作：测量到给定的 advance，确定字符范围的 advance，并为字符范围生成一个 TextLayout。

class

TransformAttribute
TransformAttribute 类为转换提供一个不可变的包装器，使其可以安全地作为属性使用。

返回 Object 的 java.awt.font 中的方法

protected  Object

TextLayout.clone()
创建此 TextLayout 的副本。

protected  Object

TextMeasurer.clone()

Object

FontRenderContext.getAntiAliasingHint()
返回此 FontRenderContext 中使用的文本 anti-aliasing 呈现模式提示。

Object

FontRenderContext.getFractionalMetricsHint()
返回此 FontRenderContext 中使用的文本 fractional metrics 呈现模式提示。

protected  Object

TextAttribute.readResolve()
将反序列化的实例解析为预定义常量。

参数类型为 Object 的 java.awt.font 中的方法

boolean

ImageGraphicAttribute.equals(Object rhs)
比较此 ImageGraphicAttribute 与指定的 Object。

boolean

NumericShaper.equals(Object o)
如果指定的对象是 NumericShaper 的一个实例，并且完全一致地成形到此实例，则返回 true。

boolean

ShapeGraphicAttribute.equals(Object rhs)
将此 ShapeGraphicAttribute 与指定的 Object 进行比较。

boolean

TextHitInfo.equals(Object obj)
如果指定的 Object 是一个 TextHitInfo 并且等于此 TextHitInfo，则返回 true。

boolean

TextLayout.equals(Object obj)
如果指定 Object 是一个 TextLayout 对象，且指定的 Object 等于此 TextLayout，则返回 true。

boolean

TransformAttribute.equals(Object rhs)
如果 rhs 是一个变换等效于此 TransformAttribute 变换的 TransformAttribute，则返回 true。

boolean

FontRenderContext.equals(Object obj)
如果 obj 是 FontRenderContext 的一个实例，并且具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。

参数类型为 Object 的 java.awt.font 中的构造方法

FontRenderContext(AffineTransform tx, Object aaHint, Object fmHint)
根据一个可选 AffineTransform 和两个 Object 值构造一个 FontRenderContext 对象，这两个值决定了新创建的对象是具有 anti-aliasing 属性，还是具有 fractional metrics 属性。

java.awt.geom 中 Object 的使用

java.awt.geom 中 Object 的子类

class

AffineTransform
AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。

class

Arc2D
Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。

static class

Arc2D.Double
此类定义以 double 精度指定的弧。

static class

Arc2D.Float
此类定义以 float 精度指定的弧。

class

Area
Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。

class

CubicCurve2D
CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。

static class

CubicCurve2D.Double
使用 double 坐标指定的三次参数曲线段。

static class

CubicCurve2D.Float
使用 float 坐标指定的三次参数曲线段。

class

Dimension2D
Dimension2D 类用于封装宽度和高度尺寸。

class

Ellipse2D
Ellipse2D 类描述窗体矩形定义的椭圆。

static class

Ellipse2D.Double
Double 类以 double 精度定义椭圆。

static class

Ellipse2D.Float
Float 类以 float 精度定义椭圆。

class

FlatteningPathIterator
FlatteningPathIterator 类返回另一个 PathIterator 对象的变平视图。

class

GeneralPath
GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。

class

IllegalPathStateException
对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。

class

Line2D
Line2D 表示 (x,y) 坐标空间中的线段。

static class

Line2D.Double
使用 double 坐标指定的线段。

static class

Line2D.Float
使用 float 坐标指定的线段。

class

NoninvertibleTransformException
NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。

class

Path2D
Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。

static class

Path2D.Double
Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。

static class

Path2D.Float
Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。

class

Point2D
Point2D 类定义表示 (x,y) 坐标空间中位置的点。

static class

Point2D.Double
Double 类以 double 精度定义指定的点。

static class

Point2D.Float
Float 类以 float 精度定义指定的点。

class

QuadCurve2D
QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。

static class

QuadCurve2D.Double
使用 double 坐标指定的二次参数曲线段。

static class

QuadCurve2D.Float
使用 float 坐标指定的二次参数曲线段。

class

Rectangle2D
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。

static class

Rectangle2D.Double
Double 类定义一个在 double 坐标中指定的矩形。

static class

Rectangle2D.Float
Float 类定义一个在 float 坐标中指定的矩形。

class

RectangularShape
RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。

class

RoundRectangle2D
RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。

static class

RoundRectangle2D.Double
Double 类定义一个所有圆角都使用 double 坐标指定的矩形。

static class

RoundRectangle2D.Float
Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

返回 Object 的 java.awt.geom 中的方法

Object

Area.clone()
返回此 Area 对象的精确副本。

Object

CubicCurve2D.clone()
创建一个与此对象具有相同类的新对象。

Object

Line2D.clone()
创建一个与此对象具有相同类的新对象。

abstract  Object

Path2D.clone()
创建一个与此对象具有相同类的新对象。

Object

Path2D.Float.clone()
创建一个与此对象具有相同类的新对象。

Object

Path2D.Double.clone()
创建一个与此对象具有相同类的新对象。

Object

QuadCurve2D.clone()
创建一个与此对象具有相同类和相同内容的新对象。

Object

RectangularShape.clone()
创建一个与此对象具有相同类和相同内容的新对象。

Object

Point2D.clone()
创建一个与此对象具有相同类和相同内容的新对象。

Object

AffineTransform.clone()
返回此 AffineTransform 对象的副本。

Object

Dimension2D.clone()
创建一个与此对象具有相同类的新对象。

参数类型为 Object 的 java.awt.geom 中的方法

boolean

Arc2D.equals(Object obj)
确定指定的 Object 是否与此 Arc2D 相等。

boolean

Ellipse2D.equals(Object obj)
确定指定的 Object 是否与此 Ellipse2D 相等。

boolean

RoundRectangle2D.equals(Object obj)
确定指定的 Object 是否与此 RoundRectangle2D 相等。

boolean

Rectangle2D.equals(Object obj)
确定指定的 Object 是否与此 Rectangle2D 相等。

boolean

Point2D.equals(Object obj)
确定两个点是否相等。

boolean

AffineTransform.equals(Object obj)
如果此 AffineTransform 表示与指定参数相同的仿射坐标变换，则返回 true。

java.awt.im 中 Object 的使用

java.awt.im 中 Object 的子类

class

InputContext
提供控制诸如输入方法和键盘布局之类的文本输入设施的方法。

class

InputMethodHighlight
InputMethodHighlight 用于描述正在撰写的文本的高亮显示属性。

class

InputSubset
定义输入方法使用的其他 Unicode 子集。

返回 Object 的 java.awt.im 中的方法

Object

InputContext.getInputMethodControlObject()
返回当前输入方法中的一个控制对象，或 null。

java.awt.im.spi 中 Object 的使用

返回 Object 的 java.awt.im.spi 中的方法

Object

InputMethod.getControlObject()
从此输入方法返回一个控制对象，或 null。

java.awt.image 中 Object 的使用

java.awt.image 中 Object 的子类

class

AffineTransformOp
此类使用仿射转换来执行从源图像或 Raster 中 2D 坐标到目标图像或 Raster 中 2D 坐标的线性映射。

class

AreaAveragingScaleFilter
这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。

class

BandCombineOp
此类使用一个指定矩阵对 Raster 中的 band 进行任意线性组合。

class

BandedSampleModel
此类表示以 band 交错方式存储的图像数据，像素的每个样本都占用 DataBuffer 的一个数据元素。

class

BufferedImage
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。

class

BufferedImageFilter
BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。

class

BufferStrategy
BufferStrategy 类表示用来在特定的 Canvas 或 Window 上组织复杂内存的机制。

class

ByteLookupTable
此类定义一个 lookup table 对象。

class

ColorConvertOp
此类对源图像中的数据执行逐像素的颜色转换。

class

ColorModel
此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。

class

ComponentColorModel
使用像素值将颜色和 alpha 信息表示为独立样本的 ColorModel 类，该类以独立的数据元素存储每个样本。

class

ComponentSampleModel
此类表示按每个像素样本占用 DataBuffer 中一个数据元素的方式存储的图像数据。

class

ConvolveOp
此类实现从源到目标的卷积。

class

CropImageFilter
用于裁剪图像的 ImageFilter 类。

class

DataBuffer
此类用于包装一个或多个数据数组。

class

DataBufferByte
此类扩展了 DataBuffer，并在内部按字节存储数据。

class

DataBufferDouble
此类扩展了 DataBuffer，并在内部以 double 形式存储数据。

class

DataBufferFloat
此类扩展了 DataBuffer，并在内部以 float 形式存储数据。

class

DataBufferInt
此类扩展了 DataBuffer，并在内部以整数形式存储数据。

class

DataBufferShort
此类扩展了 DataBuffer，并在内部以 short 类型存储数据。

class

DataBufferUShort
此类扩展了 DataBuffer，并在内部以 short 类型存储数据。

class

DirectColorModel
DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。

class

FilteredImageSource
此类是 ImageProducer 接口的一个实现，该接口使用现有的图像和过滤器对象作为参数，并使用它们为原图像的新过滤版本产生图像数据。

class

ImageFilter
此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。

class

ImagingOpException
如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。

class

IndexColorModel
IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。

class

Kernel
Kernel 类定义了一个矩阵，描述指定的像素及其周围像素如何影响过滤操作输出图像中像素位置的计算值。

class

LookupOp
此类实现从源到目标的查找操作。

class

LookupTable
此抽象类定义了一个查找表对象。

class

MemoryImageSource
此类是 ImageProducer 接口的一个实现，该接口使用一个数组为 Image 生成像素值。

class

MultiPixelPackedSampleModel
MultiPixelPackedSampleModel 类表示单 band 图像，能够将多个单样本像素打包到一个数据元素中。

class

PackedColorModel
PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。

class

PixelGrabber
PixelGrabber 类实现可以附加在 Image 或 ImageProducer 对象上获得图像像素子集的 ImageConsumer。

class

PixelInterleavedSampleModel
此类表示以像素交替方式存储的图像数据，其中像素的每个采样占用 DataBuffer 的一个数据元素。

class

Raster
表示像素矩形数组的类。

class

RasterFormatException
如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

class

ReplicateScaleFilter
使用最简单的算法缩放图像的 ImageFilter 类。

class

RescaleOp
通过将每个像素的样本值乘以一个缩放因子，然后加上一个偏移量，此类对源图像中数据进行逐像素重缩放。

class

RGBImageFilter
此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。

class

SampleModel
此抽象类定义一个提取图像像素样本的接口。

class

ShortLookupTable
此类定义了一个查找表对象。

class

SinglePixelPackedSampleModel
此类表示压缩的像素数据：将 N 个样本组成的单个像素存储在单个数据数组元素中，每个数据数组元素只保存一个像素的样本。

class

VolatileImage
VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。

class

WritableRaster
此类扩展了 Raster 以提供像素写入功能。

声明为 Object 的 java.awt.image 中的字段

protected  Object

ReplicateScaleFilter.outpixbuf
使用 ReplicateScaleFilter.destWidth 的大小初始化的 byte 数组，用于将像素数据行传递给 ImageConsumer。

返回 Object 的 java.awt.image 中的方法

Object

Kernel.clone()
复制此对象。

Object

ImageFilter.clone()
复制此对象。

Object

ComponentColorModel.getDataElements(float[] normComponents, int normOffset, Object obj)
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

ColorModel.getDataElements(float[] normComponents, int normOffset, Object obj)
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

ComponentColorModel.getDataElements(int[] components, int offset, Object obj)
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

IndexColorModel.getDataElements(int[] components, int offset, Object pixel)
在给定非标准化颜色/alpha 分量数组的情况下，返回表示此 ColorModel 中像素的数据元素数组。

Object

DirectColorModel.getDataElements(int[] components, int offset, Object obj)
在给定未标准化的颜色/alpha 分量的数组的情况下，返回此 ColorModel 中的像素的数据元素数组表示形式。

Object

ColorModel.getDataElements(int[] components, int offset, Object obj)
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

Raster.getDataElements(int x, int y, int w, int h, Object outData)
以 TransferType 类型基本数组形式返回指定像素矩形的像素数据。

Object

SampleModel.getDataElements(int x, int y, int w, int h, Object obj, DataBuffer data)
在 TransferType 类型基本数组中返回指定像素矩形的像素数据。

Object

Raster.getDataElements(int x, int y, Object outData)
以 TransferType 类型的基本数组形式返回单个像素的数据。

Object

BandedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
在 TransferType 类型基本数组中返回单个像素的数据。

Object

MultiPixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。

Object

SinglePixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。

Object

ComponentSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
以 TransferType 类型基本数组形式返回单个像素的数据。

abstract  Object

SampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
在 TransferType 类型的基本数组中返回单个像素的数据。

Object

ComponentColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

Object

IndexColorModel.getDataElements(int rgb, Object pixel)
根据默认 RGB 颜色模型中的整数像素表示形式，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

DirectColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

Object

ColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

Object

PixelGrabber.getPixels()
获取像素缓冲区。

Object

BufferedImage.getProperty(String name)
按名称返回图像的属性。

Object

RenderedImage.getProperty(String name)
从此图像的属性设置中获取一个属性。

Object

BufferedImage.getProperty(String name, ImageObserver observer)
按名称返回图像的属性。

参数类型为 Object 的 java.awt.image 中的方法

boolean

ComponentColorModel.equals(Object obj)
将此颜色模型与其他模型进行相等性比较。

boolean

MultiPixelPackedSampleModel.equals(Object o)

boolean

SinglePixelPackedSampleModel.equals(Object o)

boolean

ComponentSampleModel.equals(Object o)

boolean

PackedColorModel.equals(Object obj)
测试指定的 Object 是否为 PackedColorModel 的一个实例并且等于此 PackedColorModel。

boolean

ColorModel.equals(Object obj)
测试指定的 Object 是否是 ColorModel 的实例，以及它是否等于此 ColorModel。

int

ComponentColorModel.getAlpha(Object inData)
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。

int

DirectColorModel.getAlpha(Object inData)
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。

int

ColorModel.getAlpha(Object inData)
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。

int

ComponentColorModel.getBlue(Object inData)
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

DirectColorModel.getBlue(Object inData)
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

ColorModel.getBlue(Object inData)
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int[]

ComponentColorModel.getComponents(Object pixel, int[] components, int offset)
返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。

int[]

IndexColorModel.getComponents(Object pixel, int[] components, int offset)
返回此 ColorModel 中指定像素的非标准化颜色/alpha 分量数组。

int[]

DirectColorModel.getComponents(Object pixel, int[] components, int offset)
返回在 ColorModel 中已给定像素的未标准化颜色/alpha 分量。

int[]

ColorModel.getComponents(Object pixel, int[] components, int offset)
返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。

Object

ComponentColorModel.getDataElements(float[] normComponents, int normOffset, Object obj)
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

ColorModel.getDataElements(float[] normComponents, int normOffset, Object obj)
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

ComponentColorModel.getDataElements(int[] components, int offset, Object obj)
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

IndexColorModel.getDataElements(int[] components, int offset, Object pixel)
在给定非标准化颜色/alpha 分量数组的情况下，返回表示此 ColorModel 中像素的数据元素数组。

Object

DirectColorModel.getDataElements(int[] components, int offset, Object obj)
在给定未标准化的颜色/alpha 分量的数组的情况下，返回此 ColorModel 中的像素的数据元素数组表示形式。

Object

ColorModel.getDataElements(int[] components, int offset, Object obj)
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

Raster.getDataElements(int x, int y, int w, int h, Object outData)
以 TransferType 类型基本数组形式返回指定像素矩形的像素数据。

Object

SampleModel.getDataElements(int x, int y, int w, int h, Object obj, DataBuffer data)
在 TransferType 类型基本数组中返回指定像素矩形的像素数据。

Object

Raster.getDataElements(int x, int y, Object outData)
以 TransferType 类型的基本数组形式返回单个像素的数据。

Object

BandedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
在 TransferType 类型基本数组中返回单个像素的数据。

Object

MultiPixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。

Object

SinglePixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。

Object

ComponentSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
以 TransferType 类型基本数组形式返回单个像素的数据。

abstract  Object

SampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
在 TransferType 类型的基本数组中返回单个像素的数据。

Object

ComponentColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

Object

IndexColorModel.getDataElements(int rgb, Object pixel)
根据默认 RGB 颜色模型中的整数像素表示形式，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

DirectColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

Object

ColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

int

ComponentColorModel.getGreen(Object inData)
返回指定像素的绿色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

DirectColorModel.getGreen(Object inData)
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

ColorModel.getGreen(Object inData)
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255）。

float[]

ComponentColorModel.getNormalizedComponents(Object pixel, float[] normComponents, int normOffset)
返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。

float[]

ColorModel.getNormalizedComponents(Object pixel, float[] normComponents, int normOffset)
返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。

int

ComponentColorModel.getRed(Object inData)
返回指定像素的红色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

DirectColorModel.getRed(Object inData)
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

ColorModel.getRed(Object inData)
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

ComponentColorModel.getRGB(Object inData)
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。

int

DirectColorModel.getRGB(Object inData)
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。

int

ColorModel.getRGB(Object inData)
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。

void

WritableRaster.setDataElements(int x, int y, int w, int h, Object inData)
为类型 TransferType 基本数组中的像素矩形设置数据。

void

SampleModel.setDataElements(int x, int y, int w, int h, Object obj, DataBuffer data)
根据 TransferType 类型的基本数组设置指定 DataBuffer 中像素矩形的数据。

void

WritableRaster.setDataElements(int x, int y, Object inData)
为类型 TransferType 基本数组中的单个像素设置数据。

void

BandedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。

void

MultiPixelPackedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。

void

SinglePixelPackedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型的基本数组设置指定 DataBuffer 中单个像素的数据。

void

ComponentSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。

abstract  void

SampleModel.setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。

java.awt.image.renderable 中 Object 的使用

java.awt.image.renderable 中 Object 的子类

class

ParameterBlock
ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。

class

RenderableImageOp
此类借助其相关的 ContextualRenderedImageFactory 实例处理某个操作的可呈现方面。

class

RenderableImageProducer
实现 ImageProducer 以允许异步生成 RenderableImage 的适配器类。

class

RenderContext
RenderContext 封装从 enderableImage 生成特定呈现所需的信息。

类型参数类型为 Object 的 java.awt.image.renderable 中的字段

protected  Vector<Object>

ParameterBlock.parameters
一个非源参数的 Vector，存储为任意 Object。

protected  Vector<Object>

ParameterBlock.sources
源的 Vector，存储为任意 Objects。

返回 Object 的 java.awt.image.renderable 中的方法

Object

ParameterBlock.clone()
创建 ParameterBlock 的一个副本。

Object

RenderContext.clone()
对 RenderContext 进行复制。

Object

ParameterBlock.getObjectParameter(int index)
获取作为对象的参数。

Object

ContextualRenderedImageFactory.getProperty(ParameterBlock paramBlock, String name)
获取由 name 参数指定的属性的适当实例。

Object

RenderableImage.getProperty(String name)
从此图像的属性集中获取某个属性。

Object

RenderableImageOp.getProperty(String name)
从此图像的属性集中获取某个属性。

Object

ParameterBlock.getSource(int index)
返回作为通用 Object 的源。

Object

ParameterBlock.shallowClone()
创建 ParameterBlock 的一个浅表副本。

返回变量类型为 Object 的类型的 java.awt.image.renderable 中的方法

Vector<Object>

ParameterBlock.getParameters()
返回参数的整个 Vector。

Vector<Object>

ParameterBlock.getSources()
返回源的整个 Vector。

参数类型为 Object 的 java.awt.image.renderable 中的方法

ParameterBlock

ParameterBlock.add(Object obj)
将一个 Object 添加到此参数列表。

ParameterBlock

ParameterBlock.addSource(Object source)
将一个图像添加到源列表的末尾。

ParameterBlock

ParameterBlock.set(Object obj, int index)
替换此参数列表中的一个 Object。

ParameterBlock

ParameterBlock.setSource(Object source, int index)
将源列表中的某个项替换为一个新源。

类型变量类型为 Object 的 java.awt.image.renderable 中的方法参数

void

ParameterBlock.setParameters(Vector<Object> parameters)
将参数的整个 Vector 设置为给定 Vector。

void

ParameterBlock.setSources(Vector<Object> sources)
将源的整个 Vector 设置为给定 Vector。

类型变量类型为 Object 的 java.awt.image.renderable 中的构造方法参数

ParameterBlock(Vector<Object> sources)
使用源的给定 Vector 构造一个 ParameterBlock。

ParameterBlock(Vector<Object> sources, Vector<Object> parameters)
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。

ParameterBlock(Vector<Object> sources, Vector<Object> parameters)
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。

java.awt.print 中 Object 的使用

java.awt.print 中 Object 的子类

class

Book
Book 类提供文档的表示形式，该文档的页面可以使用不同的页面格式和页面 painter。

class

PageFormat
PageFormat 类描述要打印的页面大小和方向。

class

Paper
Paper 类描述一张纸的物理特征。

class

PrinterAbortException
PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。

class

PrinterException
PrinterException 类及其子类用于指示打印系统中发生的异常情况。

class

PrinterIOException
PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

class

PrinterJob
PrinterJob 类是控制打印的主要类。

返回 Object 的 java.awt.print 中的方法

Object

PageFormat.clone()
制作此 PageFormat 的副本，使它与此 PageFormat 具有相同的内容。

Object

Paper.clone()
创建此 Paper 的一个副本，内容与此 Paper 相同。

java.beans 中 Object 的使用

java.beans 中 Object 的子类

class

BeanDescriptor
BeanDescriptor 提供有关 "bean" 的全局信息，其中包括其 Java 类、其 displayName 等等。

class

Beans
此类提供一些通用的 bean 控制方法。

class

DefaultPersistenceDelegate
DefaultPersistenceDelegate 是 PersistenceDelegate 抽象类的具体实现，是没有关于其可用信息的类在默认情况下使用的委托。

class

Encoder
Encoder 是这样的类，它可用于创建根据其公共 API 对 JavaBeans 集合状态进行编码的文件或流。

class

EventHandler
EventHandler 类为动态生成事件侦听器提供支持，这些侦听器的方法执行一条涉及传入事件对象和目标对象的简单语句。

class

EventSetDescriptor
描述给定 Java bean 激发的一组事件的 EventSetDescriptor。

class

Expression
Expression 对象表示基本表达式，其中将单个方法应用于某一目标和一组参数，以返回结果，与在 "a.getFoo()" 中一样。

class

FeatureDescriptor
FeatureDescriptor 类是 PropertyDescriptor、EventSetDescriptor 和 MethodDescriptor 等的公共基类。

class

IndexedPropertyChangeEvent
无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。

class

IndexedPropertyDescriptor
IndexedPropertyDescriptor 描述了类似数组行为的属性，且有一种访问数组特定元素的索引读和/或索引写方法。

class

IntrospectionException
在 Introspection 期间发生异常时抛出异常。

class

Introspector
Introspector 类为通过工具学习有关受目标 Java Bean 支持的属性、事件和方法的知识提供了一个标准方法。

class

MethodDescriptor
MethodDescriptor 描述了一种特殊方法，即 Java Bean 支持从其他组件对其进行外部访问。

class

ParameterDescriptor
ParameterDescriptor 类允许 bean 实现者提供除 java.lang.reflect.Method 类提供的低级别信息之外的关于其每个参数的额外信息。

class

PersistenceDelegate
PersistenceDelegate 类负责根据类的公共 API 中的方法表示给定类的实例状态。

class

PropertyChangeEvent
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。

class

PropertyChangeListenerProxy
扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。

class

PropertyChangeSupport
这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。

class

PropertyDescriptor
PropertyDescriptor 描述 Java Bean 通过一对存储器方法导出的一个属性。

class

PropertyEditorManager
PropertyEditorManager 可用于查找任何给定类型名称的属性编辑器。

class

PropertyEditorSupport
这是一个帮助构建属性编辑器的支持类。

class

PropertyVetoException
当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。

class

SimpleBeanInfo
这是一个使得用户提供 BeanInfo 类更容易的支持类。

class

Statement
Statement 对象表示基本语句，其中将单个方法应用于某一目标和一组参数，以返回结果，比如 "a.setFoo(b)"。

class

VetoableChangeListenerProxy
扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。

class

VetoableChangeSupport
这是一个实用工具类，支持约束 (constrained) 属性的 bean 可以使用此类。

class

XMLDecoder
XMLDecoder 类用于读取使用 XMLEncoder 创建的 XML 文档，用途类似于 ObjectInputStream。

class

XMLEncoder
XMLEncoder 类是 ObjectOutputStream 的互补替换，可用于生成 JavaBean 的文本表示形式，所使用方式与用 ObjectOutputStream 创建 Serializable 对象的二进制表示形式的方式相同。

返回 Object 的 java.beans 中的方法

Object

Encoder.get(Object oldInstance)
在由此流创建的环境中返回 oldInstance 的一个实验值。

Object[]

Statement.getArguments()
返回此语句的参数。

static Object

Beans.getInstanceOf(Object bean, Class<?> targetType)
从给定 bean 中获得表示源对象的指定类型视图的对象。

Object

PropertyChangeEvent.getNewValue()
获取属性的新值，以 Object 的形式表示。

Object

PropertyChangeEvent.getOldValue()
获取属性的旧值，以 Object 的形式表示。

Object

XMLDecoder.getOwner()
获得此解码器的所有者。

Object

XMLEncoder.getOwner()
获得此编码器的所有者。

Object

PropertyChangeEvent.getPropagationId()
保留 "propagationId" 字段以供将来使用。

Object

PropertyEditorSupport.getSource()
返回用作事件源的 bean。

Object

EventHandler.getTarget()
返回此事件处理程序将为其发送消息的对象。

Object

Statement.getTarget()
返回此语句的目标。

Object

Expression.getValue()
如果此实例的 value 属性尚未设置，则此方法利用这些参数，在此目标上动态查找具有指定 methodName 的方法，并调用该方法。

Object

PropertyEditor.getValue()
获取属性值。

Object

PropertyEditorSupport.getValue()
获得属性值。

Object

FeatureDescriptor.getValue(String attributeName)
利用此特性检索指定属性。

static Object

Beans.instantiate(ClassLoader cls, String beanName)
实例化 JavaBean。

static Object

Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext)
实例化 JavaBean。

static Object

Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
实例化 bean。

Object

EventHandler.invoke(Object proxy, Method method, Object[] arguments)
从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。

Object

XMLDecoder.readObject()
从基础输入流中读取下一个对象。

Object

Encoder.remove(Object oldInstance)
移除此实例的条目，返回旧条目。

参数类型为 Object 的 java.beans 中的方法

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action)
创建 listenerInterface 的实现，在该实现中，侦听器接口中的所有 方法都会将处理程序的 action 应用到 target。

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName)
创建 listenerInterface 的实现，在该实现中，所有 方法都会将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)
创建 listenerInterface 的实现，在该实现中，名为 listenerMethodName 的方法将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。

PropertyEditor

PropertyDescriptor.createPropertyEditor(Object bean)
使用当前属性编辑器类构造一个属性编辑器实例。

boolean

IndexedPropertyDescriptor.equals(Object obj)
将此 PropertyDescriptor 与指定对象比较。

boolean

PropertyDescriptor.equals(Object obj)
将此 PropertyDescriptor 与指定对象进行比较。

void

PropertyChangeSupport.fireIndexedPropertyChange(String propertyName, int index, Object oldValue, Object newValue)
报告所有已注册侦听器的绑定 (bound) 索引 (indexed) 属性更新。

void

PropertyChangeSupport.firePropertyChange(String propertyName, Object oldValue, Object newValue)
报告所有已注册侦听器的绑定属性更新。

void

VetoableChangeSupport.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
向所有已注册的侦听器报告 vetoable 属性更新。

Object

Encoder.get(Object oldInstance)
在由此流创建的环境中返回 oldInstance 的一个实验值。

static Object

Beans.getInstanceOf(Object bean, Class<?> targetType)
从给定 bean 中获得表示源对象的指定类型视图的对象。

protected  void

DefaultPersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
initialize 方法的此默认实现假设保存在此类型对象中的所有状态都是通过匹配 "setter" 和 "getter" 方法对来公开的，公开的顺序是 Introspector 返回它们的顺序。

protected  void

PersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
产生一系列对 newInstance 有副作用的语句，使得新实例等于 oldInstance。

protected  Expression

DefaultPersistenceDelegate.instantiate(Object oldInstance, Encoder out)
instantiate 方法的此默认实现返回一个表达式，该表达式包含预先定义的方法名称 "new"，该名称表示调用带有参数（在 DefaultPersistenceDelegate 的构造方法中指定）的构造方法。

protected abstract  Expression

PersistenceDelegate.instantiate(Object oldInstance, Encoder out)
返回其值为 oldInstance 的表达式。

Object

EventHandler.invoke(Object proxy, Method method, Object[] arguments)
从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。

Object

EventHandler.invoke(Object proxy, Method method, Object[] arguments)
从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。

static boolean

Beans.isInstanceOf(Object bean, Class<?> targetType)
检查是否可以将 bean 视为给定目标类型。

protected  boolean

DefaultPersistenceDelegate.mutatesTo(Object oldInstance, Object newInstance)
如果指定构造方法中的参数数量不为零，且 oldInstance 的类显式声明了一个 "equals" 方法，则此方法返回 oldInstance.equals(newInstance) 的值。

protected  boolean

PersistenceDelegate.mutatesTo(Object oldInstance, Object newInstance)
如果 oldInstance 的等效 副本可以可以通过应用 newInstance 的一系列语句来创建，则返回 true。

Object

Encoder.remove(Object oldInstance)
移除此实例的条目，返回旧条目。

void

Customizer.setObject(Object bean)
设置将要自定义的对象。

void

XMLDecoder.setOwner(Object owner)
将此解码器的所有者设置为 owner。

void

XMLEncoder.setOwner(Object owner)
将此编码器的所有者设置为 owner。

void

PropertyChangeEvent.setPropagationId(Object propagationId)
设置事件的 propagationId 对象。

void

PropertyEditorSupport.setSource(Object source)
设置源 bean。

void

Expression.setValue(Object value)
将此表达式的值设置为 value。

void

PropertyEditor.setValue(Object value)
设置（或更改）将编辑的对象。

void

PropertyEditorSupport.setValue(Object value)
设置（或更改）将被编辑的对象。

void

FeatureDescriptor.setValue(String attributeName, Object value)
将某一指定属性与此特性相关联。

protected  void

Encoder.writeObject(Object o)
将指定对象写入输出流中。

void

XMLEncoder.writeObject(Object o)
将指定对象的 XML 表示形式写入输出中。

void

PersistenceDelegate.writeObject(Object oldInstance, Encoder out)
writeObject 是持久性的一个入口点，由传统委托模式中的 Encoder 使用。

参数类型为 Object 的 java.beans 中的构造方法

EventHandler(Object target, String action, String eventPropertyName, String listenerMethodName)
创建一个新的 EventHandler 对象；通常使用 create 方法之一，而不是直接调用此构造方法。

Expression(Object value, Object target, String methodName, Object[] arguments)
为某个返回结果的方法创建一个新的 Expression 对象。

Expression(Object value, Object target, String methodName, Object[] arguments)
为某个返回结果的方法创建一个新的 Expression 对象。

Expression(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

Expression(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

IndexedPropertyChangeEvent(Object source, String propertyName, Object oldValue, Object newValue, int index)
构造一个新的 IndexedPropertyChangeEvent 对象。

PropertyChangeEvent(Object source, String propertyName, Object oldValue, Object newValue)
构造一个新的 PropertyChangeEvent。

PropertyChangeSupport(Object sourceBean)
构造一个 PropertyChangeSupport 对象。

PropertyEditorSupport(Object source)
构造一个 PropertyEditorSupport 对象。

Statement(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

Statement(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

VetoableChangeSupport(Object sourceBean)
构造一个 VetoableChangeSupport 对象。

XMLDecoder(InputStream in, Object owner)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

java.beans.beancontext 中 Object 的使用

java.beans.beancontext 中 Object 的子类

class

BeanContextChildSupport
这是一个为实现 BeanContextChild 协议提供支持的一般支持类。

class

BeanContextEvent
BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。

class

BeanContextMembershipEvent
BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。

class

BeanContextServiceAvailableEvent
BeanContextServicesListener 使用此事件类型来标识将被注册的服务。

class

BeanContextServiceRevokedEvent
BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。

class

BeanContextServicesSupport
此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。

protected  class

BeanContextServicesSupport.BCSSChild

protected  class

BeanContextServicesSupport.BCSSProxyServiceProvider

protected static class

BeanContextServicesSupport.BCSSServiceProvider
子类可以为此嵌套类创建子类，以便为每个 BeanContextServicesProvider 添加行为。

class

BeanContextSupport
此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

protected  class

BeanContextSupport.BCSChild

protected static class

BeanContextSupport.BCSIterator
受保护的最终子类，它封装一个迭代器但实现无操作 remove() 方法。

声明为 Object 的 java.beans.beancontext 中的字段

static Object

BeanContext.globalHierarchyLock
BeanContext 和 BeanContextServices 实现者均使用此全局锁定来序列化 BeanContext 中的更改和所有服务请求等。

返回 Object 的 java.beans.beancontext 中的方法

protected  Object[]

BeanContextSupport.copyChildren()
获得此 BeanContext 子级的副本。

Object

BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。

Object

BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
获得一个可被委托的服务。

Object

BeanContextServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)
由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。

Object

BeanContextServicesSupport.BCSSProxyServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)

Object

BeanContext.instantiateChild(String beanName)
实例化指定为此 BeanContext 的一个子级的 javaBean。

Object

BeanContextSupport.instantiateChild(String beanName)
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。

Object

BeanContextSupport.BCSIterator.next()

Object[]

BeanContextMembershipEvent.toArray()
获得受此事件影响的子级的数组。

Object[]

BeanContextSupport.toArray()
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。

Object[]

BeanContextSupport.toArray(Object[] arry)
获得包含与数组中所包含类型匹配的此 BeanContext 的所有子级的数组。

参数类型为 Object 的 java.beans.beancontext 中的方法

boolean

BeanContextSupport.add(Object targetChild)
在此 BeanContext 中添加/嵌套一个子级。

protected  void

BeanContextSupport.childDeserializedHook(Object child, BeanContextSupport.BCSChild bcsc)
由 readObject 利用新近反序列化的子级和 BCSChild 调用。

protected  void

BeanContextSupport.childJustAddedHook(Object child, BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经添加子对象之后，且在发生事件通知之前，只扩展 add() 语义。

protected  void

BeanContextServicesSupport.childJustRemovedHook(Object child, BeanContextSupport.BCSChild bcsc)
在已成功移除子级之后，从超类的子级移除操作中调用。

protected  void

BeanContextSupport.childJustRemovedHook(Object child, BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经移除子对象之后，且在发生事件通知之前，只扩展 remove() 语义。

boolean

BeanContextMembershipEvent.contains(Object child)
指定子级受事件影响吗？

boolean

BeanContextSupport.contains(Object o)
确定指定对象当前是否是此 BeanContext 的子级。

boolean

BeanContextSupport.containsKey(Object o)
确定指定对象当前是否是此 BeanContext 的子级。

protected  BeanContextSupport.BCSChild

BeanContextServicesSupport.createBCSChild(Object targetChild, Object peer)
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。

protected  BeanContextSupport.BCSChild

BeanContextSupport.createBCSChild(Object targetChild, Object peer)
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。

void

BeanContextChildSupport.firePropertyChange(String name, Object oldValue, Object newValue)
向所有已注册的侦听器报告绑定 (bound) 属性更新。

void

BeanContextChildSupport.fireVetoableChange(String name, Object oldValue, Object newValue)
向所有已注册的侦听器报告 vetoable 属性更新。

protected static BeanContextChild

BeanContextSupport.getChildBeanContextChild(Object child)
与指定 Child 相关联的 BeanContextChild（如果有）。

protected static BeanContextMembershipListener

BeanContextSupport.getChildBeanContextMembershipListener(Object child)
与指定 Child 相关联的 BeanContextMembershipListener（如果有）。

protected static BeanContextServicesListener

BeanContextServicesSupport.getChildBeanContextServicesListener(Object child)
获得指定子级的 BeanContextServicesListener（如果有）。

protected static PropertyChangeListener

BeanContextSupport.getChildPropertyChangeListener(Object child)
与指定 Child 相关联的 PropertyChangeListener（如果有）

protected static Serializable

BeanContextSupport.getChildSerializable(Object child)
获得与指定 Child 相关联的 Serializable（如果有）

protected static VetoableChangeListener

BeanContextSupport.getChildVetoableChangeListener(Object child)
与指定 Child 相关联的 VetoableChangeListener（如果有）。

protected static Visibility

BeanContextSupport.getChildVisibility(Object child)
获得与指定子级相关联的 Component（如果有）。

Object

BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。

Object

BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
获得一个可被委托的服务。

Object

BeanContextServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)
由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。

Object

BeanContextServicesSupport.BCSSProxyServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)

void

BeanContextServices.releaseService(BeanContextChild child, Object requestor, Object service)
通过在基础 BeanContextServiceProvider 上调用 releaseService() 释放 BeanContextChild（或与 BeanContextChild 关联的任意对象）对指定服务的引用。

void

BeanContextServicesSupport.releaseService(BeanContextChild child, Object requestor, Object service)
释放服务。

void

BeanContextServiceProvider.releaseService(BeanContextServices bcs, Object requestor, Object service)
由 BeanContextServices 调用，此方法释放一个对特定服务的嵌套 BeanContextChild（或与 BeanContextChild 关联的任意对象）的引用。

void

BeanContextServicesSupport.BCSSProxyServiceProvider.releaseService(BeanContextServices bcs, Object requestor, Object service)

boolean

BeanContextSupport.remove(Object targetChild)
从此 BeanContext 中移除一个子对象。

protected  boolean

BeanContextSupport.remove(Object targetChild, boolean callChildSetBC)
当由意外的 setBeanContext 或 remove() 调用导致移除时使用的内部移除方法。

Object[]

BeanContextSupport.toArray(Object[] arry)
获得包含与数组中所包含类型匹配的此 BeanContext 的所有子级的数组。

protected  boolean

BeanContextSupport.validatePendingAdd(Object targetChild)
此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象添加到 BeanContext 之前立即检查它们。

protected  boolean

BeanContextSupport.validatePendingRemove(Object targetChild)
此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象从 BeanContext 中移除之前立即检查它们。

参数类型为 Object 的 java.beans.beancontext 中的构造方法

BeanContextMembershipEvent(BeanContext bc, Object[] changes)
构造一个 BeanContextMembershipEvent

java.io 中 Object 的使用

java.io 中 Object 的子类

class

BufferedInputStream
BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。

class

BufferedOutputStream
该类实现缓冲的输出流。

class

BufferedReader
从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。

class

BufferedWriter
将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。

class

ByteArrayInputStream
ByteArrayInputStream 包含一个内部缓冲区，该缓冲区包含从流中读取的字节。

class

ByteArrayOutputStream
此类实现了一个输出流，其中的数据被写入一个 byte 数组。

class

CharArrayReader
此类实现一个可用作字符输入流的字符缓冲区。

class

CharArrayWriter
此类实现一个可用作 Writer 的字符缓冲区。

class

CharConversionException
用于字符转换异常的基类。

class

Console
此类包含多个方法，可访问与当前 Java 虚拟机关联的基于字符的控制台设备（如果有）。

class

DataInputStream
数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。

class

DataOutputStream
数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。

class

EOFException
当输入过程中意外到达文件或流的末尾时，抛出此异常。

class

File
文件和目录路径名的抽象表示形式。

class

FileDescriptor
文件描述符类的实例用作与基础机器有关的某种结构的不透明句柄，该结构表示开放文件、开放套接字或者字节的另一个源或接收者。

class

FileInputStream
FileInputStream 从文件系统中的某个文件中获得输入字节。

class

FileNotFoundException
当试图打开指定路径名表示的文件失败时，抛出此异常。

class

FileOutputStream
文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。

class

FilePermission
此类表示对文件和目录的访问。

class

FileReader
用来读取字符文件的便捷类。

class

FileWriter
用来写入字符文件的便捷类。

class

FilterInputStream
FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。

class

FilterOutputStream
此类是过滤输出流的所有类的超类。

class

FilterReader
用于读取已过滤的字符流的抽象类。

class

FilterWriter
用于写入已过滤的字符流的抽象类。

class

InputStream
此抽象类是表示字节输入流的所有类的超类。

class

InputStreamReader
InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。

class

InterruptedIOException
I/O 操作已中断信号，抛出此异常。

class

InvalidClassException
当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。

class

InvalidObjectException
指示一个或多个反序列化对象未通过验证测试。

class

IOError
当发生严重的 I/O 错误时，抛出此错误。

class

IOException
当发生某种 I/O 异常时，抛出此异常。

class

LineNumberInputStream
已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。

class

LineNumberReader
跟踪行号的缓冲字符输入流。

class

NotActiveException
当序列化和反序列化不活动时，抛出此异常。

class

NotSerializableException
当实例需要具有序列化接口时，抛出此异常。

class

ObjectInputStream
ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。

static class

ObjectInputStream.GetField
提供对从输入流读取的持久字段的访问权限。

class

ObjectOutputStream
ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。

static class

ObjectOutputStream.PutField
提供对要写入 ObjectOutput 的持久字段的编程访问。

class

ObjectStreamClass
类的序列化描述符。

class

ObjectStreamException
特定于 Object Stream 类的所有异常的超类。

class

ObjectStreamField
Serializable 类中 Serializable 字段的描述。

class

OptionalDataException
指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。

class

OutputStream
此抽象类是表示输出字节流的所有类的超类。

class

OutputStreamWriter
OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。

class

PipedInputStream
管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。

class

PipedOutputStream
可以将管道输出流连接到管道输入流来创建通信管道。

class

PipedReader
传送的字符输入流。

class

PipedWriter
传送的字符输出流。

class

PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。

class

PrintWriter
向文本输出流打印对象的格式化表示形式。

class

PushbackInputStream
PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。

class

PushbackReader
允许将字符推回到流的字符流 reader。

class

RandomAccessFile
此类的实例支持对随机访问文件的读取和写入。

class

Reader
用于读取字符流的抽象类。

class

SequenceInputStream
SequenceInputStream 表示其他输入流的逻辑串联。

class

SerializablePermission
此类用于可序列化权限。

class

StreamCorruptedException
当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。

class

StreamTokenizer
StreamTokenizer 类获取输入流并将其解析为“标记”，允许一次读取一个标记。

class

StringBufferInputStream
已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。

class

StringReader
其源为一个字符串的字符流。

class

StringWriter
一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。

class

SyncFailedException
当 sync 操作失败时，抛出此异常。

class

UnsupportedEncodingException
不支持字符编码。

class

UTFDataFormatException
在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。

class

WriteAbortedException
在写入操作过程中抛出 ObjectStreamException 之一的信号。

class

Writer
写入字符流的抽象类。

声明为 Object 的 java.io 中的字段

protected  Object

Reader.lock
用于同步针对此流的操作的对象。

protected  Object

Writer.lock
用于同步针对此流的操作的对象。

返回 Object 的 java.io 中的方法

abstract  Object

ObjectInputStream.GetField.get(String name, Object val)
从持久字段获取指定 Object 字段的值。

Object

ObjectInputStream.readObject()
从 ObjectInputStream 读取对象。

Object

ObjectInput.readObject()
读取并返回对象。

protected  Object

ObjectInputStream.readObjectOverride()
此方法由 ObjectOutputStream 的受信任子类调用，这些子类使用受保护的无参数构造方法构造 ObjectOutputStream。

Object

ObjectInputStream.readUnshared()
从 ObjectInputStream 读取“非共享”对象。

protected  Object

ObjectOutputStream.replaceObject(Object obj)
在序列化期间，此方法允许 ObjectOutputStream 的受信任子类使用一个对象替代另一个对象。

protected  Object

ObjectInputStream.resolveObject(Object obj)
在反序列化期间，此方法允许 ObjectInputStream 的受信任子类使用一个对象替代另一个。

参数类型为 Object 的 java.io 中的方法

int

ObjectStreamField.compareTo(Object obj)
将此字段与另一个 ObjectStreamField 进行比较。

boolean

FilePermission.equals(Object obj)
检查两个 FilePermission 对象是否相等。

boolean

File.equals(Object obj)
测试此抽象路径名与给定对象是否相等。

PrintWriter

PrintWriter.format(Locale l, String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。

PrintStream

PrintStream.format(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此输出流中。

Console

Console.format(String fmt, Object... args)
使用指定格式字符串和参数将格式化字符串写入此控制台的输出流中。

PrintWriter

PrintWriter.format(String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。

PrintStream

PrintStream.format(String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此输出流中。

abstract  Object

ObjectInputStream.GetField.get(String name, Object val)
从持久字段获取指定 Object 字段的值。

void

PrintWriter.print(Object obj)
打印对象。

void

PrintStream.print(Object obj)
打印对象。

PrintWriter

PrintWriter.printf(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。

PrintStream

PrintStream.printf(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

Console

Console.printf(String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此控制台输出流的便捷方法。

PrintWriter

PrintWriter.printf(String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。

PrintStream

PrintStream.printf(String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

void

PrintWriter.println(Object x)
打印 Object，然后终止该行。

void

PrintStream.println(Object x)
打印 Object，然后终止该行。

abstract  void

ObjectOutputStream.PutField.put(String name, Object val)
将指定的 Object 字段的值置于持久字段中。

String

Console.readLine(String fmt, Object... args)
提供一个格式化提示，然后从控制台读取单行文本。

char[]

Console.readPassword(String fmt, Object... args)
提供一个格式化提示，然后从控制台读取密码，禁用回显。

protected  Object

ObjectOutputStream.replaceObject(Object obj)
在序列化期间，此方法允许 ObjectOutputStream 的受信任子类使用一个对象替代另一个对象。

protected  Object

ObjectInputStream.resolveObject(Object obj)
在反序列化期间，此方法允许 ObjectInputStream 的受信任子类使用一个对象替代另一个。

void

ObjectOutputStream.writeObject(Object obj)
将指定的对象写入 ObjectOutputStream。

void

ObjectOutput.writeObject(Object obj)
将对象写入底层存储或流。

protected  void

ObjectOutputStream.writeObjectOverride(Object obj)
子类用于重写默认 writeObject 方法的方法。

void

ObjectOutputStream.writeUnshared(Object obj)
将“未共享”对象写入 ObjectOutputStream。

参数类型为 Object 的 java.io 中的构造方法

Reader(Object lock)
创建一个新的字符流 reader，其重要部分将同步给定的对象。

Writer(Object lock)
创建一个新的字符流 writer，其关键部分将同步给定的对象。

java.lang 中 Object 的使用

java.lang 中 Object 的子类

class

AbstractMethodError
当应用程序试图调用一个抽象方法时，抛出此错误。

class

ArithmeticException
当出现异常的运算条件时，抛出此异常。

class

ArrayIndexOutOfBoundsException
用非法索引访问数组时抛出的异常。

class

ArrayStoreException
试图将错误类型的对象存储到一个对象数组时抛出的异常。

class

AssertionError
抛出该异常指示某个断言失败。

class

Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。

class

Byte
Byte 类将基本类型 byte 的值包装在一个对象中。

class

Character
Character 类在对象中包装一个基本类型 char 的值。

static class

Character.Subset
此类的实例表示 Unicode 字符集的特定子集。

static class

Character.UnicodeBlock
表示 Unicode 规范中字符块的一系列字符子集。

class

Class<T>
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。

class

ClassCastException
当试图将对象强制转换为不是实例的子类时，抛出该异常。

class

ClassCircularityError
当初始化类时检测到类的循环调用的时候，抛出该错误。

class

ClassFormatError
当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。

class

ClassLoader
类加载器是负责加载类的对象。

class

ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。

class

CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。

class

Compiler
Compiler 类主要支持 Java 到本机代码的编译器及相关服务。

class

Double
Double 类在对象中包装一个基本类型 double 的值。

class

Enum<E extends Enum<E>>
这是所有 Java 语言枚举类型的公共基本类。

class

EnumConstantNotPresentException
当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。

class

Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。

class

Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。

class

ExceptionInInitializerError
静态初始化程序中发生意外异常的信号。

class

Float
Float 类在对象中包装一个基本类型 float 的值。

class

IllegalAccessError
当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。

class

IllegalAccessException
当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。

class

IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。

class

IllegalMonitorStateException
抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。

class

IllegalStateException
在非法或不适当的时间调用方法时产生的信号。

class

IllegalThreadStateException
指示线程没有处于请求操作所要求的适当状态时抛出的异常。

class

IncompatibleClassChangeError
在某些类定义中出现不兼容的类更改时抛出该异常。

class

IndexOutOfBoundsException
指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。

class

InheritableThreadLocal<T>
该类扩展了 ThreadLocal，为子线程提供从父线程那里继承的值：在创建子线程时，子线程会接收所有可继承的线程局部变量的初始值，以获得父线程所具有的值。

class

InstantiationError
当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。

class

InstantiationException
当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。

class

Integer
Integer 类在对象中包装了一个基本类型 int 的值。

class

InternalError
该异常指示 Java 虚拟机中出现一些意外的内部错误。

class

InterruptedException
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。

class

LinkageError
LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。

class

Long
Long 类在对象中包装了基本类型 long 的值。

class

Math
Math 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。

class

NegativeArraySizeException
如果应用程序试图创建大小为负的数组，则抛出该异常。

class

NoClassDefFoundError
当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。

class

NoSuchFieldError
如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。

class

NoSuchFieldException
类不包含指定名称的字段时产生的信号。

class

NoSuchMethodError
当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。

class

NoSuchMethodException
无法找到某一特定方法时，抛出该异常。

class

NullPointerException
当应用程序试图在需要对象的地方使用 null 时，抛出该异常。

class

Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。

class

NumberFormatException
当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。

class

OutOfMemoryError
因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。

class

Package
Package 对象包含有关 Java 包的实现和规范的版本信息。

class

Process
ProcessBuilder.start() 和 Runtime.exec 方法创建一个本机进程，并返回 Process 子类的一个实例，该实例可用来控制进程并获得相关信息。

class

ProcessBuilder
此类用于创建操作系统进程。

class

Runtime
每个 Java 应用程序都有一个 Runtime 类实例，使应用程序能够与其运行的环境相连接。

class

RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。

class

RuntimePermission
该类用于运行时权限。

class

SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。

class

SecurityManager
安全管理器是一个允许应用程序实现安全策略的类。

class

Short
Short 类在对象中包装基本类型 short 的值。

class

StackOverflowError
当应用程序递归太深而发生堆栈溢出时，抛出该错误。

class

StackTraceElement
堆栈跟踪中的元素，它由 Throwable.getStackTrace() 返回。

class

StrictMath
StrictMath 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。

class

String
String 类代表字符串。

class

StringBuffer
线程安全的可变字符序列。

class

StringBuilder
一个可变的字符序列。

class

StringIndexOutOfBoundsException
此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。

class

System
System 类包含一些有用的类字段和方法。

class

Thread
线程 是程序中的执行线程。

class

ThreadDeath
调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。

class

ThreadGroup
线程组表示一个线程的集合。

class

ThreadLocal<T>
该类提供了线程局部 (thread-local) 变量。

class

Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

class

TypeNotPresentException
当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。

class

UnknownError
当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。

class

UnsatisfiedLinkError
当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。

class

UnsupportedClassVersionError
当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。

class

UnsupportedOperationException
当不支持请求的操作时，抛出该异常。

class

VerifyError
当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。

class

VirtualMachineError
当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

class

Void
Void 类是一个不可实例化的占位符类，它持有对表示 Java 关键字 void 的 Class 对象的引用。

返回 Object 的 java.lang 中的方法

protected  Object

Enum.clone()
抛出 CloneNotSupportedException。

protected  Object

Object.clone()
创建并返回此对象的一个副本。

static Object

Compiler.command(Object any)
检查参数类型及其字段，并执行一些文档操作。

T[]

Class.getEnumConstants()
如果此 Class 对象不表示枚举类型，则返回枚举类的元素或 null。

Object

SecurityManager.getSecurityContext()
创建一个封装当前执行环境的对象。

Object[]

Class.getSigners()
获取此类的标记。

参数类型为 Object 的 java.lang 中的方法

StringBuilder

StringBuilder.append(Object obj)

StringBuffer

StringBuffer.append(Object obj)

static void

System.arraycopy(Object src, int srcPos, Object dest, int destPos, int length)
从指定源数组中复制一个数组，复制从指定的位置开始，到目标数组的指定位置结束。

T

Class.cast(Object obj)
将一个对象强制转换成此 Class 对象所表示的类或接口。

void

SecurityManager.checkConnect(String host, int port, Object context)
如果不允许指定的安全上下文打开与指定主机和端口号的套接字连接，则抛出 SecurityException。

void

SecurityManager.checkPermission(Permission perm, Object context)
如果拒绝指定的安全上下文访问由给定权限所指定的资源，则抛出 SecurityException。

void

SecurityManager.checkRead(String file, Object context)
如果不允许指定的安全上下文读取由字符串参数所指定的文件，则抛出 SecurityException。

boolean

SecurityManager.checkTopLevelWindow(Object window)
如果不受信任的调用线程调出由 window 参数指出的顶层窗口，则返回 false。

static Object

Compiler.command(Object any)
检查参数类型及其字段，并执行一些文档操作。

boolean

Enum.equals(Object other)
当指定对象等于此枚举常量时，返回 true。

boolean

Long.equals(Object obj)
将此对象与指定对象进行比较。

boolean

Integer.equals(Object obj)
比较此对象与指定对象。

boolean

Short.equals(Object obj)
将此对象与指定对象比较。

boolean

Byte.equals(Object obj)
将此对象与指定对象比较。

boolean

Double.equals(Object obj)
将此对象与指定对象比较。

boolean

Float.equals(Object obj)
将此对象与指定对象进行比较。

boolean

Character.equals(Object obj)
将此对象与指定对象比较。

boolean

Character.Subset.equals(Object obj)
比较两个 Subset 对象的相等性。

boolean

Boolean.equals(Object obj)
当且仅当参数不是 null，而是一个与此对象一样，都表示同一个 Boolean 值的 boolean 对象时，才返回 true。

boolean

StackTraceElement.equals(Object obj)
如果指定的对象是另一个 StackTraceElement 实例，并且该对象表示的执行点与该实例的相同，则返回 ture。

boolean

String.equals(Object anObject)
将此字符串与指定的对象比较。

boolean

Object.equals(Object obj)
指示其他某个对象是否与此对象“相等”。

static String

String.format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数返回一个格式化字符串。

static String

String.format(String format, Object... args)
使用指定的格式字符串和参数返回一个格式化字符串。

static boolean

Thread.holdsLock(Object obj)
当且仅当当前线程在指定的对象上保持监视器锁时，才返回 true。

static int

System.identityHashCode(Object x)
返回给定对象的哈希码，该代码与默认的方法 hashCode() 返回的代码一样，无论给定对象的类是否重写 hashCode()。

StringBuilder

StringBuilder.insert(int offset, Object obj)

StringBuffer

StringBuffer.insert(int offset, Object obj)

boolean

Class.isInstance(Object obj)
判定指定的 Object 是否与此 Class 所表示的对象赋值兼容。

protected  void

ClassLoader.setSigners(Class<?> c, Object[] signers)
设置类的签署者。

static String

String.valueOf(Object obj)
返回 Object 参数的字符串表示形式。

参数类型为 Object 的 java.lang 中的构造方法

AssertionError(Object detailMessage)
构造一个 AssertionError，其详细消息派生于指定的对象，该对象将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。

java.lang.annotation 中 Object 的使用

java.lang.annotation 中 Object 的子类

class

AnnotationFormatError
当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。

class

AnnotationTypeMismatchException
若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。

class

IncompleteAnnotationException
若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。

参数类型为 Object 的 java.lang.annotation 中的方法

boolean

Annotation.equals(Object obj)
如果指定的对象表示在逻辑上等效于此接口的注释，则返回 true。

java.lang.instrument 中 Object 的使用

java.lang.instrument 中 Object 的子类

class

ClassDefinition
此类用作 Instrumentation.redefineClasses 方法的参数锁定。

class

IllegalClassFormatException
当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。

class

UnmodifiableClassException
在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

参数类型为 Object 的 java.lang.instrument 中的方法

long

Instrumentation.getObjectSize(Object objectToSize)
返回指定对象使用的特定于实现的近似存储量。

java.lang.management 中 Object 的使用

java.lang.management 中 Object 的子类

class

LockInfo
关于锁 的信息。

class

ManagementFactory
ManagementFactory 类是一种工厂类，用于获取 Java 平台的管理 Bean。

class

ManagementPermission
使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。

class

MemoryNotificationInfo
关于内存通知的信息。

class

MemoryUsage
表示内存使用量快照的 MemoryUsage 对象。

class

MonitorInfo
关于对象监视器锁的信息。

class

ThreadInfo
线程信息。

java.lang.ref 中 Object 的使用

java.lang.ref 中 Object 的子类

class

PhantomReference<T>
虚引用对象，在回收器确定其指示对象可另外回收之后，被加入队列。

class

Reference<T>
引用对象的抽象基类。

class

ReferenceQueue<T>
引用队列，在检测到适当的可到达性更改后，垃圾回收器将已注册的引用对象添加到该队列中。

class

SoftReference<T>
软引用对象，在响应内存需要时，由垃圾回收器决定是否清除此对象。

class

WeakReference<T>
弱引用对象，它们并不禁止其指示对象变得可终结，并被终结，然后被回收。

java.lang.reflect 中 Object 的使用

java.lang.reflect 中 Object 的子类

class

AccessibleObject
AccessibleObject 类是 Field、Method 和 Constructor 对象的基类。

class

Array
Array 类提供了动态创建和访问 Java 数组的方法。

class

Constructor<T>
Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。

class

Field
Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。

class

GenericSignatureFormatError
当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。

class

InvocationTargetException
InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。

class

MalformedParameterizedTypeException
当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。

class

Method
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

class

Modifier
Modifier 类提供了 static 方法和常量，对类和成员访问修饰符进行解码。

class

Proxy
Proxy 提供用于创建动态代理类和实例的静态方法，它还是由这些方法创建的所有动态代理类的超类。

class

ReflectPermission
反射操作的 Permission 类。

class

UndeclaredThrowableException
如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

返回 Object 的 java.lang.reflect 中的方法

Object

Field.get(Object obj)
返回指定对象上此 Field 表示的字段的值。

static Object

Array.get(Object array, int index)
返回指定数组对象中索引组件的值。

Object

Method.getDefaultValue()
返回由此 Method 实例表示的注释成员的默认值。

Object

InvocationHandler.invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

Object

Method.invoke(Object obj, Object... args)
对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。

static Object

Array.newInstance(Class<?> componentType, int... dimensions)
创建一个具有指定的组件类型和维度的新数组。

static Object

Array.newInstance(Class<?> componentType, int length)
创建一个具有指定的组件类型和长度的新数组。

static Object

Proxy.newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)
返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。

参数类型为 Object 的 java.lang.reflect 中的方法

boolean

Constructor.equals(Object obj)
将此 Constructor 对象与指定的对象进行比较。

boolean

Method.equals(Object obj)
将此 Method 与指定对象进行比较。

boolean

Field.equals(Object obj)
将此 Field 与指定对象比较。

Object

Field.get(Object obj)
返回指定对象上此 Field 表示的字段的值。

static Object

Array.get(Object array, int index)
返回指定数组对象中索引组件的值。

boolean

Field.getBoolean(Object obj)
获取一个静态或实例 boolean 字段的值。

static boolean

Array.getBoolean(Object array, int index)
以 boolean 形式返回指定数组对象中索引组件的值。

byte

Field.getByte(Object obj)
获取一个静态或实例 byte 字段的值。

static byte

Array.getByte(Object array, int index)
以 byte 形式返回指定数组对象中索引组件的值。

char

Field.getChar(Object obj)
获取 char 类型或另一个通过扩展转换可以转换为 char 类型的基本类型的静态或实例字段的值。

static char

Array.getChar(Object array, int index)
以 char 形式返回指定数组对象中索引组件的值。

double

Field.getDouble(Object obj)
获取 double 类型或另一个通过扩展转换可以转换为 double 类型的基本类型的静态或实例字段的值。

static double

Array.getDouble(Object array, int index)
以 double 形式返回指定数组对象中索引组件的值。

float

Field.getFloat(Object obj)
获取 float 类型或另一个通过扩展转换可以转换为 float 类型的基本类型的静态或实例字段的值。

static float

Array.getFloat(Object array, int index)
以 float 形式返回指定数组对象中索引组件的值。

int

Field.getInt(Object obj)
获取 int 类型或另一个通过扩展转换可以转换为 int 类型的基本类型的静态或实例字段的值。

static int

Array.getInt(Object array, int index)
以 int 形式返回指定数组对象中索引组件的值。

static InvocationHandler

Proxy.getInvocationHandler(Object proxy)
返回指定代理实例的调用处理程序。

static int

Array.getLength(Object array)
以 int 形式返回指定数组对象的长度。

long

Field.getLong(Object obj)
获取 long 类型或另一个通过扩展转换可以转换为 long 类型的基本类型的静态或实例字段的值。

static long

Array.getLong(Object array, int index)
以 long 形式返回指定数组对象中索引组件的值。

short

Field.getShort(Object obj)
获取 short 类型或另一个通过扩展转换可以转换为 short 类型的基本类型的静态或实例字段的值。

static short

Array.getShort(Object array, int index)
以 short 形式返回指定数组对象中索引组件的值。

Object

InvocationHandler.invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

Object

InvocationHandler.invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

Object

Method.invoke(Object obj, Object... args)
对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。

Object

Method.invoke(Object obj, Object... args)
对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。

T

Constructor.newInstance(Object... initargs)
使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。

static void

Array.set(Object array, int index, Object value)
将指定数组对象中索引组件的值设置为指定的新值。

void

Field.set(Object obj, Object value)
将指定对象变量上此 Field 对象表示的字段设置为指定的新值。

void

Field.setBoolean(Object obj, boolean z)
将字段的值设置为指定对象上的一个 boolean 值。

static void

Array.setBoolean(Object array, int index, boolean z)
将指定数组对象中索引组件的值设置为指定的 boolean 值。

void

Field.setByte(Object obj, byte b)
将字段的值设置为指定对象上的一个 byte 值。

static void

Array.setByte(Object array, int index, byte b)
将指定数组对象中索引组件的值设置为指定的 byte 值。

void

Field.setChar(Object obj, char c)
将字段的值设置为指定对象上的一个 char 值。

static void

Array.setChar(Object array, int index, char c)
将指定数组对象中索引组件的值设置为指定的 char 值。

void

Field.setDouble(Object obj, double d)
将字段的值设置为指定对象上的一个 double 值。

static void

Array.setDouble(Object array, int index, double d)
将指定数组对象中索引组件的值设置为指定的 double 值。

void

Field.setFloat(Object obj, float f)
将字段的值设置为指定对象上的一个 float 值。

static void

Array.setFloat(Object array, int index, float f)
将指定数组对象中索引组件的值设置为指定的 float 值。

void

Field.setInt(Object obj, int i)
将字段的值设置为指定对象上的一个 int 值。

static void

Array.setInt(Object array, int index, int i)
将指定数组对象中索引组件的值设置为指定的 int 值。

static void

Array.setLong(Object array, int index, long l)
将指定数组对象中索引组件的值设置为指定的 long 值。

void

Field.setLong(Object obj, long l)
将字段的值设置为指定对象上的一个 long 值。

static void

Array.setShort(Object array, int index, short s)
将指定数组对象中索引组件的值设置为指定的 short 值。

void

Field.setShort(Object obj, short s)
将字段的值设置为指定对象上的一个 short 值。

java.math 中 Object 的使用

java.math 中 Object 的子类

class

BigDecimal
不可变的、任意精度的有符号十进制数。

class

BigInteger
不可变的任意精度的整数。

class

MathContext
该对象是封装上下文设置的不可变对象，它描述数字运算符的某些规则，例如由 BigDecimal 类实现的规则。

参数类型为 Object 的 java.math 中的方法

boolean

BigDecimal.equals(Object x)
比较此 BigDecimal 与指定的 Object 的相等性。

boolean

MathContext.equals(Object x)
将此 MathContext 与指定的 Object 进行相等性比较。

boolean

BigInteger.equals(Object x)
比较此 BigInteger 与指定的 Object 的相等性。

java.net 中 Object 的使用

java.net 中 Object 的子类

class

Authenticator
Authenticator 类表示懂得如何获得网络连接验证的对象。

class

BindException
试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。

class

CacheRequest
表示在 ResponseCache 中存储资源的通道。

class

CacheResponse
表示从 ResponseCache 获取资源的通道。

class

ContentHandler
抽象类 ContentHandler 是从 URLConnection 读取 Object 的所有类的超类。

class

CookieHandler
CookieHandler 对象提供一种回调机制以将 HTTP 状态管理策略实现挂钩到 HTTP 协议处理程序。

class

CookieManager
CookieManager 提供 CookieHandler 的具体实现，它将 cookie 的存储区与围绕接受和拒绝 cookie 的策略分离开来。

class

DatagramPacket
此类表示数据报包。

class

DatagramSocket
此类表示用来发送和接收数据报包的套接字。

class

DatagramSocketImpl
数据报和多播套接字实现的抽象基类。

class

HttpCookie
HttpCookie 对象表示一个 http cookie，该 cookie 带有服务器和用户代理之间的状态信息。

class

HttpRetryException
抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。

class

HttpURLConnection
支持 HTTP 特定功能的 URLConnection。

class

IDN
提供在普通 Unicode 表示形式和 ASCII 兼容性编码 (ACE) 表示形式之间进行国际化域名 (IDN) 转换的方法。

class

Inet4Address
此类表示 Internet Protocol version 4 (IPv4) 地址。

class

Inet6Address
此类表示互联网协议第 6 版 (IPv6) 地址。

class

InetAddress
此类表示互联网协议 (IP) 地址。

class

InetSocketAddress
此类实现 IP 套接字地址（IP 地址 + 端口号）。

class

InterfaceAddress
此类表示网络接口地址。

class

JarURLConnection
连接到 Java ARchive (JAR) 文件或 JAR 文件中条目的 URL Connection。

class

MalformedURLException
抛出这一异常指示出现了错误的 URL。

class

MulticastSocket
多播数据报套接字类用于发送和接收 IP 多播包。

class

NetPermission
此类可用于各种网络权限。

class

NetworkInterface
此类表示一个由名称和分配给此接口的 IP 地址列表组成的网络接口。

class

NoRouteToHostException
试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。

class

PasswordAuthentication
PasswordAuthentication 类是供 Authenticator 使用的数据持有者。

class

PortUnreachableException
在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。

class

ProtocolException
抛出此异常指示在底层协议中存在错误，如 TCP 错误。

class

ProxySelector
连接到 URL 引用的网络资源时选择要使用的代理服务器（如果有）。

class

ResponseCache
表示 URLConnection 缓存的实现。

class

SecureCacheResponse
表示最初通过安全方法（如 TLS）获得的缓存响应。

class

ServerSocket
此类实现服务器套接字。

class

Socket
此类实现客户端套接字（也可以就叫“套接字”）。

class

SocketAddress
此类表示不带任何协议附件的 Socket Address。

class

SocketException
抛出此异常指示在底层协议中存在错误，如 TCP 错误。

class

SocketImpl
抽象类 SocketImpl 是实际实现套接字的所有类的通用超类。

class

SocketPermission
此类表示通过套接字对网络的访问。

class

SocketTimeoutException
如果在读取或接受套接字时发生超时，则抛出此异常。

class

UnknownHostException
指示主机 IP 地址无法确定而抛出的异常。

class

UnknownServiceException
抛出这一异常指示出现了未知服务异常。

class

URI
表示一个统一资源标识符 (URI) 引用。

class

URISyntaxException
抛出经过检查的指示字符串不能解析为 URI 引用的异常。

class

URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

class

URLClassLoader
该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。

class

URLConnection
抽象类 URLConnection 是所有类的超类，它代表应用程序和 URL 之间的通信链接。

class

URLDecoder
HTML 格式解码的实用工具类。

class

URLEncoder
HTML 格式编码的实用工具类。

class

URLStreamHandler
抽象类 URLStreamHandler 是所有流协议处理程序的通用超类。

返回 Object 的 java.net 中的方法

Object

HttpCookie.clone()
创建并返回此对象的一个副本。

Object

URLConnection.getContent()
获取此 URL 连接的内容。

Object

URL.getContent()
获取此 URL 的内容。

Object

URLConnection.getContent(Class[] classes)
获取此 URL 连接的内容。

Object

URL.getContent(Class[] classes)
获取此 URL 的内容。

abstract  Object

ContentHandler.getContent(URLConnection urlc)
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并根据其创建对象。

Object

ContentHandler.getContent(URLConnection urlc, Class[] classes)
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。

Object

SocketOptions.getOption(int optID)
获取选项的值。

参数类型为 Object 的 java.net 中的方法

boolean

HttpCookie.equals(Object obj)
测试两个 http cookie 的相等性。

boolean

SocketPermission.equals(Object obj)
检查两个 SocketPermission 对象的相等性。

boolean

InterfaceAddress.equals(Object obj)
将此对象与指定对象比较。

boolean

NetworkInterface.equals(Object obj)
将此对象与指定对象比较。

boolean

Proxy.equals(Object obj)
将此对象与指定对象比较。

boolean

URI.equals(Object ob)
测试此 URI 与另一对象的相等性。

boolean

Inet6Address.equals(Object obj)
将此对象与指定对象比较。

boolean

InetSocketAddress.equals(Object obj)
将此对象与指定对象比较。

boolean

Inet4Address.equals(Object obj)
将此对象与指定对象比较。

boolean

InetAddress.equals(Object obj)
将此对象与指定对象比较。

boolean

URL.equals(Object obj)
比较此 URL 是否等于另一个对象。

void

SocketOptions.setOption(int optID, Object value)
启用/禁用 optID 指定的选项。

java.nio 中 Object 的使用

java.nio 中 Object 的子类

class

Buffer
一个用于特定基本类型数据的容器。

class

BufferOverflowException
当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。

class

BufferUnderflowException
当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。

class

ByteBuffer
字节缓冲区。

class

ByteOrder
字节顺序的类型安全枚举。

class

CharBuffer
字符缓冲区。

class

DoubleBuffer
double 缓冲区。

class

FloatBuffer
float 缓冲区。

class

IntBuffer
int 缓冲区。

class

InvalidMarkException
当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。

class

LongBuffer
long 缓冲区。

class

MappedByteBuffer
直接字节缓冲区，其内容是文件的内存映射区域。

class

ReadOnlyBufferException
当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

class

ShortBuffer
short 缓冲区。

返回 Object 的 java.nio 中的方法

abstract  Object

Buffer.array()
返回此缓冲区的底层实现数组（可选操作）。

参数类型为 Object 的 java.nio 中的方法

boolean

DoubleBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

FloatBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

LongBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

ShortBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

IntBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

CharBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

ByteBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

java.nio.channels 中 Object 的使用

java.nio.channels 中 Object 的子类

class

AlreadyConnectedException
试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。

class

AsynchronousCloseException
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。

class

CancelledKeyException
当试图使用不再有效的选择键时，抛出此未经检查的异常。

class

Channels
针对信道和流的实用工具方法。

class

ClosedByInterruptException
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。

class

ClosedChannelException
当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。

class

ClosedSelectorException
试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。

class

ConnectionPendingException
试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。

class

DatagramChannel
针对面向数据报套接字的可选择通道。

class

FileChannel
用于读取、写入、映射和操作文件的通道。

static class

FileChannel.MapMode
文件映射模式的类型安全的枚举。

class

FileLock
表示文件区域锁定的标记。

class

FileLockInterruptionException
当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。

class

IllegalBlockingModeException
当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。

class

IllegalSelectorException
试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。

class

NoConnectionPendingException
在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。

class

NonReadableChannelException
试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。

class

NonWritableChannelException
试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。

class

NotYetBoundException
试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。

class

NotYetConnectedException
试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。

class

OverlappingFileLockException
试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。

class

Pipe
实现单向管道传送的通道对。

static class

Pipe.SinkChannel
表示 Pipe 的可写入结尾的通道。

static class

Pipe.SourceChannel
表示 Pipe 的可读取结尾的通道。

class

SelectableChannel
可通过 Selector 实现多路复用的通道。

class

SelectionKey
表示 SelectableChannel 在 Selector 中的注册的标记。

class

Selector
SelectableChannel 对象的多路复用器。

class

ServerSocketChannel
针对面向流的侦听套接字的可选择通道。

class

SocketChannel
针对面向流的连接套接字的可选择通道。

class

UnresolvedAddressException
试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。

class

UnsupportedAddressTypeException
试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

返回 Object 的 java.nio.channels 中的方法

Object

SelectionKey.attach(Object ob)
将给定的对象附加到此键。

Object

SelectionKey.attachment()
获取当前的附加对象。

abstract  Object

SelectableChannel.blockingLock()
获取其 configureBlocking 和 register 方法实现同步的对象。

参数类型为 Object 的 java.nio.channels 中的方法

Object

SelectionKey.attach(Object ob)
将给定的对象附加到此键。

abstract  SelectionKey

SelectableChannel.register(Selector sel, int ops, Object att)
向给定的选择器注册此通道，返回一个选择键。

java.nio.channels.spi 中 Object 的使用

java.nio.channels.spi 中 Object 的子类

class

AbstractInterruptibleChannel
可中断通道的基本实现类。

class

AbstractSelectableChannel
可选择通道的基本实现类。

class

AbstractSelectionKey
选择键的基本实现类。

class

AbstractSelector
选择器的基本实现类。

class

SelectorProvider
用于选择器和可选择通道的服务提供者类。

返回 Object 的 java.nio.channels.spi 中的方法

Object

AbstractSelectableChannel.blockingLock()

参数类型为 Object 的 java.nio.channels.spi 中的方法

protected abstract  SelectionKey

AbstractSelector.register(AbstractSelectableChannel ch, int ops, Object att)
向此选择器注册给定的通道。

SelectionKey

AbstractSelectableChannel.register(Selector sel, int ops, Object att)
向给定的选择器注册此通道，返回一个选择键。

java.nio.charset 中 Object 的使用

java.nio.charset 中 Object 的子类

class

CharacterCodingException
出现字符编码或解码错误时，抛出此经过检查的异常。

class

Charset
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。

class

CharsetDecoder
能够把特定 charset 中的字节序列转换成 16 位 Unicode 字符序列的引擎。

class

CharsetEncoder
能够把 16 位 Unicode 字符序列转换成特定 charset 中字节序列的引擎。

class

CoderMalfunctionError
当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。

class

CoderResult
coder 结果状态的描述。

class

CodingErrorAction
编码错误操作的类型安全的枚举。

class

IllegalCharsetNameException
将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。

class

MalformedInputException
当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。

class

UnmappableCharacterException
当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。

class

UnsupportedCharsetException
当不支持请求的 charset 时，抛出此未经检查的异常。

参数类型为 Object 的 java.nio.charset 中的方法

boolean

Charset.equals(Object ob)
通知此对象是否和其他对象相等。

java.nio.charset.spi 中 Object 的使用

java.nio.charset.spi 中 Object 的子类

class

CharsetProvider
Charset 服务提供者类。

java.rmi 中 Object 的使用

java.rmi 中 Object 的子类

class

AccessException
AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。

class

AlreadyBoundException
如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。

class

ConnectException
如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。

class

ConnectIOException
如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。

class

MarshalledObject<T>
MarshalledObject 包含一个字节流，该流具有给定了其构造方法的对象的序列化表示形式。

class

Naming
Naming 类提供在对象注册表中存储和获得远程对远程对象引用的方法。

class

NoSuchObjectException
如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。

class

NotBoundException
如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。

class

RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

class

RMISecurityException
已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。

class

RMISecurityManager
由使用下载的代码的 RMI 应用程序使用的 SecurityManager 的子类。

class

ServerError
当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。

class

ServerException
在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。

class

ServerRuntimeException
已过时。 无替换版本

class

StubNotFoundException
如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。

class

UnexpectedException
如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。

class

UnmarshalException
在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

参数类型为 Object 的 java.rmi 中的方法

boolean

MarshalledObject.equals(Object obj)
将此 MarshalledObject 与另一对象进行比较。

java.rmi.activation 中 Object 的使用

java.rmi.activation 中 Object 的子类

class

Activatable
Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。

class

ActivateFailedException
在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。

class

ActivationDesc
激活描述符包含激活对象所必需的信息： 对象的组标识符， 对象的完全限定的类名， 对象的代码基（类中的位置），一个代码基 URL 路径， 对象的重启“模式”，以及 一个可包含特定于对象的初始化数据的“编组”对象。

class

ActivationException
激活接口所使用的一般异常。

class

ActivationGroup
ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。

class

ActivationGroup_Stub
ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

class

ActivationGroupDesc
激活组描述符包含了创建/重建在其中激活对象的一个激活组所必需的信息。

static class

ActivationGroupDesc.CommandEnvironment
ActivationGroup 实现的启动选项。

class

ActivationGroupID
针对一个注册激活组的标识符，它完成几个目标： 在激活系统中唯一地标识该组，以及 包含指向该组的激活系统的引用，以便该组在必要时能够联络上其激活系统。

class

ActivationID
激活利用特定的标识符来表示远程对象，对象能随着时间被激活。

class

UnknownGroupException
当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。

class

UnknownObjectException
当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

参数类型为 Object 的 java.rmi.activation 中的方法

boolean

ActivationDesc.equals(Object obj)
比较两个激活描述符的内容相等性。

boolean

ActivationGroupDesc.equals(Object obj)
比较两个激活组描述符的内容相等性。

boolean

ActivationGroupDesc.CommandEnvironment.equals(Object obj)
比较两个命令环境的内容相等性。

boolean

ActivationGroupID.equals(Object obj)
比较两个组标识符的内容相等性。

boolean

ActivationID.equals(Object obj)
比较两个激活 id 的内容相等性。

java.rmi.dgc 中 Object 的使用

java.rmi.dgc 中 Object 的子类

class

Lease
一个 lease 包含了一个唯一的 VM 标识符和一个租借期限。

class

VMID
VMID 是跨所有 Java 虚拟机都唯一的标识符。

参数类型为 Object 的 java.rmi.dgc 中的方法

boolean

VMID.equals(Object obj)
将此 VMID 与另一个进行比较，如果它们是同一标识符，则返回 true。

java.rmi.registry 中 Object 的使用

java.rmi.registry 中 Object 的子类

class

LocateRegistry
LocateRegistry 用于获得对特定主机（包括本地主机）上引导远程对象注册表的引用，或用于创建一个接受对特定端口调用的远程对象注册表。

java.rmi.server 中 Object 的使用

java.rmi.server 中 Object 的子类

class

ExportException
ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。

class

LogStream
已过时。 无替代版本

class

ObjID
ObjID 是用于标识导出到 RMI 运行时的远程对象。

class

Operation
已过时。 无替代版本

class

RemoteObject
该 RemoteObject 类实现远程对象的 java.lang.Object 行为。

class

RemoteObjectInvocationHandler
与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。

class

RemoteServer
该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。

class

RemoteStub
该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。

class

RMIClassLoader
RMIClassLoader 包含支持用 RMI 进行动态类加载的静态方法。

class

RMIClassLoaderSpi
RMIClassLoaderSpi 是 RMIClassLoader 的服务提供者接口。

class

RMISocketFactory
RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。

class

ServerCloneException
如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。

class

ServerNotActiveException
如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。

class

SkeletonMismatchException
已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。

class

SkeletonNotFoundException
已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。

class

SocketSecurityException
已废弃的 ExportException 的子类。

class

UID
UID 表示一个和生成它的主机的时间有关的唯一标识符，或者是 216 个“熟知”标识符之一。

class

UnicastRemoteObject
用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

返回 Object 的 java.rmi.server 中的方法

Object

UnicastRemoteObject.clone()
返回与初始对象不同的远程对象的副本。

Object

LoaderHandler.getSecurityContext(ClassLoader loader)
已过时。 无替代版本

static Object

RMIClassLoader.getSecurityContext(ClassLoader loader)
已过时。 无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。

Object

RemoteObjectInvocationHandler.invoke(Object proxy, Method method, Object[] args)
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。

Object

RemoteRef.invoke(Remote obj, Method method, Object[] params, long opnum)
调用某个方法。

参数类型为 Object 的 java.rmi.server 中的方法

boolean

ObjID.equals(Object obj)
比较指定对象与此 ObjID 是否相等。

boolean

RemoteObject.equals(Object obj)
比较两个远程对象是否相等。

boolean

UID.equals(Object obj)
比较给定对象与此 UID 的相等性。

RemoteStub

ServerRef.exportObject(Remote obj, Object data)
为提供的 Remote 对象创建客户机 stub 对象。

Object

RemoteObjectInvocationHandler.invoke(Object proxy, Method method, Object[] args)
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。

Object

RemoteObjectInvocationHandler.invoke(Object proxy, Method method, Object[] args)
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。

Object

RemoteRef.invoke(Remote obj, Method method, Object[] params, long opnum)
调用某个方法。

java.security 中 Object 的使用

java.security 中 Object 的子类

class

AccessControlContext
AccessControlContext 用于基于它所封装的上下文作出系统资源访问决定。

class

AccessControlException
此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。

class

AccessController
AccessController 类用于与访问控制相关的操作和决定。

class

AlgorithmParameterGenerator
AlgorithmParameterGenerator 类用于生成将在某个特定算法中使用的参数集合。

class

AlgorithmParameterGeneratorSpi
此类为 AlgorithmParameterGenerator 类定义服务提供者接口 (SPI)，AlgorithmParameterGenerator 类用于生成在某个特定算法中使用的参数集合。

class

AlgorithmParameters
此类用作密码参数的不透明表示形式。

class

AlgorithmParametersSpi
此类为 AlgorithmParameters 类定义服务提供者接口 (SPI)，AlgorithmParameters 类用于管理算法参数。

class

AllPermission
AllPermission 是暗含所有其他权限的权限。

class

AuthProvider
此类定义 provider 的登录和注销方法。

class

BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。

class

CodeSigner
此类封装关于代码签名者的信息。

class

CodeSource
此类扩展 codebase 的概念，不仅可以封装位置 (URL) 而且可以封装用于验证起源于该位置的签名代码的证书链。

class

DigestException
此为一般 Message Digest 异常。

class

DigestInputStream
使用通过流的位更新关联消息摘要的透明流。

class

DigestOutputStream
使用通过流的位更新关联消息摘要的透明流。

class

GeneralSecurityException
GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。

class

GuardedObject
GuardedObject 是一个用来保护对另一个对象的访问的对象。

class

Identity
已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。

class

IdentityScope
已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。

class

InvalidAlgorithmParameterException
用于无效或不合适的算法参数的异常。

class

InvalidKeyException
用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。

class

InvalidParameterException
当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。

class

KeyException
此异常是基本的密钥异常。

class

KeyFactory
密钥工厂用于将密钥（Key 类型的不透明加密密钥）转换成密钥规范（底层密钥材料的透明表示），反之亦然。

class

KeyFactorySpi
此类为 KeyFactory 类定义服务提供者接口 (SPI)。

class

KeyManagementException
此异常是用于所有处理密钥管理的操作的通用密钥管理异常。

class

KeyPair
此类是简单的密钥对（公钥和私钥）持有者。

class

KeyPairGenerator
KeyPairGenerator 类用于生成公钥和私钥对。

class

KeyPairGeneratorSpi
此类为用来生成公钥和私钥的 KeyPairGenerator 类定义了服务提供者接口 (SPI)。

class

KeyRep
已序列化的 Key 对象的标准表示形式。

class

KeyStore
此类表示密钥和证书的存储设施。

static class

KeyStore.Builder
将被实例化的 KeyStore 对象的描述。

static class

KeyStore.CallbackHandlerProtection
封装 CallbackHandler 的 ProtectionParameter。

static class

KeyStore.PasswordProtection
ProtectionParameter 的一个基于密码的实现。

static class

KeyStore.PrivateKeyEntry
保存 PrivateKey 和相应证书链的 KeyStore 项。

static class

KeyStore.SecretKeyEntry
保存 SecretKey 的 KeyStore 项。

static class

KeyStore.TrustedCertificateEntry
保存可信的 Certificate 的 KeyStore 项。

class

KeyStoreException
这是一般的 KeyStore 异常。

class

KeyStoreSpi
此类为 KeyStore 类定义服务提供者接口 (SPI)。

class

MessageDigest
此 MessageDigest 类为应用程序提供信息摘要算法的功能，如 MD5 或 SHA 算法。

class

MessageDigestSpi
此类为 MessageDigest 类定义服务提供者接口 (SPI)，MessageDigest 类提供信息摘要算法的功能，如 MD5 或 SHA。

class

NoSuchAlgorithmException
当请求特定的加密算法而它在该环境中不可用时抛出此异常。

class

NoSuchProviderException
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。

class

Permission
表示访问系统资源的抽象类。

class

PermissionCollection
表示 Permission 对象集合的抽象类。

class

Permissions
此类表示一个不同种类的 Permission 集合。

class

Policy
Policy 对象负责确定在 Java 运行时环境中执行的代码是否有权执行安全敏感的操作。

class

PolicySpi
此类为 Policy 类定义服务提供者接口 (SPI)。

class

PrivilegedActionException
doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。

class

ProtectionDomain
此 ProtectionDomain 类封装域的特征，域中包装一个类集合，在代表给定的主体集合执行这些类的实例时会授予它们一个权限集合。

static class

Provider.Service
安全服务的描述。

class

ProviderException
用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。

class

SecureClassLoader
此类扩展了 ClassLoader，使它另外还支持使用相关的代码源和权限定义类，这些代码源和权限默认情况下可根据系统策略获取到。

class

SecureRandom
此类提供强加密随机数生成器 (RNG)。

class

SecureRandomSpi
此类为 SecureRandom 类定义了服务提供者接口 (SPI)。

class

Security
此类集中了所有的安全属性和常见的安全方法。

class

SecurityPermission
此类用于安全权限。

class

Signature
此 Signature 类用来为应用程序提供数字签名算法功能。

class

SignatureException
这是一般的签名异常。

class

SignatureSpi
此类为 Signature 类定义了服务提供者接口 (SPI)，可用来提供数字签名算法功能。

class

SignedObject
SignedObject 是一个用来创建实际运行时对象的类，在检测不到这些对象的情况下，其完整性不会遭受损害。

class

Signer
已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。

class

Timestamp
此类封装有关签署时间戳的信息。

class

UnrecoverableEntryException
如果 keystore 中的某项无法恢复，则抛出此异常。

class

UnrecoverableKeyException
如果 keystore 中的密钥无法恢复，则抛出此异常。

class

UnresolvedPermission
UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。

class

URIParameter
包含一个 URI 的参数，该 URI 指向用于 PolicySpi 或 ConfigurationSpi 实现的数据。

返回 Object 的 java.security 中的方法

Object

Signature.clone()
如果此实现可以复制，则返回副本。

Object

SignatureSpi.clone()
如果此实现可以复制，则返回一个副本。

Object

MessageDigest.clone()
如果实现是可复制的，则返回一个副本。

Object

MessageDigestSpi.clone()
如果实现是可复制的，则返回一个副本。

protected abstract  Object

SignatureSpi.engineGetParameter(String param)
已过时。

Object

Provider.get(Object key)

Object

GuardedObject.getObject()
获取受保护对象；如果 guard 拒绝了对受保护对象的访问，则抛出异常。

Object

SignedObject.getObject()
获取已封装的对象。

Object

Signature.getParameter(String param)
已过时。

Object

Provider.Service.newInstance(Object constructorParameter)
返回此服务描述的实现的新实例。

Object

Provider.put(Object key, Object value)
设置 key 属性，使其具有指定的 value。

protected  Object

KeyRep.readResolve()
解析 Key 对象。

Object

Provider.remove(Object key)
移除 key 属性（及其相应的 value）。

返回变量类型为 Object 的类型的 java.security 中的方法

Enumeration<Object>

Provider.elements()

Set<Map.Entry<Object,Object>>

Provider.entrySet()
返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。

Set<Map.Entry<Object,Object>>

Provider.entrySet()
返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。

Enumeration<Object>

Provider.keys()

Set<Object>

Provider.keySet()
返回此 provider 中所包含的属性键的一个不可修改的 Set 视图。

Collection<Object>

Provider.values()
返回此 provider 中所包含的属性值的一个不可修改的 Collection 视图。

参数类型为 Object 的 java.security 中的方法

void

Permission.checkGuard(Object object)
为某权限实现 guard 接口。

void

Guard.checkGuard(Object object)
确定是否允许访问受保护的 object 对象。

protected abstract  void

SignatureSpi.engineSetParameter(String param, Object value)
已过时。 由 engineSetParameter 取代。

boolean

Identity.equals(Object identity)
已过时。 测试指定对象与此 Identity 的相等性。

boolean

Timestamp.equals(Object obj)
比较指定的对象和此时间戳之间的相同性。

boolean

CodeSigner.equals(Object obj)
测试指定对象与此代码签名者之间是否相等。

boolean

Principal.equals(Object another)
将此主体与指定对象比较。

boolean

UnresolvedPermission.equals(Object obj)
检查两个 UnresolvedPermission 对象的相等性。

boolean

AllPermission.equals(Object obj)
检查两个 AllPermission 对象是否相等。

boolean

CodeSource.equals(Object obj)
测试指定对象与此对象之间的相等性。

boolean

BasicPermission.equals(Object obj)
检查两个 BasicPermission 对象是否相等。

abstract  boolean

Permission.equals(Object obj)
检查两个 Permission 对象是否相等。

boolean

AccessControlContext.equals(Object obj)
检查两个 AccessControlContext 对象是否相等。

Object

Provider.get(Object key)

Object

Provider.Service.newInstance(Object constructorParameter)
返回此服务描述的实现的新实例。

Object

Provider.put(Object key, Object value)
设置 key 属性，使其具有指定的 value。

Object

Provider.remove(Object key)
移除 key 属性（及其相应的 value）。

void

Signature.setParameter(String param, Object value)
已过时。 使用 setParameter 取代。

boolean

Provider.Service.supportsParameter(Object parameter)
测试此 Service 是否能使用指定的参数。

参数类型为 Object 的 java.security 中的构造方法

GuardedObject(Object object, Guard guard)
使用指定的对象和 guard 构造 GuardedObject。

java.security.acl 中 Object 的使用

java.security.acl 中 Object 的子类

class

AclNotFoundException
如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。

class

LastOwnerException
如果试图删除访问控制列表的最后一个所有者，则抛出此异常。

class

NotOwnerException
当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。

返回 Object 的 java.security.acl 中的方法

Object

AclEntry.clone()
复制此 ACL 项。

参数类型为 Object 的 java.security.acl 中的方法

boolean

Permission.equals(Object another)
如果传递的对象与此接口中所表示的权限相匹配，则返回 true。

java.security.cert 中 Object 的使用

java.security.cert 中 Object 的子类

class

Certificate
管理各种身份证书的抽象类。

protected static class

Certificate.CertificateRep
用于序列化的替换 Certificate 类。

class

CertificateFactory
此类定义了用于从相关的编码中生成证书、证书路径 (CertPath) 和证书撤消列表 (CRL) 对象的 CertificateFactory 功能。

class

CertificateFactorySpi
此类定义了 CertificateFactory 类的服务提供者接口 (SPI)。

class

CertPath
不可变的证书序列（证书路径）。

protected static class

CertPath.CertPathRep
用于序列化的替换 CertPath 类。

class

CertPathBuilder
构建证书路径（也称为证书链）的类。

class

CertPathBuilderException
指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。

class

CertPathBuilderSpi
CertPathBuilder 类的服务提供者接口 (SPI)。

class

CertPathValidator
验证证书路径（也称为证书链）的类。

class

CertPathValidatorException
指示在验证一个证书路径时遇到了某种问题的异常。

class

CertPathValidatorSpi
CertPathValidator 类的服务提供者接口 (SPI)。

class

CertStore
用于从存储库中获取 Certificate 和 CRL 的类。

class

CertStoreException
指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。

class

CertStoreSpi
CertStore 类的服务提供者接口 (SPI)。

class

CollectionCertStoreParameters
用作 Collection CertStore 算法输入的参数。

class

CRL
此类是具有不同格式但很常用的证书撤消列表 (CRL) 的抽象。

class

CRLException
CRL（证书撤消列表）异常。

class

LDAPCertStoreParameters
用作 LDAP CertStore 算法的输入的参数。

class

PKIXBuilderParameters
用作 PKIX CertPathBuilder 算法的输入的参数。

class

PKIXCertPathBuilderResult
此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。

class

PKIXCertPathChecker
对 X509Certificate 执行一种或多种检查的抽象类。

class

PKIXCertPathValidatorResult
此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。

class

PKIXParameters
用作 PKIX CertPathValidator 算法的输入的参数。

class

PolicyQualifierInfo
由 ASN.1 PolicyQualifierInfo 结构所表示的、不可变的策略限定符。

class

TrustAnchor
一个信任定位点或最受信任的证书颁发机构 (CA)。

class

X509Certificate
X.509 证书的抽象类。

class

X509CertSelector
选择与所有指定标准匹配的 X509Certificates 的 CertSelector。

class

X509CRL
X.509 证书撤消列表 (CRL) 的抽象类。

class

X509CRLEntry
用于 CRL（证书撤消列表）中已撤消证书的抽象类。

class

X509CRLSelector
选择与所有指定标准相匹配的 X509CRL 的 CRLSelector。

返回 Object 的 java.security.cert 中的方法

Object

CRLSelector.clone()
对此 CRLSelector 进行复制。

Object

CertPathBuilderResult.clone()
对此 CertPathBuilderResult 进行复制。

Object

CertPathParameters.clone()
对此 CertPathParameters 进行复制。

Object

CertPathValidatorResult.clone()
对此 CertPathValidatorResult 进行复制。

Object

CertSelector.clone()
对此 CertSelector 进行复制。

Object

CertStoreParameters.clone()
对此 CertStoreParameters 进行复制。

Object

CollectionCertStoreParameters.clone()
返回此对象的副本。

Object

LDAPCertStoreParameters.clone()
返回此对象的副本。

Object

PKIXCertPathChecker.clone()
返回此对象的副本。

Object

PKIXCertPathValidatorResult.clone()
返回此对象的副本。

Object

PKIXParameters.clone()
对此 PKIXParameters 对象进行复制。

Object

X509CRLSelector.clone()
返回此对象的副本。

Object

X509CertSelector.clone()
返回此对象的副本。

protected  Object

CertPath.CertPathRep.readResolve()
返回根据类型和数据所构造的 CertPath。

protected  Object

Certificate.CertificateRep.readResolve()
解析该 Certificate 对象。

protected  Object

CertPath.writeReplace()
使用 CertPathRep 对象替换要被序列化的 CertPath。

protected  Object

Certificate.writeReplace()
替换要被序列化的 Certificate。

返回变量类型为 Object 的类型的 java.security.cert 中的方法

Collection<Object>

X509CRLSelector.getIssuerNames()
返回该 issuerNames 标准的一个副本。

参数类型为 Object 的 java.security.cert 中的方法

boolean

X509CRL.equals(Object other)
比较此 CRL 与给定对象的相等性。

boolean

X509CRLEntry.equals(Object other)
比较此 CRL 项与给定对象的相等性。

boolean

CertPath.equals(Object other)
比较此证书路径与指定对象的相等性。

boolean

Certificate.equals(Object other)
比较此证书与指定对象的相等性。

java.security.spec 中 Object 的使用

java.security.spec 中 Object 的子类

class

DSAParameterSpec
此类指定用于 DSA 算法的参数的集合。

class

DSAPrivateKeySpec
此类指定带关联参数的 DSA 专用密钥。

class

DSAPublicKeySpec
此类指定带关联参数的 DSA 公用密钥。

class

ECFieldF2m
此不可变类定义椭圆曲线 (EC) 首数为 2 的有限字段。

class

ECFieldFp
此不可变类定义椭圆曲线 (EC) 素数的有限字段。

class

ECGenParameterSpec
此不可变类指定用于生成椭圆曲线 (EC) 域参数的参数集。

class

ECParameterSpec
此不可变类指定用于椭圆曲线加密方法 (ECC) 的域参数集。

class

ECPoint
此不可变类在仿射坐标中表示椭圆曲线 (EC) 上的点。

class

ECPrivateKeySpec
此不可变类指定带关联参数的椭圆曲线专用密钥。

class

ECPublicKeySpec
此不可变类指定带关联参数的椭圆曲线公用密钥。

class

EllipticCurve
此不可变类持有表示椭圆曲线所必需的值。

class

EncodedKeySpec
此类用编码格式表示公用密钥或专用密钥。

class

InvalidKeySpecException
这是针对无效密钥规范的异常。

class

InvalidParameterSpecException
这是针对无效参数规范的异常。

class

MGF1ParameterSpec
此类指定 OAEP Padding 和 RSA-PSS 签名方案中的掩码生成函数 MGF1（如 PKCS #1 v2.1 标准中所定义的）使用的参数集。

class

PKCS8EncodedKeySpec
此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。

class

PSSParameterSpec
此类指定 RSA-PSS 签名方案的参数规范，如 PKCS#1 v2.1 标准中所定义的。

class

RSAKeyGenParameterSpec
此类指定用于生成 RSA 密钥对的参数集。

class

RSAMultiPrimePrivateCrtKeySpec
如 PKCS#1 v2.1 中所定义的，此类为了提高效率，使用 Chinese Remainder Theorem (CRT) 信息值指定 RSA 多素数专用密钥。

class

RSAOtherPrimeInfo
此类表示 RSA 的 OtherPrimeInfo 结构中的三元组（素数、指数和素数），如 PKCS#1 v2.1 中所定义的。

class

RSAPrivateCrtKeySpec
为了提高效率，此类根据 PKCS#1 标准所定义的，使用 Chinese Remainder Theorem（中国剩余定理，CRT）信息值指定一个 RSA 专用密钥。

class

RSAPrivateKeySpec
此类指定 RSA 专用密钥。

class

RSAPublicKeySpec
此类指定 RSA 公用密钥。

class

X509EncodedKeySpec
此类表示根据 ASN.1 类型 SubjectPublicKeyInfo 进行编码的公用密钥的 ASN.1 编码。

参数类型为 Object 的 java.security.spec 中的方法

boolean

ECFieldF2m.equals(Object obj)
比较此有限字段与指定对象的相等性。

boolean

ECFieldFp.equals(Object obj)
比较此素数有限字段与指定对象的相等性。

boolean

ECPoint.equals(Object obj)
比较此椭圆曲线点与指定对象的相等性。

boolean

EllipticCurve.equals(Object obj)
比较此椭圆曲线与指定对象的相等性。

java.sql 中 Object 的使用

java.sql 中 Object 的子类

class

BatchUpdateException
进行批量更新操作期间发生错误时抛出的 SQLException 子类。

class

DataTruncation
以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。

class

DriverManager
管理一组 JDBC 驱动程序的基本服务。

class

DriverPropertyInfo
用于建立连接的驱动程序属性。

class

SQLClientInfoException
当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。

class

SQLDataException
当 SQLState 类值为“22”时抛出的 SQLException 子类。

class

SQLException
提供关于数据库访问错误或其他错误信息的异常。

class

SQLFeatureNotSupportedException
当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。

class

SQLIntegrityConstraintViolationException
当 SQLState 类值为“23”时抛出的 SQLException 子类。

class

SQLInvalidAuthorizationSpecException
当 SQLState 类值为“28”时抛出的 SQLException 子类。

class

SQLNonTransientConnectionException
SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。

class

SQLNonTransientException
重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。

class

SQLPermission
SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。

class

SQLRecoverableException
应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。

class

SQLSyntaxErrorException
当 SQLState 类值为“42”时抛出的 SQLException 子类。

class

SQLTimeoutException
Statement 指定的超时已到期时抛出的 SQLException 子类。

class

SQLTransactionRollbackException
当 SQLState 类值为“40”时，抛出此 SQLException 的子类。

class

SQLTransientConnectionException
SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。

class

SQLTransientException
没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。

class

SQLWarning
提供关于数据库访问警告信息的异常。

class

Time
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。

class

Types
定义用于标识一般 SQL 类型（称为 JDBC 类型）的常量的类。

返回 Object 的 java.sql 中的方法

Object

Array.getArray()
以 Java 编程语言数组的形式获取由此 Array 对象指定的 SQL ARRAY 值的内容。

Object

Array.getArray(long index, int count)
获取由此 Array 对象指定的 SQL ARRAY 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。

Object

Array.getArray(long index, int count, Map<String,Class<?>> map)
获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。

Object

Array.getArray(Map<String,Class<?>> map)
获取由此 Array 对象指定的 SQL ARRAY 值的内容。

Object[]

Struct.getAttributes()
生成此 Struct 对象所表示的 SQL 结构类型属性的有序值。

Object[]

Struct.getAttributes(Map<String,Class<?>> map)
生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。

Object

Ref.getObject()
获取此 Ref 对象引用的 SQL 结构类型实例。

Object

CallableStatement.getObject(int parameterIndex)
以 Java 编程语言中 Object 的形式获取指定参数的值。

Object

ResultSet.getObject(int columnIndex)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

CallableStatement.getObject(int parameterIndex, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。

Object

ResultSet.getObject(int columnIndex, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

Ref.getObject(Map<String,Class<?>> map)
获取引用对象并使用给定类型映射表将其映射到 Java 类型。

Object

CallableStatement.getObject(String parameterName)
以 Java 编程语言中 Object 的形式获取参数的值。

Object

ResultSet.getObject(String columnLabel)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

CallableStatement.getObject(String parameterName, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。

Object

ResultSet.getObject(String columnLabel, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

SQLInput.readObject()
读取流头中的下一个属性并将其作为 Java 编程语言中的 Object 返回。

参数类型为 Object 的 java.sql 中的方法

Array

Connection.createArrayOf(String typeName, Object[] elements)
创建 Array 对象的工厂方法。

Struct

Connection.createStruct(String typeName, Object[] attributes)
创建 Struct 对象的工厂方法。

boolean

RowId.equals(Object obj)
将此 RowId 与指定对象比较。

boolean

Timestamp.equals(Object ts)
测试此对象是否等于给定的 Timestamp 对象。

void

PreparedStatement.setObject(int parameterIndex, Object x)
使用给定对象设置指定参数的值。

void

PreparedStatement.setObject(int parameterIndex, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

PreparedStatement.setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)
使用给定对象设置指定参数的值。

void

Ref.setObject(Object value)
将此 Ref 对象引用的结构类型值设置为给定的 Object 实例。

void

CallableStatement.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

CallableStatement.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

CallableStatement.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

void

ResultSet.updateObject(int columnIndex, Object x)
用 Object 值更新指定列。

void

ResultSet.updateObject(int columnIndex, Object x, int scaleOrLength)
用 Object 值更新指定列。

void

ResultSet.updateObject(String columnLabel, Object x)
用 Object 值更新指定列。

void

ResultSet.updateObject(String columnLabel, Object x, int scaleOrLength)
用 Object 值更新指定列。

java.text 中 Object 的使用

java.text 中 Object 的子类

class

Annotation
如果文本属性具有 annotation 特征，则 Annotation 对象用作文本属性值的包装器。

static class

AttributedCharacterIterator.Attribute
定义用于标识文本属性的属性键。

class

AttributedString
AttributedString 保存文本及相关属性信息。

class

Bidi
此类实现了 Unicode 双向算法 (Unicode Bidirectional Algorithm)。

class

BreakIterator
BreakIterator 类实现用于查找文本中边界位置的方法。

class

ChoiceFormat
ChoiceFormat 允许将格式应用到某个范围的数。

class

CollationElementIterator
CollationElementIterator 类用作一个迭代器，以遍历国际化字符串的每个字符。

class

CollationKey
CollationKey 表示遵守特定 Collator 对象规则的 String。

class

Collator
Collator 类执行区分语言环境的 String 比较。

class

DateFormat
DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。

static class

DateFormat.Field
定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。

class

DateFormatSymbols
DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。

class

DecimalFormat
DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。

class

DecimalFormatSymbols
此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。

class

FieldPosition
FieldPosition 是 Format 及其子类用于在格式输出中标识字段的简单类。

class

Format
Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。

static class

Format.Field
定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。

class

MessageFormat
MessageFormat 提供了以与语言无关方式生成连接消息的方式。

static class

MessageFormat.Field
在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。

class

Normalizer
此类提供 normalize 方法，它把 Unicode 文本转换为等效的组合或分解形式，允许对文本进行更方便地分类和搜索。

class

NumberFormat
NumberFormat 是所有数值格式的抽象基类。

static class

NumberFormat.Field
定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。

class

ParseException
表示解析时出现意外错误。

class

ParsePosition
ParsePosition 是 Format 及其子类所使用的简单类，用来在解析过程中跟踪当前位置。

class

RuleBasedCollator
RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。

class

SimpleDateFormat
SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。

class

StringCharacterIterator
StringCharacterIterator 为 String 实现 CharacterIterater 协议。

返回 Object 的 java.text 中的方法

Object

BreakIterator.clone()
创建此迭代器的副本。

Object

ChoiceFormat.clone()
重写 Cloneable

Object

StringCharacterIterator.clone()
创建此迭代器的副本。

Object

RuleBasedCollator.clone()
标准重写，无语义变化。

Object

Collator.clone()
重写 Cloneable

Object

DecimalFormat.clone()
标准重写；没有语义上的变化。

Object

DecimalFormatSymbols.clone()
标准重写。

Object

NumberFormat.clone()
重写 Cloneable

Object

DateFormatSymbols.clone()
重写 Cloneable。

Object

SimpleDateFormat.clone()
创建此 SimpleDateFormat 的一个副本。

Object

DateFormat.clone()
重写 Cloneable

Object

MessageFormat.clone()
创建并返回此对象的一个副本。

Object

Format.clone()
创建并返回此对象的一个副本。

Object

CharacterIterator.clone()
创建此迭代器的一个副本

Object

AttributedCharacterIterator.getAttribute(AttributedCharacterIterator.Attribute attribute)
返回当前字符的命名属性的值。

Object[]

ChoiceFormat.getFormats()
获取传入构造方法的 format。

Object

Annotation.getValue()
返回属性值，可能为 null。

Object[]

MessageFormat.parse(String source)
从给定字符串的开始位置解析文本，以生成一个对象数组。

Object[]

MessageFormat.parse(String source, ParsePosition pos)
解析字符串。

Object

Format.parseObject(String source)
从给定字符串的开始处解析文本以生成一个对象。

Object

NumberFormat.parseObject(String source, ParsePosition pos)
解析字符串中的文本，以生成一个 Number。

Object

DateFormat.parseObject(String source, ParsePosition pos)
解析字符串中的文本，以生成一个 Date。

Object

MessageFormat.parseObject(String source, ParsePosition pos)
解析字符串文本，生成一个对象数组。

abstract  Object

Format.parseObject(String source, ParsePosition pos)
解析字符串文本，生成一个对象。

protected  Object

AttributedCharacterIterator.Attribute.readResolve()
解析将被反序列化为预定义常量的实例。

protected  Object

NumberFormat.Field.readResolve()
将正被反序列化的实例解析为预定义的常量。

protected  Object

DateFormat.Field.readResolve()
将反序列化的实例解析成预定义的常量。

protected  Object

MessageFormat.Field.readResolve()
把正被反序列化的实例解析为预定义的常量。

返回变量类型为 Object 的类型的 java.text 中的方法

Map<AttributedCharacterIterator.Attribute,Object>

AttributedCharacterIterator.getAttributes()
返回具有定义于当前字符上的多个属性的映射。

参数类型为 Object 的 java.text 中的方法

void

AttributedString.addAttribute(AttributedCharacterIterator.Attribute attribute, Object value)
将一个属性添加到整个字符串中。

void

AttributedString.addAttribute(AttributedCharacterIterator.Attribute attribute, Object value, int beginIndex, int endIndex)
将一个属性添加到字符串的子范围。

int

Collator.compare(Object o1, Object o2)
比较此方法两个参数的顺序。

boolean

AttributedCharacterIterator.Attribute.equals(Object obj)
比较两个对象的相等性。

boolean

ChoiceFormat.equals(Object obj)
两个对象之间的相等性比较。

boolean

ParsePosition.equals(Object obj)
重写 equals

boolean

StringCharacterIterator.equals(Object obj)
比较两个 StringCharacterIterator 对象的相等性。

boolean

RuleBasedCollator.equals(Object obj)
比较两个 collation 对象的相等性。

boolean

Collator.equals(Object that)
比较两个 Collator 的相等性。

boolean

DecimalFormat.equals(Object obj)
重写 equals

boolean

DecimalFormatSymbols.equals(Object obj)
重写 equals。

boolean

NumberFormat.equals(Object obj)
重写 equals

boolean

DateFormatSymbols.equals(Object obj)
重写 equals。

boolean

SimpleDateFormat.equals(Object obj)
比较给定对象与此 SimpleDateFormat 的相等性。

boolean

DateFormat.equals(Object obj)
重写 equals

boolean

FieldPosition.equals(Object obj)
重写 equals

boolean

MessageFormat.equals(Object obj)
两个消息格式对象之间的相等性比较

String

Format.format(Object obj)
格式化一个对象以生成一个字符串。

StringBuffer

MessageFormat.format(Object[] arguments, StringBuffer result, FieldPosition pos)
格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。

StringBuffer

DecimalFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos)
格式化一个数，并将所得文本追加到给定的字符串缓冲区。

StringBuffer

NumberFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos)
格式化一个数并将所得文本添加到给定字符串缓冲区。

StringBuffer

DateFormat.format(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition)
重写 Format。

StringBuffer

MessageFormat.format(Object arguments, StringBuffer result, FieldPosition pos)
格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。

abstract  StringBuffer

Format.format(Object obj, StringBuffer toAppendTo, FieldPosition pos)
格式化一个对象，并将得到的文本添加到给定的字符缓冲区。

static String

MessageFormat.format(String pattern, Object... arguments)
创建具有给定模式的 MessageFormat，并用它来格式化给定的参数。

AttributedCharacterIterator

DecimalFormat.formatToCharacterIterator(Object obj)
格式化一个 Object，以生成一个 AttributedCharacterIterator。

AttributedCharacterIterator

SimpleDateFormat.formatToCharacterIterator(Object obj)
格式化生成 AttributedCharacterIterator 的对象。

AttributedCharacterIterator

MessageFormat.formatToCharacterIterator(Object arguments)
格式化一个对象数组，并将它们插入 MessageFormat 的模式中，生成一个 AttributedCharacterIterator。

AttributedCharacterIterator

Format.formatToCharacterIterator(Object obj)
格式化一个对象，生成一个 AttributedCharacterIterator。

static void

Bidi.reorderVisually(byte[] levels, int levelStart, Object[] objects, int objectStart, int count)
根据对象的层次，在数组中将对象重新排序为可视顺序。

参数类型为 Object 的 java.text 中的构造方法

Annotation(Object value)
构造一条具有给定值（可能为 null）的 annotation 记录。

java.text.spi 中 Object 的使用

java.text.spi 中 Object 的子类

class

BreakIteratorProvider
提供 BreakIterator 类具体实现的服务提供者的抽象类。

class

CollatorProvider
提供 Collator 类具体实现的服务提供者的抽象类。

class

DateFormatProvider
提供 DateFormat 类具体实现的服务提供者的抽象类。

class

DateFormatSymbolsProvider
提供 DateFormatSymbols 类实例的服务提供者的抽象类。

class

DecimalFormatSymbolsProvider
提供 DecimalFormatSymbols 类实例的服务提供者的抽象类。

class

NumberFormatProvider
提供 NumberFormat 类具体实现的服务提供者的抽象类。

java.util 中 Object 的使用

java.util 中 Object 的子类

class

AbstractCollection<E>
此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。

class

AbstractList<E>
此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。

class

AbstractMap<K,V>
此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。

static class

AbstractMap.SimpleEntry<K,V>
维护键和值的 Entry。

static class

AbstractMap.SimpleImmutableEntry<K,V>
维护不可变的键和值的 Entry。

class

AbstractQueue<E>
此类提供某些 Queue 操作的骨干实现。

class

AbstractSequentialList<E>
此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。

class

AbstractSet<E>
此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。

class

ArrayDeque<E>
Deque 接口的大小可变数组的实现。

class

ArrayList<E>
List 接口的大小可变数组的实现。

class

Arrays
此类包含用来操作数组（比如排序和搜索）的各种方法。

class

BitSet
此类实现了一个按需增长的位向量。

class

Calendar
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。

class

Collections
此类完全由在 collection 上进行操作或返回 collection 的静态方法组成。

class

ConcurrentModificationException
当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。

class

Currency
表示货币。

class

Date
类 Date 表示特定的瞬间，精确到毫秒。

class

Dictionary<K,V>
Dictionary 类是任何可将键映射到相应值的类（如 Hashtable）的抽象父类。

class

DuplicateFormatFlagsException
格式说明符中提供重复标志时抛出的未经检查的异常。

class

EmptyStackException
该异常由 Stack 类中的方法抛出，以表明堆栈为空。

class

EnumMap<K extends Enum<K>,V>
与枚举类型键一起使用的专用 Map 实现。

class

EnumSet<E extends Enum<E>>
与枚举类型一起使用的专用 Set 实现。

class

EventListenerProxy
将一组附加参数与侦听器关联的 EventListener 类的抽象包装器类。

class

EventObject
所有事件状态对象都将从其派生的根类。

class

FormatFlagsConversionMismatchException
转换与标志不兼容时抛出未经检查的异常。

class

FormattableFlags
将 FomattableFlags 传递给 Formattable.formatTo() 方法，并修改 Formattables 的输出格式。

class

Formatter
printf 风格的格式字符串的解释程序。

class

FormatterClosedException
格式器已关闭时抛出的未经检查的异常。

class

GregorianCalendar
GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。

class

HashMap<K,V>
基于哈希表的 Map 接口的实现。

class

HashSet<E>
此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。

class

Hashtable<K,V>
此类实现一个哈希表，该哈希表将键映射到相应的值。

class

IdentityHashMap<K,V>
此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。

class

IllegalFormatCodePointException
将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。

class

IllegalFormatConversionException
当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。

class

IllegalFormatException
当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。

class

IllegalFormatFlagsException
当给出非法组合标志时，抛出未经检查的异常。

class

IllegalFormatPrecisionException
当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。

class

IllegalFormatWidthException
当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。

class

InputMismatchException
由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。

class

InvalidPropertiesFormatException
当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。

class

LinkedHashMap<K,V>
Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。

class

LinkedHashSet<E>
具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。

class

LinkedList<E>
List 接口的链接列表实现。

class

ListResourceBundle
ListResourceBundle 是 ResourceBundle 的一个抽象类，用于管理方便而又易于使用的列表中的语言环境资源。

class

Locale
Locale 对象表示了特定的地理、政治和文化地区。

class

MissingFormatArgumentException
如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。

class

MissingFormatWidthException
请求格式宽度时抛出未经检查的异常。

class

MissingResourceException
缺少资源时抛出此异常。

class

NoSuchElementException
由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。

class

Observable
此类表示模型视图范例中的 observable 对象，或者说“数据”。

class

PriorityQueue<E>
一个基于优先级堆的无界优先级队列。

class

Properties
Properties 类表示了一个持久的属性集。

class

PropertyPermission
此类用于属性权限。

class

PropertyResourceBundle
PropertyResourceBundle 是 ResourceBundle 的一个具体子类，它使用属性文件中的静态字符串集来管理语言环境资源。

class

Random
此类的实例用于生成伪随机数流。

class

ResourceBundle
资源包包含特定于语言环境的对象。

static class

ResourceBundle.Control
ResourceBundle.Control 定义一个回调方法集，它在包加载进程中由 ResourceBundle.getBundle 工厂方法调用。

class

Scanner
一个可以使用正则表达式来解析基本类型和字符串的简单文本扫描器。

class

ServiceConfigurationError
在加载服务提供者的过程中出错时抛出的错误。

class

ServiceLoader<S>
一个简单的服务提供者加载设施。

class

SimpleTimeZone
SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。

class

Stack<E>
Stack 类表示后进先出（LIFO）的对象堆栈。

class

StringTokenizer
string tokenizer 类允许应用程序将字符串分解为标记。

class

Timer
一种工具，线程用其安排以后在后台线程中执行的任务。

class

TimerTask
由 Timer 安排为一次执行或重复执行的任务。

class

TimeZone
TimeZone 表示时区偏移量，也可以计算夏令时。

class

TooManyListenersException
TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。

class

TreeMap<K,V>
基于红黑树（Red-Black tree）的 NavigableMap 实现。

class

TreeSet<E>
基于 TreeMap 的 NavigableSet 实现。

class

UnknownFormatConversionException
给定未知的转换时所抛出的未经检查的异常。

class

UnknownFormatFlagsException
给定未知标志时所抛出的未经检查的异常。

class

UUID
表示通用唯一标识符 (UUID) 的类。

class

Vector<E>
Vector 类可以实现可增长的对象数组。

class

WeakHashMap<K,V>
以弱键 实现的基于哈希表的 Map。

声明为 Object 的 java.util 中的字段

protected  Object[]

Vector.elementData
存储向量组件的数组缓冲区。

protected  Object

EventObject.source
最初发生 Event 的对象。

类型参数类型为 Object 的 java.util 中的方法

static

<T extends Object & Comparable<? super T>>
T

Collections.max(Collection<? extends T> coll)
根据元素的自然顺序，返回给定 collection 的最大元素。

static

<T extends Object & Comparable<? super T>>
T

Collections.min(Collection<? extends T> coll)
根据元素的自然顺序 返回给定 collection 的最小元素。

返回 Object 的 java.util 中的方法

Object

SimpleTimeZone.clone()
返回此 SimpleTimeZone 实例的一个副本。

Object

GregorianCalendar.clone()

Object

Calendar.clone()
创建并返回此对象的一个副本。

Object

TreeSet.clone()
返回 TreeSet 实例的浅表副本。

Object

TimeZone.clone()
创建此 TimeZone 的一个副本。

Object

Date.clone()
返回此对象的副本。

Object

IdentityHashMap.clone()
返回此标识哈希映射的浅表副本：不复制键和值本身。

Object

LinkedList.clone()
返回此 LinkedList 的浅表副本。

Object

TreeMap.clone()
返回此 TreeMap 实例的浅表副本。

Object

HashSet.clone()
返回此 HashSet 实例的浅表副本：并没有复制这些元素本身。

Object

Locale.clone()
重写 Cloneable。

Object

BitSet.clone()
复制此 BitSet，生成一个与之相等的新 BitSet。

Object

ArrayList.clone()
返回此 ArrayList 实例的浅表副本。

Object

HashMap.clone()
返回此 HashMap 实例的浅表副本：并不复制键和值本身。

protected  Object

AbstractMap.clone()
返回此 AbstractMap 实例的浅表副本：不复制键和值本身。

Object

Vector.clone()
返回向量的一个副本。

Object

Hashtable.clone()
创建此哈希表的浅表副本。

static

<T> T[]

Arrays.copyOf(T[] original, int newLength)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。

static

<T,U> T[]

Arrays.copyOf(U[] original, int newLength, Class<? extends T[]> newType)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。

static

<T> T[]

Arrays.copyOfRange(T[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。

static

<T,U> T[]

Arrays.copyOfRange(U[] original, int from, int to, Class<? extends T[]> newType)
将指定数组的指定范围复制到一个新数组。

protected abstract  Object[][]

ListResourceBundle.getContents()
返回一个数组，其中 Object 数组中的每个项都是一个对象对。

Object

ResourceBundle.getObject(String key)
从此资源包或它的某个父包中获取给定键的对象。

Object

EventObject.getSource()
最初发生 Event 的对象。

Object

PropertyResourceBundle.handleGetObject(String key)

Object

ListResourceBundle.handleGetObject(String key)

protected abstract  Object

ResourceBundle.handleGetObject(String key)
从此资源包中获取给定键的对象。

Object

StringTokenizer.nextElement()
除了其声明返回值是 Object 而不是 String 之外，它返回与 nextToken 方法相同的值。

Object

Properties.setProperty(String key, String value)
调用 Hashtable 的方法 put。

Object[]

ArrayDeque.toArray()
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）。

Object[]

PriorityQueue.toArray()
返回一个包含此队列所有元素的数组。

Object[]

LinkedList.toArray()
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。

Object[]

ArrayList.toArray()
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组。

Object[]

Set.toArray()
返回一个包含 set 中所有元素的数组。

Object[]

Vector.toArray()
返回一个数组，包含此向量中以恰当顺序存放的所有元素。

Object[]

AbstractCollection.toArray()
返回包含此 collection 中所有元素的数组。

Object[]

List.toArray()
返回按适当顺序包含列表中的所有元素的数组（从第一个元素到最后一个元素）。

Object[]

Collection.toArray()
返回包含此 collection 中所有元素的数组。

<T> T[]

ArrayDeque.toArray(T[] a)
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

PriorityQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

LinkedList.toArray(T[] a)
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组；返回数组的运行时类型为指定数组的类型。

<T> T[]

ArrayList.toArray(T[] a)
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

Set.toArray(T[] a)
返回一个包含此 set 中所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

Vector.toArray(T[] a)
返回一个数组，包含此向量中以恰当顺序存放的所有元素；返回数组的运行时类型为指定数组的类型。

<T> T[]

AbstractCollection.toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。

<T> T[]

List.toArray(T[] a)
返回按适当顺序（从第一个元素到最后一个元素）包含列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

Collection.toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。

参数类型为 Object 的 java.util 中的方法

static

<T> boolean

Collections.addAll(Collection<? super T> c, T... elements)
将所有指定元素添加到指定 collection 中。

boolean

Calendar.after(Object when)
判断此 Calendar 表示的时间是否在指定 Object 表示的时间之后，返回判断结果。

static

<T> List<T>

Arrays.asList(T... a)
返回一个受指定数组支持的固定大小的列表。

boolean

Calendar.before(Object when)
判断此 Calendar 表示的时间是否在指定 Object 表示的时间之前，返回判断结果。

static int

Arrays.binarySearch(Object[] a, int fromIndex, int toIndex, Object key)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。

static int

Arrays.binarySearch(Object[] a, int fromIndex, int toIndex, Object key)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。

static int

Arrays.binarySearch(Object[] a, Object key)
使用二分搜索法来搜索指定数组，以获得指定对象。

static int

Arrays.binarySearch(Object[] a, Object key)
使用二分搜索法来搜索指定数组，以获得指定对象。

static

<T> int

Arrays.binarySearch(T[] a, int fromIndex, int toIndex, T key, Comparator<? super T> c)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。

static

<T> int

Arrays.binarySearch(T[] a, T key, Comparator<? super T> c)
使用二分搜索法来搜索指定数组，以获得指定对象。

boolean

ArrayDeque.contains(Object o)
如果此双端队列包含指定元素，则返回 true。

boolean

PriorityQueue.contains(Object o)
如果此队列包含指定的元素，则返回 true。

boolean

TreeSet.contains(Object o)
如果此 set 包含指定的元素，则返回 true。

boolean

LinkedList.contains(Object o)
如果此列表包含指定元素，则返回 true。

boolean

Deque.contains(Object o)
如果此双端队列包含指定元素，则返回 true。

boolean

HashSet.contains(Object o)
如果此 set 包含指定元素，则返回 true。

boolean

ArrayList.contains(Object o)
如果此列表中包含指定的元素，则返回 true。

boolean

Set.contains(Object o)
如果 set 包含指定的元素，则返回 true。

boolean

Vector.contains(Object o)
如果此向量包含指定的元素，则返回 true。

boolean

AbstractCollection.contains(Object o)
如果此 collection 包含指定的元素，则返回 true。

boolean

List.contains(Object o)
如果列表包含指定的元素，则返回 true。

boolean

Collection.contains(Object o)
如果此 collection 包含指定的元素，则返回 true。

boolean

Hashtable.contains(Object value)
测试此映射表中是否存在与指定值关联的键。

boolean

EnumMap.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

IdentityHashMap.containsKey(Object key)
测试指定的对象引用是否为此标识哈希映射中的键。

boolean

TreeMap.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

WeakHashMap.containsKey(Object key)
如果此映射对于指定的键包含映射关系，则返回 true。

boolean

HashMap.containsKey(Object key)
如果此映射包含对于指定键的映射关系，则返回 true。

boolean

AbstractMap.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

Hashtable.containsKey(Object key)
测试指定对象是否为此哈希表中的键。

boolean

Map.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

EnumMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

IdentityHashMap.containsValue(Object value)
测试指定的对象引用是否为此标识哈希映射中的值。

boolean

TreeMap.containsValue(Object value)
如果此映射为指定值映射一个或多个键，则返回 true。

boolean

WeakHashMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

LinkedHashMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

HashMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

AbstractMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

Hashtable.containsValue(Object value)
如果此 Hashtable 将一个或多个键映射到此值，则返回 true。

boolean

Map.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

void

Vector.copyInto(Object[] anArray)
将此向量的组件复制到指定的数组中。

static

<T> T[]

Arrays.copyOf(T[] original, int newLength)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。

static

<T,U> T[]

Arrays.copyOf(U[] original, int newLength, Class<? extends T[]> newType)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。

static

<T> T[]

Arrays.copyOfRange(T[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。

static

<T,U> T[]

Arrays.copyOfRange(U[] original, int from, int to, Class<? extends T[]> newType)
将指定数组的指定范围复制到一个新数组。

static boolean

Arrays.deepEquals(Object[] a1, Object[] a2)
如果两个指定数组彼此是深层相等 的，则返回 true。

static boolean

Arrays.deepEquals(Object[] a1, Object[] a2)
如果两个指定数组彼此是深层相等 的，则返回 true。

static int

Arrays.deepHashCode(Object[] a)
基于指定数组的“深层内容”返回哈希码。

static String

Arrays.deepToString(Object[] a)
返回指定数组“深层内容”的字符串表示形式。

boolean

EnumMap.equals(Object o)
比较指定对象与此映射的相等性。

boolean

SimpleTimeZone.equals(Object obj)
比较两个 SimpleTimeZone 对象的相等性。

boolean

UUID.equals(Object obj)
将此对象与指定对象比较。

boolean

PropertyPermission.equals(Object obj)
检查两个 PropertyPermission 对象是否相等。

boolean

GregorianCalendar.equals(Object obj)
比较此 GregorianCalendar 与指定的 Object。

boolean

Calendar.equals(Object obj)
将此 Calendar 与指定 Object 比较。

boolean

Date.equals(Object obj)
比较两个日期的相等性。

boolean

IdentityHashMap.equals(Object o)
比较指定对象与此映射的相等性。

boolean

Locale.equals(Object obj)
如果该 Locale 等于另一个对象，则返回 true。

boolean

BitSet.equals(Object obj)
将此对象与指定的对象进行比较。

boolean

AbstractSet.equals(Object o)
比较指定对象与此 set 的相等性。

boolean

Set.equals(Object o)
比较指定对象与此 set 的相等性。

boolean

AbstractMap.equals(Object o)
比较指定对象与此映射的相等性。

boolean

AbstractMap.SimpleEntry.equals(Object o)
比较指定对象与此项的相等性。

boolean

AbstractMap.SimpleImmutableEntry.equals(Object o)
比较指定对象与此项的相等性。

boolean

Comparator.equals(Object obj)
指示某个其他对象是否“等于”此 Comparator。

boolean

Vector.equals(Object o)
比较指定对象与此向量的相等性。

boolean

AbstractList.equals(Object o)
将指定的对象与此列表进行相等性比较。

boolean

List.equals(Object o)
比较指定的对象与列表是否相等。

boolean

Collection.equals(Object o)
比较此 collection 与指定对象是否相等。

boolean

Hashtable.equals(Object o)
按照 Map 接口的定义，比较指定 Object 与此 Map 是否相等。

boolean

Map.equals(Object o)
比较指定的对象与此映射是否相等。

boolean

Map.Entry.equals(Object o)
比较指定对象与此项的相等性。

static boolean

Arrays.equals(Object[] a, Object[] a2)
如果两个指定的 Objects 数组彼此相等，则返回 true。

static boolean

Arrays.equals(Object[] a, Object[] a2)
如果两个指定的 Objects 数组彼此相等，则返回 true。

static void

Arrays.fill(Object[] a, int fromIndex, int toIndex, Object val)
将指定的 Object 引用分配给指定 Object 数组指定范围中的每个元素。

static void

Arrays.fill(Object[] a, int fromIndex, int toIndex, Object val)
将指定的 Object 引用分配给指定 Object 数组指定范围中的每个元素。

static void

Arrays.fill(Object[] a, Object val)
将指定的 Object 引用分配给指定 Object 数组的每个元素。

static void

Arrays.fill(Object[] a, Object val)
将指定的 Object 引用分配给指定 Object 数组的每个元素。

Formatter

Formatter.format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。

Formatter

Formatter.format(String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此对象的目标文件中。

static int

Collections.frequency(Collection<?> c, Object o)
返回指定 collection 中等于指定对象的元素数。

V

EnumMap.get(Object key)
返回指定键所映射的值，如果此映射不包含此键的映射关系，则返回 null。

V

IdentityHashMap.get(Object key)
返回指定键映射的值；如果映射不包含此键的任何映射关系，则返回 null。

V

TreeMap.get(Object key)
返回指定键所映射的值，如果对于该键而言，此映射不包含任何映射关系，则返回 null。

V

WeakHashMap.get(Object key)
返回指定键所映射的值，如果对于该键来说，此映射不包含任何映射关系，则返回 null。

V

LinkedHashMap.get(Object key)
返回此映射到指定键的值。

V

HashMap.get(Object key)
返回指定键所映射的值；如果对于该键来说，此映射不包含任何映射关系，则返回 null。

V

AbstractMap.get(Object key)
返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。

V

Hashtable.get(Object key)
返回指定键所映射到的值，如果此映射不包含此键的映射，则返回 null. 更确切地讲，如果此映射包含满足 (key.equals(k)) 的从键 k 到值 v 的映射，则此方法返回 v；否则，返回 null。

abstract  V

Dictionary.get(Object key)
返回此 dictionary 中该键所映射到的值。

V

Map.get(Object key)
返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。

static int

Arrays.hashCode(Object[] a)
基于指定数组的内容返回哈希码。

int

LinkedList.indexOf(Object o)
返回此列表中首次出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。

int

ArrayList.indexOf(Object o)
返回此列表中首次出现的指定元素的索引，或如果此列表不包含元素，则返回 -1。

int

Vector.indexOf(Object o)
返回此向量中第一次出现的指定元素的索引，如果此向量不包含该元素，则返回 -1。

int

AbstractList.indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。

int

List.indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。

int

Vector.indexOf(Object o, int index)
返回此向量中第一次出现的指定元素的索引，从 index 处正向搜索，如果未找到该元素，则返回 -1。

int

LinkedList.lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。

int

ArrayList.lastIndexOf(Object o)
返回此列表中最后一次出现的指定元素的索引，或如果此列表不包含索引，则返回 -1。

int

Vector.lastIndexOf(Object o)
返回此向量中最后一次出现的指定元素的索引；如果此向量不包含该元素，则返回 -1。

int

AbstractList.lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。

int

List.lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。

int

Vector.lastIndexOf(Object o, int index)
返回此向量中最后一次出现的指定元素的索引，从 index 处逆向搜索，如果未找到该元素，则返回 -1。

void

Observable.notifyObservers(Object arg)
如果 hasChanged 方法指示对象已改变，则通知其所有观察者，并调用 clearChanged 方法来指示此对象不再改变。

boolean

ArrayDeque.remove(Object o)
从此双端队列中移除指定元素的单个实例。

V

EnumMap.remove(Object key)
从此映射中移除该键的映射关系（如果存在）。

boolean

PriorityQueue.remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。

boolean

TreeSet.remove(Object o)
将指定的元素从 set 中移除（如果该元素存在于此 set 中）。

V

IdentityHashMap.remove(Object key)
移除映射中此键的映射关系（如果存在的话）。

boolean

LinkedList.remove(Object o)
从此列表中移除首次出现的指定元素（如果存在）。

boolean

Deque.remove(Object o)
从此双端队列中移除第一次出现的指定元素。

V

TreeMap.remove(Object key)
如果此 TreeMap 中存在该键的映射关系，则将其删除。

V

WeakHashMap.remove(Object key)
从此弱哈希映射中移除键的映射关系（如果存在）。

boolean

HashSet.remove(Object o)
如果指定元素存在于此 set 中，则将其移除。

boolean

ArrayList.remove(Object o)
移除此列表中首次出现的指定元素（如果存在）。

boolean

Set.remove(Object o)
如果 set 中存在指定的元素，则将其移除（可选操作）。

V

HashMap.remove(Object key)
从此映射中移除指定键的映射关系（如果存在）。

V

AbstractMap.remove(Object key)
如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。

boolean

Vector.remove(Object o)
移除此向量中指定元素的第一个匹配项，如果向量不包含该元素，则元素保持不变。

boolean

AbstractCollection.remove(Object o)
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。

boolean

List.remove(Object o)
从此列表中移除第一次出现的指定元素（如果存在）（可选操作）。

boolean

Collection.remove(Object o)
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。

V

Hashtable.remove(Object key)
从哈希表中移除该键及其相应的值。

abstract  V

Dictionary.remove(Object key)
从此 dictionary 中移除 key （及其相应的 value）。

V

Map.remove(Object key)
如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。

boolean

Vector.removeElement(Object obj)
从此向量中移除变量的第一个（索引最小的）匹配项。

boolean

ArrayDeque.removeFirstOccurrence(Object o)
移除此双端队列中第一次出现的指定元素（当从头部到尾部遍历双端队列时）。

boolean

LinkedList.removeFirstOccurrence(Object o)
从此列表中移除第一次出现的指定元素（从头部到尾部遍历列表时）。

boolean

Deque.removeFirstOccurrence(Object o)
从此双端队列移除第一次出现的指定元素。

boolean

ArrayDeque.removeLastOccurrence(Object o)
移除此双端队列中最后一次出现的指定元素（当从头部到尾部遍历双端队列时）。

boolean

LinkedList.removeLastOccurrence(Object o)
从此列表中移除最后一次出现的指定元素（从头部到尾部遍历列表时）。

boolean

Deque.removeLastOccurrence(Object o)
从此双端队列移除最后一次出现的指定元素。

int

Stack.search(Object o)
返回对象在堆栈中的位置，以 1 为基数。

static void

Arrays.sort(Object[] a)
根据元素的自然顺序对指定对象数组按升序进行排序。

static void

Arrays.sort(Object[] a, int fromIndex, int toIndex)
根据元素的自然顺序对指定对象数组的指定范围按升序进行排序。

static

<T> void

Arrays.sort(T[] a, Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组进行排序。

static

<T> void

Arrays.sort(T[] a, int fromIndex, int toIndex, Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组的指定范围进行排序。

<T> T[]

ArrayDeque.toArray(T[] a)
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

PriorityQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

LinkedList.toArray(T[] a)
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组；返回数组的运行时类型为指定数组的类型。

<T> T[]

ArrayList.toArray(T[] a)
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

Set.toArray(T[] a)
返回一个包含此 set 中所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

Vector.toArray(T[] a)
返回一个数组，包含此向量中以恰当顺序存放的所有元素；返回数组的运行时类型为指定数组的类型。

<T> T[]

AbstractCollection.toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。

<T> T[]

List.toArray(T[] a)
返回按适当顺序（从第一个元素到最后一个元素）包含列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

Collection.toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。

static String

Arrays.toString(Object[] a)
返回指定数组内容的字符串表示形式。

void

Observer.update(Observable o, Object arg)
只要改变了 observable 对象就调用此方法。

参数类型为 Object 的 java.util 中的构造方法

EventObject(Object source)
构造一个原型 Event。

java.util.concurrent 中 Object 的使用

java.util.concurrent 中 Object 的子类

class

AbstractExecutorService
提供 ExecutorService 执行方法的默认实现。

class

ArrayBlockingQueue<E>
一个由数组支持的有界阻塞队列。

class

BrokenBarrierException
当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。

class

CancellationException
如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。

class

ConcurrentHashMap<K,V>
支持获取的完全并发和更新的所期望可调整并发的哈希表。

class

ConcurrentLinkedQueue<E>
一个基于链接节点的无界线程安全队列。

class

ConcurrentSkipListMap<K,V>
可缩放的并发 ConcurrentNavigableMap 实现。

class

ConcurrentSkipListSet<E>
一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。

class

CopyOnWriteArrayList<E>
ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。

class

CopyOnWriteArraySet<E>
对其所有操作使用内部 CopyOnWriteArrayList 的 Set。

class

CountDownLatch
一个同步辅助类，在完成一组正在其他线程中执行的操作之前，它允许一个或多个线程一直等待。

class

CyclicBarrier
一个同步辅助类，它允许一组线程互相等待，直到到达某个公共屏障点 (common barrier point)。

class

DelayQueue<E extends Delayed>
Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。

class

Exchanger<V>
可以在对中对元素进行配对和交换的线程的同步点。

class

ExecutionException
当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。

class

ExecutorCompletionService<V>
使用提供的 Executor 来执行任务的 CompletionService。

class

Executors
此包中所定义的 Executor、ExecutorService、ScheduledExecutorService、ThreadFactory 和 Callable 类的工厂和实用方法。

class

FutureTask<V>
可取消的异步计算。

class

LinkedBlockingDeque<E>
一个基于已链接节点的、任选范围的阻塞双端队列。

class

LinkedBlockingQueue<E>
一个基于已链接节点的、范围任意的 blocking queue。

class

PriorityBlockingQueue<E>
一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。

class

RejectedExecutionException
当无法执行某个任务时,由 Executor 抛出的异常。

class

ScheduledThreadPoolExecutor
ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。

class

Semaphore
一个计数信号量。

class

SynchronousQueue<E>
一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

class

ThreadPoolExecutor
一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。

static class

ThreadPoolExecutor.AbortPolicy
用于被拒绝任务的处理程序，它将抛出 RejectedExecutionException.

static class

ThreadPoolExecutor.CallerRunsPolicy
用于被拒绝任务的处理程序，它直接在 execute 方法的调用线程中运行被拒绝的任务；如果执行程序已关闭，则会丢弃该任务。

static class

ThreadPoolExecutor.DiscardOldestPolicy
用于被拒绝任务的处理程序，它放弃最旧的未处理请求，然后重试 execute；如果执行程序已关闭，则会丢弃该任务。

static class

ThreadPoolExecutor.DiscardPolicy
用于被拒绝任务的处理程序，默认情况下它将丢弃被拒绝的任务。

class

TimeoutException
阻塞操作超时时，抛出该异常。

返回 Object 的 java.util.concurrent 中的方法

Object

CopyOnWriteArrayList.clone()
返回此列表的浅表副本。

Object[]

ArrayBlockingQueue.toArray()
返回一个按适当顺序包含此队列中所有元素的数组。

Object[]

ConcurrentLinkedQueue.toArray()
返回以恰当顺序包含此队列所有元素的数组。

Object[]

CopyOnWriteArrayList.toArray()
返回一个按恰当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。

Object[]

CopyOnWriteArraySet.toArray()
返回一个包含此 set 所有元素的数组。

Object[]

DelayQueue.toArray()
返回包含此队列所有元素的数组。

Object[]

LinkedBlockingDeque.toArray()
返回以恰当顺序（从第一个元素到最后一个元素）包含此双端队列所有元素的数组。

Object[]

LinkedBlockingQueue.toArray()
返回按适当顺序包含此队列中所有元素的数组。

Object[]

PriorityBlockingQueue.toArray()
返回包含此队列所有元素的数组。

Object[]

SynchronousQueue.toArray()
返回一个 0 长度的数组。

<T> T[]

ArrayBlockingQueue.toArray(T[] a)
返回一个按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

ConcurrentLinkedQueue.toArray(T[] a)
返回以恰当顺序包含此队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

CopyOnWriteArrayList.toArray(T[] a)
返回以恰当顺序（从第一个元素到最后一个元素）包含列表所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

CopyOnWriteArraySet.toArray(T[] a)
返回一个包含此 set 所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

DelayQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

LinkedBlockingDeque.toArray(T[] a)
返回以恰当顺序包含此双端队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

LinkedBlockingQueue.toArray(T[] a)
返回按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

PriorityBlockingQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

SynchronousQueue.toArray(T[] a)
将指定数组的第 0 个元素设置为 null（如果该数组有非 0 的长度）并返回它。

返回变量类型为 Object 的类型的 java.util.concurrent 中的方法

static Callable<Object>

Executors.callable(PrivilegedAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的操作并返回其结果。

static Callable<Object>

Executors.callable(PrivilegedExceptionAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的异常操作并返回其结果。

static Callable<Object>

Executors.callable(Runnable task)
返回 Callable 对象，调用它时可运行给定的任务并返回 null。

参数类型为 Object 的 java.util.concurrent 中的方法

boolean

ArrayBlockingQueue.contains(Object o)
如果此队列包含指定的元素，则返回 true。

boolean

BlockingDeque.contains(Object o)
如果此双端队列包含指定的元素，则返回 true。

boolean

BlockingQueue.contains(Object o)
如果此队列包含指定元素，则返回 true。

boolean

ConcurrentLinkedQueue.contains(Object o)
如果此队列包含指定元素，则返回 true。

boolean

ConcurrentSkipListSet.contains(Object o)
如果此 set 包含指定的元素，则返回 true。

boolean

CopyOnWriteArrayList.contains(Object o)
如果此列表包含指定的元素，则返回 true。

boolean

CopyOnWriteArraySet.contains(Object o)
如果此 set 包含指定元素，则返回 true。

boolean

LinkedBlockingDeque.contains(Object o)
如果此双端队列包含指定的元素，则返回 true。

boolean

PriorityBlockingQueue.contains(Object o)
如果队列包含指定的元素，则返回 true。

boolean

SynchronousQueue.contains(Object o)
始终返回 false。

boolean

ConcurrentHashMap.contains(Object value)
一种遗留方法，测试此表中是否有一些与指定值存在映射关系的键。

boolean

ConcurrentSkipListMap.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

ConcurrentHashMap.containsKey(Object key)
测试指定对象是否为此表中的键。

boolean

ConcurrentSkipListMap.containsValue(Object value)
如果此映射为指定值映射一个或多个键，则返回 true。

boolean

ConcurrentHashMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

ConcurrentSkipListMap.equals(Object o)
比较指定对象与此映射的相等性。

boolean

ConcurrentSkipListSet.equals(Object o)
比较指定对象与此 set 的相等性。

boolean

CopyOnWriteArrayList.equals(Object o)
比较指定对象与此列表的相等性。

boolean

CopyOnWriteArraySet.equals(Object o)
比较指定对象与此 set 的相等性。

V

ConcurrentSkipListMap.get(Object key)
返回指定键所映射到的值；如果此映射不包含该键的映射关系，则返回 null。

V

ConcurrentHashMap.get(Object key)
返回指定键所映射到的值，如果此映射不包含该键的映射关系，则返回 null。

int

CopyOnWriteArrayList.indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。

int

CopyOnWriteArrayList.lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。

boolean

ArrayBlockingQueue.remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。

boolean

BlockingDeque.remove(Object o)
从此双端队列移除第一次出现的指定元素。

boolean

BlockingQueue.remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。

boolean

ConcurrentLinkedQueue.remove(Object o)
从队列中移除指定元素的单个实例（如果存在）。

V

ConcurrentSkipListMap.remove(Object key)
从此映射中移除指定键的映射关系（如果存在）。

boolean

ConcurrentSkipListSet.remove(Object o)
如果此 set 中存在指定的元素，则将其移除。

boolean

CopyOnWriteArrayList.remove(Object o)
从此列表移除第一次出现的指定元素（如果存在）。

boolean

CopyOnWriteArraySet.remove(Object o)
如果指定元素存在于此 set 中，则将其移除。

boolean

DelayQueue.remove(Object o)
从此队列中移除指定元素的单个实例（如果存在），无论它是否到期。

boolean

LinkedBlockingDeque.remove(Object o)
从此双端队列移除第一次出现的指定元素。

boolean

LinkedBlockingQueue.remove(Object o)
从此队列移除指定元素的单个实例（如果存在）。

boolean

PriorityBlockingQueue.remove(Object o)
从队列中移除指定元素的单个实例（如果存在）。

boolean

SynchronousQueue.remove(Object o)
始终返回 false。

V

ConcurrentHashMap.remove(Object key)
从此映射中移除键（及其相应的值）。

boolean

ConcurrentSkipListMap.remove(Object key, Object value)
只有目前将键的条目映射到给定值时，才移除该键的条目。

boolean

ConcurrentHashMap.remove(Object key, Object value)
只有目前将键的条目映射到给定值时，才移除该键的条目。

boolean

ConcurrentMap.remove(Object key, Object value)
只有目前将键的条目映射到给定值时，才移除该键的条目。

boolean

BlockingDeque.removeFirstOccurrence(Object o)
从此双端队列移除第一次出现的指定元素。

boolean

LinkedBlockingDeque.removeFirstOccurrence(Object o)

boolean

BlockingDeque.removeLastOccurrence(Object o)
从此双端队列移除最后一次出现的指定元素。

boolean

LinkedBlockingDeque.removeLastOccurrence(Object o)

void

TimeUnit.timedWait(Object obj, long timeout)
使用此时间单元执行计时的 Object.wait。

<T> T[]

ArrayBlockingQueue.toArray(T[] a)
返回一个按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

ConcurrentLinkedQueue.toArray(T[] a)
返回以恰当顺序包含此队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

CopyOnWriteArrayList.toArray(T[] a)
返回以恰当顺序（从第一个元素到最后一个元素）包含列表所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

CopyOnWriteArraySet.toArray(T[] a)
返回一个包含此 set 所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

DelayQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

LinkedBlockingDeque.toArray(T[] a)
返回以恰当顺序包含此双端队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

LinkedBlockingQueue.toArray(T[] a)
返回按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

PriorityBlockingQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

SynchronousQueue.toArray(T[] a)
将指定数组的第 0 个元素设置为 null（如果该数组有非 0 的长度）并返回它。

参数类型为 Object 的 java.util.concurrent 中的构造方法

CopyOnWriteArrayList(E[] toCopyIn)
创建一个保存给定数组的副本的列表。

java.util.concurrent.atomic 中 Object 的使用

java.util.concurrent.atomic 中 Object 的子类

class

AtomicBoolean
可以用原子方式更新的 boolean 值。

class

AtomicInteger
可以用原子方式更新的 int 值。

class

AtomicIntegerArray
可以用原子方式更新其元素的 int 数组。

class

AtomicIntegerFieldUpdater<T>
基于反射的实用工具，可以对指定类的指定 volatile int 字段进行原子更新。

class

AtomicLong
可以用原子方式更新的 long 值。

class

AtomicLongArray
可以用原子方式更新其元素的 long 数组。

class

AtomicLongFieldUpdater<T>
基于反射的实用工具，可以对指定类的指定 volatile long 字段进行原子更新。

class

AtomicMarkableReference<V>
AtomicMarkableReference 维护带有标记位的对象引用，可以原子方式对其进行更新。

class

AtomicReference<V>
可以用原子方式更新的对象引用。

class

AtomicReferenceArray<E>
可以用原子方式更新其元素的对象引用数组。

class

AtomicReferenceFieldUpdater<T,V>
基于反射的实用工具，可以对指定类的指定 volatile 字段进行原子更新。

class

AtomicStampedReference<V>
AtomicStampedReference 维护带有整数“标志”的对象引用，可以用原子方式对其进行更新。

参数类型为 Object 的 java.util.concurrent.atomic 中的构造方法

AtomicReferenceArray(E[] array)
创建与给定数组具有相同长度的新 AtomicReferenceArray，并从给定数组复制其所有元素。

java.util.concurrent.locks 中 Object 的使用

java.util.concurrent.locks 中 Object 的子类

class

AbstractOwnableSynchronizer
可以由线程以独占方式拥有的同步器。

class

AbstractQueuedLongSynchronizer
以 long 形式维护同步状态的一个 AbstractQueuedSynchronizer 版本。

class

AbstractQueuedLongSynchronizer.ConditionObject
作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。

class

AbstractQueuedSynchronizer
为实现依赖于先进先出 (FIFO) 等待队列的阻塞锁和相关同步器（信号量、事件，等等）提供一个框架。

class

AbstractQueuedSynchronizer.ConditionObject
AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。

class

LockSupport
用来创建锁和其他同步类的基本线程阻塞原语。

class

ReentrantLock
一个可重入的互斥锁 Lock，它具有与使用 synchronized 方法和语句所访问的隐式监视器锁相同的一些基本行为和语义，但功能更强大。

class

ReentrantReadWriteLock
支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。

static class

ReentrantReadWriteLock.ReadLock
ReentrantReadWriteLock.readLock() 方法返回的锁。

static class

ReentrantReadWriteLock.WriteLock
ReentrantReadWriteLock.writeLock() 方法返回的锁。

返回 Object 的 java.util.concurrent.locks 中的方法

static Object

LockSupport.getBlocker(Thread t)
返回提供给最近一次尚未解除阻塞的 park 方法调用的 blocker 对象，如果该调用不受阻塞，则返回 null。

参数类型为 Object 的 java.util.concurrent.locks 中的方法

static void

LockSupport.park(Object blocker)
为了线程调度，在许可可用之前禁用当前线程。

static void

LockSupport.parkNanos(Object blocker, long nanos)
为了线程调度，在许可可用前禁用当前线程，并最多等待指定的等待时间。

static void

LockSupport.parkUntil(Object blocker, long deadline)
为了线程调度，在指定的时限前禁用当前线程，除非许可可用。

java.util.jar 中 Object 的使用

java.util.jar 中 Object 的子类

class

Attributes
Attributes 类将 Manifest 属性名称映射到关联的字符串值。

static class

Attributes.Name
Attributes.Name 类表示存储在此 Map 中的一个属性名称。

class

JarEntry
此类用于表示 JAR 文件条目。

class

JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

class

JarFile
JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。

class

JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。

class

JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

class

Manifest
Manifest 类用于维护 Manifest 条目名称及其相关的 Attributes。

class

Pack200
以 Pack200 格式在 JAR 文件和打包的流之间进行转换。

类型参数类型为 Object 的 java.util.jar 中的字段

protected  Map<Object,Object>

Attributes.map
属性名称-值映射关系。

protected  Map<Object,Object>

Attributes.map
属性名称-值映射关系。

返回 Object 的 java.util.jar 中的方法

Object

Attributes.clone()
返回 Attributes 的副本，实现方法如下: public Object clone() { return new Attributes(this); } 由于属性名称和值本身不可变，因此可以安全地修改返回的 Attributes，而不会影响原始值。

Object

Manifest.clone()
返回 Manifest 的浅表副本。

Object

Attributes.get(Object name)
返回指定的属性名称的值，如果未找到属性名称，则返回 null。

Object

Attributes.put(Object name, Object value)
在此 Map 中将指定的值关联到指定的属性名称（键）。

Object

Attributes.remove(Object name)
从此 Map 中移除具有指定名称（键）的属性。

返回变量类型为 Object 的类型的 java.util.jar 中的方法

Set<Map.Entry<Object,Object>>

Attributes.entrySet()
返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。

Set<Map.Entry<Object,Object>>

Attributes.entrySet()
返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。

Set<Object>

Attributes.keySet()
返回此 Map 所包含的属性名称（键）的 Set 视图。

Collection<Object>

Attributes.values()
返回此 Map 所包含的属性值的 Collection 视图。

参数类型为 Object 的 java.util.jar 中的方法

boolean

Attributes.containsKey(Object name)
如果此 Map 包含指定的属性名称（键），则返回 true。

boolean

Attributes.containsValue(Object value)
如果此 Map 将一个或多个属性名称（键）映射到指定值，则返回 true。

boolean

Attributes.equals(Object o)
将指定的 Attributes 对象与此 Map 进行相等性比较。

boolean

Attributes.Name.equals(Object o)
将此属性名称与另一个属性名称进行相等性比较。

boolean

Manifest.equals(Object o)
如果指定的 Object 也是一个 Manifest，并且具有相同的主 Attributes 和条目，则返回 true。

Object

Attributes.get(Object name)
返回指定的属性名称的值，如果未找到属性名称，则返回 null。

Object

Attributes.put(Object name, Object value)
在此 Map 中将指定的值关联到指定的属性名称（键）。

Object

Attributes.remove(Object name)
从此 Map 中移除具有指定名称（键）的属性。

java.util.logging 中 Object 的使用

java.util.logging 中 Object 的子类

class

ConsoleHandler
此 Handler 向 System.err 发布日志记录。

class

ErrorManager
可将 ErrorManager 对象附加到 Handler，以便处理日志记录过程中 Handler 上所发生的错误。

class

FileHandler
简单的文件日志记录 Handler。

class

Handler
Handler 对象从 Logger 中获取日志信息，并将这些信息导出。

class

Level
Level 类定义了一组可用来控制日志输出的标准日志级别。

class

Logger
Logger 对象用来记录特定系统或应用程序组件的日志消息。

class

LoggingPermission
当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。

class

LogManager
存在一个单一的全局 LogManager 对象，它可用于维护 Logger 和日志服务的一组共享状态。

class

LogRecord
LogRecord 对象用于在日志框架和单个日志 Handler 之间传递日志请求。

class

MemoryHandler
Handler 在内存中的循环缓冲区中对请求进行缓冲处理。

class

SimpleFormatter
以可读格式输出 LogRecord 的简单摘要。

class

SocketHandler
简单的网络日志 Handler。

class

StreamHandler
基于流的日志 Handler。

class

XMLFormatter
将 LogRecord 格式化为标准 XML 格式。

返回 Object 的 java.util.logging 中的方法

Object[]

LogRecord.getParameters()
获取日志消息的参数。

参数类型为 Object 的 java.util.logging 中的方法

void

Logger.entering(String sourceClass, String sourceMethod, Object param1)
记录一个方法条目，带有一个参数。

void

Logger.entering(String sourceClass, String sourceMethod, Object[] params)
记录一个方法条目，带有一组参数。

boolean

Level.equals(Object ox)
比较两个对象值的相等性。

void

Logger.exiting(String sourceClass, String sourceMethod, Object result)
记录一个方法返回，带有结果对象。

void

Logger.log(Level level, String msg, Object param1)
记录带有一个对象参数的消息。

void

Logger.log(Level level, String msg, Object[] params)
记录带有一组对象参数的消息。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object param1)
记录一条消息，具有指定的源类和方法，带有单个日志消息的对象参数。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object[] params)
记录一条消息，具有指定的源类和方法，带有一组对象参数。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1)
记录一条消息，具有指定的源类、方法和资源包名，带有单个日志消息的对象参数。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params)
记录一条消息，具有指定的源类、方法和资源包名，带有一组对象参数。

void

LogRecord.setParameters(Object[] parameters)
设置日志消息的参数。

java.util.prefs 中 Object 的使用

java.util.prefs 中 Object 的子类

class

AbstractPreferences
此类提供了 Preferences 类的骨干实现，从而大大简化了实现此类的任务。

class

BackingStoreException
抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。

class

InvalidPreferencesFormatException
抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。

class

NodeChangeEvent
Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。

class

PreferenceChangeEvent
Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。

class

Preferences
首选项数据的层次结构 collection 中的节点。

声明为 Object 的 java.util.prefs 中的字段

protected  Object

AbstractPreferences.lock
使用其监视器锁定此节点的对象。

java.util.regex 中 Object 的使用

java.util.regex 中 Object 的子类

class

Matcher
通过解释 Pattern 对 character sequence 执行匹配操作的引擎。

class

Pattern
正则表达式的编译表示形式。

class

PatternSyntaxException
抛出未经检查的异常，表明正则表达式模式中的语法错误。

java.util.spi 中 Object 的使用

java.util.spi 中 Object 的子类

class

CurrencyNameProvider
为 Currency 类提供本地化货币符号的服务提供者的抽象类。

class

LocaleNameProvider
为 Locale 类提供本地化名称的服务提供者的一个抽象类。

class

LocaleServiceProvider
此类是所有与语言环境有关的服务提供者接口（SPI）的超类。

class

TimeZoneNameProvider
为 TimeZone 类提供本地化时区名称的服务提供者的抽象类。

java.util.zip 中 Object 的使用

java.util.zip 中 Object 的子类

class

Adler32
可用于计算数据流的 Adler-32 校验和的类。

class

CheckedInputStream
需要维护所读取数据校验和的输入流。

class

CheckedOutputStream
需要维护写入数据校验和的输出流。

class

CRC32
可用于计算数据流的 CRC-32 的类。

class

DataFormatException
当数据格式发生错误时，抛出此异常。

class

Deflater
此类使用流行的 ZLIB 压缩程序库为通用压缩提供支持。

class

DeflaterInputStream
为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。

class

DeflaterOutputStream
此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。

class

GZIPInputStream
此类为读取 GZIP 文件格式的压缩数据实现流过滤器。

class

GZIPOutputStream
此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。

class

Inflater
此类使用流行的 ZLIB 压缩程序库为通用解压缩提供支持。

class

InflaterInputStream
此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。

class

InflaterOutputStream
为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。

class

ZipEntry
此类用于表示 ZIP 文件条目。

class

ZipError
发生不可恢复的错误时抛出。

class

ZipException
如果某种 ZIP 异常发生，则抛出此错误。

class

ZipFile
此类用于从 ZIP 文件读取条目。

class

ZipInputStream
此类为读取 ZIP 文件格式的文件实现输入流过滤器。

class

ZipOutputStream
此类为以 ZIP 文件格式写入文件实现输出流过滤器。

返回 Object 的 java.util.zip 中的方法

Object

ZipEntry.clone()
返回此条目的副本。

javax.accessibility 中 Object 的使用

javax.accessibility 中 Object 的子类

class

AccessibleAttributeSequence
此类汇集共享相同连续属性集的文本的跨度，以及该属性集。

class

AccessibleBundle
用于维护强类型枚举的基类。

class

AccessibleContext
AccessibleContext 表示所有可访问对象返回的最少信息。

class

AccessibleHyperlink
Hypertext 文档中的某个链接或一组链接（例如客户端 imagemap）的封装。

class

AccessibleRelation
AccessibleRelation 类描述了实现 AccessibleRelation 的对象与一个或多个其他对象之间的关系。

class

AccessibleRelationSet
AccessibleRelationSet 类确定了组件的关系集。

class

AccessibleResourceBundle
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。

class

AccessibleRole
AccessibleRole 类确定组件的职责。

class

AccessibleState
AccessibleState 类描述了组件的特殊状态。

class

AccessibleStateSet
AccessibleStateSet 类确定组件的状态集。

class

AccessibleTextSequence
此类汇集文本区域的关键细节。

返回 Object 的 javax.accessibility 中的方法

abstract  Object

AccessibleHyperlink.getAccessibleActionAnchor(int i)
返回表示适合于该链接的链接锚点的对象。

abstract  Object

AccessibleHyperlink.getAccessibleActionObject(int i)
返回表示适合于该链接的链接动作的对象。

Object

AccessibleKeyBinding.getAccessibleKeyBinding(int i)
返回此对象的键绑定。

Object[][]

AccessibleResourceBundle.getContents()
已过时。 返回编程键和本地化显示字符串之间的映射关系。

Object[]

AccessibleRelation.getTarget()
返回此关系的目标对象

参数类型为 Object 的 javax.accessibility 中的方法

void

AccessibleContext.firePropertyChange(String propertyName, Object oldValue, Object newValue)
对报告 bound 属性更改的支持。

void

AccessibleRelation.setTarget(Object target)
设置此关系的目标对象

void

AccessibleRelation.setTarget(Object[] target)
设置此关系的目标对象

参数类型为 Object 的 javax.accessibility 中的构造方法

AccessibleRelation(String key, Object target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。

AccessibleRelation(String key, Object[] target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。

javax.activation 中 Object 的使用

javax.activation 中 Object 的子类

class

ActivationDataFlavor
ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。

class

CommandInfo
CommandMap 实现使用 CommandInfo 类描述命令请求的结果。

class

CommandMap
CommandMap 类为系统中可用的命令对象注册表提供接口。

class

DataHandler
DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。

class

FileDataSource
FileDataSource 类实现一个封装文件的简单 DataSource 对象。

class

FileTypeMap
FileTypeMap 是一个抽象类，它为文件提供数据分类接口。

class

MailcapCommandMap
MailcapCommandMap 扩展 CommandMap 抽象类。

class

MimeType
RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。

class

MimeTypeParameterList
RFC 2045 和 2046 中定义的 MimeType 参数列表。

class

MimetypesFileTypeMap
此类扩展 FileTypeMap 并通过其文件扩展名提供文件的数据分类。

class

UnsupportedDataTypeException
当请求操作不支持请求的数据类型时，抛出此异常。

class

URLDataSource
URLDataSource 类提供一个对象，此对象将 URL 对象包装在 DataSource 接口中。

返回 Object 的 javax.activation 中的方法

Object

DataHandler.getBean(CommandInfo cmdinfo)
一个便捷方法，它接受 CommandInfo 对象并且实例化相应的命令，通常是 JavaBean 组件。

Object

CommandInfo.getCommandObject(DataHandler dh, ClassLoader loader)
返回已实例化的 JavaBean 组件。

Object

DataHandler.getContent()
以其首选 Object 的形式返回数据。

Object

DataContentHandler.getContent(DataSource ds)
返回一个对象，该对象表示其首选形式的数据。

Object

DataHandler.getTransferData(DataFlavor flavor)
返回一个对象，该对象表示要传输的数据。

Object

DataContentHandler.getTransferData(DataFlavor df, DataSource ds)
返回一个对象，该对象表示将要传输的数据。

参数类型为 Object 的 javax.activation 中的方法

void

DataContentHandler.writeTo(Object obj, String mimeType, OutputStream os)
将对象转换为指定 MIME 类型的字节流，并将其写入输出流。

参数类型为 Object 的 javax.activation 中的构造方法

DataHandler(Object obj, String mimeType)
创建表示此 MIME 类型对象的 DataHandler 实例。

javax.activity 中 Object 的使用

javax.activity 中 Object 的子类

class

ActivityCompletedException
任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。

class

ActivityRequiredException
如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。

class

InvalidActivityException
任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

javax.annotation.processing 中 Object 的使用

javax.annotation.processing 中 Object 的子类

class

AbstractProcessor
旨在用作最具体注释 processor 的便捷超类的抽象注释 processor。

class

Completions
用来组合 Completion 对象的实用工具类。

class

FilerException
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

javax.crypto 中 Object 的使用

javax.crypto 中 Object 的子类

class

BadPaddingException
当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。

class

Cipher
此类为加密和解密提供密码功能。

class

CipherInputStream
CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。

class

CipherOutputStream
CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。

class

CipherSpi
此类为 Cipher 类定义了服务提供者接口 (SPI)。

class

EncryptedPrivateKeyInfo
此类实现 EncryptedPrivateKeyInfo 类型，如在 PKCS #8 中定义的那样。

class

ExemptionMechanism
此类提供了豁免 (exemption) 机制的功能，例如，密钥恢复、密钥唤醒 和密钥托管。

class

ExemptionMechanismException
此为一般 ExemptionMechanism 异常。

class

ExemptionMechanismSpi
此类为 ExemptionMechanism 类定义了服务提供者接口 (SPI)。

class

IllegalBlockSizeException
如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。

class

KeyAgreement
此类提供密钥协定（或密钥交换）协议的功能。

class

KeyAgreementSpi
此类为 KeyAgreement 类定义了服务提供者接口 (SPI)。

class

KeyGenerator
此类提供（对称）密钥生成器的功能。

class

KeyGeneratorSpi
此类为 KeyGenerator 类定义了服务提供者接口 (SPI)。

class

Mac
此类提供“消息验证码”（Message Authentication Code，MAC）算法的功能。

class

MacSpi
此类为 Mac 类定义服务提供者接口 (SPI)。

class

NoSuchPaddingException
当请求特定填充机制但该环境中未提供时，抛出此异常。

class

NullCipher
NullCipher 类是一个提供“标识密码”的类，其不转换纯文本。

class

SealedObject
此类使程序员能够用加密算法创建对象并保护其机密性。

class

SecretKeyFactory
此类表示秘密密钥的工厂。

class

SecretKeyFactorySpi
此类定义 SecretKeyFactory 类的服务提供者接口 (SPI)。

class

ShortBufferException
当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

返回 Object 的 javax.crypto 中的方法

Object

Mac.clone()
如果提供者实现可以复制，则返回一个副本。

Object

MacSpi.clone()
如果此实现可以复制，则返回一个副本。

Object

SealedObject.getObject(Cipher c)
获取原始（封装的）对象。

Object

SealedObject.getObject(Key key)
获取原始（封装的）对象。

Object

SealedObject.getObject(Key key, String provider)
获取原始（封装的）对象。

javax.crypto.spec 中 Object 的使用

javax.crypto.spec 中 Object 的子类

class

DESedeKeySpec
此类指定一个 DES-EDE ("triple-DES") 密钥。

class

DESKeySpec
此类指定一个 DES 密钥。

class

DHGenParameterSpec
此类指定用于生成在 Diffie-Hellman 密钥协议中使用的 Diffie-Hellman（系统）参数的参数集合。

class

DHParameterSpec
此类指定随同 Diffie-Hellman 算法使用的参数集合，该算法在 PKCS #3：Diffie-Hellman Key-Agreement Standard 中指定。

class

DHPrivateKeySpec
此类使用其关联的参数指定一个 Diffie-Hellman 私钥。

class

DHPublicKeySpec
此类使用关联的参数指定一个 Diffie-Hellman 公钥。

class

IvParameterSpec
此类指定一个初始化向量 (IV)。

class

OAEPParameterSpec
此类指定随同 OAEP 冗余使用的参数集合，OAEP 冗余在 PKCS #1 标准中定义。

class

PBEKeySpec
可随同基于密码的加密法 (PBE) 使用的供用户选择的密码。

class

PBEParameterSpec
此类指定随同以密码为基础的加密法 (PBE) 使用的参数集合，该加密法在 PKCS #5 标准中定义。

class

PSource
此类为在 OAEP 冗余中的编码输入 P 指定源，OAEP 冗余在 PKCS #1 标准中定义。

static class

PSource.PSpecified
此类用于显式地指定 OAEP 冗余中编码输入 P 的值。

class

RC2ParameterSpec
此类指定随同 RC2 算法使用的参数。

class

RC5ParameterSpec
此类指定随同 RC5 算法使用的参数。

class

SecretKeySpec
此类以与 provider 无关的方式指定一个密钥。

参数类型为 Object 的 javax.crypto.spec 中的方法

boolean

RC2ParameterSpec.equals(Object obj)
测试给定对象与此对象的相等性。

boolean

RC5ParameterSpec.equals(Object obj)
测试给定对象与此对象的相等性。

boolean

SecretKeySpec.equals(Object obj)
测试给定对象与此对象的相等性。

javax.imageio 中 Object 的使用

javax.imageio 中 Object 的子类

class

IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。

class

IIOImage
一个聚集图像、缩略（预览）图像集和表示与图像关联的元数据的对象的简单容器类。

class

IIOParam
所有描述应该如何对流进行编码和解码的类的超类。

class

ImageIO
该类包含一些用来查找 ImageReader 和 ImageWriter 以及执行简单编码和解码的静态便捷方法。

class

ImageReader
用来解析和解码图像的抽象超类。

class

ImageReadParam
描述如何对流进行解码的类。

class

ImageTypeSpecifier
允许以便捷方式指定图像格式（尤其是其 SampleModel 和 ColorModel）的类。

class

ImageWriteParam
描述如何对流进行编码的类。

class

ImageWriter
用来编码和写入图像的抽象超类。

声明为 Object 的 javax.imageio 中的字段

protected  Object

ImageReader.input
由 setInput 设置并由 getInput 获取的 ImageInputStream 或其他 Object。

protected  Object

ImageWriter.output
由 setOutput 设置并由 getOutput 获取的 ImageOutputStream 或其他 Object。

返回 Object 的 javax.imageio 中的方法

Object

ImageReader.getInput()
返回以前设置为输入源的 ImageInputStream 或其他 Object。

Object

ImageWriter.getOutput()
返回 ImageOutputStream 或最近一次调用 setOutput 方法设置的其他 Object如果没有设置目标，则返回 null。

参数类型为 Object 的 javax.imageio 中的方法

static ImageInputStream

ImageIO.createImageInputStream(Object input)
返回一个 ImageInputStream，它将从给定 Object 中获取输入。

static ImageOutputStream

ImageIO.createImageOutputStream(Object output)
返回一个 ImageOutputStream，它将其输出发送到给定 Object。

boolean

ImageTypeSpecifier.equals(Object o)
如果给定 Object 是一个 ImageTypeSpecifier 并且具有与此对象相同的 SampleModel 和 ColorModel，则返回 true。

static Iterator<ImageReader>

ImageIO.getImageReaders(Object input)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码所提供的 Object（通常是一个 ImageInputStream）。

void

ImageReader.setInput(Object input)
设置用于给定的 ImageInputStream 或其他 Object 的输入源。

void

ImageReader.setInput(Object input, boolean seekForwardOnly)
设置用于给定的 ImageInputStream 或其他 Object 的输入源。

void

ImageReader.setInput(Object input, boolean seekForwardOnly, boolean ignoreMetadata)
设置用于给定的 ImageInputStream 或其他 Object 的输入源。

void

ImageWriter.setOutput(Object output)
将目标设置为给定 ImageOutputStream 或其他 Object。

javax.imageio.metadata 中 Object 的使用

javax.imageio.metadata 中 Object 的子类

class

IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

class

IIOMetadata
将由表示与图像和流关联的元数据（非图像数据）的对象扩展的抽象类。

class

IIOMetadataFormatImpl
提供 IIOMetadataFormat 接口的可重用实现的具体类。

class

IIOMetadataNode
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

类型参数类型为 Object 的 javax.imageio.metadata 中的方法

protected

<T extends Object & Comparable<? super T>>
void

IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

返回 Object 的 javax.imageio.metadata 中的方法

Object

IIOMetadataNode.getFeature(String feature, String version)

Object

IIOMetadataFormat.getObjectDefaultValue(String elementName)
返回包含指定元素中 Object 引用的默认值的 Object。

Object

IIOMetadataFormatImpl.getObjectDefaultValue(String elementName)

Object[]

IIOMetadataFormat.getObjectEnumerations(String elementName)
返回一个 Object 数组，该数组包含指定元素中 Object 引用的合法枚举值。

Object[]

IIOMetadataFormatImpl.getObjectEnumerations(String elementName)

Object

IIOMetadataNode.getUserData(String key)

Object

IIOMetadataNode.getUserObject()
返回与此节点关联的 Object 值。

Object

IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)

参数类型为 Object 的 javax.imageio.metadata 中的方法

Object

IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)

void

IIOMetadataNode.setUserObject(Object userObject)
设置与此节点关联的值。

javax.imageio.plugins.bmp 中 Object 的使用

javax.imageio.plugins.bmp 中 Object 的子类

class

BMPImageWriteParam
用于以 BMP 格式编码图像的 ImageWriteParam 的子类。

javax.imageio.plugins.jpeg 中 Object 的使用

javax.imageio.plugins.jpeg 中 Object 的子类

class

JPEGHuffmanTable
封装单个 JPEG Huffman 表的类。

class

JPEGImageReadParam
此类添加了使用内置 JPEG reader 插件时设置 JPEG 量化表和 Huffman 表的能力。

class

JPEGImageWriteParam
此类添加了使用内置 JPEG writer 插件时设置 JPEG 量化表和 Huffman 表以及请求为图像计算最佳 Huffman 表的能力。

class

JPEGQTable
封装单个 JPEG 量化表的类。

javax.imageio.spi 中 Object 的使用

javax.imageio.spi 中 Object 的子类

class

IIORegistry
用于服务提供者实例的注册表。

class

IIOServiceProvider
一个常用于所有 Image I/O 服务提供者接口 (SPI) 的功能性超接口。

class

ImageInputStreamSpi
用于 ImageInputStream 的服务提供者接口 (SPI)。

class

ImageOutputStreamSpi
用于 ImageOutputStream 的服务提供者接口 (SPI)。

class

ImageReaderSpi
用于 ImageReader 的服务提供者接口 (SPI)。

class

ImageReaderWriterSpi
包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。

class

ImageTranscoderSpi
用于 ImageTranscoder 的服务提供者接口 (SPI)。

class

ImageWriterSpi
用于 ImageWriter 的服务提供者接口 (SPI)。

class

ServiceRegistry
用于服务提供者实例的注册表。

参数类型为 Object 的 javax.imageio.spi 中的方法

abstract  boolean

ImageReaderSpi.canDecodeInput(Object source)
如果给定的源对象看起来是此 reader 支持的格式，则返回 true。

boolean

ServiceRegistry.contains(Object provider)
如果当前注册了 provider，则返回 true。

ImageInputStream

ImageInputStreamSpi.createInputStreamInstance(Object input)
返回与此服务提供者关联的 ImageInputStream 实现的实例。

abstract  ImageInputStream

ImageInputStreamSpi.createInputStreamInstance(Object input, boolean useCache, File cacheDir)
返回与此服务提供者关联的 ImageInputStream 实现的实例。

ImageOutputStream

ImageOutputStreamSpi.createOutputStreamInstance(Object output)
返回与此服务提供者关联的 ImageOutputStream 实现的实例。

abstract  ImageOutputStream

ImageOutputStreamSpi.createOutputStreamInstance(Object output, boolean useCache, File cacheDir)
返回与此服务提供者关联的 ImageOutputStream 实现的实例。

abstract  ImageReader

ImageReaderSpi.createReaderInstance(Object extension)
返回与此服务提供者关联的 ImageReader 实现的实例。

abstract  ImageWriter

ImageWriterSpi.createWriterInstance(Object extension)
返回与此服务提供者关联的 ImageWriter 实现的实例。

void

ServiceRegistry.deregisterServiceProvider(Object provider)
从包含它的所有类别中移除服务提供者对象。

boolean

ServiceRegistry.Filter.filter(Object provider)
如果给定的 provider 对象与由此 Filter 定义的条件匹配，则返回 true。

void

ServiceRegistry.registerServiceProvider(Object provider)
将一个服务提供者对象添加到注册表。

javax.imageio.stream 中 Object 的使用

javax.imageio.stream 中 Object 的子类

class

FileCacheImageInputStream
从常规 InputStream 获取其输入的 ImageInputStream 的实现。

class

FileCacheImageOutputStream
将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

class

FileImageInputStream
从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。

class

FileImageOutputStream
将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。

class

IIOByteBuffer
表示对某个字节数组及该数组中偏移量和长度的可变引用的类。

class

ImageInputStreamImpl
实现 ImageInputStream 接口的抽象类。

class

ImageOutputStreamImpl
实现 ImageOutputStream 接口的抽象类。

class

MemoryCacheImageInputStream
从常规 InputStream 获取输入的 ImageInputStream 的实现。

class

MemoryCacheImageOutputStream
将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

javax.lang.model.element 中 Object 的使用

javax.lang.model.element 中 Object 的子类

class

UnknownAnnotationValueException
指示遇到一个未知种类的注释值。

class

UnknownElementException
指示遇到一个未知种类的元素。

返回 Object 的 javax.lang.model.element 中的方法

Object

UnknownAnnotationValueException.getArgument()
返回附加参数。

Object

UnknownElementException.getArgument()
返回附加参数。

Object

VariableElement.getConstantValue()
如果此变量是一个被初始化为编译时常量的 static final 字段，则返回此变量的值。

Object

AnnotationValue.getValue()
返回值。

参数类型为 Object 的 javax.lang.model.element 中的方法

boolean

Name.equals(Object obj)
如果参数表示与 this 相同的名称，则返回 true，否则返回 false。

boolean

Element.equals(Object obj)
如果参数表示与此元素相同的元素，则返回 true；否则返回 false。

参数类型为 Object 的 javax.lang.model.element 中的构造方法

UnknownAnnotationValueException(AnnotationValue av, Object p)
创建一个新的 UnknownAnnotationValueException。

UnknownElementException(Element e, Object p)
创建一个新的 UnknownElementException。

javax.lang.model.type 中 Object 的使用

javax.lang.model.type 中 Object 的子类

class

MirroredTypeException
当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。

class

MirroredTypesException
当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。

class

UnknownTypeException
指示遇到未知种类的类型。

返回 Object 的 javax.lang.model.type 中的方法

Object

UnknownTypeException.getArgument()
返回附加参数。

参数类型为 Object 的 javax.lang.model.type 中的方法

boolean

TypeMirror.equals(Object obj)
遵守 Object.equals 的常规协定。

参数类型为 Object 的 javax.lang.model.type 中的构造方法

UnknownTypeException(TypeMirror t, Object p)
创建一个新的 UnknownTypeException。

javax.lang.model.util 中 Object 的使用

javax.lang.model.util 中 Object 的子类

class

AbstractAnnotationValueVisitor6<R,P>
注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

AbstractElementVisitor6<R,P>
程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

AbstractTypeVisitor6<R,P>
类型的骨干 visitor，具有适用于第 6 版语言级别的默认行为。

class

ElementFilter
用来从元素集合中只选择所需元素的过滤器。

class

ElementKindVisitor6<R,P>
基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

ElementScanner6<R,P>
程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

SimpleAnnotationValueVisitor6<R,P>
注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

SimpleElementVisitor6<R,P>
程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

SimpleTypeVisitor6<R,P>
类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

TypeKindVisitor6<R,P>
基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

声明为 Object 的 javax.lang.model.util 中的字段

protected  R

ElementScanner6.DEFAULT_VALUE
指定的默认值。

protected  R

SimpleAnnotationValueVisitor6.DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。

protected  R

SimpleElementVisitor6.DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。

protected  R

SimpleTypeVisitor6.DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。

参数类型为 Object 的 javax.lang.model.util 中的方法

protected  R

SimpleAnnotationValueVisitor6.defaultAction(Object o, P p)
visit 方法的默认动作。

String

Elements.getConstantExpression(Object value)
返回表示基本值或字符串的常量表达式 文本。

javax.management 中 Object 的使用

javax.management 中 Object 的子类

class

Attribute
通过将 MBean 属性名与其值相关联来表示 MBean 属性。

class

AttributeChangeNotification
提供 MBean 所发送的属性更改通知的定义。

class

AttributeChangeNotificationFilter
此类实现 attribute change notification 的 NotificationFilter 接口。

class

AttributeNotFoundException
指定的属性不存在或无法检索。

class

AttributeValueExp
表示用作关系约束参数的属性。

class

BadAttributeValueExpException
向构造的查询方法传递无效的 MBean 属性时，抛出此异常。

class

BadBinaryOpValueExpException
向构造查询的方法传递无效的表达式时，抛出此异常。

class

BadStringOperationException
向构造查询的方法传递无效的字符串操作时，抛出此异常。

class

DefaultLoaderRepository
已过时。 使用 MBeanServer.getClassLoaderRepository() 取代。

class

ImmutableDescriptor
不可变的描述符。

class

InstanceAlreadyExistsException
已经在存储库中注册了 MBean。

class

InstanceNotFoundException
存储库中不存在指定的 MBean。

class

InvalidApplicationException
试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。

class

InvalidAttributeValueException
指定的值对该属性无效。

class

JMException
由 JMX 实现所抛出的异常。

class

JMRuntimeException
由 JMX 实现所发出的运行时异常。

class

JMX
JMX API 提供的静态方法。

class

ListenerNotFoundException
存储库中不存在指定的 MBean 侦听器。

class

MalformedObjectNameException
字符串的格式不对应于有效的 ObjectName。

class

MBeanAttributeInfo
描述出于管理目的而公开的 MBean 属性。

class

MBeanConstructorInfo
描述 MBean 所公开的构造方法。

class

MBeanException
表示由代理的 MBean 方法所抛出的“用户定义的”异常。

class

MBeanFeatureInfo
提供 MBean 描述符对象的常规信息。

class

MBeanInfo
描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。

class

MBeanNotificationInfo
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。

class

MBeanOperationInfo
描述由 MBean 公开的管理操作。

class

MBeanParameterInfo
描述由 MBean 公开的操作的参数。

class

MBeanPermission
权限控制对 MBeanServer 操作的访问。

class

MBeanRegistrationException
包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。

class

MBeanServerBuilder
此类表示创建默认 MBeanServer 实现的生成器。

class

MBeanServerDelegate
从管理的角度表示 MBean 服务器。

class

MBeanServerFactory
提供 MBean 服务器引用。

class

MBeanServerInvocationHandler
通过 MBean 服务器将 MBean 的管理接口中的方法转发到 MBean 的 InvocationHandler。

class

MBeanServerNotification
表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。

class

MBeanServerPermission
执行与 MBeanServer 关联的操作的 Permission。

class

MBeanTrustPermission
此权限表示“信任”签名者或代码基。

class

NotCompliantMBeanException
尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。

class

Notification
Notification 类表示 MBean 所发出的通知。

class

NotificationBroadcasterSupport
提供 NotificationEmitter 接口的实现。

class

NotificationFilterSupport
提供 NotificationFilter 接口的实现。

class

ObjectInstance
用于表示 MBean 对象名及其类名。

class

ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

class

OperationsException
表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。

class

Query
构造查询对象约束。

class

QueryEval
允许在特定的 MBean 服务器上下文中执行查询。

class

ReflectionException
表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。

class

RuntimeErrorException
当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。

class

RuntimeMBeanException
表示由代理中的 MBean 方法抛出的运行时异常。

class

RuntimeOperationsException
表示在 MBean 上执行操作时代理中抛出的运行时异常。

class

ServiceNotFoundException
表示请求的服务不受支持时引发的异常。

class

StandardEmitterMBean
一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。

class

StandardMBean
一个管理接口由 Java 接口上的反射确定的 MBean。

class

StringValueExp
表示作为关系约束变量的字符串。

声明为 Object 的 javax.management 中的字段

protected  Object

Notification.source
此域隐藏了父类中的 EventObject.source 域，使其成为非 transient 的，并因此成为序列化形式的一部分。

返回 Object 的 javax.management 中的方法

Object

Descriptor.clone()
返回一个与此描述符相等的描述符。

Object

MBeanAttributeInfo.clone()
返回此实例的浅表副本。

Object

MBeanConstructorInfo.clone()
返回此实例的浅表副本。

Object

MBeanInfo.clone()
返回此实例的浅表副本。

Object

MBeanNotificationInfo.clone()
返回此实例的浅表副本。

Object

MBeanOperationInfo.clone()
返回此实例的浅表副本。

Object

MBeanParameterInfo.clone()
返回此实例的浅表副本。

protected  Object

AttributeValueExp.getAttribute(ObjectName name)
返回指定的 MBean 中给定属性的值。

Object

MBeanServer.getAttribute(ObjectName name, String attribute)

Object

MBeanServerConnection.getAttribute(ObjectName name, String attribute)
获得指定 MBean 的特定属性值。

Object

DynamicMBean.getAttribute(String attribute)
获得 Dynamic MBean 的特定属性的值。

Object

StandardMBean.getAttribute(String attribute)

Object

Descriptor.getFieldValue(String fieldName)
返回指定字段名的值，如果该名称不存在任何值，则返回 null。

Object

ImmutableDescriptor.getFieldValue(String fieldName)

Object[]

Descriptor.getFieldValues(String... fieldNames)
以 Object 数组的形式返回该 descriptor 中的所有字段值。

Object[]

ImmutableDescriptor.getFieldValues(String... fieldNames)

Object

StandardMBean.getImplementation()
获取此 Standard MBean（或 MXBean）的实现。

Object

AttributeChangeNotification.getNewValue()
获得已更改属性的新值。

Object

AttributeChangeNotification.getOldValue()
获得已更改属性的旧值。

Object

Notification.getUserData()
获得用户数据。

Object

Attribute.getValue()
返回此 Attribute 值的 Object。

Object

MBeanServer.instantiate(String className)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。

Object

MBeanServer.instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName)
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。

Object

MBeanServerInvocationHandler.invoke(Object proxy, Method method, Object[] args)

Object

MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。

Object

DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
允许在 Dynamic MBean 上调用某个操作。

Object

StandardMBean.invoke(String actionName, Object[] params, String[] signature)

Object

AttributeList.set(int index, Object element)

参数类型为 Object 的 javax.management 中的方法

void

AttributeList.add(int index, Object element)

boolean

AttributeList.add(Object o)

void

MBeanServerDelegate.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

NotificationBroadcaster.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
在此 MBean 中添加一个侦听器。

void

NotificationBroadcasterSupport.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
添加一个侦听器。

void

StandardEmitterMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)

void

MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
向已注册的 MBean 添加一个侦听器。

void

MBeanServer.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)

void

MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
向已注册的 MBean 添加一个侦听器。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

boolean

Attribute.equals(Object object)
比较当前的 Attribute Object 与另一个 Attribute Object。

boolean

Descriptor.equals(Object obj)
将此描述符与给定对象比较。

boolean

ImmutableDescriptor.equals(Object o)
将此描述符与给定对象进行比较。

boolean

MBeanAttributeInfo.equals(Object o)
比较此 MBeanAttributeInfo 与另一个 MBeanAttributeInfo。

boolean

MBeanConstructorInfo.equals(Object o)
比较此 MBeanConstructorInfo 与另一个 MBeanConstructorInfo。

boolean

MBeanFeatureInfo.equals(Object o)
比较此 MBeanFeatureInfo 与另一个 MBeanFeatureInfo。

boolean

MBeanInfo.equals(Object o)
比较此 MBeanInfo 与另一个 MBeanInfo。

boolean

MBeanNotificationInfo.equals(Object o)
把此 MBeanNotificationInfo 与另一个 MBeanNotificationInfo 进行比较。

boolean

MBeanOperationInfo.equals(Object o)
比较此 MBeanOperationInfo 与另一个 MBeanOperationInfo。

boolean

MBeanParameterInfo.equals(Object o)
比较此 MBeanParameterInfo 与另一个 MBeanParameterInfo。

boolean

MBeanPermission.equals(Object obj)
检查两个 MBeanPermission 对象的相等性。

boolean

MBeanServerPermission.equals(Object obj)
检查两个 MBeanServerPermission 对象的相等性。

boolean

ObjectInstance.equals(Object object)
比较当前的 ObjectInstance 与另一个 ObjectInstance 是否相等。

boolean

ObjectName.equals(Object object)
比较当前的对象名与另一个对象名是否相等。

protected  MBeanConstructorInfo[]

StandardMBean.getConstructors(MBeanConstructorInfo[] ctors, Object impl)
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 MBeanConstructorInfo[]。

protected  void

NotificationBroadcasterSupport.handleNotification(NotificationListener listener, Notification notif, Object handback)
为了向侦听器发送通知，由该侦听器的 sendNotification 调用此方法。

void

NotificationListener.handleNotification(Notification notification, Object handback)
出现 JMX 通知时调用。

Object

MBeanServer.instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。

Object

MBeanServerInvocationHandler.invoke(Object proxy, Method method, Object[] args)

Object

MBeanServerInvocationHandler.invoke(Object proxy, Method method, Object[] args)

Object

MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。

Object

DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
允许在 Dynamic MBean 上调用某个操作。

Object

StandardMBean.invoke(String actionName, Object[] params, String[] signature)

ObjectInstance

MBeanServer.registerMBean(Object object, ObjectName name)
将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。

void

MBeanServerDelegate.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

NotificationEmitter.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
从此 MBean 移除一个侦听器。

void

StandardEmitterMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)

void

MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
从已注册的 MBean 中移除一个侦听器。

void

MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)

void

MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
从已注册的 MBean 中移除一个侦听器。

Object

AttributeList.set(int index, Object element)

void

Descriptor.setField(String fieldName, Object fieldValue)
设置特定字段名的值。

void

ImmutableDescriptor.setField(String fieldName, Object fieldValue)
因为此类不可变，所以不支持此操作。

void

Descriptor.setFields(String[] fieldNames, Object[] fieldValues)
将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。

void

ImmutableDescriptor.setFields(String[] fieldNames, Object[] fieldValues)
因为此类不可变，所以不支持此操作。

void

StandardMBean.setImplementation(Object implementation)
替换包装在此对象中的实现对象。

void

Notification.setSource(Object source)
设置源。

void

Notification.setUserData(Object userData)
设置用户数据。

参数类型为 Object 的 javax.management 中的构造方法

Attribute(String name, Object value)
构造将给定的属性名与给定值相关联的 Attribute 对象。

AttributeChangeNotification(Object source, long sequenceNumber, long timeStamp, String msg, String attributeName, String attributeType, Object oldValue, Object newValue)
构造一个 AttributeChangeNotification 对象。

BadAttributeValueExpException(Object val)
构造带指定 Object 的 BadAttributeValueExpException。

ImmutableDescriptor(String[] fieldNames, Object[] fieldValues)
构造包含给定字段和值的描述符。

InvalidApplicationException(Object val)
构造具有指定 Object 的 InvalidApplicationException。

MBeanServerNotification(String type, Object source, long sequenceNumber, ObjectName objectName)
创建一个指定了导致该通知的 MBean 对象名和指定通知类型的 MBeanServerNotification 对象。

Notification(String type, Object source, long sequenceNumber)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, long timeStamp)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, long timeStamp, String message)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, String message)
创建一个 Notification 对象。

javax.management.loading 中 Object 的使用

javax.management.loading 中 Object 的子类

class

MLet
允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。

class

MLetContent
此类表示 MLET 标记的内容。

class

PrivateMLet
不添加到 ClassLoaderRepository 的 MLet。

返回变量类型为 Object 的类型的 javax.management.loading 中的方法

Set<Object>

MLet.getMBeansFromURL(String url)
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

Set<Object>

MLetMBean.getMBeansFromURL(String url)
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

Set<Object>

MLet.getMBeansFromURL(URL url)
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

Set<Object>

MLetMBean.getMBeansFromURL(URL url)
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

javax.management.modelmbean 中 Object 的使用

javax.management.modelmbean 中 Object 的子类

class

DescriptorSupport
此类表示 ModelMBean 元素的元数据集。

class

InvalidTargetObjectTypeException
当指定了无效的目标对象类型时，抛出此异常。

class

ModelMBeanAttributeInfo
ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。

class

ModelMBeanConstructorInfo
ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。

class

ModelMBeanInfoSupport
此类表示 ModelMBean 的元数据。

class

ModelMBeanNotificationInfo
ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。

class

ModelMBeanOperationInfo
ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

class

RequiredModelMBean
此类是 ModelMBean 的实现。

class

XMLParseException
当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。

返回 Object 的 javax.management.modelmbean 中的方法

Object

DescriptorSupport.clone()
返回作为 Descriptor 副本的新 Descriptor。

Object

ModelMBeanAttributeInfo.clone()
创建并返回新的 ModelMBeanAttributeInfo，它是此 ModelMBeanAttributeInfo 的副本。

Object

ModelMBeanConstructorInfo.clone()
创建并返回新 ModelMBeanConstructorInfo，它是此 ModelMBeanConstructorInfo 的副本。

Object

ModelMBeanInfo.clone()
创建并返回此对象的一个副本。

Object

ModelMBeanInfoSupport.clone()
返回此实例的浅表复制。

Object

ModelMBeanNotificationInfo.clone()
创建并返回新 ModelMBeanNotificationInfo，它是此 ModelMBeanNotificationInfo 的副本。

Object

ModelMBeanOperationInfo.clone()
创建并返回新的 ModelMBeanOperationInfo，它是此 ModelMBeanOperationInfo 的副本。

Object

RequiredModelMBean.getAttribute(String attrName)
返回为此 ModelMBean 定义的指定属性的值。

Object

DescriptorSupport.getFieldValue(String fieldName)

Object[]

DescriptorSupport.getFieldValues(String... fieldNames)

Object

RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig)
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。

参数类型为 Object 的 javax.management.modelmbean 中的方法

void

ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback)
注册一个将 NotificationListener 接口实现为侦听器的对象。

void

RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)

void

RequiredModelMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
注册一个将 NotificationListener 接口实现为侦听器的对象。

boolean

DescriptorSupport.equals(Object o)
将此描述符与给定对象比较。

Object

RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig)
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。

void

RequiredModelMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

DescriptorSupport.setField(String fieldName, Object fieldValue)

void

DescriptorSupport.setFields(String[] fieldNames, Object[] fieldValues)

void

ModelMBean.setManagedResource(Object mr, String mr_type)
设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。

void

RequiredModelMBean.setManagedResource(Object mr, String mr_type)
设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。

参数类型为 Object 的 javax.management.modelmbean 中的构造方法

DescriptorSupport(String[] fieldNames, Object[] fieldValues)
带有字段名称和字段值的构造方法。

javax.management.monitor 中 Object 的使用

javax.management.monitor 中 Object 的子类

class

CounterMonitor
定义专门用来观察计数器属性值的监视器 MBean。

class

GaugeMonitor
定义专门用来观察尺度属性值的监视器 MBean。

class

Monitor
定义所有监视器 MBean 的公共部分。

class

MonitorNotification
提供对监视器 MBean 发送的通知的定义。

class

MonitorSettingException
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

class

StringMonitor
定义设计用于观察字符串属性值的监视器 MBean。

返回 Object 的 javax.management.monitor 中的方法

Object

MonitorNotification.getDerivedGauge()
获取此监视器通知的派生尺度。

Object

MonitorNotification.getTrigger()
获取触发此监视器通知的阈值/字符串（取决于监视器类型）。

javax.management.openmbean 中 Object 的使用

javax.management.openmbean 中 Object 的子类

class

ArrayType<T>
ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。

class

CompositeDataInvocationHandler
将获取方法转发给 CompositeData 的 InvocationHandler。

class

CompositeDataSupport
CompositeDataSupport 类是实现 CompositeData 接口的开放数据 类。

class

CompositeType
CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。

class

InvalidOpenTypeException
当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。

class

KeyAlreadyExistsException
当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。

class

OpenDataException
因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。

class

OpenMBeanAttributeInfoSupport
描述 open MBean 的一个属性。

class

OpenMBeanConstructorInfoSupport
描述 Open MBean 的构造方法。

class

OpenMBeanInfoSupport
OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。

class

OpenMBeanOperationInfoSupport
描述 Open MBean 的一个操作。

class

OpenMBeanParameterInfoSupport
描述用于 open MBean 的一个或多个操作或构造方法的参数。

class

OpenType<T>
OpenType 类是所有类的父抽象类，它描述开放数据值的实际开放类型。

class

SimpleType<T>
SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。

class

TabularDataSupport
TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。

class

TabularType
TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。

返回 Object 的 javax.management.openmbean 中的方法

Object[]

TabularData.calculateIndex(CompositeData value)
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例中后引用该参数。

Object[]

TabularDataSupport.calculateIndex(CompositeData value)
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例后引用该参数。

Object

TabularDataSupport.clone()
返回此 TabularDataSupport 实例的一个副本：通过调用 super.clone()，然后副本此基础映射，即可得到该副本。

Object

TabularDataSupport.get(Object key)
此方法仅调用 get((Object[]) key)。

Object

CompositeData.get(String key)
返回名称为 key 的项的值。

Object

CompositeDataSupport.get(String key)
返回其名称是 key 的项的值。

Object[]

CompositeData.getAll(String[] keys)
返回通过 keys 指定其项名称的值组成的数组，值排列的顺序与 keys 相同。

Object[]

CompositeDataSupport.getAll(String[] keys)
返回由 keys 指定其项名称的值的数组，顺序与 keys 相同。

Object

OpenMBeanAttributeInfoSupport.getDefaultValue()
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的默认值（如果已指定），否则返回 null。

Object

OpenMBeanParameterInfo.getDefaultValue()
返回此参数的默认值（如果存在），否则返回 null。

Object

OpenMBeanParameterInfoSupport.getDefaultValue()
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的默认值（如果指定），否则返回 null。

Object

CompositeDataInvocationHandler.invoke(Object proxy, Method method, Object[] args)

Object

TabularDataSupport.put(Object key, Object value)
此方法仅调用 put((CompositeData) value)，因此忽略其可能为 null 的 key 参数。

Object

SimpleType.readResolve()
使用该值的唯一实例替换从 ObjectInputStream 读取的对象。

Object

TabularDataSupport.remove(Object key)
此方法仅调用 remove((Object[]) key)。

返回变量类型为 Object 的类型的 javax.management.openmbean 中的方法

Set<Map.Entry<Object,Object>>

TabularDataSupport.entrySet()
返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。

Set<Map.Entry<Object,Object>>

TabularDataSupport.entrySet()
返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。

Set<Object>

TabularDataSupport.keySet()
返回包含在此 TabularDataSupport 实例的基础映射中的键的 set 视图，并用于索引行。

Collection<Object>

TabularDataSupport.values()
返回包含在此 TabularDataSupport 实例中的行的 collection 视图。

参数类型为 Object 的 javax.management.openmbean 中的方法

boolean

TabularDataSupport.containsKey(Object key)
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。

boolean

TabularData.containsKey(Object[] key)
当且仅当此 TabularData 实例包含其索引为指定 key 的 CompositeData 值（即行）时，才返回 true。

boolean

TabularDataSupport.containsKey(Object[] key)
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。

boolean

CompositeData.containsValue(Object value)
当且仅当此 CompositeData 实例包含值为 value 的项时，返回 true。

boolean

CompositeDataSupport.containsValue(Object value)
当且仅当此 CompositeData 实例包含其值是 value 的项时，返回 true。

boolean

TabularDataSupport.containsValue(Object value)
当且仅当此 TabularData 实例包含指定的值时，才返回 true。

boolean

ArrayType.equals(Object obj)
比较指定的 obj 参数与此 ArrayType 实例的相等性。

boolean

CompositeData.equals(Object obj)
比较指定 obj 参数与此 CompositeData 实例的相等性。

boolean

CompositeDataSupport.equals(Object obj)
比较指定的 obj 参数与此 CompositeDataSupport 实例的相等性。

boolean

CompositeType.equals(Object obj)
比较指定的 obj 参数与此 CompositeType 实例的相等性。

boolean

OpenMBeanAttributeInfo.equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanAttributeInfo 实例的相等性。

boolean

OpenMBeanAttributeInfoSupport.equals(Object obj)
比较指定 obj 参数与此 OpenMBeanAttributeInfoSupport 实例的相等性。

boolean

OpenMBeanConstructorInfo.equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanConstructorInfo 实例的相等性。

boolean

OpenMBeanConstructorInfoSupport.equals(Object obj)
比较指定 obj 参数与此 OpenMBeanConstructorInfoSupport 实例的相等性。

boolean

OpenMBeanInfo.equals(Object obj)
比较指定 obj 参数与此 OpenMBeanInfo 实例的相等性。

boolean

OpenMBeanInfoSupport.equals(Object obj)
比较指定 obj 参数与此 OpenMBeanInfoSupport 实例的相等性。

boolean

OpenMBeanOperationInfo.equals(Object obj)
比较指定 obj 参数与此 OpenMBeanOperationInfo 实例的相等性。

boolean

OpenMBeanOperationInfoSupport.equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanOperationInfoSupport 实例的相等性。

boolean

OpenMBeanParameterInfo.equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanParameterInfo 实例的相等性。

boolean

OpenMBeanParameterInfoSupport.equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanParameterInfoSupport 实例的相等性。

abstract  boolean

OpenType.equals(Object obj)
比较指定的 obj 参数与此开放类型实例的相等性。

boolean

SimpleType.equals(Object obj)
比较指定 obj 参数与此 SimpleType 实例的相等性。

boolean

TabularData.equals(Object obj)
比较指定的 obj 参数与此 TabularData 实例的相等性。

boolean

TabularDataSupport.equals(Object obj)
比较指定的 obj 参数与此 TabularDataSupport 实例的相等性。

boolean

TabularType.equals(Object obj)
比较指定的 obj 参数与此 TabularType 实例的相等性。

Object

TabularDataSupport.get(Object key)
此方法仅调用 get((Object[]) key)。

CompositeData

TabularData.get(Object[] key)
返回此 TabularData 实例中其索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。

CompositeData

TabularDataSupport.get(Object[] key)
返回此 TabularData 实例中索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。

Object

CompositeDataInvocationHandler.invoke(Object proxy, Method method, Object[] args)

Object

CompositeDataInvocationHandler.invoke(Object proxy, Method method, Object[] args)

boolean

ArrayType.isValue(Object obj)
测试 obj 是否为此 ArrayType 实例的值。

boolean

CompositeType.isValue(Object obj)
测试 obj 是否为此 CompositeType 实例可以描述的值。

boolean

OpenMBeanAttributeInfoSupport.isValue(Object obj)
测试 obj 是否为此 OpenMBeanAttributeInfoSupport 实例描述的属性的有效值。

boolean

OpenMBeanParameterInfo.isValue(Object obj)
测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。

boolean

OpenMBeanParameterInfoSupport.isValue(Object obj)
测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。

abstract  boolean

OpenType.isValue(Object obj)
测试 obj 是否为此开放类型的值。

boolean

SimpleType.isValue(Object obj)
测试 obj 是否为此 SimpleType 实例的值。

boolean

TabularType.isValue(Object obj)
测试 obj 是否为此 TabularType 实例可以描述的值。

Object

TabularDataSupport.put(Object key, Object value)
此方法仅调用 put((CompositeData) value)，因此忽略其可能为 null 的 key 参数。

Object

TabularDataSupport.remove(Object key)
此方法仅调用 remove((Object[]) key)。

CompositeData

TabularData.remove(Object[] key)
从此 TabularData 实例中移除其索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。

CompositeData

TabularDataSupport.remove(Object[] key)
从此 TabularData 实例中移除索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。

参数类型为 Object 的 javax.management.openmbean 中的构造方法

CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。

javax.management.relation 中 Object 的使用

javax.management.relation 中 Object 的子类

class

InvalidRelationIdException
为关系提供的关系 id 已使用时引发此异常。

class

InvalidRelationServiceException
提供无效 Relation Service（关系服务）时引发此异常。

class

InvalidRelationTypeException
无效的关系类型。

class

InvalidRoleInfoException
在角色信息中，其最小程度大于其最大程度时，引发此异常。

class

InvalidRoleValueException
角色值无效。

class

MBeanServerNotificationFilter
MBeanServerNotification 的过滤器。

class

RelationException
此类是关系管理过程中引发的任何异常的超类。

class

RelationNotFoundException
Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。

class

RelationNotification
Relation Service（关系服务）中的更改通知。

class

RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

class

RelationServiceNotRegisteredException
在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。

class

RelationSupport
RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。

class

RelationTypeNotFoundException
Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。

class

RelationTypeSupport
RelationTypeSupport 对象实现 RelationType 接口。

class

Role
表示角色：包括角色名称和引用的 MBean（通过其 ObjectName）。

class

RoleInfo
RoleInfo 概括介绍关系类型中的角色。

class

RoleInfoNotFoundException
给定的关系类型中不存在带指定名称的角色信息时引发此异常。

class

RoleList
RoleList 表示角色（Role 对象）的列表。

class

RoleNotFoundException
关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

class

RoleResult
表示对一个关系的几个角色多个访问的结果（可以是读取，也可以是写入）。

class

RoleStatus
此类描述访问某个角色时可能遇到的各种问题。

class

RoleUnresolved
表示未解析的角色：由于存在问题而无法从关系中检索到的角色。

class

RoleUnresolvedList
RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

返回 Object 的 javax.management.relation 中的方法

Object

Role.clone()
复制角色对象。

Object

RoleUnresolved.clone()
复制此对象。

Object

RoleList.set(int index, Object element)

Object

RoleUnresolvedList.set(int index, Object element)

参数类型为 Object 的 javax.management.relation 中的方法

void

RoleList.add(int index, Object element)

void

RoleUnresolvedList.add(int index, Object element)

boolean

RoleList.add(Object o)

boolean

RoleUnresolvedList.add(Object o)

void

RelationService.handleNotification(Notification notif, Object handback)
出现 JMX 通知时调用。

Object

RoleList.set(int index, Object element)

Object

RoleUnresolvedList.set(int index, Object element)

参数类型为 Object 的 javax.management.relation 中的构造方法

RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。

RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。

javax.management.remote 中 Object 的使用

javax.management.remote 中 Object 的子类

class

JMXConnectionNotification
在客户端连接打开或关闭时，或者当通知丢失时发出的通知。

class

JMXConnectorFactory
用于创建 JMX API 连接器客户端的工厂。

class

JMXConnectorServer
每个连接器服务器的超类。

class

JMXConnectorServerFactory
用于创建 JMX API 连接器服务器的工厂。

class

JMXPrincipal
JMX Remote API 的远程客户端的身份。

class

JMXProviderException
当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。

class

JMXServerErrorException
在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。

class

JMXServiceURL
JMX API 连接器服务器的地址。

class

NotificationResult
缓存的通知的查询结果。

class

SubjectDelegationPermission
授权标识表示验证标识执行操作所需的权限。

class

TargetedNotification
一个 (Notification, Listener ID) 对。

参数类型为 Object 的 javax.management.remote 中的方法

void

JMXConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
添加一个接收连接状态改变的侦听器。

Subject

JMXAuthenticator.authenticate(Object credentials)
用给定的客户端凭据验证 MBeanServerConnection 客户端。

protected  void

JMXConnectorServer.connectionClosed(String connectionId, String message, Object userData)
正常关闭客户端连接时由子类调用。

protected  void

JMXConnectorServer.connectionFailed(String connectionId, String message, Object userData)
客户端连接失败时由子类调用。

protected  void

JMXConnectorServer.connectionOpened(String connectionId, String message, Object userData)
打开新的客户端连接时由子类调用。

boolean

JMXPrincipal.equals(Object o)
比较指定的 Object 与此 JMXPrincipal 是否相等。

boolean

JMXServiceURL.equals(Object obj)
指示是否有其他的对象等于此对象。

void

JMXConnector.removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback)
将一个用于接收状态更改通知的侦听器从列表中移除。

参数类型为 Object 的 javax.management.remote 中的构造方法

JMXConnectionNotification(String type, Object source, String connectionId, long sequenceNumber, String message, Object userData)
构造一个新的连接通知。

javax.management.remote.rmi 中 Object 的使用

javax.management.remote.rmi 中 Object 的子类

class

RMIConnectionImpl
RMIConnection 接口的实现。

class

RMIConnectionImpl_Stub

class

RMIConnector
一个到远程 RMI 连接器的连接。

class

RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

class

RMIIIOPServerImpl
一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。

class

RMIJRMPServerImpl
一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。

class

RMIServerImpl
表示连接器服务器的 RMI 对象。

class

RMIServerImpl_Stub

返回 Object 的 javax.management.remote.rmi 中的方法

Object

RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。

Object

RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)

Object

RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)

Object

RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。

Object

RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)

Object

RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

参数类型为 Object 的 javax.management.remote.rmi 中的方法

void

RMIConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

protected  void

RMIConnectorServer.connectionClosed(String connectionId, String message, Object userData)

protected  void

RMIConnectorServer.connectionFailed(String connectionId, String message, Object userData)

protected  void

RMIConnectorServer.connectionOpened(String connectionId, String message, Object userData)

RMIConnection

RMIServer.newClient(Object credentials)
建立一个使用该 RMI 连接器的新连接。

RMIConnection

RMIServerImpl.newClient(Object credentials)
创建一个新的客户端连接。

RMIConnection

RMIServerImpl_Stub.newClient(Object $param_Object_1)

void

RMIConnector.removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

javax.management.timer 中 Object 的使用

javax.management.timer 中 Object 的子类

class

TimerNotification
此类定义了由计时器 MBean 发送的通知。

返回 Object 的 javax.management.timer 中的方法

Object

Timer.getNotificationUserData(Integer id)
获得与指定标识符对应的计时器通知用户数据对象。

Object

TimerMBean.getNotificationUserData(Integer id)
获得与指定的标识符对应的计时器通知用户数据对象。

参数类型为 Object 的 javax.management.timer 中的方法

Integer

Timer.addNotification(String type, String message, Object userData, Date date)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

参数类型为 Object 的 javax.management.timer 中的构造方法

TimerNotification(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)
创建计时器通知对象。

javax.naming 中 Object 的使用

javax.naming 中 Object 的子类

class

AuthenticationNotSupportedException
当所请求验证的特定 flavor 不受支持时，抛出此异常。

class

BinaryRefAddr
此类表示通信终端地址的二进制形式。

class

CannotProceedException
抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。

class

CommunicationException
当客户端无法与目录或命名服务通信时，抛出此异常。

class

CompositeName
此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。

class

CompoundName
此类表示一个组合名称，即一个取自层次名称空间的名称。

class

ConfigurationException
当存在配置问题时，抛出此异常。

class

ContextNotEmptyException
当试图销毁一个不为空的上下文时，抛出此异常。

class

InitialContext
此类是执行命名操作的初始上下文。

class

InsufficientResourcesException
当无法使用资源完成所请求的操作时，抛出此异常。

class

InterruptedNamingException
当正被调用的命名操作已经被中断时，抛出此异常。

class

InvalidNameException
此异常指示被指定的名称不符合命名系统的命名语法。

class

LimitExceededException
当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。

class

LinkException
此异常用于描述解析链接时遇到的问题。

class

LinkLoopException
当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。

class

LinkRef
此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。

class

MalformedLinkException
如果在解析或构造链接时遇到错误链接，则抛出此异常。

class

NameAlreadyBoundException
一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。

class

NameClassPair
此类表示存在于上下文中的某一绑定的对象名称和类名称对。

class

NameNotFoundException
当名称的组件由于没有被绑定而无法解析时，抛出此异常。

class

NamingException
此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。

class

NamingSecurityException
此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。

class

NoInitialContextException
当不能创建任何初始上下文实现时，抛出此异常。

class

NoPermissionException
当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。

class

NotContextException
当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。

class

OperationNotSupportedException
当上下文实现不支持将调用的操作时，抛出此异常。

class

PartialResultException
抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。

class

RefAddr
此类表示通信端点的地址。

class

ReferralException
此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。

class

ServiceUnavailableException
当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。

class

SizeLimitExceededException
当某一方法生成的结果超出与大小有关的限制时，抛出此异常。

class

StringRefAddr
此类表示通信终端地址的字符串形式。

class

TimeLimitExceededException
当某一方法没有在指定的时间限制内终止时，抛出此异常。

声明为 Object 的 javax.naming 中的字段

protected  Object

LinkException.linkResolvedObj
包含一个对象，已成功解析的链接部分一直到达该对象。

protected  Object

NamingException.resolvedObj
包含一个对象，已成功解析的名称部分进行到该对象。

类型参数类型为 Object 的 javax.naming 中的字段

protected  Hashtable<Object,Object>

InitialContext.myProps
与此 InitialContext 关联的环境。

protected  Hashtable<Object,Object>

InitialContext.myProps
与此 InitialContext 关联的环境。

返回 Object 的 javax.naming 中的方法

Object

Context.addToEnvironment(String propName, Object propVal)
将一个新环境属性添加到此上下文的环境中。

Object

InitialContext.addToEnvironment(String propName, Object propVal)

Object

CompositeName.clone()
生成此复合名称的副本。

Object

CompoundName.clone()
创建此组合名称的副本。

Object

Name.clone()
生成此名称的新副本。

Object

Reference.clone()
使用地址的类名称列表、类工厂名称和类工厂位置创建此引用的副本。

Object

BinaryRefAddr.getContent()
以 Object 形式检索此地址的内容。

abstract  Object

RefAddr.getContent()
检索此地址的内容。

Object

StringRefAddr.getContent()
检索此地址的内容。

Object

LinkException.getLinkResolvedObj()
检索已成功解析成的对象。

Object

Binding.getObject()
检索绑定到此绑定名称的对象。

abstract  Object

ReferralException.getReferralInfo()
检索与此引用有关的信息（比如 URL）。

Object

NamingException.getResolvedObj()
检索已成功解析成的对象。

Object

Context.lookup(Name name)
检索指定的对象。

Object

InitialContext.lookup(Name name)

Object

Context.lookup(String name)
检索指定的对象。

Object

InitialContext.lookup(String name)

Object

Context.lookupLink(Name name)
按照除名称的最终原子组件以外的链接检索指定对象。

Object

InitialContext.lookupLink(Name name)

Object

Context.lookupLink(String name)
按照除名称的最终原子组件以外的链接检索指定对象。

Object

InitialContext.lookupLink(String name)

Object

CompositeName.remove(int posn)
从此复合名称中删除一个组件。

Object

CompoundName.remove(int posn)
从此组合名称中删除一个组件。

Object

Name.remove(int posn)
从此名称中移除一个组件。

Object

Reference.remove(int posn)
从地址列表中删除索引 posn 处的地址。

Object

Context.removeFromEnvironment(String propName)
从此上下文的环境中移除一个环境属性。

Object

InitialContext.removeFromEnvironment(String propName)

参数类型为 Object 的 javax.naming 中的方法

Object

Context.addToEnvironment(String propName, Object propVal)
将一个新环境属性添加到此上下文的环境中。

Object

InitialContext.addToEnvironment(String propName, Object propVal)

void

Context.bind(Name name, Object obj)
将名称绑定到对象。

void

InitialContext.bind(Name name, Object obj)

void

Context.bind(String name, Object obj)
将名称绑定到对象。

void

InitialContext.bind(String name, Object obj)

int

CompositeName.compareTo(Object obj)
比较此 CompositeName 与指定 Object 的顺序。

int

CompoundName.compareTo(Object obj)
比较此 CompoundName 与指定 Object 的顺序。

int

Name.compareTo(Object obj)
比较此名称与另一个名称的顺序。

boolean

BinaryRefAddr.equals(Object obj)
确定 obj 是否等于此地址。

boolean

CompositeName.equals(Object obj)
确定两个复合名称是否相等。

boolean

CompoundName.equals(Object obj)
确定 obj 在语法上是否等同于此组合名称。

boolean

RefAddr.equals(Object obj)
确定 obj 是否等于此 RefAddr。

boolean

Reference.equals(Object obj)
确定 obj 是否是一个与此引用具有相同地址（按相同顺序）的引用。

void

Context.rebind(Name name, Object obj)
将名称绑定到对象，重写任何现有绑定。

void

InitialContext.rebind(Name name, Object obj)

void

Context.rebind(String name, Object obj)
将名称绑定到对象，重写所有现有绑定。

void

InitialContext.rebind(String name, Object obj)

void

LinkException.setLinkResolvedObj(Object obj)
设置此异常的已解析链接对象字段。

void

Binding.setObject(Object obj)
设置与此绑定关联的对象。

void

NamingException.setResolvedObj(Object obj)
设置此异常的已解析对象字段。

参数类型为 Object 的 javax.naming 中的构造方法

Binding(String name, Object obj)
在给定其名称和对象的情况下构造一个 Binding 实例。

Binding(String name, Object obj, boolean isRelative)
在给定其名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。

Binding(String name, String className, Object obj)
在给定其名称、类名称和对象的情况下构造一个 Binding 实例。

Binding(String name, String className, Object obj, boolean isRelative)
在给定其名称、类名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。

javax.naming.directory 中 Object 的使用

javax.naming.directory 中 Object 的子类

class

AttributeInUseException
当操作试图添加已经存在的属性时抛出此异常。

class

AttributeModificationException
当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。

class

BasicAttribute
此类提供 Attribute 接口的基本实现。

class

BasicAttributes
此类提供 Attributes 接口的基本实现。

class

InitialDirContext
此类是执行目录操作的初始上下文。

class

InvalidAttributeIdentifierException
在试图用无效的属性标识符创建属性时，抛出此异常。

class

InvalidAttributesException
在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。

class

InvalidSearchControlsException
在为搜索操作指定的 SearchControls 无效时，抛出此异常。

class

InvalidSearchFilterException
当指定的搜索过滤器无效时，抛出此异常。

class

ModificationItem
此类表示修改项。

class

NoSuchAttributeException
尝试访问不存在的属性时，抛出此异常。

class

SchemaViolationException
当方法在某些方面违反模式时，抛出此异常。

class

SearchControls
此类封装确定搜索范围和搜索返回结果的因子。

class

SearchResult
此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

类型参数类型为 Object 的 javax.naming.directory 中的字段

protected  Vector<Object>

BasicAttribute.values
保存属性的值。

返回 Object 的 javax.naming.directory 中的方法

Object

Attribute.clone()
对属性进行复制。

Object

Attributes.clone()
对属性集进行复制。

Object

BasicAttribute.clone()

Object

BasicAttributes.clone()

Object

Attribute.get()
检索此属性的其中一个值。

Object

BasicAttribute.get()
检索此属性的其中一个值。

Object

Attribute.get(int ix)
从属性值的有序列表中检索属性值。

Object

BasicAttribute.get(int ix)

Object

Attribute.remove(int ix)
从属性值的有序列表中移除属性值。

Object

BasicAttribute.remove(int ix)

Object

Attribute.set(int ix, Object attrVal)
设置属性值的有序列表中的属性值。

Object

BasicAttribute.set(int ix, Object attrVal)

参数类型为 Object 的 javax.naming.directory 中的方法

void

Attribute.add(int ix, Object attrVal)
将属性值添加到属性值的有序列表中。

void

BasicAttribute.add(int ix, Object attrVal)

boolean

Attribute.add(Object attrVal)
向属性添加新值。

boolean

BasicAttribute.add(Object attrVal)
向此属性添加新值。

void

DirContext.bind(Name name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象。

void

InitialDirContext.bind(Name name, Object obj, Attributes attrs)

void

DirContext.bind(String name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象。

void

InitialDirContext.bind(String name, Object obj, Attributes attrs)

boolean

Attribute.contains(Object attrVal)
确定某个值是否在属性中。

boolean

BasicAttribute.contains(Object attrVal)
确定值是否在此属性中。

boolean

BasicAttribute.equals(Object obj)
确定 obj 是否等于此属性。

boolean

BasicAttributes.equals(Object obj)
确定此 BasicAttributes 是否等于另一个 Attributes。

Attribute

Attributes.put(String attrID, Object val)
向属性集中添加新属性。

Attribute

BasicAttributes.put(String attrID, Object val)

void

DirContext.rebind(Name name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。

void

InitialDirContext.rebind(Name name, Object obj, Attributes attrs)

void

DirContext.rebind(String name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。

void

InitialDirContext.rebind(String name, Object obj, Attributes attrs)

boolean

Attribute.remove(Object attrval)
从属性中移除指定值。

boolean

BasicAttribute.remove(Object attrval)
从此属性中移除指定值。

NamingEnumeration<SearchResult>

DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)

NamingEnumeration<SearchResult>

DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)

Object

Attribute.set(int ix, Object attrVal)
设置属性值的有序列表中的属性值。

Object

BasicAttribute.set(int ix, Object attrVal)

参数类型为 Object 的 javax.naming.directory 中的构造方法

BasicAttribute(String id, Object value)
构造一个带有单个值的无序属性的新实例。

BasicAttribute(String id, Object value, boolean ordered)
构造一个带有单个值的可能为有序属性的新实例。

BasicAttributes(String attrID, Object val)
构造带有一个属性的新 Attributes 实例。

BasicAttributes(String attrID, Object val, boolean ignoreCase)
构造带有一个属性的新 Attributes 实例。

SearchResult(String name, Object obj, Attributes attrs)
使用结果的名称、绑定对象及其属性构造一个搜索结果。

SearchResult(String name, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

SearchResult(String name, String className, Object obj, Attributes attrs)
使用结果的名称、类名称、绑定对象及其属性构造一个搜索结果。

SearchResult(String name, String className, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、类名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

javax.naming.event 中 Object 的使用

javax.naming.event 中 Object 的子类

class

NamingEvent
此类表示命名/目录服务触发的事件。

class

NamingExceptionEvent
此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。

声明为 Object 的 javax.naming.event 中的字段

protected  Object

NamingEvent.changeInfo
包含关于生成此事件的更改的信息。

返回 Object 的 javax.naming.event 中的方法

Object

NamingEvent.getChangeInfo()
检索此事件的更改信息。

参数类型为 Object 的 javax.naming.event 中的方法

void

EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。

void

EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。

参数类型为 Object 的 javax.naming.event 中的构造方法

NamingEvent(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)
构造一个 NamingEvent 的实例。

javax.naming.ldap 中 Object 的使用

javax.naming.ldap 中 Object 的子类

class

BasicControl
此类提供 Control 接口的基本实现。

class

ControlFactory
此抽象类表示用于创建 LDAPv3 控件的工厂。

class

InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

class

LdapName
此类表示 RFC 2253 指定的标识名。

class

LdapReferralException
此抽象类用于表示 LDAP 引用异常。

class

ManageReferralControl
将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。

class

PagedResultsControl
请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。

class

PagedResultsResponseControl
指示一批搜索结果的末尾。

class

Rdn
此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。

class

SortControl
请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。

class

SortKey
排序键及其关联的排序参数。

class

SortResponseControl
指示搜索结果的请求排序是否成功。

class

StartTlsRequest
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展请求。

class

StartTlsResponse
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展响应。

class

UnsolicitedNotificationEvent
此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。

返回 Object 的 javax.naming.ldap 中的方法

Object

LdapName.clone()
生成此名称的新副本。

Object

Rdn.getValue()
检索一个此 Rdn 的值。

Object

LdapName.remove(int posn)
从此 LDAP 名称中移除一个组件。

static Object

Rdn.unescapeValue(String val)
在给定根据 RFC 2253 中指定的规则进行格式化的属性值字符串的情况下，返回未格式化的值。

参数类型为 Object 的 javax.naming.ldap 中的方法

int

LdapName.compareTo(Object obj)
比较此 LdapName 与指定 Object 的顺序。

int

Rdn.compareTo(Object obj)
比较此 Rdn 与指定 Object 的顺序。

boolean

LdapName.equals(Object obj)
确定两个 LDAP 名称是否相等。

boolean

Rdn.equals(Object obj)
比较指定 Object 与此 Rdn 的相等性。

static String

Rdn.escapeValue(Object val)
在给定属性值的情况下返回根据 RFC 2253 中指定的规则转义的字符串。

参数类型为 Object 的 javax.naming.ldap 中的构造方法

Rdn(String type, Object value)
根据给定属性类型和值构造 Rdn。

UnsolicitedNotificationEvent(Object src, UnsolicitedNotification notice)
构造一个新的 UnsolicitedNotificationEvent 实例。

javax.naming.spi 中 Object 的使用

javax.naming.spi 中 Object 的子类

class

DirectoryManager
此类包含支持 DirContext 实现的方法。

static class

DirStateFactory.Result
用于返回 DirStateFactory.getStateToBind() 的结果的对象/属性对。

class

NamingManager
此类包含一些方法来创建上下文对象以及通过命名或目录服务中的信息引用的对象。

class

ResolveResult
此类表示解析某一名称的结果。

声明为 Object 的 javax.naming.spi 中的字段

protected  Object

ResolveResult.resolvedObj
该字段包含已成功解析成的 Object。

返回 Object 的 javax.naming.spi 中的方法

Object

DirStateFactory.Result.getObject()
检索要绑定的对象。

static Object

NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)
为指定对象和环境创建一个对象实例。

Object

ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
使用指定的位置或引用信息创建一个对象。

Object

DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
使用位置或引用信息以及指定的属性创建一个对象。

static Object

DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
为指定对象、属性和环境创建一个对象实例。

Object

ResolveResult.getResolvedObj()
检索已成功解析成的 Object。

static Object

NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
检索用于绑定的对象的状态。

Object

StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
检索用于绑定的对象状态。

参数类型为 Object 的 javax.naming.spi 中的方法

ObjectFactory

ObjectFactoryBuilder.createObjectFactory(Object obj, Hashtable<?,?> environment)
使用所提供的环境创建一个新对象工厂。

static Object

NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)
为指定对象和环境创建一个对象实例。

Object

ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
使用指定的位置或引用信息创建一个对象。

Object

DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
使用位置或引用信息以及指定的属性创建一个对象。

static Object

DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
为指定对象、属性和环境创建一个对象实例。

static Object

NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
检索用于绑定的对象的状态。

Object

StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
检索用于绑定的对象状态。

DirStateFactory.Result

DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)
在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。

static DirStateFactory.Result

DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
在给定初始对象及其属性时，检索用于绑定的对象的状态。

void

ResolveResult.setResolvedObj(Object obj)
将此结果的已解析 Object 字段设置为 obj。

参数类型为 Object 的 javax.naming.spi 中的构造方法

DirStateFactory.Result(Object obj, Attributes outAttrs)
构造一个 Result 实例。

ResolveResult(Object robj, Name rname)
构造一个新的 ResolveResult 实例，该实例由已解析 Object 和剩余名称组成。

ResolveResult(Object robj, String rcomp)
构造一个新的 ResolveResult 实例，该实例由已解析对象和剩余未解析组件组成。

javax.net 中 Object 的使用

javax.net 中 Object 的子类

class

ServerSocketFactory
此类创建服务器套接字。

class

SocketFactory
此类创建套接字。

javax.net.ssl 中 Object 的使用

javax.net.ssl 中 Object 的子类

class

CertPathTrustManagerParameters
CertPathParameters 的包装器。

class

HandshakeCompletedEvent
此事件指示在给定的 SSL 连接上 SSL 握手结束。

class

HttpsURLConnection
HttpsURLConnection 扩展 HttpURLConnection，支持各种特定于 https 功能。

class

KeyManagerFactory
此类充当基于密钥内容源的密钥管理器的工厂。

class

KeyManagerFactorySpi
此类为 KeyManagerFactory 类定义了服务提供者接口 (SPI)。

class

KeyStoreBuilderParameters
封装了 KeyStore.Builders 列表的 X509KeyManagers 参数对象。

class

SSLContext
此类的实例表示安全套接字协议的实现，它充当用于安全套接字工厂或 SSLEngine 的工厂。

class

SSLContextSpi
此类为 SSLContext 类定义了服务提供者接口 (SPI)。

class

SSLEngine
此类允许使用安全套接字层 (SSL) 或 IETF RFC 2246 "Transport Layer Security" (TLS) 协议进行安全通信，但它与传输无关。

class

SSLEngineResult
SSLEngine I/O 调用所生成的结果状态的封装。

class

SSLException
指示由 SSL 子系统检测到的某类错误。

class

SSLHandshakeException
指示客户端和服务器不能就所需安全级别进行协商。

class

SSLKeyException
报告错误的 SSL 密钥。

class

SSLParameters
封装 SSL/TLS 连接的参数。

class

SSLPeerUnverifiedException
指示还没有验证同位体的身份。

class

SSLPermission
此类用于各种网络权限。

class

SSLProtocolException
报告在 SSL 协议的操作中的错误。

class

SSLServerSocket
此类扩展了 ServerSocket 并且提供使用像 Secure Sockets Layer (SSL) 或 Transport Layer Security (TLS) 协议的安全服务器套接字。

class

SSLServerSocketFactory
SSLServerSocketFactory 创建 SSLServerSocket。

class

SSLSessionBindingEvent
此事件向 SSLSessionBindingListener 传播。

class

SSLSocket
此类扩展 Socket 并提供使用诸如安全套接字层 (Secure Sockets Layer, SSL) 或 IETF 传输层安全性 (Transport Layer Security, TLS) 等协议的安全套接字。

class

SSLSocketFactory
SSLSocketFactory 创建 SSLSocket。

class

TrustManagerFactory
此类充当基于信任材料源的信任管理器的工厂。

class

TrustManagerFactorySpi
此类为 TrustManagerFactory 类定义了服务提供者接口 (SPI)。

class

X509ExtendedKeyManager
提供 X509KeyManager 接口的扩展的抽象类。

返回 Object 的 javax.net.ssl 中的方法

Object

SSLSession.getValue(String name)
返回会话的应用层数据中的绑定到给定名称的对象。

参数类型为 Object 的 javax.net.ssl 中的方法

void

SSLSession.putValue(String name, Object value)
使用给定的 name 将指定的 value 对象绑定到会话的应用层数据中。

javax.print 中 Object 的使用

javax.print 中 Object 的子类

class

DocFlavor
类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。

static class

DocFlavor.BYTE_ARRAY
类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。

static class

DocFlavor.CHAR_ARRAY
类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。

static class

DocFlavor.INPUT_STREAM
类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。

static class

DocFlavor.READER
类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。

static class

DocFlavor.SERVICE_FORMATTED
类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。

static class

DocFlavor.STRING
类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。

static class

DocFlavor.URL
类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。

class

PrintException
类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。

class

PrintServiceLookup
此类的实现为特定类型的 PrintService（通常等效于打印机）提供查找服务。

class

ServiceUI
此类是各种 UI 便捷方法的集合，这些方法为浏览那些通过 Java Print Service API 所查找的 PrintService 提供了图形用户对话框。

class

ServiceUIFactory
服务可以可选地提供 UI，这些 UI 允许以不同的角色进行不同风格的交互。

class

SimpleDoc
此类是接口 Doc 的实现，可用于很多常见的打印请求中。

class

StreamPrintService
此类扩展了 PrintService 并表示这样一种 PrintService，即以不同的格式向客户端提供的输出流打印数据。

class

StreamPrintServiceFactory
StreamPrintServiceFactory 是 StreamPrintService 实例的工厂，StreamPrintService 可以 mime 类型所描述的特定文档格式向输出流中打印数据。

返回 Object 的 javax.print 中的方法

Object

PrintService.getDefaultAttributeValue(Class<? extends Attribute> category)
确定给定类别中此 PrintService 的默认打印属性值。

Object

Doc.getPrintData()
获得打印数据表示形式对象，该对象包含此 doc 对象的部分打印数据，其格式对应于受支持的 DocFlavor。

Object

SimpleDoc.getPrintData()

Object

PrintService.getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。

abstract  Object

ServiceUIFactory.getUI(int role, String ui)
获得一个 UI 对象，它可能被应用程序强制转换为所请求的 UI 类型并在该应用程序的用户界面中使用。

参数类型为 Object 的 javax.print 中的方法

boolean

DocFlavor.equals(Object obj)
确定此 DocFlavor 对象是否等于给定的对象。

boolean

PrintService.equals(Object obj)
确定两个服务是否引用相同的底层服务。

参数类型为 Object 的 javax.print 中的构造方法

SimpleDoc(Object printData, DocFlavor flavor, DocAttributeSet attributes)
构造具有指定打印数据、doc flavor 和 doc 属性集的 SimpleDoc。

javax.print.attribute 中 Object 的使用

javax.print.attribute 中 Object 的子类

class

AttributeSetUtilities
类 AttributeSetUtilities 为操作 AttributeSets 提供静态方法。

class

DateTimeSyntax
类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。

class

EnumSyntax
类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。

class

HashAttributeSet
类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。

class

HashDocAttributeSet
类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。

class

HashPrintJobAttributeSet
类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。

class

HashPrintRequestAttributeSet
类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。

class

HashPrintServiceAttributeSet
类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。

class

IntegerSyntax
类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。

class

ResolutionSyntax
类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。

class

SetOfIntegerSyntax
类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。

class

Size2DSyntax
类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。

class

TextSyntax
类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。

class

UnmodifiableSetException
当由于设置不可修改而无法执行请求的操作时，抛出该异常。

class

URISyntax
类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。

返回 Object 的 javax.print.attribute 中的方法

Object

EnumSyntax.clone()
返回此枚举值的一个副本，该副本保留了枚举值的语义，它是与此枚举值相同的对象。

protected  Object

EnumSyntax.readResolve()
在对象输入过程中，将此反序列化的枚举实例转换为枚举属性类中定义的适当枚举值。

参数类型为 Object 的 javax.print.attribute 中的方法

boolean

AttributeSet.equals(Object object)
比较指定的对象与此属性集的相等性。

boolean

DateTimeSyntax.equals(Object object)
返回此日期-时间属性是否等效于传入的对象。

boolean

HashAttributeSet.equals(Object object)
比较指定的对象与此属性集的相等性。

boolean

IntegerSyntax.equals(Object object)
返回此整数属性是否等效于传入的对象。

boolean

ResolutionSyntax.equals(Object object)
返回此分辨率属性是否等效于传入的对象。

boolean

SetOfIntegerSyntax.equals(Object object)
返回此整数集属性是否等效于传入的对象。

boolean

Size2DSyntax.equals(Object object)
返回此二维大小属性是否等效于传入的对象。

boolean

TextSyntax.equals(Object object)
返回此文本属性是否等效于传入的对象。

boolean

URISyntax.equals(Object object)
返回此 URI 属性是否等效于传入的对象。

static Class<?>

AttributeSetUtilities.verifyAttributeCategory(Object object, Class<?> interfaceName)
验证给定的对象是否为实现给定接口（假定为接口 Attribute 或其子接口）的 Class。

static Attribute

AttributeSetUtilities.verifyAttributeValue(Object object, Class<?> interfaceName)
验证给定的对象是否为给定接口（假定为接口 Attribute 或其子接口）的一个实例。

javax.print.attribute.standard 中 Object 的使用

javax.print.attribute.standard 中 Object 的子类

class

Chromaticity
Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。

class

ColorSupported
ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。

class

Compression
Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。

class

Copies
Copies 类是整数值形式的打印属性类，它指定了要打印的份数。

class

CopiesSupported
CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。

class

DateTimeAtCompleted
DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。

class

DateTimeAtCreation
DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。

class

DateTimeAtProcessing
DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。

class

Destination
Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。

class

DocumentName
DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。

class

Fidelity
Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。

class

Finishings
Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。

class

JobHoldUntil
JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。

class

JobImpressions
JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。

class

JobImpressionsCompleted
JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。

class

JobImpressionsSupported
JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。

class

JobKOctets
JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。

class

JobKOctetsProcessed
JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。

class

JobKOctetsSupported
JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。

class

JobMediaSheets
JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。

class

JobMediaSheetsCompleted
JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。

class

JobMediaSheetsSupported
Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。

class

JobMessageFromOperator
JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。

class

JobName
JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。

class

JobOriginatingUserName
JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。

class

JobPriority
JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。

class

JobPrioritySupported
JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。

class

JobSheets
JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。

class

JobState
JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。

class

JobStateReason
JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。

class

JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

class

Media
Media 类是打印属性类，它指定了要在其上打印的介质。

class

MediaName
MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。

class

MediaPrintableArea
MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。

class

MediaSize
MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。

static class

MediaSize.Engineering
MediaSize.Engineering 类包括 engineering 介质的 MediaSize 值。

static class

MediaSize.ISO
MediaSize.ISO 类包括 ISO 介质的 MediaSize 值。

static class

MediaSize.JIS
MediaSize.JIS 类包括 JIS (Japanese) 介质的 MediaSize 值。

static class

MediaSize.NA
MediaSize.NA 类包括 North American 介质的 MediaSize 值。

static class

MediaSize.Other
MediaSize.Other 类包括其他介质的 MediaSize 值。

class

MediaSizeName
MediaSizeName 类是 Media 的子类。

class

MediaTray
MediaTray 类是 Media 的子类。

class

MultipleDocumentHandling
MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。

class

NumberOfDocuments
NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。

class

NumberOfInterveningJobs
NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。

class

NumberUp
NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。

class

NumberUpSupported
NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。

class

OrientationRequested
OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。

class

OutputDeviceAssigned
OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。

class

PageRanges
PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。

class

PagesPerMinute
PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。

class

PagesPerMinuteColor
PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。

class

PDLOverrideSupported
PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。

class

PresentationDirection
PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。

class

PrinterInfo
PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。

class

PrinterIsAcceptingJobs
PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。

class

PrinterLocation
PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。

class

PrinterMakeAndModel
PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。

class

PrinterMessageFromOperator
PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。

class

PrinterMoreInfo
PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。

class

PrinterMoreInfoManufacturer
PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。

class

PrinterName
PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。

class

PrinterResolution
PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。

class

PrinterState
PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。

class

PrinterStateReason
PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

class

PrinterStateReasons
PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

class

PrinterURI
PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。

class

PrintQuality
PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。

class

QueuedJobCount
QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。

class

ReferenceUriSchemesSupported
ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。

class

RequestingUserName
RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。

class

Severity
Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。

class

SheetCollate
SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。

class

Sides
Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

参数类型为 Object 的 javax.print.attribute.standard 中的方法

boolean

Copies.equals(Object object)
返回此副本属性是否等效于传入的对象。

boolean

CopiesSupported.equals(Object object)
返回支持副本的此属性是否等于传入的对象。

boolean

DateTimeAtCompleted.equals(Object object)
返回此 DateTimeAtCompleted 属性是否等效于传入的对象。

boolean

DateTimeAtCreation.equals(Object object)
返回此 DateTimeAtCreation 属性是否等效于传入的对象。

boolean

DateTimeAtProcessing.equals(Object object)
返回此 DateTimeAtProcessing 属性是否等效于传入的对象。

boolean

Destination.equals(Object object)
返回此目标属性是否等效于传入的对象。

boolean

DocumentName.equals(Object object)
返回此文档名称属性是否等效于传入的对象。

boolean

JobHoldUntil.equals(Object object)
返回此 JobHoldUntil 属性是否等效于传入的对象。

boolean

JobImpressions.equals(Object object)
返回此作业印张属性是否等效于传入的对象。

boolean

JobImpressionsCompleted.equals(Object object)
返回此 JobImpressionsCompleted 属性是否等效于传入的对象。

boolean

JobImpressionsSupported.equals(Object object)
返回此 JobImpressionsSupported 属性是否等效于传入的对象。

boolean

JobKOctets.equals(Object object)
返回此 JobKOctets 属性是否等效于传入的对象。

boolean

JobKOctetsProcessed.equals(Object object)
返回此 JobKOctetsProcessed 属性是否等效于传入的对象。

boolean

JobKOctetsSupported.equals(Object object)
返回此 JobKOctetsSupported 属性是否等效于传入的对象。

boolean

JobMediaSheets.equals(Object object)
返回此 JobMediaSheets 属性是否等效于传入的对象。

boolean

JobMediaSheetsCompleted.equals(Object object)
返回此 JobMediaSheetsCompleted 属性是否等效于传入的对象。

boolean

JobMediaSheetsSupported.equals(Object object)
返回支持的此 JobMediaSheetsSupported 属性是否等效于传入的对象。

boolean

JobMessageFromOperator.equals(Object object)
返回 Operator 属性传来的此作业消息是否等效于传入的对象。

boolean

JobName.equals(Object object)
返回此作业名称属性是否等效于传入的对象。

boolean

JobOriginatingUserName.equals(Object object)
返回此 JobOriginatingUserName 属性是否等效于传入的对象。

boolean

JobPriority.equals(Object object)
返回此作业优先级属性是否等效于传入的对象。

boolean

JobPrioritySupported.equals(Object object)
返回支持的此作业优先级属性是否等效于传入的对象。

boolean

Media.equals(Object object)
返回此介质属性是否等效于传入的对象。

boolean

MediaPrintableArea.equals(Object object)
返回此介质页边距属性是否等效于传入的对象。

boolean

MediaSize.equals(Object object)
返回此介质尺寸属性是否等效于传入的对象。

boolean

NumberOfDocuments.equals(Object object)
返回此文档数属性是否等效于传入的对象。

boolean

NumberOfInterveningJobs.equals(Object object)
返回此 NumberOfInterveningJobs 属性是否等效于传入的对象。

boolean

NumberUp.equals(Object object)
返回此计数属性是否等效于传入的对象。

boolean

NumberUpSupported.equals(Object object)
返回此 NumberUpSupported 属性是否等效于传入的对象。

boolean

OutputDeviceAssigned.equals(Object object)
返回此 OutputDeviceAssigned 属性是否等效于传入的对象。

boolean

PageRanges.equals(Object object)
返回此 PageRanges 属性是否等效于传入的对象。

boolean

PagesPerMinute.equals(Object object)
返回此 PagesPerMinute 属性是否等效于传入的对象。

boolean

PagesPerMinuteColor.equals(Object object)
返回此 PagesPerMinuteColor 属性是否等效于传入的对象。

boolean

PrinterInfo.equals(Object object)
返回此 PrinterInfo 属性是否等效于传入的对象。

boolean

PrinterLocation.equals(Object object)
返回此 PrinterLocation 属性是否等效于传入的对象。

boolean

PrinterMakeAndModel.equals(Object object)
返回此 PrinterMakeAndModel 属性是否等效于传入的对象。

boolean

PrinterMessageFromOperator.equals(Object object)
返回此 PrinterMessageFromOperator 属性是否等效于传入的对象。

boolean

PrinterMoreInfo.equals(Object object)
返回此 PrinterMoreInfo 属性是否等效于传入的对象。

boolean

PrinterMoreInfoManufacturer.equals(Object object)
返回此 PrinterMoreInfoManufacturer 属性是否等效于传入的对象。

boolean

PrinterName.equals(Object object)
返回此 PrinterName 属性是否等效于传入的对象。

boolean

PrinterResolution.equals(Object object)
返回此 PrinterResolution 属性是否等效于传入的对象。

boolean

PrinterURI.equals(Object object)
返回此打印机名称属性是否等效于传入的对象。

boolean

QueuedJobCount.equals(Object object)
返回此 QueuedJobCount 属性是否等效于传入的对象。

boolean

RequestingUserName.equals(Object object)
返回此 RequestingUserName 属性是否等效于传入的对象。

javax.print.event 中 Object 的使用

javax.print.event 中 Object 的子类

class

PrintEvent
类 PrintEvent 是所有 Print Service API 事件的超类。

class

PrintJobAdapter
接收打印作业事件的抽象适配器类。

class

PrintJobAttributeEvent
类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。

class

PrintJobEvent
类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。

class

PrintServiceAttributeEvent
类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

参数类型为 Object 的 javax.print.event 中的构造方法

PrintEvent(Object source)
构造一个 PrintEvent 对象。

javax.rmi 中 Object 的使用

javax.rmi 中 Object 的子类

class

PortableRemoteObject
服务器实现对象可以从 javax.rmi.PortableRemoteObject 继承，也可以实现一个远程接口，然后使用 exportObject 方法将其本身注册为服务器对象。

返回 Object 的 javax.rmi 中的方法

static Object

PortableRemoteObject.narrow(Object narrowFrom, Class narrowTo)
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。

参数类型为 Object 的 javax.rmi 中的方法

static Object

PortableRemoteObject.narrow(Object narrowFrom, Class narrowTo)
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。

javax.rmi.CORBA 中 Object 的使用

javax.rmi.CORBA 中 Object 的子类

class

ClassDesc
此类用于对 IIOP 上的 java.lang.Class 对象进行编组。

class

Stub
必须从其继承所有 RMI-IIOP stub 的基类。

class

Util
提供可以由 stub 和 tie 用于执行公共操作的实用方法。

返回 Object 的 javax.rmi.CORBA 中的方法

static Object

Util.copyObject(Object obj, ORB orb)
复制或连接一个对象。

Object

UtilDelegate.copyObject(Object obj, ORB orb)
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。

static Object[]

Util.copyObjects(Object[] obj, ORB orb)
复制或连接一个对象数组。

Object[]

UtilDelegate.copyObjects(Object[] obj, ORB orb)
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。

Object

PortableRemoteObjectDelegate.narrow(Object narrowFrom, Class narrowTo)
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。

static Object

Util.readAny(InputStream in)
将 java.lang.Object 作为 CORBA any 读取。

Object

UtilDelegate.readAny(InputStream in)
Util.readAny(org.omg.CORBA.portable.InputStream) 的委托调用。

参数类型为 Object 的 javax.rmi.CORBA 中的方法

static Object

Util.copyObject(Object obj, ORB orb)
复制或连接一个对象。

Object

UtilDelegate.copyObject(Object obj, ORB orb)
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。

static Object[]

Util.copyObjects(Object[] obj, ORB orb)
复制或连接一个对象数组。

Object[]

UtilDelegate.copyObjects(Object[] obj, ORB orb)
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。

boolean

Stub.equals(Object obj)
比较两个 stub 的相等性。

boolean

StubDelegate.equals(Stub self, Object obj)
Stub.equals(java.lang.Object) 的委托调用。

Object

PortableRemoteObjectDelegate.narrow(Object narrowFrom, Class narrowTo)
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。

static void

Util.writeAbstractObject(OutputStream out, Object obj)
将 java.lang.Object 作为一个值或 CORBA Object 写入。

void

UtilDelegate.writeAbstractObject(OutputStream out, Object obj)
Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。

static void

Util.writeAny(OutputStream out, Object obj)
将 any java.lang.Object 作为 CORBA any 写入。

void

UtilDelegate.writeAny(OutputStream out, Object obj)
Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。

static void

Util.writeRemoteObject(OutputStream out, Object obj)
将 java.lang.Object 作为 CORBA Object 写入。

void

UtilDelegate.writeRemoteObject(OutputStream out, Object obj)
Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。

javax.rmi.ssl 中 Object 的使用

javax.rmi.ssl 中 Object 的子类

class

SslRMIClientSocketFactory
SslRMIClientSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的客户端套接字。

class

SslRMIServerSocketFactory
SslRMIServerSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的服务端套接字。

参数类型为 Object 的 javax.rmi.ssl 中的方法

boolean

SslRMIClientSocketFactory.equals(Object obj)
指示某个其他对象是否“等于”此对象。

boolean

SslRMIServerSocketFactory.equals(Object obj)
指示某个其他对象是否“等于”此对象。

javax.script 中 Object 的使用

javax.script 中 Object 的子类

class

AbstractScriptEngine
为几个 eval 方法的变体提供标准实现。

class

CompiledScript
存储编译结果的类扩展自此类。

class

ScriptEngineManager
ScriptEngineManager 为 ScriptEngine 类实现一个发现和实例化机制，还维护一个键/值对集合来存储所有 Manager 创建的引擎所共享的状态。

class

ScriptException
脚本 API 的一般 Exception 类。

class

SimpleBindings
一个受 HashMap 或其他某些指定 Map 支持的 Bindings 的简单实现。

class

SimpleScriptContext
ScriptContext 的简单实现。

返回 Object 的 javax.script 中的方法

Object

CompiledScript.eval()
执行存储在 CompiledScript 对象中的程序。

Object

CompiledScript.eval(Bindings bindings)
执行存储在 CompiledScript 对象中的程序，脚本执行期间使用所提供的属性的 Bindings 作为关联 ScriptEngine 的 ENGINE_SCOPE。

Object

AbstractScriptEngine.eval(Reader reader)
eval(Reader) 调用抽象 eval(Reader, ScriptContext)，并传递 context 字段的值给它。

Object

ScriptEngine.eval(Reader reader)
除了脚本的源是以 Reader 形式提供的外，与 eval(String) 相同。

Object

AbstractScriptEngine.eval(Reader reader, Bindings bindings)
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。

Object

ScriptEngine.eval(Reader reader, Bindings n)
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。

Object

ScriptEngine.eval(Reader reader, ScriptContext context)
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。

abstract  Object

CompiledScript.eval(ScriptContext context)
执行存储在此 CompiledScript 对象中的程序。

Object

AbstractScriptEngine.eval(String script)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader) 相同。

Object

ScriptEngine.eval(String script)
执行指定的脚本。

Object

AbstractScriptEngine.eval(String script, Bindings bindings)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。

Object

ScriptEngine.eval(String script, Bindings n)
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。

Object

ScriptEngine.eval(String script, ScriptContext context)
立即执行脚本，该脚本的源是作为第一个参数传递的 String。

Object

Bindings.get(Object key)
返回此映射将指定键所映射的值。

Object

SimpleBindings.get(Object key)
返回此映射将指定键所映射到的值。

Object

AbstractScriptEngine.get(String key)
获取受保护 context 字段的 ENGINE_SCOPE 中指定键的值。

Object

ScriptEngine.get(String key)
获取在此引擎的状态中设置的值。

Object

ScriptEngineManager.get(String key)
获取 Global Scope 中指定键的值。

Object

ScriptContext.getAttribute(String name)
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。

Object

SimpleScriptContext.getAttribute(String name)
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。

Object

ScriptContext.getAttribute(String name, int scope)
获取给定范围中某一属性的值。

Object

SimpleScriptContext.getAttribute(String name, int scope)
获取给定范围中某一属性的值。

Object

ScriptEngineFactory.getParameter(String key)
返回属性值，该属性的含义可能是特定于实现的。

Object

Invocable.invokeFunction(String name, Object... args)
用于调用脚本中定义的顶层程序和函数。

Object

Invocable.invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

Object

Bindings.put(String name, Object value)
设置指定的值。

Object

SimpleBindings.put(String name, Object value)
设置底层 map 字段中的指定键/值。

Object

Bindings.remove(Object key)
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。

Object

SimpleBindings.remove(Object key)
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。

Object

ScriptContext.removeAttribute(String name, int scope)
移除给定范围中的某一属性。

Object

SimpleScriptContext.removeAttribute(String name, int scope)
移除给定范围中的某一属性。

返回变量类型为 Object 的类型的 javax.script 中的方法

Set<Map.Entry<String,Object>>

SimpleBindings.entrySet()
返回此映射中包含的映射关系的 Set 视图。

Collection<Object>

SimpleBindings.values()
返回此映射中包含的值的 Collection 视图。

参数类型为 Object 的 javax.script 中的方法

boolean

Bindings.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

SimpleBindings.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

SimpleBindings.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

Object

Bindings.get(Object key)
返回此映射将指定键所映射的值。

Object

SimpleBindings.get(Object key)
返回此映射将指定键所映射到的值。

<T> T

Invocable.getInterface(Object thiz, Class<T> clasz)
返回一个接口的实现，该接口使用解释器中已编译脚本对象的成员函数。

Object

Invocable.invokeFunction(String name, Object... args)
用于调用脚本中定义的顶层程序和函数。

Object

Invocable.invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

Object

Invocable.invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

void

AbstractScriptEngine.put(String key, Object value)
使用受保护 context 字段的 ENGINE_SCOPE Bindings 中的指定键设置指定的值。

Object

Bindings.put(String name, Object value)
设置指定的值。

void

ScriptEngine.put(String key, Object value)
设置 ScriptEngine 的状态中的键/值对，它创建一个将在脚本执行中使用或者以其他方式使用的 Java Language Binding，具体取决于该键是否被保留。

void

ScriptEngineManager.put(String key, Object value)
设置 Global Scope 中指定的键/值对。

Object

SimpleBindings.put(String name, Object value)
设置底层 map 字段中的指定键/值。

Object

Bindings.remove(Object key)
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。

Object

SimpleBindings.remove(Object key)
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。

void

ScriptContext.setAttribute(String name, Object value, int scope)
设置给定范围中某一属性的值。

void

SimpleScriptContext.setAttribute(String name, Object value, int scope)
设置给定范围中某一属性的值。

类型变量类型为 Object 的 javax.script 中的方法参数

void

Bindings.putAll(Map<? extends String,? extends Object> toMerge)
将给定 Map 中的所有映射关系添加到此 Bindings 中。

void

SimpleBindings.putAll(Map<? extends String,? extends Object> toMerge)
putAll 是使用 Map.putAll 实现的。

类型变量类型为 Object 的 javax.script 中的构造方法参数

SimpleBindings(Map<String,Object> m)
构造方法使用现有 Map 来存储值。

javax.security.auth 中 Object 的使用

javax.security.auth 中 Object 的子类

class

AuthPermission
此类用于验证权限。

class

DestroyFailedException
当 destroy 操作失败时，抛出此异常。

class

PrivateCredentialPermission
此类用来保护对属于特定 Subject 的私有 Credential 的访问。

class

RefreshFailedException
当 refresh 操作失败时，抛出此异常。

class

Subject
Subject 表示某一项（如一个人）的一组相关信息。

class

SubjectDomainCombiner
SubjectDomainCombiner 通过与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新 ProtectionDomains。

返回变量类型为 Object 的类型的 javax.security.auth 中的方法

Set<Object>

Subject.getPrivateCredentials()
返回此 Subject 中包含的私有证书 Set。

Set<Object>

Subject.getPublicCredentials()
返回此 Subject 中包含的公开证书 Set。

参数类型为 Object 的 javax.security.auth 中的方法

boolean

PrivateCredentialPermission.equals(Object obj)
检查两个 PrivateCredentialPermission 对象是否相等。

boolean

Subject.equals(Object o)
比较指定对象与此 Subject 的相等性。

javax.security.auth.callback 中 Object 的使用

javax.security.auth.callback 中 Object 的子类

class

ChoiceCallback
底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。

class

ConfirmationCallback
底层安全服务实例化 ConfirmationCallback，并将其传递到 CallbackHandler 的 handle 方法，以请求 YES/NO、OK/CANCEL、YES/NO/CANCEL 或其他类似的确认信息。

class

LanguageCallback
底层安全服务实例化一个 LanguageCallback, 并将其传递给 CallbackHandler 的 handle 方法，以获取用于本地化文本的 Locale。

class

NameCallback
底层安全服务实例化一个 NameCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取名称信息。

class

PasswordCallback
底层安全服务实例化一个 PasswordCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取密码信息。

class

TextInputCallback
底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。

class

TextOutputCallback
底层安全服务实例化一个 TextOutputCallback 并将其传递给 CallbackHandler 的 handle 方法，以显示信息消息、警告消息和错误消息。

class

UnsupportedCallbackException
在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

javax.security.auth.kerberos 中 Object 的使用

javax.security.auth.kerberos 中 Object 的子类

class

DelegationPermission
此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。

class

KerberosKey
此类为 Kerberos 主体封装一个长期秘密密钥。

class

KerberosPrincipal
此类封装 Kerberos 主体。

class

KerberosTicket
此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。

class

ServicePermission
此类用于保护 Kerberos 服务和访问这些服务所必需的证书。

参数类型为 Object 的 javax.security.auth.kerberos 中的方法

boolean

DelegationPermission.equals(Object obj)
检查两个 DelegationPermission 对象是否相等。

boolean

KerberosKey.equals(Object other)
比较指定 Object 与此 KerberosKey 的相等性。

boolean

KerberosPrincipal.equals(Object other)
比较指定的对象与此 Principal 是否相等。

boolean

KerberosTicket.equals(Object other)
比较给定 Object 与此 KerberosTicket 的相等性。

boolean

ServicePermission.equals(Object obj)
检查两个 ServicePermission 对象是否相等。

javax.security.auth.login 中 Object 的使用

javax.security.auth.login 中 Object 的子类

class

AccountException
一般的帐户异常。

class

AccountExpiredException
当用户帐户到期时抛出此异常。

class

AccountLockedException
帐户被锁定时抛出此异常。

class

AccountNotFoundException
未找到帐户时抛出此异常。

class

AppConfigurationEntry
此类表示为在 Configuration 类中的 getAppConfigurationEntry(String appName) 方法中指定的应用程序配置的单个 LoginModule 条目。

static class

AppConfigurationEntry.LoginModuleControlFlag
此类表示 LoginModule 是否为 REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL。

class

Configuration
Configuration 对象负责指定应该将哪一个 LoginModule 用于某一特定应用程序，以及应该以什么样的顺序调用 LoginModule。

class

ConfigurationSpi
此类为 Configuration 类定义服务提供者接口（SPI）。

class

CredentialException
一般证书异常。

class

CredentialExpiredException
当 Credential 到期时抛出此异常。

class

CredentialNotFoundException
找不到证书时抛出此异常。

class

FailedLoginException
当用户验证失败时抛出此异常。

class

LoginContext
LoginContext 类描述用于验证 Subjects 的基本方法和提供开发与底层验证技术无关的应用程序的方法。

class

LoginException
此异常是基本的登录异常。

javax.security.auth.x500 中 Object 的使用

javax.security.auth.x500 中 Object 的子类

class

X500Principal
此类表示一个 X.500 Principal。

class

X500PrivateCredential
此类表示一个 X500PrivateCredential。

参数类型为 Object 的 javax.security.auth.x500 中的方法

boolean

X500Principal.equals(Object o)
比较指定的 Object 与此 X500Principal 的相等性。

javax.security.cert 中 Object 的使用

javax.security.cert 中 Object 的子类

class

CertificateEncodingException
证书编码异常。

class

CertificateException
此异常指示各种证书问题之一。

class

CertificateExpiredException
证书过期异常。

class

CertificateNotYetValidException
证书不再有效异常。

class

CertificateParsingException
证书解析异常。

参数类型为 Object 的 javax.security.cert 中的方法

boolean

Certificate.equals(Object other)
比较此证书是否与指定对象相等。

javax.security.sasl 中 Object 的使用

javax.security.sasl 中 Object 的子类

class

AuthenticationException
此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。

class

AuthorizeCallback
此回调由 SaslServer 使用，以确定某个实体（由已验证的验证 id 所标识）能否代表另一个实体（由授权 id 所标识）。

class

RealmCallback
SaslClient 和 SaslServer 使用此回调来获取领域信息。

class

RealmChoiceCallback
SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。

class

Sasl
用于创建 SASL 客户端和服务器的静态类。

class

SaslException
此类表示在使用 SASL 时所发生的错误。

返回 Object 的 javax.security.sasl 中的方法

Object

SaslClient.getNegotiatedProperty(String propName)
获取已协商的属性。

Object

SaslServer.getNegotiatedProperty(String propName)
获取已协商的属性。

javax.sound.midi 中 Object 的使用

javax.sound.midi 中 Object 的子类

class

Instrument
乐器是带特定参数设置的声音合成算法，通常是为模仿现实世界的特定乐器或为获得特定音效而设计的。

class

InvalidMidiDataException
一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。

class

MetaMessage
MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。

static class

MidiDevice.Info
一个 MidiDevice.Info 对象，它包含了有关 MidiDevice 的各种数据，包括其名称、创建它的公司及描述性文本。

class

MidiEvent
MIDI 事件包含一个 MIDI 消息和一个相应的用刻度表示的时间戳，可代表存储在 MIDI 文件或 Sequence 对象中的 MIDI 事件信息。

class

MidiFileFormat
MidiFileFormat 对象，它封装了 MIDI 文件的类型、长度和定时信息。

class

MidiMessage
MidiMessage 是 MIDI 消息的基类。

class

MidiSystem
MidiSystem 类提供了对已安装的 MIDI 系统资源的访问，包括诸如 synthesizer、sequencer 和 MIDI 输入和输出端口等设备。

class

MidiUnavailableException
当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。

class

Patch
一个 Patch 对象，用于表示 MIDI 合成器上的某个位置，其中存储（加载）了单个乐器。

class

Sequence
Sequence 是一种数据结构，包含可由 Sequencer 对象回放的音乐信息（通常是整首歌曲或音乐作品）。

static class

Sequencer.SyncMode
SyncMode 对象表示 MIDI sequencer 的时间标记可与主或从设备同步的方式之一。

class

ShortMessage
ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。

class

SoundbankResource
SoundbankResource 表示存储在 Soundbank 中的任何音频资源。

class

SysexMessage
表示 MIDI 系统独占消息 SysexMessage 对象。

class

Track
MIDI 音轨是一个可随其他音轨存储在标准 MIDI 文件中的独立的 MIDI 事件流（带时间戳的 MIDI 数据）。

class

VoiceStatus
VoiceStatus 对象包含有关由 Synthesizer 生成的某个声音当前状态的信息。

返回 Object 的 javax.sound.midi 中的方法

Object

MetaMessage.clone()
创建一个与此对象具有相同类和相同内容的新对象。

abstract  Object

MidiMessage.clone()
创建一个与此对象具有相同类和相同内容的新对象。

Object

ShortMessage.clone()
创建一个与此对象具有相同类和相同内容的新对象。

Object

SysexMessage.clone()
创建一个与此对象具有相同类和相同内容的新对象。

abstract  Object

SoundbankResource.getData()
获得存储在此 SoundbankResource 中的采样音频。

Object

MidiFileFormat.getProperty(String key)
获得由键指定的属性值。

返回变量类型为 Object 的类型的 javax.sound.midi 中的方法

Map<String,Object>

MidiFileFormat.properties()
获得属性的一个不可修改的映射。

参数类型为 Object 的 javax.sound.midi 中的方法

boolean

MidiDevice.Info.equals(Object obj)
报告两个对象是否相等。

boolean

Sequencer.SyncMode.equals(Object obj)
确定两个对象是否等价。

类型变量类型为 Object 的 javax.sound.midi 中的构造方法参数

MidiFileFormat(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)
构造带一组属性的 MidiFileFormat。

javax.sound.midi.spi 中 Object 的使用

javax.sound.midi.spi 中 Object 的子类

class

MidiDeviceProvider
MidiDeviceProvider 是特定类型的 MIDI 设备的工厂或提供者。

class

MidiFileReader
MidiFileReader 提供 MIDI 文件读取服务。

class

MidiFileWriter
MidiFileWriter 提供 MIDI 文件写入服务。

class

SoundbankReader
SoundbankReader 提供音库文件读取服务。

javax.sound.sampled 中 Object 的使用

javax.sound.sampled 中 Object 的子类

class

AudioFileFormat
AudioFileFormat 类的实例描述音频文件，包括文件类型、文件长度（以字节为单位）、文件中包含的音频数据的长度（以示例帧为单位），以及音频数据的格式。

static class

AudioFileFormat.Type
Type 类的实例表示音频文件的标准类型之一。

class

AudioFormat
AudioFormat 是在声音流中指定特定数据安排的类。

static class

AudioFormat.Encoding
Encoding 类命名用于音频流的数据表示形式的特定类型。

class

AudioInputStream
音频输入流是具有指定音频格式和长度的输入流。

class

AudioPermission
AudioPermission 类表示对音频系统资源的访问权限。

class

AudioSystem
AudioSystem 类充当取样音频系统资源的入口点。

class

BooleanControl
BooleanControl 能够在影响行音频的两个可能的设置之间切换。

static class

BooleanControl.Type
BooleanControl.Type 类的实例标识一种 boolean 控件。

class

CompoundControl
CompoundControl（如图形均衡器）控制两个或多个相关属性，每个属性本身都表示为 Control。

static class

CompoundControl.Type
CompoundControl.Type 内部类的实例标识一种组合控件。

class

Control
Line 常常具有一个控件（如 gain 和 pan）集合，这些控件都会影响通过行传递的音频信号。

static class

Control.Type
Type 类的实例表示控件的类型。

static class

DataLine.Info
除了继承自其超类的类信息之外，DataLine.Info 还提供特定于数据行的其他信息。

class

EnumControl
EnumControl 提供对一组截然不同的可能值的控制，每个值都由一个对象表示。

static class

EnumControl.Type
EnumControl.Type 内部类的实例标识了某种枚举控件。

class

FloatControl
FloatControl 对象提供对浮点值范围的控制。

static class

FloatControl.Type
FloatControl.Type 内部类的实例标识了某种 float 控件。

static class

Line.Info
Line.Info 对象包含关于行的信息。

class

LineEvent
LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。

static class

LineEvent.Type
该 LineEvent.Type 内部类标识行上所发生事件的种类。

class

LineUnavailableException
LineUnavailableException 是指示某一行因为不可用而无法打开的异常。

static class

Mixer.Info
Mixer.Info 类表示关于音频混频器的信息，包括产品的名称、版本和供应商，以及文本描述。

static class

Port.Info
该 Port.Info 类扩展了具有其他特定于端口的信息的 Line.Info，这些信息包括端口的名称以及该端口是否是其混频器的源或目标。

class

ReverbType
ReverbType 类提供用于访问应用于音频信号的各种回响设置的方法。

class

UnsupportedAudioFileException
UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

返回 Object 的 javax.sound.sampled 中的方法

Object

AudioFileFormat.getProperty(String key)
获得键指定的属性值。

Object

AudioFormat.getProperty(String key)
获取键指定的属性值。

Object

EnumControl.getValue()
获得此控件的当前值。

Object[]

EnumControl.getValues()
返回此控件的可能值的集合。

返回变量类型为 Object 的类型的 javax.sound.sampled 中的方法

Map<String,Object>

AudioFileFormat.properties()
获得不可修改的属性映射。

Map<String,Object>

AudioFormat.properties()
获取不可修改的属性映射。

参数类型为 Object 的 javax.sound.sampled 中的方法

boolean

AudioFileFormat.Type.equals(Object obj)
终止 equals 方法

boolean

AudioFormat.Encoding.equals(Object obj)
终止 equals 方法

boolean

Control.Type.equals(Object obj)
终止 equals 方法

boolean

LineEvent.Type.equals(Object obj)
指示指定对象是否等于此事件类型，如果对象是相同的，则返回 true。

boolean

Mixer.Info.equals(Object obj)
指示两个 info 对象是否相等；如果相等，则返回 true。

boolean

Port.Info.equals(Object obj)
终止 equals 方法

boolean

ReverbType.equals(Object obj)
指示指定对象是否等于此回响类型，如果对象相同，则返回 true。

void

EnumControl.setValue(Object value)
设置控件的当前值。

参数类型为 Object 的 javax.sound.sampled 中的构造方法

EnumControl(EnumControl.Type type, Object[] values, Object value)
构造一个具有给定参数的新枚举控件对象。

EnumControl(EnumControl.Type type, Object[] values, Object value)
构造一个具有给定参数的新枚举控件对象。

类型变量类型为 Object 的 javax.sound.sampled 中的构造方法参数

AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。

AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
构造具有给定参数的 AudioFormat。

javax.sound.sampled.spi 中 Object 的使用

javax.sound.sampled.spi 中 Object 的子类

class

AudioFileReader
音频文件读取服务的提供者。

class

AudioFileWriter
音频文件写入服务的提供者。

class

FormatConversionProvider
格式转换提供者提供从一种或多种输入格式到一种或多种输出格式的格式转换服务。

class

MixerProvider
特定的混频器类型的提供者和工厂。

javax.sql 中 Object 的使用

javax.sql 中 Object 的子类

class

ConnectionEvent
提供关于连接相关事件的源信息的 Event 对象。

class

RowSetEvent
RowSet 对象发生事件时生成的 Event 对象。

class

StatementEvent
StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。

返回 Object 的 javax.sql 中的方法

Object[]

RowSetInternal.getParams()
获取已为此 RowSet 对象的命令设置的参数。

参数类型为 Object 的 javax.sql 中的方法

void

RowSet.setObject(int parameterIndex, Object x)
使用 Java Object 设置此 RowSet 对象命令中的指定参数。

void

RowSet.setObject(int parameterIndex, Object x, int targetSqlType)
使用 Java Object 设置此 RowSet 对象命令中的指定参数。

void

RowSet.setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)
使用给定 Java Object 设置此 RowSet 对象命令中的指定参数。

void

RowSet.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

RowSet.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

RowSet.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

javax.sql.rowset 中 Object 的使用

javax.sql.rowset 中 Object 的子类

class

BaseRowSet
提供一个具有基本功能的 RowSet 对象的抽象类。

class

RowSetMetaDataImpl
为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。

class

RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

返回 Object 的 javax.sql.rowset 中的方法

Object[]

BaseRowSet.getParams()
获取一个数组，其中包含为此 RowSet 对象命令设置的参数值（包括 Object 和基本类型），如果尚未设置任何参数，则抛出 SQLException 对象。

参数类型为 Object 的 javax.sql.rowset 中的方法

boolean

Predicate.evaluate(Object value, int column)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter() 方法设置的过滤标准（或标准，如果存在多个约束）中。

boolean

Predicate.evaluate(Object value, String columnName)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter 方法设置的过滤标准中。

void

BaseRowSet.setObject(int parameterIndex, Object x)
将指定参数设置为 Java 编程语言中的 Object。

void

BaseRowSet.setObject(int parameterIndex, Object x, int targetSqlType)
使用给定 Object 值设置指定参数的值。

void

BaseRowSet.setObject(int parameterIndex, Object x, int targetSqlType, int scale)
将指定参数设置为 Java 编程语言中的 Object。

void

BaseRowSet.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

BaseRowSet.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

BaseRowSet.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

javax.sql.rowset.serial 中 Object 的使用

javax.sql.rowset.serial 中 Object 的子类

class

SerialArray
序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。

class

SerialBlob
SQL BLOB 值在 Java 编程语言中的序列化映射关系。

class

SerialClob
SQL CLOB 值在 Java 编程语言中的序列化映射关系。

class

SerialDatalink
SQL DATALINK 值在 Java 编程语言中的序列化映射关系。

class

SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

class

SerialJavaObject
SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。

class

SerialRef
Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。

class

SerialStruct
SQL 结构类型在 Java 编程语言中的序列化映射关系。

class

SQLInputImpl
用于自定义映射用户定义类型 (UDT) 的输入流。

class

SQLOutputImpl
用于将自定义映射的用户定义类型 (UDT) 的属性写回数据库的输出流。

返回 Object 的 javax.sql.rowset.serial 中的方法

Object

SerialArray.getArray()
返回一个新数组，它是此 SerialArray 对象的副本。

Object

SerialArray.getArray(long index, int count)
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。

Object

SerialArray.getArray(long index, int count, Map<String,Class<?>> map)
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。

Object

SerialArray.getArray(Map<String,Class<?>> map)
返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。

Object[]

SerialStruct.getAttributes()
获取 Object 值的数组，该数组包含此 SerialStruct 对象所表示的 SQL 结构类型的属性。

Object[]

SerialStruct.getAttributes(Map<String,Class<?>> map)
获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。

Object

SerialJavaObject.getObject()
返回一个 Object，它是此 SerialJavaObject 对象的副本。

Object

SerialRef.getObject()
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。

Object

SerialRef.getObject(Map<String,Class<?>> map)
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。

Object

SQLInputImpl.readObject()
以 Java 编程语言中 Object 的形式获取此 SQLInputImpl 对象的头部值。

参数类型为 Object 的 javax.sql.rowset.serial 中的方法

void

SerialRef.setObject(Object obj)
将此 SerialRef 对象引用的 SQL 结构类型设置为给定的 Object 对象。

参数类型为 Object 的 javax.sql.rowset.serial 中的构造方法

SerialJavaObject(Object obj)
SerialJavaObject 帮助器类的构造方法。

SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。

javax.sql.rowset.spi 中 Object 的使用

javax.sql.rowset.spi 中 Object 的子类

class

SyncFactory
该服务提供者接口 (SPI) 机制可以生成由非连接 RowSet 对象使用的 SyncProvider 实例。

class

SyncFactoryException
指示 SyncFactory 机制发生的错误。

class

SyncProvider
为非连接 RowSet 对象提供 reader/writer 功能的同步机制。

class

SyncProviderException
指示 SyncProvider 机制发生的错误。

返回 Object 的 javax.sql.rowset.spi 中的方法

Object

SyncResolver.getConflictValue(int index)
获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。

Object

SyncResolver.getConflictValue(String columnName)
获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。

参数类型为 Object 的 javax.sql.rowset.spi 中的方法

void

SyncResolver.setResolvedValue(int index, Object obj)
将 obj 设置为将同步的 RowSet 对象当前行中第 index 列的值。

void

SyncResolver.setResolvedValue(String columnName, Object obj)
将 obj 设置为将同步的 RowSet 对象当前行中列 columnName 的值。

javax.swing 中 Object 的使用

javax.swing 中 Object 的子类

class

AbstractAction
此类提供 JFC Action 接口的默认实现。

class

AbstractButton
定义按钮和菜单项的一般行为。

protected  class

AbstractButton.AccessibleAbstractButton
此类实现对 AbstractButton 类的可访问性支持。

protected  class

AbstractButton.ButtonChangeListener
将 ChangeListener 扩展为可序列化的。

class

AbstractCellEditor

class

AbstractListModel
该数据模型的抽象定义提供一个带内容的 List。

class

AbstractSpinnerModel
此类提供 SpinnerModel 接口的 ChangeListener 部分，该接口应该适用于最具体的 SpinnerModel 实现。

class

ActionMap
ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。

class

BorderFactory
提供标准 Border 对象的工厂类。

class

Box
使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。

protected  class

Box.AccessibleBox
此类实现 Box 类的可访问性支持。

static class

Box.Filler
参与布局但没有视图的轻量级组件的实现。

protected  class

Box.Filler.AccessibleBoxFiller
此类实现 Box.Filler 类的可访问性支持。

class

BoxLayout
允许垂直或水平布置多个组件的布局管理器。

class

ButtonGroup
此类用于为一组按钮创建一个多斥（multiple-exclusion）作用域。

class

CellRendererPane
此类被插入在单元格渲染器与使用它们的组件之间。

protected  class

CellRendererPane.AccessibleCellRendererPane
此类实现 Panel 类的可访问性支持。

class

ComponentInputMap
ComponentInputMap 是与特定 JComponent 相关联的 InputMap。

class

DebugGraphics
支持图形调试的图形子类。

class

DefaultBoundedRangeModel
BoundedRangeModel 的一般实现。

class

DefaultButtonModel
Button 组件的数据模型的默认实现。

class

DefaultCellEditor
表单元格和树单元格的默认编辑器。

protected  class

DefaultCellEditor.EditorDelegate
受保护的 (protected) EditorDelegate 类。

class

DefaultComboBoxModel
组合框的默认模型。

class

DefaultDesktopManager
此类是 DesktopManager 的实现。

class

DefaultFocusManager
此类已被废弃，用 1.4 focus API 取代。

class

DefaultListCellRenderer
呈现列表中的一个项。

static class

DefaultListCellRenderer.UIResource
实现 UIResource 的 DefaultListCellRenderer 的子类。

class

DefaultListModel
此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。

class

DefaultListSelectionModel
列表选择的默认数据模型。

class

DefaultRowSorter<M,I>
RowSorter 的一个实现，它围绕基于网格的数据模型提供排序和过滤操作。

protected static class

DefaultRowSorter.ModelWrapper<M,I>
DefaultRowSorter.ModelWrapper 负责提供由 DefaultRowSorter 进行排序的数据。

class

DefaultSingleSelectionModel
SingleSelectionModel 的一般实现。

class

FocusManager
从 1.4 focus API 开始，此类已被废弃。

class

GrayFilter
一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。

class

GroupLayout
GroupLayout 是一个 LayoutManager，它将组件按层次分组，以决定它们在 Container 中的位置。

class

GroupLayout.Group
Group 为 GroupLayout 所支持的以下两种操作提供基础：一个接一个地布置组件（SequentialGroup）或对齐组件（ParallelGroup）。

class

GroupLayout.ParallelGroup
一个 Group，它对齐其子元素并确定其大小。

class

GroupLayout.SequentialGroup
一个 Group，它按顺序一个接一个地确定其元素的位置和大小。

class

ImageIcon
一个 Icon 接口的实现，它根据 Image 绘制 Icon。

protected  class

ImageIcon.AccessibleImageIcon
此类实现 ImageIcon 类的可访问性支持。

class

InputMap
InputMap 提供输入事件（目前只使用 KeyStroke）和 Object 之间的绑定。

class

InputVerifier
此类的用途是通过带文本字段的 GUI 帮助客户端支持流畅的焦点导航。

class

InternalFrameFocusTraversalPolicy
该 FocusTraversalPolicy 可以有选择地提供确定 JInternalFrame 初始 Component 的算法。

class

JApplet
java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。

protected  class

JApplet.AccessibleJApplet
此类实现对 JApplet 类的可访问性支持。

class

JButton
"push" 按钮的实现。

protected  class

JButton.AccessibleJButton
此类实现对 JButton 类的可访问性支持。

class

JCheckBox
复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。

protected  class

JCheckBox.AccessibleJCheckBox
此类实现对 JCheckBox 类的可访问性支持。

class

JCheckBoxMenuItem
可以被选定或取消选定的菜单项。

protected  class

JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
此类实现对 JCheckBoxMenuItem 类的可访问性支持。

class

JColorChooser
JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。

protected  class

JColorChooser.AccessibleJColorChooser
此类实现对 JColorChooser 类的可访问性支持。

class

JComboBox
将按钮或可编辑字段与下拉列表组合的组件。

protected  class

JComboBox.AccessibleJComboBox
此类实现 JComboBox 类的可访问性支持。

class

JComponent
该类是除顶层容器外所有 Swing 组件的基类。

class

JComponent.AccessibleJComponent
用于为可访问性提供默认支持的 JComponent 内部类。

protected  class

JComponent.AccessibleJComponent.AccessibleContainerHandler
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

protected  class

JComponent.AccessibleJComponent.AccessibleFocusHandler
发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

class

JDesktopPane
用于创建多文档界面或虚拟桌面的容器。

protected  class

JDesktopPane.AccessibleJDesktopPane
此类实现对 JDesktopPane 类的可访问性支持。

class

JDialog
创建对话框窗口的主要类。

protected  class

JDialog.AccessibleJDialog
此类实现对 JDialog 类的可访问性支持。

class

JEditorPane
可编辑各种内容的文本组件。

protected  class

JEditorPane.AccessibleJEditorPane
此类实现对 JEditorPane 类的可访问性支持。

protected  class

JEditorPane.AccessibleJEditorPaneHTML
此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。

protected  class

JEditorPane.JEditorPaneAccessibleHypertextSupport
AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。

class

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

class

JFileChooser
JFileChooser 为用户选择文件提供了一种简单的机制。

protected  class

JFileChooser.AccessibleJFileChooser
此类实现对 JFileChooser 类的可访问性支持。

class

JFormattedTextField
JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。

static class

JFormattedTextField.AbstractFormatter
JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。

static class

JFormattedTextField.AbstractFormatterFactory
JFormattedTextField 使用的 AbstractFormatterFactory 实例，用来获得 AbstractFormatter 实例，依次使用该实例格式化各个值。

class

JFrame
java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。

protected  class

JFrame.AccessibleJFrame
此类实现对 JFrame 类的可访问性支持。

class

JInternalFrame
提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。

protected  class

JInternalFrame.AccessibleJInternalFrame
此类实现对 JInternalFrame 类的可访问性支持。

static class

JInternalFrame.JDesktopIcon
此组件表示 JInternalFrame 的图标化版本。

protected  class

JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。

class

JLabel
用于短文本字符串或图像或二者的显示区。

protected  class

JLabel.AccessibleJLabel
该类用于获得此对象的可访问性职责。

class

JLayeredPane
JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。

protected  class

JLayeredPane.AccessibleJLayeredPane
此类实现对 JLayeredPane 类的可访问性支持。

class

JList
显示对象列表并且允许用户选择一个或多个项的组件。

protected  class

JList.AccessibleJList
此类实现 JList 类的可访问性支持。

protected  class

JList.AccessibleJList.AccessibleJListChild
此类实现供 List 子级使用的可访问性支持。

static class

JList.DropLocation
TransferHandler.DropLocation 的一个子类，表示 JList 的放置位置 (drop location)。

class

JMenu
菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。

protected  class

JMenu.AccessibleJMenu
此类实现 JMenu 类的可访问性支持。

protected  class

JMenu.WinListener
观察弹出窗口关闭的侦听器类。

class

JMenuBar
菜单栏的实现。

protected  class

JMenuBar.AccessibleJMenuBar
此类实现 JMenuBar 类的可访问性支持。

class

JMenuItem
菜单中的项的实现。

protected  class

JMenuItem.AccessibleJMenuItem
此类实现 JMenuItem 类的可访问性支持。

class

JOptionPane
JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。

protected  class

JOptionPane.AccessibleJOptionPane
此类实现对 JOptionPane 类的可访问性支持。

class

JPanel
JPanel 是一般轻量级容器。

protected  class

JPanel.AccessibleJPanel
此类实现对 JPanel 类的可访问性支持。

class

JPasswordField
JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。

protected  class

JPasswordField.AccessibleJPasswordField
此类实现对 JPasswordField 类的可访问性支持。

class

JPopupMenu
弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。

protected  class

JPopupMenu.AccessibleJPopupMenu
此类实现 JPopupMenu 类的可访问性支持。

static class

JPopupMenu.Separator
弹出与菜单有关的分隔符。

class

JProgressBar
以可视化形式显示某些任务进度的组件。

protected  class

JProgressBar.AccessibleJProgressBar
此类实现 JProgressBar 类的可访问性支持。

class

JRadioButton
实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。

protected  class

JRadioButton.AccessibleJRadioButton
此类实现对 JRadioButton 类的可访问性支持。

class

JRadioButtonMenuItem
一个单选按钮菜单项的实现。

protected  class

JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
此类实现对 JRadioButtonMenuItem 类的可访问性支持。

class

JRootPane
该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。

protected  class

JRootPane.AccessibleJRootPane
此类实现对 JRootPane 类的可访问性支持。

protected  class

JRootPane.RootLayout
该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。

class

JScrollBar
滚动条的实现。

protected  class

JScrollBar.AccessibleJScrollBar
此类实现 JScrollBar 类的可访问性支持。

class

JScrollPane
提供轻量级组件的 scrollable 视图。

protected  class

JScrollPane.AccessibleJScrollPane
此类实现 JScrollPane 类的可访问性支持。

protected  class

JScrollPane.ScrollBar
默认情况下，JScrollPane 创建的滚动条为此类的实例。

class

JSeparator
JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。

protected  class

JSeparator.AccessibleJSeparator
此类实现 JSeparator 类的可访问性支持。

class

JSlider
一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。

protected  class

JSlider.AccessibleJSlider
此类实现 JSlider 类的可访问性支持。

class

JSpinner
让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。

protected  class

JSpinner.AccessibleJSpinner
AccessibleJSpinner 实现 JSpinner 类的可访问性支持。

static class

JSpinner.DateEditor
其模型为 SpinnerDateModel 的 JSpinner 编辑器。

static class

JSpinner.DefaultEditor
一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。

static class

JSpinner.ListEditor
其模型为 SpinnerListModel 的 JSpinner 编辑器。

static class

JSpinner.NumberEditor
其模型为 SpinnerNumberModel 的 JSpinner 编辑器。

class

JSplitPane
JSplitPane 用于分隔两个（只能两个）Component。

protected  class

JSplitPane.AccessibleJSplitPane
此类实现 JSplitPane 类的可访问性支持。

class

JTabbedPane
一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。

protected  class

JTabbedPane.AccessibleJTabbedPane
此类实现对 JTabbedPane 类的可访问性支持。

protected  class

JTabbedPane.ModelListener
将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。

class

JTable
JTable 用来显示和编辑常规二维单元表。

protected  class

JTable.AccessibleJTable
此类实现对 JTable 类的可访问性支持。

protected  class

JTable.AccessibleJTable.AccessibleJTableCell
此类提供了适用于表单元格的 Java Accessibility API 实现。

protected  class

JTable.AccessibleJTable.AccessibleJTableModelChange

static class

JTable.DropLocation
TransferHandler.DropLocation 的一个子类，表示 JTable 的放置位置 (drop location)。

class

JTextArea
JTextArea 是一个显示纯文本的多行区域。

protected  class

JTextArea.AccessibleJTextArea
此类实现对 JTextArea 类的可访问性支持。

class

JTextField
JTextField 是一个轻量级组件，它允许编辑单行文本。

protected  class

JTextField.AccessibleJTextField
此类实现对 JTextField 类的可访问性支持。

class

JTextPane
可以用以图形方式表示的属性来标记的文本组件。

class

JToggleButton
具有两个状态的（two-state）按钮的实现。

protected  class

JToggleButton.AccessibleJToggleButton
此类实现对 JToggleButton 类的可访问性支持。

static class

JToggleButton.ToggleButtonModel
ToggleButton 模型。

class

JToolBar
JToolBar 提供了一个用来显示常用的 Action 或控件的组件。

protected  class

JToolBar.AccessibleJToolBar
此类实现对 JToolBar 类的可访问性支持。

static class

JToolBar.Separator
一个特定于工具栏的分隔符。

class

JToolTip
用来显示 Component 的“提示”。

protected  class

JToolTip.AccessibleJToolTip
此类实现对 JToolTip 类的可访问性支持。

class

JTree
将分层数据集显示为轮廓的控件。

protected  class

JTree.AccessibleJTree
此类实现 JTree 类的可访问性支持。

protected  class

JTree.AccessibleJTree.AccessibleJTreeNode
此类实现 JTree 子类的可访问性支持。

static class

JTree.DropLocation
TransferHandler.DropLocation 的一个子类，表示 JTree 的放置位置 (drop location)。

static class

JTree.DynamicUtilTreeNode
DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。

protected static class

JTree.EmptySelectionModel
EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。

protected  class

JTree.TreeModelHandler
在移除或更改节点时，监听模型并相应地更新 expandedState。

protected  class

JTree.TreeSelectionRedirector
使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。

class

JViewport
用于查看底层信息的“视口”或“观察孔”。

protected  class

JViewport.AccessibleJViewport
此类实现对 JViewport 类的可访问性支持。

protected  class

JViewport.ViewListener
视图的侦听器。

class

JWindow
JWindow 是一个容器，可以显示在用户桌面上的任何位置。

protected  class

JWindow.AccessibleJWindow
此类实现对 JWindow 类的可访问性支持。

class

KeyStroke
表示键盘或等效输入设置上的键操作的 KeyStroke。

class

LayoutFocusTraversalPolicy
根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。

class

LayoutStyle
LayoutStyle 提供有关如何确定组件位置的信息。

class

LookAndFeel
顾名思义，LookAndFeel 封装了一个外观。

class

MenuSelectionManager
MenuSelectionManager 拥有菜单层次结构中的选项。

class

OverlayLayout
要在彼此顶部安排组件的布局管理器。

class

Popup
Popup 用于向用户显示 Component，它通常位于特定包含层次结构中所有其他 Component 的顶部。

class

PopupFactory
顾名思义，PopupFactory 用于获取 Popup 的实例。

class

ProgressMonitor
监视某个操作的进度的类。

protected  class

ProgressMonitor.AccessibleProgressMonitor
AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

class

ProgressMonitorInputStream
监视读取某些 InputStream 的进度。

class

RepaintManager
此类管理重绘请求，以最大限度地降低重绘次数。

class

RowFilter<M,I>
RowFilter 用于从模型中过滤条目，使得这些条目不会在视图中显示。

static class

RowFilter.Entry<M,I>
一个传递给 RowFilter 实例的 Entry 对象，允许过滤器获取该条目的数据的值，以确定是否应该显示该条目。

class

RowSorter<M>
RowSorter 提供排序和过滤的基础。

static class

RowSorter.SortKey
SortKey 描述特定列的排序顺序。

class

ScrollPaneLayout
JScrollPane 使用的布局管理器。

static class

ScrollPaneLayout.UIResource
ScrollPaneLayout 的 UI 资源版本。

class

SizeRequirements
为方便布局管理器，计算组件的有关大小和位置信息。

class

SizeSequence
一个 SizeSequence 对象，它有效地维护一个包含大小和相应位置的顺序列表。

class

SortingFocusTraversalPolicy
通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。

class

SpinnerDateModel
Date 序列的一个 SpinnerModel。

class

SpinnerListModel
其值由数组或 List 定义的 SpinnerModel 的简单实现。

class

SpinnerNumberModel
用于数字序列的 SpinnerModel。

class

Spring
该 Spring 类的实例将存储以下三个表示其行为特征的属性：minimum、preferred 和 maximum 值。

class

SpringLayout
SpringLayout 根据一组约束布置其相关容器的子组件。

static class

SpringLayout.Constraints
Constraints 对象将管理组件大小和位置更改方式的约束存储在 SpringLayout 控制的容器中。

class

SwingUtilities
Swing 实用方法的集合。

class

SwingWorker<T,V>
在专用线程中执行长时间 GUI 交互任务的抽象类。

class

ToolTipManager
管理系统中的所有 ToolTips。

protected  class

ToolTipManager.insideTimerAction

protected  class

ToolTipManager.outsideTimerAction

protected  class

ToolTipManager.stillInsideTimerAction

class

TransferHandler
此类用于处理往返于 Swing 组件的 Transferable 的传输。

static class

TransferHandler.DropLocation
表示放置的数据 (dropped data) 应该插入的位置。

static class

TransferHandler.TransferSupport
此类封装剪贴板或拖放传输的所有相关详细信息，并且还允许自定义拖放过程的各方面。

class

UIDefaults
Swing 组件的默认值表。

static class

UIDefaults.LazyInputMap
LazyInputMap 将在其 createValue 方法中创建一个 InputMap。

static class

UIDefaults.ProxyLazyValue
此类提供一个可用于延迟加载要创建实例类的 LazyValue 的实现。

class

UIManager
UIManager 管理当前外观、可用外观集合、外观更改时被通知的 PropertyChangeListeners、外观默认值以及获取各种默认值的便捷方法。

static class

UIManager.LookAndFeelInfo
为了配置菜单或为了初始应用程序设置而提供关于已安装的 LookAndFeel 的少量信息。

class

UnsupportedLookAndFeelException
指示在用户系统上不存在请求的外观管理类的异常。

class

ViewportLayout
JViewport 的默认布局管理器。

声明为 Object 的 javax.swing 中的字段

protected  Object

JTree.DynamicUtilTreeNode.childValue
用于创建子节点的值。

protected  Object

JOptionPane.initialSelectionValue
要在 selectionValues 中选择的初始值。

protected  Object

JOptionPane.initialValue
应该在 options 中最初选择的值。

protected  Object

JOptionPane.inputValue
用户已输入的值。

protected  Object

JOptionPane.message
要显示的消息。

protected  Object[]

JOptionPane.options
要向用户显示的选项。

protected  Object

JComboBox.selectedItemReminder
此受保护字段是特定于实现的。

protected  Object[]

JOptionPane.selectionValues
用户可以从中选择值的数组。

static Object

JOptionPane.UNINITIALIZED_VALUE
指示用户尚未选择值。

protected  Object

JOptionPane.value
当前选择的值，该值将为有效选项或者 UNINITIALIZED_VALUE 或 null。

protected  Object

DefaultCellEditor.EditorDelegate.value
此单元格的值。

返回 Object 的 javax.swing 中的方法

Object[]

ActionMap.allKeys()
返回在此 ActionMap 及其父级中定义的键所组成的数组。

protected  Object

JFormattedTextField.AbstractFormatter.clone()
复制 AbstractFormatter。

protected  Object

AbstractAction.clone()
复制抽象操作。

Object

DefaultListSelectionModel.clone()
返回此选择模型的具有相同选择的副本。

Object

UIDefaults.LazyValue.createValue(UIDefaults table)
创建从 UIDefaults 表中检索的实际值。

Object

UIDefaults.ActiveValue.createValue(UIDefaults table)
创建从 UIDefaults 表中检索的值。

Object

UIDefaults.ProxyLazyValue.createValue(UIDefaults table)
创建从 UIDefaults 表中检索的值。

Object

UIDefaults.LazyInputMap.createValue(UIDefaults table)
使用传入的绑定创建一个 InputMap。

Object

DefaultListModel.elementAt(int index)
返回指定索引处的组件。

Object

DefaultListModel.firstElement()
返回此列表中的第一个组件。

Object

DefaultListModel.get(int index)
返回列表中指定位置处的元素。

Object

InputMap.get(KeyStroke keyStroke)
返回 keyStroke 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 InputMap。

Object

UIDefaults.get(Object key)
返回键的值。

static Object

UIManager.get(Object key)
从默认值中返回一个对象。

Object

UIDefaults.get(Object key, Locale l)
返回与给定语言环境相关的那些键的值。

static Object

UIManager.get(Object key, Locale l)
从适合给定语言环境的默认值中返回一个对象。

Object

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionAnchor(int i)
返回表示适合于该链接的链接锚点的对象。

Object

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionObject(int i)
返回表示该链接的 URL 对象。

Object

DefaultCellEditor.getCellEditorValue()
将消息从 CellEditor 转发到 delegate。

Object

DefaultCellEditor.EditorDelegate.getCellEditorValue()
返回此单元格的值。

Object

CellEditor.getCellEditorValue()
返回编辑器中包含的值。

Object

JComponent.getClientProperty(Object key)
返回具有指定键的属性的值。

static Object

LookAndFeel.getDesktopPropertyValue(String systemPropertyName, Object fallbackValue)
通过调用 Toolkit.getDefaultToolkit().getDesktopProperty() 返回指定系统桌面属性的值。

Object

DefaultListModel.getElementAt(int index)
返回指定索引处的组件。

Object

DefaultComboBoxModel.getElementAt(int index)

Object

ListModel.getElementAt(int index)
返回指定索引处的值。

Object

JOptionPane.getInitialSelectionValue()
返回（根据最初选择）向用户显示的输入值。

Object

JOptionPane.getInitialValue()
返回初始值。

Object

JOptionPane.getInputValue()
如果 wantsInput 为 true，则返回用户已输入的值。

Object

ComboBoxEditor.getItem()
返回已编辑项。

Object

JComboBox.getItemAt(int index)
返回指定索引处的列表项。

Object[]

AbstractAction.getKeys()
返回 Object 的数组，这些对象是一些已经为其设置此 AbstractAction 值的键，如果没有已经设置该值的键，则返回 null。

Object

JTree.getLastSelectedPathComponent()
返回当前选择的第一个节点中的最后一个路径组件。

Object

JOptionPane.getMessage()
返回此窗格显示的消息对象。

Object

JSpinner.getNextValue()
返回序列中由 getValue() 所返回的对象之后的对象。

Object

SpinnerDateModel.getNextValue()
返回序列中的下一个 Date，如果下一个日期在 end 之后，则返回 null。

Object

SpinnerListModel.getNextValue()
返回基础序列的下一个合法值，如果值已经是最后一个元素，则返回 null。

Object

SpinnerModel.getNextValue()
返回该序列中出现在 getValue() 返回的对象之后的对象。

Object

SpinnerNumberModel.getNextValue()
返回该序列中的下一个数字。

Object[]

JOptionPane.getOptions()
返回用户可以作出的选择。

Object

JSpinner.getPreviousValue()
返回序列中由 getValue() 所返回对象之前的对象。

Object

SpinnerDateModel.getPreviousValue()
返回序列中上一个 Date，如果上一个日期是在 start 之前，则返回 null。

Object

SpinnerListModel.getPreviousValue()
返回该基础序列的前一个元素，如果值已经是第一个元素，则返回 null。

Object

SpinnerModel.getPreviousValue()
返回该序列中出现在 getValue() 返回的对象之前的对象。

Object

SpinnerNumberModel.getPreviousValue()
返回该序列中的上一个数字。

Object

JList.getPrototypeCellValue()
返回“原型的”单元值，即用于计算单元的固定宽度和高度的值。

Object

JComboBox.getPrototypeDisplayValue()
返回“原型显示”值，即用于计算显示高度和宽度的 Object。

Object

DefaultComboBoxModel.getSelectedItem()

Object

ComboBoxModel.getSelectedItem()
返回选择的项

Object

JComboBox.getSelectedItem()
返回当前所选项。

Object[]

JComboBox.getSelectedObjects()
返回包含所选项的数组。

Object[]

DefaultButtonModel.getSelectedObjects()
重写以返回 null。

Object[]

JCheckBoxMenuItem.getSelectedObjects()
返回包含复选框菜单项标签的数组 (length 1)，如果没有选定复选框，则返回 null。

Object[]

AbstractButton.getSelectedObjects()
返回包含标签的数组（长度为 1），如果没有选择按钮，则返回 null。

Object

JList.getSelectedValue()
返回最小的选择单元索引的值；只选择了列表中单个项时，返回所选值。

Object[]

JList.getSelectedValues()
返回所有选择值的数组，根据其列表中的索引顺序按升序排序。

Object[]

JOptionPane.getSelectionValues()
返回输入选择值。

Object

JFormattedTextField.getValue()
返回最后一个有效值。

Object

JOptionPane.getValue()
返回用户所选值。

Object

JSpinner.getValue()
返回模型的当前值，通常此值是 editor 所显示的值。

Object

SpinnerDateModel.getValue()
返回此 Date 序列中的当前元素。

Object

SpinnerListModel.getValue()
返回该序列的当前元素。

Object

SpinnerModel.getValue()
该序列的当前元素。

Object

SpinnerNumberModel.getValue()
返回该序列的当前元素的值。

abstract  Object

RowFilter.Entry.getValue(int index)
返回指定索引处的值。

Object

AbstractAction.getValue(String key)
获得与指定键关联的 Object。

Object

Action.getValue(String key)
使用关联的键获取此对象的一个属性。

abstract  Object

DefaultRowSorter.ModelWrapper.getValueAt(int row, int column)
返回指定索引处的值。

Object

JTable.getValueAt(int row, int column)
返回 row 和 column 位置的单元格值。

Object[]

ActionMap.keys()
返回此 ActionMap 中绑定的 Action 名称。

Object

DefaultListModel.lastElement()
返回列表的最后一个组件。

static Object

LookAndFeel.makeIcon(Class<?> baseClass, String gifFile)
创建并返回一个加载图像的 UIDefault.LazyValue。

Object

UIDefaults.put(Object key, Object value)
将 key 值设置为所有语言环境的 value。

static Object

UIManager.put(Object key, Object value)
在开发人员默认值中存储一个对象。

Object

DefaultListModel.remove(int index)
移除此列表中指定位置处的元素。

Object

DefaultListModel.set(int index, Object element)
使用指定元素替换此列表中指定位置上的元素。

static Object

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。

static Object

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。

abstract  Object

JFormattedTextField.AbstractFormatter.stringToValue(String text)
分析 text，返回任意 Object。

Object[]

DefaultListModel.toArray()
以正确顺序返回包含此列表中所有元素的数组。

参数类型为 Object 的 javax.swing 中的方法

void

JTabbedPane.add(Component component, Object constraints)
将一个 component 添加到选项卡窗格中。

void

JTabbedPane.add(Component component, Object constraints, int index)
在指定的选项卡索引位置添加一个 component。

void

DefaultListModel.add(int index, Object element)
在此列表的指定位置处插入指定元素。

void

DefaultListModel.addElement(Object obj)
将指定组件添加到此类表的末尾。

void

DefaultComboBoxModel.addElement(Object anObject)

void

MutableComboBoxModel.addElement(Object obj)
在模型的末尾添加项。

protected  void

JDesktopPane.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上。

protected  void

JApplet.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。

protected  void

JWindow.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。

protected  void

JViewport.addImpl(Component child, Object constraints, int index)
设置 JViewport 的轻量子对象，可以为 null。

protected  void

CellRendererPane.addImpl(Component x, Object constraints, int index)
如果指定组件已经是此组件的子组件，则不必再操心去做任何事，堆栈顺序对于单元格渲染器组件而言无关紧要（CellRendererPane 不管怎样都不进行绘制）。

protected  void

JSplitPane.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此分隔窗格。

protected  void

JToolBar.addImpl(Component comp, Object constraints, int index)
在添加 JButton 时，它最初被设置为 disabled。

protected  void

JDialog.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。

protected  void

AbstractButton.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上，有关此方法的完整描述，请参阅 Container.addImpl(Component, Object, int)。

protected  void

JInternalFrame.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。

protected  void

JLayeredPane.addImpl(Component comp, Object constraints, int index)

protected  void

JRootPane.addImpl(Component comp, Object constraints, int index)
重写以便将玻璃组件的位置强行设置成零位子级。

protected  void

JFrame.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。

void

JComboBox.addItem(Object anObject)
为项列表添加项。

void

GroupLayout.addLayoutComponent(Component component, Object constraints)
已将 Component 添加到父容器的通知。

void

OverlayLayout.addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。

void

SpringLayout.addLayoutComponent(Component component, Object constraints)
如果 constraints 是 SpringLayout.Constraints 的一个实例，则将该约束与指定组件相关联。

void

BoxLayout.addLayoutComponent(Component comp, Object constraints)
此类不使用。

void

JRootPane.RootLayout.addLayoutComponent(Component comp, Object constraints)

void

JComboBox.configureEditor(ComboBoxEditor anEditor, Object anItem)
利用指定项初始化编辑器。

boolean

DefaultListModel.contains(Object elem)
测试指定对象是否为此类表中的组件。

String

JTree.convertValueToText(Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
通过渲染器调用以将指定值转换为文本。

void

DefaultListModel.copyInto(Object[] anArray)
将此列表的组件复制到指定数组中。

static void

JTree.DynamicUtilTreeNode.createChildren(DefaultMutableTreeNode parent, Object children)
将 children 中的所有子节点添加到父节点。

protected static TreeModel

JTree.createTreeModel(Object value)
返回一个 TreeModel，它包装指定的对象。

boolean

RowSorter.SortKey.equals(Object o)
如果此对象与指定对象相等，则返回 true。

protected  void

AbstractListModel.fireContentsChanged(Object source, int index0, int index1)
AbstractListModel 子类必须在列表的一个或多个元素发生更改之后调用此方法。

protected  void

AbstractListModel.fireIntervalAdded(Object source, int index0, int index1)
AbstractListModel 子类必须在将一个或多个元素添加到模型中之后调用此方法。

protected  void

AbstractListModel.fireIntervalRemoved(Object source, int index0, int index1)
AbstractListModel 子类必须在从模型中移除一个或多个元素之后调用此方法。

void

SwingWorker.firePropertyChange(String propertyName, Object oldValue, Object newValue)
向所有已注册的侦听器报告绑定属性更新。

protected  void

AbstractAction.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告绑定 (bound) 属性的改变。

protected  void

JViewport.firePropertyChange(String propertyName, Object oldValue, Object newValue)
通知侦听器发生的属性更改。

protected  void

DefaultListCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

protected  void

UIDefaults.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告绑定属性更改。

protected  void

JComponent.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
支持报告约束 (constrained) 属性的更改。

Action

ActionMap.get(Object key)
返回 key 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 ActionMap。

Object

UIDefaults.get(Object key)
返回键的值。

static Object

UIManager.get(Object key)
从默认值中返回一个对象。

Object

UIDefaults.get(Object key, Locale l)
返回与给定语言环境相关的那些键的值。

static Object

UIManager.get(Object key, Locale l)
从适合给定语言环境的默认值中返回一个对象。

boolean

UIDefaults.getBoolean(Object key)
如果 key 是 boolean 值，则返回该 boolean 值，否则返回 false。

static boolean

UIManager.getBoolean(Object key)
从与键值相关的默认值中返回一个布尔变量。

boolean

UIDefaults.getBoolean(Object key, Locale l)
如果给定 Locale 的 key 值是 boolean 值，则返回该 boolean 值，否则返回 false。

static boolean

UIManager.getBoolean(Object key, Locale l)
从与键值和给定的 Locale 相关的默认值中返回一个布尔变量。

Border

UIDefaults.getBorder(Object key)
如果 key 值为一个 Border，则返回该 Border，否则返回 null。

static Border

UIManager.getBorder(Object key)
从默认值中返回一个边框。

Border

UIDefaults.getBorder(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Border，则返回该 Border，否则返回 null。

static Border

UIManager.getBorder(Object key, Locale l)
从适合给定语言环境的默认值中返回一个边框。

Object

JComponent.getClientProperty(Object key)
返回具有指定键的属性的值。

Color

UIDefaults.getColor(Object key)
如果 key 值为一个 Color，则返回它，否则返回 null。

static Color

UIManager.getColor(Object key)
从默认值返回一种颜色。

Color

UIDefaults.getColor(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Color，则返回它，否则返回 null。

static Color

UIManager.getColor(Object key, Locale l)
从适合给定语言环境的默认值中返回一种颜色。

TableColumn

JTable.getColumn(Object identifier)
返回表中列的 TableColumn 对象，当使用 equals 进行比较时，表的标识符等于 identifier。

static Object

LookAndFeel.getDesktopPropertyValue(String systemPropertyName, Object fallbackValue)
通过调用 Toolkit.getDefaultToolkit().getDesktopProperty() 返回指定系统桌面属性的值。

Dimension

UIDefaults.getDimension(Object key)
如果 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。

static Dimension

UIManager.getDimension(Object key)
从默认值中返回一个维数。

Dimension

UIDefaults.getDimension(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。

static Dimension

UIManager.getDimension(Object key, Locale l)
从适合给定语言环境的默认值中返回一个维数。

Font

UIDefaults.getFont(Object key)
如果 key 值为一个 Font，则返回该 Font，否则返回 null。

static Font

UIManager.getFont(Object key)
从默认值返回一种字体。

Font

UIDefaults.getFont(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Font，则返回它，否则返回 null。

static Font

UIManager.getFont(Object key, Locale l)
从适合给定语言环境的默认值中返回一种字体。

Icon

UIDefaults.getIcon(Object key)
如果 key 值为一个 Icon，则返回该 Icon，否则返回 null。

static Icon

UIManager.getIcon(Object key)
从默认值中返回一个 Icon。

Icon

UIDefaults.getIcon(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Icon，则返回该 Icon，否则返回 null。

static Icon

UIManager.getIcon(Object key, Locale l)
从适合给定语言环境的默认值中返回一个 Icon。

int

DefaultComboBoxModel.getIndexOf(Object anObject)
返回指定对象在列表中的索引位置。

Insets

UIDefaults.getInsets(Object key)
如果 key 值为一个 Insets，则返回它，否则返回 null。

static Insets

UIManager.getInsets(Object key)
从默认值中返回一个 Insets 对象。

Insets

UIDefaults.getInsets(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Insets，则返回该 Insets，否则返回 null。

static Insets

UIManager.getInsets(Object key, Locale l)
从适合给定语言环境的默认值中返回一个 Insets 对象。

int

UIDefaults.getInt(Object key)
如果 key 值为一个 Integer，则返回该整数值，否则返回 0。

static int

UIManager.getInt(Object key)
从默认值中返回一个整数。

int

UIDefaults.getInt(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Integer，则返回其整数值，否则返回 0。

static int

UIManager.getInt(Object key, Locale l)
从适合给定语言环境的默认值中返回一个整数。

Component

DefaultListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)

Component

ListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
返回已配置用于显示指定值的组件。

String

UIDefaults.getString(Object key)
如果 key 值为一个 String，则返回该 String，否则返回 null。

static String

UIManager.getString(Object key)
从默认值中返回一个字符串。

String

UIDefaults.getString(Object key, Locale l)
如果给定 Locale 的 key 值为一个 String，则返回该 String，否则返回 null。

static String

UIManager.getString(Object key, Locale l)
从适合给定语言环境的默认值中返回一个字符串。

Component

DefaultCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
实现 TableCellEditor 接口。

Component

DefaultCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
实现 TreeCellEditor 接口。

int

DefaultListModel.indexOf(Object elem)
搜索 elem 的第一次出现。

int

DefaultListModel.indexOf(Object elem, int index)
从 index 开始搜索 elem 的第一次出现。

void

DefaultListModel.insertElementAt(Object obj, int index)
将指定对象作为此列表中的组件插入到指定的 index 处。

void

DefaultComboBoxModel.insertElementAt(Object anObject, int index)

void

MutableComboBoxModel.insertElementAt(Object obj, int index)
在指定索引处添加项。

void

JComboBox.insertItemAt(Object anObject, int index)
在项列表中的给定索引处插入项。

static void

LookAndFeel.installProperty(JComponent c, String propertyName, Object propertyValue)
在组件上安装具有指定名称和值的属性的便捷方法，条件是该属性尚未由开发人员设置。

int

DefaultListModel.lastIndexOf(Object elem)
返回 elem 最后一次出现处的索引。

int

DefaultListModel.lastIndexOf(Object elem, int index)
从指定的索引处开始反向搜索 elem，并返回该对象的索引。

static void

LookAndFeel.loadKeyBindings(InputMap retMap, Object[] keys)
使用指定绑定填充 InputMap。

static ComponentInputMap

LookAndFeel.makeComponentInputMap(JComponent c, Object[] keys)
根据 keys 创建一个 ComponentInputMapUIResource。

static InputMap

LookAndFeel.makeInputMap(Object[] keys)
根据 keys 创建一个 InputMapUIResource。

static JTextComponent.KeyBinding[]

LookAndFeel.makeKeyBindings(Object[] keyBindingList)
构建一个 KeyBinding 数组的便捷方法。

static boolean

SwingUtilities.notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers)
如果启用 action（且为非 null），则调用 action 上的 actionPerformed。

protected  void

SwingWorker.publish(V... chunks)
将数据块发送给 SwingWorker.process(java.util.List) 方法。

void

ComponentInputMap.put(KeyStroke keyStroke, Object actionMapKey)
将一个 keyStroke 的绑定添加到 actionMapKey。

void

InputMap.put(KeyStroke keyStroke, Object actionMapKey)
将 keyStroke 的一个绑定添加到 actionMapKey。

void

ActionMap.put(Object key, Action action)
添加一个 key 到 action 的绑定。

Object

UIDefaults.put(Object key, Object value)
将 key 值设置为所有语言环境的 value。

static Object

UIManager.put(Object key, Object value)
在开发人员默认值中存储一个对象。

void

JComponent.putClientProperty(Object key, Object value)
向此组件添加任意的键/值“客户端属性”。

void

UIDefaults.putDefaults(Object[] keyValueList)
将所有键/值对放入数据库中，并无条件地生成一个 PropertyChangeEvent。

void

AbstractAction.putValue(String key, Object newValue)
设置与指定键关联的 Value。

void

Action.putValue(String key, Object value)
使用关联的键设置此对象的一个属性。

void

JEditorPane.read(InputStream in, Object desc)
此方法根据流进行初始化。

void

ActionMap.remove(Object key)
从此 ActionMap 中移除 key 的绑定。

boolean

DefaultListModel.removeElement(Object obj)
从此列表中移除参数的第一个（索引最小的）匹配项。

void

DefaultComboBoxModel.removeElement(Object anObject)

void

MutableComboBoxModel.removeElement(Object obj)
从模型中移除项。

void

JComboBox.removeItem(Object anObject)
从项列表中移除项。

Object

DefaultListModel.set(int index, Object element)
使用指定元素替换此列表中指定位置上的元素。

void

DefaultListModel.setElementAt(Object obj, int index)
将此列表指定 index 处的组件设置为指定的对象。

void

JOptionPane.setInitialSelectionValue(Object newValue)
设置（根据选择）最初向用户显示的输入值。

void

JOptionPane.setInitialValue(Object newInitialValue)
设置要启用的初始值，即最初显示窗格时处于焦点状态的 Component。

void

JOptionPane.setInputValue(Object newValue)
设置由用户选择或输入的输入值。

void

ComboBoxEditor.setItem(Object anObject)
设置应该编辑的项。

void

JList.setListData(Object[] listData)
根据一个对象数组构造只读 ListModel，然后对此模型调用 setModel。

void

JOptionPane.setMessage(Object newMessage)
设置选项窗格的消息对象。

void

JOptionPane.setOptions(Object[] newOptions)
设置此窗格显示的选项。

void

JList.setPrototypeCellValue(Object prototypeCellValue)
设置 prototypeCellValue 属性，然后（如果新值为非 null）计算 fixedCellWidth 和 fixedCellHeight 属性：请求单元渲染器组件提供单元渲染器的给定值（及索引 0），并使用该组件的首选大小。

void

JComboBox.setPrototypeDisplayValue(Object prototypeDisplayValue)
设置用于计算 UI 部分的显示大小的原型显示值。

void

DefaultComboBoxModel.setSelectedItem(Object anObject)
设置选择项的值。

void

ComboBoxModel.setSelectedItem(Object anItem)
设置选择项。

void

JComboBox.setSelectedItem(Object anObject)
将组合框显示区域中所选项设置为参数中的对象。

void

JList.setSelectedValue(Object anObject, boolean shouldScroll)
从列表中选择指定的对象。

void

JOptionPane.setSelectionValues(Object[] newValues)
设置窗格的输入选择值，该窗格向用户提供可以从中进行选择的项列表。

void

JFormattedTextField.setValue(Object value)
设置值，该值由从当前 AbstractFormatterFactory 获得的 AbstractFormatter 进行格式化。

void

JOptionPane.setValue(Object newValue)
设置用户所选值。

void

JSpinner.setValue(Object value)
更改模型的当前值，通常此值是 editor 所显示的值。

void

SpinnerDateModel.setValue(Object value)
设置此序列的当前 Date。

void

SpinnerListModel.setValue(Object elt)
改变该序列的当前元素并通知 ChangeListeners。

void

SpinnerModel.setValue(Object value)
改变该模型的当前值，通常此值由 JSpinner 的 editor 部分显示。

void

SpinnerNumberModel.setValue(Object value)
设置此序列的当前元素。

void

DefaultCellEditor.EditorDelegate.setValue(Object value)
设置此单元格的值。

void

Renderer.setValue(Object aValue, boolean isSelected)
指定要显示的值和是否应将该值描绘为“当前选定”。

void

JTable.setValueAt(Object aValue, int row, int column)
设置表模型中 row 和 column 位置的单元格值。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message)
调出带有选项 Yes、No 和 Cancel 的对话框；标题为 Select an Option。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的对话框。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message, Object initialSelectionValue)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。

static Object

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。

static Object

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。

static String

JOptionPane.showInputDialog(Object message)
显示请求用户输入的问题消息对话框。

static String

JOptionPane.showInputDialog(Object message, Object initialSelectionValue)
显示请求用户输入的问题消息对话框，它带有已初始化为 initialSelectionValue 的输入值。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message)
调出带有选项 Yes、No 和 Cancel 的内部对话框面板；标题为 Select an Option。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板，messageType 参数确定要显示的图标。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。

static String

JOptionPane.showInternalInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的内部问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。

static Object

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。

static Object

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。

static void

JOptionPane.showInternalMessageDialog(Component parentComponent, Object message)
调出内部确认对话框面板。

static void

JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出一个显示消息的内部对话框面板，它使用由 messageType 参数确定的默认图标。

static void

JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示消息的内部对话框面板，为其指定了所有参数。

static int

JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

static int

JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

static void

JOptionPane.showMessageDialog(Component parentComponent, Object message)
调出标题为 "Message" 的信息消息对话框。

static void

JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。

static void

JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示信息的对话框，为其指定了所有参数。

static int

JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

static int

JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

abstract  String

JFormattedTextField.AbstractFormatter.valueToString(Object value)
返回为 value 显示的 string 值。

参数类型为 Object 的 javax.swing 中的构造方法

DefaultComboBoxModel(Object[] items)
构造一个用对象数组初始化的 DefaultComboBoxModel 对象。

JComboBox(Object[] items)
创建包含指定数组中的元素的 JComboBox。

JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory, Object currentValue)
创建一个具有指定 AbstractFormatterFactory 和初始值的 JFormattedTextField。

JFormattedTextField(Object value)
创建一个具有指定值的 JFormattedTextField。

JList(Object[] listData)
构造一个 JList，使其显示指定数组中的元素。

JOptionPane(Object message)
创建一个显示消息的 JOptionPane 的实例，使其使用 UI 提供的普通消息消息类型和默认选项。

JOptionPane(Object message, int messageType)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和默认选项。

JOptionPane(Object message, int messageType, int optionType)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和选项。

JOptionPane(Object message, int messageType, int optionType, Icon icon)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、选项和图标。

JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。

JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。

JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options, Object initialValue)
在指定最初选择的选项的前提下，创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。

JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options, Object initialValue)
在指定最初选择的选项的前提下，创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。

JTable(Object[][] rowData, Object[] columnNames)
构造一个 JTable 来显示二维数组 rowData 中的值，其列名称为 columnNames。

JTable(Object[][] rowData, Object[] columnNames)
构造一个 JTable 来显示二维数组 rowData 中的值，其列名称为 columnNames。

JTree.DynamicUtilTreeNode(Object value, Object children)
使用指定的对象作为其值并使用指定的子节点创建一个节点。

JTree(Object[] value)
返回 JTree，指定数组的每个元素作为不被显示的新根节点的子节点。

ProgressMonitor(Component parentComponent, Object message, String note, int min, int max)
构造一个图形对象，它一般会根据进程的完成情况通过填充矩形条来显示进度。

ProgressMonitorInputStream(Component parentComponent, Object message, InputStream in)
构造一个对象，以监视输入流的进度。

SpinnerListModel(Object[] values)
构造一个由指定数组定义其值序列的 SpinnerModel。

UIDefaults.LazyInputMap(Object[] bindings)

UIDefaults.ProxyLazyValue(String c, Object[] o)
创建一个将在请求时构造实例的 LazyValue。

UIDefaults.ProxyLazyValue(String c, String m, Object[] o)
创建一个将在请求时构造实例的 LazyValue。

UIDefaults(Object[] keyValueList)
创建一个使用指定键/值对初始化的默认值表。

javax.swing.border 中 Object 的使用

javax.swing.border 中 Object 的子类

class

AbstractBorder
实现无大小限制的空边框类。

class

BevelBorder
该类实现简单的双线斜面边框。

class

CompoundBorder
一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。

class

EmptyBorder
该类提供了一个占用空间但不执行绘制的空透明边框。

class

EtchedBorder
该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。

class

LineBorder
实现单色、任意厚度线边框的类。

class

MatteBorder
该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。

class

SoftBevelBorder
实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。

class

TitledBorder
该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

javax.swing.colorchooser 中 Object 的使用

javax.swing.colorchooser 中 Object 的子类

class

AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

class

ColorChooserComponentFactory
旨在生成要插入到颜色选取器中的预先配置的“访问器”对象的类。

class

DefaultColorSelectionModel
ColorSelectionModel 的一般实现。

javax.swing.event 中 Object 的使用

javax.swing.event 中 Object 的子类

class

AncestorEvent
报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。

class

CaretEvent
CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。

class

ChangeEvent
ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。

static class

DocumentEvent.EventType
文档事件类型的枚举

class

EventListenerList
保存 EventListener 列表的类。

class

HyperlinkEvent
HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。

static class

HyperlinkEvent.EventType
定义 ENTERED、EXITED 和 ACTIVATED 事件类型，以及由 toString() 返回的这些事件类型的字符串表示形式。

class

InternalFrameAdapter
用于接收内部窗体事件的抽象适配器类。

class

InternalFrameEvent
以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。

class

ListDataEvent
定义一个封装列表更改的事件。

class

ListSelectionEvent
表现选择中更改的特征的事件。

class

MenuDragMouseEvent
MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。

class

MenuEvent
MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。

class

MenuKeyEvent
MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

class

MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

class

PopupMenuEvent
PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu 警告：此类的序列化对象将与以后的 Swing 版本不兼容。

class

RowSorterEvent
RowSorterEvent 提供 RowSorter 的更改通知。

class

SwingPropertyChangeSupport
java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。

class

TableColumnModelEvent
TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。

class

TableModelEvent
TableModelEvent 用于通知侦听器某一表模型已发生更改。

class

TreeExpansionEvent
用于标识树中的单个路径的事件。

class

TreeModelEvent
封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。

class

TreeSelectionEvent
描述当前选择中的更改的事件。

class

UndoableEditEvent
指示发生了可撤消操作的事件。

声明为 Object 的 javax.swing.event 中的字段

protected  Object[]

TreeModelEvent.children
已被移除的子节点。

protected  Object[]

EventListenerList.listenerList

返回 Object 的 javax.swing.event 中的方法

Object

TreeSelectionEvent.cloneWithSource(Object newSource)
返回接收方的副本，但带有将成为 newSource 的源。

Object[]

TreeModelEvent.getChildren()
返回位于 getChildIndices 指定位置处的、作为 getPath 所标识节点的子节点的对象。

Object[]

EventListenerList.getListenerList()
将事件侦听器列表以 ListenerType 侦听器对数组的形式传回。

Object[]

TreeModelEvent.getPath()
从此事件包装的 TreePath 实例中获得对象数组的便捷方法。

参数类型为 Object 的 javax.swing.event 中的方法

Object

TreeSelectionEvent.cloneWithSource(Object newSource)
返回接收方的副本，但带有将成为 newSource 的源。

参数类型为 Object 的 javax.swing.event 中的构造方法

CaretEvent(Object source)
创建一个新的 CaretEvent 对象。

ChangeEvent(Object source)
构造一个 ChangeEvent 对象。

HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u)
创建一个表示超文本链接事件的新对象。

HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
创建一个表示超文本链接事件的新对象。

HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。

ListDataEvent(Object source, int type, int index0, int index1)
构造一个 ListDataEvent 对象。

ListSelectionEvent(Object source, int firstIndex, int lastIndex, boolean isAdjusting)
表示 firstIndex 与 lastIndex（包括两者）范围内的选择状态的更改。

MenuEvent(Object source)
构造一个 MenuEvent 对象。

PopupMenuEvent(Object source)
构造一个 PopupMenuEvent 对象。

SwingPropertyChangeSupport(Object sourceBean)
构造一个 SwingPropertyChangeSupport 对象。

SwingPropertyChangeSupport(Object sourceBean, boolean notifyOnEDT)
构造一个 SwingPropertyChangeSupport 对象。

TreeExpansionEvent(Object source, TreePath path)
构造一个 TreeExpansionEvent 对象。

TreeModelEvent(Object source, Object[] path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 Object 数组。

TreeModelEvent(Object source, Object[] path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 Object 数组。

TreeModelEvent(Object source, Object[] path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 Object 数组。

TreeModelEvent(Object source, Object[] path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 Object 数组。

TreeModelEvent(Object source, Object[] path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 Object 数组。

TreeModelEvent(Object source, TreePath path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 TreePath 对象。

TreeModelEvent(Object source, TreePath path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 TreePath 对象。

TreeModelEvent(Object source, TreePath path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 TreePath 对象。

TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。

TreeSelectionEvent(Object source, TreePath path, boolean isNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。

UndoableEditEvent(Object source, UndoableEdit edit)
构造一个 UndoableEditEvent 对象。

javax.swing.filechooser 中 Object 的使用

javax.swing.filechooser 中 Object 的子类

class

FileFilter
FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。

class

FileNameExtensionFilter
FileFilter 的一个实现，它使用指定的扩展名集合进行过滤。

class

FileSystemView
FileSystemView 是 JFileChooser 的文件系统网关。

class

FileView
FileView 定义一个抽象类，可以实现该抽象类来为 File 提供带 UI 信息的文件选择器。

javax.swing.plaf 中 Object 的使用

javax.swing.plaf 中 Object 的子类

class

ActionMapUIResource
实现 UIResource 的 javax.swing.ActionMap 的子类。

class

BorderUIResource

static class

BorderUIResource.BevelBorderUIResource

static class

BorderUIResource.CompoundBorderUIResource

static class

BorderUIResource.EmptyBorderUIResource

static class

BorderUIResource.EtchedBorderUIResource

static class

BorderUIResource.LineBorderUIResource

static class

BorderUIResource.MatteBorderUIResource

static class

BorderUIResource.TitledBorderUIResource

class

ButtonUI
JButton 的可插入外观界面。

class

ColorChooserUI
JColorChooser 的可插入外观界面。

class

ColorUIResource

class

ComboBoxUI
JComboBox 的可插入外观界面。

class

ComponentInputMapUIResource
实现 UIResource 的 javax.swing.ComponentInputMap 的子类。

class

ComponentUI
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。

class

DesktopIconUI
JDesktopIcon 的可插入外观界面。

class

DesktopPaneUI
JDesktopPane 的可插入外观界面。

class

DimensionUIResource

class

FileChooserUI
JFileChooser 的可插入外观界面。

class

FontUIResource
实现 UIResource 的 java.awt.Font 的子类。

class

IconUIResource
实现 UIResource 的 Icon 包装类。

class

InputMapUIResource
实现 UIResource 的 javax.swing.InputMap 的子类。

class

InsetsUIResource

class

InternalFrameUI
JInternalFrame 的可插入外观界面。

class

LabelUI
JLabel 的可插入外观界面。

class

ListUI
JList 的可插入外观代理。

class

MenuBarUI
JMenuBar 的可插入外观界面。

class

MenuItemUI
JMenuItem 的可插入外观界面。

class

OptionPaneUI
JOptionPane 的可插入外观界面。

class

PanelUI
Panel 的可插入外观界面。

class

PopupMenuUI
JPopupMenu 的可插入外观界面。

class

ProgressBarUI
JProgressBar 的可插入外观界面。

class

RootPaneUI
JRootPane 的可插入外观界面。

class

ScrollBarUI
JScrollBar 的可插入外观界面。

class

ScrollPaneUI
JScrollPane 的可插入外观界面。

class

SeparatorUI
JSeparator 的可插入外观界面。

class

SliderUI
JSlider 的可插入外观界面。

class

SpinnerUI
JSpinner 的可插入外观界面

class

SplitPaneUI
JSplitPane 的可插入外观界面。

class

TabbedPaneUI
JTabbedPane 的可插入外观界面。

class

TableHeaderUI
JTableHeader 的可插入外观界面。

class

TableUI
JTable 的可插入外观界面。

class

TextUI
文本编辑器用户界面

class

ToolBarUI
JToolBar 的可插入外观界面。

class

ToolTipUI
JToolTip 的可插入外观界面。

class

TreeUI
JTree 的可插入外观界面。

class

ViewportUI
JViewport 的可插入外观界面。

javax.swing.plaf.basic 中 Object 的使用

javax.swing.plaf.basic 中 Object 的子类

class

BasicArrowButton
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。

class

BasicBorders
可以提供适合基本 L&F 的 Border 的工厂对象。

static class

BasicBorders.ButtonBorder

static class

BasicBorders.FieldBorder

static class

BasicBorders.MarginBorder

static class

BasicBorders.MenuBarBorder

static class

BasicBorders.RadioButtonBorder

static class

BasicBorders.RolloverButtonBorder
用于翻转工具栏按钮的特殊细边框。

static class

BasicBorders.SplitPaneBorder
绘制围绕拆分窗格的边框。

static class

BasicBorders.ToggleButtonBorder

class

BasicButtonListener
按钮侦听器。

class

BasicButtonUI
BasicButton 实现

class

BasicCheckBoxMenuItemUI
BasicCheckboxMenuItem 实现

class

BasicCheckBoxUI
BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。

class

BasicColorChooserUI
为 JColorChooser 提供基本外观。

class

BasicColorChooserUI.PropertyHandler
因编译器故障而被标记为 "public" 的内部类。

class

BasicComboBoxEditor
用于可编辑组合框的默认编辑器。

static class

BasicComboBoxEditor.UIResource
实现 UIResource 的 BasicComboBoxEditor 的子类。

class

BasicComboBoxRenderer
ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。

static class

BasicComboBoxRenderer.UIResource
实现 UIResource 的 BasicComboBoxRenderer 的子类。

class

BasicComboBoxUI
JComboBox 的基本 UI 实现。

class

BasicComboBoxUI.ComboBoxLayoutManager
此布局管理器处理组合框的“标准”布局。

class

BasicComboBoxUI.FocusHandler
失去焦点时，此侦听器将隐藏弹出部分。

class

BasicComboBoxUI.ItemHandler
此侦听器观察组合框中选择的更改。

class

BasicComboBoxUI.KeyHandler
此侦听器检查键事件是否不是导航键。

class

BasicComboBoxUI.ListDataHandler
此侦听器观察 ComboBoxModel 中的更改。

class

BasicComboBoxUI.PropertyChangeHandler
此侦听器观察在组合框中发生更改的绑定 (bound) 属性。

class

BasicComboPopup
此为 ComboPopup 接口的基本实现。

class

BasicComboPopup.InvocationKeyHandler
从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。

protected  class

BasicComboPopup.InvocationMouseHandler
要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。

protected  class

BasicComboPopup.InvocationMouseMotionHandler
此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。

protected  class

BasicComboPopup.ItemHandler
此侦听器观察组合框中选择的更改。

class

BasicComboPopup.ListDataHandler
从 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。

protected  class

BasicComboPopup.ListMouseHandler
在列表中释放鼠标时，此侦听器隐藏弹出部分。

protected  class

BasicComboPopup.ListMouseMotionHandler
在列表上移动鼠标时，此侦听器更改所选项。

protected  class

BasicComboPopup.ListSelectionHandler
从 Java 2 平台 v 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。

protected  class

BasicComboPopup.PropertyChangeHandler
此侦听器观察已在组合框中更改的绑定 (bound) 属性 希望侦听组合框属性更改的子类应该调用超类方法来确保组合框弹出部分正确处理属性更改。

class

BasicDesktopIconUI
用于桌面最小化窗口的 L&F。

class

BasicDesktopIconUI.MouseInputHandler
侦听鼠标移动及对其操作。

class

BasicDesktopPaneUI
桌面的基本 L&F。

protected  class

BasicDesktopPaneUI.CloseAction
处理关闭一个内部窗体。

protected  class

BasicDesktopPaneUI.MaximizeAction
处理最大化一个内部窗体。

protected  class

BasicDesktopPaneUI.MinimizeAction
处理最小化一个内部窗体。

protected  class

BasicDesktopPaneUI.NavigateAction
处理导航到下一个内部窗体。

protected  class

BasicDesktopPaneUI.OpenAction
处理恢复一个最小化或最大化的内部窗体。

class

BasicDirectoryModel
文件列表的基本实现。

class

BasicEditorPaneUI
为 JEditorPane 提供外观。

class

BasicFileChooserUI
FileChooser 的基本 L&F 实现。

protected  class

BasicFileChooserUI.AcceptAllFileFilter

protected  class

BasicFileChooserUI.ApproveSelectionAction
响应 Open 或 Save 请求

protected  class

BasicFileChooserUI.BasicFileView

protected  class

BasicFileChooserUI.CancelSelectionAction
响应取消请求。

protected  class

BasicFileChooserUI.ChangeToParentDirectoryAction

protected  class

BasicFileChooserUI.DoubleClickListener

protected  class

BasicFileChooserUI.GoHomeAction
基于“Home”键事件或等效事件的动作。

protected  class

BasicFileChooserUI.NewFolderAction
创建新文件夹。

protected  class

BasicFileChooserUI.SelectionListener

protected  class

BasicFileChooserUI.UpdateAction
重新扫描当前目录中的文件。

class

BasicFormattedTextFieldUI
提供 JFormattedTextField 的外观实现。

class

BasicGraphicsUtils

class

BasicHTML
支持为 swing 组件提供 html 视图。

class

BasicIconFactory
提供适于基本 L & F 使用的 Icon 的工厂对象。

class

BasicInternalFrameTitlePane
管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。

class

BasicInternalFrameTitlePane.CloseAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.IconifyAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.MaximizeAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.MoveAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.PropertyChangeHandler
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.RestoreAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.SizeAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.SystemMenuBar
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.TitlePaneLayout
此类应视为“受保护”内部类。

class

BasicInternalFrameUI
JInternalFrame 的基本 L&F 实现。

protected  class

BasicInternalFrameUI.BasicInternalFrameListener

protected  class

BasicInternalFrameUI.BorderListener
侦听边框调整。

protected  class

BasicInternalFrameUI.ComponentHandler

protected  class

BasicInternalFrameUI.GlassPaneDispatcher

class

BasicInternalFrameUI.InternalFrameLayout

class

BasicInternalFrameUI.InternalFramePropertyChangeListener

class

BasicLabelUI
LabelUI 的 Windows L&F 实现。

class

BasicListUI
ListUI 的可扩展实现。

class

BasicListUI.FocusHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicListUI.ListDataHandler
在 installUI 时和只要 JList.model 属性更改时就要添加到 JList 模型的 ListDataListener。

class

BasicListUI.ListSelectionHandler
在 installUI 时和只要 JList.selectionModel 属性更改时就要添加到 JList 模型的 ListSelectionListener。

class

BasicListUI.MouseInputHandler
鼠标输入和 JList 的焦点处理。

class

BasicListUI.PropertyChangeHandler
在 installUI 时添加到 JList 的 PropertyChangeListener。

class

BasicLookAndFeel
为 Swing 创建外观时要使用的基类。

class

BasicMenuBarUI
MenuBarUI 的默认 L&F 实现。

class

BasicMenuItemUI
BasicMenuItem 实现

protected  class

BasicMenuItemUI.MouseInputHandler

class

BasicMenuUI
MenuUI 的默认 L&F 实现。

class

BasicMenuUI.ChangeHandler
从 Java 2 平台 1.4 开始，已废弃这种以前没有记录的类。

protected  class

BasicMenuUI.MouseInputHandler
实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。

class

BasicOptionPaneUI
为 JOptionPane 提供基本外观。

class

BasicOptionPaneUI.ButtonActionListener
此内部类因编译器故障而被标记为“公开”。

static class

BasicOptionPaneUI.ButtonAreaLayout
ButtonAreaLayout 的行为方式类似于 FlowLayout。

class

BasicOptionPaneUI.PropertyChangeHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicPanelUI
BasicPanel 实现

class

BasicPasswordFieldUI
为密码字段提供 Windows 外观。

class

BasicPopupMenuSeparatorUI
PopupMenuSeparatorUI 的基本 L&F 实现。

class

BasicPopupMenuUI
PopupMenuUI 的 Windows L&F 实现。

class

BasicProgressBarUI
ProgressBarUI 的基本 L&F 实现。

class

BasicProgressBarUI.ChangeHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicRadioButtonMenuItemUI
BasicRadioButtonMenuItem 实现

class

BasicRadioButtonUI
BasicRadioButtonUI 的 RadioButtonUI 实现

class

BasicRootPaneUI
RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。

class

BasicScrollBarUI
基本外观的 ScrollBarUI 的实现

protected  class

BasicScrollBarUI.ArrowButtonListener
光标键的侦听器。

protected  class

BasicScrollBarUI.ModelListener
侦听模型更改的侦听器。

class

BasicScrollBarUI.PropertyChangeHandler

protected  class

BasicScrollBarUI.ScrollListener
在 ScrollPane 中发起的滚动事件的侦听器。

protected  class

BasicScrollBarUI.TrackListener
跟踪鼠标拖动。

class

BasicScrollPaneUI
ScrollPaneUI 的默认 L&F 实现。

class

BasicScrollPaneUI.HSBChangeListener
水平滚动条侦听器。

protected  class

BasicScrollPaneUI.MouseWheelHandler
MouseWheelHandler 是实现 MouseWheelListener 接口的内部类。

class

BasicScrollPaneUI.PropertyChangeHandler

class

BasicScrollPaneUI.ViewportChangeHandler
视口事件的侦听器。

class

BasicScrollPaneUI.VSBChangeListener
垂直滚动条侦听器。

class

BasicSeparatorUI
SeparatorUI 的基本 L&F 实现。

class

BasicSliderUI
SliderUI 的基本 L&F 实现。

class

BasicSliderUI.ActionScroller
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。

class

BasicSliderUI.ChangeHandler
数据模型侦听器。

class

BasicSliderUI.ComponentHandler
调整事件大小的侦听器。

class

BasicSliderUI.FocusHandler
焦点更改侦听器。

class

BasicSliderUI.PropertyChangeHandler

class

BasicSliderUI.ScrollListener
滚动事件侦听器。

class

BasicSliderUI.TrackListener
跟踪鼠标移动。

class

BasicSpinnerUI
默认 Spinner UI 委托。

class

BasicSplitPaneDivider
BasicSplitPaneUI 使用的分隔符。

protected  class

BasicSplitPaneDivider.DividerLayout
用于布置 BasicSplitPaneDivider。

protected  class

BasicSplitPaneDivider.DragController
在面向 HORIZONTAL_SPLIT 的拆分窗格的拖动会话期间处理事件。

protected  class

BasicSplitPaneDivider.MouseHandler
MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。

protected  class

BasicSplitPaneDivider.VerticalDragController
在面向 VERTICAL_SPLIT 的拆分窗格的拖动会话期间处理事件。

class

BasicSplitPaneUI
SplitPaneUI 的基本 L&F 实现。

class

BasicSplitPaneUI.BasicHorizontalLayoutManager
具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。

class

BasicSplitPaneUI.BasicVerticalLayoutManager
用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。

class

BasicSplitPaneUI.FocusHandler
JSplitPane UI 使用的 FocusListener 的实现。

class

BasicSplitPaneUI.KeyboardDownRightHandler
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

class

BasicSplitPaneUI.KeyboardEndHandler
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

class

BasicSplitPaneUI.KeyboardHomeHandler
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

class

BasicSplitPaneUI.KeyboardResizeToggleHandler
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

class

BasicSplitPaneUI.KeyboardUpLeftHandler
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

class

BasicSplitPaneUI.PropertyHandler
JSplitPane UI 使用的 PropertyChangeListener 的实现。

class

BasicTabbedPaneUI
TabbedPaneUI 的基本 L&F 实现。

class

BasicTabbedPaneUI.FocusHandler
此类应视为“受保护”内部类。

class

BasicTabbedPaneUI.MouseHandler
此类应视为“受保护”内部类。

class

BasicTabbedPaneUI.PropertyChangeHandler
此类应视为“受保护”内部类。

class

BasicTabbedPaneUI.TabbedPaneLayout
此类应视为“受保护”内部类。

class

BasicTabbedPaneUI.TabSelectionHandler
此类应视为“受保护”内部类。

class

BasicTableHeaderUI
BasicTableHeaderUI 实现

class

BasicTableHeaderUI.MouseInputHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicTableUI
BasicTableUI 实现

class

BasicTableUI.FocusHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicTableUI.KeyHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicTableUI.MouseInputHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicTextAreaUI
为纯文本编辑器提供外观。

class

BasicTextFieldUI
JTextField 的外观的基础。

class

BasicTextPaneUI
为样式化文本编辑器提供外观。

class

BasicTextUI
此类是文本组件外观的基础。

static class

BasicTextUI.BasicCaret

static class

BasicTextUI.BasicHighlighter

class

BasicToggleButtonUI
BasicToggleButton 实现

class

BasicToolBarSeparatorUI
ToolBarSeparatorUI 的基本 L&F 实现。

class

BasicToolBarUI
ToolBarUI 的基本 L&F 实现。

class

BasicToolBarUI.DockingListener
此类应视为“受保护”内部类。

protected  class

BasicToolBarUI.DragWindow

protected  class

BasicToolBarUI.FrameListener

protected  class

BasicToolBarUI.PropertyListener

protected  class

BasicToolBarUI.ToolBarContListener

protected  class

BasicToolBarUI.ToolBarFocusListener

class

BasicToolTipUI
标准工具提示 L&F。

class

BasicTreeUI
层次数据结构的基本 L&F。

class

BasicTreeUI.CellEditorHandler
侦听器负责获取单元格编辑事件并相应地更新树。

class

BasicTreeUI.ComponentHandler
滚动时更新首选大小（如果需要）。

class

BasicTreeUI.FocusHandler
失去/获得焦点时重绘前导选择行。

class

BasicTreeUI.KeyHandler
用于获取多个按键事件以适当生成事件。

class

BasicTreeUI.MouseHandler
TreeMouseListener 负责基于鼠标事件更新选择。

class

BasicTreeUI.MouseInputHandler
在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。

class

BasicTreeUI.NodeDimensionsHandler
负责获取节点大小的类，其方法被转发到 BasicTreeUI 方法。

class

BasicTreeUI.PropertyChangeHandler
树的 PropertyChangeListener。

class

BasicTreeUI.SelectionModelPropertyChangeHandler
TreeSelectionModel 上的侦听器，如果模型的任何属性发生更改，则重置行选择。

class

BasicTreeUI.TreeCancelEditingAction
执行操作时调用 cancelEditing 的 ActionListener。

class

BasicTreeUI.TreeExpansionHandler
更新 TreeState 以响应节点的展开/折叠。

class

BasicTreeUI.TreeHomeAction
TreeHomeAction 用于处理 end/home 动作。

class

BasicTreeUI.TreeIncrementAction
TreeIncrementAction 用于处理向上/向下操作。

class

BasicTreeUI.TreeModelHandler
将所有 TreeModel 事件转发到 TreeState。

class

BasicTreeUI.TreePageAction
TreePageAction 处理向上翻页和向下翻页事件。

class

BasicTreeUI.TreeSelectionHandler
侦听选择模型中的更改并相应地更新显示。

class

BasicTreeUI.TreeToggleAction
对于第一个选定行展开将被切换。

class

BasicTreeUI.TreeTraverseAction
TreeTraverseAction 是用于向左/向右方向键的动作。

class

BasicViewportUI
BasicViewport 实现

class

DefaultMenuLayout
Popup 菜单和菜单栏的默认布局管理器。

返回 Object 的 javax.swing.plaf.basic 中的方法

protected  Object[]

BasicOptionPaneUI.getButtons()
返回从接收者为其提供外观的 JOptionPane 显示的按钮。

Object

BasicDirectoryModel.getElementAt(int index)

Object

BasicComboBoxEditor.getItem()

protected  Object

BasicOptionPaneUI.getMessage()
返回从接收者为其提供外观的 JOptionPane 显示的消息。

参数类型为 Object 的 javax.swing.plaf.basic 中的方法

protected  void

BasicOptionPaneUI.addButtonComponents(Container container, Object[] buttons, int initialIndex)
创建表示 buttons 中每个对象的适当对象并将其添加到 container。

void

BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。

protected  void

BasicOptionPaneUI.addMessageComponents(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated)
创建表示 msg 的适当对象并将其置于 container 中。

boolean

BasicDirectoryModel.contains(Object o)

protected  Action

BasicLookAndFeel.createAudioAction(Object key)
创建并返回用于播放音频的 Action。

protected  void

BasicDirectoryModel.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告 boolean 属性的绑定属性的改变。

Component

BasicComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)

Rectangle

BasicTreeUI.NodeDimensionsHandler.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle size)
负责获取特定节点的大小。

int

BasicDirectoryModel.indexOf(Object o)

void

BasicComboBoxEditor.setItem(Object anObject)
设置应该编辑的项。

javax.swing.plaf.metal 中 Object 的使用

javax.swing.plaf.metal 中 Object 的子类

class

DefaultMetalTheme
提供 Java 外观原型的 MetalTheme 的一个具体实现，代码名称为“Steel”。

class

MetalBorders
可以提供适用于 metal L & F 的 Border 的工厂对象。

static class

MetalBorders.ButtonBorder

static class

MetalBorders.Flush3DBorder

static class

MetalBorders.InternalFrameBorder

static class

MetalBorders.MenuBarBorder

static class

MetalBorders.MenuItemBorder

static class

MetalBorders.OptionDialogBorder

static class

MetalBorders.PaletteBorder
Palette 的边框。

static class

MetalBorders.PopupMenuBorder

static class

MetalBorders.RolloverButtonBorder

static class

MetalBorders.ScrollPaneBorder

static class

MetalBorders.TableHeaderBorder
Table Header 的边框

static class

MetalBorders.TextFieldBorder

static class

MetalBorders.ToggleButtonBorder

static class

MetalBorders.ToolBarBorder

class

MetalButtonUI
MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。

class

MetalCheckBoxIcon
OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。

class

MetalCheckBoxUI
MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

class

MetalComboBoxButton
协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

class

MetalComboBoxEditor
Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

MetalComboBoxEditor.UIResource
实现 UIResource 的 BasicComboBoxEditor 的一个子类。

class

MetalComboBoxIcon
此实用工具类绘制指示 MetalComboBox 的水平条

class

MetalComboBoxUI
JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

class

MetalComboBoxUI.MetalComboBoxLayoutManager
此内部类因编译器故障而被标记为 "public"。

class

MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

class

MetalComboBoxUI.MetalPropertyChangeListener
此内部类由于编译器故障而被标记为 "public"。

class

MetalDesktopIconUI
Metal 桌面图标。

class

MetalFileChooserUI
FileChooser 的 Metal L&F 实现。

protected  class

MetalFileChooserUI.DirectoryComboBoxAction
当 DirectoryComboBox 已更改所选项时调用。

protected  class

MetalFileChooserUI.DirectoryComboBoxModel
字体选择组合框的数据模型。

protected  class

MetalFileChooserUI.FileRenderer

protected  class

MetalFileChooserUI.FilterComboBoxModel
字体选择组合框的数据模型。

class

MetalFileChooserUI.FilterComboBoxRenderer
呈现不同的类型大小和风格。

protected  class

MetalFileChooserUI.SingleClickListener

class

MetalIconFactory
为 JavaTM 外观 (Metal) 提供 Icon 的工厂对象。

static class

MetalIconFactory.FileIcon16
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

MetalIconFactory.FolderIcon16
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

MetalIconFactory.PaletteCloseIcon
定义一个用于 Palette 关闭的图标

static class

MetalIconFactory.TreeControlIcon
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

MetalIconFactory.TreeFolderIcon
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

MetalIconFactory.TreeLeafIcon

class

MetalInternalFrameTitlePane
管理 JLF 标题栏的类

class

MetalInternalFrameUI
JInternalFrame 的 Metal 实现。

class

MetalLabelUI
LabelUI 的 Windows L&F 实现。

class

MetalLookAndFeel
Java 外观，也称为 Metal。

class

MetalMenuBarUI
MenuBarUI 的 Metal 实现。

class

MetalPopupMenuSeparatorUI
PopupMenuSeparatorUI 的 Metal L&F 实现。

class

MetalProgressBarUI
ProgressBarUI 的 Metal 实现。

class

MetalRadioButtonUI
MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

class

MetalRootPaneUI
提供 RootPaneUI 的 metal 外观实现。

class

MetalScrollBarUI
ScrollBarUI 的 Metal 外观实现

class

MetalScrollButton
Metal 滚动条箭头的 JButton 对象。

class

MetalScrollPaneUI
ScrollPaneUI 的 Metal L&F 实现。

class

MetalSeparatorUI
SeparatorUI 的 Metal L&F 实现。

class

MetalSliderUI
SliderUI 的 Java L&F 实现。

protected  class

MetalSliderUI.MetalPropertyListener

class

MetalSplitPaneUI
Metal 分隔窗格。

class

MetalTabbedPaneUI
BasicTabbedPaneUI 的 Metal 子类。

class

MetalTabbedPaneUI.TabbedPaneLayout
此内部类由于编译器故障而被标记为 "public"。

class

MetalTextFieldUI
JTextField 外观的基础。

class

MetalTheme
MetalTheme 提供 Java 外观所使用的调色板和字体。

class

MetalToggleButtonUI
MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

class

MetalToolBarUI
ToolBarUI 的 Metal 外观实现。

protected  class

MetalToolBarUI.MetalContainerListener

protected  class

MetalToolBarUI.MetalDockingListener

protected  class

MetalToolBarUI.MetalRolloverListener

class

MetalToolTipUI
BasicToolTipUI 的 Metal L&F 扩展。

class

MetalTreeUI
TreeUI 的 metal 外观实现。

class

OceanTheme
MetalLookAndFeel 的默认主题。

返回 Object 的 javax.swing.plaf.metal 中的方法

Object

MetalFileChooserUI.DirectoryComboBoxModel.getElementAt(int index)

Object

MetalFileChooserUI.FilterComboBoxModel.getElementAt(int index)

Object

MetalFileChooserUI.DirectoryComboBoxModel.getSelectedItem()

Object

MetalFileChooserUI.FilterComboBoxModel.getSelectedItem()

参数类型为 Object 的 javax.swing.plaf.metal 中的方法

protected  void

MetalTreeUI.decodeLineStyle(Object lineStyleFlag)
此方法进行传入客户端属性中的字符串和内部表示形式（当前的并且用 int 值表示）之间的转换

Component

MetalFileChooserUI.FilterComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)

void

MetalFileChooserUI.DirectoryComboBoxModel.setSelectedItem(Object selectedDirectory)

void

MetalFileChooserUI.FilterComboBoxModel.setSelectedItem(Object filter)

javax.swing.plaf.multi 中 Object 的使用

javax.swing.plaf.multi 中 Object 的子类

class

MultiButtonUI
用于组合 ButtonUI 的多路 UI。

class

MultiColorChooserUI
用于组合 ColorChooserUI 的多路 UI。

class

MultiComboBoxUI
用于组合 ComboBoxUI 的多路 UI。

class

MultiDesktopIconUI
用于组合 DesktopIconUI 的多路 UI。

class

MultiDesktopPaneUI
用于组合 DesktopPaneUI 的多路 UI。

class

MultiFileChooserUI
用于组合 FileChooserUI 的多路 UI。

class

MultiInternalFrameUI
用于组合 InternalFrameUI 的多路 UI。

class

MultiLabelUI
用于组合 LabelUI 的多路 UI。

class

MultiListUI
用于组合 ListUI 的多路 UI。

class

MultiLookAndFeel
多路外观允许同时将多个 UI 与一个组件相关联。

class

MultiMenuBarUI
用于组合 MenuBarUI 的多路 UI。

class

MultiMenuItemUI
用于组合 MenuItemUI 的多路 UI。

class

MultiOptionPaneUI
用于组合 OptionPaneUI 的多路 UI。

class

MultiPanelUI
用于组合 PanelUI 的多路 UI。

class

MultiPopupMenuUI
用于组合 PopupMenuUI 的多路 UI。

class

MultiProgressBarUI
用于组合 ProgressBarUI 的多路 UI。

class

MultiRootPaneUI
用于组合 RootPaneUI 的多路 UI。

class

MultiScrollBarUI
用于组合 ScrollBarUI 的多路 UI。

class

MultiScrollPaneUI
用于组合 ScrollPaneUI 的多路 UI。

class

MultiSeparatorUI
用于组合 SeparatorUI 的多路 UI。

class

MultiSliderUI
用于组合 SliderUI 的多路 UI。

class

MultiSpinnerUI
用于组合 SpinnerUI 的多路 UI。

class

MultiSplitPaneUI
用于组合 SplitPaneUI 的多路 UI。

class

MultiTabbedPaneUI
用于组合 TabbedPaneUI 的多路 UI。

class

MultiTableHeaderUI
用于组合 TableHeaderUI 的多路 UI。

class

MultiTableUI
用于组合 TableUI 的多路 UI。

class

MultiTextUI
用于组合 TextUI 的多路 UI。

class

MultiToolBarUI
用于组合 ToolBarUI 的多路 UI。

class

MultiToolTipUI
用于组合 ToolTipUI 的多路 UI。

class

MultiTreeUI
用于组合 TreeUI 的多路 UI。

class

MultiViewportUI
用于组合 ViewportUI 的多路 UI。

javax.swing.plaf.synth 中 Object 的使用

javax.swing.plaf.synth 中 Object 的子类

class

ColorType
可从某种风格中获取的一些颜色的类型安全枚举。

class

Region
Swing 组件的独特呈现区域。

class

SynthContext
一个不可变的瞬态对象，它包含有关 Region 的上下文信息。

class

SynthGraphicsUtils
用于基本图形调用的包装器。

class

SynthLookAndFeel
SynthLookAndFeel 提供创建定制外观的基础。

class

SynthPainter
SynthPainter 用于绘制 JComponent 的某些部分。

class

SynthStyle
SynthStyle 是一个样式属性集。

class

SynthStyleFactory
用于获得 SynthStyle 的工厂。

返回 Object 的 javax.swing.plaf.synth 中的方法

Object

SynthStyle.get(SynthContext context, Object key)
某个 region 特定样式属性的获取器。

参数类型为 Object 的 javax.swing.plaf.synth 中的方法

void

SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2)
在两个端点之间绘制一条线。

void

SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey)
在两个端点之间绘制一条线。

Object

SynthStyle.get(SynthContext context, Object key)
某个 region 特定样式属性的获取器。

boolean

SynthStyle.getBoolean(SynthContext context, Object key, boolean defaultValue)
获得其值是一个 Boolean 值的特定样式属性的便捷方法。

Icon

SynthStyle.getIcon(SynthContext context, Object key)
获得其值是一个 Icon 的特定样式属性的便捷方法。

int

SynthStyle.getInt(SynthContext context, Object key, int defaultValue)
获得值为 Number 的一个特定样式属性的便捷方法。

String

SynthStyle.getString(SynthContext context, Object key, String defaultValue)
获得其值是一个 String 值的特定样式属性的便捷方法。

javax.swing.table 中 Object 的使用

javax.swing.table 中 Object 的子类

class

AbstractTableModel
此抽象类为 TableModel 接口中的大多数方法提供默认实现。

class

DefaultTableCellRenderer
呈现（显示） JTable 中每个单元格的标准类。

static class

DefaultTableCellRenderer.UIResource
DefaultTableCellRenderer 的一个子类，它实现 UIResource。

class

DefaultTableColumnModel
JTable 的标准列处理程序。

class

DefaultTableModel
这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。

class

JTableHeader
这是管理 JTable 的头的对象。

protected  class

JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。

protected  class

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。

class

TableColumn
TableColumn 表示 JTable 中列的所有属性，如宽度、大小可调整性、最小和最大宽度。

class

TableRowSorter<M extends TableModel>
RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。

class

TableStringConverter
TableStringConverter 用于将对象从模型转换为字符串。

声明为 Object 的 javax.swing.table 中的字段

protected  Object

TableColumn.headerValue
列的标题值。

protected  Object

TableColumn.identifier
根据 JTable 的绘制机制，此对象不会在内部使用；可在 TableColumn 中设置标识符，并将其作为标记和定位表列的可选方式。

返回 Object 的 javax.swing.table 中的方法

Object

TableColumn.getHeaderValue()
返回用作标题渲染器值的 Object。

Object

TableColumn.getIdentifier()
返回此列的 identifier 对象。

Object

DefaultTableModel.getValueAt(int row, int column)
返回 row 和 column 处单元格的属性值。

Object

TableModel.getValueAt(int rowIndex, int columnIndex)
返回 columnIndex 和 rowIndex 位置的单元格值。

参数类型为 Object 的 javax.swing.table 中的方法

void

DefaultTableModel.addColumn(Object columnName)
将一列添加到模型中。

void

DefaultTableModel.addColumn(Object columnName, Object[] columnData)
将一列添加到模型中。

void

DefaultTableModel.addColumn(Object columnName, Object[] columnData)
将一列添加到模型中。

void

DefaultTableModel.addColumn(Object columnName, Vector columnData)
将一列添加到模型中。

void

DefaultTableModel.addRow(Object[] rowData)
添加一行到模型的结尾。

protected static Vector

DefaultTableModel.convertToVector(Object[] anArray)
返回一个包含与该数组相同的对象的向量。

protected static Vector

DefaultTableModel.convertToVector(Object[][] anArray)
返回一个 vector，该 vector 由包含与该数组相同的对象的多个 vector 组成。

protected  void

DefaultTableCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

int

DefaultTableColumnModel.getColumnIndex(Object identifier)
返回 tableColumns 数组中第一列的索引，当使用 equals 进行比较时，该列的标识符等于 identifier。

int

TableColumnModel.getColumnIndex(Object columnIdentifier)
返回该表中首列的索引，使用 equals 进行比较时，该列的标识符等于 identifier。

Component

TableCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
为编辑器设置初始 value。

Component

DefaultTableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
返回默认的表单元格渲染器。

Component

TableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
返回用于绘制单元格的组件。

void

DefaultTableModel.insertRow(int row, Object[] rowData)
在模型中的 row 位置插入一行。

void

DefaultTableModel.setColumnIdentifiers(Object[] newIdentifiers)
替换模型中的列标识符。

void

DefaultTableModel.setDataVector(Object[][] dataVector, Object[] columnIdentifiers)
用数组 dataVector 中的值替换 dataVector 实例变量中的值。

void

DefaultTableModel.setDataVector(Object[][] dataVector, Object[] columnIdentifiers)
用数组 dataVector 中的值替换 dataVector 实例变量中的值。

void

TableColumn.setHeaderValue(Object headerValue)
设置 Object，将使用其字符串表示形式作为 headerRenderer 的值。

void

TableColumn.setIdentifier(Object identifier)
将 TableColumn 的标识符设置为 anIdentifier。

protected  void

DefaultTableCellRenderer.setValue(Object value)
将要呈现的单元格的 String 对象设置为 value。

void

DefaultTableModel.setValueAt(Object aValue, int row, int column)
设置 column 和 row 处单元格的对象值。

void

AbstractTableModel.setValueAt(Object aValue, int rowIndex, int columnIndex)
由于提供了此空实现，因此，如果用户的数据模型是不可编辑的，则他们不必实现此方法。

void

TableModel.setValueAt(Object aValue, int rowIndex, int columnIndex)
将 columnIndex 和 rowIndex 位置的单元格中的值设置为 aValue。

参数类型为 Object 的 javax.swing.table 中的构造方法

DefaultTableModel(Object[][] data, Object[] columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。

DefaultTableModel(Object[][] data, Object[] columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。

DefaultTableModel(Object[] columnNames, int rowCount)
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。

javax.swing.text 中 Object 的使用

javax.swing.text 中 Object 的子类

class

AbstractDocument
文档接口的实现，可作为实现各种文档的基础。

class

AbstractDocument.AbstractElement
实现元素的抽象部分。

class

AbstractDocument.BranchElement
实现一个包含其他元素的复合元素。

class

AbstractDocument.DefaultDocumentEvent
存储修改文档时发生的文档更改。

static class

AbstractDocument.ElementEdit
一个 ElementChange 实现，可将其添加到文档事件中。

class

AbstractDocument.LeafElement
实现可直接表示某类内容的元素。

class

AbstractWriter
AbstractWriter 是一个抽象类，它实际执行元素树（包括属性）的写出工作。

class

AsyncBoxView
异步执行布局处理的框。

class

AsyncBoxView.ChildLocator
该类在本地化区域发生更改时，管理该本地化区域中子视图的有效位置。

class

AsyncBoxView.ChildState
表示子视图布局状态的记录。

class

BadLocationException
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。

class

BoxView
一个视图，它通过沿某轴平铺将其子级排列到框形状中。

class

ChangedCharSetException
顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。

class

ComponentView
实现视图接口的组件装饰器。

class

CompositeView
CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。

class

DateFormatter
DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。

class

DefaultCaret
插入符的默认实现。

class

DefaultEditorKit
这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。

static class

DefaultEditorKit.BeepAction
创建蜂鸣声。

static class

DefaultEditorKit.CopyAction
复制选定的区域并将其内容放入系统剪贴板中。

static class

DefaultEditorKit.CutAction
剪切选定的区域并将其内容放入系统剪贴板中。

static class

DefaultEditorKit.DefaultKeyTypedAction
如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。

static class

DefaultEditorKit.InsertBreakAction
在文档中放置行/段落中断。

static class

DefaultEditorKit.InsertContentAction
将内容置于关联的文档中。

static class

DefaultEditorKit.InsertTabAction
将一个制表符置于文档中。

static class

DefaultEditorKit.PasteAction
将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。

class

DefaultFormatter
DefaultFormatter 格式化任意对象。

class

DefaultFormatterFactory
JFormattedTextField.AbstractFormatterFactory 的一个实现。

class

DefaultHighlighter
实现 Highlighter 接口。

static class

DefaultHighlighter.DefaultHighlightPainter
只高亮显示用纯色填充高亮显示区域的 painter。

class

DefaultStyledDocument
能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。

static class

DefaultStyledDocument.AttributeUndoableEdit
用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。

class

DefaultStyledDocument.ElementBuffer
管理对元素层次结构更改的类。

static class

DefaultStyledDocument.ElementSpec
构建元素的规范。

protected  class

DefaultStyledDocument.SectionElement
文档的默认根元素... 与所包含的段落/行对应。

class

DefaultTextUI
已过时。

class

DocumentFilter
DocumentFilter，顾名思义，它是 Document 改变方法的一个过滤器。

static class

DocumentFilter.FilterBypass
充当避开回调 Document 进行更改的方法。

class

EditorKit
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。

class

ElementIterator
ElementIterator，顾名思义，沿 Element 树进行迭代。

class

FieldView
扩展多行纯文本视图，使其适合单行编辑器视图。

class

FlowView
试图将其子级流入某个部分受约束的空间的视图。

static class

FlowView.FlowStrategy
维护流的物理形式的策略。

class

GapContent
AbstractDocument.Content 接口的一个实现，使用类似于 emacs 使用的间隙缓冲区来实现。

class

GlyphView
GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。

static class

GlyphView.GlyphPainter
执行字形呈现的类。

class

IconView
实现视图接口的图标修饰符。

class

InternationalFormatter
InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。

class

JTextComponent
JTextComponent 是 swing 文本组件的基类。

class

JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

static class

JTextComponent.DropLocation
表示 JTextComponent 的放置位置 (drop location)。

static class

JTextComponent.KeyBinding
用于创建键绑定的绑定记录。

class

LabelView
LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。

class

LayeredHighlighter

static class

LayeredHighlighter.LayerPainter
分层的高亮显示渲染器。

class

LayoutQueue
文本布局任务的队列。

class

MaskFormatter
MaskFormatter 用于格式化和编辑字符串。

class

NavigationFilter
NavigationFilter 可用于限制光标的定位。

static class

NavigationFilter.FilterBypass
用作防止回调插入符以定位光标的方式。

class

NumberFormatter
添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。

class

ParagraphView
存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。

class

PasswordView
实现适用于 JPasswordField UI 实现的视图。

class

PlainDocument
维护无任何字符属性的普通文档。

class

PlainView
实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。

static class

Position.Bias
用来指示模型中位置偏差的类型安全的枚举。

class

Segment
表示文本片段的字符数组的 segment。

class

SimpleAttributeSet
使用哈希表的 MutableAttributeSet 的直接实现。

class

StringContent
AbstractDocument.Content 接口的一个实现，这是一个对相对于较小的文档和/或调试很有用的强制实现。

class

StyleConstants
一个已知的 或常见的属性键和方法的集合，可通过应用 AttributeSet 或 MutableAttributeSet 方法以类型安全的方式获取/设置属性。

static class

StyleConstants.CharacterConstants
这是一个类型安全的已知 属性的枚举，它用于字符样式。

static class

StyleConstants.ColorConstants
这是一个类型安全的已知 属性的枚举，它用于颜色样式。

static class

StyleConstants.FontConstants
这是一个类型安全的已知 属性的枚举，它用于字体样式。

static class

StyleConstants.ParagraphConstants
这是一个类型安全的已知 属性的枚举，它用于段落样式。

class

StyleContext
样式池及其关联的资源。

class

StyleContext.NamedStyle
通常用于表示字符和段落样式的属性集合。

class

StyleContext.SmallAttributeSet
此类可在数组中存储少量的属性。

class

StyledEditorKit
这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。

static class

StyledEditorKit.AlignmentAction
设置段落对齐的操作。

static class

StyledEditorKit.BoldAction
切换粗体属性的操作。

static class

StyledEditorKit.FontFamilyAction
在相关的 JEditorPane 中设置字体系列的操作。

static class

StyledEditorKit.FontSizeAction
设置关联的 JEditorPane 中字体大小的操作。

static class

StyledEditorKit.ForegroundAction
设置前景色的操作。

static class

StyledEditorKit.ItalicAction
切换斜体属性的一种操作。

static class

StyledEditorKit.StyledTextAction
假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。

static class

StyledEditorKit.UnderlineAction
切换下划线属性的操作。

class

TableView
为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。

class

TableView.TableCell
已过时。 表单元格如今可以是任何 View 实现。

class

TableView.TableRow
以行为中心的表格中的行视图。

class

TabSet
由许多 TabStop 组成的一个 TabSet。

class

TabStop
此类封装单个制表位 (tab stop)（基本上是由 RTF 认定的制表位）。

class

TextAction
用于跨多个不同文本组件共享的键绑定的 Action 实现。

class

Utilities
处理各种文本相关活动的方法集合。

class

View
View 类是 text 包极为重要的一部分。

class

WrappedPlainView
进行换行的纯文本（仅有一种字体和颜色的文本）视图。

class

ZoneView
ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

声明为 Object 的 javax.swing.text 中的字段

static Object

StyleConstants.Alignment
段落的对齐方式。

static Object

StyleConstants.Background
背景色属性的名称。

static Object

StyleConstants.BidiLevel
由 Unicode bidi 算法指派的字符双向级别。

static Object

StyleConstants.Bold
粗体属性的名称。

static Object

StyleConstants.ComponentAttribute
组件属性的名称。

static Object

StyleConstants.ComposedTextAttribute
撰写文本的输入法属性的名称。

static Object

StyleConstants.Family
字体系列的名称。

static Object

StyleConstants.FirstLineIndent
段落第一行要缩进的空间量。

static Object

StyleConstants.FontFamily
字体系列的名称。

static Object

StyleConstants.FontSize
字体大小的名称。

static Object

StyleConstants.Foreground
前景色属性的名称。

static Object

StyleConstants.IconAttribute
图标属性的名称。

static Object

StyleConstants.Italic
斜体属性的名称。

static Object

StyleConstants.LeftIndent
段落左边的缩进量。

static Object

StyleConstants.LineSpacing
段落的行之间的空间量。

static Object

StyleConstants.ModelAttribute
用来标识嵌入了对象的模型的属性，这些嵌入的对象具有分开的模型视图。

static Object

AttributeSet.NameAttribute
用于命名属性集合的属性名。

static Object

StyleConstants.NameAttribute
用于命名属性集合的属性名称。

static Object

StyleConstants.Orientation
段落的方向。

static Object

AttributeSet.ResolveAttribute
用于标识解析父集合属性集（如果已定义）的属性名。

static Object

StyleConstants.ResolveAttribute
用来标识属性的解析父集的属性名（如果定义了属性的解析父集）。

static Object

StyleConstants.RightIndent
段落右边的缩进量。

static Object

StyleConstants.Size
字体大小的名称。

static Object

StyleConstants.SpaceAbove
段落上方的空间量。

static Object

StyleConstants.SpaceBelow
段落下方的空间量。

static Object

StyleConstants.StrikeThrough
删除线属性的名称。

static Object

StyleConstants.Subscript
下标属性的名称。

static Object

StyleConstants.Superscript
上标属性的名称。

static Object

StyleConstants.TabSet
段落的 TabSet，类型为包含了 TabStop 的 TabSet。

static Object

StyleConstants.Underline
下划线属性的名称。

返回 Object 的 javax.swing.text 中的方法

Object

DefaultHighlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
向视图添加高亮显示。

Object

Highlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
向视图添加高亮显示。

protected  Object

GapContent.allocateArray(int len)
分配一个存储适当类型项的数组（由子类确定）。

Object

DefaultFormatter.clone()
创建此 DefaultFormatter 的副本。

Object

ElementIterator.clone()
复制 ElementIterator。

protected  Object

GlyphView.clone()
创建一个浅表复制。

Object

InternationalFormatter.clone()
创建该 DefaultFormatter 的一个副本。

Object

StyledEditorKit.clone()
创建此编辑器工具包的一个副本。

Object

EditorKit.clone()
创建此编辑器工具包的副本。

Object

Segment.clone()
创建一个浅表副本。

Object

SimpleAttributeSet.clone()
复制属性集。

Object

StyleContext.SmallAttributeSet.clone()
复制属性集。

Object

SimpleAttributeSet.getAttribute(Object name)
获取属性的值。

Object

AttributeSet.getAttribute(Object key)
获取给定属性的值。

Object

StyleContext.SmallAttributeSet.getAttribute(Object key)
获取属性的值。

Object

StyleContext.NamedStyle.getAttribute(Object attrName)
获取属性的值。

Object

AbstractDocument.AbstractElement.getAttribute(Object attrName)
获取属性值。

Object

AbstractDocument.getProperty(Object key)
查找属性值的便捷方法。

Object

Document.getProperty(Object key)
获得与文档关联的属性。

static Object

StyleContext.getStaticAttribute(Object key)
返回以前用 registerStaticAttributeKey 注册的对象。

static Object

StyleContext.getStaticAttributeKey(Object key)
返回其 key 将要注册的 String

Object

DefaultFormatter.stringToValue(String string)
通过使用带 String 参数的构造方法将传入的 String 转换为 getValueClass 的一个实例。

Object

InternationalFormatter.stringToValue(String text)
返回 String text 的 Object 表示形式。

Object

MaskFormatter.stringToValue(String value)
解析文本，返回 String value 的适当 Object 表示形式。

返回变量类型为 Object 的类型的 javax.swing.text 中的方法

Dictionary<Object,Object>

AbstractDocument.getDocumentProperties()
支持管理属性集。

Dictionary<Object,Object>

AbstractDocument.getDocumentProperties()
支持管理属性集。

参数类型为 Object 的 javax.swing.text 中的方法

AttributeSet

StyleContext.addAttribute(AttributeSet old, Object name, Object value)
向给定的集合中添加属性，并返回新的有代表性的集合。

AttributeSet

AbstractDocument.AttributeContext.addAttribute(AttributeSet old, Object name, Object value)
向给定属性集中添加一个属性，并返回新的有代表性的属性集。

void

SimpleAttributeSet.addAttribute(Object name, Object value)
向列表添加属性。

void

MutableAttributeSet.addAttribute(Object name, Object value)
创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。

void

StyleContext.NamedStyle.addAttribute(Object name, Object value)
添加属性。

void

AbstractDocument.AbstractElement.addAttribute(Object name, Object value)
向该元素添加一个属性。

void

DefaultHighlighter.changeHighlight(Object tag, int p0, int p1)
更改高亮显示。

void

Highlighter.changeHighlight(Object tag, int p0, int p1)
更改给定的高亮显示，以使其横跨文档的不同部分。

boolean

SimpleAttributeSet.containsAttribute(Object name, Object value)
检查属性列表中是否包含了指定的属性名称/值对。

boolean

AttributeSet.containsAttribute(Object name, Object value)
如果此集合用相同的名称和相等值定义一个属性，则返回 true 。

boolean

StyleContext.SmallAttributeSet.containsAttribute(Object name, Object value)
检查给定的属性名称/值是否已定义。

boolean

StyleContext.NamedStyle.containsAttribute(Object name, Object value)
确定给定的属性名称/值是否已定义。

boolean

AbstractDocument.AbstractElement.containsAttribute(Object name, Object value)
检查是否定义了给定的属性名称/值。

boolean

TabSet.equals(Object o)
指示此 TabSet 是否与另一个相等。

boolean

TabStop.equals(Object other)
如果制表符相等，则返回 true。

boolean

DefaultCaret.equals(Object obj)
将此对象与指定的对象进行比较。

boolean

SimpleAttributeSet.equals(Object obj)
将该对象与指定对象比较。

boolean

StyleContext.SmallAttributeSet.equals(Object obj)
将此对象与指定对象比较。

Object

SimpleAttributeSet.getAttribute(Object name)
获取属性的值。

Object

AttributeSet.getAttribute(Object key)
获取给定属性的值。

Object

StyleContext.SmallAttributeSet.getAttribute(Object key)
获取属性的值。

Object

StyleContext.NamedStyle.getAttribute(Object attrName)
获取属性的值。

Object

AbstractDocument.AbstractElement.getAttribute(Object attrName)
获取属性值。

Object

AbstractDocument.getProperty(Object key)
查找属性值的便捷方法。

Object

Document.getProperty(Object key)
获得与文档关联的属性。

static Object

StyleContext.getStaticAttribute(Object key)
返回以前用 registerStaticAttributeKey 注册的对象。

static Object

StyleContext.getStaticAttributeKey(Object key)
返回其 key 将要注册的 String

boolean

SimpleAttributeSet.isDefined(Object attrName)
告知是否定义了给定的属性。

boolean

AttributeSet.isDefined(Object attrName)
检查指定属性是否具有该属性集中指定的值，而无需通过其他属性集进行解析。

boolean

StyleContext.SmallAttributeSet.isDefined(Object key)
检查给定属性是否已定义。

boolean

StyleContext.NamedStyle.isDefined(Object attrName)
确定给定属性是否已定义。

boolean

AbstractDocument.AbstractElement.isDefined(Object attrName)
检查是否定义了给定的属性。

void

AbstractDocument.putProperty(Object key, Object value)
存储属性值的便捷方法。

void

Document.putProperty(Object key, Object value)
将属性与文档关联。

void

JTextComponent.read(Reader in, Object desc)
根据流进行初始化。

static void

StyleContext.registerStaticAttributeKey(Object key)
将一个对象注册为用作属性集中的一个键的静态对象。

AttributeSet

StyleContext.removeAttribute(AttributeSet old, Object name)
从集合中移除一个属性。

AttributeSet

AbstractDocument.AttributeContext.removeAttribute(AttributeSet old, Object name)
从属性集中移除某个属性。

void

SimpleAttributeSet.removeAttribute(Object name)
从列表中移除属性。

void

MutableAttributeSet.removeAttribute(Object name)
移除具有给定 name 的属性。

void

StyleContext.NamedStyle.removeAttribute(Object name)
从集合中移除属性。

void

AbstractDocument.AbstractElement.removeAttribute(Object name)
从该集合中移除一个属性。

void

DefaultHighlighter.removeHighlight(Object tag)
从视图中移除高亮显示。

void

Highlighter.removeHighlight(Object tag)
从视图中移除高亮显示。

String

DefaultFormatter.valueToString(Object value)
使用 toString 方法将传入的 Object 转换为 String。

String

InternationalFormatter.valueToString(Object value)
返回 Object value 的 String 表示形式。

String

MaskFormatter.valueToString(Object value)
返回基于掩码的 Object value 的 String 表示形式。

类型变量类型为 Object 的 javax.swing.text 中的方法参数

void

AbstractDocument.setDocumentProperties(Dictionary<Object,Object> x)
替换此文档的文档属性字典。

void

AbstractDocument.setDocumentProperties(Dictionary<Object,Object> x)
替换此文档的文档属性字典。

参数类型为 Object 的 javax.swing.text 中的构造方法

StyleContext.SmallAttributeSet(Object[] attributes)

javax.swing.text.html 中 Object 的使用

javax.swing.text.html 中 Object 的子类

class

BlockView
用来显示具有 CSS 规范的块（作为一个框）的视图实现。

class

CSS
将 CSS attributes 集定义为类型安全的枚举。

static class

CSS.Attribute
用作 AttributeSet 的键的定义，此属性集可存储 CSS 属性。

class

FormSubmitEvent
FormSubmitEvent 用于通知提交表单所需的参与者。

class

FormView
实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。

protected  class

FormView.MouseEventListener
当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。

class

HTML
HTMLDocument 中使用的常量。

static class

HTML.Attribute
表示 HTML 属性的类型安全的枚举。

static class

HTML.Tag
HTML 标记的类型安全的枚举。

static class

HTML.UnknownTag

class

HTMLDocument
对 HTML 进行建模的文档。

class

HTMLDocument.BlockElement
表示结构性 HTML 块 的元素。

class

HTMLDocument.HTMLReader
一个 HTML reader，用来加载具有 HTML 元素结构的 HTML 文档。

class

HTMLDocument.HTMLReader.BlockAction

class

HTMLDocument.HTMLReader.CharacterAction

class

HTMLDocument.HTMLReader.FormAction
此动作通过构建所有用于表示表单控件的元素来支持表单。

class

HTMLDocument.HTMLReader.HiddenAction

class

HTMLDocument.HTMLReader.IsindexAction

class

HTMLDocument.HTMLReader.ParagraphAction

class

HTMLDocument.HTMLReader.PreAction

class

HTMLDocument.HTMLReader.SpecialAction

class

HTMLDocument.HTMLReader.TagAction
为响应对标记的解析而执行的动作。

static class

HTMLDocument.Iterator
对特定类型的标记进行迭代的迭代器。

class

HTMLDocument.RunElement
表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

class

HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。

static class

HTMLEditorKit.HTMLFactory
用于构建 HTML 视图的工厂。

static class

HTMLEditorKit.HTMLTextAction
提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。

static class

HTMLEditorKit.InsertHTMLTextAction
InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

static class

HTMLEditorKit.LinkController
此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

static class

HTMLEditorKit.Parser
解析器要支持的接口。

static class

HTMLEditorKit.ParserCallback
解析结果驱动这些回调方法。

class

HTMLFrameHyperlinkEvent
HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。

class

HTMLWriter
这是用于 HTMLDocuments 的 writer。

class

ImageView
图像视图，用于支持 HTML <IMG> 标记。

class

InlineView
显示基于 css 属性的 inline element 样式。

class

ListView
用于显示 html 列表的视图实现。

class

MinimalHTMLWriter
MinimalHTMLWriter 是一个回退 writer，HTMLEditorKit 使用它为非 EditorKit 生成的文档写出 HTML。

class

ObjectView
实现 <object> 元素视图接口的组件装饰符。

class

Option
用来表示 <option> 元素的 ListModel 值。

class

StyleSheet
支持定义要呈现的 HTML 视图的可视化特征。

static class

StyleSheet.BoxPainter
可以执行某些 CSS 格式化任务的类。

static class

StyleSheet.ListPainter
要执行某些 CSS 列表格式化任务的类。

声明为 Object 的 javax.swing.text.html 中的字段

static Object

HTMLEditorKit.ParserCallback.IMPLIED
这是作为属性集中的一个属性来传递的，用来指示元素是隐含的，例如字符串 '<>foo<\t>' 包含隐含的 html 元素和隐含的正文元素。

返回 Object 的 javax.swing.text.html 中的方法

Object

HTMLEditorKit.clone()
创建编辑器工具包的一个副本。

参数类型为 Object 的 javax.swing.text.html 中的方法

AttributeSet

StyleSheet.addAttribute(AttributeSet old, Object key, Object value)
向给定集合添加属性，并返回新的表示方式的集合。

boolean

HTML.UnknownTag.equals(Object obj)
将此对象与指定对象进行比较。

Element

HTMLDocument.getElement(Element e, Object attribute, Object value)
返回 e（它包含具有值 value 的属性 attribute）的子元素，如果未找到，则返回 null。

AttributeSet

StyleSheet.removeAttribute(AttributeSet old, Object key)
从集合中移除属性。

参数类型为 Object 的 javax.swing.text.html 中的构造方法

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
创建一个表示 html 框架超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
创建一个表示超文本链接事件的新对象。

javax.swing.text.html.parser 中 Object 的使用

javax.swing.text.html.parser 中 Object 的子类

class

AttributeList
此类使用 ATTLIST 构造定义 DTD 中描述的 SGML 元素的属性。

class

ContentModel
内容模式的表示形式。

class

DocumentParser
HTML 文档的解析器 (Parser)（实际上，您可以指定一个 DTD，但实际上仅应将此类与 swing 中的 html dtd 一起使用）。

class

DTD
SGML DTD 的表示形式。

class

Element
使用 ELEMENT 构造在 DTD 中描述的一个元素。

class

Entity
使用 ENTITY 构造在 DTD 中描述了一个实体。

class

Parser
一个简单的 DTD 驱动的 HTML 解析器。

class

ParserDelegator
负责每次在调用其 parse 方法时启动一个新的 DocumentParser。

class

TagElement
一般的 HTML TagElement 类。

声明为 Object 的 javax.swing.text.html.parser 中的字段

Object

ContentModel.content
内容。

Object

Element.data
存储用户数据的字段。

类型参数类型为 Object 的 javax.swing.text.html.parser 中的字段

Hashtable<Object,Entity>

DTD.entityHash

参数类型为 Object 的 javax.swing.text.html.parser 中的方法

protected  ContentModel

DTD.defContentModel(int type, Object obj, ContentModel next)
创建并返回一个新的内容模式。

boolean

ContentModel.first(Object token)
如果标记可能为输入流中第一个标记，则返回 true。

参数类型为 Object 的 javax.swing.text.html.parser 中的构造方法

ContentModel(int type, Object content, ContentModel next)
创建一个特定类型的内容模式。

javax.swing.text.rtf 中 Object 的使用

javax.swing.text.rtf 中 Object 的子类

class

RTFEditorKit
这是对 RTF 编辑功能的默认实现。

javax.swing.tree 中 Object 的使用

javax.swing.tree 中 Object 的子类

class

AbstractLayoutCache
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

AbstractLayoutCache.NodeDimensions
由 AbstractLayoutCache 使用，用于确定特定节点的大小和 x 原点。

class

DefaultMutableTreeNode
DefaultMutableTreeNode 是树数据结构中的通用节点。

class

DefaultTreeCellEditor
TreeCellEditor。

class

DefaultTreeCellEditor.DefaultTextField
不提供任何编辑器时所使用的 TextField。

class

DefaultTreeCellEditor.EditorContainer
负责存放 editingComponent 的容器。

class

DefaultTreeCellRenderer
显示树中的条目。

class

DefaultTreeModel
使用 TreeNodes 的简单树数据模型。

class

DefaultTreeSelectionModel
TreeSelectionModel 的默认实现。

class

ExpandVetoException
用于阻止扩展/折叠发生的异常。

class

FixedHeightLayoutCache
注：在以后的版本中，这将变得更加开放。

class

TreePath
表示节点的路径。

class

VariableHeightLayoutCache
注：在以后的版本中，此类将变得更加开放。

声明为 Object 的 javax.swing.tree 中的字段

protected  Object

DefaultMutableTreeNode.userObject
可选用户对象

返回 Object 的 javax.swing.tree 中的方法

Object

DefaultMutableTreeNode.clone()
重写以复制 public。

Object

DefaultTreeSelectionModel.clone()
返回具有相同 selection 的此对象的副本。

Object

DefaultTreeCellEditor.getCellEditorValue()
返回当前正在编辑的值。

Object

DefaultTreeModel.getChild(Object parent, int index)
返回父节点的子节点数组中索引 index 处的 parent 的子节点。

Object

TreeModel.getChild(Object parent, int index)
返回父节点的子数组中索引 index 位置的 parent 的子节点。

Object

TreePath.getLastPathComponent()
返回此路径的最后一个组件。

Object[]

TreePath.getPath()
返回有序的 Objects 数组，它包含此 TreePath 的组件。

Object

TreePath.getPathComponent(int element)
返回指定索引位置的路径组件。

Object

DefaultTreeModel.getRoot()
返回树的根。

Object

TreeModel.getRoot()
返回树的根。

Object

DefaultMutableTreeNode.getUserObject()
返回此节点的用户对象。

Object[]

DefaultMutableTreeNode.getUserObjectPath()
返回从根到达此节点的路径。

参数类型为 Object 的 javax.swing.tree 中的方法

protected  void

DefaultTreeCellEditor.determineOffset(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)

boolean

TreePath.equals(Object o)
通过检查路径中每个元素的相等性，测试两个 TreePaths 的相等性。

protected  void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

protected  void

DefaultTreeModel.fireTreeNodesChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesInserted(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesInserted(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesInserted(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesRemoved(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesRemoved(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesRemoved(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeStructureChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeStructureChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeStructureChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

Object

DefaultTreeModel.getChild(Object parent, int index)
返回父节点的子节点数组中索引 index 处的 parent 的子节点。

Object

TreeModel.getChild(Object parent, int index)
返回父节点的子数组中索引 index 位置的 parent 的子节点。

int

DefaultTreeModel.getChildCount(Object parent)
返回 parent 的子节点数。

int

TreeModel.getChildCount(Object parent)
返回 parent 的子节点数。

int

DefaultTreeModel.getIndexOfChild(Object parent, Object child)
返回父节点中子节点的索引。

int

TreeModel.getIndexOfChild(Object parent, Object child)
返回父节点中子节点的索引。

protected  Rectangle

AbstractLayoutCache.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle placeIn)
返回通过 placeIn 中的引用，表示 value 所需的大小。

abstract  Rectangle

AbstractLayoutCache.NodeDimensions.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle bounds)
通过对 bounds 的引用，返回用于保存值的节点的大小和其在 x 轴上的起点。

Component

DefaultTreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
配置编辑器。

Component

TreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
设置编辑器的初始值。

Component

DefaultTreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus)
配置基于传入组件的渲染器。

Component

TreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
将当前树单元格的值设置为 value。

boolean

DefaultTreeModel.isLeaf(Object node)
返回指定的节点是否为叶节点。

boolean

TreeModel.isLeaf(Object node)
如果 node 为叶节点，则返回 true。

void

DefaultTreeModel.nodesWereRemoved(TreeNode node, int[] childIndices, Object[] removedChildren)
从节点移除一些 TreeNodes 之后，调用此方法。

TreePath

TreePath.pathByAddingChild(Object child)
返回包含此对象的所有元素加上 child 的新路径。

void

DefaultMutableTreeNode.setUserObject(Object userObject)
将此节点的用户对象设置为 userObject。

void

MutableTreeNode.setUserObject(Object object)
将接收者的用户对象重新设置为 object。

void

DefaultTreeModel.valueForPathChanged(TreePath path, Object newValue)
此方法设置由路径标识的 TreeNode 的用户对象，并发送更改的节点。

void

TreeModel.valueForPathChanged(TreePath path, Object newValue)
用户已将 path 标识的项的值更改为 newValue 时，进行通知。

参数类型为 Object 的 javax.swing.tree 中的构造方法

DefaultMutableTreeNode(Object userObject)
创建没有父节点和子节点、但允许有子节点的树节点，并使用指定的用户对象对它进行初始化。

DefaultMutableTreeNode(Object userObject, boolean allowsChildren)
创建没有父节点和子节点的树节点，使用指定的用户对象对它进行初始化，仅在指定时才允许有子节点。

TreePath(Object singlePath)
构造仅包含单个元素的 TreePath。

TreePath(Object[] path)
根据 Objects 的数组构造路径，并根据树的数据模型的返回情况，唯一地标识树的根到指定节点的路径。

TreePath(Object[] path, int length)
构造一个具有长度为 length 的标识路径组件的新 TreePath。

TreePath(TreePath parent, Object lastElement)
构造一个新的 TreePath，它是以 lastElement 结束的 parent 标识的路径。

javax.swing.undo 中 Object 的使用

javax.swing.undo 中 Object 的子类

class

AbstractUndoableEdit
UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。

class

CannotRedoException
当 UndoableEdit 被通知 redo() 但无法执行时抛出。

class

CannotUndoException
当 UndoableEdit 被通知 undo() 但无法执行时抛出。

class

CompoundEdit
AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。

class

StateEdit
StateEdit 是更改状态的对象的通用编辑。

class

UndoableEditSupport
用于管理 UndoableEdit 侦听器的支持类。

class

UndoManager
UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

声明为 Object 的 javax.swing.undo 中的字段

protected  Object

UndoableEditSupport.realSource

类型参数类型为 Object 的 javax.swing.undo 中的字段

protected  Hashtable<Object,Object>

StateEdit.postState
编辑之后的状态信息

protected  Hashtable<Object,Object>

StateEdit.postState
编辑之后的状态信息

protected  Hashtable<Object,Object>

StateEdit.preState
编辑之前的状态信息

protected  Hashtable<Object,Object>

StateEdit.preState
编辑之前的状态信息

类型变量类型为 Object 的 javax.swing.undo 中的方法参数

void

StateEditable.storeState(Hashtable<Object,Object> state)
收到此消息时，接收者应把任何相关状态放置到 state 中。

void

StateEditable.storeState(Hashtable<Object,Object> state)
收到此消息时，接收者应把任何相关状态放置到 state 中。

参数类型为 Object 的 javax.swing.undo 中的构造方法

UndoableEditSupport(Object r)
构造一个 UndoableEditSupport 对象。

javax.tools 中 Object 的使用

javax.tools 中 Object 的子类

class

DiagnosticCollector<S>
提供将诊断收集到一个列表中的简单方法。

class

ForwardingFileObject<F extends FileObject>
将调用转发到给定的文件对象。

class

ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

class

ForwardingJavaFileObject<F extends JavaFileObject>
将调用转发到给定的文件对象。

class

SimpleJavaFileObject
为 JavaFileObject 中的大多数方法提供简单实现。

class

ToolProvider
为查找工具提供者提供方法，例如，编译器的提供者。

javax.transaction 中 Object 的使用

javax.transaction 中 Object 的子类

class

InvalidTransactionException
此异常指示该请求带来了无效的事务上下文。

class

TransactionRequiredException
此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。

class

TransactionRolledbackException
此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

javax.transaction.xa 中 Object 的使用

javax.transaction.xa 中 Object 的子类

class

XAException
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。

javax.xml 中 Object 的使用

javax.xml 中 Object 的子类

class

XMLConstants
包含基本 XML 值作为常量的实用工具类。

javax.xml.bind 中 Object 的使用

javax.xml.bind 中 Object 的子类

class

Binder<XmlNode>
在 XML 信息集节点和表示相同 XML 文档的 JAXB 对象之间启用同步。

class

DatatypeConverter
可以使用 javaType 绑定声明来自定义 XML 模式数据类型到 Java 数据类型的绑定。

class

JAXBContext
JAXBContext 类提供到 JAXB API 的客户端入口点。

class

JAXBElement<T>
Xml 元素的 JAXB 表示形式。

static class

JAXBElement.GlobalScope
为 xml 元素指定全局作用域。

class

JAXBException
这是所有 JAXB 异常的根异常类。

class

JAXBIntrospector
提供对 JAXB 对象的 JAXB xml 绑定数据的访问。

static class

Marshaller.Listener

向 Marshaller 注册此类的一个实现的实例，以从外部侦听编组事件。

class

PropertyException
此异常指示在获取或设置属性时遇到一个错误。

class

SchemaOutputResolver
控制 JAXB 实现放置生成的模式文件的位置。

class

TypeConstraintException
此异常指示已检测到存在违反动态检查的类型约束的情况。

static class

Unmarshaller.Listener

向 Unmarshaller 注册此类的一个实现的实例，以便外部侦听解组事件。

class

ValidationException
此异常指示在执行验证操作时发生错误。

声明为 Object 的 javax.xml.bind 中的字段

protected  T

JAXBElement.value
xml 元素值。

返回 Object 的 javax.xml.bind 中的方法

abstract  Object

Binder.getJAXBNode(XmlNode xmlNode)
获取与给定 XML 元素关联的 JAXB 对象。

Object

ValidationEventLocator.getObject()
返回对 Java 内容树中对象的引用（如果可用）。

abstract  Object

Binder.getProperty(String name)
获取 Binder 的基础实现中的特定属性。

Object

Marshaller.getProperty(String name)
获取 Marshaller 底层实现中的特定属性。

Object

Unmarshaller.getProperty(String name)
获取 Unmarshaller 底层实现中的特定属性。

Object

Validator.getProperty(String name)
已过时。 从 JAXB2.0 开始

Object

UnmarshallerHandler.getResult()
获得解组的结果。

static Object

JAXBIntrospector.getValue(Object jaxbElement)
获取 JAXB 元素的元素值。

Object

Unmarshaller.unmarshal(File f)
从指定的文件解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(InputSource source)
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(InputStream is)
从指定的 InputStream 解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(Node node)
从指定的 DOM 树解组全局 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(Reader reader)
从指定的 Reader 解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(Source source)
从指定的 XML Source 解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(URL url)
从指定的 URL 解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(XMLEventReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。

abstract  Object

Binder.unmarshal(XmlNode xmlNode)
将 XML 信息集视图解组为 JAXB 对象树。

Object

Unmarshaller.unmarshal(XMLStreamReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。

abstract  Object

Binder.updateJAXB(XmlNode xmlNode)
取一个 XML 节点，并更新与其关联的 JAXB 对象和该对象的子级。

参数类型为 Object 的 javax.xml.bind 中的方法

void

Marshaller.Listener.afterMarshal(Object source)

将 source 编组到 XML 之后调用的回调方法。

void

Unmarshaller.Listener.afterUnmarshal(Object target, Object parent)

将 XML 数据解组到 target 之后调用的回调方法。

void

Marshaller.Listener.beforeMarshal(Object source)

从 source 编组到 XML 之前调用的回调方法。

void

Unmarshaller.Listener.beforeUnmarshal(Object target, Object parent)

在解组到 target 之前调用的回调方法。

abstract  QName

JAXBIntrospector.getElementName(Object jaxbElement)
获取 jaxbElement 的 xml 元素 qname。

Node

Marshaller.getNode(Object contentTree)
获取内容树的 DOM 树视图（可选）。

static Object

JAXBIntrospector.getValue(Object jaxbElement)
获取 JAXB 元素的元素值。

abstract  XmlNode

Binder.getXMLNode(Object jaxbObject)
获取与给定 JAXB 对象关联的 XML 元素。

abstract  boolean

JAXBIntrospector.isElement(Object object)
如果 object 表示一个 JAXB 元素，则返回 true。

void

Marshaller.marshal(Object jaxbElement, ContentHandler handler)
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。

void

Marshaller.marshal(Object jaxbElement, Node node)
将以 jaxbElement 为根的内容树编组到 DOM 树中。

void

Marshaller.marshal(Object jaxbElement, OutputStream os)
将以 jaxbElement 为根的内容树编组到输出流中。

void

Marshaller.marshal(Object jaxbElement, Result result)
将以 jaxbElement 为根的内容树编组到指定的 javax.xml.transform.Result 中。

void

Marshaller.marshal(Object jaxbElement, Writer writer)
将以 jaxbElement 为根的内容树编组到 Writer 中。

void

Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。

abstract  void

Binder.marshal(Object jaxbObject, XmlNode xmlNode)
将 JAXB 对象树编组为新的 XML 文档。

void

Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。

abstract  void

Binder.setProperty(String name, Object value)
设置 Binder 的基础实现中的特定属性。

void

Marshaller.setProperty(String name, Object value)
设置 Marshaller 底层实现中的特定属性。

void

Unmarshaller.setProperty(String name, Object value)
设置 Unmarshaller 底层实现中的特定属性。

void

Validator.setProperty(String name, Object value)
已过时。 从 JAXB2.0 开始

abstract  XmlNode

Binder.updateXML(Object jaxbObject)
取一个 JAXB 对象，并更新与其关联的 XML 节点和该节点的子级。

abstract  XmlNode

Binder.updateXML(Object jaxbObject, XmlNode xmlNode)
JAXB 对象树中所做的更改在与其关联的 XML 解析树中得到更新。

boolean

Validator.validate(Object subrootObj)
已过时。 从 JAXB2.0 开始

boolean

Validator.validateRoot(Object rootObj)
已过时。 从 JAXB2.0 开始

参数类型为 Object 的 javax.xml.bind 中的构造方法

PropertyException(String name, Object value)
构造一个基于属性名称和 value.toString() 设置其消息字段的 PropertyException。

javax.xml.bind.annotation 中 Object 的使用

javax.xml.bind.annotation 中 Object 的子类

class

W3CDomHandler
W3C DOM（org.w3c.dom 包）的 DomHandler 实现。

static class

XmlElement.DEFAULT
在 XmlElement.type() 中使用，用于表示根据属性签名推断出来的类型。

static class

XmlElementDecl.GLOBAL
在 XmlElementDecl.scope() 中使用，指示声明是全局范围的。

static class

XmlElementRef.DEFAULT
在 XmlElementRef.type() 中使用，用于表示根据属性签名推断出来的类型。

static class

XmlSchemaType.DEFAULT
在 XmlSchemaType.type() 中使用，用于表示根据属性签名推断出来的类型。

static class

XmlType.DEFAULT
在 XmlType.factoryClass() 中使用，指示工厂方法未被使用或者在具有此 XmlType 的类中。

javax.xml.bind.annotation.adapters 中 Object 的使用

javax.xml.bind.annotation.adapters 中 Object 的子类

class

CollapsedStringAdapter
用来处理 xs:token 及其派生类型的内置 XmlAdapter。

class

HexBinaryAdapter
xs:hexBinary 的 XmlAdapter。

class

NormalizedStringAdapter
处理 xs:normalizedString 的 XmlAdapter。

class

XmlAdapter<ValueType,BoundType>
修改 Java 类型以适应自定义编组。

static class

XmlJavaTypeAdapter.DEFAULT
此类在 XmlJavaTypeAdapter.type() 中使用，用来表示从字段、属性、参数或类的签名推导出的类型。

javax.xml.bind.attachment 中 Object 的使用

javax.xml.bind.attachment 中 Object 的子类

class

AttachmentMarshaller
启用 JAXB 编组来优化二进制数据存储。

class

AttachmentUnmarshaller
启用包含优化的二进制数据格式的根文档的 JAXB 解组。

javax.xml.bind.helpers 中 Object 的使用

javax.xml.bind.helpers 中 Object 的子类

class

AbstractMarshallerImpl
部分默认 Marshaller 实现。

class

AbstractUnmarshallerImpl
部分默认 Unmarshaller 实现。

class

DefaultValidationEventHandler
唯一的 JAXB 1.0 默认验证事件处理程序。

class

NotIdentifiableEventImpl
NotIdentifiableEvent 接口的默认实现。

class

ParseConversionEventImpl
ParseConversionEvent 接口的默认实现。

class

PrintConversionEventImpl
PrintConversionEvent 接口的默认实现。

class

ValidationEventImpl
ValidationEvent 接口的默认实现。

class

ValidationEventLocatorImpl
ValidationEventLocator 接口的默认实现。

返回 Object 的 javax.xml.bind.helpers 中的方法

Object

ValidationEventLocatorImpl.getObject()

Object

AbstractMarshallerImpl.getProperty(String name)
getProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。

Object

AbstractUnmarshallerImpl.getProperty(String name)
由于没有必需的属性，getProperty 方法的默认实现总是抛出 PropertyException。

Object

AbstractUnmarshallerImpl.unmarshal(File f)

Object

AbstractUnmarshallerImpl.unmarshal(InputSource source)

Object

AbstractUnmarshallerImpl.unmarshal(InputStream is)

Object

AbstractUnmarshallerImpl.unmarshal(Reader reader)

Object

AbstractUnmarshallerImpl.unmarshal(Source source)

Object

AbstractUnmarshallerImpl.unmarshal(URL url)

Object

AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)

protected abstract  Object

AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
使用指定的 XMLReader 和 InputSource 解组对象。

Object

AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)

参数类型为 Object 的 javax.xml.bind.helpers 中的方法

Node

AbstractMarshallerImpl.getNode(Object obj)
默认情况下，getNode 方法不受支持并抛出 UnsupportedOperationException。

void

AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)

void

AbstractMarshallerImpl.marshal(Object obj, Node node)

void

AbstractMarshallerImpl.marshal(Object obj, OutputStream os)

void

AbstractMarshallerImpl.marshal(Object obj, Writer w)

void

AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)

void

AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)

void

ValidationEventLocatorImpl.setObject(Object _object)
在此事件定位符上设置 Object 字段。

void

AbstractMarshallerImpl.setProperty(String name, Object value)
setProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。

void

AbstractUnmarshallerImpl.setProperty(String name, Object value)
由于没有必需的属性，setProperty 方法的默认实现总是抛出 PropertyException。

参数类型为 Object 的 javax.xml.bind.helpers 中的构造方法

ValidationEventLocatorImpl(Object _object)
构造一个指向 JAXB 内容对象的对象。

javax.xml.bind.util 中 Object 的使用

javax.xml.bind.util 中 Object 的子类

class

JAXBResult
解组 JAXB 对象的 JAXP Result 实现。

class

JAXBSource
编组 JAXB 生成的对象的 JAXP Source 实现。

class

ValidationEventCollector
收集所有事件的 ValidationEventHandler 实现。

返回 Object 的 javax.xml.bind.util 中的方法

Object

JAXBResult.getResult()
获取通过转换创建的已解组对象。

参数类型为 Object 的 javax.xml.bind.util 中的构造方法

JAXBSource(JAXBContext context, Object contentObject)
针对给定的内容对象创建一个新 Source。

JAXBSource(Marshaller marshaller, Object contentObject)
针对给定的内容对象创建一个新 Source。

javax.xml.crypto 中 Object 的使用

javax.xml.crypto 中 Object 的子类

class

KeySelector
一个选择器，可使用 KeyInfo 对象中包含的数据查找并返回某个密钥。

static class

KeySelector.Purpose
将被选中的密钥的用途。

class

KeySelectorException
指示由 KeySelector 抛出的异常条件。

class

MarshalException
指示 XML 编组或解组过程中发生的异常条件。

class

NoSuchMechanismException
当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。

class

OctetStreamData
包含一个八位组流的 Data 类型的表示形式。

class

URIReferenceException
指示取消引用 URIReference 时抛出的异常条件。

返回 Object 的 javax.xml.crypto 中的方法

Object

XMLCryptoContext.get(Object key)
返回此上下文将指定键映射到的值。

Object

XMLCryptoContext.getProperty(String name)
返回指定属性的值。

Object

XMLCryptoContext.put(Object key, Object value)
将指定值与此上下文中的指定键关联。

Object

XMLCryptoContext.setProperty(String name, Object value)
设置指定的属性。

参数类型为 Object 的 javax.xml.crypto 中的方法

Object

XMLCryptoContext.get(Object key)
返回此上下文将指定键映射到的值。

Object

XMLCryptoContext.put(Object key, Object value)
将指定值与此上下文中的指定键关联。

Object

XMLCryptoContext.setProperty(String name, Object value)
设置指定的属性。

javax.xml.crypto.dom 中 Object 的使用

javax.xml.crypto.dom 中 Object 的子类

class

DOMCryptoContext
此类提供 XMLCryptoContext 接口特定于 DOM 的实现。

class

DOMStructure
特定于 DOM 的 XMLStructure。

返回 Object 的 javax.xml.crypto.dom 中的方法

Object

DOMCryptoContext.get(Object key)
此实现使用内部 HashMap 获取指定键所映射的对象。

Object

DOMCryptoContext.getProperty(String name)
此实现使用内部 HashMap 获取指定名称所映射的对象。

Object

DOMCryptoContext.put(Object key, Object value)
此实现使用内部 HashMap 将键映射到指定的对象。

Object

DOMCryptoContext.setProperty(String name, Object value)
此实现使用内部 HashMap 将名称映射到指定对象。

参数类型为 Object 的 javax.xml.crypto.dom 中的方法

Object

DOMCryptoContext.get(Object key)
此实现使用内部 HashMap 获取指定键所映射的对象。

Object

DOMCryptoContext.put(Object key, Object value)
此实现使用内部 HashMap 将键映射到指定的对象。

Object

DOMCryptoContext.setProperty(String name, Object value)
此实现使用内部 HashMap 将名称映射到指定对象。

javax.xml.crypto.dsig 中 Object 的使用

javax.xml.crypto.dsig 中 Object 的子类

class

TransformException
指示执行转换算法时出现异常的异常条件。

class

TransformService
转换算法和规范算法的服务提供者接口。

class

XMLSignatureException
指示生成或验证 XML 签名过程中发生的异常条件。

class

XMLSignatureFactory
用于从头创建 XMLSignature 对象或从相应的 XML 表示形式解组 XMLSignature 对象的工厂。

javax.xml.crypto.dsig.dom 中 Object 的使用

javax.xml.crypto.dsig.dom 中 Object 的子类

class

DOMSignContext
特定于 DOM 的 XMLSignContext。

class

DOMValidateContext
特定于 DOM 的 XMLValidateContext。

javax.xml.crypto.dsig.keyinfo 中 Object 的使用

javax.xml.crypto.dsig.keyinfo 中 Object 的子类

class

KeyInfoFactory
用于从头创建 KeyInfo 对象或从相应的 XML 表示形式解组 KeyInfo 对象的工厂。

javax.xml.crypto.dsig.spec 中 Object 的使用

javax.xml.crypto.dsig.spec 中 Object 的子类

class

ExcC14NParameterSpec
W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。

class

HMACParameterSpec
XML Signature HMAC Algorithm 的参数。

class

XPathFilter2ParameterSpec
W3C Recommendation XPath Filter 2.0 Transform Algorithm 的参数。

class

XPathFilterParameterSpec
XPath Filtering Transform Algorithm 的参数。

class

XPathType
W3C Recommendation for XML-Signature XPath Filter 2.0 中所定义的 XPath 元素的 XML 模式定义：

static class

XPathType.Filter
表示过滤器设置操作。

class

XSLTTransformParameterSpec
XSLT Transform Algorithm 的参数。

javax.xml.datatype 中 Object 的使用

javax.xml.datatype 中 Object 的子类

class

DatatypeConfigurationException
指示严重的配置错误。

class

DatatypeConstants
包含基本 Datatype 值作为常量的实用工具类。

static class

DatatypeConstants.Field
类型安全的枚举类，它表示 Duration 类的六个字段。

class

DatatypeFactory
创建新 javax.xml.datatype Object 的工厂，创建的对象可提供 XML 和 Java Object 之间的映射。

class

Duration
W3C XML 模式 1.0 规范中定义的时间范围的不可变表示形式。

class

XMLGregorianCalendar
W3C XML 模式 1.0 日期/时间数据类型的表示形式。

返回 Object 的 javax.xml.datatype 中的方法

abstract  Object

XMLGregorianCalendar.clone()
创建并返回此对象的一个副本。

参数类型为 Object 的 javax.xml.datatype 中的方法

boolean

Duration.equals(Object duration)
检查此持续时间对象是否与另一个 Duration 对象具有相同的持续时间。

boolean

XMLGregorianCalendar.equals(Object obj)
将此日历与指定的对象进行比较。

javax.xml.namespace 中 Object 的使用

javax.xml.namespace 中 Object 的子类

class

QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

参数类型为 Object 的 javax.xml.namespace 中的方法

boolean

QName.equals(Object objectToTest)
测试此 QName 与另一个 Object 的相等性。

javax.xml.parsers 中 Object 的使用

javax.xml.parsers 中 Object 的子类

class

DocumentBuilder
定义 API， 使其从 XML 文档获取 DOM 文档实例。

class

DocumentBuilderFactory
定义工厂 API，使应用程序能够从 XML 文档获取生成 DOM 对象树的解析器。

class

FactoryConfigurationError
当解析器工厂的配置存在问题时抛出该异常。

class

ParserConfigurationException
指示一个严重的配置错误。

class

SAXParser
定义包装 XMLReader 实现类的 API。

class

SAXParserFactory
定义工厂 API，使应用程序能够配置和获取基于 SAX 的解析器以解析 XML 文档。

返回 Object 的 javax.xml.parsers 中的方法

abstract  Object

DocumentBuilderFactory.getAttribute(String name)
允许用户在底层实现上检索特定属性。

abstract  Object

SAXParser.getProperty(String name)
返回 XMLReader 的底层实现中请求的特定属性。

参数类型为 Object 的 javax.xml.parsers 中的方法

abstract  void

DocumentBuilderFactory.setAttribute(String name, Object value)
允许用户在底层实现上设置特定属性。

abstract  void

SAXParser.setProperty(String name, Object value)
设置 XMLReader 的底层实现中的特定属性。

javax.xml.soap 中 Object 的使用

javax.xml.soap 中 Object 的子类

class

AttachmentPart
SOAPMessage 对象的一个附件。

class

MessageFactory
创建 SOAPMessage 对象的工厂。

class

MimeHeader
存储 MIME 头名称及其值的对象。

class

MimeHeaders
MimeHeader 对象的容器，这些对象表示出现在消息的 MIME 部分的 MIME 头。

class

SAAJMetaFactory
SAAJ API 中定义的工厂实现类的访问点。

class

SAAJResult
以 SAAJ 树的形式，充当 JAXP 转换或 JAXB 编组结果的持有者。

class

SOAPConnection
客户端可以用于直接将消息发送到（例如，用 URL 表示的）远程方的点对点连接。

class

SOAPConnectionFactory
创建 SOAPConnection 对象的工厂。

class

SOAPElementFactory
已过时。 - 使用 javax.xml.soap.SOAPFactory 创建 SOAPElements。

class

SOAPException
当发生 SOAP 异常时，抛出此异常。

class

SOAPFactory
SOAPFactory 是用来创建存在于 SOAP XML 树中的各种对象的工厂。

class

SOAPMessage
所有 SOAP 消息的根类。

class

SOAPPart
SOAPMessage 对象中特定于 SOAP 部分的容器。

返回 Object 的 javax.xml.soap 中的方法

abstract  Object

AttachmentPart.getContent()
以 Java 对象的形式获取此 AttachmentPart 对象的内容。

Object

SOAPMessage.getProperty(String property)
检索指定属性的值。

参数类型为 Object 的 javax.xml.soap 中的方法

abstract  SOAPMessage

SOAPConnection.call(SOAPMessage request, Object to)
将给定消息发送到指定端点，在返回应答前将一直阻塞。

AttachmentPart

SOAPMessage.createAttachmentPart(Object content, String contentType)
创建 AttachmentPart 对象并使用指定内容类型的指定数据填充。

SOAPMessage

SOAPConnection.get(Object to)
从特定端点获取消息，在收到消息前将一直阻塞。

abstract  void

AttachmentPart.setContent(Object object, String contentType)
将此附件部分的内容设置为给定 Object 的内容，并将 Content-Type 头的值设置为给定类型。

void

SOAPMessage.setProperty(String property, Object value)
将指定值与指定属性关联。

javax.xml.stream 中 Object 的使用

javax.xml.stream 中 Object 的子类

class

XMLEventFactory
此接口定义一个创建 XMLEvent 实例的实用工具类。

class

XMLInputFactory
定义用于获取流的工厂的抽象实现。

class

XMLOutputFactory
定义用于获取 XMLEventWriter 和 XMLStreamWriter 的工厂抽象实现。

class

XMLStreamException
用于不可预料处理错误的基本异常。

返回 Object 的 javax.xml.stream 中的方法

Object

XMLEventReader.getProperty(String name)
从底层实现获取功能/属性值。

abstract  Object

XMLInputFactory.getProperty(String name)
从底层实现获取功能/属性的值。

abstract  Object

XMLOutputFactory.getProperty(String name)
获取底层实现上的功能/属性

Object

XMLStreamReader.getProperty(String name)
从底层实现获取功能/属性的值

Object

XMLStreamWriter.getProperty(String name)
从底层实现获取功能/属性值

Object

XMLResolver.resolveEntity(String publicID, String systemID, String baseURI, String namespace)
检索资源。

参数类型为 Object 的 javax.xml.stream 中的方法

void

XMLReporter.report(String message, String errorType, Object relatedInformation, Location location)
以特定于应用程序的格式报告所需消息。

abstract  void

XMLInputFactory.setProperty(String name, Object value)
允许用户在底层实现上设置特定功能/属性。

abstract  void

XMLOutputFactory.setProperty(String name, Object value)
允许用户在底层实现上设置特定功能/属性。

javax.xml.stream.events 中 Object 的使用

返回 Object 的 javax.xml.stream.events 中的方法

Object

DTD.getProcessedDTD()
返回定义 DTD 表示形式的实现。

javax.xml.stream.util 中 Object 的使用

javax.xml.stream.util 中 Object 的子类

class

EventReaderDelegate
该类是用于派生 XMLEventReader 过滤器的基类。

class

StreamReaderDelegate
该类是用于派生 XMLStreamReader 过滤器的基类。

返回 Object 的 javax.xml.stream.util 中的方法

Object

EventReaderDelegate.getProperty(String name)

Object

StreamReaderDelegate.getProperty(String name)

Object

EventReaderDelegate.next()

javax.xml.transform 中 Object 的使用

javax.xml.transform 中 Object 的子类

class

OutputKeys
提供可用于设置 Transformer 的输出属性或从 Transformer 或 Templates 对象检索输出属性的字符串常量。

class

Transformer
此抽象类的实例能够将源树转换为结果树。

class

TransformerConfigurationException
指示严重的配置错误。

class

TransformerException
此类指定了转换过程中发生的异常条件。

class

TransformerFactory
TransformerFactory 实例可用于创建 Transformer 和 Templates 对象。

class

TransformerFactoryConfigurationError
当通过 Transformer Factories 进行的配置存在问题时抛出此异常。

返回 Object 的 javax.xml.transform 中的方法

abstract  Object

TransformerFactory.getAttribute(String name)
允许用户在底层实现上检索指定属性。

abstract  Object

Transformer.getParameter(String name)
获取通过 setParameter 显式设置的参数。

参数类型为 Object 的 javax.xml.transform 中的方法

abstract  void

TransformerFactory.setAttribute(String name, Object value)
允许用户设置底层实现上的指定属性。

abstract  void

Transformer.setParameter(String name, Object value)
添加一个转换参数。

javax.xml.transform.dom 中 Object 的使用

javax.xml.transform.dom 中 Object 的子类

class

DOMResult
以 Document Object Model（DOM）树的形式充当转换结果树的持有者。

class

DOMSource
以 Document Object Model（DOM）树的形式充当转换 Source 树的持有者。

javax.xml.transform.sax 中 Object 的使用

javax.xml.transform.sax 中 Object 的子类

class

SAXResult
充当转换 Result 的持有者。

class

SAXSource
充当 SAX 样式 Source 的持有者。

class

SAXTransformerFactory
此类扩展了 TransformerFactory 以提供特定于 SAX 的工厂方法。

javax.xml.transform.stax 中 Object 的使用

javax.xml.transform.stax 中 Object 的子类

class

StAXResult
以 StAX writer 的形式（即 XMLStreamWriter 或 XMLEventWriter）充当 XML Result 的持有者。

class

StAXSource
以 StAX reader 的形式（即 XMLStreamReader 或 XMLEventReader）充当 XML Source 的持有者。

javax.xml.transform.stream 中 Object 的使用

javax.xml.transform.stream 中 Object 的子类

class

StreamResult
充当转换结果的持有者，可以为 XML、纯文本、HTML 或某些其他格式的标记。

class

StreamSource
以 XML 标记流的形式充当转换 Source 的持有者。

javax.xml.validation 中 Object 的使用

javax.xml.validation 中 Object 的子类

class

Schema
不可变的语法存储表示形式。

class

SchemaFactory
创建 Schema 对象的工厂。

class

SchemaFactoryLoader
创建 SchemaFactory 的工厂。

class

TypeInfoProvider
此类提供了对 ValidatorHandler 所确定的类型信息的访问。

class

Validator
根据 Schema 检查 XML 文档的处理器。

class

ValidatorHandler
处理 SAX 流的流验证器。

返回 Object 的 javax.xml.validation 中的方法

Object

SchemaFactory.getProperty(String name)
查找属性值。

Object

Validator.getProperty(String name)
查找属性值。

Object

ValidatorHandler.getProperty(String name)
查找属性值。

参数类型为 Object 的 javax.xml.validation 中的方法

void

SchemaFactory.setProperty(String name, Object object)
设置属性值。

void

Validator.setProperty(String name, Object object)
设置属性值。

void

ValidatorHandler.setProperty(String name, Object object)
设置属性值。

javax.xml.ws 中 Object 的使用

javax.xml.ws 中 Object 的子类

class

Endpoint
Web 服务端点。

class

Holder<T>
包含类型为 T 的值。

class

Service
Service 对象提供 Web 服务的客户端视图。

class

WebServiceException
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

class

WebServicePermission
此类定义 Web 服务权限。

声明为 Object 的 javax.xml.ws 中的字段

T

Holder.value
持有者中包含的值。

返回 Object 的 javax.xml.ws 中的方法

abstract  Object

Endpoint.getImplementor()
返回此端点的实现对象。

Object

LogicalMessage.getPayload(JAXBContext context)
以 JAXB 对象的形式获取消息负载。

返回变量类型为 Object 的类型的 javax.xml.ws 中的方法

Dispatch<Object>

Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与生成的 JAXB 对象一起使用的 Dispatch 实例。

Map<String,Object>

Response.getContext()
获取所含的响应上下文。

abstract  Map<String,Object>

Endpoint.getProperties()
返回此 Endpoint 实例的属性包。

Map<String,Object>

BindingProvider.getRequestContext()
获取用于初始化请求消息的消息上下文的上下文。

Map<String,Object>

BindingProvider.getResponseContext()
获取处理响应消息所得的上下文。

参数类型为 Object 的 javax.xml.ws 中的方法

static Endpoint

Endpoint.create(Object implementor)
创建具有指定实现者对象的端点。

static Endpoint

Endpoint.create(String bindingId, Object implementor)
创建具有指定绑定类型和实现者对象的端点。

abstract  void

Endpoint.publish(Object serverContext)
在提供的服务器上下文中发布此端点。

static Endpoint

Endpoint.publish(String address, Object implementor)
在给定地址处针对指定的实现者对象创建并发布端点。

void

LogicalMessage.setPayload(Object payload, JAXBContext context)
设置消息负载

类型变量类型为 Object 的 javax.xml.ws 中的方法参数

abstract  void

Endpoint.setProperties(Map<String,Object> properties)
设置此 Endpoint 实例的属性包。

javax.xml.ws.handler.soap 中 Object 的使用

返回 Object 的 javax.xml.ws.handler.soap 中的方法

Object[]

SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
从消息上下文的消息中获得具有特定限定名的头。

javax.xml.ws.http 中 Object 的使用

javax.xml.ws.http 中 Object 的子类

class

HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 Object 的使用

javax.xml.ws.soap 中 Object 的子类

class

SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

javax.xml.ws.spi 中 Object 的使用

javax.xml.ws.spi 中 Object 的子类

class

Provider
ServiceDelegate 和 Endpoint 对象的服务提供者。

class

ServiceDelegate
服务委托由 Service 对象内部使用，以允许插入 JAX-WS 实现。

返回变量类型为 Object 的类型的 javax.xml.ws.spi 中的方法

abstract  Dispatch<Object>

ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。

参数类型为 Object 的 javax.xml.ws.spi 中的方法

abstract  Endpoint

Provider.createAndPublishEndpoint(String address, Object implementor)
创建和发布具有指定地址和实现对象的端点对象。

abstract  Endpoint

Provider.createEndpoint(String bindingId, Object implementor)
创建具有提供的绑定和实现对象的端点对象。

javax.xml.xpath 中 Object 的使用

javax.xml.xpath 中 Object 的子类

class

XPathConstants
XPath 常量。

class

XPathException
XPathException 表示通用 XPath 异常。

class

XPathExpressionException
XPathExpressionException 表示 XPath 表达式中的错误。

class

XPathFactory
XPathFactory 实例可用于创建 XPath 对象。

class

XPathFactoryConfigurationException
XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。

class

XPathFunctionException
XPathFunctionException 表示 XPath 函数的错误。

返回 Object 的 javax.xml.xpath 中的方法

Object

XPathExpression.evaluate(InputSource source, QName returnType)
计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。

Object

XPathFunction.evaluate(List args)
计算带指定参数的函数。

Object

XPathExpression.evaluate(Object item, QName returnType)
计算指定上下文中的 XPath 表达式并返回指定类型的结果。

Object

XPath.evaluate(String expression, InputSource source, QName returnType)
计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。

Object

XPath.evaluate(String expression, Object item, QName returnType)
计算指定上下文中的 XPath 表达式并返回指定类型的结果。

Object

XPathVariableResolver.resolveVariable(QName variableName)
在可用的变量集中查找变量。

参数类型为 Object 的 javax.xml.xpath 中的方法

String

XPathExpression.evaluate(Object item)
计算指定上下文中编译后的 XPath 表达式并以 String 形式返回结果。

Object

XPathExpression.evaluate(Object item, QName returnType)
计算指定上下文中的 XPath 表达式并返回指定类型的结果。

String

XPath.evaluate(String expression, Object item)
计算指定上下文中的 XPath 表达式并返回 String 形式的结果。

Object

XPath.evaluate(String expression, Object item, QName returnType)
计算指定上下文中的 XPath 表达式并返回指定类型的结果。

org.ietf.jgss 中 Object 的使用

org.ietf.jgss 中 Object 的子类

class

ChannelBinding
此类封装关于调用者提供的通道绑定信息的概念。

class

GSSException
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。

class

GSSManager
此类作为其他重要 GSS-API 类的工厂，并且还提供有关受支持的机制的信息。

class

MessageProp
这是一个在 per-message GSSContext 方法中使用的、用来传送 per-message 属性的实用工具类。

class

Oid
此类表示 Universal Object Identifiers（通用对象标识符，即 Oid）及其相关的操作。

参数类型为 Object 的 org.ietf.jgss 中的方法

boolean

ChannelBinding.equals(Object obj)
比较 ChannelBinding 的两个实例。

boolean

GSSCredential.equals(Object another)
进行测试，看此 GSSCredential 是否具有与提供的对象相同的实体。

boolean

GSSName.equals(Object another)
将此 GSSName 对象与可能是 GSSName 的另一个对象进行比较。

boolean

Oid.equals(Object other)
测试两个 Oid 对象是否表示相同的 Object 标识符值。

org.omg.CORBA 中 Object 的使用

org.omg.CORBA 中 Object 的子类

class

_IDLTypeStub
IDLType 的 Stub。

class

_PolicyStub
Policy 的 Stub。

class

ACTIVITY_COMPLETED
ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。

class

ACTIVITY_REQUIRED
ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。

class

Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。

class

AnyHolder
Any 的 Holder。

class

AnySeqHelper
AnySeq 的 Helper。

class

AnySeqHolder
AnySeq 的 Holder。

class

BAD_CONTEXT
当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。

class

BAD_INV_ORDER
此异常指示调用者按错误顺序调用了操作。

class

BAD_OPERATION
当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。

class

BAD_PARAM
当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。

class

BAD_QOS
只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。

class

BAD_TYPECODE
当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。

class

BooleanHolder
Boolean 的 Holder。

class

BooleanSeqHelper
BooleanSeq 的 Helper。

class

BooleanSeqHolder
BooleanSeq 的 Holder。

class

Bounds
当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。

class

ByteHolder
Byte 的 Holder。

class

CharHolder
Char 的 Holder。

class

CharSeqHelper
CharSeq 的 Helper。

class

CharSeqHolder
CharSeq 的 Holder。

class

CODESET_INCOMPATIBLE
当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。

class

COMM_FAILURE
如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。

class

CompletionStatus
指示某一方法抛出 SystemException 时是否已结束运行的对象。

class

CompletionStatusHelper
CompletionStatus 的 Helper。

class

Context
用于在 Request 操作中指定上下文对象的对象，上下文字符串在与请求调用一起被发送之前，必须在该指定的上下文对象中进行解析。

class

ContextList
一个对象，它包含表示属性名称的 String 对象所组成的可修改列表。

class

CurrentHelper
Current 的 Helper。

class

CurrentHolder
Current 的 Holder。

class

DATA_CONVERSION
如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。

class

DefinitionKind
该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。

class

DefinitionKindHelper
DefinitionKind 的 Helper。

class

DoubleHolder
Double 的 Holder。

class

DoubleSeqHelper
DoubleSeq 的 Helper。

class

DoubleSeqHolder
DoubleSeq 的 Holder。

class

DynamicImplementation
已过时。 org.omg.CORBA.DynamicImplementation

class

Environment
用于 Request 操作的异常的容器 (holder)，使异常可用于客户端。

class

ExceptionList
Request 操作中使用的对象，用于描述可由某一方法抛出的异常。

class

FieldNameHelper
FieldName 的 Helper。

class

FixedHolder
Fixed 的 Holder。

class

FloatHolder
Float 的 Holder。

class

FloatSeqHelper
FloatSeq 的 Helper。

class

FloatSeqHolder
FloatSeq 的 Holder。

class

FREE_MEM
当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。

class

IdentifierHelper
Identifier 的 Helper。

class

IDLTypeHelper
IDLType 的 Helper。

class

IMP_LIMIT
此异常指示在 OBR 运行时超过了某一项实现限制。

class

INITIALIZE
ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。

class

INTERNAL
此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。

class

INTF_REPOS
当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。

class

IntHolder
Int 的 Holder。

class

INV_FLAG
在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。

class

INV_IDENT
此异常指示 IDL 标识符在语法上是无效的。

class

INV_OBJREF
此异常指示对象引用存在内部错误。

class

INV_POLICY
当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。

class

INVALID_ACTIVITY
如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。

class

INVALID_TRANSACTION
当请求带有无效的事务上下文时，抛出此异常。

class

LocalObject
用作 Java 语言映射中的本地 IDL 接口实现的基本类。

class

LongHolder
Long 值的 Holder。

class

LongLongSeqHelper
LongLongSeq 的 Helper。

class

LongLongSeqHolder
LongLongSeq 的 Holder。

class

LongSeqHelper
LongSeqHelper 的 Helper。

class

LongSeqHolder
LongSeq 的 Holder。

class

MARSHAL
表示网络中传来的请求或应答在结构上无效。

class

NamedValue
在 DII 和 DSI 中用来描述参数和返回值的对象。

class

NameValuePair
将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。

class

NameValuePairHelper
NameValuePair 的 Helper。

class

NO_IMPLEMENT
此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。

class

NO_MEMORY
如果 ORB 运行时出现内存不足，则抛出此异常。

class

NO_PERMISSION
当因为调用者没有足够的权限而导致调用失败时，抛出此异常。

class

NO_RESOURCES
当 ORB 遇到一些一般资源限制时，抛出此异常。

class

NO_RESPONSE
如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。

class

NVList
包含 NamedValue 对象所组成的可修改列表。

class

OBJ_ADAPTER
此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。

class

OBJECT_NOT_EXIST
只要在已删除的对象上执行调用，就会引发此异常。

class

ObjectHelper

class

ObjectHolder
Object 的 Holder。

class

OctetSeqHelper
OctetSeq 的 Helper。

class

OctetSeqHolder
OctetSeq 的 Holder。

class

ORB
为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。

class

ParameterMode
Parameter 参数模式的枚举。

class

ParameterModeHelper
Parameter 参数模式的枚举。

class

ParameterModeHolder
Parameter 参数模式的枚举。

class

PERSIST_STORE
此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。

class

PolicyError
发生策略错误时抛出的用户异常。

class

PolicyErrorCodeHelper
封装 Policy 无效的原因。

class

PolicyErrorHelper
抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。

class

PolicyErrorHolder
抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。

class

PolicyHelper
Policy 的 Helper。

class

PolicyHolder
Policy 的 Holder。

class

PolicyListHelper
PolicyList 的 Helper。

class

PolicyListHolder
PolicyList 的 Holder。

class

PolicyTypeHelper
PolicyType 的 Helper。

class

Principal
已过时。 已由 CORBA 2.2 取代。

class

PrincipalHolder
已过时。 Deprecated by CORBA 2.2.

class

REBIND
如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。

class

RepositoryIdHelper
RepositoryId 的 Helper。

class

Request
包含调用某一方法所必需的信息的对象。

class

ServerRequest
捕获对动态框架接口（Dynamic Skeleton Interface，DSI）请求的显式状态的对象。

class

ServiceDetail
表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。

class

ServiceDetailHelper

class

ServiceInformation
CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。

class

ServiceInformationHelper

class

ServiceInformationHolder
ServiceInformation 的 Holder。

class

SetOverrideType
标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。

class

SetOverrideTypeHelper
SetOverrideType 的 Helper。

class

ShortHolder
Short 的 Holder。

class

ShortSeqHelper
ShortSeqHelper 的 Helper。

class

ShortSeqHolder
ShortSeq 的 Holder。

class

StringHolder
String 的 Holder。

class

StringSeqHelper
String 数组

class

StringSeqHolder
String 数组

class

StringValueHelper
StringValue 的 Helper。

class

StructMember
描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。

class

StructMemberHelper
StructMember 的 Helper。

class

SystemException
所有 CORBA 标准异常的根类。

class

TCKind
IDL enum TCKind 的 Java 映射，TCKind 指定 TypeCode 对象的种类。

class

TIMEOUT
当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。

class

TRANSACTION_MODE
如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。

class

TRANSACTION_REQUIRED
此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。

class

TRANSACTION_ROLLEDBACK
当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。

class

TRANSACTION_UNAVAILABLE
当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。

class

TRANSIENT
当 ORB 试图到达某一对象但失败时，抛出此异常。

class

TypeCode
用于有关特定 CORBA 数据类型的信息的容器。

class

TypeCodeHolder
TypeCode 的 Holder。

class

ULongLongSeqHelper
ULongLongSeq 的 Helper。

class

ULongLongSeqHolder
ULongLongSeq 的 Holder。

class

ULongSeqHelper
ULongSeq 的 Helper。

class

ULongSeqHolder
ULongSeq 的 Holder。

class

UnionMember
接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。

class

UnionMemberHelper
UnionMember 的 Helper。

class

UNKNOWN
如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。

class

UnknownUserException
包含由服务器返回的用户异常的类。

class

UnknownUserExceptionHelper
UnknownUserException 的 Helper。

class

UnknownUserExceptionHolder
UnknownUserException 的 Holder。

class

UserException
CORBA IDL 定义的用户异常的根类。

class

UShortSeqHelper
UShortSeq 的 Helper。

class

UShortSeqHolder
UShortSeq 的 Holder。

class

ValueBaseHelper

class

ValueBaseHolder
ValueBase 的 Holder。

class

ValueMember
接口存储库 (Interface Repository) 中关于 value 对象成员的描述。

class

ValueMemberHelper
ValueMember 的 Helper。

class

VersionSpecHelper
VersionSpec 的 Helper。

class

VisibilityHelper
Visibility 的 Helper。

class

WCharSeqHelper
WCharSeq 的 Helper。

class

WCharSeqHolder
WCharSeq 的 Holder。

class

WrongTransaction
CORBA WrongTransaction 用户定义异常。

class

WrongTransactionHelper
WrongTransaction 的 Helper。

class

WrongTransactionHolder
WrongTransaction 的 Holder。

class

WStringSeqHelper
WString 数组

class

WStringSeqHolder
WString 数组

class

WStringValueHelper
org/omg/CORBA/WStringValueHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 orb.idl 中生成，生成时间为 1999 年 5 月 31 日 22:27:30 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范： 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07) ptc/00-01-08 中定义的 IDL/Java 语言映射

返回 Object 的 org.omg.CORBA 中的方法

Object

DataInputStream.read_Abstract()
从输入流读取 IDL Abstract 接口。

参数类型为 Object 的 org.omg.CORBA 中的方法

void

DataOutputStream.write_Abstract(Object value)
将 IDL Abstract 接口类型写入输出流。

org.omg.CORBA_2_3 中 Object 的使用

参数类型为 Object 的 org.omg.CORBA_2_3 中的方法

void

ORB.set_delegate(Object wrapper)

org.omg.CORBA_2_3.portable 中 Object 的使用

返回 Object 的 org.omg.CORBA_2_3.portable 中的方法

Object

InputStream.read_abstract_interface()
解组值对象或适当的 stub 对象。

Object

InputStream.read_abstract_interface(Class clz)
解组与传递类型相对应的类对象或 stub 类。

参数类型为 Object 的 org.omg.CORBA_2_3.portable 中的方法

void

OutputStream.write_abstract_interface(Object obj)
编组值对象或 stub 对象。

org.omg.CORBA.DynAnyPackage 中 Object 的使用

org.omg.CORBA.DynAnyPackage 中 Object 的子类

class

Invalid
动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。

class

InvalidSeq
任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。

class

InvalidValue

class

TypeMismatch
动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 Object 的使用

org.omg.CORBA.ORBPackage 中 Object 的子类

class

InconsistentTypeCode
当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。

class

InvalidName
当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.portable 中 Object 的使用

org.omg.CORBA.portable 中 Object 的子类

class

ApplicationException
此类用来报告 ORB 和 stub 之间的应用程序级异常。

class

Delegate
为 org.omg.CORBA.Object 方法特定于供应商的 ORB 实现指定一个可移植的 API。

class

IndirectionException
Indirection 异常是一个特定于 Java 的系统异常。

class

ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。

class

RemarshalException
此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。

class

ServantObject
此类是本地 stub API 的一部分，其目的是为配置的客户端和服务器（即驻留在同一 Java VM 上的客户端和服务器）提供高性能的调用。

class

UnknownException
org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

声明为 Object 的 org.omg.CORBA.portable 中的字段

Object

ServantObject.servant
实际的 servant。

参数类型为 Object 的 org.omg.CORBA.portable 中的方法

boolean

ObjectImpl.equals(Object obj)
比较此 ObjectImpl 对象与给定对象是否相等。

boolean

Delegate.equals(Object self, Object obj)
提供重写委托 CORBA 对象方法 equals(java.lang.Object obj) 的实现。

org.omg.CORBA.TypeCodePackage 中 Object 的使用

org.omg.CORBA.TypeCodePackage 中 Object 的子类

class

BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming 中 Object 的使用

org.omg.CosNaming 中 Object 的子类

class

_BindingIteratorImplBase

class

_BindingIteratorStub
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。

class

_NamingContextExtStub
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

class

_NamingContextImplBase

class

_NamingContextStub
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

class

Binding
org/omg/CosNaming/Binding.java。

class

BindingHelper
org/omg/CosNaming/BindingHelper.java。

class

BindingHolder
org/omg/CosNaming/BindingHolder.java。

class

BindingIteratorHelper
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。

class

BindingIteratorHolder
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。

class

BindingIteratorPOA
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。

class

BindingListHelper
绑定列表。

class

BindingListHolder
绑定列表。

class

BindingType
指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。

class

BindingTypeHelper
指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。

class

BindingTypeHolder
指定给定的绑定是对象（非命名上下文的对象）的还是命名上下文的。

class

IstringHelper
org/omg/CosNaming/IstringHelper.java。

class

NameComponent
org/omg/CosNaming/NameComponent.java。

class

NameComponentHelper
org/omg/CosNaming/NameComponentHelper.java。

class

NameComponentHolder
org/omg/CosNaming/NameComponentHolder.java。

class

NameHelper
名称是名称组件的序列。

class

NameHolder
名称是名称组件的序列。

class

NamingContextExtHelper
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

class

NamingContextExtHolder
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

class

NamingContextExtPOA
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

class

NamingContextHelper
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

class

NamingContextHolder
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

class

NamingContextPOA
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.CosNaming.NamingContextExtPackage 中 Object 的使用

org.omg.CosNaming.NamingContextExtPackage 中 Object 的子类

class

AddressHelper
地址是以 String 形式表示的主机和端口信息。

class

InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

class

InvalidAddressHelper
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java。

class

InvalidAddressHolder
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java。

class

StringNameHelper
StringName 是以 String 形式表示的“字符串化的名称”和“名称组件数组”。

class

URLStringHelper
URLString 是以 String 形式表示的 URL 地址（corbaloc: 或 corbaname:）。

org.omg.CosNaming.NamingContextPackage 中 Object 的使用

org.omg.CosNaming.NamingContextPackage 中 Object 的子类

class

AlreadyBound
org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。

class

AlreadyBoundHelper
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java。

class

AlreadyBoundHolder
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java。

class

CannotProceed
org/omg/CosNaming/NamingContextPackage/CannotProceed.java。

class

CannotProceedHelper
org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java。

class

CannotProceedHolder
org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java。

class

InvalidNameHelper
org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java。

class

InvalidNameHolder
org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java。

class

NotEmpty
org/omg/CosNaming/NamingContextPackage/NotEmpty.java。

class

NotEmptyHelper
org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java。

class

NotEmptyHolder
org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java。

class

NotFound
org/omg/CosNaming/NamingContextPackage/NotFound.java。

class

NotFoundHelper
org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java。

class

NotFoundHolder
org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java。

class

NotFoundReason
指示未能解析的原因。

class

NotFoundReasonHelper
指示未能解析的原因。

class

NotFoundReasonHolder
指示未能解析的原因。

org.omg.Dynamic 中 Object 的使用

org.omg.Dynamic 中 Object 的子类

class

Parameter
org/omg/Dynamic/Parameter.java。

org.omg.DynamicAny 中 Object 的使用

org.omg.DynamicAny 中 Object 的子类

class

_DynAnyFactoryStub
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。

class

_DynAnyStub
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。

class

_DynArrayStub
DynArray 对象支持对 IDL 数组 (array) 的操作。

class

_DynEnumStub
DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。

class

_DynFixedStub
DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。

class

_DynSequenceStub
DynSequence 对象支持对 IDL 序列 (sequence) 的操作。

class

_DynStructStub
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。

class

_DynUnionStub
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。

class

_DynValueStub
DynValue 对象支持 IDL non-boxed value 类型的操作。

class

DynAnyFactoryHelper
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。

class

DynAnyHelper
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。

class

DynAnySeqHelper
org/omg/DynamicAny/DynAnySeqHelper.java。

class

DynArrayHelper
DynArray 对象支持对 IDL 数组的操作。

class

DynEnumHelper
DynEnum 对象支持对 IDL 枚举值的操作。

class

DynFixedHelper
DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。

class

DynSequenceHelper
DynSequence 对象支持对 IDL 序列的操作。

class

DynStructHelper
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。

class

DynUnionHelper
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。

class

DynValueHelper
DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。

class

NameDynAnyPair
org/omg/DynamicAny/NameDynAnyPair.java。

class

NameDynAnyPairHelper
org/omg/DynamicAny/NameDynAnyPairHelper.java。

class

NameDynAnyPairSeqHelper
org/omg/DynamicAny/NameDynAnyPairSeqHelper.java。

class

NameValuePairSeqHelper
org/omg/DynamicAny/NameValuePairSeqHelper.java。

org.omg.DynamicAny.DynAnyFactoryPackage 中 Object 的使用

org.omg.DynamicAny.DynAnyFactoryPackage 中 Object 的子类

class

InconsistentTypeCodeHelper
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java。

org.omg.DynamicAny.DynAnyPackage 中 Object 的使用

org.omg.DynamicAny.DynAnyPackage 中 Object 的子类

class

InvalidValueHelper
org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java。

org.omg.IOP 中 Object 的使用

org.omg.IOP 中 Object 的子类

class

CodecFactoryHelper
Codec 可从 CodecFactory 中获得。

class

ComponentIdHelper
表示多组件配置文件的标准方式。

class

Encoding
org/omg/IOP/Encoding.java。

class

IOR
org/omg/IOP/IOR.java。

class

IORHelper
org/omg/IOP/IORHelper.java。

class

IORHolder
org/omg/IOP/IORHolder.java。

class

MultipleComponentProfileHelper
形成多组件配置文件的一组加标记的组件。

class

MultipleComponentProfileHolder
形成多组件配置文件的一组加标记的组件。

class

ProfileIdHelper
配置文件 ID

class

ServiceContext
org/omg/IOP/ServiceContext.java。

class

ServiceContextHelper
org/omg/IOP/ServiceContextHelper.java。

class

ServiceContextHolder
org/omg/IOP/ServiceContextHolder.java。

class

ServiceContextListHelper
形成服务上下文列表的一组服务上下文。

class

ServiceContextListHolder
形成服务上下文列表的一组服务上下文。

class

ServiceIdHelper
以 int 形式表示的服务 id

class

TaggedComponent
org/omg/IOP/TaggedComponent.java。

class

TaggedComponentHelper
org/omg/IOP/TaggedComponentHelper.java。

class

TaggedComponentHolder
org/omg/IOP/TaggedComponentHolder.java。

class

TaggedProfile
org/omg/IOP/TaggedProfile.java。

class

TaggedProfileHelper
org/omg/IOP/TaggedProfileHelper.java。

class

TaggedProfileHolder
org/omg/IOP/TaggedProfileHolder.java。

org.omg.IOP.CodecFactoryPackage 中 Object 的使用

org.omg.IOP.CodecFactoryPackage 中 Object 的子类

class

UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

class

UnknownEncodingHelper
org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java。

org.omg.IOP.CodecPackage 中 Object 的使用

org.omg.IOP.CodecPackage 中 Object 的子类

class

FormatMismatch
org/omg/IOP/CodecPackage/FormatMismatch.java。

class

FormatMismatchHelper
org/omg/IOP/CodecPackage/FormatMismatchHelper.java。

class

InvalidTypeForEncoding
org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

class

InvalidTypeForEncodingHelper
org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java。

class

TypeMismatchHelper
org/omg/IOP/CodecPackage/TypeMismatchHelper.java。

org.omg.Messaging 中 Object 的使用

org.omg.Messaging 中 Object 的子类

class

SyncScopeHelper
Synchronization 作用域

org.omg.PortableInterceptor 中 Object 的使用

org.omg.PortableInterceptor 中 Object 的子类

class

AdapterManagerIdHelper
适配器管理器标识符。

class

AdapterNameHelper
对象适配器的名称。

class

AdapterStateHelper
对象适配器状态的类型。

class

InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

class

InvalidSlotHelper
org/omg/PortableInterceptor/InvalidSlotHelper.java。

class

IORInterceptor_3_0Helper
org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java。

class

IORInterceptor_3_0Holder
org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java。

class

ObjectIdHelper
对象 id 类型。

class

ObjectReferenceFactoryHelper
对象引用工厂。

class

ObjectReferenceFactoryHolder
对象引用工厂。

class

ObjectReferenceTemplateHelper
对象引用模板。

class

ObjectReferenceTemplateHolder
对象引用模板。

class

ObjectReferenceTemplateSeqHelper
对象引用模板序列用来报告不发生在适配器管理器的状态更改。

class

ObjectReferenceTemplateSeqHolder
对象引用模板序列用来报告不发生在适配器管理器的状态更改。

class

ORBIdHelper
org/omg/PortableInterceptor/ORBIdHelper.java。

class

ServerIdHelper
org/omg/PortableInterceptor/ServerIdHelper.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Object 的使用

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Object 的子类

class

DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

class

DuplicateNameHelper
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java。

org.omg.PortableServer 中 Object 的使用

org.omg.PortableServer 中 Object 的子类

class

_ServantActivatorStub
当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。

class

_ServantLocatorStub
POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。

class

ForwardRequest
org/omg/PortableServer/ForwardRequest.java。

class

ForwardRequestHelper
org/omg/PortableServer/ForwardRequestHelper.java。

class

IdAssignmentPolicyValue
IdAssignmentPolicyValue 可以具有以下值。

class

IdUniquenessPolicyValue
IdUniquenessPolicyValue 可以具有以下值。

class

ImplicitActivationPolicyValue
ImplicitActivationPolicyValue 具有以下语义。

class

LifespanPolicyValue
LifespanPolicyValue 可以具有以下值。

class

POAHelper
POA 对象管理对象集合的实现。

class

RequestProcessingPolicyValue
RequestProcessingPolicyValue 可以具有以下值。

class

Servant
定义本机 Servant 类型。

class

ServantActivatorHelper
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

class

ServantActivatorPOA
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

class

ServantLocatorHelper
POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

class

ServantLocatorPOA
POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

class

ServantRetentionPolicyValue
ServantRetentionPolicyValue 可以具有以下值。

class

ThreadPolicyValue
ThreadPolicyValue 可以具有以下值。

参数类型为 Object 的 org.omg.PortableServer 中的方法

void

ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
servant 完成请求时都将调用此操作。

void

_ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
servant 完成请求时都将调用此操作。

org.omg.PortableServer.CurrentPackage 中 Object 的使用

org.omg.PortableServer.CurrentPackage 中 Object 的子类

class

NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

class

NoContextHelper
org/omg/PortableServer/CurrentPackage/NoContextHelper.java。

org.omg.PortableServer.POAManagerPackage 中 Object 的使用

org.omg.PortableServer.POAManagerPackage 中 Object 的子类

class

AdapterInactive
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。

class

AdapterInactiveHelper
org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java。

class

State
指定 POAManager 的状态。

org.omg.PortableServer.POAPackage 中 Object 的使用

org.omg.PortableServer.POAPackage 中 Object 的子类

class

AdapterAlreadyExists
org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。

class

AdapterAlreadyExistsHelper
org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java。

class

AdapterNonExistent
org/omg/PortableServer/POAPackage/AdapterNonExistent.java。

class

AdapterNonExistentHelper
org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java。

class

InvalidPolicy
org/omg/PortableServer/POAPackage/InvalidPolicy.java。

class

InvalidPolicyHelper
org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java。

class

NoServant
org/omg/PortableServer/POAPackage/NoServant.java。

class

NoServantHelper
org/omg/PortableServer/POAPackage/NoServantHelper.java。

class

ObjectAlreadyActive
org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。

class

ObjectAlreadyActiveHelper
org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java。

class

ObjectNotActive
org/omg/PortableServer/POAPackage/ObjectNotActive.java。

class

ObjectNotActiveHelper
org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java。

class

ServantAlreadyActive
org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。

class

ServantAlreadyActiveHelper
org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java。

class

ServantNotActive
org/omg/PortableServer/POAPackage/ServantNotActive.java。

class

ServantNotActiveHelper
org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java。

class

WrongAdapter
org/omg/PortableServer/POAPackage/WrongAdapter.java。

class

WrongAdapterHelper
org/omg/PortableServer/POAPackage/WrongAdapterHelper.java。

class

WrongPolicy
org/omg/PortableServer/POAPackage/WrongPolicy.java。

class

WrongPolicyHelper
org/omg/PortableServer/POAPackage/WrongPolicyHelper.java。

org.omg.PortableServer.ServantLocatorPackage 中 Object 的使用

org.omg.PortableServer.ServantLocatorPackage 中 Object 的子类

class

CookieHolder
native 类型 PortableServer::ServantLocator::Cookie 被映射到 java.lang.Object。

声明为 Object 的 org.omg.PortableServer.ServantLocatorPackage 中的字段

Object

CookieHolder.value

参数类型为 Object 的 org.omg.PortableServer.ServantLocatorPackage 中的构造方法

CookieHolder(Object initial)

org.omg.stub.java.rmi 中 Object 的使用

org.omg.stub.java.rmi 中 Object 的子类

class

_Remote_Stub
此类为 Remote 类型提供 Stub。

org.w3c.dom 中 Object 的使用

org.w3c.dom 中 Object 的子类

class

DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

返回 Object 的 org.w3c.dom 中的方法

Object

DOMImplementation.getFeature(String feature, String version)
此方法返回一个特定的对象，该对象实现了 DOM Features 中所指定的特定特性或版本的特殊 API。

Object

Node.getFeature(String feature, String version)
此方法返回一个特定的对象，该对象实现指定功能或版本的特定 API，如下所述。

Object

DOMConfiguration.getParameter(String name)
如果已知，则返回参数的值。

Object

DOMError.getRelatedData()
相关的与 DOMError.type 有关的数据（如果有）。

Object

DOMError.getRelatedException()
相关的与相关平台有关的异常（如果有）。

Object

Node.getUserData(String key)
检索与此节点上的某个键相关联的对象。

Object

Node.setUserData(String key, Object data, UserDataHandler handler)
将对象与此节点上的键相关联。

参数类型为 Object 的 org.w3c.dom 中的方法

boolean

DOMConfiguration.canSetParameter(String name, Object value)
检查是否支持将参数设置为特定值。

void

UserDataHandler.handle(short operation, String key, Object data, Node src, Node dst)
每当导入或克隆为其注册此处理程序的节点时，调用此方法。

void

DOMConfiguration.setParameter(String name, Object value)
设置参数的值。

Object

Node.setUserData(String key, Object data, UserDataHandler handler)
将对象与此节点上的键相关联。

org.w3c.dom.bootstrap 中 Object 的使用

org.w3c.dom.bootstrap 中 Object 的子类

class

DOMImplementationRegistry
启用应用程序来获得 DOMImplementation 实例的工厂。

org.w3c.dom.events 中 Object 的使用

org.w3c.dom.events 中 Object 的子类

class

EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。

org.w3c.dom.ls 中 Object 的使用

org.w3c.dom.ls 中 Object 的子类

class

LSException
如果处理停止，解析或写操作可以抛出 LSException。

org.xml.sax 中 Object 的使用

org.xml.sax 中 Object 的子类

class

HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

class

InputSource
XML 实体的单一输入源。

class

SAXException
封装一般的 SAX 错误或警告。

class

SAXNotRecognizedException
用于未识别的标识符的 Exception 类。

class

SAXNotSupportedException
用于不被支持的操作的 Exception 类。

class

SAXParseException
封装 XML 解析错误或警告。

返回 Object 的 org.xml.sax 中的方法

Object

XMLReader.getProperty(String name)
查找属性的值。

参数类型为 Object 的 org.xml.sax 中的方法

void

XMLReader.setProperty(String name, Object value)
设置属性的值。

org.xml.sax.ext 中 Object 的使用

org.xml.sax.ext 中 Object 的子类

class

Attributes2Impl
用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。

class

DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

class

Locator2Impl
用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。

org.xml.sax.helpers 中 Object 的使用

org.xml.sax.helpers 中 Object 的子类

class

AttributeListImpl
已过时。 此类实现不推荐使用的接口 AttributeList；该接口已被 AttributesImpl 帮助器类中实现的 Attributes 取代。

class

AttributesImpl
Attributes 接口的默认实现。

class

DefaultHandler
SAX2 事件处理程序的默认基类。

class

LocatorImpl
提供 Locator 的可选的有用实现。

class

NamespaceSupport
封装名称空间逻辑，以便由使用 SAX 的应用程序使用，或由 SAX 驱动程序内部使用。

class

ParserAdapter
将 SAX1 Parser 适配为 SAX2 XMLReader。

class

ParserFactory
已过时。 此类与不推荐使用的 Parser 接口一起使用。

class

XMLFilterImpl
派生 XML 过滤器的基类。

class

XMLReaderAdapter
将 SAX2 XMLReader 适配为 SAX1 解析器。

class

XMLReaderFactory
创建 XML 阅读器的工厂。

返回 Object 的 org.xml.sax.helpers 中的方法

Object

ParserAdapter.getProperty(String name)
获取解析器属性。

Object

XMLFilterImpl.getProperty(String name)
查找属性值。

参数类型为 Object 的 org.xml.sax.helpers 中的方法

void

ParserAdapter.setProperty(String name, Object value)
设置解析器属性。

void

XMLFilterImpl.setProperty(String name, Object value)
设置属性值。

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM 2 Platform
Standard Ed. 6

上一个 下一个

框架 无框架


类 java.lang.OutOfMemoryError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.OutOfMemoryError
的使用

没有 java.lang.OutOfMemoryError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Override 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Override
的使用

使用 Override 的软件包
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.lang.model.util 中 Override 的使用

注释类型为 Override 的 javax.lang.model.util 中的方法
R | ElementKindVisitor6.visitExecutable(ExecutableElement e, P p) 访问 executable 元素，指派给用于特定的 executable 种类 CONSTRUCTOR、INSTANCE_INIT、METHOD 或 STATIC_INIT 的 visit 方法。
R | TypeKindVisitor6.visitNoType(NoType t, P p) 访问 NoType 实例，指派给用于以下特定的伪类型种类的 visit 方法：VOID、PACKAGE 或 NONE。
R | ElementKindVisitor6.visitPackage(PackageElement e, P p) 访问包元素。
R | TypeKindVisitor6.visitPrimitive(PrimitiveType t, P p) 访问基本类型，指派给用于以下特定的基本类型种类的 visit 方法：BOOLEAN、BYTE 等。
R | ElementKindVisitor6.visitType(TypeElement e, P p) 访问类型元素，指派给用于特定的类型种类 ANNOTATION_TYPE、CLASS、ENUM 或 INTERFACE 的 visit 方法。
R | ElementKindVisitor6.visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。
R | ElementKindVisitor6.visitVariable(VariableElement e, P p) 访问变量元素，指派给用于特定的变量种类 ENUM_CONSTANT、EXCEPTION_PARAMETER、FIELD、LOCAL_VARIABLE 或 PARAMETER 的 visit 方法。

javax.management 中 Override 的使用

注释类型为 Override 的 javax.management 中的方法
void | AttributeList.add(int index, Object element)
boolean | AttributeList.add(Object o)
boolean | AttributeList.addAll(Collection<?> c)
boolean | AttributeList.addAll(int index, Collection<?> c)
Object | AttributeList.set(int index, Object element)

javax.management.modelmbean 中 Override 的使用

注释类型为 Override 的 javax.management.modelmbean 中的方法
 Descriptor ModelMBeanInfoSupport.getDescriptor()

javax.management.relation 中 Override 的使用

注释类型为 Override 的 javax.management.relation 中的方法
void | RoleList.add(int index, Object element)
void | RoleUnresolvedList.add(int index, Object element)
boolean | RoleList.add(Object o)
boolean | RoleUnresolvedList.add(Object o)
boolean | RoleList.addAll(Collection<?> c)
boolean | RoleUnresolvedList.addAll(Collection<?> c)
boolean | RoleList.addAll(int index, Collection<?> c)
boolean | RoleUnresolvedList.addAll(int index, Collection<?> c)
Object | RoleList.set(int index, Object element)
Object | RoleUnresolvedList.set(int index, Object element)

javax.tools 中 Override 的使用

注释类型为 Override 的 javax.tools 中的方法
 String SimpleJavaFileObject.toString()

javax.xml.bind 中 Override 的使用

注释类型为 Override 的 javax.xml.bind 中的方法
 Throwable JAXBException.getCause()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Package 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Package
的使用

使用 Package 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。

java.lang 中 Package 的使用

返回 Package 的 java.lang 中的方法
protected Package | ClassLoader.definePackage(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase) 根据 name 在此 ClassLoader 中定义包。
Package | Class.getPackage() 获取此类的包。
static Package | Package.getPackage(String name) 通过调用方的 ClassLoader 实例中的名称找到一个包。
protected Package | ClassLoader.getPackage(String name) 返回由此类加载器或其任何祖先所定义的 Package。
static Package[] | Package.getPackages() 获得调用方的 ClassLoader 实例当前已知的所有包。
protected Package[] | ClassLoader.getPackages() 返回此类加载器及其祖先所定义的所有 Package。

java.net 中 Package 的使用

返回 Package 的 java.net 中的方法
protected  Package URLClassLoader.definePackage(String name, Manifest man, URL url)
用该 ClassLoader 中的名称定义一个新包。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Process 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Process
的使用

使用 Process 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 Process 的使用

返回 Process 的 java.lang 中的方法
Process | Runtime.exec(String command) 在单独的进程中执行指定的字符串命令。
Process | Runtime.exec(String[] cmdarray) 在单独的进程中执行指定命令和变量。
Process | Runtime.exec(String[] cmdarray, String[] envp) 在指定环境的独立进程中执行指定命令和变量。
Process | Runtime.exec(String[] cmdarray, String[] envp, File dir) 在指定环境和工作目录的独立进程中执行指定的命令和变量。
Process | Runtime.exec(String command, String[] envp) 在指定环境的单独进程中执行指定的字符串命令。
Process | Runtime.exec(String command, String[] envp, File dir) 在有指定环境和工作目录的独立进程中执行指定的字符串命令。
Process | ProcessBuilder.start() 使用此进程生成器的属性启动一个新进程。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ProcessBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ProcessBuilder
的使用

使用 ProcessBuilder 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 ProcessBuilder 的使用

返回 ProcessBuilder 的 java.lang 中的方法
ProcessBuilder | ProcessBuilder.command(List<String> command) 设置此进程生成器的操作系统程序和参数。
ProcessBuilder | ProcessBuilder.command(String... command) 设置此进程生成器的操作系统程序和参数。
ProcessBuilder | ProcessBuilder.directory(File directory) 设置此进程生成器的工作目录。
ProcessBuilder | ProcessBuilder.redirectErrorStream(boolean redirectErrorStream) 设置此进程生成器的 redirectErrorStream 属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.Readable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Readable
的使用

使用 Readable 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.io 中 Readable 的使用

实现 Readable 的 java.io 中的类
class | BufferedReader 从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。
class | CharArrayReader 此类实现一个可用作字符输入流的字符缓冲区。
class | FileReader 用来读取字符文件的便捷类。
class | FilterReader 用于读取已过滤的字符流的抽象类。
class | InputStreamReader InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。
class | LineNumberReader 跟踪行号的缓冲字符输入流。
class | PipedReader 传送的字符输入流。
class | PushbackReader 允许将字符推回到流的字符流 reader。
class | Reader 用于读取字符流的抽象类。
class | StringReader 其源为一个字符串的字符流。

java.nio 中 Readable 的使用

实现 Readable 的 java.nio 中的类
 class CharBuffer
字符缓冲区。

java.util 中 Readable 的使用

参数类型为 Readable 的 java.util 中的构造方法
Scanner(Readable source)
构造一个新的 Scanner，它生成的值是从指定源扫描的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.Runnable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Runnable
的使用

使用 Runnable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Runnable 的使用

参数类型为 Runnable 的 java.awt 中的方法
static void | EventQueue.invokeAndWait(Runnable runnable) 导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。
static void | EventQueue.invokeLater(Runnable runnable) 导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。

java.awt.event 中 Runnable 的使用

声明为 Runnable 的 java.awt.event 中的字段
protected  Runnable InvocationEvent.runnable
调用其 run() 方法的 Runnable。

参数类型为 Runnable 的 java.awt.event 中的构造方法
InvocationEvent(Object source, int id, Runnable runnable, Object notifier, boolean catchThrowables)
构造一个具有指定源和 ID 的 InvocationEvent，此源和 ID 将在被指派时执行 runnable 的 run 方法。
InvocationEvent(Object source, Runnable runnable)
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。
InvocationEvent(Object source, Runnable runnable, Object notifier, boolean catchThrowables)
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。

java.awt.image.renderable 中 Runnable 的使用

实现 Runnable 的 java.awt.image.renderable 中的类
 class RenderableImageProducer
实现 ImageProducer 以允许异步生成 RenderableImage 的适配器类。

java.lang 中 Runnable 的使用

实现 Runnable 的 java.lang 中的类
 class Thread
线程 是程序中的执行线程。

参数类型为 Runnable 的 java.lang 中的构造方法
Thread(Runnable target)
分配新的 Thread 对象。
Thread(Runnable target, String name)
分配新的 Thread 对象。
Thread(ThreadGroup group, Runnable target)
分配新的 Thread 对象。
Thread(ThreadGroup group, Runnable target, String name)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，并作为 group 所引用的线程组的一员。
Thread(ThreadGroup group, Runnable target, String name, long stackSize)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，作为 group 所引用的线程组的一员，并具有指定的堆栈大小。

java.util 中 Runnable 的使用

实现 Runnable 的 java.util 中的类
 class TimerTask
由 Timer 安排为一次执行或重复执行的任务。

java.util.concurrent 中 Runnable 的使用

java.util.concurrent 中 Runnable 的子接口
interface | RunnableFuture<V> 作为 Runnable 的 Future。
interface | RunnableScheduledFuture<V> 作为 Runnable 的 ScheduledFuture。

实现 Runnable 的 java.util.concurrent 中的类
 class FutureTask<V>
可取消的异步计算。

返回变量类型为 Runnable 的类型的 java.util.concurrent 中的方法
BlockingQueue<Runnable> | ScheduledThreadPoolExecutor.getQueue() 返回此执行程序使用的任务队列。
BlockingQueue<Runnable> | ThreadPoolExecutor.getQueue() 返回此执行程序使用的任务队列。
List<Runnable> | ExecutorService.shutdownNow() 试图停止所有正在执行的活动任务，暂停处理正在等待的任务，并返回等待执行的任务列表。
List<Runnable> | ScheduledThreadPoolExecutor.shutdownNow() 尝试停止所有正在执行的任务、暂停等待任务的处理，并返回等待执行的任务列表。
List<Runnable> | ThreadPoolExecutor.shutdownNow() 尝试停止所有的活动执行任务、暂停等待任务的处理，并返回等待执行的任务列表。

参数类型为 Runnable 的 java.util.concurrent 中的方法
protected  void ThreadPoolExecutor.afterExecute(Runnable r, Throwable t)
基于完成执行给定 Runnable 所调用的方法。
protected  void ThreadPoolExecutor.beforeExecute(Thread t, Runnable r)
在执行给定线程中的给定 Runnable 之前调用的方法。
static Callable<Object> Executors.callable(Runnable task)
返回 Callable 对象，调用它时可运行给定的任务并返回 null。
static
<T> Callable<T>
Executors.callable(Runnable task, T result)
返回 Callable 对象，调用它时可运行给定的任务并返回给定的结果。
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Runnable runnable, RunnableScheduledFuture<V> task)
修改或替换用于执行 runnable 的任务。
 void Executor.execute(Runnable command)
在未来某个时间执行给定的命令。
 void ScheduledThreadPoolExecutor.execute(Runnable command)
使用所要求的零延迟执行命令。
 void ThreadPoolExecutor.execute(Runnable command)
在将来某个时间执行给定任务。
protected
<T> RunnableFuture<T>
AbstractExecutorService.newTaskFor(Runnable runnable, T value)
为给定可运行任务和默认值返回一个 RunnableFuture。
 Thread ThreadFactory.newThread(Runnable r)
构造一个新 Thread。
 void RejectedExecutionHandler.rejectedExecution(Runnable r, ThreadPoolExecutor executor)
当 execute 不能接受某个任务时，可以由 ThreadPoolExecutor 调用的方法。
 void ThreadPoolExecutor.CallerRunsPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e)
执行调用者线程中的任务 r；如果执行程序已关闭，则会丢弃该任务。
 void ThreadPoolExecutor.AbortPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e)
总是抛出 RejectedExecutionException。
 void ThreadPoolExecutor.DiscardPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e)
不执行任何操作，在这种情况下将放弃任务 r。
 void ThreadPoolExecutor.DiscardOldestPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e)
获取并忽略下一个任务，否则如果该任务立即可用，执行程序将执行该任务，然后再试图重新执行任务 r；如果执行程序已关闭，则会丢弃任务 r。
 boolean ScheduledThreadPoolExecutor.remove(Runnable task)
 boolean ThreadPoolExecutor.remove(Runnable task)
从执行程序的内部队列中移除此任务（如果存在），从而如果尚未开始，则其不再运行。
 ScheduledFuture<?> ScheduledExecutorService.schedule(Runnable command, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的一次性操作。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.schedule(Runnable command, long delay, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
 Future<?> AbstractExecutorService.submit(Runnable task)
 Future<?> ExecutorService.submit(Runnable task)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
 Future<?> ScheduledThreadPoolExecutor.submit(Runnable task)
<T> Future<T>
AbstractExecutorService.submit(Runnable task, T result)
<T> Future<T>
ExecutorService.submit(Runnable task, T result)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
<T> Future<T>
ScheduledThreadPoolExecutor.submit(Runnable task, T result)
 Future<V> CompletionService.submit(Runnable task, V result)
提交要执行的 Runnable 任务，并返回一个表示任务完成的 Future，可以提取或轮询此任务。
 Future<V> ExecutorCompletionService.submit(Runnable task, V result)

参数类型为 Runnable 的 java.util.concurrent 中的构造方法
CyclicBarrier(int parties, Runnable barrierAction)
创建一个新的 CyclicBarrier，它将在给定数量的参与者（线程）处于等待状态时启动，并在启动 barrier 时执行给定的屏障操作，该操作由最后一个进入 barrier 的线程执行。
FutureTask(Runnable runnable, V result)
创建一个 FutureTask，一旦运行就执行给定的 Runnable，并安排成功完成时 get 返回给定的结果 。

类型变量类型为 Runnable 的 java.util.concurrent 中的构造方法参数
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
用给定的初始参数和默认的线程工厂及被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

javax.net.ssl 中 Runnable 的使用

返回 Runnable 的 javax.net.ssl 中的方法
abstract  Runnable SSLEngine.getDelegatedTask()
返回此 SSLEngine 的一个委托 Runnable 任务。

javax.swing 中 Runnable 的使用

实现 Runnable 的 javax.swing 中的类
 class SwingWorker<T,V>
在专用线程中执行长时间 GUI 交互任务的抽象类。

参数类型为 Runnable 的 javax.swing 中的方法
static void SwingUtilities.invokeAndWait(Runnable doRun)
导致 doRun.run() 在 AWT 事件指派线程上同步执行。
static void SwingUtilities.invokeLater(Runnable doRun)
导致 doRun.run() 在 AWT 事件指派线程上异步执行。

javax.swing.text 中 Runnable 的使用

实现 Runnable 的 javax.swing.text 中的类
 class AsyncBoxView.ChildState
表示子视图布局状态的记录。

返回 Runnable 的 javax.swing.text 中的方法
protected  Runnable LayoutQueue.waitForWork()
由 worker 线程使用以获取一个要执行的新任务

参数类型为 Runnable 的 javax.swing.text 中的方法
void | LayoutQueue.addTask(Runnable task) 添加一个任务，该任务不必立即执行，原因是其结果可能是不可见的。
void | AbstractDocument.render(Runnable r) 如果模型支持被异步更新，则此方法允许在并发情况下安全地呈现该模型。
void | Document.render(Runnable r) 如果模型支持异步更新，则允许在并发情况下安全呈现模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Runtime 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Runtime
的使用

使用 Runtime 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 Runtime 的使用

返回 Runtime 的 java.lang 中的方法
static Runtime Runtime.getRuntime()
返回与当前 Java 应用程序相关的运行时对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.RuntimeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.RuntimeException
的使用

使用 RuntimeException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |

java.awt 中 RuntimeException 的使用

java.awt 中 RuntimeException 的子类
class | HeadlessException 在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
class | IllegalComponentStateException 当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

java.awt.color 中 RuntimeException 的使用

java.awt.color 中 RuntimeException 的子类
class | CMMException 如果本机 CMM 返回一个错误，则抛出此异常。
class | ProfileDataException 当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

java.awt.dnd 中 RuntimeException 的使用

java.awt.dnd 中 RuntimeException 的子类
 class InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

java.awt.geom 中 RuntimeException 的使用

java.awt.geom 中 RuntimeException 的子类
 class IllegalPathStateException
对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。

java.awt.image 中 RuntimeException 的使用

java.awt.image 中 RuntimeException 的子类
class | ImagingOpException 如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
class | RasterFormatException 如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

java.lang 中 RuntimeException 的使用

java.lang 中 RuntimeException 的子类
class | ArithmeticException 当出现异常的运算条件时，抛出此异常。
class | ArrayIndexOutOfBoundsException 用非法索引访问数组时抛出的异常。
class | ArrayStoreException 试图将错误类型的对象存储到一个对象数组时抛出的异常。
class | ClassCastException 当试图将对象强制转换为不是实例的子类时，抛出该异常。
class | EnumConstantNotPresentException 当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
class | IllegalArgumentException 抛出的异常表明向方法传递了一个不合法或不正确的参数。
class | IllegalMonitorStateException 抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
class | IllegalStateException 在非法或不适当的时间调用方法时产生的信号。
class | IllegalThreadStateException 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
class | IndexOutOfBoundsException 指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
class | NegativeArraySizeException 如果应用程序试图创建大小为负的数组，则抛出该异常。
class | NullPointerException 当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
class | NumberFormatException 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
class | SecurityException 由安全管理器抛出的异常，指示存在安全侵犯。
class | StringIndexOutOfBoundsException 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
class | TypeNotPresentException 当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
class | UnsupportedOperationException 当不支持请求的操作时，抛出该异常。

java.lang.annotation 中 RuntimeException 的使用

java.lang.annotation 中 RuntimeException 的子类
class | AnnotationTypeMismatchException 若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
class | IncompleteAnnotationException 若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。

java.lang.reflect 中 RuntimeException 的使用

java.lang.reflect 中 RuntimeException 的子类
class | MalformedParameterizedTypeException 当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
class | UndeclaredThrowableException 如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

java.nio 中 RuntimeException 的使用

java.nio 中 RuntimeException 的子类
class | BufferOverflowException 当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
class | BufferUnderflowException 当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
class | InvalidMarkException 当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
class | ReadOnlyBufferException 当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

java.nio.channels 中 RuntimeException 的使用

java.nio.channels 中 RuntimeException 的子类
class | AlreadyConnectedException 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
class | CancelledKeyException 当试图使用不再有效的选择键时，抛出此未经检查的异常。
class | ClosedSelectorException 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
class | ConnectionPendingException 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
class | IllegalBlockingModeException 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
class | IllegalSelectorException 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
class | NoConnectionPendingException 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
class | NonReadableChannelException 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
class | NonWritableChannelException 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
class | NotYetBoundException 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | NotYetConnectedException 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | OverlappingFileLockException 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
class | UnresolvedAddressException 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
class | UnsupportedAddressTypeException 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

java.nio.charset 中 RuntimeException 的使用

java.nio.charset 中 RuntimeException 的子类
class | IllegalCharsetNameException 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
class | UnsupportedCharsetException 当不支持请求的 charset 时，抛出此未经检查的异常。

java.rmi 中 RuntimeException 的使用

java.rmi 中 RuntimeException 的子类
 class RMISecurityException
已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。

java.security 中 RuntimeException 的使用

java.security 中 RuntimeException 的子类
class | AccessControlException 此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
class | InvalidParameterException 当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
class | ProviderException 用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。

java.util 中 RuntimeException 的使用

java.util 中 RuntimeException 的子类
class | ConcurrentModificationException 当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | EmptyStackException 该异常由 Stack 类中的方法抛出，以表明堆栈为空。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
class | FormatterClosedException 格式器已关闭时抛出的未经检查的异常。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatException 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | InputMismatchException 由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | MissingResourceException 缺少资源时抛出此异常。
class | NoSuchElementException 由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。

java.util.concurrent 中 RuntimeException 的使用

java.util.concurrent 中 RuntimeException 的子类
class | CancellationException 如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
class | RejectedExecutionException 当无法执行某个任务时,由 Executor 抛出的异常。

java.util.regex 中 RuntimeException 的使用

java.util.regex 中 RuntimeException 的子类
 class PatternSyntaxException
抛出未经检查的异常，表明正则表达式模式中的语法错误。

javax.lang.model.element 中 RuntimeException 的使用

javax.lang.model.element 中 RuntimeException 的子类
class | UnknownAnnotationValueException 指示遇到一个未知种类的注释值。
class | UnknownElementException 指示遇到一个未知种类的元素。

javax.lang.model.type 中 RuntimeException 的使用

javax.lang.model.type 中 RuntimeException 的子类
class | MirroredTypeException 当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
class | MirroredTypesException 当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
class | UnknownTypeException 指示遇到未知种类的类型。

javax.management 中 RuntimeException 的使用

javax.management 中 RuntimeException 的子类
class | JMRuntimeException 由 JMX 实现所发出的运行时异常。
class | RuntimeErrorException 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
class | RuntimeMBeanException 表示由代理中的 MBean 方法抛出的运行时异常。
class | RuntimeOperationsException 表示在 MBean 上执行操作时代理中抛出的运行时异常。

返回 RuntimeException 的 javax.management 中的方法
RuntimeException | RuntimeMBeanException.getTargetException() 返回抛出的实际 RuntimeException。
RuntimeException | RuntimeOperationsException.getTargetException() 返回抛出的实际 RuntimeException。

参数类型为 RuntimeException 的 javax.management 中的构造方法
RuntimeMBeanException(RuntimeException e)
创建包装实际 java.lang.RuntimeException 的 RuntimeMBeanException。
RuntimeMBeanException(RuntimeException e, String message)
创建带有详细信息的实际 java.lang.RuntimeException 的 RuntimeMBeanException。
RuntimeOperationsException(RuntimeException e)
创建包装实际 java.lang.RuntimeException 的 RuntimeOperationsException。
RuntimeOperationsException(RuntimeException e, String message)
创建包装带有详细信息的实际 java.lang.RuntimeException 的 RuntimeOperationsException。

javax.management.monitor 中 RuntimeException 的使用

javax.management.monitor 中 RuntimeException 的子类
 class MonitorSettingException
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

javax.management.openmbean 中 RuntimeException 的使用

javax.management.openmbean 中 RuntimeException 的子类
class | InvalidKeyException 当方法参数作为复合数据 的项名称或表格数据 的行索引时，如果其无效，则抛出此运行时异常。
class | InvalidOpenTypeException 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
class | KeyAlreadyExistsException 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。

javax.print.attribute 中 RuntimeException 的使用

javax.print.attribute 中 RuntimeException 的子类
 class UnmodifiableSetException
当由于设置不可修改而无法执行请求的操作时，抛出该异常。

javax.swing.undo 中 RuntimeException 的使用

javax.swing.undo 中 RuntimeException 的子类
class | CannotRedoException 当 UndoableEdit 被通知 redo() 但无法执行时抛出。
class | CannotUndoException 当 UndoableEdit 被通知 undo() 但无法执行时抛出。

javax.xml.bind 中 RuntimeException 的使用

javax.xml.bind 中 RuntimeException 的子类
 class TypeConstraintException
此异常指示已检测到存在违反动态检查的类型约束的情况。

javax.xml.crypto 中 RuntimeException 的使用

javax.xml.crypto 中 RuntimeException 的子类
 class NoSuchMechanismException
当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。

javax.xml.ws 中 RuntimeException 的使用

javax.xml.ws 中 RuntimeException 的子类
class | ProtocolException ProtocolException 类是与特定协议绑定有关的异常的基类。
class | WebServiceException WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

javax.xml.ws.http 中 RuntimeException 的使用

javax.xml.ws.http 中 RuntimeException 的子类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 RuntimeException 的使用

javax.xml.ws.soap 中 RuntimeException 的子类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

org.omg.CORBA 中 RuntimeException 的使用

org.omg.CORBA 中 RuntimeException 的子类
class | ACTIVITY_COMPLETED ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
class | ACTIVITY_REQUIRED ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
class | BAD_CONTEXT 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
class | BAD_INV_ORDER 此异常指示调用者按错误顺序调用了操作。
class | BAD_OPERATION 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
class | BAD_PARAM 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
class | BAD_QOS 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
class | BAD_TYPECODE 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
class | CODESET_INCOMPATIBLE 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
class | COMM_FAILURE 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
class | DATA_CONVERSION 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
class | FREE_MEM 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
class | IMP_LIMIT 此异常指示在 OBR 运行时超过了某一项实现限制。
class | INITIALIZE ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
class | INTERNAL 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
class | INTF_REPOS 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
class | INV_FLAG 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
class | INV_IDENT 此异常指示 IDL 标识符在语法上是无效的。
class | INV_OBJREF 此异常指示对象引用存在内部错误。
class | INV_POLICY 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
class | INVALID_ACTIVITY 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
class | INVALID_TRANSACTION 当请求带有无效的事务上下文时，抛出此异常。
class | MARSHAL 表示网络中传来的请求或应答在结构上无效。
class | NO_IMPLEMENT 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
class | NO_MEMORY 如果 ORB 运行时出现内存不足，则抛出此异常。
class | NO_PERMISSION 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
class | NO_RESOURCES 当 ORB 遇到一些一般资源限制时，抛出此异常。
class | NO_RESPONSE 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
class | OBJ_ADAPTER 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
class | OBJECT_NOT_EXIST 只要在已删除的对象上执行调用，就会引发此异常。
class | PERSIST_STORE 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
class | REBIND 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
class | SystemException 所有 CORBA 标准异常的根类。
class | TIMEOUT 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
class | TRANSACTION_MODE 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
class | TRANSACTION_REQUIRED 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
class | TRANSACTION_ROLLEDBACK 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
class | TRANSACTION_UNAVAILABLE 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
class | TRANSIENT 当 ORB 试图到达某一对象但失败时，抛出此异常。
class | UNKNOWN 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。

org.omg.CORBA.portable 中 RuntimeException 的使用

org.omg.CORBA.portable 中 RuntimeException 的子类
class | IndirectionException Indirection 异常是一个特定于 Java 的系统异常。
class | UnknownException org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

org.w3c.dom 中 RuntimeException 的使用

org.w3c.dom 中 RuntimeException 的子类
 class DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

org.w3c.dom.events 中 RuntimeException 的使用

org.w3c.dom.events 中 RuntimeException 的子类
 class EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。

org.w3c.dom.ls 中 RuntimeException 的使用

org.w3c.dom.ls 中 RuntimeException 的子类
 class LSException
如果处理停止，解析或写操作可以抛出 LSException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.RuntimePermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.RuntimePermission
的使用

没有 java.lang.RuntimePermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.SecurityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.SecurityException
的使用

使用 SecurityException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.rmi | 提供 RMI 包。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 SecurityException 的使用

抛出 SecurityException 的 java.awt 中的方法
protected Window | KeyboardFocusManager.getGlobalActiveWindow() 返回活动 Window，即使调用线程处于活动 Window 之外的上下文中。
protected Container | KeyboardFocusManager.getGlobalCurrentFocusCycleRoot() 返回当前焦点循环根，即使调用线程处于当前焦点循环根之外的上下文中。
protected Window | KeyboardFocusManager.getGlobalFocusedWindow() 返回聚焦 Window，即使调用线程处于聚焦 Window 之外的上下文中。
protected Component | KeyboardFocusManager.getGlobalFocusOwner() 返回焦点所有者，即使调用线程处于焦点所有者之外的上下文中。
protected Component | KeyboardFocusManager.getGlobalPermanentFocusOwner() 返回持久焦点所有者，即使调用线程处于该持久焦点所有者之外的上下文中。
void | Window.setAlwaysOnTop(boolean alwaysOnTop) 设置此窗口是否应该始终位于其他窗口上方。
static void | KeyboardFocusManager.setCurrentKeyboardFocusManager(KeyboardFocusManager newManager) 设置调用线程上下文的当前 KeyboardFocusManager 实例。

java.beans 中 SecurityException 的使用

抛出 SecurityException 的 java.beans 中的方法
static void | Beans.setDesignTime(boolean isDesignTime) 用于指示是否正运行在应用程序生成器环境中。
static void | Beans.setGuiAvailable(boolean isGuiAvailable) 用于指示是否正运行在可进行 GUI 交互的环境中。

java.io 中 SecurityException 的使用

抛出 SecurityException 的 java.io 中的方法
protected boolean | ObjectOutputStream.enableReplaceObject(boolean enable) 允许流对流中的对象进行替换。
protected boolean | ObjectInputStream.enableResolveObject(boolean enable) 使流允许从该流读取的对象被替代。

抛出 SecurityException 的 java.io 中的构造方法
ObjectInputStream()
为完全重新实现 ObjectInputStream 的子类提供一种方式，让它不必分配仅由 ObjectInputStream 的实现使用的私有数据。
ObjectOutputStream()
为完全重新实现 ObjectOutputStream 的子类提供一种方法，让它不必分配仅由 ObjectOutputStream 的实现使用的私有数据。

java.lang 中 SecurityException 的使用

抛出 SecurityException 的 java.lang 中的方法
Constructor<T> | Class.getConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
Constructor<?>[] | Class.getConstructors() 返回一个包含某些 Constructor 对象的数组，这些对象反映此 Class 对象所表示的类的所有公共构造方法。
Class<?>[] | Class.getDeclaredClasses() 返回 Class 对象的一个数组，这些对象反映声明为此 Class 对象所表示的类的成员的所有类和接口。
Constructor<T> | Class.getDeclaredConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
Constructor<?>[] | Class.getDeclaredConstructors() 返回 Constructor 对象的一个数组，这些对象反映此 Class 对象表示的类声明的所有构造方法。
Field | Class.getDeclaredField(String name) 返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。
Field[] | Class.getDeclaredFields() 返回 Field 对象的一个数组，这些对象反映此 Class 对象所表示的类或接口所声明的所有字段。
Method | Class.getDeclaredMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
Method[] | Class.getDeclaredMethods() 返回 Method 对象的一个数组，这些对象反映此 Class 对象表示的类或接口声明的所有方法，包括公共、保护、默认（包）访问和私有方法，但不包括继承的方法。
Field | Class.getField(String name) 返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。
Field[] | Class.getFields() 返回一个包含某些 Field 对象的数组，这些对象反映此 Class 对象所表示的类或接口的所有可访问公共字段。
Method | Class.getMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。
Method[] | Class.getMethods() 返回一个包含某些 Method 对象的数组，这些对象反映此 Class 对象所表示的类或接口（包括那些由该类或接口声明的以及从超类和超接口继承的那些的类或接口）的公共 member 方法。

java.lang.reflect 中 SecurityException 的使用

抛出 SecurityException 的 java.lang.reflect 中的方法
static void | AccessibleObject.setAccessible(AccessibleObject[] array, boolean flag) 使用单一安全性检查（为了提高效率）为一组对象设置 accessible 标志的便捷方法。
void | AccessibleObject.setAccessible(boolean flag) 将此对象的 accessible 标志设置为指示的布尔值。

java.rmi 中 SecurityException 的使用

java.rmi 中 SecurityException 的子类
 class RMISecurityException
已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。

java.rmi.server 中 SecurityException 的使用

抛出 SecurityException 的 java.rmi.server 中的方法
static ClassLoader RMIClassLoader.getClassLoader(String codebase)
返回从给定的基本代码 URL 路径加载类的类加载器。

java.security 中 SecurityException 的使用

java.security 中 SecurityException 的子类
 class AccessControlException
此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。

抛出 SecurityException 的 java.security 中的方法
void | Permission.checkGuard(Object object) 为某权限实现 guard 接口。
void | Guard.checkGuard(Object object) 确定是否允许访问受保护的 object 对象。
Object | GuardedObject.getObject() 获取受保护对象；如果 guard 拒绝了对受保护对象的访问，则抛出异常。

java.util.logging 中 SecurityException 的使用

抛出 SecurityException 的 java.util.logging 中的方法
void | Logger.addHandler(Handler handler) 添加一个日志 Handler 以接收日志记录消息。
void | LogManager.addPropertyChangeListener(PropertyChangeListener l) 添加重读日志属性时调用的事件侦听器。
void | LogManager.checkAccess() 检查使用当前上下文来修改日志配置是否受信任。
void | FileHandler.close() 关闭所有文件。
void | MemoryHandler.close() 关闭 Handler，并释放所有相关的资源。
void | SocketHandler.close() 关闭此输出流。
void | StreamHandler.close() 关闭当前输出流。
abstract void | Handler.close() 关闭 Handler，并释放所有相关的资源。
void | LogManager.readConfiguration() 重新初始化日志属性并重新读取日志配置。
void | LogManager.readConfiguration(InputStream ins) 从给定流重新初始化并重新读取日志配置，该配置为 java.util.Properties 格式。
void | Logger.removeHandler(Handler handler) 移除一个日志 Handler。
void | LogManager.removePropertyChangeListener(PropertyChangeListener l) 移除属性更改事件的事件侦听器。
void | LogManager.reset() 重置日志配置。
void | StreamHandler.setEncoding(String encoding) 设置（或更改）该 Handler 所用的字符编码。
void | Handler.setEncoding(String encoding) 设置该 Handler 所用的字符编码。
void | Handler.setFilter(Filter newFilter) 设置 Filter，以控制该 Handler 的输出。
void | Logger.setFilter(Filter newFilter) 设置过滤器以控制此 Logger 的输出。
void | Handler.setFormatter(Formatter newFormatter) 设置 Formatter。
void | Handler.setLevel(Level newLevel) 设置日志级别，指定该 Handler 所记录的信息级别。
void | Logger.setLevel(Level newLevel) 设置日志级别，指定此 logger 记录的消息级别。
protected void | StreamHandler.setOutputStream(OutputStream out) 更改输出流。
void | MemoryHandler.setPushLevel(Level newLevel) 设置 pushLevel。

抛出 SecurityException 的 java.util.logging 中的构造方法
FileHandler()
构造一个默认的 FileHandler。
FileHandler(String pattern)
初始化要写入给定文件名的 FileHandler 。
FileHandler(String pattern, boolean append)
初始化要写入给定文件名的 FileHandler（使用可选的 append）。
FileHandler(String pattern, int limit, int count)
初始化要写入文件集的 FileHandler。
FileHandler(String pattern, int limit, int count, boolean append)
初始化要写入文件集的 FileHandler（使用可选的 append）。

javax.swing 中 SecurityException 的使用

抛出 SecurityException 的 javax.swing 中的方法
static void | FocusManager.setCurrentManager(FocusManager aFocusManager) 设置调用线程上下文的当前 KeyboardFocusManager 实例。
static void | UIManager.setInstalledLookAndFeels(UIManager.LookAndFeelInfo[] infos) 设置可用外观的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.SecurityManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.SecurityManager
的使用

使用 SecurityManager 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.rmi | 提供 RMI 包。

java.lang 中 SecurityManager 的使用

返回 SecurityManager 的 java.lang 中的方法
static SecurityManager System.getSecurityManager()
获取系统安全接口。

参数类型为 SecurityManager 的 java.lang 中的方法
static void System.setSecurityManager(SecurityManager s)
设置系统安全性。

java.rmi 中 SecurityManager 的使用

java.rmi 中 SecurityManager 的子类
 class RMISecurityManager
由使用下载的代码的 RMI 应用程序使用的 SecurityManager 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Short 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Short
的使用

使用 Short 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang 中 Short 的使用

类型参数类型为 Short 的 java.lang 中的字段
static Class<Short> Short.TYPE
表示基本类型 short 的 Class 实例。

返回 Short 的 java.lang 中的方法
static Short | Short.decode(String nm) 将 String 解码为 Short。
static Short | Short.valueOf(short s) 返回表示指定 short 值的 Short 实例。
static Short | Short.valueOf(String s) 返回一个保持指定 String 所给出的值的 Short 对象。
static Short | Short.valueOf(String s, int radix) 返回一个 Short 对象，该对象保持从指定的 String 中提取的值，该值是在使用第二个参数给出的基数对指定字符串进行解析时提取的。

参数类型为 Short 的 java.lang 中的方法
 int Short.compareTo(Short anotherShort)
比较两个 Short 对象所表示的数值。

javax.management.openmbean 中 Short 的使用

类型参数类型为 Short 的 javax.management.openmbean 中的字段
static SimpleType<Short> SimpleType.SHORT
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Short 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.StackOverflowError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StackOverflowError
的使用

没有 java.lang.StackOverflowError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.StackTraceElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StackTraceElement
的使用

使用 StackTraceElement 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang 中 StackTraceElement 的使用

返回 StackTraceElement 的 java.lang 中的方法
 StackTraceElement[] Thread.getStackTrace()
返回一个表示该线程堆栈转储的堆栈跟踪元素数组。
 StackTraceElement[] Throwable.getStackTrace()
提供编程访问由 Throwable.printStackTrace() 输出的堆栈跟踪信息。

参数类型为 StackTraceElement 的 java.lang 中的方法
 void Throwable.setStackTrace(StackTraceElement[] stackTrace)
设置将由 Throwable.getStackTrace() 返回，并由 Throwable.printStackTrace() 和相关方法输出的堆栈跟踪元素。

java.lang.management 中 StackTraceElement 的使用

返回 StackTraceElement 的 java.lang.management 中的方法
StackTraceElement | MonitorInfo.getLockedStackFrame() 返回锁定对象监视器的堆栈帧。
StackTraceElement[] | ThreadInfo.getStackTrace() 返回与此 ThreadInfo 关联的线程的堆栈跟踪。

参数类型为 StackTraceElement 的 java.lang.management 中的构造方法
MonitorInfo(String className, int identityHashCode, int stackDepth, StackTraceElement stackFrame)
构造一个 MonitorInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.StrictMath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StrictMath
的使用

没有 java.lang.StrictMath 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.String 的使用 (Java 2 Platform SE 6)

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM 2 Platform
Standard Ed. 6

上一个 下一个

框架 无框架

类 java.lang.String
的使用

使用 String 的软件包

java.applet

提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

java.awt

包含用于创建用户界面和绘制图形图像的所有类。

java.awt.color

提供用于颜色空间的类。

java.awt.datatransfer

提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.dnd

Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.event

提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt.font

提供与字体相关的类和接口。

java.awt.geom

提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.im.spi

提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.image

提供创建和修改图像的各种类。

java.awt.image.renderable

提供用于生成与呈现无关的图像的类和接口。

java.awt.print

为通用的打印 API 提供类和接口。

java.beans

包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans.beancontext

提供与 bean 上下文有关的类和接口。

java.io

通过数据流、序列化和文件系统提供系统输入和输出。

java.lang

提供利用 Java 编程语言进行程序设计的基础类。

java.lang.annotation

为 Java 编程语言注释设施提供库支持。

java.lang.instrument

提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.management

提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.reflect

提供类和接口，以获得关于类和对象的反射信息。

java.math

提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。

java.net

为实现网络应用程序提供类。

java.nio

定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio.channels

定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.charset

定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.nio.charset.spi

java.nio.charset 包的服务提供者类。

java.rmi

提供 RMI 包。

java.rmi.activation

为 RMI 对象激活提供支持。

java.rmi.dgc

为 RMI 分布式垃圾回收提供了类和接口。

java.rmi.registry

提供 RMI 注册表的一个类和两个接口。

java.rmi.server

提供支持服务器端 RMI 的类和接口。

java.security

为安全框架提供类和接口。

java.security.acl

此包中的类和接口已经被 java.security 包中的类取代。

java.security.cert

提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.spec

提供密钥规范和算法参数规范的类和接口。

java.sql

提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.text

提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.util

包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util.concurrent

在并发编程中很常用的实用工具类。

java.util.concurrent.atomic

类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.locks

为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.jar

提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.logging

提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.prefs

此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.regex

用于匹配字符序列与正则表达式指定模式的类。

java.util.spi

java.util 包中类的服务提供者类。

java.util.zip

提供用于读写标准 ZIP 和 GZIP 文件格式的类。

javax.accessibility

定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.activation

javax.activity

包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。

javax.annotation

javax.annotation.processing

用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.crypto

为加密操作提供类和接口。

javax.crypto.spec

为密钥规范和算法参数规范提供类和接口。

javax.imageio

Java Image I/O API 的主要包。

javax.imageio.event

Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。

javax.imageio.metadata

用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio.plugins.jpeg

支持内置 JPEG 插件的类。

javax.imageio.spi

包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.stream

Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.jws

javax.jws.soap

javax.lang.model

用来为 Java 编程语言建立模型的包的类和层次结构。

javax.lang.model.element

用于 Java 编程语言的模型元素的接口。

javax.lang.model.type

用来为 Java 编程语言类型建立模型的接口。

javax.lang.model.util

用来帮助处理程序元素和类型的实用工具。

javax.management

提供 Java Management Extensions 的核心类。

javax.management.loading

提供实现高级动态加载的类。

javax.management.modelmbean

提供了 ModelMBean 类的定义。

javax.management.monitor

提供 monitor 类的定义。

javax.management.openmbean

提供开放数据类型和 Open MBean 描述符类。

javax.management.relation

提供 Relation Service 的定义。

javax.management.remote

对 JMX MBean 服务器进行远程访问使用的接口。

javax.management.remote.rmi

RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.timer

提供对 Timer MBean（计时器 MBean）的定义。

javax.naming

为访问命名服务提供类和接口。

javax.naming.directory

扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming.event

在访问命名和目录服务时提供对事件通知的支持。

javax.naming.ldap

提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.spi

提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.net

提供用于网络应用程序的类。

javax.net.ssl

提供用于安全套接字包的类。

javax.print

为 JavaTM Print Service API 提供了主要类和接口。

javax.print.attribute

提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

javax.print.attribute.standard

包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.event

包 javax.print.event 包含事件类和侦听器接口。

javax.rmi.CORBA

包含用于 RMI-IIOP 的可移植性 API。

javax.rmi.ssl

通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

javax.script

脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.security.auth

此包提供用于进行验证和授权的框架。

javax.security.auth.callback

此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。

javax.security.auth.kerberos

此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth.login

此包提供可插入的验证框架。

javax.security.auth.spi

此包提供用于实现可插入验证模块的接口。

javax.security.auth.x500

此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

javax.security.cert

为公钥证书提供类。

javax.security.sasl

包含用于支持 SASL 的类和接口。

javax.sound.midi

提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.sampled

提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sql

为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql.rowset

JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset.serial

提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

javax.sql.rowset.spi

第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.swing

提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing.border

提供围绕 Swing 组件绘制特殊边框的类和接口。

javax.swing.colorchooser

包含供 JColorChooser 组件使用的类和接口。

javax.swing.event

供 Swing 组件触发的事件使用。

javax.swing.filechooser

包含 JFileChooser 组件使用的类和接口。

javax.swing.plaf

提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.plaf.basic

提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.metal

提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.multi

提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf.synth

Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.table

提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.text

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html.parser

提供默认的 HTML 解析器以及支持类。

javax.swing.text.rtf

提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing.tree

提供处理 javax.swing.JTree 的类和接口。

javax.swing.undo

允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.tools

为能够从程序（例如，编译器）中调用的工具提供接口。

javax.transaction

包含解组期间通过 ORB 机制抛出的三个异常。

javax.transaction.xa

提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.xml

根据 XML 规范定义核心 XML 常量和功能。

javax.xml.bind

为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind.annotation

定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation.adapters

XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。

javax.xml.bind.attachment

此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。

javax.xml.bind.helpers

仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.crypto

用于 XML 加密的通用类。

javax.xml.crypto.dom

javax.xml.crypto 包的特定于 DOM 的类。

javax.xml.crypto.dsig

用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig.keyinfo

用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.spec

XML 数字签名的参数类。

javax.xml.datatype

XML/Java 类型映射关系。

javax.xml.namespace

XML 名称空间处理。

javax.xml.parsers

提供允许处理 XML 文档的类。

javax.xml.soap

提供用于创建和构建 SOAP 消息的 API。

javax.xml.stream

javax.xml.stream.events

javax.xml.stream.util

javax.xml.transform

此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform.dom

此包实现特定于 DOM 的转换 API。

javax.xml.transform.sax

此包实现特定于 SAX2 的转换 API。

javax.xml.transform.stax

提供特定于 StAX 的转换 API。

javax.xml.transform.stream

此包实现特定于流和 URI 的转换 API。

javax.xml.validation

此包提供了用于 XML 文档验证的 API。

javax.xml.ws

此包包含核心 JAX-WS API。

javax.xml.ws.handler

该包定义用于消息处理程序的 API。

javax.xml.ws.handler.soap

该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws.http

该包定义特定于 HTTP 绑定的 API。

javax.xml.ws.soap

该包定义特定于 SOAP 绑定的 API。

javax.xml.ws.spi

该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.xpath

此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

org.ietf.jgss

此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.omg.CORBA

提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA_2_3

CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。

org.omg.CORBA_2_3.portable

提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。

org.omg.CORBA.DynAnyPackage

提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。

org.omg.CORBA.ORBPackage

提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。

org.omg.CORBA.portable

提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA.TypeCodePackage

提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。

org.omg.CosNaming

为 Java IDL 提供命名服务。

org.omg.CosNaming.NamingContextExtPackage

此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

org.omg.CosNaming.NamingContextPackage

此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.DynamicAny

提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny.DynAnyFactoryPackage

此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。

org.omg.DynamicAny.DynAnyPackage

此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。

org.omg.IOP

此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP.CodecFactoryPackage

此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。

org.omg.IOP.CodecPackage

此包根据 IOP::Codec IDL 接口定义生成。

org.omg.Messaging

此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。

org.omg.PortableInterceptor

提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor.ORBInitInfoPackage

此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。

org.omg.PortableServer

提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer.CurrentPackage

提供各种方法实现，这些实现能够访问调用方法的对象的身份。

org.omg.PortableServer.POAManagerPackage

封装 POA 关联的处理状态。

org.omg.PortableServer.POAPackage

允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer.portable

提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.stub.java.rmi

包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

org.w3c.dom

为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom.bootstrap

org.w3c.dom.events

org.w3c.dom.ls

org.xml.sax

此包提供了核心 SAX API。

org.xml.sax.ext

此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.helpers

此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 中 String 的使用

返回 String 的 java.applet 中的方法

String

Applet.getAppletInfo()
返回有关此 applet 的信息。

String

AppletStub.getParameter(String name)
返回 HTML 标记中命名参数的值。

String

Applet.getParameter(String name)
返回 HTML 标记中指定参数的值。

String[][]

Applet.getParameterInfo()
返回此 applet 理解的关于参数的信息。

返回变量类型为 String 的类型的 java.applet 中的方法

Iterator<String>

AppletContext.getStreamKeys()
找到此 applet 上下文中所有流对应的键。

参数类型为 String 的 java.applet 中的方法

Applet

AppletContext.getApplet(String name)
通过给定名称找到并返回此 applet 上下文表示的文档中的 applet。

AudioClip

Applet.getAudioClip(URL url, String name)
返回 URL 和 name 参数指定的 AudioClip 对象。

Image

Applet.getImage(URL url, String name)
返回能被绘制到屏幕上的 Image 对象。

String

AppletStub.getParameter(String name)
返回 HTML 标记中命名参数的值。

String

Applet.getParameter(String name)
返回 HTML 标记中指定参数的值。

InputStream

AppletContext.getStream(String key)
返回此 applet 上下文中指定键所关联的流。

void

Applet.play(URL url, String name)
播放音频剪辑，给定了 URL 及与之相对的说明符。

void

AppletContext.setStream(String key, InputStream stream)
在此 applet 上下文中用指定的键关联指定的流。

void

AppletContext.showDocument(URL url, String target)
请求浏览器或 applet viewer 显示由 url 参数所指示的 Web 页。

void

AppletContext.showStatus(String status)
请求参数字符串显示在“状态窗口”中。

void

Applet.showStatus(String msg)
请求将参数字符串显示在“状态窗口”中。

java.awt 中 String 的使用

声明为 String 的 java.awt 中的字段

static String

BorderLayout.AFTER_LAST_LINE
与 PAGE_END 同义。

static String

BorderLayout.AFTER_LINE_ENDS
与 LINE_END 同义。

static String

BorderLayout.BEFORE_FIRST_LINE
与 PAGE_START 同义。

static String

BorderLayout.BEFORE_LINE_BEGINS
与 LINE_START 同义。

static String

BorderLayout.CENTER
中间区域的布局约束（容器中央）。

static String

Font.DIALOG
逻辑字体 "Dialog" 的规范系列名称的 String 常量。

static String

Font.DIALOG_INPUT
逻辑字体 "DialogInput" 的规范系列名称的 String 常量。

static String

BorderLayout.EAST
东区域的布局约束（容器右边）。

static String

BorderLayout.LINE_END
组件出现在布局的行方向的结尾处。

static String

BorderLayout.LINE_START
组件出现在布局的行方向的开始处。

static String

Font.MONOSPACED
逻辑字体 "Monospaced" 的规范系列名称的 String 常量。

protected  String

Font.name
Font 的逻辑名称，它被传递到构造方法中。

protected  String

Cursor.name
光标的用户可视名称。

static String

BorderLayout.NORTH
北区域的布局约束（容器顶部）。

static String

BorderLayout.PAGE_END
组件出现在最后一行布局内容之后。

static String

BorderLayout.PAGE_START
组件出现在第一行布局内容之前。

static String

Font.SANS_SERIF
逻辑字体 "SansSerif" 的规范系列名称的 String 常量。

static String

Font.SERIF
逻辑字体 "Serif" 的规范系列名称的 String 常量。

static String

BorderLayout.SOUTH
南区域的布局约束（容器底部）。

static String

BorderLayout.WEST
西区域的布局约束（容器左边）。

类型参数类型为 String 的 java.awt 中的字段

protected  Map<String,Object>

Toolkit.desktopProperties

返回 String 的 java.awt 中的方法

String

Button.AccessibleAWTButton.getAccessibleActionDescription(int i)
返回对象指定操作的描述。

String

Checkbox.AccessibleAWTCheckbox.getAccessibleActionDescription(int i)
返回对象指定操作的描述。

String

CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleActionDescription(int i)
返回对象指定操作的描述。

String

Choice.AccessibleAWTChoice.getAccessibleActionDescription(int i)
返回对象指定操作的描述。

String

MenuItem.AccessibleAWTMenuItem.getAccessibleActionDescription(int i)
返回对该对象指定操作的描述。

String

MenuComponent.AccessibleAWTMenuComponent.getAccessibleDescription()
获取此对象的可访问的描述。

String

Component.AccessibleAWTComponent.getAccessibleDescription()
获取此对象的可访问描述。

String

Button.AccessibleAWTButton.getAccessibleName()
获取此对象的可访问名称。

String

MenuItem.AccessibleAWTMenuItem.getAccessibleName()
获取此对象的可访问名称。

String

MenuComponent.AccessibleAWTMenuComponent.getAccessibleName()
获取此对象的可访问的名称。

String

Label.AccessibleAWTLabel.getAccessibleName()
获取此对象的可访问名称。

String

Component.AccessibleAWTComponent.getAccessibleName()
获取此对象的可访问名称。

String

Button.getActionCommand()
返回此按钮激发的动作事件的命令名称。

String

TrayIcon.getActionCommand()
返回由此托盘图标触发的动作事件的命令名。

String

MenuItem.getActionCommand()
获取由此菜单项引发的动作事件的命令名。

String

TextComponent.AccessibleAWTTextComponent.getAfterIndex(int part, int index)
返回给定索引后面的 String。

String

TextComponent.AccessibleAWTTextComponent.getAtIndex(int part, int index)
返回给定索引处的 String。

abstract  String[]

GraphicsEnvironment.getAvailableFontFamilyNames()
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，它针对默认语言环境进行了本地化，由 Locale.getDefault() 返回。

abstract  String[]

GraphicsEnvironment.getAvailableFontFamilyNames(Locale l)
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，已针对默认语言环境对它进行了本地化。

String

TextComponent.AccessibleAWTTextComponent.getBeforeIndex(int part, int index)
返回给定索引前面的 String。

String

FileDialog.getDirectory()
获取此文件对话框的目录。

String

Font.getFamily()
返回此 Font 的系列名称。

String

Font.getFamily(Locale l)
返回此 Font 的系列名称（已经针对指定语言环境进行了本地化）。

String

FileDialog.getFile()
获取此文件对话框的选定文件。

String

JobAttributes.getFileName()
指定使用这些属性的作业的输出文件的文件名。

abstract  String[]

Toolkit.getFontList()
已过时。 请参阅 GraphicsEnvironment.getAvailableFontFamilyNames()

String

Font.getFontName()
返回此 Font 的字体外观名称。

String

Font.getFontName(Locale l)
返回此 Font 的字体外观名称（已经针对指定语言环境进行了本地化）。

abstract  String

GraphicsDevice.getIDstring()
返回与此 GraphicsDevice 关联的标识字符串。

String

Choice.getItem(int index)
获取此 Choice 菜单中指定索引上的字符串。

String

List.getItem(int index)
获取与指定索引关联的项。

String[]

List.getItems()
获取列表中的项。

String

Button.getLabel()
获取此按钮的标签。

String

Checkbox.getLabel()
获取此复选框的标签。

String

MenuItem.getLabel()
获取此菜单项的标签。

String

HeadlessException.getMessage()

String

MenuComponent.getName()
获取该菜单组件的名称。

String

Font.getName()
返回此 Font 的逻辑名称。

String

Cursor.getName()
返回此光标的名称。

String

Component.getName()
获取组件的名称。

String

JobAttributes.getPrinter()
为使用这些属性的作业返回目标打印机。

static String

Toolkit.getProperty(String key, String defaultValue)
获取具有指定键和默认值的属性。

String

Font.getPSName()
返回此 Font 的 postscript 名称。

String

Choice.getSelectedItem()
获取当前选择的字符串表示形式。

String

List.getSelectedItem()
获取此滚动列表中选中的项。

String[]

List.getSelectedItems()
获取此滚动列表中选中的项。

String

TextComponent.getSelectedText()
返回此文本组件所表示文本的选定文本。

String

TextComponent.AccessibleAWTTextComponent.getSelectedText()
返回选定文本的一部分。

String

TextComponent.getText()
返回此文本组件表示的文本。

String

Label.getText()
获取此标签的文本。

String

Dialog.getTitle()
获取 dialog 的标题。

String

Frame.getTitle()
获得窗体的标题。

String

TrayIcon.getToolTip()
返回与此 TrayIcon 关联的工具提示字符串。

String

Window.getWarningString()
获取此窗口中显示的警告字符串。

protected  String

Button.paramString()
返回此 Button 状态的字符串表示形式。

protected  String

Checkbox.paramString()
返回表示此 Checkbox 的状态的字符串。

String

CheckboxMenuItem.paramString()
返回表示此 CheckBoxMenuItem 状态的字符串。

protected  String

Choice.paramString()
返回表示此 Choice 菜单的状态的字符串。

protected  String

FileDialog.paramString()
返回表示此 FileDialog 窗口状态的字符串。

protected  String

List.paramString()
返回表示此滚动列表状态的参数字符串。

String

ScrollPane.paramString()
返回表示此 ScrollPane 的状态的字符串。

String

ScrollPaneAdjustable.paramString()
返回表示此滚动条的状态的字符串。

protected  String

Scrollbar.paramString()
返回表示此 Scrollbar 当前状态的字符串表示形式。

protected  String

TextArea.paramString()
返回表示此 TextArea 状态的字符串。

protected  String

TextComponent.paramString()
返回表示此 TextComponent 状态的字符串。

protected  String

TextField.paramString()
返回表示此 TextField 状态的字符串。

protected  String

MenuShortcut.paramString()
返回表示此 MenuShortcut 状态的参数字符串。

protected  String

Event.paramString()
注：Event 类已废弃，只可用于向后兼容。

String

Menu.paramString()
返回表示此 Menu 状态的字符串。

String

MenuItem.paramString()
返回表示此 MenuItem 状态的字符串。

protected  String

MenuComponent.paramString()
返回表示此 MenuComponent 状态的字符串。

protected  String

Dialog.paramString()
返回表示此 dialog 状态的字符串。

String

AWTEvent.paramString()
返回表示此 Event 状态的字符串。

protected  String

Label.paramString()
返回一个表示此 Label 状态的字符串。

protected  String

Frame.paramString()
返回表示此 Frame 状态的字符串。

protected  String

Container.paramString()
返回表示此 Container 的状态的字符串。

protected  String

Component.paramString()
返回此组件状态的字符串表示形式。

String

CheckboxGroup.toString()
返回此复选框组的字符串表示形式，包含当前选中复选框的值。

String

GridBagLayout.toString()
返回此网格包布局的值的字符串表示形式。

String

JobAttributes.toString()
返回此 JobAttributes 的字符串表示形式。

String

PageAttributes.toString()
返回此 PageAttributes 的字符串表示形式。

String

Robot.toString()
返回此 Robot 的字符串表示形式。

String

ScrollPaneAdjustable.toString()
返回此滚动条及其值的字符串表示形式。

String

MenuShortcut.toString()
返回此菜单快捷方式的国际化描述。

String

GridLayout.toString()
返回此网格布局的值的字符串表示形式。

String

CardLayout.toString()
返回此卡片布局状态的字符串表示形式。

String

FlowLayout.toString()
返回此 FlowLayout 对象及其值的字符串表示形式。

String

FontMetrics.toString()
返回此 FontMetrics 对象的值的 String 表示形式。

String

Event.toString()
注：Event 类已废弃，只可用于向后兼容。

String

MenuComponent.toString()
返回此菜单组件的表示形式。

String

Point.toString()
返回此点的字符串表示形式及其在 (x,y) 坐标空间中的位置。

String

SystemColor.toString()
返回此 Color 值的字符串表示形式。

String

AWTKeyStroke.toString()
返回一个显示并标识此对象属性的字符串。

String

Insets.toString()
返回此 Insets 对象的字符串表示形式。

String

Rectangle.toString()
返回表示此 Rectangle 及其值的 String。

String

BorderLayout.toString()
返回此边框布局的状态的字符串表示形式。

String

Color.toString()
返回此 Color 的字符串表示形式。

String

Graphics.toString()
返回表示此 Graphics 对象值的 String 对象。

String

RenderingHints.toString()
返回 hashmap 的一个相当长的字符串表示形式，该 hashmap 包含此 RenderingHints 对象的键或值的映射关系。

String

Font.toString()
将此 Font 对象转换为 String 表示形式。

String

Cursor.toString()
返回此光标的字符串表示形式。

String

Dimension.toString()
返回此 Dimension 对象的 height 和 width 字段的字符串表示形式。

String

AWTEvent.toString()
返回此对象的字符串表示形式。

String

Component.toString()
返回此组件及其值的字符串表示形式。

参数类型为 String 的 java.awt 中的方法

void

Choice.add(String item)
将一个项添加到此 Choice 菜单中。

void

List.add(String item)
向滚动列表的末尾添加指定的项。

void

Menu.add(String label)
将带有指定标签的项添加到此菜单。

Component

Container.add(String name, Component comp)
将指定组件添加到此容器中。

void

List.add(String item, int index)
向滚动列表中索引指示的位置添加指定的项。

void

Choice.addItem(String item)
如果对于 Java 2 platform v1.1 已过时，请使用 add 方法替换。

void

List.addItem(String item)
已过时。 由 add(String) 取代。

void

List.addItem(String item, int index)
已过时。 由 add(String, int) 取代。

void

GridBagLayout.addLayoutComponent(String name, Component comp)
无效，因为此布局管理器不使用每组件字符串。

void

GridLayout.addLayoutComponent(String name, Component comp)
将具有指定名称的指定组件添加到布局。

void

CardLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。

void

FlowLayout.addLayoutComponent(String name, Component comp)
将指定的组件添加到布局中。

void

BorderLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。

void

LayoutManager.addLayoutComponent(String name, Component comp)
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

void

SystemTray.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 添加到特定属性的侦听器列表中。

void

KeyboardFocusManager.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 添加到特定属性的侦听器列表。

void

Toolkit.addPropertyChangeListener(String name, PropertyChangeListener pcl)
为指定的桌面属性添加指定的属性更改侦听器。

void

Window.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 添加到某个特定属性的侦听器列表。

void

Container.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到某个指定属性的侦听器列表中。

void

Component.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
向指定属性的侦听器列表添加一个 PropertyChangeListener。

void

KeyboardFocusManager.addVetoableChangeListener(String propertyName, VetoableChangeListener listener)
将 VetoableChangeListener 添加到特定属性的侦听器列表。

void

TextArea.append(String str)
将给定文本追加到文本区的当前文本。

void

TextArea.appendText(String str)
已过时。 从 JDK version 1.1 开始，由 append(String) 取代。

void

Window.applyResourceBundle(String rbName)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。

int

Font.canDisplayUpTo(String str)
指示此 Font 是否可以显示指定的 String。

Cursor

Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name)
创建一个新的自定义光标对象。

GlyphVector

Font.createGlyphVector(FontRenderContext frc, String str)
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。

abstract  Image

Toolkit.createImage(String filename)
返回从指定文件获取像素数据的图像。

static Color

Color.decode(String nm)
将 String 转换成整数，并返回指定的不透明 Color。

static Font

Font.decode(String str)
返回 str 参数所描述的 Font。

void

TrayIcon.displayMessage(String caption, String text, TrayIcon.MessageType messageType)
在托盘图标附近显示弹出消息。

abstract  void

Graphics2D.drawString(String str, float x, float y)
使用 Graphics2D 上下文中当前文本属性状态呈现由指定 String 指定的文本。

abstract  void

Graphics2D.drawString(String str, int x, int y)
使用 Graphics2D 上下文中的当前文本属性状态呈现指定的 String 的文本。

abstract  void

Graphics.drawString(String str, int x, int y)
使用此图形上下文的当前字体和颜色绘制由指定 string 给定的文本。

protected  void

Component.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
支持报告布尔属性的绑定属性改变。

void

Component.firePropertyChange(String propertyName, byte oldValue, byte newValue)
报告绑定属性的改变。

void

Component.firePropertyChange(String propertyName, char oldValue, char newValue)
报告绑定属性的改变。

void

Component.firePropertyChange(String propertyName, double oldValue, double newValue)
报告绑定属性的改变。

void

Component.firePropertyChange(String propertyName, float oldValue, float newValue)
报告绑定属性的改变。

protected  void

Component.firePropertyChange(String propertyName, int oldValue, int newValue)
支持报告整数属性的绑定属性改变。

void

Component.firePropertyChange(String propertyName, long oldValue, long newValue)
报告绑定属性的改变。

protected  void

KeyboardFocusManager.firePropertyChange(String propertyName, Object oldValue, Object newValue)
激发 PropertyChangeEvent 以响应绑定属性中的更改。

protected  void

Component.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告 Object 属性的绑定属性改变。

void

Component.firePropertyChange(String propertyName, short oldValue, short newValue)
报告绑定属性的改变。

protected  void

KeyboardFocusManager.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
激发 PropertyChangeEvent 以响应可否决属性中的更改。

static AWTKeyStroke

AWTKeyStroke.getAWTKeyStroke(String s)
分析字符串并返回一个 AWTKeyStroke。

static Color

Color.getColor(String nm)
查找系统属性中的一种颜色。

static Color

Color.getColor(String nm, Color v)
查找系统属性中的一种颜色。

static Color

Color.getColor(String nm, int v)
查找系统属性中的一种颜色。

Object

Toolkit.getDesktopProperty(String propertyName)
获取指定桌面属性的值。

static Font

Font.getFont(String nm)
从系统属性列表返回一个 Font 对象。

static Font

Font.getFont(String nm, Font font)
从系统属性列表获取指定的 Font。

protected abstract  java.awt.peer.FontPeer

Toolkit.getFontPeer(String name, int style)
已过时。 请参阅 java.awt.GraphicsEnvironment#getAllFonts

abstract  Image

Toolkit.getImage(String filename)
返回一幅图像，该图像从指定文件中获取像素数据，图像格式可以是 GIF、JPEG 或 PNG。

LineMetrics

Font.getLineMetrics(String str, FontRenderContext frc)
返回一个使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。

LineMetrics

FontMetrics.getLineMetrics(String str, Graphics context)
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。

LineMetrics

Font.getLineMetrics(String str, int beginIndex, int limit, FontRenderContext frc)
返回使用指定参数创建的 LineMetrics 对象。

LineMetrics

FontMetrics.getLineMetrics(String str, int beginIndex, int limit, Graphics context)
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。

PrintJob

Toolkit.getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes)
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

abstract  PrintJob

Toolkit.getPrintJob(Frame frame, String jobtitle, Properties props)
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

abstract  Object

Image.getProperty(String name, ImageObserver observer)
通过名称获取此图像的属性。

static String

Toolkit.getProperty(String key, String defaultValue)
获取具有指定键和默认值的属性。

PropertyChangeListener[]

SystemTray.getPropertyChangeListeners(String propertyName)
返回与指定属性关联的所有侦听器的数组。

PropertyChangeListener[]

KeyboardFocusManager.getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有 PropertyChangeListener 组成的数组。

PropertyChangeListener[]

Toolkit.getPropertyChangeListeners(String propertyName)
返回与指定属性关联的所有 PropertyChangeListener 所组成的数组。

PropertyChangeListener[]

Component.getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器的数组。

Rectangle2D

Font.getStringBounds(String str, FontRenderContext frc)
返回指定 FontRenderContext 中指定 String 的逻辑边界。

Rectangle2D

FontMetrics.getStringBounds(String str, Graphics context)
返回指定 Graphics 上下文中指定 String 的边界。

Rectangle2D

Font.getStringBounds(String str, int beginIndex, int limit, FontRenderContext frc)
返回指定 FontRenderContext 中指定 String 的逻辑边界。

Rectangle2D

FontMetrics.getStringBounds(String str, int beginIndex, int limit, Graphics context)
返回指定 Graphics 上下文中指定 String 的边界。

static Cursor

Cursor.getSystemCustomCursor(String name)
返回与指定名称匹配的特定于系统的定制光标对象。

VetoableChangeListener[]

KeyboardFocusManager.getVetoableChangeListeners(String propertyName)
返回与指定属性相关联的所有 VetoableChangeListener 组成的数组。

void

Choice.insert(String item, int index)
将菜单项插入此选择的指定位置上。

void

TextArea.insert(String str, int pos)
在此文本区的指定位置插入指定文本。

void

Menu.insert(String label, int index)
将带有指定标签的菜单项插入到此菜单的指定位置。

void

TextArea.insertText(String str, int pos)
已过时。 从 JDK version 1.1 开始，由 insert(String, int) 取代。

protected  Object

Toolkit.lazilyLoadDesktopProperty(String name)
一个对桌面属性值延迟计算的机会。

void

Choice.remove(String item)
移除 Choice 菜单中第一个出现的 item。

void

List.remove(String item)
从列表中移除项的第一次出现。

void

SystemTray.removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
从特定属性的侦听器列表中移除 PropertyChangeListener。

void

KeyboardFocusManager.removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
从特定属性的侦听器列表移除 PropertyChangeListener。

void

Toolkit.removePropertyChangeListener(String name, PropertyChangeListener pcl)
为指定的桌面属性移除指定的属性更改侦听器。

void

Component.removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
从指定属性的侦听器列表中移除一个 PropertyChangeListener。

void

KeyboardFocusManager.removeVetoableChangeListener(String propertyName, VetoableChangeListener listener)
从特定属性的侦听器列表移除 VetoableChangeListener。

void

List.replaceItem(String newValue, int index)
使用新字符串替换滚动列表中指定索引处的项。

void

TextArea.replaceRange(String str, int start, int end)
用指定替换文本替换指定开始位置与结束位置之间的文本。

void

TextArea.replaceText(String str, int start, int end)
已过时。 从 JDK version 1.1 开始，由 replaceRange(String, int, int) 取代。

protected static void

AWTEventMulticaster.save(ObjectOutputStream s, String k, EventListener l)

protected  void

AWTEventMulticaster.saveInternal(ObjectOutputStream s, String k)

void

Choice.select(String str)
将此 Choice 菜单中的选定项设置为其名称等于指定字符串的项。

void

Button.setActionCommand(String command)
设置此按钮激发的动作事件的命令名称。

void

TrayIcon.setActionCommand(String command)
设置由此托盘图标触发的动作事件的命令名。

void

MenuItem.setActionCommand(String command)
设置由此菜单项引发的动作事件的命令名。

protected  void

Toolkit.setDesktopProperty(String name, Object newValue)
将指定桌面属性设置为指定值，并触发一个属性更改事件，以通知所有侦听器该值已更改。

void

FileDialog.setDirectory(String dir)
将此文件对话框窗口的目录设置为指定目录。

void

FileDialog.setFile(String file)
将此文件对话框窗口的选定文件设置为指定文件。

void

JobAttributes.setFileName(String fileName)
指定使用这些属性的作业的输出文件的文件名。

void

Button.setLabel(String label)
将按钮的标签设置为指定的字符串。

void

Checkbox.setLabel(String label)
将此复选框的标签设置为字符串参数。

void

MenuItem.setLabel(String label)
将此菜单项的标签设置为指定标签。

void

MenuComponent.setName(String name)
将该组件的名称设置为指定字符串。

void

Component.setName(String name)
将组件的名称设置为指定的字符串。

void

JobAttributes.setPrinter(String printer)
为使用这些属性的作业指定目标打印机。

void

TextComponent.setText(String t)
将此文本组件显示的文本设置为指定文本。

void

TextField.setText(String t)
将此文本组件显示的文本设置为指定文本。

void

Label.setText(String text)
将此标签的文本设置为指定的文本。

void

Dialog.setTitle(String title)
设置 Dialog 的标题。

void

Frame.setTitle(String title)
将此窗体的标题设置为指定的字符串。

void

TrayIcon.setToolTip(String tooltip)
设置此 TrayIcon 的工具提示字符串。

void

CardLayout.show(Container parent, String name)
翻转到使用 addLayoutComponent 添加到此布局的具有指定 name 的组件。

int

FontMetrics.stringWidth(String str)
返回此 Font 中指定 String 的总 advance width。

static Desktop.Action

Desktop.Action.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static MultipleGradientPaint.CycleMethod

MultipleGradientPaint.CycleMethod.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static MultipleGradientPaint.ColorSpaceType

MultipleGradientPaint.ColorSpaceType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static TrayIcon.MessageType

TrayIcon.MessageType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Dialog.ModalityType

Dialog.ModalityType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Dialog.ModalExclusionType

Dialog.ModalExclusionType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Component.BaselineResizeBehavior

Component.BaselineResizeBehavior.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.awt 中的构造方法

AWTError(String msg)
构造带指定详细消息的 AWTError 的实例。

AWTException(String msg)
构造带指定详细消息的 AWTException 实例。

AWTPermission(String name)
创建具有指定名称的新 AWTPermission。

AWTPermission(String name, String actions)
创建具有指定名称的新 AWTPermission 对象。

Button(String label)
构造一个带指定标签的按钮。

Checkbox(String label)
使用指定标签创建一个复选框。

Checkbox(String label, boolean state)
使用指定标签创建一个复选框，并将它设置为指定状态。

Checkbox(String label, boolean state, CheckboxGroup group)
构造具有指定标签的 Checkbox，并将它设置为指定状态，使它处于指定复选框组中。

Checkbox(String label, CheckboxGroup group, boolean state)
创建具有指定标签的 Checkbox，并使它处于指定复选框组内，将它设置为指定状态。

CheckboxMenuItem(String label)
创建具有指定标签的复选框菜单项。

CheckboxMenuItem(String label, boolean state)
创建 具有指定标签和状态的复选框菜单项。

Cursor(String name)
用指定名称创建一个新的定制光标对象。

Dialog(Dialog owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Dialog 和标题。

Dialog(Dialog owner, String title, boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题和模式。

Dialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题、模式和 GraphicsConfiguration。

Dialog(Frame owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Frame 和标题。

Dialog(Frame owner, String title, boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题和模式。

Dialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题、模式和 GraphicsConfiguration。

Dialog(Window owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Window 和标题。

Dialog(Window owner, String title, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题和模式。

Dialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。

FileDialog(Dialog parent, String title)
创建一个具有指定标题的文件对话框，用于加载文件。

FileDialog(Dialog parent, String title, int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。

FileDialog(Frame parent, String title)
创建一个具有指定标题的文件对话框窗口，用于加载文件。

FileDialog(Frame parent, String title, int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。

Font(String name, int style, int size)
根据指定名称、样式和磅值大小，创建一个新 Font。

FontFormatException(String reason)
报告一个指定了原因的 FontFormatException。

Frame(String title)
构造一个新的、最初不可见的、具有指定标题的 Frame 对象。

Frame(String title, GraphicsConfiguration gc)
构造一个新的、初始不可见的、具有指定标题和 GraphicsConfiguration 的 Frame 对象。

HeadlessException(String msg)

IllegalComponentStateException(String s)
构造带指定详细消息的 IllegalComponentStateException。

JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

Label(String text)
使用指定的文本字符串构造一个新的标签，其文本对齐方式为左对齐。

Label(String text, int alignment)
构造一个显示指定的文本字符串的新标签，其文本对齐方式为指定的方式。

Menu(String label)
构造具有指定标签的新菜单。

Menu(String label, boolean tearOff)
构造具有指定标签的新菜单，指示该菜单是否可以分离。

MenuItem(String label)
构造具有指定的标签且没有键盘快捷方式的新菜单项。

MenuItem(String label, MenuShortcut s)
创建具有关联的键盘快捷方式的菜单项。

PopupMenu(String label)
创建具有指定名称的新弹出式菜单。

TextArea(String text)
构造具有指定文本的新文本区。

TextArea(String text, int rows, int columns)
构造一个新文本区，该文本区具有指定的文本，以及指定的行数和列数。

TextArea(String text, int rows, int columns, int scrollbars)
构造一个新文本区，该文本区具有指定的文本，以及指定的行数、列数和滚动条可见性。

TextField(String text)
构造使用指定文本初始化的新文本字段。

TextField(String text, int columns)
构造使用要显示的指定文本初始化的新文本字段，宽度足够容纳指定列数。

TrayIcon(Image image, String tooltip)
创建带有指定图像和工具提示文本的 TrayIcon。

TrayIcon(Image image, String tooltip, PopupMenu popup)
创建带指定图像、工具提示和弹出菜单的 TrayIcon。

java.awt.color 中 String 的使用

返回 String 的 java.awt.color 中的方法

String

ColorSpace.getName(int idx)
返回给定分量索引处的分量名称。

参数类型为 String 的 java.awt.color 中的方法

static ICC_Profile

ICC_Profile.getInstance(String fileName)
构造一个与文件中的数据相对应的 ICC_Profile。

void

ICC_Profile.write(String fileName)
将此 ICC_Profile 写入一个文件。

参数类型为 String 的 java.awt.color 中的构造方法

CMMException(String s)
构造带指定详细消息的 CMMException。

ProfileDataException(String s)
构造带指定详细消息的 ProfileDataException。

java.awt.datatransfer 中 String 的使用

声明为 String 的 java.awt.datatransfer 中的字段

static String

DataFlavor.javaJVMLocalObjectMimeType
要将一个引用传输到不具有关联 MIME Content 类型的任意 Java 对象引用（跨越同一 JVM 中的 Transferable 接口），需要使用具有此类型/子类型的 DataFlavor，其中 representationClass 等于跨越 Transferable 传递的类/接口的类型。

static String

DataFlavor.javaRemoteObjectMimeType
为了通过拖放 ACTION_LINK 操作将活动链接传递到 Remote 对象，应该使用 Mime Content 类型的 application/x-java-remote-object，其中 DataFlavor 的表示形式类表示要传输的 Remote 接口的类型。

static String

DataFlavor.javaSerializedObjectMimeType
MIME Content 类型的 application/x-java-serialized-object 表示已变得持久的 Java 对象的图形。

返回 String 的 java.awt.datatransfer 中的方法

static String

SystemFlavorMap.decodeJavaMIMEType(String nat)
解码 String native 以用作 Java MIME 类型。

static String

SystemFlavorMap.encodeDataFlavor(DataFlavor flav)
编码 DataFlavor 以用作 String native。

static String

SystemFlavorMap.encodeJavaMIMEType(String mimeType)
编码 MIME 类型以用作 String native。

String

DataFlavor.getDefaultRepresentationClassAsString()

String

DataFlavor.getHumanPresentableName()
返回此 DataFlavor 表示的数据格式的得体的名称。

String

DataFlavor.getMimeType()
返回此 DataFlavor 的 MIME 类型字符串。

String

Clipboard.getName()
返回此剪贴板对象的名称。

String

DataFlavor.getParameter(String paramName)
如果 paramName 等于 "humanPresentableName"，则返回此 DataFlavor 的得体的名称。

String

DataFlavor.getPrimaryType()
返回此 DataFlavor 的基本 MIME 类型。

String

DataFlavor.getSubType()
返回此 DataFlavor 的子 MIME 类型。

protected  String

DataFlavor.normalizeMimeType(String mimeType)
已过时。

protected  String

DataFlavor.normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。

String

DataFlavor.toString()
此 DataFlavor 及其参数的字符串表示形式。

返回变量类型为 String 的类型的 java.awt.datatransfer 中的方法

Map<String,DataFlavor>

SystemFlavorMap.getFlavorsForNatives(String[] natives)
返回指定 String native 到其大多数首选 DataFlavor 的 Map。

Map<String,DataFlavor>

FlavorMap.getFlavorsForNatives(String[] natives)
返回指定 String native 到其相应 DataFlavor 的 Map。

List<String>

SystemFlavorMap.getNativesForFlavor(DataFlavor flav)
返回数据传输子系统可以将指定 DataFlavor 转换成的 String native 的 List。

List<String>

FlavorTable.getNativesForFlavor(DataFlavor flav)
返回与指定 DataFlavor 对应的 String native 的 List。

Map<DataFlavor,String>

SystemFlavorMap.getNativesForFlavors(DataFlavor[] flavors)
返回指定 DataFlavor 到其大多数首选的 String native 的 Map。

Map<DataFlavor,String>

FlavorMap.getNativesForFlavors(DataFlavor[] flavors)
返回指定 DataFlavor 到其对应的 String native 的 Map。

参数类型为 String 的 java.awt.datatransfer 中的方法

void

SystemFlavorMap.addFlavorForUnencodedNative(String nat, DataFlavor flav)
添加从单个 String native 到单个 DataFlavor 的映射。

void

SystemFlavorMap.addUnencodedNativeForFlavor(DataFlavor flav, String nat)
添加从指定的 DataFlavor（和等于指定 DataFlavor 的所有 DataFlavor）到指定 String native 的映射。

static DataFlavor

SystemFlavorMap.decodeDataFlavor(String nat)
解码 String native 以用作 DataFlavor。

static String

SystemFlavorMap.decodeJavaMIMEType(String nat)
解码 String native 以用作 Java MIME 类型。

static String

SystemFlavorMap.encodeJavaMIMEType(String mimeType)
编码 MIME 类型以用作 String native。

boolean

DataFlavor.equals(String s)
已过时。 与 hashCode() 协定不一致，使用 isMimeTypeEqual(String) 代替。

List<DataFlavor>

SystemFlavorMap.getFlavorsForNative(String nat)
返回数据传输子系统可以将指定 String native 转换成的 DataFlavor 的 List。

List<DataFlavor>

FlavorTable.getFlavorsForNative(String nat)
返回与指定 String 对应的 DataFlavor 的 List。

Map<String,DataFlavor>

SystemFlavorMap.getFlavorsForNatives(String[] natives)
返回指定 String native 到其大多数首选 DataFlavor 的 Map。

Map<String,DataFlavor>

FlavorMap.getFlavorsForNatives(String[] natives)
返回指定 String native 到其相应 DataFlavor 的 Map。

String

DataFlavor.getParameter(String paramName)
如果 paramName 等于 "humanPresentableName"，则返回此 DataFlavor 的得体的名称。

static boolean

SystemFlavorMap.isJavaMIMEType(String str)
返回指定的 String 是否为编码的 Java MIME 类型。

boolean

DataFlavor.isMimeTypeEqual(String mimeType)
返回传入的 MIME 类型的字符串表示形式是否等于此 DataFlavor 的 MIME 类型。

protected  String

DataFlavor.normalizeMimeType(String mimeType)
已过时。

protected  String

DataFlavor.normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。

void

SystemFlavorMap.setFlavorsForNative(String nat, DataFlavor[] flavors)
放弃指定 String native 的当前映射，而创建指定 DataFlavor 的新映射。

void

DataFlavor.setHumanPresentableName(String humanPresentableName)
设置此 DataFlavor 表示的数据格式的得体的名称。

void

SystemFlavorMap.setNativesForFlavor(DataFlavor flav, String[] natives)
放弃指定 DataFlavor 和等于指定 DataFlavor 的所有 DataFlavor 的当前映射，并创建到指定 String native 的新映射。

protected static Class<?>

DataFlavor.tryToLoadClass(String className, ClassLoader fallback)
试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。

参数类型为 String 的 java.awt.datatransfer 中的构造方法

Clipboard(String name)
创建剪贴板对象。

DataFlavor(Class<?> representationClass, String humanPresentableName)
构造一个表示 Java 类的 DataFlavor。

DataFlavor(String mimeType)
根据 mimeType 字符串构造 DataFlavor。

DataFlavor(String mimeType, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。

DataFlavor(String mimeType, String humanPresentableName, ClassLoader classLoader)
构造一个表示 MimeType 的 DataFlavor。

MimeTypeParseException(String s)
构造带指定详细消息的 MimeTypeParseException。

StringSelection(String data)
创建能传输指定 String 的 Transferable。

java.awt.dnd 中 String 的使用

参数类型为 String 的 java.awt.dnd 中的构造方法

InvalidDnDOperationException(String msg)
创建一个带有其自身描述性消息的异常。

java.awt.event 中 String 的使用

返回 String 的 java.awt.event 中的方法

String

ActionEvent.getActionCommand()
返回与此动作相关的命令字符串。

static String

KeyEvent.getKeyModifiersText(int modifiers)
返回描述修改键的 String，如 "Shift" 或 "Ctrl+Shift"。

static String

KeyEvent.getKeyText(int keyCode)
返回描述 keyCode 的 String，如 "HOME"、"F1" 或 "A"。

static String

InputEvent.getModifiersExText(int modifiers)
返回描述扩展修改键和鼠标按钮（例如 "Shift"、"Button1" 或 "Ctrl+Shift"）的 String。

static String

MouseEvent.getMouseModifiersText(int modifiers)
返回一个描述事件期间所按下的修改键和鼠标按键（如“Shift”或“Ctrl+Shift”）的 String。

String

TextEvent.paramString()
返回标识此文本事件的参数字符串。

String

ItemEvent.paramString()
返回标识此项事件的参数字符串。

String

AdjustmentEvent.paramString()

String

ContainerEvent.paramString()
返回标识此事件的参数字符串。

String

ActionEvent.paramString()
返回标识此动作事件的参数字符串。

String

WindowEvent.paramString()
返回标识此事件的参数字符串。

String

InputMethodEvent.paramString()
返回标识此事件的参数字符串。

String

HierarchyEvent.paramString()
返回标识此事件的参数字符串。

String

FocusEvent.paramString()
返回标识此事件的参数字符串。

String

MouseWheelEvent.paramString()
返回标识此事件的参数字符串。

String

InvocationEvent.paramString()
返回标识此事件的参数字符串。

String

PaintEvent.paramString()

String

MouseEvent.paramString()
返回标识此事件的参数字符串。

String

KeyEvent.paramString()
返回标识此事件的参数字符串。

String

ComponentEvent.paramString()
返回标识此事件的参数字符串。

参数类型为 String 的 java.awt.event 中的构造方法

ActionEvent(Object source, int id, String command)
构造一个 ActionEvent 对象。

ActionEvent(Object source, int id, String command, int modifiers)
使用修改键构造一个 ActionEvent 对象。

ActionEvent(Object source, int id, String command, long when, int modifiers)
使用指定修改键和时间戳构造一个 ActionEvent 对象。

java.awt.font 中 String 的使用

返回 String 的 java.awt.font 中的方法

String[]

MultipleMaster.getDesignAxisNames()
返回每个设计轴的名称。

String

NumericShaper.toString()
返回描述此成形器的 String。

String

TextHitInfo.toString()
返回表示此 TextHitInfo 的 String，只用于调试目的。

String

TextLayout.toString()
返回此 TextLayout 的调试信息。

参数类型为 String 的 java.awt.font 中的方法

byte[]

OpenType.getFontTable(String strSfntTag)
返回作为指定标签字节数组的表。

byte[]

OpenType.getFontTable(String strSfntTag, int offset, int count)
返回作为指定标签字节数组的表的子集。

int

OpenType.getFontTableSize(String strSfntTag)
返回指定标签的表的大小。

参数类型为 String 的 java.awt.font 中的构造方法

TextAttribute(String name)
构造一个具有指定名称的 TextAttribute。

TextLayout(String string, Font font, FontRenderContext frc)
根据 String 和 Font 构造一个 TextLayout。

TextLayout(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
根据 String 和属性集构造一个 TextLayout。

java.awt.geom 中 String 的使用

返回 String 的 java.awt.geom 中的方法

String

Rectangle2D.Float.toString()
返回此 Rectangle2D 的 String 表示形式。

String

Rectangle2D.Double.toString()
返回此 Rectangle2D 的 String 表示形式。

String

Point2D.Float.toString()
返回表示此 Point2D 值的 String。

String

Point2D.Double.toString()
返回表示此 Point2D 值的 String。

String

AffineTransform.toString()
返回表示此 Object 值的 String。

参数类型为 String 的 java.awt.geom 中的构造方法

IllegalPathStateException(String s)
构造带指定详细消息的 IllegalMonitorStateException。

NoninvertibleTransformException(String s)
构造具有指定详细消息的 NoninvertibleTransformException 的实例。

java.awt.im.spi 中 String 的使用

返回 String 的 java.awt.im.spi 中的方法

String

InputMethodDescriptor.getInputMethodDisplayName(Locale inputLocale, Locale displayLanguage)
用将显示该名称的语言返回用户可视名称，该名称与给定的输入语言环境的输入方法相对应。

参数类型为 String 的 java.awt.im.spi 中的方法

JFrame

InputMethodContext.createInputMethodJFrame(String title, boolean attachToInputContext)
创建输入方法使用的顶层 Swing JFrame。

Window

InputMethodContext.createInputMethodWindow(String title, boolean attachToInputContext)
创建输入方法使用的顶层窗口。

java.awt.image 中 String 的使用

返回 String 的 java.awt.image 中的方法

String[]

BufferedImage.getPropertyNames()
返回由 getProperty(String) 识别的名称数组；如果没有识别出属性名，则返回 null。

String[]

RenderedImage.getPropertyNames()
返回由 getProperty(String) 识别的名称的数组，如果没有属性名被识别，则返回 null。

String

BufferedImage.toString()
返回此 BufferedImage 对象及其值的 String 表示形式。

String

IndexColorModel.toString()
返回此 ColorModel 对象内容的 String 表示形式。

String

DirectColorModel.toString()
返回表示此 DirectColorModel 的 String。

String

ColorModel.toString()
返回此 ColorModel 对象的内容的 String 表示形式。

参数类型为 String 的 java.awt.image 中的方法

Object

BufferedImage.getProperty(String name)
按名称返回图像的属性。

Object

RenderedImage.getProperty(String name)
从此图像的属性设置中获取一个属性。

Object

BufferedImage.getProperty(String name, ImageObserver observer)
按名称返回图像的属性。

参数类型为 String 的 java.awt.image 中的构造方法

ImagingOpException(String s)
构造带指定消息的 ImagingOpException 对象。

RasterFormatException(String s)
构造带指定消息的新 RasterFormatException。

java.awt.image.renderable 中 String 的使用

声明为 String 的 java.awt.image.renderable 中的字段

static String

RenderableImage.HINTS_OBSERVED
可以用于在通过 createRendering 或 createScaledRendering 方法获取的 RenderedImage 上标识属性的字符串常量。

返回 String 的 java.awt.image.renderable 中的方法

String[]

ContextualRenderedImageFactory.getPropertyNames()
返回由 getProperty 识别的名称列表。

String[]

RenderableImage.getPropertyNames()
返回由 getProperty 识别的名称列表。

String[]

RenderableImageOp.getPropertyNames()
返回由 getProperty 识别的名称列表。

参数类型为 String 的 java.awt.image.renderable 中的方法

Object

ContextualRenderedImageFactory.getProperty(ParameterBlock paramBlock, String name)
获取由 name 参数指定的属性的适当实例。

Object

RenderableImage.getProperty(String name)
从此图像的属性集中获取某个属性。

Object

RenderableImageOp.getProperty(String name)
从此图像的属性集中获取某个属性。

java.awt.print 中 String 的使用

返回 String 的 java.awt.print 中的方法

abstract  String

PrinterJob.getJobName()
获取要打印的文档名称。

abstract  String

PrinterJob.getUserName()
获取打印用户的名称。

参数类型为 String 的 java.awt.print 中的方法

static StreamPrintServiceFactory[]

PrinterJob.lookupStreamPrintServices(String mimeType)
定位可以成像 2D 图形的流打印服务工厂的便捷方法。

abstract  void

PrinterJob.setJobName(String jobName)
设置要打印的文档名称。

参数类型为 String 的 java.awt.print 中的构造方法

PrinterAbortException(String msg)
构造带指定详细信息的新 PrinterAbortException。

PrinterException(String msg)
构造带指定详细信息的新 PrinterException 对象。

java.beans 中 String 的使用

声明为 String 的 java.beans 中的字段

static String

DesignMode.PROPERTYNAME
从 BeanContext 或 PropertyChangeEvent 的其他源激发的 propertyName 的标准值。

返回 String 的 java.beans 中的方法

static String

Introspector.decapitalize(String name)
获得一个字符串并将它转换成普通 Java 变量名称大写形式的实用工具方法。

String

EventHandler.getAction()
返回此事件处理程序将设置的目标的可写属性名称，或者此事件处理程序将在目标上调用的方法名称。

String

PropertyEditor.getAsText()
以文本形式获得属性值。

String

PropertyEditorSupport.getAsText()
获得人类可编辑的适当字符串表示形式的属性值。

static String[]

Introspector.getBeanInfoSearchPath()
获得将用来查找 BeanInfo 类的包名称的列表。

String

FeatureDescriptor.getDisplayName()
获得此特性的本地化显示名称。

static String[]

PropertyEditorManager.getEditorSearchPath()
获得用来搜索属性编辑器的包名称。

String

EventHandler.getEventPropertyName()
返回应该在应用于目标的动作中使用的事件属性。

String

PropertyEditor.getJavaInitializationString()
返回一部分 Java 代码，可以使用这部分代码来设置某个属性，以匹配编辑器当前状态。

String

PropertyEditorSupport.getJavaInitializationString()
生成 Java 代码来设置属性值时使用此方法。

String

EventHandler.getListenerMethodName()
返回将触发动作的属性名称。

String

Statement.getMethodName()
返回方法名称。

String

FeatureDescriptor.getName()
获得此特性的编程名称。

String

VetoableChangeListenerProxy.getPropertyName()
返回与侦听器有关联的指定属性的名称。

String

PropertyChangeListenerProxy.getPropertyName()
返回与侦听器相关联的指定属性的名称。

String

PropertyChangeEvent.getPropertyName()
获取已更改属性的编程名称。

String

FeatureDescriptor.getShortDescription()
获得此特性的简短描述。

String[]

PropertyEditor.getTags()
如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记数组。

String[]

PropertyEditorSupport.getTags()
如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记值数组。

String

Expression.toString()
使用 Java 风格的语法打印此表达式的值。

String

Statement.toString()
使用 Java 风格的语法打印此语句的值。

返回变量类型为 String 的类型的 java.beans 中的方法

Enumeration<String>

FeatureDescriptor.attributeNames()
获得与语言环境无关的此特性名称的枚举。

参数类型为 String 的 java.beans 中的方法

void

PropertyChangeSupport.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
为指定的属性向侦听器列表中添加一个 PropertyChangeListener。

void

VetoableChangeSupport.addVetoableChangeListener(String propertyName, VetoableChangeListener listener)
为特定属性添加一个 VetoableChangeListener。

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action)
创建 listenerInterface 的实现，在该实现中，侦听器接口中的所有 方法都会将处理程序的 action 应用到 target。

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName)
创建 listenerInterface 的实现，在该实现中，所有 方法都会将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)
创建 listenerInterface 的实现，在该实现中，名为 listenerMethodName 的方法将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。

static String

Introspector.decapitalize(String name)
获得一个字符串并将它转换成普通 Java 变量名称大写形式的实用工具方法。

void

PropertyChangeSupport.fireIndexedPropertyChange(String propertyName, int index, boolean oldValue, boolean newValue)
以 boolean 值形式报告所有已注册侦听器的绑定索引属性更新。

void

PropertyChangeSupport.fireIndexedPropertyChange(String propertyName, int index, int oldValue, int newValue)
以 int 值形式报告所有已注册侦听器的绑定索引属性更新。

void

PropertyChangeSupport.fireIndexedPropertyChange(String propertyName, int index, Object oldValue, Object newValue)
报告所有已注册侦听器的绑定 (bound) 索引 (indexed) 属性更新。

void

PropertyChangeSupport.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
以 boolean 值形式报告所有已注册侦听器的绑定属性更新。

void

PropertyChangeSupport.firePropertyChange(String propertyName, int oldValue, int newValue)
以 int 值形式报告所有已注册侦听器的绑定属性更新。

void

PropertyChangeSupport.firePropertyChange(String propertyName, Object oldValue, Object newValue)
报告所有已注册侦听器的绑定属性更新。

void

VetoableChangeSupport.fireVetoableChange(String propertyName, boolean oldValue, boolean newValue)
向所有已注册的侦听器报告一个 boolean vetoable 属性更新。

void

VetoableChangeSupport.fireVetoableChange(String propertyName, int oldValue, int newValue)
向所有已注册的侦听器报告一个 int vetoable 属性更新。

void

VetoableChangeSupport.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
向所有已注册的侦听器报告 vetoable 属性更新。

PropertyChangeListener[]

PropertyChangeSupport.getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器的列表。

Object

FeatureDescriptor.getValue(String attributeName)
利用此特性检索指定属性。

VetoableChangeListener[]

VetoableChangeSupport.getVetoableChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器组成的数组。

boolean

VetoableChangeSupport.hasListeners(String propertyName)
检查是否存在特定属性的侦听器，包括那些已在所有属性上注册的侦听器。

boolean

PropertyChangeSupport.hasListeners(String propertyName)
检查是否存在特定属性的任何侦听器，包括那些已在所有属性上注册的侦听器。

static Object

Beans.instantiate(ClassLoader cls, String beanName)
实例化 JavaBean。

static Object

Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext)
实例化 JavaBean。

static Object

Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
实例化 bean。

Image

SimpleBeanInfo.loadImage(String resourceName)
这是帮助加载图标图像的实用工具方法。

void

PropertyChangeSupport.removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
为特定属性移除一个 PropertyChangeListener。

void

VetoableChangeSupport.removeVetoableChangeListener(String propertyName, VetoableChangeListener listener)
为特定属性移除一个 VetoableChangeListener。

void

PropertyEditor.setAsText(String text)
通过解析给定 String 设置属性值。

void

PropertyEditorSupport.setAsText(String text)
通过解析给定字符串设置属性值。

static void

Introspector.setBeanInfoSearchPath(String[] path)
更改将用来查找 BeanInfo 类的包名称的列表。

void

FeatureDescriptor.setDisplayName(String displayName)
设置此特性的本地化显示名称。

static void

PropertyEditorManager.setEditorSearchPath(String[] path)
更改将用来查找属性编辑器的包名称的列表。

void

FeatureDescriptor.setName(String name)
设置此特性的编程名称。

void

FeatureDescriptor.setShortDescription(String text)
可以将简短描述性字符串与某一特性相关联。

void

FeatureDescriptor.setValue(String attributeName, Object value)
将某一指定属性与此特性相关联。

参数类型为 String 的 java.beans 中的构造方法

DefaultPersistenceDelegate(String[] constructorPropertyNames)
为其构造方法的参数是属性名称值（由 constructorPropertyNames 指定）的类创建默认持久委托。

EventHandler(Object target, String action, String eventPropertyName, String listenerMethodName)
创建一个新的 EventHandler 对象；通常使用 create 方法之一，而不是直接调用此构造方法。

EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。

EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。

EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。

EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。

EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。

EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

Expression(Object value, Object target, String methodName, Object[] arguments)
为某个返回结果的方法创建一个新的 Expression 对象。

Expression(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

IndexedPropertyChangeEvent(Object source, String propertyName, Object oldValue, Object newValue, int index)
构造一个新的 IndexedPropertyChangeEvent 对象。

IndexedPropertyDescriptor(String propertyName, Class<?> beanClass)
此构造方法通过 getFoo 和 setFoo 存取方法为符合标准 Java 约定的属性构造 IndexedPropertyDescriptor，将其用于索引访问和数组访问。

IndexedPropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称，它们都是带索引的或不带索引的。

IndexedPropertyDescriptor(String propertyName, Method readMethod, Method writeMethod, Method indexedReadMethod, Method indexedWriteMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。

IntrospectionException(String mess)
构造带详细消息的 IntrospectionException。

PropertyChangeEvent(Object source, String propertyName, Object oldValue, Object newValue)
构造一个新的 PropertyChangeEvent。

PropertyChangeListenerProxy(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 绑定到特定属性的构造方法。

PropertyDescriptor(String propertyName, Class<?> beanClass)
通过调用 getFoo 和 setFoo 存取方法，为符合标准 Java 约定的属性构造一个 PropertyDescriptor。

PropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称。

PropertyDescriptor(String propertyName, Method readMethod, Method writeMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。

PropertyVetoException(String mess, PropertyChangeEvent evt)
构造带详细消息的 PropertyVetoException。

Statement(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

VetoableChangeListenerProxy(String propertyName, VetoableChangeListener listener)

java.beans.beancontext 中 String 的使用

参数类型为 String 的 java.beans.beancontext 中的方法

void

BeanContextChild.addPropertyChangeListener(String name, PropertyChangeListener pcl)
将一个 PropertyChangeListener 添加到此 BeanContextChild 中，以便无论指定属性何时发生更改都可以接收一个 PropertyChangeEvent。

void

BeanContextChildSupport.addPropertyChangeListener(String name, PropertyChangeListener pcl)
为特定属性添加一个 PropertyChangeListener。

void

BeanContextChild.addVetoableChangeListener(String name, VetoableChangeListener vcl)
将一个 VetoableChangeListener 添加到此 BeanContextChild，以便无论指定属性何时发生更改都可以接收事件。

void

BeanContextChildSupport.addVetoableChangeListener(String name, VetoableChangeListener vcl)
为特定属性添加一个 VetoableChangeListener。

void

BeanContextChildSupport.firePropertyChange(String name, Object oldValue, Object newValue)
向所有已注册的侦听器报告绑定 (bound) 属性更新。

void

BeanContextChildSupport.fireVetoableChange(String name, Object oldValue, Object newValue)
向所有已注册的侦听器报告 vetoable 属性更新。

URL

BeanContext.getResource(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。

URL

BeanContextSupport.getResource(String name, BeanContextChild bcc)

InputStream

BeanContext.getResourceAsStream(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。

InputStream

BeanContextSupport.getResourceAsStream(String name, BeanContextChild bcc)

Object

BeanContext.instantiateChild(String beanName)
实例化指定为此 BeanContext 的一个子级的 javaBean。

Object

BeanContextSupport.instantiateChild(String beanName)
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。

void

BeanContextChild.removePropertyChangeListener(String name, PropertyChangeListener pcl)
从此 BeanContextChild 中移除一个 PropertyChangeListener，以便指定属性发生更改时不再接收 PropertyChangeEvent。

void

BeanContextChildSupport.removePropertyChangeListener(String name, PropertyChangeListener pcl)
为特定属性移除一个 PropertyChangeListener。

void

BeanContextChild.removeVetoableChangeListener(String name, VetoableChangeListener vcl)
从此 BeanContextChild 中移除一个 VetoableChangeListener，以便指定属性发生更改时不再接收事件。

void

BeanContextChildSupport.removeVetoableChangeListener(String name, VetoableChangeListener vcl)
移除一个 VetoableChangeListener。

java.io 中 String 的使用

声明为 String 的 java.io 中的字段

protected  String

StringBufferInputStream.buffer
已过时。 从中读取字节的字符串。

String

InvalidClassException.classname
无效类的名称。

static String

File.pathSeparator
与系统有关的路径分隔符，为了方便，它被表示为一个字符串。

static String

File.separator
与系统有关的默认名称分隔符，为了方便，它被表示为一个字符串。

String

StreamTokenizer.sval
如果当前标记是一个文字标记，则此字段包含一个给出该文字标记的字符的字符串。

返回 String 的 java.io 中的方法

String

File.getAbsolutePath()
返回此抽象路径名的绝对路径名字符串。

String

FilePermission.getActions()
返回操作的“规范化字符串表示形式”。

String

File.getCanonicalPath()
返回此抽象路径名的规范路径名字符串。

String

InputStreamReader.getEncoding()
返回此流使用的字符编码的名称。

String

OutputStreamWriter.getEncoding()
返回此流使用的字符编码的名称。

String

WriteAbortedException.getMessage()
生成此消息并包括嵌入异常的消息（如果有）。

String

InvalidClassException.getMessage()
生成消息并包括类名称（如果存在）。

String

ObjectStreamClass.getName()
返回由此描述符描述的类的名称。

String

File.getName()
返回由此抽象路径名表示的文件或目录的名称。

String

ObjectStreamField.getName()
获取此字段的名称。

String

File.getParent()
返回此抽象路径名父目录的路径名字符串；如果此路径名没有指定父目录，则返回 null。

String

File.getPath()
将此抽象路径名转换为一个路径名字符串。

String

ObjectStreamField.getTypeString()
返回 JVM 类型签名。

String[]

File.list()
返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中的文件和目录。

String[]

File.list(FilenameFilter filter)
返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中满足指定过滤器的文件和目录。

String

Console.readLine()
从控制台读取单行文本。

String

LineNumberReader.readLine()
读取文本行。

String

RandomAccessFile.readLine()
从此文件读取文本的下一行。

String

ObjectInputStream.readLine()
已过时。 此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。

String

DataInputStream.readLine()
已过时。 该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
String

DataInput.readLine()
从输入流中读取下一文本行。

String

BufferedReader.readLine()
读取一个文本行。

String

Console.readLine(String fmt, Object... args)
提供一个格式化提示，然后从控制台读取单行文本。

String

RandomAccessFile.readUTF()
从此文件读取一个字符串。

String

ObjectInputStream.readUTF()
读取 UTF-8 修改版格式的 String。

String

DataInputStream.readUTF()
参见 DataInput 的 readUTF 方法的常规协定。

String

DataInput.readUTF()
读入一个已使用 UTF-8 修改版格式编码的字符串。

static String

DataInputStream.readUTF(DataInput in)
从流 in 中读取用 UTF-8 修改版格式编码的 Unicode 字符格式的字符串；然后以 String 形式返回此字符串。

String

CharArrayWriter.toString()
将输入数据转换为字符串。

String

StreamTokenizer.toString()
返回当前流标记和在其上发生的行号的字符串表示形式。

String

StringWriter.toString()
以字符串的形式返回该缓冲区的当前值。

String

ByteArrayOutputStream.toString()
使用平台默认的字符集，通过解码字节将缓冲区内容转换为字符串。

String

ObjectStreamClass.toString()
返回描述此 ObjectStreamClass 的字符串。

String

File.toString()
返回此抽象路径名的路径名字符串。

String

ObjectStreamField.toString()
返回描述此字段的字符串。

String

ByteArrayOutputStream.toString(int hibyte)
已过时。 此方法无法将字节正确转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是通过 toString(String enc) 方法（使用一个编码名称参数），或 toString() 方法（使用平台的默认字符编码）。

String

ByteArrayOutputStream.toString(String charsetName)
使用指定的 charsetName，通过解码字节将缓冲区内容转换为字符串。

参数类型为 String 的 java.io 中的方法

boolean

FilenameFilter.accept(File dir, String name)
测试指定文件是否应该包含在某一文件列表中。

static File

File.createTempFile(String prefix, String suffix)
在默认临时文件目录中创建一个空文件，使用给定前缀和后缀生成其名称。

static File

File.createTempFile(String prefix, String suffix, File directory)
在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。

abstract  boolean

ObjectInputStream.GetField.defaulted(String name)
如果指定的字段是默认字段并且在此流中不存在任何值，则返回 true。

PrintWriter

PrintWriter.format(Locale l, String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。

PrintStream

PrintStream.format(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此输出流中。

Console

Console.format(String fmt, Object... args)
使用指定格式字符串和参数将格式化字符串写入此控制台的输出流中。

PrintWriter

PrintWriter.format(String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。

PrintStream

PrintStream.format(String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此输出流中。

abstract  boolean

ObjectInputStream.GetField.get(String name, boolean val)
从持久字段获取指定的 boolean 字段值。

abstract  byte

ObjectInputStream.GetField.get(String name, byte val)
从持久字段获取指定字节字段的值。

abstract  char

ObjectInputStream.GetField.get(String name, char val)
从持久字段获取指定 char 字段的值。

abstract  double

ObjectInputStream.GetField.get(String name, double val)
从持久字段获取指定 double 字段的值。

abstract  float

ObjectInputStream.GetField.get(String name, float val)
从持久字段获取指定 float 字段的值。

abstract  int

ObjectInputStream.GetField.get(String name, int val)
从持久字段获取指定的 int 字段值。

abstract  long

ObjectInputStream.GetField.get(String name, long val)
从持久字段获取指定 long 字段的值。

abstract  Object

ObjectInputStream.GetField.get(String name, Object val)
从持久字段获取指定 Object 字段的值。

abstract  short

ObjectInputStream.GetField.get(String name, short val)
从持久字段获取指定的 short 字段值。

ObjectStreamField

ObjectStreamClass.getField(String name)
按名称获取此类的字段。

void

PrintWriter.print(String s)
打印字符串。

void

PrintStream.print(String s)
打印字符串。

PrintWriter

PrintWriter.printf(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。

PrintStream

PrintStream.printf(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

Console

Console.printf(String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此控制台输出流的便捷方法。

PrintWriter

PrintWriter.printf(String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。

PrintStream

PrintStream.printf(String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

void

PrintWriter.println(String x)
打印 String，然后终止该行。

void

PrintStream.println(String x)
打印 String，然后终止该行。

abstract  void

ObjectOutputStream.PutField.put(String name, boolean val)
将指定的 boolean 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, byte val)
将指定的 byte 字段值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, char val)
将指定的 char 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, double val)
将指定的 double 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, float val)
将指定的 float 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, int val)
将指定的 int 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, long val)
将指定的 long 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, Object val)
将指定的 Object 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, short val)
将指定的 short 字段的值置于持久字段中。

String

Console.readLine(String fmt, Object... args)
提供一个格式化提示，然后从控制台读取单行文本。

char[]

Console.readPassword(String fmt, Object... args)
提供一个格式化提示，然后从控制台读取密码，禁用回显。

protected  Class<?>

ObjectInputStream.resolveProxyClass(String[] interfaces)
返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。

String

ByteArrayOutputStream.toString(String charsetName)
使用指定的 charsetName，通过解码字节将缓冲区内容转换为字符串。

void

StringWriter.write(String str)
写入一个字符串。

void

PrintWriter.write(String s)
写入字符串。

void

Writer.write(String str)
写入字符串。

void

CharArrayWriter.write(String str, int off, int len)
将字符串的某一部分写入缓冲区。

void

FilterWriter.write(String str, int off, int len)
写入一部分字符串。

void

StringWriter.write(String str, int off, int len)
写入字符串的某一部分。

void

PrintWriter.write(String s, int off, int len)
写入字符串的某一部分。

void

BufferedWriter.write(String s, int off, int len)
写入字符串的某一部分。

void

OutputStreamWriter.write(String str, int off, int len)
写入字符串的某一部分。

void

Writer.write(String str, int off, int len)
写入字符串的某一部分。

void

DataOutputStream.writeBytes(String s)
将字符串按字节顺序写出到基础输出流中。

void

RandomAccessFile.writeBytes(String s)
按字节序列将该字符串写入该文件。

void

ObjectOutputStream.writeBytes(String str)
以字节序列形式写入一个 String。

void

DataOutput.writeBytes(String s)
将一个字符串写入输出流。

void

DataOutputStream.writeChars(String s)
将字符串按字符顺序写入基础输出流。

void

RandomAccessFile.writeChars(String s)
按字符序列将一个字符串写入该文件。

void

ObjectOutputStream.writeChars(String str)
以 char 序列形式写入一个 String。

void

DataOutput.writeChars(String s)
将字符串 s 中的所有字符按顺序写入输出流，每个字符用两个字节表示。

void

DataOutputStream.writeUTF(String str)
以与机器无关方式使用 UTF-8 修改版编码将一个字符串写入基础输出流。

void

RandomAccessFile.writeUTF(String str)
使用 modified UTF-8 编码以与机器无关的方式将一个字符串写入该文件。

void

ObjectOutputStream.writeUTF(String str)
以 UTF-8 修改版格式写入此 String 的基本数据。

void

DataOutput.writeUTF(String s)
将表示长度信息的两个字节写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。

参数类型为 String 的 java.io 中的构造方法

CharConversionException(String s)
此异常提供详细消息。

EOFException(String s)
构造带有指定详细消息的 EOFException。

File(File parent, String child)
根据 parent 抽象路径名和 child 路径名字符串创建一个新 File 实例。

File(String pathname)
通过将给定路径名字符串转换为抽象路径名来创建一个新 File 实例。

File(String parent, String child)
根据 parent 路径名字符串和 child 路径名字符串创建一个新 File 实例。

FileInputStream(String name)
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的路径名 name 指定。

FileNotFoundException(String s)
构造带有指定详细消息的 FileNotFoundException。

FileOutputStream(String name)
创建一个向具有指定名称的文件中写入数据的输出文件流。

FileOutputStream(String name, boolean append)
创建一个向具有指定 name 的文件中写入数据的输出文件流。

FilePermission(String path, String actions)
创建具有指定操作的新 FilePermission 对象，path 是文件或目录的路径名，actions 包含对文件或目录授予的所需操作的列表，该列表由逗号分隔。

FileReader(String fileName)
在给定从中读取数据的文件名的情况下创建一个新 FileReader。

FileWriter(String fileName)
根据给定的文件名构造一个 FileWriter 对象。

FileWriter(String fileName, boolean append)
根据给定的文件名以及指示是否附加写入数据的 boolean 值来构造 FileWriter 对象。

InputStreamReader(InputStream in, String charsetName)
创建使用指定字符集的 InputStreamReader。

InterruptedIOException(String s)
构造带指定详细消息的 InterruptedIOException。

InvalidClassException(String reason)
报告指定了原因的 InvalidClassException。

InvalidClassException(String cname, String reason)
构造一个 InvalidClassException 对象。

InvalidObjectException(String reason)
构造一个 InvalidObjectException。

IOException(String message)
构造带指定详细消息的 IOException。

IOException(String message, Throwable cause)
构造带有指定详细消息和 cause 的 IOException。

NotActiveException(String reason)
创建带给定原因的新 NotActiveException 的构造方法。

NotSerializableException(String classname)
构造带消息字符串的 NotSerializableException 对象。

ObjectStreamException(String classname)
创建具有指定参数的 ObjectStreamException。

ObjectStreamField(String name, Class<?> type)
创建具有指定类型的 Serializable 字段。

ObjectStreamField(String name, Class<?> type, boolean unshared)
创建一个 ObjectStreamField，表示给定名称和类型的可序列化字段。

OutputStreamWriter(OutputStream out, String charsetName)
创建使用指定字符集的 OutputStreamWriter。

PrintStream(File file, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。

PrintStream(OutputStream out, boolean autoFlush, String encoding)
创建新的打印流。

PrintStream(String fileName)
创建具有指定文件名称且不带自动行刷新的新打印流。

PrintStream(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。

PrintWriter(File file, String csn)
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。

PrintWriter(String fileName)
创建具有指定文件名称且不带自动行刷新的新 PrintWriter。

PrintWriter(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新 PrintWriter。

RandomAccessFile(File file, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件由 File 参数指定。

RandomAccessFile(String name, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件具有指定名称。

SerializablePermission(String name)
创建具有指定名称的新 SerializablePermission。

SerializablePermission(String name, String actions)
创建具有指定名称的新 SerializablePermission 对象。

StreamCorruptedException(String reason)
创建一个 StreamCorruptedException 并列出抛出异常的一个原因。

StringBufferInputStream(String s)
已过时。 创建一个字符串输入流，以从指定字符串读取数据。

StringReader(String s)
创建一个新字符串 reader。

SyncFailedException(String desc)
构造一个带详细消息的 SyncFailedException。

UnsupportedEncodingException(String s)
构造带详细消息的 UnsupportedEncodingException。

UTFDataFormatException(String s)
构造带有指定详细消息的 UTFDataFormatException。

WriteAbortedException(String s, Exception ex)
使用描述该异常的字符串和导致中止的异常构造一个 WriteAbortedException。

java.lang 中 String 的使用

类型参数类型为 String 的 java.lang 中的字段

static Comparator<String>

String.CASE_INSENSITIVE_ORDER
一个对 String 对象进行排序的 Comparator，作用与 compareToIgnoreCase 相同。

返回 String 的 java.lang 中的方法

static String

System.clearProperty(String key)
移除指定键指示的系统属性。

String

String.concat(String str)
将指定字符串连接到此字符串的结尾。

String

EnumConstantNotPresentException.constantName()
返回缺少的枚举常量的名称。

static String

String.copyValueOf(char[] data)
返回指定数组中表示该字符序列的 String。

static String

String.copyValueOf(char[] data, int offset, int count)
返回指定数组中表示该字符序列的 String。

protected  String

ClassLoader.findLibrary(String libname)
返回本机库的绝对路径名。

static String

String.format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数返回一个格式化字符串。

static String

String.format(String format, Object... args)
使用指定的格式字符串和参数返回一个格式化字符串。

String

Class.getCanonicalName()
返回 Java Language Specification 中所定义的底层类的规范化名称。

String

StackTraceElement.getClassName()
返回类的完全限定名，该类包含由该堆栈跟踪元素所表示的执行点。

static String

System.getenv(String name)
获取指定的环境变量值。

String

StackTraceElement.getFileName()
返回源文件名，该文件包含由该堆栈跟踪元素所表示的执行点。

String

Package.getImplementationTitle()
返回此包的标题。

String

Package.getImplementationVendor()
返回提供该实现的组织、供应商或公司的名称。

String

Package.getImplementationVersion()
返回该实现的版本。

String

Throwable.getLocalizedMessage()
创建此 throwable 的本地化描述。

String

Throwable.getMessage()
返回此 throwable 的详细消息字符串。

String

StackTraceElement.getMethodName()
返回方法名，此方法包含由该堆栈跟踪元素所表示的执行点。

String

Package.getName()
返回此包的名称。

String

ThreadGroup.getName()
返回此线程组的名称。

String

Thread.getName()
返回该线程的名称。

String

Class.getName()
以 String 的形式返回此 Class 对象所表示的实体（类、接口、数组类、基本类型或 void）名称。

static String

System.getProperty(String key)
获取指定键指示的系统属性。

static String

System.getProperty(String key, String def)
获取用指定键描述的系统属性。

String

Class.getSimpleName()
返回源代码中给出的底层类的简称。

String

Package.getSpecificationTitle()
返回此包实现的规范标题。

String

Package.getSpecificationVendor()
返回拥有并维护实现此包的类规范的组织、供应商或公司的名称。

String

Package.getSpecificationVersion()
返回此包实现的规范的版本号。

String

String.intern()
返回字符串对象的规范化表示形式。

static String

System.mapLibraryName(String libname)
将一个库名称映射到特定于平台的、表示本机库的字符串中。

String

Enum.name()
返回此枚举常量的名称，在其枚举声明中对其进行声明。

String

String.replace(char oldChar, char newChar)
返回一个新的字符串，它是通过用 newChar 替换此字符串中出现的所有 oldChar 得到的。

String

String.replace(CharSequence target, CharSequence replacement)
使用指定的字面值替换序列替换此字符串所有匹配字面值目标序列的子字符串。

String

String.replaceAll(String regex, String replacement)
使用给定的 replacement 替换此字符串所有匹配给定的正则表达式的子字符串。

String

String.replaceFirst(String regex, String replacement)
使用给定的 replacement 替换此字符串匹配给定的正则表达式的第一个子字符串。

static String

System.setProperty(String key, String value)
设置指定键指示的系统属性。

String[]

String.split(String regex)
根据给定正则表达式的匹配拆分此字符串。

String[]

String.split(String regex, int limit)
根据匹配给定的正则表达式来拆分此字符串。

String

StringBuffer.substring(int start)

String

String.substring(int beginIndex)
返回一个新的字符串，它是此字符串的一个子字符串。

String

StringBuffer.substring(int start, int end)

String

String.substring(int beginIndex, int endIndex)
返回一个新字符串，它是此字符串的一个子字符串。

static String

Integer.toBinaryString(int i)
以二进制（基数 2）无符号整数形式返回一个整数参数的字符串表示形式。

static String

Long.toBinaryString(long i)
以二进制无符号整数形式返回 long 参数的字符串表示形式。

static String

Double.toHexString(double d)
返回 double 参数的十六进制字符串表示形式。

static String

Float.toHexString(float f)
返回 float 参数的十六进制字符串表示形式。

static String

Integer.toHexString(int i)
以十六进制（基数 16）无符号整数形式返回一个整数参数的字符串表示形式。

static String

Long.toHexString(long i)
以十六进制无符号整数形式返回 long 参数的字符串表示形式。

String

String.toLowerCase()
使用默认语言环境的规则将此 String 中的所有字符都转换为小写。

String

String.toLowerCase(Locale locale)
使用给定 Locale 的规则将此 String 中的所有字符都转换为小写。

static String

Integer.toOctalString(int i)
以八进制（基数 8）无符号整数形式返回一个整数参数的字符串表示形式。

static String

Long.toOctalString(long i)
以八进制无符号整数形式返回 long 参数的字符串表示形式。

String

Package.toString()
返回此 Package 的字符串表示形式。

String

Enum.toString()
返回枚举常量的名称，它包含在声明中。

String

StringBuilder.toString()

String

Long.toString()
返回表示 Long 值的 String 对象。

String

Integer.toString()
返回一个表示该 Integer 值的 String 对象。

String

Short.toString()
返回表示此 Short 的值的 String 对象。

String

Byte.toString()
返回表示此 Byte 的值的 String 对象。

String

Double.toString()
返回此 Double 对象的字符串表示形式。

String

Float.toString()
返回此 Float 对象的字符串表示形式。

String

Character.toString()
返回表示此 Character 值的 String 对象。

String

Character.Subset.toString()
返回该子集的名称。

String

Boolean.toString()
返回表示该布尔值的 String 对象。

String

StackTraceElement.toString()
返回表示该堆栈跟踪元素的字符串。

String

StringBuffer.toString()

String

ThreadGroup.toString()
返回此线程组的字符串表示形式。

String

Thread.toString()
返回该线程的字符串表示形式，包括线程名称、优先级和线程组。

String

Throwable.toString()
返回此 throwable 的简短描述。

String

Class.toString()
将对象转换为字符串。

String

String.toString()
返回此对象本身（它已经是一个字符串！）。

String

CharSequence.toString()
返回一个包含此序列中字符的字符串，该字符串与此序列的顺序相同。

String

Object.toString()
返回该对象的字符串表示。

static String

Boolean.toString(boolean b)
返回一个表示指定布尔值的 String 对象。

static String

Byte.toString(byte b)
返回表示指定 byte 的一个新 String 对象。

static String

Character.toString(char c)
返回一个表示指定 char 值的 String 对象。

static String

Double.toString(double d)
返回 double 参数的字符串表示形式。

static String

Float.toString(float f)
返回 float 参数的字符串表示形式。

static String

Integer.toString(int i)
返回一个表示指定整数的 String 对象。

static String

Integer.toString(int i, int radix)
返回用第二个参数指定基数表示的第一个参数的字符串表示形式。

static String

Long.toString(long i)
返回表示指定 long 的 String 对象。

static String

Long.toString(long i, int radix)
返回在使用第二个参数指定的基数时第一个参数的字符串表示形式。

static String

Short.toString(short s)
返回表示指定 short 的一个新 String 对象。

String

String.toUpperCase()
使用默认语言环境的规则将此 String 中的所有字符都转换为大写。

String

String.toUpperCase(Locale locale)
使用给定 Locale 的规则将此 String 中的所有字符都转换为大写。

String

String.trim()
返回字符串的副本，忽略前导空白和尾部空白。

String

TypeNotPresentException.typeName()
返回不可用类型的完全限定名。

static String

String.valueOf(boolean b)
返回 boolean 参数的字符串表示形式。

static String

String.valueOf(char c)
返回 char 参数的字符串表示形式。

static String

String.valueOf(char[] data)
返回 char 数组参数的字符串表示形式。

static String

String.valueOf(char[] data, int offset, int count)
返回 char 数组参数的特定子数组的字符串表示形式。

static String

String.valueOf(double d)
返回 double 参数的字符串表示形式。

static String

String.valueOf(float f)
返回 float 参数的字符串表示形式。

static String

String.valueOf(int i)
返回 int 参数的字符串表示形式。

static String

String.valueOf(long l)
返回 long 参数的字符串表示形式。

static String

String.valueOf(Object obj)
返回 Object 参数的字符串表示形式。

返回变量类型为 String 的类型的 java.lang 中的方法

List<String>

ProcessBuilder.command()
返回此进程生成器的操作系统程序和参数。

Map<String,String>

ProcessBuilder.environment()
返回此进程生成器环境的字符串映射视图。

Map<String,String>

ProcessBuilder.environment()
返回此进程生成器环境的字符串映射视图。

static Map<String,String>

System.getenv()
返回一个不能修改的当前系统环境的字符串映射视图。

static Map<String,String>

System.getenv()
返回一个不能修改的当前系统环境的字符串映射视图。

参数类型为 String 的 java.lang 中的方法

StringBuilder

StringBuilder.append(String str)

StringBuffer

StringBuffer.append(String str)

void

SecurityManager.checkAccept(String host, int port)
如果不允许调用线程从指定的主机和端口号接受套接字连接，则抛出 SecurityException。

void

SecurityManager.checkConnect(String host, int port)
如果不允许调用线程打开到指定主机和端口号的套接字连接，则抛出 SecurityException。

void

SecurityManager.checkConnect(String host, int port, Object context)
如果不允许指定的安全上下文打开与指定主机和端口号的套接字连接，则抛出 SecurityException。

void

SecurityManager.checkDelete(String file)
如果不允许调用线程删除指定的文件，则抛出 SecurityException。

void

SecurityManager.checkExec(String cmd)
如果不允许调用线程创建一个子进程，则抛出 SecurityException。

void

SecurityManager.checkLink(String lib)
如果不允许调用线程动态链接由字符串参数文件指定的库代码，则抛出 SecurityException。

void

SecurityManager.checkPackageAccess(String pkg)
如果不允许调用线程访问由参数指定的包，则抛出 SecurityException。

void

SecurityManager.checkPackageDefinition(String pkg)
如果不允许调用线程在参数指定的包中定义类，则抛出 SecurityException。

void

SecurityManager.checkPropertyAccess(String key)
如果不允许调用线程访问具有指定的 key 名的系统属性，则抛出 SecurityException。

void

SecurityManager.checkRead(String file)
如果不允许调用线程读取由字符串参数指定的文件，则抛出 SecurityException。

void

SecurityManager.checkRead(String file, Object context)
如果不允许指定的安全上下文读取由字符串参数所指定的文件，则抛出 SecurityException。

void

SecurityManager.checkSecurityAccess(String target)
确定是应该允许还是拒绝具有指定权限目标名的权限。

void

SecurityManager.checkWrite(String file)
如果不允许调用线程写由字符串参数指定的文件，则抛出 SecurityException。

protected  int

SecurityManager.classDepth(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

static String

System.clearProperty(String key)
移除指定键指示的系统属性。

ProcessBuilder

ProcessBuilder.command(String... command)
设置此进程生成器的操作系统程序和参数。

int

String.compareTo(String anotherString)
按字典顺序比较两个字符串。

int

String.compareToIgnoreCase(String str)
按字典顺序比较两个字符串，不考虑大小写。

static boolean

Compiler.compileClasses(String string)
编译那些名称与指定字符串相匹配的所有类。

String

String.concat(String str)
将指定字符串连接到此字符串的结尾。

static Long

Long.decode(String nm)
将 String 解码成 Long。

static Integer

Integer.decode(String nm)
将 String 解码为 Integer。

static Short

Short.decode(String nm)
将 String 解码为 Short。

static Byte

Byte.decode(String nm)
将 String 解码为 Byte。

protected  Class<?>

ClassLoader.defineClass(String name, byte[] b, int off, int len)
将一个 byte 数组转换为 Class 类的实例。

protected  Class<?>

ClassLoader.defineClass(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。

protected  Class<?>

ClassLoader.defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。

protected  Package

ClassLoader.definePackage(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase)
根据 name 在此 ClassLoader 中定义包。

boolean

String.endsWith(String suffix)
测试此字符串是否以指定的后缀结束。

boolean

String.equalsIgnoreCase(String anotherString)
将此 String 与另一个 String 比较，不考虑大小写。

Process

Runtime.exec(String command)
在单独的进程中执行指定的字符串命令。

Process

Runtime.exec(String[] cmdarray)
在单独的进程中执行指定命令和变量。

Process

Runtime.exec(String[] cmdarray, String[] envp)
在指定环境的独立进程中执行指定命令和变量。

Process

Runtime.exec(String[] cmdarray, String[] envp)
在指定环境的独立进程中执行指定命令和变量。

Process

Runtime.exec(String[] cmdarray, String[] envp, File dir)
在指定环境和工作目录的独立进程中执行指定的命令和变量。

Process

Runtime.exec(String[] cmdarray, String[] envp, File dir)
在指定环境和工作目录的独立进程中执行指定的命令和变量。

Process

Runtime.exec(String command, String[] envp)
在指定环境的单独进程中执行指定的字符串命令。

Process

Runtime.exec(String command, String[] envp)
在指定环境的单独进程中执行指定的字符串命令。

Process

Runtime.exec(String command, String[] envp, File dir)
在有指定环境和工作目录的独立进程中执行指定的字符串命令。

Process

Runtime.exec(String command, String[] envp, File dir)
在有指定环境和工作目录的独立进程中执行指定的字符串命令。

protected  Class<?>

ClassLoader.findClass(String name)
使用指定的二进制名称查找类。

protected  String

ClassLoader.findLibrary(String libname)
返回本机库的绝对路径名。

protected  Class<?>

ClassLoader.findLoadedClass(String name)
如果 Java 虚拟机已将此加载器记录为具有给定二进制名称的某个类的启动加载器，则返回该二进制名称的类。

protected  URL

ClassLoader.findResource(String name)
查找具有给定名称的资源。

protected  Enumeration<URL>

ClassLoader.findResources(String name)
返回表示所有具有给定名称的资源的 URL 对象的枚举。

protected  Class<?>

ClassLoader.findSystemClass(String name)
查找具有指定的二进制名称的类，必要时加载它。

static String

String.format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数返回一个格式化字符串。

static String

String.format(String format, Object... args)
使用指定的格式字符串和参数返回一个格式化字符串。

static Character.UnicodeBlock

Character.UnicodeBlock.forName(String blockName)
返回带有给定名称的 UnicodeBlock。

static Class<?>

Class.forName(String className)
返回与带有给定字符串名的类或接口相关联的 Class 对象。

static Class<?>

Class.forName(String name, boolean initialize, ClassLoader loader)
使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。

static boolean

Boolean.getBoolean(String name)
当且仅当以参数命名的系统属性存在，且等于 "true" 字符串时，才返回 true。

byte[]

String.getBytes(String charsetName)
使用指定的字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。

Field

Class.getDeclaredField(String name)
返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。

Method

Class.getDeclaredMethod(String name, Class<?>... parameterTypes)
返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。

static String

System.getenv(String name)
获取指定的环境变量值。

Field

Class.getField(String name)
返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。

static Integer

Integer.getInteger(String nm)
确定具有指定名称的系统属性的整数值。

static Integer

Integer.getInteger(String nm, int val)
确定具有指定名称的系统属性的整数值。

static Integer

Integer.getInteger(String nm, Integer val)
返回具有指定名称的系统属性的整数值。

static Long

Long.getLong(String nm)
确定具有指定名称的系统属性的 long 值。

static Long

Long.getLong(String nm, long val)
使用指定名称确定系统属性的 long 值。

static Long

Long.getLong(String nm, Long val)
使用指定名称返回系统属性的 long 值。

Method

Class.getMethod(String name, Class<?>... parameterTypes)
返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。

static Package

Package.getPackage(String name)
通过调用方的 ClassLoader 实例中的名称找到一个包。

protected  Package

ClassLoader.getPackage(String name)
返回由此类加载器或其任何祖先所定义的 Package。

static String

System.getProperty(String key)
获取指定键指示的系统属性。

static String

System.getProperty(String key, String def)
获取用指定键描述的系统属性。

URL

ClassLoader.getResource(String name)
查找具有给定名称的资源。

URL

Class.getResource(String name)
查找带有给定名称的资源。

InputStream

ClassLoader.getResourceAsStream(String name)
返回读取指定资源的输入流。

InputStream

Class.getResourceAsStream(String name)
查找具有给定名称的资源。

Enumeration<URL>

ClassLoader.getResources(String name)
查找所有给定名称的资源。

static URL

ClassLoader.getSystemResource(String name)
从用来加载类的搜索路径中查找具有指定名称的资源。

static InputStream

ClassLoader.getSystemResourceAsStream(String name)
从用来加载类的搜索路径打开具有指定名称的资源，以读取该资源。

static Enumeration<URL>

ClassLoader.getSystemResources(String name)
从用来加载类的搜索路径中查找所有具有指定名称的资源。

protected  boolean

SecurityManager.inClass(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

int

StringBuilder.indexOf(String str)

int

StringBuffer.indexOf(String str)

int

String.indexOf(String str)
返回指定子字符串在此字符串中第一次出现处的索引。

int

StringBuilder.indexOf(String str, int fromIndex)

int

StringBuffer.indexOf(String str, int fromIndex)

int

String.indexOf(String str, int fromIndex)
返回指定子字符串在此字符串中第一次出现处的索引，从指定的索引开始。

StringBuilder

StringBuilder.insert(int offset, String str)

StringBuffer

StringBuffer.insert(int offset, String str)

boolean

Package.isCompatibleWith(String desired)
比较此包的规范版本和所需版本。

int

StringBuilder.lastIndexOf(String str)

int

StringBuffer.lastIndexOf(String str)

int

String.lastIndexOf(String str)
返回指定子字符串在此字符串中最右边出现处的索引。

int

StringBuilder.lastIndexOf(String str, int fromIndex)

int

StringBuffer.lastIndexOf(String str, int fromIndex)

int

String.lastIndexOf(String str, int fromIndex)
返回指定子字符串在此字符串中最后一次出现处的索引，从指定的索引开始反向搜索。

void

Runtime.load(String filename)
加载作为动态库的指定文件名。

static void

System.load(String filename)
从作为动态库的本地文件系统中以指定的文件名加载代码文件。

Class<?>

ClassLoader.loadClass(String name)
使用指定的二进制名称来加载类。

protected  Class<?>

ClassLoader.loadClass(String name, boolean resolve)
使用指定的二进制名称来加载类。

void

Runtime.loadLibrary(String libname)
加载具有指定库名的动态库。

static void

System.loadLibrary(String libname)
加载由 libname 参数指定的系统库。

static String

System.mapLibraryName(String libname)
将一个库名称映射到特定于平台的、表示本机库的字符串中。

boolean

String.matches(String regex)
告知此字符串是否匹配给定的正则表达式。

static boolean

Boolean.parseBoolean(String s)
将字符串参数解析为 boolean 值。

static byte

Byte.parseByte(String s)
将 string 参数解析为有符号的十进制 byte。

static byte

Byte.parseByte(String s, int radix)
将 string 参数解析为一个有符号的 byte，其基数由第二个参数指定。

static double

Double.parseDouble(String s)
返回一个新的 double 值，该值被初始化为用指定 String 表示的值，这与 Double 类的 valueOf 方法一样。

static float

Float.parseFloat(String s)
返回一个新的 float 值，该值被初始化为用指定 String 表示的值，这与 Float 类的 valueOf 方法一样。

static int

Integer.parseInt(String s)
将字符串参数作为有符号的十进制整数进行解析。

static int

Integer.parseInt(String s, int radix)
使用第二个参数指定的基数，将字符串参数解析为有符号的整数。

static long

Long.parseLong(String s)
将 string 参数解析为有符号十进制 long。

static long

Long.parseLong(String s, int radix)
将 string 参数解析为有符号的 long，基数由第二个参数指定。

static short

Short.parseShort(String s)
将字符串参数解析为有符号的十进制 short。

static short

Short.parseShort(String s, int radix)
将字符串参数解析为由第二个参数指定的基数中的有符号的 short。

boolean

String.regionMatches(boolean ignoreCase, int toffset, String other, int ooffset, int len)
测试两个字符串区域是否相等。

boolean

String.regionMatches(int toffset, String other, int ooffset, int len)
测试两个字符串区域是否相等。

StringBuilder

StringBuilder.replace(int start, int end, String str)

StringBuffer

StringBuffer.replace(int start, int end, String str)

String

String.replaceAll(String regex, String replacement)
使用给定的 replacement 替换此字符串所有匹配给定的正则表达式的子字符串。

String

String.replaceFirst(String regex, String replacement)
使用给定的 replacement 替换此字符串匹配给定的正则表达式的第一个子字符串。

void

ClassLoader.setClassAssertionStatus(String className, boolean enabled)
设置在此类加载器及其包含的嵌套类中指定的最高层类所需的断言状态。

void

Thread.setName(String name)
改变线程名称，使之与参数 name 相同。

void

ClassLoader.setPackageAssertionStatus(String packageName, boolean enabled)
为指定包设置默认断言状态。

static String

System.setProperty(String key, String value)
设置指定键指示的系统属性。

String[]

String.split(String regex)
根据给定正则表达式的匹配拆分此字符串。

String[]

String.split(String regex, int limit)
根据匹配给定的正则表达式来拆分此字符串。

boolean

String.startsWith(String prefix)
测试此字符串是否以指定的前缀开始。

boolean

String.startsWith(String prefix, int toffset)
测试此字符串从指定索引开始的子字符串是否以指定前缀开始。

static

<T extends Enum<T>>
T

Enum.valueOf(Class<T> enumType, String name)
返回带指定名称的指定枚举类型的枚举常量。

static Long

Long.valueOf(String s)
返回保持指定 String 的值的 Long 对象。

static Integer

Integer.valueOf(String s)
返回保存指定的 String 的值的 Integer 对象。

static Short

Short.valueOf(String s)
返回一个保持指定 String 所给出的值的 Short 对象。

static Byte

Byte.valueOf(String s)
返回一个保持指定 String 所给出的值的 Byte 对象。

static Double

Double.valueOf(String s)
返回保存用参数字符串 s 表示的 double 值的 Double 对象。

static Float

Float.valueOf(String s)
返回保存用参数字符串 s 表示的 float 值的 Float 对象。

static Boolean

Boolean.valueOf(String s)
返回一个用指定的字符串表示值的 Boolean 值。

static Thread.State

Thread.State.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Long

Long.valueOf(String s, int radix)
当使用第二个参数给出的基数进行解析时，返回保持从指定 String 中提取的值的 Long 对象。

static Integer

Integer.valueOf(String s, int radix)
返回一个 Integer 对象，该对象中保存了用第二个参数提供的基数进行解析时从指定的 String 中提取的值。

static Short

Short.valueOf(String s, int radix)
返回一个 Short 对象，该对象保持从指定的 String 中提取的值，该值是在使用第二个参数给出的基数对指定字符串进行解析时提取的。

static Byte

Byte.valueOf(String s, int radix)
返回一个 Byte 对象，该对象保持从指定的 String 中提取的值，该值是在用第二个参数所给定的基数对指定字符串进行解析时提取的。

类型变量类型为 String 的 java.lang 中的方法参数

ProcessBuilder

ProcessBuilder.command(List<String> command)
设置此进程生成器的操作系统程序和参数。

参数类型为 String 的 java.lang 中的构造方法

AbstractMethodError(String s)
构造带指定详细消息的 AbstractMethodError。

ArithmeticException(String s)
构造具有指定详细消息的 ArithmeticException。

ArrayIndexOutOfBoundsException(String s)
构造具有指定详细消息的 ArrayIndexOutOfBoundsException 类。

ArrayStoreException(String s)
构造具有指定详细消息的 ArrayStoreException。

Boolean(String s)
如果 String 参数不为 null 且在忽略大小写时等于 "true"，则分配一个表示 true 值的 Boolean 对象。

Byte(String s)
构造一个新分配的 Byte 对象，以表示 String 参数所指示的 byte 值。

Character.Subset(String name)
构造一个新的 Subset 实例。

ClassCastException(String s)
构造带指定详细消息的 ClassCastException。

ClassCircularityError(String s)
构造带指定详细消息的 ClassCircularityError。

ClassFormatError(String s)
构造带指定详细消息的 ClassFormatError。

ClassNotFoundException(String s)
构造带指定详细消息的 ClassNotFoundException。

ClassNotFoundException(String s, Throwable ex)
构造一个 ClassNotFoundException，它带有指定详细消息和加载类时引发的可选异常。

CloneNotSupportedException(String s)
构造带指定详细消息的 CloneNotSupportedException。

Double(String s)
构造一个新分配的 Double 对象，表示用字符串表示的 double 类型的浮点值。

Enum(String name, int ordinal)
单独的构造方法。

EnumConstantNotPresentException(Class<? extends Enum> enumType, String constantName)
为指定常量构造一个 EnumConstantNotPresentException。

Error(String message)
构造带指定详细消息的新错误。

Error(String message, Throwable cause)
构造带指定详细消息和原因的新错误。

Exception(String message)
构造带指定详细消息的新异常。

Exception(String message, Throwable cause)
构造带指定详细消息和原因的新异常。

ExceptionInInitializerError(String s)
构造带指定详细消息的 ExceptionInInitializerError。

Float(String s)
构造一个新分配的 Float 对象，它表示用字符串表示的 float 类型的浮点值。

IllegalAccessError(String s)
构造带指定详细消息的 IllegalAccessError。

IllegalAccessException(String s)
构造带指定详细消息的 IllegalAccessException。

IllegalArgumentException(String s)
构造带指定详细消息的 IllegalArgumentException。

IllegalArgumentException(String message, Throwable cause)
根据指定的详细消息和原因构造一个新异常。

IllegalMonitorStateException(String s)
构造带指定详细消息的 IllegalMonitorStateException。

IllegalStateException(String s)
构造带指定详细消息的 IllegalStateException。

IllegalStateException(String message, Throwable cause)
构造一个新异常，它带有指定的详细消息和原因。

IllegalThreadStateException(String s)
构造带指定详细消息的 IllegalThreadStateException。

IncompatibleClassChangeError(String s)
构造带指定详细消息的 IncompatibleClassChangeError。

IndexOutOfBoundsException(String s)
构造带指定详细消息的 IndexOutOfBoundsException。

InstantiationError(String s)
构造带指定详细消息的 InstantiationError。

InstantiationException(String s)
构造带指定详细消息的 InstantiationException。

Integer(String s)
构造一个新分配的 Integer 对象，它表示 String 参数所指示的 int 值。

InternalError(String s)
构造带指定详细消息的 InternalError。

InterruptedException(String s)
构造带指定详细消息的 InterruptedException。

LinkageError(String s)
构造带指定详细消息的 LinkageError 类。

Long(String s)
构造新分配的 Long 对象，表示由 String 参数指示的 long 值。

NegativeArraySizeException(String s)
构造带指定详细消息的 NegativeArraySizeException。

NoClassDefFoundError(String s)
构造带指定详细消息的 NoClassDefFoundError。

NoSuchFieldError(String s)
构造带指定详细消息的 NoSuchFieldException。

NoSuchFieldException(String s)
带有详细消息的构造方法。

NoSuchMethodError(String s)
构造带指定详细消息的 NoSuchMethodError。

NoSuchMethodException(String s)
构造带指定详细消息的 NoSuchMethodException。

NullPointerException(String s)
构造带指定详细消息的 NullPointerException。

NumberFormatException(String s)
构造带指定详细消息的 NumberFormatException。

OutOfMemoryError(String s)
构造带指定详细消息的 OutOfMemoryError。

ProcessBuilder(String... command)
利用指定的操作系统程序和参数构造一个进程生成器。

RuntimeException(String message)
用指定的详细消息构造一个新的运行时异常。

RuntimeException(String message, Throwable cause)
用指定的详细消息和原因构造一个新的运行时异常。

RuntimePermission(String name)
创建具有指定名称的新 RuntimePermission。

RuntimePermission(String name, String actions)
创建具有指定名称的新 RuntimePermission 对象。

SecurityException(String s)
构造带指定详细消息的 SecurityException。

SecurityException(String message, Throwable cause)
创建带指定详细消息和原因的 SecurityException。

Short(String s)
构造一个新分配的 Short 对象，用来表示 String 参数所指示的 short 值。

StackOverflowError(String s)
构造带指定详细消息的 StackOverflowError。

StackTraceElement(String declaringClass, String methodName, String fileName, int lineNumber)
创建表示指定执行点的堆栈跟踪元素。

String(byte[] bytes, int offset, int length, String charsetName)
通过使用指定的字符集解码指定的 byte 子数组，构造一个新的 String。

String(byte[] bytes, String charsetName)
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。

String(String original)
初始化一个新创建的 String 对象，使其表示一个与参数相同的字符序列；换句话说，新创建的字符串是该参数字符串的副本。

StringBuffer(String str)
构造一个字符串缓冲区，并将其内容初始化为指定的字符串内容。

StringBuilder(String str)
构造一个字符串生成器，并初始化为指定的字符串内容。

StringIndexOutOfBoundsException(String s)
构造带指定详细消息的 StringIndexOutOfBoundsException。

Thread(Runnable target, String name)
分配新的 Thread 对象。

Thread(String name)
分配新的 Thread 对象。

Thread(ThreadGroup group, Runnable target, String name)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，并作为 group 所引用的线程组的一员。

Thread(ThreadGroup group, Runnable target, String name, long stackSize)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，作为 group 所引用的线程组的一员，并具有指定的堆栈大小。

Thread(ThreadGroup group, String name)
分配新的 Thread 对象。

ThreadGroup(String name)
构造一个新线程组。

ThreadGroup(ThreadGroup parent, String name)
创建一个新线程组。

Throwable(String message)
构造带指定详细消息的新 throwable。

Throwable(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 throwable。

TypeNotPresentException(String typeName, Throwable cause)
为指定类型构造一个带指定原因的 TypeNotPresentException。

UnknownError(String s)
构造带指定详细消息的 UnknownError。

UnsatisfiedLinkError(String s)
构造带指定详细消息的 UnsatisfiedLinkError。

UnsupportedClassVersionError(String s)
构造带指定详细消息的 UnsupportedClassVersionError。

UnsupportedOperationException(String message)
构造带指定详细消息的 UnsupportedOperationException。

UnsupportedOperationException(String message, Throwable cause)
根据指定的详细消息和原因，构造一个新异常。

VerifyError(String s)
构造带指定详细消息的 VerifyError。

VirtualMachineError(String s)
构造带指定详细消息的 VirtualMachineError。

类型变量类型为 String 的 java.lang 中的构造方法参数

ProcessBuilder(List<String> command)
利用指定的操作系统程序和参数构造一个进程生成器。

java.lang.annotation 中 String 的使用

返回 String 的 java.lang.annotation 中的方法

String

IncompleteAnnotationException.elementName()
返回缺少元素的名称。

String

AnnotationTypeMismatchException.foundType()
返回在类型不正确的元素中找到的数据类型。

String

Annotation.toString()
返回此 annotation 的字符串表示形式。

参数类型为 String 的 java.lang.annotation 中的方法

static ElementType

ElementType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static RetentionPolicy

RetentionPolicy.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.lang.annotation 中的构造方法

AnnotationFormatError(String message)
构造具有指定详细消息的新 AnnotationFormatError。

AnnotationFormatError(String message, Throwable cause)
构造带指定详细消息和原因的新 AnnotationFormatError。

AnnotationTypeMismatchException(Method element, String foundType)
构造针对指定的注释类型元素和找到的数据类型的 AnnotationTypeMismatchException。

IncompleteAnnotationException(Class<? extends Annotation> annotationType, String elementName)
构造一个指示指定注释类型中缺少指定元素的 IncompleteAnnotationException。

java.lang.instrument 中 String 的使用

参数类型为 String 的 java.lang.instrument 中的方法

void

Instrumentation.setNativeMethodPrefix(ClassFileTransformer transformer, String prefix)
通过允许重试，将前缀应用到名称，此方法修改本机方法解析的失败处理。

byte[]

ClassFileTransformer.transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

参数类型为 String 的 java.lang.instrument 中的构造方法

IllegalClassFormatException(String s)
构造具有指定详细消息的 IllegalClassFormatException。

UnmodifiableClassException(String s)
构造具有指定详细消息的 UnmodifiableClassException。

java.lang.management 中 String 的使用

声明为 String 的 java.lang.management 中的字段

static String

ManagementFactory.CLASS_LOADING_MXBEAN_NAME
ClassLoadingMXBean 的 ObjectName 的字符串表示形式。

static String

ManagementFactory.COMPILATION_MXBEAN_NAME
CompilationMXBean 的 ObjectName 的字符串表示形式。

static String

ManagementFactory.GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE
GarbageCollectorMXBean 的 ObjectName 中的域名和类型键属性。

static String

MemoryNotificationInfo.MEMORY_COLLECTION_THRESHOLD_EXCEEDED
表示当 Java 虚拟机对内存池中的不使用的对象进行了回收工作之后，内存池的内存使用量大于或等于其集合使用量阈值的通知类型。

static String

ManagementFactory.MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE
MemoryManagerMXBean 的 ObjectName 中的域名和类型键属性。

static String

ManagementFactory.MEMORY_MXBEAN_NAME
MemoryMXBean 的 ObjectName 的字符串表示形式。

static String

ManagementFactory.MEMORY_POOL_MXBEAN_DOMAIN_TYPE
MemoryPoolMXBean 的 ObjectName 中的域名和类型键属性。

static String

MemoryNotificationInfo.MEMORY_THRESHOLD_EXCEEDED
表示内存池的内存使用量已达到或超过其使用量阈值的通知类型。

static String

ManagementFactory.OPERATING_SYSTEM_MXBEAN_NAME
OperatingSystemMXBean 的 ObjectName 的字符串表示形式。

static String

ManagementFactory.RUNTIME_MXBEAN_NAME
RuntimeMXBean 的 ObjectName 的字符串表示形式。

static String

ManagementFactory.THREAD_MXBEAN_NAME
ThreadMXBean 的 ObjectName 的字符串表示形式。

返回 String 的 java.lang.management 中的方法

String

OperatingSystemMXBean.getArch()
返回操作系统的架构。

String

RuntimeMXBean.getBootClassPath()
返回由引导类加载器用于搜索类文件的引导类路径。

String

LockInfo.getClassName()
返回锁对象的完全限定类名称。

String

RuntimeMXBean.getClassPath()
返回系统类加载器用于搜索类文件的 Java 类路径。

String

RuntimeMXBean.getLibraryPath()
返回 Java 库路径。

String

ThreadInfo.getLockName()
返回对象的字符串表示形式，与此 ThreadInfo 关联的线程被锁定并等待该对象。

String

ThreadInfo.getLockOwnerName()
返回拥有对象的线程的名称，与此 ThreadInfo 关联的线程被阻塞并等待该对象。

String

RuntimeMXBean.getManagementSpecVersion()
返回正在运行的 Java 虚拟机实现的管理接口的规范版本。

String[]

MemoryPoolMXBean.getMemoryManagerNames()
返回管理此内存池的内存管理器的名称。

String[]

MemoryManagerMXBean.getMemoryPoolNames()
返回此内存管理器管理的内存池名称。

String

CompilationMXBean.getName()
返回即时 (JIT) 编译器的名称。

String

MemoryManagerMXBean.getName()
返回表示此内存管理器的名称。

String

MemoryPoolMXBean.getName()
返回表示此内存池的名称。

String

OperatingSystemMXBean.getName()
返回操作系统名称。

String

RuntimeMXBean.getName()
返回表示正在运行的 Java 虚拟机的名称。

String

MemoryNotificationInfo.getPoolName()
返回触发此通知的内存池的名称。

String

RuntimeMXBean.getSpecName()
返回 Java 虚拟机规范名称。

String

RuntimeMXBean.getSpecVendor()
返回 Java 虚拟机规范供应商。

String

RuntimeMXBean.getSpecVersion()
返回 Java 虚拟机规范版本。

String

ThreadInfo.getThreadName()
返回与此 ThreadInfo 关联的线程的名称。

String

OperatingSystemMXBean.getVersion()
返回操作系统的版本。

String

RuntimeMXBean.getVmName()
返回 Java 虚拟机实现名称。

String

RuntimeMXBean.getVmVendor()
返回 Java 虚拟机实现供应商。

String

RuntimeMXBean.getVmVersion()
返回 Java 虚拟机实现版本。

String

LockInfo.toString()
返回锁的字符串表示形式。

String

MemoryType.toString()
返回该 MemoryType 的字符串表示形式。

String

MemoryUsage.toString()
返回此内存使用量的描述性表示形式。

String

ThreadInfo.toString()
返回此线程信息的字符串表示形式。

返回变量类型为 String 的类型的 java.lang.management 中的方法

List<String>

RuntimeMXBean.getInputArguments()
返回传递给 Java 虚拟机的输入变量，其中不包括传递给 main 方法的变量。

Map<String,String>

RuntimeMXBean.getSystemProperties()
返回所有系统属性的名称和值的映射。

Map<String,String>

RuntimeMXBean.getSystemProperties()
返回所有系统属性的名称和值的映射。

参数类型为 String 的 java.lang.management 中的方法

static

<T> T

ManagementFactory.newPlatformMXBeanProxy(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。

static MemoryType

MemoryType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.lang.management 中的构造方法

LockInfo(String className, int identityHashCode)
构造一个 LockInfo 对象。

ManagementPermission(String name)
构造具有指定名称的 ManagementPermission。

ManagementPermission(String name, String actions)
构造新的 ManagementPermission 对象。

MemoryNotificationInfo(String poolName, MemoryUsage usage, long count)
构造一个 MemoryNotificationInfo 对象。

MonitorInfo(String className, int identityHashCode, int stackDepth, StackTraceElement stackFrame)
构造一个 MonitorInfo 对象。

java.lang.reflect 中 String 的使用

返回 String 的 java.lang.reflect 中的方法

String

TypeVariable.getName()
返回此类型变量的名称，它出现在源代码中。

String

Constructor.getName()
以字符串形式返回此构造方法的名称。

String

Method.getName()
以 String 形式返回此 Method 对象表示的方法名称。

String

Field.getName()
返回此 Field 对象表示的字段的名称。

String

Member.getName()
返回此 Member 表示的底层成员或构造方法的简单名称。

String

Constructor.toGenericString()
返回描述此 Constructor 的字符串，其中包括类型参数。

String

Method.toGenericString()
返回描述此 Method 的字符串，包括类型参数。

String

Field.toGenericString()
返回一个描述此 Field（包括其一般类型）的字符串。

String

Constructor.toString()
返回描述此 Constructor 的字符串。

String

Method.toString()
返回描述此 Method 的字符串。

String

Field.toString()
返回一个描述此 Field 的字符串。

static String

Modifier.toString(int mod)
返回描述指定修饰符中的访问修饰符标志的字符串。

参数类型为 String 的 java.lang.reflect 中的构造方法

InvocationTargetException(Throwable target, String s)
构造带目标异常和详细消息的 InvocationTargetException。

ReflectPermission(String name)
构造不带指定名称的 ReflectPermission。

ReflectPermission(String name, String actions)
构造带指定名称和动作的 ReflectPermission。

UndeclaredThrowableException(Throwable undeclaredThrowable, String s)
根据指定的 Throwable 和详细消息构造 UndeclaredThrowableException。

java.math 中 String 的使用

返回 String 的 java.math 中的方法

String

BigDecimal.toEngineeringString()
返回此 BigDecimal 的字符串表示形式，需要指数时，则使用工程计数法。

String

BigDecimal.toPlainString()
返回不带指数字段的此 BigDecimal 的字符串表示形式。

String

BigDecimal.toString()
返回此 BigDecimal 的字符串表示形式，如果需要指数，则使用科学记数法。

String

MathContext.toString()
返回此 MathContext 的字符串表示形式。

String

BigInteger.toString()
返回此 BigInteger 的十进制字符串表示形式。

String

BigInteger.toString(int radix)
返回此 BigInteger 的给定基数的字符串表示形式。

参数类型为 String 的 java.math 中的方法

static RoundingMode

RoundingMode.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.math 中的构造方法

BigDecimal(String val)
将 BigDecimal 的字符串表示形式转换为 BigDecimal。

BigDecimal(String val, MathContext mc)
将 BigDecimal 的字符串表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符串（按照上下文设置进行舍入）。

BigInteger(String val)
将 BigInteger 的十进制字符串表示形式转换为 BigInteger。

BigInteger(String val, int radix)
将指定基数的 BigInteger 的字符串表示形式转换为 BigInteger。

MathContext(String val)
根据字符串构造一个新的 MathContext。

java.net 中 String 的使用

声明为 String 的 java.net 中的字段

protected  String

HttpURLConnection.method
HTTP 方法（GET、POST、PUT 等）。

protected  String

HttpURLConnection.responseMessage
HTTP 响应消息。

返回 String 的 java.net 中的方法

static String

URLDecoder.decode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。

static String

URLDecoder.decode(String s, String enc)
使用指定的编码机制对 application/x-www-form-urlencoded 字符串解码。

static String

URLEncoder.encode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。

static String

URLEncoder.encode(String s, String enc)
使用指定的编码机制将字符串转换为 application/x-www-form-urlencoded 格式。

String

SocketPermission.getActions()
返回动作的规范化字符串表示形式。

String

URI.getAuthority()
返回此 URI 的已解码的授权组成部分。

String

URL.getAuthority()
获取此 URL 的授权部分。

String

InetAddress.getCanonicalHostName()
获取此 IP 地址的完全限定域名。

abstract  String

SecureCacheResponse.getCipherSuite()
返回正在获得了网络资源的初始连接上使用的密码套件。

String

HttpCookie.getComment()
返回描述此 cookie 用途的注释；如果该 cookie 没有注释，则返回 null。

String

HttpCookie.getCommentURL()
返回描述此 cookie 用途的注释 URL；如果 cookie 没有注释 URL，则返回 null。

String

URLConnection.getContentEncoding()
返回 content-encoding 头字段的值。

String

URLConnection.getContentType()
返回 content-type 头字段的值。

String

FileNameMap.getContentTypeFor(String fileName)
获取指定文件名的 MIME 类型。

static String

URLConnection.getDefaultRequestProperty(String key)
已过时。 应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。

String

NetworkInterface.getDisplayName()
获取此网络接口的显示名称。

String

HttpCookie.getDomain()
返回为此 cookie 设置的域名。

String

JarURLConnection.getEntryName()
返回此连接的条目名称。

String

URL.getFile()
获取此 URL 的文件名。

String

URI.getFragment()
返回此 URI 的已解码的片段组成部分。

String

HttpURLConnection.getHeaderField(int n)
返回 nth 头字段的值。

String

URLConnection.getHeaderField(int n)
返回第 n 个头字段的值。

String

URLConnection.getHeaderField(String name)
返回指定的头字段的值。

String

HttpURLConnection.getHeaderFieldKey(int n)
返回 nth 头字段的键。

String

URLConnection.getHeaderFieldKey(int n)
返回第 n 个头字段的键。

String

URI.getHost()
返回此 URI 的主机组成部分。

String

URL.getHost()
获取此 URL 的主机名（如果适用）。

String

Inet6Address.getHostAddress()
返回 IP 地址字符串（以文本表现形式）。

String

Inet4Address.getHostAddress()
返回 IP 地址字符串（以文本表现形式）。

String

InetAddress.getHostAddress()
返回 IP 地址字符串（以文本表现形式）。

String

InetSocketAddress.getHostName()
获取 hostname。

String

InetAddress.getHostName()
获取此 IP 地址的主机名。

String

URISyntaxException.getInput()
返回输入字符串。

String

HttpRetryException.getLocation()
如果重定向产生错误，则返回 Location 头字段的值。

String

URISyntaxException.getMessage()
返回描述解析错误的字符串。

String

HttpCookie.getName()
返回 cookie 的名称。

String

NetworkInterface.getName()
获取此网络接口的名称。

String

HttpCookie.getPath()
返回浏览器将此 cookie 返回到的服务器上的路径。

String

URI.getPath()
返回此 URI 的已解码的路径组成部分。

String

URL.getPath()
获取此 URL 的路径部分。

String

HttpCookie.getPortlist()
返回 cookie 的端口列表属性

String

URL.getProtocol()
获取此 URL 的协议名称。

String

URI.getQuery()
返回此 URI 的已解码的查询组成部分。

String

URL.getQuery()
获取此 URL 的查询部分。

String

URI.getRawAuthority()
返回此 URI 的原始授权组成部分。

String

URI.getRawFragment()
返回此 URI 的原始片段组成部分。

String

URI.getRawPath()
返回此 URI 的原始路径组成部分。

String

URI.getRawQuery()
返回此 URI 的原始查询组成部分。

String

URI.getRawSchemeSpecificPart()
返回此 URI 原始的、特定于方案的部分。

String

URI.getRawUserInfo()
返回此 URI 的原始用户信息组成部分。

String

HttpRetryException.getReason()
返回解释不能重试 http 请求的原因的字符串。

String

URISyntaxException.getReason()
返回一个字符串，解释输入字符串不能解析的原因。

String

URL.getRef()
获取此 URL 的锚点（也称为“引用”）。

protected  String

Authenticator.getRequestingHost()
获取请求验证的站点或代理的 hostname；如果不可用，则为 null。

protected  String

Authenticator.getRequestingPrompt()
获取请求方给出的提示字符串。

protected  String

Authenticator.getRequestingProtocol()
给出正在请求连接的协议。

protected  String

Authenticator.getRequestingScheme()
获取请求方的方案（例如，HTTP 防火墙的 HTTP 方案）。

String

HttpURLConnection.getRequestMethod()
获取请求方法。

String

URLConnection.getRequestProperty(String key)
返回此连接指定的一般请求属性值。

String

HttpURLConnection.getResponseMessage()
获取与来自服务器的响应代码一起返回的 HTTP 响应消息（如果有）。

String

URI.getScheme()
返回此 URI 的方案组成部分。

String

URI.getSchemeSpecificPart()
返回此 URI 的特定于方案的解码部分。

String

URI.getUserInfo()
返回此 URI 的已解码的用户信息组成部分。

String

URL.getUserInfo()
获取此 URL 的 userInfo 部分。

String

PasswordAuthentication.getUserName()
返回用户名。

String

HttpCookie.getValue()
返回 cookie 的值。

static String

URLConnection.guessContentTypeFromName(String fname)
根据 URL 的指定 "file" 部分尝试确定对象的内容类型。

static String

URLConnection.guessContentTypeFromStream(InputStream is)
根据输入流的开始字符尝试确定输入流的类型。

static String

IDN.toASCII(String input)
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。

static String

IDN.toASCII(String input, int flag)
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。

String

URI.toASCIIString()
以 US-ASCII 字符串形式返回此 URI 的内容。

String

URL.toExternalForm()
构造此 URL 的字符串表示形式。

protected  String

URLStreamHandler.toExternalForm(URL u)
将特定协议的 URL 转换为 String。

String

HttpCookie.toString()
构造此 cookie 的一个 cookie 头字符串表示形式，其格式为对应的 cookie 规范定义的格式，但没有前导 "Cookie:" 标记。

String

InterfaceAddress.toString()
将此接口地址转换为 String。

String

NetworkInterface.toString()

String

ServerSocket.toString()
作为 String 返回此套接字的实现地址和实现端口。

String

Proxy.toString()
构造此代理的字符串表示形式。

String

URI.toString()
以字符串形式返回此 URI 的内容。

String

SocketImpl.toString()
以 String 的形式返回此套接字的地址和端口。

String

InetSocketAddress.toString()
构造此 InetSocketAddress 的字符串表示形式。

String

InetAddress.toString()
将此 IP 地址转换为 String。

String

Socket.toString()
将此套接字转换为 String。

String

URLConnection.toString()
返回此 URL 连接的 String 表示形式。

String

URL.toString()
构造此 URL 的字符串表示形式。

static String

IDN.toUnicode(String input)
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 ACE) 转换为 Unicode。

static String

IDN.toUnicode(String input, int flag)
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 (ACE) 转换为 Unicode。

返回变量类型为 String 的类型的 java.net 中的方法

abstract  Map<String,List<String>>

CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders)
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。

abstract  Map<String,List<String>>

CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders)
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。

Map<String,List<String>>

CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)

Map<String,List<String>>

CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)

Map<String,List<String>>

URLConnection.getHeaderFields()
返回头字段的不可修改的 Map。

Map<String,List<String>>

URLConnection.getHeaderFields()
返回头字段的不可修改的 Map。

abstract  Map<String,List<String>>

CacheResponse.getHeaders()
以 Map 的形式返回响应头。

abstract  Map<String,List<String>>

CacheResponse.getHeaders()
以 Map 的形式返回响应头。

Map<String,List<String>>

URLConnection.getRequestProperties()
返回一个由此连接的一般请求属性构成的不可修改的 Map。

Map<String,List<String>>

URLConnection.getRequestProperties()
返回一个由此连接的一般请求属性构成的不可修改的 Map。

参数类型为 String 的 java.net 中的方法

void

URLConnection.addRequestProperty(String key, String value)
添加由键值对指定的一般请求属性。

protected abstract  void

SocketImpl.connect(String host, int port)
将此套接字连接到指定主机上的指定端口。

static URI

URI.create(String str)
通过解析给定的字符串创建 URI。

ContentHandler

ContentHandlerFactory.createContentHandler(String mimetype)
创建从 URLStreamHandler 读取对象的新 ContentHandler。

static InetSocketAddress

InetSocketAddress.createUnresolved(String host, int port)
根据主机名和端口号创建未解析的套接字地址。

URLStreamHandler

URLStreamHandlerFactory.createURLStreamHandler(String protocol)
创建具有指定协议的新 URLStreamHandler 实例。

static String

URLDecoder.decode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。

static String

URLDecoder.decode(String s, String enc)
使用指定的编码机制对 application/x-www-form-urlencoded 字符串解码。

protected  Package

URLClassLoader.definePackage(String name, Manifest man, URL url)
用该 ClassLoader 中的名称定义一个新包。

static boolean

HttpCookie.domainMatches(String domain, String host)
检查主机名是否在域中的实用方法。

static String

URLEncoder.encode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。

static String

URLEncoder.encode(String s, String enc)
使用指定的编码机制将字符串转换为 application/x-www-form-urlencoded 格式。

protected  Class<?>

URLClassLoader.findClass(String name)
通过 URL 搜索路径查找并加载具有指定名称的类。

URL

URLClassLoader.findResource(String name)
在 URL 搜索路径中查找具有指定名称的资源。

Enumeration<URL>

URLClassLoader.findResources(String name)
返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。

abstract  CacheResponse

ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
根据请求的 uri、请求方法和请求头获取缓存的响应。

static InetAddress[]

InetAddress.getAllByName(String host)
在给定主机名的情况下，根据系统上配置的名称服务返回其 IP 地址所组成的数组。

static InetAddress

InetAddress.getByAddress(String host, byte[] addr)
根据提供的主机名和 IP 地址创建 InetAddress。

static Inet6Address

Inet6Address.getByAddress(String host, byte[] addr, int scope_id)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为给定的数字值。

static Inet6Address

Inet6Address.getByAddress(String host, byte[] addr, NetworkInterface nif)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。

static NetworkInterface

NetworkInterface.getByName(String name)
搜索具有指定名称的网络接口。

static InetAddress

InetAddress.getByName(String host)
在给定主机名的情况下确定主机的 IP 地址。

String

FileNameMap.getContentTypeFor(String fileName)
获取指定文件名的 MIME 类型。

static String

URLConnection.getDefaultRequestProperty(String key)
已过时。 应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。

String

URLConnection.getHeaderField(String name)
返回指定的头字段的值。

long

HttpURLConnection.getHeaderFieldDate(String name, long Default)

long

URLConnection.getHeaderFieldDate(String name, long Default)
返回解析为日期的指定字段的值。

int

URLConnection.getHeaderFieldInt(String name, int Default)
返回解析为数字的指定字段的值。

String

URLConnection.getRequestProperty(String key)
返回此连接指定的一般请求属性值。

static String

URLConnection.guessContentTypeFromName(String fname)
根据 URL 的指定 "file" 部分尝试确定对象的内容类型。

static List<HttpCookie>

HttpCookie.parse(String header)
根据 set-cookie 或 set-cookie2 头字符串构造 cookie。

protected  void

URLStreamHandler.parseURL(URL u, String spec, int start, int limit)
将 URL 的字符表示形式解析为 URL 对象。

static PasswordAuthentication

Authenticator.requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String scheme)
要求已经向系统注册的 authenticator 提供密码。

static PasswordAuthentication

Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme)
要求已经向系统注册的 authenticator 提供密码。

static PasswordAuthentication

Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
要求已经向系统注册的 authenticator 提供密码。

URI

URI.resolve(String str)
解析给定的字符串，然后在此 URI 的基础上构造一个新的 URI。

protected  void

URL.set(String protocol, String host, int port, String file, String ref)
设置 URL 的字段。

protected  void

URL.set(String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref)
设置 URL 的指定的 8 个字段。

void

HttpCookie.setComment(String purpose)
指定一个描述 cookie 用途的注释。

void

HttpCookie.setCommentURL(String purpose)
指定一个描述 cookie 用途的注释 URL。

static void

URLConnection.setDefaultRequestProperty(String key, String value)
已过时。 应在获得 URLConnection 的适当实例后使用特定 setRequestProperty 方法的实例。调用此方法没有任何作用。

void

HttpCookie.setDomain(String pattern)
指定应在其中显示此 cookie 的域。

void

HttpCookie.setPath(String uri)
指定客户机应该返回 cookie 的路径。

void

HttpCookie.setPortlist(String ports)
指定 cookie 的端口列表，该列表在 Cookie 头中限制可能将 cookie 发送回的端口。

void

HttpURLConnection.setRequestMethod(String method)
设置 URL 请求的方法， GET POST HEAD OPTIONS PUT DELETE TRACE 以上方法之一是合法的，具体取决于协议的限制。

void

URLConnection.setRequestProperty(String key, String value)
设置一般请求属性。

protected  void

URLStreamHandler.setURL(URL u, String protocol, String host, int port, String file, String ref)
已过时。 使用 setURL(URL, String, String, int, String, String, String, String);

protected  void

URLStreamHandler.setURL(URL u, String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref)
将 URL 参数的字段设置为指示的值。

void

HttpCookie.setValue(String newValue)
在创建 cookie 之后将新值分配给 cookie。

static String

IDN.toASCII(String input)
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。

static String

IDN.toASCII(String input, int flag)
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。

static String

IDN.toUnicode(String input)
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 ACE) 转换为 Unicode。

static String

IDN.toUnicode(String input, int flag)
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 (ACE) 转换为 Unicode。

static Proxy.Type

Proxy.Type.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Authenticator.RequestorType

Authenticator.RequestorType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

类型变量类型为 String 的 java.net 中的方法参数

abstract  Map<String,List<String>>

CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders)
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。

abstract  Map<String,List<String>>

CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders)
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。

Map<String,List<String>>

CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)

Map<String,List<String>>

CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)

abstract  CacheResponse

ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
根据请求的 uri、请求方法和请求头获取缓存的响应。

abstract  CacheResponse

ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
根据请求的 uri、请求方法和请求头获取缓存的响应。

abstract  void

CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders)
将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。

abstract  void

CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders)
将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。

void

CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)

void

CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)

参数类型为 String 的 java.net 中的构造方法

BindException(String msg)
构造一个新的 BindException，使其具有关于绑定错误产生原因的指定详细消息。

ConnectException(String msg)
构造一个新的 ConnectException，使其具有关于连接错误产生原因的指定详细消息。

HttpCookie(String name, String value)
构造带有指定名称和值的 cookie。

HttpRetryException(String detail, int code)
根据指定的响应代码和异常详细消息构造新 HttpRetryException。

HttpRetryException(String detail, int code, String location)
构造一个新 HttpRetryException，使其具有详细消息 responseCode 和 Location 响应头字段的内容。

InetSocketAddress(String hostname, int port)
根据主机名和端口号创建套接字地址。

MalformedURLException(String msg)
构造带指定详细消息的 MalformedURLException。

NetPermission(String name)
创建具有指定名称的新 NetPermission。

NetPermission(String name, String actions)
创建带指定名称的新 NetPermission。

NoRouteToHostException(String msg)
构造一个新的 NoRouteToHostException，使其具有关于无法到达远程主机的原因的指定详细消息。

PasswordAuthentication(String userName, char[] password)
根据给定用户名和密码创建新的 PasswordAuthentication 对象。

PortUnreachableException(String msg)
构造带详细消息的新 PortUnreachableException。

ProtocolException(String host)
构造带指定详细消息的新 ProtocolException。

Socket(String host, int port)
创建一个流套接字并将其连接到指定主机上的指定端口号。

Socket(String host, int port, boolean stream)
已过时。 使用 DatagramSocket 取代 UDP 传输。

Socket(String host, int port, InetAddress localAddr, int localPort)
创建一个套接字并将其连接到指定远程主机上的指定远程端口。

SocketException(String msg)
构造带指定详细消息的新 SocketException。

SocketPermission(String host, String action)
创建带指定动作的新 SocketPermission 对象。

SocketTimeoutException(String msg)
构造带详细消息的新 SocketTimeoutException。

UnknownHostException(String host)
构造带有指定详细消息的新 UnknownHostException。

UnknownServiceException(String msg)
构造带指定详细消息的新 UnknownServiceException。

URI(String str)
通过解析给定的字符串构造一个 URI。

URI(String scheme, String ssp, String fragment)
根据给定的组成部分构造 URI。

URI(String scheme, String userInfo, String host, int port, String path, String query, String fragment)
根据给定的组成部分构造一个分层 URI。

URI(String scheme, String host, String path, String fragment)
根据给定的组成部分构造分层 URI。

URI(String scheme, String authority, String path, String query, String fragment)
根据给定的组成部分构造分层 URI。

URISyntaxException(String input, String reason)
根据给定的输入字符串和原因构造一个实例。

URISyntaxException(String input, String reason, int index)
根据给定的输入字符串、原因和错误索引构造一个实例。

URL(String spec)
根据 String 表示形式创建 URL 对象。

URL(String protocol, String host, int port, String file)
根据指定 protocol、host、port 号和 file 创建 URL 对象。

URL(String protocol, String host, int port, String file, URLStreamHandler handler)
根据指定的 protocol、host、port 号、file 和 handler 创建 URL 对象。

URL(String protocol, String host, String file)
根据指定的 protocol 名称、host 名称和 file 名称创建 URL。

URL(URL context, String spec)
通过在指定的上下文中对给定的 spec 进行解析创建 URL。

URL(URL context, String spec, URLStreamHandler handler)
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。

java.nio 中 String 的使用

返回 String 的 java.nio 中的方法

String

DoubleBuffer.toString()
返回总结了此缓冲区状态的字符串。

String

FloatBuffer.toString()
返回总结了此缓冲区状态的字符串。

String

LongBuffer.toString()
返回总结了此缓冲区状态的字符串。

String

ShortBuffer.toString()
返回总结了此缓冲区状态的字符串。

String

IntBuffer.toString()
返回总结了此缓冲区状态的字符串。

String

CharBuffer.toString()
返回包含此缓冲区中字符的字符串。

String

ByteOrder.toString()
构造描述此对象的字符串。

String

ByteBuffer.toString()
返回汇总了此缓冲区状态的字符串。

参数类型为 String 的 java.nio 中的方法

CharBuffer

CharBuffer.put(String src)
相对批量 put 方法（可选操作）。

CharBuffer

CharBuffer.put(String src, int start, int end)
相对批量 put 方法（可选操作）。

java.nio.channels 中 String 的使用

返回 String 的 java.nio.channels 中的方法

String

FileLock.toString()
返回描述此锁定的范围、类型和有效性的字符串。

String

FileChannel.MapMode.toString()
返回描述此文件映射模式的字符串。

参数类型为 String 的 java.nio.channels 中的方法

static Reader

Channels.newReader(ReadableByteChannel ch, String csName)
构造一个 reader，它根据命名的 charset 对取自给定信道的字节进行解码。

static Writer

Channels.newWriter(WritableByteChannel ch, String csName)
构造一个 writer，它根据指定的 charset 对字符进行编码，并将所得的字节写入给定的信道。

java.nio.charset 中 String 的使用

返回 String 的 java.nio.charset 中的方法

String

Charset.displayName()
返回此 charset 用于默认语言环境的可读名称。

String

Charset.displayName(Locale locale)
返回此 charset 用于给定语言环境的可读名称。

String

IllegalCharsetNameException.getCharsetName()
获取非法的 charset 名称。

String

UnsupportedCharsetException.getCharsetName()
获取不受支持的 charset 的名称。

String

MalformedInputException.getMessage()

String

UnmappableCharacterException.getMessage()

String

Charset.name()
返回此 charset 的规范名称。

String

CharsetDecoder.replacement()
返回此解码器的替换值。

String

CoderResult.toString()
返回描述此 CoderResult 的字符串。

String

CodingErrorAction.toString()
返回描述此操作的字符串。

String

Charset.toString()
返回描述此 charset 的字符串。

返回变量类型为 String 的类型的 java.nio.charset 中的方法

Set<String>

Charset.aliases()
返回包含此 charset 各个别名的集合。

static SortedMap<String,Charset>

Charset.availableCharsets()
构造从规范 charset 名称到 charset 对象的有序映射。

参数类型为 String 的 java.nio.charset 中的方法

ByteBuffer

Charset.encode(String str)
将此 charset 中的字符串编码成字节的便捷方法。

static Charset

Charset.forName(String charsetName)
返回指定 charset 的 charset 对象。

protected  void

CharsetDecoder.implReplaceWith(String newReplacement)
报告此解码器替换值的更改。

static boolean

Charset.isSupported(String charsetName)
通知是否支持指定的 charset。

CharsetDecoder

CharsetDecoder.replaceWith(String newReplacement)
更改此解码器的替换值。

参数类型为 String 的 java.nio.charset 中的构造方法

Charset(String canonicalName, String[] aliases)
使用给定的规范名称和别名集合初始化新 charset。

Charset(String canonicalName, String[] aliases)
使用给定的规范名称和别名集合初始化新 charset。

IllegalCharsetNameException(String charsetName)
构造此类的一个实例。

UnsupportedCharsetException(String charsetName)
构造此类的一个实例。

java.nio.charset.spi 中 String 的使用

参数类型为 String 的 java.nio.charset.spi 中的方法

abstract  Charset

CharsetProvider.charsetForName(String charsetName)
用给定的 charset 名称获取 charset。

java.rmi 中 String 的使用

返回 String 的 java.rmi 中的方法

String

RemoteException.getMessage()
返回此异常的详细消息，包括来自原因（如果有）方面的消息。

static String[]

Naming.list(String name)
返回在注册表中绑定的名称所组成的数组。

参数类型为 String 的 java.rmi 中的方法

static void

Naming.bind(String name, Remote obj)
将指定 name 绑定到远程对象。

static String[]

Naming.list(String name)
返回在注册表中绑定的名称所组成的数组。

static Remote

Naming.lookup(String name)
返回与指定 name 关联的远程对象的引用（一个 stub）。

static void

Naming.rebind(String name, Remote obj)
将指定名称重新绑定到一个新的远程对象。

static void

Naming.unbind(String name)
销毁与远程对象关联的指定名称的绑定。

参数类型为 String 的 java.rmi 中的构造方法

AccessException(String s)
构造带指定详细消息的 AccessException。

AccessException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 AccessException。

AlreadyBoundException(String s)
构造带指定详细消息的 AlreadyBoundException。

ConnectException(String s)
构造带指定详细消息的 ConnectException。

ConnectException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ConnectException。

ConnectIOException(String s)
构造带指定详细消息的 ConnectIOException。

ConnectIOException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ConnectIOException。

MarshalException(String s)
构造带有指定详细消息的 MarshalException。

MarshalException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 MarshalException。

NoSuchObjectException(String s)
构造带指定详细消息的 NoSuchObjectException。

NotBoundException(String s)
构造带指定详细消息的 NotBoundException。

RemoteException(String s)
构造带指定详细消息的 RemoteException。

RemoteException(String s, Throwable cause)
构造带指定详细消息和原因的 RemoteException。

RMISecurityException(String name)
已过时。 无替换版本

RMISecurityException(String name, String arg)
已过时。 无替换版本

ServerError(String s, Error err)
构造带指定详细消息和嵌入错误的 ServerError。

ServerException(String s)
构造带指定详细消息的 ServerException。

ServerException(String s, Exception ex)
构造带有指定详细消息和嵌入异常的 ServerException。

ServerRuntimeException(String s, Exception ex)
已过时。 无替换版本

StubNotFoundException(String s)
构造带指定详细消息的 StubNotFoundException。

StubNotFoundException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 StubNotFoundException。

UnexpectedException(String s)
构造带指定详细消息的 UnexpectedException。

UnexpectedException(String s, Exception ex)
构造带有指定详细消息和嵌入异常的 UnexpectedException。

UnknownHostException(String s)
构造带指定详细消息的 UnknownHostException。

UnknownHostException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 UnknownHostException。

UnmarshalException(String s)
构造带指定详细消息的 UnmarshalException。

UnmarshalException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 UnmarshalException。

java.rmi.activation 中 String 的使用

返回 String 的 java.rmi.activation 中的方法

String

ActivationDesc.getClassName()
返回此描述符指定的对象的类名。

String

ActivationGroupDesc.getClassName()
返回组的类名（可能为 null）。

String[]

ActivationGroupDesc.CommandEnvironment.getCommandOptions()
取得配置的 java 命令选项。

String

ActivationGroupDesc.CommandEnvironment.getCommandPath()
取得配置的限定路径的 java 命令名称。

String

ActivationDesc.getLocation()
返回此描述符指定的对象的代码基。

String

ActivationGroupDesc.getLocation()
返回组的代码基。

String

ActivationException.getMessage()
返回包含来自此异常的原因（如果有）的消息的详细消息。

参数类型为 String 的 java.rmi.activation 中的方法

static ActivationID

Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port)
注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。

static ActivationID

Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

参数类型为 String 的 java.rmi.activation 中的构造方法

Activatable(String location, MarshalledObject<?> data, boolean restart, int port)
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。

Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

ActivateFailedException(String s)
构造带指定详细消息的 ActivateFailedException。

ActivateFailedException(String s, Exception ex)
构造带指定详细消息和嵌套异常的 ActivateFailedException。

ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。

ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码的 location 处加载，并且其初始化信息为 data。

ActivationDesc(String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。

ActivationDesc(String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。

ActivationException(String s)
构造带指定详细消息的 ActivationException。

ActivationException(String s, Throwable cause)
构造带指定详细消息和原因的 ActivationException。

ActivationGroupDesc.CommandEnvironment(String cmdpath, String[] argv)
用所有必要的信息创建一个 CommandEnvironment。

ActivationGroupDesc.CommandEnvironment(String cmdpath, String[] argv)
用所有必要的信息创建一个 CommandEnvironment。

ActivationGroupDesc(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
指定一个用于该组的替代组实现和执行环境。

UnknownGroupException(String s)
构造带指定详细消息的 UnknownGroupException。

UnknownObjectException(String s)
构造带指定详细消息的 UnknownObjectException。

java.rmi.dgc 中 String 的使用

返回 String 的 java.rmi.dgc 中的方法

String

VMID.toString()
返回此 VMID 的字符串表示形式。

java.rmi.registry 中 String 的使用

返回 String 的 java.rmi.registry 中的方法

String[]

Registry.list()
返回在此注册表中绑定的名称的数组。

参数类型为 String 的 java.rmi.registry 中的方法

void

Registry.bind(String name, Remote obj)
绑定对此注册表中指定 name 的远程引用。

static Registry

LocateRegistry.getRegistry(String host)
返回指定 host 在默认注册表端口 1099 上对远程对象 Registry 的引用。

static Registry

LocateRegistry.getRegistry(String host, int port)
返回指定的 host 和 port 上对远程对象 Registry 的引用。

static Registry

LocateRegistry.getRegistry(String host, int port, RMIClientSocketFactory csf)
返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。

Remote

Registry.lookup(String name)
返回注册表中绑定到指定 name 的远程引用。

void

Registry.rebind(String name, Remote obj)
用提供的远程引用替换此注册表中指定的 name 绑定。

Registry

RegistryHandler.registryStub(String host, int port)
已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。

void

Registry.unbind(String name)
移除此注册表中指定的 name 绑定。

java.rmi.server 中 String 的使用

声明为 String 的 java.rmi.server 中的字段

static String

LoaderHandler.packagePrefix
已过时。 系统 LoaderHandler 实现的包。

static String

RemoteRef.packagePrefix
初始化服务器包的前缀：假定服务器 ref 类（如 UnicastRef、UnicastServerRef）的实现位于由前缀定义的包中。

返回 String 的 java.rmi.server 中的方法

static String

RMIClassLoader.getClassAnnotation(Class<?> cl)
返回表示类定义位置的注释字符串，RMI 将在编组给定类的对象时用其注释类描述符。

abstract  String

RMIClassLoaderSpi.getClassAnnotation(Class<?> cl)
提供 RMIClassLoader.getClassAnnotation(Class) 的实现。

static String

RemoteServer.getClientHost()
返回一个客户机主机的字符串表示形式，用于在当前线程中正在处理的远程方法调用。

String

ServerRef.getClientHost()
返回当前客户机的主机名。

String

ServerCloneException.getMessage()
返回此异常的详细信息，包括原因的消息（如果有）。

String

Operation.getOperation()
已过时。 无替代版本

String

RemoteRef.getRefClass(ObjectOutput out)
返回要在流 'out' 上序列化的 ref 类型的类名称。

String

RemoteRef.remoteToString()
返回表示此远程对象的引用的 String。

String

LogStream.toString()
已过时。 无替代版本

String

ObjID.toString()
返回此对象标识符的字符串表示形式。

String

Operation.toString()
已过时。 无替代版本

String

RemoteObject.toString()
返回表示此远程对象的值的 String。

String

UID.toString()
返回此 UID 的字符串表示形式。

参数类型为 String 的 java.rmi.server 中的方法

Socket

RMIClientSocketFactory.createSocket(String host, int port)
创建连接到指定主机和端口的客户机套接字。

abstract  Socket

RMISocketFactory.createSocket(String host, int port)
创建连接到指定主机和端口的客户机套接字。

static ClassLoader

RMIClassLoader.getClassLoader(String codebase)
返回从给定的基本代码 URL 路径加载类的类加载器。

abstract  ClassLoader

RMIClassLoaderSpi.getClassLoader(String codebase)
提供 RMIClassLoader.getClassLoader(String) 的实现。

Class<?>

LoaderHandler.loadClass(String name)
已过时。 无替代版本

static Class<?>

RMIClassLoader.loadClass(String name)
已过时。 由 loadClass(String,String) 方法取代

static Class<?>

RMIClassLoader.loadClass(String codebase, String name)
从基本代码 URL 路径加载类。

static Class<?>

RMIClassLoader.loadClass(String codebase, String name, ClassLoader defaultLoader)
有选择地使用提供的加载器从基本代码 URL 路径加载类。

abstract  Class<?>

RMIClassLoaderSpi.loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。

Class<?>

LoaderHandler.loadClass(URL codebase, String name)
已过时。 无替代版本

static Class<?>

RMIClassLoader.loadClass(URL codebase, String name)
从基本代码 URL 加载类。

static Class<?>

RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。

static Class<?>

RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。

abstract  Class<?>

RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

abstract  Class<?>

RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

static LogStream

LogStream.log(String name)
已过时。 无替代版本

static int

LogStream.parseLevel(String s)
已过时。 无替代版本

参数类型为 String 的 java.rmi.server 中的构造方法

ExportException(String s)
构造带指定详细消息的 ExportException。

ExportException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ExportException。

Operation(String op)
已过时。 无替代版本

ServerCloneException(String s)
构造带指定详细消息的 ServerCloneException。

ServerCloneException(String s, Exception cause)
构造带指定详细消息和原因的 ServerCloneException。

ServerNotActiveException(String s)
构造带指定详细消息的 ServerNotActiveException。

SkeletonMismatchException(String s)
已过时。 无替代版本

SkeletonNotFoundException(String s)
已过时。 构造带指定详细消息的 SkeletonNotFoundException。

SkeletonNotFoundException(String s, Exception ex)
已过时。 构造带指定详细消息和嵌套异常的 SkeletonNotFoundException。

SocketSecurityException(String s)
构造带指定详细消息的 SocketSecurityException。

SocketSecurityException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 SocketSecurityIOException。

java.security 中 String 的使用

返回 String 的 java.security 中的方法

abstract  String

KeyStoreSpi.engineGetCertificateAlias(Certificate cert)
返回其证书和给定证书匹配的第一个 keystore 项的名称（别名）。

protected abstract  String

AlgorithmParametersSpi.engineToString()
返回描述参数的格式化字符串。

String

UnresolvedPermission.getActions()
返回这些操作的规范的字符串表示形式，该字符串当前为空字符串 ""，原因是没有针对 UnresolvedPermission 的操作。

String

AllPermission.getActions()
返回操作的规范化字符串表示形式。

String

BasicPermission.getActions()
返回操作的规范化字符串表示形式，该表示形式当前为空字符串 ""，因为不存在 BasicPermission 的操作。

abstract  String

Permission.getActions()
以 String 的形式返回操作。

String

AlgorithmParameterGenerator.getAlgorithm()
返回与此参数生成器关联的算法的标准名称。

String

KeyPairGenerator.getAlgorithm()
返回此密钥对生成器算法的标准名称。

String

SecureRandom.getAlgorithm()
返回此 SecureRandom 对象实现的算法的名称。

String

SignedObject.getAlgorithm()
获取签名算法的名称。

String

Signature.getAlgorithm()
返回此签名对象的算法名称。

String

AlgorithmParameters.getAlgorithm()
返回与此参数对象关联的算法的名称。

String

KeyFactory.getAlgorithm()
获取与此 KeyFactory 关联的算法的名称。

String

Key.getAlgorithm()
返回此密钥的标准算法名称。

String

MessageDigest.getAlgorithm()
返回标识算法的独立于实现细节的字符串。

String

Provider.Service.getAlgorithm()
返回此服务的算法的名称。

static String

Security.getAlgorithmProperty(String algName, String propName)
已过时。 此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。

String

Provider.Service.getAttribute(String name)
返回指定属性的值，如果没有为此 Service 设置此属性，则返回 null。

String

KeyStore.getCertificateAlias(Certificate cert)
返回证书与给定证书匹配的第一个 keystore 条目的别名。

String

Provider.Service.getClassName()
返回实现此服务的类的名称。

static String

KeyStore.getDefaultType()
返回 Java 安全属性文件中指定的默认 keystore 类型；如果不存在此类属性，则返回字符串 "jks"（"Java keystore" 的首字母缩写）。

String

Certificate.getFormat()
已过时。 返回编码格式的名称。

String

Key.getFormat()
返回此密钥的基本编码格式，如果此密钥不支持编码，则返回 null。

String

Identity.getInfo()
已过时。 返回以前为此 Identity 指定的常规信息字符串。

String

Provider.getInfo()
返回 provider 及其服务的人可读 (human-readable) 的描述。

String

Identity.getName()
已过时。 返回此 Identity 的名称。

String

Provider.getName()
返回此 provider 的名称。

String

Principal.getName()
返回此主体的名称。

String

Permission.getName()
返回此 Permission 的名称。

static String

Security.getProperty(String key)
获取安全属性值。

String

Provider.getProperty(String key)

String

KeyStore.getType()
返回此 keystore 的类型。

String

Provider.Service.getType()
获取此服务的类型。

String

Policy.getType()
返回此 Policy 的类型。

String

UnresolvedPermission.getUnresolvedActions()
获取尚未解析的基础权限的操作。

String

UnresolvedPermission.getUnresolvedName()
获取尚未解析的基础权限的目标名称。

String

UnresolvedPermission.getUnresolvedType()
获取尚未解析的基础权限的类型（类名称）。

String

DigestInputStream.toString()
打印此摘要输入流及其关联的消息摘要对象的字符串表示形式。

String

DigestOutputStream.toString()
打印此摘要输出流及其关联的消息摘要对象的字符串表示形式。

String

Identity.toString()
已过时。 返回描述此 Identity 的短字符串，说明其名称和作用域（如果有的话）。

String

IdentityScope.toString()
已过时。 返回此身份作用域的字符串表示形式，包括其名称、作用域名称和此身份作用域中身份的数目。

String

KeyStore.PrivateKeyEntry.toString()
返回此 PrivateKeyEntry 的字符串表示形式。

String

KeyStore.SecretKeyEntry.toString()
返回此 SecretKeyEntry 的字符串表示形式。

String

KeyStore.TrustedCertificateEntry.toString()
返回此 TrustedCertificateEntry 的字符串表示形式。

String

Signer.toString()
已过时。 返回有关该 signer 信息的字符串。

String

Timestamp.toString()
返回描述此时间戳的字符串。

String

CodeSigner.toString()
返回描述此代码签名者的字符串。

String

Signature.toString()
返回此签名对象的字符串表示形式，以提供包括对象状态和所用算法名称在内的信息。

String

AlgorithmParameters.toString()
返回描述参数的格式化字符串。

String

MessageDigest.toString()
返回此信息摘要对象的字符串表示形式。

String

Provider.toString()
返回具有此 provider 名称和版本号的字符串。

String

Provider.Service.toString()
返回此服务的字符串表示形式。

String

Principal.toString()
返回此主体的字符串表示形式。

String

UnresolvedPermission.toString()
返回描述此 UnresolvedPermission 的字符串。

String

PermissionCollection.toString()
返回描述此 PermissionCollection 对象的字符串，提供该对象中包含的关于所有权限的信息。

String

CodeSource.toString()
返回描述此 CodeSource 的字符串，告知其 URL 和证书。

String

PrivilegedActionException.toString()

String

Permission.toString()
返回描述此 Permission 的字符串。

String

ProtectionDomain.toString()
将 ProtectionDomain 转换成为 String。

String

Certificate.toString(boolean detailed)
已过时。 返回表示证书内容的字符串。

String

Identity.toString(boolean detailed)
已过时。 返回此 Identity 的字符串表示形式，可以选择比不带任何参数的 toString 方法带有更多的详细信息。

返回变量类型为 String 的类型的 java.security 中的方法

Enumeration<String>

KeyStore.aliases()
列出此 keystore 的所有别名。

abstract  Enumeration<String>

KeyStoreSpi.engineAliases()
列出此 keystore 的所有别名。

static Set<String>

Security.getAlgorithms(String serviceName)
返回字符串 Set，这些字符串包含了指定的 Java 加密服务的所有可用算法或类型的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。

参数类型为 String 的 java.security 中的方法

boolean

KeyStore.containsAlias(String alias)
检查给定别名是否存在于此 keystore 中。

protected  Class<?>

SecureClassLoader.defineClass(String name, byte[] b, int off, int len, CodeSource cs)
使用可选的 CodeSource 将 byte 数组转换为 Class 类的实例。

protected  Class<?>

SecureClassLoader.defineClass(String name, ByteBuffer b, CodeSource cs)
使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。

void

KeyStore.deleteEntry(String alias)
删除此 keystore 中给定别名标识的条目。

abstract  boolean

KeyStoreSpi.engineContainsAlias(String alias)
检查给定别名是否存在于此 keystore 中。

abstract  void

KeyStoreSpi.engineDeleteEntry(String alias)
删除由此 keystore 中给定的别名标识的项。

boolean

KeyStoreSpi.engineEntryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass)
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。

abstract  Certificate

KeyStoreSpi.engineGetCertificate(String alias)
返回与给定别名关联的证书。

abstract  Certificate[]

KeyStoreSpi.engineGetCertificateChain(String alias)
返回与给定别名关联的证书链。

abstract  Date

KeyStoreSpi.engineGetCreationDate(String alias)
返回该别名标识的项的创建日期。

protected abstract  byte[]

AlgorithmParametersSpi.engineGetEncoded(String format)
返回以指定格式编码的参数。

KeyStore.Entry

KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam)
使用指定保护参数获取指定别名的 KeyStore.Entry。

abstract  Key

KeyStoreSpi.engineGetKey(String alias, char[] password)
返回与给定别名关联的密钥，使用给定密码恢复它。

protected abstract  Object

SignatureSpi.engineGetParameter(String param)
已过时。

protected abstract  void

AlgorithmParametersSpi.engineInit(byte[] params, String format)
根据指定的解码格式从 params 导入参数并对其解码。

abstract  boolean

KeyStoreSpi.engineIsCertificateEntry(String alias)
如果给定别名标识的项是通过调用 setCertificateEntry 或者调用使用 TrustedCertificateEntry 作为参数的 setEntry 来创建的，则返回 true。

abstract  boolean

KeyStoreSpi.engineIsKeyEntry(String alias)
如果给定别名标识的项是通过调用 setKeyEntry 或者调用使用 PrivateKeyEntry 或 SecretKeyEntry 作为参数的 setEntry 创建的，则返回 true。

abstract  void

KeyStoreSpi.engineSetCertificateEntry(String alias, Certificate cert)
将给定证书分配给给定别名。

void

KeyStoreSpi.engineSetEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
用指定别名保存 KeyStore.Entry。

abstract  void

KeyStoreSpi.engineSetKeyEntry(String alias, byte[] key, Certificate[] chain)
将给定密钥（已经被保护）分配给给定别名。

abstract  void

KeyStoreSpi.engineSetKeyEntry(String alias, Key key, char[] password, Certificate[] chain)
将给定的密钥分配给给定的别名，用给定的密码保护它。

protected abstract  void

SignatureSpi.engineSetParameter(String param, Object value)
已过时。 由 engineSetParameter 取代。

boolean

KeyStore.entryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass)
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。

static String

Security.getAlgorithmProperty(String algName, String propName)
已过时。 此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。

static Set<String>

Security.getAlgorithms(String serviceName)
返回字符串 Set，这些字符串包含了指定的 Java 加密服务的所有可用算法或类型的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。

String

Provider.Service.getAttribute(String name)
返回指定属性的值，如果没有为此 Service 设置此属性，则返回 null。

Certificate

KeyStore.getCertificate(String alias)
返回与给定别名关联的证书。

Certificate[]

KeyStore.getCertificateChain(String alias)
返回与给定别名关联的证书链。

Date

KeyStore.getCreationDate(String alias)
返回给定别名标识的条目的创建日期。

byte[]

AlgorithmParameters.getEncoded(String format)
返回以指定方案编码的参数。

KeyStore.Entry

KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam)
使用指定保护参数获取指定别名的 keystore Entry。

abstract  Identity

IdentityScope.getIdentity(String name)
已过时。 返回此作用域内具有指定名称的身份（如果有的话）。

static AlgorithmParameterGenerator

AlgorithmParameterGenerator.getInstance(String algorithm)
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

static KeyPairGenerator

KeyPairGenerator.getInstance(String algorithm)
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

static KeyStore

KeyStore.getInstance(String type)
返回指定类型的 keystore 对象。

static SecureRandom

SecureRandom.getInstance(String algorithm)
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

static Signature

Signature.getInstance(String algorithm)
返回实现指定签名算法的 Signature 对象。

static AlgorithmParameters

AlgorithmParameters.getInstance(String algorithm)
返回指定算法的参数对象。

static KeyFactory

KeyFactory.getInstance(String algorithm)
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

static MessageDigest

MessageDigest.getInstance(String algorithm)
返回实现指定摘要算法的 MessageDigest 对象。

static Policy

Policy.getInstance(String type, Policy.Parameters params)
返回指定类型的 Policy 对象。

static Policy

Policy.getInstance(String type, Policy.Parameters params, Provider provider)
返回指定类型的 Policy 对象。

static Policy

Policy.getInstance(String type, Policy.Parameters params, String provider)
返回指定类型的 Policy 对象。

static AlgorithmParameterGenerator

AlgorithmParameterGenerator.getInstance(String algorithm, Provider provider)
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

static KeyPairGenerator

KeyPairGenerator.getInstance(String algorithm, Provider provider)
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

static KeyStore

KeyStore.getInstance(String type, Provider provider)
返回指定类型的 keystore 对象。

static SecureRandom

SecureRandom.getInstance(String algorithm, Provider provider)
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

static Signature

Signature.getInstance(String algorithm, Provider provider)
返回实现指定签名算法的 Signature 对象。

static AlgorithmParameters

AlgorithmParameters.getInstance(String algorithm, Provider provider)
返回指定算法的参数对象。

static KeyFactory

KeyFactory.getInstance(String algorithm, Provider provider)
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

static MessageDigest

MessageDigest.getInstance(String algorithm, Provider provider)
返回实现指定摘要算法的 MessageDigest 对象。

static AlgorithmParameterGenerator

AlgorithmParameterGenerator.getInstance(String algorithm, String provider)
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

static KeyPairGenerator

KeyPairGenerator.getInstance(String algorithm, String provider)
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

static KeyStore

KeyStore.getInstance(String type, String provider)
返回指定类型的 keystore 对象。

static SecureRandom

SecureRandom.getInstance(String algorithm, String provider)
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

static Signature

Signature.getInstance(String algorithm, String provider)
返回实现指定签名算法的 Signature 对象。

static AlgorithmParameters

AlgorithmParameters.getInstance(String algorithm, String provider)
返回指定算法的参数对象。

static KeyFactory

KeyFactory.getInstance(String algorithm, String provider)
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

static MessageDigest

MessageDigest.getInstance(String algorithm, String provider)
返回实现指定摘要算法的 MessageDigest 对象。

Key

KeyStore.getKey(String alias, char[] password)
返回与给定别名关联的密钥，并用给定密码来恢复它。

Object

Signature.getParameter(String param)
已过时。

static String

Security.getProperty(String key)
获取安全属性值。

String

Provider.getProperty(String key)

abstract  KeyStore.ProtectionParameter

KeyStore.Builder.getProtectionParameter(String alias)
返回应该用来获取具有给定别名的 Entry 的 ProtectionParameters。

static Provider

Security.getProvider(String name)
返回使用指定的名称安装的提供者（如果有）。

static Provider[]

Security.getProviders(String filter)
返回包含满足指定的选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。

Provider.Service

Provider.getService(String type, String algorithm)
获取描述此算法或别名的指定类型的此 Provider 实现的服务。

void

AlgorithmParameters.init(byte[] params, String format)
根据指定的解码方案从 params 导入参数并对其解码。

boolean

KeyStore.isCertificateEntry(String alias)
如果给定别名标识的条目是通过调用 setCertificateEntry 或者以 TrustedCertificateEntry 为参数的 setEntry 创建的，则返回 true。

boolean

KeyStore.isKeyEntry(String alias)
如果给定别名标识的条目是通过调用 setKeyEntry 或者以 PrivateKeyEntry 或 SecretKeyEntry 为参数的 setEntry 创建的，则返回 true。

static KeyStore.Builder

KeyStore.Builder.newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection)
返回新的 Builder 对象。

static KeyStore.Builder

KeyStore.Builder.newInstance(String type, Provider provider, KeyStore.ProtectionParameter protection)
返回新的 Builder 对象。

static void

Security.removeProvider(String name)
移除带有指定名称的提供者。

void

KeyStore.setCertificateEntry(String alias, Certificate cert)
将给定可信证书分配给给定别名。

void

KeyStore.setEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
用指定别名保存 keystore Entry。

void

Identity.setInfo(String info)
已过时。 为此 Identity 指定一个常规信息字符串。

void

KeyStore.setKeyEntry(String alias, byte[] key, Certificate[] chain)
将给定密钥（已经被保护）分配给给定别名。

void

KeyStore.setKeyEntry(String alias, Key key, char[] password, Certificate[] chain)
将给定的密钥分配给给定的别名，并用给定密码保护它。

void

Signature.setParameter(String param, Object value)
已过时。 使用 setParameter 取代。

static void

Security.setProperty(String key, String datum)
设置安全属性值。

static KeyRep.Type

KeyRep.Type.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

类型变量类型为 String 的 java.security 中的方法参数

static Provider[]

Security.getProviders(Map<String,String> filter)
返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。

static Provider[]

Security.getProviders(Map<String,String> filter)
返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。

参数类型为 String 的 java.security 中的构造方法

AccessControlException(String s)
构造带指定详细消息的 AccessControlException。

AccessControlException(String s, Permission p)
构造带指定详细消息和导致异常的请求权限的 AccessControlException。

AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameterGenerator 对象。

AlgorithmParameters(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameters 对象。

AllPermission(String name, String actions)
创建新的 AllPermission 对象。

AuthProvider(String name, double version, String info)
构造具有指定名称、版本号和信息的 provider。

BasicPermission(String name)
创建具有指定名称的新 BasicPermission。

BasicPermission(String name, String actions)
创建具有指定名称的新 BasicPermission 对象。

DigestException(String msg)
构造带指定详细消息的 DigestException。

DigestException(String message, Throwable cause)
创建带指定详细消息和 cause 的 DigestException。

GeneralSecurityException(String msg)
构造带指定详细消息的 GeneralSecurityException。

GeneralSecurityException(String message, Throwable cause)
创建带指定详细消息和 cause 的 GeneralSecurityException。

Identity(String name)
已过时。 构造一个具有指定名称且没有作用域的 Identity。

Identity(String name, IdentityScope scope)
已过时。 构造一个具有指定名称和作用域的 Identity。

IdentityScope(String name)
已过时。 构造具有指定名称的新身份作用域。

IdentityScope(String name, IdentityScope scope)
已过时。 构造具有指定名称和作用域的新身份作用域。

InvalidAlgorithmParameterException(String msg)
构造带指定详细消息的 InvalidAlgorithmParameterException。

InvalidAlgorithmParameterException(String message, Throwable cause)
创建带指定详细消息和 cause 的 InvalidAlgorithmParameterException。

InvalidKeyException(String msg)
构造带指定详细消息的 InvalidKeyException。

InvalidKeyException(String message, Throwable cause)
创建带指定详细消息和 cause 的 InvalidKeyException。

InvalidParameterException(String msg)
构造带指定详细消息的 InvalidParameterException。

KeyException(String msg)
构造带指定详细消息的 KeyException。

KeyException(String message, Throwable cause)
创建带指定详细消息和 cause 的 KeyException。

KeyFactory(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 KeyFactory 对象。

KeyManagementException(String msg)
构造带指定详细消息的 KeyManagementException。

KeyManagementException(String message, Throwable cause)
创建带指定详细消息和 cause 的 KeyManagementException。

KeyPairGenerator(String algorithm)
为指定的算法创建 KeyPairGenerator 对象。

KeyRep(KeyRep.Type type, String algorithm, String format, byte[] encoded)
构造替换的 Key 类。

KeyStore(KeyStoreSpi keyStoreSpi, Provider provider, String type)
创建给定类型的 KeyStore 对象，并在其中封装给定的提供者实现（SPI 对象）。

KeyStoreException(String msg)
构造带指定详细消息的 KeyStoreException。

KeyStoreException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 KeyStoreException。

MessageDigest(String algorithm)
创建具有指定算法名称的信息摘要。

NoSuchAlgorithmException(String msg)
构造带指定详细消息的 NoSuchAlgorithmException。

NoSuchAlgorithmException(String message, Throwable cause)
创建带指定详细消息和 cause 的 NoSuchAlgorithmException。

NoSuchProviderException(String msg)
构造带指定详细消息的 NoSuchProviderException。

Permission(String name)
构造具有指定名称的权限。

Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

Provider(String name, double version, String info)
用指定的名称、版本号和信息构造一个 provider。

ProviderException(String s)
构造带指定详细消息的 ProviderException。

ProviderException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 ProviderException。

SecurityPermission(String name)
创建具有指定名称的新 SecurityPermission。

SecurityPermission(String name, String actions)
创建具有指定名称的新 SecurityPermission 对象。

Signature(String algorithm)
创建指定算法的 Signature 对象。

SignatureException(String msg)
构造带指定详细消息的 SignatureException。

SignatureException(String message, Throwable cause)
创建带指定详细消息和原因的 SignatureException。

Signer(String name)
已过时。 创建带有指定标识名称的 signer。

Signer(String name, IdentityScope scope)
已过时。 创建带有指定标识名称和范围的 signer。

UnrecoverableEntryException(String msg)
构造具有指定详细消息的 UnrecoverableEntryException，其提供了有关为什么抛出此异常的更多信息。

UnrecoverableKeyException(String msg)
构造具有指定详细消息的 UnrecoverableKeyException，其提供了有关为什么抛出此异常的更多信息。

UnresolvedPermission(String type, String name, String actions, Certificate[] certs)
在解析权限时，创建一个新的 UnresolvedPermission，使之包含稍后实际创建指定类的 Permission 时所需的权限信息。

类型变量类型为 String 的 java.security 中的构造方法参数

Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

java.security.acl 中 String 的使用

返回 String 的 java.security.acl 中的方法

String

Acl.getName()
返回此 ACL 的名称。

String

Acl.toString()
返回 ACL 内容的字符串表示形式。

String

AclEntry.toString()
返回此 ACL 项内容的字符串表示形式。

String

Permission.toString()
打印此权限的字符串表示形式。

参数类型为 String 的 java.security.acl 中的方法

void

Acl.setName(Principal caller, String name)
设置此 ACL 的名称。

java.security.cert 中 String 的使用

返回 String 的 java.security.cert 中的方法

String

CertPathBuilder.getAlgorithm()
返回此 CertPathBuilder 的算法名称。

String

CertPathValidator.getAlgorithm()
返回此 CertPathValidator 的算法名称。

String

TrustAnchor.getCAName()
以 RFC 2253 String 格式返回最受信任的 CA 的名称。

static String

CertPathBuilder.getDefaultType()
返回 Java 安全属性文件中所指定的默认 CertPathBuilder 类型，如果没有此属性，则返回字符串 "PKIX"。

static String

CertPathValidator.getDefaultType()
返回 Java 安全属性文件中所指定的默认 CertPathValidator 类型，如果没有此属性，则返回字符串 "PKIX"。

static String

CertStore.getDefaultType()
返回 Java 安全属性文件中指定的默认 CertStore 类型；如果没有此属性，则返回字符串 "LDAP"。

String

X509CertSelector.getIssuerAsString()
已过时，使用 X509CertSelector.getIssuer() 或 X509CertSelector.getIssuerAsBytes() 替代。

String

PolicyQualifierInfo.getPolicyQualifierId()
返回此 PolicyQualifierInfo 的 policyQualifierId 字段。

String

LDAPCertStoreParameters.getServerName()
返回 LDAP 服务器的 DNS 名称。

abstract  String

X509CRL.getSigAlgName()
获取 CRL 签名算法的签名算法名。

abstract  String

X509Certificate.getSigAlgName()
获取证书签名算法的签名算法名。

abstract  String

X509CRL.getSigAlgOID()
获取 CRL 的签名算法 OID 字符串。

abstract  String

X509Certificate.getSigAlgOID()
获取证书的签名算法 OID 字符串。

String

PKIXParameters.getSigProvider()
返回签名提供者的名称，如果未设置，则返回 null。

String

X509CertSelector.getSubjectAsString()
已过时，使用 X509CertSelector.getSubject() 或 X509CertSelector.getSubjectAsBytes() 替代。

String

X509CertSelector.getSubjectPublicKeyAlgID()
返回 subjectPublicKeyAlgID 标准。

String

CRL.getType()
返回此 CRL 的类型。

String

CertStore.getType()
返回此 CertStore 的类型。

String

CertPath.getType()
返回此证书路径中的 Certificate 类型。

String

CertificateFactory.getType()
返回与此 CertificateFactory 关联的证书类型的名称。

String

Certificate.getType()
返回此证书的类型。

String

PolicyNode.getValidPolicy()
返回此节点所表示的有效策略。

abstract  String

CRL.toString()
返回此 CRL 的字符串表示形式。

String

CollectionCertStoreParameters.toString()
返回描述该参数的格式化字符串。

String

LDAPCertStoreParameters.toString()
返回描述该参数的格式化字符串。

String

PKIXBuilderParameters.toString()
返回描述该参数的格式化字符串。

String

PKIXCertPathBuilderResult.toString()
返回此 PKIXCertPathBuilderResult 的可打印表示形式。

String

PKIXCertPathValidatorResult.toString()
返回此 PKIXCertPathValidatorResult 的可打印表示形式。

String

PKIXParameters.toString()
返回描述该参数的格式化字符串。

String

PolicyQualifierInfo.toString()
返回此 PolicyQualifierInfo 的可打印表示形式。

String

TrustAnchor.toString()
返回描述此 TrustAnchor 的格式化字符串。

abstract  String

X509CRLEntry.toString()
返回此 CRL 项的字符串表示形式。

String

X509CRLSelector.toString()
返回该 X509CRLSelector 的可打印表示形式。

String

X509CertSelector.toString()
返回该 CertSelector 的可打印表示形式。

String

CertPath.toString()
返回此证书路径的字符串表示形式。

abstract  String

Certificate.toString()
返回此证书的字符串表示形式。

返回变量类型为 String 的类型的 java.security.cert 中的方法

Iterator<String>

CertificateFactorySpi.engineGetCertPathEncodings()
返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。

Iterator<String>

CertificateFactory.getCertPathEncodings()
返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。

Set<String>

X509Extension.getCriticalExtensionOIDs()
获取实现此接口的对象所管理的证书/CRL 中，被标记为 CRITICAL 的扩展的 OID 字符串 Set。

abstract  Iterator<String>

CertPath.getEncodings()
返回此证书路径支持的编码的迭代，默认编码方式优先。

Set<String>

PolicyNode.getExpectedPolicies()
返回预期的策略集，其中的策略将满足下一个要处理证书中此节点的有效策略。

Set<String>

X509CertSelector.getExtendedKeyUsage()
返回 extendedKeyUsage 标准。

List<String>

X509Certificate.getExtendedKeyUsage()
获取一个不可修改的 String 列表，表示已扩展的密钥使用扩展 (OID = 2.5.29.37) 中 ExtKeyUsageSyntax 字段的对象标识符（OBJECT IDENTIFIER）。

Set<String>

PKIXParameters.getInitialPolicies()
返回初始策略标识符（OID 字符串）的不可变 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。

Set<String>

X509Extension.getNonCriticalExtensionOIDs()
获取实现此接口的对象所管理的证书/CRL 中，被标记为 NON-CRITICAL 的扩展的 OID 字符串 Set。

Set<String>

X509CertSelector.getPolicy()
返回策略标准。

abstract  Set<String>

PKIXCertPathChecker.getSupportedExtensions()
返回一个此 PKIXCertPathChecker 支持（也就是识别，即能够处理）的 X.509 证书扩展的不可变的 Set，如果不支持这些扩展，则返回 null。

参数类型为 String 的 java.security.cert 中的方法

void

X509CRLSelector.addIssuerName(String name)
已过时，使用 X509CRLSelector.addIssuer(X500Principal) 或 X509CRLSelector.addIssuerName(byte[]) 替代。

void

X509CertSelector.addPathToName(int type, String name)
向 pathToNames 标准中添加一个名称。

void

X509CertSelector.addSubjectAlternativeName(int type, String name)
向 subjectAlternativeNames 标准中添加一个名称。

CertPath

CertificateFactorySpi.engineGenerateCertPath(InputStream inStream, String encoding)
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。

CertPath

CertificateFactory.generateCertPath(InputStream inStream, String encoding)
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。

abstract  byte[]

CertPath.getEncoded(String encoding)
返回此证书路径的编码形式，使用指定的编码。

byte[]

X509Extension.getExtensionValue(String oid)
获取扩展值 (extnValue) 的 DER 编码 OCTET 字符串，该扩展值由传入的 oid String 标识。

static CertPathBuilder

CertPathBuilder.getInstance(String algorithm)
返回实现了指定算法的 CertPathBuilder 对象。

static CertPathValidator

CertPathValidator.getInstance(String algorithm)
返回实现了指定算法的 CertPathValidator 对象。

static CertificateFactory

CertificateFactory.getInstance(String type)
返回实现指定证书类型的 CertificateFactory 对象。

static CertStore

CertStore.getInstance(String type, CertStoreParameters params)
返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。

static CertStore

CertStore.getInstance(String type, CertStoreParameters params, Provider provider)
返回一个实现指定 CertStore 类型的 CertStore 对象。

static CertStore

CertStore.getInstance(String type, CertStoreParameters params, String provider)
返回一个实现指定 CertStore 类型的 CertStore 对象。

static CertPathBuilder

CertPathBuilder.getInstance(String algorithm, Provider provider)
返回实现了指定算法的 CertPathBuilder 对象。

static CertPathValidator

CertPathValidator.getInstance(String algorithm, Provider provider)
返回实现指定算法的 CertPathValidator 对象。

static CertificateFactory

CertificateFactory.getInstance(String type, Provider provider)
返回指定证书类型的 CertificateFactory 对象。

static CertPathBuilder

CertPathBuilder.getInstance(String algorithm, String provider)
返回实现了指定算法的 CertPathBuilder 对象。

static CertPathValidator

CertPathValidator.getInstance(String algorithm, String provider)
返回实现指定算法的 CertPathValidator 对象。

static CertificateFactory

CertificateFactory.getInstance(String type, String provider)
返回指定证书类型的 CertificateFactory 对象。

void

X509CertSelector.setIssuer(String issuerDN)
已过时，使用 X509CertSelector.setIssuer(X500Principal) 或 X509CertSelector.setIssuer(byte[]) 替代。

void

PKIXParameters.setSigProvider(String sigProvider)
设置签名提供者的名称。

void

X509CertSelector.setSubject(String subjectDN)
已过时，使用 X509CertSelector.setSubject(X500Principal) 或 X509CertSelector.setSubject(byte[]) 替代。

void

X509CertSelector.setSubjectPublicKeyAlgID(String oid)
设置 subjectPublicKeyAlgID 标准。

abstract  void

X509CRL.verify(PublicKey key, String sigProvider)
验证是否已使用与给定公钥相应的私钥签署了此 CRL。

abstract  void

Certificate.verify(PublicKey key, String sigProvider)
验证是否已使用与指定公钥相应的私钥签署了此证书。

类型变量类型为 String 的 java.security.cert 中的方法参数

abstract  void

PKIXCertPathChecker.check(Certificate cert, Collection<String> unresolvedCritExts)
使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。

void

X509CertSelector.setExtendedKeyUsage(Set<String> keyPurposeSet)
设置 extendedKeyUsage 标准。

void

PKIXParameters.setInitialPolicies(Set<String> initialPolicies)
设置初始策略标识符（OID 字符串）的 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。

void

X509CertSelector.setPolicy(Set<String> certPolicySet)
设置策略限制。

参数类型为 String 的 java.security.cert 中的构造方法

Certificate.CertificateRep(String type, byte[] data)
构造带有 Certificate 类型和 Certificate 编码字节的替代 Certificate 类。

Certificate(String type)
创建指定类型的证书。

CertificateEncodingException(String message)
构造带指定详细消息的 CertificateEncodingException。

CertificateEncodingException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateEncodingException。

CertificateException(String msg)
构造带给定详细消息的 Certificate 异常。

CertificateException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateException。

CertificateExpiredException(String message)
构造带指定详细消息的 CertificateExpiredException。

CertificateFactory(CertificateFactorySpi certFacSpi, Provider provider, String type)
创建给定类型的 CertificateFactory 对象，并在其中封装给定的提供者实现（SPI 对象）。

CertificateNotYetValidException(String message)
构造带指定详细消息的 CertificateNotYetValidException。

CertificateParsingException(String message)
构造带指定详细消息的 CertificateParsingException。

CertificateParsingException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateParsingException。

CertPath.CertPathRep(String type, byte[] data)
创建具有指定证书路径类型和编码形式的 CertPathRep。

CertPath(String type)
创建指定类型的 CertPath。

CertPathBuilder(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathBuilder 对象，并在其中封装给定的提供者实现（SPI 对象）。

CertPathBuilderException(String msg)
创建带给定详细消息的 CertPathBuilderException。

CertPathBuilderException(String msg, Throwable cause)
创建带指定详细消息和原因的 CertPathBuilderException。

CertPathValidator(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathValidator 对象，并在其中封装给定的提供者实现（SPI 对象）。

CertPathValidatorException(String msg)
创建带给定详细消息的 CertPathValidatorException。

CertPathValidatorException(String msg, Throwable cause)
创建带指定详细消息和 cause 的 CertPathValidatorException。

CertPathValidatorException(String msg, Throwable cause, CertPath certPath, int index)
创建带指定详细消息、cause、证书路径和索引的 CertPathValidatorException。

CertStore(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。

CertStoreException(String msg)
创建带指定详细消息的 CertStoreException。

CertStoreException(String msg, Throwable cause)
创建带指定详细消息和 cause 的 CertStoreException。

CRL(String type)
创建指定类型的 CRL。

CRLException(String message)
构造带指定详细消息的 CRLException。

CRLException(String message, Throwable cause)
创建带指定详细消息和 cause 的 CRLException。

LDAPCertStoreParameters(String serverName)
创建具有指定服务器名称和默认端口 389 的 LDAPCertStoreParameters 的实例。

LDAPCertStoreParameters(String serverName, int port)
创建具有指定参数值的 LDAPCertStoreParameters 的实例。

TrustAnchor(String caName, PublicKey pubKey, byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以不同的名称和公钥的形式指定最受信任的 CA。

java.security.spec 中 String 的使用

返回 String 的 java.security.spec 中的方法

String

MGF1ParameterSpec.getDigestAlgorithm()
返回掩码生成函数使用的消息摘要的算法名称。

String

PSSParameterSpec.getDigestAlgorithm()
返回消息摘要算法名称。

String

PKCS8EncodedKeySpec.getFormat()
返回与此密钥规范关联的编码格式的名称。

String

X509EncodedKeySpec.getFormat()
返回与此密钥规范关联的编码格式的名称。

abstract  String

EncodedKeySpec.getFormat()
返回与此密钥规范关联的编码格式的名称。

String

PSSParameterSpec.getMGFAlgorithm()
返回掩码生成函数算法名称。

String

ECGenParameterSpec.getName()
返回要生成的 EC 域参数的标准名称或预定义名称。

参数类型为 String 的 java.security.spec 中的构造方法

ECGenParameterSpec(String stdName)
使用标准的（或预定义的）名称 stdName 创建用于 EC 参数生成的参数规范，以便生成相应的（预计算的）椭圆曲线域参数。

InvalidKeySpecException(String msg)
构造带指定详细消息的 InvalidKeySpecException。

InvalidKeySpecException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 InvalidKeySpecException。

InvalidParameterSpecException(String msg)
构造带指定详细消息的 InvalidParameterSpecException。

MGF1ParameterSpec(String mdName)
构造如 PKCS #1 标准中所定义的掩码生成函数 MGF1 的参数集。

PSSParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, int saltLen, int trailerField)
根据 PKCS #1 中的定义，使用指定的消息摘要、掩码生成函数、掩码生成函数的参数、salt 长度和尾部字段值，创建一个新的 PSSParameterSpec。

java.sql 中 String 的使用

声明为 String 的 java.sql 中的字段

String[]

DriverPropertyInfo.choices
如果可以从特定一组值中选择 DriverPropertyInfo.value 字段的值，则返回可能值组成的数组；否则返回 null。

String

DriverPropertyInfo.description
属性的简要描述，可能为 null。

String

DriverPropertyInfo.name
属性的名称。

String

DriverPropertyInfo.value
value 字段通过综合为 getPropertyInfo 方法提供的信息、Java 环境和驱动程序提供的默认值来指定当前属性值。

返回 String 的 java.sql 中的方法

String

Array.getBaseTypeName()
在由此 Array 对象指定的数组中获取元素的 SQL 类型名称。

String

Ref.getBaseTypeName()
获取此 Ref 对象所引用 SQL 结构类型的完全限定的 SQL 名称。

String

Connection.getCatalog()
获取此 Connection 对象的当前目录名称。

String

ResultSetMetaData.getCatalogName(int column)
获取指定列的表目录名称。

String

DatabaseMetaData.getCatalogSeparator()
获取此数据库用作类别和表名之间的分隔符的 String。

String

DatabaseMetaData.getCatalogTerm()
获取数据库供应商用于 "catalog" 的首选术语。

String

Connection.getClientInfo(String name)
返回通过名称指定的客户端信息属性的值。

String

ResultSetMetaData.getColumnClassName(int column)
如果调用方法 ResultSet.getObject 从列中获取值，则返回构造其实例的 Java 类的完全限定名称。

String

ResultSetMetaData.getColumnLabel(int column)
获取用于打印输出和显示的指定列的建议标题。

String

ResultSetMetaData.getColumnName(int column)
获取指定列的名称。

String

ResultSetMetaData.getColumnTypeName(int column)
获取指定列的数据库特定的类型名称。

String

ResultSet.getCursorName()
获取此 ResultSet 对象使用的 SQL 光标的名称。

String

DatabaseMetaData.getDatabaseProductName()
获取此数据库产品的名称。

String

DatabaseMetaData.getDatabaseProductVersion()
获取此数据库产品的版本号。

String

DatabaseMetaData.getDriverName()
获取此 JDBC 驱动程序的名称。

String

DatabaseMetaData.getDriverVersion()
获取此 JDBC 驱动程序的 String 形式的版本号。

String

DatabaseMetaData.getExtraNameCharacters()
获取可以在不带引号的标识符名称中使用的所有“额外”字符（除了 a-z、A-Z、0-9 和 _ 以外的字符）。

String

DatabaseMetaData.getIdentifierQuoteString()
获取用于引用 SQL 标识符的字符串。

String

CallableStatement.getNString(int parameterIndex)
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。

String

ResultSet.getNString(int columnIndex)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

String

CallableStatement.getNString(String parameterName)
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。

String

ResultSet.getNString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

String

DatabaseMetaData.getNumericFunctions()
获取可用于此数据库的数学函数的逗号分隔列表。

String

ParameterMetaData.getParameterClassName(int param)
获取 Java 类的完全限定名称，该类的实例应该传递给 PreparedStatement.setObject 方法。

String

ParameterMetaData.getParameterTypeName(int param)
获取指定参数的特定于数据库的类型名称。

String

DatabaseMetaData.getProcedureTerm()
获取数据库供应商用于 "procedure" 的首选术语。

String

Savepoint.getSavepointName()
获取此 Savepoint 对象表示的保存点的名称。

String

ResultSetMetaData.getSchemaName(int column)
获取指定列的表模式。

String

DatabaseMetaData.getSchemaTerm()
获取数据库供应商用于 "schema" 的首选术语。

String

DatabaseMetaData.getSearchStringEscape()
获取可用于转义通配符的字符串。

String

DatabaseMetaData.getSQLKeywords()
获取此数据库的还“不”是 SQL:2003 关键字的所有 SQL 关键字的逗号分隔列表。

String

SQLException.getSQLState()
获取此 SQLException 对象的 SQLState。

String

SQLData.getSQLTypeName()
返回此对象表示的 SQL 用户定义类型的完全限定名。

String

Struct.getSQLTypeName()
获取此 Struct 对象所表示 SQL 结构的完全限定的 SQL 名称。

String

SQLXML.getString()
返回此 SQLXML 实例指定的 XML 值的字符串表示形式。

String

CallableStatement.getString(int parameterIndex)
以 Java 编程语言中 String 的形式获取指定的 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。

String

ResultSet.getString(int columnIndex)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

String

CallableStatement.getString(String parameterName)
以 Java 编程语言中 String 的形式获取 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。

String

ResultSet.getString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

String

DatabaseMetaData.getStringFunctions()
获取可用于此数据库的字符串函数的逗号分隔列表。

String

Clob.getSubString(long pos, int length)
获取此 Clob 对象指定的 CLOB 值中指定子字符串的副本。

String

DatabaseMetaData.getSystemFunctions()
获取可用于此数据库的系统函数的逗号分隔列表。

String

ResultSetMetaData.getTableName(int column)
获取指定列的名称。

String

DatabaseMetaData.getTimeDateFunctions()
获取可用于此数据库的时间和日期函数的逗号分隔列表。

String

DatabaseMetaData.getURL()
获取此 DBMS 的 URL。

String

DatabaseMetaData.getUserName()
获取此数据库的已知的用户名称。

String

Connection.nativeSQL(String sql)
将给定的 SQL 语句转换成系统本机 SQL 语法。

String

SQLInput.readNString()
读取流中的下一个属性，并以 Java 编程语言中 String 的形式返回。

String

SQLInput.readString()
读取流中的下一个属性并将其作为 Java 编程语言中的 String 返回。

String

Date.toString()
格式化日期转义形式 yyyy-mm-dd 的日期。

String

RowId.toString()
返回表示此 java.sql.RowId 对象指定的 SQL ROWID 值的 String。

String

Time.toString()
使用 JDBC 时间转义格式对时间进行格式化。

String

Timestamp.toString()
使用 JDBC 时间戳转义格式编排时间戳。

返回变量类型为 String 的类型的 java.sql 中的方法

Map<String,ClientInfoStatus>

SQLClientInfoException.getFailedProperties()
返回无法设置的客户端信息属性列表。

Map<String,Class<?>>

Connection.getTypeMap()
获取与此 Connection 对象关联的 Map 对象。

参数类型为 String 的 java.sql 中的方法

boolean

Driver.acceptsURL(String url)
查询驱动程序是否认为它可以打开到给定 URL 的连接。

void

Statement.addBatch(String sql)
将给定的 SQL 命令添加到此 Statement 对象的当前命令列表中。

Connection

Driver.connect(String url, Properties info)
试图创建一个到给定 URL 的数据库连接。

Array

Connection.createArrayOf(String typeName, Object[] elements)
创建 Array 对象的工厂方法。

Struct

Connection.createStruct(String typeName, Object[] attributes)
创建 Struct 对象的工厂方法。

boolean

Statement.execute(String sql)
执行给定的 SQL 语句，该语句可能返回多个结果。

boolean

Statement.execute(String sql, int autoGeneratedKeys)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序所有自动生成的键都应该可用于获取。

boolean

Statement.execute(String sql, int[] columnIndexes)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

boolean

Statement.execute(String sql, String[] columnNames)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

boolean

Statement.execute(String sql, String[] columnNames)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

ResultSet

Statement.executeQuery(String sql)
执行给定的 SQL 语句，该语句返回单个 ResultSet 对象。

int

Statement.executeUpdate(String sql)
执行给定 SQL 语句，该语句可能为 INSERT、UPDATE 或 DELETE 语句，或者不返回任何内容的 SQL 语句（如 SQL DDL 语句）。

int

Statement.executeUpdate(String sql, int autoGeneratedKeys)
执行给定的 SQL 语句，并用给定标志通知驱动程序由此 Statement 生成的自动生成键是否可用于获取。

int

Statement.executeUpdate(String sql, int[] columnIndexes)
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

int

Statement.executeUpdate(String sql, String[] columnNames)
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

int

Statement.executeUpdate(String sql, String[] columnNames)
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

int

ResultSet.findColumn(String columnLabel)
将给定的 ResultSet 列标签映射到其 ResultSet 列索引。

Array

CallableStatement.getArray(String parameterName)
以 Java 编程语言中 java.sql.ARRAY 对象的形式获取 JDBC ARRAY 参数的值。

Array

ResultSet.getArray(String columnLabel)
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

InputStream

ResultSet.getAsciiStream(String columnLabel)
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getAttributes(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern)
获取可在给定模式和类别中使用的用户定义类型 (UDT) 的给定类型的给定属性的描述。

ResultSet

DatabaseMetaData.getBestRowIdentifier(String catalog, String schema, String table, int scope, boolean nullable)
获取唯一标识行的表的最佳列集合的描述。

BigDecimal

CallableStatement.getBigDecimal(String parameterName)
以 java.math.BigDecimal 对象的形式获取 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。

BigDecimal

ResultSet.getBigDecimal(String columnLabel)
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。

BigDecimal

ResultSet.getBigDecimal(String columnLabel, int scale)
已过时。

InputStream

ResultSet.getBinaryStream(String columnLabel)
以未解释的 byte 流的形式获取此 ResultSet 对象的当前行中指定列的值。

Blob

CallableStatement.getBlob(String parameterName)
以 Java 编程语言中 Blob 对象的形式获取 JDBC BLOB 参数的值。

Blob

ResultSet.getBlob(String columnLabel)
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

boolean

CallableStatement.getBoolean(String parameterName)
以 Java 编程语言中 boolean 值的形式获取 JDBC BIT 或 BOOLEAN 参数的值。

boolean

ResultSet.getBoolean(String columnLabel)
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。

byte

CallableStatement.getByte(String parameterName)
以 Java 编程语言中 byte 值的形式获取 JDBC TINYINT 参数的值。

byte

ResultSet.getByte(String columnLabel)
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。

byte[]

CallableStatement.getBytes(String parameterName)
以 Java 编程语言中 byte 数组值的形式获取 JDBC BINARY 或 VARBINARY 参数的值。

byte[]

ResultSet.getBytes(String columnLabel)
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。

Reader

CallableStatement.getCharacterStream(String parameterName)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。

Reader

ResultSet.getCharacterStream(String columnLabel)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

String

Connection.getClientInfo(String name)
返回通过名称指定的客户端信息属性的值。

Clob

CallableStatement.getClob(String parameterName)
以 Java 编程语言中 java.sql.CLOB 对象的形式获取 JDBC CLOB 参数的值。

Clob

ResultSet.getClob(String columnLabel)
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getColumnPrivileges(String catalog, String schema, String table, String columnNamePattern)
获取用于表列的访问权的描述。

ResultSet

DatabaseMetaData.getColumns(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)
获取可在指定类别中使用的表列的描述。

static Connection

DriverManager.getConnection(String url)
试图建立到给定数据库 URL 的连接。

static Connection

DriverManager.getConnection(String url, Properties info)
试图建立到给定数据库 URL 的连接。

static Connection

DriverManager.getConnection(String url, String user, String password)
试图建立到给定数据库 URL 的连接。

ResultSet

DatabaseMetaData.getCrossReference(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable)
获取给定外键列表中外键列的描述，这些列引用主键或表示父表（可能是相同的表，也可能是不同的表）唯一约束的列。

Date

CallableStatement.getDate(String parameterName)
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值。

Date

ResultSet.getDate(String columnLabel)
以 Java 编程语言中的 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

Date

CallableStatement.getDate(String parameterName, Calendar cal)
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。

Date

ResultSet.getDate(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

double

CallableStatement.getDouble(String parameterName)
以 Java 编程语言中 double 值的形式获取 JDBC DOUBLE 参数的值。

double

ResultSet.getDouble(String columnLabel)
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。

static Driver

DriverManager.getDriver(String url)
试图查找能理解给定 URL 的驱动程序。

ResultSet

DatabaseMetaData.getExportedKeys(String catalog, String schema, String table)
获取引用给定表的主键列（表导入的外键）的外键列的描述。

float

CallableStatement.getFloat(String parameterName)
以 Java 编程语言中 float 值的形式获取 JDBC FLOAT 参数的值。

float

ResultSet.getFloat(String columnLabel)
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getFunctionColumns(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern)
获取给定类别的系统或用户函数参数和返回类型的描述。

ResultSet

DatabaseMetaData.getFunctions(String catalog, String schemaPattern, String functionNamePattern)
获取给定类别中可用的系统和用户函数的描述。

ResultSet

DatabaseMetaData.getImportedKeys(String catalog, String schema, String table)
获取由给定表的外键列（表导入的主键）引用的主键列的描述。

ResultSet

DatabaseMetaData.getIndexInfo(String catalog, String schema, String table, boolean unique, boolean approximate)
获取给定表的索引和统计信息的描述。

int

CallableStatement.getInt(String parameterName)
以 Java 编程语言中 int 值的形式获取 JDBC INTEGER 参数的值。

int

ResultSet.getInt(String columnLabel)
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。

long

CallableStatement.getLong(String parameterName)
以 Java 编程语言中 long 值的形式获取 JDBC BIGINT 参数的值。

long

ResultSet.getLong(String columnLabel)
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。

Reader

CallableStatement.getNCharacterStream(String parameterName)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。

Reader

ResultSet.getNCharacterStream(String columnLabel)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

NClob

CallableStatement.getNClob(String parameterName)
以 Java 编程语言中 java.sql.NClob 对象的形式获取 JDBC NCLOB 参数的值。

NClob

ResultSet.getNClob(String columnLabel)
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

String

CallableStatement.getNString(String parameterName)
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。

String

ResultSet.getNString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

CallableStatement.getObject(String parameterName)
以 Java 编程语言中 Object 的形式获取参数的值。

Object

ResultSet.getObject(String columnLabel)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

CallableStatement.getObject(String parameterName, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。

Object

ResultSet.getObject(String columnLabel, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getPrimaryKeys(String catalog, String schema, String table)
获取对给定表的主键列的描述。

ResultSet

DatabaseMetaData.getProcedureColumns(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern)
获取给定类别的存储过程参数和结果列的描述。

ResultSet

DatabaseMetaData.getProcedures(String catalog, String schemaPattern, String procedureNamePattern)
获取可在给定类别中使用的存储过程的描述。

DriverPropertyInfo[]

Driver.getPropertyInfo(String url, Properties info)
获得此驱动程序的可能属性信息。

Ref

CallableStatement.getRef(String parameterName)
以 Java 编程语言中 Ref 对象的形式获取 JDBC REF(<structured-type>) 参数的值。

Ref

ResultSet.getRef(String columnLabel)
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

RowId

CallableStatement.getRowId(String parameterName)
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。

RowId

ResultSet.getRowId(String columnLabel)
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getSchemas(String catalog, String schemaPattern)
获取此数据库中可用的模式名称。

short

CallableStatement.getShort(String parameterName)
以 Java 编程语言中 short 值的形式获取 JDBC SMALLINT 参数的值。

short

ResultSet.getShort(String columnLabel)
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。

SQLXML

CallableStatement.getSQLXML(String parameterName)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。

SQLXML

ResultSet.getSQLXML(String columnLabel)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

String

CallableStatement.getString(String parameterName)
以 Java 编程语言中 String 的形式获取 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。

String

ResultSet.getString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getSuperTables(String catalog, String schemaPattern, String tableNamePattern)
获取在此数据库的特定模式中定义的表分层结构的描述。

ResultSet

DatabaseMetaData.getSuperTypes(String catalog, String schemaPattern, String typeNamePattern)
获取在此数据库的特定模式中定义的用户定义类型 (UDT) 分层结构的描述。

ResultSet

DatabaseMetaData.getTablePrivileges(String catalog, String schemaPattern, String tableNamePattern)
获取可在类别中使用的每个表的访问权的描述。

ResultSet

DatabaseMetaData.getTables(String catalog, String schemaPattern, String tableNamePattern, String[] types)
获取可在给定类别中使用的表的描述。

ResultSet

DatabaseMetaData.getTables(String catalog, String schemaPattern, String tableNamePattern, String[] types)
获取可在给定类别中使用的表的描述。

Time

CallableStatement.getTime(String parameterName)
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值。

Time

ResultSet.getTime(String columnLabel)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

Time

CallableStatement.getTime(String parameterName, Calendar cal)
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。

Time

ResultSet.getTime(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

Timestamp

CallableStatement.getTimestamp(String parameterName)
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值。

Timestamp

ResultSet.getTimestamp(String columnLabel)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

Timestamp

CallableStatement.getTimestamp(String parameterName, Calendar cal)
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。

Timestamp

ResultSet.getTimestamp(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getUDTs(String catalog, String schemaPattern, String typeNamePattern, int[] types)
获取在特定模式中定义的用户定义类型 (UDT) 的描述。

InputStream

ResultSet.getUnicodeStream(String columnLabel)
已过时。 使用 getCharacterStream 代替

URL

CallableStatement.getURL(String parameterName)
以 java.net.URL 对象的形式获取 JDBC DATALINK 参数的值。

URL

ResultSet.getURL(String columnLabel)
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getVersionColumns(String catalog, String schema, String table)
获取在更新行中的任意值时自动更新的表列的描述。

String

Connection.nativeSQL(String sql)
将给定的 SQL 语句转换成系统本机 SQL 语法。

long

Clob.position(String searchstr, long start)
获取此 Clob 对象表示的 SQL CLOB 值中指定子字符串 searchstr 出现的字符位置。

CallableStatement

Connection.prepareCall(String sql)
创建一个 CallableStatement 对象来调用数据库存储过程。

CallableStatement

Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency)
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。

CallableStatement

Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。

PreparedStatement

Connection.prepareStatement(String sql)
创建一个 PreparedStatement 对象来将参数化的 SQL 语句发送到数据库。

PreparedStatement

Connection.prepareStatement(String sql, int autoGeneratedKeys)
创建一个默认 PreparedStatement 对象，该对象能获取自动生成的键。

PreparedStatement

Connection.prepareStatement(String sql, int[] columnIndexes)
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。

PreparedStatement

Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency)
创建一个 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。

PreparedStatement

Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
创建一个 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。

PreparedStatement

Connection.prepareStatement(String sql, String[] columnNames)
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。

PreparedStatement

Connection.prepareStatement(String sql, String[] columnNames)
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。

static void

DriverManager.println(String message)
将一条消息打印到当前 JDBC 日志流中。

void

SQLData.readSQL(SQLInput stream, String typeName)
用从数据库读取的数据填充此对象。

void

CallableStatement.registerOutParameter(int parameterIndex, int sqlType, String typeName)
注册指定的输出参数。

void

CallableStatement.registerOutParameter(String parameterName, int sqlType)
将名为 parameterName 的 OUT 参数注册为 JDBC 类型 sqlType。

void

CallableStatement.registerOutParameter(String parameterName, int sqlType, int scale)
将名为 parameterName 的参数注册为 JDBC 类型 sqlType。

void

CallableStatement.registerOutParameter(String parameterName, int sqlType, String typeName)
注册指定的输出参数。

void

CallableStatement.setAsciiStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。

void

CallableStatement.setAsciiStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。

void

CallableStatement.setAsciiStream(String parameterName, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。

void

CallableStatement.setBigDecimal(String parameterName, BigDecimal x)
将指定参数设置为给定 java.math.BigDecimal 值。

void

CallableStatement.setBinaryStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。

void

CallableStatement.setBinaryStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。

void

CallableStatement.setBinaryStream(String parameterName, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将拥有指定字节数。

void

CallableStatement.setBlob(String parameterName, Blob x)
将指定参数设置为给定的 java.sql.Blob 对象。

void

CallableStatement.setBlob(String parameterName, InputStream inputStream)
将指定参数设置为 InputStream 对象。

void

CallableStatement.setBlob(String parameterName, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。

void

CallableStatement.setBoolean(String parameterName, boolean x)
将指定参数设置为给定 Java boolean 值。

void

CallableStatement.setByte(String parameterName, byte x)
将指定参数设置为给定 Java byte 值。

void

CallableStatement.setBytes(String parameterName, byte[] x)
将指定参数设置为给定 Java byte 数组。

void

Connection.setCatalog(String catalog)
设置给定目录名称，以便选择要在其中进行工作的此 Connection 对象数据库的子空间。

void

CallableStatement.setCharacterStream(String parameterName, Reader reader)
将指定参数设置为给定 Reader 对象。

void

CallableStatement.setCharacterStream(String parameterName, Reader reader, int length)
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数。

void

CallableStatement.setCharacterStream(String parameterName, Reader reader, long length)
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。

void

Connection.setClientInfo(String name, String value)
将 name 指定的客户端信息属性的值设置为 value 指定的值。

void

CallableStatement.setClob(String parameterName, Clob x)
将指定参数设置为给定的 java.sql.Clob 对象。

void

CallableStatement.setClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

CallableStatement.setClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

Statement.setCursorName(String name)
将 SQL 指针名称设置为给定的 String，后续 Statement 对象的 execute 方法将使用此字符串。

void

CallableStatement.setDate(String parameterName, Date x)
使用运行应用程序的虚拟机默认时区将指定参数设置为给定 java.sql.Date 值。

void

CallableStatement.setDate(String parameterName, Date x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。

void

CallableStatement.setDouble(String parameterName, double x)
将指定参数设置为给定 Java double 值。

void

CallableStatement.setFloat(String parameterName, float x)
将指定参数设置为给定 Java float 值。

void

CallableStatement.setInt(String parameterName, int x)
将指定参数设置为给定 Java int 值。

void

CallableStatement.setLong(String parameterName, long x)
将指定参数设置为给定 Java long 值。

void

CallableStatement.setNCharacterStream(String parameterName, Reader value)
将指定参数设置为 Reader 对象。

void

CallableStatement.setNCharacterStream(String parameterName, Reader value, long length)
将指定参数设置为 Reader 对象。

void

CallableStatement.setNClob(String parameterName, NClob value)
将指定参数设置为 java.sql.NClob 对象。

void

CallableStatement.setNClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

CallableStatement.setNClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

PreparedStatement.setNString(int parameterIndex, String value)
将指定参数设置为给定 String 对象。

void

CallableStatement.setNString(String parameterName, String value)
将指定参数设置为给定 String 对象。

void

PreparedStatement.setNull(int parameterIndex, int sqlType, String typeName)
将指定参数设置为 SQL NULL。

void

CallableStatement.setNull(String parameterName, int sqlType)
将指定参数设置为 SQL NULL。

void

CallableStatement.setNull(String parameterName, int sqlType, String typeName)
将指定参数设置为 SQL NULL。

void

CallableStatement.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

CallableStatement.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

CallableStatement.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

void

CallableStatement.setRowId(String parameterName, RowId x)
将指定参数设置为给定 java.sql.RowId 对象。

Savepoint

Connection.setSavepoint(String name)
在当前事务中创建一个具有给定名称的保存点，并返回表示它的新 Savepoint 对象。

void

CallableStatement.setShort(String parameterName, short x)
将指定参数设置为给定 Java short 值。

void

CallableStatement.setSQLXML(String parameterName, SQLXML xmlObject)
将指定参数设置为给定 java.sql.SQLXML 对象。

void

PreparedStatement.setString(int parameterIndex, String x)
将指定参数设置为给定 Java String 值。

int

Clob.setString(long pos, String str)
在位置 pos 处将给定 Java String 写入此 Clob 对象指定的 CLOB 值中。

int

Clob.setString(long pos, String str, int offset, int len)
将 str 的 len 个字符（从字符 offset 开始）写入此 Clob 表示的 CLOB 值中。

void

SQLXML.setString(String value)
将此 SQLXML 实例指定的 XML 值设置为给定的 String 表示形式。

void

CallableStatement.setString(String parameterName, String x)
将指定参数设置为给定 Java String 值。

void

CallableStatement.setTime(String parameterName, Time x)
将指定参数设置为给定 java.sql.Time 值。

void

CallableStatement.setTime(String parameterName, Time x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。

void

CallableStatement.setTimestamp(String parameterName, Timestamp x)
将指定参数设置为给定 java.sql.Timestamp 值。

void

CallableStatement.setTimestamp(String parameterName, Timestamp x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。

void

CallableStatement.setURL(String parameterName, URL val)
将指定参数设置为给定 java.net.URL 对象。

void

ResultSet.updateArray(String columnLabel, Array x)
用 java.sql.Array 值更新指定列。

void

ResultSet.updateAsciiStream(String columnLabel, InputStream x)
用 ascii 流值更新指定列。

void

ResultSet.updateAsciiStream(String columnLabel, InputStream x, int length)
用 ascii 流值更新指定列，该列具有指定的字节数。

void

ResultSet.updateAsciiStream(String columnLabel, InputStream x, long length)
用 ascii 流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateBigDecimal(String columnLabel, BigDecimal x)
用 java.sql.BigDecimal 值更新指定列。

void

ResultSet.updateBinaryStream(String columnLabel, InputStream x)
用二进制流值更新指定列。

void

ResultSet.updateBinaryStream(String columnLabel, InputStream x, int length)
用二进制流值更新指定列，该列具有指定的字节数。

void

ResultSet.updateBinaryStream(String columnLabel, InputStream x, long length)
用二进制流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateBlob(String columnLabel, Blob x)
用 java.sql.Blob 值更新指定列。

void

ResultSet.updateBlob(String columnLabel, InputStream inputStream)
使用给定输入流值更新指定列。

void

ResultSet.updateBlob(String columnLabel, InputStream inputStream, long length)
使用给定输入流更新指定列，该流将具有指定的字节数。

void

ResultSet.updateBoolean(String columnLabel, boolean x)
用 boolean 值更新指定列。

void

ResultSet.updateByte(String columnLabel, byte x)
用 byte 值更新指定列。

void

ResultSet.updateBytes(String columnLabel, byte[] x)
用字节数组值更新指定列。

void

ResultSet.updateCharacterStream(String columnLabel, Reader reader)
用字符流值更新指定列。

void

ResultSet.updateCharacterStream(String columnLabel, Reader reader, int length)
用字符流值更新指定列，该列具有指定的字节数。

void

ResultSet.updateCharacterStream(String columnLabel, Reader reader, long length)
用字符流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateClob(String columnLabel, Clob x)
用 java.sql.Clob 值更新指定列。

void

ResultSet.updateClob(String columnLabel, Reader reader)
使用给定的 Reader 对象更新指定列。

void

ResultSet.updateClob(String columnLabel, Reader reader, long length)
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。

void

ResultSet.updateDate(String columnLabel, Date x)
用 java.sql.Date 值更新指定列。

void

ResultSet.updateDouble(String columnLabel, double x)
用 double 值更新指定列。

void

ResultSet.updateFloat(String columnLabel, float x)
用 float 值更新指定列。

void

ResultSet.updateInt(String columnLabel, int x)
用 int 值更新指定列。

void

ResultSet.updateLong(String columnLabel, long x)
用 long 值更新指定列。

void

ResultSet.updateNCharacterStream(String columnLabel, Reader reader)
用字符流值更新指定的列。

void

ResultSet.updateNCharacterStream(String columnLabel, Reader reader, long length)
用字符流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateNClob(String columnLabel, NClob nClob)
用 java.sql.NClob 值更新指定的列。

void

ResultSet.updateNClob(String columnLabel, Reader reader)
使用给定的 Reader 对象更新指定列。

void

ResultSet.updateNClob(String columnLabel, Reader reader, long length)
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。

void

ResultSet.updateNString(int columnIndex, String nString)
用 String 值更新指定的列。

void

ResultSet.updateNString(String columnLabel, String nString)
用 String 值更新指定的列。

void

ResultSet.updateNull(String columnLabel)
用 null 值更新指定列。

void

ResultSet.updateObject(String columnLabel, Object x)
用 Object 值更新指定列。

void

ResultSet.updateObject(String columnLabel, Object x, int scaleOrLength)
用 Object 值更新指定列。

void

ResultSet.updateRef(String columnLabel, Ref x)
用 java.sql.Ref 值更新指定列。

void

ResultSet.updateRowId(String columnLabel, RowId x)
用 RowId 值更新指定的列。

void

ResultSet.updateShort(String columnLabel, short x)
用 short 值更新指定列。

void

ResultSet.updateSQLXML(String columnLabel, SQLXML xmlObject)
用 java.sql.SQLXML 值更新指定的列。

void

ResultSet.updateString(int columnIndex, String x)
用 String 值更新指定列。

void

ResultSet.updateString(String columnLabel, String x)
用 String 值更新指定列。

void

ResultSet.updateTime(String columnLabel, Time x)
用 java.sql.Time 值更新指定列。

void

ResultSet.updateTimestamp(String columnLabel, Timestamp x)
用 java.sql.Timestamp 值更新指定列。

static ClientInfoStatus

ClientInfoStatus.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Date

Date.valueOf(String s)
将 JDBC 日期转义形式的字符串转换成 Date 值。

static RowIdLifetime

RowIdLifetime.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Time

Time.valueOf(String s)
将使用 JDBC 时间转义格式的字符串转换为 Time 值。

static Timestamp

Timestamp.valueOf(String s)
将使用 JDBC 时间戳转义格式的 String 对象转换为 Timestamp 值。

void

SQLOutput.writeNString(String x)
将下一个属性以 Java 编程语言中 String 的形式写入流中。

void

SQLOutput.writeString(String x)
将下一个属性作为 Java 编程语言中的 String 写入流中。

类型变量类型为 String 的 java.sql 中的方法参数

Object

Array.getArray(long index, int count, Map<String,Class<?>> map)
获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。

Object

Array.getArray(Map<String,Class<?>> map)
获取由此 Array 对象指定的 SQL ARRAY 值的内容。

Object[]

Struct.getAttributes(Map<String,Class<?>> map)
生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。

Object

CallableStatement.getObject(int parameterIndex, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。

Object

ResultSet.getObject(int columnIndex, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

Ref.getObject(Map<String,Class<?>> map)
获取引用对象并使用给定类型映射表将其映射到 Java 类型。

Object

CallableStatement.getObject(String parameterName, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。

Object

ResultSet.getObject(String columnLabel, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

Array.getResultSet(long index, int count, Map<String,Class<?>> map)
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。

ResultSet

Array.getResultSet(Map<String,Class<?>> map)
获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。

void

Connection.setTypeMap(Map<String,Class<?>> map)
将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。

参数类型为 String 的 java.sql 中的构造方法

BatchUpdateException(String reason, int[] updateCounts)
构造一个使用给定 reason 和 updateCounts 初始化的 BatchUpdateException 对象。

BatchUpdateException(String reason, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、cause 和 updateCounts 构造的 BatchUpdateException 对象。

BatchUpdateException(String reason, String SQLState, int[] updateCounts)
构造一个使用给定 reason、SQLState 和 updateCounts 初始化的 BatchUpdateException 对象。

BatchUpdateException(String reason, String SQLState, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 updateCounts 初始化的 BatchUpdateException 对象。

BatchUpdateException(String reason, String SQLState, int vendorCode, int[] updateCounts)
构造一个使用给定 reason、SQLState、vendorCode 和 updateCounts 初始化的 BatchUpdateException 对象。

BatchUpdateException(String reason, String SQLState, int vendorCode, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、SQLState、vendorCode、cause 和 updateCounts 初始化的 BatchUpdateException 对象。

DriverPropertyInfo(String name, String value)
构造一个带有给定名称和值的 DriverPropertyInfo 对象。

SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLDataException(String reason)
构造一个带有给定 reason 的 SQLDataException 对象。

SQLDataException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLDataException 对象。

SQLDataException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLDataException 对象。

SQLDataException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLDataException 对象。

SQLDataException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLDataException 对象。

SQLDataException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLDataException 对象。

SQLException(String reason)
构造一个具有给定 reason 的 SQLException 对象。

SQLException(String reason, String SQLState)
构造一个具有给定 reason 和 SQLState 的 SQLException 对象。

SQLException(String reason, String SQLState, int vendorCode)
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLException 对象。

SQLException(String reason, String sqlState, int vendorCode, Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLException 对象。

SQLException(String reason, String sqlState, Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLException 对象。

SQLException(String reason, Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLException 对象。

SQLFeatureNotSupportedException(String reason)
构造一个带有给定 reason 的 SQLFeatureNotSupportedException 对象。

SQLFeatureNotSupportedException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLFeatureNotSupportedException 对象。

SQLFeatureNotSupportedException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLFeatureNotSupportedException 对象。

SQLFeatureNotSupportedException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLFeatureNotSupportedException 对象。

SQLFeatureNotSupportedException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLFeatureNotSupportedException 对象。

SQLFeatureNotSupportedException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLFeatureNotSupportedException 对象。

SQLIntegrityConstraintViolationException(String reason)
构造一个带有给定 reason 的 SQLIntegrityConstraintViolationException。

SQLIntegrityConstraintViolationException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLIntegrityConstraintViolationException 对象。

SQLIntegrityConstraintViolationException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLIntegrityConstraintViolationException 对象。

SQLIntegrityConstraintViolationException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLIntegrityConstraintViolationException 对象。

SQLIntegrityConstraintViolationException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLIntegrityConstraintViolationException 对象。

SQLIntegrityConstraintViolationException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLIntegrityConstraintViolationException 对象。

SQLInvalidAuthorizationSpecException(String reason)
构造一个带有给定 reason 的 SQLInvalidAuthorizationSpecException 对象。

SQLInvalidAuthorizationSpecException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLInvalidAuthorizationSpecException 对象。

SQLInvalidAuthorizationSpecException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLInvalidAuthorizationSpecException 对象。

SQLInvalidAuthorizationSpecException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLInvalidAuthorizationSpecException 对象。

SQLInvalidAuthorizationSpecException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLInvalidAuthorizationSpecException 对象。

SQLInvalidAuthorizationSpecException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLInvalidAuthorizationSpecException 对象。

SQLNonTransientConnectionException(String reason)
构造一个带有给定 reason 的 SQLNonTransientConnectionException 对象。

SQLNonTransientConnectionException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientConnectionException 对象。

SQLNonTransientConnectionException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientConnectionException 对象。

SQLNonTransientConnectionException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientConnectionException 对象。

SQLNonTransientConnectionException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientConnectionException 对象。

SQLNonTransientConnectionException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。

SQLNonTransientException(String reason)
构造一个带有给定 reason 的 SQLNonTransientException 对象。

SQLNonTransientException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientException 对象。

SQLNonTransientException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientException 对象。

SQLNonTransientException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientException 对象。

SQLNonTransientException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientException 对象。

SQLNonTransientException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。

SQLPermission(String name)
创建具有指定名称的新 SQLPermission 对象。

SQLPermission(String name, String actions)
创建具有指定名称的新 SQLPermission 对象。

SQLRecoverableException(String reason)
构造一个带有给定 reason 的 SQLRecoverableException 对象。

SQLRecoverableException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLRecoverableException 对象。

SQLRecoverableException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLRecoverableException 对象。

SQLRecoverableException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLRecoverableException 对象。

SQLRecoverableException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLRecoverableException 对象。

SQLRecoverableException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLRecoverableException 对象。

SQLSyntaxErrorException(String reason)
构造一个带有给定 reason 的 SQLSyntaxErrorException 对象。

SQLSyntaxErrorException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLSyntaxErrorException 对象。

SQLSyntaxErrorException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLSyntaxErrorException 对象。

SQLSyntaxErrorException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLSyntaxErrorException 对象。

SQLSyntaxErrorException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLSyntaxErrorException 对象。

SQLSyntaxErrorException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLSyntaxErrorException 对象。

SQLTimeoutException(String reason)
构造一个带有给定 reason 的 SQLTimeoutException 对象。

SQLTimeoutException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTimeoutException 对象。

SQLTimeoutException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTimeoutException 对象。

SQLTimeoutException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTimeoutException 对象。

SQLTimeoutException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTimeoutException 对象。

SQLTimeoutException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTimeoutException 对象。

SQLTransactionRollbackException(String reason)
构造一个带有给定 reason 的 SQLTransactionRollbackException 对象。

SQLTransactionRollbackException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransactionRollbackException 对象。

SQLTransactionRollbackException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransactionRollbackException 对象。

SQLTransactionRollbackException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransactionRollbackException 对象。

SQLTransactionRollbackException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransactionRollbackException 对象。

SQLTransactionRollbackException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransactionRollbackException 对象。

SQLTransientConnectionException(String reason)
构造一个带有给定 reason 的 SQLTransientConnectionException 对象。

SQLTransientConnectionException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransientConnectionException 对象。

SQLTransientConnectionException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientConnectionException 对象。

SQLTransientConnectionException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientConnectionException 对象。

SQLTransientConnectionException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientConnectionException 对象。

SQLTransientConnectionException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientConnectionException 对象。

SQLTransientException(String reason)
构造一个带有给定 reason 的 SQLTransientException 对象。

SQLTransientException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransientException 对象。

SQLTransientException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientException 对象。

SQLTransientException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientException 对象。

SQLTransientException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientException 对象。

SQLTransientException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。

SQLWarning(String reason)
构造一个具有给定 reason 的 SQLWarning 对象。

SQLWarning(String reason, String SQLState)
构造一个具有给定 reason 和 SQLState 的 SQLWarning 对象。

SQLWarning(String reason, String SQLState, int vendorCode)
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLWarning 对象。

SQLWarning(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLWarning 对象。

SQLWarning(String reason, String SQLState, Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLWarning 对象。

SQLWarning(String reason, Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLWarning 对象。

类型变量类型为 String 的 java.sql 中的构造方法参数

SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

java.text 中 String 的使用

返回 String 的 java.text 中的方法

String

DateFormat.format(Date date)
将一个 Date 格式化为日期/时间字符串。

String

NumberFormat.format(double number)
格式规范。

String

NumberFormat.format(long number)
格式规范。

String

Format.format(Object obj)
格式化一个对象以生成一个字符串。

static String

MessageFormat.format(String pattern, Object... arguments)
创建具有给定模式的 MessageFormat，并用它来格式化给定的参数。

String[]

DateFormatSymbols.getAmPmStrings()
获取 ampm 字符串。

String

DecimalFormatSymbols.getCurrencySymbol()
返回这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。

String[]

DateFormatSymbols.getEras()
获取年代字符串。

String

DecimalFormatSymbols.getExponentSeparator()
返回用于分隔尾数和指数的字符串。

String

DecimalFormatSymbols.getInfinity()
获得用于表示无穷大的字符串。

String

DecimalFormatSymbols.getInternationalCurrencySymbol()
返回这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。

String

DateFormatSymbols.getLocalPatternChars()
获取本地化的日期-时间模式字符。

String[]

DateFormatSymbols.getMonths()
获取月份字符串。

protected  String

AttributedCharacterIterator.Attribute.getName()
返回此属性的名称。

String

DecimalFormatSymbols.getNaN()
获得用于表示“非数字”的字符串。

String

DecimalFormat.getNegativePrefix()
获取负数前缀。

String

DecimalFormat.getNegativeSuffix()
获取负数后缀。

String

DecimalFormat.getPositivePrefix()
获取正数前缀。

String

DecimalFormat.getPositiveSuffix()
获取正数后缀。

String

RuleBasedCollator.getRules()
获取 collation 对象的基于表的规则。

String[]

DateFormatSymbols.getShortMonths()
获取简短形式的月份字符串。

String[]

DateFormatSymbols.getShortWeekdays()
获取简短形式的星期字符串。

String

CollationKey.getSourceString()
返回此 CollationKey 表示的 String。

String[]

DateFormatSymbols.getWeekdays()
获取星期字符串。

String[][]

DateFormatSymbols.getZoneStrings()
获取时区字符串。

static String

Normalizer.normalize(CharSequence src, Normalizer.Form form)
标准化 char 值序列。

String

DecimalFormat.toLocalizedPattern()
合成一个表示此 Format 对象当前状态的、已本地化的模式字符串。

String

SimpleDateFormat.toLocalizedPattern()
返回描述此日期格式的本地化模式字符串。

String

ChoiceFormat.toPattern()
获取模式。

String

DecimalFormat.toPattern()
合成一个表示此 Format 对象当前状态的模式字符串。

String

SimpleDateFormat.toPattern()
返回描述此日期格式的模式字符串。

String

MessageFormat.toPattern()
返回表示消息格式当前状态的模式。

String

Annotation.toString()
返回此 Annotation 的 String 表示形式。

String

AttributedCharacterIterator.Attribute.toString()
返回该对象的字符串表示形式。

String

Bidi.toString()
用于调试时显示双向算法的内部状态。

String

ParsePosition.toString()
返回此 ParsePosition 的字符串表示形式。

String

FieldPosition.toString()
返回此 FieldPosition 的字符串表示形式。

参数类型为 String 的 java.text 中的方法

void

DecimalFormat.applyLocalizedPattern(String pattern)
将给定的模式应用于此 Format 对象。

void

SimpleDateFormat.applyLocalizedPattern(String pattern)
将给定的本地化模式字符串应用于此日期格式。

void

ChoiceFormat.applyPattern(String newPattern)
设置模式。

void

DecimalFormat.applyPattern(String pattern)
将给定的模式应用于此 Format 对象。

void

SimpleDateFormat.applyPattern(String pattern)
将给定模式字符串应用于此日期格式。

void

MessageFormat.applyPattern(String pattern)
设置此消息格式所使用的模式。

int

RuleBasedCollator.compare(String source, String target)
根据表规则比较存储在两个不同字符串中的字符数据。

abstract  int

Collator.compare(String source, String target)
根据此 Collator 的整理规则来比较源字符串和目标字符串。

boolean

Collator.equals(String source, String target)
根据此 Collator 的整理规则比较两个字符串是否相等的便捷方法。

static String

MessageFormat.format(String pattern, Object... arguments)
创建具有给定模式的 MessageFormat，并用它来格式化给定的参数。

CollationElementIterator

RuleBasedCollator.getCollationElementIterator(String source)
返回给定 String 的 CollationElementIterator。

CollationKey

RuleBasedCollator.getCollationKey(String source)
将字符串转换为能够与 CollationKey.compareTo 进行比较的一系列字符。

abstract  CollationKey

Collator.getCollationKey(String source)
将该 String 转换为一系列可以和其他 CollationKey 按位进行比较的位。

Number

NumberFormat.parse(String source)
解析给定字符串开头的文本，生成一个数值。

Date

DateFormat.parse(String source)
从给定字符串的开始解析文本，以生成一个日期。

Object[]

MessageFormat.parse(String source)
从给定字符串的开始位置解析文本，以生成一个对象数组。

Number

ChoiceFormat.parse(String text, ParsePosition status)
解析输入文本中的一个 Number。

Number

DecimalFormat.parse(String text, ParsePosition pos)
解析字符串中的文本，以生成一个 Number。

abstract  Number

NumberFormat.parse(String source, ParsePosition parsePosition)
如果可能则返回 Long （例如，在 [Long.MIN_VALUE, Long.MAX_VALUE] 范围内且没有小数），否则返回 Double。

Date

SimpleDateFormat.parse(String text, ParsePosition pos)
解析字符串的文本，生成 Date。

abstract  Date

DateFormat.parse(String source, ParsePosition pos)
根据给定的解析位置开始解析日期/时间字符串。

Object[]

MessageFormat.parse(String source, ParsePosition pos)
解析字符串。

Object

Format.parseObject(String source)
从给定字符串的开始处解析文本以生成一个对象。

Object

NumberFormat.parseObject(String source, ParsePosition pos)
解析字符串中的文本，以生成一个 Number。

Object

DateFormat.parseObject(String source, ParsePosition pos)
解析字符串中的文本，以生成一个 Date。

Object

MessageFormat.parseObject(String source, ParsePosition pos)
解析字符串文本，生成一个对象数组。

abstract  Object

Format.parseObject(String source, ParsePosition pos)
解析字符串文本，生成一个对象。

void

DateFormatSymbols.setAmPmStrings(String[] newAmpms)
设置 ampm 字符串。

void

ChoiceFormat.setChoices(double[] limits, String[] formats)
设置要在格式化中使用的 choice。

void

DecimalFormatSymbols.setCurrencySymbol(String currency)
设置这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。

void

DateFormatSymbols.setEras(String[] newEras)
设置年代字符串。

void

DecimalFormatSymbols.setExponentSeparator(String exp)
设置用于分隔尾数和指数的字符串。

void

DecimalFormatSymbols.setInfinity(String infinity)
设置用于表示无穷大的字符串。

void

DecimalFormatSymbols.setInternationalCurrencySymbol(String currencyCode)
设置这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。

void

DateFormatSymbols.setLocalPatternChars(String newLocalPatternChars)
设置本地化的日期-时间模式字符。

void

DateFormatSymbols.setMonths(String[] newMonths)
设置月份字符串。

void

DecimalFormatSymbols.setNaN(String NaN)
设置用于表示“非数字”的字符串。

void

DecimalFormat.setNegativePrefix(String newValue)
设置负数前缀。

void

DecimalFormat.setNegativeSuffix(String newValue)
设置负数后缀。

void

DecimalFormat.setPositivePrefix(String newValue)
设置正数前缀。

void

DecimalFormat.setPositiveSuffix(String newValue)
设置正数后缀。

void

DateFormatSymbols.setShortMonths(String[] newShortMonths)
设置简短形式的月份字符串。

void

DateFormatSymbols.setShortWeekdays(String[] newShortWeekdays)
设置简短形式的星期字符串。

void

BreakIterator.setText(String newText)
设置要被扫描的新文本字符串。

void

CollationElementIterator.setText(String source)
设置一个要迭代的新字符串。

void

StringCharacterIterator.setText(String text)
将此迭代器重置为指向一个新的字符串。

void

DateFormatSymbols.setWeekdays(String[] newWeekdays)
设置星期字符串。

void

DateFormatSymbols.setZoneStrings(String[][] newZoneStrings)
设置时区字符串。

static Normalizer.Form

Normalizer.Form.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.text 中的构造方法

AttributedCharacterIterator.Attribute(String name)
构造具有给定名称的 Attribute。

AttributedString(String text)
构造带给定文本的 AttributedString 实例。

AttributedString(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
构造带给定文本和属性的 AttributedString。

Bidi(String paragraph, int flags)
由给定的文本段和基本方向构造 Bidi。

ChoiceFormat(double[] limits, String[] formats)
根据 limit 和相应的 format 构造。

ChoiceFormat(String newPattern)
根据 limit 和相应的 format（基于模式）构造。

CollationKey(String source)
CollationKey 构造方法。

DateFormat.Field(String name, int calendarField)
创建一个 Field。

DecimalFormat(String pattern)
使用给定的模式和默认语言环境的符号创建一个 DecimalFormat。

DecimalFormat(String pattern, DecimalFormatSymbols symbols)
使用给定的模式和符号创建一个 DecimalFormat。

Format.Field(String name)
创建具有指定名称的 Field。

MessageFormat.Field(String name)
创建具有指定名称的 Field。

MessageFormat(String pattern)
构造默认语言环境和指定模式的 MessageFormat。

MessageFormat(String pattern, Locale locale)
构造指定语言环境和模式的 MessageFormat。

NumberFormat.Field(String name)
创建具有指定名称的 Field 实例。

ParseException(String s, int errorOffset)
构造带指定详细消息和偏移量的 ParseException。

RuleBasedCollator(String rules)
RuleBasedCollator 构造方法。

SimpleDateFormat(String pattern)
用给定的模式和默认语言环境的日期格式符号构造 SimpleDateFormat。

SimpleDateFormat(String pattern, DateFormatSymbols formatSymbols)
用给定的模式和日期符号构造 SimpleDateFormat。

SimpleDateFormat(String pattern, Locale locale)
用给定的模式和给定语言环境的默认日期格式符号构造 SimpleDateFormat。

StringCharacterIterator(String text)
构造初始索引为 0 的迭代器。

StringCharacterIterator(String text, int pos)
构造具有指定的初始索引的迭代器。

StringCharacterIterator(String text, int begin, int end, int pos)
构造对给定字符串的给定范围进行迭代的迭代器（其索引设置为指定位置）。

java.util 中 String 的使用

类型参数类型为 String 的 java.util 中的字段

static List<String>

ResourceBundle.Control.FORMAT_CLASS
包含 "java.class" 的纯类 (class-only) 格式 List。

static List<String>

ResourceBundle.Control.FORMAT_DEFAULT
默认的格式 List，它包含字符串 "java.class" 和 "java.properties"（按此顺序）。

static List<String>

ResourceBundle.Control.FORMAT_PROPERTIES
包含 "java.properties" 的纯属性 (properties-only) 格式 List。

返回 String 的 java.util 中的方法

static String

Arrays.deepToString(Object[] a)
返回指定数组“深层内容”的字符串表示形式。

String

Scanner.findInLine(Pattern pattern)
试图在忽略分隔符的情况下查找下一个指定模式。

String

Scanner.findInLine(String pattern)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。

String

Scanner.findWithinHorizon(Pattern pattern, int horizon)
试图查找下一个指定模式。

String

Scanner.findWithinHorizon(String pattern, int horizon)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。

String

PropertyPermission.getActions()
返回动作的“规范化字符串表示形式”。

static String[]

TimeZone.getAvailableIDs()
获取受支持的所有可用 ID。

static String[]

TimeZone.getAvailableIDs(int rawOffset)
根据给定的时区偏移量（以毫秒为单位）获取可用的 ID。

String

MissingResourceException.getClassName()
获得构造方法所传递的参数。

String

UnknownFormatConversionException.getConversion()
返回未知的转换。

String

Locale.getCountry()
返回此语言环境的国家/地区代码，将为空字符串或大写的 ISO 3166 两字母代码。

String

Currency.getCurrencyCode()
获取此货币的 ISO 4217 货币代码。

String

Locale.getDisplayCountry()
返回适合向用户显示的语言环境国家/地区名。

String

Locale.getDisplayCountry(Locale inLocale)
返回适合向用户显示的语言环境国家/地区名。

String

Locale.getDisplayLanguage()
返回适合向用户显示的语言环境语言名。

String

Locale.getDisplayLanguage(Locale inLocale)
返回适合向用户显示的语言环境语言名。

String

TimeZone.getDisplayName()
返回适合于展示给默认区域的用户的时区名称。

String

Locale.getDisplayName()
返回适合向用户显示的语言环境名。

String

TimeZone.getDisplayName(boolean daylight, int style)
返回适合于展示给默认区域的用户的时区名称。

String

TimeZone.getDisplayName(boolean daylight, int style, Locale locale)
返回适合于展示给指定区域的用户的时区名称。

String

Calendar.getDisplayName(int field, int style, Locale locale)
返回给定 style 和 locale 下的日历 field 值的字符串表示形式。

String

TimeZone.getDisplayName(Locale locale)
返回适合于展示给指定区域的用户的时区名称。

String

Locale.getDisplayName(Locale inLocale)
返回适合向用户显示的语言环境名。

String

Locale.getDisplayVariant()
返回适合向用户显示的语言环境变量代码名。

String

Locale.getDisplayVariant(Locale inLocale)
返回适合向用户显示的语言环境变量代码名。

String

DuplicateFormatFlagsException.getFlags()
返回包含重复标志的一组标志。

String

FormatFlagsConversionMismatchException.getFlags()
返回不兼容的标志。

String

IllegalFormatFlagsException.getFlags()
返回包含非法组合的标志的集合。

String

UnknownFormatFlagsException.getFlags()
返回包含未知标志的标志集。

String

MissingFormatArgumentException.getFormatSpecifier()
返回不匹配的格式说明符。

String

MissingFormatWidthException.getFormatSpecifier()
返回没有宽度的格式说明符。

String

TimeZone.getID()
获取此时区的 ID。

String

Locale.getISO3Country()
返回此语言环境国家/地区的三字母缩写。

String

Locale.getISO3Language()
返回此语言环境语言的三字母缩写。

static String[]

Locale.getISOCountries()
返回 ISO 3166 中所定义的所有两字母国家/地区代码。

static String[]

Locale.getISOLanguages()
返回 ISO 639 中所定义的所有两字母语言代码。

String

MissingResourceException.getKey()
获得构造方法所传递的参数。

String

Locale.getLanguage()
返回此语言环境的语言代码，可以是空字符串或小写的 ISO 639 代码。

String

DuplicateFormatFlagsException.getMessage()

String

FormatFlagsConversionMismatchException.getMessage()

String

IllegalFormatCodePointException.getMessage()

String

IllegalFormatConversionException.getMessage()

String

IllegalFormatFlagsException.getMessage()

String

IllegalFormatPrecisionException.getMessage()

String

IllegalFormatWidthException.getMessage()

String

MissingFormatArgumentException.getMessage()

String

MissingFormatWidthException.getMessage()

String

UnknownFormatConversionException.getMessage()

String

UnknownFormatFlagsException.getMessage()

String

Properties.getProperty(String key)
用指定的键在此属性列表中搜索属性。

String

Properties.getProperty(String key, String defaultValue)
用指定的键在属性列表中搜索属性。

String

ResourceBundle.getString(String key)
从此资源包或它的某个父包中获取给定键的字符串。

String[]

ResourceBundle.getStringArray(String key)
从此资源包或它的某个父包中获取给定键的字符串数组。

String

Currency.getSymbol()
获取默认语言环境的货币符号。

String

Currency.getSymbol(Locale locale)
获取指定语言环境的货币符号。

String

Locale.getVariant()
返回此语言环境的变量代码。

String

Scanner.next()
查找并返回来自此扫描器的下一个完整标记。

String

Scanner.next(Pattern pattern)
如果下一个标记与指定模式匹配，则返回下一个标记。

String

Scanner.next(String pattern)
如果下一个标记与从指定字符串构造的模式匹配，则返回下一个标记。

String

Scanner.nextLine()
此扫描器执行当前行，并返回跳过的输入信息。

String

StringTokenizer.nextToken()
返回此 string tokenizer 的下一个标记。

String

StringTokenizer.nextToken(String delim)
返回此 string tokenizer 的字符串中的下一个标记。

String

ResourceBundle.Control.toBundleName(String baseName, Locale locale)
将给定 baseName 和 locale 转换为包名称。

String

Date.toGMTString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代，使用 GMT TimeZone。

String

Date.toLocaleString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代。

String

ResourceBundle.Control.toResourceName(String bundleName, String suffix)
将给定 bundleName 转换为 ClassLoader.getResource 方法要求的形式：用 '/' 替换 bundleName 中出现的所有 '.'，并添加一个 '.' 和给定的文件 suffix。

String

Formatter.toString()
返回对输出的目标文件调用 toString() 的结果。

String

Scanner.toString()
返回此 Scanner 的字符串表示形式。

String

ServiceLoader.toString()
返回一个描述此服务的字符串。

String

SimpleTimeZone.toString()
返回此时区的字符串表示形式。

String

UUID.toString()
返回表示此 UUID 的 String 对象。

String

Currency.toString()
返回此货币的 ISO 4217 货币代码。

String

Calendar.toString()
返回此日历的字符串表示形式。

String

Date.toString()
把此 Date 对象转换为以下形式的 String： dow mon dd hh:mm:ss zzz yyyy 其中： dow 是一周中的某一天 (Sun, Mon, Tue, Wed, Thu, Fri, Sat)。

String

EventObject.toString()
返回此 EventObject 的 String 表示形式。

String

Locale.toString()
使用由下划线分隔的语言、国家/地区和变量来获取整个语言环境的编程名称。

String

BitSet.toString()
返回此位 set 的字符串表示形式。

String

AbstractMap.toString()
返回此映射的字符串表示形式。

String

AbstractMap.SimpleEntry.toString()
返回此映射项的 String 表示形式。

String

AbstractMap.SimpleImmutableEntry.toString()
返回此映射项的 String 表示形式。

String

Vector.toString()
返回此向量的字符串表示形式，其中包含每个元素的 String 表示形式。

String

AbstractCollection.toString()
返回此 collection 的字符串表示形式。

String

Hashtable.toString()
返回此 Hashtable 对象的字符串表示形式，其形式为 ASCII 字符 ", " （逗号加空格）分隔开的、括在括号中的一组条目。

static String

Arrays.toString(boolean[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(byte[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(char[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(double[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(float[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(int[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(long[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(Object[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(short[] a)
返回指定数组内容的字符串表示形式。

返回变量类型为 String 的类型的 java.util 中的方法

Map<String,Integer>

Calendar.getDisplayNames(int field, int style, Locale locale)
返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。

List<String>

ResourceBundle.Control.getFormats(String baseName)
返回 String 的 List，它包含要用于加载给定 baseName 的资源包的格式。

Enumeration<String>

PropertyResourceBundle.getKeys()
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。

Enumeration<String>

ListResourceBundle.getKeys()
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。

abstract  Enumeration<String>

ResourceBundle.getKeys()
返回键的枚举。

protected  Set<String>

PropertyResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。

protected  Set<String>

ListResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。

protected  Set<String>

ResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。

Set<String>

ResourceBundle.keySet()
返回此 ResourceBundle 及其父包中包含的所有键的 Set。

Set<String>

Properties.stringPropertyNames()
返回此属性列表中的键集，其中该键及其对应值是字符串，如果在主属性列表中未找到同名的键，则还包括默认属性列表中不同的键。

参数类型为 String 的 java.util 中的方法

boolean

ResourceBundle.containsKey(String key)
确定给定 key 是否包含在此 ResourceBundle 及其父包中。

String

Scanner.findInLine(String pattern)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。

String

Scanner.findWithinHorizon(String pattern, int horizon)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。

Formatter

Formatter.format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。

Formatter

Formatter.format(String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此对象的目标文件中。

static UUID

UUID.fromString(String name)
根据 UUID.toString() 方法中描述的字符串标准表示形式创建 UUID。

static ResourceBundle

ResourceBundle.getBundle(String baseName)
使用指定的基本名称、默认的语言环境和调用者的类加载器获取资源包。

static ResourceBundle

ResourceBundle.getBundle(String baseName, Locale locale)
使用指定的基本名称、语言环境和调用者的类加载器获取资源包。

static ResourceBundle

ResourceBundle.getBundle(String baseName, Locale locale, ClassLoader loader)
使用指定的基本名称、语言环境和类加载器获取资源包。

static ResourceBundle

ResourceBundle.getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control)
使用指定基本名称、目标语言环境、类加载器和控件返回资源包。

static ResourceBundle

ResourceBundle.getBundle(String baseName, Locale targetLocale, ResourceBundle.Control control)
使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。

static ResourceBundle

ResourceBundle.getBundle(String baseName, ResourceBundle.Control control)
使用指定基本名称、默认语言环境和指定控件返回一个资源包。

List<Locale>

ResourceBundle.Control.getCandidateLocales(String baseName, Locale locale)
返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。

Locale

ResourceBundle.Control.getFallbackLocale(String baseName, Locale locale)
返回一个要用作回退语言环境的 Locale，用于 ResourceBundle.getBundle 工厂方法进行进一步资源包搜索。

List<String>

ResourceBundle.Control.getFormats(String baseName)
返回 String 的 List，它包含要用于加载给定 baseName 的资源包的格式。

static Currency

Currency.getInstance(String currencyCode)
返回给定货币代码的 Currency 实例。

Object

ResourceBundle.getObject(String key)
从此资源包或它的某个父包中获取给定键的对象。

String

Properties.getProperty(String key)
用指定的键在此属性列表中搜索属性。

String

Properties.getProperty(String key, String defaultValue)
用指定的键在属性列表中搜索属性。

String

ResourceBundle.getString(String key)
从此资源包或它的某个父包中获取给定键的字符串。

String[]

ResourceBundle.getStringArray(String key)
从此资源包或它的某个父包中获取给定键的字符串数组。

long

ResourceBundle.Control.getTimeToLive(String baseName, Locale locale)
返回在此 ResourceBundle.Control 下加载的资源包生存时间 (TTL) 值。

static TimeZone

TimeZone.getTimeZone(String ID)
获取给定 ID 的 TimeZone。

Object

PropertyResourceBundle.handleGetObject(String key)

Object

ListResourceBundle.handleGetObject(String key)

protected abstract  Object

ResourceBundle.handleGetObject(String key)
从此资源包中获取给定键的对象。

boolean

Scanner.hasNext(String pattern)
如果下一个标记与从指定字符串构造的模式匹配，则返回 true。

boolean

ResourceBundle.Control.needsReload(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime)
确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。

ResourceBundle

ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。

String

Scanner.next(String pattern)
如果下一个标记与从指定字符串构造的模式匹配，则返回下一个标记。

String

StringTokenizer.nextToken(String delim)
返回此 string tokenizer 的字符串中的下一个标记。

static long

Date.parse(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。

void

Properties.save(OutputStream out, String comments)
已过时。 如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。

void

TimeZone.setID(String ID)
设置时区 ID。

Object

Properties.setProperty(String key, String value)
调用 Hashtable 的方法 put。

Scanner

Scanner.skip(String pattern)
跳过与从指定字符串构造的模式匹配的输入信息。

void

Properties.store(OutputStream out, String comments)
以适合使用 load(InputStream) 方法加载到 Properties 表中的格式，将此 Properties 表中的属性列表（键和元素对）写入输出流。

void

Properties.store(Writer writer, String comments)
以适合使用 load(Reader) 方法的格式，将此 Properties 表中的属性列表（键和元素对）写入输出字符。

void

Properties.storeToXML(OutputStream os, String comment)
发出一个表示此表中包含的所有属性的 XML 文档。

void

Properties.storeToXML(OutputStream os, String comment, String encoding)
使用指定的编码发出一个表示此表中包含的所有属性的 XML 文档。

String

ResourceBundle.Control.toBundleName(String baseName, Locale locale)
将给定 baseName 和 locale 转换为包名称。

String

ResourceBundle.Control.toResourceName(String bundleName, String suffix)
将给定 bundleName 转换为 ClassLoader.getResource 方法要求的形式：用 '/' 替换 bundleName 中出现的所有 '.'，并添加一个 '.' 和给定的文件 suffix。

Scanner

Scanner.useDelimiter(String pattern)
将此扫描器的分隔模式设置为从指定 String 构造的模式。

static Formatter.BigDecimalLayoutForm

Formatter.BigDecimalLayoutForm.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

类型变量类型为 String 的 java.util 中的方法参数

static ResourceBundle.Control

ResourceBundle.Control.getControl(List<String> formats)
返回 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats。

static ResourceBundle.Control

ResourceBundle.Control.getNoFallbackControl(List<String> formats)
返回一个 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats，getFallbackLocale 方法在其中返回 null。

参数类型为 String 的 java.util 中的构造方法

ConcurrentModificationException(String message)
构造带指定详细消息的 ConcurrentModificationException。

Date(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。

DuplicateFormatFlagsException(String f)
构造带指定标志的此类的一个实例。

FormatFlagsConversionMismatchException(String f, char c)
构造带指定标志和转换的此类的一个实例。

Formatter(File file, String csn)
构造一个带指定文件和字符集的新 formatter。

Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。

Formatter(OutputStream os, String csn)
构造一个带指定输出流和字符集的新 formatter。

Formatter(OutputStream os, String csn, Locale l)
构造一个带指定输出流、字符集和语言环境的新 formatter。

Formatter(String fileName)
构造一个带指定文件名的新 formatter。

Formatter(String fileName, String csn)
构造一个带指定文件名和字符集的新 formatter。

Formatter(String fileName, String csn, Locale l)
构造一个带指定文件名、字符集和语言环境的新 formatter。

IllegalFormatFlagsException(String f)
构造带有指定标志的此类的一个实例。

InputMismatchException(String s)
构造 InputMismatchException，将引用保存到错误消息字符串 s 中，以便将来由 getMessage 方法获取。

InvalidPropertiesFormatException(String message)
构造一个带指定详细消息的 InvalidPropertiesFormatException。

Locale(String language)
根据语言代码构造一个语言环境。

Locale(String language, String country)
根据语言和国家/地区构造一个语言环境。

Locale(String language, String country, String variant)
根据语言、国家/地区和变量构造一个语言环境。

MissingFormatArgumentException(String s)
构造带有不匹配的格式说明符的此类的一个实例。

MissingFormatWidthException(String s)
构造带有指定格式说明符的此类的一个实例。

MissingResourceException(String s, String className, String key)
构造带有指定信息的 MissingResourceException。

NoSuchElementException(String s)
构造一个 NoSuchElementException，保存对错误消息字符串 s 的引用，以便将来通过 getMessage 方法进行获取。

PropertyPermission(String name, String actions)
创建带指定名称的新 PropertyPermission 对象。

Scanner(File source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。

Scanner(InputStream source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。

Scanner(ReadableByteChannel source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定信道扫描的。

Scanner(String source)
构造一个新的 Scanner，它生成的值是从指定字符串扫描的。

ServiceConfigurationError(String msg)
构造一个带有指定消息的新实例。

ServiceConfigurationError(String msg, Throwable cause)
构造一个带有指定消息和 cause 的新实例。

SimpleTimeZone(int rawOffset, String ID)
使用给定的相对于 GMT 的基准时区偏移量和不带夏令时安排的时区 ID 构造一个 SimpleTimeZone。

SimpleTimeZone(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int endMonth, int endDay, int endDayOfWeek, int endTime)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。

SimpleTimeZone(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int endMonth, int endDay, int endDayOfWeek, int endTime, int dstSavings)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。

SimpleTimeZone(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int startTimeMode, int endMonth, int endDay, int endDayOfWeek, int endTime, int endTimeMode, int dstSavings)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。

StringTokenizer(String str)
为指定字符串构造一个 string tokenizer。

StringTokenizer(String str, String delim)
为指定字符串构造一个 string tokenizer。

StringTokenizer(String str, String delim, boolean returnDelims)
为指定字符串构造一个 string tokenizer。

Timer(String name)
创建一个新计时器，其相关的线程具有指定的名称。

Timer(String name, boolean isDaemon)
创建一个新计时器，其相关的线程具有指定的名称，并且可以指定作为守护程序运行。

TooManyListenersException(String s)
构造带指定详细消息的 TooManyListenersException。

UnknownFormatConversionException(String s)
使用未知的转换构造此类的实例。

UnknownFormatFlagsException(String f)
使用指定的标志构造此类的实例。

java.util.concurrent 中 String 的使用

返回 String 的 java.util.concurrent 中的方法

String

ArrayBlockingQueue.toString()

String

CopyOnWriteArrayList.toString()
返回此列表的字符串表示形式。

String

CountDownLatch.toString()
返回标识此锁存器及其状态的字符串。

String

LinkedBlockingDeque.toString()

String

LinkedBlockingQueue.toString()

String

PriorityBlockingQueue.toString()

String

Semaphore.toString()
返回标识此信号量的字符串，以及信号量的状态。

参数类型为 String 的 java.util.concurrent 中的方法

static TimeUnit

TimeUnit.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.util.concurrent 中的构造方法

BrokenBarrierException(String message)
构造带指定详细消息的 BrokenBarrierException。

CancellationException(String message)
构造带指定详细消息的 CancellationException。

ExecutionException(String message)
构造带指定详细消息的 ExecutionException。

ExecutionException(String message, Throwable cause)
构造带指定详细消息和原因的 ExecutionException。

RejectedExecutionException(String message)
构造带指定详细消息的 RejectedExecutionException。

RejectedExecutionException(String message, Throwable cause)
构造带指定详细消息和原因的 RejectedExecutionException。

TimeoutException(String message)
构造带指定详细消息的 TimeoutException。

java.util.concurrent.atomic 中 String 的使用

返回 String 的 java.util.concurrent.atomic 中的方法

String

AtomicIntegerArray.toString()
返回数组当前值的字符串表示形式。

String

AtomicLongArray.toString()
返回数组当前值的字符串表示形式。

String

AtomicReference.toString()
返回当前值的字符串表示形式。

String

AtomicReferenceArray.toString()
返回数组当前值的字符串表示形式。

String

AtomicInteger.toString()
返回当前值的字符串表示形式。

String

AtomicLong.toString()
返回当前值的字符串表示形式。

String

AtomicBoolean.toString()
返回当前值的字符串表示形式。

参数类型为 String 的 java.util.concurrent.atomic 中的方法

static

<U,W> AtomicReferenceFieldUpdater<U,W>

AtomicReferenceFieldUpdater.newUpdater(Class<U> tclass, Class<W> vclass, String fieldName)
使用给定的字段为对象创建和返回一个更新器。

static

<U> AtomicIntegerFieldUpdater<U>

AtomicIntegerFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
使用给定字段为对象创建和返回一个更新器。

static

<U> AtomicLongFieldUpdater<U>

AtomicLongFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
为对象创建并返回一个具有给定字段的更新器。

java.util.concurrent.locks 中 String 的使用

返回 String 的 java.util.concurrent.locks 中的方法

String

AbstractQueuedLongSynchronizer.toString()
返回标识此同步器及其状态的字符串。

String

ReentrantReadWriteLock.toString()
返回标识此锁及其锁状态的字符串。

String

ReentrantReadWriteLock.ReadLock.toString()
返回标识此锁及其锁状态的字符串。

String

ReentrantReadWriteLock.WriteLock.toString()
返回标识此锁及其锁状态的字符串。

String

AbstractQueuedSynchronizer.toString()
返回标识此同步器及其状态的字符串。

String

ReentrantLock.toString()
返回标识此锁及其锁定状态的字符串。

java.util.jar 中 String 的使用

声明为 String 的 java.util.jar 中的字段

static String

Pack200.Packer.CLASS_ATTRIBUTE_PFX
当与类属性名称连在一起时，使用 JSR 200 规范中指定的布局语言指出该属性的格式。

static String

Pack200.Packer.CODE_ATTRIBUTE_PFX
当与代码属性名称连在一起时，指出该属性的格式。

static String

Pack200.Packer.DEFLATE_HINT
如果将此属性设置为 Pack200.Packer.TRUE 或 Pack200.Packer.FALSE，则打包器将在输出存档中设置相应的压缩提示，并且不传输存档元素的单个压缩提示。

static String

Pack200.Unpacker.DEFLATE_HINT
此属性指示解包器应该忽略 DEFLATE_HINT 的所有已传输的值，并用给定值 Pack200.Unpacker.TRUE 或 Pack200.Unpacker.FALSE 替换它们。

static String

Pack200.Packer.EFFORT
如果将此属性设置为单个十进制数字，则打包器将在压缩存档时使用指定压缩级别。

static String

Pack200.Packer.ERROR
字符串 "error"，某些属性的可能值。

static String

Pack200.Packer.FALSE
字符串 "false"，某些属性的可能值。

static String

Pack200.Unpacker.FALSE
字符串 "false"，某些属性的可能值。

static String

Pack200.Packer.FIELD_ATTRIBUTE_PFX
当与字段属性名称连在一起时，指出该属性的格式。

static String

Pack200.Packer.KEEP
字符串 "keep"，某些属性的可能值。

static String

Pack200.Unpacker.KEEP
字符串 "keep"，某些属性的可能值。

static String

Pack200.Packer.KEEP_FILE_ORDER
如果将此属性设置为 Pack200.Packer.TRUE，则打包器将按它们在源存档中的原始顺序传输所有元素。

static String

Pack200.Packer.LATEST
字符串 "latest"，某些属性的可能值。

static String

JarFile.MANIFEST_NAME
JAR 清单文件名称。

static String

Pack200.Packer.METHOD_ATTRIBUTE_PFX
当与方法属性名称连在一起时，指出该属性的格式。

static String

Pack200.Packer.MODIFICATION_TIME
如果将此属性设置为特殊的字符串 Pack200.Packer.LATEST，则打包器将尝试在原始存档中的所有可用条目中确定最后修改时间，或者确定每个段中所有可用条目的最后修改时间。

static String

Pack200.Packer.PASS
字符串 "pass"，某些属性的可能值。

static String

Pack200.Packer.PASS_FILE_PFX
指出文件应该按字节传递（无压缩）。

static String

Pack200.Packer.PROGRESS
解包器的百分比进度，由解包器定期更新。

static String

Pack200.Unpacker.PROGRESS
解包器的百分比进度，由解包器定期更新。

static String

Pack200.Packer.SEGMENT_LIMIT
此属性是一个数字，给出了每个存档段的估计目标大小 N（以字节为单位）。

static String

Pack200.Packer.STRIP
字符串 "strip"，某些属性的可能值。

static String

Pack200.Packer.TRUE
字符串 "true"，某些属性的可能值。

static String

Pack200.Unpacker.TRUE
字符串 "true"，某些属性的可能值。

static String

Pack200.Packer.UNKNOWN_ATTRIBUTE
指出遇到包含有未知属性的类文件时所采取的行动。

返回 String 的 java.util.jar 中的方法

String

Attributes.getValue(Attributes.Name name)
返回指定的 Attributes.Name 的值，如果未找到，则返回 null。

String

Attributes.getValue(String name)
返回指定属性名称的值，如果未找到，则返回 null。

String

Attributes.putValue(String name, String value)
将指定的值作为一个 String 关联到指定的属性名称。

String

Attributes.Name.toString()
返回字符串形式的属性名称。

返回变量类型为 String 的类型的 java.util.jar 中的方法

Map<String,Attributes>

Manifest.getEntries()
返回此 Manifest 中所包含条目的 Map。

SortedMap<String,String>

Pack200.Packer.properties()
获取此引擎属性集。

SortedMap<String,String>

Pack200.Packer.properties()
获取此引擎属性集。

SortedMap<String,String>

Pack200.Unpacker.properties()
获取此引擎属性集。

SortedMap<String,String>

Pack200.Unpacker.properties()
获取此引擎属性集。

参数类型为 String 的 java.util.jar 中的方法

protected  ZipEntry

JarInputStream.createZipEntry(String name)
为指定的 JAR 文件条目名称创建新的 JarEntry (ZipEntry)。

Attributes

Manifest.getAttributes(String name)
返回指定条目名称的 Attributes。

ZipEntry

JarFile.getEntry(String name)
返回给定条目名称的 ZipEntry；如果未找到，则返回 null。

JarEntry

JarFile.getJarEntry(String name)
返回给定条目名称的 JarEntry；如果未找到，则返回 null。

String

Attributes.getValue(String name)
返回指定属性名称的值，如果未找到，则返回 null。

String

Attributes.putValue(String name, String value)
将指定的值作为一个 String 关联到指定的属性名称。

参数类型为 String 的 java.util.jar 中的构造方法

Attributes.Name(String name)
用给定字符串名称构造一个新的属性名称。

JarEntry(String name)
为指定的 JAR 文件条目名称创建新的 JarEntry。

JarException(String s)
构造带指定详细消息的 JarException。

JarFile(String name)
创建一个要从指定的文件 name 读取的新的 JarFile。

JarFile(String name, boolean verify)
创建一个要从指定的文件 name 读取的新的 JarFile。

java.util.logging 中 String 的使用

声明为 String 的 java.util.logging 中的字段

static String

Logger.GLOBAL_LOGGER_NAME
GLOBAL_LOGGER_NAME 是全局 logger 的一个名称。

static String

LogManager.LOGGING_MXBEAN_NAME
LoggingMXBean 的 ObjectName 的字符串表示形式。

返回 String 的 java.util.logging 中的方法

abstract  String

Formatter.format(LogRecord record)
格式化给定的日志记录，并返回格式化后的字符串。

String

SimpleFormatter.format(LogRecord record)
格式化给定的 LogRecord。

String

XMLFormatter.format(LogRecord record)
将给定消息格式化为 XML。

String

Formatter.formatMessage(LogRecord record)
本地化和格式化来自日志记录的消息字符串。

String

Handler.getEncoding()
返回该 Handler 的字符编码。

String

Formatter.getHead(Handler h)
返回一组格式化记录的头部字符串。

String

XMLFormatter.getHead(Handler h)
返回一组 XML 格式记录的头部字符串。

String

Level.getLocalizedName()
返回当前默认语言环境的 Level 的本地化字符串名称。

String

LoggingMXBean.getLoggerLevel(String loggerName)
获取与指定 logger 相关的日志级别名称。

String

LogRecord.getLoggerName()
获取源 Logger 名称

String

LogRecord.getMessage()
获取本地化或格式化之前的“原始”日志消息。

String

Level.getName()
返回 Level 的非本地化字符串名称。

String

Logger.getName()
获取此 logger 的名称。

String

LoggingMXBean.getParentLoggerName(String loggerName)
返回指定 logger 的父 logger 名称。

String

LogManager.getProperty(String name)
获取日志属性的值。

String

LogRecord.getResourceBundleName()
获取本地化资源包名称。

String

Level.getResourceBundleName()
返回级别的本地化资源包名称；如果没有定义本地化包，则返回 null。

String

Logger.getResourceBundleName()
获取此 logger 的本地化资源包名称。

String

LogRecord.getSourceClassName()
获取发出日志请求的类的名称。

String

LogRecord.getSourceMethodName()
获取（可能）发出日志请求的方法的名称。

String

Formatter.getTail(Handler h)
返回一组格式化记录的尾部字符串。

String

XMLFormatter.getTail(Handler h)
返回一组 XML 格式记录的尾部字符串。

String

Level.toString()

返回变量类型为 String 的类型的 java.util.logging 中的方法

List<String>

LoggingMXBean.getLoggerNames()
返回当前已注册的 logger 列表。

Enumeration<String>

LogManager.getLoggerNames()
获取已知 logger 名称的枚举。

参数类型为 String 的 java.util.logging 中的方法

void

Logger.config(String msg)
记录一条 CONFIG 消息。

void

Logger.entering(String sourceClass, String sourceMethod)
记录一个方法条目。

void

Logger.entering(String sourceClass, String sourceMethod, Object param1)
记录一个方法条目，带有一个参数。

void

Logger.entering(String sourceClass, String sourceMethod, Object[] params)
记录一个方法条目，带有一组参数。

void

ErrorManager.error(String msg, Exception ex, int code)
在发生 Handler 失败时调用 error 方法。

void

Logger.exiting(String sourceClass, String sourceMethod)
记录一个方法返回。

void

Logger.exiting(String sourceClass, String sourceMethod, Object result)
记录一个方法返回，带有结果对象。

void

Logger.fine(String msg)
记录一条 FINE 消息。

void

Logger.finer(String msg)
记录一条 FINER 消息。

void

Logger.finest(String msg)
记录一条 FINEST 消息。

static Logger

Logger.getAnonymousLogger(String resourceBundleName)
创建一个匿名的 Logger。

Logger

LogManager.getLogger(String name)
查找指定 logger 的方法。

static Logger

Logger.getLogger(String name)
为指定子系统查找或创建一个 logger。

static Logger

Logger.getLogger(String name, String resourceBundleName)
为指定子系统查找或创建一个 logger。

String

LoggingMXBean.getLoggerLevel(String loggerName)
获取与指定 logger 相关的日志级别名称。

String

LoggingMXBean.getParentLoggerName(String loggerName)
返回指定 logger 的父 logger 名称。

String

LogManager.getProperty(String name)
获取日志属性的值。

void

Logger.info(String msg)
记录一条 INFO 消息。

void

Logger.log(Level level, String msg)
记录一条不带参数的消息。

void

Logger.log(Level level, String msg, Object param1)
记录带有一个对象参数的消息。

void

Logger.log(Level level, String msg, Object[] params)
记录带有一组对象参数的消息。

void

Logger.log(Level level, String msg, Throwable thrown)
记录带有相关的可抛出信息的消息。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg)
记录一条消息，具有指定的源类和方法，不带参数。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object param1)
记录一条消息，具有指定的源类和方法，带有单个日志消息的对象参数。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object[] params)
记录一条消息，具有指定的源类和方法，带有一组对象参数。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown)
记录一条消息，具有指定源类和方法，带有相关的可抛出信息。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg)
记录一条消息，具有指定的源类、方法和资源包名，不带参数。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1)
记录一条消息，具有指定的源类、方法和资源包名，带有单个日志消息的对象参数。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params)
记录一条消息，具有指定的源类、方法和资源包名，带有一组对象参数。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown)
记录一条消息，具有指定的源类、方法和资源包名，带有相关的可抛出对象。

static Level

Level.parse(String name)
将级别名称字符串解析成 Level。

protected  void

Handler.reportError(String msg, Exception ex, int code)
用于向该 Handler 的 ErrorManager 报告错误的受保护便利方法。

void

StreamHandler.setEncoding(String encoding)
设置（或更改）该 Handler 所用的字符编码。

void

Handler.setEncoding(String encoding)
设置该 Handler 所用的字符编码。

void

LoggingMXBean.setLoggerLevel(String loggerName, String levelName)
将指定 logger 设置为指定的新级别。

void

LogRecord.setLoggerName(String name)
设置源 Logger 名称。

void

LogRecord.setMessage(String message)
设置本地化或格式化之前的“原始”日志消息。

void

LogRecord.setResourceBundleName(String name)
设置本地化资源包名称。

void

LogRecord.setSourceClassName(String sourceClassName)
设置（可能）发出日志请求的类的名称。

void

LogRecord.setSourceMethodName(String sourceMethodName)
设置（可能）发出日志请求的方法的名称。

void

Logger.severe(String msg)
记录一条 SEVERE 消息。

void

Logger.throwing(String sourceClass, String sourceMethod, Throwable thrown)
正抛出异常的记录。

void

Logger.warning(String msg)
记录一条 WARNING 消息。

参数类型为 String 的 java.util.logging 中的构造方法

FileHandler(String pattern)
初始化要写入给定文件名的 FileHandler 。

FileHandler(String pattern, boolean append)
初始化要写入给定文件名的 FileHandler（使用可选的 append）。

FileHandler(String pattern, int limit, int count)
初始化要写入文件集的 FileHandler。

FileHandler(String pattern, int limit, int count, boolean append)
初始化要写入文件集的 FileHandler（使用可选的 append）。

Level(String name, int value)
使用给定的整数值创建一个指定的 Level。

Level(String name, int value, String resourceBundleName)
使用给定的整数值和给定的本地化资源名称创建一个指定的 Level。

Logger(String name, String resourceBundleName)
受保护的方法，它用于为一个指定子系统的构造 logger。

LoggingPermission(String name, String actions)
创建一个新的 LoggingPermission 对象。

LogRecord(Level level, String msg)
用给定级别和消息值构造 LogRecord。

SocketHandler(String host, int port)
构造一个带有指定主机和端口的 SocketHandler。

java.util.prefs 中 String 的使用

返回 String 的 java.util.prefs 中的方法

String

AbstractPreferences.absolutePath()
根据 Preferences.absolutePath() 中的规范实现 absolutePath 方法。

abstract  String

Preferences.absolutePath()
返回此首选项节点的绝对路径名。

String[]

AbstractPreferences.childrenNames()
根据 Preferences.childrenNames() 中的规范实现 children 方法。

abstract  String[]

Preferences.childrenNames()
返回此首选项节点相对于此节点的子节点名称。

protected abstract  String[]

AbstractPreferences.childrenNamesSpi()
返回此首选项节点的子节点名称。

String

AbstractPreferences.get(String key, String def)
根据 Preferences.get(String,String) 中的规范实现 get 方法。

abstract  String

Preferences.get(String key, String def)
返回与此首选项节点中指定键相关联的值。

String

PreferenceChangeEvent.getKey()
返回已更改首选项的键。

String

PreferenceChangeEvent.getNewValue()
返回首选项的新值。

protected abstract  String

AbstractPreferences.getSpi(String key)
返回与此首选项节点上的指定键相关联的值；如果不存在此键的关联值或此时无法确定该关联值，则返回 null。

String[]

AbstractPreferences.keys()
根据 Preferences.keys() 中的规范实现 keys 方法。

abstract  String[]

Preferences.keys()
返回在此首选项节点中具有关联值的所有键。

protected abstract  String[]

AbstractPreferences.keysSpi()
返回在此首选项节点中具有关联值的所有键。

String

AbstractPreferences.name()
根据 Preferences.name() 中的规范实现 name 方法。

abstract  String

Preferences.name()
返回此首选项节点相对于父节点的名称。

String

AbstractPreferences.toString()
返回此首选项节点的绝对路径名称。

abstract  String

Preferences.toString()
返回此首选项节点的字符串表示形式，与通过表达式：(this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath() 计算的结果一样。

参数类型为 String 的 java.util.prefs 中的方法

protected abstract  AbstractPreferences

AbstractPreferences.childSpi(String name)
返回此首选项节点的指定子节点；如果该子节点尚未存在，则创建它。

String

AbstractPreferences.get(String key, String def)
根据 Preferences.get(String,String) 中的规范实现 get 方法。

abstract  String

Preferences.get(String key, String def)
返回与此首选项节点中指定键相关联的值。

boolean

AbstractPreferences.getBoolean(String key, boolean def)
根据 Preferences.getBoolean(String,boolean) 中的规范实现 getBoolean 方法。

abstract  boolean

Preferences.getBoolean(String key, boolean def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 boolean 值。

byte[]

AbstractPreferences.getByteArray(String key, byte[] def)
根据 Preferences.getByteArray(String,byte[]) 中的规范实现 getByteArray 方法。

abstract  byte[]

Preferences.getByteArray(String key, byte[] def)
返回与此首选项节点中指定键相关联的、由字符串表示的字节数组。

protected  AbstractPreferences

AbstractPreferences.getChild(String nodeName)
如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。

double

AbstractPreferences.getDouble(String key, double def)
根据 Preferences.getDouble(String,double) 中的规范实现 getDouble 方法。

abstract  double

Preferences.getDouble(String key, double def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 double 值。

float

AbstractPreferences.getFloat(String key, float def)
根据 Preferences.getFloat(String,float) 中的规范实现 getFloat 方法。

abstract  float

Preferences.getFloat(String key, float def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 float 值。

int

AbstractPreferences.getInt(String key, int def)
根据 Preferences.getInt(String,int) 中的规范实现 getInt 方法。

abstract  int

Preferences.getInt(String key, int def)
返回与此首选项节点中与指定键相关联的、由字符串表示的 int 值。

long

AbstractPreferences.getLong(String key, long def)
根据 Preferences.getLong(String,long) 中的规范实现 getLong 方法。

abstract  long

Preferences.getLong(String key, long def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 long 值。

protected abstract  String

AbstractPreferences.getSpi(String key)
返回与此首选项节点上的指定键相关联的值；如果不存在此键的关联值或此时无法确定该关联值，则返回 null。

Preferences

AbstractPreferences.node(String path)
根据 Preferences.node(String) 中的规范实现 node 方法。

abstract  Preferences

Preferences.node(String pathName)
将指定首选项节点返回到此节点所在的同一树中，如果此节点及其祖先已经不存在，则创建它们。

boolean

AbstractPreferences.nodeExists(String path)
根据 Preferences.nodeExists(String) 中的规范实现 nodeExists 方法。

abstract  boolean

Preferences.nodeExists(String pathName)
如果此节点所在的树中存在指定首选项节点，则返回 true。

void

AbstractPreferences.put(String key, String value)
根据 Preferences.put(String,String) 中的规范实现 put 方法。

abstract  void

Preferences.put(String key, String value)
将指定值与此首选项节点中的指定键相关联。

void

AbstractPreferences.putBoolean(String key, boolean value)
根据 Preferences.putBoolean(String,boolean) 中的规范实现 putBoolean 方法。

abstract  void

Preferences.putBoolean(String key, boolean value)
将表示指定 boolean 值的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putByteArray(String key, byte[] value)
根据 Preferences.putByteArray(String,byte[]) 中的规范实现 putByteArray 方法。

abstract  void

Preferences.putByteArray(String key, byte[] value)
将表示指定字节数组的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putDouble(String key, double value)
根据 Preferences.putDouble(String,double) 中的规范实现 putDouble 方法。

abstract  void

Preferences.putDouble(String key, double value)
将表示指定 double 值的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putFloat(String key, float value)
根据 Preferences.putFloat(String,float) 中的规范实现 putFloat 方法。

abstract  void

Preferences.putFloat(String key, float value)
将表示指定 float 值的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putInt(String key, int value)
根据 Preferences.putInt(String,int) 中的规范实现 putInt 方法。

abstract  void

Preferences.putInt(String key, int value)
将表示指定 int 值的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putLong(String key, long value)
根据 Preferences.putLong(String,long) 中的规范实现 putLong 方法。

abstract  void

Preferences.putLong(String key, long value)
将表示指定 long 值的字符串与此首选项节点中的指定键相关联。

protected abstract  void

AbstractPreferences.putSpi(String key, String value)
将给定的键-值关联置于此首选项节点中。

void

AbstractPreferences.remove(String key)
根据 Preferences.remove(String) 中的规范实现 remove(String) 方法。

abstract  void

Preferences.remove(String key)
移除与此首选项节点中与指定键相关联的值（如果有）。

protected abstract  void

AbstractPreferences.removeSpi(String key)
移除此首选项节点上指定键的关联值（如果有）。

参数类型为 String 的 java.util.prefs 中的构造方法

AbstractPreferences(AbstractPreferences parent, String name)
用指定的父节点和与其父节点相关的指定名称创建首选项节点。

BackingStoreException(String s)
构造带指定详细消息的 BackingStoreException。

InvalidPreferencesFormatException(String message)
构造带指定详细消息的 InvalidPreferencesFormatException。

InvalidPreferencesFormatException(String message, Throwable cause)
构造带指定详细消息和原因的 InvalidPreferencesFormatException。

PreferenceChangeEvent(Preferences node, String key, String newValue)
构造新的 PreferenceChangeEvent 实例。

java.util.regex 中 String 的使用

返回 String 的 java.util.regex 中的方法

String

PatternSyntaxException.getDescription()
获取错误的描述。

String

PatternSyntaxException.getMessage()
返回多行字符串，包含语法错误及其索引的描述、错误的正则表达式模式和模式中错误索引的可视化指示。

String

PatternSyntaxException.getPattern()
获取错误的正则表达式模式。

String

Matcher.group()
返回由以前匹配操作所匹配的输入子序列。

String

MatchResult.group()
返回由以前匹配所匹配的输入子序列。

String

Matcher.group(int group)
返回在以前匹配操作期间由给定组捕获的输入子序列。

String

MatchResult.group(int group)
返回在以前匹配操作期间由给定组捕获的输入子序列。

String

Pattern.pattern()
返回在其中编译过此模式的正则表达式。

static String

Pattern.quote(String s)
返回指定 String 的字面值模式 String。

static String

Matcher.quoteReplacement(String s)
返回指定 String 的字面值替换 String。

String

Matcher.replaceAll(String replacement)
替换模式与给定替换字符串相匹配的输入序列的每个子序列。

String

Matcher.replaceFirst(String replacement)
替换模式与给定替换字符串匹配的输入序列的第一个子序列。

String[]

Pattern.split(CharSequence input)
围绕此模式的匹配拆分给定输入序列。

String[]

Pattern.split(CharSequence input, int limit)
围绕此模式的匹配拆分给定输入序列。

String

Matcher.toString()
返回匹配器的字符串表示形式。

String

Pattern.toString()
返回此模式的字符串表示形式。

参数类型为 String 的 java.util.regex 中的方法

Matcher

Matcher.appendReplacement(StringBuffer sb, String replacement)
实现非终端添加和替换步骤。

static Pattern

Pattern.compile(String regex)
将给定的正则表达式编译到模式中。

static Pattern

Pattern.compile(String regex, int flags)
将给定的正则表达式编译到具有给定标志的模式中。

static boolean

Pattern.matches(String regex, CharSequence input)
编译给定正则表达式并尝试将给定输入与其匹配。

static String

Pattern.quote(String s)
返回指定 String 的字面值模式 String。

static String

Matcher.quoteReplacement(String s)
返回指定 String 的字面值替换 String。

String

Matcher.replaceAll(String replacement)
替换模式与给定替换字符串相匹配的输入序列的每个子序列。

String

Matcher.replaceFirst(String replacement)
替换模式与给定替换字符串匹配的输入序列的第一个子序列。

参数类型为 String 的 java.util.regex 中的构造方法

PatternSyntaxException(String desc, String regex, int index)
构造此类的新实例。

java.util.spi 中 String 的使用

返回 String 的 java.util.spi 中的方法

abstract  String

LocaleNameProvider.getDisplayCountry(String countryCode, Locale locale)
返回适合向用户显示的给定 ISO 3166 国家代码和给定语言环境的本地化名称。

abstract  String

LocaleNameProvider.getDisplayLanguage(String languageCode, Locale locale)
返回适合向用户显示的给定 ISO 639 语言代码和给定语言环境的本地化名称。

abstract  String

TimeZoneNameProvider.getDisplayName(String ID, boolean daylight, int style, Locale locale)
返回适于展示给指定语言环境用户的给定时区 ID 名称。

abstract  String

LocaleNameProvider.getDisplayVariant(String variant, Locale locale)
返回适合向用户显示的给定变量代码和给定语言环境的本地化名称。

abstract  String

CurrencyNameProvider.getSymbol(String currencyCode, Locale locale)
获取指定语言环境的给定货币代码的符号。

参数类型为 String 的 java.util.spi 中的方法

abstract  String

LocaleNameProvider.getDisplayCountry(String countryCode, Locale locale)
返回适合向用户显示的给定 ISO 3166 国家代码和给定语言环境的本地化名称。

abstract  String

LocaleNameProvider.getDisplayLanguage(String languageCode, Locale locale)
返回适合向用户显示的给定 ISO 639 语言代码和给定语言环境的本地化名称。

abstract  String

TimeZoneNameProvider.getDisplayName(String ID, boolean daylight, int style, Locale locale)
返回适于展示给指定语言环境用户的给定时区 ID 名称。

abstract  String

LocaleNameProvider.getDisplayVariant(String variant, Locale locale)
返回适合向用户显示的给定变量代码和给定语言环境的本地化名称。

abstract  String

CurrencyNameProvider.getSymbol(String currencyCode, Locale locale)
获取指定语言环境的给定货币代码的符号。

java.util.zip 中 String 的使用

返回 String 的 java.util.zip 中的方法

String

ZipEntry.getComment()
返回条目的注释字符串；如果没有，则返回 null。

String

ZipEntry.getName()
返回条目名称。

String

ZipFile.getName()
返回 ZIP 文件的路径名。

String

ZipEntry.toString()
返回 ZIP 条目的字符串表示形式。

参数类型为 String 的 java.util.zip 中的方法

protected  ZipEntry

ZipInputStream.createZipEntry(String name)
为指定条目名称创建一个新的 ZipEntry 对象。

ZipEntry

ZipFile.getEntry(String name)
返回指定名称的 ZIP 文件条目；如果未找到，则返回 null。

void

ZipOutputStream.setComment(String comment)
设置 ZIP 文件注释。

void

ZipEntry.setComment(String comment)
为条目设置可选的注释字符串。

参数类型为 String 的 java.util.zip 中的构造方法

DataFormatException(String s)
构造带指定详细消息的 DataFormatException。

ZipEntry(String name)
使用指定名称创建新的 ZIP 条目。

ZipError(String s)
构造带有给定详细消息的 ZipError。

ZipException(String s)
构建带指定详细消息的 ZipException。

ZipFile(String name)
打开 ZIP 文件进行阅读。

javax.accessibility 中 String 的使用

声明为 String 的 javax.accessibility 中的字段

static String

AccessibleContext.ACCESSIBLE_ACTION_PROPERTY
用于指示支持的动作集已更改的常量。

static String

AccessibleContext.ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY
用于确定组件的活动子级已更改的常量。

static String

AccessibleContext.ACCESSIBLE_CARET_PROPERTY
用于确定 accessibleText 插入符已更改的常量。

static String

AccessibleContext.ACCESSIBLE_CHILD_PROPERTY
用于确定何时向对象添加或从对象移除 Accessible 子级的常量。

static String

AccessibleContext.ACCESSIBLE_COMPONENT_BOUNDS_CHANGED
指示组件边界已更改的 PropertyChangeEvent。

static String

AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY
用于确定 accessibleDescription 属性已更改的常量。

static String

AccessibleContext.ACCESSIBLE_HYPERTEXT_OFFSET
用于指示超文本元素已收到焦点的常量。

static String

AccessibleContext.ACCESSIBLE_INVALIDATE_CHILDREN
指示某个组件（例如树或文本）的子级已发生重要更改的 PropertyChangeEvent。

static String

AccessibleContext.ACCESSIBLE_NAME_PROPERTY
用于确定 accessibleName 属性已更改的常量。

static String

AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY
用于确定 accessibleSelection 已更改的常量。

static String

AccessibleContext.ACCESSIBLE_STATE_PROPERTY
用于确定 accessibleStateSet 属性已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_CAPTION_CHANGED
用于指示表标题已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED
用于指示列描述已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED
用于指示列标题已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_MODEL_CHANGED
用于指示表数据已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED
用于指示行描述已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_ROW_HEADER_CHANGED
用于指示行标题已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_SUMMARY_CHANGED
用于指示表摘要已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED
指示文本属性已更改的 PropertyChangeEvent。

static String

AccessibleContext.ACCESSIBLE_TEXT_PROPERTY
指示文本已更改的 PropertyChangeEvent。

static String

AccessibleContext.ACCESSIBLE_VALUE_PROPERTY
用于确定 accessibleValue 属性已更改的常量。

static String

AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY
用于确定对象的可见外观已更改的常量。

protected  String

AccessibleContext.accessibleDescription
包含对象描述的本地化 String。

protected  String

AccessibleContext.accessibleName
包含对象名称的本地化 String。

static String

AccessibleRelation.CHILD_NODE_OF
指示某个对象是一个或多个对象的子节点。

static String

AccessibleRelation.CHILD_NODE_OF_PROPERTY
指示两个或多个对象之间的 CHILD_NODE_OF 关系已更改。

static String

AccessibleAction.CLICK
导致某个组件执行其默认动作的动作。

static String

AccessibleRelation.CONTROLLED_BY
指示某个对象由一个或多个目标对象控制。

static String

AccessibleRelation.CONTROLLED_BY_PROPERTY
标识正在进行控制操作的目标对象已更改

static String

AccessibleRelation.CONTROLLER_FOR
指示某个对象是一个或多个目标对象的控制器。

static String

AccessibleRelation.CONTROLLER_FOR_PROPERTY
标识目标对象的控制器已更改

static String

AccessibleAction.DECREMENT
减少某个值的动作。

static String

AccessibleRelation.EMBEDDED_BY
指示某个对象嵌入一个或多个对象。

static String

AccessibleRelation.EMBEDDED_BY_PROPERTY
指示两个或多个对象之间的 EMBEDDED_BY 关系已更改。

static String

AccessibleRelation.EMBEDS
指示某个对象具有一个或多个嵌入它的对象。

static String

AccessibleRelation.EMBEDS_PROPERTY
指示两个或多个对象之间的 EMBEDS 关系已更改。

static String

AccessibleRelation.FLOWS_FROM
指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象出现在该对象前面。

static String

AccessibleRelation.FLOWS_FROM_PROPERTY
指示两个对象之间的 FLOWS_FROM 关系已更改。

static String

AccessibleRelation.FLOWS_TO
指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象在该对象后面出现。

static String

AccessibleRelation.FLOWS_TO_PROPERTY
指示两个对象之间的 FLOWS_TO 关系已更改。

static String

AccessibleAction.INCREMENT
增加某个值的动作。

protected  String

AccessibleBundle.key
与语言环境无关的状态名称。

static String

AccessibleRelation.LABEL_FOR
指示某个对象是一个或多个目标对象的标签。

static String

AccessibleRelation.LABEL_FOR_PROPERTY
标识某个标签的目标组已更改

static String

AccessibleRelation.LABELED_BY
指示一个或多个目标对象作为某个对象的标签。

static String

AccessibleRelation.LABELED_BY_PROPERTY
标识正在进行标签操作的对象已更改

static String

AccessibleRelation.MEMBER_OF
指示某个对象是一个或多个目标对象集合的成员。

static String

AccessibleRelation.MEMBER_OF_PROPERTY
标识组成员已更改。

static String

AccessibleRelation.PARENT_WINDOW_OF
指示某个对象是一个或多个对象的父窗口。

static String

AccessibleRelation.PARENT_WINDOW_OF_PROPERTY
指示两个或多个对象之间的 PARENT_WINDOW_OF 关系已更改。

static String

AccessibleRelation.SUBWINDOW_OF
指示某个对象是一个或多个对象的子窗口。

static String

AccessibleRelation.SUBWINDOW_OF_PROPERTY
指示两个或多个对象之间的 SUBWINDOW_OF 关系已更改。

String

AccessibleTextSequence.text
文本

static String

AccessibleAction.TOGGLE_EXPAND
如果树节点是展开的，则此动作将折叠它，如果是折叠的则展开它。

static String

AccessibleAction.TOGGLE_POPUP
如果某个弹出菜单是隐藏的，则此动作将使其可见，如果是可见的则将其隐藏。

返回 String 的 javax.accessibility 中的方法

abstract  String

AccessibleHyperlink.getAccessibleActionDescription(int i)
返回此特定链接动作的 String 描述。

String

AccessibleAction.getAccessibleActionDescription(int i)
返回对对象指定动作的描述。

String

AccessibleContext.getAccessibleDescription()
获取此对象的 accessibleDescription 属性。

String

AccessibleIcon.getAccessibleIconDescription()
获取此图标的描述。

String

AccessibleContext.getAccessibleName()
获取此对象的 accessibleName 属性。

String

AccessibleText.getAfterIndex(int part, int index)
返回给定索引后面的 String。

String

AccessibleText.getAtIndex(int part, int index)
返回给定索引处的 String。

String

AccessibleText.getBeforeIndex(int part, int index)
返回给定索引前面的 String。

String

AccessibleRelation.getKey()
返回此关系的键

String

AccessibleText.getSelectedText()
返回选定的部分文本。

String

AccessibleEditableText.getTextRange(int startIndex, int endIndex)
返回两个索引之间的文本字符串。

String

AccessibleExtendedText.getTextRange(int startIndex, int endIndex)
返回两个索引之间的文本。

String

AccessibleExtendedComponent.getTitledBorderText()
返回有标题的边框文本

String

AccessibleExtendedComponent.getToolTipText()
返回工具提示文本

String

AccessibleBundle.toDisplayString()
获取使用默认语言环境来描述键的本地化字符串。

String

AccessibleBundle.toDisplayString(Locale locale)
获取本地化字符串形式的键。

protected  String

AccessibleBundle.toDisplayString(String resourceBundleName, Locale locale)
获取本地化字符串形式的键。

String

AccessibleBundle.toString()
获取使用默认语言环境来描述键的本地化字符串。

String

AccessibleRelationSet.toString()
使用默认语言环境创建表示关系集中所有关系的本地化 String。

String

AccessibleStateSet.toString()
使用默认语言环境创建表示状态集中所有状态的本地化 String。

参数类型为 String 的 javax.accessibility 中的方法

boolean

AccessibleRelationSet.contains(String key)
返回关系集是否包含与指定键匹配的关系。

void

AccessibleContext.firePropertyChange(String propertyName, Object oldValue, Object newValue)
对报告 bound 属性更改的支持。

AccessibleRelation

AccessibleRelationSet.get(String key)
返回与指定键匹配的关系。

void

AccessibleEditableText.insertTextAtIndex(int index, String s)
在给定索引处插入指定的字符串。

void

AccessibleEditableText.replaceText(int startIndex, int endIndex, String s)
用指定的字符串替换两个索引之间的文本。

void

AccessibleContext.setAccessibleDescription(String s)
设置此对象的可访问描述。

void

AccessibleIcon.setAccessibleIconDescription(String description)
设置图标的描述。

void

AccessibleContext.setAccessibleName(String s)
设置此对象的可访问的本地化名称。

void

AccessibleEditableText.setTextContents(String s)
将文本内容设置为指定字符串。

protected  String

AccessibleBundle.toDisplayString(String resourceBundleName, Locale locale)
获取本地化字符串形式的键。

参数类型为 String 的 javax.accessibility 中的构造方法

AccessibleRelation(String key)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。

AccessibleRelation(String key, Object target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。

AccessibleRelation(String key, Object[] target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。

AccessibleRole(String key)
使用与语言环境无关的给定键创建新的 AccessibleRole。

AccessibleState(String key)
使用给定的与语言环境无关的键创建新的 AccessibleState。

AccessibleTextSequence(int start, int end, String txt)
构造带有给定参数的 AccessibleTextSequence。

javax.activation 中 String 的使用

返回 String 的 javax.activation 中的方法

String

MimeTypeParameterList.get(String name)
获取与给定名称关联的值；如果不存在当前关联，则返回 null。

String

MimeType.getBaseType()
返回此对象的 String 表示形式，不带参数列表。

String

CommandInfo.getCommandClass()
返回命令的类名。

String

CommandInfo.getCommandName()
返回命令动词。

String

DataHandler.getContentType()
返回从源对象中获取的此对象的 MIME 类型。

String

DataSource.getContentType()
此方法以字符串形式返回数据的 MIME 类型。

String

FileDataSource.getContentType()
此方法以字符串形式返回数据的 MIME 类型。

String

URLDataSource.getContentType()
返回 URL 内容-类型 (content-type) 头字段的值。

abstract  String

FileTypeMap.getContentType(File file)
返回文件对象的类型。

String

MimetypesFileTypeMap.getContentType(File f)
返回该文件对象的 MIME 类型。

abstract  String

FileTypeMap.getContentType(String filename)
返回传入文件的类型。

String

MimetypesFileTypeMap.getContentType(String filename)
返回基于指定文件名的 MIME 类型。

String

ActivationDataFlavor.getHumanPresentableName()
返回得体的名称。

String

ActivationDataFlavor.getMimeType()
返回此 DataFlavor 的 MIME 类型。

String[]

CommandMap.getMimeTypes()
获取此命令映射已知的所有 MIME 类型。

String[]

MailcapCommandMap.getMimeTypes()
获取此命令映射已知的所有 MIME 类型。

String

DataHandler.getName()
返回数据对象的名称。

String

DataSource.getName()
返回此对象的名称，其中对象的名称依赖于底层对象的特性。

String

FileDataSource.getName()
返回此对象的名称。

String

URLDataSource.getName()
调用用于实例化对象的 URL 的 getFile 方法。

String[]

MailcapCommandMap.getNativeCommands(String mimeType)
获取给定 MIME 类型的本地命令。

String

MimeType.getParameter(String name)
获取与给定名称关联的值；如果没有当前关联，则返回 null。

String

MimeType.getPrimaryType()
获取此对象的基本类型。

String

MimeType.getSubType()
获取此对象的子类型。

protected  String

ActivationDataFlavor.normalizeMimeType(String mimeType)
已过时。

protected  String

ActivationDataFlavor.normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。

String

MimeType.toString()
返回此对象的 String 表示形式。

String

MimeTypeParameterList.toString()
返回此对象的字符串表示形式。

参数类型为 String 的 javax.activation 中的方法

void

MailcapCommandMap.addMailcap(String mail_cap)
将条目添加到注册表。

void

MimetypesFileTypeMap.addMimeTypes(String mime_types)
将 MIME 类型值预先添加到注册表。

abstract  DataContentHandler

CommandMap.createDataContentHandler(String mimeType)
查找与 MIME 类型对应的 DataContentHandler。

DataContentHandler

DataContentHandlerFactory.createDataContentHandler(String mimeType)
针对 MIME 类型创建一个新的 DataContentHandler 对象。

DataContentHandler

MailcapCommandMap.createDataContentHandler(String mimeType)
返回指定 MIME 类型的 DataContentHandler。

DataContentHandler

CommandMap.createDataContentHandler(String mimeType, DataSource ds)
查找与 MIME 类型对应的 DataContentHandler。

String

MimeTypeParameterList.get(String name)
获取与给定名称关联的值；如果不存在当前关联，则返回 null。

abstract  CommandInfo[]

CommandMap.getAllCommands(String mimeType)
获取此类型的所有可用命令。

CommandInfo[]

MailcapCommandMap.getAllCommands(String mimeType)
针对此 MIME 类型获取此 MailcapCommandMap 实例已知的所有 mailcap 文件中的所有可用命令。

CommandInfo[]

CommandMap.getAllCommands(String mimeType, DataSource ds)
获取此类型的所有可用命令。

CommandInfo

DataHandler.getCommand(String cmdName)
获取命令 cmdName。

abstract  CommandInfo

CommandMap.getCommand(String mimeType, String cmdName)
获取与 MIME 类型对应的默认命令。

CommandInfo

MailcapCommandMap.getCommand(String mimeType, String cmdName)
针对 MIME 类型获取与 cmdName 对应的命令。

CommandInfo

CommandMap.getCommand(String mimeType, String cmdName, DataSource ds)
获取与 MIME 类型对应的默认命令。

abstract  String

FileTypeMap.getContentType(String filename)
返回传入文件的类型。

String

MimetypesFileTypeMap.getContentType(String filename)
返回基于指定文件名的 MIME 类型。

String[]

MailcapCommandMap.getNativeCommands(String mimeType)
获取给定 MIME 类型的本地命令。

String

MimeType.getParameter(String name)
获取与给定名称关联的值；如果没有当前关联，则返回 null。

abstract  CommandInfo[]

CommandMap.getPreferredCommands(String mimeType)
从 MIME 类型获取首选命令表。

CommandInfo[]

MailcapCommandMap.getPreferredCommands(String mimeType)
获取 MIME 类型的首选命令列表。

CommandInfo[]

CommandMap.getPreferredCommands(String mimeType, DataSource ds)
从 MIME 类型获取首选命令表。

boolean

ActivationDataFlavor.isMimeTypeEqual(String mimeType)
传入的 MIME 类型的字符串表示形式是否等效于此 DataFlavor 的 MIME 类型。

boolean

MimeType.match(String rawdata)
确定此对象的基本类型和子类型与 rawdata 中描述的内容类型是否相同。

protected  String

ActivationDataFlavor.normalizeMimeType(String mimeType)
已过时。

protected  String

ActivationDataFlavor.normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。

protected  void

MimeTypeParameterList.parse(String parameterList)
将参数列表从一个 String 解析出来的例程。

void

MimeTypeParameterList.remove(String name)
移除与给定名称关联的所有值。

void

MimeType.removeParameter(String name)
移除与给定名称关联的所有值。

void

MimeTypeParameterList.set(String name, String value)
将值设置为与给定名称关联，替换以前的任何关联。

void

CommandObject.setCommandContext(String verb, DataHandler dh)
用请求处理的动词和描述将要操作的数据的 DataHandler 来初始化 Command。

void

ActivationDataFlavor.setHumanPresentableName(String humanPresentableName)
设置得体的名称。

void

MimeType.setParameter(String name, String value)
将值设置为与给定的名称关联，替换以前的任何关联。

void

MimeType.setPrimaryType(String primary)
将此对象的基本类型设置为给定的 String。

void

MimeType.setSubType(String sub)
将此对象的子类型设置为给定的 String。

void

DataContentHandler.writeTo(Object obj, String mimeType, OutputStream os)
将对象转换为指定 MIME 类型的字节流，并将其写入输出流。

参数类型为 String 的 javax.activation 中的构造方法

ActivationDataFlavor(Class representationClass, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。

ActivationDataFlavor(Class representationClass, String mimeType, String humanPresentableName)
构造一个表示任意 Java 对象的 DataFlavor。

ActivationDataFlavor(String mimeType, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。

CommandInfo(String verb, String className)
CommandInfo 的构造方法。

DataHandler(Object obj, String mimeType)
创建表示此 MIME 类型对象的 DataHandler 实例。

FileDataSource(String name)
根据指定的路径名创建 FileDataSource。

MailcapCommandMap(String fileName)
允许调用者指定 mailcap 文件路径的构造方法。

MimeType(String rawdata)
根据 String 构建 MimeType 的构造方法。

MimeType(String primary, String sub)
用给定的基本类型和子类型构建 MimeType 的构造方法，它的参数列表为空。

MimeTypeParameterList(String parameterList)
用传入的数据构造新的 MimeTypeParameterList。

MimeTypeParseException(String s)
构造带指定详细消息的 MimeTypeParseException。

MimetypesFileTypeMap(String mimeTypeFileName)
用从指定文件中添加的编程条目构造 MimetypesFileTypeMap。

UnsupportedDataTypeException(String s)
构造带指定消息的 UnsupportedDataTypeException。

javax.activity 中 String 的使用

参数类型为 String 的 javax.activity 中的构造方法

ActivityCompletedException(String message)
构造带有指定详细消息的新实例。

ActivityCompletedException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。

ActivityRequiredException(String message)
构造带有指定详细消息的新实例。

ActivityRequiredException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。

InvalidActivityException(String message)
构造带有指定详细消息的新实例。

InvalidActivityException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。

javax.annotation 中 String 的使用

参数类型为 String 的 javax.annotation 中的方法

static Resource.AuthenticationType

Resource.AuthenticationType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.annotation.processing 中 String 的使用

返回 String 的 javax.annotation.processing 中的方法

String

Completion.getMessage()
返回包含许多有关 completion 信息的消息。

String

Completion.getValue()
返回建议 completion 的文本。

返回变量类型为 String 的类型的 javax.annotation.processing 中的方法

Map<String,String>

ProcessingEnvironment.getOptions()
返回传递给注释处理工具的特定于 processor 的选项。

Map<String,String>

ProcessingEnvironment.getOptions()
返回传递给注释处理工具的特定于 processor 的选项。

Set<String>

AbstractProcessor.getSupportedAnnotationTypes()
如果 processor 类是使用 SupportedAnnotationTypes 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。

Set<String>

Processor.getSupportedAnnotationTypes()
返回此 Processor 支持的注释类型的名称。

Set<String>

AbstractProcessor.getSupportedOptions()
如果 processor 类是使用 SupportedOptions 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。

Set<String>

Processor.getSupportedOptions()
返回此 Processor 识别的选项。

参数类型为 String 的 javax.annotation.processing 中的方法

Iterable<? extends Completion>

AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
返回一个空的 completion 迭代。

Iterable<? extends Completion>

Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
向工具框架返回某一注释的建议 completion 迭代。

static Completion

Completions.of(String value)
返回值和空消息的 completion。

static Completion

Completions.of(String value, String message)
返回值和消息的 completion。

参数类型为 String 的 javax.annotation.processing 中的构造方法

FilerException(String s)
构造带指定详细消息的异常。

javax.crypto 中 String 的使用

返回 String 的 javax.crypto 中的方法

String

EncryptedPrivateKeyInfo.getAlgName()
返回加密算法。

String

Cipher.getAlgorithm()
返回此 Cipher 对象的算法名称。

String

KeyAgreement.getAlgorithm()
返回此 KeyAgreement 对象的算法名称。

String

KeyGenerator.getAlgorithm()
返回此 KeyGenerator 对象的算法名称。

String

Mac.getAlgorithm()
返回此 Mac 对象的算法名称。

String

SecretKeyFactory.getAlgorithm()
返回此 SecretKeyFactory 对象的算法名称。

String

SealedObject.getAlgorithm()
返回用于密封此对象的算法。

String

ExemptionMechanism.getName()
返回此 ExemptionMechanism 对象的豁免机制名称。

参数类型为 String 的 javax.crypto 中的方法

protected abstract  SecretKey

KeyAgreementSpi.engineGenerateSecret(String algorithm)
创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。

protected abstract  void

CipherSpi.engineSetMode(String mode)
设置此 cipher 的模式。

protected abstract  void

CipherSpi.engineSetPadding(String padding)
设置此 cipher 的填充机制。

protected  Key

CipherSpi.engineUnwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
打开一个以前包装的密钥。

SecretKey

KeyAgreement.generateSecret(String algorithm)
创建共享秘密并将其作为指定算法的 SecretKey 对象返回。

static Cipher

Cipher.getInstance(String transformation)
返回实现指定转换的 Cipher 对象。

static ExemptionMechanism

ExemptionMechanism.getInstance(String algorithm)
返回实现指定豁免机制算法的 ExemptionMechanism 对象。

static KeyAgreement

KeyAgreement.getInstance(String algorithm)
返回实现指定密钥协定算法的 KeyAgreement 对象。

static KeyGenerator

KeyGenerator.getInstance(String algorithm)
返回生成指定算法的秘密密钥的 KeyGenerator 对象。

static Mac

Mac.getInstance(String algorithm)
返回实现指定 MAC 算法的 Mac 对象。

static SecretKeyFactory

SecretKeyFactory.getInstance(String algorithm)
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

static Cipher

Cipher.getInstance(String transformation, Provider provider)
返回实现指定转换的 Cipher 对象。

static ExemptionMechanism

ExemptionMechanism.getInstance(String algorithm, Provider provider)
返回实现指定豁免机制算法的 ExemptionMechanism 对象。

static KeyAgreement

KeyAgreement.getInstance(String algorithm, Provider provider)
返回实现指定密钥协定算法的 KeyAgreement 对象。

static KeyGenerator

KeyGenerator.getInstance(String algorithm, Provider provider)
返回生成指定算法的秘密密钥的 KeyGenerator 对象。

static Mac

Mac.getInstance(String algorithm, Provider provider)
返回实现指定 MAC 算法的 Mac 对象。

static SecretKeyFactory

SecretKeyFactory.getInstance(String algorithm, Provider provider)
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

static Cipher

Cipher.getInstance(String transformation, String provider)
返回实现指定转换的 Cipher 对象。

static ExemptionMechanism

ExemptionMechanism.getInstance(String algorithm, String provider)
返回实现指定豁免机制算法的 ExemptionMechanism 对象。

static KeyAgreement

KeyAgreement.getInstance(String algorithm, String provider)
返回实现指定密钥协定算法的 KeyAgreement 对象。

static KeyGenerator

KeyGenerator.getInstance(String algorithm, String provider)
返回生成指定算法的秘密密钥的 KeyGenerator 对象。

static Mac

Mac.getInstance(String algorithm, String provider)
返回实现指定 MAC 算法的 Mac 对象。

static SecretKeyFactory

SecretKeyFactory.getInstance(String algorithm, String provider)
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

PKCS8EncodedKeySpec

EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName)
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。

static int

Cipher.getMaxAllowedKeyLength(String transformation)
根据所安装的 JCE 仲裁策略文件，返回指定转换的最大密钥长度。

static AlgorithmParameterSpec

Cipher.getMaxAllowedParameterSpec(String transformation)
根据仲裁策略文件，返回包含最大 Cipher 参数值的 AlgorithmParameterSpec 对象。

Object

SealedObject.getObject(Key key, String provider)
获取原始（封装的）对象。

Key

Cipher.unwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
解包一个以前包装的密钥。

参数类型为 String 的 javax.crypto 中的构造方法

BadPaddingException(String msg)
构造带指定详细消息的 BadPaddingException。

Cipher(CipherSpi cipherSpi, Provider provider, String transformation)
创建 Cipher 对象。

EncryptedPrivateKeyInfo(String algName, byte[] encryptedData)
根据加密算法名称和加密数据构造 EncryptedPrivateKeyInfo。

ExemptionMechanism(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)
创建 ExemptionMechanism 对象。

ExemptionMechanismException(String msg)
构造带指定详细消息的 ExemptionMechanismException。

IllegalBlockSizeException(String msg)
构造带指定详细信息的 IllegalBlockSizeException。

KeyAgreement(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)
创建一个 KeyAgreement 对象。

KeyGenerator(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)
创建一个 KeyGenerator 对象。

Mac(MacSpi macSpi, Provider provider, String algorithm)
创建一个 MAC 对象。

NoSuchPaddingException(String msg)
构造带指定详细消息的 NoSuchPaddingException。

SecretKeyFactory(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 SecretKeyFactory 对象。

ShortBufferException(String msg)
构造带指定详细信息的 ShortBufferException。

javax.crypto.spec 中 String 的使用

返回 String 的 javax.crypto.spec 中的方法

String

SecretKeySpec.getAlgorithm()
返回与此密钥关联的算法的名称。

String

PSource.getAlgorithm()
返回 PSource 算法名称。

String

OAEPParameterSpec.getDigestAlgorithm()
返回信息摘要算法名称。

String

SecretKeySpec.getFormat()
返回此密钥编码格式的名称。

String

OAEPParameterSpec.getMGFAlgorithm()
返回掩码生成函数算法名称。

参数类型为 String 的 javax.crypto.spec 中的构造方法

OAEPParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)
使用指定的信息摘要算法 mdName、掩码生成函数算法 mgfName、掩码生成函数参数 mgfSpec 以及编码输入 P 源 pSrc 来为 PKCS #1 标准中定义的 OAEP 冗余构造一个参数集合。

PSource(String pSrcName)
使用指定的 PSource 算法为 PKCS #1 标准中定义的 OAEP 冗余构造一个编码输入 P 的源。

SecretKeySpec(byte[] key, int offset, int len, String algorithm)
根据给定的字节数组构造一个密钥，使用 key 中的始于且包含 offset 的前 len 个字节。

SecretKeySpec(byte[] key, String algorithm)
根据给定的字节数组构造一个密钥。

javax.imageio 中 String 的使用

声明为 String 的 javax.imageio 中的字段

protected  String

ImageWriteParam.compressionType
包含当前压缩类型名称的 String，如果没有设置压缩类型，则返回 null。

protected  String[]

ImageWriteParam.compressionTypes
包含可用压缩类型名称的 String 数组。

返回 String 的 javax.imageio 中的方法

String[]

ImageWriteParam.getCompressionQualityDescriptions()
返回一个 String 数组，可作为用户界面的一部分与 getCompressionQualityValues 一起使用，以设置或显示压缩质量级别。

String

ImageWriteParam.getCompressionType()
返回当前设置的压缩类型，如果没有设置任何压缩类型，则返回 null。

String[]

ImageWriteParam.getCompressionTypes()
以数组或 String 形式返回可用压缩类型的列表，如果不能使用这些接口选择压缩类型，则返回 null。

String

ImageReader.getFormatName()
返回一个标识输入源格式的 String。

String

ImageWriteParam.getLocalizedCompressionTypeName()
返回当前压缩类型的本地化名称，使用 getLocale 返回的 Locale。

static String[]

ImageIO.getReaderFileSuffixes()
返回一个 String 数组，该数组列出与当前已注册 reader 集合所理解的格式关联的所有文件后缀。

static String[]

ImageIO.getReaderFormatNames()
返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有非正式格式名称。

static String[]

ImageIO.getReaderMIMETypes()
返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有 MIME 类型。

static String[]

ImageIO.getWriterFileSuffixes()
返回一个 String 数组，该数组列出与当前已注册 writer 集合所理解的格式关联的所有文件后缀。

static String[]

ImageIO.getWriterFormatNames()
返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有非正式格式名称。

static String[]

ImageIO.getWriterMIMETypes()
返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有 MIME 类型。

参数类型为 String 的 javax.imageio 中的方法

IIOMetadata

ImageReader.getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames)
返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。

static Iterator<ImageReader>

ImageIO.getImageReadersByFormatName(String formatName)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码指定格式。

static Iterator<ImageReader>

ImageIO.getImageReadersByMIMEType(String MIMEType)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定 MIME 类型的文件。

static Iterator<ImageReader>

ImageIO.getImageReadersBySuffix(String fileSuffix)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定后缀的文件。

static Iterator<ImageWriter>

ImageIO.getImageWriters(ImageTypeSpecifier type, String formatName)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。

static Iterator<ImageWriter>

ImageIO.getImageWritersByFormatName(String formatName)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码指定格式。

static Iterator<ImageWriter>

ImageIO.getImageWritersByMIMEType(String MIMEType)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定 MIME 类型的文件。

static Iterator<ImageWriter>

ImageIO.getImageWritersBySuffix(String fileSuffix)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定后缀的文件。

IIOMetadata

ImageReader.getStreamMetadata(String formatName, Set<String> nodeNames)
返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。

protected  void

ImageWriter.processWarningOccurred(int imageIndex, String warning)
通过调用 warningOccurred 方法向所有已注册 IIOWriteWarningListener 广播一条警告消息。

protected  void

ImageWriter.processWarningOccurred(int imageIndex, String baseName, String keyword)
通过使用取自 ResourceBundle 的字符串调用 warningOccurred 方法来向所有已注册 IIOWriteWarningListener 广播一条本地化警告消息。

protected  void

ImageReader.processWarningOccurred(String warning)
通过调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播警告消息。

protected  void

ImageReader.processWarningOccurred(String baseName, String keyword)
通过使用取自 ResourceBundle 的字符串调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播本地化警告消息。

void

ImageWriteParam.setCompressionType(String compressionType)
将压缩类型设置为 getCompressionTypes 指示的值之一。

static boolean

ImageIO.write(RenderedImage im, String formatName, File output)
使用支持给定格式的任意 ImageWriter 将一个图像写入 File。

static boolean

ImageIO.write(RenderedImage im, String formatName, ImageOutputStream output)
使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。

static boolean

ImageIO.write(RenderedImage im, String formatName, OutputStream output)
使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。

类型变量类型为 String 的 javax.imageio 中的方法参数

IIOMetadata

ImageReader.getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames)
返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。

IIOMetadata

ImageReader.getStreamMetadata(String formatName, Set<String> nodeNames)
返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。

参数类型为 String 的 javax.imageio 中的构造方法

IIOException(String message)
构造带有给定消息 String 的 IIOException。

IIOException(String message, Throwable cause)
构造一个 IIOException，使其带有给定消息 String 以及作为其底层 cause 的 Throwable。

javax.imageio.event 中 String 的使用

参数类型为 String 的 javax.imageio.event 中的方法

void

IIOReadWarningListener.warningOccurred(ImageReader source, String warning)
报告在解码中发生非严重错误。

void

IIOWriteWarningListener.warningOccurred(ImageWriter source, int imageIndex, String warning)
报告在编码中发生非严重错误。

javax.imageio.metadata 中 String 的使用

声明为 String 的 javax.imageio.metadata 中的字段

protected  String[]

IIOMetadata.extraMetadataFormatClassNames
实现 IIOMetadataFormat 和表示此插件支持的元数据格式（标准格式和本机格式除外）的类的名称所组成的数组，初始化为 null，通过构造方法设置。

protected  String[]

IIOMetadata.extraMetadataFormatNames
此插件支持的格式（标准格式和本机格式除外）的名称所组成的数组，初始化为 null，通过构造方法设置。

protected  String

IIOMetadata.nativeMetadataFormatClassName
实现 IIOMetadataFormat 和表示本机元数据格式的类的名称，初始化为 null，通过构造方法设置。

protected  String

IIOMetadata.nativeMetadataFormatName
此对象本机元数据格式的名称，初始化为 null，通过构造方法设置。

static String

IIOMetadataFormatImpl.standardMetadataFormatName
包含标准格式名称 "javax_imageio_1.0" 的 String 常量。

返回 String 的 javax.imageio.metadata 中的方法

String

IIOMetadataNode.getAttribute(String name)

String

IIOMetadataFormat.getAttributeDefaultValue(String elementName, String attrName)
如果指定属性不显式存在于指定元素中，则以 String 的形式返回其默认值；如果不存在可用的默认值，则返回 null。

String

IIOMetadataFormatImpl.getAttributeDefaultValue(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeDescription(String elementName, String attrName, Locale locale)
返回包含指定属性的描述的 String，或者 null。

String

IIOMetadataFormatImpl.getAttributeDescription(String elementName, String attrName, Locale locale)
返回包含指定属性的描述的 String，或者 null。

String[]

IIOMetadataFormat.getAttributeEnumerations(String elementName, String attrName)
返回一个 String 数组，其包含指定元素中给定属性的合法枚举值。

String[]

IIOMetadataFormatImpl.getAttributeEnumerations(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMaxValue(String elementName, String attrName)
返回属性的最大合法值。

String

IIOMetadataFormatImpl.getAttributeMaxValue(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMinValue(String elementName, String attrName)
返回属性的最小合法值。

String

IIOMetadataFormatImpl.getAttributeMinValue(String elementName, String attrName)

String[]

IIOMetadataFormat.getAttributeNames(String elementName)
返回一个 String 数组，该数组列出了与指定元素关联的属性的名称。

String[]

IIOMetadataFormatImpl.getAttributeNames(String elementName)

String

IIOMetadataNode.getAttributeNS(String namespaceURI, String localName)
等效于 getAttribute(localName)。

String

IIOMetadataNode.getBaseURI()

String[]

IIOMetadataFormat.getChildNames(String elementName)
返回一个按出现顺序排列的 String 数组，指示允许作为指定元素子元素的元素的名称。

String[]

IIOMetadataFormatImpl.getChildNames(String elementName)

String

IIOMetadataFormat.getElementDescription(String elementName, Locale locale)
返回包含指定元素的描述的 String，或者 null。

String

IIOMetadataFormatImpl.getElementDescription(String elementName, Locale locale)
返回包含指定元素的描述的 String，或者 null。

String[]

IIOMetadata.getExtraMetadataFormatNames()
返回一个 String 数组，包含此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的其他元数据格式（本机格式和标准格式除外）的名称。

String

IIOMetadataNode.getLocalName()
等效于 getNodeName。

String[]

IIOMetadata.getMetadataFormatNames()
返回一个 String 数组，包含包括此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的所有元数据格式（包括本机格式和标准格式）的名称。

String

IIOMetadataNode.getNamespaceURI()
返回 null，因为不支持名称空间。

String

IIOMetadata.getNativeMetadataFormatName()
返回此插件的“本机”元数据格式的名称，该格式通常允许无损失地编码和传输以此插件处理的格式存储的元数据。

String

IIOMetadataNode.getNodeName()
返回与此节点关联的节点名称。

String

IIOMetadataNode.getNodeValue()

String

IIOMetadataNode.getPrefix()
返回 null，因为不支持名称空间。

protected  String

IIOMetadataFormatImpl.getResourceBaseName()
返回当前设置的用于查找 ResourceBundle 的基本名称。

String

IIOMetadataFormat.getRootName()
返回格式的根元素的名称。

String

IIOMetadataFormatImpl.getRootName()

String

IIOMetadataNode.getTagName()

String

IIOMetadataNode.getTextContent()

String

IIOMetadataNode.lookupNamespaceURI(String prefix)

String

IIOMetadataNode.lookupPrefix(String namespaceURI)

参数类型为 String 的 javax.imageio.metadata 中的方法

protected  void

IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, int listMinLength, int listMaxLength)
将新属性添加到以前定义的元素中，该元素将由值的列表定义。

protected  void

IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue)
将新属性添加到以前定义的可以被设置为任意值的元素中。

protected  void

IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)
将新属性添加到以前定义的元素中，该元素将由一组枚举值定义。

protected  void

IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue, String minValue, String maxValue, boolean minInclusive, boolean maxInclusive)
将新属性添加到以前定义的元素中，该元素将由一系列值定义。

protected  void

IIOMetadataFormatImpl.addBooleanAttribute(String elementName, String attrName, boolean hasDefaultValue, boolean defaultValue)
将新属性添加到以前定义的元素中，该元素将由枚举值 TRUE 和 FALSE 定义，数据类型为 DATATYPE_BOOLEAN。

protected  void

IIOMetadataFormatImpl.addChildElement(String elementName, String parentName)
将现有元素添加到给定父节点类型的合法子节点的列表中。

protected  void

IIOMetadataFormatImpl.addElement(String elementName, String parentName, int childPolicy)
使用某个子策略（CHILD_POLICY_REPEAT 除外）将新元素类型添加到此元数据文档格式中。

protected  void

IIOMetadataFormatImpl.addElement(String elementName, String parentName, int minChildren, int maxChildren)
使用子策略 CHILD_POLICY_REPEAT 将新元素类型添加到此元数据文档格式中。

protected  void

IIOMetadataFormatImpl.addObjectValue(String elementName, Class<?> classType, int arrayMinLength, int arrayMaxLength)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

protected

<T> void

IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

protected

<T> void

IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

protected

<T extends Object & Comparable<? super T>>
void

IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

boolean

IIOMetadataFormat.canNodeAppear(String elementName, ImageTypeSpecifier imageType)
如果允许元素（和它下面的子树）在给定类型（由 ImageTypeSpecifier 定义）的图像的元数据文档中出现，则返回 true。

abstract  boolean

IIOMetadataFormatImpl.canNodeAppear(String elementName, ImageTypeSpecifier imageType)

abstract  Node

IIOMetadata.getAsTree(String formatName)
返回 XML DOM Node 对象，该对象表示此对象所包含的元数据树的根（根据给定元数据格式定义的约定）。

String

IIOMetadataNode.getAttribute(String name)

int

IIOMetadataFormat.getAttributeDataType(String elementName, String attrName)
返回以 DATATYPE_ 开头的常量之一，指示指定元素中给定属性的值的格式和解释。

int

IIOMetadataFormatImpl.getAttributeDataType(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeDefaultValue(String elementName, String attrName)
如果指定属性不显式存在于指定元素中，则以 String 的形式返回其默认值；如果不存在可用的默认值，则返回 null。

String

IIOMetadataFormatImpl.getAttributeDefaultValue(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeDescription(String elementName, String attrName, Locale locale)
返回包含指定属性的描述的 String，或者 null。

String

IIOMetadataFormatImpl.getAttributeDescription(String elementName, String attrName, Locale locale)
返回包含指定属性的描述的 String，或者 null。

String[]

IIOMetadataFormat.getAttributeEnumerations(String elementName, String attrName)
返回一个 String 数组，其包含指定元素中给定属性的合法枚举值。

String[]

IIOMetadataFormatImpl.getAttributeEnumerations(String elementName, String attrName)

int

IIOMetadataFormat.getAttributeListMaxLength(String elementName, String attrName)
返回可用于定义此属性的最大列表项数。

int

IIOMetadataFormatImpl.getAttributeListMaxLength(String elementName, String attrName)

int

IIOMetadataFormat.getAttributeListMinLength(String elementName, String attrName)
返回可用于定义此属性的最小列表项数。

int

IIOMetadataFormatImpl.getAttributeListMinLength(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMaxValue(String elementName, String attrName)
返回属性的最大合法值。

String

IIOMetadataFormatImpl.getAttributeMaxValue(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMinValue(String elementName, String attrName)
返回属性的最小合法值。

String

IIOMetadataFormatImpl.getAttributeMinValue(String elementName, String attrName)

String[]

IIOMetadataFormat.getAttributeNames(String elementName)
返回一个 String 数组，该数组列出了与指定元素关联的属性的名称。

String[]

IIOMetadataFormatImpl.getAttributeNames(String elementName)

Attr

IIOMetadataNode.getAttributeNode(String name)

Attr

IIOMetadataNode.getAttributeNodeNS(String namespaceURI, String localName)
等效于 getAttributeNode(localName)。

String

IIOMetadataNode.getAttributeNS(String namespaceURI, String localName)
等效于 getAttribute(localName)。

int

IIOMetadataFormat.getAttributeValueType(String elementName, String attrName)
返回以 VALUE_ 开头的常量之一，指示指定元素中给定属性的值是任意值、被限制在指定范围中的值、被限制为一组枚举值之一，还是一个任意值的以空白分隔的列表。

int

IIOMetadataFormatImpl.getAttributeValueType(String elementName, String attrName)

String[]

IIOMetadataFormat.getChildNames(String elementName)
返回一个按出现顺序排列的 String 数组，指示允许作为指定元素子元素的元素的名称。

String[]

IIOMetadataFormatImpl.getChildNames(String elementName)

int

IIOMetadataFormat.getChildPolicy(String elementName)
返回以 CHILD_POLICY_ 开头的常量之一，指示指定元素子元素的合法模式。

int

IIOMetadataFormatImpl.getChildPolicy(String elementName)

String

IIOMetadataFormat.getElementDescription(String elementName, Locale locale)
返回包含指定元素的描述的 String，或者 null。

String

IIOMetadataFormatImpl.getElementDescription(String elementName, Locale locale)
返回包含指定元素的描述的 String，或者 null。

int

IIOMetadataFormat.getElementMaxChildren(String elementName)
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最大子元素数。

int

IIOMetadataFormatImpl.getElementMaxChildren(String elementName)

int

IIOMetadataFormat.getElementMinChildren(String elementName)
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最小子元素数。

int

IIOMetadataFormatImpl.getElementMinChildren(String elementName)

NodeList

IIOMetadataNode.getElementsByTagName(String name)

NodeList

IIOMetadataNode.getElementsByTagNameNS(String namespaceURI, String localName)
等效于 getElementsByTagName(localName)。

Object

IIOMetadataNode.getFeature(String feature, String version)

IIOMetadataFormat

IIOMetadata.getMetadataFormat(String formatName)
返回描述给定元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。

int

IIOMetadataFormat.getObjectArrayMaxLength(String elementName)
返回指定元素中可用于定义 Object 引用的最大数组元素数。

int

IIOMetadataFormatImpl.getObjectArrayMaxLength(String elementName)

int

IIOMetadataFormat.getObjectArrayMinLength(String elementName)
返回指定元素中可用于定义 Object 引用的最小数组元素数。

int

IIOMetadataFormatImpl.getObjectArrayMinLength(String elementName)

Class<?>

IIOMetadataFormat.getObjectClass(String elementName)
返回存储在元素中的 Class 类型的 Object 引用。

Class<?>

IIOMetadataFormatImpl.getObjectClass(String elementName)

Object

IIOMetadataFormat.getObjectDefaultValue(String elementName)
返回包含指定元素中 Object 引用的默认值的 Object。

Object

IIOMetadataFormatImpl.getObjectDefaultValue(String elementName)

Object[]

IIOMetadataFormat.getObjectEnumerations(String elementName)
返回一个 Object 数组，该数组包含指定元素中 Object 引用的合法枚举值。

Object[]

IIOMetadataFormatImpl.getObjectEnumerations(String elementName)

Comparable<?>

IIOMetadataFormat.getObjectMaxValue(String elementName)
返回指定元素中 Object 引用的最大合法值。

Comparable<?>

IIOMetadataFormatImpl.getObjectMaxValue(String elementName)

Comparable<?>

IIOMetadataFormat.getObjectMinValue(String elementName)
返回指定元素中 Object 引用的最小合法值。

Comparable<?>

IIOMetadataFormatImpl.getObjectMinValue(String elementName)

int

IIOMetadataFormat.getObjectValueType(String elementName)
返回以 VALUE_ 开头的枚举值之一，指示允许用于 Object 引用的值（枚举、范围或数组）的类型。

int

IIOMetadataFormatImpl.getObjectValueType(String elementName)

Object

IIOMetadataNode.getUserData(String key)

boolean

IIOMetadataNode.hasAttribute(String name)

boolean

IIOMetadataNode.hasAttributeNS(String namespaceURI, String localName)
等效于 hasAttribute(localName)。

boolean

IIOMetadataFormat.isAttributeRequired(String elementName, String attrName)
如果指定属性必须在指定元素中存在，则返回 true。

boolean

IIOMetadataFormatImpl.isAttributeRequired(String elementName, String attrName)

boolean

IIOMetadataNode.isDefaultNamespace(String namespaceURI)

boolean

IIOMetadataNode.isSupported(String feature, String version)
返回 false，因为不支持 DOM 功能。

String

IIOMetadataNode.lookupNamespaceURI(String prefix)

String

IIOMetadataNode.lookupPrefix(String namespaceURI)

abstract  void

IIOMetadata.mergeTree(String formatName, Node root)
根据 XML DOM Node 树（其语法由给定元数据格式定义）改变此 IIOMetadata 对象的内部状态。

void

IIOMetadataNode.removeAttribute(String name)

protected  void

IIOMetadataFormatImpl.removeAttribute(String elementName, String attrName)
从以前定义的元素中移除属性。

void

IIOMetadataNode.removeAttributeNS(String namespaceURI, String localName)
等效于 removeAttribute(localName)。

protected  void

IIOMetadataFormatImpl.removeElement(String elementName)
从格式中移除元素。

protected  void

IIOMetadataFormatImpl.removeObjectValue(String elementName)
禁止将 Object 引用存储在实现指定元素的节点中。

void

IIOMetadataNode.setAttribute(String name, String value)

void

IIOMetadataNode.setAttributeNS(String namespaceURI, String qualifiedName, String value)
等效于 setAttribute(qualifiedName, value)。

void

IIOMetadata.setFromTree(String formatName, Node root)
根据 XML DOM Node 的树（其语法由给定元数据格式定义）设置此 IIOMetadata 对象的内部状态。

void

IIOMetadataNode.setIdAttribute(String name, boolean isId)

void

IIOMetadataNode.setIdAttributeNS(String namespaceURI, String localName, boolean isId)

void

IIOMetadataNode.setNodeValue(String nodeValue)

void

IIOMetadataNode.setPrefix(String prefix)
不执行任何操作，因为不支持名称空间。

protected  void

IIOMetadataFormatImpl.setResourceBaseName(String resourceBaseName)
设置用于查找包含此格式的元素和属性描述的 ResourceBundle 新基本名称。

void

IIOMetadataNode.setTextContent(String textContent)

Object

IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)

类型变量类型为 String 的 javax.imageio.metadata 中的方法参数

protected  void

IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)
将新属性添加到以前定义的元素中，该元素将由一组枚举值定义。

参数类型为 String 的 javax.imageio.metadata 中的构造方法

IIOInvalidTreeException(String message, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串和对导致解析错误的 Node 的引用。

IIOInvalidTreeException(String message, Throwable cause, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串、对导致此异常的异常的引用和导致解析错误的 Node 的引用。

IIOMetadata(boolean standardMetadataFormatSupported, String nativeMetadataFormatName, String nativeMetadataFormatClassName, String[] extraMetadataFormatNames, String[] extraMetadataFormatClassNames)
构造一个 IIOMetadata 对象，使其带有给定格式名称和格式类名称，以及指示是否支持标准格式的 boolean 值。

IIOMetadata(boolean standardMetadataFormatSupported, String nativeMetadataFormatName, String nativeMetadataFormatClassName, String[] extraMetadataFormatNames, String[] extraMetadataFormatClassNames)
构造一个 IIOMetadata 对象，使其带有给定格式名称和格式类名称，以及指示是否支持标准格式的 boolean 值。

IIOMetadata(boolean standardMetadataFormatSupported, String nativeMetadataFormatName, String nativeMetadataFormatClassName, String[] extraMetadataFormatNames, String[] extraMetadataFormatClassNames)
构造一个 IIOMetadata 对象，使其带有给定格式名称和格式类名称，以及指示是否支持标准格式的 boolean 值。

IIOMetadataFormatImpl(String rootName, int childPolicy)
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略（CHILD_POLICY_REPEAT 除外）。

IIOMetadataFormatImpl(String rootName, int minChildren, int maxChildren)
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略 CHILD_POLICY_REPEAT。

IIOMetadataNode(String nodeName)
构造一个具有给定节点名称的 IIOMetadataNode。

javax.imageio.plugins.jpeg 中 String 的使用

返回 String 的 javax.imageio.plugins.jpeg 中的方法

String[]

JPEGImageWriteParam.getCompressionQualityDescriptions()

String

JPEGHuffmanTable.toString()

String

JPEGQTable.toString()

javax.imageio.spi 中 String 的使用

声明为 String 的 javax.imageio.spi 中的字段

protected  String[]

ImageReaderWriterSpi.extraImageMetadataFormatClassNames
包含此插件支持的其他任何图像元数据格式的类名称的 String 数组，该数组最初为 null。

protected  String[]

ImageReaderWriterSpi.extraImageMetadataFormatNames
包含此插件支持的其他任何图像元数据格式的名称的 String 数组，该数组最初为 null。

protected  String[]

ImageReaderWriterSpi.extraStreamMetadataFormatClassNames
包含此插件支持的其他任何流元数据格式的类名称的 String 数组，该数组最初为 null。

protected  String[]

ImageReaderWriterSpi.extraStreamMetadataFormatNames
包含此插件支持的其他任何流元数据格式的名称的 String 数组，该字符串最初为 null。

protected  String[]

ImageReaderWriterSpi.MIMETypes
从 getMIMETypes 返回的字符串数组，该数组最初为 null。

protected  String[]

ImageReaderWriterSpi.names
从 getFormatNames 返回的字符串数组，该数组最初为 null。

protected  String

ImageReaderWriterSpi.nativeImageMetadataFormatClassName
包含此插件支持的本地流元数据格式的类名称的 String，该字符串最初为 null。

protected  String

ImageReaderWriterSpi.nativeImageMetadataFormatName
包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。

protected  String

ImageReaderWriterSpi.nativeStreamMetadataFormatClassName
包含此插件支持的本地流元数据格式的类名称的 String，初始为 null。

protected  String

ImageReaderWriterSpi.nativeStreamMetadataFormatName
包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。

protected  String

ImageReaderWriterSpi.pluginClassName
包含关联的插件类名称的 String，该字符串最初为 null。

protected  String[]

ImageWriterSpi.readerSpiNames
将从 getImageReaderSpiNames 返回的字符串数组，该数组最初为 null。

protected  String[]

ImageReaderWriterSpi.suffixes
从 getFileSuffixes 返回的字符串数组，该数组最初为 null。

protected  String

IIOServiceProvider.vendorName
将从 getVendorName 返回的一个 String，初始值为 null。

protected  String

IIOServiceProvider.version
将从 getVersion 返回的一个 String，初始值为 null。

protected  String[]

ImageReaderSpi.writerSpiNames
将从 getImageWriterSpiNames 返回的字符串数组，该数组最初为 null。

返回 String 的 javax.imageio.spi 中的方法

abstract  String

IIOServiceProvider.getDescription(Locale locale)
返回此服务提供者及其相关实现的一个简明的可读描述。

String[]

ImageReaderWriterSpi.getExtraImageMetadataFormatNames()
返回包含其他文档格式名称，而不是此插件生成或使用的图像元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。

String[]

ImageReaderWriterSpi.getExtraStreamMetadataFormatNames()
返回包含其他文档格式名称，而不是此插件生成或使用的流元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。

String[]

ImageReaderWriterSpi.getFileSuffixes()
返回一个包含通常可由与此服务提供者关联的 ImageReader 或 ImageWriter 实现所用格式所关联文件后缀列表的 String 数组。

String[]

ImageReaderWriterSpi.getFormatNames()
返回一个 String 数组，该数组包含通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的那些格式的可读名称。

String[]

ImageWriterSpi.getImageReaderSpiNames()
返回一个 String 数组，该数组包含所有能够理解由与此服务提供者关联的 ImageWriter 使用的内部元数据表示形式的 ImageReaderSpi 类的完全限定名。

String[]

ImageReaderSpi.getImageWriterSpiNames()
返回一个 String 数组，其包含所有能够理解由与此服务提供者关联的 ImageReader 使用的内部元数据表示形式的 ImageWriterSpi 类的完全限定名。

String[]

ImageReaderWriterSpi.getMIMETypes()
返回一个 String 数组，该数组包含与通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的格式有关的 MIME 类型的列表。

String

ImageReaderWriterSpi.getNativeImageMetadataFormatName()
返回此插件的“本地”图像元数据格式的名称，它通常允许无损失地编码或传输按照由此插件处理的格式存储的图像元数据。

String

ImageReaderWriterSpi.getNativeStreamMetadataFormatName()
返回此插件的“本地”流元数据格式的名称，它通常允许无损失地编码和传输按照由此插件处理的格式存储的流元数据。

String

ImageReaderWriterSpi.getPluginClassName()
返回与此服务提供者关联的 ImageReader 或 ImageWriter 插件的完全限定类名称。

abstract  String

ImageTranscoderSpi.getReaderServiceProviderName()
返回 ImageReaderSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。

String

IIOServiceProvider.getVendorName()
返回负责创建此服务提供者及其相关实现的供应商名称。

String

IIOServiceProvider.getVersion()
返回描述此服务提供者版本号及其相关实现的字符串。

abstract  String

ImageTranscoderSpi.getWriterServiceProviderName()
返回 ImageWriterSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。

参数类型为 String 的 javax.imageio.spi 中的方法

IIOMetadataFormat

ImageReaderWriterSpi.getImageMetadataFormat(String formatName)
返回描述给定的图像元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。

IIOMetadataFormat

ImageReaderWriterSpi.getStreamMetadataFormat(String formatName)
返回描述给定的流元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。

参数类型为 String 的 javax.imageio.spi 中的构造方法

IIOServiceProvider(String vendorName, String version)
构造一个具有给定供应商名称和版本标识符的 IIOServiceProvider。

ImageInputStreamSpi(String vendorName, String version, Class<?> inputClass)
用给定的一组值构造 ImageInputStreamSpi。

ImageOutputStreamSpi(String vendorName, String version, Class<?> outputClass)
用给定的一组值构造 ImageOutputStreamSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageTranscoderSpi(String vendorName, String version)
用给定的一组值构造 ImageTranscoderSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

javax.imageio.stream 中 String 的使用

返回 String 的 javax.imageio.stream 中的方法

String

ImageInputStream.readLine()
从输入流中读取文本的下一行。

String

ImageInputStreamImpl.readLine()

String

ImageInputStream.readUTF()
读入一个已使用 UTF-8 修改版格式编码的字符串。

String

ImageInputStreamImpl.readUTF()

参数类型为 String 的 javax.imageio.stream 中的方法

void

ImageOutputStream.writeBytes(String s)
将一个字符串写入输出流。

void

ImageOutputStreamImpl.writeBytes(String s)

void

ImageOutputStream.writeChars(String s)
将一个字符串写入输出流。

void

ImageOutputStreamImpl.writeChars(String s)

void

ImageOutputStream.writeUTF(String s)
将表示长度信息的两个字节按网络字节顺序写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。

void

ImageOutputStreamImpl.writeUTF(String s)

javax.jws 中 String 的使用

参数类型为 String 的 javax.jws 中的方法

static WebParam.Mode

WebParam.Mode.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.jws.soap 中 String 的使用

参数类型为 String 的 javax.jws.soap 中的方法

static SOAPBinding.Style

SOAPBinding.Style.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static SOAPBinding.Use

SOAPBinding.Use.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static SOAPBinding.ParameterStyle

SOAPBinding.ParameterStyle.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.lang.model 中 String 的使用

参数类型为 String 的 javax.lang.model 中的方法

static SourceVersion

SourceVersion.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.lang.model.element 中 String 的使用

返回 String 的 javax.lang.model.element 中的方法

String

AnnotationValue.toString()
返回此值的字符串表示形式。

String

Modifier.toString()
返回此修饰符的小写名称。

参数类型为 String 的 javax.lang.model.element 中的方法

static ElementKind

ElementKind.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Modifier

Modifier.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static NestingKind

NestingKind.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

R

AnnotationValueVisitor.visitString(String s, P p)
访问注释中的 string 值。

javax.lang.model.type 中 String 的使用

返回 String 的 javax.lang.model.type 中的方法

String

TypeMirror.toString()
返回包含此类型许多信息的字符串表示形式。

参数类型为 String 的 javax.lang.model.type 中的方法

static TypeKind

TypeKind.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.lang.model.util 中 String 的使用

返回 String 的 javax.lang.model.util 中的方法

String

Elements.getConstantExpression(Object value)
返回表示基本值或字符串的常量表达式 文本。

String

Elements.getDocComment(Element e)
返回元素的文档（"Javadoc"）注释文本。

参数类型为 String 的 javax.lang.model.util 中的方法

R

SimpleAnnotationValueVisitor6.visitString(String s, P p)
访问注释中的 string 值。

javax.management 中 String 的使用

声明为 String 的 javax.management 中的字段

static String

AttributeChangeNotification.ATTRIBUTE_CHANGE
通知类型，指示所观察的 MBean 属性值已更改。

static String

JMX.DEFAULT_VALUE_FIELD
defaultValue 字段的名称。

protected  String

MBeanFeatureInfo.description
该功能的可读描述。

static String

JMX.IMMUTABLE_INFO_FIELD
immutableInfo 字段的名称。

static String

JMX.INTERFACE_CLASS_NAME_FIELD
interfaceClassName 字段的名称。

static String

JMX.LEGAL_VALUES_FIELD
legalValues 字段的名称。

static String

JMX.MAX_VALUE_FIELD
maxValue 字段的名称。

static String

JMX.MIN_VALUE_FIELD
minValue 字段的名称。

static String

JMX.MXBEAN_FIELD
mxbean 字段的名称。

protected  String

MBeanFeatureInfo.name
该功能的名称。

static String

JMX.OPEN_TYPE_FIELD
openType 字段的名称。

static String

JMX.ORIGINAL_TYPE_FIELD
originalType 字段的名称。

static String

MBeanServerNotification.REGISTRATION_NOTIFICATION
表示已注册该 MBean 的通知类型。

static String

MBeanServerNotification.UNREGISTRATION_NOTIFICATION
表示已注销该 MBean 的通知类型。

返回 String 的 javax.management 中的方法

String

MBeanPermission.getActions()
返回操作的“规范化字符串表示形式”。

String

AttributeChangeNotification.getAttributeName()
获得已更改属性的名称。

String

AttributeValueExp.getAttributeName()
返回该属性名称的字符串表示形式。

String

AttributeChangeNotification.getAttributeType()
获得已更改属性的类型。

String

ObjectName.getCanonicalKeyPropertyListString()
返回键属性列表的字符串表示形式，其中键属性按词汇顺序排序。

String

ObjectName.getCanonicalName()
返回该名称的规范形式；也就是说，一种字符串表示形式，其中属性按词汇顺序排序。

String

MBeanInfo.getClassName()
返回此 MBeanInfo 描述的 MBean 的 Java 类名。

String

ObjectInstance.getClassName()
返回类部分。

protected  String

StandardMBean.getClassName(MBeanInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 className。

String

MBeanServer.getDefaultDomain()

String

MBeanServerConnection.getDefaultDomain()
返回对 MBean 命名时使用的默认域。

String

MBeanFeatureInfo.getDescription()
返回该功能的可读描述。

String

MBeanInfo.getDescription()
返回该 MBean 的可读描述。

protected  String

StandardMBean.getDescription(MBeanAttributeInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanAttributeInfo 中使用的描述。

protected  String

StandardMBean.getDescription(MBeanConstructorInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanConstructorInfo 中使用的描述。

protected  String

StandardMBean.getDescription(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的描述。

protected  String

StandardMBean.getDescription(MBeanFeatureInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanFeatureInfo 中使用的描述。

protected  String

StandardMBean.getDescription(MBeanInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的描述。

protected  String

StandardMBean.getDescription(MBeanOperationInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的描述。

protected  String

StandardMBean.getDescription(MBeanOperationInfo op, MBeanParameterInfo param, int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的描述。

String

ObjectName.getDomain()
返回域部分。

String[]

MBeanServer.getDomains()

String[]

MBeanServerConnection.getDomains()
返回其中所有 MBean 当前已注册的域的列表。

String[]

Descriptor.getFieldNames()
返回描述符中的所有字段名。

String[]

ImmutableDescriptor.getFieldNames()

String[]

Descriptor.getFields()
以 string 数组的形式返回此 descriptor 中所包含的所有字段。

String[]

ImmutableDescriptor.getFields()

String

MBeanServerDelegate.getImplementationName()
返回 JMX 实现的名称（此产品的名称）。

String

MBeanServerDelegateMBean.getImplementationName()
返回 JMX 实现名（此产品的名称）。

String

MBeanServerDelegate.getImplementationVendor()
返回 JMX 实现供应商（此产品的供应商）。

String

MBeanServerDelegateMBean.getImplementationVendor()
返回 JMX 实现供应商（此产品的供应商）。

String

MBeanServerDelegate.getImplementationVersion()
返回 JMX 实现的版本（此产品的版本）。

String

MBeanServerDelegateMBean.getImplementationVersion()
返回 JMX 实现版本（此产品的版本）。

String

ObjectName.getKeyProperty(String property)
获得与键属性中某个键相关联的值。

String

ObjectName.getKeyPropertyListString()
返回创建时指定的键属性列表的字符串表示形式。

String

MBeanServerDelegate.getMBeanServerId()
返回 MBean 服务器代理标识。

String

MBeanServerDelegateMBean.getMBeanServerId()
返回 MBean 服务器代理标识。

String

Notification.getMessage()
获得通知消息。

String

Attribute.getName()
返回包含该 Attribute 的名称的 String。

String

MBeanFeatureInfo.getName()
返回该功能的名称。

String[]

MBeanNotificationInfo.getNotifTypes()
返回包含 MBean 可发出的通知类型的字符串数组（用点表示）。

protected  String

StandardMBean.getParameterName(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的名称。

protected  String

StandardMBean.getParameterName(MBeanOperationInfo op, MBeanParameterInfo param, int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的名称。

String

MBeanOperationInfo.getReturnType()
返回该方法的返回值的类型。

String

MBeanServerDelegate.getSpecificationName()
返回此产品实现的 JMX 规范的全名。

String

MBeanServerDelegateMBean.getSpecificationName()
返回此产品实现的 JMX 规范的全名。

String

MBeanServerDelegate.getSpecificationVendor()
返回此产品实现的 JMX 规范的供应商。

String

MBeanServerDelegateMBean.getSpecificationVendor()
返回此产品实现的 JMX 规范的供应商。

String

MBeanServerDelegate.getSpecificationVersion()
返回此产品实现的 JMX 规范的版本。

String

MBeanServerDelegateMBean.getSpecificationVersion()
返回此产品实现的 JMX 规范的版本。

String

MBeanAttributeInfo.getType()
返回该属性的类名。

String

MBeanParameterInfo.getType()
返回该数据的类型或类名。

String

Notification.getType()
获得通知类型。

String

StringValueExp.getValue()
返回由 StringValueExp 实例表示的字符串。

static String

ObjectName.quote(String s)
返回给定 String 的有引号形式，使之适合包含在 ObjectName 中。

String

Attribute.toString()
返回一个表示此 Attribute 值 String 对象。

String

AttributeValueExp.toString()
返回表示其值的字符串。

String

BadAttributeValueExpException.toString()
返回该对象的字符串表示形式。

String

BadBinaryOpValueExpException.toString()
返回该对象的字符串表示形式。

String

BadStringOperationException.toString()
返回该对象的字符串表示形式。

String

ImmutableDescriptor.toString()

String

MBeanAttributeInfo.toString()

String

MBeanConstructorInfo.toString()

String

MBeanInfo.toString()

String

MBeanNotificationInfo.toString()

String

MBeanOperationInfo.toString()

String

MBeanParameterInfo.toString()

String

Notification.toString()
返回此通知的字符串表示形式。

String

ObjectInstance.toString()
返回表示此 ObjectInstance 对象字符串。

String

ObjectName.toString()
返回该对象名的字符串表示形式。

String

StringValueExp.toString()
返回表示对象的字符串。

static String

ObjectName.unquote(String q)
返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。

返回变量类型为 String 的类型的 javax.management 中的方法

Vector<String>

AttributeChangeNotificationFilter.getEnabledAttributes()
获得此过滤器的所有已启用属性名称。

Vector<String>

NotificationFilterSupport.getEnabledTypes()
获得此过滤器的所有允许通知类型。

Hashtable<String,String>

ObjectName.getKeyPropertyList()
以哈希表的形式返回键属性。

Hashtable<String,String>

ObjectName.getKeyPropertyList()
以哈希表的形式返回键属性。

参数类型为 String 的 javax.management 中的方法

static AttributeValueExp

Query.attr(String name)
返回新的属性表达式。

static AttributeValueExp

Query.attr(String className, String name)
返回新的限定属性表达式。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

static MBeanServer

MBeanServerFactory.createMBeanServer(String domain)
返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口。

ObjectInputStream

MBeanServer.deserialize(String className, byte[] data)
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。

ObjectInputStream

MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。

void

AttributeChangeNotificationFilter.disableAttribute(String name)
禁用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定属性名称。

void

NotificationFilterSupport.disableType(String prefix)
从前缀列表中移除给定的前缀。

void

AttributeChangeNotificationFilter.enableAttribute(String name)
启用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定名称。

void

NotificationFilterSupport.enableType(String prefix)
允许将其类型以指定前缀开始的所有通知发送到该侦听器。

static ArrayList<MBeanServer>

MBeanServerFactory.findMBeanServer(String agentId)
返回已注册 MBeanServer 对象的列表。

Object

MBeanServer.getAttribute(ObjectName name, String attribute)

Object

MBeanServerConnection.getAttribute(ObjectName name, String attribute)
获得指定 MBean 的特定属性值。

Object

DynamicMBean.getAttribute(String attribute)
获得 Dynamic MBean 的特定属性的值。

Object

StandardMBean.getAttribute(String attribute)

AttributeList

MBeanServer.getAttributes(ObjectName name, String[] attributes)

AttributeList

MBeanServerConnection.getAttributes(ObjectName name, String[] attributes)
获得指定 MBean 的多个属性值。

AttributeList

DynamicMBean.getAttributes(String[] attributes)
获得 Dynamic MBean 多个属性的值。

AttributeList

StandardMBean.getAttributes(String[] attributes)

Object

Descriptor.getFieldValue(String fieldName)
返回指定字段名的值，如果该名称不存在任何值，则返回 null。

Object

ImmutableDescriptor.getFieldValue(String fieldName)

Object[]

Descriptor.getFieldValues(String... fieldNames)
以 Object 数组的形式返回该 descriptor 中的所有字段值。

Object[]

ImmutableDescriptor.getFieldValues(String... fieldNames)

static ObjectName

ObjectName.getInstance(String name)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。

static ObjectName

ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。

static ObjectName

ObjectName.getInstance(String domain, String key, String value)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。

String

ObjectName.getKeyProperty(String property)
获得与键属性中某个键相关联的值。

Object

MBeanServer.instantiate(String className)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。

Object

MBeanServer.instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。

Object

MBeanServer.instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName)
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。

Object

MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。

Object

MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。

Object

DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
允许在 Dynamic MBean 上调用某个操作。

Object

DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
允许在 Dynamic MBean 上调用某个操作。

Object

StandardMBean.invoke(String actionName, Object[] params, String[] signature)

Object

StandardMBean.invoke(String actionName, Object[] params, String[] signature)

boolean

MBeanServer.isInstanceOf(ObjectName name, String className)

boolean

MBeanServerConnection.isInstanceOf(ObjectName name, String className)
如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。

boolean

ObjectName.isPropertyValuePattern(String property)
检查键属性中与值关联的值是否为一个模式。

static Class

DefaultLoaderRepository.loadClass(String className)
已过时。 仔细检查类加载器列表，并尝试加载所请求的类。

static Class

DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className)
已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。

static MBeanServer

MBeanServerFactory.newMBeanServer(String domain)
返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。

MBeanServer

MBeanServerBuilder.newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate)
此方法创建一个新的 MBeanServer 实现对象。

static String

ObjectName.quote(String s)
返回给定 String 的有引号形式，使之适合包含在 ObjectName 中。

void

Descriptor.removeField(String fieldName)
从该 descriptor 中删除字段。

void

ImmutableDescriptor.removeField(String fieldName)
从描述符移除字段。

void

Descriptor.setField(String fieldName, Object fieldValue)
设置特定字段名的值。

void

ImmutableDescriptor.setField(String fieldName, Object fieldValue)
因为此类不可变，所以不支持此操作。

void

Descriptor.setFields(String[] fieldNames, Object[] fieldValues)
将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。

void

ImmutableDescriptor.setFields(String[] fieldNames, Object[] fieldValues)
因为此类不可变，所以不支持此操作。

static String

ObjectName.unquote(String q)
返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。

static StringValueExp

Query.value(String val)
返回一个新的字符串表达式。

类型变量类型为 String 的 javax.management 中的方法参数

static ObjectName

ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。

static ObjectName

ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。

参数类型为 String 的 javax.management 中的构造方法

Attribute(String name, Object value)
构造将给定的属性名与给定值相关联的 Attribute 对象。

AttributeChangeNotification(Object source, long sequenceNumber, long timeStamp, String msg, String attributeName, String attributeType, Object oldValue, Object newValue)
构造一个 AttributeChangeNotification 对象。

AttributeNotFoundException(String message)
允许指定具体错误消息的构造方法。

AttributeValueExp(String attr)
创建一个表示指定对象属性 attr 的新 AttributeValueExp。

BadStringOperationException(String message)
构造带指定详细消息的 BadStringOperationException。

ImmutableDescriptor(String... fields)
构造包含给定字段的描述符。

ImmutableDescriptor(String[] fieldNames, Object[] fieldValues)
构造包含给定字段和值的描述符。

InstanceAlreadyExistsException(String message)
允许指定特定错误消息的构造方法。

InstanceNotFoundException(String message)
允许指定特定错误消息的构造方法。

IntrospectionException(String message)
允许指定特定错误消息的构造方法。

InvalidAttributeValueException(String message)
允许指定特定错误消息的构造方法。

JMException(String msg)
允许指定特定错误消息的构造方法。

JMRuntimeException(String message)
允许指定特定错误消息的构造方法。

ListenerNotFoundException(String message)
允许指定特定错误消息的构造方法。

MalformedObjectNameException(String message)
允许指定特定错误消息的构造方法。

MBeanAttributeInfo(String name, String description, Method getter, Method setter)
此构造方法带有简单属性的名称，以及读取和写入属性的 Method 对象。

MBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)
构造一个 MBeanAttributeInfo 对象。

MBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 MBeanAttributeInfo 对象。

MBeanConstructorInfo(String description, Constructor constructor)
构造一个 MBeanConstructorInfo 对象。

MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
构造一个 MBeanConstructorInfo 对象。

MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 MBeanConstructorInfo 对象。

MBeanException(Exception e, String message)
创建一个包装实际 java.lang.Exception 的 MBeanException（带有详细消息）。

MBeanFeatureInfo(String name, String description)
构造一个 MBeanFeatureInfo 对象。

MBeanFeatureInfo(String name, String description, Descriptor descriptor)
构造一个 MBeanFeatureInfo 对象。

MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。

MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。

MBeanNotificationInfo(String[] notifTypes, String name, String description)
构造一个 MBeanNotificationInfo 对象。

MBeanNotificationInfo(String[] notifTypes, String name, String description)
构造一个 MBeanNotificationInfo 对象。

MBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造一个 MBeanNotificationInfo 对象。

MBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造一个 MBeanNotificationInfo 对象。

MBeanOperationInfo(String description, Method method)
构造一个 MBeanOperationInfo 对象。

MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
构造一个 MBeanOperationInfo 对象。

MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造一个 MBeanOperationInfo 对象。

MBeanParameterInfo(String name, String type, String description)
构造一个 MBeanParameterInfo 对象。

MBeanParameterInfo(String name, String type, String description, Descriptor descriptor)
构造一个 MBeanParameterInfo 对象。

MBeanPermission(String name, String actions)
创建具有指定目标名称和操作的新 MBeanPermission 对象。

MBeanPermission(String className, String member, ObjectName objectName, String actions)
创建具有指定目标名称（类名、成员、对象名）和操作的 MBeanPermission 对象。

MBeanRegistrationException(Exception e, String message)
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException（带有详细消息）。

MBeanServerNotification(String type, Object source, long sequenceNumber, ObjectName objectName)
创建一个指定了导致该通知的 MBean 对象名和指定通知类型的 MBeanServerNotification 对象。

MBeanServerPermission(String name)
创建具有给定名称的新 MBeanServerPermission。

MBeanServerPermission(String name, String actions)
创建具有给定名称的新 MBeanServerPermission。

MBeanTrustPermission(String name)
创建具有给定名称的新 MBeanTrustPermission。

MBeanTrustPermission(String name, String actions)
创建具有给定名称的新 MBeanTrustPermission。

NotCompliantMBeanException(String message)
允许指定具体错误消息的构造方法。

Notification(String type, Object source, long sequenceNumber)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, long timeStamp)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, long timeStamp, String message)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, String message)
创建一个 Notification 对象。

ObjectInstance(ObjectName objectName, String className)
允许创建具有给定对象名和完整类名（包括包名）的 ObjectInstance。

ObjectInstance(String objectName, String className)
允许创建具有给定字符串表示形式的对象名和完整类名（包括包名）的ｏbjectInstance。

ObjectName(String name)
根据给定的字符串构造一个对象名。

ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。

ObjectName(String domain, String key, String value)
构造只具有一个键属性的对象名。

OperationsException(String message)
允许指定具体错误消息的构造方法。

ReflectionException(Exception e, String message)
创建包装带有详细消息的实际 java.lang.Exception 的 ReflectionException。

RuntimeErrorException(Error e, String message)
允许指定特定错误消息的构造方法。

RuntimeMBeanException(RuntimeException e, String message)
创建带有详细信息的实际 java.lang.RuntimeException 的 RuntimeMBeanException。

RuntimeOperationsException(RuntimeException e, String message)
创建包装带有详细信息的实际 java.lang.RuntimeException 的 RuntimeOperationsException。

ServiceNotFoundException(String message)
允许指定特定错误消息的构造方法。

StringValueExp(String val)
创建表示给定字符串的新 StringValueExp。

类型变量类型为 String 的 javax.management 中的构造方法参数

ImmutableDescriptor(Map<String,?> fields)
构造一个描述符，其中字段名称和值是给定 Map 的键和值。

ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。

ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。

javax.management.loading 中 String 的使用

返回 String 的 javax.management.loading 中的方法

protected  String

MLet.findLibrary(String libname)
返回本机库的绝对路径名称。

String

MLetContent.getCode()
获取 MLET 标记的 CODE 属性的值。

String

MLetContent.getJarFiles()
获取由 MLET 标记的 ARCHIVE 属性指定的 .jar 文件的列表。

String

MLet.getLibraryDirectory()
获取库加载器在将本机库加载到内存中之前用于存储这些本机库的当前目录。

String

MLetMBean.getLibraryDirectory()
获取在将本机库加载到内存中之前库加载器用来存储这些本机库的当前目录。

String

MLetContent.getName()
获取 MLET 标记的 NAME 属性的值。

String

MLetContent.getSerializedObject()
获取 MLET 标记的 OBJECT 属性的值。

String

MLetContent.getVersion()
获取 MLET 标记的 VERSION 属性的值。

返回变量类型为 String 的类型的 javax.management.loading 中的方法

Map<String,String>

MLetContent.getAttributes()
获取 MLET 标记的属性。

Map<String,String>

MLetContent.getAttributes()
获取 MLET 标记的属性。

List<String>

MLetContent.getParameterTypes()
获取 MLET 标记中每个嵌套 <PARAM> 标记中的 TYPE 属性值的列表。

List<String>

MLetContent.getParameterValues()
获取 MLET 标记中每个嵌套 <PARAM> 标记中的 VALUE 属性值的列表。

参数类型为 String 的 javax.management.loading 中的方法

void

MLet.addURL(String url)
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。

void

MLetMBean.addURL(String url)
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。

protected  URL

MLet.check(String version, URL codebase, String jarfile, MLetContent mlet)
当扩展此服务来支持缓存和版本控制时，要重写此方法。

protected  Class<?>

MLet.findClass(String name)
这是要重新定义的类加载器的主要方法。

protected  String

MLet.findLibrary(String libname)
返回本机库的绝对路径名称。

Set<Object>

MLet.getMBeansFromURL(String url)
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

Set<Object>

MLetMBean.getMBeansFromURL(String url)
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

URL

MLetMBean.getResource(String name)
查找具有给定名称的资源。

InputStream

MLetMBean.getResourceAsStream(String name)
返回读取指定资源的输入流。

Enumeration<URL>

MLetMBean.getResources(String name)
查找所有具有给定名称的资源。

Class<?>

ClassLoaderRepository.loadClass(String className)
通过类加载器列表加载给定的类名称。

static Class

DefaultLoaderRepository.loadClass(String className)
已过时。 仔细检查类加载器列表，并尝试加载所请求的类。

Class<?>

MLet.loadClass(String name, ClassLoaderRepository clr)
如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。

Class<?>

ClassLoaderRepository.loadClassBefore(ClassLoader stop, String className)
通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。

Class<?>

ClassLoaderRepository.loadClassWithout(ClassLoader exclude, String className)
通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。

static Class

DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className)
已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。

void

MLet.setLibraryDirectory(String libdir)
设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。

void

MLetMBean.setLibraryDirectory(String libdir)
设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。

类型变量类型为 String 的 javax.management.loading 中的构造方法参数

MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

javax.management.modelmbean 中 String 的使用

返回 String 的 javax.management.modelmbean 中的方法

String

ModelMBeanInfo.getClassName()
返回此 MBeanInfo 所描述的 MBean 的 Java 类名称。

String

ModelMBeanInfo.getDescription()
返回 MBean 的可读描述。

String[]

DescriptorSupport.getFieldNames()

String[]

DescriptorSupport.getFields()

String

DescriptorSupport.toString()
返回表示描述符的可读字符串。

String

ModelMBeanAttributeInfo.toString()
返回 ModelMBeanAttributeInfo 实例的可读版本。

String

ModelMBeanConstructorInfo.toString()
以可读形式返回包含 ModelMBeanConstructorInfo 全部内容的字符串。

String

ModelMBeanNotificationInfo.toString()
返回包含 ModelMBeanNotificationInfo 的可读字符串。

String

ModelMBeanOperationInfo.toString()
以可读形式返回包含 ModelMBeanOperationInfo 全部内容的字符串。

String

DescriptorSupport.toXMLString()
返回表示描述符的 XML 字符串。

参数类型为 String 的 javax.management.modelmbean 中的方法

void

ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback)
注册一个将 NotificationListener 接口实现为侦听器的对象。

void

RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)

ModelMBeanAttributeInfo

ModelMBeanInfo.getAttribute(String inName)
返回通过名称请求的 ModelMBeanAttributeInfo。

ModelMBeanAttributeInfo

ModelMBeanInfoSupport.getAttribute(String inName)

Object

RequiredModelMBean.getAttribute(String attrName)
返回为此 ModelMBean 定义的指定属性的值。

AttributeList

RequiredModelMBean.getAttributes(String[] attrNames)
返回 ModelMBean 中几个属性的值。

ModelMBeanConstructorInfo

ModelMBeanInfoSupport.getConstructor(String inName)
返回通过名称请求的 ModelMBeanConstructorInfo。

Descriptor

ModelMBeanInfoSupport.getDescriptor(String inDescriptorName)
返回通过名称请求的 Descriptor。

Descriptor

ModelMBeanInfo.getDescriptor(String inDescriptorName, String inDescriptorType)
返回通过 name 和 descriptorType 请求的 Descriptor。

Descriptor

ModelMBeanInfoSupport.getDescriptor(String inDescriptorName, String inDescriptorType)

Descriptor[]

ModelMBeanInfo.getDescriptors(String inDescriptorType)
返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。

Descriptor[]

ModelMBeanInfoSupport.getDescriptors(String inDescriptorType)

Object

DescriptorSupport.getFieldValue(String fieldName)

Object[]

DescriptorSupport.getFieldValues(String... fieldNames)

ModelMBeanNotificationInfo

ModelMBeanInfo.getNotification(String inName)
返回通过名称请求的 ModelMBeanNotificationInfo。

ModelMBeanNotificationInfo

ModelMBeanInfoSupport.getNotification(String inName)

ModelMBeanOperationInfo

ModelMBeanInfo.getOperation(String inName)
返回通过名称请求的 ModelMBeanOperationInfo。

ModelMBeanOperationInfo

ModelMBeanInfoSupport.getOperation(String inName)

Object

RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig)
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。

Object

RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig)
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。

void

ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName)
从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。

void

RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)

void

DescriptorSupport.removeField(String fieldName)

void

ModelMBeanNotificationBroadcaster.sendNotification(String ntfyText)
将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。

void

RequiredModelMBean.sendNotification(String ntfyText)

void

ModelMBeanInfo.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。

void

ModelMBeanInfoSupport.setDescriptor(Descriptor inDescriptor, String inDescriptorType)

void

DescriptorSupport.setField(String fieldName, Object fieldValue)

void

DescriptorSupport.setFields(String[] fieldNames, Object[] fieldValues)

void

ModelMBean.setManagedResource(Object mr, String mr_type)
设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。

void

RequiredModelMBean.setManagedResource(Object mr, String mr_type)
设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。

参数类型为 String 的 javax.management.modelmbean 中的构造方法

DescriptorSupport(String... fields)
带有 fieldName=fieldValue 格式的字段的构造方法。

DescriptorSupport(String inStr)
Descriptor 构造方法带有一个 XML String。

DescriptorSupport(String[] fieldNames, Object[] fieldValues)
带有字段名称和字段值的构造方法。

InvalidTargetObjectTypeException(Exception e, String s)
带有异常和字符串的构造方法。

InvalidTargetObjectTypeException(String s)
根据字符串进行构造的构造方法。

ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。

ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter, Descriptor descriptor)
构造 ModelMBeanAttributeInfo 对象。

ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。

ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。

ModelMBeanConstructorInfo(String description, Constructor constructorMethod)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。

ModelMBeanConstructorInfo(String description, Constructor constructorMethod, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。

ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。

ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。

ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。

ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。

ModelMBeanNotificationInfo(String[] notifTypes, String name, String description)
构造带有默认描述符的 ModelMBeanNotificationInfo 对象。

ModelMBeanNotificationInfo(String[] notifTypes, String name, String description)
构造带有默认描述符的 ModelMBeanNotificationInfo 对象。

ModelMBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造 ModelMBeanNotificationInfo 对象。

ModelMBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造 ModelMBeanNotificationInfo 对象。

ModelMBeanOperationInfo(String description, Method operationMethod)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。

ModelMBeanOperationInfo(String description, Method operationMethod, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。

ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

XMLParseException(Exception e, String s)
带有字符串和异常的构造方法。

XMLParseException(String s)
带有字符串的构造方法。

javax.management.monitor 中 String 的使用

声明为 String 的 javax.management.monitor 中的字段

protected  String

Monitor.dbgTag
已过时。 无替代版本。

static String

MonitorNotification.OBSERVED_ATTRIBUTE_ERROR
表示被观察属性未包含在被观察对象中的通知类型。

static String

MonitorNotification.OBSERVED_ATTRIBUTE_TYPE_ERROR
表示被观察属性的类型不正确的通知类型。

static String

MonitorNotification.OBSERVED_OBJECT_ERROR
表示被观察对象未在 MBean 服务器中注册的通知类型。

static String

MonitorNotification.RUNTIME_ERROR
表示在尝试获取被观察属性的值时发生未预定义的错误类型的通知类型。

static String

MonitorNotification.STRING_TO_COMPARE_VALUE_DIFFERED
表示被观察属性与“要比较的字符串”值不同的通知类型。

static String

MonitorNotification.STRING_TO_COMPARE_VALUE_MATCHED
表示被观察属性与“要比较的字符串”值匹配的通知类型。

static String

MonitorNotification.THRESHOLD_ERROR
表示阈值类型、偏移量或模不正确的通知类型。

static String

MonitorNotification.THRESHOLD_HIGH_VALUE_EXCEEDED
表示被观察属性已超出高阈值的通知类型。

static String

MonitorNotification.THRESHOLD_LOW_VALUE_EXCEEDED
表示被观察属性已超出低阈值的通知类型。

static String

MonitorNotification.THRESHOLD_VALUE_EXCEEDED
表示被观察属性已达到阈值的通知类型。

返回 String 的 javax.management.monitor 中的方法

String

StringMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 StringMonitor.getDerivedGauge(ObjectName) 取代

String

StringMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGauge(ObjectName) 取代

String

StringMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生的尺度，否则将为 null。

String

StringMonitorMBean.getDerivedGauge(ObjectName object)
获取指定 MBean 的派生尺度。

String

Monitor.getObservedAttribute()
获取要观察的属性。

String

MonitorMBean.getObservedAttribute()
获取要观察的属性。

String

MonitorNotification.getObservedAttribute()
获取此监视器通知的被观察属性。

String

StringMonitor.getStringToCompare()
获取要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。

String

StringMonitorMBean.getStringToCompare()
获取要与 observed 属性进行比较的字符串。

参数类型为 String 的 javax.management.monitor 中的方法

void

Monitor.setObservedAttribute(String attribute)
设置要观察的属性。

void

MonitorMBean.setObservedAttribute(String attribute)
设置要观察的属性。

void

StringMonitor.setStringToCompare(String value)
设置要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。

void

StringMonitorMBean.setStringToCompare(String value)
设置要与 observed 属性进行比较的字符串。

参数类型为 String 的 javax.management.monitor 中的构造方法

MonitorSettingException(String message)
允许指定错误消息的构造方法。

javax.management.openmbean 中 String 的使用

声明为 String 的 javax.management.openmbean 中的字段

static String[]

OpenType.ALLOWED_CLASSNAMES
已过时。 使用 ALLOWED_CLASSNAMES_LIST 取代。

类型参数类型为 String 的 javax.management.openmbean 中的字段

static List<String>

OpenType.ALLOWED_CLASSNAMES_LIST
开放数据值允许的 Java 类的完全限定名称的列表。

static SimpleType<String>

SimpleType.STRING
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.String 的值。

返回 String 的 javax.management.openmbean 中的方法

String

OpenMBeanInfo.getClassName()
返回此 OpenMBeanInfo 描述的 open MBean 实例的完全限定的 Java 类名。

String

OpenType.getClassName()
返回此开放类型描述的开放数据值的完全限定的 Java 类名。

String

OpenMBeanConstructorInfo.getDescription()
返回此 OpenMBeanConstructorInfo 实例描述的构造方法的可读描述。

String

OpenMBeanInfo.getDescription()
返回此 OpenMBeanInfo 描述的 open MBean 实例的类型的可读描述。

String

OpenMBeanOperationInfo.getDescription()
返回此 OpenMBeanOperationInfo 实例描述的操作的可读描述。

String

OpenMBeanParameterInfo.getDescription()
返回此 OpenMBeanParameterInfo 实例描述的参数的可读描述。

String

OpenType.getDescription()
返回此 OpenType 实例的文本描述。

String

CompositeType.getDescription(String itemName)
返回名称是 itemName 的项的描述，如果此 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。

String

OpenMBeanConstructorInfo.getName()
返回此 OpenMBeanConstructorInfo 实例描述的构造方法名称。

String

OpenMBeanOperationInfo.getName()
返回此 OpenMBeanOperationInfo 实例描述的操作名称。

String

OpenMBeanParameterInfo.getName()
返回此 OpenMBeanParameterInfo 实例描述的参数名称。

String

OpenMBeanOperationInfo.getReturnType()
返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的完全限定的 Java 类名。

String

OpenType.getTypeName()
返回此 OpenType 实例的名称。

String

ArrayType.toString()
返回此 ArrayType 实例的字符串表示形式。

String

CompositeData.toString()
返回此 CompositeData 实例的字符串表示形式。

String

CompositeDataSupport.toString()
返回此 CompositeDataSupport 实例的字符串表示形式。

String

CompositeType.toString()
返回此 CompositeType 实例的字符串表示形式。

String

OpenMBeanAttributeInfo.toString()
返回此 OpenMBeanAttributeInfo 实例的字符串表示形式。

String

OpenMBeanAttributeInfoSupport.toString()
返回此 OpenMBeanAttributeInfoSupport 实例的字符串表示形式。

String

OpenMBeanConstructorInfo.toString()
返回此 OpenMBeanConstructorInfo 实例的字符串表示形式。

String

OpenMBeanConstructorInfoSupport.toString()
返回此 OpenMBeanConstructorInfoSupport 实例的字符串表示形式。

String

OpenMBeanInfo.toString()
返回此 OpenMBeanInfo 实例的字符串表示形式。

String

OpenMBeanInfoSupport.toString()
返回此 OpenMBeanInfoSupport 实例的字符串表示形式。

String

OpenMBeanOperationInfo.toString()
返回此 OpenMBeanOperationInfo 实例的字符串表示形式。

String

OpenMBeanOperationInfoSupport.toString()
返回此 OpenMBeanOperationInfoSupport 实例的字符串表示形式。

String

OpenMBeanParameterInfo.toString()
返回此 OpenMBeanParameterInfo 实例的字符串表示形式。

String

OpenMBeanParameterInfoSupport.toString()
返回此 OpenMBeanParameterInfoSupport 实例的字符串表示形式。

abstract  String

OpenType.toString()
返回此开放类型实例的字符串表示形式。

String

SimpleType.toString()
返回此 SimpleType 实例的字符串表示形式。

String

TabularData.toString()
返回此 TabularData 实例的字符串表示形式。

String

TabularDataSupport.toString()
返回此 TabularDataSupport 实例的字符串表示形式。

String

TabularType.toString()
返回此 TabularType 实例的字符串表示形式。

返回变量类型为 String 的类型的 javax.management.openmbean 中的方法

List<String>

TabularType.getIndexNames()
按照提供此实例的构造方法的顺序返回一个不可修改的项名称列表，可以使用该列表的值唯一地索引此 TabularType 实例所描述的表格数据值的每个行元素。

Set<String>

CompositeType.keySet()
返回此 CompositeType 实例定义的所有项名称的不可修改的 Set 视图。

参数类型为 String 的 javax.management.openmbean 中的方法

boolean

CompositeData.containsKey(String key)
当且仅当此 CompositeData 实例包含名称为 key 的项时，返回 true。

boolean

CompositeDataSupport.containsKey(String key)
当且仅当此 CompositeData 实例包含名称是 key 的项时，才返回 true。

boolean

CompositeType.containsKey(String itemName)
如果此 CompositeType 实例定义了名称为 itemName 的项，则返回 true。

Object

CompositeData.get(String key)
返回名称为 key 的项的值。

Object

CompositeDataSupport.get(String key)
返回其名称是 key 的项的值。

Object[]

CompositeData.getAll(String[] keys)
返回通过 keys 指定其项名称的值组成的数组，值排列的顺序与 keys 相同。

Object[]

CompositeDataSupport.getAll(String[] keys)
返回由 keys 指定其项名称的值的数组，顺序与 keys 相同。

String

CompositeType.getDescription(String itemName)
返回名称是 itemName 的项的描述，如果此 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。

OpenType<?>

CompositeType.getType(String itemName)
返回名称是 itemName 的项的开放类型，如果 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。

参数类型为 String 的 javax.management.openmbean 中的构造方法

CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。

CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。

CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。

CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。

InvalidKeyException(String msg)
带详细消息的 InvalidKeyException。

InvalidOpenTypeException(String msg)
带详细消息的 InvalidOpenTypeException。

KeyAlreadyExistsException(String msg)
带详细消息的 KeyAlreadyExistsException。

OpenDataException(String msg)
带详细消息的 OpenDataException。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、<openType 和 description 以及指定的读/写访问属性来描述 open MBean 的属性。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、读/写访问属性和 Descriptor 来描述 open MBean 的属性。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue，以及制定的读/写访问属性来描述 open MBean 的属性。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。

OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description 和 signature 描述 open MBeans 的类的构造方法。

OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description、signature 和 descriptor 来描述 open MBean 类的构造方法。

OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。

OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType 和 impact 描述 open MBeans 的类的操作。

OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType 和 description 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType, Descriptor descriptor)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 descriptor 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 defaultValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。

OpenType(String className, String typeName, String description)
构造一个 OpenType 实例（实际上是一个子类实例，因为 OpenType 是抽象的），检查给定参数的有效性。

TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
构造一个 TabularType 实例，检查给定参数的有效性。

TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
构造一个 TabularType 实例，检查给定参数的有效性。

类型变量类型为 String 的 javax.management.openmbean 中的构造方法参数

CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。

javax.management.relation 中 String 的使用

声明为 String 的 javax.management.relation 中的字段

static String

RelationNotification.RELATION_BASIC_CREATION
内部关系的创建类型。

static String

RelationNotification.RELATION_BASIC_REMOVAL
从内部关系的 Relation Service 中移除的类型。

static String

RelationNotification.RELATION_BASIC_UPDATE
内部关系的更新类型。

static String

RelationNotification.RELATION_MBEAN_CREATION
添加到 Relation Service 中的关系 MBean 的类型。

static String

RelationNotification.RELATION_MBEAN_REMOVAL
从关系 MBean 的 Relation Service 中移除的类型。

static String

RelationNotification.RELATION_MBEAN_UPDATE
关系 MBean 的更新类型。

返回 String 的 javax.management.relation 中的方法

String

RoleInfo.getDescription()
返回角色的描述文本。

String

RoleInfo.getName()
返回角色名称。

String

RoleInfo.getRefMBeanClassName()
返回期望在相应角色中引用的 MBean 的类型名称。

String

Relation.getRelationId()
返回关系标识符（用于唯一标识 Relation Service 内的关系）。

String

RelationNotification.getRelationId()
返回创建/移除/更新的关系的关系标识符。

String

RelationSupport.getRelationId()
返回关系标识符（用于唯一标识 Relation Service 中的关系）。

String

Relation.getRelationTypeName()
返回相关关系类型的名称。

String

RelationNotification.getRelationTypeName()
返回创建/移除/更新的关系的关系类型名称。

String

RelationSupport.getRelationTypeName()
返回相关关系类型的名称。

String

RelationType.getRelationTypeName()
返回关系类型名称。

String

RelationTypeSupport.getRelationTypeName()
返回关系类型名称。

String

RelationService.getRelationTypeName(String relationId)
返回给定关系的相关关系类型的名称。

String

RelationServiceMBean.getRelationTypeName(String relationId)
返回给定关系的相关关系类型的名称。

String

RelationNotification.getRoleName()
返回更新关系的更新角色的名称（仅限于角色更新）。

String

Role.getRoleName()
检索角色名称。

String

RoleUnresolved.getRoleName()
检索角色名称。

String

RelationService.isRelation(ObjectName objectName)
如果已经将 MBean 作为关系添加在 Relation Service 中，则返回与给定 ObjectName 相关的关系 id。

String

RelationServiceMBean.isRelation(ObjectName objectName)
如果 Relation Service 中作为关系添加 MBean，则返回与给定 ObjectName 相关的关系 id。

static String

Role.roleValueToString(List<ObjectName> roleValue)
返回给定角色值的字符串。

String

Role.toString()
返回描述角色的字符串。

String

RoleInfo.toString()
返回描述角色信息的字符串。

String

RoleUnresolved.toString()
返回描述此对象的字符串。

返回变量类型为 String 的类型的 javax.management.relation 中的方法

Map<ObjectName,List<String>>

RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
检索与关系中给定关系相关的 MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
检索与关系中给定关系相关的 MBean。

Map<String,List<String>>

RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在引用给定 MBean 的引用关系。

Map<String,List<String>>

RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在引用给定 MBean 的引用关系。

Map<String,List<String>>

RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在其中引用给定 MBean 的关系。

Map<String,List<String>>

RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在其中引用给定 MBean 的关系。

List<String>

RelationService.findRelationsOfType(String relationTypeName)
返回给定类型的关系的关系 id。

List<String>

RelationServiceMBean.findRelationsOfType(String relationTypeName)
返回给定类型的关系的关系 id。

List<String>

RelationService.getAllRelationIds()
返回由 Relation Service 处理的所有关系的所有关系 id。

List<String>

RelationServiceMBean.getAllRelationIds()
返回由 Relation Service 处理的所有关系的所有关系 id。

List<String>

RelationService.getAllRelationTypeNames()
检索所有已知关系类型的名称。

List<String>

RelationServiceMBean.getAllRelationTypeNames()
检索所有已知关系类型的名称。

Map<ObjectName,List<String>>

Relation.getReferencedMBeans()
检索在该关系的各种角色中引用的 MBean。

Map<ObjectName,List<String>>

RelationSupport.getReferencedMBeans()
检索在该关系的各种角色中引用的 MBean。

Map<ObjectName,List<String>>

RelationService.getReferencedMBeans(String relationId)
检索关系的各种角色中引用的 MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.getReferencedMBeans(String relationId)
检索关系的各种角色中引用的 MBean。

参数类型为 String 的 javax.management.relation 中的方法

Integer

RelationService.checkRoleReading(String roleName, String relationTypeName)
检查给定 Role 能否以给定类型的关系进行读取。

Integer

RelationServiceMBean.checkRoleReading(String roleName, String relationTypeName)
检查给定 Role 能否在给定类型的关系中读取。

Integer

RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag)
检查给定 Role 能否以给定类型的关系进行设置。

Integer

RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag)
检查给定 Role 能否在给定类型的关系中设置。

void

RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList)
创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。

void

RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList)
创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。

void

RelationService.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray)
用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。

void

RelationServiceMBean.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray)
用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。

Map<ObjectName,List<String>>

RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
检索与关系中给定关系相关的 MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
检索与关系中给定关系相关的 MBean。

Map<String,List<String>>

RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在引用给定 MBean 的引用关系。

Map<String,List<String>>

RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在其中引用给定 MBean 的关系。

List<String>

RelationService.findRelationsOfType(String relationTypeName)
返回给定类型的关系的关系 id。

List<String>

RelationServiceMBean.findRelationsOfType(String relationTypeName)
返回给定类型的关系的关系 id。

RoleResult

RelationService.getAllRoles(String relationId)
返回关系中存在的所有角色。

RoleResult

RelationServiceMBean.getAllRoles(String relationId)
返回关系中存在的所有角色。

Map<ObjectName,List<String>>

RelationService.getReferencedMBeans(String relationId)
检索关系的各种角色中引用的 MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.getReferencedMBeans(String relationId)
检索关系的各种角色中引用的 MBean。

String

RelationService.getRelationTypeName(String relationId)
返回给定关系的相关关系类型的名称。

String

RelationServiceMBean.getRelationTypeName(String relationId)
返回给定关系的相关关系类型的名称。

List<ObjectName>

Relation.getRole(String roleName)
检索给定角色名称的角色值。

List<ObjectName>

RelationSupport.getRole(String roleName)
检索给定角色名称的角色值。

List<ObjectName>

RelationService.getRole(String relationId, String roleName)
检索给定关系中给定角色名称的角色值。

List<ObjectName>

RelationServiceMBean.getRole(String relationId, String roleName)
检索给定关系中给定角色名称的角色值。

Integer

Relation.getRoleCardinality(String roleName)
返回当前在给定角色中引用的 MBean 数。

Integer

RelationSupport.getRoleCardinality(String roleName)
返回当前在给定角色中引用的 MBean 数。

Integer

RelationService.getRoleCardinality(String relationId, String roleName)
检索给定角色中当前引用的 MBean 数。

Integer

RelationServiceMBean.getRoleCardinality(String relationId, String roleName)
检索给定角色中当前引用的 MBean 数。

RoleInfo

RelationType.getRoleInfo(String roleInfoName)
返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。

RoleInfo

RelationTypeSupport.getRoleInfo(String roleInfoName)
返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。

RoleInfo

RelationService.getRoleInfo(String relationTypeName, String roleInfoName)
检索给定关系类型的给定角色名称的角色信息。

RoleInfo

RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName)
检索给定关系类型的给定角色的角色信息。

List<RoleInfo>

RelationService.getRoleInfos(String relationTypeName)
检索给定关系类型的角色信息（RoleInfo 对象）的列表。

List<RoleInfo>

RelationServiceMBean.getRoleInfos(String relationTypeName)
检索给定关系类型的角色信息（RoleInfo 对象）的列表。

RoleResult

Relation.getRoles(String[] roleNameArray)
检索具有给定名称的角色值。

RoleResult

RelationSupport.getRoles(String[] roleNameArray)
检索具有给定名称的角色值。

RoleResult

RelationService.getRoles(String relationId, String[] roleNameArray)
检索给定关系中具有给定名称的角色值。

RoleResult

RelationService.getRoles(String relationId, String[] roleNameArray)
检索给定关系中具有给定名称的角色值。

RoleResult

RelationServiceMBean.getRoles(String relationId, String[] roleNameArray)
检索给定关系中具有给定名称的角色值。

RoleResult

RelationServiceMBean.getRoles(String relationId, String[] roleNameArray)
检索给定关系中具有给定名称的角色值。

void

Relation.handleMBeanUnregistration(ObjectName objectName, String roleName)
在注销角色中引用的 MBean 时由 Relation Service 使用的回调。

void

RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName)
在注销角色中引用的 MBean 时由 Relation Service 使用的回调。

Boolean

RelationService.hasRelation(String relationId)
用给定的关系 id 检查是否存在 Relation Service 中标识的关系。

Boolean

RelationServiceMBean.hasRelation(String relationId)
用给定的关系 id 检查是否存在 Relation Service 中标识的关系。

ObjectName

RelationService.isRelationMBean(String relationId)
如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。

ObjectName

RelationServiceMBean.isRelationMBean(String relationId)
如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。

void

RelationService.removeRelation(String relationId)
从 Relation Service 移除给定的关系。

void

RelationServiceMBean.removeRelation(String relationId)
从 Relation Service 移除给定的关系。

void

RelationService.removeRelationType(String relationTypeName)
从 Relation Service 中移除给定的关系类型。

void

RelationServiceMBean.removeRelationType(String relationTypeName)
从 Relation Service 中移除给定的关系类型。

void

RelationService.sendRelationCreationNotification(String relationId)
发送关系创建通知 (RelationNotification)。

void

RelationServiceMBean.sendRelationCreationNotification(String relationId)
发送关系创建通知 (RelationNotification)。

void

RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList)
发送关系移除通知 (RelationNotification)。

void

RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList)
发送关系移除通知 (RelationNotification)。

void

RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue)
发送给定关系中的角色更新通知 (RelationNotification)。

void

RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue)
发送给定关系中的角色更新通知 (RelationNotification)。

void

RelationService.setRole(String relationId, Role role)
设置给定关系中的给定角色。

void

RelationServiceMBean.setRole(String relationId, Role role)
以给定关系设置给定角色。

void

Role.setRoleName(String roleName)
设置角色名称。

void

RoleUnresolved.setRoleName(String name)
设置角色名称。

RoleResult

RelationService.setRoles(String relationId, RoleList roleList)
设置给定关系中的给定角色。

RoleResult

RelationServiceMBean.setRoles(String relationId, RoleList roleList)
以给定关系设置给定角色。

void

RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue)
针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

void

RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue)
针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

参数类型为 String 的 javax.management.relation 中的构造方法

InvalidRelationIdException(String message)
异常中放置了给定消息的构造方法。

InvalidRelationServiceException(String message)
异常中放置了给定消息的构造方法。

InvalidRelationTypeException(String message)
异常中放置了给定消息的构造方法。

InvalidRoleInfoException(String message)
异常中放置了给定消息的构造方法。

InvalidRoleValueException(String message)
异常中放置了给定消息的构造方法。

RelationException(String message)
异常中放置了给定消息的构造方法。

RelationNotFoundException(String message)
异常中放置了给定消息的构造方法。

RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。

RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。

RelationServiceNotRegisteredException(String message)
异常中放置了给定消息的构造方法。

RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。

RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。

RelationTypeNotFoundException(String message)
异常中放置了给定消息的构造方法。

RelationTypeSupport(String relationTypeName)
用于子类的构造方法。

RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
所有角色定义在其中动态创建并作为参数传递的构造方法。

Role(String roleName, List<ObjectName> roleValue)
创建一个新的 Role 对象。

RoleInfo(String roleName, String mbeanClassName)
构造方法。

RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write)
构造方法。

RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。

RoleInfoNotFoundException(String message)
异常中放置了给定消息的构造方法。

RoleNotFoundException(String message)
异常中放置了给定消息的构造方法。

RoleUnresolved(String name, List<ObjectName> value, int pbType)
构造方法。

javax.management.remote 中 String 的使用

声明为 String 的 javax.management.remote 中的字段

static String

JMXConnectorServer.AUTHENTICATOR
为连接器服务器指定经验证的属性名称。

static String

JMXConnectionNotification.CLOSED
关闭连接通知的通知类型字符串。

static String

JMXConnector.CREDENTIALS
属性的名称，它指定了连接过程中发送给连接器服务器的凭据。

static String

JMXConnectorFactory.DEFAULT_CLASS_LOADER
指定默认的类加载器的属性名称。

static String

JMXConnectorServerFactory.DEFAULT_CLASS_LOADER
指定默认的类加载器的属性名称。

static String

JMXConnectorServerFactory.DEFAULT_CLASS_LOADER_NAME
指定默认的类加载器 MBean 名称的属性名称。

static String

JMXConnectionNotification.FAILED
连接失败通知的通知类型字符串。

static String

JMXConnectionNotification.NOTIFS_LOST
可能已丢失通知的连接的通知类型字符串。

static String

JMXConnectionNotification.OPENED
打开连接通知的通知类型字符串。

static String

JMXConnectorFactory.PROTOCOL_PROVIDER_CLASS_LOADER
指定用于加载协议提供者的类加载器的属性名称。

static String

JMXConnectorServerFactory.PROTOCOL_PROVIDER_CLASS_LOADER
指定用于加载协议提供者的类加载器的属性名称。

static String

JMXConnectorFactory.PROTOCOL_PROVIDER_PACKAGES
指定查找协议的处理程序时需参考的提供者包的属性名称。

static String

JMXConnectorServerFactory.PROTOCOL_PROVIDER_PACKAGES
指定查找协议的处理程序时需参考的提供者包的属性名称。

返回 String 的 javax.management.remote 中的方法

String

JMXConnectionNotification.getConnectionId()
该通知所属连接的连接 ID。

String

JMXConnector.getConnectionId()
获得来自连接器服务器的连接 ID。

String[]

JMXConnectorServer.getConnectionIds()

String[]

JMXConnectorServerMBean.getConnectionIds()
当前打开的到此连接器服务器的连接 ID 列表。

String

JMXServiceURL.getHost()
Service URL 的主机部分。

String

JMXPrincipal.getName()
返回此 principal 的名称。

String

JMXServiceURL.getProtocol()
Service URL 的协议部分。

String

JMXServiceURL.getURLPath()
Service URL 的 URL Path 部分。

String

JMXPrincipal.toString()
返回此 JMXPrincipal 的字符串表示形式。

String

JMXServiceURL.toString()
此 Service URL 的字符串表示形式。

String

NotificationResult.toString()
返回该对象的字符串表示形式。

String

TargetedNotification.toString()
返回此定向通知的一个文本表示形式。

返回变量类型为 String 的类型的 javax.management.remote 中的方法

Map<String,?>

JMXConnectorServerMBean.getAttributes()
此连接器服务器的属性。

参数类型为 String 的 javax.management.remote 中的方法

protected  void

JMXConnectorServer.connectionClosed(String connectionId, String message, Object userData)
正常关闭客户端连接时由子类调用。

protected  void

JMXConnectorServer.connectionFailed(String connectionId, String message, Object userData)
客户端连接失败时由子类调用。

protected  void

JMXConnectorServer.connectionOpened(String connectionId, String message, Object userData)
打开新的客户端连接时由子类调用。

类型变量类型为 String 的 javax.management.remote 中的方法参数

static JMXConnector

JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment)
创建到位于给定地址的连接器服务器的连接。

void

JMXConnector.connect(Map<String,?> env)
建立到连接器服务器的连接。

static JMXConnector

JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
为位于给定地址的连接器服务器创建一个连接器客户端。

JMXConnector

JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。

static JMXConnectorServer

JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
创建位于给定地址的连接器服务器。

JMXConnectorServer

JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
创建位于给定地址的新连接器服务器。

JMXConnector

JMXConnectorServer.toJMXConnector(Map<String,?> env)
返回此连接器服务器的客户端 stub。

JMXConnector

JMXConnectorServerMBean.toJMXConnector(Map<String,?> env)
返回此连接器服务器的客户端 stub。

参数类型为 String 的 javax.management.remote 中的构造方法

JMXConnectionNotification(String type, Object source, String connectionId, long sequenceNumber, String message, Object userData)
构造一个新的连接通知。

JMXPrincipal(String name)
为给定的身份创建一个 JMXPrincipal。

JMXProviderException(String message)
构造带指定详细消息的 JMXProviderException。

JMXProviderException(String message, Throwable cause)
构造带指定详细消息和嵌套异常的 JMXProviderException。

JMXServerErrorException(String s, Error err)
构造带指定详细消息和嵌套错误的 JMXServerErrorException。

JMXServiceURL(String serviceURL)
通过解析 Service URL 字符串来构造 JMXServiceURL。

JMXServiceURL(String protocol, String host, int port)
构造具有给定协议、主机和端口的 JMXServiceURL。

JMXServiceURL(String protocol, String host, int port, String urlPath)
构造具有给定部分的 JMXServiceURL。

SubjectDelegationPermission(String name)
创建具有指定名称的新 SubjectDelegationPermission。

SubjectDelegationPermission(String name, String actions)
创建带指定名称的新 SubjectDelegationPermission 对象。

javax.management.remote.rmi 中 String 的使用

声明为 String 的 javax.management.remote.rmi 中的字段

static String

RMIConnectorServer.JNDI_REBIND_ATTRIBUTE
属性名称，它指定代表 RMI 连接器服务器的 RMIServer stub 是否应重写位于同一地址的现有 stub。

static String

RMIConnectorServer.RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE
属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIClientSocketFactory。

static String

RMIConnectorServer.RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE
属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIServerSocketFactory。

返回 String 的 javax.management.remote.rmi 中的方法

String

RMIConnection.getConnectionId()
返回连接 ID。

String

RMIConnectionImpl.getConnectionId()

String

RMIConnectionImpl_Stub.getConnectionId()

String

RMIConnector.getConnectionId()

String

RMIConnection.getDefaultDomain(Subject delegationSubject)
处理 MBeanServerConnection.getDefaultDomain() 方法。

String

RMIConnectionImpl.getDefaultDomain(Subject delegationSubject)

String

RMIConnectionImpl_Stub.getDefaultDomain(Subject $param_Subject_1)

String[]

RMIConnection.getDomains(Subject delegationSubject)
处理 MBeanServerConnection.getDomains() 方法。

String[]

RMIConnectionImpl.getDomains(Subject delegationSubject)

String[]

RMIConnectionImpl_Stub.getDomains(Subject $param_Subject_1)

protected  String

RMIIIOPServerImpl.getProtocol()

protected  String

RMIJRMPServerImpl.getProtocol()

protected abstract  String

RMIServerImpl.getProtocol()
返回该对象的协议字符串。

String

RMIServer.getVersion()
此连接器服务器能识别的 RMI 连接协议版本。

String

RMIServerImpl.getVersion()

String

RMIServerImpl_Stub.getVersion()

String

RMIConnectionImpl.toString()
返回此对象的字符串表示形式。

String

RMIConnector.toString()
返回此对象的字符串表示形式。

返回变量类型为 String 的类型的 javax.management.remote.rmi 中的方法

Map<String,?>

RMIConnectorServer.getAttributes()

参数类型为 String 的 javax.management.remote.rmi 中的方法

protected  void

RMIConnectorServer.connectionClosed(String connectionId, String message, Object userData)

protected  void

RMIConnectorServer.connectionFailed(String connectionId, String message, Object userData)

protected  void

RMIConnectorServer.connectionOpened(String connectionId, String message, Object userData)

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)

Object

RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。

Object

RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)

Object

RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)

AttributeList

RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。

AttributeList

RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)

AttributeList

RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)

Object

RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。

Object

RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。

Object

RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)

Object

RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)

Object

RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

Object

RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

boolean

RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。

boolean

RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)

boolean

RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)

protected  RMIConnection

RMIIIOPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。

protected  RMIConnection

RMIJRMPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。

protected abstract  RMIConnection

RMIServerImpl.makeClient(String connectionId, Subject subject)
创建一个新的客户端连接。

类型变量类型为 String 的 javax.management.remote.rmi 中的方法参数

void

RMIConnector.connect(Map<String,?> environment)

JMXConnector

RMIConnectorServer.toJMXConnector(Map<String,?> env)
返回此连接器服务器的客户端 stub。

参数类型为 String 的 javax.management.remote.rmi 中的构造方法

RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。

类型变量类型为 String 的 javax.management.remote.rmi 中的构造方法参数

RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。

RMIConnector(JMXServiceURL url, Map<String,?> environment)
构造一个将 RMI 连接器服务器连接到给定地址的 RMIConnector。

RMIConnector(RMIServer rmiServer, Map<String,?> environment)
用给定的 RMI stub 构造一个 RMIConnector。

RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
建立 RMIConnectorServer。

RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。

RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。

RMIIIOPServerImpl(Map<String,?> env)
创建新的 RMIServerImpl。

RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。

RMIServerImpl(Map<String,?> env)
构造一个新的 RMIServerImpl。

javax.management.timer 中 String 的使用

返回 String 的 javax.management.timer 中的方法

String

Timer.getNotificationMessage(Integer id)
获得与指定标识符对应的计时器通知的详细消息。

String

TimerMBean.getNotificationMessage(Integer id)
获得与指定的标识符对应的计时器通知的详细消息。

String

Timer.getNotificationType(Integer id)
获得与指定标识符对应的计时器通知类型。

String

TimerMBean.getNotificationType(Integer id)
获得与指定标识符对应的计时器通知类型。

参数类型为 String 的 javax.management.timer 中的方法

Integer

Timer.addNotification(String type, String message, Object userData, Date date)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Vector<Integer>

Timer.getNotificationIDs(String type)
获得所有与指定类型对应的计时器通知的标识符。

Vector<Integer>

TimerMBean.getNotificationIDs(String type)
获得所有与指定类型对应的计时器通知的标识符。

void

Timer.removeNotifications(String type)
从通知列表中移除与指定类型对应的所有计时器通知。

void

TimerMBean.removeNotifications(String type)
从通知列表中移除与指定的类型对应的所有计时器通知。

参数类型为 String 的 javax.management.timer 中的构造方法

TimerNotification(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)
创建计时器通知对象。

javax.naming 中 String 的使用

声明为 String 的 javax.naming 中的字段

protected  String

RefAddr.addrType
包含此地址的类型。

static String

Context.APPLET
该常量保存用来指定搜索其他属性时将使用的初始上下文构造方法的 applet 的环境属性名称。

static String

Context.AUTHORITATIVE
该常量保存用来指定所请求服务的权威性的环境属性名称。

static String

Context.BATCHSIZE
该常量保存用来指定通过服务协议返回数据时要使用的批处理量 (batch size) 的环境属性名称。

protected  String

Reference.classFactory
包含用来创建此 Reference 所引用的对象实例的工厂类名称。

protected  String

Reference.classFactoryLocation
包含工厂类的位置。

protected  String

Reference.className
包含此 Reference 所引用的对象类的完全限定名称。

static String

Context.DNS_URL
该常量保存用来指定用于 JNDI URL 上下文的 DNS 主机名和域名（例如 "dns://somehost/wiz.com"）的环境属性名称。

static String

Context.INITIAL_CONTEXT_FACTORY
该常量保存用来指定要使用的初始上下文工厂的环境属性名称。

static String

Context.LANGUAGE
该常量保存用来指定用于服务的首选语言的环境属性名称。

protected  String

LinkException.linkExplanation
包含链接解析失败原因的异常。

static String

Context.OBJECT_FACTORIES
该常量保存用来指定要使用的对象工厂列表的环境属性名称。

static String

Context.PROVIDER_URL
该常量保存用来指定要使用的服务提供者配置信息的环境属性名称。

static String

Context.REFERRAL
该常量保存用来指定将如何处理服务提供者遇到的引用的环境属性名称。

static String

Context.SECURITY_AUTHENTICATION
该常量保存用来指定将使用的安全级别的环境属性名称。

static String

Context.SECURITY_CREDENTIALS
该常量保存用来指定用于验证服务调用者主体证书的环境属性名称。

static String

Context.SECURITY_PRINCIPAL
该常量保存用来指定用于验证服务调用者主体身份的环境属性名称。

static String

Context.SECURITY_PROTOCOL
该常量保存用来指定将使用的安全协议的环境属性名称。

static String

Context.STATE_FACTORIES
该常量保存用来指定要使用的状态工厂列表的环境属性名称。

static String

Context.URL_PKG_PREFIXES
该常量保存用来指定加载 URL 上下文工厂时要使用的包前缀列表的环境属性名称。

返回 String 的 javax.naming 中的方法

String

Context.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。

String

InitialContext.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。

String

CompositeName.get(int posn)
检索此复合名称的组件。

String

CompoundName.get(int posn)
检索此组合名称的组件。

String

Name.get(int posn)
检索此名称的组件。

String

Binding.getClassName()
检索绑定到此绑定名称的对象的类名称。

String

NameClassPair.getClassName()
检索绑定到此绑定名称的对象的类名称。

String

Reference.getClassName()
检索此引用所引用对象的类名称。

String

NamingException.getExplanation()
检索与此异常关联的解释。

String

Reference.getFactoryClassLocation()
检索此引用所引用对象的工厂的位置。

String

Reference.getFactoryClassName()
检索此引用所引用对象的工厂的类名称。

String

LinkException.getLinkExplanation()
检索与解析某一链接时遇到的问题关联的解释。

String

LinkRef.getLinkName()
检索此链接的名称。

String

NameClassPair.getName()
检索此绑定的名称。

String

Context.getNameInNamespace()
在此上下文自己的名称空间中检索其完全名称。

String

InitialContext.getNameInNamespace()

String

NameClassPair.getNameInNamespace()
检索此绑定的完全名称。

String

RefAddr.getType()
检索此地址的地址类型。

String

BinaryRefAddr.toString()
生成此地址的字符串表示形式。

String

Binding.toString()
生成此绑定的字符串表示形式。

String

CompositeName.toString()
生成此复合名称的字符串表示形式。

String

CompoundName.toString()
使用组合名称的语法规则生成此组合名称的字符串表示形式。

String

LinkException.toString()
生成此异常的字符串表示形式。

String

NameClassPair.toString()
生成此名称/类对的字符串表示形式。

String

NamingException.toString()
生成此异常的字符串表示形式。

String

RefAddr.toString()
生成此地址的字符串表示形式。

String

Reference.toString()
生成此引用的字符串表示形式。

String

LinkException.toString(boolean detail)
生成此异常的字符串表示形式。

String

NamingException.toString(boolean detail)
生成更详细的字符串表示形式。

返回变量类型为 String 的类型的 javax.naming 中的方法

Enumeration<String>

CompositeName.getAll()
以字符串枚举的形式检索此复合名称的组件。

Enumeration<String>

CompoundName.getAll()
以字符串枚举的形式检索此组合名称的组件。

Enumeration<String>

Name.getAll()
以字符串枚举的形式检索此名称的组件。

参数类型为 String 的 javax.naming 中的方法

Name

CompositeName.add(int posn, String comp)
在此复合名称中的指定位置添加单个组件。

Name

CompoundName.add(int posn, String comp)
在此组合名称中的指定位置添加单个组件。

Name

Name.add(int posn, String comp)
在此名称中的指定位置添加单个组件。

Name

CompositeName.add(String comp)
将单个组件添加到此复合名称的末尾。

Name

CompoundName.add(String comp)
将单个组件添加到此组合名称的末尾。

Name

Name.add(String comp)
将单个组件添加到此名称的末尾。

Object

Context.addToEnvironment(String propName, Object propVal)
将一个新环境属性添加到此上下文的环境中。

Object

InitialContext.addToEnvironment(String propName, Object propVal)

void

NamingException.appendRemainingComponent(String name)
将 name 作为剩余名称中最后的组件添加。

void

Context.bind(String name, Object obj)
将名称绑定到对象。

void

InitialContext.bind(String name, Object obj)

String

Context.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。

String

InitialContext.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。

Context

Context.createSubcontext(String name)
创建并绑定一个新上下文。

Context

InitialContext.createSubcontext(String name)

void

Context.destroySubcontext(String name)
销毁指定上下文，并将它从名称空间中移除。

void

InitialContext.destroySubcontext(String name)

static

<T> T

InitialContext.doLookup(String name)
获取指定对象的静态方法。

RefAddr

Reference.get(String addrType)
检索地址类型为 'addrType' 的第一个地址。

NameParser

Context.getNameParser(String name)
检索与指定上下文关联的解析器。

NameParser

InitialContext.getNameParser(String name)

protected  Context

InitialContext.getURLOrDefaultInitCtx(String name)
获取用来解析字符串名称 name 的上下文。

NamingEnumeration<NameClassPair>

Context.list(String name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。

NamingEnumeration<NameClassPair>

InitialContext.list(String name)

NamingEnumeration<Binding>

Context.listBindings(String name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。

NamingEnumeration<Binding>

InitialContext.listBindings(String name)

Object

Context.lookup(String name)
检索指定的对象。

Object

InitialContext.lookup(String name)

Object

Context.lookupLink(String name)
按照除名称的最终原子组件以外的链接检索指定对象。

Object

InitialContext.lookupLink(String name)

Name

NameParser.parse(String name)
将某一名称解析成其组件。

void

Context.rebind(String name, Object obj)
将名称绑定到对象，重写所有现有绑定。

void

InitialContext.rebind(String name, Object obj)

Object

Context.removeFromEnvironment(String propName)
从此上下文的环境中移除一个环境属性。

Object

InitialContext.removeFromEnvironment(String propName)

void

Context.rename(String oldName, String newName)
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。

void

InitialContext.rename(String oldName, String newName)

void

NameClassPair.setClassName(String name)
设置此绑定的类名称。

void

LinkException.setLinkExplanation(String msg)
设置与解析某一链接时所遇问题关联的解释。

void

NameClassPair.setName(String name)
设置此绑定的名称。

void

NameClassPair.setNameInNamespace(String fullName)
设置此绑定的完全名称。

void

Context.unbind(String name)
取消对指定对象的绑定。

void

InitialContext.unbind(String name)

参数类型为 String 的 javax.naming 中的构造方法

AuthenticationException(String explanation)
使用所提供的解释构造一个新的 AuthenticationException 实例。

AuthenticationNotSupportedException(String explanation)
使用解释构造一个新的 AuthenticationNotSupportedException 实例。

BinaryRefAddr(String addrType, byte[] src)
使用地址类型和用于内容的字节数组构造一个新的 BinaryRefAddr 实例。

BinaryRefAddr(String addrType, byte[] src, int offset, int count)
使用地址类型和用于内容的字节数组区域构造一个新的 BinaryRefAddr 实例。

Binding(String name, Object obj)
在给定其名称和对象的情况下构造一个 Binding 实例。

Binding(String name, Object obj, boolean isRelative)
在给定其名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。

Binding(String name, String className, Object obj)
在给定其名称、类名称和对象的情况下构造一个 Binding 实例。

Binding(String name, String className, Object obj, boolean isRelative)
在给定其名称、类名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。

CannotProceedException(String explanation)
使用解释构造一个新的 CannotProceedException 实例。

CommunicationException(String explanation)
使用所提供的参数构造一个新的 CommunicationException 实例。

CompositeName(String n)
通过使用复合名称语法（从左到右，用斜杠分隔）解析字符串 n 来构造一个新的复合名称实例。

CompoundName(String n, Properties syntax)
通过解析使用提供的 syntax 属性所指定的语法的字符串 n 来构造一个新的组合名称实例。

ConfigurationException(String explanation)
使用解释构造一个新的 ConfigurationException 实例。

ContextNotEmptyException(String explanation)
使用解释构造一个新的 ContextNotEmptyException 实例。

InsufficientResourcesException(String explanation)
使用解释构造一个新的 InsufficientResourcesException 实例。

InterruptedNamingException(String explanation)
使用问题的解释构造一个 InterruptedNamingException 实例。

InvalidNameException(String explanation)
使用问题的解释构造一个 InvalidNameException 实例。

LimitExceededException(String explanation)
使用解释构造一个新的 LimitExceededException 实例。

LinkException(String explanation)
使用解释构造一个新的 LinkException 实例，其他所有字段都初始化为 null。

LinkLoopException(String explanation)
使用解释构造一个新的 LinkLoopException 实例，其他所有字段都被初始化为 null。

LinkRef(String linkName)
为某一字符串名称构造一个 LinkRef。

MalformedLinkException(String explanation)
使用解释构造一个新的 MalformedLinkException 实例，其他所有字段都被初始化为 null。

NameAlreadyBoundException(String explanation)
使用所提供的解释构造一个新的 NameAlreadyBoundException 实例。

NameClassPair(String name, String className)
在给定名称和类名称的情况下构造一个 NameClassPair 实例。

NameClassPair(String name, String className, boolean isRelative)
在给定其名称、类名称以及该名称是否相对于列表上下文的情况下构造一个 NameClassPair 实例。

NameNotFoundException(String explanation)
使用所提供的解释构造一个新的 NameNotFoundException 实例。

NamingException(String explanation)
使用解释构造一个新的 NamingException。

NamingSecurityException(String explanation)
使用所提供的解释构造一个新的 NamingSecurityException 实例。

NoInitialContextException(String explanation)
使用解释构造一个 NoInitialContextException 实例。

NoPermissionException(String explanation)
使用解释构造一个新的 NoPermissionException 实例。

NotContextException(String explanation)
使用解释构造一个新的 NotContextException 实例。

OperationNotSupportedException(String explanation)
使用解释构造一个新的 OperationNotSupportedException 实例。

PartialResultException(String explanation)
使用指定的解释消息构造一个新的异常实例。

RefAddr(String addrType)
使用地址类型构造一个新的 RefAddr 实例。

Reference(String className)
使用类名称 'className' 构造对某个对象的新引用。

Reference(String className, RefAddr addr)
使用类名称 'className' 和一个地址构造对某个对象的新引用。

Reference(String className, RefAddr addr, String factory, String factoryLocation)
使用类名称 'className'、对象工厂的类名称和位置以及对象的地址创建该对某个对象的新引用。

Reference(String className, String factory, String factoryLocation)
使用类名称 'className' 以及对象工厂的类名称和位置创建对某个对象的新引用。

ReferralException(String explanation)
使用所提供的解释构造一个新的 ReferralException 实例。

ServiceUnavailableException(String explanation)
使用解释构造一个新的 ServiceUnavailableException 实例。

SizeLimitExceededException(String explanation)
使用解释构造一个新的 SizeLimitExceededException 实例。

StringRefAddr(String addrType, String addr)
使用地址类型和内容构造一个新的 StringRefAddr 实例。

TimeLimitExceededException(String explanation)
使用所提供的参数构造一个新的 TimeLimitExceededException 实例。

类型变量类型为 String 的 javax.naming 中的构造方法参数

CompositeName(Enumeration<String> comps)
使用由 'comps' 指定的组件构造一个新的复合名称实例。

CompoundName(Enumeration<String> comps, Properties syntax)
使用 comps 和 syntax 指定的组件构造一个新的组合名称实例。

javax.naming.directory 中 String 的使用

声明为 String 的 javax.naming.directory 中的字段

protected  String

BasicAttribute.attrID
保存属性的 id。

返回 String 的 javax.naming.directory 中的方法

String

Attribute.getID()
检索此属性的 id。

String

BasicAttribute.getID()

String[]

SearchControls.getReturningAttributes()
检索将作为搜索的一部分返回的属性。

String

AttributeModificationException.toString()
此异常的字符串表示形式由关于发生错误的位置信息和第一个未执行的修改组成。

String

BasicAttribute.toString()
生成此属性的字符串表示形式。

String

BasicAttributes.toString()
生成此属性集的字符串表示形式。

String

ModificationItem.toString()
生成此修改项的字符串表示形式，该表示形式由修改操作及其相关属性组成。

String

SearchResult.toString()
生成此 SearchResult 的字符串表示形式。

返回变量类型为 String 的类型的 javax.naming.directory 中的方法

NamingEnumeration<String>

Attributes.getIDs()
检索属性集中属性的 id 的枚举。

NamingEnumeration<String>

BasicAttributes.getIDs()

参数类型为 String 的 javax.naming.directory 中的方法

void

DirContext.bind(String name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象。

void

InitialDirContext.bind(String name, Object obj, Attributes attrs)

DirContext

DirContext.createSubcontext(String name, Attributes attrs)
创建并绑定新的上下文及关联的属性。

DirContext

InitialDirContext.createSubcontext(String name, Attributes attrs)

Attribute

Attributes.get(String attrID)
利用属性集中的给定属性 id 检索属性。

Attribute

BasicAttributes.get(String attrID)

Attributes

DirContext.getAttributes(Name name, String[] attrIds)
检索与命名对象关联的选定属性。

Attributes

InitialDirContext.getAttributes(Name name, String[] attrIds)

Attributes

DirContext.getAttributes(String name)
检索所有与命名对象关联的属性。

Attributes

InitialDirContext.getAttributes(String name)

Attributes

DirContext.getAttributes(String name, String[] attrIds)
检索与命名对象关联的选定属性。

Attributes

DirContext.getAttributes(String name, String[] attrIds)
检索与命名对象关联的选定属性。

Attributes

InitialDirContext.getAttributes(String name, String[] attrIds)

Attributes

InitialDirContext.getAttributes(String name, String[] attrIds)

DirContext

DirContext.getSchema(String name)
检索与命名对象关联的模式。

DirContext

InitialDirContext.getSchema(String name)

DirContext

DirContext.getSchemaClassDefinition(String name)
检索包含命名对象类定义的模式对象的上下文。

DirContext

InitialDirContext.getSchemaClassDefinition(String name)

void

DirContext.modifyAttributes(String name, int mod_op, Attributes attrs)
修改与命名对象关联的属性。

void

InitialDirContext.modifyAttributes(String name, int mod_op, Attributes attrs)

void

DirContext.modifyAttributes(String name, ModificationItem[] mods)
使用有序的修改列表修改与命名对象关联的属性。

void

InitialDirContext.modifyAttributes(String name, ModificationItem[] mods)

Attribute

Attributes.put(String attrID, Object val)
向属性集中添加新属性。

Attribute

BasicAttributes.put(String attrID, Object val)

void

DirContext.rebind(String name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。

void

InitialDirContext.rebind(String name, Object obj, Attributes attrs)

Attribute

Attributes.remove(String attrID)
从属性集中移除属性 id 为 'attrID' 的属性。

Attribute

BasicAttributes.remove(String attrID)

NamingEnumeration<SearchResult>

DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。

NamingEnumeration<SearchResult>

InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)

NamingEnumeration<SearchResult>

DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)

NamingEnumeration<SearchResult>

DirContext.search(Name name, String filter, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(Name name, String filter, SearchControls cons)

NamingEnumeration<SearchResult>

DirContext.search(String name, Attributes matchingAttributes)
在单个上下文中搜索包含指定属性集的对象。

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, Attributes matchingAttributes)

NamingEnumeration<SearchResult>

DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。

NamingEnumeration<SearchResult>

DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)

NamingEnumeration<SearchResult>

DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)

NamingEnumeration<SearchResult>

DirContext.search(String name, String filter, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, String filter, SearchControls cons)

void

SearchControls.setReturningAttributes(String[] attrs)
指定将作为搜索的一部分返回的属性。

参数类型为 String 的 javax.naming.directory 中的构造方法

AttributeInUseException(String explanation)
使用解释构造一个新的 AttributeInUseException 实例。

AttributeModificationException(String explanation)
使用解释构造一个新的 AttributeModificationException 实例。

BasicAttribute(String id)
构造一个不带值无序属性的新实例。

BasicAttribute(String id, boolean ordered)
构造一个不带值的可能为有序属性的新实例。

BasicAttribute(String id, Object value)
构造一个带有单个值的无序属性的新实例。

BasicAttribute(String id, Object value, boolean ordered)
构造一个带有单个值的可能为有序属性的新实例。

BasicAttributes(String attrID, Object val)
构造带有一个属性的新 Attributes 实例。

BasicAttributes(String attrID, Object val, boolean ignoreCase)
构造带有一个属性的新 Attributes 实例。

InvalidAttributeIdentifierException(String explanation)
使用所提供的解释构造一个新的 InvalidAttributeIdentifierException 实例。

InvalidAttributesException(String explanation)
使用解释构造一个新的 InvalidAttributesException 实例。

InvalidAttributeValueException(String explanation)
使用解释构造一个新的 InvalidAttributeValueException 实例。

InvalidSearchControlsException(String msg)
使用解释构造一个新的 InvalidSearchControlsException 实例。

InvalidSearchFilterException(String msg)
使用解释构造一个新的 InvalidSearchFilterException 实例。

NoSuchAttributeException(String explanation)
使用解释构造一个新的 NoSuchAttributeException 实例。

SchemaViolationException(String explanation)
使用所提供的解释构造一个新的 SchemaViolationException 实例。

SearchControls(int scope, long countlim, int timelim, String[] attrs, boolean retobj, boolean deref)
使用参数构造搜索约束。

SearchResult(String name, Object obj, Attributes attrs)
使用结果的名称、绑定对象及其属性构造一个搜索结果。

SearchResult(String name, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

SearchResult(String name, String className, Object obj, Attributes attrs)
使用结果的名称、类名称、绑定对象及其属性构造一个搜索结果。

SearchResult(String name, String className, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、类名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

javax.naming.event 中 String 的使用

参数类型为 String 的 javax.naming.event 中的方法

void

EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。

void

EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。

void

EventContext.addNamingListener(String target, int scope, NamingListener l)
添加接收命名事件的侦听器，这些事件在目标名称和范围指定的对象发生更改时触发。

void

EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。

void

EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。

javax.naming.ldap 中 String 的使用

声明为 String 的 javax.naming.ldap 中的字段

static String

LdapContext.CONTROL_FACTORIES
该常量保存用来指定要使用的控件工厂列表的环境属性名称。

protected  String

BasicControl.id
控件的对象标识符字符串。

static String

ManageReferralControl.OID
ManageReferral 控件的分配对象标识符为 2.16.840.1.113730.3.4.2。

static String

PagedResultsControl.OID
分页结果控件的分配对象标识符为 1.2.840.113556.1.4.319。

static String

PagedResultsResponseControl.OID
分页结果响应控件的分配对象标识符为 1.2.840.113556.1.4.319。

static String

SortControl.OID
服务器端排序控件的分配对象标识符为 1.2.840.113556.1.4.473。

static String

SortResponseControl.OID
服务器端排序响应控件的分配对象标识符为 1.2.840.113556.1.4.474。

static String

StartTlsRequest.OID
StartTLS 扩展请求的分配对象标识符为 1.3.6.1.4.1.1466.20037。

static String

StartTlsResponse.OID
StartTLS 扩展响应的分配对象标识符为 1.3.6.1.4.1.1466.20037。

返回 String 的 javax.naming.ldap 中的方法

static String

Rdn.escapeValue(Object val)
在给定属性值的情况下返回根据 RFC 2253 中指定的规则转义的字符串。

String

LdapName.get(int posn)
以字符串形式检索此 LDAP 名称的组件。

String

SortKey.getAttributeID()
检索排序键的属性 ID。

String

SortResponseControl.getAttributeID()
检索导致排序失败的属性的 ID。

String

BasicControl.getID()
检索控件的对象标识符字符串。

String

Control.getID()
检索为 LDAP 控件分配的对象标识符。

String

ExtendedRequest.getID()
检索请求的对象标识符。

String

ExtendedResponse.getID()
检索响应的对象标识符。

String

StartTlsRequest.getID()
检索 StartTLS 请求的对象标识符字符串。

String

StartTlsResponse.getID()
检索 StartTLS 响应的对象标识符字符串。

String

SortKey.getMatchingRuleID()
检索用于排序属性值的匹配规则 ID。

String[]

UnsolicitedNotification.getReferrals()
检索服务器发送的引用。

String

Rdn.getType()
检索一个此 Rdn 的类型。

String

LdapName.toString()
返回一个此 LDAP 名称的字符串表示形式，该表示形式使用 RFC 2253 定义并在类描述中描述的格式。

String

Rdn.toString()
以字符串形式返回此 Rdn，该字符串使用由 RFC 2253 定义并在 LdapName 类描述中描述的格式表示。

返回变量类型为 String 的类型的 javax.naming.ldap 中的方法

Enumeration<String>

LdapName.getAll()
以字符串枚举的形式检索此名称的组件。

参数类型为 String 的 javax.naming.ldap 中的方法

Name

LdapName.add(int posn, String comp)
将单个组件添加到此 LDAP 名称中的指定位置。

Name

LdapName.add(String comp)
将单个组件添加到此 LDAP 名称的末尾。

ExtendedResponse

ExtendedRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length)
创建与此请求对应的响应对象。

ExtendedResponse

StartTlsRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length)
创建与 LDAP StartTLS 扩展请求相对应的扩展响应对象。

abstract  void

StartTlsResponse.setEnabledCipherSuites(String[] suites)
重写在 TLS 连接上启用的密码套件的默认列表。

static Object

Rdn.unescapeValue(String val)
在给定根据 RFC 2253 中指定的规则进行格式化的属性值字符串的情况下，返回未格式化的值。

参数类型为 String 的 javax.naming.ldap 中的构造方法

BasicControl(String id)
构造一个非关键控件。

BasicControl(String id, boolean criticality, byte[] value)
使用提供的参数构造控件。

LdapName(String name)
根据给定标识名构造 LDAP 名称。

LdapReferralException(String explanation)
使用所提供的解释构造一个新的 LdapReferralException 实例。

PagedResultsResponseControl(String id, boolean criticality, byte[] value)
构造分页结果响应控件。

Rdn(String rdnString)
根据给定字符串构造 Rdn。

Rdn(String type, Object value)
根据给定属性类型和值构造 Rdn。

SortControl(String[] sortBy, boolean criticality)
构造一个控件来按升序对属性列表进行排序。

SortControl(String sortBy, boolean criticality)
构造一个控件来按升序对单个属性进行排序。

SortKey(String attrID)
创建属性的默认排序键。

SortKey(String attrID, boolean ascendingOrder, String matchingRuleID)
创建属性的排序键。

SortResponseControl(String id, boolean criticality, byte[] value)
构造一个控件来指示排序请求的结果。

javax.naming.spi 中 String 的使用

声明为 String 的 javax.naming.spi 中的字段

static String

NamingManager.CPE
保存环境属性名称的常量，getContinuationContext() 将其 CannotProceedException 参数的值保存在该环境属性中。

参数类型为 String 的 javax.naming.spi 中的方法

void

ResolveResult.appendRemainingComponent(String name)
将单个组件添加到剩余名称末尾。

static Context

NamingManager.getURLContext(String scheme, Hashtable<?,?> environment)
为给定的 URL 方案 id 创建一个上下文。

ResolveResult

Resolver.resolveToClass(String name, Class<? extends Context> contextType)
部分解析某一名称。

参数类型为 String 的 javax.naming.spi 中的构造方法

ResolveResult(Object robj, String rcomp)
构造一个新的 ResolveResult 实例，该实例由已解析对象和剩余未解析组件组成。

javax.net 中 String 的使用

参数类型为 String 的 javax.net 中的方法

abstract  Socket

SocketFactory.createSocket(String host, int port)
创建一个套接字并把它连接到指定远程主机上的指定远程端口。

abstract  Socket

SocketFactory.createSocket(String host, int port, InetAddress localHost, int localPort)
创建一个套接字并把它连接到指定远程主机上的指定远程端口。

javax.net.ssl 中 String 的使用

返回 String 的 javax.net.ssl 中的方法

String

X509KeyManager.chooseClientAlias(String[] keyType, Principal[] issuers, Socket socket)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。

String

X509ExtendedKeyManager.chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine)
选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。

String

X509ExtendedKeyManager.chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine)
选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。

String

X509KeyManager.chooseServerAlias(String keyType, Principal[] issuers, Socket socket)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。

String

KeyManagerFactory.getAlgorithm()
返回此 KeyManagerFactory 对象的算法名称。

String

TrustManagerFactory.getAlgorithm()
返回此 TrustManagerFactory 对象的算法名称。

String

HandshakeCompletedEvent.getCipherSuite()
返回由握手产生的会话所使用的密码套件。

String

SSLSession.getCipherSuite()
返回会话中的所有连接所使用的 SSL 密码套件的名称。

abstract  String

HttpsURLConnection.getCipherSuite()
返回在此连接上使用的密码套件。

String[]

SSLParameters.getCipherSuites()
返回密码套件数组的副本；如果未设置，则返回 null。

String[]

X509KeyManager.getClientAliases(String keyType, Principal[] issuers)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字客户端的匹配别名。

static String

KeyManagerFactory.getDefaultAlgorithm()
获取默认的 KeyManagerFactory 算法名称。

static String

TrustManagerFactory.getDefaultAlgorithm()
获取默认的 TrustManagerFactory 算法名称。

abstract  String[]

SSLSocketFactory.getDefaultCipherSuites()
返回默认情况下启用的密码套件的列表。

abstract  String[]

SSLServerSocketFactory.getDefaultCipherSuites()
返回默认情况下启用的密码套件的列表。

abstract  String[]

SSLSocket.getEnabledCipherSuites()
返回当前启用以供此连接使用的 SSL 密码套件的名称。

abstract  String[]

SSLEngine.getEnabledCipherSuites()
返回为了在此引擎上使用而当前已启用的 SSL 密码套件名称。

abstract  String[]

SSLServerSocket.getEnabledCipherSuites()
返回当前被启用以供新接受的连接使用的密码套件列表。

abstract  String[]

SSLSocket.getEnabledProtocols()
返回当前启用以供此连接使用的协议版本的名称。

abstract  String[]

SSLEngine.getEnabledProtocols()
返回当前已启用的，以便让 SSLEngine 使用的协议版本的名称。

abstract  String[]

SSLServerSocket.getEnabledProtocols()
返回当前新接受的连接启用的协议的名称。

String

SSLSessionBindingEvent.getName()
返回将对象绑定到或从其解除绑定的名称。

String

SSLSession.getPeerHost()
返回此会话中同位体的主机名称。

String

SSLEngine.getPeerHost()
返回同位体的主机名。

String

SSLSession.getProtocol()
返回会话中的所有连接使用的协议的标准名称。

String

SSLContext.getProtocol()
返回此 SSLContext 对象的协议名称。

String[]

SSLParameters.getProtocols()
返回协议数组的副本；如果未设置，则返回 null。

String[]

X509KeyManager.getServerAliases(String keyType, Principal[] issuers)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字服务器端的别名。

abstract  String[]

SSLSocket.getSupportedCipherSuites()
返回可以启用以供此连接使用的密码套件的名称。

abstract  String[]

SSLSocketFactory.getSupportedCipherSuites()
返回可以在 SSL 连接上启用的密码套件的名称。

abstract  String[]

SSLServerSocketFactory.getSupportedCipherSuites()
返回可以在由此工厂创建的 SSL 连接上启用的密码套件的名称。

abstract  String[]

SSLEngine.getSupportedCipherSuites()
返回为了在此引擎上使用而可以启用的密码套件名称。

abstract  String[]

SSLServerSocket.getSupportedCipherSuites()
返回可以启用以供 SSL 连接使用的密码套件的名称。

abstract  String[]

SSLSocket.getSupportedProtocols()
返回能够被启用以供 SSL 连接使用的协议的名称。

abstract  String[]

SSLEngine.getSupportedProtocols()
返回能够被启用，以便让 SSLEngine 可使用的协议的名称。

abstract  String[]

SSLServerSocket.getSupportedProtocols()
返回可以启用的协议的名称。

String[]

SSLSession.getValueNames()
返回绑定到会话中的所有应用层数据对象的名称组成的数组。

String

SSLEngineResult.toString()
返回此对象的字符串表示形式。

参数类型为 String 的 javax.net.ssl 中的方法

void

X509TrustManager.checkClientTrusted(X509Certificate[] chain, String authType)
给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的客户端 SSL 验证。

void

X509TrustManager.checkServerTrusted(X509Certificate[] chain, String authType)
给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的服务器 SSL 验证。

String

X509KeyManager.chooseClientAlias(String[] keyType, Principal[] issuers, Socket socket)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。

String

X509ExtendedKeyManager.chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine)
选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。

String

X509ExtendedKeyManager.chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine)
选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。

String

X509KeyManager.chooseServerAlias(String keyType, Principal[] issuers, Socket socket)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。

abstract  Socket

SSLSocketFactory.createSocket(Socket s, String host, int port, boolean autoClose)
返回在连接到指定主机的给定端口的现有套接字上分层的套接字。

SSLEngine

SSLContext.createSSLEngine(String peerHost, int peerPort)
使用此上下文创建新的 SSLEngine，该上下文使用劝告同位体信息。

protected abstract  SSLEngine

SSLContextSpi.engineCreateSSLEngine(String host, int port)
使用此上下文创建 SSLEngine。

X509Certificate[]

X509KeyManager.getCertificateChain(String alias)
返回与给定别名关联的证书链。

String[]

X509KeyManager.getClientAliases(String keyType, Principal[] issuers)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字客户端的匹配别名。

static KeyManagerFactory

KeyManagerFactory.getInstance(String algorithm)
返回充当密钥管理器工厂的 KeyManagerFactory 对象。

static SSLContext

SSLContext.getInstance(String protocol)
返回实现指定安全套接字协议的 SSLContext 对象。

static TrustManagerFactory

TrustManagerFactory.getInstance(String algorithm)
返回充当信任管理器工厂的 TrustManagerFactory 对象。

static KeyManagerFactory

KeyManagerFactory.getInstance(String algorithm, Provider provider)
返回充当密钥管理器工厂的 KeyManagerFactory 对象。

static SSLContext

SSLContext.getInstance(String protocol, Provider provider)
返回实现指定安全套接字协议的 SSLContext 对象。

static TrustManagerFactory

TrustManagerFactory.getInstance(String algorithm, Provider provider)
返回充当信任管理器工厂的 TrustManagerFactory 对象。

static KeyManagerFactory

KeyManagerFactory.getInstance(String algorithm, String provider)
返回充当密钥管理器工厂的 KeyManagerFactory 对象。

static SSLContext

SSLContext.getInstance(String protocol, String provider)
返回实现指定安全套接字协议的 SSLContext 对象。

static TrustManagerFactory

TrustManagerFactory.getInstance(String algorithm, String provider)
返回充当信任管理器工厂的 TrustManagerFactory 对象。

PrivateKey

X509KeyManager.getPrivateKey(String alias)
返回与给定别名关联的密钥。

String[]

X509KeyManager.getServerAliases(String keyType, Principal[] issuers)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字服务器端的别名。

Object

SSLSession.getValue(String name)
返回会话的应用层数据中的绑定到给定名称的对象。

void

SSLSession.putValue(String name, Object value)
使用给定的 name 将指定的 value 对象绑定到会话的应用层数据中。

void

SSLSession.removeValue(String name)
移除会话的应用层数据中绑定到给定名称的对象。

void

SSLParameters.setCipherSuites(String[] cipherSuites)
设置密码套件数组。

abstract  void

SSLSocket.setEnabledCipherSuites(String[] suites)
将密码套件设置为启用以供此连接使用。

abstract  void

SSLEngine.setEnabledCipherSuites(String[] suites)
设置密码套件为启用，以便在此引擎上使用。

abstract  void

SSLServerSocket.setEnabledCipherSuites(String[] suites)
把密码套件设置为启用的以供接受的连接使用。

abstract  void

SSLSocket.setEnabledProtocols(String[] protocols)
设置启用以供此连接使用的协议版本。

abstract  void

SSLEngine.setEnabledProtocols(String[] protocols)
设置为了在此引擎上使用而启用的协议版本。

abstract  void

SSLServerSocket.setEnabledProtocols(String[] protocols)
控制启用哪些特定的协议以供接受的连接使用。

void

SSLParameters.setProtocols(String[] protocols)
设置协议数组。

static SSLEngineResult.Status

SSLEngineResult.Status.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static SSLEngineResult.HandshakeStatus

SSLEngineResult.HandshakeStatus.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

boolean

HostnameVerifier.verify(String hostname, SSLSession session)
验证主机名和服务器验证方案的匹配是可接受的。

参数类型为 String 的 javax.net.ssl 中的构造方法

KeyManagerFactory(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 KeyManagerFactory 对象。

SSLContext(SSLContextSpi contextSpi, Provider provider, String protocol)
创建 SSLContext 对象。

SSLEngine(String peerHost, int peerPort)
SSLEngine 的构造方法。

SSLException(String reason)
构造一个异常，该异常报告由 SSL 子系统发现的错误。

SSLException(String message, Throwable cause)
创建带指定详细消息和原因的 SSLException。

SSLHandshakeException(String reason)
构造一个报告由 SSL 子系统在握手期间发现的错误的异常。

SSLKeyException(String reason)
构造一个报告由 SSL 子系统发现的密钥管理错误的异常。

SSLParameters(String[] cipherSuites)
根据指定的密码套件数组构造 SSLParameters。

SSLParameters(String[] cipherSuites, String[] protocols)
根据指定的密码套件数组和协议数组构造 SSLParameters。

SSLParameters(String[] cipherSuites, String[] protocols)
根据指定的密码套件数组和协议数组构造 SSLParameters。

SSLPeerUnverifiedException(String reason)
构造一个报告还没有验证 SSL 同位体的身份的异常。

SSLPermission(String name)
用指定的名称创建一个新的 SSLPermission。

SSLPermission(String name, String actions)
用指定的名称创建一个新的 SSLPermission 对象。

SSLProtocolException(String reason)
构造一个报告由 SSL 子系统检测到的 SSL 协议错误的异常。

SSLSessionBindingEvent(SSLSession session, String name)
构造一个新的 SSLSessionBindingEvent。

SSLSocket(String host, int port)
仅供子类使用。

SSLSocket(String host, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。

TrustManagerFactory(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 TrustManagerFactory 对象。

javax.print 中 String 的使用

声明为 String 的 javax.print 中的字段

static String

ServiceUIFactory.DIALOG_UI
表示一个作为 AWT 对话框实现的 UI。

static String

DocFlavor.hostEncoding
表示主机操作系统编码的 String。

static String

ServiceUIFactory.JCOMPONENT_UI
表示一个作为 Swing 组件实现的 UI。

static String

ServiceUIFactory.JDIALOG_UI
表示一个作为 Swing 对话框实现的 UI。

static String

ServiceUIFactory.PANEL_UI
表示一个作为 AWT 面板实现的 UI。

返回 String 的 javax.print 中的方法

String

DocFlavor.getMediaSubtype()
返回此 DocFlavor 对象的媒体子类型（根据 MIME 类型）。

String

DocFlavor.getMediaType()
返回此 DocFlavor 对象的媒体类型（根据 MIME 类型）。

String

DocFlavor.getMimeType()
根据 MIME 类型的规范形式返回此 DocFlavor 对象的 MIME 类型字符串。

String

PrintService.getName()
返回此 PrintService 的 String 名称，应用程序可以使用该名称来请求特定的 PrintService。

abstract  String

StreamPrintService.getOutputFormat()
返回此 PrintService 所发出的文档格式。

abstract  String

StreamPrintServiceFactory.getOutputFormat()
查询该工厂，了解从此工厂获得的打印机所发出的文档的格式。

String

DocFlavor.getParameter(String paramName)
返回表示 MIME 参数的 String。

String

DocFlavor.getRepresentationClassName()
返回此 DocFlavor 对象的表示形式类名。

abstract  String[]

ServiceUIFactory.getUIClassNamesForRole(int role)
给定从此工厂获取的 UI 角色，获取实现此角色的此工厂可提供的 UI 类型。

String

DocFlavor.toString()
将此 DocFlavor 转换为字符串。

参数类型为 String 的 javax.print 中的方法

String

DocFlavor.getParameter(String paramName)
返回表示 MIME 参数的 String。

abstract  Object

ServiceUIFactory.getUI(int role, String ui)
获得一个 UI 对象，它可能被应用程序强制转换为所请求的 UI 类型并在该应用程序的用户界面中使用。

static StreamPrintServiceFactory[]

StreamPrintServiceFactory.lookupStreamPrintServiceFactories(DocFlavor flavor, String outputMimeType)
查找 PrintService 的工厂，PrintJob 可使用它来输出数据流，数据格式由 flavor 指定。

参数类型为 String 的 javax.print 中的构造方法

DocFlavor.BYTE_ARRAY(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "[B"（byte 数组）的新 DocFlavor。

DocFlavor.CHAR_ARRAY(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "[C"（字符数组）的新 DocFlavor。

DocFlavor.INPUT_STREAM(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.InputStream"（byte 流）的新 DocFlavor。

DocFlavor.READER(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.Reader"（字符流）的新 DocFlavor。

DocFlavor.SERVICE_FORMATTED(String className)
构造具有 "application/x-java-jvm-local-objectref" MIME 类型（指示服务格式化打印数据）和给定打印数据表示形式类名的新 DocFlavor。

DocFlavor.STRING(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.lang.String" 的新 DocFlavor。

DocFlavor.URL(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.net.URL" 的新 DocFlavor。

DocFlavor(String mimeType, String className)
根据给定的 MIME 类型和表示形式类名构造新的 DocFlavor 对象。

PrintException(String s)
构造带给定详细消息的 print 异常。

PrintException(String s, Exception e)
构造带给定详细消息和链异常的 print 异常。

javax.print.attribute 中 String 的使用

返回 String 的 javax.print.attribute 中的方法

String

Attribute.getName()
获取类别的名称,此属性值是该类别的一个实例。

protected  String[]

EnumSyntax.getStringTable()
返回此枚举值的枚举类的字符串表。

String

TextSyntax.getValue()
返回此文本属性的文本字符串。

String

DateTimeSyntax.toString()
返回对应于此日期-时间属性的字符串值。

String

EnumSyntax.toString()
返回对应于此枚举值的字符串值。

String

IntegerSyntax.toString()
返回对应于此整数属性的字符串值。

String

ResolutionSyntax.toString()
返回此分辨率属性的字符串版本。

String

SetOfIntegerSyntax.toString()
返回对应于此整数集属性的字符串值。

String

Size2DSyntax.toString()
返回此二维大小属性的字符串版本。

String

TextSyntax.toString()
返回标识此文本属性的字符串。

String

URISyntax.toString()
返回标识此 URI 属性的字符串。

String

ResolutionSyntax.toString(int units, String unitsName)
返回给定单位的此分辨率属性的字符串版本。

String

Size2DSyntax.toString(int units, String unitsName)
返回给定单位的此二维大小属性的字符串版本。

参数类型为 String 的 javax.print.attribute 中的方法

String

ResolutionSyntax.toString(int units, String unitsName)
返回给定单位的此分辨率属性的字符串版本。

String

Size2DSyntax.toString(int units, String unitsName)
返回给定单位的此二维大小属性的字符串版本。

参数类型为 String 的 javax.print.attribute 中的构造方法

SetOfIntegerSyntax(String members)
使用以字符串形式给定的成员构造一个新的整数集属性。

TextSyntax(String value, Locale locale)
使用指定的字符串和语言环境构造 TextAttribute。

UnmodifiableSetException(String message)
构造带指定详细消息的 UnmodifiableSetException。

javax.print.attribute.standard 中 String 的使用

返回 String 的 javax.print.attribute.standard 中的方法

String

Chromaticity.getName()
获取类别名称，这里此属性值是该类别的实例。

String

ColorSupported.getName()
获取类别名称，这里此属性值是该类别的实例。

String

Compression.getName()
获取类别名称，这里此属性值是该类别的实例。

String

Copies.getName()
获取类别名称，这里此属性值是该类别的实例。

String

CopiesSupported.getName()
获取类别名称，这里此属性值是该类别的实例。

String

DateTimeAtCompleted.getName()
获取类别名称，这里此属性值是该类别的实例。

String

DateTimeAtCreation.getName()
获取类别名称，这里此属性值是该类别的实例。

String

DateTimeAtProcessing.getName()
获取类别名称，这里此属性值是该类别的实例。

String

Destination.getName()
获取类别名称，这里此属性值是该类别的实例。

String

DocumentName.getName()
获取类别名称，这里此属性值是该类别的实例。

String

Fidelity.getName()
获取类别名称，这里此属性值是该类别的实例。

String

Finishings.getName()
获取类别名称，此属性值为该类别的实例。

String

JobHoldUntil.getName()
获取类别名称，此属性值为该类别的实例。

String

JobImpressions.getName()
获取类别名称，此属性值为该类别的实例。

String

JobImpressionsCompleted.getName()
获取类别名称，此属性值为该类别的实例。

String

JobImpressionsSupported.getName()
获取类别名称，此属性值为该类别的实例。

String

JobKOctets.getName()
获取类别名称，此属性值为该类别的实例。

String

JobKOctetsProcessed.getName()
获取类别名称，此属性值为该类别的实例。

String

JobKOctetsSupported.getName()
获取类别名称，此属性值为该类别的实例。

String

JobMediaSheets.getName()
获取类别名称，此属性值为该类别的实例。

String

JobMediaSheetsCompleted.getName()
获取类别名称，此属性值是该类别的实例。

String

JobMediaSheetsSupported.getName()
获取类别名称，此属性值为该类别的实例。

String

JobMessageFromOperator.getName()
获取类别名称，此属性值为该类别的实例。

String

JobName.getName()
获取类别名称，此属性值为该类别的实例。

String

JobOriginatingUserName.getName()
获取类别名称，此属性值为该类别的实例。

String

JobPriority.getName()
获取类别名称，此属性值为该类别的实例。

String

JobPrioritySupported.getName()
获取类别名称，此属性值为该类别的实例。

String

JobSheets.getName()
获取类别名称，此属性值为该类别的实例。

String

JobState.getName()
获取类别名称，此属性值为该类别的实例。

String

JobStateReason.getName()
获取类别名称，此属性值为该类别的实例。

String

JobStateReasons.getName()
获取类别名称，此属性值为该类别的实例。

String

Media.getName()
获取类别名称，此属性值为该类别的实例。

String

MediaPrintableArea.getName()
获取类别名称，此属性值为该类别的实例。

String

MediaSize.getName()
获取类别名称，此属性值为该类别的实例。

String

MultipleDocumentHandling.getName()
获取类别名称，此属性值为该类别的实例。

String

NumberOfDocuments.getName()
获取类别名称，此属性值为该类别的实例。

String

NumberOfInterveningJobs.getName()
获取类别名称，此属性值为该类别的实例。

String

NumberUp.getName()
获取类别名称，此属性值为该类别的实例。

String

NumberUpSupported.getName()
获取类别名称，此属性值为该类别的实例。

String

OrientationRequested.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

OutputDeviceAssigned.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PDLOverrideSupported.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PageRanges.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PagesPerMinute.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PagesPerMinuteColor.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PresentationDirection.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrintQuality.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterInfo.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterIsAcceptingJobs.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterLocation.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterMakeAndModel.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterMessageFromOperator.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterMoreInfo.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterMoreInfoManufacturer.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterName.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterResolution.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterState.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterStateReason.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterStateReasons.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterURI.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

QueuedJobCount.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

ReferenceUriSchemesSupported.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

RequestingUserName.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

Severity.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

SheetCollate.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

Sides.getName()
获取类别的名称，此属性值是该类别的一个实例。

protected  String[]

Chromaticity.getStringTable()
返回 Chromaticity 类的字符串表。

protected  String[]

ColorSupported.getStringTable()
返回 ColorSupported 类的字符串表。

protected  String[]

Compression.getStringTable()
返回 Compression 类的字符串表。

protected  String[]

Fidelity.getStringTable()
返回 Fidelity 类的字符串表。

protected  String[]

Finishings.getStringTable()
返回 Finishings 类的字符串表。

protected  String[]

JobSheets.getStringTable()
返回 JobSheets 类的字符串表。

protected  String[]

JobState.getStringTable()
返回 JobState 类的字符串表。

protected  String[]

JobStateReason.getStringTable()
返回 JobStateReason 类的字符串表。

protected  String[]

MediaName.getStringTable()
返回 MediaTray 类的字符串表。

protected  String[]

MediaSizeName.getStringTable()
返回 MediaSizeName 类的字符串表。

protected  String[]

MediaTray.getStringTable()
返回 MediaTray 类字符串表。

protected  String[]

MultipleDocumentHandling.getStringTable()
返回 MultipleDocumentHandling 类的字符串表。

protected  String[]

OrientationRequested.getStringTable()
返回类 OrientationRequested 的字符串表。

protected  String[]

PDLOverrideSupported.getStringTable()
返回类 PDLOverrideSupported 的字符串表。

protected  String[]

PresentationDirection.getStringTable()
返回类 PresentationDirection 的字符串表。

protected  String[]

PrintQuality.getStringTable()
返回类 PrintQuality 的字符串表。

protected  String[]

PrinterIsAcceptingJobs.getStringTable()
返回类 PrinterIsAcceptingJobs 的字符串表。

protected  String[]

PrinterState.getStringTable()
返回类 PrinterState 的字符串表。

protected  String[]

PrinterStateReason.getStringTable()
返回类 PrinterStateReason 的字符串表。

protected  String[]

ReferenceUriSchemesSupported.getStringTable()
返回类 ReferenceUriSchemesSupported 的字符串表。

protected  String[]

Severity.getStringTable()
返回类 Severity 的字符串表。

protected  String[]

SheetCollate.getStringTable()
返回类 SheetCollate 的字符串表。

protected  String[]

Sides.getStringTable()
返回类 Sides 的字符串表。

String

MediaPrintableArea.toString()
以 mm 为单位返回此矩形大小属性的字符串版本。

String

MediaPrintableArea.toString(int units, String unitsName)
以给定单位返回此矩形大小属性的字符串版本。

参数类型为 String 的 javax.print.attribute.standard 中的方法

String

MediaPrintableArea.toString(int units, String unitsName)
以给定单位返回此矩形大小属性的字符串版本。

参数类型为 String 的 javax.print.attribute.standard 中的构造方法

DocumentName(String documentName, Locale locale)
构造具有给定文档名称和语言环境的新文档名称属性。

JobMessageFromOperator(String message, Locale locale)
使用给定消息和语言环境构造新的 JobMessageFromOperator 属性。

JobName(String jobName, Locale locale)
构造具有给定作业名称和语言环境的新JobName属性。

JobOriginatingUserName(String userName, Locale locale)
构造具有给定用户名称和语言环境的新的 JobOriginatingUserName 属性。

OutputDeviceAssigned(String deviceName, Locale locale)
构造具有给定设备名称和语言环境的新 OutputDeviceAssigned 属性。

PageRanges(String members)
构造具有给定成员（字符串形式）的新 PageRanges 属性。

PrinterInfo(String info, Locale locale)
构造具有给定信息字符串和语言环境的新 PrinterInfo 属性。

PrinterLocation(String location, Locale locale)
构造具有给定位置和语言环境的新 PrinterLocation 属性。

PrinterMakeAndModel(String makeAndModel, Locale locale)
构造具有给定制造和型号字符串以及语言环境的新 PrinterMakeAndModel 属性。

PrinterMessageFromOperator(String message, Locale locale)
构造具有给定消息和语言环境的新 PrinterMessageFromOperator 属性。

PrinterName(String printerName, Locale locale)
构造具有给定名称和语言环境的新 PrinterName 属性。

RequestingUserName(String userName, Locale locale)
构造具有给定用户名称和语言环境的新 RequestingUserName 属性。

javax.print.event 中 String 的使用

返回 String 的 javax.print.event 中的方法

String

PrintEvent.toString()

javax.rmi.CORBA 中 String 的使用

返回 String 的 javax.rmi.CORBA 中的方法

static String

Util.getCodebase(Class clz)
返回给定类的代码基（如果存在）。

String

UtilDelegate.getCodebase(Class clz)
Util.getCodebase(java.lang.Class) 的委托调用。

String

ValueHandler.getRMIRepositoryID(Class clz)
返回给定 Java 类的 CORBA RepositoryId。

String

Stub.toString()
返回此 stub 的字符串表示形式。

String

StubDelegate.toString(Stub self)
Stub.toString() 的委托调用。

参数类型为 String 的 javax.rmi.CORBA 中的方法

static Class

Util.loadClass(String className, String remoteCodebase, ClassLoader loader)
为指定的类返回一个类实例。

Class

UtilDelegate.loadClass(String className, String remoteCodebase, ClassLoader loader)
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。

Serializable

ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
使用 Java 语义从流中读取一个值。

javax.rmi.ssl 中 String 的使用

返回 String 的 javax.rmi.ssl 中的方法

String[]

SslRMIServerSocketFactory.getEnabledCipherSuites()
返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的密码套件的名称，如果此工厂使用默认启用的密码套件，则返回 null。

String[]

SslRMIServerSocketFactory.getEnabledProtocols()
返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的协议版本的名称，如果此工厂使用默认启用的协议版本，则返回 null。

参数类型为 String 的 javax.rmi.ssl 中的方法

Socket

SslRMIClientSocketFactory.createSocket(String host, int port)
创建一个 SSL 套接字。

参数类型为 String 的 javax.rmi.ssl 中的构造方法

SslRMIServerSocketFactory(String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
使用指定的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。

SslRMIServerSocketFactory(String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
使用指定的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。

javax.script 中 String 的使用

声明为 String 的 javax.script 中的字段

static String

ScriptEngine.ARGV
指定值的保留键，它将一个位置参数数组传递给某一脚本。

static String

ScriptEngine.ENGINE
指定值的保留键，它是 ScriptEngine 实现的名称。

static String

ScriptEngine.ENGINE_VERSION
指定值的保留键，它标识 ScriptEngine 实现的版本。

static String

ScriptEngine.FILENAME
指定值的保留键，它是将被执行的文件的名称。

static String

ScriptEngine.LANGUAGE
指定值的保留键，它是受实现支持的 Scripting Language 的完全名称。

static String

ScriptEngine.LANGUAGE_VERSION
指定值的保留键，它标识受实现支持的脚本语言的版本。

static String

ScriptEngine.NAME
指定值的保留键，它标识脚本语言的短名称。

返回 String 的 javax.script 中的方法

String

ScriptEngineFactory.getEngineName()
返回 ScriptEngine 的完全名称。

String

ScriptEngineFactory.getEngineVersion()
返回 ScriptEngine 的版本。

String

ScriptException.getFileName()
获取导致错误的脚本的源。

String

ScriptEngineFactory.getLanguageName()
返回此 ScriptEngine 支持的脚本语言的名称。

String

ScriptEngineFactory.getLanguageVersion()
返回此 ScriptEngine 支持的脚本语言的版本。

String

ScriptException.getMessage()
返回一条消息，该消息包含传递给构造方法的 String，以及行号、列号和文件名（如果它们已知）。

String

ScriptEngineFactory.getMethodCallSyntax(String obj, String m, String... args)
返回一个 String，该 String 可用来调用使用受支持脚本语言语法的 Java 对象的方法。

String

ScriptEngineFactory.getOutputStatement(String toDisplay)
返回一个 String，该 String 可用作一个语句来显示使用受支持脚本语言语法的指定 String。

String

ScriptEngineFactory.getProgram(String... statements)
返回一个包含给定语句的有效脚本语言的可执行程序。

返回变量类型为 String 的类型的 javax.script 中的方法

Set<Map.Entry<String,Object>>

SimpleBindings.entrySet()
返回此映射中包含的映射关系的 Set 视图。

List<String>

ScriptEngineFactory.getExtensions()
返回文件扩展名的不可变列表，这些扩展名通常标识使用此 ScriptEngine 支持的语言所编写的脚本。

List<String>

ScriptEngineFactory.getMimeTypes()
返回 mimetypes 的不可变列表，这些 mimetypes 与可由引擎执行的脚本关联。

List<String>

ScriptEngineFactory.getNames()
返回 ScriptEngine 短名称的不可变列表，这些名称由 ScriptEngineManager 用来标识 ScriptEngine。

Set<String>

SimpleBindings.keySet()
返回此映射中包含的键的 Set 视图。

参数类型为 String 的 javax.script 中的方法

CompiledScript

Compilable.compile(String script)
编译脚本（以 String 形式表示的源），以便以后执行。

Object

AbstractScriptEngine.eval(String script)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader) 相同。

Object

ScriptEngine.eval(String script)
执行指定的脚本。

Object

AbstractScriptEngine.eval(String script, Bindings bindings)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。

Object

ScriptEngine.eval(String script, Bindings n)
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。

Object

ScriptEngine.eval(String script, ScriptContext context)
立即执行脚本，该脚本的源是作为第一个参数传递的 String。

Object

AbstractScriptEngine.get(String key)
获取受保护 context 字段的 ENGINE_SCOPE 中指定键的值。

Object

ScriptEngine.get(String key)
获取在此引擎的状态中设置的值。

Object

ScriptEngineManager.get(String key)
获取 Global Scope 中指定键的值。

Object

ScriptContext.getAttribute(String name)
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。

Object

SimpleScriptContext.getAttribute(String name)
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。

Object

ScriptContext.getAttribute(String name, int scope)
获取给定范围中某一属性的值。

Object

SimpleScriptContext.getAttribute(String name, int scope)
获取给定范围中某一属性的值。

int

ScriptContext.getAttributesScope(String name)
获取定义了某个属性的最小范围。

int

SimpleScriptContext.getAttributesScope(String name)
获取用来定义属性的最小范围。

ScriptEngine

ScriptEngineManager.getEngineByExtension(String extension)
查找并创建一个给定扩展的 ScriptEngine。

ScriptEngine

ScriptEngineManager.getEngineByMimeType(String mimeType)
查找并创建一个给定 mime 类型的 ScriptEngine。

ScriptEngine

ScriptEngineManager.getEngineByName(String shortName)
查找并创建一个给定名称的 ScriptEngine。

String

ScriptEngineFactory.getMethodCallSyntax(String obj, String m, String... args)
返回一个 String，该 String 可用来调用使用受支持脚本语言语法的 Java 对象的方法。

String

ScriptEngineFactory.getMethodCallSyntax(String obj, String m, String... args)
返回一个 String，该 String 可用来调用使用受支持脚本语言语法的 Java 对象的方法。

String

ScriptEngineFactory.getOutputStatement(String toDisplay)
返回一个 String，该 String 可用作一个语句来显示使用受支持脚本语言语法的指定 String。

Object

ScriptEngineFactory.getParameter(String key)
返回属性值，该属性的含义可能是特定于实现的。

String

ScriptEngineFactory.getProgram(String... statements)
返回一个包含给定语句的有效脚本语言的可执行程序。

Object

Invocable.invokeFunction(String name, Object... args)
用于调用脚本中定义的顶层程序和函数。

Object

Invocable.invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

void

AbstractScriptEngine.put(String key, Object value)
使用受保护 context 字段的 ENGINE_SCOPE Bindings 中的指定键设置指定的值。

Object

Bindings.put(String name, Object value)
设置指定的值。

void

ScriptEngine.put(String key, Object value)
设置 ScriptEngine 的状态中的键/值对，它创建一个将在脚本执行中使用或者以其他方式使用的 Java Language Binding，具体取决于该键是否被保留。

void

ScriptEngineManager.put(String key, Object value)
设置 Global Scope 中指定的键/值对。

Object

SimpleBindings.put(String name, Object value)
设置底层 map 字段中的指定键/值。

void

ScriptEngineManager.registerEngineExtension(String extension, ScriptEngineFactory factory)
注册一个 ScriptEngineFactory 来处理扩展。

void

ScriptEngineManager.registerEngineMimeType(String type, ScriptEngineFactory factory)
注册一个 ScriptEngineFactory 来处理 mime 类型。

void

ScriptEngineManager.registerEngineName(String name, ScriptEngineFactory factory)
注册一个 ScriptEngineFactory 来处理语言名称。

Object

ScriptContext.removeAttribute(String name, int scope)
移除给定范围中的某一属性。

Object

SimpleScriptContext.removeAttribute(String name, int scope)
移除给定范围中的某一属性。

void

ScriptContext.setAttribute(String name, Object value, int scope)
设置给定范围中某一属性的值。

void

SimpleScriptContext.setAttribute(String name, Object value, int scope)
设置给定范围中某一属性的值。

类型变量类型为 String 的 javax.script 中的方法参数

void

Bindings.putAll(Map<? extends String,? extends Object> toMerge)
将给定 Map 中的所有映射关系添加到此 Bindings 中。

void

SimpleBindings.putAll(Map<? extends String,? extends Object> toMerge)
putAll 是使用 Map.putAll 实现的。

参数类型为 String 的 javax.script 中的构造方法

ScriptException(String s)
使用将在其消息中使用的 String 创建一个 ScriptException。

ScriptException(String message, String fileName, int lineNumber)
使用将在错误消息中使用的消息、文件名和行号创建一个 ScriptException。

ScriptException(String message, String fileName, int lineNumber, int columnNumber)
指定消息、文件名、行号和列号的 ScriptException 构造方法。

类型变量类型为 String 的 javax.script 中的构造方法参数

SimpleBindings(Map<String,Object> m)
构造方法使用现有 Map 来存储值。

javax.security.auth 中 String 的使用

返回 String 的 javax.security.auth 中的方法

String

PrivateCredentialPermission.getActions()
返回操作的“规范的字符串表示形式”。

String

PrivateCredentialPermission.getCredentialClass()
返回与此 PrivateCredentialPermission 相关联的 Credential 的 Class 名称。

String[][]

PrivateCredentialPermission.getPrincipals()
返回与此 PrivateCredentialPermission 相关联的 Principal 类和名称。

String

Subject.toString()
返回此 Subject 的字符串表示形式。

参数类型为 String 的 javax.security.auth 中的构造方法

AuthPermission(String name)
创建具有指定名称的新 AuthPermission。

AuthPermission(String name, String actions)
创建具有指定名称的新 AuthPermission 对象。

DestroyFailedException(String msg)
构造带指定详细消息的 DestroyFailedException。

PrivateCredentialPermission(String name, String actions)
创建具有指定 name 的新 PrivateCredentialPermission。

RefreshFailedException(String msg)
构造带指定详细消息的 RefreshFailedException。

javax.security.auth.callback 中 String 的使用

返回 String 的 javax.security.auth.callback 中的方法

String[]

ChoiceCallback.getChoices()
获取选项列表。

String

NameCallback.getDefaultName()
获取默认名称。

String

TextInputCallback.getDefaultText()
获取默认文本。

String

TextOutputCallback.getMessage()
获取将要显示的消息。

String

NameCallback.getName()
获取检索到的名称。

String[]

ConfirmationCallback.getOptions()
获取确认选项。

String

ChoiceCallback.getPrompt()
获取提示。

String

ConfirmationCallback.getPrompt()
获取提示。

String

NameCallback.getPrompt()
获取提示。

String

PasswordCallback.getPrompt()
获取提示。

String

TextInputCallback.getPrompt()
获取提示。

String

TextInputCallback.getText()
获取检索到的文本。

参数类型为 String 的 javax.security.auth.callback 中的方法

void

NameCallback.setName(String name)
设置检索到的名称。

void

TextInputCallback.setText(String text)
设置获取到的文本。

参数类型为 String 的 javax.security.auth.callback 中的构造方法

ChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multipleSelectionsAllowed)
构造一个 ChoiceCallback，带有提示、选项列表、默认选项和指定选项列表是否允许进行多重选择的布尔值。

ChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multipleSelectionsAllowed)
构造一个 ChoiceCallback，带有提示、选项列表、默认选项和指定选项列表是否允许进行多重选择的布尔值。

ConfirmationCallback(int messageType, String[] options, int defaultOption)
构造一个带有消息类型、选项列表和默认选项的 ConfirmationCallback。

ConfirmationCallback(String prompt, int messageType, int optionType, int defaultOption)
构造一个带有提示、消息类型、选项类型和默认选项的 ConfirmationCallback。

ConfirmationCallback(String prompt, int messageType, String[] options, int defaultOption)
构造一个带有提示、消息类型、选项列表和默认选项的 ConfirmationCallback。

ConfirmationCallback(String prompt, int messageType, String[] options, int defaultOption)
构造一个带有提示、消息类型、选项列表和默认选项的 ConfirmationCallback。

NameCallback(String prompt)
构造一个带提示的 NameCallback。

NameCallback(String prompt, String defaultName)
构造一个带提示和默认名称的 NameCallback。

PasswordCallback(String prompt, boolean echoOn)
构造带提示和布尔值的 PasswordCallback，该布尔值指定键入密码时是否应该显示该密码。

TextInputCallback(String prompt)
构造一个带提示的 TextInputCallback。

TextInputCallback(String prompt, String defaultText)
构造一个带提示和默认输入值的 TextInputCallback。

TextOutputCallback(int messageType, String message)
构造一个带消息类型和将要显示的消息的 TextOutputCallback。

UnsupportedCallbackException(Callback callback, String msg)
构造带指定详细消息的 UnsupportedCallbackException。

javax.security.auth.kerberos 中 String 的使用

返回 String 的 javax.security.auth.kerberos 中的方法

String

ServicePermission.getActions()
返回动作的规范化字符串表示形式。

String

KerberosKey.getAlgorithm()
返回此密钥的标准算法名称。

String

KerberosKey.getFormat()
返回此秘密密钥的编码格式的名称。

String

KerberosPrincipal.getName()
返回的字符串对应于 Kerberos Principal 名称的 single-string 表示形式，RFC 1964 的 2.1 小节中指定了这种表示形式。

String

KerberosPrincipal.getRealm()
返回此 Kerberos 主体的域组件。

String

KerberosKey.toString()

String

KerberosPrincipal.toString()

String

KerberosTicket.toString()

参数类型为 String 的 javax.security.auth.kerberos 中的构造方法

DelegationPermission(String principals)
创建带有指定从属主体和目标主体的新 DelegationPermission。

DelegationPermission(String principals, String actions)
创建带有指定从属主体和目标主体的新 DelegationPermission。

KerberosKey(KerberosPrincipal principal, char[] password, String algorithm)
根据主体的密码构造 KerberosKey。

KerberosPrincipal(String name)
根据提供的字符串输入构造 KerberosPrincipal。

KerberosPrincipal(String name, int nameType)
根据提供的字符串和名称类型输入构造 KerberosPrincipal。

ServicePermission(String servicePrincipal, String action)
创建带指定的 servicePrincipal 和 action 的新 ServicePermission。

javax.security.auth.login 中 String 的使用

返回 String 的 javax.security.auth.login 中的方法

String

AppConfigurationEntry.getLoginModuleName()
获取所配置的 LoginModule 的类名称。

String

Configuration.getType()
返回此 Configuration 的类型。

String

AppConfigurationEntry.LoginModuleControlFlag.toString()
返回此 controlFlag 的字符串表示形式。

返回变量类型为 String 的类型的 javax.security.auth.login 中的方法

Map<String,?>

AppConfigurationEntry.getOptions()
获取为此 LoginModule 配置的选项。

参数类型为 String 的 javax.security.auth.login 中的方法

protected abstract  AppConfigurationEntry[]

ConfigurationSpi.engineGetAppConfigurationEntry(String name)
获取指定 name 的 AppConfigurationEntry。

abstract  AppConfigurationEntry[]

Configuration.getAppConfigurationEntry(String name)
获取此 Configuration 中指定 name 的 AppConfigurationEntry。

static Configuration

Configuration.getInstance(String type, Configuration.Parameters params)
返回指定类型的 Configuration 对象。

static Configuration

Configuration.getInstance(String type, Configuration.Parameters params, Provider provider)
返回指定类型的 Configuration 对象。

static Configuration

Configuration.getInstance(String type, Configuration.Parameters params, String provider)
返回指定类型的 Configuration 对象。

参数类型为 String 的 javax.security.auth.login 中的构造方法

AccountException(String msg)
构造带指定详细消息的 AccountException。

AccountExpiredException(String msg)
构造带指定详细消息的 AccountExpiredException。

AccountLockedException(String msg)
构造带指定详细消息的 AccountLockedException。

AccountNotFoundException(String msg)
构造带指定详细消息的 AccountNotFoundException。

AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
此类的默认构造方法。

CredentialException(String msg)
构造带指定详细消息的 CredentialException。

CredentialExpiredException(String msg)
构造带指定详细消息的 CredentialExpiredException。

CredentialNotFoundException(String msg)
构造带指定详细消息的 CredentialNotFoundException。

FailedLoginException(String msg)
构造带指定详细消息的 FailedLoginException。

LoginContext(String name)
使用 name 实例化一个新 LoginContext 对象。

LoginContext(String name, CallbackHandler callbackHandler)
使用 name 和 CallbackHandler 对象实例化一个新 LoginContext 对象。

LoginContext(String name, Subject subject)
使用 name 和 Subject 对象实例化一个新 LoginContext 对象。

LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。

LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

LoginException(String msg)
构造带指定详细消息的 LoginException。

类型变量类型为 String 的 javax.security.auth.login 中的构造方法参数

AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
此类的默认构造方法。

javax.security.auth.spi 中 String 的使用

类型变量类型为 String 的 javax.security.auth.spi 中的方法参数

void

LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
初始化此 LoginModule。

void

LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
初始化此 LoginModule。

javax.security.auth.x500 中 String 的使用

声明为 String 的 javax.security.auth.x500 中的字段

static String

X500Principal.CANONICAL
标识名的规范化字符串格式。

static String

X500Principal.RFC1779
标识名的 RFC 1779 字符串格式。

static String

X500Principal.RFC2253
标识名的 RFC 2253 字符串格式。

返回 String 的 javax.security.auth.x500 中的方法

String

X500PrivateCredential.getAlias()
返回 KeyStore 别名。

String

X500Principal.getName()
返回使用 RFC 2253 中所定义格式的 X.500 标识名的字符串表示形式。

String

X500Principal.getName(String format)
返回使用指定格式的 X.500 标识名的字符串表示形式。

String

X500Principal.getName(String format, Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。

String

X500Principal.toString()
返回此 X500Principal 的用户友好的字符串表示形式。

参数类型为 String 的 javax.security.auth.x500 中的方法

String

X500Principal.getName(String format)
返回使用指定格式的 X.500 标识名的字符串表示形式。

String

X500Principal.getName(String format, Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。

类型变量类型为 String 的 javax.security.auth.x500 中的方法参数

String

X500Principal.getName(String format, Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。

String

X500Principal.getName(String format, Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。

参数类型为 String 的 javax.security.auth.x500 中的构造方法

X500Principal(String name)
根据 X.500 标识名（例："CN=Duke、 OU=JavaSoft、 O=Sun Microsystems、 C=US"）的字符串表示形式创建 X500Principal。

X500Principal(String name, Map<String,String> keywordMap)
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。

X500PrivateCredential(X509Certificate cert, PrivateKey key, String alias)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。

类型变量类型为 String 的 javax.security.auth.x500 中的构造方法参数

X500Principal(String name, Map<String,String> keywordMap)
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。

X500Principal(String name, Map<String,String> keywordMap)
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。

javax.security.cert 中 String 的使用

返回 String 的 javax.security.cert 中的方法

abstract  String

X509Certificate.getSigAlgName()
获取用于该证书签名算法的名称。

abstract  String

X509Certificate.getSigAlgOID()
获取证书的签名算法 OID 字符串。

abstract  String

Certificate.toString()
返回此证书的字符串表示形式。

参数类型为 String 的 javax.security.cert 中的方法

abstract  void

Certificate.verify(PublicKey key, String sigProvider)
验证是否已使用与指定公钥相对应的私钥签署了此证书。

参数类型为 String 的 javax.security.cert 中的构造方法

CertificateEncodingException(String message)
构造带指定详细信息的 CertificateEncodingException。

CertificateException(String msg)
构造带给定详细消息的 CertificateException。

CertificateExpiredException(String message)
构造带指定详细信息的 CertificateExpiredException。

CertificateNotYetValidException(String message)
构造带指定详细消息的 CertificateNotYetValidException。

CertificateParsingException(String message)
构造带指定详细信息的 CertificateParsingException。

javax.security.sasl 中 String 的使用

声明为 String 的 javax.security.sasl 中的字段

static String

Sasl.CREDENTIALS
属性的名称，它指定要使用的证书。

static String

Sasl.MAX_BUFFER
属性名，指定 SaslClient/SaslServer 接收缓冲区的最大大小（以字节为单位）。

static String

Sasl.POLICY_FORWARD_SECRECY
属性名，指定是否需要在会话间实现了转发安全性的机制。

static String

Sasl.POLICY_NOACTIVE
属性名，指定是否允许易受主动式攻击（非字典）的机制。

static String

Sasl.POLICY_NOANONYMOUS
属性名，指定是否允许接受匿名登录的机制。

static String

Sasl.POLICY_NODICTIONARY
属性名，指定是否允许易受被动式字典攻击的机制。

static String

Sasl.POLICY_NOPLAINTEXT
属性名，指定是否允许易受简单被动式攻击（例如 "PLAIN"）的机制。

static String

Sasl.POLICY_PASS_CREDENTIALS
属性名，指定是否需要传递客户端证书的机制。

static String

Sasl.QOP
属性名，指定要使用的保护级别。

static String

Sasl.RAW_SEND_SIZE
属性名，指定 SaslClient/SaslServer 初始发送缓冲区的最大大小（以字节为单位）。

static String

Sasl.REUSE
属性名，指定是否重用以前已验证过的会话信息。

static String

Sasl.SERVER_AUTH
属性名，指定服务器是否必须验证客户端。

static String

Sasl.STRENGTH
属性名，指定要使用的密码强度。

返回 String 的 javax.security.sasl 中的方法

String

AuthorizeCallback.getAuthenticationID()
返回要检查的验证 id。

String

AuthorizeCallback.getAuthorizationID()
返回要检查的授权 id。

String

SaslServer.getAuthorizationID()
报告此会话客户端的有效授权 ID。

String

AuthorizeCallback.getAuthorizedID()
返回已授权用户的 id。

String

SaslClient.getMechanismName()
返回此 SASL 客户端的 IANA 注册机制名。

String

SaslServer.getMechanismName()
返回此 SASL 服务器的 IANA 注册机制名。

String[]

SaslClientFactory.getMechanismNames(Map<String,?> props)
返回与指定的机制选择策略相符的机制的名称数组。

String[]

SaslServerFactory.getMechanismNames(Map<String,?> props)
返回与指定的机制选择策略相符的机制的名称数组。

String

SaslException.toString()
返回此异常的字符串表示形式。

参数类型为 String 的 javax.security.sasl 中的方法

static SaslClient

Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

static SaslClient

Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

SaslClient

SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

SaslClient

SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

static SaslServer

Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
为指定机制创建一个 SaslServer。

SaslServer

SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslServer。

Object

SaslClient.getNegotiatedProperty(String propName)
获取已协商的属性。

Object

SaslServer.getNegotiatedProperty(String propName)
获取已协商的属性。

void

AuthorizeCallback.setAuthorizedID(String id)
设置已授权实体的 id。

类型变量类型为 String 的 javax.security.sasl 中的方法参数

static SaslClient

Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

SaslClient

SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

static SaslServer

Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
为指定机制创建一个 SaslServer。

SaslServer

SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslServer。

String[]

SaslClientFactory.getMechanismNames(Map<String,?> props)
返回与指定的机制选择策略相符的机制的名称数组。

String[]

SaslServerFactory.getMechanismNames(Map<String,?> props)
返回与指定的机制选择策略相符的机制的名称数组。

参数类型为 String 的 javax.security.sasl 中的构造方法

AuthenticationException(String detail)
构造带详细消息的新 AuthenticationException 实例。

AuthenticationException(String detail, Throwable ex)
构造带详细消息和根异常的新 AuthenticationException 实例。

AuthorizeCallback(String authnID, String authzID)
构造 AuthorizeCallback 的实例。

RealmCallback(String prompt)
构造带提示的 RealmCallback。

RealmCallback(String prompt, String defaultRealmInfo)
构造带提示和默认领域信息的 RealmCallback。

RealmChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multiple)
构造带提示、选项列表和默认选项的 RealmChoiceCallback。

RealmChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multiple)
构造带提示、选项列表和默认选项的 RealmChoiceCallback。

SaslException(String detail)
构造带详细消息的新 SaslException 实例。

SaslException(String detail, Throwable ex)
构造带详细消息和根异常的新 SaslException 实例。

javax.sound.midi 中 String 的使用

返回 String 的 javax.sound.midi 中的方法

String

MidiDevice.Info.getDescription()
获得关于设备的描述。

String

Soundbank.getDescription()
获得音库适于显示的文本描述。

String

MidiDevice.Info.getName()
获得设备的名称。

String

Soundbank.getName()
获得音库的名称。

String

SoundbankResource.getName()
获得资源的名称。

String

MidiDevice.Info.getVendor()
获得提供设备的公司名称。

String

Soundbank.getVendor()
获得命名提供此音库的公司的 string

String

MidiDevice.Info.getVersion()
获得设备的版本。

String

Soundbank.getVersion()
获得音库的版本字符串。

String

MidiDevice.Info.toString()
提供设备信息的字符串表示形式。

String

Sequencer.SyncMode.toString()
以模式的字符串表示形式提供此同步模式的名称。

返回变量类型为 String 的类型的 javax.sound.midi 中的方法

Map<String,Object>

MidiFileFormat.properties()
获得属性的一个不可修改的映射。

参数类型为 String 的 javax.sound.midi 中的方法

Object

MidiFileFormat.getProperty(String key)
获得由键指定的属性值。

参数类型为 String 的 javax.sound.midi 中的构造方法

Instrument(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)
从指定的 Patch 构造一个新的 MIDI 乐器。

InvalidMidiDataException(String message)
构造带指定详细消息的 InvalidMidiDataException。

MidiDevice.Info(String name, String vendor, String description, String version)
构造一个设备 info 对象。

MidiUnavailableException(String message)
构造带指定详细消息的 MidiUnavailableException。

Sequencer.SyncMode(String name)
构造一个同步模式。

SoundbankResource(Soundbank soundBank, String name, Class<?> dataClass)
根据给定的音库和波表索引构造一个新的 SoundbankResource。

类型变量类型为 String 的 javax.sound.midi 中的构造方法参数

MidiFileFormat(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)
构造带一组属性的 MidiFileFormat。

javax.sound.sampled 中 String 的使用

返回 String 的 javax.sound.sampled 中的方法

String

Mixer.Info.getDescription()
获得混频器的描述。

String

AudioFileFormat.Type.getExtension()
获得此文件类型的常见文件扩展名。

String

FloatControl.getMaxLabel()
获得最大值的标签，如 "Right" 或 "Full"。

String

FloatControl.getMidLabel()
获得中点值的标签，如 "Center" 或 "Default"。

String

FloatControl.getMinLabel()
获得最小值的标签，如 "Left" 或 "Off"。

String

Mixer.Info.getName()
获得混频器的名称。

String

Port.Info.getName()
获得端口的名称。

String

ReverbType.getName()
获得此回响类型的名称。

String

BooleanControl.getStateLabel(boolean state)
获得指定状态的标签。

String

FloatControl.getUnits()
获得表示控件值的单位标签，如 "dB" 或 "frames per second"。

String

Mixer.Info.getVendor()
获得混频器的供应商。

String

Mixer.Info.getVersion()
获得混频器的版本。

String

AudioFileFormat.toString()
提供文件格式的字符串表示形式。

String

AudioFileFormat.Type.toString()
按文件类型的 String 表示形式提供文件类型的名称。

String

AudioFormat.toString()
返回描述格式的字符串，如："PCM SIGNED 22050 Hz 16 bit mono big-endian"。

String

AudioFormat.Encoding.toString()
提供编码的 String 表示形式。

String

BooleanControl.toString()
提供控件的字符串表示形式

String

CompoundControl.toString()
提供控件的字符串表示形式

String

Control.toString()
获得描述控件类型及其当前状态的 String。

String

Control.Type.toString()
提供控件类型的 String 表示形式。

String

EnumControl.toString()
提供该控件的字符串表示形式。

String

FloatControl.toString()
提供控件的字符串表示形式

String

LineEvent.toString()
获得事件的字符串表示形式。

String

LineEvent.Type.toString()
以字符串形式返回类型名称。

String

Mixer.Info.toString()
提供混频器信息的字符串表示形式。

String

Port.Info.toString()
提供该端口的 String 表示形式。

String

ReverbType.toString()
提供回响类型的 String 表示形式，包括其名称和其参数设置。

String

DataLine.Info.toString()
获得数据行信息的文本描述。

String

Line.Info.toString()
获得行信息的文本描述。

返回变量类型为 String 的类型的 javax.sound.sampled 中的方法

Map<String,Object>

AudioFileFormat.properties()
获得不可修改的属性映射。

Map<String,Object>

AudioFormat.properties()
获取不可修改的属性映射。

参数类型为 String 的 javax.sound.sampled 中的方法

Object

AudioFileFormat.getProperty(String key)
获得键指定的属性值。

Object

AudioFormat.getProperty(String key)
获取键指定的属性值。

参数类型为 String 的 javax.sound.sampled 中的构造方法

AudioFileFormat.Type(String name, String extension)
构造文件类型。

AudioFormat.Encoding(String name)
构造一个新编码。

AudioPermission(String name)
创建具有指定符号名（如 "play" 或 "record"）的 AudioPermission 对象。

AudioPermission(String name, String actions)
创建具有指定符号名（"play" 或 "record"）的 AudioPermission 对象。

BooleanControl.Type(String name)
构造新的 boolean 控件类型。

BooleanControl(BooleanControl.Type type, boolean initialValue, String trueStateLabel, String falseStateLabel)
构造一个具有给定参数的新 boolean 控件对象。

CompoundControl.Type(String name)
构造一个新的组合控件类型。

Control.Type(String name)
构造具有指定名称的新控件类型。

EnumControl.Type(String name)
构造一个新的枚举控件类型。

FloatControl.Type(String name)
构造新的 float 控件类型。

FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units)
构造具有给定参数的新 float 控件对象。

FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units, String minLabel, String midLabel, String maxLabel)
构造具有给定参数的新 float 控件对象

LineEvent.Type(String name)
构造新的事件类型。

LineUnavailableException(String message)
构造具有指定详细消息的 LineUnavailableException。

Mixer.Info(String name, String vendor, String description, String version)
构造混频器的 info 对象，并向它传递给定的文本信息。

Port.Info(Class<?> lineClass, String name, boolean isSource)
根据给定的信息构造端口的 info 对象。

ReverbType(String name, int earlyReflectionDelay, float earlyReflectionIntensity, int lateReflectionDelay, float lateReflectionIntensity, int decayTime)
构造具有指定回响参数值的新回响类型。

UnsupportedAudioFileException(String message)
构造具有指定详细消息的 UnsupportedAudioFileException。

类型变量类型为 String 的 javax.sound.sampled 中的构造方法参数

AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。

AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
构造具有给定参数的 AudioFormat。

javax.sql 中 String 的使用

返回 String 的 javax.sql 中的方法

String

RowSet.getCommand()
获取此 RowSet 对象的命令属性。

String

RowSet.getDataSourceName()
获取标识此 RowSet 对象的数据源的逻辑名称。

String

RowSet.getPassword()
获取用于创建数据库连接的密码。

String

RowSet.getUrl()
如果此 RowSet 对象使用 DriverManager 而非 DataSource 对象建立连接，则获取创建连接时将使用的 url 属性。

String

RowSet.getUsername()
获取用于创建此 RowSet 对象的数据库连接的用户名。

返回变量类型为 String 的类型的 javax.sql 中的方法

Map<String,Class<?>>

RowSet.getTypeMap()
获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。

参数类型为 String 的 javax.sql 中的方法

Connection

DataSource.getConnection(String username, String password)
尝试建立与此 DataSource 对象所表示的数据源的连接。

PooledConnection

ConnectionPoolDataSource.getPooledConnection(String user, String password)
尝试建立可用作入池连接的物理数据库连接。

XAConnection

XADataSource.getXAConnection(String user, String password)
使用给定的用户名和密码，尝试建立一个物理数据库连接。

void

RowSet.setAsciiStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。

void

RowSet.setAsciiStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定字节数。

void

RowSet.setBigDecimal(String parameterName, BigDecimal x)
将指定参数设置为给定的 java.math.BigDecimal 值。

void

RowSet.setBinaryStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。

void

RowSet.setBinaryStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有给定字节数。

void

RowSet.setBlob(String parameterName, Blob x)
将指定参数设置为给定的 java.sql.Blob 对象。

void

RowSet.setBlob(String parameterName, InputStream inputStream)
将指定参数设置为 InputStream 对象。

void

RowSet.setBlob(String parameterName, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。

void

RowSet.setBoolean(String parameterName, boolean x)
将指定参数设置为给定的 Java boolean 值。

void

RowSet.setByte(String parameterName, byte x)
将指定参数设置为给定的 Java byte 值。

void

RowSet.setBytes(String parameterName, byte[] x)
将指定参数设置为给定的 Java byte 数组。

void

RowSetMetaData.setCatalogName(int columnIndex, String catalogName)
将指定列的表的类别名称（如果有）设置为给定的 String。

void

RowSet.setCharacterStream(String parameterName, Reader reader)
将指定参数设置为给定 Reader 对象。

void

RowSet.setCharacterStream(String parameterName, Reader reader, int length)
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数目。

void

RowSet.setClob(String parameterName, Clob x)
将指定参数设置为给定的 java.sql.Clob 对象。

void

RowSet.setClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

RowSet.setClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

RowSetMetaData.setColumnLabel(int columnIndex, String label)
将建议用于打印输出和显示的列标题（如果有）设置为给定的 String。

void

RowSetMetaData.setColumnName(int columnIndex, String columnName)
将指定列的名称设置为给定的 String。

void

RowSetMetaData.setColumnTypeName(int columnIndex, String typeName)
将指定列的特定于数据源的类型名称（如果有）设置为给定的 String。

void

RowSet.setCommand(String cmd)
将此 RowSet 对象的命令属性设置为给定的 SQL 查询。

void

RowSet.setDataSourceName(String name)
将此 RowSet 对象的数据源名称属性设置为给定的 String。

void

RowSet.setDate(String parameterName, Date x)
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。

void

RowSet.setDate(String parameterName, Date x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。

void

RowSet.setDouble(String parameterName, double x)
将指定参数设置为给定的 Java double 值。

void

RowSet.setFloat(String parameterName, float x)
将指定参数设置为给定的 Java float 值。

void

RowSet.setInt(String parameterName, int x)
将指定参数设置为给定的 Java int 值。

void

RowSet.setLong(String parameterName, long x)
将指定参数设置为给定的 Java long 值。

void

RowSet.setNCharacterStream(String parameterName, Reader value)
将指定参数设置为 Reader 对象。

void

RowSet.setNCharacterStream(String parameterName, Reader value, long length)
将指定参数设置为 Reader 对象。

void

RowSet.setNClob(String parameterName, NClob value)
将指定参数设置为 java.sql.NClob 对象。

void

RowSet.setNClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

RowSet.setNClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

RowSet.setNString(int parameterIndex, String value)
将指定参数设置为给定的 String 对象。

void

RowSet.setNString(String parameterName, String value)
将指定参数设置为给定的 String 对象。

void

RowSet.setNull(int paramIndex, int sqlType, String typeName)
将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。

void

RowSet.setNull(String parameterName, int sqlType)
将指定参数设置为 SQL NULL。

void

RowSet.setNull(String parameterName, int sqlType, String typeName)
将指定参数设置为 SQL NULL。

void

RowSet.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

RowSet.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

RowSet.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

void

RowSet.setPassword(String password)
将此 RowSet 对象的数据库密码设置为给定的 String。

void

RowSet.setRowId(String parameterName, RowId x)
将指定参数设置为给定的 java.sql.RowId 对象。

void

RowSetMetaData.setSchemaName(int columnIndex, String schemaName)
将指定列的表模式的名称（如果有）设置为给定的 String。

void

RowSet.setShort(String parameterName, short x)
将指定参数设置为给定的 Java short 值。

void

RowSet.setSQLXML(String parameterName, SQLXML xmlObject)
将指定参数设置为给定的 java.sql.SQLXML 对象。

void

RowSet.setString(int parameterIndex, String x)
将此 RowSet 对象命令中的指定参数设置为给定的 Java String 值。

void

RowSet.setString(String parameterName, String x)
将指定参数设置为给定的 Java String 值。

void

RowSetMetaData.setTableName(int columnIndex, String tableName)
将指定列的表名称（如果有）设置为给定的 String。

void

RowSet.setTime(String parameterName, Time x)
将指定参数设置为给定的 java.sql.Time 值。

void

RowSet.setTime(String parameterName, Time x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。

void

RowSet.setTimestamp(String parameterName, Timestamp x)
将指定参数设置为给定的 java.sql.Timestamp 值。

void

RowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

void

RowSet.setUrl(String url)
设置此 RowSet 对象在使用 DriverManager 创建连接时将使用的 URL。

void

RowSet.setUsername(String name)
将此 RowSet 对象的用户名属性设置为给定的 String。

类型变量类型为 String 的 javax.sql 中的方法参数

void

RowSet.setTypeMap(Map<String,Class<?>> map)
将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。

javax.sql.rowset 中 String 的使用

声明为 String 的 javax.sql.rowset 中的字段

static String

WebRowSet.PUBLIC_XML_SCHEMA
为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的公共标识符。

static String

WebRowSet.SCHEMA_SYSTEM_ID
为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的 URL。

返回 String 的 javax.sql.rowset 中的方法

String

RowSetMetaDataImpl.getCatalogName(int columnIndex)
获取派生指定列中值的表的类别名称。

String

RowSetMetaDataImpl.getColumnClassName(int columnIndex)
获取 Java 编程语言中一个类的完全限定名，该类是指定列中的值将映射到的那个类。

String

RowSetMetaDataImpl.getColumnLabel(int columnIndex)
获取用于打印输出和显示的指定列的建议列标题。

String

RowSetMetaDataImpl.getColumnName(int columnIndex)
获取指定列的名称。

String

RowSetMetaDataImpl.getColumnTypeName(int columnIndex)
获取存储在指定列中值的特定于 DBMS 的类型名称。

String

BaseRowSet.getCommand()
获取作为此 RowSet 对象的命令的 SQL 查询。

String

BaseRowSet.getDataSourceName()
返回向使用 Java Naming and Directory Interface (JNDI) API 的命名服务所提供的逻辑名，这将获得 javax.sql.DataSource 对象。

String[]

Joinable.getMatchColumnNames()
获取使用方法 setMatchColumn(String [] columnNames) 为此 RowSet 对象设置的匹配列的名称。

String

BaseRowSet.getPassword()
返回用于创建此 RowSet 对象的数据库连接的密码。

String[]

JoinRowSet.getRowSetNames()
返回一个 String 数组，包含添加到此 JoinRowSet 对象的 RowSet 对象的名称。

String

RowSetMetaDataImpl.getSchemaName(int columnIndex)
获取派生指定列中值的表的模式名称。

String

CachedRowSet.getTableName()
返回创建此 CachedRowSet 对象时所用对象（表）的标识符。

String

RowSetMetaDataImpl.getTableName(int columnIndex)
获取派生指定列中值的表名称。

String

BaseRowSet.getUrl()
获取此 RowSet 对象的 javax.sql.Reader 对象用来建立与关系数据库连接（使用启用 JDBC 技术的驱动程序）的 JDBC URL。

String

BaseRowSet.getUsername()
返回用于创建数据库连接的用户名。

String

JoinRowSet.getWhereClause()
返回在 JoinRowSet 对象中使用的 WHERE 子句的类似 SQL 的描述。

返回变量类型为 String 的类型的 javax.sql.rowset 中的方法

Map<String,Class<?>>

BaseRowSet.getTypeMap()
获取与此 RowSet 对象的 Connection 对象关联的类型映射表。

参数类型为 String 的 javax.sql.rowset 中的方法

void

JoinRowSet.addRowSet(RowSet[] rowset, String[] columnName)
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列名数组中的匹配列。

void

JoinRowSet.addRowSet(RowSet rowset, String columnName)
将 rowset 添加到此 JoinRowSet 对象，并将指定的列设置为匹配列。

boolean

CachedRowSet.columnUpdated(String columnName)
指示此 CachedRowSet 对象当前行中的指定列是否已更新。

boolean

Predicate.evaluate(Object value, String columnName)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter 方法设置的过滤标准中。

void

BaseRowSet.setAsciiStream(String parameterName, InputStream x)
将指定参数设置为给定的输入流。

void

BaseRowSet.setAsciiStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定字节数。

void

BaseRowSet.setBigDecimal(String parameterName, BigDecimal x)
将指定参数设置为给定的 java.math.BigDecimal 值。

void

BaseRowSet.setBinaryStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。

void

BaseRowSet.setBinaryStream(String parameterName, InputStream x, int length)
将指定参数设置为给定的输入流，该输入流将拥有指定的字节数。

void

BaseRowSet.setBlob(String parameterName, Blob x)
将指定参数设置为给定的 java.sql.Blob 对象。

void

BaseRowSet.setBlob(String parameterName, InputStream inputStream)
将指定参数设置为 InputStream 对象。

void

BaseRowSet.setBlob(String parameterName, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。

void

BaseRowSet.setBoolean(String parameterName, boolean x)
将指定参数设置为给定的 Java boolean 值。

void

BaseRowSet.setByte(String parameterName, byte x)
将指定参数设置为给定的 Java byte 值。

void

BaseRowSet.setBytes(String parameterName, byte[] x)
将指定参数设置为给定的 Java byte 数组。

void

RowSetMetaDataImpl.setCatalogName(int columnIndex, String catalogName)
将派生指定列的表名称设置为 catalogName。

void

BaseRowSet.setCharacterStream(String parameterName, Reader reader)
将指定参数设置为给定 Reader 对象。

void

BaseRowSet.setCharacterStream(String parameterName, Reader reader, int length)
将指定参数设置为给定的 Reader 对象，该对象是给定的字符长度数目。

void

BaseRowSet.setClob(String parameterName, Clob x)
将指定参数设置为给定的 java.sql.Clob 对象。

void

BaseRowSet.setClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

BaseRowSet.setClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

RowSetMetaDataImpl.setColumnLabel(int columnIndex, String label)
将建议用于打印输出和显示的列标签（如果有）设置为给定的 label。

void

RowSetMetaDataImpl.setColumnName(int columnIndex, String columnName)
将指定列的列名称设置为给定的名称。

void

RowSetMetaDataImpl.setColumnTypeName(int columnIndex, String typeName)
将供存储在指定列中的值的数据源使用的类型名称设置为给定类型名称。

void

BaseRowSet.setCommand(String cmd)
将此 RowSet 对象的 command 属性设置为给定的 String 对象，并清除为前一个命令设置的参数（如果有）。

void

BaseRowSet.setDataSourceName(String name)
将此 RowSet 对象的 DataSource 名称属性设置为给定的逻辑名，并将此 RowSet 对象的 Url 属性设置为 null。

void

BaseRowSet.setDate(String parameterName, Date x)
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。

void

BaseRowSet.setDate(String parameterName, Date x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。

void

BaseRowSet.setDouble(String parameterName, double x)
将指定参数设置为给定的 Java double 值。

void

BaseRowSet.setFloat(String parameterName, float x)
将指定参数设置为给定的 Java float 值。

void

BaseRowSet.setInt(String parameterName, int x)
将指定参数设置为给定的 Java int 值。

void

BaseRowSet.setLong(String parameterName, long x)
将指定参数设置为给定的 Java long 值。

void

Joinable.setMatchColumn(String columnName)
将指定的列设置为此 RowSet 对象的匹配列。

void

Joinable.setMatchColumn(String[] columnNames)
将指定的列设置为此 RowSet 对象的匹配列。

void

BaseRowSet.setNCharacterStream(String parameterName, Reader value)
将指定参数设置为 Reader 对象。

void

BaseRowSet.setNCharacterStream(String parameterName, Reader value, long length)
将指定参数设置为 Reader 对象。

void

BaseRowSet.setNClob(String parameterName, NClob value)
将指定参数设置为 java.sql.NClob 对象。

void

BaseRowSet.setNClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

BaseRowSet.setNClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

BaseRowSet.setNString(int parameterIndex, String value)
将指定参数设置为给定的 String 对象。

void

BaseRowSet.setNString(String parameterName, String value)
将指定参数设置为给定的 String 对象。

void

BaseRowSet.setNull(int parameterIndex, int sqlType, String typeName)
将指定参数设置为 SQL NULL。

void

BaseRowSet.setNull(String parameterName, int sqlType)
将指定参数设置为 SQL NULL。

void

BaseRowSet.setNull(String parameterName, int sqlType, String typeName)
将指定参数设置为 SQL NULL。

void

BaseRowSet.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

BaseRowSet.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

BaseRowSet.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

void

BaseRowSet.setPassword(String pass)
将用于创建此 RowSet 对象的数据库连接的密码设置为给定的 String 对象。

void

BaseRowSet.setRowId(String parameterName, RowId x)
将指定参数设置为给定的 java.sql.RowId 对象。

void

RowSetMetaDataImpl.setSchemaName(int columnIndex, String schemaName)
将指定列的表的模式名称（如果有）设置为 schemaName。

void

BaseRowSet.setShort(String parameterName, short x)
将指定参数设置为给定的 Java short 值。

void

BaseRowSet.setSQLXML(String parameterName, SQLXML xmlObject)
将指定参数设置为给定的 java.sql.SQLXML 对象。

void

BaseRowSet.setString(int parameterIndex, String x)
将指定参数设置为给定的 String 值。

void

BaseRowSet.setString(String parameterName, String x)
将指定参数设置为给定的 Java String 值。

void

CachedRowSet.setSyncProvider(String provider)
将此 CachedRowSet 对象的 SyncProvider 对象设置为指定的提供者。

void

RowSetMetaDataImpl.setTableName(int columnIndex, String tableName)
将派生指定列的表名称设置为给定的表名称。

void

CachedRowSet.setTableName(String tabName)
将派生此 CachedRowSet 对象的表的标识符设置为给定的表名。

void

BaseRowSet.setTime(String parameterName, Time x)
将指定参数设置为给定的 java.sql.Time 值。

void

BaseRowSet.setTime(String parameterName, Time x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。

void

BaseRowSet.setTimestamp(String parameterName, Timestamp x)
将指定参数设置为给定的 java.sql.Timestamp 值。

void

BaseRowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

void

BaseRowSet.setUrl(String url)
将此 RowSet 对象的 Url 属性设置为给定的 String 对象，并将 dataSource 名称属性设置为 null。

void

BaseRowSet.setUsername(String name)
将此 RowSet 对象的 username 属性设置为给定的用户名。

Collection<?>

CachedRowSet.toCollection(String column)
将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。

void

Joinable.unsetMatchColumn(String columnName)
取消将指定的列设置为此 RowSet 对象的匹配列。

void

Joinable.unsetMatchColumn(String[] columnName)
取消将指定的列设置为此 RowSet 对象的匹配列。

类型变量类型为 String 的 javax.sql.rowset 中的方法参数

void

BaseRowSet.setTypeMap(Map<String,Class<?>> map)
将给定的 java.util.Map 对象安装为与此 RowSet 对象的 Connection 对象关联的类型映射表。

参数类型为 String 的 javax.sql.rowset 中的构造方法

RowSetWarning(String reason)
用给定的 reason 值构造 RowSetWarning 对象；SQLState 默认为 null，vendorCode 默认为 0。

RowSetWarning(String reason, String SQLState)
构造一个 RowSetWarning 对象，并使用给定的 reason 和 SQLState 值进行初始化。

RowSetWarning(String reason, String SQLState, int vendorCode)
构造一个完全指定的 RowSetWarning 对象，并使用给定的 reason、SQLState 和 vendorCode 值进行初始化。

javax.sql.rowset.serial 中 String 的使用

返回 String 的 javax.sql.rowset.serial 中的方法

String

SerialArray.getBaseTypeName()
获取此 SerialArray 对象元素特定于 DBMS 的类型名称。

String

SerialRef.getBaseTypeName()
返回描述 Ref 的基本类型名称的字符串。

String

SerialStruct.getSQLTypeName()
获取此 SerialStruct 对象的 SQL 类型名称。

String

SerialClob.getSubString(long pos, int length)
返回包含在此 SerialClob 对象中的子字符串的副本，从给定位置开始，后跟指定字符数。

String

SQLInputImpl.readNString()
读取流中下一个属性并以 Java 编程语言中 String 的形式返回。

String

SQLInputImpl.readString()
以 Java 编程语言中 String 的形式获取此 SQLInputImpl 对象中的下一个属性。

参数类型为 String 的 javax.sql.rowset.serial 中的方法

long

SerialClob.position(String searchStr, long start)
返回此 SerialClob 对象中给定 String 对象开始的位置，搜索从指定位置开始。

int

SerialClob.setString(long pos, String str)
在位置 pos 处将给定 Java String 写入此 SerialClob 对象表示的 CLOB 值中。

int

SerialClob.setString(long pos, String str, int offset, int length)
将 str 的 len 个字符写入此 Clob 表示的 CLOB 值中，从字符 offset 开始。

void

SQLOutputImpl.writeNString(String x)
将下一个属性以 Java 编程语言中 String 的形式写入流中。

void

SQLOutputImpl.writeString(String x)
将 Java 编程语言中的 String 写入此 SQLOutputImpl 对象。

类型变量类型为 String 的 javax.sql.rowset.serial 中的方法参数

Object

SerialArray.getArray(long index, int count, Map<String,Class<?>> map)
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。

Object

SerialArray.getArray(Map<String,Class<?>> map)
返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。

Object[]

SerialStruct.getAttributes(Map<String,Class<?>> map)
获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。

Object

SerialRef.getObject(Map<String,Class<?>> map)
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。

ResultSet

SerialArray.getResultSet(long index, int count, Map<String,Class<?>> map)
获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。

ResultSet

SerialArray.getResultSet(Map<String,Class<?>> map)
获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。

参数类型为 String 的 javax.sql.rowset.serial 中的构造方法

SerialException(String msg)
创建带有指定消息的新 SerialException。

类型变量类型为 String 的 javax.sql.rowset.serial 中的构造方法参数

SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。

SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。

SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。

SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。

SQLOutputImpl(Vector<?> attributes, Map<String,?> map)
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。

javax.sql.rowset.spi 中 String 的使用

声明为 String 的 javax.sql.rowset.spi 中的字段

static String

SyncFactory.ROWSET_SYNC_PROVIDER
用于同步提供者实现名称的标准属性 id。

static String

SyncFactory.ROWSET_SYNC_PROVIDER_VERSION
用于同步提供者实现版本标记的标准属性 id。

static String

SyncFactory.ROWSET_SYNC_VENDOR
用于同步提供者实现供应商名称的标准属性 id。

返回 String 的 javax.sql.rowset.spi 中的方法

abstract  String

SyncProvider.getProviderID()
返回此 SyncProvider 对象的唯一标识符。

abstract  String

SyncProvider.getVendor()
返回此 SyncProvider 实例的供应商名称

abstract  String

SyncProvider.getVersion()
返回此 SyncProvider 实例的发行版本。

参数类型为 String 的 javax.sql.rowset.spi 中的方法

Object

SyncResolver.getConflictValue(String columnName)
获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。

static SyncProvider

SyncFactory.getInstance(String providerID)
返回 providerID 标识的 SyncProvider 实例。

static void

SyncFactory.registerProvider(String providerID)
将给定的同步提供者添加到工厂注册器。

void

SyncResolver.setResolvedValue(String columnName, Object obj)
将 obj 设置为将同步的 RowSet 对象当前行中列 columnName 的值。

static void

SyncFactory.unregisterProvider(String providerID)
从工厂 SPI 注册器移除指派的当前已注册同步提供者。

参数类型为 String 的 javax.sql.rowset.spi 中的构造方法

SyncFactoryException(String msg)
构造带指定详细消息的 SyncFactoryException。

SyncProviderException(String msg)
构造带指定详细消息的 SyncProviderException 对象。

javax.swing 中 String 的使用

声明为 String 的 javax.swing 中的字段

static String

Action.ACCELERATOR_KEY
用来存储将用作动作加速器的 KeyStroke 的键。

static String

JFileChooser.ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY
标识是否使用 AcceptAllFileFilter。

static String

JFileChooser.ACCESSORY_CHANGED_PROPERTY
声明正在使用不同的 accessory 组件（例如预览文件）。

static String

Action.ACTION_COMMAND_KEY
用来确定 ActionEvent 的命令 String 的键，ActionEvent 是在 Action 因驻留在与 JComponent 关联的 Keymap 中而被通知时所创建的。

protected  String

JComboBox.actionCommand
此受保护字段是特定于实现的。

protected  String

DefaultButtonModel.actionCommand
按钮所触发的动作命令字符串。

static String

JTree.ANCHOR_SELECTION_PATH_PROPERTY
定位选择路径的绑定属性名称。

static String

JFileChooser.APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY
标识用于确认（yes、ok）按钮的助记符的更改。

static String

JFileChooser.APPROVE_BUTTON_TEXT_CHANGED_PROPERTY
标识确认（yes、ok）按钮上的文本更改。

static String

JFileChooser.APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY
标识用于确认（yes、ok）按钮的工具提示文本的更改。

static String

JFileChooser.APPROVE_SELECTION
指示确认当前的选择（与按下 yes 或 ok 相同）。

static String

SpringLayout.BASELINE
指定组件的基线。

static String

AbstractButton.BORDER_PAINTED_CHANGED_PROPERTY
标识是否绘制边框的更改。

static String

JCheckBox.BORDER_PAINTED_FLAT_CHANGED_PROPERTY
标识 flat 属性的更改。

static String

JSplitPane.BOTTOM
用于添加一个 Component 到另一个 Component 的下面。

static String

JFileChooser.CANCEL_SELECTION
指示取消当前的选择。

static String

JTree.CELL_EDITOR_PROPERTY
cellEditor 的绑定属性名称。

static String

JTree.CELL_RENDERER_PROPERTY
cellRenderer 的绑定属性名称。

static String

JFileChooser.CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY
标识预定义文件过滤器列表的更改，用户可从该列表中进行选择。

static String

JColorChooser.CHOOSER_PANELS_PROPERTY
chooserPanel 数组属性名。

static String

ScrollPaneConstants.COLUMN_HEADER
标识视口顶部左上角和右上角之间的区域。

static String

AbstractButton.CONTENT_AREA_FILLED_CHANGED_PROPERTY
标识对按钮绘制的内容区域的更改。

static String

JInternalFrame.CONTENT_PANE_PROPERTY
绑定属性名。

static String

JSplitPane.CONTINUOUS_LAYOUT_PROPERTY
绑定 continuousLayout 属性名称。

static String

JFileChooser.CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY
指示显示控制按钮。

static String

Action.DEFAULT
当前未使用。

static String

JFileChooser.DIALOG_TITLE_CHANGED_PROPERTY
标识对话框标题的更改。

static String

JFileChooser.DIALOG_TYPE_CHANGED_PROPERTY
标识显示文件类型的更改（仅显示文件、仅显示目录或显示文件和目录）。

static String

JFileChooser.DIRECTORY_CHANGED_PROPERTY
标识用户的目录更改。

static String

AbstractButton.DISABLED_ICON_CHANGED_PROPERTY
标识禁用按钮时使用的图标的更改。

static String

AbstractButton.DISABLED_SELECTED_ICON_CHANGED_PROPERTY
标识禁用并选定按钮时使用的图标的更改。

static String

Action.DISPLAYED_MNEMONIC_INDEX_KEY
用来存储对应于文本（由 NAME 属性标识）索引的 Integer 值的键，助记符的装饰应在该文本中呈现。

static String

JSplitPane.DIVIDER
用于添加一个表示分隔条的 Component。

static String

JSplitPane.DIVIDER_LOCATION_PROPERTY
绑定 dividerLocation 属性。

static String

JSplitPane.DIVIDER_SIZE_PROPERTY
绑定 border 属性名称。

static String

SpringLayout.EAST
指定组件的边界矩形的右边。

static String

JTree.EDITABLE_PROPERTY
editable 的绑定属性名称。

static String

JTree.EXPANDS_SELECTED_PATHS_PROPERTY
展开选择路径属性的绑定属性名称

static String

JFileChooser.FILE_FILTER_CHANGED_PROPERTY
用户更改要显示的文件种类。

static String

JFileChooser.FILE_HIDING_CHANGED_PROPERTY
标识在显示隐藏文件属性中的更改。

static String

JFileChooser.FILE_SELECTION_MODE_CHANGED_PROPERTY
标识在选择种类（选择单个、多个等等）方面的更改。

static String

JFileChooser.FILE_SYSTEM_VIEW_CHANGED_PROPERTY
声明使用其他对象在系统上查找可用的驱动器。

static String

JFileChooser.FILE_VIEW_CHANGED_PROPERTY
声明使用其他对象检索文件信息。

static String

FocusManager.FOCUS_MANAGER_CLASS_PROPERTY
该字段已被废弃，不鼓励使用它，因为它的规范与 1.4 focus API 不兼容。

static String

AbstractButton.FOCUS_PAINTED_CHANGED_PROPERTY
标识是否在边框拥有焦点时高亮显示。

static String

JInternalFrame.FRAME_ICON_PROPERTY
绑定属性名。

static String

JInternalFrame.GLASS_PANE_PROPERTY
绑定属性名。

static String

SpringLayout.HEIGHT
指定组件边界矩形的高度。

static String

JEditorPane.HONOR_DISPLAY_PROPERTIES
用于客户机属性的关键字，指示如果在样式化文本中未指定字体或前景色，那么是否使用该组件的默认字体和前景色。

static String

AbstractButton.HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY
标识按钮的水平对齐方式的更改。

static String

SpringLayout.HORIZONTAL_CENTER
指定组件边界矩形的水平中央位置。

static String

ScrollPaneConstants.HORIZONTAL_SCROLLBAR
标识水平滚动条。

static String

ScrollPaneConstants.HORIZONTAL_SCROLLBAR_POLICY
标识水平滚动条策略属性。

static String

AbstractButton.HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY
标识按钮的水平文本位置的更改。

static String

AbstractButton.ICON_CHANGED_PROPERTY
标识对表示该按钮的图标的更改。

static String

JOptionPane.ICON_PROPERTY
icon 的绑定属性名。

static String

JOptionPane.INITIAL_SELECTION_VALUE_PROPERTY
initialSelectionValue 的绑定属性名。

static String

JOptionPane.INITIAL_VALUE_PROPERTY
initialValue 的绑定属性名。

static String

JOptionPane.INPUT_VALUE_PROPERTY
inputValue 的绑定属性名。

static String

JTree.INVOKES_STOP_CELL_EDITING_PROPERTY
messagesStopCellEditing 的绑定属性名称。

static String

JInternalFrame.IS_CLOSED_PROPERTY
约束属性名，指示该内部窗体已关闭。

static String

JInternalFrame.IS_ICON_PROPERTY
约束属性名，指示该内部窗体已图标化。

static String

JInternalFrame.IS_MAXIMUM_PROPERTY
约束属性名，指示该内部窗体已最大化。

static String

JInternalFrame.IS_SELECTED_PROPERTY
约束属性名，指示此窗体具有选定状态。

static String

Action.LARGE_ICON_KEY
用来存储 Icon 的键。

static String

JTree.LARGE_MODEL_PROPERTY
largeModel 的绑定属性名称。

static String

JSplitPane.LAST_DIVIDER_LOCATION_PROPERTY
绑定 lastLocation 属性。

static String

JLayeredPane.LAYER_PROPERTY
绑定属性

static String

JInternalFrame.LAYERED_PANE_PROPERTY
绑定属性名。

static String

JTree.LEAD_SELECTION_PATH_PROPERTY
leadSelectionPath 的绑定属性名称。

static String

JSplitPane.LEFT
用于添加一个 Component 到另一个 Component 的左边。

static String

Action.LONG_DESCRIPTION
用来存储动作的较长 String 描述的键，用于上下文相关的帮助文件。

static String

ScrollPaneConstants.LOWER_LEADING_CORNER
标识视口的底端开始边角。

static String

ScrollPaneConstants.LOWER_LEFT_CORNER
标识视口的左下角。

static String

ScrollPaneConstants.LOWER_RIGHT_CORNER
标识视口的右下角。

static String

ScrollPaneConstants.LOWER_TRAILING_CORNER
标识视口的底端结束边角。

static String

AbstractButton.MARGIN_CHANGED_PROPERTY
标识按钮的边界空白的更改。

static String

JInternalFrame.MENU_BAR_PROPERTY
绑定属性名。

static String

JOptionPane.MESSAGE_PROPERTY
message 的绑定属性名。

static String

JOptionPane.MESSAGE_TYPE_PROPERTY
type 的绑定属性名。

static String

AbstractButton.MNEMONIC_CHANGED_PROPERTY
标识按钮的助记符中的更改。

static String

Action.MNEMONIC_KEY
用来存储对应于一个 KeyEvent 键代码的 Integer 值的键。

static String

AbstractButton.MODEL_CHANGED_PROPERTY
标识按钮模型中的更改。

static String

JFileChooser.MULTI_SELECTION_ENABLED_CHANGED_PROPERTY
允许选择多个文件。

static String

Action.NAME
用来存储动作的 String 名称的键，用于菜单或按钮。

static String

SpringLayout.NORTH
指定组件的边界矩形的顶边。

static String

JTextField.notifyAction
发送通知（已接收字段内容）的动作名称。

static String

JSplitPane.ONE_TOUCH_EXPANDABLE_PROPERTY
绑定 oneTouchExpandable 属性。

static String

JOptionPane.OPTION_TYPE_PROPERTY
optionType 的绑定属性名。

static String

JOptionPane.OPTIONS_PROPERTY
option 的绑定属性名。

static String

JSplitPane.ORIENTATION_PROPERTY
绑定 orientation（水平或者垂直）属性名称。

static String

AbstractButton.PRESSED_ICON_CHANGED_PROPERTY
标识对按下按钮时使用的图标的更改。

static String

JColorChooser.PREVIEW_PANEL_PROPERTY
预览面板属性名。

protected  String

JProgressBar.progressString
可以在进度条上显示的可选字符串。

static String

JSplitPane.RESIZE_WEIGHT_PROPERTY
绑定 weight 属性。

static String

JSplitPane.RIGHT
用于添加一个 Component 到另一个 Component 的右边。

static String

AbstractButton.ROLLOVER_ENABLED_CHANGED_PROPERTY
标识从启用翻转到禁用翻转或者从禁用翻转到启用翻转的更改。

static String

AbstractButton.ROLLOVER_ICON_CHANGED_PROPERTY
标识对光标移动到按钮上时使用的图标的更改。

static String

AbstractButton.ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY
标识对光标移动到按钮上并选定该按钮时使用的图标的更改。

static String

JInternalFrame.ROOT_PANE_PROPERTY
绑定属性名。

static String

JTree.ROOT_VISIBLE_PROPERTY
rootVisible 的绑定属性名称。

static String

ScrollPaneConstants.ROW_HEADER
标识沿视口左边左上角和左下角之间的区域。

static String

JTree.ROW_HEIGHT_PROPERTY
rowHeight 的绑定属性名称。

static String

JTree.SCROLLS_ON_EXPAND_PROPERTY
scrollsOnExpand 的绑定属性名称。

static String

JFileChooser.SELECTED_FILE_CHANGED_PROPERTY
标识用户单个文件选择的更改。

static String

JFileChooser.SELECTED_FILES_CHANGED_PROPERTY
标识用户多个文件选择的更改。

static String

AbstractButton.SELECTED_ICON_CHANGED_PROPERTY
标识对选定按钮时使用的图标的更改。

static String

Action.SELECTED_KEY
用来存储对应于选定状态的 Boolean 值的键。

static String

JColorChooser.SELECTION_MODEL_PROPERTY
选择模型属性名。

static String

JTree.SELECTION_MODEL_PROPERTY
selectionModel 的绑定属性名称。

static String

JOptionPane.SELECTION_VALUES_PROPERTY
selectionValues 的绑定属性名。

static String

Action.SHORT_DESCRIPTION
用来存储动作的简短 String 描述的键，用于工具提示文本。

static String

JTree.SHOWS_ROOT_HANDLES_PROPERTY
showsRootHandles 的绑定属性名称。

static String

Action.SMALL_ICON
用来存储小型 Icon（比如 ImageIcon）的键。

static String

SpringLayout.SOUTH
指定组件的边界矩形的底边。

static String

AbstractButton.TEXT_CHANGED_PROPERTY
标识按钮的文本中的更改。

protected  String

JInternalFrame.title
此内部窗体标题栏中所显示的标题。

static String

JInternalFrame.TITLE_PROPERTY
绑定属性名。

static String

JTree.TOGGLE_CLICK_COUNT_PROPERTY
toggleClickCount 的绑定属性名称。

static String

JComponent.TOOL_TIP_TEXT_KEY
光标位于组件上方时显示的注释，也称为“值提示”、“相交提示 (flyover help)”或“相交标签 (flyover label)”。

static String

JSplitPane.TOP
用于添加一个 Component 到另一个 Component 的上面。

static String

JTree.TREE_MODEL_PROPERTY
treeModel 的绑定属性名称。

static String

ScrollPaneConstants.UPPER_LEADING_CORNER
标识视口的顶端开始边角。

static String

ScrollPaneConstants.UPPER_LEFT_CORNER
标识视口的左上角。

static String

ScrollPaneConstants.UPPER_RIGHT_CORNER
标识视口的右上角。

static String

ScrollPaneConstants.UPPER_TRAILING_CORNER
标识视口的顶端结束边角。

static String

JOptionPane.VALUE_PROPERTY
value 的绑定属性名。

static String

AbstractButton.VERTICAL_ALIGNMENT_CHANGED_PROPERTY
标识按钮的垂直对齐方式的更改。

static String

SpringLayout.VERTICAL_CENTER
指定组件的边界矩形的垂直中央位置。

static String

ScrollPaneConstants.VERTICAL_SCROLLBAR
标识垂直滚动条。

static String

ScrollPaneConstants.VERTICAL_SCROLLBAR_POLICY
标识垂直滚动条策略属性。

static String

AbstractButton.VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
标识按钮的垂直文本位置的更改。

static String

ScrollPaneConstants.VIEWPORT
标识一个“视口”或显示区域，在这个范围内能看到滚动的内容。

static String

JTree.VISIBLE_ROW_COUNT_PROPERTY
visibleRowCount 的绑定属性名称。

static String

JEditorPane.W3C_LENGTH_UNITS
用于客户机属性的关键字，指示是否为 html 呈现使用 w3c 兼容的长度单位。

static String

JOptionPane.WANTS_INPUT_PROPERTY
wantsInput 的绑定属性名。

static String

SpringLayout.WEST
指定组件的边界矩形的左边。

static String

SpringLayout.WIDTH
指定组件边界矩形的宽度。

返回 String 的 javax.swing 中的方法

String

JTree.convertValueToText(Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
通过渲染器调用以将指定值转换为文本。

String

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionDescription(int i)
返回此特定链接操作的 String 描述。

String

JSpinner.AccessibleJSpinner.getAccessibleActionDescription(int i)
返回此对象指定操作的描述。

String

JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleActionDescription(int i)
返回该树节点的指定操作的描述。

String

JComboBox.AccessibleJComboBox.getAccessibleActionDescription(int i)
返回该对象的指定操作的描述。

String

AbstractButton.AccessibleAbstractButton.getAccessibleActionDescription(int i)
返回对该对象的指定操作的描述。

String

JEditorPane.AccessibleJEditorPane.getAccessibleDescription()
获得此对象的 accessibleDescription 属性。

String

ProgressMonitor.AccessibleProgressMonitor.getAccessibleDescription()
获取对象的 accessibleDescription 属性。

String

JToolTip.AccessibleJToolTip.getAccessibleDescription()
获取此对象的可访问的描述。

String

JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleDescription()
获取此对象的可访问的描述。

String

JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleDescription()
获取此对象的可访问的描述。

String

JList.AccessibleJList.AccessibleJListChild.getAccessibleDescription()

String

JComponent.AccessibleJComponent.getAccessibleDescription()
获取此对象的可访问描述。

String

ImageIcon.AccessibleImageIcon.getAccessibleIconDescription()
获得此图标的描述。

String

ProgressMonitor.AccessibleProgressMonitor.getAccessibleName()
获取此对象的 accessibleName 属性。

String

JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleName()
获取此对象的可访问名称。

String

JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleName()
获取此对象的可访问的名称。

String

JTabbedPane.AccessibleJTabbedPane.getAccessibleName()
返回此对象的可访问名称；如果没有可访问名称，则返回 null。

String

JList.AccessibleJList.AccessibleJListChild.getAccessibleName()

String

JDialog.AccessibleJDialog.getAccessibleName()
获取此对象的可访问名称。

String

AbstractButton.AccessibleAbstractButton.getAccessibleName()
返回此对象的可访问名称。

String

JInternalFrame.AccessibleJInternalFrame.getAccessibleName()
获取此对象的可访问名称。

String

JLabel.AccessibleJLabel.getAccessibleName()
获取此对象的可访问名称。

String

JComponent.AccessibleJComponent.getAccessibleName()
获取此对象的可访问名称。

String

JFrame.AccessibleJFrame.getAccessibleName()
获得此对象的可访问名称。

String

JComboBox.getActionCommand()
返回发送到动作侦听器的事件中包括的动作命令。

String

DefaultButtonModel.getActionCommand()
返回该按钮的动作命令字符串。

String

ButtonModel.getActionCommand()
返回该按钮的动作命令字符串。

String

Timer.getActionCommand()
返回将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。

String

AbstractButton.getActionCommand()
返回此按钮的动作命令。

String

JPasswordField.AccessibleJPasswordField.getAfterIndex(int part, int index)
返回给定 index 之后的 String。

String

JSpinner.AccessibleJSpinner.getAfterIndex(int part, int index)
返回给定索引后的 String。

String

ProgressMonitor.AccessibleProgressMonitor.getAfterIndex(int part, int index)
返回给定索引后面的 String。

String

AbstractButton.AccessibleAbstractButton.getAfterIndex(int part, int index)
返回给定索引之后的 String。

String

JLabel.AccessibleJLabel.getAfterIndex(int part, int index)
返回给定索引后的 String。

String

JFileChooser.getApproveButtonText()
返回 ApproveButton 中的 FileChooserUI 内使用的文本。

String

JFileChooser.getApproveButtonToolTipText()
返回 ApproveButton 中使用的工具提示文本。

String

JPasswordField.AccessibleJPasswordField.getAtIndex(int part, int index)
返回给定 index 处的 String。

String

JSpinner.AccessibleJSpinner.getAtIndex(int part, int index)
返回给定索引处的 String。

String

ProgressMonitor.AccessibleProgressMonitor.getAtIndex(int part, int index)
返回给定索引处的 String。

String

AbstractButton.AccessibleAbstractButton.getAtIndex(int part, int index)
返回给定索引处的 String。

String

JLabel.AccessibleJLabel.getAtIndex(int part, int index)
返回给定索引处的 String。

String

JPasswordField.AccessibleJPasswordField.getBeforeIndex(int part, int index)
返回给定 index 之前的 String。

String

JSpinner.AccessibleJSpinner.getBeforeIndex(int part, int index)
返回给定索引前的 String。

String

ProgressMonitor.AccessibleProgressMonitor.getBeforeIndex(int part, int index)
返回给定索引前面的 String。

String

AbstractButton.AccessibleAbstractButton.getBeforeIndex(int part, int index)
返回给定索引前面的 String。

String

JLabel.AccessibleJLabel.getBeforeIndex(int part, int index)
返回给定索引前的 String。

protected  String

JComponent.AccessibleJComponent.getBorderTitle(Border b)
在边界层次结构（如果存在）中递归地搜索带有非 null 标题的 TitledBorder。

String

UIManager.LookAndFeelInfo.getClassName()
返回实现此外观的类名称。

String

JTable.getColumnName(int column)
返回出现在视图中 column 列位置处的列名称。

String

JEditorPane.getContentType()
获得设置此编辑器当前要处理的内容类型。

static String

UIManager.getCrossPlatformLookAndFeelClassName()
返回实现默认的跨平台外观 -- Java Look and Feel (JLF) -- 的 LookAndFeel 类的名称。

String

ImageIcon.getDescription()
获得图像的描述。

abstract  String

LookAndFeel.getDescription()
返回对此外观实现的单行描述，例如，"The CDE/Motif Look and Feel"。

String

JFileChooser.getDescription(File f)
返回文件描述。

String

JFileChooser.getDialogTitle()
获得 JFileChooser 的标题栏中所显示的字符串。

static String

JEditorPane.getEditorKitClassNameForContentType(String type)
返回当前向类型 type 所注册的 EditorKit 类名。

abstract  String

LookAndFeel.getID()
返回标识此外观的字符串。

String

JPopupMenu.getLabel()
返回弹出菜单的标签。

String

AbstractButton.getLabel()
已过时。 - 由 getText 取代

String

JEditorPane.JEditorPaneAccessibleHypertextSupport.getLinkText(int linkIndex)
返回文档中与此超链接关联的连续文本。

abstract  String

LookAndFeel.getName()
返回标识此外观的短字符串，例如 "CDE/Motif"。

String

UIManager.LookAndFeelInfo.getName()
以适合菜单或其他展示的形式返回外观的名称

String

JFileChooser.getName(File f)
返回文件名。

String

ProgressMonitor.getNote()
指定随进度消息一起显示的其他注释。

String

JSpinner.AccessibleJSpinner.getSelectedText()
返回选中的部分文本。

String

ProgressMonitor.AccessibleProgressMonitor.getSelectedText()
返回选择的一部分文本。

String

AbstractButton.AccessibleAbstractButton.getSelectedText()
返回选定文本的一部分。

String

JLabel.AccessibleJLabel.getSelectedText()
返回选定的部分文本。

String

JProgressBar.getString()
返回当前进度的 String 表示形式。

String

UIDefaults.getString(Object key)
如果 key 值为一个 String，则返回该 String，否则返回 null。

static String

UIManager.getString(Object key)
从默认值中返回一个字符串。

String

UIDefaults.getString(Object key, Locale l)
如果给定 Locale 的 key 值为一个 String，则返回该 String，否则返回 null。

static String

UIManager.getString(Object key, Locale l)
从适合给定语言环境的默认值中返回一个字符串。

String

RowFilter.Entry.getStringValue(int index)
返回指定索引处的字符串值。

String

DefaultRowSorter.ModelWrapper.getStringValueAt(int row, int column)
以 String 的形式返回指定索引处的值。

static String

UIManager.getSystemLookAndFeelClassName()
如果有实现本机系统外观的 LookAndFeel 类的名称，则返回该名称；否则返回默认的跨平台 LookAndFeel 类的名称。

String

JEditorPane.getText()
根据此编辑器的内容类型返回此 TextComponent 中所包含的文本。

String

JPasswordField.getText()
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。

String

AbstractButton.getText()
返回按钮的文本。

String

JLabel.getText()
返回该标签所显示的文本字符串。

String

JPasswordField.getText(int offs, int len)
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。

String

JPasswordField.AccessibleJPasswordField.getTextRange(int startIndex, int endIndex)
返回两个索引之间的文本。

String

JSpinner.AccessibleJSpinner.getTextRange(int startIndex, int endIndex)
返回两个索引之间的文本字符串。

String

JToolTip.getTipText()
返回显示工具提示时所显示的文本。

String

JInternalFrame.getTitle()
返回 JInternalFrame 的标题。

String

JTabbedPane.getTitleAt(int index)
返回 index 位置的选项卡标题。

String

AbstractButton.AccessibleAbstractButton.getTitledBorderText()
返回加标题的边界文本

String

JLabel.AccessibleJLabel.getTitledBorderText()
返回有标题边框的文本

String

JComponent.AccessibleJComponent.getTitledBorderText()
返回有标题边界的文本

String

AbstractButton.AccessibleAbstractButton.getToolTipText()
返回工具提示文本

String

JLabel.AccessibleJLabel.getToolTipText()
返回工具提示文本

String

JComponent.getToolTipText()
返回通过 setToolTipText 所设置的工具提示字符串。

String

JComponent.AccessibleJComponent.getToolTipText()
返回工具提示文本

String

JTree.getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，以允许使用渲染器的提示（如果渲染器设置了文本）。

String

JTable.getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，从而允许使用渲染器的提示（如果设置了文本）。

String

JTabbedPane.getToolTipText(MouseEvent event)
返回由鼠标事件位置确定的组件的工具提示文本。

String

JList.getToolTipText(MouseEvent event)
返回用于给定事件的工具提示文本。

String

JComponent.getToolTipText(MouseEvent event)
返回用作 event 工具提示的字符串。

String

JTabbedPane.getToolTipTextAt(int index)
返回 index 位置的选项卡工具提示文本。

String

JFileChooser.getTypeDescription(File f)
返回文件类型。

String

JColorChooser.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JDesktopPane.getUIClassID()
返回呈现此组件的 L&F 类名。

String

JEditorPane.getUIClassID()
获得该 UI 的类 ID。

String

JFileChooser.getUIClassID()
返回一个指示 L&F 类名的字符串，该类负责呈现此组件。

String

JFormattedTextField.getUIClassID()
获得 UI 的类 ID。

String

JOptionPane.getUIClassID()
返回实现此组件 L&F 的 UI 类的名称。

String

JPasswordField.getUIClassID()
返回呈现此组件的 L&F 类名。

String

JSpinner.getUIClassID()
返回用于构造呈现此组件外观 (L&F) 类的名称的后缀。

String

JTextPane.getUIClassID()
返回 UI 的类 ID。

String

JRadioButtonMenuItem.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JSlider.getUIClassID()
返回呈现此组件的 L&F 的类名。

String

JToolTip.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JTree.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JTable.getUIClassID()
返回用于构造呈现此组件时所用 L&F 类名称的后缀。

String

JProgressBar.getUIClassID()
返回呈现此组件的外观类的名称。

String

JCheckBox.getUIClassID()
返回指定呈现此组件的 L&F 类名的字符串。

String

JTabbedPane.getUIClassID()
返回实现此组件的 L&F 的 UI 类的名称。

String

JRadioButton.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JTextArea.getUIClassID()
返回 UI 的类 ID。

String

JTextField.getUIClassID()
获取 UI 的类 ID。

String

JViewport.getUIClassID()
返回指定呈现此组件的 L&F 类名称的字符串。

String

JScrollPane.getUIClassID()
返回用于构造呈现此组件时所用 L&F 类的名称的后缀。

String

JList.getUIClassID()
返回 "ListUI"，它是用于查找定义此组件外观的 javax.swing.plaf.ListUI 类名称的 UIDefaults 键。

String

JScrollBar.getUIClassID()
返回此组件的 LookAndFeel 类的名称。

String

JComboBox.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JSeparator.getUIClassID()
返回呈现此组件的 L&F 的类名。

String

JPopupMenu.getUIClassID()
返回用于呈现此组件的 L&F 类名。

String

JPopupMenu.Separator.getUIClassID()
返回呈现此组件的 L&F 类名。

String

JMenuBar.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JToggleButton.getUIClassID()
返回指定了 l&f 类名称的字符串，其中 l&f 类呈现此组件。

String

JSplitPane.getUIClassID()
返回呈现此组件的 L&F 类名。

String

JToolBar.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JToolBar.Separator.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JButton.getUIClassID()
返回指定呈现此组件的 L&F 类名的字符串。

String

JCheckBoxMenuItem.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JMenu.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JMenuItem.getUIClassID()
返回用于构造呈现此组件时使用的 L&F 类名称的后缀。

String

JInternalFrame.getUIClassID()
返回呈现此组件的外观类名。

String

JInternalFrame.JDesktopIcon.getUIClassID()
返回呈现此组件的外观类名。

String

JPanel.getUIClassID()
返回指定呈现此组件的 L&F 类名的字符串。

String

JRootPane.getUIClassID()
返回一个指定呈现此组件的 L&F 类名称的字符串。

String

JLabel.getUIClassID()
返回一个指定 L&F 类名称的字符串，该类呈现此组件。

String

JComponent.getUIClassID()
返回用于查找 wing.plaf.ComponentUI 类（定义了此组件的外观）名的 UIDefaults 键。

String

JInternalFrame.getWarningString()
获取此内部窗体中显示的警告字符串。

static String

SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。

static String

SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。

protected  String

JColorChooser.paramString()
返回此 JColorChooser 的字符串表示形式。

protected  String

JDesktopPane.paramString()
返回此 JDesktopPane 的字符串表示形式。

protected  String

JEditorPane.paramString()
返回此 JEditorPane 的字符串表示形式。

protected  String

JFileChooser.paramString()
返回此 JFileChooser 的字符串表示形式。

protected  String

JOptionPane.paramString()
返回此 JOptionPane 的字符串表示形式。

protected  String

JPasswordField.paramString()
返回此 JPasswordField 的字符串表示形式。

protected  String

JTextPane.paramString()
返回此 JTextPane 的字符串表示形式。

protected  String

JApplet.paramString()
返回此 JApplet 的字符串表示形式。

protected  String

JRadioButtonMenuItem.paramString()
返回此 JRadioButtonMenuItem 的字符串表示形式。

protected  String

JSlider.paramString()
返回此 JSlider 的字符串表示形式。

protected  String

JToolTip.paramString()
返回此 JToolTip 的字符串表示形式。

protected  String

JTree.paramString()
返回此 JTree 的字符串表示形式。

protected  String

JTable.paramString()
返回此表的字符串表示形式。

protected  String

JProgressBar.paramString()
返回此 JProgressBar 的字符串表示形式。

protected  String

JCheckBox.paramString()
返回此 JCheckBox 的字符串表示形式。

protected  String

JTabbedPane.paramString()
返回此 JTabbedPane 的字符串表示。

protected  String

JRadioButton.paramString()
返回此 JRadioButton 的字符串表示形式。

protected  String

JWindow.paramString()
返回此 JWindow 的字符串表示形式。

protected  String

JTextArea.paramString()
返回此 JTextArea 的字符串表示形式。

protected  String

JTextField.paramString()
返回此 JTextField 的字符串表示形式。

protected  String

JViewport.paramString()
返回此 JViewport 的字符串表示形式。

protected  String

JScrollPane.paramString()
返回此 JScrollPane 的字符串表示形式。

protected  String

JList.paramString()
返回此 JList 的 String 表示形式。

protected  String

JScrollBar.paramString()
返回此 JScrollBar 的字符串表示形式。

protected  String

JComboBox.paramString()
返回此 JComboBox 的字符串表示形式。

protected  String

JSeparator.paramString()
返回表示此 JSeparator 的一个字符串。

protected  String

JPopupMenu.paramString()
返回此 JPopupMenu 的字符串表示形式。

protected  String

JMenuBar.paramString()
返回此 JMenuBar 的字符串表示形式。

protected  String

JToggleButton.paramString()
返回此 JToggleButton 的字符串表示形式。

protected  String

JSplitPane.paramString()
返回此 JSplitPane 的字符串表示形式。

protected  String

JToolBar.paramString()
返回此 JToolBar 的字符串表示形式。

protected  String

JDialog.paramString()
返回此 JDialog 的字符串表示形式。

protected  String

JButton.paramString()
返回此 JButton 的字符串表示形式。

protected  String

JCheckBoxMenuItem.paramString()
返回此 JCheckBoxMenuItem 的字符串表示形式。

protected  String

JMenu.paramString()
返回此 JMenu 的字符串表示形式。

protected  String

JMenuItem.paramString()
返回此 JMenuItem 的字符串表示形式。

protected  String

AbstractButton.paramString()
返回此 AbstractButton 的字符串表示形式。

protected  String

JInternalFrame.paramString()
返回此 JInternalFrame 的字符串表示形式。

protected  String

JLayeredPane.paramString()
返回此 JLayeredPane 的字符串表示形式。

protected  String

JPanel.paramString()
返回此 JPanel 的字符串表示形式。

protected  String

JRootPane.paramString()
返回此 JRootPane 的字符串表示形式。

protected  String

JLabel.paramString()
返回此 JLabel 的字符串表示形式。

protected  String

JComponent.paramString()
返回此 JComponent 的字符串表示形式。

protected  String

JFrame.paramString()
返回此 JFrame 的字符串表示形式。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message, Object initialSelectionValue)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。

static String

JOptionPane.showInputDialog(Object message)
显示请求用户输入的问题消息对话框。

static String

JOptionPane.showInputDialog(Object message, Object initialSelectionValue)
显示请求用户输入的问题消息对话框，它带有已初始化为 initialSelectionValue 的输入值。

static String

JOptionPane.showInternalInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的内部问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。

String

GroupLayout.toString()
返回此 GroupLayout 的字符串表示形式。

String

DefaultListModel.toString()
返回显示并标识此对象的属性的字符串。

String

JTree.DropLocation.toString()
返回此放置位置的字符串表示形式。

String

JTable.DropLocation.toString()
返回此放置位置的字符串表示形式。

String

SizeRequirements.toString()
返回一个描述最小、首选和最大大小以及对齐方式要求的字符串。

String

TransferHandler.DropLocation.toString()
返回此放置位置的字符串表示形式。

String

DefaultListSelectionModel.toString()
返回显示并标识此对象的属性的字符串。

String

JList.DropLocation.toString()
返回此放置位置的字符串表示形式。

String

DefaultBoundedRangeModel.toString()
返回显示所有 BoundedRangeModel 属性的字符串。

String

ImageIcon.toString()
返回此图像的字符串表示形式。

String

RepaintManager.toString()
返回一个显示并标记此对象属性的字符串。

String

LookAndFeel.toString()
返回显示和标识此对象属性的字符串。

String

UIManager.LookAndFeelInfo.toString()
返回一个显示并标识此对象属性的字符串。

abstract  String

JFormattedTextField.AbstractFormatter.valueToString(Object value)
返回为 value 显示的 string 值。

参数类型为 String 的 javax.swing 中的方法

protected  void

JTextField.actionPropertyChanged(Action action, String propertyName)
更新文本字段的状态以响应关联动作中的属性更改。

protected  void

JComboBox.actionPropertyChanged(Action action, String propertyName)
更新组合框的状态以响应关联动作中的属性更改。

protected  void

JMenuItem.actionPropertyChanged(Action action, String propertyName)
更新按钮的状态以响应相关的操作中的属性更改。

protected  void

AbstractButton.actionPropertyChanged(Action action, String propertyName)
更新按钮的状态以响应相关的操作中的属性更改。

JMenuItem

JPopupMenu.add(String s)
创建具有指定文本的菜单项，并将其添加到此菜单的末尾。

JMenuItem

JMenu.add(String s)
创建具有指定文本的新菜单项，并将其追加到此菜单的末尾。

Component

JTabbedPane.add(String title, Component component)
添加具有指定选项卡标题的 component。

void

GroupLayout.addLayoutComponent(String name, Component component)
已将 Component 添加到父容器的通知。

void

JSpinner.DefaultEditor.addLayoutComponent(String name, Component child)
此 LayoutManager 方法不执行任何操作。

void

OverlayLayout.addLayoutComponent(String name, Component comp)
将指定的组件添加到布局中。

void

SpringLayout.addLayoutComponent(String name, Component c)
无效，因为此布局管理器不使用每组件字符串。

void

ViewportLayout.addLayoutComponent(String name, Component c)
将指定的组件添加到布局中。

void

ScrollPaneLayout.addLayoutComponent(String s, Component c)
将指定的组件添加到布局中。

void

BoxLayout.addLayoutComponent(String name, Component comp)
此类不使用。

void

JRootPane.RootLayout.addLayoutComponent(String name, Component comp)

void

UIDefaults.addResourceBundle(String bundleName)
将一个资源包添加到从中搜索本地化值的资源包的列表中。

Style

JTextPane.addStyle(String nm, Style parent)
将一个新样式添加到逻辑样式层次结构中。

void

JTabbedPane.addTab(String title, Component component)
添加一个由 title 表示，且没有图标的 component。

void

JTabbedPane.addTab(String title, Icon icon, Component component)
添加一个由 title 和/或 icon 表示的 component，其任意一个都可以为 null。

void

JTabbedPane.addTab(String title, Icon icon, Component component, String tip)
添加由 title 和/或 icon 表示的 component 和 tip，其中任意一个都可以为 null。

void

JTextArea.append(String str)
将给定文本追加到文档结尾。

protected  int

AbstractButton.checkHorizontalKey(int key, String exception)
验证 key 参数是否为 horizontalAlignment 和 horizontalTextPosition 属性的合法值。

protected  int

JLabel.checkHorizontalKey(int key, String message)
验证该键是否为 horizontalAlignment 属性的合法值。

protected  int

AbstractButton.checkVerticalKey(int key, String exception)
验证 key 参数是否为垂直属性的合法值。

protected  int

JLabel.checkVerticalKey(int key, String message)
验证该键是否为 verticalAlignment 或 verticalTextPosition 属性的合法值。

static int

SwingUtilities.computeStringWidth(FontMetrics fm, String str)
使用具有指定“规格”（大小）的字体计算字符串的宽度。

JDialog

JOptionPane.createDialog(Component parentComponent, String title)
创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。

static JDialog

JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。

JDialog

JOptionPane.createDialog(String title)
创建并返回一个新的带有指定标题的无父 JDialog。

static EditorKit

JEditorPane.createEditorKitForContentType(String type)
根据默认的编辑器工具包注册表为给定的类型创建处理程序。

JInternalFrame

JOptionPane.createInternalFrame(Component parentComponent, String title)
创建并返回 JInternalFrame 的实例。

static TitledBorder

BorderFactory.createTitledBorder(Border border, String title)
向现有边框添加一个标题，使其具有默认的位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。

static TitledBorder

BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition)
向现有边框添加一个标题，使其具有指定的位置和默认字体和文本颜色（由当前外观确定）。

static TitledBorder

BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。

static TitledBorder

BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
向现有边框添加一个标题，使其具有指定的位置、字体和颜色。

static TitledBorder

BorderFactory.createTitledBorder(String title)
创建一个新标题边框，使其具有指定的标题、默认的边框类型（由当前外观确定）、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。

void

DebugGraphics.drawString(String aString, int x, int y)
重写 Graphics.drawString。

protected  void

JFileChooser.fireActionPerformed(String command)
通知对此事件类型感兴趣的所有侦听器。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
因为性能原因而被重写。

void

JComponent.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
支持报告 boolean 属性的绑定属性更改。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, byte oldValue, byte newValue)
因为性能原因而被重写。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, char oldValue, char newValue)
因为性能原因而被重写。

void

JComponent.firePropertyChange(String propertyName, char oldValue, char newValue)

void

DefaultListCellRenderer.firePropertyChange(String propertyName, double oldValue, double newValue)
因为性能原因而被重写。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, float oldValue, float newValue)
因为性能原因而被重写。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, int oldValue, int newValue)
因为性能原因而被重写。

void

JComponent.firePropertyChange(String propertyName, int oldValue, int newValue)
支持报告整数属性的绑定属性更改。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, long oldValue, long newValue)
因为性能原因而被重写。

void

SwingWorker.firePropertyChange(String propertyName, Object oldValue, Object newValue)
向所有已注册的侦听器报告绑定属性更新。

protected  void

AbstractAction.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告绑定 (bound) 属性的改变。

protected  void

JViewport.firePropertyChange(String propertyName, Object oldValue, Object newValue)
通知侦听器发生的属性更改。

protected  void

DefaultListCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

protected  void

UIDefaults.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告绑定属性更改。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, short oldValue, short newValue)
因为性能原因而被重写。

protected  void

JComponent.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
支持报告约束 (constrained) 属性的更改。

static Container

SwingUtilities.getAncestorNamed(String name, Component comp)
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的 name 第一个对象。

Spring

SpringLayout.Constraints.getConstraint(String edgeName)
返回指定边的值，它可以为一个派生值，甚至可以为 null。

Spring

SpringLayout.getConstraint(String edgeName, Component c)
返回控制该组件指定边及其父级的顶边或左边之间距离的 spring。

Component

ScrollPaneLayout.getCorner(String key)
返回位于指定角的 Component。

Component

JScrollPane.getCorner(String key)
返回位于指定角的组件。

static Object

LookAndFeel.getDesktopPropertyValue(String systemPropertyName, Object fallbackValue)
通过调用 Toolkit.getDefaultToolkit().getDesktopProperty() 返回指定系统桌面属性的值。

static String

JEditorPane.getEditorKitClassNameForContentType(String type)
返回当前向类型 type 所注册的 EditorKit 类名。

EditorKit

JEditorPane.getEditorKitForContentType(String type)
获取用于给定内容类型的编辑器工具包。

static KeyStroke

KeyStroke.getKeyStroke(String s)
分析字符串并返回 KeyStroke。

TreePath

JTree.getNextMatch(String prefix, int startingRow, Position.Bias bias)
将 TreePath 返回到以一个前缀开头的下一个树元素。

int

JList.getNextMatch(String prefix, int startIndex, Position.Bias bias)
返回其 toString 值以给定前缀开头的下一个列表元素。

Style

JTextPane.getStyle(String nm)
获取以前添加的已命名的非 null 样式。

Class<? extends ComponentUI>

UIDefaults.getUIClass(String uiClassID)
返回呈现此组件的 L&F 类。

Class<? extends ComponentUI>

UIDefaults.getUIClass(String uiClassID, ClassLoader uiClassLoader)
get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。

protected  void

UIDefaults.getUIError(String msg)
如果由于某种原因导致 getUI() 失败，则它会在返回 null 之前调用此方法。

Object

AbstractAction.getValue(String key)
获得与指定键关联的 Object。

Object

Action.getValue(String key)
使用关联的键获取此对象的一个属性。

int

JTabbedPane.indexOfTab(String title)
返回具有给定 title 的第一个选项卡索引，如果没有具有此标题的选项卡，则返回 -1。

protected  void

JMenuItem.init(String text, Icon icon)
利用指定文本和图标初始化菜单项。

protected  void

AbstractButton.init(String text, Icon icon)

void

JTextArea.insert(String str, int pos)
将指定文本插入指定位置。

void

JMenu.insert(String s, int pos)
在给定位置插入具有指定文本的新菜单项。

void

JTabbedPane.insertTab(String title, Icon icon, Component component, String tip, int index)
在 index 位置插入一个 component，该组件通过 title 和/或 icon（任意一个都可以为 null）来表示。

void

JSpinner.AccessibleJSpinner.insertTextAtIndex(int index, String s)
在给定索引处插入指定的字符串。

static void

LookAndFeel.installBorder(JComponent c, String defaultBorderName)
使用默认的值设置组件边框属性的便捷方法。

static void

LookAndFeel.installColors(JComponent c, String defaultBgName, String defaultFgName)
使用默认的值设置组件的前景和背景颜色属性的便捷方法。

static void

LookAndFeel.installColorsAndFont(JComponent c, String defaultBgName, String defaultFgName, String defaultFontName)
使用默认的值设置组件的前景、背景和字体属性的便捷方法。

static void

UIManager.installLookAndFeel(String name, String className)
将指定的外观添加到可用外观的集合中。

static void

LookAndFeel.installProperty(JComponent c, String propertyName, Object propertyValue)
在组件上安装具有指定名称和值的属性的便捷方法，条件是该属性尚未由开发人员设置。

static String

SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。

static String

SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。

static Object

LookAndFeel.makeIcon(Class<?> baseClass, String gifFile)
创建并返回一个加载图像的 UIDefault.LazyValue。

void

SpringLayout.putConstraint(String e1, Component c1, int pad, String e2, Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2，边与边之间的距离固定。

void

SpringLayout.putConstraint(String e1, Component c1, Spring s, String e2, Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2。

void

AbstractAction.putValue(String key, Object newValue)
设置与指定键关联的 Value。

void

Action.putValue(String key, Object value)
使用关联的键设置此对象的一个属性。

static

<M,I> RowFilter<M,I>

RowFilter.regexFilter(String regex, int... indices)
返回一个 RowFilter，它使用正则表达式确定要包含哪些条目。

static void

JEditorPane.registerEditorKitForContentType(String type, String classname)
建立 type 到 classname 的默认绑定。

static void

JEditorPane.registerEditorKitForContentType(String type, String classname, ClassLoader loader)
建立 type 到 classname 的默认绑定。

void

JComponent.registerKeyboardAction(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。

void

UIDefaults.removeResourceBundle(String bundleName)
从在其中搜索本地化默认的资源包列表中移除一个资源包。

void

JTextPane.removeStyle(String nm)
移除以前添加到文档中的已命名的非 null 样式。

void

JTextArea.replaceRange(String str, int start, int end)
用给定的新文本替换从指示的起始位置到结尾位置的文本。

void

JEditorPane.replaceSelection(String content)
用由给定字符串表示的新内容替换当前选中的内容。

void

JTextPane.replaceSelection(String content)
用给定字符串所表示的新内容替换当前选择的内容。

void

JSpinner.AccessibleJSpinner.replaceText(int startIndex, int endIndex, String s)
用指定的字符串替换两个索引之间的文本。

void

JEditorPane.scrollToReference(String reference)
将视图滚动到给定的参考位置（也就是正在显示的 URL 的 UL.getRef 方法所返回的值）。

void

JTree.AccessibleJTree.AccessibleJTreeNode.setAccessibleDescription(String s)
设置此对象的可访问描述。

void

JTable.AccessibleJTable.AccessibleJTableCell.setAccessibleDescription(String s)
设置此对象的可访问的描述。

void

JList.AccessibleJList.AccessibleJListChild.setAccessibleDescription(String s)

void

ImageIcon.AccessibleImageIcon.setAccessibleIconDescription(String description)
设置图标的描述。

void

JTree.AccessibleJTree.AccessibleJTreeNode.setAccessibleName(String s)
设置此对象的本地化可访问名称。

void

JTable.AccessibleJTable.AccessibleJTableCell.setAccessibleName(String s)
获取此对象的可访问的本地化名称。

void

JList.AccessibleJList.AccessibleJListChild.setAccessibleName(String s)

void

JTextField.setActionCommand(String command)
设置用于操作事件的命令字符串。

void

JComboBox.setActionCommand(String aCommand)
设置发送到动作侦听器的事件中应该包括的动作命令。

void

DefaultButtonModel.setActionCommand(String actionCommand)
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。

void

ButtonModel.setActionCommand(String s)
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。

void

Timer.setActionCommand(String command)
设置将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。

void

AbstractButton.setActionCommand(String actionCommand)
设置此按钮的动作命令。

void

JFileChooser.setApproveButtonText(String approveButtonText)
设置 FileChooserUI 中的 ApproveButton 内使用的文本。

void

JFileChooser.setApproveButtonToolTipText(String toolTipText)
设置 ApproveButton 中使用的工具提示文本。

void

SpringLayout.Constraints.setConstraint(String edgeName, Spring s)
设置控制指定边的 spring。

void

JEditorPane.setContentType(String type)
设置此编辑器所处理的内容类型。

void

JScrollPane.setCorner(String key, Component corner)
添加一个将显示在一个滚动窗格角中的子级，如果有空间的话。

void

ImageIcon.setDescription(String description)
设置图像的描述。

void

JFileChooser.setDialogTitle(String dialogTitle)
设置显示在 JFileChooser 窗口标题栏的字符串。

void

JEditorPane.setEditorKitForContentType(String type, EditorKit k)
直接设置用于给定类型的编辑器工具包。

void

JPopupMenu.setLabel(String label)
设置弹出菜单的标签。

void

AbstractButton.setLabel(String label)
已过时。 - 由 setText(text) 取代

static void

UIManager.setLookAndFeel(String className)
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

void

ProgressMonitor.setNote(String note)
指定与进度消息一起显示的其他注释。

void

JEditorPane.setPage(String url)
设置当前要显示的 URL。

void

JProgressBar.setString(String s)
设置进度字符串的值。

void

JEditorPane.setText(String t)
将此 TextComponent 的文本设置为指定内容，预期以此编辑器的内容类型格式提供该内容。

void

AbstractButton.setText(String text)
设置按钮的文本。

void

JLabel.setText(String text)
定义此组件将要显示的单行文本。

void

JSpinner.AccessibleJSpinner.setTextContents(String s)
将文本内容设置为指定字符串。

void

JToolTip.setTipText(String tipText)
设置显示工具提示时要显示的文本。

void

JInternalFrame.setTitle(String title)
设置 JInternalFrame 的标题。

void

JTabbedPane.setTitleAt(int index, String title)
将 index 位置的标题设置为 title，它可以为 null。

void

JComponent.setToolTipText(String text)
注册要在工具提示中显示的文本。

void

JTabbedPane.setToolTipTextAt(int index, String toolTipText)
将 index 位置的工具提示文本设置为 toolTipText，它可以为 null。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的对话框。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。

int

JFileChooser.showDialog(Component parent, String approveButtonText)
弹出具有自定义 approve 按钮的自定义文件选择器对话框。

static Color

JColorChooser.showDialog(Component component, String title, Color initialColor)
显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。

static Object

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板，messageType 参数确定要显示的图标。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。

static String

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。

static Object

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。

static void

JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出一个显示消息的内部对话框面板，它使用由 messageType 参数确定的默认图标。

static void

JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示消息的内部对话框面板，为其指定了所有参数。

static int

JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

static void

JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。

static void

JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示信息的对话框，为其指定了所有参数。

static int

JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

abstract  Object

JFormattedTextField.AbstractFormatter.stringToValue(String text)
分析 text，返回任意 Object。

static GroupLayout.Alignment

GroupLayout.Alignment.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static LayoutStyle.ComponentPlacement

LayoutStyle.ComponentPlacement.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static RowFilter.ComparisonType

RowFilter.ComparisonType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static SortOrder

SortOrder.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static SwingWorker.StateValue

SwingWorker.StateValue.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static JTable.PrintMode

JTable.PrintMode.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static DropMode

DropMode.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 javax.swing 中的构造方法

AbstractAction(String name)
用指定描述字符串和默认图标定义一个 Action 对象。

AbstractAction(String name, Icon icon)
用指定描述字符串和指定图标定义一个 Action 对象。

ImageIcon(byte[] imageData, String description)
根据字节数组创建一个 ImageIcon，这些字节读取自一个包含受支持图像格式（比如 GIF、JPEG 或从 1.3 版本开始的 PNG）的图像文件。

ImageIcon(Image image, String description)
根据图像创建一个 ImageIcon。

ImageIcon(String filename)
根据指定的文件创建一个 ImageIcon。

ImageIcon(String filename, String description)
根据指定的文件创建一个 ImageIcon。

ImageIcon(URL location, String description)
根据指定的 URL 创建一个 ImageIcon。

JButton(String text)
创建一个带文本的按钮。

JButton(String text, Icon icon)
创建一个带初始文本和图标的按钮。

JCheckBox(String text)
创建一个带文本的、最初未被选定的复选框。

JCheckBox(String text, boolean selected)
创建一个带文本的复选框，并指定其最初是否处于选定状态。

JCheckBox(String text, Icon icon)
创建带有指定文本和图标的、最初未选定的复选框。

JCheckBox(String text, Icon icon, boolean selected)
创建一个带文本和图标的复选框，并指定其最初是否处于选定状态。

JCheckBoxMenuItem(String text)
创建一个带文本的、最初未被选定的复选框菜单项。

JCheckBoxMenuItem(String text, boolean b)
创建带有指定文本和选择状态的复选框菜单项。

JCheckBoxMenuItem(String text, Icon icon)
创建带有指定文本和图标的、最初未被选定的复选框菜单项。

JCheckBoxMenuItem(String text, Icon icon, boolean b)
创建带有指定文本、图标和选择状态的复选框菜单项。

JDialog(Dialog owner, String title)
创建一个具有指定标题和指定所有者对话框的无模式对话框。

JDialog(Dialog owner, String title, boolean modal)
创建一个具有指定标题、模式和指定所有者 Dialog 的对话框。

JDialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Dialog、模式和 GraphicsConfiguration 的对话框。

JDialog(Frame owner, String title)
创建一个具有指定标题和指定所有者窗体的无模式对话框。

JDialog(Frame owner, String title, boolean modal)
创建一个具有指定标题、所有者 Frame 和模式的对话框。

JDialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Frame、模式和 GraphicsConfiguration 的对话框。

JDialog(Window owner, String title)
创建一个具有指定标题和所有者 Window 的无模式对话框。

JDialog(Window owner, String title, Dialog.ModalityType modalityType)
创建一个具有指定标题、所有者 Window 和模式的对话框。

JDialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。

JEditorPane(String url)
根据包含 URL 规范的字符串创建一个 JEditorPane。

JEditorPane(String type, String text)
创建一个已初始化为给定文件的 JEditorPane。

JFileChooser(String currentDirectoryPath)
构造一个使用给定路径的 JFileChooser。

JFileChooser(String currentDirectoryPath, FileSystemView fsv)
使用给定的当前目录路径和 FileSystemView 构造一个 JFileChooser。

JFrame(String title)
创建一个新的、初始不可见的、具有指定标题的 Frame。

JFrame(String title, GraphicsConfiguration gc)
创建一个具有指定标题和指定屏幕设备的 GraphicsConfiguration 的 JFrame。

JInternalFrame(String title)
创建不可调整大小的、不可关闭的、不可最大化的、不可图标化的、具有指定标题的 JInternalFrame。

JInternalFrame(String title, boolean resizable)
创建不可关闭的、不可最大化的、不可图标化的，以及具有指定标题和可调整大小的 JInternalFrame。

JInternalFrame(String title, boolean resizable, boolean closable)
创建不可最大化的、不可图标化的，以及具有指定标题、可调整大小和可关闭的 JInternalFrame。

JInternalFrame(String title, boolean resizable, boolean closable, boolean maximizable)
创建不可图标化的，但具有指定标题、可调整大小、可关闭和可最大化的 JInternalFrame。

JInternalFrame(String title, boolean resizable, boolean closable, boolean maximizable, boolean iconifiable)
创建具有指定标题、可调整、可关闭、可最大化和可图标化的 JInternalFrame。

JLabel(String text)
创建具有指定文本的 JLabel 实例。

JLabel(String text, Icon icon, int horizontalAlignment)
创建具有指定文本、图像和水平对齐方式的 JLabel 实例。

JLabel(String text, int horizontalAlignment)
创建具有指定文本和水平对齐方式的 JLabel 实例。

JMenu(String s)
构造一个新 JMenu，用提供的字符串作为其文本。

JMenu(String s, boolean b)
构造一个新 JMenu，用提供的字符串作为其文本并指定其是否为分离式 (tear-off) 菜单。

JMenuItem(String text)
创建带有指定文本的 JMenuItem。

JMenuItem(String text, Icon icon)
创建带有指定文本和图标的 JMenuItem。

JMenuItem(String text, int mnemonic)
创建带有指定文本和键盘助记符的 JMenuItem。

JPasswordField(Document doc, String txt, int columns)
构造一个使用给定文本存储模型和给定列数的新 JPasswordField。

JPasswordField(String text)
构造一个利用指定文本初始化的新 JPasswordField。

JPasswordField(String text, int columns)
构造一个利用指定文本和列初始化的新 JPasswordField。

JPopupMenu(String label)
构造一个具有指定标题的 JPopupMenu。

JRadioButton(String text)
创建一个具有指定文本的状态为未选择的单选按钮。

JRadioButton(String text, boolean selected)
创建一个具有指定文本和选择状态的单选按钮。

JRadioButton(String text, Icon icon)
创建一个具有指定的文本和图像并初始化为未选择的单选按钮。

JRadioButton(String text, Icon icon, boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮。

JRadioButtonMenuItem(String text)
创建一个带文本的 JRadioButtonMenuItem。

JRadioButtonMenuItem(String text, boolean selected)
创建一个具有指定文本和选择状态的单选按钮菜单项。

JRadioButtonMenuItem(String text, Icon icon)
创建一个具有指定文本和 Icon 的单选按钮菜单项。

JRadioButtonMenuItem(String text, Icon icon, boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮菜单项。

JSpinner.DateEditor(JSpinner spinner, String dateFormatPattern)
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。

JSpinner.NumberEditor(JSpinner spinner, String decimalFormatPattern)
构造一个 JSpinner，使其支持具有一个 JFormattedTextField 的 SpinnerNumberModel 的值。

JTextArea(Document doc, String text, int rows, int columns)
构造具有指定行数和列数以及给定模型的新的 JTextArea。

JTextArea(String text)
构造显示指定文本的新的 TextArea。

JTextArea(String text, int rows, int columns)
构造具有指定文本、行数和列数的新的 TextArea。

JTextField(Document doc, String text, int columns)
构造一个新的 JTextField，它使用给定文本存储模型和给定的列数。

JTextField(String text)
构造一个用指定文本初始化的新 TextField。

JTextField(String text, int columns)
构造一个用指定文本和列初始化的新 TextField。

JToggleButton(String text)
创建具有指定文本的未选定的切换按钮。

JToggleButton(String text, boolean selected)
创建具有指定文本和选择状态的切换按钮。

JToggleButton(String text, Icon icon)
创建一个最初未选定的切换按钮，该按钮具有指定的文本和图像。

JToggleButton(String text, Icon icon, boolean selected)
创建具有指定文本、图像和选择状态的切换按钮。

JToolBar(String name)
创建一个具有指定 name 的新工具栏。

JToolBar(String name, int orientation)
创建一个具有指定 name 和 orientation 的新工具栏。

ProgressMonitor(Component parentComponent, Object message, String note, int min, int max)
构造一个图形对象，它一般会根据进程的完成情况通过填充矩形条来显示进度。

TransferHandler(String property)
构造一个通过剪贴板或拖放操作可以将 Java Bean 属性从一个组件传输到另一个组件的传输处理程序。

UIDefaults.ProxyLazyValue(String c)
创建一个将在请求时构造实例的 LazyValue。

UIDefaults.ProxyLazyValue(String c, Object[] o)
创建一个将在请求时构造实例的 LazyValue。

UIDefaults.ProxyLazyValue(String c, String m)
创建一个将在请求时构造实例的 LazyValue。

UIDefaults.ProxyLazyValue(String c, String m, Object[] o)
创建一个将在请求时构造实例的 LazyValue。

UIManager.LookAndFeelInfo(String name, String className)
构造一个 UIManager LookAndFeelInfo 对象。

UnsupportedLookAndFeelException(String s)
构造一个 UnsupportedLookAndFeelException 对象。

javax.swing.border 中 String 的使用

声明为 String 的 javax.swing.border 中的字段

protected  String

TitledBorder.title

返回 String 的 javax.swing.border 中的方法

String

TitledBorder.getTitle()
返回带标题边框的标题。

参数类型为 String 的 javax.swing.border 中的方法

void

TitledBorder.setTitle(String title)
设置带标题边框的标题。

参数类型为 String 的 javax.swing.border 中的构造方法

TitledBorder(Border border, String title)
创建具有指定边框和标题的 TitledBorder 实例。

TitledBorder(Border border, String title, int titleJustification, int titlePosition)
用指定的边框、标题、标题对齐方式和标题位置创建 TitledBorder 实例。

TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
用指定的边框、标题、标题对齐方式、标题位置和标题字体创建 TitledBorder 实例。

TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。

TitledBorder(String title)
创建 TitledBorder 实例。

javax.swing.colorchooser 中 String 的使用

返回 String 的 javax.swing.colorchooser 中的方法

abstract  String

AbstractColorChooserPanel.getDisplayName()
返回一个包含面板显示名称的字符串。

javax.swing.event 中 String 的使用

返回 String 的 javax.swing.event 中的方法

String

HyperlinkEvent.getDescription()
获得链接描述的字符串表示形式。

String

InternalFrameEvent.paramString()
返回标识此事件的参数字符串。

String

HyperlinkEvent.EventType.toString()
将类型转换成一个字符串。

String

ListDataEvent.toString()
返回此 ListDataEvent 的字符串表示形式。

String

TreeModelEvent.toString()
返回显示和标识此对象属性的字符串。

String

ListSelectionEvent.toString()
返回显示并标识此对象的属性的 String。

String

DocumentEvent.EventType.toString()
将类型转换成一个字符串。

String

EventListenerList.toString()
返回此 EventListenerList 的字符串表示形式。

参数类型为 String 的 javax.swing.event 中的方法

static RowSorterEvent.Type

RowSorterEvent.Type.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 javax.swing.event 中的构造方法

HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
创建一个表示超文本链接事件的新对象。

HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。

javax.swing.filechooser 中 String 的使用

返回 String 的 javax.swing.filechooser 中的方法

String

FileNameExtensionFilter.getDescription()
此过滤器的描述。

abstract  String

FileFilter.getDescription()
此过滤器的描述。

String

FileView.getDescription(File f)
文件的可读描述。

String[]

FileNameExtensionFilter.getExtensions()
返回要测试文件的文件扩展名集合。

String

FileView.getName(File f)
文件名称。

String

FileSystemView.getSystemDisplayName(File f)
在系统文件浏览器中显示的文件、目录或文件夹名。

String

FileSystemView.getSystemTypeDescription(File f)
在系统文件浏览器中显示的文件、目录或文件夹类型描述。

String

FileView.getTypeDescription(File f)
文件类型的可读描述。

String

FileNameExtensionFilter.toString()
返回 FileNameExtensionFilter 的字符串表示形式。

参数类型为 String 的 javax.swing.filechooser 中的方法

File

FileSystemView.createFileObject(File dir, String filename)
返回根据给定的 filename 在 dir 中构造的 File 对象。

File

FileSystemView.createFileObject(String path)
返回根据给定路径字符串构造的 File 对象。

File

FileSystemView.getChild(File parent, String fileName)

参数类型为 String 的 javax.swing.filechooser 中的构造方法

FileNameExtensionFilter(String description, String... extensions)
使用指定的描述和文件扩展名创建一个 FileNameExtensionFilter。

FileNameExtensionFilter(String description, String... extensions)
使用指定的描述和文件扩展名创建一个 FileNameExtensionFilter。

javax.swing.plaf 中 String 的使用

返回 String 的 javax.swing.plaf 中的方法

abstract  String

FileChooserUI.getApproveButtonText(JFileChooser fc)

abstract  String

FileChooserUI.getDialogTitle(JFileChooser fc)

String

TextUI.getToolTipText(JTextComponent t, Point pt)
返回在传入位置上用作工具提示的字符串。

参数类型为 String 的 javax.swing.plaf 中的构造方法

BorderUIResource.TitledBorderUIResource(Border border, String title)

BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition)

BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont)

BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)

BorderUIResource.TitledBorderUIResource(String title)

FontUIResource(String name, int style, int size)

javax.swing.plaf.basic 中 String 的使用

声明为 String 的 javax.swing.plaf.basic 中的字段

protected  String

BasicFileChooserUI.cancelButtonText

protected  String

BasicFileChooserUI.cancelButtonToolTipText

protected static String

BasicInternalFrameTitlePane.CLOSE_CMD

protected  String

BasicToolBarUI.constraintBeforeFloating

protected  String

BasicFileChooserUI.directoryOpenButtonText
选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的标签文本。

protected  String

BasicFileChooserUI.directoryOpenButtonToolTipText
选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的工具提示文本。

static String

BasicHTML.documentBaseKey
存储为客户端属性以指示用作解析相关引用的基址的键。

protected  String

BasicFileChooserUI.helpButtonText

protected  String

BasicFileChooserUI.helpButtonToolTipText

protected static String

BasicInternalFrameTitlePane.ICONIFY_CMD

protected static String

BasicInternalFrameTitlePane.MAXIMIZE_CMD

protected static String

BasicInternalFrameTitlePane.MOVE_CMD

protected static String

BasicSplitPaneUI.NON_CONTINUOUS_DIVIDER
用于非连续布局的分隔符通过此对象添加到拆分窗格。

protected  String

BasicFileChooserUI.openButtonText

protected  String

BasicFileChooserUI.openButtonToolTipText

static String

BasicHTML.propertyKey
存储为 JComponent 的客户端属性时用于 html 渲染器的键。

protected static String

BasicInternalFrameTitlePane.RESTORE_CMD

protected  String

BasicFileChooserUI.saveButtonText

protected  String

BasicFileChooserUI.saveButtonToolTipText

protected static String

BasicInternalFrameTitlePane.SIZE_CMD

protected  String

BasicFileChooserUI.updateButtonText

protected  String

BasicFileChooserUI.updateButtonToolTipText

返回 String 的 javax.swing.plaf.basic 中的方法

String

BasicFileChooserUI.getApproveButtonText(JFileChooser fc)

String

BasicFileChooserUI.getApproveButtonToolTipText(JFileChooser fc)

String

BasicFileChooserUI.AcceptAllFileFilter.getDescription()

String

BasicFileChooserUI.BasicFileView.getDescription(File f)

String

BasicFileChooserUI.getDialogTitle(JFileChooser fc)
返回此对话框的标题

String

BasicFileChooserUI.getDirectoryName()

String

BasicFileChooserUI.getFileName()

protected  String

BasicTextUI.getKeymapName()
获取默认情况下为此 UI 安装或用于此 UI 的 keymap 的名称。

String

BasicFileChooserUI.BasicFileView.getName(File f)

String

BasicCheckBoxUI.getPropertyPrefix()

protected  String

BasicEditorPaneUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected  String

BasicFormattedTextFieldUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected  String

BasicPasswordFieldUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected  String

BasicTextPaneUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected  String

BasicRadioButtonMenuItemUI.getPropertyPrefix()

protected  String

BasicCheckBoxMenuItemUI.getPropertyPrefix()

protected  String

BasicTextAreaUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected  String

BasicRadioButtonUI.getPropertyPrefix()

protected  String

BasicTextFieldUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected abstract  String

BasicTextUI.getPropertyPrefix()
获取通过 UIManager 查找属性时用作键的名称。

protected  String

BasicMenuUI.getPropertyPrefix()

protected  String

BasicMenuItemUI.getPropertyPrefix()

protected  String

BasicToggleButtonUI.getPropertyPrefix()

protected  String

BasicButtonUI.getPropertyPrefix()

protected  String

BasicInternalFrameTitlePane.getTitle(String text, FontMetrics fm, int availTextWidth)

String

BasicTextUI.getToolTipText(JTextComponent t, Point pt)
返回在传入位置上用作工具提示的字符串。

String

BasicFileChooserUI.BasicFileView.getTypeDescription(File f)

protected  String

BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。

参数类型为 String 的 javax.swing.plaf.basic 中的方法

void

BasicInternalFrameTitlePane.TitlePaneLayout.addLayoutComponent(String name, Component c)

void

BasicInternalFrameUI.InternalFrameLayout.addLayoutComponent(String name, Component c)

void

BasicOptionPaneUI.ButtonAreaLayout.addLayoutComponent(String string, Component comp)

void

BasicSplitPaneDivider.DividerLayout.addLayoutComponent(String string, Component c)

void

BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent(String place, Component component)
在 place 位置添加组件。

void

BasicTabbedPaneUI.TabbedPaneLayout.addLayoutComponent(String name, Component comp)

void

BasicComboBoxUI.ComboBoxLayoutManager.addLayoutComponent(String name, Component comp)

void

BasicScrollBarUI.addLayoutComponent(String name, Component child)

protected  void

BasicOptionPaneUI.burstStringInto(Container c, String d, int maxll)
递归式创建表示 d 的新 JLabel 实例每个 JLabel 实例都将被添加到 c。

static View

BasicHTML.createHTMLView(JComponent c, String html)
创建给定组件和 html 字符串的 html 渲染器。

static void

BasicGraphicsUtils.drawString(Graphics g, String text, int underlinedChar, int x, int y)
像 g.drawString 那样利用图形 g 在位置 (x,y) 绘制字符串。

static void

BasicGraphicsUtils.drawStringUnderlineCharAt(Graphics g, String text, int underlinedIndex, int x, int y)
像 g.drawString 那样利用图形 g 在位置 (x, y) 绘制字符串。

protected  void

BasicDirectoryModel.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告 boolean 属性的绑定属性的改变。

protected  Point

BasicProgressBarUI.getStringPlacement(Graphics g, String progressString, int x, int y, int width, int height)
指定将绘制进度字符串的位置。

protected  String

BasicInternalFrameTitlePane.getTitle(String text, FontMetrics fm, int availTextWidth)

static boolean

BasicHTML.isHTMLString(String s)
检查给定字符串以查看它是否应该在支持 html 呈现的非文本组件中触发 html 呈现逻辑。

protected  String

BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。

protected  void

BasicTabbedPaneUI.layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)

protected  void

BasicLookAndFeel.loadSystemColors(UIDefaults table, String[] systemColors, boolean useNative)
用 systemColors 中的 name-color 对填充 table。

protected  void

BasicLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用 background.lighter() 将 clippedText 绘制在 textX、textY 处，然后利用 background.darker() 向右下移动一个像素。

protected  void

BasicLabelUI.paintEnabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用标签的前景色将 clippedText 绘制在 textX、textY 处。

protected  void

BasicButtonUI.paintText(Graphics g, AbstractButton b, Rectangle textRect, String text)
呈现当前按钮文本的方法。

protected  void

BasicTabbedPaneUI.paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)

protected  void

BasicButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。

protected  void

BasicMenuItemUI.paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
呈现当前菜单项的文本。

void

BasicFileChooserUI.setDirectoryName(String dirname)

void

BasicFileChooserUI.setFileName(String filename)

static void

BasicHTML.updateRenderer(JComponent c, String text)
将给定文本的 HTML 渲染器隐藏在给定 JComponent 的客户端属性中。

参数类型为 String 的 javax.swing.plaf.basic 中的构造方法

BasicTreeUI.TreeCancelEditingAction(String name)

BasicTreeUI.TreeHomeAction(int direction, String name)

BasicTreeUI.TreeIncrementAction(int direction, String name)

BasicTreeUI.TreePageAction(int direction, String name)

BasicTreeUI.TreeToggleAction(String name)

BasicTreeUI.TreeTraverseAction(int direction, String name)

javax.swing.plaf.metal 中 String 的使用

声明为 String 的 javax.swing.plaf.metal 中的字段

static String

MetalScrollBarUI.FREE_STANDING_PROP

protected static String

MetalInternalFrameUI.IS_PALETTE

protected  String

MetalSliderUI.SLIDER_FILL

返回 String 的 javax.swing.plaf.metal 中的方法

String

MetalToolTipUI.getAcceleratorString()

String

MetalLookAndFeel.getDescription()
返回此外观的简短描述。

String

MetalFileChooserUI.getDirectoryName()

String

MetalFileChooserUI.getFileName()

String

MetalLookAndFeel.getID()
此外观的标识符。

String

OceanTheme.getName()
返回此主题的名称，即 "Ocean"。

String

DefaultMetalTheme.getName()
返回此主题的名称。

abstract  String

MetalTheme.getName()
返回此主题的名称。

String

MetalLookAndFeel.getName()
返回此外观的名称。

String

MetalCheckBoxUI.getPropertyPrefix()

参数类型为 String 的 javax.swing.plaf.metal 中的方法

protected  void

MetalLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
只绘制文本灰度 (Label.disabledForeground)，而不是使用标签前景色。

protected  void

MetalToggleButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)

protected  void

MetalButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)

void

MetalFileChooserUI.setDirectoryName(String dirname)

void

MetalFileChooserUI.setFileName(String filename)

javax.swing.plaf.multi 中 String 的使用

返回 String 的 javax.swing.plaf.multi 中的方法

String

MultiFileChooserUI.getApproveButtonText(JFileChooser a)
在由此对象处理的每个 UI 上调用 getApproveButtonText 方法。

String

MultiLookAndFeel.getDescription()
返回对此外观的一行描述。

String

MultiFileChooserUI.getDialogTitle(JFileChooser a)
在由此对象处理的每个 UI 上调用 getDialogTitle 方法。

String

MultiLookAndFeel.getID()
返回适合应用程序/服务使用、标识此外观的 string。

String

MultiLookAndFeel.getName()
返回适合在菜单中使用、标识此外观的 string。

String

MultiTextUI.getToolTipText(JTextComponent a, Point b)
在由此对象处理的每个 UI 上调用 getToolTipText 方法。

javax.swing.plaf.synth 中 String 的使用

返回 String 的 javax.swing.plaf.synth 中的方法

String

SynthLookAndFeel.getDescription()
返回 SynthLookAndFeel 的文本描述。

String

SynthLookAndFeel.getID()
返回一个标识此外观的短字符串。

String

Region.getName()
返回 region 的名称。

String

SynthLookAndFeel.getName()
返回一个标识此外观的短字符串。

String

SynthStyle.getString(SynthContext context, Object key, String defaultValue)
获得其值是一个 String 值的特定样式属性的便捷方法。

String

SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)
根据通过引用返回的放置图标和文本的位置，布局文本和图标。

String

ColorType.toString()
返回此 ColorType 的文本描述。

String

Region.toString()
返回 Region 的名称。

参数类型为 String 的 javax.swing.plaf.synth 中的方法

int

SynthGraphicsUtils.computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text)
返回传入字符串的大小。

Dimension

SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
返回正确呈现图标和文本所需的最大大小。

Dimension

SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
返回正确呈现图标和文本所需的最小大小。

Dimension

SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
返回正确呈现图标和文本所需的首选大小。

String

SynthStyle.getString(SynthContext context, Object key, String defaultValue)
获得其值是一个 String 值的特定样式属性的便捷方法。

String

SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)
根据通过引用返回的放置图标和文本的位置，布局文本和图标。

void

SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset)
绘制图标和文本。

void

SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex)
在指定位置上绘制文本。

void

SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex)
在指定位置上绘制文本。

参数类型为 String 的 javax.swing.plaf.synth 中的构造方法

ColorType(String description)
创建一个具有指定描述的 ColorType。

Region(String name, String ui, boolean subregion)
创建具有指定名称的 Region。

javax.swing.table 中 String 的使用

声明为 String 的 javax.swing.table 中的字段

static String

TableColumn.CELL_RENDERER_PROPERTY
从 Java 2 platform v1.3 开始已过时。

static String

TableColumn.COLUMN_WIDTH_PROPERTY
从 Java 2 platform v1.3 开始已过时。

static String

TableColumn.HEADER_RENDERER_PROPERTY
从 Java 2 platform v1.3 开始已过时。

static String

TableColumn.HEADER_VALUE_PROPERTY
从 Java 2 platform v1.3 开始已过时。

返回 String 的 javax.swing.table 中的方法

String

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleDescription()

String

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleName()

String

DefaultTableModel.getColumnName(int column)
返回列名称。

String

AbstractTableModel.getColumnName(int column)
返回列默认名称，其中列使用以下工作表约定：A、B、C……Z、AA、AB 等等。

String

TableModel.getColumnName(int columnIndex)
返回 columnIndex 位置的列的名称。

String

JTableHeader.getToolTipText(MouseEvent event)
如果设置了提示文本，则允许使用渲染器的提示。

String

JTableHeader.getUIClassID()
返回用于构造外观 (L&F) 类名称的后缀，该类用于渲染此组件。

protected  String

JTableHeader.paramString()
返回此 JTableHeader 的字符串表示形式。

abstract  String

TableStringConverter.toString(TableModel model, int row, int column)
返回指定位置处值的字符串表示形式。

参数类型为 String 的 javax.swing.table 中的方法

int

AbstractTableModel.findColumn(String columnName)
返回具有给定名称的列。

void

DefaultTableCellRenderer.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
因为性能原因而被重写。

protected  void

DefaultTableCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

void

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setAccessibleDescription(String s)

void

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setAccessibleName(String s)

javax.swing.text 中 String 的使用

声明为 String 的 javax.swing.text 中的字段

String

JTextComponent.KeyBinding.actionName
键的操作名称。

static String

DefaultEditorKit.backwardAction
用于将插入符在逻辑上向后移动一个位置的动作名称。

protected static String

AbstractDocument.BAD_LOCATION
指示位置错误的错误消息。

static String

DefaultEditorKit.beepAction
用于创建蜂鸣声的动作名称。

static String

DefaultEditorKit.beginAction
用于将插入符移动到文档开头的 Action 名称。

static String

DefaultEditorKit.beginLineAction
用于将插入符移动到行首的 Action 名称。

static String

DefaultEditorKit.beginParagraphAction
用于将插入符移动到段落开头的 Action 名称。

static String

DefaultEditorKit.beginWordAction
用于将插入符移动到字首的 Action 名称。

static String

AbstractDocument.BidiElementName
用于保存单向操作的元素名。

static String

StyleConstants.ComponentElementName
用于表示组件的元素名称。

static String

AbstractDocument.ContentElementName
用于表示内容的元素名

static String

DefaultEditorKit.copyAction
复制选定区域并将其内容置于剪贴板中的动作名称。

static String

DefaultEditorKit.cutAction
剪切选定区域并将其内容置于剪贴板中的动作名称。

static String

JTextComponent.DEFAULT_KEYMAP
将由所有 JTextComponent 实例共享的默认 keymap，除非这些实例已有另一个 keymap 集合。

static String

StyleContext.DEFAULT_STYLE
赋予与段落相关的默认逻辑样式的名称。

static String

DefaultEditorKit.defaultKeyTypedAction
在接收到键输入事件 并且无 keymap 输入时默认执行的动作名称。

static String

DefaultEditorKit.deleteNextCharAction
删除当前插入符位置之后字符内容的动作名称。

static String

DefaultEditorKit.deleteNextWordAction
删除选择开始位置之后单词的动作名称。

static String

DefaultEditorKit.deletePrevCharAction
删除当前插入符位置之前字符内容的动作名称。

static String

DefaultEditorKit.deletePrevWordAction
删除选择开始位置之前单词的动作名称。

static String

DefaultEditorKit.downAction
用于将插入符在逻辑上向下移动一个位置的动作名称。

static String

AbstractDocument.ElementNameAttribute
用于指定元素名的属性名。

static String

DefaultEditorKit.endAction
用于将插入符移动到文档末尾的 Action 名称。

static String

DefaultEditorKit.endLineAction
用于将插入符移动到行尾的 Action 名称。

static String

DefaultEditorKit.EndOfLineStringProperty
在读取文档时，如果遇到 CRLF，将添加具有此名称的一个属性，属性值为 "\r\n"。

static String

DefaultEditorKit.endParagraphAction
用于将插入符移动到段落末尾的 Action 名称。

static String

DefaultEditorKit.endWordAction
用于将插入符移动到字尾的动作名称。

static String

JTextComponent.FOCUS_ACCELERATOR_KEY
焦点加速键的绑定 (bound) 属性名称。

static String

DefaultEditorKit.forwardAction
用于将插入符逻辑向前移动一个位置的动作名称。

static String

StyleConstants.IconElementName
用于表示图标的元素名称。

static String

DefaultEditorKit.insertBreakAction
向文档放置行/段中断的动作名称。

static String

DefaultEditorKit.insertContentAction
将内容置于关联文档中的动作名称。

static String

DefaultEditorKit.insertTabAction
将制表符置于文档中的动作名称。

static String

PlainDocument.lineLimitAttribute
指定行的最大长度的属性名称（如果有最大长度）。

static String

DefaultEditorKit.nextWordAction
用于将插入符移动到下一个字开头的 Action 名称。

static String

DefaultEditorKit.pageDownAction
垂直向下翻页的动作名称。

static String

DefaultEditorKit.pageUpAction
垂直向上翻页的动作名称。

static String

AbstractDocument.ParagraphElementName
用于表示段落的元素名

static String

DefaultEditorKit.pasteAction
将系统剪贴板内容粘贴到选定区域、如果未选中任何内容，则粘贴到插入符之前的动作名称。

static String

DefaultEditorKit.previousWordAction
用于将插入符移动到前一个字开头的 Action 名称。

static String

DefaultEditorKit.readOnlyAction
将编辑器设置为只读模式的动作名称。

static String

AbstractDocument.SectionElementName
用于保存各节（行/段落）的元素名。

static String

DefaultEditorKit.selectAllAction
用于选中整个文档的动作名称

static String

DefaultEditorKit.selectionBackwardAction
通过将插入符在逻辑上向后移动一个位置来扩展选定内容的动作名称。

static String

DefaultEditorKit.selectionBeginAction
用于将插入符移动到文档开头的 Action 名称。

static String

DefaultEditorKit.selectionBeginLineAction
用于将插入符移动到行首并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionBeginParagraphAction
用于将插入符移动到段落开头并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionBeginWordAction
用于将插入符移动到字首并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionDownAction
用于将插入符在逻辑上向下移动一个位置并扩展选定内容的动作名称。

static String

DefaultEditorKit.selectionEndAction
用于将插入符移动到文档末尾的 Action 名称。

static String

DefaultEditorKit.selectionEndLineAction
用于将插入符移动到行尾并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionEndParagraphAction
用于将插入符移动到段落末尾并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionEndWordAction
用于将插入符移动到字尾并扩展选定内容的动作名称。

static String

DefaultEditorKit.selectionForwardAction
通过将插入符在逻辑上向前移动一个位置来扩展选定内容的动作名称。

static String

DefaultEditorKit.selectionNextWordAction
用于将选定内容移动到下一个字的开头并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionPreviousWordAction
用于将选定内容移动到前一个字的开头并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionUpAction
用于将插入符在逻辑上向上移动一个位置并扩展选定内容的动作名称。

static String

DefaultEditorKit.selectLineAction
用于选中围绕插入符的某一行的 Action 名称。

static String

DefaultEditorKit.selectParagraphAction
用于选中围绕插入符的一个段落的动作名称。

static String

DefaultEditorKit.selectWordAction
用于选中围绕插入符的某个字的 Action 名称。

static String

Document.StreamDescriptionProperty
用于描述初始化文档的流的属性名。

static String

PlainDocument.tabSizeAttribute
指定内容中包含的制表符大小的属性名称。

static String

Document.TitleProperty
文档标题的属性名（如果有）。

static String

DefaultEditorKit.upAction
用于将插入符在逻辑上向上移动一个位置的动作名称。

static String

DefaultEditorKit.writableAction
将编辑器设置为可写入模式的动作名称。

返回 String 的 javax.swing.text 中的方法

String

JTextComponent.AccessibleJTextComponent.getAccessibleActionDescription(int i)
返回对该对象的指定操作的描述。

String

JTextComponent.AccessibleJTextComponent.getAfterIndex(int part, int index)
返回给定索引之后的 String。

String

JTextComponent.AccessibleJTextComponent.getAtIndex(int part, int index)
返回给定索引处的 String。

String

JTextComponent.AccessibleJTextComponent.getBeforeIndex(int part, int index)
返回给定索引之前的 String。

String

ChangedCharSetException.getCharSetSpec()

String

DefaultEditorKit.getContentType()
获取此工具包声明支持的数据的 MIME 类型。

abstract  String

EditorKit.getContentType()
获得此工具包声明支持的数据的 MIME 类型。

static String

StyleConstants.getFontFamily(AttributeSet a)
从属性列表中获取字体系列设置。

String

MaskFormatter.getInvalidCharacters()
返回输入无效的字符。

String

AbstractWriter.getLineSeparator()
返回用于表示换行的 String。

String

MaskFormatter.getMask()
返回格式化掩码。

String

DefaultStyledDocument.SectionElement.getName()
获得元素的名称。

String

Keymap.getName()
获取键绑定集合的名称。

String

Style.getName()
获取样式名称。

String

StyleContext.NamedStyle.getName()
获取样式的名称。

String

AbstractDocument.AbstractElement.getName()
获取该元素的名称。

String

AbstractDocument.BranchElement.getName()
获得元素名。

String

AbstractDocument.LeafElement.getName()
获得元素名。

String

Element.getName()
获取元素的名称。

String

MaskFormatter.getPlaceholder()
如果值未完全填充掩码，则返回要使用的 String。

String

AbstractDocument.DefaultDocumentEvent.getPresentationName()
提供此次编辑的已本地化的、可读的描述，比如，适合于在更改日志中使用的。

String

AbstractDocument.DefaultDocumentEvent.getRedoPresentationName()
提供此次编辑可重复执行形式的、已本地化的、可读的描述，例如用作 Redo 菜单项。

String

JTextComponent.getSelectedText()
返回此 TextComponent 中包含的选定文本。

String

JTextComponent.AccessibleJTextComponent.getSelectedText()
返回选定文本的某一部分。

String

StringContent.getString(int where, int len)
检索内容的某一部分，where ＋ len 必须 <= length()。

String

GapContent.getString(int where, int len)
检索部分内容。

String

AbstractDocument.Content.getString(int where, int len)
获取序列中包含的字符串。

String

JTextComponent.getText()
返回此 TextComponent 中包含的文本。

protected  String

AbstractWriter.getText(Element elem)
返回与该元素关联的文本。

String

JTextComponent.getText(int offs, int len)
获取由组件表示的文本部分。

String

AbstractDocument.getText(int offset, int length)
从文档中获得文本序列。

String

Document.getText(int offset, int length)
获取文档中给定部分包含的文本。

String

JTextComponent.AccessibleJTextComponent.getTextRange(int startIndex, int endIndex)
返回两个索引之间的文本字符串。

String

View.getToolTipText(float x, float y, Shape allocation)
返回提定位置的工具提示文本。

String

JTextComponent.getToolTipText(MouseEvent event)
返回用作 event 的工具提示的字符串。

String

AbstractDocument.DefaultDocumentEvent.getUndoPresentationName()
提供此次编辑可撤消形式的、已本地化的、可读的描述，例如，用作 Undo 菜单项。

String

MaskFormatter.getValidCharacters()
返回可以输入的有效字符。

protected  String

JTextComponent.paramString()
返回此 JTextComponent 的字符串表示形式。

String

DefaultStyledDocument.ElementSpec.toString()
将元素转换为字符串。

String

TabSet.toString()
返回此 tab 集合的字符串表示形式。

String

TabStop.toString()

String

DefaultCaret.toString()

String

JTextComponent.DropLocation.toString()
返回此放置位置的字符串表示形式。

String

Segment.toString()
将 segment 转换为 String。

String

Position.Bias.toString()
字符串表示形式

String

SimpleAttributeSet.toString()
将属性集转换为 String。

String

StyleConstants.toString()
返回字符串表示形式。

String

StyleContext.toString()
将 StyleContext 转换成为 String。

String

StyleContext.SmallAttributeSet.toString()
返回表示键/值对的字符串

String

StyleContext.NamedStyle.toString()
将样式转换成为字符串。

String

AbstractDocument.BranchElement.toString()
将该元素转换为字符串。

String

AbstractDocument.LeafElement.toString()
将该元素转换为字符串。

String

AbstractDocument.DefaultDocumentEvent.toString()
返回更改事件的字符串表示形式。

String

DefaultFormatter.valueToString(Object value)
使用 toString 方法将传入的 Object 转换为 String。

String

InternationalFormatter.valueToString(Object value)
返回 Object value 的 String 表示形式。

String

MaskFormatter.valueToString(Object value)
返回基于掩码的 Object value 的 String 表示形式。

参数类型为 String 的 javax.swing.text 中的方法

static Keymap

JTextComponent.addKeymap(String nm, Keymap parent)
将一个新 keymap 添加到 keymap 层次结构。

Style

DefaultStyledDocument.addStyle(String nm, Style parent)
向逻辑样式层次结构中添加新样式。

Style

StyledDocument.addStyle(String nm, Style parent)
向逻辑样式层次中添加新样式。

Style

StyleContext.addStyle(String nm, Style parent)
将新的样式添加到样式层次中。

Font

StyleContext.getFont(String family, int style, int size)
获取新字体。

static Keymap

JTextComponent.getKeymap(String nm)
获取以前添加到文档中的已命名 keymap。

Style

DefaultStyledDocument.getStyle(String nm)
获取以前添加的已命名的样式。

Style

StyledDocument.getStyle(String nm)
获取以前添加的指定样式。

Style

StyleContext.getStyle(String nm)
获取以前添加到文档中的已命名样式

void

DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr)
将文本插入指定的 Document 之前调用。

UndoableEdit

StringContent.insertString(int where, String str)
将字符串插入到内容中。

UndoableEdit

GapContent.insertString(int where, String str)
在内容中插入字符串。

UndoableEdit

AbstractDocument.Content.insertString(int where, String str)
向序列中插入一个字符串。

abstract  void

DocumentFilter.FilterBypass.insertString(int offset, String string, AttributeSet attr)
插入指定的文本，绕过 DocumentFilter。

void

PlainDocument.insertString(int offs, String str, AttributeSet a)
向文档中插入某些内容。

void

AbstractDocument.insertString(int offs, String str, AttributeSet a)
将某些内容插入文档。

void

Document.insertString(int offset, String str, AttributeSet a)
插入内容字符串。

void

JTextComponent.AccessibleJTextComponent.insertTextAtIndex(int index, String s)
在给定索引处插入指定字符串

static Keymap

JTextComponent.removeKeymap(String nm)
移除以前添加到文档中的已命名 keymap。

void

DefaultStyledDocument.removeStyle(String nm)
移除以前添加到文档中的已命名样式。

void

StyledDocument.removeStyle(String nm)
移除以前添加到文档中的指定样式。

void

StyleContext.removeStyle(String nm)
移除以前添加到文档中的已命名样式。

void

DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs)
在替换指定的 Document 中的文本区域之前调用。

abstract  void

DocumentFilter.FilterBypass.replace(int offset, int length, String string, AttributeSet attrs)
删除从 offset 到 offset + length 的文本区域，并用 text 替换。

void

AbstractDocument.replace(int offset, int length, String text, AttributeSet attrs)
删除从 offset 到 offset + length 的文本区域，并用 text 替换它。

void

JTextComponent.replaceSelection(String content)
用给定字符串所表示的新内容替换当前选定的内容。

void

JTextComponent.AccessibleJTextComponent.replaceText(int startIndex, int endIndex, String s)
使用指定字符串替换两个索引之间的文本。

static void

StyleConstants.setFontFamily(MutableAttributeSet a, String fam)
设置字体属性。

void

MaskFormatter.setInvalidCharacters(String invalidCharacters)
允许进一步限制可以输入的字符。

void

AbstractWriter.setLineSeparator(String value)
设置用于表示换行的 String。

void

MaskFormatter.setMask(String mask)
设置指示合法字符的掩码。

void

StyleContext.NamedStyle.setName(String name)
更改样式的名称。

void

MaskFormatter.setPlaceholder(String placeholder)
设置值未完全填充掩码时要使用的字符串。

void

JTextComponent.setText(String t)
将此 TextComponent 文本设置为指定文本。

void

JTextComponent.AccessibleJTextComponent.setTextContents(String s)
将文本内容设置为指定字符串。

void

MaskFormatter.setValidCharacters(String validCharacters)
允许进一步限制可以输入的字符。

Object

DefaultFormatter.stringToValue(String string)
通过使用带 String 参数的构造方法将传入的 String 转换为 getValueClass 的一个实例。

Object

InternationalFormatter.stringToValue(String text)
返回 String text 的 Object 表示形式。

Object

MaskFormatter.stringToValue(String value)
解析文本，返回 String value 的适当 Object 表示形式。

protected  void

AbstractWriter.write(String content)
写出字符串。

参数类型为 String 的 javax.swing.text 中的构造方法

BadLocationException(String s, int offs)
创建新的 BadLocationException 对象。

ChangedCharSetException(String charSetSpec, boolean charSetKey)

JTextComponent.KeyBinding(KeyStroke key, String actionName)
创建新的键绑定。

MaskFormatter(String mask)
创建具有指定掩码的 MaskFormatter。

StyleContext.NamedStyle(String name, Style parent)
创建新的命名样式。

StyledEditorKit.AlignmentAction(String nm, int a)
创建新的 AlignmentAction。

StyledEditorKit.FontFamilyAction(String nm, String family)
创建新的 FontFamilyAction。

StyledEditorKit.FontSizeAction(String nm, int size)
创建新 FontSizeAction。

StyledEditorKit.ForegroundAction(String nm, Color fg)
创建新的 ForegroundAction。

StyledEditorKit.StyledTextAction(String nm)
通过字符串操作名称创建新的 StyledTextAction。

TextAction(String name)
创建一个新的 JTextAction 对象。

javax.swing.text.html 中 String 的使用

声明为 String 的 javax.swing.text.html 中的字段

static String

HTMLDocument.AdditionalComments
文档属性键值。

static String

HTMLEditorKit.BOLD_ACTION
粗体动作标识符

static String

HTMLEditorKit.COLOR_ACTION
Color 选择动作标识符（颜色作为参数传递）

static String

HTMLEditorKit.DEFAULT_CSS
用于设置标记视图的默认级联样式表 (Cascading Style Sheet) 文件。

static String

HTMLEditorKit.FONT_CHANGE_BIGGER
字体大小增大到下一个值的动作标识符

static String

HTMLEditorKit.FONT_CHANGE_SMALLER
字体大小减小到下一个值的动作标识符

protected  String

HTMLEditorKit.InsertHTMLTextAction.html
要插入的 HTML。

static String

HTMLEditorKit.IMG_ALIGN_BOTTOM
将图像底部对齐。

static String

HTMLEditorKit.IMG_ALIGN_MIDDLE
将图像居中对齐。

static String

HTMLEditorKit.IMG_ALIGN_TOP
将图像顶部对齐。

static String

HTMLEditorKit.IMG_BORDER
将图像对齐到边框。

static String

HTMLEditorKit.ITALIC_ACTION
斜体动作标识符

static String

HTMLEditorKit.LOGICAL_STYLE_ACTION
逻辑样式选择动作标识符（逻辑样式作为参数传递）

static String

HTML.NULL_ATTRIBUTE_VALUE

static String

HTMLEditorKit.PARA_INDENT_LEFT
段落左缩进动作标识符

static String

HTMLEditorKit.PARA_INDENT_RIGHT
段落右缩进动作标识符

static String

FormView.RESET
已过时。 从 1.3 开始，将使用来自 UIManager UIManager property FormView.resetButtonText 的值

static String

FormView.SUBMIT
已过时。 从 1.3 开始，将使用来自 UIManager property FormView.submitButtonText 的值

返回 String 的 javax.swing.text.html 中的方法

String

ImageView.getAltText()
如果不能加载图像，则返回要显示的文本。

String

HTMLEditorKit.getContentType()
获取此工具包支持的 MIME 类型的数据。

String

FormSubmitEvent.getData()
获取表单提交数据。

String

CSS.Attribute.getDefaultValue()
获取属性的默认值。

String

Option.getLabel()
获取与该选项相关的标签。

String

HTMLDocument.RunElement.getName()
获取元素名称。

String

HTMLDocument.BlockElement.getName()
获取元素名称。

String

HTMLFrameHyperlinkEvent.getTarget()
返回链接的目标。

String

ImageView.getToolTipText(float x, float y, Shape allocation)
对于图像，工具提示文本来自于 ALT 属性指定的文本。

String

Option.getValue()
返回与 value 属性相关的字符串的便捷方法。

String

CSS.Attribute.toString()
属性的字符串表示形式。

String

HTML.Tag.toString()
返回该标记的字符串表示形式。

String

HTML.Attribute.toString()
返回此属性的字符串表示形式。

String

Option.toString()
String 的表示形式为 label。

参数类型为 String 的 javax.swing.text.html 中的方法

void

StyleSheet.addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value)
将 CSS 属性添加到给定的集合。

boolean

StyleSheet.addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value)
将 CSS 属性添加到给定的集合。

void

StyleSheet.addRule(String rule)
向 sheet 添加规则集合。

static CSS.Attribute

CSS.getAttribute(String name)
将字符串转换为 CSS.Attribute 对象。

static HTML.Attribute

HTML.getAttributeKey(String attName)
获取已知属性名称的属性常量（即集合 {FACE, COMMENT, SIZE, COLOR, CLEAR, BACKGROUND, BGCOLOR, TEXT, LINK, VLINK, ALINK, WIDTH, HEIGHT, ALIGN, NAME, HREF, REL, REV, TITLE, TARGET, SHAPE, COORDS, ISMAP, NOHREF, ALT, ID, SRC, HSPACE, VSPACE, USEMAP, LOWSRC, CODEBASE, CODE, ARCHIVE, VALUE, VALUETYPE, TYPE, CLASS, STYLE, LANG, DIR, DECLARE, CLASSID, DATA, CODETYPE, STANDBY, BORDER, SHAPES, NOSHADE, COMPACT, START, ACTION, METHOD, ENCTYPE, CHECKED, MAXLENGTH, MULTIPLE, SELECTED, ROWS, COLS, DUMMY, CELLSPACING, CELLPADDING, VALIGN, HALIGN, NOWRAP, ROWSPAN, COLSPAN, PROMPT, HTTPEQUIV, CONTENT, LANGUAGE, VERSION, N, FRAMEBORDER, MARGINWIDTH, MARGINHEIGHT, SCROLLING, NORESIZE, MEDIA, ENDTAG} 中的某个属性）。

AttributeSet

StyleSheet.getDeclaration(String decl)
将 CSS 声明转换为表示 CSS 声明的 AttributeSet。

Element

HTMLDocument.getElement(String id)
返回具有给定 id Attribute 的元素。

float

StyleSheet.getPointSize(String size)
如果给定字符串（如 "+2"、"-2" 或 "2"），则返回点大小值。

Style

StyleSheet.getRule(String selector)
获取最能匹配以字符串形式表示的选择器的规则。

static HTML.Tag

HTML.getTag(String tagName)
获取已知标记名称的标记常量（即集合 {A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOBR, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, S, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR} 中的某个标记）。

void

HTMLDocument.HTMLReader.handleEndOfLineString(String eol)
它的调用是在完成流的解析之后且在调用 flush 之前。

void

HTMLEditorKit.ParserCallback.handleEndOfLineString(String eol)
它的调用是在完成流的解析之后且在调用 flush 之前。

void

HTMLEditorKit.ParserCallback.handleError(String errorMsg, int pos)

protected  void

FormView.imageSubmit(String imageData)
调用此方法来提交表单，以响应在图像上的单击，此图像是类型为 "image" 的 <INPUT> 表单元素。

void

HTMLDocument.insertAfterEnd(Element elem, String htmlText)
将指定为字符串的 HTML 插入给定元素的起始处之后。

void

HTMLDocument.insertAfterStart(Element elem, String htmlText)
将指定为字符串的 HTML 插入元素的起始处。

protected  void

HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
当在边界上插入时调用。

protected  void

HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary

void

HTMLDocument.insertBeforeEnd(Element elem, String htmlText)
将指定为字符串的 HTML 插入元素的结尾处。

void

HTMLDocument.insertBeforeStart(Element elem, String htmlText)
将指定为字符串的 HTML 插入给定元素的起始处之前。

void

HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
将 HTML 插入现有文档。

protected  void

HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag)
HTMLEditorKit.insertHTML 的一个覆盖。

void

StyleSheet.removeStyle(String nm)
移除以前添加到该文档中的指定样式。

void

StyleSheet.setBaseFontSize(String size)
根据传入的 String 设置基本字体大小。

void

HTMLDocument.setInnerHTML(Element elem, String htmlText)
用指定为 HTML 字符串的内容替换给定元素的子元素。

void

Option.setLabel(String label)
设置该选项使用的标签。

void

HTMLDocument.setOuterHTML(Element elem, String htmlText)
用指定为 HTML 字符串的内容替换父元素中的给定元素。

protected  void

MinimalHTMLWriter.startFontTag(String style)
此方法已不再使用，而用写出 <span> 来替换。

Color

StyleSheet.stringToColor(String string)
将颜色字符串（如 "RED" 或 "#NNNNNN"）转换为 Color。

protected  void

FormView.submitData(String data)
此方法负责提交表单数据。

static FormSubmitEvent.MethodType

FormSubmitEvent.MethodType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

protected  void

MinimalHTMLWriter.writeEndTag(String endTag)
写出适当缩进的结束标记。

protected  void

MinimalHTMLWriter.writeStartTag(String tag)
写出适当缩进的开始标记。

参数类型为 String 的 javax.swing.text.html 中的构造方法

HTML.Tag(String id)
创建具有指定 id 的新 Tag，且 causesBreak 和 isBlock 设置为 false。

HTML.Tag(String id, boolean causesBreak, boolean isBlock)
创建具有指定 id 的新 Tag；causesBreak 和 isBlock 由用户定义。

HTML.UnknownTag(String id)
创建具有指定 id 的新 UnknownTag。

HTMLEditorKit.HTMLTextAction(String name)

HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag)

HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag, HTML.Tag alternateParentTag, HTML.Tag alternateAddTag)

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
创建一个表示 html 框架超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
创建一个表示超文本链接事件的新对象。

javax.swing.text.html.parser 中 String 的使用

声明为 String 的 javax.swing.text.html.parser 中的字段

String

AttributeList.name

String

DTD.name

String

Element.name

String

Entity.name

String

AttributeList.value

类型参数类型为 String 的 javax.swing.text.html.parser 中的字段

Hashtable<String,Element>

DTD.elementHash

返回 String 的 javax.swing.text.html.parser 中的方法

String

AttributeList.getName()

String

DTD.getName()
获取 DTD 的名称。

String

Element.getName()
获取元素的名称。

String

Entity.getName()
获取实体的名称。

String

Entity.getString()
返回以 String 表示的数据。

String

AttributeList.getValue()

String

Parser.parseDTDMarkup()
解析 Document Type Declaration 标记声明。

String

AttributeList.toString()

String

ContentModel.toString()
转换为字符串。

String

DTD.toString()
返回此 DTD 的字符串表示形式。

String

Element.toString()
转换为字符串。

static String

AttributeList.type2name(int tp)

参数类型为 String 的 javax.swing.text.html.parser 中的方法

protected static DTD

ParserDelegator.createDTD(DTD dtd, String name)

protected  AttributeList

DTD.defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts)
创建并返回一个 AttributeList。

protected  Element

DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
创建并返回一个 Element。

protected  Element

DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
创建并返回一个 Element。

protected  Element

DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
创建并返回一个 Element。

Entity

DTD.defEntity(String name, int type, int ch)
创建并返回一个字符 Entity。

protected  Entity

DTD.defEntity(String name, int type, String str)
创建并返回一个 Entity。

void

DTD.defineAttributes(String name, AttributeList atts)
定义 Element 的属性。

Element

DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
返回与指定参数匹配的 Element。

Entity

DTD.defineEntity(String name, int type, char[] data)
定义一个实体。

protected  void

Parser.error(String err)

protected  void

Parser.error(String err, String arg1)

protected  void

Parser.error(String err, String arg1, String arg2)

protected  void

Parser.error(String err, String arg1, String arg2, String arg3)
调用错误处理程序。

AttributeList

Element.getAttribute(String name)
按名称获取一个元素。

AttributeList

Element.getAttributeByValue(String name)
按值获取一个属性。

static DTD

DTD.getDTD(String name)
返回具有指定 name 的 DTD。

Element

DTD.getElement(String name)
按名称获取一个元素。

Entity

DTD.getEntity(String name)
按名称获取一个实体。

protected  void

DocumentParser.handleError(int ln, String errorMsg)

protected  void

Parser.handleError(int ln, String msg)
发生了一个错误。

static int

AttributeList.name2type(String nm)

static int

Element.name2type(String nm)

static int

Entity.name2type(String nm)
将 nm 字符串转换为相应的实体类型。

static void

DTD.putDTDHash(String name, DTD dtd)

参数类型为 String 的 javax.swing.text.html.parser 中的构造方法

AttributeList(String name)
创建一个属性列表元素。

AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
创建一个属性列表元素。

DTD(String name)
创建具有指定名称的新 DTD。

Entity(String name, int type, char[] data)
创建一个实体。

javax.swing.text.rtf 中 String 的使用

返回 String 的 javax.swing.text.rtf 中的方法

String

RTFEditorKit.getContentType()
获取此工具包支持的 MIME 类型的数据。

javax.swing.tree 中 String 的使用

声明为 String 的 javax.swing.tree 中的字段

static String

DefaultTreeSelectionModel.SELECTION_MODE_PROPERTY
selectionMode 的属性名称。

返回 String 的 javax.swing.tree 中的方法

String

DefaultMutableTreeNode.toString()
返回将 toString() 发送到此节点的用户对象的结果，如果此节点没有用户对象，则返回 null。

String

TreePath.toString()
返回一个显示并标识此对象属性的字符串。

String

DefaultTreeSelectionModel.toString()
返回显示并标识此对象属性的字符串。

参数类型为 String 的 javax.swing.tree 中的方法

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, byte oldValue, byte newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, char oldValue, char newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, double oldValue, double newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, float oldValue, float newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, int oldValue, int newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, long oldValue, long newValue)
因为性能原因而被重写。

protected  void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, short oldValue, short newValue)
因为性能原因而被重写。

参数类型为 String 的 javax.swing.tree 中的构造方法

ExpandVetoException(TreeExpansionEvent event, String message)
构造带指定消息的 ExpandVetoException 对象。

javax.swing.undo 中 String 的使用

声明为 String 的 javax.swing.undo 中的字段

protected static String

StateEdit.RCSID

static String

StateEditable.RCSID
此类的资源 ID。

protected static String

AbstractUndoableEdit.RedoName
由 getRedoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此段落。

protected static String

AbstractUndoableEdit.UndoName
由 getUndoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此字段。

protected  String

StateEdit.undoRedoName
撤消/恢复的表示名称

返回 String 的 javax.swing.undo 中的方法

String

StateEdit.getPresentationName()
获取此编辑的表示名称

String

CompoundEdit.getPresentationName()
从添加到 edits 的最后 UndoableEdit 返回 getPresentationName。

String

AbstractUndoableEdit.getPresentationName()
此默认实现返回 ""。

String

UndoableEdit.getPresentationName()
返回此编辑的本地化可读描述，例如，适于在更改日志中使用。

String

UndoManager.getRedoPresentationName()
返回此编辑可恢复形式的描述。

String

CompoundEdit.getRedoPresentationName()
从添加到 edits 的最后 UndoableEdit 返回 getRedoPresentationName。

String

AbstractUndoableEdit.getRedoPresentationName()
检索默认表中 AbstractUndoableEdit.redoText 键的值，并返回该值，后跟一个空格和 getPresentationName。

String

UndoableEdit.getRedoPresentationName()
返回此编辑可恢复形式的本地化可读描述，例如，适于用作 “Redo” 菜单项。

String

UndoManager.getUndoOrRedoPresentationName()
一个便捷方法，它返回 getUndoPresentationName 或 getRedoPresentationName。

String

UndoManager.getUndoPresentationName()
返回此编辑可撤消形式的描述。

String

CompoundEdit.getUndoPresentationName()
从添加到 edits 的最后 UndoableEdit 返回 getUndoPresentationName。

String

AbstractUndoableEdit.getUndoPresentationName()
检索默认表中 AbstractUndoableEdit.undoText 键的值，并返回该值，后跟一个空格和 getPresentationName。

String

UndoableEdit.getUndoPresentationName()
返回此编辑可撤消形式的本地化可读描述，例如，适于用作 “Undo” 菜单项。

String

UndoManager.toString()
返回显示和标识此对象属性的字符串。

String

UndoableEditSupport.toString()
返回显示和标识此对象属性的字符串。

String

CompoundEdit.toString()
返回一个显示并标识此对象属性的字符串。

String

AbstractUndoableEdit.toString()
返回显示和标识此对象属性的字符串。

参数类型为 String 的 javax.swing.undo 中的方法

protected  void

StateEdit.init(StateEditable anObject, String name)

参数类型为 String 的 javax.swing.undo 中的构造方法

StateEdit(StateEditable anObject, String name)
创建并返回具有表示名称的新 StateEdit。

javax.tools 中 String 的使用

声明为 String 的 javax.tools 中的字段

String

JavaFileObject.Kind.extension
通常用于此类文件对象的扩展名（按照约定）。

返回 String 的 javax.tools 中的方法

String

Diagnostic.getCode()
获取指示诊断类型的诊断代码。

String

Diagnostic.getMessage(Locale locale)
获取给定语言环境的本地化消息。

String

StandardLocation.getName()

String

FileObject.getName()
获取此文件对象的用户友好 (user-friendly) 的名称。

String

ForwardingFileObject.getName()

String

JavaFileManager.Location.getName()
获取此位置的名称。

String

SimpleJavaFileObject.getName()

String

ForwardingJavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)

String

JavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
根据位置推断文件对象的二进制名称。

String

SimpleJavaFileObject.toString()

参数类型为 String 的 javax.tools 中的方法

FileObject

ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)

FileObject

JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。

FileObject

ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)

FileObject

JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。

JavaFileObject

ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)

JavaFileObject

JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
获取输入的文件对象，它表示给定位置处指定类型的指定类。

JavaFileObject

ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)

JavaFileObject

JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
获取输出的文件对象，它表示给定位置处指定类型的指定类。

Iterable<? extends JavaFileObject>

StandardJavaFileManager.getJavaFileObjects(String... names)
获取表示给定文件名称的文件对象。

boolean

ForwardingJavaFileManager.handleOption(String current, Iterator<String> remaining)

boolean

JavaFileManager.handleOption(String current, Iterator<String> remaining)
处理一个选项。

boolean

ForwardingJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)

boolean

JavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
检查此文件对象是否与指定的简单名称和种类兼容。

boolean

SimpleJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
此实现对其 URI 路径和给定简单名称进行比较。

int

ForwardingJavaFileManager.isSupportedOption(String option)

int

OptionChecker.isSupportedOption(String option)
确定是否支持给定选项，如果支持，则返回该选项所使用的参数数量。

Iterable<JavaFileObject>

ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)

Iterable<JavaFileObject>

JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
列出给定位置处符合给定标准的所有文件对象。

static JavaFileManager.Location

StandardLocation.locationFor(String name)
使用给定名称获取位置对象。

int

Tool.run(InputStream in, OutputStream out, OutputStream err, String... arguments)
使用给定 I/O 通道和参数运行工具。

static StandardLocation

StandardLocation.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Diagnostic.Kind

Diagnostic.Kind.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static JavaFileObject.Kind

JavaFileObject.Kind.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

类型变量类型为 String 的 javax.tools 中的方法参数

Iterable<? extends JavaFileObject>

StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String> names)
获取表示给定文件名称的文件对象。

JavaCompiler.CompilationTask

JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。

JavaCompiler.CompilationTask

JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。

boolean

ForwardingJavaFileManager.handleOption(String current, Iterator<String> remaining)

boolean

JavaFileManager.handleOption(String current, Iterator<String> remaining)
处理一个选项。

javax.transaction 中 String 的使用

参数类型为 String 的 javax.transaction 中的构造方法

InvalidTransactionException(String msg)

TransactionRequiredException(String msg)

TransactionRolledbackException(String msg)

javax.transaction.xa 中 String 的使用

参数类型为 String 的 javax.transaction.xa 中的构造方法

XAException(String s)
创建一个具有给定字符串的 XAException。

javax.xml 中 String 的使用

声明为 String 的 javax.xml 中的字段

static String

XMLConstants.DEFAULT_NS_PREFIX
用于表示默认 XML 名称空间的前缀。

static String

XMLConstants.FEATURE_SECURE_PROCESSING
用于安全处理的功能。

static String

XMLConstants.NULL_NS_URI
用于表示不存在名称空间的名称空间 URI。

static String

XMLConstants.RELAXNG_NS_URI
RELAX NG Namespace URI. 被定义为 "http://relaxng.org/ns/structure/1.0"。

static String

XMLConstants.W3C_XML_SCHEMA_INSTANCE_NS_URI
W3C XML Schema Instance Namespace URI. 被定义为 "http://www.w3.org/2001/XMLSchema"。

static String

XMLConstants.W3C_XML_SCHEMA_NS_URI
W3C XML Schema Namespace URI. 被定义为 "http://www.w3.org/2001/XMLSchema"。

static String

XMLConstants.W3C_XPATH_DATATYPE_NS_URI
W3C XPath Datatype Namespace URI. 被定义为 "http://www.w3.org/2003/11/xpath-datatypes"。

static String

XMLConstants.XML_DTD_NS_URI
作为属性值的 XML 文档类型声明名称空间 URI。

static String

XMLConstants.XML_NS_PREFIX
正式的 XML 名称空间前缀。

static String

XMLConstants.XML_NS_URI
正式的 XML 名称空间名称 URI。

static String

XMLConstants.XMLNS_ATTRIBUTE
用于指定 XML 名称空间声明的正式 XML 属性。

static String

XMLConstants.XMLNS_ATTRIBUTE_NS_URI
用于指定 XML 名称空间声明、XMLConstants.XMLNS_ATTRIBUTE、名称空间名称 URI 的正式 XML 属性。

javax.xml.bind 中 String 的使用

声明为 String 的 javax.xml.bind 中的字段

static String

JAXBContext.JAXB_CONTEXT_FACTORY
属性名称，它包含能够创建新的 JAXBContext 对象的类名称。

static String

Marshaller.JAXB_ENCODING
用来指定已编组 XML 数据中输出编码的属性名称。

static String

Marshaller.JAXB_FORMATTED_OUTPUT
用来指定是否使用换行和缩排对已编组 XML 数据进行格式化的属性名称。

static String

Marshaller.JAXB_FRAGMENT
用来指定 marshaller 是否将生成文档级事件（即调用 startDocument 或 endDocument）的属性名称。

static String

Marshaller.JAXB_NO_NAMESPACE_SCHEMA_LOCATION
用来指定将放置在已编组 XML 输出中的 xsi:noNamespaceSchemaLocation 属性值的属性名称。

static String

Marshaller.JAXB_SCHEMA_LOCATION
用来指定将放置在已编组 XML 输出中的 xsi:schemaLocation 属性值的属性名称。

返回 String 的 javax.xml.bind 中的方法

String

JAXBException.getErrorCode()
获取特定于供应商的错误代码。

String

TypeConstraintException.getErrorCode()
获取特定于供应商的错误代码。

String

ValidationEvent.getMessage()
检索此警告/错误的文本消息。

static String

DatatypeConverter.parseAnySimpleType(String lexicalXSDAnySimpleType)
返回包含简单类型的词汇表示形式的字符串。

String

DatatypeConverterInterface.parseAnySimpleType(String lexicalXSDAnySimpleType)
返回包含简单类型的词汇表示形式的字符串。

static String

DatatypeConverter.parseString(String lexicalXSDString)
将词汇 XSD 字符串参数转换为一个 String 值。

String

DatatypeConverterInterface.parseString(String lexicalXSDString)
将字符串参数转换为一个字符串。

static String

DatatypeConverter.printAnySimpleType(String val)
将字符串值转换为一个字符串。

String

DatatypeConverterInterface.printAnySimpleType(String val)
将字符串值转换为一个字符串。

static String

DatatypeConverter.printBase64Binary(byte[] val)
将字节数组转换为一个字符串。

String

DatatypeConverterInterface.printBase64Binary(byte[] val)
将字节数组转换为一个字符串。

static String

DatatypeConverter.printBoolean(boolean val)
将 boolean 值转换为一个字符串。

String

DatatypeConverterInterface.printBoolean(boolean val)
将 boolean 值转换为一个字符串。

static String

DatatypeConverter.printByte(byte val)
将 byte 值转换为一个字符串。

String

DatatypeConverterInterface.printByte(byte val)
将 byte 值转换为一个字符串。

static String

DatatypeConverter.printDate(Calendar val)
将 Calendar 值转换为一个字符串。

String

DatatypeConverterInterface.printDate(Calendar val)
将 Calendar 值转换为一个字符串。

static String

DatatypeConverter.printDateTime(Calendar val)
将 Calendar 值转换为一个字符串。

String

DatatypeConverterInterface.printDateTime(Calendar val)
将 Calendar 值转换为一个字符串。

static String

DatatypeConverter.printDecimal(BigDecimal val)
将 BigDecimal 值转换为一个字符串。

String

DatatypeConverterInterface.printDecimal(BigDecimal val)
将 BigDecimal 值转换为一个字符串。

static String

DatatypeConverter.printDouble(double val)
将 double 值转换为一个字符串。

String

DatatypeConverterInterface.printDouble(double val)
将 double 值转换为一个字符串。

static String

DatatypeConverter.printFloat(float val)
将 float 值转换为一个字符串。

String

DatatypeConverterInterface.printFloat(float val)
将 float 值转换为一个字符串。

static String

DatatypeConverter.printHexBinary(byte[] val)
将字节数组转换为一个字符串。

String

DatatypeConverterInterface.printHexBinary(byte[] val)
将字节数组转换为一个字符串。

static String

DatatypeConverter.printInt(int val)
将 int 值转换为一个字符串。

String

DatatypeConverterInterface.printInt(int val)
将 int 值转换为一个字符串。

static String

DatatypeConverter.printInteger(BigInteger val)
将 BigInteger 值转换为一个字符串。

String

DatatypeConverterInterface.printInteger(BigInteger val)
将 BigInteger 值转换为一个字符串。

static String

DatatypeConverter.printLong(long val)
将 long 值转换为一个字符串。

String

DatatypeConverterInterface.printLong(long val)
将 long 值转换为一个字符串。

static String

DatatypeConverter.printQName(QName val, NamespaceContext nsc)
将 QName 实例转换为一个字符串。

String

DatatypeConverterInterface.printQName(QName val, NamespaceContext nsc)
将 QName 实例转换为一个字符串。

static String

DatatypeConverter.printShort(short val)
将 short 值转换为一个字符串。

String

DatatypeConverterInterface.printShort(short val)
将 short 值转换为一个字符串。

static String

DatatypeConverter.printString(String val)
将字符串参数转换为一个字符串。

String

DatatypeConverterInterface.printString(String val)
将字符串参数转换为一个字符串。

static String

DatatypeConverter.printTime(Calendar val)
将 Calendar 值转换为一个字符串。

String

DatatypeConverterInterface.printTime(Calendar val)
将 Calendar 值转换为一个字符串。

static String

DatatypeConverter.printUnsignedInt(long val)
将 long 值转换为一个字符串。

String

DatatypeConverterInterface.printUnsignedInt(long val)
将 long 值转换为一个字符串。

static String

DatatypeConverter.printUnsignedShort(int val)
将 int 值转换为一个字符串。

String

DatatypeConverterInterface.printUnsignedShort(int val)
将 int 值转换为一个字符串。

String

JAXBException.toString()
返回此 JAXBException 的简短描述。

String

TypeConstraintException.toString()
返回此 TypeConstraintException 的简短描述。

参数类型为 String 的 javax.xml.bind 中的方法

abstract  Result

SchemaOutputResolver.createOutput(String namespaceUri, String suggestedFileName)
确定写入模式文件（由给定名称空间 URI 指定）的位置，并以 Result 对象的形式返回它。

abstract  Object

Binder.getProperty(String name)
获取 Binder 的基础实现中的特定属性。

Object

Marshaller.getProperty(String name)
获取 Marshaller 底层实现中的特定属性。

Object

Unmarshaller.getProperty(String name)
获取 Unmarshaller 底层实现中的特定属性。

Object

Validator.getProperty(String name)
已过时。 从 JAXB2.0 开始

static JAXBContext

JAXBContext.newInstance(String contextPath)
获得 JAXBContext 类的新实例。

static JAXBContext

JAXBContext.newInstance(String contextPath, ClassLoader classLoader)
获得 JAXBContext 类的新实例。

static JAXBContext

JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
获得 JAXBContext 类的新实例。

static String

DatatypeConverter.parseAnySimpleType(String lexicalXSDAnySimpleType)
返回包含简单类型的词汇表示形式的字符串。

String

DatatypeConverterInterface.parseAnySimpleType(String lexicalXSDAnySimpleType)
返回包含简单类型的词汇表示形式的字符串。

static byte[]

DatatypeConverter.parseBase64Binary(String lexicalXSDBase64Binary)
将字符串参数转换为一个字节数组。

byte[]

DatatypeConverterInterface.parseBase64Binary(String lexicalXSDBase64Binary)
将字符串参数转换为一个字节数组。

static boolean

DatatypeConverter.parseBoolean(String lexicalXSDBoolean)
将字符串参数转换为一个 boolean 值。

boolean

DatatypeConverterInterface.parseBoolean(String lexicalXSDBoolean)
将字符串参数转换为一个 boolean 值。

static byte

DatatypeConverter.parseByte(String lexicalXSDByte)
将字符串参数转换为一个 byte 值。

byte

DatatypeConverterInterface.parseByte(String lexicalXSDByte)
将字符串参数转换为一个 byte 值。

static Calendar

DatatypeConverter.parseDate(String lexicalXSDDate)
将字符串参数转换为一个 Calendar 值。

Calendar

DatatypeConverterInterface.parseDate(String lexicalXSDDate)
将字符串参数转换为一个 Calendar 值。

static Calendar

DatatypeConverter.parseDateTime(String lexicalXSDDateTime)
将字符串参数转换为一个 Calendar 值。

Calendar

DatatypeConverterInterface.parseDateTime(String lexicalXSDDateTime)
将字符串参数转换为一个 Calendar 值。

static BigDecimal

DatatypeConverter.parseDecimal(String lexicalXSDDecimal)
将字符串参数转换为一个 BigDecimal 值。

BigDecimal

DatatypeConverterInterface.parseDecimal(String lexicalXSDDecimal)
将字符串参数转换为一个 BigDecimal 值。

static double

DatatypeConverter.parseDouble(String lexicalXSDDouble)
将字符串参数转换为一个 double 值。

double

DatatypeConverterInterface.parseDouble(String lexicalXSDDouble)
将字符串参数转换为一个 double 值。

static float

DatatypeConverter.parseFloat(String lexicalXSDFloat)
将字符串参数转换为一个 float 值。

float

DatatypeConverterInterface.parseFloat(String lexicalXSDFloat)
将字符串参数转换为一个 float 值。

static byte[]

DatatypeConverter.parseHexBinary(String lexicalXSDHexBinary)
将字符串参数转换为一个字节数组。

byte[]

DatatypeConverterInterface.parseHexBinary(String lexicalXSDHexBinary)
将字符串参数转换为一个字节数组。

static int

DatatypeConverter.parseInt(String lexicalXSDInt)
将字符串参数转换为一个 int 值。

int

DatatypeConverterInterface.parseInt(String lexicalXSDInt)
将字符串参数转换为一个 int 值。

static BigInteger

DatatypeConverter.parseInteger(String lexicalXSDInteger)
将字符串参数转换为一个 BigInteger 值。

BigInteger

DatatypeConverterInterface.parseInteger(String lexicalXSDInteger)
将字符串参数转换为一个 BigInteger 值。

static long

DatatypeConverter.parseLong(String lexicalXSDLong)
将字符串参数转换为一个 long 值。

long

DatatypeConverterInterface.parseLong(String lexicalXSDLong)
将字符串参数转换为一个 long 值。

static QName

DatatypeConverter.parseQName(String lexicalXSDQName, NamespaceContext nsc)
将字符串参数转换为一个 byte 值。

QName

DatatypeConverterInterface.parseQName(String lexicalXSDQName, NamespaceContext nsc)
将字符串参数转换为一个 QName 值。

static short

DatatypeConverter.parseShort(String lexicalXSDShort)
将字符串参数转换为一个 short 值。

short

DatatypeConverterInterface.parseShort(String lexicalXSDShort)
将字符串参数转换为一个 short 值。

static String

DatatypeConverter.parseString(String lexicalXSDString)
将词汇 XSD 字符串参数转换为一个 String 值。

String

DatatypeConverterInterface.parseString(String lexicalXSDString)
将字符串参数转换为一个字符串。

static Calendar

DatatypeConverter.parseTime(String lexicalXSDTime)
将字符串参数转换为一个 Calendar 值。

Calendar

DatatypeConverterInterface.parseTime(String lexicalXSDTime)
将字符串参数转换为一个 Calendar 值。

static long

DatatypeConverter.parseUnsignedInt(String lexicalXSDUnsignedInt)
将字符串参数转换为一个 long 值。

long

DatatypeConverterInterface.parseUnsignedInt(String lexicalXSDUnsignedInt)
将字符串参数转换为一个 long 值。

static int

DatatypeConverter.parseUnsignedShort(String lexicalXSDUnsignedShort)
将字符串参数转换为一个 int 值。

int

DatatypeConverterInterface.parseUnsignedShort(String lexicalXSDUnsignedShort)
将字符串参数转换为一个 int 值。

static String

DatatypeConverter.printAnySimpleType(String val)
将字符串值转换为一个字符串。

String

DatatypeConverterInterface.printAnySimpleType(String val)
将字符串值转换为一个字符串。

static String

DatatypeConverter.printString(String val)
将字符串参数转换为一个字符串。

String

DatatypeConverterInterface.printString(String val)
将字符串参数转换为一个字符串。

abstract  void

Binder.setProperty(String name, Object value)
设置 Binder 的基础实现中的特定属性。

void

Marshaller.setProperty(String name, Object value)
设置 Marshaller 底层实现中的特定属性。

void

Unmarshaller.setProperty(String name, Object value)
设置 Unmarshaller 底层实现中的特定属性。

void

Validator.setProperty(String name, Object value)
已过时。 从 JAXB2.0 开始

类型变量类型为 String 的 javax.xml.bind 中的方法参数

static JAXBContext

JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties)
获得 JAXBContext 类的新实例。

static JAXBContext

JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
获得 JAXBContext 类的新实例。

参数类型为 String 的 javax.xml.bind 中的构造方法

JAXBException(String message)
构造带指定详细消息的 JAXBException。

JAXBException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 JAXBException。

JAXBException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 JAXBException。

JAXBException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 JAXBException。

MarshalException(String message)
构造带指定详细消息的 MarshalException。

MarshalException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 MarshalException。

MarshalException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 MarshalException。

MarshalException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 MarshalException。

PropertyException(String message)
构造带指定详细消息的 PropertyException。

PropertyException(String name, Object value)
构造一个基于属性名称和 value.toString() 设置其消息字段的 PropertyException。

PropertyException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 PropertyException。

PropertyException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 PropertyException。

PropertyException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 PropertyException。

TypeConstraintException(String message)
构造带指定详细消息的 TypeConstraintException。

TypeConstraintException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 TypeConstraintException。

TypeConstraintException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 TypeConstraintException。

TypeConstraintException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 TypeConstraintException。

UnmarshalException(String message)
构造带指定详细消息的 UnmarshalException。

UnmarshalException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 UnmarshalException。

UnmarshalException(String message, String errorCode, Throwable exception)
构造带指定详细消息、特定于供应商的 errorCode 和 linkedException 的 UnmarshalException。

UnmarshalException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 UnmarshalException。

ValidationException(String message)
构造带指定详细消息的 ValidationException。

ValidationException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 ValidationException。

ValidationException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 ValidationException。

ValidationException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 ValidationException。

javax.xml.bind.annotation 中 String 的使用

参数类型为 String 的 javax.xml.bind.annotation 中的方法

static XmlAccessOrder

XmlAccessOrder.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static XmlAccessType

XmlAccessType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static XmlNsForm

XmlNsForm.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.xml.bind.annotation.adapters 中 String 的使用

返回 String 的 javax.xml.bind.annotation.adapters 中的方法

String

HexBinaryAdapter.marshal(byte[] bytes)

String

CollapsedStringAdapter.marshal(String s)
无任何操作。

String

NormalizedStringAdapter.marshal(String s)
无任何操作。

String

CollapsedStringAdapter.unmarshal(String text)
移除作为参数提供的字符串的前导空白和尾部空白，然后用单个空白字符“ ”截断任何制表符、CR、LF 和 SP 序列。

String

NormalizedStringAdapter.unmarshal(String text)
移除作为参数给定的字符串的前导空白和尾部空白，然后用单个空白字符“ ”替换所有制表符、CR 和 LF。

参数类型为 String 的 javax.xml.bind.annotation.adapters 中的方法

String

CollapsedStringAdapter.marshal(String s)
无任何操作。

String

NormalizedStringAdapter.marshal(String s)
无任何操作。

String

CollapsedStringAdapter.unmarshal(String text)
移除作为参数提供的字符串的前导空白和尾部空白，然后用单个空白字符“ ”截断任何制表符、CR、LF 和 SP 序列。

byte[]

HexBinaryAdapter.unmarshal(String s)

String

NormalizedStringAdapter.unmarshal(String text)
移除作为参数给定的字符串的前导空白和尾部空白，然后用单个空白字符“ ”替换所有制表符、CR 和 LF。

javax.xml.bind.attachment 中 String 的使用

返回 String 的 javax.xml.bind.attachment 中的方法

abstract  String

AttachmentMarshaller.addMtomAttachment(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName)
将用于优化二进制存储的二进制 data 作为附件。

abstract  String

AttachmentMarshaller.addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName)
将用于优化二进制存储的 MIME 内容 data 作为附件。

abstract  String

AttachmentMarshaller.addSwaRefAttachment(DataHandler data)
将 MIME data 作为附件添加，并返回附件的内容 id（即 cid）。

参数类型为 String 的 javax.xml.bind.attachment 中的方法

abstract  String

AttachmentMarshaller.addMtomAttachment(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName)
将用于优化二进制存储的二进制 data 作为附件。

abstract  String

AttachmentMarshaller.addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName)
将用于优化二进制存储的 MIME 内容 data 作为附件。

abstract  byte[]

AttachmentUnmarshaller.getAttachmentAsByteArray(String cid)
以 byte[] 形式检索由内容 id（即 cid）标识的附件。

abstract  DataHandler

AttachmentUnmarshaller.getAttachmentAsDataHandler(String cid)
通过内容 id（即 cid）查找 MIME 内容，并作为 DataHandler 返回。

javax.xml.bind.helpers 中 String 的使用

返回 String 的 javax.xml.bind.helpers 中的方法

protected  String

AbstractMarshallerImpl.getEncoding()
获取当前输出编码的便捷方法。

protected  String

AbstractMarshallerImpl.getJavaEncoding(String encoding)
从 IANA 名称获取相应的 Java 编码名称。

String

ValidationEventImpl.getMessage()

protected  String

AbstractMarshallerImpl.getNoNSSchemaLocation()
获取当前 noNamespaceSchemaLocation 的便捷方法。

protected  String

AbstractMarshallerImpl.getSchemaLocation()
获取当前 schemaLocation 的便捷方法。

String

ValidationEventImpl.toString()
以有助于调试的格式返回此对象的字符串表示形式。

String

ValidationEventLocatorImpl.toString()
以有助于调试的格式返回此对象的字符串表示形式。

参数类型为 String 的 javax.xml.bind.helpers 中的方法

protected  String

AbstractMarshallerImpl.getJavaEncoding(String encoding)
从 IANA 名称获取相应的 Java 编码名称。

Object

AbstractMarshallerImpl.getProperty(String name)
getProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。

Object

AbstractUnmarshallerImpl.getProperty(String name)
由于没有必需的属性，getProperty 方法的默认实现总是抛出 PropertyException。

protected  void

AbstractMarshallerImpl.setEncoding(String encoding)
设置输出编码的便捷方法。

void

ValidationEventImpl.setMessage(String _message)
设置此事件的 message 字段。

protected  void

AbstractMarshallerImpl.setNoNSSchemaLocation(String location)
设置 noNamespaceSchemaLocation 的便捷方法。

void

AbstractMarshallerImpl.setProperty(String name, Object value)
setProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。

void

AbstractUnmarshallerImpl.setProperty(String name, Object value)
由于没有必需的属性，setProperty 方法的默认实现总是抛出 PropertyException。

protected  void

AbstractMarshallerImpl.setSchemaLocation(String location)
设置 schemaLocation 的便捷方法。

参数类型为 String 的 javax.xml.bind.helpers 中的构造方法

NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 NotIdentifiableEventImpl。

NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 NotIdentifiableEventImpl。

ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 ParseConversionEventImpl。

ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ParseConversionEventImpl。

PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 PrintConversionEventImpl。

PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 PrintConversionEventImpl。

ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 ValidationEventImpl。

ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ValidationEventImpl。

javax.xml.crypto 中 String 的使用

返回 String 的 javax.xml.crypto 中的方法

String

AlgorithmMethod.getAlgorithm()
返回此 AlgorithmMethod 的算法 URI。

String

XMLCryptoContext.getBaseURI()
返回基本 URI。

String

XMLCryptoContext.getDefaultNamespacePrefix()
返回默认名称空间前缀。

String

OctetStreamData.getMimeType()
返回与由此 OctetStreamData 表示的数据对象关联的 MIME 类型。

String

XMLCryptoContext.getNamespacePrefix(String namespaceURI, String defaultPrefix)
返回与指定的名称空间 URI 关联的名称空间前缀。

String

URIReference.getType()
返回通过此 URI 引用的数据类型。

String

OctetStreamData.getURI()
返回用来标识由此 OctetStreamData 表示的数据对象的 URI String。

String

URIReference.getURI()
返回所引用数据对象的 URI。

String

XMLCryptoContext.putNamespacePrefix(String namespaceURI, String prefix)
将指定的名称空间 URI 映射到指定的前缀。

String

KeySelector.Purpose.toString()
返回此用途的字符串表示形式（“sign”、“verify”、“encrypt”或“decrypt”）。

参数类型为 String 的 javax.xml.crypto 中的方法

String

XMLCryptoContext.getNamespacePrefix(String namespaceURI, String defaultPrefix)
返回与指定的名称空间 URI 关联的名称空间前缀。

Object

XMLCryptoContext.getProperty(String name)
返回指定属性的值。

boolean

XMLStructure.isFeatureSupported(String feature)
指示是否支持指定的功能。

String

XMLCryptoContext.putNamespacePrefix(String namespaceURI, String prefix)
将指定的名称空间 URI 映射到指定的前缀。

void

XMLCryptoContext.setBaseURI(String baseURI)
设置基本 URI。

void

XMLCryptoContext.setDefaultNamespacePrefix(String defaultPrefix)
设置默认的名称空间前缀。

Object

XMLCryptoContext.setProperty(String name, Object value)
设置指定的属性。

参数类型为 String 的 javax.xml.crypto 中的构造方法

KeySelectorException(String message)
构造带指定详细信息的新 KeySelectorException。

KeySelectorException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 KeySelectorException。

MarshalException(String message)
构造带指定详细消息的新 MarshalException。

MarshalException(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 MarshalException。

NoSuchMechanismException(String message)
构造带指定详细消息的新 NoSuchMechanismException。

NoSuchMechanismException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 NoSuchMechanismException。

OctetStreamData(InputStream octetStream, String uri, String mimeType)
创建新的 OctetStreamData。

URIReferenceException(String message)
构造带指定详细消息的新 URIReferenceException。

URIReferenceException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 URIReferenceException。

URIReferenceException(String message, Throwable cause, URIReference uriReference)
构造带指定详细消息、cause 和 URIReference 的新 URIReferenceException。

javax.xml.crypto.dom 中 String 的使用

返回 String 的 javax.xml.crypto.dom 中的方法

String

DOMCryptoContext.getBaseURI()

String

DOMCryptoContext.getDefaultNamespacePrefix()

String

DOMCryptoContext.getNamespacePrefix(String namespaceURI, String defaultPrefix)
此实现使用内部 HashMap 来获取指定 URI 所映射的前缀。

String

DOMCryptoContext.putNamespacePrefix(String namespaceURI, String prefix)
此实现使用内部 HashMap 将 URI 映射到指定的前缀。

参数类型为 String 的 javax.xml.crypto.dom 中的方法

Element

DOMCryptoContext.getElementById(String idValue)
返回具有指定 ID 属性值的 Element。

String

DOMCryptoContext.getNamespacePrefix(String namespaceURI, String defaultPrefix)
此实现使用内部 HashMap 来获取指定 URI 所映射的前缀。

Object

DOMCryptoContext.getProperty(String name)
此实现使用内部 HashMap 获取指定名称所映射的对象。

boolean

DOMStructure.isFeatureSupported(String feature)

String

DOMCryptoContext.putNamespacePrefix(String namespaceURI, String prefix)
此实现使用内部 HashMap 将 URI 映射到指定的前缀。

void

DOMCryptoContext.setBaseURI(String baseURI)

void

DOMCryptoContext.setDefaultNamespacePrefix(String defaultPrefix)

void

DOMCryptoContext.setIdAttributeNS(Element element, String namespaceURI, String localName)
将名称空间 URI 和本地名称指定的元素属性注册为类型 ID。

Object

DOMCryptoContext.setProperty(String name, Object value)
此实现使用内部 HashMap 将名称映射到指定对象。

javax.xml.crypto.dsig 中 String 的使用

声明为 String 的 javax.xml.crypto.dsig 中的字段

static String

Transform.BASE64
Base64 转换算法 URI。

static String

SignatureMethod.DSA_SHA1
DSAwithSHA1 (DSS) 签名方法的算法 URI。

static String

Transform.ENVELOPED
Enveloped Signature 转换算法 URI。

static String

CanonicalizationMethod.EXCLUSIVE
Exclusive Canonical XML（不带注释）规范化方法的算法 URI。

static String

CanonicalizationMethod.EXCLUSIVE_WITH_COMMENTS
带注释的 Exclusive Canonical XML 规范化方法的算法 URI。

static String

SignatureMethod.HMAC_SHA1
HMAC-SHA1 MAC 签名方法的算法 URI。

static String

CanonicalizationMethod.INCLUSIVE
Canonical XML（不带注释）的规范化方法的算法 URI。

static String

CanonicalizationMethod.INCLUSIVE_WITH_COMMENTS
带注释的 Canonical XML 的规范化方法的算法 URI。

static String

DigestMethod.RIPEMD160
RIPEMD-160 摘要方法的算法 URI。

static String

SignatureMethod.RSA_SHA1
RSAwithSHA1 (PKCS #1) 签名方法的算法 URI。

static String

DigestMethod.SHA1
SHA1 摘要方法的算法 URI。

static String

DigestMethod.SHA256
SHA256 摘要方法的算法 URI。

static String

DigestMethod.SHA512
SHA512 摘要方法的算法 URI。

static String

Manifest.TYPE
标识 Manifest 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。

static String

SignatureProperties.TYPE
标识 SignatureProperties 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。

static String

XMLObject.TYPE
标识 Object 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。

static String

XMLSignature.XMLNS
W3C Recommendation for XML-Signature Syntax and Processing 的 XML 名称空间 URI。

static String

Transform.XPATH
XPath 转换算法 URI。

static String

Transform.XPATH2
XPath Filter 2 转换算法 URI。

static String

Transform.XSLT
XSLT 转换算法 URI。

返回 String 的 javax.xml.crypto.dsig 中的方法

String

TransformService.getAlgorithm()
返回此 TransformService 支持的算法 URI。

String

XMLObject.getEncoding()
返回此 XMLObject 的编码 URI。

String

Manifest.getId()
返回此 Manifest 的 Id。

String

Reference.getId()
返回此 Reference 的可选 Id 属性，该属性允许从其他地方引用此 Reference。

String

SignatureProperties.getId()
返回此 SignatureProperties 的 Id。

String

SignatureProperty.getId()
返回此 SignatureProperty 的 Id。

String

SignedInfo.getId()
返回此 SignedInfo 的可选 Id 属性。

String

XMLObject.getId()
返回此 XMLObject 的 Id。

String

XMLSignature.getId()
返回此 XMLSignature 的可选 Id。

String

XMLSignature.SignatureValue.getId()
返回此 SignatureValue 的可选 Id 属性，该属性允许从其他地方引用此元素。

String

TransformService.getMechanismType()
返回此 TransformService 支持的机制类型。

String

XMLSignatureFactory.getMechanismType()
返回此 XMLSignatureFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。

String

XMLObject.getMimeType()
返回此 XMLObject 的 MIME 类型。

String

SignatureProperty.getTarget()
返回此 SignatureProperty 的目标 URI。

参数类型为 String 的 javax.xml.crypto.dsig 中的方法

static XMLSignatureFactory

XMLSignatureFactory.getInstance(String mechanismType)
返回 XMLSignatureFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。

static XMLSignatureFactory

XMLSignatureFactory.getInstance(String mechanismType, Provider provider)
返回支持请求的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。

static TransformService

TransformService.getInstance(String algorithm, String mechanismType)
返回支持指定算法 URI 的 TransformService（比如：Transform.XPATH2）和机制类型（比如：DOM）。

static XMLSignatureFactory

XMLSignatureFactory.getInstance(String mechanismType, String provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。

static TransformService

TransformService.getInstance(String algorithm, String mechanismType, Provider provider)
返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。

static TransformService

TransformService.getInstance(String algorithm, String mechanismType, String provider)
返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。

abstract  boolean

XMLSignatureFactory.isFeatureSupported(String feature)
指示是否支持指定的功能。

abstract  CanonicalizationMethod

XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params)
针对指定的算法 URI 和参数创建 CanonicalizationMethod。

abstract  CanonicalizationMethod

XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params)
针对指定的算法 URI 和参数创建 CanonicalizationMethod。

abstract  DigestMethod

XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params)
针对指定的算法 URI 和参数创建 DigestMethod。

abstract  Manifest

XMLSignatureFactory.newManifest(List references, String id)
创建包含指定的 Reference 列表和可选 id 的 Manifest。

abstract  Reference

XMLSignatureFactory.newReference(String uri, DigestMethod dm)
创建带指定 URI 和摘要方法的 Reference。

abstract  Reference

XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id)
创建带指定参数的 Reference。

abstract  Reference

XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id)
创建带指定参数的 Reference。

abstract  Reference

XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue)
创建带指定参数和预计算的摘要值的 Reference。

abstract  SignatureMethod

XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params)
针对指定的算法 URI 和参数创建 SignatureMethod。

abstract  SignatureProperties

XMLSignatureFactory.newSignatureProperties(List properties, String id)
创建包含指定的 SignatureProperty 列表和可选 id 的 SignatureProperties。

abstract  SignatureProperty

XMLSignatureFactory.newSignatureProperty(List content, String target, String id)
创建包含指定的 XMLStructure 列表、目标 URI 和可选 id 的SignatureProperty。

abstract  SignedInfo

XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id)
创建带指定参数的 SignedInfo。

abstract  Transform

XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params)
针对指定的算法 URI 和参数创建 Transform。

abstract  Transform

XMLSignatureFactory.newTransform(String algorithm, XMLStructure params)
针对指定的算法 URI 和参数创建 Transform。

abstract  XMLObject

XMLSignatureFactory.newXMLObject(List content, String id, String mimeType, String encoding)
根据指定参数创建 XMLObject。

abstract  XMLSignature

XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId)
创建一个 XMLSignature，并使用指定的参数对其进行初始化。

参数类型为 String 的 javax.xml.crypto.dsig 中的构造方法

TransformException(String message)
构造带有指定详细消息的新 TransformException。

TransformException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 TransformException。

XMLSignatureException(String message)
构造带指定详细消息的新 XMLSignatureException。

XMLSignatureException(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 XMLSignatureException。

javax.xml.crypto.dsig.keyinfo 中 String 的使用

声明为 String 的 javax.xml.crypto.dsig.keyinfo 中的字段

static String

KeyValue.DSA_TYPE
标识 DSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#DSAKeyValue。

static String

X509Data.RAW_X509_CERTIFICATE_TYPE
标识二进制 (ASN.1 DER) X.509 Certificate KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#rawX509Certificate。

static String

KeyValue.RSA_TYPE
标识 RSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#RSAKeyValue。

static String

PGPData.TYPE
标识 PGPData KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#PGPData.可以将其指定为 RetrievalMethod 类的 type 参数值，以描述远程 PGPData 结构。

static String

X509Data.TYPE
标识 X509Data KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#X509Data。

返回 String 的 javax.xml.crypto.dsig.keyinfo 中的方法

String

KeyInfo.getId()
返回此 KeyInfo 的可选 Id 属性，这对于从其他 XML 结构引用此 KeyInfo 可能很有用。

String

X509IssuerSerial.getIssuerName()
返回 RFC 2253 String 格式的此 X509IssuerSerial 的 X.500 标识名。

String

KeyInfoFactory.getMechanismType()
返回此 KeyInfoFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。

String

KeyName.getName()
返回此 KeyName 的名称。

String

RetrievalMethod.getURI()
返回已引用的 KeyInfo 信息的 URI。

参数类型为 String 的 javax.xml.crypto.dsig.keyinfo 中的方法

static KeyInfoFactory

KeyInfoFactory.getInstance(String mechanismType)
返回 KeyInfoFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。

static KeyInfoFactory

KeyInfoFactory.getInstance(String mechanismType, Provider provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。

static KeyInfoFactory

KeyInfoFactory.getInstance(String mechanismType, String provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。

abstract  boolean

KeyInfoFactory.isFeatureSupported(String feature)
指示是否支持指定的功能。

abstract  KeyInfo

KeyInfoFactory.newKeyInfo(List content, String id)
创建包含指定的密钥信息类型列表和可选 id 的 KeyInfo。

abstract  KeyName

KeyInfoFactory.newKeyName(String name)
根据指定的名称创建 KeyName。

abstract  RetrievalMethod

KeyInfoFactory.newRetrievalMethod(String uri)
根据指定的 URI 创建 RetrievalMethod。

abstract  RetrievalMethod

KeyInfoFactory.newRetrievalMethod(String uri, String type, List transforms)
根据指定的参数创建 RetrievalMethod。

abstract  X509IssuerSerial

KeyInfoFactory.newX509IssuerSerial(String issuerName, BigInteger serialNumber)
根据指定的 X.500 发布方标识名和序列号创建 X509IssuerSerial。

javax.xml.crypto.dsig.spec 中 String 的使用

声明为 String 的 javax.xml.crypto.dsig.spec 中的字段

static String

ExcC14NParameterSpec.DEFAULT
指示默认名称空间（“#default”）。

返回 String 的 javax.xml.crypto.dsig.spec 中的方法

String

XPathType.getExpression()
返回要计算的 XPath 表达式。

String

XPathFilterParameterSpec.getXPath()
返回要计算的 XPath 表达式。

String

XPathType.Filter.toString()
返回操作的字符串形式。

参数类型为 String 的 javax.xml.crypto.dsig.spec 中的构造方法

XPathFilterParameterSpec(String xPath)
创建带有指定 XPath 表达式的 XPathFilterParameterSpec。

XPathFilterParameterSpec(String xPath, Map namespaceMap)
创建带有指定 XPath 表达式和名称空间映射表的 XPathFilterParameterSpec。

XPathType(String expression, XPathType.Filter filter)
创建带有指定 XPath 表达式和过滤器的 XPathType 实例。

XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
创建带有指定 XPath 表达式、过滤器和名称空间映射表的 XPathType 实例。

javax.xml.datatype 中 String 的使用

声明为 String 的 javax.xml.datatype 中的字段

static String

DatatypeFactory.DATATYPEFACTORY_IMPLEMENTATION_CLASS
JSR 206: Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。

static String

DatatypeFactory.DATATYPEFACTORY_PROPERTY
JSR 206:Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。

返回 String 的 javax.xml.datatype 中的方法

String

DatatypeConstants.Field.toString()
以英文返回字段名称。

String

Duration.toString()
返回此 Duration Object 的 String 表示形式。

String

XMLGregorianCalendar.toString()
返回此 XMLGregorianCalendar Object 的 String 表示形式。

abstract  String

XMLGregorianCalendar.toXMLFormat()
返回 this 实例的词汇表示形式。

参数类型为 String 的 javax.xml.datatype 中的方法

abstract  Duration

DatatypeFactory.newDuration(String lexicalRepresentation)
获取新的 Duration 实例，它根据 XML 模式 1.0 第 3.2.6.1 节中的定义将 Duration 指定为其字符串表示形式 "PnYnMnDTnHnMnS"。

Duration

DatatypeFactory.newDurationDayTime(String lexicalRepresentation)
通过解析其 String 表示形式 "PnDTnHnMnS"（XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration）创建类型为 xdt:dayTimeDuration 的 Duration。

Duration

DatatypeFactory.newDurationYearMonth(String lexicalRepresentation)
通过解析其 String 表示形式 "PnYnM"（XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration）创建类型为 xdt:yearMonthDuration 的 Duration。

static DatatypeFactory

DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader)
从类名称中获取新的 DatatypeFactory 实例。

abstract  XMLGregorianCalendar

DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation)
通过将字符串解析为词汇表示形式，创建新的 XMLGregorianCalendar。

参数类型为 String 的 javax.xml.datatype 中的构造方法

DatatypeConfigurationException(String message)
创建带指定详细消息的新 DatatypeConfigurationException。

DatatypeConfigurationException(String message, Throwable cause)
创建带有指定详细消息和原因的新 DatatypeConfigurationException。

javax.xml.namespace 中 String 的使用

返回 String 的 javax.xml.namespace 中的方法

String

QName.getLocalPart()
获取此 QName 的本地部分。

String

QName.getNamespaceURI()
获取此 QName 的名称空间 URI。

String

NamespaceContext.getNamespaceURI(String prefix)
获取绑定到当前范围中的前缀的名称空间 URI。

String

QName.getPrefix()
获取此 QName 的前缀。

String

NamespaceContext.getPrefix(String namespaceURI)
获取绑定到当前范围中名称空间 URI 的前缀。

String

QName.toString()
此 QName 的 String 表示形式。

参数类型为 String 的 javax.xml.namespace 中的方法

String

NamespaceContext.getNamespaceURI(String prefix)
获取绑定到当前范围中的前缀的名称空间 URI。

String

NamespaceContext.getPrefix(String namespaceURI)
获取绑定到当前范围中名称空间 URI 的前缀。

Iterator

NamespaceContext.getPrefixes(String namespaceURI)
获取绑定到当前范围中名称空间 URI 的所有前缀。

static QName

QName.valueOf(String qNameAsString)
从解析格式化 String 中派生的 QName。

参数类型为 String 的 javax.xml.namespace 中的构造方法

QName(String localPart)
指定本地部分的 QName 构造方法。

QName(String namespaceURI, String localPart)
指定名称空间 URI 和本地部分的 QName 构造方法。

QName(String namespaceURI, String localPart, String prefix)
指定名称空间 URI、本地部分和前缀的 QName 构造方法。

javax.xml.parsers 中 String 的使用

返回 String 的 javax.xml.parsers 中的方法

String

FactoryConfigurationError.getMessage()
返回此错误的消息（如果有）。

参数类型为 String 的 javax.xml.parsers 中的方法

abstract  Object

DocumentBuilderFactory.getAttribute(String name)
允许用户在底层实现上检索特定属性。

abstract  boolean

SAXParserFactory.getFeature(String name)
返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。

abstract  boolean

DocumentBuilderFactory.getFeature(String name)
获取指定功能的状态。

abstract  Object

SAXParser.getProperty(String name)
返回 XMLReader 的底层实现中请求的特定属性。

static SAXParserFactory

SAXParserFactory.newInstance(String factoryClassName, ClassLoader classLoader)
从类名称中获取新的 SAXParserFactory 实例。

static DocumentBuilderFactory

DocumentBuilderFactory.newInstance(String factoryClassName, ClassLoader classLoader)
从类名称中获取新的 DocumentBuilderFactory 实例。

void

SAXParser.parse(InputStream is, DefaultHandler dh, String systemId)
使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。

void

SAXParser.parse(InputStream is, HandlerBase hb, String systemId)
使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。

Document

DocumentBuilder.parse(InputStream is, String systemId)
将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。

Document

DocumentBuilder.parse(String uri)
将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。

void

SAXParser.parse(String uri, DefaultHandler dh)
使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

void

SAXParser.parse(String uri, HandlerBase hb)
使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

abstract  void

DocumentBuilderFactory.setAttribute(String name, Object value)
允许用户在底层实现上设置特定属性。

abstract  void

SAXParserFactory.setFeature(String name, boolean value)
在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。

abstract  void

DocumentBuilderFactory.setFeature(String name, boolean value)
设置由此工厂创建的此 DocumentBuilderFactory 和 DocumentBuilder 的功能。

abstract  void

SAXParser.setProperty(String name, Object value)
设置 XMLReader 的底层实现中的特定属性。

参数类型为 String 的 javax.xml.parsers 中的构造方法

FactoryConfigurationError(Exception e, String msg)
使用给定 Exception 的基本原因和详细消息创建一个新的 FactoryConfigurationError。

FactoryConfigurationError(String msg)
创建一个新的 FactoryConfigurationError，并将 String 指定为一个错误消息。

ParserConfigurationException(String msg)
创建一个新的 ParserConfigurationException，并将 String 指定为一个错误消息。

javax.xml.soap 中 String 的使用

声明为 String 的 javax.xml.soap 中的字段

static String

SOAPMessage.CHARACTER_SET_ENCODING
指定 SOAP Message 的字符类型编码。

static String

SOAPConstants.DEFAULT_SOAP_PROTOCOL
默认协议：向后兼容的 SOAP 1.1。

static String

SOAPConstants.DYNAMIC_SOAP_PROTOCOL
用于创建 MessageFactory 实例，该实例可创建 SOAPMessages，SOAPMessages 的具体类型取决于传递给 createMessage 方法的 Content-Type MIME 头。

static String

SOAPConstants.SOAP_1_1_CONTENT_TYPE
SOAP 1.1 中 Content-Type MIME 头的媒体类型。

static String

SOAPConstants.SOAP_1_1_PROTOCOL
用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.1 规范的 SOAPMessages。

static String

SOAPConstants.SOAP_1_2_CONTENT_TYPE
SOAP 1.2 中 Content-Type MIME 头的媒体类型。

static String

SOAPConstants.SOAP_1_2_PROTOCOL
用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.2 规范的 SOAPMessages

static String

SOAPConstants.SOAP_ENV_PREFIX
http://www.w3.org/2003/05/soap-envelope 的默认名称空间前缀。

static String

SOAPConstants.URI_NS_SOAP_1_1_ENVELOPE
SOAP 1.1 信封的名称空间标识符。

static String

SOAPConstants.URI_NS_SOAP_1_2_ENCODING
SOAP 1.2 编码的名称空间标识符。

static String

SOAPConstants.URI_NS_SOAP_1_2_ENVELOPE
SOAP 1.2 信封的名称空间标识符。

static String

SOAPConstants.URI_NS_SOAP_ENCODING
SOAP 1.1 编码的名称空间标识符。

static String

SOAPConstants.URI_NS_SOAP_ENVELOPE
SOAP 1.1 信封的名称空间标识符，此名称空间中的所有 SOAPElements 是由 SOAP 1.1 规范定义的。

static String

SOAPConstants.URI_SOAP_1_2_ROLE_NEXT
该 URI 标识将 SOAP 请求处理为 SOAP 1.2 头条目预定角色 (intended role) 的下一个应用程序（请参阅 SOAP 1.2 规范第 1 部分第 2.2 节）。

static String

SOAPConstants.URI_SOAP_1_2_ROLE_NONE
该 URI 指定 SOAP 1.2 中的角色 None。

static String

SOAPConstants.URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER
该 URI 标识 SOAP 1.2 消息的最终接收者。

static String

SOAPConstants.URI_SOAP_ACTOR_NEXT
该 URI 标识将 SOAP 请求处理为 SOAP 1.1 头条目预定参与者的下一个应用程序（请参阅 SOAP 1.1 规范的第 4.2.2 节）。

static String

SOAPMessage.WRITE_XML_DECLARATION
指定 SOAP Message 在发送时是否包含 XML 声明。

返回 String 的 javax.xml.soap 中的方法

String

SOAPHeaderElement.getActor()
返回此 SOAPHeaderElement actor 属性的 URL。

String

SOAPElement.getAttributeValue(Name name)
返回带有指定名称的属性值。

String

SOAPElement.getAttributeValue(QName qname)
返回带有指定 qname 的属性值。

abstract  String

SOAPMessage.getContentDescription()
检索此 SOAPMessage 对象内容的描述。

String

AttachmentPart.getContentId()
获取名为 "Content-ID" 的 MIME 头的值。

String

SOAPPart.getContentId()
检索名为 "Content-Id" 的 MIME 头的值。

String

AttachmentPart.getContentLocation()
获取名为 "Content-Location" 的 MIME 头的值。

String

SOAPPart.getContentLocation()
检索名为 "Content-Location" 的 MIME 头的值。

String

AttachmentPart.getContentType()
获取名为 "Content-Type" 的 MIME 头的值。

String

SOAPElement.getEncodingStyle()
返回此 SOAPElement 对象的编码样式。

String

SOAPFault.getFaultActor()
获取此 SOAPFault 对象的错误参与者。

String

SOAPFault.getFaultCode()
获取此 SOAPFault 对象的错误代码。

String

SOAPFault.getFaultNode()
返回此 SOAPFault 对象的可选 Node 元素值。

String

SOAPFault.getFaultReasonText(Locale locale)
返回与给定 Locale 关联的 Reason Text。

String

SOAPFault.getFaultRole()
返回此 SOAPFault 对象的可选 Role 元素值。

String

SOAPFault.getFaultString()
获取此 SOAPFault 对象的错误字符串。

String[]

MimeHeaders.getHeader(String name)
以 String 对象数组的形式返回指定头的所有值。

String

Name.getLocalName()
获取此 Name 对象表示的 XML 名称的本地名称部分。

String

SOAPException.getMessage()
返回此 SOAPException 对象的详细消息。

abstract  String[]

AttachmentPart.getMimeHeader(String name)
获取给定 String 所标识的头的所有值。

abstract  String[]

SOAPPart.getMimeHeader(String name)
获取此 SOAPPart 对象中所有由给定 String 标识的 MimeHeader 对象的值。

String

MimeHeader.getName()
返回此 MimeHeader 对象的名称。

String

SOAPElement.getNamespaceURI(String prefix)
返回带有给定前缀的名称空间的 URI。

String

Name.getPrefix()
返回初始化此 Name 对象时指定的前缀。

String

Name.getQualifiedName()
获取此 Name 对象表示的 XML 名称限定于命名空间的名称。

String

SOAPHeaderElement.getRole()
返回此 SOAPHeaderElement Role 属性的值。

String

Name.getURI()
返回此 Name 对象表示的 XML 名称命名空间的 URI。

String

MimeHeader.getValue()
返回此 MimeHeader 对象的值。

String

Node.getValue()
如果这是一个 Text 节点，则返回此节点的值，否则返回此节点的直接子节点值。

参数类型为 String 的 javax.xml.soap 中的方法

SOAPElement

SOAPElement.addAttribute(Name name, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。

SOAPElement

SOAPElement.addAttribute(QName qname, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。

SOAPElement

SOAPElement.addChildElement(String localName)
创建使用指定本地名称初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。

SOAPElement

SOAPElement.addChildElement(String localName, String prefix)
创建使用指定本地名称和前缀初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。

SOAPElement

SOAPElement.addChildElement(String localName, String prefix, String uri)
创建使用指定本地名称、前缀和 URI 初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。

SOAPFault

SOAPBody.addFault(Name faultCode, String faultString)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。

SOAPFault

SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。

SOAPFault

SOAPBody.addFault(QName faultCode, String faultString)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。

SOAPFault

SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。

void

SOAPFault.addFaultReasonText(String text, Locale locale)
追加或替换包含指定文本消息的 Reason Text 项，以及从 locale 派生的 xml:lang。

void

MimeHeaders.addHeader(String name, String value)
将带有指定名称和值的 MimeHeader 对象添加到此 MimeHeaders 对象的头列表。

abstract  void

AttachmentPart.addMimeHeader(String name, String value)
将带有指定名称和值的 MIME 头添加到此 AttachmentPart 对象。

abstract  void

SOAPPart.addMimeHeader(String name, String value)
使用指定名称和值创建 MimeHeader 对象，并将其添加到此 SOAPPart 对象。

SOAPElement

SOAPElement.addNamespaceDeclaration(String prefix, String uri)
将带有指定前缀和 URI 的名称空间声明添加到此 SOAPElement 对象。

SOAPElement

SOAPElement.addTextNode(String text)
创建使用给定 String 初始化的新 Text 对象，并将其添加到此 SOAPElement 对象。

SOAPHeaderElement

SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri)
创建使用指定受支持 SOAP URI 初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。

SOAPHeaderElement

SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris)
创建使用指定 SOAP URI 支持数组初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。

SOAPElement

SOAPElementFactory.create(String localName)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换

SOAPElement

SOAPElementFactory.create(String localName, String prefix, String uri)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换

AttachmentPart

SOAPMessage.createAttachmentPart(Object content, String contentType)
创建 AttachmentPart 对象并使用指定内容类型的指定数据填充。

abstract  SOAPElement

SOAPFactory.createElement(String localName)
创建使用给定本地名称初始化的 SOAPElement 对象。

abstract  SOAPElement

SOAPFactory.createElement(String localName, String prefix, String uri)
使用本地名称、前缀和 URI 创建新的 SOAPElement 对象。

abstract  SOAPFault

SOAPFactory.createFault(String reasonText, QName faultCode)
创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象

Name

SOAPEnvelope.createName(String localName)
创建使用给定本地名称初始化的新 Name 对象。

abstract  Name

SOAPFactory.createName(String localName)
创建使用给定本地名称初始化的新 Name 对象。

Name

SOAPEnvelope.createName(String localName, String prefix, String uri)
创建使用给定本地名称、名称空间前缀和名称空间 URL 初始化的新 Name 对象。

abstract  Name

SOAPFactory.createName(String localName, String prefix, String uri)
创建使用给定本地名称、名称空间前缀和名称空间 URI 初始化的新 Name 对象。

QName

SOAPElement.createQName(String localName, String prefix)
创建一个 QName，其名称空间 URI 应与此 SOAPElement 上下文中的参数、prefix 相关联。

Iterator

SOAPHeader.examineHeaderElements(String actor)
返回可在此 SOAPHeader 对象中具有指定的 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator。

Iterator

SOAPHeader.examineMustUnderstandHeaderElements(String actor)
返回可在此 SOAPHeader 对象中所有符合以下条件的 SOAPHeaderElement 对象上进行迭代的 Iterator：具有指定的 actor 以及一个值等于 true 的 MustUnderstand 属性。

Iterator

SOAPHeader.extractHeaderElements(String actor)
返回可在此 SOAPHeader 对象中所有具有指定 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。

String[]

MimeHeaders.getHeader(String name)
以 String 对象数组的形式返回指定头的所有值。

Iterator

MimeHeaders.getMatchingHeaders(String[] names)
返回其名称与给定名称数组中的任一名称匹配的所有 MimeHeader 对象。

abstract  Iterator

AttachmentPart.getMatchingMimeHeaders(String[] names)
检索匹配给定数组中名称的所有 MimeHeader 对象。

abstract  Iterator

SOAPPart.getMatchingMimeHeaders(String[] names)
检索与给定数组中的名称匹配的所有 MimeHeader 对象。

abstract  String[]

AttachmentPart.getMimeHeader(String name)
获取给定 String 所标识的头的所有值。

abstract  String[]

SOAPPart.getMimeHeader(String name)
获取此 SOAPPart 对象中所有由给定 String 标识的 MimeHeader 对象的值。

String

SOAPElement.getNamespaceURI(String prefix)
返回带有给定前缀的名称空间的 URI。

Iterator

MimeHeaders.getNonMatchingHeaders(String[] names)
返回其名称与给定名称数组中的任何名称都不匹配的所有 MimeHeader 对象。

abstract  Iterator

AttachmentPart.getNonMatchingMimeHeaders(String[] names)
检索所有名称不匹配给定数组中任一名称的 MimeHeader 对象。

abstract  Iterator

SOAPPart.getNonMatchingMimeHeaders(String[] names)
检索名称与给定数组中任一名称不匹配的所有 MimeHeader 对象。

Object

SOAPMessage.getProperty(String property)
检索指定属性的值。

static MessageFactory

MessageFactory.newInstance(String protocol)
创建新的 MessageFactory 对象，该对象是指定实现的实例。

static SOAPFactory

SOAPFactory.newInstance(String protocol)
创建新的 SOAPFactory 对象，该对象是指定实现的实例，此方法使用 SAAJMetaFactory 来定位实现类并创建 SOAPFactory 实例。

protected abstract  MessageFactory

SAAJMetaFactory.newMessageFactory(String protocol)
创建给定 String 协议的 MessageFactory 对象。

protected abstract  SOAPFactory

SAAJMetaFactory.newSOAPFactory(String protocol)
创建给定 String 协议的 SOAPFactory 对象。

void

MimeHeaders.removeHeader(String name)
移除其名称与给定名称匹配的所有 MimeHeader 对象。

abstract  void

AttachmentPart.removeMimeHeader(String header)
移除匹配给定名称的所有 MIME 头。

abstract  void

SOAPPart.removeMimeHeader(String header)
移除所有与给定名称匹配的 MIME 头。

boolean

SOAPElement.removeNamespaceDeclaration(String prefix)
移除对应于给定前缀的名称空间声明。

void

SOAPHeaderElement.setActor(String actorURI)
将与此 SOAPHeaderElement 对象关联的 actor 设置为指定 actor。

abstract  void

AttachmentPart.setBase64Content(InputStream content, String contentType)
根据 Base64 源 InputStream 设置此附件部分的内容，并将 Content-Type 头的值设置为 contentType 中包含的值，此方法将首先对 base64 输入流进行解码，然后将得到的原始字节写入附件。

abstract  void

AttachmentPart.setContent(Object object, String contentType)
将此附件部分的内容设置为给定 Object 的内容，并将 Content-Type 头的值设置为给定类型。

abstract  void

SOAPMessage.setContentDescription(String description)
使用给定描述设置此 SOAPMessage 对象内容的描述。

void

AttachmentPart.setContentId(String contentId)
使用给定值设置名为 "Content-ID" 的 MIME 头。

void

SOAPPart.setContentId(String contentId)
将名为 "Content-Id" 的 MIME 头的值设置为给定 String。

void

AttachmentPart.setContentLocation(String contentLocation)
使用给定值设置名为 "Content-Location" 的 MIME 头。

void

SOAPPart.setContentLocation(String contentLocation)
将 MIME 头 "Content-Location" 的值设置为给定 String。

void

AttachmentPart.setContentType(String contentType)
使用给定值设置名为 "Content-Type" 的 MIME 头。

void

SOAPElement.setEncodingStyle(String encodingStyle)
将此 SOAPElement 对象的编码样式设置为指定样式。

void

SOAPFault.setFaultActor(String faultActor)
使用给定的错误参与者 (actor) 设置此 SOAPFault 对象。

void

SOAPFault.setFaultCode(String faultCode)
使用给定的错误代码设置此 SOAPFault 对象。

void

SOAPFault.setFaultNode(String uri)
创建或替换此 SOAPFault 对象的任何现有 Node 元素。

void

SOAPFault.setFaultRole(String uri)
创建或替换此 SOAPFault 对象的任何现有 Role 元素。

void

SOAPFault.setFaultString(String faultString)
将此 SOAPFault 对象的错误字符串设定为给定字符串。

void

SOAPFault.setFaultString(String faultString, Locale locale)
将此 SOAPFault 对象的错误字符串设定为给定字符串，并本地化为给定语言环境。

void

MimeHeaders.setHeader(String name, String value)
将其名称与给定名称匹配的第一个头条目的当前值替换为给定值，如果现有的头名称都不匹配，则添加一个新的头。

abstract  void

AttachmentPart.setMimeHeader(String name, String value)
将匹配给定名称的第一个头条目的值更改为给定值，如果现有的头都不匹配，则添加一个新的头。

abstract  void

SOAPPart.setMimeHeader(String name, String value)
将与给定头名称匹配的第一个头条目的值更改为给定值，如果现有头都不匹配，则添加一个带有给定名称和值的新头。

void

SOAPMessage.setProperty(String property, Object value)
将指定值与指定属性关联。

abstract  void

AttachmentPart.setRawContent(InputStream content, String contentType)
将此附件部分的内容设置为 InputStream content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。

abstract  void

AttachmentPart.setRawContentBytes(byte[] content, int offset, int len, String contentType)
将此附件部分的内容设置为 byte[] 数组 content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。

void

SOAPHeaderElement.setRole(String uri)
将与此 SOAPHeaderElement 对象关联的 Role 设置为指定 Role。

void

Node.setValue(String value)
如果这是一个 Text 节点，则此方法会设置它的值，否则该方法设置此节点的直接 (Text) 子节点值。

参数类型为 String 的 javax.xml.soap 中的构造方法

MimeHeader(String name, String value)
构造使用给定的名称和值初始化的 MimeHeader 对象。

SAAJResult(String protocol)
创建一个 SAAJResult，它将以支持指定协议的 SAAJ 树的形式显示结果。

SOAPException(String reason)
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因。

SOAPException(String reason, Throwable cause)
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因，使用给定 Throwable 对象作为嵌入的异常。

javax.xml.stream 中 String 的使用

声明为 String 的 javax.xml.stream 中的字段

static String

XMLInputFactory.ALLOCATOR
用于设置/获取分配器实现的属性。

static String

XMLInputFactory.IS_COALESCING
要求解析器组合相邻字符数据部分的属性。

static String

XMLInputFactory.IS_NAMESPACE_AWARE
用于开启/关闭名称空间支持的属性，该属性用于支持 XML 1.0 文档，只有 true 设置是必须受支持的。

static String

XMLOutputFactory.IS_REPAIRING_NAMESPACES
用于设置输出端上默认前缀的属性。

static String

XMLInputFactory.IS_REPLACING_ENTITY_REFERENCES
要求解析器用它们的替换文本替换内部实体引用并将它们报告为字符。

static String

XMLInputFactory.IS_SUPPORTING_EXTERNAL_ENTITIES
要求解析器解析外部解析实体的属性。

static String

XMLInputFactory.IS_VALIDATING
用于开启/关闭特定于实现的验证的属性。

static String

XMLInputFactory.REPORTER
用于设置/获取 XMLReporter 接口实现的属性。

static String

XMLInputFactory.RESOLVER
用于设置/获取 XMLResolver 实现的属性。

static String

XMLInputFactory.SUPPORT_DTD
要求解析器支持 DTD 的属性。

返回 String 的 javax.xml.stream 中的方法

String

XMLStreamReader.getAttributeLocalName(int index)
返回所提供索引处的属性的 localName

String

XMLStreamReader.getAttributeNamespace(int index)
返回所提供索引处的属性的名称空间

String

XMLStreamReader.getAttributePrefix(int index)
返回所提供索引处的属性的前缀

String

XMLStreamReader.getAttributeType(int index)
返回所提供索引处的属性的 XML 类型

String

XMLStreamReader.getAttributeValue(int index)
返回 index 处的属性值

String

XMLStreamReader.getAttributeValue(String namespaceURI, String localName)
返回带有名称空间和 localName 的属性的规范化属性值。

String

XMLStreamReader.getCharacterEncodingScheme()
返回 xml 声明中声明的字符编码。

String

XMLEventReader.getElementText()
读取纯文本元素的内容。

String

XMLStreamReader.getElementText()
读取纯文本元素的内容，如果不是纯文本元素，则抛出异常。

String

XMLStreamReader.getEncoding()
如果输入编码已知，则返回输入编码；如果未知，则返回 null。

String

XMLStreamReader.getLocalName()
返回当前事件的（本地）名称。

String

FactoryConfigurationError.getMessage()
报告与此错误关联的消息。

String

XMLStreamReader.getNamespacePrefix(int index)
返回在 index 处声明的名称空间前缀。

String

XMLStreamReader.getNamespaceURI()
如果当前事件是 START_ELEMENT 或 END_ELEMENT，则此方法返回前缀的 URI 或默认名称空间。

String

XMLStreamReader.getNamespaceURI(int index)
返回在 index 处声明的名称空间 URI。

String

XMLStreamReader.getNamespaceURI(String prefix)
返回给定前缀的 URI。

String

XMLStreamReader.getPIData()
获取处理指令的数据节

String

XMLStreamReader.getPITarget()
获取处理指令的目标

String

XMLStreamReader.getPrefix()
返回当前事件的前缀，如果事件没有前缀，则返回 null

String

XMLEventWriter.getPrefix(String uri)
获取绑定 URI 的前缀。

String

XMLStreamWriter.getPrefix(String uri)
获取绑定 URI 的前缀

String

Location.getPublicId()
返回 XML 的公共 ID

String

Location.getSystemId()
返回 XML 的系统 ID

String

XMLStreamReader.getText()
以字符串的形式返回解析事件的当前值，此方法返回 CHARACTERS 事件的字符串值，返回 COMMENT 的值、ENTITY_REFERENCE 的替代值、CDATA 节的字符串值、SPACE 事件的字符串值、DTD 内部子集的字符串值。

String

XMLStreamReader.getVersion()
获取在 xml 声明中声明的 xml 版本，如果没有声明版本，则返回 null

参数类型为 String 的 javax.xml.stream 中的方法

abstract  Attribute

XMLEventFactory.createAttribute(QName name, String value)
创建一个新 Attribute。

abstract  Attribute

XMLEventFactory.createAttribute(String localName, String value)
创建一个新 Attribute。

abstract  Attribute

XMLEventFactory.createAttribute(String prefix, String namespaceURI, String localName, String value)
创建一个新 Attribute。

abstract  Characters

XMLEventFactory.createCData(String content)
创建一个 CData 标记设置为 true 的 Character 事件。

abstract  Characters

XMLEventFactory.createCharacters(String content)
创建一个 Character 事件，此方法不检查内容是否全部为空白。

abstract  Comment

XMLEventFactory.createComment(String text)
创建一个注释。

abstract  DTD

XMLEventFactory.createDTD(String dtd)
创建一个文档类型定义事件。

abstract  EndElement

XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName)
创建一个新 EndElement。

abstract  EndElement

XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces)
创建一个新 EndElement。

abstract  EntityReference

XMLEventFactory.createEntityReference(String name, EntityDeclaration declaration)
创建一个 EntityReference 事件的新实例。

abstract  Characters

XMLEventFactory.createIgnorableSpace(String content)
创建一个可忽略的空间。

abstract  Namespace

XMLEventFactory.createNamespace(String namespaceURI)
创建一个新的默认 Namespace。

abstract  Namespace

XMLEventFactory.createNamespace(String prefix, String namespaceUri)
创建一个新的 Namespace。

abstract  ProcessingInstruction

XMLEventFactory.createProcessingInstruction(String target, String data)
创建一个处理指令。

abstract  Characters

XMLEventFactory.createSpace(String content)
创建一个 isSpace 标记设置为 true 的 Character 事件。

abstract  StartDocument

XMLEventFactory.createStartDocument(String encoding)
创建一个 StartDocument 事件的新实例。

abstract  StartDocument

XMLEventFactory.createStartDocument(String encoding, String version)
创建一个 StartDocument 事件的新实例。

abstract  StartDocument

XMLEventFactory.createStartDocument(String encoding, String version, boolean standalone)
创建一个 StartDocument 事件的新实例。

abstract  StartElement

XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName)
创建一个新 StartElement。

abstract  StartElement

XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces)
创建一个新 StartElement。

abstract  StartElement

XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context)
创建一个新 StartElement。

abstract  XMLEventReader

XMLInputFactory.createXMLEventReader(InputStream stream, String encoding)
根据 java.io.InputStream 创建一个新 XMLEventReader。

abstract  XMLEventReader

XMLInputFactory.createXMLEventReader(String systemId, InputStream stream)
根据 java.io.InputStream 创建一个新 XMLEventReader。

abstract  XMLEventReader

XMLInputFactory.createXMLEventReader(String systemId, Reader reader)
根据 reader 创建一个新 XMLEventReader。

abstract  XMLEventWriter

XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding)
创建一个写入到流的新 XMLEventWriter。

abstract  XMLStreamReader

XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding)
根据 java.io.InputStream 创建一个新 XMLStreamReader。

abstract  XMLStreamReader

XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream)
根据 java.io.InputStream 创建一个新 XMLStreamReader。

abstract  XMLStreamReader

XMLInputFactory.createXMLStreamReader(String systemId, Reader reader)
根据 java.io.InputStream 创建一个新 XMLStreamReader。

abstract  XMLStreamWriter

XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding)
创建一个写入到流的新 XMLStreamWriter。

String

XMLStreamReader.getAttributeValue(String namespaceURI, String localName)
返回带有名称空间和 localName 的属性的规范化属性值。

String

XMLStreamReader.getNamespaceURI(String prefix)
返回给定前缀的 URI。

String

XMLEventWriter.getPrefix(String uri)
获取绑定 URI 的前缀。

String

XMLStreamWriter.getPrefix(String uri)
获取绑定 URI 的前缀

Object

XMLEventReader.getProperty(String name)
从底层实现获取功能/属性值。

abstract  Object

XMLInputFactory.getProperty(String name)
从底层实现获取功能/属性的值。

abstract  Object

XMLOutputFactory.getProperty(String name)
获取底层实现上的功能/属性

Object

XMLStreamReader.getProperty(String name)
从底层实现获取功能/属性的值

Object

XMLStreamWriter.getProperty(String name)
从底层实现获取功能/属性值

abstract  boolean

XMLInputFactory.isPropertySupported(String name)
查询此工厂支持的属性集合。

abstract  boolean

XMLOutputFactory.isPropertySupported(String name)
查询此工厂支持的属性集合。

static XMLEventFactory

XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader)
创建一个新的工厂实例。

static XMLInputFactory

XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader)
创建一个新的工厂实例。

static XMLInputFactory

XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader)
创建一个的新工厂实例。

void

XMLReporter.report(String message, String errorType, Object relatedInformation, Location location)
以特定于应用程序的格式报告所需消息。

void

XMLStreamReader.require(int type, String namespaceURI, String localName)
测试当前事件是否属于给定的类型，以及名称空间和名称是否与当前事件的当前名称空间和名称相匹配。

Object

XMLResolver.resolveEntity(String publicID, String systemID, String baseURI, String namespace)
检索资源。

void

XMLEventWriter.setDefaultNamespace(String uri)
将 URI 绑定到默认名称空间。

void

XMLStreamWriter.setDefaultNamespace(String uri)
将 URI 绑定到默认名称空间。

void

XMLEventWriter.setPrefix(String prefix, String uri)
设置绑定 URI 的前缀。

void

XMLStreamWriter.setPrefix(String prefix, String uri)
设置绑定 URI 的前缀。

abstract  void

XMLInputFactory.setProperty(String name, Object value)
允许用户在底层实现上设置特定功能/属性。

abstract  void

XMLOutputFactory.setProperty(String name, Object value)
允许用户在底层实现上设置特定功能/属性。

void

XMLStreamWriter.writeAttribute(String localName, String value)
向输出流写入一个不带前缀的属性。

void

XMLStreamWriter.writeAttribute(String namespaceURI, String localName, String value)
向输出流写入一个属性

void

XMLStreamWriter.writeAttribute(String prefix, String namespaceURI, String localName, String value)
向输出流写入一个属性

void

XMLStreamWriter.writeCData(String data)
编写 CData 节

void

XMLStreamWriter.writeCharacters(String text)
向输出写入文本

void

XMLStreamWriter.writeComment(String data)
编写一个包含数据的 XML 注释

void

XMLStreamWriter.writeDefaultNamespace(String namespaceURI)
向流写入默认名称空间

void

XMLStreamWriter.writeDTD(String dtd)
编写 DTD 节。

void

XMLStreamWriter.writeEmptyElement(String localName)
向输出写入一个空元素标记

void

XMLStreamWriter.writeEmptyElement(String namespaceURI, String localName)
向输出写入一个空元素标记

void

XMLStreamWriter.writeEmptyElement(String prefix, String localName, String namespaceURI)
向输出写入一个空元素标记

void

XMLStreamWriter.writeEntityRef(String name)
编写一个实体引用

void

XMLStreamWriter.writeNamespace(String prefix, String namespaceURI)
向输出流写入一个名称空间。

void

XMLStreamWriter.writeProcessingInstruction(String target)
编写一条处理指令

void

XMLStreamWriter.writeProcessingInstruction(String target, String data)
编写一条处理指令

void

XMLStreamWriter.writeStartDocument(String version)
编写 XML 声明。

void

XMLStreamWriter.writeStartDocument(String encoding, String version)
编写 XML 声明。

void

XMLStreamWriter.writeStartElement(String localName)
向输出写入一个开始标记。

void

XMLStreamWriter.writeStartElement(String namespaceURI, String localName)
向输出写入一个开始标记

void

XMLStreamWriter.writeStartElement(String prefix, String localName, String namespaceURI)
向输出写入一个开始标记

参数类型为 String 的 javax.xml.stream 中的构造方法

FactoryConfigurationError(Exception e, String msg)
构造具有嵌套内部异常和消息的异常。

FactoryConfigurationError(String msg)
构造具有关联消息的异常。

FactoryConfigurationError(String msg, Exception e)
构造具有嵌套内部异常和消息的异常。

XMLStreamException(String msg)
构造具有关联消息的异常。

XMLStreamException(String msg, Location location)
构造具有关联消息、异常和位置的异常。

XMLStreamException(String msg, Location location, Throwable th)
构造具有关联消息、异常和位置的异常。

XMLStreamException(String msg, Throwable th)
构造具有关联消息和异常的异常

javax.xml.stream.events 中 String 的使用

返回 String 的 javax.xml.stream.events 中的方法

String

EntityDeclaration.getBaseURI()
获取此引用的基准 URI，如果此信息不可用，则获得 null

String

StartDocument.getCharacterEncodingScheme()
返回 XML 数据的编码样式

String

Characters.getData()
获取此事件的字符数据。

String

ProcessingInstruction.getData()
处理指令的数据部分。

String

DTD.getDocumentTypeDeclaration()
以字符串形式返回完整文档类型声明，其中包括内部 DTD 子集。

String

Attribute.getDTDType()
获取此属性的类型，默认值是字符串 "CDATA"，

String

EntityDeclaration.getName()
实体的名称

String

EntityReference.getName()
实体的名称

String

NotationDeclaration.getName()
注释的名称。

String

Namespace.getNamespaceURI()
获取绑定到此名称空间的前缀的 URI。

String

StartElement.getNamespaceURI(String prefix)
获取绑定在此元素上下文中的前缀的值。

String

EntityDeclaration.getNotationName()
关联的注释的名称。

String

Namespace.getPrefix()
获取前缀，如果它是默认名称空间声明，则返回 ""。

String

EntityDeclaration.getPublicId()
实体的公共标识符，如果未给定该标识符，则为 null

String

NotationDeclaration.getPublicId()
注释的公共标识符，如果未提供该标识符，则为 null。

String

EntityDeclaration.getReplacementText()
实体的替换文本。

String

EntityDeclaration.getSystemId()
实体的系统标识符。

String

NotationDeclaration.getSystemId()
注释的系统标识符，如果未提供该标识符，则为 null。

String

StartDocument.getSystemId()
返回 XML 数据的系统 ID

String

ProcessingInstruction.getTarget()
处理指令的目标部分。

String

Comment.getText()
返回注释的字符串数据，如果不存在这样的数据，则返回空字符串。

String

Attribute.getValue()
获取此属性的标准化值。

String

StartDocument.getVersion()
返回此 XML 流的 XML 版本

参数类型为 String 的 javax.xml.stream.events 中的方法

String

StartElement.getNamespaceURI(String prefix)
获取绑定在此元素上下文中的前缀的值。

javax.xml.stream.util 中 String 的使用

返回 String 的 javax.xml.stream.util 中的方法

String

StreamReaderDelegate.getAttributeLocalName(int index)

String

StreamReaderDelegate.getAttributeNamespace(int index)

String

StreamReaderDelegate.getAttributePrefix(int index)

String

StreamReaderDelegate.getAttributeType(int index)

String

StreamReaderDelegate.getAttributeValue(int index)

String

StreamReaderDelegate.getAttributeValue(String namespaceUri, String localName)

String

StreamReaderDelegate.getCharacterEncodingScheme()

String

EventReaderDelegate.getElementText()

String

StreamReaderDelegate.getElementText()

String

StreamReaderDelegate.getEncoding()

String

StreamReaderDelegate.getLocalName()

String

StreamReaderDelegate.getNamespacePrefix(int index)

String

StreamReaderDelegate.getNamespaceURI()

String

StreamReaderDelegate.getNamespaceURI(int index)

String

StreamReaderDelegate.getNamespaceURI(String prefix)

String

StreamReaderDelegate.getPIData()

String

StreamReaderDelegate.getPITarget()

String

StreamReaderDelegate.getPrefix()

String

StreamReaderDelegate.getText()

String

StreamReaderDelegate.getVersion()

参数类型为 String 的 javax.xml.stream.util 中的方法

String

StreamReaderDelegate.getAttributeValue(String namespaceUri, String localName)

String

StreamReaderDelegate.getNamespaceURI(String prefix)

Object

EventReaderDelegate.getProperty(String name)

Object

StreamReaderDelegate.getProperty(String name)

void

StreamReaderDelegate.require(int type, String namespaceURI, String localName)

javax.xml.transform 中 String 的使用

声明为 String 的 javax.xml.transform 中的字段

static String

OutputKeys.CDATA_SECTION_ELEMENTS
cdata-section-elements = expanded names. cdata-section-elements 指定了由空白分隔的元素名称列表，其中的文本节点子级应使用 CDATA 部分来输出。

static String

OutputKeys.DOCTYPE_PUBLIC
doctype-public = string. 有关关键值应为何值的描述，请参阅 OutputKeys.DOCTYPE_SYSTEM 属性文档。

static String

OutputKeys.DOCTYPE_SYSTEM
doctype-system = string. doctype-system 指定了要在文档类型声明中使用的系统标识符。

static String

OutputKeys.ENCODING
encoding = string. encoding 指定了首选的字符编码，Transformer 应使用此编码将字符序列编码作为字节序列进行编码。

static String

OutputKeys.INDENT
indent = "yes" | "no". indent 指定了当输出结果树时，Transformer 是否可以添加额外的空白；其值必须为 yes 或 no。

static String

OutputKeys.MEDIA_TYPE
media-type = string. media-type 指定了输出结果树得到的数据的介质类型（MIME 内容类型）。

static String

OutputKeys.METHOD
method = "xml" | "html" | "text" | expanded name。

static String

OutputKeys.OMIT_XML_DECLARATION
omit-xml-declaration = "yes" | "no". omit-xml-declaration 指定了 XSLT 处理器是否应输出 XML 声明，其值必须为 yes 或 no。

static String

Result.PI_DISABLE_OUTPUT_ESCAPING
如果结果树禁用了输出转义，则为发送处理指令的名称。

static String

Result.PI_ENABLE_OUTPUT_ESCAPING
如果结果树在已接收 PI_DISABLE_OUTPUT_ESCAPING 处理指令后的某时刻启用了输出转义，则发送处理指令的名称。

static String

OutputKeys.STANDALONE
standalone = "yes" | "no". standalone 指定了 Transformer 是否应输出单独的文档声明，其值必须为 yes 或 no。

static String

OutputKeys.VERSION
version = nmtoken. version 指定了输出方法的版本。

返回 String 的 javax.xml.transform 中的方法

String

TransformerException.getLocationAsString()
获取字符串形式的位置信息。

String

TransformerFactoryConfigurationError.getMessage()
返回针对此错误的消息（如果有）。

String

TransformerException.getMessageAndLocation()
获取带有追加的位置信息的错误消息。

abstract  String

Transformer.getOutputProperty(String name)
获取对转换器有效的输出属性。

String

SourceLocator.getPublicId()
返回当前文档事件的公共标识符。

String

Result.getSystemId()
获取通过 setSystemId 设置的系统标识符。

String

Source.getSystemId()
获取通过 setSystemId 设置的系统标识符。

String

SourceLocator.getSystemId()
返回当前文档事件的系统标识符。

参数类型为 String 的 javax.xml.transform 中的方法

abstract  Source

TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset)
通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。

abstract  Object

TransformerFactory.getAttribute(String name)
允许用户在底层实现上检索指定属性。

abstract  boolean

TransformerFactory.getFeature(String name)
查找功能值。

abstract  String

Transformer.getOutputProperty(String name)
获取对转换器有效的输出属性。

abstract  Object

Transformer.getParameter(String name)
获取通过 setParameter 显式设置的参数。

static TransformerFactory

TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader)
根据类名称获得一个新 TransformerFactory 实例。

Source

URIResolver.resolve(String href, String base)
当遇到 xsl:include、xsl:import 或 document() 函数时，由处理器调用此方法。

abstract  void

TransformerFactory.setAttribute(String name, Object value)
允许用户设置底层实现上的指定属性。

abstract  void

TransformerFactory.setFeature(String name, boolean value)
设置通过此工厂创建的此 TransformerFactory 和 Transformer 或 Template 的功能。

abstract  void

Transformer.setOutputProperty(String name, String value)
设置转换中实际的输出属性。

abstract  void

Transformer.setParameter(String name, Object value)
添加一个转换参数。

void

Result.setSystemId(String systemId)
设置此 Result 的系统标识符。

void

Source.setSystemId(String systemId)
设置此 Source 的系统标识符。

参数类型为 String 的 javax.xml.transform 中的构造方法

TransformerConfigurationException(String msg)
创建带有指定为错误消息的 String 的新 TransformerConfigurationException。

TransformerConfigurationException(String message, SourceLocator locator)
从消息和 Locator 创建新 TransformerConfigurationException。

TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
包装了 TransformerConfigurationException 中的现有异常。

TransformerConfigurationException(String msg, Throwable e)
创建带有给定 Exception 基本原因和详细消息的新 TransformerConfigurationException。

TransformerException(String message)
创建一个新的 TransformerException。

TransformerException(String message, SourceLocator locator)
从消息和 Locator 创建一个新 TransformerException。

TransformerException(String message, SourceLocator locator, Throwable e)
包装了 TransformerException 中的现有异常。

TransformerException(String message, Throwable e)
包装 TransformerException 中的一个现有异常。

TransformerFactoryConfigurationError(Exception e, String msg)
创建带有给定 Exception 基本原因和详细消息的新 TransformerFactoryConfigurationError。

TransformerFactoryConfigurationError(String msg)
创建带有指定为错误消息的 String 的新 TransformerFactoryConfigurationError。

javax.xml.transform.dom 中 String 的使用

声明为 String 的 javax.xml.transform.dom 中的字段

static String

DOMResult.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。

static String

DOMSource.FEATURE
当将此值作为参数传递时如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。

返回 String 的 javax.xml.transform.dom 中的方法

String

DOMResult.getSystemId()
获取系统标识符。

String

DOMSource.getSystemId()
获取将从其解析 URL 的基本 ID（URL 或系统 ID）。

参数类型为 String 的 javax.xml.transform.dom 中的方法

void

DOMResult.setSystemId(String systemId)
设置可与此节点联合使用的 systemId。

void

DOMSource.setSystemId(String systemID)
设置将从其解析 URL 的基本 ID（URL 或系统 ID）。

参数类型为 String 的 javax.xml.transform.dom 中的构造方法

DOMResult(Node node, Node nextSibling, String systemId)
使用 DOM 节点创建新输出目标，此目标指定了子节点，其中结果节点为指定 System ID 且应该插入到该子节点之前。

DOMResult(Node node, String systemId)
使用 DOM 节点创建带有指定 System ID 的新输出目标。

DOMSource(Node node, String systemID)
创建带有 DOM 节点的新输入源，系统 ID 也作为基本 URI 被传入。

javax.xml.transform.sax 中 String 的使用

声明为 String 的 javax.xml.transform.sax 中的字段

static String

SAXResult.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。

static String

SAXSource.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。

static String

SAXTransformerFactory.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则从 TransformerFactory.newInstance() 返回的 TransformerFactory 可以安全地被转换为 SAXTransformerFactory。

static String

SAXTransformerFactory.FEATURE_XMLFILTER
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 SAXTransformerFactory.newXMLFilter(Source src) 和 SAXTransformerFactory.newXMLFilter(Templates templates) 方法是受支持的。

返回 String 的 javax.xml.transform.sax 中的方法

String

SAXResult.getSystemId()
获取通过 setSystemId 设置的系统标识符。

String

SAXSource.getSystemId()
获取要从其解析 URI 的基本 ID（URI 或系统 ID）。

String

TemplatesHandler.getSystemId()
获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。

String

TransformerHandler.getSystemId()
获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。

参数类型为 String 的 javax.xml.transform.sax 中的方法

void

SAXResult.setSystemId(String systemId)
setSystemId 方法设置可与 ContentHandler 关联使用的 systemID。

void

SAXSource.setSystemId(String systemId)
设置此 Source 的系统标识符。

void

TemplatesHandler.setSystemId(String systemID)
设置此生成器所创建的 Templates 对象的基本 ID（URI 或系统 ID）。

void

TransformerHandler.setSystemId(String systemID)
设置要从其解析相对 URL 的基本 ID（URI 或系统 ID）。

javax.xml.transform.stax 中 String 的使用

声明为 String 的 javax.xml.transform.stax 中的字段

static String

StAXResult.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Result 输出。

static String

StAXSource.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Source 输入。

返回 String 的 javax.xml.transform.stax 中的方法

String

StAXResult.getSystemId()
返回的系统标识符始终为 null。

String

StAXSource.getSystemId()
获取此 StAXSource 使用的系统标识符。

参数类型为 String 的 javax.xml.transform.stax 中的方法

void

StAXResult.setSystemId(String systemId)
在 StAXResult 的上下文中，它不适合显示设置系统标识符。

void

StAXSource.setSystemId(String systemId)
在 StAXSource 的上下文中，它不适合显示设置系统标识符。

javax.xml.transform.stream 中 String 的使用

声明为 String 的 javax.xml.transform.stream 中的字段

static String

StreamResult.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。

static String

StreamSource.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source。

返回 String 的 javax.xml.transform.stream 中的方法

String

StreamSource.getPublicId()
获取通过 setPublicId 设置的公共标识符。

String

StreamResult.getSystemId()
获取通过 setSystemId 设置的系统标识符。

String

StreamSource.getSystemId()
获取通过 setSystemId 设置的系统标识符。

参数类型为 String 的 javax.xml.transform.stream 中的方法

void

StreamSource.setPublicId(String publicId)
设置此 Source 的公共标识符。

void

StreamResult.setSystemId(String systemId)
设置可以与字节流或字符流关联使用的 systemID，如果未设置，则使用此值作为 writeable URI（可能是文件名）。

void

StreamSource.setSystemId(String systemId)
设置此 Source 的系统标识符。

参数类型为 String 的 javax.xml.transform.stream 中的构造方法

StreamResult(String systemId)
从 URL 构造 StreamResult。

StreamSource(InputStream inputStream, String systemId)
从字节流构造 StreamSource。

StreamSource(Reader reader, String systemId)
从字符 reader 构造 StreamSource。

StreamSource(String systemId)
从 URL 构造 StreamSource。

javax.xml.validation 中 String 的使用

参数类型为 String 的 javax.xml.validation 中的方法

boolean

SchemaFactory.getFeature(String name)
查找功能标志的值。

boolean

Validator.getFeature(String name)
查找功能标志的值。

boolean

ValidatorHandler.getFeature(String name)
查找特性标志的值。

Object

SchemaFactory.getProperty(String name)
查找属性值。

Object

Validator.getProperty(String name)
查找属性值。

Object

ValidatorHandler.getProperty(String name)
查找属性值。

abstract  boolean

SchemaFactory.isSchemaLanguageSupported(String schemaLanguage)
此 SchemaFactory 支持指定的模式吗？

abstract  SchemaFactory

SchemaFactoryLoader.newFactory(String schemaLanguage)
创建指定模式语言的新 SchemaFactory 对象。

static SchemaFactory

SchemaFactory.newInstance(String schemaLanguage)
查找支持指定模式语言的 SchemaFactory 的实现并返回它。

static SchemaFactory

SchemaFactory.newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)
根据类名称获得一个新 SchemaFactory 实例。

void

SchemaFactory.setFeature(String name, boolean value)
设置此 SchemaFactory 的特性，Schema 由此工厂创建，更进一步说，Validator 和 ValidatorHandler 由这些 Schema 创建。

void

Validator.setFeature(String name, boolean value)
设置功能标志的值。

void

ValidatorHandler.setFeature(String name, boolean value)
设置此 ValidatorHandler 的特性。

void

SchemaFactory.setProperty(String name, Object object)
设置属性值。

void

Validator.setProperty(String name, Object object)
设置属性值。

void

ValidatorHandler.setProperty(String name, Object object)
设置属性值。

javax.xml.ws 中 String 的使用

声明为 String 的 javax.xml.ws 中的字段

static String

BindingProvider.ENDPOINT_ADDRESS_PROPERTY
标准属性：目标服务端点地址。

static String

BindingProvider.PASSWORD_PROPERTY
标准属性：用于验证的密码。

static String

BindingProvider.SESSION_MAINTAIN_PROPERTY
标准属性：服务客户端使用此 boolean 属性指示它是否希望参与与服务端点的会话。

static String

BindingProvider.SOAPACTION_URI_PROPERTY
SOAPAction 的标准属性。

static String

BindingProvider.SOAPACTION_USE_PROPERTY
SOAPAction 的标准属性。

static String

BindingProvider.USERNAME_PROPERTY
标准属性：用于验证的用户名。

static String

Endpoint.WSDL_PORT
标准属性：WSDL 端口的名称。

static String

Endpoint.WSDL_SERVICE
标准属性：WSDL 服务的名称。

返回变量类型为 String 的类型的 javax.xml.ws 中的方法

Map<String,Object>

Response.getContext()
获取所含的响应上下文。

abstract  Map<String,Object>

Endpoint.getProperties()
返回此 Endpoint 实例的属性包。

Map<String,Object>

BindingProvider.getRequestContext()
获取用于初始化请求消息的消息上下文的上下文。

Map<String,Object>

BindingProvider.getResponseContext()
获取处理响应消息所得的上下文。

参数类型为 String 的 javax.xml.ws 中的方法

void

Service.addPort(QName portName, String bindingId, String endpointAddress)
为服务创建新的端口。

static Endpoint

Endpoint.create(String bindingId, Object implementor)
创建具有指定绑定类型和实现者对象的端点。

boolean

WebServiceContext.isUserInRole(String role)
返回一个布尔值，指示指定的逻辑角色中是否包含经过验证的用户。

abstract  void

Endpoint.publish(String address)
在给定地址处发布此端点。

static Endpoint

Endpoint.publish(String address, Object implementor)
在给定地址处针对指定的实现者对象创建并发布端点。

static Service.Mode

Service.Mode.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

类型变量类型为 String 的 javax.xml.ws 中的方法参数

abstract  void

Endpoint.setProperties(Map<String,Object> properties)
设置此 Endpoint 实例的属性包。

参数类型为 String 的 javax.xml.ws 中的构造方法

ProtocolException(String message)
构造一个具有指定详细消息的新协议异常。

ProtocolException(String message, Throwable cause)
构造一个具有指定详细消息和 cause 的新运行时异常。

WebServiceException(String message)
构造具有指定详细消息的新异常。

WebServiceException(String message, Throwable cause)
构造一个具有指定详细消息和 cause 的新异常。

WebServicePermission(String name)
创建具有指定名称的新权限。

WebServicePermission(String name, String actions)
创建具有指定名称和操作的新权限。

javax.xml.ws.handler 中 String 的使用

声明为 String 的 javax.xml.ws.handler 中的字段

static String

MessageContext.HTTP_REQUEST_HEADERS
标准属性：HTTP 请求头。

static String

MessageContext.HTTP_REQUEST_METHOD
标准属性：HTTP 请求方法。

static String

MessageContext.HTTP_RESPONSE_CODE
标准属性：HTTP 响应状态代码。

static String

MessageContext.HTTP_RESPONSE_HEADERS
标准属性：HTTP 响应头。

static String

MessageContext.INBOUND_MESSAGE_ATTACHMENTS
标准属性：用于入站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。

static String

MessageContext.MESSAGE_OUTBOUND_PROPERTY
标准属性：消息方向，对于出站消息为 true，对于入站消息为 false。

static String

MessageContext.OUTBOUND_MESSAGE_ATTACHMENTS
标准属性: 用于出站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。

static String

MessageContext.PATH_INFO
标准属性：请求路径信息

static String

MessageContext.QUERY_STRING
标准属性：请求的查询字符串。

static String

MessageContext.SERVLET_CONTEXT
标准属性：servlet 上下文对象

static String

MessageContext.SERVLET_REQUEST
标准属性：servlet 请求对象。

static String

MessageContext.SERVLET_RESPONSE
标准属性：servlet 响应对象。

static String

MessageContext.WSDL_DESCRIPTION
标准属性：WSDL 文档的输入源。

static String

MessageContext.WSDL_INTERFACE
标准属性：wsdl 接口 (2.0) 或端口类型 (1.1) 的名称。

static String

MessageContext.WSDL_OPERATION
标准属性：WSDL 操作的名称。

static String

MessageContext.WSDL_PORT
标准属性：WSDL 端口的名称。

static String

MessageContext.WSDL_SERVICE
标准属性：WSDL 服务的名称。

返回 String 的 javax.xml.ws.handler 中的方法

String

PortInfo.getBindingID()
获取标识正由被访问的端口所用绑定的 URI。

参数类型为 String 的 javax.xml.ws.handler 中的方法

MessageContext.Scope

MessageContext.getScope(String name)
获得属性的作用域。

void

MessageContext.setScope(String name, MessageContext.Scope scope)
设置属性的作用域。

static MessageContext.Scope

MessageContext.Scope.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.xml.ws.handler.soap 中 String 的使用

返回变量类型为 String 的类型的 javax.xml.ws.handler.soap 中的方法

Set<String>

SOAPMessageContext.getRoles()
获取与执行处理程序链关联的 SOAP 参与者角色。

javax.xml.ws.http 中 String 的使用

声明为 String 的 javax.xml.ws.http 中的字段

static String

HTTPBinding.HTTP_BINDING
表示 XML/HTTP 绑定标识的常量。

javax.xml.ws.soap 中 String 的使用

声明为 String 的 javax.xml.ws.soap 中的字段

static String

SOAPBinding.SOAP11HTTP_BINDING
表示 HTTP 绑定上的 SOAP 1.1 标识的常量。

static String

SOAPBinding.SOAP11HTTP_MTOM_BINDING
表示 HTTP 绑定上的 SOAP 1.1 标识，且默认启用 MTOM 的常量。

static String

SOAPBinding.SOAP12HTTP_BINDING
表示 HTTP 绑定上的 SOAP 1.2 标识的常量。

static String

SOAPBinding.SOAP12HTTP_MTOM_BINDING
表示 HTTP 绑定上的 SOAP 1.2 标识，且默认启用 MTOM 的常量。

返回变量类型为 String 的类型的 javax.xml.ws.soap 中的方法

Set<String>

SOAPBinding.getRoles()
获取 SOAP 绑定实例所扮演的角色。

类型变量类型为 String 的 javax.xml.ws.soap 中的方法参数

void

SOAPBinding.setRoles(Set<String> roles)
设置由 SOAP 绑定实例扮演的角色。

javax.xml.ws.spi 中 String 的使用

声明为 String 的 javax.xml.ws.spi 中的字段

static String

Provider.JAXWSPROVIDER_PROPERTY
表示用于查找 Provider 实现类名称的属性的常量。

参数类型为 String 的 javax.xml.ws.spi 中的方法

abstract  void

ServiceDelegate.addPort(QName portName, String bindingId, String endpointAddress)
为服务创建新的端口。

abstract  Endpoint

Provider.createAndPublishEndpoint(String address, Object implementor)
创建和发布具有指定地址和实现对象的端点对象。

abstract  Endpoint

Provider.createEndpoint(String bindingId, Object implementor)
创建具有提供的绑定和实现对象的端点对象。

javax.xml.xpath 中 String 的使用

声明为 String 的 javax.xml.xpath 中的字段

static String

XPathFactory.DEFAULT_OBJECT_MODEL_URI
默认 Object Model URI。

static String

XPathFactory.DEFAULT_PROPERTY_NAME
遵守 JAXP 规范的默认属性名称。

static String

XPathConstants.DOM_OBJECT_MODEL
DOM 对象模型的 URI，"http://java.sun.com/jaxp/xpath/dom"。

返回 String 的 javax.xml.xpath 中的方法

String

XPathExpression.evaluate(InputSource source)
计算指定 InputSource 上下文中编译后的 XPath 表达式并以 String 形式返回结果。

String

XPathExpression.evaluate(Object item)
计算指定上下文中编译后的 XPath 表达式并以 String 形式返回结果。

String

XPath.evaluate(String expression, InputSource source)
计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。

String

XPath.evaluate(String expression, Object item)
计算指定上下文中的 XPath 表达式并返回 String 形式的结果。

参数类型为 String 的 javax.xml.xpath 中的方法

XPathExpression

XPath.compile(String expression)
编译 XPath 表达式供以后计算使用。

String

XPath.evaluate(String expression, InputSource source)
计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。

Object

XPath.evaluate(String expression, InputSource source, QName returnType)
计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。

String

XPath.evaluate(String expression, Object item)
计算指定上下文中的 XPath 表达式并返回 String 形式的结果。

Object

XPath.evaluate(String expression, Object item, QName returnType)
计算指定上下文中的 XPath 表达式并返回指定类型的结果。

abstract  boolean

XPathFactory.getFeature(String name)
获取指定功能的状态。

abstract  boolean

XPathFactory.isObjectModelSupported(String objectModel)
此 XPathFactory 是否支持指定的对象模型

static XPathFactory

XPathFactory.newInstance(String uri)
获取使用指定对象模型的新 XPathFactory 实例。

static XPathFactory

XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader)
根据工厂类名称获取一个新 XPathFactory 实例。

abstract  void

XPathFactory.setFeature(String name, boolean value)
设置此工厂所创建的此 XPathFactory 和 XPath 的功能。

参数类型为 String 的 javax.xml.xpath 中的构造方法

XPathException(String message)
构造带指定详细 message 的新 XPathException。

XPathExpressionException(String message)
构造带指定详细 message 的新 XPathExpressionException。

XPathFactoryConfigurationException(String message)
构造带指定详细 message 的新 XPathFactoryConfigurationException。

XPathFunctionException(String message)
构造带指定详细 message 的新 XPathFunctionException。

org.ietf.jgss 中 String 的使用

返回 String 的 org.ietf.jgss 中的方法

String

GSSException.getMajorString()
返回一个字符串，解释在此异常中 GSS-API 级的主要错误代码。

String

GSSException.getMessage()
返回主要和次要状态码的文本表示形式。

String

GSSException.getMinorString()
返回解释特定于机制的错误代码的字符串。

String

MessageProp.getMinorString()
检索解释次要状态码的字符串。

String

GSSException.toString()
返回主要和次要状态码的文本表示形式。

String

GSSName.toString()
返回 GSSName 对象的文本表示形式。

String

Oid.toString()
返回 oid 用句点符号分隔的整数组件的字符串表示形式。

参数类型为 String 的 org.ietf.jgss 中的方法

abstract  GSSName

GSSManager.createName(String nameStr, Oid nameType)
将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。

abstract  GSSName

GSSManager.createName(String nameStr, Oid nameType, Oid mech)
将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。

void

GSSException.setMinor(int minorCode, String message)
由异常抛出器使用，以设置机制级的次要错误代码及其字符串解释。

void

MessageProp.setSupplementaryStates(boolean duplicate, boolean old, boolean unseq, boolean gap, int minorStatus, String minorString)
此方法将设置 MessageProp 中的增补信息标记的状态和次要状态。

参数类型为 String 的 org.ietf.jgss 中的构造方法

GSSException(int majorCode, int minorCode, String minorString)
使用指定的主要代码、次要代码和次要代码文本性解释，创建一个 GSSException 对象。

Oid(String strOid)
从其整数组件的字符串表示形式中构建 Oid 对象。

org.omg.CORBA 中 String 的使用

声明为 String 的 org.omg.CORBA 中的字段

String

ValueMember.defined_in
用来定义此成员的 value 的存储库 ID。

String

NameValuePair.id
将通过此 NameValuePair 对象与某一值关联的名称。

String

ValueMember.id
此 ValueMember 对象所描述的 value 成员的存储库 ID

String

StructMember.name
此 StructMember 对象所描述的 struct 成员的名称。

String

UnionMember.name
此 UnionMember 对象所描述的 union 成员的名称。

String

ValueMember.name
此 ValueMember 对象所描述的 value 成员的名称。

String

StringHolder.value
此 StringHolder 对象保存的 String 值。

String[]

StringSeqHolder.value

String[]

WStringSeqHolder.value

String

ValueMember.version
用来定义此成员的 value 的版本。

返回 String 的 org.omg.CORBA 中的方法

String[]

DynamicImplementation._ids()
已过时。

String[]

_IDLTypeStub._ids()

String[]

_PolicyStub._ids()

abstract  String

Context.context_name()
检索此 Context 对象的名称。

String

DynStruct.current_member_name()
已过时。 在遍历期间返回当前成员的名称。

String

DynValue.current_member_name()
已过时。 在遍历表示某个 Value 对象的 DynAny 对象时，返回当前成员的名称。

abstract  String

Any.extract_string()
提取此 Any 对象 value 字段中的 String 对象。

abstract  String

Any.extract_wstring()
提取此 Any 对象 value 字段中的 String 对象。

static String

FieldNameHelper.extract(Any a)

static String

IdentifierHelper.extract(Any a)

static String

RepositoryIdHelper.extract(Any a)

static String[]

StringSeqHelper.extract(Any a)

static String

StringValueHelper.extract(Any a)

static String

VersionSpecHelper.extract(Any a)

static String[]

WStringSeqHelper.extract(Any a)

static String

WStringValueHelper.extract(Any a)

String

StringValueHelper.get_id()

String

WStringValueHelper.get_id()

String

DynAny.get_string()
已过时。 检索此 DynAny 对象中包含的 String。

String

DynAny.get_wstring()
已过时。 检索此 DynAny 对象中包含的 String。

static String

AnySeqHelper.id()

static String

BooleanSeqHelper.id()

static String

CharSeqHelper.id()

static String

CompletionStatusHelper.id()

static String

CurrentHelper.id()

static String

DefinitionKindHelper.id()

static String

DoubleSeqHelper.id()

static String

FieldNameHelper.id()

static String

FloatSeqHelper.id()

static String

IDLTypeHelper.id()

static String

IdentifierHelper.id()

static String

LongLongSeqHelper.id()

static String

LongSeqHelper.id()

static String

NameValuePairHelper.id()

static String

ObjectHelper.id()

static String

OctetSeqHelper.id()

static String

ParameterModeHelper.id()

static String

PolicyErrorCodeHelper.id()

static String

PolicyErrorHelper.id()

static String

PolicyHelper.id()

static String

PolicyListHelper.id()

static String

PolicyTypeHelper.id()

static String

RepositoryIdHelper.id()

static String

ServiceDetailHelper.id()

static String

ServiceInformationHelper.id()

static String

SetOverrideTypeHelper.id()

static String

ShortSeqHelper.id()

static String

StringSeqHelper.id()

static String

StringValueHelper.id()

static String

StructMemberHelper.id()

abstract  String

TypeCode.id()
检索全局标识此 TypeCode 对象类型的 RepositoryId。

static String

ULongLongSeqHelper.id()

static String

ULongSeqHelper.id()

static String

UShortSeqHelper.id()

static String

UnionMemberHelper.id()

static String

UnknownUserExceptionHelper.id()

static String

ValueBaseHelper.id()

static String

ValueMemberHelper.id()

static String

VersionSpecHelper.id()

static String

VisibilityHelper.id()

static String

WCharSeqHelper.id()

static String

WStringSeqHelper.id()

static String

WStringValueHelper.id()

static String

WrongTransactionHelper.id()

abstract  String

ContextList.item(int index)
返回位于给定索引的 String 对象。

abstract  String[]

ORB.list_initial_services()
返回最初可用 CORBA 对象引用（比如 "NameService" 和 "InterfaceRepository"）的列表。

String

DynUnion.member_name()
已过时。 允许在没有检查鉴别符值的情况下检测此 union 成员的名称。

abstract  String

TypeCode.member_name(int index)
检索给定索引标识的成员的简单名称。

abstract  String

NamedValue.name()
检索此 NamedValue 对象的名称。

abstract  String

TypeCode.name()
在 TypeCode 对象的封闭作用域内检索标识此对象的简单名称。

abstract  String

ORB.object_to_string(Object obj)
将给定 CORBA 对象引用转换为字符串。

String

ServerRequest.op_name()
已过时。 使用 operation()

abstract  String

Request.operation()
检索将被调用的方法的名称。

String

ServerRequest.operation()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

String

DataInputStream.read_string()
从输入流读取 IDL 字符串值。

String

DataInputStream.read_wstring()
从输入流读取 IDL 宽字符串值。

static String

FieldNameHelper.read(InputStream istream)

static String

IdentifierHelper.read(InputStream istream)

static String

RepositoryIdHelper.read(InputStream istream)

static String[]

StringSeqHelper.read(InputStream istream)

static String

StringValueHelper.read(InputStream istream)

static String

VersionSpecHelper.read(InputStream istream)

static String[]

WStringSeqHelper.read(InputStream istream)

static String

WStringValueHelper.read(InputStream istream)

String

SystemException.toString()
将此异常转换成有代表性的字符串。

String

DynEnum.value_as_string()
已过时。 以字符串形式返回此 DynEnum 中存储的 IDL enum 的值。

参数类型为 String 的 org.omg.CORBA 中的方法

Request

LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

Request

Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。

Request

LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

Request

Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。

boolean

LocalObject._is_a(String repository_id)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

boolean

Object._is_a(String repositoryIdentifier)
检查此对象是否是实现给定接口的类的实例。

Request

LocalObject._request(String operation)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

Request

Object._request(String operation)
创建一个在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。

OutputStream

LocalObject._request(String operation, boolean responseExpected)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

ServantObject

LocalObject._servant_preinvoke(String operation, Class expectedType)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

abstract  NamedValue

NVList.add_item(String item_name, int flags)
创建一个新的 NamedValue 对象，使用给定名称和标志初始化该对象，并将它添加到此 NVList 对象的末尾。

abstract  Any

Request.add_named_in_arg(String name)
使用给定名称创建一个输入参数，并将它添加到此 Request 对象中。

abstract  Any

Request.add_named_inout_arg(String name)
将具有给定名称的输入/输出参数添加到此 Request 对象中。

abstract  Any

Request.add_named_out_arg(String name)
将具有给定名称的输出参数添加到此 Request 对象中。

abstract  NamedValue

NVList.add_value(String item_name, Any val, int flags)
创建一个新的 NamedValue 对象，使用给定名称、值和标志初始化该对象，并将它添加到此 NVList 对象的末尾。

abstract  void

ContextList.add(String ctx)
将 String 对象添加到此 ContextList 对象中。

TypeCode

ORB.create_abstract_interface_tc(String id, String name)
为 IDL 抽象接口创建一个 TypeCode 对象。

abstract  TypeCode

ORB.create_alias_tc(String id, String name, TypeCode original_type)
创建一个表示 IDL alias 的 TypeCode 对象 (typedef)。

abstract  Context

Context.create_child(String child_ctx_name)
创建一个 Context 对象，使用给定字符串作为其名称，并将此 Context 对象设置为其父对象。

abstract  TypeCode

ORB.create_enum_tc(String id, String name, String[] members)
创建一个表示 IDL enum 的 TypeCode 对象。

abstract  TypeCode

ORB.create_enum_tc(String id, String name, String[] members)
创建一个表示 IDL enum 的 TypeCode 对象。

abstract  TypeCode

ORB.create_exception_tc(String id, String name, StructMember[] members)
创建一个表示 IDL exception 的 TypeCode 对象。

abstract  TypeCode

ORB.create_interface_tc(String id, String name)
创建一个表示 IDL interface 的 TypeCode 对象。

abstract  NamedValue

ORB.create_named_value(String s, Any any, int flags)
使用给定名称、值和参数模式标志创建一个 NamedValue 对象。

TypeCode

ORB.create_native_tc(String id, String name)
为 IDL native 类型创建一个 TypeCode 对象。

TypeCode

ORB.create_recursive_tc(String id)
创建一个递归 TypeCode 对象，在创建包含递归的 TypeCodes 期间，该对象充当具体 TypeCode 的占位符。

abstract  TypeCode

ORB.create_struct_tc(String id, String name, StructMember[] members)
创建一个表示 IDL struct 的 TypeCode 对象。

abstract  TypeCode

ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members)
创建一个表示 IDL union 的 TypeCode 对象。

TypeCode

ORB.create_value_box_tc(String id, String name, TypeCode boxed_type)
为 IDL value box 类型创建一个 TypeCode 对象。

TypeCode

ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)
为 IDL value 类型创建一个 TypeCode 对象。

abstract  void

Context.delete_values(String propname)
从此 Context 对象中删除 name 字段与给定属性名称匹配的 NamedValue 对象。

abstract  NVList

Context.get_values(String start_scope, int op_flags, String pattern)
检索 name 字段与给定名称或名称模式匹配的 NamedValue 对象。

static ORB

ORB.init(String[] args, Properties props)
为独立的应用程序创建一个新的 ORB 实例。

abstract  void

Any.insert_string(String s)
将给定 String 对象插入此 Any 对象的 value 字段。

void

DynAny.insert_string(String value)
已过时。 插入给定 String 对象作为此 DynAny 对象的值。

abstract  void

Any.insert_wstring(String s)
将给定 String 对象插入此 Any 对象的 value 字段。

void

DynAny.insert_wstring(String value)
已过时。 插入给定 String 作为此 DynAny 对象的值。

static void

FieldNameHelper.insert(Any a, String that)

static void

IdentifierHelper.insert(Any a, String that)

static void

RepositoryIdHelper.insert(Any a, String that)

static void

StringValueHelper.insert(Any a, String that)

static void

VersionSpecHelper.insert(Any a, String that)

static void

WStringValueHelper.insert(Any a, String that)

static void

StringSeqHelper.insert(Any a, String[] that)

static void

WStringSeqHelper.insert(Any a, String[] that)

void

DynUnion.member_name(String arg)
已过时。 允许分配此 union 成员的名称。

abstract  Object

ORB.resolve_initial_references(String object_name)
根据可用初始服务名称集解析特定对象引用。

abstract  void

Context.set_one_value(String propname, Any propvalue)
创建一个 NamedValue 对象，并将它添加到此 Context 对象中。

protected abstract  void

ORB.set_parameters(String[] args, Properties props)
允许使用给定的参数和属性初始化 ORB 实现。

abstract  Object

ORB.string_to_object(String str)
将方法 object_to_string 生成的字符串转换回 CORBA 对象引用。

void

DynEnum.value_as_string(String arg)
已过时。 设置此 DynEnum 中的特定 enum。

void

DataOutputStream.write_string(String value)
将 IDL string 值写入输出流。

void

DataOutputStream.write_wstring(String value)
将 IDL 宽字符串值（以 Java String 的形式表示）写入输出流。

static void

FieldNameHelper.write(OutputStream ostream, String value)

static void

IdentifierHelper.write(OutputStream ostream, String value)

static void

RepositoryIdHelper.write(OutputStream ostream, String value)

static void

StringValueHelper.write(OutputStream ostream, String value)

static void

VersionSpecHelper.write(OutputStream ostream, String value)

static void

WStringValueHelper.write(OutputStream ostream, String value)

static void

StringSeqHelper.write(OutputStream ostream, String[] value)

static void

WStringSeqHelper.write(OutputStream ostream, String[] value)

参数类型为 String 的 org.omg.CORBA 中的构造方法

ACTIVITY_COMPLETED(String detailMessage)
使用指定消息构造 ACTIVITY_COMPLETED 异常。

ACTIVITY_COMPLETED(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。

ACTIVITY_REQUIRED(String detailMessage)
使用指定消息构造一个 ACTIVITY_REQUIRED 异常。

ACTIVITY_REQUIRED(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。

BAD_CONTEXT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_CONTEXT 异常。

BAD_CONTEXT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_CONTEXT 异常。

BAD_INV_ORDER(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_INV_ORDER 异常。

BAD_INV_ORDER(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_INV_ORDER 异常。

BAD_OPERATION(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_OPERATION 异常。

BAD_OPERATION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_OPERATION 异常。

BAD_PARAM(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_PARAM 异常。

BAD_PARAM(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_PARAM 异常。

BAD_QOS(String detailMessage)
使用指定消息构造一个 BAD_QOS 异常。

BAD_QOS(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 BAD_QOS 异常。

BAD_TYPECODE(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_TYPECODE 异常。

BAD_TYPECODE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_TYPECODE 异常。

Bounds(String reason)
构造带指定详细消息的 Bounds。

CODESET_INCOMPATIBLE(String detailMessage)
使用指定消息构造一个 CODESET_INCOMPATIBLE 异常。

CODESET_INCOMPATIBLE(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。

COMM_FAILURE(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 COMM_FAILURE 异常。

COMM_FAILURE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 COMM_FAILURE 异常。

DATA_CONVERSION(String s)
使用指定详细消息构造一个 DATA_CONVERSION 异常。

DATA_CONVERSION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 DATA_CONVERSION 异常。

FREE_MEM(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 FREE_MEM 异常。

FREE_MEM(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 FREE_MEM 异常。

IMP_LIMIT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 IMP_LIMIT 异常。

IMP_LIMIT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 IMP_LIMIT 异常。

INITIALIZE(String s)
使用指定详细消息、次要代码 0 和完成状态 CompletionStatus.COMPLETED_NO 构造一个 INITIALIZE 异常。

INITIALIZE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INITIALIZE 异常。

INTERNAL(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTERNAL 异常。

INTERNAL(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTERNAL 异常。

INTF_REPOS(String s)
使用指定详细消息构造一个 INTF_REPOS 异常。

INTF_REPOS(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTF_REPOS 异常。

INV_FLAG(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_FLAG 异常。

INV_FLAG(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_FLAG 异常。

INV_IDENT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_IDENT 异常。

INV_IDENT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_IDENT 异常。

INV_OBJREF(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_OBJREF 异常。

INV_OBJREF(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_OBJREF 异常。

INV_POLICY(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_POLICY 异常。

INV_POLICY(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 INV_POLICY 异常。

INVALID_ACTIVITY(String detailMessage)
使用指定消息构造一个 INVALID_ACTIVITY 异常。

INVALID_ACTIVITY(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。

INVALID_TRANSACTION(String s)
使用指定消息构造一个 INVALID_TRANSACTION 异常。

INVALID_TRANSACTION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。

MARSHAL(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 MARSHAL 异常。

MARSHAL(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 MARSHAL 异常。

NameValuePair(String __id, Any __value)
构造一个 NameValuePair 对象，该对象将给定名称与给定 org.omg.CORBA.Any 对象关联。

NO_IMPLEMENT(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_IMPLEMENT 异常。

NO_IMPLEMENT(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_IMPLEMENT 异常。

NO_MEMORY(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_MEMORY 异常。

NO_MEMORY(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_MEMORY 异常。

NO_PERMISSION(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_PERMISSION 异常。

NO_PERMISSION(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_PERMISSION 异常。

NO_RESOURCES(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESOURCES 异常。

NO_RESOURCES(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESOURCES 异常。

NO_RESPONSE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESPONSE 异常。

NO_RESPONSE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESPONSE 异常。

OBJ_ADAPTER(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJ_ADAPTER 异常。

OBJ_ADAPTER(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJ_ADAPTER 异常。

OBJECT_NOT_EXIST(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJECT_NOT_EXIST 异常。

OBJECT_NOT_EXIST(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。

PERSIST_STORE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 PERSIST_STORE 异常。

PERSIST_STORE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 PERSIST_STORE 异常。

PolicyError(String reason_string, short __reason)
构造一个 PolicyError 用户异常，并使用给定原因详细消息和原因代码初始化。

REBIND(String detailMessage)
使用指定消息构造一个 REBIND 异常。

REBIND(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 REBIND 异常。

StringHolder(String initial)
构造一个新的 StringHolder 对象，并使用给定 String 初始化其 value 字段。

StringSeqHolder(String[] initialValue)

StructMember(String __name, TypeCode __type, IDLType __type_def)
构造一个 StructMember 对象，并使用给定值进行初始化。

SystemException(String reason, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 SystemException 异常。

TIMEOUT(String detailMessage)
使用指定消息构造一个 TIMEOUT 异常。

TIMEOUT(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 TIMEOUT 异常。

TRANSACTION_MODE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_MODE 异常。

TRANSACTION_MODE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_MODE 异常。

TRANSACTION_REQUIRED(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_REQUIRED 异常。

TRANSACTION_REQUIRED(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。

TRANSACTION_ROLLEDBACK(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_ROLLEDBACK 异常。

TRANSACTION_ROLLEDBACK(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。

TRANSACTION_UNAVAILABLE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_UNAVAILABLE 异常。

TRANSACTION_UNAVAILABLE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。

TRANSIENT(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSIENT 异常。

TRANSIENT(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSIENT 异常。

UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
构造一个新的 UnionMember 对象，将其字段初始化为给定值。

UNKNOWN(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 UNKNOWN 异常。

UNKNOWN(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 UNKNOWN 异常。

UserException(String reason)
构造带详细消息的 UserException 对象。

ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
构造一个 ValueMember 对象，使用给定值进行初始化。

WrongTransaction(String reason)
使用给定详细消息构造一个 WrongTransaction 对象。

WStringSeqHolder(String[] initialValue)

org.omg.CORBA_2_3 中 String 的使用

参数类型为 String 的 org.omg.CORBA_2_3 中的方法

Object

ORB.get_value_def(String repid)

ValueFactory

ORB.lookup_value_factory(String id)

ValueFactory

ORB.register_value_factory(String id, ValueFactory factory)

void

ORB.unregister_value_factory(String id)

org.omg.CORBA_2_3.portable 中 String 的使用

返回 String 的 org.omg.CORBA_2_3.portable 中的方法

String

ObjectImpl._get_codebase()
返回此对象引用的代码基。

String

Delegate.get_codebase(Object self)
返回提供的对象引用的代码基。

参数类型为 String 的 org.omg.CORBA_2_3.portable 中的方法

Serializable

InputStream.read_value(String rep_id)
从输入流解组值类型。

void

OutputStream.write_value(Serializable value, String repository_id)
将值类型编组到输出流中。

org.omg.CORBA.DynAnyPackage 中 String 的使用

参数类型为 String 的 org.omg.CORBA.DynAnyPackage 中的构造方法

Invalid(String reason)
构造一个 Invalid 对象。

InvalidSeq(String reason)
构造一个 InvalidSeq 对象。

InvalidValue(String reason)
构造一个 InvalidValue 对象。

TypeMismatch(String reason)
构造一个 TypeMismatch 对象。

org.omg.CORBA.ORBPackage 中 String 的使用

参数类型为 String 的 org.omg.CORBA.ORBPackage 中的构造方法

InconsistentTypeCode(String reason)
构造一个带有指定原因信息的 InconsistentTypeCode 用户异常。

InvalidName(String reason)
构造一个带有指定原因消息的 InvalidName 异常。

org.omg.CORBA.portable 中 String 的使用

返回 String 的 org.omg.CORBA.portable 中的方法

abstract  String[]

ObjectImpl._ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。

String[]

ValueBase._truncatable_ids()
提供可截断的存储库 id。

String

BoxedValueHelper.get_id()

String

ApplicationException.getId()
返回异常的 CORBA 存储库 ID 而不会将其从异常输入流中移除。

abstract  String

InputStream.read_string()
从此输入流中读取一个 string 值。

abstract  String

InputStream.read_wstring()
从此输入流中读取一个 wide string 值。

String

ObjectImpl.toString()
返回表示此 ObjectImpl 对象的 String 对象。

String

Delegate.toString(Object self)
提供重写委托 CORBA 对象的 toString() 方法的实现。

参数类型为 String 的 org.omg.CORBA.portable 中的方法

Request

ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。

Request

ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。

OutputStream

InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
由 ORB 调用来调度对 servant 的请求。

boolean

ObjectImpl._is_a(String repository_id)
检查给定存储库标识符标识的对象是否是 ObjectImpl 对象。

Request

ObjectImpl._request(String operation)
创建一个 Request 对象，使其包含可用于动态调用接口 (Dynamic Invocation Interface) 的给定方法。

OutputStream

ObjectImpl._request(String operation, boolean responseExpected)
返回一个 OutputStream 对象，该对象用于编组给定方法的参数。

ServantObject

ObjectImpl._servant_preinvoke(String operation, Class expectedType)
返回对本地 servant 的 Java 引用，该引用应该被用来发送对指定方法的请求。

abstract  Request

Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
创建在动态调用接口中使用的 Request 实例。

abstract  Request

Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
创建在动态调用接口中使用的 Request 实例。

abstract  boolean

Delegate.is_a(Object obj, String repository_id)
检查对象引用是否是给定接口的实例。

abstract  Request

Delegate.request(Object obj, String operation)
创建在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。

OutputStream

Delegate.request(Object self, String operation, boolean responseExpected)
request 由 stub 调用，以获取用于编组参数的 OutputStream。

ServantObject

Delegate.servant_preinvoke(Object self, String operation, Class expectedType)
返回对应该用作此请求的 servant 的 Java 引用。

void

ValueOutputStream.start_value(String rep_id)
start_value 方法结束任何当前开启的程序块，写入嵌套自定义 valuetype 的 valuetype 头（使用 null 代码基和指定的存储库 ID），并将 valuetype 嵌套层次加 1。

abstract  void

OutputStream.write_string(String value)
将一个 string 值写入此流。

abstract  void

OutputStream.write_wstring(String value)
将一个 wide string 值写入此流。

参数类型为 String 的 org.omg.CORBA.portable 中的构造方法

ApplicationException(String id, InputStream ins)
根据异常的 CORBA 存储库 ID 和一个输入流（可从中读取异常数据作为其参数）构造 ApplicationException。

org.omg.CORBA.TypeCodePackage 中 String 的使用

参数类型为 String 的 org.omg.CORBA.TypeCodePackage 中的构造方法

BadKind(String reason)
构造一个带有指定原因消息的 BadKind 异常。

Bounds(String reason)
构造一个带有指定原因信息的 Bounds 异常。

org.omg.CosNaming 中 String 的使用

声明为 String 的 org.omg.CosNaming 中的字段

String

NameComponent.id

String

NameComponent.kind

返回 String 的 org.omg.CosNaming 中的方法

String[]

BindingIteratorPOA._all_interfaces(POA poa, byte[] objectId)

String[]

NamingContextExtPOA._all_interfaces(POA poa, byte[] objectId)

String[]

NamingContextPOA._all_interfaces(POA poa, byte[] objectId)

String[]

_BindingIteratorImplBase._ids()

String[]

_BindingIteratorStub._ids()

String[]

_NamingContextExtStub._ids()

String[]

_NamingContextImplBase._ids()

String[]

_NamingContextStub._ids()

static String

IstringHelper.extract(Any a)

static String

BindingHelper.id()

static String

BindingIteratorHelper.id()

static String

BindingListHelper.id()

static String

BindingTypeHelper.id()

static String

IstringHelper.id()

static String

NameComponentHelper.id()

static String

NameHelper.id()

static String

NamingContextExtHelper.id()

static String

NamingContextHelper.id()

static String

IstringHelper.read(InputStream istream)

String

NamingContextExtOperations.to_string(NameComponent[] n)
此操作根据 Name 组件数组创建字符串化的名称。

String

_NamingContextExtStub.to_string(NameComponent[] n)
此操作从 Name 组件数组创建字符串化的名称。

String

NamingContextExtOperations.to_url(String addr, String sn)
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

String

_NamingContextExtStub.to_url(String addr, String sn)
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

参数类型为 String 的 org.omg.CosNaming 中的方法

OutputStream

BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

OutputStream

NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

OutputStream

NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

static void

IstringHelper.insert(Any a, String that)

Object

NamingContextExtOperations.resolve_str(String sn)
此操作将“字符串化的”名称解析为对象引用。

Object

_NamingContextExtStub.resolve_str(String sn)
此操作将“字符串化的”名称解析为对象引用。

NameComponent[]

NamingContextExtOperations.to_name(String sn)
此操作将“字符串化的名称”转换为等效的“名称组件”数组。

NameComponent[]

_NamingContextExtStub.to_name(String sn)
此操作将“字符串化的名称”转换为等效的“名称组件”数组。

String

NamingContextExtOperations.to_url(String addr, String sn)
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

String

_NamingContextExtStub.to_url(String addr, String sn)
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

static void

IstringHelper.write(OutputStream ostream, String value)

参数类型为 String 的 org.omg.CosNaming 中的构造方法

NameComponent(String _id, String _kind)

org.omg.CosNaming.NamingContextExtPackage 中 String 的使用

返回 String 的 org.omg.CosNaming.NamingContextExtPackage 中的方法

static String

AddressHelper.extract(Any a)

static String

StringNameHelper.extract(Any a)

static String

URLStringHelper.extract(Any a)

static String

AddressHelper.id()

static String

InvalidAddressHelper.id()

static String

StringNameHelper.id()

static String

URLStringHelper.id()

static String

AddressHelper.read(InputStream istream)

static String

StringNameHelper.read(InputStream istream)

static String

URLStringHelper.read(InputStream istream)

参数类型为 String 的 org.omg.CosNaming.NamingContextExtPackage 中的方法

static void

AddressHelper.insert(Any a, String that)

static void

StringNameHelper.insert(Any a, String that)

static void

URLStringHelper.insert(Any a, String that)

static void

AddressHelper.write(OutputStream ostream, String value)

static void

StringNameHelper.write(OutputStream ostream, String value)

static void

URLStringHelper.write(OutputStream ostream, String value)

参数类型为 String 的 org.omg.CosNaming.NamingContextExtPackage 中的构造方法

InvalidAddress(String $reason)

org.omg.CosNaming.NamingContextPackage 中 String 的使用

返回 String 的 org.omg.CosNaming.NamingContextPackage 中的方法

static String

AlreadyBoundHelper.id()

static String

CannotProceedHelper.id()

static String

InvalidNameHelper.id()

static String

NotEmptyHelper.id()

static String

NotFoundHelper.id()

static String

NotFoundReasonHelper.id()

参数类型为 String 的 org.omg.CosNaming.NamingContextPackage 中的构造方法

AlreadyBound(String $reason)

CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)

InvalidName(String $reason)

NotEmpty(String $reason)

NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)

org.omg.DynamicAny 中 String 的使用

声明为 String 的 org.omg.DynamicAny 中的字段

String

NameDynAnyPair.id
与 DynAny 关联的名称。

String

NameValuePair.id
与 Any 有关联的名称。

返回 String 的 org.omg.DynamicAny 中的方法

String[]

_DynAnyFactoryStub._ids()

String[]

_DynAnyStub._ids()

String[]

_DynArrayStub._ids()

String[]

_DynEnumStub._ids()

String[]

_DynFixedStub._ids()

String[]

_DynSequenceStub._ids()

String[]

_DynStructStub._ids()

String[]

_DynUnionStub._ids()

String[]

_DynValueStub._ids()

String

DynStructOperations.current_member_name()
返回当前位置的成员的名称。

String

DynValueOperations.current_member_name()
返回当前位置上的成员的名称。

String

_DynStructStub.current_member_name()
返回当前位置上的成员的名称。

String

_DynValueStub.current_member_name()
返回当前位置上成员的名称。

static String

FieldNameHelper.extract(Any a)

String

DynEnumOperations.get_as_string()
以 IDL 标识符的形式返回 DynEnum 的值。

String

_DynEnumStub.get_as_string()
以 IDL 标识符的形式返回 DynEnum 的值。

String

DynAnyOperations.get_string()
从此 DynAny 中提取 string 值。

String

_DynAnyStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynArrayStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynEnumStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynFixedStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynSequenceStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynStructStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynUnionStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynValueStub.get_string()
从此 DynAny 中提取 string 值。

String

DynFixedOperations.get_value()
返回 DynFixed 的值。

String

_DynFixedStub.get_value()
返回 DynFixed 的值。

String

DynAnyOperations.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynAnyStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynArrayStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynEnumStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynFixedStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynSequenceStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynStructStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynUnionStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynValueStub.get_wstring()
从此 DynAny 中提取 string 值。

static String

AnySeqHelper.id()

static String

DynAnyFactoryHelper.id()

static String

DynAnyHelper.id()

static String

DynAnySeqHelper.id()

static String

DynArrayHelper.id()

static String

DynEnumHelper.id()

static String

DynFixedHelper.id()

static String

DynSequenceHelper.id()

static String

DynStructHelper.id()

static String

DynUnionHelper.id()

static String

DynValueHelper.id()

static String

FieldNameHelper.id()

static String

NameDynAnyPairHelper.id()

static String

NameDynAnyPairSeqHelper.id()

static String

NameValuePairHelper.id()

static String

NameValuePairSeqHelper.id()

String

DynUnionOperations.member_name()
返回当前活动成员的名称。

String

_DynUnionStub.member_name()
返回当前活动成员的名称。

static String

FieldNameHelper.read(InputStream istream)

参数类型为 String 的 org.omg.DynamicAny 中的方法

void

DynAnyOperations.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynAnyStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynArrayStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynEnumStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynFixedStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynSequenceStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynStructStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynUnionStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynValueStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

DynAnyOperations.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynAnyStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynArrayStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynEnumStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynFixedStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynSequenceStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynStructStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynUnionStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynValueStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

static void

FieldNameHelper.insert(Any a, String that)

void

DynEnumOperations.set_as_string(String value)
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。

void

_DynEnumStub.set_as_string(String value)
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。

boolean

DynFixedOperations.set_value(String val)
设置 DynFixed 的值。

boolean

_DynFixedStub.set_value(String val)
设置 DynFixed 的值。

static void

FieldNameHelper.write(OutputStream ostream, String value)

参数类型为 String 的 org.omg.DynamicAny 中的构造方法

NameDynAnyPair(String _id, DynAny _value)

NameValuePair(String _id, Any _value)

org.omg.DynamicAny.DynAnyFactoryPackage 中 String 的使用

返回 String 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法

static String

InconsistentTypeCodeHelper.id()

参数类型为 String 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的构造方法

InconsistentTypeCode(String $reason)

org.omg.DynamicAny.DynAnyPackage 中 String 的使用

返回 String 的 org.omg.DynamicAny.DynAnyPackage 中的方法

static String

InvalidValueHelper.id()

static String

TypeMismatchHelper.id()

参数类型为 String 的 org.omg.DynamicAny.DynAnyPackage 中的构造方法

InvalidValue(String $reason)

TypeMismatch(String $reason)

org.omg.IOP 中 String 的使用

声明为 String 的 org.omg.IOP 中的字段

String

IOR.type_id
以 String 形式表示的类型 id。

返回 String 的 org.omg.IOP 中的方法

static String

CodecFactoryHelper.id()

static String

ComponentIdHelper.id()

static String

IORHelper.id()

static String

MultipleComponentProfileHelper.id()

static String

ProfileIdHelper.id()

static String

ServiceContextHelper.id()

static String

ServiceContextListHelper.id()

static String

ServiceIdHelper.id()

static String

TaggedComponentHelper.id()

static String

TaggedProfileHelper.id()

参数类型为 String 的 org.omg.IOP 中的构造方法

IOR(String _type_id, TaggedProfile[] _profiles)

org.omg.IOP.CodecFactoryPackage 中 String 的使用

返回 String 的 org.omg.IOP.CodecFactoryPackage 中的方法

static String

UnknownEncodingHelper.id()

参数类型为 String 的 org.omg.IOP.CodecFactoryPackage 中的构造方法

UnknownEncoding(String $reason)

org.omg.IOP.CodecPackage 中 String 的使用

返回 String 的 org.omg.IOP.CodecPackage 中的方法

static String

FormatMismatchHelper.id()

static String

InvalidTypeForEncodingHelper.id()

static String

TypeMismatchHelper.id()

参数类型为 String 的 org.omg.IOP.CodecPackage 中的构造方法

FormatMismatch(String $reason)

InvalidTypeForEncoding(String $reason)

TypeMismatch(String $reason)

org.omg.Messaging 中 String 的使用

返回 String 的 org.omg.Messaging 中的方法

static String

SyncScopeHelper.id()

org.omg.PortableInterceptor 中 String 的使用

返回 String 的 org.omg.PortableInterceptor 中的方法

String[]

ObjectReferenceTemplate.adapter_name()

String[]

ServerRequestInfoOperations.adapter_name()
返回字符串序列，这些字符串标识正处理此请求的对象适配器实例。

String[]

ORBInitInfoOperations.arguments()
返回传递给 ORB.init 的参数。

String[]

RequestInfoOperations.contexts()
返回一个 String 对象数组，这些对象描述可以在此操作调用上传递的上下文。

static String[]

AdapterNameHelper.extract(Any a)

static String

ORBIdHelper.extract(Any a)

static String

ServerIdHelper.extract(Any a)

static String

AdapterManagerIdHelper.id()

static String

AdapterNameHelper.id()

static String

AdapterStateHelper.id()

static String

CurrentHelper.id()

static String

ForwardRequestHelper.id()

static String

IORInterceptor_3_0Helper.id()

static String

InvalidSlotHelper.id()

static String

ORBIdHelper.id()

static String

ObjectIdHelper.id()

static String

ObjectReferenceFactoryHelper.id()

static String

ObjectReferenceTemplateHelper.id()

static String

ObjectReferenceTemplateSeqHelper.id()

static String

ServerIdHelper.id()

String

InterceptorOperations.name()
返回 interceptor 的名称。

String[]

RequestInfoOperations.operation_context()
返回一个 String 对象数组，这些对象包含将在请求上发送上下文。

String

RequestInfoOperations.operation()
返回将被调用的操作的名称。

String

ORBInitInfoOperations.orb_id()
返回将被初始化的 ORB 的 ID。

String

ObjectReferenceTemplate.orb_id()

String

ServerRequestInfoOperations.orb_id()
返回用于创建 ORB 的 ID。

static String[]

AdapterNameHelper.read(InputStream istream)

static String

ORBIdHelper.read(InputStream istream)

static String

ServerIdHelper.read(InputStream istream)

String

ClientRequestInfoOperations.received_exception_id()
返回将向客户端返回的异常的存储库 id。

String

ObjectReferenceTemplate.server_id()

String

ServerRequestInfoOperations.server_id()
返回使用 -ORBServerId 参数的 ORB::init 上指定的服务器 ID。

String

ServerRequestInfoOperations.target_most_derived_interface()
返回 servant 最终派生接口的存储库 id。

参数类型为 String 的 org.omg.PortableInterceptor 中的方法

static void

ORBIdHelper.insert(Any a, String that)

static void

ServerIdHelper.insert(Any a, String that)

static void

AdapterNameHelper.insert(Any a, String[] that)

Object

ObjectReferenceFactory.make_object(String repositoryId, byte[] object_id)
make_object 根据此模板中的数据，使用给定的存储库 ID 和对象 ID 创建 CORBA 对象引用。

void

ORBInitInfoOperations.register_initial_reference(String id, Object obj)
等同于 ORB.register_initial_reference。

Object

ORBInitInfoOperations.resolve_initial_references(String id)
等同于 ORB.resolve_initial_references。

boolean

ServerRequestInfoOperations.target_is_a(String id)
如果 servant 是给定的存储库 id，则返回 true；若不是则返回 false。

static void

ORBIdHelper.write(OutputStream ostream, String value)

static void

ServerIdHelper.write(OutputStream ostream, String value)

static void

AdapterNameHelper.write(OutputStream ostream, String[] value)

参数类型为 String 的 org.omg.PortableInterceptor 中的构造方法

ForwardRequest(String $reason, Object _forward)

InvalidSlot(String $reason)

org.omg.PortableInterceptor.ORBInitInfoPackage 中 String 的使用

声明为 String 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的字段

String

DuplicateName.name
已为其注册了 interceptor 的名称。

返回 String 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法

static String

ObjectIdHelper.extract(Any a)

static String

DuplicateNameHelper.id()

static String

InvalidNameHelper.id()

static String

ObjectIdHelper.id()

static String

ObjectIdHelper.read(InputStream istream)

参数类型为 String 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法

static void

ObjectIdHelper.insert(Any a, String that)

static void

ObjectIdHelper.write(OutputStream ostream, String value)

参数类型为 String 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的构造方法

DuplicateName(String _name)

DuplicateName(String $reason, String _name)

InvalidName(String $reason)

org.omg.PortableServer 中 String 的使用

返回 String 的 org.omg.PortableServer 中的方法

abstract  String[]

Servant._all_interfaces(POA poa, byte[] objectId)
ORB 使用此操作从 servant 获取完整的类型信息。

String[]

ServantActivatorPOA._all_interfaces(POA poa, byte[] objectId)

String[]

ServantLocatorPOA._all_interfaces(POA poa, byte[] objectId)

String[]

_ServantActivatorStub._ids()

String[]

_ServantLocatorStub._ids()

static String

CurrentHelper.id()

static String

ForwardRequestHelper.id()

static String

POAHelper.id()

static String

ServantActivatorHelper.id()

static String

ServantLocatorHelper.id()

String

POAOperations.the_name()
此属性标识相对于其父 POA 的 POA。

参数类型为 String 的 org.omg.PortableServer 中的方法

OutputStream

ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

OutputStream

ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

boolean

Servant._is_a(String repository_id)
查看指定的 repository_id 是否存在于 _all_interfaces() 返回的列表，或者其是否是一般 CORBA 对象的 repository_id。

POA

POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。

Object

POAOperations.create_reference_with_id(byte[] oid, String intf)
此操作创建一个对象引用，该引用封装指定的 Object Id 和接口存储库 Id 值。

Object

POAOperations.create_reference(String intf)
此操作创建一个对象引用，该引用封装 POA 生成的 Object Id 值和指定的接口存储库 id。

POA

POAOperations.find_POA(String adapter_name, boolean activate_it)
如果目标 POA 是具有指定名称的子 POA（相对于目标 POA）的父 POA，则返回该子 POA。

void

ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
servant 完成请求时都将调用此操作。

void

_ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
servant 完成请求时都将调用此操作。

Servant

ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。

Servant

_ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。

boolean

AdapterActivatorOperations.unknown_adapter(POA parent, String name)
在 ORB 接收对象引用的请求时，如果该对象引用定义不存在的目标 POA，则将调用此操作。

参数类型为 String 的 org.omg.PortableServer 中的构造方法

ForwardRequest(String $reason, Object _forward_reference)

org.omg.PortableServer.CurrentPackage 中 String 的使用

返回 String 的 org.omg.PortableServer.CurrentPackage 中的方法

static String

NoContextHelper.id()

参数类型为 String 的 org.omg.PortableServer.CurrentPackage 中的构造方法

NoContext(String $reason)

org.omg.PortableServer.POAManagerPackage 中 String 的使用

返回 String 的 org.omg.PortableServer.POAManagerPackage 中的方法

static String

AdapterInactiveHelper.id()

参数类型为 String 的 org.omg.PortableServer.POAManagerPackage 中的构造方法

AdapterInactive(String $reason)

org.omg.PortableServer.POAPackage 中 String 的使用

返回 String 的 org.omg.PortableServer.POAPackage 中的方法

static String

AdapterAlreadyExistsHelper.id()

static String

AdapterNonExistentHelper.id()

static String

InvalidPolicyHelper.id()

static String

NoServantHelper.id()

static String

ObjectAlreadyActiveHelper.id()

static String

ObjectNotActiveHelper.id()

static String

ServantAlreadyActiveHelper.id()

static String

ServantNotActiveHelper.id()

static String

WrongAdapterHelper.id()

static String

WrongPolicyHelper.id()

参数类型为 String 的 org.omg.PortableServer.POAPackage 中的构造方法

AdapterAlreadyExists(String $reason)

AdapterNonExistent(String $reason)

InvalidPolicy(String $reason, short _index)

NoServant(String $reason)

ObjectAlreadyActive(String $reason)

ObjectNotActive(String $reason)

ServantAlreadyActive(String $reason)

ServantNotActive(String $reason)

WrongAdapter(String $reason)

WrongPolicy(String $reason)

org.omg.PortableServer.portable 中 String 的使用

参数类型为 String 的 org.omg.PortableServer.portable 中的方法

boolean

Delegate.is_a(Servant Self, String Repository_Id)
此方法查看指定的 repid 是否存在于 _all_interfaces() 返回的列表上，或者该 repid 是否是通用 CORBA 对象的存储库 id。

org.omg.stub.java.rmi 中 String 的使用

返回 String 的 org.omg.stub.java.rmi 中的方法

String[]

_Remote_Stub._ids()
返回对象实现的存储库 id 数组。

org.w3c.dom 中 String 的使用

返回 String 的 org.w3c.dom 中的方法

String

Element.getAttribute(String name)
通过名称获得属性值。

String

Element.getAttributeNS(String namespaceURI, String localName)
通过本地名称和名称空间 URI 获得属性值。

String

Node.getBaseURI()
此节点的绝对基 URI；如果实现不能获得绝对 URI，则为 null。

String

ProcessingInstruction.getData()
此处理指令的内容。

String

CharacterData.getData()
实现此接口的节点的字符数据。

String

Document.getDocumentURI()
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。

String

Entity.getInputEncoding()
当实体为外部解析实体时，它是在解析时用于此实体的指定编码的属性。

String

Document.getInputEncoding()
指定解析时此文档使用的编码的属性。

String

DocumentType.getInternalSubset()
以字符串表示的内部子集，如果没有内部子集，则为 null。

String

Node.getLocalName()
返回此节点限定名称的本地部分。

String

DOMError.getMessage()
描述所发生错误的特定于实现的字符串。

String

DocumentType.getName()
DTD 的名称；即紧跟在 DOCTYPE 关键字后面的名称。

String

Attr.getName()
返回此属性的名称。

String

NameList.getName(int index)
返回集合中的第 index 个名称项。

String

Node.getNamespaceURI()
此节点的名称空间 URI；如果它未被指定，则返回 null（参见）。

String

NameList.getNamespaceURI(int index)
返回集合中的第 index 个 namespaceURI 项。

String

Node.getNodeName()
此节点的名称，取决于其类型；参见上表。

String

Node.getNodeValue()
此节点的值，取决于其类型；参见上表。

String

Entity.getNotationName()
对于未解析实体，则为该实体的表示法名称。

String

Node.getPrefix()
此节点的名称空间前缀；如果它未被指定，则为 null。

String

Notation.getPublicId()
此表示法的公共标识符。

String

DocumentType.getPublicId()
外部子集的公共标识符。

String

Entity.getPublicId()
如果已指定，则为与实体相关的公共标识符；否则为 null。

String

Notation.getSystemId()
此表示法的系统标识符。

String

DocumentType.getSystemId()
外部子集的系统标识符。

String

Entity.getSystemId()
如果已指定，则为与实体相关的系统标识符；否则为 null。

String

Element.getTagName()
元素的名称。

String

ProcessingInstruction.getTarget()
此处理指令的目标。

String

Node.getTextContent()
此属性返回此节点及其后代的文本内容。

String

DOMError.getType()
DOMString，指示在 relatedData 中哪个相关数据是所期望的。

String

TypeInfo.getTypeName()
为相关元素或属性声明的类型的名称；如果未知，则为 null。

String

TypeInfo.getTypeNamespace()
为相关元素或属性声明的类型的名称空间；如果该元素没有声明或如果没有名称空间信息可用，则为 null。

String

DOMLocator.getUri()
此定位器指向的 URI；如果没有可用的 URI，则为 null。

String

Attr.getValue()
检索时，该属性值以字符串形式返回。

String

Text.getWholeText()
返回 Text 节点（逻辑上与此节点相邻的节点）的以文档顺序串接的所有文本。

String

Entity.getXmlEncoding()
当实体为外部解析实体时，它是作为文本声明的一部分指定此实体的编码的属性。

String

Document.getXmlEncoding()
作为 XML 声明的一部分，指定此文档编码的属性。

String

Entity.getXmlVersion()
当实体为外部解析实体时，它是作为文本声明的一部分指定此实体版本号的属性。

String

Document.getXmlVersion()
作为 XML 声明 的一部分指定此文档版本号的属性。

String

DOMStringList.item(int index)
返回集合中的第 index 个项。

String

Node.lookupNamespaceURI(String prefix)
从此节点开始，查找与给定前缀相关的名称空间 URI。

String

Node.lookupPrefix(String namespaceURI)
从此节点开始，查找与给定名称空间 URI 相关的前缀。

String

CharacterData.substringData(int offset, int count)
从该节点提取某个范围的数据。

参数类型为 String 的 org.w3c.dom 中的方法

void

CharacterData.appendData(String arg)
将字符串追加到节点的字符数据的结尾。

boolean

DOMConfiguration.canSetParameter(String name, Object value)
检查是否支持将参数设置为特定值。

boolean

DOMStringList.contains(String str)
测试一个字符串是否是此 DOMStringList 的一部分。

boolean

NameList.contains(String str)
测试名称是否是此 NameList 中的一部分。

boolean

NameList.containsNS(String namespaceURI, String name)
测试 namespaceURI/name 对是否是此 NameList 中的一部分。

Attr

Document.createAttribute(String name)
创建给定名称的 Attr。

Attr

Document.createAttributeNS(String namespaceURI, String qualifiedName)
创建给定的限定名称和名称空间 URI 的属性。

CDATASection

Document.createCDATASection(String data)
创建其值为指定字符串的 CDATASection 节点。

Comment

Document.createComment(String data)
创建给定指定字符串的 Comment 节点。

Document

DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
创建具有文档元素的指定类型的 DOM Document 对象。

DocumentType

DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId)
创建空 DocumentType 节点。

Element

Document.createElement(String tagName)
创建指定类型的元素。

Element

Document.createElementNS(String namespaceURI, String qualifiedName)
创建给定的限定名称和名称空间 URI 的元素。

EntityReference

Document.createEntityReference(String name)
创建 EntityReference 对象。

ProcessingInstruction

Document.createProcessingInstruction(String target, String data)
创建给定指定名称和数据字符串的 ProcessingInstruction 节点。

Text

Document.createTextNode(String data)
创建给定指定字符串的 Text 节点。

String

Element.getAttribute(String name)
通过名称获得属性值。

Attr

Element.getAttributeNode(String name)
通过名称获得属性节点。

Attr

Element.getAttributeNodeNS(String namespaceURI, String localName)
通过本地名称和名称空间 URI 获得 Attr 节点。

String

Element.getAttributeNS(String namespaceURI, String localName)
通过本地名称和名称空间 URI 获得属性值。

DOMImplementation

DOMImplementationSource.getDOMImplementation(String features)
请求支持指定的功能的第一个 DOM 实现的方法。

DOMImplementationList

DOMImplementationSource.getDOMImplementationList(String features)
请求支持指定功能和版本的 DOM 实现的列表的方法，如下所述。

Element

Document.getElementById(String elementId)
返回具有带给定值的 ID 属性的 Element。

NodeList

Element.getElementsByTagName(String name)
以文档顺序返回具有给定标记名称的所有后代 Elements 的 NodeList。

NodeList

Document.getElementsByTagName(String tagname)
按文档顺序返回包含在文档中且具有给定标记名称的所有 Element 的 NodeList。

NodeList

Element.getElementsByTagNameNS(String namespaceURI, String localName)
以文档顺序返回具有给定本地名称和名称空间 URI 的所有后代 Elements 的 NodeList。

NodeList

Document.getElementsByTagNameNS(String namespaceURI, String localName)
以文档顺序返回具有给定本地名称和名称空间 URI 的所有 Elements 的 NodeList。

Object

DOMImplementation.getFeature(String feature, String version)
此方法返回一个特定的对象，该对象实现了 DOM Features 中所指定的特定特性或版本的特殊 API。

Object

Node.getFeature(String feature, String version)
此方法返回一个特定的对象，该对象实现指定功能或版本的特定 API，如下所述。

Node

NamedNodeMap.getNamedItem(String name)
检索通过名称指定的节点。

Node

NamedNodeMap.getNamedItemNS(String namespaceURI, String localName)
检索通过本地名称和名称空间 URI 指定的节点。

Object

DOMConfiguration.getParameter(String name)
如果已知，则返回参数的值。

Object

Node.getUserData(String key)
检索与此节点上的某个键相关联的对象。

void

UserDataHandler.handle(short operation, String key, Object data, Node src, Node dst)
每当导入或克隆为其注册此处理程序的节点时，调用此方法。

boolean

Element.hasAttribute(String name)
当具有给定名称的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。

boolean

Element.hasAttributeNS(String namespaceURI, String localName)
当具有给定本地名称和名称空间 URI 的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。

boolean

DOMImplementation.hasFeature(String feature, String version)
测试 DOM 实现是否实现在 DOM Features 中指定的特定特性和版本。

void

CharacterData.insertData(int offset, String arg)
在指定的 16 位单元偏移量位置插入一个字符串。

boolean

Node.isDefaultNamespace(String namespaceURI)
此方法检查指定的 namespaceURI 是否是默认名称空间。

boolean

TypeInfo.isDerivedFrom(String typeNamespaceArg, String typeNameArg, int derivationMethod)
此方法返回引用类型定义（即在其上调用该方法的 TypeInfo）和其他类型定义（即作为参数传递的类型定义）之间是否存在派生。

boolean

Node.isSupported(String feature, String version)
测试 DOM 实现是否实现特定功能，且该功能是否受此节点支持，如下所述。

String

Node.lookupNamespaceURI(String prefix)
从此节点开始，查找与给定前缀相关的名称空间 URI。

String

Node.lookupPrefix(String namespaceURI)
从此节点开始，查找与给定名称空间 URI 相关的前缀。

void

Element.removeAttribute(String name)
通过名称移除一个属性。

void

Element.removeAttributeNS(String namespaceURI, String localName)
通过本地名称和名称空间 URI 移除属性值。

Node

NamedNodeMap.removeNamedItem(String name)
移除通过名称指定的节点。

Node

NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName)
移除通过本地名称和名称空间 URI 指定的节点。

Node

Document.renameNode(Node n, String namespaceURI, String qualifiedName)
重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。

void

CharacterData.replaceData(int offset, int count, String arg)
用指定的字符串替换从指定 16 位单元偏移量起始的字符。

Text

Text.replaceWholeText(String content)
将当前节点和所有逻辑上相邻的文本节点的文本替换为指定的文本。

void

Element.setAttribute(String name, String value)
添加一个新属性。

void

Element.setAttributeNS(String namespaceURI, String qualifiedName, String value)
添加新属性。

void

ProcessingInstruction.setData(String data)
此处理指令的内容。

void

CharacterData.setData(String data)
实现此接口的节点的字符数据。

void

Document.setDocumentURI(String documentURI)
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。

void

Element.setIdAttribute(String name, boolean isId)
如果参数 isId 为 true，则此方法将指定的属性声明为用于确定用户的 ID 属性。

void

Element.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。

void

Node.setNodeValue(String nodeValue)
此节点的值，取决于其类型；参见上表。

void

DOMConfiguration.setParameter(String name, Object value)
设置参数的值。

void

Node.setPrefix(String prefix)
此节点的名称空间前缀；如果未指定，则为 null。

void

Node.setTextContent(String textContent)
此属性返回此节点及其后代的文本内容。

Object

Node.setUserData(String key, Object data, UserDataHandler handler)
将对象与此节点上的键相关联。

void

Attr.setValue(String value)
检索时，该属性值以字符串形式返回。

void

Document.setXmlVersion(String xmlVersion)
作为 XML 声明 的一部分指定此文档版本号的属性。

参数类型为 String 的 org.w3c.dom 中的构造方法

DOMException(short code, String message)

org.w3c.dom.bootstrap 中 String 的使用

声明为 String 的 org.w3c.dom.bootstrap 中的字段

static String

DOMImplementationRegistry.PROPERTY
指定 DOMImplementationSource 类名称的系统属性。

参数类型为 String 的 org.w3c.dom.bootstrap 中的方法

DOMImplementation

DOMImplementationRegistry.getDOMImplementation(String features)
返回第一个具有所需功能的实现；如果找不到具有所需功能的任何实现，则返回 null。

DOMImplementationList

DOMImplementationRegistry.getDOMImplementationList(String features)
返回支持所需功能的实现列表。

org.w3c.dom.events 中 String 的使用

返回 String 的 org.w3c.dom.events 中的方法

String

MutationEvent.getAttrName()
attrName 指示 DOMAttrModified 事件中已更改的 Attr 节点的名称。

String

MutationEvent.getNewValue()
newValue 指示 DOMAttrModified 事件中 Attr 节点的新值，以及 DOMCharacterDataModified 中 CharacterData 节点的新值。

String

MutationEvent.getPrevValue()
prevValue 指示 DOMAttrModified 事件中 Attr 节点以前的值，以及 DOMCharacterDataModified 事件中 CharacterData 节点以前的值。

String

Event.getType()
事件的名称（不区分大小写）。

参数类型为 String 的 org.w3c.dom.events 中的方法

void

EventTarget.addEventListener(String type, EventListener listener, boolean useCapture)
此方法允许在事件目标上注册事件侦听器。

Event

DocumentEvent.createEvent(String eventType)

void

Event.initEvent(String eventTypeArg, boolean canBubbleArg, boolean cancelableArg)
initEvent 方法用于初始化通过 DocumentEvent 接口创建的 Event 的值。

void

MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
initMouseEvent 方法用于初始化通过 DocumentEvent 接口创建的 MouseEvent 的值。

void

MutationEvent.initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)
该 initMutationEvent 方法用于初始化通过 DocumentEvent 接口创建的 MutationEvent 的值。

void

UIEvent.initUIEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg)
initUIEvent 方法用于初始化通过 DocumentEvent 接口创建的 UIEvent 的值。

void

EventTarget.removeEventListener(String type, EventListener listener, boolean useCapture)
此方法允许从事件目标移除事件侦听器。

参数类型为 String 的 org.w3c.dom.events 中的构造方法

EventException(short code, String message)

org.w3c.dom.ls 中 String 的使用

返回 String 的 org.w3c.dom.ls 中的方法

String

LSInput.getBaseURI()
基 URI（请参阅 [IETF RFC 2396]中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。

String

LSInput.getEncoding()
字符编码（如果已知）。

String

LSOutput.getEncoding()
用于输出的字符编码。

String

LSSerializer.getNewLine()
在所写出的 XML 中使用的字符的行尾序列。

String

LSInput.getPublicId()
此输入源的公共标识符。

String

LSInput.getStringData()
要解析的字符串数据。

String

LSInput.getSystemId()
系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。

String

LSOutput.getSystemId()
系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。

String

LSSerializer.writeToString(Node nodeArg)
像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。

参数类型为 String 的 org.w3c.dom.ls 中的方法

LSParser

DOMImplementationLS.createLSParser(short mode, String schemaType)
创建一个新的 LSParser。

Document

LSParser.parseURI(String uri)
从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。

LSInput

LSResourceResolver.resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI)
允许应用程序解析外部资源。

void

LSInput.setBaseURI(String baseURI)
基 URI（请参阅 [IETF RFC 2396])中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。

void

LSInput.setEncoding(String encoding)
字符串编码（如果已知）。

void

LSOutput.setEncoding(String encoding)
用于输出的字符编码。

void

LSSerializer.setNewLine(String newLine)
在所写出的 XML 中使用的字符的行尾序列。

void

LSInput.setPublicId(String publicId)
此输入源的公共标识符。

void

LSInput.setStringData(String stringData)
要解析的字符串数据。

void

LSInput.setSystemId(String systemId)
系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。

void

LSOutput.setSystemId(String systemId)
系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。

boolean

LSSerializer.writeToURI(Node nodeArg, String uri)
这是一种简便方法，其作用就像使用没有指定编码的 LSOutput 调用 LSSerializer.write，并且 LSOutput.systemId 被设置为 uri 参数。

参数类型为 String 的 org.w3c.dom.ls 中的构造方法

LSException(short code, String message)

org.xml.sax 中 String 的使用

返回 String 的 org.xml.sax 中的方法

String

InputSource.getEncoding()
获取字节流或 URI 的字符编码。

String

Attributes.getLocalName(int index)
通过索引查找属性的本地名称。

String

SAXException.getMessage()
返回此异常的详细消息。

String

AttributeList.getName(int i)
已过时。 返回此列表中属性的名称（根据位置）。

String

SAXParseException.getPublicId()
获取发生异常的实体的公共标识符。

String

Locator.getPublicId()
返回当前文档事件的公共标识符。

String

InputSource.getPublicId()
获取此输入源的公共标识符。

String

Attributes.getQName(int index)
通过索引查找属性的 XML 限定（前缀）名。

String

SAXParseException.getSystemId()
获取发生异常的实体的系统标识符。

String

Locator.getSystemId()
返回当前文档事件的系统标识符。

String

InputSource.getSystemId()
获取此输入源的系统标识符。

String

Attributes.getType(int index)
通过索引查找属性的类型。

String

AttributeList.getType(int i)
已过时。 返回列表中属性的类型（根据位置）。

String

Attributes.getType(String qName)
通过 XML 限定（前缀）名查找属性的类型。

String

AttributeList.getType(String name)
已过时。 返回列表中属性的类型（根据名称）。

String

Attributes.getType(String uri, String localName)
根据名称空间的名称查找属性的类型。

String

Attributes.getURI(int index)
通过索引查找属性的名称空间 URI。

String

Attributes.getValue(int index)
通过索引查找属性的值。

String

AttributeList.getValue(int i)
已过时。 返回列表中属性的值（根据位置）。

String

Attributes.getValue(String qName)
通过 XML 限定（前缀）名查找属性的值。

String

AttributeList.getValue(String name)
已过时。 返回列表中属性的值（根据名称）。

String

Attributes.getValue(String uri, String localName)
根据名称空间的名称查找属性的值。

String

SAXException.toString()
重写 toString 以获取任何嵌入的异常。

参数类型为 String 的 org.xml.sax 中的方法

void

DocumentHandler.endElement(String name)
已过时。 接收元素结束的通知。

void

HandlerBase.endElement(String name)
已过时。 接收元素结束的通知。

void

ContentHandler.endElement(String uri, String localName, String qName)
接收元素结束的通知。

void

ContentHandler.endPrefixMapping(String prefix)
结束前缀 URI 范围的映射。

boolean

XMLReader.getFeature(String name)
查找功能标志的值。

int

Attributes.getIndex(String qName)
通过 XML 限定（前缀）名查找属性的索引。

int

Attributes.getIndex(String uri, String localName)
通过名称空间的名称查找属性的索引。

Object

XMLReader.getProperty(String name)
查找属性的值。

String

Attributes.getType(String qName)
通过 XML 限定（前缀）名查找属性的类型。

String

AttributeList.getType(String name)
已过时。 返回列表中属性的类型（根据名称）。

String

Attributes.getType(String uri, String localName)
根据名称空间的名称查找属性的类型。

String

Attributes.getValue(String qName)
通过 XML 限定（前缀）名查找属性的值。

String

AttributeList.getValue(String name)
已过时。 返回列表中属性的值（根据名称）。

String

Attributes.getValue(String uri, String localName)
根据名称空间的名称查找属性的值。

void

DTDHandler.notationDecl(String name, String publicId, String systemId)
接收注释声明事件的通知。

void

HandlerBase.notationDecl(String name, String publicId, String systemId)
已过时。 接收注释声明的通知。

void

Parser.parse(String systemId)
已过时。 从系统标识符 (URI) 解析 XML 文档。

void

XMLReader.parse(String systemId)
从系统标识符 (URI) 解析 XML 文档。

void

ContentHandler.processingInstruction(String target, String data)
接收处理指令的通知。

void

DocumentHandler.processingInstruction(String target, String data)
已过时。 接收处理指令的通知。

void

HandlerBase.processingInstruction(String target, String data)
已过时。 接收处理指令的通知。

InputSource

HandlerBase.resolveEntity(String publicId, String systemId)
已过时。 解析外部实体。

InputSource

EntityResolver.resolveEntity(String publicId, String systemId)
允许应用程序解析外部实体。

void

InputSource.setEncoding(String encoding)
设置字符编码（如果已知）。

void

XMLReader.setFeature(String name, boolean value)
设置功能标志的值。

void

XMLReader.setProperty(String name, Object value)
设置属性的值。

void

InputSource.setPublicId(String publicId)
设置此输入源的公共标识符。

void

InputSource.setSystemId(String systemId)
设置此输入源的系统标识符。

void

ContentHandler.skippedEntity(String name)
接收跳过的实体的通知。

void

DocumentHandler.startElement(String name, AttributeList atts)
已过时。 接收元素开始的通知。

void

HandlerBase.startElement(String name, AttributeList attributes)
已过时。 接收元素开始的通知。

void

ContentHandler.startElement(String uri, String localName, String qName, Attributes atts)
接收元素开始的通知。

void

ContentHandler.startPrefixMapping(String prefix, String uri)
开始前缀 URI 名称空间范围映射。

void

DTDHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
接收未解析的实体声明事件的通知。

void

HandlerBase.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
已过时。 接收未解析的实体声明的通知。

参数类型为 String 的 org.xml.sax 中的构造方法

InputSource(String systemId)
使用系统标识符创建新的输入源。

SAXException(String message)
创建一个新的 SAXException。

SAXException(String message, Exception e)
从现有的异常创建新的 SAXException。

SAXNotRecognizedException(String message)
构造带指定的消息的新的异常。

SAXNotSupportedException(String message)
构造带指定消息的新的异常。

SAXParseException(String message, Locator locator)
从消息和 Locator 创建新的 SAXParseException。

SAXParseException(String message, Locator locator, Exception e)
将现有的异常包装在 SAXParseException 中。

SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber)
创建新的 SAXParseException。

SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber, Exception e)
创建带有嵌入异常的新 SAXParseException。

org.xml.sax.ext 中 String 的使用

返回 String 的 org.xml.sax.ext 中的方法

String

Locator2.getEncoding()
返回实体的字符编码的名称。

String

Locator2Impl.getEncoding()
返回编码属性的当前值。

String

Locator2.getXMLVersion()
返回用于该实体的 XML 的版本。

String

Locator2Impl.getXMLVersion()
返回版本属性的当前值。

参数类型为 String 的 org.xml.sax.ext 中的方法

void

Attributes2Impl.addAttribute(String uri, String localName, String qName, String type, String value)
将属性添回到列表的末尾，将其“指定的”标志设置为 true。

void

DeclHandler.attributeDecl(String eName, String aName, String type, String mode, String value)
报告属性类型声明。

void

DefaultHandler2.attributeDecl(String eName, String aName, String type, String mode, String value)

void

DeclHandler.elementDecl(String name, String model)
报告元素类型声明。

void

DefaultHandler2.elementDecl(String name, String model)

void

DefaultHandler2.endEntity(String name)

void

LexicalHandler.endEntity(String name)
报告实体的结束。

void

DeclHandler.externalEntityDecl(String name, String publicId, String systemId)
报告解析的外部实体声明。

void

DefaultHandler2.externalEntityDecl(String name, String publicId, String systemId)

InputSource

DefaultHandler2.getExternalSubset(String name, String baseURI)
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。

InputSource

EntityResolver2.getExternalSubset(String name, String baseURI)
允许应用程序为不能显式定义外部子集的文档提供外部子集。

void

DeclHandler.internalEntityDecl(String name, String value)
报告内部实体声明。

void

DefaultHandler2.internalEntityDecl(String name, String value)

boolean

Attributes2.isDeclared(String qName)
返回 false，除非在 DTD 中声明该属性。

boolean

Attributes2Impl.isDeclared(String qName)
返回属性的“声明的”标志的当前值。

boolean

Attributes2.isDeclared(String uri, String localName)
返回 false，除非在 DTD 中声明属性。

boolean

Attributes2Impl.isDeclared(String uri, String localName)
返回属性的“声明的”标志的当前值。

boolean

Attributes2.isSpecified(String qName)
返回 true，除非由 DTD 默认提供属性值。

boolean

Attributes2Impl.isSpecified(String qName)
返回属性的“指定的”标志的当前值。

boolean

Attributes2.isSpecified(String uri, String localName)
返回 true，除非由 DTD 默认提供属性值。

boolean

Attributes2Impl.isSpecified(String uri, String localName)
返回属性的“指定的”标志的当前值。

InputSource

DefaultHandler2.resolveEntity(String publicId, String systemId)
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。

InputSource

DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。

InputSource

EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。

void

Locator2Impl.setEncoding(String encoding)
分配编码属性的当前值。

void

Locator2Impl.setXMLVersion(String version)
分配版本属性的当前值。

void

DefaultHandler2.startDTD(String name, String publicId, String systemId)

void

LexicalHandler.startDTD(String name, String publicId, String systemId)
报告 DTD 声明的开始（如果存在）。

void

DefaultHandler2.startEntity(String name)

void

LexicalHandler.startEntity(String name)
报告一些内部和外部 XML 实体的开始。

org.xml.sax.helpers 中 String 的使用

声明为 String 的 org.xml.sax.helpers 中的字段

static String

NamespaceSupport.NSDECL
作为常量的名称空间声明 URI。

static String

NamespaceSupport.XMLNS
作为常量的 XML 名称空间 URI。

返回 String 的 org.xml.sax.helpers 中的方法

String

AttributesImpl.getLocalName(int index)
返回属性的本地名称。

String

AttributeListImpl.getName(int i)
已过时。 获取属性名称（按位置）。

String

NamespaceSupport.getPrefix(String uri)
返回映射到名称空间 URI 的前缀之一。

String

LocatorImpl.getPublicId()
返回保存的公开标识符。

String

AttributesImpl.getQName(int index)
返回属性的限定（加前缀的）名称。

String

LocatorImpl.getSystemId()
返回保存的系统标识符。

String

AttributeListImpl.getType(int i)
已过时。 获取属性的类型（按位置）。

String

AttributesImpl.getType(int index)
通过索引返回属性的类型。

String

AttributeListImpl.getType(String name)
已过时。 获取属性的类型（按名称）。

String

AttributesImpl.getType(String qName)
通过限定（加前缀的）名称查找属性的类型。

String

AttributesImpl.getType(String uri, String localName)
通过限定名称空间的名称查找属性的类型。

String

AttributesImpl.getURI(int index)
返回属性的名称空间 URI。

String

NamespaceSupport.getURI(String prefix)
查找前缀，并获取当前映射的名称空间 URI。

String

AttributeListImpl.getValue(int i)
已过时。 获取属性的值（按位置）。

String

AttributesImpl.getValue(int index)
通过索引返回属性的值。

String

AttributeListImpl.getValue(String name)
已过时。 获取属性的值（按名称）。

String

AttributesImpl.getValue(String qName)
通过限定（加前缀的）名称查找属性的值。

String

AttributesImpl.getValue(String uri, String localName)
通过限定名称空间的名称查找属性的值。

String[]

NamespaceSupport.processName(String qName, String[] parts, boolean isAttribute)
declarePrefix() 处理完当前上下文中的所有声明之后，处理原始 XML 限定名称。

参数类型为 String 的 org.xml.sax.helpers 中的方法

void

AttributeListImpl.addAttribute(String name, String type, String value)
已过时。 向属性列表添加属性。

void

AttributesImpl.addAttribute(String uri, String localName, String qName, String type, String value)
将属性添加到列表的末尾。

static XMLReader

XMLReaderFactory.createXMLReader(String className)
尝试从类名称创建一个 XML 阅读器。

boolean

NamespaceSupport.declarePrefix(String prefix, String uri)
声明名称空间前缀。

void

ParserAdapter.endElement(String qName)
适配器实现方法；不调用。

void

DefaultHandler.endElement(String uri, String localName, String qName)
接收元素结束的通知。

void

XMLFilterImpl.endElement(String uri, String localName, String qName)
过滤一个结束元素事件。

void

XMLReaderAdapter.endElement(String uri, String localName, String qName)
适配 SAX2 结束元素事件。

void

DefaultHandler.endPrefixMapping(String prefix)
接收名称空间映射结束的通知。

void

XMLFilterImpl.endPrefixMapping(String prefix)
过滤一个结束名称空间前缀映射事件。

void

XMLReaderAdapter.endPrefixMapping(String prefix)
适配 SAX2 结束前缀映射事件。

boolean

ParserAdapter.getFeature(String name)
检查解析器功能标志。

boolean

XMLFilterImpl.getFeature(String name)
查找功能值。

int

AttributesImpl.getIndex(String qName)
通过限定（加前缀的）名称查找属性的索引。

int

AttributesImpl.getIndex(String uri, String localName)
通过名称空间名称查找属性的索引。

String

NamespaceSupport.getPrefix(String uri)
返回映射到名称空间 URI 的前缀之一。

Enumeration

NamespaceSupport.getPrefixes(String uri)
返回给定 URI 的 所有前缀的枚举，给定 URI 的声明在当前上下文中是活动的。

Object

ParserAdapter.getProperty(String name)
获取解析器属性。

Object

XMLFilterImpl.getProperty(String name)
查找属性值。

String

AttributeListImpl.getType(String name)
已过时。 获取属性的类型（按名称）。

String

AttributesImpl.getType(String qName)
通过限定（加前缀的）名称查找属性的类型。

String

AttributesImpl.getType(String uri, String localName)
通过限定名称空间的名称查找属性的类型。

String

NamespaceSupport.getURI(String prefix)
查找前缀，并获取当前映射的名称空间 URI。

String

AttributeListImpl.getValue(String name)
已过时。 获取属性的值（按名称）。

String

AttributesImpl.getValue(String qName)
通过限定（加前缀的）名称查找属性的值。

String

AttributesImpl.getValue(String uri, String localName)
通过限定名称空间的名称查找属性的值。

static Parser

ParserFactory.makeParser(String className)
已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

void

DefaultHandler.notationDecl(String name, String publicId, String systemId)
接收注释声明的通知。

void

XMLFilterImpl.notationDecl(String name, String publicId, String systemId)
过滤一个注释声明事件。

void

ParserAdapter.parse(String systemId)
解析 XML 文档。

void

XMLFilterImpl.parse(String systemId)
解析一个文档。

void

XMLReaderAdapter.parse(String systemId)
解析文档。

void

DefaultHandler.processingInstruction(String target, String data)
接收处理指令的通知。

void

ParserAdapter.processingInstruction(String target, String data)
适配器实现方法；不调用。

void

XMLFilterImpl.processingInstruction(String target, String data)
过滤一个处理指令事件。

void

XMLReaderAdapter.processingInstruction(String target, String data)
适配 SAX2 处理指令事件。

String[]

NamespaceSupport.processName(String qName, String[] parts, boolean isAttribute)
declarePrefix() 处理完当前上下文中的所有声明之后，处理原始 XML 限定名称。

String[]

NamespaceSupport.processName(String qName, String[] parts, boolean isAttribute)
declarePrefix() 处理完当前上下文中的所有声明之后，处理原始 XML 限定名称。

void

AttributeListImpl.removeAttribute(String name)
已过时。 从列表移除属性。

InputSource

DefaultHandler.resolveEntity(String publicId, String systemId)
解析外部实体。

InputSource

XMLFilterImpl.resolveEntity(String publicId, String systemId)
过滤一个外部实体解析。

void

AttributesImpl.setAttribute(int index, String uri, String localName, String qName, String type, String value)
在列表中设置属性。

void

ParserAdapter.setFeature(String name, boolean value)
为解析器设置功能标志。

void

XMLFilterImpl.setFeature(String name, boolean value)
设置功能的值。

void

AttributesImpl.setLocalName(int index, String localName)
设置特定属性的本地名称。

void

ParserAdapter.setProperty(String name, Object value)
设置解析器属性。

void

XMLFilterImpl.setProperty(String name, Object value)
设置属性值。

void

LocatorImpl.setPublicId(String publicId)
设置此定位器的公开标识符。

void

AttributesImpl.setQName(int index, String qName)
设置特定属性的限定名称。

void

LocatorImpl.setSystemId(String systemId)
设置此定位器的系统标识符。

void

AttributesImpl.setType(int index, String type)
设置特定属性的类型。

void

AttributesImpl.setURI(int index, String uri)
设置特定属性的名称空间 URI。

void

AttributesImpl.setValue(int index, String value)
设置特定属性的值。

void

DefaultHandler.skippedEntity(String name)
接收跳过的实体的通知。

void

XMLFilterImpl.skippedEntity(String name)
过滤一个跳过的实体事件。

void

XMLReaderAdapter.skippedEntity(String name)
适配 SAX2 跳过的实体事件。

void

ParserAdapter.startElement(String qName, AttributeList qAtts)
适配器实现方法；不调用。

void

DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes)
接收元素开始的通知。

void

XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts)
过滤一个开始元素事件。

void

XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts)
适配 SAX2 开始元素事件。

void

DefaultHandler.startPrefixMapping(String prefix, String uri)
接收名称空间映射开始的通知。

void

XMLFilterImpl.startPrefixMapping(String prefix, String uri)
过滤一个开始名称空间前缀映射事件。

void

XMLReaderAdapter.startPrefixMapping(String prefix, String uri)
适配 SAX2 开始前缀映射事件。

void

DefaultHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
接收未解析实体声明的通知。

void

XMLFilterImpl.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
过滤一个未解析实体声明事件。

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM 2 Platform
Standard Ed. 6

上一个 下一个

框架 无框架


类 java.lang.StringBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StringBuffer
的使用

使用 StringBuffer 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

java.io 中 StringBuffer 的使用

返回 StringBuffer 的 java.io 中的方法
 StringBuffer StringWriter.getBuffer()
返回该字符串缓冲区本身。

java.lang 中 StringBuffer 的使用

返回 StringBuffer 的 java.lang 中的方法
StringBuffer | StringBuffer.append(boolean b)
StringBuffer | StringBuffer.append(char c)
StringBuffer | StringBuffer.append(char[] str)
StringBuffer | StringBuffer.append(char[] str, int offset, int len)
StringBuffer | StringBuffer.append(CharSequence s) 将指定的 CharSequence 添加到该序列。
StringBuffer | StringBuffer.append(CharSequence s, int start, int end)
StringBuffer | StringBuffer.append(double d)
StringBuffer | StringBuffer.append(float f)
StringBuffer | StringBuffer.append(int i)
StringBuffer | StringBuffer.append(long lng)
StringBuffer | StringBuffer.append(Object obj)
StringBuffer | StringBuffer.append(String str)
StringBuffer | StringBuffer.append(StringBuffer sb) 将指定的 StringBuffer 添加到此序列中。
StringBuffer | StringBuffer.appendCodePoint(int codePoint)
StringBuffer | StringBuffer.delete(int start, int end)
StringBuffer | StringBuffer.deleteCharAt(int index)
StringBuffer | StringBuffer.insert(int offset, boolean b)
StringBuffer | StringBuffer.insert(int offset, char c)
StringBuffer | StringBuffer.insert(int offset, char[] str)
StringBuffer | StringBuffer.insert(int index, char[] str, int offset, int len)
StringBuffer | StringBuffer.insert(int dstOffset, CharSequence s)
StringBuffer | StringBuffer.insert(int dstOffset, CharSequence s, int start, int end)
StringBuffer | StringBuffer.insert(int offset, double d)
StringBuffer | StringBuffer.insert(int offset, float f)
StringBuffer | StringBuffer.insert(int offset, int i)
StringBuffer | StringBuffer.insert(int offset, long l)
StringBuffer | StringBuffer.insert(int offset, Object obj)
StringBuffer | StringBuffer.insert(int offset, String str)
StringBuffer | StringBuffer.replace(int start, int end, String str)
StringBuffer | StringBuffer.reverse()

参数类型为 StringBuffer 的 java.lang 中的方法
StringBuilder | StringBuilder.append(StringBuffer sb) 将指定的 StringBuffer 添加到此序列。
StringBuffer | StringBuffer.append(StringBuffer sb) 将指定的 StringBuffer 添加到此序列中。
boolean | String.contentEquals(StringBuffer sb) 将此字符串与指定的 StringBuffer 比较。

参数类型为 StringBuffer 的 java.lang 中的构造方法
String(StringBuffer buffer)
分配一个新的字符串，它包含字符串缓冲区参数中当前包含的字符序列。

java.text 中 StringBuffer 的使用

返回 StringBuffer 的 java.text 中的方法
StringBuffer | SimpleDateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition pos) 将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
abstract StringBuffer | DateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition) 将一个 Date 格式化为日期/时间字符串。
StringBuffer | ChoiceFormat.format(double number, StringBuffer toAppendTo, FieldPosition status) 返回带已格式化 double 的模式。
StringBuffer | DecimalFormat.format(double number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 double 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(double number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | ChoiceFormat.format(long number, StringBuffer toAppendTo, FieldPosition status) 特殊格式。
StringBuffer | DecimalFormat.format(long number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 long 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(long number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | MessageFormat.format(Object[] arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
StringBuffer | DecimalFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数，并将所得文本追加到给定的字符串缓冲区。
StringBuffer | NumberFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数并将所得文本添加到给定字符串缓冲区。
StringBuffer | DateFormat.format(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition) 重写 Format。
StringBuffer | MessageFormat.format(Object arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
abstract StringBuffer | Format.format(Object obj, StringBuffer toAppendTo, FieldPosition pos) 格式化一个对象，并将得到的文本添加到给定的字符缓冲区。

参数类型为 StringBuffer 的 java.text 中的方法
StringBuffer | SimpleDateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition pos) 将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
abstract StringBuffer | DateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition) 将一个 Date 格式化为日期/时间字符串。
StringBuffer | ChoiceFormat.format(double number, StringBuffer toAppendTo, FieldPosition status) 返回带已格式化 double 的模式。
StringBuffer | DecimalFormat.format(double number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 double 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(double number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | ChoiceFormat.format(long number, StringBuffer toAppendTo, FieldPosition status) 特殊格式。
StringBuffer | DecimalFormat.format(long number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 long 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(long number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | MessageFormat.format(Object[] arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
StringBuffer | DecimalFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数，并将所得文本追加到给定的字符串缓冲区。
StringBuffer | NumberFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数并将所得文本添加到给定字符串缓冲区。
StringBuffer | DateFormat.format(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition) 重写 Format。
StringBuffer | MessageFormat.format(Object arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
abstract StringBuffer | Format.format(Object obj, StringBuffer toAppendTo, FieldPosition pos) 格式化一个对象，并将得到的文本添加到给定的字符缓冲区。

java.util.regex 中 StringBuffer 的使用

返回 StringBuffer 的 java.util.regex 中的方法
 StringBuffer Matcher.appendTail(StringBuffer sb)
实现终端添加和替换步骤。

参数类型为 StringBuffer 的 java.util.regex 中的方法
Matcher | Matcher.appendReplacement(StringBuffer sb, String replacement) 实现非终端添加和替换步骤。
StringBuffer | Matcher.appendTail(StringBuffer sb) 实现终端添加和替换步骤。

javax.swing.text.html.parser 中 StringBuffer 的使用

参数类型为 StringBuffer 的 javax.swing.text.html.parser 中的方法
protected  boolean Parser.parseMarkupDeclarations(StringBuffer strBuff)
解析标记声明。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.StringBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StringBuilder
的使用

使用 StringBuilder 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 StringBuilder 的使用

返回 StringBuilder 的 java.lang 中的方法
StringBuilder | StringBuilder.append(boolean b)
StringBuilder | StringBuilder.append(char c)
StringBuilder | StringBuilder.append(char[] str)
StringBuilder | StringBuilder.append(char[] str, int offset, int len)
StringBuilder | StringBuilder.append(CharSequence s)
StringBuilder | StringBuilder.append(CharSequence s, int start, int end)
StringBuilder | StringBuilder.append(double d)
StringBuilder | StringBuilder.append(float f)
StringBuilder | StringBuilder.append(int i)
StringBuilder | StringBuilder.append(long lng)
StringBuilder | StringBuilder.append(Object obj)
StringBuilder | StringBuilder.append(String str)
StringBuilder | StringBuilder.append(StringBuffer sb) 将指定的 StringBuffer 添加到此序列。
StringBuilder | StringBuilder.appendCodePoint(int codePoint)
StringBuilder | StringBuilder.delete(int start, int end)
StringBuilder | StringBuilder.deleteCharAt(int index)
StringBuilder | StringBuilder.insert(int offset, boolean b)
StringBuilder | StringBuilder.insert(int offset, char c)
StringBuilder | StringBuilder.insert(int offset, char[] str)
StringBuilder | StringBuilder.insert(int index, char[] str, int offset, int len)
StringBuilder | StringBuilder.insert(int dstOffset, CharSequence s)
StringBuilder | StringBuilder.insert(int dstOffset, CharSequence s, int start, int end)
StringBuilder | StringBuilder.insert(int offset, double d)
StringBuilder | StringBuilder.insert(int offset, float f)
StringBuilder | StringBuilder.insert(int offset, int i)
StringBuilder | StringBuilder.insert(int offset, long l)
StringBuilder | StringBuilder.insert(int offset, Object obj)
StringBuilder | StringBuilder.insert(int offset, String str)
StringBuilder | StringBuilder.replace(int start, int end, String str)
StringBuilder | StringBuilder.reverse()

参数类型为 StringBuilder 的 java.lang 中的构造方法
String(StringBuilder builder)
分配一个新的字符串，它包含字符串生成器参数中当前包含的字符序列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.StringIndexOutOfBoundsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StringIndexOutOfBoundsException
的使用

没有 java.lang.StringIndexOutOfBoundsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.SuppressWarnings 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.SuppressWarnings
的使用

使用 SuppressWarnings 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.management 中 SuppressWarnings 的使用

注释类型为 SuppressWarnings 的 javax.management 中的类
 class ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

注释类型为 SuppressWarnings 的 javax.management 中的方法
 List<Attribute> AttributeList.asList()
以 List<Attribute> 的形式返回此列表的视图。

javax.management.relation 中 SuppressWarnings 的使用

注释类型为 SuppressWarnings 的 javax.management.relation 中的方法
List<Role> | RoleList.asList() 以 List<Role> 的形式返回此列表的示图。
List<RoleUnresolved> | RoleUnresolvedList.asList() 以 List<RoleUnresolved> 的形式返回此列表的视图。

javax.swing 中 SuppressWarnings 的使用

注释类型为 SuppressWarnings 的 javax.swing 中的类
 class TransferHandler
此类用于处理往返于 Swing 组件的 Transferable 的传输。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.System 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.System
的使用

没有 java.lang.System 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Thread 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Thread
的使用

使用 Thread 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.lang 中 Thread 的使用

返回 Thread 的 java.lang 中的方法
static Thread Thread.currentThread()
返回对当前正在执行的线程对象的引用。

返回变量类型为 Thread 的类型的 java.lang 中的方法
static Map<Thread,StackTraceElement[]> Thread.getAllStackTraces()
返回所有活动线程的堆栈跟踪的一个映射。

参数类型为 Thread 的 java.lang 中的方法
void | Runtime.addShutdownHook(Thread hook) 注册新的虚拟机来关闭钩子。
void | SecurityManager.checkAccess(Thread t) 如果不允许调用线程修改 thread 参数，则抛出 SecurityException。
int | ThreadGroup.enumerate(Thread[] list) 把此线程组及其子组中的所有活动线程复制到指定数组中。
static int | Thread.enumerate(Thread[] tarray) 将当前线程的线程组及其子组中的每一个活动线程复制到指定的数组中。
int | ThreadGroup.enumerate(Thread[] list, boolean recurse) 把此线程组中的所有活动线程复制到指定数组中。
boolean | Runtime.removeShutdownHook(Thread hook) 取消注册某个先前已注册的虚拟机关闭钩子。
void | ThreadGroup.uncaughtException(Thread t, Throwable e) 当此线程组中的线程因为一个未捕获的异常而停止，并且线程没有安装特定 Thread.UncaughtExceptionHandler 时，由 Java Virtual Machine 调用此方法。
void | Thread.UncaughtExceptionHandler.uncaughtException(Thread t, Throwable e) 当给定线程因给定的未捕获异常而终止时，调用该方法。

java.util.concurrent 中 Thread 的使用

返回 Thread 的 java.util.concurrent 中的方法
 Thread ThreadFactory.newThread(Runnable r)
构造一个新 Thread。

返回变量类型为 Thread 的类型的 java.util.concurrent 中的方法
protected  Collection<Thread> Semaphore.getQueuedThreads()
返回一个 collection，包含可能等待获取的线程。

参数类型为 Thread 的 java.util.concurrent 中的方法
protected void | ThreadPoolExecutor.beforeExecute(Thread t, Runnable r) 在执行给定线程中的给定 Runnable 之前调用的方法。
void | TimeUnit.timedJoin(Thread thread, long timeout) 使用此时间单元执行计时的 Thread.join。

java.util.concurrent.locks 中 Thread 的使用

返回 Thread 的 java.util.concurrent.locks 中的方法
protected Thread | AbstractOwnableSynchronizer.getExclusiveOwnerThread() 返回由 setExclusiveOwnerThread 最后设置的线程；如果从未设置，则返回 null。
Thread | AbstractQueuedLongSynchronizer.getFirstQueuedThread() 返回队列中第一个（等待时间最长的）线程；如果当前没有将任何线程加入队列，则返回 null。
Thread | AbstractQueuedSynchronizer.getFirstQueuedThread() 返回队列中第一个（等待时间最长的）线程，如果目前没有将任何线程加入队列，则返回 null. 在此实现中，该操作是以固定时间返回的，但是，如果其他线程目前正在并发修改该队列，则可能出现循环争用。
protected Thread | ReentrantReadWriteLock.getOwner() 返回当前拥有写入锁的线程，如果没有这样的线程，则返回 null。
protected Thread | ReentrantLock.getOwner() 返回目前拥有此锁的线程，如果此锁不被任何线程拥有，则返回 null。

返回变量类型为 Thread 的类型的 java.util.concurrent.locks 中的方法
Collection<Thread> | AbstractQueuedLongSynchronizer.getExclusiveQueuedThreads() 返回一个 collection，该 collection 包含正以独占模式等待获取的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getExclusiveQueuedThreads() 返回包含可能正以独占模式等待获取的线程 collection。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedReaderThreads() 返回一个 collection，它包含可能正在等待获取读取锁的线程。
Collection<Thread> | AbstractQueuedLongSynchronizer.getQueuedThreads() 返回一个 collection，该 collection 包含正在等待获取的线程。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedThreads() 返回一个 collection，它包含可能正在等待获取读取或写入锁的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getQueuedThreads() 返回包含可能正在等待获取的线程 collection。
protected Collection<Thread> | ReentrantLock.getQueuedThreads() 返回一个 collection，它包含可能正等待获取此锁的线程。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedWriterThreads() 返回一个 collection，它包含可能正在等待获取写入锁的线程。
Collection<Thread> | AbstractQueuedLongSynchronizer.getSharedQueuedThreads() 返回一个 collection，该 collection 包含正以共享模式等待获取的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getSharedQueuedThreads() 返回包含可能正以共享模式等待获取的线程 collection。
protected Collection<Thread> | AbstractQueuedLongSynchronizer.ConditionObject.getWaitingThreads() 返回一个 collection，该 collection 包含那些正在此条件等待的线程。
protected Collection<Thread> | AbstractQueuedSynchronizer.ConditionObject.getWaitingThreads() 返回包含那些可能正在等待此条件的线程 collection。
Collection<Thread> | AbstractQueuedLongSynchronizer.getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject condition) 返回一个 collection，该 collection 包含那些正在与此同步器关联的给定条件上等待的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject condition) 返回一个 collection，其中包含可能正在等待与此同步器有关的给定条件的那些线程。
protected Collection<Thread> | ReentrantReadWriteLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与写入锁相关的给定条件的那些线程。
protected Collection<Thread> | ReentrantLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与此锁相关给定条件的那些线程。

参数类型为 Thread 的 java.util.concurrent.locks 中的方法
static Object | LockSupport.getBlocker(Thread t) 返回提供给最近一次尚未解除阻塞的 park 方法调用的 blocker 对象，如果该调用不受阻塞，则返回 null。
boolean | ReentrantReadWriteLock.hasQueuedThread(Thread thread) 查询是否给定线程正在等待获取读取或写入锁。
boolean | ReentrantLock.hasQueuedThread(Thread thread) 查询给定线程是否正在等待获取此锁。
boolean | AbstractQueuedLongSynchronizer.isQueued(Thread thread) 如果给定线程当前已加入队列，则返回 true。
boolean | AbstractQueuedSynchronizer.isQueued(Thread thread) 如果给定线程的当前已加入队列，则返回 true。
protected void | AbstractOwnableSynchronizer.setExclusiveOwnerThread(Thread t) 设置当前拥有独占访问的线程。
static void | LockSupport.unpark(Thread thread) 如果给定线程的许可尚不可用，则使其可用。

javax.swing.text 中 Thread 的使用

返回 Thread 的 javax.swing.text 中的方法
protected  Thread AbstractDocument.getCurrentWriter()
获取当前的写入线程（如果有的话）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Thread.State 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Thread.State
的使用

使用 Thread.State 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang 中 Thread.State 的使用

返回 Thread.State 的 java.lang 中的方法
Thread.State | Thread.getState() 返回该线程的状态。
static Thread.State | Thread.State.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Thread.State[] | Thread.State.values() Returns an array containing the constants of this enum type, in the order they are declared.

java.lang.management 中 Thread.State 的使用

返回 Thread.State 的 java.lang.management 中的方法
 Thread.State ThreadInfo.getThreadState()
返回与此 ThreadInfo 关联的线程的状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.Thread.UncaughtExceptionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Thread.UncaughtExceptionHandler
的使用

使用 Thread.UncaughtExceptionHandler 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 Thread.UncaughtExceptionHandler 的使用

实现 Thread.UncaughtExceptionHandler 的 java.lang 中的类
 class ThreadGroup
线程组表示一个线程的集合。

返回 Thread.UncaughtExceptionHandler 的 java.lang 中的方法
static Thread.UncaughtExceptionHandler | Thread.getDefaultUncaughtExceptionHandler() 返回线程由于未捕获到异常而突然终止时调用的默认处理程序。
Thread.UncaughtExceptionHandler | Thread.getUncaughtExceptionHandler() 返回该线程由于未捕获到异常而突然终止时调用的处理程序。

参数类型为 Thread.UncaughtExceptionHandler 的 java.lang 中的方法
static void | Thread.setDefaultUncaughtExceptionHandler(Thread.UncaughtExceptionHandler eh) 设置当线程由于未捕获到异常而突然终止，并且没有为该线程定义其他处理程序时所调用的默认处理程序。
void | Thread.setUncaughtExceptionHandler(Thread.UncaughtExceptionHandler eh) 设置该线程由于未捕获到异常而突然终止时调用的处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ThreadDeath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ThreadDeath
的使用

没有 java.lang.ThreadDeath 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ThreadGroup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ThreadGroup
的使用

使用 ThreadGroup 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 ThreadGroup 的使用

返回 ThreadGroup 的 java.lang 中的方法
ThreadGroup | ThreadGroup.getParent() 返回此线程组的父线程组。
ThreadGroup | SecurityManager.getThreadGroup() 调用此方法时，返回所有新创建的线程实例化后所在的线程组。
ThreadGroup | Thread.getThreadGroup() 返回该线程所属的线程组。

参数类型为 ThreadGroup 的 java.lang 中的方法
void | SecurityManager.checkAccess(ThreadGroup g) 如果不允许调用线程修改线程组参数，则抛出 SecurityException。
int | ThreadGroup.enumerate(ThreadGroup[] list) 把对此线程组中的所有活动子组的引用复制到指定数组中。
int | ThreadGroup.enumerate(ThreadGroup[] list, boolean recurse) 把对此线程组中的所有活动子组的引用复制到指定数组中。
boolean | ThreadGroup.parentOf(ThreadGroup g) 测试此线程组是否为线程组参数或其祖先线程组之一。

参数类型为 ThreadGroup 的 java.lang 中的构造方法
Thread(ThreadGroup group, Runnable target)
分配新的 Thread 对象。
Thread(ThreadGroup group, Runnable target, String name)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，并作为 group 所引用的线程组的一员。
Thread(ThreadGroup group, Runnable target, String name, long stackSize)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，作为 group 所引用的线程组的一员，并具有指定的堆栈大小。
Thread(ThreadGroup group, String name)
分配新的 Thread 对象。
ThreadGroup(ThreadGroup parent, String name)
创建一个新线程组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ThreadLocal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ThreadLocal
的使用

使用 ThreadLocal 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 ThreadLocal 的使用

java.lang 中 ThreadLocal 的子类
 class InheritableThreadLocal<T>
该类扩展了 ThreadLocal，为子线程提供从父线程那里继承的值：在创建子线程时，子线程会接收所有可继承的线程局部变量的初始值，以获得父线程所具有的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Throwable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Throwable
的使用

使用 Throwable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.cert | 为公钥证书提供类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。

java.awt 中 Throwable 的使用

java.awt 中 Throwable 的子类
class | AWTError 当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。
class | AWTException 表示发生了 Absract Window Toolkit 异常。
class | FontFormatException 此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。
class | HeadlessException 在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
class | IllegalComponentStateException 当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

抛出 Throwable 的 java.awt 中的方法
protected  void Font.finalize()
移除本机 Font 对象。

java.awt.color 中 Throwable 的使用

java.awt.color 中 Throwable 的子类
class | CMMException 如果本机 CMM 返回一个错误，则抛出此异常。
class | ProfileDataException 当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

java.awt.datatransfer 中 Throwable 的使用

java.awt.datatransfer 中 Throwable 的子类
class | MimeTypeParseException 对分析相关异常的 MimeType 进行封装的类
class | UnsupportedFlavorException 在此 flavor 中不支持所请求的数据的信号。

java.awt.dnd 中 Throwable 的使用

java.awt.dnd 中 Throwable 的子类
 class InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

java.awt.event 中 Throwable 的使用

返回 Throwable 的 java.awt.event 中的方法
 Throwable InvocationEvent.getThrowable()
返回在执行 Runnable 的 run() 方法时捕获的任何 Throwable。

java.awt.geom 中 Throwable 的使用

java.awt.geom 中 Throwable 的子类
class | IllegalPathStateException 对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。
class | NoninvertibleTransformException NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。

java.awt.image 中 Throwable 的使用

java.awt.image 中 Throwable 的子类
class | ImagingOpException 如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
class | RasterFormatException 如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

java.awt.print 中 Throwable 的使用

java.awt.print 中 Throwable 的子类
class | PrinterAbortException PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
class | PrinterException PrinterException 类及其子类用于指示打印系统中发生的异常情况。
class | PrinterIOException PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

返回 Throwable 的 java.awt.print 中的方法
 Throwable PrinterIOException.getCause()
返回此异常的 cause（终止打印作业的 IOException）。

java.beans 中 Throwable 的使用

java.beans 中 Throwable 的子类
class | IntrospectionException 在 Introspection 期间发生异常时抛出异常。
class | PropertyVetoException 当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。

java.io 中 Throwable 的使用

java.io 中 Throwable 的子类
class | CharConversionException 用于字符转换异常的基类。
class | EOFException 当输入过程中意外到达文件或流的末尾时，抛出此异常。
class | FileNotFoundException 当试图打开指定路径名表示的文件失败时，抛出此异常。
class | InterruptedIOException I/O 操作已中断信号，抛出此异常。
class | InvalidClassException 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
class | InvalidObjectException 指示一个或多个反序列化对象未通过验证测试。
class | IOError 当发生严重的 I/O 错误时，抛出此错误。
class | IOException 当发生某种 I/O 异常时，抛出此异常。
class | NotActiveException 当序列化和反序列化不活动时，抛出此异常。
class | NotSerializableException 当实例需要具有序列化接口时，抛出此异常。
class | ObjectStreamException 特定于 Object Stream 类的所有异常的超类。
class | OptionalDataException 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
class | StreamCorruptedException 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
class | SyncFailedException 当 sync 操作失败时，抛出此异常。
class | UnsupportedEncodingException 不支持字符编码。
class | UTFDataFormatException 在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
class | WriteAbortedException 在写入操作过程中抛出 ObjectStreamException 之一的信号。

返回 Throwable 的 java.io 中的方法
 Throwable WriteAbortedException.getCause()
返回终止操作的异常（即 cause）。

参数类型为 Throwable 的 java.io 中的构造方法
IOError(Throwable cause)
构造带有指定 cause 的新 IOError 实例。
IOException(String message, Throwable cause)
构造带有指定详细消息和 cause 的 IOException。
IOException(Throwable cause)
构造一个 IOException，使其具有指定的 cause 以及详细消息 (cause==null ? null : cause.toString())（通常包含类和 cause 的详细消息）。

java.lang 中 Throwable 的使用

java.lang 中 Throwable 的子类
class | AbstractMethodError 当应用程序试图调用一个抽象方法时，抛出此错误。
class | ArithmeticException 当出现异常的运算条件时，抛出此异常。
class | ArrayIndexOutOfBoundsException 用非法索引访问数组时抛出的异常。
class | ArrayStoreException 试图将错误类型的对象存储到一个对象数组时抛出的异常。
class | AssertionError 抛出该异常指示某个断言失败。
class | ClassCastException 当试图将对象强制转换为不是实例的子类时，抛出该异常。
class | ClassCircularityError 当初始化类时检测到类的循环调用的时候，抛出该错误。
class | ClassFormatError 当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
class | ClassNotFoundException 当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
class | CloneNotSupportedException 当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
class | EnumConstantNotPresentException 当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
class | Error Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
class | Exception Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
class | ExceptionInInitializerError 静态初始化程序中发生意外异常的信号。
class | IllegalAccessError 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
class | IllegalAccessException 当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
class | IllegalArgumentException 抛出的异常表明向方法传递了一个不合法或不正确的参数。
class | IllegalMonitorStateException 抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
class | IllegalStateException 在非法或不适当的时间调用方法时产生的信号。
class | IllegalThreadStateException 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
class | IncompatibleClassChangeError 在某些类定义中出现不兼容的类更改时抛出该异常。
class | IndexOutOfBoundsException 指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
class | InstantiationError 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
class | InstantiationException 当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
class | InternalError 该异常指示 Java 虚拟机中出现一些意外的内部错误。
class | InterruptedException 当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
class | LinkageError LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
class | NegativeArraySizeException 如果应用程序试图创建大小为负的数组，则抛出该异常。
class | NoClassDefFoundError 当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
class | NoSuchFieldError 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
class | NoSuchFieldException 类不包含指定名称的字段时产生的信号。
class | NoSuchMethodError 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
class | NoSuchMethodException 无法找到某一特定方法时，抛出该异常。
class | NullPointerException 当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
class | NumberFormatException 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
class | OutOfMemoryError 因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
class | RuntimeException RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
class | SecurityException 由安全管理器抛出的异常，指示存在安全侵犯。
class | StackOverflowError 当应用程序递归太深而发生堆栈溢出时，抛出该错误。
class | StringIndexOutOfBoundsException 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
class | ThreadDeath 调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。
class | TypeNotPresentException 当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
class | UnknownError 当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。
class | UnsatisfiedLinkError 当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
class | UnsupportedClassVersionError 当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
class | UnsupportedOperationException 当不支持请求的操作时，抛出该异常。
class | VerifyError 当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。
class | VirtualMachineError 当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

返回 Throwable 的 java.lang 中的方法
Throwable | Throwable.fillInStackTrace() 在异常堆栈跟踪中填充。
Throwable | ExceptionInInitializerError.getCause() 返回导致该错误的原因（导致发生此错误的静态初始化期间发生的异常）。
Throwable | ClassNotFoundException.getCause() 返回此异常的原因（尝试加载类时发生错误引发的异常；否则返回 null）。
Throwable | Throwable.getCause() 返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。
Throwable | ExceptionInInitializerError.getException() 返回静态初始化期间发生的异常，该异常导致发生此错误。
Throwable | ClassNotFoundException.getException() 返回尝试加载类时发生错误引发的异常。
Throwable | Throwable.initCause(Throwable cause) 将此 throwable 的 cause 初始化为指定值。

参数类型为 Throwable 的 java.lang 中的方法
 Throwable Throwable.initCause(Throwable cause)
将此 throwable 的 cause 初始化为指定值。
 void Thread.stop(Throwable obj)
已过时。 该方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。 该方法的附加危险是它可用于生成目标线程未准备处理的异常（包括若没有该方法该线程不太可能抛出的已检查的异常）。 有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void ThreadGroup.uncaughtException(Thread t, Throwable e)
当此线程组中的线程因为一个未捕获的异常而停止，并且线程没有安装特定 Thread.UncaughtExceptionHandler 时，由 Java Virtual Machine 调用此方法。
 void Thread.UncaughtExceptionHandler.uncaughtException(Thread t, Throwable e)
当给定线程因给定的未捕获异常而终止时，调用该方法。

抛出 Throwable 的 java.lang 中的方法
protected  void Object.finalize()
当垃圾回收器确定不存在对该对象的更多引用时，由对象的垃圾回收器调用此方法。

参数类型为 Throwable 的 java.lang 中的构造方法
ClassNotFoundException(String s, Throwable ex)
构造一个 ClassNotFoundException，它带有指定详细消息和加载类时引发的可选异常。
Error(String message, Throwable cause)
构造带指定详细消息和原因的新错误。
Error(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息来构造新的错误（通常包含 cause 的类和详细消息）。
Exception(String message, Throwable cause)
构造带指定详细消息和原因的新异常。
Exception(Throwable cause)
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造新异常（它通常包含 cause 的类和详细消息）。
ExceptionInInitializerError(Throwable thrown)
保存对抛出的 Throwable 对象的引用，以便以后通过 ExceptionInInitializerError.getException() 方法对其进行获取，通过这种方式构造一个新的 ExceptionInInitializerError 类。
IllegalArgumentException(String message, Throwable cause)
根据指定的详细消息和原因构造一个新异常。
IllegalArgumentException(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息构造一个新异常（它通常包含 cause 的类和详细消息）。
IllegalStateException(String message, Throwable cause)
构造一个新异常，它带有指定的详细消息和原因。
IllegalStateException(Throwable cause)
构造一个新异常，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含 cause 的类和详细消息）。
RuntimeException(String message, Throwable cause)
用指定的详细消息和原因构造一个新的运行时异常。
RuntimeException(Throwable cause)
用指定的原因和详细消息 (cause==null ? null :cause.toString()） 构造一个新的运行时异常（它通常包含类和 cause 的详细消息）。
SecurityException(String message, Throwable cause)
创建带指定详细消息和原因的 SecurityException。
SecurityException(Throwable cause)
创建一个 SecurityException，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含该类和 cause 的详细消息）。
Throwable(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 throwable。
Throwable(Throwable cause)
构造一个带指定 cause 和 (cause==null ? null :cause.toString())（它通常包含类和 cause 的详细消息）的详细消息的新 throwable。
TypeNotPresentException(String typeName, Throwable cause)
为指定类型构造一个带指定原因的 TypeNotPresentException。
UnsupportedOperationException(String message, Throwable cause)
根据指定的详细消息和原因，构造一个新异常。
UnsupportedOperationException(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString())（它通常包含了 cause 的类和详细消息）的详细消息，构造一个新异常。

java.lang.annotation 中 Throwable 的使用

java.lang.annotation 中 Throwable 的子类
class | AnnotationFormatError 当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。
class | AnnotationTypeMismatchException 若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
class | IncompleteAnnotationException 若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。

参数类型为 Throwable 的 java.lang.annotation 中的构造方法
AnnotationFormatError(String message, Throwable cause)
构造带指定详细消息和原因的新 AnnotationFormatError。
AnnotationFormatError(Throwable cause)
构造带指定原因和详细消息的新 AnnotationFormatError，该消息为 (cause == null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

java.lang.instrument 中 Throwable 的使用

java.lang.instrument 中 Throwable 的子类
class | IllegalClassFormatException 当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。
class | UnmodifiableClassException 在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

java.lang.reflect 中 Throwable 的使用

java.lang.reflect 中 Throwable 的子类
class | GenericSignatureFormatError 当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。
class | InvocationTargetException InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。
class | MalformedParameterizedTypeException 当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
class | UndeclaredThrowableException 如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

返回 Throwable 的 java.lang.reflect 中的方法
Throwable | UndeclaredThrowableException.getCause() 返回此异常的原因（此 UndeclaredThrowableException 中包装的 Throwable 实例，可能为 null）。
Throwable | InvocationTargetException.getCause() 返回此异常的原因（抛出的目标异常，可能为 null）。
Throwable | InvocationTargetException.getTargetException() 获取抛出的目标异常。
Throwable | UndeclaredThrowableException.getUndeclaredThrowable() 返回此 UndeclaredThrowableException 中包装的 Throwable 实例，它可能为 null。

抛出 Throwable 的 java.lang.reflect 中的方法
 Object InvocationHandler.invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

参数类型为 Throwable 的 java.lang.reflect 中的构造方法
InvocationTargetException(Throwable target)
构造带目标异常的 InvocationTargetException。
InvocationTargetException(Throwable target, String s)
构造带目标异常和详细消息的 InvocationTargetException。
UndeclaredThrowableException(Throwable undeclaredThrowable)
根据指定的 Throwable 构造一个 UndeclaredThrowableException。
UndeclaredThrowableException(Throwable undeclaredThrowable, String s)
根据指定的 Throwable 和详细消息构造 UndeclaredThrowableException。

java.net 中 Throwable 的使用

java.net 中 Throwable 的子类
class | BindException 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
class | HttpRetryException 抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
class | MalformedURLException 抛出这一异常指示出现了错误的 URL。
class | NoRouteToHostException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | PortUnreachableException 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
class | ProtocolException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketTimeoutException 如果在读取或接受套接字时发生超时，则抛出此异常。
class | UnknownHostException 指示主机 IP 地址无法确定而抛出的异常。
class | UnknownServiceException 抛出这一异常指示出现了未知服务异常。
class | URISyntaxException 抛出经过检查的指示字符串不能解析为 URI 引用的异常。

java.nio 中 Throwable 的使用

java.nio 中 Throwable 的子类
class | BufferOverflowException 当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
class | BufferUnderflowException 当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
class | InvalidMarkException 当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
class | ReadOnlyBufferException 当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

java.nio.channels 中 Throwable 的使用

java.nio.channels 中 Throwable 的子类
class | AlreadyConnectedException 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
class | AsynchronousCloseException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
class | CancelledKeyException 当试图使用不再有效的选择键时，抛出此未经检查的异常。
class | ClosedByInterruptException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
class | ClosedChannelException 当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
class | ClosedSelectorException 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
class | ConnectionPendingException 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
class | FileLockInterruptionException 当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。
class | IllegalBlockingModeException 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
class | IllegalSelectorException 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
class | NoConnectionPendingException 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
class | NonReadableChannelException 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
class | NonWritableChannelException 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
class | NotYetBoundException 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | NotYetConnectedException 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | OverlappingFileLockException 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
class | UnresolvedAddressException 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
class | UnsupportedAddressTypeException 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

java.nio.charset 中 Throwable 的使用

java.nio.charset 中 Throwable 的子类
class | CharacterCodingException 出现字符编码或解码错误时，抛出此经过检查的异常。
class | CoderMalfunctionError 当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。
class | IllegalCharsetNameException 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
class | MalformedInputException 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
class | UnmappableCharacterException 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。
class | UnsupportedCharsetException 当不支持请求的 charset 时，抛出此未经检查的异常。

java.rmi 中 Throwable 的使用

java.rmi 中 Throwable 的子类
class | AccessException AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
class | AlreadyBoundException 如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
class | ConnectException 如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
class | ConnectIOException 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
class | NoSuchObjectException 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
class | NotBoundException 如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
class | RemoteException RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
class | RMISecurityException 已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
class | ServerError 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
class | ServerException 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
class | ServerRuntimeException 已过时。 无替换版本
class | StubNotFoundException 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
class | UnexpectedException 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
class | UnmarshalException 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

声明为 Throwable 的 java.rmi 中的字段
 Throwable RemoteException.detail
远程异常的原因。

返回 Throwable 的 java.rmi 中的方法
 Throwable RemoteException.getCause()
返回此异常的原因。

参数类型为 Throwable 的 java.rmi 中的构造方法
RemoteException(String s, Throwable cause)
构造带指定详细消息和原因的 RemoteException。

java.rmi.activation 中 Throwable 的使用

java.rmi.activation 中 Throwable 的子类
class | ActivateFailedException 在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。
class | ActivationException 激活接口所使用的一般异常。
class | UnknownGroupException 当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
class | UnknownObjectException 当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

声明为 Throwable 的 java.rmi.activation 中的字段
 Throwable ActivationException.detail
激活异常的原因。

返回 Throwable 的 java.rmi.activation 中的方法
 Throwable ActivationException.getCause()
返回此异常的原因。

参数类型为 Throwable 的 java.rmi.activation 中的构造方法
ActivationException(String s, Throwable cause)
构造带指定详细消息和原因的 ActivationException。

java.rmi.server 中 Throwable 的使用

java.rmi.server 中 Throwable 的子类
class | ExportException ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
class | ServerCloneException 如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。
class | ServerNotActiveException 如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SocketSecurityException 已废弃的 ExportException 的子类。

返回 Throwable 的 java.rmi.server 中的方法
 Throwable ServerCloneException.getCause()
返回此异常的原因。

抛出 Throwable 的 java.rmi.server 中的方法
 Object RemoteObjectInvocationHandler.invoke(Object proxy, Method method, Object[] args)
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。

java.security 中 Throwable 的使用

java.security 中 Throwable 的子类
class | AccessControlException 此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
class | DigestException 此为一般 Message Digest 异常。
class | GeneralSecurityException GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
class | InvalidAlgorithmParameterException 用于无效或不合适的算法参数的异常。
class | InvalidKeyException 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
class | InvalidParameterException 当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
class | KeyException 此异常是基本的密钥异常。
class | KeyManagementException 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
class | KeyStoreException 这是一般的 KeyStore 异常。
class | NoSuchAlgorithmException 当请求特定的加密算法而它在该环境中不可用时抛出此异常。
class | NoSuchProviderException 当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
class | PrivilegedActionException doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
class | ProviderException 用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。
class | SignatureException 这是一般的签名异常。
class | UnrecoverableEntryException 如果 keystore 中的某项无法恢复，则抛出此异常。
class | UnrecoverableKeyException 如果 keystore 中的密钥无法恢复，则抛出此异常。

返回 Throwable 的 java.security 中的方法
 Throwable PrivilegedActionException.getCause()
返回此异常（特权计算抛出的异常，该异常导致此 PrivilegedActionException）的 cause。

参数类型为 Throwable 的 java.security 中的构造方法
DigestException(String message, Throwable cause)
创建带指定详细消息和 cause 的 DigestException。
DigestException(Throwable cause)
创建带指定 cause 和详细消息 DigestException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。
GeneralSecurityException(String message, Throwable cause)
创建带指定详细消息和 cause 的 GeneralSecurityException。
GeneralSecurityException(Throwable cause)
用指定的原因和详细消息创建一个 GeneralSecurityException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。
InvalidAlgorithmParameterException(String message, Throwable cause)
创建带指定详细消息和 cause 的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(Throwable cause)
创建带指定 cause 和详细消息的 InvalidAlgorithmParameterException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
InvalidKeyException(String message, Throwable cause)
创建带指定详细消息和 cause 的 InvalidKeyException。
InvalidKeyException(Throwable cause)
创建带指定 cause 和详细消息的 InvalidKeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyException(String message, Throwable cause)
创建带指定详细消息和 cause 的 KeyException。
KeyException(Throwable cause)
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyManagementException(String message, Throwable cause)
创建带指定详细消息和 cause 的 KeyManagementException。
KeyManagementException(Throwable cause)
创建带指定 cause 和详细消息的 KeyManagementException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyStoreException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 KeyStoreException。
KeyStoreException(Throwable cause)
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
NoSuchAlgorithmException(String message, Throwable cause)
创建带指定详细消息和 cause 的 NoSuchAlgorithmException。
NoSuchAlgorithmException(Throwable cause)
创建带指定 cause 和详细消息的 NoSuchAlgorithmException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
ProviderException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 ProviderException。
ProviderException(Throwable cause)
创建带指定的 cause 和详细消息的 ProviderException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
SignatureException(String message, Throwable cause)
创建带指定详细消息和原因的 SignatureException。
SignatureException(Throwable cause)
创建带指定的原因和详细消息的 SignatureException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

java.security.acl 中 Throwable 的使用

java.security.acl 中 Throwable 的子类
class | AclNotFoundException 如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。
class | LastOwnerException 如果试图删除访问控制列表的最后一个所有者，则抛出此异常。
class | NotOwnerException 当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。

java.security.cert 中 Throwable 的使用

java.security.cert 中 Throwable 的子类
class | CertPathBuilderException 指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
class | CertPathValidatorException 指示在验证一个证书路径时遇到了某种问题的异常。
class | CertStoreException 指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
class | CRLException CRL（证书撤消列表）异常。

参数类型为 Throwable 的 java.security.cert 中的构造方法
CertificateEncodingException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateEncodingException。
CertificateEncodingException(Throwable cause)
创建带指定原因和详细消息的 CertificateEncodingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertificateException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateException。
CertificateException(Throwable cause)
创建带指定原因和详细消息的 CertificateException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertificateParsingException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateParsingException。
CertificateParsingException(Throwable cause)
创建带指定原因和详细消息的 CertificateParsingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertPathBuilderException(String msg, Throwable cause)
创建带指定详细消息和原因的 CertPathBuilderException。
CertPathBuilderException(Throwable cause)
创建包装指定 throwable 的 CertPathBuilderException。
CertPathValidatorException(String msg, Throwable cause)
创建带指定详细消息和 cause 的 CertPathValidatorException。
CertPathValidatorException(String msg, Throwable cause, CertPath certPath, int index)
创建带指定详细消息、cause、证书路径和索引的 CertPathValidatorException。
CertPathValidatorException(Throwable cause)
创建包装指定 throwable 的 CertPathValidatorException。
CertStoreException(String msg, Throwable cause)
创建带指定详细消息和 cause 的 CertStoreException。
CertStoreException(Throwable cause)
创建包装指定 throwable 的 CertStoreException。
CRLException(String message, Throwable cause)
创建带指定详细消息和 cause 的 CRLException。
CRLException(Throwable cause)
创建带指定 cause 和详细消息的 CRLException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

java.security.spec 中 Throwable 的使用

java.security.spec 中 Throwable 的子类
class | InvalidKeySpecException 这是针对无效密钥规范的异常。
class | InvalidParameterSpecException 这是针对无效参数规范的异常。

参数类型为 Throwable 的 java.security.spec 中的构造方法
InvalidKeySpecException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 InvalidKeySpecException。
InvalidKeySpecException(Throwable cause)
创建带指定的 cause 和详细消息 (cause==null ? null : cause.toString()) 的 InvalidKeySpecException（它通常包含 cause 的类和详细消息）。

java.sql 中 Throwable 的使用

java.sql 中 Throwable 的子类
class | BatchUpdateException 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
class | DataTruncation 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
class | SQLClientInfoException 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLException 提供关于数据库访问错误或其他错误信息的异常。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLNonTransientException 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
class | SQLRecoverableException 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
class | SQLTransientException 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
class | SQLWarning 提供关于数据库访问警告信息的异常。

返回变量类型为 Throwable 的类型的 java.sql 中的方法
 Iterator<Throwable> SQLException.iterator()
返回在链接的 SQLExceptions 上进行迭代的迭代器。

参数类型为 Throwable 的 java.sql 中的构造方法
BatchUpdateException(int[] updateCounts, Throwable cause)
构造一个使用给定 cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String reason, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、cause 和 updateCounts 构造的 BatchUpdateException 对象。
BatchUpdateException(String reason, String SQLState, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String reason, String SQLState, int vendorCode, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、SQLState、vendorCode、cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(Throwable cause)
构造一个使用给定 cause 初始化的 BatchUpdateException 对象。
DataTruncation(int index, boolean parameter, boolean read, int dataSize, int transferSize, Throwable cause)
创建一个 DataTruncation 对象，当 read 被设置为 true 时，该对象的 SQLState 初始化为 01004，当 read 被设置为 false 时，则初始化为 22001，reason 被设置为 "Data truncation"，供应商代码被设置为 0，其他字段被设置为给定值。
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLDataException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLDataException 对象。
SQLDataException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLDataException 对象。
SQLDataException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLDataException 对象。
SQLDataException(Throwable cause)
构造一个带有给定 cause 的 SQLDataException 对象。
SQLException(String reason, String sqlState, int vendorCode, Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLException 对象。
SQLException(String reason, String sqlState, Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLException 对象。
SQLException(String reason, Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLException 对象。
SQLException(Throwable cause)
构造一个具有给定 cause 的 SQLException 对象。
SQLFeatureNotSupportedException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(Throwable cause)
构造一个带有给定 cause 的 SQLFeatureNotSupportedException 对象。
SQLIntegrityConstraintViolationException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(Throwable cause)
构造一个带有给定 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLInvalidAuthorizationSpecException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(Throwable cause)
构造一个带有给定 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLNonTransientConnectionException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLNonTransientConnectionException(Throwable cause)
构造一个带有给定 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientException 对象。
SQLNonTransientException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientException 对象。
SQLNonTransientException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLNonTransientException(Throwable cause)
构造一个带有给定 cause 的 SQLNonTransientException 对象。
SQLRecoverableException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(Throwable cause)
构造一个带有给定 cause 的 SQLRecoverableException 对象。
SQLSyntaxErrorException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(Throwable cause)
构造一个带有给定 cause 的 SQLSyntaxErrorException 对象。
SQLTimeoutException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(Throwable cause)
构造一个带有给定 cause 的 SQLTimeoutException 对象。
SQLTransactionRollbackException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(Throwable cause)
构造一个带有给定 cause 的 SQLTransactionRollbackException 对象。
SQLTransientConnectionException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(Throwable cause)
构造一个带有给定 cause 的 SQLTransientConnectionException 对象。
SQLTransientException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientException 对象。
SQLTransientException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientException 对象。
SQLTransientException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLTransientException(Throwable cause)
构造一个带有给定 cause 的 SQLTransientException 对象。
SQLWarning(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLWarning 对象。
SQLWarning(String reason, String SQLState, Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLWarning 对象。
SQLWarning(String reason, Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLWarning 对象。
SQLWarning(Throwable cause)
构造一个具有给定 cause 的 SQLWarning 对象。

java.text 中 Throwable 的使用

java.text 中 Throwable 的子类
 class ParseException
表示解析时出现意外错误。

java.util 中 Throwable 的使用

java.util 中 Throwable 的子类
class | ConcurrentModificationException 当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | EmptyStackException 该异常由 Stack 类中的方法抛出，以表明堆栈为空。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
class | FormatterClosedException 格式器已关闭时抛出的未经检查的异常。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatException 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | InputMismatchException 由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
class | InvalidPropertiesFormatException 当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | MissingResourceException 缺少资源时抛出此异常。
class | NoSuchElementException 由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
class | ServiceConfigurationError 在加载服务提供者的过程中出错时抛出的错误。
class | TooManyListenersException TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。

参数类型为 Throwable 的 java.util 中的构造方法
InvalidPropertiesFormatException(Throwable cause)
构造一个带指定原因的 InvalidPropertiesFormatException。
ServiceConfigurationError(String msg, Throwable cause)
构造一个带有指定消息和 cause 的新实例。

java.util.concurrent 中 Throwable 的使用

java.util.concurrent 中 Throwable 的子类
class | BrokenBarrierException 当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。
class | CancellationException 如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
class | ExecutionException 当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
class | RejectedExecutionException 当无法执行某个任务时,由 Executor 抛出的异常。
class | TimeoutException 阻塞操作超时时，抛出该异常。

参数类型为 Throwable 的 java.util.concurrent 中的方法
protected void | ThreadPoolExecutor.afterExecute(Runnable r, Throwable t) 基于完成执行给定 Runnable 所调用的方法。
protected void | FutureTask.setException(Throwable t) 除非已经设置了此 Future 或已将其取消，否则它将报告一个 ExecutionException，并将给定的 throwable 作为其原因。

参数类型为 Throwable 的 java.util.concurrent 中的构造方法
ExecutionException(String message, Throwable cause)
构造带指定详细消息和原因的 ExecutionException。
ExecutionException(Throwable cause)
构造带指定原因的 ExecutionException。
RejectedExecutionException(String message, Throwable cause)
构造带指定详细消息和原因的 RejectedExecutionException。
RejectedExecutionException(Throwable cause)
构造带指定原因的 RejectedExecutionException。

java.util.jar 中 Throwable 的使用

java.util.jar 中 Throwable 的子类
 class JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

java.util.logging 中 Throwable 的使用

返回 Throwable 的 java.util.logging 中的方法
 Throwable LogRecord.getThrown()
获取与日志记录相关联的所有 throwable。

参数类型为 Throwable 的 java.util.logging 中的方法
void | Logger.log(Level level, String msg, Throwable thrown) 记录带有相关的可抛出信息的消息。
void | Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown) 记录一条消息，具有指定源类和方法，带有相关的可抛出信息。
void | Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown) 记录一条消息，具有指定的源类、方法和资源包名，带有相关的可抛出对象。
void | LogRecord.setThrown(Throwable thrown) 设置与日志事件相关联的 throwable。
void | Logger.throwing(String sourceClass, String sourceMethod, Throwable thrown) 正抛出异常的记录。

java.util.prefs 中 Throwable 的使用

java.util.prefs 中 Throwable 的子类
class | BackingStoreException 抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。
class | InvalidPreferencesFormatException 抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。

参数类型为 Throwable 的 java.util.prefs 中的构造方法
BackingStoreException(Throwable cause)
构造带指定原因的 BackingStoreException。
InvalidPreferencesFormatException(String message, Throwable cause)
构造带指定详细消息和原因的 InvalidPreferencesFormatException。
InvalidPreferencesFormatException(Throwable cause)
构造带指定原因的 InvalidPreferencesFormatException。

java.util.regex 中 Throwable 的使用

java.util.regex 中 Throwable 的子类
 class PatternSyntaxException
抛出未经检查的异常，表明正则表达式模式中的语法错误。

java.util.zip 中 Throwable 的使用

java.util.zip 中 Throwable 的子类
class | DataFormatException 当数据格式发生错误时，抛出此异常。
class | ZipError 发生不可恢复的错误时抛出。
class | ZipException 如果某种 ZIP 异常发生，则抛出此错误。

javax.activation 中 Throwable 的使用

javax.activation 中 Throwable 的子类
 class UnsupportedDataTypeException
当请求操作不支持请求的数据类型时，抛出此异常。

javax.activity 中 Throwable 的使用

javax.activity 中 Throwable 的子类
class | ActivityCompletedException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
class | ActivityRequiredException 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
class | InvalidActivityException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

参数类型为 Throwable 的 javax.activity 中的构造方法
ActivityCompletedException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。
ActivityCompletedException(Throwable cause)
构造带有指定 cause 的新 throwable。
ActivityRequiredException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。
ActivityRequiredException(Throwable cause)
构造带有指定 cause 的新 throwable。
InvalidActivityException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。
InvalidActivityException(Throwable cause)
构造带有指定 cause 的新 throwable。

javax.annotation.processing 中 Throwable 的使用

javax.annotation.processing 中 Throwable 的子类
 class FilerException
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

javax.crypto 中 Throwable 的使用

javax.crypto 中 Throwable 的子类
class | BadPaddingException 当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
class | ExemptionMechanismException 此为一般 ExemptionMechanism 异常。
class | IllegalBlockSizeException 如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
class | NoSuchPaddingException 当请求特定填充机制但该环境中未提供时，抛出此异常。
class | ShortBufferException 当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

javax.imageio 中 Throwable 的使用

javax.imageio 中 Throwable 的子类
 class IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。

参数类型为 Throwable 的 javax.imageio 中的构造方法
IIOException(String message, Throwable cause)
构造一个 IIOException，使其带有给定消息 String 以及作为其底层 cause 的 Throwable。

javax.imageio.metadata 中 Throwable 的使用

javax.imageio.metadata 中 Throwable 的子类
 class IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

参数类型为 Throwable 的 javax.imageio.metadata 中的构造方法
IIOInvalidTreeException(String message, Throwable cause, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串、对导致此异常的异常的引用和导致解析错误的 Node 的引用。

javax.imageio.spi 中 Throwable 的使用

抛出 Throwable 的 javax.imageio.spi 中的方法
 void ServiceRegistry.finalize()
在垃圾回收前终止此对象。

javax.imageio.stream 中 Throwable 的使用

抛出 Throwable 的 javax.imageio.stream 中的方法
protected void | FileCacheImageInputStream.finalize() 在垃圾回收前结束此对象。
protected void | FileImageInputStream.finalize() 在垃圾回收前结束此对象。
protected void | FileImageOutputStream.finalize() 在垃圾回收前结束此对象。
protected void | ImageInputStreamImpl.finalize() 在垃圾回收前结束此对象。
protected void | MemoryCacheImageInputStream.finalize() 在垃圾回收前结束此对象。

javax.lang.model.element 中 Throwable 的使用

javax.lang.model.element 中 Throwable 的子类
class | UnknownAnnotationValueException 指示遇到一个未知种类的注释值。
class | UnknownElementException 指示遇到一个未知种类的元素。

javax.lang.model.type 中 Throwable 的使用

javax.lang.model.type 中 Throwable 的子类
class | MirroredTypeException 当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
class | MirroredTypesException 当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
class | UnknownTypeException 指示遇到未知种类的类型。

javax.management 中 Throwable 的使用

javax.management 中 Throwable 的子类
class | AttributeNotFoundException 指定的属性不存在或无法检索。
class | BadAttributeValueExpException 向构造的查询方法传递无效的 MBean 属性时，抛出此异常。
class | BadBinaryOpValueExpException 向构造查询的方法传递无效的表达式时，抛出此异常。
class | BadStringOperationException 向构造查询的方法传递无效的字符串操作时，抛出此异常。
class | InstanceAlreadyExistsException 已经在存储库中注册了 MBean。
class | InstanceNotFoundException 存储库中不存在指定的 MBean。
class | InvalidApplicationException 试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。
class | InvalidAttributeValueException 指定的值对该属性无效。
class | JMException 由 JMX 实现所抛出的异常。
class | JMRuntimeException 由 JMX 实现所发出的运行时异常。
class | ListenerNotFoundException 存储库中不存在指定的 MBean 侦听器。
class | MalformedObjectNameException 字符串的格式不对应于有效的 ObjectName。
class | MBeanException 表示由代理的 MBean 方法所抛出的“用户定义的”异常。
class | MBeanRegistrationException 包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
class | NotCompliantMBeanException 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
class | OperationsException 表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
class | ReflectionException 表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
class | RuntimeErrorException 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
class | RuntimeMBeanException 表示由代理中的 MBean 方法抛出的运行时异常。
class | RuntimeOperationsException 表示在 MBean 上执行操作时代理中抛出的运行时异常。
class | ServiceNotFoundException 表示请求的服务不受支持时引发的异常。

返回 Throwable 的 javax.management 中的方法
Throwable | MBeanException.getCause() 返回实际抛出的 Exception。
Throwable | ReflectionException.getCause() 返回抛出的实际 Exception。
Throwable | RuntimeErrorException.getCause() 返回抛出的实际 Error。
Throwable | RuntimeMBeanException.getCause() 返回抛出的实际 RuntimeException。
Throwable | RuntimeOperationsException.getCause() 返回抛出的实际 RuntimeException。

抛出 Throwable 的 javax.management 中的方法
 Object MBeanServerInvocationHandler.invoke(Object proxy, Method method, Object[] args)

javax.management.modelmbean 中 Throwable 的使用

javax.management.modelmbean 中 Throwable 的子类
class | InvalidTargetObjectTypeException 当指定了无效的目标对象类型时，抛出此异常。
class | XMLParseException 当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。

javax.management.monitor 中 Throwable 的使用

javax.management.monitor 中 Throwable 的子类
 class MonitorSettingException
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

javax.management.openmbean 中 Throwable 的使用

javax.management.openmbean 中 Throwable 的子类
class | InvalidOpenTypeException 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
class | KeyAlreadyExistsException 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。
class | OpenDataException 因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。

抛出 Throwable 的 javax.management.openmbean 中的方法
 Object CompositeDataInvocationHandler.invoke(Object proxy, Method method, Object[] args)

javax.management.relation 中 Throwable 的使用

javax.management.relation 中 Throwable 的子类
class | InvalidRelationIdException 为关系提供的关系 id 已使用时引发此异常。
class | InvalidRelationServiceException 提供无效 Relation Service（关系服务）时引发此异常。
class | InvalidRelationTypeException 无效的关系类型。
class | InvalidRoleInfoException 在角色信息中，其最小程度大于其最大程度时，引发此异常。
class | InvalidRoleValueException 角色值无效。
class | RelationException 此类是关系管理过程中引发的任何异常的超类。
class | RelationNotFoundException Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
class | RelationServiceNotRegisteredException 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
class | RelationTypeNotFoundException Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
class | RoleInfoNotFoundException 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
class | RoleNotFoundException 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

javax.management.remote 中 Throwable 的使用

javax.management.remote 中 Throwable 的子类
class | JMXProviderException 当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
class | JMXServerErrorException 在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。

返回 Throwable 的 javax.management.remote 中的方法
Throwable | JMXProviderException.getCause()
Throwable | JMXServerErrorException.getCause()

参数类型为 Throwable 的 javax.management.remote 中的构造方法
JMXProviderException(String message, Throwable cause)
构造带指定详细消息和嵌套异常的 JMXProviderException。

javax.naming 中 Throwable 的使用

javax.naming 中 Throwable 的子类
class | AuthenticationNotSupportedException 当所请求验证的特定 flavor 不受支持时，抛出此异常。
class | CannotProceedException 抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
class | CommunicationException 当客户端无法与目录或命名服务通信时，抛出此异常。
class | ConfigurationException 当存在配置问题时，抛出此异常。
class | ContextNotEmptyException 当试图销毁一个不为空的上下文时，抛出此异常。
class | InsufficientResourcesException 当无法使用资源完成所请求的操作时，抛出此异常。
class | InterruptedNamingException 当正被调用的命名操作已经被中断时，抛出此异常。
class | InvalidNameException 此异常指示被指定的名称不符合命名系统的命名语法。
class | LimitExceededException 当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
class | LinkException 此异常用于描述解析链接时遇到的问题。
class | LinkLoopException 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
class | MalformedLinkException 如果在解析或构造链接时遇到错误链接，则抛出此异常。
class | NameAlreadyBoundException 一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
class | NameNotFoundException 当名称的组件由于没有被绑定而无法解析时，抛出此异常。
class | NamingException 此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
class | NamingSecurityException 此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
class | NoInitialContextException 当不能创建任何初始上下文实现时，抛出此异常。
class | NoPermissionException 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
class | NotContextException 当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
class | OperationNotSupportedException 当上下文实现不支持将调用的操作时，抛出此异常。
class | PartialResultException 抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
class | ReferralException 此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
class | ServiceUnavailableException 当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
class | SizeLimitExceededException 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
class | TimeLimitExceededException 当某一方法没有在指定的时间限制内终止时，抛出此异常。

声明为 Throwable 的 javax.naming 中的字段
protected  Throwable NamingException.rootException
包含导致抛出此 NamingException 的原始异常。

返回 Throwable 的 javax.naming 中的方法
Throwable | NamingException.getCause() 返回此异常的 cause。
Throwable | NamingException.getRootCause() 检索此 NamingException 的根 cause，如果有的话。
Throwable | NamingException.initCause(Throwable cause) 将此异常的 cause 初始化为指定值。

参数类型为 Throwable 的 javax.naming 中的方法
Throwable | NamingException.initCause(Throwable cause) 将此异常的 cause 初始化为指定值。
void | NamingException.setRootCause(Throwable e) 记录此 NamingException 的根 cause。

javax.naming.directory 中 Throwable 的使用

javax.naming.directory 中 Throwable 的子类
class | AttributeInUseException 当操作试图添加已经存在的属性时抛出此异常。
class | AttributeModificationException 当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
class | InvalidAttributeIdentifierException 在试图用无效的属性标识符创建属性时，抛出此异常。
class | InvalidAttributesException 在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
class | InvalidSearchControlsException 在为搜索操作指定的 SearchControls 无效时，抛出此异常。
class | InvalidSearchFilterException 当指定的搜索过滤器无效时，抛出此异常。
class | NoSuchAttributeException 尝试访问不存在的属性时，抛出此异常。
class | SchemaViolationException 当方法在某些方面违反模式时，抛出此异常。

javax.naming.ldap 中 Throwable 的使用

javax.naming.ldap 中 Throwable 的子类
 class LdapReferralException
此抽象类用于表示 LDAP 引用异常。

javax.net.ssl 中 Throwable 的使用

javax.net.ssl 中 Throwable 的子类
class | SSLException 指示由 SSL 子系统检测到的某类错误。
class | SSLHandshakeException 指示客户端和服务器不能就所需安全级别进行协商。
class | SSLKeyException 报告错误的 SSL 密钥。
class | SSLPeerUnverifiedException 指示还没有验证同位体的身份。
class | SSLProtocolException 报告在 SSL 协议的操作中的错误。

参数类型为 Throwable 的 javax.net.ssl 中的构造方法
SSLException(String message, Throwable cause)
创建带指定详细消息和原因的 SSLException。
SSLException(Throwable cause)
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造异常 SSLException（它通常包含 cause 的类和详细消息）。

javax.print 中 Throwable 的使用

javax.print 中 Throwable 的子类
 class PrintException
类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。

javax.print.attribute 中 Throwable 的使用

javax.print.attribute 中 Throwable 的子类
 class UnmodifiableSetException
当由于设置不可修改而无法执行请求的操作时，抛出该异常。

javax.rmi.CORBA 中 Throwable 的使用

参数类型为 Throwable 的 javax.rmi.CORBA 中的方法
static RemoteException Util.wrapException(Throwable orig)
包装由实现方法抛出的异常。
 RemoteException UtilDelegate.wrapException(Throwable obj)
Util.wrapException(java.lang.Throwable) 的委托调用。

javax.script 中 Throwable 的使用

javax.script 中 Throwable 的子类
 class ScriptException
脚本 API 的一般 Exception 类。

javax.security.auth 中 Throwable 的使用

javax.security.auth 中 Throwable 的子类
class | DestroyFailedException 当 destroy 操作失败时，抛出此异常。
class | RefreshFailedException 当 refresh 操作失败时，抛出此异常。

javax.security.auth.callback 中 Throwable 的使用

javax.security.auth.callback 中 Throwable 的子类
 class UnsupportedCallbackException
在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

javax.security.auth.login 中 Throwable 的使用

javax.security.auth.login 中 Throwable 的子类
class | AccountException 一般的帐户异常。
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。
class | CredentialException 一般证书异常。
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。
class | FailedLoginException 当用户验证失败时抛出此异常。
class | LoginException 此异常是基本的登录异常。

javax.security.cert 中 Throwable 的使用

javax.security.cert 中 Throwable 的子类
class | CertificateEncodingException 证书编码异常。
class | CertificateException 此异常指示各种证书问题之一。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书不再有效异常。
class | CertificateParsingException 证书解析异常。

javax.security.sasl 中 Throwable 的使用

javax.security.sasl 中 Throwable 的子类
class | AuthenticationException 此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。
class | SaslException 此类表示在使用 SASL 时所发生的错误。

返回 Throwable 的 javax.security.sasl 中的方法
Throwable | SaslException.getCause()
Throwable | SaslException.initCause(Throwable cause)

参数类型为 Throwable 的 javax.security.sasl 中的方法
 Throwable SaslException.initCause(Throwable cause)

参数类型为 Throwable 的 javax.security.sasl 中的构造方法
AuthenticationException(String detail, Throwable ex)
构造带详细消息和根异常的新 AuthenticationException 实例。
SaslException(String detail, Throwable ex)
构造带详细消息和根异常的新 SaslException 实例。

javax.sound.midi 中 Throwable 的使用

javax.sound.midi 中 Throwable 的子类
class | InvalidMidiDataException 一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
class | MidiUnavailableException 当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。

javax.sound.sampled 中 Throwable 的使用

javax.sound.sampled 中 Throwable 的子类
class | LineUnavailableException LineUnavailableException 是指示某一行因为不可用而无法打开的异常。
class | UnsupportedAudioFileException UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

javax.sql.rowset 中 Throwable 的使用

javax.sql.rowset 中 Throwable 的子类
 class RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

javax.sql.rowset.serial 中 Throwable 的使用

javax.sql.rowset.serial 中 Throwable 的子类
 class SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

javax.sql.rowset.spi 中 Throwable 的使用

javax.sql.rowset.spi 中 Throwable 的子类
class | SyncFactoryException 指示 SyncFactory 机制发生的错误。
class | SyncProviderException 指示 SyncProvider 机制发生的错误。

javax.swing 中 Throwable 的使用

javax.swing 中 Throwable 的子类
 class UnsupportedLookAndFeelException
指示在用户系统上不存在请求的外观管理类的异常。

javax.swing.text 中 Throwable 的使用

javax.swing.text 中 Throwable 的子类
class | BadLocationException 此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
class | ChangedCharSetException 顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。

javax.swing.tree 中 Throwable 的使用

javax.swing.tree 中 Throwable 的子类
 class ExpandVetoException
用于阻止扩展/折叠发生的异常。

javax.swing.undo 中 Throwable 的使用

javax.swing.undo 中 Throwable 的子类
class | CannotRedoException 当 UndoableEdit 被通知 redo() 但无法执行时抛出。
class | CannotUndoException 当 UndoableEdit 被通知 undo() 但无法执行时抛出。

javax.transaction 中 Throwable 的使用

javax.transaction 中 Throwable 的子类
class | InvalidTransactionException 此异常指示该请求带来了无效的事务上下文。
class | TransactionRequiredException 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
class | TransactionRolledbackException 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

javax.transaction.xa 中 Throwable 的使用

javax.transaction.xa 中 Throwable 的子类
 class XAException
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。

javax.xml.bind 中 Throwable 的使用

javax.xml.bind 中 Throwable 的子类
class | JAXBException 这是所有 JAXB 异常的根异常类。
class | PropertyException 此异常指示在获取或设置属性时遇到一个错误。
class | TypeConstraintException 此异常指示已检测到存在违反动态检查的类型约束的情况。
class | ValidationException 此异常指示在执行验证操作时发生错误。

返回 Throwable 的 javax.xml.bind 中的方法
Throwable | JAXBException.getCause()
Throwable | JAXBException.getLinkedException() 获取链接的异常。
Throwable | TypeConstraintException.getLinkedException() 获取链接的异常。
Throwable | ValidationEvent.getLinkedException() 检索此警告/错误的链接异常。

参数类型为 Throwable 的 javax.xml.bind 中的方法
void | JAXBException.setLinkedException(Throwable exception) 添加链接的异常。
void | TypeConstraintException.setLinkedException(Throwable exception) 添加一个链接的异常。

参数类型为 Throwable 的 javax.xml.bind 中的构造方法
JAXBException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 JAXBException。
JAXBException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 JAXBException。
JAXBException(Throwable exception)
构造带有一个 linkedException 的 JAXBException。
MarshalException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 MarshalException。
MarshalException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 MarshalException。
MarshalException(Throwable exception)
构造带有一个 linkedException 的 MarshalException。
PropertyException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 PropertyException。
PropertyException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 PropertyException。
PropertyException(Throwable exception)
构造带有一个 linkedException 的 PropertyException。
TypeConstraintException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 TypeConstraintException。
TypeConstraintException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 TypeConstraintException。
TypeConstraintException(Throwable exception)
构造带有一个 linkedException 的 TypeConstraintException。
UnmarshalException(String message, String errorCode, Throwable exception)
构造带指定详细消息、特定于供应商的 errorCode 和 linkedException 的 UnmarshalException。
UnmarshalException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 UnmarshalException。
UnmarshalException(Throwable exception)
构造带有一个 linkedException 的 UnmarshalException。
ValidationException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 ValidationException。
ValidationException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 ValidationException。
ValidationException(Throwable exception)
构造带有一个 linkedException 的 ValidationException。

javax.xml.bind.helpers 中 Throwable 的使用

返回 Throwable 的 javax.xml.bind.helpers 中的方法
 Throwable ValidationEventImpl.getLinkedException()

参数类型为 Throwable 的 javax.xml.bind.helpers 中的方法
 void ValidationEventImpl.setLinkedException(Throwable _linkedException)
设置此事件的 linked exception 字段。

参数类型为 Throwable 的 javax.xml.bind.helpers 中的构造方法
NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 NotIdentifiableEventImpl。
ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ParseConversionEventImpl。
PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 PrintConversionEventImpl。
ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ValidationEventImpl。

javax.xml.crypto 中 Throwable 的使用

javax.xml.crypto 中 Throwable 的子类
class | KeySelectorException 指示由 KeySelector 抛出的异常条件。
class | MarshalException 指示 XML 编组或解组过程中发生的异常条件。
class | NoSuchMechanismException 当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。
class | URIReferenceException 指示取消引用 URIReference 时抛出的异常条件。

返回 Throwable 的 javax.xml.crypto 中的方法
Throwable | KeySelectorException.getCause() 返回此 KeySelectorException 的 cause，如果 cause 不存在或未知，则返回 null。
Throwable | MarshalException.getCause() 返回此 MarshalException 的 cause；如果 cause 不存在或未知，则返回 null。
Throwable | NoSuchMechanismException.getCause() 返回此 NoSuchMechanismException 的 cause，如果 cause 不存在或未知，则返回 null。
Throwable | URIReferenceException.getCause() 返回此 URIReferenceException 的 cause，如果 cause 不存在或未知，则返回 null。

参数类型为 Throwable 的 javax.xml.crypto 中的构造方法
KeySelectorException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 KeySelectorException。
KeySelectorException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 KeySelectorException（它通常包含 cause 的类和详细消息）。
MarshalException(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 MarshalException。
MarshalException(Throwable cause)
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的 MarshalException（它通常包含 cause 的类和详细消息）。
NoSuchMechanismException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 NoSuchMechanismException。
NoSuchMechanismException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 NoSuchMechanismException（它通常包含 cause 的类和详细消息）。
URIReferenceException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 URIReferenceException。
URIReferenceException(String message, Throwable cause, URIReference uriReference)
构造带指定详细消息、cause 和 URIReference 的新 URIReferenceException。
URIReferenceException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 URIReferenceException（它通常包含 cause 的类和详细消息）。

javax.xml.crypto.dsig 中 Throwable 的使用

javax.xml.crypto.dsig 中 Throwable 的子类
class | TransformException 指示执行转换算法时出现异常的异常条件。
class | XMLSignatureException 指示生成或验证 XML 签名过程中发生的异常条件。

返回 Throwable 的 javax.xml.crypto.dsig 中的方法
Throwable | TransformException.getCause() 返回此 TransformException 的 cause，如果 cause 不存在或未知，则返回 null。
Throwable | XMLSignatureException.getCause() 返回此 XMLSignatureException 的 cause；如果 cause 不存在或未知，则返回 null。

参数类型为 Throwable 的 javax.xml.crypto.dsig 中的构造方法
TransformException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 TransformException。
TransformException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 TransformException（它通常包含 cause 的类和详细消息）。
XMLSignatureException(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 XMLSignatureException。
XMLSignatureException(Throwable cause)
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 XMLSignatureException（它通常包含 cause 的类和详细消息）。

javax.xml.datatype 中 Throwable 的使用

javax.xml.datatype 中 Throwable 的子类
 class DatatypeConfigurationException
指示严重的配置错误。

参数类型为 Throwable 的 javax.xml.datatype 中的构造方法
DatatypeConfigurationException(String message, Throwable cause)
创建带有指定详细消息和原因的新 DatatypeConfigurationException。
DatatypeConfigurationException(Throwable cause)
使用指定的原因创建一个新的 DatatypeConfigurationException。

javax.xml.parsers 中 Throwable 的使用

javax.xml.parsers 中 Throwable 的子类
class | FactoryConfigurationError 当解析器工厂的配置存在问题时抛出该异常。
class | ParserConfigurationException 指示一个严重的配置错误。

javax.xml.soap 中 Throwable 的使用

javax.xml.soap 中 Throwable 的子类
 class SOAPException
当发生 SOAP 异常时，抛出此异常。

返回 Throwable 的 javax.xml.soap 中的方法
Throwable | SOAPException.getCause() 返回此 SOAPException 中嵌入的 Throwable 对象（如果有）。
Throwable | SOAPException.initCause(Throwable cause) 使用给定的 Throwable 对象初始化此 SOAPException 对象的 cause 字段。

参数类型为 Throwable 的 javax.xml.soap 中的方法
 Throwable SOAPException.initCause(Throwable cause)
使用给定的 Throwable 对象初始化此 SOAPException 对象的 cause 字段。

参数类型为 Throwable 的 javax.xml.soap 中的构造方法
SOAPException(String reason, Throwable cause)
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因，使用给定 Throwable 对象作为嵌入的异常。
SOAPException(Throwable cause)
构造使用给定 Throwable 对象初始化的 SOAPException 对象。

javax.xml.stream 中 Throwable 的使用

javax.xml.stream 中 Throwable 的子类
 class XMLStreamException
用于不可预料处理错误的基本异常。

声明为 Throwable 的 javax.xml.stream 中的字段
protected  Throwable XMLStreamException.nested

返回 Throwable 的 javax.xml.stream 中的方法
 Throwable XMLStreamException.getNestedException()
获取嵌套异常。

参数类型为 Throwable 的 javax.xml.stream 中的构造方法
XMLStreamException(String msg, Location location, Throwable th)
构造具有关联消息、异常和位置的异常。
XMLStreamException(String msg, Throwable th)
构造具有关联消息和异常的异常
XMLStreamException(Throwable th)
构造具有关联异常的异常

javax.xml.transform 中 Throwable 的使用

javax.xml.transform 中 Throwable 的子类
class | TransformerConfigurationException 指示严重的配置错误。
class | TransformerException 此类指定了转换过程中发生的异常条件。
class | TransformerFactoryConfigurationError 当通过 Transformer Factories 进行的配置存在问题时抛出此异常。

返回 Throwable 的 javax.xml.transform 中的方法
Throwable | TransformerException.getCause() 返回此抛出对象的原因，如果原因不存在或未知，则返回 null。
Throwable | TransformerException.getException() 此方法检索此异常所包装的异常。
Throwable | TransformerException.initCause(Throwable cause) 将此抛出对象的原因 初始化为指定值。

参数类型为 Throwable 的 javax.xml.transform 中的方法
 Throwable TransformerException.initCause(Throwable cause)
将此抛出对象的原因 初始化为指定值。

参数类型为 Throwable 的 javax.xml.transform 中的构造方法
TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
包装了 TransformerConfigurationException 中的现有异常。
TransformerConfigurationException(String msg, Throwable e)
创建带有给定 Exception 基本原因和详细消息的新 TransformerConfigurationException。
TransformerConfigurationException(Throwable e)
创建带有错误的给定 Exception 基本原因的新 TransformerConfigurationException。
TransformerException(String message, SourceLocator locator, Throwable e)
包装了 TransformerException 中的现有异常。
TransformerException(String message, Throwable e)
包装 TransformerException 中的一个现有异常。
TransformerException(Throwable e)
创建一个包装了现有异常的新 TransformerException。

javax.xml.ws 中 Throwable 的使用

javax.xml.ws 中 Throwable 的子类
 class WebServiceException
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

参数类型为 Throwable 的 javax.xml.ws 中的构造方法
ProtocolException(String message, Throwable cause)
构造一个具有指定详细消息和 cause 的新运行时异常。
ProtocolException(Throwable cause)
构造具有指定 cause 和详细消息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新运行时异常。
WebServiceException(String message, Throwable cause)
构造一个具有指定详细消息和 cause 的新异常。
WebServiceException(Throwable cause)
构造具有指定 cause 和详细信息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新 WebServiceException。

javax.xml.ws.http 中 Throwable 的使用

javax.xml.ws.http 中 Throwable 的子类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 Throwable 的使用

javax.xml.ws.soap 中 Throwable 的子类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

javax.xml.xpath 中 Throwable 的使用

javax.xml.xpath 中 Throwable 的子类
class | XPathException XPathException 表示通用 XPath 异常。
class | XPathExpressionException XPathExpressionException 表示 XPath 表达式中的错误。
class | XPathFactoryConfigurationException XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
class | XPathFunctionException XPathFunctionException 表示 XPath 函数的错误。

返回 Throwable 的 javax.xml.xpath 中的方法
 Throwable XPathException.getCause()
获取此 XPathException 的 cause。

参数类型为 Throwable 的 javax.xml.xpath 中的构造方法
XPathException(Throwable cause)
构造带指定 cause 的新 XPathException。
XPathExpressionException(Throwable cause)
构造带指定 cause 的新 XPathExpressionException。
XPathFactoryConfigurationException(Throwable cause)
构造带指定 cause 的新 XPathFactoryConfigurationException。
XPathFunctionException(Throwable cause)
构造带指定 cause 的新 XPathFunctionException。

org.ietf.jgss 中 Throwable 的使用

org.ietf.jgss 中 Throwable 的子类
 class GSSException
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。

org.omg.CORBA 中 Throwable 的使用

org.omg.CORBA 中 Throwable 的子类
class | ACTIVITY_COMPLETED ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
class | ACTIVITY_REQUIRED ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
class | BAD_CONTEXT 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
class | BAD_INV_ORDER 此异常指示调用者按错误顺序调用了操作。
class | BAD_OPERATION 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
class | BAD_PARAM 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
class | BAD_QOS 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
class | BAD_TYPECODE 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
class | Bounds 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
class | CODESET_INCOMPATIBLE 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
class | COMM_FAILURE 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
class | DATA_CONVERSION 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
class | FREE_MEM 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
class | IMP_LIMIT 此异常指示在 OBR 运行时超过了某一项实现限制。
class | INITIALIZE ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
class | INTERNAL 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
class | INTF_REPOS 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
class | INV_FLAG 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
class | INV_IDENT 此异常指示 IDL 标识符在语法上是无效的。
class | INV_OBJREF 此异常指示对象引用存在内部错误。
class | INV_POLICY 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
class | INVALID_ACTIVITY 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
class | INVALID_TRANSACTION 当请求带有无效的事务上下文时，抛出此异常。
class | MARSHAL 表示网络中传来的请求或应答在结构上无效。
class | NO_IMPLEMENT 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
class | NO_MEMORY 如果 ORB 运行时出现内存不足，则抛出此异常。
class | NO_PERMISSION 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
class | NO_RESOURCES 当 ORB 遇到一些一般资源限制时，抛出此异常。
class | NO_RESPONSE 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
class | OBJ_ADAPTER 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
class | OBJECT_NOT_EXIST 只要在已删除的对象上执行调用，就会引发此异常。
class | PERSIST_STORE 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
class | PolicyError 发生策略错误时抛出的用户异常。
class | REBIND 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
class | SystemException 所有 CORBA 标准异常的根类。
class | TIMEOUT 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
class | TRANSACTION_MODE 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
class | TRANSACTION_REQUIRED 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
class | TRANSACTION_ROLLEDBACK 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
class | TRANSACTION_UNAVAILABLE 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
class | TRANSIENT 当 ORB 试图到达某一对象但失败时，抛出此异常。
class | UNKNOWN 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。
class | UnknownUserException 包含由服务器返回的用户异常的类。
class | UserException CORBA IDL 定义的用户异常的根类。
class | WrongTransaction CORBA WrongTransaction 用户定义异常。

org.omg.CORBA.DynAnyPackage 中 Throwable 的使用

org.omg.CORBA.DynAnyPackage 中 Throwable 的子类
class | Invalid 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
class | InvalidSeq 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
class | InvalidValue
class | TypeMismatch 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 Throwable 的使用

org.omg.CORBA.ORBPackage 中 Throwable 的子类
class | InconsistentTypeCode 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
class | InvalidName 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.portable 中 Throwable 的使用

org.omg.CORBA.portable 中 Throwable 的子类
class | ApplicationException 此类用来报告 ORB 和 stub 之间的应用程序级异常。
class | IndirectionException Indirection 异常是一个特定于 Java 的系统异常。
class | RemarshalException 此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
class | UnknownException org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

声明为 Throwable 的 org.omg.CORBA.portable 中的字段
 Throwable UnknownException.originalEx
一个 throwable 对象，包装在 CORBA UnknownException 中的原始异常。

参数类型为 Throwable 的 org.omg.CORBA.portable 中的构造方法
UnknownException(Throwable ex)
构造一个 UnknownException 对象。

org.omg.CORBA.TypeCodePackage 中 Throwable 的使用

org.omg.CORBA.TypeCodePackage 中 Throwable 的子类
 class BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming.NamingContextExtPackage 中 Throwable 的使用

org.omg.CosNaming.NamingContextExtPackage 中 Throwable 的子类
 class InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextPackage 中 Throwable 的使用

org.omg.CosNaming.NamingContextPackage 中 Throwable 的子类
class | AlreadyBound org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
class | CannotProceed org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
class | NotEmpty org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
class | NotFound org/omg/CosNaming/NamingContextPackage/NotFound.java。

org.omg.IOP.CodecFactoryPackage 中 Throwable 的使用

org.omg.IOP.CodecFactoryPackage 中 Throwable 的子类
 class UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecPackage 中 Throwable 的使用

org.omg.IOP.CodecPackage 中 Throwable 的子类
class | FormatMismatch org/omg/IOP/CodecPackage/FormatMismatch.java。
class | InvalidTypeForEncoding org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

org.omg.PortableInterceptor 中 Throwable 的使用

org.omg.PortableInterceptor 中 Throwable 的子类
 class InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Throwable 的使用

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Throwable 的子类
 class DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

org.omg.PortableServer 中 Throwable 的使用

org.omg.PortableServer 中 Throwable 的子类
 class ForwardRequest
org/omg/PortableServer/ForwardRequest.java。

org.omg.PortableServer.CurrentPackage 中 Throwable 的使用

org.omg.PortableServer.CurrentPackage 中 Throwable 的子类
 class NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.POAManagerPackage 中 Throwable 的使用

org.omg.PortableServer.POAManagerPackage 中 Throwable 的子类
 class AdapterInactive
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。

org.omg.PortableServer.POAPackage 中 Throwable 的使用

org.omg.PortableServer.POAPackage 中 Throwable 的子类
class | AdapterAlreadyExists org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
class | AdapterNonExistent org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
class | InvalidPolicy org/omg/PortableServer/POAPackage/InvalidPolicy.java。
class | NoServant org/omg/PortableServer/POAPackage/NoServant.java。
class | ObjectAlreadyActive org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
class | ObjectNotActive org/omg/PortableServer/POAPackage/ObjectNotActive.java。
class | ServantAlreadyActive org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
class | ServantNotActive org/omg/PortableServer/POAPackage/ServantNotActive.java。
class | WrongAdapter org/omg/PortableServer/POAPackage/WrongAdapter.java。
class | WrongPolicy org/omg/PortableServer/POAPackage/WrongPolicy.java。

org.w3c.dom 中 Throwable 的使用

org.w3c.dom 中 Throwable 的子类
 class DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

org.w3c.dom.events 中 Throwable 的使用

org.w3c.dom.events 中 Throwable 的子类
 class EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。

org.w3c.dom.ls 中 Throwable 的使用

org.w3c.dom.ls 中 Throwable 的子类
 class LSException
如果处理停止，解析或写操作可以抛出 LSException。

org.xml.sax 中 Throwable 的使用

org.xml.sax 中 Throwable 的子类
class | SAXException 封装一般的 SAX 错误或警告。
class | SAXNotRecognizedException 用于未识别的标识符的 Exception 类。
class | SAXNotSupportedException 用于不被支持的操作的 Exception 类。
class | SAXParseException 封装 XML 解析错误或警告。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.TypeNotPresentException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.TypeNotPresentException
的使用

没有 java.lang.TypeNotPresentException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.UnknownError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.UnknownError
的使用

没有 java.lang.UnknownError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.UnsatisfiedLinkError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.UnsatisfiedLinkError
的使用

没有 java.lang.UnsatisfiedLinkError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.UnsupportedClassVersionError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.UnsupportedClassVersionError
的使用

没有 java.lang.UnsupportedClassVersionError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.UnsupportedOperationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.UnsupportedOperationException
的使用

使用 UnsupportedOperationException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
javax.imageio | Java Image I/O API 的主要包。
javax.management.loading | 提供实现高级动态加载的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。

java.awt 中 UnsupportedOperationException 的使用

java.awt 中 UnsupportedOperationException 的子类
 class HeadlessException
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。

抛出 UnsupportedOperationException 的 java.awt 中的方法
boolean | Toolkit.getLockingKeyState(int keyCode) 返回键盘上给定锁定键是否处于 "on" 状态。
void | Toolkit.setLockingKeyState(int keyCode, boolean on) 设置键盘上给定锁定键的状态。

java.nio 中 UnsupportedOperationException 的使用

java.nio 中 UnsupportedOperationException 的子类
 class ReadOnlyBufferException
当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

javax.imageio 中 UnsupportedOperationException 的使用

抛出 UnsupportedOperationException 的 javax.imageio 中的方法
 void ImageReadParam.setSourceRenderSize(Dimension size)
如果能够以任意大小呈现图像，则将源宽度和高度设置为所提供的值。

javax.management.loading 中 UnsupportedOperationException 的使用

抛出 UnsupportedOperationException 的 javax.management.loading 中的方法
void | MLet.readExternal(ObjectInput in) 从给定的 ObjectInput 恢复此 MLet 的内容。
void | MLet.writeExternal(ObjectOutput out) 将此 MLet 的内容保存到给定的 ObjectOutput。

javax.xml.soap 中 UnsupportedOperationException 的使用

抛出 UnsupportedOperationException 的 javax.xml.soap 中的方法
static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
创建默认 SOAPConnectionFactory 对象的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.VerifyError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.VerifyError
的使用

没有 java.lang.VerifyError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.VirtualMachineError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.VirtualMachineError
的使用

使用 VirtualMachineError 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.lang 中 VirtualMachineError 的使用

java.lang 中 VirtualMachineError 的子类
class | InternalError 该异常指示 Java 虚拟机中出现一些意外的内部错误。
class | OutOfMemoryError 因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
class | StackOverflowError 当应用程序递归太深而发生堆栈溢出时，抛出该错误。
class | UnknownError 当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。

java.util.zip 中 VirtualMachineError 的使用

java.util.zip 中 VirtualMachineError 的子类
 class ZipError
发生不可恢复的错误时抛出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.Void 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Void
的使用

使用 Void 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang 中 Void 的使用

类型参数类型为 Void 的 java.lang 中的字段
static Class<Void> Void.TYPE
表示对应于关键字 void 的伪类型的 Class 对象。

javax.management.openmbean 中 Void 的使用

类型参数类型为 Void 的 javax.management.openmbean 中的字段
static SimpleType<Void> SimpleType.VOID
SimpleType 实例描述其 Java 类名称为 java.lang.Void 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.lang.instrument (Java 2 Platform SE 6)

 java.lang.instrument
接口
ClassFileTransformer
Instrumentation
类
ClassDefinition
异常
IllegalClassFormatException
UnmodifiableClassException


类 java.lang.instrument.ClassDefinition 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.instrument.ClassDefinition
的使用

使用 ClassDefinition 的软件包
java.lang.instrument 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.instrument 中 ClassDefinition 的使用

参数类型为 ClassDefinition 的 java.lang.instrument 中的方法
 void Instrumentation.redefineClasses(ClassDefinition... definitions)
使用提供的类文件重定义提供的类集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.instrument.ClassFileTransformer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.instrument.ClassFileTransformer
的使用

使用 ClassFileTransformer 的软件包
java.lang.instrument 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.instrument 中 ClassFileTransformer 的使用

参数类型为 ClassFileTransformer 的 java.lang.instrument 中的方法
void | Instrumentation.addTransformer(ClassFileTransformer transformer) 注册提供的转换器。
void | Instrumentation.addTransformer(ClassFileTransformer transformer, boolean canRetransform) 注册提供的转换器。
boolean | Instrumentation.removeTransformer(ClassFileTransformer transformer) 注销提供的转换器。
void | Instrumentation.setNativeMethodPrefix(ClassFileTransformer transformer, String prefix) 通过允许重试，将前缀应用到名称，此方法修改本机方法解析的失败处理。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.instrument.IllegalClassFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.instrument.IllegalClassFormatException
的使用

使用 IllegalClassFormatException 的软件包
java.lang.instrument 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.instrument 中 IllegalClassFormatException 的使用

抛出 IllegalClassFormatException 的 java.lang.instrument 中的方法
 byte[] ClassFileTransformer.transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.instrument.Instrumentation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.instrument.Instrumentation
的使用

没有 java.lang.instrument.Instrumentation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.instrument.UnmodifiableClassException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.instrument.UnmodifiableClassException
的使用

使用 UnmodifiableClassException 的软件包
java.lang.instrument 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.instrument 中 UnmodifiableClassException 的使用

抛出 UnmodifiableClassException 的 java.lang.instrument 中的方法
void | Instrumentation.redefineClasses(ClassDefinition... definitions) 使用提供的类文件重定义提供的类集。
void | Instrumentation.retransformClasses(Class<?>... classes) 重转换提供的类集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.lang.management (Java 2 Platform SE 6)

 java.lang.management
接口
ClassLoadingMXBean
CompilationMXBean
GarbageCollectorMXBean
MemoryManagerMXBean
MemoryMXBean
MemoryPoolMXBean
OperatingSystemMXBean
RuntimeMXBean
ThreadMXBean
类
LockInfo
ManagementFactory
ManagementPermission
MemoryNotificationInfo
MemoryUsage
MonitorInfo
ThreadInfo
枚举
MemoryType


接口 java.lang.management.ClassLoadingMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.ClassLoadingMXBean
的使用

使用 ClassLoadingMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 ClassLoadingMXBean 的使用

返回 ClassLoadingMXBean 的 java.lang.management 中的方法
static ClassLoadingMXBean ManagementFactory.getClassLoadingMXBean()
返回 Java 虚拟机的类加载系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.management.CompilationMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.CompilationMXBean
的使用

使用 CompilationMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 CompilationMXBean 的使用

返回 CompilationMXBean 的 java.lang.management 中的方法
static CompilationMXBean ManagementFactory.getCompilationMXBean()
返回 Java 虚拟机的编译系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.management.GarbageCollectorMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.GarbageCollectorMXBean
的使用

使用 GarbageCollectorMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 GarbageCollectorMXBean 的使用

返回变量类型为 GarbageCollectorMXBean 的类型的 java.lang.management 中的方法
static List<GarbageCollectorMXBean> ManagementFactory.getGarbageCollectorMXBeans()
返回 Java 虚拟机中的 GarbageCollectorMXBean 对象列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.management.LockInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.LockInfo
的使用

使用 LockInfo 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 LockInfo 的使用

java.lang.management 中 LockInfo 的子类
 class MonitorInfo
关于对象监视器锁的信息。

返回 LockInfo 的 java.lang.management 中的方法
LockInfo[] | ThreadInfo.getLockedSynchronizers() 返回 LockInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的可拥有同步器。
LockInfo | ThreadInfo.getLockInfo() 返回对象的 LockInfo，与此 ThreadInfo 关联的线程被阻塞并等待该对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.management.ManagementFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.ManagementFactory
的使用

没有 java.lang.management.ManagementFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.management.ManagementPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.ManagementPermission
的使用

没有 java.lang.management.ManagementPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.management.MemoryManagerMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.MemoryManagerMXBean
的使用

使用 MemoryManagerMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryManagerMXBean 的使用

java.lang.management 中 MemoryManagerMXBean 的子接口
 interface GarbageCollectorMXBean
用于 Java 虚拟机的垃圾回收的管理接口。

返回变量类型为 MemoryManagerMXBean 的类型的 java.lang.management 中的方法
static List<MemoryManagerMXBean> ManagementFactory.getMemoryManagerMXBeans()
返回 Java 虚拟机中的 MemoryManagerMXBean 对象列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.management.MemoryMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.MemoryMXBean
的使用

使用 MemoryMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryMXBean 的使用

返回 MemoryMXBean 的 java.lang.management 中的方法
static MemoryMXBean ManagementFactory.getMemoryMXBean()
返回 Java 虚拟机的内存系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.management.MemoryNotificationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.MemoryNotificationInfo
的使用

使用 MemoryNotificationInfo 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryNotificationInfo 的使用

返回 MemoryNotificationInfo 的 java.lang.management 中的方法
static MemoryNotificationInfo MemoryNotificationInfo.from(CompositeData cd)
返回由给定 CompositeData 表示的 MemoryNotificationInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.management.MemoryPoolMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.MemoryPoolMXBean
的使用

使用 MemoryPoolMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryPoolMXBean 的使用

返回变量类型为 MemoryPoolMXBean 的类型的 java.lang.management 中的方法
static List<MemoryPoolMXBean> ManagementFactory.getMemoryPoolMXBeans()
返回 Java 虚拟机中的 MemoryPoolMXBean 对象列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.management.MemoryType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.MemoryType
的使用

使用 MemoryType 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryType 的使用

返回 MemoryType 的 java.lang.management 中的方法
MemoryType | MemoryPoolMXBean.getType() 返回此内存池的类型。
static MemoryType | MemoryType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MemoryType[] | MemoryType.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.management.MemoryUsage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.MemoryUsage
的使用

使用 MemoryUsage 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryUsage 的使用

返回 MemoryUsage 的 java.lang.management 中的方法
static MemoryUsage | MemoryUsage.from(CompositeData cd) 返回由给定 CompositeData 表示的 MemoryUsage 对象。
MemoryUsage | MemoryPoolMXBean.getCollectionUsage() 返回 Java 虚拟机最近回收了此内存池中的不使用的对象之后的内存使用量。
MemoryUsage | MemoryMXBean.getHeapMemoryUsage() 返回用于对象分配的堆的当前内存使用量。
MemoryUsage | MemoryMXBean.getNonHeapMemoryUsage() 返回 Java 虚拟机使用的非堆内存的当前内存使用量。
MemoryUsage | MemoryPoolMXBean.getPeakUsage() 返回自 Java 虚拟机启动以来或自峰值重置以来此内存池的峰值内存使用量。
MemoryUsage | MemoryNotificationInfo.getUsage() 返回构造此通知时内存池的内存使用量。
MemoryUsage | MemoryPoolMXBean.getUsage() 返回此内存池的内存使用量的估计数。

参数类型为 MemoryUsage 的 java.lang.management 中的构造方法
MemoryNotificationInfo(String poolName, MemoryUsage usage, long count)
构造一个 MemoryNotificationInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.management.MonitorInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.MonitorInfo
的使用

使用 MonitorInfo 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MonitorInfo 的使用

返回 MonitorInfo 的 java.lang.management 中的方法
static MonitorInfo | MonitorInfo.from(CompositeData cd) 返回给定 CompositeData 表示的 MonitorInfo 对象。
MonitorInfo[] | ThreadInfo.getLockedMonitors() 返回 MonitorInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的对象监视器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.management.OperatingSystemMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.OperatingSystemMXBean
的使用

使用 OperatingSystemMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 OperatingSystemMXBean 的使用

返回 OperatingSystemMXBean 的 java.lang.management 中的方法
static OperatingSystemMXBean ManagementFactory.getOperatingSystemMXBean()
返回运行 Java 虚拟机的操作系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.management.RuntimeMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.RuntimeMXBean
的使用

使用 RuntimeMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 RuntimeMXBean 的使用

返回 RuntimeMXBean 的 java.lang.management 中的方法
static RuntimeMXBean ManagementFactory.getRuntimeMXBean()
返回 Java 虚拟机的运行时系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.management.ThreadInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.ThreadInfo
的使用

使用 ThreadInfo 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 ThreadInfo 的使用

返回 ThreadInfo 的 java.lang.management 中的方法
ThreadInfo[] | ThreadMXBean.dumpAllThreads(boolean lockedMonitors, boolean lockedSynchronizers) 返回所有活动线程的线程信息，并带有堆栈跟踪和同步信息。
static ThreadInfo | ThreadInfo.from(CompositeData cd) 返回由给定 CompositeData 表示的 ThreadInfo 对象。
ThreadInfo | ThreadMXBean.getThreadInfo(long id) 返回指定 id 的不具有堆栈跟踪的线程的线程信息。
ThreadInfo[] | ThreadMXBean.getThreadInfo(long[] ids) 返回其 ID 在输出数组 ids 中的每个线程的线程信息，这些线程不具有堆栈跟踪。
ThreadInfo[] | ThreadMXBean.getThreadInfo(long[] ids, boolean lockedMonitors, boolean lockedSynchronizers) 返回每个线程的线程信息，线程 ID 位于输入数组 ids 中，带有堆栈跟踪和同步信息。
ThreadInfo[] | ThreadMXBean.getThreadInfo(long[] ids, int maxDepth) 返回其 ID 在输入数组 ids 中的每个线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。
ThreadInfo | ThreadMXBean.getThreadInfo(long id, int maxDepth) 返回指定 id 的线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.management.ThreadMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.ThreadMXBean
的使用

使用 ThreadMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 ThreadMXBean 的使用

返回 ThreadMXBean 的 java.lang.management 中的方法
static ThreadMXBean ManagementFactory.getThreadMXBean()
返回 Java 虚拟机的线程系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.lang.ref (Java 2 Platform SE 6)

 java.lang.ref
类
PhantomReference
Reference
ReferenceQueue
SoftReference
WeakReference


类 java.lang.ref.PhantomReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ref.PhantomReference
的使用

没有 java.lang.ref.PhantomReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ref.Reference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ref.Reference
的使用

使用 Reference 的软件包
java.lang.ref 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。

java.lang.ref 中 Reference 的使用

java.lang.ref 中 Reference 的子类
class | PhantomReference<T> 虚引用对象，在回收器确定其指示对象可另外回收之后，被加入队列。
class | SoftReference<T> 软引用对象，在响应内存需要时，由垃圾回收器决定是否清除此对象。
class | WeakReference<T> 弱引用对象，它们并不禁止其指示对象变得可终结，并被终结，然后被回收。

返回 Reference 的 java.lang.ref 中的方法
Reference<? extends T> | ReferenceQueue.poll() 轮询此队列，查看是否存在可用的引用对象。
Reference<? extends T> | ReferenceQueue.remove() 移除此队列中的下一个引用对象，阻塞到某个对象变得可用为止。
Reference<? extends T> | ReferenceQueue.remove(long timeout) 移除此队列中的下一个引用对象，阻塞到有一个对象变得可用或者给定的超时期满了为止。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ref.ReferenceQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ref.ReferenceQueue
的使用

使用 ReferenceQueue 的软件包
java.lang.ref 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。

java.lang.ref 中 ReferenceQueue 的使用

参数类型为 ReferenceQueue 的 java.lang.ref 中的构造方法
PhantomReference(T referent, ReferenceQueue<? super T> q)
创建一个引用给定对象的新的虚引用，并向给定队列注册它。
SoftReference(T referent, ReferenceQueue<? super T> q)
创建一个引用给定对象的新的软引用，并向给定队列注册该引用。
WeakReference(T referent, ReferenceQueue<? super T> q)
创建引用给定对象的新的弱引用，并向给定队列注册该引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ref.SoftReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ref.SoftReference
的使用

没有 java.lang.ref.SoftReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.ref.WeakReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ref.WeakReference
的使用

没有 java.lang.ref.WeakReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.lang.reflect (Java 2 Platform SE 6)

 java.lang.reflect
接口
AnnotatedElement
GenericArrayType
GenericDeclaration
InvocationHandler
Member
ParameterizedType
Type
TypeVariable
WildcardType
类
AccessibleObject
Array
Constructor
Field
Method
Modifier
Proxy
ReflectPermission
异常
InvocationTargetException
MalformedParameterizedTypeException
UndeclaredThrowableException
错误
GenericSignatureFormatError


类 java.lang.reflect.AccessibleObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.AccessibleObject
的使用

使用 AccessibleObject 的软件包
java.lang.reflect 提供类和接口，以获得关于类和对象的反射信息。

java.lang.reflect 中 AccessibleObject 的使用

java.lang.reflect 中 AccessibleObject 的子类
class | Constructor<T> Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
class | Field Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。
class | Method Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

参数类型为 AccessibleObject 的 java.lang.reflect 中的方法
static void AccessibleObject.setAccessible(AccessibleObject[] array, boolean flag)
使用单一安全性检查（为了提高效率）为一组对象设置 accessible 标志的便捷方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.reflect.AnnotatedElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.AnnotatedElement
的使用

使用 AnnotatedElement 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 AnnotatedElement 的使用

实现 AnnotatedElement 的 java.lang 中的类
class | Class<T> Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
class | Package Package 对象包含有关 Java 包的实现和规范的版本信息。

java.lang.reflect 中 AnnotatedElement 的使用

实现 AnnotatedElement 的 java.lang.reflect 中的类
class | AccessibleObject AccessibleObject 类是 Field、Method 和 Constructor 对象的基类。
class | Constructor<T> Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
class | Field Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。
class | Method Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.Array 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Array
的使用

没有 java.lang.reflect.Array 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.Constructor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Constructor
的使用

使用 Constructor 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

java.lang 中 Constructor 的使用

返回 Constructor 的 java.lang 中的方法
Constructor<T> | Class.getConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
Constructor<?>[] | Class.getConstructors() 返回一个包含某些 Constructor 对象的数组，这些对象反映此 Class 对象所表示的类的所有公共构造方法。
Constructor<T> | Class.getDeclaredConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
Constructor<?>[] | Class.getDeclaredConstructors() 返回 Constructor 对象的一个数组，这些对象反映此 Class 对象表示的类声明的所有构造方法。
Constructor<?> | Class.getEnclosingConstructor() 如果该 Class 对象表示构造方法中的一个本地或匿名类，则返回 Constructor 对象，它表示底层类的立即封闭构造方法。

javax.management 中 Constructor 的使用

参数类型为 Constructor 的 javax.management 中的构造方法
MBeanConstructorInfo(String description, Constructor constructor)
构造一个 MBeanConstructorInfo 对象。

javax.management.modelmbean 中 Constructor 的使用

参数类型为 Constructor 的 javax.management.modelmbean 中的构造方法
ModelMBeanConstructorInfo(String description, Constructor constructorMethod)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String description, Constructor constructorMethod, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Field
的使用

使用 Field 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.lang 中 Field 的使用

返回 Field 的 java.lang 中的方法
Field | Class.getDeclaredField(String name) 返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。
Field[] | Class.getDeclaredFields() 返回 Field 对象的一个数组，这些对象反映此 Class 对象所表示的类或接口所声明的所有字段。
Field | Class.getField(String name) 返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。
Field[] | Class.getFields() 返回一个包含某些 Field 对象的数组，这些对象反映此 Class 对象所表示的类或接口的所有可访问公共字段。

javax.sql.rowset.serial 中 Field 的使用

返回 Field 的 javax.sql.rowset.serial 中的方法
 Field[] SerialJavaObject.getFields()
返回 Field 对象数组，该对象包含此帮助器类将序列化的对象的每个字段。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.reflect.GenericArrayType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.GenericArrayType
的使用

没有 java.lang.reflect.GenericArrayType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.reflect.GenericDeclaration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.GenericDeclaration
的使用

使用 GenericDeclaration 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 GenericDeclaration 的使用

实现 GenericDeclaration 的 java.lang 中的类
 class Class<T>
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。

java.lang.reflect 中 GenericDeclaration 的使用

类型参数类型为 GenericDeclaration 的 java.lang.reflect 中的类
 interface TypeVariable<D extends GenericDeclaration>
TypeVariable 是各种类型变量的公共高级接口。

实现 GenericDeclaration 的 java.lang.reflect 中的类
class | Constructor<T> Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
class | Method Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.GenericSignatureFormatError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.GenericSignatureFormatError
的使用

没有 java.lang.reflect.GenericSignatureFormatError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.reflect.InvocationHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.InvocationHandler
的使用

使用 InvocationHandler 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.beans 中 InvocationHandler 的使用

实现 InvocationHandler 的 java.beans 中的类
 class EventHandler
EventHandler 类为动态生成事件侦听器提供支持，这些侦听器的方法执行一条涉及传入事件对象和目标对象的简单语句。

java.lang.reflect 中 InvocationHandler 的使用

声明为 InvocationHandler 的 java.lang.reflect 中的字段
protected  InvocationHandler Proxy.h
此代理实例的调用处理程序。

返回 InvocationHandler 的 java.lang.reflect 中的方法
static InvocationHandler Proxy.getInvocationHandler(Object proxy)
返回指定代理实例的调用处理程序。

参数类型为 InvocationHandler 的 java.lang.reflect 中的方法
static Object Proxy.newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)
返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。

参数类型为 InvocationHandler 的 java.lang.reflect 中的构造方法
Proxy(InvocationHandler h)
使用其调用处理程序的指定值从子类（通常为动态代理类）构建新的 Proxy 实例。

java.rmi.server 中 InvocationHandler 的使用

实现 InvocationHandler 的 java.rmi.server 中的类
 class RemoteObjectInvocationHandler
与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。

javax.management 中 InvocationHandler 的使用

实现 InvocationHandler 的 javax.management 中的类
 class MBeanServerInvocationHandler
通过 MBean 服务器将 MBean 的管理接口中的方法转发到 MBean 的 InvocationHandler。

javax.management.openmbean 中 InvocationHandler 的使用

实现 InvocationHandler 的 javax.management.openmbean 中的类
 class CompositeDataInvocationHandler
将获取方法转发给 CompositeData 的 InvocationHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.InvocationTargetException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.InvocationTargetException
的使用

使用 InvocationTargetException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 InvocationTargetException 的使用

抛出 InvocationTargetException 的 java.awt 中的方法
static void EventQueue.invokeAndWait(Runnable runnable)
导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。

java.lang.reflect 中 InvocationTargetException 的使用

抛出 InvocationTargetException 的 java.lang.reflect 中的方法
Object | Method.invoke(Object obj, Object... args) 对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。
T | Constructor.newInstance(Object... initargs) 使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。

javax.swing 中 InvocationTargetException 的使用

抛出 InvocationTargetException 的 javax.swing 中的方法
static void SwingUtilities.invokeAndWait(Runnable doRun)
导致 doRun.run() 在 AWT 事件指派线程上同步执行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.MalformedParameterizedTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.MalformedParameterizedTypeException
的使用

没有 java.lang.reflect.MalformedParameterizedTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.reflect.Member 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.Member
的使用

使用 Member 的软件包
java.lang.reflect 提供类和接口，以获得关于类和对象的反射信息。

java.lang.reflect 中 Member 的使用

实现 Member 的 java.lang.reflect 中的类
class | Constructor<T> Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
class | Field Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。
class | Method Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.Method 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Method
的使用

使用 Method 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.beans 中 Method 的使用

返回 Method 的 java.beans 中的方法
Method | EventSetDescriptor.getAddListenerMethod() 获得用来添加事件侦听器的方法。
Method | EventSetDescriptor.getGetListenerMethod() 获得用来访问已注册事件侦听器的方法。
Method | IndexedPropertyDescriptor.getIndexedReadMethod() 获得应该用于读取索引属性值的方法。
Method | IndexedPropertyDescriptor.getIndexedWriteMethod() 获得应该用于写入索引属性值的方法。
Method[] | EventSetDescriptor.getListenerMethods() 获得目标侦听器接口的方法。
Method | MethodDescriptor.getMethod() 获得此 MethodDescriptor 封装的方法。
Method | PropertyDescriptor.getReadMethod() 获得应该用于读取属性值的方法。
Method | EventSetDescriptor.getRemoveListenerMethod() 获得用来移除事件侦听器的方法。
Method | PropertyDescriptor.getWriteMethod() 获得应该用于写入属性值的方法。

参数类型为 Method 的 java.beans 中的方法
Object | EventHandler.invoke(Object proxy, Method method, Object[] arguments) 从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。
void | IndexedPropertyDescriptor.setIndexedReadMethod(Method readMethod) 设置应该用于读取索引属性值的方法。
void | IndexedPropertyDescriptor.setIndexedWriteMethod(Method writeMethod) 设置应该用于写入索引属性值的方法。
void | PropertyDescriptor.setReadMethod(Method readMethod) 设置应该用于读取属性值的方法。
void | PropertyDescriptor.setWriteMethod(Method writeMethod) 设置应该用于写入属性值的方法。

参数类型为 Method 的 java.beans 中的构造方法
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
IndexedPropertyDescriptor(String propertyName, Method readMethod, Method writeMethod, Method indexedReadMethod, Method indexedWriteMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。
MethodDescriptor(Method method)
根据 Method 构造一个 MethodDescriptor。
MethodDescriptor(Method method, ParameterDescriptor[] parameterDescriptors)
根据为每个方法参数提供描述性信息的 Method 构造一个 MethodDescriptor。
PropertyDescriptor(String propertyName, Method readMethod, Method writeMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。

java.lang 中 Method 的使用

返回 Method 的 java.lang 中的方法
Method | Class.getDeclaredMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
Method[] | Class.getDeclaredMethods() 返回 Method 对象的一个数组，这些对象反映此 Class 对象表示的类或接口声明的所有方法，包括公共、保护、默认（包）访问和私有方法，但不包括继承的方法。
Method | Class.getEnclosingMethod() 如果此 Class 对象表示某一方法中的一个本地或匿名类，则返回 Method 对象，它表示底层类的立即封闭方法。
Method | Class.getMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。
Method[] | Class.getMethods() 返回一个包含某些 Method 对象的数组，这些对象反映此 Class 对象所表示的类或接口（包括那些由该类或接口声明的以及从超类和超接口继承的那些的类或接口）的公共 member 方法。

java.lang.annotation 中 Method 的使用

返回 Method 的 java.lang.annotation 中的方法
 Method AnnotationTypeMismatchException.element()
返回类型不正确的元素的 Method 对象。

参数类型为 Method 的 java.lang.annotation 中的构造方法
AnnotationTypeMismatchException(Method element, String foundType)
构造针对指定的注释类型元素和找到的数据类型的 AnnotationTypeMismatchException。

java.lang.reflect 中 Method 的使用

参数类型为 Method 的 java.lang.reflect 中的方法
 Object InvocationHandler.invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

java.rmi.server 中 Method 的使用

参数类型为 Method 的 java.rmi.server 中的方法
Object | RemoteObjectInvocationHandler.invoke(Object proxy, Method method, Object[] args) 处理在封装的代理实例 proxy 上进行的方法调用并返回结果。
Object | RemoteRef.invoke(Remote obj, Method method, Object[] params, long opnum) 调用某个方法。

javax.management 中 Method 的使用

参数类型为 Method 的 javax.management 中的方法
 Object MBeanServerInvocationHandler.invoke(Object proxy, Method method, Object[] args)

参数类型为 Method 的 javax.management 中的构造方法
MBeanAttributeInfo(String name, String description, Method getter, Method setter)
此构造方法带有简单属性的名称，以及读取和写入属性的 Method 对象。
MBeanOperationInfo(String description, Method method)
构造一个 MBeanOperationInfo 对象。

javax.management.modelmbean 中 Method 的使用

参数类型为 Method 的 javax.management.modelmbean 中的构造方法
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter, Descriptor descriptor)
构造 ModelMBeanAttributeInfo 对象。
ModelMBeanOperationInfo(String description, Method operationMethod)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String description, Method operationMethod, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

javax.management.openmbean 中 Method 的使用

参数类型为 Method 的 javax.management.openmbean 中的方法
 Object CompositeDataInvocationHandler.invoke(Object proxy, Method method, Object[] args)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.Modifier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Modifier
的使用

没有 java.lang.reflect.Modifier 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.reflect.ParameterizedType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.ParameterizedType
的使用

没有 java.lang.reflect.ParameterizedType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.Proxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Proxy
的使用

没有 java.lang.reflect.Proxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.ReflectPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.ReflectPermission
的使用

没有 java.lang.reflect.ReflectPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.reflect.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.Type
的使用

使用 Type 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 Type 的使用

实现 Type 的 java.lang 中的类
 class Class<T>
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。

返回 Type 的 java.lang 中的方法
Type[] | Class.getGenericInterfaces() 返回表示某些接口的 Type，这些接口由此对象所表示的类或接口直接实现。
Type | Class.getGenericSuperclass() 返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的直接超类的 Type。

java.lang.reflect 中 Type 的使用

java.lang.reflect 中 Type 的子接口
interface | GenericArrayType GenericArrayType 表示一种数组类型，其组件类型为参数化类型或类型变量。
interface | ParameterizedType ParameterizedType 表示参数化类型，如 Collection<String>。
interface | TypeVariable<D extends GenericDeclaration> TypeVariable 是各种类型变量的公共高级接口。
interface | WildcardType WildcardType 表示一个通配符类型表达式，如 ?、? extends Number 或 ? super Integer。

返回 Type 的 java.lang.reflect 中的方法
Type[] | ParameterizedType.getActualTypeArguments() 返回表示此类型实际类型参数的 Type 对象的数组。
Type[] | TypeVariable.getBounds() 返回表示此类型变量上边界的 Type 对象的数组。
Type | GenericArrayType.getGenericComponentType() 返回表示此数组的组件类型的 Type 对象。
Type[] | Constructor.getGenericExceptionTypes() 返回一组 Type 对象，这些对象表示声明要由此 Constructor 对象抛出的异常。
Type[] | Method.getGenericExceptionTypes() 返回 Type 对象数组，这些对象描述了声明由此 Method 对象抛出的异常。
Type[] | Constructor.getGenericParameterTypes() 按照声明顺序返回一组 Type 对象，这些对象表示此 Constructor 对象所表示的方法的形参类型。
Type[] | Method.getGenericParameterTypes() 按照声明顺序返回 Type 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型的。
Type | Method.getGenericReturnType() 返回表示由此 Method 对象所表示方法的正式返回类型的 Type 对象。
Type | Field.getGenericType() 返回一个 Type 对象，它表示此 Field 对象所表示字段的声明类型。
Type[] | WildcardType.getLowerBounds() 返回表示此类型变量下边界的 Type 对象的数组。
Type | ParameterizedType.getOwnerType() 返回 Type 对象，表示此类型是其成员之一的类型。
Type | ParameterizedType.getRawType() 返回 Type 对象，表示声明此类型的类或接口。
Type[] | WildcardType.getUpperBounds() 返回表示此类型变量上边界的 Type 对象的数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.reflect.TypeVariable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.TypeVariable
的使用

使用 TypeVariable 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 TypeVariable 的使用

返回 TypeVariable 的 java.lang 中的方法
 TypeVariable<Class<T>>[] Class.getTypeParameters()
按声明顺序返回 TypeVariable 对象的一个数组，这些对象表示用此 GenericDeclaration 对象所表示的常规声明来声明的类型变量。

java.lang.reflect 中 TypeVariable 的使用

返回 TypeVariable 的 java.lang.reflect 中的方法
TypeVariable<Constructor<T>>[] | Constructor.getTypeParameters() 按照声明顺序返回一组 TypeVariable 对象，这些对象表示通过此 GenericDeclaration 对象所表示的一般声明来声明的类型变量。
TypeVariable<Method>[] | Method.getTypeParameters() 返回 TypeVariable 对象的数组，这些对象描述了由 GenericDeclaration 对象表示的一般声明按声明顺序来声明的类型变量。
TypeVariable<?>[] | GenericDeclaration.getTypeParameters() 返回声明顺序的 TypeVariable 对象的数组，这些对象表示由此 GenericDeclaration 对象表示的一般声明声明的类型变量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.lang.reflect.UndeclaredThrowableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.UndeclaredThrowableException
的使用

没有 java.lang.reflect.UndeclaredThrowableException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.lang.reflect.WildcardType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.WildcardType
的使用

没有 java.lang.reflect.WildcardType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.math (Java 2 Platform SE 6)

 java.math
类
BigDecimal
BigInteger
MathContext
枚举
RoundingMode


类 java.math.BigDecimal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.math.BigDecimal
的使用

使用 BigDecimal 的软件包
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.datatype | XML/Java 类型映射关系。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

java.math 中 BigDecimal 的使用

声明为 BigDecimal 的 java.math 中的字段
static BigDecimal | BigDecimal.ONE 值为 1，标度为 0。
static BigDecimal | BigDecimal.TEN 值为 10，标度为 0。
static BigDecimal | BigDecimal.ZERO 值为 0，标度为 0。

返回 BigDecimal 的 java.math 中的方法
 BigDecimal BigDecimal.abs()
返回 BigDecimal，其值为此 BigDecimal 的绝对值，其标度为 this.scale()。
 BigDecimal BigDecimal.abs(MathContext mc)
返回其值为此 BigDecimal 绝对值的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.add(BigDecimal augend)
返回一个 BigDecimal，其值为 (this + augend)，其标度为 max(this.scale(), augend.scale())。
 BigDecimal BigDecimal.add(BigDecimal augend, MathContext mc)
返回其值为 (this + augend) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.divide(BigDecimal divisor)
返回一个 BigDecimal，其值为 (this / divisor)，其首选标度为 (this.scale() - divisor.scale())；如果无法表示准确的商值（因为它有无穷的十进制扩展），则抛出 ArithmeticException。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int scale, int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int scale, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal BigDecimal.divide(BigDecimal divisor, MathContext mc)
返回其值为 (this / divisor) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.divide(BigDecimal divisor, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal[] BigDecimal.divideAndRemainder(BigDecimal divisor)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟对两个操作数计算所得到的 remainder。
 BigDecimal[] BigDecimal.divideAndRemainder(BigDecimal divisor, MathContext mc)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟根据上下文设置对两个操作数进行舍入计算所得到的 remainder 的结果。
 BigDecimal BigDecimal.divideToIntegralValue(BigDecimal divisor)
返回 BigDecimal，其值为向下舍入所得商值 (this / divisor) 的整数部分。
 BigDecimal BigDecimal.divideToIntegralValue(BigDecimal divisor, MathContext mc)
返回 BigDecimal，其值为 (this / divisor) 的整数部分。
 BigDecimal BigDecimal.max(BigDecimal val)
返回此 BigDecimal 和 val 的最大值。
 BigDecimal BigDecimal.min(BigDecimal val)
返回此 BigDecimal 和 val 的最小值。
 BigDecimal BigDecimal.movePointLeft(int n)
返回一个 BigDecimal，它等效于将该值的小数点向左移动 n 位。
 BigDecimal BigDecimal.movePointRight(int n)
返回一个 BigDecimal，它等效于将该值的小数点向右移动 n 位。
 BigDecimal BigDecimal.multiply(BigDecimal multiplicand)
返回一个 BigDecimal，其值为 (this × multiplicand)，其标度为 (this.scale() + multiplicand.scale())。
 BigDecimal BigDecimal.multiply(BigDecimal multiplicand, MathContext mc)
返回其值为 (this × multiplicand) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.negate()
返回 BigDecimal，其值为 (-this)，其标度为 this.scale()。
 BigDecimal BigDecimal.negate(MathContext mc)
返回其值为 (-this) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.plus()
返回 BigDecimal，其值为 (+this)，其标度为 this.scale()。
 BigDecimal BigDecimal.plus(MathContext mc)
返回其值为 (+this) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.pow(int n)
返回其值为 (thisn) 的 BigDecimal，准确计算该幂，使其具有无限精度。
 BigDecimal BigDecimal.pow(int n, MathContext mc)
返回其值为 (thisn) 的 BigDecimal。
 BigDecimal BigDecimal.remainder(BigDecimal divisor)
返回其值为 (this % divisor) 的 BigDecimal。
 BigDecimal BigDecimal.remainder(BigDecimal divisor, MathContext mc)
返回其值为 (this % divisor) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.round(MathContext mc)
返回根据 MathContext 设置进行舍入后的 BigDecimal。
 BigDecimal BigDecimal.scaleByPowerOfTen(int n)
返回其数值等于 (this * 10n) 的 BigDecimal。
 BigDecimal BigDecimal.setScale(int newScale)
返回一个 BigDecimal，其标度为指定值，其值在数值上等于此 BigDecimal 的值。
 BigDecimal BigDecimal.setScale(int newScale, int roundingMode)
返回一个 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
 BigDecimal BigDecimal.setScale(int newScale, RoundingMode roundingMode)
返回 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
 BigDecimal BigDecimal.stripTrailingZeros()
返回数值上等于此小数，但从该表示形式移除所有尾部零的 BigDecimal。
 BigDecimal BigDecimal.subtract(BigDecimal subtrahend)
返回一个 BigDecimal，其值为 (this - subtrahend)，其标度为 max(this.scale(), subtrahend.scale())。
 BigDecimal BigDecimal.subtract(BigDecimal subtrahend, MathContext mc)
返回其值为 (this - subtrahend) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.ulp()
返回此 BigDecimal 的 ulp（最后一位的单位）的大小。
static BigDecimal BigDecimal.valueOf(double val)
使用 Double.toString(double) 方法提供的 double 规范的字符串表示形式将 double 转换为 BigDecimal。
static BigDecimal BigDecimal.valueOf(long val)
将 long 值转换为具有零标度的 BigDecimal。
static BigDecimal BigDecimal.valueOf(long unscaledVal, int scale)
将 long 非标度值和 int 标度转换为 BigDecimal。

参数类型为 BigDecimal 的 java.math 中的方法
 BigDecimal BigDecimal.add(BigDecimal augend)
返回一个 BigDecimal，其值为 (this + augend)，其标度为 max(this.scale(), augend.scale())。
 BigDecimal BigDecimal.add(BigDecimal augend, MathContext mc)
返回其值为 (this + augend) 的 BigDecimal（根据上下文设置进行舍入）。
 int BigDecimal.compareTo(BigDecimal val)
将此 BigDecimal 与指定的 BigDecimal 比较。
 BigDecimal BigDecimal.divide(BigDecimal divisor)
返回一个 BigDecimal，其值为 (this / divisor)，其首选标度为 (this.scale() - divisor.scale())；如果无法表示准确的商值（因为它有无穷的十进制扩展），则抛出 ArithmeticException。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int scale, int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int scale, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal BigDecimal.divide(BigDecimal divisor, MathContext mc)
返回其值为 (this / divisor) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.divide(BigDecimal divisor, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal[] BigDecimal.divideAndRemainder(BigDecimal divisor)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟对两个操作数计算所得到的 remainder。
 BigDecimal[] BigDecimal.divideAndRemainder(BigDecimal divisor, MathContext mc)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟根据上下文设置对两个操作数进行舍入计算所得到的 remainder 的结果。
 BigDecimal BigDecimal.divideToIntegralValue(BigDecimal divisor)
返回 BigDecimal，其值为向下舍入所得商值 (this / divisor) 的整数部分。
 BigDecimal BigDecimal.divideToIntegralValue(BigDecimal divisor, MathContext mc)
返回 BigDecimal，其值为 (this / divisor) 的整数部分。
 BigDecimal BigDecimal.max(BigDecimal val)
返回此 BigDecimal 和 val 的最大值。
 BigDecimal BigDecimal.min(BigDecimal val)
返回此 BigDecimal 和 val 的最小值。
 BigDecimal BigDecimal.multiply(BigDecimal multiplicand)
返回一个 BigDecimal，其值为 (this × multiplicand)，其标度为 (this.scale() + multiplicand.scale())。
 BigDecimal BigDecimal.multiply(BigDecimal multiplicand, MathContext mc)
返回其值为 (this × multiplicand) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.remainder(BigDecimal divisor)
返回其值为 (this % divisor) 的 BigDecimal。
 BigDecimal BigDecimal.remainder(BigDecimal divisor, MathContext mc)
返回其值为 (this % divisor) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.subtract(BigDecimal subtrahend)
返回一个 BigDecimal，其值为 (this - subtrahend)，其标度为 max(this.scale(), subtrahend.scale())。
 BigDecimal BigDecimal.subtract(BigDecimal subtrahend, MathContext mc)
返回其值为 (this - subtrahend) 的 BigDecimal（根据上下文设置进行舍入）。

java.sql 中 BigDecimal 的使用

返回 BigDecimal 的 java.sql 中的方法
BigDecimal | CallableStatement.getBigDecimal(int parameterIndex) 以 java.math.BigDecimal 对象的形式获取指定 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
BigDecimal | ResultSet.getBigDecimal(int columnIndex) 以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
BigDecimal | CallableStatement.getBigDecimal(int parameterIndex, int scale) 已过时。 使用 getBigDecimal(int parameterIndex) 或 getBigDecimal(String parameterName)
BigDecimal | ResultSet.getBigDecimal(int columnIndex, int scale) 已过时。
BigDecimal | CallableStatement.getBigDecimal(String parameterName) 以 java.math.BigDecimal 对象的形式获取 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
BigDecimal | ResultSet.getBigDecimal(String columnLabel) 以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
BigDecimal | ResultSet.getBigDecimal(String columnLabel, int scale) 已过时。
BigDecimal | SQLInput.readBigDecimal() 读取流中的下一个属性并将其作为 Java 编程语言中的 java.math.BigDecimal 对象返回。

参数类型为 BigDecimal 的 java.sql 中的方法
void | PreparedStatement.setBigDecimal(int parameterIndex, BigDecimal x) 将指定参数设置为给定 java.math.BigDecimal 值。
void | CallableStatement.setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定 java.math.BigDecimal 值。
void | ResultSet.updateBigDecimal(int columnIndex, BigDecimal x) 用 java.math.BigDecimal 值更新指定列。
void | ResultSet.updateBigDecimal(String columnLabel, BigDecimal x) 用 java.sql.BigDecimal 值更新指定列。
void | SQLOutput.writeBigDecimal(BigDecimal x) 将下一个属性作为 java.math.BigDecimal 对象写入流中。

java.util 中 BigDecimal 的使用

返回 BigDecimal 的 java.util 中的方法
 BigDecimal Scanner.nextBigDecimal()
将输入信息的下一个标记扫描为一个 BigDecimal。

javax.management.openmbean 中 BigDecimal 的使用

类型参数类型为 BigDecimal 的 javax.management.openmbean 中的字段
static SimpleType<BigDecimal> SimpleType.BIGDECIMAL
SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigDecimal 的值。

javax.sql 中 BigDecimal 的使用

参数类型为 BigDecimal 的 javax.sql 中的方法
void | RowSet.setBigDecimal(int parameterIndex, BigDecimal x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.math.BigDeciaml 值。
void | RowSet.setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定的 java.math.BigDecimal 值。

javax.sql.rowset 中 BigDecimal 的使用

参数类型为 BigDecimal 的 javax.sql.rowset 中的方法
void | BaseRowSet.setBigDecimal(int parameterIndex, BigDecimal x) 将指定参数设置为给定的 java.lang.BigDecimal 值。
void | BaseRowSet.setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定的 java.math.BigDecimal 值。

javax.sql.rowset.serial 中 BigDecimal 的使用

返回 BigDecimal 的 javax.sql.rowset.serial 中的方法
 BigDecimal SQLInputImpl.readBigDecimal()
以 java.math.BigDecimal 的形式获取此 SQLInputImpl 对象中的下一个属性。

参数类型为 BigDecimal 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeBigDecimal(BigDecimal x)
将 Java 编程语言中的 java.math.BigDecimal 对象写入此 SQLOutputImpl 对象。

javax.xml.bind 中 BigDecimal 的使用

返回 BigDecimal 的 javax.xml.bind 中的方法
static BigDecimal | DatatypeConverter.parseDecimal(String lexicalXSDDecimal) 将字符串参数转换为一个 BigDecimal 值。
BigDecimal | DatatypeConverterInterface.parseDecimal(String lexicalXSDDecimal) 将字符串参数转换为一个 BigDecimal 值。

参数类型为 BigDecimal 的 javax.xml.bind 中的方法
static String | DatatypeConverter.printDecimal(BigDecimal val) 将 BigDecimal 值转换为一个字符串。
String | DatatypeConverterInterface.printDecimal(BigDecimal val) 将 BigDecimal 值转换为一个字符串。

javax.xml.datatype 中 BigDecimal 的使用

返回 BigDecimal 的 javax.xml.datatype 中的方法
abstract  BigDecimal XMLGregorianCalendar.getFractionalSecond()
返回小数秒。

参数类型为 BigDecimal 的 javax.xml.datatype 中的方法
abstract Duration | Duration.multiply(BigDecimal factor) 计算新的持续时间，其值是此持续时间值的 factor 倍。
abstract Duration | DatatypeFactory.newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds) 获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone) W3C XML 模式 1.0 推荐考虑完整值空间的构造方法，该方法用于 xsd:dateTime 和相关的内置数据类型。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
abstract void | XMLGregorianCalendar.setFractionalSecond(BigDecimal fractional) 设置小数秒。
void | XMLGregorianCalendar.setTime(int hour, int minute, int second, BigDecimal fractional) 将时间设置为一个单元，包括可选无限精度小数秒。

org.omg.CORBA 中 BigDecimal 的使用

声明为 BigDecimal 的 org.omg.CORBA 中的字段
 BigDecimal FixedHolder.value
FixedHolder 保存的值。

返回 BigDecimal 的 org.omg.CORBA 中的方法
 BigDecimal Any.extract_fixed()
提取此 Any 对象 value 字段中的 java.math.BigDecimal 对象。

参数类型为 BigDecimal 的 org.omg.CORBA 中的方法
void | Any.insert_fixed(BigDecimal value) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
void | Any.insert_fixed(BigDecimal value, TypeCode type) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

参数类型为 BigDecimal 的 org.omg.CORBA 中的构造方法
FixedHolder(BigDecimal initial)
构造 FixedHolder，并使用给定值初始化。

org.omg.CORBA.portable 中 BigDecimal 的使用

返回 BigDecimal 的 org.omg.CORBA.portable 中的方法
 BigDecimal InputStream.read_fixed()
读取一个 BigDecimal 数。

参数类型为 BigDecimal 的 org.omg.CORBA.portable 中的方法
 void OutputStream.write_fixed(BigDecimal value)
写入一个 BigDecimal 数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.math.BigInteger 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.math.BigInteger
的使用

使用 BigInteger 的软件包
java.awt.image | 提供创建和修改图像的各种类。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.security.cert | 为公钥证书提供类。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.datatype | XML/Java 类型映射关系。

java.awt.image 中 BigInteger 的使用

返回 BigInteger 的 java.awt.image 中的方法
 BigInteger IndexColorModel.getValidPixels()
返回一个指示 colormap 中有效/无效像素的 BigInteger。

参数类型为 BigInteger 的 java.awt.image 中的构造方法
IndexColorModel(int bits, int size, int[] cmap, int start, int transferType, BigInteger validBits)
根据一个 int 数组构造一个 IndexColorModel，该数组中的每个 int 值都由默认 RGB 颜色模型格式的红色、绿色、蓝色和 alpha 分量构成。

java.math 中 BigInteger 的使用

声明为 BigInteger 的 java.math 中的字段
static BigInteger | BigInteger.ONE BigInteger 的常量 1。
static BigInteger | BigInteger.TEN BigInteger 的常量 10。
static BigInteger | BigInteger.ZERO BigInteger 的常量 0。

返回 BigInteger 的 java.math 中的方法
BigInteger | BigInteger.abs() 返回其值是此 BigInteger 的绝对值的 BigInteger。
BigInteger | BigInteger.add(BigInteger val) 返回其值为 (this + val) 的 BigInteger。
BigInteger | BigInteger.and(BigInteger val) 返回其值为 (this & val) 的 BigInteger。
BigInteger | BigInteger.andNot(BigInteger val) 返回其值为 (this & ~val) 的 BigInteger。
BigInteger | BigInteger.clearBit(int n) 返回其值与清除了指定位的此 BigInteger 等效的 BigInteger。
BigInteger | BigInteger.divide(BigInteger val) 返回其值为 (this / val) 的 BigInteger。
BigInteger[] | BigInteger.divideAndRemainder(BigInteger val) 返回包含 (this / val) 后跟 (this % val) 的两个 BigInteger 的数组。
BigInteger | BigInteger.flipBit(int n) 返回其值与对此 BigInteger 进行指定位翻转后的值等效的 BigInteger。
BigInteger | BigInteger.gcd(BigInteger val) 返回一个 BigInteger，其值是 abs(this) 和 abs(val) 的最大公约数。
BigInteger | BigInteger.max(BigInteger val) 返回此 BigInteger 和 val 的最大值。
BigInteger | BigInteger.min(BigInteger val) 返回此 BigInteger 和 val 的最小值。
BigInteger | BigInteger.mod(BigInteger m) 返回其值为 (this mod m) 的 BigInteger。
BigInteger | BigInteger.modInverse(BigInteger m) 返回其值为 (this-1 mod m) 的 BigInteger。
BigInteger | BigInteger.modPow(BigInteger exponent, BigInteger m) 返回其值为 (thisexponent mod m) 的 BigInteger。
BigInteger | BigInteger.multiply(BigInteger val) 返回其值为 (this * val) 的 BigInteger。
BigInteger | BigInteger.negate() 返回其值是 (-this) 的 BigInteger。
BigInteger | BigInteger.nextProbablePrime() 返回大于此 BigInteger 的可能为素数的第一个整数。
BigInteger | BigInteger.not() 返回其值为 (~this) 的 BigInteger。
BigInteger | BigInteger.or(BigInteger val) 返回其值为 (this | val) 的 BigInteger。
BigInteger | BigInteger.pow(int exponent) 返回其值为 (thisexponent) 的 BigInteger。
static BigInteger | BigInteger.probablePrime(int bitLength, Random rnd) 返回有可能是素数的、具有指定长度的正 BigInteger。
BigInteger | BigInteger.remainder(BigInteger val) 返回其值为 (this % val) 的 BigInteger。
BigInteger | BigInteger.setBit(int n) 返回其值与设置了指定位的此 BigInteger 等效的 BigInteger。
BigInteger | BigInteger.shiftLeft(int n) 返回其值为 (this << n) 的 BigInteger。
BigInteger | BigInteger.shiftRight(int n) 返回其值为 (this >> n) 的 BigInteger。
BigInteger | BigInteger.subtract(BigInteger val) 返回其值为 (this - val) 的 BigInteger。
BigInteger | BigDecimal.toBigInteger() 将此 BigDecimal 转换为 BigInteger。
BigInteger | BigDecimal.toBigIntegerExact() 将此 BigDecimal 转换为 BigInteger，以检查丢失的信息。
BigInteger | BigDecimal.unscaledValue() 返回其值为此 BigDecimal 的非标度值 的 BigInteger。
static BigInteger | BigInteger.valueOf(long val) 返回其值等于指定 long 的值的 BigInteger。
BigInteger | BigInteger.xor(BigInteger val) 返回其值为 (this ^ val) 的 BigInteger。

参数类型为 BigInteger 的 java.math 中的方法
BigInteger | BigInteger.add(BigInteger val) 返回其值为 (this + val) 的 BigInteger。
BigInteger | BigInteger.and(BigInteger val) 返回其值为 (this & val) 的 BigInteger。
BigInteger | BigInteger.andNot(BigInteger val) 返回其值为 (this & ~val) 的 BigInteger。
int | BigInteger.compareTo(BigInteger val) 将此 BigInteger 与指定的 BigInteger 进行比较。
BigInteger | BigInteger.divide(BigInteger val) 返回其值为 (this / val) 的 BigInteger。
BigInteger[] | BigInteger.divideAndRemainder(BigInteger val) 返回包含 (this / val) 后跟 (this % val) 的两个 BigInteger 的数组。
BigInteger | BigInteger.gcd(BigInteger val) 返回一个 BigInteger，其值是 abs(this) 和 abs(val) 的最大公约数。
BigInteger | BigInteger.max(BigInteger val) 返回此 BigInteger 和 val 的最大值。
BigInteger | BigInteger.min(BigInteger val) 返回此 BigInteger 和 val 的最小值。
BigInteger | BigInteger.mod(BigInteger m) 返回其值为 (this mod m) 的 BigInteger。
BigInteger | BigInteger.modInverse(BigInteger m) 返回其值为 (this-1 mod m) 的 BigInteger。
BigInteger | BigInteger.modPow(BigInteger exponent, BigInteger m) 返回其值为 (thisexponent mod m) 的 BigInteger。
BigInteger | BigInteger.multiply(BigInteger val) 返回其值为 (this * val) 的 BigInteger。
BigInteger | BigInteger.or(BigInteger val) 返回其值为 (this | val) 的 BigInteger。
BigInteger | BigInteger.remainder(BigInteger val) 返回其值为 (this % val) 的 BigInteger。
BigInteger | BigInteger.subtract(BigInteger val) 返回其值为 (this - val) 的 BigInteger。
BigInteger | BigInteger.xor(BigInteger val) 返回其值为 (this ^ val) 的 BigInteger。

参数类型为 BigInteger 的 java.math 中的构造方法
BigDecimal(BigInteger val)
将 BigInteger 转换为 BigDecimal。
BigDecimal(BigInteger unscaledVal, int scale)
将 BigInteger 非标度值和 int 标度转换为 BigDecimal。
BigDecimal(BigInteger unscaledVal, int scale, MathContext mc)
将 BigInteger 非标度值和 int 标度转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(BigInteger val, MathContext mc)
将 BigInteger 转换为 BigDecimal（根据上下文设置进行舍入）。

java.security.cert 中 BigInteger 的使用

返回 BigInteger 的 java.security.cert 中的方法
BigInteger | X509CRLSelector.getMaxCRL() 返回 maxCRLNumber 标准。
BigInteger | X509CRLSelector.getMinCRL() 返回 minCRLNumber 标准。
abstract BigInteger | X509CRLEntry.getSerialNumber() 获取此 X509CRLEntry 的序列号 userCertificate。
BigInteger | X509CertSelector.getSerialNumber() 返回 serialNumber 标准。
abstract BigInteger | X509Certificate.getSerialNumber() 获取证书的 serialNumber 值。

参数类型为 BigInteger 的 java.security.cert 中的方法
abstract X509CRLEntry | X509CRL.getRevokedCertificate(BigInteger serialNumber) 获取具有给定证书 serialNumber 的 CRL 项（如果有）。
void | X509CRLSelector.setMaxCRLNumber(BigInteger maxCRL) 设置 maxCRLNumber 标准。
void | X509CRLSelector.setMinCRLNumber(BigInteger minCRL) 设置 minCRLNumber 标准。
void | X509CertSelector.setSerialNumber(BigInteger serial) 设置 serialNumber 标准。

java.security.interfaces 中 BigInteger 的使用

返回 BigInteger 的 java.security.interfaces 中的方法
BigInteger | RSAMultiPrimePrivateCrtKey.getCrtCoefficient() 返回 crtCoefficient。
BigInteger | RSAPrivateCrtKey.getCrtCoefficient() 返回 crtCoefficient。
BigInteger | DSAParams.getG() 返回基数 g。
BigInteger | RSAKey.getModulus() 返回该系数。
BigInteger | DSAParams.getP() 返回素数 p。
BigInteger | RSAMultiPrimePrivateCrtKey.getPrimeExponentP() 返回 primeExponentP。
BigInteger | RSAPrivateCrtKey.getPrimeExponentP() 返回 primeExponentP。
BigInteger | RSAMultiPrimePrivateCrtKey.getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | RSAPrivateCrtKey.getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | RSAMultiPrimePrivateCrtKey.getPrimeP() 返回 primeP。
BigInteger | RSAPrivateCrtKey.getPrimeP() 返回 primeP。
BigInteger | RSAMultiPrimePrivateCrtKey.getPrimeQ() 返回 primeQ。
BigInteger | RSAPrivateCrtKey.getPrimeQ() 返回 primeQ。
BigInteger | RSAPrivateKey.getPrivateExponent() 返回专用指数。
BigInteger | RSAMultiPrimePrivateCrtKey.getPublicExponent() 返回公用指数。
BigInteger | RSAPrivateCrtKey.getPublicExponent() 返回公用指数。
BigInteger | RSAPublicKey.getPublicExponent() 返回该公用指数。
BigInteger | DSAParams.getQ() 返回子素数 q。
BigInteger | ECPrivateKey.getS() 返回专用密钥值 S。
BigInteger | DSAPrivateKey.getX() 返回专用密钥值 x。
BigInteger | DSAPublicKey.getY() 返回公用密钥值 y。

java.security.spec 中 BigInteger 的使用

声明为 BigInteger 的 java.security.spec 中的字段
static BigInteger | RSAKeyGenParameterSpec.F0 公用指数值 F0 = 3。
static BigInteger | RSAKeyGenParameterSpec.F4 公用指数值 F4 = 65537。

返回 BigInteger 的 java.security.spec 中的方法
BigInteger | EllipticCurve.getA() 返回椭圆曲线的第一个系数 a。
BigInteger | ECPoint.getAffineX() 返回仿射 x 坐标 x。
BigInteger | ECPoint.getAffineY() 返回仿射 y 坐标 y。
BigInteger | EllipticCurve.getB() 返回椭圆曲线的第二个系数 b。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getCrtCoefficient() 返回 crtCoefficient。
BigInteger | RSAOtherPrimeInfo.getCrtCoefficient() 返回素数的 crtCoefficient。
BigInteger | RSAPrivateCrtKeySpec.getCrtCoefficient() 返回 crtCoefficient。
BigInteger | RSAOtherPrimeInfo.getExponent() 返回素数的指数。
BigInteger | DSAPrivateKeySpec.getG() 返回基数 g。
BigInteger | DSAParameterSpec.getG() 返回基数 g。
BigInteger | DSAPublicKeySpec.getG() 返回基数 g。
BigInteger | RSAPrivateKeySpec.getModulus() 返回系数。
BigInteger | RSAPublicKeySpec.getModulus() 返回该系数。
BigInteger | ECParameterSpec.getOrder() 返回生成器的顺序。
BigInteger | DSAPrivateKeySpec.getP() 返回素数 p。
BigInteger | ECFieldFp.getP() 返回此素数有限字段的素数 p。
BigInteger | DSAParameterSpec.getP() 返回素数 p。
BigInteger | DSAPublicKeySpec.getP() 返回素数 p。
BigInteger | RSAOtherPrimeInfo.getPrime() 返回素数。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getPrimeExponentP() 返回 primeExponentP。
BigInteger | RSAPrivateCrtKeySpec.getPrimeExponentP() 返回 primeExponentP。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | RSAPrivateCrtKeySpec.getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getPrimeP() 返回 primeP。
BigInteger | RSAPrivateCrtKeySpec.getPrimeP() 返回 primeP。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getPrimeQ() 返回 primeQ。
BigInteger | RSAPrivateCrtKeySpec.getPrimeQ() 返回 primeQ。
BigInteger | RSAPrivateKeySpec.getPrivateExponent() 返回专用指数。
BigInteger | RSAKeyGenParameterSpec.getPublicExponent() 返回公用指数值。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getPublicExponent() 返回公用指数。
BigInteger | RSAPrivateCrtKeySpec.getPublicExponent() 返回公用指数。
BigInteger | RSAPublicKeySpec.getPublicExponent() 返回该公用指数。
BigInteger | DSAPrivateKeySpec.getQ() 返回子素数 q。
BigInteger | DSAParameterSpec.getQ() 返回子素数 q。
BigInteger | DSAPublicKeySpec.getQ() 返回子素数 q。
BigInteger | ECFieldF2m.getReductionPolynomial() 对于多项式方法，返回一个 BigInteger，其第 i 位对应于降序排列多项式的第 i 个系数，对于常规方法，返回 null。
BigInteger | ECPrivateKeySpec.getS() 返回专用值 S。
BigInteger | DSAPrivateKeySpec.getX() 返回专用密钥 x。
BigInteger | DSAPublicKeySpec.getY() 返回公用密钥 y。

参数类型为 BigInteger 的 java.security.spec 中的构造方法
DSAParameterSpec(BigInteger p, BigInteger q, BigInteger g)
创建一个具有指定参数值的新的 DSAParameterSpec。
DSAPrivateKeySpec(BigInteger x, BigInteger p, BigInteger q, BigInteger g)
创建一个具有指定参数值的新 DSAPrivateKeySpec。
DSAPublicKeySpec(BigInteger y, BigInteger p, BigInteger q, BigInteger g)
创建一个具有指定参数值的新 DSAPublicKeySpec。
ECFieldF2m(int m, BigInteger rp)
使用多项式方法创建一个椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
ECFieldFp(BigInteger p)
根据指定的素数 p 创建一个椭圆曲线素数的有限字段。
ECParameterSpec(EllipticCurve curve, ECPoint g, BigInteger n, int h)
创建基于指定值的椭圆曲线域参数。
ECPoint(BigInteger x, BigInteger y)
根据指定的仿射 x 坐标 x 和仿射 y 坐标 y 创建 ECPoint。
ECPrivateKeySpec(BigInteger s, ECParameterSpec params)
使用指定的参数值创建一个新的 ECPrivateKeySpec。
EllipticCurve(ECField field, BigInteger a, BigInteger b)
使用指定的椭圆字段 field 以及系数 a 和 b 创建椭圆曲线。
EllipticCurve(ECField field, BigInteger a, BigInteger b, byte[] seed)
使用指定的椭圆字段 field、系数 a 和 b，以及用于生成曲线的 seed 创建椭圆曲线。
RSAKeyGenParameterSpec(int keysize, BigInteger publicExponent)
构造一个具有给定密钥大小和公用指数值的新的 RSAParameterSpec 对象。
RSAMultiPrimePrivateCrtKeySpec(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient, RSAOtherPrimeInfo[] otherPrimeInfo)
给定系数、publicExponent、privateExponent、primeP、primeQ、primeExponentP、primeExponentQ、crtCoefficient 和如 PKCS#1 v2.1 中所定义的 otherPrimeInfo，创建一个新的 RSAMultiPrimePrivateCrtKeySpec。
RSAOtherPrimeInfo(BigInteger prime, BigInteger primeExponent, BigInteger crtCoefficient)
给定如 PKCS#1 中所定义的素数、primeExponent 和 crtCoefficient，创建一个新的 RSAOtherPrimeInfo。
RSAPrivateCrtKeySpec(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient)
给定在 PKCS#1 v2.1 中所定义的系数、publicExponent、privateExponent、 primeP、primeQ、primeExponentP、primeExponentQ 和 crtCoefficient，创建一个新的 RSAPrivateCrtKeySpec。
RSAPrivateKeySpec(BigInteger modulus, BigInteger privateExponent)
创建一个新的 RSAPrivateKeySpec。
RSAPublicKeySpec(BigInteger modulus, BigInteger publicExponent)
创建一个新的 RSAPublicKeySpec。

java.util 中 BigInteger 的使用

返回 BigInteger 的 java.util 中的方法
BigInteger | Scanner.nextBigInteger() 将输入信息的下一个标记扫描为一个 BigInteger。
BigInteger | Scanner.nextBigInteger(int radix) 将输入信息的下一个标记扫描为一个 BigInteger。

javax.crypto.interfaces 中 BigInteger 的使用

返回 BigInteger 的 javax.crypto.interfaces 中的方法
BigInteger | DHPrivateKey.getX() 返回私钥值 x。
BigInteger | DHPublicKey.getY() 返回公钥值 y。

javax.crypto.spec 中 BigInteger 的使用

返回 BigInteger 的 javax.crypto.spec 中的方法
BigInteger | DHParameterSpec.getG() 返回基生成器 g。
BigInteger | DHPrivateKeySpec.getG() 返回基生成器 g。
BigInteger | DHPublicKeySpec.getG() 返回基生成器 g。
BigInteger | DHParameterSpec.getP() 返回质数模数 p。
BigInteger | DHPrivateKeySpec.getP() 返回质数模数 p。
BigInteger | DHPublicKeySpec.getP() 返回质数模数 p。
BigInteger | DHPrivateKeySpec.getX() 返回私有值 x。
BigInteger | DHPublicKeySpec.getY() 返回公有值 y。

参数类型为 BigInteger 的 javax.crypto.spec 中的构造方法
DHParameterSpec(BigInteger p, BigInteger g)
使用质数模数 p 和基生成器 g 为 Diffie-Hellman 构造一个参数集。
DHParameterSpec(BigInteger p, BigInteger g, int l)
使用质数模数 p、基生成器 g 以及以位为单位的随机指数大小 l（私有值）为 Diffie-Hellman 构造一个参数集。
DHPrivateKeySpec(BigInteger x, BigInteger p, BigInteger g)
带有一个私有值 x、一个质数模数 p 以及一个基生成器 g 的构造方法。
DHPublicKeySpec(BigInteger y, BigInteger p, BigInteger g)
带有一个公有值 y、一个质数模数 p 以及一个基生成器 g 的构造方法。

javax.management.openmbean 中 BigInteger 的使用

类型参数类型为 BigInteger 的 javax.management.openmbean 中的字段
static SimpleType<BigInteger> SimpleType.BIGINTEGER
SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigInteger 的值。

javax.security.cert 中 BigInteger 的使用

返回 BigInteger 的 javax.security.cert 中的方法
abstract  BigInteger X509Certificate.getSerialNumber()
获取证书的 serialNumber 值。

javax.xml.bind 中 BigInteger 的使用

返回 BigInteger 的 javax.xml.bind 中的方法
static BigInteger | DatatypeConverter.parseInteger(String lexicalXSDInteger) 将字符串参数转换为一个 BigInteger 值。
BigInteger | DatatypeConverterInterface.parseInteger(String lexicalXSDInteger) 将字符串参数转换为一个 BigInteger 值。

参数类型为 BigInteger 的 javax.xml.bind 中的方法
static String | DatatypeConverter.printInteger(BigInteger val) 将 BigInteger 值转换为一个字符串。
String | DatatypeConverterInterface.printInteger(BigInteger val) 将 BigInteger 值转换为一个字符串。

javax.xml.crypto.dsig.keyinfo 中 BigInteger 的使用

返回 BigInteger 的 javax.xml.crypto.dsig.keyinfo 中的方法
 BigInteger X509IssuerSerial.getSerialNumber()
返回此 X509IssuerSerial 的序列号。

参数类型为 BigInteger 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  X509IssuerSerial KeyInfoFactory.newX509IssuerSerial(String issuerName, BigInteger serialNumber)
根据指定的 X.500 发布方标识名和序列号创建 X509IssuerSerial。

javax.xml.datatype 中 BigInteger 的使用

返回 BigInteger 的 javax.xml.datatype 中的方法
abstract BigInteger | XMLGregorianCalendar.getEon() 返回 year XML 模式 1.0 日期时间数据类型字段的高顺序组件。
abstract BigInteger | XMLGregorianCalendar.getEonAndYear() 返回 year XML 模式 1.0 的日期时间数据类型字段。

参数类型为 BigInteger 的 javax.xml.datatype 中的方法
abstract Duration | DatatypeFactory.newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds) 获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
Duration | DatatypeFactory.newDurationDayTime(boolean isPositive, BigInteger day, BigInteger hour, BigInteger minute, BigInteger second) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | DatatypeFactory.newDurationYearMonth(boolean isPositive, BigInteger year, BigInteger month) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone) W3C XML 模式 1.0 推荐考虑完整值空间的构造方法，该方法用于 xsd:dateTime 和相关的内置数据类型。
abstract void | XMLGregorianCalendar.setYear(BigInteger year) 设置 XSD dateTime year 字段的低和高顺序组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.math.MathContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.math.MathContext
的使用

使用 MathContext 的软件包
java.math 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。

java.math 中 MathContext 的使用

声明为 MathContext 的 java.math 中的字段
static MathContext | MathContext.DECIMAL128 一个 MathContext 对象，其精度设置与 IEEE 754R Decimal128 格式（即 34 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
static MathContext | MathContext.DECIMAL32 一个 MathContext 对象，其精度设置与 IEEE 754R Decimal32 格式（即 7 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
static MathContext | MathContext.DECIMAL64 一个 MathContext 对象，其精度设置与 IEEE 754R Decimal64 格式（即 16 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
static MathContext | MathContext.UNLIMITED 其设置具有无限精度算法所需值的 MathContext 对象。

参数类型为 MathContext 的 java.math 中的方法
BigDecimal | BigDecimal.abs(MathContext mc) 返回其值为此 BigDecimal 绝对值的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.add(BigDecimal augend, MathContext mc) 返回其值为 (this + augend) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.divide(BigDecimal divisor, MathContext mc) 返回其值为 (this / divisor) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal[] | BigDecimal.divideAndRemainder(BigDecimal divisor, MathContext mc) 返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟根据上下文设置对两个操作数进行舍入计算所得到的 remainder 的结果。
BigDecimal | BigDecimal.divideToIntegralValue(BigDecimal divisor, MathContext mc) 返回 BigDecimal，其值为 (this / divisor) 的整数部分。
BigDecimal | BigDecimal.multiply(BigDecimal multiplicand, MathContext mc) 返回其值为 (this × multiplicand) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.negate(MathContext mc) 返回其值为 (-this) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.plus(MathContext mc) 返回其值为 (+this) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.pow(int n, MathContext mc) 返回其值为 (thisn) 的 BigDecimal。
BigDecimal | BigDecimal.remainder(BigDecimal divisor, MathContext mc) 返回其值为 (this % divisor) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.round(MathContext mc) 返回根据 MathContext 设置进行舍入后的 BigDecimal。
BigDecimal | BigDecimal.subtract(BigDecimal subtrahend, MathContext mc) 返回其值为 (this - subtrahend) 的 BigDecimal（根据上下文设置进行舍入）。

参数类型为 MathContext 的 java.math 中的构造方法
BigDecimal(BigInteger unscaledVal, int scale, MathContext mc)
将 BigInteger 非标度值和 int 标度转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(BigInteger val, MathContext mc)
将 BigInteger 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(char[] in, int offset, int len, MathContext mc)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列，同时允许指定子数组，并根据上下文设置进行舍入。
BigDecimal(char[] in, MathContext mc)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列（根据上下文设置进行舍入）。
BigDecimal(double val, MathContext mc)
将 double 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(int val, MathContext mc)
将 int 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(long val, MathContext mc)
将 long 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(String val, MathContext mc)
将 BigDecimal 的字符串表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符串（按照上下文设置进行舍入）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.math.RoundingMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.math.RoundingMode
的使用

使用 RoundingMode 的软件包
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.math 中 RoundingMode 的使用

返回 RoundingMode 的 java.math 中的方法
RoundingMode | MathContext.getRoundingMode() 返回 roundingMode 设置。
static RoundingMode | RoundingMode.valueOf(int rm) 返回与 BigDecimal 中遗留整数舍入模式常量对应的 RoundingMode 对象。
static RoundingMode | RoundingMode.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RoundingMode[] | RoundingMode.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 RoundingMode 的 java.math 中的方法
 BigDecimal BigDecimal.divide(BigDecimal divisor, int scale, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal BigDecimal.divide(BigDecimal divisor, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal BigDecimal.setScale(int newScale, RoundingMode roundingMode)
返回 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。

参数类型为 RoundingMode 的 java.math 中的构造方法
MathContext(int setPrecision, RoundingMode setRoundingMode)
构造一个新的 MathContext，它具有指定的精度和舍入模式。

java.text 中 RoundingMode 的使用

返回 RoundingMode 的 java.text 中的方法
RoundingMode | DecimalFormat.getRoundingMode() 获取在此 DecimalFormat 中使用的 RoundingMode。
RoundingMode | NumberFormat.getRoundingMode() 获取在此 NumberFormat 中使用的 RoundingMode。

参数类型为 RoundingMode 的 java.text 中的方法
void | DecimalFormat.setRoundingMode(RoundingMode roundingMode) 设置在此 DecimalFormat 中使用的 RoundingMode。
void | NumberFormat.setRoundingMode(RoundingMode roundingMode) 设置在此 NumberFormat 中使用的 RoundingMode。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.net (Java 2 Platform SE 6)

 java.net
接口
ContentHandlerFactory
CookiePolicy
CookieStore
DatagramSocketImplFactory
FileNameMap
SocketImplFactory
SocketOptions
URLStreamHandlerFactory
类
Authenticator
CacheRequest
CacheResponse
ContentHandler
CookieHandler
CookieManager
DatagramPacket
DatagramSocket
DatagramSocketImpl
HttpCookie
HttpURLConnection
IDN
Inet4Address
Inet6Address
InetAddress
InetSocketAddress
InterfaceAddress
JarURLConnection
MulticastSocket
NetPermission
NetworkInterface
PasswordAuthentication
Proxy
ProxySelector
ResponseCache
SecureCacheResponse
ServerSocket
Socket
SocketAddress
SocketImpl
SocketPermission
URI
URL
URLClassLoader
URLConnection
URLDecoder
URLEncoder
URLStreamHandler
枚举
Authenticator.RequestorType
Proxy.Type
异常
BindException
ConnectException
HttpRetryException
MalformedURLException
NoRouteToHostException
PortUnreachableException
ProtocolException
SocketException
SocketTimeoutException
UnknownHostException
UnknownServiceException
URISyntaxException


类 java.net.Authenticator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Authenticator
的使用

使用 Authenticator 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 Authenticator 的使用

参数类型为 Authenticator 的 java.net 中的方法
static void Authenticator.setDefault(Authenticator a)
设置在代理或 HTTP 服务器请求验证时连网密码使用的 authenticator。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.Authenticator.RequestorType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Authenticator.RequestorType
的使用

使用 Authenticator.RequestorType 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 Authenticator.RequestorType 的使用

返回 Authenticator.RequestorType 的 java.net 中的方法
protected Authenticator.RequestorType | Authenticator.getRequestorType() 返回请求方是代理还是服务器。
static Authenticator.RequestorType | Authenticator.RequestorType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Authenticator.RequestorType[] | Authenticator.RequestorType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Authenticator.RequestorType 的 java.net 中的方法
static PasswordAuthentication Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
要求已经向系统注册的 authenticator 提供密码。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.BindException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.BindException
的使用

没有 java.net.BindException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.CacheRequest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.CacheRequest
的使用

使用 CacheRequest 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 CacheRequest 的使用

返回 CacheRequest 的 java.net 中的方法
abstract  CacheRequest ResponseCache.put(URI uri, URLConnection conn)
协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.CacheResponse 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.CacheResponse
的使用

使用 CacheResponse 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 CacheResponse 的使用

java.net 中 CacheResponse 的子类
 class SecureCacheResponse
表示最初通过安全方法（如 TLS）获得的缓存响应。

返回 CacheResponse 的 java.net 中的方法
abstract  CacheResponse ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
根据请求的 uri、请求方法和请求头获取缓存的响应。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.ConnectException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ConnectException
的使用

没有 java.net.ConnectException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.ContentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ContentHandler
的使用

使用 ContentHandler 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 ContentHandler 的使用

返回 ContentHandler 的 java.net 中的方法
 ContentHandler ContentHandlerFactory.createContentHandler(String mimetype)
创建从 URLStreamHandler 读取对象的新 ContentHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.net.ContentHandlerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.ContentHandlerFactory
的使用

使用 ContentHandlerFactory 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 ContentHandlerFactory 的使用

参数类型为 ContentHandlerFactory 的 java.net 中的方法
static void URLConnection.setContentHandlerFactory(ContentHandlerFactory fac)
设置应用程序的 ContentHandlerFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.CookieHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.CookieHandler
的使用

使用 CookieHandler 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 CookieHandler 的使用

java.net 中 CookieHandler 的子类
 class CookieManager
CookieManager 提供 CookieHandler 的具体实现，它将 cookie 的存储区与围绕接受和拒绝 cookie 的策略分离开来。

返回 CookieHandler 的 java.net 中的方法
static CookieHandler CookieHandler.getDefault()
获取系统级 cookie 处理程序。

参数类型为 CookieHandler 的 java.net 中的方法
static void CookieHandler.setDefault(CookieHandler cHandler)
设置（或取消设置）系统级 cookie 处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.CookieManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.CookieManager
的使用

没有 java.net.CookieManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.net.CookiePolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.CookiePolicy
的使用

使用 CookiePolicy 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 CookiePolicy 的使用

声明为 CookiePolicy 的 java.net 中的字段
static CookiePolicy | CookiePolicy.ACCEPT_ALL 一种预定义策略，表示接受所有 cookie。
static CookiePolicy | CookiePolicy.ACCEPT_NONE 一种预定义策略，表示不接受任何 cookie。
static CookiePolicy | CookiePolicy.ACCEPT_ORIGINAL_SERVER 一种预定义策略，表示只接受来自原始服务器的 cookie。

参数类型为 CookiePolicy 的 java.net 中的方法
 void CookieManager.setCookiePolicy(CookiePolicy cookiePolicy)
设置此 cookie 管理器的 cookie 策略。

参数类型为 CookiePolicy 的 java.net 中的构造方法
CookieManager(CookieStore store, CookiePolicy cookiePolicy)
使用指定 cookie 存储区和 cookie 策略创建一个新 cookie 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.net.CookieStore 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.CookieStore
的使用

使用 CookieStore 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 CookieStore 的使用

返回 CookieStore 的 java.net 中的方法
 CookieStore CookieManager.getCookieStore()
获取当前 cookie 存储区。

参数类型为 CookieStore 的 java.net 中的构造方法
CookieManager(CookieStore store, CookiePolicy cookiePolicy)
使用指定 cookie 存储区和 cookie 策略创建一个新 cookie 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.DatagramPacket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.DatagramPacket
的使用

使用 DatagramPacket 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 DatagramPacket 的使用

参数类型为 DatagramPacket 的 java.net 中的方法
protected abstract  int DatagramSocketImpl.peekData(DatagramPacket p)
查看包来自哪里。
protected abstract  void DatagramSocketImpl.receive(DatagramPacket p)
接收数据报包。
 void DatagramSocket.receive(DatagramPacket p)
从此套接字接收数据报包。
protected abstract  void DatagramSocketImpl.send(DatagramPacket p)
发送数据报包。
 void DatagramSocket.send(DatagramPacket p)
从此套接字发送数据报包。
 void MulticastSocket.send(DatagramPacket p, byte ttl)
已过时。 使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.DatagramSocket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.DatagramSocket
的使用

使用 DatagramSocket 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.net 中 DatagramSocket 的使用

java.net 中 DatagramSocket 的子类
 class MulticastSocket
多播数据报套接字类用于发送和接收 IP 多播包。

java.nio.channels 中 DatagramSocket 的使用

返回 DatagramSocket 的 java.nio.channels 中的方法
abstract  DatagramSocket DatagramChannel.socket()
获取与此通道关联的数据报套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.DatagramSocketImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.DatagramSocketImpl
的使用

使用 DatagramSocketImpl 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 DatagramSocketImpl 的使用

返回 DatagramSocketImpl 的 java.net 中的方法
 DatagramSocketImpl DatagramSocketImplFactory.createDatagramSocketImpl()
创建新的 DatagramSocketImpl 实例。

参数类型为 DatagramSocketImpl 的 java.net 中的构造方法
DatagramSocket(DatagramSocketImpl impl)
创建带有指定 DatagramSocketImpl 的未绑定数据报套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.net.DatagramSocketImplFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.DatagramSocketImplFactory
的使用

使用 DatagramSocketImplFactory 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 DatagramSocketImplFactory 的使用

参数类型为 DatagramSocketImplFactory 的 java.net 中的方法
static void DatagramSocket.setDatagramSocketImplFactory(DatagramSocketImplFactory fac)
为应用程序设置数据报套接字实现工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.net.FileNameMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.FileNameMap
的使用

使用 FileNameMap 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 FileNameMap 的使用

返回 FileNameMap 的 java.net 中的方法
static FileNameMap URLConnection.getFileNameMap()
从数据文件加载文件名映射（一个 mimetable）。

参数类型为 FileNameMap 的 java.net 中的方法
static void URLConnection.setFileNameMap(FileNameMap map)
设置 FileNameMap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.HttpCookie 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.HttpCookie
的使用

使用 HttpCookie 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 HttpCookie 的使用

返回变量类型为 HttpCookie 的类型的 java.net 中的方法
List<HttpCookie> | CookieStore.get(URI uri) 获取与给定 URI 关联或其域与给定 URI 匹配的 cookie。
List<HttpCookie> | CookieStore.getCookies() 获取 cookie 存储区中所有未过期的 cookie。
static List<HttpCookie> | HttpCookie.parse(String header) 根据 set-cookie 或 set-cookie2 头字符串构造 cookie。

参数类型为 HttpCookie 的 java.net 中的方法
void | CookieStore.add(URI uri, HttpCookie cookie) 将一个 HTTP cookie 添加到存储区中。
boolean | CookieStore.remove(URI uri, HttpCookie cookie) 从存储区中移除 cookie。
boolean | CookiePolicy.shouldAccept(URI uri, HttpCookie cookie) 调用此方法查看此 cookie 是否应该被接受。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.HttpRetryException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.HttpRetryException
的使用

没有 java.net.HttpRetryException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.HttpURLConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.HttpURLConnection
的使用

使用 HttpURLConnection 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 HttpURLConnection 的使用

javax.net.ssl 中 HttpURLConnection 的子类
 class HttpsURLConnection
HttpsURLConnection 扩展 HttpURLConnection，支持各种特定于 https 功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.IDN 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.IDN
的使用

没有 java.net.IDN 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.Inet4Address 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Inet4Address
的使用

没有 java.net.Inet4Address 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.Inet6Address 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Inet6Address
的使用

使用 Inet6Address 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 Inet6Address 的使用

返回 Inet6Address 的 java.net 中的方法
static Inet6Address Inet6Address.getByAddress(String host, byte[] addr, int scope_id)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为给定的数字值。
static Inet6Address Inet6Address.getByAddress(String host, byte[] addr, NetworkInterface nif)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.InetAddress 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.InetAddress
的使用

使用 InetAddress 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

java.lang 中 InetAddress 的使用

参数类型为 InetAddress 的 java.lang 中的方法
 void SecurityManager.checkMulticast(InetAddress maddr)
如果不允许调用线程使用（加入/离开/发送/接收）IP 多址广播，则抛出 SecurityException。
 void SecurityManager.checkMulticast(InetAddress maddr, byte ttl)
已过时。 由 #checkPermission(java.security.Permission) 取代

java.net 中 InetAddress 的使用

java.net 中 InetAddress 的子类
class | Inet4Address 此类表示 Internet Protocol version 4 (IPv4) 地址。
class | Inet6Address 此类表示互联网协议第 6 版 (IPv6) 地址。

声明为 InetAddress 的 java.net 中的字段
protected  InetAddress SocketImpl.address
此套接字的远程端点的 IP 地址。

返回 InetAddress 的 java.net 中的方法
InetAddress | InterfaceAddress.getAddress() 返回此地址的 InetAddress。
InetAddress | DatagramPacket.getAddress() 返回某台机器的 IP 地址，此数据报将要发往该机器或者是从该机器接收到的。
InetAddress | InetSocketAddress.getAddress() 获取 InetAddress。
static InetAddress[] | InetAddress.getAllByName(String host) 在给定主机名的情况下，根据系统上配置的名称服务返回其 IP 地址所组成的数组。
InetAddress | InterfaceAddress.getBroadcast() 返回此 InterfaceAddress 广播地址的 InetAddress。
static InetAddress | InetAddress.getByAddress(byte[] addr) 在给定原始 IP 地址的情况下，返回 InetAddress 对象。
static InetAddress | InetAddress.getByAddress(String host, byte[] addr) 根据提供的主机名和 IP 地址创建 InetAddress。
static InetAddress | InetAddress.getByName(String host) 在给定主机名的情况下确定主机的 IP 地址。
protected InetAddress | URLStreamHandler.getHostAddress(URL u) 获取主机的 IP 地址。
InetAddress | DatagramSocket.getInetAddress() 返回此套接字连接的地址。
InetAddress | ServerSocket.getInetAddress() 返回此服务器套接字的本地地址。
protected InetAddress | SocketImpl.getInetAddress() 返回此套接字的 address 字段的值。
InetAddress | Socket.getInetAddress() 返回套接字连接的地址。
InetAddress | MulticastSocket.getInterface() 获取用于多播数据包的网络接口的地址。
InetAddress | DatagramSocket.getLocalAddress() 获取套接字绑定的本地地址。
InetAddress | Socket.getLocalAddress() 获取套接字绑定的本地地址。
static InetAddress | InetAddress.getLocalHost() 返回本地主机。
protected InetAddress | Authenticator.getRequestingSite() 获取请求授权的站点的 InetAddress；如果不可用，则为 null。

返回变量类型为 InetAddress 的类型的 java.net 中的方法
 Enumeration<InetAddress> NetworkInterface.getInetAddresses()
一个便捷方法，返回一个具有绑定到此网络接口全部或部分 InetAddress 的 Enumeration。

参数类型为 InetAddress 的 java.net 中的方法
protected abstract void | SocketImpl.bind(InetAddress host, int port) 将此套接字绑定到指定的本地 IP 地址和端口号。
protected abstract void | DatagramSocketImpl.bind(int lport, InetAddress laddr) 将数据报套接字绑定到本地端口和地址。
protected void | DatagramSocketImpl.connect(InetAddress address, int port) 将数据报套接字连接到远程目标。
void | DatagramSocket.connect(InetAddress address, int port) 将套接字连接到此套接字的远程地址。
protected abstract void | SocketImpl.connect(InetAddress address, int port) 将此套接字连接到指定主机上的指定端口号。
static NetworkInterface | NetworkInterface.getByInetAddress(InetAddress addr) 一个便捷方法，搜索绑定了指定 Internet 协议 (IP) 地址的网络接口。
protected abstract void | DatagramSocketImpl.join(InetAddress inetaddr) 加入多播组。
void | MulticastSocket.joinGroup(InetAddress mcastaddr) 加入多播组。
protected abstract void | DatagramSocketImpl.leave(InetAddress inetaddr) 退出多播组。
void | MulticastSocket.leaveGroup(InetAddress mcastaddr) 离开多播组。
protected abstract int | DatagramSocketImpl.peek(InetAddress i) 查看包来自哪里。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String scheme) 要求已经向系统注册的 authenticator 提供密码。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme) 要求已经向系统注册的 authenticator 提供密码。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType) 要求已经向系统注册的 authenticator 提供密码。
void | DatagramPacket.setAddress(InetAddress iaddr) 设置要将此数据报发往的那台机器的 IP 地址。
void | MulticastSocket.setInterface(InetAddress inf) 设置多播网络接口，供其行为将受网络接口值影响的方法使用。

参数类型为 InetAddress 的 java.net 中的构造方法
DatagramPacket(byte[] buf, int length, InetAddress address, int port)
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[] buf, int offset, int length, InetAddress address, int port)
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramSocket(int port, InetAddress laddr)
创建数据报套接字，将其绑定到指定的本地地址。
InetSocketAddress(InetAddress addr, int port)
根据 IP 地址和端口号创建套接字地址。
ServerSocket(int port, int backlog, InetAddress bindAddr)
使用指定的端口、侦听 backlog 和要绑定到的本地 IP 地址创建服务器。
Socket(InetAddress address, int port)
创建一个流套接字并将其连接到指定 IP 地址的指定端口号。
Socket(InetAddress host, int port, boolean stream)
已过时。 Use DatagramSocket instead for UDP transport.
Socket(InetAddress address, int port, InetAddress localAddr, int localPort)
创建一个套接字并将其连接到指定远程地址上的指定远程端口。
Socket(String host, int port, InetAddress localAddr, int localPort)
创建一个套接字并将其连接到指定远程主机上的指定远程端口。

javax.net 中 InetAddress 的使用

参数类型为 InetAddress 的 javax.net 中的方法
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port, int backlog, InetAddress ifAddress) 返回绑定到指定端口的服务器套接字，该套接字带有指定的侦听 backlog 和本地 IP。
abstract Socket | SocketFactory.createSocket(InetAddress host, int port) 创建一个套接字并把它连接到指定地址上的指定端口号。
abstract Socket | SocketFactory.createSocket(InetAddress address, int port, InetAddress localAddress, int localPort) 创建一个套接字并把它连接到指定远程端口上的指定远程地址。
abstract Socket | SocketFactory.createSocket(String host, int port, InetAddress localHost, int localPort) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。

javax.net.ssl 中 InetAddress 的使用

参数类型为 InetAddress 的 javax.net.ssl 中的构造方法
SSLServerSocket(int port, int backlog, InetAddress address)
仅供子类使用。
SSLSocket(InetAddress address, int port)
仅供子类使用。
SSLSocket(InetAddress address, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。
SSLSocket(String host, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。

javax.security.auth.kerberos 中 InetAddress 的使用

返回 InetAddress 的 javax.security.auth.kerberos 中的方法
 InetAddress[] KerberosTicket.getClientAddresses()
返回可从其所指位置使用票据的地址列表。

参数类型为 InetAddress 的 javax.security.auth.kerberos 中的构造方法
KerberosTicket(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
使用客户端从 KDC 接收的或从缓存中读取的证书信息构造 KerberosTicket。

org.ietf.jgss 中 InetAddress 的使用

返回 InetAddress 的 org.ietf.jgss 中的方法
InetAddress | ChannelBinding.getAcceptorAddress() 获得此通道绑定的接受端的地址。
InetAddress | ChannelBinding.getInitiatorAddress() 获得此通道绑定的初始端地址。

参数类型为 InetAddress 的 org.ietf.jgss 中的构造方法
ChannelBinding(InetAddress initAddr, InetAddress acceptAddr, byte[] appData)
使用用户提供的地址信息和数据创建 ChannelBinding 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.InetSocketAddress 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.InetSocketAddress
的使用

使用 InetSocketAddress 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 InetSocketAddress 的使用

返回 InetSocketAddress 的 java.net 中的方法
static InetSocketAddress InetSocketAddress.createUnresolved(String host, int port)
根据主机名和端口号创建未解析的套接字地址。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.InterfaceAddress 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.InterfaceAddress
的使用

使用 InterfaceAddress 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 InterfaceAddress 的使用

返回变量类型为 InterfaceAddress 的类型的 java.net 中的方法
 List<InterfaceAddress> NetworkInterface.getInterfaceAddresses()
获取此网络接口的全部或部分 InterfaceAddresses 所组成的列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.JarURLConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.JarURLConnection
的使用

没有 java.net.JarURLConnection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.MalformedURLException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.MalformedURLException
的使用

使用 MalformedURLException 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.net | 为实现网络应用程序提供类。
java.rmi | 提供 RMI 包。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。

java.io 中 MalformedURLException 的使用

抛出 MalformedURLException 的 java.io 中的方法
 URL File.toURL()
已过时。 此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。

java.net 中 MalformedURLException 的使用

抛出 MalformedURLException 的 java.net 中的方法
 URL URI.toURL()
根据此 URI 构造一个 URL。

抛出 MalformedURLException 的 java.net 中的构造方法
JarURLConnection(URL url)
创建到指定 URL 的新 JarURLConnection。
URL(String spec)
根据 String 表示形式创建 URL 对象。
URL(String protocol, String host, int port, String file)
根据指定 protocol、host、port 号和 file 创建 URL 对象。
URL(String protocol, String host, int port, String file, URLStreamHandler handler)
根据指定的 protocol、host、port 号、file 和 handler 创建 URL 对象。
URL(String protocol, String host, String file)
根据指定的 protocol 名称、host 名称和 file 名称创建 URL。
URL(URL context, String spec)
通过在指定的上下文中对给定的 spec 进行解析创建 URL。
URL(URL context, String spec, URLStreamHandler handler)
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。

java.rmi 中 MalformedURLException 的使用

抛出 MalformedURLException 的 java.rmi 中的方法
static void | Naming.bind(String name, Remote obj) 将指定 name 绑定到远程对象。
static String[] | Naming.list(String name) 返回在注册表中绑定的名称所组成的数组。
static Remote | Naming.lookup(String name) 返回与指定 name 关联的远程对象的引用（一个 stub）。
static void | Naming.rebind(String name, Remote obj) 将指定名称重新绑定到一个新的远程对象。
static void | Naming.unbind(String name) 销毁与远程对象关联的指定名称的绑定。

java.rmi.server 中 MalformedURLException 的使用

抛出 MalformedURLException 的 java.rmi.server 中的方法
static ClassLoader RMIClassLoader.getClassLoader(String codebase)
返回从给定的基本代码 URL 路径加载类的类加载器。
abstract  ClassLoader RMIClassLoaderSpi.getClassLoader(String codebase)
提供 RMIClassLoader.getClassLoader(String) 的实现。
 Class<?> LoaderHandler.loadClass(String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(String name)
已过时。 由 loadClass(String,String) 方法取代
static Class<?> RMIClassLoader.loadClass(String codebase, String name)
从基本代码 URL 路径加载类。
static Class<?> RMIClassLoader.loadClass(String codebase, String name, ClassLoader defaultLoader)
有选择地使用提供的加载器从基本代码 URL 路径加载类。
abstract  Class<?> RMIClassLoaderSpi.loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
 Class<?> LoaderHandler.loadClass(URL codebase, String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(URL codebase, String name)
从基本代码 URL 加载类。
static Class<?> RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
abstract  Class<?> RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

javax.management.remote 中 MalformedURLException 的使用

抛出 MalformedURLException 的 javax.management.remote 中的构造方法
JMXServiceURL(String serviceURL)
通过解析 Service URL 字符串来构造 JMXServiceURL。
JMXServiceURL(String protocol, String host, int port)
构造具有给定协议、主机和端口的 JMXServiceURL。
JMXServiceURL(String protocol, String host, int port, String urlPath)
构造具有给定部分的 JMXServiceURL。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.MulticastSocket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.MulticastSocket
的使用

没有 java.net.MulticastSocket 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.NetPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.NetPermission
的使用

没有 java.net.NetPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.NetworkInterface 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.NetworkInterface
的使用

使用 NetworkInterface 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 NetworkInterface 的使用

返回 NetworkInterface 的 java.net 中的方法
static NetworkInterface | NetworkInterface.getByInetAddress(InetAddress addr) 一个便捷方法，搜索绑定了指定 Internet 协议 (IP) 地址的网络接口。
static NetworkInterface | NetworkInterface.getByName(String name) 搜索具有指定名称的网络接口。
NetworkInterface | MulticastSocket.getNetworkInterface() 获取多播网络接口集合。
NetworkInterface | NetworkInterface.getParent() 如果此接口是子接口，则返回它的父 NetworkInterface；如果它是物理（非虚拟）接口或没有父接口，则返回 null。
NetworkInterface | Inet6Address.getScopedInterface() 如果此实例是使用范围接口创建的，则返回范围接口。

返回变量类型为 NetworkInterface 的类型的 java.net 中的方法
static Enumeration<NetworkInterface> | NetworkInterface.getNetworkInterfaces() 返回此机器上的所有接口。
Enumeration<NetworkInterface> | NetworkInterface.getSubInterfaces() 获取具有连接到此网络接口的所有子接口（也称虚拟接口）的 Enumeration。

参数类型为 NetworkInterface 的 java.net 中的方法
static Inet6Address Inet6Address.getByAddress(String host, byte[] addr, NetworkInterface nif)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。
 boolean InetAddress.isReachable(NetworkInterface netif, int ttl, int timeout)
测试是否可以达到该地址。
protected abstract  void DatagramSocketImpl.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf)
加入多播组。
 void MulticastSocket.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf)
加入指定接口上的指定多播组。
protected abstract  void DatagramSocketImpl.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf)
退出多播组。
 void MulticastSocket.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf)
离开指定本地接口上的多播组。
 void MulticastSocket.setNetworkInterface(NetworkInterface netIf)
指定在此套接字上发送的输出多播数据报的网络接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.NoRouteToHostException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.NoRouteToHostException
的使用

没有 java.net.NoRouteToHostException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.PasswordAuthentication 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.PasswordAuthentication
的使用

使用 PasswordAuthentication 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 PasswordAuthentication 的使用

返回 PasswordAuthentication 的 java.net 中的方法
protected PasswordAuthentication | Authenticator.getPasswordAuthentication() 需要密码授权时调用。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String scheme) 要求已经向系统注册的 authenticator 提供密码。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme) 要求已经向系统注册的 authenticator 提供密码。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType) 要求已经向系统注册的 authenticator 提供密码。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.PortUnreachableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.PortUnreachableException
的使用

没有 java.net.PortUnreachableException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.ProtocolException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ProtocolException
的使用

使用 ProtocolException 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 ProtocolException 的使用

抛出 ProtocolException 的 java.net 中的方法
 void HttpURLConnection.setRequestMethod(String method)
设置 URL 请求的方法， GET POST HEAD OPTIONS PUT DELETE TRACE 以上方法之一是合法的，具体取决于协议的限制。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.Proxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Proxy
的使用

使用 Proxy 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 Proxy 的使用

声明为 Proxy 的 java.net 中的字段
static Proxy Proxy.NO_PROXY
表示 DIRECT 连接的代理设置，主要通知协议处理程序不使用任何代理。

返回变量类型为 Proxy 的类型的 java.net 中的方法
abstract  List<Proxy> ProxySelector.select(URI uri)
基于访问资源所需的协议和访问资源的目标地址选择所有可用的代理。

参数类型为 Proxy 的 java.net 中的方法
 URLConnection URL.openConnection(Proxy proxy)
与 openConnection() 类似，所不同是连接通过指定的代理建立；不支持代理方式的协议处理程序将忽略该代理参数并建立正常的连接。
protected  URLConnection URLStreamHandler.openConnection(URL u, Proxy p)
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。

参数类型为 Proxy 的 java.net 中的构造方法
Socket(Proxy proxy)
创建一个未连接的套接字并指定代理类型（如果有），该代理不管其他设置如何都应被使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.Proxy.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Proxy.Type
的使用

使用 Proxy.Type 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 Proxy.Type 的使用

返回 Proxy.Type 的 java.net 中的方法
Proxy.Type | Proxy.type() 返回代理类型。
static Proxy.Type | Proxy.Type.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Proxy.Type[] | Proxy.Type.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Proxy.Type 的 java.net 中的构造方法
Proxy(Proxy.Type type, SocketAddress sa)
创建表示 PROXY 连接的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.ProxySelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ProxySelector
的使用

使用 ProxySelector 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 ProxySelector 的使用

返回 ProxySelector 的 java.net 中的方法
static ProxySelector ProxySelector.getDefault()
获取系统级代理选择器。

参数类型为 ProxySelector 的 java.net 中的方法
static void ProxySelector.setDefault(ProxySelector ps)
设置（或取消设置）系统级代理选择器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.ResponseCache 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ResponseCache
的使用

使用 ResponseCache 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 ResponseCache 的使用

返回 ResponseCache 的 java.net 中的方法
static ResponseCache ResponseCache.getDefault()
获取系统级响应缓存。

参数类型为 ResponseCache 的 java.net 中的方法
static void ResponseCache.setDefault(ResponseCache responseCache)
设置（或取消设置）系统级缓存。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.SecureCacheResponse 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SecureCacheResponse
的使用

没有 java.net.SecureCacheResponse 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.ServerSocket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ServerSocket
的使用

使用 ServerSocket 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

java.nio.channels 中 ServerSocket 的使用

返回 ServerSocket 的 java.nio.channels 中的方法
abstract  ServerSocket ServerSocketChannel.socket()
获取与此通道关联的服务器套接字。

java.rmi.server 中 ServerSocket 的使用

返回 ServerSocket 的 java.rmi.server 中的方法
ServerSocket | RMIServerSocketFactory.createServerSocket(int port) 在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
abstract ServerSocket | RMISocketFactory.createServerSocket(int port) 在指定端口上（端口 0 指示匿名端口）创建服务器套接字。

javax.net 中 ServerSocket 的使用

返回 ServerSocket 的 javax.net 中的方法
ServerSocket | ServerSocketFactory.createServerSocket() 返回未绑定的服务器套接字。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port) 返回绑定到指定端口的服务器套接字。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port, int backlog) 返回绑定到指定端口的服务器套接字，并且使用指定的连接 backlog。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port, int backlog, InetAddress ifAddress) 返回绑定到指定端口的服务器套接字，该套接字带有指定的侦听 backlog 和本地 IP。

javax.net.ssl 中 ServerSocket 的使用

javax.net.ssl 中 ServerSocket 的子类
 class SSLServerSocket
此类扩展了 ServerSocket 并且提供使用像 Secure Sockets Layer (SSL) 或 Transport Layer Security (TLS) 协议的安全服务器套接字。

javax.rmi.ssl 中 ServerSocket 的使用

返回 ServerSocket 的 javax.rmi.ssl 中的方法
 ServerSocket SslRMIServerSocketFactory.createServerSocket(int port)
创建一个服务器套接字，该套接字接受根据此工厂的 SSL 套接字配置参数配置的 SSL 连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.Socket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Socket
的使用

使用 Socket 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

java.net 中 Socket 的使用

返回 Socket 的 java.net 中的方法
 Socket ServerSocket.accept()
侦听并接受到此套接字的连接。

参数类型为 Socket 的 java.net 中的方法
protected  void ServerSocket.implAccept(Socket s)
ServerSocket 的子类使用此方法重写 accept() 以返回它们自己的套接字子类。

java.nio.channels 中 Socket 的使用

返回 Socket 的 java.nio.channels 中的方法
abstract  Socket SocketChannel.socket()
获取与此通道关联的套接字。

java.rmi.server 中 Socket 的使用

返回 Socket 的 java.rmi.server 中的方法
Socket | RMIClientSocketFactory.createSocket(String host, int port) 创建连接到指定主机和端口的客户机套接字。
abstract Socket | RMISocketFactory.createSocket(String host, int port) 创建连接到指定主机和端口的客户机套接字。

javax.net 中 Socket 的使用

返回 Socket 的 javax.net 中的方法
Socket | SocketFactory.createSocket() 创建一个未连接的套接字。
abstract Socket | SocketFactory.createSocket(InetAddress host, int port) 创建一个套接字并把它连接到指定地址上的指定端口号。
abstract Socket | SocketFactory.createSocket(InetAddress address, int port, InetAddress localAddress, int localPort) 创建一个套接字并把它连接到指定远程端口上的指定远程地址。
abstract Socket | SocketFactory.createSocket(String host, int port) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。
abstract Socket | SocketFactory.createSocket(String host, int port, InetAddress localHost, int localPort) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。

javax.net.ssl 中 Socket 的使用

javax.net.ssl 中 Socket 的子类
 class SSLSocket
此类扩展 Socket 并提供使用诸如安全套接字层 (Secure Sockets Layer, SSL) 或 IETF 传输层安全性 (Transport Layer Security, TLS) 等协议的安全套接字。

返回 Socket 的 javax.net.ssl 中的方法
abstract  Socket SSLSocketFactory.createSocket(Socket s, String host, int port, boolean autoClose)
返回在连接到指定主机的给定端口的现有套接字上分层的套接字。

参数类型为 Socket 的 javax.net.ssl 中的方法
String | X509KeyManager.chooseClientAlias(String[] keyType, Principal[] issuers, Socket socket) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。
String | X509KeyManager.chooseServerAlias(String keyType, Principal[] issuers, Socket socket) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。
abstract Socket | SSLSocketFactory.createSocket(Socket s, String host, int port, boolean autoClose) 返回在连接到指定主机的给定端口的现有套接字上分层的套接字。

javax.rmi.ssl 中 Socket 的使用

返回 Socket 的 javax.rmi.ssl 中的方法
 Socket SslRMIClientSocketFactory.createSocket(String host, int port)
创建一个 SSL 套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.SocketAddress 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SocketAddress
的使用

使用 SocketAddress 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.net 中 SocketAddress 的使用

java.net 中 SocketAddress 的子类
 class InetSocketAddress
此类实现 IP 套接字地址（IP 地址 + 端口号）。

返回 SocketAddress 的 java.net 中的方法
SocketAddress | Proxy.address() 返回代理的套接字地址，如果其为直接连接，则返回 null。
SocketAddress | DatagramSocket.getLocalSocketAddress() 返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
SocketAddress | ServerSocket.getLocalSocketAddress() 返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
SocketAddress | Socket.getLocalSocketAddress() 返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
SocketAddress | DatagramSocket.getRemoteSocketAddress() 返回此套接字连接的端点的地址，如果未连接则返回 null。
SocketAddress | Socket.getRemoteSocketAddress() 返回此套接字连接的端点的地址，如果未连接则返回 null。
SocketAddress | DatagramPacket.getSocketAddress() 获取要将此包发送到的或发出此数据报的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。

参数类型为 SocketAddress 的 java.net 中的方法
void | DatagramSocket.bind(SocketAddress addr) 将此 DatagramSocket 绑定到特定的地址和端口。
void | ServerSocket.bind(SocketAddress endpoint) 将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
void | Socket.bind(SocketAddress bindpoint) 将套接字绑定到本地地址。
void | ServerSocket.bind(SocketAddress endpoint, int backlog) 将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
void | DatagramSocket.connect(SocketAddress addr) 将此套接字连接到远程套接字地址（IP 地址 + 端口号）。
void | Socket.connect(SocketAddress endpoint) 将此套接字连接到服务器。
protected abstract void | SocketImpl.connect(SocketAddress address, int timeout) 将此套接字连接到指定主机上的指定端口号。
void | Socket.connect(SocketAddress endpoint, int timeout) 将此套接字连接到服务器，并指定一个超时值。
abstract void | ProxySelector.connectFailed(URI uri, SocketAddress sa, IOException ioe) 调用此方法来指示无法建立到代理/socks 服务器的连接。
protected abstract void | DatagramSocketImpl.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf) 加入多播组。
void | MulticastSocket.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf) 加入指定接口上的指定多播组。
protected abstract void | DatagramSocketImpl.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf) 退出多播组。
void | MulticastSocket.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf) 离开指定本地接口上的多播组。
void | DatagramPacket.setSocketAddress(SocketAddress address) 设置要将此数据报发往的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。

参数类型为 SocketAddress 的 java.net 中的构造方法
DatagramPacket(byte[] buf, int offset, int length, SocketAddress address)
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[] buf, int length, SocketAddress address)
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramSocket(SocketAddress bindaddr)
创建数据报套接字，将其绑定到指定的本地套接字地址。
MulticastSocket(SocketAddress bindaddr)
创建绑定到指定套接字地址的 MulticastSocket。
Proxy(Proxy.Type type, SocketAddress sa)
创建表示 PROXY 连接的条目。

java.nio.channels 中 SocketAddress 的使用

返回 SocketAddress 的 java.nio.channels 中的方法
abstract  SocketAddress DatagramChannel.receive(ByteBuffer dst)
通过此通道接收数据报。

参数类型为 SocketAddress 的 java.nio.channels 中的方法
abstract DatagramChannel | DatagramChannel.connect(SocketAddress remote) 连接此通道的套接字。
abstract boolean | SocketChannel.connect(SocketAddress remote) 连接此通道的套接字。
static SocketChannel | SocketChannel.open(SocketAddress remote) 打开套接字通道并将其连接到远程地址。
abstract int | DatagramChannel.send(ByteBuffer src, SocketAddress target) 通过此通道发送数据报。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.SocketException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SocketException
的使用

使用 SocketException 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 SocketException 的使用

java.net 中 SocketException 的子类
class | BindException 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
class | ConnectException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | NoRouteToHostException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | PortUnreachableException 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。

抛出 SocketException 的 java.net 中的方法
protected abstract void | DatagramSocketImpl.bind(int lport, InetAddress laddr) 将数据报套接字绑定到本地端口和地址。
void | DatagramSocket.bind(SocketAddress addr) 将此 DatagramSocket 绑定到特定的地址和端口。
protected void | DatagramSocketImpl.connect(InetAddress address, int port) 将数据报套接字连接到远程目标。
void | DatagramSocket.connect(SocketAddress addr) 将此套接字连接到远程套接字地址（IP 地址 + 端口号）。
protected abstract void | DatagramSocketImpl.create() 创建数据报套接字。
boolean | DatagramSocket.getBroadcast() 检测是否启用了 SO_BROADCAST。
static NetworkInterface | NetworkInterface.getByInetAddress(InetAddress addr) 一个便捷方法，搜索绑定了指定 Internet 协议 (IP) 地址的网络接口。
static NetworkInterface | NetworkInterface.getByName(String name) 搜索具有指定名称的网络接口。
byte[] | NetworkInterface.getHardwareAddress() 如果存在硬件地址并可以使用给定的当前权限访问，则返回该硬件地址（通常是 MAC）。
InetAddress | MulticastSocket.getInterface() 获取用于多播数据包的网络接口的地址。
boolean | Socket.getKeepAlive() 测试是否启用 SO_KEEPALIVE。
boolean | MulticastSocket.getLoopbackMode() 获取多播数据报的本地回送的设置。
int | NetworkInterface.getMTU() 返回此接口的最大传输单元（Maximum Transmission Unit，MTU）。
NetworkInterface | MulticastSocket.getNetworkInterface() 获取多播网络接口集合。
static Enumeration<NetworkInterface> | NetworkInterface.getNetworkInterfaces() 返回此机器上的所有接口。
boolean | Socket.getOOBInline() 测试是否启用 OOBINLINE。
Object | SocketOptions.getOption(int optID) 获取选项的值。
int | DatagramSocket.getReceiveBufferSize() 获取此 DatagramSocket 的 SO_RCVBUF 选项的值，该值是平台在 DatagramSocket 上输入时使用的缓冲区大小。
int | ServerSocket.getReceiveBufferSize() 获取此 ServerSocket 的 SO_RCVBUF 选项的值，该值是将用于从此 ServerSocket 接受的套接字的建议缓冲区大小。
int | Socket.getReceiveBufferSize() 获取此 Socket 的 SO_RCVBUF 选项的值，该值是平台在 Socket 上输入时使用的缓冲区大小。
boolean | DatagramSocket.getReuseAddress() 检测是否启用了 SO_REUSEADDR。
boolean | ServerSocket.getReuseAddress() 测试是否启用 SO_REUSEADDR。
boolean | Socket.getReuseAddress() 测试是否启用 SO_REUSEADDR。
int | DatagramSocket.getSendBufferSize() 获取此 DatagramSocket 的 SO_SNDBUF 选项的值，该值是平台在 DatagramSocket 上输出时使用的缓冲区大小。
int | Socket.getSendBufferSize() 获取此 Socket 的 SO_SNDBUF 选项的值，该值是平台在 Socket 上输出时使用的缓冲区大小。
int | Socket.getSoLinger() 返回 SO_LINGER 的设置。
int | DatagramSocket.getSoTimeout() 获取 SO_TIMEOUT 的设置。
int | Socket.getSoTimeout() 返回 SO_TIMEOUT 的设置。
boolean | Socket.getTcpNoDelay() 测试是否启用 TCP_NODELAY。
int | DatagramSocket.getTrafficClass() 为从此 DatagramSocket 上发送的包获取 IP 数据报头中的流量类别或服务类型。
int | Socket.getTrafficClass() 为从此 Socket 上发送的包获取 IP 头中的流量类别或服务类型。
boolean | NetworkInterface.isLoopback() 返回网络接口是否是回送接口。
boolean | NetworkInterface.isPointToPoint() 返回网络接口是否是点对点接口。
boolean | NetworkInterface.isUp() 返回网络接口是否已经开启并运行。
void | DatagramSocket.setBroadcast(boolean on) 启用/禁用 SO_BROADCAST。
void | MulticastSocket.setInterface(InetAddress inf) 设置多播网络接口，供其行为将受网络接口值影响的方法使用。
void | Socket.setKeepAlive(boolean on) 启用/禁用 SO_KEEPALIVE。
void | MulticastSocket.setLoopbackMode(boolean disable) 启用/禁用多播数据报的本地回送。
void | MulticastSocket.setNetworkInterface(NetworkInterface netIf) 指定在此套接字上发送的输出多播数据报的网络接口。
void | Socket.setOOBInline(boolean on) 启用/禁用 OOBINLINE（TCP 紧急数据的接收者） 默认情况下，此选项是禁用的，即在套接字上接收的 TCP 紧急数据被静默丢弃。
void | SocketOptions.setOption(int optID, Object value) 启用/禁用 optID 指定的选项。
void | DatagramSocket.setReceiveBufferSize(int size) 将此 DatagramSocket 的 SO_RCVBUF 选项设置为指定的值。
void | ServerSocket.setReceiveBufferSize(int size) 为从此 ServerSocket 接受的套接字的 SO_RCVBUF 选项设置默认建议值。
void | Socket.setReceiveBufferSize(int size) 将此 Socket 的 SO_RCVBUF 选项设置为指定的值。
void | DatagramSocket.setReuseAddress(boolean on) 启用/禁用 SO_REUSEADDR 套接字选项。
void | ServerSocket.setReuseAddress(boolean on) 启用/禁用 SO_REUSEADDR 套接字选项。
void | Socket.setReuseAddress(boolean on) 启用/禁用 SO_REUSEADDR 套接字选项。
void | DatagramSocket.setSendBufferSize(int size) 将此 DatagramSocket 的 SO_SNDBUF 选项设置为指定的值。
void | Socket.setSendBufferSize(int size) 将此 Socket 的 SO_SNDBUF 选项设置为指定的值。
void | Socket.setSoLinger(boolean on, int linger) 启用/禁用具有指定逗留时间（以秒为单位）的 SO_LINGER。
void | DatagramSocket.setSoTimeout(int timeout) 启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。
void | ServerSocket.setSoTimeout(int timeout) 通过指定超时值启用/禁用 SO_TIMEOUT，以毫秒为单位。
void | Socket.setSoTimeout(int timeout) 启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。
void | Socket.setTcpNoDelay(boolean on) 启用/禁用 TCP_NODELAY（启用/禁用 Nagle 算法）。
void | DatagramSocket.setTrafficClass(int tc) 为从此 DatagramSocket 上发送的数据报在 IP 数据报头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。
void | Socket.setTrafficClass(int tc) 为从此 Socket 上发送的包在 IP 头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。
boolean | NetworkInterface.supportsMulticast() 返回网络接口是否支持多址广播。

抛出 SocketException 的 java.net 中的构造方法
DatagramPacket(byte[] buf, int offset, int length, SocketAddress address)
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[] buf, int length, SocketAddress address)
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramSocket()
构造数据报套接字并将其绑定到本地主机上任何可用的端口。
DatagramSocket(int port)
创建数据报套接字并将其绑定到本地主机上的指定端口。
DatagramSocket(int port, InetAddress laddr)
创建数据报套接字，将其绑定到指定的本地地址。
DatagramSocket(SocketAddress bindaddr)
创建数据报套接字，将其绑定到指定的本地套接字地址。
Socket(SocketImpl impl)
使用用户指定的 SocketImpl 创建一个未连接 Socket。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.SocketImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SocketImpl
的使用

使用 SocketImpl 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 SocketImpl 的使用

返回 SocketImpl 的 java.net 中的方法
 SocketImpl SocketImplFactory.createSocketImpl()
创建新的 SocketImpl 实例。

参数类型为 SocketImpl 的 java.net 中的方法
protected abstract  void SocketImpl.accept(SocketImpl s)
接受连接。

参数类型为 SocketImpl 的 java.net 中的构造方法
Socket(SocketImpl impl)
使用用户指定的 SocketImpl 创建一个未连接 Socket。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.net.SocketImplFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.SocketImplFactory
的使用

使用 SocketImplFactory 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 SocketImplFactory 的使用

参数类型为 SocketImplFactory 的 java.net 中的方法
static void | ServerSocket.setSocketFactory(SocketImplFactory fac) 为应用程序设置服务器套接字实现工厂。
static void | Socket.setSocketImplFactory(SocketImplFactory fac) 为应用程序设置客户端套接字实现工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.net.SocketOptions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.SocketOptions
的使用

使用 SocketOptions 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 SocketOptions 的使用

实现 SocketOptions 的 java.net 中的类
class | DatagramSocketImpl 数据报和多播套接字实现的抽象基类。
class | SocketImpl 抽象类 SocketImpl 是实际实现套接字的所有类的通用超类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.SocketPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SocketPermission
的使用

没有 java.net.SocketPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.SocketTimeoutException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SocketTimeoutException
的使用

没有 java.net.SocketTimeoutException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.UnknownHostException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.UnknownHostException
的使用

使用 UnknownHostException 的软件包
java.net | 为实现网络应用程序提供类。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。

java.net 中 UnknownHostException 的使用

抛出 UnknownHostException 的 java.net 中的方法
static InetAddress[] InetAddress.getAllByName(String host)
在给定主机名的情况下，根据系统上配置的名称服务返回其 IP 地址所组成的数组。
static InetAddress InetAddress.getByAddress(byte[] addr)
在给定原始 IP 地址的情况下，返回 InetAddress 对象。
static InetAddress InetAddress.getByAddress(String host, byte[] addr)
根据提供的主机名和 IP 地址创建 InetAddress。
static Inet6Address Inet6Address.getByAddress(String host, byte[] addr, int scope_id)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为给定的数字值。
static Inet6Address Inet6Address.getByAddress(String host, byte[] addr, NetworkInterface nif)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。
static InetAddress InetAddress.getByName(String host)
在给定主机名的情况下确定主机的 IP 地址。
static InetAddress InetAddress.getLocalHost()
返回本地主机。

抛出 UnknownHostException 的 java.net 中的构造方法
Socket(String host, int port)
创建一个流套接字并将其连接到指定主机上的指定端口号。

javax.net 中 UnknownHostException 的使用

抛出 UnknownHostException 的 javax.net 中的方法
abstract Socket | SocketFactory.createSocket(String host, int port) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。
abstract Socket | SocketFactory.createSocket(String host, int port, InetAddress localHost, int localPort) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。

javax.net.ssl 中 UnknownHostException 的使用

抛出 UnknownHostException 的 javax.net.ssl 中的构造方法
SSLSocket(String host, int port)
仅供子类使用。
SSLSocket(String host, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.UnknownServiceException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.UnknownServiceException
的使用

没有 java.net.UnknownServiceException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.URI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URI
的使用

使用 URI 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.awt 中 URI 的使用

参数类型为 URI 的 java.awt 中的方法
void | Desktop.browse(URI uri) 启动默认浏览器来显示 URI。
void | Desktop.mail(URI mailtoURI) 启动用户默认邮件客户端的邮件组合窗口，填充由 mailto: URI 指定的消息字段。

java.io 中 URI 的使用

返回 URI 的 java.io 中的方法
 URI File.toURI()
构造一个表示此抽象路径名的 file: URI。

参数类型为 URI 的 java.io 中的构造方法
File(URI uri)
通过将给定的 file: URI 转换为一个抽象路径名来创建一个新的 File 实例。

java.net 中 URI 的使用

返回 URI 的 java.net 中的方法
static URI | URI.create(String str) 通过解析给定的字符串创建 URI。
URI | URI.normalize() 规范化此 URI 的路径。
URI | URI.parseServerAuthority() 尝试将此 URI 的授权组成部分（如果已定义）解析为用户信息、主机和端口组成部分。
URI | URI.relativize(URI uri) 根据此 URI 将给定 URI 相对化。
URI | URI.resolve(String str) 解析给定的字符串，然后在此 URI 的基础上构造一个新的 URI。
URI | URI.resolve(URI uri) 根据此 URI 解析给定的 URI。
URI | URL.toURI() 返回与此 URL 等效的 URI。

返回变量类型为 URI 的类型的 java.net 中的方法
 List<URI> CookieStore.getURIs()
获取所有标识此 cookie 存储区中 cookie 的 URI。

参数类型为 URI 的 java.net 中的方法
void | CookieStore.add(URI uri, HttpCookie cookie) 将一个 HTTP cookie 添加到存储区中。
int | URI.compareTo(URI that) 将此 URI 与另一个对象（也必须是 URI）进行比较。
abstract void | ProxySelector.connectFailed(URI uri, SocketAddress sa, IOException ioe) 调用此方法来指示无法建立到代理/socks 服务器的连接。
List<HttpCookie> | CookieStore.get(URI uri) 获取与给定 URI 关联或其域与给定 URI 匹配的 cookie。
abstract Map<String,List<String>> | CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
Map<String,List<String>> | CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
abstract CacheResponse | ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders) 根据请求的 uri、请求方法和请求头获取缓存的响应。
abstract void | CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders) 将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
void | CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)
abstract CacheRequest | ResponseCache.put(URI uri, URLConnection conn) 协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。
URI | URI.relativize(URI uri) 根据此 URI 将给定 URI 相对化。
boolean | CookieStore.remove(URI uri, HttpCookie cookie) 从存储区中移除 cookie。
URI | URI.resolve(URI uri) 根据此 URI 解析给定的 URI。
abstract List<Proxy> | ProxySelector.select(URI uri) 基于访问资源所需的协议和访问资源的目标地址选择所有可用的代理。
boolean | CookiePolicy.shouldAccept(URI uri, HttpCookie cookie) 调用此方法查看此 cookie 是否应该被接受。

java.security 中 URI 的使用

返回 URI 的 java.security 中的方法
 URI URIParameter.getURI()
返回 URI。

参数类型为 URI 的 java.security 中的构造方法
URIParameter(URI uri)
使用指向数据的 URI 构造一个 URIParameter，指向的数据用于 SPI 实现。

javax.print 中 URI 的使用

返回 URI 的 javax.print 中的方法
 URI URIException.getUnsupportedURI()
返回 URI。

javax.print.attribute 中 URI 的使用

返回 URI 的 javax.print.attribute 中的方法
 URI URISyntax.getURI()
返回此 URI 属性的 URI 值。

参数类型为 URI 的 javax.print.attribute 中的构造方法
URISyntax(URI uri)
构造带有指定 URI 的 URI 属性。

javax.print.attribute.standard 中 URI 的使用

参数类型为 URI 的 javax.print.attribute.standard 中的构造方法
Destination(URI uri)
构造具有给定 URI 的新目标属性。
PrinterMoreInfo(URI uri)
构造具有指定 URI 的新 PrinterMoreInfo 属性。
PrinterMoreInfoManufacturer(URI uri)
构造具有指定 URI 的新 PrinterMoreInfoManufacturer 属性。
PrinterURI(URI uri)
构建具有指定 URI 的新 PrinterURI 属性。

javax.tools 中 URI 的使用

声明为 URI 的 javax.tools 中的字段
protected  URI SimpleJavaFileObject.uri
此文件对象的 URI。

返回 URI 的 javax.tools 中的方法
URI | FileObject.toUri() 返回标识此文件对象的 URI。
URI | ForwardingFileObject.toUri()
URI | SimpleJavaFileObject.toUri()

参数类型为 URI 的 javax.tools 中的构造方法
SimpleJavaFileObject(URI uri, JavaFileObject.Kind kind)
使用给定 URI 构建给定种类的 SimpleJavaFileObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.URISyntaxException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URISyntaxException
的使用

使用 URISyntaxException 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 URISyntaxException 的使用

抛出 URISyntaxException 的 java.net 中的方法
URI | URI.parseServerAuthority() 尝试将此 URI 的授权组成部分（如果已定义）解析为用户信息、主机和端口组成部分。
URI | URL.toURI() 返回与此 URL 等效的 URI。

抛出 URISyntaxException 的 java.net 中的构造方法
URI(String str)
通过解析给定的字符串构造一个 URI。
URI(String scheme, String ssp, String fragment)
根据给定的组成部分构造 URI。
URI(String scheme, String userInfo, String host, int port, String path, String query, String fragment)
根据给定的组成部分构造一个分层 URI。
URI(String scheme, String host, String path, String fragment)
根据给定的组成部分构造分层 URI。
URI(String scheme, String authority, String path, String query, String fragment)
根据给定的组成部分构造分层 URI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.URL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URL
的使用

使用 URL 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.activation |
javax.imageio | Java Image I/O API 的主要包。
javax.management.loading | 提供实现高级动态加载的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

java.applet 中 URL 的使用

返回 URL 的 java.applet 中的方法
URL | AppletStub.getCodeBase() 获取基 URL。
URL | Applet.getCodeBase() 获得基 URL。
URL | AppletStub.getDocumentBase() 获取嵌入 applet 的文档的 URL。
URL | Applet.getDocumentBase() 获取嵌入此 applet 的文档的 URL。

参数类型为 URL 的 java.applet 中的方法
AudioClip | AppletContext.getAudioClip(URL url) 创建音频剪辑。
AudioClip | Applet.getAudioClip(URL url) 返回 URL 参数指定的 AudioClip 对象。
AudioClip | Applet.getAudioClip(URL url, String name) 返回 URL 和 name 参数指定的 AudioClip 对象。
Image | AppletContext.getImage(URL url) 返回能被绘制到屏幕上的 Image 对象。
Image | Applet.getImage(URL url) 返回能被绘制到屏幕上的 Image 对象。
Image | Applet.getImage(URL url, String name) 返回能被绘制到屏幕上的 Image 对象。
static AudioClip | Applet.newAudioClip(URL url) 从给定 URL 处获取音频剪辑。
void | Applet.play(URL url) 播放指定绝对 URL 处的音频剪辑。
void | Applet.play(URL url, String name) 播放音频剪辑，给定了 URL 及与之相对的说明符。
void | AppletContext.showDocument(URL url) 请求浏览器或 applet viewer 显示 url 参数指示的 Web 页面。
void | AppletContext.showDocument(URL url, String target) 请求浏览器或 applet viewer 显示由 url 参数所指示的 Web 页。

java.awt 中 URL 的使用

返回 URL 的 java.awt 中的方法
 URL SplashScreen.getImageURL()
返回当前闪现屏幕图像。

参数类型为 URL 的 java.awt 中的方法
abstract Image | Toolkit.createImage(URL url) 返回一幅图像，该图像从指定 URL 获取像素数据。
abstract Image | Toolkit.getImage(URL url) 返回一幅图像，该图像从指定 URL 获取像素数据。
void | SplashScreen.setImageURL(URL imageURL) 更改闪现屏幕图像。

java.beans.beancontext 中 URL 的使用

返回 URL 的 java.beans.beancontext 中的方法
 URL BeanContext.getResource(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 URL BeanContextSupport.getResource(String name, BeanContextChild bcc)

java.io 中 URL 的使用

返回 URL 的 java.io 中的方法
 URL File.toURL()
已过时。 此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。

java.lang 中 URL 的使用

返回 URL 的 java.lang 中的方法
protected URL | ClassLoader.findResource(String name) 查找具有给定名称的资源。
URL | ClassLoader.getResource(String name) 查找具有给定名称的资源。
URL | Class.getResource(String name) 查找带有给定名称的资源。
static URL | ClassLoader.getSystemResource(String name) 从用来加载类的搜索路径中查找具有指定名称的资源。

返回变量类型为 URL 的类型的 java.lang 中的方法
protected Enumeration<URL> | ClassLoader.findResources(String name) 返回表示所有具有给定名称的资源的 URL 对象的枚举。
Enumeration<URL> | ClassLoader.getResources(String name) 查找所有给定名称的资源。
static Enumeration<URL> | ClassLoader.getSystemResources(String name) 从用来加载类的搜索路径中查找所有具有指定名称的资源。

参数类型为 URL 的 java.lang 中的方法
protected Package | ClassLoader.definePackage(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase) 根据 name 在此 ClassLoader 中定义包。
boolean | Package.isSealed(URL url) 如果此包对于指定的代码源 url 是密封的，则返回 ture。

java.net 中 URL 的使用

声明为 URL 的 java.net 中的字段
protected  URL URLConnection.url
URL 表示此连接要在互联网上打开的远程对象。

返回 URL 的 java.net 中的方法
URL | URLClassLoader.findResource(String name) 在 URL 搜索路径中查找具有指定名称的资源。
URL | JarURLConnection.getJarFileURL() 返回此连接的 Jar 文件的 URL。
protected URL | Authenticator.getRequestingURL() 返回导致请求验证的 URL。
URL | URLConnection.getURL() 返回此 URLConnection 的 URL 字段的值。
URL[] | URLClassLoader.getURLs() 返回用于加载类和资源的 URL 搜索路径。
URL | URI.toURL() 根据此 URI 构造一个 URL。

返回变量类型为 URL 的类型的 java.net 中的方法
 Enumeration<URL> URLClassLoader.findResources(String name)
返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。

参数类型为 URL 的 java.net 中的方法
protected  void URLClassLoader.addURL(URL url)
将指定的 URL 添加到 URL 列表中，以便搜索类和资源。
protected  Package URLClassLoader.definePackage(String name, Manifest man, URL url)
用该 ClassLoader 中的名称定义一个新包。
protected  boolean URLStreamHandler.equals(URL u1, URL u2)
提供默认的 equals 计算。
protected  InetAddress URLStreamHandler.getHostAddress(URL u)
获取主机的 IP 地址。
protected  int URLStreamHandler.hashCode(URL u)
提供默认的哈希计算。
protected  boolean URLStreamHandler.hostsEqual(URL u1, URL u2)
比较两个 URL 的主机组件。
static URLClassLoader URLClassLoader.newInstance(URL[] urls)
为指定的 URL 和默认的父类加载器创建新 URLClassLoader 实例。
static URLClassLoader URLClassLoader.newInstance(URL[] urls, ClassLoader parent)
为指定的 URL 和父类加载器创建新 URLClassLoader 实例。
protected abstract  URLConnection URLStreamHandler.openConnection(URL u)
打开一个到 URL 参数引用的对象的连接。
protected  URLConnection URLStreamHandler.openConnection(URL u, Proxy p)
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。
protected  void URLStreamHandler.parseURL(URL u, String spec, int start, int limit)
将 URL 的字符表示形式解析为 URL 对象。
static PasswordAuthentication Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
要求已经向系统注册的 authenticator 提供密码。
 boolean URL.sameFile(URL other)
比较两个 URL，不包括片段部分。
protected  boolean URLStreamHandler.sameFile(URL u1, URL u2)
比较两个 url 以确定它们是否引用相同的文件（即具有相同的协议、主机、端口和路径）。
protected  void URLStreamHandler.setURL(URL u, String protocol, String host, int port, String file, String ref)
已过时。 使用 setURL(URL, String, String, int, String, String, String, String);
protected  void URLStreamHandler.setURL(URL u, String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref)
将 URL 参数的字段设置为指示的值。
protected  String URLStreamHandler.toExternalForm(URL u)
将特定协议的 URL 转换为 String。

参数类型为 URL 的 java.net 中的构造方法
HttpURLConnection(URL u)
HttpURLConnection 的构造方法。
JarURLConnection(URL url)
创建到指定 URL 的新 JarURLConnection。
URL(URL context, String spec)
通过在指定的上下文中对给定的 spec 进行解析创建 URL。
URL(URL context, String spec, URLStreamHandler handler)
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。
URLClassLoader(URL[] urls)
使用默认的委托父 ClassLoader 为指定的 URL 构造一个新 URLClassLoader。
URLClassLoader(URL[] urls, ClassLoader parent)
为给定的 URL 构造新 URLClassLoader。
URLClassLoader(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 创建新 URLClassLoader。
URLConnection(URL url)
构造一个到指定 URL 的 URL 连接。

java.rmi.server 中 URL 的使用

参数类型为 URL 的 java.rmi.server 中的方法
Class<?> | LoaderHandler.loadClass(URL codebase, String name) 已过时。 无替代版本
static Class<?> | RMIClassLoader.loadClass(URL codebase, String name) 从基本代码 URL 加载类。

java.security 中 URL 的使用

返回 URL 的 java.security 中的方法
 URL CodeSource.getLocation()
返回与此 CodeSource 关联的位置。

参数类型为 URL 的 java.security 中的构造方法
CodeSource(URL url, Certificate[] certs)
构造一个 CodeSource 并将其与指定位置和证书集合相关联。
CodeSource(URL url, CodeSigner[] signers)
构造一个 CodeSource 并将其与指定位置和代码签名者集合相关联。

java.sql 中 URL 的使用

返回 URL 的 java.sql 中的方法
URL | CallableStatement.getURL(int parameterIndex) 以 java.sql.URL 对象的形式获取指定 JDBC DATALINK 参数的值。
URL | ResultSet.getURL(int columnIndex) 以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
URL | CallableStatement.getURL(String parameterName) 以 java.net.URL 对象的形式获取 JDBC DATALINK 参数的值。
URL | ResultSet.getURL(String columnLabel) 以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
URL | SQLInput.readURL() 从流中读取 SQL DATALINK 值并将其作为 Java 编程语言中的 java.net.URL 对象返回。

参数类型为 URL 的 java.sql 中的方法
void | PreparedStatement.setURL(int parameterIndex, URL x) 将指定参数设置为给定 java.net.URL 值。
void | CallableStatement.setURL(String parameterName, URL val) 将指定参数设置为给定 java.net.URL 对象。
void | SQLOutput.writeURL(URL x) 将 SQL DATALINK 值写入流中。

javax.activation 中 URL 的使用

返回 URL 的 javax.activation 中的方法
 URL URLDataSource.getURL()
返回用于创建此 DataSource 的 URL。

参数类型为 URL 的 javax.activation 中的构造方法
DataHandler(URL url)
创建引用 URL 的 DataHandler 实例。
URLDataSource(URL url)
URLDataSource 构造方法。

javax.imageio 中 URL 的使用

参数类型为 URL 的 javax.imageio 中的方法
static BufferedImage ImageIO.read(URL input)
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 URL 的结果。

javax.management.loading 中 URL 的使用

返回 URL 的 javax.management.loading 中的方法
protected URL | MLet.check(String version, URL codebase, String jarfile, MLetContent mlet) 当扩展此服务来支持缓存和版本控制时，要重写此方法。
URL | MLetContent.getCodeBase() 获取代码基 URL。
URL | MLetContent.getDocumentBase() 获取 MLet 文本文件的基本 URL。
URL | MLetMBean.getResource(String name) 查找具有给定名称的资源。
URL[] | MLet.getURLs() 返回用于加载类和资源的 URL 搜索路径。
URL[] | MLetMBean.getURLs() 返回用于加载类和资源的 URL 搜索路径。

返回变量类型为 URL 的类型的 javax.management.loading 中的方法
 Enumeration<URL> MLetMBean.getResources(String name)
查找所有具有给定名称的资源。

参数类型为 URL 的 javax.management.loading 中的方法
void | MLet.addURL(URL url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
void | MLetMBean.addURL(URL url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
protected URL | MLet.check(String version, URL codebase, String jarfile, MLetContent mlet) 当扩展此服务来支持缓存和版本控制时，要重写此方法。
Set<Object> | MLet.getMBeansFromURL(URL url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLetMBean.getMBeansFromURL(URL url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

参数类型为 URL 的 javax.management.loading 中的构造方法
MLet(URL[] urls)
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。
MLet(URL[] urls, boolean delegateToCLR)
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent)
为给定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
为给定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。
PrivateMLet(URL[] urls, boolean delegateToCLR)
使用默认的委托父 ClassLoader 为指定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
为给定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新 PrivateMLet。

javax.net.ssl 中 URL 的使用

参数类型为 URL 的 javax.net.ssl 中的构造方法
HttpsURLConnection(URL url)
使用指定的 URL 创建 HttpsURLConnection。

javax.sound.midi 中 URL 的使用

参数类型为 URL 的 javax.sound.midi 中的方法
static MidiFileFormat | MidiSystem.getMidiFileFormat(URL url) 获得指定 URL 中数据的 MIDI 文件格式。
static Sequence | MidiSystem.getSequence(URL url) 从指定的 URL 获得 MIDI 序列。
static Soundbank | MidiSystem.getSoundbank(URL url) 通过从指定的 URL 处读取来构造一个 Soundbank。

javax.sound.midi.spi 中 URL 的使用

参数类型为 URL 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(URL url) 获得提供的 URL 的 MIDI 文件格式。
abstract Sequence | MidiFileReader.getSequence(URL url) 从提供的 URL 获得 MIDI 序列。
abstract Soundbank | SoundbankReader.getSoundbank(URL url) 从提供的 URL 获得音库对象。

javax.sound.sampled 中 URL 的使用

参数类型为 URL 的 javax.sound.sampled 中的方法
static AudioFileFormat | AudioSystem.getAudioFileFormat(URL url) 获得指定 URL 的音频文件格式。
static AudioInputStream | AudioSystem.getAudioInputStream(URL url) 从提供的 URL 获得音频输入流。

javax.sound.sampled.spi 中 URL 的使用

参数类型为 URL 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(URL url) 获得所提供 URL 的音频文件格式。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(URL url) 从所提供的 URL 获得音频输入流。

javax.sql 中 URL 的使用

参数类型为 URL 的 javax.sql 中的方法
 void RowSet.setURL(int parameterIndex, URL x)
将指定参数设置为给定的 java.net.URL 值。

javax.sql.rowset 中 URL 的使用

参数类型为 URL 的 javax.sql.rowset 中的方法
 void BaseRowSet.setURL(int parameterIndex, URL x)
将指定参数设置为给定的 java.net.URL 值。

javax.sql.rowset.serial 中 URL 的使用

返回 URL 的 javax.sql.rowset.serial 中的方法
URL | SerialDatalink.getDatalink() 返回一个新 URL，它是此 SerialDatalink 对象的副本。
URL | SQLInputImpl.readURL() 从流中读取 SQL DATALINK 值并以 Java 编程语言中 URL 对象的形式返回。

参数类型为 URL 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeURL(URL url)
将 Java 编程语言中的 java.sql.Type.DATALINK 对象写入此 SQLOutputImpl 对象。

参数类型为 URL 的 javax.sql.rowset.serial 中的构造方法
SerialDatalink(URL url)
根据给定的 java.net.URL 对象构造新的 SerialDatalink 对象。

javax.swing 中 URL 的使用

返回 URL 的 javax.swing 中的方法
 URL JEditorPane.getPage()
获得当前正在显示的 URL。

参数类型为 URL 的 javax.swing 中的方法
protected InputStream | JEditorPane.getStream(URL page) 获取给定 URL 的流，该 URL 是将要由 setPage 方法加载的。
void | JEditorPane.setPage(URL page) 设置当前要显示的 URL。

参数类型为 URL 的 javax.swing 中的构造方法
ImageIcon(URL location)
根据指定的 URL 创建一个 ImageIcon。
ImageIcon(URL location, String description)
根据指定的 URL 创建一个 ImageIcon。
JEditorPane(URL initialPage)
根据用作输入的指定 URL 创建一个 JEditorPane。

javax.swing.event 中 URL 的使用

返回 URL 的 javax.swing.event 中的方法
 URL HyperlinkEvent.getURL()
获得链接引用的 URL。

参数类型为 URL 的 javax.swing.event 中的构造方法
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u)
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。

javax.swing.plaf.synth 中 URL 的使用

参数类型为 URL 的 javax.swing.plaf.synth 中的方法
 void SynthLookAndFeel.load(URL url)
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。

javax.swing.text.html 中 URL 的使用

返回 URL 的 javax.swing.text.html 中的方法
URL | HTMLDocument.getBase() 返回解析相对 URL 所根据的位置。
URL | StyleSheet.getBase() 返回 base。
URL | ImageView.getImageURL() 返回图像源的 URL，如果不能确定图像源，则返回 null。

参数类型为 URL 的 javax.swing.text.html 中的方法
void | StyleSheet.importStyleSheet(URL url) 从 url 导入样式表。
void | StyleSheet.loadRules(Reader in, URL ref) 加载 CSS1 语法中指定的规则集合。
void | HTMLDocument.setBase(URL u) 设置解析相对 URL 所根据的位置。
void | StyleSheet.setBase(URL base) 设置 base。

参数类型为 URL 的 javax.swing.text.html 中的构造方法
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
创建一个表示 html 框架超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
创建一个表示超文本链接事件的新对象。

javax.xml.bind 中 URL 的使用

返回 URL 的 javax.xml.bind 中的方法
 URL ValidationEventLocator.getURL()
返回 URL 形式的 XML 源名称（如果可用）。

参数类型为 URL 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(URL url)
从指定的 URL 解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 URL 的使用

返回 URL 的 javax.xml.bind.helpers 中的方法
 URL ValidationEventLocatorImpl.getURL()

参数类型为 URL 的 javax.xml.bind.helpers 中的方法
void | ValidationEventLocatorImpl.setURL(URL _url) 在此事件定位符上设置 URL 字段。
Object | AbstractUnmarshallerImpl.unmarshal(URL url)

javax.xml.validation 中 URL 的使用

参数类型为 URL 的 javax.xml.validation 中的方法
 Schema SchemaFactory.newSchema(URL schema)
解析作为模式的指定 URL 并以 Schema 形式返回它。

javax.xml.ws 中 URL 的使用

返回 URL 的 javax.xml.ws 中的方法
 URL Service.getWSDLDocumentLocation()
获取此 Service 的 WSDL 文档的位置。

参数类型为 URL 的 javax.xml.ws 中的方法
static Service Service.create(URL wsdlDocumentLocation, QName serviceName)
创建 Service 实例。

参数类型为 URL 的 javax.xml.ws 中的构造方法
Service(URL wsdlDocumentLocation, QName serviceName)

javax.xml.ws.spi 中 URL 的使用

返回 URL 的 javax.xml.ws.spi 中的方法
abstract  URL ServiceDelegate.getWSDLDocumentLocation()
获取此服务的 WSDL 文档的位置。

参数类型为 URL 的 javax.xml.ws.spi 中的方法
abstract  ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class serviceClass)
创建一个服务委托对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.URLClassLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URLClassLoader
的使用

使用 URLClassLoader 的软件包
java.net | 为实现网络应用程序提供类。
javax.management.loading | 提供实现高级动态加载的类。

java.net 中 URLClassLoader 的使用

返回 URLClassLoader 的 java.net 中的方法
static URLClassLoader | URLClassLoader.newInstance(URL[] urls) 为指定的 URL 和默认的父类加载器创建新 URLClassLoader 实例。
static URLClassLoader | URLClassLoader.newInstance(URL[] urls, ClassLoader parent) 为指定的 URL 和父类加载器创建新 URLClassLoader 实例。

javax.management.loading 中 URLClassLoader 的使用

javax.management.loading 中 URLClassLoader 的子类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.URLConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URLConnection
的使用

使用 URLConnection 的软件包
java.net | 为实现网络应用程序提供类。
javax.net.ssl | 提供用于安全套接字包的类。

java.net 中 URLConnection 的使用

java.net 中 URLConnection 的子类
class | HttpURLConnection 支持 HTTP 特定功能的 URLConnection。
class | JarURLConnection 连接到 Java ARchive (JAR) 文件或 JAR 文件中条目的 URL Connection。

声明为 URLConnection 的 java.net 中的字段
protected  URLConnection JarURLConnection.jarFileURLConnection
到 JAR 文件 URL 的连接，如果已启动连接。

返回 URLConnection 的 java.net 中的方法
 URLConnection URL.openConnection()
返回一个 URLConnection 对象，它表示到 URL 所引用的远程对象的连接。
 URLConnection URL.openConnection(Proxy proxy)
与 openConnection() 类似，所不同是连接通过指定的代理建立；不支持代理方式的协议处理程序将忽略该代理参数并建立正常的连接。
protected abstract  URLConnection URLStreamHandler.openConnection(URL u)
打开一个到 URL 参数引用的对象的连接。
protected  URLConnection URLStreamHandler.openConnection(URL u, Proxy p)
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。

参数类型为 URLConnection 的 java.net 中的方法
abstract Object | ContentHandler.getContent(URLConnection urlc) 如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并根据其创建对象。
Object | ContentHandler.getContent(URLConnection urlc, Class[] classes) 如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。
abstract CacheRequest | ResponseCache.put(URI uri, URLConnection conn) 协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。

javax.net.ssl 中 URLConnection 的使用

javax.net.ssl 中 URLConnection 的子类
 class HttpsURLConnection
HttpsURLConnection 扩展 HttpURLConnection，支持各种特定于 https 功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.URLDecoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URLDecoder
的使用

没有 java.net.URLDecoder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.URLEncoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URLEncoder
的使用

没有 java.net.URLEncoder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.net.URLStreamHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URLStreamHandler
的使用

使用 URLStreamHandler 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 URLStreamHandler 的使用

返回 URLStreamHandler 的 java.net 中的方法
 URLStreamHandler URLStreamHandlerFactory.createURLStreamHandler(String protocol)
创建具有指定协议的新 URLStreamHandler 实例。

参数类型为 URLStreamHandler 的 java.net 中的构造方法
URL(String protocol, String host, int port, String file, URLStreamHandler handler)
根据指定的 protocol、host、port 号、file 和 handler 创建 URL 对象。
URL(URL context, String spec, URLStreamHandler handler)
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.net.URLStreamHandlerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.URLStreamHandlerFactory
的使用

使用 URLStreamHandlerFactory 的软件包
java.net | 为实现网络应用程序提供类。
javax.management.loading | 提供实现高级动态加载的类。

java.net 中 URLStreamHandlerFactory 的使用

参数类型为 URLStreamHandlerFactory 的 java.net 中的方法
static void URL.setURLStreamHandlerFactory(URLStreamHandlerFactory fac)
设置应用程序的 URLStreamHandlerFactory。

参数类型为 URLStreamHandlerFactory 的 java.net 中的构造方法
URLClassLoader(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 创建新 URLClassLoader。

javax.management.loading 中 URLStreamHandlerFactory 的使用

参数类型为 URLStreamHandlerFactory 的 javax.management.loading 中的构造方法
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
PrivateMLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新 PrivateMLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.nio (Java 2 Platform SE 6)

 java.nio
类
Buffer
ByteBuffer
ByteOrder
CharBuffer
DoubleBuffer
FloatBuffer
IntBuffer
LongBuffer
MappedByteBuffer
ShortBuffer
异常
BufferOverflowException
BufferUnderflowException
InvalidMarkException
ReadOnlyBufferException


java.nio.channels (Java 2 Platform SE 6)

 java.nio.channels
接口
ByteChannel
Channel
GatheringByteChannel
InterruptibleChannel
ReadableByteChannel
ScatteringByteChannel
WritableByteChannel
类
Channels
DatagramChannel
FileChannel
FileChannel.MapMode
FileLock
Pipe
Pipe.SinkChannel
Pipe.SourceChannel
SelectableChannel
SelectionKey
Selector
ServerSocketChannel
SocketChannel
异常
AlreadyConnectedException
AsynchronousCloseException
CancelledKeyException
ClosedByInterruptException
ClosedChannelException
ClosedSelectorException
ConnectionPendingException
FileLockInterruptionException
IllegalBlockingModeException
IllegalSelectorException
NoConnectionPendingException
NonReadableChannelException
NonWritableChannelException
NotYetBoundException
NotYetConnectedException
OverlappingFileLockException
UnresolvedAddressException
UnsupportedAddressTypeException


类 java.nio.channels.AlreadyConnectedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.AlreadyConnectedException
的使用

没有 java.nio.channels.AlreadyConnectedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.AsynchronousCloseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.AsynchronousCloseException
的使用

使用 AsynchronousCloseException 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 AsynchronousCloseException 的使用

java.nio.channels 中 AsynchronousCloseException 的子类
 class ClosedByInterruptException
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。

java.nio.channels.spi 中 AsynchronousCloseException 的使用

抛出 AsynchronousCloseException 的 java.nio.channels.spi 中的方法
protected  void AbstractInterruptibleChannel.end(boolean completed)
标记可能无限期阻塞的 I/O 操作的结尾。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.nio.channels.ByteChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.ByteChannel
的使用

使用 ByteChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 ByteChannel 的使用

实现 ByteChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.CancelledKeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.CancelledKeyException
的使用

没有 java.nio.channels.CancelledKeyException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.nio.channels.Channel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.Channel
的使用

使用 Channel 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.lang 中 Channel 的使用

返回 Channel 的 java.lang 中的方法
static Channel System.inheritedChannel()
返回从创建此 Java 虚拟机的实体中继承的信道。

java.nio.channels 中 Channel 的使用

java.nio.channels 中 Channel 的子接口
interface | ByteChannel 可读取和写入字节的信道。
interface | GatheringByteChannel 可从缓冲区序列写入字节的通道。
interface | InterruptibleChannel 可被异步关闭和中断的通道。
interface | ReadableByteChannel 可读取字节的通道。
interface | ScatteringByteChannel 可将字节读入缓冲区序列的通道。
interface | WritableByteChannel 可写入字节的通道。

实现 Channel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SelectableChannel 可通过 Selector 实现多路复用的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

java.nio.channels.spi 中 Channel 的使用

实现 Channel 的 java.nio.channels.spi 中的类
class | AbstractInterruptibleChannel 可中断通道的基本实现类。
class | AbstractSelectableChannel 可选择通道的基本实现类。

返回 Channel 的 java.nio.channels.spi 中的方法
 Channel SelectorProvider.inheritedChannel()
返回从创建此 Java 虚拟机的实体中继承的通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.Channels 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.Channels
的使用

没有 java.nio.channels.Channels 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.ClosedByInterruptException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.ClosedByInterruptException
的使用

没有 java.nio.channels.ClosedByInterruptException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.ClosedChannelException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.ClosedChannelException
的使用

使用 ClosedChannelException 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 ClosedChannelException 的使用

java.nio.channels 中 ClosedChannelException 的子类
class | AsynchronousCloseException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
class | ClosedByInterruptException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。

抛出 ClosedChannelException 的 java.nio.channels 中的方法
SelectionKey | SelectableChannel.register(Selector sel, int ops) 向给定的选择器注册此通道，返回一个选择键。
abstract SelectionKey | SelectableChannel.register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。

java.nio.channels.spi 中 ClosedChannelException 的使用

抛出 ClosedChannelException 的 java.nio.channels.spi 中的方法
 SelectionKey AbstractSelectableChannel.register(Selector sel, int ops, Object att)
向给定的选择器注册此通道，返回一个选择键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.ClosedSelectorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.ClosedSelectorException
的使用

没有 java.nio.channels.ClosedSelectorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.ConnectionPendingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.ConnectionPendingException
的使用

没有 java.nio.channels.ConnectionPendingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.DatagramChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.DatagramChannel
的使用

使用 DatagramChannel 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.net 中 DatagramChannel 的使用

返回 DatagramChannel 的 java.net 中的方法
 DatagramChannel DatagramSocket.getChannel()
返回与此数据报套接字关联的唯一 DatagramChannel 对象（如果有）。

java.nio.channels 中 DatagramChannel 的使用

返回 DatagramChannel 的 java.nio.channels 中的方法
abstract DatagramChannel | DatagramChannel.connect(SocketAddress remote) 连接此通道的套接字。
abstract DatagramChannel | DatagramChannel.disconnect() 断开此通道套接字的连接。
static DatagramChannel | DatagramChannel.open() 打开数据报通道。

java.nio.channels.spi 中 DatagramChannel 的使用

返回 DatagramChannel 的 java.nio.channels.spi 中的方法
abstract  DatagramChannel SelectorProvider.openDatagramChannel()
打开数据报通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.FileChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.FileChannel
的使用

使用 FileChannel 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.io 中 FileChannel 的使用

返回 FileChannel 的 java.io 中的方法
FileChannel | RandomAccessFile.getChannel() 返回与此文件关联的唯一 FileChannel 对象。
FileChannel | FileOutputStream.getChannel() 返回与此文件输出流有关的唯一 FileChannel 对象。
FileChannel | FileInputStream.getChannel() 返回与此文件输入流有关的唯一 FileChannel 对象。

java.nio.channels 中 FileChannel 的使用

返回 FileChannel 的 java.nio.channels 中的方法
FileChannel | FileLock.channel() 返回文件通道，此锁定保持在该通道的文件上。
abstract FileChannel | FileChannel.position(long newPosition) 设置此通道的文件位置。
abstract FileChannel | FileChannel.truncate(long size) 将此通道的文件截取为给定大小。

参数类型为 FileChannel 的 java.nio.channels 中的构造方法
FileLock(FileChannel channel, long position, long size, boolean shared)
初始化此类的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.FileChannel.MapMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.FileChannel.MapMode
的使用

使用 FileChannel.MapMode 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 FileChannel.MapMode 的使用

声明为 FileChannel.MapMode 的 java.nio.channels 中的字段
static FileChannel.MapMode | FileChannel.MapMode.PRIVATE 专用（写入时拷贝）映射模式。
static FileChannel.MapMode | FileChannel.MapMode.READ_ONLY 只读映射模式。
static FileChannel.MapMode | FileChannel.MapMode.READ_WRITE 读取/写入映射模式。

参数类型为 FileChannel.MapMode 的 java.nio.channels 中的方法
abstract  MappedByteBuffer FileChannel.map(FileChannel.MapMode mode, long position, long size)
将此通道的文件区域直接映射到内存中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.FileLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.FileLock
的使用

使用 FileLock 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 FileLock 的使用

返回 FileLock 的 java.nio.channels 中的方法
FileLock | FileChannel.lock() 获取对此通道的文件的独占锁定。
abstract FileLock | FileChannel.lock(long position, long size, boolean shared) 获取此通道的文件给定区域上的锁定。
FileLock | FileChannel.tryLock() 试图获取对此通道的文件的独占锁定。
abstract FileLock | FileChannel.tryLock(long position, long size, boolean shared) 试图获取对此通道的文件给定区域的锁定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.FileLockInterruptionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.FileLockInterruptionException
的使用

没有 java.nio.channels.FileLockInterruptionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.nio.channels.GatheringByteChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.GatheringByteChannel
的使用

使用 GatheringByteChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 GatheringByteChannel 的使用

实现 GatheringByteChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.IllegalBlockingModeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.IllegalBlockingModeException
的使用

没有 java.nio.channels.IllegalBlockingModeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.IllegalSelectorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.IllegalSelectorException
的使用

没有 java.nio.channels.IllegalSelectorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.nio.channels.InterruptibleChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.InterruptibleChannel
的使用

使用 InterruptibleChannel 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 InterruptibleChannel 的使用

实现 InterruptibleChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SelectableChannel 可通过 Selector 实现多路复用的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

java.nio.channels.spi 中 InterruptibleChannel 的使用

实现 InterruptibleChannel 的 java.nio.channels.spi 中的类
class | AbstractInterruptibleChannel 可中断通道的基本实现类。
class | AbstractSelectableChannel 可选择通道的基本实现类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.NoConnectionPendingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.NoConnectionPendingException
的使用

没有 java.nio.channels.NoConnectionPendingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.NonReadableChannelException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.NonReadableChannelException
的使用

没有 java.nio.channels.NonReadableChannelException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.NonWritableChannelException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.NonWritableChannelException
的使用

没有 java.nio.channels.NonWritableChannelException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.NotYetBoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.NotYetBoundException
的使用

没有 java.nio.channels.NotYetBoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.NotYetConnectedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.NotYetConnectedException
的使用

没有 java.nio.channels.NotYetConnectedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.OverlappingFileLockException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.OverlappingFileLockException
的使用

没有 java.nio.channels.OverlappingFileLockException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.Pipe 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.Pipe
的使用

使用 Pipe 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 Pipe 的使用

返回 Pipe 的 java.nio.channels 中的方法
static Pipe Pipe.open()
打开一个管道。

java.nio.channels.spi 中 Pipe 的使用

返回 Pipe 的 java.nio.channels.spi 中的方法
abstract  Pipe SelectorProvider.openPipe()
打开一个管道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.Pipe.SinkChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.Pipe.SinkChannel
的使用

使用 Pipe.SinkChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 Pipe.SinkChannel 的使用

返回 Pipe.SinkChannel 的 java.nio.channels 中的方法
abstract  Pipe.SinkChannel Pipe.sink()
返回此管道的接收器通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.Pipe.SourceChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.Pipe.SourceChannel
的使用

使用 Pipe.SourceChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 Pipe.SourceChannel 的使用

返回 Pipe.SourceChannel 的 java.nio.channels 中的方法
abstract  Pipe.SourceChannel Pipe.source()
返回此管道的源通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.nio.channels.ReadableByteChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.ReadableByteChannel
的使用

使用 ReadableByteChannel 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.nio.channels 中 ReadableByteChannel 的使用

java.nio.channels 中 ReadableByteChannel 的子接口
interface | ByteChannel 可读取和写入字节的信道。
interface | ScatteringByteChannel 可将字节读入缓冲区序列的通道。

实现 ReadableByteChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

返回 ReadableByteChannel 的 java.nio.channels 中的方法
static ReadableByteChannel Channels.newChannel(InputStream in)
构造从给定流读取字节的信道。

参数类型为 ReadableByteChannel 的 java.nio.channels 中的方法
static InputStream | Channels.newInputStream(ReadableByteChannel ch) 构造从给定信道读取字节的流。
static Reader | Channels.newReader(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap) 构造一个 reader，它用给定的解码器对取自给定信道的字节进行解码。
static Reader | Channels.newReader(ReadableByteChannel ch, String csName) 构造一个 reader，它根据命名的 charset 对取自给定信道的字节进行解码。
abstract long | FileChannel.transferFrom(ReadableByteChannel src, long position, long count) 将字节从给定的可读取字节通道传输到此通道的文件中。

java.util 中 ReadableByteChannel 的使用

参数类型为 ReadableByteChannel 的 java.util 中的构造方法
Scanner(ReadableByteChannel source)
构造一个新的 Scanner，它生成的值是从指定信道扫描的。
Scanner(ReadableByteChannel source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定信道扫描的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.nio.channels.ScatteringByteChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.ScatteringByteChannel
的使用

使用 ScatteringByteChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 ScatteringByteChannel 的使用

实现 ScatteringByteChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.SelectableChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.SelectableChannel
的使用

使用 SelectableChannel 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 SelectableChannel 的使用

java.nio.channels 中 SelectableChannel 的子类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

返回 SelectableChannel 的 java.nio.channels 中的方法
abstract SelectableChannel | SelectionKey.channel() 返回为之创建此键的通道。
abstract SelectableChannel | SelectableChannel.configureBlocking(boolean block) 调整此通道的阻塞模式。

java.nio.channels.spi 中 SelectableChannel 的使用

java.nio.channels.spi 中 SelectableChannel 的子类
 class AbstractSelectableChannel
可选择通道的基本实现类。

返回 SelectableChannel 的 java.nio.channels.spi 中的方法
 SelectableChannel AbstractSelectableChannel.configureBlocking(boolean block)
调整此通道的阻塞模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.SelectionKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.SelectionKey
的使用

使用 SelectionKey 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 SelectionKey 的使用

返回 SelectionKey 的 java.nio.channels 中的方法
abstract SelectionKey | SelectionKey.interestOps(int ops) 将此键的 interest 集合设置为给定值。
abstract SelectionKey | SelectableChannel.keyFor(Selector sel) 获取表示通道向给定选择器注册的键。
SelectionKey | SelectableChannel.register(Selector sel, int ops) 向给定的选择器注册此通道，返回一个选择键。
abstract SelectionKey | SelectableChannel.register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。

返回变量类型为 SelectionKey 的类型的 java.nio.channels 中的方法
abstract Set<SelectionKey> | Selector.keys() 返回此选择器的键集。
abstract Set<SelectionKey> | Selector.selectedKeys() 返回此选择器的已选择键集。

java.nio.channels.spi 中 SelectionKey 的使用

java.nio.channels.spi 中 SelectionKey 的子类
 class AbstractSelectionKey
选择键的基本实现类。

返回 SelectionKey 的 java.nio.channels.spi 中的方法
SelectionKey | AbstractSelectableChannel.keyFor(Selector sel)
protected abstract SelectionKey | AbstractSelector.register(AbstractSelectableChannel ch, int ops, Object att) 向此选择器注册给定的通道。
SelectionKey | AbstractSelectableChannel.register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。

返回变量类型为 SelectionKey 的类型的 java.nio.channels.spi 中的方法
protected  Set<SelectionKey> AbstractSelector.cancelledKeys()
获取此选择器的已取消键集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.Selector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.Selector
的使用

使用 Selector 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 Selector 的使用

返回 Selector 的 java.nio.channels 中的方法
static Selector | Selector.open() 打开一个选择器。
abstract Selector | SelectionKey.selector() 返回为此选择器创建的键。
abstract Selector | Selector.wakeup() 使尚未返回的第一个选择操作立即返回。

参数类型为 Selector 的 java.nio.channels 中的方法
abstract SelectionKey | SelectableChannel.keyFor(Selector sel) 获取表示通道向给定选择器注册的键。
SelectionKey | SelectableChannel.register(Selector sel, int ops) 向给定的选择器注册此通道，返回一个选择键。
abstract SelectionKey | SelectableChannel.register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。

java.nio.channels.spi 中 Selector 的使用

java.nio.channels.spi 中 Selector 的子类
 class AbstractSelector
选择器的基本实现类。

参数类型为 Selector 的 java.nio.channels.spi 中的方法
SelectionKey | AbstractSelectableChannel.keyFor(Selector sel)
SelectionKey | AbstractSelectableChannel.register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.ServerSocketChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.ServerSocketChannel
的使用

使用 ServerSocketChannel 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.net 中 ServerSocketChannel 的使用

返回 ServerSocketChannel 的 java.net 中的方法
 ServerSocketChannel ServerSocket.getChannel()
返回与此套接字关联的唯一 ServerSocketChannel 对象（如果有）。

java.nio.channels 中 ServerSocketChannel 的使用

返回 ServerSocketChannel 的 java.nio.channels 中的方法
static ServerSocketChannel ServerSocketChannel.open()
打开服务器套接字通道。

java.nio.channels.spi 中 ServerSocketChannel 的使用

返回 ServerSocketChannel 的 java.nio.channels.spi 中的方法
abstract  ServerSocketChannel SelectorProvider.openServerSocketChannel()
打开服务器套接字通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.SocketChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.SocketChannel
的使用

使用 SocketChannel 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.net 中 SocketChannel 的使用

返回 SocketChannel 的 java.net 中的方法
 SocketChannel Socket.getChannel()
返回与此数据报套接字关联的唯一 SocketChannel 对象（如果有）。

java.nio.channels 中 SocketChannel 的使用

返回 SocketChannel 的 java.nio.channels 中的方法
abstract SocketChannel | ServerSocketChannel.accept() 接受到此通道套接字的连接。
static SocketChannel | SocketChannel.open() 打开套接字通道。
static SocketChannel | SocketChannel.open(SocketAddress remote) 打开套接字通道并将其连接到远程地址。

java.nio.channels.spi 中 SocketChannel 的使用

返回 SocketChannel 的 java.nio.channels.spi 中的方法
abstract  SocketChannel SelectorProvider.openSocketChannel()
打开套接字通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.UnresolvedAddressException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.UnresolvedAddressException
的使用

没有 java.nio.channels.UnresolvedAddressException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.UnsupportedAddressTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.UnsupportedAddressTypeException
的使用

没有 java.nio.channels.UnsupportedAddressTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.nio.channels.WritableByteChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.WritableByteChannel
的使用

使用 WritableByteChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 WritableByteChannel 的使用

java.nio.channels 中 WritableByteChannel 的子接口
interface | ByteChannel 可读取和写入字节的信道。
interface | GatheringByteChannel 可从缓冲区序列写入字节的通道。

实现 WritableByteChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

返回 WritableByteChannel 的 java.nio.channels 中的方法
static WritableByteChannel Channels.newChannel(OutputStream out)
构造向给定流写入字节的信道。

参数类型为 WritableByteChannel 的 java.nio.channels 中的方法
static OutputStream | Channels.newOutputStream(WritableByteChannel ch) 构造向给定信道写入字节的流。
static Writer | Channels.newWriter(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap) 构造一个 writer，它使用给定的编码器对字符进行编码，并将所得的字节写入给定的信道。
static Writer | Channels.newWriter(WritableByteChannel ch, String csName) 构造一个 writer，它根据指定的 charset 对字符进行编码，并将所得的字节写入给定的信道。
abstract long | FileChannel.transferTo(long position, long count, WritableByteChannel target) 将字节从此通道的文件传输到给定的可写入字节通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.nio.channels.spi (Java 2 Platform SE 6)

 java.nio.channels.spi
类
AbstractInterruptibleChannel
AbstractSelectableChannel
AbstractSelectionKey
AbstractSelector
SelectorProvider


类 java.nio.channels.spi.AbstractInterruptibleChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.spi.AbstractInterruptibleChannel
的使用

使用 AbstractInterruptibleChannel 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 AbstractInterruptibleChannel 的使用

java.nio.channels 中 AbstractInterruptibleChannel 的子类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SelectableChannel 可通过 Selector 实现多路复用的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

java.nio.channels.spi 中 AbstractInterruptibleChannel 的使用

java.nio.channels.spi 中 AbstractInterruptibleChannel 的子类
 class AbstractSelectableChannel
可选择通道的基本实现类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.spi.AbstractSelectableChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.spi.AbstractSelectableChannel
的使用

使用 AbstractSelectableChannel 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 AbstractSelectableChannel 的使用

java.nio.channels 中 AbstractSelectableChannel 的子类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

java.nio.channels.spi 中 AbstractSelectableChannel 的使用

参数类型为 AbstractSelectableChannel 的 java.nio.channels.spi 中的方法
protected abstract  SelectionKey AbstractSelector.register(AbstractSelectableChannel ch, int ops, Object att)
向此选择器注册给定的通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.spi.AbstractSelectionKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.spi.AbstractSelectionKey
的使用

使用 AbstractSelectionKey 的软件包
java.nio.channels.spi 用于 java.nio.channels 包的服务提供者类。

java.nio.channels.spi 中 AbstractSelectionKey 的使用

参数类型为 AbstractSelectionKey 的 java.nio.channels.spi 中的方法
protected  void AbstractSelector.deregister(AbstractSelectionKey key)
从其通道的键集中移除给定的键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.spi.AbstractSelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.spi.AbstractSelector
的使用

使用 AbstractSelector 的软件包
java.nio.channels.spi 用于 java.nio.channels 包的服务提供者类。

java.nio.channels.spi 中 AbstractSelector 的使用

返回 AbstractSelector 的 java.nio.channels.spi 中的方法
abstract  AbstractSelector SelectorProvider.openSelector()
打开一个选择器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.channels.spi.SelectorProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.spi.SelectorProvider
的使用

使用 SelectorProvider 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 SelectorProvider 的使用

返回 SelectorProvider 的 java.nio.channels 中的方法
abstract SelectorProvider | Selector.provider() 返回创建此通道的提供者。
abstract SelectorProvider | SelectableChannel.provider() 返回创建此通道的提供者。

参数类型为 SelectorProvider 的 java.nio.channels 中的构造方法
DatagramChannel(SelectorProvider provider)
初始化此类的一个新实例。
Pipe.SinkChannel(SelectorProvider provider)
初始化此类的一个新实例。
Pipe.SourceChannel(SelectorProvider provider)
构造此类的一个新实例。
ServerSocketChannel(SelectorProvider provider)
初始化此类的一个新实例。
SocketChannel(SelectorProvider provider)
初始化此类的一个新实例。

java.nio.channels.spi 中 SelectorProvider 的使用

返回 SelectorProvider 的 java.nio.channels.spi 中的方法
SelectorProvider | AbstractSelector.provider() 返回创建此通道的提供者。
static SelectorProvider | SelectorProvider.provider() 返回此次调用 Java 虚拟机的系统级默认选择器提供者。
SelectorProvider | AbstractSelectableChannel.provider() 返回创建此通道的提供者。

参数类型为 SelectorProvider 的 java.nio.channels.spi 中的构造方法
AbstractSelectableChannel(SelectorProvider provider)
初始化此类的一个新实例。
AbstractSelector(SelectorProvider provider)
初始化此类的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.nio.charset (Java 2 Platform SE 6)

 java.nio.charset
类
Charset
CharsetDecoder
CharsetEncoder
CoderResult
CodingErrorAction
异常
CharacterCodingException
IllegalCharsetNameException
MalformedInputException
UnmappableCharacterException
UnsupportedCharsetException
错误
CoderMalfunctionError


类 java.nio.charset.CharacterCodingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CharacterCodingException
的使用

使用 CharacterCodingException 的软件包
java.nio.charset 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.nio.charset 中 CharacterCodingException 的使用

java.nio.charset 中 CharacterCodingException 的子类
class | MalformedInputException 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
class | UnmappableCharacterException 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。

抛出 CharacterCodingException 的 java.nio.charset 中的方法
CharBuffer | CharsetDecoder.decode(ByteBuffer in) 把单个输入字节缓冲区的剩余内容解码到新分配的字符缓冲区的便捷方法。
ByteBuffer | CharsetEncoder.encode(CharBuffer in) 把单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区的便捷方法。
void | CoderResult.throwException() 抛出相应于此对象描述的结果的异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.charset.Charset 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.Charset
的使用

使用 Charset 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.nio.charset.spi | java.nio.charset 包的服务提供者类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.io 中 Charset 的使用

参数类型为 Charset 的 java.io 中的构造方法
InputStreamReader(InputStream in, Charset cs)
创建使用给定字符集的 InputStreamReader。
OutputStreamWriter(OutputStream out, Charset cs)
创建使用给定字符集的 OutputStreamWriter。

java.lang 中 Charset 的使用

参数类型为 Charset 的 java.lang 中的方法
 byte[] String.getBytes(Charset charset)
使用给定的 charset 将此 String 编码到 byte 序列，并将结果存储到新的 byte 数组。

参数类型为 Charset 的 java.lang 中的构造方法
String(byte[] bytes, Charset charset)
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。
String(byte[] bytes, int offset, int length, Charset charset)
通过使用指定的 charset 解码指定的 byte 子数组，构造一个新的 String。

java.nio.charset 中 Charset 的使用

返回 Charset 的 java.nio.charset 中的方法
Charset | CharsetEncoder.charset() 返回创建此编码器的 charset。
Charset | CharsetDecoder.charset() 返回创建此解码器的 charset。
static Charset | Charset.defaultCharset() 返回此 Java 虚拟机的默认 charset。
Charset | CharsetDecoder.detectedCharset() 获取此解码器检测到的 charset（可选操作）。
static Charset | Charset.forName(String charsetName) 返回指定 charset 的 charset 对象。

返回变量类型为 Charset 的类型的 java.nio.charset 中的方法
static SortedMap<String,Charset> Charset.availableCharsets()
构造从规范 charset 名称到 charset 对象的有序映射。

参数类型为 Charset 的 java.nio.charset 中的方法
int | Charset.compareTo(Charset that) 比较此 charset 与其他 charset。
abstract boolean | Charset.contains(Charset cs) 通知此 charset 是否包含给定的 charset。

参数类型为 Charset 的 java.nio.charset 中的构造方法
CharsetDecoder(Charset cs, float averageCharsPerByte, float maxCharsPerByte)
初始化新的解码器。
CharsetEncoder(Charset cs, float averageBytesPerChar, float maxBytesPerChar)
初始化新的编码器。
CharsetEncoder(Charset cs, float averageBytesPerChar, float maxBytesPerChar, byte[] replacement)
初始化新的编码器。

java.nio.charset.spi 中 Charset 的使用

返回 Charset 的 java.nio.charset.spi 中的方法
abstract  Charset CharsetProvider.charsetForName(String charsetName)
用给定的 charset 名称获取 charset。

返回变量类型为 Charset 的类型的 java.nio.charset.spi 中的方法
abstract  Iterator<Charset> CharsetProvider.charsets()
创建在此提供者所支持的 charset 上进行迭代的迭代器。

javax.tools 中 Charset 的使用

参数类型为 Charset 的 javax.tools 中的方法
 StandardJavaFileManager JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
为此工具获取一个标准文件管理器实现的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.charset.CharsetDecoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CharsetDecoder
的使用

使用 CharsetDecoder 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.io 中 CharsetDecoder 的使用

参数类型为 CharsetDecoder 的 java.io 中的构造方法
InputStreamReader(InputStream in, CharsetDecoder dec)
创建使用给定字符集解码器的 InputStreamReader。

java.nio.channels 中 CharsetDecoder 的使用

参数类型为 CharsetDecoder 的 java.nio.channels 中的方法
static Reader Channels.newReader(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap)
构造一个 reader，它用给定的解码器对取自给定信道的字节进行解码。

java.nio.charset 中 CharsetDecoder 的使用

返回 CharsetDecoder 的 java.nio.charset 中的方法
abstract CharsetDecoder | Charset.newDecoder() 为此 charset 构造新的解码器。
CharsetDecoder | CharsetDecoder.onMalformedInput(CodingErrorAction newAction) 更改此解码器对错误输入错误的操作。
CharsetDecoder | CharsetDecoder.onUnmappableCharacter(CodingErrorAction newAction) 更改此解码器对不可映射的字符错误的操作。
CharsetDecoder | CharsetDecoder.replaceWith(String newReplacement) 更改此解码器的替换值。
CharsetDecoder | CharsetDecoder.reset() 重置此解码器，清除所有内部状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.charset.CharsetEncoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CharsetEncoder
的使用

使用 CharsetEncoder 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.io 中 CharsetEncoder 的使用

参数类型为 CharsetEncoder 的 java.io 中的构造方法
OutputStreamWriter(OutputStream out, CharsetEncoder enc)
创建使用给定字符集编码器的 OutputStreamWriter。

java.nio.channels 中 CharsetEncoder 的使用

参数类型为 CharsetEncoder 的 java.nio.channels 中的方法
static Writer Channels.newWriter(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap)
构造一个 writer，它使用给定的编码器对字符进行编码，并将所得的字节写入给定的信道。

java.nio.charset 中 CharsetEncoder 的使用

返回 CharsetEncoder 的 java.nio.charset 中的方法
abstract CharsetEncoder | Charset.newEncoder() 为此 charset 构造新的编码器。
CharsetEncoder | CharsetEncoder.onMalformedInput(CodingErrorAction newAction) 更改此编码器对错误输入错误的操作。
CharsetEncoder | CharsetEncoder.onUnmappableCharacter(CodingErrorAction newAction) 更改此编码器对不可映射的字符错误的操作。
CharsetEncoder | CharsetEncoder.replaceWith(byte[] newReplacement) 更改此编码器的替换值。
CharsetEncoder | CharsetEncoder.reset() 重置此编码器，清除所有内部状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.charset.CoderMalfunctionError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CoderMalfunctionError
的使用

没有 java.nio.charset.CoderMalfunctionError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.charset.CoderResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CoderResult
的使用

使用 CoderResult 的软件包
java.nio.charset 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.nio.charset 中 CoderResult 的使用

声明为 CoderResult 的 java.nio.charset 中的字段
static CoderResult | CoderResult.OVERFLOW 指示溢出的结果对象，意味着输出缓冲区没有足够的空间。
static CoderResult | CoderResult.UNDERFLOW 指示下溢的结果对象，意味着输入缓冲区中的输入被用完，或者如果输入缓冲区不是空的，但还需要其他的输入。

返回 CoderResult 的 java.nio.charset 中的方法
CoderResult | CharsetDecoder.decode(ByteBuffer in, CharBuffer out, boolean endOfInput) 从给定的输入缓冲区中解码尽可能多的字节，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetDecoder.decodeLoop(ByteBuffer in, CharBuffer out) 将一个或多个字节解码为一个或多个字符。
CoderResult | CharsetEncoder.encode(CharBuffer in, ByteBuffer out, boolean endOfInput) 从给定输入缓冲区中编码尽可能多的字符，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetEncoder.encodeLoop(CharBuffer in, ByteBuffer out) 将一个或多个字符编码为一个或多个字节。
CoderResult | CharsetEncoder.flush(ByteBuffer out) 刷新此编码器。
CoderResult | CharsetDecoder.flush(CharBuffer out) 刷新此解码器。
protected CoderResult | CharsetEncoder.implFlush(ByteBuffer out) 刷新此编码器。
protected CoderResult | CharsetDecoder.implFlush(CharBuffer out) 刷新此解码器。
static CoderResult | CoderResult.malformedForLength(int length) 静态工厂方法，返回描述给定长度的错误输入错误的唯一对象。
static CoderResult | CoderResult.unmappableForLength(int length) 静态工厂方法，返回描述给定长度的不可映射的字符错误的唯一对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.charset.CodingErrorAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CodingErrorAction
的使用

使用 CodingErrorAction 的软件包
java.nio.charset 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.nio.charset 中 CodingErrorAction 的使用

声明为 CodingErrorAction 的 java.nio.charset 中的字段
static CodingErrorAction | CodingErrorAction.IGNORE 指示通过删除错误输入和恢复编码操作来处理编码错误的操作。
static CodingErrorAction | CodingErrorAction.REPLACE 指示通过删除错误输入、向输出缓冲区追加 coder 的替换值和恢复编码操作来处理编码错误的操作。
static CodingErrorAction | CodingErrorAction.REPORT 指示要报告编码错误的操作，报告的方式是通过返回 CoderResult 对象或抛出 CharacterCodingException，以上两者都适合实现编码过程的方法。

返回 CodingErrorAction 的 java.nio.charset 中的方法
CodingErrorAction | CharsetEncoder.malformedInputAction() 返回此编码器对错误输入错误的当前操作。
CodingErrorAction | CharsetDecoder.malformedInputAction() 返回此解码器对错误输入错误的当前操作。
CodingErrorAction | CharsetEncoder.unmappableCharacterAction() 返回此编码器对不可映射的字符错误的当前操作。
CodingErrorAction | CharsetDecoder.unmappableCharacterAction() 返回此解码器对不可映射的字符错误的当前操作。

参数类型为 CodingErrorAction 的 java.nio.charset 中的方法
protected void | CharsetEncoder.implOnMalformedInput(CodingErrorAction newAction) 报告此编码器的错误输入操作的更改。
protected void | CharsetDecoder.implOnMalformedInput(CodingErrorAction newAction) 报告此解码器的错误输入操作的更改。
protected void | CharsetEncoder.implOnUnmappableCharacter(CodingErrorAction newAction) 报告此编码器的不可映射的字符操作的更改。
protected void | CharsetDecoder.implOnUnmappableCharacter(CodingErrorAction newAction) 报告此解码器的不可映射的字符操作的更改。
CharsetEncoder | CharsetEncoder.onMalformedInput(CodingErrorAction newAction) 更改此编码器对错误输入错误的操作。
CharsetDecoder | CharsetDecoder.onMalformedInput(CodingErrorAction newAction) 更改此解码器对错误输入错误的操作。
CharsetEncoder | CharsetEncoder.onUnmappableCharacter(CodingErrorAction newAction) 更改此编码器对不可映射的字符错误的操作。
CharsetDecoder | CharsetDecoder.onUnmappableCharacter(CodingErrorAction newAction) 更改此解码器对不可映射的字符错误的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.charset.IllegalCharsetNameException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.IllegalCharsetNameException
的使用

没有 java.nio.charset.IllegalCharsetNameException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.charset.MalformedInputException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.MalformedInputException
的使用

没有 java.nio.charset.MalformedInputException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.charset.UnmappableCharacterException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.UnmappableCharacterException
的使用

没有 java.nio.charset.UnmappableCharacterException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.charset.UnsupportedCharsetException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.UnsupportedCharsetException
的使用

没有 java.nio.charset.UnsupportedCharsetException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.nio.charset.spi (Java 2 Platform SE 6)

 java.nio.charset.spi
类
CharsetProvider


类 java.nio.charset.spi.CharsetProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.spi.CharsetProvider
的使用

没有 java.nio.charset.spi.CharsetProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.Buffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.Buffer
的使用

使用 Buffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 Buffer 的使用

java.nio 中 Buffer 的子类
class | ByteBuffer 字节缓冲区。
class | CharBuffer 字符缓冲区。
class | DoubleBuffer double 缓冲区。
class | FloatBuffer float 缓冲区。
class | IntBuffer int 缓冲区。
class | LongBuffer long 缓冲区。
class | MappedByteBuffer 直接字节缓冲区，其内容是文件的内存映射区域。
class | ShortBuffer short 缓冲区。

返回 Buffer 的 java.nio 中的方法
Buffer | Buffer.clear() 清除此缓冲区。
Buffer | Buffer.flip() 反转此缓冲区。
Buffer | Buffer.limit(int newLimit) 设置此缓冲区的限制。
Buffer | Buffer.mark() 在此缓冲区的位置设置标记。
Buffer | Buffer.position(int newPosition) 设置此缓冲区的位置。
Buffer | Buffer.reset() 将此缓冲区的位置重置为以前标记的位置。
Buffer | Buffer.rewind() 重绕此缓冲区。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.BufferOverflowException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.BufferOverflowException
的使用

没有 java.nio.BufferOverflowException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.BufferUnderflowException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.BufferUnderflowException
的使用

没有 java.nio.BufferUnderflowException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.ByteBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.ByteBuffer
的使用

使用 ByteBuffer 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.security | 为安全框架提供类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.lang 中 ByteBuffer 的使用

参数类型为 ByteBuffer 的 java.lang 中的方法
protected  Class<?> ClassLoader.defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。

java.nio 中 ByteBuffer 的使用

java.nio 中 ByteBuffer 的子类
 class MappedByteBuffer
直接字节缓冲区，其内容是文件的内存映射区域。

返回 ByteBuffer 的 java.nio 中的方法
static ByteBuffer | ByteBuffer.allocate(int capacity) 分配一个新的字节缓冲区。
static ByteBuffer | ByteBuffer.allocateDirect(int capacity) 分配新的直接字节缓冲区。
abstract ByteBuffer | ByteBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读字节缓冲区。
abstract ByteBuffer | ByteBuffer.compact() 压缩此缓冲区（可选操作）。
abstract ByteBuffer | ByteBuffer.duplicate() 创建共享此缓冲区内容的新的字节缓冲区。
ByteBuffer | ByteBuffer.get(byte[] dst) 相对批量 get 方法。
ByteBuffer | ByteBuffer.get(byte[] dst, int offset, int length) 相对批量 get 方法。
ByteBuffer | ByteBuffer.order(ByteOrder bo) 修改此缓冲区的字节顺序。
abstract ByteBuffer | ByteBuffer.put(byte b) 相对 put 方法（可选操作）。
ByteBuffer | ByteBuffer.put(byte[] src) 相对批量 put 方法（可选操作）。
ByteBuffer | ByteBuffer.put(byte[] src, int offset, int length) 相对批量 put 方法（可选操作）。
ByteBuffer | ByteBuffer.put(ByteBuffer src) 相对批量 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.put(int index, byte b) 绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putChar(char value) 用来写入 char 值的相对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putChar(int index, char value) 用于写入 char 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putDouble(double value) 用于写入 double 值的相对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putDouble(int index, double value) 用于写入 double 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putFloat(float value) 用于写入 float 值的相对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putFloat(int index, float value) 用于写入 float 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putInt(int value) 用于写入 int 值的相对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putInt(int index, int value) 用于写入 int 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putLong(int index, long value) 用于写入 long 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putLong(long value) 用于写入 long 值（可先操作） 的相对 put 方法。
abstract ByteBuffer | ByteBuffer.putShort(int index, short value) 用于写入 short 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putShort(short value) 用于写入 short 值的相对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.slice() 创建新的字节缓冲区，其内容是此缓冲区内容的共享子序列。
static ByteBuffer | ByteBuffer.wrap(byte[] array) 将 byte 数组包装到缓冲区中。
static ByteBuffer | ByteBuffer.wrap(byte[] array, int offset, int length) 将 byte 数组包装到缓冲区中。

参数类型为 ByteBuffer 的 java.nio 中的方法
int | ByteBuffer.compareTo(ByteBuffer that) 将此缓冲区与另一个缓冲区进行比较。
ByteBuffer | ByteBuffer.put(ByteBuffer src) 相对批量 put 方法（可选操作）。

java.nio.channels 中 ByteBuffer 的使用

参数类型为 ByteBuffer 的 java.nio.channels 中的方法
abstract int | DatagramChannel.read(ByteBuffer dst) 从此通道读取数据报。
abstract int | SocketChannel.read(ByteBuffer dst)
abstract int | FileChannel.read(ByteBuffer dst) 将字节序列从此通道读入给定的缓冲区。
int | ReadableByteChannel.read(ByteBuffer dst) 将字节序列从此通道中读入给定的缓冲区。
long | DatagramChannel.read(ByteBuffer[] dsts) 从此通道读取数据报。
long | SocketChannel.read(ByteBuffer[] dsts)
long | FileChannel.read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
long | ScatteringByteChannel.read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
abstract long | DatagramChannel.read(ByteBuffer[] dsts, int offset, int length) 从此通道读取数据报。
abstract long | SocketChannel.read(ByteBuffer[] dsts, int offset, int length)
abstract long | FileChannel.read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
long | ScatteringByteChannel.read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
abstract int | FileChannel.read(ByteBuffer dst, long position) 从给定的文件位置开始，从此通道读取字节序列,并写入给定的缓冲区。
abstract SocketAddress | DatagramChannel.receive(ByteBuffer dst) 通过此通道接收数据报。
abstract int | DatagramChannel.send(ByteBuffer src, SocketAddress target) 通过此通道发送数据报。
abstract int | DatagramChannel.write(ByteBuffer src) 将数据报写入此通道。
abstract int | SocketChannel.write(ByteBuffer src)
abstract int | FileChannel.write(ByteBuffer src) 将字节序列从给定的缓冲区写入此通道。
int | WritableByteChannel.write(ByteBuffer src) 将字节序列从给定的缓冲区中写入此通道。
long | DatagramChannel.write(ByteBuffer[] srcs) 将数据报写入此通道。
long | SocketChannel.write(ByteBuffer[] srcs)
long | FileChannel.write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
long | GatheringByteChannel.write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
abstract long | DatagramChannel.write(ByteBuffer[] srcs, int offset, int length) 将数据报写入此通道。
abstract long | SocketChannel.write(ByteBuffer[] srcs, int offset, int length)
abstract long | FileChannel.write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
long | GatheringByteChannel.write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
abstract int | FileChannel.write(ByteBuffer src, long position) 从给定的文件位置开始，将字节序列从给定缓冲区写入此通道。

java.nio.charset 中 ByteBuffer 的使用

返回 ByteBuffer 的 java.nio.charset 中的方法
ByteBuffer | CharsetEncoder.encode(CharBuffer in) 把单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区的便捷方法。
ByteBuffer | Charset.encode(CharBuffer cb) 将此 charset 中的 Unicode 字符编码成字节的便捷方法。
ByteBuffer | Charset.encode(String str) 将此 charset 中的字符串编码成字节的便捷方法。

参数类型为 ByteBuffer 的 java.nio.charset 中的方法
CharBuffer | CharsetDecoder.decode(ByteBuffer in) 把单个输入字节缓冲区的剩余内容解码到新分配的字符缓冲区的便捷方法。
CharBuffer | Charset.decode(ByteBuffer bb) 将此 charset 中的字节解码成 Unicode 字符的便捷方法。
CoderResult | CharsetDecoder.decode(ByteBuffer in, CharBuffer out, boolean endOfInput) 从给定的输入缓冲区中解码尽可能多的字节，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetDecoder.decodeLoop(ByteBuffer in, CharBuffer out) 将一个或多个字节解码为一个或多个字符。
CoderResult | CharsetEncoder.encode(CharBuffer in, ByteBuffer out, boolean endOfInput) 从给定输入缓冲区中编码尽可能多的字符，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetEncoder.encodeLoop(CharBuffer in, ByteBuffer out) 将一个或多个字符编码为一个或多个字节。
CoderResult | CharsetEncoder.flush(ByteBuffer out) 刷新此编码器。
protected CoderResult | CharsetEncoder.implFlush(ByteBuffer out) 刷新此编码器。

java.security 中 ByteBuffer 的使用

参数类型为 ByteBuffer 的 java.security 中的方法
protected Class<?> | SecureClassLoader.defineClass(String name, ByteBuffer b, CodeSource cs) 使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。
protected void | SignatureSpi.engineUpdate(ByteBuffer input) 使用指定的 ByteBuffer 更新要签名或验证的数据。
protected void | MessageDigestSpi.engineUpdate(ByteBuffer input) 使用指定的 ByteBuffer 更新摘要。
void | Signature.update(ByteBuffer data) 使用指定的 ByteBuffer 更新要签名或验证的数据。
void | MessageDigest.update(ByteBuffer input) 使用指定的 ByteBuffer 更新摘要。

javax.crypto 中 ByteBuffer 的使用

参数类型为 ByteBuffer 的 javax.crypto 中的方法
 int Cipher.doFinal(ByteBuffer input, ByteBuffer output)
按单部分操作加密或解密数据，或者结束一个多部分操作。
protected  int CipherSpi.engineDoFinal(ByteBuffer input, ByteBuffer output)
按单部分操作加密或解密数据，或者结束一个多部分操作。
protected  void MacSpi.engineUpdate(ByteBuffer input)
从 input.position() 开始处，处理 ByteBuffer input 中的 input.remaining() 字节。
protected  int CipherSpi.engineUpdate(ByteBuffer input, ByteBuffer output)
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
 void Mac.update(ByteBuffer input)
从 input.position() 开始，处理 ByteBuffer input 中的 input.remaining() 个字节。
 int Cipher.update(ByteBuffer input, ByteBuffer output)
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。

javax.net.ssl 中 ByteBuffer 的使用

参数类型为 ByteBuffer 的 javax.net.ssl 中的方法
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer dst) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区中。
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
abstract SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
abstract SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, ByteBuffer dst) 尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, ByteBuffer dst) 尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
abstract SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst) 尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
abstract SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst) 尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
SSLEngineResult | SSLEngine.wrap(ByteBuffer src, ByteBuffer dst) 试图把缓冲区的纯文本应用程序数据编码成 SSL/TLS 网络数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.ByteOrder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.ByteOrder
的使用

使用 ByteOrder 的软件包
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

java.nio 中 ByteOrder 的使用

声明为 ByteOrder 的 java.nio 中的字段
static ByteOrder | ByteOrder.BIG_ENDIAN 表示 big-endian 字节顺序的常量。
static ByteOrder | ByteOrder.LITTLE_ENDIAN 表示 little-endian 字节顺序的常量。

返回 ByteOrder 的 java.nio 中的方法
static ByteOrder | ByteOrder.nativeOrder() 获取底层平台的本机字节顺序。
abstract ByteOrder | DoubleBuffer.order() 获取此缓冲区的字节顺序。
abstract ByteOrder | FloatBuffer.order() 获取此缓冲区的字节顺序。
abstract ByteOrder | LongBuffer.order() 获取此缓冲区的字节顺序。
abstract ByteOrder | ShortBuffer.order() 获取此缓冲区的字节顺序。
abstract ByteOrder | IntBuffer.order() 获取此缓冲区的字节顺序。
abstract ByteOrder | CharBuffer.order() 获取此缓冲区的字节顺序。
ByteOrder | ByteBuffer.order() 获取此缓冲区的字节顺序。

参数类型为 ByteOrder 的 java.nio 中的方法
 ByteBuffer ByteBuffer.order(ByteOrder bo)
修改此缓冲区的字节顺序。

javax.imageio.stream 中 ByteOrder 的使用

声明为 ByteOrder 的 javax.imageio.stream 中的字段
protected  ByteOrder ImageInputStreamImpl.byteOrder
流的字节顺序，其为枚举类 java.nio.ByteOrder 的实例，其中 ByteOrder.BIG_ENDIAN 指示网络字节顺序，ByteOrder.LITTLE_ENDIAN 指示反向顺序。

返回 ByteOrder 的 javax.imageio.stream 中的方法
ByteOrder | ImageInputStream.getByteOrder() 以 java.nio.ByteOrder 枚举实例的形式返回从此流中读取数据值时所使用的字节顺序。
ByteOrder | ImageInputStreamImpl.getByteOrder()

参数类型为 ByteOrder 的 javax.imageio.stream 中的方法
void | ImageInputStream.setByteOrder(ByteOrder byteOrder) 设置希望以后从此流中读取数据值时使用的字节顺序。
void | ImageInputStreamImpl.setByteOrder(ByteOrder byteOrder)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.CharBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.CharBuffer
的使用

使用 CharBuffer 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.io 中 CharBuffer 的使用

参数类型为 CharBuffer 的 java.io 中的方法
 int Reader.read(CharBuffer target)
试图将字符读入指定的字符缓冲区。

java.lang 中 CharBuffer 的使用

参数类型为 CharBuffer 的 java.lang 中的方法
 int Readable.read(CharBuffer cb)
试图将字符读入指定的字符缓冲区。

java.nio 中 CharBuffer 的使用

返回 CharBuffer 的 java.nio 中的方法
static CharBuffer | CharBuffer.allocate(int capacity) 分配新的字符缓冲区。
CharBuffer | CharBuffer.append(char c) 将指定字符添加到此缓冲区（可选操作）。
CharBuffer | CharBuffer.append(CharSequence csq) 将指定的字符序列添加到此缓冲区（可选操作）。
CharBuffer | CharBuffer.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此缓冲区（可选操作）。
abstract CharBuffer | ByteBuffer.asCharBuffer() 创建此字节缓冲区的视图，作为 char 缓冲区。
abstract CharBuffer | CharBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读字符缓冲区。
abstract CharBuffer | CharBuffer.compact() 压缩此缓冲区（可选操作）。
abstract CharBuffer | CharBuffer.duplicate() 创建共享此缓冲区内容的新的字符缓冲区。
CharBuffer | CharBuffer.get(char[] dst) 相对批量 get 方法。
CharBuffer | CharBuffer.get(char[] dst, int offset, int length) 相对批量 get 方法。
abstract CharBuffer | CharBuffer.put(char c) 相对 put 方法（可选操作）。
CharBuffer | CharBuffer.put(char[] src) 相对批量 put 方法（可选操作）。
CharBuffer | CharBuffer.put(char[] src, int offset, int length) 相对批量 put 方法（可选操作）。
CharBuffer | CharBuffer.put(CharBuffer src) 相对批量 put 方法（可选操作）。
abstract CharBuffer | CharBuffer.put(int index, char c) 绝对 put 方法（可选操作）。
CharBuffer | CharBuffer.put(String src) 相对批量 put 方法（可选操作）。
CharBuffer | CharBuffer.put(String src, int start, int end) 相对批量 put 方法（可选操作）。
abstract CharBuffer | CharBuffer.slice() 创建新的字符缓冲区，其内容为此缓冲区内容的共享子序列。
static CharBuffer | CharBuffer.wrap(char[] array) 将字符数组包装到缓冲区中。
static CharBuffer | CharBuffer.wrap(char[] array, int offset, int length) 将字符数组包装到缓冲区中。
static CharBuffer | CharBuffer.wrap(CharSequence csq) 将字符序列包装到缓冲区中。
static CharBuffer | CharBuffer.wrap(CharSequence csq, int start, int end) 将字符序列包装到缓冲区中。

参数类型为 CharBuffer 的 java.nio 中的方法
int | CharBuffer.compareTo(CharBuffer that) 将此缓冲区与另一个缓冲区进行比较。
CharBuffer | CharBuffer.put(CharBuffer src) 相对批量 put 方法（可选操作）。
int | CharBuffer.read(CharBuffer target) 试图将字符读入指定的字符缓冲区。

java.nio.charset 中 CharBuffer 的使用

返回 CharBuffer 的 java.nio.charset 中的方法
CharBuffer | CharsetDecoder.decode(ByteBuffer in) 把单个输入字节缓冲区的剩余内容解码到新分配的字符缓冲区的便捷方法。
CharBuffer | Charset.decode(ByteBuffer bb) 将此 charset 中的字节解码成 Unicode 字符的便捷方法。

参数类型为 CharBuffer 的 java.nio.charset 中的方法
CoderResult | CharsetDecoder.decode(ByteBuffer in, CharBuffer out, boolean endOfInput) 从给定的输入缓冲区中解码尽可能多的字节，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetDecoder.decodeLoop(ByteBuffer in, CharBuffer out) 将一个或多个字节解码为一个或多个字符。
ByteBuffer | CharsetEncoder.encode(CharBuffer in) 把单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区的便捷方法。
ByteBuffer | Charset.encode(CharBuffer cb) 将此 charset 中的 Unicode 字符编码成字节的便捷方法。
CoderResult | CharsetEncoder.encode(CharBuffer in, ByteBuffer out, boolean endOfInput) 从给定输入缓冲区中编码尽可能多的字符，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetEncoder.encodeLoop(CharBuffer in, ByteBuffer out) 将一个或多个字符编码为一个或多个字节。
CoderResult | CharsetDecoder.flush(CharBuffer out) 刷新此解码器。
protected CoderResult | CharsetDecoder.implFlush(CharBuffer out) 刷新此解码器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.DoubleBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.DoubleBuffer
的使用

使用 DoubleBuffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 DoubleBuffer 的使用

返回 DoubleBuffer 的 java.nio 中的方法
static DoubleBuffer | DoubleBuffer.allocate(int capacity) 分配新的 double 缓冲区。
abstract DoubleBuffer | ByteBuffer.asDoubleBuffer() 创建此字节缓冲区的视图，作为 double 缓冲区。
abstract DoubleBuffer | DoubleBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 double 缓冲区。
abstract DoubleBuffer | DoubleBuffer.compact() 压缩此缓冲区（可选操作）。
abstract DoubleBuffer | DoubleBuffer.duplicate() 创建共享此缓冲区内容的新的 double 缓冲区。
DoubleBuffer | DoubleBuffer.get(double[] dst) 相对批量 get 方法。
DoubleBuffer | DoubleBuffer.get(double[] dst, int offset, int length) 相对批量 get 方法。
abstract DoubleBuffer | DoubleBuffer.put(double d) 相对 put 方法（可选操作）。
DoubleBuffer | DoubleBuffer.put(double[] src) 相对批量 put 方法（可选操作）。
DoubleBuffer | DoubleBuffer.put(double[] src, int offset, int length) 相对批量 put 方法（可选操作）。
DoubleBuffer | DoubleBuffer.put(DoubleBuffer src) 相对批量 put 方法（可选操作）。
abstract DoubleBuffer | DoubleBuffer.put(int index, double d) 绝对 put 方法（可选操作）。
abstract DoubleBuffer | DoubleBuffer.slice() 创建新的 double 缓冲区，其内容是此缓冲区内容的共享子序列。
static DoubleBuffer | DoubleBuffer.wrap(double[] array) 将 double 数组包装到缓冲区中。
static DoubleBuffer | DoubleBuffer.wrap(double[] array, int offset, int length) 将 double 数组包装到缓冲区中。

参数类型为 DoubleBuffer 的 java.nio 中的方法
int | DoubleBuffer.compareTo(DoubleBuffer that) 将此缓冲区与另一个缓冲区进行比较。
DoubleBuffer | DoubleBuffer.put(DoubleBuffer src) 相对批量 put 方法（可选操作）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.FloatBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.FloatBuffer
的使用

使用 FloatBuffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 FloatBuffer 的使用

返回 FloatBuffer 的 java.nio 中的方法
static FloatBuffer | FloatBuffer.allocate(int capacity) 分配新的 float 缓冲区。
abstract FloatBuffer | ByteBuffer.asFloatBuffer() 创建此字节缓冲区的视图，作为 float 缓冲区。
abstract FloatBuffer | FloatBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 float 缓冲区。
abstract FloatBuffer | FloatBuffer.compact() 压缩此缓冲区（可选操作）。
abstract FloatBuffer | FloatBuffer.duplicate() 创建共享此缓冲区内容的新的 float 缓冲区。
FloatBuffer | FloatBuffer.get(float[] dst) 相对批量 get 方法。
FloatBuffer | FloatBuffer.get(float[] dst, int offset, int length) 相对批量 get 方法。
abstract FloatBuffer | FloatBuffer.put(float f) 相对 put 方法（可选操作）。
FloatBuffer | FloatBuffer.put(float[] src) 相对批量 put 方法（可选操作）。
FloatBuffer | FloatBuffer.put(float[] src, int offset, int length) 相对批量 put 方法（可选操作）。
FloatBuffer | FloatBuffer.put(FloatBuffer src) 相对批量 put 方法（可选操作）。
abstract FloatBuffer | FloatBuffer.put(int index, float f) 绝对 put 方法（可选操作）。
abstract FloatBuffer | FloatBuffer.slice() 创建新的 float 缓冲区，其内容是此缓冲区内容的共享子序列。
static FloatBuffer | FloatBuffer.wrap(float[] array) 将 float 数组包装到缓冲区中。
static FloatBuffer | FloatBuffer.wrap(float[] array, int offset, int length) 将 float 数组包装到缓冲区中。

参数类型为 FloatBuffer 的 java.nio 中的方法
int | FloatBuffer.compareTo(FloatBuffer that) 将此缓冲区与另一个缓冲区进行比较。
FloatBuffer | FloatBuffer.put(FloatBuffer src) 相对批量 put 方法（可选操作）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.IntBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.IntBuffer
的使用

使用 IntBuffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 IntBuffer 的使用

返回 IntBuffer 的 java.nio 中的方法
static IntBuffer | IntBuffer.allocate(int capacity) 分配新的 int 缓冲区。
abstract IntBuffer | ByteBuffer.asIntBuffer() 创建此字节缓冲区的视图，作为 int 缓冲区。
abstract IntBuffer | IntBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 int 缓冲区。
abstract IntBuffer | IntBuffer.compact() 压缩此缓冲区（可选操作）。
abstract IntBuffer | IntBuffer.duplicate() 创建共享此缓冲区内容的新的 int 缓冲区。
IntBuffer | IntBuffer.get(int[] dst) 相对批量 get 方法。
IntBuffer | IntBuffer.get(int[] dst, int offset, int length) 相对批量 get 方法。
abstract IntBuffer | IntBuffer.put(int i) 相对 put 方法（可选操作）。
IntBuffer | IntBuffer.put(int[] src) 相对批量 put 方法（可选操作）。
IntBuffer | IntBuffer.put(int[] src, int offset, int length) 相对批量 put 方法（可选操作）。
IntBuffer | IntBuffer.put(IntBuffer src) 相对批量 put 方法（可选操作）。
abstract IntBuffer | IntBuffer.put(int index, int i) 绝对 put 方法（可选操作）。
abstract IntBuffer | IntBuffer.slice() 创建新的 int 数组，其内容是此缓冲区内容的共享子序列。
static IntBuffer | IntBuffer.wrap(int[] array) 将 int 数组包装到缓冲区中。
static IntBuffer | IntBuffer.wrap(int[] array, int offset, int length) 将 int 数组包装到缓冲区中。

参数类型为 IntBuffer 的 java.nio 中的方法
int | IntBuffer.compareTo(IntBuffer that) 将此缓冲区与另一个缓冲区进行比较。
IntBuffer | IntBuffer.put(IntBuffer src) 相对批量 put 方法（可选操作）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.InvalidMarkException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.InvalidMarkException
的使用

没有 java.nio.InvalidMarkException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.LongBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.LongBuffer
的使用

使用 LongBuffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 LongBuffer 的使用

返回 LongBuffer 的 java.nio 中的方法
static LongBuffer | LongBuffer.allocate(int capacity) 分配新的 long 缓冲区。
abstract LongBuffer | ByteBuffer.asLongBuffer() 创建此字节缓冲区的视图，作为 long 缓冲区。
abstract LongBuffer | LongBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 long 缓冲区。
abstract LongBuffer | LongBuffer.compact() 压缩此缓冲区（可选操作）。
abstract LongBuffer | LongBuffer.duplicate() 创建共享此缓冲区内容的新的 long 缓冲区。
LongBuffer | LongBuffer.get(long[] dst) 相对批量 get 方法。
LongBuffer | LongBuffer.get(long[] dst, int offset, int length) 相对批量 get 方法。
abstract LongBuffer | LongBuffer.put(int index, long l) 绝对 put 方法（可选操作）。
abstract LongBuffer | LongBuffer.put(long l) 相对 put 方法（可选操作）。
LongBuffer | LongBuffer.put(long[] src) 相对批量 put 方法（可选操作）。
LongBuffer | LongBuffer.put(long[] src, int offset, int length) 相对批量 put 方法（可选操作）。
LongBuffer | LongBuffer.put(LongBuffer src) 相对批量 put 方法（可选操作）。
abstract LongBuffer | LongBuffer.slice() 创建新的 long 缓冲区，其内容是此缓冲区内容的共享子序列。
static LongBuffer | LongBuffer.wrap(long[] array) 将 long 数组包装到缓冲区中。
static LongBuffer | LongBuffer.wrap(long[] array, int offset, int length) 将 long 数组包装到缓冲区中。

参数类型为 LongBuffer 的 java.nio 中的方法
int | LongBuffer.compareTo(LongBuffer that) 将此缓冲区与另一个缓冲区进行比较。
LongBuffer | LongBuffer.put(LongBuffer src) 相对批量 put 方法（可选操作）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.MappedByteBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.MappedByteBuffer
的使用

使用 MappedByteBuffer 的软件包
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio 中 MappedByteBuffer 的使用

返回 MappedByteBuffer 的 java.nio 中的方法
MappedByteBuffer | MappedByteBuffer.force() 将此缓冲区所做的内容更改强制写入包含映射文件的存储设备中。
MappedByteBuffer | MappedByteBuffer.load() 将此缓冲区内容加载到物理内存中。

java.nio.channels 中 MappedByteBuffer 的使用

返回 MappedByteBuffer 的 java.nio.channels 中的方法
abstract  MappedByteBuffer FileChannel.map(FileChannel.MapMode mode, long position, long size)
将此通道的文件区域直接映射到内存中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.ReadOnlyBufferException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.ReadOnlyBufferException
的使用

没有 java.nio.ReadOnlyBufferException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.nio.ShortBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.ShortBuffer
的使用

使用 ShortBuffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 ShortBuffer 的使用

返回 ShortBuffer 的 java.nio 中的方法
static ShortBuffer | ShortBuffer.allocate(int capacity) 分配新的 short 缓冲区。
abstract ShortBuffer | ShortBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 short 缓冲区。
abstract ShortBuffer | ByteBuffer.asShortBuffer() 创建此字节缓冲区的视图，作为 short 缓冲区。
abstract ShortBuffer | ShortBuffer.compact() 压缩此缓冲区（可选操作）。
abstract ShortBuffer | ShortBuffer.duplicate() 创建共享此缓冲区内容的新的 short 缓冲区。
ShortBuffer | ShortBuffer.get(short[] dst) 相对批量 get 方法。
ShortBuffer | ShortBuffer.get(short[] dst, int offset, int length) 相对批量 get 方法。
abstract ShortBuffer | ShortBuffer.put(int index, short s) 绝对 put 方法（可选操作）。
abstract ShortBuffer | ShortBuffer.put(short s) 相对 put 方法（可选操作）。
ShortBuffer | ShortBuffer.put(short[] src) 相对批量 put 方法（可选操作）。
ShortBuffer | ShortBuffer.put(short[] src, int offset, int length) 相对批量 put 方法（可选操作）。
ShortBuffer | ShortBuffer.put(ShortBuffer src) 相对批量 put 方法（可选操作）。
abstract ShortBuffer | ShortBuffer.slice() 创建新的 short 缓冲区，其内容是此缓冲区内容的共享子序列。
static ShortBuffer | ShortBuffer.wrap(short[] array) 将 short 数组包装到缓冲区中。
static ShortBuffer | ShortBuffer.wrap(short[] array, int offset, int length) 将 short 数组包装到缓冲区中。

参数类型为 ShortBuffer 的 java.nio 中的方法
int | ShortBuffer.compareTo(ShortBuffer that) 将此缓冲区与另一个缓冲区进行比较。
ShortBuffer | ShortBuffer.put(ShortBuffer src) 相对批量 put 方法（可选操作）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.rmi (Java 2 Platform SE 6)

 java.rmi
接口
Remote
类
MarshalledObject
Naming
RMISecurityManager
异常
AccessException
AlreadyBoundException
ConnectException
ConnectIOException
MarshalException
NoSuchObjectException
NotBoundException
RemoteException
RMISecurityException
ServerError
ServerException
ServerRuntimeException
StubNotFoundException
UnexpectedException
UnknownHostException
UnmarshalException


java.rmi.activation (Java 2 Platform SE 6)

 java.rmi.activation
接口
ActivationInstantiator
ActivationMonitor
ActivationSystem
Activator
类
Activatable
ActivationDesc
ActivationGroup
ActivationGroup_Stub
ActivationGroupDesc
ActivationGroupDesc.CommandEnvironment
ActivationGroupID
ActivationID
异常
ActivateFailedException
ActivationException
UnknownGroupException
UnknownObjectException


类 java.rmi.activation.Activatable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.Activatable
的使用

没有 java.rmi.activation.Activatable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.ActivateFailedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivateFailedException
的使用

没有 java.rmi.activation.ActivateFailedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.ActivationDesc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationDesc
的使用

使用 ActivationDesc 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationDesc 的使用

返回 ActivationDesc 的 java.rmi.activation 中的方法
ActivationDesc | ActivationSystem.getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。

参数类型为 ActivationDesc 的 java.rmi.activation 中的方法
MarshalledObject | ActivationGroup_Stub.newInstance(ActivationID id, ActivationDesc desc) ActivationGroup.newInstance 的 stub 方法。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。
static Remote | Activatable.register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
ActivationID | ActivationSystem.registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.ActivationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationException
的使用

使用 ActivationException 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationException 的使用

java.rmi.activation 中 ActivationException 的子类
class | UnknownGroupException 当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
class | UnknownObjectException 当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

抛出 ActivationException 的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
Remote | ActivationID.activate(boolean force) 激活此 id 的对象。
ActivationMonitor | ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation) 通过回调来通知激活系统该组现在是活动的。
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
abstract void | ActivationGroup.activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
static ActivationGroup | ActivationGroup.createGroup(ActivationGroupID id, ActivationGroupDesc desc, long incarnation) 为当前 VM 创建并设置激活组。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
ActivationDesc | ActivationSystem.getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
ActivationGroupDesc | ActivationSystem.getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
static ActivationSystem | ActivationGroup.getSystem() 返回该 VM 的激活系统。
static boolean | Activatable.inactive(ActivationID id) 通知系统具有相应激活 id 的对象目前没有处于活动状态的。
boolean | ActivationGroup.inactiveObject(ActivationID id) 通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
MarshalledObject | ActivationGroup_Stub.newInstance(ActivationID id, ActivationDesc desc) ActivationGroup.newInstance 的 stub 方法。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。
static Remote | Activatable.register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
ActivationGroupID | ActivationSystem.registerGroup(ActivationGroupDesc desc) 注册激活组。
ActivationID | ActivationSystem.registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。
static void | ActivationGroup.setSystem(ActivationSystem system) 设置该 VM 的激活系统。
static void | Activatable.unregister(ActivationID id) 为与 id 关联的激活描述符撤消前面的注册。
void | ActivationSystem.unregisterGroup(ActivationGroupID id) 移除激活组。
void | ActivationSystem.unregisterObject(ActivationID id) 移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。

抛出 ActivationException 的 java.rmi.activation 中的构造方法
Activatable(String location, MarshalledObject<?> data, boolean restart, int port)
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
ActivationDesc(String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.ActivationGroup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationGroup
的使用

使用 ActivationGroup 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationGroup 的使用

返回 ActivationGroup 的 java.rmi.activation 中的方法
static ActivationGroup ActivationGroup.createGroup(ActivationGroupID id, ActivationGroupDesc desc, long incarnation)
为当前 VM 创建并设置激活组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.ActivationGroup_Stub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationGroup_Stub
的使用

没有 java.rmi.activation.ActivationGroup_Stub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.ActivationGroupDesc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationGroupDesc
的使用

使用 ActivationGroupDesc 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationGroupDesc 的使用

返回 ActivationGroupDesc 的 java.rmi.activation 中的方法
ActivationGroupDesc | ActivationSystem.getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。

参数类型为 ActivationGroupDesc 的 java.rmi.activation 中的方法
static ActivationGroup | ActivationGroup.createGroup(ActivationGroupID id, ActivationGroupDesc desc, long incarnation) 为当前 VM 创建并设置激活组。
ActivationGroupID | ActivationSystem.registerGroup(ActivationGroupDesc desc) 注册激活组。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment
的使用

使用 ActivationGroupDesc.CommandEnvironment 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationGroupDesc.CommandEnvironment 的使用

返回 ActivationGroupDesc.CommandEnvironment 的 java.rmi.activation 中的方法
 ActivationGroupDesc.CommandEnvironment ActivationGroupDesc.getCommandEnvironment()
返回组的命令环境控制对象。

参数类型为 ActivationGroupDesc.CommandEnvironment 的 java.rmi.activation 中的构造方法
ActivationGroupDesc(Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
使用组实现的系统默认值和代码基来构造一个组描述符。
ActivationGroupDesc(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
指定一个用于该组的替代组实现和执行环境。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.ActivationGroupID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationGroupID
的使用

使用 ActivationGroupID 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationGroupID 的使用

返回 ActivationGroupID 的 java.rmi.activation 中的方法
static ActivationGroupID | ActivationGroup.currentGroupID() 返回当前激活组的标识符。
ActivationGroupID | ActivationDesc.getGroupID() 返回由此描述符指定的对象的组标识符。
ActivationGroupID | ActivationSystem.registerGroup(ActivationGroupDesc desc) 注册激活组。

参数类型为 ActivationGroupID 的 java.rmi.activation 中的方法
ActivationMonitor | ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation) 通过回调来通知激活系统该组现在是活动的。
static ActivationGroup | ActivationGroup.createGroup(ActivationGroupID id, ActivationGroupDesc desc, long incarnation) 为当前 VM 创建并设置激活组。
ActivationGroupDesc | ActivationSystem.getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
void | ActivationMonitor.inactiveGroup(ActivationGroupID id, long incarnation) 通知该组现在是不活动的。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。
void | ActivationSystem.unregisterGroup(ActivationGroupID id) 移除激活组。

参数类型为 ActivationGroupID 的 java.rmi.activation 中的构造方法
ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码的 location 处加载，并且其初始化信息为 data。
ActivationGroup(ActivationGroupID groupID)
用给定的激活组标识符创建一个激活组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.ActivationID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationID
的使用

使用 ActivationID 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationID 的使用

返回 ActivationID 的 java.rmi.activation 中的方法
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
protected ActivationID | Activatable.getID() 返回对象的激活标识符。
ActivationID | ActivationSystem.registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。

参数类型为 ActivationID 的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
void | ActivationMonitor.activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。
abstract void | ActivationGroup.activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
ActivationDesc | ActivationSystem.getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
static boolean | Activatable.inactive(ActivationID id) 通知系统具有相应激活 id 的对象目前没有处于活动状态的。
boolean | ActivationGroup.inactiveObject(ActivationID id) 通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
void | ActivationMonitor.inactiveObject(ActivationID id) 当组中的一个对象成为不活动（取消激活）时，一个激活组调用其监视器的 inactiveObject 方法。
MarshalledObject | ActivationGroup_Stub.newInstance(ActivationID id, ActivationDesc desc) ActivationGroup.newInstance 的 stub 方法。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
static void | Activatable.unregister(ActivationID id) 为与 id 关联的激活描述符撤消前面的注册。
void | ActivationSystem.unregisterObject(ActivationID id) 移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。

参数类型为 ActivationID 的 java.rmi.activation 中的构造方法
Activatable(ActivationID id, int port)
构造方法用于在指定端口上激活/导出对象。
Activatable(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造方法用于在指定端口上激活/导出对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.activation.ActivationInstantiator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.activation.ActivationInstantiator
的使用

使用 ActivationInstantiator 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationInstantiator 的使用

实现 ActivationInstantiator 的 java.rmi.activation 中的类
class | ActivationGroup ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
class | ActivationGroup_Stub ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

参数类型为 ActivationInstantiator 的 java.rmi.activation 中的方法
 ActivationMonitor ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation)
通过回调来通知激活系统该组现在是活动的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.activation.ActivationMonitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.activation.ActivationMonitor
的使用

使用 ActivationMonitor 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationMonitor 的使用

返回 ActivationMonitor 的 java.rmi.activation 中的方法
 ActivationMonitor ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation)
通过回调来通知激活系统该组现在是活动的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.activation.ActivationSystem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.activation.ActivationSystem
的使用

使用 ActivationSystem 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationSystem 的使用

返回 ActivationSystem 的 java.rmi.activation 中的方法
static ActivationSystem | ActivationGroup.getSystem() 返回该 VM 的激活系统。
ActivationSystem | ActivationGroupID.getSystem() 返回组的激活系统。

参数类型为 ActivationSystem 的 java.rmi.activation 中的方法
static void ActivationGroup.setSystem(ActivationSystem system)
设置该 VM 的激活系统。

参数类型为 ActivationSystem 的 java.rmi.activation 中的构造方法
ActivationGroupID(ActivationSystem system)
构造一个唯一的组 id。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.activation.Activator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.activation.Activator
的使用

使用 Activator 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 Activator 的使用

参数类型为 Activator 的 java.rmi.activation 中的构造方法
ActivationID(Activator activator)
ActivationID 的构造方法带有单个参数 activator，这指定了一个对激活器（负责激活与此标识符相关联的对象）的远程引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.UnknownGroupException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.UnknownGroupException
的使用

使用 UnknownGroupException 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 UnknownGroupException 的使用

抛出 UnknownGroupException 的 java.rmi.activation 中的方法
ActivationMonitor | ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation) 通过回调来通知激活系统该组现在是活动的。
ActivationGroupDesc | ActivationSystem.getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
protected void | ActivationGroup.inactiveGroup() 如果子类要进行对组监视器的 inactiveGroup 回调，则此 protected 方法是必要的。
void | ActivationMonitor.inactiveGroup(ActivationGroupID id, long incarnation) 通知该组现在是不活动的。
static Remote | Activatable.register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
ActivationID | ActivationSystem.registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。
void | ActivationSystem.unregisterGroup(ActivationGroupID id) 移除激活组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.activation.UnknownObjectException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.UnknownObjectException
的使用

使用 UnknownObjectException 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 UnknownObjectException 的使用

抛出 UnknownObjectException 的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
Remote | ActivationID.activate(boolean force) 激活此 id 的对象。
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
void | ActivationMonitor.activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。
abstract void | ActivationGroup.activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
ActivationDesc | ActivationSystem.getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
static boolean | Activatable.inactive(ActivationID id) 通知系统具有相应激活 id 的对象目前没有处于活动状态的。
boolean | ActivationGroup.inactiveObject(ActivationID id) 通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
void | ActivationMonitor.inactiveObject(ActivationID id) 当组中的一个对象成为不活动（取消激活）时，一个激活组调用其监视器的 inactiveObject 方法。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
static void | Activatable.unregister(ActivationID id) 为与 id 关联的激活描述符撤消前面的注册。
void | ActivationSystem.unregisterObject(ActivationID id) 移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.AccessException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.AccessException
的使用

使用 AccessException 的软件包
java.rmi.registry 提供 RMI 注册表的一个类和两个接口。

java.rmi.registry 中 AccessException 的使用

抛出 AccessException 的 java.rmi.registry 中的方法
void | Registry.bind(String name, Remote obj) 绑定对此注册表中指定 name 的远程引用。
String[] | Registry.list() 返回在此注册表中绑定的名称的数组。
Remote | Registry.lookup(String name) 返回注册表中绑定到指定 name 的远程引用。
void | Registry.rebind(String name, Remote obj) 用提供的远程引用替换此注册表中指定的 name 绑定。
void | Registry.unbind(String name) 移除此注册表中指定的 name 绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.AlreadyBoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.AlreadyBoundException
的使用

使用 AlreadyBoundException 的软件包
java.rmi | 提供 RMI 包。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。

java.rmi 中 AlreadyBoundException 的使用

抛出 AlreadyBoundException 的 java.rmi 中的方法
static void Naming.bind(String name, Remote obj)
将指定 name 绑定到远程对象。

java.rmi.registry 中 AlreadyBoundException 的使用

抛出 AlreadyBoundException 的 java.rmi.registry 中的方法
 void Registry.bind(String name, Remote obj)
绑定对此注册表中指定 name 的远程引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.ConnectException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.ConnectException
的使用

没有 java.rmi.ConnectException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.ConnectIOException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.ConnectIOException
的使用

没有 java.rmi.ConnectIOException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.MarshalException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.MarshalException
的使用

没有 java.rmi.MarshalException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.MarshalledObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.MarshalledObject
的使用

使用 MarshalledObject 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

java.rmi.activation 中 MarshalledObject 的使用

返回 MarshalledObject 的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
MarshalledObject<?> | ActivationDesc.getData() 为此描述符指定的对象返回包含初始化/激活数据的“编组对象”。
MarshalledObject<?> | ActivationGroupDesc.getData() 返回组的初始化数据。
MarshalledObject | ActivationGroup_Stub.newInstance(ActivationID id, ActivationDesc desc) ActivationGroup.newInstance 的 stub 方法。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。

参数类型为 MarshalledObject 的 java.rmi.activation 中的方法
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
void | ActivationMonitor.activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

参数类型为 MarshalledObject 的 java.rmi.activation 中的构造方法
Activatable(String location, MarshalledObject<?> data, boolean restart, int port)
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码的 location 处加载，并且其初始化信息为 data。
ActivationDesc(String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationGroupDesc(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
指定一个用于该组的替代组实现和执行环境。

javax.management.remote.rmi 中 MarshalledObject 的使用

参数类型为 MarshalledObject 的 javax.management.remote.rmi 中的方法
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.Naming 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.Naming
的使用

没有 java.rmi.Naming 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.NoSuchObjectException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.NoSuchObjectException
的使用

使用 NoSuchObjectException 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。

java.rmi.activation 中 NoSuchObjectException 的使用

抛出 NoSuchObjectException 的 java.rmi.activation 中的方法
static boolean Activatable.unexportObject(Remote obj, boolean force)
从 RMI 运行库中移除远程对象 obj。

java.rmi.server 中 NoSuchObjectException 的使用

抛出 NoSuchObjectException 的 java.rmi.server 中的方法
static Remote | RemoteObject.toStub(Remote obj) 返回作为参数传递的远程对象 obj 的 stub。
static boolean | UnicastRemoteObject.unexportObject(Remote obj, boolean force) 从 RMI 运行时移除远程对象 obj。

javax.rmi 中 NoSuchObjectException 的使用

抛出 NoSuchObjectException 的 javax.rmi 中的方法
static Remote | PortableRemoteObject.toStub(Remote obj) 返回给定服务器对象的 stub。
static void | PortableRemoteObject.unexportObject(Remote obj) 从运行时注销服务器对象，允许对象用于垃圾回收。

javax.rmi.CORBA 中 NoSuchObjectException 的使用

抛出 NoSuchObjectException 的 javax.rmi.CORBA 中的方法
 void Tie.deactivate()
取消激活此 tie 表示的目标对象。
 Remote PortableRemoteObjectDelegate.toStub(Remote obj)
PortableRemoteObject.toStub(java.rmi.Remote) 的委托调用。
 void PortableRemoteObjectDelegate.unexportObject(Remote obj)
PortableRemoteObject.unexportObject(java.rmi.Remote) 的委托调用。
static void Util.unexportObject(Remote target)
从内部表中移除关联的 tie，并调用 Tie.deactivate() 以取消激活该对象。
 void UtilDelegate.unexportObject(Remote target)
Util.unexportObject(java.rmi.Remote) 的委托调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.NotBoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.NotBoundException
的使用

使用 NotBoundException 的软件包
java.rmi | 提供 RMI 包。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。

java.rmi 中 NotBoundException 的使用

抛出 NotBoundException 的 java.rmi 中的方法
static Remote | Naming.lookup(String name) 返回与指定 name 关联的远程对象的引用（一个 stub）。
static void | Naming.unbind(String name) 销毁与远程对象关联的指定名称的绑定。

java.rmi.registry 中 NotBoundException 的使用

抛出 NotBoundException 的 java.rmi.registry 中的方法
Remote | Registry.lookup(String name) 返回注册表中绑定到指定 name 的远程引用。
void | Registry.unbind(String name) 移除此注册表中指定的 name 绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.Remote 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.Remote
的使用

使用 Remote 的软件包
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

java.rmi 中 Remote 的使用

返回 Remote 的 java.rmi 中的方法
static Remote Naming.lookup(String name)
返回与指定 name 关联的远程对象的引用（一个 stub）。

参数类型为 Remote 的 java.rmi 中的方法
static void | Naming.bind(String name, Remote obj) 将指定 name 绑定到远程对象。
static void | Naming.rebind(String name, Remote obj) 将指定名称重新绑定到一个新的远程对象。

java.rmi.activation 中 Remote 的使用

java.rmi.activation 中 Remote 的子接口
interface | ActivationInstantiator ActivationInstantiator 负责创建“可激活”对象的实例。
interface | ActivationMonitor 一个 ActivationMonitor 特定于一个 ActivationGroup，当一个组通过对 ActivationSystem.activeGroup 的调用（这是内部完成的）被报告为活动时，获得一个 ActivationMonitor。
interface | ActivationSystem ActivationSystem 为注册组和在那些组中要被激活的“可激活”对象提供一种方式。
interface | Activator Activator 方便了远程对象激活。

实现 Remote 的 java.rmi.activation 中的类
class | Activatable Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
class | ActivationGroup ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
class | ActivationGroup_Stub ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

返回 Remote 的 java.rmi.activation 中的方法
Remote | ActivationID.activate(boolean force) 激活此 id 的对象。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | Activatable.register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。

返回变量类型为 Remote 的类型的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。

参数类型为 Remote 的 java.rmi.activation 中的方法
abstract void | ActivationGroup.activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
static boolean | Activatable.unexportObject(Remote obj, boolean force) 从 RMI 运行库中移除远程对象 obj。

类型变量类型为 Remote 的 java.rmi.activation 中的方法参数
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
void | ActivationMonitor.activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。

java.rmi.dgc 中 Remote 的使用

java.rmi.dgc 中 Remote 的子接口
 interface DGC
DGC 抽象用于分布式垃圾回收算法的服务器端。

java.rmi.registry 中 Remote 的使用

java.rmi.registry 中 Remote 的子接口
 interface Registry
Registry 是简单远程对象注册表的一个远程接口，它提供存储和获取绑定了任意字符串名称的远程对象引用的方法。

返回 Remote 的 java.rmi.registry 中的方法
 Remote Registry.lookup(String name)
返回注册表中绑定到指定 name 的远程引用。

参数类型为 Remote 的 java.rmi.registry 中的方法
void | Registry.bind(String name, Remote obj) 绑定对此注册表中指定 name 的远程引用。
void | Registry.rebind(String name, Remote obj) 用提供的远程引用替换此注册表中指定的 name 绑定。

java.rmi.server 中 Remote 的使用

实现 Remote 的 java.rmi.server 中的类
class | RemoteObject 该 RemoteObject 类实现远程对象的 java.lang.Object 行为。
class | RemoteObjectInvocationHandler 与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。
class | RemoteServer 该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
class | RemoteStub 该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
class | UnicastRemoteObject 用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

返回 Remote 的 java.rmi.server 中的方法
static Remote | UnicastRemoteObject.exportObject(Remote obj, int port) 使用提供的特定端口导出远程对象，以便能够接收传入的调用。
static Remote | UnicastRemoteObject.exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。
static Remote | RemoteObject.toStub(Remote obj) 返回作为参数传递的远程对象 obj 的 stub。

参数类型为 Remote 的 java.rmi.server 中的方法
void | Skeleton.dispatch(Remote obj, RemoteCall theCall, int opnum, long hash) 已过时。 无替代版本
static RemoteStub | UnicastRemoteObject.exportObject(Remote obj) 使用匿名端口导出远程对象，以便能够接收传入的调用。
static Remote | UnicastRemoteObject.exportObject(Remote obj, int port) 使用提供的特定端口导出远程对象，以便能够接收传入的调用。
static Remote | UnicastRemoteObject.exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。
RemoteStub | ServerRef.exportObject(Remote obj, Object data) 为提供的 Remote 对象创建客户机 stub 对象。
Object | RemoteRef.invoke(Remote obj, Method method, Object[] params, long opnum) 调用某个方法。
static Remote | RemoteObject.toStub(Remote obj) 返回作为参数传递的远程对象 obj 的 stub。
static boolean | UnicastRemoteObject.unexportObject(Remote obj, boolean force) 从 RMI 运行时移除远程对象 obj。

javax.management.remote.rmi 中 Remote 的使用

javax.management.remote.rmi 中 Remote 的子接口
interface | RMIConnection RMI 对象，用于将 MBeanServer 请求从客户端转发到其位于服务器端的 MBeanServer 实现。
interface | RMIServer 用于建立到 RMI 连接器的连接的 RMI 对象。

实现 Remote 的 javax.management.remote.rmi 中的类
class | RMIConnectionImpl RMIConnection 接口的实现。
class | RMIConnectionImpl_Stub
class | RMIIIOPServerImpl 一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
class | RMIJRMPServerImpl 一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。
class | RMIServerImpl 表示连接器服务器的 RMI 对象。
class | RMIServerImpl_Stub

返回 Remote 的 javax.management.remote.rmi 中的方法
Remote | RMIIIOPServerImpl.toStub() 返回一个 IIOP stub。
Remote | RMIJRMPServerImpl.toStub() 返回此 RMIServer 对象的可序列化的 stub。
abstract Remote | RMIServerImpl.toStub() 返回此服务器对象的可远程化的 stub。

javax.rmi 中 Remote 的使用

返回 Remote 的 javax.rmi 中的方法
static Remote PortableRemoteObject.toStub(Remote obj)
返回给定服务器对象的 stub。

参数类型为 Remote 的 javax.rmi 中的方法
static void | PortableRemoteObject.connect(Remote target, Remote source) 使 Remote 对象准备好进行远程通信。
static void | PortableRemoteObject.exportObject(Remote obj) 准备服务器对象，以接收远程调用。
static Remote | PortableRemoteObject.toStub(Remote obj) 返回给定服务器对象的 stub。
static void | PortableRemoteObject.unexportObject(Remote obj) 从运行时注销服务器对象，允许对象用于垃圾回收。

javax.rmi.CORBA 中 Remote 的使用

返回 Remote 的 javax.rmi.CORBA 中的方法
 Remote Tie.getTarget()
返回此 tie 的目标。
 Remote PortableRemoteObjectDelegate.toStub(Remote obj)
PortableRemoteObject.toStub(java.rmi.Remote) 的委托调用。

参数类型为 Remote 的 javax.rmi.CORBA 中的方法
 void PortableRemoteObjectDelegate.connect(Remote target, Remote source)
PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 的委托调用。
 void PortableRemoteObjectDelegate.exportObject(Remote obj)
PortableRemoteObject.exportObject(java.rmi.Remote) 的委托调用。
static Tie Util.getTie(Remote target)
返回给定目标对象的 tie（如果存在）。
 Tie UtilDelegate.getTie(Remote target)
Util.getTie(java.rmi.Remote) 的委托调用。
static void Util.registerTarget(Tie tie, Remote target)
为 tie 注册一个目标。
 void UtilDelegate.registerTarget(Tie tie, Remote target)
Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 的委托调用。
 void Tie.setTarget(Remote target)
由 Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 调用以设置此 tie 的目标。
 Remote PortableRemoteObjectDelegate.toStub(Remote obj)
PortableRemoteObject.toStub(java.rmi.Remote) 的委托调用。
 void PortableRemoteObjectDelegate.unexportObject(Remote obj)
PortableRemoteObject.unexportObject(java.rmi.Remote) 的委托调用。
static void Util.unexportObject(Remote target)
从内部表中移除关联的 tie，并调用 Tie.deactivate() 以取消激活该对象。
 void UtilDelegate.unexportObject(Remote target)
Util.unexportObject(java.rmi.Remote) 的委托调用。

org.omg.stub.java.rmi 中 Remote 的使用

实现 Remote 的 org.omg.stub.java.rmi 中的类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.RemoteException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.RemoteException
的使用

使用 RemoteException 的软件包
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。

java.rmi 中 RemoteException 的使用

java.rmi 中 RemoteException 的子类
class | AccessException AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
class | ConnectException 如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
class | ConnectIOException 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
class | MarshalException 如果在编组远程调用标题、参数或远程方法调用的返回值时发生 java.io.IOException，则抛出 MarshalException。
class | NoSuchObjectException 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
class | ServerError 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
class | ServerException 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
class | ServerRuntimeException 已过时。 无替换版本
class | StubNotFoundException 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
class | UnexpectedException 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
class | UnknownHostException 如果在创建到远程主机的连接以便进行远程方法调用时发生 java.net.UnknownHostException，则抛出 UnknownHostException。
class | UnmarshalException 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

抛出 RemoteException 的 java.rmi 中的方法
static void | Naming.bind(String name, Remote obj) 将指定 name 绑定到远程对象。
static String[] | Naming.list(String name) 返回在注册表中绑定的名称所组成的数组。
static Remote | Naming.lookup(String name) 返回与指定 name 关联的远程对象的引用（一个 stub）。
static void | Naming.rebind(String name, Remote obj) 将指定名称重新绑定到一个新的远程对象。
static void | Naming.unbind(String name) 销毁与远程对象关联的指定名称的绑定。

java.rmi.activation 中 RemoteException 的使用

java.rmi.activation 中 RemoteException 的子类
 class ActivateFailedException
在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。

抛出 RemoteException 的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
Remote | ActivationID.activate(boolean force) 激活此 id 的对象。
ActivationMonitor | ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation) 通过回调来通知激活系统该组现在是活动的。
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
void | ActivationMonitor.activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。
abstract void | ActivationGroup.activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
ActivationDesc | ActivationSystem.getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
ActivationGroupDesc | ActivationSystem.getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
static boolean | Activatable.inactive(ActivationID id) 通知系统具有相应激活 id 的对象目前没有处于活动状态的。
protected void | ActivationGroup.inactiveGroup() 如果子类要进行对组监视器的 inactiveGroup 回调，则此 protected 方法是必要的。
void | ActivationMonitor.inactiveGroup(ActivationGroupID id, long incarnation) 通知该组现在是不活动的。
boolean | ActivationGroup.inactiveObject(ActivationID id) 通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
void | ActivationMonitor.inactiveObject(ActivationID id) 当组中的一个对象成为不活动（取消激活）时，一个激活组调用其监视器的 inactiveObject 方法。
MarshalledObject | ActivationGroup_Stub.newInstance(ActivationID id, ActivationDesc desc) ActivationGroup.newInstance 的 stub 方法。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。
static Remote | Activatable.register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
ActivationGroupID | ActivationSystem.registerGroup(ActivationGroupDesc desc) 注册激活组。
ActivationID | ActivationSystem.registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。
void | ActivationSystem.shutdown() 关闭此激活系统。
static void | Activatable.unregister(ActivationID id) 为与 id 关联的激活描述符撤消前面的注册。
void | ActivationSystem.unregisterGroup(ActivationGroupID id) 移除激活组。
void | ActivationSystem.unregisterObject(ActivationID id) 移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。

抛出 RemoteException 的 java.rmi.activation 中的构造方法
Activatable(ActivationID id, int port)
构造方法用于在指定端口上激活/导出对象。
Activatable(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造方法用于在指定端口上激活/导出对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port)
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
ActivationGroup(ActivationGroupID groupID)
用给定的激活组标识符创建一个激活组。

java.rmi.dgc 中 RemoteException 的使用

抛出 RemoteException 的 java.rmi.dgc 中的方法
void | DGC.clean(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong) 洁调用从 'ids' 指示的每个远程对象的引用列表中移除 'vmid'。
Lease | DGC.dirty(ObjID[] ids, long sequenceNum, Lease lease) 脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。

java.rmi.registry 中 RemoteException 的使用

抛出 RemoteException 的 java.rmi.registry 中的方法
void | Registry.bind(String name, Remote obj) 绑定对此注册表中指定 name 的远程引用。
static Registry | LocateRegistry.createRegistry(int port) 创建并导出接受指定 port 请求的本地主机上的 Registry 实例。
static Registry | LocateRegistry.createRegistry(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。
static Registry | LocateRegistry.getRegistry() 返回本地主机在默认注册表端口 1099 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(int port) 返回本地主机在指定 port 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host) 返回指定 host 在默认注册表端口 1099 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host, int port) 返回指定的 host 和 port 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host, int port, RMIClientSocketFactory csf) 返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。
String[] | Registry.list() 返回在此注册表中绑定的名称的数组。
Remote | Registry.lookup(String name) 返回注册表中绑定到指定 name 的远程引用。
void | Registry.rebind(String name, Remote obj) 用提供的远程引用替换此注册表中指定的 name 绑定。
Registry | RegistryHandler.registryImpl(int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。
Registry | RegistryHandler.registryStub(String host, int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。
void | Registry.unbind(String name) 移除此注册表中指定的 name 绑定。

java.rmi.server 中 RemoteException 的使用

java.rmi.server 中 RemoteException 的子类
class | ExportException ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SocketSecurityException 已废弃的 ExportException 的子类。

抛出 RemoteException 的 java.rmi.server 中的方法
 void RemoteRef.done(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
static RemoteStub UnicastRemoteObject.exportObject(Remote obj)
使用匿名端口导出远程对象，以便能够接收传入的调用。
static Remote UnicastRemoteObject.exportObject(Remote obj, int port)
使用提供的特定端口导出远程对象，以便能够接收传入的调用。
static Remote UnicastRemoteObject.exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。
 RemoteStub ServerRef.exportObject(Remote obj, Object data)
为提供的 Remote 对象创建客户机 stub 对象。
 RemoteCall RemoteRef.newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。

抛出 RemoteException 的 java.rmi.server 中的构造方法
UnicastRemoteObject()
使用匿名端口创建并导出一个新 UnicastRemoteObject 对象。
UnicastRemoteObject(int port)
使用提供的特定端口创建并导出一个新 UnicastRemoteObject 对象。
UnicastRemoteObject(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用提供的特定端口和套接字工厂创建并导出一个新 UnicastRemoteObject 对象。

javax.activity 中 RemoteException 的使用

javax.activity 中 RemoteException 的子类
class | ActivityCompletedException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
class | ActivityRequiredException 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
class | InvalidActivityException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

javax.management.remote.rmi 中 RemoteException 的使用

抛出 RemoteException 的 javax.management.remote.rmi 中的方法
String | RMIServer.getVersion() 此连接器服务器能识别的 RMI 连接协议版本。
String | RMIServerImpl_Stub.getVersion()

javax.rmi 中 RemoteException 的使用

抛出 RemoteException 的 javax.rmi 中的方法
static void | PortableRemoteObject.connect(Remote target, Remote source) 使 Remote 对象准备好进行远程通信。
static void | PortableRemoteObject.exportObject(Remote obj) 准备服务器对象，以接收远程调用。

抛出 RemoteException 的 javax.rmi 中的构造方法
PortableRemoteObject()
通过调用 exportObject(this) 初始化该对象。

javax.rmi.CORBA 中 RemoteException 的使用

返回 RemoteException 的 javax.rmi.CORBA 中的方法
static RemoteException Util.mapSystemException(SystemException ex)
将 SystemException 映射到 RemoteException。
 RemoteException UtilDelegate.mapSystemException(SystemException ex)
Util.mapSystemException(org.omg.CORBA.SystemException) 的委托调用。
static RemoteException Util.wrapException(Throwable orig)
包装由实现方法抛出的异常。
 RemoteException UtilDelegate.wrapException(Throwable obj)
Util.wrapException(java.lang.Throwable) 的委托调用。

抛出 RemoteException 的 javax.rmi.CORBA 中的方法
 void Stub.connect(ORB orb)
将此 stub 连接到 ORB。
 void PortableRemoteObjectDelegate.connect(Remote target, Remote source)
PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 的委托调用。
 void StubDelegate.connect(Stub self, ORB orb)
Stub.connect(org.omg.CORBA.ORB) 的委托调用。
static Object Util.copyObject(Object obj, ORB orb)
复制或连接一个对象。
 Object UtilDelegate.copyObject(Object obj, ORB orb)
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。
static Object[] Util.copyObjects(Object[] obj, ORB orb)
复制或连接一个对象数组。
 Object[] UtilDelegate.copyObjects(Object[] obj, ORB orb)
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。
 void PortableRemoteObjectDelegate.exportObject(Remote obj)
PortableRemoteObject.exportObject(java.rmi.Remote) 的委托调用。
static boolean Util.isLocal(Stub stub)
isLocal 方法与 ObjectImpl._is_local 方法具有相同的语义，否则可能抛出 RemoteException。
 boolean UtilDelegate.isLocal(Stub stub)
Util.isLocal(javax.rmi.CORBA.Stub) 的委托调用。

javax.transaction 中 RemoteException 的使用

javax.transaction 中 RemoteException 的子类
class | InvalidTransactionException 此异常指示该请求带来了无效的事务上下文。
class | TransactionRequiredException 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
class | TransactionRolledbackException 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.RMISecurityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.RMISecurityException
的使用

没有 java.rmi.RMISecurityException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.RMISecurityManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.RMISecurityManager
的使用

没有 java.rmi.RMISecurityManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.ServerError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.ServerError
的使用

没有 java.rmi.ServerError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.ServerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.ServerException
的使用

没有 java.rmi.ServerException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.ServerRuntimeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.ServerRuntimeException
的使用

没有 java.rmi.ServerRuntimeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.StubNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.StubNotFoundException
的使用

没有 java.rmi.StubNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.UnexpectedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.UnexpectedException
的使用

没有 java.rmi.UnexpectedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.UnknownHostException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.UnknownHostException
的使用

使用 UnknownHostException 的软件包
java.rmi.registry 提供 RMI 注册表的一个类和两个接口。

java.rmi.registry 中 UnknownHostException 的使用

抛出 UnknownHostException 的 java.rmi.registry 中的方法
 Registry RegistryHandler.registryStub(String host, int port)
已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.UnmarshalException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.UnmarshalException
的使用

没有 java.rmi.UnmarshalException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.rmi.dgc (Java 2 Platform SE 6)

 java.rmi.dgc
接口
DGC
类
Lease
VMID


接口 java.rmi.dgc.DGC 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.dgc.DGC
的使用

没有 java.rmi.dgc.DGC 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.dgc.Lease 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.dgc.Lease
的使用

使用 Lease 的软件包
java.rmi.dgc 为 RMI 分布式垃圾回收提供了类和接口。

java.rmi.dgc 中 Lease 的使用

返回 Lease 的 java.rmi.dgc 中的方法
 Lease DGC.dirty(ObjID[] ids, long sequenceNum, Lease lease)
脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。

参数类型为 Lease 的 java.rmi.dgc 中的方法
 Lease DGC.dirty(ObjID[] ids, long sequenceNum, Lease lease)
脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.dgc.VMID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.dgc.VMID
的使用

使用 VMID 的软件包
java.rmi.dgc 为 RMI 分布式垃圾回收提供了类和接口。

java.rmi.dgc 中 VMID 的使用

返回 VMID 的 java.rmi.dgc 中的方法
 VMID Lease.getVMID()
返回与此 lease 关联的客户机 VMID。

参数类型为 VMID 的 java.rmi.dgc 中的方法
 void DGC.clean(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong)
洁调用从 'ids' 指示的每个远程对象的引用列表中移除 'vmid'。

参数类型为 VMID 的 java.rmi.dgc 中的构造方法
Lease(VMID id, long duration)
构造一个具有指定 VMID 和租借期限的 lease。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.rmi.registry (Java 2 Platform SE 6)

 java.rmi.registry
接口
Registry
RegistryHandler
类
LocateRegistry


类 java.rmi.registry.LocateRegistry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.registry.LocateRegistry
的使用

没有 java.rmi.registry.LocateRegistry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.registry.Registry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.registry.Registry
的使用

使用 Registry 的软件包
java.rmi.registry 提供 RMI 注册表的一个类和两个接口。

java.rmi.registry 中 Registry 的使用

返回 Registry 的 java.rmi.registry 中的方法
static Registry | LocateRegistry.createRegistry(int port) 创建并导出接受指定 port 请求的本地主机上的 Registry 实例。
static Registry | LocateRegistry.createRegistry(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。
static Registry | LocateRegistry.getRegistry() 返回本地主机在默认注册表端口 1099 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(int port) 返回本地主机在指定 port 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host) 返回指定 host 在默认注册表端口 1099 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host, int port) 返回指定的 host 和 port 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host, int port, RMIClientSocketFactory csf) 返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。
Registry | RegistryHandler.registryImpl(int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。
Registry | RegistryHandler.registryStub(String host, int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.registry.RegistryHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.registry.RegistryHandler
的使用

没有 java.rmi.registry.RegistryHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.rmi.server (Java 2 Platform SE 6)

 java.rmi.server
接口
LoaderHandler
RemoteCall
RemoteRef
RMIClientSocketFactory
RMIFailureHandler
RMIServerSocketFactory
ServerRef
Skeleton
Unreferenced
类
LogStream
ObjID
Operation
RemoteObject
RemoteObjectInvocationHandler
RemoteServer
RemoteStub
RMIClassLoader
RMIClassLoaderSpi
RMISocketFactory
UID
UnicastRemoteObject
异常
ExportException
ServerCloneException
ServerNotActiveException
SkeletonMismatchException
SkeletonNotFoundException
SocketSecurityException


类 java.rmi.server.ExportException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.ExportException
的使用

使用 ExportException 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 ExportException 的使用

java.rmi.server 中 ExportException 的子类
 class SocketSecurityException
已废弃的 ExportException 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.server.LoaderHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.LoaderHandler
的使用

没有 java.rmi.server.LoaderHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.LogStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.LogStream
的使用

使用 LogStream 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 LogStream 的使用

返回 LogStream 的 java.rmi.server 中的方法
static LogStream LogStream.log(String name)
已过时。 无替代版本

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.ObjID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.ObjID
的使用

使用 ObjID 的软件包
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。

java.rmi.dgc 中 ObjID 的使用

参数类型为 ObjID 的 java.rmi.dgc 中的方法
void | DGC.clean(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong) 洁调用从 'ids' 指示的每个远程对象的引用列表中移除 'vmid'。
Lease | DGC.dirty(ObjID[] ids, long sequenceNum, Lease lease) 脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。

java.rmi.server 中 ObjID 的使用

返回 ObjID 的 java.rmi.server 中的方法
static ObjID ObjID.read(ObjectInput in)
通过从 ObjectInput 实例解组二进制表示形式来构造和返回一个新的 ObjID 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.Operation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.Operation
的使用

使用 Operation 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 Operation 的使用

返回 Operation 的 java.rmi.server 中的方法
 Operation[] Skeleton.getOperations()
已过时。 无替代版本

参数类型为 Operation 的 java.rmi.server 中的方法
 RemoteCall RemoteRef.newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.server.RemoteCall 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.RemoteCall
的使用

使用 RemoteCall 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 RemoteCall 的使用

返回 RemoteCall 的 java.rmi.server 中的方法
 RemoteCall RemoteRef.newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。

参数类型为 RemoteCall 的 java.rmi.server 中的方法
 void Skeleton.dispatch(Remote obj, RemoteCall theCall, int opnum, long hash)
已过时。 无替代版本
 void RemoteRef.done(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
 void RemoteRef.invoke(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.RemoteObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RemoteObject
的使用

使用 RemoteObject 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

java.rmi.activation 中 RemoteObject 的使用

java.rmi.activation 中 RemoteObject 的子类
class | Activatable Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
class | ActivationGroup ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
class | ActivationGroup_Stub ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

java.rmi.server 中 RemoteObject 的使用

java.rmi.server 中 RemoteObject 的子类
class | RemoteObjectInvocationHandler 与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。
class | RemoteServer 该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
class | RemoteStub 该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
class | UnicastRemoteObject 用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

参数类型为 RemoteObject 的 java.rmi.server 中的方法
 RemoteCall RemoteRef.newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。

javax.management.remote.rmi 中 RemoteObject 的使用

javax.management.remote.rmi 中 RemoteObject 的子类
class | RMIConnectionImpl_Stub
class | RMIServerImpl_Stub

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.RemoteObjectInvocationHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RemoteObjectInvocationHandler
的使用

没有 java.rmi.server.RemoteObjectInvocationHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.server.RemoteRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.RemoteRef
的使用

使用 RemoteRef 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

java.rmi.activation 中 RemoteRef 的使用

参数类型为 RemoteRef 的 java.rmi.activation 中的构造方法
ActivationGroup_Stub(RemoteRef ref)
为 ActivationGroup 类构造一个 stub。

java.rmi.server 中 RemoteRef 的使用

java.rmi.server 中 RemoteRef 的子接口
 interface ServerRef
ServerRef 表示远程对象实现的服务器端句柄。

声明为 RemoteRef 的 java.rmi.server 中的字段
protected  RemoteRef RemoteObject.ref
对象的远程引用。

返回 RemoteRef 的 java.rmi.server 中的方法
 RemoteRef RemoteObject.getRef()
返回远程对象的远程引用。

参数类型为 RemoteRef 的 java.rmi.server 中的方法
boolean | RemoteRef.remoteEquals(RemoteRef obj) 比较两个远程对象是否相等。
protected static void | RemoteStub.setRef(RemoteStub stub, RemoteRef ref) 已过时。 无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。

参数类型为 RemoteRef 的 java.rmi.server 中的构造方法
RemoteObject(RemoteRef newref)
创建一个用指定远程引用初始化的远程对象。
RemoteObjectInvocationHandler(RemoteRef ref)
创建一个用指定 RemoteRef 构造的新 RemoteObjectInvocationHandler。
RemoteServer(RemoteRef ref)
构造带指定引用类型的 RemoteServer。
RemoteStub(RemoteRef ref)
构造带指定远程引用的 RemoteStub。

javax.management.remote.rmi 中 RemoteRef 的使用

参数类型为 RemoteRef 的 javax.management.remote.rmi 中的构造方法
RMIConnectionImpl_Stub(RemoteRef ref)
RMIServerImpl_Stub(RemoteRef ref)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.RemoteServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RemoteServer
的使用

使用 RemoteServer 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。

java.rmi.activation 中 RemoteServer 的使用

java.rmi.activation 中 RemoteServer 的子类
class | Activatable Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
class | ActivationGroup ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。

java.rmi.server 中 RemoteServer 的使用

java.rmi.server 中 RemoteServer 的子类
 class UnicastRemoteObject
用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.RemoteStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RemoteStub
的使用

使用 RemoteStub 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

java.rmi.activation 中 RemoteStub 的使用

java.rmi.activation 中 RemoteStub 的子类
 class ActivationGroup_Stub
ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

java.rmi.server 中 RemoteStub 的使用

返回 RemoteStub 的 java.rmi.server 中的方法
static RemoteStub | UnicastRemoteObject.exportObject(Remote obj) 使用匿名端口导出远程对象，以便能够接收传入的调用。
RemoteStub | ServerRef.exportObject(Remote obj, Object data) 为提供的 Remote 对象创建客户机 stub 对象。

参数类型为 RemoteStub 的 java.rmi.server 中的方法
protected static void RemoteStub.setRef(RemoteStub stub, RemoteRef ref)
已过时。 无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。

javax.management.remote.rmi 中 RemoteStub 的使用

javax.management.remote.rmi 中 RemoteStub 的子类
class | RMIConnectionImpl_Stub
class | RMIServerImpl_Stub

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.RMIClassLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RMIClassLoader
的使用

没有 java.rmi.server.RMIClassLoader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.RMIClassLoaderSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RMIClassLoaderSpi
的使用

使用 RMIClassLoaderSpi 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 RMIClassLoaderSpi 的使用

返回 RMIClassLoaderSpi 的 java.rmi.server 中的方法
static RMIClassLoaderSpi RMIClassLoader.getDefaultProviderInstance()
返回服务提供者接口 RMIClassLoaderSpi 的默认提供者的规范化实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.server.RMIClientSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.RMIClientSocketFactory
的使用

使用 RMIClientSocketFactory 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

java.rmi.activation 中 RMIClientSocketFactory 的使用

参数类型为 RMIClientSocketFactory 的 java.rmi.activation 中的方法
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

参数类型为 RMIClientSocketFactory 的 java.rmi.activation 中的构造方法
Activatable(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造方法用于在指定端口上激活/导出对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

java.rmi.registry 中 RMIClientSocketFactory 的使用

参数类型为 RMIClientSocketFactory 的 java.rmi.registry 中的方法
static Registry | LocateRegistry.createRegistry(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。
static Registry | LocateRegistry.getRegistry(String host, int port, RMIClientSocketFactory csf) 返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。

java.rmi.server 中 RMIClientSocketFactory 的使用

实现 RMIClientSocketFactory 的 java.rmi.server 中的类
 class RMISocketFactory
RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。

参数类型为 RMIClientSocketFactory 的 java.rmi.server 中的方法
static Remote UnicastRemoteObject.exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。

参数类型为 RMIClientSocketFactory 的 java.rmi.server 中的构造方法
UnicastRemoteObject(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用提供的特定端口和套接字工厂创建并导出一个新 UnicastRemoteObject 对象。

javax.management.remote.rmi 中 RMIClientSocketFactory 的使用

参数类型为 RMIClientSocketFactory 的 javax.management.remote.rmi 中的构造方法
RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。

javax.rmi.ssl 中 RMIClientSocketFactory 的使用

实现 RMIClientSocketFactory 的 javax.rmi.ssl 中的类
 class SslRMIClientSocketFactory
SslRMIClientSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的客户端套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.server.RMIFailureHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.RMIFailureHandler
的使用

使用 RMIFailureHandler 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 RMIFailureHandler 的使用

返回 RMIFailureHandler 的 java.rmi.server 中的方法
static RMIFailureHandler RMISocketFactory.getFailureHandler()
返回由 setFailureHandler 方法设置的套接字创建失败的处理程序。

参数类型为 RMIFailureHandler 的 java.rmi.server 中的方法
static void RMISocketFactory.setFailureHandler(RMIFailureHandler fh)
如果服务器套接字创建失败，则设置将由 RMI 运行时调用的 failure 处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.server.RMIServerSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.RMIServerSocketFactory
的使用

使用 RMIServerSocketFactory 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

java.rmi.activation 中 RMIServerSocketFactory 的使用

参数类型为 RMIServerSocketFactory 的 java.rmi.activation 中的方法
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

参数类型为 RMIServerSocketFactory 的 java.rmi.activation 中的构造方法
Activatable(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造方法用于在指定端口上激活/导出对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

java.rmi.registry 中 RMIServerSocketFactory 的使用

参数类型为 RMIServerSocketFactory 的 java.rmi.registry 中的方法
static Registry LocateRegistry.createRegistry(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。

java.rmi.server 中 RMIServerSocketFactory 的使用

实现 RMIServerSocketFactory 的 java.rmi.server 中的类
 class RMISocketFactory
RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。

参数类型为 RMIServerSocketFactory 的 java.rmi.server 中的方法
static Remote UnicastRemoteObject.exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。

参数类型为 RMIServerSocketFactory 的 java.rmi.server 中的构造方法
UnicastRemoteObject(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用提供的特定端口和套接字工厂创建并导出一个新 UnicastRemoteObject 对象。

javax.management.remote.rmi 中 RMIServerSocketFactory 的使用

参数类型为 RMIServerSocketFactory 的 javax.management.remote.rmi 中的构造方法
RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。

javax.rmi.ssl 中 RMIServerSocketFactory 的使用

实现 RMIServerSocketFactory 的 javax.rmi.ssl 中的类
 class SslRMIServerSocketFactory
SslRMIServerSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的服务端套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.RMISocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RMISocketFactory
的使用

使用 RMISocketFactory 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 RMISocketFactory 的使用

返回 RMISocketFactory 的 java.rmi.server 中的方法
static RMISocketFactory | RMISocketFactory.getDefaultSocketFactory() 返回对此 RMI 实现使用的默认套接字工厂的引用。
static RMISocketFactory | RMISocketFactory.getSocketFactory() 返回由 setSocketFactory 方法设置的套接字工厂。

参数类型为 RMISocketFactory 的 java.rmi.server 中的方法
static void RMISocketFactory.setSocketFactory(RMISocketFactory fac)
设置 RMI 从中获取套接字的全局套接字工厂（如果远程对象与指定客户机和/或服务器套接字工厂无关）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.ServerCloneException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.ServerCloneException
的使用

没有 java.rmi.server.ServerCloneException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.ServerNotActiveException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.ServerNotActiveException
的使用

使用 ServerNotActiveException 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 ServerNotActiveException 的使用

抛出 ServerNotActiveException 的 java.rmi.server 中的方法
static String | RemoteServer.getClientHost() 返回一个客户机主机的字符串表示形式，用于在当前线程中正在处理的远程方法调用。
String | ServerRef.getClientHost() 返回当前客户机的主机名。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.server.ServerRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.ServerRef
的使用

没有 java.rmi.server.ServerRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.server.Skeleton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.Skeleton
的使用

没有 java.rmi.server.Skeleton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.SkeletonMismatchException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.SkeletonMismatchException
的使用

没有 java.rmi.server.SkeletonMismatchException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.SkeletonNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.SkeletonNotFoundException
的使用

没有 java.rmi.server.SkeletonNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.SocketSecurityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.SocketSecurityException
的使用

没有 java.rmi.server.SocketSecurityException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.UID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.UID
的使用

使用 UID 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 UID 的使用

返回 UID 的 java.rmi.server 中的方法
static UID UID.read(DataInput in)
通过从 DataInput 实例解组二进制表示形式构造并返回一个新的 UID。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.rmi.server.UnicastRemoteObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.UnicastRemoteObject
的使用

使用 UnicastRemoteObject 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 UnicastRemoteObject 的使用

java.rmi.activation 中 UnicastRemoteObject 的子类
 class ActivationGroup
ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.rmi.server.Unreferenced 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.Unreferenced
的使用

使用 Unreferenced 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 中 Unreferenced 的使用

实现 Unreferenced 的 javax.management.remote.rmi 中的类
 class RMIConnectionImpl
RMIConnection 接口的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.security (Java 2 Platform SE 6)

 java.security
接口
Certificate
DomainCombiner
Guard
Key
KeyStore.Entry
KeyStore.LoadStoreParameter
KeyStore.ProtectionParameter
Policy.Parameters
Principal
PrivateKey
PrivilegedAction
PrivilegedExceptionAction
PublicKey
类
AccessControlContext
AccessController
AlgorithmParameterGenerator
AlgorithmParameterGeneratorSpi
AlgorithmParameters
AlgorithmParametersSpi
AllPermission
AuthProvider
BasicPermission
CodeSigner
CodeSource
DigestInputStream
DigestOutputStream
GuardedObject
Identity
IdentityScope
KeyFactory
KeyFactorySpi
KeyPair
KeyPairGenerator
KeyPairGeneratorSpi
KeyRep
KeyStore
KeyStore.Builder
KeyStore.CallbackHandlerProtection
KeyStore.PasswordProtection
KeyStore.PrivateKeyEntry
KeyStore.SecretKeyEntry
KeyStore.TrustedCertificateEntry
KeyStoreSpi
MessageDigest
MessageDigestSpi
Permission
PermissionCollection
Permissions
Policy
PolicySpi
ProtectionDomain
Provider
Provider.Service
SecureClassLoader
SecureRandom
SecureRandomSpi
Security
SecurityPermission
Signature
SignatureSpi
SignedObject
Signer
Timestamp
UnresolvedPermission
URIParameter
枚举
KeyRep.Type
异常
AccessControlException
DigestException
GeneralSecurityException
InvalidAlgorithmParameterException
InvalidKeyException
InvalidParameterException
KeyException
KeyManagementException
KeyStoreException
NoSuchAlgorithmException
NoSuchProviderException
PrivilegedActionException
ProviderException
SignatureException
UnrecoverableEntryException
UnrecoverableKeyException


java.security.acl (Java 2 Platform SE 6)

 java.security.acl
接口
Acl
AclEntry
Group
Owner
Permission
异常
AclNotFoundException
LastOwnerException
NotOwnerException


接口 java.security.acl.Acl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.acl.Acl
的使用

没有 java.security.acl.Acl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.acl.AclEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.acl.AclEntry
的使用

使用 AclEntry 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 中 AclEntry 的使用

返回变量类型为 AclEntry 的类型的 java.security.acl 中的方法
 Enumeration<AclEntry> Acl.entries()
返回此 ACL 中各项的枚举。

参数类型为 AclEntry 的 java.security.acl 中的方法
boolean | Acl.addEntry(Principal caller, AclEntry entry) 向此 ACL 中添加 ACL 项。
boolean | Acl.removeEntry(Principal caller, AclEntry entry) 从此 ACL 中移除 ACL 项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.acl.AclNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.acl.AclNotFoundException
的使用

没有 java.security.acl.AclNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.acl.Group 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.acl.Group
的使用

没有 java.security.acl.Group 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.acl.LastOwnerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.acl.LastOwnerException
的使用

使用 LastOwnerException 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 中 LastOwnerException 的使用

抛出 LastOwnerException 的 java.security.acl 中的方法
 boolean Owner.deleteOwner(Principal caller, Principal owner)
删除一个所有者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.acl.NotOwnerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.acl.NotOwnerException
的使用

使用 NotOwnerException 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 中 NotOwnerException 的使用

抛出 NotOwnerException 的 java.security.acl 中的方法
boolean | Acl.addEntry(Principal caller, AclEntry entry) 向此 ACL 中添加 ACL 项。
boolean | Owner.addOwner(Principal caller, Principal owner) 添加一个所有者。
boolean | Owner.deleteOwner(Principal caller, Principal owner) 删除一个所有者。
boolean | Acl.removeEntry(Principal caller, AclEntry entry) 从此 ACL 中移除 ACL 项。
void | Acl.setName(Principal caller, String name) 设置此 ACL 的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.acl.Owner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.acl.Owner
的使用

使用 Owner 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 中 Owner 的使用

java.security.acl 中 Owner 的子接口
 interface Acl
表示访问控制列表 (ACL) 的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.acl.Permission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.acl.Permission
的使用

使用 Permission 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 中 Permission 的使用

返回变量类型为 Permission 的类型的 java.security.acl 中的方法
Enumeration<Permission> | Acl.getPermissions(Principal user) 返回一个指定主体（表示一个实体，如个体或组）的许可权限集合的枚举。
Enumeration<Permission> | AclEntry.permissions() 返回此 ACL 项中各个权限的枚举。

参数类型为 Permission 的 java.security.acl 中的方法
boolean | AclEntry.addPermission(Permission permission) 向此 ACL 项添加指定的权限。
boolean | AclEntry.checkPermission(Permission permission) 检查指定的权限是否为此项中权限集合的一部分。
boolean | Acl.checkPermission(Principal principal, Permission permission) 检查指定的主体是否具有指定的权限。
boolean | AclEntry.removePermission(Permission permission) 从此 ACL 项中移除指定的权限。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.security.cert (Java 2 Platform SE 6)

 java.security.cert
接口
CertPathBuilderResult
CertPathParameters
CertPathValidatorResult
CertSelector
CertStoreParameters
CRLSelector
PolicyNode
X509Extension
类
Certificate
Certificate.CertificateRep
CertificateFactory
CertificateFactorySpi
CertPath
CertPath.CertPathRep
CertPathBuilder
CertPathBuilderSpi
CertPathValidator
CertPathValidatorSpi
CertStore
CertStoreSpi
CollectionCertStoreParameters
CRL
LDAPCertStoreParameters
PKIXBuilderParameters
PKIXCertPathBuilderResult
PKIXCertPathChecker
PKIXCertPathValidatorResult
PKIXParameters
PolicyQualifierInfo
TrustAnchor
X509Certificate
X509CertSelector
X509CRL
X509CRLEntry
X509CRLSelector
异常
CertificateEncodingException
CertificateException
CertificateExpiredException
CertificateNotYetValidException
CertificateParsingException
CertPathBuilderException
CertPathValidatorException
CertStoreException
CRLException


类 java.security.cert.Certificate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.Certificate
的使用

使用 Certificate 的软件包
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.net 中 Certificate 的使用

返回 Certificate 的 java.net 中的方法
 Certificate[] JarURLConnection.getCertificates()
如果此连接的 URL 指向 JAR 文件条目，则返回其 Certificate 对象；否则返回 null。

返回变量类型为 Certificate 的类型的 java.net 中的方法
abstract List<Certificate> | SecureCacheResponse.getLocalCertificateChain() 返回在获得了网络资源的初始连接的联络期间发送到服务器的证书链。
abstract List<Certificate> | SecureCacheResponse.getServerCertificateChain() 从缓存返回服务器的证书链，该证书链是作为在获得了网络资源的初始连接中定义会话的一部分建立的。

java.security 中 Certificate 的使用

返回 Certificate 的 java.security 中的方法
abstract Certificate | KeyStoreSpi.engineGetCertificate(String alias) 返回与给定别名关联的证书。
abstract Certificate[] | KeyStoreSpi.engineGetCertificateChain(String alias) 返回与给定别名关联的证书链。
Certificate | KeyStore.PrivateKeyEntry.getCertificate() 从此项中的证书链获取终端实体 Certificate。
Certificate | KeyStore.getCertificate(String alias) 返回与给定别名关联的证书。
Certificate[] | KeyStore.PrivateKeyEntry.getCertificateChain() 从此项获取 Certificate 链。
Certificate[] | KeyStore.getCertificateChain(String alias) 返回与给定别名关联的证书链。
Certificate[] | CodeSource.getCertificates() 返回与此 CodeSource 关联的证书。
Certificate | KeyStore.TrustedCertificateEntry.getTrustedCertificate() 从此项获取可信 Certficate。
Certificate[] | UnresolvedPermission.getUnresolvedCerts() 获取尚未解析的基础权限的签署者证书（无任何支持链）。

参数类型为 Certificate 的 java.security 中的方法
abstract String | KeyStoreSpi.engineGetCertificateAlias(Certificate cert) 返回其证书和给定证书匹配的第一个 keystore 项的名称（别名）。
abstract void | KeyStoreSpi.engineSetCertificateEntry(String alias, Certificate cert) 将给定证书分配给给定别名。
abstract void | KeyStoreSpi.engineSetKeyEntry(String alias, byte[] key, Certificate[] chain) 将给定密钥（已经被保护）分配给给定别名。
abstract void | KeyStoreSpi.engineSetKeyEntry(String alias, Key key, char[] password, Certificate[] chain) 将给定的密钥分配给给定的别名，用给定的密码保护它。
String | KeyStore.getCertificateAlias(Certificate cert) 返回证书与给定证书匹配的第一个 keystore 条目的别名。
void | Signature.initVerify(Certificate certificate) 使用来自给定证书的公钥初始化此用于验证的对象。
void | KeyStore.setCertificateEntry(String alias, Certificate cert) 将给定可信证书分配给给定别名。
void | KeyStore.setKeyEntry(String alias, byte[] key, Certificate[] chain) 将给定密钥（已经被保护）分配给给定别名。
void | KeyStore.setKeyEntry(String alias, Key key, char[] password, Certificate[] chain) 将给定的密钥分配给给定的别名，并用给定密码保护它。

参数类型为 Certificate 的 java.security 中的构造方法
CodeSource(URL url, Certificate[] certs)
构造一个 CodeSource 并将其与指定位置和证书集合相关联。
KeyStore.PrivateKeyEntry(PrivateKey privateKey, Certificate[] chain)
构造带 PrivateKey 和相应证书链的 PrivateKeyEntry。
KeyStore.TrustedCertificateEntry(Certificate trustedCert)
用可信 Certificate 构造 TrustedCertificateEntry。
UnresolvedPermission(String type, String name, String actions, Certificate[] certs)
在解析权限时，创建一个新的 UnresolvedPermission，使之包含稍后实际创建指定类的 Permission 时所需的权限信息。

java.security.cert 中 Certificate 的使用

java.security.cert 中 Certificate 的子类
 class X509Certificate
X.509 证书的抽象类。

返回 Certificate 的 java.security.cert 中的方法
abstract Certificate | CertificateFactorySpi.engineGenerateCertificate(InputStream inStream) 生成一个证书对象并使用从输入流 inStream 中读取的数据对它进行初始化。
Certificate | CertificateFactory.generateCertificate(InputStream inStream) 生成一个证书对象，并使用从输入流 inStream 中读取的数据对它进行初始化。

返回变量类型为 Certificate 的类型的 java.security.cert 中的方法
abstract Collection<? extends Certificate> | CertificateFactorySpi.engineGenerateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
abstract Collection<? extends Certificate> | CertStoreSpi.engineGetCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
Collection<? extends Certificate> | CertificateFactory.generateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
abstract List<? extends Certificate> | CertPath.getCertificates() 返回此证书路径中的证书列表。
Collection<? extends Certificate> | CertStore.getCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。

参数类型为 Certificate 的 java.security.cert 中的方法
abstract void | PKIXCertPathChecker.check(Certificate cert, Collection<String> unresolvedCritExts) 使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。
abstract boolean | CRL.isRevoked(Certificate cert) 检查给定的证书是否在此 CRL 中。
boolean | CertSelector.match(Certificate cert) 决定是否应该选择某个 Certificate。
boolean | X509CertSelector.match(Certificate cert) 决定是否应该选择某个 Certificate。

类型变量类型为 Certificate 的 java.security.cert 中的方法参数
CertPath | CertificateFactorySpi.engineGenerateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
CertPath | CertificateFactory.generateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。

java.util.jar 中 Certificate 的使用

返回 Certificate 的 java.util.jar 中的方法
 Certificate[] JarEntry.getCertificates()
返回此条目的 Certificate 对象；如果没有，则返回 null。

javax.crypto 中 Certificate 的使用

参数类型为 Certificate 的 javax.crypto 中的方法
void | Cipher.init(int opmode, Certificate certificate) 用取自给定证书的公钥初始化此 Cipher。
void | Cipher.init(int opmode, Certificate certificate, SecureRandom random) 用取自给定证书的公钥和随机源初始化此 Cipher。

javax.net.ssl 中 Certificate 的使用

返回 Certificate 的 javax.net.ssl 中的方法
Certificate[] | HandshakeCompletedEvent.getLocalCertificates() 返回握手期间发送到同位体的证书。
Certificate[] | SSLSession.getLocalCertificates() 返回握手期间发送给同位体的证书。
abstract Certificate[] | HttpsURLConnection.getLocalCertificates() 返回握手期间发送给服务器的证书。
Certificate[] | HandshakeCompletedEvent.getPeerCertificates() 返回同位体的标识，同位体是作为定义会话的一部分而建立的。
Certificate[] | SSLSession.getPeerCertificates() 返回同级身份，该同级身份是作为定义会话的一部分而建立的。
abstract Certificate[] | HttpsURLConnection.getServerCertificates() 返回服务器的证书链，它是作为定义会话的一部分而建立的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.Certificate.CertificateRep 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.Certificate.CertificateRep
的使用

没有 java.security.cert.Certificate.CertificateRep 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertificateEncodingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateEncodingException
的使用

使用 CertificateEncodingException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateEncodingException 的使用

抛出 CertificateEncodingException 的 java.security.cert 中的方法
abstract byte[] | CertPath.getEncoded() 返回此证书路径的编码形式，使用默认的编码。
abstract byte[] | Certificate.getEncoded() 返回此证书的编码形式。
abstract byte[] | CertPath.getEncoded(String encoding) 返回此证书路径的编码形式，使用指定的编码。
abstract byte[] | X509Certificate.getTBSCertificate() 从此证书中获取以 DER 编码的证书信息，即 tbsCertificate。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertificateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateException
的使用

使用 CertificateException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 CertificateException 的使用

抛出 CertificateException 的 java.security 中的方法
abstract void | KeyStoreSpi.engineLoad(InputStream stream, char[] password) 从给定的输入流中加载此 KeyStore。
void | KeyStoreSpi.engineLoad(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
void | KeyStoreSpi.engineStore(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
abstract void | KeyStoreSpi.engineStore(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
void | KeyStore.load(InputStream stream, char[] password) 从给定输入流中加载此 KeyStore。
void | KeyStore.load(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 加载此 keystore。
void | KeyStore.store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。
void | KeyStore.store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。

java.security.cert 中 CertificateException 的使用

java.security.cert 中 CertificateException 的子类
class | CertificateEncodingException 证书编码异常。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书尚无效异常。
class | CertificateParsingException 证书解析异常。

抛出 CertificateException 的 java.security.cert 中的方法
abstract Certificate | CertificateFactorySpi.engineGenerateCertificate(InputStream inStream) 生成一个证书对象并使用从输入流 inStream 中读取的数据对它进行初始化。
abstract Collection<? extends Certificate> | CertificateFactorySpi.engineGenerateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactorySpi.engineGenerateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
Certificate | CertificateFactory.generateCertificate(InputStream inStream) 生成一个证书对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
Collection<? extends Certificate> | CertificateFactory.generateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
CertPath | CertificateFactory.generateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactory.generateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactory.generateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。
static CertificateFactory | CertificateFactory.getInstance(String type) 返回实现指定证书类型的 CertificateFactory 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, Provider provider) 返回指定证书类型的 CertificateFactory 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, String provider) 返回指定证书类型的 CertificateFactory 对象。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

javax.net.ssl 中 CertificateException 的使用

抛出 CertificateException 的 javax.net.ssl 中的方法
void | X509TrustManager.checkClientTrusted(X509Certificate[] chain, String authType) 给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的客户端 SSL 验证。
void | X509TrustManager.checkServerTrusted(X509Certificate[] chain, String authType) 给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的服务器 SSL 验证。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertificateExpiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateExpiredException
的使用

使用 CertificateExpiredException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateExpiredException 的使用

抛出 CertificateExpiredException 的 java.security.cert 中的方法
abstract void | X509Certificate.checkValidity() 检查证书目前是否有效。
abstract void | X509Certificate.checkValidity(Date date) 检查给定的日期是否处于证书的有效期内。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertificateFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateFactory
的使用

使用 CertificateFactory 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateFactory 的使用

返回 CertificateFactory 的 java.security.cert 中的方法
static CertificateFactory | CertificateFactory.getInstance(String type) 返回实现指定证书类型的 CertificateFactory 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, Provider provider) 返回指定证书类型的 CertificateFactory 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, String provider) 返回指定证书类型的 CertificateFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertificateFactorySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateFactorySpi
的使用

使用 CertificateFactorySpi 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateFactorySpi 的使用

参数类型为 CertificateFactorySpi 的 java.security.cert 中的构造方法
CertificateFactory(CertificateFactorySpi certFacSpi, Provider provider, String type)
创建给定类型的 CertificateFactory 对象，并在其中封装给定的提供者实现（SPI 对象）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertificateNotYetValidException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateNotYetValidException
的使用

使用 CertificateNotYetValidException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateNotYetValidException 的使用

抛出 CertificateNotYetValidException 的 java.security.cert 中的方法
abstract void | X509Certificate.checkValidity() 检查证书目前是否有效。
abstract void | X509Certificate.checkValidity(Date date) 检查给定的日期是否处于证书的有效期内。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertificateParsingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateParsingException
的使用

使用 CertificateParsingException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateParsingException 的使用

抛出 CertificateParsingException 的 java.security.cert 中的方法
List<String> | X509Certificate.getExtendedKeyUsage() 获取一个不可修改的 String 列表，表示已扩展的密钥使用扩展 (OID = 2.5.29.37) 中 ExtKeyUsageSyntax 字段的对象标识符（OBJECT IDENTIFIER）。
Collection<List<?>> | X509Certificate.getIssuerAlternativeNames() 从 IssuerAltName 扩展 (OID = 2.5.29.18) 中获取一个发布方替换名称的不可变集合。
Collection<List<?>> | X509Certificate.getSubjectAlternativeNames() 从 SubjectAltName 扩展 (OID = 2.5.29.17) 中获取一个主体替换名称的不可变集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertPath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPath
的使用

使用 CertPath 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security 中 CertPath 的使用

返回 CertPath 的 java.security 中的方法
CertPath | Timestamp.getSignerCertPath() 返回 Timestamping Authority 的证书路径。
CertPath | CodeSigner.getSignerCertPath() 返回签名者的证书路径。

参数类型为 CertPath 的 java.security 中的构造方法
CodeSigner(CertPath signerCertPath, Timestamp timestamp)
构造 CodeSigner 对象。
Timestamp(Date timestamp, CertPath signerCertPath)
构造一个时间戳。

java.security.cert 中 CertPath 的使用

返回 CertPath 的 java.security.cert 中的方法
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactorySpi.engineGenerateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
CertPath | CertificateFactory.generateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactory.generateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactory.generateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。
CertPath | CertPathBuilderResult.getCertPath() 返回已构建的证书路径。
CertPath | CertPathValidatorException.getCertPath() 返回抛出异常时正在验证的证书路径
CertPath | PKIXCertPathBuilderResult.getCertPath() 返回已构建并已验证的证书路径。

参数类型为 CertPath 的 java.security.cert 中的方法
abstract CertPathValidatorResult | CertPathValidatorSpi.engineValidate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
CertPathValidatorResult | CertPathValidator.validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。

参数类型为 CertPath 的 java.security.cert 中的构造方法
CertPathValidatorException(String msg, Throwable cause, CertPath certPath, int index)
创建带指定详细消息、cause、证书路径和索引的 CertPathValidatorException。
PKIXCertPathBuilderResult(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathBuilderResult 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertPath.CertPathRep 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPath.CertPathRep
的使用

没有 java.security.cert.CertPath.CertPathRep 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertPathBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathBuilder
的使用

使用 CertPathBuilder 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathBuilder 的使用

返回 CertPathBuilder 的 java.security.cert 中的方法
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, Provider provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, String provider) 返回实现了指定算法的 CertPathBuilder 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertPathBuilderException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathBuilderException
的使用

使用 CertPathBuilderException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathBuilderException 的使用

抛出 CertPathBuilderException 的 java.security.cert 中的方法
CertPathBuilderResult | CertPathBuilder.build(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathBuilderResult | CertPathBuilderSpi.engineBuild(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.cert.CertPathBuilderResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CertPathBuilderResult
的使用

使用 CertPathBuilderResult 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathBuilderResult 的使用

实现 CertPathBuilderResult 的 java.security.cert 中的类
 class PKIXCertPathBuilderResult
此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。

返回 CertPathBuilderResult 的 java.security.cert 中的方法
CertPathBuilderResult | CertPathBuilder.build(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathBuilderResult | CertPathBuilderSpi.engineBuild(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertPathBuilderSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathBuilderSpi
的使用

使用 CertPathBuilderSpi 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathBuilderSpi 的使用

参数类型为 CertPathBuilderSpi 的 java.security.cert 中的构造方法
CertPathBuilder(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathBuilder 对象，并在其中封装给定的提供者实现（SPI 对象）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.cert.CertPathParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CertPathParameters
的使用

使用 CertPathParameters 的软件包
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security.cert 中 CertPathParameters 的使用

实现 CertPathParameters 的 java.security.cert 中的类
class | PKIXBuilderParameters 用作 PKIX CertPathBuilder 算法的输入的参数。
class | PKIXParameters 用作 PKIX CertPathValidator 算法的输入的参数。

参数类型为 CertPathParameters 的 java.security.cert 中的方法
CertPathBuilderResult | CertPathBuilder.build(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathBuilderResult | CertPathBuilderSpi.engineBuild(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathValidatorResult | CertPathValidatorSpi.engineValidate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
CertPathValidatorResult | CertPathValidator.validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。

javax.net.ssl 中 CertPathParameters 的使用

返回 CertPathParameters 的 javax.net.ssl 中的方法
 CertPathParameters CertPathTrustManagerParameters.getParameters()
返回此类封装的 CertPathParameters 的副本。

参数类型为 CertPathParameters 的 javax.net.ssl 中的构造方法
CertPathTrustManagerParameters(CertPathParameters parameters)
根据指定的 parameters 构造新的 CertPathTrustManagerParameters。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertPathValidator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathValidator
的使用

使用 CertPathValidator 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathValidator 的使用

返回 CertPathValidator 的 java.security.cert 中的方法
static CertPathValidator | CertPathValidator.getInstance(String algorithm) 返回实现了指定算法的 CertPathValidator 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, Provider provider) 返回实现指定算法的 CertPathValidator 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, String provider) 返回实现指定算法的 CertPathValidator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertPathValidatorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathValidatorException
的使用

使用 CertPathValidatorException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathValidatorException 的使用

抛出 CertPathValidatorException 的 java.security.cert 中的方法
abstract void | PKIXCertPathChecker.check(Certificate cert, Collection<String> unresolvedCritExts) 使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。
abstract CertPathValidatorResult | CertPathValidatorSpi.engineValidate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
abstract void | PKIXCertPathChecker.init(boolean forward) 初始化此 PKIXCertPathChecker 的内部状态。
CertPathValidatorResult | CertPathValidator.validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.cert.CertPathValidatorResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CertPathValidatorResult
的使用

使用 CertPathValidatorResult 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathValidatorResult 的使用

实现 CertPathValidatorResult 的 java.security.cert 中的类
class | PKIXCertPathBuilderResult 此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。
class | PKIXCertPathValidatorResult 此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。

返回 CertPathValidatorResult 的 java.security.cert 中的方法
abstract CertPathValidatorResult | CertPathValidatorSpi.engineValidate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
CertPathValidatorResult | CertPathValidator.validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertPathValidatorSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathValidatorSpi
的使用

使用 CertPathValidatorSpi 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathValidatorSpi 的使用

参数类型为 CertPathValidatorSpi 的 java.security.cert 中的构造方法
CertPathValidator(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathValidator 对象，并在其中封装给定的提供者实现（SPI 对象）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.cert.CertSelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CertSelector
的使用

使用 CertSelector 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertSelector 的使用

实现 CertSelector 的 java.security.cert 中的类
 class X509CertSelector
选择与所有指定标准匹配的 X509Certificates 的 CertSelector。

返回 CertSelector 的 java.security.cert 中的方法
 CertSelector PKIXParameters.getTargetCertConstraints()
返回目标证书所需的限制。

参数类型为 CertSelector 的 java.security.cert 中的方法
abstract Collection<? extends Certificate> | CertStoreSpi.engineGetCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
Collection<? extends Certificate> | CertStore.getCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
void | PKIXParameters.setTargetCertConstraints(CertSelector selector) 设置目标证书所需的限制。

参数类型为 CertSelector 的 java.security.cert 中的构造方法
PKIXBuilderParameters(KeyStore keystore, CertSelector targetConstraints)
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXBuilderParameters(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertStore 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertStore
的使用

使用 CertStore 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertStore 的使用

返回 CertStore 的 java.security.cert 中的方法
static CertStore | CertStore.getInstance(String type, CertStoreParameters params) 返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。

返回变量类型为 CertStore 的类型的 java.security.cert 中的方法
 List<CertStore> PKIXParameters.getCertStores()
返回用于查找证书和 CRL 的不可变 CertStore List。

参数类型为 CertStore 的 java.security.cert 中的方法
 void PKIXParameters.addCertStore(CertStore store)
将 CertStore 添加到查找证书和 CRL 所使用的 CertStore 列表末尾。

类型变量类型为 CertStore 的 java.security.cert 中的方法参数
 void PKIXParameters.setCertStores(List<CertStore> stores)
设置在查找证书和 CRL 时所使用的 CertStore 列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertStoreException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertStoreException
的使用

使用 CertStoreException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertStoreException 的使用

抛出 CertStoreException 的 java.security.cert 中的方法
abstract Collection<? extends Certificate> | CertStoreSpi.engineGetCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
abstract Collection<? extends CRL> | CertStoreSpi.engineGetCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
Collection<? extends Certificate> | CertStore.getCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
Collection<? extends CRL> | CertStore.getCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.cert.CertStoreParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CertStoreParameters
的使用

使用 CertStoreParameters 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertStoreParameters 的使用

实现 CertStoreParameters 的 java.security.cert 中的类
class | CollectionCertStoreParameters 用作 Collection CertStore 算法输入的参数。
class | LDAPCertStoreParameters 用作 LDAP CertStore 算法的输入的参数。

返回 CertStoreParameters 的 java.security.cert 中的方法
 CertStoreParameters CertStore.getCertStoreParameters()
返回初始化此 CertStore 所用的参数。

参数类型为 CertStoreParameters 的 java.security.cert 中的方法
static CertStore | CertStore.getInstance(String type, CertStoreParameters params) 返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。

参数类型为 CertStoreParameters 的 java.security.cert 中的构造方法
CertStore(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。
CertStoreSpi(CertStoreParameters params)
唯一的构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CertStoreSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertStoreSpi
的使用

使用 CertStoreSpi 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertStoreSpi 的使用

参数类型为 CertStoreSpi 的 java.security.cert 中的构造方法
CertStore(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CollectionCertStoreParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CollectionCertStoreParameters
的使用

没有 java.security.cert.CollectionCertStoreParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CRL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CRL
的使用

使用 CRL 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CRL 的使用

java.security.cert 中 CRL 的子类
 class X509CRL
X.509 证书撤消列表 (CRL) 的抽象类。

返回 CRL 的 java.security.cert 中的方法
abstract CRL | CertificateFactorySpi.engineGenerateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
CRL | CertificateFactory.generateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。

返回变量类型为 CRL 的类型的 java.security.cert 中的方法
abstract Collection<? extends CRL> | CertificateFactorySpi.engineGenerateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
abstract Collection<? extends CRL> | CertStoreSpi.engineGetCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
Collection<? extends CRL> | CertificateFactory.generateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
Collection<? extends CRL> | CertStore.getCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。

参数类型为 CRL 的 java.security.cert 中的方法
boolean | CRLSelector.match(CRL crl) 决定是否应该选择某个 CRL。
boolean | X509CRLSelector.match(CRL crl) 决定是否应该选择某个 CRL。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.CRLException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CRLException
的使用

使用 CRLException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CRLException 的使用

抛出 CRLException 的 java.security.cert 中的方法
abstract CRL | CertificateFactorySpi.engineGenerateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
abstract Collection<? extends CRL> | CertificateFactorySpi.engineGenerateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
CRL | CertificateFactory.generateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
Collection<? extends CRL> | CertificateFactory.generateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
abstract byte[] | X509CRL.getEncoded() 返回此 CRL 的 ASN.1 DER 编码形式。
abstract byte[] | X509CRLEntry.getEncoded() 返回此 CRL Entry 的 ASN.1 DER 编码形式，即内部 SEQUENCE。
abstract byte[] | X509CRL.getTBSCertList() 从此 CRL 中获取以 DER 编码的 CRL 信息，即 tbsCertList。
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.cert.CRLSelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CRLSelector
的使用

使用 CRLSelector 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CRLSelector 的使用

实现 CRLSelector 的 java.security.cert 中的类
 class X509CRLSelector
选择与所有指定标准相匹配的 X509CRL 的 CRLSelector。

参数类型为 CRLSelector 的 java.security.cert 中的方法
abstract Collection<? extends CRL> | CertStoreSpi.engineGetCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
Collection<? extends CRL> | CertStore.getCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.LDAPCertStoreParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.LDAPCertStoreParameters
的使用

没有 java.security.cert.LDAPCertStoreParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.PKIXBuilderParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PKIXBuilderParameters
的使用

没有 java.security.cert.PKIXBuilderParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.PKIXCertPathBuilderResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PKIXCertPathBuilderResult
的使用

没有 java.security.cert.PKIXCertPathBuilderResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.PKIXCertPathChecker 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PKIXCertPathChecker
的使用

使用 PKIXCertPathChecker 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 PKIXCertPathChecker 的使用

返回变量类型为 PKIXCertPathChecker 的类型的 java.security.cert 中的方法
 List<PKIXCertPathChecker> PKIXParameters.getCertPathCheckers()
返回证书路径检查器的 List。

参数类型为 PKIXCertPathChecker 的 java.security.cert 中的方法
 void PKIXParameters.addCertPathChecker(PKIXCertPathChecker checker)
向证书路径检查器列表中添加一个 PKIXCertPathChecker。

类型变量类型为 PKIXCertPathChecker 的 java.security.cert 中的方法参数
 void PKIXParameters.setCertPathCheckers(List<PKIXCertPathChecker> checkers)
设置其他证书路径检查器的 List。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.PKIXCertPathValidatorResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PKIXCertPathValidatorResult
的使用

使用 PKIXCertPathValidatorResult 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 PKIXCertPathValidatorResult 的使用

java.security.cert 中 PKIXCertPathValidatorResult 的子类
 class PKIXCertPathBuilderResult
此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.PKIXParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PKIXParameters
的使用

使用 PKIXParameters 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 PKIXParameters 的使用

java.security.cert 中 PKIXParameters 的子类
 class PKIXBuilderParameters
用作 PKIX CertPathBuilder 算法的输入的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.cert.PolicyNode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.PolicyNode
的使用

使用 PolicyNode 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 PolicyNode 的使用

返回 PolicyNode 的 java.security.cert 中的方法
PolicyNode | PolicyNode.getParent() 返回此节点的父节点，如果此节点是根节点，则返回 null。
PolicyNode | PKIXCertPathValidatorResult.getPolicyTree() 返回 PKIX 证书路径验证算法所得的有效策略树的根节点。

返回变量类型为 PolicyNode 的类型的 java.security.cert 中的方法
 Iterator<? extends PolicyNode> PolicyNode.getChildren()
返回在此节点的子节点上进行迭代的迭代器。

参数类型为 PolicyNode 的 java.security.cert 中的构造方法
PKIXCertPathBuilderResult(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathBuilderResult 实例。
PKIXCertPathValidatorResult(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathValidatorResult 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.PolicyQualifierInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PolicyQualifierInfo
的使用

使用 PolicyQualifierInfo 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 PolicyQualifierInfo 的使用

返回变量类型为 PolicyQualifierInfo 的类型的 java.security.cert 中的方法
 Set<? extends PolicyQualifierInfo> PolicyNode.getPolicyQualifiers()
返回与此节点所表示的有效策略相关联的策略限定符集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.TrustAnchor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.TrustAnchor
的使用

使用 TrustAnchor 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 TrustAnchor 的使用

返回 TrustAnchor 的 java.security.cert 中的方法
 TrustAnchor PKIXCertPathValidatorResult.getTrustAnchor()
返回描述作为证书路径受信定位点的 CA 的 TrustAnchor。

返回变量类型为 TrustAnchor 的类型的 java.security.cert 中的方法
 Set<TrustAnchor> PKIXParameters.getTrustAnchors()
返回不可变的、最受信任的 CA Set。

类型变量类型为 TrustAnchor 的 java.security.cert 中的方法参数
 void PKIXParameters.setTrustAnchors(Set<TrustAnchor> trustAnchors)
设置最受信任的 CA Set。

参数类型为 TrustAnchor 的 java.security.cert 中的构造方法
PKIXCertPathBuilderResult(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathBuilderResult 实例。
PKIXCertPathValidatorResult(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathValidatorResult 实例。

类型变量类型为 TrustAnchor 的 java.security.cert 中的构造方法参数
PKIXBuilderParameters(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。
PKIXParameters(Set<TrustAnchor> trustAnchors)
创建具有指定最受信任 CA Set 的 PKIXParameters 的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.X509Certificate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.X509Certificate
的使用

使用 X509Certificate 的软件包
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

java.security.cert 中 X509Certificate 的使用

返回 X509Certificate 的 java.security.cert 中的方法
X509Certificate | X509CertSelector.getCertificate() 返回 certificateEquals 标准。
X509Certificate | X509CRLSelector.getCertificateChecking() 返回要检查的证书。
X509Certificate | TrustAnchor.getTrustedCert() 返回最受信任的 CA 证书。

参数类型为 X509Certificate 的 java.security.cert 中的方法
X509CRLEntry | X509CRL.getRevokedCertificate(X509Certificate certificate) 获取给定证书的 CRL 项（如果有）。
void | X509CertSelector.setCertificate(X509Certificate cert) 设置 certificateEquals 标准。
void | X509CRLSelector.setCertificateChecking(X509Certificate cert) 设置要检查的证书。

参数类型为 X509Certificate 的 java.security.cert 中的构造方法
TrustAnchor(X509Certificate trustedCert, byte[] nameConstraints)
创建具有指定 X509Certificate 和可选 nameConstraints 的 TrustAnchor 实例，在验证 X.509 证书路径时，该 nameConstraints 用作额外的限制条件。

javax.net.ssl 中 X509Certificate 的使用

返回 X509Certificate 的 javax.net.ssl 中的方法
X509Certificate[] | X509TrustManager.getAcceptedIssuers() 返回受验证同位体信任的认证中心的数组。
X509Certificate[] | X509KeyManager.getCertificateChain(String alias) 返回与给定别名关联的证书链。

参数类型为 X509Certificate 的 javax.net.ssl 中的方法
void | X509TrustManager.checkClientTrusted(X509Certificate[] chain, String authType) 给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的客户端 SSL 验证。
void | X509TrustManager.checkServerTrusted(X509Certificate[] chain, String authType) 给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的服务器 SSL 验证。

javax.security.auth.x500 中 X509Certificate 的使用

返回 X509Certificate 的 javax.security.auth.x500 中的方法
 X509Certificate X500PrivateCredential.getCertificate()
返回 X.509 证书。

参数类型为 X509Certificate 的 javax.security.auth.x500 中的构造方法
X500PrivateCredential(X509Certificate cert, PrivateKey key)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。
X500PrivateCredential(X509Certificate cert, PrivateKey key, String alias)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.X509CertSelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.X509CertSelector
的使用

没有 java.security.cert.X509CertSelector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.X509CRL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.X509CRL
的使用

没有 java.security.cert.X509CRL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.X509CRLEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.X509CRLEntry
的使用

使用 X509CRLEntry 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 X509CRLEntry 的使用

返回 X509CRLEntry 的 java.security.cert 中的方法
abstract X509CRLEntry | X509CRL.getRevokedCertificate(BigInteger serialNumber) 获取具有给定证书 serialNumber 的 CRL 项（如果有）。
X509CRLEntry | X509CRL.getRevokedCertificate(X509Certificate certificate) 获取给定证书的 CRL 项（如果有）。

返回变量类型为 X509CRLEntry 的类型的 java.security.cert 中的方法
abstract  Set<? extends X509CRLEntry> X509CRL.getRevokedCertificates()
获取此 CRL 中的所有项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.cert.X509CRLSelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.X509CRLSelector
的使用

没有 java.security.cert.X509CRLSelector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.cert.X509Extension 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.X509Extension
的使用

使用 X509Extension 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 X509Extension 的使用

实现 X509Extension 的 java.security.cert 中的类
class | X509Certificate X.509 证书的抽象类。
class | X509CRL X.509 证书撤消列表 (CRL) 的抽象类。
class | X509CRLEntry 用于 CRL（证书撤消列表）中已撤消证书的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.AccessControlContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AccessControlContext
的使用

使用 AccessControlContext 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.security 中 AccessControlContext 的使用

返回 AccessControlContext 的 java.security 中的方法
static AccessControlContext AccessController.getContext()
此方法获取当前调用上下文（包括当前 Thread 的继承 AccessControlContext）的“快照”，并将其置于 AccessControlContext 对象中。

参数类型为 AccessControlContext 的 java.security 中的方法
static
<T> T
AccessController.doPrivileged(PrivilegedAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedAction。
static
<T> T
AccessController.doPrivileged(PrivilegedExceptionAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedExceptionAction。

参数类型为 AccessControlContext 的 java.security 中的构造方法
AccessControlContext(AccessControlContext acc, DomainCombiner combiner)
创建具有给定 AccessControlContext 和 DomainCombiner 的新 AccessControlContext。

javax.security.auth 中 AccessControlContext 的使用

参数类型为 AccessControlContext 的 javax.security.auth 中的方法
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。
static Subject Subject.getSubject(AccessControlContext acc)
获取与提供的 AccessControlContext 关联的 Subject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.AccessControlException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AccessControlException
的使用

使用 AccessControlException 的软件包
java.security 为安全框架提供类和接口。

java.security 中 AccessControlException 的使用

抛出 AccessControlException 的 java.security 中的方法
static void | AccessController.checkPermission(Permission perm) 基于当前 AccessControlContext 和安全策略确定是否允许指定权限所指示的访问请求。
void | AccessControlContext.checkPermission(Permission perm) 基于当前生效的安全策略和此对象中的上下文确定是否允许指定权限指示的访问请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.AccessController 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AccessController
的使用

没有 java.security.AccessController 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.AlgorithmParameterGenerator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AlgorithmParameterGenerator
的使用

使用 AlgorithmParameterGenerator 的软件包
java.security 为安全框架提供类和接口。

java.security 中 AlgorithmParameterGenerator 的使用

返回 AlgorithmParameterGenerator 的 java.security 中的方法
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, Provider provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, String provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.AlgorithmParameterGeneratorSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AlgorithmParameterGeneratorSpi
的使用

使用 AlgorithmParameterGeneratorSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 AlgorithmParameterGeneratorSpi 的使用

参数类型为 AlgorithmParameterGeneratorSpi 的 java.security 中的构造方法
AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameterGenerator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.AlgorithmParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AlgorithmParameters
的使用

使用 AlgorithmParameters 的软件包
java.security | 为安全框架提供类和接口。
javax.crypto | 为加密操作提供类和接口。

java.security 中 AlgorithmParameters 的使用

返回 AlgorithmParameters 的 java.security 中的方法
protected abstract AlgorithmParameters | AlgorithmParameterGeneratorSpi.engineGenerateParameters() 生成参数。
protected AlgorithmParameters | SignatureSpi.engineGetParameters() 此方法将由提供者重写，以返回与此签名引擎配合使用的参数，如果此签名引擎未使用任何参数，则返回 null。
AlgorithmParameters | AlgorithmParameterGenerator.generateParameters() 生成参数。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm) 返回指定算法的参数对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, Provider provider) 返回指定算法的参数对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, String provider) 返回指定算法的参数对象。
AlgorithmParameters | Signature.getParameters() 返回与此签名对象一起使用的参数。

javax.crypto 中 AlgorithmParameters 的使用

返回 AlgorithmParameters 的 javax.crypto 中的方法
protected abstract AlgorithmParameters | CipherSpi.engineGetParameters() 返回此 cipher 使用的参数。
AlgorithmParameters | EncryptedPrivateKeyInfo.getAlgParameters() 返回加密算法使用的算法参数。
AlgorithmParameters | Cipher.getParameters() 返回此 Cipher 使用的参数。

参数类型为 AlgorithmParameters 的 javax.crypto 中的方法
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | ExemptionMechanism.init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。

参数类型为 AlgorithmParameters 的 javax.crypto 中的构造方法
EncryptedPrivateKeyInfo(AlgorithmParameters algParams, byte[] encryptedData)
根据加密算法参数和加密数据构造 EncryptedPrivateKeyInfo。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.AlgorithmParametersSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AlgorithmParametersSpi
的使用

使用 AlgorithmParametersSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 AlgorithmParametersSpi 的使用

参数类型为 AlgorithmParametersSpi 的 java.security 中的构造方法
AlgorithmParameters(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameters 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.AllPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AllPermission
的使用

没有 java.security.AllPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.AuthProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AuthProvider
的使用

没有 java.security.AuthProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.BasicPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.BasicPermission
的使用

使用 BasicPermission 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.awt 中 BasicPermission 的使用

java.awt 中 BasicPermission 的子类
 class AWTPermission
此类用于 AWT 权限。

java.io 中 BasicPermission 的使用

java.io 中 BasicPermission 的子类
 class SerializablePermission
此类用于可序列化权限。

java.lang 中 BasicPermission 的使用

java.lang 中 BasicPermission 的子类
 class RuntimePermission
该类用于运行时权限。

java.lang.management 中 BasicPermission 的使用

java.lang.management 中 BasicPermission 的子类
 class ManagementPermission
使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。

java.lang.reflect 中 BasicPermission 的使用

java.lang.reflect 中 BasicPermission 的子类
 class ReflectPermission
反射操作的 Permission 类。

java.net 中 BasicPermission 的使用

java.net 中 BasicPermission 的子类
 class NetPermission
此类可用于各种网络权限。

java.security 中 BasicPermission 的使用

java.security 中 BasicPermission 的子类
 class SecurityPermission
此类用于安全权限。

java.sql 中 BasicPermission 的使用

java.sql 中 BasicPermission 的子类
 class SQLPermission
SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。

java.util 中 BasicPermission 的使用

java.util 中 BasicPermission 的子类
 class PropertyPermission
此类用于属性权限。

java.util.logging 中 BasicPermission 的使用

java.util.logging 中 BasicPermission 的子类
 class LoggingPermission
当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。

javax.management 中 BasicPermission 的使用

javax.management 中 BasicPermission 的子类
class | MBeanServerPermission 执行与 MBeanServer 关联的操作的 Permission。
class | MBeanTrustPermission 此权限表示“信任”签名者或代码基。

javax.management.remote 中 BasicPermission 的使用

javax.management.remote 中 BasicPermission 的子类
 class SubjectDelegationPermission
授权标识表示验证标识执行操作所需的权限。

javax.net.ssl 中 BasicPermission 的使用

javax.net.ssl 中 BasicPermission 的子类
 class SSLPermission
此类用于各种网络权限。

javax.security.auth 中 BasicPermission 的使用

javax.security.auth 中 BasicPermission 的子类
 class AuthPermission
此类用于验证权限。

javax.security.auth.kerberos 中 BasicPermission 的使用

javax.security.auth.kerberos 中 BasicPermission 的子类
 class DelegationPermission
此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。

javax.sound.sampled 中 BasicPermission 的使用

javax.sound.sampled 中 BasicPermission 的子类
 class AudioPermission
AudioPermission 类表示对音频系统资源的访问权限。

javax.xml.ws 中 BasicPermission 的使用

javax.xml.ws 中 BasicPermission 的子类
 class WebServicePermission
此类定义 Web 服务权限。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.Certificate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.Certificate
的使用

使用 Certificate 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Certificate 的使用

返回 Certificate 的 java.security 中的方法
 Certificate[] Identity.certificates()
已过时。 返回此 Identity 所有证书的一个副本。

参数类型为 Certificate 的 java.security 中的方法
void | Identity.addCertificate(Certificate certificate) 已过时。 为此 Identity 添加一个证书。
void | Identity.removeCertificate(Certificate certificate) 已过时。 从此 Identity 中移除证书。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.CodeSigner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.CodeSigner
的使用

使用 CodeSigner 的软件包
java.security | 为安全框架提供类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.security 中 CodeSigner 的使用

返回 CodeSigner 的 java.security 中的方法
 CodeSigner[] CodeSource.getCodeSigners()
返回与此 CodeSource 关联的代码签名者。

参数类型为 CodeSigner 的 java.security 中的构造方法
CodeSource(URL url, CodeSigner[] signers)
构造一个 CodeSource 并将其与指定位置和代码签名者集合相关联。

java.util.jar 中 CodeSigner 的使用

返回 CodeSigner 的 java.util.jar 中的方法
 CodeSigner[] JarEntry.getCodeSigners()
返回此条目的 CodeSigner 对象；如果没有，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.CodeSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.CodeSource
的使用

使用 CodeSource 的软件包
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.net 中 CodeSource 的使用

参数类型为 CodeSource 的 java.net 中的方法
protected  PermissionCollection URLClassLoader.getPermissions(CodeSource codesource)
返回给定 codesource 对象的权限。

java.security 中 CodeSource 的使用

返回 CodeSource 的 java.security 中的方法
 CodeSource ProtectionDomain.getCodeSource()
返回此域的 CodeSource。

参数类型为 CodeSource 的 java.security 中的方法
protected Class<?> | SecureClassLoader.defineClass(String name, byte[] b, int off, int len, CodeSource cs) 使用可选的 CodeSource 将 byte 数组转换为 Class 类的实例。
protected Class<?> | SecureClassLoader.defineClass(String name, ByteBuffer b, CodeSource cs) 使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。
protected PermissionCollection | PolicySpi.engineGetPermissions(CodeSource codesource) 返回包含授予指定 CodeSource 的权限集的 PermissionCollection 对象。
PermissionCollection | Policy.getPermissions(CodeSource codesource) 返回一个 PermissionCollection 对象，它包含授予指定 CodeSource 的权限集。
protected PermissionCollection | SecureClassLoader.getPermissions(CodeSource codesource) 返回给定的 CodeSource 对象的权限。
boolean | CodeSource.implies(CodeSource codesource) 如果此 CodeSource 对象“暗含”指定的 CodeSource，则返回 true。

参数类型为 CodeSource 的 java.security 中的构造方法
ProtectionDomain(CodeSource codesource, PermissionCollection permissions)
创建具有给定 CodeSource 和 Permissions 的新 ProtectionDomain。
ProtectionDomain(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。

javax.security.auth 中 CodeSource 的使用

参数类型为 CodeSource 的 javax.security.auth 中的方法
abstract  PermissionCollection Policy.getPermissions(Subject subject, CodeSource cs)
已过时。 获取授予与指定的 CodeSource 关联的 Principals 的 Permissions。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.DigestException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.DigestException
的使用

使用 DigestException 的软件包
java.security 为安全框架提供类和接口。

java.security 中 DigestException 的使用

抛出 DigestException 的 java.security 中的方法
int | MessageDigest.digest(byte[] buf, int offset, int len) 通过执行诸如填充之类的最终操作完成哈希计算。
protected int | MessageDigestSpi.engineDigest(byte[] buf, int offset, int len) 通过执行诸如填充等之类的最终操作完成哈希计算。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.DigestInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.DigestInputStream
的使用

没有 java.security.DigestInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.DigestOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.DigestOutputStream
的使用

没有 java.security.DigestOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.DomainCombiner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.DomainCombiner
的使用

使用 DomainCombiner 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.security 中 DomainCombiner 的使用

返回 DomainCombiner 的 java.security 中的方法
 DomainCombiner AccessControlContext.getDomainCombiner()
获取与此 AccessControlContext 关联的 DomainCombiner。

参数类型为 DomainCombiner 的 java.security 中的构造方法
AccessControlContext(AccessControlContext acc, DomainCombiner combiner)
创建具有给定 AccessControlContext 和 DomainCombiner 的新 AccessControlContext。

javax.security.auth 中 DomainCombiner 的使用

实现 DomainCombiner 的 javax.security.auth 中的类
 class SubjectDomainCombiner
SubjectDomainCombiner 通过与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新 ProtectionDomains。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.GeneralSecurityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.GeneralSecurityException
的使用

使用 GeneralSecurityException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.security.auth.login | 此包提供可插入的验证框架。

java.security 中 GeneralSecurityException 的使用

java.security 中 GeneralSecurityException 的子类
class | DigestException 此为一般 Message Digest 异常。
class | InvalidAlgorithmParameterException 用于无效或不合适的算法参数的异常。
class | InvalidKeyException 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
class | KeyException 此异常是基本的密钥异常。
class | KeyManagementException 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
class | KeyStoreException 这是一般的 KeyStore 异常。
class | NoSuchAlgorithmException 当请求特定的加密算法而它在该环境中不可用时抛出此异常。
class | NoSuchProviderException 当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
class | SignatureException 这是一般的签名异常。
class | UnrecoverableEntryException 如果 keystore 中的某项无法恢复，则抛出此异常。
class | UnrecoverableKeyException 如果 keystore 中的密钥无法恢复，则抛出此异常。

java.security.cert 中 GeneralSecurityException 的使用

java.security.cert 中 GeneralSecurityException 的子类
class | CertificateEncodingException 证书编码异常。
class | CertificateException 此异常指示各种证书问题中的一种。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书尚无效异常。
class | CertificateParsingException 证书解析异常。
class | CertPathBuilderException 指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
class | CertPathValidatorException 指示在验证一个证书路径时遇到了某种问题的异常。
class | CertStoreException 指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
class | CRLException CRL（证书撤消列表）异常。

java.security.spec 中 GeneralSecurityException 的使用

java.security.spec 中 GeneralSecurityException 的子类
class | InvalidKeySpecException 这是针对无效密钥规范的异常。
class | InvalidParameterSpecException 这是针对无效参数规范的异常。

javax.crypto 中 GeneralSecurityException 的使用

javax.crypto 中 GeneralSecurityException 的子类
class | BadPaddingException 当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
class | ExemptionMechanismException 此为一般 ExemptionMechanism 异常。
class | IllegalBlockSizeException 如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
class | NoSuchPaddingException 当请求特定填充机制但该环境中未提供时，抛出此异常。
class | ShortBufferException 当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

javax.security.auth.login 中 GeneralSecurityException 的使用

javax.security.auth.login 中 GeneralSecurityException 的子类
class | AccountException 一般的帐户异常。
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。
class | CredentialException 一般证书异常。
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。
class | FailedLoginException 当用户验证失败时抛出此异常。
class | LoginException 此异常是基本的登录异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.Guard 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.Guard
的使用

使用 Guard 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.awt 中 Guard 的使用

实现 Guard 的 java.awt 中的类
 class AWTPermission
此类用于 AWT 权限。

java.io 中 Guard 的使用

实现 Guard 的 java.io 中的类
class | FilePermission 此类表示对文件和目录的访问。
class | SerializablePermission 此类用于可序列化权限。

java.lang 中 Guard 的使用

实现 Guard 的 java.lang 中的类
 class RuntimePermission
该类用于运行时权限。

java.lang.management 中 Guard 的使用

实现 Guard 的 java.lang.management 中的类
 class ManagementPermission
使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。

java.lang.reflect 中 Guard 的使用

实现 Guard 的 java.lang.reflect 中的类
 class ReflectPermission
反射操作的 Permission 类。

java.net 中 Guard 的使用

实现 Guard 的 java.net 中的类
class | NetPermission 此类可用于各种网络权限。
class | SocketPermission 此类表示通过套接字对网络的访问。

java.security 中 Guard 的使用

实现 Guard 的 java.security 中的类
class | AllPermission AllPermission 是暗含所有其他权限的权限。
class | BasicPermission BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
class | Permission 表示访问系统资源的抽象类。
class | SecurityPermission 此类用于安全权限。
class | UnresolvedPermission UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。

参数类型为 Guard 的 java.security 中的构造方法
GuardedObject(Object object, Guard guard)
使用指定的对象和 guard 构造 GuardedObject。

java.sql 中 Guard 的使用

实现 Guard 的 java.sql 中的类
 class SQLPermission
SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。

java.util 中 Guard 的使用

实现 Guard 的 java.util 中的类
 class PropertyPermission
此类用于属性权限。

java.util.logging 中 Guard 的使用

实现 Guard 的 java.util.logging 中的类
 class LoggingPermission
当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。

javax.management 中 Guard 的使用

实现 Guard 的 javax.management 中的类
class | MBeanPermission 权限控制对 MBeanServer 操作的访问。
class | MBeanServerPermission 执行与 MBeanServer 关联的操作的 Permission。
class | MBeanTrustPermission 此权限表示“信任”签名者或代码基。

javax.management.remote 中 Guard 的使用

实现 Guard 的 javax.management.remote 中的类
 class SubjectDelegationPermission
授权标识表示验证标识执行操作所需的权限。

javax.net.ssl 中 Guard 的使用

实现 Guard 的 javax.net.ssl 中的类
 class SSLPermission
此类用于各种网络权限。

javax.security.auth 中 Guard 的使用

实现 Guard 的 javax.security.auth 中的类
class | AuthPermission 此类用于验证权限。
class | PrivateCredentialPermission 此类用来保护对属于特定 Subject 的私有 Credential 的访问。

javax.security.auth.kerberos 中 Guard 的使用

实现 Guard 的 javax.security.auth.kerberos 中的类
class | DelegationPermission 此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。
class | ServicePermission 此类用于保护 Kerberos 服务和访问这些服务所必需的证书。

javax.sound.sampled 中 Guard 的使用

实现 Guard 的 javax.sound.sampled 中的类
 class AudioPermission
AudioPermission 类表示对音频系统资源的访问权限。

javax.xml.ws 中 Guard 的使用

实现 Guard 的 javax.xml.ws 中的类
 class WebServicePermission
此类定义 Web 服务权限。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.GuardedObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.GuardedObject
的使用

没有 java.security.GuardedObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.Identity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Identity
的使用

使用 Identity 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Identity 的使用

java.security 中 Identity 的子类
class | IdentityScope 已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | Signer 已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。

返回 Identity 的 java.security 中的方法
Identity | IdentityScope.getIdentity(Principal principal) 已过时。 获取名称与指定的主体相同的身份。
abstract Identity | IdentityScope.getIdentity(PublicKey key) 已过时。 获取具有指定公钥的身份。
abstract Identity | IdentityScope.getIdentity(String name) 已过时。 返回此作用域内具有指定名称的身份（如果有的话）。

返回变量类型为 Identity 的类型的 java.security 中的方法
abstract  Enumeration<Identity> IdentityScope.identities()
已过时。 返回此身份作用域内所有身份的枚举。

参数类型为 Identity 的 java.security 中的方法
abstract void | IdentityScope.addIdentity(Identity identity) 已过时。 向此身份作用域添加一个身份。
protected boolean | Identity.identityEquals(Identity identity) 已过时。 测试指定 Identity 与此 Identity 的相等性。
abstract void | IdentityScope.removeIdentity(Identity identity) 已过时。 从此身份作用作用域移除一个身份。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.IdentityScope 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.IdentityScope
的使用

使用 IdentityScope 的软件包
java.security 为安全框架提供类和接口。

java.security 中 IdentityScope 的使用

返回 IdentityScope 的 java.security 中的方法
IdentityScope | Identity.getScope() 已过时。 返回此 Identity 的作用域。
static IdentityScope | IdentityScope.getSystemScope() 已过时。 返回系统的身份作用域。

参数类型为 IdentityScope 的 java.security 中的方法
protected static void IdentityScope.setSystemScope(IdentityScope scope)
已过时。 设置系统的身份作用域。

参数类型为 IdentityScope 的 java.security 中的构造方法
Identity(String name, IdentityScope scope)
已过时。 构造一个具有指定名称和作用域的 Identity。
IdentityScope(String name, IdentityScope scope)
已过时。 构造具有指定名称和作用域的新身份作用域。
Signer(String name, IdentityScope scope)
已过时。 创建带有指定标识名称和范围的 signer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.InvalidAlgorithmParameterException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.InvalidAlgorithmParameterException
的使用

使用 InvalidAlgorithmParameterException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。

java.security 中 InvalidAlgorithmParameterException 的使用

抛出 InvalidAlgorithmParameterException 的 java.security 中的方法
protected abstract void | AlgorithmParameterGeneratorSpi.engineInit(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值的集合初始化此参数生成器。
protected void | SignatureSpi.engineSetParameter(AlgorithmParameterSpec params) 此方法将由提供者重写，以便使用指定的参数设置初始化此签名引擎。
void | AlgorithmParameterGenerator.init(AlgorithmParameterSpec genParamSpec) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | AlgorithmParameterGenerator.init(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | KeyPairGenerator.initialize(AlgorithmParameterSpec params) 初始化密钥对生成器，使用指定参数集合，并使用以最高优先级安装的提供者的 SecureRandom 的实现作为随机源。
void | KeyPairGenerator.initialize(AlgorithmParameterSpec params, SecureRandom random) 使用给定参数集合和随机源初始化密钥对生成器。
void | KeyPairGeneratorSpi.initialize(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集合和用户提供的随机源初始化密钥对生成器。
void | Signature.setParameter(AlgorithmParameterSpec params) 使用指定的参数集初始化此签名引擎。

java.security.cert 中 InvalidAlgorithmParameterException 的使用

抛出 InvalidAlgorithmParameterException 的 java.security.cert 中的方法
CertPathBuilderResult | CertPathBuilder.build(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathBuilderResult | CertPathBuilderSpi.engineBuild(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathValidatorResult | CertPathValidatorSpi.engineValidate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params) 返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
void | PKIXParameters.setTrustAnchors(Set<TrustAnchor> trustAnchors) 设置最受信任的 CA Set。
CertPathValidatorResult | CertPathValidator.validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。

抛出 InvalidAlgorithmParameterException 的 java.security.cert 中的构造方法
CertStoreSpi(CertStoreParameters params)
唯一的构造方法。
PKIXBuilderParameters(KeyStore keystore, CertSelector targetConstraints)
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXBuilderParameters(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。
PKIXParameters(KeyStore keystore)
创建一个 PKIXParameters 实例，它根据指定 KeyStore 中所包含的受信证书项生成最受信任的 CA 集。
PKIXParameters(Set<TrustAnchor> trustAnchors)
创建具有指定最受信任 CA Set 的 PKIXParameters 的实例。

javax.crypto 中 InvalidAlgorithmParameterException 的使用

抛出 InvalidAlgorithmParameterException 的 javax.crypto 中的方法
protected abstract void | KeyGeneratorSpi.engineInit(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化密钥生成器。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | MacSpi.engineInit(Key key, AlgorithmParameterSpec params) 用给定的（秘密）密钥和算法参数初始化 MAC。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | KeyAgreementSpi.engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | KeyGenerator.init(AlgorithmParameterSpec params) 用指定参数集初始化此密钥生成器。
void | KeyGenerator.init(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化此密钥生成器。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | ExemptionMechanism.init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | ExemptionMechanism.init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params) 用给定密钥和算法参数集初始化此密钥协定。
void | Mac.init(Key key, AlgorithmParameterSpec params) 用给定的密钥和算法参数初始化此 Mac 对象。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。

javax.net.ssl 中 InvalidAlgorithmParameterException 的使用

抛出 InvalidAlgorithmParameterException 的 javax.net.ssl 中的方法
protected abstract void | KeyManagerFactorySpi.engineInit(ManagerFactoryParameters spec) 使用密钥内容源初始化此工厂。
protected abstract void | TrustManagerFactorySpi.engineInit(ManagerFactoryParameters spec) 使用特定于提供者的密钥材料源初始化此工厂。
void | KeyManagerFactory.init(ManagerFactoryParameters spec) 使用特定于提供者的密钥内容源初始化此工厂。
void | TrustManagerFactory.init(ManagerFactoryParameters spec) 使用特定于提供者的信任材料源初始化此工厂。

javax.xml.crypto.dsig 中 InvalidAlgorithmParameterException 的使用

抛出 InvalidAlgorithmParameterException 的 javax.xml.crypto.dsig 中的方法
abstract void | TransformService.init(TransformParameterSpec params) 使用指定的参数初始化此 TransformService。
abstract void | TransformService.init(XMLStructure parent, XMLCryptoContext context) 使用指定的参数和文档上下文初始化此 TransformService。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract DigestMethod | XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params) 针对指定的算法 URI 和参数创建 DigestMethod。
abstract SignatureMethod | XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params) 针对指定的算法 URI 和参数创建 SignatureMethod。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params) 针对指定的算法 URI 和参数创建 Transform。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 Transform。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.InvalidKeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.InvalidKeyException
的使用

使用 InvalidKeyException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.security.cert | 为公钥证书提供类。

java.security 中 InvalidKeyException 的使用

抛出 InvalidKeyException 的 java.security 中的方法
protected abstract void | SignatureSpi.engineInitSign(PrivateKey privateKey) 通过用于签名操作的指定私钥初始化此签名对象。
protected void | SignatureSpi.engineInitSign(PrivateKey privateKey, SecureRandom random) 通过用于签名操作的指定私钥和随机源初始化此签名对象。
protected abstract void | SignatureSpi.engineInitVerify(PublicKey publicKey) 通过用于验证操作的指定公钥初始化此签名对象。
protected abstract Key | KeyFactorySpi.engineTranslateKey(Key key) 将其 provider 可能是未知的或可能不受信任的密钥对象转换成此密钥工厂的相应密钥对象。
void | Signature.initSign(PrivateKey privateKey) 初始化这个用于签名的对象。
void | Signature.initSign(PrivateKey privateKey, SecureRandom random) 初始化这个用于签名的对象。
void | Signature.initVerify(Certificate certificate) 使用来自给定证书的公钥初始化此用于验证的对象。
void | Signature.initVerify(PublicKey publicKey) 初始化此用于验证的对象。
Key | KeyFactory.translateKey(Key key) 将提供者可能未知或不受信任的密钥对象转换成此密钥工厂对应的密钥对象。
boolean | SignedObject.verify(PublicKey verificationKey, Signature verificationEngine) 使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。

抛出 InvalidKeyException 的 java.security 中的构造方法
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

java.security.cert 中 InvalidKeyException 的使用

抛出 InvalidKeyException 的 java.security.cert 中的方法
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

javax.crypto 中 InvalidKeyException 的使用

抛出 InvalidKeyException 的 javax.crypto 中的方法
Key | KeyAgreement.doPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
protected abstract Key | KeyAgreementSpi.engineDoPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
protected abstract SecretKey | KeyAgreementSpi.engineGenerateSecret(String algorithm) 创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
protected int | CipherSpi.engineGetKeySize(Key key) 返回给定密钥对象的密钥大小，以位为单位。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 cipher。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key) 用密钥初始化此豁免机制。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | MacSpi.engineInit(Key key, AlgorithmParameterSpec params) 用给定的（秘密）密钥和算法参数初始化 MAC。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | KeyAgreementSpi.engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
protected abstract void | KeyAgreementSpi.engineInit(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协定。
protected abstract SecretKey | SecretKeyFactorySpi.engineTranslateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此密钥工厂的相应密钥对象。
protected Key | CipherSpi.engineUnwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 打开一个以前包装的密钥。
protected byte[] | CipherSpi.engineWrap(Key key) 将密钥包装。
SecretKey | KeyAgreement.generateSecret(String algorithm) 创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
Object | SealedObject.getObject(Key key) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。
void | Cipher.init(int opmode, Certificate certificate) 用取自给定证书的公钥初始化此 Cipher。
void | Cipher.init(int opmode, Certificate certificate, SecureRandom random) 用取自给定证书的公钥和随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key) 用密钥初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 Cipher。
void | ExemptionMechanism.init(Key key) 用密钥初始化此豁免机制。
void | KeyAgreement.init(Key key) 用给定密钥初始化此密钥协定，给定密钥需要包含此密钥协定所需的所有算法参数。
void | Mac.init(Key key) 用给定的密钥初始化此 Mac 对象。
void | ExemptionMechanism.init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | ExemptionMechanism.init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params) 用给定密钥和算法参数集初始化此密钥协定。
void | Mac.init(Key key, AlgorithmParameterSpec params) 用给定的密钥和算法参数初始化此 Mac 对象。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | KeyAgreement.init(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协议。
SecretKey | SecretKeyFactory.translateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此秘密密钥工厂的相应密钥对象。
Key | Cipher.unwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 解包一个以前包装的密钥。
byte[] | Cipher.wrap(Key key) 包装密钥。

javax.crypto.spec 中 InvalidKeyException 的使用

抛出 InvalidKeyException 的 javax.crypto.spec 中的方法
static boolean | DESKeySpec.isParityAdjusted(byte[] key, int offset) 确定给定的始于且包含 offset 的 DES 密钥内容是否是奇偶校验的 (parity-adjusted)。
static boolean | DESedeKeySpec.isParityAdjusted(byte[] key, int offset) 确定给定的始于且包含 offset 的 DES-EDE 密钥是否是奇偶校验的 (parity-adjusted)。
static boolean | DESKeySpec.isWeak(byte[] key, int offset) 确定给定的 DES 密钥内容是否是全弱或者半弱的。

抛出 InvalidKeyException 的 javax.crypto.spec 中的构造方法
DESedeKeySpec(byte[] key)
创建一个 DESedeKeySpec 对象，使用 key 中的前 24 个字节作为 DES-EDE 密钥的密钥内容。
DESedeKeySpec(byte[] key, int offset)
创建一个 DESedeKeySpec 对象，使用 key 中始于且包含 offset 的前 24 个字节作为 DES-EDE 密钥的密钥内容。
DESKeySpec(byte[] key)
创建一个 DESKeySpec 对象，使用 key 中的前 8 个字节作为 DES 密钥的密钥内容。
DESKeySpec(byte[] key, int offset)
创建一个 DESKeySpec 对象，使用 key 中始于且包含 offset 的前 8 个字节作为 DES-EDE 密钥的密钥内容。

javax.security.cert 中 InvalidKeyException 的使用

抛出 InvalidKeyException 的 javax.security.cert 中的方法
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.InvalidParameterException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.InvalidParameterException
的使用

使用 InvalidParameterException 的软件包
java.security | 为安全框架提供类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

java.security 中 InvalidParameterException 的使用

抛出 InvalidParameterException 的 java.security 中的方法
protected abstract Object | SignatureSpi.engineGetParameter(String param) 已过时。
protected abstract void | SignatureSpi.engineSetParameter(String param, Object value) 已过时。 由 engineSetParameter 取代。
Object | Signature.getParameter(String param) 已过时。
void | Signer.setKeyPair(KeyPair pair) 已过时。 为此签署人设置密钥对（公钥和私钥）。
void | Signature.setParameter(String param, Object value) 已过时。 使用 setParameter 取代。

java.security.interfaces 中 InvalidParameterException 的使用

抛出 InvalidParameterException 的 java.security.interfaces 中的方法
void | DSAKeyPairGenerator.initialize(DSAParams params, SecureRandom random) 使用 DSA 系列参数（p、q 和 g）和可选 SecureRandom 位源初始化密钥对生成器。
void | DSAKeyPairGenerator.initialize(int modlen, boolean genParams, SecureRandom random) 使用给定系数长度（而不是参数）和可选 SecureRandom 位源初始化密钥对生成器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.Key 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.Key
的使用

使用 Key 的软件包
java.security | 为安全框架提供类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。

java.security 中 Key 的使用

java.security 中 Key 的子接口
interface | PrivateKey 私钥。
interface | PublicKey 公钥。

返回 Key 的 java.security 中的方法
abstract Key | KeyStoreSpi.engineGetKey(String alias, char[] password) 返回与给定别名关联的密钥，使用给定密码恢复它。
protected abstract Key | KeyFactorySpi.engineTranslateKey(Key key) 将其 provider 可能是未知的或可能不受信任的密钥对象转换成此密钥工厂的相应密钥对象。
Key | KeyStore.getKey(String alias, char[] password) 返回与给定别名关联的密钥，并用给定密码来恢复它。
Key | KeyFactory.translateKey(Key key) 将提供者可能未知或不受信任的密钥对象转换成此密钥工厂对应的密钥对象。

参数类型为 Key 的 java.security 中的方法
protected abstract
<T extends KeySpec>
T
KeyFactorySpi.engineGetKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
abstract  void KeyStoreSpi.engineSetKeyEntry(String alias, Key key, char[] password, Certificate[] chain)
将给定的密钥分配给给定的别名，用给定的密码保护它。
protected abstract  Key KeyFactorySpi.engineTranslateKey(Key key)
将其 provider 可能是未知的或可能不受信任的密钥对象转换成此密钥工厂的相应密钥对象。
<T extends KeySpec>
T
KeyFactory.getKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
 void KeyStore.setKeyEntry(String alias, Key key, char[] password, Certificate[] chain)
将给定的密钥分配给给定的别名，并用给定密码保护它。
 Key KeyFactory.translateKey(Key key)
将提供者可能未知或不受信任的密钥对象转换成此密钥工厂对应的密钥对象。

java.security.interfaces 中 Key 的使用

java.security.interfaces 中 Key 的子接口
interface | DSAPrivateKey DSA 专用密钥的标准接口。
interface | DSAPublicKey DSA 公用密钥的接口。
interface | ECPrivateKey 椭圆曲线 (EC) 专用密钥的接口。
interface | ECPublicKey 椭圆曲线 (EC) 公用密钥的接口。
interface | RSAMultiPrimePrivateCrtKey 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
interface | RSAPrivateCrtKey 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
interface | RSAPrivateKey RSA 专用密钥的接口。
interface | RSAPublicKey RSA 公用密钥的接口。

javax.crypto 中 Key 的使用

javax.crypto 中 Key 的子接口
 interface SecretKey
秘密（对称）密钥。

返回 Key 的 javax.crypto 中的方法
Key | KeyAgreement.doPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
protected abstract Key | KeyAgreementSpi.engineDoPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
protected Key | CipherSpi.engineUnwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 打开一个以前包装的密钥。
Key | Cipher.unwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 解包一个以前包装的密钥。

参数类型为 Key 的 javax.crypto 中的方法
Key | KeyAgreement.doPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
protected abstract Key | KeyAgreementSpi.engineDoPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
protected int | CipherSpi.engineGetKeySize(Key key) 返回给定密钥对象的密钥大小，以位为单位。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 cipher。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key) 用密钥初始化此豁免机制。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | MacSpi.engineInit(Key key, AlgorithmParameterSpec params) 用给定的（秘密）密钥和算法参数初始化 MAC。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | KeyAgreementSpi.engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
protected abstract void | KeyAgreementSpi.engineInit(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协定。
protected byte[] | CipherSpi.engineWrap(Key key) 将密钥包装。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
Object | SealedObject.getObject(Key key) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。
void | Cipher.init(int opmode, Key key) 用密钥初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 Cipher。
void | ExemptionMechanism.init(Key key) 用密钥初始化此豁免机制。
void | KeyAgreement.init(Key key) 用给定密钥初始化此密钥协定，给定密钥需要包含此密钥协定所需的所有算法参数。
void | Mac.init(Key key) 用给定的密钥初始化此 Mac 对象。
void | ExemptionMechanism.init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | ExemptionMechanism.init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params) 用给定密钥和算法参数集初始化此密钥协定。
void | Mac.init(Key key, AlgorithmParameterSpec params) 用给定的密钥和算法参数初始化此 Mac 对象。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | KeyAgreement.init(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协议。
boolean | ExemptionMechanism.isCryptoAllowed(Key key) 返回此豁免机制是否已成功生成结果 blob。
byte[] | Cipher.wrap(Key key) 包装密钥。

javax.crypto.interfaces 中 Key 的使用

javax.crypto.interfaces 中 Key 的子接口
interface | DHPrivateKey Diffie-Hellman 私钥接口。
interface | DHPublicKey Diffie-Hellman 公钥接口。
interface | PBEKey 调用者 PBE 密钥接口。

javax.crypto.spec 中 Key 的使用

实现 Key 的 javax.crypto.spec 中的类
 class SecretKeySpec
此类以与 provider 无关的方式指定一个密钥。

javax.security.auth.kerberos 中 Key 的使用

实现 Key 的 javax.security.auth.kerberos 中的类
 class KerberosKey
此类为 Kerberos 主体封装一个长期秘密密钥。

javax.xml.crypto 中 Key 的使用

返回 Key 的 javax.xml.crypto 中的方法
 Key KeySelectorResult.getKey()
返回选定的密钥。

参数类型为 Key 的 javax.xml.crypto 中的方法
static KeySelector KeySelector.singletonKeySelector(Key key)
返回一个总是选择指定密钥的 KeySelector，不管传递给它的 KeyInfo 是什么。

javax.xml.crypto.dsig.dom 中 Key 的使用

参数类型为 Key 的 javax.xml.crypto.dsig.dom 中的构造方法
DOMSignContext(Key signingKey, Node parent)
创建带有指定签名密钥和父节点的 DOMSignContext。
DOMSignContext(Key signingKey, Node parent, Node nextSibling)
创建带有指定的签名密钥、父节点和下一个兄弟节点的 DOMSignContext。
DOMValidateContext(Key validatingKey, Node node)
创建包含指定密钥和节点的 DOMValidateContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyException
的使用

使用 KeyException 的软件包
java.security | 为安全框架提供类和接口。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

java.security 中 KeyException 的使用

java.security 中 KeyException 的子类
class | InvalidKeyException 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
class | KeyManagementException 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。

抛出 KeyException 的 java.security 中的方法
void | Certificate.decode(InputStream stream) 已过时。 从输入流解码证书。
void | Certificate.encode(OutputStream stream) 已过时。 以 decode 方法可以解码的格式将证书编码到输出流。
void | Signer.setKeyPair(KeyPair pair) 已过时。 为此签署人设置密钥对（公钥和私钥）。

javax.xml.crypto.dsig.keyinfo 中 KeyException 的使用

抛出 KeyException 的 javax.xml.crypto.dsig.keyinfo 中的方法
PublicKey | KeyValue.getPublicKey() 返回此 KeyValue 的公钥。
abstract KeyValue | KeyInfoFactory.newKeyValue(PublicKey key) 根据指定的公钥创建 KeyValue。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyFactory
的使用

使用 KeyFactory 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyFactory 的使用

返回 KeyFactory 的 java.security 中的方法
static KeyFactory | KeyFactory.getInstance(String algorithm) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyFactorySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyFactorySpi
的使用

使用 KeyFactorySpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyFactorySpi 的使用

参数类型为 KeyFactorySpi 的 java.security 中的构造方法
KeyFactory(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 KeyFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyManagementException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyManagementException
的使用

使用 KeyManagementException 的软件包
java.security | 为安全框架提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 KeyManagementException 的使用

抛出 KeyManagementException 的 java.security 中的方法
void | Identity.addCertificate(Certificate certificate) 已过时。 为此 Identity 添加一个证书。
abstract void | IdentityScope.addIdentity(Identity identity) 已过时。 向此身份作用域添加一个身份。
void | Identity.removeCertificate(Certificate certificate) 已过时。 从此 Identity 中移除证书。
abstract void | IdentityScope.removeIdentity(Identity identity) 已过时。 从此身份作用作用域移除一个身份。
void | Identity.setPublicKey(PublicKey key) 已过时。 设置此 Identity 的公钥。

抛出 KeyManagementException 的 java.security 中的构造方法
Identity(String name, IdentityScope scope)
已过时。 构造一个具有指定名称和作用域的 Identity。
IdentityScope(String name, IdentityScope scope)
已过时。 构造具有指定名称和作用域的新身份作用域。
Signer(String name, IdentityScope scope)
已过时。 创建带有指定标识名称和范围的 signer。

javax.net.ssl 中 KeyManagementException 的使用

抛出 KeyManagementException 的 javax.net.ssl 中的方法
protected abstract void | SSLContextSpi.engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr) 初始化此上下文。
void | SSLContext.init(KeyManager[] km, TrustManager[] tm, SecureRandom random) 初始化此上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyPair 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyPair
的使用

使用 KeyPair 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyPair 的使用

返回 KeyPair 的 java.security 中的方法
KeyPair | KeyPairGenerator.generateKeyPair() 生成一个密钥对。
abstract KeyPair | KeyPairGeneratorSpi.generateKeyPair() 生成密钥对。
KeyPair | KeyPairGenerator.genKeyPair() 生成密钥对。

参数类型为 KeyPair 的 java.security 中的方法
 void Signer.setKeyPair(KeyPair pair)
已过时。 为此签署人设置密钥对（公钥和私钥）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyPairGenerator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyPairGenerator
的使用

使用 KeyPairGenerator 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyPairGenerator 的使用

返回 KeyPairGenerator 的 java.security 中的方法
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyPairGeneratorSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyPairGeneratorSpi
的使用

使用 KeyPairGeneratorSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyPairGeneratorSpi 的使用

java.security 中 KeyPairGeneratorSpi 的子类
 class KeyPairGenerator
KeyPairGenerator 类用于生成公钥和私钥对。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyRep 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyRep
的使用

没有 java.security.KeyRep 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyRep.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyRep.Type
的使用

使用 KeyRep.Type 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyRep.Type 的使用

返回 KeyRep.Type 的 java.security 中的方法
static KeyRep.Type | KeyRep.Type.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static KeyRep.Type[] | KeyRep.Type.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 KeyRep.Type 的 java.security 中的构造方法
KeyRep(KeyRep.Type type, String algorithm, String format, byte[] encoded)
构造替换的 Key 类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyStore 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore
的使用

使用 KeyStore 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 KeyStore 的使用

返回 KeyStore 的 java.security 中的方法
static KeyStore | KeyStore.getInstance(String type) 返回指定类型的 keystore 对象。
static KeyStore | KeyStore.getInstance(String type, Provider provider) 返回指定类型的 keystore 对象。
static KeyStore | KeyStore.getInstance(String type, String provider) 返回指定类型的 keystore 对象。
abstract KeyStore | KeyStore.Builder.getKeyStore() 返回此对象描述的 KeyStore。

参数类型为 KeyStore 的 java.security 中的方法
static KeyStore.Builder KeyStore.Builder.newInstance(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter)
返回封装给定 KeyStore 的新 Builder。

java.security.cert 中 KeyStore 的使用

参数类型为 KeyStore 的 java.security.cert 中的构造方法
PKIXBuilderParameters(KeyStore keystore, CertSelector targetConstraints)
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXParameters(KeyStore keystore)
创建一个 PKIXParameters 实例，它根据指定 KeyStore 中所包含的受信证书项生成最受信任的 CA 集。

javax.net.ssl 中 KeyStore 的使用

参数类型为 KeyStore 的 javax.net.ssl 中的方法
protected abstract void | TrustManagerFactorySpi.engineInit(KeyStore ks) 用证书授权源和相关的信任材料初始化此工厂。
protected abstract void | KeyManagerFactorySpi.engineInit(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。
void | TrustManagerFactory.init(KeyStore ks) 用证书授权源和相关的信任材料初始化此工厂。
void | KeyManagerFactory.init(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyStore.Builder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.Builder
的使用

使用 KeyStore.Builder 的软件包
java.security | 为安全框架提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 KeyStore.Builder 的使用

返回 KeyStore.Builder 的 java.security 中的方法
static KeyStore.Builder | KeyStore.Builder.newInstance(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter) 返回封装给定 KeyStore 的新 Builder。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。

javax.net.ssl 中 KeyStore.Builder 的使用

参数类型为 KeyStore.Builder 的 javax.net.ssl 中的构造方法
KeyStoreBuilderParameters(KeyStore.Builder builder)
根据指定的 KeyStore.Builder 构造新的 KeyStoreBuilderParameters。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyStore.CallbackHandlerProtection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.CallbackHandlerProtection
的使用

没有 java.security.KeyStore.CallbackHandlerProtection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.KeyStore.Entry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.KeyStore.Entry
的使用

使用 KeyStore.Entry 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyStore.Entry 的使用

实现 KeyStore.Entry 的 java.security 中的类
static class | KeyStore.PrivateKeyEntry 保存 PrivateKey 和相应证书链的 KeyStore 项。
static class | KeyStore.SecretKeyEntry 保存 SecretKey 的 KeyStore 项。
static class | KeyStore.TrustedCertificateEntry 保存可信的 Certificate 的 KeyStore 项。

返回 KeyStore.Entry 的 java.security 中的方法
KeyStore.Entry | KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
KeyStore.Entry | KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。

参数类型为 KeyStore.Entry 的 java.security 中的方法
void | KeyStoreSpi.engineSetEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 KeyStore.Entry。
void | KeyStore.setEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 keystore Entry。

类型变量类型为 KeyStore.Entry 的 java.security 中的方法参数
boolean | KeyStoreSpi.engineEntryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass) 确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
boolean | KeyStore.entryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass) 确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.KeyStore.LoadStoreParameter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.KeyStore.LoadStoreParameter
的使用

使用 KeyStore.LoadStoreParameter 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyStore.LoadStoreParameter 的使用

参数类型为 KeyStore.LoadStoreParameter 的 java.security 中的方法
void | KeyStoreSpi.engineLoad(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
void | KeyStoreSpi.engineStore(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
void | KeyStore.load(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 加载此 keystore。
void | KeyStore.store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyStore.PasswordProtection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.PasswordProtection
的使用

没有 java.security.KeyStore.PasswordProtection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyStore.PrivateKeyEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.PrivateKeyEntry
的使用

没有 java.security.KeyStore.PrivateKeyEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.KeyStore.ProtectionParameter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.KeyStore.ProtectionParameter
的使用

使用 KeyStore.ProtectionParameter 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyStore.ProtectionParameter 的使用

实现 KeyStore.ProtectionParameter 的 java.security 中的类
static class | KeyStore.CallbackHandlerProtection 封装 CallbackHandler 的 ProtectionParameter。
static class | KeyStore.PasswordProtection ProtectionParameter 的一个基于密码的实现。

返回 KeyStore.ProtectionParameter 的 java.security 中的方法
KeyStore.ProtectionParameter | KeyStore.LoadStoreParameter.getProtectionParameter() 获取用于保护 keystore 数据的参数。
abstract KeyStore.ProtectionParameter | KeyStore.Builder.getProtectionParameter(String alias) 返回应该用来获取具有给定别名的 Entry 的 ProtectionParameters。

参数类型为 KeyStore.ProtectionParameter 的 java.security 中的方法
KeyStore.Entry | KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
void | KeyStoreSpi.engineSetEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 KeyStore.Entry。
KeyStore.Entry | KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。
static KeyStore.Builder | KeyStore.Builder.newInstance(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter) 返回封装给定 KeyStore 的新 Builder。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。
void | KeyStore.setEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 keystore Entry。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyStore.SecretKeyEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.SecretKeyEntry
的使用

没有 java.security.KeyStore.SecretKeyEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyStore.TrustedCertificateEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.TrustedCertificateEntry
的使用

没有 java.security.KeyStore.TrustedCertificateEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyStoreException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStoreException
的使用

使用 KeyStoreException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 KeyStoreException 的使用

抛出 KeyStoreException 的 java.security 中的方法
Enumeration<String> | KeyStore.aliases() 列出此 keystore 的所有别名。
boolean | KeyStore.containsAlias(String alias) 检查给定别名是否存在于此 keystore 中。
void | KeyStore.deleteEntry(String alias) 删除此 keystore 中给定别名标识的条目。
abstract void | KeyStoreSpi.engineDeleteEntry(String alias) 删除由此 keystore 中给定的别名标识的项。
KeyStore.Entry | KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
abstract void | KeyStoreSpi.engineSetCertificateEntry(String alias, Certificate cert) 将给定证书分配给给定别名。
void | KeyStoreSpi.engineSetEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 KeyStore.Entry。
abstract void | KeyStoreSpi.engineSetKeyEntry(String alias, byte[] key, Certificate[] chain) 将给定密钥（已经被保护）分配给给定别名。
abstract void | KeyStoreSpi.engineSetKeyEntry(String alias, Key key, char[] password, Certificate[] chain) 将给定的密钥分配给给定的别名，用给定的密码保护它。
boolean | KeyStore.entryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass) 确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
Certificate | KeyStore.getCertificate(String alias) 返回与给定别名关联的证书。
String | KeyStore.getCertificateAlias(Certificate cert) 返回证书与给定证书匹配的第一个 keystore 条目的别名。
Certificate[] | KeyStore.getCertificateChain(String alias) 返回与给定别名关联的证书链。
Date | KeyStore.getCreationDate(String alias) 返回给定别名标识的条目的创建日期。
KeyStore.Entry | KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。
static KeyStore | KeyStore.getInstance(String type) 返回指定类型的 keystore 对象。
static KeyStore | KeyStore.getInstance(String type, Provider provider) 返回指定类型的 keystore 对象。
static KeyStore | KeyStore.getInstance(String type, String provider) 返回指定类型的 keystore 对象。
Key | KeyStore.getKey(String alias, char[] password) 返回与给定别名关联的密钥，并用给定密码来恢复它。
abstract KeyStore | KeyStore.Builder.getKeyStore() 返回此对象描述的 KeyStore。
abstract KeyStore.ProtectionParameter | KeyStore.Builder.getProtectionParameter(String alias) 返回应该用来获取具有给定别名的 Entry 的 ProtectionParameters。
boolean | KeyStore.isCertificateEntry(String alias) 如果给定别名标识的条目是通过调用 setCertificateEntry 或者以 TrustedCertificateEntry 为参数的 setEntry 创建的，则返回 true。
boolean | KeyStore.isKeyEntry(String alias) 如果给定别名标识的条目是通过调用 setKeyEntry 或者以 PrivateKeyEntry 或 SecretKeyEntry 为参数的 setEntry 创建的，则返回 true。
void | KeyStore.setCertificateEntry(String alias, Certificate cert) 将给定可信证书分配给给定别名。
void | KeyStore.setEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 keystore Entry。
void | KeyStore.setKeyEntry(String alias, byte[] key, Certificate[] chain) 将给定密钥（已经被保护）分配给给定别名。
void | KeyStore.setKeyEntry(String alias, Key key, char[] password, Certificate[] chain) 将给定的密钥分配给给定的别名，并用给定密码保护它。
int | KeyStore.size() 获取此 keystore 中条目数。
void | KeyStore.store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。
void | KeyStore.store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。

java.security.cert 中 KeyStoreException 的使用

抛出 KeyStoreException 的 java.security.cert 中的构造方法
PKIXBuilderParameters(KeyStore keystore, CertSelector targetConstraints)
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXParameters(KeyStore keystore)
创建一个 PKIXParameters 实例，它根据指定 KeyStore 中所包含的受信证书项生成最受信任的 CA 集。

javax.net.ssl 中 KeyStoreException 的使用

抛出 KeyStoreException 的 javax.net.ssl 中的方法
protected abstract void | TrustManagerFactorySpi.engineInit(KeyStore ks) 用证书授权源和相关的信任材料初始化此工厂。
protected abstract void | KeyManagerFactorySpi.engineInit(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。
void | TrustManagerFactory.init(KeyStore ks) 用证书授权源和相关的信任材料初始化此工厂。
void | KeyManagerFactory.init(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.KeyStoreSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStoreSpi
的使用

使用 KeyStoreSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyStoreSpi 的使用

参数类型为 KeyStoreSpi 的 java.security 中的构造方法
KeyStore(KeyStoreSpi keyStoreSpi, Provider provider, String type)
创建给定类型的 KeyStore 对象，并在其中封装给定的提供者实现（SPI 对象）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.MessageDigest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.MessageDigest
的使用

使用 MessageDigest 的软件包
java.security 为安全框架提供类和接口。

java.security 中 MessageDigest 的使用

声明为 MessageDigest 的 java.security 中的字段
protected MessageDigest | DigestInputStream.digest 与此流关联的消息摘要。
protected MessageDigest | DigestOutputStream.digest 与此流关联的消息摘要。

返回 MessageDigest 的 java.security 中的方法
static MessageDigest | MessageDigest.getInstance(String algorithm) 返回实现指定摘要算法的 MessageDigest 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, Provider provider) 返回实现指定摘要算法的 MessageDigest 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, String provider) 返回实现指定摘要算法的 MessageDigest 对象。
MessageDigest | DigestInputStream.getMessageDigest() 返回与此流关联的消息摘要。
MessageDigest | DigestOutputStream.getMessageDigest() 返回与此流关联的消息摘要。

参数类型为 MessageDigest 的 java.security 中的方法
void | DigestInputStream.setMessageDigest(MessageDigest digest) 将指定的消息摘要与此流相关联。
void | DigestOutputStream.setMessageDigest(MessageDigest digest) 将指定的消息摘要与此流相关联。

参数类型为 MessageDigest 的 java.security 中的构造方法
DigestInputStream(InputStream stream, MessageDigest digest)
使用指定的输入流和消息摘要创建一个摘要输入流。
DigestOutputStream(OutputStream stream, MessageDigest digest)
使用指定的输出流和消息摘要创建一个摘要输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.MessageDigestSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.MessageDigestSpi
的使用

使用 MessageDigestSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 MessageDigestSpi 的使用

java.security 中 MessageDigestSpi 的子类
 class MessageDigest
此 MessageDigest 类为应用程序提供信息摘要算法的功能，如 MD5 或 SHA 算法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.NoSuchAlgorithmException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.NoSuchAlgorithmException
的使用

使用 NoSuchAlgorithmException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.cert | 为公钥证书提供类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。

java.security 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 java.security 中的方法
KeyStore.Entry | KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
abstract Key | KeyStoreSpi.engineGetKey(String alias, char[] password) 返回与给定别名关联的密钥，使用给定密码恢复它。
abstract void | KeyStoreSpi.engineLoad(InputStream stream, char[] password) 从给定的输入流中加载此 KeyStore。
void | KeyStoreSpi.engineLoad(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
void | KeyStoreSpi.engineStore(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
abstract void | KeyStoreSpi.engineStore(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
KeyStore.Entry | KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static Signature | Signature.getInstance(String algorithm) 返回实现指定签名算法的 Signature 对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm) 返回指定算法的参数对象。
static KeyFactory | KeyFactory.getInstance(String algorithm) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm) 返回实现指定摘要算法的 MessageDigest 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, Provider provider) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, String provider) 返回指定类型的 Policy 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, Provider provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, Provider provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static Signature | Signature.getInstance(String algorithm, Provider provider) 返回实现指定签名算法的 Signature 对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, Provider provider) 返回指定算法的参数对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, Provider provider) 返回实现指定摘要算法的 MessageDigest 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, String provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, String provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static Signature | Signature.getInstance(String algorithm, String provider) 返回实现指定签名算法的 Signature 对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, String provider) 返回指定算法的参数对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, String provider) 返回实现指定摘要算法的 MessageDigest 对象。
Key | KeyStore.getKey(String alias, char[] password) 返回与给定别名关联的密钥，并用给定密码来恢复它。
void | KeyStore.load(InputStream stream, char[] password) 从给定输入流中加载此 KeyStore。
void | KeyStore.load(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 加载此 keystore。
Object | Provider.Service.newInstance(Object constructorParameter) 返回此服务描述的实现的新实例。
void | KeyStore.store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。
void | KeyStore.store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。

java.security.cert 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 java.security.cert 中的方法
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm) 返回实现了指定算法的 CertPathValidator 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params) 返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, Provider provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, Provider provider) 返回实现指定算法的 CertPathValidator 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, String provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, String provider) 返回实现指定算法的 CertPathValidator 对象。
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

javax.crypto 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 javax.crypto 中的方法
protected abstract SecretKey | KeyAgreementSpi.engineGenerateSecret(String algorithm) 创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
protected abstract void | CipherSpi.engineSetMode(String mode) 设置此 cipher 的模式。
protected Key | CipherSpi.engineUnwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 打开一个以前包装的密钥。
SecretKey | KeyAgreement.generateSecret(String algorithm) 创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
static Cipher | Cipher.getInstance(String transformation) 返回实现指定转换的 Cipher 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static Mac | Mac.getInstance(String algorithm) 返回实现指定 MAC 算法的 Mac 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
static Cipher | Cipher.getInstance(String transformation, Provider provider) 返回实现指定转换的 Cipher 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, Provider provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, Provider provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static Mac | Mac.getInstance(String algorithm, Provider provider) 返回实现指定 MAC 算法的 Mac 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
static Cipher | Cipher.getInstance(String transformation, String provider) 返回实现指定转换的 Cipher 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, String provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, String provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static Mac | Mac.getInstance(String algorithm, String provider) 返回实现指定 MAC 算法的 Mac 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
static int | Cipher.getMaxAllowedKeyLength(String transformation) 根据所安装的 JCE 仲裁策略文件，返回指定转换的最大密钥长度。
static AlgorithmParameterSpec | Cipher.getMaxAllowedParameterSpec(String transformation) 根据仲裁策略文件，返回包含最大 Cipher 参数值的 AlgorithmParameterSpec 对象。
Object | SealedObject.getObject(Key key) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。
Key | Cipher.unwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 解包一个以前包装的密钥。

抛出 NoSuchAlgorithmException 的 javax.crypto 中的构造方法
EncryptedPrivateKeyInfo(AlgorithmParameters algParams, byte[] encryptedData)
根据加密算法参数和加密数据构造 EncryptedPrivateKeyInfo。
EncryptedPrivateKeyInfo(String algName, byte[] encryptedData)
根据加密算法名称和加密数据构造 EncryptedPrivateKeyInfo。

javax.net.ssl 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 javax.net.ssl 中的方法
protected abstract void | KeyManagerFactorySpi.engineInit(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。
static SSLContext | SSLContext.getDefault() 返回默认的 SSL 上下文。
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static SSLContext | SSLContext.getInstance(String protocol) 返回实现指定安全套接字协议的 SSLContext 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, Provider provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static SSLContext | SSLContext.getInstance(String protocol, Provider provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, Provider provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, String provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static SSLContext | SSLContext.getInstance(String protocol, String provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, String provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
void | KeyManagerFactory.init(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。

javax.security.auth.login 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 javax.security.auth.login 中的方法
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, Provider provider) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, String provider) 返回指定类型的 Configuration 对象。

javax.security.cert 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 javax.security.cert 中的方法
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

javax.xml.crypto.dsig 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 javax.xml.crypto.dsig 中的方法
static TransformService | TransformService.getInstance(String algorithm, String mechanismType) 返回支持指定算法 URI 的 TransformService（比如：Transform.XPATH2）和机制类型（比如：DOM）。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, Provider provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, String provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract DigestMethod | XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params) 针对指定的算法 URI 和参数创建 DigestMethod。
abstract SignatureMethod | XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params) 针对指定的算法 URI 和参数创建 SignatureMethod。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params) 针对指定的算法 URI 和参数创建 Transform。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 Transform。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.NoSuchProviderException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.NoSuchProviderException
的使用

使用 NoSuchProviderException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.cert | 为公钥证书提供类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

java.security 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 java.security 中的方法
static Policy | Policy.getInstance(String type, Policy.Parameters params, String provider) 返回指定类型的 Policy 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, String provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static KeyStore | KeyStore.getInstance(String type, String provider) 返回指定类型的 keystore 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, String provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static Signature | Signature.getInstance(String algorithm, String provider) 返回实现指定签名算法的 Signature 对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, String provider) 返回指定算法的参数对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, String provider) 返回实现指定摘要算法的 MessageDigest 对象。

java.security.cert 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 java.security.cert 中的方法
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, String provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, String provider) 返回实现指定算法的 CertPathValidator 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, String provider) 返回指定证书类型的 CertificateFactory 对象。
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

javax.crypto 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.crypto 中的方法
static Cipher | Cipher.getInstance(String transformation, String provider) 返回实现指定转换的 Cipher 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, String provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, String provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static Mac | Mac.getInstance(String algorithm, String provider) 返回实现指定 MAC 算法的 Mac 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。

javax.net.ssl 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.net.ssl 中的方法
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, String provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static SSLContext | SSLContext.getInstance(String protocol, String provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, String provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。

javax.security.auth.login 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.security.auth.login 中的方法
static Configuration Configuration.getInstance(String type, Configuration.Parameters params, String provider)
返回指定类型的 Configuration 对象。

javax.security.cert 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.security.cert 中的方法
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

javax.xml.crypto.dsig 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.xml.crypto.dsig 中的方法
static XMLSignatureFactory | XMLSignatureFactory.getInstance(String mechanismType, String provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, String provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。

javax.xml.crypto.dsig.keyinfo 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.xml.crypto.dsig.keyinfo 中的方法
static KeyInfoFactory KeyInfoFactory.getInstance(String mechanismType, String provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.Permission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Permission
的使用

使用 Permission 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.awt 中 Permission 的使用

java.awt 中 Permission 的子类
 class AWTPermission
此类用于 AWT 权限。

java.io 中 Permission 的使用

java.io 中 Permission 的子类
class | FilePermission 此类表示对文件和目录的访问。
class | SerializablePermission 此类用于可序列化权限。

参数类型为 Permission 的 java.io 中的方法
 boolean FilePermission.implies(Permission p)
检查 FilePermission 对象是否“隐含”指定的权限。

java.lang 中 Permission 的使用

java.lang 中 Permission 的子类
 class RuntimePermission
该类用于运行时权限。

参数类型为 Permission 的 java.lang 中的方法
void | SecurityManager.checkPermission(Permission perm) 如果基于当前有效的安全策略，不允许执行根据给定权限所指定的请求访问，则抛出 SecurityException。
void | SecurityManager.checkPermission(Permission perm, Object context) 如果拒绝指定的安全上下文访问由给定权限所指定的资源，则抛出 SecurityException。

java.lang.management 中 Permission 的使用

java.lang.management 中 Permission 的子类
 class ManagementPermission
使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。

java.lang.reflect 中 Permission 的使用

java.lang.reflect 中 Permission 的子类
 class ReflectPermission
反射操作的 Permission 类。

java.net 中 Permission 的使用

java.net 中 Permission 的子类
class | NetPermission 此类可用于各种网络权限。
class | SocketPermission 此类表示通过套接字对网络的访问。

返回 Permission 的 java.net 中的方法
Permission | HttpURLConnection.getPermission()
Permission | URLConnection.getPermission() 返回一个权限对象，其代表建立此对象表示的连接所需的权限。

参数类型为 Permission 的 java.net 中的方法
 boolean SocketPermission.implies(Permission p)
检查此套接字权限对象是否“暗含”指定的权限。

java.security 中 Permission 的使用

java.security 中 Permission 的子类
class | AllPermission AllPermission 是暗含所有其他权限的权限。
class | BasicPermission BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
class | SecurityPermission 此类用于安全权限。
class | UnresolvedPermission UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。

返回 Permission 的 java.security 中的方法
 Permission AccessControlException.getPermission()
获取与此异常关联的 Permission 对象；如果不存在相应的 Permission 对象，则为 null。

返回变量类型为 Permission 的类型的 java.security 中的方法
Enumeration<Permission> | Permissions.elements() 返回此 Permissions 对象中所有 PermissionCollection 中的所有 Permission 对象的枚举。
abstract Enumeration<Permission> | PermissionCollection.elements() 返回集合中所有 Permission 对象的枚举。

参数类型为 Permission 的 java.security 中的方法
void | Permissions.add(Permission permission) 将一个 permission 对象添加到该权限所属的类的 PermissionCollection 中。
abstract void | PermissionCollection.add(Permission permission) 将一个权限对象添加到当前权限对象的集合。
static void | AccessController.checkPermission(Permission perm) 基于当前 AccessControlContext 和安全策略确定是否允许指定权限所指示的访问请求。
void | AccessControlContext.checkPermission(Permission perm) 基于当前生效的安全策略和此对象中的上下文确定是否允许指定权限指示的访问请求。
protected abstract boolean | PolicySpi.engineImplies(ProtectionDomain domain, Permission permission) 检查该策略是否已将 Permission 授予 ProtectionDomain。
boolean | UnresolvedPermission.implies(Permission p) 对于未解析的权限，此方法始终返回 false。
boolean | AllPermission.implies(Permission p) 检查此对象是否“暗含”指定的权限。
boolean | Permissions.implies(Permission permission) 查看此对象用于指定 permission 类的 permissions 的 PermissionCollection 是否暗含了 permission 对象中表示的权限。
abstract boolean | PermissionCollection.implies(Permission permission) 查看此 PermissionCollection 中保存的 Permission 对象集合是否暗含指定的权限。
boolean | BasicPermission.implies(Permission p) 检查此对象是否“暗含”指定的权限。
abstract boolean | Permission.implies(Permission permission) 检查此对象的操作是否“暗含”指定权限的操作。
boolean | ProtectionDomain.implies(Permission permission) 查看此 ProtectionDomain 是否暗含了 Permission 对象中表示的权限。
boolean | Policy.implies(ProtectionDomain domain, Permission permission) 计算授予 ProtectionDomain 的权限的全局策略，并测试是否授予了该权限。

参数类型为 Permission 的 java.security 中的构造方法
AccessControlException(String s, Permission p)
构造带指定详细消息和导致异常的请求权限的 AccessControlException。

java.sql 中 Permission 的使用

java.sql 中 Permission 的子类
 class SQLPermission
SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。

java.util 中 Permission 的使用

java.util 中 Permission 的子类
 class PropertyPermission
此类用于属性权限。

参数类型为 Permission 的 java.util 中的方法
 boolean PropertyPermission.implies(Permission p)
检查 PropertyPermission 对象是否“暗指”指定的权限。

java.util.logging 中 Permission 的使用

java.util.logging 中 Permission 的子类
 class LoggingPermission
当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。

javax.management 中 Permission 的使用

javax.management 中 Permission 的子类
class | MBeanPermission 权限控制对 MBeanServer 操作的访问。
class | MBeanServerPermission 执行与 MBeanServer 关联的操作的 Permission。
class | MBeanTrustPermission 此权限表示“信任”签名者或代码基。

参数类型为 Permission 的 javax.management 中的方法
boolean | MBeanPermission.implies(Permission p) 检查此 MBeanPermission 对象是否“隐含”指定的权限。
boolean | MBeanServerPermission.implies(Permission p) 检查此 MBeanServerPermission 对象是否“隐含”指定的权限。

javax.management.remote 中 Permission 的使用

javax.management.remote 中 Permission 的子类
 class SubjectDelegationPermission
授权标识表示验证标识执行操作所需的权限。

javax.net.ssl 中 Permission 的使用

javax.net.ssl 中 Permission 的子类
 class SSLPermission
此类用于各种网络权限。

javax.security.auth 中 Permission 的使用

javax.security.auth 中 Permission 的子类
class | AuthPermission 此类用于验证权限。
class | PrivateCredentialPermission 此类用来保护对属于特定 Subject 的私有 Credential 的访问。

参数类型为 Permission 的 javax.security.auth 中的方法
 boolean PrivateCredentialPermission.implies(Permission p)
检查此 PrivateCredentialPermission 是否暗含指定的Permission。

javax.security.auth.kerberos 中 Permission 的使用

javax.security.auth.kerberos 中 Permission 的子类
class | DelegationPermission 此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。
class | ServicePermission 此类用于保护 Kerberos 服务和访问这些服务所必需的证书。

参数类型为 Permission 的 javax.security.auth.kerberos 中的方法
boolean | DelegationPermission.implies(Permission p) 检查此 Kerberos 代理权限对象是否“隐含”指定的权限。
boolean | ServicePermission.implies(Permission p) 检查此 Kerberos 服务权限对象是否“隐含”指定的权限。

javax.sound.sampled 中 Permission 的使用

javax.sound.sampled 中 Permission 的子类
 class AudioPermission
AudioPermission 类表示对音频系统资源的访问权限。

javax.xml.ws 中 Permission 的使用

javax.xml.ws 中 Permission 的子类
 class WebServicePermission
此类定义 Web 服务权限。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.PermissionCollection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.PermissionCollection
的使用

使用 PermissionCollection 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。

java.io 中 PermissionCollection 的使用

返回 PermissionCollection 的 java.io 中的方法
 PermissionCollection FilePermission.newPermissionCollection()
返回用于存储 FilePermission 对象的新 PermissionCollection 对象。

java.net 中 PermissionCollection 的使用

返回 PermissionCollection 的 java.net 中的方法
protected PermissionCollection | URLClassLoader.getPermissions(CodeSource codesource) 返回给定 codesource 对象的权限。
PermissionCollection | SocketPermission.newPermissionCollection() 用于存储 SocketPermission 对象的新 PermissionCollection 对象。

java.security 中 PermissionCollection 的使用

java.security 中 PermissionCollection 的子类
 class Permissions
此类表示一个不同种类的 Permission 集合。

声明为 PermissionCollection 的 java.security 中的字段
static PermissionCollection Policy.UNSUPPORTED_EMPTY_COLLECTION
一个空的只读 PermissionCollection 实例。

返回 PermissionCollection 的 java.security 中的方法
protected PermissionCollection | PolicySpi.engineGetPermissions(CodeSource codesource) 返回包含授予指定 CodeSource 的权限集的 PermissionCollection 对象。
protected PermissionCollection | PolicySpi.engineGetPermissions(ProtectionDomain domain) 返回包含授予指定 ProtectionDomain 的权限集的 PermissionCollection 对象。
PermissionCollection | ProtectionDomain.getPermissions() 返回授予此域的静态权限。
PermissionCollection | Policy.getPermissions(CodeSource codesource) 返回一个 PermissionCollection 对象，它包含授予指定 CodeSource 的权限集。
protected PermissionCollection | SecureClassLoader.getPermissions(CodeSource codesource) 返回给定的 CodeSource 对象的权限。
PermissionCollection | Policy.getPermissions(ProtectionDomain domain) 返回一个 PermissionCollection 对象，它包含授予指定 ProtectionDomain 的权限集。
PermissionCollection | UnresolvedPermission.newPermissionCollection() 返回存储 UnresolvedPermission 对象的新 PermissionCollection 对象。
PermissionCollection | AllPermission.newPermissionCollection() 返回用于存储 AllPermission 对象的新 PermissionCollection 对象。
PermissionCollection | BasicPermission.newPermissionCollection() 用于存储 BasicPermission 对象的新 PermissionCollection 对象。
PermissionCollection | Permission.newPermissionCollection() 对给定 Permission 对象返回空 PermissionCollection，如果没有定义则返回 null。

参数类型为 PermissionCollection 的 java.security 中的构造方法
ProtectionDomain(CodeSource codesource, PermissionCollection permissions)
创建具有给定 CodeSource 和 Permissions 的新 ProtectionDomain。
ProtectionDomain(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。

java.util 中 PermissionCollection 的使用

返回 PermissionCollection 的 java.util 中的方法
 PermissionCollection PropertyPermission.newPermissionCollection()
用于存储 PropertyPermission 对象的新 PermissionCollection 对象。

javax.management 中 PermissionCollection 的使用

返回 PermissionCollection 的 javax.management 中的方法
 PermissionCollection MBeanServerPermission.newPermissionCollection()

javax.security.auth 中 PermissionCollection 的使用

返回 PermissionCollection 的 javax.security.auth 中的方法
abstract PermissionCollection | Policy.getPermissions(Subject subject, CodeSource cs) 已过时。 获取授予与指定的 CodeSource 关联的 Principals 的 Permissions。
PermissionCollection | PrivateCredentialPermission.newPermissionCollection() 返回 PermissionCollection 中同类的 PrivateCredentialPermissions 集合。

javax.security.auth.kerberos 中 PermissionCollection 的使用

返回 PermissionCollection 的 javax.security.auth.kerberos 中的方法
PermissionCollection | DelegationPermission.newPermissionCollection() 返回用于存储 DelegationPermission 对象的 PermissionCollection 对象。
PermissionCollection | ServicePermission.newPermissionCollection() 返回用于存储 ServicePermission 对象的 PermissionCollection 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.Permissions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Permissions
的使用

没有 java.security.Permissions 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.Policy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Policy
的使用

使用 Policy 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Policy 的使用

返回 Policy 的 java.security 中的方法
static Policy | Policy.getInstance(String type, Policy.Parameters params) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, Provider provider) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, String provider) 返回指定类型的 Policy 对象。
static Policy | Policy.getPolicy() 返回安装的 Policy 对象。

参数类型为 Policy 的 java.security 中的方法
static void Policy.setPolicy(Policy p)
设置系统范围的 Policy 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.Policy.Parameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.Policy.Parameters
的使用

使用 Policy.Parameters 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Policy.Parameters 的使用

实现 Policy.Parameters 的 java.security 中的类
 class URIParameter
包含一个 URI 的参数，该 URI 指向用于 PolicySpi 或 ConfigurationSpi 实现的数据。

返回 Policy.Parameters 的 java.security 中的方法
 Policy.Parameters Policy.getParameters()
返回 Policy 参数。

参数类型为 Policy.Parameters 的 java.security 中的方法
static Policy | Policy.getInstance(String type, Policy.Parameters params) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, Provider provider) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, String provider) 返回指定类型的 Policy 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.PolicySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.PolicySpi
的使用

没有 java.security.PolicySpi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.Principal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.Principal
的使用

使用 Principal 的软件包
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.cert | 为公钥证书提供类。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.net 中 Principal 的使用

返回 Principal 的 java.net 中的方法
abstract Principal | SecureCacheResponse.getLocalPrincipal() 返回在获得了网络资源的初始连接中的联络期间发送到服务器的主体。
abstract Principal | SecureCacheResponse.getPeerPrincipal() 返回服务器的主体，该主体是作为在获得了网络资源的初始连接期间定义会话的一部分建立的。

java.security 中 Principal 的使用

实现 Principal 的 java.security 中的类
class | Identity 已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | IdentityScope 已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | Signer 已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。

返回 Principal 的 java.security 中的方法
Principal | Certificate.getGuarantor() 已过时。 返回证书的保证人，即某个主体，其保证与此证书关联的公钥是与此证书关联的主体的公钥。
Principal | Certificate.getPrincipal() 已过时。 返回保证人所保证的主体密钥对的主体。
Principal[] | ProtectionDomain.getPrincipals() 返回此域的 principals 数组。

参数类型为 Principal 的 java.security 中的方法
 Identity IdentityScope.getIdentity(Principal principal)
已过时。 获取名称与指定的主体相同的身份。

参数类型为 Principal 的 java.security 中的构造方法
ProtectionDomain(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。

java.security.acl 中 Principal 的使用

java.security.acl 中 Principal 的子接口
 interface Group
此接口用于表示一个主体组。

返回 Principal 的 java.security.acl 中的方法
 Principal AclEntry.getPrincipal()
返回此 ACL 项将为其授予或拒绝权限的主体。

返回变量类型为 Principal 的类型的 java.security.acl 中的方法
 Enumeration<? extends Principal> Group.members()
返回此组中成员的枚举。

参数类型为 Principal 的 java.security.acl 中的方法
boolean | Acl.addEntry(Principal caller, AclEntry entry) 向此 ACL 中添加 ACL 项。
boolean | Group.addMember(Principal user) 向组中添加指定的成员。
boolean | Owner.addOwner(Principal caller, Principal owner) 添加一个所有者。
boolean | Acl.checkPermission(Principal principal, Permission permission) 检查指定的主体是否具有指定的权限。
boolean | Owner.deleteOwner(Principal caller, Principal owner) 删除一个所有者。
Enumeration<Permission> | Acl.getPermissions(Principal user) 返回一个指定主体（表示一个实体，如个体或组）的许可权限集合的枚举。
boolean | Group.isMember(Principal member) 如果传递的主体是组的一个成员，则返回 true。
boolean | Owner.isOwner(Principal owner) 如果给定的主体是该 ACL 的所有者，则返回 true。
boolean | Acl.removeEntry(Principal caller, AclEntry entry) 从此 ACL 中移除 ACL 项。
boolean | Group.removeMember(Principal user) 从组中移除指定的成员。
void | Acl.setName(Principal caller, String name) 设置此 ACL 的名称。
boolean | AclEntry.setPrincipal(Principal user) 指定此 ACL 项要为其授予或拒绝权限的主体。

java.security.cert 中 Principal 的使用

返回 Principal 的 java.security.cert 中的方法
abstract  Principal X509CRL.getIssuerDN()
已过时，由 X509CRL.getIssuerX500Principal() 替代。
abstract  Principal X509Certificate.getIssuerDN()
已过时，由 X509Certificate.getIssuerX500Principal() 替代。
abstract  Principal X509Certificate.getSubjectDN()
已过时，由 X509Certificate.getSubjectX500Principal() 替代。

javax.management.remote 中 Principal 的使用

实现 Principal 的 javax.management.remote 中的类
 class JMXPrincipal
JMX Remote API 的远程客户端的身份。

javax.net.ssl 中 Principal 的使用

返回 Principal 的 javax.net.ssl 中的方法
Principal | HandshakeCompletedEvent.getLocalPrincipal() 返回握手期间发送到同位体的主体。
Principal | SSLSession.getLocalPrincipal() 返回握手期间发送给同位体的主体。
Principal | HttpsURLConnection.getLocalPrincipal() 返回握手期间发送到服务器的主体。
Principal | HandshakeCompletedEvent.getPeerPrincipal() 返回同位体的标识，同位体是作为定义会话的一部分而建立的。
Principal | SSLSession.getPeerPrincipal() 返回同级身份，该同级身份是作为定义会话的一部分而建立的。
Principal | HttpsURLConnection.getPeerPrincipal() 返回服务器的主体，它是作为定义会话的一部分而建立的。

参数类型为 Principal 的 javax.net.ssl 中的方法
String | X509KeyManager.chooseClientAlias(String[] keyType, Principal[] issuers, Socket socket) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。
String | X509ExtendedKeyManager.chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine) 选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。
String | X509ExtendedKeyManager.chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine) 选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。
String | X509KeyManager.chooseServerAlias(String keyType, Principal[] issuers, Socket socket) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。
String[] | X509KeyManager.getClientAliases(String keyType, Principal[] issuers) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字客户端的匹配别名。
String[] | X509KeyManager.getServerAliases(String keyType, Principal[] issuers) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字服务器端的别名。

javax.security.auth 中 Principal 的使用

类型参数类型为 Principal 的 javax.security.auth 中的方法
<T extends Principal>
Set<T>
Subject.getPrincipals(Class<T> c)
返回与此 Subject 关联的 Principal Set，它是指定的 Class 的实例或子类。

返回变量类型为 Principal 的类型的 javax.security.auth 中的方法
 Set<Principal> Subject.getPrincipals()
返回与此 Subject 关联的 Principal Set。

类型变量类型为 Principal 的 javax.security.auth 中的构造方法参数
Subject(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
创建带有 Principal 和证书的 Subject 的实例。

javax.security.auth.kerberos 中 Principal 的使用

实现 Principal 的 javax.security.auth.kerberos 中的类
 class KerberosPrincipal
此类封装 Kerberos 主体。

javax.security.auth.x500 中 Principal 的使用

实现 Principal 的 javax.security.auth.x500 中的类
 class X500Principal
此类表示一个 X.500 Principal。

javax.security.cert 中 Principal 的使用

返回 Principal 的 javax.security.cert 中的方法
abstract Principal | X509Certificate.getIssuerDN() 获取证书的 issuer（发布方的标识名）值。
abstract Principal | X509Certificate.getSubjectDN() 获取证书的 subject（主体的标识名）值。

javax.xml.ws 中 Principal 的使用

返回 Principal 的 javax.xml.ws 中的方法
 Principal WebServiceContext.getUserPrincipal()
返回标识当前正服务请求发送方的 Principal。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.PrivateKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.PrivateKey
的使用

使用 PrivateKey 的软件包
java.security | 为安全框架提供类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

java.security 中 PrivateKey 的使用

返回 PrivateKey 的 java.security 中的方法
protected abstract PrivateKey | KeyFactorySpi.engineGeneratePrivate(KeySpec keySpec) 根据所提供的密钥规范（密钥材料）生成私钥对象。
PrivateKey | KeyFactory.generatePrivate(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成私钥对象。
PrivateKey | KeyPair.getPrivate() 返回对此密钥对的私钥组件的引用。
PrivateKey | KeyStore.PrivateKeyEntry.getPrivateKey() 从此项获取 PrivateKey。
PrivateKey | Signer.getPrivateKey() 已过时。 返回此 signer 的私钥。

参数类型为 PrivateKey 的 java.security 中的方法
protected abstract void | SignatureSpi.engineInitSign(PrivateKey privateKey) 通过用于签名操作的指定私钥初始化此签名对象。
protected void | SignatureSpi.engineInitSign(PrivateKey privateKey, SecureRandom random) 通过用于签名操作的指定私钥和随机源初始化此签名对象。
void | Signature.initSign(PrivateKey privateKey) 初始化这个用于签名的对象。
void | Signature.initSign(PrivateKey privateKey, SecureRandom random) 初始化这个用于签名的对象。

参数类型为 PrivateKey 的 java.security 中的构造方法
KeyPair(PublicKey publicKey, PrivateKey privateKey)
根据给定的公钥和私钥构造密钥对。
KeyStore.PrivateKeyEntry(PrivateKey privateKey, Certificate[] chain)
构造带 PrivateKey 和相应证书链的 PrivateKeyEntry。
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

java.security.interfaces 中 PrivateKey 的使用

java.security.interfaces 中 PrivateKey 的子接口
interface | DSAPrivateKey DSA 专用密钥的标准接口。
interface | ECPrivateKey 椭圆曲线 (EC) 专用密钥的接口。
interface | RSAMultiPrimePrivateCrtKey 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
interface | RSAPrivateCrtKey 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
interface | RSAPrivateKey RSA 专用密钥的接口。

javax.crypto.interfaces 中 PrivateKey 的使用

javax.crypto.interfaces 中 PrivateKey 的子接口
 interface DHPrivateKey
Diffie-Hellman 私钥接口。

javax.net.ssl 中 PrivateKey 的使用

返回 PrivateKey 的 javax.net.ssl 中的方法
 PrivateKey X509KeyManager.getPrivateKey(String alias)
返回与给定别名关联的密钥。

javax.security.auth.x500 中 PrivateKey 的使用

返回 PrivateKey 的 javax.security.auth.x500 中的方法
 PrivateKey X500PrivateCredential.getPrivateKey()
返回 PrivateKey。

参数类型为 PrivateKey 的 javax.security.auth.x500 中的构造方法
X500PrivateCredential(X509Certificate cert, PrivateKey key)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。
X500PrivateCredential(X509Certificate cert, PrivateKey key, String alias)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.PrivilegedAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.PrivilegedAction
的使用

使用 PrivilegedAction 的软件包
java.security | 为安全框架提供类和接口。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.security 中 PrivilegedAction 的使用

参数类型为 PrivilegedAction 的 java.security 中的方法
static
<T> T
AccessController.doPrivileged(PrivilegedAction<T> action)
启用特权，执行指定的 PrivilegedAction。
static
<T> T
AccessController.doPrivileged(PrivilegedAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedAction。
static
<T> T
AccessController.doPrivilegedWithCombiner(PrivilegedAction<T> action)
启用特权，执行指定的 PrivilegedAction。

java.util.concurrent 中 PrivilegedAction 的使用

参数类型为 PrivilegedAction 的 java.util.concurrent 中的方法
static Callable<Object> Executors.callable(PrivilegedAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的操作并返回其结果。

javax.security.auth 中 PrivilegedAction 的使用

参数类型为 PrivilegedAction 的 javax.security.auth 中的方法
static
<T> T
Subject.doAs(Subject subject, PrivilegedAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.PrivilegedActionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.PrivilegedActionException
的使用

使用 PrivilegedActionException 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.security 中 PrivilegedActionException 的使用

抛出 PrivilegedActionException 的 java.security 中的方法
static
<T> T
AccessController.doPrivileged(PrivilegedExceptionAction<T> action)
启用特权，执行指定的 PrivilegedExceptionAction。
static
<T> T
AccessController.doPrivileged(PrivilegedExceptionAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedExceptionAction。
static
<T> T
AccessController.doPrivilegedWithCombiner(PrivilegedExceptionAction<T> action)
启用特权，执行指定的 PrivilegedExceptionAction。

javax.security.auth 中 PrivilegedActionException 的使用

抛出 PrivilegedActionException 的 javax.security.auth 中的方法
static
<T> T
Subject.doAs(Subject subject, PrivilegedExceptionAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.PrivilegedExceptionAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.PrivilegedExceptionAction
的使用

使用 PrivilegedExceptionAction 的软件包
java.security | 为安全框架提供类和接口。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.security 中 PrivilegedExceptionAction 的使用

参数类型为 PrivilegedExceptionAction 的 java.security 中的方法
static
<T> T
AccessController.doPrivileged(PrivilegedExceptionAction<T> action)
启用特权，执行指定的 PrivilegedExceptionAction。
static
<T> T
AccessController.doPrivileged(PrivilegedExceptionAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedExceptionAction。
static
<T> T
AccessController.doPrivilegedWithCombiner(PrivilegedExceptionAction<T> action)
启用特权，执行指定的 PrivilegedExceptionAction。

java.util.concurrent 中 PrivilegedExceptionAction 的使用

参数类型为 PrivilegedExceptionAction 的 java.util.concurrent 中的方法
static Callable<Object> Executors.callable(PrivilegedExceptionAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的异常操作并返回其结果。

javax.security.auth 中 PrivilegedExceptionAction 的使用

参数类型为 PrivilegedExceptionAction 的 javax.security.auth 中的方法
static
<T> T
Subject.doAs(Subject subject, PrivilegedExceptionAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.ProtectionDomain 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.ProtectionDomain
的使用

使用 ProtectionDomain 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.lang 中 ProtectionDomain 的使用

返回 ProtectionDomain 的 java.lang 中的方法
 ProtectionDomain Class.getProtectionDomain()
返回该类的 ProtectionDomain。

参数类型为 ProtectionDomain 的 java.lang 中的方法
protected Class<?> | ClassLoader.defineClass(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain) 使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。
protected Class<?> | ClassLoader.defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain) 使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。

java.lang.instrument 中 ProtectionDomain 的使用

参数类型为 ProtectionDomain 的 java.lang.instrument 中的方法
 byte[] ClassFileTransformer.transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

java.security 中 ProtectionDomain 的使用

返回 ProtectionDomain 的 java.security 中的方法
 ProtectionDomain[] DomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
修改或更新提供的 ProtectionDomain。

参数类型为 ProtectionDomain 的 java.security 中的方法
ProtectionDomain[] | DomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains) 修改或更新提供的 ProtectionDomain。
ProtectionDomain[] | DomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains) 修改或更新提供的 ProtectionDomain。
protected PermissionCollection | PolicySpi.engineGetPermissions(ProtectionDomain domain) 返回包含授予指定 ProtectionDomain 的权限集的 PermissionCollection 对象。
protected abstract boolean | PolicySpi.engineImplies(ProtectionDomain domain, Permission permission) 检查该策略是否已将 Permission 授予 ProtectionDomain。
PermissionCollection | Policy.getPermissions(ProtectionDomain domain) 返回一个 PermissionCollection 对象，它包含授予指定 ProtectionDomain 的权限集。
boolean | Policy.implies(ProtectionDomain domain, Permission permission) 计算授予 ProtectionDomain 的权限的全局策略，并测试是否授予了该权限。

参数类型为 ProtectionDomain 的 java.security 中的构造方法
AccessControlContext(ProtectionDomain[] context)
创建带有给定 ProtectionDomain 集合的 AccessControlContext。

javax.security.auth 中 ProtectionDomain 的使用

返回 ProtectionDomain 的 javax.security.auth 中的方法
 ProtectionDomain[] SubjectDomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
使用与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新相关的 ProtectionDomains。

参数类型为 ProtectionDomain 的 javax.security.auth 中的方法
ProtectionDomain[] | SubjectDomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains) 使用与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新相关的 ProtectionDomains。
ProtectionDomain[] | SubjectDomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains) 使用与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新相关的 ProtectionDomains。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.Provider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Provider
的使用

使用 Provider 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

java.security 中 Provider 的使用

java.security 中 Provider 的子类
 class AuthProvider
此类定义 provider 的登录和注销方法。

返回 Provider 的 java.security 中的方法
Provider | AlgorithmParameterGenerator.getProvider() 返回此算法参数生成器对象的提供者。
Provider | KeyPairGenerator.getProvider() 返回此密钥对生成器对象的提供者。
Provider | KeyStore.getProvider() 返回此 keystore 的提供者。
Provider | SecureRandom.getProvider() 返回此 SecureRandom 对象的提供者。
Provider | Signature.getProvider() 返回此签名对象的提供者。
Provider | AlgorithmParameters.getProvider() 返回此参数对象的提供者。
Provider | KeyFactory.getProvider() 返回此密钥工厂对象的提供者。
Provider | MessageDigest.getProvider() 返回此信息摘要对象的提供者。
Provider | Provider.Service.getProvider() 返回此服务的 Provider。
Provider | Policy.getProvider() 返回此 Policy 的 Provider。
static Provider | Security.getProvider(String name) 返回使用指定的名称安装的提供者（如果有）。
static Provider[] | Security.getProviders() 返回包含所有已安装的提供者的数组。
static Provider[] | Security.getProviders(Map<String,String> filter) 返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。
static Provider[] | Security.getProviders(String filter) 返回包含满足指定的选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。

参数类型为 Provider 的 java.security 中的方法
static int | Security.addProvider(Provider provider) 将提供者添加到下一个可用位置。
static Policy | Policy.getInstance(String type, Policy.Parameters params, Provider provider) 返回指定类型的 Policy 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, Provider provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static KeyStore | KeyStore.getInstance(String type, Provider provider) 返回指定类型的 keystore 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, Provider provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static Signature | Signature.getInstance(String algorithm, Provider provider) 返回实现指定签名算法的 Signature 对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, Provider provider) 返回指定算法的参数对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, Provider provider) 返回实现指定摘要算法的 MessageDigest 对象。
static int | Security.insertProviderAt(Provider provider, int position) 在指定的位置添加新的提供者。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。

参数类型为 Provider 的 java.security 中的构造方法
AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameterGenerator 对象。
AlgorithmParameters(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameters 对象。
KeyFactory(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 KeyFactory 对象。
KeyStore(KeyStoreSpi keyStoreSpi, Provider provider, String type)
创建给定类型的 KeyStore 对象，并在其中封装给定的提供者实现（SPI 对象）。
Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。
SecureRandom(SecureRandomSpi secureRandomSpi, Provider provider)
创建 SecureRandom 对象。

java.security.cert 中 Provider 的使用

返回 Provider 的 java.security.cert 中的方法
Provider | CertPathBuilder.getProvider() 返回此 CertPathBuilder 的提供者。
Provider | CertPathValidator.getProvider() 返回此 CertPathValidator 的 Provider。
Provider | CertStore.getProvider() 返回此 CertStore 的提供者。
Provider | CertificateFactory.getProvider() 返回此 CertificateFactory 的提供者。

参数类型为 Provider 的 java.security.cert 中的方法
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, Provider provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, Provider provider) 返回实现指定算法的 CertPathValidator 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, Provider provider) 返回指定证书类型的 CertificateFactory 对象。

参数类型为 Provider 的 java.security.cert 中的构造方法
CertificateFactory(CertificateFactorySpi certFacSpi, Provider provider, String type)
创建给定类型的 CertificateFactory 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertPathBuilder(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathBuilder 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertPathValidator(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathValidator 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertStore(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。

javax.crypto 中 Provider 的使用

返回 Provider 的 javax.crypto 中的方法
Provider | Cipher.getProvider() 返回此 Cipher 对象的提供者。
Provider | ExemptionMechanism.getProvider() 返回此 ExemptionMechanism 对象的提供者。
Provider | KeyAgreement.getProvider() 返回此 KeyAgreement 对象的提供者。
Provider | KeyGenerator.getProvider() 返回此 KeyGenerator 对象的提供者。
Provider | Mac.getProvider() 返回此 Mac 对象的提供者。
Provider | SecretKeyFactory.getProvider() 返回此 SecretKeyFactory 对象的提供者。

参数类型为 Provider 的 javax.crypto 中的方法
static Cipher | Cipher.getInstance(String transformation, Provider provider) 返回实现指定转换的 Cipher 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, Provider provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, Provider provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static Mac | Mac.getInstance(String algorithm, Provider provider) 返回实现指定 MAC 算法的 Mac 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。

参数类型为 Provider 的 javax.crypto 中的构造方法
Cipher(CipherSpi cipherSpi, Provider provider, String transformation)
创建 Cipher 对象。
ExemptionMechanism(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)
创建 ExemptionMechanism 对象。
KeyAgreement(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)
创建一个 KeyAgreement 对象。
KeyGenerator(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)
创建一个 KeyGenerator 对象。
Mac(MacSpi macSpi, Provider provider, String algorithm)
创建一个 MAC 对象。
SecretKeyFactory(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 SecretKeyFactory 对象。

javax.net.ssl 中 Provider 的使用

返回 Provider 的 javax.net.ssl 中的方法
Provider | KeyManagerFactory.getProvider() 返回此 KeyManagerFactory 对象的提供者。
Provider | SSLContext.getProvider() 返回此 SSLContext 对象的提供者。
Provider | TrustManagerFactory.getProvider() 返回此 TrustManagerFactory 对象的提供者。

参数类型为 Provider 的 javax.net.ssl 中的方法
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, Provider provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static SSLContext | SSLContext.getInstance(String protocol, Provider provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, Provider provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。

参数类型为 Provider 的 javax.net.ssl 中的构造方法
KeyManagerFactory(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 KeyManagerFactory 对象。
SSLContext(SSLContextSpi contextSpi, Provider provider, String protocol)
创建 SSLContext 对象。
TrustManagerFactory(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 TrustManagerFactory 对象。

javax.security.auth.login 中 Provider 的使用

返回 Provider 的 javax.security.auth.login 中的方法
 Provider Configuration.getProvider()
返回此 Configuration 的 Provider。

参数类型为 Provider 的 javax.security.auth.login 中的方法
static Configuration Configuration.getInstance(String type, Configuration.Parameters params, Provider provider)
返回指定类型的 Configuration 对象。

javax.xml.crypto.dsig 中 Provider 的使用

返回 Provider 的 javax.xml.crypto.dsig 中的方法
Provider | TransformService.getProvider() 返回此 TransformService 的提供者。
Provider | XMLSignatureFactory.getProvider() 返回此 XMLSignatureFactory 的提供者。

参数类型为 Provider 的 javax.xml.crypto.dsig 中的方法
static XMLSignatureFactory | XMLSignatureFactory.getInstance(String mechanismType, Provider provider) 返回支持请求的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, Provider provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。

javax.xml.crypto.dsig.keyinfo 中 Provider 的使用

返回 Provider 的 javax.xml.crypto.dsig.keyinfo 中的方法
 Provider KeyInfoFactory.getProvider()
返回此 KeyInfoFactory 的提供者。

参数类型为 Provider 的 javax.xml.crypto.dsig.keyinfo 中的方法
static KeyInfoFactory KeyInfoFactory.getInstance(String mechanismType, Provider provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。

org.ietf.jgss 中 Provider 的使用

参数类型为 Provider 的 org.ietf.jgss 中的方法
abstract void | GSSManager.addProviderAtEnd(Provider p, Oid mech) 此方法用于向 GSSManager 指示，如果没有其他的提供者支持指定的机制，则应用程序将使用特定的提供者。
abstract void | GSSManager.addProviderAtFront(Provider p, Oid mech) 此方法用来向 GSSManager 表示，当支持是指定的机制所需要的支持时，应用程序希望优先于其他所有提供者使用特定的提供者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.Provider.Service 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Provider.Service
的使用

使用 Provider.Service 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Provider.Service 的使用

返回 Provider.Service 的 java.security 中的方法
 Provider.Service Provider.getService(String type, String algorithm)
获取描述此算法或别名的指定类型的此 Provider 实现的服务。

返回变量类型为 Provider.Service 的类型的 java.security 中的方法
 Set<Provider.Service> Provider.getServices()
获取此 Provider 支持的所有服务的一个不可修改的 Set。

参数类型为 Provider.Service 的 java.security 中的方法
protected  void Provider.putService(Provider.Service s)
添加服务。
protected  void Provider.removeService(Provider.Service s)
移除以前用 putService() 添加的服务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.ProviderException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.ProviderException
的使用

没有 java.security.ProviderException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.PublicKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.PublicKey
的使用

使用 PublicKey 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.security.cert | 为公钥证书提供类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

java.security 中 PublicKey 的使用

返回 PublicKey 的 java.security 中的方法
protected abstract PublicKey | KeyFactorySpi.engineGeneratePublic(KeySpec keySpec) 根据所提供的密钥规范（密钥材料）生成公钥对象。
PublicKey | KeyFactory.generatePublic(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成公钥对象。
PublicKey | KeyPair.getPublic() 返回对此密钥对的公钥组件的引用。
PublicKey | Certificate.getPublicKey() 已过时。 返回保证人所保证的主体密钥对的密钥。
PublicKey | Identity.getPublicKey() 已过时。 返回此 Identity 的公钥。

参数类型为 PublicKey 的 java.security 中的方法
protected abstract void | SignatureSpi.engineInitVerify(PublicKey publicKey) 通过用于验证操作的指定公钥初始化此签名对象。
abstract Identity | IdentityScope.getIdentity(PublicKey key) 已过时。 获取具有指定公钥的身份。
void | Signature.initVerify(PublicKey publicKey) 初始化此用于验证的对象。
void | Identity.setPublicKey(PublicKey key) 已过时。 设置此 Identity 的公钥。
boolean | SignedObject.verify(PublicKey verificationKey, Signature verificationEngine) 使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。

参数类型为 PublicKey 的 java.security 中的构造方法
KeyPair(PublicKey publicKey, PrivateKey privateKey)
根据给定的公钥和私钥构造密钥对。

java.security.cert 中 PublicKey 的使用

返回 PublicKey 的 java.security.cert 中的方法
PublicKey | TrustAnchor.getCAPublicKey() 返回最受信任的 CA 的公钥。
PublicKey | PKIXCertPathValidatorResult.getPublicKey() 返回证书路径主体（目标）的公钥，如果适用，要包括所有继承的公钥参数。
abstract PublicKey | Certificate.getPublicKey() 从此证书中获取公钥。
PublicKey | X509CertSelector.getSubjectPublicKey() 返回 subjectPublicKey 标准。

参数类型为 PublicKey 的 java.security.cert 中的方法
void | X509CertSelector.setSubjectPublicKey(PublicKey key) 设置 subjectPublicKey 标准。
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

参数类型为 PublicKey 的 java.security.cert 中的构造方法
PKIXCertPathBuilderResult(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathBuilderResult 实例。
PKIXCertPathValidatorResult(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathValidatorResult 实例。
TrustAnchor(String caName, PublicKey pubKey, byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以不同的名称和公钥的形式指定最受信任的 CA。
TrustAnchor(X500Principal caPrincipal, PublicKey pubKey, byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以 X500Principal 和公钥的形式指定最受信任的 CA。

java.security.interfaces 中 PublicKey 的使用

java.security.interfaces 中 PublicKey 的子接口
interface | DSAPublicKey DSA 公用密钥的接口。
interface | ECPublicKey 椭圆曲线 (EC) 公用密钥的接口。
interface | RSAPublicKey RSA 公用密钥的接口。

javax.crypto.interfaces 中 PublicKey 的使用

javax.crypto.interfaces 中 PublicKey 的子接口
 interface DHPublicKey
Diffie-Hellman 公钥接口。

javax.security.cert 中 PublicKey 的使用

返回 PublicKey 的 javax.security.cert 中的方法
abstract  PublicKey Certificate.getPublicKey()
从此证书中获取公钥。

参数类型为 PublicKey 的 javax.security.cert 中的方法
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

javax.xml.crypto.dsig.keyinfo 中 PublicKey 的使用

返回 PublicKey 的 javax.xml.crypto.dsig.keyinfo 中的方法
 PublicKey KeyValue.getPublicKey()
返回此 KeyValue 的公钥。

参数类型为 PublicKey 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  KeyValue KeyInfoFactory.newKeyValue(PublicKey key)
根据指定的公钥创建 KeyValue。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.SecureClassLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SecureClassLoader
的使用

使用 SecureClassLoader 的软件包
java.net | 为实现网络应用程序提供类。
javax.management.loading | 提供实现高级动态加载的类。

java.net 中 SecureClassLoader 的使用

java.net 中 SecureClassLoader 的子类
 class URLClassLoader
该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。

javax.management.loading 中 SecureClassLoader 的使用

javax.management.loading 中 SecureClassLoader 的子类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.SecureRandom 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SecureRandom
的使用

使用 SecureRandom 的软件包
java.security | 为安全框架提供类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 SecureRandom 的使用

声明为 SecureRandom 的 java.security 中的字段
protected  SecureRandom SignatureSpi.appRandom
应用程序指定的随机源。

返回 SecureRandom 的 java.security 中的方法
static SecureRandom | SecureRandom.getInstance(String algorithm) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, Provider provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, String provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

参数类型为 SecureRandom 的 java.security 中的方法
protected abstract void | AlgorithmParameterGeneratorSpi.engineInit(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值的集合初始化此参数生成器。
protected abstract void | AlgorithmParameterGeneratorSpi.engineInit(int size, SecureRandom random) 针对某个特定大小和随机源初始化此参数生成器。
protected void | SignatureSpi.engineInitSign(PrivateKey privateKey, SecureRandom random) 通过用于签名操作的指定私钥和随机源初始化此签名对象。
void | AlgorithmParameterGenerator.init(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | AlgorithmParameterGenerator.init(int size, SecureRandom random) 针对某个特定大小和随机源初始化此参数生成器。
void | KeyPairGenerator.initialize(AlgorithmParameterSpec params, SecureRandom random) 使用给定参数集合和随机源初始化密钥对生成器。
void | KeyPairGeneratorSpi.initialize(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集合和用户提供的随机源初始化密钥对生成器。
void | KeyPairGenerator.initialize(int keysize, SecureRandom random) 使用给定的随机源（和默认的参数集合）初始化确定密钥大小的密钥对生成器。
abstract void | KeyPairGeneratorSpi.initialize(int keysize, SecureRandom random) 使用默认参数集初始化确定密钥大小的密钥对生成器。
void | Signature.initSign(PrivateKey privateKey, SecureRandom random) 初始化这个用于签名的对象。

java.security.interfaces 中 SecureRandom 的使用

参数类型为 SecureRandom 的 java.security.interfaces 中的方法
void | DSAKeyPairGenerator.initialize(DSAParams params, SecureRandom random) 使用 DSA 系列参数（p、q 和 g）和可选 SecureRandom 位源初始化密钥对生成器。
void | DSAKeyPairGenerator.initialize(int modlen, boolean genParams, SecureRandom random) 使用给定系数长度（而不是参数）和可选 SecureRandom 位源初始化密钥对生成器。

javax.crypto 中 SecureRandom 的使用

参数类型为 SecureRandom 的 javax.crypto 中的方法
protected abstract void | KeyGeneratorSpi.engineInit(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化密钥生成器。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 cipher。
protected abstract void | KeyGeneratorSpi.engineInit(int keysize, SecureRandom random) 使用给定随机源初始化此密钥生成器，以获取确定的密钥长度。
protected abstract void | KeyAgreementSpi.engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
protected abstract void | KeyAgreementSpi.engineInit(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协定。
protected abstract void | KeyGeneratorSpi.engineInit(SecureRandom random) 初始化该密钥生成器。
void | KeyGenerator.init(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化此密钥生成器。
void | Cipher.init(int opmode, Certificate certificate, SecureRandom random) 用取自给定证书的公钥和随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 Cipher。
void | KeyGenerator.init(int keysize, SecureRandom random) 使用用户提供的随机源初始化此密钥生成器，使其具有确定的密钥大小。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | KeyAgreement.init(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协议。
void | KeyGenerator.init(SecureRandom random) 初始化此密钥生成器。

javax.net.ssl 中 SecureRandom 的使用

参数类型为 SecureRandom 的 javax.net.ssl 中的方法
protected abstract void | SSLContextSpi.engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr) 初始化此上下文。
void | SSLContext.init(KeyManager[] km, TrustManager[] tm, SecureRandom random) 初始化此上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.SecureRandomSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SecureRandomSpi
的使用

使用 SecureRandomSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 SecureRandomSpi 的使用

参数类型为 SecureRandomSpi 的 java.security 中的构造方法
SecureRandom(SecureRandomSpi secureRandomSpi, Provider provider)
创建 SecureRandom 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.Security 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Security
的使用

没有 java.security.Security 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.SecurityPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SecurityPermission
的使用

没有 java.security.SecurityPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.Signature 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Signature
的使用

使用 Signature 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Signature 的使用

返回 Signature 的 java.security 中的方法
static Signature | Signature.getInstance(String algorithm) 返回实现指定签名算法的 Signature 对象。
static Signature | Signature.getInstance(String algorithm, Provider provider) 返回实现指定签名算法的 Signature 对象。
static Signature | Signature.getInstance(String algorithm, String provider) 返回实现指定签名算法的 Signature 对象。

参数类型为 Signature 的 java.security 中的方法
 boolean SignedObject.verify(PublicKey verificationKey, Signature verificationEngine)
使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。

参数类型为 Signature 的 java.security 中的构造方法
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.SignatureException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SignatureException
的使用

使用 SignatureException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.security.cert | 为公钥证书提供类。

java.security 中 SignatureException 的使用

抛出 SignatureException 的 java.security 中的方法
protected abstract byte[] | SignatureSpi.engineSign() 返回迄今为止所有更新的数据的签名字节。
protected int | SignatureSpi.engineSign(byte[] outbuf, int offset, int len) 完成此签名操作，并从 offset 开始将得到的签名字节保存在提供的缓冲区 outbuf 中。
protected abstract void | SignatureSpi.engineUpdate(byte b) 使用指定的字节更新要签名或验证的数据。
protected abstract void | SignatureSpi.engineUpdate(byte[] b, int off, int len) 使用指定的 byte 数组，从指定的偏移量开始更新要签名或验证的数据。
protected abstract boolean | SignatureSpi.engineVerify(byte[] sigBytes) 验证传入的签名。
protected boolean | SignatureSpi.engineVerify(byte[] sigBytes, int offset, int length) 在指定的 byte 数组中，从指定的偏移量处开始，验证传入的签名。
byte[] | Signature.sign() 返回所有已更新数据的签名字节。
int | Signature.sign(byte[] outbuf, int offset, int len) 完成签名操作并从 offset 开始，将得到的签名字节存储在提供的缓冲区 outbuf 中。
void | Signature.update(byte b) 更新要由字节签名或验证的数据。
void | Signature.update(byte[] data) 使用指定的 byte 数组更新要签名或验证的数据。
void | Signature.update(byte[] data, int off, int len) 从指定的偏移量开始，使用指定的 byte 数组更新要签名或验证的数据。
void | Signature.update(ByteBuffer data) 使用指定的 ByteBuffer 更新要签名或验证的数据。
boolean | Signature.verify(byte[] signature) 验证传入的签名。
boolean | Signature.verify(byte[] signature, int offset, int length) 从指定的偏移量开始，验证指定的 byte 数组中传入的签名。
boolean | SignedObject.verify(PublicKey verificationKey, Signature verificationEngine) 使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。

抛出 SignatureException 的 java.security 中的构造方法
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

java.security.cert 中 SignatureException 的使用

抛出 SignatureException 的 java.security.cert 中的方法
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

javax.security.cert 中 SignatureException 的使用

抛出 SignatureException 的 javax.security.cert 中的方法
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.SignatureSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SignatureSpi
的使用

使用 SignatureSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 SignatureSpi 的使用

java.security 中 SignatureSpi 的子类
 class Signature
此 Signature 类用来为应用程序提供数字签名算法功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.SignedObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SignedObject
的使用

没有 java.security.SignedObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.Signer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Signer
的使用

没有 java.security.Signer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.Timestamp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Timestamp
的使用

使用 Timestamp 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Timestamp 的使用

返回 Timestamp 的 java.security 中的方法
 Timestamp CodeSigner.getTimestamp()
返回签名时间戳。

参数类型为 Timestamp 的 java.security 中的构造方法
CodeSigner(CertPath signerCertPath, Timestamp timestamp)
构造 CodeSigner 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.UnrecoverableEntryException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.UnrecoverableEntryException
的使用

使用 UnrecoverableEntryException 的软件包
java.security 为安全框架提供类和接口。

java.security 中 UnrecoverableEntryException 的使用

java.security 中 UnrecoverableEntryException 的子类
 class UnrecoverableKeyException
如果 keystore 中的密钥无法恢复，则抛出此异常。

抛出 UnrecoverableEntryException 的 java.security 中的方法
KeyStore.Entry | KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
KeyStore.Entry | KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.UnrecoverableKeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.UnrecoverableKeyException
的使用

使用 UnrecoverableKeyException 的软件包
java.security | 为安全框架提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 UnrecoverableKeyException 的使用

抛出 UnrecoverableKeyException 的 java.security 中的方法
abstract Key | KeyStoreSpi.engineGetKey(String alias, char[] password) 返回与给定别名关联的密钥，使用给定密码恢复它。
Key | KeyStore.getKey(String alias, char[] password) 返回与给定别名关联的密钥，并用给定密码来恢复它。

javax.net.ssl 中 UnrecoverableKeyException 的使用

抛出 UnrecoverableKeyException 的 javax.net.ssl 中的方法
protected abstract void | KeyManagerFactorySpi.engineInit(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。
void | KeyManagerFactory.init(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.UnresolvedPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.UnresolvedPermission
的使用

没有 java.security.UnresolvedPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.URIParameter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.URIParameter
的使用

没有 java.security.URIParameter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.security.interfaces (Java 2 Platform SE 6)

 java.security.interfaces
接口
DSAKey
DSAKeyPairGenerator
DSAParams
DSAPrivateKey
DSAPublicKey
ECKey
ECPrivateKey
ECPublicKey
RSAKey
RSAMultiPrimePrivateCrtKey
RSAPrivateCrtKey
RSAPrivateKey
RSAPublicKey


接口 java.security.interfaces.DSAKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.DSAKey
的使用

使用 DSAKey 的软件包
java.security.interfaces 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

java.security.interfaces 中 DSAKey 的使用

java.security.interfaces 中 DSAKey 的子接口
interface | DSAPrivateKey DSA 专用密钥的标准接口。
interface | DSAPublicKey DSA 公用密钥的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.DSAKeyPairGenerator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.DSAKeyPairGenerator
的使用

没有 java.security.interfaces.DSAKeyPairGenerator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.DSAParams 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.DSAParams
的使用

使用 DSAParams 的软件包
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。

java.security.interfaces 中 DSAParams 的使用

返回 DSAParams 的 java.security.interfaces 中的方法
 DSAParams DSAKey.getParams()
返回特定于 DSA 的密钥参数。

参数类型为 DSAParams 的 java.security.interfaces 中的方法
 void DSAKeyPairGenerator.initialize(DSAParams params, SecureRandom random)
使用 DSA 系列参数（p、q 和 g）和可选 SecureRandom 位源初始化密钥对生成器。

java.security.spec 中 DSAParams 的使用

实现 DSAParams 的 java.security.spec 中的类
 class DSAParameterSpec
此类指定用于 DSA 算法的参数的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.DSAPrivateKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.DSAPrivateKey
的使用

没有 java.security.interfaces.DSAPrivateKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.DSAPublicKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.DSAPublicKey
的使用

没有 java.security.interfaces.DSAPublicKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.ECKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.ECKey
的使用

使用 ECKey 的软件包
java.security.interfaces 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

java.security.interfaces 中 ECKey 的使用

java.security.interfaces 中 ECKey 的子接口
interface | ECPrivateKey 椭圆曲线 (EC) 专用密钥的接口。
interface | ECPublicKey 椭圆曲线 (EC) 公用密钥的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.ECPrivateKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.ECPrivateKey
的使用

没有 java.security.interfaces.ECPrivateKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.ECPublicKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.ECPublicKey
的使用

没有 java.security.interfaces.ECPublicKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.RSAKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.RSAKey
的使用

使用 RSAKey 的软件包
java.security.interfaces 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

java.security.interfaces 中 RSAKey 的使用

java.security.interfaces 中 RSAKey 的子接口
interface | RSAMultiPrimePrivateCrtKey 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
interface | RSAPrivateCrtKey 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
interface | RSAPrivateKey RSA 专用密钥的接口。
interface | RSAPublicKey RSA 公用密钥的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey
的使用

没有 java.security.interfaces.RSAMultiPrimePrivateCrtKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.RSAPrivateCrtKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.RSAPrivateCrtKey
的使用

没有 java.security.interfaces.RSAPrivateCrtKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.RSAPrivateKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.RSAPrivateKey
的使用

使用 RSAPrivateKey 的软件包
java.security.interfaces 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

java.security.interfaces 中 RSAPrivateKey 的使用

java.security.interfaces 中 RSAPrivateKey 的子接口
interface | RSAMultiPrimePrivateCrtKey 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
interface | RSAPrivateCrtKey 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.interfaces.RSAPublicKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.RSAPublicKey
的使用

没有 java.security.interfaces.RSAPublicKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.security.spec (Java 2 Platform SE 6)

 java.security.spec
接口
AlgorithmParameterSpec
ECField
KeySpec
类
DSAParameterSpec
DSAPrivateKeySpec
DSAPublicKeySpec
ECFieldF2m
ECFieldFp
ECGenParameterSpec
ECParameterSpec
ECPoint
ECPrivateKeySpec
ECPublicKeySpec
EllipticCurve
EncodedKeySpec
MGF1ParameterSpec
PKCS8EncodedKeySpec
PSSParameterSpec
RSAKeyGenParameterSpec
RSAMultiPrimePrivateCrtKeySpec
RSAOtherPrimeInfo
RSAPrivateCrtKeySpec
RSAPrivateKeySpec
RSAPublicKeySpec
X509EncodedKeySpec
异常
InvalidKeySpecException
InvalidParameterSpecException


接口 java.security.spec.AlgorithmParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.spec.AlgorithmParameterSpec
的使用

使用 AlgorithmParameterSpec 的软件包
java.security | 为安全框架提供类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

java.security 中 AlgorithmParameterSpec 的使用

类型参数类型为 AlgorithmParameterSpec 的 java.security 中的方法
protected abstract
<T extends AlgorithmParameterSpec>
T
AlgorithmParametersSpi.engineGetParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。
<T extends AlgorithmParameterSpec>
T
AlgorithmParameters.getParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。

参数类型为 AlgorithmParameterSpec 的 java.security 中的方法
protected abstract void | AlgorithmParametersSpi.engineInit(AlgorithmParameterSpec paramSpec) 使用在 paramSpec 中指定的参数初始化此参数对象。
protected abstract void | AlgorithmParameterGeneratorSpi.engineInit(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值的集合初始化此参数生成器。
protected void | SignatureSpi.engineSetParameter(AlgorithmParameterSpec params) 此方法将由提供者重写，以便使用指定的参数设置初始化此签名引擎。
void | AlgorithmParameterGenerator.init(AlgorithmParameterSpec genParamSpec) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | AlgorithmParameters.init(AlgorithmParameterSpec paramSpec) 使用在 paramSpec 中指定的参数初始化此参数对象。
void | AlgorithmParameterGenerator.init(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | KeyPairGenerator.initialize(AlgorithmParameterSpec params) 初始化密钥对生成器，使用指定参数集合，并使用以最高优先级安装的提供者的 SecureRandom 的实现作为随机源。
void | KeyPairGenerator.initialize(AlgorithmParameterSpec params, SecureRandom random) 使用给定参数集合和随机源初始化密钥对生成器。
void | KeyPairGeneratorSpi.initialize(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集合和用户提供的随机源初始化密钥对生成器。
void | Signature.setParameter(AlgorithmParameterSpec params) 使用指定的参数集初始化此签名引擎。

java.security.spec 中 AlgorithmParameterSpec 的使用

实现 AlgorithmParameterSpec 的 java.security.spec 中的类
class | DSAParameterSpec 此类指定用于 DSA 算法的参数的集合。
class | ECGenParameterSpec 此不可变类指定用于生成椭圆曲线 (EC) 域参数的参数集。
class | ECParameterSpec 此不可变类指定用于椭圆曲线加密方法 (ECC) 的域参数集。
class | MGF1ParameterSpec 此类指定 OAEP Padding 和 RSA-PSS 签名方案中的掩码生成函数 MGF1（如 PKCS #1 v2.1 标准中所定义的）使用的参数集。
class | PSSParameterSpec 此类指定 RSA-PSS 签名方案的参数规范，如 PKCS#1 v2.1 标准中所定义的。
class | RSAKeyGenParameterSpec 此类指定用于生成 RSA 密钥对的参数集。

返回 AlgorithmParameterSpec 的 java.security.spec 中的方法
 AlgorithmParameterSpec PSSParameterSpec.getMGFParameters()
返回掩码生成函数的参数。

参数类型为 AlgorithmParameterSpec 的 java.security.spec 中的构造方法
PSSParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, int saltLen, int trailerField)
根据 PKCS #1 中的定义，使用指定的消息摘要、掩码生成函数、掩码生成函数的参数、salt 长度和尾部字段值，创建一个新的 PSSParameterSpec。

javax.crypto 中 AlgorithmParameterSpec 的使用

返回 AlgorithmParameterSpec 的 javax.crypto 中的方法
static AlgorithmParameterSpec Cipher.getMaxAllowedParameterSpec(String transformation)
根据仲裁策略文件，返回包含最大 Cipher 参数值的 AlgorithmParameterSpec 对象。

参数类型为 AlgorithmParameterSpec 的 javax.crypto 中的方法
protected abstract void | KeyGeneratorSpi.engineInit(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化密钥生成器。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | MacSpi.engineInit(Key key, AlgorithmParameterSpec params) 用给定的（秘密）密钥和算法参数初始化 MAC。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | KeyAgreementSpi.engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | KeyGenerator.init(AlgorithmParameterSpec params) 用指定参数集初始化此密钥生成器。
void | KeyGenerator.init(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化此密钥生成器。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | ExemptionMechanism.init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params) 用给定密钥和算法参数集初始化此密钥协定。
void | Mac.init(Key key, AlgorithmParameterSpec params) 用给定的密钥和算法参数初始化此 Mac 对象。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。

javax.crypto.spec 中 AlgorithmParameterSpec 的使用

实现 AlgorithmParameterSpec 的 javax.crypto.spec 中的类
class | DHGenParameterSpec 此类指定用于生成在 Diffie-Hellman 密钥协议中使用的 Diffie-Hellman（系统）参数的参数集合。
class | DHParameterSpec 此类指定随同 Diffie-Hellman 算法使用的参数集合，该算法在 PKCS #3：Diffie-Hellman Key-Agreement Standard 中指定。
class | IvParameterSpec 此类指定一个初始化向量 (IV)。
class | OAEPParameterSpec 此类指定随同 OAEP 冗余使用的参数集合，OAEP 冗余在 PKCS #1 标准中定义。
class | PBEParameterSpec 此类指定随同以密码为基础的加密法 (PBE) 使用的参数集合，该加密法在 PKCS #5 标准中定义。
class | RC2ParameterSpec 此类指定随同 RC2 算法使用的参数。
class | RC5ParameterSpec 此类指定随同 RC5 算法使用的参数。

返回 AlgorithmParameterSpec 的 javax.crypto.spec 中的方法
 AlgorithmParameterSpec OAEPParameterSpec.getMGFParameters()
返回掩码生成函数的参数。

参数类型为 AlgorithmParameterSpec 的 javax.crypto.spec 中的构造方法
OAEPParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)
使用指定的信息摘要算法 mdName、掩码生成函数算法 mgfName、掩码生成函数参数 mgfSpec 以及编码输入 P 源 pSrc 来为 PKCS #1 标准中定义的 OAEP 冗余构造一个参数集合。

javax.xml.crypto 中 AlgorithmParameterSpec 的使用

返回 AlgorithmParameterSpec 的 javax.xml.crypto 中的方法
 AlgorithmParameterSpec AlgorithmMethod.getParameterSpec()
返回此 AlgorithmMethod 的算法参数。

javax.xml.crypto.dsig 中 AlgorithmParameterSpec 的使用

返回 AlgorithmParameterSpec 的 javax.xml.crypto.dsig 中的方法
AlgorithmParameterSpec | CanonicalizationMethod.getParameterSpec() 返回与此 CanonicalizationMethod 关联的特定于算法的输入参数。
AlgorithmParameterSpec | DigestMethod.getParameterSpec() 返回与此 DigestMethod 关联的特定于算法的输入参数。
AlgorithmParameterSpec | SignatureMethod.getParameterSpec() 返回此 SignatureMethod 的特定于算法的输入参数。
AlgorithmParameterSpec | Transform.getParameterSpec() 返回与此 Transform 关联的特定于算法的输入参数。

javax.xml.crypto.dsig.spec 中 AlgorithmParameterSpec 的使用

javax.xml.crypto.dsig.spec 中 AlgorithmParameterSpec 的子接口
interface | C14NMethodParameterSpec CanonicalizationMethod 算法的算法参数规范。
interface | DigestMethodParameterSpec 用于 DigestMethod 算法的算法参数的规范。
interface | SignatureMethodParameterSpec 用于 XML SignatureMethod 算法的算法参数规范。
interface | TransformParameterSpec 用于 Transform 算法的算法参数规范。

实现 AlgorithmParameterSpec 的 javax.xml.crypto.dsig.spec 中的类
class | ExcC14NParameterSpec W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。
class | HMACParameterSpec XML Signature HMAC Algorithm 的参数。
class | XPathFilter2ParameterSpec W3C Recommendation XPath Filter 2.0 Transform Algorithm 的参数。
class | XPathFilterParameterSpec XPath Filtering Transform Algorithm 的参数。
class | XSLTTransformParameterSpec XSLT Transform Algorithm 的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.DSAParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.DSAParameterSpec
的使用

没有 java.security.spec.DSAParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.DSAPrivateKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.DSAPrivateKeySpec
的使用

没有 java.security.spec.DSAPrivateKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.DSAPublicKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.DSAPublicKeySpec
的使用

没有 java.security.spec.DSAPublicKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.spec.ECField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.spec.ECField
的使用

使用 ECField 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 ECField 的使用

实现 ECField 的 java.security.spec 中的类
class | ECFieldF2m 此不可变类定义椭圆曲线 (EC) 首数为 2 的有限字段。
class | ECFieldFp 此不可变类定义椭圆曲线 (EC) 素数的有限字段。

返回 ECField 的 java.security.spec 中的方法
 ECField EllipticCurve.getField()
返回此椭圆曲线结束的有限字段 field。

参数类型为 ECField 的 java.security.spec 中的构造方法
EllipticCurve(ECField field, BigInteger a, BigInteger b)
使用指定的椭圆字段 field 以及系数 a 和 b 创建椭圆曲线。
EllipticCurve(ECField field, BigInteger a, BigInteger b, byte[] seed)
使用指定的椭圆字段 field、系数 a 和 b，以及用于生成曲线的 seed 创建椭圆曲线。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.ECFieldF2m 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECFieldF2m
的使用

没有 java.security.spec.ECFieldF2m 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.ECFieldFp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECFieldFp
的使用

没有 java.security.spec.ECFieldFp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.ECGenParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECGenParameterSpec
的使用

没有 java.security.spec.ECGenParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.ECParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECParameterSpec
的使用

使用 ECParameterSpec 的软件包
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。

java.security.interfaces 中 ECParameterSpec 的使用

返回 ECParameterSpec 的 java.security.interfaces 中的方法
 ECParameterSpec ECKey.getParams()
返回与此密钥关联的域参数。

java.security.spec 中 ECParameterSpec 的使用

返回 ECParameterSpec 的 java.security.spec 中的方法
ECParameterSpec | ECPrivateKeySpec.getParams() 返回关联的椭圆曲线域参数。
ECParameterSpec | ECPublicKeySpec.getParams() 返回关联的椭圆曲线域参数。

参数类型为 ECParameterSpec 的 java.security.spec 中的构造方法
ECPrivateKeySpec(BigInteger s, ECParameterSpec params)
使用指定的参数值创建一个新的 ECPrivateKeySpec。
ECPublicKeySpec(ECPoint w, ECParameterSpec params)
根据指定参数值，创建一个新的 ECPublicKeySpec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.ECPoint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECPoint
的使用

使用 ECPoint 的软件包
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。

java.security.interfaces 中 ECPoint 的使用

返回 ECPoint 的 java.security.interfaces 中的方法
 ECPoint ECPublicKey.getW()
返回公用点 W。

java.security.spec 中 ECPoint 的使用

声明为 ECPoint 的 java.security.spec 中的字段
static ECPoint ECPoint.POINT_INFINITY
这就将该点定义为无穷大。

返回 ECPoint 的 java.security.spec 中的方法
ECPoint | ECParameterSpec.getGenerator() 返回也称为基点的生成器。
ECPoint | ECPublicKeySpec.getW() 返回公用点 W。

参数类型为 ECPoint 的 java.security.spec 中的构造方法
ECParameterSpec(EllipticCurve curve, ECPoint g, BigInteger n, int h)
创建基于指定值的椭圆曲线域参数。
ECPublicKeySpec(ECPoint w, ECParameterSpec params)
根据指定参数值，创建一个新的 ECPublicKeySpec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.ECPrivateKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECPrivateKeySpec
的使用

没有 java.security.spec.ECPrivateKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.ECPublicKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECPublicKeySpec
的使用

没有 java.security.spec.ECPublicKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.EllipticCurve 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.EllipticCurve
的使用

使用 EllipticCurve 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 EllipticCurve 的使用

返回 EllipticCurve 的 java.security.spec 中的方法
 EllipticCurve ECParameterSpec.getCurve()
返回此参数定义的椭圆曲线。

参数类型为 EllipticCurve 的 java.security.spec 中的构造方法
ECParameterSpec(EllipticCurve curve, ECPoint g, BigInteger n, int h)
创建基于指定值的椭圆曲线域参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.EncodedKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.EncodedKeySpec
的使用

使用 EncodedKeySpec 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 EncodedKeySpec 的使用

java.security.spec 中 EncodedKeySpec 的子类
class | PKCS8EncodedKeySpec 此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。
class | X509EncodedKeySpec 此类表示根据 ASN.1 类型 SubjectPublicKeyInfo 进行编码的公用密钥的 ASN.1 编码。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.InvalidKeySpecException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.InvalidKeySpecException
的使用

使用 InvalidKeySpecException 的软件包
java.security | 为安全框架提供类和接口。
javax.crypto | 为加密操作提供类和接口。

java.security 中 InvalidKeySpecException 的使用

抛出 InvalidKeySpecException 的 java.security 中的方法
protected abstract  PrivateKey KeyFactorySpi.engineGeneratePrivate(KeySpec keySpec)
根据所提供的密钥规范（密钥材料）生成私钥对象。
protected abstract  PublicKey KeyFactorySpi.engineGeneratePublic(KeySpec keySpec)
根据所提供的密钥规范（密钥材料）生成公钥对象。
protected abstract
<T extends KeySpec>
T
KeyFactorySpi.engineGetKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
 PrivateKey KeyFactory.generatePrivate(KeySpec keySpec)
根据提供的密钥规范（密钥材料）生成私钥对象。
 PublicKey KeyFactory.generatePublic(KeySpec keySpec)
根据提供的密钥规范（密钥材料）生成公钥对象。
<T extends KeySpec>
T
KeyFactory.getKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。

javax.crypto 中 InvalidKeySpecException 的使用

抛出 InvalidKeySpecException 的 javax.crypto 中的方法
protected abstract SecretKey | SecretKeyFactorySpi.engineGenerateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
protected abstract KeySpec | SecretKeyFactorySpi.engineGetKeySpec(SecretKey key, Class keySpec) 以所需格式返回给定密钥对象的规范（密钥材料）。
SecretKey | SecretKeyFactory.generateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Cipher cipher) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
KeySpec | SecretKeyFactory.getKeySpec(SecretKey key, Class keySpec) 以请求的格式返回给定密钥对象的规范（密钥材料）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.InvalidParameterSpecException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.InvalidParameterSpecException
的使用

使用 InvalidParameterSpecException 的软件包
java.security 为安全框架提供类和接口。

java.security 中 InvalidParameterSpecException 的使用

抛出 InvalidParameterSpecException 的 java.security 中的方法
protected abstract
<T extends AlgorithmParameterSpec>
T
AlgorithmParametersSpi.engineGetParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。
protected abstract  void AlgorithmParametersSpi.engineInit(AlgorithmParameterSpec paramSpec)
使用在 paramSpec 中指定的参数初始化此参数对象。
<T extends AlgorithmParameterSpec>
T
AlgorithmParameters.getParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。
 void AlgorithmParameters.init(AlgorithmParameterSpec paramSpec)
使用在 paramSpec 中指定的参数初始化此参数对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.security.spec.KeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.spec.KeySpec
的使用

使用 KeySpec 的软件包
java.security | 为安全框架提供类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。

java.security 中 KeySpec 的使用

类型参数类型为 KeySpec 的 java.security 中的方法
protected abstract
<T extends KeySpec>
T
KeyFactorySpi.engineGetKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
<T extends KeySpec>
T
KeyFactory.getKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。

参数类型为 KeySpec 的 java.security 中的方法
protected abstract PrivateKey | KeyFactorySpi.engineGeneratePrivate(KeySpec keySpec) 根据所提供的密钥规范（密钥材料）生成私钥对象。
protected abstract PublicKey | KeyFactorySpi.engineGeneratePublic(KeySpec keySpec) 根据所提供的密钥规范（密钥材料）生成公钥对象。
PrivateKey | KeyFactory.generatePrivate(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成私钥对象。
PublicKey | KeyFactory.generatePublic(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成公钥对象。

java.security.spec 中 KeySpec 的使用

实现 KeySpec 的 java.security.spec 中的类
class | DSAPrivateKeySpec 此类指定带关联参数的 DSA 专用密钥。
class | DSAPublicKeySpec 此类指定带关联参数的 DSA 公用密钥。
class | ECPrivateKeySpec 此不可变类指定带关联参数的椭圆曲线专用密钥。
class | ECPublicKeySpec 此不可变类指定带关联参数的椭圆曲线公用密钥。
class | EncodedKeySpec 此类用编码格式表示公用密钥或专用密钥。
class | PKCS8EncodedKeySpec 此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。
class | RSAMultiPrimePrivateCrtKeySpec 如 PKCS#1 v2.1 中所定义的，此类为了提高效率，使用 Chinese Remainder Theorem (CRT) 信息值指定 RSA 多素数专用密钥。
class | RSAPrivateCrtKeySpec 为了提高效率，此类根据 PKCS#1 标准所定义的，使用 Chinese Remainder Theorem（中国剩余定理，CRT）信息值指定一个 RSA 专用密钥。
class | RSAPrivateKeySpec 此类指定 RSA 专用密钥。
class | RSAPublicKeySpec 此类指定 RSA 公用密钥。
class | X509EncodedKeySpec 此类表示根据 ASN.1 类型 SubjectPublicKeyInfo 进行编码的公用密钥的 ASN.1 编码。

javax.crypto 中 KeySpec 的使用

返回 KeySpec 的 javax.crypto 中的方法
protected abstract KeySpec | SecretKeyFactorySpi.engineGetKeySpec(SecretKey key, Class keySpec) 以所需格式返回给定密钥对象的规范（密钥材料）。
KeySpec | SecretKeyFactory.getKeySpec(SecretKey key, Class keySpec) 以请求的格式返回给定密钥对象的规范（密钥材料）。

参数类型为 KeySpec 的 javax.crypto 中的方法
protected abstract SecretKey | SecretKeyFactorySpi.engineGenerateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
SecretKey | SecretKeyFactory.generateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。

javax.crypto.spec 中 KeySpec 的使用

实现 KeySpec 的 javax.crypto.spec 中的类
class | DESedeKeySpec 此类指定一个 DES-EDE ("triple-DES") 密钥。
class | DESKeySpec 此类指定一个 DES 密钥。
class | DHPrivateKeySpec 此类使用其关联的参数指定一个 Diffie-Hellman 私钥。
class | DHPublicKeySpec 此类使用关联的参数指定一个 Diffie-Hellman 公钥。
class | PBEKeySpec 可随同基于密码的加密法 (PBE) 使用的供用户选择的密码。
class | SecretKeySpec 此类以与 provider 无关的方式指定一个密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.MGF1ParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.MGF1ParameterSpec
的使用

使用 MGF1ParameterSpec 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 MGF1ParameterSpec 的使用

声明为 MGF1ParameterSpec 的 java.security.spec 中的字段
static MGF1ParameterSpec | MGF1ParameterSpec.SHA1 使用“SHA-1”消息摘要的 MGF1ParameterSpec。
static MGF1ParameterSpec | MGF1ParameterSpec.SHA256 使用“SHA-256”消息摘要的 MGF1ParameterSpec。
static MGF1ParameterSpec | MGF1ParameterSpec.SHA384 使用“SHA-384”消息摘要的 MGF1ParameterSpec。
static MGF1ParameterSpec | MGF1ParameterSpec.SHA512 使用 SHA-512 消息摘要的 MGF1ParameterSpec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.PKCS8EncodedKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.PKCS8EncodedKeySpec
的使用

使用 PKCS8EncodedKeySpec 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 PKCS8EncodedKeySpec 的使用

返回 PKCS8EncodedKeySpec 的 javax.crypto 中的方法
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Cipher cipher) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.PSSParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.PSSParameterSpec
的使用

使用 PSSParameterSpec 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 PSSParameterSpec 的使用

声明为 PSSParameterSpec 的 java.security.spec 中的字段
static PSSParameterSpec PSSParameterSpec.DEFAULT
带所有默认值的 PSS 参数集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.RSAKeyGenParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAKeyGenParameterSpec
的使用

没有 java.security.spec.RSAKeyGenParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec
的使用

没有 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.RSAOtherPrimeInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAOtherPrimeInfo
的使用

使用 RSAOtherPrimeInfo 的软件包
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。

java.security.interfaces 中 RSAOtherPrimeInfo 的使用

返回 RSAOtherPrimeInfo 的 java.security.interfaces 中的方法
 RSAOtherPrimeInfo[] RSAMultiPrimePrivateCrtKey.getOtherPrimeInfo()
返回 otherPrimeInfo；如果仅存在两个素数因子（p 和 q），则返回 null。

java.security.spec 中 RSAOtherPrimeInfo 的使用

返回 RSAOtherPrimeInfo 的 java.security.spec 中的方法
 RSAOtherPrimeInfo[] RSAMultiPrimePrivateCrtKeySpec.getOtherPrimeInfo()
返回 otherPrimeInfo 的副本，如果仅有两个素数因子（p 和 q），则返回 null。

参数类型为 RSAOtherPrimeInfo 的 java.security.spec 中的构造方法
RSAMultiPrimePrivateCrtKeySpec(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient, RSAOtherPrimeInfo[] otherPrimeInfo)
给定系数、publicExponent、privateExponent、primeP、primeQ、primeExponentP、primeExponentQ、crtCoefficient 和如 PKCS#1 v2.1 中所定义的 otherPrimeInfo，创建一个新的 RSAMultiPrimePrivateCrtKeySpec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.RSAPrivateCrtKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAPrivateCrtKeySpec
的使用

没有 java.security.spec.RSAPrivateCrtKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.RSAPrivateKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAPrivateKeySpec
的使用

使用 RSAPrivateKeySpec 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 RSAPrivateKeySpec 的使用

java.security.spec 中 RSAPrivateKeySpec 的子类
class | RSAMultiPrimePrivateCrtKeySpec 如 PKCS#1 v2.1 中所定义的，此类为了提高效率，使用 Chinese Remainder Theorem (CRT) 信息值指定 RSA 多素数专用密钥。
class | RSAPrivateCrtKeySpec 为了提高效率，此类根据 PKCS#1 标准所定义的，使用 Chinese Remainder Theorem（中国剩余定理，CRT）信息值指定一个 RSA 专用密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.RSAPublicKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAPublicKeySpec
的使用

没有 java.security.spec.RSAPublicKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.security.spec.X509EncodedKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.X509EncodedKeySpec
的使用

没有 java.security.spec.X509EncodedKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.sql (Java 2 Platform SE 6)

 java.sql
接口
Array
Blob
CallableStatement
Clob
Connection
DatabaseMetaData
Driver
NClob
ParameterMetaData
PreparedStatement
Ref
ResultSet
ResultSetMetaData
RowId
Savepoint
SQLData
SQLInput
SQLOutput
SQLXML
Statement
Struct
Wrapper
类
Date
DriverManager
DriverPropertyInfo
SQLPermission
Time
Timestamp
Types
枚举
ClientInfoStatus
RowIdLifetime
异常
BatchUpdateException
DataTruncation
SQLClientInfoException
SQLDataException
SQLException
SQLFeatureNotSupportedException
SQLIntegrityConstraintViolationException
SQLInvalidAuthorizationSpecException
SQLNonTransientConnectionException
SQLNonTransientException
SQLRecoverableException
SQLSyntaxErrorException
SQLTimeoutException
SQLTransactionRollbackException
SQLTransientConnectionException
SQLTransientException
SQLWarning


接口 java.sql.Array 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Array
的使用

使用 Array 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Array 的使用

返回 Array 的 java.sql 中的方法
Array | Connection.createArrayOf(String typeName, Object[] elements) 创建 Array 对象的工厂方法。
Array | CallableStatement.getArray(int parameterIndex) 以 Java 编程语言中 Array 对象的形式获取指定的 JDBC ARRAY 参数的值。
Array | ResultSet.getArray(int columnIndex) 以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Array | CallableStatement.getArray(String parameterName) 以 Java 编程语言中 java.sql.ARRAY 对象的形式获取 JDBC ARRAY 参数的值。
Array | ResultSet.getArray(String columnLabel) 以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Array | SQLInput.readArray() 从流中读取 SQL ARRAY 值并将其作为 Java 编程语言中的 Array 对象返回。

参数类型为 Array 的 java.sql 中的方法
void | PreparedStatement.setArray(int parameterIndex, Array x) 将指定参数设置为给定 java.sql.Array 对象。
void | ResultSet.updateArray(int columnIndex, Array x) 用 java.sql.Array 值更新指定列。
void | ResultSet.updateArray(String columnLabel, Array x) 用 java.sql.Array 值更新指定列。
void | SQLOutput.writeArray(Array x) 将 SQL ARRAY 值写入流中。

javax.sql 中 Array 的使用

参数类型为 Array 的 javax.sql 中的方法
 void RowSet.setArray(int i, Array x)
使用给定 Array 值设置此 RowSet 对象命令中的指定参数。

javax.sql.rowset 中 Array 的使用

参数类型为 Array 的 javax.sql.rowset 中的方法
 void BaseRowSet.setArray(int parameterIndex, Array array)
将指定参数设置为 Java 编程语言中的 Array 对象。

javax.sql.rowset.serial 中 Array 的使用

实现 Array 的 javax.sql.rowset.serial 中的类
 class SerialArray
序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。

返回 Array 的 javax.sql.rowset.serial 中的方法
 Array SQLInputImpl.readArray()
从流中读取 SQL ARRAY 值并以 Java 编程语言中 Array 对象的形式返回。

参数类型为 Array 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeArray(Array x)
将 Java 编程语言中的 Array 对象写入此 SQLOutputImpl 对象。

参数类型为 Array 的 javax.sql.rowset.serial 中的构造方法
SerialArray(Array array)
根据给定 Array 对象构造新的 SerialArray 对象。
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.BatchUpdateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.BatchUpdateException
的使用

没有 java.sql.BatchUpdateException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.Blob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Blob
的使用

使用 Blob 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Blob 的使用

返回 Blob 的 java.sql 中的方法
Blob | Connection.createBlob() 构造实现 Blob 接口的对象。
Blob | CallableStatement.getBlob(int parameterIndex) 以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
Blob | ResultSet.getBlob(int columnIndex) 以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Blob | CallableStatement.getBlob(String parameterName) 以 Java 编程语言中 Blob 对象的形式获取 JDBC BLOB 参数的值。
Blob | ResultSet.getBlob(String columnLabel) 以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Blob | SQLInput.readBlob() 从流中读取 SQL BLOB 值并将其作为 Java 编程语言中的 Blob 对象返回。

参数类型为 Blob 的 java.sql 中的方法
long | Blob.position(Blob pattern, long start) 获取此 Blob 对象指定的 BLOB 值中 pattern 开始处的字节位置。
void | PreparedStatement.setBlob(int parameterIndex, Blob x) 将指定参数设置为给定 java.sql.Blob 对象。
void | CallableStatement.setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。
void | ResultSet.updateBlob(int columnIndex, Blob x) 用 java.sql.Blob 值更新指定列。
void | ResultSet.updateBlob(String columnLabel, Blob x) 用 java.sql.Blob 值更新指定列。
void | SQLOutput.writeBlob(Blob x) 将 SQL BLOB 值写入流中。

javax.sql 中 Blob 的使用

参数类型为 Blob 的 javax.sql 中的方法
void | RowSet.setBlob(int i, Blob x) 使用给定 Blob 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。

javax.sql.rowset 中 Blob 的使用

参数类型为 Blob 的 javax.sql.rowset 中的方法
void | BaseRowSet.setBlob(int parameterIndex, Blob x) 将指定参数设置为 Java 编程语言中的给定 Blob 对象。
void | BaseRowSet.setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。

javax.sql.rowset.serial 中 Blob 的使用

实现 Blob 的 javax.sql.rowset.serial 中的类
 class SerialBlob
SQL BLOB 值在 Java 编程语言中的序列化映射关系。

返回 Blob 的 javax.sql.rowset.serial 中的方法
 Blob SQLInputImpl.readBlob()
以 Java 编程语言中 Blob 对象的形式获取此 SQLInputImpl 对象头部的 BLOB 值。

参数类型为 Blob 的 javax.sql.rowset.serial 中的方法
long | SerialBlob.position(Blob pattern, long start) 返回此 SerialBlob 对象中给定 Blob 对象开始的位置，搜索从指定位置开始。
void | SQLOutputImpl.writeBlob(Blob x) 将 Java 编程语言中的 Blob 对象写入此 SQLOutputImpl 对象。

参数类型为 Blob 的 javax.sql.rowset.serial 中的构造方法
SerialBlob(Blob blob)
根据给定 Blob 对象的序列化形式构造一个 SerialBlob 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.CallableStatement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.CallableStatement
的使用

使用 CallableStatement 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 CallableStatement 的使用

返回 CallableStatement 的 java.sql 中的方法
CallableStatement | Connection.prepareCall(String sql) 创建一个 CallableStatement 对象来调用数据库存储过程。
CallableStatement | Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency) 创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
CallableStatement | Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.ClientInfoStatus 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.ClientInfoStatus
的使用

使用 ClientInfoStatus 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 ClientInfoStatus 的使用

返回 ClientInfoStatus 的 java.sql 中的方法
static ClientInfoStatus | ClientInfoStatus.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static ClientInfoStatus[] | ClientInfoStatus.values() Returns an array containing the constants of this enum type, in the order they are declared.

返回变量类型为 ClientInfoStatus 的类型的 java.sql 中的方法
 Map<String,ClientInfoStatus> SQLClientInfoException.getFailedProperties()
返回无法设置的客户端信息属性列表。

类型变量类型为 ClientInfoStatus 的 java.sql 中的构造方法参数
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.Clob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Clob
的使用

使用 Clob 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Clob 的使用

java.sql 中 Clob 的子接口
 interface NClob
SQL NCLOB 类型在 JavaTM 编程语言中的映射。

返回 Clob 的 java.sql 中的方法
Clob | Connection.createClob() 构造实现 Clob 接口的对象。
Clob | CallableStatement.getClob(int parameterIndex) 以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
Clob | ResultSet.getClob(int columnIndex) 以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Clob | CallableStatement.getClob(String parameterName) 以 Java 编程语言中 java.sql.CLOB 对象的形式获取 JDBC CLOB 参数的值。
Clob | ResultSet.getClob(String columnLabel) 以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Clob | SQLInput.readClob() 从流中读取 SQL CLOB 值并将其作为 Java 编程语言中的 Clob 对象返回。

参数类型为 Clob 的 java.sql 中的方法
long | Clob.position(Clob searchstr, long start) 获取此 Clob 对象中指定的 Clob 对象 searchstr 出现的字符位置。
void | PreparedStatement.setClob(int parameterIndex, Clob x) 将指定参数设置为给定 java.sql.Clob 对象。
void | CallableStatement.setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。
void | ResultSet.updateClob(int columnIndex, Clob x) 用 java.sql.Clob 值更新指定列。
void | ResultSet.updateClob(String columnLabel, Clob x) 用 java.sql.Clob 值更新指定列。
void | SQLOutput.writeClob(Clob x) 将 SQL CLOB 值写入流中。

javax.sql 中 Clob 的使用

参数类型为 Clob 的 javax.sql 中的方法
void | RowSet.setClob(int i, Clob x) 使用给定 Clob 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。

javax.sql.rowset 中 Clob 的使用

参数类型为 Clob 的 javax.sql.rowset 中的方法
void | BaseRowSet.setClob(int parameterIndex, Clob x) 将指定参数设置为 Java 编程语言中的给定 Clob 对象。
void | BaseRowSet.setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。

javax.sql.rowset.serial 中 Clob 的使用

实现 Clob 的 javax.sql.rowset.serial 中的类
 class SerialClob
SQL CLOB 值在 Java 编程语言中的序列化映射关系。

返回 Clob 的 javax.sql.rowset.serial 中的方法
 Clob SQLInputImpl.readClob()
以 Java 编程语言中 Clob 对象的形式获取此 SQLInputImpl 对象头部的 CLOB 值。

参数类型为 Clob 的 javax.sql.rowset.serial 中的方法
long | SerialClob.position(Clob searchStr, long start) 返回此 SerialClob 对象中给定 Clob 签名开始的位置，搜索从指定位置开始。
void | SQLOutputImpl.writeClob(Clob x) 将 Java 编程语言中的 Clob 对象写入此 SQLOutputImpl 对象。

参数类型为 Clob 的 javax.sql.rowset.serial 中的构造方法
SerialClob(Clob clob)
按照给定 Clob 对象的序列化形式构造一个 SerialClob 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.Connection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Connection
的使用

使用 Connection 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

java.sql 中 Connection 的使用

返回 Connection 的 java.sql 中的方法
Connection | Driver.connect(String url, Properties info) 试图创建一个到给定 URL 的数据库连接。
Connection | DatabaseMetaData.getConnection() 获取此元数据对象所产生的连接。
Connection | Statement.getConnection() 获取生成此 Statement 对象的 Connection 对象。
static Connection | DriverManager.getConnection(String url) 试图建立到给定数据库 URL 的连接。
static Connection | DriverManager.getConnection(String url, Properties info) 试图建立到给定数据库 URL 的连接。
static Connection | DriverManager.getConnection(String url, String user, String password) 试图建立到给定数据库 URL 的连接。

javax.sql 中 Connection 的使用

返回 Connection 的 javax.sql 中的方法
Connection | DataSource.getConnection() 尝试建立与此 DataSource 对象所表示的数据源的连接。
Connection | PooledConnection.getConnection() 创建并返回一个 Connection 对象，它是此 PooledConnection 对象表示的物理连接的句柄。
Connection | RowSetInternal.getConnection() 获取传递给此 RowSet 对象的 Connection 对象。
Connection | DataSource.getConnection(String username, String password) 尝试建立与此 DataSource 对象所表示的数据源的连接。

javax.sql.rowset 中 Connection 的使用

参数类型为 Connection 的 javax.sql.rowset 中的方法
void | CachedRowSet.acceptChanges(Connection con) 将所有行更新、插入以及删除更改传播到支持此 CachedRowSet 对象的数据源，使用指定的 Connection 对象建立到数据源的连接。
void | CachedRowSet.execute(Connection conn) 用数据填充此 CachedRowSet 对象，使用给定的连接来生成从中读取数据的结果集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.DatabaseMetaData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.DatabaseMetaData
的使用

使用 DatabaseMetaData 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 DatabaseMetaData 的使用

返回 DatabaseMetaData 的 java.sql 中的方法
 DatabaseMetaData Connection.getMetaData()
获取一个 DatabaseMetaData 对象，该对象包含关于此 Connection 对象所连接的数据库的元数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.DataTruncation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.DataTruncation
的使用

没有 java.sql.DataTruncation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.Date 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.Date
的使用

使用 Date 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Date 的使用

返回 Date 的 java.sql 中的方法
Date | CallableStatement.getDate(int parameterIndex) 以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值。
Date | ResultSet.getDate(int columnIndex) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | CallableStatement.getDate(int parameterIndex, Calendar cal) 以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
Date | ResultSet.getDate(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | CallableStatement.getDate(String parameterName) 以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值。
Date | ResultSet.getDate(String columnLabel) 以 Java 编程语言中的 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | CallableStatement.getDate(String parameterName, Calendar cal) 以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
Date | ResultSet.getDate(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | SQLInput.readDate() 读取流中的下一个属性并将其作为 java.sql.Date 对象返回。
static Date | Date.valueOf(String s) 将 JDBC 日期转义形式的字符串转换成 Date 值。

参数类型为 Date 的 java.sql 中的方法
void | PreparedStatement.setDate(int parameterIndex, Date x) 使用运行应用程序的虚拟机的默认时区将指定参数设置为给定 java.sql.Date 值。
void | PreparedStatement.setDate(int parameterIndex, Date x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
void | CallableStatement.setDate(String parameterName, Date x) 使用运行应用程序的虚拟机默认时区将指定参数设置为给定 java.sql.Date 值。
void | CallableStatement.setDate(String parameterName, Date x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
void | ResultSet.updateDate(int columnIndex, Date x) 用 java.sql.Date 值更新指定列。
void | ResultSet.updateDate(String columnLabel, Date x) 用 java.sql.Date 值更新指定列。
void | SQLOutput.writeDate(Date x) 将下一个属性作为 java.sql.Date 对象写入流中。

javax.sql 中 Date 的使用

参数类型为 Date 的 javax.sql 中的方法
void | RowSet.setDate(int parameterIndex, Date x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setDate(int parameterIndex, Date x, Calendar cal) 使用给定 java.sql.Date 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setDate(String parameterName, Date x) 使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。

javax.sql.rowset 中 Date 的使用

参数类型为 Date 的 javax.sql.rowset 中的方法
void | BaseRowSet.setDate(int parameterIndex, Date x) 将指定参数设置为给定的 java.sql.Date 值。
void | BaseRowSet.setDate(int parameterIndex, Date x, Calendar cal) 将指定参数设置为给定的 java.sql.Date 对象。
void | BaseRowSet.setDate(String parameterName, Date x) 使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
void | BaseRowSet.setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。

javax.sql.rowset.serial 中 Date 的使用

返回 Date 的 javax.sql.rowset.serial 中的方法
 Date SQLInputImpl.readDate()
以 java.sql.Date 对象的形式获取此 SQLInputImpl 中的下一个属性。

参数类型为 Date 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeDate(Date x)
将 Java 编程语言中的 java.sql.Date 对象写入此 SQLOutputImpl 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.Driver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Driver
的使用

使用 Driver 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 Driver 的使用

返回 Driver 的 java.sql 中的方法
static Driver DriverManager.getDriver(String url)
试图查找能理解给定 URL 的驱动程序。

返回变量类型为 Driver 的类型的 java.sql 中的方法
static Enumeration<Driver> DriverManager.getDrivers()
获取带有当前调用者可以访问的所有当前已加载 JDBC 驱动程序的 Enumeration。

参数类型为 Driver 的 java.sql 中的方法
static void | DriverManager.deregisterDriver(Driver driver) 从 DriverManager 的列表中删除一个驱动程序。
static void | DriverManager.registerDriver(Driver driver) 向 DriverManager 注册给定驱动程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.DriverManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.DriverManager
的使用

没有 java.sql.DriverManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.DriverPropertyInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.DriverPropertyInfo
的使用

使用 DriverPropertyInfo 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 DriverPropertyInfo 的使用

返回 DriverPropertyInfo 的 java.sql 中的方法
 DriverPropertyInfo[] Driver.getPropertyInfo(String url, Properties info)
获得此驱动程序的可能属性信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.NClob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.NClob
的使用

使用 NClob 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 NClob 的使用

返回 NClob 的 java.sql 中的方法
NClob | Connection.createNClob() 构造实现 NClob 接口的对象。
NClob | CallableStatement.getNClob(int parameterIndex) 以 Java 编程语言中 java.sql.NClob 对象的形式获取指定的 JDBC NCLOB 参数的值。
NClob | ResultSet.getNClob(int columnIndex) 以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
NClob | CallableStatement.getNClob(String parameterName) 以 Java 编程语言中 java.sql.NClob 对象的形式获取 JDBC NCLOB 参数的值。
NClob | ResultSet.getNClob(String columnLabel) 以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
NClob | SQLInput.readNClob() 从流中读取一个 SQL NCLOB 值，并以 Java 编程语言中 NCLOB 对象的形式返回。

参数类型为 NClob 的 java.sql 中的方法
void | PreparedStatement.setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | CallableStatement.setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | ResultSet.updateNClob(int columnIndex, NClob nClob) 用 java.sql.NClob 值更新指定的列。
void | ResultSet.updateNClob(String columnLabel, NClob nClob) 用 java.sql.NClob 值更新指定的列。
void | SQLOutput.writeNClob(NClob x) 将 SQL NCLOB 值写入流中。

javax.sql 中 NClob 的使用

参数类型为 NClob 的 javax.sql 中的方法
void | RowSet.setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | RowSet.setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。

javax.sql.rowset 中 NClob 的使用

参数类型为 NClob 的 javax.sql.rowset 中的方法
void | BaseRowSet.setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | BaseRowSet.setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。

javax.sql.rowset.serial 中 NClob 的使用

返回 NClob 的 javax.sql.rowset.serial 中的方法
 NClob SQLInputImpl.readNClob()
从流中读取 SQL NCLOB 值并以 Java 编程语言中 Clob 对象的形式返回。

参数类型为 NClob 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeNClob(NClob x)
将 SQL NCLOB 值写入流中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.ParameterMetaData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.ParameterMetaData
的使用

使用 ParameterMetaData 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 ParameterMetaData 的使用

返回 ParameterMetaData 的 java.sql 中的方法
 ParameterMetaData PreparedStatement.getParameterMetaData()
获取此 PreparedStatement 对象的参数的编号、类型和属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.PreparedStatement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.PreparedStatement
的使用

使用 PreparedStatement 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

java.sql 中 PreparedStatement 的使用

java.sql 中 PreparedStatement 的子接口
 interface CallableStatement
用于执行 SQL 存储过程的接口。

返回 PreparedStatement 的 java.sql 中的方法
PreparedStatement | Connection.prepareStatement(String sql) 创建一个 PreparedStatement 对象来将参数化的 SQL 语句发送到数据库。
PreparedStatement | Connection.prepareStatement(String sql, int autoGeneratedKeys) 创建一个默认 PreparedStatement 对象，该对象能获取自动生成的键。
PreparedStatement | Connection.prepareStatement(String sql, int[] columnIndexes) 创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
PreparedStatement | Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency) 创建一个 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
PreparedStatement | Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 创建一个 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
PreparedStatement | Connection.prepareStatement(String sql, String[] columnNames) 创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。

javax.sql 中 PreparedStatement 的使用

返回 PreparedStatement 的 javax.sql 中的方法
 PreparedStatement StatementEvent.getStatement()
返回正在关闭或无效的 PreparedStatement。

参数类型为 PreparedStatement 的 javax.sql 中的构造方法
StatementEvent(PooledConnection con, PreparedStatement statement)
用指定的 PooledConnection 和 PreparedStatement 构造 StatementEvent。
StatementEvent(PooledConnection con, PreparedStatement statement, SQLException exception)
用指定的 PooledConnection、PreparedStatement 和 SQLException 构造 StatementEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.Ref 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Ref
的使用

使用 Ref 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Ref 的使用

返回 Ref 的 java.sql 中的方法
Ref | CallableStatement.getRef(int parameterIndex) 以 Java 编程语言中 Ref 对象的形式获取指定的 JDBC REF(<structured-type>) 参数的值。
Ref | ResultSet.getRef(int columnIndex) 以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Ref | CallableStatement.getRef(String parameterName) 以 Java 编程语言中 Ref 对象的形式获取 JDBC REF(<structured-type>) 参数的值。
Ref | ResultSet.getRef(String columnLabel) 以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Ref | SQLInput.readRef() 从流读取 SQL REF 值并将其作为 Java 编程语言中的 Ref 对象返回。

参数类型为 Ref 的 java.sql 中的方法
void | PreparedStatement.setRef(int parameterIndex, Ref x) 将指定参数设置为给定 REF(<structured-type>) 值。
void | ResultSet.updateRef(int columnIndex, Ref x) 用 java.sql.Ref 值更新指定列。
void | ResultSet.updateRef(String columnLabel, Ref x) 用 java.sql.Ref 值更新指定列。
void | SQLOutput.writeRef(Ref x) 将 SQL REF 值写入流中。

javax.sql 中 Ref 的使用

参数类型为 Ref 的 javax.sql 中的方法
 void RowSet.setRef(int i, Ref x)
使用给定 Ref 值设置此 RowSet 对象命令中的指定参数。

javax.sql.rowset 中 Ref 的使用

参数类型为 Ref 的 javax.sql.rowset 中的方法
 void BaseRowSet.setRef(int parameterIndex, Ref ref)
将指定参数设置为 Java 编程语言中的给定 Ref 对象。

javax.sql.rowset.serial 中 Ref 的使用

实现 Ref 的 javax.sql.rowset.serial 中的类
 class SerialRef
Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。

返回 Ref 的 javax.sql.rowset.serial 中的方法
 Ref SQLInputImpl.readRef()
以 Java 编程语言中 Ref 对象的形式获取此 SQLInputImpl 对象的头部值。

参数类型为 Ref 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeRef(Ref x)
将 Java 编程语言中的 Ref 对象写入此 SQLOutputImpl 对象。

参数类型为 Ref 的 javax.sql.rowset.serial 中的构造方法
SerialRef(Ref ref)
根据给定 Ref 对象构造 SerialRef 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.ResultSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.ResultSet
的使用

使用 ResultSet 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.sql 中 ResultSet 的使用

返回 ResultSet 的 java.sql 中的方法
ResultSet | PreparedStatement.executeQuery() 在此 PreparedStatement 对象中执行 SQL 查询，并返回该查询生成的 ResultSet 对象。
ResultSet | Statement.executeQuery(String sql) 执行给定的 SQL 语句，该语句返回单个 ResultSet 对象。
ResultSet | DatabaseMetaData.getAttributes(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern) 获取可在给定模式和类别中使用的用户定义类型 (UDT) 的给定类型的给定属性的描述。
ResultSet | DatabaseMetaData.getBestRowIdentifier(String catalog, String schema, String table, int scope, boolean nullable) 获取唯一标识行的表的最佳列集合的描述。
ResultSet | DatabaseMetaData.getCatalogs() 获取可在此数据库中使用的类别名称。
ResultSet | DatabaseMetaData.getClientInfoProperties() 获取驱动程序支持的客户端信息属性的列表。
ResultSet | DatabaseMetaData.getColumnPrivileges(String catalog, String schema, String table, String columnNamePattern) 获取用于表列的访问权的描述。
ResultSet | DatabaseMetaData.getColumns(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern) 获取可在指定类别中使用的表列的描述。
ResultSet | DatabaseMetaData.getCrossReference(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable) 获取给定外键列表中外键列的描述，这些列引用主键或表示父表（可能是相同的表，也可能是不同的表）唯一约束的列。
ResultSet | DatabaseMetaData.getExportedKeys(String catalog, String schema, String table) 获取引用给定表的主键列（表导入的外键）的外键列的描述。
ResultSet | DatabaseMetaData.getFunctionColumns(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern) 获取给定类别的系统或用户函数参数和返回类型的描述。
ResultSet | DatabaseMetaData.getFunctions(String catalog, String schemaPattern, String functionNamePattern) 获取给定类别中可用的系统和用户函数的描述。
ResultSet | Statement.getGeneratedKeys() 获取由于执行此 Statement 对象而创建的所有自动生成的键。
ResultSet | DatabaseMetaData.getImportedKeys(String catalog, String schema, String table) 获取由给定表的外键列（表导入的主键）引用的主键列的描述。
ResultSet | DatabaseMetaData.getIndexInfo(String catalog, String schema, String table, boolean unique, boolean approximate) 获取给定表的索引和统计信息的描述。
ResultSet | DatabaseMetaData.getPrimaryKeys(String catalog, String schema, String table) 获取对给定表的主键列的描述。
ResultSet | DatabaseMetaData.getProcedureColumns(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern) 获取给定类别的存储过程参数和结果列的描述。
ResultSet | DatabaseMetaData.getProcedures(String catalog, String schemaPattern, String procedureNamePattern) 获取可在给定类别中使用的存储过程的描述。
ResultSet | Array.getResultSet() 获取包含此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
ResultSet | Statement.getResultSet() 以 ResultSet 对象的形式获取当前结果。
ResultSet | Array.getResultSet(long index, int count) 获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
ResultSet | Array.getResultSet(long index, int count, Map<String,Class<?>> map) 获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
ResultSet | Array.getResultSet(Map<String,Class<?>> map) 获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
ResultSet | DatabaseMetaData.getSchemas() 获取可在此数据库中使用的模式名称。
ResultSet | DatabaseMetaData.getSchemas(String catalog, String schemaPattern) 获取此数据库中可用的模式名称。
ResultSet | DatabaseMetaData.getSuperTables(String catalog, String schemaPattern, String tableNamePattern) 获取在此数据库的特定模式中定义的表分层结构的描述。
ResultSet | DatabaseMetaData.getSuperTypes(String catalog, String schemaPattern, String typeNamePattern) 获取在此数据库的特定模式中定义的用户定义类型 (UDT) 分层结构的描述。
ResultSet | DatabaseMetaData.getTablePrivileges(String catalog, String schemaPattern, String tableNamePattern) 获取可在类别中使用的每个表的访问权的描述。
ResultSet | DatabaseMetaData.getTables(String catalog, String schemaPattern, String tableNamePattern, String[] types) 获取可在给定类别中使用的表的描述。
ResultSet | DatabaseMetaData.getTableTypes() 获取可在此数据库中使用的表类型。
ResultSet | DatabaseMetaData.getTypeInfo() 获取此数据库支持的所有数据类型的描述。
ResultSet | DatabaseMetaData.getUDTs(String catalog, String schemaPattern, String typeNamePattern, int[] types) 获取在特定模式中定义的用户定义类型 (UDT) 的描述。
ResultSet | DatabaseMetaData.getVersionColumns(String catalog, String schema, String table) 获取在更新行中的任意值时自动更新的表列的描述。

javax.sql 中 ResultSet 的使用

javax.sql 中 ResultSet 的子接口
 interface RowSet
该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。

返回 ResultSet 的 javax.sql 中的方法
ResultSet | RowSetInternal.getOriginal() 获取包含此 RowSet 对象原始值的 ResultSet 对象。
ResultSet | RowSetInternal.getOriginalRow() 获取仅包含当前行原始值的 ResultSet 对象。

javax.sql.rowset 中 ResultSet 的使用

javax.sql.rowset 中 ResultSet 的子接口
interface | CachedRowSet 所有标准 CachedRowSet 实现都必须实现的接口。
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JdbcRowSet 所有标准 JdbcRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
interface | WebRowSet 所有 WebRowSet 的实现都必须实现的标准接口。

返回 ResultSet 的 javax.sql.rowset 中的方法
ResultSet | CachedRowSet.getOriginal() 返回一个包含此 CachedRowSet 对象原始值的 ResultSet 对象。
ResultSet | CachedRowSet.getOriginalRow() 返回一个只包含此 CachedRowSet 对象当前行原始值的 ResultSet 对象。

参数类型为 ResultSet 的 javax.sql.rowset 中的方法
void | CachedRowSet.populate(ResultSet data) 使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
void | CachedRowSet.populate(ResultSet rs, int startRow) 使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
void | WebRowSet.writeXml(ResultSet rs, OutputStream oStream) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。
void | WebRowSet.writeXml(ResultSet rs, Writer writer) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 Writer 对象。

javax.sql.rowset.serial 中 ResultSet 的使用

返回 ResultSet 的 javax.sql.rowset.serial 中的方法
ResultSet | SerialArray.getResultSet() 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 ARRAY 值中的元素。
ResultSet | SerialArray.getResultSet(long index, int count) 获取保存子数组元素的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(long index, int count, Map<String,Class<?>> map) 获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(Map<String,Class<?>> map) 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。

javax.sql.rowset.spi 中 ResultSet 的使用

javax.sql.rowset.spi 中 ResultSet 的子接口
 interface SyncResolver
定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.ResultSetMetaData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.ResultSetMetaData
的使用

使用 ResultSetMetaData 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

java.sql 中 ResultSetMetaData 的使用

返回 ResultSetMetaData 的 java.sql 中的方法
ResultSetMetaData | PreparedStatement.getMetaData() 获取包含有关 ResultSet 对象列信息的 ResultSetMetaData 对象，ResultSet 对象将在执行此 PreparedStatement 对象时返回。
ResultSetMetaData | ResultSet.getMetaData() 获取此 ResultSet 对象的列的编号、类型和属性。

javax.sql 中 ResultSetMetaData 的使用

javax.sql 中 ResultSetMetaData 的子接口
 interface RowSetMetaData
该对象包含关于 RowSet 对象的列的信息。

javax.sql.rowset 中 ResultSetMetaData 的使用

实现 ResultSetMetaData 的 javax.sql.rowset 中的类
 class RowSetMetaDataImpl
为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.RowId 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.RowId
的使用

使用 RowId 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 RowId 的使用

返回 RowId 的 java.sql 中的方法
RowId | CallableStatement.getRowId(int parameterIndex) 以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
RowId | ResultSet.getRowId(int columnIndex) 以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
RowId | CallableStatement.getRowId(String parameterName) 以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
RowId | ResultSet.getRowId(String columnLabel) 以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
RowId | SQLInput.readRowId() 从流中读取一个 SQL ROWID 值，并以 Java 编程语言中 RowId 对象的形式返回。

参数类型为 RowId 的 java.sql 中的方法
void | PreparedStatement.setRowId(int parameterIndex, RowId x) 将指定参数设置为给定 java.sql.RowId 对象。
void | CallableStatement.setRowId(String parameterName, RowId x) 将指定参数设置为给定 java.sql.RowId 对象。
void | ResultSet.updateRowId(int columnIndex, RowId x) 用 RowId 值更新指定列。
void | ResultSet.updateRowId(String columnLabel, RowId x) 用 RowId 值更新指定的列。
void | SQLOutput.writeRowId(RowId x) 将 SQL ROWID 值写入流中。

javax.sql 中 RowId 的使用

参数类型为 RowId 的 javax.sql 中的方法
void | RowSet.setRowId(int parameterIndex, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | RowSet.setRowId(String parameterName, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。

javax.sql.rowset 中 RowId 的使用

参数类型为 RowId 的 javax.sql.rowset 中的方法
void | BaseRowSet.setRowId(int parameterIndex, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | BaseRowSet.setRowId(String parameterName, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。

javax.sql.rowset.serial 中 RowId 的使用

返回 RowId 的 javax.sql.rowset.serial 中的方法
 RowId SQLInputImpl.readRowId()
从流中读取 SQL ROWID 值并以 Java 编程语言中 RowId 对象的形式返回。

参数类型为 RowId 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeRowId(RowId x)
将 SQL ROWID 值写入流中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.RowIdLifetime 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.RowIdLifetime
的使用

使用 RowIdLifetime 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 RowIdLifetime 的使用

返回 RowIdLifetime 的 java.sql 中的方法
RowIdLifetime | DatabaseMetaData.getRowIdLifetime() 指示此数据源是否支持 SQL ROWID 类型，如果支持，则 RowId 对象在该类型的生存期内持续有效。
static RowIdLifetime | RowIdLifetime.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RowIdLifetime[] | RowIdLifetime.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.Savepoint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Savepoint
的使用

使用 Savepoint 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.sql 中 Savepoint 的使用

返回 Savepoint 的 java.sql 中的方法
Savepoint | Connection.setSavepoint() 在当前事务中创建一个未命名的保存点 (savepoint)，并返回表示它的新 Savepoint 对象。
Savepoint | Connection.setSavepoint(String name) 在当前事务中创建一个具有给定名称的保存点，并返回表示它的新 Savepoint 对象。

参数类型为 Savepoint 的 java.sql 中的方法
void | Connection.releaseSavepoint(Savepoint savepoint) 从当前事务中移除指定的 Savepoint 和后续 Savepoint 对象。
void | Connection.rollback(Savepoint savepoint) 取消所有设置给定 Savepoint 对象之后进行的更改。

javax.sql.rowset 中 Savepoint 的使用

参数类型为 Savepoint 的 javax.sql.rowset 中的方法
void | CachedRowSet.rollback(Savepoint s) 每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
void | JdbcRowSet.rollback(Savepoint s) 每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。

javax.sql.rowset.spi 中 Savepoint 的使用

参数类型为 Savepoint 的 javax.sql.rowset.spi 中的方法
 void TransactionalWriter.rollback(Savepoint s)
撤消在给定 Savepoint 对象之前所进行的当前事务中的所有更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLClientInfoException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLClientInfoException
的使用

使用 SQLClientInfoException 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 SQLClientInfoException 的使用

抛出 SQLClientInfoException 的 java.sql 中的方法
void | Connection.setClientInfo(Properties properties) 设置连接的客户端信息属性的值。
void | Connection.setClientInfo(String name, String value) 将 name 指定的客户端信息属性的值设置为 value 指定的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.SQLData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.SQLData
的使用

使用 SQLData 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 SQLData 的使用

参数类型为 SQLData 的 java.sql 中的方法
 void SQLOutput.writeObject(SQLData x)
将给定 SQLData 对象中包含的数据写入流中。

javax.sql.rowset.serial 中 SQLData 的使用

参数类型为 SQLData 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeObject(SQLData x)
将包含在给定 SQLData 对象中的数据写入流中。

参数类型为 SQLData 的 javax.sql.rowset.serial 中的构造方法
SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLDataException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLDataException
的使用

没有 java.sql.SQLDataException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLException
的使用

使用 SQLException 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.sql 中 SQLException 的使用

java.sql 中 SQLException 的子类
class | BatchUpdateException 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
class | DataTruncation 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
class | SQLClientInfoException 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLNonTransientException 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
class | SQLRecoverableException 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
class | SQLTransientException 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
class | SQLWarning 提供关于数据库访问警告信息的异常。

返回 SQLException 的 java.sql 中的方法
 SQLException SQLException.getNextException()
通过 setNextException(SQLException ex) 获取链接到此 SQLException 对象的异常。

参数类型为 SQLException 的 java.sql 中的方法
 void SQLException.setNextException(SQLException ex)
将 SQLException 对象添加到链接的末尾。

抛出 SQLException 的 java.sql 中的方法
 boolean ResultSet.absolute(int row)
将光标移动到此 ResultSet 对象的给定行编号。
 boolean Driver.acceptsURL(String url)
查询驱动程序是否认为它可以打开到给定 URL 的连接。
 void PreparedStatement.addBatch()
将一组参数添加到此 PreparedStatement 对象的批处理命令中。
 void Statement.addBatch(String sql)
将给定的 SQL 命令添加到此 Statement 对象的当前命令列表中。
 void ResultSet.afterLast()
将光标移动到此 ResultSet 对象的末尾，正好位于最后一行之后。
 boolean DatabaseMetaData.allProceduresAreCallable()
获取当前用户是否可以调用 getProcedures 方法返回的所有过程。
 boolean DatabaseMetaData.allTablesAreSelectable()
获取当前用户是否可以使用 SELECT 语句中的 getTables 方法返回的所有表。
 boolean DatabaseMetaData.autoCommitFailureClosesAllResultSets()
当 autoCommit 为 true 时，获取 SQLException 是否指示所有打开的 ResultSets 已关闭（包括那些可保持的）。
 void ResultSet.beforeFirst()
将光标移动到此 ResultSet 对象的开头，正好位于第一行之前。
 void Statement.cancel()
如果 DBMS 和驱动程序都支持中止 SQL 语句，则取消此 Statement 对象。
 void ResultSet.cancelRowUpdates()
取消对 ResultSet 对象中的当前行所作的更新。
 void Statement.clearBatch()
清空此 Statement 对象的当前 SQL 命令列表。
 void PreparedStatement.clearParameters()
立即清除当前参数值。
 void Connection.clearWarnings()
清除为此 Connection 对象报告的所有警告。
 void ResultSet.clearWarnings()
清除在此 ResultSet 对象上报告的所有警告。
 void Statement.clearWarnings()
清除在此 Statement 对象上报告的所有警告。
 void Connection.close()
立即释放此 Connection 对象的数据库和 JDBC 资源，而不是等待它们被自动释放。
 void ResultSet.close()
立即释放此 ResultSet 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。
 void Statement.close()
立即释放此 Statement 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。
 void Connection.commit()
使所有上一次提交/回滚后进行的更改成为持久更改，并释放此 Connection 对象当前持有的所有数据库锁。
 Connection Driver.connect(String url, Properties info)
试图创建一个到给定 URL 的数据库连接。
 Array Connection.createArrayOf(String typeName, Object[] elements)
创建 Array 对象的工厂方法。
 Blob Connection.createBlob()
构造实现 Blob 接口的对象。
 Clob Connection.createClob()
构造实现 Clob 接口的对象。
 NClob Connection.createNClob()
构造实现 NClob 接口的对象。
 SQLXML Connection.createSQLXML()
构造实现 SQLXML 接口的对象。
 Statement Connection.createStatement()
创建一个 Statement 对象来将 SQL 语句发送到数据库。
 Statement Connection.createStatement(int resultSetType, int resultSetConcurrency)
创建一个 Statement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
 Statement Connection.createStatement(int resultSetType, int resultSetConcurrency, int resultSetHoldability)
创建一个 Statement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
 Struct Connection.createStruct(String typeName, Object[] attributes)
创建 Struct 对象的工厂方法。
 boolean DatabaseMetaData.dataDefinitionCausesTransactionCommit()
获取事务中的数据定义语句是否强迫该事务进行提交。
 boolean DatabaseMetaData.dataDefinitionIgnoredInTransactions()
获取此数据库是否忽略事务中的数据定义语句。
 void ResultSet.deleteRow()
从此 ResultSet 对象和底层数据库中删除当前行。
 boolean DatabaseMetaData.deletesAreDetected(int type)
获取是否可以通过调用 ResultSet.rowDeleted 方法检测可见行的删除。
static void DriverManager.deregisterDriver(Driver driver)
从 DriverManager 的列表中删除一个驱动程序。
 boolean DatabaseMetaData.doesMaxRowSizeIncludeBlobs()
获取 getMaxRowSize 方法的返回值是否包括 SQL 数据类型 LONGVARCHAR 和 LONGVARBINARY。
 boolean PreparedStatement.execute()
在此 PreparedStatement 对象中执行 SQL 语句，该语句可以是任何种类的 SQL 语句。
 boolean Statement.execute(String sql)
执行给定的 SQL 语句，该语句可能返回多个结果。
 boolean Statement.execute(String sql, int autoGeneratedKeys)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序所有自动生成的键都应该可用于获取。
 boolean Statement.execute(String sql, int[] columnIndexes)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
 boolean Statement.execute(String sql, String[] columnNames)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
 int[] Statement.executeBatch()
将一批命令提交给数据库来执行，如果全部命令执行成功，则返回更新计数组成的数组。
 ResultSet PreparedStatement.executeQuery()
在此 PreparedStatement 对象中执行 SQL 查询，并返回该查询生成的 ResultSet 对象。
 ResultSet Statement.executeQuery(String sql)
执行给定的 SQL 语句，该语句返回单个 ResultSet 对象。
 int PreparedStatement.executeUpdate()
在此 PreparedStatement 对象中执行 SQL 语句，该语句必须是一个 SQL 数据操作语言（Data Manipulation Language，DML）语句，比如 INSERT、UPDATE 或 DELETE 语句；或者是无返回内容的 SQL 语句，比如 DDL 语句。
 int Statement.executeUpdate(String sql)
执行给定 SQL 语句，该语句可能为 INSERT、UPDATE 或 DELETE 语句，或者不返回任何内容的 SQL 语句（如 SQL DDL 语句）。
 int Statement.executeUpdate(String sql, int autoGeneratedKeys)
执行给定的 SQL 语句，并用给定标志通知驱动程序由此 Statement 生成的自动生成键是否可用于获取。
 int Statement.executeUpdate(String sql, int[] columnIndexes)
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
 int Statement.executeUpdate(String sql, String[] columnNames)
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
 int ResultSet.findColumn(String columnLabel)
将给定的 ResultSet 列标签映射到其 ResultSet 列索引。
 boolean ResultSet.first()
将光标移动到此 ResultSet 对象的第一行。
 void Array.free()
此方法释放 Array 对象以及它占用的资源。
 void Blob.free()
此方法释放 Blob 对象以及它所占用的资源。
 void Clob.free()
此方法释放 Clob 对象以及它所占用的资源。
 void SQLXML.free()
此方法关闭此对象并释放其持有的资源。
 Object Array.getArray()
以 Java 编程语言数组的形式获取由此 Array 对象指定的 SQL ARRAY 值的内容。
 Array CallableStatement.getArray(int parameterIndex)
以 Java 编程语言中 Array 对象的形式获取指定的 JDBC ARRAY 参数的值。
 Array ResultSet.getArray(int columnIndex)
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Object Array.getArray(long index, int count)
获取由此 Array 对象指定的 SQL ARRAY 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
 Object Array.getArray(long index, int count, Map<String,Class<?>> map)
获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
 Object Array.getArray(Map<String,Class<?>> map)
获取由此 Array 对象指定的 SQL ARRAY 值的内容。
 Array CallableStatement.getArray(String parameterName)
以 Java 编程语言中 java.sql.ARRAY 对象的形式获取 JDBC ARRAY 参数的值。
 Array ResultSet.getArray(String columnLabel)
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 InputStream Clob.getAsciiStream()
以 ascii 流形式获取此 Clob 对象指定的 CLOB 值。
 InputStream ResultSet.getAsciiStream(int columnIndex)
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
 InputStream ResultSet.getAsciiStream(String columnLabel)
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
 Object[] Struct.getAttributes()
生成此 Struct 对象所表示的 SQL 结构类型属性的有序值。
 Object[] Struct.getAttributes(Map<String,Class<?>> map)
生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。
 ResultSet DatabaseMetaData.getAttributes(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern)
获取可在给定模式和类别中使用的用户定义类型 (UDT) 的给定类型的给定属性的描述。
 boolean Connection.getAutoCommit()
获取此 Connection 对象的当前自动提交模式。
 int Array.getBaseType()
在由此 Array 对象指定的数组中获取元素的 JDBC 类型。
 String Array.getBaseTypeName()
在由此 Array 对象指定的数组中获取元素的 SQL 类型名称。
 String Ref.getBaseTypeName()
获取此 Ref 对象所引用 SQL 结构类型的完全限定的 SQL 名称。
 ResultSet DatabaseMetaData.getBestRowIdentifier(String catalog, String schema, String table, int scope, boolean nullable)
获取唯一标识行的表的最佳列集合的描述。
 BigDecimal CallableStatement.getBigDecimal(int parameterIndex)
以 java.math.BigDecimal 对象的形式获取指定 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
 BigDecimal ResultSet.getBigDecimal(int columnIndex)
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
 BigDecimal CallableStatement.getBigDecimal(int parameterIndex, int scale)
已过时。 使用 getBigDecimal(int parameterIndex) 或 getBigDecimal(String parameterName)
 BigDecimal ResultSet.getBigDecimal(int columnIndex, int scale)
已过时。
 BigDecimal CallableStatement.getBigDecimal(String parameterName)
以 java.math.BigDecimal 对象的形式获取 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
 BigDecimal ResultSet.getBigDecimal(String columnLabel)
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
 BigDecimal ResultSet.getBigDecimal(String columnLabel, int scale)
已过时。
 InputStream Blob.getBinaryStream()
以流的形式获取此 Blob 实例指定的 BLOB 值。
 InputStream SQLXML.getBinaryStream()
以流的形式获取此 SQLXML 实例指定的 XML 值。
 InputStream ResultSet.getBinaryStream(int columnIndex)
以未解释字节的流的形式获取此 ResultSet 对象的当前行中指定列的值。
 InputStream Blob.getBinaryStream(long pos, long length)
返回包含部分 Blob 值的 InputStream 对象，该值从 pos 指定的字节开始，长度为 length 个字节。
 InputStream ResultSet.getBinaryStream(String columnLabel)
以未解释的 byte 流的形式获取此 ResultSet 对象的当前行中指定列的值。
 Blob CallableStatement.getBlob(int parameterIndex)
以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
 Blob ResultSet.getBlob(int columnIndex)
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Blob CallableStatement.getBlob(String parameterName)
以 Java 编程语言中 Blob 对象的形式获取 JDBC BLOB 参数的值。
 Blob ResultSet.getBlob(String columnLabel)
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 boolean CallableStatement.getBoolean(int parameterIndex)
以 Java 编程语言中 boolean 值的形式获取指定的 JDBC BIT 或 BOOLEAN 参数的值。
 boolean ResultSet.getBoolean(int columnIndex)
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。
 boolean CallableStatement.getBoolean(String parameterName)
以 Java 编程语言中 boolean 值的形式获取 JDBC BIT 或 BOOLEAN 参数的值。
 boolean ResultSet.getBoolean(String columnLabel)
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。
 byte CallableStatement.getByte(int parameterIndex)
以 Java 编程语言中 byte 的形式获取指定的 JDBC TINYINT 参数的值。
 byte ResultSet.getByte(int columnIndex)
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。
 byte CallableStatement.getByte(String parameterName)
以 Java 编程语言中 byte 值的形式获取 JDBC TINYINT 参数的值。
 byte ResultSet.getByte(String columnLabel)
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。
 byte[] CallableStatement.getBytes(int parameterIndex)
以 Java 编程语言中 byte 数组值的形式获取指定的 JDBC BINARY 或 VARBINARY 参数的值。
 byte[] ResultSet.getBytes(int columnIndex)
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。
 byte[] Blob.getBytes(long pos, int length)
以 byte 数组的形式获取此 Blob 对象表示的全部或部分 BLOB 值。
 byte[] CallableStatement.getBytes(String parameterName)
以 Java 编程语言中 byte 数组值的形式获取 JDBC BINARY 或 VARBINARY 参数的值。
 byte[] ResultSet.getBytes(String columnLabel)
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。
 String Connection.getCatalog()
获取此 Connection 对象的当前目录名称。
 String ResultSetMetaData.getCatalogName(int column)
获取指定列的表目录名称。
 ResultSet DatabaseMetaData.getCatalogs()
获取可在此数据库中使用的类别名称。
 String DatabaseMetaData.getCatalogSeparator()
获取此数据库用作类别和表名之间的分隔符的 String。
 String DatabaseMetaData.getCatalogTerm()
获取数据库供应商用于 "catalog" 的首选术语。
 Reader Clob.getCharacterStream()
以 java.io.Reader 对象形式（或字符流形式）获取此 Clob 对象指定的 CLOB 值。
 Reader SQLXML.getCharacterStream()
以 java.io.Reader 对象的形式获取此 SQLXML 实例指定的 XML 值。
 Reader CallableStatement.getCharacterStream(int parameterIndex)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
 Reader ResultSet.getCharacterStream(int columnIndex)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Reader Clob.getCharacterStream(long pos, long length)
返回包含部分 Clob 值的 Reader 对象，该值从 pos 指定的字符开始，长度为 length 个字符。
 Reader CallableStatement.getCharacterStream(String parameterName)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
 Reader ResultSet.getCharacterStream(String columnLabel)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Properties Connection.getClientInfo()
返回一个列表，它包含驱动程序支持的每个客户端信息属性的名称和当前值。
 String Connection.getClientInfo(String name)
返回通过名称指定的客户端信息属性的值。
 ResultSet DatabaseMetaData.getClientInfoProperties()
获取驱动程序支持的客户端信息属性的列表。
 Clob CallableStatement.getClob(int parameterIndex)
以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
 Clob ResultSet.getClob(int columnIndex)
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Clob CallableStatement.getClob(String parameterName)
以 Java 编程语言中 java.sql.CLOB 对象的形式获取 JDBC CLOB 参数的值。
 Clob ResultSet.getClob(String columnLabel)
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 String ResultSetMetaData.getColumnClassName(int column)
如果调用方法 ResultSet.getObject 从列中获取值，则返回构造其实例的 Java 类的完全限定名称。
 int ResultSetMetaData.getColumnCount()
返回此 ResultSet 对象中的列数。
 int ResultSetMetaData.getColumnDisplaySize(int column)
指示指定列的最大标准宽度，以字符为单位。
 String ResultSetMetaData.getColumnLabel(int column)
获取用于打印输出和显示的指定列的建议标题。
 String ResultSetMetaData.getColumnName(int column)
获取指定列的名称。
 ResultSet DatabaseMetaData.getColumnPrivileges(String catalog, String schema, String table, String columnNamePattern)
获取用于表列的访问权的描述。
 ResultSet DatabaseMetaData.getColumns(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)
获取可在指定类别中使用的表列的描述。
 int ResultSetMetaData.getColumnType(int column)
获取指定列的 SQL 类型。
 String ResultSetMetaData.getColumnTypeName(int column)
获取指定列的数据库特定的类型名称。
 int ResultSet.getConcurrency()
获取此 ResultSet 对象的并发模式。
 Connection DatabaseMetaData.getConnection()
获取此元数据对象所产生的连接。
 Connection Statement.getConnection()
获取生成此 Statement 对象的 Connection 对象。
static Connection DriverManager.getConnection(String url)
试图建立到给定数据库 URL 的连接。
static Connection DriverManager.getConnection(String url, Properties info)
试图建立到给定数据库 URL 的连接。
static Connection DriverManager.getConnection(String url, String user, String password)
试图建立到给定数据库 URL 的连接。
 ResultSet DatabaseMetaData.getCrossReference(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable)
获取给定外键列表中外键列的描述，这些列引用主键或表示父表（可能是相同的表，也可能是不同的表）唯一约束的列。
 String ResultSet.getCursorName()
获取此 ResultSet 对象使用的 SQL 光标的名称。
 int DatabaseMetaData.getDatabaseMajorVersion()
获取底层数据库的主版本号。
 int DatabaseMetaData.getDatabaseMinorVersion()
底层数据库的次版本号。
 String DatabaseMetaData.getDatabaseProductName()
获取此数据库产品的名称。
 String DatabaseMetaData.getDatabaseProductVersion()
获取此数据库产品的版本号。
 Date CallableStatement.getDate(int parameterIndex)
以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值。
 Date ResultSet.getDate(int columnIndex)
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Date CallableStatement.getDate(int parameterIndex, Calendar cal)
以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
 Date ResultSet.getDate(int columnIndex, Calendar cal)
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Date CallableStatement.getDate(String parameterName)
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值。
 Date ResultSet.getDate(String columnLabel)
以 Java 编程语言中的 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Date CallableStatement.getDate(String parameterName, Calendar cal)
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
 Date ResultSet.getDate(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 int DatabaseMetaData.getDefaultTransactionIsolation()
获取此数据库的默认事务隔离级别。
 double CallableStatement.getDouble(int parameterIndex)
以 Java 编程语言中 double 值的形式获取指定的 JDBC DOUBLE 参数的值。
 double ResultSet.getDouble(int columnIndex)
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。
 double CallableStatement.getDouble(String parameterName)
以 Java 编程语言中 double 值的形式获取 JDBC DOUBLE 参数的值。
 double ResultSet.getDouble(String columnLabel)
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。
static Driver DriverManager.getDriver(String url)
试图查找能理解给定 URL 的驱动程序。
 String DatabaseMetaData.getDriverName()
获取此 JDBC 驱动程序的名称。
 String DatabaseMetaData.getDriverVersion()
获取此 JDBC 驱动程序的 String 形式的版本号。
 ResultSet DatabaseMetaData.getExportedKeys(String catalog, String schema, String table)
获取引用给定表的主键列（表导入的外键）的外键列的描述。
 String DatabaseMetaData.getExtraNameCharacters()
获取可以在不带引号的标识符名称中使用的所有“额外”字符（除了 a-z、A-Z、0-9 和 _ 以外的字符）。
 int ResultSet.getFetchDirection()
获取此 ResultSet 对象的获取方向。
 int Statement.getFetchDirection()
获取从数据库表获取行的方向，该方向是根据此 Statement 对象生成的结果集合的默认值。
 int ResultSet.getFetchSize()
获取此 ResultSet 对象的获取大小。
 int Statement.getFetchSize()
获取结果集合的行数，该数是根据此 Statement 对象生成的 ResultSet 对象的默认获取大小。
 float CallableStatement.getFloat(int parameterIndex)
以 Java 编程语言中 float 值的形式获取指定的 JDBC FLOAT 参数的值。
 float ResultSet.getFloat(int columnIndex)
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。
 float CallableStatement.getFloat(String parameterName)
以 Java 编程语言中 float 值的形式获取 JDBC FLOAT 参数的值。
 float ResultSet.getFloat(String columnLabel)
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。
 ResultSet DatabaseMetaData.getFunctionColumns(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern)
获取给定类别的系统或用户函数参数和返回类型的描述。
 ResultSet DatabaseMetaData.getFunctions(String catalog, String schemaPattern, String functionNamePattern)
获取给定类别中可用的系统和用户函数的描述。
 ResultSet Statement.getGeneratedKeys()
获取由于执行此 Statement 对象而创建的所有自动生成的键。
 int Connection.getHoldability()
获取使用此 Connection 对象创建的 ResultSet 对象的当前可保存性。
 int ResultSet.getHoldability()
获取此 ResultSet 对象的可保存性
 String DatabaseMetaData.getIdentifierQuoteString()
获取用于引用 SQL 标识符的字符串。
 ResultSet DatabaseMetaData.getImportedKeys(String catalog, String schema, String table)
获取由给定表的外键列（表导入的主键）引用的主键列的描述。
 ResultSet DatabaseMetaData.getIndexInfo(String catalog, String schema, String table, boolean unique, boolean approximate)
获取给定表的索引和统计信息的描述。
 int CallableStatement.getInt(int parameterIndex)
以 Java 编程语言中 int 值的形式获取指定的 JDBC INTEGER 参数的值。
 int ResultSet.getInt(int columnIndex)
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。
 int CallableStatement.getInt(String parameterName)
以 Java 编程语言中 int 值的形式获取 JDBC INTEGER 参数的值。
 int ResultSet.getInt(String columnLabel)
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。
 int DatabaseMetaData.getJDBCMajorVersion()
获取此驱动程序的主 JDBC 版本号。
 int DatabaseMetaData.getJDBCMinorVersion()
获取此驱动程序的次 JDBC 版本号。
 long CallableStatement.getLong(int parameterIndex)
以 Java 编程语言中 long 值的形式获取指定的 JDBC BIGINT 参数的值。
 long ResultSet.getLong(int columnIndex)
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。
 long CallableStatement.getLong(String parameterName)
以 Java 编程语言中 long 值的形式获取 JDBC BIGINT 参数的值。
 long ResultSet.getLong(String columnLabel)
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。
 int DatabaseMetaData.getMaxBinaryLiteralLength()
获取此数据库允许在内嵌二进制字面值中使用的最大十六进制字符数。
 int DatabaseMetaData.getMaxCatalogNameLength()
获取此数据库允许用于类别名称的最大字符数。
 int DatabaseMetaData.getMaxCharLiteralLength()
获取此数据库允许用于字符字面值的最大字符数。
 int DatabaseMetaData.getMaxColumnNameLength()
获取此数据库允许用于列名称的最大字符数。
 int DatabaseMetaData.getMaxColumnsInGroupBy()
获取此数据库允许在 GROUP BY 子句中使用的最大列数。
 int DatabaseMetaData.getMaxColumnsInIndex()
获取此数据库允许在索引中使用的最大列数。
 int DatabaseMetaData.getMaxColumnsInOrderBy()
获取此数据库允许在 ORDER BY 子句中使用的最大列数。
 int DatabaseMetaData.getMaxColumnsInSelect()
获取此数据库允许在 SELECT 列表中使用的最大列数。
 int DatabaseMetaData.getMaxColumnsInTable()
获取此数据库允许在表中使用的最大列数。
 int DatabaseMetaData.getMaxConnections()
获取连接到此数据库的并发连接的可能最大数。
 int DatabaseMetaData.getMaxCursorNameLength()
获取此数据库允许用于游标名称的最大字符数。
 int Statement.getMaxFieldSize()
获取可以为此 Statement 对象所生成 ResultSet 对象中的字符和二进制列值返回的最大字节数。
 int DatabaseMetaData.getMaxIndexLength()
获取此数据库允许用于索引（包括索引的所有部分）的最大字节数。
 int DatabaseMetaData.getMaxProcedureNameLength()
获取此数据库允许用于过程名称的最大字符数。
 int Statement.getMaxRows()
获取由此 Statement 对象生成的 ResultSet 对象可以包含的最大行数。
 int DatabaseMetaData.getMaxRowSize()
获取此数据库允许在单行中使用的最大字节数。
 int DatabaseMetaData.getMaxSchemaNameLength()
获取此数据库允许在模式名称中使用的最大字符数。
 int DatabaseMetaData.getMaxStatementLength()
获取此数据库允许在 SQL 语句中使用的最大字符数。
 int DatabaseMetaData.getMaxStatements()
获取在此数据库中在同一时间内可处于开放状态的最大活动语句数。
 int DatabaseMetaData.getMaxTableNameLength()
获取此数据库允许在表名称中使用的最大字符数。
 int DatabaseMetaData.getMaxTablesInSelect()
获取此数据库允许在 SELECT 语句中使用的表的最大数量。
 int DatabaseMetaData.getMaxUserNameLength()
获取此数据库允许在用户名称中使用的最大字符数。
 DatabaseMetaData Connection.getMetaData()
获取一个 DatabaseMetaData 对象，该对象包含关于此 Connection 对象所连接的数据库的元数据。
 ResultSetMetaData PreparedStatement.getMetaData()
获取包含有关 ResultSet 对象列信息的 ResultSetMetaData 对象，ResultSet 对象将在执行此 PreparedStatement 对象时返回。
 ResultSetMetaData ResultSet.getMetaData()
获取此 ResultSet 对象的列的编号、类型和属性。
 boolean Statement.getMoreResults()
移动到此 Statement 对象的下一个结果，如果其为 ResultSet 对象，则返回 true，并隐式关闭利用方法 getResultSet 获取的所有当前 ResultSet 对象。
 boolean Statement.getMoreResults(int current)
将此 Statement 对象移动到下一个结果，根据给定标志指定的指令处理所有当前 ResultSet 对象；如果下一个结果为 ResultSet 对象，则返回 true。
 Reader CallableStatement.getNCharacterStream(int parameterIndex)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
 Reader ResultSet.getNCharacterStream(int columnIndex)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Reader CallableStatement.getNCharacterStream(String parameterName)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
 Reader ResultSet.getNCharacterStream(String columnLabel)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 NClob CallableStatement.getNClob(int parameterIndex)
以 Java 编程语言中 java.sql.NClob 对象的形式获取指定的 JDBC NCLOB 参数的值。
 NClob ResultSet.getNClob(int columnIndex)
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 NClob CallableStatement.getNClob(String parameterName)
以 Java 编程语言中 java.sql.NClob 对象的形式获取 JDBC NCLOB 参数的值。
 NClob ResultSet.getNClob(String columnLabel)
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 String CallableStatement.getNString(int parameterIndex)
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。
 String ResultSet.getNString(int columnIndex)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
 String CallableStatement.getNString(String parameterName)
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。
 String ResultSet.getNString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
 String DatabaseMetaData.getNumericFunctions()
获取可用于此数据库的数学函数的逗号分隔列表。
 Object Ref.getObject()
获取此 Ref 对象引用的 SQL 结构类型实例。
 Object CallableStatement.getObject(int parameterIndex)
以 Java 编程语言中 Object 的形式获取指定参数的值。
 Object ResultSet.getObject(int columnIndex)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
 Object CallableStatement.getObject(int parameterIndex, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。
 Object ResultSet.getObject(int columnIndex, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
 Object Ref.getObject(Map<String,Class<?>> map)
获取引用对象并使用给定类型映射表将其映射到 Java 类型。
 Object CallableStatement.getObject(String parameterName)
以 Java 编程语言中 Object 的形式获取参数的值。
 Object ResultSet.getObject(String columnLabel)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
 Object CallableStatement.getObject(String parameterName, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。
 Object ResultSet.getObject(String columnLabel, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
 String ParameterMetaData.getParameterClassName(int param)
获取 Java 类的完全限定名称，该类的实例应该传递给 PreparedStatement.setObject 方法。
 int ParameterMetaData.getParameterCount()
获取 PreparedStatement 对象中的参数的数量，此 ParameterMetaData 对象包含了该对象的信息。
 ParameterMetaData PreparedStatement.getParameterMetaData()
获取此 PreparedStatement 对象的参数的编号、类型和属性。
 int ParameterMetaData.getParameterMode(int param)
获取指定参数的模式。
 int ParameterMetaData.getParameterType(int param)
获取指定参数的 SQL 类型。
 String ParameterMetaData.getParameterTypeName(int param)
获取指定参数的特定于数据库的类型名称。
 int ParameterMetaData.getPrecision(int param)
获取指定参数的指定列大小。
 int ResultSetMetaData.getPrecision(int column)
获取指定列的指定列宽。
 ResultSet DatabaseMetaData.getPrimaryKeys(String catalog, String schema, String table)
获取对给定表的主键列的描述。
 ResultSet DatabaseMetaData.getProcedureColumns(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern)
获取给定类别的存储过程参数和结果列的描述。
 ResultSet DatabaseMetaData.getProcedures(String catalog, String schemaPattern, String procedureNamePattern)
获取可在给定类别中使用的存储过程的描述。
 String DatabaseMetaData.getProcedureTerm()
获取数据库供应商用于 "procedure" 的首选术语。
 DriverPropertyInfo[] Driver.getPropertyInfo(String url, Properties info)
获得此驱动程序的可能属性信息。
 int Statement.getQueryTimeout()
获取驱动程序等待 Statement 对象执行的秒数。
 Ref CallableStatement.getRef(int parameterIndex)
以 Java 编程语言中 Ref 对象的形式获取指定的 JDBC REF(<structured-type>) 参数的值。
 Ref ResultSet.getRef(int columnIndex)
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Ref CallableStatement.getRef(String parameterName)
以 Java 编程语言中 Ref 对象的形式获取 JDBC REF(<structured-type>) 参数的值。
 Ref ResultSet.getRef(String columnLabel)
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 ResultSet Array.getResultSet()
获取包含此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
 ResultSet Statement.getResultSet()
以 ResultSet 对象的形式获取当前结果。
 ResultSet Array.getResultSet(long index, int count)
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
 ResultSet Array.getResultSet(long index, int count, Map<String,Class<?>> map)
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
 ResultSet Array.getResultSet(Map<String,Class<?>> map)
获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
 int Statement.getResultSetConcurrency()
获取此 Statement 对象生成的 ResultSet 对象的结果集合并发性。
 int DatabaseMetaData.getResultSetHoldability()
针对 ResultSet 对象获取此数据库的默认可保存性。
 int Statement.getResultSetHoldability()
获取此 Statement 对象生成的 ResultSet 对象的结果集合可保存性。
 int Statement.getResultSetType()
获取此 Statement 对象生成的 ResultSet 对象的结果集合类型。
 int ResultSet.getRow()
获取当前行编号。
 RowId CallableStatement.getRowId(int parameterIndex)
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
 RowId ResultSet.getRowId(int columnIndex)
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 RowId CallableStatement.getRowId(String parameterName)
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
 RowId ResultSet.getRowId(String columnLabel)
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 RowIdLifetime DatabaseMetaData.getRowIdLifetime()
指示此数据源是否支持 SQL ROWID 类型，如果支持，则 RowId 对象在该类型的生存期内持续有效。
 int Savepoint.getSavepointId()
获取此 Savepoint 对象表示的保存点的生成 ID。
 String Savepoint.getSavepointName()
获取此 Savepoint 对象表示的保存点的名称。
 int ParameterMetaData.getScale(int param)
获取指定参数的小数点右边的位数。
 int ResultSetMetaData.getScale(int column)
获取指定列的小数点右边的位数。
 String ResultSetMetaData.getSchemaName(int column)
获取指定列的表模式。
 ResultSet DatabaseMetaData.getSchemas()
获取可在此数据库中使用的模式名称。
 ResultSet DatabaseMetaData.getSchemas(String catalog, String schemaPattern)
获取此数据库中可用的模式名称。
 String DatabaseMetaData.getSchemaTerm()
获取数据库供应商用于 "schema" 的首选术语。
 String DatabaseMetaData.getSearchStringEscape()
获取可用于转义通配符的字符串。
 short CallableStatement.getShort(int parameterIndex)
以 Java 编程语言中 short 值的形式获取指定的 JDBC SMALLINT 参数的值。
 short ResultSet.getShort(int columnIndex)
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。
 short CallableStatement.getShort(String parameterName)
以 Java 编程语言中 short 值的形式获取 JDBC SMALLINT 参数的值。
 short ResultSet.getShort(String columnLabel)
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。
<T extends Source>
T
SQLXML.getSource(Class<T> sourceClass)
返回读取此 SQLXML 实例指定的 XML 值的 Source。
 String DatabaseMetaData.getSQLKeywords()
获取此数据库的还“不”是 SQL:2003 关键字的所有 SQL 关键字的逗号分隔列表。
 int DatabaseMetaData.getSQLStateType()
指示由 SQLException.getSQLState 返回的 SQLSTATE 是 X/Open（现在称为 Open Group）SQL CLI 还是 SQL:2003。
 String SQLData.getSQLTypeName()
返回此对象表示的 SQL 用户定义类型的完全限定名。
 String Struct.getSQLTypeName()
获取此 Struct 对象所表示 SQL 结构的完全限定的 SQL 名称。
 SQLXML CallableStatement.getSQLXML(int parameterIndex)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
 SQLXML ResultSet.getSQLXML(int columnIndex)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 SQLXML CallableStatement.getSQLXML(String parameterName)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
 SQLXML ResultSet.getSQLXML(String columnLabel)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Statement ResultSet.getStatement()
获取生成此 ResultSet 对象的 Statement 对象。
 String SQLXML.getString()
返回此 SQLXML 实例指定的 XML 值的字符串表示形式。
 String CallableStatement.getString(int parameterIndex)
以 Java 编程语言中 String 的形式获取指定的 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。
 String ResultSet.getString(int columnIndex)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
 String CallableStatement.getString(String parameterName)
以 Java 编程语言中 String 的形式获取 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。
 String ResultSet.getString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
 String DatabaseMetaData.getStringFunctions()
获取可用于此数据库的字符串函数的逗号分隔列表。
 String Clob.getSubString(long pos, int length)
获取此 Clob 对象指定的 CLOB 值中指定子字符串的副本。
 ResultSet DatabaseMetaData.getSuperTables(String catalog, String schemaPattern, String tableNamePattern)
获取在此数据库的特定模式中定义的表分层结构的描述。
 ResultSet DatabaseMetaData.getSuperTypes(String catalog, String schemaPattern, String typeNamePattern)
获取在此数据库的特定模式中定义的用户定义类型 (UDT) 分层结构的描述。
 String DatabaseMetaData.getSystemFunctions()
获取可用于此数据库的系统函数的逗号分隔列表。
 String ResultSetMetaData.getTableName(int column)
获取指定列的名称。
 ResultSet DatabaseMetaData.getTablePrivileges(String catalog, String schemaPattern, String tableNamePattern)
获取可在类别中使用的每个表的访问权的描述。
 ResultSet DatabaseMetaData.getTables(String catalog, String schemaPattern, String tableNamePattern, String[] types)
获取可在给定类别中使用的表的描述。
 ResultSet DatabaseMetaData.getTableTypes()
获取可在此数据库中使用的表类型。
 Time CallableStatement.getTime(int parameterIndex)
以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值。
 Time ResultSet.getTime(int columnIndex)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Time CallableStatement.getTime(int parameterIndex, Calendar cal)
以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
 Time ResultSet.getTime(int columnIndex, Calendar cal)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Time CallableStatement.getTime(String parameterName)
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值。
 Time ResultSet.getTime(String columnLabel)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Time CallableStatement.getTime(String parameterName, Calendar cal)
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
 Time ResultSet.getTime(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 String DatabaseMetaData.getTimeDateFunctions()
获取可用于此数据库的时间和日期函数的逗号分隔列表。
 Timestamp CallableStatement.getTimestamp(int parameterIndex)
以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值。
 Timestamp ResultSet.getTimestamp(int columnIndex)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Timestamp CallableStatement.getTimestamp(int parameterIndex, Calendar cal)
以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
 Timestamp ResultSet.getTimestamp(int columnIndex, Calendar cal)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Timestamp CallableStatement.getTimestamp(String parameterName)
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值。
 Timestamp ResultSet.getTimestamp(String columnLabel)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Timestamp CallableStatement.getTimestamp(String parameterName, Calendar cal)
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
 Timestamp ResultSet.getTimestamp(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 int Connection.getTransactionIsolation()
获取此 Connection 对象的当前事务隔离级别。
 int ResultSet.getType()
获取此 ResultSet 对象的类型。
 ResultSet DatabaseMetaData.getTypeInfo()
获取此数据库支持的所有数据类型的描述。
 Map<String,Class<?>> Connection.getTypeMap()
获取与此 Connection 对象关联的 Map 对象。
 ResultSet DatabaseMetaData.getUDTs(String catalog, String schemaPattern, String typeNamePattern, int[] types)
获取在特定模式中定义的用户定义类型 (UDT) 的描述。
 InputStream ResultSet.getUnicodeStream(int columnIndex)
已过时。 使用 getCharacterStream 取代 getUnicodeStream
 InputStream ResultSet.getUnicodeStream(String columnLabel)
已过时。 使用 getCharacterStream 代替
 int Statement.getUpdateCount()
以更新计数的形式获取当前结果；如果结果为 ResultSet 对象或没有更多结果，则返回 -1。
 String DatabaseMetaData.getURL()
获取此 DBMS 的 URL。
 URL CallableStatement.getURL(int parameterIndex)
以 java.sql.URL 对象的形式获取指定 JDBC DATALINK 参数的值。
 URL ResultSet.getURL(int columnIndex)
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 URL CallableStatement.getURL(String parameterName)
以 java.net.URL 对象的形式获取 JDBC DATALINK 参数的值。
 URL ResultSet.getURL(String columnLabel)
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 String DatabaseMetaData.getUserName()
获取此数据库的已知的用户名称。
 ResultSet DatabaseMetaData.getVersionColumns(String catalog, String schema, String table)
获取在更新行中的任意值时自动更新的表列的描述。
 SQLWarning Connection.getWarnings()
获取此 Connection 对象上的调用报告的第一个警告。
 SQLWarning ResultSet.getWarnings()
获取此 ResultSet 对象上的调用报告的第一个警告。
 SQLWarning Statement.getWarnings()
获取此 Statement 对象上的调用报告的第一个警告。
 void ResultSet.insertRow()
将插入行的内容插入到此 ResultSet 对象和数据库中。
 boolean DatabaseMetaData.insertsAreDetected(int type)
获取是否可以通过调用 ResultSet.rowInserted 方法检测可见行的插入。
 boolean ResultSet.isAfterLast()
获取光标是否位于此 ResultSet 对象的最后一行之后。
 boolean ResultSetMetaData.isAutoIncrement(int column)
指示是否自动为指定列进行编号。
 boolean ResultSet.isBeforeFirst()
获取光标是否位于此 ResultSet 对象的第一行之前。
 boolean ResultSetMetaData.isCaseSensitive(int column)
指示列的大小写是否有关系。
 boolean DatabaseMetaData.isCatalogAtStart()
获取某个类别是否出现在完全限定表名的开头。
 boolean Connection.isClosed()
查询此 Connection 对象是否已经被关闭。
 boolean ResultSet.isClosed()
获取此 ResultSet 对象是否已关闭。
 boolean Statement.isClosed()
获取是否已关闭了此 Statement 对象。
 boolean ResultSetMetaData.isCurrency(int column)
指示指定的列是否是一个哈希代码值。
 boolean ResultSetMetaData.isDefinitelyWritable(int column)
指示在指定的列上进行写操作是否明确可以获得成功。
 boolean ResultSet.isFirst()
获取光标是否位于此 ResultSet 对象的第一行。
 boolean ResultSet.isLast()
获取光标是否位于此 ResultSet 对象的最后一行。
 int ParameterMetaData.isNullable(int param)
获取是否允许在指定参数中使用 null 值。
 int ResultSetMetaData.isNullable(int column)
指示指定列中的值是否可以为 null。
 boolean Statement.isPoolable()
返回指示 Statement 是否是可池化的值。
 boolean Connection.isReadOnly()
查询此 Connection 对象是否处于只读模式。
 boolean DatabaseMetaData.isReadOnly()
获取此数据库是否处于只读模式。
 boolean ResultSetMetaData.isReadOnly(int column)
指示指定的列是否明确不可写入。
 boolean ResultSetMetaData.isSearchable(int column)
指示是否可以在 where 子句中使用指定的列。
 boolean ParameterMetaData.isSigned(int param)
获取指定参数的值是否可以是带符号的数字。
 boolean ResultSetMetaData.isSigned(int column)
指示指定列中的值是否带正负号。
 boolean Connection.isValid(int timeout)
如果连接尚未关闭并且仍然有效，则返回 true。
 boolean Wrapper.isWrapperFor(Class<?> iface)
如果调用此方法的对象实现接口参数，或者是实现接口参数的对象的直接或间接包装器，则返回 true。
 boolean ResultSetMetaData.isWritable(int column)
指示在指定的列上进行写操作是否可以获得成功。
 boolean ResultSet.last()
将光标移动到此 ResultSet 对象的最后一行。
 long Blob.length()
返回此 Blob 对象指定的 BLOB 值中的字节数。
 long Clob.length()
获取此 Clob 对象指定的 CLOB 值中的字符数。
 boolean DatabaseMetaData.locatorsUpdateCopy()
指示对 LOB 的更新是在副本上进行还是直接更新到 LOB。
 void ResultSet.moveToCurrentRow()
将光标移动到记住的光标位置，通常为当前行。
 void ResultSet.moveToInsertRow()
将光标移动到插入行。
 String Connection.nativeSQL(String sql)
将给定的 SQL 语句转换成系统本机 SQL 语法。
 boolean ResultSet.next()
将光标从当前位置向前移一行。
 boolean DatabaseMetaData.nullPlusNonNullIsNull()
获取此数据库是否支持 NULL 值与等于 NULL 的非 NULL 值之间的连接。
 boolean DatabaseMetaData.nullsAreSortedAtEnd()
获取 NULL 值是否始终排在末尾，不管排序顺序如何。
 boolean DatabaseMetaData.nullsAreSortedAtStart()
获取 NULL 值是否始终排在开头，不管排序顺序如何。
 boolean DatabaseMetaData.nullsAreSortedHigh()
获取 NULL 值是否被高排序。
 boolean DatabaseMetaData.nullsAreSortedLow()
获取 NULL 值是否被低排序。
 boolean DatabaseMetaData.othersDeletesAreVisible(int type)
获取由其他结果集类型进行的删除是否可见。
 boolean DatabaseMetaData.othersInsertsAreVisible(int type)
获取由其他结果集类型进行的插入是否可见。
 boolean DatabaseMetaData.othersUpdatesAreVisible(int type)
获取由其他结果集类型进行的更新是否可见。
 boolean DatabaseMetaData.ownDeletesAreVisible(int type)
获取结果集自身的删除是否可见。
 boolean DatabaseMetaData.ownInsertsAreVisible(int type)
获取结果集自身的插入是否可见。
 boolean DatabaseMetaData.ownUpdatesAreVisible(int type)
获取对于给定类型的 ResultSet 对象，结果集自身的更新是否可见。
 long Blob.position(Blob pattern, long start)
获取此 Blob 对象指定的 BLOB 值中 pattern 开始处的字节位置。
 long Blob.position(byte[] pattern, long start)
获取此 Blob 对象表示的 BLOB 值中指定 byte 数组 pattern 开始处的字节位置。
 long Clob.position(Clob searchstr, long start)
获取此 Clob 对象中指定的 Clob 对象 searchstr 出现的字符位置。
 long Clob.position(String searchstr, long start)
获取此 Clob 对象表示的 SQL CLOB 值中指定子字符串 searchstr 出现的字符位置。
 CallableStatement Connection.prepareCall(String sql)
创建一个 CallableStatement 对象来调用数据库存储过程。
 CallableStatement Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency)
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
 CallableStatement Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
 PreparedStatement Connection.prepareStatement(String sql)
创建一个 PreparedStatement 对象来将参数化的 SQL 语句发送到数据库。
 PreparedStatement Connection.prepareStatement(String sql, int autoGeneratedKeys)
创建一个默认 PreparedStatement 对象，该对象能获取自动生成的键。
 PreparedStatement Connection.prepareStatement(String sql, int[] columnIndexes)
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
 PreparedStatement Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency)
创建一个 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
 PreparedStatement Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
创建一个 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
 PreparedStatement Connection.prepareStatement(String sql, String[] columnNames)
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
 boolean ResultSet.previous()
将光标移动到此 ResultSet 对象的上一行。
 Array SQLInput.readArray()
从流中读取 SQL ARRAY 值并将其作为 Java 编程语言中的 Array 对象返回。
 InputStream SQLInput.readAsciiStream()
读取流中的下一个属性并将其作为 ASCII 字符流返回。
 BigDecimal SQLInput.readBigDecimal()
读取流中的下一个属性并将其作为 Java 编程语言中的 java.math.BigDecimal 对象返回。
 InputStream SQLInput.readBinaryStream()
读取流中的下一个属性并将其作为未解释的字节流返回。
 Blob SQLInput.readBlob()
从流中读取 SQL BLOB 值并将其作为 Java 编程语言中的 Blob 对象返回。
 boolean SQLInput.readBoolean()
读取流中的下一个属性并将其作为 Java 编程语言中的 boolean 返回。
 byte SQLInput.readByte()
读取流中的下一个属性并将其作为 Java 编程语言中的 byte 返回。
 byte[] SQLInput.readBytes()
读取流中的下一个属性并将其作为 Java 编程语言中的字节数组返回。
 Reader SQLInput.readCharacterStream()
读取流中的下一个属性并将其作为 Unicode 字符流返回。
 Clob SQLInput.readClob()
从流中读取 SQL CLOB 值并将其作为 Java 编程语言中的 Clob 对象返回。
 Date SQLInput.readDate()
读取流中的下一个属性并将其作为 java.sql.Date 对象返回。
 double SQLInput.readDouble()
读取流中的下一个属性并将其作为 Java 编程语言中的 double 返回。
 float SQLInput.readFloat()
读取流中的下一个属性并将其作为 Java 编程语言中的 float 返回。
 int SQLInput.readInt()
读取流中的下一个属性并将其作为 Java 编程语言中的 int 返回。
 long SQLInput.readLong()
读取流中的下一个属性并将其作为 Java 编程语言中的 long 返回。
 NClob SQLInput.readNClob()
从流中读取一个 SQL NCLOB 值，并以 Java 编程语言中 NCLOB 对象的形式返回。
 String SQLInput.readNString()
读取流中的下一个属性，并以 Java 编程语言中 String 的形式返回。
 Object SQLInput.readObject()
读取流头中的下一个属性并将其作为 Java 编程语言中的 Object 返回。
 Ref SQLInput.readRef()
从流读取 SQL REF 值并将其作为 Java 编程语言中的 Ref 对象返回。
 RowId SQLInput.readRowId()
从流中读取一个 SQL ROWID 值，并以 Java 编程语言中 RowId 对象的形式返回。
 short SQLInput.readShort()
读取流中的下一个属性并将其作为 Java 编程语言中的 short 返回。
 void SQLData.readSQL(SQLInput stream, String typeName)
用从数据库读取的数据填充此对象。
 SQLXML SQLInput.readSQLXML()
从流中读取一个 SQL XML 值，并以 Java 编程语言中 SQLXML 对象的形式返回。
 String SQLInput.readString()
读取流中的下一个属性并将其作为 Java 编程语言中的 String 返回。
 Time SQLInput.readTime()
读取流中的下一个属性并将其作为 java.sql.Time 对象返回。
 Timestamp SQLInput.readTimestamp()
读取流中的下一个属性并将其作为 java.sql.Timestamp 对象返回。
 URL SQLInput.readURL()
从流中读取 SQL DATALINK 值并将其作为 Java 编程语言中的 java.net.URL 对象返回。
 void ResultSet.refreshRow()
用数据库中的最近值刷新当前行。
static void DriverManager.registerDriver(Driver driver)
向 DriverManager 注册给定驱动程序。
 void CallableStatement.registerOutParameter(int parameterIndex, int sqlType)
按顺序位置 parameterIndex 将 OUT 参数注册为 JDBC 类型 sqlType。
 void CallableStatement.registerOutParameter(int parameterIndex, int sqlType, int scale)
按顺序位置 parameterIndex 将参数注册为 JDBC 类型 sqlType。
 void CallableStatement.registerOutParameter(int parameterIndex, int sqlType, String typeName)
注册指定的输出参数。
 void CallableStatement.registerOutParameter(String parameterName, int sqlType)
将名为 parameterName 的 OUT 参数注册为 JDBC 类型 sqlType。
 void CallableStatement.registerOutParameter(String parameterName, int sqlType, int scale)
将名为 parameterName 的参数注册为 JDBC 类型 sqlType。
 void CallableStatement.registerOutParameter(String parameterName, int sqlType, String typeName)
注册指定的输出参数。
 boolean ResultSet.relative(int rows)
按相对行数（或正或负）移动光标。
 void Connection.releaseSavepoint(Savepoint savepoint)
从当前事务中移除指定的 Savepoint 和后续 Savepoint 对象。
 void Connection.rollback()
取消在当前事务中进行的所有更改，并释放此 Connection 对象当前持有的所有数据库锁。
 void Connection.rollback(Savepoint savepoint)
取消所有设置给定 Savepoint 对象之后进行的更改。
 boolean ResultSet.rowDeleted()
获取是否已删除某行。
 boolean ResultSet.rowInserted()
获取当前行是否已有插入。
 boolean ResultSet.rowUpdated()
获取是否已更新当前行。
 void PreparedStatement.setArray(int parameterIndex, Array x)
将指定参数设置为给定 java.sql.Array 对象。
 void PreparedStatement.setAsciiStream(int parameterIndex, InputStream x)
将指定参数设置为给定输入流。
 void PreparedStatement.setAsciiStream(int parameterIndex, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将具有给定字节数。
 void PreparedStatement.setAsciiStream(int parameterIndex, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将具有指定字节数。
 OutputStream Clob.setAsciiStream(long pos)
获取用于将 Ascii 字符写入此 Clob 对象表示的 Clob 值中的流，从位置 pos 处开始。
 void CallableStatement.setAsciiStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。
 void CallableStatement.setAsciiStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
 void CallableStatement.setAsciiStream(String parameterName, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
 void Connection.setAutoCommit(boolean autoCommit)
将此连接的自动提交模式设置为给定状态。
 void PreparedStatement.setBigDecimal(int parameterIndex, BigDecimal x)
将指定参数设置为给定 java.math.BigDecimal 值。
 void CallableStatement.setBigDecimal(String parameterName, BigDecimal x)
将指定参数设置为给定 java.math.BigDecimal 值。
 OutputStream SQLXML.setBinaryStream()
获取可用于写入此 SQLXML 实例表示的 XML 值的流。
 void PreparedStatement.setBinaryStream(int parameterIndex, InputStream x)
将指定参数设置为给定输入流。
 void PreparedStatement.setBinaryStream(int parameterIndex, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将具有给定字节数。
 void PreparedStatement.setBinaryStream(int parameterIndex, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将具有指定字节数。
 OutputStream Blob.setBinaryStream(long pos)
获取用于写入此 Blob 对象表示的 BLOB 值的流。
 void CallableStatement.setBinaryStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。
 void CallableStatement.setBinaryStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
 void CallableStatement.setBinaryStream(String parameterName, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将拥有指定字节数。
 void PreparedStatement.setBlob(int parameterIndex, Blob x)
将指定参数设置为给定 java.sql.Blob 对象。
 void PreparedStatement.setBlob(int parameterIndex, InputStream inputStream)
将指定参数设置为 InputStream 对象。
 void PreparedStatement.setBlob(int parameterIndex, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。
 void CallableStatement.setBlob(String parameterName, Blob x)
将指定参数设置为给定的 java.sql.Blob 对象。
 void CallableStatement.setBlob(String parameterName, InputStream inputStream)
将指定参数设置为 InputStream 对象。
 void CallableStatement.setBlob(String parameterName, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。
 void PreparedStatement.setBoolean(int parameterIndex, boolean x)
将指定参数设置为给定 Java boolean 值。
 void CallableStatement.setBoolean(String parameterName, boolean x)
将指定参数设置为给定 Java boolean 值。
 void PreparedStatement.setByte(int parameterIndex, byte x)
将指定参数设置为给定 Java byte 值。
 void CallableStatement.setByte(String parameterName, byte x)
将指定参数设置为给定 Java byte 值。
 void PreparedStatement.setBytes(int parameterIndex, byte[] x)
将指定参数设置为给定 Java byte 数组。
 int Blob.setBytes(long pos, byte[] bytes)
从位置 pos 处开始，将给定 byte 数组写入此 Blob 对象表示的 BLOB 值，并返回写入的字节数。
 int Blob.setBytes(long pos, byte[] bytes, int offset, int len)
将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
 void CallableStatement.setBytes(String parameterName, byte[] x)
将指定参数设置为给定 Java byte 数组。
 void Connection.setCatalog(String catalog)
设置给定目录名称，以便选择要在其中进行工作的此 Connection 对象数据库的子空间。
 Writer SQLXML.setCharacterStream()
获取用于写入此 SQLXML 实例表示的 XML 值的流。
 void PreparedStatement.setCharacterStream(int parameterIndex, Reader reader)
将指定参数设置为给定 Reader 对象。
 void PreparedStatement.setCharacterStream(int parameterIndex, Reader reader, int length)
将给定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
 void PreparedStatement.setCharacterStream(int parameterIndex, Reader reader, long length)
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
 Writer Clob.setCharacterStream(long pos)
获取用于将 Unicode 字符流写入此 Clob 对象表示的 CLOB 值中（位置 pos 处）的流。
 void CallableStatement.setCharacterStream(String parameterName, Reader reader)
将指定参数设置为给定 Reader 对象。
 void CallableStatement.setCharacterStream(String parameterName, Reader reader, int length)
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数。
 void CallableStatement.setCharacterStream(String parameterName, Reader reader, long length)
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
 void PreparedStatement.setClob(int parameterIndex, Clob x)
将指定参数设置为给定 java.sql.Clob 对象。
 void PreparedStatement.setClob(int parameterIndex, Reader reader)
将指定参数设置为 Reader 对象。
 void PreparedStatement.setClob(int parameterIndex, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void CallableStatement.setClob(String parameterName, Clob x)
将指定参数设置为给定的 java.sql.Clob 对象。
 void CallableStatement.setClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。
 void CallableStatement.setClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void Statement.setCursorName(String name)
将 SQL 指针名称设置为给定的 String，后续 Statement 对象的 execute 方法将使用此字符串。
 void PreparedStatement.setDate(int parameterIndex, Date x)
使用运行应用程序的虚拟机的默认时区将指定参数设置为给定 java.sql.Date 值。
 void PreparedStatement.setDate(int parameterIndex, Date x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
 void CallableStatement.setDate(String parameterName, Date x)
使用运行应用程序的虚拟机默认时区将指定参数设置为给定 java.sql.Date 值。
 void CallableStatement.setDate(String parameterName, Date x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
 void PreparedStatement.setDouble(int parameterIndex, double x)
将指定参数设置为给定 Java double 值。
 void CallableStatement.setDouble(String parameterName, double x)
将指定参数设置为给定 Java double 值。
 void Statement.setEscapeProcessing(boolean enable)
将转义处理设置为开或关。
 void ResultSet.setFetchDirection(int direction)
设置此 ResultSet 对象中行的处理方向。
 void Statement.setFetchDirection(int direction)
向驱动程序提供关于方向的提示，在使用此 Statement 对象创建的 ResultSet 对象中将按该方向处理行。
 void ResultSet.setFetchSize(int rows)
为 JDBC 驱动程序设置此 ResultSet 对象需要更多行时应该从数据库获取的行数。
 void Statement.setFetchSize(int rows)
为 JDBC 驱动程序提供一个提示，它提示此 Statement 生成的 ResultSet 对象需要更多行时应该从数据库获取的行数。
 void PreparedStatement.setFloat(int parameterIndex, float x)
将指定参数设置为给定 Java REAL 值。
 void CallableStatement.setFloat(String parameterName, float x)
将指定参数设置为给定 Java float 值。
 void Connection.setHoldability(int holdability)
将使用此 Connection 对象创建的 ResultSet 对象的默认可保存性 (holdability) 更改为给定可保存性。
 void PreparedStatement.setInt(int parameterIndex, int x)
将指定参数设置为给定 Java int 值。
 void CallableStatement.setInt(String parameterName, int x)
将指定参数设置为给定 Java int 值。
 void PreparedStatement.setLong(int parameterIndex, long x)
将指定参数设置为给定 Java long 值。
 void CallableStatement.setLong(String parameterName, long x)
将指定参数设置为给定 Java long 值。
 void Statement.setMaxFieldSize(int max)
设置此 Statement 对象生成的 ResultSet 对象中字符和二进制列值可以返回的最大字节数限制。
 void Statement.setMaxRows(int max)
将此 Statement 对象生成的所有 ResultSet 对象可以包含的最大行数限制设置为给定数。
 void PreparedStatement.setNCharacterStream(int parameterIndex, Reader value)
将指定参数设置为 Reader 对象。
 void PreparedStatement.setNCharacterStream(int parameterIndex, Reader value, long length)
将指定参数设置为 Reader 对象。
 void CallableStatement.setNCharacterStream(String parameterName, Reader value)
将指定参数设置为 Reader 对象。
 void CallableStatement.setNCharacterStream(String parameterName, Reader value, long length)
将指定参数设置为 Reader 对象。
 void PreparedStatement.setNClob(int parameterIndex, NClob value)
将指定参数设置为 java.sql.NClob 对象。
 void PreparedStatement.setNClob(int parameterIndex, Reader reader)
将指定参数设置为 Reader 对象。
 void PreparedStatement.setNClob(int parameterIndex, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void CallableStatement.setNClob(String parameterName, NClob value)
将指定参数设置为 java.sql.NClob 对象。
 void CallableStatement.setNClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。
 void CallableStatement.setNClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void PreparedStatement.setNString(int parameterIndex, String value)
将指定参数设置为给定 String 对象。
 void CallableStatement.setNString(String parameterName, String value)
将指定参数设置为给定 String 对象。
 void PreparedStatement.setNull(int parameterIndex, int sqlType)
将指定参数设置为 SQL NULL。
 void PreparedStatement.setNull(int parameterIndex, int sqlType, String typeName)
将指定参数设置为 SQL NULL。
 void CallableStatement.setNull(String parameterName, int sqlType)
将指定参数设置为 SQL NULL。
 void CallableStatement.setNull(String parameterName, int sqlType, String typeName)
将指定参数设置为 SQL NULL。
 void PreparedStatement.setObject(int parameterIndex, Object x)
使用给定对象设置指定参数的值。
 void PreparedStatement.setObject(int parameterIndex, Object x, int targetSqlType)
使用给定对象设置指定参数的值。
 void PreparedStatement.setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)
使用给定对象设置指定参数的值。
 void Ref.setObject(Object value)
将此 Ref 对象引用的结构类型值设置为给定的 Object 实例。
 void CallableStatement.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。
 void CallableStatement.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。
 void CallableStatement.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。
 void Statement.setPoolable(boolean poolable)
请求将 Statement 池化或非池化。
 void Statement.setQueryTimeout(int seconds)
将驱动程序等待 Statement 对象执行的秒数设置为给定秒数。
 void Connection.setReadOnly(boolean readOnly)
将此连接设置为只读模式，作为驱动程序启用数据库优化的提示。
 void PreparedStatement.setRef(int parameterIndex, Ref x)
将指定参数设置为给定 REF(<structured-type>) 值。
<T extends Result>
T
SQLXML.setResult(Class<T> resultClass)
返回设置此 SQLXML 实例指定的 XML 值的 Result。
 void PreparedStatement.setRowId(int parameterIndex, RowId x)
将指定参数设置为给定 java.sql.RowId 对象。
 void CallableStatement.setRowId(String parameterName, RowId x)
将指定参数设置为给定 java.sql.RowId 对象。
 Savepoint Connection.setSavepoint()
在当前事务中创建一个未命名的保存点 (savepoint)，并返回表示它的新 Savepoint 对象。
 Savepoint Connection.setSavepoint(String name)
在当前事务中创建一个具有给定名称的保存点，并返回表示它的新 Savepoint 对象。
 void PreparedStatement.setShort(int parameterIndex, short x)
将指定参数设置为给定 Java short 值。
 void CallableStatement.setShort(String parameterName, short x)
将指定参数设置为给定 Java short 值。
 void PreparedStatement.setSQLXML(int parameterIndex, SQLXML xmlObject)
将指定参数设置为给定 java.sql.SQLXML 对象。
 void CallableStatement.setSQLXML(String parameterName, SQLXML xmlObject)
将指定参数设置为给定 java.sql.SQLXML 对象。
 void PreparedStatement.setString(int parameterIndex, String x)
将指定参数设置为给定 Java String 值。
 int Clob.setString(long pos, String str)
在位置 pos 处将给定 Java String 写入此 Clob 对象指定的 CLOB 值中。
 int Clob.setString(long pos, String str, int offset, int len)
将 str 的 len 个字符（从字符 offset 开始）写入此 Clob 表示的 CLOB 值中。
 void SQLXML.setString(String value)
将此 SQLXML 实例指定的 XML 值设置为给定的 String 表示形式。
 void CallableStatement.setString(String parameterName, String x)
将指定参数设置为给定 Java String 值。
 void PreparedStatement.setTime(int parameterIndex, Time x)
将指定参数设置为给定 java.sql.Time 值。
 void PreparedStatement.setTime(int parameterIndex, Time x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
 void CallableStatement.setTime(String parameterName, Time x)
将指定参数设置为给定 java.sql.Time 值。
 void CallableStatement.setTime(String parameterName, Time x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
 void PreparedStatement.setTimestamp(int parameterIndex, Timestamp x)
将指定参数设置为给定 java.sql.Timestamp 值。
 void PreparedStatement.setTimestamp(int parameterIndex, Timestamp x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
 void CallableStatement.setTimestamp(String parameterName, Timestamp x)
将指定参数设置为给定 java.sql.Timestamp 值。
 void CallableStatement.setTimestamp(String parameterName, Timestamp x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
 void Connection.setTransactionIsolation(int level)
试图将此 Connection 对象的事务隔离级别更改为给定的级别。
 void Connection.setTypeMap(Map<String,Class<?>> map)
将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。
 void PreparedStatement.setUnicodeStream(int parameterIndex, InputStream x, int length)
已过时。
 void PreparedStatement.setURL(int parameterIndex, URL x)
将指定参数设置为给定 java.net.URL 值。
 void CallableStatement.setURL(String parameterName, URL val)
将指定参数设置为给定 java.net.URL 对象。
 boolean DatabaseMetaData.storesLowerCaseIdentifiers()
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。
 boolean DatabaseMetaData.storesLowerCaseQuotedIdentifiers()
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。
 boolean DatabaseMetaData.storesMixedCaseIdentifiers()
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。
 boolean DatabaseMetaData.storesMixedCaseQuotedIdentifiers()
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。
 boolean DatabaseMetaData.storesUpperCaseIdentifiers()
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。
 boolean DatabaseMetaData.storesUpperCaseQuotedIdentifiers()
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。
 boolean DatabaseMetaData.supportsAlterTableWithAddColumn()
获取此数据库是否支持带有 add 列的 ALTER TABLE。
 boolean DatabaseMetaData.supportsAlterTableWithDropColumn()
获取此数据库是否支持带有 drop 列的 ALTER TABLE。
 boolean DatabaseMetaData.supportsANSI92EntryLevelSQL()
获取此数据库是否支持 ANSI92 入门级 SQL 语法。
 boolean DatabaseMetaData.supportsANSI92FullSQL()
获取此数据库是否支持受支持的 ANSI92 完全 SQL 语法。
 boolean DatabaseMetaData.supportsANSI92IntermediateSQL()
获取此数据库是否支持受支持的 ANSI92 中间 SQL 语法。
 boolean DatabaseMetaData.supportsBatchUpdates()
获取此数据库是否支持批量更新。
 boolean DatabaseMetaData.supportsCatalogsInDataManipulation()
获取某个类别名称是否可以在数据操作语句中使用。
 boolean DatabaseMetaData.supportsCatalogsInIndexDefinitions()
获取某个类别名称是否可以在获取定义语句中使用。
 boolean DatabaseMetaData.supportsCatalogsInPrivilegeDefinitions()
获取某个类别名称是否可以在特权定义语句中使用。
 boolean DatabaseMetaData.supportsCatalogsInProcedureCalls()
获取某个类别名称是否可以在过程调用语句中使用。
 boolean DatabaseMetaData.supportsCatalogsInTableDefinitions()
获取某个类别名称是否可以在表定义语句中使用。
 boolean DatabaseMetaData.supportsColumnAliasing()
获取此数据库是否支持为列提供别名。
 boolean DatabaseMetaData.supportsConvert()
获取此数据库是否支持用于 JDBC 类型之间转换的 JDBC 标量函数 CONVERT。
 boolean DatabaseMetaData.supportsConvert(int fromType, int toType)
获取此数据库是否支持用于 JDBC fromType 和 toType 类型之间转换的 JDBC 标量函数 CONVERT。
 boolean DatabaseMetaData.supportsCoreSQLGrammar()
获取此数据库是否支持 ODBC Core SQL 语法。
 boolean DatabaseMetaData.supportsCorrelatedSubqueries()
获取此数据库是否支持相关子查询。
 boolean DatabaseMetaData.supportsDataDefinitionAndDataManipulationTransactions()
获取此数据库是否同时支持事务中的数据定义和数据操作语句。
 boolean DatabaseMetaData.supportsDataManipulationTransactionsOnly()
获取此数据库是否仅支持事务中的数据操作语句。
 boolean DatabaseMetaData.supportsDifferentTableCorrelationNames()
获取在表关联名称受支持时，是否要限制它们与表的名称不同。
 boolean DatabaseMetaData.supportsExpressionsInOrderBy()
获取此数据库是否支持 ORDER BY 列表中的表达式。
 boolean DatabaseMetaData.supportsExtendedSQLGrammar()
获取此数据库是否支持 ODBC Extended SQL 语法。
 boolean DatabaseMetaData.supportsFullOuterJoins()
获取此数据库是否支持完全嵌套的外连接。
 boolean DatabaseMetaData.supportsGetGeneratedKeys()
获取是否可以在执行语句后获取自动生成的键。
 boolean DatabaseMetaData.supportsGroupBy()
获取此数据库是否支持某种形式的 GROUP BY 子句。
 boolean DatabaseMetaData.supportsGroupByBeyondSelect()
获取此数据库是否支持使用不包含在 SELECT 语句中而包含在 GROUP BY 子句中的列，假设 SELECT 语句中的所有列都包含在 GROUP BY 子句中。
 boolean DatabaseMetaData.supportsGroupByUnrelated()
获取此数据库是否支持使用不在 SELECT 语句中而在 GROUP BY 子句中的列。
 boolean DatabaseMetaData.supportsIntegrityEnhancementFacility()
获取此数据库是否支持 SQL Integrity Enhancement Facility。
 boolean DatabaseMetaData.supportsLikeEscapeClause()
获取此数据库是否支持指定 LIKE 转义子句。
 boolean DatabaseMetaData.supportsLimitedOuterJoins()
获取此数据库是否为外连接提供受限制的支持。
 boolean DatabaseMetaData.supportsMinimumSQLGrammar()
获取此数据库是否支持 ODBC Minimum SQL 语法。
 boolean DatabaseMetaData.supportsMixedCaseIdentifiers()
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。
 boolean DatabaseMetaData.supportsMixedCaseQuotedIdentifiers()
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。
 boolean DatabaseMetaData.supportsMultipleOpenResults()
获取是否可以同时拥有从 CallableStatement 对象中返回的多个 ResultSet 对象。
 boolean DatabaseMetaData.supportsMultipleResultSets()
获取此数据库是否支持一次调用 execute 方法获得多个 ResultSet 对象。
 boolean DatabaseMetaData.supportsMultipleTransactions()
获取此数据库是否允许一次打开多个事务（在不同的 connection 上）。
 boolean DatabaseMetaData.supportsNamedParameters()
获取此数据库是否支持可调用语句的指定参数。
 boolean DatabaseMetaData.supportsNonNullableColumns()
获取是否可以将此数据库中的列定义为非 null。
 boolean DatabaseMetaData.supportsOpenCursorsAcrossCommit()
获取此数据库是否支持在进行提交期间保持游标开放。
 boolean DatabaseMetaData.supportsOpenCursorsAcrossRollback()
获取此数据库是否支持在回滚期间保持游标开放。
 boolean DatabaseMetaData.supportsOpenStatementsAcrossCommit()
获取此数据库是否支持在进行提交期间保持语句开放。
 boolean DatabaseMetaData.supportsOpenStatementsAcrossRollback()
获取此数据库是否支持在回滚期间保持语句开放。
 boolean DatabaseMetaData.supportsOrderByUnrelated()
获取此数据库是否支持使用不在 SELECT 语句中而在 ORDER BY 子句中的列。
 boolean DatabaseMetaData.supportsOuterJoins()
获取此数据库是否支持某种形式的外连接。
 boolean DatabaseMetaData.supportsPositionedDelete()
获取此数据库是否支持位置的 DELETE 语句。
 boolean DatabaseMetaData.supportsPositionedUpdate()
获取此数据库是否支持位置的 UPDATE 语句。
 boolean DatabaseMetaData.supportsResultSetConcurrency(int type, int concurrency)
获取此数据库是否支持与给定结果集类型结合在一起的给定并发性类型。
 boolean DatabaseMetaData.supportsResultSetHoldability(int holdability)
获取此数据库是否支持给定结果集可保存性。
 boolean DatabaseMetaData.supportsResultSetType(int type)
获取此数据库是否支持给定结果集类型。
 boolean DatabaseMetaData.supportsSavepoints()
获取此数据库是否支持保存点 (savepoint)。
 boolean DatabaseMetaData.supportsSchemasInDataManipulation()
获取某个模式名称是否可以数据操作语句中使用。
 boolean DatabaseMetaData.supportsSchemasInIndexDefinitions()
获取某个模式名称是否可以在获取定义语句中使用。
 boolean DatabaseMetaData.supportsSchemasInPrivilegeDefinitions()
获取某个模式名称是否可以在特权定义语句中使用。
 boolean DatabaseMetaData.supportsSchemasInProcedureCalls()
获取某个模式名称是否可以在过程调用语句中使用。
 boolean DatabaseMetaData.supportsSchemasInTableDefinitions()
获取某个模式名称是否可以在表定义语句中使用。
 boolean DatabaseMetaData.supportsSelectForUpdate()
获取此数据库是否支持位置的 SELECT FOR UPDATE 语句。
 boolean DatabaseMetaData.supportsStatementPooling()
获取此数据库是否支持语句合并 (statement pooling)。
 boolean DatabaseMetaData.supportsStoredFunctionsUsingCallSyntax()
获取此数据库是否支持使用存储过程转义语法调用用户定义的函数或供应商函数。
 boolean DatabaseMetaData.supportsStoredProcedures()
获取此数据库是否支持使用存储过程转义语法的存储过程调用。
 boolean DatabaseMetaData.supportsSubqueriesInComparisons()
获取此数据库是否支持比较表达式中的子查询。
 boolean DatabaseMetaData.supportsSubqueriesInExists()
获取此数据库是否支持 EXISTS 表达式中的子查询。
 boolean DatabaseMetaData.supportsSubqueriesInIns()
获取此数据库是否支持 IN 表达式中的子查询。
 boolean DatabaseMetaData.supportsSubqueriesInQuantifieds()
获取此数据库是否支持量化表达式 (quantified expression) 中的子查询。
 boolean DatabaseMetaData.supportsTableCorrelationNames()
获取此数据库是否支持表关联名称。
 boolean DatabaseMetaData.supportsTransactionIsolationLevel(int level)
获取此数据库是否支持给定事务隔离级别。
 boolean DatabaseMetaData.supportsTransactions()
获取此数据库是否支持事务。
 boolean DatabaseMetaData.supportsUnion()
获取此数据库是否支持 SQL UNION。
 boolean DatabaseMetaData.supportsUnionAll()
获取此数据库是否支持 SQL UNION ALL。
 void Blob.truncate(long len)
截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。
 void Clob.truncate(long len)
截取此 Clob 指定的 CLOB 值，使其长度为 len 个字符。
<T> T
Wrapper.unwrap(Class<T> iface)
返回一个对象，该对象实现给定接口，以允许访问非标准方法或代理未公开的标准方法。
 void ResultSet.updateArray(int columnIndex, Array x)
用 java.sql.Array 值更新指定列。
 void ResultSet.updateArray(String columnLabel, Array x)
用 java.sql.Array 值更新指定列。
 void ResultSet.updateAsciiStream(int columnIndex, InputStream x)
用 ascii 流值更新指定的列。
 void ResultSet.updateAsciiStream(int columnIndex, InputStream x, int length)
用 ascii 流值更新指定列，该列将具有指定字节数。
 void ResultSet.updateAsciiStream(int columnIndex, InputStream x, long length)
用 ascii 流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateAsciiStream(String columnLabel, InputStream x)
用 ascii 流值更新指定列。
 void ResultSet.updateAsciiStream(String columnLabel, InputStream x, int length)
用 ascii 流值更新指定列，该列具有指定的字节数。
 void ResultSet.updateAsciiStream(String columnLabel, InputStream x, long length)
用 ascii 流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateBigDecimal(int columnIndex, BigDecimal x)
用 java.math.BigDecimal 值更新指定列。
 void ResultSet.updateBigDecimal(String columnLabel, BigDecimal x)
用 java.sql.BigDecimal 值更新指定列。
 void ResultSet.updateBinaryStream(int columnIndex, InputStream x)
用二进制流值更新指定的列。
 void ResultSet.updateBinaryStream(int columnIndex, InputStream x, int length)
用二进制流值更新指定列，该列将具有指定字节数。
 void ResultSet.updateBinaryStream(int columnIndex, InputStream x, long length)
用二进制流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateBinaryStream(String columnLabel, InputStream x)
用二进制流值更新指定列。
 void ResultSet.updateBinaryStream(String columnLabel, InputStream x, int length)
用二进制流值更新指定列，该列具有指定的字节数。
 void ResultSet.updateBinaryStream(String columnLabel, InputStream x, long length)
用二进制流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateBlob(int columnIndex, Blob x)
用 java.sql.Blob 值更新指定列。
 void ResultSet.updateBlob(int columnIndex, InputStream inputStream)
使用给定输入流值更新指定列。
 void ResultSet.updateBlob(int columnIndex, InputStream inputStream, long length)
使用给定输入流更新指定的列，该流将具有指定的字节数。
 void ResultSet.updateBlob(String columnLabel, Blob x)
用 java.sql.Blob 值更新指定列。
 void ResultSet.updateBlob(String columnLabel, InputStream inputStream)
使用给定输入流值更新指定列。
 void ResultSet.updateBlob(String columnLabel, InputStream inputStream, long length)
使用给定输入流更新指定列，该流将具有指定的字节数。
 void ResultSet.updateBoolean(int columnIndex, boolean x)
用 boolean 值更新指定列。
 void ResultSet.updateBoolean(String columnLabel, boolean x)
用 boolean 值更新指定列。
 void ResultSet.updateByte(int columnIndex, byte x)
用 byte 值更新指定列。
 void ResultSet.updateByte(String columnLabel, byte x)
用 byte 值更新指定列。
 void ResultSet.updateBytes(int columnIndex, byte[] x)
用 byte 数组值更新指定列。
 void ResultSet.updateBytes(String columnLabel, byte[] x)
用字节数组值更新指定列。
 void ResultSet.updateCharacterStream(int columnIndex, Reader x)
用字符流值更新指定的列。
 void ResultSet.updateCharacterStream(int columnIndex, Reader x, int length)
用字符流值更新指定列，该列将具有指定字节数。
 void ResultSet.updateCharacterStream(int columnIndex, Reader x, long length)
用字符流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateCharacterStream(String columnLabel, Reader reader)
用字符流值更新指定列。
 void ResultSet.updateCharacterStream(String columnLabel, Reader reader, int length)
用字符流值更新指定列，该列具有指定的字节数。
 void ResultSet.updateCharacterStream(String columnLabel, Reader reader, long length)
用字符流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateClob(int columnIndex, Clob x)
用 java.sql.Clob 值更新指定列。
 void ResultSet.updateClob(int columnIndex, Reader reader)
使用给定的 Reader 对象更新指定列。
 void ResultSet.updateClob(int columnIndex, Reader reader, long length)
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
 void ResultSet.updateClob(String columnLabel, Clob x)
用 java.sql.Clob 值更新指定列。
 void ResultSet.updateClob(String columnLabel, Reader reader)
使用给定的 Reader 对象更新指定列。
 void ResultSet.updateClob(String columnLabel, Reader reader, long length)
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
 void ResultSet.updateDate(int columnIndex, Date x)
用 java.sql.Date 值更新指定列。
 void ResultSet.updateDate(String columnLabel, Date x)
用 java.sql.Date 值更新指定列。
 void ResultSet.updateDouble(int columnIndex, double x)
用 double 值更新指定列。
 void ResultSet.updateDouble(String columnLabel, double x)
用 double 值更新指定列。
 void ResultSet.updateFloat(int columnIndex, float x)
用 float 值更新指定列。
 void ResultSet.updateFloat(String columnLabel, float x)
用 float 值更新指定列。
 void ResultSet.updateInt(int columnIndex, int x)
用 int 值更新指定列。
 void ResultSet.updateInt(String columnLabel, int x)
用 int 值更新指定列。
 void ResultSet.updateLong(int columnIndex, long x)
用 long 值更新指定列。
 void ResultSet.updateLong(String columnLabel, long x)
用 long 值更新指定列。
 void ResultSet.updateNCharacterStream(int columnIndex, Reader x)
用字符流值更新指定的列。
 void ResultSet.updateNCharacterStream(int columnIndex, Reader x, long length)
用字符流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateNCharacterStream(String columnLabel, Reader reader)
用字符流值更新指定的列。
 void ResultSet.updateNCharacterStream(String columnLabel, Reader reader, long length)
用字符流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateNClob(int columnIndex, NClob nClob)
用 java.sql.NClob 值更新指定的列。
 void ResultSet.updateNClob(int columnIndex, Reader reader)
使用给定的 Reader 对象更新指定列。
 void ResultSet.updateNClob(int columnIndex, Reader reader, long length)
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
 void ResultSet.updateNClob(String columnLabel, NClob nClob)
用 java.sql.NClob 值更新指定的列。
 void ResultSet.updateNClob(String columnLabel, Reader reader)
使用给定的 Reader 对象更新指定列。
 void ResultSet.updateNClob(String columnLabel, Reader reader, long length)
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
 void ResultSet.updateNString(int columnIndex, String nString)
用 String 值更新指定的列。
 void ResultSet.updateNString(String columnLabel, String nString)
用 String 值更新指定的列。
 void ResultSet.updateNull(int columnIndex)
用 null 值更新指定列。
 void ResultSet.updateNull(String columnLabel)
用 null 值更新指定列。
 void ResultSet.updateObject(int columnIndex, Object x)
用 Object 值更新指定列。
 void ResultSet.updateObject(int columnIndex, Object x, int scaleOrLength)
用 Object 值更新指定列。
 void ResultSet.updateObject(String columnLabel, Object x)
用 Object 值更新指定列。
 void ResultSet.updateObject(String columnLabel, Object x, int scaleOrLength)
用 Object 值更新指定列。
 void ResultSet.updateRef(int columnIndex, Ref x)
用 java.sql.Ref 值更新指定列。
 void ResultSet.updateRef(String columnLabel, Ref x)
用 java.sql.Ref 值更新指定列。
 void ResultSet.updateRow()
用此 ResultSet 对象的当前行的新内容更新底层数据库。
 void ResultSet.updateRowId(int columnIndex, RowId x)
用 RowId 值更新指定列。
 void ResultSet.updateRowId(String columnLabel, RowId x)
用 RowId 值更新指定的列。
 boolean DatabaseMetaData.updatesAreDetected(int type)
获取是否可以通过调用 ResultSet.rowUpdated 方法检测可见行的更新。
 void ResultSet.updateShort(int columnIndex, short x)
用 short 值更新指定列。
 void ResultSet.updateShort(String columnLabel, short x)
用 short 值更新指定列。
 void ResultSet.updateSQLXML(int columnIndex, SQLXML xmlObject)
用 java.sql.SQLXML 值更新指定列。
 void ResultSet.updateSQLXML(String columnLabel, SQLXML xmlObject)
用 java.sql.SQLXML 值更新指定的列。
 void ResultSet.updateString(int columnIndex, String x)
用 String 值更新指定列。
 void ResultSet.updateString(String columnLabel, String x)
用 String 值更新指定列。
 void ResultSet.updateTime(int columnIndex, Time x)
用 java.sql.Time 值更新指定列。
 void ResultSet.updateTime(String columnLabel, Time x)
用 java.sql.Time 值更新指定列。
 void ResultSet.updateTimestamp(int columnIndex, Timestamp x)
用 java.sql.Timestamp 值更新指定列。
 void ResultSet.updateTimestamp(String columnLabel, Timestamp x)
用 java.sql.Timestamp 值更新指定列。
 boolean DatabaseMetaData.usesLocalFilePerTable()
获取此数据库是否为每个表使用一个文件。
 boolean DatabaseMetaData.usesLocalFiles()
获取此数据库是否将表存储在本地文件中。
 boolean CallableStatement.wasNull()
查询最后一个读取的 OUT 参数是否为 SQL NULL。
 boolean ResultSet.wasNull()
报告最后一个读取的列是否具有值 SQL NULL。
 boolean SQLInput.wasNull()
获取最后一个读取的值是否为 SQL NULL。
 void SQLOutput.writeArray(Array x)
将 SQL ARRAY 值写入流中。
 void SQLOutput.writeAsciiStream(InputStream x)
将下一个属性作为 ASCII 字符流写入流中。
 void SQLOutput.writeBigDecimal(BigDecimal x)
将下一个属性作为 java.math.BigDecimal 对象写入流中。
 void SQLOutput.writeBinaryStream(InputStream x)
将下一个属性作为未解释字节流写入流中。
 void SQLOutput.writeBlob(Blob x)
将 SQL BLOB 值写入流中。
 void SQLOutput.writeBoolean(boolean x)
将下一个属性作为 Java boolean 值写入流。
 void SQLOutput.writeByte(byte x)
将下一个属性作为 Java byte 值写入流中。
 void SQLOutput.writeBytes(byte[] x)
将下一个属性作为字节数组写入流中。
 void SQLOutput.writeCharacterStream(Reader x)
将下一个属性作为 Unicode 字符的流写入流中。
 void SQLOutput.writeClob(Clob x)
将 SQL CLOB 值写入流中。
 void SQLOutput.writeDate(Date x)
将下一个属性作为 java.sql.Date 对象写入流中。
 void SQLOutput.writeDouble(double x)
将下一个属性作为 Java double 值写入流中。
 void SQLOutput.writeFloat(float x)
将下一个属性作为 Java float 值写入流中。
 void SQLOutput.writeInt(int x)
将下一个属性作为 Java int 值写入流中。
 void SQLOutput.writeLong(long x)
将下一个属性作为 Java long 值写入流中。
 void SQLOutput.writeNClob(NClob x)
将 SQL NCLOB 值写入流中。
 void SQLOutput.writeNString(String x)
将下一个属性以 Java 编程语言中 String 的形式写入流中。
 void SQLOutput.writeObject(SQLData x)
将给定 SQLData 对象中包含的数据写入流中。
 void SQLOutput.writeRef(Ref x)
将 SQL REF 值写入流中。
 void SQLOutput.writeRowId(RowId x)
将 SQL ROWID 值写入流中。
 void SQLOutput.writeShort(short x)
将下一个属性作为 Java short 值写入流中。
 void SQLData.writeSQL(SQLOutput stream)
将此对象写入给定的 SQL 数据流，同时将其转换回数据源中它的 SQL 值。
 void SQLOutput.writeSQLXML(SQLXML x)
将 SQL XML 值写入流中。
 void SQLOutput.writeString(String x)
将下一个属性作为 Java 编程语言中的 String 写入流中。
 void SQLOutput.writeStruct(Struct x)
将 SQL 结构类型值写入流中。
 void SQLOutput.writeTime(Time x)
将下一个属性作为 java.sql.Time 对象写入流中。
 void SQLOutput.writeTimestamp(Timestamp x)
将下一个属性作为 java.sql.Timestamp 对象写入流中。
 void SQLOutput.writeURL(URL x)
将 SQL DATALINK 值写入流中。

javax.sql 中 SQLException 的使用

返回 SQLException 的 javax.sql 中的方法
SQLException | ConnectionEvent.getSQLException() 获取此 ConnectionEvent 对象的 SQLException。
SQLException | StatementEvent.getSQLException() 返回驱动程序将要抛出的 SQLException。

抛出 SQLException 的 javax.sql 中的方法
void | RowSet.clearParameters() 清除为此 RowSet 对象命令设置的参数。
void | PooledConnection.close() 关闭此 PooledConnection 对象表示的物理连接。
void | RowSet.execute() 使用数据填充此 RowSet 对象。
Connection | DataSource.getConnection() 尝试建立与此 DataSource 对象所表示的数据源的连接。
Connection | PooledConnection.getConnection() 创建并返回一个 Connection 对象，它是此 PooledConnection 对象表示的物理连接的句柄。
Connection | RowSetInternal.getConnection() 获取传递给此 RowSet 对象的 Connection 对象。
Connection | DataSource.getConnection(String username, String password) 尝试建立与此 DataSource 对象所表示的数据源的连接。
boolean | RowSet.getEscapeProcessing() 获取是否为此 RowSet 对象启用转义处理。
int | CommonDataSource.getLoginTimeout() 获取此数据源试图连接到某一数据库时可以等待的最长时间，以秒为单位。
PrintWriter | CommonDataSource.getLogWriter() 获取此 DataSource 对象的日志 writer。
int | RowSet.getMaxFieldSize() 获取可以对某些列值返回的最大字节数。
int | RowSet.getMaxRows() 获取此 RowSet 对象可以包含的最大行数。
ResultSet | RowSetInternal.getOriginal() 获取包含此 RowSet 对象原始值的 ResultSet 对象。
ResultSet | RowSetInternal.getOriginalRow() 获取仅包含当前行原始值的 ResultSet 对象。
Object[] | RowSetInternal.getParams() 获取已为此 RowSet 对象的命令设置的参数。
PooledConnection | ConnectionPoolDataSource.getPooledConnection() 尝试建立可用作入池连接的物理数据库连接。
PooledConnection | ConnectionPoolDataSource.getPooledConnection(String user, String password) 尝试建立可用作入池连接的物理数据库连接。
int | RowSet.getQueryTimeout() 获取驱动程序等待语句执行的最大秒数。
Map<String,Class<?>> | RowSet.getTypeMap() 获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。
String | RowSet.getUrl() 如果此 RowSet 对象使用 DriverManager 而非 DataSource 对象建立连接，则获取创建连接时将使用的 url 属性。
XAConnection | XADataSource.getXAConnection() 尝试建立可在分布式事务中使用的物理数据库连接。
XAConnection | XADataSource.getXAConnection(String user, String password) 使用给定的用户名和密码，尝试建立一个物理数据库连接。
XAResource | XAConnection.getXAResource() 获取 XAResource 对象，事务管理器将使用该对象管理此 XAConnection 对象如何参与到分布式事务中。
void | RowSetReader.readData(RowSetInternal caller) 读取调用 RowSet 对象的新内容。
void | RowSet.setArray(int i, Array x) 使用给定 Array 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setAsciiStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | RowSet.setAsciiStream(int parameterIndex, InputStream x, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
void | RowSet.setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | RowSet.setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | RowSetMetaData.setAutoIncrement(int columnIndex, boolean property) 设置是否为指定列自动编号。
void | RowSet.setBigDecimal(int parameterIndex, BigDecimal x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.math.BigDeciaml 值。
void | RowSet.setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定的 java.math.BigDecimal 值。
void | RowSet.setBinaryStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | RowSet.setBinaryStream(int parameterIndex, InputStream x, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
void | RowSet.setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | RowSet.setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有给定字节数。
void | RowSet.setBlob(int i, Blob x) 使用给定 Blob 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。
void | RowSet.setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | RowSet.setBoolean(int parameterIndex, boolean x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java boolean 值。
void | RowSet.setBoolean(String parameterName, boolean x) 将指定参数设置为给定的 Java boolean 值。
void | RowSet.setByte(int parameterIndex, byte x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值。
void | RowSet.setByte(String parameterName, byte x) 将指定参数设置为给定的 Java byte 值。
void | RowSet.setBytes(int parameterIndex, byte[] x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值数组。
void | RowSet.setBytes(String parameterName, byte[] x) 将指定参数设置为给定的 Java byte 数组。
void | RowSetMetaData.setCaseSensitive(int columnIndex, boolean property) 设置指定列是否区分大小写。
void | RowSetMetaData.setCatalogName(int columnIndex, String catalogName) 将指定列的表的类别名称（如果有）设置为给定的 String。
void | RowSet.setCharacterStream(int parameterIndex, Reader reader) 将此 RowSet 对象命令中的指定参数设置为给定 Reader 对象。
void | RowSet.setCharacterStream(int parameterIndex, Reader reader, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.Reader 值。
void | RowSet.setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | RowSet.setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数目。
void | RowSet.setClob(int i, Clob x) 使用给定 Clob 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。
void | RowSet.setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSetMetaData.setColumnCount(int columnCount) 将 RowSet 对象中的列数设置为给定数。
void | RowSetMetaData.setColumnDisplaySize(int columnIndex, int size) 将指定列的正常最大宽度（以 char 表示）设置为给定的 int。
void | RowSetMetaData.setColumnLabel(int columnIndex, String label) 将建议用于打印输出和显示的列标题（如果有）设置为给定的 String。
void | RowSetMetaData.setColumnName(int columnIndex, String columnName) 将指定列的名称设置为给定的 String。
void | RowSetMetaData.setColumnType(int columnIndex, int SQLType) 将指定列的 SQL 类型设置为给定的类型。
void | RowSetMetaData.setColumnTypeName(int columnIndex, String typeName) 将指定列的特定于数据源的类型名称（如果有）设置为给定的 String。
void | RowSet.setCommand(String cmd) 将此 RowSet 对象的命令属性设置为给定的 SQL 查询。
void | RowSet.setConcurrency(int concurrency) 将此 RowSet 对象的并发性设置为给定的并发级别。
void | RowSetMetaData.setCurrency(int columnIndex, boolean property) 设置指定的列是否是现金值。
void | RowSet.setDataSourceName(String name) 将此 RowSet 对象的数据源名称属性设置为给定的 String。
void | RowSet.setDate(int parameterIndex, Date x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setDate(int parameterIndex, Date x, Calendar cal) 使用给定 java.sql.Date 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setDate(String parameterName, Date x) 使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setDouble(int parameterIndex, double x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java double 值。
void | RowSet.setDouble(String parameterName, double x) 将指定参数设置为给定的 Java double 值。
void | RowSet.setEscapeProcessing(boolean enable) 将此 RowSet 对象的转义处理设置为开或关。
void | RowSet.setFloat(int parameterIndex, float x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java float 值。
void | RowSet.setFloat(String parameterName, float x) 将指定参数设置为给定的 Java float 值。
void | RowSet.setInt(int parameterIndex, int x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java int 值。
void | RowSet.setInt(String parameterName, int x) 将指定参数设置为给定的 Java int 值。
void | CommonDataSource.setLoginTimeout(int seconds) 设置此数据源试图连接到某一数据库时将等待的最长时间，以秒为单位。
void | CommonDataSource.setLogWriter(PrintWriter out) 将此 DataSource 对象的日志 writer 设置为给定的 java.io.PrintWriter 对象。
void | RowSet.setLong(int parameterIndex, long x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java long 值。
void | RowSet.setLong(String parameterName, long x) 将指定参数设置为给定的 Java long 值。
void | RowSet.setMaxFieldSize(int max) 将可以对列值返回的最大字节数设置为给定的字节数。
void | RowSet.setMaxRows(int max) 将此 RowSet 对象可以包含的最大行数设置为指定数。
void | RowSetInternal.setMetaData(RowSetMetaData md) 将给定的 RowSetMetaData 对象设置为此 RowSet 对象的 RowSetMetaData 对象。
void | RowSet.setNCharacterStream(int parameterIndex, Reader value) 将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | RowSet.setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | RowSet.setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNString(int parameterIndex, String value) 将指定参数设置为给定的 String 对象。
void | RowSet.setNString(String parameterName, String value) 将指定参数设置为给定的 String 对象。
void | RowSet.setNull(int parameterIndex, int sqlType) 将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。
void | RowSet.setNull(int paramIndex, int sqlType, String typeName) 将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。
void | RowSet.setNull(String parameterName, int sqlType) 将指定参数设置为 SQL NULL。
void | RowSet.setNull(String parameterName, int sqlType, String typeName) 将指定参数设置为 SQL NULL。
void | RowSetMetaData.setNullable(int columnIndex, int property) 设置是否可以将指定列的值设置为 NULL。
void | RowSet.setObject(int parameterIndex, Object x) 使用 Java Object 设置此 RowSet 对象命令中的指定参数。
void | RowSet.setObject(int parameterIndex, Object x, int targetSqlType) 使用 Java Object 设置此 RowSet 对象命令中的指定参数。
void | RowSet.setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength) 使用给定 Java Object 设置此 RowSet 对象命令中的指定参数。
void | RowSet.setObject(String parameterName, Object x) 使用给定对象设置指定参数的值。
void | RowSet.setObject(String parameterName, Object x, int targetSqlType) 使用给定对象设置指定参数的值。
void | RowSet.setObject(String parameterName, Object x, int targetSqlType, int scale) 使用给定对象设置指定参数的值。
void | RowSet.setPassword(String password) 将此 RowSet 对象的数据库密码设置为给定的 String。
void | RowSetMetaData.setPrecision(int columnIndex, int precision) 将指定列的小数位数设置为给定的 int。
void | RowSet.setQueryTimeout(int seconds) 将驱动程序等待语句执行的最大秒数设置为给定的秒数。
void | RowSet.setReadOnly(boolean value) 将此 RowSet 对象的只读性设置为给定的 boolean 值。
void | RowSet.setRef(int i, Ref x) 使用给定 Ref 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setRowId(int parameterIndex, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | RowSet.setRowId(String parameterName, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | RowSetMetaData.setScale(int columnIndex, int scale) 将指定列的小数点右边的位数设置为给定的 int。
void | RowSetMetaData.setSchemaName(int columnIndex, String schemaName) 将指定列的表模式的名称（如果有）设置为给定的 String。
void | RowSetMetaData.setSearchable(int columnIndex, boolean property) 设置是否可以在 where 子句中使用指定的列。
void | RowSet.setShort(int parameterIndex, short x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java short 值。
void | RowSet.setShort(String parameterName, short x) 将指定参数设置为给定的 Java short 值。
void | RowSetMetaData.setSigned(int columnIndex, boolean property) 设置指定列是否是有符号数字。
void | RowSet.setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | RowSet.setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定的 java.sql.SQLXML 对象。
void | RowSet.setString(int parameterIndex, String x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java String 值。
void | RowSet.setString(String parameterName, String x) 将指定参数设置为给定的 Java String 值。
void | RowSetMetaData.setTableName(int columnIndex, String tableName) 将指定列的表名称（如果有）设置为给定的 String。
void | RowSet.setTime(int parameterIndex, Time x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTime(int parameterIndex, Time x, Calendar cal) 使用给定 java.sql.Time 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTime(String parameterName, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTimestamp(int parameterIndex, Timestamp x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Timestamp 值。
void | RowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定 java.sql.Timestamp 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | RowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。
void | RowSet.setTransactionIsolation(int level) 设置此 RowSet 对象的事务隔离级别。
void | RowSet.setType(int type) 将此 RowSet 对象的类型设置为给定的类型。
void | RowSet.setTypeMap(Map<String,Class<?>> map) 将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。
void | RowSet.setURL(int parameterIndex, URL x) 将指定参数设置为给定的 java.net.URL 值。
void | RowSet.setUrl(String url) 设置此 RowSet 对象在使用 DriverManager 创建连接时将使用的 URL。
void | RowSet.setUsername(String name) 将此 RowSet 对象的用户名属性设置为给定的 String。
boolean | RowSetWriter.writeData(RowSetInternal caller) 将此 RowSetWriter 对象的 rowset 中的更改写回它从中获取数据的数据源。

参数类型为 SQLException 的 javax.sql 中的构造方法
ConnectionEvent(PooledConnection con, SQLException ex)
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象和 SQLException 对象进行初始化。
StatementEvent(PooledConnection con, PreparedStatement statement, SQLException exception)
用指定的 PooledConnection、PreparedStatement 和 SQLException 构造 StatementEvent。

javax.sql.rowset 中 SQLException 的使用

javax.sql.rowset 中 SQLException 的子类
 class RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

抛出 SQLException 的 javax.sql.rowset 中的方法
 void JoinRowSet.addRowSet(Joinable rowset)
将给定的 RowSet 对象添加到此 JoinRowSet 对象。
 void JoinRowSet.addRowSet(RowSet[] rowset, int[] columnIdx)
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列索引数组中的匹配列。
 void JoinRowSet.addRowSet(RowSet[] rowset, String[] columnName)
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列名数组中的匹配列。
 void JoinRowSet.addRowSet(RowSet rowset, int columnIdx)
将给定的 RowSet 对象添加到此 JoinRowSet 对象，并将指定的列设置为 RowSet 对象的匹配列。
 void JoinRowSet.addRowSet(RowSet rowset, String columnName)
将 rowset 添加到此 JoinRowSet 对象，并将指定的列设置为匹配列。
 void BaseRowSet.clearParameters()
清除所有此 RowSet 对象的内部参数表示形式的当前参数值，这些参数值将在执行此 RowSet 对象的命令时在其中设置这些参数。
 boolean CachedRowSet.columnUpdated(int idx)
指示此 CachedRowSet 对象当前行中的指定列是否已更新。
 boolean CachedRowSet.columnUpdated(String columnName)
指示此 CachedRowSet 对象当前行中的指定列是否已更新。
 void CachedRowSet.commit()
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。
 void JdbcRowSet.commit()
每个 JdbcRowSet 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。
 CachedRowSet CachedRowSet.createCopy()
创建一个 RowSet 对象，它是此 CachedRowSet 对象中数据的深层副本。
 CachedRowSet CachedRowSet.createCopyNoConstraints()
创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象数据的深层副本，但是独立于此 CachedRowSet 对象。
 CachedRowSet CachedRowSet.createCopySchema()
创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象的空副本。
 RowSet CachedRowSet.createShared()
返回一个新的 RowSet 对象，支持该对象的数据与此 CachedRowSet 对象的相同。
 boolean Predicate.evaluate(Object value, int column)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter() 方法设置的过滤标准（或标准，如果存在多个约束）中。
 boolean Predicate.evaluate(Object value, String columnName)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter 方法设置的过滤标准中。
 void CachedRowSet.execute(Connection conn)
用数据填充此 CachedRowSet 对象，使用给定的连接来生成从中读取数据的结果集。
 boolean JdbcRowSet.getAutoCommit()
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 String RowSetMetaDataImpl.getCatalogName(int columnIndex)
获取派生指定列中值的表的类别名称。
 String RowSetMetaDataImpl.getColumnClassName(int columnIndex)
获取 Java 编程语言中一个类的完全限定名，该类是指定列中的值将映射到的那个类。
 int RowSetMetaDataImpl.getColumnCount()
获取为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中的列数。
 int RowSetMetaDataImpl.getColumnDisplaySize(int columnIndex)
获取以 char 为单位的指定列的正常最大宽度。
 String RowSetMetaDataImpl.getColumnLabel(int columnIndex)
获取用于打印输出和显示的指定列的建议列标题。
 String RowSetMetaDataImpl.getColumnName(int columnIndex)
获取指定列的名称。
 int RowSetMetaDataImpl.getColumnType(int columnIndex)
获取存储在指定行中值的 SQL 类型的类型代码（java.sql.Types 常量之一）。
 String RowSetMetaDataImpl.getColumnTypeName(int columnIndex)
获取存储在指定列中值的特定于 DBMS 的类型名称。
 int BaseRowSet.getConcurrency()
返回此 RowSet 对象的并发性。
 boolean BaseRowSet.getEscapeProcessing()
确定是否为此 RowSet 对象启用了转义处理。
 int BaseRowSet.getFetchDirection()
获取此 RowSet 对象的当前有关获取方向的设置。
 int BaseRowSet.getFetchSize()
返回此 RowSet 对象的获取大小。
 int JoinRowSet.getJoinType()
返回一个 int 值，它描述控制此 JoinRowSet 实例的已设置 SQL JOIN 类型。
 int[] CachedRowSet.getKeyColumns()
返回一个包含一个或多个列号的数组，这些列号指示了形成某个键的列，该键唯一地标识了此 CachedRowSet 对象中的某个行。
 int[] Joinable.getMatchColumnIndexes()
获取使用方法 setMatchColumn(int[] columnIdxes) 为此 RowSet 对象设置的匹配列的索引。
 String[] Joinable.getMatchColumnNames()
获取使用方法 setMatchColumn(String [] columnNames) 为此 RowSet 对象设置的匹配列的名称。
 int BaseRowSet.getMaxFieldSize()
获取可用于此 RowSet 对象列值的最大字节数。
 int BaseRowSet.getMaxRows()
获取此 RowSet 对象可以包含的最大行数。
 ResultSet CachedRowSet.getOriginal()
返回一个包含此 CachedRowSet 对象原始值的 ResultSet 对象。
 ResultSet CachedRowSet.getOriginalRow()
返回一个只包含此 CachedRowSet 对象当前行原始值的 ResultSet 对象。
 Object[] BaseRowSet.getParams()
获取一个数组，其中包含为此 RowSet 对象命令设置的参数值（包括 Object 和基本类型），如果尚未设置任何参数，则抛出 SQLException 对象。
 int RowSetMetaDataImpl.getPrecision(int columnIndex)
获取存储在指定列中的值的数字总数。
 int BaseRowSet.getQueryTimeout()
获取驱动程序等待查询执行的最大秒数。
 String[] JoinRowSet.getRowSetNames()
返回一个 String 数组，包含添加到此 JoinRowSet 对象的 RowSet 对象的名称。
 Collection<?> JoinRowSet.getRowSets()
返回一个 Collection 对象，包含已经添加到此 JoinRowSet 对象的 RowSet 对象。
 RowSetWarning CachedRowSet.getRowSetWarnings()
获取此 RowSet 对象上的调用报告的第一个警告。
 RowSetWarning JdbcRowSet.getRowSetWarnings()
获取此 JdbcRowSet 对象上的调用报告的第一个警告。
 int RowSetMetaDataImpl.getScale(int columnIndex)
获取存储在指定列中的值的小数点右边的数字数。
 String RowSetMetaDataImpl.getSchemaName(int columnIndex)
获取派生指定列中值的表的模式名称。
 boolean BaseRowSet.getShowDeleted()
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
 boolean CachedRowSet.getShowDeleted()
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
 boolean JdbcRowSet.getShowDeleted()
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
 SyncProvider CachedRowSet.getSyncProvider()
获取此 CachedRowSet 对象的 SyncProvider 实现。
 String CachedRowSet.getTableName()
返回创建此 CachedRowSet 对象时所用对象（表）的标识符。
 String RowSetMetaDataImpl.getTableName(int columnIndex)
获取派生指定列中值的表名称。
 int BaseRowSet.getType()
返回此 RowSet 对象的类型。
 String BaseRowSet.getUrl()
获取此 RowSet 对象的 javax.sql.Reader 对象用来建立与关系数据库连接（使用启用 JDBC 技术的驱动程序）的 JDBC URL。
 String JoinRowSet.getWhereClause()
返回在 JoinRowSet 对象中使用的 WHERE 子句的类似 SQL 的描述。
 boolean RowSetMetaDataImpl.isAutoIncrement(int columnIndex)
获取存储在指定列中的值是否自动编号，因而是只读的。
 boolean RowSetMetaDataImpl.isCaseSensitive(int columnIndex)
指示指定列的名称是否区分大小写。
 boolean RowSetMetaDataImpl.isCurrency(int columnIndex)
指示存储在指定列中的值是否为缓存值。
 boolean RowSetMetaDataImpl.isDefinitelyWritable(int columnIndex)
指示在指定的列上进行写操作是否一定可以获得成功。
 int RowSetMetaDataImpl.isNullable(int columnIndex)
获取指示是否可以在指定列中存储 NULL 值的常量。
 boolean RowSetMetaDataImpl.isReadOnly(int columnIndex)
指示指定的列是否一定不可写入，即只读。
 boolean RowSetMetaDataImpl.isSearchable(int columnIndex)
指示是否可以在 WHERE 子句中使用存储在指定列中的值。
 boolean RowSetMetaDataImpl.isSigned(int columnIndex)
指示存储在指定列中的值是否为有符号数。
 boolean RowSetMetaDataImpl.isWrapperFor(Class<?> interfaces)
如果调用者实现接口参数或者是实现接口参数的对象的直接或间接包装器，则返回 true。
 boolean RowSetMetaDataImpl.isWritable(int columnIndex)
指示在指定的列上进行写操作是否可以获得成功。
 boolean CachedRowSet.nextPage()
逐个增加 CachedRowSet 的当前页。
protected  void BaseRowSet.notifyCursorMoved()
通知向此 RowSet 对象注册的所有侦听器其光标已移动。
protected  void BaseRowSet.notifyRowChanged()
通知向此 RowSet 对象注册的所有侦听器其行已更改。
protected  void BaseRowSet.notifyRowSetChanged()
通知向此 RowSet 对象注册的所有侦听器其整个内容已更改。
 void CachedRowSet.populate(ResultSet data)
使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
 void CachedRowSet.populate(ResultSet rs, int startRow)
使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
 boolean CachedRowSet.previousPage()
逐个减少 CachedRowSet 的当前页。
 void WebRowSet.readXml(InputStream iStream)
读取基于流的 XML 输入，以填充此 WebRowSet 对象。
 void WebRowSet.readXml(Reader reader)
从给定的 Reader 对象以其 XML 格式读取 WebRowSet 对象。
 void CachedRowSet.release()
释放此 CachedRowSet 对象的当前内容并将 rowSetChanged 事件发送到所有已注册侦听器。
 void CachedRowSet.restoreOriginal()
将此 CachedRowSet 对象还原成其原始值，即执行上一组更改前的值。
 void CachedRowSet.rollback()
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 void JdbcRowSet.rollback()
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 void CachedRowSet.rollback(Savepoint s)
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 void JdbcRowSet.rollback(Savepoint s)
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 void CachedRowSet.rowSetPopulated(RowSetEvent event, int numRows)
通知已注册侦听器给定 RowSetEvent 对象中的某个 RowSet 对象已经填充了多个附加行。
 void BaseRowSet.setArray(int parameterIndex, Array array)
将指定参数设置为 Java 编程语言中的 Array 对象。
 void BaseRowSet.setAsciiStream(int parameterIndex, InputStream x)
将此 RowSet 对象命令中的指定参数设置为给定输入流。
 void BaseRowSet.setAsciiStream(int parameterIndex, InputStream x, int length)
将指定参数设置为给定的 java.io.InputStream 对象，该对象将具有指定的字节数。
 void BaseRowSet.setAsciiStream(String parameterName, InputStream x)
将指定参数设置为给定的输入流。
 void BaseRowSet.setAsciiStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定字节数。
 void JdbcRowSet.setAutoCommit(boolean autoCommit)
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 void RowSetMetaDataImpl.setAutoIncrement(int columnIndex, boolean property)
将指定列设置为给定 boolean 值，以指示是否为该列自动编号，从而变为只读。
 void BaseRowSet.setBigDecimal(int parameterIndex, BigDecimal x)
将指定参数设置为给定的 java.lang.BigDecimal 值。
 void BaseRowSet.setBigDecimal(String parameterName, BigDecimal x)
将指定参数设置为给定的 java.math.BigDecimal 值。
 void BaseRowSet.setBinaryStream(int parameterIndex, InputStream x)
将此 RowSet 对象命令中的指定参数设置为给定输入流。
 void BaseRowSet.setBinaryStream(int parameterIndex, InputStream x, int length)
将指定参数设置为给定的 java.io.InputStream 对象，该对象具有指定的字节数。
 void BaseRowSet.setBinaryStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。
 void BaseRowSet.setBinaryStream(String parameterName, InputStream x, int length)
将指定参数设置为给定的输入流，该输入流将拥有指定的字节数。
 void BaseRowSet.setBlob(int parameterIndex, Blob x)
将指定参数设置为 Java 编程语言中的给定 Blob 对象。
 void BaseRowSet.setBlob(int parameterIndex, InputStream inputStream)
将指定参数设置为 InputStream 对象。
 void BaseRowSet.setBlob(int parameterIndex, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。
 void BaseRowSet.setBlob(String parameterName, Blob x)
将指定参数设置为给定的 java.sql.Blob 对象。
 void BaseRowSet.setBlob(String parameterName, InputStream inputStream)
将指定参数设置为 InputStream 对象。
 void BaseRowSet.setBlob(String parameterName, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。
 void BaseRowSet.setBoolean(int parameterIndex, boolean x)
将指定参数设置为 Java 编程语言中的给定 boolean 值。
 void BaseRowSet.setBoolean(String parameterName, boolean x)
将指定参数设置为给定的 Java boolean 值。
 void BaseRowSet.setByte(int parameterIndex, byte x)
将指定参数设置为 Java 编程语言中的给定 byte 值。
 void BaseRowSet.setByte(String parameterName, byte x)
将指定参数设置为给定的 Java byte 值。
 void BaseRowSet.setBytes(int parameterIndex, byte[] x)
将指定参数设置为给定的 byte 数组。
 void BaseRowSet.setBytes(String parameterName, byte[] x)
将指定参数设置为给定的 Java byte 数组。
 void RowSetMetaDataImpl.setCaseSensitive(int columnIndex, boolean property)
将指定列设置为给定的 boolean 值，以指示该列的名称是否区分大小写。
 void RowSetMetaDataImpl.setCatalogName(int columnIndex, String catalogName)
将派生指定列的表名称设置为 catalogName。
 void BaseRowSet.setCharacterStream(int parameterIndex, Reader reader)
将此 RowSet 对象命令中的指定参数设置为给定的 Reader 对象。
 void BaseRowSet.setCharacterStream(int parameterIndex, Reader reader, int length)
将指定参数设置为给定的 java.io.Reader 对象，该对象具有指定的字符数。
 void BaseRowSet.setCharacterStream(String parameterName, Reader reader)
将指定参数设置为给定 Reader 对象。
 void BaseRowSet.setCharacterStream(String parameterName, Reader reader, int length)
将指定参数设置为给定的 Reader 对象，该对象是给定的字符长度数目。
 void BaseRowSet.setClob(int parameterIndex, Clob x)
将指定参数设置为 Java 编程语言中的给定 Clob 对象。
 void BaseRowSet.setClob(int parameterIndex, Reader reader)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setClob(int parameterIndex, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setClob(String parameterName, Clob x)
将指定参数设置为给定的 java.sql.Clob 对象。
 void BaseRowSet.setClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void RowSetMetaDataImpl.setColumnCount(int columnCount)
在为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中，将列数设置为给定数。
 void RowSetMetaDataImpl.setColumnDisplaySize(int columnIndex, int size)
将指定列中的正常最大 char 数设置为给定数。
 void RowSetMetaDataImpl.setColumnLabel(int columnIndex, String label)
将建议用于打印输出和显示的列标签（如果有）设置为给定的 label。
 void RowSetMetaDataImpl.setColumnName(int columnIndex, String columnName)
将指定列的列名称设置为给定的名称。
 void RowSetMetaDataImpl.setColumnType(int columnIndex, int SQLType)
将存储在指定列中的值的 SQL 类型代码设置为 java.sql.Types 类中的给定类型代码。
 void RowSetMetaDataImpl.setColumnTypeName(int columnIndex, String typeName)
将供存储在指定列中的值的数据源使用的类型名称设置为给定类型名称。
 void BaseRowSet.setCommand(String cmd)
将此 RowSet 对象的 command 属性设置为给定的 String 对象，并清除为前一个命令设置的参数（如果有）。
 void BaseRowSet.setConcurrency(int concurrency)
将此 RowSet 对象的并发性设置为指定的并发性。
 void RowSetMetaDataImpl.setCurrency(int columnIndex, boolean property)
将指定列设置为给定的 boolean，以指示存储在该列中的值是否为缓存值。
 void BaseRowSet.setDataSourceName(String name)
将此 RowSet 对象的 DataSource 名称属性设置为给定的逻辑名，并将此 RowSet 对象的 Url 属性设置为 null。
 void BaseRowSet.setDate(int parameterIndex, Date x)
将指定参数设置为给定的 java.sql.Date 值。
 void BaseRowSet.setDate(int parameterIndex, Date x, Calendar cal)
将指定参数设置为给定的 java.sql.Date 对象。
 void BaseRowSet.setDate(String parameterName, Date x)
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
 void BaseRowSet.setDate(String parameterName, Date x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
 void BaseRowSet.setDouble(int parameterIndex, double x)
将指定参数设置为 Java 编程语言中的给定 double 值。
 void BaseRowSet.setDouble(String parameterName, double x)
将指定参数设置为给定的 Java double 值。
 void BaseRowSet.setEscapeProcessing(boolean enable)
设置为给定的 boolean 值，指示将 SQL 语句发送到数据库之前，驱动程序是否扫描转义语法并进行转义替换。
 void BaseRowSet.setFetchDirection(int direction)
为驱动程序提供一个性能提示，该提示指示处理此 RowSet 对象中各行时使用的方向。
 void BaseRowSet.setFetchSize(int rows)
将此 RowSet 对象的获取大小设置为给定的行数。
 void FilteredRowSet.setFilter(Predicate p)
将给定的 Predicate 对象应用到此 FilteredRowSet 对象。
 void BaseRowSet.setFloat(int parameterIndex, float x)
将指定参数设置为 Java 编程语言中的给定 float 值。
 void BaseRowSet.setFloat(String parameterName, float x)
将指定参数设置为给定的 Java float 值。
 void BaseRowSet.setInt(int parameterIndex, int x)
将指定参数设置为 Java 编程语言中的 int 值。
 void BaseRowSet.setInt(String parameterName, int x)
将指定参数设置为给定的 Java int 值。
 void JoinRowSet.setJoinType(int joinType)
允许应用程序调整在 JoinRowSet 对象实例包含的表上强制应用的 JOIN 类型。
 void CachedRowSet.setKeyColumns(int[] keys)
使用给定的列号数组设置此 CachedRowSet 对象的 keyCols 字段，它形成了唯一标识此 CachedRowSet 对象中某个行的键。
 void BaseRowSet.setLong(int parameterIndex, long x)
将指定参数设置为 Java 编程语言中的给定 long 值。
 void BaseRowSet.setLong(String parameterName, long x)
将指定参数设置为给定的 Java long 值。
 void Joinable.setMatchColumn(int columnIdx)
将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.setMatchColumn(int[] columnIdxes)
将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.setMatchColumn(String columnName)
将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.setMatchColumn(String[] columnNames)
将指定的列设置为此 RowSet 对象的匹配列。
 void BaseRowSet.setMaxFieldSize(int max)
将可用于此 RowSet 对象列值的最大字节数设置为给定数。
 void BaseRowSet.setMaxRows(int max)
将此 RowSet 对象可以包含的最大行数设置为给定数。
 void CachedRowSet.setMetaData(RowSetMetaData md)
使用给定的 RowSetMetaData 对象设置此 CachedRowSet 对象的元数据。
 void BaseRowSet.setNCharacterStream(int parameterIndex, Reader value)
将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
 void BaseRowSet.setNCharacterStream(int parameterIndex, Reader value, long length)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNCharacterStream(String parameterName, Reader value)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNCharacterStream(String parameterName, Reader value, long length)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNClob(int parameterIndex, NClob value)
将指定参数设置为 java.sql.NClob 对象。
 void BaseRowSet.setNClob(int parameterIndex, Reader reader)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNClob(int parameterIndex, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNClob(String parameterName, NClob value)
将指定参数设置为 java.sql.NClob 对象。
 void BaseRowSet.setNClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNString(int parameterIndex, String value)
将指定参数设置为给定的 String 对象。
 void BaseRowSet.setNString(String parameterName, String value)
将指定参数设置为给定的 String 对象。
 void BaseRowSet.setNull(int parameterIndex, int sqlType)
将指定参数设置为 SQL NULL。
 void BaseRowSet.setNull(int parameterIndex, int sqlType, String typeName)
将指定参数设置为 SQL NULL。
 void BaseRowSet.setNull(String parameterName, int sqlType)
将指定参数设置为 SQL NULL。
 void BaseRowSet.setNull(String parameterName, int sqlType, String typeName)
将指定参数设置为 SQL NULL。
 void RowSetMetaDataImpl.setNullable(int columnIndex, int property)
将指定列设置为 ResultSetMetaData 接口中的给定常量，以指示是否可以将存储在该列中的值设置为 NULL。
 void BaseRowSet.setObject(int parameterIndex, Object x)
将指定参数设置为 Java 编程语言中的 Object。
 void BaseRowSet.setObject(int parameterIndex, Object x, int targetSqlType)
使用给定 Object 值设置指定参数的值。
 void BaseRowSet.setObject(int parameterIndex, Object x, int targetSqlType, int scale)
将指定参数设置为 Java 编程语言中的 Object。
 void BaseRowSet.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。
 void BaseRowSet.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。
 void BaseRowSet.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。
 void CachedRowSet.setOriginalRow()
将此 CachedRowSet 对象中的当前行设置为原始行。
 void CachedRowSet.setPageSize(int size)
设置 CachedRowSet 对象的页大小。
 void RowSetMetaDataImpl.setPrecision(int columnIndex, int precision)
将存储在指定列中的值的小数位数的总数设置为给定数。
 void BaseRowSet.setQueryTimeout(int seconds)
将驱动程序等待查询执行的最大秒数设置为给定的数。
 void BaseRowSet.setRef(int parameterIndex, Ref ref)
将指定参数设置为 Java 编程语言中的给定 Ref 对象。
 void BaseRowSet.setRowId(int parameterIndex, RowId x)
将指定参数设置为给定的 java.sql.RowId 对象。
 void BaseRowSet.setRowId(String parameterName, RowId x)
将指定参数设置为给定的 java.sql.RowId 对象。
 void RowSetMetaDataImpl.setScale(int columnIndex, int scale)
将存储在指定列中的值的小数点右边的位数设置为给定数。
 void RowSetMetaDataImpl.setSchemaName(int columnIndex, String schemaName)
将指定列的表的模式名称（如果有）设置为 schemaName。
 void RowSetMetaDataImpl.setSearchable(int columnIndex, boolean property)
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否可以在 WHERE 子句中使用。
 void BaseRowSet.setShort(int parameterIndex, short x)
将指定参数设置为 Java 编程语言中的给定 short 值。
 void BaseRowSet.setShort(String parameterName, short x)
将指定参数设置为给定的 Java short 值。
 void BaseRowSet.setShowDeleted(boolean value)
将属性 showDeleted 设置为给定的 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
 void CachedRowSet.setShowDeleted(boolean b)
将属性 showDeleted 设置为给定的 boolean 值，它确定标记为删除的行是否会出现在当前行集合中。
 void JdbcRowSet.setShowDeleted(boolean b)
将属性 showDeleted 设置为给定的 boolean 值。
 void RowSetMetaDataImpl.setSigned(int columnIndex, boolean property)
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否为有符号数。
 void BaseRowSet.setSQLXML(int parameterIndex, SQLXML xmlObject)
将指定参数设置为给定 java.sql.SQLXML 对象。
 void BaseRowSet.setSQLXML(String parameterName, SQLXML xmlObject)
将指定参数设置为给定的 java.sql.SQLXML 对象。
 void BaseRowSet.setString(int parameterIndex, String x)
将指定参数设置为给定的 String 值。
 void BaseRowSet.setString(String parameterName, String x)
将指定参数设置为给定的 Java String 值。
 void CachedRowSet.setSyncProvider(String provider)
将此 CachedRowSet 对象的 SyncProvider 对象设置为指定的提供者。
 void RowSetMetaDataImpl.setTableName(int columnIndex, String tableName)
将派生指定列的表名称设置为给定的表名称。
 void CachedRowSet.setTableName(String tabName)
将派生此 CachedRowSet 对象的表的标识符设置为给定的表名。
 void BaseRowSet.setTime(int parameterIndex, Time x)
将指定参数设置为给定的 java.sql.Time 值。
 void BaseRowSet.setTime(int parameterIndex, Time x, Calendar cal)
将指定参数设置为给定的 java.sql.Time 对象。
 void BaseRowSet.setTime(String parameterName, Time x)
将指定参数设置为给定的 java.sql.Time 值。
 void BaseRowSet.setTime(String parameterName, Time x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
 void BaseRowSet.setTimestamp(int parameterIndex, Timestamp x)
将指定参数设置为给定的 java.sql.Timestamp 值。
 void BaseRowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal)
将指定参数设置为给定的 java.sql.Timestamp 对象。
 void BaseRowSet.setTimestamp(String parameterName, Timestamp x)
将指定参数设置为给定的 java.sql.Timestamp 值。
 void BaseRowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。
 void BaseRowSet.setTransactionIsolation(int level)
将此 JDBC RowSet 对象的事务隔离属性设置为给定的常量。
 void BaseRowSet.setType(int type)
将此 RowSet 对象的类型设置为指定类型。
 void BaseRowSet.setUnicodeStream(int parameterIndex, InputStream x, int length)
已过时。 应该使用 getCharacterStream 替代它
 void BaseRowSet.setURL(int parameterIndex, URL x)
将指定参数设置为给定的 java.net.URL 值。
 void BaseRowSet.setUrl(String url)
将此 RowSet 对象的 Url 属性设置为给定的 String 对象，并将 dataSource 名称属性设置为 null。
 CachedRowSet JoinRowSet.toCachedRowSet()
创建一个包含此 JoinRowSet 对象中数据的新 CachedRowSet 对象，可以使用 CachedRowSet 对象的 SyncProvider 对象将此 JoinRowSet 对象保存到数据源。
 Collection<?> CachedRowSet.toCollection()
将此 CachedRowSet 对象转换成一个 Collection 对象，它包含此 CachedRowSet 对象的所有数据。
 Collection<?> CachedRowSet.toCollection(int column)
将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
 Collection<?> CachedRowSet.toCollection(String column)
将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
 void CachedRowSet.undoDelete()
取消删除当前行并通知侦听器已更改了某个行。
 void CachedRowSet.undoInsert()
如果已经插入了当前行，则立即将它从此 CachedRowSet 对象移除，同样要通知侦听器已更改了某个行。
 void CachedRowSet.undoUpdate()
如果已经修改了行，则立即逆转上一次更新操作。
 void Joinable.unsetMatchColumn(int columnIdx)
取消将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.unsetMatchColumn(int[] columnIdxes)
取消将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.unsetMatchColumn(String columnName)
取消将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.unsetMatchColumn(String[] columnName)
取消将指定的列设置为此 RowSet 对象的匹配列。
<T> T
RowSetMetaDataImpl.unwrap(Class<T> iface)
返回实现给定接口以允许访问非标准方法，或者代理未公开标准方法的的对象。
 void WebRowSet.writeXml(OutputStream oStream)
以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 OutputStream 对象。
 void WebRowSet.writeXml(ResultSet rs, OutputStream oStream)
使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。
 void WebRowSet.writeXml(ResultSet rs, Writer writer)
使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 Writer 对象。
 void WebRowSet.writeXml(Writer writer)
以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 Writer 对象。

javax.sql.rowset.serial 中 SQLException 的使用

javax.sql.rowset.serial 中 SQLException 的子类
 class SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

抛出 SQLException 的 javax.sql.rowset.serial 中的方法
void | SerialArray.free() 此方法释放 Array 对象及其占有的资源。
void | SerialBlob.free() 此方法释放 Blob 对象及其占有的资源。
void | SerialClob.free()
InputStream | SerialClob.getAsciiStream() 以 ascii 流的形式获取此 SerialClob 对象指定的 CLOB 值。
InputStream | SerialBlob.getBinaryStream(long pos, long length) 返回一个包含部分 Blob 值的 InputStream 对象，它从 pos 指定的字节开始，具有 length 个字节长度。
Reader | SerialClob.getCharacterStream(long pos, long length)
long | SerialBlob.position(Blob pattern, long start) 返回此 SerialBlob 对象中给定 Blob 对象开始的位置，搜索从指定位置开始。
long | SerialBlob.position(byte[] pattern, long start) 返回在此 SerialBlob 对象中给定模式的字节开始的位置，搜索从指定的位置开始。
long | SerialClob.position(Clob searchStr, long start) 返回此 SerialClob 对象中给定 Clob 签名开始的位置，搜索从指定位置开始。
long | SerialClob.position(String searchStr, long start) 返回此 SerialClob 对象中给定 String 对象开始的位置，搜索从指定位置开始。
Array | SQLInputImpl.readArray() 从流中读取 SQL ARRAY 值并以 Java 编程语言中 Array 对象的形式返回。
InputStream | SQLInputImpl.readAsciiStream() 以 ASCII 字符流的形式返回此 SQLInputImpl 对象中的下一个属性。
BigDecimal | SQLInputImpl.readBigDecimal() 以 java.math.BigDecimal 的形式获取此 SQLInputImpl 对象中的下一个属性。
InputStream | SQLInputImpl.readBinaryStream() 以未解释字节流的形式返回此 SQLInputImpl 对象中的下一个属性。
Blob | SQLInputImpl.readBlob() 以 Java 编程语言中 Blob 对象的形式获取此 SQLInputImpl 对象头部的 BLOB 值。
boolean | SQLInputImpl.readBoolean() 以 Java 编程语言中 boolean 的形式获取此 SQLInputImpl 对象中的下一个属性。
byte | SQLInputImpl.readByte() 以 Java 编程语言中 byte 的形式获取此 SQLInputImpl 对象中的下一个属性。
byte[] | SQLInputImpl.readBytes() 以字节数组的形式获取此 SQLInputImpl 对象中的下一个属性。
Reader | SQLInputImpl.readCharacterStream() 以 Unicode 字符流的形式获取此 SQLInputImpl 对象中的下一个属性。
Clob | SQLInputImpl.readClob() 以 Java 编程语言中 Clob 对象的形式获取此 SQLInputImpl 对象头部的 CLOB 值。
Date | SQLInputImpl.readDate() 以 java.sql.Date 对象的形式获取此 SQLInputImpl 中的下一个属性。
double | SQLInputImpl.readDouble() 以 Java 编程语言中 double 的形式获取此 SQLInputImpl 对象中的下一个属性。
float | SQLInputImpl.readFloat() 以 Java 编程语言中 float 的形式获取此 SQLInputImpl 对象中的下一个属性。
int | SQLInputImpl.readInt() 以 Java 编程语言中 int 的形式获取此 SQLInputImpl 对象中的下一个属性。
long | SQLInputImpl.readLong() 以 Java 编程语言中 long 的形式获取此 SQLInputImpl 对象中的下一个属性。
NClob | SQLInputImpl.readNClob() 从流中读取 SQL NCLOB 值并以 Java 编程语言中 Clob 对象的形式返回。
String | SQLInputImpl.readNString() 读取流中下一个属性并以 Java 编程语言中 String 的形式返回。
Object | SQLInputImpl.readObject() 以 Java 编程语言中 Object 的形式获取此 SQLInputImpl 对象的头部值。
Ref | SQLInputImpl.readRef() 以 Java 编程语言中 Ref 对象的形式获取此 SQLInputImpl 对象的头部值。
RowId | SQLInputImpl.readRowId() 从流中读取 SQL ROWID 值并以 Java 编程语言中 RowId 对象的形式返回。
short | SQLInputImpl.readShort() 以 Java 编程语言中 short 的形式获取此 SQLInputImpl 对象中的下一个属性。
SQLXML | SQLInputImpl.readSQLXML() 从流中读取 SQL XML 值并以 Java 编程语言中 SQLXML 对象的形式返回。
String | SQLInputImpl.readString() 以 Java 编程语言中 String 的形式获取此 SQLInputImpl 对象中的下一个属性。
Time | SQLInputImpl.readTime() 以 java.sql.Time 对象的形式获取此 SQLInputImpl 对象中的下一个属性。
Timestamp | SQLInputImpl.readTimestamp() 以 java.sql.Timestamp 对象的形式获取此 SQLInputImpl 对象中的下一个属性。
URL | SQLInputImpl.readURL() 从流中读取 SQL DATALINK 值并以 Java 编程语言中 URL 对象的形式返回。
OutputStream | SerialClob.setAsciiStream(long pos) 获取用于将 Ascii 字符写入此 SerialClob 对象所表示的 Clob 值的流，从位置 pos 处开始。
OutputStream | SerialBlob.setBinaryStream(long pos) 获取用于写入此 Blob 对象所表示的 BLOB 值的流。
int | SerialBlob.setBytes(long pos, byte[] bytes) 将给定字节数组写入此 Blob 对象表示的 BLOB 值（从位置 pos 处开始），并返回写入的字节数。
int | SerialBlob.setBytes(long pos, byte[] bytes, int offset, int length) 将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
Writer | SerialClob.setCharacterStream(long pos) 获取用于将 Unicode 字符流写入此 SerialClob 对象所表示的 CLOB 值（位置 pos 处）的流。
boolean | SQLInputImpl.wasNull() 确认从此 SQLInputImpl 对象读取的上一个值是否为 null。
void | SQLOutputImpl.writeArray(Array x) 将 Java 编程语言中的 Array 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeAsciiStream(InputStream x) 将 ASCII 字符流写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBigDecimal(BigDecimal x) 将 Java 编程语言中的 java.math.BigDecimal 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBinaryStream(InputStream x) 将未解释字节流写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBlob(Blob x) 将 Java 编程语言中的 Blob 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBoolean(boolean x) 将 Java 编程语言中的 boolean 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeByte(byte x) 将 Java 编程语言中的 byte 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBytes(byte[] x) 将 Java 编程语言中的 byte 数组写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeCharacterStream(Reader x) 将 Unicode 字符流写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeClob(Clob x) 将 Java 编程语言中的 Clob 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeDate(Date x) 将 Java 编程语言中的 java.sql.Date 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeDouble(double x) 将 Java 编程语言中的 double 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeFloat(float x) 将 Java 编程语言中的 float 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeInt(int x) 将 Java 编程语言中的 int 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeLong(long x) 将 Java 编程语言中的 long 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeNClob(NClob x) 将 SQL NCLOB 值写入流中。
void | SQLOutputImpl.writeNString(String x) 将下一个属性以 Java 编程语言中 String 的形式写入流中。
void | SQLOutputImpl.writeObject(SQLData x) 将包含在给定 SQLData 对象中的数据写入流中。
void | SQLOutputImpl.writeRef(Ref x) 将 Java 编程语言中的 Ref 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeRowId(RowId x) 将 SQL ROWID 值写入流中。
void | SQLOutputImpl.writeShort(short x) 将 Java 编程语言中的 short 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeSQLXML(SQLXML x) 将 SQL XML 值写入流中。
void | SQLOutputImpl.writeString(String x) 将 Java 编程语言中的 String 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeStruct(Struct x) 将 Java 编程语言中的 Struct 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeTime(Time x) 将 Java 编程语言中的 java.sql.Time 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeTimestamp(Timestamp x) 将 Java 编程语言中的 java.sql.Timestamp 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeURL(URL url) 将 Java 编程语言中的 java.sql.Type.DATALINK 对象写入此 SQLOutputImpl 对象。

抛出 SQLException 的 javax.sql.rowset.serial 中的构造方法
SerialArray(Array array)
根据给定 Array 对象构造新的 SerialArray 对象。
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
SerialBlob(Blob blob)
根据给定 Blob 对象的序列化形式构造一个 SerialBlob 对象。
SerialBlob(byte[] b)
按照给定 byte 数组的序列化形式构造一个 SerialBlob 对象。
SerialClob(char[] ch)
按照给定 char 数组的序列化形式构造一个 SerialClob 对象。
SerialClob(Clob clob)
按照给定 Clob 对象的序列化形式构造一个 SerialClob 对象。
SerialRef(Ref ref)
根据给定 Ref 对象构造 SerialRef 对象。
SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。
SQLOutputImpl(Vector<?> attributes, Map<String,?> map)
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。

javax.sql.rowset.spi 中 SQLException 的使用

javax.sql.rowset.spi 中 SQLException 的子类
class | SyncFactoryException 指示 SyncFactory 机制发生的错误。
class | SyncProviderException 指示 SyncProvider 机制发生的错误。

抛出 SQLException 的 javax.sql.rowset.spi 中的方法
void | TransactionalWriter.commit() 使最后一次调用 commit 或 rollback 方法以来 acceptChanges 执行的所有更改永久化。
Object | SyncResolver.getConflictValue(int index) 获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。
Object | SyncResolver.getConflictValue(String columnName) 获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。
boolean | SyncResolver.nextConflict() 将指针从其当前位置移动到下一个包含冲突值的行。
boolean | SyncResolver.previousConflict() 将指针从其当前位置移动到此 SyncResolver 对象中上一个冲突行。
void | XmlReader.readXML(WebRowSet caller, Reader reader) 从给定的 XML 格式的输入流读取并解析给定的 WebRowSet 对象。
void | TransactionalWriter.rollback() 撤消在当前事务中进行的所有更改。
void | TransactionalWriter.rollback(Savepoint s) 撤消在给定 Savepoint 对象之前所进行的当前事务中的所有更改。
void | SyncResolver.setResolvedValue(int index, Object obj) 将 obj 设置为将同步的 RowSet 对象当前行中第 index 列的值。
void | SyncResolver.setResolvedValue(String columnName, Object obj) 将 obj 设置为将同步的 RowSet 对象当前行中列 columnName 的值。
void | XmlWriter.writeXML(WebRowSet caller, Writer writer) 将给定的 WebRowSet 对象以 XML 文档的形式编写到指定的 java.io.Writer 输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLFeatureNotSupportedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLFeatureNotSupportedException
的使用

没有 java.sql.SQLFeatureNotSupportedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.SQLInput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.SQLInput
的使用

使用 SQLInput 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 SQLInput 的使用

参数类型为 SQLInput 的 java.sql 中的方法
 void SQLData.readSQL(SQLInput stream, String typeName)
用从数据库读取的数据填充此对象。

javax.sql.rowset.serial 中 SQLInput 的使用

实现 SQLInput 的 javax.sql.rowset.serial 中的类
 class SQLInputImpl
用于自定义映射用户定义类型 (UDT) 的输入流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLIntegrityConstraintViolationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLIntegrityConstraintViolationException
的使用

没有 java.sql.SQLIntegrityConstraintViolationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLInvalidAuthorizationSpecException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLInvalidAuthorizationSpecException
的使用

没有 java.sql.SQLInvalidAuthorizationSpecException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLNonTransientConnectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLNonTransientConnectionException
的使用

没有 java.sql.SQLNonTransientConnectionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLNonTransientException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLNonTransientException
的使用

使用 SQLNonTransientException 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 SQLNonTransientException 的使用

java.sql 中 SQLNonTransientException 的子类
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.SQLOutput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.SQLOutput
的使用

使用 SQLOutput 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 SQLOutput 的使用

参数类型为 SQLOutput 的 java.sql 中的方法
 void SQLData.writeSQL(SQLOutput stream)
将此对象写入给定的 SQL 数据流，同时将其转换回数据源中它的 SQL 值。

javax.sql.rowset.serial 中 SQLOutput 的使用

实现 SQLOutput 的 javax.sql.rowset.serial 中的类
 class SQLOutputImpl
用于将自定义映射的用户定义类型 (UDT) 的属性写回数据库的输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLPermission
的使用

没有 java.sql.SQLPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLRecoverableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLRecoverableException
的使用

没有 java.sql.SQLRecoverableException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLSyntaxErrorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLSyntaxErrorException
的使用

没有 java.sql.SQLSyntaxErrorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLTimeoutException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLTimeoutException
的使用

没有 java.sql.SQLTimeoutException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLTransactionRollbackException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLTransactionRollbackException
的使用

没有 java.sql.SQLTransactionRollbackException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLTransientConnectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLTransientConnectionException
的使用

没有 java.sql.SQLTransientConnectionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLTransientException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLTransientException
的使用

使用 SQLTransientException 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 SQLTransientException 的使用

java.sql 中 SQLTransientException 的子类
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.SQLWarning 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLWarning
的使用

使用 SQLWarning 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 SQLWarning 的使用

java.sql 中 SQLWarning 的子类
 class DataTruncation
以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。

返回 SQLWarning 的 java.sql 中的方法
SQLWarning | SQLWarning.getNextWarning() 通过 setNextWarning 获取链接到此 SQLWarning 对象的警告。
SQLWarning | Connection.getWarnings() 获取此 Connection 对象上的调用报告的第一个警告。
SQLWarning | ResultSet.getWarnings() 获取此 ResultSet 对象上的调用报告的第一个警告。
SQLWarning | Statement.getWarnings() 获取此 Statement 对象上的调用报告的第一个警告。

参数类型为 SQLWarning 的 java.sql 中的方法
 void SQLWarning.setNextWarning(SQLWarning w)
将 SQLWarning 对象添加到链接的末尾。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.SQLXML 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.SQLXML
的使用

使用 SQLXML 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 SQLXML 的使用

返回 SQLXML 的 java.sql 中的方法
SQLXML | Connection.createSQLXML() 构造实现 SQLXML 接口的对象。
SQLXML | CallableStatement.getSQLXML(int parameterIndex) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
SQLXML | ResultSet.getSQLXML(int columnIndex) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
SQLXML | CallableStatement.getSQLXML(String parameterName) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
SQLXML | ResultSet.getSQLXML(String columnLabel) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
SQLXML | SQLInput.readSQLXML() 从流中读取一个 SQL XML 值，并以 Java 编程语言中 SQLXML 对象的形式返回。

参数类型为 SQLXML 的 java.sql 中的方法
void | PreparedStatement.setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | CallableStatement.setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | ResultSet.updateSQLXML(int columnIndex, SQLXML xmlObject) 用 java.sql.SQLXML 值更新指定列。
void | ResultSet.updateSQLXML(String columnLabel, SQLXML xmlObject) 用 java.sql.SQLXML 值更新指定的列。
void | SQLOutput.writeSQLXML(SQLXML x) 将 SQL XML 值写入流中。

javax.sql 中 SQLXML 的使用

参数类型为 SQLXML 的 javax.sql 中的方法
void | RowSet.setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | RowSet.setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定的 java.sql.SQLXML 对象。

javax.sql.rowset 中 SQLXML 的使用

参数类型为 SQLXML 的 javax.sql.rowset 中的方法
void | BaseRowSet.setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | BaseRowSet.setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定的 java.sql.SQLXML 对象。

javax.sql.rowset.serial 中 SQLXML 的使用

返回 SQLXML 的 javax.sql.rowset.serial 中的方法
 SQLXML SQLInputImpl.readSQLXML()
从流中读取 SQL XML 值并以 Java 编程语言中 SQLXML 对象的形式返回。

参数类型为 SQLXML 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeSQLXML(SQLXML x)
将 SQL XML 值写入流中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.Statement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Statement
的使用

使用 Statement 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 Statement 的使用

java.sql 中 Statement 的子接口
interface | CallableStatement 用于执行 SQL 存储过程的接口。
interface | PreparedStatement 表示预编译的 SQL 语句的对象。

返回 Statement 的 java.sql 中的方法
Statement | Connection.createStatement() 创建一个 Statement 对象来将 SQL 语句发送到数据库。
Statement | Connection.createStatement(int resultSetType, int resultSetConcurrency) 创建一个 Statement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
Statement | Connection.createStatement(int resultSetType, int resultSetConcurrency, int resultSetHoldability) 创建一个 Statement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
Statement | ResultSet.getStatement() 获取生成此 ResultSet 对象的 Statement 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.Struct 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Struct
的使用

使用 Struct 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Struct 的使用

返回 Struct 的 java.sql 中的方法
 Struct Connection.createStruct(String typeName, Object[] attributes)
创建 Struct 对象的工厂方法。

参数类型为 Struct 的 java.sql 中的方法
 void SQLOutput.writeStruct(Struct x)
将 SQL 结构类型值写入流中。

javax.sql.rowset.serial 中 Struct 的使用

实现 Struct 的 javax.sql.rowset.serial 中的类
 class SerialStruct
SQL 结构类型在 Java 编程语言中的序列化映射关系。

参数类型为 Struct 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeStruct(Struct x)
将 Java 编程语言中的 Struct 对象写入此 SQLOutputImpl 对象。

参数类型为 Struct 的 javax.sql.rowset.serial 中的构造方法
SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.Time 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.Time
的使用

使用 Time 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Time 的使用

返回 Time 的 java.sql 中的方法
Time | CallableStatement.getTime(int parameterIndex) 以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值。
Time | ResultSet.getTime(int columnIndex) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | CallableStatement.getTime(int parameterIndex, Calendar cal) 以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
Time | ResultSet.getTime(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | CallableStatement.getTime(String parameterName) 以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值。
Time | ResultSet.getTime(String columnLabel) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | CallableStatement.getTime(String parameterName, Calendar cal) 以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
Time | ResultSet.getTime(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | SQLInput.readTime() 读取流中的下一个属性并将其作为 java.sql.Time 对象返回。
static Time | Time.valueOf(String s) 将使用 JDBC 时间转义格式的字符串转换为 Time 值。

参数类型为 Time 的 java.sql 中的方法
void | PreparedStatement.setTime(int parameterIndex, Time x) 将指定参数设置为给定 java.sql.Time 值。
void | PreparedStatement.setTime(int parameterIndex, Time x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
void | CallableStatement.setTime(String parameterName, Time x) 将指定参数设置为给定 java.sql.Time 值。
void | CallableStatement.setTime(String parameterName, Time x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
void | ResultSet.updateTime(int columnIndex, Time x) 用 java.sql.Time 值更新指定列。
void | ResultSet.updateTime(String columnLabel, Time x) 用 java.sql.Time 值更新指定列。
void | SQLOutput.writeTime(Time x) 将下一个属性作为 java.sql.Time 对象写入流中。

javax.sql 中 Time 的使用

参数类型为 Time 的 javax.sql 中的方法
void | RowSet.setTime(int parameterIndex, Time x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTime(int parameterIndex, Time x, Calendar cal) 使用给定 java.sql.Time 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTime(String parameterName, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。

javax.sql.rowset 中 Time 的使用

参数类型为 Time 的 javax.sql.rowset 中的方法
void | BaseRowSet.setTime(int parameterIndex, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | BaseRowSet.setTime(int parameterIndex, Time x, Calendar cal) 将指定参数设置为给定的 java.sql.Time 对象。
void | BaseRowSet.setTime(String parameterName, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | BaseRowSet.setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。

javax.sql.rowset.serial 中 Time 的使用

返回 Time 的 javax.sql.rowset.serial 中的方法
 Time SQLInputImpl.readTime()
以 java.sql.Time 对象的形式获取此 SQLInputImpl 对象中的下一个属性。

参数类型为 Time 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeTime(Time x)
将 Java 编程语言中的 java.sql.Time 对象写入此 SQLOutputImpl 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.Timestamp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.Timestamp
的使用

使用 Timestamp 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Timestamp 的使用

返回 Timestamp 的 java.sql 中的方法
Timestamp | CallableStatement.getTimestamp(int parameterIndex) 以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值。
Timestamp | ResultSet.getTimestamp(int columnIndex) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | CallableStatement.getTimestamp(int parameterIndex, Calendar cal) 以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
Timestamp | ResultSet.getTimestamp(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | CallableStatement.getTimestamp(String parameterName) 以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值。
Timestamp | ResultSet.getTimestamp(String columnLabel) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | CallableStatement.getTimestamp(String parameterName, Calendar cal) 以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
Timestamp | ResultSet.getTimestamp(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | SQLInput.readTimestamp() 读取流中的下一个属性并将其作为 java.sql.Timestamp 对象返回。
static Timestamp | Timestamp.valueOf(String s) 将使用 JDBC 时间戳转义格式的 String 对象转换为 Timestamp 值。

参数类型为 Timestamp 的 java.sql 中的方法
boolean | Timestamp.after(Timestamp ts) 指示此 Timestamp 对象是否晚于给定的 Timestamp 对象。
boolean | Timestamp.before(Timestamp ts) 指示此 Timestamp 对象是否早于给定的 Timestamp 对象。
int | Timestamp.compareTo(Timestamp ts) 将此 Timestamp 对象与给定 Timestamp 对象相比较。
boolean | Timestamp.equals(Timestamp ts) 测试此 Timestamp 对象是否等于给定的 Timestamp 对象。
void | PreparedStatement.setTimestamp(int parameterIndex, Timestamp x) 将指定参数设置为给定 java.sql.Timestamp 值。
void | PreparedStatement.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
void | CallableStatement.setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定 java.sql.Timestamp 值。
void | CallableStatement.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
void | ResultSet.updateTimestamp(int columnIndex, Timestamp x) 用 java.sql.Timestamp 值更新指定列。
void | ResultSet.updateTimestamp(String columnLabel, Timestamp x) 用 java.sql.Timestamp 值更新指定列。
void | SQLOutput.writeTimestamp(Timestamp x) 将下一个属性作为 java.sql.Timestamp 对象写入流中。

javax.sql 中 Timestamp 的使用

参数类型为 Timestamp 的 javax.sql 中的方法
void | RowSet.setTimestamp(int parameterIndex, Timestamp x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Timestamp 值。
void | RowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定 java.sql.Timestamp 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | RowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

javax.sql.rowset 中 Timestamp 的使用

参数类型为 Timestamp 的 javax.sql.rowset 中的方法
void | BaseRowSet.setTimestamp(int parameterIndex, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | BaseRowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 将指定参数设置为给定的 java.sql.Timestamp 对象。
void | BaseRowSet.setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | BaseRowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

javax.sql.rowset.serial 中 Timestamp 的使用

返回 Timestamp 的 javax.sql.rowset.serial 中的方法
 Timestamp SQLInputImpl.readTimestamp()
以 java.sql.Timestamp 对象的形式获取此 SQLInputImpl 对象中的下一个属性。

参数类型为 Timestamp 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeTimestamp(Timestamp x)
将 Java 编程语言中的 java.sql.Timestamp 对象写入此 SQLOutputImpl 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.sql.Types 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.Types
的使用

没有 java.sql.Types 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.sql.Wrapper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Wrapper
的使用

使用 Wrapper 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.sql 中 Wrapper 的使用

java.sql 中 Wrapper 的子接口
interface | CallableStatement 用于执行 SQL 存储过程的接口。
interface | Connection 与特定数据库的连接（会话）。
interface | DatabaseMetaData 关于数据库的整体综合信息。
interface | ParameterMetaData 可用于获取关于 PreparedStatement 对象中每个参数标记的类型和属性信息的对象。
interface | PreparedStatement 表示预编译的 SQL 语句的对象。
interface | ResultSet 表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
interface | ResultSetMetaData 可用于获取关于 ResultSet 对象中列的类型和属性信息的对象。
interface | Statement 用于执行静态 SQL 语句并返回它所生成结果的对象。

javax.sql 中 Wrapper 的使用

javax.sql 中 Wrapper 的子接口
interface | DataSource 该工厂用于提供到此 DataSource 对象所表示的物理数据源的连接。
interface | RowSet 该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。
interface | RowSetMetaData 该对象包含关于 RowSet 对象的列的信息。

javax.sql.rowset 中 Wrapper 的使用

javax.sql.rowset 中 Wrapper 的子接口
interface | CachedRowSet 所有标准 CachedRowSet 实现都必须实现的接口。
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JdbcRowSet 所有标准 JdbcRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
interface | WebRowSet 所有 WebRowSet 的实现都必须实现的标准接口。

实现 Wrapper 的 javax.sql.rowset 中的类
 class RowSetMetaDataImpl
为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。

javax.sql.rowset.spi 中 Wrapper 的使用

javax.sql.rowset.spi 中 Wrapper 的子接口
 interface SyncResolver
定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.text (Java 2 Platform SE 6)

 java.text
接口
AttributedCharacterIterator
CharacterIterator
类
Annotation
AttributedCharacterIterator.Attribute
AttributedString
Bidi
BreakIterator
ChoiceFormat
CollationElementIterator
CollationKey
Collator
DateFormat
DateFormat.Field
DateFormatSymbols
DecimalFormat
DecimalFormatSymbols
FieldPosition
Format
Format.Field
MessageFormat
MessageFormat.Field
Normalizer
NumberFormat
NumberFormat.Field
ParsePosition
RuleBasedCollator
SimpleDateFormat
StringCharacterIterator
枚举
Normalizer.Form
异常
ParseException


类 java.text.Annotation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Annotation
的使用

没有 java.text.Annotation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.text.AttributedCharacterIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.text.AttributedCharacterIterator
的使用

使用 AttributedCharacterIterator 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 AttributedCharacterIterator 的使用

参数类型为 AttributedCharacterIterator 的 java.awt 中的方法
abstract void | Graphics2D.drawString(AttributedCharacterIterator iterator, float x, float y) 依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。
abstract void | Graphics2D.drawString(AttributedCharacterIterator iterator, int x, int y) 依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。
abstract void | Graphics.drawString(AttributedCharacterIterator iterator, int x, int y) 依据 TextAttribute 类的规范应用指定迭代器的属性，呈现迭代器的文本。

java.awt.event 中 AttributedCharacterIterator 的使用

返回 AttributedCharacterIterator 的 java.awt.event 中的方法
 AttributedCharacterIterator InputMethodEvent.getText()
获取已提交文本和撰写文本的组合。

参数类型为 AttributedCharacterIterator 的 java.awt.event 中的构造方法
InputMethodEvent(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、时间、文本、插入符和 visiblePosition 来构造 InputMethodEvent。

java.awt.font 中 AttributedCharacterIterator 的使用

参数类型为 AttributedCharacterIterator 的 java.awt.font 中的方法
void | LineBreakMeasurer.deleteChar(AttributedCharacterIterator newParagraph, int deletePos) 从文本删除单个字符之后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。
void | TextMeasurer.deleteChar(AttributedCharacterIterator newParagraph, int deletePos) 从当前由此 TextMeasurer 表示的段落中删除一个字符后，更新 TextMeasurer。
void | LineBreakMeasurer.insertChar(AttributedCharacterIterator newParagraph, int insertPos) 将单个字符插入文本后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。
void | TextMeasurer.insertChar(AttributedCharacterIterator newParagraph, int insertPos) 在将单个字符插入当前由此 TextMeasurer 表示的段落中后，更新该 TextMeasurer。

参数类型为 AttributedCharacterIterator 的 java.awt.font 中的构造方法
LineBreakMeasurer(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。
LineBreakMeasurer(AttributedCharacterIterator text, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。
TextLayout(AttributedCharacterIterator text, FontRenderContext frc)
根据样式文本上的迭代器构造一个 TextLayout。
TextMeasurer(AttributedCharacterIterator text, FontRenderContext frc)
从源文本构造 TextMeasurer。

java.awt.im 中 AttributedCharacterIterator 的使用

返回 AttributedCharacterIterator 的 java.awt.im 中的方法
AttributedCharacterIterator | InputMethodRequests.cancelLatestCommittedText(AttributedCharacterIterator.Attribute[] attributes) 从文本编辑组件中获取最新的提交文本，并将其从该组件的文本正文中移除。
AttributedCharacterIterator | InputMethodRequests.getCommittedText(int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes) 获取提供对文本编辑组件中包含的除未提交文本外整个文本和属性访问的迭代器。
AttributedCharacterIterator | InputMethodRequests.getSelectedText(AttributedCharacterIterator.Attribute[] attributes) 从文本编辑组件中获取当前已选定文本。

java.awt.im.spi 中 AttributedCharacterIterator 的使用

参数类型为 AttributedCharacterIterator 的 java.awt.im.spi 中的方法
 void InputMethodContext.dispatchInputMethodEvent(int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
根据给定的参数创建输入方法事件并将其指派到客户端组件。

java.text 中 AttributedCharacterIterator 的使用

返回 AttributedCharacterIterator 的 java.text 中的方法
AttributedCharacterIterator | DecimalFormat.formatToCharacterIterator(Object obj) 格式化一个 Object，以生成一个 AttributedCharacterIterator。
AttributedCharacterIterator | SimpleDateFormat.formatToCharacterIterator(Object obj) 格式化生成 AttributedCharacterIterator 的对象。
AttributedCharacterIterator | MessageFormat.formatToCharacterIterator(Object arguments) 格式化一个对象数组，并将它们插入 MessageFormat 的模式中，生成一个 AttributedCharacterIterator。
AttributedCharacterIterator | Format.formatToCharacterIterator(Object obj) 格式化一个对象，生成一个 AttributedCharacterIterator。
AttributedCharacterIterator | AttributedString.getIterator() 创建一个 AttributedCharacterIterator 实例，提供对整个字符串内容的访问。
AttributedCharacterIterator | AttributedString.getIterator(AttributedCharacterIterator.Attribute[] attributes) 创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
AttributedCharacterIterator | AttributedString.getIterator(AttributedCharacterIterator.Attribute[] attributes, int beginIndex, int endIndex) 创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。

参数类型为 AttributedCharacterIterator 的 java.text 中的构造方法
AttributedString(AttributedCharacterIterator text)
构造带有 AttributedCharacterIterator 表示的给定属性文本的 AttributedString。
AttributedString(AttributedCharacterIterator text, int beginIndex, int endIndex)
构造带有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。
AttributedString(AttributedCharacterIterator text, int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
构造具有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。
Bidi(AttributedCharacterIterator paragraph)
由给定的文本段构造 Bidi。

javax.swing 中 AttributedCharacterIterator 的使用

参数类型为 AttributedCharacterIterator 的 javax.swing 中的方法
 void DebugGraphics.drawString(AttributedCharacterIterator iterator, int x, int y)
重写 Graphics.drawString。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.AttributedCharacterIterator.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.AttributedCharacterIterator.Attribute
的使用

使用 AttributedCharacterIterator.Attribute 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.awt 中 AttributedCharacterIterator.Attribute 的使用

返回 AttributedCharacterIterator.Attribute 的 java.awt 中的方法
 AttributedCharacterIterator.Attribute[] Font.getAvailableAttributes()
返回由此 Font 支持的所有属性的键。

类型变量类型为 AttributedCharacterIterator.Attribute 的 java.awt 中的方法参数
Font | Font.deriveFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 通过复制当前 Font 对象并应用新的字体属性集，创建一个新 Font 对象。
static Font | Font.getFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 返回适合于这些属性的 Font。

类型变量类型为 AttributedCharacterIterator.Attribute 的 java.awt 中的构造方法参数
Font(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
创建一个具有指定属性的新 Font。

java.awt.font 中 AttributedCharacterIterator.Attribute 的使用

java.awt.font 中 AttributedCharacterIterator.Attribute 的子类
 class TextAttribute
TextAttribute 类定义用于呈现文本的属性键和属性值。

类型变量类型为 AttributedCharacterIterator.Attribute 的 java.awt.font 中的构造方法参数
TextLayout(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
根据 String 和属性集构造一个 TextLayout。

java.awt.im 中 AttributedCharacterIterator.Attribute 的使用

参数类型为 AttributedCharacterIterator.Attribute 的 java.awt.im 中的方法
AttributedCharacterIterator | InputMethodRequests.cancelLatestCommittedText(AttributedCharacterIterator.Attribute[] attributes) 从文本编辑组件中获取最新的提交文本，并将其从该组件的文本正文中移除。
AttributedCharacterIterator | InputMethodRequests.getCommittedText(int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes) 获取提供对文本编辑组件中包含的除未提交文本外整个文本和属性访问的迭代器。
AttributedCharacterIterator | InputMethodRequests.getSelectedText(AttributedCharacterIterator.Attribute[] attributes) 从文本编辑组件中获取当前已选定文本。

java.text 中 AttributedCharacterIterator.Attribute 的使用

java.text 中 AttributedCharacterIterator.Attribute 的子类
static class | DateFormat.Field 定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
static class | Format.Field 定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。
static class | MessageFormat.Field 在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
static class | NumberFormat.Field 定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。

声明为 AttributedCharacterIterator.Attribute 的 java.text 中的字段
static AttributedCharacterIterator.Attribute | AttributedCharacterIterator.Attribute.INPUT_METHOD_SEGMENT 输入法段的属性键。
static AttributedCharacterIterator.Attribute | AttributedCharacterIterator.Attribute.LANGUAGE 某些文本的语言的属性键。
static AttributedCharacterIterator.Attribute | AttributedCharacterIterator.Attribute.READING 某些文本的读法的属性键。

返回变量类型为 AttributedCharacterIterator.Attribute 的类型的 java.text 中的方法
Set<AttributedCharacterIterator.Attribute> | AttributedCharacterIterator.getAllAttributeKeys() 返回定义于迭代器文本范围上的所有属性的键。
Map<AttributedCharacterIterator.Attribute,Object> | AttributedCharacterIterator.getAttributes() 返回具有定义于当前字符上的多个属性的映射。

参数类型为 AttributedCharacterIterator.Attribute 的 java.text 中的方法
void | AttributedString.addAttribute(AttributedCharacterIterator.Attribute attribute, Object value) 将一个属性添加到整个字符串中。
void | AttributedString.addAttribute(AttributedCharacterIterator.Attribute attribute, Object value, int beginIndex, int endIndex) 将一个属性添加到字符串的子范围。
Object | AttributedCharacterIterator.getAttribute(AttributedCharacterIterator.Attribute attribute) 返回当前字符的命名属性的值。
AttributedCharacterIterator | AttributedString.getIterator(AttributedCharacterIterator.Attribute[] attributes) 创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
AttributedCharacterIterator | AttributedString.getIterator(AttributedCharacterIterator.Attribute[] attributes, int beginIndex, int endIndex) 创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
int | AttributedCharacterIterator.getRunLimit(AttributedCharacterIterator.Attribute attribute) 返回关于包含当前字符的给定属性的运行之后的第一个字符的索引。
int | AttributedCharacterIterator.getRunStart(AttributedCharacterIterator.Attribute attribute) 返回关于包含当前字符的给定属性的运行的第一个字符的索引。

类型变量类型为 AttributedCharacterIterator.Attribute 的 java.text 中的方法参数
void | AttributedString.addAttributes(Map<? extends AttributedCharacterIterator.Attribute,?> attributes, int beginIndex, int endIndex) 将属性集添加到字符串的子范围。
int | AttributedCharacterIterator.getRunLimit(Set<? extends AttributedCharacterIterator.Attribute> attributes) 返回关于包含当前字符的给定多个属性的运行之后的第一个字符的索引。
int | AttributedCharacterIterator.getRunStart(Set<? extends AttributedCharacterIterator.Attribute> attributes) 返回关于包含当前字符的给定多个属性的运行的第一个字符的索引。

参数类型为 AttributedCharacterIterator.Attribute 的 java.text 中的构造方法
AttributedString(AttributedCharacterIterator text, int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
构造具有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。

类型变量类型为 AttributedCharacterIterator.Attribute 的 java.text 中的构造方法参数
AttributedString(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
构造带给定文本和属性的 AttributedString。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.AttributedString 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.AttributedString
的使用

没有 java.text.AttributedString 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.Bidi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Bidi
的使用

使用 Bidi 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 Bidi 的使用

返回 Bidi 的 java.text 中的方法
 Bidi Bidi.createLineBidi(int lineStart, int lineLimit)
构造一个 Bidi 对象，表示当前 Bidi 所代表的段落中的一行文本上的双向信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.BreakIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.BreakIterator
的使用

使用 BreakIterator 的软件包
java.awt.font | 提供与字体相关的类和接口。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。

java.awt.font 中 BreakIterator 的使用

参数类型为 BreakIterator 的 java.awt.font 中的构造方法
LineBreakMeasurer(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。

java.text 中 BreakIterator 的使用

返回 BreakIterator 的 java.text 中的方法
static BreakIterator | BreakIterator.getCharacterInstance() 返回一个用于默认语言环境 字符分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getCharacterInstance(Locale locale) 返回一个用于给定语言环境字符分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getLineInstance() 返回一个用于默认语言环境 行分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getLineInstance(Locale locale) 返回一个用于给定语言环境行分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getSentenceInstance() 返回一个用于默认语言环境 句子分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getSentenceInstance(Locale locale) 返回一个用于给定语言环境句子分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getWordInstance() 返回一个用于默认语言环境 单词分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getWordInstance(Locale locale) 返回一个用于给定语言环境单词分解的新 BreakIterator 实例。

java.text.spi 中 BreakIterator 的使用

返回 BreakIterator 的 java.text.spi 中的方法
abstract BreakIterator | BreakIteratorProvider.getCharacterInstance(Locale locale) 为给定语言环境的字符分解返回新的 BreakIterator 实例。
abstract BreakIterator | BreakIteratorProvider.getLineInstance(Locale locale) 为给定语言环境的行分解返回新的 BreakIterator 实例。
abstract BreakIterator | BreakIteratorProvider.getSentenceInstance(Locale locale) 为给定语言环境的句子分解返回新的 BreakIterator 实例。
abstract BreakIterator | BreakIteratorProvider.getWordInstance(Locale locale) 为给定语言环境的单词分解返回一个新 BreakIterator 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.text.CharacterIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.text.CharacterIterator
的使用

使用 CharacterIterator 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 CharacterIterator 的使用

参数类型为 CharacterIterator 的 java.awt 中的方法
int | Font.canDisplayUpTo(CharacterIterator iter, int start, int limit) 指示此 Font 是否可以显示由 iter 指定的文本（从 start 开始至 limit 结束）。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, CharacterIterator ci) 根据此 Font 中的 Unicode cmap 将指定字符一一映射到字形，从而创建一个 GlyphVector。
LineMetrics | Font.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 CharacterIterator 的 LineMetrics 对象。
Rectangle2D | Font.getStringBounds(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的逻辑边界。
Rectangle2D | FontMetrics.getStringBounds(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回用指定 Graphics 上下文中指定 CharacterIterator 进行索引的字符的边界。

java.text 中 CharacterIterator 的使用

java.text 中 CharacterIterator 的子接口
 interface AttributedCharacterIterator
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。

实现 CharacterIterator 的 java.text 中的类
 class StringCharacterIterator
StringCharacterIterator 为 String 实现 CharacterIterater 协议。

返回 CharacterIterator 的 java.text 中的方法
abstract  CharacterIterator BreakIterator.getText()
获取被扫描的文本

参数类型为 CharacterIterator 的 java.text 中的方法
CollationElementIterator | RuleBasedCollator.getCollationElementIterator(CharacterIterator source) 返回给定 String 的 CollationElementIterator。
abstract void | BreakIterator.setText(CharacterIterator newText) 设置一个新文本用于扫描。
void | CollationElementIterator.setText(CharacterIterator source) 设置一个要迭代的新字符串。

javax.swing.text 中 CharacterIterator 的使用

实现 CharacterIterator 的 javax.swing.text 中的类
 class Segment
表示文本片段的字符数组的 segment。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.ChoiceFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.ChoiceFormat
的使用

没有 java.text.ChoiceFormat 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.CollationElementIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.CollationElementIterator
的使用

使用 CollationElementIterator 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 CollationElementIterator 的使用

返回 CollationElementIterator 的 java.text 中的方法
CollationElementIterator | RuleBasedCollator.getCollationElementIterator(CharacterIterator source) 返回给定 String 的 CollationElementIterator。
CollationElementIterator | RuleBasedCollator.getCollationElementIterator(String source) 返回给定 String 的 CollationElementIterator。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.CollationKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.CollationKey
的使用

使用 CollationKey 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 CollationKey 的使用

返回 CollationKey 的 java.text 中的方法
CollationKey | RuleBasedCollator.getCollationKey(String source) 将字符串转换为能够与 CollationKey.compareTo 进行比较的一系列字符。
abstract CollationKey | Collator.getCollationKey(String source) 将该 String 转换为一系列可以和其他 CollationKey 按位进行比较的位。

参数类型为 CollationKey 的 java.text 中的方法
abstract  int CollationKey.compareTo(CollationKey target)
比较此 CollationKey 与目标 CollationKey。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.Collator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Collator
的使用

使用 Collator 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。

java.text 中 Collator 的使用

java.text 中 Collator 的子类
 class RuleBasedCollator
RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。

返回 Collator 的 java.text 中的方法
static Collator | Collator.getInstance() 获取当前默认语言环境的 Collator。
static Collator | Collator.getInstance(Locale desiredLocale) 获取所需语言环境的 Collator。

java.text.spi 中 Collator 的使用

返回 Collator 的 java.text.spi 中的方法
abstract  Collator CollatorProvider.getInstance(Locale locale)
为指定语言环境返回新的 Collator 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.DateFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.DateFormat
的使用

使用 DateFormat 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.text 中 DateFormat 的使用

java.text 中 DateFormat 的子类
 class SimpleDateFormat
SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。

返回 DateFormat 的 java.text 中的方法
static DateFormat | DateFormat.getDateInstance() 获取日期格式器，该格式器具有默认语言环境的默认格式化风格。
static DateFormat | DateFormat.getDateInstance(int style) 获取日期格式器，该格式器具有默认语言环境的给定格式化风格。
static DateFormat | DateFormat.getDateInstance(int style, Locale aLocale) 获取日期格式器，该格式器具有给定语言环境的给定格式化风格。
static DateFormat | DateFormat.getDateTimeInstance() 获取日期/时间格式器，该格式器具有默认语言环境的默认格式化风格。
static DateFormat | DateFormat.getDateTimeInstance(int dateStyle, int timeStyle) 获取日期/时间格式器，该格式器具有默认语言环境的给定日期和时间格式化风格。
static DateFormat | DateFormat.getDateTimeInstance(int dateStyle, int timeStyle, Locale aLocale) 获取日期/时间格式器，该格式器具有给定语言环境的给定格式化风格。
static DateFormat | DateFormat.getInstance() 获取为日期和时间使用 SHORT 风格的默认日期/时间格式器。
static DateFormat | DateFormat.getTimeInstance() 获取时间格式器，该格式器具有默认语言环境的默认格式化风格。
static DateFormat | DateFormat.getTimeInstance(int style) 获取时间格式器，该格式器具有默认语言环境的给定格式化风格。
static DateFormat | DateFormat.getTimeInstance(int style, Locale aLocale) 获取时间格式器，该格式器具有给定语言环境的给定格式化风格。

java.text.spi 中 DateFormat 的使用

返回 DateFormat 的 java.text.spi 中的方法
abstract DateFormat | DateFormatProvider.getDateInstance(int style, Locale locale) 返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期。
abstract DateFormat | DateFormatProvider.getDateTimeInstance(int dateStyle, int timeStyle, Locale locale) 返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期和时间。
abstract DateFormat | DateFormatProvider.getTimeInstance(int style, Locale locale) 返回一个新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化时间。

javax.swing.text 中 DateFormat 的使用

参数类型为 DateFormat 的 javax.swing.text 中的方法
 void DateFormatter.setFormat(DateFormat format)
设置用于指示可编辑和显示的合法值的格式。

参数类型为 DateFormat 的 javax.swing.text 中的构造方法
DateFormatter(DateFormat format)
返回用指定的 Format 实例配置的 DateFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.DateFormat.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.DateFormat.Field
的使用

使用 DateFormat.Field 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 DateFormat.Field 的使用

声明为 DateFormat.Field 的 java.text 中的字段
static DateFormat.Field | DateFormat.Field.AM_PM 标识每日时间指示符（例如 "a.m." 或 "p.m."）的常量。
static DateFormat.Field | DateFormat.Field.DAY_OF_MONTH 标识 DAY_OF_MONTH 字段的常量。
static DateFormat.Field | DateFormat.Field.DAY_OF_WEEK 标识 DAY_OF_WEEK 字段的常量。
static DateFormat.Field | DateFormat.Field.DAY_OF_WEEK_IN_MONTH 标识 DAY_OF_WEEK_IN_MONTH 字段的常量。
static DateFormat.Field | DateFormat.Field.DAY_OF_YEAR 标识 DAY_OF_YEAR 字段的常量。
static DateFormat.Field | DateFormat.Field.ERA 标识 ERA 字段的常量。
static DateFormat.Field | DateFormat.Field.HOUR_OF_DAY0 标识 HOUR_OF_DAY0 字段的常量，其合法的值是 0 到 23。
static DateFormat.Field | DateFormat.Field.HOUR_OF_DAY1 标识 HOUR_OF_DAY1 字段的常量，其合法的值是 1 到 24。
static DateFormat.Field | DateFormat.Field.HOUR0 标识 HOUR0 字段的常量，其合法的值是 1 到 11。
static DateFormat.Field | DateFormat.Field.HOUR1 标识 HOUR1 字段的常量，其合法的值是 1 到 12。
static DateFormat.Field | DateFormat.Field.MILLISECOND 标识 MILLISECOND 字段的常量。
static DateFormat.Field | DateFormat.Field.MINUTE 标识 MINUTE 字段的常量。
static DateFormat.Field | DateFormat.Field.MONTH 标识 MONTH 字段的常量。
static DateFormat.Field | DateFormat.Field.SECOND 标识 SECOND 字段的常量。
static DateFormat.Field | DateFormat.Field.TIME_ZONE 标识 TIME_ZONE 字段的常量。
static DateFormat.Field | DateFormat.Field.WEEK_OF_MONTH 标识 WEEK_OF_MONTH 字段的常量。
static DateFormat.Field | DateFormat.Field.WEEK_OF_YEAR 标识 WEEK_OF_YEAR 字段的常量。
static DateFormat.Field | DateFormat.Field.YEAR 标识 YEAR 字段的常量。

返回 DateFormat.Field 的 java.text 中的方法
static DateFormat.Field DateFormat.Field.ofCalendarField(int calendarField)
返回与此 Calendar 常量 calendarField 对应的 Field 常量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.DateFormatSymbols 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.DateFormatSymbols
的使用

使用 DateFormatSymbols 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。

java.text 中 DateFormatSymbols 的使用

返回 DateFormatSymbols 的 java.text 中的方法
DateFormatSymbols | SimpleDateFormat.getDateFormatSymbols() 获取此日期格式的日期和时间格式符号的一个副本。
static DateFormatSymbols | DateFormatSymbols.getInstance() 获取默认语言环境的 DateFormatSymbols 实例。
static DateFormatSymbols | DateFormatSymbols.getInstance(Locale locale) 获取指定语言环境的 DateFormatSymbols 实例。

参数类型为 DateFormatSymbols 的 java.text 中的方法
 void SimpleDateFormat.setDateFormatSymbols(DateFormatSymbols newFormatSymbols)
设置此日期格式的日期和时间格式符号。

参数类型为 DateFormatSymbols 的 java.text 中的构造方法
SimpleDateFormat(String pattern, DateFormatSymbols formatSymbols)
用给定的模式和日期符号构造 SimpleDateFormat。

java.text.spi 中 DateFormatSymbols 的使用

返回 DateFormatSymbols 的 java.text.spi 中的方法
abstract  DateFormatSymbols DateFormatSymbolsProvider.getInstance(Locale locale)
为指定语言环境返回一个新的 DateFormatSymbols 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.DecimalFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.DecimalFormat
的使用

使用 DecimalFormat 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DecimalFormat 的使用

返回 DecimalFormat 的 javax.swing 中的方法
 DecimalFormat JSpinner.NumberEditor.getFormat()
返回 JFormattedTextField 用于分析和格式化数字的 java.text.DecimalFormat 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.DecimalFormatSymbols 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.DecimalFormatSymbols
的使用

使用 DecimalFormatSymbols 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。

java.text 中 DecimalFormatSymbols 的使用

返回 DecimalFormatSymbols 的 java.text 中的方法
DecimalFormatSymbols | DecimalFormat.getDecimalFormatSymbols() 返回小数格式符号的一个副本，通常程序员或用户不改变此副本。
static DecimalFormatSymbols | DecimalFormatSymbols.getInstance() 获取默认语言环境的 DecimalFormatSymbols 实例。
static DecimalFormatSymbols | DecimalFormatSymbols.getInstance(Locale locale) 获取指定语言环境的 DecimalFormatSymbols 实例。

参数类型为 DecimalFormatSymbols 的 java.text 中的方法
 void DecimalFormat.setDecimalFormatSymbols(DecimalFormatSymbols newSymbols)
设置小数格式符号，通常程序员或用户不改变此符号。

参数类型为 DecimalFormatSymbols 的 java.text 中的构造方法
DecimalFormat(String pattern, DecimalFormatSymbols symbols)
使用给定的模式和符号创建一个 DecimalFormat。

java.text.spi 中 DecimalFormatSymbols 的使用

返回 DecimalFormatSymbols 的 java.text.spi 中的方法
abstract  DecimalFormatSymbols DecimalFormatSymbolsProvider.getInstance(Locale locale)
为指定语言环境返回新的 DecimalFormatSymbols 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.FieldPosition 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.FieldPosition
的使用

使用 FieldPosition 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 FieldPosition 的使用

参数类型为 FieldPosition 的 java.text 中的方法
StringBuffer | SimpleDateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition pos) 将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
abstract StringBuffer | DateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition) 将一个 Date 格式化为日期/时间字符串。
StringBuffer | ChoiceFormat.format(double number, StringBuffer toAppendTo, FieldPosition status) 返回带已格式化 double 的模式。
StringBuffer | DecimalFormat.format(double number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 double 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(double number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | ChoiceFormat.format(long number, StringBuffer toAppendTo, FieldPosition status) 特殊格式。
StringBuffer | DecimalFormat.format(long number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 long 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(long number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | MessageFormat.format(Object[] arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
StringBuffer | DecimalFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数，并将所得文本追加到给定的字符串缓冲区。
StringBuffer | NumberFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数并将所得文本添加到给定字符串缓冲区。
StringBuffer | DateFormat.format(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition) 重写 Format。
StringBuffer | MessageFormat.format(Object arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
abstract StringBuffer | Format.format(Object obj, StringBuffer toAppendTo, FieldPosition pos) 格式化一个对象，并将得到的文本添加到给定的字符缓冲区。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.Format 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Format
的使用

使用 Format 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.text 中 Format 的使用

java.text 中 Format 的子类
class | ChoiceFormat ChoiceFormat 允许将格式应用到某个范围的数。
class | DateFormat DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
class | DecimalFormat DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。
class | MessageFormat MessageFormat 提供了以与语言无关方式生成连接消息的方式。
class | NumberFormat NumberFormat 是所有数值格式的抽象基类。
class | SimpleDateFormat SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。

返回 Format 的 java.text 中的方法
Format[] | MessageFormat.getFormats() 获取用于以前所设置的模式字符串中格式元素的格式。
Format[] | MessageFormat.getFormatsByArgumentIndex() 获取传递给 format 方法或从 parse 方法返回的值的格式。

参数类型为 Format 的 java.text 中的方法
void | MessageFormat.setFormat(int formatElementIndex, Format newFormat) 使用在以前设置的模式字符串中给定的格式元素索引来设置格式元素使用的格式。
void | MessageFormat.setFormatByArgumentIndex(int argumentIndex, Format newFormat) 设置用于以前所设置的模式字符串中格式元素的格式，其中以前的模式字符串是用给定的参数索引设置的。
void | MessageFormat.setFormats(Format[] newFormats) 设置用于以前所设置的模式字符串中格式元素的格式。
void | MessageFormat.setFormatsByArgumentIndex(Format[] newFormats) 设置传递给 format 方法或从 parse 方法返回的值使用的格式。

javax.swing 中 Format 的使用

参数类型为 Format 的 javax.swing 中的构造方法
JFormattedTextField(Format format)
创建一个 JFormattedTextField。

javax.swing.text 中 Format 的使用

返回 Format 的 javax.swing.text 中的方法
 Format InternationalFormatter.getFormat()
返回指示可以编辑和显示的合法值的格式。

参数类型为 Format 的 javax.swing.text 中的方法
void | InternationalFormatter.setFormat(Format format) 设置指示可以编辑和显示的合法值的格式。
void | NumberFormatter.setFormat(Format format) 设置指示可以编辑和显示的合法值的格式。

参数类型为 Format 的 javax.swing.text 中的构造方法
InternationalFormatter(Format format)
创建一个具有指定 Format 实例的 InternationalFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.Format.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Format.Field
的使用

使用 Format.Field 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.text 中 Format.Field 的使用

java.text 中 Format.Field 的子类
static class | DateFormat.Field 定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
static class | MessageFormat.Field 在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
static class | NumberFormat.Field 定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。

返回 Format.Field 的 java.text 中的方法
 Format.Field FieldPosition.getFieldAttribute()
以来自 Field 子类之一的属性常量返回该字段的标识符。

参数类型为 Format.Field 的 java.text 中的构造方法
FieldPosition(Format.Field attribute)
为给定的字段常量创建一个 FieldPosition 对象。
FieldPosition(Format.Field attribute, int fieldID)
为给定的字段创建一个 FieldPosition 对象。

javax.swing.text 中 Format.Field 的使用

返回 Format.Field 的 javax.swing.text 中的方法
 Format.Field[] InternationalFormatter.getFields(int offset)
返回与 offset 处的文本相关的 Format.Field 常量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.MessageFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.MessageFormat
的使用

使用 MessageFormat 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 MessageFormat 的使用

参数类型为 MessageFormat 的 javax.swing 中的方法
Printable | JTable.getPrintable(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 返回打印此 JTable 中所使用的 Printable。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，打印指定的标题和脚注文本。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。

javax.swing.text 中 MessageFormat 的使用

参数类型为 MessageFormat 的 javax.swing.text 中的方法
Printable | JTextComponent.getPrintable(MessageFormat headerFormat, MessageFormat footerFormat) 返回一个 Printable，用于打印此 JTextComponent 的内容。
boolean | JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，打印指定的标题和脚注文本。
boolean | JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive) 打印此 JTextComponent 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.MessageFormat.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.MessageFormat.Field
的使用

使用 MessageFormat.Field 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 MessageFormat.Field 的使用

声明为 MessageFormat.Field 的 java.text 中的字段
static MessageFormat.Field MessageFormat.Field.ARGUMENT
标识消息某一部分的常量，其中此消息是从传入 formatToCharacterIterator 的参数生成的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.Normalizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Normalizer
的使用

没有 java.text.Normalizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.Normalizer.Form 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Normalizer.Form
的使用

使用 Normalizer.Form 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 Normalizer.Form 的使用

返回 Normalizer.Form 的 java.text 中的方法
static Normalizer.Form | Normalizer.Form.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Normalizer.Form[] | Normalizer.Form.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Normalizer.Form 的 java.text 中的方法
static boolean | Normalizer.isNormalized(CharSequence src, Normalizer.Form form) 确定给定的 char 值序列是否被标准化。
static String | Normalizer.normalize(CharSequence src, Normalizer.Form form) 标准化 char 值序列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.NumberFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.NumberFormat
的使用

使用 NumberFormat 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.text 中 NumberFormat 的使用

java.text 中 NumberFormat 的子类
class | ChoiceFormat ChoiceFormat 允许将格式应用到某个范围的数。
class | DecimalFormat DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。

声明为 NumberFormat 的 java.text 中的字段
protected  NumberFormat DateFormat.numberFormat
数字格式器，DateFormat 用其来格式化日期和时间中的数字。

返回 NumberFormat 的 java.text 中的方法
static NumberFormat | NumberFormat.getCurrencyInstance() 返回当前默认语言环境的货币格式。
static NumberFormat | NumberFormat.getCurrencyInstance(Locale inLocale) 返回指定语言环境的货币格式。
static NumberFormat | NumberFormat.getInstance() 返回当前默认语言环境的通用数值格式。
static NumberFormat | NumberFormat.getInstance(Locale inLocale) 返回指定语言环境的通用数值格式。
static NumberFormat | NumberFormat.getIntegerInstance() 返回当前默认语言环境的整数格式。
static NumberFormat | NumberFormat.getIntegerInstance(Locale inLocale) 返回指定语言环境的整数格式。
NumberFormat | DateFormat.getNumberFormat() 获取此日期/时间格式器用于格式化和解析时间的数字格式器。
static NumberFormat | NumberFormat.getNumberInstance() 返回当前默认语言环境的通用数值格式。
static NumberFormat | NumberFormat.getNumberInstance(Locale inLocale) 返回指定语言环境的通用数值格式。
static NumberFormat | NumberFormat.getPercentInstance() 返回当前默认语言环境的百分比格式。
static NumberFormat | NumberFormat.getPercentInstance(Locale inLocale) 返回指定语言环境的百分比格式。

参数类型为 NumberFormat 的 java.text 中的方法
 void DateFormat.setNumberFormat(NumberFormat newNumberFormat)
允许用户设置数字格式器。

java.text.spi 中 NumberFormat 的使用

返回 NumberFormat 的 java.text.spi 中的方法
abstract NumberFormat | NumberFormatProvider.getCurrencyInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定的语言环境格式化货币价值。
abstract NumberFormat | NumberFormatProvider.getIntegerInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定的语言环境格式化整数值。
abstract NumberFormat | NumberFormatProvider.getNumberInstance(Locale locale) 为指定语言环境返回新的通用 NumberFormat 实例。
abstract NumberFormat | NumberFormatProvider.getPercentInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定语言环境格式化百分比值。

javax.swing.text 中 NumberFormat 的使用

参数类型为 NumberFormat 的 javax.swing.text 中的构造方法
NumberFormatter(NumberFormat format)
创建具有指定 Format 实例的 NumberFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.NumberFormat.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.NumberFormat.Field
的使用

使用 NumberFormat.Field 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 NumberFormat.Field 的使用

声明为 NumberFormat.Field 的 java.text 中的字段
static NumberFormat.Field | NumberFormat.Field.CURRENCY 标识货币字段的常量。
static NumberFormat.Field | NumberFormat.Field.DECIMAL_SEPARATOR 标识小数点字段的常量。
static NumberFormat.Field | NumberFormat.Field.EXPONENT 标识指数字段的常量。
static NumberFormat.Field | NumberFormat.Field.EXPONENT_SIGN 标识指数符号 (exponent sign) 字段的常量。
static NumberFormat.Field | NumberFormat.Field.EXPONENT_SYMBOL 标识指数符号 (exponent symbol) 字段的常量。
static NumberFormat.Field | NumberFormat.Field.FRACTION 标识小数字段的常量。
static NumberFormat.Field | NumberFormat.Field.GROUPING_SEPARATOR 标识组分隔符字段的常量。
static NumberFormat.Field | NumberFormat.Field.INTEGER 标识整数字段的常量。
static NumberFormat.Field | NumberFormat.Field.PERCENT 标识百分数字段的常量。
static NumberFormat.Field | NumberFormat.Field.PERMILLE 标识千分数字段的常量。
static NumberFormat.Field | NumberFormat.Field.SIGN 标识符号字段的常量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.ParseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.ParseException
的使用

使用 ParseException 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.text 中 ParseException 的使用

抛出 ParseException 的 java.text 中的方法
Number | NumberFormat.parse(String source) 解析给定字符串开头的文本，生成一个数值。
Date | DateFormat.parse(String source) 从给定字符串的开始解析文本，以生成一个日期。
Object[] | MessageFormat.parse(String source) 从给定字符串的开始位置解析文本，以生成一个对象数组。
Object | Format.parseObject(String source) 从给定字符串的开始处解析文本以生成一个对象。

抛出 ParseException 的 java.text 中的构造方法
RuleBasedCollator(String rules)
RuleBasedCollator 构造方法。

javax.swing 中 ParseException 的使用

抛出 ParseException 的 javax.swing 中的方法
void | JFormattedTextField.commitEdit() 强制从 AbstractFormatter 获得当前值并将其设置为当前值。
void | JSpinner.commitEdit() 将当前编辑的值提交给 SpinnerModel。
void | JSpinner.DefaultEditor.commitEdit() 将当前编辑值赋给 SpinnerModel。
abstract Object | JFormattedTextField.AbstractFormatter.stringToValue(String text) 分析 text，返回任意 Object。
abstract String | JFormattedTextField.AbstractFormatter.valueToString(Object value) 返回为 value 显示的 string 值。

javax.swing.plaf.synth 中 ParseException 的使用

抛出 ParseException 的 javax.swing.plaf.synth 中的方法
void | SynthLookAndFeel.load(InputStream input, Class<?> resourceBase) 加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。
void | SynthLookAndFeel.load(URL url) 加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。

javax.swing.text 中 ParseException 的使用

抛出 ParseException 的 javax.swing.text 中的方法
void | MaskFormatter.setMask(String mask) 设置指示合法字符的掩码。
Object | DefaultFormatter.stringToValue(String string) 通过使用带 String 参数的构造方法将传入的 String 转换为 getValueClass 的一个实例。
Object | InternationalFormatter.stringToValue(String text) 返回 String text 的 Object 表示形式。
Object | MaskFormatter.stringToValue(String value) 解析文本，返回 String value 的适当 Object 表示形式。
String | DefaultFormatter.valueToString(Object value) 使用 toString 方法将传入的 Object 转换为 String。
String | InternationalFormatter.valueToString(Object value) 返回 Object value 的 String 表示形式。
String | MaskFormatter.valueToString(Object value) 返回基于掩码的 Object value 的 String 表示形式。

抛出 ParseException 的 javax.swing.text 中的构造方法
MaskFormatter(String mask)
创建具有指定掩码的 MaskFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.ParsePosition 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.ParsePosition
的使用

使用 ParsePosition 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 ParsePosition 的使用

参数类型为 ParsePosition 的 java.text 中的方法
Number | ChoiceFormat.parse(String text, ParsePosition status) 解析输入文本中的一个 Number。
Number | DecimalFormat.parse(String text, ParsePosition pos) 解析字符串中的文本，以生成一个 Number。
abstract Number | NumberFormat.parse(String source, ParsePosition parsePosition) 如果可能则返回 Long （例如，在 [Long.MIN_VALUE, Long.MAX_VALUE] 范围内且没有小数），否则返回 Double。
Date | SimpleDateFormat.parse(String text, ParsePosition pos) 解析字符串的文本，生成 Date。
abstract Date | DateFormat.parse(String source, ParsePosition pos) 根据给定的解析位置开始解析日期/时间字符串。
Object[] | MessageFormat.parse(String source, ParsePosition pos) 解析字符串。
Object | NumberFormat.parseObject(String source, ParsePosition pos) 解析字符串中的文本，以生成一个 Number。
Object | DateFormat.parseObject(String source, ParsePosition pos) 解析字符串中的文本，以生成一个 Date。
Object | MessageFormat.parseObject(String source, ParsePosition pos) 解析字符串文本，生成一个对象数组。
abstract Object | Format.parseObject(String source, ParsePosition pos) 解析字符串文本，生成一个对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.RuleBasedCollator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.RuleBasedCollator
的使用

没有 java.text.RuleBasedCollator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.SimpleDateFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.SimpleDateFormat
的使用

使用 SimpleDateFormat 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SimpleDateFormat 的使用

返回 SimpleDateFormat 的 javax.swing 中的方法
 SimpleDateFormat JSpinner.DateEditor.getFormat()
返回 JFormattedTextField 用于分析和格式化数字的 java.text.SimpleDateFormat 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.StringCharacterIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.StringCharacterIterator
的使用

没有 java.text.StringCharacterIterator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.text.spi (Java 2 Platform SE 6)

 java.text.spi
类
BreakIteratorProvider
CollatorProvider
DateFormatProvider
DateFormatSymbolsProvider
DecimalFormatSymbolsProvider
NumberFormatProvider


类 java.text.spi.BreakIteratorProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.BreakIteratorProvider
的使用

没有 java.text.spi.BreakIteratorProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.spi.CollatorProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.CollatorProvider
的使用

没有 java.text.spi.CollatorProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.spi.DateFormatProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.DateFormatProvider
的使用

没有 java.text.spi.DateFormatProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.spi.DateFormatSymbolsProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.DateFormatSymbolsProvider
的使用

没有 java.text.spi.DateFormatSymbolsProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.spi.DecimalFormatSymbolsProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.DecimalFormatSymbolsProvider
的使用

没有 java.text.spi.DecimalFormatSymbolsProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.text.spi.NumberFormatProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.NumberFormatProvider
的使用

没有 java.text.spi.NumberFormatProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


AbstractMap.SimpleEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 AbstractMap.SimpleEntry<K,V>

java.lang.Object
    继承者  java.util.AbstractMap.SimpleEntry<K,V>
所有已实现的接口：
Serializable, Map.Entry<K,V>
正在封闭类：
AbstractMap<K,V>
public static class AbstractMap.SimpleEntry<K,V>
extends Object
implements Map.Entry<K,V>, Serializable

维护键和值的 Entry。可以使用 setValue 方法更改值。此类简化了构建自定义映射实现的过程。例如，可以使用 Map.entrySet().toArray 方法方便地返回 SimpleEntry 实例数组。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
AbstractMap.SimpleEntry(K key, V value)
创建一个项，它表示从指定键到指定值的映射关系。
AbstractMap.SimpleEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定的项相同。
方法摘要
boolean | equals(Object o) 比较指定对象与此项的相等性。
K | getKey() 返回对应于此项的键。
V | getValue() 返回对应于此项的值。
int | hashCode() 返回此映射项的哈希码值。
V | setValue(V value) 用指定值替换对应于此项的值。
String | toString() 返回此映射项的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractMap.SimpleEntry

public AbstractMap.SimpleEntry(K key,
                               V value)
创建一个项，它表示从指定键到指定值的映射关系。

参数：
key - 此项所表示的键
value - 此项所表示的值

AbstractMap.SimpleEntry

public AbstractMap.SimpleEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定的项相同。

参数：
entry - 要复制的项
方法详细信息

getKey

public K getKey()
返回对应于此项的键。

指定者：
接口 Map.Entry<K,V> 中的 getKey
返回：
对应于此项的键

getValue

public V getValue()
返回对应于此项的值。

指定者：
接口 Map.Entry<K,V> 中的 getValue
返回：
对应于此项的值

setValue

public V setValue(V value)
用指定值替换对应于此项的值。

指定者：
接口 Map.Entry<K,V> 中的 setValue
参数：
value - 要在此项中存储的新值
返回：
对应于此项的旧值

equals

public boolean equals(Object o)
比较指定对象与此项的相等性。如果给定对象也是一个映射项，并且两个项表示的映射关系相同，则返回 true。 更确切地讲，如果满足以下条件，则两个项 e1 和 e2 表示的映射关系相同：
(e1.getKey()==null ?
e2.getKey()==null :
e1.getKey().equals(e2.getKey()))
   &&
(e1.getValue()==null ?
e2.getValue()==null :
e1.getValue().equals(e2.getValue()))
这确保 equals 方法可在 Map.Entry 接口的不同实现之间正常工作。

指定者：
接口 Map.Entry<K,V> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 将与此映射项进行相等性比较的对象
返回：
如果指定的对象等于此映射项，则返回 true
另请参见：
hashCode()

hashCode

public int hashCode()
返回此映射项的哈希码值。映射项 e 的哈希码值定义如下：
(e.getKey()==null   ?0 : e.getKey().hashCode()) ^
(e.getValue()==null ?0 : e.getValue().hashCode())
这确保 e1.equals(e2) 意味着对于任意两个项 e1 和 e2 而言，都存在 e1.hashCode()==e2.hashCode()，正如 Object.hashCode() 常规协定所要求的那样。

指定者：
接口 Map.Entry<K,V> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此映射项的哈希码值
另请参见：
equals(java.lang.Object)

toString

public String toString()
返回此映射项的 String 表示形式。此实现返回此项的键的字符串表示形式，后跟等号 ("=")，然后是此项的值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此映射项的 String 表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractMap.SimpleImmutableEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 AbstractMap.SimpleImmutableEntry<K,V>

java.lang.Object
    继承者  java.util.AbstractMap.SimpleImmutableEntry<K,V>
所有已实现的接口：
Serializable, Map.Entry<K,V>
正在封闭类：
AbstractMap<K,V>
public static class AbstractMap.SimpleImmutableEntry<K,V>
extends Object
implements Map.Entry<K,V>, Serializable

维护不可变的键和值的 Entry。此类不支持 setValue 方法。在返回线程安全的键-值映射关系快照的方法中，此类也许很方便。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
AbstractMap.SimpleImmutableEntry(K key, V value)
创建一个项，它表示从指定键到指定值的映射关系。
AbstractMap.SimpleImmutableEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定项相同。
方法摘要
boolean | equals(Object o) 比较指定对象与此项的相等性。
K | getKey() 返回对应于此项的键。
V | getValue() 返回对应于此项的值。
int | hashCode() 返回此映射项的哈希码值。
V | setValue(V value) 用指定值替换对应于此项的值（可选操作）。
String | toString() 返回此映射项的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractMap.SimpleImmutableEntry

public AbstractMap.SimpleImmutableEntry(K key,
                                        V value)
创建一个项，它表示从指定键到指定值的映射关系。

参数：
key - 此项所表示的键
value - 此项所表示的值

AbstractMap.SimpleImmutableEntry

public AbstractMap.SimpleImmutableEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定项相同。

参数：
entry - 要复制的项
方法详细信息

getKey

public K getKey()
返回对应于此项的键。

指定者：
接口 Map.Entry<K,V> 中的 getKey
返回：
对应于此项的键

getValue

public V getValue()
返回对应于此项的值。

指定者：
接口 Map.Entry<K,V> 中的 getValue
返回：
对应于此项的值

setValue

public V setValue(V value)
用指定值替换对应于此项的值（可选操作）。此类实现一个不可变的 映射项，所以此实现抛出 UnsupportedOperationException。

指定者：
接口 Map.Entry<K,V> 中的 setValue
参数：
value - 要在此项中存储的新值
返回：
与此项对应的旧值
抛出：
UnsupportedOperationException - 始终抛出

equals

public boolean equals(Object o)
比较指定对象与此项的相等性。如果给定对象也是一个映射项，并且两个项表示的映射关系相同，则返回 true。 更确切地讲，如果满足以下条件，则两个项 e1 和 e2 表示的映射关系相同：
(e1.getKey()==null ?
e2.getKey()==null :
e1.getKey().equals(e2.getKey()))
   &&
(e1.getValue()==null ?
e2.getValue()==null :
e1.getValue().equals(e2.getValue()))
这确保 equals 方法可在 Map.Entry 接口的不同实现之间正常工作。

指定者：
接口 Map.Entry<K,V> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 将与此映射项进行相等性比较的对象
返回：
如果指定的对象等于此映射项，则返回 true
另请参见：
hashCode()

hashCode

public int hashCode()
返回此映射项的哈希码值。映射项 e 的哈希码值定义如下：
(e.getKey()==null   ?0 : e.getKey().hashCode()) ^
(e.getValue()==null ?0 : e.getValue().hashCode())
这确保 e1.equals(e2) 意味着对于任意两个项 e1 和 e2 而言，都存在 e1.hashCode()==e2.hashCode()，正如 Object.hashCode() 常规协定所要求的那样。

指定者：
接口 Map.Entry<K,V> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此映射项的哈希码值
另请参见：
equals(java.lang.Object)

toString

public String toString()
返回此映射项的 String 表示形式。此实现返回此项的键的字符串表示形式，后跟等号 ("=")，然后是此项的值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此映射项的 String 表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Map.Entry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Map.Entry<K,V>

所有已知实现类：
AbstractMap.SimpleEntry, AbstractMap.SimpleImmutableEntry
正在封闭接口：
Map<K,V>
public static interface Map.Entry<K,V>

映射项（键-值对）。Map.entrySet 方法返回映射的 collection 视图，其中的元素属于此类。获得映射项引用的唯一 方法是通过此 collection 视图的迭代器来实现。这些 Map.Entry 对象仅 在迭代期间有效；更确切地讲，如果在迭代器返回项之后修改了底层映射，则某些映射项的行为是不确定的，除了通过 setValue 在映射项上执行操作之外。

从以下版本开始：
1.2
另请参见：
Map.entrySet()

方法摘要
boolean | equals(Object o) 比较指定对象与此项的相等性。
K | getKey() 返回与此项对应的键。
V | getValue() 返回与此项对应的值。
int | hashCode() 返回此映射项的哈希码值。
V | setValue(V value) 用指定的值替换与此项对应的值（可选操作）。

方法详细信息

getKey

K getKey()
返回与此项对应的键。

返回：
与此项对应的键
抛出：
IllegalStateException - 如果已经从底层映射中移除了该项，则实现可能（但不要求）抛出此异常。

getValue

V getValue()
返回与此项对应的值。如果已经从底层映射中移除了映射关系（通过迭代器的 remove 操作），则此调用的结果是不确定的。

返回：
与此项对应的值
抛出：
IllegalStateException - 如果已经从底层映射中移除了该项，则实现可能，但不要求，抛出此异常。

setValue

V setValue(V value)
用指定的值替换与此项对应的值（可选操作）。（写入该映射。）如果已经从映射中移除了映射关系（通过迭代器的 remove 操作），则此调用的行为是不确定的。

参数：
value - 要存储在此项中的新值
返回：
与此项对应的旧值
抛出：
UnsupportedOperationException - 如果底层映射不支持 put 操作
ClassCastException - 如果指定值的类不允许将该值存储在底层映射中
NullPointerException - 如果底层映射不允许 null 值，并且指定的值为 null
IllegalArgumentException - 如果此值的某些方面不允许将其存储在底层映射中
IllegalStateException - 如果已经从底层映射中移除了该项，则实现可能，但不要求，抛出此异常

equals

boolean equals(Object o)
比较指定对象与此项的相等性。如果给定对象也是一个映射项，并且两个项表示相同的映射关系，则返回 true。更确切地讲，如果满足以下条件，则两个项 e1 和 e2 才表示相同的映射关系
     (e1.getKey()==null ?
      e2.getKey()==null : e1.getKey().equals(e2.getKey()))  &&
     (e1.getValue()==null ?
      e2.getValue()==null : e1.getValue().equals(e2.getValue()))
这可以确保 equals 方法在不同的 Map.Entry 接口实现间可正确地工作。

覆盖：
类 Object 中的 equals
参数：
o - 要与此映射项进行相等性比较的对象
返回：
如果指定的对象等于此映射项，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此映射项的哈希码值。映射项 e 的哈希码定义如下：
     (e.getKey()==null   ? 0 : e.getKey().hashCode()) ^
     (e.getValue()==null ? 0 : e.getValue().hashCode())
这确保 e1.equals(e2) 意味着对于任意两个项 e1 和 e2 而言，e1.hashCode()==e2.hashCode()，这正是 Object.hashCode 的常规协定所要求的。

覆盖：
类 Object 中的 hashCode
返回：
映射项的哈希码值
另请参见：
Object.hashCode(),
Object.equals(Object),
equals(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


java.util (Java 2 Platform SE 6)

 java.util
接口
Collection
Comparator
Deque
Enumeration
EventListener
Formattable
Iterator
List
ListIterator
Map
Map.Entry
NavigableMap
NavigableSet
Observer
Queue
RandomAccess
Set
SortedMap
SortedSet
类
AbstractCollection
AbstractList
AbstractMap
AbstractMap.SimpleEntry
AbstractMap.SimpleImmutableEntry
AbstractQueue
AbstractSequentialList
AbstractSet
ArrayDeque
ArrayList
Arrays
BitSet
Calendar
Collections
Currency
Date
Dictionary
EnumMap
EnumSet
EventListenerProxy
EventObject
FormattableFlags
Formatter
GregorianCalendar
HashMap
HashSet
Hashtable
IdentityHashMap
LinkedHashMap
LinkedHashSet
LinkedList
ListResourceBundle
Locale
Observable
PriorityQueue
Properties
PropertyPermission
PropertyResourceBundle
Random
ResourceBundle
ResourceBundle.Control
Scanner
ServiceLoader
SimpleTimeZone
Stack
StringTokenizer
Timer
TimerTask
TimeZone
TreeMap
TreeSet
UUID
Vector
WeakHashMap
枚举
Formatter.BigDecimalLayoutForm
异常
ConcurrentModificationException
DuplicateFormatFlagsException
EmptyStackException
FormatFlagsConversionMismatchException
FormatterClosedException
IllegalFormatCodePointException
IllegalFormatConversionException
IllegalFormatException
IllegalFormatFlagsException
IllegalFormatPrecisionException
IllegalFormatWidthException
InputMismatchException
InvalidPropertiesFormatException
MissingFormatArgumentException
MissingFormatWidthException
MissingResourceException
NoSuchElementException
TooManyListenersException
UnknownFormatConversionException
UnknownFormatFlagsException
错误
ServiceConfigurationError


类 java.util.AbstractCollection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractCollection
的使用

使用 AbstractCollection 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

java.util 中 AbstractCollection 的使用

java.util 中 AbstractCollection 的子类
class | AbstractList<E> 此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
class | AbstractQueue<E> 此类提供某些 Queue 操作的骨干实现。
class | AbstractSequentialList<E> 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
class | AbstractSet<E> 此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | LinkedList<E> List 接口的链接列表实现。
class | PriorityQueue<E> 一个基于优先级堆的无界优先级队列。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。
class | Vector<E> Vector 类可以实现可增长的对象数组。

java.util.concurrent 中 AbstractCollection 的使用

java.util.concurrent 中 AbstractCollection 的子类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

javax.management 中 AbstractCollection 的使用

javax.management 中 AbstractCollection 的子类
 class AttributeList
表示 MBean 属性值的列表。

javax.management.relation 中 AbstractCollection 的使用

javax.management.relation 中 AbstractCollection 的子类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

javax.print.attribute.standard 中 AbstractCollection 的使用

javax.print.attribute.standard 中 AbstractCollection 的子类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.AbstractList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractList
的使用

使用 AbstractList 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。

java.util 中 AbstractList 的使用

java.util 中 AbstractList 的子类
class | AbstractSequentialList<E> 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | LinkedList<E> List 接口的链接列表实现。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | Vector<E> Vector 类可以实现可增长的对象数组。

javax.management 中 AbstractList 的使用

javax.management 中 AbstractList 的子类
 class AttributeList
表示 MBean 属性值的列表。

javax.management.relation 中 AbstractList 的使用

javax.management.relation 中 AbstractList 的子类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.AbstractMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractMap
的使用

使用 AbstractMap 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

java.util 中 AbstractMap 的使用

java.util 中 AbstractMap 的子类
class | EnumMap<K extends Enum<K>,V> 与枚举类型键一起使用的专用 Map 实现。
class | HashMap<K,V> 基于哈希表的 Map 接口的实现。
class | IdentityHashMap<K,V> 此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
class | LinkedHashMap<K,V> Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
class | TreeMap<K,V> 基于红黑树（Red-Black tree）的 NavigableMap 实现。
class | WeakHashMap<K,V> 以弱键 实现的基于哈希表的 Map。

java.util.concurrent 中 AbstractMap 的使用

java.util.concurrent 中 AbstractMap 的子类
class | ConcurrentHashMap<K,V> 支持获取的完全并发和更新的所期望可调整并发的哈希表。
class | ConcurrentSkipListMap<K,V> 可缩放的并发 ConcurrentNavigableMap 实现。

javax.print.attribute.standard 中 AbstractMap 的使用

javax.print.attribute.standard 中 AbstractMap 的子类
 class PrinterStateReasons
PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.AbstractMap.SimpleEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractMap.SimpleEntry
的使用

没有 java.util.AbstractMap.SimpleEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.AbstractMap.SimpleImmutableEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractMap.SimpleImmutableEntry
的使用

没有 java.util.AbstractMap.SimpleImmutableEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.AbstractQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractQueue
的使用

使用 AbstractQueue 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 AbstractQueue 的使用

java.util 中 AbstractQueue 的子类
 class PriorityQueue<E>
一个基于优先级堆的无界优先级队列。

java.util.concurrent 中 AbstractQueue 的使用

java.util.concurrent 中 AbstractQueue 的子类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.AbstractSequentialList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractSequentialList
的使用

使用 AbstractSequentialList 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 AbstractSequentialList 的使用

java.util 中 AbstractSequentialList 的子类
 class LinkedList<E>
List 接口的链接列表实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.AbstractSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractSet
的使用

使用 AbstractSet 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

java.util 中 AbstractSet 的使用

java.util 中 AbstractSet 的子类
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。

java.util.concurrent 中 AbstractSet 的使用

java.util.concurrent 中 AbstractSet 的子类
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。

javax.print.attribute.standard 中 AbstractSet 的使用

javax.print.attribute.standard 中 AbstractSet 的子类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.ArrayDeque 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ArrayDeque
的使用

使用 ArrayDeque 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 ArrayDeque 的使用

返回 ArrayDeque 的 java.util 中的方法
 ArrayDeque<E> ArrayDeque.clone()
返回此双端队列的副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.ArrayList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ArrayList
的使用

使用 ArrayList 的软件包
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。

java.awt.dnd 中 ArrayList 的使用

声明为 ArrayList 的 java.awt.dnd 中的字段
protected  ArrayList<InputEvent> DragGestureRecognizer.events
DragGestureRecognizer“识别”为触发拖动的“动作”事件列表（按顺序）。

java.beans.beancontext 中 ArrayList 的使用

声明为 ArrayList 的 java.beans.beancontext 中的字段
protected ArrayList | BeanContextSupport.bcmListeners protected ArrayList bcmListeners 字段的所有访问在该对象上都将是同步的。
protected ArrayList | BeanContextServicesSupport.bcsListeners BeanContextServicesListener 对象的列表。

java.util 中 ArrayList 的使用

返回 ArrayList 的 java.util 中的方法
static
<T> ArrayList<T>
Collections.list(Enumeration<T> e)
返回一个数组列表，它按返回顺序包含指定枚举返回的元素。

javax.management 中 ArrayList 的使用

javax.management 中 ArrayList 的子类
 class AttributeList
表示 MBean 属性值的列表。

返回 ArrayList 的 javax.management 中的方法
static ArrayList<MBeanServer> MBeanServerFactory.findMBeanServer(String agentId)
返回已注册 MBeanServer 对象的列表。

javax.management.relation 中 ArrayList 的使用

javax.management.relation 中 ArrayList 的子类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Arrays 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Arrays
的使用

没有 java.util.Arrays 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.BitSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.BitSet
的使用

使用 BitSet 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

java.util 中 BitSet 的使用

返回 BitSet 的 java.util 中的方法
 BitSet BitSet.get(int fromIndex, int toIndex)
返回一个新的 BitSet，它由此 BitSet 中从 fromIndex（包括）到 toIndex（不包括）范围内的位组成。

参数类型为 BitSet 的 java.util 中的方法
void | BitSet.and(BitSet set) 对此目标位 set 和参数位 set 执行逻辑与操作。
void | BitSet.andNot(BitSet set) 清除此 BitSet 中所有的位，其相应的位在指定的 BitSet 中已设置。
boolean | BitSet.intersects(BitSet set) 如果指定的 BitSet 中有设置为 true 的位，并且在此 BitSet 中也将其设置为 true，则返回 ture。
void | BitSet.or(BitSet set) 对此位 set 和位 set 参数执行逻辑或操作。
void | BitSet.xor(BitSet set) 对此位 set 和位 set 参数执行逻辑异或操作。

javax.swing.text.html.parser 中 BitSet 的使用

声明为 BitSet 的 javax.swing.text.html.parser 中的字段
BitSet | Element.exclusions
BitSet | Element.inclusions

参数类型为 BitSet 的 javax.swing.text.html.parser 中的方法
 Element DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
返回与指定参数匹配的 Element。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Calendar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Calendar
的使用

使用 Calendar 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.datatype | XML/Java 类型映射关系。

java.sql 中 Calendar 的使用

参数类型为 Calendar 的 java.sql 中的方法
Date | CallableStatement.getDate(int parameterIndex, Calendar cal) 以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
Date | ResultSet.getDate(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | CallableStatement.getDate(String parameterName, Calendar cal) 以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
Date | ResultSet.getDate(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | CallableStatement.getTime(int parameterIndex, Calendar cal) 以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
Time | ResultSet.getTime(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | CallableStatement.getTime(String parameterName, Calendar cal) 以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
Time | ResultSet.getTime(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | CallableStatement.getTimestamp(int parameterIndex, Calendar cal) 以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
Timestamp | ResultSet.getTimestamp(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | CallableStatement.getTimestamp(String parameterName, Calendar cal) 以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
Timestamp | ResultSet.getTimestamp(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
void | PreparedStatement.setDate(int parameterIndex, Date x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
void | CallableStatement.setDate(String parameterName, Date x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
void | PreparedStatement.setTime(int parameterIndex, Time x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
void | CallableStatement.setTime(String parameterName, Time x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
void | PreparedStatement.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
void | CallableStatement.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。

java.text 中 Calendar 的使用

声明为 Calendar 的 java.text 中的字段
protected  Calendar DateFormat.calendar
DateFormat 使用 calendar 来生成实现日期和时间格式化所需的时间字段值。

返回 Calendar 的 java.text 中的方法
 Calendar DateFormat.getCalendar()
获取与此日期/时间格式器关联的日历。

参数类型为 Calendar 的 java.text 中的方法
 void DateFormat.setCalendar(Calendar newCalendar)
设置此日期格式所使用的日历。

java.util 中 Calendar 的使用

java.util 中 Calendar 的子类
 class GregorianCalendar
GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。

返回 Calendar 的 java.util 中的方法
static Calendar | Calendar.getInstance() 使用默认时区和语言环境获得一个日历。
static Calendar | Calendar.getInstance(Locale aLocale) 使用默认时区和指定语言环境获得一个日历。
static Calendar | Calendar.getInstance(TimeZone zone) 使用指定时区和默认语言环境获得一个日历。
static Calendar | Calendar.getInstance(TimeZone zone, Locale aLocale) 使用指定时区和语言环境获得一个日历。

参数类型为 Calendar 的 java.util 中的方法
 int Calendar.compareTo(Calendar anotherCalendar)
比较两个 Calendar 对象表示的时间值（从历元至现在的毫秒偏移量）。

javax.sql 中 Calendar 的使用

参数类型为 Calendar 的 javax.sql 中的方法
void | RowSet.setDate(int parameterIndex, Date x, Calendar cal) 使用给定 java.sql.Date 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setTime(int parameterIndex, Time x, Calendar cal) 使用给定 java.sql.Time 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定 java.sql.Timestamp 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

javax.sql.rowset 中 Calendar 的使用

参数类型为 Calendar 的 javax.sql.rowset 中的方法
void | BaseRowSet.setDate(int parameterIndex, Date x, Calendar cal) 将指定参数设置为给定的 java.sql.Date 对象。
void | BaseRowSet.setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
void | BaseRowSet.setTime(int parameterIndex, Time x, Calendar cal) 将指定参数设置为给定的 java.sql.Time 对象。
void | BaseRowSet.setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
void | BaseRowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 将指定参数设置为给定的 java.sql.Timestamp 对象。
void | BaseRowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

javax.xml.bind 中 Calendar 的使用

返回 Calendar 的 javax.xml.bind 中的方法
static Calendar | DatatypeConverter.parseDate(String lexicalXSDDate) 将字符串参数转换为一个 Calendar 值。
Calendar | DatatypeConverterInterface.parseDate(String lexicalXSDDate) 将字符串参数转换为一个 Calendar 值。
static Calendar | DatatypeConverter.parseDateTime(String lexicalXSDDateTime) 将字符串参数转换为一个 Calendar 值。
Calendar | DatatypeConverterInterface.parseDateTime(String lexicalXSDDateTime) 将字符串参数转换为一个 Calendar 值。
static Calendar | DatatypeConverter.parseTime(String lexicalXSDTime) 将字符串参数转换为一个 Calendar 值。
Calendar | DatatypeConverterInterface.parseTime(String lexicalXSDTime) 将字符串参数转换为一个 Calendar 值。

参数类型为 Calendar 的 javax.xml.bind 中的方法
static String | DatatypeConverter.printDate(Calendar val) 将 Calendar 值转换为一个字符串。
String | DatatypeConverterInterface.printDate(Calendar val) 将 Calendar 值转换为一个字符串。
static String | DatatypeConverter.printDateTime(Calendar val) 将 Calendar 值转换为一个字符串。
String | DatatypeConverterInterface.printDateTime(Calendar val) 将 Calendar 值转换为一个字符串。
static String | DatatypeConverter.printTime(Calendar val) 将 Calendar 值转换为一个字符串。
String | DatatypeConverterInterface.printTime(Calendar val) 将 Calendar 值转换为一个字符串。

javax.xml.datatype 中 Calendar 的使用

参数类型为 Calendar 的 javax.xml.datatype 中的方法
abstract void | Duration.addTo(Calendar calendar) 将此持续时间添加到 Calendar 对象。
long | Duration.getTimeInMillis(Calendar startInstant) 返回以毫秒为单位的持续时间的长度。
abstract Duration | Duration.normalizeWith(Calendar startTimeInstant) 通过使用特定的时间点作为参考点，将 years 和 months 字段转换为 days 字段。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Collection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Collection
的使用

使用 Collection 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

java.awt 中 Collection 的使用

返回 Collection 的 java.awt 中的方法
 Collection<Object> RenderingHints.values()
返回此 RenderinHints 中所包含键的 Collection 视图。

java.beans.beancontext 中 Collection 的使用

java.beans.beancontext 中 Collection 的子接口
interface | BeanContext BeanContext 是 JavaBean 的逻辑层次容器。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 Collection 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

声明为 Collection 的 java.beans.beancontext 中的字段
protected  Collection BeanContextMembershipEvent.children
受此事件通知影响的子级的列表。

参数类型为 Collection 的 java.beans.beancontext 中的方法
boolean | BeanContextSupport.addAll(Collection c) 将 Collection 添加到 Children（不受支持的）实现的集合，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
boolean | BeanContextSupport.containsAll(Collection c) 测试以查看指定 Collection 中的所有对象是否是此 BeanContext 的子对象。
protected void | BeanContextSupport.deserialize(ObjectInputStream ois, Collection coll) readObject 使用此方法来反序列化一个 collection。
boolean | BeanContextSupport.removeAll(Collection c) 移除所有指定 Children（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
boolean | BeanContextSupport.retainAll(Collection c) 仅保留指定子对象（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
protected void | BeanContextSupport.serialize(ObjectOutputStream oos, Collection coll) writeObject 使用此方法来序列化一个 Collection。

参数类型为 Collection 的 java.beans.beancontext 中的构造方法
BeanContextMembershipEvent(BeanContext bc, Collection changes)
构造一个 BeanContextMembershipEvent

java.security 中 Collection 的使用

返回 Collection 的 java.security 中的方法
 Collection<Object> Provider.values()
返回此 provider 中所包含的属性值的一个不可修改的 Collection 视图。

java.security.cert 中 Collection 的使用

返回 Collection 的 java.security.cert 中的方法
abstract Collection<? extends Certificate> | CertificateFactorySpi.engineGenerateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
abstract Collection<? extends CRL> | CertificateFactorySpi.engineGenerateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
abstract Collection<? extends Certificate> | CertStoreSpi.engineGetCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
abstract Collection<? extends CRL> | CertStoreSpi.engineGetCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
Collection<? extends Certificate> | CertificateFactory.generateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
Collection<? extends CRL> | CertificateFactory.generateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
Collection<? extends Certificate> | CertStore.getCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
Collection<?> | CollectionCertStoreParameters.getCollection() 返回从中获取 Certificate 和 CRL 的 Collection。
Collection<? extends CRL> | CertStore.getCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
Collection<List<?>> | X509Certificate.getIssuerAlternativeNames() 从 IssuerAltName 扩展 (OID = 2.5.29.18) 中获取一个发布方替换名称的不可变集合。
Collection<Object> | X509CRLSelector.getIssuerNames() 返回该 issuerNames 标准的一个副本。
Collection<X500Principal> | X509CRLSelector.getIssuers() 返回 issuerNames 标准。
Collection<List<?>> | X509CertSelector.getPathToNames() 返回 pathToNames 标准的一个副本。
Collection<List<?>> | X509CertSelector.getSubjectAlternativeNames() 返回 subjectAlternativeNames 标准的一个副本。
Collection<List<?>> | X509Certificate.getSubjectAlternativeNames() 从 SubjectAltName 扩展 (OID = 2.5.29.17) 中获取一个主体替换名称的不可变集合。

参数类型为 Collection 的 java.security.cert 中的方法
abstract  void PKIXCertPathChecker.check(Certificate cert, Collection<String> unresolvedCritExts)
使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。
 void X509CRLSelector.setIssuerNames(Collection<?> names)
注意：请使用 X509CRLSelector.setIssuers(Collection) 方法，或者使用此方法时仅指定 byte 数组形式的标识名。
 void X509CRLSelector.setIssuers(Collection<X500Principal> issuers)
设置 issuerNames 标准。
 void X509CertSelector.setPathToNames(Collection<List<?>> names)
设置 pathToNames 标准。
 void X509CertSelector.setSubjectAlternativeNames(Collection<List<?>> names)
设置 subjectAlternativeNames 标准。

参数类型为 Collection 的 java.security.cert 中的构造方法
CollectionCertStoreParameters(Collection<?> collection)
创建 CollectionCertStoreParameters 的一个实例，它允许从指定的 Collection 中获取证书和 CRL。

java.util 中 Collection 的使用

java.util 中 Collection 的子接口
interface | Deque<E> 一个线性 collection，支持在两端插入和移除元素。
interface | List<E> 有序的 collection（也称为序列）。
interface | NavigableSet<E> 扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
interface | Queue<E> 在处理元素前用于保存元素的 collection。
interface | Set<E> 一个不包含重复元素的 collection。
interface | SortedSet<E> 进一步提供关于元素的总体排序 的 Set。

实现 Collection 的 java.util 中的类
class | AbstractCollection<E> 此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
class | AbstractList<E> 此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
class | AbstractQueue<E> 此类提供某些 Queue 操作的骨干实现。
class | AbstractSequentialList<E> 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
class | AbstractSet<E> 此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | LinkedList<E> List 接口的链接列表实现。
class | PriorityQueue<E> 一个基于优先级堆的无界优先级队列。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。
class | Vector<E> Vector 类可以实现可增长的对象数组。

返回 Collection 的 java.util 中的方法
static
<E> Collection<E>
Collections.checkedCollection(Collection<E> c, Class<E> type)
返回指定 collection 的一个动态类型安全视图。
static
<T> Collection<T>
Collections.synchronizedCollection(Collection<T> c)
返回指定 collection 支持的同步（线程安全的）collection。
static
<T> Collection<T>
Collections.unmodifiableCollection(Collection<? extends T> c)
返回指定 collection 的不可修改视图。
 Collection<V> EnumMap.values()
返回此映射中所包含值的 Collection 视图。
 Collection<V> IdentityHashMap.values()
返回映射所包含值的 Collection 视图。
 Collection<V> TreeMap.values()
返回此映射包含的值的 Collection 视图。
 Collection<V> SortedMap.values()
返回在此映射中所包含值的 Collection 视图。
 Collection<V> WeakHashMap.values()
返回此映射所包含的值的 Collection 视图。
 Collection<V> HashMap.values()
返回此映射所包含的值的 Collection 视图。
 Collection<V> AbstractMap.values()
返回此映射中包含的值的 Collection 视图。
 Collection<V> Hashtable.values()
返回此映射中包含的键的 Collection 视图。
 Collection<V> Map.values()
返回此映射中包含的值的 Collection 视图。

参数类型为 Collection 的 java.util 中的方法
 boolean AbstractQueue.addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此队列中。
 boolean TreeSet.addAll(Collection<? extends E> c)
将指定 collection 中的所有元素添加到此 set 中。
 boolean LinkedList.addAll(Collection<? extends E> c)
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序。
 boolean ArrayList.addAll(Collection<? extends E> c)
按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。
 boolean Set.addAll(Collection<? extends E> c)
如果 set 中没有指定 collection 中的所有元素，则将其添加到此 set 中（可选操作）。
 boolean Vector.addAll(Collection<? extends E> c)
将指定 Collection 中的所有元素添加到此向量的末尾，按照指定 collection 的迭代器所返回的顺序添加这些元素。
 boolean AbstractCollection.addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。
 boolean List.addAll(Collection<? extends E> c)
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序（可选操作）。
 boolean Collection.addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。
static
<T> boolean
Collections.addAll(Collection<? super T> c, T... elements)
将所有指定元素添加到指定 collection 中。
 boolean LinkedList.addAll(int index, Collection<? extends E> c)
将指定 collection 中的所有元素从指定位置开始插入此列表。
 boolean AbstractSequentialList.addAll(int index, Collection<? extends E> c)
在此列表中指定的位置上插入指定 collection 中的所有元素（可选操作）。
 boolean ArrayList.addAll(int index, Collection<? extends E> c)
从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。
 boolean Vector.addAll(int index, Collection<? extends E> c)
在指定位置将指定 Collection 中的所有元素插入到此向量中。
 boolean AbstractList.addAll(int index, Collection<? extends E> c)
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。
 boolean List.addAll(int index, Collection<? extends E> c)
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。
static
<E> Collection<E>
Collections.checkedCollection(Collection<E> c, Class<E> type)
返回指定 collection 的一个动态类型安全视图。
 boolean Set.containsAll(Collection<?> c)
如果此 set 包含指定 collection 的所有元素，则返回 true。
 boolean Vector.containsAll(Collection<?> c)
如果此向量包含指定 Collection 中的所有元素，则返回 true。
 boolean AbstractCollection.containsAll(Collection<?> c)
如果此 collection 包含指定 collection 中的所有元素，则返回 true。
 boolean List.containsAll(Collection<?> c)
如果列表包含指定 collection 的所有元素，则返回 true。
 boolean Collection.containsAll(Collection<?> c)
如果此 collection 包含指定 collection 中的所有元素，则返回 true。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(Collection<E> c)
创建一个从指定 collection 初始化的枚举 set。
static boolean Collections.disjoint(Collection<?> c1, Collection<?> c2)
如果两个指定 collection 中没有相同的元素，则返回 true。
static boolean Collections.disjoint(Collection<?> c1, Collection<?> c2)
如果两个指定 collection 中没有相同的元素，则返回 true。
static
<T> Enumeration<T>
Collections.enumeration(Collection<T> c)
返回一个指定 collection 上的枚举。
static int Collections.frequency(Collection<?> c, Object o)
返回指定 collection 中等于指定对象的元素数。
static
<T extends Object & Comparable<? super T>>
T
Collections.max(Collection<? extends T> coll)
根据元素的自然顺序，返回给定 collection 的最大元素。
static
<T> T
Collections.max(Collection<? extends T> coll, Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最大元素。
static
<T extends Object & Comparable<? super T>>
T
Collections.min(Collection<? extends T> coll)
根据元素的自然顺序 返回给定 collection 的最小元素。
static
<T> T
Collections.min(Collection<? extends T> coll, Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最小元素。
 boolean AbstractSet.removeAll(Collection<?> c)
从此 set 中移除包含在指定 collection 中的所有元素（可选操作）。
 boolean Set.removeAll(Collection<?> c)
移除 set 中那些包含在指定 collection 中的元素（可选操作）。
 boolean Vector.removeAll(Collection<?> c)
从此向量中移除包含在指定 Collection 中的所有元素。
 boolean AbstractCollection.removeAll(Collection<?> c)
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。
 boolean List.removeAll(Collection<?> c)
从列表中移除指定 collection 中包含的其所有元素（可选操作）。
 boolean Collection.removeAll(Collection<?> c)
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。
 boolean Set.retainAll(Collection<?> c)
仅保留 set 中那些包含在指定 collection 中的元素（可选操作）。
 boolean Vector.retainAll(Collection<?> c)
在此向量中仅保留包含在指定 Collection 中的元素。
 boolean AbstractCollection.retainAll(Collection<?> c)
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。
 boolean List.retainAll(Collection<?> c)
仅在列表中保留指定 collection 中所包含的元素（可选操作）。
 boolean Collection.retainAll(Collection<?> c)
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。
static
<T> Collection<T>
Collections.synchronizedCollection(Collection<T> c)
返回指定 collection 支持的同步（线程安全的）collection。
static
<T> Collection<T>
Collections.unmodifiableCollection(Collection<? extends T> c)
返回指定 collection 的不可修改视图。

参数类型为 Collection 的 java.util 中的构造方法
ArrayDeque(Collection<? extends E> c)
构造一个包含指定 collection 的元素的双端队列，这些元素按 collection 的迭代器返回的顺序排列。
ArrayList(Collection<? extends E> c)
构造一个包含指定 collection 的元素的列表，这些元素是按照该 collection 的迭代器返回它们的顺序排列的。
HashSet(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的新 set。
LinkedHashSet(Collection<? extends E> c)
构造一个与指定 collection 中的元素相同的新链接哈希 set。
LinkedList(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的列表，这些元素按其 collection 的迭代器返回的顺序排列。
PriorityQueue(Collection<? extends E> c)
创建包含指定 collection 中元素的 PriorityQueue。
TreeSet(Collection<? extends E> c)
构造一个包含指定 collection 元素的新 TreeSet，它按照其元素的自然顺序进行排序。
Vector(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的向量，这些元素按其 collection 的迭代器返回元素的顺序排列。

java.util.concurrent 中 Collection 的使用

java.util.concurrent 中 Collection 的子接口
interface | BlockingDeque<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。
interface | BlockingQueue<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。

实现 Collection 的 java.util.concurrent 中的类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArrayList<E> ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

返回 Collection 的 java.util.concurrent 中的方法
protected Collection<Thread> | Semaphore.getQueuedThreads() 返回一个 collection，包含可能等待获取的线程。
Collection<V> | ConcurrentSkipListMap.values() 返回此映射中所包含值的 Collection 视图。
Collection<V> | ConcurrentHashMap.values() 返回此映射中包含的值的 Collection 视图。

参数类型为 Collection 的 java.util.concurrent 中的方法
 boolean CopyOnWriteArrayList.addAll(Collection<? extends E> c)
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中的所有元素添加此列表的尾部。
 boolean CopyOnWriteArraySet.addAll(Collection<? extends E> c)
如果此 set 中没有指定 collection 中的所有元素，则将它们都添加到此 set 中。
 boolean CopyOnWriteArrayList.addAll(int index, Collection<? extends E> c)
从指定位置开始，将指定 collection 的所有元素插入此列表。
 int CopyOnWriteArrayList.addAllAbsent(Collection<? extends E> c)
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中尚未包含在此列表中的所有元素添加列表的尾部。
 boolean CopyOnWriteArrayList.containsAll(Collection<?> c)
如果此列表包含指定 collection 的所有元素，则返回 true。
 boolean CopyOnWriteArraySet.containsAll(Collection<?> c)
如果此 set 包含指定 collection 的所有元素，则返回 true。
 boolean SynchronousQueue.containsAll(Collection<?> c)
除非给定 collection 为空，否则返回 false。
 int ArrayBlockingQueue.drainTo(Collection<? super E> c)
 int BlockingQueue.drainTo(Collection<? super E> c)
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
 int DelayQueue.drainTo(Collection<? super E> c)
 int LinkedBlockingDeque.drainTo(Collection<? super E> c)
 int LinkedBlockingQueue.drainTo(Collection<? super E> c)
 int PriorityBlockingQueue.drainTo(Collection<? super E> c)
 int SynchronousQueue.drainTo(Collection<? super E> c)
 int ArrayBlockingQueue.drainTo(Collection<? super E> c, int maxElements)
 int BlockingQueue.drainTo(Collection<? super E> c, int maxElements)
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
 int DelayQueue.drainTo(Collection<? super E> c, int maxElements)
 int LinkedBlockingDeque.drainTo(Collection<? super E> c, int maxElements)
 int LinkedBlockingQueue.drainTo(Collection<? super E> c, int maxElements)
 int PriorityBlockingQueue.drainTo(Collection<? super E> c, int maxElements)
 int SynchronousQueue.drainTo(Collection<? super E> c, int maxElements)
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。
 boolean ConcurrentSkipListSet.removeAll(Collection<?> c)
从此 set 中移除包含在指定 collection 中的所有元素。
 boolean CopyOnWriteArrayList.removeAll(Collection<?> c)
从此列表移除所有包含在指定 collection 中的元素。
 boolean CopyOnWriteArraySet.removeAll(Collection<?> c)
移除此 set 中包含在指定 collection 中的所有元素。
 boolean SynchronousQueue.removeAll(Collection<?> c)
始终返回 false。
 boolean CopyOnWriteArrayList.retainAll(Collection<?> c)
只保留此列表中包含在指定 collection 中的元素。
 boolean CopyOnWriteArraySet.retainAll(Collection<?> c)
仅保留此 set 中那些包含在指定 collection 中的元素。
 boolean SynchronousQueue.retainAll(Collection<?> c)
始终返回 false。

参数类型为 Collection 的 java.util.concurrent 中的构造方法
ArrayBlockingQueue(int capacity, boolean fair, Collection<? extends E> c)
创建一个具有给定的（固定）容量和指定访问策略的 ArrayBlockingQueue，它最初包含给定 collection 的元素，并以 collection 迭代器的遍历顺序添加元素。
ConcurrentLinkedQueue(Collection<? extends E> c)
创建一个最初包含给定 collection 元素的 ConcurrentLinkedQueue，按照此 collection 迭代器的遍历顺序来添加元素。
ConcurrentSkipListSet(Collection<? extends E> c)
构造一个包含指定 collection 中元素的新 set，这个新 set 按照元素的自然顺序对其进行排序。
CopyOnWriteArrayList(Collection<? extends E> c)
创建一个按 collection 的迭代器返回元素的顺序包含指定 collection 元素的列表。
CopyOnWriteArraySet(Collection<? extends E> c)
创建一个包含指定 collection 所有元素的 set。
DelayQueue(Collection<? extends E> c)
创建一个最初包含 Delayed 实例的给定 collection 元素的 DelayQueue。
LinkedBlockingDeque(Collection<? extends E> c)
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingDeque，最初包含给定 collection 的元素，以该 collection 迭代器的遍历顺序添加。
LinkedBlockingQueue(Collection<? extends E> c)
创建一个容量是 Integer.MAX_VALUE 的 LinkedBlockingQueue，最初包含给定 collection 的元素，元素按该 collection 迭代器的遍历顺序添加。
PriorityBlockingQueue(Collection<? extends E> c)
创建一个包含指定 collection 元素的 PriorityBlockingQueue。

java.util.concurrent.locks 中 Collection 的使用

返回 Collection 的 java.util.concurrent.locks 中的方法
Collection<Thread> | AbstractQueuedLongSynchronizer.getExclusiveQueuedThreads() 返回一个 collection，该 collection 包含正以独占模式等待获取的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getExclusiveQueuedThreads() 返回包含可能正以独占模式等待获取的线程 collection。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedReaderThreads() 返回一个 collection，它包含可能正在等待获取读取锁的线程。
Collection<Thread> | AbstractQueuedLongSynchronizer.getQueuedThreads() 返回一个 collection，该 collection 包含正在等待获取的线程。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedThreads() 返回一个 collection，它包含可能正在等待获取读取或写入锁的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getQueuedThreads() 返回包含可能正在等待获取的线程 collection。
protected Collection<Thread> | ReentrantLock.getQueuedThreads() 返回一个 collection，它包含可能正等待获取此锁的线程。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedWriterThreads() 返回一个 collection，它包含可能正在等待获取写入锁的线程。
Collection<Thread> | AbstractQueuedLongSynchronizer.getSharedQueuedThreads() 返回一个 collection，该 collection 包含正以共享模式等待获取的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getSharedQueuedThreads() 返回包含可能正以共享模式等待获取的线程 collection。
protected Collection<Thread> | AbstractQueuedLongSynchronizer.ConditionObject.getWaitingThreads() 返回一个 collection，该 collection 包含那些正在此条件等待的线程。
protected Collection<Thread> | AbstractQueuedSynchronizer.ConditionObject.getWaitingThreads() 返回包含那些可能正在等待此条件的线程 collection。
Collection<Thread> | AbstractQueuedLongSynchronizer.getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject condition) 返回一个 collection，该 collection 包含那些正在与此同步器关联的给定条件上等待的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject condition) 返回一个 collection，其中包含可能正在等待与此同步器有关的给定条件的那些线程。
protected Collection<Thread> | ReentrantReadWriteLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与写入锁相关的给定条件的那些线程。
protected Collection<Thread> | ReentrantLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与此锁相关给定条件的那些线程。

java.util.jar 中 Collection 的使用

返回 Collection 的 java.util.jar 中的方法
 Collection<Object> Attributes.values()
返回此 Map 所包含的属性值的 Collection 视图。

javax.management 中 Collection 的使用

实现 Collection 的 javax.management 中的类
 class AttributeList
表示 MBean 属性值的列表。

参数类型为 Collection 的 javax.management 中的方法
boolean | AttributeList.addAll(Collection<?> c)
boolean | AttributeList.addAll(int index, Collection<?> c)

javax.management.openmbean 中 Collection 的使用

返回 Collection 的 javax.management.openmbean 中的方法
Collection<?> | CompositeData.values() 返回此 CompositeData 实例中所包含项值的不可修改的 Collection 视图。
Collection<?> | CompositeDataSupport.values() 返回此 CompositeData 实例中包含的项值的不可修改的 Collection 视图。
Collection<?> | TabularData.values() 返回此 TabularData 实例中包含的 CompositeData 值（即各行）的 collection 视图。
Collection<Object> | TabularDataSupport.values() 返回包含在此 TabularDataSupport 实例中的行的 collection 视图。

javax.management.relation 中 Collection 的使用

实现 Collection 的 javax.management.relation 中的类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

参数类型为 Collection 的 javax.management.relation 中的方法
boolean | RoleList.addAll(Collection<?> c)
boolean | RoleUnresolvedList.addAll(Collection<?> c)
boolean | RoleList.addAll(int index, Collection<?> c)
boolean | RoleUnresolvedList.addAll(int index, Collection<?> c)

javax.print.attribute.standard 中 Collection 的使用

实现 Collection 的 javax.print.attribute.standard 中的类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

参数类型为 Collection 的 javax.print.attribute.standard 中的构造方法
JobStateReasons(Collection<JobStateReason> collection)
构造新的作业状态原因属性，它包含与给定集合相同的 JobStateReason 对象。

javax.script 中 Collection 的使用

返回 Collection 的 javax.script 中的方法
 Collection<Object> SimpleBindings.values()
返回此映射中包含的值的 Collection 视图。

javax.sql.rowset 中 Collection 的使用

返回 Collection 的 javax.sql.rowset 中的方法
Collection<?> | JoinRowSet.getRowSets() 返回一个 Collection 对象，包含已经添加到此 JoinRowSet 对象的 RowSet 对象。
Collection<?> | CachedRowSet.toCollection() 将此 CachedRowSet 对象转换成一个 Collection 对象，它包含此 CachedRowSet 对象的所有数据。
Collection<?> | CachedRowSet.toCollection(int column) 将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
Collection<?> | CachedRowSet.toCollection(String column) 将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Collections 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Collections
的使用

没有 java.util.Collections 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Comparator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Comparator
的使用

使用 Comparator 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

java.lang 中 Comparator 的使用

声明为 Comparator 的 java.lang 中的字段
static Comparator<String> String.CASE_INSENSITIVE_ORDER
一个对 String 对象进行排序的 Comparator，作用与 compareToIgnoreCase 相同。

java.text 中 Comparator 的使用

实现 Comparator 的 java.text 中的类
class | Collator Collator 类执行区分语言环境的 String 比较。
class | RuleBasedCollator RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。

java.util 中 Comparator 的使用

返回 Comparator 的 java.util 中的方法
 Comparator<? super E> PriorityQueue.comparator()
返回用来对此队列中的元素进行排序的比较器；如果此队列根据其元素的自然顺序进行排序，则返回 null。
 Comparator<? super E> TreeSet.comparator()
 Comparator<? super E> SortedSet.comparator()
返回对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null。
 Comparator<? super K> TreeMap.comparator()
 Comparator<? super K> SortedMap.comparator()
返回对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null。
static
<T> Comparator<T>
Collections.reverseOrder()
返回一个比较器，它强行逆转实现了 Comparable 接口的对象 collection 的自然顺序。
static
<T> Comparator<T>
Collections.reverseOrder(Comparator<T> cmp)
返回一个比较器，它强行逆转指定比较器的顺序。

参数类型为 Comparator 的 java.util 中的方法
static
<T> int
Collections.binarySearch(List<? extends T> list, T key, Comparator<? super T> c)
使用二分搜索法搜索指定列表，以获得指定对象。
static
<T> int
Arrays.binarySearch(T[] a, int fromIndex, int toIndex, T key, Comparator<? super T> c)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。
static
<T> int
Arrays.binarySearch(T[] a, T key, Comparator<? super T> c)
使用二分搜索法来搜索指定数组，以获得指定对象。
static
<T> T
Collections.max(Collection<? extends T> coll, Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最大元素。
static
<T> T
Collections.min(Collection<? extends T> coll, Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最小元素。
static
<T> Comparator<T>
Collections.reverseOrder(Comparator<T> cmp)
返回一个比较器，它强行逆转指定比较器的顺序。
static
<T> void
Collections.sort(List<T> list, Comparator<? super T> c)
根据指定比较器产生的顺序对指定列表进行排序。
static
<T> void
Arrays.sort(T[] a, Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组进行排序。
static
<T> void
Arrays.sort(T[] a, int fromIndex, int toIndex, Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组的指定范围进行排序。

参数类型为 Comparator 的 java.util 中的构造方法
PriorityQueue(int initialCapacity, Comparator<? super E> comparator)
使用指定的初始容量创建一个 PriorityQueue，并根据指定的比较器对元素进行排序。
TreeMap(Comparator<? super K> comparator)
构造一个新的、空的树映射，该映射根据给定比较器进行排序。
TreeSet(Comparator<? super E> comparator)
构造一个新的空 TreeSet，它根据指定比较器进行排序。

java.util.concurrent 中 Comparator 的使用

返回 Comparator 的 java.util.concurrent 中的方法
Comparator<? super K> | ConcurrentSkipListMap.comparator()
Comparator<? super E> | ConcurrentSkipListSet.comparator()
Comparator<? super E> | PriorityBlockingQueue.comparator() 返回用于对此队列元素进行排序的比较器；如果此队列使用其元素的自然顺序，则返回 null。

参数类型为 Comparator 的 java.util.concurrent 中的构造方法
ConcurrentSkipListMap(Comparator<? super K> comparator)
构造一个新的空映射，该映射按照指定的比较器进行排序。
ConcurrentSkipListSet(Comparator<? super E> comparator)
构造一个新的空 set，该 set 按照指定的比较器对其元素进行排序。
PriorityBlockingQueue(int initialCapacity, Comparator<? super E> comparator)
使用指定的初始容量创建一个 PriorityBlockingQueue，并根据指定的比较器对其元素进行排序。

javax.swing 中 Comparator 的使用

返回 Comparator 的 javax.swing 中的方法
protected Comparator<? super Component> | SortingFocusTraversalPolicy.getComparator() 返回将用于对焦点遍历循环中的 Components 排序的 Comparator。
Comparator<?> | DefaultRowSorter.getComparator(int column) 返回指定列的 Comparator。

参数类型为 Comparator 的 javax.swing 中的方法
protected void | SortingFocusTraversalPolicy.setComparator(Comparator<? super Component> comparator) 设置将用于对焦点遍历循环中的 Components 排序的 Comparator。
void | DefaultRowSorter.setComparator(int column, Comparator<?> comparator) 设置对指定列进行排序时要使用的 Comparator。

参数类型为 Comparator 的 javax.swing 中的构造方法
SortingFocusTraversalPolicy(Comparator<? super Component> comparator)
构造具有指定 Comparator 的 SortingFocusTraversalPolicy。

javax.swing.table 中 Comparator 的使用

返回 Comparator 的 javax.swing.table 中的方法
 Comparator<?> TableRowSorter.getComparator(int column)
返回指定列的 Comparator。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.ConcurrentModificationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ConcurrentModificationException
的使用

没有 java.util.ConcurrentModificationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Currency 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Currency
的使用

使用 Currency 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.text 中 Currency 的使用

返回 Currency 的 java.text 中的方法
Currency | DecimalFormat.getCurrency() 获取格式化货币值时，此十进制格式使用的货币。
Currency | DecimalFormatSymbols.getCurrency() 获得这些 DecimalFormatSymbols 的货币。
Currency | NumberFormat.getCurrency() 获取格式化货币值时此数值格式使用的货币。

参数类型为 Currency 的 java.text 中的方法
void | DecimalFormat.setCurrency(Currency currency) 设置格式化货币值时，此数字格式使用的货币。
void | DecimalFormatSymbols.setCurrency(Currency currency) 设置这些 DecimalFormatSymbols 的货币。
void | NumberFormat.setCurrency(Currency currency) 设置格式化货币值时此数值格式使用的货币。

java.util 中 Currency 的使用

返回 Currency 的 java.util 中的方法
static Currency | Currency.getInstance(Locale locale) 返回给定语言环境的国家/地区的 Currency 实例。
static Currency | Currency.getInstance(String currencyCode) 返回给定货币代码的 Currency 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Date 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Date
的使用

使用 Date 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.cert | 为公钥证书提供类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.datatype | XML/Java 类型映射关系。

java.security 中 Date 的使用

返回 Date 的 java.security 中的方法
abstract Date | KeyStoreSpi.engineGetCreationDate(String alias) 返回该别名标识的项的创建日期。
Date | KeyStore.getCreationDate(String alias) 返回给定别名标识的条目的创建日期。
Date | Timestamp.getTimestamp() 返回生成时间戳时的日期和时间。

参数类型为 Date 的 java.security 中的构造方法
Timestamp(Date timestamp, CertPath signerCertPath)
构造一个时间戳。

java.security.cert 中 Date 的使用

返回 Date 的 java.security.cert 中的方法
Date | X509CertSelector.getCertificateValid() 返回 certificateValid 标准。
Date | PKIXParameters.getDate() 返回应该确定证书路径有效性的时间。
Date | X509CRLSelector.getDateAndTime() 返回 dateAndTime 标准。
abstract Date | X509CRL.getNextUpdate() 获取 CRL 的 nextUpdate 日期。
abstract Date | X509Certificate.getNotAfter() 获取证书有效期的 notAfter 日期。
abstract Date | X509Certificate.getNotBefore() 获取证书有效期的 notBefore 日期。
Date | X509CertSelector.getPrivateKeyValid() 返回 privateKeyValid 标准。
abstract Date | X509CRLEntry.getRevocationDate() 获取此 X509CRLEntry 的撤消日期 revocationDate。
abstract Date | X509CRL.getThisUpdate() 获取 CRL 的 thisUpdate 日期。

参数类型为 Date 的 java.security.cert 中的方法
abstract void | X509Certificate.checkValidity(Date date) 检查给定的日期是否处于证书的有效期内。
void | X509CertSelector.setCertificateValid(Date certValid) 设置 certificateValid 标准。
void | PKIXParameters.setDate(Date date) 设置应该确定证书路径有效性的时间。
void | X509CRLSelector.setDateAndTime(Date dateAndTime) 设置 dateAndTime 标准。
void | X509CertSelector.setPrivateKeyValid(Date privateKeyValid) 设置 privateKeyValid 标准。

java.sql 中 Date 的使用

java.sql 中 Date 的子类
class | Date 一个包装了毫秒值的瘦包装器 (thin wrapper)，它允许 JDBC 将毫秒值标识为 SQL DATE 值。
class | Time 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
class | Timestamp 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。

参数类型为 Date 的 java.sql 中的方法
 int Timestamp.compareTo(Date o)
将此 Timestamp 对象与给定的 Date（必须为 Timestamp 对象）相比较。

java.text 中 Date 的使用

返回 Date 的 java.text 中的方法
Date | SimpleDateFormat.get2DigitYearStart() 返回在 100 年周期内被解释的两位数字年份的开始日期。
Date | DateFormat.parse(String source) 从给定字符串的开始解析文本，以生成一个日期。
Date | SimpleDateFormat.parse(String text, ParsePosition pos) 解析字符串的文本，生成 Date。
abstract Date | DateFormat.parse(String source, ParsePosition pos) 根据给定的解析位置开始解析日期/时间字符串。

参数类型为 Date 的 java.text 中的方法
String | DateFormat.format(Date date) 将一个 Date 格式化为日期/时间字符串。
StringBuffer | SimpleDateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition pos) 将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
abstract StringBuffer | DateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition) 将一个 Date 格式化为日期/时间字符串。
void | SimpleDateFormat.set2DigitYearStart(Date startDate) 设置 100 年周期的两位数年份，该年份将被解释为从用户指定的日期开始。

java.util 中 Date 的使用

返回 Date 的 java.util 中的方法
Date | GregorianCalendar.getGregorianChange() 获得格里高利历的更改日期。
Date | Calendar.getTime() 返回一个表示此 Calendar 时间值（从历元至现在的毫秒偏移量）的 Date 对象。

参数类型为 Date 的 java.util 中的方法
boolean | Date.after(Date when) 测试此日期是否在指定日期之后。
boolean | Date.before(Date when) 测试此日期是否在指定日期之前。
int | Date.compareTo(Date anotherDate) 比较两个日期的顺序。
boolean | SimpleTimeZone.inDaylightTime(Date date) 如果给定日期在夏令时期间，则执行查询。
abstract boolean | TimeZone.inDaylightTime(Date date) 查询给定的日期是否在此时区的夏令时中。
void | Timer.schedule(TimerTask task, Date time) 安排在指定的时间执行指定的任务。
void | Timer.schedule(TimerTask task, Date firstTime, long period) 安排指定的任务在指定的时间开始进行重复的固定延迟执行。
void | Timer.scheduleAtFixedRate(TimerTask task, Date firstTime, long period) 安排指定的任务在指定的时间开始进行重复的固定速率执行。
void | GregorianCalendar.setGregorianChange(Date date) 设置 GregorianCalendar 的更改日期。
void | Calendar.setTime(Date date) 使用给定的 Date 设置此 Calendar 的时间。

java.util.concurrent.locks 中 Date 的使用

参数类型为 Date 的 java.util.concurrent.locks 中的方法
boolean | AbstractQueuedLongSynchronizer.ConditionObject.awaitUntil(Date deadline) 实现绝对定时条件等待。
boolean | Condition.awaitUntil(Date deadline) 造成当前线程在接到信号、被中断或到达指定最后期限之前一直处于等待状态。
boolean | AbstractQueuedSynchronizer.ConditionObject.awaitUntil(Date deadline) 实现绝对定时条件等待。

javax.management.openmbean 中 Date 的使用

类型参数类型为 Date 的 javax.management.openmbean 中的字段
static SimpleType<Date> SimpleType.DATE
SimpleType 实例，该实例描述其 Java 类名称为 java.util.Date 的值。

javax.management.timer 中 Date 的使用

返回 Date 的 javax.management.timer 中的方法
Date | Timer.getDate(Integer id) 获得与计时器通知关联的日期的一个副本。
Date | TimerMBean.getDate(Integer id) 获得与计时器通知关联的日期的一个副本。

参数类型为 Date 的 javax.management.timer 中的方法
Integer | Timer.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

javax.print.attribute 中 Date 的使用

返回 Date 的 javax.print.attribute 中的方法
 Date DateTimeSyntax.getValue()
返回此日期-时间属性的 java.util.Date 值。

参数类型为 Date 的 javax.print.attribute 中的构造方法
DateTimeSyntax(Date value)
构造具有给定 java.util.Date 值的新的日期-时间属性。

javax.print.attribute.standard 中 Date 的使用

参数类型为 Date 的 javax.print.attribute.standard 中的构造方法
DateTimeAtCompleted(Date dateTime)
构造具有给定 Date 值的新 date-time at completed 属性。
DateTimeAtCreation(Date dateTime)
构造具有给定 Date 值的新的 DateTimeAtCreation 属性。
DateTimeAtProcessing(Date dateTime)
构造具有给定 Date 值的新的 DateTimeAtProcessing 属性。
JobHoldUntil(Date dateTime)
构造具有给定 Date 值新 JobHoldUntil 属性。

javax.security.auth.kerberos 中 Date 的使用

返回 Date 的 javax.security.auth.kerberos 中的方法
Date | KerberosTicket.getAuthTime() 返回客户端进行验证的时间。
Date | KerberosTicket.getEndTime() 返回此票据有效期的期满时间。
Date | KerberosTicket.getRenewTill() 返回此票据最新的期满时间，包括所有的更新。
Date | KerberosTicket.getStartTime() 返回此票据有效期的开始时间。

参数类型为 Date 的 javax.security.auth.kerberos 中的构造方法
KerberosTicket(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
使用客户端从 KDC 接收的或从缓存中读取的证书信息构造 KerberosTicket。

javax.security.cert 中 Date 的使用

返回 Date 的 javax.security.cert 中的方法
abstract Date | X509Certificate.getNotAfter() 获取证书有效期的 notAfter 日期。
abstract Date | X509Certificate.getNotBefore() 获取证书有效期的 notBefore 日期。

参数类型为 Date 的 javax.security.cert 中的方法
abstract  void X509Certificate.checkValidity(Date date)
检查指定的日期是否处于证书的有效期内。

javax.swing 中 Date 的使用

返回 Date 的 javax.swing 中的方法
 Date SpinnerDateModel.getDate()
返回此 Date 序列中的当前元素。

参数类型为 Date 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.dateFilter(RowFilter.ComparisonType type, Date date, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Date 值的条目。

参数类型为 Date 的 javax.swing 中的构造方法
SpinnerDateModel(Date value, Comparable start, Comparable end, int calendarField)
创建一个表示 start 和 end 之间的日期序列的 SpinnerDateModel。

javax.xml.datatype 中 Date 的使用

参数类型为 Date 的 javax.xml.datatype 中的方法
void | Duration.addTo(Date date) 将此持续时间添加到 Date 对象。
long | Duration.getTimeInMillis(Date startInstant) 返回以毫秒为单位的持续时间的长度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Deque 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Deque
的使用

使用 Deque 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 Deque 的使用

实现 Deque 的 java.util 中的类
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | LinkedList<E> List 接口的链接列表实现。

参数类型为 Deque 的 java.util 中的方法
static
<T> Queue<T>
Collections.asLifoQueue(Deque<T> deque)
以后进先出 (Lifo) Queue 的形式返回某个 Deque 的视图。

java.util.concurrent 中 Deque 的使用

java.util.concurrent 中 Deque 的子接口
 interface BlockingDeque<E>
支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。

实现 Deque 的 java.util.concurrent 中的类
 class LinkedBlockingDeque<E>
一个基于已链接节点的、任选范围的阻塞双端队列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Dictionary 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Dictionary
的使用

使用 Dictionary 的软件包
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.security 中 Dictionary 的使用

java.security 中 Dictionary 的子类
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

java.util 中 Dictionary 的使用

java.util 中 Dictionary 的子类
class | Hashtable<K,V> 此类实现一个哈希表，该哈希表将键映射到相应的值。
class | Properties Properties 类表示了一个持久的属性集。

javax.swing 中 Dictionary 的使用

javax.swing 中 Dictionary 的子类
 class UIDefaults
Swing 组件的默认值表。

返回 Dictionary 的 javax.swing 中的方法
 Dictionary JSlider.getLabelTable()
返回哪些标签在哪些值处绘制的字典。

参数类型为 Dictionary 的 javax.swing 中的方法
 void JSlider.setLabelTable(Dictionary labels)
用于指定将在给定值处绘制哪个标签。

javax.swing.text 中 Dictionary 的使用

返回 Dictionary 的 javax.swing.text 中的方法
 Dictionary<Object,Object> AbstractDocument.getDocumentProperties()
支持管理属性集。

参数类型为 Dictionary 的 javax.swing.text 中的方法
 void AbstractDocument.setDocumentProperties(Dictionary<Object,Object> x)
替换此文档的文档属性字典。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.DuplicateFormatFlagsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.DuplicateFormatFlagsException
的使用

没有 java.util.DuplicateFormatFlagsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.EmptyStackException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.EmptyStackException
的使用

使用 EmptyStackException 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 EmptyStackException 的使用

抛出 EmptyStackException 的 java.awt 中的方法
protected  void EventQueue.pop()
停止使用此 EventQueue 指派事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Enumeration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Enumeration
的使用

使用 Enumeration 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.management.loading | 提供实现高级动态加载的类。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 中 Enumeration 的使用

返回 Enumeration 的 java.applet 中的方法
 Enumeration<Applet> AppletContext.getApplets()
找到此 applet 上下文表示的文档中的所有 applet。

java.awt 中 Enumeration 的使用

返回 Enumeration 的 java.awt 中的方法
 Enumeration<MenuShortcut> MenuBar.shortcuts()
获取此菜单栏正在管理的所有菜单快捷方式的枚举。

java.beans 中 Enumeration 的使用

返回 Enumeration 的 java.beans 中的方法
 Enumeration<String> FeatureDescriptor.attributeNames()
获得与语言环境无关的此特性名称的枚举。

java.io 中 Enumeration 的使用

参数类型为 Enumeration 的 java.io 中的构造方法
SequenceInputStream(Enumeration<? extends InputStream> e)
通过记住参数来初始化新创建的 SequenceInputStream，该参数必须是生成运行时类型为 InputStream 对象的 Enumeration 型参数。

java.lang 中 Enumeration 的使用

返回 Enumeration 的 java.lang 中的方法
protected Enumeration<URL> | ClassLoader.findResources(String name) 返回表示所有具有给定名称的资源的 URL 对象的枚举。
Enumeration<URL> | ClassLoader.getResources(String name) 查找所有给定名称的资源。
static Enumeration<URL> | ClassLoader.getSystemResources(String name) 从用来加载类的搜索路径中查找所有具有指定名称的资源。

java.net 中 Enumeration 的使用

返回 Enumeration 的 java.net 中的方法
Enumeration<URL> | URLClassLoader.findResources(String name) 返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。
Enumeration<InetAddress> | NetworkInterface.getInetAddresses() 一个便捷方法，返回一个具有绑定到此网络接口全部或部分 InetAddress 的 Enumeration。
static Enumeration<NetworkInterface> | NetworkInterface.getNetworkInterfaces() 返回此机器上的所有接口。
Enumeration<NetworkInterface> | NetworkInterface.getSubInterfaces() 获取具有连接到此网络接口的所有子接口（也称虚拟接口）的 Enumeration。

java.security 中 Enumeration 的使用

返回 Enumeration 的 java.security 中的方法
Enumeration<String> | KeyStore.aliases() 列出此 keystore 的所有别名。
Enumeration<Object> | Provider.elements()
Enumeration<Permission> | Permissions.elements() 返回此 Permissions 对象中所有 PermissionCollection 中的所有 Permission 对象的枚举。
abstract Enumeration<Permission> | PermissionCollection.elements() 返回集合中所有 Permission 对象的枚举。
abstract Enumeration<String> | KeyStoreSpi.engineAliases() 列出此 keystore 的所有别名。
abstract Enumeration<Identity> | IdentityScope.identities() 已过时。 返回此身份作用域内所有身份的枚举。
Enumeration<Object> | Provider.keys()

java.security.acl 中 Enumeration 的使用

返回 Enumeration 的 java.security.acl 中的方法
Enumeration<AclEntry> | Acl.entries() 返回此 ACL 中各项的枚举。
Enumeration<Permission> | Acl.getPermissions(Principal user) 返回一个指定主体（表示一个实体，如个体或组）的许可权限集合的枚举。
Enumeration<? extends Principal> | Group.members() 返回此组中成员的枚举。
Enumeration<Permission> | AclEntry.permissions() 返回此 ACL 项中各个权限的枚举。

java.sql 中 Enumeration 的使用

返回 Enumeration 的 java.sql 中的方法
static Enumeration<Driver> DriverManager.getDrivers()
获取带有当前调用者可以访问的所有当前已加载 JDBC 驱动程序的 Enumeration。

java.util 中 Enumeration 的使用

实现 Enumeration 的 java.util 中的类
 class StringTokenizer
string tokenizer 类允许应用程序将字符串分解为标记。

返回 Enumeration 的 java.util 中的方法
 Enumeration<E> Vector.elements()
返回此向量的组件的枚举。
 Enumeration<V> Hashtable.elements()
返回此哈希表中的值的枚举。
abstract  Enumeration<V> Dictionary.elements()
返回此 dictionary 中值的枚举。
static
<T> Enumeration<T>
Collections.enumeration(Collection<T> c)
返回一个指定 collection 上的枚举。
 Enumeration<String> PropertyResourceBundle.getKeys()
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。
 Enumeration<String> ListResourceBundle.getKeys()
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。
abstract  Enumeration<String> ResourceBundle.getKeys()
返回键的枚举。
 Enumeration<K> Hashtable.keys()
返回此哈希表中的键的枚举。
abstract  Enumeration<K> Dictionary.keys()
返回此 dictionary 中的键的枚举。
 Enumeration<?> Properties.propertyNames()
返回属性列表中所有键的枚举，如果在主属性列表中未找到同名的键，则包括默认属性列表中不同的键。

参数类型为 Enumeration 的 java.util 中的方法
static
<T> ArrayList<T>
Collections.list(Enumeration<T> e)
返回一个数组列表，它按返回顺序包含指定枚举返回的元素。

java.util.concurrent 中 Enumeration 的使用

返回 Enumeration 的 java.util.concurrent 中的方法
Enumeration<V> | ConcurrentHashMap.elements() 返回此表中值的枚举。
Enumeration<K> | ConcurrentHashMap.keys() 返回此表中键的枚举。

java.util.jar 中 Enumeration 的使用

返回 Enumeration 的 java.util.jar 中的方法
 Enumeration<JarEntry> JarFile.entries()
返回 zip 文件条目的枚举。

java.util.logging 中 Enumeration 的使用

返回 Enumeration 的 java.util.logging 中的方法
 Enumeration<String> LogManager.getLoggerNames()
获取已知 logger 名称的枚举。

java.util.zip 中 Enumeration 的使用

返回 Enumeration 的 java.util.zip 中的方法
 Enumeration<? extends ZipEntry> ZipFile.entries()
返回 ZIP 文件条目的枚举。

javax.activation 中 Enumeration 的使用

返回 Enumeration 的 javax.activation 中的方法
 Enumeration MimeTypeParameterList.getNames()
获取此列表中所有名称的枚举。

javax.management.loading 中 Enumeration 的使用

返回 Enumeration 的 javax.management.loading 中的方法
 Enumeration<URL> MLetMBean.getResources(String name)
查找所有具有给定名称的资源。

javax.naming 中 Enumeration 的使用

javax.naming 中 Enumeration 的子接口
 interface NamingEnumeration<T>
此接口用于枚举 javax.naming 和 javax.naming.directory 包中的方法所返回的列表。

返回 Enumeration 的 javax.naming 中的方法
Enumeration<String> | CompositeName.getAll() 以字符串枚举的形式检索此复合名称的组件。
Enumeration<String> | CompoundName.getAll() 以字符串枚举的形式检索此组合名称的组件。
Enumeration<String> | Name.getAll() 以字符串枚举的形式检索此名称的组件。
Enumeration<RefAddr> | Reference.getAll() 返回此索引中的地址所组成的枚举。

参数类型为 Enumeration 的 javax.naming 中的构造方法
CompositeName(Enumeration<String> comps)
使用由 'comps' 指定的组件构造一个新的复合名称实例。
CompoundName(Enumeration<String> comps, Properties syntax)
使用 comps 和 syntax 指定的组件构造一个新的组合名称实例。

javax.naming.ldap 中 Enumeration 的使用

返回 Enumeration 的 javax.naming.ldap 中的方法
 Enumeration<String> LdapName.getAll()
以字符串枚举的形式检索此名称的组件。

javax.net.ssl 中 Enumeration 的使用

返回 Enumeration 的 javax.net.ssl 中的方法
 Enumeration SSLSessionContext.getIds()
返回在此 SSLSessionContext 下分组的所有会话 id 的 Enumeration。

javax.security.sasl 中 Enumeration 的使用

返回 Enumeration 的 javax.security.sasl 中的方法
static Enumeration<SaslClientFactory> | Sasl.getSaslClientFactories() 获得用于生成 SaslClient 的已知工厂的枚举。
static Enumeration<SaslServerFactory> | Sasl.getSaslServerFactories() 获得用于生成 SaslServer 的已知工厂的枚举。

javax.sql.rowset.spi 中 Enumeration 的使用

返回 Enumeration 的 javax.sql.rowset.spi 中的方法
static Enumeration<SyncProvider> SyncFactory.getRegisteredProviders()
返回当前已注册的同步提供者所组成的枚举。

javax.swing 中 Enumeration 的使用

返回 Enumeration 的 javax.swing 中的方法
Enumeration | JTree.DynamicUtilTreeNode.children() 必要时创建子类以加载此子节点。
Enumeration<?> | DefaultListModel.elements() 返回此列表的组件枚举。
protected Enumeration<TreePath> | JTree.getDescendantToggledPaths(TreePath parent) 返回已展开且为 parent 的子路径的 TreePath 的 Enumeration。
Enumeration<AbstractButton> | ButtonGroup.getElements() 返回此组中的所有按钮。
Enumeration<TreePath> | JTree.getExpandedDescendants(TreePath parent) 返回当前展开的 parent 路径的子路径的 Enumeration。

参数类型为 Enumeration 的 javax.swing 中的方法
protected  void JTree.removeDescendantToggledPaths(Enumeration<TreePath> toRemove)
移除已展开的 toRemove 中 TreePath 的所有子路径。

javax.swing.table 中 Enumeration 的使用

返回 Enumeration 的 javax.swing.table 中的方法
Enumeration<TableColumn> | DefaultTableColumnModel.getColumns() 返回该模型中所有列的一个 Enumeration。
Enumeration<TableColumn> | TableColumnModel.getColumns() 返回该模型中所有列的 Enumeration。

javax.swing.text 中 Enumeration 的使用

返回 Enumeration 的 javax.swing.text 中的方法
abstract Enumeration | AbstractDocument.AbstractElement.children() 以 Enumeration 形式返回接收方的子级。
Enumeration | AbstractDocument.BranchElement.children() 以 Enumeration 的形式返回接收者的子级。
Enumeration | AbstractDocument.LeafElement.children() 以 Enumeration 的形式返回接收者的子级。
Enumeration<?> | SimpleAttributeSet.getAttributeNames() 获取集合中的属性名称。
Enumeration<?> | AttributeSet.getAttributeNames() 返回集合中本地定义的属性名称的枚举。
Enumeration<?> | StyleContext.SmallAttributeSet.getAttributeNames() 获取所有属性的名称。
Enumeration<?> | StyleContext.NamedStyle.getAttributeNames() 获取所有属性的名称。
Enumeration<?> | AbstractDocument.AbstractElement.getAttributeNames() 获取所有属性的名称。
Enumeration<?> | DefaultStyledDocument.getStyleNames() 获取样式名称列表。
Enumeration<?> | StyleContext.getStyleNames() 获取定义的样式名称。

参数类型为 Enumeration 的 javax.swing.text 中的方法
AttributeSet | StyleContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一个属性集。
AttributeSet | AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一组属性。
void | SimpleAttributeSet.removeAttributes(Enumeration<?> names) 从列表中移除属性集。
void | MutableAttributeSet.removeAttributes(Enumeration<?> names) 移除具有给定 name 的属性集。
void | StyleContext.NamedStyle.removeAttributes(Enumeration<?> names) 移除元素的属性集。
void | AbstractDocument.AbstractElement.removeAttributes(Enumeration<?> names) 移除该元素的属性集合。

javax.swing.text.html 中 Enumeration 的使用

参数类型为 Enumeration 的 javax.swing.text.html 中的方法
 AttributeSet StyleSheet.removeAttributes(AttributeSet old, Enumeration<?> names)
移除元素的属性集。

javax.swing.text.html.parser 中 Enumeration 的使用

返回 Enumeration 的 javax.swing.text.html.parser 中的方法
 Enumeration<?> AttributeList.getValues()

javax.swing.tree 中 Enumeration 的使用

声明为 Enumeration 的 javax.swing.tree 中的字段
static Enumeration<TreeNode> DefaultMutableTreeNode.EMPTY_ENUMERATION
始终为空的枚举。

返回 Enumeration 的 javax.swing.tree 中的方法
Enumeration | DefaultMutableTreeNode.breadthFirstEnumeration() 创建并返回一个枚举，该枚举按广度优先的顺序遍历以此节点为根的子树。
Enumeration | DefaultMutableTreeNode.children() 创建并返回此节点的子节点的正向枚举。
Enumeration | TreeNode.children() 以 Enumeration 的形式返回接收者的子节点。
Enumeration | DefaultMutableTreeNode.depthFirstEnumeration() 创建并返回一个枚举，该枚举按深度优先的顺序遍历以此节点为根的子树。
Enumeration<TreePath> | FixedHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回表示从传入位置开始的可见路径的增量的 Enumerator。
Enumeration<TreePath> | VariableHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回从传入位置开始的可见路径的增量的 Enumerator。
abstract Enumeration<TreePath> | AbstractLayoutCache.getVisiblePathsFrom(TreePath path) 返回一个 Enumerator，它列举从传入位置开始的可视路径的增量。
Enumeration | DefaultMutableTreeNode.pathFromAncestorEnumeration(TreeNode ancestor) 创建并返回沿着从 ancestor 到此节点的路径的一个枚举。
Enumeration | DefaultMutableTreeNode.postorderEnumeration() 创建并返回按后序遍历以此节点为根的树的一个枚举。
Enumeration | DefaultMutableTreeNode.preorderEnumeration() 创建并返回按前序遍历以此节点为根的子树的一个枚举。

org.xml.sax.helpers 中 Enumeration 的使用

返回 Enumeration 的 org.xml.sax.helpers 中的方法
Enumeration | NamespaceSupport.getDeclaredPrefixes() 返回此上下文中声明的所有前缀的枚举。
Enumeration | NamespaceSupport.getPrefixes() 返回所有前缀的枚举，其声明在当前上下文中是活动的。
Enumeration | NamespaceSupport.getPrefixes(String uri) 返回给定 URI 的 所有前缀的枚举，给定 URI 的声明在当前上下文中是活动的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.EnumMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.EnumMap
的使用

使用 EnumMap 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 EnumMap 的使用

返回 EnumMap 的 java.util 中的方法
 EnumMap<K,V> EnumMap.clone()
返回此枚举映射的浅表副本。

参数类型为 EnumMap 的 java.util 中的构造方法
EnumMap(EnumMap<K,? extends V> m)
创建一个其键类型与指定枚举映射相同的枚举映射，最初包含相同的映射关系（如果有的话）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.EnumSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.EnumSet
的使用

使用 EnumSet 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 EnumSet 的使用

返回 EnumSet 的 java.util 中的方法
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.allOf(Class<E> elementType)
创建一个包含指定元素类型的所有元素的枚举 set。
 EnumSet<E> EnumSet.clone()
返回 set 的副本。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.complementOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含指定 set 中所不 包含的此类型的所有元素。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(Collection<E> c)
创建一个从指定 collection 初始化的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含相同的元素（如果有的话）。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.noneOf(Class<E> elementType)
创建一个具有指定元素类型的空枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E first, E... rest)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3, E e4)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3, E e4, E e5)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.range(E from, E to)
创建一个最初包含由两个指定端点所定义范围内的所有元素的枚举 set。

参数类型为 EnumSet 的 java.util 中的方法
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.complementOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含指定 set 中所不 包含的此类型的所有元素。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含相同的元素（如果有的话）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.EventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.EventListener
的使用

使用 EventListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

java.awt 中 EventListener 的使用

实现 EventListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）
protected class | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）
protected class | Container.AccessibleAWTContainer.AccessibleContainerHandler 添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。

声明为 EventListener 的 java.awt 中的字段
protected EventListener | AWTEventMulticaster.a
protected EventListener | AWTEventMulticaster.b

类型参数类型为 EventListener 的 java.awt 中的方法
<T extends EventListener>
T[]
Button.getListeners(Class<T> listenerType)
返回当前在此 Button 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Checkbox.getListeners(Class<T> listenerType)
返回目前已在此 Checkbox 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
CheckboxMenuItem.getListeners(Class<T> listenerType)
返回当前在此 CheckboxMenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Choice.getListeners(Class<T> listenerType)
返回目前已在此 Choice 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
List.getListeners(Class<T> listenerType)
返回目前已在此 List 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Scrollbar.getListeners(Class<T> listenerType)
返回目前已在此 Scrollbar 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
TextComponent.getListeners(Class<T> listenerType)
返回当前已在此 TextComponent 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
TextField.getListeners(Class<T> listenerType)
返回当前已在此 TextField 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
MenuItem.getListeners(Class<T> listenerType)
返回当前在此 MenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Window.getListeners(Class<T> listenerType)
返回当前在此 Window 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
Container.getListeners(Class<T> listenerType)
返回当前已在此 Container 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Component.getListeners(Class<T> listenerType)
返回一个当前在此 Component 上作为 FooListener 注册的所有对象的数组。
static
<T extends EventListener>
T[]
AWTEventMulticaster.getListeners(EventListener l, Class<T> listenerType)
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。

返回 EventListener 的 java.awt 中的方法
protected static EventListener AWTEventMulticaster.addInternal(EventListener a, EventListener b)
从正添加的侦听器 a 和侦听器 b 中一起返回得到的多路广播侦听器。
<T extends EventListener>
T[]
Button.getListeners(Class<T> listenerType)
返回当前在此 Button 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Checkbox.getListeners(Class<T> listenerType)
返回目前已在此 Checkbox 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
CheckboxMenuItem.getListeners(Class<T> listenerType)
返回当前在此 CheckboxMenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Choice.getListeners(Class<T> listenerType)
返回目前已在此 Choice 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
List.getListeners(Class<T> listenerType)
返回目前已在此 List 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Scrollbar.getListeners(Class<T> listenerType)
返回目前已在此 Scrollbar 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
TextComponent.getListeners(Class<T> listenerType)
返回当前已在此 TextComponent 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
TextField.getListeners(Class<T> listenerType)
返回当前已在此 TextField 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
MenuItem.getListeners(Class<T> listenerType)
返回当前在此 MenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Window.getListeners(Class<T> listenerType)
返回当前在此 Window 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
Container.getListeners(Class<T> listenerType)
返回当前已在此 Container 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Component.getListeners(Class<T> listenerType)
返回一个当前在此 Component 上作为 FooListener 注册的所有对象的数组。
static
<T extends EventListener>
T[]
AWTEventMulticaster.getListeners(EventListener l, Class<T> listenerType)
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。
protected  EventListener AWTEventMulticaster.remove(EventListener oldl)
从此多路广播器中移除一个侦听器。
protected static EventListener AWTEventMulticaster.removeInternal(EventListener l, EventListener oldl)
在从侦听器 l 中移除旧的侦听器之后，返回得到的多路广播侦听器。

参数类型为 EventListener 的 java.awt 中的方法
protected static EventListener AWTEventMulticaster.addInternal(EventListener a, EventListener b)
从正添加的侦听器 a 和侦听器 b 中一起返回得到的多路广播侦听器。
static
<T extends EventListener>
T[]
AWTEventMulticaster.getListeners(EventListener l, Class<T> listenerType)
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。
protected  EventListener AWTEventMulticaster.remove(EventListener oldl)
从此多路广播器中移除一个侦听器。
protected static EventListener AWTEventMulticaster.removeInternal(EventListener l, EventListener oldl)
在从侦听器 l 中移除旧的侦听器之后，返回得到的多路广播侦听器。
protected static void AWTEventMulticaster.save(ObjectOutputStream s, String k, EventListener l)

参数类型为 EventListener 的 java.awt 中的构造方法
AWTEventMulticaster(EventListener a, EventListener b)
创建一个将侦听器 a 和侦听器 b 链接起来的事件多路广播器实例。

java.awt.datatransfer 中 EventListener 的使用

java.awt.datatransfer 中 EventListener 的子接口
 interface FlavorListener
定义侦听 FlavorEvent 的对象。

java.awt.dnd 中 EventListener 的使用

java.awt.dnd 中 EventListener 的子接口
interface | DragGestureListener 此接口源于 DragGestureRecognizer，当该（子）类的对象检测到拖动启动动作时，调用此接口。
interface | DragSourceListener DragSourceListener 定义了事件接口，Drag 和 Drop 操作的始发端使用它来跟踪用户操作的状态，并通过 Drag 和 Drop 操作为用户提供合适的“拖动结束”反馈。
interface | DragSourceMotionListener 用于接收拖动操作期间鼠标移动事件的侦听器接口。
interface | DropTargetListener DropTargetListener 接口是 DropTarget 类所使用的回调接口，用于提供所涉及的 DropTarget 的 DnD 操作的通知。

实现 EventListener 的 java.awt.dnd 中的类
class | DragSourceAdapter 用于接收拖动源事件的抽象适配器类。
class | DragSourceContext DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。
class | DropTarget 在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
protected static class | DropTarget.DropTargetAutoScroller 此受保护的嵌套类实现自动滚动
class | DropTargetAdapter 接收放置目标事件的抽象适配器类。
class | MouseDragGestureRecognizer DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

类型参数类型为 EventListener 的 java.awt.dnd 中的方法
<T extends EventListener>
T[]
DragSource.getListeners(Class<T> listenerType)
获得目前已在此 DragSource 上注册为 FooListener 的所有对象。

返回 EventListener 的 java.awt.dnd 中的方法
<T extends EventListener>
T[]
DragSource.getListeners(Class<T> listenerType)
获得目前已在此 DragSource 上注册为 FooListener 的所有对象。

java.awt.event 中 EventListener 的使用

java.awt.event 中 EventListener 的子接口
interface | ActionListener 用于接收操作事件的侦听器接口。
interface | AdjustmentListener 用于接收调整事件的侦听器接口。
interface | AWTEventListener 该侦听器接口用于接收指派给对象的事件的通知，这些对象是 Component、MenuComponent 或其子类的实例。
interface | ComponentListener 用于接收组件事件的侦听器接口。
interface | ContainerListener 用于接收容器事件的侦听器接口。
interface | FocusListener 用于接收组件上的键盘焦点事件的侦听器接口。
interface | HierarchyBoundsListener 用于接收祖先的移动和大小调整事件的侦听器接口。
interface | HierarchyListener 用于接收层次结构更改事件的侦听器接口。
interface | InputMethodListener 接收输入方法事件的侦听器接口。
interface | ItemListener 接收项事件的侦听器接口。
interface | KeyListener 用于接收键盘事件（击键）的侦听器接口。
interface | MouseListener 用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
interface | MouseMotionListener 用于接收组件上的鼠标移动事件的侦听器接口。
interface | MouseWheelListener 用于接收组件上的鼠标滚轮事件的侦听器接口。
interface | TextListener 用于接收文本事件的侦听器接口。
interface | WindowFocusListener 用于接收 WindowEvent（包括 WINDOW_GAINED_FOCUS 和 WINDOW_LOST_FOCUS 事件）的侦听器接口。
interface | WindowListener 用于接收窗口事件的侦听器接口。
interface | WindowStateListener 用于接收窗口状态事件的侦听器接口。

实现 EventListener 的 java.awt.event 中的类
class | AWTEventListenerProxy 扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。
class | ComponentAdapter 用于接收组件事件的抽象适配器类。
class | ContainerAdapter 用于接收容器事件的抽象适配器类。
class | FocusAdapter 用于接收键盘焦点事件的抽象适配器类。
class | HierarchyBoundsAdapter 用于接收祖先的移动和大小重调事件的抽象适配器类。
class | KeyAdapter 接收键盘事件的抽象适配器类。
class | MouseAdapter 接收鼠标事件的抽象适配器类。
class | MouseMotionAdapter 接收鼠标移动事件的抽象适配器类。
class | WindowAdapter 接收窗口事件的抽象适配器类。

java.beans 中 EventListener 的使用

java.beans 中 EventListener 的子接口
interface | PropertyChangeListener 无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。
interface | VetoableChangeListener 只要 bean 更改 "constrained" 属性，都将会激发一个 VetoableChange 事件。

实现 EventListener 的 java.beans 中的类
class | PropertyChangeListenerProxy 扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。
class | VetoableChangeListenerProxy 扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。

java.beans.beancontext 中 EventListener 的使用

java.beans.beancontext 中 EventListener 的子接口
interface | BeanContextMembershipListener 当 BeanContext 的成员关系状态发生更改时，兼容的 BeanContext 在此接口上触发事件。
interface | BeanContextServiceRevokedListener 用于接收 BeanContextServiceRevokedEvent 对象的侦听器接口。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。
interface | BeanContextServicesListener 用于接收 BeanContextServiceAvailableEvent 对象的侦听器接口。

实现 EventListener 的 java.beans.beancontext 中的类
class | BeanContextChildSupport 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
protected class | BeanContextServicesSupport.BCSSProxyServiceProvider
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

java.util 中 EventListener 的使用

实现 EventListener 的 java.util 中的类
 class EventListenerProxy
将一组附加参数与侦听器关联的 EventListener 类的抽象包装器类。

返回 EventListener 的 java.util 中的方法
 EventListener EventListenerProxy.getListener()

参数类型为 EventListener 的 java.util 中的构造方法
EventListenerProxy(EventListener listener)

java.util.prefs 中 EventListener 的使用

java.util.prefs 中 EventListener 的子接口
interface | NodeChangeListener 用于接收首选项节点更改事件的侦听器。
interface | PreferenceChangeListener 用于接收首选项节点更改事件的侦听器。

javax.imageio.event 中 EventListener 的使用

javax.imageio.event 中 EventListener 的子接口
interface | IIOReadProgressListener 供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关进度的接口。
interface | IIOReadUpdateListener 供 ImageReader 实现用于通知其图像和缩略图的调用者相关像素更新的接口。
interface | IIOReadWarningListener 供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。
interface | IIOWriteProgressListener 供 ImageWriter 实现用于通知其图像和缩略图写入方法的调用者相关进度的方法。
interface | IIOWriteWarningListener 供 ImageWriter 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。

javax.management 中 EventListener 的使用

javax.management 中 EventListener 的子接口
 interface NotificationListener
应该由想要接收通知的对象来实现。

javax.management.relation 中 EventListener 的使用

实现 EventListener 的 javax.management.relation 中的类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

javax.naming.event 中 EventListener 的使用

javax.naming.event 中 EventListener 的子接口
interface | NamespaceChangeListener 指定对名称空间更改感兴趣的侦听器必须实现的方法。
interface | NamingListener 此接口是处理 NamingEvent 的侦听器接口的根。
interface | ObjectChangeListener 指定事件类型为 OBJECT_CHANGED 的 NamingEvent 侦听器必须实现的方法。

javax.naming.ldap 中 EventListener 的使用

javax.naming.ldap 中 EventListener 的子接口
 interface UnsolicitedNotificationListener
此接口用于处理 UnsolicitedNotificationEvent。

javax.net.ssl 中 EventListener 的使用

javax.net.ssl 中 EventListener 的子接口
interface | HandshakeCompletedListener 任何希望接收有关给定 SSL 连接上 SSL 协议握手结束通知的类实现此接口。
interface | SSLSessionBindingListener 想知道何时将它们绑定到 SSLSession 或从 SSLSession 解除绑定的对象实现此接口。

javax.sound.midi 中 EventListener 的使用

javax.sound.midi 中 EventListener 的子接口
interface | ControllerEventListener ControllerEventListener 接口应由一个其实例需要在 Sequencer 处理了请求的 MIDI 控制更改事件类型时接收通知的类实现。
interface | MetaEventListener MetaEventListener 接口应由其实例需要在 Sequencer 处理了 MetaMessage 时接收通知的类实现。

javax.sound.sampled 中 EventListener 的使用

javax.sound.sampled 中 EventListener 的子接口
 interface LineListener
可以注册实现 LineListener 接口的类的实例来接收行状态更改时发生的事件。

javax.sql 中 EventListener 的使用

javax.sql 中 EventListener 的子接口
interface | ConnectionEventListener 注册该对象便可获得由 PooledConnection 对象生成的事件的通知。
interface | RowSetListener 要在 RowSet 对象的生命周期内发生重要事件时得到通知的组件必须实现该接口。
interface | StatementEventListener 注册为能获得 Statement 池中 PreparedStatement 上所发生事件的通知的对象。

javax.swing 中 EventListener 的使用

javax.swing 中 EventListener 的子接口
 interface Action
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。

实现 EventListener 的 javax.swing 中的类
class | AbstractAction 此类提供 JFC Action 接口的默认实现。
protected class | AbstractButton.ButtonChangeListener 将 ChangeListener 扩展为可序列化的。
protected class | DefaultCellEditor.EditorDelegate 受保护的 (protected) EditorDelegate 类。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
protected class | JComponent.AccessibleJComponent.AccessibleContainerHandler 添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
protected class | JComponent.AccessibleJComponent.AccessibleFocusHandler 发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenu.WinListener 观察弹出窗口关闭的侦听器类。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTabbedPane.ModelListener 将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。
class | JTable JTable 用来显示和编辑常规二维单元表。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JTree.TreeModelHandler 在移除或更改节点时，监听模型并相应地更新 expandedState。
protected class | JTree.TreeSelectionRedirector 使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。
protected class | JViewport.ViewListener 视图的侦听器。
protected class | ProgressMonitor.AccessibleProgressMonitor AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。
class | ToolTipManager 管理系统中的所有 ToolTips。
protected class | ToolTipManager.insideTimerAction
protected class | ToolTipManager.outsideTimerAction
protected class | ToolTipManager.stillInsideTimerAction

类型参数类型为 EventListener 的 javax.swing 中的方法
<T extends EventListener>
T[]
AbstractSpinnerModel.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
DefaultListSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractListModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultBoundedRangeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultSingleSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultButtonModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Timer.getListeners(Class<T> listenerType)
返回目前已在此 Timer 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
JComponent.getListeners(Class<T> listenerType)
返回当前在此 JComponent 上注册为 FooListener 的所有对象所组成的数组。

返回 EventListener 的 javax.swing 中的方法
<T extends EventListener>
T[]
AbstractSpinnerModel.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
DefaultListSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractListModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultBoundedRangeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultSingleSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultButtonModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Timer.getListeners(Class<T> listenerType)
返回目前已在此 Timer 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
JComponent.getListeners(Class<T> listenerType)
返回当前在此 JComponent 上注册为 FooListener 的所有对象所组成的数组。

javax.swing.event 中 EventListener 的使用

javax.swing.event 中 EventListener 的子接口
interface | AncestorListener AncestorListener 接口支持 JComponent 或其祖先之一发生更改时进行通知。
interface | CaretListener 用于侦听文本组件插入符的位置更改的侦听器。
interface | CellEditorListener CellEditorListener 定义用于侦听 CellEditor 中更改的对象的接口
interface | ChangeListener 定义一个侦听 ChangeEvent 的对象。
interface | DocumentListener 观察者使用该接口注册以接收文本文档的更改通知。
interface | HyperlinkListener HyperlinkListener
interface | InternalFrameListener 用于接收内部窗体事件的侦听器接口。
interface | ListDataListener ListDataListener
interface | ListSelectionListener 列表选择值发生更改时收到通知的侦听器。
interface | MenuDragMouseListener 定义一个菜单鼠标拖动侦听器。
interface | MenuKeyListener MenuKeyListener
interface | MenuListener 定义一个菜单事件侦听器。
interface | MouseInputListener 实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。
interface | PopupMenuListener 弹出菜单侦听器
interface | RowSorterListener 通知 RowSorterListener 对 RowSorter 的更改。
interface | TableColumnModelListener TableColumnModelListener 定义侦听 TableColumnModel 中更改的对象的接口。
interface | TableModelListener TableModelListener 定义侦听 TableModel 中更改的对象的接口。
interface | TreeExpansionListener 当树扩展或折叠某一节点时获得通知的侦听器。
interface | TreeModelListener 定义侦听 TreeModel 中更改的对象的接口。
interface | TreeSelectionListener 当 TreeSelectionModel 中的选择发生更改时收到通知的侦听器。
interface | TreeWillExpandListener 当树扩展或折叠某一节点时获得通知的侦听器。
interface | UndoableEditListener 该接口由某个对接收有关可撤消操作的消息感兴趣的类实现。

实现 EventListener 的 javax.swing.event 中的类
class | InternalFrameAdapter 用于接收内部窗体事件的抽象适配器类。
class | MouseInputAdapter MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

类型参数类型为 EventListener 的 javax.swing.event 中的方法
<T extends EventListener>
void
EventListenerList.add(Class<T> t, T l)
将侦听器作为指定类型的侦听器进行添加。
<T extends EventListener>
T[]
EventListenerList.getListeners(Class<T> t)
返回给定类型的所有侦听器组成的数组。
<T extends EventListener>
void
EventListenerList.remove(Class<T> t, T l)
将侦听器作为指定类型的侦听器进行移除。

返回 EventListener 的 javax.swing.event 中的方法
<T extends EventListener>
T[]
EventListenerList.getListeners(Class<T> t)
返回给定类型的所有侦听器组成的数组。

javax.swing.plaf.basic 中 EventListener 的使用

实现 EventListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
class | BasicColorChooserUI.PropertyHandler 因编译器故障而被标记为 "public" 的内部类。
class | BasicComboBoxEditor 用于可编辑组合框的默认编辑器。
static class | BasicComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的子类。
class | BasicComboBoxUI.FocusHandler 失去焦点时，此侦听器将隐藏弹出部分。
class | BasicComboBoxUI.ItemHandler 此侦听器观察组合框中选择的更改。
class | BasicComboBoxUI.KeyHandler 此侦听器检查键事件是否不是导航键。
class | BasicComboBoxUI.ListDataHandler 此侦听器观察 ComboBoxModel 中的更改。
class | BasicComboBoxUI.PropertyChangeHandler 此侦听器观察在组合框中发生更改的绑定 (bound) 属性。
class | BasicComboPopup.InvocationKeyHandler 从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.InvocationMouseMotionHandler 此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。
protected class | BasicComboPopup.ItemHandler 此侦听器观察组合框中选择的更改。
class | BasicComboPopup.ListDataHandler 从 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
protected class | BasicComboPopup.ListMouseMotionHandler 在列表上移动鼠标时，此侦听器更改所选项。
protected class | BasicComboPopup.ListSelectionHandler 从 Java 2 平台 v 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
protected class | BasicComboPopup.PropertyChangeHandler 此侦听器观察已在组合框中更改的绑定 (bound) 属性 希望侦听组合框属性更改的子类应该调用超类方法来确保组合框弹出部分正确处理属性更改。
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
class | BasicDirectoryModel 文件列表的基本实现。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.SelectionListener
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.PropertyChangeHandler 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
protected class | BasicInternalFrameUI.BasicInternalFrameListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicInternalFrameUI.ComponentHandler
protected class | BasicInternalFrameUI.GlassPaneDispatcher
class | BasicInternalFrameUI.InternalFramePropertyChangeListener
class | BasicLabelUI LabelUI 的 Windows L&F 实现。
class | BasicListUI.FocusHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicListUI.ListDataHandler 在 installUI 时和只要 JList.model 属性更改时就要添加到 JList 模型的 ListDataListener。
class | BasicListUI.ListSelectionHandler 在 installUI 时和只要 JList.selectionModel 属性更改时就要添加到 JList 模型的 ListSelectionListener。
class | BasicListUI.MouseInputHandler 鼠标输入和 JList 的焦点处理。
class | BasicListUI.PropertyChangeHandler 在 installUI 时添加到 JList 的 PropertyChangeListener。
protected class | BasicMenuItemUI.MouseInputHandler
class | BasicMenuUI.ChangeHandler 从 Java 2 平台 1.4 开始，已废弃这种以前没有记录的类。
protected class | BasicMenuUI.MouseInputHandler 实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
class | BasicOptionPaneUI.ButtonActionListener 此内部类因编译器故障而被标记为“公开”。
class | BasicOptionPaneUI.PropertyChangeHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicProgressBarUI.ChangeHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicRootPaneUI RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.ModelListener 侦听模型更改的侦听器。
class | BasicScrollBarUI.PropertyChangeHandler
protected class | BasicScrollBarUI.ScrollListener 在 ScrollPane 中发起的滚动事件的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
class | BasicScrollPaneUI.HSBChangeListener 水平滚动条侦听器。
protected class | BasicScrollPaneUI.MouseWheelHandler MouseWheelHandler 是实现 MouseWheelListener 接口的内部类。
class | BasicScrollPaneUI.PropertyChangeHandler
class | BasicScrollPaneUI.ViewportChangeHandler 视口事件的侦听器。
class | BasicScrollPaneUI.VSBChangeListener 垂直滚动条侦听器。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicSliderUI.ChangeHandler 数据模型侦听器。
class | BasicSliderUI.ComponentHandler 调整事件大小的侦听器。
class | BasicSliderUI.FocusHandler 焦点更改侦听器。
class | BasicSliderUI.PropertyChangeHandler
class | BasicSliderUI.ScrollListener 滚动事件侦听器。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
class | BasicSplitPaneUI.FocusHandler JSplitPane UI 使用的 FocusListener 的实现。
class | BasicSplitPaneUI.KeyboardDownRightHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardEndHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardHomeHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardResizeToggleHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardUpLeftHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.PropertyHandler JSplitPane UI 使用的 PropertyChangeListener 的实现。
class | BasicTabbedPaneUI.FocusHandler 此类应视为“受保护”内部类。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTabbedPaneUI.PropertyChangeHandler 此类应视为“受保护”内部类。
class | BasicTabbedPaneUI.TabSelectionHandler 此类应视为“受保护”内部类。
class | BasicTableHeaderUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.FocusHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.KeyHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
static class | BasicTextUI.BasicCaret
class | BasicToolBarUI.DockingListener 此类应视为“受保护”内部类。
protected class | BasicToolBarUI.FrameListener
protected class | BasicToolBarUI.PropertyListener
protected class | BasicToolBarUI.ToolBarContListener
protected class | BasicToolBarUI.ToolBarFocusListener
class | BasicTreeUI.CellEditorHandler 侦听器负责获取单元格编辑事件并相应地更新树。
class | BasicTreeUI.ComponentHandler 滚动时更新首选大小（如果需要）。
class | BasicTreeUI.FocusHandler 失去/获得焦点时重绘前导选择行。
class | BasicTreeUI.KeyHandler 用于获取多个按键事件以适当生成事件。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。
class | BasicTreeUI.MouseInputHandler 在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。
class | BasicTreeUI.PropertyChangeHandler 树的 PropertyChangeListener。
class | BasicTreeUI.SelectionModelPropertyChangeHandler TreeSelectionModel 上的侦听器，如果模型的任何属性发生更改，则重置行选择。
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeExpansionHandler 更新 TreeState 以响应节点的展开/折叠。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreeModelHandler 将所有 TreeModel 事件转发到 TreeState。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeSelectionHandler 侦听选择模型中的更改并相应地更新显示。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。

javax.swing.plaf.metal 中 EventListener 的使用

实现 EventListener 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxEditor Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的一个子类。
class | MetalComboBoxUI.MetalPropertyChangeListener 此内部类由于编译器故障而被标记为 "public"。
protected class | MetalFileChooserUI.DirectoryComboBoxAction 当 DirectoryComboBox 已更改所选项时调用。
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.SingleClickListener
class | MetalLabelUI LabelUI 的 Windows L&F 实现。
class | MetalRootPaneUI 提供 RootPaneUI 的 metal 外观实现。
protected class | MetalSliderUI.MetalPropertyListener
protected class | MetalToolBarUI.MetalContainerListener
protected class | MetalToolBarUI.MetalDockingListener
protected class | MetalToolBarUI.MetalRolloverListener

javax.swing.table 中 EventListener 的使用

实现 EventListener 的 javax.swing.table 中的类
class | DefaultTableColumnModel JTable 的标准列处理程序。
class | JTableHeader 这是管理 JTable 的头的对象。

类型参数类型为 EventListener 的 javax.swing.table 中的方法
<T extends EventListener>
T[]
DefaultTableColumnModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractTableModel.getListeners(Class<T> listenerType)
返回一个包含当前注册为此 AbstractTableModel 上的 FooListener 的所有对象的数组。

返回 EventListener 的 javax.swing.table 中的方法
<T extends EventListener>
T[]
DefaultTableColumnModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractTableModel.getListeners(Class<T> listenerType)
返回一个包含当前注册为此 AbstractTableModel 上的 FooListener 的所有对象的数组。

javax.swing.text 中 EventListener 的使用

实现 EventListener 的 javax.swing.text 中的类
class | DefaultCaret 插入符的默认实现。
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
class | JTextComponent.AccessibleJTextComponent 此类实现 JTextComponent 类的可访问性支持。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

类型参数类型为 EventListener 的 javax.swing.text 中的方法
<T extends EventListener>
T[]
DefaultCaret.getListeners(Class<T> listenerType)
返回目前已在此插入符上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
StyleContext.NamedStyle.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
AbstractDocument.getListeners(Class<T> listenerType)
返回目前已在此文档上注册为 FooListener 的所有对象组成的数组。

返回 EventListener 的 javax.swing.text 中的方法
<T extends EventListener>
T[]
DefaultCaret.getListeners(Class<T> listenerType)
返回目前已在此插入符上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
StyleContext.NamedStyle.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
AbstractDocument.getListeners(Class<T> listenerType)
返回目前已在此文档上注册为 FooListener 的所有对象组成的数组。

javax.swing.text.html 中 EventListener 的使用

实现 EventListener 的 javax.swing.text.html 中的类
class | FormView 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
protected class | FormView.MouseEventListener 当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

javax.swing.tree 中 EventListener 的使用

实现 EventListener 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor
TreeCellEditor。

类型参数类型为 EventListener 的 javax.swing.tree 中的方法
<T extends EventListener>
T[]
DefaultTreeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultTreeSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。

返回 EventListener 的 javax.swing.tree 中的方法
<T extends EventListener>
T[]
DefaultTreeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultTreeSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。

javax.swing.undo 中 EventListener 的使用

实现 EventListener 的 javax.swing.undo 中的类
 class UndoManager
UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.EventListenerProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.EventListenerProxy
的使用

使用 EventListenerProxy 的软件包
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.awt.event 中 EventListenerProxy 的使用

java.awt.event 中 EventListenerProxy 的子类
 class AWTEventListenerProxy
扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。

java.beans 中 EventListenerProxy 的使用

java.beans 中 EventListenerProxy 的子类
class | PropertyChangeListenerProxy 扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。
class | VetoableChangeListenerProxy 扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.EventObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.EventObject
的使用

使用 EventObject 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 EventObject 的使用

java.awt 中 EventObject 的子类
 class AWTEvent
所有 AWT 事件的根事件类。

java.awt.datatransfer 中 EventObject 的使用

java.awt.datatransfer 中 EventObject 的子类
 class FlavorEvent
FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。

java.awt.dnd 中 EventObject 的使用

java.awt.dnd 中 EventObject 的子类
class | DragGestureEvent 当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。
class | DragSourceDragEvent 通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。
class | DragSourceDropEvent 通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。
class | DragSourceEvent 此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。
class | DropTargetDragEvent 通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。
class | DropTargetDropEvent 通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。
class | DropTargetEvent DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。

java.awt.event 中 EventObject 的使用

java.awt.event 中 EventObject 的子类
class | ActionEvent 指示发生了组件定义的动作的语义事件。
class | AdjustmentEvent 由 Adjustable 对象所发出的调整事件。
class | ComponentEvent 指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
class | ContainerEvent 指示容器内容因为添加或移除组件而更改的低级别事件。
class | FocusEvent 指示 Component 已获得或失去输入焦点的低级别事件。
class | HierarchyEvent 指示 Component 所属的 Component 层次结构发生更改的事件。
class | InputEvent 所有组件级别输入事件的根事件类。
class | InputMethodEvent 输入方法事件包含有关使用输入方法进行撰写的文本的信息。
class | InvocationEvent 当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。
class | ItemEvent 指示项被选定或取消选定的语义事件。
class | KeyEvent 表示组件中发生键击的事件。
class | MouseEvent 指示组件中发生鼠标动作的事件。
class | MouseWheelEvent 表示鼠标滚轮在组件中滚动的事件。
class | PaintEvent 组件级绘制事件。
class | TextEvent 指示对象文本已改变的语义事件。
class | WindowEvent 指示窗口状态改变的低级别事件。

java.beans 中 EventObject 的使用

java.beans 中 EventObject 的子类
class | IndexedPropertyChangeEvent 无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。
class | PropertyChangeEvent 无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。

java.beans.beancontext 中 EventObject 的使用

java.beans.beancontext 中 EventObject 的子类
class | BeanContextEvent BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。
class | BeanContextMembershipEvent BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。
class | BeanContextServiceAvailableEvent BeanContextServicesListener 使用此事件类型来标识将被注册的服务。
class | BeanContextServiceRevokedEvent BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。

java.util.prefs 中 EventObject 的使用

java.util.prefs 中 EventObject 的子类
class | NodeChangeEvent Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。
class | PreferenceChangeEvent Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。

javax.management 中 EventObject 的使用

javax.management 中 EventObject 的子类
class | AttributeChangeNotification 提供 MBean 所发送的属性更改通知的定义。
class | MBeanServerNotification 表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。
class | Notification Notification 类表示 MBean 所发出的通知。

javax.management.monitor 中 EventObject 的使用

javax.management.monitor 中 EventObject 的子类
 class MonitorNotification
提供对监视器 MBean 发送的通知的定义。

javax.management.relation 中 EventObject 的使用

javax.management.relation 中 EventObject 的子类
 class RelationNotification
Relation Service（关系服务）中的更改通知。

javax.management.remote 中 EventObject 的使用

javax.management.remote 中 EventObject 的子类
 class JMXConnectionNotification
在客户端连接打开或关闭时，或者当通知丢失时发出的通知。

javax.management.timer 中 EventObject 的使用

javax.management.timer 中 EventObject 的子类
 class TimerNotification
此类定义了由计时器 MBean 发送的通知。

javax.naming.event 中 EventObject 的使用

javax.naming.event 中 EventObject 的子类
class | NamingEvent 此类表示命名/目录服务触发的事件。
class | NamingExceptionEvent 此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。

javax.naming.ldap 中 EventObject 的使用

javax.naming.ldap 中 EventObject 的子类
 class UnsolicitedNotificationEvent
此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。

javax.net.ssl 中 EventObject 的使用

javax.net.ssl 中 EventObject 的子类
class | HandshakeCompletedEvent 此事件指示在给定的 SSL 连接上 SSL 握手结束。
class | SSLSessionBindingEvent 此事件向 SSLSessionBindingListener 传播。

javax.print.event 中 EventObject 的使用

javax.print.event 中 EventObject 的子类
class | PrintEvent 类 PrintEvent 是所有 Print Service API 事件的超类。
class | PrintJobAttributeEvent 类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。
class | PrintJobEvent 类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。
class | PrintServiceAttributeEvent 类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

javax.sound.sampled 中 EventObject 的使用

javax.sound.sampled 中 EventObject 的子类
 class LineEvent
LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。

javax.sql 中 EventObject 的使用

javax.sql 中 EventObject 的子类
class | ConnectionEvent 提供关于连接相关事件的源信息的 Event 对象。
class | RowSetEvent RowSet 对象发生事件时生成的 Event 对象。
class | StatementEvent StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。

javax.swing 中 EventObject 的使用

参数类型为 EventObject 的 javax.swing 中的方法
boolean | JTable.editCellAt(int row, int column, EventObject e) 如果 row 和 column 位置的索引在有效范围内，并且这些索引处的单元格是可编辑的，则以编程方式启动该位置单元格的编辑。
boolean | DefaultCellEditor.isCellEditable(EventObject anEvent) 将消息从 CellEditor 转发到 delegate。
boolean | DefaultCellEditor.EditorDelegate.isCellEditable(EventObject anEvent) 如果 anEvent 不是一个 MouseEvent，则返回 true。
boolean | AbstractCellEditor.isCellEditable(EventObject e) 返回 true。
boolean | CellEditor.isCellEditable(EventObject anEvent) 询问编辑器它是否可以使用 anEvent 开始进行编辑。
boolean | DefaultCellEditor.shouldSelectCell(EventObject anEvent) 将消息从 CellEditor 转发到 delegate。
boolean | DefaultCellEditor.EditorDelegate.shouldSelectCell(EventObject anEvent) 返回 true 指示可能选定正编辑的单元格。
boolean | AbstractCellEditor.shouldSelectCell(EventObject anEvent) 返回 true。
boolean | CellEditor.shouldSelectCell(EventObject anEvent) 如果应该选择正编辑的单元格，则返回 true，否则返回 false。
boolean | DefaultCellEditor.EditorDelegate.startCellEditing(EventObject anEvent) 返回 true 指示编辑已经开始。

javax.swing.event 中 EventObject 的使用

javax.swing.event 中 EventObject 的子类
class | AncestorEvent 报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。
class | CaretEvent CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。
class | ChangeEvent ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
class | HyperlinkEvent HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。
class | InternalFrameEvent 以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
class | ListDataEvent 定义一个封装列表更改的事件。
class | ListSelectionEvent 表现选择中更改的特征的事件。
class | MenuDragMouseEvent MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
class | MenuEvent MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。
class | MenuKeyEvent MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。
class | PopupMenuEvent PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | RowSorterEvent RowSorterEvent 提供 RowSorter 的更改通知。
class | TableColumnModelEvent TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。
class | TableModelEvent TableModelEvent 用于通知侦听器某一表模型已发生更改。
class | TreeExpansionEvent 用于标识树中的单个路径的事件。
class | TreeModelEvent 封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
class | TreeSelectionEvent 描述当前选择中的更改的事件。
class | UndoableEditEvent 指示发生了可撤消操作的事件。

javax.swing.text.html 中 EventObject 的使用

javax.swing.text.html 中 EventObject 的子类
class | FormSubmitEvent FormSubmitEvent 用于通知提交表单所需的参与者。
class | HTMLFrameHyperlinkEvent HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。

javax.swing.tree 中 EventObject 的使用

参数类型为 EventObject 的 javax.swing.tree 中的方法
protected boolean | DefaultTreeCellEditor.canEditImmediately(EventObject event) 如果 event 为 null，或者它是一个单击计数 > 2 的 MouseEvent，并且 inHitRegion 返回 true，则此方法返回 true。
boolean | DefaultTreeCellEditor.isCellEditable(EventObject event) 如果 realEditor 将 true 返回到此消息，则会通知 prepareForEditing，并返回 true。
boolean | DefaultTreeCellEditor.shouldSelectCell(EventObject event) 针对返回值，向 realEditor 发送消息。
protected boolean | DefaultTreeCellEditor.shouldStartEditingTimer(EventObject event) 如果 event 为 MouseEvent，并且单击计数为 1，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.FormatFlagsConversionMismatchException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.FormatFlagsConversionMismatchException
的使用

没有 java.util.FormatFlagsConversionMismatchException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Formattable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Formattable
的使用

没有 java.util.Formattable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.FormattableFlags 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.FormattableFlags
的使用

没有 java.util.FormattableFlags 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Formatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Formatter
的使用

使用 Formatter 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 Formatter 的使用

返回 Formatter 的 java.util 中的方法
Formatter | Formatter.format(Locale l, String format, Object... args) 使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。
Formatter | Formatter.format(String format, Object... args) 使用指定格式字符串和参数将一个格式化字符串写入此对象的目标文件中。

参数类型为 Formatter 的 java.util 中的方法
 void Formattable.formatTo(Formatter formatter, int flags, int width, int precision)
使用提供的格式器来格式化对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Formatter.BigDecimalLayoutForm 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Formatter.BigDecimalLayoutForm
的使用

使用 Formatter.BigDecimalLayoutForm 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 Formatter.BigDecimalLayoutForm 的使用

返回 Formatter.BigDecimalLayoutForm 的 java.util 中的方法
static Formatter.BigDecimalLayoutForm | Formatter.BigDecimalLayoutForm.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Formatter.BigDecimalLayoutForm[] | Formatter.BigDecimalLayoutForm.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.FormatterClosedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.FormatterClosedException
的使用

没有 java.util.FormatterClosedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.GregorianCalendar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.GregorianCalendar
的使用

使用 GregorianCalendar 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 GregorianCalendar 的使用

返回 GregorianCalendar 的 javax.xml.datatype 中的方法
abstract GregorianCalendar | XMLGregorianCalendar.toGregorianCalendar() 将此 XMLGregorianCalendar 转换为 GregorianCalendar。
abstract GregorianCalendar | XMLGregorianCalendar.toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults) 将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。

参数类型为 GregorianCalendar 的 javax.xml.datatype 中的方法
abstract  XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar(GregorianCalendar cal)
根据 GregorianCalendar 创建 XMLGregorianCalendar。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.HashMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.HashMap
的使用

使用 HashMap 的软件包
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

java.beans.beancontext 中 HashMap 的使用

声明为 HashMap 的 java.beans.beancontext 中的字段
protected HashMap | BeanContextSupport.children protected HashMap children 字段的所有访问在该对象上都将是同步的。
protected HashMap | BeanContextServicesSupport.services protected transient HashMap services 字段的所有访问在该对象上都应该是同步的。

java.util 中 HashMap 的使用

java.util 中 HashMap 的子类
 class LinkedHashMap<K,V>
Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。

javax.print.attribute.standard 中 HashMap 的使用

javax.print.attribute.standard 中 HashMap 的子类
 class PrinterStateReasons
PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.HashSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.HashSet
的使用

使用 HashSet 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

java.util 中 HashSet 的使用

java.util 中 HashSet 的子类
 class LinkedHashSet<E>
具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。

javax.print.attribute.standard 中 HashSet 的使用

javax.print.attribute.standard 中 HashSet 的子类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Hashtable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Hashtable
的使用

使用 Hashtable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

java.awt 中 Hashtable 的使用

声明为 Hashtable 的 java.awt 中的字段
protected  Hashtable<Component,GridBagConstraints> GridBagLayout.comptable
此哈希表维持组件与其网格包约束之间的关联。

java.awt.image 中 Hashtable 的使用

参数类型为 Hashtable 的 java.awt.image 中的方法
void | CropImageFilter.setProperties(Hashtable<?,?> props) 添加指示裁剪区域的属性后传递源对象的属性。
void | PixelGrabber.setProperties(Hashtable<?,?> props) setProperties 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | ReplicateScaleFilter.setProperties(Hashtable<?,?> props) 在添加一个指示所应用的缩放比例的属性后传递来自源对象的属性。
void | ImageFilter.setProperties(Hashtable<?,?> props) 添加一个属性，来指示已通过的过滤器流，并在这之后从源对象传递这些属性。
void | ImageConsumer.setProperties(Hashtable<?,?> props) 设置与此图像关联的可扩展属性列表。

参数类型为 Hashtable 的 java.awt.image 中的构造方法
BufferedImage(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
构造一个具有指定 ColorModel 和 Raster 的新 BufferedImage。
MemoryImageSource(int w, int h, ColorModel cm, byte[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, int[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, int[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用默认 RGB ColorModel 中的整数数组为 Image 对象生成数据的 ImageProducer 对象。

java.security 中 Hashtable 的使用

java.security 中 Hashtable 的子类
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

java.util 中 Hashtable 的使用

java.util 中 Hashtable 的子类
 class Properties
Properties 类表示了一个持久的属性集。

javax.management 中 Hashtable 的使用

返回 Hashtable 的 javax.management 中的方法
 Hashtable<String,String> ObjectName.getKeyPropertyList()
以哈希表的形式返回键属性。

参数类型为 Hashtable 的 javax.management 中的方法
static ObjectName ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。

参数类型为 Hashtable 的 javax.management 中的构造方法
ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。

javax.naming 中 Hashtable 的使用

声明为 Hashtable 的 javax.naming 中的字段
protected Hashtable<?,?> | CannotProceedException.environment 包含与无法继续进行的 Context 或 DirContext 方法有关的环境。
protected Hashtable<Object,Object> | InitialContext.myProps 与此 InitialContext 关联的环境。

返回 Hashtable 的 javax.naming 中的方法
Hashtable<?,?> | CannotProceedException.getEnvironment() 检索创建此异常时受影响的环境。
Hashtable<?,?> | Context.getEnvironment() 检索对此上下文有效的环境。
Hashtable<?,?> | InitialContext.getEnvironment()

参数类型为 Hashtable 的 javax.naming 中的方法
abstract  Context ReferralException.getReferralContext(Hashtable<?,?> env)
使用环境属性检索继续该方法的上下文。
protected  void InitialContext.init(Hashtable<?,?> environment)
使用所提供的环境初始化初始上下文。
 void CannotProceedException.setEnvironment(Hashtable<?,?> environment)
设置调用 getEnvironment() 时将返回的环境。

参数类型为 Hashtable 的 javax.naming 中的构造方法
InitialContext(Hashtable<?,?> environment)
使用所提供的环境构造一个初始上下文。

javax.naming.directory 中 Hashtable 的使用

参数类型为 Hashtable 的 javax.naming.directory 中的构造方法
InitialDirContext(Hashtable<?,?> environment)
使用所提供的环境构造一个初始 DirContext。

javax.naming.ldap 中 Hashtable 的使用

参数类型为 Hashtable 的 javax.naming.ldap 中的方法
static Control | ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env) 使用已知控件工厂创建控件。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env) 使用环境属性（但不使用控件）检索继续该方法的上下文。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls) 使用请求控件和环境属性检索继续该方法的上下文。

参数类型为 Hashtable 的 javax.naming.ldap 中的构造方法
InitialLdapContext(Hashtable<?,?> environment, Control[] connCtls)
使用环境属性或连接请求控件构造初始上下文。

javax.naming.spi 中 Hashtable 的使用

参数类型为 Hashtable 的 javax.naming.spi 中的方法
InitialContextFactory | InitialContextFactoryBuilder.createInitialContextFactory(Hashtable<?,?> environment) 使用指定环境创建一个初始上下文工厂。
ObjectFactory | ObjectFactoryBuilder.createObjectFactory(Object obj, Hashtable<?,?> environment) 使用所提供的环境创建一个新对象工厂。
Context | InitialContextFactory.getInitialContext(Hashtable<?,?> environment) 创建一个初始上下文，以便开始进行名称解析。
static Context | NamingManager.getInitialContext(Hashtable<?,?> env) 使用指定环境属性创建一个初始上下文工厂。
static Object | NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment) 为指定对象和环境创建一个对象实例。
Object | ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 使用指定的位置或引用信息创建一个对象。
Object | DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 使用位置或引用信息以及指定的属性创建一个对象。
static Object | DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。
static Object | NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象的状态。
Object | StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象状态。
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。
static Context | NamingManager.getURLContext(String scheme, Hashtable<?,?> environment) 为给定的 URL 方案 id 创建一个上下文。

javax.swing 中 Hashtable 的使用

javax.swing 中 Hashtable 的子类
 class UIDefaults
Swing 组件的默认值表。

声明为 Hashtable 的 javax.swing 中的字段
protected Hashtable | JTable.defaultEditorsByColumnClass 一个由对象组成的表，它显示并编辑单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。
protected Hashtable | JTable.defaultRenderersByColumnClass 一个由对象组成的表，它显示单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。

返回 Hashtable 的 javax.swing 中的方法
Hashtable | JSlider.createStandardLabels(int increment) 创建一个数字文本标签的 Hashtable，从滑块最小值处开始并使用指定的增量。
Hashtable | JSlider.createStandardLabels(int increment, int start) 创建一个数字文本标签的 Hashtable，从指定起始点处开始并使用指定的增量。
protected Hashtable<Component,Integer> | JLayeredPane.getComponentToLayer() 返回将组件映射到层的哈希表。

参数类型为 Hashtable 的 javax.swing 中的构造方法
JTree(Hashtable<?,?> value)
返回从 Hashtable 创建的 JTree，它不显示根。

javax.swing.plaf.basic 中 Hashtable 的使用

声明为 Hashtable 的 javax.swing.plaf.basic 中的字段
protected Hashtable<TreePath,Boolean> | BasicTreeUI.drawingCache 用于最小化垂直线的绘制。
protected Hashtable<File,Icon> | BasicFileChooserUI.BasicFileView.iconCache

javax.swing.text.html.parser 中 Hashtable 的使用

声明为 Hashtable 的 javax.swing.text.html.parser 中的字段
Hashtable<String,Element> | DTD.elementHash
Hashtable<Object,Entity> | DTD.entityHash

javax.swing.undo 中 Hashtable 的使用

声明为 Hashtable 的 javax.swing.undo 中的字段
protected Hashtable<Object,Object> | StateEdit.postState 编辑之后的状态信息
protected Hashtable<Object,Object> | StateEdit.preState 编辑之前的状态信息

参数类型为 Hashtable 的 javax.swing.undo 中的方法
void | StateEditable.restoreState(Hashtable<?,?> state) 收到此消息时，接收者应从 state 中提取任何相关状态。
void | StateEditable.storeState(Hashtable<Object,Object> state) 收到此消息时，接收者应把任何相关状态放置到 state 中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.IdentityHashMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IdentityHashMap
的使用

没有 java.util.IdentityHashMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.IllegalFormatCodePointException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatCodePointException
的使用

没有 java.util.IllegalFormatCodePointException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.IllegalFormatConversionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatConversionException
的使用

没有 java.util.IllegalFormatConversionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.IllegalFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatException
的使用

使用 IllegalFormatException 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 IllegalFormatException 的使用

java.util 中 IllegalFormatException 的子类
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.IllegalFormatFlagsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatFlagsException
的使用

没有 java.util.IllegalFormatFlagsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.IllegalFormatPrecisionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatPrecisionException
的使用

没有 java.util.IllegalFormatPrecisionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.IllegalFormatWidthException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatWidthException
的使用

没有 java.util.IllegalFormatWidthException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.InputMismatchException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.InputMismatchException
的使用

没有 java.util.InputMismatchException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.InvalidPropertiesFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.InvalidPropertiesFormatException
的使用

使用 InvalidPropertiesFormatException 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 InvalidPropertiesFormatException 的使用

抛出 InvalidPropertiesFormatException 的 java.util 中的方法
 void Properties.loadFromXML(InputStream in)
将指定输入流中由 XML 文档所表示的所有属性加载到此属性表中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Iterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Iterator
的使用

使用 Iterator 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio.charset.spi | java.nio.charset 包的服务提供者类。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.namespace | XML 名称空间处理。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

java.applet 中 Iterator 的使用

返回 Iterator 的 java.applet 中的方法
 Iterator<String> AppletContext.getStreamKeys()
找到此 applet 上下文中所有流对应的键。

java.awt.dnd 中 Iterator 的使用

返回 Iterator 的 java.awt.dnd 中的方法
 Iterator<InputEvent> DragGestureEvent.iterator()
返回组成动作的事件 Iterator。

java.beans.beancontext 中 Iterator 的使用

实现 Iterator 的 java.beans.beancontext 中的类
protected static class BeanContextSupport.BCSIterator
受保护的最终子类，它封装一个迭代器但实现无操作 remove() 方法。

返回 Iterator 的 java.beans.beancontext 中的方法
protected  Iterator BeanContextSupport.bcsChildren()
返回此 BeanContext 所有子级的迭代器。
 Iterator BeanContextServices.getCurrentServiceClasses()
获得此上下文的当前可用服务。
 Iterator BeanContextServicesSupport.getCurrentServiceClasses()
 Iterator BeanContextServiceAvailableEvent.getCurrentServiceSelectors()
获得与服务相关的选择器列表。
 Iterator BeanContextServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass)
由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。
 Iterator BeanContextServicesSupport.BCSSProxyServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass)
 Iterator BeanContextServices.getCurrentServiceSelectors(Class serviceClass)
通过在基础 BeanContextServiceProvider 上调用 getCurrentServiceSelectors() 获得指定服务的与服务有关的服务参数列表（服务选择器）。
 Iterator BeanContextServicesSupport.getCurrentServiceSelectors(Class serviceClass)
 Iterator BeanContextMembershipEvent.iterator()
获得受此事件影响的子级的数组。
 Iterator BeanContextSupport.iterator()
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。

java.lang 中 Iterator 的使用

返回 Iterator 的 java.lang 中的方法
 Iterator<T> Iterable.iterator()
返回一个在一组 T 类型的元素上进行迭代的迭代器。

java.nio.charset.spi 中 Iterator 的使用

返回 Iterator 的 java.nio.charset.spi 中的方法
abstract  Iterator<Charset> CharsetProvider.charsets()
创建在此提供者所支持的 charset 上进行迭代的迭代器。

java.security.cert 中 Iterator 的使用

返回 Iterator 的 java.security.cert 中的方法
Iterator<String> | CertificateFactorySpi.engineGetCertPathEncodings() 返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。
Iterator<String> | CertificateFactory.getCertPathEncodings() 返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。
Iterator<? extends PolicyNode> | PolicyNode.getChildren() 返回在此节点的子节点上进行迭代的迭代器。
abstract Iterator<String> | CertPath.getEncodings() 返回此证书路径支持的编码的迭代，默认编码方式优先。

java.sql 中 Iterator 的使用

返回 Iterator 的 java.sql 中的方法
 Iterator<Throwable> SQLException.iterator()
返回在链接的 SQLExceptions 上进行迭代的迭代器。

java.util 中 Iterator 的使用

java.util 中 Iterator 的子接口
 interface ListIterator<E>
系列表迭代器，允许程序员按任一方向遍历列表、迭代期间修改列表，并获得迭代器在列表中的当前位置。

实现 Iterator 的 java.util 中的类
 class Scanner
一个可以使用正则表达式来解析基本类型和字符串的简单文本扫描器。

返回 Iterator 的 java.util 中的方法
Iterator<E> | ArrayDeque.descendingIterator()
Iterator<E> | TreeSet.descendingIterator() 返回在此 set 元素上按降序进行迭代的迭代器。
Iterator<E> | NavigableSet.descendingIterator() 以降序返回在此 set 的元素上进行迭代的迭代器。
Iterator<E> | LinkedList.descendingIterator()
Iterator<E> | Deque.descendingIterator() 返回以逆向顺序在此双端队列的元素上进行迭代的迭代器。
Iterator<E> | ArrayDeque.iterator() 返回在此双端队列的元素上进行迭代的迭代器。
Iterator<E> | PriorityQueue.iterator() 返回在此队列中的元素上进行迭代的迭代器。
Iterator<S> | ServiceLoader.iterator() 以延迟方式加载此加载器服务的可用提供者。
Iterator<E> | TreeSet.iterator() 返回在此 set 中的元素上按升序进行迭代的迭代器。
Iterator<E> | NavigableSet.iterator() 以升序返回在此 set 的元素上进行迭代的迭代器。
Iterator<E> | AbstractSequentialList.iterator() 返回在此列表中的元素上进行迭代的迭代器（按适当顺序）。
Iterator<E> | Deque.iterator() 返回以恰当顺序在此双端队列的元素上进行迭代的迭代器。
Iterator<E> | HashSet.iterator() 返回对此 set 中元素进行迭代的迭代器。
Iterator<E> | Set.iterator() 返回在此 set 中的元素上进行迭代的迭代器。
Iterator<E> | AbstractList.iterator() 返回以恰当顺序在此列表的元素上进行迭代的迭代器。
abstract Iterator<E> | AbstractCollection.iterator() 返回在此 collection 中的元素上进行迭代的迭代器。
Iterator<E> | List.iterator() 返回按适当顺序在列表的元素上进行迭代的迭代器。
Iterator<E> | Collection.iterator() 返回在此 collection 的元素上进行迭代的迭代器。

java.util.concurrent 中 Iterator 的使用

返回 Iterator 的 java.util.concurrent 中的方法
Iterator<E> | ConcurrentSkipListSet.descendingIterator() 返回在此 set 的元素上以降序进行迭代的迭代器。
Iterator<E> | LinkedBlockingDeque.descendingIterator() 返回在此双端队列的元素上以逆向连续顺序进行迭代的迭代器。
Iterator<E> | ArrayBlockingQueue.iterator() 返回在此队列中的元素上按适当顺序进行迭代的迭代器。
Iterator<E> | BlockingDeque.iterator() 返回在此双端队列中的元素上以恰当顺序进行迭代的迭代器。
Iterator<E> | ConcurrentLinkedQueue.iterator() 返回在此队列元素上以恰当顺序进行迭代的迭代器。
Iterator<E> | ConcurrentSkipListSet.iterator() 返回在此 set 的元素上以升序进行迭代的迭代器。
Iterator<E> | CopyOnWriteArrayList.iterator() 返回以恰当顺序在此列表元素上进行迭代的迭代器。
Iterator<E> | CopyOnWriteArraySet.iterator() 返回按照元素添加顺序在此 set 中包含的元素上进行迭代的迭代器。
Iterator<E> | DelayQueue.iterator() 返回在此队列所有元素（既包括到期的，也包括未到期的）上进行迭代的迭代器。
Iterator<E> | LinkedBlockingDeque.iterator() 返回在此双端队列元素上以恰当顺序进行迭代的迭代器。
Iterator<E> | LinkedBlockingQueue.iterator() 返回在队列中的元素上按适当顺序进行迭代的迭代器。
Iterator<E> | PriorityBlockingQueue.iterator() 返回在此队列元素上进行迭代的迭代器。
Iterator<E> | SynchronousQueue.iterator() 返回一个空迭代器，其中 hasNext 始终返回 false。

javax.imageio 中 Iterator 的使用

返回 Iterator 的 javax.imageio 中的方法
static Iterator<ImageReader> | ImageIO.getImageReaders(Object input) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码所提供的 Object（通常是一个 ImageInputStream）。
static Iterator<ImageReader> | ImageIO.getImageReadersByFormatName(String formatName) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码指定格式。
static Iterator<ImageReader> | ImageIO.getImageReadersByMIMEType(String MIMEType) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定 MIME 类型的文件。
static Iterator<ImageReader> | ImageIO.getImageReadersBySuffix(String fileSuffix) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定后缀的文件。
static Iterator<ImageTranscoder> | ImageIO.getImageTranscoders(ImageReader reader, ImageWriter writer) 返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。
abstract Iterator<ImageTypeSpecifier> | ImageReader.getImageTypes(int imageIndex) 以 ImageTypeSpecifier 形式返回包含可能的图像类型的 Iterator，给定图像可能被解码成这些类型。
static Iterator<ImageWriter> | ImageIO.getImageWriters(ImageTypeSpecifier type, String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。
static Iterator<ImageWriter> | ImageIO.getImageWritersByFormatName(String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码指定格式。
static Iterator<ImageWriter> | ImageIO.getImageWritersByMIMEType(String MIMEType) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定 MIME 类型的文件。
static Iterator<ImageWriter> | ImageIO.getImageWritersBySuffix(String fileSuffix) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定后缀的文件。
Iterator<IIOImage> | ImageReader.readAll(Iterator<? extends ImageReadParam> params) 以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。

参数类型为 Iterator 的 javax.imageio 中的方法
protected static BufferedImage | ImageReader.getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height) 返回应该在其中写入解码的像素数据的 BufferedImage。
Iterator<IIOImage> | ImageReader.readAll(Iterator<? extends ImageReadParam> params) 以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。

javax.imageio.spi 中 Iterator 的使用

返回 Iterator 的 javax.imageio.spi 中的方法
 Iterator<Class<?>> ServiceRegistry.getCategories()
返回指示当前类别集的 Class 对象的 Iterator。
<T> Iterator<T>
ServiceRegistry.getServiceProviders(Class<T> category, boolean useOrdering)
返回一个包含给定类别中的所有已注册的服务提供者的 Iterator。
<T> Iterator<T>
ServiceRegistry.getServiceProviders(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
返回一个 Iterator，其包含给定类别中满足由指定的 ServiceRegistry.Filter 对象的 filter 方法定义的条件的服务提供者对象。
static
<T> Iterator<T>
ServiceRegistry.lookupProviders(Class<T> providerClass)
使用上下文类加载器定位和递增地实例化给定服务的可用的提供者。
static
<T> Iterator<T>
ServiceRegistry.lookupProviders(Class<T> providerClass, ClassLoader loader)
使用给定的类加载器搜索特定服务类的实现。

参数类型为 Iterator 的 javax.imageio.spi 中的方法
 void ServiceRegistry.registerServiceProviders(Iterator<?> providers)
将一组取自 Iterator 的服务提供者对象添加到注册表。

参数类型为 Iterator 的 javax.imageio.spi 中的构造方法
ServiceRegistry(Iterator<Class<?>> categories)
使用取自 categories 参数的一组类别构造 ServiceRegistry 实例。

javax.tools 中 Iterator 的使用

参数类型为 Iterator 的 javax.tools 中的方法
boolean | ForwardingJavaFileManager.handleOption(String current, Iterator<String> remaining)
boolean | JavaFileManager.handleOption(String current, Iterator<String> remaining) 处理一个选项。

javax.xml.crypto 中 Iterator 的使用

返回 Iterator 的 javax.xml.crypto 中的方法
 Iterator NodeSetData.iterator()
返回可按照文档顺序在此 NodeSetData 中包含的节点上进行迭代的只读迭代器。

javax.xml.crypto.dom 中 Iterator 的使用

返回 Iterator 的 javax.xml.crypto.dom 中的方法
 Iterator DOMCryptoContext.iterator()
返回可在此 DOMCryptoContext 的 Id/Element 映射集上进行迭代的只读迭代器。

javax.xml.namespace 中 Iterator 的使用

返回 Iterator 的 javax.xml.namespace 中的方法
 Iterator NamespaceContext.getPrefixes(String namespaceURI)
获取绑定到当前范围中名称空间 URI 的所有前缀。

javax.xml.soap 中 Iterator 的使用

返回 Iterator 的 javax.xml.soap 中的方法
Iterator | SOAPHeader.examineAllHeaderElements() 返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator。
Iterator | SOAPHeader.examineHeaderElements(String actor) 返回可在此 SOAPHeader 对象中具有指定的 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator。
Iterator | SOAPHeader.examineMustUnderstandHeaderElements(String actor) 返回可在此 SOAPHeader 对象中所有符合以下条件的 SOAPHeaderElement 对象上进行迭代的 Iterator：具有指定的 actor 以及一个值等于 true 的 MustUnderstand 属性。
Iterator | SOAPHeader.extractAllHeaderElements() 返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。
Iterator | SOAPHeader.extractHeaderElements(String actor) 返回可在此 SOAPHeader 对象中所有具有指定 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。
Iterator | SOAPElement.getAllAttributes() 返回可在此 SOAPElement 对象中所有属性 Name 对象上进行迭代的 Iterator。
Iterator | SOAPElement.getAllAttributesAsQNames() 返回可在此 SOAPElement 对象（以 QName 对象的形式）中的所有属性上进行迭代的 Iterator。
Iterator | MimeHeaders.getAllHeaders() 返回此 MimeHeaders 对象中的所有 MimeHeader。
abstract Iterator | AttachmentPart.getAllMimeHeaders() 以 MimeHeader 对象上的迭代器形式，检索此 AttachmentPart 对象的所有头。
abstract Iterator | SOAPPart.getAllMimeHeaders() 以可在 MimeHeader 对象上进行迭代的迭代器形式，检索此 SOAPPart 对象的所有头。
abstract Iterator | SOAPMessage.getAttachments() 检索所有作为此 SOAPMessage 对象一部分的 AttachmentPart 对象。
abstract Iterator | SOAPMessage.getAttachments(MimeHeaders headers) 检索所有头条目匹配指定头的 AttachmentPart 对象。
Iterator | SOAPElement.getChildElements() 返回可在此元素的所有直接子 Node 上进行迭代的 Iterator。
Iterator | SOAPElement.getChildElements(Name name) 返回可在带有指定名称的此元素所有直接子 Node 上进行迭代的 Iterator。
Iterator | SOAPElement.getChildElements(QName qname) 返回可在带有指定 qname 的此元素所有直接子 Node 上进行迭代的 Iterator。
Iterator | Detail.getDetailEntries() 获取在此 Detail 对象中所有 DetailEntry 上进行迭代的迭代器。
Iterator | SOAPFault.getFaultReasonLocales() 返回一个 Iterator，它可以在与 Reason Text 项关联的 Locale 独特序列上进行迭代。
Iterator | SOAPFault.getFaultReasonTexts() 返回一个 Iterator，它可以在包含此 SOAPFault 所有 Reason Text 项的 String 对象序列上进行迭代。
Iterator | SOAPFault.getFaultSubcodes() 以 QNames 迭代器形式获取此 SOAPFault 的 Subcode。
Iterator | MimeHeaders.getMatchingHeaders(String[] names) 返回其名称与给定名称数组中的任一名称匹配的所有 MimeHeader 对象。
abstract Iterator | AttachmentPart.getMatchingMimeHeaders(String[] names) 检索匹配给定数组中名称的所有 MimeHeader 对象。
abstract Iterator | SOAPPart.getMatchingMimeHeaders(String[] names) 检索与给定数组中的名称匹配的所有 MimeHeader 对象。
Iterator | SOAPElement.getNamespacePrefixes() 返回可在此元素声明的名称空间前缀 String 上进行迭代的 Iterator。
Iterator | MimeHeaders.getNonMatchingHeaders(String[] names) 返回其名称与给定名称数组中的任何名称都不匹配的所有 MimeHeader 对象。
abstract Iterator | AttachmentPart.getNonMatchingMimeHeaders(String[] names) 检索所有名称不匹配给定数组中任一名称的 MimeHeader 对象。
abstract Iterator | SOAPPart.getNonMatchingMimeHeaders(String[] names) 检索名称与给定数组中任一名称不匹配的所有 MimeHeader 对象。
Iterator | SOAPElement.getVisibleNamespacePrefixes() 返回在此元素可见的名称空间前缀 String 上进行迭代的 Iterator。

参数类型为 Iterator 的 javax.xml.soap 中的方法
 SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs)
创建使用指定的 SOAP URI 支持列表初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。

javax.xml.stream 中 Iterator 的使用

javax.xml.stream 中 Iterator 的子接口
 interface XMLEventReader
此类是用于解析 XML 事件的顶层接口。

参数类型为 Iterator 的 javax.xml.stream 中的方法
abstract EndElement | XMLEventFactory.createEndElement(QName name, Iterator namespaces) 创建一个新 EndElement。
abstract EndElement | XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces) 创建一个新 EndElement。
abstract StartElement | XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context) 创建一个新 StartElement。

javax.xml.stream.events 中 Iterator 的使用

返回 Iterator 的 javax.xml.stream.events 中的方法
Iterator | StartElement.getAttributes() 返回在此 START_ELEMENT 上声明的已声明非名称空间属性的 Iterator；如果没有这样的属性，则返回空迭代器。
Iterator | EndElement.getNamespaces() 返回超出范围名称空间的 Iterator。
Iterator | StartElement.getNamespaces() 返回在此元素上声明的名称空间的 Iterator。

javax.xml.stream.util 中 Iterator 的使用

实现 Iterator 的 javax.xml.stream.util 中的类
 class EventReaderDelegate
该类是用于派生 XMLEventReader 过滤器的基类。

javax.xml.ws 中 Iterator 的使用

返回 Iterator 的 javax.xml.ws 中的方法
 Iterator<QName> Service.getPorts()
返回一个 Iterator，它用于此服务所组合的服务端点的 QName 列表。

javax.xml.ws.spi 中 Iterator 的使用

返回 Iterator 的 javax.xml.ws.spi 中的方法
abstract  Iterator<QName> ServiceDelegate.getPorts()
返回一个 Iterator，该迭代器用于根据此服务分组的服务端点的 QName 列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.LinkedHashMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.LinkedHashMap
的使用

没有 java.util.LinkedHashMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.LinkedHashSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.LinkedHashSet
的使用

没有 java.util.LinkedHashSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.LinkedList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.LinkedList
的使用

没有 java.util.LinkedList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.List 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.List
的使用

使用 List 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。
javax.xml.stream.events |
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

java.awt 中 List 的使用

返回 List 的 java.awt 中的方法
List<Image> | Window.getIconImages() 返回要作为此窗口的图标显示的图像序列。
protected List<KeyEventDispatcher> | KeyboardFocusManager.getKeyEventDispatchers() 作为 List 返回此 KeyboardFocusManager 的 KeyEventDispatcher 链。
protected List<KeyEventPostProcessor> | KeyboardFocusManager.getKeyEventPostProcessors() 作为 List 返回此 KeyboardFocusManager 的 KeyEventPostProcessor 链。

参数类型为 List 的 java.awt 中的方法
 void Window.setIconImages(List<? extends Image> icons)
设置要作为此窗口的图标显示的图像序列。

java.awt.datatransfer 中 List 的使用

返回 List 的 java.awt.datatransfer 中的方法
List<DataFlavor> | SystemFlavorMap.getFlavorsForNative(String nat) 返回数据传输子系统可以将指定 String native 转换成的 DataFlavor 的 List。
List<DataFlavor> | FlavorTable.getFlavorsForNative(String nat) 返回与指定 String 对应的 DataFlavor 的 List。
List<String> | SystemFlavorMap.getNativesForFlavor(DataFlavor flav) 返回数据传输子系统可以将指定 DataFlavor 转换成的 String native 的 List。
List<String> | FlavorTable.getNativesForFlavor(DataFlavor flav) 返回与指定 DataFlavor 对应的 String native 的 List。

java.awt.dnd 中 List 的使用

返回 List 的 java.awt.dnd 中的方法
List<DataFlavor> | DropTargetDragEvent.getCurrentDataFlavorsAsList() 此方法以 java.util.List 形式返回当前的 DataFlavor
List<DataFlavor> | DropTargetDropEvent.getCurrentDataFlavorsAsList() 此方法以 java.util.List 形式返回当前可用的 DataFlavor。
protected List<DataFlavor> | DropTargetContext.getCurrentDataFlavorsAsList() 此方法返回 Transferable 操作数当前可用的 DataFlavor，作为一个 java.util.List。

参数类型为 List 的 java.awt.dnd 中的构造方法
DragGestureEvent(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。

java.lang 中 List 的使用

返回 List 的 java.lang 中的方法
 List<String> ProcessBuilder.command()
返回此进程生成器的操作系统程序和参数。

参数类型为 List 的 java.lang 中的方法
 ProcessBuilder ProcessBuilder.command(List<String> command)
设置此进程生成器的操作系统程序和参数。

参数类型为 List 的 java.lang 中的构造方法
ProcessBuilder(List<String> command)
利用指定的操作系统程序和参数构造一个进程生成器。

java.lang.management 中 List 的使用

返回 List 的 java.lang.management 中的方法
static List<GarbageCollectorMXBean> | ManagementFactory.getGarbageCollectorMXBeans() 返回 Java 虚拟机中的 GarbageCollectorMXBean 对象列表。
List<String> | RuntimeMXBean.getInputArguments() 返回传递给 Java 虚拟机的输入变量，其中不包括传递给 main 方法的变量。
static List<MemoryManagerMXBean> | ManagementFactory.getMemoryManagerMXBeans() 返回 Java 虚拟机中的 MemoryManagerMXBean 对象列表。
static List<MemoryPoolMXBean> | ManagementFactory.getMemoryPoolMXBeans() 返回 Java 虚拟机中的 MemoryPoolMXBean 对象列表。

java.net 中 List 的使用

返回 List 的 java.net 中的方法
List<HttpCookie> | CookieStore.get(URI uri) 获取与给定 URI 关联或其域与给定 URI 匹配的 cookie。
List<HttpCookie> | CookieStore.getCookies() 获取 cookie 存储区中所有未过期的 cookie。
List<InterfaceAddress> | NetworkInterface.getInterfaceAddresses() 获取此网络接口的全部或部分 InterfaceAddresses 所组成的列表。
abstract List<Certificate> | SecureCacheResponse.getLocalCertificateChain() 返回在获得了网络资源的初始连接的联络期间发送到服务器的证书链。
abstract List<Certificate> | SecureCacheResponse.getServerCertificateChain() 从缓存返回服务器的证书链，该证书链是作为在获得了网络资源的初始连接中定义会话的一部分建立的。
List<URI> | CookieStore.getURIs() 获取所有标识此 cookie 存储区中 cookie 的 URI。
static List<HttpCookie> | HttpCookie.parse(String header) 根据 set-cookie 或 set-cookie2 头字符串构造 cookie。
abstract List<Proxy> | ProxySelector.select(URI uri) 基于访问资源所需的协议和访问资源的目标地址选择所有可用的代理。

返回变量类型为 List 的类型的 java.net 中的方法
abstract Map<String,List<String>> | CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
Map<String,List<String>> | CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
Map<String,List<String>> | URLConnection.getHeaderFields() 返回头字段的不可修改的 Map。
abstract Map<String,List<String>> | CacheResponse.getHeaders() 以 Map 的形式返回响应头。
Map<String,List<String>> | URLConnection.getRequestProperties() 返回一个由此连接的一般请求属性构成的不可修改的 Map。

类型变量类型为 List 的 java.net 中的方法参数
abstract Map<String,List<String>> | CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
Map<String,List<String>> | CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
abstract CacheResponse | ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders) 根据请求的 uri、请求方法和请求头获取缓存的响应。
abstract void | CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders) 将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
void | CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)

java.security 中 List 的使用

参数类型为 List 的 java.security 中的构造方法
Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

java.security.cert 中 List 的使用

返回 List 的 java.security.cert 中的方法
abstract List<? extends Certificate> | CertPath.getCertificates() 返回此证书路径中的证书列表。
List<PKIXCertPathChecker> | PKIXParameters.getCertPathCheckers() 返回证书路径检查器的 List。
List<CertStore> | PKIXParameters.getCertStores() 返回用于查找证书和 CRL 的不可变 CertStore List。
List<String> | X509Certificate.getExtendedKeyUsage() 获取一个不可修改的 String 列表，表示已扩展的密钥使用扩展 (OID = 2.5.29.37) 中 ExtKeyUsageSyntax 字段的对象标识符（OBJECT IDENTIFIER）。

返回变量类型为 List 的类型的 java.security.cert 中的方法
Collection<List<?>> | X509Certificate.getIssuerAlternativeNames() 从 IssuerAltName 扩展 (OID = 2.5.29.18) 中获取一个发布方替换名称的不可变集合。
Collection<List<?>> | X509CertSelector.getPathToNames() 返回 pathToNames 标准的一个副本。
Collection<List<?>> | X509CertSelector.getSubjectAlternativeNames() 返回 subjectAlternativeNames 标准的一个副本。
Collection<List<?>> | X509Certificate.getSubjectAlternativeNames() 从 SubjectAltName 扩展 (OID = 2.5.29.17) 中获取一个主体替换名称的不可变集合。

参数类型为 List 的 java.security.cert 中的方法
CertPath | CertificateFactorySpi.engineGenerateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
CertPath | CertificateFactory.generateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。
void | PKIXParameters.setCertPathCheckers(List<PKIXCertPathChecker> checkers) 设置其他证书路径检查器的 List。
void | PKIXParameters.setCertStores(List<CertStore> stores) 设置在查找证书和 CRL 时所使用的 CertStore 列表。

类型变量类型为 List 的 java.security.cert 中的方法参数
void | X509CertSelector.setPathToNames(Collection<List<?>> names) 设置 pathToNames 标准。
void | X509CertSelector.setSubjectAlternativeNames(Collection<List<?>> names) 设置 subjectAlternativeNames 标准。

java.util 中 List 的使用

实现 List 的 java.util 中的类
class | AbstractList<E> 此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
class | AbstractSequentialList<E> 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | LinkedList<E> List 接口的链接列表实现。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | Vector<E> Vector 类可以实现可增长的对象数组。

声明为 List 的 java.util 中的字段
static List | Collections.EMPTY_LIST 空的列表（不可变的）。
static List<String> | ResourceBundle.Control.FORMAT_CLASS 包含 "java.class" 的纯类 (class-only) 格式 List。
static List<String> | ResourceBundle.Control.FORMAT_DEFAULT 默认的格式 List，它包含字符串 "java.class" 和 "java.properties"（按此顺序）。
static List<String> | ResourceBundle.Control.FORMAT_PROPERTIES 包含 "java.properties" 的纯属性 (properties-only) 格式 List。

返回 List 的 java.util 中的方法
static
<T> List<T>
Arrays.asList(T... a)
返回一个受指定数组支持的固定大小的列表。
static
<E> List<E>
Collections.checkedList(List<E> list, Class<E> type)
返回指定列表的一个动态类型安全视图。
static
<T> List<T>
Collections.emptyList()
返回空的列表（不可变的）。
 List<Locale> ResourceBundle.Control.getCandidateLocales(String baseName, Locale locale)
返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。
 List<String> ResourceBundle.Control.getFormats(String baseName)
返回 String 的 List，它包含要用于加载给定 baseName 的资源包的格式。
static
<T> List<T>
Collections.nCopies(int n, T o)
返回由指定对象的 n 个副本组成的不可变列表。
static
<T> List<T>
Collections.singletonList(T o)
返回一个只包含指定对象的不可变列表。
 List<E> Vector.subList(int fromIndex, int toIndex)
返回此 List 的部分视图，元素范围为从 fromIndex（包括）到 toIndex（不包括）。
 List<E> AbstractList.subList(int fromIndex, int toIndex)
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。
 List<E> List.subList(int fromIndex, int toIndex)
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。
static
<T> List<T>
Collections.synchronizedList(List<T> list)
返回指定列表支持的同步（线程安全的）列表。
static
<T> List<T>
Collections.unmodifiableList(List<? extends T> list)
返回指定列表的不可修改视图。

参数类型为 List 的 java.util 中的方法
static
<T> int
Collections.binarySearch(List<? extends Comparable<? super T>> list, T key)
使用二分搜索法搜索指定列表，以获得指定对象。
static
<T> int
Collections.binarySearch(List<? extends T> list, T key, Comparator<? super T> c)
使用二分搜索法搜索指定列表，以获得指定对象。
static
<E> List<E>
Collections.checkedList(List<E> list, Class<E> type)
返回指定列表的一个动态类型安全视图。
static
<T> void
Collections.copy(List<? super T> dest, List<? extends T> src)
将所有元素从一个列表复制到另一个列表。
static
<T> void
Collections.copy(List<? super T> dest, List<? extends T> src)
将所有元素从一个列表复制到另一个列表。
static
<T> void
Collections.fill(List<? super T> list, T obj)
使用指定元素替换指定列表中的所有元素。
static ResourceBundle.Control ResourceBundle.Control.getControl(List<String> formats)
返回 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats。
static ResourceBundle.Control ResourceBundle.Control.getNoFallbackControl(List<String> formats)
返回一个 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats，getFallbackLocale 方法在其中返回 null。
static int Collections.indexOfSubList(List<?> source, List<?> target)
返回指定源列表中第一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
static int Collections.indexOfSubList(List<?> source, List<?> target)
返回指定源列表中第一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
static int Collections.lastIndexOfSubList(List<?> source, List<?> target)
返回指定源列表中最后一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
static int Collections.lastIndexOfSubList(List<?> source, List<?> target)
返回指定源列表中最后一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
static
<T> boolean
Collections.replaceAll(List<T> list, T oldVal, T newVal)
使用另一个值替换列表中出现的所有某一指定值。
static void Collections.reverse(List<?> list)
反转指定列表中元素的顺序。
static void Collections.rotate(List<?> list, int distance)
根据指定的距离轮换指定列表中的元素。
static void Collections.shuffle(List<?> list)
使用默认随机源对指定列表进行置换。
static void Collections.shuffle(List<?> list, Random rnd)
使用指定的随机源对指定列表进行置换。
static
<T extends Comparable<? super T>>
void
Collections.sort(List<T> list)
根据元素的自然顺序 对指定列表按升序进行排序。
static
<T> void
Collections.sort(List<T> list, Comparator<? super T> c)
根据指定比较器产生的顺序对指定列表进行排序。
static void Collections.swap(List<?> list, int i, int j)
在指定列表的指定位置处交换元素。
static
<T> List<T>
Collections.synchronizedList(List<T> list)
返回指定列表支持的同步（线程安全的）列表。
static
<T> List<T>
Collections.unmodifiableList(List<? extends T> list)
返回指定列表的不可修改视图。

java.util.concurrent 中 List 的使用

实现 List 的 java.util.concurrent 中的类
 class CopyOnWriteArrayList<E>
ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。

返回 List 的 java.util.concurrent 中的方法
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
 List<Runnable> ExecutorService.shutdownNow()
试图停止所有正在执行的活动任务，暂停处理正在等待的任务，并返回等待执行的任务列表。
 List<Runnable> ScheduledThreadPoolExecutor.shutdownNow()
尝试停止所有正在执行的任务、暂停等待任务的处理，并返回等待执行的任务列表。
 List<Runnable> ThreadPoolExecutor.shutdownNow()
尝试停止所有的活动执行任务、暂停等待任务的处理，并返回等待执行的任务列表。
 List<E> CopyOnWriteArrayList.subList(int fromIndex, int toIndex)
返回此列表中 fromIndex（包括）和 toIndex（不包括）之间部分的视图。

java.util.logging 中 List 的使用

返回 List 的 java.util.logging 中的方法
 List<String> LoggingMXBean.getLoggerNames()
返回当前已注册的 logger 列表。

javax.imageio 中 List 的使用

声明为 List 的 javax.imageio 中的字段
protected List<IIOReadProgressListener> | ImageReader.progressListeners 当前已注册 IIOReadProgressListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<IIOWriteProgressListener> | ImageWriter.progressListeners 当前已注册 IIOWriteProgressListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。
protected List<? extends BufferedImage> | IIOImage.thumbnails BufferedImage 缩略图的 List，或为 null。
protected List<IIOReadUpdateListener> | ImageReader.updateListeners 当前已注册 IIOReadUpdateListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<IIOReadWarningListener> | ImageReader.warningListeners 当前已注册 IIOReadWarningListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<IIOWriteWarningListener> | ImageWriter.warningListeners 当前已注册 IIOWriteWarningListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。
protected List<Locale> | ImageReader.warningLocales 与每个当前已注册 IIOReadWarningListener 关联的 Locale 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<Locale> | ImageWriter.warningLocales Locale 的 List，warningListeners 的每个元素都有一个 Locale 列表，默认情况下该列表被初始化为 null，它与空 List 同义。

返回 List 的 javax.imageio 中的方法
 List<? extends BufferedImage> IIOImage.getThumbnails()
返回缩略图 BufferedImage 的当前 List，如果没有设置任何缩略图，则返回 null。

参数类型为 List 的 javax.imageio 中的方法
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | IIOImage.setThumbnails(List<? extends BufferedImage> thumbnails) 将缩略图列表设置为 BufferedImage 的一个新 List 或 null。

参数类型为 List 的 javax.imageio 中的构造方法
IIOImage(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。
IIOImage(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。

javax.imageio.metadata 中 List 的使用

参数类型为 List 的 javax.imageio.metadata 中的方法
protected  void IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)
将新属性添加到以前定义的元素中，该元素将由一组枚举值定义。
protected
<T> void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

javax.lang.model.element 中 List 的使用

返回 List 的 javax.lang.model.element 中的方法
List<? extends AnnotationMirror> | Element.getAnnotationMirrors() 返回直接存在于此元素上的注释。
List<? extends TypeMirror> | TypeParameterElement.getBounds() 返回此类型参数的边界。
List<? extends Element> | Element.getEnclosedElements() 返回此元素直接封装（非严格意义上）的元素。
List<? extends TypeMirror> | TypeElement.getInterfaces() 返回直接由此类实现或直接由此接口扩展的接口类型。
List<? extends VariableElement> | ExecutableElement.getParameters() 返回此 executable 的形参。
List<? extends TypeMirror> | ExecutableElement.getThrownTypes() 按声明顺序返回此方法或构造方法的 throws 子句中所列出的异常和其他 throwable。
List<? extends TypeParameterElement> | ExecutableElement.getTypeParameters() 按照声明顺序返回此 executable 的形式类型参数。
List<? extends TypeParameterElement> | TypeElement.getTypeParameters() 按照声明顺序返回此类型元素的形式类型参数。

参数类型为 List 的 javax.lang.model.element 中的方法
 R AnnotationValueVisitor.visitArray(List<? extends AnnotationValue> vals, P p)
访问注释中的 array 值。

javax.lang.model.type 中 List 的使用

返回 List 的 javax.lang.model.type 中的方法
List<? extends TypeMirror> | ExecutableType.getParameterTypes() 返回此 executable 的形参类型。
List<? extends TypeMirror> | ExecutableType.getThrownTypes() 返回此 executable 的 throws 子句中列出的异常和其他 throwable。
List<? extends TypeMirror> | DeclaredType.getTypeArguments() 返回此类型的实际类型参数。
List<? extends TypeMirror> | MirroredTypesException.getTypeMirrors() 返回对应于要访问的类型的类型镜像。
List<? extends TypeVariable> | ExecutableType.getTypeVariables() 返回由此 executable 的形式类型参数所声明的类型变量。

参数类型为 List 的 javax.lang.model.type 中的构造方法
MirroredTypesException(List<? extends TypeMirror> types)
构造一个针对指定类型的新 MirroredTypesException。

javax.lang.model.util 中 List 的使用

返回 List 的 javax.lang.model.util 中的方法
static List<ExecutableElement> | ElementFilter.constructorsIn(Iterable<? extends Element> elements) elements 中构造方法的列表。
List<? extends TypeMirror> | Types.directSupertypes(TypeMirror t) 返回类型的直接超类型。
static List<VariableElement> | ElementFilter.fieldsIn(Iterable<? extends Element> elements) 返回 elements 中字段的列表。
List<? extends AnnotationMirror> | Elements.getAllAnnotationMirrors(Element e) 返回元素的所有注释，不管是继承的还是直接存在的。
List<? extends Element> | Elements.getAllMembers(TypeElement type) 返回类型元素的所有成员，不管是继承的还是直接声明的。
static List<ExecutableElement> | ElementFilter.methodsIn(Iterable<? extends Element> elements) 返回 elements 中方法的列表。
static List<PackageElement> | ElementFilter.packagesIn(Iterable<? extends Element> elements) 返回 elements 中包的列表。
static List<TypeElement> | ElementFilter.typesIn(Iterable<? extends Element> elements) 返回 elements 中类型的列表。

参数类型为 List 的 javax.lang.model.util 中的方法
 R SimpleAnnotationValueVisitor6.visitArray(List<? extends AnnotationValue> vals, P p)
访问注释中的 array 值。

javax.management 中 List 的使用

实现 List 的 javax.management 中的类
 class AttributeList
表示 MBean 属性值的列表。

返回 List 的 javax.management 中的方法
 List<Attribute> AttributeList.asList()
以 List<Attribute> 的形式返回此列表的视图。

参数类型为 List 的 javax.management 中的构造方法
AttributeList(List<Attribute> list)
构造一个包含指定 List 的元素的 AttributeList，这些元素按 List 的迭代器返回的顺序排列。

javax.management.loading 中 List 的使用

返回 List 的 javax.management.loading 中的方法
List<String> | MLetContent.getParameterTypes() 获取 MLET 标记中每个嵌套 <PARAM> 标记中的 TYPE 属性值的列表。
List<String> | MLetContent.getParameterValues() 获取 MLET 标记中每个嵌套 <PARAM> 标记中的 VALUE 属性值的列表。

参数类型为 List 的 javax.management.loading 中的构造方法
MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。
MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

javax.management.openmbean 中 List 的使用

声明为 List 的 javax.management.openmbean 中的字段
static List<String> OpenType.ALLOWED_CLASSNAMES_LIST
开放数据值允许的 Java 类的完全限定名称的列表。

返回 List 的 javax.management.openmbean 中的方法
 List<String> TabularType.getIndexNames()
按照提供此实例的构造方法的顺序返回一个不可修改的项名称列表，可以使用该列表的值唯一地索引此 TabularType 实例所描述的表格数据值的每个行元素。

javax.management.relation 中 List 的使用

实现 List 的 javax.management.relation 中的类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

返回 List 的 javax.management.relation 中的方法
List<Role> | RoleList.asList() 以 List<Role> 的形式返回此列表的示图。
List<RoleUnresolved> | RoleUnresolvedList.asList() 以 List<RoleUnresolved> 的形式返回此列表的视图。
List<String> | RelationService.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
List<String> | RelationServiceMBean.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
List<String> | RelationService.getAllRelationIds() 返回由 Relation Service 处理的所有关系的所有关系 id。
List<String> | RelationServiceMBean.getAllRelationIds() 返回由 Relation Service 处理的所有关系的所有关系 id。
List<String> | RelationService.getAllRelationTypeNames() 检索所有已知关系类型的名称。
List<String> | RelationServiceMBean.getAllRelationTypeNames() 检索所有已知关系类型的名称。
List<ObjectName> | RelationNotification.getMBeansToUnregister() 返回因为关系移除而需要注销的 MBean 的 ObjectName 列表（仅限于关系移除）。
List<ObjectName> | RelationNotification.getNewRoleValue() 返回更新的角色的新值（仅限于角色更新）。
List<ObjectName> | RelationNotification.getOldRoleValue() 返回更新的角色的旧值（仅限于角色更新）。
List<ObjectName> | Relation.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationSupport.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<RoleInfo> | RelationType.getRoleInfos() 返回角色定义的列表（RoleInfo 对象的 ArrayList）。
List<RoleInfo> | RelationTypeSupport.getRoleInfos() 返回角色定义的列表（RoleInfo 对象的 ArrayList）。
List<RoleInfo> | RelationService.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
List<RoleInfo> | RelationServiceMBean.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
List<ObjectName> | Role.getRoleValue() 检索角色值。
List<ObjectName> | RoleUnresolved.getRoleValue() 检索角色值。

返回变量类型为 List 的类型的 javax.management.relation 中的方法
Map<ObjectName,List<String>> | RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<String,List<String>> | RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在引用给定 MBean 的引用关系。
Map<String,List<String>> | RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在其中引用给定 MBean 的关系。
Map<ObjectName,List<String>> | Relation.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationSupport.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationService.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。

参数类型为 List 的 javax.management.relation 中的方法
static String | Role.roleValueToString(List<ObjectName> roleValue) 返回给定角色值的字符串。
void | RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | Role.setRoleValue(List<ObjectName> roleValue) 设置角色值。
void | RoleUnresolved.setRoleValue(List<ObjectName> value) 设置角色值。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

参数类型为 List 的 javax.management.relation 中的构造方法
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
Role(String roleName, List<ObjectName> roleValue)
创建一个新的 Role 对象。
RoleList(List<Role> list)
构造一个包含指定 List 元素的 RoleList，这些元素按 List 迭代器返回的顺序排列。
RoleUnresolved(String name, List<ObjectName> value, int pbType)
构造方法。
RoleUnresolvedList(List<RoleUnresolved> list)
构造一个包含指定 List 元素的 RoleUnresolvedList，这些元素按 List 迭代器返回的顺序排列。

javax.naming.ldap 中 List 的使用

返回 List 的 javax.naming.ldap 中的方法
 List<Rdn> LdapName.getRdns()
检索相对标识名列表。

参数类型为 List 的 javax.naming.ldap 中的方法
Name | LdapName.addAll(int posn, List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称中的指定位置。
Name | LdapName.addAll(List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称的末尾。
boolean | LdapName.endsWith(List<Rdn> rdns) 确定指定的 RDN 序列是否形成此 LDAP 名称的后缀。
boolean | LdapName.startsWith(List<Rdn> rdns) 确定指定的 RDN 序列是否形成此 LDAP 名称的前缀。

参数类型为 List 的 javax.naming.ldap 中的构造方法
LdapName(List<Rdn> rdns)
在给定已解析 RDN 组件的情况下构造 LDAP 名称。

javax.net.ssl 中 List 的使用

返回 List 的 javax.net.ssl 中的方法
 List KeyStoreBuilderParameters.getParameters()
返回此对象封装的不可修改的 KeyStore.Builder 列表。

参数类型为 List 的 javax.net.ssl 中的构造方法
KeyStoreBuilderParameters(List parameters)
根据 KeyStore.Builder 的列表构造新的 KeyStoreBuilderParameters。

javax.script 中 List 的使用

返回 List 的 javax.script 中的方法
List<ScriptEngineFactory> | ScriptEngineManager.getEngineFactories() 返回一个数组，该数组的元素是发现机制找到的所有 ScriptEngineFactory 类的实例。
List<String> | ScriptEngineFactory.getExtensions() 返回文件扩展名的不可变列表，这些扩展名通常标识使用此 ScriptEngine 支持的语言所编写的脚本。
List<String> | ScriptEngineFactory.getMimeTypes() 返回 mimetypes 的不可变列表，这些 mimetypes 与可由引擎执行的脚本关联。
List<String> | ScriptEngineFactory.getNames() 返回 ScriptEngine 短名称的不可变列表，这些名称由 ScriptEngineManager 用来标识 ScriptEngine。
List<Integer> | ScriptContext.getScopes() 返回 ScriptContext 中所有有效范围值的不可变 List。
List<Integer> | SimpleScriptContext.getScopes() 返回 ScriptContext 中所有有效范围值的不可变 List。

javax.sound.midi 中 List 的使用

返回 List 的 javax.sound.midi 中的方法
List<Receiver> | MidiDevice.getReceivers() 返回与该 MidiDevice 连接的所有当前活动的、非关闭的接收器。
List<Transmitter> | MidiDevice.getTransmitters() 返回与该 MidiDevice 连接的所有当前活动的、非关闭的传输器。

javax.swing 中 List 的使用

返回 List 的 javax.swing 中的方法
List<?> | SpinnerListModel.getList() 返回定义此模型的序列的 List。
List<? extends RowSorter.SortKey> | DefaultRowSorter.getSortKeys() 返回当前排序键。
abstract List<? extends RowSorter.SortKey> | RowSorter.getSortKeys() 返回当前排序键。

参数类型为 List 的 javax.swing 中的方法
protected void | SwingWorker.process(List<V> chunks) 在事件指派线程 上异步地从 publish 方法接收数据块。
void | SpinnerListModel.setList(List<?> list) 更改定义此序列的列表，并将该模型 value 的索引重新设置为零。
void | DefaultRowSorter.setSortKeys(List<? extends RowSorter.SortKey> sortKeys) 设置排序键。
abstract void | RowSorter.setSortKeys(List<? extends RowSorter.SortKey> keys) 设置当前排序键。

参数类型为 List 的 javax.swing 中的构造方法
SpinnerListModel(List<?> values)
构造一个由指定 List 定义其值序列的 SpinnerModel。

javax.tools 中 List 的使用

返回 List 的 javax.tools 中的方法
 List<Diagnostic<? extends S>> DiagnosticCollector.getDiagnostics()
获取此对象收集的诊断所组成的列表视图。

javax.xml.crypto.dsig 中 List 的使用

返回 List 的 javax.xml.crypto.dsig 中的方法
List | SignatureProperty.getContent() 返回一个不可修改的列表，由包含在此 SignatureProperty 中的一个或多个 XMLStructure 组成。
List | XMLObject.getContent() 返回一个可修改列表，由包含在此 XMLObject 中的 XMLStructure 组成，其中 XMLObject 表示来自任何命名空间的元素。
List | XMLSignature.getObjects() 返回一个可修改的列表，由包含在此 XMLSignature 中的 XMLObject 组成。
List | SignatureProperties.getProperties() 返回一个可修改的列表，由包含此在 SignatureProperties 中的一个或多个 SignatureProperty 组成。
List | Manifest.getReferences() 返回一个不可修改的列表，由包含在此 Manifest 中的一个或多个 Reference 组成。
List | SignedInfo.getReferences() 返回一个或多个 Reference 的不可修改的列表。
List | Reference.getTransforms() 返回一个 不可修改的列表，由包含在此 Reference 中的 Transform 组成。

参数类型为 List 的 javax.xml.crypto.dsig 中的方法
abstract Manifest | XMLSignatureFactory.newManifest(List references) 创建包含指定的 Reference 列表的 Manifest。
abstract Manifest | XMLSignatureFactory.newManifest(List references, String id) 创建包含指定的 Reference 列表和可选 id 的 Manifest。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue) 创建带指定参数和预计算的摘要值的 Reference。
abstract SignatureProperties | XMLSignatureFactory.newSignatureProperties(List properties, String id) 创建包含指定的 SignatureProperty 列表和可选 id 的 SignatureProperties。
abstract SignatureProperty | XMLSignatureFactory.newSignatureProperty(List content, String target, String id) 创建包含指定的 XMLStructure 列表、目标 URI 和可选 id 的SignatureProperty。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references) 创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id) 创建带指定参数的 SignedInfo。
abstract XMLObject | XMLSignatureFactory.newXMLObject(List content, String id, String mimeType, String encoding) 根据指定参数创建 XMLObject。
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId) 创建一个 XMLSignature，并使用指定的参数对其进行初始化。

javax.xml.crypto.dsig.keyinfo 中 List 的使用

返回 List 的 javax.xml.crypto.dsig.keyinfo 中的方法
List | KeyInfo.getContent() 返回包含密钥信息的 unmodifiable list。
List | X509Data.getContent() 返回一个不可修改的列表，由此 X509Data 的内容组成。
List | PGPData.getExternalElements() 返回一个不可修改列表，由表示外部名称空间元素中的 XMLStructure 组成。
List | RetrievalMethod.getTransforms() 返回一个不可修改的列表，由此 RetrievalMethod 的 Transform 组成。

参数类型为 List 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract KeyInfo | KeyInfoFactory.newKeyInfo(List content) 创建包含指定的密钥信息类型列表的 KeyInfo。
abstract KeyInfo | KeyInfoFactory.newKeyInfo(List content, String id) 创建包含指定的密钥信息类型列表和可选 id 的 KeyInfo。
abstract PGPData | KeyInfoFactory.newPGPData(byte[] keyId, byte[] keyPacket, List other) 根据指定的 PGP 公钥标识符、可选的密钥材料包和外部元素的列表，创建 PGPData。
abstract PGPData | KeyInfoFactory.newPGPData(byte[] keyPacket, List other) 根据指定的 PGP 密钥材料包和可选的外部元素列表创建 PGPData。
abstract RetrievalMethod | KeyInfoFactory.newRetrievalMethod(String uri, String type, List transforms) 根据指定的参数创建 RetrievalMethod。
abstract X509Data | KeyInfoFactory.newX509Data(List content) 创建包含指定的 X.509 内容列表的 X509Data。

javax.xml.crypto.dsig.spec 中 List 的使用

返回 List 的 javax.xml.crypto.dsig.spec 中的方法
List | ExcC14NParameterSpec.getPrefixList() 返回相容名称空间前缀列表。
List | XPathFilter2ParameterSpec.getXPathList() 返回一个列表，由一个或多个 XPathType 对象组成。

参数类型为 List 的 javax.xml.crypto.dsig.spec 中的构造方法
ExcC14NParameterSpec(List prefixList)
创建带有指定前缀列表的 ExcC14NParameterSpec。
XPathFilter2ParameterSpec(List xPathList)
创建一个 XPathFilter2ParameterSpec。

javax.xml.stream.events 中 List 的使用

返回 List 的 javax.xml.stream.events 中的方法
List | DTD.getEntities() 返回一个列表，其中包含在 DTD 中声明的外部和内部常规实体。
List | DTD.getNotations() 返回一个 List，其中包含在 DTD 中声明的注释。

javax.xml.ws 中 List 的使用

返回 List 的 javax.xml.ws 中的方法
List<Handler> | Binding.getHandlerChain() 获取协议绑定实例处理程序链的副本。
abstract List<Source> | Endpoint.getMetadata() 返回服务的元数据文档列表。

参数类型为 List 的 javax.xml.ws 中的方法
void | Binding.setHandlerChain(List<Handler> chain) 设置协议绑定实例的处理程序链。
abstract void | Endpoint.setMetadata(List<Source> metadata) 设置此端点的元数据。

javax.xml.ws.handler 中 List 的使用

返回 List 的 javax.xml.ws.handler 中的方法
 List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
获取指定端口的处理程序链。

javax.xml.xpath 中 List 的使用

参数类型为 List 的 javax.xml.xpath 中的方法
 Object XPathFunction.evaluate(List args)
计算带指定参数的函数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.ListIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.ListIterator
的使用

使用 ListIterator 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 ListIterator 的使用

返回 ListIterator 的 java.util 中的方法
ListIterator<E> | AbstractList.listIterator() 返回此列表元素的列表迭代器（按适当顺序）。
ListIterator<E> | List.listIterator() 返回此列表元素的列表迭代器（按适当顺序）。
ListIterator<E> | LinkedList.listIterator(int index) 返回此列表中的元素的列表迭代器（按适当顺序），从列表中指定位置开始。
abstract ListIterator<E> | AbstractSequentialList.listIterator(int index) 返回在此列表中的元素上进行迭代的列表迭代器（按适当顺序）。
ListIterator<E> | AbstractList.listIterator(int index) 返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
ListIterator<E> | List.listIterator(int index) 返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。

java.util.concurrent 中 ListIterator 的使用

返回 ListIterator 的 java.util.concurrent 中的方法
ListIterator<E> | CopyOnWriteArrayList.listIterator() 返回此列表元素的列表迭代器（按适当顺序）。
ListIterator<E> | CopyOnWriteArrayList.listIterator(int index) 返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.ListResourceBundle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ListResourceBundle
的使用

使用 ListResourceBundle 的软件包
javax.accessibility 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.accessibility 中 ListResourceBundle 的使用

javax.accessibility 中 ListResourceBundle 的子类
 class AccessibleResourceBundle
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Locale 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Locale
的使用

使用 Locale 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.spi | java.util 包中类的服务提供者类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.plugins.bmp | 包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 中 Locale 的使用

返回 Locale 的 java.applet 中的方法
 Locale Applet.getLocale()
获取 applet 的语言环境。

java.awt 中 Locale 的使用

返回 Locale 的 java.awt 中的方法
Locale | List.AccessibleAWTList.AccessibleAWTListChild.getLocale() 获取组件的区域设置。
Locale | MenuComponent.AccessibleAWTMenuComponent.getLocale() 返回此对象的区域。
Locale | Window.getLocale() 如果设置了区域，则获取与此窗口关联的 Locale 对象。
Locale | Component.getLocale() 获取组件的语言环境。
Locale | Component.AccessibleAWTComponent.getLocale() 返回此对象的区域。

参数类型为 Locale 的 java.awt 中的方法
abstract String[] | GraphicsEnvironment.getAvailableFontFamilyNames(Locale l) 返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，已针对默认语言环境对它进行了本地化。
String | Font.getFamily(Locale l) 返回此 Font 的系列名称（已经针对指定语言环境进行了本地化）。
String | Font.getFontName(Locale l) 返回此 Font 的字体外观名称（已经针对指定语言环境进行了本地化）。
static ComponentOrientation | ComponentOrientation.getOrientation(Locale locale) 返回适合于给定区域的方向。
void | Component.setLocale(Locale l) 设置组件的语言环境。

java.awt.im 中 Locale 的使用

返回 Locale 的 java.awt.im 中的方法
 Locale InputContext.getLocale()
返回当前输入方法或键盘布局的当前语言环境。

参数类型为 Locale 的 java.awt.im 中的方法
 boolean InputContext.selectInputMethod(Locale locale)
试图选择一个支持给定语言环境的输入方法或键盘布局，并返回指示是否成功选定此类输入方法或键盘布局的值。

java.awt.im.spi 中 Locale 的使用

返回 Locale 的 java.awt.im.spi 中的方法
Locale[] | InputMethodDescriptor.getAvailableLocales() 返回相应输入方法支持的语言环境。
Locale | InputMethod.getLocale() 返回当前的输入语言环境。

参数类型为 Locale 的 java.awt.im.spi 中的方法
String | InputMethodDescriptor.getInputMethodDisplayName(Locale inputLocale, Locale displayLanguage) 用将显示该名称的语言返回用户可视名称，该名称与给定的输入语言环境的输入方法相对应。
Image | InputMethodDescriptor.getInputMethodIcon(Locale inputLocale) 返回相应输入方法的图标。
boolean | InputMethod.setLocale(Locale locale) 试图设置输入语言环境。

java.beans.beancontext 中 Locale 的使用

声明为 Locale 的 java.beans.beancontext 中的字段
protected  Locale BeanContextSupport.locale
此 BeanContext 的当前语言环境。

返回 Locale 的 java.beans.beancontext 中的方法
 Locale BeanContextSupport.getLocale()
获得此 BeanContext 的语言环境。

参数类型为 Locale 的 java.beans.beancontext 中的方法
 void BeanContextSupport.setLocale(Locale newLocale)
设置此 BeanContext 的语言环境。

参数类型为 Locale 的 java.beans.beancontext 中的构造方法
BeanContextServicesSupport(BeanContextServices peer, Locale lcle)
使用指定语言环境创建一个实例。
BeanContextServicesSupport(BeanContextServices peer, Locale lcle, boolean dtime)
使用指定 Locale 和设计模式创建一个实例。
BeanContextServicesSupport(BeanContextServices peer, Locale lcle, boolean dTime, boolean visible)
构造一个 BeanContextServicesSupport 实例
BeanContextSupport(BeanContext peer, Locale lcle)
使用指定语言环境创建一个实例。
BeanContextSupport(BeanContext peer, Locale lcle, boolean dtime)
使用指定 Locale 和设计模式创建一个实例。
BeanContextSupport(BeanContext peer, Locale lcle, boolean dTime, boolean visible)
构造一个 BeanContextSupport 实例。

java.io 中 Locale 的使用

参数类型为 Locale 的 java.io 中的方法
PrintWriter | PrintWriter.format(Locale l, String format, Object... args) 使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
PrintStream | PrintStream.format(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此输出流中。
PrintWriter | PrintWriter.printf(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
PrintStream | PrintStream.printf(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

java.lang 中 Locale 的使用

参数类型为 Locale 的 java.lang 中的方法
static String | String.format(Locale l, String format, Object... args) 使用指定的语言环境、格式字符串和参数返回一个格式化字符串。
String | String.toLowerCase(Locale locale) 使用给定 Locale 的规则将此 String 中的所有字符都转换为小写。
String | String.toUpperCase(Locale locale) 使用给定 Locale 的规则将此 String 中的所有字符都转换为大写。

java.nio.charset 中 Locale 的使用

参数类型为 Locale 的 java.nio.charset 中的方法
 String Charset.displayName(Locale locale)
返回此 charset 用于给定语言环境的可读名称。

java.text 中 Locale 的使用

返回 Locale 的 java.text 中的方法
static Locale[] | BreakIterator.getAvailableLocales() 返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。
static Locale[] | Collator.getAvailableLocales() 返回一个所有受支持语言环境的数组，此类的 getInstance 方法可为这些语言环境返回已本地化的实例。
static Locale[] | DecimalFormatSymbols.getAvailableLocales() 返回一个数组，它包括所有此类的 getInstance 方法可为之返回本地化实例的语言环境。
static Locale[] | NumberFormat.getAvailableLocales() 返回一个数组，它包含所有此类的 get*Instance 方法可以为其返回本地化实例的语言环境。
static Locale[] | DateFormatSymbols.getAvailableLocales() 返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。
static Locale[] | DateFormat.getAvailableLocales() 返回所有语言环境的数组，此类的 get*Instance 方法可以为其返回已本地化的实例。
Locale | MessageFormat.getLocale() 获取创建或比较子格式时所使用的语言环境。

参数类型为 Locale 的 java.text 中的方法
static BreakIterator | BreakIterator.getCharacterInstance(Locale locale) 返回一个用于给定语言环境字符分解的新 BreakIterator 实例。
static NumberFormat | NumberFormat.getCurrencyInstance(Locale inLocale) 返回指定语言环境的货币格式。
static DateFormat | DateFormat.getDateInstance(int style, Locale aLocale) 获取日期格式器，该格式器具有给定语言环境的给定格式化风格。
static DateFormat | DateFormat.getDateTimeInstance(int dateStyle, int timeStyle, Locale aLocale) 获取日期/时间格式器，该格式器具有给定语言环境的给定格式化风格。
static Collator | Collator.getInstance(Locale desiredLocale) 获取所需语言环境的 Collator。
static DecimalFormatSymbols | DecimalFormatSymbols.getInstance(Locale locale) 获取指定语言环境的 DecimalFormatSymbols 实例。
static NumberFormat | NumberFormat.getInstance(Locale inLocale) 返回指定语言环境的通用数值格式。
static DateFormatSymbols | DateFormatSymbols.getInstance(Locale locale) 获取指定语言环境的 DateFormatSymbols 实例。
static NumberFormat | NumberFormat.getIntegerInstance(Locale inLocale) 返回指定语言环境的整数格式。
static BreakIterator | BreakIterator.getLineInstance(Locale locale) 返回一个用于给定语言环境行分解的新 BreakIterator 实例。
static NumberFormat | NumberFormat.getNumberInstance(Locale inLocale) 返回指定语言环境的通用数值格式。
static NumberFormat | NumberFormat.getPercentInstance(Locale inLocale) 返回指定语言环境的百分比格式。
static BreakIterator | BreakIterator.getSentenceInstance(Locale locale) 返回一个用于给定语言环境句子分解的新 BreakIterator 实例。
static DateFormat | DateFormat.getTimeInstance(int style, Locale aLocale) 获取时间格式器，该格式器具有给定语言环境的给定格式化风格。
static BreakIterator | BreakIterator.getWordInstance(Locale locale) 返回一个用于给定语言环境单词分解的新 BreakIterator 实例。
void | MessageFormat.setLocale(Locale locale) 设置创建或比较子格式时要使用的语言环境。

参数类型为 Locale 的 java.text 中的构造方法
DateFormatSymbols(Locale locale)
通过从给定语言环境资源加载格式数据，构造一个 DateFormatSymbols 对象。
DecimalFormatSymbols(Locale locale)
为给定的语言环境创建一个 DecimalFormatSymbols 对象。
MessageFormat(String pattern, Locale locale)
构造指定语言环境和模式的 MessageFormat。
SimpleDateFormat(String pattern, Locale locale)
用给定的模式和给定语言环境的默认日期格式符号构造 SimpleDateFormat。

java.text.spi 中 Locale 的使用

参数类型为 Locale 的 java.text.spi 中的方法
abstract BreakIterator | BreakIteratorProvider.getCharacterInstance(Locale locale) 为给定语言环境的字符分解返回新的 BreakIterator 实例。
abstract NumberFormat | NumberFormatProvider.getCurrencyInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定的语言环境格式化货币价值。
abstract DateFormat | DateFormatProvider.getDateInstance(int style, Locale locale) 返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期。
abstract DateFormat | DateFormatProvider.getDateTimeInstance(int dateStyle, int timeStyle, Locale locale) 返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期和时间。
abstract Collator | CollatorProvider.getInstance(Locale locale) 为指定语言环境返回新的 Collator 实例。
abstract DecimalFormatSymbols | DecimalFormatSymbolsProvider.getInstance(Locale locale) 为指定语言环境返回新的 DecimalFormatSymbols 实例。
abstract DateFormatSymbols | DateFormatSymbolsProvider.getInstance(Locale locale) 为指定语言环境返回一个新的 DateFormatSymbols 实例。
abstract NumberFormat | NumberFormatProvider.getIntegerInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定的语言环境格式化整数值。
abstract BreakIterator | BreakIteratorProvider.getLineInstance(Locale locale) 为给定语言环境的行分解返回新的 BreakIterator 实例。
abstract NumberFormat | NumberFormatProvider.getNumberInstance(Locale locale) 为指定语言环境返回新的通用 NumberFormat 实例。
abstract NumberFormat | NumberFormatProvider.getPercentInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定语言环境格式化百分比值。
abstract BreakIterator | BreakIteratorProvider.getSentenceInstance(Locale locale) 为给定语言环境的句子分解返回新的 BreakIterator 实例。
abstract DateFormat | DateFormatProvider.getTimeInstance(int style, Locale locale) 返回一个新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化时间。
abstract BreakIterator | BreakIteratorProvider.getWordInstance(Locale locale) 为给定语言环境的单词分解返回一个新 BreakIterator 实例。

java.util 中 Locale 的使用

声明为 Locale 的 java.util 中的字段
static Locale | Locale.CANADA 用于表示国家/地区的有用常量。
static Locale | Locale.CANADA_FRENCH 用于表示国家/地区的有用常量。
static Locale | Locale.CHINA 用于表示国家/地区的有用常量。
static Locale | Locale.CHINESE 用于表示语言的有用常量。
static Locale | Locale.ENGLISH 用于表示语言的有用常量。
static Locale | Locale.FRANCE 用于表示国家/地区的有用常量。
static Locale | Locale.FRENCH 用于表示语言的有用常量。
static Locale | Locale.GERMAN 用于表示语言的有用常量。
static Locale | Locale.GERMANY 用于表示国家/地区的有用常量。
static Locale | Locale.ITALIAN 用于表示语言的有用常量。
static Locale | Locale.ITALY 用于表示国家/地区的有用常量。
static Locale | Locale.JAPAN 用于表示国家/地区的有用常量。
static Locale | Locale.JAPANESE 用于表示语言的有用常量。
static Locale | Locale.KOREA 用于表示国家/地区的有用常量。
static Locale | Locale.KOREAN 用于表示语言的有用常量。
static Locale | Locale.PRC 用于表示国家/地区的有用常量。
static Locale | Locale.ROOT 用于表示根语言环境的有用常量。
static Locale | Locale.SIMPLIFIED_CHINESE 用于表示语言的有用常量。
static Locale | Locale.TAIWAN 用于表示国家/地区的有用常量。
static Locale | Locale.TRADITIONAL_CHINESE 用于表示语言的有用常量。
static Locale | Locale.UK 用于表示国家/地区的有用常量。
static Locale | Locale.US 用于表示国家/地区的有用常量。

返回 Locale 的 java.util 中的方法
static Locale[] | Calendar.getAvailableLocales() 返回所有语言环境的数组，此类的 getInstance 方法可以为其返回本地化的实例。
static Locale[] | Locale.getAvailableLocales() 返回所有已安装语言环境的数组。
static Locale | Locale.getDefault() 获得此 Java 虚拟机实例的当前默认语言环境值。
Locale | ResourceBundle.Control.getFallbackLocale(String baseName, Locale locale) 返回一个要用作回退语言环境的 Locale，用于 ResourceBundle.getBundle 工厂方法进行进一步资源包搜索。
Locale | ResourceBundle.getLocale() 返回此资源包的语言环境。
Locale | Formatter.locale() 返回构造此 formatter 时设置的语言环境。
Locale | Scanner.locale() 返回此扫描器的语言环境。

返回变量类型为 Locale 的类型的 java.util 中的方法
 List<Locale> ResourceBundle.Control.getCandidateLocales(String baseName, Locale locale)
返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。

参数类型为 Locale 的 java.util 中的方法
Formatter | Formatter.format(Locale l, String format, Object... args) 使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale locale) 使用指定的基本名称、语言环境和调用者的类加载器获取资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale locale, ClassLoader loader) 使用指定的基本名称、语言环境和类加载器获取资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control) 使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ResourceBundle.Control control) 使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。
List<Locale> | ResourceBundle.Control.getCandidateLocales(String baseName, Locale locale) 返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。
String | Locale.getDisplayCountry(Locale inLocale) 返回适合向用户显示的语言环境国家/地区名。
String | Locale.getDisplayLanguage(Locale inLocale) 返回适合向用户显示的语言环境语言名。
String | TimeZone.getDisplayName(boolean daylight, int style, Locale locale) 返回适合于展示给指定区域的用户的时区名称。
String | Calendar.getDisplayName(int field, int style, Locale locale) 返回给定 style 和 locale 下的日历 field 值的字符串表示形式。
String | TimeZone.getDisplayName(Locale locale) 返回适合于展示给指定区域的用户的时区名称。
String | Locale.getDisplayName(Locale inLocale) 返回适合向用户显示的语言环境名。
Map<String,Integer> | Calendar.getDisplayNames(int field, int style, Locale locale) 返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。
String | Locale.getDisplayVariant(Locale inLocale) 返回适合向用户显示的语言环境变量代码名。
Locale | ResourceBundle.Control.getFallbackLocale(String baseName, Locale locale) 返回一个要用作回退语言环境的 Locale，用于 ResourceBundle.getBundle 工厂方法进行进一步资源包搜索。
static Currency | Currency.getInstance(Locale locale) 返回给定语言环境的国家/地区的 Currency 实例。
static Calendar | Calendar.getInstance(Locale aLocale) 使用默认时区和指定语言环境获得一个日历。
static Calendar | Calendar.getInstance(TimeZone zone, Locale aLocale) 使用指定时区和语言环境获得一个日历。
String | Currency.getSymbol(Locale locale) 获取指定语言环境的货币符号。
long | ResourceBundle.Control.getTimeToLive(String baseName, Locale locale) 返回在此 ResourceBundle.Control 下加载的资源包生存时间 (TTL) 值。
boolean | ResourceBundle.Control.needsReload(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime) 确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。
ResourceBundle | ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload) 针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。
static void | Locale.setDefault(Locale newLocale) 为此 Java 虚拟机实例设置默认语言环境。
String | ResourceBundle.Control.toBundleName(String baseName, Locale locale) 将给定 baseName 和 locale 转换为包名称。
Scanner | Scanner.useLocale(Locale locale) 将此扫描器的语言环境设置为指定的语言环境。

参数类型为 Locale 的 java.util 中的构造方法
Calendar(TimeZone zone, Locale aLocale)
构造一个带有指定时区和语言环境的 Calendar。
Formatter(Appendable a, Locale l)
构造一个带指定目标文件和语言环境的新 formatter。
Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。
Formatter(Locale l)
构造一个带指定语言环境的新 formatter。
Formatter(OutputStream os, String csn, Locale l)
构造一个带指定输出流、字符集和语言环境的新 formatter。
Formatter(String fileName, String csn, Locale l)
构造一个带指定文件名、字符集和语言环境的新 formatter。
GregorianCalendar(Locale aLocale)
在具有给定语言环境的默认时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(TimeZone zone, Locale aLocale)
在具有给定语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。

java.util.spi 中 Locale 的使用

返回 Locale 的 java.util.spi 中的方法
abstract  Locale[] LocaleServiceProvider.getAvailableLocales()
返回一个数组，它包含此语言环境服务提供者可以为其提供本地化对象或名称的所有语言环境。

参数类型为 Locale 的 java.util.spi 中的方法
abstract String | LocaleNameProvider.getDisplayCountry(String countryCode, Locale locale) 返回适合向用户显示的给定 ISO 3166 国家代码和给定语言环境的本地化名称。
abstract String | LocaleNameProvider.getDisplayLanguage(String languageCode, Locale locale) 返回适合向用户显示的给定 ISO 639 语言代码和给定语言环境的本地化名称。
abstract String | TimeZoneNameProvider.getDisplayName(String ID, boolean daylight, int style, Locale locale) 返回适于展示给指定语言环境用户的给定时区 ID 名称。
abstract String | LocaleNameProvider.getDisplayVariant(String variant, Locale locale) 返回适合向用户显示的给定变量代码和给定语言环境的本地化名称。
abstract String | CurrencyNameProvider.getSymbol(String currencyCode, Locale locale) 获取指定语言环境的给定货币代码的符号。

javax.accessibility 中 Locale 的使用

返回 Locale 的 javax.accessibility 中的方法
abstract  Locale AccessibleContext.getLocale()
获取该组件的语言环境。

参数类型为 Locale 的 javax.accessibility 中的方法
String | AccessibleBundle.toDisplayString(Locale locale) 获取本地化字符串形式的键。
protected String | AccessibleBundle.toDisplayString(String resourceBundleName, Locale locale) 获取本地化字符串形式的键。

javax.annotation.processing 中 Locale 的使用

返回 Locale 的 javax.annotation.processing 中的方法
 Locale ProcessingEnvironment.getLocale()
返回当前语言环境；如果没有有效的语言环境，则返回 null。

javax.imageio 中 Locale 的使用

声明为 Locale 的 javax.imageio 中的字段
protected Locale[] | ImageReader.availableLocales 可以用来本地化警告消息的 Locale 组成的数组，如果不支持本地化，则为 null。
protected Locale[] | ImageWriter.availableLocales 可以用来本地化警告消息和压缩设置值的 Locale 组成的数组，如果本地化不受支持，则将它们初始化为 null。
protected Locale | ImageReader.locale 用于本地化的当前 Locale，如果没有设置，则为 null。
protected Locale | ImageWriteParam.locale 用于本地化压缩类型名称和质量描述的 Locale，null 表示使用默认 Locale。
protected Locale | ImageWriter.locale 用于本地化的当前 Locale，如果没有设置 Locale，则将它初始化为 null。

类型参数类型为 Locale 的 javax.imageio 中的字段
protected List<Locale> | ImageReader.warningLocales 与每个当前已注册 IIOReadWarningListener 关联的 Locale 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<Locale> | ImageWriter.warningLocales Locale 的 List，warningListeners 的每个元素都有一个 Locale 列表，默认情况下该列表被初始化为 null，它与空 List 同义。

返回 Locale 的 javax.imageio 中的方法
Locale[] | ImageReader.getAvailableLocales() 返回可用来初始化警告侦听器和压缩设置值的 Locale 所组成的数组。
Locale[] | ImageWriter.getAvailableLocales() 返回可用来初始化警告侦听器和压缩设置的 Locale 组成的数组。
Locale | ImageReader.getLocale() 返回当前设置的 Locale，如果没有设置 Locale，则返回 null。
Locale | ImageWriteParam.getLocale() 返回当前设置的 Locale，如果仅支持默认 Locale，则返回 null。
Locale | ImageWriter.getLocale() 返回当前设置的 Locale，如果没有设置 Locale，则返回 null。

参数类型为 Locale 的 javax.imageio 中的方法
void | ImageReader.setLocale(Locale locale) 将此 ImageReader 的当前 Locale 设置为给定值。
void | ImageWriter.setLocale(Locale locale) 将此 ImageWriter 的当前 Locale 设置为给定值。

参数类型为 Locale 的 javax.imageio 中的构造方法
ImageWriteParam(Locale locale)
构造一个 ImageWriteParam 集，以使用给定 Locale。

javax.imageio.metadata 中 Locale 的使用

参数类型为 Locale 的 javax.imageio.metadata 中的方法
String | IIOMetadataFormat.getAttributeDescription(String elementName, String attrName, Locale locale) 返回包含指定属性的描述的 String，或者 null。
String | IIOMetadataFormatImpl.getAttributeDescription(String elementName, String attrName, Locale locale) 返回包含指定属性的描述的 String，或者 null。
String | IIOMetadataFormat.getElementDescription(String elementName, Locale locale) 返回包含指定元素的描述的 String，或者 null。
String | IIOMetadataFormatImpl.getElementDescription(String elementName, Locale locale) 返回包含指定元素的描述的 String，或者 null。

javax.imageio.plugins.bmp 中 Locale 的使用

参数类型为 Locale 的 javax.imageio.plugins.bmp 中的构造方法
BMPImageWriteParam(Locale locale)
构造一个设置为使用给定 Locale 并且所有参数都采用默认值的 BMPImageWriteParam。

javax.imageio.plugins.jpeg 中 Locale 的使用

参数类型为 Locale 的 javax.imageio.plugins.jpeg 中的构造方法
JPEGImageWriteParam(Locale locale)
构造一个 JPEGImageWriteParam。

javax.imageio.spi 中 Locale 的使用

参数类型为 Locale 的 javax.imageio.spi 中的方法
abstract  String IIOServiceProvider.getDescription(Locale locale)
返回此服务提供者及其相关实现的一个简明的可读描述。

javax.print.attribute 中 Locale 的使用

返回 Locale 的 javax.print.attribute 中的方法
 Locale TextSyntax.getLocale()
返回此文本属性的文本字符串的自然语言（语言环境）。

参数类型为 Locale 的 javax.print.attribute 中的构造方法
TextSyntax(String value, Locale locale)
使用指定的字符串和语言环境构造 TextAttribute。

javax.print.attribute.standard 中 Locale 的使用

参数类型为 Locale 的 javax.print.attribute.standard 中的构造方法
DocumentName(String documentName, Locale locale)
构造具有给定文档名称和语言环境的新文档名称属性。
JobMessageFromOperator(String message, Locale locale)
使用给定消息和语言环境构造新的 JobMessageFromOperator 属性。
JobName(String jobName, Locale locale)
构造具有给定作业名称和语言环境的新JobName属性。
JobOriginatingUserName(String userName, Locale locale)
构造具有给定用户名称和语言环境的新的 JobOriginatingUserName 属性。
OutputDeviceAssigned(String deviceName, Locale locale)
构造具有给定设备名称和语言环境的新 OutputDeviceAssigned 属性。
PrinterInfo(String info, Locale locale)
构造具有给定信息字符串和语言环境的新 PrinterInfo 属性。
PrinterLocation(String location, Locale locale)
构造具有给定位置和语言环境的新 PrinterLocation 属性。
PrinterMakeAndModel(String makeAndModel, Locale locale)
构造具有给定制造和型号字符串以及语言环境的新 PrinterMakeAndModel 属性。
PrinterMessageFromOperator(String message, Locale locale)
构造具有给定消息和语言环境的新 PrinterMessageFromOperator 属性。
PrinterName(String printerName, Locale locale)
构造具有给定名称和语言环境的新 PrinterName 属性。
RequestingUserName(String userName, Locale locale)
构造具有给定用户名称和语言环境的新 RequestingUserName 属性。

javax.security.auth.callback 中 Locale 的使用

返回 Locale 的 javax.security.auth.callback 中的方法
 Locale LanguageCallback.getLocale()
获取检索到的 Locale。

参数类型为 Locale 的 javax.security.auth.callback 中的方法
 void LanguageCallback.setLocale(Locale locale)
设置获取到的 Locale。

javax.swing 中 Locale 的使用

返回 Locale 的 javax.swing 中的方法
Locale | UIDefaults.getDefaultLocale() 返回该默认语言环境。
static Locale | JComponent.getDefaultLocale() 返回在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。
Locale | ProgressMonitor.AccessibleProgressMonitor.getLocale() 获取该组件的语言环境。
Locale | JTree.AccessibleJTree.AccessibleJTreeNode.getLocale() 获取组件的区域。
Locale | JTable.AccessibleJTable.AccessibleJTableCell.getLocale() 获取该组件的语言环境。
Locale | JList.AccessibleJList.AccessibleJListChild.getLocale()
Locale | ImageIcon.AccessibleImageIcon.getLocale() 返回此对象的区域。

参数类型为 Locale 的 javax.swing 中的方法
Object | UIDefaults.get(Object key, Locale l) 返回与给定语言环境相关的那些键的值。
static Object | UIManager.get(Object key, Locale l) 从适合给定语言环境的默认值中返回一个对象。
boolean | UIDefaults.getBoolean(Object key, Locale l) 如果给定 Locale 的 key 值是 boolean 值，则返回该 boolean 值，否则返回 false。
static boolean | UIManager.getBoolean(Object key, Locale l) 从与键值和给定的 Locale 相关的默认值中返回一个布尔变量。
Border | UIDefaults.getBorder(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Border，则返回该 Border，否则返回 null。
static Border | UIManager.getBorder(Object key, Locale l) 从适合给定语言环境的默认值中返回一个边框。
Color | UIDefaults.getColor(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Color，则返回它，否则返回 null。
static Color | UIManager.getColor(Object key, Locale l) 从适合给定语言环境的默认值中返回一种颜色。
Dimension | UIDefaults.getDimension(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
static Dimension | UIManager.getDimension(Object key, Locale l) 从适合给定语言环境的默认值中返回一个维数。
Font | UIDefaults.getFont(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Font，则返回它，否则返回 null。
static Font | UIManager.getFont(Object key, Locale l) 从适合给定语言环境的默认值中返回一种字体。
Icon | UIDefaults.getIcon(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Icon，则返回该 Icon，否则返回 null。
static Icon | UIManager.getIcon(Object key, Locale l) 从适合给定语言环境的默认值中返回一个 Icon。
Insets | UIDefaults.getInsets(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Insets，则返回该 Insets，否则返回 null。
static Insets | UIManager.getInsets(Object key, Locale l) 从适合给定语言环境的默认值中返回一个 Insets 对象。
int | UIDefaults.getInt(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Integer，则返回其整数值，否则返回 0。
static int | UIManager.getInt(Object key, Locale l) 从适合给定语言环境的默认值中返回一个整数。
String | UIDefaults.getString(Object key, Locale l) 如果给定 Locale 的 key 值为一个 String，则返回该 String，否则返回 null。
static String | UIManager.getString(Object key, Locale l) 从适合给定语言环境的默认值中返回一个字符串。
void | UIDefaults.setDefaultLocale(Locale l) 设置默认语言环境。
static void | JComponent.setDefaultLocale(Locale l) 设置在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。

javax.swing.table 中 Locale 的使用

返回 Locale 的 javax.swing.table 中的方法
 Locale JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocale()

javax.tools 中 Locale 的使用

参数类型为 Locale 的 javax.tools 中的方法
String | Diagnostic.getMessage(Locale locale) 获取给定语言环境的本地化消息。
StandardJavaFileManager | JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset) 为此工具获取一个标准文件管理器实现的新实例。
void | JavaCompiler.CompilationTask.setLocale(Locale locale) 设置格式化诊断和其他本地化数据时要应用的语言环境。

javax.xml.datatype 中 Locale 的使用

参数类型为 Locale 的 javax.xml.datatype 中的方法
abstract  GregorianCalendar XMLGregorianCalendar.toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。

javax.xml.soap 中 Locale 的使用

返回 Locale 的 javax.xml.soap 中的方法
 Locale SOAPFault.getFaultStringLocale()
获取此 SOAPFault 对象错误字符串的语言环境。

参数类型为 Locale 的 javax.xml.soap 中的方法
SOAPFault | SOAPBody.addFault(Name faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(QName faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
void | SOAPFault.addFaultReasonText(String text, Locale locale) 追加或替换包含指定文本消息的 Reason Text 项，以及从 locale 派生的 xml:lang。
String | SOAPFault.getFaultReasonText(Locale locale) 返回与给定 Locale 关联的 Reason Text。
void | SOAPFault.setFaultString(String faultString, Locale locale) 将此 SOAPFault 对象的错误字符串设定为给定字符串，并本地化为给定语言环境。

org.xml.sax 中 Locale 的使用

参数类型为 Locale 的 org.xml.sax 中的方法
 void Parser.setLocale(Locale locale)
已过时。 允许应用程序请求错误和警告的环境。

org.xml.sax.helpers 中 Locale 的使用

参数类型为 Locale 的 org.xml.sax.helpers 中的方法
 void XMLReaderAdapter.setLocale(Locale locale)
设置错误报告的语言环境。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Map 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Map
的使用

使用 Map 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。

java.awt 中 Map 的使用

实现 Map 的 java.awt 中的类
 class RenderingHints
RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。

声明为 Map 的 java.awt 中的字段
protected  Map<String,Object> Toolkit.desktopProperties

返回 Map 的 java.awt 中的方法
Map<TextAttribute,?> | Font.getAttributes() 返回此 Font 中可用的字体属性的映射。
abstract Map<TextAttribute,?> | Toolkit.mapInputMethodHighlight(InputMethodHighlight highlight) 返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。

参数类型为 Map 的 java.awt 中的方法
abstract void | Graphics2D.addRenderingHints(Map<?,?> hints) 为呈现算法设置任意数量的首选项值。
Font | Font.deriveFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 通过复制当前 Font 对象并应用新的字体属性集，创建一个新 Font 对象。
static Font | Font.getFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 返回适合于这些属性的 Font。
void | RenderingHints.putAll(Map<?,?> m) 将指定 Map 中所有映射关系复制到此 RenderingHints 中。
abstract void | Graphics2D.setRenderingHints(Map<?,?> hints) 使用指定的 hints 替换用于所有呈现算法首选项的值。

参数类型为 Map 的 java.awt 中的构造方法
Font(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
创建一个具有指定属性的新 Font。
RenderingHints(Map<RenderingHints.Key,?> init)
构造一个新对象，该对象具有根据指定 Map 对象（可以为 null）初始化的键和值。

java.awt.datatransfer 中 Map 的使用

返回 Map 的 java.awt.datatransfer 中的方法
Map<String,DataFlavor> | SystemFlavorMap.getFlavorsForNatives(String[] natives) 返回指定 String native 到其大多数首选 DataFlavor 的 Map。
Map<String,DataFlavor> | FlavorMap.getFlavorsForNatives(String[] natives) 返回指定 String native 到其相应 DataFlavor 的 Map。
Map<DataFlavor,String> | SystemFlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其大多数首选的 String native 的 Map。
Map<DataFlavor,String> | FlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其对应的 String native 的 Map。

java.awt.font 中 Map 的使用

参数类型为 Map 的 java.awt.font 中的构造方法
TextLayout(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
根据 String 和属性集构造一个 TextLayout。

java.awt.im 中 Map 的使用

返回 Map 的 java.awt.im 中的方法
 Map<TextAttribute,?> InputMethodHighlight.getStyle()
返回文本范围的呈现样式属性，或 null。

参数类型为 Map 的 java.awt.im 中的构造方法
InputMethodHighlight(boolean selected, int state, int variation, Map<TextAttribute,?> style)
构造输入方法高亮显示记录。

java.lang 中 Map 的使用

返回 Map 的 java.lang 中的方法
Map<String,String> | ProcessBuilder.environment() 返回此进程生成器环境的字符串映射视图。
static Map<Thread,StackTraceElement[]> | Thread.getAllStackTraces() 返回所有活动线程的堆栈跟踪的一个映射。
static Map<String,String> | System.getenv() 返回一个不能修改的当前系统环境的字符串映射视图。

java.lang.management 中 Map 的使用

返回 Map 的 java.lang.management 中的方法
 Map<String,String> RuntimeMXBean.getSystemProperties()
返回所有系统属性的名称和值的映射。

java.net 中 Map 的使用

返回 Map 的 java.net 中的方法
abstract Map<String,List<String>> | CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
Map<String,List<String>> | CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
Map<String,List<String>> | URLConnection.getHeaderFields() 返回头字段的不可修改的 Map。
abstract Map<String,List<String>> | CacheResponse.getHeaders() 以 Map 的形式返回响应头。
Map<String,List<String>> | URLConnection.getRequestProperties() 返回一个由此连接的一般请求属性构成的不可修改的 Map。

参数类型为 Map 的 java.net 中的方法
abstract Map<String,List<String>> | CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
Map<String,List<String>> | CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
abstract CacheResponse | ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders) 根据请求的 uri、请求方法和请求头获取缓存的响应。
abstract void | CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders) 将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
void | CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)

java.security 中 Map 的使用

实现 Map 的 java.security 中的类
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

参数类型为 Map 的 java.security 中的方法
static Provider[] | Security.getProviders(Map<String,String> filter) 返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。
void | Provider.putAll(Map<?,?> t) 将指定 Map 中所有映射关系复制到此 provider 中。

参数类型为 Map 的 java.security 中的构造方法
Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

java.sql 中 Map 的使用

返回 Map 的 java.sql 中的方法
Map<String,ClientInfoStatus> | SQLClientInfoException.getFailedProperties() 返回无法设置的客户端信息属性列表。
Map<String,Class<?>> | Connection.getTypeMap() 获取与此 Connection 对象关联的 Map 对象。

参数类型为 Map 的 java.sql 中的方法
Object | Array.getArray(long index, int count, Map<String,Class<?>> map) 获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
Object | Array.getArray(Map<String,Class<?>> map) 获取由此 Array 对象指定的 SQL ARRAY 值的内容。
Object[] | Struct.getAttributes(Map<String,Class<?>> map) 生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。
Object | CallableStatement.getObject(int parameterIndex, Map<String,Class<?>> map) 返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。
Object | ResultSet.getObject(int columnIndex, Map<String,Class<?>> map) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
Object | Ref.getObject(Map<String,Class<?>> map) 获取引用对象并使用给定类型映射表将其映射到 Java 类型。
Object | CallableStatement.getObject(String parameterName, Map<String,Class<?>> map) 返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。
Object | ResultSet.getObject(String columnLabel, Map<String,Class<?>> map) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
ResultSet | Array.getResultSet(long index, int count, Map<String,Class<?>> map) 获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
ResultSet | Array.getResultSet(Map<String,Class<?>> map) 获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
void | Connection.setTypeMap(Map<String,Class<?>> map) 将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。

参数类型为 Map 的 java.sql 中的构造方法
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

java.text 中 Map 的使用

返回 Map 的 java.text 中的方法
 Map<AttributedCharacterIterator.Attribute,Object> AttributedCharacterIterator.getAttributes()
返回具有定义于当前字符上的多个属性的映射。

参数类型为 Map 的 java.text 中的方法
 void AttributedString.addAttributes(Map<? extends AttributedCharacterIterator.Attribute,?> attributes, int beginIndex, int endIndex)
将属性集添加到字符串的子范围。

参数类型为 Map 的 java.text 中的构造方法
AttributedString(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
构造带给定文本和属性的 AttributedString。

java.util 中 Map 的使用

java.util 中 Map 的子接口
interface | NavigableMap<K,V> 扩展的 SortedMap，具有了针对给定搜索目标返回最接近匹配项的导航方法。
interface | SortedMap<K,V> 进一步提供关于键的总体排序 的 Map。

实现 Map 的 java.util 中的类
class | AbstractMap<K,V> 此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。
class | EnumMap<K extends Enum<K>,V> 与枚举类型键一起使用的专用 Map 实现。
class | HashMap<K,V> 基于哈希表的 Map 接口的实现。
class | Hashtable<K,V> 此类实现一个哈希表，该哈希表将键映射到相应的值。
class | IdentityHashMap<K,V> 此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
class | LinkedHashMap<K,V> Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
class | Properties Properties 类表示了一个持久的属性集。
class | TreeMap<K,V> 基于红黑树（Red-Black tree）的 NavigableMap 实现。
class | WeakHashMap<K,V> 以弱键 实现的基于哈希表的 Map。

声明为 Map 的 java.util 中的字段
static Map Collections.EMPTY_MAP
空的映射（不可变的）。

返回 Map 的 java.util 中的方法
static
<K,V> Map<K,V>
Collections.checkedMap(Map<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定映射的一个动态类型安全视图。
static
<K,V> Map<K,V>
Collections.emptyMap()
返回空的映射（不可变的）。
 Map<String,Integer> Calendar.getDisplayNames(int field, int style, Locale locale)
返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。
static
<K,V> Map<K,V>
Collections.singletonMap(K key, V value)
返回一个不可变的映射，它只将指定键映射到指定值。
static
<K,V> Map<K,V>
Collections.synchronizedMap(Map<K,V> m)
返回由指定映射支持的同步（线程安全的）映射。
static
<K,V> Map<K,V>
Collections.unmodifiableMap(Map<? extends K,? extends V> m)
返回指定映射的不可修改视图。

参数类型为 Map 的 java.util 中的方法
static
<K,V> Map<K,V>
Collections.checkedMap(Map<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定映射的一个动态类型安全视图。
static
<E> Set<E>
Collections.newSetFromMap(Map<E,Boolean> map)
返回指定映射支持的 set。
 void EnumMap.putAll(Map<? extends K,? extends V> m)
将指定映射中所有映射关系复制到此映射中。
 void IdentityHashMap.putAll(Map<? extends K,? extends V> m)
将指定映射的全部映射关系复制到此映射，这些映射关系将替换此映射目前针对指定映射的任何键的任何映射关系。
 void TreeMap.putAll(Map<? extends K,? extends V> map)
将指定映射中的所有映射关系复制到此映射中。
 void WeakHashMap.putAll(Map<? extends K,? extends V> m)
将指定映射的全部映射关系复制到此映射。
 void HashMap.putAll(Map<? extends K,? extends V> m)
将指定映射的所有映射关系复制到此映射中，这些映射关系将替换此映射目前针对指定映射中所有键的所有映射关系。
 void AbstractMap.putAll(Map<? extends K,? extends V> m)
从指定映射中将所有映射关系复制到此映射中（可选操作）。
 void Hashtable.putAll(Map<? extends K,? extends V> t)
将指定映射的所有映射关系复制到此哈希表中，这些映射关系将替换此哈希表拥有的、针对当前指定映射中所有键的所有映射关系。
 void Map.putAll(Map<? extends K,? extends V> m)
从指定映射中将所有映射关系复制到此映射中（可选操作）。
static
<K,V> Map<K,V>
Collections.synchronizedMap(Map<K,V> m)
返回由指定映射支持的同步（线程安全的）映射。
static
<K,V> Map<K,V>
Collections.unmodifiableMap(Map<? extends K,? extends V> m)
返回指定映射的不可修改视图。

参数类型为 Map 的 java.util 中的构造方法
EnumMap(Map<K,? extends V> m)
创建一个枚举映射，从指定映射对其初始化。
HashMap(Map<? extends K,? extends V> m)
构造一个映射关系与指定 Map 相同的新 HashMap。
Hashtable(Map<? extends K,? extends V> t)
构造一个与给定的 Map 具有相同映射关系的新哈希表。
IdentityHashMap(Map<? extends K,? extends V> m)
构造包含指定映射中键-值映射关系的新标识哈希映射。
LinkedHashMap(Map<? extends K,? extends V> m)
构造一个映射关系与指定映射相同的插入顺序 LinkedHashMap 实例。
TreeMap(Map<? extends K,? extends V> m)
构造一个与给定映射具有相同映射关系的新的树映射，该映射根据其键的自然顺序 进行排序。
WeakHashMap(Map<? extends K,? extends V> m)
构造一个新 WeakHashMap，使其与指定的映射具有相同的映射关系。

java.util.concurrent 中 Map 的使用

java.util.concurrent 中 Map 的子接口
interface | ConcurrentMap<K,V> 提供其他原子 putIfAbsent、remove、replace 方法的 Map。
interface | ConcurrentNavigableMap<K,V> 支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。

实现 Map 的 java.util.concurrent 中的类
class | ConcurrentHashMap<K,V> 支持获取的完全并发和更新的所期望可调整并发的哈希表。
class | ConcurrentSkipListMap<K,V> 可缩放的并发 ConcurrentNavigableMap 实现。

参数类型为 Map 的 java.util.concurrent 中的方法
 void ConcurrentHashMap.putAll(Map<? extends K,? extends V> m)
将指定映射中所有映射关系复制到此映射中。

参数类型为 Map 的 java.util.concurrent 中的构造方法
ConcurrentHashMap(Map<? extends K,? extends V> m)
构造一个与给定映射具有相同映射关系的新映射。
ConcurrentSkipListMap(Map<? extends K,? extends V> m)
构造一个新映射，该映射所包含的映射关系与给定映射包含的映射关系相同，并按照键的自然顺序进行排序。

java.util.jar 中 Map 的使用

实现 Map 的 java.util.jar 中的类
 class Attributes
Attributes 类将 Manifest 属性名称映射到关联的字符串值。

声明为 Map 的 java.util.jar 中的字段
protected  Map<Object,Object> Attributes.map
属性名称-值映射关系。

返回 Map 的 java.util.jar 中的方法
 Map<String,Attributes> Manifest.getEntries()
返回此 Manifest 中所包含条目的 Map。

参数类型为 Map 的 java.util.jar 中的方法
 void Attributes.putAll(Map<?,?> attr)
将所有的属性名称-值映射关系从指定的 Attributes 复制到此 Map。

javax.annotation.processing 中 Map 的使用

返回 Map 的 javax.annotation.processing 中的方法
 Map<String,String> ProcessingEnvironment.getOptions()
返回传递给注释处理工具的特定于 processor 的选项。

javax.lang.model.element 中 Map 的使用

返回 Map 的 javax.lang.model.element 中的方法
 Map<? extends ExecutableElement,? extends AnnotationValue> AnnotationMirror.getElementValues()
返回此注释元素的值。

javax.lang.model.util 中 Map 的使用

返回 Map 的 javax.lang.model.util 中的方法
 Map<? extends ExecutableElement,? extends AnnotationValue> Elements.getElementValuesWithDefaults(AnnotationMirror a)
返回注释元素的值，包括默认值。

javax.management 中 Map 的使用

参数类型为 Map 的 javax.management 中的构造方法
ImmutableDescriptor(Map<String,?> fields)
构造一个描述符，其中字段名称和值是给定 Map 的键和值。

javax.management.loading 中 Map 的使用

返回 Map 的 javax.management.loading 中的方法
 Map<String,String> MLetContent.getAttributes()
获取 MLET 标记的属性。

参数类型为 Map 的 javax.management.loading 中的构造方法
MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

javax.management.openmbean 中 Map 的使用

实现 Map 的 javax.management.openmbean 中的类
 class TabularDataSupport
TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。

参数类型为 Map 的 javax.management.openmbean 中的方法
 void TabularDataSupport.putAll(Map<?,?> t)
将包含在指定映射 t 中的所有值添加到此 TabularData 实例。

参数类型为 Map 的 javax.management.openmbean 中的构造方法
CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。

javax.management.relation 中 Map 的使用

返回 Map 的 javax.management.relation 中的方法
Map<ObjectName,List<String>> | RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<String,List<String>> | RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在引用给定 MBean 的引用关系。
Map<String,List<String>> | RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在其中引用给定 MBean 的关系。
Map<ObjectName,List<String>> | Relation.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationSupport.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationService.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。

javax.management.remote 中 Map 的使用

返回 Map 的 javax.management.remote 中的方法
 Map<String,?> JMXConnectorServerMBean.getAttributes()
此连接器服务器的属性。

参数类型为 Map 的 javax.management.remote 中的方法
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment) 创建到位于给定地址的连接器服务器的连接。
void | JMXConnector.connect(Map<String,?> env) 建立到连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 为位于给定地址的连接器服务器创建一个连接器客户端。
JMXConnector | JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。
static JMXConnectorServer | JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的连接器服务器。
JMXConnectorServer | JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的新连接器服务器。
JMXConnector | JMXConnectorServer.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。
JMXConnector | JMXConnectorServerMBean.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。

javax.management.remote.rmi 中 Map 的使用

返回 Map 的 javax.management.remote.rmi 中的方法
 Map<String,?> RMIConnectorServer.getAttributes()

参数类型为 Map 的 javax.management.remote.rmi 中的方法
void | RMIConnector.connect(Map<String,?> environment)
JMXConnector | RMIConnectorServer.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。

参数类型为 Map 的 javax.management.remote.rmi 中的构造方法
RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。
RMIConnector(JMXServiceURL url, Map<String,?> environment)
构造一个将 RMI 连接器服务器连接到给定地址的 RMIConnector。
RMIConnector(RMIServer rmiServer, Map<String,?> environment)
用给定的 RMI stub 构造一个 RMIConnector。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
建立 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIIIOPServerImpl(Map<String,?> env)
创建新的 RMIServerImpl。
RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。
RMIServerImpl(Map<String,?> env)
构造一个新的 RMIServerImpl。

javax.print.attribute.standard 中 Map 的使用

实现 Map 的 javax.print.attribute.standard 中的类
 class PrinterStateReasons
PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

参数类型为 Map 的 javax.print.attribute.standard 中的构造方法
PrinterStateReasons(Map<PrinterStateReason,Severity> map)
构造一个新的 PrinterStateReasons 属性，它包括与给定映射相同的 PrinterStateReason 到 Severity 映射关系。

javax.script 中 Map 的使用

javax.script 中 Map 的子接口
 interface Bindings
所有键均为 String 的键/值对映射关系。

实现 Map 的 javax.script 中的类
 class SimpleBindings
一个受 HashMap 或其他某些指定 Map 支持的 Bindings 的简单实现。

参数类型为 Map 的 javax.script 中的方法
void | Bindings.putAll(Map<? extends String,? extends Object> toMerge) 将给定 Map 中的所有映射关系添加到此 Bindings 中。
void | SimpleBindings.putAll(Map<? extends String,? extends Object> toMerge) putAll 是使用 Map.putAll 实现的。

参数类型为 Map 的 javax.script 中的构造方法
SimpleBindings(Map<String,Object> m)
构造方法使用现有 Map 来存储值。

javax.security.auth.login 中 Map 的使用

返回 Map 的 javax.security.auth.login 中的方法
 Map<String,?> AppConfigurationEntry.getOptions()
获取为此 LoginModule 配置的选项。

参数类型为 Map 的 javax.security.auth.login 中的构造方法
AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
此类的默认构造方法。

javax.security.auth.spi 中 Map 的使用

参数类型为 Map 的 javax.security.auth.spi 中的方法
void | LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options) 初始化此 LoginModule。
void | LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options) 初始化此 LoginModule。

javax.security.auth.x500 中 Map 的使用

参数类型为 Map 的 javax.security.auth.x500 中的方法
 String X500Principal.getName(String format, Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。

参数类型为 Map 的 javax.security.auth.x500 中的构造方法
X500Principal(String name, Map<String,String> keywordMap)
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。

javax.security.sasl 中 Map 的使用

参数类型为 Map 的 javax.security.sasl 中的方法
static SaslClient | Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
SaslClient | SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
static SaslServer | Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 为指定机制创建一个 SaslServer。
SaslServer | SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslServer。
String[] | SaslClientFactory.getMechanismNames(Map<String,?> props) 返回与指定的机制选择策略相符的机制的名称数组。
String[] | SaslServerFactory.getMechanismNames(Map<String,?> props) 返回与指定的机制选择策略相符的机制的名称数组。

javax.sound.midi 中 Map 的使用

返回 Map 的 javax.sound.midi 中的方法
 Map<String,Object> MidiFileFormat.properties()
获得属性的一个不可修改的映射。

参数类型为 Map 的 javax.sound.midi 中的构造方法
MidiFileFormat(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)
构造带一组属性的 MidiFileFormat。

javax.sound.sampled 中 Map 的使用

返回 Map 的 javax.sound.sampled 中的方法
Map<String,Object> | AudioFileFormat.properties() 获得不可修改的属性映射。
Map<String,Object> | AudioFormat.properties() 获取不可修改的属性映射。

参数类型为 Map 的 javax.sound.sampled 中的构造方法
AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。
AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
构造具有给定参数的 AudioFormat。

javax.sql 中 Map 的使用

返回 Map 的 javax.sql 中的方法
 Map<String,Class<?>> RowSet.getTypeMap()
获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。

参数类型为 Map 的 javax.sql 中的方法
 void RowSet.setTypeMap(Map<String,Class<?>> map)
将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。

javax.sql.rowset 中 Map 的使用

返回 Map 的 javax.sql.rowset 中的方法
 Map<String,Class<?>> BaseRowSet.getTypeMap()
获取与此 RowSet 对象的 Connection 对象关联的类型映射表。

参数类型为 Map 的 javax.sql.rowset 中的方法
 void BaseRowSet.setTypeMap(Map<String,Class<?>> map)
将给定的 java.util.Map 对象安装为与此 RowSet 对象的 Connection 对象关联的类型映射表。

javax.sql.rowset.serial 中 Map 的使用

参数类型为 Map 的 javax.sql.rowset.serial 中的方法
Object | SerialArray.getArray(long index, int count, Map<String,Class<?>> map) 返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
Object | SerialArray.getArray(Map<String,Class<?>> map) 返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。
Object[] | SerialStruct.getAttributes(Map<String,Class<?>> map) 获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。
Object | SerialRef.getObject(Map<String,Class<?>> map) 返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
ResultSet | SerialArray.getResultSet(long index, int count, Map<String,Class<?>> map) 获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(Map<String,Class<?>> map) 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。

参数类型为 Map 的 javax.sql.rowset.serial 中的构造方法
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。
SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。
SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。
SQLOutputImpl(Vector<?> attributes, Map<String,?> map)
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。

javax.swing 中 Map 的使用

实现 Map 的 javax.swing 中的类
 class UIDefaults
Swing 组件的默认值表。

javax.xml.bind 中 Map 的使用

参数类型为 Map 的 javax.xml.bind 中的方法
static JAXBContext | JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties) 获得 JAXBContext 类的新实例。

javax.xml.crypto.dsig.spec 中 Map 的使用

返回 Map 的 javax.xml.crypto.dsig.spec 中的方法
Map | XPathFilterParameterSpec.getNamespaceMap() 返回名称空间前缀的映射表。
Map | XPathType.getNamespaceMap() 返回名称空间前缀的映射表。

参数类型为 Map 的 javax.xml.crypto.dsig.spec 中的构造方法
XPathFilterParameterSpec(String xPath, Map namespaceMap)
创建带有指定 XPath 表达式和名称空间映射表的 XPathFilterParameterSpec。
XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
创建带有指定 XPath 表达式、过滤器和名称空间映射表的 XPathType 实例。

javax.xml.ws 中 Map 的使用

返回 Map 的 javax.xml.ws 中的方法
Map<String,Object> | Response.getContext() 获取所含的响应上下文。
abstract Map<String,Object> | Endpoint.getProperties() 返回此 Endpoint 实例的属性包。
Map<String,Object> | BindingProvider.getRequestContext() 获取用于初始化请求消息的消息上下文的上下文。
Map<String,Object> | BindingProvider.getResponseContext() 获取处理响应消息所得的上下文。

参数类型为 Map 的 javax.xml.ws 中的方法
abstract  void Endpoint.setProperties(Map<String,Object> properties)
设置此 Endpoint 实例的属性包。

javax.xml.ws.handler 中 Map 的使用

javax.xml.ws.handler 中 Map 的子接口
interface | LogicalMessageContext LogicalMessageContext 接口扩展了 MessageContext，以访问以与协议无关的 LogicalMessage 形式包含的消息。
interface | MessageContext 接口 MessageContext 抽象化由 handle 方法中的处理程序处理的消息上下文。

javax.xml.ws.handler.soap 中 Map 的使用

javax.xml.ws.handler.soap 中 Map 的子接口
 interface SOAPMessageContext
接口 SOAPMessageContext 提供对 RPC 请求或响应的 SOAP 消息的访问。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Map.Entry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Map.Entry
的使用

使用 Map.Entry 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

java.awt 中 Map.Entry 的使用

返回变量类型为 Map.Entry 的类型的 java.awt 中的方法
 Set<Map.Entry<Object,Object>> RenderingHints.entrySet()
返回此 RenderingHints 中所包含映射关系的 Set 视图。

java.security 中 Map.Entry 的使用

返回变量类型为 Map.Entry 的类型的 java.security 中的方法
 Set<Map.Entry<Object,Object>> Provider.entrySet()
返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。

java.util 中 Map.Entry 的使用

实现 Map.Entry 的 java.util 中的类
static class | AbstractMap.SimpleEntry<K,V> 维护键和值的 Entry。
static class | AbstractMap.SimpleImmutableEntry<K,V> 维护不可变的键和值的 Entry。

返回 Map.Entry 的 java.util 中的方法
Map.Entry<K,V> | TreeMap.ceilingEntry(K key)
Map.Entry<K,V> | NavigableMap.ceilingEntry(K key) 返回一个键-值映射关系，它与大于等于给定键的最小键关联；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | TreeMap.firstEntry()
Map.Entry<K,V> | NavigableMap.firstEntry() 返回一个与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
Map.Entry<K,V> | TreeMap.floorEntry(K key)
Map.Entry<K,V> | NavigableMap.floorEntry(K key) 返回一个键-值映射关系，它与小于等于给定键的最大键关联；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | TreeMap.higherEntry(K key)
Map.Entry<K,V> | NavigableMap.higherEntry(K key) 返回一个键-值映射关系，它与严格大于给定键的最小键关联；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | TreeMap.lastEntry()
Map.Entry<K,V> | NavigableMap.lastEntry() 返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。
Map.Entry<K,V> | TreeMap.lowerEntry(K key)
Map.Entry<K,V> | NavigableMap.lowerEntry(K key) 返回一个键-值映射关系，它与严格小于给定键的最大键关联；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | TreeMap.pollFirstEntry()
Map.Entry<K,V> | NavigableMap.pollFirstEntry() 移除并返回与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
Map.Entry<K,V> | TreeMap.pollLastEntry()
Map.Entry<K,V> | NavigableMap.pollLastEntry() 移除并返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。

返回变量类型为 Map.Entry 的类型的 java.util 中的方法
Set<Map.Entry<K,V>> | EnumMap.entrySet() 返回此映射中所包含映射关系的 Set 视图。
Set<Map.Entry<K,V>> | IdentityHashMap.entrySet() 返回此映射所包含映射关系的 Set 视图。
Set<Map.Entry<K,V>> | TreeMap.entrySet() 返回此映射中包含的映射关系的 Set 视图。
Set<Map.Entry<K,V>> | SortedMap.entrySet() 返回在此映射中包含的映射关系的 Set 视图。
Set<Map.Entry<K,V>> | WeakHashMap.entrySet() 返回此映射所包含的映射关系的 Set 视图。
Set<Map.Entry<K,V>> | HashMap.entrySet() 返回此映射所包含的映射关系的 Set 视图。
abstract Set<Map.Entry<K,V>> | AbstractMap.entrySet()
Set<Map.Entry<K,V>> | Hashtable.entrySet() 返回此映射中包含的键的 Set 视图。
Set<Map.Entry<K,V>> | Map.entrySet() 返回此映射中包含的映射关系的 Set 视图。

参数类型为 Map.Entry 的 java.util 中的方法
protected  boolean LinkedHashMap.removeEldestEntry(Map.Entry<K,V> eldest)
如果此映射移除其最旧的条目，则返回 true。

参数类型为 Map.Entry 的 java.util 中的构造方法
AbstractMap.SimpleEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定的项相同。
AbstractMap.SimpleImmutableEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定项相同。

java.util.concurrent 中 Map.Entry 的使用

返回 Map.Entry 的 java.util.concurrent 中的方法
Map.Entry<K,V> | ConcurrentSkipListMap.ceilingEntry(K key) 返回与大于等于给定键的最小键关联的键-值映射关系；如果不存在这样的条目，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.firstEntry() 返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.floorEntry(K key) 返回与小于等于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.higherEntry(K key) 返回与严格大于给定键的最小键关联的键-值映射关系；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.lastEntry() 返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.lowerEntry(K key) 返回与严格小于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.pollFirstEntry() 移除并返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.pollLastEntry() 移除并返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。

返回变量类型为 Map.Entry 的类型的 java.util.concurrent 中的方法
Set<Map.Entry<K,V>> | ConcurrentSkipListMap.entrySet() 返回此映射中所包含的映射关系的 Set 视图。
Set<Map.Entry<K,V>> | ConcurrentHashMap.entrySet() 返回此映射所包含的映射关系的 Set 视图。

java.util.jar 中 Map.Entry 的使用

返回变量类型为 Map.Entry 的类型的 java.util.jar 中的方法
 Set<Map.Entry<Object,Object>> Attributes.entrySet()
返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。

javax.management.openmbean 中 Map.Entry 的使用

返回变量类型为 Map.Entry 的类型的 javax.management.openmbean 中的方法
 Set<Map.Entry<Object,Object>> TabularDataSupport.entrySet()
返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。

javax.script 中 Map.Entry 的使用

返回变量类型为 Map.Entry 的类型的 javax.script 中的方法
 Set<Map.Entry<String,Object>> SimpleBindings.entrySet()
返回此映射中包含的映射关系的 Set 视图。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.MissingFormatArgumentException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.MissingFormatArgumentException
的使用

没有 java.util.MissingFormatArgumentException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.MissingFormatWidthException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.MissingFormatWidthException
的使用

没有 java.util.MissingFormatWidthException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.MissingResourceException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.MissingResourceException
的使用

使用 MissingResourceException 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 MissingResourceException 的使用

抛出 MissingResourceException 的 java.util 中的方法
String | Locale.getISO3Country() 返回此语言环境国家/地区的三字母缩写。
String | Locale.getISO3Language() 返回此语言环境语言的三字母缩写。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.NavigableMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.NavigableMap
的使用

使用 NavigableMap 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 NavigableMap 的使用

实现 NavigableMap 的 java.util 中的类
 class TreeMap<K,V>
基于红黑树（Red-Black tree）的 NavigableMap 实现。

返回 NavigableMap 的 java.util 中的方法
NavigableMap<K,V> | TreeMap.descendingMap()
NavigableMap<K,V> | NavigableMap.descendingMap() 返回此映射中所包含映射关系的逆序视图。
NavigableMap<K,V> | TreeMap.headMap(K toKey, boolean inclusive)
NavigableMap<K,V> | NavigableMap.headMap(K toKey, boolean inclusive) 返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。
NavigableMap<K,V> | TreeMap.subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
NavigableMap<K,V> | NavigableMap.subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive) 返回此映射的部分视图，其键的范围从 fromKey 到 toKey。
NavigableMap<K,V> | TreeMap.tailMap(K fromKey, boolean inclusive)
NavigableMap<K,V> | NavigableMap.tailMap(K fromKey, boolean inclusive) 返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。

java.util.concurrent 中 NavigableMap 的使用

java.util.concurrent 中 NavigableMap 的子接口
 interface ConcurrentNavigableMap<K,V>
支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。

实现 NavigableMap 的 java.util.concurrent 中的类
 class ConcurrentSkipListMap<K,V>
可缩放的并发 ConcurrentNavigableMap 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.NavigableSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.NavigableSet
的使用

使用 NavigableSet 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 NavigableSet 的使用

实现 NavigableSet 的 java.util 中的类
 class TreeSet<E>
基于 TreeMap 的 NavigableSet 实现。

返回 NavigableSet 的 java.util 中的方法
NavigableSet<K> | TreeMap.descendingKeySet()
NavigableSet<K> | NavigableMap.descendingKeySet() 返回此映射中所包含键的逆序 NavigableSet 视图。
NavigableSet<E> | TreeSet.descendingSet()
NavigableSet<E> | NavigableSet.descendingSet() 返回此 set 中所包含元素的逆序视图。
NavigableSet<E> | TreeSet.headSet(E toElement, boolean inclusive)
NavigableSet<E> | NavigableSet.headSet(E toElement, boolean inclusive) 返回此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement。
NavigableSet<K> | TreeMap.navigableKeySet()
NavigableSet<K> | NavigableMap.navigableKeySet() 返回此映射中所包含键的 NavigableSet 视图。
NavigableSet<E> | TreeSet.subSet(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive)
NavigableSet<E> | NavigableSet.subSet(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive) 返回此 set 的部分视图，其元素范围从 fromElement 到 toElement。
NavigableSet<E> | TreeSet.tailSet(E fromElement, boolean inclusive)
NavigableSet<E> | NavigableSet.tailSet(E fromElement, boolean inclusive) 返回此 set 的部分视图，其元素大于（或等于，如果 inclusive 为 true）fromElement。

java.util.concurrent 中 NavigableSet 的使用

实现 NavigableSet 的 java.util.concurrent 中的类
 class ConcurrentSkipListSet<E>
一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。

返回 NavigableSet 的 java.util.concurrent 中的方法
NavigableSet<K> | ConcurrentNavigableMap.descendingKeySet() 返回此映射中所包含键的逆序 NavigableSet 视图。
NavigableSet<K> | ConcurrentSkipListMap.descendingKeySet()
NavigableSet<E> | ConcurrentSkipListSet.descendingSet() 返回此 set 中所包含元素的逆序视图。
NavigableSet<E> | ConcurrentSkipListSet.headSet(E toElement)
NavigableSet<E> | ConcurrentSkipListSet.headSet(E toElement, boolean inclusive)
NavigableSet<K> | ConcurrentNavigableMap.keySet() 返回此映射中所包含键的 NavigableSet 视图。
NavigableSet<K> | ConcurrentSkipListMap.keySet() 返回此映射中所包含键的 NavigableSet 视图。
NavigableSet<K> | ConcurrentNavigableMap.navigableKeySet() 返回此映射中所包含键的 NavigableSet 视图。
NavigableSet<K> | ConcurrentSkipListMap.navigableKeySet()
NavigableSet<E> | ConcurrentSkipListSet.subSet(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive)
NavigableSet<E> | ConcurrentSkipListSet.subSet(E fromElement, E toElement)
NavigableSet<E> | ConcurrentSkipListSet.tailSet(E fromElement)
NavigableSet<E> | ConcurrentSkipListSet.tailSet(E fromElement, boolean inclusive)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.NoSuchElementException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.NoSuchElementException
的使用

使用 NoSuchElementException 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 NoSuchElementException 的使用

java.util 中 NoSuchElementException 的子类
 class InputMismatchException
由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Observable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Observable
的使用

使用 Observable 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 Observable 的使用

参数类型为 Observable 的 java.util 中的方法
 void Observer.update(Observable o, Object arg)
只要改变了 observable 对象就调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Observer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Observer
的使用

使用 Observer 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 Observer 的使用

参数类型为 Observer 的 java.util 中的方法
void | Observable.addObserver(Observer o) 如果观察者与集合中已有的观察者不同，则向对象的观察者集中添加此观察者。
void | Observable.deleteObserver(Observer o) 从对象的观察者集合中删除某个观察者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.PriorityQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.PriorityQueue
的使用

使用 PriorityQueue 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 PriorityQueue 的使用

参数类型为 PriorityQueue 的 java.util 中的构造方法
PriorityQueue(PriorityQueue<? extends E> c)
创建包含指定优先级队列元素的 PriorityQueue。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Properties 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Properties
的使用

使用 Properties 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.naming | 为访问命名服务提供类和接口。
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

java.awt 中 Properties 的使用

参数类型为 Properties 的 java.awt 中的方法
abstract  PrintJob Toolkit.getPrintJob(Frame frame, String jobtitle, Properties props)
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

java.lang 中 Properties 的使用

返回 Properties 的 java.lang 中的方法
static Properties System.getProperties()
确定当前的系统属性。

参数类型为 Properties 的 java.lang 中的方法
static void System.setProperties(Properties props)
将系统属性设置为 Properties 参数。

java.rmi.activation 中 Properties 的使用

返回 Properties 的 java.rmi.activation 中的方法
 Properties ActivationGroupDesc.getPropertyOverrides()
返回组的重写属性列表。

参数类型为 Properties 的 java.rmi.activation 中的构造方法
ActivationGroupDesc(Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
使用组实现的系统默认值和代码基来构造一个组描述符。
ActivationGroupDesc(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
指定一个用于该组的替代组实现和执行环境。

java.security 中 Properties 的使用

java.security 中 Properties 的子类
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

java.sql 中 Properties 的使用

返回 Properties 的 java.sql 中的方法
 Properties Connection.getClientInfo()
返回一个列表，它包含驱动程序支持的每个客户端信息属性的名称和当前值。

参数类型为 Properties 的 java.sql 中的方法
Connection | Driver.connect(String url, Properties info) 试图创建一个到给定 URL 的数据库连接。
static Connection | DriverManager.getConnection(String url, Properties info) 试图建立到给定数据库 URL 的连接。
DriverPropertyInfo[] | Driver.getPropertyInfo(String url, Properties info) 获得此驱动程序的可能属性信息。
void | Connection.setClientInfo(Properties properties) 设置连接的客户端信息属性的值。

java.util 中 Properties 的使用

声明为 Properties 的 java.util 中的字段
protected  Properties Properties.defaults
一个属性列表，包含属性列表中所有未找到值的键的默认值。

参数类型为 Properties 的 java.util 中的构造方法
Properties(Properties defaults)
创建一个带有指定默认值的空属性列表。

javax.naming 中 Properties 的使用

声明为 Properties 的 javax.naming 中的字段
protected  Properties CompoundName.mySyntax
此组合名称的语法属性。

参数类型为 Properties 的 javax.naming 中的构造方法
CompoundName(Enumeration<String> comps, Properties syntax)
使用 comps 和 syntax 指定的组件构造一个新的组合名称实例。
CompoundName(String n, Properties syntax)
通过解析使用提供的 syntax 属性所指定的语法的字符串 n 来构造一个新的组合名称实例。

javax.xml.transform 中 Properties 的使用

返回 Properties 的 javax.xml.transform 中的方法
Properties | Templates.getOutputProperties() 获取对应于有效 xsl:output 元素的属性。
abstract Properties | Transformer.getOutputProperties() 获取转换的输出属性的副本。

参数类型为 Properties 的 javax.xml.transform 中的方法
abstract  void Transformer.setOutputProperties(Properties oformat)
设置转换的输出属性。

org.omg.CORBA 中 Properties 的使用

参数类型为 Properties 的 org.omg.CORBA 中的方法
static ORB | ORB.init(Applet app, Properties props) 为 applet 创建一个新的 ORB 实例。
static ORB | ORB.init(String[] args, Properties props) 为独立的应用程序创建一个新的 ORB 实例。
protected abstract void | ORB.set_parameters(Applet app, Properties props) 允许使用给定 applet 和参数初始化 ORB 实现。
protected abstract void | ORB.set_parameters(String[] args, Properties props) 允许使用给定的参数和属性初始化 ORB 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.PropertyPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.PropertyPermission
的使用

没有 java.util.PropertyPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.PropertyResourceBundle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.PropertyResourceBundle
的使用

没有 java.util.PropertyResourceBundle 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Queue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Queue
的使用

使用 Queue 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 Queue 的使用

java.util 中 Queue 的子接口
 interface Deque<E>
一个线性 collection，支持在两端插入和移除元素。

实现 Queue 的 java.util 中的类
class | AbstractQueue<E> 此类提供某些 Queue 操作的骨干实现。
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | LinkedList<E> List 接口的链接列表实现。
class | PriorityQueue<E> 一个基于优先级堆的无界优先级队列。

返回 Queue 的 java.util 中的方法
static
<T> Queue<T>
Collections.asLifoQueue(Deque<T> deque)
以后进先出 (Lifo) Queue 的形式返回某个 Deque 的视图。

java.util.concurrent 中 Queue 的使用

java.util.concurrent 中 Queue 的子接口
interface | BlockingDeque<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。
interface | BlockingQueue<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。

实现 Queue 的 java.util.concurrent 中的类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Random 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Random
的使用

使用 Random 的软件包
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.math 中 Random 的使用

参数类型为 Random 的 java.math 中的方法
static BigInteger BigInteger.probablePrime(int bitLength, Random rnd)
返回有可能是素数的、具有指定长度的正 BigInteger。

参数类型为 Random 的 java.math 中的构造方法
BigInteger(int bitLength, int certainty, Random rnd)
构造一个随机生成的正 BigInteger，它可能是一个具有指定 bitLength 的素数。
BigInteger(int numBits, Random rnd)
构造一个随机生成的 BigInteger，它是在 0 到 (2numBits - 1)（包括）范围内均匀分布的值。

java.security 中 Random 的使用

java.security 中 Random 的子类
 class SecureRandom
此类提供强加密随机数生成器 (RNG)。

java.util 中 Random 的使用

参数类型为 Random 的 java.util 中的方法
static void Collections.shuffle(List<?> list, Random rnd)
使用指定的随机源对指定列表进行置换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.RandomAccess 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.RandomAccess
的使用

使用 RandomAccess 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。

java.util 中 RandomAccess 的使用

实现 RandomAccess 的 java.util 中的类
class | ArrayList<E> List 接口的大小可变数组的实现。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | Vector<E> Vector 类可以实现可增长的对象数组。

java.util.concurrent 中 RandomAccess 的使用

实现 RandomAccess 的 java.util.concurrent 中的类
 class CopyOnWriteArrayList<E>
ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。

javax.management 中 RandomAccess 的使用

实现 RandomAccess 的 javax.management 中的类
 class AttributeList
表示 MBean 属性值的列表。

javax.management.relation 中 RandomAccess 的使用

实现 RandomAccess 的 javax.management.relation 中的类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.ResourceBundle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ResourceBundle
的使用

使用 ResourceBundle 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

java.awt 中 ResourceBundle 的使用

参数类型为 ResourceBundle 的 java.awt 中的方法
 void Window.applyResourceBundle(ResourceBundle rb)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
static ComponentOrientation ComponentOrientation.getOrientation(ResourceBundle bdl)
已过时。 在 J2SE 1.4 中，使用 ComponentOrientation.getOrientation(java.util.Locale)。

java.util 中 ResourceBundle 的使用

java.util 中 ResourceBundle 的子类
class | ListResourceBundle ListResourceBundle 是 ResourceBundle 的一个抽象类，用于管理方便而又易于使用的列表中的语言环境资源。
class | PropertyResourceBundle PropertyResourceBundle 是 ResourceBundle 的一个具体子类，它使用属性文件中的静态字符串集来管理语言环境资源。

声明为 ResourceBundle 的 java.util 中的字段
protected  ResourceBundle ResourceBundle.parent
此包的父包。

返回 ResourceBundle 的 java.util 中的方法
static ResourceBundle | ResourceBundle.getBundle(String baseName) 使用指定的基本名称、默认的语言环境和调用者的类加载器获取资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale locale) 使用指定的基本名称、语言环境和调用者的类加载器获取资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale locale, ClassLoader loader) 使用指定的基本名称、语言环境和类加载器获取资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control) 使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ResourceBundle.Control control) 使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, ResourceBundle.Control control) 使用指定基本名称、默认语言环境和指定控件返回一个资源包。
ResourceBundle | ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload) 针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。

参数类型为 ResourceBundle 的 java.util 中的方法
boolean | ResourceBundle.Control.needsReload(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime) 确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。
protected void | ResourceBundle.setParent(ResourceBundle parent) 设置此包的父包。

java.util.logging 中 ResourceBundle 的使用

返回 ResourceBundle 的 java.util.logging 中的方法
ResourceBundle | LogRecord.getResourceBundle() 获取本地化资源包。
ResourceBundle | Logger.getResourceBundle() 获取此 logger 在当前默认语言环境的本地化资源包。

参数类型为 ResourceBundle 的 java.util.logging 中的方法
 void LogRecord.setResourceBundle(ResourceBundle bundle)
设置本地化资源包。

javax.accessibility 中 ResourceBundle 的使用

javax.accessibility 中 ResourceBundle 的子类
 class AccessibleResourceBundle
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.ResourceBundle.Control 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ResourceBundle.Control
的使用

使用 ResourceBundle.Control 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 ResourceBundle.Control 的使用

返回 ResourceBundle.Control 的 java.util 中的方法
static ResourceBundle.Control | ResourceBundle.Control.getControl(List<String> formats) 返回 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats。
static ResourceBundle.Control | ResourceBundle.Control.getNoFallbackControl(List<String> formats) 返回一个 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats，getFallbackLocale 方法在其中返回 null。

参数类型为 ResourceBundle.Control 的 java.util 中的方法
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control) 使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ResourceBundle.Control control) 使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, ResourceBundle.Control control) 使用指定基本名称、默认语言环境和指定控件返回一个资源包。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Scanner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Scanner
的使用

使用 Scanner 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 Scanner 的使用

返回 Scanner 的 java.util 中的方法
Scanner | Scanner.reset() 重置此扫描器。
Scanner | Scanner.skip(Pattern pattern) 在忽略分隔符的情况下跳过与指定模式匹配的输入信息。
Scanner | Scanner.skip(String pattern) 跳过与从指定字符串构造的模式匹配的输入信息。
Scanner | Scanner.useDelimiter(Pattern pattern) 将此扫描器的分隔模式设置为指定模式。
Scanner | Scanner.useDelimiter(String pattern) 将此扫描器的分隔模式设置为从指定 String 构造的模式。
Scanner | Scanner.useLocale(Locale locale) 将此扫描器的语言环境设置为指定的语言环境。
Scanner | Scanner.useRadix(int radix) 将此扫描器的默认基数设置为指定基数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.ServiceConfigurationError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ServiceConfigurationError
的使用

没有 java.util.ServiceConfigurationError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.ServiceLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ServiceLoader
的使用

使用 ServiceLoader 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 ServiceLoader 的使用

返回 ServiceLoader 的 java.util 中的方法
static
<S> ServiceLoader<S>
ServiceLoader.load(Class<S> service)
针对给定服务类型创建新的服务加载器，使用当前线程的上下文类加载器。
static
<S> ServiceLoader<S>
ServiceLoader.load(Class<S> service, ClassLoader loader)
针对给定服务类型和类加载器创建新的服务加载器。
static
<S> ServiceLoader<S>
ServiceLoader.loadInstalled(Class<S> service)
针对给定服务类型创建新的服务加载器，使用扩展类加载器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.Set 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Set
的使用

使用 Set 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.imageio | Java Image I/O API 的主要包。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

java.awt 中 Set 的使用

返回 Set 的 java.awt 中的方法
Set<Map.Entry<Object,Object>> | RenderingHints.entrySet() 返回此 RenderingHints 中所包含映射关系的 Set 视图。
Set<AWTKeyStroke> | KeyboardFocusManager.getDefaultFocusTraversalKeys(int id) 返回给定遍历操作的默认焦点遍历键的 Set。
Set<AWTKeyStroke> | Window.getFocusTraversalKeys(int id) 获取此窗口的焦点遍历键。
Set<AWTKeyStroke> | Container.getFocusTraversalKeys(int id) 为此 Container 的给定遍历操作返回焦点遍历键的 Set。
Set<AWTKeyStroke> | Component.getFocusTraversalKeys(int id) 返回此 Component 的给定遍历操作的焦点遍历键 Set。
Set<Object> | RenderingHints.keySet() 返回此 RenderingHints 中所包含键的 Set 视图。

参数类型为 Set 的 java.awt 中的方法
void | KeyboardFocusManager.setDefaultFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 设置给定遍历操作的默认焦点遍历键。
void | Container.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 为此 Container 的给定遍历操作设置焦点遍历键。
void | Component.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 为此 Component 的给定遍历操作设置焦点遍历键。

java.nio.channels 中 Set 的使用

返回 Set 的 java.nio.channels 中的方法
abstract Set<SelectionKey> | Selector.keys() 返回此选择器的键集。
abstract Set<SelectionKey> | Selector.selectedKeys() 返回此选择器的已选择键集。

java.nio.channels.spi 中 Set 的使用

返回 Set 的 java.nio.channels.spi 中的方法
protected  Set<SelectionKey> AbstractSelector.cancelledKeys()
获取此选择器的已取消键集。

java.nio.charset 中 Set 的使用

返回 Set 的 java.nio.charset 中的方法
 Set<String> Charset.aliases()
返回包含此 charset 各个别名的集合。

java.security 中 Set 的使用

返回 Set 的 java.security 中的方法
Set<Map.Entry<Object,Object>> | Provider.entrySet() 返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。
static Set<String> | Security.getAlgorithms(String serviceName) 返回字符串 Set，这些字符串包含了指定的 Java 加密服务的所有可用算法或类型的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。
Set<Provider.Service> | Provider.getServices() 获取此 Provider 支持的所有服务的一个不可修改的 Set。
Set<Object> | Provider.keySet() 返回此 provider 中所包含的属性键的一个不可修改的 Set 视图。

java.security.cert 中 Set 的使用

返回 Set 的 java.security.cert 中的方法
Set<String> | X509Extension.getCriticalExtensionOIDs() 获取实现此接口的对象所管理的证书/CRL 中，被标记为 CRITICAL 的扩展的 OID 字符串 Set。
Set<String> | PolicyNode.getExpectedPolicies() 返回预期的策略集，其中的策略将满足下一个要处理证书中此节点的有效策略。
Set<String> | X509CertSelector.getExtendedKeyUsage() 返回 extendedKeyUsage 标准。
Set<String> | PKIXParameters.getInitialPolicies() 返回初始策略标识符（OID 字符串）的不可变 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。
Set<String> | X509Extension.getNonCriticalExtensionOIDs() 获取实现此接口的对象所管理的证书/CRL 中，被标记为 NON-CRITICAL 的扩展的 OID 字符串 Set。
Set<String> | X509CertSelector.getPolicy() 返回策略标准。
Set<? extends PolicyQualifierInfo> | PolicyNode.getPolicyQualifiers() 返回与此节点所表示的有效策略相关联的策略限定符集。
abstract Set<? extends X509CRLEntry> | X509CRL.getRevokedCertificates() 获取此 CRL 中的所有项。
abstract Set<String> | PKIXCertPathChecker.getSupportedExtensions() 返回一个此 PKIXCertPathChecker 支持（也就是识别，即能够处理）的 X.509 证书扩展的不可变的 Set，如果不支持这些扩展，则返回 null。
Set<TrustAnchor> | PKIXParameters.getTrustAnchors() 返回不可变的、最受信任的 CA Set。

参数类型为 Set 的 java.security.cert 中的方法
void | X509CertSelector.setExtendedKeyUsage(Set<String> keyPurposeSet) 设置 extendedKeyUsage 标准。
void | PKIXParameters.setInitialPolicies(Set<String> initialPolicies) 设置初始策略标识符（OID 字符串）的 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。
void | X509CertSelector.setPolicy(Set<String> certPolicySet) 设置策略限制。
void | PKIXParameters.setTrustAnchors(Set<TrustAnchor> trustAnchors) 设置最受信任的 CA Set。

参数类型为 Set 的 java.security.cert 中的构造方法
PKIXBuilderParameters(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。
PKIXParameters(Set<TrustAnchor> trustAnchors)
创建具有指定最受信任 CA Set 的 PKIXParameters 的实例。

java.text 中 Set 的使用

返回 Set 的 java.text 中的方法
 Set<AttributedCharacterIterator.Attribute> AttributedCharacterIterator.getAllAttributeKeys()
返回定义于迭代器文本范围上的所有属性的键。

参数类型为 Set 的 java.text 中的方法
int | AttributedCharacterIterator.getRunLimit(Set<? extends AttributedCharacterIterator.Attribute> attributes) 返回关于包含当前字符的给定多个属性的运行之后的第一个字符的索引。
int | AttributedCharacterIterator.getRunStart(Set<? extends AttributedCharacterIterator.Attribute> attributes) 返回关于包含当前字符的给定多个属性的运行的第一个字符的索引。

java.util 中 Set 的使用

java.util 中 Set 的子接口
interface | NavigableSet<E> 扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
interface | SortedSet<E> 进一步提供关于元素的总体排序 的 Set。

实现 Set 的 java.util 中的类
class | AbstractSet<E> 此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。

声明为 Set 的 java.util 中的字段
static Set Collections.EMPTY_SET
空的 set（不可变的）。

返回 Set 的 java.util 中的方法
static
<E> Set<E>
Collections.checkedSet(Set<E> s, Class<E> type)
返回指定 set 的一个动态类型安全视图。
static
<T> Set<T>
Collections.emptySet()
返回空的 set（不可变的）。
 Set<Map.Entry<K,V>> EnumMap.entrySet()
返回此映射中所包含映射关系的 Set 视图。
 Set<Map.Entry<K,V>> IdentityHashMap.entrySet()
返回此映射所包含映射关系的 Set 视图。
 Set<Map.Entry<K,V>> TreeMap.entrySet()
返回此映射中包含的映射关系的 Set 视图。
 Set<Map.Entry<K,V>> SortedMap.entrySet()
返回在此映射中包含的映射关系的 Set 视图。
 Set<Map.Entry<K,V>> WeakHashMap.entrySet()
返回此映射所包含的映射关系的 Set 视图。
 Set<Map.Entry<K,V>> HashMap.entrySet()
返回此映射所包含的映射关系的 Set 视图。
abstract  Set<Map.Entry<K,V>> AbstractMap.entrySet()
 Set<Map.Entry<K,V>> Hashtable.entrySet()
返回此映射中包含的键的 Set 视图。
 Set<Map.Entry<K,V>> Map.entrySet()
返回此映射中包含的映射关系的 Set 视图。
protected  Set<String> PropertyResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。
protected  Set<String> ListResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。
protected  Set<String> ResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。
 Set<K> EnumMap.keySet()
返回此映射中所包含键的 Set 视图。
 Set<K> IdentityHashMap.keySet()
返回映射中所包含键的基于标识的 set 视图。
 Set<K> TreeMap.keySet()
返回此映射包含的键的 Set 视图。
 Set<K> SortedMap.keySet()
返回在此映射中所包含键的 Set 视图。
 Set<K> WeakHashMap.keySet()
返回此映射所包含的键的 Set 视图。
 Set<String> ResourceBundle.keySet()
返回此 ResourceBundle 及其父包中包含的所有键的 Set。
 Set<K> HashMap.keySet()
返回此映射中所包含的键的 Set 视图。
 Set<K> AbstractMap.keySet()
返回此映射中包含的键的 Set 视图。
 Set<K> Hashtable.keySet()
返回此映射中包含的键的 Set 视图。
 Set<K> Map.keySet()
返回此映射中包含的键的 Set 视图。
static
<E> Set<E>
Collections.newSetFromMap(Map<E,Boolean> map)
返回指定映射支持的 set。
static
<T> Set<T>
Collections.singleton(T o)
返回一个只包含指定对象的不可变 set。
 Set<String> Properties.stringPropertyNames()
返回此属性列表中的键集，其中该键及其对应值是字符串，如果在主属性列表中未找到同名的键，则还包括默认属性列表中不同的键。
static
<T> Set<T>
Collections.synchronizedSet(Set<T> s)
返回指定 set 支持的同步（线程安全的）set。
static
<T> Set<T>
Collections.unmodifiableSet(Set<? extends T> s)
返回指定 set 的不可修改视图。

参数类型为 Set 的 java.util 中的方法
static
<E> Set<E>
Collections.checkedSet(Set<E> s, Class<E> type)
返回指定 set 的一个动态类型安全视图。
static
<T> Set<T>
Collections.synchronizedSet(Set<T> s)
返回指定 set 支持的同步（线程安全的）set。
static
<T> Set<T>
Collections.unmodifiableSet(Set<? extends T> s)
返回指定 set 的不可修改视图。

java.util.concurrent 中 Set 的使用

实现 Set 的 java.util.concurrent 中的类
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。

返回 Set 的 java.util.concurrent 中的方法
Set<Map.Entry<K,V>> | ConcurrentSkipListMap.entrySet() 返回此映射中所包含的映射关系的 Set 视图。
Set<Map.Entry<K,V>> | ConcurrentHashMap.entrySet() 返回此映射所包含的映射关系的 Set 视图。
Set<K> | ConcurrentHashMap.keySet() 返回此映射中包含的键的 Set 视图。

java.util.jar 中 Set 的使用

返回 Set 的 java.util.jar 中的方法
Set<Map.Entry<Object,Object>> | Attributes.entrySet() 返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。
Set<Object> | Attributes.keySet() 返回此 Map 所包含的属性名称（键）的 Set 视图。

javax.annotation.processing 中 Set 的使用

返回 Set 的 javax.annotation.processing 中的方法
Set<? extends Element> | RoundEnvironment.getElementsAnnotatedWith(Class<? extends Annotation> a) 返回使用给定注释类型注释的元素。
Set<? extends Element> | RoundEnvironment.getElementsAnnotatedWith(TypeElement a) 返回使用给定注释类型注释的元素。
Set<? extends Element> | RoundEnvironment.getRootElements() 返回以前的 round 生成的注释处理根元素。
Set<String> | AbstractProcessor.getSupportedAnnotationTypes() 如果 processor 类是使用 SupportedAnnotationTypes 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。
Set<String> | Processor.getSupportedAnnotationTypes() 返回此 Processor 支持的注释类型的名称。
Set<String> | AbstractProcessor.getSupportedOptions() 如果 processor 类是使用 SupportedOptions 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。
Set<String> | Processor.getSupportedOptions() 返回此 Processor 识别的选项。

参数类型为 Set 的 javax.annotation.processing 中的方法
abstract boolean | AbstractProcessor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
boolean | Processor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。

javax.imageio 中 Set 的使用

参数类型为 Set 的 javax.imageio 中的方法
IIOMetadata | ImageReader.getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames) 返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。
IIOMetadata | ImageReader.getStreamMetadata(String formatName, Set<String> nodeNames) 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。

javax.lang.model.element 中 Set 的使用

返回 Set 的 javax.lang.model.element 中的方法
 Set<Modifier> Element.getModifiers()
返回此元素的修饰符，不包括注释。

javax.lang.model.util 中 Set 的使用

返回 Set 的 javax.lang.model.util 中的方法
static Set<ExecutableElement> | ElementFilter.constructorsIn(Set<? extends Element> elements) 返回 elements 中构造方法的集合。
static Set<VariableElement> | ElementFilter.fieldsIn(Set<? extends Element> elements) 返回 elements 中字段的集合。
static Set<ExecutableElement> | ElementFilter.methodsIn(Set<? extends Element> elements) 返回 elements 中方法的集合。
static Set<PackageElement> | ElementFilter.packagesIn(Set<? extends Element> elements) 返回 elements 中包的集合。
static Set<TypeElement> | ElementFilter.typesIn(Set<? extends Element> elements) 返回 elements 中类型的集合。

参数类型为 Set 的 javax.lang.model.util 中的方法
static Set<ExecutableElement> | ElementFilter.constructorsIn(Set<? extends Element> elements) 返回 elements 中构造方法的集合。
static Set<VariableElement> | ElementFilter.fieldsIn(Set<? extends Element> elements) 返回 elements 中字段的集合。
static Set<ExecutableElement> | ElementFilter.methodsIn(Set<? extends Element> elements) 返回 elements 中方法的集合。
static Set<PackageElement> | ElementFilter.packagesIn(Set<? extends Element> elements) 返回 elements 中包的集合。
static Set<TypeElement> | ElementFilter.typesIn(Set<? extends Element> elements) 返回 elements 中类型的集合。

javax.management 中 Set 的使用

返回 Set 的 javax.management 中的方法
Set<ObjectInstance> | MBeanServer.queryMBeans(ObjectName name, QueryExp query)
Set<ObjectInstance> | MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean。
Set<ObjectName> | MBeanServer.queryNames(ObjectName name, QueryExp query)
Set<ObjectName> | MBeanServerConnection.queryNames(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean 的名称。

javax.management.loading 中 Set 的使用

返回 Set 的 javax.management.loading 中的方法
Set<Object> | MLet.getMBeansFromURL(String url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLetMBean.getMBeansFromURL(String url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLet.getMBeansFromURL(URL url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLetMBean.getMBeansFromURL(URL url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

javax.management.openmbean 中 Set 的使用

返回 Set 的 javax.management.openmbean 中的方法
Set<Map.Entry<Object,Object>> | TabularDataSupport.entrySet() 返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。
Set<?> | OpenMBeanAttributeInfoSupport.getLegalValues() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的合法值的不可修改的 Set（如果已指定），否则返回 null。
Set<?> | OpenMBeanParameterInfo.getLegalValues() 返回此参数的合法值的集合（如果存在），否则返回 null。
Set<?> | OpenMBeanParameterInfoSupport.getLegalValues() 返回此 OpenMBeanParameterInfoSupport 实例描述的合法参数值的不可修改的 Set（如果指定），否则返回 null。
Set<String> | CompositeType.keySet() 返回此 CompositeType 实例定义的所有项名称的不可修改的 Set 视图。
Set<?> | TabularData.keySet() 返回此 TabularData 实例中包含的 CompositeData 值（即各行）的键（即索引值）的 set 视图。
Set<Object> | TabularDataSupport.keySet() 返回包含在此 TabularDataSupport 实例的基础映射中的键的 set 视图，并用于索引行。

javax.management.remote.rmi 中 Set 的使用

返回 Set 的 javax.management.remote.rmi 中的方法
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

javax.print.attribute.standard 中 Set 的使用

实现 Set 的 javax.print.attribute.standard 中的类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

返回 Set 的 javax.print.attribute.standard 中的方法
 Set<PrinterStateReason> PrinterStateReasons.printerStateReasonSet(Severity severity)
在此 PrinterStateReasons 中，获得在给定的严重性级别每个 PrinterStateReasons 属性的不可修改的视图集。

javax.script 中 Set 的使用

返回 Set 的 javax.script 中的方法
Set<Map.Entry<String,Object>> | SimpleBindings.entrySet() 返回此映射中包含的映射关系的 Set 视图。
Set<String> | SimpleBindings.keySet() 返回此映射中包含的键的 Set 视图。

javax.security.auth 中 Set 的使用

返回 Set 的 javax.security.auth 中的方法
 Set<Principal> Subject.getPrincipals()
返回与此 Subject 关联的 Principal Set。
<T extends Principal>
Set<T>
Subject.getPrincipals(Class<T> c)
返回与此 Subject 关联的 Principal Set，它是指定的 Class 的实例或子类。
 Set<Object> Subject.getPrivateCredentials()
返回此 Subject 中包含的私有证书 Set。
<T> Set<T>
Subject.getPrivateCredentials(Class<T> c)
返回与此 Subject关联的私有证书 Set，它是指定的 Class 的实例或子类。
 Set<Object> Subject.getPublicCredentials()
返回此 Subject 中包含的公开证书 Set。
<T> Set<T>
Subject.getPublicCredentials(Class<T> c)
返回与此 Subject 关联的公开证书 Set，它是指定的 Class 的实例或子类。

参数类型为 Set 的 javax.security.auth 中的构造方法
Subject(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
创建带有 Principal 和证书的 Subject 的实例。
Subject(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
创建带有 Principal 和证书的 Subject 的实例。
Subject(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
创建带有 Principal 和证书的 Subject 的实例。

javax.swing 中 Set 的使用

参数类型为 Set 的 javax.swing 中的方法
 void JComponent.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes)
设置针对此 Component 的给定遍历操作的焦点遍历键。

javax.tools 中 Set 的使用

返回 Set 的 javax.tools 中的方法
 Set<SourceVersion> Tool.getSourceVersions()
获取此工具支持的 Java™ 编程语言的源版本。

参数类型为 Set 的 javax.tools 中的方法
Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
Iterable<JavaFileObject> | JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。

javax.xml.ws.handler.soap 中 Set 的使用

返回 Set 的 javax.xml.ws.handler.soap 中的方法
Set<QName> | SOAPHandler.getHeaders() 获取可以由此处理程序实例处理的头块。
Set<String> | SOAPMessageContext.getRoles() 获取与执行处理程序链关联的 SOAP 参与者角色。

javax.xml.ws.soap 中 Set 的使用

返回 Set 的 javax.xml.ws.soap 中的方法
 Set<String> SOAPBinding.getRoles()
获取 SOAP 绑定实例所扮演的角色。

参数类型为 Set 的 javax.xml.ws.soap 中的方法
 void SOAPBinding.setRoles(Set<String> roles)
设置由 SOAP 绑定实例扮演的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.SimpleTimeZone 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.SimpleTimeZone
的使用

没有 java.util.SimpleTimeZone 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.SortedMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.SortedMap
的使用

使用 SortedMap 的软件包
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.nio.charset 中 SortedMap 的使用

返回 SortedMap 的 java.nio.charset 中的方法
static SortedMap<String,Charset> Charset.availableCharsets()
构造从规范 charset 名称到 charset 对象的有序映射。

java.util 中 SortedMap 的使用

java.util 中 SortedMap 的子接口
 interface NavigableMap<K,V>
扩展的 SortedMap，具有了针对给定搜索目标返回最接近匹配项的导航方法。

实现 SortedMap 的 java.util 中的类
 class TreeMap<K,V>
基于红黑树（Red-Black tree）的 NavigableMap 实现。

返回 SortedMap 的 java.util 中的方法
static
<K,V> SortedMap<K,V>
Collections.checkedSortedMap(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定有序映射的一个动态类型安全视图。
 SortedMap<K,V> TreeMap.headMap(K toKey)
 SortedMap<K,V> NavigableMap.headMap(K toKey)
返回此映射的部分视图，其键值严格小于 toKey。
 SortedMap<K,V> SortedMap.headMap(K toKey)
返回此映射的部分视图，其键值严格小于 toKey。
 SortedMap<K,V> TreeMap.subMap(K fromKey, K toKey)
 SortedMap<K,V> NavigableMap.subMap(K fromKey, K toKey)
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
 SortedMap<K,V> SortedMap.subMap(K fromKey, K toKey)
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
static
<K,V> SortedMap<K,V>
Collections.synchronizedSortedMap(SortedMap<K,V> m)
返回指定有序映射支持的同步（线程安全的）有序映射。
 SortedMap<K,V> TreeMap.tailMap(K fromKey)
 SortedMap<K,V> NavigableMap.tailMap(K fromKey)
返回此映射的部分视图，其键大于等于 fromKey。
 SortedMap<K,V> SortedMap.tailMap(K fromKey)
返回此映射的部分视图，其键大于等于 fromKey。
static
<K,V> SortedMap<K,V>
Collections.unmodifiableSortedMap(SortedMap<K,? extends V> m)
返回指定有序映射的不可修改视图。

参数类型为 SortedMap 的 java.util 中的方法
static
<K,V> SortedMap<K,V>
Collections.checkedSortedMap(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定有序映射的一个动态类型安全视图。
static
<K,V> SortedMap<K,V>
Collections.synchronizedSortedMap(SortedMap<K,V> m)
返回指定有序映射支持的同步（线程安全的）有序映射。
static
<K,V> SortedMap<K,V>
Collections.unmodifiableSortedMap(SortedMap<K,? extends V> m)
返回指定有序映射的不可修改视图。

参数类型为 SortedMap 的 java.util 中的构造方法
TreeMap(SortedMap<K,? extends V> m)
构造一个与指定有序映射具有相同映射关系和相同排序顺序的新的树映射。

java.util.concurrent 中 SortedMap 的使用

java.util.concurrent 中 SortedMap 的子接口
 interface ConcurrentNavigableMap<K,V>
支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。

实现 SortedMap 的 java.util.concurrent 中的类
 class ConcurrentSkipListMap<K,V>
可缩放的并发 ConcurrentNavigableMap 实现。

参数类型为 SortedMap 的 java.util.concurrent 中的构造方法
ConcurrentSkipListMap(SortedMap<K,? extends V> m)
构造一个新映射，该映射所包含的映射关系与指定的有序映射包含的映射关系相同，使用的顺序也相同。

java.util.jar 中 SortedMap 的使用

返回 SortedMap 的 java.util.jar 中的方法
SortedMap<String,String> | Pack200.Packer.properties() 获取此引擎属性集。
SortedMap<String,String> | Pack200.Unpacker.properties() 获取此引擎属性集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.SortedSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.SortedSet
的使用

使用 SortedSet 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 SortedSet 的使用

java.util 中 SortedSet 的子接口
 interface NavigableSet<E>
扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。

实现 SortedSet 的 java.util 中的类
 class TreeSet<E>
基于 TreeMap 的 NavigableSet 实现。

返回 SortedSet 的 java.util 中的方法
static
<E> SortedSet<E>
Collections.checkedSortedSet(SortedSet<E> s, Class<E> type)
返回指定有序 set 的一个动态类型安全视图。
 SortedSet<E> TreeSet.headSet(E toElement)
 SortedSet<E> NavigableSet.headSet(E toElement)
返回此 set 的部分视图，其元素严格小于 toElement。
 SortedSet<E> SortedSet.headSet(E toElement)
返回此 set 的部分视图，其元素严格小于 toElement。
 SortedSet<E> TreeSet.subSet(E fromElement, E toElement)
 SortedSet<E> NavigableSet.subSet(E fromElement, E toElement)
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
 SortedSet<E> SortedSet.subSet(E fromElement, E toElement)
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
static
<T> SortedSet<T>
Collections.synchronizedSortedSet(SortedSet<T> s)
返回指定有序 set 支持的同步（线程安全的）有序 set。
 SortedSet<E> TreeSet.tailSet(E fromElement)
 SortedSet<E> NavigableSet.tailSet(E fromElement)
返回此 set 的部分视图，其元素大于等于 fromElement。
 SortedSet<E> SortedSet.tailSet(E fromElement)
返回此 set 的部分视图，其元素大于等于 fromElement。
static
<T> SortedSet<T>
Collections.unmodifiableSortedSet(SortedSet<T> s)
返回指定有序 set 的不可修改视图。

参数类型为 SortedSet 的 java.util 中的方法
static
<E> SortedSet<E>
Collections.checkedSortedSet(SortedSet<E> s, Class<E> type)
返回指定有序 set 的一个动态类型安全视图。
static
<T> SortedSet<T>
Collections.synchronizedSortedSet(SortedSet<T> s)
返回指定有序 set 支持的同步（线程安全的）有序 set。
static
<T> SortedSet<T>
Collections.unmodifiableSortedSet(SortedSet<T> s)
返回指定有序 set 的不可修改视图。

参数类型为 SortedSet 的 java.util 中的构造方法
PriorityQueue(SortedSet<? extends E> c)
创建包含指定有序 set 元素的 PriorityQueue。
TreeSet(SortedSet<E> s)
构造一个与指定有序 set 具有相同映射关系和相同排序的新 TreeSet。

java.util.concurrent 中 SortedSet 的使用

实现 SortedSet 的 java.util.concurrent 中的类
 class ConcurrentSkipListSet<E>
一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。

参数类型为 SortedSet 的 java.util.concurrent 中的构造方法
ConcurrentSkipListSet(SortedSet<E> s)
构造一个新 set，该 set 所包含的元素与指定的有序 set 包含的元素相同，使用的顺序也相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Stack 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Stack
的使用

没有 java.util.Stack 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.StringTokenizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.StringTokenizer
的使用

没有 java.util.StringTokenizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Timer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Timer
的使用

没有 java.util.Timer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.TimerTask 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.TimerTask
的使用

使用 TimerTask 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 TimerTask 的使用

参数类型为 TimerTask 的 java.util 中的方法
void | Timer.schedule(TimerTask task, Date time) 安排在指定的时间执行指定的任务。
void | Timer.schedule(TimerTask task, Date firstTime, long period) 安排指定的任务在指定的时间开始进行重复的固定延迟执行。
void | Timer.schedule(TimerTask task, long delay) 安排在指定延迟后执行指定的任务。
void | Timer.schedule(TimerTask task, long delay, long period) 安排指定的任务从指定的延迟后开始进行重复的固定延迟执行。
void | Timer.scheduleAtFixedRate(TimerTask task, Date firstTime, long period) 安排指定的任务在指定的时间开始进行重复的固定速率执行。
void | Timer.scheduleAtFixedRate(TimerTask task, long delay, long period) 安排指定的任务在指定的延迟后开始进行重复的固定速率执行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.TimeZone 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.TimeZone
的使用

使用 TimeZone 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.xml.datatype | XML/Java 类型映射关系。

java.text 中 TimeZone 的使用

返回 TimeZone 的 java.text 中的方法
 TimeZone DateFormat.getTimeZone()
获取时区。

参数类型为 TimeZone 的 java.text 中的方法
 void DateFormat.setTimeZone(TimeZone zone)
为此 DateFormat 对象的日历设置时区。

java.util 中 TimeZone 的使用

java.util 中 TimeZone 的子类
 class SimpleTimeZone
SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。

返回 TimeZone 的 java.util 中的方法
static TimeZone | TimeZone.getDefault() 获取此主机的默认 TimeZone。
TimeZone | GregorianCalendar.getTimeZone()
TimeZone | Calendar.getTimeZone() 获得时区。
static TimeZone | TimeZone.getTimeZone(String ID) 获取给定 ID 的 TimeZone。

参数类型为 TimeZone 的 java.util 中的方法
static Calendar | Calendar.getInstance(TimeZone zone) 使用指定时区和默认语言环境获得一个日历。
static Calendar | Calendar.getInstance(TimeZone zone, Locale aLocale) 使用指定时区和语言环境获得一个日历。
boolean | SimpleTimeZone.hasSameRules(TimeZone other) 如果此时区与另一时区具有相同的规则和偏移量，则返回 true。
boolean | TimeZone.hasSameRules(TimeZone other) 如果此区域和另一个区域具有相同的规则和偏移量，也就是说，如果此区域只可能在 ID 上与另一个区域不同，则返回 true。
static void | TimeZone.setDefault(TimeZone zone) 设置由 getDefault 方法返回的 TimeZone。
void | GregorianCalendar.setTimeZone(TimeZone zone)
void | Calendar.setTimeZone(TimeZone value) 使用给定的时区值来设置时区。

参数类型为 TimeZone 的 java.util 中的构造方法
Calendar(TimeZone zone, Locale aLocale)
构造一个带有指定时区和语言环境的 Calendar。
GregorianCalendar(TimeZone zone)
在具有默认语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(TimeZone zone, Locale aLocale)
在具有给定语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。

javax.xml.datatype 中 TimeZone 的使用

返回 TimeZone 的 javax.xml.datatype 中的方法
abstract  TimeZone XMLGregorianCalendar.getTimeZone(int defaultZoneoffset)
返回此类的 java.util.TimeZone。

参数类型为 TimeZone 的 javax.xml.datatype 中的方法
abstract  GregorianCalendar XMLGregorianCalendar.toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.TooManyListenersException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.TooManyListenersException
的使用

使用 TooManyListenersException 的软件包
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。

java.awt.dnd 中 TooManyListenersException 的使用

抛出 TooManyListenersException 的 java.awt.dnd 中的方法
void | DragGestureRecognizer.addDragGestureListener(DragGestureListener dgl) 注册一个新的 DragGestureListener。
void | DragSourceContext.addDragSourceListener(DragSourceListener dsl) 如果尚未将 DragSourceListener 添加到此 DragSourceContext，则添加一个。
void | DropTarget.addDropTargetListener(DropTargetListener dtl) 添加一个新的 DropTargetListener (UNICAST SOURCE)。

java.beans.beancontext 中 TooManyListenersException 的使用

抛出 TooManyListenersException 的 java.beans.beancontext 中的方法
Object | BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl) BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
Object | BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl) 获得一个可被委托的服务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.TreeMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.TreeMap
的使用

没有 java.util.TreeMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.TreeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.TreeSet
的使用

没有 java.util.TreeSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.UnknownFormatConversionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.UnknownFormatConversionException
的使用

没有 java.util.UnknownFormatConversionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.UnknownFormatFlagsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.UnknownFormatFlagsException
的使用

没有 java.util.UnknownFormatFlagsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.UUID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.UUID
的使用

使用 UUID 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 UUID 的使用

返回 UUID 的 java.util 中的方法
static UUID UUID.fromString(String name)
根据 toString() 方法中描述的字符串标准表示形式创建 UUID。
static UUID UUID.nameUUIDFromBytes(byte[] name)
根据指定的字节数组获取类型 3（基于名称的）UUID 的静态工厂。
static UUID UUID.randomUUID()
获取类型 4（伪随机生成的）UUID 的静态工厂。

参数类型为 UUID 的 java.util 中的方法
 int UUID.compareTo(UUID val)
将此 UUID 与指定的 UUID 比较。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.Vector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Vector
的使用

使用 Vector 的软件包
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

java.awt.image 中 Vector 的使用

返回 Vector 的 java.awt.image 中的方法
Vector<RenderedImage> | BufferedImage.getSources() 返回 RenderedImage 对象的 Vector，该对象是此 BufferedImage 图像数据的直接来源，而不是这些直接来源的来源。
Vector<RenderedImage> | RenderedImage.getSources() 返回作为此 RenderedImage 直接图像数据源的 RenderedImage 向量。

java.awt.image.renderable 中 Vector 的使用

声明为 Vector 的 java.awt.image.renderable 中的字段
protected Vector<Object> | ParameterBlock.parameters 一个非源参数的 Vector，存储为任意 Object。
protected Vector<Object> | ParameterBlock.sources 源的 Vector，存储为任意 Objects。

返回 Vector 的 java.awt.image.renderable 中的方法
Vector<Object> | ParameterBlock.getParameters() 返回参数的整个 Vector。
Vector<Object> | ParameterBlock.getSources() 返回源的整个 Vector。
Vector<RenderableImage> | RenderableImage.getSources() 返回作为此 RenderableImage 的图像数据源的 RenderableImage 的向量。
Vector<RenderableImage> | RenderableImageOp.getSources() 返回作为此 RenderableImage 图像数据源的 RenderableImage 的向量。

参数类型为 Vector 的 java.awt.image.renderable 中的方法
void | ParameterBlock.setParameters(Vector<Object> parameters) 将参数的整个 Vector 设置为给定 Vector。
void | ParameterBlock.setSources(Vector<Object> sources) 将源的整个 Vector 设置为给定 Vector。

参数类型为 Vector 的 java.awt.image.renderable 中的构造方法
ParameterBlock(Vector<Object> sources)
使用源的给定 Vector 构造一个 ParameterBlock。
ParameterBlock(Vector<Object> sources, Vector<Object> parameters)
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。
ParameterBlock(Vector<Object> sources, Vector<Object> parameters)
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。

java.util 中 Vector 的使用

java.util 中 Vector 的子类
 class Stack<E>
Stack 类表示后进先出（LIFO）的对象堆栈。

javax.accessibility 中 Vector 的使用

声明为 Vector 的 javax.accessibility 中的字段
protected Vector<AccessibleRelation> | AccessibleRelationSet.relations Vector 中的每个项表示一个 AccessibleRelation。
protected Vector<AccessibleState> | AccessibleStateSet.states Vector 中的每个项表示一个 AccessibleState。

javax.management 中 Vector 的使用

返回 Vector 的 javax.management 中的方法
Vector<String> | AttributeChangeNotificationFilter.getEnabledAttributes() 获得此过滤器的所有已启用属性名称。
Vector<String> | NotificationFilterSupport.getEnabledTypes() 获得此过滤器的所有允许通知类型。

javax.management.relation 中 Vector 的使用

返回 Vector 的 javax.management.relation 中的方法
Vector<ObjectName> | MBeanServerNotificationFilter.getDisabledObjectNames() 获取禁用的所有 ObjectName。
Vector<ObjectName> | MBeanServerNotificationFilter.getEnabledObjectNames() 获取所有已启用的 ObjectName。

javax.management.timer 中 Vector 的使用

返回 Vector 的 javax.management.timer 中的方法
Vector<Integer> | Timer.getAllNotificationIDs() 获得所有在通知列表中注册的计时器通知标识符。
Vector<Integer> | TimerMBean.getAllNotificationIDs() 获得所有在通知的列表中注册的计时器通知标识符。
Vector<Integer> | Timer.getNotificationIDs(String type) 获得所有与指定类型对应的计时器通知的标识符。
Vector<Integer> | TimerMBean.getNotificationIDs(String type) 获得所有与指定类型对应的计时器通知的标识符。

javax.naming 中 Vector 的使用

声明为 Vector 的 javax.naming 中的字段
protected  Vector<RefAddr> Reference.addrs
包含此 Reference 中所包含的地址。

javax.naming.directory 中 Vector 的使用

声明为 Vector 的 javax.naming.directory 中的字段
protected  Vector<Object> BasicAttribute.values
保存属性的值。

javax.sound.midi 中 Vector 的使用

声明为 Vector 的 javax.sound.midi 中的字段
protected  Vector<Track> Sequence.tracks
此 sequence 中的 MIDI 轨道。

javax.sql.rowset.serial 中 Vector 的使用

参数类型为 Vector 的 javax.sql.rowset.serial 中的构造方法
SQLOutputImpl(Vector<?> attributes, Map<String,?> map)
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。

javax.swing 中 Vector 的使用

声明为 Vector 的 javax.swing 中的字段
protected  Vector<AbstractButton> ButtonGroup.buttons

参数类型为 Vector 的 javax.swing 中的方法
 void JList.setListData(Vector<?> listData)
根据一个 Vector 构造只读 ListModel，然后对此模型调用 setModel。

参数类型为 Vector 的 javax.swing 中的构造方法
DefaultComboBoxModel(Vector<?> v)
构造一个用向量初始化的 DefaultComboBoxModel 对象。
JComboBox(Vector<?> items)
创建包含指定 Vector 中的元素的 JComboBox。
JList(Vector<?> listData)
构造一个 JList，使其显示指定 Vector 中的元素。
JTable(Vector rowData, Vector columnNames)
构造一个 JTable 来显示 Vector 所组成的 Vector rowData 中的值，其列名称为 columnNames。
JTable(Vector rowData, Vector columnNames)
构造一个 JTable 来显示 Vector 所组成的 Vector rowData 中的值，其列名称为 columnNames。
JTree(Vector<?> value)
返回 JTree，指定 Vector 的每个元素作为不被显示的新根节点的子节点。

javax.swing.plaf.basic 中 Vector 的使用

返回 Vector 的 javax.swing.plaf.basic 中的方法
Vector<File> | BasicDirectoryModel.getDirectories()
Vector<File> | BasicDirectoryModel.getFiles()

参数类型为 Vector 的 javax.swing.plaf.basic 中的方法
protected  void BasicDirectoryModel.sort(Vector<? extends File> v)

javax.swing.plaf.multi 中 Vector 的使用

声明为 Vector 的 javax.swing.plaf.multi 中的字段
protected Vector | MultiButtonUI.uis 包含实际 UI 的向量。
protected Vector | MultiColorChooserUI.uis 包含实际 UI 的向量。
protected Vector | MultiComboBoxUI.uis 包含实际 UI 的向量。
protected Vector | MultiDesktopIconUI.uis 包含实际 UI 的向量。
protected Vector | MultiDesktopPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiFileChooserUI.uis 包含实际 UI 的向量。
protected Vector | MultiInternalFrameUI.uis 包含实际 UI 的向量。
protected Vector | MultiLabelUI.uis 包含实际 UI 的向量。
protected Vector | MultiListUI.uis 包含实际 UI 的向量。
protected Vector | MultiMenuBarUI.uis 包含实际 UI 的向量。
protected Vector | MultiMenuItemUI.uis 包含实际 UI 的向量。
protected Vector | MultiOptionPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiPanelUI.uis 包含实际 UI 的向量。
protected Vector | MultiPopupMenuUI.uis 包含实际 UI 的向量。
protected Vector | MultiProgressBarUI.uis 包含实际 UI 的向量。
protected Vector | MultiRootPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiScrollBarUI.uis 包含实际 UI 的向量。
protected Vector | MultiScrollPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiSeparatorUI.uis 包含实际 UI 的向量。
protected Vector | MultiSliderUI.uis 包含实际 UI 的向量。
protected Vector | MultiSpinnerUI.uis 包含实际 UI 的向量。
protected Vector | MultiSplitPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiTabbedPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiTableHeaderUI.uis 包含实际 UI 的向量。
protected Vector | MultiTableUI.uis 包含实际 UI 的向量。
protected Vector | MultiTextUI.uis 包含实际 UI 的向量。
protected Vector | MultiToolBarUI.uis 包含实际 UI 的向量。
protected Vector | MultiToolTipUI.uis 包含实际 UI 的向量。
protected Vector | MultiTreeUI.uis 包含实际 UI 的向量。
protected Vector | MultiViewportUI.uis 包含实际 UI 的向量。

参数类型为 Vector 的 javax.swing.plaf.multi 中的方法
static ComponentUI | MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target) 创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。
protected static ComponentUI[] | MultiLookAndFeel.uisToArray(Vector uis) 创建一个数组，使用来自传入向量的 UI 对象填充它并返回该数组。

javax.swing.table 中 Vector 的使用

声明为 Vector 的 javax.swing.table 中的字段
protected Vector | DefaultTableModel.columnIdentifiers Vector，由多个列标识符组成。
protected Vector | DefaultTableModel.dataVector Vector，由包含多个 Object 值的 Vector 组成。
protected Vector<TableColumn> | DefaultTableColumnModel.tableColumns 此模型中 TableColumn 对象组成的数组

返回 Vector 的 javax.swing.table 中的方法
protected static Vector | DefaultTableModel.convertToVector(Object[] anArray) 返回一个包含与该数组相同的对象的向量。
protected static Vector | DefaultTableModel.convertToVector(Object[][] anArray) 返回一个 vector，该 vector 由包含与该数组相同的对象的多个 vector 组成。
Vector | DefaultTableModel.getDataVector() 返回由多个包含表数据值的 Vector 组成的 Vector。

参数类型为 Vector 的 javax.swing.table 中的方法
void | DefaultTableModel.addColumn(Object columnName, Vector columnData) 将一列添加到模型中。
void | DefaultTableModel.addRow(Vector rowData) 添加一行到模型的结尾。
void | DefaultTableModel.insertRow(int row, Vector rowData) 在模型中的 row 位置插入一行。
void | DefaultTableModel.setColumnIdentifiers(Vector columnIdentifiers) 替换模型中的列标识符。
void | DefaultTableModel.setDataVector(Vector dataVector, Vector columnIdentifiers) 用新的行 Vector（dataVector）替换当前的 dataVector 实例变量。
void | DefaultTableModel.setDataVector(Vector dataVector, Vector columnIdentifiers) 用新的行 Vector（dataVector）替换当前的 dataVector 实例变量。

参数类型为 Vector 的 javax.swing.table 中的构造方法
DefaultTableModel(Vector columnNames, int rowCount)
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。
DefaultTableModel(Vector data, Vector columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。
DefaultTableModel(Vector data, Vector columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。

javax.swing.text 中 Vector 的使用

返回 Vector 的 javax.swing.text 中的方法
protected Vector | StringContent.getPositionsInRange(Vector v, int offset, int length) 返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
protected Vector | GapContent.getPositionsInRange(Vector v, int offset, int length) 返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。

参数类型为 Vector 的 javax.swing.text 中的方法
protected Vector | StringContent.getPositionsInRange(Vector v, int offset, int length) 返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
protected Vector | GapContent.getPositionsInRange(Vector v, int offset, int length) 返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
protected void | StringContent.updateUndoPositions(Vector positions) 在 positions 处重新设置所有 UndoPosRef 实例的位置。
protected void | GapContent.updateUndoPositions(Vector positions, int offset, int length) 重新设置处在 positions 的所有 UndoPosRef 实例的位置。

javax.swing.text.html 中 Vector 的使用

声明为 Vector 的 javax.swing.text.html 中的字段
protected  Vector<DefaultStyledDocument.ElementSpec> HTMLDocument.HTMLReader.parseBuffer

javax.swing.text.html.parser 中 Vector 的使用

声明为 Vector 的 javax.swing.text.html.parser 中的字段
Vector<Element> | DTD.elements
Vector<?> | AttributeList.values

参数类型为 Vector 的 javax.swing.text.html.parser 中的方法
 void ContentModel.getElements(Vector<Element> elemVec)
使用作为此 contentModel 一部分的元素列表更新 elemVec。

参数类型为 Vector 的 javax.swing.text.html.parser 中的构造方法
AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
创建一个属性列表元素。

javax.swing.tree 中 Vector 的使用

声明为 Vector 的 javax.swing.tree 中的字段
protected  Vector DefaultMutableTreeNode.children
子节点的数组，如果此节点没有子节点，则可以为 null

参数类型为 Vector 的 javax.swing.tree 中的方法
protected  void DefaultTreeSelectionModel.notifyPathChange(Vector<javax.swing.tree.PathPlaceHolder> changedPaths, TreePath oldLeadSelection)
通知侦听器路径中的更改。

javax.swing.undo 中 Vector 的使用

声明为 Vector 的 javax.swing.undo 中的字段
protected Vector<UndoableEdit> | CompoundEdit.edits 由此 CompoundEdit 全部撤消/恢复的 UndoableEdit 的集合。
protected Vector<UndoableEditListener> | UndoableEditSupport.listeners

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.WeakHashMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.WeakHashMap
的使用

没有 java.util.WeakHashMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.util.concurrent (Java 2 Platform SE 6)

 java.util.concurrent
接口
BlockingDeque
BlockingQueue
Callable
CompletionService
ConcurrentMap
ConcurrentNavigableMap
Delayed
Executor
ExecutorService
Future
RejectedExecutionHandler
RunnableFuture
RunnableScheduledFuture
ScheduledExecutorService
ScheduledFuture
ThreadFactory
类
AbstractExecutorService
ArrayBlockingQueue
ConcurrentHashMap
ConcurrentLinkedQueue
ConcurrentSkipListMap
ConcurrentSkipListSet
CopyOnWriteArrayList
CopyOnWriteArraySet
CountDownLatch
CyclicBarrier
DelayQueue
Exchanger
ExecutorCompletionService
Executors
FutureTask
LinkedBlockingDeque
LinkedBlockingQueue
PriorityBlockingQueue
ScheduledThreadPoolExecutor
Semaphore
SynchronousQueue
ThreadPoolExecutor
ThreadPoolExecutor.AbortPolicy
ThreadPoolExecutor.CallerRunsPolicy
ThreadPoolExecutor.DiscardOldestPolicy
ThreadPoolExecutor.DiscardPolicy
枚举
TimeUnit
异常
BrokenBarrierException
CancellationException
ExecutionException
RejectedExecutionException
TimeoutException


java.util.concurrent.atomic (Java 2 Platform SE 6)

 java.util.concurrent.atomic
类
AtomicBoolean
AtomicInteger
AtomicIntegerArray
AtomicIntegerFieldUpdater
AtomicLong
AtomicLongArray
AtomicLongFieldUpdater
AtomicMarkableReference
AtomicReference
AtomicReferenceArray
AtomicReferenceFieldUpdater
AtomicStampedReference


类 java.util.concurrent.atomic.AtomicBoolean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicBoolean
的使用

没有 java.util.concurrent.atomic.AtomicBoolean 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicInteger 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicInteger
的使用

没有 java.util.concurrent.atomic.AtomicInteger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicIntegerArray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicIntegerArray
的使用

没有 java.util.concurrent.atomic.AtomicIntegerArray 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater
的使用

使用 AtomicIntegerFieldUpdater 的软件包
java.util.concurrent.atomic 类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.atomic 中 AtomicIntegerFieldUpdater 的使用

返回 AtomicIntegerFieldUpdater 的 java.util.concurrent.atomic 中的方法
static
<U> AtomicIntegerFieldUpdater<U>
AtomicIntegerFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
使用给定字段为对象创建和返回一个更新器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicLong 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicLong
的使用

没有 java.util.concurrent.atomic.AtomicLong 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicLongArray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicLongArray
的使用

没有 java.util.concurrent.atomic.AtomicLongArray 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicLongFieldUpdater 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicLongFieldUpdater
的使用

使用 AtomicLongFieldUpdater 的软件包
java.util.concurrent.atomic 类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.atomic 中 AtomicLongFieldUpdater 的使用

返回 AtomicLongFieldUpdater 的 java.util.concurrent.atomic 中的方法
static
<U> AtomicLongFieldUpdater<U>
AtomicLongFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
为对象创建并返回一个具有给定字段的更新器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicMarkableReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicMarkableReference
的使用

没有 java.util.concurrent.atomic.AtomicMarkableReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicReference
的使用

没有 java.util.concurrent.atomic.AtomicReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicReferenceArray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicReferenceArray
的使用

没有 java.util.concurrent.atomic.AtomicReferenceArray 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater
的使用

使用 AtomicReferenceFieldUpdater 的软件包
java.util.concurrent.atomic 类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.atomic 中 AtomicReferenceFieldUpdater 的使用

返回 AtomicReferenceFieldUpdater 的 java.util.concurrent.atomic 中的方法
static
<U,W> AtomicReferenceFieldUpdater<U,W>
AtomicReferenceFieldUpdater.newUpdater(Class<U> tclass, Class<W> vclass, String fieldName)
使用给定的字段为对象创建和返回一个更新器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.atomic.AtomicStampedReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicStampedReference
的使用

没有 java.util.concurrent.atomic.AtomicStampedReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.AbstractExecutorService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.AbstractExecutorService
的使用

使用 AbstractExecutorService 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 AbstractExecutorService 的使用

java.util.concurrent 中 AbstractExecutorService 的子类
class | ScheduledThreadPoolExecutor ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。
class | ThreadPoolExecutor 一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ArrayBlockingQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ArrayBlockingQueue
的使用

没有 java.util.concurrent.ArrayBlockingQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.BlockingDeque 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.BlockingDeque
的使用

使用 BlockingDeque 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 BlockingDeque 的使用

实现 BlockingDeque 的 java.util.concurrent 中的类
 class LinkedBlockingDeque<E>
一个基于已链接节点的、任选范围的阻塞双端队列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.BlockingQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.BlockingQueue
的使用

使用 BlockingQueue 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 BlockingQueue 的使用

java.util.concurrent 中 BlockingQueue 的子接口
 interface BlockingDeque<E>
支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。

实现 BlockingQueue 的 java.util.concurrent 中的类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

返回 BlockingQueue 的 java.util.concurrent 中的方法
BlockingQueue<Runnable> | ScheduledThreadPoolExecutor.getQueue() 返回此执行程序使用的任务队列。
BlockingQueue<Runnable> | ThreadPoolExecutor.getQueue() 返回此执行程序使用的任务队列。

参数类型为 BlockingQueue 的 java.util.concurrent 中的构造方法
ExecutorCompletionService(Executor executor, BlockingQueue<Future<V>> completionQueue)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将所提供的队列作为其完成队列。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
用给定的初始参数和默认的线程工厂及被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.BrokenBarrierException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.BrokenBarrierException
的使用

使用 BrokenBarrierException 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 BrokenBarrierException 的使用

抛出 BrokenBarrierException 的 java.util.concurrent 中的方法
int | CyclicBarrier.await() 在所有参与者都已经在此 barrier 上调用 await 方法之前，将一直等待。
int | CyclicBarrier.await(long timeout, TimeUnit unit) 在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.Callable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.Callable
的使用

使用 Callable 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.util.concurrent 中 Callable 的使用

返回 Callable 的 java.util.concurrent 中的方法
static Callable<Object> Executors.callable(PrivilegedAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的操作并返回其结果。
static Callable<Object> Executors.callable(PrivilegedExceptionAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的异常操作并返回其结果。
static Callable<Object> Executors.callable(Runnable task)
返回 Callable 对象，调用它时可运行给定的任务并返回 null。
static
<T> Callable<T>
Executors.callable(Runnable task, T result)
返回 Callable 对象，调用它时可运行给定的任务并返回给定的结果。
static
<T> Callable<T>
Executors.privilegedCallable(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中执行给定的 callable 对象。
static
<T> Callable<T>
Executors.privilegedCallableUsingCurrentClassLoader(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中，使用当前上下文类加载器作为上下文类加载器来执行给定的 callable 对象。

参数类型为 Callable 的 java.util.concurrent 中的方法
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Callable<V> callable, RunnableScheduledFuture<V> task)
修改或替换用于执行 callable 的任务。
protected
<T> RunnableFuture<T>
AbstractExecutorService.newTaskFor(Callable<T> callable)
为给定可调用任务返回一个 RunnableFuture。
static
<T> Callable<T>
Executors.privilegedCallable(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中执行给定的 callable 对象。
static
<T> Callable<T>
Executors.privilegedCallableUsingCurrentClassLoader(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中，使用当前上下文类加载器作为上下文类加载器来执行给定的 callable 对象。
<V> ScheduledFuture<V>
ScheduledExecutorService.schedule(Callable<V> callable, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的 ScheduledFuture。
<V> ScheduledFuture<V>
ScheduledThreadPoolExecutor.schedule(Callable<V> callable, long delay, TimeUnit unit)
<T> Future<T>
AbstractExecutorService.submit(Callable<T> task)
<T> Future<T>
ExecutorService.submit(Callable<T> task)
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。
<T> Future<T>
ScheduledThreadPoolExecutor.submit(Callable<T> task)
 Future<V> CompletionService.submit(Callable<V> task)
提交要执行的值返回任务，并返回表示挂起的任务结果的 Future。
 Future<V> ExecutorCompletionService.submit(Callable<V> task)

类型变量类型为 Callable 的 java.util.concurrent 中的方法参数
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。

参数类型为 Callable 的 java.util.concurrent 中的构造方法
FutureTask(Callable<V> callable)
创建一个 FutureTask，一旦运行就执行给定的 Callable。

javax.tools 中 Callable 的使用

javax.tools 中 Callable 的子接口
static interface JavaCompiler.CompilationTask
表示编译任务的 future 的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.CancellationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.CancellationException
的使用

没有 java.util.concurrent.CancellationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.CompletionService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.CompletionService
的使用

使用 CompletionService 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 CompletionService 的使用

实现 CompletionService 的 java.util.concurrent 中的类
 class ExecutorCompletionService<V>
使用提供的 Executor 来执行任务的 CompletionService。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ConcurrentHashMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ConcurrentHashMap
的使用

没有 java.util.concurrent.ConcurrentHashMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ConcurrentLinkedQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ConcurrentLinkedQueue
的使用

没有 java.util.concurrent.ConcurrentLinkedQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.ConcurrentMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ConcurrentMap
的使用

使用 ConcurrentMap 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ConcurrentMap 的使用

java.util.concurrent 中 ConcurrentMap 的子接口
 interface ConcurrentNavigableMap<K,V>
支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。

实现 ConcurrentMap 的 java.util.concurrent 中的类
class | ConcurrentHashMap<K,V> 支持获取的完全并发和更新的所期望可调整并发的哈希表。
class | ConcurrentSkipListMap<K,V> 可缩放的并发 ConcurrentNavigableMap 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.ConcurrentNavigableMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ConcurrentNavigableMap
的使用

使用 ConcurrentNavigableMap 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ConcurrentNavigableMap 的使用

实现 ConcurrentNavigableMap 的 java.util.concurrent 中的类
 class ConcurrentSkipListMap<K,V>
可缩放的并发 ConcurrentNavigableMap 实现。

返回 ConcurrentNavigableMap 的 java.util.concurrent 中的方法
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.descendingMap() 返回此映射中所包含映射关系的逆序视图。
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.descendingMap()
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.headMap(K toKey)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.headMap(K toKey)
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.headMap(K toKey, boolean inclusive)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.headMap(K toKey, boolean inclusive)
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.subMap(K fromKey, K toKey)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.subMap(K fromKey, K toKey)
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.tailMap(K fromKey)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.tailMap(K fromKey)
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.tailMap(K fromKey, boolean inclusive)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.tailMap(K fromKey, boolean inclusive)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ConcurrentSkipListMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ConcurrentSkipListMap
的使用

使用 ConcurrentSkipListMap 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ConcurrentSkipListMap 的使用

返回 ConcurrentSkipListMap 的 java.util.concurrent 中的方法
 ConcurrentSkipListMap<K,V> ConcurrentSkipListMap.clone()
返回此 ConcurrentSkipListMap 实例的浅表副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ConcurrentSkipListSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ConcurrentSkipListSet
的使用

使用 ConcurrentSkipListSet 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ConcurrentSkipListSet 的使用

返回 ConcurrentSkipListSet 的 java.util.concurrent 中的方法
 ConcurrentSkipListSet<E> ConcurrentSkipListSet.clone()
返回此 ConcurrentSkipListSet 实例的浅表副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.CopyOnWriteArrayList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.CopyOnWriteArrayList
的使用

没有 java.util.concurrent.CopyOnWriteArrayList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.CopyOnWriteArraySet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.CopyOnWriteArraySet
的使用

没有 java.util.concurrent.CopyOnWriteArraySet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.CountDownLatch 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.CountDownLatch
的使用

没有 java.util.concurrent.CountDownLatch 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.CyclicBarrier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.CyclicBarrier
的使用

没有 java.util.concurrent.CyclicBarrier 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.Delayed 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.Delayed
的使用

使用 Delayed 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 Delayed 的使用

类型参数类型为 Delayed 的 java.util.concurrent 中的类
 class DelayQueue<E extends Delayed>
Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。

java.util.concurrent 中 Delayed 的子接口
interface | RunnableScheduledFuture<V> 作为 Runnable 的 ScheduledFuture。
interface | ScheduledFuture<V> 一个延迟的、结果可接受的操作，可将其取消。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.DelayQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.DelayQueue
的使用

没有 java.util.concurrent.DelayQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.Exchanger 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.Exchanger
的使用

没有 java.util.concurrent.Exchanger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ExecutionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ExecutionException
的使用

使用 ExecutionException 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.util.concurrent 中 ExecutionException 的使用

抛出 ExecutionException 的 java.util.concurrent 中的方法
 V Future.get()
如有必要，等待计算完成，然后获取其结果。
 V FutureTask.get()
 V Future.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
 V FutureTask.get(long timeout, TimeUnit unit)
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。

javax.swing 中 ExecutionException 的使用

抛出 ExecutionException 的 javax.swing 中的方法
T | SwingWorker.get() 如有必要，等待计算完成，然后获取其结果。
T | SwingWorker.get(long timeout, TimeUnit unit) 如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.Executor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.Executor
的使用

使用 Executor 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

java.util.concurrent 中 Executor 的使用

java.util.concurrent 中 Executor 的子接口
interface | ExecutorService Executor 提供了管理终止的方法，以及可为跟踪一个或多个异步任务执行状况而生成 Future 的方法。
interface | ScheduledExecutorService 一个 ExecutorService，可安排在给定的延迟后运行或定期执行的命令。

实现 Executor 的 java.util.concurrent 中的类
class | AbstractExecutorService 提供 ExecutorService 执行方法的默认实现。
class | ScheduledThreadPoolExecutor ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。
class | ThreadPoolExecutor 一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。

参数类型为 Executor 的 java.util.concurrent 中的构造方法
ExecutorCompletionService(Executor executor)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将 LinkedBlockingQueue 作为完成队列。
ExecutorCompletionService(Executor executor, BlockingQueue<Future<V>> completionQueue)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将所提供的队列作为其完成队列。

javax.management 中 Executor 的使用

参数类型为 Executor 的 javax.management 中的构造方法
NotificationBroadcasterSupport(Executor executor)
构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。
NotificationBroadcasterSupport(Executor executor, MBeanNotificationInfo... info)
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。

javax.xml.ws 中 Executor 的使用

返回 Executor 的 javax.xml.ws 中的方法
abstract Executor | Endpoint.getExecutor() 返回此 Endpoint 实例的执行程序。
Executor | Service.getExecutor() 返回此 Service 实例的执行程序。

参数类型为 Executor 的 javax.xml.ws 中的方法
abstract void | Endpoint.setExecutor(Executor executor) 设置此 Endpoint 实例的执行程序。
void | Service.setExecutor(Executor executor) 设置此 Service 实例的执行程序。

javax.xml.ws.spi 中 Executor 的使用

返回 Executor 的 javax.xml.ws.spi 中的方法
abstract  Executor ServiceDelegate.getExecutor()
返回此 Service 实例的执行程序。

参数类型为 Executor 的 javax.xml.ws.spi 中的方法
abstract  void ServiceDelegate.setExecutor(Executor executor)
设置此 Service 实例的执行程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ExecutorCompletionService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ExecutorCompletionService
的使用

没有 java.util.concurrent.ExecutorCompletionService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.Executors 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.Executors
的使用

没有 java.util.concurrent.Executors 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.ExecutorService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ExecutorService
的使用

使用 ExecutorService 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ExecutorService 的使用

java.util.concurrent 中 ExecutorService 的子接口
 interface ScheduledExecutorService
一个 ExecutorService，可安排在给定的延迟后运行或定期执行的命令。

实现 ExecutorService 的 java.util.concurrent 中的类
class | AbstractExecutorService 提供 ExecutorService 执行方法的默认实现。
class | ScheduledThreadPoolExecutor ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。
class | ThreadPoolExecutor 一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。

返回 ExecutorService 的 java.util.concurrent 中的方法
static ExecutorService | Executors.newCachedThreadPool() 创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们。
static ExecutorService | Executors.newCachedThreadPool(ThreadFactory threadFactory) 创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们，并在需要时使用提供的 ThreadFactory 创建新线程。
static ExecutorService | Executors.newFixedThreadPool(int nThreads) 创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程。
static ExecutorService | Executors.newFixedThreadPool(int nThreads, ThreadFactory threadFactory) 创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程，在需要时使用提供的 ThreadFactory 创建新线程。
static ExecutorService | Executors.newSingleThreadExecutor() 创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程。
static ExecutorService | Executors.newSingleThreadExecutor(ThreadFactory threadFactory) 创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程，并在需要时使用提供的 ThreadFactory 创建新线程。
static ExecutorService | Executors.unconfigurableExecutorService(ExecutorService executor) 返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。

参数类型为 ExecutorService 的 java.util.concurrent 中的方法
static ExecutorService Executors.unconfigurableExecutorService(ExecutorService executor)
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.Future 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.Future
的使用

使用 Future 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.util.concurrent 中 Future 的使用

java.util.concurrent 中 Future 的子接口
interface | RunnableFuture<V> 作为 Runnable 的 Future。
interface | RunnableScheduledFuture<V> 作为 Runnable 的 ScheduledFuture。
interface | ScheduledFuture<V> 一个延迟的、结果可接受的操作，可将其取消。

实现 Future 的 java.util.concurrent 中的类
 class FutureTask<V>
可取消的异步计算。

返回 Future 的 java.util.concurrent 中的方法
 Future<V> CompletionService.poll()
获取并移除表示下一个已完成任务的 Future，如果不存在这样的任务，则返回 null。
 Future<V> ExecutorCompletionService.poll()
 Future<V> CompletionService.poll(long timeout, TimeUnit unit)
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。
 Future<V> ExecutorCompletionService.poll(long timeout, TimeUnit unit)
<T> Future<T>
AbstractExecutorService.submit(Callable<T> task)
<T> Future<T>
ExecutorService.submit(Callable<T> task)
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。
<T> Future<T>
ScheduledThreadPoolExecutor.submit(Callable<T> task)
 Future<V> CompletionService.submit(Callable<V> task)
提交要执行的值返回任务，并返回表示挂起的任务结果的 Future。
 Future<V> ExecutorCompletionService.submit(Callable<V> task)
 Future<?> AbstractExecutorService.submit(Runnable task)
 Future<?> ExecutorService.submit(Runnable task)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
 Future<?> ScheduledThreadPoolExecutor.submit(Runnable task)
<T> Future<T>
AbstractExecutorService.submit(Runnable task, T result)
<T> Future<T>
ExecutorService.submit(Runnable task, T result)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
<T> Future<T>
ScheduledThreadPoolExecutor.submit(Runnable task, T result)
 Future<V> CompletionService.submit(Runnable task, V result)
提交要执行的 Runnable 任务，并返回一个表示任务完成的 Future，可以提取或轮询此任务。
 Future<V> ExecutorCompletionService.submit(Runnable task, V result)
 Future<V> CompletionService.take()
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则等待。
 Future<V> ExecutorCompletionService.take()

返回变量类型为 Future 的类型的 java.util.concurrent 中的方法
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。

类型变量类型为 Future 的 java.util.concurrent 中的构造方法参数
ExecutorCompletionService(Executor executor, BlockingQueue<Future<V>> completionQueue)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将所提供的队列作为其完成队列。

javax.swing 中 Future 的使用

实现 Future 的 javax.swing 中的类
 class SwingWorker<T,V>
在专用线程中执行长时间 GUI 交互任务的抽象类。

javax.xml.ws 中 Future 的使用

javax.xml.ws 中 Future 的子接口
 interface Response<T>
Response 接口提供一些方法，用来获得为响应操作调用而发送的消息的净荷和上下文。

返回 Future 的 javax.xml.ws 中的方法
 Future<?> Dispatch.invokeAsync(T msg, AsyncHandler<T> handler)
异步调用服务操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.FutureTask 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.FutureTask
的使用

没有 java.util.concurrent.FutureTask 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.LinkedBlockingDeque 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.LinkedBlockingDeque
的使用

没有 java.util.concurrent.LinkedBlockingDeque 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.LinkedBlockingQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.LinkedBlockingQueue
的使用

没有 java.util.concurrent.LinkedBlockingQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.PriorityBlockingQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.PriorityBlockingQueue
的使用

没有 java.util.concurrent.PriorityBlockingQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.RejectedExecutionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.RejectedExecutionException
的使用

没有 java.util.concurrent.RejectedExecutionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.RejectedExecutionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.RejectedExecutionHandler
的使用

使用 RejectedExecutionHandler 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 RejectedExecutionHandler 的使用

实现 RejectedExecutionHandler 的 java.util.concurrent 中的类
static class | ThreadPoolExecutor.AbortPolicy 用于被拒绝任务的处理程序，它将抛出 RejectedExecutionException.
static class | ThreadPoolExecutor.CallerRunsPolicy 用于被拒绝任务的处理程序，它直接在 execute 方法的调用线程中运行被拒绝的任务；如果执行程序已关闭，则会丢弃该任务。
static class | ThreadPoolExecutor.DiscardOldestPolicy 用于被拒绝任务的处理程序，它放弃最旧的未处理请求，然后重试 execute；如果执行程序已关闭，则会丢弃该任务。
static class | ThreadPoolExecutor.DiscardPolicy 用于被拒绝任务的处理程序，默认情况下它将丢弃被拒绝的任务。

返回 RejectedExecutionHandler 的 java.util.concurrent 中的方法
 RejectedExecutionHandler ThreadPoolExecutor.getRejectedExecutionHandler()
返回用于未执行任务的当前处理程序。

参数类型为 RejectedExecutionHandler 的 java.util.concurrent 中的方法
 void ThreadPoolExecutor.setRejectedExecutionHandler(RejectedExecutionHandler handler)
设置用于未执行任务的新处理程序。

参数类型为 RejectedExecutionHandler 的 java.util.concurrent 中的构造方法
ScheduledThreadPoolExecutor(int corePoolSize, RejectedExecutionHandler handler)
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int corePoolSize, ThreadFactory threadFactory, RejectedExecutionHandler handler)
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.RunnableFuture 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.RunnableFuture
的使用

使用 RunnableFuture 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.util.concurrent 中 RunnableFuture 的使用

java.util.concurrent 中 RunnableFuture 的子接口
 interface RunnableScheduledFuture<V>
作为 Runnable 的 ScheduledFuture。

实现 RunnableFuture 的 java.util.concurrent 中的类
 class FutureTask<V>
可取消的异步计算。

返回 RunnableFuture 的 java.util.concurrent 中的方法
protected
<T> RunnableFuture<T>
AbstractExecutorService.newTaskFor(Callable<T> callable)
为给定可调用任务返回一个 RunnableFuture。
protected
<T> RunnableFuture<T>
AbstractExecutorService.newTaskFor(Runnable runnable, T value)
为给定可运行任务和默认值返回一个 RunnableFuture。

javax.swing 中 RunnableFuture 的使用

实现 RunnableFuture 的 javax.swing 中的类
 class SwingWorker<T,V>
在专用线程中执行长时间 GUI 交互任务的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.RunnableScheduledFuture 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.RunnableScheduledFuture
的使用

使用 RunnableScheduledFuture 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 RunnableScheduledFuture 的使用

返回 RunnableScheduledFuture 的 java.util.concurrent 中的方法
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Callable<V> callable, RunnableScheduledFuture<V> task)
修改或替换用于执行 callable 的任务。
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Runnable runnable, RunnableScheduledFuture<V> task)
修改或替换用于执行 runnable 的任务。

参数类型为 RunnableScheduledFuture 的 java.util.concurrent 中的方法
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Callable<V> callable, RunnableScheduledFuture<V> task)
修改或替换用于执行 callable 的任务。
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Runnable runnable, RunnableScheduledFuture<V> task)
修改或替换用于执行 runnable 的任务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.ScheduledExecutorService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ScheduledExecutorService
的使用

使用 ScheduledExecutorService 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ScheduledExecutorService 的使用

实现 ScheduledExecutorService 的 java.util.concurrent 中的类
 class ScheduledThreadPoolExecutor
ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。

返回 ScheduledExecutorService 的 java.util.concurrent 中的方法
static ScheduledExecutorService | Executors.newScheduledThreadPool(int corePoolSize) 创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
static ScheduledExecutorService | Executors.newScheduledThreadPool(int corePoolSize, ThreadFactory threadFactory) 创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
static ScheduledExecutorService | Executors.newSingleThreadScheduledExecutor() 创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
static ScheduledExecutorService | Executors.newSingleThreadScheduledExecutor(ThreadFactory threadFactory) 创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
static ScheduledExecutorService | Executors.unconfigurableScheduledExecutorService(ScheduledExecutorService executor) 返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。

参数类型为 ScheduledExecutorService 的 java.util.concurrent 中的方法
static ScheduledExecutorService Executors.unconfigurableScheduledExecutorService(ScheduledExecutorService executor)
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.ScheduledFuture 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ScheduledFuture
的使用

使用 ScheduledFuture 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ScheduledFuture 的使用

java.util.concurrent 中 ScheduledFuture 的子接口
 interface RunnableScheduledFuture<V>
作为 Runnable 的 ScheduledFuture。

返回 ScheduledFuture 的 java.util.concurrent 中的方法
<V> ScheduledFuture<V>
ScheduledExecutorService.schedule(Callable<V> callable, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的 ScheduledFuture。
<V> ScheduledFuture<V>
ScheduledThreadPoolExecutor.schedule(Callable<V> callable, long delay, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.schedule(Runnable command, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的一次性操作。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.schedule(Runnable command, long delay, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ScheduledThreadPoolExecutor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ScheduledThreadPoolExecutor
的使用

没有 java.util.concurrent.ScheduledThreadPoolExecutor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.Semaphore 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.Semaphore
的使用

没有 java.util.concurrent.Semaphore 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.SynchronousQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.SynchronousQueue
的使用

没有 java.util.concurrent.SynchronousQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.ThreadFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ThreadFactory
的使用

使用 ThreadFactory 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ThreadFactory 的使用

返回 ThreadFactory 的 java.util.concurrent 中的方法
static ThreadFactory | Executors.defaultThreadFactory() 返回用于创建新线程的默认线程工厂。
ThreadFactory | ThreadPoolExecutor.getThreadFactory() 返回用于创建新线程的线程工厂。
static ThreadFactory | Executors.privilegedThreadFactory() 返回用于创建新线程的线程工厂，这些新线程与当前线程具有相同的权限。

参数类型为 ThreadFactory 的 java.util.concurrent 中的方法
static ExecutorService | Executors.newCachedThreadPool(ThreadFactory threadFactory) 创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们，并在需要时使用提供的 ThreadFactory 创建新线程。
static ExecutorService | Executors.newFixedThreadPool(int nThreads, ThreadFactory threadFactory) 创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程，在需要时使用提供的 ThreadFactory 创建新线程。
static ScheduledExecutorService | Executors.newScheduledThreadPool(int corePoolSize, ThreadFactory threadFactory) 创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
static ExecutorService | Executors.newSingleThreadExecutor(ThreadFactory threadFactory) 创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程，并在需要时使用提供的 ThreadFactory 创建新线程。
static ScheduledExecutorService | Executors.newSingleThreadScheduledExecutor(ThreadFactory threadFactory) 创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
void | ThreadPoolExecutor.setThreadFactory(ThreadFactory threadFactory) 设置用于创建新线程的线程工厂。

参数类型为 ThreadFactory 的 java.util.concurrent 中的构造方法
ScheduledThreadPoolExecutor(int corePoolSize, ThreadFactory threadFactory)
使用给定的初始参数创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int corePoolSize, ThreadFactory threadFactory, RejectedExecutionHandler handler)
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ThreadPoolExecutor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ThreadPoolExecutor
的使用

使用 ThreadPoolExecutor 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ThreadPoolExecutor 的使用

java.util.concurrent 中 ThreadPoolExecutor 的子类
 class ScheduledThreadPoolExecutor
ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。

参数类型为 ThreadPoolExecutor 的 java.util.concurrent 中的方法
void | RejectedExecutionHandler.rejectedExecution(Runnable r, ThreadPoolExecutor executor) 当 execute 不能接受某个任务时，可以由 ThreadPoolExecutor 调用的方法。
void | ThreadPoolExecutor.CallerRunsPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e) 执行调用者线程中的任务 r；如果执行程序已关闭，则会丢弃该任务。
void | ThreadPoolExecutor.AbortPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e) 总是抛出 RejectedExecutionException。
void | ThreadPoolExecutor.DiscardPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e) 不执行任何操作，在这种情况下将放弃任务 r。
void | ThreadPoolExecutor.DiscardOldestPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e) 获取并忽略下一个任务，否则如果该任务立即可用，执行程序将执行该任务，然后再试图重新执行任务 r；如果执行程序已关闭，则会丢弃任务 r。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ThreadPoolExecutor.AbortPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ThreadPoolExecutor.AbortPolicy
的使用

没有 java.util.concurrent.ThreadPoolExecutor.AbortPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy
的使用

没有 java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy
的使用

没有 java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.ThreadPoolExecutor.DiscardPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ThreadPoolExecutor.DiscardPolicy
的使用

没有 java.util.concurrent.ThreadPoolExecutor.DiscardPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.TimeoutException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.TimeoutException
的使用

使用 TimeoutException 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.util.concurrent 中 TimeoutException 的使用

抛出 TimeoutException 的 java.util.concurrent 中的方法
 int CyclicBarrier.await(long timeout, TimeUnit unit)
在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。
 V Exchanger.exchange(V x, long timeout, TimeUnit unit)
等待另一个线程到达此交换点（除非当前线程被中断，或者超出了指定的等待时间），然后将给定的对象传送给该线程，同时接收该线程的对象。
 V Future.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
 V FutureTask.get(long timeout, TimeUnit unit)
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。

javax.swing 中 TimeoutException 的使用

抛出 TimeoutException 的 javax.swing 中的方法
 T SwingWorker.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.TimeUnit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.TimeUnit
的使用

使用 TimeUnit 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.util.concurrent 中 TimeUnit 的使用

返回 TimeUnit 的 java.util.concurrent 中的方法
static TimeUnit | TimeUnit.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static TimeUnit[] | TimeUnit.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 TimeUnit 的 java.util.concurrent 中的方法
 boolean CountDownLatch.await(long timeout, TimeUnit unit)
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断或超出了指定的等待时间。
 int CyclicBarrier.await(long timeout, TimeUnit unit)
在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。
 boolean ExecutorService.awaitTermination(long timeout, TimeUnit unit)
请求关闭、发生超时或者当前线程中断，无论哪一个首先发生之后，都将导致阻塞，直到所有任务完成执行。
 boolean ThreadPoolExecutor.awaitTermination(long timeout, TimeUnit unit)
 long TimeUnit.convert(long sourceDuration, TimeUnit sourceUnit)
将给定单元的时间段转换到此单元。
 V Exchanger.exchange(V x, long timeout, TimeUnit unit)
等待另一个线程到达此交换点（除非当前线程被中断，或者超出了指定的等待时间），然后将给定的对象传送给该线程，同时接收该线程的对象。
 V Future.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
 V FutureTask.get(long timeout, TimeUnit unit)
 long Delayed.getDelay(TimeUnit unit)
返回与此对象相关的剩余延迟时间，以给定的时间单位表示。
 long ThreadPoolExecutor.getKeepAliveTime(TimeUnit unit)
返回线程保持活动的时间，该时间就是超过核心池大小的线程可以在终止前保持空闲的时间值。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。
 boolean ArrayBlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定的元素插入此队列的尾部，如果该队列已满，则在到达指定的等待时间之前等待可用的空间。
 boolean BlockingDeque.offer(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将在指定的等待时间内一直等待可用空间。
 boolean BlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入此队列中，在到达指定的等待时间前等待可用的空间（如果有必要）。
 boolean DelayQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入此延迟队列中。
 boolean LinkedBlockingDeque.offer(E e, long timeout, TimeUnit unit)
 boolean LinkedBlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入到此队列的尾部，如有必要，则等待指定的时间以使空间变得可用。
 boolean PriorityBlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入此优先级队列。
 boolean SynchronousQueue.offer(E o, long timeout, TimeUnit unit)
将指定元素插入到此队列，如有必要则等待指定的时间，以便另一个线程接收它。
 boolean BlockingDeque.offerFirst(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列的开头，必要时将在指定的等待时间内等待可用空间。
 boolean LinkedBlockingDeque.offerFirst(E e, long timeout, TimeUnit unit)
 boolean BlockingDeque.offerLast(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列的末尾，必要时将在指定的等待时间内等待可用空间。
 boolean LinkedBlockingDeque.offerLast(E e, long timeout, TimeUnit unit)
 E ArrayBlockingQueue.poll(long timeout, TimeUnit unit)
 E BlockingDeque.poll(long timeout, TimeUnit unit)
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），如有必要将在指定的等待时间内等待可用元素。
 E BlockingQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。
 Future<V> CompletionService.poll(long timeout, TimeUnit unit)
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。
 E DelayQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在可从此队列获得到期延迟的元素，或者到达指定的等待时间之前一直等待（如有必要）。
 Future<V> ExecutorCompletionService.poll(long timeout, TimeUnit unit)
 E LinkedBlockingDeque.poll(long timeout, TimeUnit unit)
 E LinkedBlockingQueue.poll(long timeout, TimeUnit unit)
 E PriorityBlockingQueue.poll(long timeout, TimeUnit unit)
 E SynchronousQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头，如有必要则等待指定的时间，以便另一个线程插入它。
 E BlockingDeque.pollFirst(long timeout, TimeUnit unit)
获取并移除此双端队列的第一个元素，必要时将在指定的等待时间等待可用元素。
 E LinkedBlockingDeque.pollFirst(long timeout, TimeUnit unit)
 E BlockingDeque.pollLast(long timeout, TimeUnit unit)
获取并移除此双端队列的最后一个元素，必要时将在指定的等待时间内等待可用元素。
 E LinkedBlockingDeque.pollLast(long timeout, TimeUnit unit)
<V> ScheduledFuture<V>
ScheduledExecutorService.schedule(Callable<V> callable, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的 ScheduledFuture。
<V> ScheduledFuture<V>
ScheduledThreadPoolExecutor.schedule(Callable<V> callable, long delay, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.schedule(Runnable command, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的一次性操作。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.schedule(Runnable command, long delay, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
 void ThreadPoolExecutor.setKeepAliveTime(long time, TimeUnit unit)
设置线程在终止前可以保持空闲的时间限制。
 boolean Semaphore.tryAcquire(int permits, long timeout, TimeUnit unit)
如果在给定的等待时间内此信号量有可用的所有许可，并且当前线程未被中断，则从此信号量获取给定数目的许可。
 boolean Semaphore.tryAcquire(long timeout, TimeUnit unit)
如果在给定的等待时间内，此信号量有可用的许可并且当前线程未被中断，则从此信号量获取一个许可。

参数类型为 TimeUnit 的 java.util.concurrent 中的构造方法
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
用给定的初始参数和默认的线程工厂及被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

java.util.concurrent.locks 中 TimeUnit 的使用

参数类型为 TimeUnit 的 java.util.concurrent.locks 中的方法
boolean | AbstractQueuedLongSynchronizer.ConditionObject.await(long time, TimeUnit unit) 实现定时条件等待。
boolean | Condition.await(long time, TimeUnit unit) 造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
boolean | AbstractQueuedSynchronizer.ConditionObject.await(long time, TimeUnit unit) 实现定时的条件等待。
boolean | ReentrantReadWriteLock.ReadLock.tryLock(long timeout, TimeUnit unit) 如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取读取锁。
boolean | ReentrantReadWriteLock.WriteLock.tryLock(long timeout, TimeUnit unit) 如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取写入锁。
boolean | ReentrantLock.tryLock(long timeout, TimeUnit unit) 如果锁在给定等待时间内没有被另一个线程保持，且当前线程未被中断，则获取该锁。
boolean | Lock.tryLock(long time, TimeUnit unit) 如果锁在给定的等待时间内空闲，并且当前线程未被中断，则获取锁。

javax.swing 中 TimeUnit 的使用

参数类型为 TimeUnit 的 javax.swing 中的方法
 T SwingWorker.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.util.concurrent.locks (Java 2 Platform SE 6)

 java.util.concurrent.locks
接口
Condition
Lock
ReadWriteLock
类
AbstractOwnableSynchronizer
AbstractQueuedLongSynchronizer
AbstractQueuedSynchronizer
LockSupport
ReentrantLock
ReentrantReadWriteLock
ReentrantReadWriteLock.ReadLock
ReentrantReadWriteLock.WriteLock


类 java.util.concurrent.locks.AbstractOwnableSynchronizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.AbstractOwnableSynchronizer
的使用

使用 AbstractOwnableSynchronizer 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 AbstractOwnableSynchronizer 的使用

java.util.concurrent.locks 中 AbstractOwnableSynchronizer 的子类
class | AbstractQueuedLongSynchronizer 以 long 形式维护同步状态的一个 AbstractQueuedSynchronizer 版本。
class | AbstractQueuedSynchronizer 为实现依赖于先进先出 (FIFO) 等待队列的阻塞锁和相关同步器（信号量、事件，等等）提供一个框架。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer
的使用

没有 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
的使用

使用 AbstractQueuedLongSynchronizer.ConditionObject 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 AbstractQueuedLongSynchronizer.ConditionObject 的使用

参数类型为 AbstractQueuedLongSynchronizer.ConditionObject 的 java.util.concurrent.locks 中的方法
Collection<Thread> | AbstractQueuedLongSynchronizer.getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject condition) 返回一个 collection，该 collection 包含那些正在与此同步器关联的给定条件上等待的线程。
int | AbstractQueuedLongSynchronizer.getWaitQueueLength(AbstractQueuedLongSynchronizer.ConditionObject condition) 返回正在与此同步器关联的给定条件上等待的线程估计数。
boolean | AbstractQueuedLongSynchronizer.hasWaiters(AbstractQueuedLongSynchronizer.ConditionObject condition) 查询是否有线程正在与此同步器关联的给定条件上等待。
boolean | AbstractQueuedLongSynchronizer.owns(AbstractQueuedLongSynchronizer.ConditionObject condition) 查询给定 ConditionObject 是否使用此同步器作为它的锁。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.locks.AbstractQueuedSynchronizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.AbstractQueuedSynchronizer
的使用

没有 java.util.concurrent.locks.AbstractQueuedSynchronizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
的使用

使用 AbstractQueuedSynchronizer.ConditionObject 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 AbstractQueuedSynchronizer.ConditionObject 的使用

参数类型为 AbstractQueuedSynchronizer.ConditionObject 的 java.util.concurrent.locks 中的方法
Collection<Thread> | AbstractQueuedSynchronizer.getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject condition) 返回一个 collection，其中包含可能正在等待与此同步器有关的给定条件的那些线程。
int | AbstractQueuedSynchronizer.getWaitQueueLength(AbstractQueuedSynchronizer.ConditionObject condition) 返回正在等待与此同步器有关的给定条件的线程数估计值。
boolean | AbstractQueuedSynchronizer.hasWaiters(AbstractQueuedSynchronizer.ConditionObject condition) 查询是否有线程正在等待给定的、与此同步器相关的条件。
boolean | AbstractQueuedSynchronizer.owns(AbstractQueuedSynchronizer.ConditionObject condition) 查询给定的 ConditionObject 是否使用了此同步器作为其锁。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.locks.Condition 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.locks.Condition
的使用

使用 Condition 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 Condition 的使用

实现 Condition 的 java.util.concurrent.locks 中的类
class | AbstractQueuedLongSynchronizer.ConditionObject 作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。
class | AbstractQueuedSynchronizer.ConditionObject AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。

返回 Condition 的 java.util.concurrent.locks 中的方法
Condition | ReentrantReadWriteLock.ReadLock.newCondition() 因为 ReadLocks 不支持条件，所以将抛出 UnsupportedOperationException。
Condition | ReentrantReadWriteLock.WriteLock.newCondition() 返回一个用来与此 Lock 实例一起使用的 Condition 实例。
Condition | ReentrantLock.newCondition() 返回用来与此 Lock 实例一起使用的 Condition 实例。
Condition | Lock.newCondition() 返回绑定到此 Lock 实例的新 Condition 实例。

参数类型为 Condition 的 java.util.concurrent.locks 中的方法
protected Collection<Thread> | ReentrantReadWriteLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与写入锁相关的给定条件的那些线程。
protected Collection<Thread> | ReentrantLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与此锁相关给定条件的那些线程。
int | ReentrantReadWriteLock.getWaitQueueLength(Condition condition) 返回正等待与写入锁相关的给定条件的线程估计数目。
int | ReentrantLock.getWaitQueueLength(Condition condition) 返回等待与此锁相关的给定条件的线程估计数。
boolean | ReentrantReadWriteLock.hasWaiters(Condition condition) 查询是否有些线程正在等待与写入锁有关的给定条件。
boolean | ReentrantLock.hasWaiters(Condition condition) 查询是否有些线程正在等待与此锁有关的给定条件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.locks.Lock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.locks.Lock
的使用

使用 Lock 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 Lock 的使用

实现 Lock 的 java.util.concurrent.locks 中的类
class | ReentrantLock 一个可重入的互斥锁 Lock，它具有与使用 synchronized 方法和语句所访问的隐式监视器锁相同的一些基本行为和语义，但功能更强大。
static class | ReentrantReadWriteLock.ReadLock ReentrantReadWriteLock.readLock() 方法返回的锁。
static class | ReentrantReadWriteLock.WriteLock ReentrantReadWriteLock.writeLock() 方法返回的锁。

返回 Lock 的 java.util.concurrent.locks 中的方法
Lock | ReadWriteLock.readLock() 返回用于读取操作的锁。
Lock | ReadWriteLock.writeLock() 返回用于写入操作的锁。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.locks.LockSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.LockSupport
的使用

没有 java.util.concurrent.locks.LockSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.concurrent.locks.ReadWriteLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.locks.ReadWriteLock
的使用

使用 ReadWriteLock 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 ReadWriteLock 的使用

实现 ReadWriteLock 的 java.util.concurrent.locks 中的类
 class ReentrantReadWriteLock
支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.locks.ReentrantLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.ReentrantLock
的使用

没有 java.util.concurrent.locks.ReentrantLock 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.locks.ReentrantReadWriteLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.ReentrantReadWriteLock
的使用

使用 ReentrantReadWriteLock 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 ReentrantReadWriteLock 的使用

参数类型为 ReentrantReadWriteLock 的 java.util.concurrent.locks 中的构造方法
ReentrantReadWriteLock.ReadLock(ReentrantReadWriteLock lock)
子类使用的构造方法
ReentrantReadWriteLock.WriteLock(ReentrantReadWriteLock lock)
子类使用的构造方法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
的使用

使用 ReentrantReadWriteLock.ReadLock 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 ReentrantReadWriteLock.ReadLock 的使用

返回 ReentrantReadWriteLock.ReadLock 的 java.util.concurrent.locks 中的方法
 ReentrantReadWriteLock.ReadLock ReentrantReadWriteLock.readLock()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
的使用

使用 ReentrantReadWriteLock.WriteLock 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 ReentrantReadWriteLock.WriteLock 的使用

返回 ReentrantReadWriteLock.WriteLock 的 java.util.concurrent.locks 中的方法
 ReentrantReadWriteLock.WriteLock ReentrantReadWriteLock.writeLock()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.util.jar (Java 2 Platform SE 6)

 java.util.jar
接口
Pack200.Packer
Pack200.Unpacker
类
Attributes
Attributes.Name
JarEntry
JarFile
JarInputStream
JarOutputStream
Manifest
Pack200
异常
JarException


类 java.util.jar.Attributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.Attributes
的使用

使用 Attributes 的软件包
java.net | 为实现网络应用程序提供类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.net 中 Attributes 的使用

返回 Attributes 的 java.net 中的方法
Attributes | JarURLConnection.getAttributes() 如果此连接的 URL 指向 JAR 文件条目，则返回其 Attribute 对象；否则返回 null。
Attributes | JarURLConnection.getMainAttributes() 返回此连接的 JAR 文件的主要 Attribute。

java.util.jar 中 Attributes 的使用

返回 Attributes 的 java.util.jar 中的方法
Attributes | JarEntry.getAttributes() 返回此条目的 Manifest Attributes；如果没有，则返回 null。
Attributes | Manifest.getAttributes(String name) 返回指定条目名称的 Attributes。
Attributes | Manifest.getMainAttributes() 返回 Manifest 的主 Attributes。

返回变量类型为 Attributes 的类型的 java.util.jar 中的方法
 Map<String,Attributes> Manifest.getEntries()
返回此 Manifest 中所包含条目的 Map。

参数类型为 Attributes 的 java.util.jar 中的构造方法
Attributes(Attributes attr)
构造新的 Attributes 对象，该对象与指定的 Attributes 具有相同的属性名称-值映射关系。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.jar.Attributes.Name 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.Attributes.Name
的使用

使用 Attributes.Name 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 Attributes.Name 的使用

声明为 Attributes.Name 的 java.util.jar 中的字段
static Attributes.Name | Attributes.Name.CLASS_PATH Class-Path 的 Name 对象具有的属性。
static Attributes.Name | Attributes.Name.CONTENT_TYPE Content-Type 的 Name 对象具有的属性。
static Attributes.Name | Attributes.Name.EXTENSION_INSTALLATION Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
static Attributes.Name | Attributes.Name.EXTENSION_LIST Extension-List 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
static Attributes.Name | Attributes.Name.EXTENSION_NAME Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
static Attributes.Name | Attributes.Name.IMPLEMENTATION_TITLE Implementation-Title 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.IMPLEMENTATION_URL Implementation-Vendor-URL 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.IMPLEMENTATION_VENDOR Implementation-Vendor 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.IMPLEMENTATION_VENDOR_ID Implementation-Vendor-Id 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.IMPLEMENTATION_VERSION Implementation-Version 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.MAIN_CLASS Main-Class 的 Name 对象具有的属性，用于启动打包在 JAR 文件中的应用程序。
static Attributes.Name | Attributes.Name.MANIFEST_VERSION Manifest-Version 的 Name 对象具有的属性。
static Attributes.Name | Attributes.Name.SEALED Sealed 的 Name 对象给出了用于密封的属性。
static Attributes.Name | Attributes.Name.SIGNATURE_VERSION Signature-Version 的 Name 对象给出了签名 JAR 文件时所使用的属性。
static Attributes.Name | Attributes.Name.SPECIFICATION_TITLE Specification-Title 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.SPECIFICATION_VENDOR Specification-Vendor 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.SPECIFICATION_VERSION Specification-Version 的 Name 对象给出了用于包的版本控制的属性。

参数类型为 Attributes.Name 的 java.util.jar 中的方法
 String Attributes.getValue(Attributes.Name name)
返回指定的 Attributes.Name 的值，如果未找到，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.jar.JarEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.JarEntry
的使用

使用 JarEntry 的软件包
java.net | 为实现网络应用程序提供类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.net 中 JarEntry 的使用

返回 JarEntry 的 java.net 中的方法
 JarEntry JarURLConnection.getJarEntry()
返回此连接的 JAR 条目对象（如果有）。

java.util.jar 中 JarEntry 的使用

返回 JarEntry 的 java.util.jar 中的方法
JarEntry | JarFile.getJarEntry(String name) 返回给定条目名称的 JarEntry；如果未找到，则返回 null。
JarEntry | JarInputStream.getNextJarEntry() 读取下一个 JAR 文件条目，并将流定位于此条目数据的开始处。

返回变量类型为 JarEntry 的类型的 java.util.jar 中的方法
 Enumeration<JarEntry> JarFile.entries()
返回 zip 文件条目的枚举。

参数类型为 JarEntry 的 java.util.jar 中的构造方法
JarEntry(JarEntry je)
使用从指定的 JarEntry 对象获取的字段创建新的 JarEntry。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.jar.JarException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.JarException
的使用

没有 java.util.jar.JarException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.jar.JarFile 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.JarFile
的使用

使用 JarFile 的软件包
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.net | 为实现网络应用程序提供类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.lang.instrument 中 JarFile 的使用

参数类型为 JarFile 的 java.lang.instrument 中的方法
void | Instrumentation.appendToBootstrapClassLoaderSearch(JarFile jarfile) 指定 JAR 文件，检测类由引导类加载器定义。
void | Instrumentation.appendToSystemClassLoaderSearch(JarFile jarfile) 指定 JAR 文件，检测类由系统类加载器定义。

java.net 中 JarFile 的使用

返回 JarFile 的 java.net 中的方法
abstract  JarFile JarURLConnection.getJarFile()
返回此连接的 JAR 文件。

java.util.jar 中 JarFile 的使用

参数类型为 JarFile 的 java.util.jar 中的方法
 void Pack200.Packer.pack(JarFile in, OutputStream out)
接收 JarFile 并将其转换为 Pack200 存档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.jar.JarInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.JarInputStream
的使用

使用 JarInputStream 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 JarInputStream 的使用

参数类型为 JarInputStream 的 java.util.jar 中的方法
 void Pack200.Packer.pack(JarInputStream in, OutputStream out)
接收 JarInputStream 并将其转换成 Pack200 存档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.jar.JarOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.JarOutputStream
的使用

使用 JarOutputStream 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 JarOutputStream 的使用

参数类型为 JarOutputStream 的 java.util.jar 中的方法
void | Pack200.Unpacker.unpack(File in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
void | Pack200.Unpacker.unpack(InputStream in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.jar.Manifest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.Manifest
的使用

使用 Manifest 的软件包
java.net | 为实现网络应用程序提供类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.net 中 Manifest 的使用

返回 Manifest 的 java.net 中的方法
 Manifest JarURLConnection.getManifest()
返回此连接的 Manifest；如果没有，则返回 null。

参数类型为 Manifest 的 java.net 中的方法
protected  Package URLClassLoader.definePackage(String name, Manifest man, URL url)
用该 ClassLoader 中的名称定义一个新包。

java.util.jar 中 Manifest 的使用

返回 Manifest 的 java.util.jar 中的方法
Manifest | JarInputStream.getManifest() 返回此 JAR 文件的 Manifest；如果没有，则返回 null。
Manifest | JarFile.getManifest() 返回 jar 文件清单；如果没有，则返回 null。

参数类型为 Manifest 的 java.util.jar 中的构造方法
JarOutputStream(OutputStream out, Manifest man)
使用指定的 Manifest 创建新的 JarOutputStream。
Manifest(Manifest man)
构造新的 Manifest，它是指定 Manifest 的副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.jar.Pack200 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.Pack200
的使用

没有 java.util.jar.Pack200 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.jar.Pack200.Packer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.jar.Pack200.Packer
的使用

使用 Pack200.Packer 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 Pack200.Packer 的使用

返回 Pack200.Packer 的 java.util.jar 中的方法
static Pack200.Packer Pack200.newPacker()
获取一个实现 Packer 的新的类实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.jar.Pack200.Unpacker 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.jar.Pack200.Unpacker
的使用

使用 Pack200.Unpacker 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 Pack200.Unpacker 的使用

返回 Pack200.Unpacker 的 java.util.jar 中的方法
static Pack200.Unpacker Pack200.newUnpacker()
获取一个实现 Unpacker 的新的类实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.util.logging (Java 2 Platform SE 6)

 java.util.logging
接口
Filter
LoggingMXBean
类
ConsoleHandler
ErrorManager
FileHandler
Formatter
Handler
Level
Logger
LoggingPermission
LogManager
LogRecord
MemoryHandler
SimpleFormatter
SocketHandler
StreamHandler
XMLFormatter


类 java.util.logging.ConsoleHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.ConsoleHandler
的使用

没有 java.util.logging.ConsoleHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.ErrorManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.ErrorManager
的使用

使用 ErrorManager 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 ErrorManager 的使用

返回 ErrorManager 的 java.util.logging 中的方法
 ErrorManager Handler.getErrorManager()
获取该 Handler 的 ErrorManager。

参数类型为 ErrorManager 的 java.util.logging 中的方法
 void Handler.setErrorManager(ErrorManager em)
为该 Handler 定义一个 ErrorManager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.FileHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.FileHandler
的使用

没有 java.util.logging.FileHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.logging.Filter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.logging.Filter
的使用

使用 Filter 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 Filter 的使用

返回 Filter 的 java.util.logging 中的方法
Filter | Handler.getFilter() 获得该 Handler 的当前 Filter。
Filter | Logger.getFilter() 获取此 Logger 的当前过滤器。

参数类型为 Filter 的 java.util.logging 中的方法
void | Handler.setFilter(Filter newFilter) 设置 Filter，以控制该 Handler 的输出。
void | Logger.setFilter(Filter newFilter) 设置过滤器以控制此 Logger 的输出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.Formatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.Formatter
的使用

使用 Formatter 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 Formatter 的使用

java.util.logging 中 Formatter 的子类
class | SimpleFormatter 以可读格式输出 LogRecord 的简单摘要。
class | XMLFormatter 将 LogRecord 格式化为标准 XML 格式。

返回 Formatter 的 java.util.logging 中的方法
 Formatter Handler.getFormatter()
返回该 Handler 的 Formatter。

参数类型为 Formatter 的 java.util.logging 中的方法
 void Handler.setFormatter(Formatter newFormatter)
设置 Formatter。

参数类型为 Formatter 的 java.util.logging 中的构造方法
StreamHandler(OutputStream out, Formatter formatter)
创建带给定 Formatter 和输出流的 StreamHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.Handler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.Handler
的使用

使用 Handler 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 Handler 的使用

java.util.logging 中 Handler 的子类
class | ConsoleHandler 此 Handler 向 System.err 发布日志记录。
class | FileHandler 简单的文件日志记录 Handler。
class | MemoryHandler Handler 在内存中的循环缓冲区中对请求进行缓冲处理。
class | SocketHandler 简单的网络日志 Handler。
class | StreamHandler 基于流的日志 Handler。

返回 Handler 的 java.util.logging 中的方法
 Handler[] Logger.getHandlers()
获得与此 logger 相关的 Handler。

参数类型为 Handler 的 java.util.logging 中的方法
void | Logger.addHandler(Handler handler) 添加一个日志 Handler 以接收日志记录消息。
String | Formatter.getHead(Handler h) 返回一组格式化记录的头部字符串。
String | XMLFormatter.getHead(Handler h) 返回一组 XML 格式记录的头部字符串。
String | Formatter.getTail(Handler h) 返回一组格式化记录的尾部字符串。
String | XMLFormatter.getTail(Handler h) 返回一组 XML 格式记录的尾部字符串。
void | Logger.removeHandler(Handler handler) 移除一个日志 Handler。

参数类型为 Handler 的 java.util.logging 中的构造方法
MemoryHandler(Handler target, int size, Level pushLevel)
创建一个 MemoryHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.Level 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.Level
的使用

使用 Level 的软件包
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.util.logging 中 Level 的使用

声明为 Level 的 java.util.logging 中的字段
static Level | Level.ALL ALL 指示应该记录所有消息。
static Level | Level.CONFIG CONFIG 是用于静态配置消息的消息级别。
static Level | Level.FINE FINE 是提供跟踪信息的消息级别。
static Level | Level.FINER FINER 指示一条相当详细的跟踪消息。
static Level | Level.FINEST FINEST 指示一条最详细的跟踪消息。
static Level | Level.INFO INFO 是报告消息的消息级别。
static Level | Level.OFF OFF 是一个可用于关闭日志记录的特殊级别。
static Level | Level.SEVERE SEVERE 是指示严重失败的消息级别。
static Level | Level.WARNING WARNING 是指示潜在问题的消息级别。

返回 Level 的 java.util.logging 中的方法
Level | LogRecord.getLevel() 获取日志消息级别，例如 Level.SEVERE。
Level | Handler.getLevel() 获得用于指定该 Handler 所记录信息的日志级别。
Level | Logger.getLevel() 获取已为此 Logger 指定的日志级别（Level）。
Level | MemoryHandler.getPushLevel() 获得 pushLevel。
static Level | Level.parse(String name) 将级别名称字符串解析成 Level。

参数类型为 Level 的 java.util.logging 中的方法
boolean | Logger.isLoggable(Level level) 检查给定级别的消息实际上是否由此 logger 记录。
void | Logger.log(Level level, String msg) 记录一条不带参数的消息。
void | Logger.log(Level level, String msg, Object param1) 记录带有一个对象参数的消息。
void | Logger.log(Level level, String msg, Object[] params) 记录带有一组对象参数的消息。
void | Logger.log(Level level, String msg, Throwable thrown) 记录带有相关的可抛出信息的消息。
void | Logger.logp(Level level, String sourceClass, String sourceMethod, String msg) 记录一条消息，具有指定的源类和方法，不带参数。
void | Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object param1) 记录一条消息，具有指定的源类和方法，带有单个日志消息的对象参数。
void | Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object[] params) 记录一条消息，具有指定的源类和方法，带有一组对象参数。
void | Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown) 记录一条消息，具有指定源类和方法，带有相关的可抛出信息。
void | Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg) 记录一条消息，具有指定的源类、方法和资源包名，不带参数。
void | Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1) 记录一条消息，具有指定的源类、方法和资源包名，带有单个日志消息的对象参数。
void | Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params) 记录一条消息，具有指定的源类、方法和资源包名，带有一组对象参数。
void | Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown) 记录一条消息，具有指定的源类、方法和资源包名，带有相关的可抛出对象。
void | LogRecord.setLevel(Level level) 设置日志消息级别，例如 Level.SEVERE。
void | Handler.setLevel(Level newLevel) 设置日志级别，指定该 Handler 所记录的信息级别。
void | Logger.setLevel(Level newLevel) 设置日志级别，指定此 logger 记录的消息级别。
void | MemoryHandler.setPushLevel(Level newLevel) 设置 pushLevel。

参数类型为 Level 的 java.util.logging 中的构造方法
LogRecord(Level level, String msg)
用给定级别和消息值构造 LogRecord。
MemoryHandler(Handler target, int size, Level pushLevel)
创建一个 MemoryHandler。

javax.sql.rowset.spi 中 Level 的使用

参数类型为 Level 的 javax.sql.rowset.spi 中的方法
static void SyncFactory.setLogger(Logger logger, Level level)
设置 SyncFactory SPI 提供的 SyncProvider 实现所使用的日志对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.Logger 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.Logger
的使用

使用 Logger 的软件包
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.util.logging 中 Logger 的使用

声明为 Logger 的 java.util.logging 中的字段
static Logger Logger.global
已过时。 此字段的初始化会容易出现死锁。必须由 Logger 类初始化来初始化字段，这可能会导致 LogManager 类初始化的死锁。在这种情况下，两个类初始化都要等待对方完成。从 JDK version 1.6 开始，获取全局 logger 对象的首选方法是通过调用 Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)。

返回 Logger 的 java.util.logging 中的方法
static Logger | Logger.getAnonymousLogger() 创建一个匿名的 Logger。
static Logger | Logger.getAnonymousLogger(String resourceBundleName) 创建一个匿名的 Logger。
Logger | LogManager.getLogger(String name) 查找指定 logger 的方法。
static Logger | Logger.getLogger(String name) 为指定子系统查找或创建一个 logger。
static Logger | Logger.getLogger(String name, String resourceBundleName) 为指定子系统查找或创建一个 logger。
Logger | Logger.getParent() 返回此 Logger 的父 logger。

参数类型为 Logger 的 java.util.logging 中的方法
boolean | LogManager.addLogger(Logger logger) 添加指定的 logger。
void | Logger.setParent(Logger parent) 设置此 Logger 的父 Logger。

javax.sql.rowset.spi 中 Logger 的使用

返回 Logger 的 javax.sql.rowset.spi 中的方法
static Logger SyncFactory.getLogger()
返回应用程序的日志对象，以获取 SyncProvider 实现发送的同步事件。

参数类型为 Logger 的 javax.sql.rowset.spi 中的方法
static void | SyncFactory.setLogger(Logger logger) 设置 SyncFactory 提供的 SyncProvider 实现所使用的日志对象。
static void | SyncFactory.setLogger(Logger logger, Level level) 设置 SyncFactory SPI 提供的 SyncProvider 实现所使用的日志对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.logging.LoggingMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.logging.LoggingMXBean
的使用

使用 LoggingMXBean 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 LoggingMXBean 的使用

返回 LoggingMXBean 的 java.util.logging 中的方法
static LoggingMXBean LogManager.getLoggingMXBean()
返回管理 logger 的 LoggingMXBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.LoggingPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.LoggingPermission
的使用

没有 java.util.logging.LoggingPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.LogManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.LogManager
的使用

使用 LogManager 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 LogManager 的使用

返回 LogManager 的 java.util.logging 中的方法
static LogManager LogManager.getLogManager()
返回全局 LogManager 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.LogRecord 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.LogRecord
的使用

使用 LogRecord 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 LogRecord 的使用

参数类型为 LogRecord 的 java.util.logging 中的方法
abstract String | Formatter.format(LogRecord record) 格式化给定的日志记录，并返回格式化后的字符串。
String | SimpleFormatter.format(LogRecord record) 格式化给定的 LogRecord。
String | XMLFormatter.format(LogRecord record) 将给定消息格式化为 XML。
String | Formatter.formatMessage(LogRecord record) 本地化和格式化来自日志记录的消息字符串。
boolean | Filter.isLoggable(LogRecord record) 检查是否应该发布给定的日志记录。
boolean | MemoryHandler.isLoggable(LogRecord record) 检查此 Handler 是否实际将给定的 LogRecord 记录到其内部缓冲区。
boolean | StreamHandler.isLoggable(LogRecord record) 检查该 Handler 是否实际记录给定的 LogRecord。
boolean | Handler.isLoggable(LogRecord record) 检查该 Handler 是否实际记录给定的 LogRecord。
void | Logger.log(LogRecord record) 记录一条 LogRecord。
void | ConsoleHandler.publish(LogRecord record) 发布 LogRecord。
void | FileHandler.publish(LogRecord record) 格式化并发布 LogRecord。
void | MemoryHandler.publish(LogRecord record) 将 LogRecord 存储在内部缓冲区。
void | SocketHandler.publish(LogRecord record) 格式化并发布 LogRecord。
void | StreamHandler.publish(LogRecord record) 格式化并发布 LogRecord。
abstract void | Handler.publish(LogRecord record) 发布 LogRecord。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.MemoryHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.MemoryHandler
的使用

没有 java.util.logging.MemoryHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.SimpleFormatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.SimpleFormatter
的使用

没有 java.util.logging.SimpleFormatter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.SocketHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.SocketHandler
的使用

没有 java.util.logging.SocketHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.StreamHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.StreamHandler
的使用

使用 StreamHandler 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 StreamHandler 的使用

java.util.logging 中 StreamHandler 的子类
class | ConsoleHandler 此 Handler 向 System.err 发布日志记录。
class | FileHandler 简单的文件日志记录 Handler。
class | SocketHandler 简单的网络日志 Handler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.logging.XMLFormatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.XMLFormatter
的使用

没有 java.util.logging.XMLFormatter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.util.prefs (Java 2 Platform SE 6)

 java.util.prefs
接口
NodeChangeListener
PreferenceChangeListener
PreferencesFactory
类
AbstractPreferences
NodeChangeEvent
PreferenceChangeEvent
Preferences
异常
BackingStoreException
InvalidPreferencesFormatException


类 java.util.prefs.AbstractPreferences 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.AbstractPreferences
的使用

使用 AbstractPreferences 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 AbstractPreferences 的使用

返回 AbstractPreferences 的 java.util.prefs 中的方法
protected AbstractPreferences[] | AbstractPreferences.cachedChildren() 返回此节点的所有已知未移除子节点。
protected abstract AbstractPreferences | AbstractPreferences.childSpi(String name) 返回此首选项节点的指定子节点；如果该子节点尚未存在，则创建它。
protected AbstractPreferences | AbstractPreferences.getChild(String nodeName) 如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。

参数类型为 AbstractPreferences 的 java.util.prefs 中的构造方法
AbstractPreferences(AbstractPreferences parent, String name)
用指定的父节点和与其父节点相关的指定名称创建首选项节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.prefs.BackingStoreException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.BackingStoreException
的使用

使用 BackingStoreException 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 BackingStoreException 的使用

抛出 BackingStoreException 的 java.util.prefs 中的方法
 String[] AbstractPreferences.childrenNames()
根据 Preferences.childrenNames() 中的规范实现 children 方法。
abstract  String[] Preferences.childrenNames()
返回此首选项节点相对于此节点的子节点名称。
protected abstract  String[] AbstractPreferences.childrenNamesSpi()
返回此首选项节点的子节点名称。
 void AbstractPreferences.clear()
根据 Preferences.clear() 中的规范实现 clear 方法。
abstract  void Preferences.clear()
移除此首选项节点中的所有首选项（键-值关联）。
 void AbstractPreferences.exportNode(OutputStream os)
根据 Preferences.exportNode(OutputStream) 中的规范实现 exportNode 方法。
abstract  void Preferences.exportNode(OutputStream os)
在指定输出流上发出表示此节点（不是其子节点）中包含的所有首选项的 XML 文档。
 void AbstractPreferences.exportSubtree(OutputStream os)
根据 Preferences.exportSubtree(OutputStream) 中的规范实现 exportSubtree 方法。
abstract  void Preferences.exportSubtree(OutputStream os)
发出表示此节点及其所有子节点中包含的全部首选项的 XML 文档。
 void AbstractPreferences.flush()
根据 Preferences.flush() 中的规范实现 flush 方法。
abstract  void Preferences.flush()
强制进行从此首选项节点及其子节点到持久存储的内容更改。
protected abstract  void AbstractPreferences.flushSpi()
此方法是在此节点被锁定的情况下调用的。
protected  AbstractPreferences AbstractPreferences.getChild(String nodeName)
如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。
 String[] AbstractPreferences.keys()
根据 Preferences.keys() 中的规范实现 keys 方法。
abstract  String[] Preferences.keys()
返回在此首选项节点中具有关联值的所有键。
protected abstract  String[] AbstractPreferences.keysSpi()
返回在此首选项节点中具有关联值的所有键。
 boolean AbstractPreferences.nodeExists(String path)
根据 Preferences.nodeExists(String) 中的规范实现 nodeExists 方法。
abstract  boolean Preferences.nodeExists(String pathName)
如果此节点所在的树中存在指定首选项节点，则返回 true。
 void AbstractPreferences.removeNode()
根据 Preferences.removeNode() 中的规范实现 removeNode() 方法。
abstract  void Preferences.removeNode()
移除此首选项节点及其所有子节点，移除的节点中所包含的全部首选项都将失效。
protected abstract  void AbstractPreferences.removeNodeSpi()
移除此首选项节点，该首选项节点及其所包含的所有首选项都将失效。
 void AbstractPreferences.sync()
根据 Preferences.sync() 中的规范实现 sync 方法。
abstract  void Preferences.sync()
确保在调用 sync 之前从此首选项节点及其子节点进行的后续读取能反映出提交到持久存储（从任何 VM）的所有更改。
protected abstract  void AbstractPreferences.syncSpi()
此方法是在此节点被锁定的情况下调用的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.prefs.InvalidPreferencesFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.InvalidPreferencesFormatException
的使用

使用 InvalidPreferencesFormatException 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 InvalidPreferencesFormatException 的使用

抛出 InvalidPreferencesFormatException 的 java.util.prefs 中的方法
static void Preferences.importPreferences(InputStream is)
导入指定输入流中由 XML 文档表示的所有首选项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.prefs.NodeChangeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.NodeChangeEvent
的使用

使用 NodeChangeEvent 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 NodeChangeEvent 的使用

参数类型为 NodeChangeEvent 的 java.util.prefs 中的方法
void | NodeChangeListener.childAdded(NodeChangeEvent evt) 添加子节点时调用此方法。
void | NodeChangeListener.childRemoved(NodeChangeEvent evt) 移除子节点时调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.prefs.NodeChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.prefs.NodeChangeListener
的使用

使用 NodeChangeListener 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 NodeChangeListener 的使用

参数类型为 NodeChangeListener 的 java.util.prefs 中的方法
void | AbstractPreferences.addNodeChangeListener(NodeChangeListener ncl)
abstract void | Preferences.addNodeChangeListener(NodeChangeListener ncl) 注册指定侦听器以接收此节点的节点更改事件。
void | AbstractPreferences.removeNodeChangeListener(NodeChangeListener ncl)
abstract void | Preferences.removeNodeChangeListener(NodeChangeListener ncl) 移除指定 NodeChangeListener，使其不再接收更改事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.prefs.PreferenceChangeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.PreferenceChangeEvent
的使用

使用 PreferenceChangeEvent 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 PreferenceChangeEvent 的使用

参数类型为 PreferenceChangeEvent 的 java.util.prefs 中的方法
 void PreferenceChangeListener.preferenceChange(PreferenceChangeEvent evt)
当添加、移除首选项或者更改首选项的值时，调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.prefs.PreferenceChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.prefs.PreferenceChangeListener
的使用

使用 PreferenceChangeListener 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 PreferenceChangeListener 的使用

参数类型为 PreferenceChangeListener 的 java.util.prefs 中的方法
void | AbstractPreferences.addPreferenceChangeListener(PreferenceChangeListener pcl)
abstract void | Preferences.addPreferenceChangeListener(PreferenceChangeListener pcl) 注册指定侦听器以接收此首选项节点的首选项更改事件。
void | AbstractPreferences.removePreferenceChangeListener(PreferenceChangeListener pcl)
abstract void | Preferences.removePreferenceChangeListener(PreferenceChangeListener pcl) 移除指定首选项更改侦听器，使其不再接收首选项更改事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.prefs.Preferences 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.Preferences
的使用

使用 Preferences 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 Preferences 的使用

java.util.prefs 中 Preferences 的子类
 class AbstractPreferences
此类提供了 Preferences 类的骨干实现，从而大大简化了实现此类的任务。

返回 Preferences 的 java.util.prefs 中的方法
 Preferences NodeChangeEvent.getChild()
返回添加或移除的节点。
 Preferences PreferenceChangeEvent.getNode()
返回发出事件的首选项节点。
 Preferences NodeChangeEvent.getParent()
返回添加或移除节点的父节点。
 Preferences AbstractPreferences.node(String path)
根据 node(String) 中的规范实现 node 方法。
abstract  Preferences Preferences.node(String pathName)
将指定首选项节点返回到此节点所在的同一树中，如果此节点及其祖先已经不存在，则创建它们。
 Preferences AbstractPreferences.parent()
根据 parent() 中的规范实现 parent 方法。
abstract  Preferences Preferences.parent()
返回此首选项节点的父节点；如果此为根，则返回 null。
static Preferences Preferences.systemNodeForPackage(Class<?> c)
从系统首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
static Preferences Preferences.systemRoot()
返回系统的根首选项节点。
 Preferences PreferencesFactory.systemRoot()
返回系统根首选项节点。
static Preferences Preferences.userNodeForPackage(Class<?> c)
从调用用户首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
static Preferences Preferences.userRoot()
返回调用用户的根首选项节点。
 Preferences PreferencesFactory.userRoot()
返回与调用用户相对应的用户根首选项节点。

参数类型为 Preferences 的 java.util.prefs 中的构造方法
NodeChangeEvent(Preferences parent, Preferences child)
构造新的 NodeChangeEvent 实例。
PreferenceChangeEvent(Preferences node, String key, String newValue)
构造新的 PreferenceChangeEvent 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.prefs.PreferencesFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.prefs.PreferencesFactory
的使用

没有 java.util.prefs.PreferencesFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.util.regex (Java 2 Platform SE 6)

 java.util.regex
接口
MatchResult
类
Matcher
Pattern
异常
PatternSyntaxException


类 java.util.regex.Matcher 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.regex.Matcher
的使用

使用 Matcher 的软件包
java.util.regex 用于匹配字符序列与正则表达式指定模式的类。

java.util.regex 中 Matcher 的使用

返回 Matcher 的 java.util.regex 中的方法
Matcher | Matcher.appendReplacement(StringBuffer sb, String replacement) 实现非终端添加和替换步骤。
Matcher | Pattern.matcher(CharSequence input) 创建匹配给定输入与此模式的匹配器。
Matcher | Matcher.region(int start, int end) 设置此匹配器的区域限制。
Matcher | Matcher.reset() 重置匹配器。
Matcher | Matcher.reset(CharSequence input) 重置此具有新输入序列的匹配器。
Matcher | Matcher.useAnchoringBounds(boolean b) 设置匹配器区域界限的定位。
Matcher | Matcher.usePattern(Pattern newPattern) 更改此 Matcher 用于查找匹配项的 Pattern。
Matcher | Matcher.useTransparentBounds(boolean b) 设置此匹配器区域边界的透明度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.regex.MatchResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.regex.MatchResult
的使用

使用 MatchResult 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。

java.util 中 MatchResult 的使用

返回 MatchResult 的 java.util 中的方法
 MatchResult Scanner.match()
返回此扫描器所执行的最后扫描操作的匹配结果。

java.util.regex 中 MatchResult 的使用

实现 MatchResult 的 java.util.regex 中的类
 class Matcher
通过解释 Pattern 对 character sequence 执行匹配操作的引擎。

返回 MatchResult 的 java.util.regex 中的方法
 MatchResult Matcher.toMatchResult()
作为 MatchResult 返回此匹配器的匹配状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.regex.Pattern 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.regex.Pattern
的使用

使用 Pattern 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。

java.util 中 Pattern 的使用

返回 Pattern 的 java.util 中的方法
 Pattern Scanner.delimiter()
返回此 Scanner 当前正在用于匹配分隔符的 Pattern。

参数类型为 Pattern 的 java.util 中的方法
String | Scanner.findInLine(Pattern pattern) 试图在忽略分隔符的情况下查找下一个指定模式。
String | Scanner.findWithinHorizon(Pattern pattern, int horizon) 试图查找下一个指定模式。
boolean | Scanner.hasNext(Pattern pattern) 如果下一个完整标记与指定模式匹配，则返回 true。
String | Scanner.next(Pattern pattern) 如果下一个标记与指定模式匹配，则返回下一个标记。
Scanner | Scanner.skip(Pattern pattern) 在忽略分隔符的情况下跳过与指定模式匹配的输入信息。
Scanner | Scanner.useDelimiter(Pattern pattern) 将此扫描器的分隔模式设置为指定模式。

java.util.regex 中 Pattern 的使用

返回 Pattern 的 java.util.regex 中的方法
static Pattern | Pattern.compile(String regex) 将给定的正则表达式编译到模式中。
static Pattern | Pattern.compile(String regex, int flags) 将给定的正则表达式编译到具有给定标志的模式中。
Pattern | Matcher.pattern() 返回由此匹配器解释的模式。

参数类型为 Pattern 的 java.util.regex 中的方法
 Matcher Matcher.usePattern(Pattern newPattern)
更改此 Matcher 用于查找匹配项的 Pattern。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.regex.PatternSyntaxException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.regex.PatternSyntaxException
的使用

没有 java.util.regex.PatternSyntaxException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.util.spi (Java 2 Platform SE 6)

 java.util.spi
类
CurrencyNameProvider
LocaleNameProvider
LocaleServiceProvider
TimeZoneNameProvider


类 java.util.spi.CurrencyNameProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.spi.CurrencyNameProvider
的使用

没有 java.util.spi.CurrencyNameProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.spi.LocaleNameProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.spi.LocaleNameProvider
的使用

没有 java.util.spi.LocaleNameProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.spi.LocaleServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.spi.LocaleServiceProvider
的使用

使用 LocaleServiceProvider 的软件包
java.text.spi | java.text 包中类的服务提供者类。
java.util.spi | java.util 包中类的服务提供者类。

java.text.spi 中 LocaleServiceProvider 的使用

java.text.spi 中 LocaleServiceProvider 的子类
class | BreakIteratorProvider 提供 BreakIterator 类具体实现的服务提供者的抽象类。
class | CollatorProvider 提供 Collator 类具体实现的服务提供者的抽象类。
class | DateFormatProvider 提供 DateFormat 类具体实现的服务提供者的抽象类。
class | DateFormatSymbolsProvider 提供 DateFormatSymbols 类实例的服务提供者的抽象类。
class | DecimalFormatSymbolsProvider 提供 DecimalFormatSymbols 类实例的服务提供者的抽象类。
class | NumberFormatProvider 提供 NumberFormat 类具体实现的服务提供者的抽象类。

java.util.spi 中 LocaleServiceProvider 的使用

java.util.spi 中 LocaleServiceProvider 的子类
class | CurrencyNameProvider 为 Currency 类提供本地化货币符号的服务提供者的抽象类。
class | LocaleNameProvider 为 Locale 类提供本地化名称的服务提供者的一个抽象类。
class | TimeZoneNameProvider 为 TimeZone 类提供本地化时区名称的服务提供者的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.spi.TimeZoneNameProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.spi.TimeZoneNameProvider
的使用

没有 java.util.spi.TimeZoneNameProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


java.util.zip (Java 2 Platform SE 6)

 java.util.zip
接口
Checksum
类
Adler32
CheckedInputStream
CheckedOutputStream
CRC32
Deflater
DeflaterInputStream
DeflaterOutputStream
GZIPInputStream
GZIPOutputStream
Inflater
InflaterInputStream
InflaterOutputStream
ZipEntry
ZipFile
ZipInputStream
ZipOutputStream
异常
DataFormatException
ZipException
错误
ZipError


类 java.util.zip.Adler32 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.Adler32
的使用

没有 java.util.zip.Adler32 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.CheckedInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.CheckedInputStream
的使用

没有 java.util.zip.CheckedInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.CheckedOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.CheckedOutputStream
的使用

没有 java.util.zip.CheckedOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 java.util.zip.Checksum 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.zip.Checksum
的使用

使用 Checksum 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 Checksum 的使用

实现 Checksum 的 java.util.zip 中的类
class | Adler32 可用于计算数据流的 Adler-32 校验和的类。
class | CRC32 可用于计算数据流的 CRC-32 的类。

返回 Checksum 的 java.util.zip 中的方法
Checksum | CheckedInputStream.getChecksum() 返回此输入流的校验和。
Checksum | CheckedOutputStream.getChecksum() 返回此输出流的校验和。

参数类型为 Checksum 的 java.util.zip 中的构造方法
CheckedInputStream(InputStream in, Checksum cksum)
使用指定校验和创建输入流。
CheckedOutputStream(OutputStream out, Checksum cksum)
使用指定校验和创建输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.CRC32 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.CRC32
的使用

使用 CRC32 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 CRC32 的使用

声明为 CRC32 的 java.util.zip 中的字段
protected CRC32 | GZIPOutputStream.crc 未压缩数据的 CRC-32 。
protected CRC32 | GZIPInputStream.crc 未压缩数据的 CRC-32。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.DataFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.DataFormatException
的使用

使用 DataFormatException 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 DataFormatException 的使用

抛出 DataFormatException 的 java.util.zip 中的方法
int | Inflater.inflate(byte[] b) 将字节解压缩到指定的缓冲区。
int | Inflater.inflate(byte[] b, int off, int len) 将字节解压缩到指定的缓冲区。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.Deflater 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.Deflater
的使用

使用 Deflater 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 Deflater 的使用

声明为 Deflater 的 java.util.zip 中的字段
protected Deflater | DeflaterInputStream.def 此流的压缩器。
protected Deflater | DeflaterOutputStream.def 此流的压缩器。

参数类型为 Deflater 的 java.util.zip 中的构造方法
DeflaterInputStream(InputStream in, Deflater defl)
创建一个带有指定压缩器和默认缓冲区大小的新输入流。
DeflaterInputStream(InputStream in, Deflater defl, int bufLen)
创建一个带有指定压缩器和缓冲区大小的新输入流。
DeflaterOutputStream(OutputStream out, Deflater def)
使用指定压缩器和默认缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream out, Deflater def, int size)
使用指定压缩器和缓冲区大小创建一个新输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.DeflaterInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.DeflaterInputStream
的使用

没有 java.util.zip.DeflaterInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.DeflaterOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.DeflaterOutputStream
的使用

使用 DeflaterOutputStream 的软件包
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.jar 中 DeflaterOutputStream 的使用

java.util.jar 中 DeflaterOutputStream 的子类
 class JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

java.util.zip 中 DeflaterOutputStream 的使用

java.util.zip 中 DeflaterOutputStream 的子类
class | GZIPOutputStream 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
class | ZipOutputStream 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.GZIPInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.GZIPInputStream
的使用

没有 java.util.zip.GZIPInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.GZIPOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.GZIPOutputStream
的使用

没有 java.util.zip.GZIPOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.Inflater 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.Inflater
的使用

使用 Inflater 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 Inflater 的使用

声明为 Inflater 的 java.util.zip 中的字段
protected Inflater | InflaterOutputStream.inf 此流的解压缩器。
protected Inflater | InflaterInputStream.inf 流的解压缩器。

参数类型为 Inflater 的 java.util.zip 中的构造方法
InflaterInputStream(InputStream in, Inflater inf)
创建一个带有指定解压缩器和默认缓冲区大小的新输入流。
InflaterInputStream(InputStream in, Inflater inf, int size)
使用指定解压缩器和缓冲区大小创建一个新输入流。
InflaterOutputStream(OutputStream out, Inflater infl)
创建一个带有指定解压缩器和默认缓冲区大小的新输出流。
InflaterOutputStream(OutputStream out, Inflater infl, int bufLen)
创建一个带有指定解压缩器和缓冲区大小的新输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.InflaterInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.InflaterInputStream
的使用

使用 InflaterInputStream 的软件包
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.jar 中 InflaterInputStream 的使用

java.util.jar 中 InflaterInputStream 的子类
 class JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。

java.util.zip 中 InflaterInputStream 的使用

java.util.zip 中 InflaterInputStream 的子类
class | GZIPInputStream 此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
class | ZipInputStream 此类为读取 ZIP 文件格式的文件实现输入流过滤器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.InflaterOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.InflaterOutputStream
的使用

没有 java.util.zip.InflaterOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.ZipEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipEntry
的使用

使用 ZipEntry 的软件包
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.jar 中 ZipEntry 的使用

java.util.jar 中 ZipEntry 的子类
 class JarEntry
此类用于表示 JAR 文件条目。

返回 ZipEntry 的 java.util.jar 中的方法
protected ZipEntry | JarInputStream.createZipEntry(String name) 为指定的 JAR 文件条目名称创建新的 JarEntry (ZipEntry)。
ZipEntry | JarFile.getEntry(String name) 返回给定条目名称的 ZipEntry；如果未找到，则返回 null。
ZipEntry | JarInputStream.getNextEntry() 读取下一个 ZIP 文件条目，并将流定位于此条目数据的开始处。

参数类型为 ZipEntry 的 java.util.jar 中的方法
InputStream | JarFile.getInputStream(ZipEntry ze) 返回用于读取指定 zip 文件条目内容的输入流。
void | JarOutputStream.putNextEntry(ZipEntry ze) 开始写入新的 JAR 文件条目，并将流定位到条目数据的开始处。

参数类型为 ZipEntry 的 java.util.jar 中的构造方法
JarEntry(ZipEntry ze)
使用从指定 ZipEntry 对象获取的字段创建新的 JarEntry。

java.util.zip 中 ZipEntry 的使用

返回 ZipEntry 的 java.util.zip 中的方法
protected ZipEntry | ZipInputStream.createZipEntry(String name) 为指定条目名称创建一个新的 ZipEntry 对象。
ZipEntry | ZipFile.getEntry(String name) 返回指定名称的 ZIP 文件条目；如果未找到，则返回 null。
ZipEntry | ZipInputStream.getNextEntry() 读取下一个 ZIP 文件条目并将流定位到该条目数据的开始处。

返回变量类型为 ZipEntry 的类型的 java.util.zip 中的方法
 Enumeration<? extends ZipEntry> ZipFile.entries()
返回 ZIP 文件条目的枚举。

参数类型为 ZipEntry 的 java.util.zip 中的方法
InputStream | ZipFile.getInputStream(ZipEntry entry) 返回输入流以读取指定 ZIP 文件条目的内容。
void | ZipOutputStream.putNextEntry(ZipEntry e) 开始写入新的 ZIP 文件条目并将流定位到条目数据的开始处。

参数类型为 ZipEntry 的 java.util.zip 中的构造方法
ZipEntry(ZipEntry e)
使用从指定 ZIP 条目获取的字段创建新的 ZIP 条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.ZipError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipError
的使用

没有 java.util.zip.ZipError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.ZipException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipException
的使用

使用 ZipException 的软件包
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.jar 中 ZipException 的使用

java.util.jar 中 ZipException 的子类
 class JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

java.util.zip 中 ZipException 的使用

抛出 ZipException 的 java.util.zip 中的构造方法
ZipFile(File file)
打开供阅读的 ZIP 文件，由指定的 File 对象给出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.ZipFile 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipFile
的使用

使用 ZipFile 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 ZipFile 的使用

java.util.jar 中 ZipFile 的子类
 class JarFile
JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.ZipInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipInputStream
的使用

使用 ZipInputStream 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 ZipInputStream 的使用

java.util.jar 中 ZipInputStream 的子类
 class JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 java.util.zip.ZipOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipOutputStream
的使用

使用 ZipOutputStream 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 ZipOutputStream 的使用

java.util.jar 中 ZipOutputStream 的子类
 class JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.accessibility (Java 2 Platform SE 6)

 javax.accessibility
接口
Accessible
AccessibleAction
AccessibleComponent
AccessibleEditableText
AccessibleExtendedComponent
AccessibleExtendedTable
AccessibleExtendedText
AccessibleHypertext
AccessibleIcon
AccessibleKeyBinding
AccessibleSelection
AccessibleStreamable
AccessibleTable
AccessibleTableModelChange
AccessibleText
AccessibleValue
类
AccessibleAttributeSequence
AccessibleBundle
AccessibleContext
AccessibleHyperlink
AccessibleRelation
AccessibleRelationSet
AccessibleResourceBundle
AccessibleRole
AccessibleState
AccessibleStateSet
AccessibleTextSequence


接口 javax.accessibility.Accessible 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.Accessible
的使用

使用 Accessible 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 Accessible 的使用

实现 Accessible 的 java.applet 中的类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 Accessible 的使用

实现 Accessible 的 java.awt 中的类
class | Button 此类创建一个标签按钮。
class | Canvas Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
class | CheckboxMenuItem 此类表示一个可包括在菜单中的复选框。
class | Choice Choice 类表示一个弹出式选择菜单。
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。
class | Label Label 对象是一个可在容器中放置文本的组件。
class | List List 组件为用户提供了一个可滚动的文本项列表。
protected class | List.AccessibleAWTList.AccessibleAWTListChild 此类实现 List 子级的可访问性支持。
class | Menu Menu 对象是从菜单栏部署的下拉式菜单组件。
class | MenuBar MenuBar 类封装绑定到框架的菜单栏的平台概念。
class | MenuItem 菜单中的所有项必须属于类 MenuItem 或其子类之一。
class | Panel Panel 是最简单的容器类。
class | PopupMenu 此类实现能够在组件中的指定位置上动态弹出的菜单。
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
class | TextArea TextArea 对象是显示文本的多行区域。
class | TextComponent TextComponent 类是所有允许编辑文本的组件的超类。
class | TextField TextField 对象是允许编辑单行文本的文本组件。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。

返回 Accessible 的 java.awt 中的方法
Accessible | List.AccessibleAWTList.getAccessibleAt(Point p) 返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
Accessible | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleAt(Point p) 如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回该子级。
Accessible | MenuComponent.AccessibleAWTMenuComponent.getAccessibleAt(Point p) 返回本地坐标 Point 包含的 Accessible 子对象（如果存在）。
Accessible | Container.AccessibleAWTContainer.getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | Component.AccessibleAWTComponent.getAccessibleAt(Point p) 返回包含在局部坐标 Point 上的 Accessible 子对象（如果存在这样的对象）。
Accessible | List.AccessibleAWTList.getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
Accessible | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
Accessible | MenuComponent.AccessibleAWTMenuComponent.getAccessibleChild(int i) 返回该对象的第 n 个 Accessible 子对象。
Accessible | Container.AccessibleAWTContainer.getAccessibleChild(int i) 返回对象的第 n 个 Accessible 子容器。
Accessible | Component.AccessibleAWTComponent.getAccessibleChild(int i) 返回该对象的第 n 个 Accessible 子对象。
Accessible | MenuComponent.AccessibleAWTMenuComponent.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | Component.AccessibleAWTComponent.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | List.AccessibleAWTList.getAccessibleSelection(int i) 返回表示对象中指定选项的 Accessible。
Accessible | MenuComponent.AccessibleAWTMenuComponent.getAccessibleSelection(int i) 返回 Accessible，它表示该对象中指定的已选择的子对象。

javax.accessibility 中 Accessible 的使用

声明为 Accessible 的 javax.accessibility 中的字段
protected  Accessible AccessibleContext.accessibleParent
此对象的可访问父级。

返回 Accessible 的 javax.accessibility 中的方法
Accessible | AccessibleTable.getAccessibleAt(int r, int c) 返回表中指定行和列处的 Accessible。
Accessible | AccessibleComponent.getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | AccessibleTable.getAccessibleCaption() 返回此表的标题。
abstract Accessible | AccessibleContext.getAccessibleChild(int i) 返回该对象的指定 Accessible 子级。
Accessible | AccessibleTable.getAccessibleColumnDescription(int c) 返回表中指定列的描述文本。
Accessible | AccessibleContext.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | AccessibleTable.getAccessibleRowDescription(int r) 返回对表中指定行的描述。
Accessible | AccessibleSelection.getAccessibleSelection(int i) 返回表示指定的所选对象子级的 Accessible。
Accessible | AccessibleTable.getAccessibleSummary() 返回表的摘要描述。

参数类型为 Accessible 的 javax.accessibility 中的方法
void | AccessibleTable.setAccessibleCaption(Accessible a) 设置表的标题。
void | AccessibleTable.setAccessibleColumnDescription(int c, Accessible a) 设置表中指定列的描述文本。
void | AccessibleContext.setAccessibleParent(Accessible a) 设置此对象的 Accessible 父对象。
void | AccessibleTable.setAccessibleRowDescription(int r, Accessible a) 设置表中指定行的描述文本。
void | AccessibleTable.setAccessibleSummary(Accessible a) 设置表的摘要描述。

javax.swing 中 Accessible 的使用

实现 Accessible 的 javax.swing 中的类
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | ImageIcon 一个 Icon 接口的实现，它根据 Image 绘制 Icon。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JDialog 创建对话框窗口的主要类。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
protected class | JList.AccessibleJList.AccessibleJListChild 此类实现供 List 子级使用的可访问性支持。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
protected class | JTable.AccessibleJTable.AccessibleJTableCell 此类提供了适用于表单元格的 Java Accessibility API 实现。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
protected class | JTree.AccessibleJTree.AccessibleJTreeNode 此类实现 JTree 子类的可访问性支持。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。
class | ProgressMonitor 监视某个操作的进度的类。

返回 Accessible 的 javax.swing 中的方法
static Accessible | SwingUtilities.getAccessibleAt(Component c, Point p) 如果存在，则返回本地坐标 Point 处包含的 Accessible 子对象。
Accessible | JTable.AccessibleJTable.getAccessibleAt(int r, int c)
Accessible | JEditorPane.AccessibleJEditorPaneHTML.getAccessibleAt(Point p) 返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
Accessible | JTree.AccessibleJTree.getAccessibleAt(Point p) 返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
Accessible | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAt(Point p) 返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
Accessible | JTable.AccessibleJTable.getAccessibleAt(Point p) 如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回 Accessible 子级。
Accessible | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAt(Point p)
Accessible | JTabbedPane.AccessibleJTabbedPane.getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | JList.AccessibleJList.getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | JList.AccessibleJList.AccessibleJListChild.getAccessibleAt(Point p)
Accessible | JTable.AccessibleJTable.getAccessibleCaption() 返回此表的标题。
static Accessible | SwingUtilities.getAccessibleChild(Component c, int i) 返回对象的第 n 个可访问子对象。
Accessible | JEditorPane.AccessibleJEditorPaneHTML.getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
Accessible | JSpinner.AccessibleJSpinner.getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
Accessible | ProgressMonitor.AccessibleProgressMonitor.getAccessibleChild(int i) 返回该对象指定的 Accessible 子对象。
Accessible | JTree.AccessibleJTree.getAccessibleChild(int i) 返回对象的第 n 个可访问子对象。
Accessible | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleChild(int i) 返回对象的指定 Accessible 子对象。
Accessible | JTable.AccessibleJTable.getAccessibleChild(int i) 返回该对象的第 n 个 Accessible 子对象。
Accessible | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleChild(int i) 返回此对象的指定的 Accessible 子对象。
Accessible | JTabbedPane.AccessibleJTabbedPane.getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
Accessible | JList.AccessibleJList.getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
Accessible | JList.AccessibleJList.AccessibleJListChild.getAccessibleChild(int i)
Accessible | JComboBox.AccessibleJComboBox.getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
Accessible | ImageIcon.AccessibleImageIcon.getAccessibleChild(int i) 返回对象的第 n 个 Accessible 子对象。
Accessible | JMenu.AccessibleJMenu.getAccessibleChild(int i) 返回对象的第 n 个 Accessible 子对象。
Accessible | JRootPane.AccessibleJRootPane.getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
Accessible | JComponent.AccessibleJComponent.getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
Accessible | JTable.AccessibleJTable.getAccessibleColumnDescription(int c) 返回对表中指定列的描述。
Accessible | ProgressMonitor.AccessibleProgressMonitor.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | ImageIcon.AccessibleImageIcon.getAccessibleParent() 获得此对象的 Accessible 父对象。
Accessible | JTable.AccessibleJTable.getAccessibleRowDescription(int r) 返回对表中指定行的描述。
Accessible | JTree.AccessibleJTree.getAccessibleSelection(int i) 返回表示对象中指定选择项的 Accessible。
Accessible | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleSelection(int i) 返回表示对象中指定选择项的 Accessible。
Accessible | JTable.AccessibleJTable.getAccessibleSelection(int i) 返回 Accessible，它表示该对象中指定的已选择的子对象。
Accessible | JTabbedPane.AccessibleJTabbedPane.getAccessibleSelection(int i)
Accessible | JList.AccessibleJList.getAccessibleSelection(int i) 返回表示对象中指定选项的 Accessible。
Accessible | JComboBox.AccessibleJComboBox.getAccessibleSelection(int i) 返回表示弹出对象中指定选择子级的 Accessible。
Accessible | JMenuBar.AccessibleJMenuBar.getAccessibleSelection(int i) 返回当前选择的菜单（如果选择了一个）；否则返回 null。
Accessible | JMenu.AccessibleJMenu.getAccessibleSelection(int i) 返回当前选择的子菜单（如果选择了），否则返回 null（只能选择一项并且只能选择子菜单，除非菜单项没有保持选中状态）。
Accessible | JTable.AccessibleJTable.getAccessibleSummary() 返回表的摘要描述。

参数类型为 Accessible 的 javax.swing 中的方法
void | JTable.AccessibleJTable.setAccessibleCaption(Accessible a) 设置表的标题。
void | JTable.AccessibleJTable.setAccessibleColumnDescription(int c, Accessible a) 设置表中指定列的描述文本。
void | JTable.AccessibleJTable.setAccessibleRowDescription(int r, Accessible a) 设置表中指定行的描述文本。
void | JTable.AccessibleJTable.setAccessibleSummary(Accessible a) 设置表的摘要描述。

参数类型为 Accessible 的 javax.swing 中的构造方法
JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
构造一个 AccessibleJTreeNode

javax.swing.colorchooser 中 Accessible 的使用

实现 Accessible 的 javax.swing.colorchooser 中的类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.plaf 中 Accessible 的使用

返回 Accessible 的 javax.swing.plaf 中的方法
 Accessible ComponentUI.getAccessibleChild(JComponent c, int i)
返回对象的第 i 个 Accessible 子对象。

javax.swing.plaf.basic 中 Accessible 的使用

实现 Accessible 的 javax.swing.plaf.basic 中的类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
protected class | BasicToolBarUI.DragWindow

返回 Accessible 的 javax.swing.plaf.basic 中的方法
 Accessible BasicComboBoxUI.getAccessibleChild(JComponent c, int i)

javax.swing.plaf.metal 中 Accessible 的使用

实现 Accessible 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

javax.swing.plaf.multi 中 Accessible 的使用

返回 Accessible 的 javax.swing.plaf.multi 中的方法
Accessible | MultiButtonUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiColorChooserUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiComboBoxUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiDesktopIconUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiDesktopPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiFileChooserUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiInternalFrameUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiLabelUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiListUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiMenuBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiMenuItemUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiOptionPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiPanelUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiPopupMenuUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiProgressBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiRootPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiScrollBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiScrollPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSeparatorUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSliderUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSpinnerUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSplitPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTabbedPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTableHeaderUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTableUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTextUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiToolBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiToolTipUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTreeUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiViewportUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

javax.swing.table 中 Accessible 的使用

实现 Accessible 的 javax.swing.table 中的类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。
protected class | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。

返回 Accessible 的 javax.swing.table 中的方法
Accessible | JTableHeader.AccessibleJTableHeader.getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAt(Point p)
Accessible | JTableHeader.AccessibleJTableHeader.getAccessibleChild(int i) 返回该对象的第 n 个可访问子对象。
Accessible | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleChild(int i)

javax.swing.text 中 Accessible 的使用

实现 Accessible 的 javax.swing.text 中的类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

javax.swing.text.html 中 Accessible 的使用

实现 Accessible 的 javax.swing.text.html 中的类
 class HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。

javax.swing.tree 中 Accessible 的使用

实现 Accessible 的 javax.swing.tree 中的类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellRenderer 显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleAction
的使用

使用 AccessibleAction 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 AccessibleAction 的使用

实现 AccessibleAction 的 java.awt 中的类
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Choice.AccessibleAWTChoice 此类实现对 Choice 类的可访问性支持。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。

返回 AccessibleAction 的 java.awt 中的方法
AccessibleAction | Button.AccessibleAWTButton.getAccessibleAction() 获取与此对象相关的 AccessibleAction。
AccessibleAction | Checkbox.AccessibleAWTCheckbox.getAccessibleAction() 获取与此对象相关的 AccessibleAction。
AccessibleAction | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleAction() 获取与此对象相关的 AccessibleAction。
AccessibleAction | Choice.AccessibleAWTChoice.getAccessibleAction() 获取与此对象相关的 AccessibleAction。
AccessibleAction | MenuItem.AccessibleAWTMenuItem.getAccessibleAction() 获取与此对象关联的 AccessibleAction。

javax.accessibility 中 AccessibleAction 的使用

实现 AccessibleAction 的 javax.accessibility 中的类
 class AccessibleHyperlink
Hypertext 文档中的某个链接或一组链接（例如客户端 imagemap）的封装。

返回 AccessibleAction 的 javax.accessibility 中的方法
 AccessibleAction AccessibleContext.getAccessibleAction()
获取与此对象关联的可支持一个或多个动作的 AccessibleAction。

javax.swing 中 AccessibleAction 的使用

实现 AccessibleAction 的 javax.swing 中的类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
class | JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JTree.AccessibleJTree.AccessibleJTreeNode 此类实现 JTree 子类的可访问性支持。

返回 AccessibleAction 的 javax.swing 中的方法
AccessibleAction | JSpinner.AccessibleJSpinner.getAccessibleAction() 获取与此对象关联的可支持一个或多个操作的 AccessibleAction。
AccessibleAction | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAction() 获取与此对象关联的 AccessibleAction。
AccessibleAction | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAction() 获取与此对象关联的 AccessibleAction（如果存在）。
AccessibleAction | JList.AccessibleJList.AccessibleJListChild.getAccessibleAction()
AccessibleAction | JComboBox.AccessibleJComboBox.getAccessibleAction() 获取与此对象关联的 AccessibleAction。
AccessibleAction | AbstractButton.AccessibleAbstractButton.getAccessibleAction() 获取与此对象关联的 AccessibleAction。

javax.swing.table 中 AccessibleAction 的使用

返回 AccessibleAction 的 javax.swing.table 中的方法
 AccessibleAction JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAction()

javax.swing.text 中 AccessibleAction 的使用

实现 AccessibleAction 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 AccessibleAction 的 javax.swing.text 中的方法
 AccessibleAction JTextComponent.AccessibleJTextComponent.getAccessibleAction()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleAttributeSequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleAttributeSequence
的使用

没有 javax.accessibility.AccessibleAttributeSequence 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleBundle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleBundle
的使用

使用 AccessibleBundle 的软件包
javax.accessibility 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.accessibility 中 AccessibleBundle 的使用

javax.accessibility 中 AccessibleBundle 的子类
class | AccessibleRelation AccessibleRelation 类描述了实现 AccessibleRelation 的对象与一个或多个其他对象之间的关系。
class | AccessibleRole AccessibleRole 类确定组件的职责。
class | AccessibleState AccessibleState 类描述了组件的特殊状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleComponent
的使用

使用 AccessibleComponent 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 AccessibleComponent 的使用

实现 AccessibleComponent 的 java.applet 中的类
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

java.awt 中 AccessibleComponent 的使用

实现 AccessibleComponent 的 java.awt 中的类
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
protected class | Canvas.AccessibleAWTCanvas 此类实现对 Canvas 类的可访问性支持。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Choice.AccessibleAWTChoice 此类实现对 Choice 类的可访问性支持。
protected class | Component.AccessibleAWTComponent 用来为可访问性提供默认支持的 Component 的内部类。
protected class | Container.AccessibleAWTContainer 用于对可访问性提供默认支持的 Container 内部类。
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。
protected class | Label.AccessibleAWTLabel 此类实现对 Label 类的可访问性支持。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | List.AccessibleAWTList.AccessibleAWTListChild 此类实现 List 子级的可访问性支持。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuBar.AccessibleAWTMenuBar 菜单栏的内部类，用于为可访问性提供默认支持。
protected class | MenuComponent.AccessibleAWTMenuComponent 用于为可访问性提供默认支持的 MenuComponent 的内部类。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | Panel.AccessibleAWTPanel 此类实现 Panel 类的可访问性支持。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。
protected class | Scrollbar.AccessibleAWTScrollBar 此类实现 Scrollbar 类的可访问性支持。
protected class | ScrollPane.AccessibleAWTScrollPane 此类实现 ScrollPane 类的可访问性支持。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。
protected class | Window.AccessibleAWTWindow 此类实现对 Window 类的可访问性支持。

返回 AccessibleComponent 的 java.awt 中的方法
AccessibleComponent | MenuComponent.AccessibleAWTMenuComponent.getAccessibleComponent() 获取与此对象关联的 AccessibleComponent（如果存在）。
AccessibleComponent | Component.AccessibleAWTComponent.getAccessibleComponent() 获取与此对象相关的 AccessibleComponent（如果存在一个这样的组件）。

javax.accessibility 中 AccessibleComponent 的使用

javax.accessibility 中 AccessibleComponent 的子接口
 interface AccessibleExtendedComponent
屏幕上呈现的任何对象都应该支持 AccessibleExtendedComponent 接口。

返回 AccessibleComponent 的 javax.accessibility 中的方法
 AccessibleComponent AccessibleContext.getAccessibleComponent()
获取与此对象关联的 AccessibleComponent，它具有图形表示形式。

javax.swing 中 AccessibleComponent 的使用

实现 AccessibleComponent 的 javax.swing 中的类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
protected class | Box.Filler.AccessibleBoxFiller 此类实现 Box.Filler 类的可访问性支持。
protected class | CellRendererPane.AccessibleCellRendererPane 此类实现 Panel 类的可访问性支持。
protected class | JApplet.AccessibleJApplet 此类实现对 JApplet 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JList.AccessibleJList.AccessibleJListChild 此类实现供 List 子级使用的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTable.AccessibleJTable.AccessibleJTableCell 此类提供了适用于表单元格的 Java Accessibility API 实现。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JTree.AccessibleJTree.AccessibleJTreeNode 此类实现 JTree 子类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。

返回 AccessibleComponent 的 javax.swing 中的方法
AccessibleComponent | ProgressMonitor.AccessibleProgressMonitor.getAccessibleComponent() 获取与此对象关联的 AccessibleComponent，它具有图形表示形式。
AccessibleComponent | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleComponent() 获取与此对象关联的 AccessibleComponent。
AccessibleComponent | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleComponent() 获取与此对象关联的 AccessibleComponent（如果存在）。
AccessibleComponent | JList.AccessibleJList.AccessibleJListChild.getAccessibleComponent() 获取与此对象关联的 AccessibleComponent。

javax.swing.table 中 AccessibleComponent 的使用

实现 AccessibleComponent 的 javax.swing.table 中的类
protected class | JTableHeader.AccessibleJTableHeader 此类实现对 JTableHeader 类的可访问性支持。
protected class | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。

返回 AccessibleComponent 的 javax.swing.table 中的方法
 AccessibleComponent JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleComponent()
获取与此对象关联的 AccessibleComponent。

javax.swing.text 中 AccessibleComponent 的使用

实现 AccessibleComponent 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleContext
的使用

使用 AccessibleContext 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 AccessibleContext 的使用

java.applet 中 AccessibleContext 的子类
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

返回 AccessibleContext 的 java.applet 中的方法
 AccessibleContext Applet.getAccessibleContext()
获取与此 Applet 关联的 AccessibleContext。

java.awt 中 AccessibleContext 的使用

java.awt 中 AccessibleContext 的子类
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
protected class | Canvas.AccessibleAWTCanvas 此类实现对 Canvas 类的可访问性支持。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Choice.AccessibleAWTChoice 此类实现对 Choice 类的可访问性支持。
protected class | Component.AccessibleAWTComponent 用来为可访问性提供默认支持的 Component 的内部类。
protected class | Container.AccessibleAWTContainer 用于对可访问性提供默认支持的 Container 内部类。
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。
protected class | Label.AccessibleAWTLabel 此类实现对 Label 类的可访问性支持。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | List.AccessibleAWTList.AccessibleAWTListChild 此类实现 List 子级的可访问性支持。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuBar.AccessibleAWTMenuBar 菜单栏的内部类，用于为可访问性提供默认支持。
protected class | MenuComponent.AccessibleAWTMenuComponent 用于为可访问性提供默认支持的 MenuComponent 的内部类。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | Panel.AccessibleAWTPanel 此类实现 Panel 类的可访问性支持。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。
protected class | Scrollbar.AccessibleAWTScrollBar 此类实现 Scrollbar 类的可访问性支持。
protected class | ScrollPane.AccessibleAWTScrollPane 此类实现 ScrollPane 类的可访问性支持。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。
protected class | Window.AccessibleAWTWindow 此类实现对 Window 类的可访问性支持。

返回 AccessibleContext 的 java.awt 中的方法
AccessibleContext | Button.getAccessibleContext() 获取与此 Button 相关的 AccessibleContext。
AccessibleContext | Checkbox.getAccessibleContext() 获取与此 Checkbox 相关的 AccessibleContext。
AccessibleContext | CheckboxMenuItem.getAccessibleContext() 获取与此 CheckboxMenuItem 相关的 AccessibleContext。
AccessibleContext | Choice.getAccessibleContext() 获取与此 Choice 相关的 AccessibleContext。
AccessibleContext | List.getAccessibleContext() 获取与此 List 关联的 AccessibleContext。
AccessibleContext | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleContext() 获取此对象的 AccessibleContext。
AccessibleContext | ScrollPane.getAccessibleContext() 获取与此 ScrollPane 相关的 AccessibleContext。
AccessibleContext | Scrollbar.getAccessibleContext() 获取与此 Scrollbar 相关的 AccessibleContext。
AccessibleContext | TextArea.getAccessibleContext() 返回与此 TextArea 相关的 AccessibleContext。
AccessibleContext | TextComponent.getAccessibleContext() 获取与此 TextComponent 关联的 AccessibleContext。
AccessibleContext | TextField.getAccessibleContext() 获取与此 TextField 关联的 AccessibleContext。
AccessibleContext | MenuBar.getAccessibleContext() 获取与此菜单栏关联的 AccessibleContext。
AccessibleContext | Panel.getAccessibleContext() 获取与 Panel 相关的 AccessibleContext。
AccessibleContext | Canvas.getAccessibleContext() 获取与此 Canvas 相关的 AccessibleContext。
AccessibleContext | PopupMenu.getAccessibleContext() 获取与此 PopupMenu 关联的 AccessibleContext。
AccessibleContext | Menu.getAccessibleContext() 获取与此菜单关联的 AccessibleContext。
AccessibleContext | MenuItem.getAccessibleContext() 获取与此菜单项关联的 AccessibleContext。
AccessibleContext | MenuComponent.getAccessibleContext() 获取与此 MenuComponent 关联的 AccessibleContext。
AccessibleContext | Dialog.getAccessibleContext() 获取与此 Dialog 有关的 AccessibleContext。
AccessibleContext | Label.getAccessibleContext() 获取与此标签相关的 AccessibleContext。
AccessibleContext | Frame.getAccessibleContext() 获取与此窗体有关的 AccessibleContext。
AccessibleContext | Window.getAccessibleContext() 获取与此窗口关联的 AccessibleContext。
AccessibleContext | Component.getAccessibleContext() 获取与此 Component 相关的 AccessibleContext。

javax.accessibility 中 AccessibleContext 的使用

返回 AccessibleContext 的 javax.accessibility 中的方法
 AccessibleContext Accessible.getAccessibleContext()
返回与此对象关联的 AccessibleContext。

javax.swing 中 AccessibleContext 的使用

javax.swing 中 AccessibleContext 的子类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
protected class | Box.Filler.AccessibleBoxFiller 此类实现 Box.Filler 类的可访问性支持。
protected class | CellRendererPane.AccessibleCellRendererPane 此类实现 Panel 类的可访问性支持。
protected class | ImageIcon.AccessibleImageIcon 此类实现 ImageIcon 类的可访问性支持。
protected class | JApplet.AccessibleJApplet 此类实现对 JApplet 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JList.AccessibleJList.AccessibleJListChild 此类实现供 List 子级使用的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTable.AccessibleJTable.AccessibleJTableCell 此类提供了适用于表单元格的 Java Accessibility API 实现。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JTree.AccessibleJTree.AccessibleJTreeNode 此类实现 JTree 子类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。
protected class | ProgressMonitor.AccessibleProgressMonitor AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

声明为 AccessibleContext 的 javax.swing 中的字段
protected AccessibleContext | JColorChooser.accessibleContext
protected AccessibleContext | JFileChooser.accessibleContext
protected AccessibleContext | ProgressMonitor.accessibleContext ProgressMonitor 的 AccessibleContext
protected AccessibleContext | JApplet.accessibleContext
protected AccessibleContext | JWindow.accessibleContext 可访问的上下文属性。
protected AccessibleContext | CellRendererPane.accessibleContext
protected AccessibleContext | JDialog.accessibleContext
protected AccessibleContext | JComponent.accessibleContext 与此 JComponent 关联的 AccessibleContext。
protected AccessibleContext | JFrame.accessibleContext 可访问的上下文属性。

返回 AccessibleContext 的 javax.swing 中的方法
AccessibleContext | JColorChooser.getAccessibleContext() 获取与此 JColorChooser 关联的 AccessibleContext。
AccessibleContext | JDesktopPane.getAccessibleContext() 获取与此 JDesktopPane 关联的 AccessibleContext。
AccessibleContext | JEditorPane.getAccessibleContext() 获取与此 JEditorPane 关联的 AccessibleContext。
AccessibleContext | JFileChooser.getAccessibleContext() 获取与此 JFileChooser 关联的 AccessibleContext。
AccessibleContext | JOptionPane.getAccessibleContext() 返回与此 JOptionPane 相关联的 AccessibleContext。
AccessibleContext | JPasswordField.getAccessibleContext() 返回与此 JPasswordField 关联的 AccessibleContext。
AccessibleContext | JSpinner.getAccessibleContext() 获取此 JSpinner 的 AccessibleContext
AccessibleContext | ProgressMonitor.getAccessibleContext() 获得 ProgressMonitor 的 AccessibleContext。
AccessibleContext | JApplet.getAccessibleContext() 获取与此 JApplet 关联的 AccessibleContext。
AccessibleContext | JRadioButtonMenuItem.getAccessibleContext() 获取与此 JRadioButtonMenuItem 相关联的 AccessibleContext。
AccessibleContext | JSlider.getAccessibleContext() 获取与此 JSlider 关联的 AccessibleContext。
AccessibleContext | JToolTip.getAccessibleContext() 获取与此 JToolTip 关联的 AccessibleContext。
AccessibleContext | JTree.getAccessibleContext() 获取与此 JTree 关联的 AccessibleContext。
AccessibleContext | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleContext() 获取与此树节点关联的 AccessibleContext。
AccessibleContext | JTable.getAccessibleContext() 获取与此 JTable 关联的 AccessibleContext。
AccessibleContext | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleContext() 获取与此组件关联的 AccessibleContext。
AccessibleContext | JProgressBar.getAccessibleContext() 获得与此 JProgressBar 关联的 AccessibleContext。
AccessibleContext | JCheckBox.getAccessibleContext() 获取与此 JCheckBox 关联的 AccessibleContext。
AccessibleContext | JTabbedPane.getAccessibleContext() 获取与此 JTabbedPane 关联的 AccessibleContext。
AccessibleContext | JRadioButton.getAccessibleContext() 获取与此 JRadioButton 相关联的 AccessibleContext。
AccessibleContext | JWindow.getAccessibleContext() 获取与此 JWindow 关联的 AccessibleContext。
AccessibleContext | JTextArea.getAccessibleContext() 获取与此 JTextArea 关联的 AccessibleContext。
AccessibleContext | JTextField.getAccessibleContext() 获取与此 JTextField 关联的 AccessibleContext。
AccessibleContext | JViewport.getAccessibleContext() 获取与此 JViewport 关联的 AccessibleContext。
AccessibleContext | JScrollPane.getAccessibleContext() 获取与此 JScrollPane 相关联的 AccessibleContext。
AccessibleContext | JList.getAccessibleContext() 获取与此 JList 关联的 AccessibleContext。
AccessibleContext | JList.AccessibleJList.AccessibleJListChild.getAccessibleContext() 获取此对象的 AccessibleContext。
AccessibleContext | CellRendererPane.getAccessibleContext() 获取与此 CellRendererPane 相关的 AccessibleContext。
AccessibleContext | JScrollBar.getAccessibleContext() 获取与此 JScrollBar 相关联的 AccessibleContext。
AccessibleContext | JComboBox.getAccessibleContext() 获取与此 JComboBox 关联的 AccessibleContext。
AccessibleContext | JSeparator.getAccessibleContext() 获取与此 JSeparator 相关的 AccessibleContext。
AccessibleContext | JPopupMenu.getAccessibleContext() 获取与此 JPopupMenu 关联的 AccessibleContext。
AccessibleContext | JMenuBar.getAccessibleContext() 获取与此 JMenuBar 相关联的 AccessibleContext。
AccessibleContext | Box.getAccessibleContext() 获取与此 Box 相关联的 AccessibleContext。
AccessibleContext | Box.Filler.getAccessibleContext() 获取与此 Box.Filler 相关联的 AccessibleContext。
AccessibleContext | JToggleButton.getAccessibleContext() 获取与此 JToggleButton 关联的 AccessibleContext。
AccessibleContext | JSplitPane.getAccessibleContext() 获取与 JSplitPane 关联的 AccessibleContext。
AccessibleContext | JToolBar.getAccessibleContext() 获取与此 JToolBar 关联的 AccessibleContext。
AccessibleContext | JDialog.getAccessibleContext() 获取与此 JDialog 关联的 AccessibleContext。
AccessibleContext | ImageIcon.getAccessibleContext() 获得与此 ImageIcon 关联的 AccessibleContext。
AccessibleContext | JButton.getAccessibleContext() 获取与此 JButton 关联的 AccessibleContext。
AccessibleContext | JCheckBoxMenuItem.getAccessibleContext() 获得与此 JCheckBoxMenuItem 关联的 AccessibleContext。
AccessibleContext | JMenu.getAccessibleContext() 获取与此 JMenu 关联的 AccessibleContext。
AccessibleContext | JMenuItem.getAccessibleContext() 返回与此 JMenuItem 关联的 AccessibleContext。
AccessibleContext | JInternalFrame.getAccessibleContext() 获得与此 JInternalFrame 关联的 AccessibleContext。
AccessibleContext | JInternalFrame.JDesktopIcon.getAccessibleContext() 获取与此 JDesktopIcon 关联的 AccessibleContext。
AccessibleContext | JLayeredPane.getAccessibleContext() 获得与此 JLayeredPane 关联的 AccessibleContext。
AccessibleContext | JPanel.getAccessibleContext() 获取与此 JPanel 关联的 AccessibleContext。
AccessibleContext | JRootPane.getAccessibleContext() 获取与此 JRootPane 相关联的 AccessibleContext。
AccessibleContext | JLabel.getAccessibleContext() 获得此对象的 AccessibleContext。
AccessibleContext | JComponent.getAccessibleContext() 返回与此 JComponent 关联的 AccessibleContext。
AccessibleContext | JFrame.getAccessibleContext() 获得与此 JFrame 关联的 AccessibleContext。
protected AccessibleContext | JTable.AccessibleJTable.AccessibleJTableCell.getCurrentAccessibleContext() 获取表单元格渲染器的 AccessibleContext。

javax.swing.plaf.basic 中 AccessibleContext 的使用

返回 AccessibleContext 的 javax.swing.plaf.basic 中的方法
 AccessibleContext BasicComboPopup.getAccessibleContext()
获取与此 BasicComboPopup 关联的 AccessibleContext。

javax.swing.table 中 AccessibleContext 的使用

javax.swing.table 中 AccessibleContext 的子类
protected class | JTableHeader.AccessibleJTableHeader 此类实现对 JTableHeader 类的可访问性支持。
protected class | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。

返回 AccessibleContext 的 javax.swing.table 中的方法
AccessibleContext | JTableHeader.getAccessibleContext() 获取与此 JTableHeader 关联的 AccessibleContext。
AccessibleContext | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleContext() 获取与此对象关联的 AccessibleContext。

javax.swing.text 中 AccessibleContext 的使用

javax.swing.text 中 AccessibleContext 的子类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 AccessibleContext 的 javax.swing.text 中的方法
 AccessibleContext JTextComponent.getAccessibleContext()
获取与此 JTextComponent 关联的 AccessibleContext。

javax.swing.text.html 中 AccessibleContext 的使用

返回 AccessibleContext 的 javax.swing.text.html 中的方法
 AccessibleContext HTMLEditorKit.getAccessibleContext()
返回与此编辑器工具包关联的 AccessibleContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleEditableText 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleEditableText
的使用

使用 AccessibleEditableText 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.accessibility 中 AccessibleEditableText 的使用

返回 AccessibleEditableText 的 javax.accessibility 中的方法
 AccessibleEditableText AccessibleContext.getAccessibleEditableText()
获取与在显示器上显示可编辑文本的此对象关联的 AccessibleEditableText。

javax.swing 中 AccessibleEditableText 的使用

实现 AccessibleEditableText 的 javax.swing 中的类
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。

javax.swing.text 中 AccessibleEditableText 的使用

实现 AccessibleEditableText 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 AccessibleEditableText 的 javax.swing.text 中的方法
 AccessibleEditableText JTextComponent.AccessibleJTextComponent.getAccessibleEditableText()
返回此文本组件的 AccessibleEditableText 接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleExtendedComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleExtendedComponent
的使用

使用 AccessibleExtendedComponent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 AccessibleExtendedComponent 的使用

实现 AccessibleExtendedComponent 的 javax.swing 中的类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。

javax.swing.table 中 AccessibleExtendedComponent 的使用

实现 AccessibleExtendedComponent 的 javax.swing.table 中的类
protected  class JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。

javax.swing.text 中 AccessibleExtendedComponent 的使用

实现 AccessibleExtendedComponent 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleExtendedTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleExtendedTable
的使用

使用 AccessibleExtendedTable 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AccessibleExtendedTable 的使用

实现 AccessibleExtendedTable 的 javax.swing 中的类
protected  class JTable.AccessibleJTable
此类实现对 JTable 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleExtendedText 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleExtendedText
的使用

使用 AccessibleExtendedText 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 AccessibleExtendedText 的使用

实现 AccessibleExtendedText 的 javax.swing 中的类
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。

javax.swing.text 中 AccessibleExtendedText 的使用

实现 AccessibleExtendedText 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleHyperlink 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleHyperlink
的使用

使用 AccessibleHyperlink 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 AccessibleHyperlink 的使用

返回 AccessibleHyperlink 的 javax.accessibility 中的方法
 AccessibleHyperlink AccessibleHypertext.getLink(int linkIndex)
返回此 Hypertext 文档中第 n 个链接。

javax.swing 中 AccessibleHyperlink 的使用

javax.swing 中 AccessibleHyperlink 的子类
 class JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

返回 AccessibleHyperlink 的 javax.swing 中的方法
 AccessibleHyperlink JEditorPane.JEditorPaneAccessibleHypertextSupport.getLink(int linkIndex)
返回超链接数组中该索引处的链接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleHypertext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleHypertext
的使用

使用 AccessibleHypertext 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AccessibleHypertext 的使用

实现 AccessibleHypertext 的 javax.swing 中的类
protected  class JEditorPane.JEditorPaneAccessibleHypertextSupport
AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleIcon
的使用

使用 AccessibleIcon 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 AccessibleIcon 的使用

返回 AccessibleIcon 的 javax.accessibility 中的方法
 AccessibleIcon[] AccessibleContext.getAccessibleIcon()
获取与此对象关联的具有一个或多个相关图标的 AccessibleIcons

javax.swing 中 AccessibleIcon 的使用

实现 AccessibleIcon 的 javax.swing 中的类
protected  class ImageIcon.AccessibleImageIcon
此类实现 ImageIcon 类的可访问性支持。

返回 AccessibleIcon 的 javax.swing 中的方法
AccessibleIcon[] | JList.AccessibleJList.AccessibleJListChild.getAccessibleIcon() 返回元素渲染器的图标，作为 AccessibleIcon 数组的唯一项；如果渲染器组件不包含任何图标，则返回一个 null 数组。
AccessibleIcon[] | AbstractButton.AccessibleAbstractButton.getAccessibleIcon() 获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。
AccessibleIcon[] | JLabel.AccessibleJLabel.getAccessibleIcon() 获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleKeyBinding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleKeyBinding
的使用

使用 AccessibleKeyBinding 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 AccessibleKeyBinding 的使用

返回 AccessibleKeyBinding 的 javax.accessibility 中的方法
 AccessibleKeyBinding AccessibleExtendedComponent.getAccessibleKeyBinding()
返回与此对象关联的键绑定。

javax.swing 中 AccessibleKeyBinding 的使用

返回 AccessibleKeyBinding 的 javax.swing 中的方法
AccessibleKeyBinding | AbstractButton.AccessibleAbstractButton.getAccessibleKeyBinding() 返回与此对象有关的键绑定。
AccessibleKeyBinding | JLabel.AccessibleJLabel.getAccessibleKeyBinding() 返回与此对象关联的键绑定
AccessibleKeyBinding | JComponent.AccessibleJComponent.getAccessibleKeyBinding() 返回与此对象关联的键绑定

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleRelation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleRelation
的使用

使用 AccessibleRelation 的软件包
javax.accessibility 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.accessibility 中 AccessibleRelation 的使用

类型参数类型为 AccessibleRelation 的 javax.accessibility 中的字段
protected  Vector<AccessibleRelation> AccessibleRelationSet.relations
Vector 中的每个项表示一个 AccessibleRelation。

返回 AccessibleRelation 的 javax.accessibility 中的方法
AccessibleRelation | AccessibleRelationSet.get(String key) 返回与指定键匹配的关系。
AccessibleRelation[] | AccessibleRelationSet.toArray() 返回作为 AccessibleRelation 数组的当前关系集

参数类型为 AccessibleRelation 的 javax.accessibility 中的方法
boolean | AccessibleRelationSet.add(AccessibleRelation relation) 将新关系添加到当前关系集中。
void | AccessibleRelationSet.addAll(AccessibleRelation[] relations) 将所有关系添加到现有关系集中。
boolean | AccessibleRelationSet.remove(AccessibleRelation relation) 从当前关系集中移除一个关系。

参数类型为 AccessibleRelation 的 javax.accessibility 中的构造方法
AccessibleRelationSet(AccessibleRelation[] relations)
创建具有传入的关系数组中所包含的初始关系集的新关系。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleRelationSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleRelationSet
的使用

使用 AccessibleRelationSet 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 AccessibleRelationSet 的使用

返回 AccessibleRelationSet 的 javax.accessibility 中的方法
 AccessibleRelationSet AccessibleContext.getAccessibleRelationSet()
获取与某个对象关联的 AccessibleRelationSet

javax.swing 中 AccessibleRelationSet 的使用

返回 AccessibleRelationSet 的 javax.swing 中的方法
AccessibleRelationSet | AbstractButton.AccessibleAbstractButton.getAccessibleRelationSet() 获得与此对象关联的 AccessibleRelationSet（如果存在）。
AccessibleRelationSet | JLabel.AccessibleJLabel.getAccessibleRelationSet() 获取与此对象关联的 AccessibleRelationSet（如果存在）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleResourceBundle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleResourceBundle
的使用

没有 javax.accessibility.AccessibleResourceBundle 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleRole 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleRole
的使用

使用 AccessibleRole 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 AccessibleRole 的使用

返回 AccessibleRole 的 java.applet 中的方法
 AccessibleRole Applet.AccessibleApplet.getAccessibleRole()
获取此对象的职责。

java.awt 中 AccessibleRole 的使用

返回 AccessibleRole 的 java.awt 中的方法
AccessibleRole | Button.AccessibleAWTButton.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Checkbox.AccessibleAWTCheckbox.getAccessibleRole() 获取此对象的职责。
AccessibleRole | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Choice.AccessibleAWTChoice.getAccessibleRole() 获取此对象的职责。
AccessibleRole | List.AccessibleAWTList.getAccessibleRole() 获取此对象的职责。
AccessibleRole | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleRole() 获取此对象的职责。
AccessibleRole | ScrollPane.AccessibleAWTScrollPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Scrollbar.AccessibleAWTScrollBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | TextComponent.AccessibleAWTTextComponent.getAccessibleRole() 获取此对象的职责。
AccessibleRole | MenuBar.AccessibleAWTMenuBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Panel.AccessibleAWTPanel.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Canvas.AccessibleAWTCanvas.getAccessibleRole() 获取此对象的职责。
AccessibleRole | PopupMenu.AccessibleAWTPopupMenu.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Menu.AccessibleAWTMenu.getAccessibleRole() 获取此对象的职责。
AccessibleRole | MenuItem.AccessibleAWTMenuItem.getAccessibleRole() 获取此对象的职责。
AccessibleRole | MenuComponent.AccessibleAWTMenuComponent.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Dialog.AccessibleAWTDialog.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Label.AccessibleAWTLabel.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Frame.AccessibleAWTFrame.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Window.AccessibleAWTWindow.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Component.AccessibleAWTComponent.getAccessibleRole() 获取此对象的职责。

javax.accessibility 中 AccessibleRole 的使用

声明为 AccessibleRole 的 javax.accessibility 中的字段
static AccessibleRole | AccessibleRole.ALERT 可用于就某事向用户报警的对象。
static AccessibleRole | AccessibleRole.AWT_COMPONENT 一个 AWT 组件，但关于它的其他信息都是未知的。
static AccessibleRole | AccessibleRole.CANVAS 可用于绘制和捕获事件的对象。
static AccessibleRole | AccessibleRole.CHECK_BOX 可以被选中或不被选中的选项，它针对当前状态提供了单独的指示符。
static AccessibleRole | AccessibleRole.COLOR_CHOOSER 允许用户选择颜色的专用窗格。
static AccessibleRole | AccessibleRole.COLUMN_HEADER 数据列的头。
static AccessibleRole | AccessibleRole.COMBO_BOX 用户可以从中进行选择的选项列表。
static AccessibleRole | AccessibleRole.DATE_EDITOR DATE_EDITOR 是允许用户编辑 java.util.Date 和 java.util.Time 对象的组件。
static AccessibleRole | AccessibleRole.DESKTOP_ICON DESKTOP_PANE 中的图标化的内部 frame。
static AccessibleRole | AccessibleRole.DESKTOP_PANE 支持内部窗体和这些内部窗体的图标化形式的窗格。
static AccessibleRole | AccessibleRole.DIALOG 带有标题栏和边框的顶层窗口。
static AccessibleRole | AccessibleRole.DIRECTORY_PANE 允许用户在目录内容中导航并进行选择的窗格。
static AccessibleRole | AccessibleRole.EDITBAR 该职责表示充当一个求值公式的对象。
static AccessibleRole | AccessibleRole.FILE_CHOOSER 一个专用的对话框，它显示目录中的文件，并允许用户选择文件、浏览不同的目录，或指定一个文件名。
static AccessibleRole | AccessibleRole.FILLER 填补用户界面空间的对象。
static AccessibleRole | AccessibleRole.FONT_CHOOSER FONT_CHOOSER 是允许用户选择各种字体属性的组件。
static AccessibleRole | AccessibleRole.FOOTER 文本脚注
static AccessibleRole | AccessibleRole.FRAME 带有标题栏、边框、菜单栏等的顶层窗口。
static AccessibleRole | AccessibleRole.GLASS_PANE 一个窗格，保证此窗格在其所有下级窗格之上进行绘制。
static AccessibleRole | AccessibleRole.GROUP_BOX GROUP_BOX 是包含它周围的边框及其内部组件的简单容器。
static AccessibleRole | AccessibleRole.HEADER 文本标题
static AccessibleRole | AccessibleRole.HTML_CONTAINER 包含一起能表示 HTML 内容的 Accessible 集合的对象。
static AccessibleRole | AccessibleRole.HYPERLINK 超文本锚
static AccessibleRole | AccessibleRole.ICON 一个固定大小的小图片，通常用于装饰组件。
static AccessibleRole | AccessibleRole.INTERNAL_FRAME 通过桌面窗格剪切的类似于窗体的对象。
static AccessibleRole | AccessibleRole.LABEL 用于在界面中显示图标或短字符串的对象。
static AccessibleRole | AccessibleRole.LAYERED_PANE 允许其子级在各层中进行绘制的专用窗格，提供堆栈顺序的形式。
static AccessibleRole | AccessibleRole.LIST 呈现给用户一个对象列表的对象，它还允许用户从中选择一个或多个对象。
static AccessibleRole | AccessibleRole.LIST_ITEM 呈现列表元素的对象。
static AccessibleRole | AccessibleRole.MENU 通常出现在菜单栏中的对象，它包含一个用户可以从中选择的动作列表。
static AccessibleRole | AccessibleRole.MENU_BAR 通常被绘制在应用程序的主对话框顶部的对象，它包含用户可以从中进行选择的菜单列表。
static AccessibleRole | AccessibleRole.MENU_ITEM 通常包含在菜单中的对象，该对象呈现用户可以选择的动作。
static AccessibleRole | AccessibleRole.OPTION_PANE 主要用于 DIALOG 内部的专用窗格
static AccessibleRole | AccessibleRole.PAGE_TAB 作为页选项卡列表子级的对象。
static AccessibleRole | AccessibleRole.PAGE_TAB_LIST 通过所提供的某种机制一次可呈现一系列窗格（或页选项卡）的对象。
static AccessibleRole | AccessibleRole.PANEL 通常用于对对象进行分组的一般容器。
static AccessibleRole | AccessibleRole.PARAGRAPH 文本段落
static AccessibleRole | AccessibleRole.PASSWORD_TEXT 用于密码或文本内容不显示给用户的其他地方的文本对象。
static AccessibleRole | AccessibleRole.POPUP_MENU 一个临时窗口，通常用于为用户提供选项列表，当用户选中其中某个选项后，此窗口隐藏。
static AccessibleRole | AccessibleRole.PROGRESS_BAR 用于指示某项任务已完成多少的对象。
static AccessibleRole | AccessibleRole.PROGRESS_MONITOR 该职责表示监视某个操作进度的对象。
static AccessibleRole | AccessibleRole.PUSH_BUTTON 用户可以操作以通知应用程序执行某任务的对象。
static AccessibleRole | AccessibleRole.RADIO_BUTTON 一个专用复选框，当选中此复选框时，将导致取消选中同一组中的其他单选按钮。
static AccessibleRole | AccessibleRole.ROOT_PANE 一个专用窗格，带有玻璃窗格和作为其子窗格的分层窗格。
static AccessibleRole | AccessibleRole.ROW_HEADER 数据行的头。
static AccessibleRole | AccessibleRole.RULER RULER 是用于测量距离的对象
static AccessibleRole | AccessibleRole.SCROLL_BAR 通常用于允许用户逐渐查看大量数据的对象。
static AccessibleRole | AccessibleRole.SCROLL_PANE 允许用户逐渐查看大量信息的对象。
static AccessibleRole | AccessibleRole.SEPARATOR 通常包含在菜单中的对象，它对菜单中的内容进行可视和逻辑分离。
static AccessibleRole | AccessibleRole.SLIDER 允许用户在有限范围内进行选择的对象。
static AccessibleRole | AccessibleRole.SPIN_BOX SPIN_BOX 是简单的微调器组件，它主要用于简单数字。
static AccessibleRole | AccessibleRole.SPLIT_PANE 同时呈现两个其他窗格的专用窗格。
static AccessibleRole | AccessibleRole.STATUS_BAR STATUS_BAR 是可以包含多个用户状态信息标签的简单组件。
static AccessibleRole | AccessibleRole.SWING_COMPONENT 一个 Swing 组件，但关于它的其他信息都是未知的。
static AccessibleRole | AccessibleRole.TABLE 用于根据行和列来呈现信息的对象。
static AccessibleRole | AccessibleRole.TEXT 将文本呈现给用户的对象。
static AccessibleRole | AccessibleRole.TOGGLE_BUTTON 可以被选中或不被选中的专用按钮，但不针对当前状态提供单独的指示符。
static AccessibleRole | AccessibleRole.TOOL_BAR 通常由普通按钮或切换按钮组成的工具栏或调色板。
static AccessibleRole | AccessibleRole.TOOL_TIP 提供关于另一个对象信息的对象。
static AccessibleRole | AccessibleRole.TREE 用于将层次结构信息呈现给用户的对象。
static AccessibleRole | AccessibleRole.UNKNOWN 该对象包含某些 Accessible 信息，但其职责是未知的。
static AccessibleRole | AccessibleRole.VIEWPORT 通常在滚动窗格中使用的对象。
static AccessibleRole | AccessibleRole.WINDOW 不带标题或边框的顶层窗口。

返回 AccessibleRole 的 javax.accessibility 中的方法
abstract  AccessibleRole AccessibleContext.getAccessibleRole()
获取此对象的职责。

javax.swing 中 AccessibleRole 的使用

返回 AccessibleRole 的 javax.swing 中的方法
AccessibleRole | JColorChooser.AccessibleJColorChooser.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JDesktopPane.AccessibleJDesktopPane.getAccessibleRole() 获取此对象的功能。
AccessibleRole | JFileChooser.AccessibleJFileChooser.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JOptionPane.AccessibleJOptionPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JPasswordField.AccessibleJPasswordField.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JSpinner.AccessibleJSpinner.getAccessibleRole() 获取此对象的职责。
AccessibleRole | ProgressMonitor.AccessibleProgressMonitor.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JSlider.AccessibleJSlider.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JToolTip.AccessibleJToolTip.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JTree.AccessibleJTree.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JTable.AccessibleJTable.getAccessibleRole() 获取此对象的功能。
AccessibleRole | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleRole() 获取此对象的功能。
AccessibleRole | JProgressBar.AccessibleJProgressBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JCheckBox.AccessibleJCheckBox.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JTabbedPane.AccessibleJTabbedPane.getAccessibleRole() 获取此对象的功能。
AccessibleRole | JRadioButton.AccessibleJRadioButton.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JViewport.AccessibleJViewport.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JScrollPane.AccessibleJScrollPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JList.AccessibleJList.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JList.AccessibleJList.AccessibleJListChild.getAccessibleRole()
AccessibleRole | CellRendererPane.AccessibleCellRendererPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JScrollBar.AccessibleJScrollBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JComboBox.AccessibleJComboBox.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JSeparator.AccessibleJSeparator.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JPopupMenu.AccessibleJPopupMenu.getAccessibleRole() 获得此对象的职责。
AccessibleRole | JMenuBar.AccessibleJMenuBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Box.Filler.AccessibleBoxFiller.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Box.AccessibleBox.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JToggleButton.AccessibleJToggleButton.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JSplitPane.AccessibleJSplitPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JToolBar.AccessibleJToolBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | ImageIcon.AccessibleImageIcon.getAccessibleRole() 获得此对象的职责。
AccessibleRole | JButton.AccessibleJButton.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JMenu.AccessibleJMenu.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JMenuItem.AccessibleJMenuItem.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JInternalFrame.AccessibleJInternalFrame.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JLayeredPane.AccessibleJLayeredPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JPanel.AccessibleJPanel.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JRootPane.AccessibleJRootPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JLabel.AccessibleJLabel.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JComponent.AccessibleJComponent.getAccessibleRole() 获取此对象的功能。

javax.swing.table 中 AccessibleRole 的使用

返回 AccessibleRole 的 javax.swing.table 中的方法
AccessibleRole | JTableHeader.AccessibleJTableHeader.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleRole()

javax.swing.text 中 AccessibleRole 的使用

返回 AccessibleRole 的 javax.swing.text 中的方法
 AccessibleRole JTextComponent.AccessibleJTextComponent.getAccessibleRole()
获取此对象的职责。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleSelection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleSelection
的使用

使用 AccessibleSelection 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

java.awt 中 AccessibleSelection 的使用

实现 AccessibleSelection 的 java.awt 中的类
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuBar.AccessibleAWTMenuBar 菜单栏的内部类，用于为可访问性提供默认支持。
protected class | MenuComponent.AccessibleAWTMenuComponent 用于为可访问性提供默认支持的 MenuComponent 的内部类。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。

返回 AccessibleSelection 的 java.awt 中的方法
AccessibleSelection | List.AccessibleAWTList.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
AccessibleSelection | MenuComponent.AccessibleAWTMenuComponent.getAccessibleSelection() 获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子对象。

javax.accessibility 中 AccessibleSelection 的使用

返回 AccessibleSelection 的 javax.accessibility 中的方法
 AccessibleSelection AccessibleContext.getAccessibleSelection()
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。

javax.swing 中 AccessibleSelection 的使用

实现 AccessibleSelection 的 javax.swing 中的类
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JTree.AccessibleJTree.AccessibleJTreeNode 此类实现 JTree 子类的可访问性支持。

返回 AccessibleSelection 的 javax.swing 中的方法
AccessibleSelection | JTree.AccessibleJTree.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
AccessibleSelection | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleSelection() 获取与此对象关联的 AccessibleSelection（如果存在）。
AccessibleSelection | JTable.AccessibleJTable.getAccessibleSelection() 获取与此对象关联的 AccessibleSelection。
AccessibleSelection | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleSelection() 获取与此对象关联的 AccessibleSelection（如果存在）。
AccessibleSelection | JTabbedPane.AccessibleJTabbedPane.getAccessibleSelection() 获取与此对象关联的 AccessibleSelection。
AccessibleSelection | JList.AccessibleJList.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
AccessibleSelection | JList.AccessibleJList.AccessibleJListChild.getAccessibleSelection()
AccessibleSelection | JComboBox.AccessibleJComboBox.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
AccessibleSelection | JMenuBar.AccessibleJMenuBar.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
AccessibleSelection | JMenu.AccessibleJMenu.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。

javax.swing.table 中 AccessibleSelection 的使用

返回 AccessibleSelection 的 javax.swing.table 中的方法
 AccessibleSelection JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleSelection()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleState 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleState
的使用

使用 AccessibleState 的软件包
javax.accessibility 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.accessibility 中 AccessibleState 的使用

声明为 AccessibleState 的 javax.accessibility 中的字段
static AccessibleState | AccessibleState.ACTIVE 指示某个窗口当前是活动窗口。
static AccessibleState | AccessibleState.ARMED 指示选中了此对象。
static AccessibleState | AccessibleState.BUSY 指示当前对象忙。
static AccessibleState | AccessibleState.CHECKED 指示此对象当前被选中。
static AccessibleState | AccessibleState.COLLAPSED 指示此对象是折叠的。
static AccessibleState | AccessibleState.EDITABLE 指示用户可以更改此对象的内容。
static AccessibleState | AccessibleState.ENABLED 指示此对象是启用的。
static AccessibleState | AccessibleState.EXPANDABLE 指示此对象允许逐步显示其子级。
static AccessibleState | AccessibleState.EXPANDED 指示此对象是展开的。
static AccessibleState | AccessibleState.FOCUSABLE 指示此对象可以接受键盘焦点，这意味着当它具有焦点时，由键盘上的键入操作所产生的所有事件将被传递到此对象。
static AccessibleState | AccessibleState.FOCUSED 指示此对象当前具有键盘焦点。
static AccessibleState | AccessibleState.HORIZONTAL 指示此对象的方向为水平方向。
static AccessibleState | AccessibleState.ICONIFIED 指示此对象是最小化的，并只通过一个图标来表示。
static AccessibleState | AccessibleState.INDETERMINATE 指示对象状态是不确定的。
static AccessibleState | AccessibleState.MANAGES_DESCENDANTS 指示此对象负责管理其子组件。
static AccessibleState | AccessibleState.MODAL 指示在用户可以与不同窗口中的某个对象交互之前，必须对此对象采取某些操作。
static AccessibleState | AccessibleState.MULTI_LINE 指示此（文本）对象可以包含多行文本
static AccessibleState | AccessibleState.MULTISELECTABLE 指示此对象允许同时选定多个子级。
static AccessibleState | AccessibleState.OPAQUE 指示此对象在其矩形区域内绘制每个像素。
static AccessibleState | AccessibleState.PRESSED 指示此对象当前是按下的。
static AccessibleState | AccessibleState.RESIZABLE 指示此对象的大小不固定。
static AccessibleState | AccessibleState.SELECTABLE 指示此对象是某个允许选择子级的对象的子对象，并且此子对象就是这些可以被选择的子对象之一。
static AccessibleState | AccessibleState.SELECTED 指示此对象是某个允许选择子级的对象的子对象，且此子对象是已被选定的子对象之一。
static AccessibleState | AccessibleState.SHOWING 指示此对象、此对象的父对象、其父对象的父对象等都是可见的。
static AccessibleState | AccessibleState.SINGLE_LINE 指示此（文本）对象只能包含单行文本
static AccessibleState | AccessibleState.TRANSIENT 指示此对象是临时的。
static AccessibleState | AccessibleState.TRUNCATED 该状态指示文本被边界矩形截取，并且有些文本不显示在屏幕上。
static AccessibleState | AccessibleState.VERTICAL 指示此对象的方向为垂直方向。
static AccessibleState | AccessibleState.VISIBLE 指示此对象是可见的。

类型参数类型为 AccessibleState 的 javax.accessibility 中的字段
protected  Vector<AccessibleState> AccessibleStateSet.states
Vector 中的每个项表示一个 AccessibleState。

返回 AccessibleState 的 javax.accessibility 中的方法
 AccessibleState[] AccessibleStateSet.toArray()
以 AccessibleState 数组形式返回当前状态集

参数类型为 AccessibleState 的 javax.accessibility 中的方法
boolean | AccessibleStateSet.add(AccessibleState state) 如果某个新状态不在当前状态集中，则将它添加到当前状态集中。
void | AccessibleStateSet.addAll(AccessibleState[] states) 将所有状态添加到现有状态集中。
boolean | AccessibleStateSet.contains(AccessibleState state) 检查当前状态是否在状态集中。
boolean | AccessibleStateSet.remove(AccessibleState state) 从当前状态集中移除一个状态。

参数类型为 AccessibleState 的 javax.accessibility 中的构造方法
AccessibleStateSet(AccessibleState[] states)
创建一个新状态，其初始状态集包含在传入的状态数组中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleStateSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleStateSet
的使用

使用 AccessibleStateSet 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 java.applet 中的方法
 AccessibleStateSet Applet.AccessibleApplet.getAccessibleStateSet()
获得此对象的状态。

java.awt 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 java.awt 中的方法
AccessibleStateSet | Checkbox.AccessibleAWTCheckbox.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | List.AccessibleAWTList.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | Scrollbar.AccessibleAWTScrollBar.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | TextArea.AccessibleAWTTextArea.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | TextComponent.AccessibleAWTTextComponent.getAccessibleStateSet() 获取 TextComponent 的状态设置。
AccessibleStateSet | TextField.AccessibleAWTTextField.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | MenuComponent.AccessibleAWTMenuComponent.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | Dialog.AccessibleAWTDialog.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | Frame.AccessibleAWTFrame.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | Window.AccessibleAWTWindow.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | Component.AccessibleAWTComponent.getAccessibleStateSet() 获取此对象的状态。

javax.accessibility 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 javax.accessibility 中的方法
abstract  AccessibleStateSet AccessibleContext.getAccessibleStateSet()
获取此对象的状态集合。

javax.swing 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 javax.swing 中的方法
AccessibleStateSet | JEditorPane.AccessibleJEditorPane.getAccessibleStateSet() 获取此对象的状态集。
AccessibleStateSet | ProgressMonitor.AccessibleProgressMonitor.getAccessibleStateSet() 获取此对象的状态集。
AccessibleStateSet | JSlider.AccessibleJSlider.getAccessibleStateSet() 获取此对象的状态集。
AccessibleStateSet | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JProgressBar.AccessibleJProgressBar.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JTextArea.AccessibleJTextArea.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JTextField.AccessibleJTextField.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JList.AccessibleJList.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JList.AccessibleJList.AccessibleJListChild.getAccessibleStateSet()
AccessibleStateSet | JScrollBar.AccessibleJScrollBar.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JComboBox.AccessibleJComboBox.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JMenuBar.AccessibleJMenuBar.getAccessibleStateSet() 获得此对象的可访问性状态设置。
AccessibleStateSet | JSplitPane.AccessibleJSplitPane.getAccessibleStateSet() 获取此对象的状态集。
AccessibleStateSet | JToolBar.AccessibleJToolBar.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | JDialog.AccessibleJDialog.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | ImageIcon.AccessibleImageIcon.getAccessibleStateSet() 获得此对象的状态。
AccessibleStateSet | AbstractButton.AccessibleAbstractButton.getAccessibleStateSet() 获得此对象的状态设置。
AccessibleStateSet | JComponent.AccessibleJComponent.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | JFrame.AccessibleJFrame.getAccessibleStateSet() 获得此对象的状态。
static AccessibleStateSet | SwingUtilities.getAccessibleStateSet(Component c) 获取此对象的状态。

javax.swing.table 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 javax.swing.table 中的方法
 AccessibleStateSet JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleStateSet()

javax.swing.text 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 javax.swing.text 中的方法
 AccessibleStateSet JTextComponent.AccessibleJTextComponent.getAccessibleStateSet()
获取 JTextComponent 的状态设置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleStreamable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleStreamable
的使用

没有 javax.accessibility.AccessibleStreamable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleTable
的使用

使用 AccessibleTable 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 AccessibleTable 的使用

javax.accessibility 中 AccessibleTable 的子接口
 interface AccessibleExtendedTable
AccessibleExtendedTable 类提供了有关以二维表的格式呈现数据的用户界面组件的扩展信息。

返回 AccessibleTable 的 javax.accessibility 中的方法
AccessibleTable | AccessibleTable.getAccessibleColumnHeader() 返回以 AccessibleTable 表示的列标题。
AccessibleTable | AccessibleTable.getAccessibleRowHeader() 返回以 AccessibleTable 表示的行标题。
AccessibleTable | AccessibleContext.getAccessibleTable() 获取与某个对象关联的 AccessibleTable

参数类型为 AccessibleTable 的 javax.accessibility 中的方法
void | AccessibleTable.setAccessibleColumnHeader(AccessibleTable table) 设置列标题。
void | AccessibleTable.setAccessibleRowHeader(AccessibleTable table) 设置行标题。

javax.swing 中 AccessibleTable 的使用

实现 AccessibleTable 的 javax.swing 中的类
protected  class JTable.AccessibleJTable
此类实现对 JTable 类的可访问性支持。

返回 AccessibleTable 的 javax.swing 中的方法
AccessibleTable | JTable.AccessibleJTable.getAccessibleColumnHeader() 返回以 AccessibleTable 表示的列标题。
AccessibleTable | JTable.AccessibleJTable.getAccessibleRowHeader() 返回以 AccessibleTable 表示的行标题。
AccessibleTable | JTable.AccessibleJTable.getAccessibleTable() 获取与此对象关联的 AccessibleTable。

参数类型为 AccessibleTable 的 javax.swing 中的方法
void | JTable.AccessibleJTable.setAccessibleColumnHeader(AccessibleTable a) 设置以 AccessibleTable 表示的列标题。
void | JTable.AccessibleJTable.setAccessibleRowHeader(AccessibleTable a) 设置以 AccessibleTable 表示的列标题。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleTableModelChange 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleTableModelChange
的使用

使用 AccessibleTableModelChange 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AccessibleTableModelChange 的使用

实现 AccessibleTableModelChange 的 javax.swing 中的类
protected  class JTable.AccessibleJTable.AccessibleJTableModelChange

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleText 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleText
的使用

使用 AccessibleText 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 AccessibleText 的使用

实现 AccessibleText 的 java.awt 中的类
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。

返回 AccessibleText 的 java.awt 中的方法
 AccessibleText TextComponent.AccessibleAWTTextComponent.getAccessibleText()
获取与此对象相关的 AccessibleText。

javax.accessibility 中 AccessibleText 的使用

javax.accessibility 中 AccessibleText 的子接口
interface | AccessibleEditableText 在显示器上显示可编辑文本信息的所有类都应该实现 AccessibleEditableText 接口。
interface | AccessibleHypertext AccessibleHypertext 类是在显示器上显示超文本信息的所有类的基类。

返回 AccessibleText 的 javax.accessibility 中的方法
 AccessibleText AccessibleContext.getAccessibleText()
获取与在显示器上显示文本的此对象关联的 AccessibleText。

javax.swing 中 AccessibleText 的使用

实现 AccessibleText 的 javax.swing 中的类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | ProgressMonitor.AccessibleProgressMonitor AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

返回 AccessibleText 的 javax.swing 中的方法
AccessibleText | JEditorPane.AccessibleJEditorPaneHTML.getAccessibleText()
AccessibleText | JPasswordField.AccessibleJPasswordField.getAccessibleText() 获取 JPasswordField 的 AccessibleText。
AccessibleText | JSpinner.AccessibleJSpinner.getAccessibleText() 获取与此对象相关联的可在显示器上表示的 AccessibleText。
AccessibleText | ProgressMonitor.AccessibleProgressMonitor.getAccessibleText() 获取与在显示器上显示文本的此对象关联的 AccessibleText。
AccessibleText | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleText() 获取与此对象关联的 AccessibleText（如果存在）。
AccessibleText | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleText() 获取与此对象关联的 AccessibleText （如果存在）。
AccessibleText | JList.AccessibleJList.AccessibleJListChild.getAccessibleText()
AccessibleText | AbstractButton.AccessibleAbstractButton.getAccessibleText()
AccessibleText | JLabel.AccessibleJLabel.getAccessibleText()

javax.swing.table 中 AccessibleText 的使用

返回 AccessibleText 的 javax.swing.table 中的方法
 AccessibleText JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleText()

javax.swing.text 中 AccessibleText 的使用

实现 AccessibleText 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 AccessibleText 的 javax.swing.text 中的方法
 AccessibleText JTextComponent.AccessibleJTextComponent.getAccessibleText()
获取与此对象关联的 AccessibleText。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.accessibility.AccessibleTextSequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleTextSequence
的使用

使用 AccessibleTextSequence 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.accessibility 中 AccessibleTextSequence 的使用

返回 AccessibleTextSequence 的 javax.accessibility 中的方法
AccessibleTextSequence | AccessibleExtendedText.getTextSequenceAfter(int part, int index) 返回给定索引后面的 AccessibleTextSequence。
AccessibleTextSequence | AccessibleExtendedText.getTextSequenceAt(int part, int index) 返回给定索引处的 AccessibleTextSequence。
AccessibleTextSequence | AccessibleExtendedText.getTextSequenceBefore(int part, int index) 返回给定索引前面的 AccessibleTextSequence。

javax.swing 中 AccessibleTextSequence 的使用

返回 AccessibleTextSequence 的 javax.swing 中的方法
AccessibleTextSequence | JPasswordField.AccessibleJPasswordField.getTextSequenceAfter(int part, int index) 返回给定 index 之后的 AccessibleTextSequence。
AccessibleTextSequence | JPasswordField.AccessibleJPasswordField.getTextSequenceAt(int part, int index) 返回给定 index 处的 AccessibleTextSequence。
AccessibleTextSequence | JPasswordField.AccessibleJPasswordField.getTextSequenceBefore(int part, int index) 返回给定 index 之前的 AccessibleTextSequence。

javax.swing.text 中 AccessibleTextSequence 的使用

返回 AccessibleTextSequence 的 javax.swing.text 中的方法
AccessibleTextSequence | JTextComponent.AccessibleJTextComponent.getTextSequenceAfter(int part, int index) 返回给定 index 之后的 AccessibleTextSequence。
AccessibleTextSequence | JTextComponent.AccessibleJTextComponent.getTextSequenceAt(int part, int index) 返回给定 index 处的 AccessibleTextSequence。
AccessibleTextSequence | JTextComponent.AccessibleJTextComponent.getTextSequenceBefore(int part, int index) 返回给定 index 之前的 AccessibleTextSequence。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.accessibility.AccessibleValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleValue
的使用

使用 AccessibleValue 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

java.awt 中 AccessibleValue 的使用

实现 AccessibleValue 的 java.awt 中的类
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。
protected class | Scrollbar.AccessibleAWTScrollBar 此类实现 Scrollbar 类的可访问性支持。

返回 AccessibleValue 的 java.awt 中的方法
AccessibleValue | Button.AccessibleAWTButton.getAccessibleValue() 获取与此对象相关的 AccessibleValue。
AccessibleValue | Checkbox.AccessibleAWTCheckbox.getAccessibleValue() 获取与此对象相关的 AccessibleValue。
AccessibleValue | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleValue() 获取与此对象相关的 AccessibleValue。
AccessibleValue | Scrollbar.AccessibleAWTScrollBar.getAccessibleValue() 获得与此对象相关的 AccessibleValue。
AccessibleValue | MenuItem.AccessibleAWTMenuItem.getAccessibleValue() 获取与此对象关联的 AccessibleValue。

javax.accessibility 中 AccessibleValue 的使用

返回 AccessibleValue 的 javax.accessibility 中的方法
 AccessibleValue AccessibleContext.getAccessibleValue()
获取与此对象关联的支持 Numerical 值的 AccessibleValue。

javax.swing 中 AccessibleValue 的使用

实现 AccessibleValue 的 javax.swing 中的类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。

返回 AccessibleValue 的 javax.swing 中的方法
AccessibleValue | JSpinner.AccessibleJSpinner.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | ProgressMonitor.AccessibleProgressMonitor.getAccessibleValue() 获取与此对象关联的 AccessibleValue，该对象支持数值。
AccessibleValue | JSlider.AccessibleJSlider.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleValue() 获取与此对象关联的 AccessibleValue（如果存在）。
AccessibleValue | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleValue() 获取与此对象关联的 AccessibleValue（如果存在）。
AccessibleValue | JProgressBar.AccessibleJProgressBar.getAccessibleValue() 获得与此对象相关联的 AccessibleValue。
AccessibleValue | JList.AccessibleJList.AccessibleJListChild.getAccessibleValue()
AccessibleValue | JScrollBar.AccessibleJScrollBar.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | JSplitPane.AccessibleJSplitPane.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | AbstractButton.AccessibleAbstractButton.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | JInternalFrame.AccessibleJInternalFrame.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getAccessibleValue() 获取与此对象关联的 AccessibleValue。

javax.swing.table 中 AccessibleValue 的使用

返回 AccessibleValue 的 javax.swing.table 中的方法
 AccessibleValue JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleValue()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.activation (Java 2 Platform SE 6)

 javax.activation
接口
CommandObject
DataContentHandler
DataContentHandlerFactory
DataSource
类
ActivationDataFlavor
CommandInfo
CommandMap
DataHandler
FileDataSource
FileTypeMap
MailcapCommandMap
MimeType
MimeTypeParameterList
MimetypesFileTypeMap
URLDataSource
异常
MimeTypeParseException
UnsupportedDataTypeException


类 javax.activation.ActivationDataFlavor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.ActivationDataFlavor
的使用

没有 javax.activation.ActivationDataFlavor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.CommandInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.CommandInfo
的使用

使用 CommandInfo 的软件包
javax.activation

javax.activation 中 CommandInfo 的使用

返回 CommandInfo 的 javax.activation 中的方法
CommandInfo[] | DataHandler.getAllCommands() 返回此数据类型的所有命令。
abstract CommandInfo[] | CommandMap.getAllCommands(String mimeType) 获取此类型的所有可用命令。
CommandInfo[] | MailcapCommandMap.getAllCommands(String mimeType) 针对此 MIME 类型获取此 MailcapCommandMap 实例已知的所有 mailcap 文件中的所有可用命令。
CommandInfo[] | CommandMap.getAllCommands(String mimeType, DataSource ds) 获取此类型的所有可用命令。
CommandInfo | DataHandler.getCommand(String cmdName) 获取命令 cmdName。
abstract CommandInfo | CommandMap.getCommand(String mimeType, String cmdName) 获取与 MIME 类型对应的默认命令。
CommandInfo | MailcapCommandMap.getCommand(String mimeType, String cmdName) 针对 MIME 类型获取与 cmdName 对应的命令。
CommandInfo | CommandMap.getCommand(String mimeType, String cmdName, DataSource ds) 获取与 MIME 类型对应的默认命令。
CommandInfo[] | DataHandler.getPreferredCommands() 返回此数据类型的首选 命令。
abstract CommandInfo[] | CommandMap.getPreferredCommands(String mimeType) 从 MIME 类型获取首选命令表。
CommandInfo[] | MailcapCommandMap.getPreferredCommands(String mimeType) 获取 MIME 类型的首选命令列表。
CommandInfo[] | CommandMap.getPreferredCommands(String mimeType, DataSource ds) 从 MIME 类型获取首选命令表。

参数类型为 CommandInfo 的 javax.activation 中的方法
 Object DataHandler.getBean(CommandInfo cmdinfo)
一个便捷方法，它接受 CommandInfo 对象并且实例化相应的命令，通常是 JavaBean 组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.CommandMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.CommandMap
的使用

使用 CommandMap 的软件包
javax.activation

javax.activation 中 CommandMap 的使用

javax.activation 中 CommandMap 的子类
 class MailcapCommandMap
MailcapCommandMap 扩展 CommandMap 抽象类。

返回 CommandMap 的 javax.activation 中的方法
static CommandMap CommandMap.getDefaultCommandMap()
获取默认的 CommandMap。

参数类型为 CommandMap 的 javax.activation 中的方法
void | DataHandler.setCommandMap(CommandMap commandMap) 设置此 DataHandler 使用的 CommandMap。
static void | CommandMap.setDefaultCommandMap(CommandMap commandMap) 设置默认的 CommandMap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.activation.CommandObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.activation.CommandObject
的使用

没有 javax.activation.CommandObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.activation.DataContentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.activation.DataContentHandler
的使用

使用 DataContentHandler 的软件包
javax.activation

javax.activation 中 DataContentHandler 的使用

返回 DataContentHandler 的 javax.activation 中的方法
abstract DataContentHandler | CommandMap.createDataContentHandler(String mimeType) 查找与 MIME 类型对应的 DataContentHandler。
DataContentHandler | DataContentHandlerFactory.createDataContentHandler(String mimeType) 针对 MIME 类型创建一个新的 DataContentHandler 对象。
DataContentHandler | MailcapCommandMap.createDataContentHandler(String mimeType) 返回指定 MIME 类型的 DataContentHandler。
DataContentHandler | CommandMap.createDataContentHandler(String mimeType, DataSource ds) 查找与 MIME 类型对应的 DataContentHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.activation.DataContentHandlerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.activation.DataContentHandlerFactory
的使用

使用 DataContentHandlerFactory 的软件包
javax.activation

javax.activation 中 DataContentHandlerFactory 的使用

参数类型为 DataContentHandlerFactory 的 javax.activation 中的方法
static void DataHandler.setDataContentHandlerFactory(DataContentHandlerFactory newFactory)
设置 DataContentHandlerFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.DataHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.DataHandler
的使用

使用 DataHandler 的软件包
javax.activation |
javax.xml.bind.attachment | 此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。

javax.activation 中 DataHandler 的使用

参数类型为 DataHandler 的 javax.activation 中的方法
Object | CommandInfo.getCommandObject(DataHandler dh, ClassLoader loader) 返回已实例化的 JavaBean 组件。
void | CommandObject.setCommandContext(String verb, DataHandler dh) 用请求处理的动词和描述将要操作的数据的 DataHandler 来初始化 Command。

javax.xml.bind.attachment 中 DataHandler 的使用

返回 DataHandler 的 javax.xml.bind.attachment 中的方法
abstract  DataHandler AttachmentUnmarshaller.getAttachmentAsDataHandler(String cid)
通过内容 id（即 cid）查找 MIME 内容，并作为 DataHandler 返回。

参数类型为 DataHandler 的 javax.xml.bind.attachment 中的方法
abstract String | AttachmentMarshaller.addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName) 将用于优化二进制存储的 MIME 内容 data 作为附件。
abstract String | AttachmentMarshaller.addSwaRefAttachment(DataHandler data) 将 MIME data 作为附件添加，并返回附件的内容 id（即 cid）。

javax.xml.soap 中 DataHandler 的使用

返回 DataHandler 的 javax.xml.soap 中的方法
abstract  DataHandler AttachmentPart.getDataHandler()
获取针对此 AttachmentPart 对象的 DataHandler 对象。

参数类型为 DataHandler 的 javax.xml.soap 中的方法
AttachmentPart | SOAPMessage.createAttachmentPart(DataHandler dataHandler) 创建 AttachmentPart 对象并使用给定的 DataHandler 对象填充。
abstract void | AttachmentPart.setDataHandler(DataHandler dataHandler) 将给定的 DataHandler 对象设置为此 AttachmentPart 对象的数据处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.activation.DataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.activation.DataSource
的使用

使用 DataSource 的软件包
javax.activation

javax.activation 中 DataSource 的使用

实现 DataSource 的 javax.activation 中的类
class | FileDataSource FileDataSource 类实现一个封装文件的简单 DataSource 对象。
class | URLDataSource URLDataSource 类提供一个对象，此对象将 URL 对象包装在 DataSource 接口中。

返回 DataSource 的 javax.activation 中的方法
 DataSource DataHandler.getDataSource()
返回与此 DataHandler 实例关联的 DataSource。

参数类型为 DataSource 的 javax.activation 中的方法
DataContentHandler | CommandMap.createDataContentHandler(String mimeType, DataSource ds) 查找与 MIME 类型对应的 DataContentHandler。
CommandInfo[] | CommandMap.getAllCommands(String mimeType, DataSource ds) 获取此类型的所有可用命令。
CommandInfo | CommandMap.getCommand(String mimeType, String cmdName, DataSource ds) 获取与 MIME 类型对应的默认命令。
Object | DataContentHandler.getContent(DataSource ds) 返回一个对象，该对象表示其首选形式的数据。
CommandInfo[] | CommandMap.getPreferredCommands(String mimeType, DataSource ds) 从 MIME 类型获取首选命令表。
Object | DataContentHandler.getTransferData(DataFlavor df, DataSource ds) 返回一个对象，该对象表示将要传输的数据。

参数类型为 DataSource 的 javax.activation 中的构造方法
DataHandler(DataSource ds)
创建引用指定 DataSource 的 DataHandler 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.FileDataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.FileDataSource
的使用

没有 javax.activation.FileDataSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.FileTypeMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.FileTypeMap
的使用

使用 FileTypeMap 的软件包
javax.activation

javax.activation 中 FileTypeMap 的使用

javax.activation 中 FileTypeMap 的子类
 class MimetypesFileTypeMap
此类扩展 FileTypeMap 并通过其文件扩展名提供文件的数据分类。

返回 FileTypeMap 的 javax.activation 中的方法
static FileTypeMap FileTypeMap.getDefaultFileTypeMap()
返回系统的默认 FileTypeMap。

参数类型为 FileTypeMap 的 javax.activation 中的方法
static void | FileTypeMap.setDefaultFileTypeMap(FileTypeMap map) 设置系统的默认 FileTypeMap。
void | FileDataSource.setFileTypeMap(FileTypeMap map) 设置用于此 FileDataSource 的 FileTypeMap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.MailcapCommandMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.MailcapCommandMap
的使用

没有 javax.activation.MailcapCommandMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.MimeType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.MimeType
的使用

使用 MimeType 的软件包
javax.activation

javax.activation 中 MimeType 的使用

参数类型为 MimeType 的 javax.activation 中的方法
 boolean MimeType.match(MimeType type)
确定此对象的基本类型和子类型与给定类型中的类型是否相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.MimeTypeParameterList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.MimeTypeParameterList
的使用

使用 MimeTypeParameterList 的软件包
javax.activation

javax.activation 中 MimeTypeParameterList 的使用

返回 MimeTypeParameterList 的 javax.activation 中的方法
 MimeTypeParameterList MimeType.getParameters()
获取此对象的参数列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.MimeTypeParseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.MimeTypeParseException
的使用

使用 MimeTypeParseException 的软件包
javax.activation

javax.activation 中 MimeTypeParseException 的使用

抛出 MimeTypeParseException 的 javax.activation 中的方法
boolean | MimeType.match(String rawdata) 确定此对象的基本类型和子类型与 rawdata 中描述的内容类型是否相同。
protected void | MimeTypeParameterList.parse(String parameterList) 将参数列表从一个 String 解析出来的例程。
void | MimeType.setPrimaryType(String primary) 将此对象的基本类型设置为给定的 String。
void | MimeType.setSubType(String sub) 将此对象的子类型设置为给定的 String。

抛出 MimeTypeParseException 的 javax.activation 中的构造方法
MimeType(String rawdata)
根据 String 构建 MimeType 的构造方法。
MimeType(String primary, String sub)
用给定的基本类型和子类型构建 MimeType 的构造方法，它的参数列表为空。
MimeTypeParameterList(String parameterList)
用传入的数据构造新的 MimeTypeParameterList。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.MimetypesFileTypeMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.MimetypesFileTypeMap
的使用

没有 javax.activation.MimetypesFileTypeMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.UnsupportedDataTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.UnsupportedDataTypeException
的使用

没有 javax.activation.UnsupportedDataTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activation.URLDataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.URLDataSource
的使用

没有 javax.activation.URLDataSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.activity (Java 2 Platform SE 6)

 javax.activity
异常
ActivityCompletedException
ActivityRequiredException
InvalidActivityException


类 javax.activity.ActivityCompletedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activity.ActivityCompletedException
的使用

没有 javax.activity.ActivityCompletedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activity.ActivityRequiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activity.ActivityRequiredException
的使用

没有 javax.activity.ActivityRequiredException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.activity.InvalidActivityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activity.InvalidActivityException
的使用

没有 javax.activity.InvalidActivityException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.annotation (Java 2 Platform SE 6)

 javax.annotation
枚举
Resource.AuthenticationType
注释类型
Generated
PostConstruct
PreDestroy
Resource
Resources


Resource.AuthenticationType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.annotation
枚举 Resource.AuthenticationType

java.lang.Object
    继承者  java.lang.Enum<Resource.AuthenticationType>
        继承者  javax.annotation.Resource.AuthenticationType
所有已实现的接口：
Serializable, Comparable<Resource.AuthenticationType>
正在封闭类：
Resource
public static enum Resource.AuthenticationType
extends Enum<Resource.AuthenticationType>

资源的两种可能验证类型。

枚举常量摘要
APPLICATION
CONTAINER
方法摘要
static Resource.AuthenticationType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Resource.AuthenticationType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

CONTAINER

public static final Resource.AuthenticationType CONTAINER

APPLICATION

public static final Resource.AuthenticationType APPLICATION
方法详细信息

values

public static final Resource.AuthenticationType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Resource.AuthenticationType c : Resource.AuthenticationType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Resource.AuthenticationType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


类 javax.annotation.Generated 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.Generated
的使用

没有 javax.annotation.Generated 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.annotation.PostConstruct 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.PostConstruct
的使用

没有 javax.annotation.PostConstruct 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.annotation.PreDestroy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.PreDestroy
的使用

没有 javax.annotation.PreDestroy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.annotation.Resource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.Resource
的使用

没有 javax.annotation.Resource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.annotation.Resource.AuthenticationType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.Resource.AuthenticationType
的使用

使用 Resource.AuthenticationType 的软件包
javax.annotation

javax.annotation 中 Resource.AuthenticationType 的使用

返回 Resource.AuthenticationType 的 javax.annotation 中的方法
static Resource.AuthenticationType | Resource.AuthenticationType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Resource.AuthenticationType[] | Resource.AuthenticationType.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.annotation.Resources 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.Resources
的使用

没有 javax.annotation.Resources 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.annotation.processing (Java 2 Platform SE 6)

 javax.annotation.processing
接口
Completion
Filer
Messager
ProcessingEnvironment
Processor
RoundEnvironment
类
AbstractProcessor
Completions
异常
FilerException
注释类型
SupportedAnnotationTypes
SupportedOptions
SupportedSourceVersion


类 javax.annotation.processing.AbstractProcessor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.AbstractProcessor
的使用

没有 javax.annotation.processing.AbstractProcessor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.annotation.processing.Completion 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.Completion
的使用

使用 Completion 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 Completion 的使用

返回 Completion 的 javax.annotation.processing 中的方法
static Completion | Completions.of(String value) 返回值和空消息的 completion。
static Completion | Completions.of(String value, String message) 返回值和消息的 completion。

返回变量类型为 Completion 的类型的 javax.annotation.processing 中的方法
Iterable<? extends Completion> | AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Iterable<? extends Completion> | Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.annotation.processing.Completions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.Completions
的使用

没有 javax.annotation.processing.Completions 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.annotation.processing.Filer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.Filer
的使用

使用 Filer 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 Filer 的使用

返回 Filer 的 javax.annotation.processing 中的方法
 Filer ProcessingEnvironment.getFiler()
返回用来创建新源、类或辅助文件的 Filer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.annotation.processing.FilerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.FilerException
的使用

没有 javax.annotation.processing.FilerException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.annotation.processing.Messager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.Messager
的使用

使用 Messager 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 Messager 的使用

返回 Messager 的 javax.annotation.processing 中的方法
 Messager ProcessingEnvironment.getMessager()
返回用来报告错误、警报和其他通知的 Messager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.annotation.processing.ProcessingEnvironment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.ProcessingEnvironment
的使用

使用 ProcessingEnvironment 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 ProcessingEnvironment 的使用

声明为 ProcessingEnvironment 的 javax.annotation.processing 中的字段
protected  ProcessingEnvironment AbstractProcessor.processingEnv
工具框架提供的处理环境。

参数类型为 ProcessingEnvironment 的 javax.annotation.processing 中的方法
void | AbstractProcessor.init(ProcessingEnvironment processingEnv) 用处理环境初始化 processor，方法是将 processingEnv 字段设置为 processingEnv 参数的值。
void | Processor.init(ProcessingEnvironment processingEnv) 用处理环境初始化 Processor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.annotation.processing.Processor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.Processor
的使用

使用 Processor 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 Processor 的使用

实现 Processor 的 javax.annotation.processing 中的类
 class AbstractProcessor
旨在用作最具体注释 processor 的便捷超类的抽象注释 processor。

javax.tools 中 Processor 的使用

类型变量类型为 Processor 的 javax.tools 中的方法参数
 void JavaCompiler.CompilationTask.setProcessors(Iterable<? extends Processor> processors)
设置处理器（用于注释处理）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.annotation.processing.RoundEnvironment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.RoundEnvironment
的使用

使用 RoundEnvironment 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 RoundEnvironment 的使用

参数类型为 RoundEnvironment 的 javax.annotation.processing 中的方法
abstract boolean | AbstractProcessor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
boolean | Processor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.annotation.processing.SupportedAnnotationTypes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.SupportedAnnotationTypes
的使用

没有 javax.annotation.processing.SupportedAnnotationTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.annotation.processing.SupportedOptions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.SupportedOptions
的使用

没有 javax.annotation.processing.SupportedOptions 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.annotation.processing.SupportedSourceVersion 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.SupportedSourceVersion
的使用

使用 SupportedSourceVersion 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 SupportedSourceVersion 的使用

注释类型为 SupportedSourceVersion 的 javax.lang.model.util 中的类
class | AbstractAnnotationValueVisitor6<R,P> 注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | AbstractElementVisitor6<R,P> 程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | ElementKindVisitor6<R,P> 基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | ElementScanner6<R,P> 程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleAnnotationValueVisitor6<R,P> 注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleElementVisitor6<R,P> 程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleTypeVisitor6<R,P> 类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | TypeKindVisitor6<R,P> 基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.crypto (Java 2 Platform SE 6)

 javax.crypto
接口
SecretKey
类
Cipher
CipherInputStream
CipherOutputStream
CipherSpi
EncryptedPrivateKeyInfo
ExemptionMechanism
ExemptionMechanismSpi
KeyAgreement
KeyAgreementSpi
KeyGenerator
KeyGeneratorSpi
Mac
MacSpi
NullCipher
SealedObject
SecretKeyFactory
SecretKeyFactorySpi
异常
BadPaddingException
ExemptionMechanismException
IllegalBlockSizeException
NoSuchPaddingException
ShortBufferException


类 javax.crypto.BadPaddingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.BadPaddingException
的使用

使用 BadPaddingException 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 BadPaddingException 的使用

抛出 BadPaddingException 的 javax.crypto 中的方法
byte[] | Cipher.doFinal() 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
byte[] | Cipher.doFinal(byte[] input) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] output, int outputOffset) 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
byte[] | Cipher.doFinal(byte[] input, int inputOffset, int inputLen) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract byte[] | CipherSpi.engineDoFinal(byte[] input, int inputOffset, int inputLen) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract int | CipherSpi.engineDoFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected int | CipherSpi.engineDoFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
Object | SealedObject.getObject(Cipher c) 获取原始（封装的）对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.Cipher 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.Cipher
的使用

使用 Cipher 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 Cipher 的使用

javax.crypto 中 Cipher 的子类
 class NullCipher
NullCipher 类是一个提供“标识密码”的类，其不转换纯文本。

返回 Cipher 的 javax.crypto 中的方法
static Cipher | Cipher.getInstance(String transformation) 返回实现指定转换的 Cipher 对象。
static Cipher | Cipher.getInstance(String transformation, Provider provider) 返回实现指定转换的 Cipher 对象。
static Cipher | Cipher.getInstance(String transformation, String provider) 返回实现指定转换的 Cipher 对象。

参数类型为 Cipher 的 javax.crypto 中的方法
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Cipher cipher) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
Object | SealedObject.getObject(Cipher c) 获取原始（封装的）对象。

参数类型为 Cipher 的 javax.crypto 中的构造方法
CipherInputStream(InputStream is, Cipher c)
根据 InputStream 和 Cipher 构造 CipherInputStream。
CipherOutputStream(OutputStream os, Cipher c)
从 OutputStream 和 Cipher 构造 CipherOutputStream。
SealedObject(Serializable object, Cipher c)
从任何 Serializable 对象构造一个 SealedObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.CipherInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.CipherInputStream
的使用

没有 javax.crypto.CipherInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.CipherOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.CipherOutputStream
的使用

没有 javax.crypto.CipherOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.CipherSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.CipherSpi
的使用

使用 CipherSpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 CipherSpi 的使用

参数类型为 CipherSpi 的 javax.crypto 中的构造方法
Cipher(CipherSpi cipherSpi, Provider provider, String transformation)
创建 Cipher 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.EncryptedPrivateKeyInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.EncryptedPrivateKeyInfo
的使用

没有 javax.crypto.EncryptedPrivateKeyInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.ExemptionMechanism 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.ExemptionMechanism
的使用

使用 ExemptionMechanism 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 ExemptionMechanism 的使用

返回 ExemptionMechanism 的 javax.crypto 中的方法
ExemptionMechanism | Cipher.getExemptionMechanism() 返回此 Cipher 使用的豁免 (exemption) 机制对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, Provider provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, String provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.ExemptionMechanismException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.ExemptionMechanismException
的使用

使用 ExemptionMechanismException 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 ExemptionMechanismException 的使用

抛出 ExemptionMechanismException 的 javax.crypto 中的方法
protected abstract byte[] | ExemptionMechanismSpi.engineGenExemptionBlob() 生成豁免机制密钥 blob。
protected abstract int | ExemptionMechanismSpi.engineGenExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob 并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key) 用密钥初始化此豁免机制。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
byte[] | ExemptionMechanism.genExemptionBlob() 生成豁免机制密钥 blob。
int | ExemptionMechanism.genExemptionBlob(byte[] output) 生成豁免机制密钥 blob，并将结果存储在 output 缓冲区中。
int | ExemptionMechanism.genExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob，并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
void | ExemptionMechanism.init(Key key) 用密钥初始化此豁免机制。
void | ExemptionMechanism.init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | ExemptionMechanism.init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
boolean | ExemptionMechanism.isCryptoAllowed(Key key) 返回此豁免机制是否已成功生成结果 blob。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.ExemptionMechanismSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.ExemptionMechanismSpi
的使用

使用 ExemptionMechanismSpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 ExemptionMechanismSpi 的使用

参数类型为 ExemptionMechanismSpi 的 javax.crypto 中的构造方法
ExemptionMechanism(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)
创建 ExemptionMechanism 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.IllegalBlockSizeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.IllegalBlockSizeException
的使用

使用 IllegalBlockSizeException 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 IllegalBlockSizeException 的使用

抛出 IllegalBlockSizeException 的 javax.crypto 中的方法
byte[] | Cipher.doFinal() 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
byte[] | Cipher.doFinal(byte[] input) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] output, int outputOffset) 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
byte[] | Cipher.doFinal(byte[] input, int inputOffset, int inputLen) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract byte[] | CipherSpi.engineDoFinal(byte[] input, int inputOffset, int inputLen) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract int | CipherSpi.engineDoFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected int | CipherSpi.engineDoFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected byte[] | CipherSpi.engineWrap(Key key) 将密钥包装。
Object | SealedObject.getObject(Cipher c) 获取原始（封装的）对象。
byte[] | Cipher.wrap(Key key) 包装密钥。

抛出 IllegalBlockSizeException 的 javax.crypto 中的构造方法
SealedObject(Serializable object, Cipher c)
从任何 Serializable 对象构造一个 SealedObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.KeyAgreement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.KeyAgreement
的使用

使用 KeyAgreement 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 KeyAgreement 的使用

返回 KeyAgreement 的 javax.crypto 中的方法
static KeyAgreement | KeyAgreement.getInstance(String algorithm) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, Provider provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, String provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.KeyAgreementSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.KeyAgreementSpi
的使用

使用 KeyAgreementSpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 KeyAgreementSpi 的使用

参数类型为 KeyAgreementSpi 的 javax.crypto 中的构造方法
KeyAgreement(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)
创建一个 KeyAgreement 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.KeyGenerator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.KeyGenerator
的使用

使用 KeyGenerator 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 KeyGenerator 的使用

返回 KeyGenerator 的 javax.crypto 中的方法
static KeyGenerator | KeyGenerator.getInstance(String algorithm) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.KeyGeneratorSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.KeyGeneratorSpi
的使用

使用 KeyGeneratorSpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 KeyGeneratorSpi 的使用

参数类型为 KeyGeneratorSpi 的 javax.crypto 中的构造方法
KeyGenerator(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)
创建一个 KeyGenerator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.Mac 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.Mac
的使用

使用 Mac 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 Mac 的使用

返回 Mac 的 javax.crypto 中的方法
static Mac | Mac.getInstance(String algorithm) 返回实现指定 MAC 算法的 Mac 对象。
static Mac | Mac.getInstance(String algorithm, Provider provider) 返回实现指定 MAC 算法的 Mac 对象。
static Mac | Mac.getInstance(String algorithm, String provider) 返回实现指定 MAC 算法的 Mac 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.MacSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.MacSpi
的使用

使用 MacSpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 MacSpi 的使用

参数类型为 MacSpi 的 javax.crypto 中的构造方法
Mac(MacSpi macSpi, Provider provider, String algorithm)
创建一个 MAC 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.NoSuchPaddingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.NoSuchPaddingException
的使用

使用 NoSuchPaddingException 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 NoSuchPaddingException 的使用

抛出 NoSuchPaddingException 的 javax.crypto 中的方法
protected abstract void | CipherSpi.engineSetPadding(String padding) 设置此 cipher 的填充机制。
static Cipher | Cipher.getInstance(String transformation) 返回实现指定转换的 Cipher 对象。
static Cipher | Cipher.getInstance(String transformation, Provider provider) 返回实现指定转换的 Cipher 对象。
static Cipher | Cipher.getInstance(String transformation, String provider) 返回实现指定转换的 Cipher 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.NullCipher 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.NullCipher
的使用

没有 javax.crypto.NullCipher 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.SealedObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.SealedObject
的使用

使用 SealedObject 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 SealedObject 的使用

参数类型为 SealedObject 的 javax.crypto 中的构造方法
SealedObject(SealedObject so)
根据传入的 SealedObject 构造一个 SealedObject 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.crypto.SecretKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.crypto.SecretKey
的使用

使用 SecretKey 的软件包
java.security | 为安全框架提供类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。

java.security 中 SecretKey 的使用

返回 SecretKey 的 java.security 中的方法
 SecretKey KeyStore.SecretKeyEntry.getSecretKey()
从此项中获取 SecretKey。

参数类型为 SecretKey 的 java.security 中的构造方法
KeyStore.SecretKeyEntry(SecretKey secretKey)
用 SecretKey 构造 SecretKeyEntry。

javax.crypto 中 SecretKey 的使用

返回 SecretKey 的 javax.crypto 中的方法
protected abstract SecretKey | KeyGeneratorSpi.engineGenerateKey() 生成一个秘密密钥。
protected abstract SecretKey | SecretKeyFactorySpi.engineGenerateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
protected abstract SecretKey | KeyAgreementSpi.engineGenerateSecret(String algorithm) 创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
protected abstract SecretKey | SecretKeyFactorySpi.engineTranslateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此密钥工厂的相应密钥对象。
SecretKey | KeyGenerator.generateKey() 生成一个密钥。
SecretKey | SecretKeyFactory.generateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
SecretKey | KeyAgreement.generateSecret(String algorithm) 创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
SecretKey | SecretKeyFactory.translateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此秘密密钥工厂的相应密钥对象。

参数类型为 SecretKey 的 javax.crypto 中的方法
protected abstract KeySpec | SecretKeyFactorySpi.engineGetKeySpec(SecretKey key, Class keySpec) 以所需格式返回给定密钥对象的规范（密钥材料）。
protected abstract SecretKey | SecretKeyFactorySpi.engineTranslateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此密钥工厂的相应密钥对象。
KeySpec | SecretKeyFactory.getKeySpec(SecretKey key, Class keySpec) 以请求的格式返回给定密钥对象的规范（密钥材料）。
SecretKey | SecretKeyFactory.translateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此秘密密钥工厂的相应密钥对象。

javax.crypto.interfaces 中 SecretKey 的使用

javax.crypto.interfaces 中 SecretKey 的子接口
 interface PBEKey
调用者 PBE 密钥接口。

javax.crypto.spec 中 SecretKey 的使用

实现 SecretKey 的 javax.crypto.spec 中的类
 class SecretKeySpec
此类以与 provider 无关的方式指定一个密钥。

javax.security.auth.kerberos 中 SecretKey 的使用

实现 SecretKey 的 javax.security.auth.kerberos 中的类
 class KerberosKey
此类为 Kerberos 主体封装一个长期秘密密钥。

返回 SecretKey 的 javax.security.auth.kerberos 中的方法
 SecretKey KerberosTicket.getSessionKey()
返回与此票据有关联的会话密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.SecretKeyFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.SecretKeyFactory
的使用

使用 SecretKeyFactory 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 SecretKeyFactory 的使用

返回 SecretKeyFactory 的 javax.crypto 中的方法
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.SecretKeyFactorySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.SecretKeyFactorySpi
的使用

使用 SecretKeyFactorySpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 SecretKeyFactorySpi 的使用

参数类型为 SecretKeyFactorySpi 的 javax.crypto 中的构造方法
SecretKeyFactory(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 SecretKeyFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.ShortBufferException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.ShortBufferException
的使用

使用 ShortBufferException 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 ShortBufferException 的使用

抛出 ShortBufferException 的 javax.crypto 中的方法
int | Cipher.doFinal(byte[] output, int outputOffset) 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
void | Mac.doFinal(byte[] output, int outOffset) 完成 MAC 操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract int | CipherSpi.engineDoFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected int | CipherSpi.engineDoFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract int | KeyAgreementSpi.engineGenerateSecret(byte[] sharedSecret, int offset) 生成共享秘密密钥，并将从 offset 开始（包括）的部分放入缓冲区 sharedSecret。
protected abstract int | ExemptionMechanismSpi.engineGenExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob 并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
protected abstract int | CipherSpi.engineUpdate(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
protected int | CipherSpi.engineUpdate(ByteBuffer input, ByteBuffer output) 继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
int | KeyAgreement.generateSecret(byte[] sharedSecret, int offset) 生成共享秘密，并将其放入缓冲区 sharedSecret，从 offset（包括）开始。
int | ExemptionMechanism.genExemptionBlob(byte[] output) 生成豁免机制密钥 blob，并将结果存储在 output 缓冲区中。
int | ExemptionMechanism.genExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob，并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
int | Cipher.update(byte[] input, int inputOffset, int inputLen, byte[] output) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
int | Cipher.update(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
int | Cipher.update(ByteBuffer input, ByteBuffer output) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.crypto.interfaces (Java 2 Platform SE 6)

 javax.crypto.interfaces
接口
DHKey
DHPrivateKey
DHPublicKey
PBEKey


接口 javax.crypto.interfaces.DHKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.crypto.interfaces.DHKey
的使用

使用 DHKey 的软件包
javax.crypto.interfaces 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。

javax.crypto.interfaces 中 DHKey 的使用

javax.crypto.interfaces 中 DHKey 的子接口
interface | DHPrivateKey Diffie-Hellman 私钥接口。
interface | DHPublicKey Diffie-Hellman 公钥接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.crypto.interfaces.DHPrivateKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.crypto.interfaces.DHPrivateKey
的使用

没有 javax.crypto.interfaces.DHPrivateKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.crypto.interfaces.DHPublicKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.crypto.interfaces.DHPublicKey
的使用

没有 javax.crypto.interfaces.DHPublicKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.crypto.interfaces.PBEKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.crypto.interfaces.PBEKey
的使用

没有 javax.crypto.interfaces.PBEKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.crypto.spec (Java 2 Platform SE 6)

 javax.crypto.spec
类
DESedeKeySpec
DESKeySpec
DHGenParameterSpec
DHParameterSpec
DHPrivateKeySpec
DHPublicKeySpec
IvParameterSpec
OAEPParameterSpec
PBEKeySpec
PBEParameterSpec
PSource
PSource.PSpecified
RC2ParameterSpec
RC5ParameterSpec
SecretKeySpec


类 javax.crypto.spec.DESedeKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DESedeKeySpec
的使用

没有 javax.crypto.spec.DESedeKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.DESKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DESKeySpec
的使用

没有 javax.crypto.spec.DESKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.DHGenParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DHGenParameterSpec
的使用

没有 javax.crypto.spec.DHGenParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.DHParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DHParameterSpec
的使用

使用 DHParameterSpec 的软件包
javax.crypto.interfaces 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。

javax.crypto.interfaces 中 DHParameterSpec 的使用

返回 DHParameterSpec 的 javax.crypto.interfaces 中的方法
 DHParameterSpec DHKey.getParams()
返回密钥参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.DHPrivateKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DHPrivateKeySpec
的使用

没有 javax.crypto.spec.DHPrivateKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.DHPublicKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DHPublicKeySpec
的使用

没有 javax.crypto.spec.DHPublicKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.IvParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.IvParameterSpec
的使用

没有 javax.crypto.spec.IvParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.OAEPParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.OAEPParameterSpec
的使用

使用 OAEPParameterSpec 的软件包
javax.crypto.spec 为密钥规范和算法参数规范提供类和接口。

javax.crypto.spec 中 OAEPParameterSpec 的使用

声明为 OAEPParameterSpec 的 javax.crypto.spec 中的字段
static OAEPParameterSpec OAEPParameterSpec.DEFAULT
使用所有默认值的 OAEP 参数设置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.PBEKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.PBEKeySpec
的使用

没有 javax.crypto.spec.PBEKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.PBEParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.PBEParameterSpec
的使用

没有 javax.crypto.spec.PBEParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.PSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.PSource
的使用

使用 PSource 的软件包
javax.crypto.spec 为密钥规范和算法参数规范提供类和接口。

javax.crypto.spec 中 PSource 的使用

javax.crypto.spec 中 PSource 的子类
static class PSource.PSpecified
此类用于显式地指定 OAEP 冗余中编码输入 P 的值。

返回 PSource 的 javax.crypto.spec 中的方法
 PSource OAEPParameterSpec.getPSource()
返回编码输入 P 的源。

参数类型为 PSource 的 javax.crypto.spec 中的构造方法
OAEPParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)
使用指定的信息摘要算法 mdName、掩码生成函数算法 mgfName、掩码生成函数参数 mgfSpec 以及编码输入 P 源 pSrc 来为 PKCS #1 标准中定义的 OAEP 冗余构造一个参数集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.PSource.PSpecified 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.PSource.PSpecified
的使用

使用 PSource.PSpecified 的软件包
javax.crypto.spec 为密钥规范和算法参数规范提供类和接口。

javax.crypto.spec 中 PSource.PSpecified 的使用

声明为 PSource.PSpecified 的 javax.crypto.spec 中的字段
static PSource.PSpecified PSource.PSpecified.DEFAULT
其值与 byte[0] 相等的编码输入 P。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.RC2ParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.RC2ParameterSpec
的使用

没有 javax.crypto.spec.RC2ParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.RC5ParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.RC5ParameterSpec
的使用

没有 javax.crypto.spec.RC5ParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.crypto.spec.SecretKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.SecretKeySpec
的使用

没有 javax.crypto.spec.SecretKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.imageio (Java 2 Platform SE 6)

 javax.imageio
接口
IIOParamController
ImageTranscoder
类
IIOImage
IIOParam
ImageIO
ImageReader
ImageReadParam
ImageTypeSpecifier
ImageWriteParam
ImageWriter
异常
IIOException


类 javax.imageio.IIOException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.IIOException
的使用

使用 IIOException 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio 中 IIOException 的使用

抛出 IIOException 的 javax.imageio 中的方法
protected static BufferedImage ImageReader.getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height)
返回应该在其中写入解码的像素数据的 BufferedImage。

javax.imageio.metadata 中 IIOException 的使用

javax.imageio.metadata 中 IIOException 的子类
 class IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.IIOImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.IIOImage
的使用

使用 IIOImage 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOImage 的使用

返回 IIOImage 的 javax.imageio 中的方法
 IIOImage ImageReader.readAll(int imageIndex, ImageReadParam param)
使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的图像，并返回包含图像、缩略图和相关图像元数据的 IIOImage。

返回变量类型为 IIOImage 的类型的 javax.imageio 中的方法
 Iterator<IIOImage> ImageReader.readAll(Iterator<? extends ImageReadParam> params)
以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。

参数类型为 IIOImage 的 javax.imageio 中的方法
void | ImageWriter.write(IIOImage image) 将包含带有默认元数据和缩略图的单个图像的完整图像流添加到输出中。
abstract void | ImageWriter.write(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param) 添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。
void | ImageWriter.writeInsert(int imageIndex, IIOImage image, ImageWriteParam param) 将新的图像插入现有图像流。
void | ImageWriter.writeToSequence(IIOImage image, ImageWriteParam param) 将单幅图像、可能相关的元数据和缩略图添加到输出中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.IIOParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.IIOParam
的使用

使用 IIOParam 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.plugins.bmp | 包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。

javax.imageio 中 IIOParam 的使用

javax.imageio 中 IIOParam 的子类
class | ImageReadParam 描述如何对流进行解码的类。
class | ImageWriteParam 描述如何对流进行编码的类。

参数类型为 IIOParam 的 javax.imageio 中的方法
 boolean IIOParamController.activate(IIOParam param)
激活控制器。

javax.imageio.plugins.bmp 中 IIOParam 的使用

javax.imageio.plugins.bmp 中 IIOParam 的子类
 class BMPImageWriteParam
用于以 BMP 格式编码图像的 ImageWriteParam 的子类。

javax.imageio.plugins.jpeg 中 IIOParam 的使用

javax.imageio.plugins.jpeg 中 IIOParam 的子类
class | JPEGImageReadParam 此类添加了使用内置 JPEG reader 插件时设置 JPEG 量化表和 Huffman 表的能力。
class | JPEGImageWriteParam 此类添加了使用内置 JPEG writer 插件时设置 JPEG 量化表和 Huffman 表以及请求为图像计算最佳 Huffman 表的能力。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.IIOParamController 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.IIOParamController
的使用

使用 IIOParamController 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOParamController 的使用

声明为 IIOParamController 的 javax.imageio 中的字段
protected IIOParamController | IIOParam.controller 调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的 IIOParamController。
protected IIOParamController | IIOParam.defaultController 调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的默认 IIOParamController。

返回 IIOParamController 的 javax.imageio 中的方法
IIOParamController | IIOParam.getController() 返回当前已安装的所有 IIOParamController。
IIOParamController | IIOParam.getDefaultController() 返回默认 IIOParamController（如果有），不考虑当前安装的控制器。

参数类型为 IIOParamController 的 javax.imageio 中的方法
 void IIOParam.setController(IIOParamController controller)
设置在调用 activateController 方法时用来为 IIOParam 对象提供设置值的 IIOParamController，重写所有默认控制器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.ImageIO 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageIO
的使用

没有 javax.imageio.ImageIO 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.ImageReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageReader
的使用

使用 ImageReader 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 中 ImageReader 的使用

返回 ImageReader 的 javax.imageio 中的方法
static ImageReader ImageIO.getImageReader(ImageWriter writer)
返回对应于给定 ImageWriter 的 ImageReader（如果有）；如果此 ImageWriter 的插件没有指定相应的 ImageReader，或者给定 ImageWriter 没有注册，则返回 null。

返回变量类型为 ImageReader 的类型的 javax.imageio 中的方法
static Iterator<ImageReader> | ImageIO.getImageReaders(Object input) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码所提供的 Object（通常是一个 ImageInputStream）。
static Iterator<ImageReader> | ImageIO.getImageReadersByFormatName(String formatName) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码指定格式。
static Iterator<ImageReader> | ImageIO.getImageReadersByMIMEType(String MIMEType) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定 MIME 类型的文件。
static Iterator<ImageReader> | ImageIO.getImageReadersBySuffix(String fileSuffix) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定后缀的文件。

参数类型为 ImageReader 的 javax.imageio 中的方法
static Iterator<ImageTranscoder> | ImageIO.getImageTranscoders(ImageReader reader, ImageWriter writer) 返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。
static ImageWriter | ImageIO.getImageWriter(ImageReader reader) 返回对应于给定 ImageReader 的 ImageWriter（如果有）；如果此 ImageReader 的插件没有指定相应的 ImageWriter，或者给定的 ImageReader 没有注册，则返回 null。

javax.imageio.event 中 ImageReader 的使用

参数类型为 ImageReader 的 javax.imageio.event 中的方法
void | IIOReadProgressListener.imageComplete(ImageReader source) 报告当前图像读操作已经完成。
void | IIOReadProgressListener.imageProgress(ImageReader source, float percentageDone) 报告对关联 ImageReader 的 read 当前调用的近似完成程度。
void | IIOReadProgressListener.imageStarted(ImageReader source, int imageIndex) 报告图像读操作将要开始。
void | IIOReadUpdateListener.imageUpdate(ImageReader source, BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 报告已更新图像的给定区域。
void | IIOReadUpdateListener.passComplete(ImageReader source, BufferedImage theImage) 报告当前读操作已经完成一个逐步传递。
void | IIOReadUpdateListener.passStarted(ImageReader source, BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 报告当前的读操作将开始逐步传递 (progressive pass)。
void | IIOReadProgressListener.readAborted(ImageReader source) 报告已通过 reader 的 abort 方法中止读操作。
void | IIOReadProgressListener.sequenceComplete(ImageReader source) 报告读操作序列已经完成。
void | IIOReadProgressListener.sequenceStarted(ImageReader source, int minIndex) 报告读操作序列将要开始。
void | IIOReadProgressListener.thumbnailComplete(ImageReader source) 报告缩略图读操作已经完成。
void | IIOReadUpdateListener.thumbnailPassComplete(ImageReader source, BufferedImage theThumbnail) 报告当前缩略图读操作已经完成一个逐步传递。
void | IIOReadUpdateListener.thumbnailPassStarted(ImageReader source, BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 报告当前的缩略图读操作将开始逐步传递。
void | IIOReadProgressListener.thumbnailProgress(ImageReader source, float percentageDone) 报告在关联的 ImageReader 中完成当前 getThumbnail 调用的近似程度。
void | IIOReadProgressListener.thumbnailStarted(ImageReader source, int imageIndex, int thumbnailIndex) 报告缩略图读操作将要开始。
void | IIOReadUpdateListener.thumbnailUpdate(ImageReader source, BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 报告已更新缩略图图像的给定区域。
void | IIOReadWarningListener.warningOccurred(ImageReader source, String warning) 报告在解码中发生非严重错误。

javax.imageio.spi 中 ImageReader 的使用

返回 ImageReader 的 javax.imageio.spi 中的方法
ImageReader | ImageReaderSpi.createReaderInstance() 返回与此服务提供者关联的 ImageReader 实现的实例。
abstract ImageReader | ImageReaderSpi.createReaderInstance(Object extension) 返回与此服务提供者关联的 ImageReader 实现的实例。

参数类型为 ImageReader 的 javax.imageio.spi 中的方法
 boolean ImageReaderSpi.isOwnReader(ImageReader reader)
如果传入的 ImageReader 对象为与此服务提供者关联的 ImageReader 的实例，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.ImageReadParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageReadParam
的使用

使用 ImageReadParam 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。

javax.imageio 中 ImageReadParam 的使用

返回 ImageReadParam 的 javax.imageio 中的方法
 ImageReadParam ImageReader.getDefaultReadParam()
返回一个适合此格式的默认 ImageReadParam 对象。

参数类型为 ImageReadParam 的 javax.imageio 中的方法
protected static void | ImageReader.checkReadParamBandSettings(ImageReadParam param, int numSrcBands, int numDstBands) reader 可用来测试 ImageReadParam 的源和目标 band 设置的有效性的实用方法。
protected static void | ImageReader.computeRegions(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion) 计算感兴趣的源区域和目标区域，将源图像的宽度和高度、可选目标图像和可选 ImageReadParam 都考虑在内。
protected static BufferedImage | ImageReader.getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height) 返回应该在其中写入解码的像素数据的 BufferedImage。
protected static Rectangle | ImageReader.getSourceRegion(ImageReadParam param, int srcWidth, int srcHeight) reader 可用来计算应该读取的源图像区域的一个实用方法，计算时考虑任何源区域，并在所提供的 ImageReadParam 中对偏移量设置进行二次取样。
abstract BufferedImage | ImageReader.read(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的对象，并将它作为一个完整的 BufferedImage 返回。
IIOImage | ImageReader.readAll(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的图像，并返回包含图像、缩略图和相关图像元数据的 IIOImage。
RenderedImage | ImageReader.readAsRenderedImage(int imageIndex, ImageReadParam param) 返回一个 RenderedImage 对象，该对象包含通过索引 imageIndex 指定的图像的内容。
Raster | ImageReader.readRaster(int imageIndex, ImageReadParam param) 返回包含图像流中原始像素数据的新 Raster 对象，不应用任何颜色转换。

类型变量类型为 ImageReadParam 的 javax.imageio 中的方法参数
 Iterator<IIOImage> ImageReader.readAll(Iterator<? extends ImageReadParam> params)
以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。

javax.imageio.plugins.jpeg 中 ImageReadParam 的使用

javax.imageio.plugins.jpeg 中 ImageReadParam 的子类
 class JPEGImageReadParam
此类添加了使用内置 JPEG reader 插件时设置 JPEG 量化表和 Huffman 表的能力。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.ImageTranscoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.ImageTranscoder
的使用

使用 ImageTranscoder 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 中 ImageTranscoder 的使用

实现 ImageTranscoder 的 javax.imageio 中的类
 class ImageWriter
用来编码和写入图像的抽象超类。

返回变量类型为 ImageTranscoder 的类型的 javax.imageio 中的方法
static Iterator<ImageTranscoder> ImageIO.getImageTranscoders(ImageReader reader, ImageWriter writer)
返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。

javax.imageio.spi 中 ImageTranscoder 的使用

返回 ImageTranscoder 的 javax.imageio.spi 中的方法
abstract  ImageTranscoder ImageTranscoderSpi.createTranscoderInstance()
返回与此服务提供者关联的 ImageTranscoder 实现的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.ImageTypeSpecifier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageTypeSpecifier
的使用

使用 ImageTypeSpecifier 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 中 ImageTypeSpecifier 的使用

声明为 ImageTypeSpecifier 的 javax.imageio 中的字段
protected  ImageTypeSpecifier IIOParam.destinationType
一个 ImageTypeSpecifier，用来在进行读取操作时生成目标图像，或者在进行写入操作时设置输出颜色类型。

返回 ImageTypeSpecifier 的 javax.imageio 中的方法
static ImageTypeSpecifier | ImageTypeSpecifier.createBanded(ColorSpace colorSpace, int[] bankIndices, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied) 返回带状图像格式的说明符，它将使用 ComponentColorModel 和 BandedSampleModel 来存储单独数组中的每个通道。
static ImageTypeSpecifier | ImageTypeSpecifier.createFromBufferedImageType(int bufferedImageType) 返回一个 ImageTypeSpecifier，它将对某一标准 BufferedImage 类型（而不是 TYPE_CUSTOM）进行编码。
static ImageTypeSpecifier | ImageTypeSpecifier.createFromRenderedImage(RenderedImage image) 返回一个 ImageTypeSpecifier，它将对 RenderedImage（可能是 BufferedImage）的布局进行编码。
static ImageTypeSpecifier | ImageTypeSpecifier.createGrayscale(int bits, int dataType, boolean isSigned) 返回灰度级图像格式的说明符，它会将给定位深 (bit depth) 的像素压缩成指定数据类型的数组元素。
static ImageTypeSpecifier | ImageTypeSpecifier.createGrayscale(int bits, int dataType, boolean isSigned, boolean isAlphaPremultiplied) 返回灰度级图像格式和 alpha 图像格式的说明符，它会将给定位深的像素压缩成指定数据类型的数组元素。
static ImageTypeSpecifier | ImageTypeSpecifier.createIndexed(byte[] redLUT, byte[] greenLUT, byte[] blueLUT, byte[] alphaLUT, int bits, int dataType) 返回索引颜色图像格式的说明符，它将给定位深的索引值压缩成指定数据类型的数组元素。
static ImageTypeSpecifier | ImageTypeSpecifier.createInterleaved(ColorSpace colorSpace, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied) 返回交错图像格式的说明符，它将使用 ComponentColorModel 和 PixelInterleavedSampleModel 来存储单个 byte、short 或 int 值形式的每个像素组件。
static ImageTypeSpecifier | ImageTypeSpecifier.createPacked(ColorSpace colorSpace, int redMask, int greenMask, int blueMask, int alphaMask, int transferType, boolean isAlphaPremultiplied) 返回压缩图像格式的说明符，它将使用 DirectColorModel 和一个压缩的 SampleModel 来存储压缩成单个 byte、short 或 int 值的像素。
ImageTypeSpecifier | IIOParam.getDestinationType() 以 ImageTypeSpecifier 的形式返回将由读取操作返回的图像类型，如果通过调用 setDestination(ImageTypeSpecifier) 设置了类型的话。
ImageTypeSpecifier | ImageReader.getRawImageType(int imageIndex) 返回一个 ImageTypeSpecifier，指示最能代表图像“原始”内部格式的 SampleModel 和 ColorModel。

返回变量类型为 ImageTypeSpecifier 的类型的 javax.imageio 中的方法
abstract  Iterator<ImageTypeSpecifier> ImageReader.getImageTypes(int imageIndex)
以 ImageTypeSpecifier 形式返回包含可能的图像类型的 Iterator，给定图像可能被解码成这些类型。

参数类型为 ImageTypeSpecifier 的 javax.imageio 中的方法
IIOMetadata | ImageTranscoder.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
abstract IIOMetadata | ImageWriter.getDefaultImageMetadata(ImageTypeSpecifier imageType, ImageWriteParam param) 返回包含用来编码给定类型图像的默认值的 IIOMetadata 对象。
static Iterator<ImageWriter> | ImageIO.getImageWriters(ImageTypeSpecifier type, String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。
int | ImageWriter.getNumThumbnailsSupported(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回受将写入的格式、给定图像类型和任何其他 write 参数支持的缩略图，以及将在编码期间使用的元数据对象。
Dimension[] | ImageWriter.getPreferredThumbnailSizes(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | IIOParam.setDestinationType(ImageTypeSpecifier destinationType) 使用 ImageTypeSpecifier 设置目标图像的所需图像类型。
void | ImageReadParam.setDestinationType(ImageTypeSpecifier destinationType)

类型变量类型为 ImageTypeSpecifier 的 javax.imageio 中的方法参数
protected static BufferedImage ImageReader.getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height)
返回应该在其中写入解码的像素数据的 BufferedImage。

javax.imageio.metadata 中 ImageTypeSpecifier 的使用

参数类型为 ImageTypeSpecifier 的 javax.imageio.metadata 中的方法
boolean | IIOMetadataFormat.canNodeAppear(String elementName, ImageTypeSpecifier imageType) 如果允许元素（和它下面的子树）在给定类型（由 ImageTypeSpecifier 定义）的图像的元数据文档中出现，则返回 true。
abstract boolean | IIOMetadataFormatImpl.canNodeAppear(String elementName, ImageTypeSpecifier imageType)

javax.imageio.spi 中 ImageTypeSpecifier 的使用

参数类型为 ImageTypeSpecifier 的 javax.imageio.spi 中的方法
abstract  boolean ImageWriterSpi.canEncodeImage(ImageTypeSpecifier type)
如果与此服务提供者关联的 ImageWriter 实现能够使用给定的布局编码图像，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.ImageWriteParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageWriteParam
的使用

使用 ImageWriteParam 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.plugins.bmp | 包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。

javax.imageio 中 ImageWriteParam 的使用

返回 ImageWriteParam 的 javax.imageio 中的方法
 ImageWriteParam ImageWriter.getDefaultWriteParam()
返回适用于此文件格式的适当类型的新 ImageWriteParam 对象，该对象包含默认值，即那些将在没有指定 ImageWriteParam 对象时使用的值。

参数类型为 ImageWriteParam 的 javax.imageio 中的方法
IIOMetadata | ImageTranscoder.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
IIOMetadata | ImageTranscoder.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param)
abstract IIOMetadata | ImageWriter.getDefaultImageMetadata(ImageTypeSpecifier imageType, ImageWriteParam param) 返回包含用来编码给定类型图像的默认值的 IIOMetadata 对象。
abstract IIOMetadata | ImageWriter.getDefaultStreamMetadata(ImageWriteParam param) 返回包含用来对图像流进行编码的默认值的 IIOMetadata 对象。
int | ImageWriter.getNumThumbnailsSupported(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回受将写入的格式、给定图像类型和任何其他 write 参数支持的缩略图，以及将在编码期间使用的元数据对象。
Dimension[] | ImageWriter.getPreferredThumbnailSizes(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | ImageWriter.replacePixels(Raster raster, ImageWriteParam param) 用给定 Raster 部分替换已出现在输出中的图像部分。
void | ImageWriter.replacePixels(RenderedImage image, ImageWriteParam param) 用给定图像部分替换已出现在输出中的图像部分。
abstract void | ImageWriter.write(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param) 添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。
void | ImageWriter.writeInsert(int imageIndex, IIOImage image, ImageWriteParam param) 将新的图像插入现有图像流。
void | ImageWriter.writeToSequence(IIOImage image, ImageWriteParam param) 将单幅图像、可能相关的元数据和缩略图添加到输出中。

javax.imageio.plugins.bmp 中 ImageWriteParam 的使用

javax.imageio.plugins.bmp 中 ImageWriteParam 的子类
 class BMPImageWriteParam
用于以 BMP 格式编码图像的 ImageWriteParam 的子类。

javax.imageio.plugins.jpeg 中 ImageWriteParam 的使用

javax.imageio.plugins.jpeg 中 ImageWriteParam 的子类
 class JPEGImageWriteParam
此类添加了使用内置 JPEG writer 插件时设置 JPEG 量化表和 Huffman 表以及请求为图像计算最佳 Huffman 表的能力。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.ImageWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageWriter
的使用

使用 ImageWriter 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 中 ImageWriter 的使用

返回 ImageWriter 的 javax.imageio 中的方法
static ImageWriter ImageIO.getImageWriter(ImageReader reader)
返回对应于给定 ImageReader 的 ImageWriter（如果有）；如果此 ImageReader 的插件没有指定相应的 ImageWriter，或者给定的 ImageReader 没有注册，则返回 null。

返回变量类型为 ImageWriter 的类型的 javax.imageio 中的方法
static Iterator<ImageWriter> | ImageIO.getImageWriters(ImageTypeSpecifier type, String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。
static Iterator<ImageWriter> | ImageIO.getImageWritersByFormatName(String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码指定格式。
static Iterator<ImageWriter> | ImageIO.getImageWritersByMIMEType(String MIMEType) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定 MIME 类型的文件。
static Iterator<ImageWriter> | ImageIO.getImageWritersBySuffix(String fileSuffix) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定后缀的文件。

参数类型为 ImageWriter 的 javax.imageio 中的方法
static ImageReader | ImageIO.getImageReader(ImageWriter writer) 返回对应于给定 ImageWriter 的 ImageReader（如果有）；如果此 ImageWriter 的插件没有指定相应的 ImageReader，或者给定 ImageWriter 没有注册，则返回 null。
static Iterator<ImageTranscoder> | ImageIO.getImageTranscoders(ImageReader reader, ImageWriter writer) 返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。

javax.imageio.event 中 ImageWriter 的使用

参数类型为 ImageWriter 的 javax.imageio.event 中的方法
void | IIOWriteProgressListener.imageComplete(ImageWriter source) 报告图像写操作已经完成。
void | IIOWriteProgressListener.imageProgress(ImageWriter source, float percentageDone) 报告在关联的 ImageWriter 中完成当前 write 调用的近似程度。
void | IIOWriteProgressListener.imageStarted(ImageWriter source, int imageIndex) 报告图像写操作将要开始。
void | IIOWriteProgressListener.thumbnailComplete(ImageWriter source) 报告缩略图写操作已经完成。
void | IIOWriteProgressListener.thumbnailProgress(ImageWriter source, float percentageDone) 报告在关联的 ImageWriter 中完成当前缩略图写操作的近似程度。
void | IIOWriteProgressListener.thumbnailStarted(ImageWriter source, int imageIndex, int thumbnailIndex) 报告缩略图写操作将要开始。
void | IIOWriteWarningListener.warningOccurred(ImageWriter source, int imageIndex, String warning) 报告在编码中发生非严重错误。
void | IIOWriteProgressListener.writeAborted(ImageWriter source) 报告已通过 writer 的 abort 方法中止写操作。

javax.imageio.spi 中 ImageWriter 的使用

返回 ImageWriter 的 javax.imageio.spi 中的方法
ImageWriter | ImageWriterSpi.createWriterInstance() 返回与此服务提供者关联的 ImageWriter 实现的实例。
abstract ImageWriter | ImageWriterSpi.createWriterInstance(Object extension) 返回与此服务提供者关联的 ImageWriter 实现的实例。

参数类型为 ImageWriter 的 javax.imageio.spi 中的方法
 boolean ImageWriterSpi.isOwnWriter(ImageWriter writer)
如果传入的 ImageWriter 对象是与此服务提供者关联的 ImageWriter 的实例，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.imageio.event (Java 2 Platform SE 6)

 javax.imageio.event
接口
IIOReadProgressListener
IIOReadUpdateListener
IIOReadWarningListener
IIOWriteProgressListener
IIOWriteWarningListener


接口 javax.imageio.event.IIOReadProgressListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.event.IIOReadProgressListener
的使用

使用 IIOReadProgressListener 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOReadProgressListener 的使用

类型参数类型为 IIOReadProgressListener 的 javax.imageio 中的字段
protected  List<IIOReadProgressListener> ImageReader.progressListeners
当前已注册 IIOReadProgressListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。

参数类型为 IIOReadProgressListener 的 javax.imageio 中的方法
void | ImageReader.addIIOReadProgressListener(IIOReadProgressListener listener) 将 IIOReadProgressListener 添加到已注册的进度侦听器列表中。
void | ImageReader.removeIIOReadProgressListener(IIOReadProgressListener listener) 从已注册的进度侦听器列表中移除 IIOReadProgressListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.event.IIOReadUpdateListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.event.IIOReadUpdateListener
的使用

使用 IIOReadUpdateListener 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOReadUpdateListener 的使用

类型参数类型为 IIOReadUpdateListener 的 javax.imageio 中的字段
protected  List<IIOReadUpdateListener> ImageReader.updateListeners
当前已注册 IIOReadUpdateListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。

参数类型为 IIOReadUpdateListener 的 javax.imageio 中的方法
void | ImageReader.addIIOReadUpdateListener(IIOReadUpdateListener listener) 将 IIOReadUpdateListener 添加到已注册的更新侦听器列表中。
void | ImageReader.removeIIOReadUpdateListener(IIOReadUpdateListener listener) 从已注册的更新侦听器列表中移除 IIOReadUpdateListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.event.IIOReadWarningListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.event.IIOReadWarningListener
的使用

使用 IIOReadWarningListener 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOReadWarningListener 的使用

类型参数类型为 IIOReadWarningListener 的 javax.imageio 中的字段
protected  List<IIOReadWarningListener> ImageReader.warningListeners
当前已注册 IIOReadWarningListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。

参数类型为 IIOReadWarningListener 的 javax.imageio 中的方法
void | ImageReader.addIIOReadWarningListener(IIOReadWarningListener listener) 将 IIOReadWarningListener 添加到已注册的警告侦听器的列表中。
void | ImageReader.removeIIOReadWarningListener(IIOReadWarningListener listener) 从已注册的错误侦听器列表中移除 IIOReadWarningListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.event.IIOWriteProgressListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.event.IIOWriteProgressListener
的使用

使用 IIOWriteProgressListener 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOWriteProgressListener 的使用

类型参数类型为 IIOWriteProgressListener 的 javax.imageio 中的字段
protected  List<IIOWriteProgressListener> ImageWriter.progressListeners
当前已注册 IIOWriteProgressListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。

参数类型为 IIOWriteProgressListener 的 javax.imageio 中的方法
void | ImageWriter.addIIOWriteProgressListener(IIOWriteProgressListener listener) 将 IIOWriteProgressListener 添加到已注册的进度侦听器列表中。
void | ImageWriter.removeIIOWriteProgressListener(IIOWriteProgressListener listener) 从已注册的进度侦听器列表中移除 IIOWriteProgressListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.event.IIOWriteWarningListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.event.IIOWriteWarningListener
的使用

使用 IIOWriteWarningListener 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOWriteWarningListener 的使用

类型参数类型为 IIOWriteWarningListener 的 javax.imageio 中的字段
protected  List<IIOWriteWarningListener> ImageWriter.warningListeners
当前已注册 IIOWriteWarningListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。

参数类型为 IIOWriteWarningListener 的 javax.imageio 中的方法
void | ImageWriter.addIIOWriteWarningListener(IIOWriteWarningListener listener) 将 IIOWriteWarningListener 添加到已注册的警告侦听器的列表中。
void | ImageWriter.removeIIOWriteWarningListener(IIOWriteWarningListener listener) 从已注册的警告侦听器列表中移除 IIOWriteWarningListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.imageio.metadata (Java 2 Platform SE 6)

 javax.imageio.metadata
接口
IIOMetadataController
IIOMetadataFormat
类
IIOMetadata
IIOMetadataFormatImpl
IIOMetadataNode
异常
IIOInvalidTreeException


类 javax.imageio.metadata.IIOInvalidTreeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.metadata.IIOInvalidTreeException
的使用

使用 IIOInvalidTreeException 的软件包
javax.imageio.metadata 用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio.metadata 中 IIOInvalidTreeException 的使用

抛出 IIOInvalidTreeException 的 javax.imageio.metadata 中的方法
abstract void | IIOMetadata.mergeTree(String formatName, Node root) 根据 XML DOM Node 树（其语法由给定元数据格式定义）改变此 IIOMetadata 对象的内部状态。
void | IIOMetadata.setFromTree(String formatName, Node root) 根据 XML DOM Node 的树（其语法由给定元数据格式定义）设置此 IIOMetadata 对象的内部状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.metadata.IIOMetadata 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.metadata.IIOMetadata
的使用

使用 IIOMetadata 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio 中 IIOMetadata 的使用

声明为 IIOMetadata 的 javax.imageio 中的字段
protected  IIOMetadata IIOImage.metadata
包含与图像关联的元数据的 IIOMetadata 对象。

返回 IIOMetadata 的 javax.imageio 中的方法
IIOMetadata | ImageTranscoder.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
IIOMetadata | ImageTranscoder.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param)
abstract IIOMetadata | ImageWriter.getDefaultImageMetadata(ImageTypeSpecifier imageType, ImageWriteParam param) 返回包含用来编码给定类型图像的默认值的 IIOMetadata 对象。
abstract IIOMetadata | ImageWriter.getDefaultStreamMetadata(ImageWriteParam param) 返回包含用来对图像流进行编码的默认值的 IIOMetadata 对象。
abstract IIOMetadata | ImageReader.getImageMetadata(int imageIndex) 返回包含与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
IIOMetadata | ImageReader.getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames) 返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。
IIOMetadata | IIOImage.getMetadata() 返回对当前 IIOMetadata 对象的引用，如果没有设置任何这样的对象，则返回 null。
abstract IIOMetadata | ImageReader.getStreamMetadata() 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）；如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
IIOMetadata | ImageReader.getStreamMetadata(String formatName, Set<String> nodeNames) 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。

参数类型为 IIOMetadata 的 javax.imageio 中的方法
IIOMetadata | ImageTranscoder.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
IIOMetadata | ImageTranscoder.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param)
int | ImageWriter.getNumThumbnailsSupported(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回受将写入的格式、给定图像类型和任何其他 write 参数支持的缩略图，以及将在编码期间使用的元数据对象。
Dimension[] | ImageWriter.getPreferredThumbnailSizes(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | ImageWriter.prepareWriteSequence(IIOMetadata streamMetadata) 使用提供的流元数据对象准备一个流，以接受一系列的后续 writeToSequence 调用。
void | ImageWriter.replaceImageMetadata(int imageIndex, IIOMetadata imageMetadata) 替换与现有图像有关的图像元数据。
void | ImageWriter.replaceStreamMetadata(IIOMetadata streamMetadata) 使用新信息替换输出中的流元数据。
void | IIOImage.setMetadata(IIOMetadata metadata) 将 IIOMetadata 设置为一个新对象或 null。
abstract void | ImageWriter.write(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param) 添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。

参数类型为 IIOMetadata 的 javax.imageio 中的构造方法
IIOImage(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。
IIOImage(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。

javax.imageio.metadata 中 IIOMetadata 的使用

参数类型为 IIOMetadata 的 javax.imageio.metadata 中的方法
 boolean IIOMetadataController.activate(IIOMetadata metadata)
激活控制器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.metadata.IIOMetadataController 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.metadata.IIOMetadataController
的使用

使用 IIOMetadataController 的软件包
javax.imageio.metadata 用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio.metadata 中 IIOMetadataController 的使用

声明为 IIOMetadataController 的 javax.imageio.metadata 中的字段
protected IIOMetadataController | IIOMetadata.controller 调用 activateController 方法时，将用来为此 IIOMetadataController 对象提供设置值的 IIOParamController。
protected IIOMetadataController | IIOMetadata.defaultController 建议用作此 IIOMetadata 对象的控制器的 IIOMetadataController。

返回 IIOMetadataController 的 javax.imageio.metadata 中的方法
IIOMetadataController | IIOMetadata.getController() 返回当前已安装的所有 IIOMetadataController。
IIOMetadataController | IIOMetadata.getDefaultController() 返回默认 IIOMetadataController（如果有），不考虑当前安装的控制器。

参数类型为 IIOMetadataController 的 javax.imageio.metadata 中的方法
 void IIOMetadata.setController(IIOMetadataController controller)
设置在调用 activateController 方法时用来为此 IIOParam 对象提供设置值的 IIOMetadataController，重写任何默认控制器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.metadata.IIOMetadataFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.metadata.IIOMetadataFormat
的使用

使用 IIOMetadataFormat 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.metadata 中 IIOMetadataFormat 的使用

实现 IIOMetadataFormat 的 javax.imageio.metadata 中的类
 class IIOMetadataFormatImpl
提供 IIOMetadataFormat 接口的可重用实现的具体类。

返回 IIOMetadataFormat 的 javax.imageio.metadata 中的方法
IIOMetadataFormat | IIOMetadata.getMetadataFormat(String formatName) 返回描述给定元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
static IIOMetadataFormat | IIOMetadataFormatImpl.getStandardFormatInstance() 返回描述标准、插件无关的 javax.imageio_1.0 元数据文档格式的 IIOMetadataFormat 对象，该文档格式在 javax.imageio.metadata 包的注释中描述。

javax.imageio.spi 中 IIOMetadataFormat 的使用

返回 IIOMetadataFormat 的 javax.imageio.spi 中的方法
IIOMetadataFormat | ImageReaderWriterSpi.getImageMetadataFormat(String formatName) 返回描述给定的图像元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
IIOMetadataFormat | ImageReaderWriterSpi.getStreamMetadataFormat(String formatName) 返回描述给定的流元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.metadata.IIOMetadataFormatImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.metadata.IIOMetadataFormatImpl
的使用

没有 javax.imageio.metadata.IIOMetadataFormatImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.metadata.IIOMetadataNode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.metadata.IIOMetadataNode
的使用

使用 IIOMetadataNode 的软件包
javax.imageio.metadata 用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio.metadata 中 IIOMetadataNode 的使用

返回 IIOMetadataNode 的 javax.imageio.metadata 中的方法
protected IIOMetadataNode | IIOMetadata.getStandardChromaNode() 返回表示标准 javax_imageio_1.0 元数据格式的色度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardCompressionNode() 返回表示标准 javax_imageio_1.0 元数据格式的压缩信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardDataNode() 返回表示标准 javax_imageio_1.0 元数据格式的数据格式信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardDimensionNode() 返回表示标准 javax_imageio_1.0 元数据格式的维度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardDocumentNode() 返回表示标准 javax_imageio_1.0 元数据格式的文档信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardTextNode() 返回表示标准 javax_imageio_1.0 元数据格式的文本信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardTileNode() 返回表示标准 javax_imageio_1.0 元数据格式的平铺信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardTransparencyNode() 返回表示标准 javax_imageio_1.0 元数据格式的透明度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardTree() 返回表示此对象中所包含元数据的 IIOMetadataNode 的树（根据标准 javax_imageio_1.0 元数据格式的约定）的实用方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


BMP Metadata Format Specification

The XML schema for the native image metadata format is as follows:
<?xml version="1.0" encoding="UTF-8"?>

<!-- Schema for BMP native image metadata format. -->

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            xmlns="http://javax.imageio.plugins"
            targetNamespace="http://javax.imageio.plugins">

  <!-- Coordinates of a point in the CIE XYZ color space. -->
  <xsd:complexType name="XYZPoint">
    <xsd:sequence>
      <xsd:element name="X" type="xsd:double"/>
      <xsd:element name="Y" type="xsd:double"/>
      <xsd:element name="Z" type="xsd:double"/>
    </xsd:sequence>
  </xsd:complexType>

  <!-- BMP Schema 1.0 root element. -->
  <xsd:element name="javax_imageio_bmp_1.0">
    <xsd:complexType>
      <xsd:sequence>

        <!-- BMP version string -->
        <xsd:element name="BMPVersion" type="xsd:string"/>

        <!-- Bitmap width -->
        <xsd:element name="Width" type="xsd:unsignedInt"/>

        <!-- Bitmap height -->
        <xsd:element name="Height" type="xsd:unsignedInt"/>

        <!-- Number of bits per pixel -->
        <xsd:element name="BitsPerPixel" type="xsd:unsignedShort"/>

        <!-- Compression type -->
        <xsd:element name="Compression" type="xsd:unsignedInt" minOccurs="0"/>

        <!-- Image size in bytes -->
        <xsd:element name="ImageSize" type="xsd:unsignedInt" minOccurs="0"/>

    <!-- Resolution in pixels per unit distance -->
        <xsd:element name="PixelsPerMeter" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="X" type="xsd:unsignedInt"/>
              <xsd:element name="Y" type="xsd:unsignedInt"/>
            </xsd:sequence>
      </xsd:complexType>
        </xsd:element> <!-- PixelsPerMeter -->

    <!-- Number of color indexes in the color table actually used -->
        <xsd:element name="ColorsUsed" type="xsd:unsignedInt" minOccurs="0"/>

    <!-- Number of color indexes considered important for display -->
        <xsd:element name="ColorsImportant" type="xsd:unsignedInt"
             minOccurs="0"/>

    <!-- Color masks; present for BI_BITFIELDS compression only -->
        <xsd:element name="Mask" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="Red" type="xsd:unsignedInt"/>
              <xsd:element name="Green" type="xsd:unsignedInt"/>
              <xsd:element name="Blue" type="xsd:unsignedInt"/>
              <xsd:element name="Alpha" type="xsd:unsignedInt" minOccurs="0"/>
            </xsd:sequence>
      </xsd:complexType>
    </xsd:element>

        <!-- Color space  -->
        <xsd:element name="ColorSpaceType" type="xsd:unsignedInt"
             minOccurs="0"/>

    <!-- CIE XYZ for the LCS_CALIBRATED_RGB color space -->
        <xsd:element name="CIEXYZEndpoints" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="Red" type="XYZPoint"/>
              <xsd:element name="Green" type="XYZPoint"/>
              <xsd:element name="Blue" type="XYZPoint"/>
            </xsd:sequence>
      </xsd:complexType>
        </xsd:element>

    <!-- Gamma values for the LCS_CALIBRATED_RGB color space -->
        <xsd:element name="Gamma" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="Red" type="xsd:unsignedInt"/>
              <xsd:element name="Green" type="xsd:unsignedInt"/>
              <xsd:element name="Blue" type="xsd:unsignedInt"/>
            </xsd:sequence>
      </xsd:complexType>
    </xsd:element>

    <!-- Rendering intent -->
        <xsd:element name="Intent" type="xsd:unsignedInt" minOccurs="0"/>

    <!-- The image colormap -->
        <xsd:element name="Palette" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="PaletteEntry">
            <xsd:complexType>
                  <xsd:sequence>
                    <xsd:element name="Red" type="xsd:unsignedByte"/>
                    <xsd:element name="Green" type="xsd:unsignedByte"/>
                    <xsd:element name="Blue" type="xsd:unsignedByte"/>
                    <xsd:element name="Alpha" type="xsd:unsignedByte" minOccurs="0"/>
                  </xsd:sequence>
            </xsd:complexType>
              </xsd:element>
            </xsd:sequence>
      </xsd:complexType>
    </xsd:element>

      </xsd:sequence>
    </xsd:complexType>
  </xsd:element> <!-- bmp_image_1.0 -->

</xsd:schema>
@since 1.5


GIF Metadata Format Specification

GIF Stream Metadata Format Specification

The GIF stream metadata format encodes the information stored in the per-file header, namely the file version, logical screen descriptor, and the global color table.

The logical screen descriptor describes the overall width and height of an animated file, as well as information about the color resolution (number of bits per pixel) and pixel aspect ratio.

The global color table contains a color lookup table that is used for images that do not have their own local color table.

<!DOCTYPE "javax_imageio_gif_stream_1.0" [

  <!ELEMENT "javax_imageio_gif_stream_1.0" (Version?,
    LogicalScreenDescriptor?, GlobalColorTable?)>

    <!ELEMENT "Version" EMPTY>
      <!-- The file version, either 87a or 89a -->
      <!ATTLIST "Version" "value" ("87a" | "89a") #REQUIRED>
        <!-- The version string -->

    <!ELEMENT "LogicalScreenDescriptor" EMPTY>
      <!-- The logical screen descriptor, except for the global color table -->
      <!ATTLIST "LogicalScreenDescriptor" "logicalScreenWidth" #CDATA
         #REQUIRED>
        <!-- The width in pixels of the whole picture -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "LogicalScreenDescriptor" "logicalScreenHeight" #CDATA
         #REQUIRED>
        <!-- The height in pixels of the whole picture -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "LogicalScreenDescriptor" "colorResolution" #CDATA
         #REQUIRED>
        <!-- The number of bits of color resolution, beteen 1 and 8 -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 8 (inclusive) -->
      <!ATTLIST "LogicalScreenDescriptor" "pixelAspectRatio" #CDATA
         #REQUIRED>
        <!-- If 0, indicates square pixels, else W/H = (value + 16)/64 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "GlobalColorTable" (ColorTableEntry)*>
      <!-- The global color table -->
      <!-- Min children: 2 -->
      <!-- Max children: 256 -->
      <!ATTLIST "GlobalColorTable" "sizeOfGlobalColorTable" ("2" |
        "4" | "8" | "16" | "32" | "64" | "128" | "256") #REQUIRED>
        <!-- The number of entries in the global color table -->
      <!ATTLIST "GlobalColorTable" "backgroundColorIndex" #CDATA
         #REQUIRED>
        <!-- The index of the color table entry to be used as a background -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->
      <!ATTLIST "GlobalColorTable" "sortFlag" ("TRUE" | "FALSE")
         #REQUIRED>
        <!-- True if the global color table is sorted by frequency -->

      <!ELEMENT "ColorTableEntry" EMPTY>
        <!-- A global color table entry -->
        <!ATTLIST "ColorTableEntry" "index" #CDATA #REQUIRED>
          <!-- The index of the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "red" #CDATA #REQUIRED>
          <!-- The red value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "green" #CDATA #REQUIRED>
          <!-- The green value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
]>

GIF Image Metadata Format Specification

The GIF image metadata format encodes the image descriptor, local color table, and extension information assciated with a single image within a GIF file, typically a frame of an animation.

The image description contains the offset of the frame within the logical screen described in the stream metadata, as well as the width and height of the frame and whether it is used interlaced encoding.

The local color table, if present, supersedes the global color table for the frame at hand.

The graphic control extension contains information on how the frame is to be incorporated into the animation. The disposal method indicates whether the current frame should remain in place (doNotDispose), be restored to the backgound color as specified in the stream metadata (restoreToBackgroundColor), or be restored to the previous frame contents (restoreToPrevious) prior to displaying the subsequent frame.

The user input flag indicates whether the animation should pause for user input before advancing to the next frame. The transparent color flag and index indicate a color index for which pixels of the frame should not be drawn. The delay time indicates how long the frame should be displayed, in hundredths of a second. If the user input flag is set and the delay time is 0, the frame is intended to be advanced only on user input.

<!DOCTYPE "javax_imageio_gif_image_1.0" [

  <!ELEMENT "javax_imageio_gif_image_1.0" (ImageDescriptor?,
    LocalColorTable?, GraphicControlExtension?, PlainTextExtension?,
    ApplicationExtensions?, CommentExtensions?)>

    <!ELEMENT "ImageDescriptor" EMPTY>
      <!-- The image descriptor -->
      <!ATTLIST "ImageDescriptor" "imageLeftPosition" #CDATA #REQUIRED>
        <!-- The X offset of the image relative to the screen origin -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "imageTopPosition" #CDATA #REQUIRED>
        <!-- The Y offset of the image relative to the screen origin -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "imageWidth" #CDATA #REQUIRED>
        <!-- The width of the image -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "imageHeight" #CDATA #REQUIRED>
        <!-- The height of the image -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "interlaceFlag" ("TRUE" | "FALSE")
         #REQUIRED>
        <!-- True if the image is stored using interlacing -->

    <!ELEMENT "LocalColorTable" (ColorTableEntry)*>
      <!-- The local color table -->
      <!-- Min children: 2 -->
      <!-- Max children: 256 -->
      <!ATTLIST "LocalColorTable" "sizeOfLocalColorTable" ("2" |
        "4" | "8" | "16" | "32" | "64" | "128" | "256") #REQUIRED>
        <!-- The number of entries in the local color table -->
      <!ATTLIST "LocalColorTable" "sortFlag" ("TRUE" | "FALSE")
         #REQUIRED>
        <!-- True if the local color table is sorted by frequency -->

      <!ELEMENT "ColorTableEntry" EMPTY>
        <!-- A local color table entry -->
        <!ATTLIST "ColorTableEntry" "index" #CDATA #REQUIRED>
          <!-- The index of the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "red" #CDATA #REQUIRED>
          <!-- The red value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "green" #CDATA #REQUIRED>
          <!-- The green value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "GraphicControlExtension" EMPTY>
      <!-- A graphic control extension -->
      <!ATTLIST "GraphicControlExtension" "disposalMethod" ("none" |
        "doNotDispose" | "restoreToBackgroundColor" |
        "restoreToPrevious" | "undefinedDisposalMethod4" |
        "undefinedDisposalMethod5" | "undefinedDisposalMethod6" |
        "undefinedDisposalMethod7") #REQUIRED>
        <!-- The disposal method for this frame -->
      <!ATTLIST "GraphicControlExtension" "userInputFlag" ("TRUE" |
        "FALSE") #REQUIRED>
        <!-- True if the frame should be advanced based on user input -->
      <!ATTLIST "GraphicControlExtension" "transparentColorFlag" (
        "TRUE" | "FALSE") #REQUIRED>
        <!-- True if a transparent color exists -->
      <!ATTLIST "GraphicControlExtension" "delayTime" #CDATA #REQUIRED>
        <!-- The time to delay between frames, in hundredths of a second -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "GraphicControlExtension" "transparentColorIndex"
         #CDATA #REQUIRED>
        <!-- The transparent color, if transparentColorFlag is true -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "PlainTextExtension" EMPTY>
      <!-- A plain text (text grid) extension -->
      <!ATTLIST "PlainTextExtension" "textGridLeft" #CDATA #REQUIRED>
        <!-- The X offset of the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textGridTop" #CDATA #REQUIRED>
        <!-- The Y offset of the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textGridWidth" #CDATA #REQUIRED>
        <!-- The number of columns in the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textGridHeight" #CDATA #REQUIRED>
        <!-- The number of rows in the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "characterCellWidth" #CDATA
         #REQUIRED>
        <!-- The width of a character cell -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "characterCellHeight" #CDATA
         #REQUIRED>
        <!-- The height of a character cell -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textForegroundColor" #CDATA
         #REQUIRED>
        <!-- The text foreground color index -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textBackgroundColor" #CDATA
         #REQUIRED>
        <!-- The text background color index -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "ApplicationExtensions" (ApplicationExtension)*>
      <!-- A set of application extensions -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "ApplicationExtension" EMPTY>
        <!-- An application extension -->
        <!-- User object: array of byte -->
        <!-- Min length: 0 -->
        <!-- Max length: 2147483647 -->
        <!ATTLIST "ApplicationExtension" "applicationID" #CDATA
           #REQUIRED>
          <!-- The application ID -->
          <!-- Data type: String -->
        <!ATTLIST "ApplicationExtension" "authenticationCode" #CDATA
           #REQUIRED>
          <!-- The authentication code -->
          <!-- Data type: String -->

    <!ELEMENT "CommentExtensions" (CommentExtension)*>
      <!-- A set of comments -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "CommentExtension" EMPTY>
        <!-- A comment -->
        <!ATTLIST "CommentExtension" "value" #CDATA #REQUIRED>
          <!-- The comment -->
          <!-- Data type: String -->
]>

Mapping of Standard to GIF Native Stream Metadata
Standard Metadata Component | GIF Native Stream Metadata Component
/Chroma/Palette/PaletteEntry@index | /GlobalColorTable/ColorTableEntry@index
/Chroma/Palette/PaletteEntry@red | /GlobalColorTable/ColorTableEntry@red
/Chroma/Palette/PaletteEntry@green | /GlobalColorTable/ColorTableEntry@green
/Chroma/Palette/PaletteEntry@blue | /GlobalColorTable/ColorTableEntry@blue
/Chroma/BackgroundIndex@value | /GlobalColorTable@backgroundColorIndex
/Data/BitsPerSample@value | /LogicalScreenDescriptor@colorResolution
/Dimension/PixelAspectRatio@value | /LogicalScreenDescriptor@pixelAspectRatio
/Dimension/HorizontalScreenSize@value | /LogicalScreenDescriptor@logicalScreenWidth
/Dimension/VerticalScreenSize@value | /LogicalScreenDescriptor@logicalScreenHeight
/Document/FormatVersion@value | /Version@value

Mapping of Standard to GIF Native Image Metadata
Standard Metadata Component | GIF Native Image Metadata Component
/Chroma/Palette/PaletteEntry@index | /LocalColorTable/ColorTableEntry@index
/Chroma/Palette/PaletteEntry@red | /LocalColorTable/ColorTableEntry@red
/Chroma/Palette/PaletteEntry@green | /LocalColorTable/ColorTableEntry@green
/Chroma/Palette/PaletteEntry@blue | /LocalColorTable/ColorTableEntry@blue
/Dimension/HorizontalPixelOffset@value | /ImageDescriptor@imageLeftPosition
/Dimension/VerticalPixelOffset@value | /ImageDescriptor@imageTopPosition
/Text/TextEntry@value | /CommentExtensions/CommentExtension@value
/Transparency/TransparentIndex@value | /GraphicControlExtension@transparentColorIndex (/GraphicControlExtension@transparentColorFlag is also set to "TRUE")


JPEG Metadata Format Specification and Usage Notes

JPEG Metadata
Abbreviated Streams
Sources of Tables
Colorspace Transformations and Conventional Markers
Thumbnail Images
Progressive Encoding
Native Metadata Format Tree Structure and Editing
Image Metadata DTD
Stream Metadata DTD

NOTE: It is important to call dispose() on the JPEG reader and writer objects when they are no longer needed, as they consume significant native resources which are not adequately recovered by garbage collection. Both reader and writer call dispose() in their finalizers, but those finalizers may not be called before the native code has exhausted native memory.

The JPEG writer does not support replacing pixels.

JPEG Metadata

JPEG metadata consists of the data contained in marker segments in a JPEG stream. The image metadata object returned from a read describes the contents of the marker segments between the SOI marker and the EOI marker for that image. The image metadata object passed into a write determines the contents of the stream between the SOI marker and the EOI marker for that image, subject to the controls in any ImageWriteParam.

Stream metadata is used only for tables-only images found (or to be placed) at the beginning of a stream containing abbreviated images. Tables-only images are not treated as images and do not consume an image index. The stream metadata object returned from a read describes the contents of the marker segments between the SOI marker and the EOI marker for the single tables-only image at the beginning of the stream, if one is present. If no tables-only image is present at the front of the stream, the getStreamMetadata method of ImageReader returns null. If stream metadata is provided to the writer, a single tables-only image containing the tables from the stream metadata object will be written at the beginning of the stream. If the stream metadata object contains no tables, default tables will be written. As the sole purpose of stream metadata is for specifying tables-only images at the front of abbreviated streams, the stream metadata argument is useful only on the ImageWriter.prepareWriteSequence method. It is ignored on all other methods.

The ImageWriter.getDefaultStreamMetadata method returns an object containing the tables from the ImageWriteParam argument, if it is a JPEGImageWriteParam and contains tables. Otherwise, the returned object will contain default tables.

The ImageWriter.getDefaultImageMetadata method returns a metadata object containing no tables if the ImageWriteParam argument contains tables. Otherwise the returned metadata object will contain default visually lossless tables. Of course, only a JPEGImageWriteParam may contain tables.

If ignoreMetadata is set to true when the input is set on the reader, stream metadata will not be available, but image metadata will.

Abbreviated Streams

Both the reader and the writer retain their tables from one operation to the next, thus permitting the use of abbreviated streams quite naturally, with a few minor restrictions:
  1. Abbreviated streams may contain only one tables-only image, which must come first in the stream. Subsequent tables-only images will cause undefined behavior.
  2. Abbreviated streams must be read fully and in order. No random access is allowed, in either direction. The same image may be read multiple times. If a call is made with an image index that is not the same as or one greater than the most recent call (or 0 if no calls have been made), then an IllegalArgumentException is thrown.
These restrictions mean that streams may contain abbreviated images interspersed with images containing tables. As required by JPEG, any tables appearing in the stream override previous tables, regardless of the source of the previous tables.

Note that once a tables-only image has been read, it's contents is available as stream metadata from the reader until either another tables-only image is read from another stream or the reader is reset. Changing the input does not reset the stream metadata. This is useful for reading the tables from one file, then changing the input to read an abbreviated stream containing a sequence of images. The tables will be used automatically, and will remain available as "stream" metadata.

Abbreviated streams are written using the sequence methods of ImageWriter. Stream metadata is used to write a tables-only image at the beginning of the stream, and the tables are set up for use, using ImageWriter.prepareWriteSequence. If no stream metadata is supplied to ImageWriter.prepareWriteSequence, then no tables-only image is written. If stream metadata containing no tables is supplied to ImageWriter.prepareWriteSequence, then a tables-only image containing default visually lossless tables is written.

Sources of Tables

Images are written with tables if tables are present in their metadata objects or without them if no tables are present in their metadata objects. If no metadata object is present then the tables are written. The tables used for compression are taken from one of the following sources, which are consulted in order:

  1. If there is an ImageWriteParam and the compression mode is set to EXPLICIT, default tables constructed using the quality setting are used. They are written only if the metadata contains tables or if there is no metadata, but they replace the tables in the metadata.
  2. If there is an ImageWriteParam and the compression mode is set to DEFAULT, default visually lossles tables are used. They are written only if the metadata contains tables or if there is no metadata, but they replace the tables in the metadata.
  3. Otherwise the compression mode on the ImageWriteParam must be MODE_COPY_FROM_METADATA, in which case the following are used:
    1. the tables in the image metadata, if present
    2. the tables in the stream metadata, if present
    3. the tables in the JPEGImageWriteParam, if present
    4. default visually lossless tables
    Tables are written only if they are taken from image metadata.
This ordering implements the design intention that tables should be included in JPEGImageWriteParams only as a means of specifying tables when no other source is available, and this can occur only when writing to an abbreviated stream without tables using known non-standard tables for compression.

When reading, tables in a JPEGImageReadParam are consulted only if tables have not been set by any previous read. Tables set from a JPEGImageReadParam are overridden by any tables present in the stream being read.

Note that if no image metadata object is specified for a particular image, a default object is used, which includes default tables.

Colorspace Transformations and Conventional Markers

Colorspace transformations are controlled by the destination type for both reading and writing of images. When Rasters are read, no colorspace transformation is performed, and any destination type is ignored. A warning is sent to any listeners if a destination type is specified in this case. When Rasters are written, any destination type is used to interpret the bands. This might result in a JFIF or Adobe header being written, or different component ids being written to the frame and scan headers. If values present in a metadata object do not match the destination type, the destination type is used and a warning is sent to any listeners.

When reading, the contents of the stream are interpreted by the usual JPEG conventions, as follows:

  • If a JFIF APP0 marker segment is present, the colorspace is known to be either grayscale or YCbCr. If an APP2 marker segment containing an embedded ICC profile is also present, then the YCbCr is converted to RGB according to the formulas given in the JFIF spec, and the ICC profile is assumed to refer to the resulting RGB space.

  • If an Adobe APP14 marker segment is present, the colorspace is determined by consulting the transform flag. The transform flag takes one of three values:
    • 2 - The image is encoded as YCCK (implicitly converted from CMYK on encoding).
    • 1 - The image is encoded as YCbCr (implicitly converted from RGB on encoding).
    • 0 - Unknown. 3-channel images are assumed to be RGB, 4-channel images are assumed to be CMYK.

  • If neither marker segment is present, the following procedure is followed: Single-channel images are assumed to be grayscale, and 2-channel images are assumed to be grayscale with an alpha channel. For 3- and 4-channel images, the component ids are consulted. If these values are 1-3 for a 3-channel image, then the image is assumed to be YCbCr. If these values are 1-4 for a 4-channel image, then the image is assumed to be YCbCrA. If these values are > 4, they are checked against the ASCII codes for 'R', 'G', 'B', 'A', 'C', 'c'. These can encode the following colorspaces:

    RGB
    RGBA
    YCC (as 'Y','C','c'), assumed to be PhotoYCC
    YCCA (as 'Y','C','c','A'), assumed to be PhotoYCCA

    Otherwise, 3-channel subsampled images are assumed to be YCbCr, 3-channel non-subsampled images are assumed to be RGB, 4-channel subsampled images are assumed to be YCCK, and 4-channel, non-subsampled images are assumed to be CMYK.

  • All other images are declared uninterpretable and an exception is thrown if an attempt is made to read one as a BufferedImage. Such an image may be read only as a Raster. If an image is interpretable but there is no Java ColorSpace available corresponding to the encoded colorspace (e.g. YCbCr), then ImageReader.getRawImageType will return null.
Once an encoded colorspace is determined, then the target colorspace is determined as follows:
  • If a destination type is not set, then the following default transformations take place after upsampling: YCbCr (and YCbCrA) images are converted to RGB (and RGBA) using the conversion provided by the underlying IJG library and either the built-in sRGB ColorSpace or a custom RGB ColorSpace object based on an embedded ICC profile is used to create the output ColorModel. PhotoYCC and PhotoYCCA images are not converted. CMYK and YCCK images are currently not supported.
  • If a destination image or type is set, it is used as follows: If the IJG library provides an appropriate conversion, it is used. Otherwise the default library conversion is followed by a colorspace conversion in Java.
  • Bands are selected AFTER any library colorspace conversion. If a subset of either source or destination bands is used, then the default library conversions are used with no further conversion in Java, regardless of any destination type.
  • An exception is thrown if an attempt is made to read an image in an unsupported jpeg colorspace as a BufferedImage (e.g. CMYK). Such images may be read as Rasters. If an image colorspace is unsupported or uninterpretable, then ImageReader.getImageTypes will return an empty Iterator. If a subset of the raw bands are required, a Raster must be obtained first and the bands obtained from that.

For writing, the color transformation to apply is determined as follows:

If a subset of the source bands is to be written, no color conversion is performed. Any destination, if set, must match the number of bands that will be written, and serves as an interpretation of the selected bands, rather than a conversion request. This behavior is identical to that for Rasters. If all the bands are to be written and an image (as opposed to a Raster) is being written, any destination type is ignored and a warning is sent to any listeners.

If a destination type is used and any aspect of the metadata object, if there is one, is not compatible with that type, the destination type is used, the metadata written is modified from that provided, and a warning is sent to listeners. This includes the app0JFIF and app14Adobe nodes. The component ids in the sof and sos nodes are not modified, however, as unless a app0JFIF node is present, any values may be used.

When a full image is written, a destination colorspace will be chosen based on the image contents and the metadata settings, according to the following algorithm:

If no metadata object is specified, then the following defaults apply:

  • Grayscale images are written with a JFIF APP0 marker segment. Grayscale images with alpha are written with no special marker. As required by JFIF, the component ids in the frame and scan header is set to 1.
  • RGB images are converted to YCbCr, subsampled in the chrominance channels by half both vertically and horizontally, and written with a JFIF APP0 marker segment. If the ColorSpace of the image is based on an ICCProfile (it is an instance of ICC_ColorSpace, but is not one of the standard built-in ColorSpaces), then that profile is embedded in an APP2 marker segment. As required by JFIF, the component ids in the frame and scan headers are set to 1, 2, and 3.
  • RGBA images are converted to YCbCrA, subsampled in the chrominance channels by half both vertically and horizontally, and written without any special marker segments. The component ids in the frame and scan headers are set to 1, 2, 3, and 4.
  • PhotoYCC and YCCAimages are subsampled by half in the chrominance channels both vertically and horizontally and written with an Adobe APP14 marker segment and 'Y','C', and 'c' (and 'A' if an alpha channel is present) as component ids in the frame and scan headers.
Default metadata objects for these image types will reflect these settings.

If a metadata object is specified, then the number of channels in the frame and scan headers must always match the number of bands to be written, or an exception is thrown. app0JFIF and app14Adobe nodes may appear in the same metadata object only if the app14Adobe node indicates YCbCr, and the component ids are JFIF compatible (0-2). The various image types are processed in the following ways:
(All multi-channel images are subsampled according to the sampling factors in the frame header node of the metadata object, regardless of color space.)

  • Grayscale Images:
    • If an app0JFIF node is present in the metadata object, a JFIF APP0 marker segment is written.
    • If an app14Adobe node is present in the metadata object, it is checked for validity (transform must be UNKNOWN) and written.
    • If neither node is present in the metadata object, no special marker segment is written.
  • Grayscale Images with an Alpha Channel:
    • If an app0JFIF node is present in the metadata object, it is ignored and a warning is sent to listeners, as JFIF does not support 2-channel images.
    • If an app14Adobe node is present in the metadata object, it is checked for validity (transform must be UNKNOWN) and written. If transform is not UNKNOWN, a warning is sent to listeners and the correct transform is written.
    • If neither node is present in the metadata object, no special marker segment is written.
  • RGB Images:
    • If an app0JFIF node is present in the metadata object, the image is converted to YCbCr and written with a JFIF APP0 marker segment. If the ColorSpace of the image is based on a non-standard ICC Profile, then that profile is embedded in an APP2 marker segment. If the ColorSpace is not based on a non-standard ICC Profile, but an app2ICC node appears in the metadata, then an APP2 marker segment is written with the appropriate standard profile. Note that the profile must specify an RGB color space, as the file must be JFIF compliant.
    • If an app14Adobe node is present in the metadata object, the image is converted according to the color transform setting and written with an Adobe APP14 marker segment. Component ids are written just as they appear in the frame and scan headers. The color transform must be either YCbCr or UNKNOWN. If it is UNKNOWN, the image is not color converted.
    • If neither node is present, the component ids in the frame header are consulted. If these indicate a colorspace as described above, then the image is converted to that colorspace if possible. If the component ids do not indicate a colorspace, then the sampling factors are consulted. If the image is to be subsampled, it is converted to YCbCr first. If the image is not to be subsampled, then no conversion is applied. No special marker segmentss are written.
  • RGBA images:
    • If an app0JFIF node is present in the metadata object, it is ignored and a warning is sent to listeners, as JFIF does not support 4-channel images.
    • If an app14Adobe node is present in the metadata object, the image is written with an Adobe APP14 marker segment. No colorspace conversion is performed. Component ids are written just as they appear in the frame and scan headers. The color transform must be UNKNOWN. If it is not, a warning is sent to listeners.
    • If no app14Adobe node is present, the component ids in the frame header are consulted. If these indicate a colorspace as described above, then the image is converted to that colorspace if possible. If the component ids do not indicate a colorspace, then the sampling factors are consulted. If the image is to be subsampled, it is converted to YCbCrA. If the image is not to be subsampled, then no conversion is applied. No special marker segments are written.
  • PhotoYCC Images:
    • If an app0JFIF node is present in the metadata object, the image is converted to sRGB, and then to YCbCr during encoding, and a JFIF APP0 marker segment is written.
    • If an app14Adobe node is present in the metadata object, no conversion is applied, and an Adobe APP14 marker segment is written. The color transform must be YCC. If it is not, a warning is sent to listeners.
    • If neither node is present in the metadata object, no conversion is applied, and no special marker segment is written.
  • PhotoYCCA Images:
    • If an app0JFIF node is present in the metadata object, it is ignored and a warning is sent to listeners, as JFIF does not support 4-channel images.
    • If an app14Adobe node is present in the metadata object, no conversion is applied, and an Adobe APP14 marker segment is written. The color transform must be UNKNOWN. If it is not, a warning is sent to listeners.
    • If neither node is present in the metadata object, no conversion is applied, and no special marker segment is written.

Thumbnail Images

Thumbnails are supported by the use of JFIF and JFIF extension marker segments. Thumbnails provided on the write methods determine the thumbnails that will be included. app0JFIF and app0JFXX nodes present in the metadata do not contain any thumbnail pixel data. However, the kinds of thumbnails written depend on the contents of the metadata object, as follows. Any thumbnail which is to be written as an indexed or RGB image and which is larger than 255 by 255 will be clipped, not scaled, to 255 by 255. Thumbnails written as JPEG images may be any size. A warning is sent to any listeners whenever a thumbnail is clipped.
  • If there is a single thumbnail, it is processed as follows:
    • If the thumbnail image is an RGB palette image, it is processed as follows:
      • If no app0JFXX node is present in the metadata, or the first app0JFXX node present in the metadata contains a JFIFthumbPalette element, a palette thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains another thumbnail form (RGB or JPEG), the palette image is expanded to RGB and the indicated thumbnail form is written.
    • If the thumbnail image is an RGB image, it is processed as follows:
      • If no app0JFXX node is present in the metadata, the thumbnail is written as part of the JFIF APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbRGB element, an RGB thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbJPEG element, a JPEG thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbPalette element, an RGB thumbnail is written in a JFXX APP0 marker segment and a warning is sent to any listeners.
    • If the thumbnail image is a grayscale image, it is processed as follows:
      • If no app0JFXX node is present in the metadata, the thumbnail is expanded to RGB and written as part of the JFIF APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbRGB element, the thumbnail is expanded to RGB and written in a separate JFXX RGB marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbJPEG element, a JPEG thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbPalette element, a JPEG thumbnail is written in a JFXX APP0 marker segment and a warning is sent to any listeners.
    • Any other thumbnail image types are ignored and a warning is sent to any listeners.
  • If there are multiple thumbnails, each one is processed as above, except that no thumbnail is placed in the JFIF APP0 segment, and the app0JFXX node consulted for each thumbnail is the app0JFXX node from the metadata that occurs in the same sequence as the thumbnail. I.e. the first app0JFXX node applies to the first thumbnail, the second node to the second thumbnail, and so on. If there are fewer app0JFXX nodes in the metadata than thumbnails, then those thumbnails are considered to have no matching app0JFXX node. An RGB thumbnail with no matching app0JFXX node is written in a JFXX APP0 marker segment. A grayscale thumbnail with no matching app0JFXX node is written as a JPEG image to a JFXX APP0 marker segment.

Note that as the only mechanism for storing thumbnails is via the JFIF or JFIF extension marker segments, only grayscale or RGB images may have thumbnails. If thumbnails are present when writing any other type of image, the thumbnails are ignored and a warning is sent to any warning listeners.

Progressive Encoding

Progressive encoding must be enabled on the ImageWriteParam passed in to a write operation, or the image will be written sequentially, regardless of the scan headers included in the metadata object. If progressive encoding is enabled and set to copy from metadata, then the sequence of scan headers from the metadata is used to write the image. If progressive encoding is enabled and set to use a default, then the scans in the metadata are ignored and a default set of scans is used. Progressive encoding always forces optimized Huffman tables to be used. Any Huffman tables present in the metadata will be ignored, and a warning will be sent to any warning listeners. If Huffman-table optimization is requested on the ImageWriteParam, all Huffman tables in the metadata or in the ImageWriteParam itself are ignored, and a warning will be sent to any warning listeners if any such tables are present.

Native Metadata Format Tree Structure and Editing

The DTDs below describe just the trees of metadata objects actually returned by the IIOMetadata object. They do not include nodes corresponding to SOI, EOI, or RST markers, as these parsing delimiters do not carry any meaningful metadata.

The first node is always a JPEGvariety node. In the javax_imageio_jpeg_image_1.0 version of the JPEG metadata format, this node may have one child, an app0JFIF node, indicating that the JPEG stream contains a JFIF marker segment and related data, or no children, indicating that the stream contains no JFIF marker. In future versions of the JPEG metadata format, other varieties of JPEG metadata may be supported (e.g. Exif) by defining other types of nodes which may appear as a child of the JPEGvariety node.

(Note that an application wishing to interpret Exif metadata given a metadata tree structure in the javax_imageio_jpeg_image_1.0 format must check for an unknown marker segment with a tag indicating an APP1 marker and containing data identifying it as an Exif marker segment. Then it may use application-specific code to interpret the data in the marker segment. If such an application were to encounter a metadata tree formatted according to a future version of the JPEG metadata format, the Exif marker segment might not be unknown in that format - it might be structured as a child node of the JPEGvariety node. Thus, it is important for an application to specify which version to use by passing the string identifying the version to the method/constructor used to obtain an IIOMetadata object.)

On reading, JFXX and app2ICC nodes occur as children of an app0JFIF node. This is true regardless of where the JFXX APP0 and APP2 marker segments actually occur in the stream. The ordering of nodes within the markerSequence node corresponds to the ordering of marker segments found in the JPEG stream.

On writing, any JFXX and app2ICC nodes must occur as children of an app0JFIF node, itself a child of a JPEGvariety node, which must always be the first node. (If the stream is not to be JFIF compliant, no app0JFIF node should be provided, and the JPEGvariety node should have no children.) Any JFIF APP0, JFXX APP0, and APP2 marker segments are written first, followed by all Adobe APP14, APPn, COM and unknown segments in the order in which their corresponding nodes appear in the markerSequence node, followed by DQT (and DHT for non-progressive writes) marker segments, followed by the SOF and SOS marker segments. For progressive writes using metadata to control progression, the SOS segments are used in the order in which their corresponding nodes occur in the markerSequence node.

The reset, mergeTree and setFromTree operations have the following semantics for the JPEG plug-in metadata object:

reset - A call to reset will restore the metadata object to the same state it had immediately after creation, whether this came about from reading a stream or by obtaining a default object from the ImageWriter. This is true regardless of how many times the metadata object has been modified since creation.

mergeTree - Native Format
The mergeTree operation accepts valid trees conforming to the DTD below, and merges the nodes using the following ordering rules. In all cases, only data present in the new node is changed in a corresponding existing node, if any. This means that nodes cannot be removed using mergeTree. To remove nodes, use setFromTree. The tree must consist of IIOMetadataNodes.

  • app0JFIF
    • If an app0JFIF node already exists, the contents of the new one modify the existing one.
    • If there is no such node, a new one is created and inserted in the appropriate position.
  • dqt
    • If there already exist dqt nodes in the sequence, then each table in the node replaces the first table, in any dqt node, with the same table id.
    • If none of the existing dqt nodes contain a table with the same id, then the table is added to the last existing dqt node.
    • If there are no dqt nodes, then a new one is created and added as follows:
      • If there are dht nodes, the new dqt node is inserted before the first one.
      • If there are no dht nodes, the new dqt node is inserted before an sof node, if there is one.
      • If there is no sof node, the new dqt node is inserted before the first sos node, if there is one.
      • If there is no sos node, the new dqt node is added to the end of the sequence.
  • dht
    • If there already exist dht nodes in the sequence, then each table in the node replaces the first table, in any dht node, with the same table class and table id.
    • If none of the existing dht nodes contain a table with the same class and id, then the table is added to the last existing dht node.
    • If there are no dht nodes, then a new one is created and added as follows:
      • If there are dqt nodes, the new dht node is inserted immediately following the last dqt node.
      • If there are no dqt nodes, the new dht node is inserted before an sof node, if there is one.
      • If there is no sof node, the new dht node is inserted before the first sos node, if there is one.
      • If there is no sos node, the new dht node is added to the end of the sequence.
  • dri
    • If there already exists a dri node, the restart interval value is updated.
    • If there is no dri node, then a new one is created and added as follows:
      • If there is an sof node, the new dri node is inserted before it.
      • If there is no sof node, the new dri node is inserted before the first sos node, if there is one.
      • If there is no sos node, the new dri node is added to the end of the sequence.
  • com
    A new com node is created and inserted as follows:
    • If there already exist com nodes, the new one is inserted after the last one.
    • If there are no com nodes, the new com node is inserted after the app14Adobe node, if there is one.
    • If there is no app14Adobe node, the new com node is inserted at the beginning of the sequence.
  • app14Adobe
    • If there already exists an app14Adobe node, then its attributes are updated from the node.
    • If there is no app14Adobe node, then a new one is created and added as follows:
      • The new app14Adobe node is inserted after the last unknown node, if there are any.
      • If there are no unknown nodes, the new app14Adobe node is inserted at the beginning of the sequence.
  • unknown
    A new unknown node is created and added to the sequence as follows:
    • If there already exist unknown marker nodes, the new one is inserted after the last one.
    • If there are no unknown nodes, the new unknown node is inserted before the app14Adobe node, if there is one.
    • If there is no app14Adobe node, the new unknown node is inserted at the beginning of the sequence.
  • sof
    • If there already exists an sof node in the sequence, then its values are updated from the node.
    • If there is no sof node, then a new one is created and added as follows:
      • If there are any sos nodes, the new sof node is inserted before the first one.
      • If there is no sos node, the new sof node is added to the end of the sequence.
  • sos
    • If there already exists a single sos node, then the values are updated from the node.
    • If there are more than one existing sos nodes, then an IIOInvalidTreeException is thrown, as sos nodes cannot be merged into a set of progressive scans.
    • If there are no sos nodes, a new one is created and added to the end of the sequence.

mergeTree - Standard Format
The mergeTree operation, when given a tree in the standard format, will modify the native tree in the following ways:

  • Chroma - The ColorSpaceType subnode of a Chroma node may change the target colorspace of the compressed image. The selection of a new colorspace can cause a number of changes, in keeping with the algorithms described above: app0JFIF and app14Adobe nodes may be added or removed, subsampling may be added or removed, component ids may be changed, and sof and sos nodes will be updated accordingly. If necessary, additional quantization and huffman tables are added. In the case of quantization tables, the default will be scaled to match the quality level of any existing tables. No tables are added to metadata that does not already contain tables. If the existing metadata specifies progressive encoding, then the number of channels must not change. Any Transparency node is also taken into account, as an explicit value of none for the Alpha subnode can cause the removal of an alpha channel, and anything other than none can cause the addition of an alpha channel.
  • Dimension - A PixelAspectRatio specification can cause the contents of an app0JFIF node to change, if there is one present, or the addition of an app0JFIF node containing appropriate values, if there can be one. An appropriate pair of integers is computed from the floating-point ratio for inclusion in the node.
  • Text - Each uncompressed text item is converted to a com node and inserted according to the rules above for merging com nodes.

setFromTree - Native Format
The setFromTree operation, when given a tree in the native format described below, will simply replace the existing tree in its entirety with the new one. The tree must consist of IIOMetadataNodes.

setFromTree - Standard Format
The setFromTree operation, when given a tree in the standard format, performs a reset followed by a merge of the new tree.

Image Metadata DTD

<!DOCTYPE "javax_imageio_jpeg_image_1.0" [

  <!ELEMENT "javax_imageio_jpeg_image_1.0" (JPEGvariety, markerSequence)>

    <!ELEMENT "JPEGvariety" (app0JFIF)>
      <!-- A node grouping all marker segments specific to the variety of
              stream being read/written (e.g. JFIF) - may be empty -->

      <!ELEMENT "app0JFIF" (JFXX?, app2ICC?)>
        <!ATTLIST "app0JFIF" "majorVersion" #CDATA "1">
          <!-- The major JFIF version number -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app0JFIF" "minorVersion" #CDATA "2">
          <!-- The minor JFIF version number -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app0JFIF" "resUnits" ("0" | "1" | "2") "0">
          <!-- The resolution units for Xdensisty and Ydensity (0 = no
               units, just aspect ratio; 1 = dots/inch; 2 = dots/cm) -->
        <!ATTLIST "app0JFIF" "Xdensity" #CDATA "1">
          <!-- The horizontal density or aspect ratio numerator -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app0JFIF" "Ydensity" #CDATA "1">
          <!-- The vertical density or aspect ratio denominator -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app0JFIF" "thumbWidth" #CDATA "0">
          <!-- The width of the thumbnail, or 0 if there isn't one -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app0JFIF" "thumbHeight" #CDATA "0">
          <!-- The height of the thumbnail, or 0 if there isn't one -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

        <!ELEMENT "JFXX" (app0JFXX)*>
          <!-- Min children: 1 -->

        <!ELEMENT "app0JFXX" (JFIFthumbJPEG | JFIFthumbPalette |
          JFIFthumbRGB)>
          <!-- A JFIF extension marker segment -->
          <!ATTLIST "app0JFXX" "extensionCode" ("16" | "17" | "19")
             #IMPLIED>
            <!-- The JFXX extension code identifying thumbnail type: (16 =
                 JPEG, 17 = indexed, 19 = RGB -->

          <!ELEMENT "JFIFthumbJPEG" (markerSequence?)>
            <!-- A JFIF thumbnail in JPEG format (no JFIF segments
                 permitted) -->

          <!ELEMENT "JFIFthumbPalette" EMPTY>
            <!-- A JFIF thumbnail as an RGB indexed image -->
            <!ATTLIST "JFIFthumbPalette" "thumbWidth" #CDATA #IMPLIED>
              <!-- The width of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->
            <!ATTLIST "JFIFthumbPalette" "thumbHeight" #CDATA #IMPLIED>
              <!-- The height of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->

          <!ELEMENT "JFIFthumbRGB" EMPTY>
            <!-- A JFIF thumbnail as an RGB image -->
            <!ATTLIST "JFIFthumbRGB" "thumbWidth" #CDATA #IMPLIED>
              <!-- The width of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->
            <!ATTLIST "JFIFthumbRGB" "thumbHeight" #CDATA #IMPLIED>
              <!-- The height of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->

        <!ELEMENT "app2ICC" EMPTY>
          <!-- An ICC profile APP2 marker segment -->
          <!-- Optional User object: java.awt.color.ICC_Profile -->

    <!ELEMENT "markerSequence" (dqt | dht | dri | com | unknown |
      app14Adobe | sof | sos)*>
      <!-- A node grouping all non-jfif marker segments -->

      <!ELEMENT "dqt" (dqtable)*>
        <!-- A Define Quantization Table(s) marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->

        <!ELEMENT "dqtable" EMPTY>
          <!-- A single quantization table -->
          <!-- User object: javax.imageio.plugins.jpeg.JPEGQTable -->
          <!ATTLIST "dqtable" "elementPrecision" #CDATA "0">
            <!-- The number of bits in each table element (0 = 8, 1 = 16)
                 -->
            <!-- Data type: Integer -->
          <!ATTLIST "dqtable" "qtableId" ("0" | "1" | "2" | "3") #REQUIRED>

      <!ELEMENT "dht" (dhtable)*>
        <!-- A Define Huffman Table(s) marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->

        <!ELEMENT "dhtable" EMPTY>
          <!-- A single Huffman table -->
          <!-- User object: javax.imageio.plugins.jpeg.JPEGHuffmanTable -->
          <!ATTLIST "dhtable" "class" ("0" | "1") #REQUIRED>
            <!-- Indicates whether this is a DC (0) or an AC (1) table -->
          <!ATTLIST "dhtable" "htableId" ("0" | "1" | "2" | "3") #REQUIRED>
            <!-- The table id -->

      <!ELEMENT "dri" EMPTY>
        <!-- A Define Restart Interval marker segment -->
        <!ATTLIST "dri" "interval" #CDATA #REQUIRED>
          <!-- The restart interval in MCUs -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "com" EMPTY>
        <!-- A Comment marker segment. The user object contains the actual
             bytes. -->
        <!-- User object: array of [B -->
        <!-- Min length: 1 -->
        <!-- Max length: 65533 -->
        <!ATTLIST "com" "comment" #CDATA #IMPLIED>
          <!-- The comment as a string (used only if user object is null)
               -->
          <!-- Data type: String -->

      <!ELEMENT "unknown" EMPTY>
        <!-- An unrecognized marker segment. The user object contains the
             data not including length. -->
        <!-- User object: array of [B -->
        <!-- Min length: 1 -->
        <!-- Max length: 65533 -->
        <!ATTLIST "unknown" "MarkerTag" #CDATA #REQUIRED>
          <!-- The tag identifying this marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "app14Adobe" EMPTY>
        <!-- An Adobe APP14 marker segment -->
        <!ATTLIST "app14Adobe" "version" #CDATA "100">
          <!-- The version of Adobe APP14 marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 100 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app14Adobe" "flags0" #CDATA "0">
          <!-- The flags0 variable of an APP14 marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app14Adobe" "flags1" #CDATA "0">
          <!-- The flags1 variable of an APP14 marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app14Adobe" "transform" ("0" | "1" | "2") #REQUIRED>
          <!-- The color transform applied to the image (0 = Unknown, 1 =
               YCbCr, 2 = YCCK) -->

      <!ELEMENT "sof" (componentSpec)*>
        <!-- A Start Of Frame marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->
        <!ATTLIST "sof" "process" ("0" | "1" | "2") #IMPLIED>
          <!-- The JPEG process (0 = Baseline sequential, 1 = Extended
               sequential, 2 = Progressive) -->
        <!ATTLIST "sof" "samplePrecision" #CDATA "8">
          <!-- The number of bits per sample -->
          <!-- Data type: Integer -->
        <!ATTLIST "sof" "numLines" #CDATA #IMPLIED>
          <!-- The number of lines in the image -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "sof" "samplesPerLine" #CDATA #IMPLIED>
          <!-- The number of samples per line -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "sof" "numFrameComponents" ("1" | "2" | "3" | "4")
           #IMPLIED>
          <!-- The number of components in the image -->

        <!ELEMENT "componentSpec" EMPTY>
          <!-- A component specification for a frame -->
          <!ATTLIST "componentSpec" "componentId" #CDATA #REQUIRED>
            <!-- The id for this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 0 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "componentSpec" "HsamplingFactor" #CDATA #REQUIRED>
            <!-- The horizontal sampling factor for this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 1 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "componentSpec" "VsamplingFactor" #CDATA #REQUIRED>
            <!-- The vertical sampling factor for this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 1 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "componentSpec" "QtableSelector" ("0" | "1" | "2" |
            "3") #REQUIRED>
            <!-- The quantization table to use for this component -->

      <!ELEMENT "sos" (scanComponentSpec)*>
        <!-- A Start Of Scan marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->
        <!ATTLIST "sos" "numScanComponents" ("1" | "2" | "3" | "4")
           #REQUIRED>
          <!-- The number of components in the scan -->
        <!ATTLIST "sos" "startSpectralSelection" #CDATA "0">
          <!-- The first spectral band included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 63 (inclusive) -->
        <!ATTLIST "sos" "endSpectralSelection" #CDATA "63">
          <!-- The last spectral band included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 63 (inclusive) -->
        <!ATTLIST "sos" "approxHigh" #CDATA "0">
          <!-- The highest bit position included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 15 (inclusive) -->
        <!ATTLIST "sos" "approxLow" #CDATA "0">
          <!-- The lowest bit position included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 15 (inclusive) -->

        <!ELEMENT "scanComponentSpec" EMPTY>
          <!-- A component specification for a scan -->
          <!ATTLIST "scanComponentSpec" "componentSelector" #CDATA
             #REQUIRED>
            <!-- The id of this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 0 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "scanComponentSpec" "dcHuffTable" ("0" | "1" | "2" |
            "3") #REQUIRED>
            <!-- The huffman table to use for encoding DC coefficients -->
          <!ATTLIST "scanComponentSpec" "acHuffTable" ("0" | "1" | "2" |
            "3") #REQUIRED>
            <!-- The huffman table to use for encoding AC coefficients -->
]>

Stream Metadata DTD

<!DOCTYPE "javax_imageio_jpeg_stream_1.0" [
  <!ELEMENT "javax_imageio_jpeg_stream_1.0" (dqt |
                      dht |
                      dri |
                      com |
                      unknown)*>

  <!-- All elements are as defined above for image metadata -->
]>


PNG Metadata Format Specification

The PNG native format encodes the complete contents of a PNG file chunk by chunk, except for the IDAT chunks that contain the actual image data. Chunks that are not defined in the PNG 1.2 specification are stored under the UnknownChunks element. Note that it is the responsibility of application software to implement the rules for PNG readers, writers, and editors (e.g., the rules concerning unsafe-to-copy chunks) described in the PNG specification. The Image I/O library is not, in and of itself, a PNG reader, writer, or editor in the sense of the specification. Rather, it is a tool that may be used to build PNG readers, writers, and editors.

The image's actual width, height, bit depth, and color type will override any values passed to the writer via metadata, with one exception. If the image has an IndexColorModel, the color table entries will be checked to determine if they form a uniform grayscale ramp. If so, the image will normally be encoded using as grayscale instead of palette color. However, if the color type set in the metadata is "Palette", palette color will be used.

If no metadata is supplied when encoding an image, the header is initialized from the image being encoded, and no optional chunks are included.

The semantics of the standard chunks are described in the PNG specification. Note that there are some restrictions on which chunks may appear for each color type. In particular,

  • A PLTE chunk may not appear in a Gray or GrayAlpha image
  • hIST and tRNS chunks require a prior PLTE chunk
  • A tRNS chunk may not appear in GrayAlpha and RGBA images
The child nodes of the bKGD, sBIT, and tRNS chunks must match the image's color type.

Certain chunks may meaningfully appear multiple times in a PNG file, in particular the text-related chunks. In order to simplify the metadata format, multiple instances of these chunks are consolidated under a single parent node (e.g., the tEXt node), which may have zero or more children (e.g., tEXtEntry nodes). If no children are present, no chunk will be written. Similarly, unknown chunks are stored as children of a single UnknownChunks node.

It is not possible to control the ordering of the chunks as they are written, or to determine the order of the chunks in a file being read.

<!DOCTYPE "javax_imageio_png_1.0" [

  <!ELEMENT "javax_imageio_png_1.0" (IHDR?, PLTE?, bKGD?, cHRM?,
    gAMA?, hIST?, iCCP?, iTXt?, pHYS?, sBIT?, sPLT?, sRGB?, tEXt?,
    tIME?, tRNS?, zTXt?, UnknownChunks?)>

    <!ELEMENT "IHDR" EMPTY>
      <!-- The IHDR chunk, containing the header -->
      <!ATTLIST "IHDR" "width" #CDATA #REQUIRED>
        <!-- The width of the image in pixels -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "IHDR" "height" #CDATA #REQUIRED>
        <!-- The height of the image in pixels -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "IHDR" "bitDepth" ("1" | "2" | "4" | "8" | "16")
         #REQUIRED>
        <!-- The bit depth of the image samples -->
      <!ATTLIST "IHDR" "colorType" ("Grayscale" | "RGB" | "Palette" |
        "GrayAlpha" | "RGBAlpha") #REQUIRED>
        <!-- The color type of the image -->
      <!ATTLIST "IHDR" "compressionMethod" ("deflate") #REQUIRED>
        <!-- The compression used for image data, always "deflate" -->
      <!ATTLIST "IHDR" "filterMethod" ("adaptive") #REQUIRED>
        <!-- The filtering method used for compression, always "adaptive" -->
      <!ATTLIST "IHDR" "interlaceMethod" ("none" | "adam7") #REQUIRED>
        <!-- The interlacing method, "none" or "adam7" -->

    <!ELEMENT "PLTE" (PLTEEntry)*>
      <!-- The PLTE chunk, containing the palette -->
      <!-- Min children: 1 -->
      <!-- Max children: 256 -->

      <!ELEMENT "PLTEEntry" EMPTY>
        <!-- A palette entry -->
        <!ATTLIST "PLTEEntry" "index" #CDATA #REQUIRED>
          <!-- The index of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "PLTEEntry" "red" #CDATA #REQUIRED>
          <!-- The red value of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "PLTEEntry" "green" #CDATA #REQUIRED>
          <!-- The green value of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "PLTEEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "bKGD" (bKGD_Grayscale | bKGD_RGB | bKGD_Palette)>
      <!-- The bKGD chunk, containing the background color -->

      <!ELEMENT "bKGD_Grayscale" EMPTY>
        <!-- A grayscale background color, for Gray and GrayAlpha images -->
        <!ATTLIST "bKGD_Grayscale" "gray" #CDATA #REQUIRED>
          <!-- A gray value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "bKGD_RGB" EMPTY>
        <!-- An RGB background color, for RGB and RGBAlpha images -->
        <!ATTLIST "bKGD_RGB" "red" #CDATA #REQUIRED>
          <!-- A red value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "bKGD_RGB" "green" #CDATA #REQUIRED>
          <!-- A green value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "bKGD_RGB" "blue" #CDATA #REQUIRED>
          <!-- A blue value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "bKGD_Palette" EMPTY>
        <!-- A background palette index -->
        <!ATTLIST "bKGD_Palette" "index" #CDATA #REQUIRED>
          <!-- A palette index to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "cHRM" EMPTY>
      <!-- The cHRM chunk, containing color calibration -->
      <!ATTLIST "cHRM" "whitePointX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the white point, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "whitePointY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the white point, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "redX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the red primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "redY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the red primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "greenX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the green primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "greenY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the green primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "blueX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the blue primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "blueY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the blue primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->

    <!ELEMENT "gAMA" EMPTY>
      <!-- The gAMA chunk, containing the image gamma -->
      <!ATTLIST "gAMA" "value" #CDATA #REQUIRED>
        <!-- The image gamma, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->

    <!ELEMENT "hIST" (hISTEntry)*>
      <!-- The hIST chunk, containing histogram information  -->
      <!-- Min children: 1 -->
      <!-- Max children: 256 -->

      <!ELEMENT "hISTEntry" EMPTY>
        <!-- A histogram entry -->
        <!ATTLIST "hISTEntry" "index" #CDATA #REQUIRED>
          <!-- The palette index of this histogram entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "hISTEntry" "value" #CDATA #REQUIRED>
          <!-- The frequency of this histogram entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

    <!ELEMENT "iCCP" EMPTY>
      <!-- The iCCP chunk, containing an ICC color profile -->
      <!-- User object: array of byte -->
      <!-- Min length: 0 -->
      <!-- Max length: 2147483647 -->
      <!ATTLIST "iCCP" "profileName" #CDATA #REQUIRED>
        <!-- The name of this ICC profile -->
        <!-- Data type: String -->
      <!ATTLIST "iCCP" "compressionMethod" ("deflate") #REQUIRED>
        <!-- The compression method used to store this ICC profile -->

    <!ELEMENT "iTXt" (iTXtEntry)*>
      <!-- The iTXt chunk, containing internationalized text -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "iTXtEntry" EMPTY>
        <!-- A localized text entry -->
        <!ATTLIST "iTXtEntry" "keyword" #CDATA #REQUIRED>
          <!-- The keyword -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "compressionFlag" ("TRUE" | "FALSE")
           #REQUIRED>
        <!ATTLIST "iTXtEntry" "compressionMethod" #CDATA #REQUIRED>
          <!-- The compression method used to store this iTXt entry -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "languageTag" #CDATA #REQUIRED>
          <!-- The ISO tag describing the language this iTXt entry -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "translatedKeyword" #CDATA #REQUIRED>
          <!-- The translated keyword for iTXt entry -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "text" #CDATA #REQUIRED>
          <!-- The localized text -->
          <!-- Data type: String -->

    <!ELEMENT "pHYS" EMPTY>
      <!-- The pHYS chunk, containing the pixel size and aspect ratio -->
      <!ATTLIST "pHYS" "pixelsPerUnitXAxis" #CDATA #REQUIRED>
        <!-- The number of horizontal pixels per unit, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "pHYS" "pixelsPerUnitYAxis" #CDATA #REQUIRED>
        <!-- The number of vertical pixels per unit, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "pHYS" "unitSpecifier" ("unknown" | "meter") #REQUIRED>
        <!-- The unit specifier for this chunk (i.e., meters) -->

    <!ELEMENT "sBIT" (sBIT_Grayscale | sBIT_GrayAlpha | sBIT_RGB |
      sBIT_RGBAlpha | sBIT_Palette)>
      <!-- The sBIT chunk, containing significant bit information -->

      <!ELEMENT "sBIT_Grayscale" EMPTY>
        <!-- Significant bit information for gray samples -->
        <!ATTLIST "sBIT_Grayscale" "gray" #CDATA #REQUIRED>
          <!-- The number of significant bits of the gray samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_GrayAlpha" EMPTY>
        <!-- Significant bit information for gray and alpha samples -->
        <!ATTLIST "sBIT_GrayAlpha" "gray" #CDATA #REQUIRED>
          <!-- The number of significant bits of the gray samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_GrayAlpha" "alpha" #CDATA #REQUIRED>
          <!-- The number of significant bits of the alpha samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_RGB" EMPTY>
        <!-- Significant bit information for RGB samples -->
        <!ATTLIST "sBIT_RGB" "red" #CDATA #REQUIRED>
          <!-- The number of significant bits of the red samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGB" "green" #CDATA #REQUIRED>
          <!-- The number of significant bits of the green samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGB" "blue" #CDATA #REQUIRED>
          <!-- The number of significant bits of the blue samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_RGBAlpha" EMPTY>
        <!-- Significant bit information for RGBA samples -->
        <!ATTLIST "sBIT_RGBAlpha" "red" #CDATA #REQUIRED>
          <!-- The number of significant bits of the red samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGBAlpha" "green" #CDATA #REQUIRED>
          <!-- The number of significant bits of the green samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGBAlpha" "blue" #CDATA #REQUIRED>
          <!-- The number of significant bits of the blue samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGBAlpha" "alpha" #CDATA #REQUIRED>
          <!-- The number of significant bits of the alpha samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_Palette" EMPTY>
        <!-- Significant bit information for RGB palette entries -->
        <!ATTLIST "sBIT_Palette" "red" #CDATA #REQUIRED>
          <!-- The number of significant bits of the red palette entries -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_Palette" "green" #CDATA #REQUIRED>
          <!-- The number of significant bits of the green palette entries -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_Palette" "blue" #CDATA #REQUIRED>
          <!-- The number of significant bits of the blue palette entries -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "sPLT" (sPLTEntry)*>
      <!-- The sPLT chunk, containing a suggested palette -->
      <!-- Min children: 1 -->
      <!-- Max children: 256 -->

      <!ELEMENT "sPLTEntry" EMPTY>
        <!-- A suggested palette entry -->
        <!ATTLIST "sPLTEntry" "index" #CDATA #REQUIRED>
          <!-- The index of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "red" #CDATA #REQUIRED>
          <!-- The red value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "green" #CDATA #REQUIRED>
          <!-- The green value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "alpha" #CDATA #REQUIRED>
          <!-- The blue value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "sRGB" EMPTY>
      <!-- The sRGB chunk, containing rendering intent information -->
      <!ATTLIST "sRGB" "renderingIntent" ("Perceptual" |
        "Relative colorimetric" | "Saturation" |
        "Absolute colorimetric") #REQUIRED>
        <!-- The rendering intent -->

    <!ELEMENT "tEXt" (tEXtEntry)*>
      <!-- The tEXt chunk, containing text -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "tEXtEntry" EMPTY>
        <!-- A text entry -->
        <!ATTLIST "tEXtEntry" "keyword" #CDATA #REQUIRED>
          <!-- The keyword -->
          <!-- Data type: String -->
        <!ATTLIST "tEXtEntry" "value" #CDATA #REQUIRED>
          <!-- The text -->
          <!-- Data type: String -->

    <!ELEMENT "tIME" EMPTY>
      <!-- The tIME chunk, containing the image modification time -->
      <!ATTLIST "tIME" "year" #CDATA #REQUIRED>
        <!-- The year when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "tIME" "month" #CDATA #REQUIRED>
        <!-- The month when the image was last modified, 1 = January -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 12 (inclusive) -->
      <!ATTLIST "tIME" "day" #CDATA #REQUIRED>
        <!-- The day of the month when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 31 (inclusive) -->
      <!ATTLIST "tIME" "hour" #CDATA #REQUIRED>
        <!-- The hour when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 23 (inclusive) -->
      <!ATTLIST "tIME" "minute" #CDATA #REQUIRED>
        <!-- The minute when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 59 (inclusive) -->
      <!ATTLIST "tIME" "second" #CDATA #REQUIRED>
        <!-- The second when the image was last modified, 60 = leap second -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 60 (inclusive) -->

    <!ELEMENT "tRNS" (tRNS_Grayscale | tRNS_RGB | tRNS_Palette)>
      <!-- The tRNS chunk, containing transparency information -->

      <!ELEMENT "tRNS_Grayscale" EMPTY>
        <!-- A grayscale value that should be considered transparent -->
        <!ATTLIST "tRNS_Grayscale" "gray" #CDATA #REQUIRED>
          <!-- The gray value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "tRNS_RGB" EMPTY>
        <!-- An RGB value that should be considered transparent -->
        <!ATTLIST "tRNS_RGB" "red" #CDATA #REQUIRED>
          <!-- The red value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "tRNS_RGB" "green" #CDATA #REQUIRED>
          <!-- The green value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "tRNS_RGB" "blue" #CDATA #REQUIRED>
          <!-- The blure value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "tRNS_Palette" EMPTY>
        <!-- A palette index that should be considered transparent -->
        <!ATTLIST "tRNS_Palette" "index" #CDATA #REQUIRED>
          <!-- A palette index to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "tRNS_Palette" "alpha" #CDATA #REQUIRED>
          <!-- The transparency associated with the palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "zTXt" (zTXtEntry)*>
      <!-- The zTXt chunk, containing compressed text -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "zTXtEntry" EMPTY>
        <!-- A compressed text entry -->
        <!-- User object: array of byte -->
        <!-- Min length: 0 -->
        <!-- Max length: 2147483647 -->
        <!ATTLIST "zTXtEntry" "keyword" #CDATA #REQUIRED>
          <!-- The keyword -->
          <!-- Data type: String -->
        <!ATTLIST "zTXtEntry" "compressionMethod" ("deflate")
           #REQUIRED>
          <!-- The compressed text -->

    <!ELEMENT "UnknownChunks" (UnknownChunk)*>
      <!-- A set of unknown chunks -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "UnknownChunk" EMPTY>
        <!-- Unknown chunk data stored as a byte array -->
        <!-- User object: array of byte -->
        <!-- Min length: 0 -->
        <!-- Max length: 2147483647 -->
        <!ATTLIST "UnknownChunk" "type" #CDATA #REQUIRED>
          <!-- The 4-character type of the unknown chunk -->
          <!-- Data type: String -->
]>


Standard Metadata Format Specification

Standard (Plug-in Neutral) Metadata Format Specification

The plug-in neutral "javax_imageio_1.0" format consists of a root node named "javax_imageio_1.0" which has child nodes "chroma", "compression", "dimension", "document", "text", "tile", and "transparency". The format is described by the following DTD:

<!DOCTYPE "javax_imageio_1.0" [

  <!ELEMENT "javax_imageio_1.0" (Chroma?, Compression?, Data?, Dimension?,
    Document?, Text?, Transparency?)>

    <!ELEMENT "Chroma" (ColorSpaceType?, NumChannels?, Gamma?,
      BlackIsZero?, Palette?, BackgroundIndex?, BackgroundColor?)>
      <!-- Chroma (color) information -->

      <!ELEMENT "ColorSpaceType" EMPTY>
        <!-- The raw color space of the image -->
        <!ATTLIST "ColorSpaceType" "name" ("XYZ" | "Lab" | "Luv" |
          "YCbCr" | "Yxy" | "YCCK" | "PhotoYCC" | "RGB" | "GRAY" | "HSV" |
          "HLS" | "CMYK" | "CMY" | "2CLR" | "3CLR" | "4CLR" | "5CLR" |
          "6CLR" | "7CLR" | "8CLR" | "9CLR" | "ACLR" | "BCLR" | "CCLR" |
          "DCLR" | "ECLR" | "FCLR") #REQUIRED>

      <!ELEMENT "NumChannels" EMPTY>
        <!-- The number of channels in the raw image, including alpha -->
        <!ATTLIST "NumChannels" "value" #CDATA #REQUIRED>
          <!-- Data type: List of Integer -->

      <!ELEMENT "Gamma" EMPTY>
        <!-- The image gamma -->
        <!ATTLIST "Gamma" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "BlackIsZero" EMPTY>
        <!-- True if smaller values represent darker shades -->
        <!ATTLIST "BlackIsZero" "value" ("TRUE" | "FALSE") "TRUE">

      <!ELEMENT "Palette" (PaletteEntry)*>
        <!-- Palette-color information -->

        <!ELEMENT "PaletteEntry" EMPTY>
          <!-- A palette entry -->
          <!ATTLIST "PaletteEntry" "index" #CDATA #REQUIRED>
            <!-- The index of the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "red" #CDATA #REQUIRED>
            <!-- The red value for the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "green" #CDATA #REQUIRED>
            <!-- The green value for the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "blue" #CDATA #REQUIRED>
            <!-- The blue value for the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "alpha" #CDATA "255">
            <!-- The alpha value for the palette entry -->
            <!-- Data type: Integer -->

      <!ELEMENT "BackgroundIndex" EMPTY>
        <!-- A palette index to be used as a background -->
        <!ATTLIST "BackgroundIndex" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "BackgroundColor" EMPTY>
        <!-- An RGB triple to be used as a background -->
        <!ATTLIST "BackgroundColor" "red" #CDATA #REQUIRED>
          <!-- The red background value -->
          <!-- Data type: Integer -->
        <!ATTLIST "BackgroundColor" "green" #CDATA #REQUIRED>
          <!-- The green background value -->
          <!-- Data type: Integer -->
        <!ATTLIST "BackgroundColor" "blue" #CDATA #REQUIRED>
          <!-- The blue background value -->
          <!-- Data type: Integer -->

    <!ELEMENT "Compression" (CompressionTypeName?, Lossless?,
      NumProgressiveScans?, BitRate?)>
      <!-- Compression information -->

      <!ELEMENT "CompressionTypeName" EMPTY>
        <!-- The name of the compression scheme in use -->
        <!ATTLIST "CompressionTypeName" "value" #CDATA #REQUIRED>
          <!-- Data type: String -->

      <!ELEMENT "Lossless" EMPTY>
        <!-- True if the compression scheme is lossless -->
        <!ATTLIST "Lossless" "value" ("TRUE" | "FALSE") "TRUE">

      <!ELEMENT "NumProgressiveScans" EMPTY>
        <!-- The number of progressive scans used in the image encoding -->
        <!ATTLIST "NumProgressiveScans" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "BitRate" EMPTY>
        <!-- The estimated bit rate of the compression scheme -->
        <!ATTLIST "BitRate" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

    <!ELEMENT "Data" (PlanarConfiguration?, SampleFormat?, BitsPerSample?,
      SignificantBitsPerSample?, SampleMSB?)>
      <!-- Information on the image layout -->

      <!ELEMENT "PlanarConfiguration" EMPTY>
        <!-- The organization of image samples in the stream -->
        <!ATTLIST "PlanarConfiguration" "value" ("PixelInterleaved" |
          "PlaneInterleaved" | "LineInterleaved" | "TileInterleaved")
           #REQUIRED>

      <!ELEMENT "SampleFormat" EMPTY>
        <!-- The numeric format of image samples -->
        <!ATTLIST "SampleFormat" "value" ("SignedIntegral" |
          "UnsignedIntegral" | "Real" | "Index") #REQUIRED>

      <!ELEMENT "BitsPerSample" EMPTY>
        <!-- The number of bits per sample -->
        <!ATTLIST "BitsPerSample" "value" #CDATA #REQUIRED>
          <!-- A list of integers, one per channel -->
          <!-- Data type: List of Integer -->
          <!-- Min length: 1 -->

      <!ELEMENT "SignificantBitsPerSample" EMPTY>
        <!-- The number of significant bits per sample -->
        <!ATTLIST "SignificantBitsPerSample" "value" #CDATA #REQUIRED>
          <!-- A list of integers, one per channel -->
          <!-- Data type: List of Integer -->
          <!-- Min length: 1 -->

      <!ELEMENT "SampleMSB" EMPTY>
        <!-- The position of the most significant bit of each sample -->
        <!ATTLIST "SampleMSB" "value" #CDATA #REQUIRED>
          <!-- A list of integers, one per channel -->
          <!-- Data type: List of Integer -->
          <!-- Min length: 1 -->

    <!ELEMENT "Dimension" (PixelAspectRatio?, ImageOrientation?,
      HorizontalPixelSize?, VerticalPixelSize?,
      HorizontalPhysicalPixelSpacing?, VerticalPhysicalPixelSpacing?,
      HorizontalPosition?, VerticalPosition?, HorizontalPixelOffset?,
      VerticalPixelOffset?, HorizontalScreenSize?, VerticalScreenSize?)>
      <!-- Dimension information -->

      <!ELEMENT "PixelAspectRatio" EMPTY>
        <!-- The width of a pixel divided by its height -->
        <!ATTLIST "PixelAspectRatio" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "ImageOrientation" EMPTY>
        <!-- The desired orientation of the image in terms of flips and
             counter-clockwise rotations -->
        <!ATTLIST "ImageOrientation" "value" ("Normal" | "Rotate90" |
          "Rotate180" | "Rotate270" | "FlipH" | "FlipV" |
          "FlipHRotate90" | "FlipVRotate90") #REQUIRED>

      <!ELEMENT "HorizontalPixelSize" EMPTY>
        <!-- The width of a pixel, in millimeters, as it should be rendered
             on media -->
        <!ATTLIST "HorizontalPixelSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "VerticalPixelSize" EMPTY>
        <!-- The height of a pixel, in millimeters, as it should be
             rendered on media -->
        <!ATTLIST "VerticalPixelSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "HorizontalPhysicalPixelSpacing" EMPTY>
        <!-- The horizontal distance in the subject of the image, in
             millimeters, represented by one pixel at the center of the
             image -->
        <!ATTLIST "HorizontalPhysicalPixelSpacing" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "VerticalPhysicalPixelSpacing" EMPTY>
        <!-- The vertical distance in the subject of the image, in
             millimeters, represented by one pixel at the center of the
             image -->
        <!ATTLIST "VerticalPhysicalPixelSpacing" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "HorizontalPosition" EMPTY>
        <!-- The horizontal position, in millimeters, where the image
             should be rendered on media -->
        <!ATTLIST "HorizontalPosition" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "VerticalPosition" EMPTY>
        <!-- The vertical position, in millimeters, where the image should
             be rendered on media -->
        <!ATTLIST "VerticalPosition" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "HorizontalPixelOffset" EMPTY>
        <!-- The horizonal position, in pixels, where the image should be
             rendered onto a raster display -->
        <!ATTLIST "HorizontalPixelOffset" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "VerticalPixelOffset" EMPTY>
        <!-- The vertical position, in pixels, where the image should be
             rendered onto a raster display -->
        <!ATTLIST "VerticalPixelOffset" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "HorizontalScreenSize" EMPTY>
        <!-- The width, in pixels, of the raster display into which the
             image should be rendered -->
        <!ATTLIST "HorizontalScreenSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "VerticalScreenSize" EMPTY>
        <!-- The height, in pixels, of the raster display into which the
             image should be rendered -->
        <!ATTLIST "VerticalScreenSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

    <!ELEMENT "Document" (FormatVersion?, SubimageInterpretation?,
      ImageCreationTime?, ImageModificationTime?)>
      <!-- Document information -->

      <!ELEMENT "FormatVersion" EMPTY>
        <!-- The version of the format used by the stream -->
        <!ATTLIST "FormatVersion" "value" #CDATA #REQUIRED>
          <!-- Data type: String -->

      <!ELEMENT "SubimageInterpretation" EMPTY>
        <!-- The interpretation of this image in relation to the other
             images stored in the same stream -->
        <!ATTLIST "SubimageInterpretation" "value" ("Standalone" |
          "SinglePage" | "FullResolution" | "ReducedResolution" |
          "PyramidLayer" | "Preview" | "VolumeSlice" | "ObjectView" |
          "Panorama" | "AnimationFrame" | "TransparencyMask" |
          "CompositingLayer" | "SpectralSlice" | "Unknown") #REQUIRED>

      <!ELEMENT "ImageCreationTime" EMPTY>
        <!-- The time of image creation -->
        <!ATTLIST "ImageCreationTime" "year" #CDATA #REQUIRED>
          <!-- The full year (e.g., 1967, not 67) -->
          <!-- Data type: Integer -->
        <!ATTLIST "ImageCreationTime" "month" #CDATA #REQUIRED>
          <!-- The month, with January = 1 -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 12 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "day" #CDATA #REQUIRED>
          <!-- The day of the month -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 31 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "hour" #CDATA "0">
          <!-- The hour from 0 to 23 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 23 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "minute" #CDATA "0">
          <!-- The minute from 0 to 59 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 59 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "second" #CDATA "0">
          <!-- The second from 0 to 60 (60 = leap second) -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 60 (inclusive) -->

      <!ELEMENT "ImageModificationTime" EMPTY>
        <!-- The time of the last image modification -->
        <!ATTLIST "ImageModificationTime" "year" #CDATA #REQUIRED>
          <!-- The full year (e.g., 1967, not 67) -->
          <!-- Data type: Integer -->
        <!ATTLIST "ImageModificationTime" "month" #CDATA #REQUIRED>
          <!-- The month, with January = 1 -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 12 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "day" #CDATA #REQUIRED>
          <!-- The day of the month -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 31 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "hour" #CDATA "0">
          <!-- The hour from 0 to 23 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 23 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "minute" #CDATA "0">
          <!-- The minute from 0 to 59 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 59 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "second" #CDATA "0">
          <!-- The second from 0 to 60 (60 = leap second) -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 60 (inclusive) -->

    <!ELEMENT "Text" (TextEntry)*>
      <!-- Text information -->

      <!ELEMENT "TextEntry" EMPTY>
        <!-- A text entry -->
        <!ATTLIST "TextEntry" "keyword" #CDATA #IMPLIED>
          <!-- A keyword associated with the text entry -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "value" #CDATA #REQUIRED>
          <!-- the text entry -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "language" #CDATA #IMPLIED>
          <!-- The language of the text -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "encoding" #CDATA #IMPLIED>
          <!-- The encoding of the text -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "compression" ("none" | "lzw" | "zip" |
          "bzip" | "other") "none">
          <!-- The method used to compress the text -->

    <!ELEMENT "Transparency" (Alpha?, TransparentIndex?,
      TransparentColor?, TileTransparencies?, TileOpacities?)>
      <!-- Transparency information -->

      <!ELEMENT "Alpha" EMPTY>
        <!-- The type of alpha information contained in the image -->
        <!ATTLIST "Alpha" "value" ("none" | "premultiplied" |
          "nonpremultiplied") "none">

      <!ELEMENT "TransparentIndex" EMPTY>
        <!-- A palette index to be treated as transparent -->
        <!ATTLIST "TransparentIndex" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "TransparentColor" EMPTY>
        <!-- An RGB color to be treated as transparent -->
        <!ATTLIST "TransparentColor" "value" #CDATA #REQUIRED>
          <!-- Data type: List of Integer -->

      <!ELEMENT "TileTransparencies" (TransparentTile)*>
        <!-- A list of completely transparent tiles -->

        <!ELEMENT "TransparentTile" EMPTY>
          <!-- The index of a completely transparent tile -->
          <!ATTLIST "TransparentTile" "x" #CDATA #REQUIRED>
            <!-- The tile's X index -->
            <!-- Data type: Integer -->
          <!ATTLIST "TransparentTile" "y" #CDATA #REQUIRED>
            <!-- The tile's Y index -->
            <!-- Data type: Integer -->

      <!ELEMENT "TileOpacities" (OpaqueTile)*>
        <!-- A list of completely opaque tiles -->

        <!ELEMENT "OpaqueTile" EMPTY>
          <!-- The index of a completely opaque tile -->
          <!ATTLIST "OpaqueTile" "x" #CDATA #REQUIRED>
            <!-- The tile's X index -->
            <!-- Data type: Integer -->
          <!ATTLIST "OpaqueTile" "y" #CDATA #REQUIRED>
            <!-- The tile's Y index -->
            <!-- Data type: Integer -->
]>


WBMP Metadata Format Specification

The XML schema for the native image metadata format is as follows:
<?xml version="1.0" encoding="UTF-8"?>
<!-- Schema for WBMP native image metadata format. -->

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            xmlns="http://javax.imageio.plugins"
            targetNamespace="http://javax.imageio.plugins">

  <!-- WBMP Schema 1.0 root element. -->
  <xsd:element name="javax_imageio_wbmp_1.0">
    <xsd:sequence>

      <!-- WBMP image type -->
      <xsd:element name="WBMPType" type="xsd:unsignedInt"/>

      <!-- Bitmap width -->
      <xsd:element name="Width" type="xsd:unsignedInt"/>

      <!-- Bitmap height -->
      <xsd:element name="Height" type="xsd:unsignedInt"/>

     </xsd:sequence>
  </xsd:element> <!-- wbmp_image_1.0 -->

</xsd:schema>
@since 1.5


javax.imageio.plugins.bmp (Java 2 Platform SE 6)

 javax.imageio.plugins.bmp
类
BMPImageWriteParam


类 javax.imageio.plugins.bmp.BMPImageWriteParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.plugins.bmp.BMPImageWriteParam
的使用

没有 javax.imageio.plugins.bmp.BMPImageWriteParam 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.imageio.plugins.jpeg (Java 2 Platform SE 6)

 javax.imageio.plugins.jpeg
类
JPEGHuffmanTable
JPEGImageReadParam
JPEGImageWriteParam
JPEGQTable


类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.plugins.jpeg.JPEGHuffmanTable
的使用

使用 JPEGHuffmanTable 的软件包
javax.imageio.plugins.jpeg 支持内置 JPEG 插件的类。

javax.imageio.plugins.jpeg 中 JPEGHuffmanTable 的使用

声明为 JPEGHuffmanTable 的 javax.imageio.plugins.jpeg 中的字段
static JPEGHuffmanTable | JPEGHuffmanTable.StdACChrominance 标准 AC 色度 Huffman 表。
static JPEGHuffmanTable | JPEGHuffmanTable.StdACLuminance 标准 AC 亮度 Huffman 表。
static JPEGHuffmanTable | JPEGHuffmanTable.StdDCChrominance 标准 DC 色度 Huffman 表。
static JPEGHuffmanTable | JPEGHuffmanTable.StdDCLuminance 标准 DC 亮度 Huffman 表。

返回 JPEGHuffmanTable 的 javax.imageio.plugins.jpeg 中的方法
JPEGHuffmanTable[] | JPEGImageReadParam.getACHuffmanTables() 返回最近一次调用 setDecodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGHuffmanTable[] | JPEGImageWriteParam.getACHuffmanTables() 返回最近一次调用 setEncodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGHuffmanTable[] | JPEGImageReadParam.getDCHuffmanTables() 返回最近一次调用 setDecodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGHuffmanTable[] | JPEGImageWriteParam.getDCHuffmanTables() 返回最近一次调用 setEncodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。

参数类型为 JPEGHuffmanTable 的 javax.imageio.plugins.jpeg 中的方法
void | JPEGImageReadParam.setDecodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在解码简写流中使用。
void | JPEGImageReadParam.setDecodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在解码简写流中使用。
void | JPEGImageWriteParam.setEncodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在编码简写流中使用。
void | JPEGImageWriteParam.setEncodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在编码简写流中使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.plugins.jpeg.JPEGImageReadParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.plugins.jpeg.JPEGImageReadParam
的使用

没有 javax.imageio.plugins.jpeg.JPEGImageReadParam 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.plugins.jpeg.JPEGImageWriteParam
的使用

没有 javax.imageio.plugins.jpeg.JPEGImageWriteParam 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.plugins.jpeg.JPEGQTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.plugins.jpeg.JPEGQTable
的使用

使用 JPEGQTable 的软件包
javax.imageio.plugins.jpeg 支持内置 JPEG 插件的类。

javax.imageio.plugins.jpeg 中 JPEGQTable 的使用

声明为 JPEGQTable 的 javax.imageio.plugins.jpeg 中的字段
static JPEGQTable | JPEGQTable.K1Div2Luminance 在 JPEG 规范的表 K.1 中给出的样本亮度量化表，其中所有元素都除以 2。
static JPEGQTable | JPEGQTable.K1Luminance 在 JPEG 规范的表 K.1 中给出的样本亮度量化表。
static JPEGQTable | JPEGQTable.K2Chrominance 在 JPEG 规范的表 K.2 中给出的样本色度量化表。
static JPEGQTable | JPEGQTable.K2Div2Chrominance 在 JPEG 规范的表 K.2 中给出的样本色度量化表，其中所有元素都除以 2。

返回 JPEGQTable 的 javax.imageio.plugins.jpeg 中的方法
JPEGQTable[] | JPEGImageReadParam.getQTables() 返回最近一次调用 setDecodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGQTable[] | JPEGImageWriteParam.getQTables() 返回最近一次调用 setEncodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGQTable | JPEGQTable.getScaledInstance(float scaleFactor, boolean forceBaseline) 返回新的量化表，其中所有值都乘以 scaleFactor，然后取 1 到 32767（如果 forceBaseline 为 true，则使用 1 到 255）范围中的值。

参数类型为 JPEGQTable 的 javax.imageio.plugins.jpeg 中的方法
void | JPEGImageReadParam.setDecodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在解码简写流中使用。
void | JPEGImageWriteParam.setEncodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在编码简写流中使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.imageio.spi (Java 2 Platform SE 6)

 javax.imageio.spi
接口
RegisterableService
ServiceRegistry.Filter
类
IIORegistry
IIOServiceProvider
ImageInputStreamSpi
ImageOutputStreamSpi
ImageReaderSpi
ImageReaderWriterSpi
ImageTranscoderSpi
ImageWriterSpi
ServiceRegistry


类 javax.imageio.spi.IIORegistry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.IIORegistry
的使用

使用 IIORegistry 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 IIORegistry 的使用

返回 IIORegistry 的 javax.imageio.spi 中的方法
static IIORegistry IIORegistry.getDefaultInstance()
返回 Image I/O API 使用的默认 IIORegistry 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.spi.IIOServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.IIOServiceProvider
的使用

使用 IIOServiceProvider 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 IIOServiceProvider 的使用

javax.imageio.spi 中 IIOServiceProvider 的子类
class | ImageInputStreamSpi 用于 ImageInputStream 的服务提供者接口 (SPI)。
class | ImageOutputStreamSpi 用于 ImageOutputStream 的服务提供者接口 (SPI)。
class | ImageReaderSpi 用于 ImageReader 的服务提供者接口 (SPI)。
class | ImageReaderWriterSpi 包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。
class | ImageTranscoderSpi 用于 ImageTranscoder 的服务提供者接口 (SPI)。
class | ImageWriterSpi 用于 ImageWriter 的服务提供者接口 (SPI)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.spi.ImageInputStreamSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageInputStreamSpi
的使用

没有 javax.imageio.spi.ImageInputStreamSpi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.spi.ImageOutputStreamSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageOutputStreamSpi
的使用

没有 javax.imageio.spi.ImageOutputStreamSpi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.spi.ImageReaderSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageReaderSpi
的使用

使用 ImageReaderSpi 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 ImageReaderSpi 的使用

声明为 ImageReaderSpi 的 javax.imageio 中的字段
protected  ImageReaderSpi ImageReader.originatingProvider
实例化此对象的 ImageReaderSpi，如果其身份未知或不存在，则为 null。

返回 ImageReaderSpi 的 javax.imageio 中的方法
 ImageReaderSpi ImageReader.getOriginatingProvider()
返回传入构造方法的 ImageReaderSpi。

参数类型为 ImageReaderSpi 的 javax.imageio 中的构造方法
ImageReader(ImageReaderSpi originatingProvider)
构造一个 ImageReader，并将其 originatingProvider 字段设置为所提供的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.spi.ImageReaderWriterSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageReaderWriterSpi
的使用

使用 ImageReaderWriterSpi 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 ImageReaderWriterSpi 的使用

javax.imageio.spi 中 ImageReaderWriterSpi 的子类
class | ImageReaderSpi 用于 ImageReader 的服务提供者接口 (SPI)。
class | ImageWriterSpi 用于 ImageWriter 的服务提供者接口 (SPI)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.spi.ImageTranscoderSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageTranscoderSpi
的使用

没有 javax.imageio.spi.ImageTranscoderSpi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.spi.ImageWriterSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageWriterSpi
的使用

使用 ImageWriterSpi 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 ImageWriterSpi 的使用

声明为 ImageWriterSpi 的 javax.imageio 中的字段
protected  ImageWriterSpi ImageWriter.originatingProvider
实例化此对象的 ImageWriterSpi，如果 ImageWriterSpi 的标识是未知的或不存在，则将此对象实例化为 null。

返回 ImageWriterSpi 的 javax.imageio 中的方法
 ImageWriterSpi ImageWriter.getOriginatingProvider()
返回创建此 ImageWriter 的 ImageWriterSpi 对象，如果此对象不是通过 IIORegistry 创建的，则返回 null。

参数类型为 ImageWriterSpi 的 javax.imageio 中的构造方法
ImageWriter(ImageWriterSpi originatingProvider)
构造一个 ImageWriter，并将其 originatingProvider 实例变量设置为所提供的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.spi.RegisterableService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.spi.RegisterableService
的使用

使用 RegisterableService 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 RegisterableService 的使用

实现 RegisterableService 的 javax.imageio.spi 中的类
class | IIOServiceProvider 一个常用于所有 Image I/O 服务提供者接口 (SPI) 的功能性超接口。
class | ImageInputStreamSpi 用于 ImageInputStream 的服务提供者接口 (SPI)。
class | ImageOutputStreamSpi 用于 ImageOutputStream 的服务提供者接口 (SPI)。
class | ImageReaderSpi 用于 ImageReader 的服务提供者接口 (SPI)。
class | ImageReaderWriterSpi 包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。
class | ImageTranscoderSpi 用于 ImageTranscoder 的服务提供者接口 (SPI)。
class | ImageWriterSpi 用于 ImageWriter 的服务提供者接口 (SPI)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.spi.ServiceRegistry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ServiceRegistry
的使用

使用 ServiceRegistry 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 ServiceRegistry 的使用

javax.imageio.spi 中 ServiceRegistry 的子类
 class IIORegistry
用于服务提供者实例的注册表。

参数类型为 ServiceRegistry 的 javax.imageio.spi 中的方法
void | IIOServiceProvider.onDeregistration(ServiceRegistry registry, Class<?> category) Spi 类一从 ServiceRegistry 中注销即执行的回调。
void | RegisterableService.onDeregistration(ServiceRegistry registry, Class<?> category) 将一个实现此接口的对象从给定的 registry 的给定 category 移除时调用此方法。
void | IIOServiceProvider.onRegistration(ServiceRegistry registry, Class<?> category) 在 ServiceRegistry 中实例化和注册 Spi 类后即执行的回调。
void | RegisterableService.onRegistration(ServiceRegistry registry, Class<?> category) 将一个实现此接口的对象添加到给定 registry 的给定 category 时调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.spi.ServiceRegistry.Filter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.spi.ServiceRegistry.Filter
的使用

使用 ServiceRegistry.Filter 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 ServiceRegistry.Filter 的使用

参数类型为 ServiceRegistry.Filter 的 javax.imageio.spi 中的方法
<T> Iterator<T>
ServiceRegistry.getServiceProviders(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
返回一个 Iterator，其包含给定类别中满足由指定的 ServiceRegistry.Filter 对象的 filter 方法定义的条件的服务提供者对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.imageio.stream (Java 2 Platform SE 6)

 javax.imageio.stream
接口
ImageInputStream
ImageOutputStream
类
FileCacheImageInputStream
FileCacheImageOutputStream
FileImageInputStream
FileImageOutputStream
IIOByteBuffer
ImageInputStreamImpl
ImageOutputStreamImpl
MemoryCacheImageInputStream
MemoryCacheImageOutputStream


类 javax.imageio.stream.FileCacheImageInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.FileCacheImageInputStream
的使用

没有 javax.imageio.stream.FileCacheImageInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.stream.FileCacheImageOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.FileCacheImageOutputStream
的使用

没有 javax.imageio.stream.FileCacheImageOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.stream.FileImageInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.FileImageInputStream
的使用

没有 javax.imageio.stream.FileImageInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.stream.FileImageOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.FileImageOutputStream
的使用

没有 javax.imageio.stream.FileImageOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.stream.IIOByteBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.IIOByteBuffer
的使用

使用 IIOByteBuffer 的软件包
javax.imageio.stream Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio.stream 中 IIOByteBuffer 的使用

参数类型为 IIOByteBuffer 的 javax.imageio.stream 中的方法
void | ImageInputStream.readBytes(IIOByteBuffer buf, int len) 从流中读取至多 len 个字节，并修改提供的 IIOByteBuffer 以指示可以找到数据的 byte 数组、偏移量和长度。
void | ImageInputStreamImpl.readBytes(IIOByteBuffer buf, int len)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.stream.ImageInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.stream.ImageInputStream
的使用

使用 ImageInputStream 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio 中 ImageInputStream 的使用

返回 ImageInputStream 的 javax.imageio 中的方法
static ImageInputStream ImageIO.createImageInputStream(Object input)
返回一个 ImageInputStream，它将从给定 Object 中获取输入。

参数类型为 ImageInputStream 的 javax.imageio 中的方法
static BufferedImage ImageIO.read(ImageInputStream stream)
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 ImageInputStream 的结果。

javax.imageio.spi 中 ImageInputStream 的使用

返回 ImageInputStream 的 javax.imageio.spi 中的方法
ImageInputStream | ImageInputStreamSpi.createInputStreamInstance(Object input) 返回与此服务提供者关联的 ImageInputStream 实现的实例。
abstract ImageInputStream | ImageInputStreamSpi.createInputStreamInstance(Object input, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageInputStream 实现的实例。

javax.imageio.stream 中 ImageInputStream 的使用

javax.imageio.stream 中 ImageInputStream 的子接口
 interface ImageOutputStream
供 ImageWriter 使用的可查找输出流接口。

实现 ImageInputStream 的 javax.imageio.stream 中的类
class | FileCacheImageInputStream 从常规 InputStream 获取其输入的 ImageInputStream 的实现。
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageInputStream 从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | ImageInputStreamImpl 实现 ImageInputStream 接口的抽象类。
class | ImageOutputStreamImpl 实现 ImageOutputStream 接口的抽象类。
class | MemoryCacheImageInputStream 从常规 InputStream 获取输入的 ImageInputStream 的实现。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.stream.ImageInputStreamImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.ImageInputStreamImpl
的使用

使用 ImageInputStreamImpl 的软件包
javax.imageio.stream Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio.stream 中 ImageInputStreamImpl 的使用

javax.imageio.stream 中 ImageInputStreamImpl 的子类
class | FileCacheImageInputStream 从常规 InputStream 获取其输入的 ImageInputStream 的实现。
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageInputStream 从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | ImageOutputStreamImpl 实现 ImageOutputStream 接口的抽象类。
class | MemoryCacheImageInputStream 从常规 InputStream 获取输入的 ImageInputStream 的实现。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.imageio.stream.ImageOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.stream.ImageOutputStream
的使用

使用 ImageOutputStream 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio 中 ImageOutputStream 的使用

返回 ImageOutputStream 的 javax.imageio 中的方法
static ImageOutputStream ImageIO.createImageOutputStream(Object output)
返回一个 ImageOutputStream，它将其输出发送到给定 Object。

参数类型为 ImageOutputStream 的 javax.imageio 中的方法
static boolean ImageIO.write(RenderedImage im, String formatName, ImageOutputStream output)
使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。

javax.imageio.spi 中 ImageOutputStream 的使用

返回 ImageOutputStream 的 javax.imageio.spi 中的方法
ImageOutputStream | ImageOutputStreamSpi.createOutputStreamInstance(Object output) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。
abstract ImageOutputStream | ImageOutputStreamSpi.createOutputStreamInstance(Object output, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。

javax.imageio.stream 中 ImageOutputStream 的使用

实现 ImageOutputStream 的 javax.imageio.stream 中的类
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | ImageOutputStreamImpl 实现 ImageOutputStream 接口的抽象类。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.stream.ImageOutputStreamImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.ImageOutputStreamImpl
的使用

使用 ImageOutputStreamImpl 的软件包
javax.imageio.stream Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio.stream 中 ImageOutputStreamImpl 的使用

javax.imageio.stream 中 ImageOutputStreamImpl 的子类
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.stream.MemoryCacheImageInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.MemoryCacheImageInputStream
的使用

没有 javax.imageio.stream.MemoryCacheImageInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.imageio.stream.MemoryCacheImageOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.MemoryCacheImageOutputStream
的使用

没有 javax.imageio.stream.MemoryCacheImageOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.jws (Java 2 Platform SE 6)

 javax.jws
枚举
WebParam.Mode
注释类型
HandlerChain
Oneway
WebMethod
WebParam
WebResult
WebService


WebParam.Mode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.jws
枚举 WebParam.Mode

java.lang.Object
    继承者  java.lang.Enum<WebParam.Mode>
        继承者  javax.jws.WebParam.Mode
所有已实现的接口：
Serializable, Comparable<WebParam.Mode>
正在封闭类：
WebParam
public static enum WebParam.Mode
extends Enum<WebParam.Mode>

参数的流向。

枚举常量摘要
IN
INOUT
OUT
方法摘要
static WebParam.Mode | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static WebParam.Mode[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

IN

public static final WebParam.Mode IN

OUT

public static final WebParam.Mode OUT

INOUT

public static final WebParam.Mode INOUT
方法详细信息

values

public static final WebParam.Mode[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(WebParam.Mode c : WebParam.Mode.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static WebParam.Mode valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


类 javax.jws.HandlerChain 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.HandlerChain
的使用

没有 javax.jws.HandlerChain 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.Oneway 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.Oneway
的使用

没有 javax.jws.Oneway 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.WebMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.WebMethod
的使用

没有 javax.jws.WebMethod 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.WebParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.WebParam
的使用

没有 javax.jws.WebParam 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.WebParam.Mode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.WebParam.Mode
的使用

使用 WebParam.Mode 的软件包
javax.jws

javax.jws 中 WebParam.Mode 的使用

返回 WebParam.Mode 的 javax.jws 中的方法
static WebParam.Mode | WebParam.Mode.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static WebParam.Mode[] | WebParam.Mode.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.WebResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.WebResult
的使用

没有 javax.jws.WebResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.WebService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.WebService
的使用

没有 javax.jws.WebService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.jws.soap (Java 2 Platform SE 6)

 javax.jws.soap
枚举
SOAPBinding.ParameterStyle
SOAPBinding.Style
SOAPBinding.Use
注释类型
InitParam
SOAPBinding
SOAPMessageHandler
SOAPMessageHandlers


SOAPBinding.ParameterStyle (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.jws.soap
枚举 SOAPBinding.ParameterStyle

java.lang.Object
    继承者  java.lang.Enum<SOAPBinding.ParameterStyle>
        继承者  javax.jws.soap.SOAPBinding.ParameterStyle
所有已实现的接口：
Serializable, Comparable<SOAPBinding.ParameterStyle>
正在封闭类：
SOAPBinding
public static enum SOAPBinding.ParameterStyle
extends Enum<SOAPBinding.ParameterStyle>

参数到 SOAP 消息的映射关系的样式。

枚举常量摘要
BARE
WRAPPED
方法摘要
static SOAPBinding.ParameterStyle | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.ParameterStyle[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

BARE

public static final SOAPBinding.ParameterStyle BARE

WRAPPED

public static final SOAPBinding.ParameterStyle WRAPPED
方法详细信息

values

public static final SOAPBinding.ParameterStyle[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SOAPBinding.ParameterStyle c : SOAPBinding.ParameterStyle.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SOAPBinding.ParameterStyle valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


SOAPBinding.Style (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.jws.soap
枚举 SOAPBinding.Style

java.lang.Object
    继承者  java.lang.Enum<SOAPBinding.Style>
        继承者  javax.jws.soap.SOAPBinding.Style
所有已实现的接口：
Serializable, Comparable<SOAPBinding.Style>
正在封闭类：
SOAPBinding
public static enum SOAPBinding.Style
extends Enum<SOAPBinding.Style>

SOAP 绑定样式。

枚举常量摘要
DOCUMENT
RPC
方法摘要
static SOAPBinding.Style | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.Style[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

DOCUMENT

public static final SOAPBinding.Style DOCUMENT

RPC

public static final SOAPBinding.Style RPC
方法详细信息

values

public static final SOAPBinding.Style[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SOAPBinding.Style c : SOAPBinding.Style.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SOAPBinding.Style valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


SOAPBinding.Use (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.jws.soap
枚举 SOAPBinding.Use

java.lang.Object
    继承者  java.lang.Enum<SOAPBinding.Use>
        继承者  javax.jws.soap.SOAPBinding.Use
所有已实现的接口：
Serializable, Comparable<SOAPBinding.Use>
正在封闭类：
SOAPBinding
public static enum SOAPBinding.Use
extends Enum<SOAPBinding.Use>

SOAP 绑定的使用。

枚举常量摘要
ENCODED
LITERAL
方法摘要
static SOAPBinding.Use | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.Use[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

LITERAL

public static final SOAPBinding.Use LITERAL

ENCODED

public static final SOAPBinding.Use ENCODED
方法详细信息

values

public static final SOAPBinding.Use[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SOAPBinding.Use c : SOAPBinding.Use.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SOAPBinding.Use valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


类 javax.jws.soap.InitParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.InitParam
的使用

没有 javax.jws.soap.InitParam 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.soap.SOAPBinding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPBinding
的使用

没有 javax.jws.soap.SOAPBinding 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.soap.SOAPBinding.ParameterStyle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPBinding.ParameterStyle
的使用

使用 SOAPBinding.ParameterStyle 的软件包
javax.jws.soap

javax.jws.soap 中 SOAPBinding.ParameterStyle 的使用

返回 SOAPBinding.ParameterStyle 的 javax.jws.soap 中的方法
static SOAPBinding.ParameterStyle | SOAPBinding.ParameterStyle.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.ParameterStyle[] | SOAPBinding.ParameterStyle.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.soap.SOAPBinding.Style 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPBinding.Style
的使用

使用 SOAPBinding.Style 的软件包
javax.jws.soap

javax.jws.soap 中 SOAPBinding.Style 的使用

返回 SOAPBinding.Style 的 javax.jws.soap 中的方法
static SOAPBinding.Style | SOAPBinding.Style.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.Style[] | SOAPBinding.Style.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.soap.SOAPBinding.Use 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPBinding.Use
的使用

使用 SOAPBinding.Use 的软件包
javax.jws.soap

javax.jws.soap 中 SOAPBinding.Use 的使用

返回 SOAPBinding.Use 的 javax.jws.soap 中的方法
static SOAPBinding.Use | SOAPBinding.Use.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.Use[] | SOAPBinding.Use.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.soap.SOAPMessageHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPMessageHandler
的使用

没有 javax.jws.soap.SOAPMessageHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.jws.soap.SOAPMessageHandlers 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPMessageHandlers
的使用

没有 javax.jws.soap.SOAPMessageHandlers 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.lang.model (Java 2 Platform SE 6)

 javax.lang.model
枚举
SourceVersion


类 javax.lang.model.SourceVersion 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.SourceVersion
的使用

使用 SourceVersion 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 SourceVersion 的使用

返回 SourceVersion 的 javax.annotation.processing 中的方法
SourceVersion | ProcessingEnvironment.getSourceVersion() 返回任何生成的源和类文件应该符合的源版本。
SourceVersion | AbstractProcessor.getSupportedSourceVersion() 如果 processor 类是使用 SupportedSourceVersion 注释的，则返回注释中的源版本。
SourceVersion | Processor.getSupportedSourceVersion() 返回此注释 Processor 支持的最新的源版本。

javax.lang.model 中 SourceVersion 的使用

返回 SourceVersion 的 javax.lang.model 中的方法
static SourceVersion | SourceVersion.latest() 返回可以建模的最新源版本。
static SourceVersion | SourceVersion.latestSupported() 返回完全受当前执行环境支持的最新源版本。
static SourceVersion | SourceVersion.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SourceVersion[] | SourceVersion.values() Returns an array containing the constants of this enum type, in the order they are declared.

javax.tools 中 SourceVersion 的使用

返回变量类型为 SourceVersion 的类型的 javax.tools 中的方法
 Set<SourceVersion> Tool.getSourceVersions()
获取此工具支持的 Java™ 编程语言的源版本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.lang.model.element (Java 2 Platform SE 6)

 javax.lang.model.element
接口
AnnotationMirror
AnnotationValue
AnnotationValueVisitor
Element
ElementVisitor
ExecutableElement
Name
PackageElement
TypeElement
TypeParameterElement
VariableElement
枚举
ElementKind
Modifier
NestingKind
异常
UnknownAnnotationValueException
UnknownElementException


接口 javax.lang.model.element.AnnotationMirror 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.AnnotationMirror
的使用

使用 AnnotationMirror 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 中 AnnotationMirror 的使用

参数类型为 AnnotationMirror 的 javax.annotation.processing 中的方法
Iterable<? extends Completion> | AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Iterable<? extends Completion> | Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a) 在已注释元素的注释镜像位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v) 在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

javax.lang.model.element 中 AnnotationMirror 的使用

返回变量类型为 AnnotationMirror 的类型的 javax.lang.model.element 中的方法
 List<? extends AnnotationMirror> Element.getAnnotationMirrors()
返回直接存在于此元素上的注释。

参数类型为 AnnotationMirror 的 javax.lang.model.element 中的方法
 R AnnotationValueVisitor.visitAnnotation(AnnotationMirror a, P p)
访问注释中的 annotation 值。

javax.lang.model.util 中 AnnotationMirror 的使用

返回变量类型为 AnnotationMirror 的类型的 javax.lang.model.util 中的方法
 List<? extends AnnotationMirror> Elements.getAllAnnotationMirrors(Element e)
返回元素的所有注释，不管是继承的还是直接存在的。

参数类型为 AnnotationMirror 的 javax.lang.model.util 中的方法
Map<? extends ExecutableElement,? extends AnnotationValue> | Elements.getElementValuesWithDefaults(AnnotationMirror a) 返回注释元素的值，包括默认值。
R | SimpleAnnotationValueVisitor6.visitAnnotation(AnnotationMirror a, P p) 访问注释中的 annotation 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.element.AnnotationValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.AnnotationValue
的使用

使用 AnnotationValue 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 中 AnnotationValue 的使用

参数类型为 AnnotationValue 的 javax.annotation.processing 中的方法
 void Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v)
在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

javax.lang.model.element 中 AnnotationValue 的使用

返回 AnnotationValue 的 javax.lang.model.element 中的方法
AnnotationValue | ExecutableElement.getDefaultValue() 如果此 executable 是一个注释类型元素，则返回默认值。
AnnotationValue | UnknownAnnotationValueException.getUnknownAnnotationValue() 返回未知注释值。

返回变量类型为 AnnotationValue 的类型的 javax.lang.model.element 中的方法
 Map<? extends ExecutableElement,? extends AnnotationValue> AnnotationMirror.getElementValues()
返回此注释元素的值。

参数类型为 AnnotationValue 的 javax.lang.model.element 中的方法
 R AnnotationValueVisitor.visit(AnnotationValue av)
等效于 v.visit(av, null) 的便捷方法。
 R AnnotationValueVisitor.visit(AnnotationValue av, P p)
访问注释值。
 R AnnotationValueVisitor.visitUnknown(AnnotationValue av, P p)
访问未知种类的注释值。

类型变量类型为 AnnotationValue 的 javax.lang.model.element 中的方法参数
 R AnnotationValueVisitor.visitArray(List<? extends AnnotationValue> vals, P p)
访问注释中的 array 值。

参数类型为 AnnotationValue 的 javax.lang.model.element 中的构造方法
UnknownAnnotationValueException(AnnotationValue av, Object p)
创建一个新的 UnknownAnnotationValueException。

javax.lang.model.util 中 AnnotationValue 的使用

返回变量类型为 AnnotationValue 的类型的 javax.lang.model.util 中的方法
 Map<? extends ExecutableElement,? extends AnnotationValue> Elements.getElementValuesWithDefaults(AnnotationMirror a)
返回注释元素的值，包括默认值。

参数类型为 AnnotationValue 的 javax.lang.model.util 中的方法
R | AbstractAnnotationValueVisitor6.visit(AnnotationValue av) 访问注释值，这与将自身传递给该值的 accept 方法，并为附加参数传递 null 一样。
R | AbstractAnnotationValueVisitor6.visit(AnnotationValue av, P p) 访问注释值，这与将自身传递给该值的 accept 方法一样。
R | AbstractAnnotationValueVisitor6.visitUnknown(AnnotationValue av, P p) 访问未知种类的注释值。

类型变量类型为 AnnotationValue 的 javax.lang.model.util 中的方法参数
 R SimpleAnnotationValueVisitor6.visitArray(List<? extends AnnotationValue> vals, P p)
访问注释中的 array 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.element.AnnotationValueVisitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.AnnotationValueVisitor
的使用

使用 AnnotationValueVisitor 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 AnnotationValueVisitor 的使用

参数类型为 AnnotationValueVisitor 的 javax.lang.model.element 中的方法
<R,P> R
AnnotationValue.accept(AnnotationValueVisitor<R,P> v, P p)
将一个 visitor 应用到此值。

javax.lang.model.util 中 AnnotationValueVisitor 的使用

实现 AnnotationValueVisitor 的 javax.lang.model.util 中的类
class | AbstractAnnotationValueVisitor6<R,P> 注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleAnnotationValueVisitor6<R,P> 注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.element.Element 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.Element
的使用

使用 Element 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 中 Element 的使用

返回变量类型为 Element 的类型的 javax.annotation.processing 中的方法
Set<? extends Element> | RoundEnvironment.getElementsAnnotatedWith(Class<? extends Annotation> a) 返回使用给定注释类型注释的元素。
Set<? extends Element> | RoundEnvironment.getElementsAnnotatedWith(TypeElement a) 返回使用给定注释类型注释的元素。
Set<? extends Element> | RoundEnvironment.getRootElements() 返回以前的 round 生成的注释处理根元素。

参数类型为 Element 的 javax.annotation.processing 中的方法
JavaFileObject | Filer.createClassFile(CharSequence name, Element... originatingElements) 创建一个新的类文件，并返回一个对象以允许写入它。
FileObject | Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
JavaFileObject | Filer.createSourceFile(CharSequence name, Element... originatingElements) 创建一个新的源文件，并返回一个对象以允许写入它。
Iterable<? extends Completion> | AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Iterable<? extends Completion> | Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e) 在元素的位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a) 在已注释元素的注释镜像位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v) 在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

javax.lang.model.element 中 Element 的使用

javax.lang.model.element 中 Element 的子接口
interface | ExecutableElement 表示某个类或接口的方法、构造方法或初始化程序（静态或实例），包括注释类型元素。
interface | PackageElement 表示一个包程序元素。
interface | TypeElement 表示一个类或接口程序元素。
interface | TypeParameterElement 表示一般类、接口、方法或构造方法元素的形式类型参数。
interface | VariableElement 表示一个字段、enum 常量、方法或构造方法参数、局部变量或异常参数。

返回 Element 的 javax.lang.model.element 中的方法
Element | Element.getEnclosingElement() 返回封装此元素（非严格意义上）的最里层元素。
Element | TypeParameterElement.getGenericElement() 返回由此类型参数参数化的一般类、接口、方法或构造方法。
Element | UnknownElementException.getUnknownElement() 返回未知元素。

返回变量类型为 Element 的类型的 javax.lang.model.element 中的方法
 List<? extends Element> Element.getEnclosedElements()
返回此元素直接封装（非严格意义上）的元素。

参数类型为 Element 的 javax.lang.model.element 中的方法
 R ElementVisitor.visit(Element e)
等效于 v.visit(e, null) 的便捷方法。
 R ElementVisitor.visit(Element e, P p)
访问一个元素。
 R ElementVisitor.visitUnknown(Element e, P p)
访问未知种类的元素。

参数类型为 Element 的 javax.lang.model.element 中的构造方法
UnknownElementException(Element e, Object p)
创建一个新的 UnknownElementException。

javax.lang.model.type 中 Element 的使用

返回 Element 的 javax.lang.model.type 中的方法
Element | DeclaredType.asElement() 返回对应于此类型的元素。
Element | TypeVariable.asElement() 返回对应于此类型变量的元素。

javax.lang.model.util 中 Element 的使用

返回 Element 的 javax.lang.model.util 中的方法
 Element Types.asElement(TypeMirror t)
返回对应于类型的元素。

返回变量类型为 Element 的类型的 javax.lang.model.util 中的方法
 List<? extends Element> Elements.getAllMembers(TypeElement type)
返回类型元素的所有成员，不管是继承的还是直接声明的。

参数类型为 Element 的 javax.lang.model.util 中的方法
 TypeMirror Types.asMemberOf(DeclaredType containing, Element element)
当元素被视为给定类型的成员或者直接由给定类型包含时，返回该元素的类型。
protected  R SimpleElementVisitor6.defaultAction(Element e, P p)
visit 方法的默认动作。
 List<? extends AnnotationMirror> Elements.getAllAnnotationMirrors(Element e)
返回元素的所有注释，不管是继承的还是直接存在的。
 String Elements.getDocComment(Element e)
返回元素的文档（"Javadoc"）注释文本。
 PackageElement Elements.getPackageOf(Element type)
返回元素的包。
 boolean Elements.hides(Element hider, Element hidden)
测试一个类型、方法或字段是否隐藏了另一个类型、方法或字段。
 boolean Elements.isDeprecated(Element e)
如果元素已过时，则返回 true，否则返回 false。
 void Elements.printElements(Writer w, Element... elements)
按指定顺序将元素的表示形式打印到给定 writer。
 R ElementScanner6.scan(Element e)
等效于 v.scan(e, null) 的便捷方法。
 R ElementScanner6.scan(Element e, P p)
通过调用 e.accept(this, p) 处理元素；此方法可被子类重写。
 R AbstractElementVisitor6.visit(Element e)
访问任何程序元素，这与将自身传递给该元素的 accept 方法，并为附加参数传递 null 一样。
 R AbstractElementVisitor6.visit(Element e, P p)
访问任何程序元素，这与将自身传递给该元素的 accept 方法一样。
 R AbstractElementVisitor6.visitUnknown(Element e, P p)
访问未知种类的元素。

类型变量类型为 Element 的 javax.lang.model.util 中的方法参数
static List<ExecutableElement> ElementFilter.constructorsIn(Iterable<? extends Element> elements)
elements 中构造方法的列表。
static Set<ExecutableElement> ElementFilter.constructorsIn(Set<? extends Element> elements)
返回 elements 中构造方法的集合。
static List<VariableElement> ElementFilter.fieldsIn(Iterable<? extends Element> elements)
返回 elements 中字段的列表。
static Set<VariableElement> ElementFilter.fieldsIn(Set<? extends Element> elements)
返回 elements 中字段的集合。
static List<ExecutableElement> ElementFilter.methodsIn(Iterable<? extends Element> elements)
返回 elements 中方法的列表。
static Set<ExecutableElement> ElementFilter.methodsIn(Set<? extends Element> elements)
返回 elements 中方法的集合。
static List<PackageElement> ElementFilter.packagesIn(Iterable<? extends Element> elements)
返回 elements 中包的列表。
static Set<PackageElement> ElementFilter.packagesIn(Set<? extends Element> elements)
返回 elements 中包的集合。
 R ElementScanner6.scan(Iterable<? extends Element> iterable, P p)
迭代给定元素并对每个元素调用 scan(Element, P)。
static List<TypeElement> ElementFilter.typesIn(Iterable<? extends Element> elements)
返回 elements 中类型的列表。
static Set<TypeElement> ElementFilter.typesIn(Set<? extends Element> elements)
返回 elements 中类型的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.element.ElementKind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.element.ElementKind
的使用

使用 ElementKind 的软件包
javax.lang.model.element 用于 Java 编程语言的模型元素的接口。

javax.lang.model.element 中 ElementKind 的使用

返回 ElementKind 的 javax.lang.model.element 中的方法
ElementKind | Element.getKind() 返回此元素的类型。
static ElementKind | ElementKind.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static ElementKind[] | ElementKind.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.element.ElementVisitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.ElementVisitor
的使用

使用 ElementVisitor 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 ElementVisitor 的使用

参数类型为 ElementVisitor 的 javax.lang.model.element 中的方法
<R,P> R
Element.accept(ElementVisitor<R,P> v, P p)
将一个 visitor 应用到此元素。

javax.lang.model.util 中 ElementVisitor 的使用

实现 ElementVisitor 的 javax.lang.model.util 中的类
class | AbstractElementVisitor6<R,P> 程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | ElementKindVisitor6<R,P> 基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | ElementScanner6<R,P> 程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleElementVisitor6<R,P> 程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.element.ExecutableElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.ExecutableElement
的使用

使用 ExecutableElement 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 中 ExecutableElement 的使用

参数类型为 ExecutableElement 的 javax.annotation.processing 中的方法
Iterable<? extends Completion> | AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Iterable<? extends Completion> | Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。

javax.lang.model.element 中 ExecutableElement 的使用

返回变量类型为 ExecutableElement 的类型的 javax.lang.model.element 中的方法
 Map<? extends ExecutableElement,? extends AnnotationValue> AnnotationMirror.getElementValues()
返回此注释元素的值。

参数类型为 ExecutableElement 的 javax.lang.model.element 中的方法
 R ElementVisitor.visitExecutable(ExecutableElement e, P p)
访问 executable 元素。

javax.lang.model.util 中 ExecutableElement 的使用

返回变量类型为 ExecutableElement 的类型的 javax.lang.model.util 中的方法
static List<ExecutableElement> | ElementFilter.constructorsIn(Iterable<? extends Element> elements) elements 中构造方法的列表。
static Set<ExecutableElement> | ElementFilter.constructorsIn(Set<? extends Element> elements) 返回 elements 中构造方法的集合。
Map<? extends ExecutableElement,? extends AnnotationValue> | Elements.getElementValuesWithDefaults(AnnotationMirror a) 返回注释元素的值，包括默认值。
static List<ExecutableElement> | ElementFilter.methodsIn(Iterable<? extends Element> elements) 返回 elements 中方法的列表。
static Set<ExecutableElement> | ElementFilter.methodsIn(Set<? extends Element> elements) 返回 elements 中方法的集合。

参数类型为 ExecutableElement 的 javax.lang.model.util 中的方法
boolean | Elements.overrides(ExecutableElement overrider, ExecutableElement overridden, TypeElement type) 测试一个方法（作为给定类型的成员）是否重写了另一个方法。
R | ElementKindVisitor6.visitExecutable(ExecutableElement e, P p) 访问 executable 元素，指派给用于特定的 executable 种类 CONSTRUCTOR、INSTANCE_INIT、METHOD 或 STATIC_INIT 的 visit 方法。
R | ElementScanner6.visitExecutable(ExecutableElement e, P p) 访问 executable 元素。
R | SimpleElementVisitor6.visitExecutable(ExecutableElement e, P p) 访问 executable 元素。
R | ElementKindVisitor6.visitExecutableAsConstructor(ExecutableElement e, P p) 通过调用 defaultAction 访问 CONSTRUCTOR executable 元素。
R | ElementKindVisitor6.visitExecutableAsInstanceInit(ExecutableElement e, P p) 通过调用 defaultAction 访问 INSTANCE_INIT executable 元素。
R | ElementKindVisitor6.visitExecutableAsMethod(ExecutableElement e, P p) 通过调用 defaultAction 访问 METHOD executable 元素。
R | ElementKindVisitor6.visitExecutableAsStaticInit(ExecutableElement e, P p) 通过调用 defaultAction 访问 STATIC_INIT executable 元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.element.Modifier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.element.Modifier
的使用

使用 Modifier 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.lang.model.element 中 Modifier 的使用

返回 Modifier 的 javax.lang.model.element 中的方法
static Modifier | Modifier.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Modifier[] | Modifier.values() Returns an array containing the constants of this enum type, in the order they are declared.

返回变量类型为 Modifier 的类型的 javax.lang.model.element 中的方法
 Set<Modifier> Element.getModifiers()
返回此元素的修饰符，不包括注释。

javax.tools 中 Modifier 的使用

返回 Modifier 的 javax.tools 中的方法
Modifier | ForwardingJavaFileObject.getAccessLevel()
Modifier | JavaFileObject.getAccessLevel() 提供有关此文件对象表示的类的访问级别的提示。
Modifier | SimpleJavaFileObject.getAccessLevel() 此实现返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.element.Name 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.Name
的使用

使用 Name 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 Name 的使用

返回 Name 的 javax.lang.model.element 中的方法
Name | PackageElement.getQualifiedName() 返回此包的完全限定名称。
Name | TypeElement.getQualifiedName() 返回此类型元素的完全限定名称。
Name | Element.getSimpleName() 返回此元素的简单（未限定）名称。

javax.lang.model.util 中 Name 的使用

返回 Name 的 javax.lang.model.util 中的方法
Name | Elements.getBinaryName(TypeElement type) 返回类型元素的二进制名称。
Name | Elements.getName(CharSequence cs) 返回与参数具有相同字符序列的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.element.NestingKind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.element.NestingKind
的使用

使用 NestingKind 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.lang.model.element 中 NestingKind 的使用

返回 NestingKind 的 javax.lang.model.element 中的方法
NestingKind | TypeElement.getNestingKind() 返回此类型元素的嵌套种类 (nesting kind)。
static NestingKind | NestingKind.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static NestingKind[] | NestingKind.values() Returns an array containing the constants of this enum type, in the order they are declared.

javax.tools 中 NestingKind 的使用

返回 NestingKind 的 javax.tools 中的方法
NestingKind | ForwardingJavaFileObject.getNestingKind()
NestingKind | JavaFileObject.getNestingKind() 提供有关此文件对象表示的类的嵌套层次的提示。
NestingKind | SimpleJavaFileObject.getNestingKind() 此实现返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.element.PackageElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.PackageElement
的使用

使用 PackageElement 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 PackageElement 的使用

参数类型为 PackageElement 的 javax.lang.model.element 中的方法
 R ElementVisitor.visitPackage(PackageElement e, P p)
访问包元素。

javax.lang.model.util 中 PackageElement 的使用

返回 PackageElement 的 javax.lang.model.util 中的方法
PackageElement | Elements.getPackageElement(CharSequence name) 返回已给出其完全限定名称的包。
PackageElement | Elements.getPackageOf(Element type) 返回元素的包。

返回变量类型为 PackageElement 的类型的 javax.lang.model.util 中的方法
static List<PackageElement> | ElementFilter.packagesIn(Iterable<? extends Element> elements) 返回 elements 中包的列表。
static Set<PackageElement> | ElementFilter.packagesIn(Set<? extends Element> elements) 返回 elements 中包的集合。

参数类型为 PackageElement 的 javax.lang.model.util 中的方法
R | ElementKindVisitor6.visitPackage(PackageElement e, P p) 访问包元素。
R | ElementScanner6.visitPackage(PackageElement e, P p) 访问包元素。
R | SimpleElementVisitor6.visitPackage(PackageElement e, P p) 访问包元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.element.TypeElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.TypeElement
的使用

使用 TypeElement 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 中 TypeElement 的使用

参数类型为 TypeElement 的 javax.annotation.processing 中的方法
 Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith(TypeElement a)
返回使用给定注释类型注释的元素。

类型变量类型为 TypeElement 的 javax.annotation.processing 中的方法参数
abstract boolean | AbstractProcessor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
boolean | Processor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。

javax.lang.model.element 中 TypeElement 的使用

参数类型为 TypeElement 的 javax.lang.model.element 中的方法
 R ElementVisitor.visitType(TypeElement e, P p)
访问类型元素。

javax.lang.model.util 中 TypeElement 的使用

返回 TypeElement 的 javax.lang.model.util 中的方法
TypeElement | Types.boxedClass(PrimitiveType p) 返回给定基本类型的装箱 (boxed) 值类型的类。
TypeElement | Elements.getTypeElement(CharSequence name) 返回已给出其规范名称的类型元素。

返回变量类型为 TypeElement 的类型的 javax.lang.model.util 中的方法
static List<TypeElement> | ElementFilter.typesIn(Iterable<? extends Element> elements) 返回 elements 中类型的列表。
static Set<TypeElement> | ElementFilter.typesIn(Set<? extends Element> elements) 返回 elements 中类型的集合。

参数类型为 TypeElement 的 javax.lang.model.util 中的方法
List<? extends Element> | Elements.getAllMembers(TypeElement type) 返回类型元素的所有成员，不管是继承的还是直接声明的。
Name | Elements.getBinaryName(TypeElement type) 返回类型元素的二进制名称。
DeclaredType | Types.getDeclaredType(DeclaredType containing, TypeElement typeElem, TypeMirror... typeArgs) 根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
DeclaredType | Types.getDeclaredType(TypeElement typeElem, TypeMirror... typeArgs) 返回对应于类型元素和实际类型参数的类型。
boolean | Elements.overrides(ExecutableElement overrider, ExecutableElement overridden, TypeElement type) 测试一个方法（作为给定类型的成员）是否重写了另一个方法。
R | ElementKindVisitor6.visitType(TypeElement e, P p) 访问类型元素，指派给用于特定的类型种类 ANNOTATION_TYPE、CLASS、ENUM 或 INTERFACE 的 visit 方法。
R | ElementScanner6.visitType(TypeElement e, P p) 访问类型元素。
R | SimpleElementVisitor6.visitType(TypeElement e, P p) 访问类型元素。
R | ElementKindVisitor6.visitTypeAsAnnotationType(TypeElement e, P p) 通过调用 defaultAction 访问 ANNOTATION_TYPE 类型元素。
R | ElementKindVisitor6.visitTypeAsClass(TypeElement e, P p) 通过调用 defaultAction 访问 CLASS 类型元素。
R | ElementKindVisitor6.visitTypeAsEnum(TypeElement e, P p) 通过调用 defaultAction 访问 ENUM 类型元素。
R | ElementKindVisitor6.visitTypeAsInterface(TypeElement e, P p) 通过调用 defaultAction 访问 INTERFACE 类型元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.element.TypeParameterElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.TypeParameterElement
的使用

使用 TypeParameterElement 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 TypeParameterElement 的使用

返回变量类型为 TypeParameterElement 的类型的 javax.lang.model.element 中的方法
List<? extends TypeParameterElement> | ExecutableElement.getTypeParameters() 按照声明顺序返回此 executable 的形式类型参数。
List<? extends TypeParameterElement> | TypeElement.getTypeParameters() 按照声明顺序返回此类型元素的形式类型参数。

参数类型为 TypeParameterElement 的 javax.lang.model.element 中的方法
 R ElementVisitor.visitTypeParameter(TypeParameterElement e, P p)
访问类型参数元素。

javax.lang.model.util 中 TypeParameterElement 的使用

参数类型为 TypeParameterElement 的 javax.lang.model.util 中的方法
R | ElementKindVisitor6.visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。
R | ElementScanner6.visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。
R | SimpleElementVisitor6.visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.element.UnknownAnnotationValueException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.element.UnknownAnnotationValueException
的使用

没有 javax.lang.model.element.UnknownAnnotationValueException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.element.UnknownElementException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.element.UnknownElementException
的使用

没有 javax.lang.model.element.UnknownElementException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.element.VariableElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.VariableElement
的使用

使用 VariableElement 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 VariableElement 的使用

返回变量类型为 VariableElement 的类型的 javax.lang.model.element 中的方法
 List<? extends VariableElement> ExecutableElement.getParameters()
返回此 executable 的形参。

参数类型为 VariableElement 的 javax.lang.model.element 中的方法
R | AnnotationValueVisitor.visitEnumConstant(VariableElement c, P p) 访问注释中的 enum 值。
R | ElementVisitor.visitVariable(VariableElement e, P p) 访问变量元素。

javax.lang.model.util 中 VariableElement 的使用

返回变量类型为 VariableElement 的类型的 javax.lang.model.util 中的方法
static List<VariableElement> | ElementFilter.fieldsIn(Iterable<? extends Element> elements) 返回 elements 中字段的列表。
static Set<VariableElement> | ElementFilter.fieldsIn(Set<? extends Element> elements) 返回 elements 中字段的集合。

参数类型为 VariableElement 的 javax.lang.model.util 中的方法
R | SimpleAnnotationValueVisitor6.visitEnumConstant(VariableElement c, P p) 访问注释中的 enum 值。
R | ElementKindVisitor6.visitVariable(VariableElement e, P p) 访问变量元素，指派给用于特定的变量种类 ENUM_CONSTANT、EXCEPTION_PARAMETER、FIELD、LOCAL_VARIABLE 或 PARAMETER 的 visit 方法。
R | ElementScanner6.visitVariable(VariableElement e, P p) 访问变量元素。
R | SimpleElementVisitor6.visitVariable(VariableElement e, P p) 访问变量元素。
R | ElementKindVisitor6.visitVariableAsEnumConstant(VariableElement e, P p) 通过调用 defaultAction 访问 ENUM_CONSTANT 变量元素。
R | ElementKindVisitor6.visitVariableAsExceptionParameter(VariableElement e, P p) 通过调用 defaultAction 访问 EXCEPTION_PARAMETER 变量元素。
R | ElementKindVisitor6.visitVariableAsField(VariableElement e, P p) 通过调用 defaultAction 访问 FIELD 变量元素。
R | ElementKindVisitor6.visitVariableAsLocalVariable(VariableElement e, P p) 通过调用 defaultAction 访问 LOCAL_VARIABLE 变量元素。
R | ElementKindVisitor6.visitVariableAsParameter(VariableElement e, P p) 通过调用 defaultAction 访问 PARAMETER 变量元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.lang.model.type (Java 2 Platform SE 6)

 javax.lang.model.type
接口
ArrayType
DeclaredType
ErrorType
ExecutableType
NoType
NullType
PrimitiveType
ReferenceType
TypeMirror
TypeVariable
TypeVisitor
WildcardType
枚举
TypeKind
异常
MirroredTypeException
MirroredTypesException
UnknownTypeException


接口 javax.lang.model.type.ArrayType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.ArrayType
的使用

使用 ArrayType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 ArrayType 的使用

参数类型为 ArrayType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitArray(ArrayType t, P p)
访问数组类型。

javax.lang.model.util 中 ArrayType 的使用

返回 ArrayType 的 javax.lang.model.util 中的方法
 ArrayType Types.getArrayType(TypeMirror componentType)
返回具有指定组件类型的数组类型。

参数类型为 ArrayType 的 javax.lang.model.util 中的方法
 R SimpleTypeVisitor6.visitArray(ArrayType t, P p)
访问数组类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.DeclaredType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.DeclaredType
的使用

使用 DeclaredType 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 DeclaredType 的使用

返回 DeclaredType 的 javax.lang.model.element 中的方法
 DeclaredType AnnotationMirror.getAnnotationType()
返回此注释的类型。

javax.lang.model.type 中 DeclaredType 的使用

javax.lang.model.type 中 DeclaredType 的子接口
 interface ErrorType
表示无法正常建模的类或接口类型。

参数类型为 DeclaredType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitDeclared(DeclaredType t, P p)
访问已声明的类型。

javax.lang.model.util 中 DeclaredType 的使用

返回 DeclaredType 的 javax.lang.model.util 中的方法
DeclaredType | Types.getDeclaredType(DeclaredType containing, TypeElement typeElem, TypeMirror... typeArgs) 根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
DeclaredType | Types.getDeclaredType(TypeElement typeElem, TypeMirror... typeArgs) 返回对应于类型元素和实际类型参数的类型。

参数类型为 DeclaredType 的 javax.lang.model.util 中的方法
TypeMirror | Types.asMemberOf(DeclaredType containing, Element element) 当元素被视为给定类型的成员或者直接由给定类型包含时，返回该元素的类型。
DeclaredType | Types.getDeclaredType(DeclaredType containing, TypeElement typeElem, TypeMirror... typeArgs) 根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
R | SimpleTypeVisitor6.visitDeclared(DeclaredType t, P p) 访问已声明的类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.ErrorType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.ErrorType
的使用

使用 ErrorType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 ErrorType 的使用

参数类型为 ErrorType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitError(ErrorType t, P p)
访问错误类型。

javax.lang.model.util 中 ErrorType 的使用

参数类型为 ErrorType 的 javax.lang.model.util 中的方法
 R SimpleTypeVisitor6.visitError(ErrorType t, P p)
访问错误类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.ExecutableType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.ExecutableType
的使用

使用 ExecutableType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 ExecutableType 的使用

参数类型为 ExecutableType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitExecutable(ExecutableType t, P p)
访问 executable 类型。

javax.lang.model.util 中 ExecutableType 的使用

参数类型为 ExecutableType 的 javax.lang.model.util 中的方法
boolean | Types.isSubsignature(ExecutableType m1, ExecutableType m2) 测试一个方法的签名是否是另一个方法的子签名。
R | SimpleTypeVisitor6.visitExecutable(ExecutableType t, P p) 访问 executable 类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.type.MirroredTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.type.MirroredTypeException
的使用

没有 javax.lang.model.type.MirroredTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.type.MirroredTypesException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.type.MirroredTypesException
的使用

没有 javax.lang.model.type.MirroredTypesException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.NoType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.NoType
的使用

使用 NoType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 NoType 的使用

参数类型为 NoType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitNoType(NoType t, P p)
访问 NoType 实例。

javax.lang.model.util 中 NoType 的使用

返回 NoType 的 javax.lang.model.util 中的方法
 NoType Types.getNoType(TypeKind kind)
返回在实际类型不适用的地方所使用的伪类型。

参数类型为 NoType 的 javax.lang.model.util 中的方法
R | SimpleTypeVisitor6.visitNoType(NoType t, P p) 访问 NoType 实例。
R | TypeKindVisitor6.visitNoType(NoType t, P p) 访问 NoType 实例，指派给用于以下特定的伪类型种类的 visit 方法：VOID、PACKAGE 或 NONE。
R | TypeKindVisitor6.visitNoTypeAsNone(NoType t, P p) 通过调用 defaultAction 访问 NONE 伪类型。
R | TypeKindVisitor6.visitNoTypeAsPackage(NoType t, P p) 通过调用 defaultAction 访问 PACKAGE 伪类型。
R | TypeKindVisitor6.visitNoTypeAsVoid(NoType t, P p) 通过调用 defaultAction 访问 VOID 伪类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.NullType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.NullType
的使用

使用 NullType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 NullType 的使用

参数类型为 NullType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitNull(NullType t, P p)
访问 null 类型。

javax.lang.model.util 中 NullType 的使用

返回 NullType 的 javax.lang.model.util 中的方法
 NullType Types.getNullType()
返回 null 类型。

参数类型为 NullType 的 javax.lang.model.util 中的方法
 R SimpleTypeVisitor6.visitNull(NullType t, P p)
访问 null 类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.PrimitiveType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.PrimitiveType
的使用

使用 PrimitiveType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 PrimitiveType 的使用

参数类型为 PrimitiveType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitPrimitive(PrimitiveType t, P p)
访问基本类型。

javax.lang.model.util 中 PrimitiveType 的使用

返回 PrimitiveType 的 javax.lang.model.util 中的方法
PrimitiveType | Types.getPrimitiveType(TypeKind kind) 返回基本类型。
PrimitiveType | Types.unboxedType(TypeMirror t) 返回给定类型的拆箱 (unboxed) 值类型（基本类型）。

参数类型为 PrimitiveType 的 javax.lang.model.util 中的方法
TypeElement | Types.boxedClass(PrimitiveType p) 返回给定基本类型的装箱 (boxed) 值类型的类。
R | SimpleTypeVisitor6.visitPrimitive(PrimitiveType t, P p) 访问基本类型。
R | TypeKindVisitor6.visitPrimitive(PrimitiveType t, P p) 访问基本类型，指派给用于以下特定的基本类型种类的 visit 方法：BOOLEAN、BYTE 等。
R | TypeKindVisitor6.visitPrimitiveAsBoolean(PrimitiveType t, P p) 通过调用 defaultAction 访问 BOOLEAN 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsByte(PrimitiveType t, P p) 通过调用 defaultAction 访问 BYTE 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsChar(PrimitiveType t, P p) 通过调用 defaultAction 访问 CHAR 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsDouble(PrimitiveType t, P p) 通过调用 defaultAction 访问 DOUBLE 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsFloat(PrimitiveType t, P p) 通过调用 defaultAction 访问 FLOAT 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsInt(PrimitiveType t, P p) 通过调用 defaultAction 访问 INT 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsLong(PrimitiveType t, P p) 通过调用 defaultAction 访问 LONG 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsShort(PrimitiveType t, P p) 通过调用 defaultAction 访问 SHORT 基本类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.ReferenceType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.ReferenceType
的使用

使用 ReferenceType 的软件包
javax.lang.model.type 用来为 Java 编程语言类型建立模型的接口。

javax.lang.model.type 中 ReferenceType 的使用

javax.lang.model.type 中 ReferenceType 的子接口
interface | ArrayType 表示一个数组类型。
interface | DeclaredType 表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。
interface | ErrorType 表示无法正常建模的类或接口类型。
interface | NullType 表示 null 类型。
interface | TypeVariable 表示一个类型变量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.type.TypeKind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.type.TypeKind
的使用

使用 TypeKind 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 TypeKind 的使用

返回 TypeKind 的 javax.lang.model.type 中的方法
TypeKind | TypeMirror.getKind() 返回此类型的 kind。
static TypeKind | TypeKind.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static TypeKind[] | TypeKind.values() Returns an array containing the constants of this enum type, in the order they are declared.

javax.lang.model.util 中 TypeKind 的使用

参数类型为 TypeKind 的 javax.lang.model.util 中的方法
NoType | Types.getNoType(TypeKind kind) 返回在实际类型不适用的地方所使用的伪类型。
PrimitiveType | Types.getPrimitiveType(TypeKind kind) 返回基本类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.TypeMirror 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.TypeMirror
的使用

使用 TypeMirror 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 TypeMirror 的使用

返回 TypeMirror 的 javax.lang.model.element 中的方法
TypeMirror | Element.asType() 返回此元素定义的类型。
TypeMirror | ExecutableElement.getReturnType() 返回此 executable 的返回类型。
TypeMirror | TypeElement.getSuperclass() 返回此类型元素的直接超类。

返回变量类型为 TypeMirror 的类型的 javax.lang.model.element 中的方法
List<? extends TypeMirror> | TypeParameterElement.getBounds() 返回此类型参数的边界。
List<? extends TypeMirror> | TypeElement.getInterfaces() 返回直接由此类实现或直接由此接口扩展的接口类型。
List<? extends TypeMirror> | ExecutableElement.getThrownTypes() 按声明顺序返回此方法或构造方法的 throws 子句中所列出的异常和其他 throwable。

参数类型为 TypeMirror 的 javax.lang.model.element 中的方法
 R AnnotationValueVisitor.visitType(TypeMirror t, P p)
访问注释中的 type 值。

javax.lang.model.type 中 TypeMirror 的使用

javax.lang.model.type 中 TypeMirror 的子接口
interface | ArrayType 表示一个数组类型。
interface | DeclaredType 表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。
interface | ErrorType 表示无法正常建模的类或接口类型。
interface | ExecutableType 表示 executable 的类型。
interface | NoType 在实际类型不适合的地方使用的伪类型。
interface | NullType 表示 null 类型。
interface | PrimitiveType 表示一个基本类型。
interface | ReferenceType 表示一个引用类型。
interface | TypeVariable 表示一个类型变量。
interface | WildcardType 表示通配符类型参数。

返回 TypeMirror 的 javax.lang.model.type 中的方法
TypeMirror | ArrayType.getComponentType() 返回此数组类型的组件类型。
TypeMirror | DeclaredType.getEnclosingType() 返回封装实例的最里层类型；如果没有任何封装实例，则返回种类为 NONE 的 NoType。
TypeMirror | WildcardType.getExtendsBound() 返回此通配符的上边界。
TypeMirror | TypeVariable.getLowerBound() 返回此类型变量的下边界。
TypeMirror | ExecutableType.getReturnType() 返回此 executable 的返回类型。
TypeMirror | WildcardType.getSuperBound() 返回此通配符的下边界。
TypeMirror | MirroredTypeException.getTypeMirror() 返回对应于要访问类型的类型镜像。
TypeMirror | UnknownTypeException.getUnknownType() 返回未知类型。
TypeMirror | TypeVariable.getUpperBound() 返回此类型变量的上边界。

返回变量类型为 TypeMirror 的类型的 javax.lang.model.type 中的方法
List<? extends TypeMirror> | ExecutableType.getParameterTypes() 返回此 executable 的形参类型。
List<? extends TypeMirror> | ExecutableType.getThrownTypes() 返回此 executable 的 throws 子句中列出的异常和其他 throwable。
List<? extends TypeMirror> | DeclaredType.getTypeArguments() 返回此类型的实际类型参数。
List<? extends TypeMirror> | MirroredTypesException.getTypeMirrors() 返回对应于要访问的类型的类型镜像。

参数类型为 TypeMirror 的 javax.lang.model.type 中的方法
 R TypeVisitor.visit(TypeMirror t)
等效于 v.visit(t, null) 的便捷方法。
 R TypeVisitor.visit(TypeMirror t, P p)
访问一个类型。
 R TypeVisitor.visitUnknown(TypeMirror t, P p)
访问未知种类的类型。

参数类型为 TypeMirror 的 javax.lang.model.type 中的构造方法
MirroredTypeException(TypeMirror type)
构造一个针对指定类型的新 MirroredTypeException。
UnknownTypeException(TypeMirror t, Object p)
创建一个新的 UnknownTypeException。

类型变量类型为 TypeMirror 的 javax.lang.model.type 中的构造方法参数
MirroredTypesException(List<? extends TypeMirror> types)
构造一个针对指定类型的新 MirroredTypesException。

javax.lang.model.util 中 TypeMirror 的使用

返回 TypeMirror 的 javax.lang.model.util 中的方法
TypeMirror | Types.asMemberOf(DeclaredType containing, Element element) 当元素被视为给定类型的成员或者直接由给定类型包含时，返回该元素的类型。
TypeMirror | Types.capture(TypeMirror t) 对类型应用 capture 转换。
TypeMirror | Types.erasure(TypeMirror t) 返回删除状态的类型。

返回变量类型为 TypeMirror 的类型的 javax.lang.model.util 中的方法
 List<? extends TypeMirror> Types.directSupertypes(TypeMirror t)
返回类型的直接超类型。

参数类型为 TypeMirror 的 javax.lang.model.util 中的方法
Element | Types.asElement(TypeMirror t) 返回对应于类型的元素。
TypeMirror | Types.capture(TypeMirror t) 对类型应用 capture 转换。
boolean | Types.contains(TypeMirror t1, TypeMirror t2) 测试一个类型参数是否包含 另一个类型参数。
protected R | SimpleTypeVisitor6.defaultAction(TypeMirror e, P p) visit 方法的默认动作。
List<? extends TypeMirror> | Types.directSupertypes(TypeMirror t) 返回类型的直接超类型。
TypeMirror | Types.erasure(TypeMirror t) 返回删除状态的类型。
ArrayType | Types.getArrayType(TypeMirror componentType) 返回具有指定组件类型的数组类型。
DeclaredType | Types.getDeclaredType(DeclaredType containing, TypeElement typeElem, TypeMirror... typeArgs) 根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
DeclaredType | Types.getDeclaredType(TypeElement typeElem, TypeMirror... typeArgs) 返回对应于类型元素和实际类型参数的类型。
WildcardType | Types.getWildcardType(TypeMirror extendsBound, TypeMirror superBound) 返回新的通配符类型参数。
boolean | Types.isAssignable(TypeMirror t1, TypeMirror t2) 测试一种类型是否可以指派给另一种类型。
boolean | Types.isSameType(TypeMirror t1, TypeMirror t2) 测试两个 TypeMirror 对象是否表示同一类型。
boolean | Types.isSubtype(TypeMirror t1, TypeMirror t2) 测试一种类型是否是另一个类型的子类型。
PrimitiveType | Types.unboxedType(TypeMirror t) 返回给定类型的拆箱 (unboxed) 值类型（基本类型）。
R | AbstractTypeVisitor6.visit(TypeMirror t) 访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法，并为附加参数传递 null 一样。
R | AbstractTypeVisitor6.visit(TypeMirror t, P p) 访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法一样。
R | SimpleAnnotationValueVisitor6.visitType(TypeMirror t, P p) 访问注释中的 type 值。
R | AbstractTypeVisitor6.visitUnknown(TypeMirror t, P p) 访问未知种类的类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.TypeVariable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.TypeVariable
的使用

使用 TypeVariable 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 TypeVariable 的使用

返回变量类型为 TypeVariable 的类型的 javax.lang.model.type 中的方法
 List<? extends TypeVariable> ExecutableType.getTypeVariables()
返回由此 executable 的形式类型参数所声明的类型变量。

参数类型为 TypeVariable 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitTypeVariable(TypeVariable t, P p)
访问类型变量。

javax.lang.model.util 中 TypeVariable 的使用

参数类型为 TypeVariable 的 javax.lang.model.util 中的方法
 R SimpleTypeVisitor6.visitTypeVariable(TypeVariable t, P p)
访问类型变量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.TypeVisitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.TypeVisitor
的使用

使用 TypeVisitor 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 TypeVisitor 的使用

参数类型为 TypeVisitor 的 javax.lang.model.type 中的方法
<R,P> R
TypeMirror.accept(TypeVisitor<R,P> v, P p)
将一个 visitor 应用于此类型。

javax.lang.model.util 中 TypeVisitor 的使用

实现 TypeVisitor 的 javax.lang.model.util 中的类
class | AbstractTypeVisitor6<R,P> 类型的骨干 visitor，具有适用于第 6 版语言级别的默认行为。
class | SimpleTypeVisitor6<R,P> 类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | TypeKindVisitor6<R,P> 基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.type.UnknownTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.type.UnknownTypeException
的使用

没有 javax.lang.model.type.UnknownTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.type.WildcardType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.WildcardType
的使用

使用 WildcardType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 WildcardType 的使用

参数类型为 WildcardType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitWildcard(WildcardType t, P p)
访问通配符类型。

javax.lang.model.util 中 WildcardType 的使用

返回 WildcardType 的 javax.lang.model.util 中的方法
 WildcardType Types.getWildcardType(TypeMirror extendsBound, TypeMirror superBound)
返回新的通配符类型参数。

参数类型为 WildcardType 的 javax.lang.model.util 中的方法
 R SimpleTypeVisitor6.visitWildcard(WildcardType t, P p)
访问通配符类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.lang.model.util (Java 2 Platform SE 6)

 javax.lang.model.util
接口
Elements
Types
类
AbstractAnnotationValueVisitor6
AbstractElementVisitor6
AbstractTypeVisitor6
ElementFilter
ElementKindVisitor6
ElementScanner6
SimpleAnnotationValueVisitor6
SimpleElementVisitor6
SimpleTypeVisitor6
TypeKindVisitor6


类 javax.lang.model.util.AbstractAnnotationValueVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.AbstractAnnotationValueVisitor6
的使用

使用 AbstractAnnotationValueVisitor6 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 AbstractAnnotationValueVisitor6 的使用

javax.lang.model.util 中 AbstractAnnotationValueVisitor6 的子类
 class SimpleAnnotationValueVisitor6<R,P>
注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.util.AbstractElementVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.AbstractElementVisitor6
的使用

使用 AbstractElementVisitor6 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 AbstractElementVisitor6 的使用

javax.lang.model.util 中 AbstractElementVisitor6 的子类
class | ElementKindVisitor6<R,P> 基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | ElementScanner6<R,P> 程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleElementVisitor6<R,P> 程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.util.AbstractTypeVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.AbstractTypeVisitor6
的使用

使用 AbstractTypeVisitor6 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 AbstractTypeVisitor6 的使用

javax.lang.model.util 中 AbstractTypeVisitor6 的子类
class | SimpleTypeVisitor6<R,P> 类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | TypeKindVisitor6<R,P> 基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.util.ElementFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.ElementFilter
的使用

没有 javax.lang.model.util.ElementFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.util.ElementKindVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.ElementKindVisitor6
的使用

没有 javax.lang.model.util.ElementKindVisitor6 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.util.Elements 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.util.Elements
的使用

使用 Elements 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 Elements 的使用

返回 Elements 的 javax.annotation.processing 中的方法
 Elements ProcessingEnvironment.getElementUtils()
返回用来在元素上进行操作的某些实用工具方法的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.util.ElementScanner6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.ElementScanner6
的使用

没有 javax.lang.model.util.ElementScanner6 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.util.SimpleAnnotationValueVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.SimpleAnnotationValueVisitor6
的使用

没有 javax.lang.model.util.SimpleAnnotationValueVisitor6 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.util.SimpleElementVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.SimpleElementVisitor6
的使用

使用 SimpleElementVisitor6 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 SimpleElementVisitor6 的使用

javax.lang.model.util 中 SimpleElementVisitor6 的子类
 class ElementKindVisitor6<R,P>
基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.util.SimpleTypeVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.SimpleTypeVisitor6
的使用

使用 SimpleTypeVisitor6 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 SimpleTypeVisitor6 的使用

javax.lang.model.util 中 SimpleTypeVisitor6 的子类
 class TypeKindVisitor6<R,P>
基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.lang.model.util.TypeKindVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.TypeKindVisitor6
的使用

没有 javax.lang.model.util.TypeKindVisitor6 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.lang.model.util.Types 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.util.Types
的使用

使用 Types 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 Types 的使用

返回 Types 的 javax.annotation.processing 中的方法
 Types ProcessingEnvironment.getTypeUtils()
返回用来在类型上进行操作的某些实用工具方法的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.management (Java 2 Platform SE 6)

 javax.management
接口
Descriptor
DescriptorAccess
DescriptorRead
DynamicMBean
MBeanRegistration
MBeanServer
MBeanServerConnection
MBeanServerDelegateMBean
NotificationBroadcaster
NotificationEmitter
NotificationFilter
NotificationListener
PersistentMBean
QueryExp
ValueExp
类
Attribute
AttributeChangeNotification
AttributeChangeNotificationFilter
AttributeList
AttributeValueExp
DefaultLoaderRepository
ImmutableDescriptor
JMX
MBeanAttributeInfo
MBeanConstructorInfo
MBeanFeatureInfo
MBeanInfo
MBeanNotificationInfo
MBeanOperationInfo
MBeanParameterInfo
MBeanPermission
MBeanServerBuilder
MBeanServerDelegate
MBeanServerFactory
MBeanServerInvocationHandler
MBeanServerNotification
MBeanServerPermission
MBeanTrustPermission
Notification
NotificationBroadcasterSupport
NotificationFilterSupport
ObjectInstance
ObjectName
Query
QueryEval
StandardEmitterMBean
StandardMBean
StringValueExp
异常
AttributeNotFoundException
BadAttributeValueExpException
BadBinaryOpValueExpException
BadStringOperationException
InstanceAlreadyExistsException
InstanceNotFoundException
IntrospectionException
InvalidApplicationException
InvalidAttributeValueException
JMException
JMRuntimeException
ListenerNotFoundException
MalformedObjectNameException
MBeanException
MBeanRegistrationException
NotCompliantMBeanException
OperationsException
ReflectionException
RuntimeErrorException
RuntimeMBeanException
RuntimeOperationsException
ServiceNotFoundException
注释类型
DescriptorKey
MXBean


类 javax.management.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.Attribute
的使用

使用 Attribute 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

javax.management 中 Attribute 的使用

返回变量类型为 Attribute 的类型的 javax.management 中的方法
 List<Attribute> AttributeList.asList()
以 List<Attribute> 的形式返回此列表的视图。

参数类型为 Attribute 的 javax.management 中的方法
void | AttributeList.add(Attribute object) 添加指定的 Attribute 作为列表的最后一个元素。
void | AttributeList.add(int index, Attribute object) 插入指定的属性作为指定位置处的元素。
void | AttributeList.set(int index, Attribute object) 将指定位置的元素设置为指定的属性。
void | DynamicMBean.setAttribute(Attribute attribute) 设置 Dynamic MBean 的特定属性的值。
void | StandardMBean.setAttribute(Attribute attribute)
void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。

类型变量类型为 Attribute 的 javax.management 中的构造方法参数
AttributeList(List<Attribute> list)
构造一个包含指定 List 的元素的 AttributeList，这些元素按 List 的迭代器返回的顺序排列。

javax.management.modelmbean 中 Attribute 的使用

参数类型为 Attribute 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(Attribute oldValue, Attribute newValue) 将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(Attribute inOldVal, Attribute inNewVal)
void | RequiredModelMBean.setAttribute(Attribute attribute) 设置指定的 ModelMBean 的指定属性值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.AttributeChangeNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.AttributeChangeNotification
的使用

使用 AttributeChangeNotification 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 AttributeChangeNotification 的使用

参数类型为 AttributeChangeNotification 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(AttributeChangeNotification notification) 将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.AttributeChangeNotificationFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.AttributeChangeNotificationFilter
的使用

没有 javax.management.AttributeChangeNotificationFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.AttributeList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.AttributeList
的使用

使用 AttributeList 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 AttributeList 的使用

返回 AttributeList 的 javax.management 中的方法
AttributeList | MBeanServer.getAttributes(ObjectName name, String[] attributes)
AttributeList | MBeanServerConnection.getAttributes(ObjectName name, String[] attributes) 获得指定 MBean 的多个属性值。
AttributeList | DynamicMBean.getAttributes(String[] attributes) 获得 Dynamic MBean 多个属性的值。
AttributeList | StandardMBean.getAttributes(String[] attributes)
AttributeList | DynamicMBean.setAttributes(AttributeList attributes) 设置 Dynamic MBean 多个属性的值。
AttributeList | StandardMBean.setAttributes(AttributeList attributes)
AttributeList | MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
AttributeList | MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes) 设置指定 MBean 的多个属性值。

参数类型为 AttributeList 的 javax.management 中的方法
boolean | AttributeList.addAll(AttributeList list) 将指定 AttributeList 中的所有元素追加到列表的末尾，元素的顺序是指定 AttributeList 的 Iterator 所返回的顺序。
boolean | AttributeList.addAll(int index, AttributeList list) 将指定 AttributeList 中的所有元素插入此列表，从指定的位置开始插入，元素的顺序是指定 Attribute 的 Iterator 所返回的顺序。
AttributeList | DynamicMBean.setAttributes(AttributeList attributes) 设置 Dynamic MBean 多个属性的值。
AttributeList | StandardMBean.setAttributes(AttributeList attributes)
AttributeList | MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
AttributeList | MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes) 设置指定 MBean 的多个属性值。

参数类型为 AttributeList 的 javax.management 中的构造方法
AttributeList(AttributeList list)
构造一个包含指定 AttributeList 元素的 AttributeList，元素的顺序是该 AttributeList 的迭代器所返回的顺序。

javax.management.modelmbean 中 AttributeList 的使用

返回 AttributeList 的 javax.management.modelmbean 中的方法
AttributeList | RequiredModelMBean.getAttributes(String[] attrNames) 返回 ModelMBean 中几个属性的值。
AttributeList | RequiredModelMBean.setAttributes(AttributeList attributes) 设置此 ModelMBean 的属性数组的值。

参数类型为 AttributeList 的 javax.management.modelmbean 中的方法
 AttributeList RequiredModelMBean.setAttributes(AttributeList attributes)
设置此 ModelMBean 的属性数组的值。

javax.management.remote.rmi 中 AttributeList 的使用

返回 AttributeList 的 javax.management.remote.rmi 中的方法
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.AttributeNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.AttributeNotFoundException
的使用

使用 AttributeNotFoundException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 AttributeNotFoundException 的使用

抛出 AttributeNotFoundException 的 javax.management 中的方法
Object | MBeanServer.getAttribute(ObjectName name, String attribute)
Object | MBeanServerConnection.getAttribute(ObjectName name, String attribute) 获得指定 MBean 的特定属性值。
Object | DynamicMBean.getAttribute(String attribute) 获得 Dynamic MBean 的特定属性的值。
Object | StandardMBean.getAttribute(String attribute)
void | DynamicMBean.setAttribute(Attribute attribute) 设置 Dynamic MBean 的特定属性的值。
void | StandardMBean.setAttribute(Attribute attribute)
void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。

javax.management.modelmbean 中 AttributeNotFoundException 的使用

抛出 AttributeNotFoundException 的 javax.management.modelmbean 中的方法
Object | RequiredModelMBean.getAttribute(String attrName) 返回为此 ModelMBean 定义的指定属性的值。
void | RequiredModelMBean.setAttribute(Attribute attribute) 设置指定的 ModelMBean 的指定属性值。

javax.management.remote.rmi 中 AttributeNotFoundException 的使用

抛出 AttributeNotFoundException 的 javax.management.remote.rmi 中的方法
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.AttributeValueExp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.AttributeValueExp
的使用

使用 AttributeValueExp 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 AttributeValueExp 的使用

返回 AttributeValueExp 的 javax.management 中的方法
static AttributeValueExp | Query.attr(String name) 返回新的属性表达式。
static AttributeValueExp | Query.attr(String className, String name) 返回新的限定属性表达式。
static AttributeValueExp | Query.classattr() 返回一个新的类属性表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

参数类型为 AttributeValueExp 的 javax.management 中的方法
static QueryExp | Query.anySubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.finalSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.initialSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.match(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的匹配约束条件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.BadAttributeValueExpException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.BadAttributeValueExpException
的使用

使用 BadAttributeValueExpException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 BadAttributeValueExpException 的使用

抛出 BadAttributeValueExpException 的 javax.management 中的方法
ValueExp | AttributeValueExp.apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
boolean | QueryExp.apply(ObjectName name) 在 MBean 上应用 QueryExp。
ValueExp | StringValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
ValueExp | ValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.BadBinaryOpValueExpException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.BadBinaryOpValueExpException
的使用

使用 BadBinaryOpValueExpException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 BadBinaryOpValueExpException 的使用

抛出 BadBinaryOpValueExpException 的 javax.management 中的方法
ValueExp | AttributeValueExp.apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
boolean | QueryExp.apply(ObjectName name) 在 MBean 上应用 QueryExp。
ValueExp | StringValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
ValueExp | ValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.BadStringOperationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.BadStringOperationException
的使用

使用 BadStringOperationException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 BadStringOperationException 的使用

抛出 BadStringOperationException 的 javax.management 中的方法
ValueExp | AttributeValueExp.apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
boolean | QueryExp.apply(ObjectName name) 在 MBean 上应用 QueryExp。
ValueExp | StringValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
ValueExp | ValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.DefaultLoaderRepository 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.DefaultLoaderRepository
的使用

没有 javax.management.DefaultLoaderRepository 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.Descriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.Descriptor
的使用

使用 Descriptor 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 Descriptor 的使用

实现 Descriptor 的 javax.management 中的类
 class ImmutableDescriptor
不可变的描述符。

返回 Descriptor 的 javax.management 中的方法
Descriptor | ImmutableDescriptor.clone() 返回一个与此描述符相等的描述符。
Descriptor | DescriptorRead.getDescriptor() 返回 Descriptor 的副本。
Descriptor | MBeanFeatureInfo.getDescriptor() 返回该功能的描述符。
Descriptor | MBeanInfo.getDescriptor() 获取此 MBean 的描述符。

参数类型为 Descriptor 的 javax.management 中的方法
void | DescriptorAccess.setDescriptor(Descriptor inDescriptor) 设置 Descriptor（完全替换）。
static ImmutableDescriptor | ImmutableDescriptor.union(Descriptor... descriptors) 返回一个 ImmutableDescriptor，其内容是给定描述符的并集。

参数类型为 Descriptor 的 javax.management 中的构造方法
MBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 MBeanAttributeInfo 对象。
MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 MBeanConstructorInfo 对象。
MBeanFeatureInfo(String name, String description, Descriptor descriptor)
构造一个 MBeanFeatureInfo 对象。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。
MBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造一个 MBeanNotificationInfo 对象。
MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造一个 MBeanOperationInfo 对象。
MBeanParameterInfo(String name, String type, String description, Descriptor descriptor)
构造一个 MBeanParameterInfo 对象。

javax.management.modelmbean 中 Descriptor 的使用

实现 Descriptor 的 javax.management.modelmbean 中的类
 class DescriptorSupport
此类表示 ModelMBean 元素的元数据集。

返回 Descriptor 的 javax.management.modelmbean 中的方法
Descriptor | ModelMBeanAttributeInfo.getDescriptor() 获取 ModelMBeanAttributeInfo 的关联 Descriptor 的副本。
Descriptor | ModelMBeanConstructorInfo.getDescriptor() 返回关联 Descriptor 的副本。
Descriptor | ModelMBeanInfoSupport.getDescriptor()
Descriptor | ModelMBeanNotificationInfo.getDescriptor() 返回 ModelMBeanNotificationInfo 的关联 Descriptor 的副本。
Descriptor | ModelMBeanOperationInfo.getDescriptor() 返回 ModelMBeanOperationInfo 的关联 Descriptor 的副本。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName) 返回通过名称请求的 Descriptor。
Descriptor | ModelMBeanInfo.getDescriptor(String inDescriptorName, String inDescriptorType) 返回通过 name 和 descriptorType 请求的 Descriptor。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName, String inDescriptorType)
Descriptor[] | ModelMBeanInfo.getDescriptors(String inDescriptorType) 返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。
Descriptor[] | ModelMBeanInfoSupport.getDescriptors(String inDescriptorType)
Descriptor | ModelMBeanInfo.getMBeanDescriptor() 返回包含 MBean 级策略的 ModelMBean 的描述符。
Descriptor | ModelMBeanInfoSupport.getMBeanDescriptor()

参数类型为 Descriptor 的 javax.management.modelmbean 中的方法
void | ModelMBeanAttributeInfo.setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanAttributeDescriptor 的关联 Descriptor（完全取代）。
void | ModelMBeanConstructorInfo.setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanConstructorInfo 的关联 Descriptor（完全替换）。
void | ModelMBeanNotificationInfo.setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanNotificationInfo 的关联 Descriptor（完全替换）。
void | ModelMBeanOperationInfo.setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanOperationInfo 的关联 Descriptor（完全取代）。
void | ModelMBeanInfo.setDescriptor(Descriptor inDescriptor, String inDescriptorType) 设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。
void | ModelMBeanInfoSupport.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
void | ModelMBeanInfo.setDescriptors(Descriptor[] inDescriptors) 添加或替换 ModelMBeanInfo 中的描述符。
void | ModelMBeanInfoSupport.setDescriptors(Descriptor[] inDescriptors)
void | ModelMBeanInfo.setMBeanDescriptor(Descriptor inDescriptor) 设置 ModelMBean 的描述符。
void | ModelMBeanInfoSupport.setMBeanDescriptor(Descriptor inMBeanDescriptor)

参数类型为 Descriptor 的 javax.management.modelmbean 中的构造方法
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter, Descriptor descriptor)
构造 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanConstructorInfo(String description, Constructor constructorMethod, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。
ModelMBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造 ModelMBeanNotificationInfo 对象。
ModelMBeanOperationInfo(String description, Method operationMethod, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

javax.management.openmbean 中 Descriptor 的使用

参数类型为 Descriptor 的 javax.management.openmbean 中的构造方法
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、读/写访问属性和 Descriptor 来描述 open MBean 的属性。
OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description、signature 和 descriptor 来描述 open MBean 类的构造方法。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType, Descriptor descriptor)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 descriptor 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.DescriptorAccess 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.DescriptorAccess
的使用

使用 DescriptorAccess 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 DescriptorAccess 的使用

实现 DescriptorAccess 的 javax.management.modelmbean 中的类
class | ModelMBeanAttributeInfo ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
class | ModelMBeanConstructorInfo ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
class | ModelMBeanNotificationInfo ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
class | ModelMBeanOperationInfo ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.DescriptorKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.DescriptorKey
的使用

没有 javax.management.DescriptorKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.DescriptorRead 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.DescriptorRead
的使用

使用 DescriptorRead 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 DescriptorRead 的使用

javax.management 中 DescriptorRead 的子接口
 interface DescriptorAccess
此接口用于获得对 Descriptor 类的描述符的访问，这些 Descriptor 类与某个 JMX 组件相关联，比如 MBean、MBeanInfo、MBeanAttributeInfo、MBeanNotificationInfo、MBeanOperationInfo 和 MBeanParameterInfo。

实现 DescriptorRead 的 javax.management 中的类
class | MBeanAttributeInfo 描述出于管理目的而公开的 MBean 属性。
class | MBeanConstructorInfo 描述 MBean 所公开的构造方法。
class | MBeanFeatureInfo 提供 MBean 描述符对象的常规信息。
class | MBeanInfo 描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
class | MBeanNotificationInfo MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
class | MBeanOperationInfo 描述由 MBean 公开的管理操作。
class | MBeanParameterInfo 描述由 MBean 公开的操作的参数。

javax.management.modelmbean 中 DescriptorRead 的使用

实现 DescriptorRead 的 javax.management.modelmbean 中的类
class | ModelMBeanAttributeInfo ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
class | ModelMBeanConstructorInfo ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
class | ModelMBeanInfoSupport 此类表示 ModelMBean 的元数据。
class | ModelMBeanNotificationInfo ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
class | ModelMBeanOperationInfo ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

javax.management.openmbean 中 DescriptorRead 的使用

实现 DescriptorRead 的 javax.management.openmbean 中的类
class | OpenMBeanAttributeInfoSupport 描述 open MBean 的一个属性。
class | OpenMBeanConstructorInfoSupport 描述 Open MBean 的构造方法。
class | OpenMBeanInfoSupport OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。
class | OpenMBeanOperationInfoSupport 描述 Open MBean 的一个操作。
class | OpenMBeanParameterInfoSupport 描述用于 open MBean 的一个或多个操作或构造方法的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.DynamicMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.DynamicMBean
的使用

使用 DynamicMBean 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

javax.management 中 DynamicMBean 的使用

实现 DynamicMBean 的 javax.management 中的类
class | StandardEmitterMBean 一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。
class | StandardMBean 一个管理接口由 Java 接口上的反射确定的 MBean。

javax.management.modelmbean 中 DynamicMBean 的使用

javax.management.modelmbean 中 DynamicMBean 的子接口
 interface ModelMBean
ModelMBean 必须实现此接口。

实现 DynamicMBean 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.ImmutableDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ImmutableDescriptor
的使用

使用 ImmutableDescriptor 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 ImmutableDescriptor 的使用

声明为 ImmutableDescriptor 的 javax.management 中的字段
static ImmutableDescriptor ImmutableDescriptor.EMPTY_DESCRIPTOR
空描述符。

返回 ImmutableDescriptor 的 javax.management 中的方法
static ImmutableDescriptor ImmutableDescriptor.union(Descriptor... descriptors)
返回一个 ImmutableDescriptor，其内容是给定描述符的并集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.InstanceAlreadyExistsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.InstanceAlreadyExistsException
的使用

使用 InstanceAlreadyExistsException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 InstanceAlreadyExistsException 的使用

抛出 InstanceAlreadyExistsException 的 javax.management 中的方法
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.registerMBean(Object object, ObjectName name) 将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。

javax.management.remote.rmi 中 InstanceAlreadyExistsException 的使用

抛出 InstanceAlreadyExistsException 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.InstanceNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.InstanceNotFoundException
的使用

使用 InstanceNotFoundException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 InstanceNotFoundException 的使用

抛出 InstanceNotFoundException 的 javax.management 中的方法
void | MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
void | MBeanServer.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInputStream | MBeanServer.deserialize(ObjectName name, byte[] data) 已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
ObjectInputStream | MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data) 已过时。 使用 getClassLoader 为反序列化获得类加载器。
Object | MBeanServer.getAttribute(ObjectName name, String attribute)
Object | MBeanServerConnection.getAttribute(ObjectName name, String attribute) 获得指定 MBean 的特定属性值。
AttributeList | MBeanServer.getAttributes(ObjectName name, String[] attributes)
AttributeList | MBeanServerConnection.getAttributes(ObjectName name, String[] attributes) 获得指定 MBean 的多个属性值。
ClassLoader | MBeanServer.getClassLoader(ObjectName loaderName) 返回指定的 ClassLoader。
ClassLoader | MBeanServer.getClassLoaderFor(ObjectName mbeanName) 返回用于加载指定 MBean 的类的 ClassLoader。
MBeanInfo | MBeanServer.getMBeanInfo(ObjectName name)
MBeanInfo | MBeanServerConnection.getMBeanInfo(ObjectName name) 此方法发现了 MBean 为管理而公开的属性和操作。
ObjectInstance | MBeanServer.getObjectInstance(ObjectName name)
ObjectInstance | MBeanServerConnection.getObjectInstance(ObjectName name) 获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
Object | MBeanServer.instantiate(String className, ObjectName loaderName) 使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
Object | MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature) 实例化一个对象。
Object | MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
Object | MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature) 在 MBean 上调用某个操作。
boolean | MBeanServer.isInstanceOf(ObjectName name, String className)
boolean | MBeanServerConnection.isInstanceOf(ObjectName name, String className) 如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。
void | PersistentMBean.load() 使用持久存储中找到的 MBean 的数据实例化此 MBean 实例。
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。
AttributeList | MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
AttributeList | MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes) 设置指定 MBean 的多个属性值。
void | PersistentMBean.store() 捕获此 MBean 实例的当前状态并将其写出到持久存储中。
void | MBeanServer.unregisterMBean(ObjectName name)
void | MBeanServerConnection.unregisterMBean(ObjectName name) 从 MBean 服务器中注销一个 MBean。

javax.management.modelmbean 中 InstanceNotFoundException 的使用

抛出 InstanceNotFoundException 的 javax.management.modelmbean 中的方法
void | RequiredModelMBean.load() 使用在持久存储中找到的 MBean 的数据实例化此 MBean。
void | ModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
void | RequiredModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。
void | RequiredModelMBean.store() 捕获此 MBean 实例的当前状态，并将它写出到持久存储中。

javax.management.relation 中 InstanceNotFoundException 的使用

抛出 InstanceNotFoundException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。

javax.management.remote.rmi 中 InstanceNotFoundException 的使用

抛出 InstanceNotFoundException 的 javax.management.remote.rmi 中的方法
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 boolean RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
 void RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
 void RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

javax.management.timer 中 InstanceNotFoundException 的使用

抛出 InstanceNotFoundException 的 javax.management.timer 中的方法
void | Timer.removeNotification(Integer id) 从通知列表中移除与指定标识符对应的计时器通知。
void | TimerMBean.removeNotification(Integer id) 从通知列表中移除与指定的标识符对应的计时器通知。
void | Timer.removeNotifications(String type) 从通知列表中移除与指定类型对应的所有计时器通知。
void | TimerMBean.removeNotifications(String type) 从通知列表中移除与指定的类型对应的所有计时器通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.IntrospectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.IntrospectionException
的使用

使用 IntrospectionException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 IntrospectionException 的使用

抛出 IntrospectionException 的 javax.management 中的方法
MBeanInfo | MBeanServer.getMBeanInfo(ObjectName name)
MBeanInfo | MBeanServerConnection.getMBeanInfo(ObjectName name) 此方法发现了 MBean 为管理而公开的属性和操作。

抛出 IntrospectionException 的 javax.management 中的构造方法
MBeanAttributeInfo(String name, String description, Method getter, Method setter)
此构造方法带有简单属性的名称，以及读取和写入属性的 Method 对象。

javax.management.modelmbean 中 IntrospectionException 的使用

抛出 IntrospectionException 的 javax.management.modelmbean 中的构造方法
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter, Descriptor descriptor)
构造 ModelMBeanAttributeInfo 对象。

javax.management.remote.rmi 中 IntrospectionException 的使用

抛出 IntrospectionException 的 javax.management.remote.rmi 中的方法
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.InvalidApplicationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.InvalidApplicationException
的使用

使用 InvalidApplicationException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 InvalidApplicationException 的使用

抛出 InvalidApplicationException 的 javax.management 中的方法
ValueExp | AttributeValueExp.apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
boolean | QueryExp.apply(ObjectName name) 在 MBean 上应用 QueryExp。
ValueExp | StringValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
ValueExp | ValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.InvalidAttributeValueException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.InvalidAttributeValueException
的使用

使用 InvalidAttributeValueException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 InvalidAttributeValueException 的使用

抛出 InvalidAttributeValueException 的 javax.management 中的方法
void | DynamicMBean.setAttribute(Attribute attribute) 设置 Dynamic MBean 的特定属性的值。
void | StandardMBean.setAttribute(Attribute attribute)
void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。

javax.management.modelmbean 中 InvalidAttributeValueException 的使用

抛出 InvalidAttributeValueException 的 javax.management.modelmbean 中的方法
 void RequiredModelMBean.setAttribute(Attribute attribute)
设置指定的 ModelMBean 的指定属性值。

javax.management.remote.rmi 中 InvalidAttributeValueException 的使用

抛出 InvalidAttributeValueException 的 javax.management.remote.rmi 中的方法
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.JMException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.JMException
的使用

使用 JMException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。

javax.management 中 JMException 的使用

javax.management 中 JMException 的子类
class | AttributeNotFoundException 指定的属性不存在或无法检索。
class | InstanceAlreadyExistsException 已经在存储库中注册了 MBean。
class | InstanceNotFoundException 存储库中不存在指定的 MBean。
class | IntrospectionException 在 MBean 的 introspection 期间出现的异常。
class | InvalidAttributeValueException 指定的值对该属性无效。
class | ListenerNotFoundException 存储库中不存在指定的 MBean 侦听器。
class | MalformedObjectNameException 字符串的格式不对应于有效的 ObjectName。
class | MBeanException 表示由代理的 MBean 方法所抛出的“用户定义的”异常。
class | MBeanRegistrationException 包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
class | NotCompliantMBeanException 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
class | OperationsException 表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
class | ReflectionException 表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
class | ServiceNotFoundException 表示请求的服务不受支持时引发的异常。

javax.management.openmbean 中 JMException 的使用

javax.management.openmbean 中 JMException 的子类
 class OpenDataException
因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。

javax.management.relation 中 JMException 的使用

javax.management.relation 中 JMException 的子类
class | InvalidRelationIdException 为关系提供的关系 id 已使用时引发此异常。
class | InvalidRelationServiceException 提供无效 Relation Service（关系服务）时引发此异常。
class | InvalidRelationTypeException 无效的关系类型。
class | InvalidRoleInfoException 在角色信息中，其最小程度大于其最大程度时，引发此异常。
class | InvalidRoleValueException 角色值无效。
class | RelationException 此类是关系管理过程中引发的任何异常的超类。
class | RelationNotFoundException Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
class | RelationServiceNotRegisteredException 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
class | RelationTypeNotFoundException Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
class | RoleInfoNotFoundException 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
class | RoleNotFoundException 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.JMRuntimeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.JMRuntimeException
的使用

使用 JMRuntimeException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.monitor | 提供 monitor 类的定义。

javax.management 中 JMRuntimeException 的使用

javax.management 中 JMRuntimeException 的子类
class | RuntimeErrorException 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
class | RuntimeMBeanException 表示由代理中的 MBean 方法抛出的运行时异常。
class | RuntimeOperationsException 表示在 MBean 上执行操作时代理中抛出的运行时异常。

javax.management.monitor 中 JMRuntimeException 的使用

javax.management.monitor 中 JMRuntimeException 的子类
 class MonitorSettingException
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.JMX 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.JMX
的使用

没有 javax.management.JMX 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.ListenerNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ListenerNotFoundException
的使用

使用 ListenerNotFoundException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 ListenerNotFoundException 的使用

抛出 ListenerNotFoundException 的 javax.management 中的方法
void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener)
void | NotificationBroadcaster.removeNotificationListener(NotificationListener listener) 从此 MBean 移除一个侦听器。
void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener)
void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener)
void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationEmitter.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 从此 MBean 移除一个侦听器。
void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。

javax.management.modelmbean 中 ListenerNotFoundException 的使用

抛出 ListenerNotFoundException 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName) 从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
void | RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
void | RequiredModelMBean.removeNotificationListener(NotificationListener listener) 从 RequiredModelMBean 移除一个 Notification 的侦听器。
void | RequiredModelMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

javax.management.remote 中 ListenerNotFoundException 的使用

抛出 ListenerNotFoundException 的 javax.management.remote 中的方法
void | JMXConnector.removeConnectionNotificationListener(NotificationListener listener) 将一个用于接收状态更改通知的侦听器从列表中移除。
void | JMXConnector.removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback) 将一个用于接收状态更改通知的侦听器从列表中移除。

javax.management.remote.rmi 中 ListenerNotFoundException 的使用

抛出 ListenerNotFoundException 的 javax.management.remote.rmi 中的方法
 void RMIConnector.removeConnectionNotificationListener(NotificationListener listener)
 void RMIConnector.removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MalformedObjectNameException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MalformedObjectNameException
的使用

使用 MalformedObjectNameException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 MalformedObjectNameException 的使用

抛出 MalformedObjectNameException 的 javax.management 中的方法
static ObjectName ObjectName.getInstance(String name)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, String key, String value)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。

抛出 MalformedObjectNameException 的 javax.management 中的构造方法
ObjectInstance(String objectName, String className)
允许创建具有给定字符串表示形式的对象名和完整类名（包括包名）的ｏbjectInstance。
ObjectName(String name)
根据给定的字符串构造一个对象名。
ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。
ObjectName(String domain, String key, String value)
构造只具有一个键属性的对象名。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanAttributeInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanAttributeInfo
的使用

使用 MBeanAttributeInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 MBeanAttributeInfo 的使用

返回 MBeanAttributeInfo 的 javax.management 中的方法
 MBeanAttributeInfo[] MBeanInfo.getAttributes()
返回为了便于管理而公开的属性的列表。

参数类型为 MBeanAttributeInfo 的 javax.management 中的方法
protected  String StandardMBean.getDescription(MBeanAttributeInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanAttributeInfo 中使用的描述。

参数类型为 MBeanAttributeInfo 的 javax.management 中的构造方法
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。

javax.management.modelmbean 中 MBeanAttributeInfo 的使用

javax.management.modelmbean 中 MBeanAttributeInfo 的子类
 class ModelMBeanAttributeInfo
ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。

返回 MBeanAttributeInfo 的 javax.management.modelmbean 中的方法
 MBeanAttributeInfo[] ModelMBeanInfo.getAttributes()
返回为管理公开的属性列表。

javax.management.openmbean 中 MBeanAttributeInfo 的使用

javax.management.openmbean 中 MBeanAttributeInfo 的子类
 class OpenMBeanAttributeInfoSupport
描述 open MBean 的一个属性。

返回 MBeanAttributeInfo 的 javax.management.openmbean 中的方法
 MBeanAttributeInfo[] OpenMBeanInfo.getAttributes()
返回 OpenMBeanAttributeInfo 实例的数组，该实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanConstructorInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanConstructorInfo
的使用

使用 MBeanConstructorInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 MBeanConstructorInfo 的使用

返回 MBeanConstructorInfo 的 javax.management 中的方法
MBeanConstructorInfo[] | MBeanInfo.getConstructors() 返回 MBean 的公共构造方法列表。
protected MBeanConstructorInfo[] | StandardMBean.getConstructors(MBeanConstructorInfo[] ctors, Object impl) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 MBeanConstructorInfo[]。

参数类型为 MBeanConstructorInfo 的 javax.management 中的方法
protected MBeanConstructorInfo[] | StandardMBean.getConstructors(MBeanConstructorInfo[] ctors, Object impl) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 MBeanConstructorInfo[]。
protected String | StandardMBean.getDescription(MBeanConstructorInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanConstructorInfo 中使用的描述。
protected String | StandardMBean.getDescription(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的描述。
protected String | StandardMBean.getParameterName(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的名称。

参数类型为 MBeanConstructorInfo 的 javax.management 中的构造方法
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。

javax.management.modelmbean 中 MBeanConstructorInfo 的使用

javax.management.modelmbean 中 MBeanConstructorInfo 的子类
 class ModelMBeanConstructorInfo
ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。

返回 MBeanConstructorInfo 的 javax.management.modelmbean 中的方法
 MBeanConstructorInfo[] ModelMBeanInfo.getConstructors()
返回 MBean 的公共构造方法列表。

javax.management.openmbean 中 MBeanConstructorInfo 的使用

javax.management.openmbean 中 MBeanConstructorInfo 的子类
 class OpenMBeanConstructorInfoSupport
描述 Open MBean 的构造方法。

返回 MBeanConstructorInfo 的 javax.management.openmbean 中的方法
 MBeanConstructorInfo[] OpenMBeanInfo.getConstructors()
返回 OpenMBeanConstructorInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanException
的使用

使用 MBeanException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 MBeanException 的使用

javax.management 中 MBeanException 的子类
 class MBeanRegistrationException
包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。

抛出 MBeanException 的 javax.management 中的方法
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
Object | MBeanServer.getAttribute(ObjectName name, String attribute)
Object | MBeanServerConnection.getAttribute(ObjectName name, String attribute) 获得指定 MBean 的特定属性值。
Object | DynamicMBean.getAttribute(String attribute) 获得 Dynamic MBean 的特定属性的值。
Object | StandardMBean.getAttribute(String attribute)
Object | MBeanServer.instantiate(String className) 使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。
Object | MBeanServer.instantiate(String className, Object[] params, String[] signature) 使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。
Object | MBeanServer.instantiate(String className, ObjectName loaderName) 使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
Object | MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature) 实例化一个对象。
Object | MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
Object | MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature) 在 MBean 上调用某个操作。
Object | DynamicMBean.invoke(String actionName, Object[] params, String[] signature) 允许在 Dynamic MBean 上调用某个操作。
Object | StandardMBean.invoke(String actionName, Object[] params, String[] signature)
void | PersistentMBean.load() 使用持久存储中找到的 MBean 的数据实例化此 MBean 实例。
void | DynamicMBean.setAttribute(Attribute attribute) 设置 Dynamic MBean 的特定属性的值。
void | StandardMBean.setAttribute(Attribute attribute)
void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。
void | PersistentMBean.store() 捕获此 MBean 实例的当前状态并将其写出到持久存储中。

javax.management.modelmbean 中 MBeanException 的使用

抛出 MBeanException 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
ModelMBeanAttributeInfo | ModelMBeanInfo.getAttribute(String inName) 返回通过名称请求的 ModelMBeanAttributeInfo。
ModelMBeanAttributeInfo | ModelMBeanInfoSupport.getAttribute(String inName)
Object | RequiredModelMBean.getAttribute(String attrName) 返回为此 ModelMBean 定义的指定属性的值。
ModelMBeanConstructorInfo | ModelMBeanInfoSupport.getConstructor(String inName) 返回通过名称请求的 ModelMBeanConstructorInfo。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName) 返回通过名称请求的 Descriptor。
Descriptor | ModelMBeanInfo.getDescriptor(String inDescriptorName, String inDescriptorType) 返回通过 name 和 descriptorType 请求的 Descriptor。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName, String inDescriptorType)
Descriptor[] | ModelMBeanInfo.getDescriptors(String inDescriptorType) 返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。
Descriptor[] | ModelMBeanInfoSupport.getDescriptors(String inDescriptorType)
Descriptor | ModelMBeanInfo.getMBeanDescriptor() 返回包含 MBean 级策略的 ModelMBean 的描述符。
Descriptor | ModelMBeanInfoSupport.getMBeanDescriptor()
ModelMBeanNotificationInfo | ModelMBeanInfo.getNotification(String inName) 返回通过名称请求的 ModelMBeanNotificationInfo。
ModelMBeanNotificationInfo | ModelMBeanInfoSupport.getNotification(String inName)
ModelMBeanOperationInfo | ModelMBeanInfo.getOperation(String inName) 返回通过名称请求的 ModelMBeanOperationInfo。
ModelMBeanOperationInfo | ModelMBeanInfoSupport.getOperation(String inName)
Object | RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig) 调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。
void | RequiredModelMBean.load() 使用在持久存储中找到的 MBean 的数据实例化此 MBean。
void | ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName) 从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
void | RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(Attribute oldValue, Attribute newValue) 将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(Attribute inOldVal, Attribute inNewVal)
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(AttributeChangeNotification notification) 将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)
void | ModelMBeanNotificationBroadcaster.sendNotification(Notification ntfyObj) 以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | RequiredModelMBean.sendNotification(Notification ntfyObj)
void | ModelMBeanNotificationBroadcaster.sendNotification(String ntfyText) 将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | RequiredModelMBean.sendNotification(String ntfyText)
void | RequiredModelMBean.setAttribute(Attribute attribute) 设置指定的 ModelMBean 的指定属性值。
void | ModelMBeanInfo.setDescriptor(Descriptor inDescriptor, String inDescriptorType) 设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。
void | ModelMBeanInfoSupport.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
void | ModelMBeanInfo.setDescriptors(Descriptor[] inDescriptors) 添加或替换 ModelMBeanInfo 中的描述符。
void | ModelMBeanInfoSupport.setDescriptors(Descriptor[] inDescriptors)
void | ModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
void | RequiredModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。
void | ModelMBeanInfo.setMBeanDescriptor(Descriptor inDescriptor) 设置 ModelMBean 的描述符。
void | ModelMBeanInfoSupport.setMBeanDescriptor(Descriptor inMBeanDescriptor)
void | ModelMBean.setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | RequiredModelMBean.setModelMBeanInfo(ModelMBeanInfo mbi) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | RequiredModelMBean.store() 捕获此 MBean 实例的当前状态，并将它写出到持久存储中。

抛出 MBeanException 的 javax.management.modelmbean 中的构造方法
DescriptorSupport(int initNumFields)
描述符构造方法。
DescriptorSupport(String inStr)
Descriptor 构造方法带有一个 XML String。
RequiredModelMBean()
构造带有空 ModelMBeanInfo 的 RequiredModelMBean。
RequiredModelMBean(ModelMBeanInfo mbi)
使用传入的 ModelMBeanInfo 构造 RequiredModelMBean 对象。

javax.management.remote.rmi 中 MBeanException 的使用

抛出 MBeanException 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanFeatureInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanFeatureInfo
的使用

使用 MBeanFeatureInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 MBeanFeatureInfo 的使用

javax.management 中 MBeanFeatureInfo 的子类
class | MBeanAttributeInfo 描述出于管理目的而公开的 MBean 属性。
class | MBeanConstructorInfo 描述 MBean 所公开的构造方法。
class | MBeanNotificationInfo MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
class | MBeanOperationInfo 描述由 MBean 公开的管理操作。
class | MBeanParameterInfo 描述由 MBean 公开的操作的参数。

参数类型为 MBeanFeatureInfo 的 javax.management 中的方法
protected  String StandardMBean.getDescription(MBeanFeatureInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanFeatureInfo 中使用的描述。

javax.management.modelmbean 中 MBeanFeatureInfo 的使用

javax.management.modelmbean 中 MBeanFeatureInfo 的子类
class | ModelMBeanAttributeInfo ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
class | ModelMBeanConstructorInfo ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
class | ModelMBeanNotificationInfo ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
class | ModelMBeanOperationInfo ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

javax.management.openmbean 中 MBeanFeatureInfo 的使用

javax.management.openmbean 中 MBeanFeatureInfo 的子类
class | OpenMBeanAttributeInfoSupport 描述 open MBean 的一个属性。
class | OpenMBeanConstructorInfoSupport 描述 Open MBean 的构造方法。
class | OpenMBeanOperationInfoSupport 描述 Open MBean 的一个操作。
class | OpenMBeanParameterInfoSupport 描述用于 open MBean 的一个或多个操作或构造方法的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanInfo
的使用

使用 MBeanInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 MBeanInfo 的使用

返回 MBeanInfo 的 javax.management 中的方法
protected MBeanInfo | StandardMBean.getCachedMBeanInfo() 自定义钩子：返回为此对象缓存的 MBeanInfo。
MBeanInfo | DynamicMBean.getMBeanInfo() 使用 MBeanInfo 对象提供该 Dynamic MBean 已公开的属性和操作。
MBeanInfo | StandardMBean.getMBeanInfo() 获取此 MBean 的 MBeanInfo。
MBeanInfo | MBeanServer.getMBeanInfo(ObjectName name)
MBeanInfo | MBeanServerConnection.getMBeanInfo(ObjectName name) 此方法发现了 MBean 为管理而公开的属性和操作。

参数类型为 MBeanInfo 的 javax.management 中的方法
protected void | StandardMBean.cacheMBeanInfo(MBeanInfo info) 自定义钩子：缓存为此对象构建的 MBeanInfo。
protected String | StandardMBean.getClassName(MBeanInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 className。
protected String | StandardMBean.getDescription(MBeanInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的描述。

javax.management.modelmbean 中 MBeanInfo 的使用

javax.management.modelmbean 中 MBeanInfo 的子类
 class ModelMBeanInfoSupport
此类表示 ModelMBean 的元数据。

返回 MBeanInfo 的 javax.management.modelmbean 中的方法
 MBeanInfo RequiredModelMBean.getMBeanInfo()
返回此 RequiredModelMBean 公开的属性、操作、构造方法和通知是为了便于管理。

javax.management.openmbean 中 MBeanInfo 的使用

javax.management.openmbean 中 MBeanInfo 的子类
 class OpenMBeanInfoSupport
OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。

javax.management.remote.rmi 中 MBeanInfo 的使用

返回 MBeanInfo 的 javax.management.remote.rmi 中的方法
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanNotificationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanNotificationInfo
的使用

使用 MBeanNotificationInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management 中的方法
MBeanNotificationInfo[] | MBeanServerDelegate.getNotificationInfo()
MBeanNotificationInfo[] | NotificationBroadcaster.getNotificationInfo() 返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。
MBeanNotificationInfo[] | NotificationBroadcasterSupport.getNotificationInfo()
MBeanNotificationInfo[] | StandardEmitterMBean.getNotificationInfo()
MBeanNotificationInfo[] | MBeanInfo.getNotifications() 返回 MBean 所发出的通知列表。

参数类型为 MBeanNotificationInfo 的 javax.management 中的构造方法
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。
NotificationBroadcasterSupport(Executor executor, MBeanNotificationInfo... info)
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。
NotificationBroadcasterSupport(MBeanNotificationInfo... info)
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport。

javax.management.modelmbean 中 MBeanNotificationInfo 的使用

javax.management.modelmbean 中 MBeanNotificationInfo 的子类
 class ModelMBeanNotificationInfo
ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。

返回 MBeanNotificationInfo 的 javax.management.modelmbean 中的方法
MBeanNotificationInfo[] | RequiredModelMBean.getNotificationInfo() 返回总是由 RequiredModelMBean 生成的 Notification 数组。
MBeanNotificationInfo[] | ModelMBeanInfo.getNotifications() 返回 MBean 所发送的通知列表。

javax.management.monitor 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management.monitor 中的方法
MBeanNotificationInfo[] | CounterMonitor.getNotificationInfo() 返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由计数器监视器发送的通知类型。
MBeanNotificationInfo[] | GaugeMonitor.getNotificationInfo() 返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由尺度监视器发送的通知类型。
MBeanNotificationInfo[] | StringMonitor.getNotificationInfo() 返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由字符串监视器发送的通知类型。

javax.management.openmbean 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management.openmbean 中的方法
 MBeanNotificationInfo[] OpenMBeanInfo.getNotifications()
返回 MBeanNotificationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 所发出的每个通知。

参数类型为 MBeanNotificationInfo 的 javax.management.openmbean 中的构造方法
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

javax.management.relation 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management.relation 中的方法
 MBeanNotificationInfo[] RelationService.getNotificationInfo()
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和发送的通知类型。

javax.management.remote 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management.remote 中的方法
 MBeanNotificationInfo[] JMXConnectorServer.getNotificationInfo()
返回一个指示由该 MBean 发送的通知的数组。

javax.management.timer 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management.timer 中的方法
 MBeanNotificationInfo[] Timer.getNotificationInfo()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanOperationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanOperationInfo
的使用

使用 MBeanOperationInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 MBeanOperationInfo 的使用

返回 MBeanOperationInfo 的 javax.management 中的方法
 MBeanOperationInfo[] MBeanInfo.getOperations()
返回 MBean 的操作列表。

参数类型为 MBeanOperationInfo 的 javax.management 中的方法
protected String | StandardMBean.getDescription(MBeanOperationInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的描述。
protected String | StandardMBean.getDescription(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的描述。
protected int | StandardMBean.getImpact(MBeanOperationInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的操作的 impact 标志。
protected String | StandardMBean.getParameterName(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的名称。

参数类型为 MBeanOperationInfo 的 javax.management 中的构造方法
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。

javax.management.modelmbean 中 MBeanOperationInfo 的使用

javax.management.modelmbean 中 MBeanOperationInfo 的子类
 class ModelMBeanOperationInfo
ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

返回 MBeanOperationInfo 的 javax.management.modelmbean 中的方法
 MBeanOperationInfo[] ModelMBeanInfo.getOperations()
返回 MBean 的操作列表。

javax.management.openmbean 中 MBeanOperationInfo 的使用

javax.management.openmbean 中 MBeanOperationInfo 的子类
 class OpenMBeanOperationInfoSupport
描述 Open MBean 的一个操作。

返回 MBeanOperationInfo 的 javax.management.openmbean 中的方法
 MBeanOperationInfo[] OpenMBeanInfo.getOperations()
返回 OpenMBeanOperationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例所描述的 open MBean 中的每个操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanParameterInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanParameterInfo
的使用

使用 MBeanParameterInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 MBeanParameterInfo 的使用

返回 MBeanParameterInfo 的 javax.management 中的方法
MBeanParameterInfo[] | MBeanConstructorInfo.getSignature() 返回此构造方法的参数列表。
MBeanParameterInfo[] | MBeanOperationInfo.getSignature() 返回此操作的参数列表。

参数类型为 MBeanParameterInfo 的 javax.management 中的方法
protected String | StandardMBean.getDescription(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的描述。
protected String | StandardMBean.getDescription(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的描述。
protected String | StandardMBean.getParameterName(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的名称。
protected String | StandardMBean.getParameterName(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的名称。

参数类型为 MBeanParameterInfo 的 javax.management 中的构造方法
MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
构造一个 MBeanConstructorInfo 对象。
MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 MBeanConstructorInfo 对象。
MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
构造一个 MBeanOperationInfo 对象。
MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造一个 MBeanOperationInfo 对象。

javax.management.modelmbean 中 MBeanParameterInfo 的使用

参数类型为 MBeanParameterInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

javax.management.openmbean 中 MBeanParameterInfo 的使用

javax.management.openmbean 中 MBeanParameterInfo 的子类
 class OpenMBeanParameterInfoSupport
描述用于 open MBean 的一个或多个操作或构造方法的参数。

返回 MBeanParameterInfo 的 javax.management.openmbean 中的方法
MBeanParameterInfo[] | OpenMBeanConstructorInfo.getSignature() 返回 OpenMBeanParameterInfo 实例的数组，该实例描述此 OpenMBeanConstructorInfo 实例描述的构造方法签名中的每个参数。
MBeanParameterInfo[] | OpenMBeanOperationInfo.getSignature() 返回 OpenMBeanOperationInfo 实例的数组，该实例描述此 OpenMBeanParameterInfo 实例所描述操作的签名中的每个参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanPermission
的使用

没有 javax.management.MBeanPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.MBeanRegistration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.MBeanRegistration
的使用

使用 MBeanRegistration 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management 中的类
class | StandardEmitterMBean 一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。
class | StandardMBean 一个管理接口由 Java 接口上的反射确定的 MBean。

javax.management.loading 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.loading 中的类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

javax.management.modelmbean 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

javax.management.monitor 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.monitor 中的类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | Monitor 定义所有监视器 MBean 的公共部分。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

javax.management.relation 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.relation 中的类
class | RelationService Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。
class | RelationSupport RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。

javax.management.remote 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.remote 中的类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.remote.rmi 中的类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

javax.management.timer 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.timer 中的类
 class Timer
提供对计时器 MBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanRegistrationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanRegistrationException
的使用

使用 MBeanRegistrationException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 MBeanRegistrationException 的使用

抛出 MBeanRegistrationException 的 javax.management 中的方法
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.registerMBean(Object object, ObjectName name) 将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。
void | MBeanServer.unregisterMBean(ObjectName name)
void | MBeanServerConnection.unregisterMBean(ObjectName name) 从 MBean 服务器中注销一个 MBean。

javax.management.remote.rmi 中 MBeanRegistrationException 的使用

抛出 MBeanRegistrationException 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
 void RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
 void RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.MBeanServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.MBeanServer
的使用

使用 MBeanServer 的软件包
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

java.lang.management 中 MBeanServer 的使用

返回 MBeanServer 的 java.lang.management 中的方法
static MBeanServer ManagementFactory.getPlatformMBeanServer()
返回平台 MBeanServer。

javax.management 中 MBeanServer 的使用

返回 MBeanServer 的 javax.management 中的方法
static MBeanServer | MBeanServerFactory.createMBeanServer() 返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口。
static MBeanServer | MBeanServerFactory.createMBeanServer(String domain) 返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口。
static MBeanServer | QueryEval.getMBeanServer() 返回此线程最近一次提供给 setMBeanServer 方法的 MBean 服务器。
static MBeanServer | MBeanServerFactory.newMBeanServer() 返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。
static MBeanServer | MBeanServerFactory.newMBeanServer(String domain) 返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。
MBeanServer | MBeanServerBuilder.newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate) 此方法创建一个新的 MBeanServer 实现对象。

返回变量类型为 MBeanServer 的类型的 javax.management 中的方法
static ArrayList<MBeanServer> MBeanServerFactory.findMBeanServer(String agentId)
返回已注册 MBeanServer 对象的列表。

参数类型为 MBeanServer 的 javax.management 中的方法
static ClassLoaderRepository MBeanServerFactory.getClassLoaderRepository(MBeanServer server)
返回给定 MBeanServer 使用的 ClassLoaderRepository。
 MBeanServer MBeanServerBuilder.newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate)
此方法创建一个新的 MBeanServer 实现对象。
 ObjectName MBeanRegistration.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
 ObjectName StandardMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。
static void MBeanServerFactory.releaseMBeanServer(MBeanServer mbeanServer)
移除对已创建 MBeanServer 的内部 MBeanServerFactory 引用。
 void AttributeValueExp.setMBeanServer(MBeanServer s)
设置要在其上执行查询的 MBean 服务器。
 void ObjectName.setMBeanServer(MBeanServer mbs)
 void QueryEval.setMBeanServer(MBeanServer s)
设置将在其上执行查询的 MBean 服务器。
 void QueryExp.setMBeanServer(MBeanServer s)
设置将在其上执行查询的 MBean 服务器。
 void StringValueExp.setMBeanServer(MBeanServer s)
设置将在其上执行查询的 MBean 服务器。
 void ValueExp.setMBeanServer(MBeanServer s)
已过时。 不再需要此方法，因为 ValueExp 可以通过使用 QueryEval.getMBeanServer() 来访问它将在其中进行计算的 MBean 服务器。

javax.management.loading 中 MBeanServer 的使用

参数类型为 MBeanServer 的 javax.management.loading 中的方法
 ObjectName MLet.preRegister(MBeanServer server, ObjectName name)
允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。

javax.management.modelmbean 中 MBeanServer 的使用

参数类型为 MBeanServer 的 javax.management.modelmbean 中的方法
 ObjectName RequiredModelMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。

javax.management.monitor 中 MBeanServer 的使用

声明为 MBeanServer 的 javax.management.monitor 中的字段
protected  MBeanServer Monitor.server
对 MBean 服务器的引用。

参数类型为 MBeanServer 的 javax.management.monitor 中的方法
 ObjectName Monitor.preRegister(MBeanServer server, ObjectName name)
允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。

javax.management.relation 中 MBeanServer 的使用

参数类型为 MBeanServer 的 javax.management.relation 中的方法
ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)

参数类型为 MBeanServer 的 javax.management.relation 中的构造方法
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。

javax.management.remote 中 MBeanServer 的使用

javax.management.remote 中 MBeanServer 的子接口
 interface MBeanServerForwarder
此类的对象实现 MBeanServer 接口并包装另一个也实现此接口的对象。

返回 MBeanServer 的 javax.management.remote 中的方法
MBeanServer | JMXConnectorServer.getMBeanServer() 返回该连接器服务器连接到的 MBean 服务器。
MBeanServer | MBeanServerForwarder.getMBeanServer() 返回请求将转发到其上的 MBeanServer 对象。

参数类型为 MBeanServer 的 javax.management.remote 中的方法
static JMXConnectorServer | JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的连接器服务器。
JMXConnectorServer | JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的新连接器服务器。
ObjectName | JMXConnectorServer.preRegister(MBeanServer mbs, ObjectName name) 当此连接器服务器在 MBean 服务器上注册时，由该 MBean 服务器调用此方法。
void | MBeanServerForwarder.setMBeanServer(MBeanServer mbs) 设置 MBeanServer 对象，请求经此对象处理后将转发到其上。

参数类型为 MBeanServer 的 javax.management.remote 中的构造方法
JMXConnectorServer(MBeanServer mbeanServer)
构造一个连接到给定 MBean 服务器的连接器服务器。

javax.management.remote.rmi 中 MBeanServer 的使用

返回 MBeanServer 的 javax.management.remote.rmi 中的方法
 MBeanServer RMIServerImpl.getMBeanServer()
此连接器服务器所连接的 MBeanServer。

参数类型为 MBeanServer 的 javax.management.remote.rmi 中的方法
 void RMIServerImpl.setMBeanServer(MBeanServer mbs)
设置此连接器服务器所连接的 MBeanServer。

参数类型为 MBeanServer 的 javax.management.remote.rmi 中的构造方法
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。

javax.management.timer 中 MBeanServer 的使用

参数类型为 MBeanServer 的 javax.management.timer 中的方法
 ObjectName Timer.preRegister(MBeanServer server, ObjectName name)
允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanServerBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerBuilder
的使用

没有 javax.management.MBeanServerBuilder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.MBeanServerConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.MBeanServerConnection
的使用

使用 MBeanServerConnection 的软件包
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

java.lang.management 中 MBeanServerConnection 的使用

参数类型为 MBeanServerConnection 的 java.lang.management 中的方法
static
<T> T
ManagementFactory.newPlatformMXBeanProxy(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。

javax.management 中 MBeanServerConnection 的使用

javax.management 中 MBeanServerConnection 的子接口
 interface MBeanServer
这是在代理端进行 MBean 操作的接口。

返回 MBeanServerConnection 的 javax.management 中的方法
 MBeanServerConnection MBeanServerInvocationHandler.getMBeanServerConnection()
MBean 服务器连接，使用此处理程序的代理的方法是通过此连接转发的。

参数类型为 MBeanServerConnection 的 javax.management 中的方法
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
MBeanServerInvocationHandler.newProxyInstance(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
返回一个代理，该代理通过将其方法从给定 MBean 服务器转发到指定 MBean 来实现给定的接口。

参数类型为 MBeanServerConnection 的 javax.management 中的构造方法
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName)
通过 MBean 服务器将方法转发给 Standard MBean 的调用处理程序。
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName, boolean isMXBean)
可以通过 MBean 服务器将方法转发给 Standard MBean 或 MXBean 的调用处理程序。

javax.management.remote 中 MBeanServerConnection 的使用

javax.management.remote 中 MBeanServerConnection 的子接口
 interface MBeanServerForwarder
此类的对象实现 MBeanServer 接口并包装另一个也实现此接口的对象。

返回 MBeanServerConnection 的 javax.management.remote 中的方法
MBeanServerConnection | JMXConnector.getMBeanServerConnection() 返回一个代表远程 MBean 服务器的 MBeanServerConnection 对象。
MBeanServerConnection | JMXConnector.getMBeanServerConnection(Subject delegationSubject) 返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。

javax.management.remote.rmi 中 MBeanServerConnection 的使用

返回 MBeanServerConnection 的 javax.management.remote.rmi 中的方法
MBeanServerConnection | RMIConnector.getMBeanServerConnection()
MBeanServerConnection | RMIConnector.getMBeanServerConnection(Subject delegationSubject)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanServerDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerDelegate
的使用

使用 MBeanServerDelegate 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 MBeanServerDelegate 的使用

返回 MBeanServerDelegate 的 javax.management 中的方法
 MBeanServerDelegate MBeanServerBuilder.newMBeanServerDelegate()
此方法为新的 MBeanServer 创建新的 MBeanServerDelegate。

参数类型为 MBeanServerDelegate 的 javax.management 中的方法
 MBeanServer MBeanServerBuilder.newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate)
此方法创建一个新的 MBeanServer 实现对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.MBeanServerDelegateMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.MBeanServerDelegateMBean
的使用

使用 MBeanServerDelegateMBean 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 MBeanServerDelegateMBean 的使用

实现 MBeanServerDelegateMBean 的 javax.management 中的类
 class MBeanServerDelegate
从管理的角度表示 MBean 服务器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanServerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerFactory
的使用

没有 javax.management.MBeanServerFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanServerInvocationHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerInvocationHandler
的使用

没有 javax.management.MBeanServerInvocationHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanServerNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerNotification
的使用

没有 javax.management.MBeanServerNotification 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanServerPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerPermission
的使用

没有 javax.management.MBeanServerPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MBeanTrustPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanTrustPermission
的使用

没有 javax.management.MBeanTrustPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.MXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MXBean
的使用

没有 javax.management.MXBean 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.NotCompliantMBeanException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.NotCompliantMBeanException
的使用

使用 NotCompliantMBeanException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 NotCompliantMBeanException 的使用

抛出 NotCompliantMBeanException 的 javax.management 中的方法
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.registerMBean(Object object, ObjectName name) 将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。
void | StandardMBean.setImplementation(Object implementation) 替换包装在此对象中的实现对象。

抛出 NotCompliantMBeanException 的 javax.management 中的构造方法
StandardMBean(Class<?> mbeanInterface)
使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
StandardMBean(T implementation, Class<T> mbeanInterface)
使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。

javax.management.relation 中 NotCompliantMBeanException 的使用

抛出 NotCompliantMBeanException 的 javax.management.relation 中的构造方法
RoleInfo(String roleName, String mbeanClassName)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。

javax.management.remote.rmi 中 NotCompliantMBeanException 的使用

抛出 NotCompliantMBeanException 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.Notification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.Notification
的使用

使用 Notification 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 Notification 的使用

javax.management 中 Notification 的子类
class | AttributeChangeNotification 提供 MBean 所发送的属性更改通知的定义。
class | MBeanServerNotification 表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。

参数类型为 Notification 的 javax.management 中的方法
protected void | NotificationBroadcasterSupport.handleNotification(NotificationListener listener, Notification notif, Object handback) 为了向侦听器发送通知，由该侦听器的 sendNotification 调用此方法。
void | NotificationListener.handleNotification(Notification notification, Object handback) 出现 JMX 通知时调用。
boolean | AttributeChangeNotificationFilter.isNotificationEnabled(Notification notification) 向侦听器发送指定的通知之前调用。
boolean | NotificationFilter.isNotificationEnabled(Notification notification) 向侦听器发送指定通知前调用。
boolean | NotificationFilterSupport.isNotificationEnabled(Notification notification) 向侦听器发送指定的通知前调用。
void | MBeanServerDelegate.sendNotification(Notification notification) 允许 MBean 服务器发送通知。
void | NotificationBroadcasterSupport.sendNotification(Notification notification) 发送一个通知。
void | StandardEmitterMBean.sendNotification(Notification n) 发送通知。

javax.management.modelmbean 中 Notification 的使用

参数类型为 Notification 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.sendNotification(Notification ntfyObj) 以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | RequiredModelMBean.sendNotification(Notification ntfyObj)

javax.management.monitor 中 Notification 的使用

javax.management.monitor 中 Notification 的子类
 class MonitorNotification
提供对监视器 MBean 发送的通知的定义。

javax.management.relation 中 Notification 的使用

javax.management.relation 中 Notification 的子类
 class RelationNotification
Relation Service（关系服务）中的更改通知。

参数类型为 Notification 的 javax.management.relation 中的方法
void | RelationService.handleNotification(Notification notif, Object handback) 出现 JMX 通知时调用。
boolean | MBeanServerNotificationFilter.isNotificationEnabled(Notification notif) 向侦听器发送指定通知之前调用。

javax.management.remote 中 Notification 的使用

javax.management.remote 中 Notification 的子类
 class JMXConnectionNotification
在客户端连接打开或关闭时，或者当通知丢失时发出的通知。

返回 Notification 的 javax.management.remote 中的方法
 Notification TargetedNotification.getNotification()
发出的通知。

参数类型为 Notification 的 javax.management.remote 中的构造方法
TargetedNotification(Notification notification, Integer listenerID)
构造一个 TargetedNotification 对象。

javax.management.timer 中 Notification 的使用

javax.management.timer 中 Notification 的子类
 class TimerNotification
此类定义了由计时器 MBean 发送的通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.NotificationBroadcaster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.NotificationBroadcaster
的使用

使用 NotificationBroadcaster 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 NotificationBroadcaster 的使用

javax.management 中 NotificationBroadcaster 的子接口
 interface NotificationEmitter
由发出 Notifications 的 MBean 实现的接口。

实现 NotificationBroadcaster 的 javax.management 中的类
class | MBeanServerDelegate 从管理的角度表示 MBean 服务器。
class | NotificationBroadcasterSupport 提供 NotificationEmitter 接口的实现。
class | StandardEmitterMBean 一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。

javax.management.modelmbean 中 NotificationBroadcaster 的使用

javax.management.modelmbean 中 NotificationBroadcaster 的子接口
interface | ModelMBean ModelMBean 必须实现此接口。
interface | ModelMBeanNotificationBroadcaster ModelMBean 必须实现此接口。

实现 NotificationBroadcaster 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

javax.management.monitor 中 NotificationBroadcaster 的使用

实现 NotificationBroadcaster 的 javax.management.monitor 中的类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | Monitor 定义所有监视器 MBean 的公共部分。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

javax.management.relation 中 NotificationBroadcaster 的使用

实现 NotificationBroadcaster 的 javax.management.relation 中的类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

javax.management.remote 中 NotificationBroadcaster 的使用

实现 NotificationBroadcaster 的 javax.management.remote 中的类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 NotificationBroadcaster 的使用

实现 NotificationBroadcaster 的 javax.management.remote.rmi 中的类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

javax.management.timer 中 NotificationBroadcaster 的使用

实现 NotificationBroadcaster 的 javax.management.timer 中的类
 class Timer
提供对计时器 MBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.NotificationBroadcasterSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.NotificationBroadcasterSupport
的使用

使用 NotificationBroadcasterSupport 的软件包
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management.monitor 中 NotificationBroadcasterSupport 的使用

javax.management.monitor 中 NotificationBroadcasterSupport 的子类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | Monitor 定义所有监视器 MBean 的公共部分。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

javax.management.relation 中 NotificationBroadcasterSupport 的使用

javax.management.relation 中 NotificationBroadcasterSupport 的子类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

javax.management.remote 中 NotificationBroadcasterSupport 的使用

javax.management.remote 中 NotificationBroadcasterSupport 的子类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 NotificationBroadcasterSupport 的使用

javax.management.remote.rmi 中 NotificationBroadcasterSupport 的子类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

javax.management.timer 中 NotificationBroadcasterSupport 的使用

javax.management.timer 中 NotificationBroadcasterSupport 的子类
 class Timer
提供对计时器 MBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.NotificationEmitter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.NotificationEmitter
的使用

使用 NotificationEmitter 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management 中的类
class | MBeanServerDelegate 从管理的角度表示 MBean 服务器。
class | NotificationBroadcasterSupport 提供 NotificationEmitter 接口的实现。
class | StandardEmitterMBean 一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。

参数类型为 NotificationEmitter 的 javax.management 中的构造方法
StandardEmitterMBean(Class<?> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(Class<?> mbeanInterface, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(T implementation, Class<T> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(T implementation, Class<T> mbeanInterface, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。

javax.management.modelmbean 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

javax.management.monitor 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.monitor 中的类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | Monitor 定义所有监视器 MBean 的公共部分。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

javax.management.relation 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.relation 中的类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

javax.management.remote 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.remote 中的类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.remote.rmi 中的类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

javax.management.timer 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.timer 中的类
 class Timer
提供对计时器 MBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.NotificationFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.NotificationFilter
的使用

使用 NotificationFilter 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 NotificationFilter 的使用

实现 NotificationFilter 的 javax.management 中的类
class | AttributeChangeNotificationFilter 此类实现 attribute change notification 的 NotificationFilter 接口。
class | NotificationFilterSupport 提供 NotificationFilter 接口的实现。

参数类型为 NotificationFilter 的 javax.management 中的方法
void | MBeanServerDelegate.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcaster.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 在此 MBean 中添加一个侦听器。
void | NotificationBroadcasterSupport.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个侦听器。
void | StandardEmitterMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
void | MBeanServer.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationEmitter.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 从此 MBean 移除一个侦听器。
void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。

javax.management.modelmbean 中 NotificationFilter 的使用

参数类型为 NotificationFilter 的 javax.management.modelmbean 中的方法
void | RequiredModelMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | RequiredModelMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

javax.management.relation 中 NotificationFilter 的使用

实现 NotificationFilter 的 javax.management.relation 中的类
 class MBeanServerNotificationFilter
MBeanServerNotification 的过滤器。

javax.management.remote 中 NotificationFilter 的使用

参数类型为 NotificationFilter 的 javax.management.remote 中的方法
void | JMXConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个接收连接状态改变的侦听器。
void | JMXConnector.removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback) 将一个用于接收状态更改通知的侦听器从列表中移除。

javax.management.remote.rmi 中 NotificationFilter 的使用

参数类型为 NotificationFilter 的 javax.management.remote.rmi 中的方法
void | RMIConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | RMIConnector.removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.NotificationFilterSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.NotificationFilterSupport
的使用

使用 NotificationFilterSupport 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 NotificationFilterSupport 的使用

javax.management.relation 中 NotificationFilterSupport 的子类
 class MBeanServerNotificationFilter
MBeanServerNotification 的过滤器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.NotificationListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.NotificationListener
的使用

使用 NotificationListener 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 NotificationListener 的使用

参数类型为 NotificationListener 的 javax.management 中的方法
void | MBeanServerDelegate.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcaster.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 在此 MBean 中添加一个侦听器。
void | NotificationBroadcasterSupport.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个侦听器。
void | StandardEmitterMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
protected void | NotificationBroadcasterSupport.handleNotification(NotificationListener listener, Notification notif, Object handback) 为了向侦听器发送通知，由该侦听器的 sendNotification 调用此方法。
void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener)
void | NotificationBroadcaster.removeNotificationListener(NotificationListener listener) 从此 MBean 移除一个侦听器。
void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener)
void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener)
void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationEmitter.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 从此 MBean 移除一个侦听器。
void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。

javax.management.modelmbean 中 NotificationListener 的使用

参数类型为 NotificationListener 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
void | RequiredModelMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName) 从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
void | RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
void | RequiredModelMBean.removeNotificationListener(NotificationListener listener) 从 RequiredModelMBean 移除一个 Notification 的侦听器。
void | RequiredModelMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

javax.management.relation 中 NotificationListener 的使用

实现 NotificationListener 的 javax.management.relation 中的类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

javax.management.remote 中 NotificationListener 的使用

参数类型为 NotificationListener 的 javax.management.remote 中的方法
void | JMXConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个接收连接状态改变的侦听器。
void | JMXConnector.removeConnectionNotificationListener(NotificationListener listener) 将一个用于接收状态更改通知的侦听器从列表中移除。
void | JMXConnector.removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback) 将一个用于接收状态更改通知的侦听器从列表中移除。

javax.management.remote.rmi 中 NotificationListener 的使用

参数类型为 NotificationListener 的 javax.management.remote.rmi 中的方法
void | RMIConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | RMIConnector.removeConnectionNotificationListener(NotificationListener listener)
void | RMIConnector.removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.ObjectInstance 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ObjectInstance
的使用

使用 ObjectInstance 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 ObjectInstance 的使用

返回 ObjectInstance 的 javax.management 中的方法
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.getObjectInstance(ObjectName name)
ObjectInstance | MBeanServerConnection.getObjectInstance(ObjectName name) 获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
ObjectInstance | MBeanServer.registerMBean(Object object, ObjectName name) 将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。

返回变量类型为 ObjectInstance 的类型的 javax.management 中的方法
Set<ObjectInstance> | MBeanServer.queryMBeans(ObjectName name, QueryExp query)
Set<ObjectInstance> | MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean。

javax.management.remote.rmi 中 ObjectInstance 的使用

返回 ObjectInstance 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

返回变量类型为 ObjectInstance 的类型的 javax.management.remote.rmi 中的方法
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.ObjectName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ObjectName
的使用

使用 ObjectName 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 ObjectName 的使用

声明为 ObjectName 的 javax.management 中的字段
static ObjectName | MBeanServerDelegate.DELEGATE_NAME 定义 MBeanServerDelegate 的默认 ObjectName。
static ObjectName | ObjectName.WILDCARD 定义通配符 "*:*" ObjectName。

返回 ObjectName 的 javax.management 中的方法
static ObjectName ObjectName.getInstance(ObjectName name)
返回 ObjectName 的实例，该 ObjectName 可用于任何可使用给定对象的地方。
static ObjectName ObjectName.getInstance(String name)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, String key, String value)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。
 ObjectName MBeanServerNotification.getMBeanName()
返回导致该通知的 MBean 的对象名。
 ObjectName MBeanServerInvocationHandler.getObjectName()
MBean 服务器中 MBean 的名称，一些方法将转发到该 MBean。
 ObjectName ObjectInstance.getObjectName()
返回对象名部分。
 ObjectName MBeanRegistration.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
 ObjectName StandardMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。

返回变量类型为 ObjectName 的类型的 javax.management 中的方法
Set<ObjectName> | MBeanServer.queryNames(ObjectName name, QueryExp query)
Set<ObjectName> | MBeanServerConnection.queryNames(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean 的名称。

参数类型为 ObjectName 的 javax.management 中的方法
 void MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
 void MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
向已注册的 MBean 添加一个侦听器。
 void MBeanServer.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
 void MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
向已注册的 MBean 添加一个侦听器。
 ValueExp AttributeValueExp.apply(ObjectName name)
在 MBean 上应用 AttributeValueExp。
 boolean ObjectName.apply(ObjectName name)
测试此 ObjectName（可以是一个模式）是否与另一个 ObjectName 匹配。
 boolean QueryExp.apply(ObjectName name)
在 MBean 上应用 QueryExp。
 ValueExp StringValueExp.apply(ObjectName name)
在 MBean 上应用 ValueExp。
 ValueExp ValueExp.apply(ObjectName name)
在 MBean 上应用 ValueExp。
 int ObjectName.compareTo(ObjectName name)
比较两个 ObjectName 实例。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInputStream MBeanServer.deserialize(ObjectName name, byte[] data)
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
 ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。
protected  Object AttributeValueExp.getAttribute(ObjectName name)
返回指定的 MBean 中给定属性的值。
 Object MBeanServer.getAttribute(ObjectName name, String attribute)
 Object MBeanServerConnection.getAttribute(ObjectName name, String attribute)
获得指定 MBean 的特定属性值。
 AttributeList MBeanServer.getAttributes(ObjectName name, String[] attributes)
 AttributeList MBeanServerConnection.getAttributes(ObjectName name, String[] attributes)
获得指定 MBean 的多个属性值。
 ClassLoader MBeanServer.getClassLoader(ObjectName loaderName)
返回指定的 ClassLoader。
 ClassLoader MBeanServer.getClassLoaderFor(ObjectName mbeanName)
返回用于加载指定 MBean 的类的 ClassLoader。
static ObjectName ObjectName.getInstance(ObjectName name)
返回 ObjectName 的实例，该 ObjectName 可用于任何可使用给定对象的地方。
 MBeanInfo MBeanServer.getMBeanInfo(ObjectName name)
 MBeanInfo MBeanServerConnection.getMBeanInfo(ObjectName name)
此方法发现了 MBean 为管理而公开的属性和操作。
 ObjectInstance MBeanServer.getObjectInstance(ObjectName name)
 ObjectInstance MBeanServerConnection.getObjectInstance(ObjectName name)
获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
 Object MBeanServer.instantiate(String className, ObjectName loaderName)
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
 Object MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。
 Object MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
 Object MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。
 boolean MBeanServer.isInstanceOf(ObjectName name, String className)
 boolean MBeanServerConnection.isInstanceOf(ObjectName name, String className)
如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。
 boolean MBeanServer.isRegistered(ObjectName name)
 boolean MBeanServerConnection.isRegistered(ObjectName name)
检查某个 MBean（通过其对象名标识）是否已向 MBean 服务器注册。
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
MBeanServerInvocationHandler.newProxyInstance(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
返回一个代理，该代理通过将其方法从给定 MBean 服务器转发到指定 MBean 来实现给定的接口。
 ObjectName MBeanRegistration.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
 ObjectName StandardMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。
 Set<ObjectInstance> MBeanServer.queryMBeans(ObjectName name, QueryExp query)
 Set<ObjectInstance> MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query)
获得该 MBean 服务器所控制的 MBean。
 Set<ObjectName> MBeanServer.queryNames(ObjectName name, QueryExp query)
 Set<ObjectName> MBeanServerConnection.queryNames(ObjectName name, QueryExp query)
获得该 MBean 服务器所控制的 MBean 的名称。
 ObjectInstance MBeanServer.registerMBean(Object object, ObjectName name)
将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。
 void MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener)
 void MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener)
从已注册的 MBean 中移除一个侦听器。
 void MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
 void MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
从已注册的 MBean 中移除一个侦听器。
 void MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener)
 void MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener)
从已注册的 MBean 中移除一个侦听器。
 void MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
 void MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
从已注册的 MBean 中移除一个侦听器。
 void MBeanServer.setAttribute(ObjectName name, Attribute attribute)
 void MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute)
设置指定 MBean 的特定属性值。
 AttributeList MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
 AttributeList MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes)
设置指定 MBean 的多个属性值。
 void MBeanServer.unregisterMBean(ObjectName name)
 void MBeanServerConnection.unregisterMBean(ObjectName name)
从 MBean 服务器中注销一个 MBean。

参数类型为 ObjectName 的 javax.management 中的构造方法
MBeanPermission(String className, String member, ObjectName objectName, String actions)
创建具有指定目标名称（类名、成员、对象名）和操作的 MBeanPermission 对象。
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName)
通过 MBean 服务器将方法转发给 Standard MBean 的调用处理程序。
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName, boolean isMXBean)
可以通过 MBean 服务器将方法转发给 Standard MBean 或 MXBean 的调用处理程序。
MBeanServerNotification(String type, Object source, long sequenceNumber, ObjectName objectName)
创建一个指定了导致该通知的 MBean 对象名和指定通知类型的 MBeanServerNotification 对象。
ObjectInstance(ObjectName objectName, String className)
允许创建具有给定对象名和完整类名（包括包名）的 ObjectInstance。

javax.management.loading 中 ObjectName 的使用

返回 ObjectName 的 javax.management.loading 中的方法
 ObjectName MLet.preRegister(MBeanServer server, ObjectName name)
允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。

参数类型为 ObjectName 的 javax.management.loading 中的方法
 ObjectName MLet.preRegister(MBeanServer server, ObjectName name)
允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。

javax.management.modelmbean 中 ObjectName 的使用

返回 ObjectName 的 javax.management.modelmbean 中的方法
 ObjectName RequiredModelMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。

参数类型为 ObjectName 的 javax.management.modelmbean 中的方法
 ObjectName RequiredModelMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。

javax.management.monitor 中 ObjectName 的使用

返回 ObjectName 的 javax.management.monitor 中的方法
 ObjectName Monitor.getObservedObject()
已过时。 从 JMX 1.2 开始，由 Monitor.getObservedObjects() 取代
 ObjectName MonitorMBean.getObservedObject()
已过时。 从 JMX 1.2 开始，由 MonitorMBean.getObservedObjects() 取代
 ObjectName MonitorNotification.getObservedObject()
获取此监视器通知的被观察对象。
 ObjectName[] Monitor.getObservedObjects()
返回一个包含要观察的对象的数组。
 ObjectName[] MonitorMBean.getObservedObjects()
返回一个包含要观察的对象的数组。
 ObjectName Monitor.preRegister(MBeanServer server, ObjectName name)
允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。

参数类型为 ObjectName 的 javax.management.monitor 中的方法
 void Monitor.addObservedObject(ObjectName object)
如果尚未显示此对象，则在观察到的 MBean 集中添加指定的对象。
 void MonitorMBean.addObservedObject(ObjectName object)
将指定的对象添加到所观察的 MBean 集中。
 boolean Monitor.containsObservedObject(ObjectName object)
测试指定的对象是否在所观察的 MBean 集中。
 boolean MonitorMBean.containsObservedObject(ObjectName object)
测试指定的对象是否在所观察的 MBean 集中。
 Number CounterMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
 Number CounterMonitorMBean.getDerivedGauge(ObjectName object)
获取指定的 MBean 的派生尺度。
 Number GaugeMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
 Number GaugeMonitorMBean.getDerivedGauge(ObjectName object)
获取指定的 MBean 的派生尺度。
 String StringMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生的尺度，否则将为 null。
 String StringMonitorMBean.getDerivedGauge(ObjectName object)
获取指定 MBean 的派生尺度。
 long CounterMonitor.getDerivedGaugeTimeStamp(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
 long CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName object)
获取指定 MBean 的派生尺度时间戳。
 long GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
 long GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName object)
获取指定 MBean 的派生尺度时间戳。
 long StringMonitor.getDerivedGaugeTimeStamp(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
 long StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName object)
获取指定 MBean 的派生尺度时间戳。
 Number CounterMonitor.getThreshold(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取指定对象的当前阈值，否则将为 null。
 Number CounterMonitorMBean.getThreshold(ObjectName object)
获取指定 MBean 的阈值。
 ObjectName Monitor.preRegister(MBeanServer server, ObjectName name)
允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。
 void Monitor.removeObservedObject(ObjectName object)
从所观察的 MBean 集中移除指定的对象。
 void MonitorMBean.removeObservedObject(ObjectName object)
从所观察的 MBean 集中移除指定的对象。
 void Monitor.setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 Monitor.addObservedObject(javax.management.ObjectName) 取代
 void MonitorMBean.setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 MonitorMBean.addObservedObject(javax.management.ObjectName) 取代

javax.management.openmbean 中 ObjectName 的使用

类型参数类型为 ObjectName 的 javax.management.openmbean 中的字段
static SimpleType<ObjectName> SimpleType.OBJECTNAME
SimpleType 实例，该实例描述其 Java 类名称为 javax.management.ObjectName 的值。

javax.management.relation 中 ObjectName 的使用

返回 ObjectName 的 javax.management.relation 中的方法
ObjectName | RelationNotification.getObjectName() 返回创建/移除/更新的关系的 ObjectName。
ObjectName | Relation.getRelationServiceName() 返回处理关系的 Relation Service 的 ObjectName。
ObjectName | RelationSupport.getRelationServiceName() 返回处理关系的 Relation Service 的 ObjectName。
ObjectName | RelationService.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
ObjectName | RelationServiceMBean.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)

返回变量类型为 ObjectName 的类型的 javax.management.relation 中的方法
Map<ObjectName,List<String>> | RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Vector<ObjectName> | MBeanServerNotificationFilter.getDisabledObjectNames() 获取禁用的所有 ObjectName。
Vector<ObjectName> | MBeanServerNotificationFilter.getEnabledObjectNames() 获取所有已启用的 ObjectName。
List<ObjectName> | RelationNotification.getMBeansToUnregister() 返回因为关系移除而需要注销的 MBean 的 ObjectName 列表（仅限于关系移除）。
List<ObjectName> | RelationNotification.getNewRoleValue() 返回更新的角色的新值（仅限于角色更新）。
List<ObjectName> | RelationNotification.getOldRoleValue() 返回更新的角色的旧值（仅限于角色更新）。
Map<ObjectName,List<String>> | Relation.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationSupport.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationService.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
List<ObjectName> | Relation.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationSupport.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | Role.getRoleValue() 检索角色值。
List<ObjectName> | RoleUnresolved.getRoleValue() 检索角色值。

参数类型为 ObjectName 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | MBeanServerNotificationFilter.disableObjectName(ObjectName objectName) 禁用与给定 ObjectName 有关的 MBeanServerNotification。
void | MBeanServerNotificationFilter.enableObjectName(ObjectName objectName) 启用与给定 ObjectName 有关的 MBeanServerNotification。
Map<ObjectName,List<String>> | RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<String,List<String>> | RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在引用给定 MBean 的引用关系。
Map<String,List<String>> | RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在其中引用给定 MBean 的关系。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
String | RelationService.isRelation(ObjectName objectName) 如果已经将 MBean 作为关系添加在 Relation Service 中，则返回与给定 ObjectName 相关的关系 id。
String | RelationServiceMBean.isRelation(ObjectName objectName) 如果 Relation Service 中作为关系添加 MBean，则返回与给定 ObjectName 相关的关系 id。
ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)

类型变量类型为 ObjectName 的 javax.management.relation 中的方法参数
static String | Role.roleValueToString(List<ObjectName> roleValue) 返回给定角色值的字符串。
void | RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | Role.setRoleValue(List<ObjectName> roleValue) 设置角色值。
void | RoleUnresolved.setRoleValue(List<ObjectName> value) 设置角色值。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

参数类型为 ObjectName 的 javax.management.relation 中的构造方法
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。

类型变量类型为 ObjectName 的 javax.management.relation 中的构造方法参数
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
Role(String roleName, List<ObjectName> roleValue)
创建一个新的 Role 对象。
RoleUnresolved(String name, List<ObjectName> value, int pbType)
构造方法。

javax.management.remote 中 ObjectName 的使用

返回 ObjectName 的 javax.management.remote 中的方法
 ObjectName JMXConnectorServer.preRegister(MBeanServer mbs, ObjectName name)
当此连接器服务器在 MBean 服务器上注册时，由该 MBean 服务器调用此方法。

参数类型为 ObjectName 的 javax.management.remote 中的方法
 ObjectName JMXConnectorServer.preRegister(MBeanServer mbs, ObjectName name)
当此连接器服务器在 MBean 服务器上注册时，由该 MBean 服务器调用此方法。

javax.management.remote.rmi 中 ObjectName 的使用

返回变量类型为 ObjectName 的类型的 javax.management.remote.rmi 中的方法
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)

参数类型为 ObjectName 的 javax.management.remote.rmi 中的方法
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 boolean RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 boolean RMIConnection.isRegistered(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
 boolean RMIConnectionImpl.isRegistered(ObjectName name, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isRegistered(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
 void RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
 void RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

javax.management.timer 中 ObjectName 的使用

返回 ObjectName 的 javax.management.timer 中的方法
 ObjectName Timer.preRegister(MBeanServer server, ObjectName name)
允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。

参数类型为 ObjectName 的 javax.management.timer 中的方法
 ObjectName Timer.preRegister(MBeanServer server, ObjectName name)
允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.OperationsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.OperationsException
的使用

使用 OperationsException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 OperationsException 的使用

javax.management 中 OperationsException 的子类
class | AttributeNotFoundException 指定的属性不存在或无法检索。
class | InstanceAlreadyExistsException 已经在存储库中注册了 MBean。
class | InstanceNotFoundException 存储库中不存在指定的 MBean。
class | IntrospectionException 在 MBean 的 introspection 期间出现的异常。
class | InvalidAttributeValueException 指定的值对该属性无效。
class | ListenerNotFoundException 存储库中不存在指定的 MBean 侦听器。
class | MalformedObjectNameException 字符串的格式不对应于有效的 ObjectName。
class | NotCompliantMBeanException 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
class | ServiceNotFoundException 表示请求的服务不受支持时引发的异常。

抛出 OperationsException 的 javax.management 中的方法
 ObjectInputStream MBeanServer.deserialize(ObjectName name, byte[] data)
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
 ObjectInputStream MBeanServer.deserialize(String className, byte[] data)
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
 ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.PersistentMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.PersistentMBean
的使用

使用 PersistentMBean 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 PersistentMBean 的使用

javax.management.modelmbean 中 PersistentMBean 的子接口
 interface ModelMBean
ModelMBean 必须实现此接口。

实现 PersistentMBean 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.Query 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.Query
的使用

没有 javax.management.Query 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.QueryEval 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.QueryEval
的使用

没有 javax.management.QueryEval 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.QueryExp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.QueryExp
的使用

使用 QueryExp 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 QueryExp 的使用

实现 QueryExp 的 javax.management 中的类
 class ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

返回 QueryExp 的 javax.management 中的方法
static QueryExp | Query.and(QueryExp q1, QueryExp q2) 返回一个查询表达式，它是其他两个查询表达式的“与”。
static QueryExp | Query.anySubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.between(ValueExp v1, ValueExp v2, ValueExp v3) 返回一个查询表达式，表示一个值在其他两个值之间的约束条件。
static QueryExp | Query.eq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的等于约束条件。
static QueryExp | Query.finalSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.geq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“大于或等于”约束条件。
static QueryExp | Query.gt(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“大于”约束条件。
static QueryExp | Query.in(ValueExp val, ValueExp[] valueList) 返回一个表达式，限制某个值为显式列表中的一项。
static QueryExp | Query.initialSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.isInstanceOf(StringValueExp classNameValue) 返回一个查询表达式，表示基于 MBean 类的继承约束条件。
static QueryExp | Query.leq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“小于或等于”约束条件。
static QueryExp | Query.lt(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示 基于两个值的“小于”约束条件。
static QueryExp | Query.match(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的匹配约束条件。
static QueryExp | Query.not(QueryExp queryExp) 返回一个与其参数相反的约束条件。
static QueryExp | Query.or(QueryExp q1, QueryExp q2) 返回一个查询表达式，它是其他两个查询表达式的“或”。

参数类型为 QueryExp 的 javax.management 中的方法
static QueryExp | Query.and(QueryExp q1, QueryExp q2) 返回一个查询表达式，它是其他两个查询表达式的“与”。
static QueryExp | Query.not(QueryExp queryExp) 返回一个与其参数相反的约束条件。
static QueryExp | Query.or(QueryExp q1, QueryExp q2) 返回一个查询表达式，它是其他两个查询表达式的“或”。
Set<ObjectInstance> | MBeanServer.queryMBeans(ObjectName name, QueryExp query)
Set<ObjectInstance> | MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean。
Set<ObjectName> | MBeanServer.queryNames(ObjectName name, QueryExp query)
Set<ObjectName> | MBeanServerConnection.queryNames(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean 的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.ReflectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ReflectionException
的使用

使用 ReflectionException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 ReflectionException 的使用

抛出 ReflectionException 的 javax.management 中的方法
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInputStream MBeanServer.deserialize(String className, byte[] data)
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
 ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。
 Object MBeanServer.getAttribute(ObjectName name, String attribute)
 Object MBeanServerConnection.getAttribute(ObjectName name, String attribute)
获得指定 MBean 的特定属性值。
 Object DynamicMBean.getAttribute(String attribute)
获得 Dynamic MBean 的特定属性的值。
 Object StandardMBean.getAttribute(String attribute)
 AttributeList MBeanServer.getAttributes(ObjectName name, String[] attributes)
 AttributeList MBeanServerConnection.getAttributes(ObjectName name, String[] attributes)
获得指定 MBean 的多个属性值。
 MBeanInfo MBeanServer.getMBeanInfo(ObjectName name)
 MBeanInfo MBeanServerConnection.getMBeanInfo(ObjectName name)
此方法发现了 MBean 为管理而公开的属性和操作。
 Object MBeanServer.instantiate(String className)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。
 Object MBeanServer.instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。
 Object MBeanServer.instantiate(String className, ObjectName loaderName)
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
 Object MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。
 Object MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
 Object MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。
 Object DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
允许在 Dynamic MBean 上调用某个操作。
 Object StandardMBean.invoke(String actionName, Object[] params, String[] signature)
 void DynamicMBean.setAttribute(Attribute attribute)
设置 Dynamic MBean 的特定属性的值。
 void StandardMBean.setAttribute(Attribute attribute)
 void MBeanServer.setAttribute(ObjectName name, Attribute attribute)
 void MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute)
设置指定 MBean 的特定属性值。
 AttributeList MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
 AttributeList MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes)
设置指定 MBean 的多个属性值。

javax.management.modelmbean 中 ReflectionException 的使用

抛出 ReflectionException 的 javax.management.modelmbean 中的方法
Object | RequiredModelMBean.getAttribute(String attrName) 返回为此 ModelMBean 定义的指定属性的值。
Object | RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig) 调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。
void | RequiredModelMBean.setAttribute(Attribute attribute) 设置指定的 ModelMBean 的指定属性值。

javax.management.remote.rmi 中 ReflectionException 的使用

抛出 ReflectionException 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.RuntimeErrorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.RuntimeErrorException
的使用

没有 javax.management.RuntimeErrorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.RuntimeMBeanException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.RuntimeMBeanException
的使用

没有 javax.management.RuntimeMBeanException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.RuntimeOperationsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.RuntimeOperationsException
的使用

使用 RuntimeOperationsException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

javax.management 中 RuntimeOperationsException 的使用

抛出 RuntimeOperationsException 的 javax.management 中的方法
Object | Descriptor.clone() 返回一个与此描述符相等的描述符。
Object | Descriptor.getFieldValue(String fieldName) 返回指定字段名的值，如果该名称不存在任何值，则返回 null。
boolean | Descriptor.isValid() 如果所有字段在给定其名称的情况下都有合法值，则返回 true。
void | PersistentMBean.load() 使用持久存储中找到的 MBean 的数据实例化此 MBean 实例。
void | Descriptor.setField(String fieldName, Object fieldValue) 设置特定字段名的值。
void | ImmutableDescriptor.setField(String fieldName, Object fieldValue) 因为此类不可变，所以不支持此操作。
void | Descriptor.setFields(String[] fieldNames, Object[] fieldValues) 将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。
void | ImmutableDescriptor.setFields(String[] fieldNames, Object[] fieldValues) 因为此类不可变，所以不支持此操作。
void | PersistentMBean.store() 捕获此 MBean 实例的当前状态并将其写出到持久存储中。

javax.management.modelmbean 中 RuntimeOperationsException 的使用

抛出 RuntimeOperationsException 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
Object | DescriptorSupport.clone() 返回作为 Descriptor 副本的新 Descriptor。
ModelMBeanAttributeInfo | ModelMBeanInfo.getAttribute(String inName) 返回通过名称请求的 ModelMBeanAttributeInfo。
ModelMBeanAttributeInfo | ModelMBeanInfoSupport.getAttribute(String inName)
ModelMBeanConstructorInfo | ModelMBeanInfoSupport.getConstructor(String inName) 返回通过名称请求的 ModelMBeanConstructorInfo。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName) 返回通过名称请求的 Descriptor。
Descriptor | ModelMBeanInfo.getDescriptor(String inDescriptorName, String inDescriptorType) 返回通过 name 和 descriptorType 请求的 Descriptor。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName, String inDescriptorType)
Descriptor[] | ModelMBeanInfo.getDescriptors(String inDescriptorType) 返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。
Descriptor[] | ModelMBeanInfoSupport.getDescriptors(String inDescriptorType)
Object | DescriptorSupport.getFieldValue(String fieldName)
Descriptor | ModelMBeanInfo.getMBeanDescriptor() 返回包含 MBean 级策略的 ModelMBean 的描述符。
ModelMBeanNotificationInfo | ModelMBeanInfo.getNotification(String inName) 返回通过名称请求的 ModelMBeanNotificationInfo。
ModelMBeanNotificationInfo | ModelMBeanInfoSupport.getNotification(String inName)
ModelMBeanOperationInfo | ModelMBeanInfo.getOperation(String inName) 返回通过名称请求的 ModelMBeanOperationInfo。
ModelMBeanOperationInfo | ModelMBeanInfoSupport.getOperation(String inName)
boolean | DescriptorSupport.isValid() 如果所有给定名称的字段都有合法值，则返回 true。
void | RequiredModelMBean.load() 使用在持久存储中找到的 MBean 的数据实例化此 MBean。
void | ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName) 从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
void | RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(Attribute oldValue, Attribute newValue) 将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(Attribute inOldVal, Attribute inNewVal)
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(AttributeChangeNotification notification) 将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)
void | ModelMBeanNotificationBroadcaster.sendNotification(Notification ntfyObj) 以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | RequiredModelMBean.sendNotification(Notification ntfyObj)
void | ModelMBeanNotificationBroadcaster.sendNotification(String ntfyText) 将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | RequiredModelMBean.sendNotification(String ntfyText)
void | ModelMBeanInfo.setDescriptor(Descriptor inDescriptor, String inDescriptorType) 设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。
void | ModelMBeanInfoSupport.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
void | ModelMBeanInfo.setDescriptors(Descriptor[] inDescriptors) 添加或替换 ModelMBeanInfo 中的描述符。
void | ModelMBeanInfoSupport.setDescriptors(Descriptor[] inDescriptors)
void | DescriptorSupport.setField(String fieldName, Object fieldValue)
void | DescriptorSupport.setFields(String[] fieldNames, Object[] fieldValues)
void | ModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
void | RequiredModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。
void | ModelMBeanInfo.setMBeanDescriptor(Descriptor inDescriptor) 设置 ModelMBean 的描述符。
void | ModelMBeanInfoSupport.setMBeanDescriptor(Descriptor inMBeanDescriptor)
void | ModelMBean.setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | RequiredModelMBean.setModelMBeanInfo(ModelMBeanInfo mbi) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | RequiredModelMBean.store() 捕获此 MBean 实例的当前状态，并将它写出到持久存储中。

抛出 RuntimeOperationsException 的 javax.management.modelmbean 中的构造方法
DescriptorSupport(int initNumFields)
描述符构造方法。
DescriptorSupport(String inStr)
Descriptor 构造方法带有一个 XML String。
DescriptorSupport(String[] fieldNames, Object[] fieldValues)
带有字段名称和字段值的构造方法。
RequiredModelMBean()
构造带有空 ModelMBeanInfo 的 RequiredModelMBean。
RequiredModelMBean(ModelMBeanInfo mbi)
使用传入的 ModelMBeanInfo 构造 RequiredModelMBean 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.ServiceNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ServiceNotFoundException
的使用

使用 ServiceNotFoundException 的软件包
javax.management.loading 提供实现高级动态加载的类。

javax.management.loading 中 ServiceNotFoundException 的使用

抛出 ServiceNotFoundException 的 javax.management.loading 中的方法
void | MLet.addURL(String url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
void | MLetMBean.addURL(String url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
Set<Object> | MLet.getMBeansFromURL(String url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLetMBean.getMBeansFromURL(String url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLet.getMBeansFromURL(URL url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLetMBean.getMBeansFromURL(URL url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.StandardEmitterMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.StandardEmitterMBean
的使用

没有 javax.management.StandardEmitterMBean 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.StandardMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.StandardMBean
的使用

使用 StandardMBean 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 StandardMBean 的使用

javax.management 中 StandardMBean 的子类
 class StandardEmitterMBean
一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.StringValueExp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.StringValueExp
的使用

使用 StringValueExp 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 StringValueExp 的使用

返回 StringValueExp 的 javax.management 中的方法
static StringValueExp Query.value(String val)
返回一个新的字符串表达式。

参数类型为 StringValueExp 的 javax.management 中的方法
static QueryExp | Query.anySubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.finalSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.initialSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.isInstanceOf(StringValueExp classNameValue) 返回一个查询表达式，表示基于 MBean 类的继承约束条件。
static QueryExp | Query.match(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的匹配约束条件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.ValueExp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.ValueExp
的使用

使用 ValueExp 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 ValueExp 的使用

实现 ValueExp 的 javax.management 中的类
class | AttributeValueExp 表示用作关系约束参数的属性。
class | StringValueExp 表示作为关系约束变量的字符串。

返回 ValueExp 的 javax.management 中的方法
ValueExp | AttributeValueExp.apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
ValueExp | StringValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
ValueExp | ValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
static ValueExp | Query.div(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的商。
ValueExp | BadBinaryOpValueExpException.getExp() 返回产生该异常的 ValueExp。
static ValueExp | Query.minus(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的差。
static ValueExp | Query.plus(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的和，或者两个字符串值的串接。
static ValueExp | Query.times(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的乘积。
static ValueExp | Query.value(boolean val) 返回一个 boolean 值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | Query.value(double val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | Query.value(float val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | Query.value(int val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | Query.value(long val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | Query.value(Number val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

参数类型为 ValueExp 的 javax.management 中的方法
static QueryExp | Query.between(ValueExp v1, ValueExp v2, ValueExp v3) 返回一个查询表达式，表示一个值在其他两个值之间的约束条件。
static ValueExp | Query.div(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的商。
static QueryExp | Query.eq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的等于约束条件。
static QueryExp | Query.geq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“大于或等于”约束条件。
static QueryExp | Query.gt(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“大于”约束条件。
static QueryExp | Query.in(ValueExp val, ValueExp[] valueList) 返回一个表达式，限制某个值为显式列表中的一项。
static QueryExp | Query.in(ValueExp val, ValueExp[] valueList) 返回一个表达式，限制某个值为显式列表中的一项。
static QueryExp | Query.leq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“小于或等于”约束条件。
static QueryExp | Query.lt(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示 基于两个值的“小于”约束条件。
static ValueExp | Query.minus(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的差。
static ValueExp | Query.plus(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的和，或者两个字符串值的串接。
static ValueExp | Query.times(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的乘积。

参数类型为 ValueExp 的 javax.management 中的构造方法
BadBinaryOpValueExpException(ValueExp exp)
构造带指定 ValueExp 的 BadBinaryOpValueExpException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.management.loading (Java 2 Platform SE 6)

 javax.management.loading
接口
ClassLoaderRepository
MLetMBean
PrivateClassLoader
类
DefaultLoaderRepository
MLet
MLetContent
PrivateMLet


接口 javax.management.loading.ClassLoaderRepository 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.loading.ClassLoaderRepository
的使用

使用 ClassLoaderRepository 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

javax.management 中 ClassLoaderRepository 的使用

返回 ClassLoaderRepository 的 javax.management 中的方法
ClassLoaderRepository | MBeanServer.getClassLoaderRepository() 返回此 MBeanServer 的 ClassLoaderRepository。
static ClassLoaderRepository | MBeanServerFactory.getClassLoaderRepository(MBeanServer server) 返回给定 MBeanServer 使用的 ClassLoaderRepository。

javax.management.loading 中 ClassLoaderRepository 的使用

参数类型为 ClassLoaderRepository 的 javax.management.loading 中的方法
 Class<?> MLet.loadClass(String name, ClassLoaderRepository clr)
如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。

javax.management.modelmbean 中 ClassLoaderRepository 的使用

返回 ClassLoaderRepository 的 javax.management.modelmbean 中的方法
protected  ClassLoaderRepository RequiredModelMBean.getClassLoaderRepository()
返回用于执行类加载的 Class Loader Repository。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.loading.DefaultLoaderRepository 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.loading.DefaultLoaderRepository
的使用

没有 javax.management.loading.DefaultLoaderRepository 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.loading.MLet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.loading.MLet
的使用

使用 MLet 的软件包
javax.management.loading 提供实现高级动态加载的类。

javax.management.loading 中 MLet 的使用

javax.management.loading 中 MLet 的子类
 class PrivateMLet
不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.loading.MLetContent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.loading.MLetContent
的使用

使用 MLetContent 的软件包
javax.management.loading 提供实现高级动态加载的类。

javax.management.loading 中 MLetContent 的使用

参数类型为 MLetContent 的 javax.management.loading 中的方法
protected  URL MLet.check(String version, URL codebase, String jarfile, MLetContent mlet)
当扩展此服务来支持缓存和版本控制时，要重写此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.loading.MLetMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.loading.MLetMBean
的使用

使用 MLetMBean 的软件包
javax.management.loading 提供实现高级动态加载的类。

javax.management.loading 中 MLetMBean 的使用

实现 MLetMBean 的 javax.management.loading 中的类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.loading.PrivateClassLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.loading.PrivateClassLoader
的使用

使用 PrivateClassLoader 的软件包
javax.management.loading 提供实现高级动态加载的类。

javax.management.loading 中 PrivateClassLoader 的使用

实现 PrivateClassLoader 的 javax.management.loading 中的类
 class PrivateMLet
不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.loading.PrivateMLet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.loading.PrivateMLet
的使用

没有 javax.management.loading.PrivateMLet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.management.modelmbean (Java 2 Platform SE 6)

 javax.management.modelmbean
接口
ModelMBean
ModelMBeanInfo
ModelMBeanNotificationBroadcaster
类
DescriptorSupport
ModelMBeanAttributeInfo
ModelMBeanConstructorInfo
ModelMBeanInfoSupport
ModelMBeanNotificationInfo
ModelMBeanOperationInfo
RequiredModelMBean
异常
InvalidTargetObjectTypeException
XMLParseException


类 javax.management.modelmbean.DescriptorSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.DescriptorSupport
的使用

使用 DescriptorSupport 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 DescriptorSupport 的使用

参数类型为 DescriptorSupport 的 javax.management.modelmbean 中的构造方法
DescriptorSupport(DescriptorSupport inDescr)
采用 Descriptor 作为参数的描述符构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.modelmbean.InvalidTargetObjectTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.InvalidTargetObjectTypeException
的使用

使用 InvalidTargetObjectTypeException 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 InvalidTargetObjectTypeException 的使用

抛出 InvalidTargetObjectTypeException 的 javax.management.modelmbean 中的方法
void | ModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
void | RequiredModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.modelmbean.ModelMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.modelmbean.ModelMBean
的使用

使用 ModelMBean 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBean 的使用

实现 ModelMBean 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.modelmbean.ModelMBeanAttributeInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.ModelMBeanAttributeInfo
的使用

使用 ModelMBeanAttributeInfo 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanAttributeInfo 的使用

返回 ModelMBeanAttributeInfo 的 javax.management.modelmbean 中的方法
ModelMBeanAttributeInfo | ModelMBeanInfo.getAttribute(String inName) 返回通过名称请求的 ModelMBeanAttributeInfo。
ModelMBeanAttributeInfo | ModelMBeanInfoSupport.getAttribute(String inName)

参数类型为 ModelMBeanAttributeInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanAttributeInfo(ModelMBeanAttributeInfo inInfo)
根据此 ModelMBeanAttributeInfo Object 构造新的 ModelMBeanAttributeInfo 对象。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.modelmbean.ModelMBeanConstructorInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.ModelMBeanConstructorInfo
的使用

使用 ModelMBeanConstructorInfo 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanConstructorInfo 的使用

返回 ModelMBeanConstructorInfo 的 javax.management.modelmbean 中的方法
 ModelMBeanConstructorInfo ModelMBeanInfoSupport.getConstructor(String inName)
返回通过名称请求的 ModelMBeanConstructorInfo。

参数类型为 ModelMBeanConstructorInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.modelmbean.ModelMBeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.modelmbean.ModelMBeanInfo
的使用

使用 ModelMBeanInfo 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanInfo 的使用

实现 ModelMBeanInfo 的 javax.management.modelmbean 中的类
 class ModelMBeanInfoSupport
此类表示 ModelMBean 的元数据。

参数类型为 ModelMBeanInfo 的 javax.management.modelmbean 中的方法
void | ModelMBean.setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | RequiredModelMBean.setModelMBeanInfo(ModelMBeanInfo mbi) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。

参数类型为 ModelMBeanInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanInfoSupport(ModelMBeanInfo mbi)
构造作为给定 ModelMBeanInfoSupport 副本的 ModelMBeanInfoSupport。
RequiredModelMBean(ModelMBeanInfo mbi)
使用传入的 ModelMBeanInfo 构造 RequiredModelMBean 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.modelmbean.ModelMBeanInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.ModelMBeanInfoSupport
的使用

没有 javax.management.modelmbean.ModelMBeanInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster
的使用

使用 ModelMBeanNotificationBroadcaster 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanNotificationBroadcaster 的使用

javax.management.modelmbean 中 ModelMBeanNotificationBroadcaster 的子接口
 interface ModelMBean
ModelMBean 必须实现此接口。

实现 ModelMBeanNotificationBroadcaster 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.modelmbean.ModelMBeanNotificationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.ModelMBeanNotificationInfo
的使用

使用 ModelMBeanNotificationInfo 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanNotificationInfo 的使用

返回 ModelMBeanNotificationInfo 的 javax.management.modelmbean 中的方法
ModelMBeanNotificationInfo | ModelMBeanInfo.getNotification(String inName) 返回通过名称请求的 ModelMBeanNotificationInfo。
ModelMBeanNotificationInfo | ModelMBeanInfoSupport.getNotification(String inName)

参数类型为 ModelMBeanNotificationInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。
ModelMBeanNotificationInfo(ModelMBeanNotificationInfo inInfo)
从此 ModelMBeanNotfication Object 构造新 ModelMBeanNotificationInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.modelmbean.ModelMBeanOperationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.ModelMBeanOperationInfo
的使用

使用 ModelMBeanOperationInfo 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanOperationInfo 的使用

返回 ModelMBeanOperationInfo 的 javax.management.modelmbean 中的方法
ModelMBeanOperationInfo | ModelMBeanInfo.getOperation(String inName) 返回通过名称请求的 ModelMBeanOperationInfo。
ModelMBeanOperationInfo | ModelMBeanInfoSupport.getOperation(String inName)

参数类型为 ModelMBeanOperationInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。
ModelMBeanOperationInfo(ModelMBeanOperationInfo inInfo)
根据此 ModelMBeanOperation Object 构造新的 ModelMBeanOperationInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.modelmbean.RequiredModelMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.RequiredModelMBean
的使用

没有 javax.management.modelmbean.RequiredModelMBean 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.modelmbean.XMLParseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.XMLParseException
的使用

使用 XMLParseException 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 XMLParseException 的使用

抛出 XMLParseException 的 javax.management.modelmbean 中的构造方法
DescriptorSupport(String inStr)
Descriptor 构造方法带有一个 XML String。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.management.monitor (Java 2 Platform SE 6)

 javax.management.monitor
接口
CounterMonitorMBean
GaugeMonitorMBean
MonitorMBean
StringMonitorMBean
类
CounterMonitor
GaugeMonitor
Monitor
MonitorNotification
StringMonitor
异常
MonitorSettingException


类 javax.management.monitor.CounterMonitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.CounterMonitor
的使用

没有 javax.management.monitor.CounterMonitor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.monitor.CounterMonitorMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.monitor.CounterMonitorMBean
的使用

使用 CounterMonitorMBean 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 中 CounterMonitorMBean 的使用

实现 CounterMonitorMBean 的 javax.management.monitor 中的类
 class CounterMonitor
定义专门用来观察计数器属性值的监视器 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.monitor.GaugeMonitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.GaugeMonitor
的使用

没有 javax.management.monitor.GaugeMonitor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.monitor.GaugeMonitorMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.monitor.GaugeMonitorMBean
的使用

使用 GaugeMonitorMBean 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 中 GaugeMonitorMBean 的使用

实现 GaugeMonitorMBean 的 javax.management.monitor 中的类
 class GaugeMonitor
定义专门用来观察尺度属性值的监视器 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.monitor.Monitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.Monitor
的使用

使用 Monitor 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 中 Monitor 的使用

javax.management.monitor 中 Monitor 的子类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.monitor.MonitorMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.monitor.MonitorMBean
的使用

使用 MonitorMBean 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 中 MonitorMBean 的使用

javax.management.monitor 中 MonitorMBean 的子接口
interface | CounterMonitorMBean 公开计数器监视器 MBean 的远程管理接口。
interface | GaugeMonitorMBean 公开尺度监视器 MBean 的远程管理接口。
interface | StringMonitorMBean 公开字符串监视器 MBean 的远程管理接口。

实现 MonitorMBean 的 javax.management.monitor 中的类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | Monitor 定义所有监视器 MBean 的公共部分。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.monitor.MonitorNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.MonitorNotification
的使用

没有 javax.management.monitor.MonitorNotification 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.monitor.MonitorSettingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.MonitorSettingException
的使用

没有 javax.management.monitor.MonitorSettingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.monitor.StringMonitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.StringMonitor
的使用

没有 javax.management.monitor.StringMonitor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.monitor.StringMonitorMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.monitor.StringMonitorMBean
的使用

使用 StringMonitorMBean 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 中 StringMonitorMBean 的使用

实现 StringMonitorMBean 的 javax.management.monitor 中的类
 class StringMonitor
定义设计用于观察字符串属性值的监视器 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.management.openmbean (Java 2 Platform SE 6)

 javax.management.openmbean
接口
CompositeData
CompositeDataView
OpenMBeanAttributeInfo
OpenMBeanConstructorInfo
OpenMBeanInfo
OpenMBeanOperationInfo
OpenMBeanParameterInfo
TabularData
类
ArrayType
CompositeDataInvocationHandler
CompositeDataSupport
CompositeType
OpenMBeanAttributeInfoSupport
OpenMBeanConstructorInfoSupport
OpenMBeanInfoSupport
OpenMBeanOperationInfoSupport
OpenMBeanParameterInfoSupport
OpenType
SimpleType
TabularDataSupport
TabularType
异常
InvalidKeyException
InvalidOpenTypeException
KeyAlreadyExistsException
OpenDataException


类 javax.management.openmbean.ArrayType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.ArrayType
的使用

使用 ArrayType 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 ArrayType 的使用

返回 ArrayType 的 javax.management.openmbean 中的方法
static
<E> ArrayType<E[]>
ArrayType.getArrayType(OpenType<E> elementType)
以类型安全的方式创建一个 ArrayType 实例。
static
<T> ArrayType<T>
ArrayType.getPrimitiveArrayType(Class<T> arrayClass)
以类型安全的方式创建一个 ArrayType 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.openmbean.CompositeData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.CompositeData
的使用

使用 CompositeData 的软件包
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang.management 中 CompositeData 的使用

参数类型为 CompositeData 的 java.lang.management 中的方法
static MemoryNotificationInfo | MemoryNotificationInfo.from(CompositeData cd) 返回由给定 CompositeData 表示的 MemoryNotificationInfo 对象。
static MemoryUsage | MemoryUsage.from(CompositeData cd) 返回由给定 CompositeData 表示的 MemoryUsage 对象。
static MonitorInfo | MonitorInfo.from(CompositeData cd) 返回给定 CompositeData 表示的 MonitorInfo 对象。
static ThreadInfo | ThreadInfo.from(CompositeData cd) 返回由给定 CompositeData 表示的 ThreadInfo 对象。

javax.management.openmbean 中 CompositeData 的使用

实现 CompositeData 的 javax.management.openmbean 中的类
 class CompositeDataSupport
CompositeDataSupport 类是实现 CompositeData 接口的开放数据 类。

返回 CompositeData 的 javax.management.openmbean 中的方法
CompositeData | TabularData.get(Object[] key) 返回此 TabularData 实例中其索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。
CompositeData | TabularDataSupport.get(Object[] key) 返回此 TabularData 实例中索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。
CompositeData | CompositeDataInvocationHandler.getCompositeData() 返回提供给构造方法的 CompositeData。
CompositeData | TabularData.remove(Object[] key) 从此 TabularData 实例中移除其索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。
CompositeData | TabularDataSupport.remove(Object[] key) 从此 TabularData 实例中移除索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。
CompositeData | CompositeDataView.toCompositeData(CompositeType ct) 返回对应于此对象中的值的 CompositeData。

参数类型为 CompositeData 的 javax.management.openmbean 中的方法
Object[] | TabularData.calculateIndex(CompositeData value) 计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例中后引用该参数。
Object[] | TabularDataSupport.calculateIndex(CompositeData value) 计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例后引用该参数。
boolean | TabularData.containsValue(CompositeData value) 当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。
boolean | TabularDataSupport.containsValue(CompositeData value) 当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。
void | TabularData.put(CompositeData value) 将 value 添加到此 TabularData 实例。
void | TabularDataSupport.put(CompositeData value)
void | TabularData.putAll(CompositeData[] values) 将 values 中的所有元素添加到此 TabularData 实例。
void | TabularDataSupport.putAll(CompositeData[] values) 将 values 中的所有元素添加到此 TabularData 实例。

参数类型为 CompositeData 的 javax.management.openmbean 中的构造方法
CompositeDataInvocationHandler(CompositeData compositeData)
构造一个受给定 CompositeData 支持的处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.CompositeDataInvocationHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.CompositeDataInvocationHandler
的使用

没有 javax.management.openmbean.CompositeDataInvocationHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.CompositeDataSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.CompositeDataSupport
的使用

没有 javax.management.openmbean.CompositeDataSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.openmbean.CompositeDataView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.CompositeDataView
的使用

没有 javax.management.openmbean.CompositeDataView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.CompositeType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.CompositeType
的使用

使用 CompositeType 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 CompositeType 的使用

返回 CompositeType 的 javax.management.openmbean 中的方法
CompositeType | CompositeData.getCompositeType() 返回此复合数据 实例的复合类型。
CompositeType | CompositeDataSupport.getCompositeType() 返回此复合数据 实例的复合类型。
CompositeType | TabularType.getRowType() 返回此 TabularType 实例描述的表格数据值的行元素的类型。

参数类型为 CompositeType 的 javax.management.openmbean 中的方法
 CompositeData CompositeDataView.toCompositeData(CompositeType ct)
返回对应于此对象中的值的 CompositeData。

参数类型为 CompositeType 的 javax.management.openmbean 中的构造方法
CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。
CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。
TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
构造一个 TabularType 实例，检查给定参数的有效性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.InvalidKeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.InvalidKeyException
的使用

没有 javax.management.openmbean.InvalidKeyException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.InvalidOpenTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.InvalidOpenTypeException
的使用

没有 javax.management.openmbean.InvalidOpenTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.KeyAlreadyExistsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.KeyAlreadyExistsException
的使用

没有 javax.management.openmbean.KeyAlreadyExistsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.OpenDataException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenDataException
的使用

使用 OpenDataException 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenDataException 的使用

抛出 OpenDataException 的 javax.management.openmbean 中的方法
static
<E> ArrayType<E[]>
ArrayType.getArrayType(OpenType<E> elementType)
以类型安全的方式创建一个 ArrayType 实例。

抛出 OpenDataException 的 javax.management.openmbean 中的构造方法
ArrayType(int dimension, OpenType<?> elementType)
构造一个描述开放数据 值的 ArrayType 实例，该值是其元素的开放类型 为 elementType、元素的维度为 dimension 的数组。
ArrayType(SimpleType<?> elementType, boolean primitiveArray)
为提供的 SimpleType 构造一个一维 ArrayType 实例。
CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。
CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。
CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue，以及制定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 defaultValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。
OpenType(String className, String typeName, String description)
构造一个 OpenType 实例（实际上是一个子类实例，因为 OpenType 是抽象的），检查给定参数的有效性。
TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
构造一个 TabularType 实例，检查给定参数的有效性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.openmbean.OpenMBeanAttributeInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.OpenMBeanAttributeInfo
的使用

使用 OpenMBeanAttributeInfo 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenMBeanAttributeInfo 的使用

实现 OpenMBeanAttributeInfo 的 javax.management.openmbean 中的类
 class OpenMBeanAttributeInfoSupport
描述 open MBean 的一个属性。

参数类型为 OpenMBeanAttributeInfo 的 javax.management.openmbean 中的构造方法
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenMBeanAttributeInfoSupport
的使用

没有 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.openmbean.OpenMBeanConstructorInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.OpenMBeanConstructorInfo
的使用

使用 OpenMBeanConstructorInfo 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenMBeanConstructorInfo 的使用

实现 OpenMBeanConstructorInfo 的 javax.management.openmbean 中的类
 class OpenMBeanConstructorInfoSupport
描述 Open MBean 的构造方法。

参数类型为 OpenMBeanConstructorInfo 的 javax.management.openmbean 中的构造方法
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenMBeanConstructorInfoSupport
的使用

没有 javax.management.openmbean.OpenMBeanConstructorInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.openmbean.OpenMBeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.OpenMBeanInfo
的使用

使用 OpenMBeanInfo 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenMBeanInfo 的使用

实现 OpenMBeanInfo 的 javax.management.openmbean 中的类
 class OpenMBeanInfoSupport
OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.OpenMBeanInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenMBeanInfoSupport
的使用

没有 javax.management.openmbean.OpenMBeanInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.openmbean.OpenMBeanOperationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.OpenMBeanOperationInfo
的使用

使用 OpenMBeanOperationInfo 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenMBeanOperationInfo 的使用

实现 OpenMBeanOperationInfo 的 javax.management.openmbean 中的类
 class OpenMBeanOperationInfoSupport
描述 Open MBean 的一个操作。

参数类型为 OpenMBeanOperationInfo 的 javax.management.openmbean 中的构造方法
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.OpenMBeanOperationInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenMBeanOperationInfoSupport
的使用

没有 javax.management.openmbean.OpenMBeanOperationInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.openmbean.OpenMBeanParameterInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.OpenMBeanParameterInfo
的使用

使用 OpenMBeanParameterInfo 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenMBeanParameterInfo 的使用

javax.management.openmbean 中 OpenMBeanParameterInfo 的子接口
 interface OpenMBeanAttributeInfo
描述 open MBean 的属性。

实现 OpenMBeanParameterInfo 的 javax.management.openmbean 中的类
class | OpenMBeanAttributeInfoSupport 描述 open MBean 的一个属性。
class | OpenMBeanParameterInfoSupport 描述用于 open MBean 的一个或多个操作或构造方法的参数。

参数类型为 OpenMBeanParameterInfo 的 javax.management.openmbean 中的构造方法
OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description 和 signature 描述 open MBeans 的类的构造方法。
OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description、signature 和 descriptor 来描述 open MBean 类的构造方法。
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType 和 impact 描述 open MBeans 的类的操作。
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenMBeanParameterInfoSupport
的使用

没有 javax.management.openmbean.OpenMBeanParameterInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.OpenType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenType
的使用

使用 OpenType 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenType 的使用

javax.management.openmbean 中 OpenType 的子类
class | ArrayType<T> ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。
class | CompositeType CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。
class | SimpleType<T> SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。
class | TabularType TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。

返回 OpenType 的 javax.management.openmbean 中的方法
OpenType<?> | ArrayType.getElementOpenType() 返回此 ArrayType 实例描述的数组中包含的元素值的开放类型。
OpenType<?> | OpenMBeanAttributeInfoSupport.getOpenType() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性值的开放类型。
OpenType<?> | OpenMBeanParameterInfo.getOpenType() 返回此 OpenMBeanParameterInfo 实例描述的参数值的开放类型。
OpenType<?> | OpenMBeanParameterInfoSupport.getOpenType() 返回此 OpenMBeanParameterInfoSupport 实例描述的参数值的开放类型。
OpenType<?> | OpenMBeanOperationInfo.getReturnOpenType() 返回此 OpenMBeanOperationInfo 描述的操作所返回的值的开放类型。
OpenType<?> | OpenMBeanOperationInfoSupport.getReturnOpenType() 返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的开放类型。
OpenType<?> | CompositeType.getType(String itemName) 返回名称是 itemName 的项的开放类型，如果 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。

参数类型为 OpenType 的 javax.management.openmbean 中的方法
static
<E> ArrayType<E[]>
ArrayType.getArrayType(OpenType<E> elementType)
以类型安全的方式创建一个 ArrayType 实例。

参数类型为 OpenType 的 javax.management.openmbean 中的构造方法
ArrayType(int dimension, OpenType<?> elementType)
构造一个描述开放数据 值的 ArrayType 实例，该值是其元素的开放类型 为 elementType、元素的维度为 dimension 的数组。
CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、<openType 和 description 以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、读/写访问属性和 Descriptor 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue，以及制定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType 和 impact 描述 open MBeans 的类的操作。
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType 和 description 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType, Descriptor descriptor)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 descriptor 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 defaultValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.SimpleType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.SimpleType
的使用

使用 SimpleType 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 SimpleType 的使用

声明为 SimpleType 的 javax.management.openmbean 中的字段
static SimpleType<BigDecimal> | SimpleType.BIGDECIMAL SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigDecimal 的值。
static SimpleType<BigInteger> | SimpleType.BIGINTEGER SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigInteger 的值。
static SimpleType<Boolean> | SimpleType.BOOLEAN SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Boolean 的值。
static SimpleType<Byte> | SimpleType.BYTE SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Byte 的值。
static SimpleType<Character> | SimpleType.CHARACTER SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Character 的值。
static SimpleType<Date> | SimpleType.DATE SimpleType 实例，该实例描述其 Java 类名称为 java.util.Date 的值。
static SimpleType<Double> | SimpleType.DOUBLE SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Double 的值。
static SimpleType<Float> | SimpleType.FLOAT SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Float 的值。
static SimpleType<Integer> | SimpleType.INTEGER SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Integer 的值。
static SimpleType<Long> | SimpleType.LONG SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Long 的值。
static SimpleType<ObjectName> | SimpleType.OBJECTNAME SimpleType 实例，该实例描述其 Java 类名称为 javax.management.ObjectName 的值。
static SimpleType<Short> | SimpleType.SHORT SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Short 的值。
static SimpleType<String> | SimpleType.STRING SimpleType 实例，该实例描述其 Java 类名称为 java.lang.String 的值。
static SimpleType<Void> | SimpleType.VOID SimpleType 实例描述其 Java 类名称为 java.lang.Void 的值。

参数类型为 SimpleType 的 javax.management.openmbean 中的构造方法
ArrayType(SimpleType<?> elementType, boolean primitiveArray)
为提供的 SimpleType 构造一个一维 ArrayType 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.openmbean.TabularData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.TabularData
的使用

使用 TabularData 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 TabularData 的使用

实现 TabularData 的 javax.management.openmbean 中的类
 class TabularDataSupport
TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.TabularDataSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.TabularDataSupport
的使用

没有 javax.management.openmbean.TabularDataSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.openmbean.TabularType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.TabularType
的使用

使用 TabularType 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 TabularType 的使用

返回 TabularType 的 javax.management.openmbean 中的方法
TabularType | TabularData.getTabularType() 返回描述此 TabularData 实例的表格类型。
TabularType | TabularDataSupport.getTabularType() 返回描述此 TabularData 实例的表格类型。

参数类型为 TabularType 的 javax.management.openmbean 中的构造方法
TabularDataSupport(TabularType tabularType)
创建一个空 TabularDataSupport 实例，其开放类型是 tabularType，并且它的基础 HashMap 具有默认初始容量 (101) 和默认加载因子 (0.75)。
TabularDataSupport(TabularType tabularType, int initialCapacity, float loadFactor)
创建一个空 TabularDataSupport 实例，其开放类型为 tabularType，它的基础 HashMap 具有指定的初始容量和加载因子。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.management.relation (Java 2 Platform SE 6)

 javax.management.relation
接口
Relation
RelationServiceMBean
RelationSupportMBean
RelationType
类
MBeanServerNotificationFilter
RelationNotification
RelationService
RelationSupport
RelationTypeSupport
Role
RoleInfo
RoleList
RoleResult
RoleStatus
RoleUnresolved
RoleUnresolvedList
异常
InvalidRelationIdException
InvalidRelationServiceException
InvalidRelationTypeException
InvalidRoleInfoException
InvalidRoleValueException
RelationException
RelationNotFoundException
RelationServiceNotRegisteredException
RelationTypeNotFoundException
RoleInfoNotFoundException
RoleNotFoundException


类 javax.management.relation.InvalidRelationIdException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.InvalidRelationIdException
的使用

使用 InvalidRelationIdException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 InvalidRelationIdException 的使用

抛出 InvalidRelationIdException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.InvalidRelationServiceException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.InvalidRelationServiceException
的使用

使用 InvalidRelationServiceException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 InvalidRelationServiceException 的使用

抛出 InvalidRelationServiceException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.InvalidRelationTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.InvalidRelationTypeException
的使用

使用 InvalidRelationTypeException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 InvalidRelationTypeException 的使用

抛出 InvalidRelationTypeException 的 javax.management.relation 中的方法
void | RelationService.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
void | RelationServiceMBean.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
protected void | RelationTypeSupport.addRoleInfo(RoleInfo roleInfo) 添加角色信息。
void | RelationService.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。

抛出 InvalidRelationTypeException 的 javax.management.relation 中的构造方法
RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
所有角色定义在其中动态创建并作为参数传递的构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.InvalidRoleInfoException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.InvalidRoleInfoException
的使用

使用 InvalidRoleInfoException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 InvalidRoleInfoException 的使用

抛出 InvalidRoleInfoException 的 javax.management.relation 中的构造方法
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.InvalidRoleValueException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.InvalidRoleValueException
的使用

使用 InvalidRoleValueException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 InvalidRoleValueException 的使用

抛出 InvalidRoleValueException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。

抛出 InvalidRoleValueException 的 javax.management.relation 中的构造方法
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.MBeanServerNotificationFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.MBeanServerNotificationFilter
的使用

没有 javax.management.relation.MBeanServerNotificationFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.relation.Relation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.relation.Relation
的使用

使用 Relation 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 Relation 的使用

javax.management.relation 中 Relation 的子接口
 interface RelationSupportMBean
RelationSupport 对象由 Relation Service 内部使用，表示任何关系类型的具有无限量角色的简单关系（只有角色，没有属性或方法）。

实现 Relation 的 javax.management.relation 中的类
 class RelationSupport
RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RelationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationException
的使用

使用 RelationException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationException 的使用

javax.management.relation 中 RelationException 的子类
class | InvalidRelationIdException 为关系提供的关系 id 已使用时引发此异常。
class | InvalidRelationServiceException 提供无效 Relation Service（关系服务）时引发此异常。
class | InvalidRelationTypeException 无效的关系类型。
class | InvalidRoleInfoException 在角色信息中，其最小程度大于其最大程度时，引发此异常。
class | InvalidRoleValueException 角色值无效。
class | RelationNotFoundException Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
class | RelationServiceNotRegisteredException 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
class | RelationTypeNotFoundException Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
class | RoleInfoNotFoundException 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
class | RoleNotFoundException 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RelationNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationNotFoundException
的使用

使用 RelationNotFoundException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationNotFoundException 的使用

抛出 RelationNotFoundException 的 javax.management.relation 中的方法
RoleResult | RelationService.getAllRoles(String relationId) 返回关系中存在的所有角色。
RoleResult | RelationServiceMBean.getAllRoles(String relationId) 返回关系中存在的所有角色。
Map<ObjectName,List<String>> | RelationService.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
String | RelationService.getRelationTypeName(String relationId) 返回给定关系的相关关系类型的名称。
String | RelationServiceMBean.getRelationTypeName(String relationId) 返回给定关系的相关关系类型的名称。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
Integer | RelationService.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
Integer | RelationServiceMBean.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
RoleResult | RelationService.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
RoleResult | RelationServiceMBean.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
ObjectName | RelationService.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
ObjectName | RelationServiceMBean.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
void | RelationService.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationServiceMBean.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationService.sendRelationCreationNotification(String relationId) 发送关系创建通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationCreationNotification(String relationId) 发送关系创建通知 (RelationNotification)。
void | RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。
RoleResult | RelationService.setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
RoleResult | RelationServiceMBean.setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RelationNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationNotification
的使用

没有 javax.management.relation.RelationNotification 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RelationService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationService
的使用

没有 javax.management.relation.RelationService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.relation.RelationServiceMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.relation.RelationServiceMBean
的使用

使用 RelationServiceMBean 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationServiceMBean 的使用

实现 RelationServiceMBean 的 javax.management.relation 中的类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RelationServiceNotRegisteredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationServiceNotRegisteredException
的使用

使用 RelationServiceNotRegisteredException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationServiceNotRegisteredException 的使用

抛出 RelationServiceNotRegisteredException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
RoleResult | Relation.getAllRoles() 返回该关系中存在的所有角色。
RoleResult | RelationSupport.getAllRoles() 返回关系中存在的所有角色。
RoleResult | RelationService.getAllRoles(String relationId) 返回关系中存在的所有角色。
RoleResult | RelationServiceMBean.getAllRoles(String relationId) 返回关系中存在的所有角色。
List<ObjectName> | Relation.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationSupport.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
RoleResult | Relation.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationSupport.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationService.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
RoleResult | RelationServiceMBean.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationService.isActive() 检查该 Relation Service 是否处于活动状态。
void | RelationServiceMBean.isActive() 检查该 Relation Service 是否处于活动状态。
void | RelationService.purgeRelations() 肃清关系。
void | RelationServiceMBean.purgeRelations() 肃清关系。
void | RelationService.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationServiceMBean.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationService.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | RelationServiceMBean.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。
RoleResult | RelationService.setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
RoleResult | RelationServiceMBean.setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RelationSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationSupport
的使用

没有 javax.management.relation.RelationSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.relation.RelationSupportMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.relation.RelationSupportMBean
的使用

使用 RelationSupportMBean 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationSupportMBean 的使用

实现 RelationSupportMBean 的 javax.management.relation 中的类
 class RelationSupport
RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.relation.RelationType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.relation.RelationType
的使用

使用 RelationType 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationType 的使用

实现 RelationType 的 javax.management.relation 中的类
 class RelationTypeSupport
RelationTypeSupport 对象实现 RelationType 接口。

参数类型为 RelationType 的 javax.management.relation 中的方法
void | RelationService.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
void | RelationServiceMBean.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RelationTypeNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationTypeNotFoundException
的使用

使用 RelationTypeNotFoundException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationTypeNotFoundException 的使用

抛出 RelationTypeNotFoundException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
Integer | RelationService.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否以给定类型的关系进行读取。
Integer | RelationServiceMBean.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否在给定类型的关系中读取。
Integer | RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
Integer | RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
List<String> | RelationService.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
List<String> | RelationServiceMBean.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
RoleInfo | RelationService.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色名称的角色信息。
RoleInfo | RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色的角色信息。
List<RoleInfo> | RelationService.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
List<RoleInfo> | RelationServiceMBean.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationService.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | RelationServiceMBean.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RelationTypeSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationTypeSupport
的使用

没有 javax.management.relation.RelationTypeSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.Role 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.Role
的使用

使用 Role 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 Role 的使用

返回变量类型为 Role 的类型的 javax.management.relation 中的方法
 List<Role> RoleList.asList()
以 List<Role> 的形式返回此列表的示图。

参数类型为 Role 的 javax.management.relation 中的方法
void | RoleList.add(int index, Role role) 插入指定为指定位置处的元素的角色。
void | RoleList.add(Role role) 添加指定为列表中最后一个元素的 Role。
Integer | RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
Integer | RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
void | RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RoleList.set(int index, Role role) 将指定位置处的元素设置为指定角色。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

类型变量类型为 Role 的 javax.management.relation 中的构造方法参数
RoleList(List<Role> list)
构造一个包含指定 List 元素的 RoleList，这些元素按 List 迭代器返回的顺序排列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RoleInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleInfo
的使用

使用 RoleInfo 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleInfo 的使用

返回 RoleInfo 的 javax.management.relation 中的方法
RoleInfo | RelationType.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。
RoleInfo | RelationTypeSupport.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。
RoleInfo | RelationService.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色名称的角色信息。
RoleInfo | RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色的角色信息。

返回变量类型为 RoleInfo 的类型的 javax.management.relation 中的方法
List<RoleInfo> | RelationType.getRoleInfos() 返回角色定义的列表（RoleInfo 对象的 ArrayList）。
List<RoleInfo> | RelationTypeSupport.getRoleInfos() 返回角色定义的列表（RoleInfo 对象的 ArrayList）。
List<RoleInfo> | RelationService.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
List<RoleInfo> | RelationServiceMBean.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。

参数类型为 RoleInfo 的 javax.management.relation 中的方法
protected void | RelationTypeSupport.addRoleInfo(RoleInfo roleInfo) 添加角色信息。
void | RelationService.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。

参数类型为 RoleInfo 的 javax.management.relation 中的构造方法
RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
所有角色定义在其中动态创建并作为参数传递的构造方法。
RoleInfo(RoleInfo roleInfo)
复制构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RoleInfoNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleInfoNotFoundException
的使用

使用 RoleInfoNotFoundException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleInfoNotFoundException 的使用

抛出 RoleInfoNotFoundException 的 javax.management.relation 中的方法
RoleInfo | RelationType.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。
RoleInfo | RelationTypeSupport.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。
RoleInfo | RelationService.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色名称的角色信息。
RoleInfo | RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色的角色信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RoleList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleList
的使用

使用 RoleList 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleList 的使用

返回 RoleList 的 javax.management.relation 中的方法
RoleList | RoleResult.getRoles() 检索成功访问的角色列表。
RoleList | Relation.retrieveAllRoles() 返回关系中的所有角色，不检查读取模式。
RoleList | RelationSupport.retrieveAllRoles() 返回关系中的所有角色，不检查读取模式。

参数类型为 RoleList 的 javax.management.relation 中的方法
boolean | RoleList.addAll(int index, RoleList roleList) 从指定位置开始，将指定 RoleList 中的所有元素插入此列表，这些元素按指定 RoleList 的迭代器返回的顺序排列。
boolean | RoleList.addAll(RoleList roleList) 将指定 RoleList 中的所有元素追加到列表末尾，这些元素按指定 RoleList 的迭代器返回的顺序排列。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。
void | RoleResult.setRoles(RoleList list) 设置成功访问的角色列表。
RoleResult | RelationService.setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
RoleResult | RelationServiceMBean.setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。

参数类型为 RoleList 的 javax.management.relation 中的构造方法
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RoleResult(RoleList list, RoleUnresolvedList unresolvedList)
构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RoleNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleNotFoundException
的使用

使用 RoleNotFoundException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleNotFoundException 的使用

抛出 RoleNotFoundException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
List<ObjectName> | Relation.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationSupport.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
Integer | Relation.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationSupport.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationService.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
Integer | RelationServiceMBean.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RoleResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleResult
的使用

使用 RoleResult 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleResult 的使用

返回 RoleResult 的 javax.management.relation 中的方法
RoleResult | Relation.getAllRoles() 返回该关系中存在的所有角色。
RoleResult | RelationSupport.getAllRoles() 返回关系中存在的所有角色。
RoleResult | RelationService.getAllRoles(String relationId) 返回关系中存在的所有角色。
RoleResult | RelationServiceMBean.getAllRoles(String relationId) 返回关系中存在的所有角色。
RoleResult | Relation.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationSupport.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationService.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
RoleResult | RelationServiceMBean.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。
RoleResult | RelationService.setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
RoleResult | RelationServiceMBean.setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RoleStatus 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleStatus
的使用

没有 javax.management.relation.RoleStatus 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RoleUnresolved 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleUnresolved
的使用

使用 RoleUnresolved 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleUnresolved 的使用

返回变量类型为 RoleUnresolved 的类型的 javax.management.relation 中的方法
 List<RoleUnresolved> RoleUnresolvedList.asList()
以 List<RoleUnresolved> 的形式返回此列表的视图。

参数类型为 RoleUnresolved 的 javax.management.relation 中的方法
void | RoleUnresolvedList.add(int index, RoleUnresolved role) 在指定位置处插入指定为元素的未解析角色。
void | RoleUnresolvedList.add(RoleUnresolved role) 添加指定为列表中最后一个元素的 RoleUnresolved。
void | RoleUnresolvedList.set(int index, RoleUnresolved role) 将指定位置处的元素设置为指定的未解析角色。

类型变量类型为 RoleUnresolved 的 javax.management.relation 中的构造方法参数
RoleUnresolvedList(List<RoleUnresolved> list)
构造一个包含指定 List 元素的 RoleUnresolvedList，这些元素按 List 迭代器返回的顺序排列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.relation.RoleUnresolvedList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleUnresolvedList
的使用

使用 RoleUnresolvedList 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleUnresolvedList 的使用

返回 RoleUnresolvedList 的 javax.management.relation 中的方法
 RoleUnresolvedList RoleResult.getRolesUnresolved()
检索未成功访问的角色列表。

参数类型为 RoleUnresolvedList 的 javax.management.relation 中的方法
boolean | RoleUnresolvedList.addAll(int index, RoleUnresolvedList roleList) 从指定位置开始，将指定 RoleUnresolvedList 中的所有元素插入此列表，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
boolean | RoleUnresolvedList.addAll(RoleUnresolvedList roleList) 将指定 RoleUnresolvedList 中的所有元素追加到列表末尾，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
void | RoleResult.setRolesUnresolved(RoleUnresolvedList unresolvedList) 设置未成功访问的角色列表。

参数类型为 RoleUnresolvedList 的 javax.management.relation 中的构造方法
RoleResult(RoleList list, RoleUnresolvedList unresolvedList)
构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.management.remote (Java 2 Platform SE 6)

 javax.management.remote
接口
JMXAddressable
JMXAuthenticator
JMXConnector
JMXConnectorProvider
JMXConnectorServerMBean
JMXConnectorServerProvider
MBeanServerForwarder
类
JMXConnectionNotification
JMXConnectorFactory
JMXConnectorServer
JMXConnectorServerFactory
JMXPrincipal
JMXServiceURL
NotificationResult
SubjectDelegationPermission
TargetedNotification
异常
JMXProviderException
JMXServerErrorException


接口 javax.management.remote.JMXAddressable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXAddressable
的使用

使用 JMXAddressable 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 JMXAddressable 的使用

实现 JMXAddressable 的 javax.management.remote 中的类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 JMXAddressable 的使用

实现 JMXAddressable 的 javax.management.remote.rmi 中的类
class | RMIConnector 一个到远程 RMI 连接器的连接。
class | RMIConnectorServer JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.remote.JMXAuthenticator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXAuthenticator
的使用

没有 javax.management.remote.JMXAuthenticator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.JMXConnectionNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXConnectionNotification
的使用

没有 javax.management.remote.JMXConnectionNotification 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.remote.JMXConnector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXConnector
的使用

使用 JMXConnector 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 JMXConnector 的使用

返回 JMXConnector 的 javax.management.remote 中的方法
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 为位于给定地址的连接器服务器创建一个连接器客户端。
JMXConnector | JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。
JMXConnector | JMXConnectorServer.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。
JMXConnector | JMXConnectorServerMBean.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。

javax.management.remote.rmi 中 JMXConnector 的使用

实现 JMXConnector 的 javax.management.remote.rmi 中的类
 class RMIConnector
一个到远程 RMI 连接器的连接。

返回 JMXConnector 的 javax.management.remote.rmi 中的方法
 JMXConnector RMIConnectorServer.toJMXConnector(Map<String,?> env)
返回此连接器服务器的客户端 stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.JMXConnectorFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXConnectorFactory
的使用

没有 javax.management.remote.JMXConnectorFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.remote.JMXConnectorProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXConnectorProvider
的使用

没有 javax.management.remote.JMXConnectorProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.JMXConnectorServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXConnectorServer
的使用

使用 JMXConnectorServer 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 JMXConnectorServer 的使用

返回 JMXConnectorServer 的 javax.management.remote 中的方法
static JMXConnectorServer | JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的连接器服务器。
JMXConnectorServer | JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的新连接器服务器。

javax.management.remote.rmi 中 JMXConnectorServer 的使用

javax.management.remote.rmi 中 JMXConnectorServer 的子类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.JMXConnectorServerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXConnectorServerFactory
的使用

没有 javax.management.remote.JMXConnectorServerFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.remote.JMXConnectorServerMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXConnectorServerMBean
的使用

使用 JMXConnectorServerMBean 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 JMXConnectorServerMBean 的使用

实现 JMXConnectorServerMBean 的 javax.management.remote 中的类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 JMXConnectorServerMBean 的使用

实现 JMXConnectorServerMBean 的 javax.management.remote.rmi 中的类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.remote.JMXConnectorServerProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXConnectorServerProvider
的使用

没有 javax.management.remote.JMXConnectorServerProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.JMXPrincipal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXPrincipal
的使用

没有 javax.management.remote.JMXPrincipal 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.JMXProviderException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXProviderException
的使用

没有 javax.management.remote.JMXProviderException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.JMXServerErrorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXServerErrorException
的使用

没有 javax.management.remote.JMXServerErrorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.JMXServiceURL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXServiceURL
的使用

使用 JMXServiceURL 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 JMXServiceURL 的使用

返回 JMXServiceURL 的 javax.management.remote 中的方法
JMXServiceURL | JMXAddressable.getAddress() 此对象的地址。
JMXServiceURL | JMXConnectorServerMBean.getAddress() 该连接器服务器的地址。

参数类型为 JMXServiceURL 的 javax.management.remote 中的方法
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 为位于给定地址的连接器服务器创建一个连接器客户端。
JMXConnector | JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。
static JMXConnectorServer | JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的连接器服务器。
JMXConnectorServer | JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的新连接器服务器。

javax.management.remote.rmi 中 JMXServiceURL 的使用

返回 JMXServiceURL 的 javax.management.remote.rmi 中的方法
JMXServiceURL | RMIConnector.getAddress() 此连接器的地址。
JMXServiceURL | RMIConnectorServer.getAddress()

参数类型为 JMXServiceURL 的 javax.management.remote.rmi 中的构造方法
RMIConnector(JMXServiceURL url, Map<String,?> environment)
构造一个将 RMI 连接器服务器连接到给定地址的 RMIConnector。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
建立 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.remote.MBeanServerForwarder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.MBeanServerForwarder
的使用

使用 MBeanServerForwarder 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 MBeanServerForwarder 的使用

参数类型为 MBeanServerForwarder 的 javax.management.remote 中的方法
void | JMXConnectorServer.setMBeanServerForwarder(MBeanServerForwarder mbsf)
void | JMXConnectorServerMBean.setMBeanServerForwarder(MBeanServerForwarder mbsf) 添加一个截取对 MBean 服务器请求的对象，该请求是通过此连接器服务器到达的。

javax.management.remote.rmi 中 MBeanServerForwarder 的使用

参数类型为 MBeanServerForwarder 的 javax.management.remote.rmi 中的方法
 void RMIConnectorServer.setMBeanServerForwarder(MBeanServerForwarder mbsf)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.NotificationResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.NotificationResult
的使用

使用 NotificationResult 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 中 NotificationResult 的使用

返回 NotificationResult 的 javax.management.remote.rmi 中的方法
NotificationResult | RMIConnection.fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout) 检索来自连接器服务器的通知。
NotificationResult | RMIConnectionImpl.fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
NotificationResult | RMIConnectionImpl_Stub.fetchNotifications(long $param_long_1, int $param_int_2, long $param_long_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.SubjectDelegationPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.SubjectDelegationPermission
的使用

没有 javax.management.remote.SubjectDelegationPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.TargetedNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.TargetedNotification
的使用

使用 TargetedNotification 的软件包
javax.management.remote 对 JMX MBean 服务器进行远程访问使用的接口。

javax.management.remote 中 TargetedNotification 的使用

返回 TargetedNotification 的 javax.management.remote 中的方法
 TargetedNotification[] NotificationResult.getTargetedNotifications()
返回查询到的通知以及相应的侦听器。

参数类型为 TargetedNotification 的 javax.management.remote 中的构造方法
NotificationResult(long earliestSequenceNumber, long nextSequenceNumber, TargetedNotification[] targetedNotifications)
构造一个通知查询结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.management.remote.rmi (Java 2 Platform SE 6)

 javax.management.remote.rmi
接口
RMIConnection
RMIServer
类
RMIConnectionImpl
RMIConnectionImpl_Stub
RMIConnector
RMIConnectorServer
RMIIIOPServerImpl
RMIJRMPServerImpl
RMIServerImpl
RMIServerImpl_Stub


接口 javax.management.remote.rmi.RMIConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.rmi.RMIConnection
的使用

使用 RMIConnection 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 中 RMIConnection 的使用

实现 RMIConnection 的 javax.management.remote.rmi 中的类
class | RMIConnectionImpl RMIConnection 接口的实现。
class | RMIConnectionImpl_Stub

返回 RMIConnection 的 javax.management.remote.rmi 中的方法
protected RMIConnection | RMIIIOPServerImpl.makeClient(String connectionId, Subject subject) 创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。
protected RMIConnection | RMIJRMPServerImpl.makeClient(String connectionId, Subject subject) 创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。
protected abstract RMIConnection | RMIServerImpl.makeClient(String connectionId, Subject subject) 创建一个新的客户端连接。
RMIConnection | RMIServer.newClient(Object credentials) 建立一个使用该 RMI 连接器的新连接。
RMIConnection | RMIServerImpl.newClient(Object credentials) 创建一个新的客户端连接。
RMIConnection | RMIServerImpl_Stub.newClient(Object $param_Object_1)

参数类型为 RMIConnection 的 javax.management.remote.rmi 中的方法
protected void | RMIServerImpl.clientClosed(RMIConnection client) 关闭由 makeClient 创建的客户端连接时调用的方法。
protected void | RMIIIOPServerImpl.closeClient(RMIConnection client)
protected void | RMIJRMPServerImpl.closeClient(RMIConnection client)
protected abstract void | RMIServerImpl.closeClient(RMIConnection client) 关闭由 makeClient 建立的客户端连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.rmi.RMIConnectionImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIConnectionImpl
的使用

没有 javax.management.remote.rmi.RMIConnectionImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.rmi.RMIConnectionImpl_Stub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIConnectionImpl_Stub
的使用

没有 javax.management.remote.rmi.RMIConnectionImpl_Stub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.rmi.RMIConnector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIConnector
的使用

没有 javax.management.remote.rmi.RMIConnector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.rmi.RMIConnectorServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIConnectorServer
的使用

没有 javax.management.remote.rmi.RMIConnectorServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.rmi.RMIIIOPServerImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIIIOPServerImpl
的使用

没有 javax.management.remote.rmi.RMIIIOPServerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.rmi.RMIJRMPServerImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIJRMPServerImpl
的使用

没有 javax.management.remote.rmi.RMIJRMPServerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.remote.rmi.RMIServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.rmi.RMIServer
的使用

使用 RMIServer 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 中 RMIServer 的使用

实现 RMIServer 的 javax.management.remote.rmi 中的类
class | RMIIIOPServerImpl 一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
class | RMIJRMPServerImpl 一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。
class | RMIServerImpl 表示连接器服务器的 RMI 对象。
class | RMIServerImpl_Stub

参数类型为 RMIServer 的 javax.management.remote.rmi 中的构造方法
RMIConnector(RMIServer rmiServer, Map<String,?> environment)
用给定的 RMI stub 构造一个 RMIConnector。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.rmi.RMIServerImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIServerImpl
的使用

使用 RMIServerImpl 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 中 RMIServerImpl 的使用

javax.management.remote.rmi 中 RMIServerImpl 的子类
class | RMIIIOPServerImpl 一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
class | RMIJRMPServerImpl 一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。

参数类型为 RMIServerImpl 的 javax.management.remote.rmi 中的构造方法
RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.remote.rmi.RMIServerImpl_Stub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIServerImpl_Stub
的使用

没有 javax.management.remote.rmi.RMIServerImpl_Stub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.management.timer (Java 2 Platform SE 6)

 javax.management.timer
接口
TimerMBean
类
Timer
TimerNotification


类 javax.management.timer.Timer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.timer.Timer
的使用

没有 javax.management.timer.Timer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.management.timer.TimerMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.timer.TimerMBean
的使用

使用 TimerMBean 的软件包
javax.management.timer 提供对 Timer MBean（计时器 MBean）的定义。

javax.management.timer 中 TimerMBean 的使用

实现 TimerMBean 的 javax.management.timer 中的类
 class Timer
提供对计时器 MBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.management.timer.TimerNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.timer.TimerNotification
的使用

没有 javax.management.timer.TimerNotification 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.naming (Java 2 Platform SE 6)

 javax.naming
接口
Context
Name
NameParser
NamingEnumeration
Referenceable
类
BinaryRefAddr
Binding
CompositeName
CompoundName
InitialContext
LinkRef
NameClassPair
RefAddr
Reference
StringRefAddr
异常
AuthenticationException
AuthenticationNotSupportedException
CannotProceedException
CommunicationException
ConfigurationException
ContextNotEmptyException
InsufficientResourcesException
InterruptedNamingException
InvalidNameException
LimitExceededException
LinkException
LinkLoopException
MalformedLinkException
NameAlreadyBoundException
NameNotFoundException
NamingException
NamingSecurityException
NoInitialContextException
NoPermissionException
NotContextException
OperationNotSupportedException
PartialResultException
ReferralException
ServiceUnavailableException
SizeLimitExceededException
TimeLimitExceededException


类 javax.naming.AuthenticationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.AuthenticationException
的使用

没有 javax.naming.AuthenticationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.AuthenticationNotSupportedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.AuthenticationNotSupportedException
的使用

没有 javax.naming.AuthenticationNotSupportedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.BinaryRefAddr 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.BinaryRefAddr
的使用

没有 javax.naming.BinaryRefAddr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.Binding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.Binding
的使用

使用 Binding 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。

javax.naming 中 Binding 的使用

返回变量类型为 Binding 的类型的 javax.naming 中的方法
NamingEnumeration<Binding> | Context.listBindings(Name name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
NamingEnumeration<Binding> | InitialContext.listBindings(Name name)
NamingEnumeration<Binding> | Context.listBindings(String name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
NamingEnumeration<Binding> | InitialContext.listBindings(String name)

javax.naming.directory 中 Binding 的使用

javax.naming.directory 中 Binding 的子类
 class SearchResult
此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

javax.naming.event 中 Binding 的使用

声明为 Binding 的 javax.naming.event 中的字段
protected Binding | NamingEvent.newBinding 包含关于更改后对象的信息。
protected Binding | NamingEvent.oldBinding 包含关于更改前对象的信息。

返回 Binding 的 javax.naming.event 中的方法
Binding | NamingEvent.getNewBinding() 检索更改后对象的绑定。
Binding | NamingEvent.getOldBinding() 检索更改前对象的绑定。

参数类型为 Binding 的 javax.naming.event 中的构造方法
NamingEvent(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)
构造一个 NamingEvent 的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.CannotProceedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.CannotProceedException
的使用

使用 CannotProceedException 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 CannotProceedException 的使用

参数类型为 CannotProceedException 的 javax.naming.spi 中的方法
static Context | NamingManager.getContinuationContext(CannotProceedException cpe) 创建一个将继续上下文操作的上下文。
static DirContext | DirectoryManager.getContinuationDirContext(CannotProceedException cpe) 创建一个将继续某个 DirContext 操作的上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.CommunicationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.CommunicationException
的使用

没有 javax.naming.CommunicationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.CompositeName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.CompositeName
的使用

没有 javax.naming.CompositeName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.CompoundName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.CompoundName
的使用

没有 javax.naming.CompoundName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ConfigurationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ConfigurationException
的使用

没有 javax.naming.ConfigurationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.Context 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.Context
的使用

使用 Context 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.naming 中 Context 的使用

实现 Context 的 javax.naming 中的类
 class InitialContext
此类是执行命名操作的初始上下文。

声明为 Context 的 javax.naming 中的字段
protected Context | CannotProceedException.altNameCtx 包含上下文，altName 是相对于该上下文指定的。
protected Context | InitialContext.defaultInitCtx 该字段保存调用 NamingManager.getInitialContext() 的结果。

返回 Context 的 javax.naming 中的方法
 Context Context.createSubcontext(Name name)
创建并绑定一个新上下文。
 Context InitialContext.createSubcontext(Name name)
 Context Context.createSubcontext(String name)
创建并绑定一个新上下文。
 Context InitialContext.createSubcontext(String name)
 Context CannotProceedException.getAltNameCtx()
检索此异常的 altNameCtx 字段。
protected  Context InitialContext.getDefaultInitCtx()
通过调用 NamingManager.getInitialContext() 获取初始上下文，并将它缓存在 defaultInitCtx 中。
abstract  Context ReferralException.getReferralContext()
检索继续该方法的上下文。
abstract  Context ReferralException.getReferralContext(Hashtable<?,?> env)
使用环境属性检索继续该方法的上下文。
protected  Context InitialContext.getURLOrDefaultInitCtx(Name name)
获取用来解析 name 的上下文。
protected  Context InitialContext.getURLOrDefaultInitCtx(String name)
获取用来解析字符串名称 name 的上下文。

参数类型为 Context 的 javax.naming 中的方法
 void CannotProceedException.setAltNameCtx(Context altNameCtx)
设置此异常的 altNameCtx 字段。

javax.naming.directory 中 Context 的使用

javax.naming.directory 中 Context 的子接口
 interface DirContext
目录服务接口，包含一些用于检查和更新与对象关联的属性以及搜索目录的方法。

实现 Context 的 javax.naming.directory 中的类
 class InitialDirContext
此类是执行目录操作的初始上下文。

javax.naming.event 中 Context 的使用

javax.naming.event 中 Context 的子接口
interface | EventContext 包含注册/注销侦听器的一些方法，这些侦听器在上下文中命名的对象发生更改时获得触发事件的通知。
interface | EventDirContext 包含注册侦听器的一些方法，这些侦听器在目录上下文中命名的对象发生更改时将获得触发事件的通知。

javax.naming.ldap 中 Context 的使用

javax.naming.ldap 中 Context 的子接口
 interface LdapContext
此接口表示一个上下文，在该上下文中可以利用 LDAPv3 样式的控件执行操作，并且可以执行 LDAPv3 样式的扩展操作。

实现 Context 的 javax.naming.ldap 中的类
 class InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

返回 Context 的 javax.naming.ldap 中的方法
abstract Context | LdapReferralException.getReferralContext() 使用上下文的环境（但不使用控件）检索继续该方法的上下文。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env) 使用环境属性（但不使用控件）检索继续该方法的上下文。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls) 使用请求控件和环境属性检索继续该方法的上下文。

参数类型为 Context 的 javax.naming.ldap 中的方法
static Control ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env)
使用已知控件工厂创建控件。

javax.naming.spi 中 Context 的使用

返回 Context 的 javax.naming.spi 中的方法
static Context | NamingManager.getContinuationContext(CannotProceedException cpe) 创建一个将继续上下文操作的上下文。
Context | InitialContextFactory.getInitialContext(Hashtable<?,?> environment) 创建一个初始上下文，以便开始进行名称解析。
static Context | NamingManager.getInitialContext(Hashtable<?,?> env) 使用指定环境属性创建一个初始上下文工厂。
static Context | NamingManager.getURLContext(String scheme, Hashtable<?,?> environment) 为给定的 URL 方案 id 创建一个上下文。

参数类型为 Context 的 javax.naming.spi 中的方法
static Object | NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment) 为指定对象和环境创建一个对象实例。
Object | ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 使用指定的位置或引用信息创建一个对象。
Object | DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 使用位置或引用信息以及指定的属性创建一个对象。
static Object | DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。
static Object | NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象的状态。
Object | StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象状态。
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。

类型变量类型为 Context 的 javax.naming.spi 中的方法参数
ResolveResult | Resolver.resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
ResolveResult | Resolver.resolveToClass(String name, Class<? extends Context> contextType) 部分解析某一名称。

javax.sql.rowset.spi 中 Context 的使用

参数类型为 Context 的 javax.sql.rowset.spi 中的方法
static void SyncFactory.setJNDIContext(Context ctx)
设置初始 JNDI 上下文，通过该上下文可以从 JNDI 名称空间获取 SyncProvider 实现

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ContextNotEmptyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ContextNotEmptyException
的使用

没有 javax.naming.ContextNotEmptyException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.InitialContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.InitialContext
的使用

使用 InitialContext 的软件包
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.directory 中 InitialContext 的使用

javax.naming.directory 中 InitialContext 的子类
 class InitialDirContext
此类是执行目录操作的初始上下文。

javax.naming.ldap 中 InitialContext 的使用

javax.naming.ldap 中 InitialContext 的子类
 class InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.InsufficientResourcesException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.InsufficientResourcesException
的使用

没有 javax.naming.InsufficientResourcesException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.InterruptedNamingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.InterruptedNamingException
的使用

没有 javax.naming.InterruptedNamingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.InvalidNameException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.InvalidNameException
的使用

使用 InvalidNameException 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming 中 InvalidNameException 的使用

抛出 InvalidNameException 的 javax.naming 中的方法
Name | CompositeName.add(int posn, String comp) 在此复合名称中的指定位置添加单个组件。
Name | CompoundName.add(int posn, String comp) 在此组合名称中的指定位置添加单个组件。
Name | Name.add(int posn, String comp) 在此名称中的指定位置添加单个组件。
Name | CompositeName.add(String comp) 将单个组件添加到此复合名称的末尾。
Name | CompoundName.add(String comp) 将单个组件添加到此组合名称的末尾。
Name | Name.add(String comp) 将单个组件添加到此名称的末尾。
Name | CompositeName.addAll(int posn, Name n) 按顺序将复合名称的组件添加到此复合名称中的指定位置。
Name | CompoundName.addAll(int posn, Name n) 按顺序将组合名称的组件添加到此组合名称中的指定位置。
Name | Name.addAll(int posn, Name n) 按顺序将名称的组件添加到此名称中的指定位置。
Name | CompositeName.addAll(Name suffix) 按顺序将复合名称的组件添加到此复合名称的末尾。
Name | CompoundName.addAll(Name suffix) 按顺序将组合名称的组件添加到此组合名称的末尾。
Name | Name.addAll(Name suffix) 按顺序将名称的组件添加到此名称的末尾。
Object | CompositeName.remove(int posn) 从此复合名称中删除一个组件。
Object | CompoundName.remove(int posn) 从此组合名称中删除一个组件。
Object | Name.remove(int posn) 从此名称中移除一个组件。

抛出 InvalidNameException 的 javax.naming 中的构造方法
CompositeName(String n)
通过使用复合名称语法（从左到右，用斜杠分隔）解析字符串 n 来构造一个新的复合名称实例。
CompoundName(String n, Properties syntax)
通过解析使用提供的 syntax 属性所指定的语法的字符串 n 来构造一个新的组合名称实例。

javax.naming.ldap 中 InvalidNameException 的使用

抛出 InvalidNameException 的 javax.naming.ldap 中的方法
Name | LdapName.add(int posn, String comp) 将单个组件添加到此 LDAP 名称中的指定位置。
Name | LdapName.add(String comp) 将单个组件添加到此 LDAP 名称的末尾。
Name | LdapName.addAll(int posn, Name suffix) 按顺序将名称的组件添加到此名称中的指定位置。
Name | LdapName.addAll(Name suffix) 按顺序将名称的组件添加到此名称的末尾。
Object | LdapName.remove(int posn) 从此 LDAP 名称中移除一个组件。

抛出 InvalidNameException 的 javax.naming.ldap 中的构造方法
LdapName(String name)
根据给定标识名构造 LDAP 名称。
Rdn(Attributes attrSet)
根据给定属性集构造 Rdn。
Rdn(String rdnString)
根据给定字符串构造 Rdn。
Rdn(String type, Object value)
根据给定属性类型和值构造 Rdn。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.LimitExceededException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.LimitExceededException
的使用

使用 LimitExceededException 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 LimitExceededException 的使用

javax.naming 中 LimitExceededException 的子类
class | SizeLimitExceededException 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
class | TimeLimitExceededException 当某一方法没有在指定的时间限制内终止时，抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.LinkException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.LinkException
的使用

使用 LinkException 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 LinkException 的使用

javax.naming 中 LinkException 的子类
class | LinkLoopException 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
class | MalformedLinkException 如果在解析或构造链接时遇到错误链接，则抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.LinkLoopException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.LinkLoopException
的使用

没有 javax.naming.LinkLoopException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.LinkRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.LinkRef
的使用

没有 javax.naming.LinkRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.MalformedLinkException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.MalformedLinkException
的使用

没有 javax.naming.MalformedLinkException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.Name 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.Name
的使用

使用 Name 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming 中 Name 的使用

实现 Name 的 javax.naming 中的类
class | CompositeName 此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
class | CompoundName 此类表示一个组合名称，即一个取自层次名称空间的名称。

声明为 Name 的 javax.naming 中的字段
protected Name | CannotProceedException.altName 包含已解析对象的名称，该名称相对于上下文 altNameCtx。
protected Name | LinkException.linkRemainingName 包含尚未解析的剩余链接名称。
protected Name | LinkException.linkResolvedName 包含已成功解析的链接部分。
protected Name | NamingException.remainingName 包含尚未解析的剩余名称。
protected Name | CannotProceedException.remainingNewName 包含 Context.rename() 第二个 "name" 参数的剩余未解析部分。
protected Name | NamingException.resolvedName 包含已成功解析的名称部分。

返回 Name 的 javax.naming 中的方法
 Name CompositeName.add(int posn, String comp)
在此复合名称中的指定位置添加单个组件。
 Name CompoundName.add(int posn, String comp)
在此组合名称中的指定位置添加单个组件。
 Name Name.add(int posn, String comp)
在此名称中的指定位置添加单个组件。
 Name CompositeName.add(String comp)
将单个组件添加到此复合名称的末尾。
 Name CompoundName.add(String comp)
将单个组件添加到此组合名称的末尾。
 Name Name.add(String comp)
将单个组件添加到此名称的末尾。
 Name CompositeName.addAll(int posn, Name n)
按顺序将复合名称的组件添加到此复合名称中的指定位置。
 Name CompoundName.addAll(int posn, Name n)
按顺序将组合名称的组件添加到此组合名称中的指定位置。
 Name Name.addAll(int posn, Name n)
按顺序将名称的组件添加到此名称中的指定位置。
 Name CompositeName.addAll(Name suffix)
按顺序将复合名称的组件添加到此复合名称的末尾。
 Name CompoundName.addAll(Name suffix)
按顺序将组合名称的组件添加到此组合名称的末尾。
 Name Name.addAll(Name suffix)
按顺序将名称的组件添加到此名称的末尾。
 Name Context.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Name InitialContext.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Name CannotProceedException.getAltName()
检索此异常的 altName 字段。
 Name LinkException.getLinkRemainingName()
检索链接名称的剩余未解析部分。
 Name LinkException.getLinkResolvedName()
检索成功被解析的链接名称的开头部分。
 Name CompositeName.getPrefix(int posn)
创建一个复合名称，其组件由此复合名称中组件的前缀组成。
 Name CompoundName.getPrefix(int posn)
创建一个组合名称，其组件由此组合名称中组件的前缀组成。
 Name Name.getPrefix(int posn)
创建一个名称，其组件由此名称中组件的前缀组成。
 Name NamingException.getRemainingName()
检索名称的剩余未解析部分。
 Name CannotProceedException.getRemainingNewName()
检索此异常的 "remaining new name" 字段，当执行 rename() 操作期间抛出此异常时，将使用该字段。
 Name NamingException.getResolvedName()
检索成功被解析的名称的开头部分。
 Name CompositeName.getSuffix(int posn)
创建一个复合名称，其组件由此复合名称中组件的后缀组成。
 Name CompoundName.getSuffix(int posn)
创建一个组合名称，其组件由该组合名称中组件的后缀组成。
 Name Name.getSuffix(int posn)
创建一个名称，其组件由此名称中组件的后缀组成。
 Name NameParser.parse(String name)
将某一名称解析成其组件。

参数类型为 Name 的 javax.naming 中的方法
 Name CompositeName.addAll(int posn, Name n)
按顺序将复合名称的组件添加到此复合名称中的指定位置。
 Name CompoundName.addAll(int posn, Name n)
按顺序将组合名称的组件添加到此组合名称中的指定位置。
 Name Name.addAll(int posn, Name n)
按顺序将名称的组件添加到此名称中的指定位置。
 Name CompositeName.addAll(Name suffix)
按顺序将复合名称的组件添加到此复合名称的末尾。
 Name CompoundName.addAll(Name suffix)
按顺序将组合名称的组件添加到此组合名称的末尾。
 Name Name.addAll(Name suffix)
按顺序将名称的组件添加到此名称的末尾。
 void NamingException.appendRemainingName(Name name)
将 'name' 中的组件作为剩余名称中最后的组件添加。
 void Context.bind(Name name, Object obj)
将名称绑定到对象。
 void InitialContext.bind(Name name, Object obj)
 Name Context.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Name InitialContext.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Context Context.createSubcontext(Name name)
创建并绑定一个新上下文。
 Context InitialContext.createSubcontext(Name name)
 void Context.destroySubcontext(Name name)
销毁指定上下文，并将它从名称空间中移除。
 void InitialContext.destroySubcontext(Name name)
static
<T> T
InitialContext.doLookup(Name name)
获取指定对象的静态方法。
 boolean CompositeName.endsWith(Name n)
确定某一复合名称是否是此复合名称的后缀。
 boolean CompoundName.endsWith(Name n)
确定某一组合名称是否是此组合名称的后缀。
 boolean Name.endsWith(Name n)
确定此名称是否以某一指定后缀结束。
 NameParser Context.getNameParser(Name name)
检索与指定上下文关联的解析器。
 NameParser InitialContext.getNameParser(Name name)
protected  Context InitialContext.getURLOrDefaultInitCtx(Name name)
获取用来解析 name 的上下文。
 NamingEnumeration<NameClassPair> Context.list(Name name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
 NamingEnumeration<NameClassPair> InitialContext.list(Name name)
 NamingEnumeration<Binding> Context.listBindings(Name name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
 NamingEnumeration<Binding> InitialContext.listBindings(Name name)
 Object Context.lookup(Name name)
检索指定的对象。
 Object InitialContext.lookup(Name name)
 Object Context.lookupLink(Name name)
按照除名称的最终原子组件以外的链接检索指定对象。
 Object InitialContext.lookupLink(Name name)
 void Context.rebind(Name name, Object obj)
将名称绑定到对象，重写任何现有绑定。
 void InitialContext.rebind(Name name, Object obj)
 void Context.rename(Name oldName, Name newName)
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
 void InitialContext.rename(Name oldName, Name newName)
 void CannotProceedException.setAltName(Name altName)
设置此异常的 altName 字段。
 void LinkException.setLinkRemainingName(Name name)
设置此异常的剩余链接名称字段。
 void LinkException.setLinkResolvedName(Name name)
设置此异常的已解析链接名称字段。
 void NamingException.setRemainingName(Name name)
设置此异常的剩余名称字段。
 void CannotProceedException.setRemainingNewName(Name newName)
设置此异常的 "remaining new name" 字段。
 void NamingException.setResolvedName(Name name)
设置此异常的已解析名称字段。
 boolean CompositeName.startsWith(Name n)
确定某一复合名称是否是此复合名称的前缀。
 boolean CompoundName.startsWith(Name n)
确定某一组合名称是否是此组合名称的前缀。
 boolean Name.startsWith(Name n)
确定此名称是否从某一指定前缀开始。
 void Context.unbind(Name name)
取消对指定对象的绑定。
 void InitialContext.unbind(Name name)

参数类型为 Name 的 javax.naming 中的构造方法
LinkRef(Name linkName)
为某一名称构造一个 LinkRef。

javax.naming.directory 中 Name 的使用

参数类型为 Name 的 javax.naming.directory 中的方法
void | DirContext.bind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | InitialDirContext.bind(Name name, Object obj, Attributes attrs)
DirContext | DirContext.createSubcontext(Name name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
Attributes | DirContext.getAttributes(Name name) 检索与命名对象关联的所有属性。
Attributes | InitialDirContext.getAttributes(Name name)
Attributes | DirContext.getAttributes(Name name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | InitialDirContext.getAttributes(Name name, String[] attrIds)
DirContext | DirContext.getSchema(Name name) 检索与命名对象关联的模式。
DirContext | InitialDirContext.getSchema(Name name)
DirContext | DirContext.getSchemaClassDefinition(Name name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | InitialDirContext.getSchemaClassDefinition(Name name)
void | DirContext.modifyAttributes(Name name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
void | DirContext.modifyAttributes(Name name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, ModificationItem[] mods)
void | DirContext.rebind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | InitialDirContext.rebind(Name name, Object obj, Attributes attrs)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)

javax.naming.event 中 Name 的使用

参数类型为 Name 的 javax.naming.event 中的方法
void | EventContext.addNamingListener(Name target, int scope, NamingListener l) 添加接收命名事件的侦听器，这些事件在目标和范围所标识的对象发生更改时触发。
void | EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。

javax.naming.ldap 中 Name 的使用

实现 Name 的 javax.naming.ldap 中的类
 class LdapName
此类表示 RFC 2253 指定的标识名。

返回 Name 的 javax.naming.ldap 中的方法
Name | LdapName.add(int posn, Rdn comp) 将单个 RDN 添加到此 LDAP 名称中的指定位置。
Name | LdapName.add(int posn, String comp) 将单个组件添加到此 LDAP 名称中的指定位置。
Name | LdapName.add(Rdn comp) 将单个 RDN 添加到此 LDAP 名称的末尾。
Name | LdapName.add(String comp) 将单个组件添加到此 LDAP 名称的末尾。
Name | LdapName.addAll(int posn, List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称中的指定位置。
Name | LdapName.addAll(int posn, Name suffix) 按顺序将名称的组件添加到此名称中的指定位置。
Name | LdapName.addAll(List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称的末尾。
Name | LdapName.addAll(Name suffix) 按顺序将名称的组件添加到此名称的末尾。
Name | LdapName.getPrefix(int posn) 创建一个名称，其组件由此 LDAP 名称中组件的前缀组成。
Name | LdapName.getSuffix(int posn) 创建一个名称，其组件由此 LDAP 名称中组件的后缀组成。

参数类型为 Name 的 javax.naming.ldap 中的方法
Name | LdapName.addAll(int posn, Name suffix) 按顺序将名称的组件添加到此名称中的指定位置。
Name | LdapName.addAll(Name suffix) 按顺序将名称的组件添加到此名称的末尾。
boolean | LdapName.endsWith(Name n) 确定此 LDAP 名称是否以某一指定 LDAP 名称后缀结尾。
boolean | LdapName.startsWith(Name n) 确定此 LDAP 名称是否从某一指定 LDAP 名称前缀开始。

javax.naming.spi 中 Name 的使用

声明为 Name 的 javax.naming.spi 中的字段
protected  Name ResolveResult.remainingName
该字段包含要解析的剩余名称。

返回 Name 的 javax.naming.spi 中的方法
 Name ResolveResult.getRemainingName()
检索名称的剩余未解析部分。

参数类型为 Name 的 javax.naming.spi 中的方法
void | ResolveResult.appendRemainingName(Name name) 将组件添加到剩余名称的末尾。
static Object | NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment) 为指定对象和环境创建一个对象实例。
Object | ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 使用指定的位置或引用信息创建一个对象。
Object | DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 使用位置或引用信息以及指定的属性创建一个对象。
static Object | DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。
static Object | NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象的状态。
Object | StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象状态。
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。
ResolveResult | Resolver.resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
void | ResolveResult.setRemainingName(Name name) 将此结果的剩余名称字段设置为 name。

参数类型为 Name 的 javax.naming.spi 中的构造方法
ResolveResult(Object robj, Name rname)
构造一个新的 ResolveResult 实例，该实例由已解析 Object 和剩余名称组成。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.NameAlreadyBoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NameAlreadyBoundException
的使用

没有 javax.naming.NameAlreadyBoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.NameClassPair 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NameClassPair
的使用

使用 NameClassPair 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming 中 NameClassPair 的使用

javax.naming 中 NameClassPair 的子类
 class Binding
此类表示上下文中一个名称到对象的绑定。

返回变量类型为 NameClassPair 的类型的 javax.naming 中的方法
NamingEnumeration<NameClassPair> | Context.list(Name name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
NamingEnumeration<NameClassPair> | InitialContext.list(Name name)
NamingEnumeration<NameClassPair> | Context.list(String name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
NamingEnumeration<NameClassPair> | InitialContext.list(String name)

javax.naming.directory 中 NameClassPair 的使用

javax.naming.directory 中 NameClassPair 的子类
 class SearchResult
此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.NameNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NameNotFoundException
的使用

没有 javax.naming.NameNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.NameParser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.NameParser
的使用

使用 NameParser 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 NameParser 的使用

返回 NameParser 的 javax.naming 中的方法
NameParser | Context.getNameParser(Name name) 检索与指定上下文关联的解析器。
NameParser | InitialContext.getNameParser(Name name)
NameParser | Context.getNameParser(String name) 检索与指定上下文关联的解析器。
NameParser | InitialContext.getNameParser(String name)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.NamingEnumeration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.NamingEnumeration
的使用

使用 NamingEnumeration 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming 中 NamingEnumeration 的使用

返回 NamingEnumeration 的 javax.naming 中的方法
NamingEnumeration<NameClassPair> | Context.list(Name name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
NamingEnumeration<NameClassPair> | InitialContext.list(Name name)
NamingEnumeration<NameClassPair> | Context.list(String name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
NamingEnumeration<NameClassPair> | InitialContext.list(String name)
NamingEnumeration<Binding> | Context.listBindings(Name name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
NamingEnumeration<Binding> | InitialContext.listBindings(Name name)
NamingEnumeration<Binding> | Context.listBindings(String name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
NamingEnumeration<Binding> | InitialContext.listBindings(String name)

javax.naming.directory 中 NamingEnumeration 的使用

返回 NamingEnumeration 的 javax.naming.directory 中的方法
NamingEnumeration<?> | Attribute.getAll() 检索属性值的枚举。
NamingEnumeration<? extends Attribute> | Attributes.getAll() 检索属性集中属性的枚举。
NamingEnumeration<?> | BasicAttribute.getAll() 检索此属性值的枚举。
NamingEnumeration<Attribute> | BasicAttributes.getAll()
NamingEnumeration<String> | Attributes.getIDs() 检索属性集中属性的 id 的枚举。
NamingEnumeration<String> | BasicAttributes.getIDs()
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.NamingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NamingException
的使用

使用 NamingException 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming 中 NamingException 的使用

javax.naming 中 NamingException 的子类
class | AuthenticationException 当访问命名或目录服务发生验证错误时，抛出此异常。
class | AuthenticationNotSupportedException 当所请求验证的特定 flavor 不受支持时，抛出此异常。
class | CannotProceedException 抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
class | CommunicationException 当客户端无法与目录或命名服务通信时，抛出此异常。
class | ConfigurationException 当存在配置问题时，抛出此异常。
class | ContextNotEmptyException 当试图销毁一个不为空的上下文时，抛出此异常。
class | InsufficientResourcesException 当无法使用资源完成所请求的操作时，抛出此异常。
class | InterruptedNamingException 当正被调用的命名操作已经被中断时，抛出此异常。
class | InvalidNameException 此异常指示被指定的名称不符合命名系统的命名语法。
class | LimitExceededException 当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
class | LinkException 此异常用于描述解析链接时遇到的问题。
class | LinkLoopException 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
class | MalformedLinkException 如果在解析或构造链接时遇到错误链接，则抛出此异常。
class | NameAlreadyBoundException 一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
class | NameNotFoundException 当名称的组件由于没有被绑定而无法解析时，抛出此异常。
class | NamingSecurityException 此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
class | NoInitialContextException 当不能创建任何初始上下文实现时，抛出此异常。
class | NoPermissionException 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
class | NotContextException 当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
class | OperationNotSupportedException 当上下文实现不支持将调用的操作时，抛出此异常。
class | PartialResultException 抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
class | ReferralException 此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
class | ServiceUnavailableException 当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
class | SizeLimitExceededException 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
class | TimeLimitExceededException 当某一方法没有在指定的时间限制内终止时，抛出此异常。

抛出 NamingException 的 javax.naming 中的方法
 Object Context.addToEnvironment(String propName, Object propVal)
将一个新环境属性添加到此上下文的环境中。
 Object InitialContext.addToEnvironment(String propName, Object propVal)
 void Context.bind(Name name, Object obj)
将名称绑定到对象。
 void InitialContext.bind(Name name, Object obj)
 void Context.bind(String name, Object obj)
将名称绑定到对象。
 void InitialContext.bind(String name, Object obj)
 void Context.close()
关闭此上下文。
 void InitialContext.close()
 void NamingEnumeration.close()
关闭此枚举。
 Name Context.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Name InitialContext.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 String Context.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。
 String InitialContext.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Context Context.createSubcontext(Name name)
创建并绑定一个新上下文。
 Context InitialContext.createSubcontext(Name name)
 Context Context.createSubcontext(String name)
创建并绑定一个新上下文。
 Context InitialContext.createSubcontext(String name)
 void Context.destroySubcontext(Name name)
销毁指定上下文，并将它从名称空间中移除。
 void InitialContext.destroySubcontext(Name name)
 void Context.destroySubcontext(String name)
销毁指定上下文，并将它从名称空间中移除。
 void InitialContext.destroySubcontext(String name)
static
<T> T
InitialContext.doLookup(Name name)
获取指定对象的静态方法。
static
<T> T
InitialContext.doLookup(String name)
获取指定对象的静态方法。
protected  Context InitialContext.getDefaultInitCtx()
通过调用 NamingManager.getInitialContext() 获取初始上下文，并将它缓存在 defaultInitCtx 中。
 Hashtable<?,?> Context.getEnvironment()
检索对此上下文有效的环境。
 Hashtable<?,?> InitialContext.getEnvironment()
 String LinkRef.getLinkName()
检索此链接的名称。
 String Context.getNameInNamespace()
在此上下文自己的名称空间中检索其完全名称。
 String InitialContext.getNameInNamespace()
 NameParser Context.getNameParser(Name name)
检索与指定上下文关联的解析器。
 NameParser InitialContext.getNameParser(Name name)
 NameParser Context.getNameParser(String name)
检索与指定上下文关联的解析器。
 NameParser InitialContext.getNameParser(String name)
 Reference Referenceable.getReference()
检索此对象的 Reference。
abstract  Context ReferralException.getReferralContext()
检索继续该方法的上下文。
abstract  Context ReferralException.getReferralContext(Hashtable<?,?> env)
使用环境属性检索继续该方法的上下文。
protected  Context InitialContext.getURLOrDefaultInitCtx(Name name)
获取用来解析 name 的上下文。
protected  Context InitialContext.getURLOrDefaultInitCtx(String name)
获取用来解析字符串名称 name 的上下文。
 boolean NamingEnumeration.hasMore()
确定枚举中是否还有元素。
protected  void InitialContext.init(Hashtable<?,?> environment)
使用所提供的环境初始化初始上下文。
 NamingEnumeration<NameClassPair> Context.list(Name name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
 NamingEnumeration<NameClassPair> InitialContext.list(Name name)
 NamingEnumeration<NameClassPair> Context.list(String name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
 NamingEnumeration<NameClassPair> InitialContext.list(String name)
 NamingEnumeration<Binding> Context.listBindings(Name name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
 NamingEnumeration<Binding> InitialContext.listBindings(Name name)
 NamingEnumeration<Binding> Context.listBindings(String name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
 NamingEnumeration<Binding> InitialContext.listBindings(String name)
 Object Context.lookup(Name name)
检索指定的对象。
 Object InitialContext.lookup(Name name)
 Object Context.lookup(String name)
检索指定的对象。
 Object InitialContext.lookup(String name)
 Object Context.lookupLink(Name name)
按照除名称的最终原子组件以外的链接检索指定对象。
 Object InitialContext.lookupLink(Name name)
 Object Context.lookupLink(String name)
按照除名称的最终原子组件以外的链接检索指定对象。
 Object InitialContext.lookupLink(String name)
 T NamingEnumeration.next()
检索枚举中的下一个元素。
 Name NameParser.parse(String name)
将某一名称解析成其组件。
 void Context.rebind(Name name, Object obj)
将名称绑定到对象，重写任何现有绑定。
 void InitialContext.rebind(Name name, Object obj)
 void Context.rebind(String name, Object obj)
将名称绑定到对象，重写所有现有绑定。
 void InitialContext.rebind(String name, Object obj)
 Object Context.removeFromEnvironment(String propName)
从此上下文的环境中移除一个环境属性。
 Object InitialContext.removeFromEnvironment(String propName)
 void Context.rename(Name oldName, Name newName)
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
 void InitialContext.rename(Name oldName, Name newName)
 void Context.rename(String oldName, String newName)
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
 void InitialContext.rename(String oldName, String newName)
 void Context.unbind(Name name)
取消对指定对象的绑定。
 void InitialContext.unbind(Name name)
 void Context.unbind(String name)
取消对指定对象的绑定。
 void InitialContext.unbind(String name)

抛出 NamingException 的 javax.naming 中的构造方法
InitialContext()
构造一个初始上下文。
InitialContext(boolean lazy)
构造一个带有不进行初始化选项的初始上下文。
InitialContext(Hashtable<?,?> environment)
使用所提供的环境构造一个初始上下文。

javax.naming.directory 中 NamingException 的使用

javax.naming.directory 中 NamingException 的子类
class | AttributeInUseException 当操作试图添加已经存在的属性时抛出此异常。
class | AttributeModificationException 当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
class | InvalidAttributeIdentifierException 在试图用无效的属性标识符创建属性时，抛出此异常。
class | InvalidAttributesException 在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
class | InvalidAttributeValueException 在尝试添加一个与属性的模式定义有冲突的属性时，抛出此类。
class | InvalidSearchControlsException 在为搜索操作指定的 SearchControls 无效时，抛出此异常。
class | InvalidSearchFilterException 当指定的搜索过滤器无效时，抛出此异常。
class | NoSuchAttributeException 尝试访问不存在的属性时，抛出此异常。
class | SchemaViolationException 当方法在某些方面违反模式时，抛出此异常。

抛出 NamingException 的 javax.naming.directory 中的方法
void | DirContext.bind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | InitialDirContext.bind(Name name, Object obj, Attributes attrs)
void | DirContext.bind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | InitialDirContext.bind(String name, Object obj, Attributes attrs)
DirContext | DirContext.createSubcontext(Name name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
DirContext | DirContext.createSubcontext(String name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(String name, Attributes attrs)
Object | Attribute.get() 检索此属性的其中一个值。
Object | BasicAttribute.get() 检索此属性的其中一个值。
Object | Attribute.get(int ix) 从属性值的有序列表中检索属性值。
Object | BasicAttribute.get(int ix)
NamingEnumeration<?> | Attribute.getAll() 检索属性值的枚举。
NamingEnumeration<?> | BasicAttribute.getAll() 检索此属性值的枚举。
DirContext | Attribute.getAttributeDefinition() 检索属性的模式定义。
DirContext | BasicAttribute.getAttributeDefinition() 检索此属性的模式定义。
Attributes | DirContext.getAttributes(Name name) 检索与命名对象关联的所有属性。
Attributes | InitialDirContext.getAttributes(Name name)
Attributes | DirContext.getAttributes(Name name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | InitialDirContext.getAttributes(Name name, String[] attrIds)
Attributes | DirContext.getAttributes(String name) 检索所有与命名对象关联的属性。
Attributes | InitialDirContext.getAttributes(String name)
Attributes | DirContext.getAttributes(String name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | InitialDirContext.getAttributes(String name, String[] attrIds)
DirContext | Attribute.getAttributeSyntaxDefinition() 检索与属性关联的语法定义。
DirContext | BasicAttribute.getAttributeSyntaxDefinition() 检索与此属性关联的语法定义。
DirContext | DirContext.getSchema(Name name) 检索与命名对象关联的模式。
DirContext | InitialDirContext.getSchema(Name name)
DirContext | DirContext.getSchema(String name) 检索与命名对象关联的模式。
DirContext | InitialDirContext.getSchema(String name)
DirContext | DirContext.getSchemaClassDefinition(Name name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | InitialDirContext.getSchemaClassDefinition(Name name)
DirContext | DirContext.getSchemaClassDefinition(String name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | InitialDirContext.getSchemaClassDefinition(String name)
void | DirContext.modifyAttributes(Name name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
void | DirContext.modifyAttributes(Name name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, ModificationItem[] mods)
void | DirContext.modifyAttributes(String name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(String name, int mod_op, Attributes attrs)
void | DirContext.modifyAttributes(String name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(String name, ModificationItem[] mods)
void | DirContext.rebind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | InitialDirContext.rebind(Name name, Object obj, Attributes attrs)
void | DirContext.rebind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | InitialDirContext.rebind(String name, Object obj, Attributes attrs)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)

抛出 NamingException 的 javax.naming.directory 中的构造方法
InitialDirContext()
构造一个初始 DirContext。
InitialDirContext(boolean lazy)
构造一个具有不进行初始化的选项的初始 DirContext。
InitialDirContext(Hashtable<?,?> environment)
使用所提供的环境构造一个初始 DirContext。

javax.naming.event 中 NamingException 的使用

返回 NamingException 的 javax.naming.event 中的方法
 NamingException NamingExceptionEvent.getException()
检索抛出的异常。

抛出 NamingException 的 javax.naming.event 中的方法
void | EventContext.addNamingListener(Name target, int scope, NamingListener l) 添加接收命名事件的侦听器，这些事件在目标和范围所标识的对象发生更改时触发。
void | EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。
void | EventContext.addNamingListener(String target, int scope, NamingListener l) 添加接收命名事件的侦听器，这些事件在目标名称和范围指定的对象发生更改时触发。
void | EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。
void | EventContext.removeNamingListener(NamingListener l) 从此 EventContext 触发的接收命名事件中移除一个侦听器。
boolean | EventContext.targetMustExist() 确定侦听器是否可以注册不存在的感兴趣目标。

参数类型为 NamingException 的 javax.naming.event 中的构造方法
NamingExceptionEvent(EventContext source, NamingException exc)
使用在抛出过 NamingException 的上下文和抛出的异常构造一个 NamingExceptionEvent 的实例。

javax.naming.ldap 中 NamingException 的使用

javax.naming.ldap 中 NamingException 的子类
 class LdapReferralException
此抽象类用于表示 LDAP 引用异常。

返回 NamingException 的 javax.naming.ldap 中的方法
NamingException | SortResponseControl.getException() 检索适合结果代码的 NamingException。
NamingException | UnsolicitedNotification.getException() 检索使用服务器发送的信息构造的异常。

抛出 NamingException 的 javax.naming.ldap 中的方法
ExtendedResponse | ExtendedRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length) 创建与此请求对应的响应对象。
ExtendedResponse | StartTlsRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length) 创建与 LDAP StartTLS 扩展请求相对应的扩展响应对象。
ExtendedResponse | InitialLdapContext.extendedOperation(ExtendedRequest request)
ExtendedResponse | LdapContext.extendedOperation(ExtendedRequest request) 执行扩展操作。
Control[] | InitialLdapContext.getConnectControls()
Control[] | LdapContext.getConnectControls() 检索对此上下文有效的连接请求控件。
abstract Control | ControlFactory.getControlInstance(Control ctl) 使用此控件工厂创建控件。
static Control | ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env) 使用已知控件工厂创建控件。
Control[] | HasControls.getControls() 从实现此接口的对象中检索 Control 数组。
abstract Context | LdapReferralException.getReferralContext() 使用上下文的环境（但不使用控件）检索继续该方法的上下文。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env) 使用环境属性（但不使用控件）检索继续该方法的上下文。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls) 使用请求控件和环境属性检索继续该方法的上下文。
Control[] | InitialLdapContext.getRequestControls()
Control[] | LdapContext.getRequestControls() 检索对此上下文有效的请求控件。
Control[] | InitialLdapContext.getResponseControls()
Control[] | LdapContext.getResponseControls() 检索对此上下文调用的最后一个方法所生成的响应控件。
LdapContext | InitialLdapContext.newInstance(Control[] reqCtls)
LdapContext | LdapContext.newInstance(Control[] requestControls) 创建此上下文的新实例，使用请求控件进行初始化。
void | InitialLdapContext.reconnect(Control[] connCtls)
void | LdapContext.reconnect(Control[] connCtls) 使用提供的控件和此上下文的环境重新连接到 LDAP 服务器。
void | InitialLdapContext.setRequestControls(Control[] requestControls)
void | LdapContext.setRequestControls(Control[] requestControls) 为在此上下文上后续调用的方法设置请求控件。

抛出 NamingException 的 javax.naming.ldap 中的构造方法
InitialLdapContext()
不使用任何环境属性或连接请求控件构造初始上下文。
InitialLdapContext(Hashtable<?,?> environment, Control[] connCtls)
使用环境属性或连接请求控件构造初始上下文。

javax.naming.spi 中 NamingException 的使用

抛出 NamingException 的 javax.naming.spi 中的方法
InitialContextFactory | InitialContextFactoryBuilder.createInitialContextFactory(Hashtable<?,?> environment) 使用指定环境创建一个初始上下文工厂。
ObjectFactory | ObjectFactoryBuilder.createObjectFactory(Object obj, Hashtable<?,?> environment) 使用所提供的环境创建一个新对象工厂。
static Context | NamingManager.getContinuationContext(CannotProceedException cpe) 创建一个将继续上下文操作的上下文。
static DirContext | DirectoryManager.getContinuationDirContext(CannotProceedException cpe) 创建一个将继续某个 DirContext 操作的上下文。
Context | InitialContextFactory.getInitialContext(Hashtable<?,?> environment) 创建一个初始上下文，以便开始进行名称解析。
static Context | NamingManager.getInitialContext(Hashtable<?,?> env) 使用指定环境属性创建一个初始上下文工厂。
static Object | NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象的状态。
Object | StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象状态。
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。
static Context | NamingManager.getURLContext(String scheme, Hashtable<?,?> environment) 为给定的 URL 方案 id 创建一个上下文。
ResolveResult | Resolver.resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
ResolveResult | Resolver.resolveToClass(String name, Class<? extends Context> contextType) 部分解析某一名称。
static void | NamingManager.setInitialContextFactoryBuilder(InitialContextFactoryBuilder builder) 将 InitialContextFactory 生成器设置为生成器。
static void | NamingManager.setObjectFactoryBuilder(ObjectFactoryBuilder builder) ObjectFactoryBuilder 确定尝试加载对象工厂时使用的策略。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.NamingSecurityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NamingSecurityException
的使用

使用 NamingSecurityException 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 NamingSecurityException 的使用

javax.naming 中 NamingSecurityException 的子类
class | AuthenticationException 当访问命名或目录服务发生验证错误时，抛出此异常。
class | AuthenticationNotSupportedException 当所请求验证的特定 flavor 不受支持时，抛出此异常。
class | NoPermissionException 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.NoInitialContextException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NoInitialContextException
的使用

没有 javax.naming.NoInitialContextException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.NoPermissionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NoPermissionException
的使用

没有 javax.naming.NoPermissionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.NotContextException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NotContextException
的使用

没有 javax.naming.NotContextException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.OperationNotSupportedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.OperationNotSupportedException
的使用

没有 javax.naming.OperationNotSupportedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.PartialResultException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.PartialResultException
的使用

没有 javax.naming.PartialResultException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.RefAddr 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.RefAddr
的使用

使用 RefAddr 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 RefAddr 的使用

javax.naming 中 RefAddr 的子类
class | BinaryRefAddr 此类表示通信终端地址的二进制形式。
class | StringRefAddr 此类表示通信终端地址的字符串形式。

类型参数类型为 RefAddr 的 javax.naming 中的字段
protected  Vector<RefAddr> Reference.addrs
包含此 Reference 中所包含的地址。

返回 RefAddr 的 javax.naming 中的方法
RefAddr | Reference.get(int posn) 检索索引 posn 处的地址。
RefAddr | Reference.get(String addrType) 检索地址类型为 'addrType' 的第一个地址。

返回变量类型为 RefAddr 的类型的 javax.naming 中的方法
 Enumeration<RefAddr> Reference.getAll()
返回此索引中的地址所组成的枚举。

参数类型为 RefAddr 的 javax.naming 中的方法
void | Reference.add(int posn, RefAddr addr) 将地址添加到地址列表中的索引 posn 处。
void | Reference.add(RefAddr addr) 将地址添加到地址列表的末尾。

参数类型为 RefAddr 的 javax.naming 中的构造方法
Reference(String className, RefAddr addr)
使用类名称 'className' 和一个地址构造对某个对象的新引用。
Reference(String className, RefAddr addr, String factory, String factoryLocation)
使用类名称 'className'、对象工厂的类名称和位置以及对象的地址创建该对某个对象的新引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.Reference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.Reference
的使用

使用 Reference 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 Reference 的使用

javax.naming 中 Reference 的子类
 class LinkRef
此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。

返回 Reference 的 javax.naming 中的方法
 Reference Referenceable.getReference()
检索此对象的 Reference。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.Referenceable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.Referenceable
的使用

没有 javax.naming.Referenceable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ReferralException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ReferralException
的使用

使用 ReferralException 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 ReferralException 的使用

javax.naming.ldap 中 ReferralException 的子类
 class LdapReferralException
此抽象类用于表示 LDAP 引用异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ServiceUnavailableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ServiceUnavailableException
的使用

没有 javax.naming.ServiceUnavailableException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.SizeLimitExceededException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.SizeLimitExceededException
的使用

没有 javax.naming.SizeLimitExceededException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.StringRefAddr 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.StringRefAddr
的使用

没有 javax.naming.StringRefAddr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.TimeLimitExceededException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.TimeLimitExceededException
的使用

没有 javax.naming.TimeLimitExceededException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.naming.directory (Java 2 Platform SE 6)

 javax.naming.directory
接口
Attribute
Attributes
DirContext
类
BasicAttribute
BasicAttributes
InitialDirContext
ModificationItem
SearchControls
SearchResult
异常
AttributeInUseException
AttributeModificationException
InvalidAttributeIdentifierException
InvalidAttributesException
InvalidAttributeValueException
InvalidSearchControlsException
InvalidSearchFilterException
NoSuchAttributeException
SchemaViolationException


接口 javax.naming.directory.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.directory.Attribute
的使用

使用 Attribute 的软件包
javax.naming.directory 扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming.directory 中 Attribute 的使用

实现 Attribute 的 javax.naming.directory 中的类
 class BasicAttribute
此类提供 Attribute 接口的基本实现。

返回 Attribute 的 javax.naming.directory 中的方法
Attribute | Attributes.get(String attrID) 利用属性集中的给定属性 id 检索属性。
Attribute | BasicAttributes.get(String attrID)
Attribute | ModificationItem.getAttribute() 检索与此修改项关联的属性。
Attribute | Attributes.put(Attribute attr) 向属性集中添加新属性。
Attribute | BasicAttributes.put(Attribute attr)
Attribute | Attributes.put(String attrID, Object val) 向属性集中添加新属性。
Attribute | BasicAttributes.put(String attrID, Object val)
Attribute | Attributes.remove(String attrID) 从属性集中移除属性 id 为 'attrID' 的属性。
Attribute | BasicAttributes.remove(String attrID)

返回变量类型为 Attribute 的类型的 javax.naming.directory 中的方法
NamingEnumeration<? extends Attribute> | Attributes.getAll() 检索属性集中属性的枚举。
NamingEnumeration<Attribute> | BasicAttributes.getAll()

参数类型为 Attribute 的 javax.naming.directory 中的方法
Attribute | Attributes.put(Attribute attr) 向属性集中添加新属性。
Attribute | BasicAttributes.put(Attribute attr)

参数类型为 Attribute 的 javax.naming.directory 中的构造方法
ModificationItem(int mod_op, Attribute attr)
创建一个新的 ModificationItem 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.AttributeInUseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.AttributeInUseException
的使用

没有 javax.naming.directory.AttributeInUseException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.AttributeModificationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.AttributeModificationException
的使用

没有 javax.naming.directory.AttributeModificationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.directory.Attributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.directory.Attributes
的使用

使用 Attributes 的软件包
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.directory 中 Attributes 的使用

实现 Attributes 的 javax.naming.directory 中的类
 class BasicAttributes
此类提供 Attributes 接口的基本实现。

返回 Attributes 的 javax.naming.directory 中的方法
Attributes | SearchResult.getAttributes() 检索此搜索结果中的属性。
Attributes | DirContext.getAttributes(Name name) 检索与命名对象关联的所有属性。
Attributes | InitialDirContext.getAttributes(Name name)
Attributes | DirContext.getAttributes(Name name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | InitialDirContext.getAttributes(Name name, String[] attrIds)
Attributes | DirContext.getAttributes(String name) 检索所有与命名对象关联的属性。
Attributes | InitialDirContext.getAttributes(String name)
Attributes | DirContext.getAttributes(String name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | InitialDirContext.getAttributes(String name, String[] attrIds)

参数类型为 Attributes 的 javax.naming.directory 中的方法
void | DirContext.bind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | InitialDirContext.bind(Name name, Object obj, Attributes attrs)
void | DirContext.bind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | InitialDirContext.bind(String name, Object obj, Attributes attrs)
DirContext | DirContext.createSubcontext(Name name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
DirContext | DirContext.createSubcontext(String name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(String name, Attributes attrs)
void | DirContext.modifyAttributes(Name name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
void | DirContext.modifyAttributes(String name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(String name, int mod_op, Attributes attrs)
void | DirContext.rebind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | InitialDirContext.rebind(Name name, Object obj, Attributes attrs)
void | DirContext.rebind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | InitialDirContext.rebind(String name, Object obj, Attributes attrs)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
void | SearchResult.setAttributes(Attributes attrs) 将此搜索结果的属性设置为 attrs。

参数类型为 Attributes 的 javax.naming.directory 中的构造方法
SearchResult(String name, Object obj, Attributes attrs)
使用结果的名称、绑定对象及其属性构造一个搜索结果。
SearchResult(String name, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。
SearchResult(String name, String className, Object obj, Attributes attrs)
使用结果的名称、类名称、绑定对象及其属性构造一个搜索结果。
SearchResult(String name, String className, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、类名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

javax.naming.ldap 中 Attributes 的使用

返回 Attributes 的 javax.naming.ldap 中的方法
 Attributes Rdn.toAttributes()
检索此 Rdn 中包含的类型/值映射关系的 Attributes 视图。

参数类型为 Attributes 的 javax.naming.ldap 中的构造方法
Rdn(Attributes attrSet)
根据给定属性集构造 Rdn。

javax.naming.spi 中 Attributes 的使用

返回 Attributes 的 javax.naming.spi 中的方法
 Attributes DirStateFactory.Result.getAttributes()
检索要绑定的属性。

参数类型为 Attributes 的 javax.naming.spi 中的方法
Object | DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 使用位置或引用信息以及指定的属性创建一个对象。
static Object | DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。

参数类型为 Attributes 的 javax.naming.spi 中的构造方法
DirStateFactory.Result(Object obj, Attributes outAttrs)
构造一个 Result 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.BasicAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.BasicAttribute
的使用

没有 javax.naming.directory.BasicAttribute 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.BasicAttributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.BasicAttributes
的使用

没有 javax.naming.directory.BasicAttributes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.directory.DirContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.directory.DirContext
的使用

使用 DirContext 的软件包
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.directory 中 DirContext 的使用

实现 DirContext 的 javax.naming.directory 中的类
 class InitialDirContext
此类是执行目录操作的初始上下文。

返回 DirContext 的 javax.naming.directory 中的方法
DirContext | DirContext.createSubcontext(Name name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
DirContext | DirContext.createSubcontext(String name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(String name, Attributes attrs)
DirContext | Attribute.getAttributeDefinition() 检索属性的模式定义。
DirContext | BasicAttribute.getAttributeDefinition() 检索此属性的模式定义。
DirContext | Attribute.getAttributeSyntaxDefinition() 检索与属性关联的语法定义。
DirContext | BasicAttribute.getAttributeSyntaxDefinition() 检索与此属性关联的语法定义。
DirContext | DirContext.getSchema(Name name) 检索与命名对象关联的模式。
DirContext | InitialDirContext.getSchema(Name name)
DirContext | DirContext.getSchema(String name) 检索与命名对象关联的模式。
DirContext | InitialDirContext.getSchema(String name)
DirContext | DirContext.getSchemaClassDefinition(Name name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | InitialDirContext.getSchemaClassDefinition(Name name)
DirContext | DirContext.getSchemaClassDefinition(String name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | InitialDirContext.getSchemaClassDefinition(String name)

javax.naming.event 中 DirContext 的使用

javax.naming.event 中 DirContext 的子接口
 interface EventDirContext
包含注册侦听器的一些方法，这些侦听器在目录上下文中命名的对象发生更改时将获得触发事件的通知。

javax.naming.ldap 中 DirContext 的使用

javax.naming.ldap 中 DirContext 的子接口
 interface LdapContext
此接口表示一个上下文，在该上下文中可以利用 LDAPv3 样式的控件执行操作，并且可以执行 LDAPv3 样式的扩展操作。

实现 DirContext 的 javax.naming.ldap 中的类
 class InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

javax.naming.spi 中 DirContext 的使用

返回 DirContext 的 javax.naming.spi 中的方法
static DirContext DirectoryManager.getContinuationDirContext(CannotProceedException cpe)
创建一个将继续某个 DirContext 操作的上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.InitialDirContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InitialDirContext
的使用

使用 InitialDirContext 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 InitialDirContext 的使用

javax.naming.ldap 中 InitialDirContext 的子类
 class InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.InvalidAttributeIdentifierException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InvalidAttributeIdentifierException
的使用

没有 javax.naming.directory.InvalidAttributeIdentifierException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.InvalidAttributesException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InvalidAttributesException
的使用

没有 javax.naming.directory.InvalidAttributesException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.InvalidAttributeValueException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InvalidAttributeValueException
的使用

没有 javax.naming.directory.InvalidAttributeValueException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.InvalidSearchControlsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InvalidSearchControlsException
的使用

没有 javax.naming.directory.InvalidSearchControlsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.InvalidSearchFilterException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InvalidSearchFilterException
的使用

没有 javax.naming.directory.InvalidSearchFilterException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.ModificationItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.ModificationItem
的使用

使用 ModificationItem 的软件包
javax.naming.directory 扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming.directory 中 ModificationItem 的使用

返回 ModificationItem 的 javax.naming.directory 中的方法
 ModificationItem[] AttributeModificationException.getUnexecutedModifications()
检索未执行修改的列表。

参数类型为 ModificationItem 的 javax.naming.directory 中的方法
void | DirContext.modifyAttributes(Name name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, ModificationItem[] mods)
void | DirContext.modifyAttributes(String name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(String name, ModificationItem[] mods)
void | AttributeModificationException.setUnexecutedModifications(ModificationItem[] e) 将未执行的修改列表设置为 e。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.NoSuchAttributeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.NoSuchAttributeException
的使用

没有 javax.naming.directory.NoSuchAttributeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.SchemaViolationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.SchemaViolationException
的使用

没有 javax.naming.directory.SchemaViolationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.SearchControls 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.SearchControls
的使用

使用 SearchControls 的软件包
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。

javax.naming.directory 中 SearchControls 的使用

参数类型为 SearchControls 的 javax.naming.directory 中的方法
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)

javax.naming.event 中 SearchControls 的使用

参数类型为 SearchControls 的 javax.naming.event 中的方法
void | EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。
void | EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.directory.SearchResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.SearchResult
的使用

使用 SearchResult 的软件包
javax.naming.directory 扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming.directory 中 SearchResult 的使用

返回变量类型为 SearchResult 的类型的 javax.naming.directory 中的方法
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.naming.event (Java 2 Platform SE 6)

 javax.naming.event
接口
EventContext
EventDirContext
NamespaceChangeListener
NamingListener
ObjectChangeListener
类
NamingEvent
NamingExceptionEvent


接口 javax.naming.event.EventContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.event.EventContext
的使用

使用 EventContext 的软件包
javax.naming.event 在访问命名和目录服务时提供对事件通知的支持。

javax.naming.event 中 EventContext 的使用

javax.naming.event 中 EventContext 的子接口
 interface EventDirContext
包含注册侦听器的一些方法，这些侦听器在目录上下文中命名的对象发生更改时将获得触发事件的通知。

返回 EventContext 的 javax.naming.event 中的方法
EventContext | NamingEvent.getEventContext() 检索触发此事件的事件源。
EventContext | NamingExceptionEvent.getEventContext() 检索触发此事件的 EventContext。

参数类型为 EventContext 的 javax.naming.event 中的构造方法
NamingEvent(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)
构造一个 NamingEvent 的实例。
NamingExceptionEvent(EventContext source, NamingException exc)
使用在抛出过 NamingException 的上下文和抛出的异常构造一个 NamingExceptionEvent 的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.event.EventDirContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.event.EventDirContext
的使用

没有 javax.naming.event.EventDirContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.event.NamespaceChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.event.NamespaceChangeListener
的使用

没有 javax.naming.event.NamespaceChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.event.NamingEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.event.NamingEvent
的使用

使用 NamingEvent 的软件包
javax.naming.event 在访问命名和目录服务时提供对事件通知的支持。

javax.naming.event 中 NamingEvent 的使用

参数类型为 NamingEvent 的 javax.naming.event 中的方法
void | NamespaceChangeListener.objectAdded(NamingEvent evt) 在已经添加了对象时调用此方法。
void | ObjectChangeListener.objectChanged(NamingEvent evt) 在已经更改了对象时调用此方法。
void | NamespaceChangeListener.objectRemoved(NamingEvent evt) 在已经移除了对象时调用此方法。
void | NamespaceChangeListener.objectRenamed(NamingEvent evt) 在已经重命名了对象时调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.event.NamingExceptionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.event.NamingExceptionEvent
的使用

使用 NamingExceptionEvent 的软件包
javax.naming.event 在访问命名和目录服务时提供对事件通知的支持。

javax.naming.event 中 NamingExceptionEvent 的使用

参数类型为 NamingExceptionEvent 的 javax.naming.event 中的方法
 void NamingListener.namingExceptionThrown(NamingExceptionEvent evt)
在试图触发 NamingEvent 期间抛出命名异常时调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.event.NamingListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.event.NamingListener
的使用

使用 NamingListener 的软件包
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.event 中 NamingListener 的使用

javax.naming.event 中 NamingListener 的子接口
interface | NamespaceChangeListener 指定对名称空间更改感兴趣的侦听器必须实现的方法。
interface | ObjectChangeListener 指定事件类型为 OBJECT_CHANGED 的 NamingEvent 侦听器必须实现的方法。

参数类型为 NamingListener 的 javax.naming.event 中的方法
 void EventContext.addNamingListener(Name target, int scope, NamingListener l)
添加接收命名事件的侦听器，这些事件在目标和范围所标识的对象发生更改时触发。
 void EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
 void EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。
 void EventContext.addNamingListener(String target, int scope, NamingListener l)
添加接收命名事件的侦听器，这些事件在目标名称和范围指定的对象发生更改时触发。
 void EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
 void EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。
 void NamingEvent.dispatch(NamingListener listener)
对此事件调用适当的侦听器方法。
 void NamingExceptionEvent.dispatch(NamingListener listener)
使用此事件对侦听器调用 namingExceptionThrown() 方法。
 void EventContext.removeNamingListener(NamingListener l)
从此 EventContext 触发的接收命名事件中移除一个侦听器。

javax.naming.ldap 中 NamingListener 的使用

javax.naming.ldap 中 NamingListener 的子接口
 interface UnsolicitedNotificationListener
此接口用于处理 UnsolicitedNotificationEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.event.ObjectChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.event.ObjectChangeListener
的使用

没有 javax.naming.event.ObjectChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.naming.ldap (Java 2 Platform SE 6)

 javax.naming.ldap
接口
Control
ExtendedRequest
ExtendedResponse
HasControls
LdapContext
UnsolicitedNotification
UnsolicitedNotificationListener
类
BasicControl
ControlFactory
InitialLdapContext
LdapName
ManageReferralControl
PagedResultsControl
PagedResultsResponseControl
Rdn
SortControl
SortKey
SortResponseControl
StartTlsRequest
StartTlsResponse
UnsolicitedNotificationEvent
异常
LdapReferralException


类 javax.naming.ldap.BasicControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.BasicControl
的使用

使用 BasicControl 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 BasicControl 的使用

javax.naming.ldap 中 BasicControl 的子类
class | ManageReferralControl 将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。
class | PagedResultsControl 请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。
class | PagedResultsResponseControl 指示一批搜索结果的末尾。
class | SortControl 请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。
class | SortResponseControl 指示搜索结果的请求排序是否成功。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.ldap.Control 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.Control
的使用

使用 Control 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 Control 的使用

实现 Control 的 javax.naming.ldap 中的类
class | BasicControl 此类提供 Control 接口的基本实现。
class | ManageReferralControl 将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。
class | PagedResultsControl 请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。
class | PagedResultsResponseControl 指示一批搜索结果的末尾。
class | SortControl 请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。
class | SortResponseControl 指示搜索结果的请求排序是否成功。

返回 Control 的 javax.naming.ldap 中的方法
Control[] | InitialLdapContext.getConnectControls()
Control[] | LdapContext.getConnectControls() 检索对此上下文有效的连接请求控件。
abstract Control | ControlFactory.getControlInstance(Control ctl) 使用此控件工厂创建控件。
static Control | ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env) 使用已知控件工厂创建控件。
Control[] | HasControls.getControls() 从实现此接口的对象中检索 Control 数组。
Control[] | InitialLdapContext.getRequestControls()
Control[] | LdapContext.getRequestControls() 检索对此上下文有效的请求控件。
Control[] | InitialLdapContext.getResponseControls()
Control[] | LdapContext.getResponseControls() 检索对此上下文调用的最后一个方法所生成的响应控件。

参数类型为 Control 的 javax.naming.ldap 中的方法
abstract Control | ControlFactory.getControlInstance(Control ctl) 使用此控件工厂创建控件。
static Control | ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env) 使用已知控件工厂创建控件。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls) 使用请求控件和环境属性检索继续该方法的上下文。
LdapContext | InitialLdapContext.newInstance(Control[] reqCtls)
LdapContext | LdapContext.newInstance(Control[] requestControls) 创建此上下文的新实例，使用请求控件进行初始化。
void | InitialLdapContext.reconnect(Control[] connCtls)
void | LdapContext.reconnect(Control[] connCtls) 使用提供的控件和此上下文的环境重新连接到 LDAP 服务器。
void | InitialLdapContext.setRequestControls(Control[] requestControls)
void | LdapContext.setRequestControls(Control[] requestControls) 为在此上下文上后续调用的方法设置请求控件。

参数类型为 Control 的 javax.naming.ldap 中的构造方法
InitialLdapContext(Hashtable<?,?> environment, Control[] connCtls)
使用环境属性或连接请求控件构造初始上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.ControlFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.ControlFactory
的使用

没有 javax.naming.ldap.ControlFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.ldap.ExtendedRequest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.ExtendedRequest
的使用

使用 ExtendedRequest 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 ExtendedRequest 的使用

实现 ExtendedRequest 的 javax.naming.ldap 中的类
 class StartTlsRequest
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展请求。

参数类型为 ExtendedRequest 的 javax.naming.ldap 中的方法
ExtendedResponse | InitialLdapContext.extendedOperation(ExtendedRequest request)
ExtendedResponse | LdapContext.extendedOperation(ExtendedRequest request) 执行扩展操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.ldap.ExtendedResponse 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.ExtendedResponse
的使用

使用 ExtendedResponse 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 ExtendedResponse 的使用

javax.naming.ldap 中 ExtendedResponse 的子接口
 interface UnsolicitedNotification
此接口表示在 RFC 2251 中定义的未经请求的通知。

实现 ExtendedResponse 的 javax.naming.ldap 中的类
 class StartTlsResponse
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展响应。

返回 ExtendedResponse 的 javax.naming.ldap 中的方法
ExtendedResponse | ExtendedRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length) 创建与此请求对应的响应对象。
ExtendedResponse | StartTlsRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length) 创建与 LDAP StartTLS 扩展请求相对应的扩展响应对象。
ExtendedResponse | InitialLdapContext.extendedOperation(ExtendedRequest request)
ExtendedResponse | LdapContext.extendedOperation(ExtendedRequest request) 执行扩展操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.ldap.HasControls 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.HasControls
的使用

使用 HasControls 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 HasControls 的使用

javax.naming.ldap 中 HasControls 的子接口
 interface UnsolicitedNotification
此接口表示在 RFC 2251 中定义的未经请求的通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.InitialLdapContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.InitialLdapContext
的使用

没有 javax.naming.ldap.InitialLdapContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.ldap.LdapContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.LdapContext
的使用

使用 LdapContext 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 LdapContext 的使用

实现 LdapContext 的 javax.naming.ldap 中的类
 class InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

返回 LdapContext 的 javax.naming.ldap 中的方法
LdapContext | InitialLdapContext.newInstance(Control[] reqCtls)
LdapContext | LdapContext.newInstance(Control[] requestControls) 创建此上下文的新实例，使用请求控件进行初始化。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.LdapName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.LdapName
的使用

没有 javax.naming.ldap.LdapName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.LdapReferralException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.LdapReferralException
的使用

没有 javax.naming.ldap.LdapReferralException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.ManageReferralControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.ManageReferralControl
的使用

没有 javax.naming.ldap.ManageReferralControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.PagedResultsControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.PagedResultsControl
的使用

没有 javax.naming.ldap.PagedResultsControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.PagedResultsResponseControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.PagedResultsResponseControl
的使用

没有 javax.naming.ldap.PagedResultsResponseControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.Rdn 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.Rdn
的使用

使用 Rdn 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 Rdn 的使用

返回 Rdn 的 javax.naming.ldap 中的方法
 Rdn LdapName.getRdn(int posn)
以 Rdn 形式检索此 LDAP 名称的 RDN。

返回变量类型为 Rdn 的类型的 javax.naming.ldap 中的方法
 List<Rdn> LdapName.getRdns()
检索相对标识名列表。

参数类型为 Rdn 的 javax.naming.ldap 中的方法
Name | LdapName.add(int posn, Rdn comp) 将单个 RDN 添加到此 LDAP 名称中的指定位置。
Name | LdapName.add(Rdn comp) 将单个 RDN 添加到此 LDAP 名称的末尾。

类型变量类型为 Rdn 的 javax.naming.ldap 中的方法参数
Name | LdapName.addAll(int posn, List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称中的指定位置。
Name | LdapName.addAll(List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称的末尾。
boolean | LdapName.endsWith(List<Rdn> rdns) 确定指定的 RDN 序列是否形成此 LDAP 名称的后缀。
boolean | LdapName.startsWith(List<Rdn> rdns) 确定指定的 RDN 序列是否形成此 LDAP 名称的前缀。

参数类型为 Rdn 的 javax.naming.ldap 中的构造方法
Rdn(Rdn rdn)
根据给定 rdn 构造 Rdn。

类型变量类型为 Rdn 的 javax.naming.ldap 中的构造方法参数
LdapName(List<Rdn> rdns)
在给定已解析 RDN 组件的情况下构造 LDAP 名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.SortControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.SortControl
的使用

没有 javax.naming.ldap.SortControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.SortKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.SortKey
的使用

使用 SortKey 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 SortKey 的使用

参数类型为 SortKey 的 javax.naming.ldap 中的构造方法
SortControl(SortKey[] sortBy, boolean criticality)
构造一个控件来对排序键列表进行排序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.SortResponseControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.SortResponseControl
的使用

没有 javax.naming.ldap.SortResponseControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.StartTlsRequest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.StartTlsRequest
的使用

没有 javax.naming.ldap.StartTlsRequest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.StartTlsResponse 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.StartTlsResponse
的使用

没有 javax.naming.ldap.StartTlsResponse 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.ldap.UnsolicitedNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.UnsolicitedNotification
的使用

使用 UnsolicitedNotification 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 UnsolicitedNotification 的使用

返回 UnsolicitedNotification 的 javax.naming.ldap 中的方法
 UnsolicitedNotification UnsolicitedNotificationEvent.getNotification()
返回未经请求的通知。

参数类型为 UnsolicitedNotification 的 javax.naming.ldap 中的构造方法
UnsolicitedNotificationEvent(Object src, UnsolicitedNotification notice)
构造一个新的 UnsolicitedNotificationEvent 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.ldap.UnsolicitedNotificationEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.UnsolicitedNotificationEvent
的使用

使用 UnsolicitedNotificationEvent 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 UnsolicitedNotificationEvent 的使用

参数类型为 UnsolicitedNotificationEvent 的 javax.naming.ldap 中的方法
 void UnsolicitedNotificationListener.notificationReceived(UnsolicitedNotificationEvent evt)
当收到了未经请求的通知时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.ldap.UnsolicitedNotificationListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.UnsolicitedNotificationListener
的使用

使用 UnsolicitedNotificationListener 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 UnsolicitedNotificationListener 的使用

参数类型为 UnsolicitedNotificationListener 的 javax.naming.ldap 中的方法
 void UnsolicitedNotificationEvent.dispatch(UnsolicitedNotificationListener listener)
使用此事件对侦听器调用 notificationReceived() 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.naming.spi (Java 2 Platform SE 6)

 javax.naming.spi
接口
DirObjectFactory
DirStateFactory
InitialContextFactory
InitialContextFactoryBuilder
ObjectFactory
ObjectFactoryBuilder
Resolver
StateFactory
类
DirectoryManager
DirStateFactory.Result
NamingManager
ResolveResult


类 javax.naming.spi.DirectoryManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.spi.DirectoryManager
的使用

没有 javax.naming.spi.DirectoryManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.spi.DirObjectFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.DirObjectFactory
的使用

没有 javax.naming.spi.DirObjectFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.spi.DirStateFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.DirStateFactory
的使用

没有 javax.naming.spi.DirStateFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.spi.DirStateFactory.Result 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.spi.DirStateFactory.Result
的使用

使用 DirStateFactory.Result 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 DirStateFactory.Result 的使用

返回 DirStateFactory.Result 的 javax.naming.spi 中的方法
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.spi.InitialContextFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.InitialContextFactory
的使用

使用 InitialContextFactory 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 InitialContextFactory 的使用

返回 InitialContextFactory 的 javax.naming.spi 中的方法
 InitialContextFactory InitialContextFactoryBuilder.createInitialContextFactory(Hashtable<?,?> environment)
使用指定环境创建一个初始上下文工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.spi.InitialContextFactoryBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.InitialContextFactoryBuilder
的使用

使用 InitialContextFactoryBuilder 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 InitialContextFactoryBuilder 的使用

参数类型为 InitialContextFactoryBuilder 的 javax.naming.spi 中的方法
static void NamingManager.setInitialContextFactoryBuilder(InitialContextFactoryBuilder builder)
将 InitialContextFactory 生成器设置为生成器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.spi.NamingManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.spi.NamingManager
的使用

使用 NamingManager 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 NamingManager 的使用

javax.naming.spi 中 NamingManager 的子类
 class DirectoryManager
此类包含支持 DirContext 实现的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.spi.ObjectFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.ObjectFactory
的使用

使用 ObjectFactory 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 ObjectFactory 的使用

javax.naming.spi 中 ObjectFactory 的子接口
 interface DirObjectFactory
此接口表示一个工厂，该工厂用来在给定某一对象以及有关该对象的属性的情况下创建该对象。

返回 ObjectFactory 的 javax.naming.spi 中的方法
 ObjectFactory ObjectFactoryBuilder.createObjectFactory(Object obj, Hashtable<?,?> environment)
使用所提供的环境创建一个新对象工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.spi.ObjectFactoryBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.ObjectFactoryBuilder
的使用

使用 ObjectFactoryBuilder 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 ObjectFactoryBuilder 的使用

参数类型为 ObjectFactoryBuilder 的 javax.naming.spi 中的方法
static void NamingManager.setObjectFactoryBuilder(ObjectFactoryBuilder builder)
ObjectFactoryBuilder 确定尝试加载对象工厂时使用的策略。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.spi.Resolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.Resolver
的使用

没有 javax.naming.spi.Resolver 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.naming.spi.ResolveResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.spi.ResolveResult
的使用

使用 ResolveResult 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 ResolveResult 的使用

返回 ResolveResult 的 javax.naming.spi 中的方法
ResolveResult | Resolver.resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
ResolveResult | Resolver.resolveToClass(String name, Class<? extends Context> contextType) 部分解析某一名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.naming.spi.StateFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.StateFactory
的使用

使用 StateFactory 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 StateFactory 的使用

javax.naming.spi 中 StateFactory 的子接口
 interface DirStateFactory
此接口表示一个工厂，该工厂用来获得对象的状态和用于绑定的相应属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.net (Java 2 Platform SE 6)

 javax.net
类
ServerSocketFactory
SocketFactory


类 javax.net.ServerSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ServerSocketFactory
的使用

使用 ServerSocketFactory 的软件包
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。

javax.net 中 ServerSocketFactory 的使用

返回 ServerSocketFactory 的 javax.net 中的方法
static ServerSocketFactory ServerSocketFactory.getDefault()
返回该环境默认套接字工厂的一个副本。

javax.net.ssl 中 ServerSocketFactory 的使用

javax.net.ssl 中 ServerSocketFactory 的子类
 class SSLServerSocketFactory
SSLServerSocketFactory 创建 SSLServerSocket。

返回 ServerSocketFactory 的 javax.net.ssl 中的方法
static ServerSocketFactory SSLServerSocketFactory.getDefault()
返回默认的 SSL 服务器套接字工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.SocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.SocketFactory
的使用

使用 SocketFactory 的软件包
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。

javax.net 中 SocketFactory 的使用

返回 SocketFactory 的 javax.net 中的方法
static SocketFactory SocketFactory.getDefault()
返回该环境默认套接字工厂的一个副本。

javax.net.ssl 中 SocketFactory 的使用

javax.net.ssl 中 SocketFactory 的子类
 class SSLSocketFactory
SSLSocketFactory 创建 SSLSocket。

返回 SocketFactory 的 javax.net.ssl 中的方法
static SocketFactory SSLSocketFactory.getDefault()
返回默认的 SSL 套接字工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.net.ssl (Java 2 Platform SE 6)

 javax.net.ssl
接口
HandshakeCompletedListener
HostnameVerifier
KeyManager
ManagerFactoryParameters
SSLSession
SSLSessionBindingListener
SSLSessionContext
TrustManager
X509KeyManager
X509TrustManager
类
CertPathTrustManagerParameters
HandshakeCompletedEvent
HttpsURLConnection
KeyManagerFactory
KeyManagerFactorySpi
KeyStoreBuilderParameters
SSLContext
SSLContextSpi
SSLEngine
SSLEngineResult
SSLParameters
SSLPermission
SSLServerSocket
SSLServerSocketFactory
SSLSessionBindingEvent
SSLSocket
SSLSocketFactory
TrustManagerFactory
TrustManagerFactorySpi
X509ExtendedKeyManager
枚举
SSLEngineResult.HandshakeStatus
SSLEngineResult.Status
异常
SSLException
SSLHandshakeException
SSLKeyException
SSLPeerUnverifiedException
SSLProtocolException


类 javax.net.ssl.CertPathTrustManagerParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.CertPathTrustManagerParameters
的使用

没有 javax.net.ssl.CertPathTrustManagerParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.HandshakeCompletedEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.HandshakeCompletedEvent
的使用

使用 HandshakeCompletedEvent 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 HandshakeCompletedEvent 的使用

参数类型为 HandshakeCompletedEvent 的 javax.net.ssl 中的方法
 void HandshakeCompletedListener.handshakeCompleted(HandshakeCompletedEvent event)
当 SSL 握手结束时，在已注册的对象上调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.net.ssl.HandshakeCompletedListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.HandshakeCompletedListener
的使用

使用 HandshakeCompletedListener 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 HandshakeCompletedListener 的使用

参数类型为 HandshakeCompletedListener 的 javax.net.ssl 中的方法
abstract void | SSLSocket.addHandshakeCompletedListener(HandshakeCompletedListener listener) 注册一个事件侦听器来接收此连接上的 SSL 握手已经完成的通知。
abstract void | SSLSocket.removeHandshakeCompletedListener(HandshakeCompletedListener listener) 移除一个以前注册的握手完成侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.net.ssl.HostnameVerifier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.HostnameVerifier
的使用

使用 HostnameVerifier 的软件包
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。

javax.naming.ldap 中 HostnameVerifier 的使用

参数类型为 HostnameVerifier 的 javax.naming.ldap 中的方法
abstract  void StartTlsResponse.setHostnameVerifier(HostnameVerifier verifier)
设置在已完成 TLS 握手且默认主机名校验失败后供 negotiate() 使用的主机名校验器。

javax.net.ssl 中 HostnameVerifier 的使用

声明为 HostnameVerifier 的 javax.net.ssl 中的字段
protected  HostnameVerifier HttpsURLConnection.hostnameVerifier
此对象的 hostnameVerifier。

返回 HostnameVerifier 的 javax.net.ssl 中的方法
static HostnameVerifier | HttpsURLConnection.getDefaultHostnameVerifier() 获取此类的新实例所继承的默认 HostnameVerifier。
HostnameVerifier | HttpsURLConnection.getHostnameVerifier() 获取此实例适当的 HostnameVerifier。

参数类型为 HostnameVerifier 的 javax.net.ssl 中的方法
static void | HttpsURLConnection.setDefaultHostnameVerifier(HostnameVerifier v) 设置此类的新实例所继承的默认 HostnameVerifier。
void | HttpsURLConnection.setHostnameVerifier(HostnameVerifier v) 设置此实例的 HostnameVerifier。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.HttpsURLConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.HttpsURLConnection
的使用

没有 javax.net.ssl.HttpsURLConnection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.net.ssl.KeyManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.KeyManager
的使用

使用 KeyManager 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 KeyManager 的使用

javax.net.ssl 中 KeyManager 的子接口
 interface X509KeyManager
此接口的实例管理使用哪一个基于 X509 证书的密钥对来验证本地的安全套接字。

实现 KeyManager 的 javax.net.ssl 中的类
 class X509ExtendedKeyManager
提供 X509KeyManager 接口的扩展的抽象类。

返回 KeyManager 的 javax.net.ssl 中的方法
protected abstract KeyManager[] | KeyManagerFactorySpi.engineGetKeyManagers() 为每类密钥内容返回一个密钥管理器。
KeyManager[] | KeyManagerFactory.getKeyManagers() 为每类密钥内容返回一个密钥管理器。

参数类型为 KeyManager 的 javax.net.ssl 中的方法
protected abstract void | SSLContextSpi.engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr) 初始化此上下文。
void | SSLContext.init(KeyManager[] km, TrustManager[] tm, SecureRandom random) 初始化此上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.KeyManagerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.KeyManagerFactory
的使用

使用 KeyManagerFactory 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 KeyManagerFactory 的使用

返回 KeyManagerFactory 的 javax.net.ssl 中的方法
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, Provider provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, String provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.KeyManagerFactorySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.KeyManagerFactorySpi
的使用

使用 KeyManagerFactorySpi 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 KeyManagerFactorySpi 的使用

参数类型为 KeyManagerFactorySpi 的 javax.net.ssl 中的构造方法
KeyManagerFactory(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 KeyManagerFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.KeyStoreBuilderParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.KeyStoreBuilderParameters
的使用

没有 javax.net.ssl.KeyStoreBuilderParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.net.ssl.ManagerFactoryParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.ManagerFactoryParameters
的使用

使用 ManagerFactoryParameters 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 ManagerFactoryParameters 的使用

实现 ManagerFactoryParameters 的 javax.net.ssl 中的类
class | CertPathTrustManagerParameters CertPathParameters 的包装器。
class | KeyStoreBuilderParameters 封装了 KeyStore.Builders 列表的 X509KeyManagers 参数对象。

参数类型为 ManagerFactoryParameters 的 javax.net.ssl 中的方法
protected abstract void | KeyManagerFactorySpi.engineInit(ManagerFactoryParameters spec) 使用密钥内容源初始化此工厂。
protected abstract void | TrustManagerFactorySpi.engineInit(ManagerFactoryParameters spec) 使用特定于提供者的密钥材料源初始化此工厂。
void | KeyManagerFactory.init(ManagerFactoryParameters spec) 使用特定于提供者的密钥内容源初始化此工厂。
void | TrustManagerFactory.init(ManagerFactoryParameters spec) 使用特定于提供者的信任材料源初始化此工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLContext
的使用

使用 SSLContext 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLContext 的使用

返回 SSLContext 的 javax.net.ssl 中的方法
static SSLContext | SSLContext.getDefault() 返回默认的 SSL 上下文。
static SSLContext | SSLContext.getInstance(String protocol) 返回实现指定安全套接字协议的 SSLContext 对象。
static SSLContext | SSLContext.getInstance(String protocol, Provider provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static SSLContext | SSLContext.getInstance(String protocol, String provider) 返回实现指定安全套接字协议的 SSLContext 对象。

参数类型为 SSLContext 的 javax.net.ssl 中的方法
static void SSLContext.setDefault(SSLContext context)
设置默认的 SSL 上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLContextSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLContextSpi
的使用

使用 SSLContextSpi 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLContextSpi 的使用

参数类型为 SSLContextSpi 的 javax.net.ssl 中的构造方法
SSLContext(SSLContextSpi contextSpi, Provider provider, String protocol)
创建 SSLContext 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLEngine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLEngine
的使用

使用 SSLEngine 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLEngine 的使用

返回 SSLEngine 的 javax.net.ssl 中的方法
SSLEngine | SSLContext.createSSLEngine() 使用此上下文创建新的 SSLEngine。
SSLEngine | SSLContext.createSSLEngine(String peerHost, int peerPort) 使用此上下文创建新的 SSLEngine，该上下文使用劝告同位体信息。
protected abstract SSLEngine | SSLContextSpi.engineCreateSSLEngine() 使用此上下文创建新的 SSLEngine。
protected abstract SSLEngine | SSLContextSpi.engineCreateSSLEngine(String host, int port) 使用此上下文创建 SSLEngine。

参数类型为 SSLEngine 的 javax.net.ssl 中的方法
String | X509ExtendedKeyManager.chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine) 选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。
String | X509ExtendedKeyManager.chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine) 选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLEngineResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLEngineResult
的使用

使用 SSLEngineResult 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLEngineResult 的使用

返回 SSLEngineResult 的 javax.net.ssl 中的方法
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer dst) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区中。
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
abstract SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, ByteBuffer dst) 尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
abstract SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst) 尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
SSLEngineResult | SSLEngine.wrap(ByteBuffer src, ByteBuffer dst) 试图把缓冲区的纯文本应用程序数据编码成 SSL/TLS 网络数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLEngineResult.HandshakeStatus 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLEngineResult.HandshakeStatus
的使用

使用 SSLEngineResult.HandshakeStatus 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLEngineResult.HandshakeStatus 的使用

返回 SSLEngineResult.HandshakeStatus 的 javax.net.ssl 中的方法
abstract SSLEngineResult.HandshakeStatus | SSLEngine.getHandshakeStatus() 返回此 SSLEngine 的当前握手状态。
SSLEngineResult.HandshakeStatus | SSLEngineResult.getHandshakeStatus() 获得此 SSLEngine 操作的握手状态。
static SSLEngineResult.HandshakeStatus | SSLEngineResult.HandshakeStatus.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SSLEngineResult.HandshakeStatus[] | SSLEngineResult.HandshakeStatus.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 SSLEngineResult.HandshakeStatus 的 javax.net.ssl 中的构造方法
SSLEngineResult(SSLEngineResult.Status status, SSLEngineResult.HandshakeStatus handshakeStatus, int bytesConsumed, int bytesProduced)
初始化此类的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLEngineResult.Status 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLEngineResult.Status
的使用

使用 SSLEngineResult.Status 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLEngineResult.Status 的使用

返回 SSLEngineResult.Status 的 javax.net.ssl 中的方法
SSLEngineResult.Status | SSLEngineResult.getStatus() 获得此 SSLEngine 操作的返回值。
static SSLEngineResult.Status | SSLEngineResult.Status.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SSLEngineResult.Status[] | SSLEngineResult.Status.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 SSLEngineResult.Status 的 javax.net.ssl 中的构造方法
SSLEngineResult(SSLEngineResult.Status status, SSLEngineResult.HandshakeStatus handshakeStatus, int bytesConsumed, int bytesProduced)
初始化此类的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLException
的使用

使用 SSLException 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLException 的使用

javax.net.ssl 中 SSLException 的子类
class | SSLHandshakeException 指示客户端和服务器不能就所需安全级别进行协商。
class | SSLKeyException 报告错误的 SSL 密钥。
class | SSLPeerUnverifiedException 指示还没有验证同位体的身份。
class | SSLProtocolException 报告在 SSL 协议的操作中的错误。

抛出 SSLException 的 javax.net.ssl 中的方法
abstract void | SSLEngine.beginHandshake() 在此 SSLEngine 上发起握手（初始的或重新协商）。
abstract void | SSLEngine.closeInbound() 通知没有更多的入站网络数据将发送到此 SSLEngine。
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer dst) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区中。
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
abstract SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, ByteBuffer dst) 尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
abstract SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst) 尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
SSLEngineResult | SSLEngine.wrap(ByteBuffer src, ByteBuffer dst) 试图把缓冲区的纯文本应用程序数据编码成 SSL/TLS 网络数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLHandshakeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLHandshakeException
的使用

没有 javax.net.ssl.SSLHandshakeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLKeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLKeyException
的使用

没有 javax.net.ssl.SSLKeyException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLParameters
的使用

使用 SSLParameters 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLParameters 的使用

返回 SSLParameters 的 javax.net.ssl 中的方法
protected SSLParameters | SSLContextSpi.engineGetDefaultSSLParameters() 返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。
protected SSLParameters | SSLContextSpi.engineGetSupportedSSLParameters() 返回表示此 SSL 上下文最大受支持设置的 SSLParameters 的副本。
SSLParameters | SSLContext.getDefaultSSLParameters() 返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。
SSLParameters | SSLSocket.getSSLParameters() 返回对此 SSLSocket 有效的 SSLParameters。
SSLParameters | SSLEngine.getSSLParameters() 返回对此 SSLEngine 有效的 SSLParameters。
SSLParameters | SSLContext.getSupportedSSLParameters() 返回表示此 SSL 上下文受支持设置的 SSLParameters 的副本。

参数类型为 SSLParameters 的 javax.net.ssl 中的方法
void | SSLSocket.setSSLParameters(SSLParameters params) 对此套接字应用 SSLParameters。
void | SSLEngine.setSSLParameters(SSLParameters params) 对此引擎应用 SSLParameters。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLPeerUnverifiedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLPeerUnverifiedException
的使用

使用 SSLPeerUnverifiedException 的软件包
java.net | 为实现网络应用程序提供类。
javax.net.ssl | 提供用于安全套接字包的类。

java.net 中 SSLPeerUnverifiedException 的使用

抛出 SSLPeerUnverifiedException 的 java.net 中的方法
abstract Principal | SecureCacheResponse.getPeerPrincipal() 返回服务器的主体，该主体是作为在获得了网络资源的初始连接期间定义会话的一部分建立的。
abstract List<Certificate> | SecureCacheResponse.getServerCertificateChain() 从缓存返回服务器的证书链，该证书链是作为在获得了网络资源的初始连接中定义会话的一部分建立的。

javax.net.ssl 中 SSLPeerUnverifiedException 的使用

抛出 SSLPeerUnverifiedException 的 javax.net.ssl 中的方法
X509Certificate[] | HandshakeCompletedEvent.getPeerCertificateChain() 返回同位体的标识，同位体是作为定义会话的一部分而标识的。
X509Certificate[] | SSLSession.getPeerCertificateChain() 返回同级身份，该同级身份被标识作为定义会话的一部分。
Certificate[] | HandshakeCompletedEvent.getPeerCertificates() 返回同位体的标识，同位体是作为定义会话的一部分而建立的。
Certificate[] | SSLSession.getPeerCertificates() 返回同级身份，该同级身份是作为定义会话的一部分而建立的。
Principal | HandshakeCompletedEvent.getPeerPrincipal() 返回同位体的标识，同位体是作为定义会话的一部分而建立的。
Principal | SSLSession.getPeerPrincipal() 返回同级身份，该同级身份是作为定义会话的一部分而建立的。
Principal | HttpsURLConnection.getPeerPrincipal() 返回服务器的主体，它是作为定义会话的一部分而建立的。
abstract Certificate[] | HttpsURLConnection.getServerCertificates() 返回服务器的证书链，它是作为定义会话的一部分而建立的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLPermission
的使用

没有 javax.net.ssl.SSLPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLProtocolException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLProtocolException
的使用

没有 javax.net.ssl.SSLProtocolException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLServerSocket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLServerSocket
的使用

没有 javax.net.ssl.SSLServerSocket 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLServerSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLServerSocketFactory
的使用

使用 SSLServerSocketFactory 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLServerSocketFactory 的使用

返回 SSLServerSocketFactory 的 javax.net.ssl 中的方法
protected abstract SSLServerSocketFactory | SSLContextSpi.engineGetServerSocketFactory() 返回此上下文的 ServerSocketFactory 对象。
SSLServerSocketFactory | SSLContext.getServerSocketFactory() 返回此上下文的 ServerSocketFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.net.ssl.SSLSession 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.SSLSession
的使用

使用 SSLSession 的软件包
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。

javax.naming.ldap 中 SSLSession 的使用

返回 SSLSession 的 javax.naming.ldap 中的方法
abstract SSLSession | StartTlsResponse.negotiate() 使用默认的 SSL 套接字工厂协商 TLS 会话。
abstract SSLSession | StartTlsResponse.negotiate(SSLSocketFactory factory) 使用 SSL 套接字工厂协商 TLS 会话。

javax.net.ssl 中 SSLSession 的使用

返回 SSLSession 的 javax.net.ssl 中的方法
SSLSession | HandshakeCompletedEvent.getSession() 返回触发此事件的会话。
abstract SSLSession | SSLSocket.getSession() 返回此连接使用的 SSL 会话。
abstract SSLSession | SSLEngine.getSession() 返回此 SSLEngine 中使用的 SSLSession。
SSLSession | SSLSessionBindingEvent.getSession() 返回 SSLSession，将侦听器绑定其中或从其解除绑定。
SSLSession | SSLSessionContext.getSession(byte[] sessionId) 返回绑定到指定会话 id 的 SSLSession。

参数类型为 SSLSession 的 javax.net.ssl 中的方法
 boolean HostnameVerifier.verify(String hostname, SSLSession session)
验证主机名和服务器验证方案的匹配是可接受的。

参数类型为 SSLSession 的 javax.net.ssl 中的构造方法
HandshakeCompletedEvent(SSLSocket sock, SSLSession s)
构造一个新的 HandshakeCompletedEvent。
SSLSessionBindingEvent(SSLSession session, String name)
构造一个新的 SSLSessionBindingEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLSessionBindingEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLSessionBindingEvent
的使用

使用 SSLSessionBindingEvent 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLSessionBindingEvent 的使用

参数类型为 SSLSessionBindingEvent 的 javax.net.ssl 中的方法
void | SSLSessionBindingListener.valueBound(SSLSessionBindingEvent event) 调用此方法通知侦听器要将其绑定到 SSLSession 中。
void | SSLSessionBindingListener.valueUnbound(SSLSessionBindingEvent event) 调用此方法通知侦听器要从 SSLSession 中解除其绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.net.ssl.SSLSessionBindingListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.SSLSessionBindingListener
的使用

没有 javax.net.ssl.SSLSessionBindingListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.net.ssl.SSLSessionContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.SSLSessionContext
的使用

使用 SSLSessionContext 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLSessionContext 的使用

返回 SSLSessionContext 的 javax.net.ssl 中的方法
protected abstract SSLSessionContext | SSLContextSpi.engineGetClientSessionContext() 返回此上下文的客户端 SSLSessionContext 对象。
protected abstract SSLSessionContext | SSLContextSpi.engineGetServerSessionContext() 返回此上下文的服务器 SSLSessionContext 对象。
SSLSessionContext | SSLContext.getClientSessionContext() 返回客户端会话上下文，它表示可供客户端 SSL 套接字握手阶段所使用的 SSL 会话集。
SSLSessionContext | SSLContext.getServerSessionContext() 返回服务器会话上下文，它表示可供服务器端 SSL 套接字握手阶段所使用的 SSL 会话集。
SSLSessionContext | SSLSession.getSessionContext() 返回此会话所在的上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLSocket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLSocket
的使用

使用 SSLSocket 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLSocket 的使用

返回 SSLSocket 的 javax.net.ssl 中的方法
 SSLSocket HandshakeCompletedEvent.getSocket()
返回作为此事件源的套接字。

参数类型为 SSLSocket 的 javax.net.ssl 中的构造方法
HandshakeCompletedEvent(SSLSocket sock, SSLSession s)
构造一个新的 HandshakeCompletedEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.SSLSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLSocketFactory
的使用

使用 SSLSocketFactory 的软件包
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。

javax.naming.ldap 中 SSLSocketFactory 的使用

参数类型为 SSLSocketFactory 的 javax.naming.ldap 中的方法
abstract  SSLSession StartTlsResponse.negotiate(SSLSocketFactory factory)
使用 SSL 套接字工厂协商 TLS 会话。

javax.net.ssl 中 SSLSocketFactory 的使用

返回 SSLSocketFactory 的 javax.net.ssl 中的方法
protected abstract SSLSocketFactory | SSLContextSpi.engineGetSocketFactory() 返回此上下文的 SocketFactory 对象。
static SSLSocketFactory | HttpsURLConnection.getDefaultSSLSocketFactory() 获取此类的新实例所继承的默认静态 SSLSocketFactory。
SSLSocketFactory | SSLContext.getSocketFactory() 返回此上下文的 SocketFactory 对象。
SSLSocketFactory | HttpsURLConnection.getSSLSocketFactory() 获取为安全 https URL 连接创建套接字时使用的 SSL 套接字工厂。

参数类型为 SSLSocketFactory 的 javax.net.ssl 中的方法
static void | HttpsURLConnection.setDefaultSSLSocketFactory(SSLSocketFactory sf) 设置此类的新实例所继承的默认 SSLSocketFactory。
void | HttpsURLConnection.setSSLSocketFactory(SSLSocketFactory sf) 设置当此实例为安全 https URL 连接创建套接字时使用的 SSLSocketFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.net.ssl.TrustManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.TrustManager
的使用

使用 TrustManager 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 TrustManager 的使用

javax.net.ssl 中 TrustManager 的子接口
 interface X509TrustManager
此接口的实例管理使用哪一个 X509 证书来验证远端的安全套接字。

返回 TrustManager 的 javax.net.ssl 中的方法
protected abstract TrustManager[] | TrustManagerFactorySpi.engineGetTrustManagers() 为每种信任材料返回一个信任管理器。
TrustManager[] | TrustManagerFactory.getTrustManagers() 为每种信任材料返回一个信任管理器。

参数类型为 TrustManager 的 javax.net.ssl 中的方法
protected abstract void | SSLContextSpi.engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr) 初始化此上下文。
void | SSLContext.init(KeyManager[] km, TrustManager[] tm, SecureRandom random) 初始化此上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.TrustManagerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.TrustManagerFactory
的使用

使用 TrustManagerFactory 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 TrustManagerFactory 的使用

返回 TrustManagerFactory 的 javax.net.ssl 中的方法
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, Provider provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, String provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.TrustManagerFactorySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.TrustManagerFactorySpi
的使用

使用 TrustManagerFactorySpi 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 TrustManagerFactorySpi 的使用

参数类型为 TrustManagerFactorySpi 的 javax.net.ssl 中的构造方法
TrustManagerFactory(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 TrustManagerFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.net.ssl.X509ExtendedKeyManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.X509ExtendedKeyManager
的使用

没有 javax.net.ssl.X509ExtendedKeyManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.net.ssl.X509KeyManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.X509KeyManager
的使用

使用 X509KeyManager 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 X509KeyManager 的使用

实现 X509KeyManager 的 javax.net.ssl 中的类
 class X509ExtendedKeyManager
提供 X509KeyManager 接口的扩展的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.net.ssl.X509TrustManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.X509TrustManager
的使用

没有 javax.net.ssl.X509TrustManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.print (Java 2 Platform SE 6)

 javax.print
接口
AttributeException
CancelablePrintJob
Doc
DocPrintJob
FlavorException
MultiDoc
MultiDocPrintJob
MultiDocPrintService
PrintService
URIException
类
DocFlavor
DocFlavor.BYTE_ARRAY
DocFlavor.CHAR_ARRAY
DocFlavor.INPUT_STREAM
DocFlavor.READER
DocFlavor.SERVICE_FORMATTED
DocFlavor.STRING
DocFlavor.URL
PrintServiceLookup
ServiceUI
ServiceUIFactory
SimpleDoc
StreamPrintService
StreamPrintServiceFactory
异常
PrintException


javax.print.attribute (Java 2 Platform SE 6)

 javax.print.attribute
接口
Attribute
AttributeSet
DocAttribute
DocAttributeSet
PrintJobAttribute
PrintJobAttributeSet
PrintRequestAttribute
PrintRequestAttributeSet
PrintServiceAttribute
PrintServiceAttributeSet
SupportedValuesAttribute
类
AttributeSetUtilities
DateTimeSyntax
EnumSyntax
HashAttributeSet
HashDocAttributeSet
HashPrintJobAttributeSet
HashPrintRequestAttributeSet
HashPrintServiceAttributeSet
IntegerSyntax
ResolutionSyntax
SetOfIntegerSyntax
Size2DSyntax
TextSyntax
URISyntax
异常
UnmodifiableSetException


接口 javax.print.attribute.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.Attribute
的使用

使用 Attribute 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print 中 Attribute 的使用

返回 Attribute 的 javax.print 中的方法
 Attribute[] AttributeException.getUnsupportedValues()
返回其 PrintService 实例支持该属性，但是不支持该属性特定值的打印属性数组，如果没有这种属性值，则返回 null。

参数类型为 Attribute 的 javax.print 中的方法
 boolean PrintService.isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定的打印属性值。

类型变量类型为 Attribute 的 javax.print 中的方法参数
Object | PrintService.getDefaultAttributeValue(Class<? extends Attribute> category) 确定给定类别中此 PrintService 的默认打印属性值。
Object | PrintService.getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
boolean | PrintService.isAttributeCategorySupported(Class<? extends Attribute> category) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定打印属性类别。

javax.print.attribute 中 Attribute 的使用

javax.print.attribute 中 Attribute 的子接口
interface | DocAttribute 接口 DocAttribute 是打印属性类实现的一个标记接口，用于指示属性表示文档 (doc) 的设置（“Doc”是一个简短的、容易发音的术语，指“打印数据的片段”。
interface | PrintJobAttribute PrintJobAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印作业”的状态或“打印作业”的一些其他特征。
interface | PrintRequestAttribute 接口 PrintRequestAttribute 是打印属性类实现的标记接口，以指示属性表示用于打印作业的请求设置。
interface | PrintServiceAttribute 接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。
interface | SupportedValuesAttribute 接口 SupportedValuesAttribute 是打印属性类实现的标记接口，以指示该属性描述用于其他属性的支持值。

返回 Attribute 的 javax.print.attribute 中的方法
Attribute | AttributeSet.get(Class<?> category) 返回此属性集在给定的属性类别中包含的属性值。
Attribute | HashAttributeSet.get(Class<?> category) 返回此属性集在给定的属性类别中包含的属性值。
Attribute[] | AttributeSet.toArray() 返回此集合中包含的属性的数组。
Attribute[] | HashAttributeSet.toArray()
static Attribute | AttributeSetUtilities.verifyAttributeValue(Object object, Class<?> interfaceName) 验证给定的对象是否为给定接口（假定为接口 Attribute 或其子接口）的一个实例。

返回变量类型为 Attribute 的类型的 javax.print.attribute 中的方法
 Class<? extends Attribute> Attribute.getCategory()
将此打印属性值添加到属性集时，为它获取用作“类别”的打印属性类。

参数类型为 Attribute 的 javax.print.attribute 中的方法
boolean | AttributeSet.add(Attribute attribute) 如果指定的属性尚不存在，则将它添加到此属性集中，首先要移除与指定属性值相同的属性类别中的任何现有值。
boolean | DocAttributeSet.add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | HashAttributeSet.add(Attribute attribute) 如果指定的属性不存在，则将它添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有属性。
boolean | PrintJobAttributeSet.add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | PrintRequestAttributeSet.add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | PrintServiceAttributeSet.add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | AttributeSet.containsValue(Attribute attribute) 如果此属性集包含给定的属性值，则返回 true。
boolean | HashAttributeSet.containsValue(Attribute attribute) 如果此属性集包含给定的属性，则返回 true。
boolean | AttributeSet.remove(Attribute attribute) 从此属性集移除指定的属性（如果存在）。
boolean | HashAttributeSet.remove(Attribute attribute) 从此属性集移除指定的属性（如果存在）。
static void | AttributeSetUtilities.verifyCategoryForValue(Class<?> category, Attribute attribute) 验证给定的属性类别对象是否等于给定属性值对象的类别。

参数类型为 Attribute 的 javax.print.attribute 中的构造方法
HashAttributeSet(Attribute attribute)
构造一个最初使用给定属性填充的新属性集。
HashAttributeSet(Attribute[] attributes)
构造一个最初使用给定数组中的值填充的新属性集。
HashAttributeSet(Attribute[] attributes, Class<?> interfaceName)
构造一个新的属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(Attribute attribute, Class<?> interfaceName)
构造一个最初使用给定属性填充的新属性集，其中该属性集的成员限于给定的接口。

javax.print.attribute.standard 中 Attribute 的使用

返回变量类型为 Attribute 的类型的 javax.print.attribute.standard 中的方法
Class<? extends Attribute> | Chromaticity.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | ColorSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Compression.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Copies.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | CopiesSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtCompleted.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtCreation.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtProcessing.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Destination.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DocumentName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Fidelity.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Finishings.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobHoldUntil.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressions.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressionsCompleted.getCategory() 获取被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressionsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctetsProcessed.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctetsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheetsCompleted.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheetsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMessageFromOperator.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobOriginatingUserName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobPriority.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobPrioritySupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobSheets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobState.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobStateReason.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobStateReasons.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Media.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MediaPrintableArea.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MediaSize.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MultipleDocumentHandling.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberOfDocuments.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberOfInterveningJobs.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberUp.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberUpSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | OrientationRequested.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | OutputDeviceAssigned.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PDLOverrideSupported.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PageRanges.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PagesPerMinute.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PagesPerMinuteColor.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PresentationDirection.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrintQuality.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterInfo.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterIsAcceptingJobs.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterLocation.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMakeAndModel.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMessageFromOperator.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMoreInfo.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMoreInfoManufacturer.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterName.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterResolution.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterState.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterStateReason.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterStateReasons.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterURI.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | QueuedJobCount.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | ReferenceUriSchemesSupported.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | RequestingUserName.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Severity.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | SheetCollate.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Sides.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.attribute.AttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.AttributeSet
的使用

使用 AttributeSet 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

javax.print 中 AttributeSet 的使用

返回 AttributeSet 的 javax.print 中的方法
 AttributeSet PrintService.getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes)
标识在特定 DocFlavor 的上下文中打印请求不支持的属性。

参数类型为 AttributeSet 的 javax.print 中的方法
abstract MultiDocPrintService[] | PrintServiceLookup.getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 应用程序不直接调用它。
abstract PrintService[] | PrintServiceLookup.getPrintServices(DocFlavor flavor, AttributeSet attributes) 查找肯定可支持指定属性和 DocFlavor 组合的服务。
Object | PrintService.getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
AttributeSet | PrintService.getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes) 标识在特定 DocFlavor 的上下文中打印请求不支持的属性。
boolean | PrintService.isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定的打印属性值。
static MultiDocPrintService[] | PrintServiceLookup.lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 查找能够打印 MultiDoc（包含所有指定的 doc flavor）的 MultiDoc PrintService。
static PrintService[] | PrintServiceLookup.lookupPrintServices(DocFlavor flavor, AttributeSet attributes) 查找能够打印指定 DocFlavor 的 PrintService。

javax.print.attribute 中 AttributeSet 的使用

javax.print.attribute 中 AttributeSet 的子接口
interface | DocAttributeSet 接口 DocAttributeSet 指定文档属性（即：实现接口 DocAttribute 的打印属性）集的接口。
interface | PrintJobAttributeSet 接口 PrintJobAttributeSet 为打印作业属性（即：实现接口 PrintJobAttribute 的打印属性）集指定接口。
interface | PrintRequestAttributeSet 接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。
interface | PrintServiceAttributeSet 接口 PrintServiceAttributeSet 为打印作业属性（即：实现接口 PrintServiceAttribute 的打印属性）集指定接口。

实现 AttributeSet 的 javax.print.attribute 中的类
class | HashAttributeSet 类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。
class | HashDocAttributeSet 类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。
class | HashPrintJobAttributeSet 类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。
class | HashPrintRequestAttributeSet 类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。
class | HashPrintServiceAttributeSet 类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。

返回 AttributeSet 的 javax.print.attribute 中的方法
static AttributeSet | AttributeSetUtilities.synchronizedView(AttributeSet attributeSet) 创建给定属性集的同步视图。
static AttributeSet | AttributeSetUtilities.unmodifiableView(AttributeSet attributeSet) 创建给定属性集的不可修改的视图。

参数类型为 AttributeSet 的 javax.print.attribute 中的方法
boolean | AttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
boolean | DocAttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
boolean | HashAttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
boolean | PrintJobAttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
boolean | PrintRequestAttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
boolean | PrintServiceAttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
static AttributeSet | AttributeSetUtilities.synchronizedView(AttributeSet attributeSet) 创建给定属性集的同步视图。
static AttributeSet | AttributeSetUtilities.unmodifiableView(AttributeSet attributeSet) 创建给定属性集的不可修改的视图。

参数类型为 AttributeSet 的 javax.print.attribute 中的构造方法
HashAttributeSet(AttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集。
HashAttributeSet(AttributeSet attributes, Class<?> interfaceName)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于给定的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.AttributeSetUtilities 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.AttributeSetUtilities
的使用

没有 javax.print.attribute.AttributeSetUtilities 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.DateTimeSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.DateTimeSyntax
的使用

使用 DateTimeSyntax 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 DateTimeSyntax 的使用

javax.print.attribute.standard 中 DateTimeSyntax 的子类
class | DateTimeAtCompleted DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
class | DateTimeAtCreation DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
class | DateTimeAtProcessing DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
class | JobHoldUntil JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.attribute.DocAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.DocAttribute
的使用

使用 DocAttribute 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 DocAttribute 的使用

参数类型为 DocAttribute 的 javax.print.attribute 中的构造方法
HashDocAttributeSet(DocAttribute attribute)
构造一个最初使用给定值填充的新哈希文档属性集。
HashDocAttributeSet(DocAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新哈希文档属性集。

javax.print.attribute.standard 中 DocAttribute 的使用

实现 DocAttribute 的 javax.print.attribute.standard 中的类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | Compression Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
class | DocumentName DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaPrintableArea MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
class | PrinterResolution PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.attribute.DocAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.DocAttributeSet
的使用

使用 DocAttributeSet 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

javax.print 中 DocAttributeSet 的使用

返回 DocAttributeSet 的 javax.print 中的方法
DocAttributeSet | Doc.getAttributes() 获取此 doc 对象的打印属性集。
DocAttributeSet | SimpleDoc.getAttributes() 获得此 doc 对象的打印属性集。

参数类型为 DocAttributeSet 的 javax.print 中的构造方法
SimpleDoc(Object printData, DocFlavor flavor, DocAttributeSet attributes)
构造具有指定打印数据、doc flavor 和 doc 属性集的 SimpleDoc。

javax.print.attribute 中 DocAttributeSet 的使用

实现 DocAttributeSet 的 javax.print.attribute 中的类
 class HashDocAttributeSet
类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。

返回 DocAttributeSet 的 javax.print.attribute 中的方法
static DocAttributeSet | AttributeSetUtilities.synchronizedView(DocAttributeSet attributeSet) 创建一个给定文档属性集的同步视图。
static DocAttributeSet | AttributeSetUtilities.unmodifiableView(DocAttributeSet attributeSet) 创建一个给定文档属性集的不可修改的视图。

参数类型为 DocAttributeSet 的 javax.print.attribute 中的方法
static DocAttributeSet | AttributeSetUtilities.synchronizedView(DocAttributeSet attributeSet) 创建一个给定文档属性集的同步视图。
static DocAttributeSet | AttributeSetUtilities.unmodifiableView(DocAttributeSet attributeSet) 创建一个给定文档属性集的不可修改的视图。

参数类型为 DocAttributeSet 的 javax.print.attribute 中的构造方法
HashDocAttributeSet(DocAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 DocAttribute 接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.EnumSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.EnumSyntax
的使用

使用 EnumSyntax 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 EnumSyntax 的使用

返回 EnumSyntax 的 javax.print.attribute 中的方法
protected  EnumSyntax[] EnumSyntax.getEnumValueTable()
返回此枚举值的枚举类的枚举值表。

javax.print.attribute.standard 中 EnumSyntax 的使用

javax.print.attribute.standard 中 EnumSyntax 的子类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | ColorSupported ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
class | Compression Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
class | Fidelity Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | JobSheets JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
class | JobState JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
class | JobStateReason JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | MultipleDocumentHandling MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | PDLOverrideSupported PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
class | PresentationDirection PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
class | PrinterIsAcceptingJobs PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
class | PrinterState PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
class | PrinterStateReason PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | ReferenceUriSchemesSupported ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。
class | Severity Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

返回 EnumSyntax 的 javax.print.attribute.standard 中的方法
protected EnumSyntax[] | Chromaticity.getEnumValueTable() 返回 Chromaticity 类的枚举值表。
protected EnumSyntax[] | ColorSupported.getEnumValueTable() 返回 ColorSupported 类的枚举值表。
protected EnumSyntax[] | Compression.getEnumValueTable() 返回 Compression 类的枚举值表。
protected EnumSyntax[] | Fidelity.getEnumValueTable() 返回 Fidelity 类的枚举值表。
protected EnumSyntax[] | Finishings.getEnumValueTable() 返回 Finishings 类的枚举值表。
protected EnumSyntax[] | JobSheets.getEnumValueTable() 返回 class JobSheets 类的枚举值表。
protected EnumSyntax[] | JobState.getEnumValueTable() 返回 JobState 类的枚举值表。
protected EnumSyntax[] | JobStateReason.getEnumValueTable() 返回 JobStateReason 类的枚举值表。
protected EnumSyntax[] | MediaName.getEnumValueTable() 返回 MediaTray 类的枚举值表。
protected EnumSyntax[] | MediaSizeName.getEnumValueTable() 返回 MediaSizeName 类的枚举值表。
protected EnumSyntax[] | MediaTray.getEnumValueTable() 返回 MediaTray 类的枚举值表。
protected EnumSyntax[] | MultipleDocumentHandling.getEnumValueTable() 返回 MultipleDocumentHandling 类的枚举值表。
protected EnumSyntax[] | OrientationRequested.getEnumValueTable() 返回类 OrientationRequested 的枚举值表。
protected EnumSyntax[] | PDLOverrideSupported.getEnumValueTable() 返回类 PDLOverrideSupported 的枚举值表。
protected EnumSyntax[] | PresentationDirection.getEnumValueTable() 返回类 PresentationDirection 的枚举值表。
protected EnumSyntax[] | PrintQuality.getEnumValueTable() 返回类 PrintQuality 的枚举值表。
protected EnumSyntax[] | PrinterIsAcceptingJobs.getEnumValueTable() 返回类 PrinterIsAcceptingJobs 的枚举值表。
protected EnumSyntax[] | PrinterState.getEnumValueTable() 返回类 PrinterState 的枚举值表。
protected EnumSyntax[] | PrinterStateReason.getEnumValueTable() 返回类 PrinterStateReason 的枚举值表。
protected EnumSyntax[] | ReferenceUriSchemesSupported.getEnumValueTable() 返回类 ReferenceUriSchemesSupported 的枚举值表。
protected EnumSyntax[] | Severity.getEnumValueTable() 返回类 Severity 的枚举值表。
protected EnumSyntax[] | SheetCollate.getEnumValueTable() 返回类 SheetCollate 的枚举值表。
protected EnumSyntax[] | Sides.getEnumValueTable() 返回类 Sides 的枚举值表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.HashAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.HashAttributeSet
的使用

使用 HashAttributeSet 的软件包
javax.print.attribute 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

javax.print.attribute 中 HashAttributeSet 的使用

javax.print.attribute 中 HashAttributeSet 的子类
class | HashDocAttributeSet 类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。
class | HashPrintJobAttributeSet 类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。
class | HashPrintRequestAttributeSet 类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。
class | HashPrintServiceAttributeSet 类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.HashDocAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.HashDocAttributeSet
的使用

没有 javax.print.attribute.HashDocAttributeSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.HashPrintJobAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.HashPrintJobAttributeSet
的使用

没有 javax.print.attribute.HashPrintJobAttributeSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.HashPrintRequestAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.HashPrintRequestAttributeSet
的使用

没有 javax.print.attribute.HashPrintRequestAttributeSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.HashPrintServiceAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.HashPrintServiceAttributeSet
的使用

没有 javax.print.attribute.HashPrintServiceAttributeSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.IntegerSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.IntegerSyntax
的使用

使用 IntegerSyntax 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 IntegerSyntax 的使用

参数类型为 IntegerSyntax 的 javax.print.attribute 中的方法
 boolean SetOfIntegerSyntax.contains(IntegerSyntax attribute)
确定此整数集属性是否包含给定的整数属性的值。

javax.print.attribute.standard 中 IntegerSyntax 的使用

javax.print.attribute.standard 中 IntegerSyntax 的子类
class | Copies Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
class | JobImpressions JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
class | JobImpressionsCompleted JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
class | JobKOctets JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
class | JobKOctetsProcessed JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
class | JobMediaSheets JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
class | JobMediaSheetsCompleted JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
class | JobPriority JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
class | JobPrioritySupported JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
class | NumberOfDocuments NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
class | NumberOfInterveningJobs NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | PagesPerMinute PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PagesPerMinuteColor PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
class | QueuedJobCount QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.attribute.PrintJobAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintJobAttribute
的使用

使用 PrintJobAttribute 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 PrintJobAttribute 的使用

参数类型为 PrintJobAttribute 的 javax.print.attribute 中的构造方法
HashPrintJobAttributeSet(PrintJobAttribute attribute)
构造一个最初使用给定值填充的新哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新哈希打印作业属性集。

javax.print.attribute.standard 中 PrintJobAttribute 的使用

实现 PrintJobAttribute 的 javax.print.attribute.standard 中的类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | Copies Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
class | DateTimeAtCompleted DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
class | DateTimeAtCreation DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
class | DateTimeAtProcessing DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
class | Destination Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
class | Fidelity Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | JobHoldUntil JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
class | JobImpressions JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
class | JobImpressionsCompleted JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
class | JobKOctets JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
class | JobKOctetsProcessed JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
class | JobMediaSheets JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
class | JobMediaSheetsCompleted JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
class | JobMessageFromOperator JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
class | JobName JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
class | JobOriginatingUserName JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
class | JobPriority JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
class | JobSheets JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
class | JobState JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
class | JobStateReasons JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaPrintableArea MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | MultipleDocumentHandling MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
class | NumberOfDocuments NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
class | NumberOfInterveningJobs NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | OutputDeviceAssigned OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
class | PresentationDirection PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
class | PrinterResolution PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.attribute.PrintJobAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintJobAttributeSet
的使用

使用 PrintJobAttributeSet 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。

javax.print 中 PrintJobAttributeSet 的使用

返回 PrintJobAttributeSet 的 javax.print 中的方法
 PrintJobAttributeSet DocPrintJob.getAttributes()
获取此 PrintJob 的打印属性集。

参数类型为 PrintJobAttributeSet 的 javax.print 中的方法
 void DocPrintJob.addPrintJobAttributeListener(PrintJobAttributeListener listener, PrintJobAttributeSet attributes)
为指定属性中的更改注册一个侦听器。

javax.print.attribute 中 PrintJobAttributeSet 的使用

实现 PrintJobAttributeSet 的 javax.print.attribute 中的类
 class HashPrintJobAttributeSet
类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。

返回 PrintJobAttributeSet 的 javax.print.attribute 中的方法
static PrintJobAttributeSet | AttributeSetUtilities.synchronizedView(PrintJobAttributeSet attributeSet) 创建一个给定打印作业属性集的同步视图。
static PrintJobAttributeSet | AttributeSetUtilities.unmodifiableView(PrintJobAttributeSet attributeSet) 创建一个给定打印作业属性集的不可修改的视图。

参数类型为 PrintJobAttributeSet 的 javax.print.attribute 中的方法
static PrintJobAttributeSet | AttributeSetUtilities.synchronizedView(PrintJobAttributeSet attributeSet) 创建一个给定打印作业属性集的同步视图。
static PrintJobAttributeSet | AttributeSetUtilities.unmodifiableView(PrintJobAttributeSet attributeSet) 创建一个给定打印作业属性集的不可修改的视图。

参数类型为 PrintJobAttributeSet 的 javax.print.attribute 中的构造方法
HashPrintJobAttributeSet(PrintJobAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintJobAttribute 接口。

javax.print.event 中 PrintJobAttributeSet 的使用

返回 PrintJobAttributeSet 的 javax.print.event 中的方法
 PrintJobAttributeSet PrintJobAttributeEvent.getAttributes()
确定已经更改的打印属性及其新值。

参数类型为 PrintJobAttributeSet 的 javax.print.event 中的构造方法
PrintJobAttributeEvent(DocPrintJob source, PrintJobAttributeSet attributes)
构造一个 PrintJobAttributeEvent 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.attribute.PrintRequestAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintRequestAttribute
的使用

使用 PrintRequestAttribute 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 PrintRequestAttribute 的使用

参数类型为 PrintRequestAttribute 的 javax.print.attribute 中的构造方法
HashPrintRequestAttributeSet(PrintRequestAttribute attribute)
构造一个最初使用给定值填充的新打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新打印请求属性集。

javax.print.attribute.standard 中 PrintRequestAttribute 的使用

实现 PrintRequestAttribute 的 javax.print.attribute.standard 中的类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | Copies Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
class | Destination Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
class | Fidelity Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | JobHoldUntil JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
class | JobImpressions JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
class | JobKOctets JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
class | JobMediaSheets JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
class | JobName JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
class | JobPriority JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
class | JobSheets JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaPrintableArea MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | MultipleDocumentHandling MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
class | PresentationDirection PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
class | PrinterResolution PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | RequestingUserName RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.attribute.PrintRequestAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintRequestAttributeSet
的使用

使用 PrintRequestAttributeSet 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 中 PrintRequestAttributeSet 的使用

参数类型为 PrintRequestAttributeSet 的 java.awt.print 中的方法
 PageFormat PrinterJob.getPageFormat(PrintRequestAttributeSet attributes)
使用与受此作业 PrintService 支持的那些值一致的值（即由 getPrintService() 返回的值），以及 attributes 中包含的介质、可打印区域和方向计算 PageFormat。
 PageFormat PrinterJob.pageDialog(PrintRequestAttributeSet attributes)
显示跨平台页面设置对话框的便捷方法。
 void PrinterJob.print(PrintRequestAttributeSet attributes)
使用属性集中的设置打印一组页面。
 boolean PrinterJob.printDialog(PrintRequestAttributeSet attributes)
为所有服务显示跨平台打印对话框的便捷方法，这些服务能够使用 Pageable 接口打印 2D 图形。

javax.print 中 PrintRequestAttributeSet 的使用

参数类型为 PrintRequestAttributeSet 的 javax.print 中的方法
void | DocPrintJob.print(Doc doc, PrintRequestAttributeSet attributes) 使用指定的作业属性打印文档。
void | MultiDocPrintJob.print(MultiDoc multiDoc, PrintRequestAttributeSet attributes) 使用指定的作业属性打印 MultiDoc。
static PrintService | ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes) 为用户提供一个选择 PrintService（打印机）的对话框。

javax.print.attribute 中 PrintRequestAttributeSet 的使用

实现 PrintRequestAttributeSet 的 javax.print.attribute 中的类
 class HashPrintRequestAttributeSet
类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。

返回 PrintRequestAttributeSet 的 javax.print.attribute 中的方法
static PrintRequestAttributeSet | AttributeSetUtilities.synchronizedView(PrintRequestAttributeSet attributeSet) 创建一个给定打印请求属性集的同步视图。
static PrintRequestAttributeSet | AttributeSetUtilities.unmodifiableView(PrintRequestAttributeSet attributeSet) 创建一个给定打印请求属性集的不可修改的视图。

参数类型为 PrintRequestAttributeSet 的 javax.print.attribute 中的方法
static PrintRequestAttributeSet | AttributeSetUtilities.synchronizedView(PrintRequestAttributeSet attributeSet) 创建一个给定打印请求属性集的同步视图。
static PrintRequestAttributeSet | AttributeSetUtilities.unmodifiableView(PrintRequestAttributeSet attributeSet) 创建一个给定打印请求属性集的不可修改的视图。

参数类型为 PrintRequestAttributeSet 的 javax.print.attribute 中的构造方法
HashPrintRequestAttributeSet(PrintRequestAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 (PrintRequestAttributeSe 接口。

javax.swing 中 PrintRequestAttributeSet 的使用

参数类型为 PrintRequestAttributeSet 的 javax.swing 中的方法
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。

javax.swing.text 中 PrintRequestAttributeSet 的使用

参数类型为 PrintRequestAttributeSet 的 javax.swing.text 中的方法
 boolean JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive)
打印此 JTextComponent 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.attribute.PrintServiceAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintServiceAttribute
的使用

使用 PrintServiceAttribute 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print 中 PrintServiceAttribute 的使用

类型参数类型为 PrintServiceAttribute 的 javax.print 中的方法
<T extends PrintServiceAttribute>
T
PrintService.getAttribute(Class<T> category)
获取单个指定服务属性的值。

javax.print.attribute 中 PrintServiceAttribute 的使用

参数类型为 PrintServiceAttribute 的 javax.print.attribute 中的构造方法
HashPrintServiceAttributeSet(PrintServiceAttribute attribute)
构造一个最初使用给定值填充的新哈希打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新打印服务属性集。

javax.print.attribute.standard 中 PrintServiceAttribute 的使用

实现 PrintServiceAttribute 的 javax.print.attribute.standard 中的类
class | ColorSupported ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
class | PagesPerMinute PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PagesPerMinuteColor PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PDLOverrideSupported PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
class | PrinterInfo PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
class | PrinterIsAcceptingJobs PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
class | PrinterLocation PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
class | PrinterMakeAndModel PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
class | PrinterMessageFromOperator PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
class | PrinterMoreInfo PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
class | PrinterMoreInfoManufacturer PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
class | PrinterName PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
class | PrinterState PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
class | PrinterStateReasons PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrinterURI PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。
class | QueuedJobCount QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.attribute.PrintServiceAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintServiceAttributeSet
的使用

使用 PrintServiceAttributeSet 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。

javax.print 中 PrintServiceAttributeSet 的使用

返回 PrintServiceAttributeSet 的 javax.print 中的方法
 PrintServiceAttributeSet PrintService.getAttributes()
获得此 PrintService 的打印机描述属性集，这些属性给出了此 PrintService 的状态。

javax.print.attribute 中 PrintServiceAttributeSet 的使用

实现 PrintServiceAttributeSet 的 javax.print.attribute 中的类
 class HashPrintServiceAttributeSet
类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。

返回 PrintServiceAttributeSet 的 javax.print.attribute 中的方法
static PrintServiceAttributeSet | AttributeSetUtilities.synchronizedView(PrintServiceAttributeSet attributeSet) 创建一个给定打印服务属性集的同步视图。
static PrintServiceAttributeSet | AttributeSetUtilities.unmodifiableView(PrintServiceAttributeSet attributeSet) 创建一个给定打印服务属性集的不可修改的视图。

参数类型为 PrintServiceAttributeSet 的 javax.print.attribute 中的方法
static PrintServiceAttributeSet | AttributeSetUtilities.synchronizedView(PrintServiceAttributeSet attributeSet) 创建一个给定打印服务属性集的同步视图。
static PrintServiceAttributeSet | AttributeSetUtilities.unmodifiableView(PrintServiceAttributeSet attributeSet) 创建一个给定打印服务属性集的不可修改的视图。

参数类型为 PrintServiceAttributeSet 的 javax.print.attribute 中的构造方法
HashPrintServiceAttributeSet(PrintServiceAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintServiceAttribute 接口。

javax.print.event 中 PrintServiceAttributeSet 的使用

返回 PrintServiceAttributeSet 的 javax.print.event 中的方法
 PrintServiceAttributeSet PrintServiceAttributeEvent.getAttributes()
确定已经更改的打印服务属性及其新值。

参数类型为 PrintServiceAttributeSet 的 javax.print.event 中的构造方法
PrintServiceAttributeEvent(PrintService source, PrintServiceAttributeSet attributes)
构造一个 PrintServiceAttributeEvent 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.ResolutionSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.ResolutionSyntax
的使用

使用 ResolutionSyntax 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 ResolutionSyntax 的使用

参数类型为 ResolutionSyntax 的 javax.print.attribute 中的方法
 boolean ResolutionSyntax.lessThanOrEquals(ResolutionSyntax other)
确定此分辨率属性的值是否小于或等于给定分辨率属性的值。

javax.print.attribute.standard 中 ResolutionSyntax 的使用

javax.print.attribute.standard 中 ResolutionSyntax 的子类
 class PrinterResolution
PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.SetOfIntegerSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.SetOfIntegerSyntax
的使用

使用 SetOfIntegerSyntax 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 SetOfIntegerSyntax 的使用

javax.print.attribute.standard 中 SetOfIntegerSyntax 的子类
class | CopiesSupported CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
class | JobImpressionsSupported JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
class | JobKOctetsSupported JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
class | JobMediaSheetsSupported Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
class | NumberUpSupported NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.Size2DSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.Size2DSyntax
的使用

使用 Size2DSyntax 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Size2DSyntax 的使用

javax.print.attribute.standard 中 Size2DSyntax 的子类
 class MediaSize
MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.attribute.SupportedValuesAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.SupportedValuesAttribute
的使用

使用 SupportedValuesAttribute 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 SupportedValuesAttribute 的使用

实现 SupportedValuesAttribute 的 javax.print.attribute.standard 中的类
class | CopiesSupported CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
class | JobImpressionsSupported JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
class | JobKOctetsSupported JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
class | JobMediaSheetsSupported Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
class | JobPrioritySupported JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
class | NumberUpSupported NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.TextSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.TextSyntax
的使用

使用 TextSyntax 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 TextSyntax 的使用

javax.print.attribute.standard 中 TextSyntax 的子类
class | DocumentName DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
class | JobMessageFromOperator JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
class | JobName JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
class | JobOriginatingUserName JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
class | OutputDeviceAssigned OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
class | PrinterInfo PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
class | PrinterLocation PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
class | PrinterMakeAndModel PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
class | PrinterMessageFromOperator PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
class | PrinterName PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
class | RequestingUserName RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.UnmodifiableSetException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.UnmodifiableSetException
的使用

没有 javax.print.attribute.UnmodifiableSetException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.URISyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.URISyntax
的使用

使用 URISyntax 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 URISyntax 的使用

javax.print.attribute.standard 中 URISyntax 的子类
class | Destination Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
class | PrinterMoreInfo PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
class | PrinterMoreInfoManufacturer PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
class | PrinterURI PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.print.attribute.standard (Java 2 Platform SE 6)

 javax.print.attribute.standard
类
Chromaticity
ColorSupported
Compression
Copies
CopiesSupported
DateTimeAtCompleted
DateTimeAtCreation
DateTimeAtProcessing
Destination
DocumentName
Fidelity
Finishings
JobHoldUntil
JobImpressions
JobImpressionsCompleted
JobImpressionsSupported
JobKOctets
JobKOctetsProcessed
JobKOctetsSupported
JobMediaSheets
JobMediaSheetsCompleted
JobMediaSheetsSupported
JobMessageFromOperator
JobName
JobOriginatingUserName
JobPriority
JobPrioritySupported
JobSheets
JobState
JobStateReason
JobStateReasons
Media
MediaName
MediaPrintableArea
MediaSize
MediaSize.Engineering
MediaSize.ISO
MediaSize.JIS
MediaSize.NA
MediaSize.Other
MediaSizeName
MediaTray
MultipleDocumentHandling
NumberOfDocuments
NumberOfInterveningJobs
NumberUp
NumberUpSupported
OrientationRequested
OutputDeviceAssigned
PageRanges
PagesPerMinute
PagesPerMinuteColor
PDLOverrideSupported
PresentationDirection
PrinterInfo
PrinterIsAcceptingJobs
PrinterLocation
PrinterMakeAndModel
PrinterMessageFromOperator
PrinterMoreInfo
PrinterMoreInfoManufacturer
PrinterName
PrinterResolution
PrinterState
PrinterStateReason
PrinterStateReasons
PrinterURI
PrintQuality
QueuedJobCount
ReferenceUriSchemesSupported
RequestingUserName
Severity
SheetCollate
Sides


类 javax.print.attribute.standard.Chromaticity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Chromaticity
的使用

使用 Chromaticity 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Chromaticity 的使用

声明为 Chromaticity 的 javax.print.attribute.standard 中的字段
static Chromaticity | Chromaticity.COLOR 彩色打印。
static Chromaticity | Chromaticity.MONOCHROME 单色打印。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.ColorSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.ColorSupported
的使用

使用 ColorSupported 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 ColorSupported 的使用

声明为 ColorSupported 的 javax.print.attribute.standard 中的字段
static ColorSupported | ColorSupported.NOT_SUPPORTED 该打印机不能进行任何类型的彩色打印。
static ColorSupported | ColorSupported.SUPPORTED 该打印机能够进行某些类型的彩色打印，例如高亮颜色或全处理颜色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.Compression 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Compression
的使用

使用 Compression 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Compression 的使用

声明为 Compression 的 javax.print.attribute.standard 中的字段
static Compression | Compression.COMPRESS UNIX 压缩技术。
static Compression | Compression.DEFLATE ZIP 公共域 inflate/deflate 压缩技术。
static Compression | Compression.GZIP RFC 1952 中所描述的 GNU zip 压缩技术。
static Compression | Compression.NONE 不使用压缩。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.Copies 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Copies
的使用

没有 javax.print.attribute.standard.Copies 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.CopiesSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.CopiesSupported
的使用

没有 javax.print.attribute.standard.CopiesSupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.DateTimeAtCompleted 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.DateTimeAtCompleted
的使用

没有 javax.print.attribute.standard.DateTimeAtCompleted 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.DateTimeAtCreation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.DateTimeAtCreation
的使用

没有 javax.print.attribute.standard.DateTimeAtCreation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.DateTimeAtProcessing 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.DateTimeAtProcessing
的使用

没有 javax.print.attribute.standard.DateTimeAtProcessing 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.Destination 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Destination
的使用

没有 javax.print.attribute.standard.Destination 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.DocumentName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.DocumentName
的使用

没有 javax.print.attribute.standard.DocumentName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.Fidelity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Fidelity
的使用

使用 Fidelity 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Fidelity 的使用

声明为 Fidelity 的 javax.print.attribute.standard 中的字段
static Fidelity | Fidelity.FIDELITY_FALSE 打印机应对打印作业进行合理尝试，即使它不能完全按照指定的要求打印该作业。
static Fidelity | Fidelity.FIDELITY_TRUE 必须完全按照指定的要求打印作业，或者拒绝该作业。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.Finishings 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Finishings
的使用

使用 Finishings 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Finishings 的使用

声明为 Finishings 的 javax.print.attribute.standard 中的字段
static Finishings | Finishings.BIND 此值指示要将某个绑定应用于文档；绑定的类型和布局是由位置定义的。
static Finishings | Finishings.COVER 当需要为文档选择非打印（或预打印）封面时指定此值。
static Finishings | Finishings.EDGE_STITCH 将文档（或多个文档）与沿某个边的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.EDGE_STITCH_BOTTOM 将文档（或多个文档）与沿底边的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.EDGE_STITCH_LEFT 将文档（或多个文档）与沿左边的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.EDGE_STITCH_RIGHT 将文档（或多个文档）与沿右边的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.EDGE_STITCH_TOP 将文档（或多个文档）与沿顶边的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.NONE 不执行绑定。
static Finishings | Finishings.SADDLE_STITCH 将文档（或多个文档）与沿中折线的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.STAPLE 将文档（或多个文档）与一个或多个装订点进行绑定。
static Finishings | Finishings.STAPLE_BOTTOM_LEFT 将文档（或多个文档）与左下角中的一个或多个装订点绑定。
static Finishings | Finishings.STAPLE_BOTTOM_RIGHT 将文档或多个文档与右下角中的一个或多个装订点绑定。
static Finishings | Finishings.STAPLE_DUAL_BOTTOM 将文档（或多个文档）与沿底边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | Finishings.STAPLE_DUAL_LEFT 将文档（或多个文档）与沿左边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | Finishings.STAPLE_DUAL_RIGHT 将文档（或多个文档）与沿右边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | Finishings.STAPLE_DUAL_TOP 将文档（或多个文档）与沿顶边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | Finishings.STAPLE_TOP_LEFT 将文档（或多个文档）与左上角中的一个或多个装订点绑定。
static Finishings | Finishings.STAPLE_TOP_RIGHT 将文档或多个文档与右上角中的一个或多个装订点绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobHoldUntil 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobHoldUntil
的使用

没有 javax.print.attribute.standard.JobHoldUntil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobImpressions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobImpressions
的使用

没有 javax.print.attribute.standard.JobImpressions 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobImpressionsCompleted 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobImpressionsCompleted
的使用

没有 javax.print.attribute.standard.JobImpressionsCompleted 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobImpressionsSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobImpressionsSupported
的使用

没有 javax.print.attribute.standard.JobImpressionsSupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobKOctets 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobKOctets
的使用

没有 javax.print.attribute.standard.JobKOctets 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobKOctetsProcessed 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobKOctetsProcessed
的使用

没有 javax.print.attribute.standard.JobKOctetsProcessed 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobKOctetsSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobKOctetsSupported
的使用

没有 javax.print.attribute.standard.JobKOctetsSupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobMediaSheets 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobMediaSheets
的使用

没有 javax.print.attribute.standard.JobMediaSheets 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobMediaSheetsCompleted 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobMediaSheetsCompleted
的使用

没有 javax.print.attribute.standard.JobMediaSheetsCompleted 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobMediaSheetsSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobMediaSheetsSupported
的使用

没有 javax.print.attribute.standard.JobMediaSheetsSupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobMessageFromOperator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobMessageFromOperator
的使用

没有 javax.print.attribute.standard.JobMessageFromOperator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobName
的使用

没有 javax.print.attribute.standard.JobName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobOriginatingUserName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobOriginatingUserName
的使用

没有 javax.print.attribute.standard.JobOriginatingUserName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobPriority 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobPriority
的使用

没有 javax.print.attribute.standard.JobPriority 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobPrioritySupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobPrioritySupported
的使用

没有 javax.print.attribute.standard.JobPrioritySupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobSheets 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobSheets
的使用

使用 JobSheets 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 JobSheets 的使用

声明为 JobSheets 的 javax.print.attribute.standard 中的字段
static JobSheets | JobSheets.NONE 不打印作业页。
static JobSheets | JobSheets.STANDARD 打印一个或多个指定位置的标准作业页，例如，打印单张开始页，或者打印开始页和结束页。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobState 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobState
的使用

使用 JobState 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 JobState 的使用

声明为 JobState 的 javax.print.attribute.standard 中的字段
static JobState | JobState.ABORTED 作业已被系统中止（通常当作业处于 PROCESSING 或 PROCESSING_STOPPED 状态时），打印机已完成正在中止的作业，且所有作业状态属性已达到作业的最终值。
static JobState | JobState.CANCELED 作业已被人为操作取消，打印机已完成了正取消的作业，且所有作业状态属性已达到作业的最终值。
static JobState | JobState.COMPLETED 作业已成功完成，或以警告或错误结束，所有作业介质纸张已成功堆栈到适当的输出纸盒（或多个纸盒）中，且所有作业状态已达到作业的最终值。
static JobState | JobState.PENDING 作业为要开始处理的候选作业，但尚未开始处理。
static JobState | JobState.PENDING_HELD 由于某些原因，作业不是要处理的候选作业，但当这些原因不再存在时，作业将返回 PENDING 状态。
static JobState | JobState.PROCESSING 正在处理作业。
static JobState | JobState.PROCESSING_STOPPED 由于某些原因，正在处理时作业已停止，且当这些原因不再存在时，作业返回到 PROCESSING 状态。
static JobState | JobState.UNKNOWN 作业状态是未知的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobStateReason 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobStateReason
的使用

使用 JobStateReason 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 JobStateReason 的使用

声明为 JobStateReason 的 javax.print.attribute.standard 中的字段
static JobStateReason | JobStateReason.ABORTED_BY_SYSTEM 系统中止了作业。
static JobStateReason | JobStateReason.COMPRESSION_ERROR 系统中止了作业，因为打印机在解压缩文档数据中遇到错误。
static JobStateReason | JobStateReason.DOCUMENT_ACCESS_ERROR 打印机不能访问由引用传递的一个或多个文档（即打印数据表示形式对象为 URL）。
static JobStateReason | JobStateReason.DOCUMENT_FORMAT_ERROR 系统中止了作业，因为打印机在处理文档数据时遇到错误。
static JobStateReason | JobStateReason.JOB_CANCELED_AT_DEVICE 非标识本地用户取消了作业，即在设备控制台的用户取消了作业。
static JobStateReason | JobStateReason.JOB_CANCELED_BY_OPERATOR 操作员取消了作业，操作员即用户，其已被授权为具有操作员权限（无论是本地还是远程）。
static JobStateReason | JobStateReason.JOB_CANCELED_BY_USER 作业所有者取消了作业，作业所有者即用户，通过验证的该用户身份与创建 Print Job 的初始用户的值相同，或某位其他授权终端用户，例如作业所有者安全组成员。
static JobStateReason | JobStateReason.JOB_COMPLETED_SUCCESSFULLY 作业成功完成。
static JobStateReason | JobStateReason.JOB_COMPLETED_WITH_ERRORS 作业以错误结束（也可能是警告）。
static JobStateReason | JobStateReason.JOB_COMPLETED_WITH_WARNINGS 作业以警告结束。
static JobStateReason | JobStateReason.JOB_DATA_INSUFFICIENT 打印机已创建 Print Job，但打印机在可以将作业转为 PROCESSING 状态之前还需要额外的打印数据。
static JobStateReason | JobStateReason.JOB_HOLD_UNTIL_SPECIFIED 为作业的 JobHoldUntil 属性值指定一个将来的日期-时间。
static JobStateReason | JobStateReason.JOB_INCOMING 打印机已创建 Print Job，但打印机尚未完成访问或接收所有打印数据。
static JobStateReason | JobStateReason.JOB_INTERPRETING 作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据。
static JobStateReason | JobStateReason.JOB_OUTGOING 打印机正将作业传输到输出设备。
static JobStateReason | JobStateReason.JOB_PRINTING 输出设备为标记介质。
static JobStateReason | JobStateReason.JOB_QUEUED 打印机处于 PROCESSING 状态，更明确地讲，打印机已对文档数据排队。
static JobStateReason | JobStateReason.JOB_QUEUED_FOR_MARKER 打印机处于 PENDING_HELD、PENDING 或 PROCESSING 状态，更明确地讲，打印机已完成足够的文档处理，能够开始标记且作业正在等待标记。
static JobStateReason | JobStateReason.JOB_RESTARTABLE 此作业被保留，且当前可以重新开始。
static JobStateReason | JobStateReason.JOB_TRANSFORMING 作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据并生成另一个电子表示形式。
static JobStateReason | JobStateReason.PRINTER_STOPPED 打印机的 PrinterState 属性值为 STOPPED。
static JobStateReason | JobStateReason.PRINTER_STOPPED_PARTLY 打印机的 PrinterStateReasons 属性值包含 STOPPED_PARTLY 的 PrinterStateReason 值。
static JobStateReason | JobStateReason.PROCESSING_TO_STOP_POINT 请求者已取消作业，或打印机已中止作业，但打印机仍在执行该作业的某些操作，直到遇到指定的停止点，或已完成作业终止/清除操作。
static JobStateReason | JobStateReason.QUEUED_IN_DEVICE 作业已被转发到某个不能发送回状态的设备或打印系统。
static JobStateReason | JobStateReason.RESOURCES_ARE_NOT_READY 在候选作业的任何物理打印机上，至少有一个该作业所需的资源（例如介质、字体、资源对象等）未就绪。
static JobStateReason | JobStateReason.SERVICE_OFF_LINE 打印机离线，不接受作业。
static JobStateReason | JobStateReason.SUBMISSION_INTERRUPTED 由于某些不可预见的原因，作业未完成提交。
static JobStateReason | JobStateReason.UNSUPPORTED_COMPRESSION 系统取消了作业，这是因为打印机尝试解压缩文档数据时确定该压缩实际上不在打印机所支持的文档数据中。
static JobStateReason | JobStateReason.UNSUPPORTED_DOCUMENT_FORMAT 系统中止了作业，因为文档数据的文档格式（doc flavor）不在打印机所支持的格式中。

参数类型为 JobStateReason 的 javax.print.attribute.standard 中的方法
 boolean JobStateReasons.add(JobStateReason o)
将指定的元素添加到此作业状态原因属性（如果它尚未存在）。

类型变量类型为 JobStateReason 的 javax.print.attribute.standard 中的构造方法参数
JobStateReasons(Collection<JobStateReason> collection)
构造新的作业状态原因属性，它包含与给定集合相同的 JobStateReason 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.JobStateReasons 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobStateReasons
的使用

没有 javax.print.attribute.standard.JobStateReasons 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.Media 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Media
的使用

使用 Media 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Media 的使用

javax.print.attribute.standard 中 Media 的子类
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MediaName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaName
的使用

使用 MediaName 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 MediaName 的使用

声明为 MediaName 的 javax.print.attribute.standard 中的字段
static MediaName | MediaName.ISO_A4_TRANSPARENT A4 纸透明度。
static MediaName | MediaName.ISO_A4_WHITE 空白 A4 纸。
static MediaName | MediaName.NA_LETTER_TRANSPARENT 信纸透明度。
static MediaName | MediaName.NA_LETTER_WHITE 空白信纸。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MediaPrintableArea 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaPrintableArea
的使用

没有 javax.print.attribute.standard.MediaPrintableArea 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MediaSize 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize
的使用

使用 MediaSize 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 MediaSize 的使用

声明为 MediaSize 的 javax.print.attribute.standard 中的字段
static MediaSize | MediaSize.Engineering.A 指定 engineering A 尺寸，8.5 inch × 11 inch。
static MediaSize | MediaSize.ISO.A0 指定 ISO A0 尺寸，841 mm × 1189 mm。
static MediaSize | MediaSize.ISO.A1 指定 ISO A1 尺寸，594 mm × 841 mm。
static MediaSize | MediaSize.ISO.A10 指定 ISO A10 尺寸，26 mm × 37 mm。
static MediaSize | MediaSize.ISO.A2 指定 ISO A2 尺寸，420 mm × 594 mm。
static MediaSize | MediaSize.ISO.A3 指定 ISO A3 尺寸，297 mm × 420 mm。
static MediaSize | MediaSize.ISO.A4 指定 ISO A4 尺寸，210 × by 297 mm。
static MediaSize | MediaSize.ISO.A5 指定 ISO A5 尺寸，148 mm × 210 mm。
static MediaSize | MediaSize.ISO.A6 指定 ISO A6 尺寸，105 mm × 148 mm。
static MediaSize | MediaSize.ISO.A7 指定 ISO A7 尺寸，74 mm × 105 mm。
static MediaSize | MediaSize.ISO.A8 指定 ISO A8 尺寸，52 mm × 74 mm。
static MediaSize | MediaSize.ISO.A9 指定 ISO A9 尺寸，37 mm × 52 mm。
static MediaSize | MediaSize.Engineering.B 指定 engineering B 尺寸，11 inch × 17 inch。
static MediaSize | MediaSize.ISO.B0 指定 ISO B0 尺寸，1000 mm × 1414 mm。
static MediaSize | MediaSize.JIS.B0 指定 JIS B0 尺寸，1030 mm × 1456 mm。
static MediaSize | MediaSize.ISO.B1 指定 ISO B1 尺寸，707 mm × 1000 mm。
static MediaSize | MediaSize.JIS.B1 指定 JIS B1 尺寸，728 mm × 1030 mm。
static MediaSize | MediaSize.ISO.B10 指定 ISO B10 尺寸，31 mm × 44 mm。
static MediaSize | MediaSize.JIS.B10 指定 JIS B10 尺寸，32 mm × 45 mm。
static MediaSize | MediaSize.ISO.B2 指定 ISO B2 尺寸，500 mm × 707 mm。
static MediaSize | MediaSize.JIS.B2 指定 JIS B2 尺寸，515 mm × 728 mm。
static MediaSize | MediaSize.ISO.B3 指定 ISO B3 尺寸，353 mm × 500 mm。
static MediaSize | MediaSize.JIS.B3 指定 JIS B3 尺寸，364 mm × 515 mm。
static MediaSize | MediaSize.ISO.B4 指定 ISO B4 尺寸，250 mm × 353 mm。
static MediaSize | MediaSize.JIS.B4 指定 JIS B4 尺寸，257 mm × 364 mm。
static MediaSize | MediaSize.ISO.B5 指定 ISO B5 尺寸，176 mm × 250 mm。
static MediaSize | MediaSize.JIS.B5 指定 JIS B5 尺寸，182 mm × 257 mm。
static MediaSize | MediaSize.ISO.B6 指定 ISO B6 尺寸，125 mm × 176 mm。
static MediaSize | MediaSize.JIS.B6 指定 JIS B6 尺寸，128 mm × 182 mm。
static MediaSize | MediaSize.ISO.B7 指定 ISO B7 尺寸，88 mm × 125 mm。
static MediaSize | MediaSize.JIS.B7 指定 JIS B7 尺寸，91 mm × 128 mm。
static MediaSize | MediaSize.ISO.B8 指定 ISO B8 尺寸，62 mm × 88 mm。
static MediaSize | MediaSize.JIS.B8 指定 JIS B8 尺寸，64 mm × 91 mm。
static MediaSize | MediaSize.ISO.B9 指定 ISO B9 尺寸，44 mm × 62 mm。
static MediaSize | MediaSize.JIS.B9 指定 JIS B9 尺寸，45 mm × 64 mm。
static MediaSize | MediaSize.Engineering.C 指定 engineering C 尺寸，17 inch × 22 inch。
static MediaSize | MediaSize.ISO.C3 指定 ISO C3 尺寸，324 mm × 458 mm。
static MediaSize | MediaSize.ISO.C4 指定 ISO C4 尺寸，229 mm × 324 mm。
static MediaSize | MediaSize.ISO.C5 指定 ISO C5 尺寸，162 mm × 229 mm。
static MediaSize | MediaSize.ISO.C6 指定 ISO C6 尺寸，114 mm × 162 mm。
static MediaSize | MediaSize.JIS.CHOU_1 指定 JIS Chou ("long") #1 信封尺寸，142 mm × 332 mm。
static MediaSize | MediaSize.JIS.CHOU_2 指定 JIS Chou ("long") #2 信封尺寸，119 mm × 277 mm。
static MediaSize | MediaSize.JIS.CHOU_3 指定 JIS Chou ("long") #3 信封尺寸，120 mm by 235 mm。
static MediaSize | MediaSize.JIS.CHOU_30 指定 JIS Chou ("long") #30 信封尺寸，92 mm by 235 mm。
static MediaSize | MediaSize.JIS.CHOU_4 指定 JIS Chou ("long") #4 信封尺寸，90 mm × 205 mm。
static MediaSize | MediaSize.JIS.CHOU_40 指定 JIS Chou ("long") #40 信封尺寸，90 mm × 225 mm。
static MediaSize | MediaSize.Engineering.D 指定 engineering D 尺寸，22 inch × 34 inch。
static MediaSize | MediaSize.ISO.DESIGNATED_LONG 指定 ISO Designated Long 尺寸，110 mm × 220 mm。
static MediaSize | MediaSize.Engineering.E 指定 engineering E 尺寸，34 inch × 44 inch。
static MediaSize | MediaSize.Other.EXECUTIVE 指定 executive 尺寸，7.25 inch × 10.5 inch。
static MediaSize | MediaSize.Other.FOLIO 指定 folio 尺寸，8.5 inch × 13 inch。
static MediaSize | MediaSize.Other.INVOICE 指定 invoice 尺寸，5.5 inch × 8.5 inch。
static MediaSize | MediaSize.Other.ITALY_ENVELOPE 指定 Italy 信封尺寸，110 mm × 230 mm。
static MediaSize | MediaSize.Other.JAPANESE_DOUBLE_POSTCARD 指定 Japanese Double 明信片尺寸，148 mm × 200 mm。
static MediaSize | MediaSize.Other.JAPANESE_POSTCARD 指定 Japanese 明信片尺寸，100 mm × 148 mm。
static MediaSize | MediaSize.JIS.KAKU_0 指定 JIS Kaku ("square") #0 信封尺寸，287 mm × 382 mm。
static MediaSize | MediaSize.JIS.KAKU_1 指定 JIS Kaku ("square") #1 信封尺寸，270 mm × 382 mm。
static MediaSize | MediaSize.JIS.KAKU_2 指定 JIS Kaku ("square") #2 信封尺寸，240 mm × 332 mm。
static MediaSize | MediaSize.JIS.KAKU_20 指定 JIS Kaku ("square") #20 信封尺寸，229 mm × 324 mm。
static MediaSize | MediaSize.JIS.KAKU_3 指定 JIS Kaku ("square") #3 信封尺寸，216 mm × 277 mm。
static MediaSize | MediaSize.JIS.KAKU_4 指定 JIS Kaku ("square") #4 信封尺寸，197 mm × 267 mm。
static MediaSize | MediaSize.JIS.KAKU_5 指定 JIS Kaku ("square") #5 信封尺寸，190 mm by 240 mm。
static MediaSize | MediaSize.JIS.KAKU_6 指定 JIS Kaku ("square") #6 信封尺寸，162 mm × 229 mm。
static MediaSize | MediaSize.JIS.KAKU_7 指定 JIS Kaku ("square") #7 信封尺寸，142 mm × 205 mm。
static MediaSize | MediaSize.JIS.KAKU_8 指定 JIS Kaku ("square") #8 信封尺寸，119 mm × 197 mm。
static MediaSize | MediaSize.JIS.KAKU_A4 指定 JIS Kaku ("square") A4 信封尺寸，228 mm × 312 mm。
static MediaSize | MediaSize.Other.LEDGER 指定 ledger 尺寸，11 inch × 17 inch。
static MediaSize | MediaSize.NA.LEGAL 指定 North American 合法尺寸，8.5 inch × 14 inch。
static MediaSize | MediaSize.NA.LETTER 指定 North American 信纸尺寸，8.5 inch × 11 inch。
static MediaSize | MediaSize.Other.MONARCH_ENVELOPE 指定 Monarch 信封尺寸，3.87 inch × 7.5 inch。
static MediaSize | MediaSize.NA.NA_10x13_ENVELOPE 指定 North American 10 inch × 13 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_10x14_ENVELOPE 指定 North American 10 inch × 14 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_10X15_ENVELOPE 指定 North American 10 inch × 15 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_5X7 指定 North American 5 inch × 7 inch 纸。
static MediaSize | MediaSize.NA.NA_6X9_ENVELOPE 指定 North American 6 inch × 9 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_7X9_ENVELOPE 指定 North American 7 inch × 9 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_8X10 指定 North American 8 inch × 10 inch 纸。
static MediaSize | MediaSize.NA.NA_9x11_ENVELOPE 指定 North American 9 inch × 11 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_9x12_ENVELOPE 指定 North American 9 inch × 12 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_NUMBER_10_ENVELOPE 指定 North American Number 10 商用信封尺寸，4.125 inch × 9.5 inch。
static MediaSize | MediaSize.NA.NA_NUMBER_11_ENVELOPE 指定 North American Number 11 商用信封尺寸，4.5 inch × 10.375 inch。
static MediaSize | MediaSize.NA.NA_NUMBER_12_ENVELOPE 指定 North American Number 12 商用信封尺寸，4.75 inch × 11 inch。
static MediaSize | MediaSize.NA.NA_NUMBER_14_ENVELOPE 指定 North American Number 14 商用信封尺寸，5 inch × 11.5 inch。
static MediaSize | MediaSize.NA.NA_NUMBER_9_ENVELOPE 指定 North American Number 9 商用信封尺寸，3.875 inch × 8.875 inch。
static MediaSize | MediaSize.Other.PERSONAL_ENVELOPE 指定 Personal 信封尺寸，3.625 inch × 6.5 inch。
static MediaSize | MediaSize.Other.QUARTO 指定 quarto 尺寸，8.5 inch × 10.83 inch。
static MediaSize | MediaSize.Other.TABLOID 指定 tabloid 尺寸，11 inch × 17 inch。
static MediaSize | MediaSize.JIS.YOU_1 指定 JIS You ("Western") #1 信封尺寸，120 mm × 176 mm。
static MediaSize | MediaSize.JIS.YOU_2 指定 JIS You ("Western") #2 信封尺寸，114 mm × 162 mm。
static MediaSize | MediaSize.JIS.YOU_3 指定 JIS You ("Western") #3 信封尺寸，98 mm × 148 mm。
static MediaSize | MediaSize.JIS.YOU_4 指定 JIS You ("Western") #4 信封尺寸，105 mm × 235 mm。
static MediaSize | MediaSize.JIS.YOU_5 指定 JIS You ("Western") #5 信封尺寸，95 mm × 217 mm。
static MediaSize | MediaSize.JIS.YOU_6 指定 JIS You ("Western") #6 信封尺寸，98 mm × 190 mm。
static MediaSize | MediaSize.JIS.YOU_7 指定 JIS You ("Western") #7 信封尺寸，92 mm × 165 mm。

返回 MediaSize 的 javax.print.attribute.standard 中的方法
static MediaSize MediaSize.getMediaSizeForName(MediaSizeName media)
获取指定的命名介质的 MediaSize。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MediaSize.Engineering 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize.Engineering
的使用

没有 javax.print.attribute.standard.MediaSize.Engineering 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MediaSize.ISO 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize.ISO
的使用

没有 javax.print.attribute.standard.MediaSize.ISO 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MediaSize.JIS 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize.JIS
的使用

没有 javax.print.attribute.standard.MediaSize.JIS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MediaSize.NA 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize.NA
的使用

没有 javax.print.attribute.standard.MediaSize.NA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MediaSize.Other 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize.Other
的使用

没有 javax.print.attribute.standard.MediaSize.Other 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MediaSizeName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSizeName
的使用

使用 MediaSizeName 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 MediaSizeName 的使用

声明为 MediaSizeName 的 javax.print.attribute.standard 中的字段
static MediaSizeName | MediaSizeName.A A 尺寸。
static MediaSizeName | MediaSizeName.B B 尺寸。
static MediaSizeName | MediaSizeName.C C 尺寸。
static MediaSizeName | MediaSizeName.D D 尺寸。
static MediaSizeName | MediaSizeName.E E 尺寸。
static MediaSizeName | MediaSizeName.EXECUTIVE executive 尺寸。
static MediaSizeName | MediaSizeName.FOLIO folio 尺寸。
static MediaSizeName | MediaSizeName.INVOICE invoice 尺寸。
static MediaSizeName | MediaSizeName.ISO_A0 A0 尺寸。
static MediaSizeName | MediaSizeName.ISO_A1 A1 尺寸。
static MediaSizeName | MediaSizeName.ISO_A10 A10 尺寸。
static MediaSizeName | MediaSizeName.ISO_A2 A2 尺寸。
static MediaSizeName | MediaSizeName.ISO_A3 A3 尺寸。
static MediaSizeName | MediaSizeName.ISO_A4 A4 尺寸。
static MediaSizeName | MediaSizeName.ISO_A5 A5 尺寸。
static MediaSizeName | MediaSizeName.ISO_A6 A6 尺寸。
static MediaSizeName | MediaSizeName.ISO_A7 A7 尺寸。
static MediaSizeName | MediaSizeName.ISO_A8 A8 尺寸。
static MediaSizeName | MediaSizeName.ISO_A9 A9 尺寸。
static MediaSizeName | MediaSizeName.ISO_B0 ISO B0 尺寸。
static MediaSizeName | MediaSizeName.ISO_B1 ISO B1 尺寸。
static MediaSizeName | MediaSizeName.ISO_B10 ISO B10 尺寸。
static MediaSizeName | MediaSizeName.ISO_B2 ISO B2 尺寸。
static MediaSizeName | MediaSizeName.ISO_B3 ISO B3 尺寸。
static MediaSizeName | MediaSizeName.ISO_B4 ISO B4 尺寸。
static MediaSizeName | MediaSizeName.ISO_B5 ISO B5 尺寸。
static MediaSizeName | MediaSizeName.ISO_B6 ISO B6 尺寸。
static MediaSizeName | MediaSizeName.ISO_B7 ISO B7 尺寸。
static MediaSizeName | MediaSizeName.ISO_B8 ISO B8 尺寸。
static MediaSizeName | MediaSizeName.ISO_B9 ISO B9 尺寸。
static MediaSizeName | MediaSizeName.ISO_C0 ISO C0 尺寸。
static MediaSizeName | MediaSizeName.ISO_C1 ISO C1 尺寸。
static MediaSizeName | MediaSizeName.ISO_C2 ISO C2 尺寸。
static MediaSizeName | MediaSizeName.ISO_C3 ISO C3 尺寸。
static MediaSizeName | MediaSizeName.ISO_C4 ISO C4 尺寸。
static MediaSizeName | MediaSizeName.ISO_C5 ISO C5 尺寸。
static MediaSizeName | MediaSizeName.ISO_C6 信纸尺寸。
static MediaSizeName | MediaSizeName.ISO_DESIGNATED_LONG ISO designated long 尺寸。
static MediaSizeName | MediaSizeName.ITALY_ENVELOPE Italy 信封尺寸。
static MediaSizeName | MediaSizeName.JAPANESE_DOUBLE_POSTCARD Japanese Double Postcard 尺寸。
static MediaSizeName | MediaSizeName.JAPANESE_POSTCARD Japanese Postcard 尺寸。
static MediaSizeName | MediaSizeName.JIS_B0 JIS B0 尺寸。
static MediaSizeName | MediaSizeName.JIS_B1 JIS B1 尺寸。
static MediaSizeName | MediaSizeName.JIS_B10 JIS B10 尺寸。
static MediaSizeName | MediaSizeName.JIS_B2 JIS B2 尺寸。
static MediaSizeName | MediaSizeName.JIS_B3 JIS B3 尺寸。
static MediaSizeName | MediaSizeName.JIS_B4 JIS B4 尺寸。
static MediaSizeName | MediaSizeName.JIS_B5 JIS B5 尺寸。
static MediaSizeName | MediaSizeName.JIS_B6 JIS B6 尺寸。
static MediaSizeName | MediaSizeName.JIS_B7 JIS B7 尺寸。
static MediaSizeName | MediaSizeName.JIS_B8 JIS B8 尺寸。
static MediaSizeName | MediaSizeName.JIS_B9 JIS B9 尺寸。
static MediaSizeName | MediaSizeName.LEDGER ledger 尺寸。
static MediaSizeName | MediaSizeName.MONARCH_ENVELOPE monarch 信封尺寸。
static MediaSizeName | MediaSizeName.NA_10X13_ENVELOPE 10x13 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_10X14_ENVELOPE 10x14North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_10X15_ENVELOPE 10x15 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_5X7 5x7 North American 纸。
static MediaSizeName | MediaSizeName.NA_6X9_ENVELOPE 6x9 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_7X9_ENVELOPE 7x9 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_8X10 8x10 North American 纸。
static MediaSizeName | MediaSizeName.NA_9X11_ENVELOPE 9x11 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_9X12_ENVELOPE 9x12 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_LEGAL legal 尺寸。
static MediaSizeName | MediaSizeName.NA_LETTER 信纸尺寸。
static MediaSizeName | MediaSizeName.NA_NUMBER_10_ENVELOPE 10 号信封尺寸。
static MediaSizeName | MediaSizeName.NA_NUMBER_11_ENVELOPE 11 号信封尺寸。
static MediaSizeName | MediaSizeName.NA_NUMBER_12_ENVELOPE 12 号信封尺寸。
static MediaSizeName | MediaSizeName.NA_NUMBER_14_ENVELOPE 14 号信封尺寸。
static MediaSizeName | MediaSizeName.NA_NUMBER_9_ENVELOPE 9 号信封尺寸。
static MediaSizeName | MediaSizeName.PERSONAL_ENVELOPE 私人信封尺寸。
static MediaSizeName | MediaSizeName.QUARTO quarto 尺寸。
static MediaSizeName | MediaSizeName.TABLOID tabloid 尺寸。

返回 MediaSizeName 的 javax.print.attribute.standard 中的方法
static MediaSizeName | MediaSize.findMedia(float x, float y, int units) 指定的维度用于从所有标准 MediaSize 实例中定位一个匹配的 MediaSize 实例。
MediaSizeName | MediaSize.getMediaSizeName() 获取此尺寸的介质名称（如果有）。

参数类型为 MediaSizeName 的 javax.print.attribute.standard 中的方法
static MediaSize MediaSize.getMediaSizeForName(MediaSizeName media)
获取指定的命名介质的 MediaSize。

参数类型为 MediaSizeName 的 javax.print.attribute.standard 中的构造方法
MediaSize(float x, float y, int units, MediaSizeName media)
从给定浮点值构造新 MediaSize 属性。
MediaSize(int x, int y, int units, MediaSizeName media)
从给定整数值构造新 MediaSize 属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MediaTray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaTray
的使用

使用 MediaTray 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 MediaTray 的使用

声明为 MediaTray 的 javax.print.attribute.standard 中的字段
static MediaTray | MediaTray.BOTTOM 打印机中的底层进纸托盘。
static MediaTray | MediaTray.ENVELOPE 打印机中的信封进纸托盘。
static MediaTray | MediaTray.LARGE_CAPACITY 打印机中的大容量进纸托盘。
static MediaTray | MediaTray.MAIN 打印机中的主要进纸托盘。
static MediaTray | MediaTray.MANUAL 打印机中的手动进纸托盘。
static MediaTray | MediaTray.MIDDLE 打印机中的中层进纸托盘。
static MediaTray | MediaTray.SIDE 侧面进纸托盘。
static MediaTray | MediaTray.TOP 打印机中的顶层进纸托盘。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.MultipleDocumentHandling 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MultipleDocumentHandling
的使用

使用 MultipleDocumentHandling 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 MultipleDocumentHandling 的使用

声明为 MultipleDocumentHandling 的 javax.print.attribute.standard 中的字段
static MultipleDocumentHandling | MultipleDocumentHandling.SEPARATE_DOCUMENTS_COLLATED_COPIES 独立文档逐份打印副本 －－ 有关更多信息，请参见上文。
static MultipleDocumentHandling | MultipleDocumentHandling.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES 独立文档非逐份打印副本 －－ 有关更多信息，请参见上文。
static MultipleDocumentHandling | MultipleDocumentHandling.SINGLE_DOCUMENT 单个文档 －－ 有关更多信息，请参见上文。
static MultipleDocumentHandling | MultipleDocumentHandling.SINGLE_DOCUMENT_NEW_SHEET 单个文档新纸张 －－ 有关更多信息，请参见上文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.NumberOfDocuments 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.NumberOfDocuments
的使用

没有 javax.print.attribute.standard.NumberOfDocuments 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.NumberOfInterveningJobs 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.NumberOfInterveningJobs
的使用

没有 javax.print.attribute.standard.NumberOfInterveningJobs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.NumberUp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.NumberUp
的使用

没有 javax.print.attribute.standard.NumberUp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.NumberUpSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.NumberUpSupported
的使用

没有 javax.print.attribute.standard.NumberUpSupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.OrientationRequested 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.OrientationRequested
的使用

使用 OrientationRequested 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 OrientationRequested 的使用

声明为 OrientationRequested 的 javax.print.attribute.standard 中的字段
static OrientationRequested | OrientationRequested.LANDSCAPE 沿介质的长边描绘内容。
static OrientationRequested | OrientationRequested.PORTRAIT 沿介质的短边描绘内容。
static OrientationRequested | OrientationRequested.REVERSE_LANDSCAPE 沿介质的长边描绘内容，但方式正好与横向相反。
static OrientationRequested | OrientationRequested.REVERSE_PORTRAIT 沿介质的短边描绘内容，但方式正好与纵向相反。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.OutputDeviceAssigned 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.OutputDeviceAssigned
的使用

没有 javax.print.attribute.standard.OutputDeviceAssigned 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PageRanges 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PageRanges
的使用

没有 javax.print.attribute.standard.PageRanges 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PagesPerMinute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PagesPerMinute
的使用

没有 javax.print.attribute.standard.PagesPerMinute 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PagesPerMinuteColor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PagesPerMinuteColor
的使用

没有 javax.print.attribute.standard.PagesPerMinuteColor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PDLOverrideSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PDLOverrideSupported
的使用

使用 PDLOverrideSupported 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PDLOverrideSupported 的使用

声明为 PDLOverrideSupported 的 javax.print.attribute.standard 中的字段
static PDLOverrideSupported | PDLOverrideSupported.ATTEMPTED 打印机会尝试让外部作业属性值优先于嵌入到文档打印数据中的指令，但是不保证确实会如此。
static PDLOverrideSupported | PDLOverrideSupported.NOT_ATTEMPTED 打印机不会尝试让外部的作业属性值优先于嵌入到文档打印数据中的指令。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PresentationDirection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PresentationDirection
的使用

使用 PresentationDirection 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PresentationDirection 的使用

声明为 PresentationDirection 的 javax.print.attribute.standard 中的字段
static PresentationDirection | PresentationDirection.TOBOTTOM_TOLEFT 从右上开始，按列布置各页，然后向左下部展开。
static PresentationDirection | PresentationDirection.TOBOTTOM_TORIGHT 从左上开始，按列布置各页，然后向右下部展开。
static PresentationDirection | PresentationDirection.TOLEFT_TOBOTTOM 从右上部开始，按行布置各页，然后向左下部展开。
static PresentationDirection | PresentationDirection.TOLEFT_TOTOP 从右下部开始，按行布置各页，然后向左上部展开。
static PresentationDirection | PresentationDirection.TORIGHT_TOBOTTOM 从左上部开始，按行布置各页，然后向右下部展开。
static PresentationDirection | PresentationDirection.TORIGHT_TOTOP 从左下部开始，按行布置各页，然后向右上部展开。
static PresentationDirection | PresentationDirection.TOTOP_TOLEFT 从右下部开始，按列布置各页，然后向左上部展开。
static PresentationDirection | PresentationDirection.TOTOP_TORIGHT 从左下部开始，按列布置各页，然后向右上部展开。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterInfo
的使用

没有 javax.print.attribute.standard.PrinterInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterIsAcceptingJobs 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterIsAcceptingJobs
的使用

使用 PrinterIsAcceptingJobs 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PrinterIsAcceptingJobs 的使用

声明为 PrinterIsAcceptingJobs 的 javax.print.attribute.standard 中的字段
static PrinterIsAcceptingJobs | PrinterIsAcceptingJobs.ACCEPTING_JOBS 打印机当前接受作业。
static PrinterIsAcceptingJobs | PrinterIsAcceptingJobs.NOT_ACCEPTING_JOBS 打印机当前拒绝发送给它的任何作业。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterLocation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterLocation
的使用

没有 javax.print.attribute.standard.PrinterLocation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterMakeAndModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterMakeAndModel
的使用

没有 javax.print.attribute.standard.PrinterMakeAndModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterMessageFromOperator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterMessageFromOperator
的使用

没有 javax.print.attribute.standard.PrinterMessageFromOperator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterMoreInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterMoreInfo
的使用

没有 javax.print.attribute.standard.PrinterMoreInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterMoreInfoManufacturer
的使用

没有 javax.print.attribute.standard.PrinterMoreInfoManufacturer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterName
的使用

没有 javax.print.attribute.standard.PrinterName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterResolution 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterResolution
的使用

没有 javax.print.attribute.standard.PrinterResolution 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterState 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterState
的使用

使用 PrinterState 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PrinterState 的使用

声明为 PrinterState 的 javax.print.attribute.standard 中的字段
static PrinterState | PrinterState.IDLE 指示可以开始处理新作业，无需等待。
static PrinterState | PrinterState.PROCESSING 指示正在处理作业；处理完成前新作业需等待。
static PrinterState | PrinterState.STOPPED 指示没有作业可以处理，需要干预。
static PrinterState | PrinterState.UNKNOWN 打印机状态未知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterStateReason 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterStateReason
的使用

使用 PrinterStateReason 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PrinterStateReason 的使用

声明为 PrinterStateReason 的 javax.print.attribute.standard 中的字段
static PrinterStateReason | PrinterStateReason.CONNECTING_TO_DEVICE 打印机已经在输出设备中安排了作业，并且正在与共享的网络输出设备进行连接（并且可能在相当长的时间内无法实际开始打印作业，因为这取决于网络上其他服务器对该输出设备的使用情况）。
static PrinterStateReason | PrinterStateReason.COVER_OPEN 设备上的一个或多个机盖处于打开状态。
static PrinterStateReason | PrinterStateReason.DEVELOPER_EMPTY 设备显影剂已用完。
static PrinterStateReason | PrinterStateReason.DEVELOPER_LOW 设备显影剂不足。
static PrinterStateReason | PrinterStateReason.DOOR_OPEN 设备上的一个或多个门处于打开状态。
static PrinterStateReason | PrinterStateReason.FUSER_OVER_TEMP 热熔器温度高于正常值。
static PrinterStateReason | PrinterStateReason.FUSER_UNDER_TEMP 热熔器温度低于正常值。
static PrinterStateReason | PrinterStateReason.INPUT_TRAY_MISSING 设备中没有一个或多个输入纸盒。
static PrinterStateReason | PrinterStateReason.INTERLOCK_OPEN 打印机上的一个或多个连锁设备未锁定。
static PrinterStateReason | PrinterStateReason.INTERPRETER_RESOURCE_UNAVAILABLE 解释器资源（例如字体、格式）不可用。
static PrinterStateReason | PrinterStateReason.MARKER_SUPPLY_EMPTY 设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）已用完。
static PrinterStateReason | PrinterStateReason.MARKER_SUPPLY_LOW 设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）不足。
static PrinterStateReason | PrinterStateReason.MARKER_WASTE_ALMOST_FULL 设备指示器耗材废物容器几乎已填满。
static PrinterStateReason | PrinterStateReason.MARKER_WASTE_FULL 设备指示器耗材废物容器已填满。
static PrinterStateReason | PrinterStateReason.MEDIA_EMPTY 至少一个输入纸盒是空的。
static PrinterStateReason | PrinterStateReason.MEDIA_JAM 设备中卡住了介质。
static PrinterStateReason | PrinterStateReason.MEDIA_LOW 至少一个输入纸盒的介质不足。
static PrinterStateReason | PrinterStateReason.MEDIA_NEEDED 纸盒中没有介质。
static PrinterStateReason | PrinterStateReason.MOVING_TO_PAUSED 已经暂停了打印机，但设备要停下来还需要一些时间。
static PrinterStateReason | PrinterStateReason.OPC_LIFE_OVER 光敏导电体已不再运行。
static PrinterStateReason | PrinterStateReason.OPC_NEAR_EOL 光敏导电体寿命将到期。
static PrinterStateReason | PrinterStateReason.OTHER 打印机已经检测到了一个以下未列出的错误。
static PrinterStateReason | PrinterStateReason.OUTPUT_AREA_ALMOST_FULL 一个或多个输出区域几乎已经填满（例如纸盒、装订器、整理器）。
static PrinterStateReason | PrinterStateReason.OUTPUT_AREA_FULL 一个或多个输出区域已经填满（例如纸盒、装订器、整理器）。
static PrinterStateReason | PrinterStateReason.OUTPUT_TRAY_MISSING 设备中没有一个或多个输出纸盒。
static PrinterStateReason | PrinterStateReason.PAUSED 已经暂停了打印机并且打印机的 PrinterState 为 STOPPED。
static PrinterStateReason | PrinterStateReason.SHUTDOWN 已经从服务中移除了打印机，并且可以给该打印机断电或者物理移除它。
static PrinterStateReason | PrinterStateReason.SPOOL_AREA_FULL 已达到为后台打印分配的持久存储限制。
static PrinterStateReason | PrinterStateReason.STOPPED_PARTLY 当打印机控制多个输出设备时，此原因指示一个或多个设备被停止。
static PrinterStateReason | PrinterStateReason.STOPPING 打印机正在停止设备，并且打印机也将很快停下来。
static PrinterStateReason | PrinterStateReason.TIMED_OUT 服务器能够连接到输出设备（或始终处于连接状态），但却无法获得输出设备的响应。
static PrinterStateReason | PrinterStateReason.TONER_EMPTY 设备的碳粉用完。
static PrinterStateReason | PrinterStateReason.TONER_LOW 设备的碳粉不足。

返回变量类型为 PrinterStateReason 的类型的 javax.print.attribute.standard 中的方法
 Set<PrinterStateReason> PrinterStateReasons.printerStateReasonSet(Severity severity)
在此 PrinterStateReasons 中，获得在给定的严重性级别每个 PrinterStateReasons 属性的不可修改的视图集。

参数类型为 PrinterStateReason 的 javax.print.attribute.standard 中的方法
 Severity PrinterStateReasons.put(PrinterStateReason reason, Severity severity)
根据给定的严重性级别，将给定的打印机状态原因添加到此 PrinterStateReasons 属性中。

类型变量类型为 PrinterStateReason 的 javax.print.attribute.standard 中的构造方法参数
PrinterStateReasons(Map<PrinterStateReason,Severity> map)
构造一个新的 PrinterStateReasons 属性，它包括与给定映射相同的 PrinterStateReason 到 Severity 映射关系。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterStateReasons 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterStateReasons
的使用

没有 javax.print.attribute.standard.PrinterStateReasons 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrinterURI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterURI
的使用

没有 javax.print.attribute.standard.PrinterURI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.PrintQuality 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrintQuality
的使用

使用 PrintQuality 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PrintQuality 的使用

声明为 PrintQuality 的 javax.print.attribute.standard 中的字段
static PrintQuality | PrintQuality.DRAFT 打印机可提供的最低打印质量。
static PrintQuality | PrintQuality.HIGH 打印机可提供的最高打印质量。
static PrintQuality | PrintQuality.NORMAL 打印机上的正常或中等质量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.QueuedJobCount 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.QueuedJobCount
的使用

没有 javax.print.attribute.standard.QueuedJobCount 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.ReferenceUriSchemesSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.ReferenceUriSchemesSupported
的使用

使用 ReferenceUriSchemesSupported 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 ReferenceUriSchemesSupported 的使用

声明为 ReferenceUriSchemesSupported 的 javax.print.attribute.standard 中的字段
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.FILE 特定于主机的文件名称。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.FTP 文件传输协议 (FTP)。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.GOPHER Gopher 协议。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.HTTP 超文本传输协议 (HTTP)。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.HTTPS 安全超文本传输协议 (HTTPS)。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.NEWS USENET 新闻。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.NNTP 使用网络新闻传输协议 (NNTP) 的 USENET 新闻。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.WAIS 广域信息服务器 (WAIS) 协议。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.RequestingUserName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.RequestingUserName
的使用

没有 javax.print.attribute.standard.RequestingUserName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.Severity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Severity
的使用

使用 Severity 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Severity 的使用

声明为 Severity 的 javax.print.attribute.standard 中的字段
static Severity | Severity.ERROR 指示 PrinterStateReason 是 "error"（最严重）。
static Severity | Severity.REPORT 指示 PrinterStateReason 是 "report"（不太严重）。
static Severity | Severity.WARNING 指示 PrinterStateReason 是 "warning"。

返回 Severity 的 javax.print.attribute.standard 中的方法
 Severity PrinterStateReasons.put(PrinterStateReason reason, Severity severity)
根据给定的严重性级别，将给定的打印机状态原因添加到此 PrinterStateReasons 属性中。

参数类型为 Severity 的 javax.print.attribute.standard 中的方法
Set<PrinterStateReason> | PrinterStateReasons.printerStateReasonSet(Severity severity) 在此 PrinterStateReasons 中，获得在给定的严重性级别每个 PrinterStateReasons 属性的不可修改的视图集。
Severity | PrinterStateReasons.put(PrinterStateReason reason, Severity severity) 根据给定的严重性级别，将给定的打印机状态原因添加到此 PrinterStateReasons 属性中。

类型变量类型为 Severity 的 javax.print.attribute.standard 中的构造方法参数
PrinterStateReasons(Map<PrinterStateReason,Severity> map)
构造一个新的 PrinterStateReasons 属性，它包括与给定映射相同的 PrinterStateReason 到 Severity 映射关系。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.SheetCollate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.SheetCollate
的使用

使用 SheetCollate 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 SheetCollate 的使用

声明为 SheetCollate 的 javax.print.attribute.standard 中的字段
static SheetCollate | SheetCollate.COLLATED 当打印多个副本时，文档中的纸张以整理后的顺序出现。
static SheetCollate | SheetCollate.UNCOLLATED 当打印多个副本时，文档中的纸张以非整理顺序出现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.attribute.standard.Sides 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Sides
的使用

使用 Sides 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Sides 的使用

声明为 Sides 的 javax.print.attribute.standard 中的字段
static Sides | Sides.DUPLEX “双面长边”的别名（请参阅 TWO_SIDED_LONG_EDGE）。
static Sides | Sides.ONE_SIDED 将每个连续的打印流页应用于连续介质纸张的相同面。
static Sides | Sides.TUMBLE “双面短边”的别名（请参阅 TWO_SIDED_SHORT_EDGE）。
static Sides | Sides.TWO_SIDED_LONG_EDGE 将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在长边上一样。
static Sides | Sides.TWO_SIDED_SHORT_EDGE 将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在短边上一样。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.AttributeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.AttributeException
的使用

没有 javax.print.AttributeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.CancelablePrintJob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.CancelablePrintJob
的使用

没有 javax.print.CancelablePrintJob 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.Doc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.Doc
的使用

使用 Doc 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 Doc 的使用

实现 Doc 的 javax.print 中的类
 class SimpleDoc
此类是接口 Doc 的实现，可用于很多常见的打印请求中。

返回 Doc 的 javax.print 中的方法
 Doc MultiDoc.getDoc()
获取当前的 doc 对象。

参数类型为 Doc 的 javax.print 中的方法
 void DocPrintJob.print(Doc doc, PrintRequestAttributeSet attributes)
使用指定的作业属性打印文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.DocFlavor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor
的使用

使用 DocFlavor 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor 的使用

javax.print 中 DocFlavor 的子类
static class | DocFlavor.BYTE_ARRAY 类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.CHAR_ARRAY 类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.INPUT_STREAM 类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.READER 类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.SERVICE_FORMATTED 类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
static class | DocFlavor.STRING 类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.URL 类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。

返回 DocFlavor 的 javax.print 中的方法
DocFlavor | Doc.getDocFlavor() 确定此 doc 对象提供其部分打印数据所用的 DocFlavor。
DocFlavor | SimpleDoc.getDocFlavor() 确定其 doc 对象将提供其部分打印数据的 doc flavor。
DocFlavor[] | PrintService.getSupportedDocFlavors() 确定在设置此 PrintService 的作业时，客户端可以指定的打印数据格式。
abstract DocFlavor[] | StreamPrintServiceFactory.getSupportedDocFlavors() 查询该工厂，了解从此工厂所获得打印机可接受的 doc flavor。
DocFlavor[] | FlavorException.getUnsupportedFlavors() 返回不受支持的 flavor。

参数类型为 DocFlavor 的 javax.print 中的方法
abstract MultiDocPrintService[] | PrintServiceLookup.getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 应用程序不直接调用它。
abstract PrintService[] | PrintServiceLookup.getPrintServices(DocFlavor flavor, AttributeSet attributes) 查找肯定可支持指定属性和 DocFlavor 组合的服务。
Object | PrintService.getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
AttributeSet | PrintService.getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes) 标识在特定 DocFlavor 的上下文中打印请求不支持的属性。
boolean | PrintService.isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定的打印属性值。
boolean | PrintService.isDocFlavorSupported(DocFlavor flavor) 确定此 PrintService 是否支持具体 DocFlavor。
static MultiDocPrintService[] | PrintServiceLookup.lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 查找能够打印 MultiDoc（包含所有指定的 doc flavor）的 MultiDoc PrintService。
static PrintService[] | PrintServiceLookup.lookupPrintServices(DocFlavor flavor, AttributeSet attributes) 查找能够打印指定 DocFlavor 的 PrintService。
static StreamPrintServiceFactory[] | StreamPrintServiceFactory.lookupStreamPrintServiceFactories(DocFlavor flavor, String outputMimeType) 查找 PrintService 的工厂，PrintJob 可使用它来输出数据流，数据格式由 flavor 指定。
static PrintService | ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes) 为用户提供一个选择 PrintService（打印机）的对话框。

参数类型为 DocFlavor 的 javax.print 中的构造方法
SimpleDoc(Object printData, DocFlavor flavor, DocAttributeSet attributes)
构造具有指定打印数据、doc flavor 和 doc 属性集的 SimpleDoc。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.DocFlavor.BYTE_ARRAY 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.BYTE_ARRAY
的使用

使用 DocFlavor.BYTE_ARRAY 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.BYTE_ARRAY 的使用

声明为 DocFlavor.BYTE_ARRAY 的 javax.print 中的字段
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.AUTOSENSE MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.GIF MIME 类型 = "image/gif"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.JPEG MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.PCL MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.PDF MIME 类型 = "application/pdf"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.PNG MIME 类型 = "image/png"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.POSTSCRIPT MIME 类型 = "application/postscript"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_HOST MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_US_ASCII MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_16 MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_16BE MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_16LE MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_8 MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_HOST MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_US_ASCII MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_16 MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_16BE MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_16LE MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_8 MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.DocFlavor.CHAR_ARRAY 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.CHAR_ARRAY
的使用

使用 DocFlavor.CHAR_ARRAY 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.CHAR_ARRAY 的使用

声明为 DocFlavor.CHAR_ARRAY 的 javax.print 中的字段
static DocFlavor.CHAR_ARRAY | DocFlavor.CHAR_ARRAY.TEXT_HTML MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。
static DocFlavor.CHAR_ARRAY | DocFlavor.CHAR_ARRAY.TEXT_PLAIN MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.DocFlavor.INPUT_STREAM 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.INPUT_STREAM
的使用

使用 DocFlavor.INPUT_STREAM 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.INPUT_STREAM 的使用

声明为 DocFlavor.INPUT_STREAM 的 javax.print 中的字段
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.AUTOSENSE MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.GIF MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.JPEG MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.PCL MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.PDF MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.PNG MIME 类型 = "image/png"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.POSTSCRIPT MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_HOST MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_US_ASCII MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_16 MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_16BE MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_16LE MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_8 MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_HOST MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_US_ASCII MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_16 MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_16BE MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_16LE MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_8 MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.DocFlavor.READER 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.READER
的使用

使用 DocFlavor.READER 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.READER 的使用

声明为 DocFlavor.READER 的 javax.print 中的字段
static DocFlavor.READER | DocFlavor.READER.TEXT_HTML MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。
static DocFlavor.READER | DocFlavor.READER.TEXT_PLAIN MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.DocFlavor.SERVICE_FORMATTED 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.SERVICE_FORMATTED
的使用

使用 DocFlavor.SERVICE_FORMATTED 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.SERVICE_FORMATTED 的使用

声明为 DocFlavor.SERVICE_FORMATTED 的 javax.print 中的字段
static DocFlavor.SERVICE_FORMATTED | DocFlavor.SERVICE_FORMATTED.PAGEABLE 打印数据表示形式类名 = "java.awt.print.Pageable"（pageable 对象）的服务格式化打印数据 DocFlavor。
static DocFlavor.SERVICE_FORMATTED | DocFlavor.SERVICE_FORMATTED.PRINTABLE 打印数据表示形式类名 = "java.awt.print.Printable"（printable 对象）的服务格式化打印数据 DocFlavor。
static DocFlavor.SERVICE_FORMATTED | DocFlavor.SERVICE_FORMATTED.RENDERABLE_IMAGE 打印数据表示形式类名 = "java.awt.image.renderable.RenderableImage"（RenderableImage 对象）的服务格式化打印数据 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.DocFlavor.STRING 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.STRING
的使用

使用 DocFlavor.STRING 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.STRING 的使用

声明为 DocFlavor.STRING 的 javax.print 中的字段
static DocFlavor.STRING | DocFlavor.STRING.TEXT_HTML MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。
static DocFlavor.STRING | DocFlavor.STRING.TEXT_PLAIN MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.DocFlavor.URL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.URL
的使用

使用 DocFlavor.URL 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.URL 的使用

声明为 DocFlavor.URL 的 javax.print 中的字段
static DocFlavor.URL | DocFlavor.URL.AUTOSENSE MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.GIF MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.JPEG MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.PCL MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.PDF MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.PNG MIME 类型 = "image/png"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.POSTSCRIPT MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_HOST MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_US_ASCII MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_UTF_16 MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_UTF_16BE MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_UTF_16LE MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_UTF_8 MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_HOST MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_US_ASCII MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_UTF_16 MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = java.net.URL""（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_UTF_16BE MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_UTF_16LE MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_UTF_8 MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.DocPrintJob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.DocPrintJob
的使用

使用 DocPrintJob 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。

javax.print 中 DocPrintJob 的使用

javax.print 中 DocPrintJob 的子接口
interface | CancelablePrintJob 打印应用程序使用此接口来取消打印作业。
interface | MultiDocPrintJob 从 MultiDocPrintService 中获得，MultiDocPrintJob 可使用作业属性集以单个 PrintJob 的形式打印指定的文档集合。

返回 DocPrintJob 的 javax.print 中的方法
 DocPrintJob PrintService.createPrintJob()
创建并返回一个 PrintJob，它应能够处理取自任意受支持的 docflavor 的数据。

javax.print.event 中 DocPrintJob 的使用

返回 DocPrintJob 的 javax.print.event 中的方法
DocPrintJob | PrintJobAttributeEvent.getPrintJob() 确定此打印作业事件适合的 Print Job。
DocPrintJob | PrintJobEvent.getPrintJob() 确定此打印作业事件适合的 DocPrintJob。

参数类型为 DocPrintJob 的 javax.print.event 中的构造方法
PrintJobAttributeEvent(DocPrintJob source, PrintJobAttributeSet attributes)
构造一个 PrintJobAttributeEvent 对象。
PrintJobEvent(DocPrintJob source, int reason)
构造一个 PrintJobEvent 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.FlavorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.FlavorException
的使用

没有 javax.print.FlavorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.MultiDoc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.MultiDoc
的使用

使用 MultiDoc 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 MultiDoc 的使用

返回 MultiDoc 的 javax.print 中的方法
 MultiDoc MultiDoc.next()
转到包含 doc 对象序列中下一个 doc 对象的 multidoc 对象。

参数类型为 MultiDoc 的 javax.print 中的方法
 void MultiDocPrintJob.print(MultiDoc multiDoc, PrintRequestAttributeSet attributes)
使用指定的作业属性打印 MultiDoc。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.MultiDocPrintJob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.MultiDocPrintJob
的使用

使用 MultiDocPrintJob 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 MultiDocPrintJob 的使用

返回 MultiDocPrintJob 的 javax.print 中的方法
 MultiDocPrintJob MultiDocPrintService.createMultiDocPrintJob()
创建一个可打印 multiDoc 的作业。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.MultiDocPrintService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.MultiDocPrintService
的使用

使用 MultiDocPrintService 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 MultiDocPrintService 的使用

返回 MultiDocPrintService 的 javax.print 中的方法
abstract MultiDocPrintService[] | PrintServiceLookup.getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 应用程序不直接调用它。
static MultiDocPrintService[] | PrintServiceLookup.lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 查找能够打印 MultiDoc（包含所有指定的 doc flavor）的 MultiDoc PrintService。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.PrintException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.PrintException
的使用

使用 PrintException 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 PrintException 的使用

抛出 PrintException 的 javax.print 中的方法
void | CancelablePrintJob.cancel() 停止对打印作业的进一步处理。
void | DocPrintJob.print(Doc doc, PrintRequestAttributeSet attributes) 使用指定的作业属性打印文档。
void | MultiDocPrintJob.print(MultiDoc multiDoc, PrintRequestAttributeSet attributes) 使用指定的作业属性打印 MultiDoc。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.PrintService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.PrintService
的使用

使用 PrintService 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 中 PrintService 的使用

返回 PrintService 的 java.awt.print 中的方法
PrintService | PrinterJob.getPrintService() 返回此打印机作业的服务（打印机）。
static PrintService[] | PrinterJob.lookupPrintServices() 查找 2D 打印服务的便捷方法。

参数类型为 PrintService 的 java.awt.print 中的方法
 void PrinterJob.setPrintService(PrintService service)
将此 PrinterJob 与新的 PrintService 关联。

javax.print 中 PrintService 的使用

javax.print 中 PrintService 的子接口
 interface MultiDocPrintService
接口 MultiPrintService 是 MultiDocPrintJob 的工厂。

实现 PrintService 的 javax.print 中的类
 class StreamPrintService
此类扩展了 PrintService 并表示这样一种 PrintService，即以不同的格式向客户端提供的输出流打印数据。

返回 PrintService 的 javax.print 中的方法
abstract PrintService | PrintServiceLookup.getDefaultPrintService() 应用程序不直接调用它。
PrintService | DocPrintJob.getPrintService() 确定此 PrintJob 对象所绑定到的 PrintService 对象。
abstract PrintService[] | PrintServiceLookup.getPrintServices() 应用程序不直接调用它。
abstract PrintService[] | PrintServiceLookup.getPrintServices(DocFlavor flavor, AttributeSet attributes) 查找肯定可支持指定属性和 DocFlavor 组合的服务。
static PrintService | PrintServiceLookup.lookupDefaultPrintService() 查找此环境的默认 PrintService。
static PrintService[] | PrintServiceLookup.lookupPrintServices(DocFlavor flavor, AttributeSet attributes) 查找能够打印指定 DocFlavor 的 PrintService。
static PrintService | ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes) 为用户提供一个选择 PrintService（打印机）的对话框。

参数类型为 PrintService 的 javax.print 中的方法
static PrintService | ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes) 为用户提供一个选择 PrintService（打印机）的对话框。
static PrintService | ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes) 为用户提供一个选择 PrintService（打印机）的对话框。
static boolean | PrintServiceLookup.registerService(PrintService service) 允许应用程序直接注册一个实现了 PrintService 的类的实例。

javax.print.event 中 PrintService 的使用

返回 PrintService 的 javax.print.event 中的方法
 PrintService PrintServiceAttributeEvent.getPrintService()
返回打印服务。

参数类型为 PrintService 的 javax.print.event 中的构造方法
PrintServiceAttributeEvent(PrintService source, PrintServiceAttributeSet attributes)
构造一个 PrintServiceAttributeEvent 对象。

javax.swing 中 PrintService 的使用

参数类型为 PrintService 的 javax.swing 中的方法
 boolean JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service)
打印此 JTable。

javax.swing.text 中 PrintService 的使用

参数类型为 PrintService 的 javax.swing.text 中的方法
 boolean JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive)
打印此 JTextComponent 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.PrintServiceLookup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.PrintServiceLookup
的使用

使用 PrintServiceLookup 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 PrintServiceLookup 的使用

参数类型为 PrintServiceLookup 的 javax.print 中的方法
static boolean PrintServiceLookup.registerServiceProvider(PrintServiceLookup sp)
允许应用程序显式地注册一个实现了查找服务的类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.ServiceUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.ServiceUI
的使用

没有 javax.print.ServiceUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.ServiceUIFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.ServiceUIFactory
的使用

使用 ServiceUIFactory 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 ServiceUIFactory 的使用

返回 ServiceUIFactory 的 javax.print 中的方法
 ServiceUIFactory PrintService.getServiceUIFactory()
返回 UI 组件的工厂方法，该组件允许用户通过各种角色与服务交互。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.SimpleDoc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.SimpleDoc
的使用

没有 javax.print.SimpleDoc 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.StreamPrintService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.StreamPrintService
的使用

使用 StreamPrintService 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 StreamPrintService 的使用

返回 StreamPrintService 的 javax.print 中的方法
abstract  StreamPrintService StreamPrintServiceFactory.getPrintService(OutputStream out)
返回可打印到指定输出流的 StreamPrintService。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.StreamPrintServiceFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.StreamPrintServiceFactory
的使用

使用 StreamPrintServiceFactory 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。

java.awt.print 中 StreamPrintServiceFactory 的使用

返回 StreamPrintServiceFactory 的 java.awt.print 中的方法
static StreamPrintServiceFactory[] PrinterJob.lookupStreamPrintServices(String mimeType)
定位可以成像 2D 图形的流打印服务工厂的便捷方法。

javax.print 中 StreamPrintServiceFactory 的使用

返回 StreamPrintServiceFactory 的 javax.print 中的方法
static StreamPrintServiceFactory[] StreamPrintServiceFactory.lookupStreamPrintServiceFactories(DocFlavor flavor, String outputMimeType)
查找 PrintService 的工厂，PrintJob 可使用它来输出数据流，数据格式由 flavor 指定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.URIException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.URIException
的使用

没有 javax.print.URIException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.print.event (Java 2 Platform SE 6)

 javax.print.event
接口
PrintJobAttributeListener
PrintJobListener
PrintServiceAttributeListener
类
PrintEvent
PrintJobAdapter
PrintJobAttributeEvent
PrintJobEvent
PrintServiceAttributeEvent


类 javax.print.event.PrintEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.event.PrintEvent
的使用

使用 PrintEvent 的软件包
javax.print.event 包 javax.print.event 包含事件类和侦听器接口。

javax.print.event 中 PrintEvent 的使用

javax.print.event 中 PrintEvent 的子类
class | PrintJobAttributeEvent 类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。
class | PrintJobEvent 类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。
class | PrintServiceAttributeEvent 类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.event.PrintJobAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.event.PrintJobAdapter
的使用

没有 javax.print.event.PrintJobAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.event.PrintJobAttributeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.event.PrintJobAttributeEvent
的使用

使用 PrintJobAttributeEvent 的软件包
javax.print.event 包 javax.print.event 包含事件类和侦听器接口。

javax.print.event 中 PrintJobAttributeEvent 的使用

参数类型为 PrintJobAttributeEvent 的 javax.print.event 中的方法
 void PrintJobAttributeListener.attributeUpdate(PrintJobAttributeEvent pjae)
通知侦听器某些打印作业属性已更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.event.PrintJobAttributeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.event.PrintJobAttributeListener
的使用

使用 PrintJobAttributeListener 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 PrintJobAttributeListener 的使用

参数类型为 PrintJobAttributeListener 的 javax.print 中的方法
void | DocPrintJob.addPrintJobAttributeListener(PrintJobAttributeListener listener, PrintJobAttributeSet attributes) 为指定属性中的更改注册一个侦听器。
void | DocPrintJob.removePrintJobAttributeListener(PrintJobAttributeListener listener) 移除此 PrintJob 的属性侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.event.PrintJobEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.event.PrintJobEvent
的使用

使用 PrintJobEvent 的软件包
javax.print.event 包 javax.print.event 包含事件类和侦听器接口。

javax.print.event 中 PrintJobEvent 的使用

参数类型为 PrintJobEvent 的 javax.print.event 中的方法
void | PrintJobAdapter.printDataTransferCompleted(PrintJobEvent pje) 调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。
void | PrintJobListener.printDataTransferCompleted(PrintJobEvent pje) 调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。
void | PrintJobAdapter.printJobCanceled(PrintJobEvent pje) 调用此方法来通知客户端，作业已被用户或程序取消。
void | PrintJobListener.printJobCanceled(PrintJobEvent pje) 调用此方法来通知客户端，作业已被用户或程序取消。
void | PrintJobAdapter.printJobCompleted(PrintJobEvent pje) 调用此方法来通知客户端，作业已成功完成。
void | PrintJobListener.printJobCompleted(PrintJobEvent pje) 调用此方法来通知客户端，作业已成功完成。
void | PrintJobAdapter.printJobFailed(PrintJobEvent pje) 调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。
void | PrintJobListener.printJobFailed(PrintJobEvent pje) 调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。
void | PrintJobAdapter.printJobNoMoreEvents(PrintJobEvent pje) 调用此方法来通知客户端，不需要再提供事件。
void | PrintJobListener.printJobNoMoreEvents(PrintJobEvent pje) 调用此方法来通知客户端，不需要再提供事件。
void | PrintJobAdapter.printJobRequiresAttention(PrintJobEvent pje) 调用此方法来通知客户端，可能会发生一些用户可纠正的问题（例如打印机缺纸）。
void | PrintJobListener.printJobRequiresAttention(PrintJobEvent pje) 调用此方法来通知客户端，发生了一个用户也许能够修复的错误，可以生成此事件的一个错误示例是打印机用完了纸张。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.event.PrintJobListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.event.PrintJobListener
的使用

使用 PrintJobListener 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。

javax.print 中 PrintJobListener 的使用

参数类型为 PrintJobListener 的 javax.print 中的方法
void | DocPrintJob.addPrintJobListener(PrintJobListener listener) 为此 PrintJob 执行期间所出现的事件注册一个侦听器。
void | DocPrintJob.removePrintJobListener(PrintJobListener listener) 移除此 PrintJob 的侦听器。

javax.print.event 中 PrintJobListener 的使用

实现 PrintJobListener 的 javax.print.event 中的类
 class PrintJobAdapter
接收打印作业事件的抽象适配器类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.print.event.PrintServiceAttributeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.event.PrintServiceAttributeEvent
的使用

使用 PrintServiceAttributeEvent 的软件包
javax.print.event 包 javax.print.event 包含事件类和侦听器接口。

javax.print.event 中 PrintServiceAttributeEvent 的使用

参数类型为 PrintServiceAttributeEvent 的 javax.print.event 中的方法
 void PrintServiceAttributeListener.attributeUpdate(PrintServiceAttributeEvent psae)
调用此方法来通知侦听器关于打印服务中的事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.print.event.PrintServiceAttributeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.event.PrintServiceAttributeListener
的使用

使用 PrintServiceAttributeListener 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 PrintServiceAttributeListener 的使用

参数类型为 PrintServiceAttributeListener 的 javax.print 中的方法
void | PrintService.addPrintServiceAttributeListener(PrintServiceAttributeListener listener) 为此 PrintService 上的事件注册一个侦听器。
void | PrintService.removePrintServiceAttributeListener(PrintServiceAttributeListener listener) 移除此 PrintService 的 PrintService 侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.rmi (Java 2 Platform SE 6)

 javax.rmi
类
PortableRemoteObject


类 javax.rmi.PortableRemoteObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.PortableRemoteObject
的使用

没有 javax.rmi.PortableRemoteObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.rmi.CORBA (Java 2 Platform SE 6)

 javax.rmi.CORBA
接口
PortableRemoteObjectDelegate
StubDelegate
Tie
UtilDelegate
ValueHandler
ValueHandlerMultiFormat
类
ClassDesc
Stub
Util


类 javax.rmi.CORBA.ClassDesc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.CORBA.ClassDesc
的使用

没有 javax.rmi.CORBA.ClassDesc 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.PortableRemoteObjectDelegate
的使用

没有 javax.rmi.CORBA.PortableRemoteObjectDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.rmi.CORBA.Stub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.CORBA.Stub
的使用

使用 Stub 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 中 Stub 的使用

参数类型为 Stub 的 javax.rmi.CORBA 中的方法
 void StubDelegate.connect(Stub self, ORB orb)
connect(org.omg.CORBA.ORB) 的委托调用。
 boolean StubDelegate.equals(Stub self, Object obj)
equals(java.lang.Object) 的委托调用。
 int StubDelegate.hashCode(Stub self)
hashCode() 的委托调用。
static boolean Util.isLocal(Stub stub)
isLocal 方法与 ObjectImpl._is_local 方法具有相同的语义，否则可能抛出 RemoteException。
 boolean UtilDelegate.isLocal(Stub stub)
Util.isLocal(javax.rmi.CORBA.Stub) 的委托调用。
 void StubDelegate.readObject(Stub self, ObjectInputStream s)
Stub.readObject(java.io.ObjectInputStream) 的委托调用。
 String StubDelegate.toString(Stub self)
toString() 的委托调用。
 void StubDelegate.writeObject(Stub self, ObjectOutputStream s)
Stub.writeObject(java.io.ObjectOutputStream) 的委托调用。

org.omg.stub.java.rmi 中 Stub 的使用

org.omg.stub.java.rmi 中 Stub 的子类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.rmi.CORBA.StubDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.StubDelegate
的使用

没有 javax.rmi.CORBA.StubDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.rmi.CORBA.Tie 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.Tie
的使用

使用 Tie 的软件包
javax.rmi.CORBA 包含用于 RMI-IIOP 的可移植性 API。

javax.rmi.CORBA 中 Tie 的使用

返回 Tie 的 javax.rmi.CORBA 中的方法
static Tie Util.getTie(Remote target)
返回给定目标对象的 tie（如果存在）。
 Tie UtilDelegate.getTie(Remote target)
Util.getTie(java.rmi.Remote) 的委托调用。

参数类型为 Tie 的 javax.rmi.CORBA 中的方法
static void Util.registerTarget(Tie tie, Remote target)
为 tie 注册一个目标。
 void UtilDelegate.registerTarget(Tie tie, Remote target)
Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 的委托调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.rmi.CORBA.Util 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.CORBA.Util
的使用

没有 javax.rmi.CORBA.Util 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.rmi.CORBA.UtilDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.UtilDelegate
的使用

没有 javax.rmi.CORBA.UtilDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.rmi.CORBA.ValueHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.ValueHandler
的使用

使用 ValueHandler 的软件包
javax.rmi.CORBA 包含用于 RMI-IIOP 的可移植性 API。

javax.rmi.CORBA 中 ValueHandler 的使用

javax.rmi.CORBA 中 ValueHandler 的子接口
 interface ValueHandlerMultiFormat
Java 到 IDL ptc 02-01-12 1.5.1.5。

返回 ValueHandler 的 javax.rmi.CORBA 中的方法
static ValueHandler Util.createValueHandler()
返回实现 ValueHandler 接口的类的单一实例。
 ValueHandler UtilDelegate.createValueHandler()
Util.createValueHandler() 的委托调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.rmi.CORBA.ValueHandlerMultiFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.ValueHandlerMultiFormat
的使用

没有 javax.rmi.CORBA.ValueHandlerMultiFormat 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.rmi.ssl (Java 2 Platform SE 6)

 javax.rmi.ssl
类
SslRMIClientSocketFactory
SslRMIServerSocketFactory


类 javax.rmi.ssl.SslRMIClientSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.ssl.SslRMIClientSocketFactory
的使用

没有 javax.rmi.ssl.SslRMIClientSocketFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.rmi.ssl.SslRMIServerSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.ssl.SslRMIServerSocketFactory
的使用

没有 javax.rmi.ssl.SslRMIServerSocketFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.script (Java 2 Platform SE 6)

 javax.script
接口
Bindings
Compilable
Invocable
ScriptContext
ScriptEngine
ScriptEngineFactory
类
AbstractScriptEngine
CompiledScript
ScriptEngineManager
SimpleBindings
SimpleScriptContext
异常
ScriptException


类 javax.script.AbstractScriptEngine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.AbstractScriptEngine
的使用

没有 javax.script.AbstractScriptEngine 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.script.Bindings 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.Bindings
的使用

使用 Bindings 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 Bindings 的使用

实现 Bindings 的 javax.script 中的类
 class SimpleBindings
一个受 HashMap 或其他某些指定 Map 支持的 Bindings 的简单实现。

声明为 Bindings 的 javax.script 中的字段
protected Bindings | SimpleScriptContext.engineScope 此字段是引擎范围 bindings。
protected Bindings | SimpleScriptContext.globalScope 此字段是全局范围 bindings。

返回 Bindings 的 javax.script 中的方法
Bindings | ScriptEngine.createBindings() 返回一个未初始化的 Bindings。
Bindings | ScriptEngineManager.getBindings() getBindings 返回 globalScope 字段的值。
Bindings | AbstractScriptEngine.getBindings(int scope) 返回受保护 context 字段中具有指定范围值的 Bindings。
Bindings | ScriptContext.getBindings(int scope) 获取与此 ScriptContext 中的给定范围关联的 Bindings。
Bindings | ScriptEngine.getBindings(int scope) 返回指定值的范围。
Bindings | SimpleScriptContext.getBindings(int scope) 如果指定范围为 ENGINE_SCOPE，则返回 engineScope 字段的值。

参数类型为 Bindings 的 javax.script 中的方法
 Object CompiledScript.eval(Bindings bindings)
执行存储在 CompiledScript 对象中的程序，脚本执行期间使用所提供的属性的 Bindings 作为关联 ScriptEngine 的 ENGINE_SCOPE。
 Object AbstractScriptEngine.eval(Reader reader, Bindings bindings)
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。
 Object ScriptEngine.eval(Reader reader, Bindings n)
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。
 Object AbstractScriptEngine.eval(String script, Bindings bindings)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。
 Object ScriptEngine.eval(String script, Bindings n)
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。
protected  ScriptContext AbstractScriptEngine.getScriptContext(Bindings nn)
返回一个 SimpleScriptContext。
 void ScriptEngineManager.setBindings(Bindings bindings)
setBindings 存储 globalScope 字段中的指定 Bindings。
 void AbstractScriptEngine.setBindings(Bindings bindings, int scope)
使用 context 字段中的相应范围值设置 Bindings。
 void ScriptContext.setBindings(Bindings bindings, int scope)
将 Bindings 实例与此 ScriptContext 中的特定范围关联。
 void ScriptEngine.setBindings(Bindings bindings, int scope)
设置将由脚本使用的指定值的范围。
 void SimpleScriptContext.setBindings(Bindings bindings, int scope)
针对给定范围设置属性的 Bindings。

参数类型为 Bindings 的 javax.script 中的构造方法
AbstractScriptEngine(Bindings n)
创建一个新实例，使用指定 Bindings 作为受保护 context 字段中的 ENGINE_SCOPE Bindings。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.script.Compilable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.Compilable
的使用

没有 javax.script.Compilable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.script.CompiledScript 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.CompiledScript
的使用

使用 CompiledScript 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 CompiledScript 的使用

返回 CompiledScript 的 javax.script 中的方法
CompiledScript | Compilable.compile(Reader script) 编译脚本（从 Reader 读取的源），以便以后执行。
CompiledScript | Compilable.compile(String script) 编译脚本（以 String 形式表示的源），以便以后执行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.script.Invocable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.Invocable
的使用

没有 javax.script.Invocable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.script.ScriptContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.ScriptContext
的使用

使用 ScriptContext 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 ScriptContext 的使用

实现 ScriptContext 的 javax.script 中的类
 class SimpleScriptContext
ScriptContext 的简单实现。

声明为 ScriptContext 的 javax.script 中的字段
protected  ScriptContext AbstractScriptEngine.context
此 AbstractScriptEngine 的默认 ScriptContext。

返回 ScriptContext 的 javax.script 中的方法
ScriptContext | AbstractScriptEngine.getContext() 返回受保护 context 字段的值。
ScriptContext | ScriptEngine.getContext() 返回 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。
protected ScriptContext | AbstractScriptEngine.getScriptContext(Bindings nn) 返回一个 SimpleScriptContext。

参数类型为 ScriptContext 的 javax.script 中的方法
 Object ScriptEngine.eval(Reader reader, ScriptContext context)
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。
abstract  Object CompiledScript.eval(ScriptContext context)
执行存储在此 CompiledScript 对象中的程序。
 Object ScriptEngine.eval(String script, ScriptContext context)
立即执行脚本，该脚本的源是作为第一个参数传递的 String。
 void AbstractScriptEngine.setContext(ScriptContext ctxt)
将受保护 context 字段的值设置为指定的 ScriptContext。
 void ScriptEngine.setContext(ScriptContext context)
设置 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.script.ScriptEngine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.ScriptEngine
的使用

使用 ScriptEngine 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 ScriptEngine 的使用

实现 ScriptEngine 的 javax.script 中的类
 class AbstractScriptEngine
为几个 eval 方法的变体提供标准实现。

返回 ScriptEngine 的 javax.script 中的方法
abstract ScriptEngine | CompiledScript.getEngine() 返回用 compile 方法创建了此 CompiledScript 的 ScriptEngine。
ScriptEngine | ScriptEngineManager.getEngineByExtension(String extension) 查找并创建一个给定扩展的 ScriptEngine。
ScriptEngine | ScriptEngineManager.getEngineByMimeType(String mimeType) 查找并创建一个给定 mime 类型的 ScriptEngine。
ScriptEngine | ScriptEngineManager.getEngineByName(String shortName) 查找并创建一个给定名称的 ScriptEngine。
ScriptEngine | ScriptEngineFactory.getScriptEngine() 返回与此 ScriptEngineFactory 关联的 ScriptEngine 的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.script.ScriptEngineFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.ScriptEngineFactory
的使用

使用 ScriptEngineFactory 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 ScriptEngineFactory 的使用

返回 ScriptEngineFactory 的 javax.script 中的方法
 ScriptEngineFactory ScriptEngine.getFactory()
返回此 ScriptEngine 所属的类的 ScriptEngineFactory。

返回变量类型为 ScriptEngineFactory 的类型的 javax.script 中的方法
 List<ScriptEngineFactory> ScriptEngineManager.getEngineFactories()
返回一个数组，该数组的元素是发现机制找到的所有 ScriptEngineFactory 类的实例。

参数类型为 ScriptEngineFactory 的 javax.script 中的方法
void | ScriptEngineManager.registerEngineExtension(String extension, ScriptEngineFactory factory) 注册一个 ScriptEngineFactory 来处理扩展。
void | ScriptEngineManager.registerEngineMimeType(String type, ScriptEngineFactory factory) 注册一个 ScriptEngineFactory 来处理 mime 类型。
void | ScriptEngineManager.registerEngineName(String name, ScriptEngineFactory factory) 注册一个 ScriptEngineFactory 来处理语言名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.script.ScriptEngineManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.ScriptEngineManager
的使用

没有 javax.script.ScriptEngineManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.script.ScriptException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.ScriptException
的使用

使用 ScriptException 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 ScriptException 的使用

抛出 ScriptException 的 javax.script 中的方法
 CompiledScript Compilable.compile(Reader script)
编译脚本（从 Reader 读取的源），以便以后执行。
 CompiledScript Compilable.compile(String script)
编译脚本（以 String 形式表示的源），以便以后执行。
 Object CompiledScript.eval()
执行存储在 CompiledScript 对象中的程序。
 Object CompiledScript.eval(Bindings bindings)
执行存储在 CompiledScript 对象中的程序，脚本执行期间使用所提供的属性的 Bindings 作为关联 ScriptEngine 的 ENGINE_SCOPE。
 Object AbstractScriptEngine.eval(Reader reader)
eval(Reader) 调用抽象 eval(Reader, ScriptContext)，并传递 context 字段的值给它。
 Object ScriptEngine.eval(Reader reader)
除了脚本的源是以 Reader 形式提供的外，与 eval(String) 相同。
 Object AbstractScriptEngine.eval(Reader reader, Bindings bindings)
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。
 Object ScriptEngine.eval(Reader reader, Bindings n)
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。
 Object ScriptEngine.eval(Reader reader, ScriptContext context)
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。
abstract  Object CompiledScript.eval(ScriptContext context)
执行存储在此 CompiledScript 对象中的程序。
 Object AbstractScriptEngine.eval(String script)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader) 相同。
 Object ScriptEngine.eval(String script)
执行指定的脚本。
 Object AbstractScriptEngine.eval(String script, Bindings bindings)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。
 Object ScriptEngine.eval(String script, Bindings n)
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。
 Object ScriptEngine.eval(String script, ScriptContext context)
立即执行脚本，该脚本的源是作为第一个参数传递的 String。
 Object Invocable.invokeFunction(String name, Object... args)
用于调用脚本中定义的顶层程序和函数。
 Object Invocable.invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.script.SimpleBindings 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.SimpleBindings
的使用

没有 javax.script.SimpleBindings 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.script.SimpleScriptContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.SimpleScriptContext
的使用

没有 javax.script.SimpleScriptContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.security.auth (Java 2 Platform SE 6)

 javax.security.auth
接口
Destroyable
Refreshable
类
AuthPermission
Policy
PrivateCredentialPermission
Subject
SubjectDomainCombiner
异常
DestroyFailedException
RefreshFailedException


javax.security.auth.callback (Java 2 Platform SE 6)

 javax.security.auth.callback
接口
Callback
CallbackHandler
类
ChoiceCallback
ConfirmationCallback
LanguageCallback
NameCallback
PasswordCallback
TextInputCallback
TextOutputCallback
异常
UnsupportedCallbackException


接口 javax.security.auth.callback.Callback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.callback.Callback
的使用

使用 Callback 的软件包
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.sasl | 包含用于支持 SASL 的类和接口。

javax.security.auth.callback 中 Callback 的使用

实现 Callback 的 javax.security.auth.callback 中的类
class | ChoiceCallback 底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。
class | ConfirmationCallback 底层安全服务实例化 ConfirmationCallback，并将其传递到 CallbackHandler 的 handle 方法，以请求 YES/NO、OK/CANCEL、YES/NO/CANCEL 或其他类似的确认信息。
class | LanguageCallback 底层安全服务实例化一个 LanguageCallback, 并将其传递给 CallbackHandler 的 handle 方法，以获取用于本地化文本的 Locale。
class | NameCallback 底层安全服务实例化一个 NameCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取名称信息。
class | PasswordCallback 底层安全服务实例化一个 PasswordCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取密码信息。
class | TextInputCallback 底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。
class | TextOutputCallback 底层安全服务实例化一个 TextOutputCallback 并将其传递给 CallbackHandler 的 handle 方法，以显示信息消息、警告消息和错误消息。

返回 Callback 的 javax.security.auth.callback 中的方法
 Callback UnsupportedCallbackException.getCallback()
获取未识别的 Callback。

参数类型为 Callback 的 javax.security.auth.callback 中的方法
 void CallbackHandler.handle(Callback[] callbacks)
获取或显示在提供的 Callback 中请求的信息。

参数类型为 Callback 的 javax.security.auth.callback 中的构造方法
UnsupportedCallbackException(Callback callback)
构造不带详细消息的 UnsupportedCallbackException。
UnsupportedCallbackException(Callback callback, String msg)
构造带指定详细消息的 UnsupportedCallbackException。

javax.security.sasl 中 Callback 的使用

实现 Callback 的 javax.security.sasl 中的类
class | AuthorizeCallback 此回调由 SaslServer 使用，以确定某个实体（由已验证的验证 id 所标识）能否代表另一个实体（由授权 id 所标识）。
class | RealmCallback SaslClient 和 SaslServer 使用此回调来获取领域信息。
class | RealmChoiceCallback SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.security.auth.callback.CallbackHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.callback.CallbackHandler
的使用

使用 CallbackHandler 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。
javax.security.sasl | 包含用于支持 SASL 的类和接口。

java.security 中 CallbackHandler 的使用

返回 CallbackHandler 的 java.security 中的方法
 CallbackHandler KeyStore.CallbackHandlerProtection.getCallbackHandler()
返回 CallbackHandler。

参数类型为 CallbackHandler 的 java.security 中的方法
abstract void | AuthProvider.login(Subject subject, CallbackHandler handler) 登录到此 provider 中。
abstract void | AuthProvider.setCallbackHandler(CallbackHandler handler) 设置 CallbackHandler。

参数类型为 CallbackHandler 的 java.security 中的构造方法
KeyStore.CallbackHandlerProtection(CallbackHandler handler)
根据 CallbackHandler 构造新的 CallbackHandlerProtection。

javax.security.auth.login 中 CallbackHandler 的使用

参数类型为 CallbackHandler 的 javax.security.auth.login 中的构造方法
LoginContext(String name, CallbackHandler callbackHandler)
使用 name 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

javax.security.auth.spi 中 CallbackHandler 的使用

参数类型为 CallbackHandler 的 javax.security.auth.spi 中的方法
 void LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
初始化此 LoginModule。

javax.security.sasl 中 CallbackHandler 的使用

参数类型为 CallbackHandler 的 javax.security.sasl 中的方法
static SaslClient | Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
SaslClient | SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
static SaslServer | Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 为指定机制创建一个 SaslServer。
SaslServer | SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslServer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.callback.ChoiceCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.ChoiceCallback
的使用

使用 ChoiceCallback 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 ChoiceCallback 的使用

javax.security.sasl 中 ChoiceCallback 的子类
 class RealmChoiceCallback
SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.callback.ConfirmationCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.ConfirmationCallback
的使用

没有 javax.security.auth.callback.ConfirmationCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.callback.LanguageCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.LanguageCallback
的使用

没有 javax.security.auth.callback.LanguageCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.callback.NameCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.NameCallback
的使用

没有 javax.security.auth.callback.NameCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.callback.PasswordCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.PasswordCallback
的使用

没有 javax.security.auth.callback.PasswordCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.callback.TextInputCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.TextInputCallback
的使用

使用 TextInputCallback 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 TextInputCallback 的使用

javax.security.sasl 中 TextInputCallback 的子类
 class RealmCallback
SaslClient 和 SaslServer 使用此回调来获取领域信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.callback.TextOutputCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.TextOutputCallback
的使用

没有 javax.security.auth.callback.TextOutputCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.callback.UnsupportedCallbackException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.UnsupportedCallbackException
的使用

使用 UnsupportedCallbackException 的软件包
javax.security.auth.callback 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。

javax.security.auth.callback 中 UnsupportedCallbackException 的使用

抛出 UnsupportedCallbackException 的 javax.security.auth.callback 中的方法
 void CallbackHandler.handle(Callback[] callbacks)
获取或显示在提供的 Callback 中请求的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.AuthPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.AuthPermission
的使用

没有 javax.security.auth.AuthPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.security.auth.Destroyable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.Destroyable
的使用

使用 Destroyable 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

java.security 中 Destroyable 的使用

实现 Destroyable 的 java.security 中的类
static class KeyStore.PasswordProtection
ProtectionParameter 的一个基于密码的实现。

javax.security.auth.kerberos 中 Destroyable 的使用

实现 Destroyable 的 javax.security.auth.kerberos 中的类
class | KerberosKey 此类为 Kerberos 主体封装一个长期秘密密钥。
class | KerberosTicket 此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。

javax.security.auth.x500 中 Destroyable 的使用

实现 Destroyable 的 javax.security.auth.x500 中的类
 class X500PrivateCredential
此类表示一个 X500PrivateCredential。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.DestroyFailedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.DestroyFailedException
的使用

使用 DestroyFailedException 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。

java.security 中 DestroyFailedException 的使用

抛出 DestroyFailedException 的 java.security 中的方法
 void KeyStore.PasswordProtection.destroy()
清除密码。

javax.security.auth 中 DestroyFailedException 的使用

抛出 DestroyFailedException 的 javax.security.auth 中的方法
 void Destroyable.destroy()
销毁此 Object。

javax.security.auth.kerberos 中 DestroyFailedException 的使用

抛出 DestroyFailedException 的 javax.security.auth.kerberos 中的方法
void | KerberosKey.destroy() 销毁此密钥。
void | KerberosTicket.destroy() 销毁票据和存储在其中的敏感信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.Policy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.Policy
的使用

使用 Policy 的软件包
javax.security.auth 此包提供用于进行验证和授权的框架。

javax.security.auth 中 Policy 的使用

返回 Policy 的 javax.security.auth 中的方法
static Policy Policy.getPolicy()
已过时。 返回安装的 Policy 对象。

参数类型为 Policy 的 javax.security.auth 中的方法
static void Policy.setPolicy(Policy policy)
已过时。 设置系统级 Policy 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.PrivateCredentialPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.PrivateCredentialPermission
的使用

没有 javax.security.auth.PrivateCredentialPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.security.auth.Refreshable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.Refreshable
的使用

使用 Refreshable 的软件包
javax.security.auth.kerberos 此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth.kerberos 中 Refreshable 的使用

实现 Refreshable 的 javax.security.auth.kerberos 中的类
 class KerberosTicket
此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.RefreshFailedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.RefreshFailedException
的使用

使用 RefreshFailedException 的软件包
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth 中 RefreshFailedException 的使用

抛出 RefreshFailedException 的 javax.security.auth 中的方法
 void Refreshable.refresh()
更新或延长此 Object 的有效期。

javax.security.auth.kerberos 中 RefreshFailedException 的使用

抛出 RefreshFailedException 的 javax.security.auth.kerberos 中的方法
 void KerberosTicket.refresh()
延长此票据的有效期。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.Subject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.Subject
的使用

使用 Subject 的软件包
java.security | 为安全框架提供类和接口。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。

java.security 中 Subject 的使用

参数类型为 Subject 的 java.security 中的方法
abstract  void AuthProvider.login(Subject subject, CallbackHandler handler)
登录到此 provider 中。

javax.management.remote 中 Subject 的使用

返回 Subject 的 javax.management.remote 中的方法
 Subject JMXAuthenticator.authenticate(Object credentials)
用给定的客户端凭据验证 MBeanServerConnection 客户端。

参数类型为 Subject 的 javax.management.remote 中的方法
 MBeanServerConnection JMXConnector.getMBeanServerConnection(Subject delegationSubject)
返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。

javax.management.remote.rmi 中 Subject 的使用

参数类型为 Subject 的 javax.management.remote.rmi 中的方法
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 String RMIConnection.getDefaultDomain(Subject delegationSubject)
处理 MBeanServerConnection.getDefaultDomain() 方法。
 String RMIConnectionImpl.getDefaultDomain(Subject delegationSubject)
 String RMIConnectionImpl_Stub.getDefaultDomain(Subject $param_Subject_1)
 String[] RMIConnection.getDomains(Subject delegationSubject)
处理 MBeanServerConnection.getDomains() 方法。
 String[] RMIConnectionImpl.getDomains(Subject delegationSubject)
 String[] RMIConnectionImpl_Stub.getDomains(Subject $param_Subject_1)
 Integer RMIConnection.getMBeanCount(Subject delegationSubject)
处理 MBeanServerConnection.getMBeanCount() 方法。
 Integer RMIConnectionImpl.getMBeanCount(Subject delegationSubject)
 Integer RMIConnectionImpl_Stub.getMBeanCount(Subject $param_Subject_1)
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 MBeanServerConnection RMIConnector.getMBeanServerConnection(Subject delegationSubject)
 ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 boolean RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 boolean RMIConnection.isRegistered(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
 boolean RMIConnectionImpl.isRegistered(ObjectName name, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isRegistered(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
protected  RMIConnection RMIIIOPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。
protected  RMIConnection RMIJRMPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。
protected abstract  RMIConnection RMIServerImpl.makeClient(String connectionId, Subject subject)
创建一个新的客户端连接。
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
 void RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
 void RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

参数类型为 Subject 的 javax.management.remote.rmi 中的构造方法
RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。

javax.security.auth 中 Subject 的使用

返回 Subject 的 javax.security.auth 中的方法
Subject | SubjectDomainCombiner.getSubject() 获取与此 SubjectDomainCombiner 关联的 Subject。
static Subject | Subject.getSubject(AccessControlContext acc) 获取与提供的 AccessControlContext 关联的 Subject。

参数类型为 Subject 的 javax.security.auth 中的方法
static
<T> T
Subject.doAs(Subject subject, PrivilegedAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
Subject.doAs(Subject subject, PrivilegedExceptionAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。
abstract  PermissionCollection Policy.getPermissions(Subject subject, CodeSource cs)
已过时。 获取授予与指定的 CodeSource 关联的 Principals 的 Permissions。

参数类型为 Subject 的 javax.security.auth 中的构造方法
SubjectDomainCombiner(Subject subject)
将提供的 Subject 与此 SubjectDomainCombiner 关联。

javax.security.auth.login 中 Subject 的使用

返回 Subject 的 javax.security.auth.login 中的方法
 Subject LoginContext.getSubject()
返回已进行验证的 Subject。

参数类型为 Subject 的 javax.security.auth.login 中的构造方法
LoginContext(String name, Subject subject)
使用 name 和 Subject 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

javax.security.auth.spi 中 Subject 的使用

参数类型为 Subject 的 javax.security.auth.spi 中的方法
 void LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
初始化此 LoginModule。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.SubjectDomainCombiner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.SubjectDomainCombiner
的使用

没有 javax.security.auth.SubjectDomainCombiner 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.security.auth.kerberos (Java 2 Platform SE 6)

 javax.security.auth.kerberos
类
DelegationPermission
KerberosKey
KerberosPrincipal
KerberosTicket
ServicePermission


类 javax.security.auth.kerberos.DelegationPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.kerberos.DelegationPermission
的使用

没有 javax.security.auth.kerberos.DelegationPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.kerberos.KerberosKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.kerberos.KerberosKey
的使用

没有 javax.security.auth.kerberos.KerberosKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.kerberos.KerberosPrincipal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.kerberos.KerberosPrincipal
的使用

使用 KerberosPrincipal 的软件包
javax.security.auth.kerberos 此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth.kerberos 中 KerberosPrincipal 的使用

返回 KerberosPrincipal 的 javax.security.auth.kerberos 中的方法
KerberosPrincipal | KerberosTicket.getClient() 返回与此票据有关联的客户端主体。
KerberosPrincipal | KerberosKey.getPrincipal() 返回此密钥所属的主体。
KerberosPrincipal | KerberosTicket.getServer() 返回与此票据有关联的服务主体。

参数类型为 KerberosPrincipal 的 javax.security.auth.kerberos 中的构造方法
KerberosKey(KerberosPrincipal principal, byte[] keyBytes, int keyType, int versionNum)
当已知密钥类型和密钥版本号时，根据给出的字节构造 KerberosKey。
KerberosKey(KerberosPrincipal principal, char[] password, String algorithm)
根据主体的密码构造 KerberosKey。
KerberosTicket(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
使用客户端从 KDC 接收的或从缓存中读取的证书信息构造 KerberosTicket。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.kerberos.KerberosTicket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.kerberos.KerberosTicket
的使用

没有 javax.security.auth.kerberos.KerberosTicket 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.kerberos.ServicePermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.kerberos.ServicePermission
的使用

没有 javax.security.auth.kerberos.ServicePermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.security.auth.login (Java 2 Platform SE 6)

 javax.security.auth.login
接口
Configuration.Parameters
类
AppConfigurationEntry
AppConfigurationEntry.LoginModuleControlFlag
Configuration
ConfigurationSpi
LoginContext
异常
AccountException
AccountExpiredException
AccountLockedException
AccountNotFoundException
CredentialException
CredentialExpiredException
CredentialNotFoundException
FailedLoginException
LoginException


类 javax.security.auth.login.AccountException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AccountException
的使用

使用 AccountException 的软件包
javax.security.auth.login 此包提供可插入的验证框架。

javax.security.auth.login 中 AccountException 的使用

javax.security.auth.login 中 AccountException 的子类
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.AccountExpiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AccountExpiredException
的使用

没有 javax.security.auth.login.AccountExpiredException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.AccountLockedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AccountLockedException
的使用

没有 javax.security.auth.login.AccountLockedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.AccountNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AccountNotFoundException
的使用

没有 javax.security.auth.login.AccountNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.AppConfigurationEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AppConfigurationEntry
的使用

使用 AppConfigurationEntry 的软件包
javax.security.auth.login 此包提供可插入的验证框架。

javax.security.auth.login 中 AppConfigurationEntry 的使用

返回 AppConfigurationEntry 的 javax.security.auth.login 中的方法
protected abstract AppConfigurationEntry[] | ConfigurationSpi.engineGetAppConfigurationEntry(String name) 获取指定 name 的 AppConfigurationEntry。
abstract AppConfigurationEntry[] | Configuration.getAppConfigurationEntry(String name) 获取此 Configuration 中指定 name 的 AppConfigurationEntry。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
的使用

使用 AppConfigurationEntry.LoginModuleControlFlag 的软件包
javax.security.auth.login 此包提供可插入的验证框架。

javax.security.auth.login 中 AppConfigurationEntry.LoginModuleControlFlag 的使用

声明为 AppConfigurationEntry.LoginModuleControlFlag 的 javax.security.auth.login 中的字段
static AppConfigurationEntry.LoginModuleControlFlag | AppConfigurationEntry.LoginModuleControlFlag.OPTIONAL 可供选择的 LoginModule。
static AppConfigurationEntry.LoginModuleControlFlag | AppConfigurationEntry.LoginModuleControlFlag.REQUIRED 所需的 LoginModule。
static AppConfigurationEntry.LoginModuleControlFlag | AppConfigurationEntry.LoginModuleControlFlag.REQUISITE 必需的 LoginModule。
static AppConfigurationEntry.LoginModuleControlFlag | AppConfigurationEntry.LoginModuleControlFlag.SUFFICIENT 足够的 LoginModule。

返回 AppConfigurationEntry.LoginModuleControlFlag 的 javax.security.auth.login 中的方法
 AppConfigurationEntry.LoginModuleControlFlag AppConfigurationEntry.getControlFlag()
返回此 LoginModule 的 controlFlag（REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL 中的任何一个）。

参数类型为 AppConfigurationEntry.LoginModuleControlFlag 的 javax.security.auth.login 中的构造方法
AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
此类的默认构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.Configuration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.Configuration
的使用

使用 Configuration 的软件包
javax.security.auth.login 此包提供可插入的验证框架。

javax.security.auth.login 中 Configuration 的使用

返回 Configuration 的 javax.security.auth.login 中的方法
static Configuration | Configuration.getConfiguration() 获取已安装的登录 Configuration。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, Provider provider) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, String provider) 返回指定类型的 Configuration 对象。

参数类型为 Configuration 的 javax.security.auth.login 中的方法
static void Configuration.setConfiguration(Configuration configuration)
设置登录 Configuration。

参数类型为 Configuration 的 javax.security.auth.login 中的构造方法
LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.security.auth.login.Configuration.Parameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.login.Configuration.Parameters
的使用

使用 Configuration.Parameters 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth.login | 此包提供可插入的验证框架。

java.security 中 Configuration.Parameters 的使用

实现 Configuration.Parameters 的 java.security 中的类
 class URIParameter
包含一个 URI 的参数，该 URI 指向用于 PolicySpi 或 ConfigurationSpi 实现的数据。

javax.security.auth.login 中 Configuration.Parameters 的使用

返回 Configuration.Parameters 的 javax.security.auth.login 中的方法
 Configuration.Parameters Configuration.getParameters()
返回 Configuration 参数。

参数类型为 Configuration.Parameters 的 javax.security.auth.login 中的方法
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, Provider provider) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, String provider) 返回指定类型的 Configuration 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.ConfigurationSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.ConfigurationSpi
的使用

没有 javax.security.auth.login.ConfigurationSpi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.CredentialException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.CredentialException
的使用

使用 CredentialException 的软件包
javax.security.auth.login 此包提供可插入的验证框架。

javax.security.auth.login 中 CredentialException 的使用

javax.security.auth.login 中 CredentialException 的子类
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.CredentialExpiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.CredentialExpiredException
的使用

没有 javax.security.auth.login.CredentialExpiredException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.CredentialNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.CredentialNotFoundException
的使用

没有 javax.security.auth.login.CredentialNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.FailedLoginException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.FailedLoginException
的使用

没有 javax.security.auth.login.FailedLoginException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.LoginContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.LoginContext
的使用

没有 javax.security.auth.login.LoginContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.login.LoginException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.LoginException
的使用

使用 LoginException 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。

java.security 中 LoginException 的使用

抛出 LoginException 的 java.security 中的方法
abstract void | AuthProvider.login(Subject subject, CallbackHandler handler) 登录到此 provider 中。
abstract void | AuthProvider.logout() 在此 provider 中注销。

javax.security.auth.login 中 LoginException 的使用

javax.security.auth.login 中 LoginException 的子类
class | AccountException 一般的帐户异常。
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。
class | CredentialException 一般证书异常。
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。
class | FailedLoginException 当用户验证失败时抛出此异常。

抛出 LoginException 的 javax.security.auth.login 中的方法
void | LoginContext.login() 执行验证。
void | LoginContext.logout() 注销 Subject。

抛出 LoginException 的 javax.security.auth.login 中的构造方法
LoginContext(String name)
使用 name 实例化一个新 LoginContext 对象。
LoginContext(String name, CallbackHandler callbackHandler)
使用 name 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject)
使用 name 和 Subject 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

javax.security.auth.spi 中 LoginException 的使用

抛出 LoginException 的 javax.security.auth.spi 中的方法
boolean | LoginModule.abort() 中止验证过程的方法（阶段 2）。
boolean | LoginModule.commit() 提交验证过程的方法（阶段 2）。
boolean | LoginModule.login() 对 Subject 进行验证的方法（阶段 1）。
boolean | LoginModule.logout() 注销 Subject 的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.security.auth.spi (Java 2 Platform SE 6)

 javax.security.auth.spi
接口
LoginModule


接口 javax.security.auth.spi.LoginModule 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.spi.LoginModule
的使用

没有 javax.security.auth.spi.LoginModule 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.security.auth.x500 (Java 2 Platform SE 6)

 javax.security.auth.x500
类
X500Principal
X500PrivateCredential


类 javax.security.auth.x500.X500Principal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.x500.X500Principal
的使用

使用 X500Principal 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 X500Principal 的使用

返回 X500Principal 的 java.security.cert 中的方法
X500Principal | TrustAnchor.getCA() 以 X500Principal 的形式返回最受信任的 CA 的名称。
X500Principal | X509CRLEntry.getCertificateIssuer() 获取此项所描述的 X509Certificate 的发布方。
X500Principal | X509CertSelector.getIssuer() 以 X500Principal 的形式返回 issuer 标准。
X500Principal | X509CRL.getIssuerX500Principal() 以 X500Principal 的形式返回 CRL 的发布方（发布方标识名）值。
X500Principal | X509Certificate.getIssuerX500Principal() 以 X500Principal 的形式返回证书的发布方（发布方标识名）值。
X500Principal | X509CertSelector.getSubject() 以 X500Principal 的形式返回 subject 标准。
X500Principal | X509Certificate.getSubjectX500Principal() 以 X500Principal 的形式返回证书的主体（主体标识名）值。

返回变量类型为 X500Principal 的类型的 java.security.cert 中的方法
 Collection<X500Principal> X509CRLSelector.getIssuers()
返回 issuerNames 标准。

参数类型为 X500Principal 的 java.security.cert 中的方法
void | X509CRLSelector.addIssuer(X500Principal issuer) 向 issuerNames 标准中添加名称。
void | X509CertSelector.setIssuer(X500Principal issuer) 设置 issuer 标准。
void | X509CertSelector.setSubject(X500Principal subject) 设置 subject 标准。

类型变量类型为 X500Principal 的 java.security.cert 中的方法参数
 void X509CRLSelector.setIssuers(Collection<X500Principal> issuers)
设置 issuerNames 标准。

参数类型为 X500Principal 的 java.security.cert 中的构造方法
TrustAnchor(X500Principal caPrincipal, PublicKey pubKey, byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以 X500Principal 和公钥的形式指定最受信任的 CA。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.auth.x500.X500PrivateCredential 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.x500.X500PrivateCredential
的使用

没有 javax.security.auth.x500.X500PrivateCredential 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.security.cert (Java 2 Platform SE 6)

 javax.security.cert
类
Certificate
X509Certificate
异常
CertificateEncodingException
CertificateException
CertificateExpiredException
CertificateNotYetValidException
CertificateParsingException


类 javax.security.cert.Certificate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.Certificate
的使用

使用 Certificate 的软件包
javax.security.cert 为公钥证书提供类。

javax.security.cert 中 Certificate 的使用

javax.security.cert 中 Certificate 的子类
 class X509Certificate
X.509 v1 证书的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.cert.CertificateEncodingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.CertificateEncodingException
的使用

使用 CertificateEncodingException 的软件包
javax.security.cert 为公钥证书提供类。

javax.security.cert 中 CertificateEncodingException 的使用

抛出 CertificateEncodingException 的 javax.security.cert 中的方法
abstract  byte[] Certificate.getEncoded()
返回此证书的编码形式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.cert.CertificateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.CertificateException
的使用

使用 CertificateException 的软件包
javax.security.cert 为公钥证书提供类。

javax.security.cert 中 CertificateException 的使用

javax.security.cert 中 CertificateException 的子类
class | CertificateEncodingException 证书编码异常。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书不再有效异常。
class | CertificateParsingException 证书解析异常。

抛出 CertificateException 的 javax.security.cert 中的方法
static X509Certificate | X509Certificate.getInstance(byte[] certData) 实例化一个 X509Certificate 对象，并使用指定的 byte 数组初始化它。
static X509Certificate | X509Certificate.getInstance(InputStream inStream) 实例化一个 X509Certificate 对象，并使用从输入流 inStream 读取的数据初始化它。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.cert.CertificateExpiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.CertificateExpiredException
的使用

使用 CertificateExpiredException 的软件包
javax.security.cert 为公钥证书提供类。

javax.security.cert 中 CertificateExpiredException 的使用

抛出 CertificateExpiredException 的 javax.security.cert 中的方法
abstract void | X509Certificate.checkValidity() 检查证书目前是否有效。
abstract void | X509Certificate.checkValidity(Date date) 检查指定的日期是否处于证书的有效期内。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.cert.CertificateNotYetValidException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.CertificateNotYetValidException
的使用

使用 CertificateNotYetValidException 的软件包
javax.security.cert 为公钥证书提供类。

javax.security.cert 中 CertificateNotYetValidException 的使用

抛出 CertificateNotYetValidException 的 javax.security.cert 中的方法
abstract void | X509Certificate.checkValidity() 检查证书目前是否有效。
abstract void | X509Certificate.checkValidity(Date date) 检查指定的日期是否处于证书的有效期内。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.cert.CertificateParsingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.CertificateParsingException
的使用

没有 javax.security.cert.CertificateParsingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.cert.X509Certificate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.X509Certificate
的使用

使用 X509Certificate 的软件包
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.cert | 为公钥证书提供类。

javax.net.ssl 中 X509Certificate 的使用

返回 X509Certificate 的 javax.net.ssl 中的方法
X509Certificate[] | HandshakeCompletedEvent.getPeerCertificateChain() 返回同位体的标识，同位体是作为定义会话的一部分而标识的。
X509Certificate[] | SSLSession.getPeerCertificateChain() 返回同级身份，该同级身份被标识作为定义会话的一部分。

javax.security.cert 中 X509Certificate 的使用

返回 X509Certificate 的 javax.security.cert 中的方法
static X509Certificate | X509Certificate.getInstance(byte[] certData) 实例化一个 X509Certificate 对象，并使用指定的 byte 数组初始化它。
static X509Certificate | X509Certificate.getInstance(InputStream inStream) 实例化一个 X509Certificate 对象，并使用从输入流 inStream 读取的数据初始化它。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.security.sasl (Java 2 Platform SE 6)

 javax.security.sasl
接口
SaslClient
SaslClientFactory
SaslServer
SaslServerFactory
类
AuthorizeCallback
RealmCallback
RealmChoiceCallback
Sasl
异常
AuthenticationException
SaslException


类 javax.security.sasl.AuthenticationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.AuthenticationException
的使用

没有 javax.security.sasl.AuthenticationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.sasl.AuthorizeCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.AuthorizeCallback
的使用

没有 javax.security.sasl.AuthorizeCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.sasl.RealmCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.RealmCallback
的使用

没有 javax.security.sasl.RealmCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.sasl.RealmChoiceCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.RealmChoiceCallback
的使用

没有 javax.security.sasl.RealmChoiceCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.sasl.Sasl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.Sasl
的使用

没有 javax.security.sasl.Sasl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.security.sasl.SaslClient 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.sasl.SaslClient
的使用

使用 SaslClient 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 SaslClient 的使用

返回 SaslClient 的 javax.security.sasl 中的方法
static SaslClient | Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
SaslClient | SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.security.sasl.SaslClientFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.sasl.SaslClientFactory
的使用

使用 SaslClientFactory 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 SaslClientFactory 的使用

返回变量类型为 SaslClientFactory 的类型的 javax.security.sasl 中的方法
static Enumeration<SaslClientFactory> Sasl.getSaslClientFactories()
获得用于生成 SaslClient 的已知工厂的枚举。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.security.sasl.SaslException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.SaslException
的使用

使用 SaslException 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 SaslException 的使用

javax.security.sasl 中 SaslException 的子类
 class AuthenticationException
此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。

抛出 SaslException 的 javax.security.sasl 中的方法
static SaslClient | Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
SaslClient | SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
static SaslServer | Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 为指定机制创建一个 SaslServer。
SaslServer | SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslServer。
void | SaslClient.dispose() 处置 SaslClient 可能使用的所有系统资源或安全敏感信息。
void | SaslServer.dispose() 处置 SaslServer 可能使用的所有系统资源或安全敏感信息。
byte[] | SaslClient.evaluateChallenge(byte[] challenge) 评估 challenge 数据并生成一个响应。
byte[] | SaslServer.evaluateResponse(byte[] response) 评估响应数据并生成一个 challenge。
byte[] | SaslClient.unwrap(byte[] incoming, int offset, int len) 解包接收自服务器的 byte 数组。
byte[] | SaslServer.unwrap(byte[] incoming, int offset, int len) 解包接收自客户端的 byte 数组。
byte[] | SaslClient.wrap(byte[] outgoing, int offset, int len) 包装要发送到服务器的 byte 数组。
byte[] | SaslServer.wrap(byte[] outgoing, int offset, int len) 包装要发送到客户端的 byte 数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.security.sasl.SaslServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.sasl.SaslServer
的使用

使用 SaslServer 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 SaslServer 的使用

返回 SaslServer 的 javax.security.sasl 中的方法
static SaslServer | Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 为指定机制创建一个 SaslServer。
SaslServer | SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslServer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.security.sasl.SaslServerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.sasl.SaslServerFactory
的使用

使用 SaslServerFactory 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 SaslServerFactory 的使用

返回变量类型为 SaslServerFactory 的类型的 javax.security.sasl 中的方法
static Enumeration<SaslServerFactory> Sasl.getSaslServerFactories()
获得用于生成 SaslServer 的已知工厂的枚举。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.sound.midi (Java 2 Platform SE 6)

 javax.sound.midi
接口
ControllerEventListener
MetaEventListener
MidiChannel
MidiDevice
Receiver
Sequencer
Soundbank
Synthesizer
Transmitter
类
Instrument
MetaMessage
MidiDevice.Info
MidiEvent
MidiFileFormat
MidiMessage
MidiSystem
Patch
Sequence
Sequencer.SyncMode
ShortMessage
SoundbankResource
SysexMessage
Track
VoiceStatus
异常
InvalidMidiDataException
MidiUnavailableException


接口 javax.sound.midi.ControllerEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.ControllerEventListener
的使用

使用 ControllerEventListener 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 ControllerEventListener 的使用

参数类型为 ControllerEventListener 的 javax.sound.midi 中的方法
int[] | Sequencer.addControllerEventListener(ControllerEventListener listener, int[] controllers) 注册一个控件事件侦听器，以便在 sequencer 处理所请求的一种或多种类型的控制更改事件时接收通知。
int[] | Sequencer.removeControllerEventListener(ControllerEventListener listener, int[] controllers) 移除侦听一类或多类控件事件的控件事件侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.Instrument 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.Instrument
的使用

使用 Instrument 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Instrument 的使用

返回 Instrument 的 javax.sound.midi 中的方法
Instrument[] | Synthesizer.getAvailableInstruments() 获得该合成器随附的乐器列表。
Instrument | Soundbank.getInstrument(Patch patch) 获得取自给定 Patch 的 Instrument。
Instrument[] | Soundbank.getInstruments() 获得包含在此音库中的乐器列表。
Instrument[] | Synthesizer.getLoadedInstruments() 获得当前加载到此 Synthesizer 中的乐器列表。

参数类型为 Instrument 的 javax.sound.midi 中的方法
boolean | Synthesizer.loadInstrument(Instrument instrument) 让特定的乐器可用于合成。
boolean | Synthesizer.remapInstrument(Instrument from, Instrument to) 重新映射一个乐器。
void | Synthesizer.unloadInstrument(Instrument instrument) 卸载特定的乐器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.InvalidMidiDataException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.InvalidMidiDataException
的使用

使用 InvalidMidiDataException 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 InvalidMidiDataException 的使用

抛出 InvalidMidiDataException 的 javax.sound.midi 中的方法
protected int | ShortMessage.getDataLength(int status) 检索与特定状态字节值关联的数据字节数。
static MidiFileFormat | MidiSystem.getMidiFileFormat(File file) 获得指定 File 的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(InputStream stream) 获得指定的输入流中数据的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(URL url) 获得指定 URL 中数据的 MIDI 文件格式。
static Sequence | MidiSystem.getSequence(File file) 从指定的 File 获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(InputStream stream) 从指定的输入流获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(URL url) 从指定的 URL 获得 MIDI 序列。
static Soundbank | MidiSystem.getSoundbank(File file) 通过从指定的 File 读取来构造一个 Soundbank。
static Soundbank | MidiSystem.getSoundbank(InputStream stream) 通过从指定的流读取来构造一个 MIDI 音库。
static Soundbank | MidiSystem.getSoundbank(URL url) 通过从指定的 URL 处读取来构造一个 Soundbank。
protected void | MidiMessage.setMessage(byte[] data, int length) 为 MIDI 消息设置数据。
void | SysexMessage.setMessage(byte[] data, int length) 为系统独占消息设置数据。
void | ShortMessage.setMessage(int status) 为不带任何数据字节的 MIDI 消息设置参数。
void | MetaMessage.setMessage(int type, byte[] data, int length) 为 MetaMessage 设置消息参数。
void | SysexMessage.setMessage(int status, byte[] data, int length) 为系统独占消息设置数据。
void | ShortMessage.setMessage(int status, int data1, int data2) 为带一个或两个数据字节的 MIDI 消息设置参数。
void | ShortMessage.setMessage(int command, int channel, int data1, int data2) 为带两个数据字节的通道消息设置短消息参数。
void | Sequencer.setSequence(InputStream stream) 设置 sequencer 所操作的当前 sequence。
void | Sequencer.setSequence(Sequence sequence) 设置 sequencer 所操作的当前 sequence。

抛出 InvalidMidiDataException 的 javax.sound.midi 中的构造方法
Sequence(float divisionType, int resolution)
构造具有指定的定时 division 类型和定时精度的新 MIDI Sequence。
Sequence(float divisionType, int resolution, int numTracks)
构造具有指定的定时 division 类型、定时精度和轨道数的新 MIDI Sequence。

javax.sound.midi.spi 中 InvalidMidiDataException 的使用

抛出 InvalidMidiDataException 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(File file) 获得提供的 File 的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(InputStream stream) 获得所提供的输入流的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(URL url) 获得提供的 URL 的 MIDI 文件格式。
abstract Sequence | MidiFileReader.getSequence(File file) 从提供的 File 获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(InputStream stream) 从提供的输入流获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(URL url) 从提供的 URL 获得 MIDI 序列。
abstract Soundbank | SoundbankReader.getSoundbank(File file) 从提供的 File 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(InputStream stream) 从提供的 InputStream 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(URL url) 从提供的 URL 获得音库对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.midi.MetaEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.MetaEventListener
的使用

使用 MetaEventListener 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MetaEventListener 的使用

参数类型为 MetaEventListener 的 javax.sound.midi 中的方法
boolean | Sequencer.addMetaEventListener(MetaEventListener listener) 注册一个元事件侦听器，以便在 sequence 中遇到元事件并由此 sequencer 处理时接收通知。
void | Sequencer.removeMetaEventListener(MetaEventListener listener) 从此 sequencer 的已注册侦听器列表中移除指定的元事件侦听器（如果实际上此侦听器已注册）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.MetaMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MetaMessage
的使用

使用 MetaMessage 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MetaMessage 的使用

参数类型为 MetaMessage 的 javax.sound.midi 中的方法
 void MetaEventListener.meta(MetaMessage meta)
在 Sequencer 遇到并处理了一个它正在处理的 Sequence 中的 MetaMessage 时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.midi.MidiChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.MidiChannel
的使用

使用 MidiChannel 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MidiChannel 的使用

返回 MidiChannel 的 javax.sound.midi 中的方法
 MidiChannel[] Synthesizer.getChannels()
获得此合成器控制的一组 MIDI 通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.midi.MidiDevice 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.MidiDevice
的使用

使用 MidiDevice 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 MidiDevice 的使用

javax.sound.midi 中 MidiDevice 的子接口
interface | Sequencer 回放 MIDI sequence 的硬件或软件设备就是所谓的 sequencer。
interface | Synthesizer Synthesizer 生成声音。

返回 MidiDevice 的 javax.sound.midi 中的方法
static MidiDevice MidiSystem.getMidiDevice(MidiDevice.Info info)
获得请求的 MIDI 设备。

javax.sound.midi.spi 中 MidiDevice 的使用

返回 MidiDevice 的 javax.sound.midi.spi 中的方法
abstract  MidiDevice MidiDeviceProvider.getDevice(MidiDevice.Info info)
获得由信息对象表示的设备的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.MidiDevice.Info 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiDevice.Info
的使用

使用 MidiDevice.Info 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 MidiDevice.Info 的使用

返回 MidiDevice.Info 的 javax.sound.midi 中的方法
MidiDevice.Info | MidiDevice.getDeviceInfo() 获得有关设备的信息，其中包括包含了其名称、供应商和描述的 Java 类和 Strings。
static MidiDevice.Info[] | MidiSystem.getMidiDeviceInfo() 获得信息对象数组，表示系统中可用的所有 MIDI 设备集。

参数类型为 MidiDevice.Info 的 javax.sound.midi 中的方法
static MidiDevice MidiSystem.getMidiDevice(MidiDevice.Info info)
获得请求的 MIDI 设备。

javax.sound.midi.spi 中 MidiDevice.Info 的使用

返回 MidiDevice.Info 的 javax.sound.midi.spi 中的方法
abstract  MidiDevice.Info[] MidiDeviceProvider.getDeviceInfo()
获得表示设备或由此 MidiDeviceProvider 提供的设备的信息对象集合。

参数类型为 MidiDevice.Info 的 javax.sound.midi.spi 中的方法
abstract MidiDevice | MidiDeviceProvider.getDevice(MidiDevice.Info info) 获得由信息对象表示的设备的实例。
boolean | MidiDeviceProvider.isDeviceSupported(MidiDevice.Info info) 指示该设备提供者是否支持由指定的设备信息对象表示的设备。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.MidiEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiEvent
的使用

使用 MidiEvent 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MidiEvent 的使用

返回 MidiEvent 的 javax.sound.midi 中的方法
 MidiEvent Track.get(int index)
获得位于指定索引处的事件。

参数类型为 MidiEvent 的 javax.sound.midi 中的方法
boolean | Track.add(MidiEvent event) 将新事件添加至音轨。
boolean | Track.remove(MidiEvent event) 从音轨中移除指定的事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.MidiFileFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiFileFormat
的使用

使用 MidiFileFormat 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 MidiFileFormat 的使用

返回 MidiFileFormat 的 javax.sound.midi 中的方法
static MidiFileFormat | MidiSystem.getMidiFileFormat(File file) 获得指定 File 的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(InputStream stream) 获得指定的输入流中数据的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(URL url) 获得指定 URL 中数据的 MIDI 文件格式。

javax.sound.midi.spi 中 MidiFileFormat 的使用

返回 MidiFileFormat 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(File file) 获得提供的 File 的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(InputStream stream) 获得所提供的输入流的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(URL url) 获得提供的 URL 的 MIDI 文件格式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.MidiMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiMessage
的使用

使用 MidiMessage 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MidiMessage 的使用

javax.sound.midi 中 MidiMessage 的子类
class | MetaMessage MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。
class | ShortMessage ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。
class | SysexMessage 表示 MIDI 系统独占消息 SysexMessage 对象。

返回 MidiMessage 的 javax.sound.midi 中的方法
 MidiMessage MidiEvent.getMessage()
获得事件中包含的 MIDI 消息。

参数类型为 MidiMessage 的 javax.sound.midi 中的方法
 void Receiver.send(MidiMessage message, long timeStamp)
向接收器发送一个 MIDI 消息和时间戳。

参数类型为 MidiMessage 的 javax.sound.midi 中的构造方法
MidiEvent(MidiMessage message, long tick)
构造一个新的 MidiEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.MidiSystem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiSystem
的使用

没有 javax.sound.midi.MidiSystem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.MidiUnavailableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiUnavailableException
的使用

使用 MidiUnavailableException 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MidiUnavailableException 的使用

抛出 MidiUnavailableException 的 javax.sound.midi 中的方法
static MidiDevice | MidiSystem.getMidiDevice(MidiDevice.Info info) 获得请求的 MIDI 设备。
Receiver | MidiDevice.getReceiver() 获得 MIDI 设备可通过其接收 MIDI 数据的 MIDI IN 接收器。
static Receiver | MidiSystem.getReceiver() 从外部 MIDI 端口或其他默认设备获得 MIDI 接收器。
static Sequencer | MidiSystem.getSequencer() 获得连接到默认设备上的默认的 Sequencer。
static Sequencer | MidiSystem.getSequencer(boolean connected) 获得默认的 Sequencer，它可选地连接到默认设备上。
static Synthesizer | MidiSystem.getSynthesizer() 获得默认的合成器。
Transmitter | MidiDevice.getTransmitter() 获得 MIDI 设备将从其传输 MIDI 数据的 MIDI OUT 连接。
static Transmitter | MidiSystem.getTransmitter() 从外部 MIDI 端口或其他默认源获得 MIDI 传输器。
void | MidiDevice.open() 打开设备，指示它现在应获取任何所需的系统资源然后开始运行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.Patch 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.Patch
的使用

使用 Patch 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Patch 的使用

返回 Patch 的 javax.sound.midi 中的方法
Patch | Instrument.getPatch() 获得 Patch 对象，该对象指示此乐器在合成器中存储位置处的库和程序号。
Patch[] | Sequence.getPatchList() 获得此 Sequence 中引用的包列表。

参数类型为 Patch 的 javax.sound.midi 中的方法
Instrument | Soundbank.getInstrument(Patch patch) 获得取自给定 Patch 的 Instrument。
boolean | Synthesizer.loadInstruments(Soundbank soundbank, Patch[] patchList) 从指定 Soundbank 加载指定修补程序所引用的乐器。
void | Synthesizer.unloadInstruments(Soundbank soundbank, Patch[] patchList) 从指定的 MIDI 音库中卸载指定修补程序所引用的乐器。

参数类型为 Patch 的 javax.sound.midi 中的构造方法
Instrument(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)
从指定的 Patch 构造一个新的 MIDI 乐器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.midi.Receiver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.Receiver
的使用

使用 Receiver 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Receiver 的使用

返回 Receiver 的 javax.sound.midi 中的方法
Receiver | MidiDevice.getReceiver() 获得 MIDI 设备可通过其接收 MIDI 数据的 MIDI IN 接收器。
static Receiver | MidiSystem.getReceiver() 从外部 MIDI 端口或其他默认设备获得 MIDI 接收器。
Receiver | Transmitter.getReceiver() 获得此传输器将向其传送 MIDI 消息的当前接收器。

返回变量类型为 Receiver 的类型的 javax.sound.midi 中的方法
 List<Receiver> MidiDevice.getReceivers()
返回与该 MidiDevice 连接的所有当前活动的、非关闭的接收器。

参数类型为 Receiver 的 javax.sound.midi 中的方法
 void Transmitter.setReceiver(Receiver receiver)
设置此传输器将向其传送 MIDI 消息的接收器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.Sequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.Sequence
的使用

使用 Sequence 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 Sequence 的使用

返回 Sequence 的 javax.sound.midi 中的方法
Sequence | Sequencer.getSequence() 获得 Sequencer 当前所操作的 sequence。
static Sequence | MidiSystem.getSequence(File file) 从指定的 File 获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(InputStream stream) 从指定的输入流获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(URL url) 从指定的 URL 获得 MIDI 序列。

参数类型为 Sequence 的 javax.sound.midi 中的方法
static int[] | MidiSystem.getMidiFileTypes(Sequence sequence) 获得系统可从指定 sequence 写入的 MIDI 文件类型集合。
static boolean | MidiSystem.isFileTypeSupported(int fileType, Sequence sequence) 指示是否可从指示的序列写入指定文件类型的 MIDI 文件。
void | Sequencer.setSequence(Sequence sequence) 设置 sequencer 所操作的当前 sequence。
static int | MidiSystem.write(Sequence in, int type, File out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的外部文件。
static int | MidiSystem.write(Sequence in, int fileType, OutputStream out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的输出流。

javax.sound.midi.spi 中 Sequence 的使用

返回 Sequence 的 javax.sound.midi.spi 中的方法
abstract Sequence | MidiFileReader.getSequence(File file) 从提供的 File 获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(InputStream stream) 从提供的输入流获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(URL url) 从提供的 URL 获得 MIDI 序列。

参数类型为 Sequence 的 javax.sound.midi.spi 中的方法
abstract int[] | MidiFileWriter.getMidiFileTypes(Sequence sequence) 获得此文件 writer 可从指定的序列写入的文件类型。
boolean | MidiFileWriter.isFileTypeSupported(int fileType, Sequence sequence) 指示是否可从指示的序列写入指定文件类型的 MIDI 文件。
abstract int | MidiFileWriter.write(Sequence in, int fileType, File out) 写入表示指示为所提供外部文件的文件类型的 MIDI 文件的字节流。
abstract int | MidiFileWriter.write(Sequence in, int fileType, OutputStream out) 写入表示指示为所提供输出流的文件类型的 MIDI 文件的字节流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.midi.Sequencer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.Sequencer
的使用

使用 Sequencer 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Sequencer 的使用

返回 Sequencer 的 javax.sound.midi 中的方法
static Sequencer | MidiSystem.getSequencer() 获得连接到默认设备上的默认的 Sequencer。
static Sequencer | MidiSystem.getSequencer(boolean connected) 获得默认的 Sequencer，它可选地连接到默认设备上。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.Sequencer.SyncMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.Sequencer.SyncMode
的使用

使用 Sequencer.SyncMode 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Sequencer.SyncMode 的使用

声明为 Sequencer.SyncMode 的 javax.sound.midi 中的字段
static Sequencer.SyncMode | Sequencer.SyncMode.INTERNAL_CLOCK 主同步模式，它使 sequencer 从其内部时钟获取计时信息。
static Sequencer.SyncMode | Sequencer.SyncMode.MIDI_SYNC 指定使用 MIDI 时钟消息的主或辅同步模式。
static Sequencer.SyncMode | Sequencer.SyncMode.MIDI_TIME_CODE 指定使用 MIDI 时间代码的主或辅同步模式如果此模式用作主同步模式，sequencer 从 MIDI 时间代码消息获取其计时信息。
static Sequencer.SyncMode | Sequencer.SyncMode.NO_SYNC 辅同步模式，指示不应向接收者发送任何计时信息。

返回 Sequencer.SyncMode 的 javax.sound.midi 中的方法
Sequencer.SyncMode | Sequencer.getMasterSyncMode() 获得此 sequencer 的当前主同步模式。
Sequencer.SyncMode[] | Sequencer.getMasterSyncModes() 获得此 sequencer 支持的主同步模式集。
Sequencer.SyncMode | Sequencer.getSlaveSyncMode() 获得此 sequencer 的当前从同步模式。
Sequencer.SyncMode[] | Sequencer.getSlaveSyncModes() 获得此 sequencer 支持的从同步模式集。

参数类型为 Sequencer.SyncMode 的 javax.sound.midi 中的方法
void | Sequencer.setMasterSyncMode(Sequencer.SyncMode sync) 设置此 sequencer 使用的定时信息源。
void | Sequencer.setSlaveSyncMode(Sequencer.SyncMode sync) 设置此 sequencer 的从同步模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.ShortMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.ShortMessage
的使用

使用 ShortMessage 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 ShortMessage 的使用

参数类型为 ShortMessage 的 javax.sound.midi 中的方法
 void ControllerEventListener.controlChange(ShortMessage event)
当 Sequencer 遇到并处理了一个此侦听器需要的控制更改事件时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.midi.Soundbank 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.Soundbank
的使用

使用 Soundbank 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 Soundbank 的使用

返回 Soundbank 的 javax.sound.midi 中的方法
Soundbank | Synthesizer.getDefaultSoundbank() 获得合成器的默认音库（如果合成器存在）。
Soundbank | SoundbankResource.getSoundbank() 获得包含此 SoundbankResource 的音库。
static Soundbank | MidiSystem.getSoundbank(File file) 通过从指定的 File 读取来构造一个 Soundbank。
static Soundbank | MidiSystem.getSoundbank(InputStream stream) 通过从指定的流读取来构造一个 MIDI 音库。
static Soundbank | MidiSystem.getSoundbank(URL url) 通过从指定的 URL 处读取来构造一个 Soundbank。

参数类型为 Soundbank 的 javax.sound.midi 中的方法
boolean | Synthesizer.isSoundbankSupported(Soundbank soundbank) 通知调用者此合成器是否能够从指定的音库加载乐器。
boolean | Synthesizer.loadAllInstruments(Soundbank soundbank) 将指定 Soundbank 中包含的所有乐器加载到 Synthesizer 中。
boolean | Synthesizer.loadInstruments(Soundbank soundbank, Patch[] patchList) 从指定 Soundbank 加载指定修补程序所引用的乐器。
void | Synthesizer.unloadAllInstruments(Soundbank soundbank) 卸载指定 Soundbank 中包含的所有乐器。
void | Synthesizer.unloadInstruments(Soundbank soundbank, Patch[] patchList) 从指定的 MIDI 音库中卸载指定修补程序所引用的乐器。

参数类型为 Soundbank 的 javax.sound.midi 中的构造方法
Instrument(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)
从指定的 Patch 构造一个新的 MIDI 乐器。
SoundbankResource(Soundbank soundBank, String name, Class<?> dataClass)
根据给定的音库和波表索引构造一个新的 SoundbankResource。

javax.sound.midi.spi 中 Soundbank 的使用

返回 Soundbank 的 javax.sound.midi.spi 中的方法
abstract Soundbank | SoundbankReader.getSoundbank(File file) 从提供的 File 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(InputStream stream) 从提供的 InputStream 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(URL url) 从提供的 URL 获得音库对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.SoundbankResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.SoundbankResource
的使用

使用 SoundbankResource 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 SoundbankResource 的使用

javax.sound.midi 中 SoundbankResource 的子类
 class Instrument
乐器是带特定参数设置的声音合成算法，通常是为模仿现实世界的特定乐器或为获得特定音效而设计的。

返回 SoundbankResource 的 javax.sound.midi 中的方法
 SoundbankResource[] Soundbank.getResources()
提取音库中包含的非乐器资源列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.midi.Synthesizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.Synthesizer
的使用

使用 Synthesizer 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Synthesizer 的使用

返回 Synthesizer 的 javax.sound.midi 中的方法
static Synthesizer MidiSystem.getSynthesizer()
获得默认的合成器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.SysexMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.SysexMessage
的使用

没有 javax.sound.midi.SysexMessage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.Track 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.Track
的使用

使用 Track 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Track 的使用

类型参数类型为 Track 的 javax.sound.midi 中的字段
protected  Vector<Track> Sequence.tracks
此 sequence 中的 MIDI 轨道。

返回 Track 的 javax.sound.midi 中的方法
Track | Sequence.createTrack() 创建一个新的、初始为空的轨道作为此 Sequence 的一部分。
Track[] | Sequence.getTracks() 获得包含此 Sequence 中所有轨道的数组。

参数类型为 Track 的 javax.sound.midi 中的方法
boolean | Sequence.deleteTrack(Track track) 从 Sequence 中移除指定的轨道。
void | Sequencer.recordDisable(Track track) 禁止向指定轨道的录制。
void | Sequencer.recordEnable(Track track, int channel) 为录制特定通道上接收的事件准备指定的轨道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.midi.Transmitter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.Transmitter
的使用

使用 Transmitter 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Transmitter 的使用

返回 Transmitter 的 javax.sound.midi 中的方法
Transmitter | MidiDevice.getTransmitter() 获得 MIDI 设备将从其传输 MIDI 数据的 MIDI OUT 连接。
static Transmitter | MidiSystem.getTransmitter() 从外部 MIDI 端口或其他默认源获得 MIDI 传输器。

返回变量类型为 Transmitter 的类型的 javax.sound.midi 中的方法
 List<Transmitter> MidiDevice.getTransmitters()
返回与该 MidiDevice 连接的所有当前活动的、非关闭的传输器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.VoiceStatus 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.VoiceStatus
的使用

使用 VoiceStatus 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 VoiceStatus 的使用

返回 VoiceStatus 的 javax.sound.midi 中的方法
 VoiceStatus[] Synthesizer.getVoiceStatus()
获得由此合成器生成的声音的当前状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.sound.midi.spi (Java 2 Platform SE 6)

 javax.sound.midi.spi
类
MidiDeviceProvider
MidiFileReader
MidiFileWriter
SoundbankReader


类 javax.sound.midi.spi.MidiDeviceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.spi.MidiDeviceProvider
的使用

没有 javax.sound.midi.spi.MidiDeviceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.spi.MidiFileReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.spi.MidiFileReader
的使用

没有 javax.sound.midi.spi.MidiFileReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.spi.MidiFileWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.spi.MidiFileWriter
的使用

没有 javax.sound.midi.spi.MidiFileWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.midi.spi.SoundbankReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.spi.SoundbankReader
的使用

没有 javax.sound.midi.spi.SoundbankReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.sound.sampled (Java 2 Platform SE 6)

 javax.sound.sampled
接口
Clip
DataLine
Line
LineListener
Mixer
Port
SourceDataLine
TargetDataLine
类
AudioFileFormat
AudioFileFormat.Type
AudioFormat
AudioFormat.Encoding
AudioInputStream
AudioPermission
AudioSystem
BooleanControl
BooleanControl.Type
CompoundControl
CompoundControl.Type
Control
Control.Type
DataLine.Info
EnumControl
EnumControl.Type
FloatControl
FloatControl.Type
Line.Info
LineEvent
LineEvent.Type
Mixer.Info
Port.Info
ReverbType
异常
LineUnavailableException
UnsupportedAudioFileException


类 javax.sound.sampled.AudioFileFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioFileFormat
的使用

使用 AudioFileFormat 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 AudioFileFormat 的使用

返回 AudioFileFormat 的 javax.sound.sampled 中的方法
static AudioFileFormat | AudioSystem.getAudioFileFormat(File file) 获得指定 File 的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(InputStream stream) 获得提供的音频输入流的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(URL url) 获得指定 URL 的音频文件格式。

javax.sound.sampled.spi 中 AudioFileFormat 的使用

返回 AudioFileFormat 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(File file) 获得所提供 File 的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(InputStream stream) 获得所提供输入流的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(URL url) 获得所提供 URL 的音频文件格式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.AudioFileFormat.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioFileFormat.Type
的使用

使用 AudioFileFormat.Type 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 AudioFileFormat.Type 的使用

声明为 AudioFileFormat.Type 的 javax.sound.sampled 中的字段
static AudioFileFormat.Type | AudioFileFormat.Type.AIFC 指定 AIFF-C 文件。
static AudioFileFormat.Type | AudioFileFormat.Type.AIFF 指定 AIFF 文件。
static AudioFileFormat.Type | AudioFileFormat.Type.AU 指定 AU 文件。
static AudioFileFormat.Type | AudioFileFormat.Type.SND 指定 SND 文件。
static AudioFileFormat.Type | AudioFileFormat.Type.WAVE 指定 WAVE 文件。

返回 AudioFileFormat.Type 的 javax.sound.sampled 中的方法
static AudioFileFormat.Type[] | AudioSystem.getAudioFileTypes() 获得由系统为其提供文件写入支持的文件类型。
static AudioFileFormat.Type[] | AudioSystem.getAudioFileTypes(AudioInputStream stream) 获得系统可从指定音频输入流写入的文件类型。
AudioFileFormat.Type | AudioFileFormat.getType() 获得音频文件类型，如 WAVE 或 AU。

参数类型为 AudioFileFormat.Type 的 javax.sound.sampled 中的方法
static boolean | AudioSystem.isFileTypeSupported(AudioFileFormat.Type fileType) 指示系统是否提供指定文件类型的文件写入支持。
static boolean | AudioSystem.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream) 指示是否可以从指示的音频输入流写入指定文件类型的音频文件。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示指定文件类型的音频文件的字节流写入所提供的外部文件。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示指定文件类型的音频文件的字节流写入所提供的输出流。

参数类型为 AudioFileFormat.Type 的 javax.sound.sampled 中的构造方法
AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength)
构造音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type type, int byteLength, AudioFormat format, int frameLength)
构造音频文件格式对象。

javax.sound.sampled.spi 中 AudioFileFormat.Type 的使用

返回 AudioFileFormat.Type 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat.Type[] | AudioFileWriter.getAudioFileTypes() 获得此音频文件 writer 为其提供文件写入支持的文件类型。
abstract AudioFileFormat.Type[] | AudioFileWriter.getAudioFileTypes(AudioInputStream stream) 获得此音频文件 writer 可以从指定的音频输入流写入的文件类型。

参数类型为 AudioFileFormat.Type 的 javax.sound.sampled.spi 中的方法
boolean | AudioFileWriter.isFileTypeSupported(AudioFileFormat.Type fileType) 指示此音频文件 writer 是否提供指定文件类型的文件写入支持。
boolean | AudioFileWriter.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream) 指示是否可以从指示的音频输入流写入指定类型的音频文件。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示所指示文件类型的音频文件的字节流写入所提供的输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.AudioFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioFormat
的使用

使用 AudioFormat 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 AudioFormat 的使用

声明为 AudioFormat 的 javax.sound.sampled 中的字段
protected  AudioFormat AudioInputStream.format
流中包含的音频数据的格式。

返回 AudioFormat 的 javax.sound.sampled 中的方法
AudioFormat | AudioFileFormat.getFormat() 获得音频文件中包含的音频数据的格式。
AudioFormat | AudioInputStream.getFormat() 获得此音频输入流中声音数据的音频格式。
AudioFormat | DataLine.getFormat() 获得数据行的音频数据的当前格式（编码、样本频率、信道数，等等）。
AudioFormat[] | DataLine.Info.getFormats() 获得数据行支持的音频格式的集合。
static AudioFormat[] | AudioSystem.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 使用已安装的格式转换器，获得具有特定编码的格式，以及系统可以从指定格式的流中获得的格式。

参数类型为 AudioFormat 的 javax.sound.sampled 中的方法
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示格式的音频输入流。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format) 获得一个源数据行，该行可用于以 AudioFormat 对象指定的格式回放音频数据。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format) 获得一个目标数据行，该行可用于以 AudioFormat 对象指定的格式记录音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。
static AudioFormat.Encoding[] | AudioSystem.getTargetEncodings(AudioFormat sourceFormat) 使用已安装的格式转换器集合，获得系统可以从具有指定格式的音频输入流中获得的编码。
static AudioFormat[] | AudioSystem.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 使用已安装的格式转换器，获得具有特定编码的格式，以及系统可以从指定格式的流中获得的格式。
static boolean | AudioSystem.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 指示是否可以从具有指定格式的音频输入流获得指定编码的音频输入流。
static boolean | AudioSystem.isConversionSupported(AudioFormat targetFormat, AudioFormat sourceFormat) 指示是否可从另一指定格式的音频输入流获得指定格式的音频输入流。
boolean | DataLine.Info.isFormatSupported(AudioFormat format) 指示此数据行是否支持特定的音频格式。
boolean | AudioFormat.matches(AudioFormat format) 指示此格式是否与指定格式匹配。
void | SourceDataLine.open(AudioFormat format) 打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
void | TargetDataLine.open(AudioFormat format) 打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
void | Clip.open(AudioFormat format, byte[] data, int offset, int bufferSize) 打开剪辑，意味着它应该获得所有所需的系统资源并变得可操作。
void | SourceDataLine.open(AudioFormat format, int bufferSize) 打开具有指定格式和建议缓冲区大小的行，这样可使该行获得所有所需系统资源并变得可操作。
void | TargetDataLine.open(AudioFormat format, int bufferSize) 打开具有指定格式和请求缓冲区大小的行，这样可使行获得所有所需的系统资源并变得可操作。

参数类型为 AudioFormat 的 javax.sound.sampled 中的构造方法
AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength)
构造音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type type, int byteLength, AudioFormat format, int frameLength)
构造音频文件格式对象。
AudioInputStream(InputStream stream, AudioFormat format, long length)
使用指定输入流中的音频数据构造具有请求的格式和长度（以示例帧为单位）的音频输入流。
DataLine.Info(Class<?> lineClass, AudioFormat format)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式。
DataLine.Info(Class<?> lineClass, AudioFormat[] formats, int minBufferSize, int maxBufferSize)
根据指定信息构造数据行的信息对象，这些包括受支持音频格式的集合和缓冲区大小的范围。
DataLine.Info(Class<?> lineClass, AudioFormat format, int bufferSize)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式和所需的缓冲区大小。

javax.sound.sampled.spi 中 AudioFormat 的使用

返回 AudioFormat 的 javax.sound.sampled.spi 中的方法
abstract  AudioFormat[] FormatConversionProvider.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
获得具有受格式转换器支持的指定编码的目标格式集合。

参数类型为 AudioFormat 的 javax.sound.sampled.spi 中的方法
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定格式的音频输入流。
abstract AudioFormat.Encoding[] | FormatConversionProvider.getTargetEncodings(AudioFormat sourceFormat) 获得受给定了特定源格式的格式转换器支持的目标格式编码集合。
abstract AudioFormat[] | FormatConversionProvider.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 获得具有受格式转换器支持的指定编码的目标格式集合。
boolean | FormatConversionProvider.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 指示格式转换器是否支持从特定格式向特定编码的转换。
boolean | FormatConversionProvider.isConversionSupported(AudioFormat targetFormat, AudioFormat sourceFormat) 指示格式转换器是否支持到从一种特定格式到另一种格式的转换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.AudioFormat.Encoding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioFormat.Encoding
的使用

使用 AudioFormat.Encoding 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 AudioFormat.Encoding 的使用

声明为 AudioFormat.Encoding 的 javax.sound.sampled 中的字段
static AudioFormat.Encoding | AudioFormat.Encoding.ALAW 指定 a-law 编码数据。
protected AudioFormat.Encoding | AudioFormat.encoding 此格式使用的音频编码技术。
static AudioFormat.Encoding | AudioFormat.Encoding.PCM_SIGNED 指定有符号的线性 PCM 数据。
static AudioFormat.Encoding | AudioFormat.Encoding.PCM_UNSIGNED 指定无符号的线性 PCM 数据。
static AudioFormat.Encoding | AudioFormat.Encoding.ULAW 指定 u-law 编码数据。

返回 AudioFormat.Encoding 的 javax.sound.sampled 中的方法
AudioFormat.Encoding | AudioFormat.getEncoding() 获取此格式声音的编码类型。
static AudioFormat.Encoding[] | AudioSystem.getTargetEncodings(AudioFormat.Encoding sourceEncoding) 使用已安装的格式转换器集合获得系统可以从具有指定编码的音频输入流中获得的编码。
static AudioFormat.Encoding[] | AudioSystem.getTargetEncodings(AudioFormat sourceFormat) 使用已安装的格式转换器集合，获得系统可以从具有指定格式的音频输入流中获得的编码。

参数类型为 AudioFormat.Encoding 的 javax.sound.sampled 中的方法
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示编码的音频输入流。
static AudioFormat.Encoding[] | AudioSystem.getTargetEncodings(AudioFormat.Encoding sourceEncoding) 使用已安装的格式转换器集合获得系统可以从具有指定编码的音频输入流中获得的编码。
static AudioFormat[] | AudioSystem.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 使用已安装的格式转换器，获得具有特定编码的格式，以及系统可以从指定格式的流中获得的格式。
static boolean | AudioSystem.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 指示是否可以从具有指定格式的音频输入流获得指定编码的音频输入流。

参数类型为 AudioFormat.Encoding 的 javax.sound.sampled 中的构造方法
AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian)
构造具有给定参数的 AudioFormat。
AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
构造具有给定参数的 AudioFormat。

javax.sound.sampled.spi 中 AudioFormat.Encoding 的使用

返回 AudioFormat.Encoding 的 javax.sound.sampled.spi 中的方法
abstract AudioFormat.Encoding[] | FormatConversionProvider.getSourceEncodings() 获得源格式编码的集合，此提供者从该集合中提供格式转换服务。
abstract AudioFormat.Encoding[] | FormatConversionProvider.getTargetEncodings() 获得目标格式编码的集合，此提供者向该集合提供格式转换服务。
abstract AudioFormat.Encoding[] | FormatConversionProvider.getTargetEncodings(AudioFormat sourceFormat) 获得受给定了特定源格式的格式转换器支持的目标格式编码集合。

参数类型为 AudioFormat.Encoding 的 javax.sound.sampled.spi 中的方法
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定编码的音频输入流。
abstract AudioFormat[] | FormatConversionProvider.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 获得具有受格式转换器支持的指定编码的目标格式集合。
boolean | FormatConversionProvider.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 指示格式转换器是否支持从特定格式向特定编码的转换。
boolean | FormatConversionProvider.isSourceEncodingSupported(AudioFormat.Encoding sourceEncoding) 指示格式转换器是否支持从指定源格式编码的转换。
boolean | FormatConversionProvider.isTargetEncodingSupported(AudioFormat.Encoding targetEncoding) 指示格式转换器是否支持到指定目标格式编码的转换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.AudioInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioInputStream
的使用

使用 AudioInputStream 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 AudioInputStream 的使用

返回 AudioInputStream 的 javax.sound.sampled 中的方法
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示编码的音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示格式的音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(File file) 从提供的 File 获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(InputStream stream) 从提供的输入流获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(URL url) 从提供的 URL 获得音频输入流。

参数类型为 AudioInputStream 的 javax.sound.sampled 中的方法
static AudioFileFormat.Type[] | AudioSystem.getAudioFileTypes(AudioInputStream stream) 获得系统可从指定音频输入流写入的文件类型。
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示编码的音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示格式的音频输入流。
static boolean | AudioSystem.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream) 指示是否可以从指示的音频输入流写入指定文件类型的音频文件。
void | Clip.open(AudioInputStream stream) 使用出现在所提供的音频输入流中的格式和音频数据打开剪辑。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示指定文件类型的音频文件的字节流写入所提供的外部文件。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示指定文件类型的音频文件的字节流写入所提供的输出流。

javax.sound.sampled.spi 中 AudioInputStream 的使用

返回 AudioInputStream 的 javax.sound.sampled.spi 中的方法
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定编码的音频输入流。
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定格式的音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(File file) 从所提供的 File 获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(InputStream stream) 从所提供的输入流中获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(URL url) 从所提供的 URL 获得音频输入流。

参数类型为 AudioInputStream 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat.Type[] | AudioFileWriter.getAudioFileTypes(AudioInputStream stream) 获得此音频文件 writer 可以从指定的音频输入流写入的文件类型。
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定编码的音频输入流。
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定格式的音频输入流。
boolean | AudioFileWriter.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream) 指示是否可以从指示的音频输入流写入指定类型的音频文件。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示所指示文件类型的音频文件的字节流写入所提供的输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.AudioPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioPermission
的使用

没有 javax.sound.sampled.AudioPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.AudioSystem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioSystem
的使用

没有 javax.sound.sampled.AudioSystem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.BooleanControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.BooleanControl
的使用

没有 javax.sound.sampled.BooleanControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.BooleanControl.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.BooleanControl.Type
的使用

使用 BooleanControl.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 BooleanControl.Type 的使用

声明为 BooleanControl.Type 的 javax.sound.sampled 中的字段
static BooleanControl.Type | BooleanControl.Type.APPLY_REVERB 表示是否将回响应用于行的控件。
static BooleanControl.Type | BooleanControl.Type.MUTE 表示行的静音状态的控件。

参数类型为 BooleanControl.Type 的 javax.sound.sampled 中的构造方法
BooleanControl(BooleanControl.Type type, boolean initialValue)
构造一个具有给定参数的新 boolean 控件对象。
BooleanControl(BooleanControl.Type type, boolean initialValue, String trueStateLabel, String falseStateLabel)
构造一个具有给定参数的新 boolean 控件对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.sampled.Clip 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.Clip
的使用

使用 Clip 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Clip 的使用

返回 Clip 的 javax.sound.sampled 中的方法
static Clip | AudioSystem.getClip() 获得可用于回放音频文件或音频流的剪辑。
static Clip | AudioSystem.getClip(Mixer.Info mixerInfo) 从指定混频器获得可用于回放音频文件或音频流的剪辑。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.CompoundControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.CompoundControl
的使用

没有 javax.sound.sampled.CompoundControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.CompoundControl.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.CompoundControl.Type
的使用

使用 CompoundControl.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 CompoundControl.Type 的使用

参数类型为 CompoundControl.Type 的 javax.sound.sampled 中的构造方法
CompoundControl(CompoundControl.Type type, Control[] memberControls)
构造一个具有给定参数的新组合控件对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.Control 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.Control
的使用

使用 Control 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Control 的使用

javax.sound.sampled 中 Control 的子类
class | BooleanControl BooleanControl 能够在影响行音频的两个可能的设置之间切换。
class | CompoundControl CompoundControl（如图形均衡器）控制两个或多个相关属性，每个属性本身都表示为 Control。
class | EnumControl EnumControl 提供对一组截然不同的可能值的控制，每个值都由一个对象表示。
class | FloatControl FloatControl 对象提供对浮点值范围的控制。

返回 Control 的 javax.sound.sampled 中的方法
Control | Line.getControl(Control.Type control) 获得指定类型的控件，如果有的话。
Control[] | Line.getControls() 获得与此行相关的控件集合。
Control[] | CompoundControl.getMemberControls() 返回组成组合控件的成员控件集合。

参数类型为 Control 的 javax.sound.sampled 中的构造方法
CompoundControl(CompoundControl.Type type, Control[] memberControls)
构造一个具有给定参数的新组合控件对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.Control.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.Control.Type
的使用

使用 Control.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Control.Type 的使用

javax.sound.sampled 中 Control.Type 的子类
static class | BooleanControl.Type BooleanControl.Type 类的实例标识一种 boolean 控件。
static class | CompoundControl.Type CompoundControl.Type 内部类的实例标识一种组合控件。
static class | EnumControl.Type EnumControl.Type 内部类的实例标识了某种枚举控件。
static class | FloatControl.Type FloatControl.Type 内部类的实例标识了某种 float 控件。

返回 Control.Type 的 javax.sound.sampled 中的方法
 Control.Type Control.getType()
获得控件的类型。

参数类型为 Control.Type 的 javax.sound.sampled 中的方法
Control | Line.getControl(Control.Type control) 获得指定类型的控件，如果有的话。
boolean | Line.isControlSupported(Control.Type control) 指示该行是否支持特定类型的控件。

参数类型为 Control.Type 的 javax.sound.sampled 中的构造方法
Control(Control.Type type)
构造具有指定类型的控件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.sampled.DataLine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.DataLine
的使用

使用 DataLine 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 DataLine 的使用

javax.sound.sampled 中 DataLine 的子接口
interface | Clip Clip 接口表示特殊种类的数据行，该数据行的音频数据可以在回放前加载，而不是实时流出。
interface | SourceDataLine 源数据行是可以写入数据的数据行。
interface | TargetDataLine 目标数据行是可以从中读取音频数据的某种类型的 DataLine。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.DataLine.Info 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.DataLine.Info
的使用

没有 javax.sound.sampled.DataLine.Info 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.EnumControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.EnumControl
的使用

没有 javax.sound.sampled.EnumControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.EnumControl.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.EnumControl.Type
的使用

使用 EnumControl.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 EnumControl.Type 的使用

声明为 EnumControl.Type 的 javax.sound.sampled 中的字段
static EnumControl.Type EnumControl.Type.REVERB
表示对一组可能的回响设置的控件。

参数类型为 EnumControl.Type 的 javax.sound.sampled 中的构造方法
EnumControl(EnumControl.Type type, Object[] values, Object value)
构造一个具有给定参数的新枚举控件对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.FloatControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.FloatControl
的使用

没有 javax.sound.sampled.FloatControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.FloatControl.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.FloatControl.Type
的使用

使用 FloatControl.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 FloatControl.Type 的使用

声明为 FloatControl.Type 的 javax.sound.sampled 中的字段
static FloatControl.Type | FloatControl.Type.AUX_RETURN 表示某一行上辅助返回音量的控件。
static FloatControl.Type | FloatControl.Type.AUX_SEND 表示某一行上辅助发送音量的控件。
static FloatControl.Type | FloatControl.Type.BALANCE 表示两个立体声扬声器之间立体声信号相对平衡的控件。
static FloatControl.Type | FloatControl.Type.MASTER_GAIN 表示某一行上总音量的控件。
static FloatControl.Type | FloatControl.Type.PAN 表示信号的相对 pan（左右定位）的控件。
static FloatControl.Type | FloatControl.Type.REVERB_RETURN 表示某一行上后回响 (post-reverb) 音量的控件。
static FloatControl.Type | FloatControl.Type.REVERB_SEND 表示某一行上预回响 (pre-reverb) 音量的控件。
static FloatControl.Type | FloatControl.Type.SAMPLE_RATE 表示更改音频回放的样本频率的控件。
static FloatControl.Type | FloatControl.Type.VOLUME 表示某一行上的音量的控件。

参数类型为 FloatControl.Type 的 javax.sound.sampled 中的构造方法
FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units)
构造具有给定参数的新 float 控件对象。
FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units, String minLabel, String midLabel, String maxLabel)
构造具有给定参数的新 float 控件对象

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.sampled.Line 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.Line
的使用

使用 Line 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Line 的使用

javax.sound.sampled 中 Line 的子接口
interface | Clip Clip 接口表示特殊种类的数据行，该数据行的音频数据可以在回放前加载，而不是实时流出。
interface | DataLine DataLine 将与介质相关的功能添加到其超接口 Line。
interface | Mixer 混频器是一个具有一行或多行的音频设备。
interface | Port 端口是往返于音频输入或输出线与音频设备之间的简单线路。
interface | SourceDataLine 源数据行是可以写入数据的数据行。
interface | TargetDataLine 目标数据行是可以从中读取音频数据的某种类型的 DataLine。

返回 Line 的 javax.sound.sampled 中的方法
Line | LineEvent.getLine() 获得作为此事件的源的音频行。
static Line | AudioSystem.getLine(Line.Info info) 获得与指定 Line.Info 对象中的描述匹配的行。
Line | Mixer.getLine(Line.Info info) 获得可供使用并且与指定 Line.Info 对象中的描述匹配的行。
Line[] | Mixer.getSourceLines() 获得当前对此混频器打开的所有源行的集合。
Line[] | Mixer.getTargetLines() 获得当前从此混频器打开的所有目标行的集合。

参数类型为 Line 的 javax.sound.sampled 中的方法
boolean | Mixer.isSynchronizationSupported(Line[] lines, boolean maintainSync) 报告此混频器是否支持指定行集合的同步。
void | Mixer.synchronize(Line[] lines, boolean maintainSync) 同步两个或多个行。
void | Mixer.unsynchronize(Line[] lines) 释放指定行的同步。

参数类型为 Line 的 javax.sound.sampled 中的构造方法
LineEvent(Line line, LineEvent.Type type, long position)
构造源自指定行的指定类型的新事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.Line.Info 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.Line.Info
的使用

使用 Line.Info 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Line.Info 的使用

javax.sound.sampled 中 Line.Info 的子类
static class | DataLine.Info 除了继承自其超类的类信息之外，DataLine.Info 还提供特定于数据行的其他信息。
static class | Port.Info 该 Port.Info 类扩展了具有其他特定于端口的信息的 Line.Info，这些信息包括端口的名称以及该端口是否是其混频器的源或目标。

返回 Line.Info 的 javax.sound.sampled 中的方法
Line.Info | Line.getLineInfo() 获得描述此行的 Line.Info 对象。
Line.Info[] | Mixer.getSourceLineInfo() 获得关于此混频器支持的源行集合的信息。
static Line.Info[] | AudioSystem.getSourceLineInfo(Line.Info info) 获得关于已安装混频器所支持特定类型的全部源行的信息。
Line.Info[] | Mixer.getSourceLineInfo(Line.Info info) 获得关于此混频器支持的特定类型源行的信息。
Line.Info[] | Mixer.getTargetLineInfo() 获得关于此混频器支持的目标行集合的信息。
static Line.Info[] | AudioSystem.getTargetLineInfo(Line.Info info) 获得关于已安装混频器所支持特定类型的全部目标行的信息。
Line.Info[] | Mixer.getTargetLineInfo(Line.Info info) 获得关于此混频器支持的特定类型目标行的信息。

参数类型为 Line.Info 的 javax.sound.sampled 中的方法
static Line | AudioSystem.getLine(Line.Info info) 获得与指定 Line.Info 对象中的描述匹配的行。
Line | Mixer.getLine(Line.Info info) 获得可供使用并且与指定 Line.Info 对象中的描述匹配的行。
int | Mixer.getMaxLines(Line.Info info) 获得可以在此混频器上同时打开的所请求类型的行的最大近似数。
static Line.Info[] | AudioSystem.getSourceLineInfo(Line.Info info) 获得关于已安装混频器所支持特定类型的全部源行的信息。
Line.Info[] | Mixer.getSourceLineInfo(Line.Info info) 获得关于此混频器支持的特定类型源行的信息。
static Line.Info[] | AudioSystem.getTargetLineInfo(Line.Info info) 获得关于已安装混频器所支持特定类型的全部目标行的信息。
Line.Info[] | Mixer.getTargetLineInfo(Line.Info info) 获得关于此混频器支持的特定类型目标行的信息。
static boolean | AudioSystem.isLineSupported(Line.Info info) 指示系统是否支持与指定 Line.Info 对象匹配的行。
boolean | Mixer.isLineSupported(Line.Info info) 指示混频器是否支持与指定 Line.Info 对象匹配的一行（或多行）。
boolean | Port.Info.matches(Line.Info info) 指示此指定 info 对象是否与此对象匹配。
boolean | DataLine.Info.matches(Line.Info info) 确定指定的信息对象是否与此对象匹配。
boolean | Line.Info.matches(Line.Info info) 指示指定的信息对象是否与此对象匹配。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.LineEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.LineEvent
的使用

使用 LineEvent 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 LineEvent 的使用

参数类型为 LineEvent 的 javax.sound.sampled 中的方法
 void LineListener.update(LineEvent event)
通知侦听器行的状态已发生更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.LineEvent.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.LineEvent.Type
的使用

使用 LineEvent.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 LineEvent.Type 的使用

声明为 LineEvent.Type 的 javax.sound.sampled 中的字段
static LineEvent.Type | LineEvent.Type.CLOSE 行关闭（释放该行在打开时获得的系统资源）时发送的事件类型。
static LineEvent.Type | LineEvent.Type.OPEN 行打开（为行本身保留系统资源）时发送的事件类型。
static LineEvent.Type | LineEvent.Type.START 在行响应 start 请求而进行音频数据的活动输入或输出时发送的事件类型。
static LineEvent.Type | LineEvent.Type.STOP 当行响应 stop 请求或者因为已到达介质的结尾处而终止音频数据的活动输入或输出时发送的事件类型。

返回 LineEvent.Type 的 javax.sound.sampled 中的方法
 LineEvent.Type LineEvent.getType()
获得事件的类型。

参数类型为 LineEvent.Type 的 javax.sound.sampled 中的构造方法
LineEvent(Line line, LineEvent.Type type, long position)
构造源自指定行的指定类型的新事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.sampled.LineListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.LineListener
的使用

使用 LineListener 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 LineListener 的使用

参数类型为 LineListener 的 javax.sound.sampled 中的方法
void | Line.addLineListener(LineListener listener) 将侦听器添加到此行。
void | Line.removeLineListener(LineListener listener) 从此行的侦听器列表中移除指定侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.LineUnavailableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.LineUnavailableException
的使用

使用 LineUnavailableException 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 LineUnavailableException 的使用

抛出 LineUnavailableException 的 javax.sound.sampled 中的方法
static Clip | AudioSystem.getClip() 获得可用于回放音频文件或音频流的剪辑。
static Clip | AudioSystem.getClip(Mixer.Info mixerInfo) 从指定混频器获得可用于回放音频文件或音频流的剪辑。
static Line | AudioSystem.getLine(Line.Info info) 获得与指定 Line.Info 对象中的描述匹配的行。
Line | Mixer.getLine(Line.Info info) 获得可供使用并且与指定 Line.Info 对象中的描述匹配的行。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format) 获得一个源数据行，该行可用于以 AudioFormat 对象指定的格式回放音频数据。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format) 获得一个目标数据行，该行可用于以 AudioFormat 对象指定的格式记录音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。
void | Line.open() 打开行，指示它应该获得所有所需系统资源并变得可操作。
void | SourceDataLine.open(AudioFormat format) 打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
void | TargetDataLine.open(AudioFormat format) 打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
void | Clip.open(AudioFormat format, byte[] data, int offset, int bufferSize) 打开剪辑，意味着它应该获得所有所需的系统资源并变得可操作。
void | SourceDataLine.open(AudioFormat format, int bufferSize) 打开具有指定格式和建议缓冲区大小的行，这样可使该行获得所有所需系统资源并变得可操作。
void | TargetDataLine.open(AudioFormat format, int bufferSize) 打开具有指定格式和请求缓冲区大小的行，这样可使行获得所有所需的系统资源并变得可操作。
void | Clip.open(AudioInputStream stream) 使用出现在所提供的音频输入流中的格式和音频数据打开剪辑。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.sampled.Mixer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.Mixer
的使用

使用 Mixer 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 Mixer 的使用

返回 Mixer 的 javax.sound.sampled 中的方法
static Mixer AudioSystem.getMixer(Mixer.Info info)
获得请求的音频混频器。

javax.sound.sampled.spi 中 Mixer 的使用

返回 Mixer 的 javax.sound.sampled.spi 中的方法
abstract  Mixer MixerProvider.getMixer(Mixer.Info info)
获得由 info 对象表示的混频器的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.Mixer.Info 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.Mixer.Info
的使用

使用 Mixer.Info 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 Mixer.Info 的使用

返回 Mixer.Info 的 javax.sound.sampled 中的方法
static Mixer.Info[] | AudioSystem.getMixerInfo() 获得混频器信息对象的数组，该数组表示当前安装在系统上的音频混频器的集合。
Mixer.Info | Mixer.getMixerInfo() 获得关于此混频器的信息，包括产品名称、版本、供应商，等等。

参数类型为 Mixer.Info 的 javax.sound.sampled 中的方法
static Clip | AudioSystem.getClip(Mixer.Info mixerInfo) 从指定混频器获得可用于回放音频文件或音频流的剪辑。
static Mixer | AudioSystem.getMixer(Mixer.Info info) 获得请求的音频混频器。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。

javax.sound.sampled.spi 中 Mixer.Info 的使用

返回 Mixer.Info 的 javax.sound.sampled.spi 中的方法
abstract  Mixer.Info[] MixerProvider.getMixerInfo()
获得表示由该 MixerProvider 提供的混频器的 info 对象集合。

参数类型为 Mixer.Info 的 javax.sound.sampled.spi 中的方法
abstract Mixer | MixerProvider.getMixer(Mixer.Info info) 获得由 info 对象表示的混频器的实例。
boolean | MixerProvider.isMixerSupported(Mixer.Info info) 指示混频器提供者是否支持由指定混频器 info 对象表示的混频器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.sampled.Port 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.Port
的使用

没有 javax.sound.sampled.Port 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.Port.Info 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.Port.Info
的使用

使用 Port.Info 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Port.Info 的使用

声明为 Port.Info 的 javax.sound.sampled 中的字段
static Port.Info | Port.Info.COMPACT_DISC 从 CD-ROM 驱动器获得音频端口类型。
static Port.Info | Port.Info.HEADPHONE 向耳机插孔发送音频端口类型。
static Port.Info | Port.Info.LINE_IN 从线路级音频输入插孔获得音频端口类型。
static Port.Info | Port.Info.LINE_OUT 向线路级音频输出插孔发送音频端口类型。
static Port.Info | Port.Info.MICROPHONE 从内置麦克风或麦克风插孔中获得音频端口类型。
static Port.Info | Port.Info.SPEAKER 向内置扬声器或扬声器插孔发送音频端口类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.ReverbType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.ReverbType
的使用

没有 javax.sound.sampled.ReverbType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.sampled.SourceDataLine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.SourceDataLine
的使用

使用 SourceDataLine 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 SourceDataLine 的使用

返回 SourceDataLine 的 javax.sound.sampled 中的方法
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format) 获得一个源数据行，该行可用于以 AudioFormat 对象指定的格式回放音频数据。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sound.sampled.TargetDataLine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.TargetDataLine
的使用

使用 TargetDataLine 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 TargetDataLine 的使用

返回 TargetDataLine 的 javax.sound.sampled 中的方法
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format) 获得一个目标数据行，该行可用于以 AudioFormat 对象指定的格式记录音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。

参数类型为 TargetDataLine 的 javax.sound.sampled 中的构造方法
AudioInputStream(TargetDataLine line)
构造从指示的目标数据行读取数据的音频输入流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.UnsupportedAudioFileException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.UnsupportedAudioFileException
的使用

使用 UnsupportedAudioFileException 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 UnsupportedAudioFileException 的使用

抛出 UnsupportedAudioFileException 的 javax.sound.sampled 中的方法
static AudioFileFormat | AudioSystem.getAudioFileFormat(File file) 获得指定 File 的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(InputStream stream) 获得提供的音频输入流的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(URL url) 获得指定 URL 的音频文件格式。
static AudioInputStream | AudioSystem.getAudioInputStream(File file) 从提供的 File 获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(InputStream stream) 从提供的输入流获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(URL url) 从提供的 URL 获得音频输入流。

javax.sound.sampled.spi 中 UnsupportedAudioFileException 的使用

抛出 UnsupportedAudioFileException 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(File file) 获得所提供 File 的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(InputStream stream) 获得所提供输入流的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(URL url) 获得所提供 URL 的音频文件格式。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(File file) 从所提供的 File 获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(InputStream stream) 从所提供的输入流中获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(URL url) 从所提供的 URL 获得音频输入流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.sound.sampled.spi (Java 2 Platform SE 6)

 javax.sound.sampled.spi
类
AudioFileReader
AudioFileWriter
FormatConversionProvider
MixerProvider


类 javax.sound.sampled.spi.AudioFileReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.spi.AudioFileReader
的使用

没有 javax.sound.sampled.spi.AudioFileReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.spi.AudioFileWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.spi.AudioFileWriter
的使用

没有 javax.sound.sampled.spi.AudioFileWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.spi.FormatConversionProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.spi.FormatConversionProvider
的使用

没有 javax.sound.sampled.spi.FormatConversionProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sound.sampled.spi.MixerProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.spi.MixerProvider
的使用

没有 javax.sound.sampled.spi.MixerProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.sql (Java 2 Platform SE 6)

 javax.sql
接口
CommonDataSource
ConnectionEventListener
ConnectionPoolDataSource
DataSource
PooledConnection
RowSet
RowSetInternal
RowSetListener
RowSetMetaData
RowSetReader
RowSetWriter
StatementEventListener
XAConnection
XADataSource
类
ConnectionEvent
RowSetEvent
StatementEvent


接口 javax.sql.CommonDataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.CommonDataSource
的使用

使用 CommonDataSource 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 CommonDataSource 的使用

javax.sql 中 CommonDataSource 的子接口
interface | ConnectionPoolDataSource PooledConnection 对象的工厂。
interface | DataSource 该工厂用于提供到此 DataSource 对象所表示的物理数据源的连接。
interface | XADataSource 在内部使用的 XAConnection 对象的工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.ConnectionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.ConnectionEvent
的使用

使用 ConnectionEvent 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 ConnectionEvent 的使用

参数类型为 ConnectionEvent 的 javax.sql 中的方法
void | ConnectionEventListener.connectionClosed(ConnectionEvent event) 通知此 ConnectionEventListener 应用程序已对其入池连接的表示形式调用 close 方法。
void | ConnectionEventListener.connectionErrorOccurred(ConnectionEvent event) 通知此 ConnectionEventListener 发生了严重错误，入池连接不再可用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.ConnectionEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.ConnectionEventListener
的使用

使用 ConnectionEventListener 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 ConnectionEventListener 的使用

参数类型为 ConnectionEventListener 的 javax.sql 中的方法
void | PooledConnection.addConnectionEventListener(ConnectionEventListener listener) 注册给定的事件侦听器，以便在此 PooledConnection 对象上发生事件时它将得到通知。
void | PooledConnection.removeConnectionEventListener(ConnectionEventListener listener) 从在此 PooledConnection 对象上发生事件时得到通知的组件所组成的列表中移除给定的事件侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.ConnectionPoolDataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.ConnectionPoolDataSource
的使用

没有 javax.sql.ConnectionPoolDataSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.DataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.DataSource
的使用

没有 javax.sql.DataSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.PooledConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.PooledConnection
的使用

使用 PooledConnection 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 PooledConnection 的使用

javax.sql 中 PooledConnection 的子接口
 interface XAConnection
为分布式事务提供支持的对象。

返回 PooledConnection 的 javax.sql 中的方法
PooledConnection | ConnectionPoolDataSource.getPooledConnection() 尝试建立可用作入池连接的物理数据库连接。
PooledConnection | ConnectionPoolDataSource.getPooledConnection(String user, String password) 尝试建立可用作入池连接的物理数据库连接。

参数类型为 PooledConnection 的 javax.sql 中的构造方法
ConnectionEvent(PooledConnection con)
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象进行初始化。
ConnectionEvent(PooledConnection con, SQLException ex)
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象和 SQLException 对象进行初始化。
StatementEvent(PooledConnection con, PreparedStatement statement)
用指定的 PooledConnection 和 PreparedStatement 构造 StatementEvent。
StatementEvent(PooledConnection con, PreparedStatement statement, SQLException exception)
用指定的 PooledConnection、PreparedStatement 和 SQLException 构造 StatementEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.RowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSet
的使用

使用 RowSet 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql 中 RowSet 的使用

参数类型为 RowSet 的 javax.sql 中的构造方法
RowSetEvent(RowSet source)
构造一个 RowSetEvent 对象，并使用给定的 RowSet 对象进行初始化。

javax.sql.rowset 中 RowSet 的使用

javax.sql.rowset 中 RowSet 的子接口
interface | CachedRowSet 所有标准 CachedRowSet 实现都必须实现的接口。
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JdbcRowSet 所有标准 JdbcRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
interface | WebRowSet 所有 WebRowSet 的实现都必须实现的标准接口。

返回 RowSet 的 javax.sql.rowset 中的方法
 RowSet CachedRowSet.createShared()
返回一个新的 RowSet 对象，支持该对象的数据与此 CachedRowSet 对象的相同。

参数类型为 RowSet 的 javax.sql.rowset 中的方法
void | JoinRowSet.addRowSet(RowSet[] rowset, int[] columnIdx) 将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列索引数组中的匹配列。
void | JoinRowSet.addRowSet(RowSet[] rowset, String[] columnName) 将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列名数组中的匹配列。
void | JoinRowSet.addRowSet(RowSet rowset, int columnIdx) 将给定的 RowSet 对象添加到此 JoinRowSet 对象，并将指定的列设置为 RowSet 对象的匹配列。
void | JoinRowSet.addRowSet(RowSet rowset, String columnName) 将 rowset 添加到此 JoinRowSet 对象，并将指定的列设置为匹配列。
boolean | Predicate.evaluate(RowSet rs) 此方法通常称为 FilteredRowSet 对象内部方法（非公共），它控制 RowSet 对象的指针从一行移动到下一行。

javax.sql.rowset.spi 中 RowSet 的使用

javax.sql.rowset.spi 中 RowSet 的子接口
 interface SyncResolver
定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.RowSetEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.RowSetEvent
的使用

使用 RowSetEvent 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

javax.sql 中 RowSetEvent 的使用

参数类型为 RowSetEvent 的 javax.sql 中的方法
void | RowSetListener.cursorMoved(RowSetEvent event) 通知已注册侦听器 RowSet 对象的指针已移动。
void | RowSetListener.rowChanged(RowSetEvent event) 通知已注册侦听器 RowSet 对象的其中一行发生了更改。
void | RowSetListener.rowSetChanged(RowSetEvent event) 通知已注册侦听器给定 RowSetEvent 对象中的 RowSet 对象已更改其全部内部。

javax.sql.rowset 中 RowSetEvent 的使用

参数类型为 RowSetEvent 的 javax.sql.rowset 中的方法
 void CachedRowSet.rowSetPopulated(RowSetEvent event, int numRows)
通知已注册侦听器给定 RowSetEvent 对象中的某个 RowSet 对象已经填充了多个附加行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.RowSetInternal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSetInternal
的使用

使用 RowSetInternal 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 RowSetInternal 的使用

参数类型为 RowSetInternal 的 javax.sql 中的方法
void | RowSetReader.readData(RowSetInternal caller) 读取调用 RowSet 对象的新内容。
boolean | RowSetWriter.writeData(RowSetInternal caller) 将此 RowSetWriter 对象的 rowset 中的更改写回它从中获取数据的数据源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.RowSetListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSetListener
的使用

使用 RowSetListener 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

javax.sql 中 RowSetListener 的使用

参数类型为 RowSetListener 的 javax.sql 中的方法
void | RowSet.addRowSetListener(RowSetListener listener) 注册给定侦听器，以便此 RowSet 对象上发生事件时将得到通知。
void | RowSet.removeRowSetListener(RowSetListener listener) 从在此 RowSet 对象上发生事件时得到通知的组件所组成的列表中移除指定的侦听器。

javax.sql.rowset 中 RowSetListener 的使用

参数类型为 RowSetListener 的 javax.sql.rowset 中的方法
void | BaseRowSet.addRowSetListener(RowSetListener listener) 只要在此 RowSet 对象上发生事件，就将通知该侦听器。
void | BaseRowSet.removeRowSetListener(RowSetListener listener) 从此 RowSet 对象的侦听器列表中移除指定的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.RowSetMetaData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSetMetaData
的使用

使用 RowSetMetaData 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

javax.sql 中 RowSetMetaData 的使用

参数类型为 RowSetMetaData 的 javax.sql 中的方法
 void RowSetInternal.setMetaData(RowSetMetaData md)
将给定的 RowSetMetaData 对象设置为此 RowSet 对象的 RowSetMetaData 对象。

javax.sql.rowset 中 RowSetMetaData 的使用

实现 RowSetMetaData 的 javax.sql.rowset 中的类
 class RowSetMetaDataImpl
为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。

参数类型为 RowSetMetaData 的 javax.sql.rowset 中的方法
 void CachedRowSet.setMetaData(RowSetMetaData md)
使用给定的 RowSetMetaData 对象设置此 CachedRowSet 对象的元数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.RowSetReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSetReader
的使用

使用 RowSetReader 的软件包
javax.sql.rowset.spi 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset.spi 中 RowSetReader 的使用

javax.sql.rowset.spi 中 RowSetReader 的子接口
 interface XmlReader
一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。

返回 RowSetReader 的 javax.sql.rowset.spi 中的方法
abstract  RowSetReader SyncProvider.getRowSetReader()
返回 javax.sql.RowSetReader 对象，它可以用于填充带有数据的 RowSet 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.RowSetWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSetWriter
的使用

使用 RowSetWriter 的软件包
javax.sql.rowset.spi 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset.spi 中 RowSetWriter 的使用

javax.sql.rowset.spi 中 RowSetWriter 的子接口
interface | TransactionalWriter 一个专用接口，用来方便地扩展标准 SyncProvider 抽象类以便拥有细粒度的事务控制。
interface | XmlWriter 一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。

返回 RowSetWriter 的 javax.sql.rowset.spi 中的方法
abstract  RowSetWriter SyncProvider.getRowSetWriter()
返回 javax.sql.RowSetWriter 对象，它可以用于将 RowSet 对象的数据写回底层数据源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.StatementEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.StatementEvent
的使用

使用 StatementEvent 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 StatementEvent 的使用

参数类型为 StatementEvent 的 javax.sql 中的方法
void | StatementEventListener.statementClosed(StatementEvent event) 检测到 PreparedStatement 关闭时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。
void | StatementEventListener.statementErrorOccurred(StatementEvent event) 检测到 PreparedStatement 无效时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.StatementEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.StatementEventListener
的使用

使用 StatementEventListener 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 StatementEventListener 的使用

参数类型为 StatementEventListener 的 javax.sql 中的方法
void | PooledConnection.addStatementEventListener(StatementEventListener listener) 向此 PooledConnection 对象注册一个 StatementEventListener。
void | PooledConnection.removeStatementEventListener(StatementEventListener listener) 从一个组件列表中移除指定的 StatementEventListener，该列表由驱动程序检测到 PreparedStatement 已关闭或无效时将获得通知的组件组成。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.XAConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.XAConnection
的使用

使用 XAConnection 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 XAConnection 的使用

返回 XAConnection 的 javax.sql 中的方法
XAConnection | XADataSource.getXAConnection() 尝试建立可在分布式事务中使用的物理数据库连接。
XAConnection | XADataSource.getXAConnection(String user, String password) 使用给定的用户名和密码，尝试建立一个物理数据库连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.XADataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.XADataSource
的使用

没有 javax.sql.XADataSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.sql.rowset (Java 2 Platform SE 6)

 javax.sql.rowset
接口
CachedRowSet
FilteredRowSet
JdbcRowSet
Joinable
JoinRowSet
Predicate
WebRowSet
类
BaseRowSet
RowSetMetaDataImpl
异常
RowSetWarning


类 javax.sql.rowset.BaseRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.BaseRowSet
的使用

没有 javax.sql.rowset.BaseRowSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.CachedRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.CachedRowSet
的使用

使用 CachedRowSet 的软件包
javax.sql.rowset JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset 中 CachedRowSet 的使用

javax.sql.rowset 中 CachedRowSet 的子接口
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
interface | WebRowSet 所有 WebRowSet 的实现都必须实现的标准接口。

返回 CachedRowSet 的 javax.sql.rowset 中的方法
CachedRowSet | CachedRowSet.createCopy() 创建一个 RowSet 对象，它是此 CachedRowSet 对象中数据的深层副本。
CachedRowSet | CachedRowSet.createCopyNoConstraints() 创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象数据的深层副本，但是独立于此 CachedRowSet 对象。
CachedRowSet | CachedRowSet.createCopySchema() 创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象的空副本。
CachedRowSet | JoinRowSet.toCachedRowSet() 创建一个包含此 JoinRowSet 对象中数据的新 CachedRowSet 对象，可以使用 CachedRowSet 对象的 SyncProvider 对象将此 JoinRowSet 对象保存到数据源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.FilteredRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.FilteredRowSet
的使用

没有 javax.sql.rowset.FilteredRowSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.JdbcRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.JdbcRowSet
的使用

没有 javax.sql.rowset.JdbcRowSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.Joinable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.Joinable
的使用

使用 Joinable 的软件包
javax.sql.rowset JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset 中 Joinable 的使用

javax.sql.rowset 中 Joinable 的子接口
interface | CachedRowSet 所有标准 CachedRowSet 实现都必须实现的接口。
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JdbcRowSet 所有标准 JdbcRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
interface | WebRowSet 所有 WebRowSet 的实现都必须实现的标准接口。

参数类型为 Joinable 的 javax.sql.rowset 中的方法
 void JoinRowSet.addRowSet(Joinable rowset)
将给定的 RowSet 对象添加到此 JoinRowSet 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.JoinRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.JoinRowSet
的使用

没有 javax.sql.rowset.JoinRowSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.Predicate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.Predicate
的使用

使用 Predicate 的软件包
javax.sql.rowset JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset 中 Predicate 的使用

返回 Predicate 的 javax.sql.rowset 中的方法
 Predicate FilteredRowSet.getFilter()
获取此 FilteredRowSet 对象的活动过滤器。

参数类型为 Predicate 的 javax.sql.rowset 中的方法
 void FilteredRowSet.setFilter(Predicate p)
将给定的 Predicate 对象应用到此 FilteredRowSet 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.RowSetMetaDataImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.RowSetMetaDataImpl
的使用

没有 javax.sql.rowset.RowSetMetaDataImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.RowSetWarning 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.RowSetWarning
的使用

使用 RowSetWarning 的软件包
javax.sql.rowset JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset 中 RowSetWarning 的使用

返回 RowSetWarning 的 javax.sql.rowset 中的方法
RowSetWarning | RowSetWarning.getNextWarning() 获取链接到此 SQLWarning 对象的警告。
RowSetWarning | CachedRowSet.getRowSetWarnings() 获取此 RowSet 对象上的调用报告的第一个警告。
RowSetWarning | JdbcRowSet.getRowSetWarnings() 获取此 JdbcRowSet 对象上的调用报告的第一个警告。

参数类型为 RowSetWarning 的 javax.sql.rowset 中的方法
 void RowSetWarning.setNextWarning(RowSetWarning warning)
将 warning 设置为下一个警告，即连接到此 RowSetWarning 对象的警告。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.WebRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.WebRowSet
的使用

使用 WebRowSet 的软件包
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset 中 WebRowSet 的使用

javax.sql.rowset 中 WebRowSet 的子接口
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。

javax.sql.rowset.spi 中 WebRowSet 的使用

参数类型为 WebRowSet 的 javax.sql.rowset.spi 中的方法
void | XmlReader.readXML(WebRowSet caller, Reader reader) 从给定的 XML 格式的输入流读取并解析给定的 WebRowSet 对象。
void | XmlWriter.writeXML(WebRowSet caller, Writer writer) 将给定的 WebRowSet 对象以 XML 文档的形式编写到指定的 java.io.Writer 输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.sql.rowset.serial (Java 2 Platform SE 6)

 javax.sql.rowset.serial
类
SerialArray
SerialBlob
SerialClob
SerialDatalink
SerialJavaObject
SerialRef
SerialStruct
SQLInputImpl
SQLOutputImpl
异常
SerialException


类 javax.sql.rowset.serial.SerialArray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialArray
的使用

没有 javax.sql.rowset.serial.SerialArray 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.serial.SerialBlob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialBlob
的使用

没有 javax.sql.rowset.serial.SerialBlob 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.serial.SerialClob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialClob
的使用

没有 javax.sql.rowset.serial.SerialClob 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.serial.SerialDatalink 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialDatalink
的使用

没有 javax.sql.rowset.serial.SerialDatalink 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.serial.SerialException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialException
的使用

使用 SerialException 的软件包
javax.sql.rowset.serial 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

javax.sql.rowset.serial 中 SerialException 的使用

抛出 SerialException 的 javax.sql.rowset.serial 中的方法
Object | SerialArray.getArray() 返回一个新数组，它是此 SerialArray 对象的副本。
Object | SerialArray.getArray(long index, int count) 返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
Object | SerialArray.getArray(long index, int count, Map<String,Class<?>> map) 返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
Object | SerialArray.getArray(Map<String,Class<?>> map) 返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。
InputStream | SerialClob.getAsciiStream() 以 ascii 流的形式获取此 SerialClob 对象指定的 CLOB 值。
Object[] | SerialStruct.getAttributes() 获取 Object 值的数组，该数组包含此 SerialStruct 对象所表示的 SQL 结构类型的属性。
Object[] | SerialStruct.getAttributes(Map<String,Class<?>> map) 获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。
int | SerialArray.getBaseType() 获取此 SerialArray 对象中 SQL 类型的元素。
String | SerialArray.getBaseTypeName() 获取此 SerialArray 对象元素特定于 DBMS 的类型名称。
String | SerialRef.getBaseTypeName() 返回描述 Ref 的基本类型名称的字符串。
InputStream | SerialBlob.getBinaryStream() 以输入流的形式返回此 SerialBlob 对象。
byte[] | SerialBlob.getBytes(long pos, int length) 将指定的字节数（从给定位置开始）从此 SerialBlob 对象复制到另一个字节数组。
Reader | SerialClob.getCharacterStream() 以 Unicode 字符流的形式返回此 SerialClob 对象的数据。
URL | SerialDatalink.getDatalink() 返回一个新 URL，它是此 SerialDatalink 对象的副本。
Field[] | SerialJavaObject.getFields() 返回 Field 对象数组，该对象包含此帮助器类将序列化的对象的每个字段。
Object | SerialJavaObject.getObject() 返回一个 Object，它是此 SerialJavaObject 对象的副本。
Object | SerialRef.getObject() 返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
Object | SerialRef.getObject(Map<String,Class<?>> map) 返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
ResultSet | SerialArray.getResultSet() 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 ARRAY 值中的元素。
ResultSet | SerialArray.getResultSet(long index, int count) 获取保存子数组元素的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(long index, int count, Map<String,Class<?>> map) 获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(Map<String,Class<?>> map) 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。
String | SerialStruct.getSQLTypeName() 获取此 SerialStruct 对象的 SQL 类型名称。
String | SerialClob.getSubString(long pos, int length) 返回包含在此 SerialClob 对象中的子字符串的副本，从给定位置开始，后跟指定字符数。
long | SerialBlob.length() 获取此 SerialBlob 对象字节数组中的字节数。
long | SerialClob.length() 获取此 SerialClob 对象字节数组中的字节数。
long | SerialBlob.position(Blob pattern, long start) 返回此 SerialBlob 对象中给定 Blob 对象开始的位置，搜索从指定位置开始。
long | SerialBlob.position(byte[] pattern, long start) 返回在此 SerialBlob 对象中给定模式的字节开始的位置，搜索从指定的位置开始。
long | SerialClob.position(Clob searchStr, long start) 返回此 SerialClob 对象中给定 Clob 签名开始的位置，搜索从指定位置开始。
long | SerialClob.position(String searchStr, long start) 返回此 SerialClob 对象中给定 String 对象开始的位置，搜索从指定位置开始。
OutputStream | SerialClob.setAsciiStream(long pos) 获取用于将 Ascii 字符写入此 SerialClob 对象所表示的 Clob 值的流，从位置 pos 处开始。
OutputStream | SerialBlob.setBinaryStream(long pos) 获取用于写入此 Blob 对象所表示的 BLOB 值的流。
int | SerialBlob.setBytes(long pos, byte[] bytes) 将给定字节数组写入此 Blob 对象表示的 BLOB 值（从位置 pos 处开始），并返回写入的字节数。
int | SerialBlob.setBytes(long pos, byte[] bytes, int offset, int length) 将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
Writer | SerialClob.setCharacterStream(long pos) 获取用于将 Unicode 字符流写入此 SerialClob 对象所表示的 CLOB 值（位置 pos 处）的流。
void | SerialRef.setObject(Object obj) 将此 SerialRef 对象引用的 SQL 结构类型设置为给定的 Object 对象。
int | SerialClob.setString(long pos, String str) 在位置 pos 处将给定 Java String 写入此 SerialClob 对象表示的 CLOB 值中。
int | SerialClob.setString(long pos, String str, int offset, int length) 将 str 的 len 个字符写入此 Clob 表示的 CLOB 值中，从字符 offset 开始。
void | SerialBlob.truncate(long length) 截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。
void | SerialClob.truncate(long length) 截取此 SerialClob 对象所表示的 CLOB 值，使其长度为 len 个字符。

抛出 SerialException 的 javax.sql.rowset.serial 中的构造方法
SerialArray(Array array)
根据给定 Array 对象构造新的 SerialArray 对象。
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
SerialBlob(Blob blob)
根据给定 Blob 对象的序列化形式构造一个 SerialBlob 对象。
SerialBlob(byte[] b)
按照给定 byte 数组的序列化形式构造一个 SerialBlob 对象。
SerialClob(char[] ch)
按照给定 char 数组的序列化形式构造一个 SerialClob 对象。
SerialClob(Clob clob)
按照给定 Clob 对象的序列化形式构造一个 SerialClob 对象。
SerialDatalink(URL url)
根据给定的 java.net.URL 对象构造新的 SerialDatalink 对象。
SerialJavaObject(Object obj)
SerialJavaObject 帮助器类的构造方法。
SerialRef(Ref ref)
根据给定 Ref 对象构造 SerialRef 对象。
SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。
SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.serial.SerialJavaObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialJavaObject
的使用

没有 javax.sql.rowset.serial.SerialJavaObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.serial.SerialRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialRef
的使用

没有 javax.sql.rowset.serial.SerialRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.serial.SerialStruct 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialStruct
的使用

没有 javax.sql.rowset.serial.SerialStruct 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.serial.SQLInputImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SQLInputImpl
的使用

没有 javax.sql.rowset.serial.SQLInputImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.serial.SQLOutputImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SQLOutputImpl
的使用

没有 javax.sql.rowset.serial.SQLOutputImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.sql.rowset.spi (Java 2 Platform SE 6)

 javax.sql.rowset.spi
接口
SyncResolver
TransactionalWriter
XmlReader
XmlWriter
类
SyncFactory
SyncProvider
异常
SyncFactoryException
SyncProviderException


类 javax.sql.rowset.spi.SyncFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.spi.SyncFactory
的使用

使用 SyncFactory 的软件包
javax.sql.rowset.spi 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset.spi 中 SyncFactory 的使用

返回 SyncFactory 的 javax.sql.rowset.spi 中的方法
static SyncFactory SyncFactory.getSyncFactory()
返回一个 SyncFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.spi.SyncFactoryException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.spi.SyncFactoryException
的使用

使用 SyncFactoryException 的软件包
javax.sql.rowset.spi 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset.spi 中 SyncFactoryException 的使用

抛出 SyncFactoryException 的 javax.sql.rowset.spi 中的方法
static SyncProvider | SyncFactory.getInstance(String providerID) 返回 providerID 标识的 SyncProvider 实例。
static Logger | SyncFactory.getLogger() 返回应用程序的日志对象，以获取 SyncProvider 实现发送的同步事件。
static Enumeration<SyncProvider> | SyncFactory.getRegisteredProviders() 返回当前已注册的同步提供者所组成的枚举。
static void | SyncFactory.registerProvider(String providerID) 将给定的同步提供者添加到工厂注册器。
static void | SyncFactory.setJNDIContext(Context ctx) 设置初始 JNDI 上下文，通过该上下文可以从 JNDI 名称空间获取 SyncProvider 实现
static void | SyncFactory.unregisterProvider(String providerID) 从工厂 SPI 注册器移除指派的当前已注册同步提供者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.spi.SyncProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.spi.SyncProvider
的使用

使用 SyncProvider 的软件包
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset 中 SyncProvider 的使用

返回 SyncProvider 的 javax.sql.rowset 中的方法
 SyncProvider CachedRowSet.getSyncProvider()
获取此 CachedRowSet 对象的 SyncProvider 实现。

javax.sql.rowset.spi 中 SyncProvider 的使用

返回 SyncProvider 的 javax.sql.rowset.spi 中的方法
static SyncProvider SyncFactory.getInstance(String providerID)
返回 providerID 标识的 SyncProvider 实例。

返回变量类型为 SyncProvider 的类型的 javax.sql.rowset.spi 中的方法
static Enumeration<SyncProvider> SyncFactory.getRegisteredProviders()
返回当前已注册的同步提供者所组成的枚举。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.sql.rowset.spi.SyncProviderException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.spi.SyncProviderException
的使用

使用 SyncProviderException 的软件包
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset 中 SyncProviderException 的使用

抛出 SyncProviderException 的 javax.sql.rowset 中的方法
void | CachedRowSet.acceptChanges() 将对此 CachedRowSet 对象所做的行更新、插入以及删除更改传播到底层数据源。
void | CachedRowSet.acceptChanges(Connection con) 将所有行更新、插入以及删除更改传播到支持此 CachedRowSet 对象的数据源，使用指定的 Connection 对象建立到数据源的连接。

javax.sql.rowset.spi 中 SyncProviderException 的使用

抛出 SyncProviderException 的 javax.sql.rowset.spi 中的方法
abstract int | SyncProvider.getDataSourceLock() 返回在此 SyncProvider 实现中活动的当前数据源锁定严重性级别。
abstract void | SyncProvider.setDataSourceLock(int datasource_lock) 按照 datasource_lock 指示的级别在底层数据源上设置锁定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.spi.SyncResolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.spi.SyncResolver
的使用

使用 SyncResolver 的软件包
javax.sql.rowset.spi 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset.spi 中 SyncResolver 的使用

返回 SyncResolver 的 javax.sql.rowset.spi 中的方法
 SyncResolver SyncProviderException.getSyncResolver()
获取为此 SyncProviderException 对象设置的 SyncResolver 对象，如果没有设置，则获取包含在参考实现中的默认 SyncResolver 实现的实例。

参数类型为 SyncResolver 的 javax.sql.rowset.spi 中的方法
 void SyncProviderException.setSyncResolver(SyncResolver syncResolver)
将此 SyncProviderException 对象的 SyncResolver 对象设置为提供的对象。

参数类型为 SyncResolver 的 javax.sql.rowset.spi 中的构造方法
SyncProviderException(SyncResolver syncResolver)
构造带指定 SyncResolver 实例的 SyncProviderException 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.spi.TransactionalWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.spi.TransactionalWriter
的使用

没有 javax.sql.rowset.spi.TransactionalWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.spi.XmlReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.spi.XmlReader
的使用

没有 javax.sql.rowset.spi.XmlReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.sql.rowset.spi.XmlWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.spi.XmlWriter
的使用

没有 javax.sql.rowset.spi.XmlWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


Box.Filler.AccessibleBoxFiller (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 Box.Filler.AccessibleBoxFiller

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  javax.swing.Box.Filler.AccessibleBoxFiller
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
Box.Filler
protected class Box.Filler.AccessibleBoxFiller
extends Component.AccessibleAWTComponent

此类实现 Box.Filler 类的可访问性支持。

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Box.Filler.AccessibleBoxFiller()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Box.Filler.AccessibleBoxFiller

protected Box.Filler.AccessibleBoxFiller()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象 (AccessibleRole.FILLER) 的职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultRowSorter.ModelWrapper (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultRowSorter.ModelWrapper<M,I>

java.lang.Object
    继承者  javax.swing.DefaultRowSorter.ModelWrapper<M,I>
类型参数：
M - 底层模型的类型
I - 提供给过滤器的标识符
正在封闭类：
DefaultRowSorter<M,I>
protected abstract static class DefaultRowSorter.ModelWrapper<M,I>
extends Object

DefaultRowSorter.ModelWrapper 负责提供由 DefaultRowSorter 进行排序的数据。通常不直接与 ModelWrapper 进行交互。DefaultRowSorter 的子类提供包装另一个模型的 ModelWrapper 实现。例如，TableRowSorter 提供包装 TableModel 的 ModelWrapper。

ModelWrapper 将值以 Object 和 String 形式加以区分。这允许实现提供要使用的自定义字符串转换器，而不是在对象上调用 toString。

从以下版本开始：
1.6
另请参见：
RowFilter, RowFilter.Entry

构造方法摘要
protected DefaultRowSorter.ModelWrapper()
创建一个新的 ModelWrapper。
方法摘要
abstract int | getColumnCount() 返回模型中的列数。
abstract I | getIdentifier(int row) 返回指定行的标识符。
abstract M | getModel() 返回此 Model 包装的底层模型。
abstract int | getRowCount() 返回模型中的行数。
String | getStringValueAt(int row, int column) 以 String 的形式返回指定索引处的值。
abstract Object | getValueAt(int row, int column) 返回指定索引处的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultRowSorter.ModelWrapper

protected DefaultRowSorter.ModelWrapper()
创建一个新的 ModelWrapper。

方法详细信息

getModel

public abstract M getModel()
返回此 Model 包装的底层模型。

返回：
底层模型

getColumnCount

public abstract int getColumnCount()
返回模型中的列数。

返回：
模型中的列数

getRowCount

public abstract int getRowCount()
返回模型中的行数。

返回：
模型中的行数

getValueAt

public abstract Object getValueAt(int row,
                                  int column)
返回指定索引处的值。

参数：
row - 行索引
column - 列索引
返回：
指定索引处的值
抛出：
IndexOutOfBoundsException - 如果索引超出模型的范围

getStringValueAt

public String getStringValueAt(int row,
                               int column)
以 String 的形式返回指定索引处的值。此实现在 getValueAt 的结果上使用 toString（确保对 null 值返回一个空字符串）。重写此方法的子类不应该返回 null。

参数：
row - 行索引
column - 列索引
返回：
指定索引处 String 形式的值
抛出：
IndexOutOfBoundsException - 如果索引超出模型的范围

getIdentifier

public abstract I getIdentifier(int row)
返回指定行的标识符。此方法的返回值用作传递给 RowFilter 的 RowFilter.Entry 的标识符。

参数：
row - 要为其返回标识符的行，就底层模型而言
返回：
标识符
另请参见：
RowFilter.Entry.getIdentifier()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JComponent.AccessibleJComponent.AccessibleContainerHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JComponent.AccessibleJComponent.AccessibleContainerHandler

java.lang.Object
    继承者  javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
所有已实现的接口：
ContainerListener, EventListener
正在封闭类：
JComponent.AccessibleJComponent
protected class JComponent.AccessibleJComponent.AccessibleContainerHandler
extends Object
implements ContainerListener

添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

构造方法摘要
protected JComponent.AccessibleJComponent.AccessibleContainerHandler()
方法摘要
void | componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JComponent.AccessibleJComponent.AccessibleContainerHandler

protected JComponent.AccessibleJComponent.AccessibleContainerHandler()
方法详细信息

componentAdded

public void componentAdded(ContainerEvent e)
从接口 ContainerListener 复制的描述
已将组件添加到容器中时调用。

指定者：
接口 ContainerListener 中的 componentAdded

componentRemoved

public void componentRemoved(ContainerEvent e)
从接口 ContainerListener 复制的描述
已从容器中移除组件时调用。

指定者：
接口 ContainerListener 中的 componentRemoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JComponent.AccessibleJComponent.AccessibleFocusHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JComponent.AccessibleJComponent.AccessibleFocusHandler

java.lang.Object
    继承者  javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
JComponent.AccessibleJComponent
protected class JComponent.AccessibleJComponent.AccessibleFocusHandler
extends Object
implements FocusListener

发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

从以下版本开始：
1.3

构造方法摘要
protected JComponent.AccessibleJComponent.AccessibleFocusHandler()
方法摘要
void | focusGained(FocusEvent event) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent event) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JComponent.AccessibleJComponent.AccessibleFocusHandler

protected JComponent.AccessibleJComponent.AccessibleFocusHandler()
方法详细信息

focusGained

public void focusGained(FocusEvent event)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent event)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

java.lang.Object
    继承者  javax.accessibility.AccessibleHyperlink
        继承者  javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
所有已实现的接口：
AccessibleAction
正在封闭类：
JEditorPane.JEditorPaneAccessibleHypertextSupport
public class JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
extends AccessibleHyperlink

字段摘要
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element e)
方法摘要
boolean | doAccessibleAction(int i) 对该对象执行指定的 Action
Object | getAccessibleActionAnchor(int i) 返回表示适合于该链接的链接锚点的对象。
int | getAccessibleActionCount() 返回此 Link 中的可访问操作数目（如果有多个），不认为首个操作是此 LINK 对象的“默认”操作（例如，在 HTML imagemap 中）。
String | getAccessibleActionDescription(int i) 返回此特定链接操作的 String 描述。
Object | getAccessibleActionObject(int i) 返回表示该链接的 URL 对象。
int | getEndIndex() 获得此链接结束处该超文本文档的索引
int | getStartIndex() 获得此链接开始处该超文本文档的索引
boolean | isValid() 因为与某个链接相关联的文档可能已改变，所以此方法返回此 Link 是否仍然有效（关于它所引用的文档是否有效）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

public JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element e)
方法详细信息

isValid

public boolean isValid()
因为与某个链接相关联的文档可能已改变，所以此方法返回此 Link 是否仍然有效（关于它所引用的文档是否有效）。

指定者：
类 AccessibleHyperlink 中的 isValid
返回：
一个标志，指示此链接对于它所属的 AccessibleHypertext 而言是否仍然有效

getAccessibleActionCount

public int getAccessibleActionCount()
返回此 Link 中的可访问操作数目（如果有多个），不认为首个操作是此 LINK 对象的“默认”操作（例如，在 HTML imagemap 中）。通常，Link 中只有一个 AccessibleAction。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
指定者：
类 AccessibleHyperlink 中的 getAccessibleActionCount
返回：
此对象中从 0 开始的 Action 数

doAccessibleAction

public boolean doAccessibleAction(int i)
对该对象执行指定的 Action

指定者：
接口 AccessibleAction 中的 doAccessibleAction
指定者：
类 AccessibleHyperlink 中的 doAccessibleAction
参数：
i - 从 0 开始的操作索引
返回：
如果执行了该操作，则返回 true；否则返回 false。
另请参见：
getAccessibleActionCount()

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回此特定链接操作的 String 描述。返回的字符串是文档内的文本，而该文档与包含此链接的元素相关联。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
指定者：
类 AccessibleHyperlink 中的 getAccessibleActionDescription
参数：
i - 从 0 开始的操作索引
返回：
该操作的 String 描述
另请参见：
getAccessibleActionCount()

getAccessibleActionObject

public Object getAccessibleActionObject(int i)
返回表示该链接的 URL 对象。

指定者：
类 AccessibleHyperlink 中的 getAccessibleActionObject
参数：
i - 从 0 开始的操作索引
返回：
表示该 HTML 链接本身的 URL
另请参见：
getAccessibleActionCount()

getAccessibleActionAnchor

public Object getAccessibleActionAnchor(int i)
返回表示适合于该链接的链接锚点的对象。例如，从 HTML：Accessibility 中，此方法会返回包含下列文本的 String：'Accessibility'。 类似地，从此 HTML：<a HREF="#top"><img src="top-hat.gif" alt="top hat"></a> 中，此方法返回对象 ImageIcon("top-hat.gif", "top hat")。

指定者：
类 AccessibleHyperlink 中的 getAccessibleActionAnchor
参数：
i - 从 0 开始的操作索引
返回：
表示该超文本锚点的 Object
另请参见：
getAccessibleActionCount()

getStartIndex

public int getStartIndex()
获得此链接开始处该超文本文档的索引

指定者：
类 AccessibleHyperlink 中的 getStartIndex
返回：
链接开始处的索引

getEndIndex

public int getEndIndex()
获得此链接结束处该超文本文档的索引

指定者：
类 AccessibleHyperlink 中的 getEndIndex
返回：
链接结束处的索引
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
正在封闭类：
JInternalFrame.JDesktopIcon
protected class JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
extends JComponent.AccessibleJComponent
implements AccessibleValue

此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。它提供适合桌面图标用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue。
Number | getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | getMinimumAccessibleValue() 以 Number 形式获取此对象的最小值。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

protected JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue。在实现此类的 Java Accessibility API 时，返回此对象，它负责代表它自己实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
以 Number 形式获取此对象的值。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
该对象的值，如果此对象没有值，则可以为 null
另请参见：
AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置该值，则返回 true
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
以 Number 形式获取此对象的最小值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
对象的最小值；如果此对象没有最小值，则返回 null
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
以 Number 形式获取此对象的最大值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
对象的最大值；如果此对象没有最大值，则返回 null
另请参见：
AccessibleValue.getMinimumAccessibleValue()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JList.AccessibleJList.AccessibleJListChild (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JList.AccessibleJList.AccessibleJListChild

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  javax.swing.JList.AccessibleJList.AccessibleJListChild
所有已实现的接口：
Accessible, AccessibleComponent
正在封闭类：
JList.AccessibleJList
protected class JList.AccessibleJList.AccessibleJListChild
extends AccessibleContext
implements Accessible, AccessibleComponent

此类实现供 List 子级使用的可访问性支持。

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
JList.AccessibleJList.AccessibleJListChild(JList parent, int indexInParent)
方法摘要
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
void | addPropertyChangeListener(PropertyChangeListener l) 将 PropertyChangeListener 添加到侦听器列表。
boolean | contains(Point p) 检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
AccessibleAction | getAccessibleAction() 获取与此对象关联的可支持一个或多个动作的 AccessibleAction。
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | getAccessibleChild(int i) 返回该对象的指定 Accessible 子级。
int | getAccessibleChildrenCount() 返回该对象的可访问子级数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent。
AccessibleContext | getAccessibleContext() 获取此对象的 AccessibleContext。
String | getAccessibleDescription() 获取此对象的 accessibleDescription 属性。
AccessibleIcon[] | getAccessibleIcon() 返回元素渲染器的图标，作为 AccessibleIcon 数组的唯一项；如果渲染器组件不包含任何图标，则返回一个 null 数组。
int | getAccessibleIndexInParent() 获取此对象在其可访问父级中的基于零的索引。
String | getAccessibleName() 获取此对象的 accessibleName 属性。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态集合。
AccessibleText | getAccessibleText() 获取与在显示器上显示文本的此对象关联的 AccessibleText。
AccessibleValue | getAccessibleValue() 获取与此对象关联的支持 Numerical 值的 AccessibleValue。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 获取 Rectangle 对象形式的此对象的边界。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Locale | getLocale() 获取该组件的语言环境。
Point | getLocation() 获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isEnabled() 确定是否已启用该对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定是否正显示对象。
boolean | isVisible() 确定此对象是否可见。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
void | removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表移除 PropertyChangeListener。
void | requestFocus() 请求此对象的焦点。
void | setAccessibleDescription(String s) 设置此对象的可访问描述。
void | setAccessibleName(String s) 设置此对象的可访问的本地化名称。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 设置 Rectangle 对象形式的此对象的边界。
void | setCursor(Cursor c) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置对象相对于父级的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置对象的可见状态。
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleParent, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JList.AccessibleJList.AccessibleJListChild

public JList.AccessibleJList.AccessibleJListChild(JList parent,
                                                  int indexInParent)
方法详细信息

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取此对象的 AccessibleContext。在针对此类的 Java Accessibility API 的实现中，返回的是此对象，它是其本身的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
此对象

getAccessibleName

public String getAccessibleName()
从类 AccessibleContext 复制的描述
获取此对象的 accessibleName 属性。对象的 accessibleName 属性是指定该对象功能的本地化 String。例如，标签和按钮的 accessibleName 属性可以是标签或按钮本身的文本。对于不显示其名称的对象，仍应设置 accessibleName。例如，对于用于输入城市名称的文本字段，在 en_US 语言环境下，accessibleName 可以为 "city"。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
对象的本地化名称；如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

setAccessibleName

public void setAccessibleName(String s)
从类 AccessibleContext 复制的描述
设置此对象的可访问的本地化名称。更改名称将导致激发 ACCESSIBLE_NAME_PROPERTY 属性的 PropertyChangeEvent。

覆盖：
类 AccessibleContext 中的 setAccessibleName
参数：
s - 对象的新本地化名称。
另请参见：
AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleDescription

public String getAccessibleDescription()
从类 AccessibleContext 复制的描述
获取此对象的 accessibleDescription 属性。此对象的 accessibleDescription 属性是描述该对象功能的本地化短语。例如，对于 "Cancel" 按钮，accessibleDescription 可以是 "Ignore changes and close dialog box"（忽略更改并关闭对话框）。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
该对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

setAccessibleDescription

public void setAccessibleDescription(String s)
从类 AccessibleContext 复制的描述
设置此对象的可访问描述。更改名称将导致激发 ACCESSIBLE_DESCRIPTION_PROPERTY 属性的 PropertyChangeEvent。

覆盖：
类 AccessibleContext 中的 setAccessibleDescription
参数：
s - 此对象的新的本地化描述
另请参见：
AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public AccessibleRole getAccessibleRole()
从类 AccessibleContext 复制的描述
获取此对象的职责。对象的职责是此对象的类的一般功能或用途。例如，push 按钮的职责是 AccessibleRole.PUSH_BUTTON。AccessibleRole 中提供了一些职责，组件开发人员可以从一组预定义职责中进行选择。这就使辅助技术能为各种交互的组件子类（例如，对所有充当按钮的组件使用 AccessibleRole.PUSH_BUTTON）以及区分行为各异的子类（例如，复选框 AccessibleRole.CHECK_BOX 和单选框 AccessibleRole.RADIO_BUTTON）提供一致的接口。

注意，AccessibleRole 类也是可扩展的，因此如果预定义的职责集合不充分，则自定义组件的开发人员可以定义他们自己的 AccessibleRole。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
从类 AccessibleContext 复制的描述
获取此对象的状态集合。对象的 AccessibleStateSet 由一组唯一的 AccessibleState 组成。对象的 AccessibleStateSet 中的更改将导致激发 ACCESSIBLE_STATE_PROPERTY 属性的 PropertyChangeEvent。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含对象的当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleStateSet, AccessibleState, AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
从类 AccessibleContext 复制的描述
获取此对象在其可访问父级中的基于零的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
返回此对象在父级中从零开始的索引；如果此对象没有可访问父级，则返回 -1。
另请参见：
AccessibleContext.getAccessibleParent(),
AccessibleContext.getAccessibleChildrenCount(),
AccessibleContext.getAccessibleChild(int)

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
从类 AccessibleContext 复制的描述
返回该对象的可访问子级数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
该对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
从类 AccessibleContext 复制的描述
返回该对象的指定 Accessible 子级。Accessible 对象的 Accessible 子级是从零开始的，因此 Accessible 对象的第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 子级从零开始的索引
返回：
对象的 Accessible 子级
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
从类 AccessibleContext 复制的描述
获取该组件的语言环境。如果该组件没有语言环境，则返回其父级的语言环境。

指定者：
类 AccessibleContext 中的 getLocale
返回：
此组件的语言环境。如果此组件没有语言环境，则返回其父级的语言环境。

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener l)
从类 AccessibleContext 复制的描述
将 PropertyChangeListener 添加到侦听器列表。此侦听器为所有 Accessible 属性注册，并且将在这些属性发生更改时调用。

覆盖：
类 AccessibleContext 中的 addPropertyChangeListener
参数：
l - 要添加的 PropertyChangeListener
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener l)
从类 AccessibleContext 复制的描述
从侦听器列表移除 PropertyChangeListener。此方法移除一个为所有属性注册的 PropertyChangeListener。

覆盖：
类 AccessibleContext 中的 removePropertyChangeListener
参数：
l - 要移除的 PropertyChangeListener

getAccessibleAction

public AccessibleAction getAccessibleAction()
从类 AccessibleContext 复制的描述
获取与此对象关联的可支持一个或多个动作的 AccessibleAction。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
如果受对象支持，则返回 AccessibleAction；否则返回 null
另请参见：
AccessibleAction

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其本身实现 AccessibleComponent 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
此对象
另请参见：
AccessibleComponent

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
从类 AccessibleContext 复制的描述
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
如果受对象支持，则返回 AccessibleSelection；否则返回 null
另请参见：
AccessibleSelection

getAccessibleText

public AccessibleText getAccessibleText()
从类 AccessibleContext 复制的描述
获取与在显示器上显示文本的此对象关联的 AccessibleText。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
如果受对象支持，则返回 AccessibleText；否则返回 null
另请参见：
AccessibleText

getAccessibleValue

public AccessibleValue getAccessibleValue()
从类 AccessibleContext 复制的描述
获取与此对象关联的支持 Numerical 值的 AccessibleValue。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
如果受对象支持，则返回 AccessibleValue；否则返回 null
另请参见：
AccessibleValue

getBackground

public Color getBackground()
从接口 AccessibleComponent 复制的描述
获取此对象的背景色。

指定者：
接口 AccessibleComponent 中的 getBackground
返回：
如果支持的话，返回对象的背景色；否则返回 null
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
从接口 AccessibleComponent 复制的描述
设置此对象的背景色。

指定者：
接口 AccessibleComponent 中的 setBackground
参数：
c - 新的背景 Color
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

getForeground

public Color getForeground()
从接口 AccessibleComponent 复制的描述
获取此对象的前景色。

指定者：
接口 AccessibleComponent 中的 getForeground
返回：
如果支持的话，返回对象的前景色；否则返回 null
另请参见：
AccessibleComponent.setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
从接口 AccessibleComponent 复制的描述
设置此对象的前景色。

指定者：
接口 AccessibleComponent 中的 setForeground
参数：
c - 新的前景 Color
另请参见：
AccessibleComponent.getForeground()

getCursor

public Cursor getCursor()
从接口 AccessibleComponent 复制的描述
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
返回：
如果支持的话，返回对象的 Cursor；否则返回 null
另请参见：
AccessibleComponent.setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor c)
从接口 AccessibleComponent 复制的描述
设置此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 setCursor
参数：
c - 对象的新 Cursor
另请参见：
AccessibleComponent.getCursor()

getFont

public Font getFont()
从接口 AccessibleComponent 复制的描述
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
返回：
如果支持的话，返回对象的 Font；否则返回 null
另请参见：
AccessibleComponent.setFont(java.awt.Font)

setFont

public void setFont(Font f)
从接口 AccessibleComponent 复制的描述
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
参数：
f - 对象的新 Font
另请参见：
AccessibleComponent.getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
从接口 AccessibleComponent 复制的描述
获取此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
参数：
f - Font
返回：
如果支持的话，返回对象的 FontMetrics；否则返回 null
另请参见：
AccessibleComponent.getFont()

isEnabled

public boolean isEnabled()
从接口 AccessibleComponent 复制的描述
确定是否已启用该对象。启用的对象在其 AccessibleStateSet 中也将具有 AccessibleState.ENABLED 状态设置。

指定者：
接口 AccessibleComponent 中的 isEnabled
返回：
如果已启用对象，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则禁用它
另请参见：
AccessibleComponent.isEnabled()

isVisible

public boolean isVisible()
从接口 AccessibleComponent 复制的描述
确定此对象是否可见。注：这意味着该对象多半是可见的；但是因为包含此对象的对象之一目前不可见，所以可能在屏幕上不显示它。要确定对象是否在屏幕上显示，需要使用 isShowing()。

可见的对象在其 AccessibleStateSet 中也将具有 AccessibleState.VISIBLE 状态设置。

指定者：
接口 AccessibleComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则隐藏它
另请参见：
AccessibleComponent.isVisible()

isShowing

public boolean isShowing()
从接口 AccessibleComponent 复制的描述
确定是否正显示对象。通过检查该对象和祖先的可见性可确定这一点。注：即使该对象被另一对象屏蔽（例如，它是下拉菜单的下级），仍然返回 true。

指定者：
接口 AccessibleComponent 中的 isShowing
返回：
如果正在显示对象，则返回 true；否则，返回 false

contains

public boolean contains(Point p)
从接口 AccessibleComponent 复制的描述
检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。

指定者：
接口 AccessibleComponent 中的 contains
参数：
p - 相对于对象的坐标系统的 Point
返回：
如果对象包含 Point，则返回 true；否则返回 false
另请参见：
AccessibleComponent.getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
从接口 AccessibleComponent 复制的描述
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
返回：
返回对象在屏幕上的位置；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

getLocation

public Point getLocation()
从接口 AccessibleComponent 复制的描述
获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
返回：
Point 的实例，该点表示屏幕坐标空间中对象边界的左上角 ；如果此对象或其父级不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

setLocation

public void setLocation(Point p)
从接口 AccessibleComponent 复制的描述
设置对象相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
AccessibleComponent.getLocation()

getBounds

public Rectangle getBounds()
从接口 AccessibleComponent 复制的描述
获取 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
返回：
返回指示此组件的边界的矩形；如果此对象不在屏幕上，则返回 null。
另请参见：
AccessibleComponent.contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
从接口 AccessibleComponent 复制的描述
设置 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
参数：
r - 指示此组件边界的矩形
另请参见：
AccessibleComponent.getBounds()

getSize

public Dimension getSize()
从接口 AccessibleComponent 复制的描述
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的 height 字段包含此对象的高度，Dimension 对象的 width 字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
从接口 AccessibleComponent 复制的描述
调整此对象，使其具有高度和宽度。

指定者：
接口 AccessibleComponent 中的 setSize
参数：
d - 指定对象新大小的维数。
另请参见：
AccessibleComponent.getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
从接口 AccessibleComponent 复制的描述
返回本地坐标 Point 包含的可访问子级（如果存在）。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
参数：
p - 相对于此对象坐标系统的 point。
返回：
如果存在，则返回指定位置处的 Accessible；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
从接口 AccessibleComponent 复制的描述
返回此对象是否可以接受焦点。可以接受焦点的对象也将具有在其 AccessibleStateSet 中设置的 AccessibleState.FOCUSABLE 状态。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
从接口 AccessibleComponent 复制的描述
请求此对象的焦点。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
另请参见：
AccessibleComponent.isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
添加指定的焦点侦听器，以接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.addFocusListener(java.awt.event.FocusListener)

getAccessibleIcon

public AccessibleIcon[] getAccessibleIcon()
返回元素渲染器的图标，作为 AccessibleIcon 数组的唯一项；如果渲染器组件不包含任何图标，则返回一个 null 数组。

覆盖：
类 AccessibleContext 中的 getAccessibleIcon
返回：
包含可访问图标的数组；如果不包含任何图标，则返回一个 null 数组
从以下版本开始：
1.3
另请参见：
AccessibleIcon
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTable.AccessibleJTable.AccessibleJTableCell (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTable.AccessibleJTable.AccessibleJTableCell

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
所有已实现的接口：
Accessible, AccessibleComponent
正在封闭类：
JTable.AccessibleJTable
protected class JTable.AccessibleJTable.AccessibleJTableCell
extends AccessibleContext
implements Accessible, AccessibleComponent

此类提供了适用于表单元格的 Java Accessibility API 实现。

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
JTable.AccessibleJTable.AccessibleJTableCell(JTable t, int r, int c, int i)
构造一个 AccessibleJTableHeaderEntry。
方法摘要
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
void | addPropertyChangeListener(PropertyChangeListener l) 将一个 PropertyChangeListener 添加到侦听器列表中。
boolean | contains(Point p) 检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系统相关。
AccessibleAction | getAccessibleAction() 获取与此对象关联的 AccessibleAction（如果存在）。
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | getAccessibleChild(int i) 返回此对象的指定的 Accessible 子对象。
int | getAccessibleChildrenCount() 返回此对象中可访问的子对象数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent（如果存在）。
AccessibleContext | getAccessibleContext() 获取与此组件关联的 AccessibleContext。
String | getAccessibleDescription() 获取此对象的可访问的描述。
int | getAccessibleIndexInParent() 获取此对象在其可访问的父对象中的索引。
String | getAccessibleName() 获取此对象的可访问的名称。
Accessible | getAccessibleParent() 获取此对象的 Accessible 父对象。
AccessibleRole | getAccessibleRole() 获取此对象的功能。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection（如果存在）。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
AccessibleText | getAccessibleText() 获取与此对象关联的 AccessibleText （如果存在）。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue（如果存在）。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 获取 Rectangle 对象形式的此对象的边界。
protected AccessibleContext | getCurrentAccessibleContext() 获取表单元格渲染器的 AccessibleContext。
protected Component | getCurrentComponent() 获取表单元格渲染器组件。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Locale | getLocale() 获取该组件的语言环境。
Point | getLocation() 以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isEnabled() 确定是否启用该对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定该对象是否正在显示。
boolean | isVisible() 确定该对象是否可见。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
void | removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表移除一个 PropertyChangeListener。
void | requestFocus() 请求此对象的焦点。
void | setAccessibleDescription(String s) 设置此对象的可访问的描述。
void | setAccessibleName(String s) 获取此对象的可访问的本地化名称。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 设置 Rectangle 对象形式的此对象的边界。
void | setCursor(Cursor c) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置该对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置该对象相对于父对象的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置该对象的可见状态。
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JTable.AccessibleJTable.AccessibleJTableCell

public JTable.AccessibleJTable.AccessibleJTableCell(JTable t,
                                                    int r,
                                                    int c,
                                                    int i)
构造一个 AccessibleJTableHeaderEntry。

从以下版本开始：
1.4
方法详细信息

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此组件关联的 AccessibleContext。在此类的 Java Accessibility API 的实现中，返回的是此对象，它是其本身的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
此对象

getCurrentAccessibleContext

protected AccessibleContext getCurrentAccessibleContext()
获取表单元格渲染器的 AccessibleContext。

返回：
表单元格渲染器的 AccessibleContext（如果存在）；否则返回 null。
从以下版本开始：
1.6

getCurrentComponent

protected Component getCurrentComponent()
获取表单元格渲染器组件。

返回：
表单元格渲染器组件（如果存在）；否则返回 null
从以下版本开始：
1.6

getAccessibleName

public String getAccessibleName()
获取此对象的可访问的名称。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
此对象的本地化名称，如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

setAccessibleName

public void setAccessibleName(String s)
获取此对象的可访问的本地化名称。

覆盖：
类 AccessibleContext 中的 setAccessibleName
参数：
s - 此对象新的本地化名称
另请参见：
AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleDescription

public String getAccessibleDescription()
获取此对象的可访问的描述。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
此对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

setAccessibleDescription

public void setAccessibleDescription(String s)
设置此对象的可访问的描述。

覆盖：
类 AccessibleContext 中的 setAccessibleDescription
参数：
s - 此对象的新的本地化描述
另请参见：
AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的功能。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述此对象功能的 AccessibleRole 的实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含该对象当前状态设置的 AccessibleStateSet 的实例
另请参见：
AccessibleState

getAccessibleParent

public Accessible getAccessibleParent()
获取此对象的 Accessible 父对象。

覆盖：
类 AccessibleContext 中的 getAccessibleParent
返回：
此对象的可访问的父对象；如果此对象没有 Accessible 父对象，则返回 null

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获取此对象在其可访问的父对象中的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
此对象在其父对象中的索引；如果此对象没有可访问的父对象，则返回 -1
另请参见：
getAccessibleParent()

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回此对象中可访问的子对象数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
此对象中可访问的子对象数

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回此对象的指定的 Accessible 子对象。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 基于 0 的子容器索引
返回：
对象的 Accessible 子容器
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
获取该组件的语言环境。如果该组件没有语言环境，则返回其父级的语言环境。

指定者：
类 AccessibleContext 中的 getLocale
返回：
组件的语言环境；如果此组件没有语言环境，则返回其父级的语言环境
抛出：
IllegalComponentStateException - 如果 Component 没有其自己的语言环境，并且尚未添加到包含层次结构中（如果添加到包含层次结构中就可以从其父级确定语言环境）
另请参见：
Component.setLocale(java.util.Locale)

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener l)
将一个 PropertyChangeListener 添加到侦听器列表中。侦听器为所有的属性注册。

覆盖：
类 AccessibleContext 中的 addPropertyChangeListener
参数：
l - 要添加的 PropertyChangeListener
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener l)
从侦听器列表移除一个 PropertyChangeListener。此方法移除了一个为所有属性注册的 PropertyChangeListener。

覆盖：
类 AccessibleContext 中的 removePropertyChangeListener
参数：
l - 要移除的 PropertyChangeListener

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象关联的 AccessibleAction（如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
AccessibleAction 或 null
另请参见：
AccessibleAction

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent（如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
AccessibleComponent 或 null
另请参见：
AccessibleComponent

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象关联的 AccessibleSelection（如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
AccessibleSelection 或 null
另请参见：
AccessibleSelection

getAccessibleText

public AccessibleText getAccessibleText()
获取与此对象关联的 AccessibleText （如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
AccessibleText 或 null
另请参见：
AccessibleText

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue（如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
AccessibleValue 或 null
另请参见：
AccessibleValue

getBackground

public Color getBackground()
获取此对象的背景色。

指定者：
接口 AccessibleComponent 中的 getBackground
返回：
该对象的背景色（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
设置此对象的背景色。

指定者：
接口 AccessibleComponent 中的 setBackground
参数：
c - 该背景的新 Color
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

getForeground

public Color getForeground()
获取此对象的前景色。

指定者：
接口 AccessibleComponent 中的 getForeground
返回：
该对象的前景色（如果受支持）；否则，返回 null
另请参见：
AccessibleComponent.setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
设置此对象的前景色。

指定者：
接口 AccessibleComponent 中的 setForeground
参数：
c - 该前景的新的 Color
另请参见：
AccessibleComponent.getForeground()

getCursor

public Cursor getCursor()
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
返回：
对象的 Cursor（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor c)
设置此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 setCursor
参数：
c - 此对象的新的 Cursor
另请参见：
AccessibleComponent.getCursor()

getFont

public Font getFont()
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
返回：
该对象的 Font（如果受支持）；否则，返回 null
另请参见：
AccessibleComponent.setFont(java.awt.Font)

setFont

public void setFont(Font f)
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
参数：
f - 该对象的新 Font
另请参见：
AccessibleComponent.getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
获取此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
参数：
f - Font
返回：
FontMetrics 对象（如果受支持）；否则返回 null
另请参见：
getFont()

isEnabled

public boolean isEnabled()
确定是否启用该对象。

指定者：
接口 AccessibleComponent 中的 isEnabled
返回：
如果启用了该对象，则返回 true；否则，返回 false
另请参见：
AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
设置该对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则，禁用它
另请参见：
AccessibleComponent.isEnabled()

isVisible

public boolean isVisible()
确定该对象是否可见。注：这意味着该对象是可见的；但是，它实际上不显示在屏幕上，因为包含此对象的对象中的一个对象不可见。要确定某一对象是否在屏幕上显示，请使用 isShowing。

指定者：
接口 AccessibleComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则，返回 false
另请参见：
AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
设置该对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则，隐藏它
另请参见：
AccessibleComponent.isVisible()

isShowing

public boolean isShowing()
确定该对象是否正在显示。通过检查该对象的可见性和祖先可确定这一点。注：这将返回 true，即使该对象被另一个对象遮掩（例如，该对象碰巧在下拉菜单的下面）。

指定者：
接口 AccessibleComponent 中的 isShowing
返回：
如果对象正在显示，则返回 true；否则，返回 false

contains

public boolean contains(Point p)
检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系统相关。

指定者：
接口 AccessibleComponent 中的 contains
参数：
p - 与该对象的坐标系统相关的 Point
返回：
如果对象包含 Point，则返回 true；否则，返回 false
另请参见：
AccessibleComponent.getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
返回：
屏幕上对象的位置（如果此对象不在屏幕上，则可以为 null）
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

getLocation

public Point getLocation()
以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
返回：
表示该屏幕坐标空间中对象边界的左上角的 Point的实例；如果此对象或其父对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

setLocation

public void setLocation(Point p)
设置该对象相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
AccessibleComponent.getLocation()

getBounds

public Rectangle getBounds()
从接口 AccessibleComponent 复制的描述
获取 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
返回：
返回指示此组件的边界的矩形；如果此对象不在屏幕上，则返回 null。
另请参见：
AccessibleComponent.contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
从接口 AccessibleComponent 复制的描述
设置 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
参数：
r - 指示此组件边界的矩形
另请参见：
AccessibleComponent.getBounds()

getSize

public Dimension getSize()
从接口 AccessibleComponent 复制的描述
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的 height 字段包含此对象的高度，Dimension 对象的 width 字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
从接口 AccessibleComponent 复制的描述
调整此对象，使其具有高度和宽度。

指定者：
接口 AccessibleComponent 中的 setSize
参数：
d - 指定对象新大小的维数。
另请参见：
AccessibleComponent.getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
从接口 AccessibleComponent 复制的描述
返回本地坐标 Point 包含的可访问子级（如果存在）。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
参数：
p - 相对于此对象坐标系统的 point。
返回：
如果存在，则返回指定位置处的 Accessible；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
从接口 AccessibleComponent 复制的描述
返回此对象是否可以接受焦点。可以接受焦点的对象也将具有在其 AccessibleStateSet 中设置的 AccessibleState.FOCUSABLE 状态。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
从接口 AccessibleComponent 复制的描述
请求此对象的焦点。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
另请参见：
AccessibleComponent.isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
添加指定的焦点侦听器，以接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.addFocusListener(java.awt.event.FocusListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTable.AccessibleJTable.AccessibleJTableModelChange (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTable.AccessibleJTable.AccessibleJTableModelChange

java.lang.Object
    继承者  javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
所有已实现的接口：
AccessibleTableModelChange
正在封闭类：
JTable.AccessibleJTable
protected class JTable.AccessibleJTable.AccessibleJTableModelChange
extends Object
implements AccessibleTableModelChange

字段摘要
protected int | firstColumn
protected int | firstRow
protected int | lastColumn
protected int | lastRow
protected int | type
从接口 javax.accessibility.AccessibleTableModelChange 继承的字段
DELETE, INSERT, UPDATE
构造方法摘要
protected JTable.AccessibleJTable.AccessibleJTableModelChange(int type, int firstRow, int lastRow, int firstColumn, int lastColumn)
方法摘要
int | getFirstColumn() 返回已更改的第一列。
int | getFirstRow() 返回已更改的第一行。
int | getLastColumn() 返回已更改的最后一列。
int | getLastRow() 返回已更改的最后一行。
int | getType() 返回事件的类型
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

type

protected int type

firstRow

protected int firstRow

lastRow

protected int lastRow

firstColumn

protected int firstColumn

lastColumn

protected int lastColumn
构造方法详细信息

JTable.AccessibleJTable.AccessibleJTableModelChange

protected JTable.AccessibleJTable.AccessibleJTableModelChange(int type,
                                                              int firstRow,
                                                              int lastRow,
                                                              int firstColumn,
                                                              int lastColumn)
方法详细信息

getType

public int getType()
从接口 AccessibleTableModelChange 复制的描述
返回事件的类型

指定者：
接口 AccessibleTableModelChange 中的 getType
另请参见：
AccessibleTableModelChange.INSERT, AccessibleTableModelChange.UPDATE, AccessibleTableModelChange.DELETE

getFirstRow

public int getFirstRow()
从接口 AccessibleTableModelChange 复制的描述
返回已更改的第一行。

指定者：
接口 AccessibleTableModelChange 中的 getFirstRow

getLastRow

public int getLastRow()
从接口 AccessibleTableModelChange 复制的描述
返回已更改的最后一行。

指定者：
接口 AccessibleTableModelChange 中的 getLastRow

getFirstColumn

public int getFirstColumn()
从接口 AccessibleTableModelChange 复制的描述
返回已更改的第一列。

指定者：
接口 AccessibleTableModelChange 中的 getFirstColumn

getLastColumn

public int getLastColumn()
从接口 AccessibleTableModelChange 复制的描述
返回已更改的最后一列。

指定者：
接口 AccessibleTableModelChange 中的 getLastColumn
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTree.AccessibleJTree.AccessibleJTreeNode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTree.AccessibleJTree.AccessibleJTreeNode

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
所有已实现的接口：
Accessible, AccessibleAction, AccessibleComponent, AccessibleSelection
正在封闭类：
JTree.AccessibleJTree
protected class JTree.AccessibleJTree.AccessibleJTreeNode
extends AccessibleContext
implements Accessible, AccessibleComponent, AccessibleSelection, AccessibleAction

此类实现 JTree 子类的可访问性支持。它提供适合树节点的 Java Accessibility API 实现。

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
构造一个 AccessibleJTreeNode
方法摘要
void | addAccessibleSelection(int i) 将对象中指定选择的项添加到对象的选择中。
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
void | addPropertyChangeListener(PropertyChangeListener l) 将 PropertyChangeListener 添加到侦听器列表。
void | clearAccessibleSelection() 清除对象中的选择，这样此对象中什么也没有选择。
boolean | contains(Point p) 检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
boolean | doAccessibleAction(int i) 执行树节点上的指定操作。
AccessibleAction | getAccessibleAction() 获取与此对象关联的 AccessibleAction。
int | getAccessibleActionCount() 返回此树节点中可用的可访问操作数。
String | getAccessibleActionDescription(int i) 返回该树节点的指定操作的描述。
Accessible | getAccessibleAt(Point p) 返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
Accessible | getAccessibleChild(int i) 返回对象的指定 Accessible 子对象。
int | getAccessibleChildrenCount() 返回对象中的可访问子对象数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent。
AccessibleContext | getAccessibleContext() 获取与此树节点关联的 AccessibleContext。
String | getAccessibleDescription() 获取此对象的可访问的描述。
int | getAccessibleIndexInParent() 获取此对象在其可访问父对象中的索引。
String | getAccessibleName() 获取此对象的可访问名称。
Accessible | getAccessibleParent() 获取此对象的 Accessible 父对象。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection（如果存在）。
Accessible | getAccessibleSelection(int i) 返回表示对象中指定选择项的 Accessible。
int | getAccessibleSelectionCount() 返回当前选中的项数。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
AccessibleText | getAccessibleText() 获取与此对象关联的 AccessibleText（如果存在）。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue（如果存在）。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 获取 Rectangle 对象形式的此对象的边界。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Locale | getLocale() 获取组件的区域。
Point | getLocation() 获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
protected Point | getLocationInJTree()
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isAccessibleChildSelected(int i) 如果选择了此对象的当前子对象，则返回 true。
boolean | isEnabled() 确定是否已启用该对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定是否正显示对象。
boolean | isVisible() 确定此对象是否可见。
void | removeAccessibleSelection(int i) 将该对象中指定选择的项从该对象的选择中移除。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
void | removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表中移除 PropertyChangeListener。
void | requestFocus() 请求此对象的焦点。
void | selectAllAccessibleSelection() 导致该对象中的所有选择项都被选中，前提是该对象支持多个选择。
void | setAccessibleDescription(String s) 设置此对象的可访问描述。
void | setAccessibleName(String s) 设置此对象的本地化可访问名称。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 设置 Rectangle 对象形式的此对象的边界。
void | setCursor(Cursor c) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置对象相对于父级的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置对象的可见状态。
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JTree.AccessibleJTree.AccessibleJTreeNode

public JTree.AccessibleJTree.AccessibleJTreeNode(JTree t,
                                                 TreePath p,
                                                 Accessible ap)
构造一个 AccessibleJTreeNode

从以下版本开始：
1.4
方法详细信息

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此树节点关联的 AccessibleContext。在此类的 Java Accessibility API 的实现中，返回的是此对象，它是其自身的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
此对象

getAccessibleName

public String getAccessibleName()
获取此对象的可访问名称。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
对象的本地化名称；如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

setAccessibleName

public void setAccessibleName(String s)
设置此对象的本地化可访问名称。

覆盖：
类 AccessibleContext 中的 setAccessibleName
参数：
s - 对象的新本地化名称。
另请参见：
AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleDescription

public String getAccessibleDescription()
获取此对象的可访问的描述。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

setAccessibleDescription

public void setAccessibleDescription(String s)
设置此对象的可访问描述。

覆盖：
类 AccessibleContext 中的 setAccessibleDescription
参数：
s - 此对象的新的本地化描述
另请参见：
AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含对象当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleState

getAccessibleParent

public Accessible getAccessibleParent()
获取此对象的 Accessible 父对象。

覆盖：
类 AccessibleContext 中的 getAccessibleParent
返回：
此对象的 Accessible 父对象；如果此对象没有 Accessible 父对象，则返回 null

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获取此对象在其可访问父对象中的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
返回此对象的父对象中的索引；如果此对象没有可访问父对象，则返回 -1。
另请参见：
getAccessibleParent()

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象中的可访问子对象数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
对象的可访问子对象数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的指定 Accessible 子对象。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 从零开始的子对象索引
返回：
对象的 Accessible 子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
获取组件的区域。如果该组件没有区域，则返回其父级的区域。

指定者：
类 AccessibleContext 中的 getLocale
返回：
此组件的区域。如果此组件没有区域，则返回其父级的区域。
抛出：
IllegalComponentStateException - 如果该 Component 没有自己的区域，并且尚未被添加到包含层次结构（那样可以从包含父级确定其区域）。
另请参见：
Component.setLocale(java.util.Locale)

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener l)
将 PropertyChangeListener 添加到侦听器列表。此侦听器为所有属性注册。

覆盖：
类 AccessibleContext 中的 addPropertyChangeListener
参数：
l - 要添加的 PropertyChangeListener
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener l)
从侦听器列表中移除 PropertyChangeListener。此方法移除了一个为所有属性注册的 PropertyChangeListener。

覆盖：
类 AccessibleContext 中的 removePropertyChangeListener
参数：
l - 要移除的 PropertyChangeListener

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象关联的 AccessibleAction。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其自身实现 AccessibleAction 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
此对象
另请参见：
AccessibleAction

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其自身实现 AccessibleComponent 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
此对象
另请参见：
AccessibleComponent

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象关联的 AccessibleSelection（如果存在）。否则，返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
AccessibleSelection 或 null
另请参见：
AccessibleSelection

getAccessibleText

public AccessibleText getAccessibleText()
获取与此对象关联的 AccessibleText（如果存在）。否则，返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
AccessibleText 或 null
另请参见：
AccessibleText

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue（如果存在）。否则，返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
AccessibleValue 或 null
另请参见：
AccessibleValue

getBackground

public Color getBackground()
获取此对象的背景色。

指定者：
接口 AccessibleComponent 中的 getBackground
返回：
对象的背景色（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
设置此对象的背景色。

指定者：
接口 AccessibleComponent 中的 setBackground
参数：
c - 背景的新颜色
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

getForeground

public Color getForeground()
获取此对象的前景色。

指定者：
接口 AccessibleComponent 中的 getForeground
返回：
对象的前景色（如果受支持）；否则，返回 null
另请参见：
AccessibleComponent.setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
从接口 AccessibleComponent 复制的描述
设置此对象的前景色。

指定者：
接口 AccessibleComponent 中的 setForeground
参数：
c - 新的前景 Color
另请参见：
AccessibleComponent.getForeground()

getCursor

public Cursor getCursor()
从接口 AccessibleComponent 复制的描述
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
返回：
如果支持的话，返回对象的 Cursor；否则返回 null
另请参见：
AccessibleComponent.setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor c)
从接口 AccessibleComponent 复制的描述
设置此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 setCursor
参数：
c - 对象的新 Cursor
另请参见：
AccessibleComponent.getCursor()

getFont

public Font getFont()
从接口 AccessibleComponent 复制的描述
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
返回：
如果支持的话，返回对象的 Font；否则返回 null
另请参见：
AccessibleComponent.setFont(java.awt.Font)

setFont

public void setFont(Font f)
从接口 AccessibleComponent 复制的描述
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
参数：
f - 对象的新 Font
另请参见：
AccessibleComponent.getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
从接口 AccessibleComponent 复制的描述
获取此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
参数：
f - Font
返回：
如果支持的话，返回对象的 FontMetrics；否则返回 null
另请参见：
AccessibleComponent.getFont()

isEnabled

public boolean isEnabled()
从接口 AccessibleComponent 复制的描述
确定是否已启用该对象。启用的对象在其 AccessibleStateSet 中也将具有 AccessibleState.ENABLED 状态设置。

指定者：
接口 AccessibleComponent 中的 isEnabled
返回：
如果已启用对象，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则禁用它
另请参见：
AccessibleComponent.isEnabled()

isVisible

public boolean isVisible()
从接口 AccessibleComponent 复制的描述
确定此对象是否可见。注：这意味着该对象多半是可见的；但是因为包含此对象的对象之一目前不可见，所以可能在屏幕上不显示它。要确定对象是否在屏幕上显示，需要使用 isShowing()。

可见的对象在其 AccessibleStateSet 中也将具有 AccessibleState.VISIBLE 状态设置。

指定者：
接口 AccessibleComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则隐藏它
另请参见：
AccessibleComponent.isVisible()

isShowing

public boolean isShowing()
从接口 AccessibleComponent 复制的描述
确定是否正显示对象。通过检查该对象和祖先的可见性可确定这一点。注：即使该对象被另一对象屏蔽（例如，它是下拉菜单的下级），仍然返回 true。

指定者：
接口 AccessibleComponent 中的 isShowing
返回：
如果正在显示对象，则返回 true；否则，返回 false

contains

public boolean contains(Point p)
从接口 AccessibleComponent 复制的描述
检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。

指定者：
接口 AccessibleComponent 中的 contains
参数：
p - 相对于对象的坐标系统的 Point
返回：
如果对象包含 Point，则返回 true；否则返回 false
另请参见：
AccessibleComponent.getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
从接口 AccessibleComponent 复制的描述
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
返回：
返回对象在屏幕上的位置；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

getLocationInJTree

protected Point getLocationInJTree()

getLocation

public Point getLocation()
从接口 AccessibleComponent 复制的描述
获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
返回：
Point 的实例，该点表示屏幕坐标空间中对象边界的左上角 ；如果此对象或其父级不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

setLocation

public void setLocation(Point p)
从接口 AccessibleComponent 复制的描述
设置对象相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
AccessibleComponent.getLocation()

getBounds

public Rectangle getBounds()
从接口 AccessibleComponent 复制的描述
获取 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
返回：
返回指示此组件的边界的矩形；如果此对象不在屏幕上，则返回 null。
另请参见：
AccessibleComponent.contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
从接口 AccessibleComponent 复制的描述
设置 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
参数：
r - 指示此组件边界的矩形
另请参见：
AccessibleComponent.getBounds()

getSize

public Dimension getSize()
从接口 AccessibleComponent 复制的描述
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的 height 字段包含此对象的高度，Dimension 对象的 width 字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
从接口 AccessibleComponent 复制的描述
调整此对象，使其具有高度和宽度。

指定者：
接口 AccessibleComponent 中的 setSize
参数：
d - 指定对象新大小的维数。
另请参见：
AccessibleComponent.getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。否则返回 null。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
参数：
p - 此 Accessible 的本地坐标中的点
返回：
在指定位置的 Accessible（如果存在）；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
从接口 AccessibleComponent 复制的描述
返回此对象是否可以接受焦点。可以接受焦点的对象也将具有在其 AccessibleStateSet 中设置的 AccessibleState.FOCUSABLE 状态。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
从接口 AccessibleComponent 复制的描述
请求此对象的焦点。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
另请参见：
AccessibleComponent.isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
添加指定的焦点侦听器，以接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.addFocusListener(java.awt.event.FocusListener)

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
返回当前选中的项数。如果未选择项，则返回值 0。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
当前选择的项数。

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
返回表示对象中指定选择项的 Accessible。如果没有作出选择，或者所选项数少于传入的整数，则返回值为 null。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选项的从零开始的索引
返回：
包含所选项的 Accessible
另请参见：
AccessibleSelection.getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
如果选择了此对象的当前子对象，则返回 true。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象的子对象的从零开始的索引。
返回：
如果此对象的当前子级已选中，则返回 true；否则返回 false。
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
将对象中指定选择的项添加到对象的选择中。如果对象支持多种选择，则将指定项添加到所有现有选择中，否则它将替换对象中的所有现有选择。如果已经选择了指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 可选择项的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

removeAccessibleSelection

public void removeAccessibleSelection(int i)
将该对象中指定选择的项从该对象的选择中移除。如果当前没有选择指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 可选择项的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
清除对象中的选择，这样此对象中什么也没有选择。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
导致该对象中的所有选择项都被选中，前提是该对象支持多个选择。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection

getAccessibleActionCount

public int getAccessibleActionCount()
返回此树节点中可用的可访问操作数。如果此节点不是叶节点，则除 TreeCellRenderer 后面对象上所有可用操作外，至少还存在一个操作（切换展开）。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
此对象中的操作数

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回该树节点的指定操作的描述。如果此节点不是叶节点，则除 TreeCellRenderer 后面对象上所有可用操作外，至少还存在一个操作描述（切换展开）。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 该操作的从零开始的索引
返回：
该操作的描述
另请参见：
AccessibleAction.getAccessibleActionCount()

doAccessibleAction

public boolean doAccessibleAction(int i)
执行树节点上的指定操作。如果此节点不是叶节点，则除 TreeCellRenderer 后面对象上所有可用操作外，至少还存在一个可以完成的操作（切换展开）。

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 操作的从零开始的索引
返回：
如果执行了该操作，则返回 true；否则返回 false。
另请参见：
AccessibleAction.getAccessibleActionCount()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


javax.swing (Java 2 Platform SE 6)

 javax.swing
接口
Action
BoundedRangeModel
ButtonModel
CellEditor
ComboBoxEditor
ComboBoxModel
DesktopManager
Icon
JComboBox.KeySelectionManager
ListCellRenderer
ListModel
ListSelectionModel
MenuElement
MutableComboBoxModel
Renderer
RootPaneContainer
Scrollable
ScrollPaneConstants
SingleSelectionModel
SpinnerModel
SwingConstants
UIDefaults.ActiveValue
UIDefaults.LazyValue
WindowConstants
类
AbstractAction
AbstractButton
AbstractCellEditor
AbstractListModel
AbstractSpinnerModel
ActionMap
BorderFactory
Box
Box.Filler
BoxLayout
ButtonGroup
CellRendererPane
ComponentInputMap
DebugGraphics
DefaultBoundedRangeModel
DefaultButtonModel
DefaultCellEditor
DefaultComboBoxModel
DefaultDesktopManager
DefaultFocusManager
DefaultListCellRenderer
DefaultListCellRenderer.UIResource
DefaultListModel
DefaultListSelectionModel
DefaultRowSorter
DefaultRowSorter.ModelWrapper
DefaultSingleSelectionModel
FocusManager
GrayFilter
GroupLayout
ImageIcon
InputMap
InputVerifier
InternalFrameFocusTraversalPolicy
JApplet
JButton
JCheckBox
JCheckBoxMenuItem
JColorChooser
JComboBox
JComponent
JDesktopPane
JDialog
JEditorPane
JFileChooser
JFormattedTextField
JFormattedTextField.AbstractFormatter
JFormattedTextField.AbstractFormatterFactory
JFrame
JInternalFrame
JInternalFrame.JDesktopIcon
JLabel
JLayeredPane
JList
JList.DropLocation
JMenu
JMenuBar
JMenuItem
JOptionPane
JPanel
JPasswordField
JPopupMenu
JPopupMenu.Separator
JProgressBar
JRadioButton
JRadioButtonMenuItem
JRootPane
JScrollBar
JScrollPane
JSeparator
JSlider
JSpinner
JSpinner.DateEditor
JSpinner.DefaultEditor
JSpinner.ListEditor
JSpinner.NumberEditor
JSplitPane
JTabbedPane
JTable
JTable.DropLocation
JTextArea
JTextField
JTextPane
JToggleButton
JToggleButton.ToggleButtonModel
JToolBar
JToolBar.Separator
JToolTip
JTree
JTree.DropLocation
JTree.DynamicUtilTreeNode
JTree.EmptySelectionModel
JViewport
JWindow
KeyStroke
LayoutFocusTraversalPolicy
LayoutStyle
LookAndFeel
MenuSelectionManager
OverlayLayout
Popup
PopupFactory
ProgressMonitor
ProgressMonitorInputStream
RepaintManager
RowFilter
RowFilter.Entry
RowSorter
RowSorter.SortKey
ScrollPaneLayout
ScrollPaneLayout.UIResource
SizeRequirements
SizeSequence
SortingFocusTraversalPolicy
SpinnerDateModel
SpinnerListModel
SpinnerNumberModel
Spring
SpringLayout
SpringLayout.Constraints
SwingUtilities
SwingWorker
Timer
ToolTipManager
TransferHandler
TransferHandler.DropLocation
TransferHandler.TransferSupport
UIDefaults
UIDefaults.LazyInputMap
UIDefaults.ProxyLazyValue
UIManager
UIManager.LookAndFeelInfo
ViewportLayout
枚举
DropMode
GroupLayout.Alignment
JTable.PrintMode
LayoutStyle.ComponentPlacement
RowFilter.ComparisonType
SortOrder
SwingWorker.StateValue
异常
UnsupportedLookAndFeelException


RowFilter.Entry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 RowFilter.Entry<M,I>

java.lang.Object
    继承者  javax.swing.RowFilter.Entry<M,I>
类型参数：
M - 模型的类型；例如 PersonModel
I - 标识符的类型；使用 TableRowSorter 时，此类型为 Integer
正在封闭类：
RowFilter<M,I>
public abstract static class RowFilter.Entry<M,I>
extends Object

一个传递给 RowFilter 实例的 Entry 对象，允许过滤器获取该条目的数据的值，以确定是否应该显示该条目。Entry 对象包含有关模型的信息以及从模型中获取底层值的方法。

从以下版本开始：
1.6
另请参见：
RowFilter, DefaultRowSorter.setRowFilter(javax.swing.RowFilter)

构造方法摘要
RowFilter.Entry()
创建一个 Entry。
方法摘要
abstract I | getIdentifier() 返回条目的标识符（在模型中）。
abstract M | getModel() 返回底层模型。
String | getStringValue(int index) 返回指定索引处的字符串值。
abstract Object | getValue(int index) 返回指定索引处的值。
abstract int | getValueCount() 返回条目中值的数量。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RowFilter.Entry

public RowFilter.Entry()
创建一个 Entry。

方法详细信息

getModel

public abstract M getModel()
返回底层模型。

返回：
包含此条目所表示数据的模型

getValueCount

public abstract int getValueCount()
返回条目中值的数量。例如，当用于表时，此值对应于列的数量。

返回：
要过滤的对象中值的数量

getValue

public abstract Object getValue(int index)
返回指定索引处的值。此方法可以返回 null。当用于表时，索引对应于模型中的列号。

参数：
index - 要获取的值的索引
返回：
指定索引处的值
抛出：
IndexOutOfBoundsException - 如果索引小于 0 或大于等于 getValueCount

getStringValue

public String getStringValue(int index)
返回指定索引处的字符串值。如果基于 String 值进行过滤操作，则首选此方法而不是使用 getValue，因为 getValue(index).toString() 返回的结果可能与 getStringValue(index) 不同。

此实现检查有无 null 值后调用 getValue(index).toString()。如有必要，提供不同字符串转换的子类应该重写此方法。

参数：
index - 要获取的值的索引
返回：
指定索引处的非 null 字符串
抛出：
IndexOutOfBoundsException - 如果索引小于 0 或大于等于 getValueCount

getIdentifier

public abstract I getIdentifier()
返回条目的标识符（在模型中）。对于表，此值对应于模式中的行索引，以 Integer 形式表示。

返回：
此条目基于模型的（而非基于视图）标识符
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


javax.swing.border (Java 2 Platform SE 6)

 javax.swing.border
接口
Border
类
AbstractBorder
BevelBorder
CompoundBorder
EmptyBorder
EtchedBorder
LineBorder
MatteBorder
SoftBevelBorder
TitledBorder


类 javax.swing.border.AbstractBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.AbstractBorder
的使用

使用 AbstractBorder 的软件包
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.border 中 AbstractBorder 的使用

javax.swing.border 中 AbstractBorder 的子类
class | BevelBorder 该类实现简单的双线斜面边框。
class | CompoundBorder 一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
class | EmptyBorder 该类提供了一个占用空间但不执行绘制的空透明边框。
class | EtchedBorder 该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。
class | LineBorder 实现单色、任意厚度线边框的类。
class | MatteBorder 该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
class | SoftBevelBorder 实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。
class | TitledBorder 该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

javax.swing.plaf 中 AbstractBorder 的使用

javax.swing.plaf 中 AbstractBorder 的子类
static class | BorderUIResource.BevelBorderUIResource
static class | BorderUIResource.CompoundBorderUIResource
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.EtchedBorderUIResource
static class | BorderUIResource.LineBorderUIResource
static class | BorderUIResource.MatteBorderUIResource
static class | BorderUIResource.TitledBorderUIResource

javax.swing.plaf.basic 中 AbstractBorder 的使用

javax.swing.plaf.basic 中 AbstractBorder 的子类
static class | BasicBorders.ButtonBorder
static class | BasicBorders.FieldBorder
static class | BasicBorders.MarginBorder
static class | BasicBorders.MenuBarBorder
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.ToggleButtonBorder

javax.swing.plaf.metal 中 AbstractBorder 的使用

javax.swing.plaf.metal 中 AbstractBorder 的子类
static class | MetalBorders.ButtonBorder
static class | MetalBorders.Flush3DBorder
static class | MetalBorders.InternalFrameBorder
static class | MetalBorders.MenuBarBorder
static class | MetalBorders.MenuItemBorder
static class | MetalBorders.OptionDialogBorder
static class | MetalBorders.PaletteBorder Palette 的边框。
static class | MetalBorders.PopupMenuBorder
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ScrollPaneBorder
static class | MetalBorders.TableHeaderBorder Table Header 的边框
static class | MetalBorders.TextFieldBorder
static class | MetalBorders.ToggleButtonBorder
static class | MetalBorders.ToolBarBorder

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.border.BevelBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.BevelBorder
的使用

使用 BevelBorder 的软件包
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.border 中 BevelBorder 的使用

javax.swing.border 中 BevelBorder 的子类
 class SoftBevelBorder
实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。

javax.swing.plaf 中 BevelBorder 的使用

javax.swing.plaf 中 BevelBorder 的子类
static class BorderUIResource.BevelBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.border.Border 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.border.Border
的使用

使用 Border 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 Border 的使用

声明为 Border 的 javax.swing 中的字段
protected static Border DefaultListCellRenderer.noFocusBorder
一个空 Border。

返回 Border 的 javax.swing 中的方法
static Border | BorderFactory.createBevelBorder(int type) 创建一个指定类型的斜面边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
static Border | BorderFactory.createBevelBorder(int type, Color highlight, Color shadow) 使用指定高亮显示和阴影显示方式来创建一个指定类型的斜面边框。
static Border | BorderFactory.createBevelBorder(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner) 创建一个指定类型的斜面边框，使用内部和外部高亮显示区域及阴影区域的指定颜色。
static Border | BorderFactory.createEmptyBorder() 创建一个不占用空间的空边框。
static Border | BorderFactory.createEmptyBorder(int top, int left, int bottom, int right) 创建一个占用空间但没有绘制的空边框，指定了顶线、底线、左边框线和右边框线的宽度。
static Border | BorderFactory.createEtchedBorder() 创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。
static Border | BorderFactory.createEtchedBorder(Color highlight, Color shadow) 使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
static Border | BorderFactory.createEtchedBorder(int type) 创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。
static Border | BorderFactory.createEtchedBorder(int type, Color highlight, Color shadow) 使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
static Border | BorderFactory.createLineBorder(Color color) 创建一个具有指定颜色的线边框。
static Border | BorderFactory.createLineBorder(Color color, int thickness) 创建一个具有指定颜色和宽度的线边框。
static Border | BorderFactory.createLoweredBevelBorder() 创建一个具有凹入斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
static Border | BorderFactory.createRaisedBevelBorder() 创建一个具有凸出斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
Border | JComponent.getBorder() 返回此组件的边框；如果当前未设置边框，则返回 null。
Border | UIDefaults.getBorder(Object key) 如果 key 值为一个 Border，则返回该 Border，否则返回 null。
static Border | UIManager.getBorder(Object key) 从默认值中返回一个边框。
Border | UIDefaults.getBorder(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Border，则返回该 Border，否则返回 null。
static Border | UIManager.getBorder(Object key, Locale l) 从适合给定语言环境的默认值中返回一个边框。
Border | JScrollPane.getViewportBorder() 返回围绕该视口的 Border 对象。

参数类型为 Border 的 javax.swing 中的方法
static CompoundBorder | BorderFactory.createCompoundBorder(Border outsideBorder, Border insideBorder) 创建一个合成边框，指定了用于外部和内部边缘的 border 对象。
static TitledBorder | BorderFactory.createTitledBorder(Border border) 创建一个空标题的新标题边框，使其具有指定的边框对象、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title) 向现有边框添加一个标题，使其具有默认的位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition) 向现有边框添加一个标题，使其具有指定的位置和默认字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont) 向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor) 向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
protected String | JComponent.AccessibleJComponent.getBorderTitle(Border b) 在边界层次结构（如果存在）中递归地搜索带有非 null 标题的 TitledBorder。
void | JViewport.setBorder(Border border) 视口通过常规父/子剪贴（一般该视图向滚动的相反方向移动）“滚动”其子视口（称为“视图”）。
void | JComponent.setBorder(Border border) 设置此组件的边框。
void | JScrollPane.setViewportBorder(Border viewportBorder) 围绕视口添加一个边界。

javax.swing.border 中 Border 的使用

实现 Border 的 javax.swing.border 中的类
class | AbstractBorder 实现无大小限制的空边框类。
class | BevelBorder 该类实现简单的双线斜面边框。
class | CompoundBorder 一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
class | EmptyBorder 该类提供了一个占用空间但不执行绘制的空透明边框。
class | EtchedBorder 该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。
class | LineBorder 实现单色、任意厚度线边框的类。
class | MatteBorder 该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
class | SoftBevelBorder 实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。
class | TitledBorder 该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

声明为 Border 的 javax.swing.border 中的字段
protected Border | TitledBorder.border
protected Border | CompoundBorder.insideBorder
protected Border | CompoundBorder.outsideBorder

返回 Border 的 javax.swing.border 中的方法
static Border | LineBorder.createBlackLineBorder() 获取一个颜色为黑色、厚度为 1 的线边框的便捷方法。
static Border | LineBorder.createGrayLineBorder() 获取一个颜色为灰色、厚度为 1 的线条边框的便捷方法。
Border | TitledBorder.getBorder() 返回带标题边框的边框。
Border | CompoundBorder.getInsideBorder() 返回内部边框对象。
Border | CompoundBorder.getOutsideBorder() 返回外部边框对象。

参数类型为 Border 的 javax.swing.border 中的方法
static Rectangle | AbstractBorder.getInteriorRectangle(Component c, Border b, int x, int y, int width, int height) 返回一个用所给的参数减去边框 insets 得到的矩形。
void | TitledBorder.setBorder(Border border) 设置带标题边框的边框。

参数类型为 Border 的 javax.swing.border 中的构造方法
CompoundBorder(Border outsideBorder, Border insideBorder)
按照指定的内部边框和外部边框创建组合边框。
TitledBorder(Border border)
创建具有指定边框和空标题的 TitledBorder 实例。
TitledBorder(Border border, String title)
创建具有指定边框和标题的 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition)
用指定的边框、标题、标题对齐方式和标题位置创建 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
用指定的边框、标题、标题对齐方式、标题位置和标题字体创建 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。

javax.swing.plaf 中 Border 的使用

实现 Border 的 javax.swing.plaf 中的类
class | BorderUIResource
static class | BorderUIResource.BevelBorderUIResource
static class | BorderUIResource.CompoundBorderUIResource
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.EtchedBorderUIResource
static class | BorderUIResource.LineBorderUIResource
static class | BorderUIResource.MatteBorderUIResource
static class | BorderUIResource.TitledBorderUIResource

返回 Border 的 javax.swing.plaf 中的方法
static Border | BorderUIResource.getBlackLineBorderUIResource()
static Border | BorderUIResource.getEtchedBorderUIResource()
static Border | BorderUIResource.getLoweredBevelBorderUIResource()
static Border | BorderUIResource.getRaisedBevelBorderUIResource()

参数类型为 Border 的 javax.swing.plaf 中的构造方法
BorderUIResource.CompoundBorderUIResource(Border outsideBorder, Border insideBorder)
BorderUIResource.TitledBorderUIResource(Border border)
BorderUIResource.TitledBorderUIResource(Border border, String title)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
BorderUIResource(Border delegate)
创建一个 UIResource 边框对象，该对象包装了一个现有 Border 实例。

javax.swing.plaf.basic 中 Border 的使用

实现 Border 的 javax.swing.plaf.basic 中的类
static class | BasicBorders.ButtonBorder
static class | BasicBorders.FieldBorder
static class | BasicBorders.MarginBorder
static class | BasicBorders.MenuBarBorder
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.SplitPaneBorder 绘制围绕拆分窗格的边框。
static class | BasicBorders.ToggleButtonBorder

声明为 Border 的 javax.swing.plaf.basic 中的字段
protected static Border BasicComboBoxRenderer.noFocusBorder
空 Border。

返回 Border 的 javax.swing.plaf.basic 中的方法
protected Border | BasicToolBarUI.createNonRolloverBorder() 创建工具栏组件的非翻转边框。
protected Border | BasicToolBarUI.createRolloverBorder() 创建工具栏组件的翻转边框。
Border | BasicSplitPaneDivider.getBorder() 返回此组件的边框，如果当前没有设置边框，则返回 null。
static Border | BasicBorders.getButtonBorder()
static Border | BasicBorders.getInternalFrameBorder()
static Border | BasicBorders.getMenuBarBorder()
protected Border | BasicToolBarUI.getNonRolloverBorder(AbstractButton b) 返回按钮的非翻转边框。
static Border | BasicBorders.getProgressBarBorder()
static Border | BasicBorders.getRadioButtonBorder()
protected Border | BasicToolBarUI.getRolloverBorder(AbstractButton b) 返回按钮的翻转边框。
static Border | BasicBorders.getSplitPaneBorder()
static Border | BasicBorders.getSplitPaneDividerBorder() 返回 JSplitPane 分隔符的边框实例
static Border | BasicBorders.getTextFieldBorder()
static Border | BasicBorders.getToggleButtonBorder()

参数类型为 Border 的 javax.swing.plaf.basic 中的方法
 void BasicSplitPaneDivider.setBorder(Border border)
设置此组件的边框。

javax.swing.plaf.metal 中 Border 的使用

实现 Border 的 javax.swing.plaf.metal 中的类
static class | MetalBorders.ButtonBorder
static class | MetalBorders.Flush3DBorder
static class | MetalBorders.InternalFrameBorder
static class | MetalBorders.MenuBarBorder
static class | MetalBorders.MenuItemBorder
static class | MetalBorders.OptionDialogBorder
static class | MetalBorders.PaletteBorder Palette 的边框。
static class | MetalBorders.PopupMenuBorder
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ScrollPaneBorder
static class | MetalBorders.TableHeaderBorder Table Header 的边框
static class | MetalBorders.TextFieldBorder
static class | MetalBorders.ToggleButtonBorder
static class | MetalBorders.ToolBarBorder

返回 Border 的 javax.swing.plaf.metal 中的方法
protected Border | MetalToolBarUI.createNonRolloverBorder()
protected Border | MetalToolBarUI.createRolloverBorder()
static Border | MetalBorders.getButtonBorder() 返回一个用于 JButton 的 border 实例
static Border | MetalBorders.getDesktopIconBorder() 返回一个用于 Desktop Icon 的 border 实例
static Border | MetalBorders.getTextBorder() 返回一个用于文本组件的 border 实例
static Border | MetalBorders.getTextFieldBorder() 返回一个用于 JTextField 的 border 实例
static Border | MetalBorders.getToggleButtonBorder() 返回一个用于 JToggleButton 的 border 实例

javax.swing.table 中 Border 的使用

声明为 Border 的 javax.swing.table 中的字段
protected static Border DefaultTableCellRenderer.noFocusBorder
一个空 Border。

javax.swing.tree 中 Border 的使用

声明为 Border 的 javax.swing.tree 中的字段
protected  Border DefaultTreeCellEditor.DefaultTextField.border
要使用的边框。

返回 Border 的 javax.swing.tree 中的方法
 Border DefaultTreeCellEditor.DefaultTextField.getBorder()
重写 JComponent.getBorder，以返回当前边框。

参数类型为 Border 的 javax.swing.tree 中的方法
 void DefaultTreeCellEditor.DefaultTextField.setBorder(Border border)
设置此组件的边框。

参数类型为 Border 的 javax.swing.tree 中的构造方法
DefaultTreeCellEditor.DefaultTextField(Border border)
构造一个 DefaultTreeCellEditor.DefaultTextField 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.border.CompoundBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.CompoundBorder
的使用

使用 CompoundBorder 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing 中 CompoundBorder 的使用

返回 CompoundBorder 的 javax.swing 中的方法
static CompoundBorder | BorderFactory.createCompoundBorder() 创建一个具有 null 内部边缘和 null 外部边缘的合成边框。
static CompoundBorder | BorderFactory.createCompoundBorder(Border outsideBorder, Border insideBorder) 创建一个合成边框，指定了用于外部和内部边缘的 border 对象。

javax.swing.plaf 中 CompoundBorder 的使用

javax.swing.plaf 中 CompoundBorder 的子类
static class BorderUIResource.CompoundBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.border.EmptyBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.EmptyBorder
的使用

使用 EmptyBorder 的软件包
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.border 中 EmptyBorder 的使用

javax.swing.border 中 EmptyBorder 的子类
 class MatteBorder
该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。

javax.swing.plaf 中 EmptyBorder 的使用

javax.swing.plaf 中 EmptyBorder 的子类
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.MatteBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.border.EtchedBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.EtchedBorder
的使用

使用 EtchedBorder 的软件包
javax.swing.plaf 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.plaf 中 EtchedBorder 的使用

javax.swing.plaf 中 EtchedBorder 的子类
static class BorderUIResource.EtchedBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.border.LineBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.LineBorder
的使用

使用 LineBorder 的软件包
javax.swing.plaf 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.plaf 中 LineBorder 的使用

javax.swing.plaf 中 LineBorder 的子类
static class BorderUIResource.LineBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.border.MatteBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.MatteBorder
的使用

使用 MatteBorder 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing 中 MatteBorder 的使用

返回 MatteBorder 的 javax.swing 中的方法
static MatteBorder | BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Color color) 使用纯色创建一个类似衬边的边框。
static MatteBorder | BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Icon tileIcon) 创建一个由多层指定图标组成的、类似衬边的边框。

javax.swing.plaf 中 MatteBorder 的使用

javax.swing.plaf 中 MatteBorder 的子类
static class BorderUIResource.MatteBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.border.SoftBevelBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.SoftBevelBorder
的使用

没有 javax.swing.border.SoftBevelBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.border.TitledBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.TitledBorder
的使用

使用 TitledBorder 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing 中 TitledBorder 的使用

返回 TitledBorder 的 javax.swing 中的方法
static TitledBorder | BorderFactory.createTitledBorder(Border border) 创建一个空标题的新标题边框，使其具有指定的边框对象、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title) 向现有边框添加一个标题，使其具有默认的位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition) 向现有边框添加一个标题，使其具有指定的位置和默认字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont) 向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor) 向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
static TitledBorder | BorderFactory.createTitledBorder(String title) 创建一个新标题边框，使其具有指定的标题、默认的边框类型（由当前外观确定）、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。

javax.swing.plaf 中 TitledBorder 的使用

javax.swing.plaf 中 TitledBorder 的子类
static class BorderUIResource.TitledBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.AbstractAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractAction
的使用

使用 AbstractAction 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 AbstractAction 的使用

javax.swing.plaf.basic 中 AbstractAction 的子类
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。

javax.swing.plaf.metal 中 AbstractAction 的使用

javax.swing.plaf.metal 中 AbstractAction 的子类
protected  class MetalFileChooserUI.DirectoryComboBoxAction
当 DirectoryComboBox 已更改所选项时调用。

javax.swing.text 中 AbstractAction 的使用

javax.swing.text 中 AbstractAction 的子类
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

javax.swing.text.html 中 AbstractAction 的使用

javax.swing.text.html 中 AbstractAction 的子类
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.AbstractButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractButton
的使用

使用 AbstractButton 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 AbstractButton 的使用

javax.swing 中 AbstractButton 的子类
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuItem 菜单中的项的实现。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。

类型参数类型为 AbstractButton 的 javax.swing 中的字段
protected  Vector<AbstractButton> ButtonGroup.buttons

返回变量类型为 AbstractButton 的类型的 javax.swing 中的方法
 Enumeration<AbstractButton> ButtonGroup.getElements()
返回此组中的所有按钮。

参数类型为 AbstractButton 的 javax.swing 中的方法
void | ButtonGroup.add(AbstractButton b) 将按钮添加到组中。
void | ButtonGroup.remove(AbstractButton b) 从组中移除按钮。

javax.swing.plaf.basic 中 AbstractButton 的使用

javax.swing.plaf.basic 中 AbstractButton 的子类
 class BasicArrowButton
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。

参数类型为 AbstractButton 的 javax.swing.plaf.basic 中的方法
protected void | BasicButtonListener.checkOpacity(AbstractButton b)
protected BasicButtonListener | BasicButtonUI.createButtonListener(AbstractButton b)
int | BasicButtonUI.getDefaultTextIconGap(AbstractButton b)
protected Border | BasicToolBarUI.getNonRolloverBorder(AbstractButton b) 返回按钮的非翻转边框。
static Dimension | BasicGraphicsUtils.getPreferredButtonSize(AbstractButton b, int textIconGap)
protected Border | BasicToolBarUI.getRolloverBorder(AbstractButton b) 返回按钮的翻转边框。
protected void | BasicRadioButtonUI.installDefaults(AbstractButton b)
protected void | BasicButtonUI.installDefaults(AbstractButton b)
protected void | BasicButtonUI.installKeyboardActions(AbstractButton b)
protected void | BasicButtonUI.installListeners(AbstractButton b)
protected void | BasicButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
protected void | BasicButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | BasicToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)
protected void | BasicButtonUI.paintText(Graphics g, AbstractButton b, Rectangle textRect, String text) 呈现当前按钮文本的方法。
protected void | BasicRadioButtonUI.uninstallDefaults(AbstractButton b)
protected void | BasicButtonUI.uninstallDefaults(AbstractButton b)
protected void | BasicButtonUI.uninstallKeyboardActions(AbstractButton b)
protected void | BasicButtonUI.uninstallListeners(AbstractButton b)

参数类型为 AbstractButton 的 javax.swing.plaf.basic 中的构造方法
BasicButtonListener(AbstractButton b)

javax.swing.plaf.metal 中 AbstractButton 的使用

javax.swing.plaf.metal 中 AbstractButton 的子类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

参数类型为 AbstractButton 的 javax.swing.plaf.metal 中的方法
protected BasicButtonListener | MetalButtonUI.createButtonListener(AbstractButton b)
void | MetalCheckBoxUI.installDefaults(AbstractButton b)
void | MetalRadioButtonUI.installDefaults(AbstractButton b)
void | MetalToggleButtonUI.installDefaults(AbstractButton b)
void | MetalButtonUI.installDefaults(AbstractButton b)
protected void | MetalToggleButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
protected void | MetalButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
protected void | MetalToggleButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect) 在空间 iconRect 中绘制按钮 b 的适当图标。
protected void | MetalCheckBoxUI.uninstallDefaults(AbstractButton b)
protected void | MetalRadioButtonUI.uninstallDefaults(AbstractButton b)
protected void | MetalToggleButtonUI.uninstallDefaults(AbstractButton b)
void | MetalButtonUI.uninstallDefaults(AbstractButton b)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.AbstractButton.AccessibleAbstractButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractButton.AccessibleAbstractButton
的使用

使用 AbstractButton.AccessibleAbstractButton 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AbstractButton.AccessibleAbstractButton 的使用

javax.swing 中 AbstractButton.AccessibleAbstractButton 的子类
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.AbstractButton.ButtonChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractButton.ButtonChangeListener
的使用

没有 javax.swing.AbstractButton.ButtonChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.AbstractCellEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractCellEditor
的使用

使用 AbstractCellEditor 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AbstractCellEditor 的使用

javax.swing 中 AbstractCellEditor 的子类
 class DefaultCellEditor
表单元格和树单元格的默认编辑器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.AbstractListModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractListModel
的使用

使用 AbstractListModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 AbstractListModel 的使用

javax.swing 中 AbstractListModel 的子类
class | DefaultComboBoxModel 组合框的默认模型。
class | DefaultListModel 此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。

javax.swing.plaf.basic 中 AbstractListModel 的使用

javax.swing.plaf.basic 中 AbstractListModel 的子类
 class BasicDirectoryModel
文件列表的基本实现。

javax.swing.plaf.metal 中 AbstractListModel 的使用

javax.swing.plaf.metal 中 AbstractListModel 的子类
protected class | MetalFileChooserUI.DirectoryComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.AbstractSpinnerModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractSpinnerModel
的使用

使用 AbstractSpinnerModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AbstractSpinnerModel 的使用

javax.swing 中 AbstractSpinnerModel 的子类
class | SpinnerDateModel Date 序列的一个 SpinnerModel。
class | SpinnerListModel 其值由数组或 List 定义的 SpinnerModel 的简单实现。
class | SpinnerNumberModel 用于数字序列的 SpinnerModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.Action 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.Action
的使用

使用 Action 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 Action 的使用

实现 Action 的 javax.swing 中的类
 class AbstractAction
此类提供 JFC Action 接口的默认实现。

返回 Action 的 javax.swing 中的方法
Action | ActionMap.get(Object key) 返回 key 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 ActionMap。
Action | JTextField.getAction() 返回此 ActionEvent 源当前设置的 Action，如果没有设置 Action 则返回 null。
Action | JComboBox.getAction() 返回此 ActionEvent 源当前设置的 Action，如果没有设置任何 Action，则返回 null。
Action | AbstractButton.getAction() 返回当前为此 ActionEvent 源设置的 Action，如果没有设置任何 Action，则返回 null。
Action[] | JFormattedTextField.getActions() 获取编辑器的命令列表。
protected Action[] | JFormattedTextField.AbstractFormatter.getActions() 如果想提供自定义的 Action 集合，则应进行子类化和重写。
Action[] | JTextField.getActions() 获取编辑器的命令列表。
static Action | TransferHandler.getCopyAction() 返回一个执行复制到剪贴板操作的 Action。
static Action | TransferHandler.getCutAction() 返回一个执行剪切到剪贴板操作的 Action。
static Action | TransferHandler.getPasteAction() 返回一个从剪贴板执行粘贴操作的 Action。

参数类型为 Action 的 javax.swing 中的方法
protected void | JTextField.actionPropertyChanged(Action action, String propertyName) 更新文本字段的状态以响应关联动作中的属性更改。
protected void | JComboBox.actionPropertyChanged(Action action, String propertyName) 更新组合框的状态以响应关联动作中的属性更改。
protected void | JMenuItem.actionPropertyChanged(Action action, String propertyName) 更新按钮的状态以响应相关的操作中的属性更改。
protected void | AbstractButton.actionPropertyChanged(Action action, String propertyName) 更新按钮的状态以响应相关的操作中的属性更改。
JMenuItem | JPopupMenu.add(Action a) 将指派指定 Action 对象的新菜单项添加到菜单的末尾。
JButton | JToolBar.add(Action a) 添加一个指派动作的新的 JButton。
JMenuItem | JMenu.add(Action a) 创建连接到指定 Action 对象的新菜单项，并将其追加到此菜单的末尾。
protected void | JTextField.configurePropertiesFromAction(Action a) 在此文本字段上设置属性，以匹配指定 Action 中的值。
protected void | JComboBox.configurePropertiesFromAction(Action a) 在此组合框上设置属性以匹配指定 Action 中的属性。
protected void | JMenuItem.configurePropertiesFromAction(Action a) 在此按钮上设置属性以匹配指定 Action 中的属性。
protected void | AbstractButton.configurePropertiesFromAction(Action a) 在此按钮上设置属性以匹配指定 Action 中的属性。
protected JMenuItem | JPopupMenu.createActionComponent(Action a) 该工厂方法为添加到 JPopupMenu 的 Action 创建对应的 JMenuItem。
protected JButton | JToolBar.createActionComponent(Action a) 将为 Action 创建 JButton 的工厂方法添加到 JToolBar 中。
protected JMenuItem | JMenu.createActionComponent(Action a) 该工厂方法创建添加到 JMenu 的 Action 的 JMenuItem。
protected PropertyChangeListener | JTextField.createActionPropertyChangeListener(Action a) 创建并返回一个负责侦听指定 Action 的更改以及更新适当属性的 PropertyChangeListener。
protected PropertyChangeListener | JComboBox.createActionPropertyChangeListener(Action a) 创建并返回一个 PropertyChangeListener，它负责侦听指定 Action 的更改并更新适当属性。
protected PropertyChangeListener | AbstractButton.createActionPropertyChangeListener(Action a) 创建并返回 PropertyChangeListener，它负责侦听指定 Action 的更改以及更新适当的属性。
void | JPopupMenu.insert(Action a, int index) 在给定位置插入指定 Action 对象的菜单项。
JMenuItem | JMenu.insert(Action a, int pos) 在给定位置插入连接到指定 Action 对象的新菜单项。
static boolean | SwingUtilities.notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers) 如果启用 action（且为非 null），则调用 action 上的 actionPerformed。
void | ActionMap.put(Object key, Action action) 添加一个 key 到 action 的绑定。
void | JTextField.setAction(Action a) 设置 ActionEvent 源的 Action。
void | JComboBox.setAction(Action a) 设置 ActionEvent 源的 Action。
void | AbstractButton.setAction(Action a) 设置 Action。

参数类型为 Action 的 javax.swing 中的构造方法
JButton(Action a)
创建一个按钮，其属性从所提供的 Action 中获取。
JCheckBox(Action a)
创建一个复选框，其属性从所提供的 Action 获取。
JCheckBoxMenuItem(Action a)
创建一个从所提供的 Action 中获取其属性的菜单项。
JMenu(Action a)
构造一个从提供的 Action 获取其属性的菜单。
JMenuItem(Action a)
创建从指定的 Action 获取其属性的菜单项。
JRadioButton(Action a)
创建一个单选按钮，其属性来自提供的 Action。
JRadioButtonMenuItem(Action a)
创建一个单选按钮菜单项，其属性来自提供的 Action。
JToggleButton(Action a)
创建一个切换按钮，其属性从所提供的 Action 获取。

javax.swing.plaf.basic 中 Action 的使用

实现 Action 的 javax.swing.plaf.basic 中的类
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。

声明为 Action 的 javax.swing.plaf.basic 中的字段
protected Action | BasicInternalFrameTitlePane.closeAction
protected Action | BasicInternalFrameTitlePane.iconifyAction
protected Action | BasicInternalFrameTitlePane.maximizeAction
protected Action | BasicInternalFrameTitlePane.moveAction
protected Action | BasicTreeUI.KeyHandler.repeatKeyAction 正在生成的键代码。
protected Action | BasicInternalFrameTitlePane.restoreAction
protected Action | BasicInternalFrameTitlePane.sizeAction

返回 Action 的 javax.swing.plaf.basic 中的方法
protected Action | BasicLookAndFeel.createAudioAction(Object key) 创建并返回用于播放音频的 Action。
Action | BasicFileChooserUI.getApproveSelectionAction()
Action | BasicFileChooserUI.getCancelSelectionAction()
Action | BasicFileChooserUI.getChangeToParentDirectoryAction()
Action | BasicFileChooserUI.getGoHomeAction()
Action | BasicFileChooserUI.getNewFolderAction()
Action | BasicFileChooserUI.getUpdateAction()

参数类型为 Action 的 javax.swing.plaf.basic 中的方法
protected  void BasicLookAndFeel.playSound(Action audioAction)
如有必要，在 audioAction 上调用 actionPerformed 以播放声音。

javax.swing.plaf.metal 中 Action 的使用

实现 Action 的 javax.swing.plaf.metal 中的类
protected  class MetalFileChooserUI.DirectoryComboBoxAction
当 DirectoryComboBox 已更改所选项时调用。

javax.swing.text 中 Action 的使用

实现 Action 的 javax.swing.text 中的类
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

返回 Action 的 javax.swing.text 中的方法
static Action[] | TextAction.augmentList(Action[] list1, Action[] list2) 取一个命令列表并用另一个命令列表去扩充。
Action | Keymap.getAction(KeyStroke key) 获取适合于给定符号事件序列的操作。
protected Action[] | InternationalFormatter.getActions() 如果 getSupportsIncrement 返回 true，则这将返回两个适合增加/减少该值的 Action。
Action[] | StyledEditorKit.getActions() 获取编辑器的命令列表。
Action[] | DefaultEditorKit.getActions() 获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。
abstract Action[] | EditorKit.getActions() 获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。
Action[] | JTextComponent.getActions() 获取编辑器的命令列表。
Action[] | Keymap.getBoundActions() 获取在此 keymap 中定义的所有操作。
Action | Keymap.getDefaultAction() 当击键（即接收 KEY_TYPED KeyEvent）且该键没有绑定操作的情况下获取激发的默认操作。

参数类型为 Action 的 javax.swing.text 中的方法
void | Keymap.addActionForKeyStroke(KeyStroke key, Action a) 向 keymap 添加绑定。
static Action[] | TextAction.augmentList(Action[] list1, Action[] list2) 取一个命令列表并用另一个命令列表去扩充。
static Action[] | TextAction.augmentList(Action[] list1, Action[] list2) 取一个命令列表并用另一个命令列表去扩充。
KeyStroke[] | Keymap.getKeyStrokesForAction(Action a) 获取将导致给定操作的击键。
static void | JTextComponent.loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions) 加载带有一组绑定的 keymap。
void | Keymap.setDefaultAction(Action a) 在进行击键的情况下设置要激发的默认操作。

javax.swing.text.html 中 Action 的使用

实现 Action 的 javax.swing.text.html 中的类
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

返回 Action 的 javax.swing.text.html 中的方法
 Action[] HTMLEditorKit.getActions()
获取编辑器的命令列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ActionMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ActionMap
的使用

使用 ActionMap 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ActionMap 的使用

返回 ActionMap 的 javax.swing 中的方法
ActionMap | JComponent.getActionMap() 返回用于确定为特定 KeyStroke 绑定触发何种 Action 的 ActionMap。
ActionMap | ActionMap.getParent() 返回此 ActionMap 的父级。
static ActionMap | SwingUtilities.getUIActionMap(JComponent component) 返回该 UI 在组件 component 中提供的 ActionMap。

参数类型为 ActionMap 的 javax.swing 中的方法
static void | SwingUtilities.replaceUIActionMap(JComponent component, ActionMap uiActionMap) 将 component 的 UI ActionMap 更改为 uiActionMap 的便捷方法。
void | JComponent.setActionMap(ActionMap am) 将 ActionMap 设置为 am。
void | ActionMap.setParent(ActionMap map) 设置此 ActionMap 的父级。

javax.swing.plaf 中 ActionMap 的使用

javax.swing.plaf 中 ActionMap 的子类
 class ActionMapUIResource
实现 UIResource 的 javax.swing.ActionMap 的子类。

javax.swing.plaf.basic 中 ActionMap 的使用

返回 ActionMap 的 javax.swing.plaf.basic 中的方法
protected  ActionMap BasicLookAndFeel.getAudioActionMap()
返回包含此外观音频动作的 ActionMap。

javax.swing.plaf.metal 中 ActionMap 的使用

返回 ActionMap 的 javax.swing.plaf.metal 中的方法
protected ActionMap | MetalFileChooserUI.createActionMap()
protected ActionMap | MetalFileChooserUI.getActionMap()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.BorderFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.BorderFactory
的使用

没有 javax.swing.BorderFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.BoundedRangeModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.BoundedRangeModel
的使用

使用 BoundedRangeModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 BoundedRangeModel 的使用

实现 BoundedRangeModel 的 javax.swing 中的类
 class DefaultBoundedRangeModel
BoundedRangeModel 的一般实现。

声明为 BoundedRangeModel 的 javax.swing 中的字段
protected BoundedRangeModel | JProgressBar.model 保存进度条数据的对象。
protected BoundedRangeModel | JScrollBar.model 表示滚动条的最小、最大、跨度（也叫 "visibleAmount"）和当前值的模型。
protected BoundedRangeModel | JSlider.sliderModel 处理滑块的数字最大值、最小值和当前位置值的数据模型。

返回 BoundedRangeModel 的 javax.swing 中的方法
BoundedRangeModel | JTextField.getHorizontalVisibility() 获取文本字段的可见性。
BoundedRangeModel | JSlider.getModel() 返回处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。
BoundedRangeModel | JProgressBar.getModel() 返回此进度条使用的数据模型。
BoundedRangeModel | JScrollBar.getModel() 返回处理滚动条的四个基本属性的数据模型：minimum、maximum、value 和 extent。

参数类型为 BoundedRangeModel 的 javax.swing 中的方法
void | JSlider.setModel(BoundedRangeModel newModel) 设置处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。
void | JProgressBar.setModel(BoundedRangeModel newModel) 设置 JProgressBar 使用的数据模型。
void | JScrollBar.setModel(BoundedRangeModel newModel) 设置处理滚动条的以下四个基本属性的模型：minimum、maximum、value 和 extent。

参数类型为 BoundedRangeModel 的 javax.swing 中的构造方法
JProgressBar(BoundedRangeModel newModel)
创建使用指定的保存进度条数据模型的水平进度条。
JSlider(BoundedRangeModel brm)
使用指定的 BoundedRangeModel 创建一个水平滑块。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.Box 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Box
的使用

使用 Box 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 Box 的使用

返回 Box 的 javax.swing 中的方法
static Box | Box.createHorizontalBox() 创建一个从左到右显示其组件的 Box。
static Box | Box.createVerticalBox() 创建一个从上到下显示其组件的 Box。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.Box.AccessibleBox 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Box.AccessibleBox
的使用

没有 javax.swing.Box.AccessibleBox 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.Box.Filler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Box.Filler
的使用

没有 javax.swing.Box.Filler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.Box.Filler.AccessibleBoxFiller 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Box.Filler.AccessibleBoxFiller
的使用

没有 javax.swing.Box.Filler.AccessibleBoxFiller 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.BoxLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.BoxLayout
的使用

使用 BoxLayout 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BoxLayout 的使用

javax.swing.plaf.basic 中 BoxLayout 的子类
 class DefaultMenuLayout
Popup 菜单和菜单栏的默认布局管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ButtonGroup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ButtonGroup
的使用

使用 ButtonGroup 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 ButtonGroup 的使用

声明为 ButtonGroup 的 javax.swing 中的字段
protected  ButtonGroup DefaultButtonModel.group
按钮所属的按钮组。

返回 ButtonGroup 的 javax.swing 中的方法
 ButtonGroup DefaultButtonModel.getGroup()
返回该按钮所属的组。

参数类型为 ButtonGroup 的 javax.swing 中的方法
void | DefaultButtonModel.setGroup(ButtonGroup group) 标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。
void | ButtonModel.setGroup(ButtonGroup group) 标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.ButtonModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ButtonModel
的使用

使用 ButtonModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 ButtonModel 的使用

实现 ButtonModel 的 javax.swing 中的类
class | DefaultButtonModel Button 组件的数据模型的默认实现。
static class | JToggleButton.ToggleButtonModel ToggleButton 模型。

声明为 ButtonModel 的 javax.swing 中的字段
protected  ButtonModel AbstractButton.model
确定按钮状态的数据模型。

返回 ButtonModel 的 javax.swing 中的方法
ButtonModel | AbstractButton.getModel() 返回此按钮表示的模型。
ButtonModel | ButtonGroup.getSelection() 返回选择按钮的模型。

参数类型为 ButtonModel 的 javax.swing 中的方法
boolean | ButtonGroup.isSelected(ButtonModel m) 返回对是否已选择一个 ButtonModel 的判断。
void | JMenu.setModel(ButtonModel newModel) 设置“菜单按钮”的数据模型，即用户单击可以打开或关闭菜单的标签。
void | JMenuItem.setModel(ButtonModel newModel) 设置此按钮表示的模型。
void | AbstractButton.setModel(ButtonModel newModel) 设置此按钮表示的模型。
void | ButtonGroup.setSelected(ButtonModel m, boolean b) 为 ButtonModel 设置选择值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.CellEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.CellEditor
的使用

使用 CellEditor 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 CellEditor 的使用

实现 CellEditor 的 javax.swing 中的类
class | AbstractCellEditor
class | DefaultCellEditor 表单元格和树单元格的默认编辑器。

javax.swing.table 中 CellEditor 的使用

javax.swing.table 中 CellEditor 的子接口
 interface TableCellEditor
此接口定义了要成为组件（如 JListBox、JComboBox、JTree 或 JTable）的值编辑器的任意对象需要实现的方法。

javax.swing.tree 中 CellEditor 的使用

javax.swing.tree 中 CellEditor 的子接口
 interface TreeCellEditor
向 CellEditor 添加配置树中编辑器必需的扩展。

实现 CellEditor 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor
TreeCellEditor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.CellRendererPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.CellRendererPane
的使用

使用 CellRendererPane 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 CellRendererPane 的使用

声明为 CellRendererPane 的 javax.swing.plaf.basic 中的字段
protected CellRendererPane | BasicComboBoxUI.currentValuePane
protected CellRendererPane | BasicTreeUI.rendererPane 用于绘制 TreeCellRenderer。
protected CellRendererPane | BasicTableUI.rendererPane
protected CellRendererPane | BasicTableHeaderUI.rendererPane
protected CellRendererPane | BasicListUI.rendererPane

返回 CellRendererPane 的 javax.swing.plaf.basic 中的方法
protected  CellRendererPane BasicTreeUI.createCellRendererPane()
返回用于放置渲染器组件的渲染器窗格。

javax.swing.plaf.metal 中 CellRendererPane 的使用

声明为 CellRendererPane 的 javax.swing.plaf.metal 中的字段
protected  CellRendererPane MetalComboBoxButton.rendererPane

参数类型为 CellRendererPane 的 javax.swing.plaf.metal 中的构造方法
MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.CellRendererPane.AccessibleCellRendererPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.CellRendererPane.AccessibleCellRendererPane
的使用

没有 javax.swing.CellRendererPane.AccessibleCellRendererPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.ComboBoxEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ComboBoxEditor
的使用

使用 ComboBoxEditor 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ComboBoxEditor 的使用

声明为 ComboBoxEditor 的 javax.swing 中的字段
protected  ComboBoxEditor JComboBox.editor
此受保护字段是特定于实现的。

返回 ComboBoxEditor 的 javax.swing 中的方法
 ComboBoxEditor JComboBox.getEditor()
返回用于绘制和编辑 JComboBox 字段中所选项的编辑器。

参数类型为 ComboBoxEditor 的 javax.swing 中的方法
void | JComboBox.configureEditor(ComboBoxEditor anEditor, Object anItem) 利用指定项初始化编辑器。
void | JComboBox.setEditor(ComboBoxEditor anEditor) 设置用于绘制和编辑 JComboBox 字段中所选项的编辑器。

javax.swing.plaf.basic 中 ComboBoxEditor 的使用

实现 ComboBoxEditor 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxEditor 用于可编辑组合框的默认编辑器。
static class | BasicComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的子类。

返回 ComboBoxEditor 的 javax.swing.plaf.basic 中的方法
protected  ComboBoxEditor BasicComboBoxUI.createEditor()
创建将在可编辑的组合框中使用的默认编辑器。

javax.swing.plaf.metal 中 ComboBoxEditor 的使用

实现 ComboBoxEditor 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxEditor Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的一个子类。

返回 ComboBoxEditor 的 javax.swing.plaf.metal 中的方法
protected  ComboBoxEditor MetalComboBoxUI.createEditor()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.ComboBoxModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ComboBoxModel
的使用

使用 ComboBoxModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ComboBoxModel 的使用

javax.swing 中 ComboBoxModel 的子接口
 interface MutableComboBoxModel
ComboBoxModel 的可变版本。

实现 ComboBoxModel 的 javax.swing 中的类
 class DefaultComboBoxModel
组合框的默认模型。

声明为 ComboBoxModel 的 javax.swing 中的字段
protected  ComboBoxModel JComboBox.dataModel
此受保护字段是特定于实现的。

返回 ComboBoxModel 的 javax.swing 中的方法
 ComboBoxModel JComboBox.getModel()
返回 JComboBox 当前使用的数据模型。

参数类型为 ComboBoxModel 的 javax.swing 中的方法
int | JComboBox.KeySelectionManager.selectionForKey(char aKey, ComboBoxModel aModel) 给定的 aKey 和模型返回应该被选择的行。
void | JComboBox.setModel(ComboBoxModel aModel) 设置 JComboBox 用于获取项列表的数据模型。

参数类型为 ComboBoxModel 的 javax.swing 中的构造方法
JComboBox(ComboBoxModel aModel)
创建一个 JComboBox，其项取自现有的 ComboBoxModel。

javax.swing.plaf.basic 中 ComboBoxModel 的使用

参数类型为 ComboBoxModel 的 javax.swing.plaf.basic 中的方法
protected void | BasicComboPopup.installComboBoxModelListeners(ComboBoxModel model) 在组合框模型中安装侦听器。
protected void | BasicComboPopup.uninstallComboBoxModelListeners(ComboBoxModel model) 从组合框模型中移除侦听器

javax.swing.plaf.metal 中 ComboBoxModel 的使用

实现 ComboBoxModel 的 javax.swing.plaf.metal 中的类
protected class | MetalFileChooserUI.DirectoryComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ComponentInputMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ComponentInputMap
的使用

使用 ComponentInputMap 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing 中 ComponentInputMap 的使用

返回 ComponentInputMap 的 javax.swing 中的方法
static ComponentInputMap LookAndFeel.makeComponentInputMap(JComponent c, Object[] keys)
根据 keys 创建一个 ComponentInputMapUIResource。

javax.swing.plaf 中 ComponentInputMap 的使用

javax.swing.plaf 中 ComponentInputMap 的子类
 class ComponentInputMapUIResource
实现 UIResource 的 javax.swing.ComponentInputMap 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DebugGraphics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DebugGraphics
的使用

没有 javax.swing.DebugGraphics 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultBoundedRangeModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultBoundedRangeModel
的使用

没有 javax.swing.DefaultBoundedRangeModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultButtonModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultButtonModel
的使用

使用 DefaultButtonModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DefaultButtonModel 的使用

javax.swing 中 DefaultButtonModel 的子类
static class JToggleButton.ToggleButtonModel
ToggleButton 模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultCellEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultCellEditor
的使用

没有 javax.swing.DefaultCellEditor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultCellEditor.EditorDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultCellEditor.EditorDelegate
的使用

使用 DefaultCellEditor.EditorDelegate 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DefaultCellEditor.EditorDelegate 的使用

声明为 DefaultCellEditor.EditorDelegate 的 javax.swing 中的字段
protected  DefaultCellEditor.EditorDelegate DefaultCellEditor.delegate
处理从 CellEditor 发送的所有方法的委托类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultComboBoxModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultComboBoxModel
的使用

没有 javax.swing.DefaultComboBoxModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultDesktopManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultDesktopManager
的使用

没有 javax.swing.DefaultDesktopManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultFocusManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultFocusManager
的使用

没有 javax.swing.DefaultFocusManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultListCellRenderer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultListCellRenderer
的使用

使用 DefaultListCellRenderer 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 DefaultListCellRenderer 的使用

javax.swing 中 DefaultListCellRenderer 的子类
static class DefaultListCellRenderer.UIResource
实现 UIResource 的 DefaultListCellRenderer 的子类。

javax.swing.plaf.metal 中 DefaultListCellRenderer 的使用

javax.swing.plaf.metal 中 DefaultListCellRenderer 的子类
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultListCellRenderer.UIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultListCellRenderer.UIResource
的使用

没有 javax.swing.DefaultListCellRenderer.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultListModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultListModel
的使用

没有 javax.swing.DefaultListModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultListSelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultListSelectionModel
的使用

使用 DefaultListSelectionModel 的软件包
javax.swing.tree 提供处理 javax.swing.JTree 的类和接口。

javax.swing.tree 中 DefaultListSelectionModel 的使用

声明为 DefaultListSelectionModel 的 javax.swing.tree 中的字段
protected  DefaultListSelectionModel DefaultTreeSelectionModel.listSelectionModel
维护列表选择模型的句柄。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultRowSorter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultRowSorter
的使用

使用 DefaultRowSorter 的软件包
javax.swing.table 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.table 中 DefaultRowSorter 的使用

javax.swing.table 中 DefaultRowSorter 的子类
 class TableRowSorter<M extends TableModel>
RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultRowSorter.ModelWrapper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultRowSorter.ModelWrapper
的使用

使用 DefaultRowSorter.ModelWrapper 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DefaultRowSorter.ModelWrapper 的使用

返回 DefaultRowSorter.ModelWrapper 的 javax.swing 中的方法
protected  DefaultRowSorter.ModelWrapper<M,I> DefaultRowSorter.getModelWrapper()
返回模型包装器，它提供将要进行排序和过滤的数据。

参数类型为 DefaultRowSorter.ModelWrapper 的 javax.swing 中的方法
protected  void DefaultRowSorter.setModelWrapper(DefaultRowSorter.ModelWrapper<M,I> modelWrapper)
设置模型包装器，它提供将要进行排序和过滤的数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DefaultSingleSelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultSingleSelectionModel
的使用

没有 javax.swing.DefaultSingleSelectionModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.DesktopManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.DesktopManager
的使用

使用 DesktopManager 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 DesktopManager 的使用

实现 DesktopManager 的 javax.swing 中的类
 class DefaultDesktopManager
此类是 DesktopManager 的实现。

返回 DesktopManager 的 javax.swing 中的方法
 DesktopManager JDesktopPane.getDesktopManager()
返回处理特定于桌面 UI 操作的 DesktopManger。

参数类型为 DesktopManager 的 javax.swing 中的方法
 void JDesktopPane.setDesktopManager(DesktopManager d)
设置处理特定于桌面 UI 操作的 DesktopManger。

javax.swing.plaf.basic 中 DesktopManager 的使用

声明为 DesktopManager 的 javax.swing.plaf.basic 中的字段
protected  DesktopManager BasicDesktopPaneUI.desktopManager

返回 DesktopManager 的 javax.swing.plaf.basic 中的方法
protected DesktopManager | BasicInternalFrameUI.createDesktopManager()
protected DesktopManager | BasicInternalFrameUI.getDesktopManager() 返回适当的 DesktopManager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.DropMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DropMode
的使用

使用 DropMode 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 DropMode 的使用

返回 DropMode 的 javax.swing 中的方法
DropMode | JTree.getDropMode() 返回此组件的放置模式。
DropMode | JTable.getDropMode() 返回此组件的放置模式。
DropMode | JList.getDropMode() 返回此组件的放置模式。
static DropMode | DropMode.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static DropMode[] | DropMode.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 DropMode 的 javax.swing 中的方法
void | JTree.setDropMode(DropMode dropMode) 设置此组件的放置模式。
void | JTable.setDropMode(DropMode dropMode) 设置此组件的放置模式。
void | JList.setDropMode(DropMode dropMode) 设置此组件的放置模式。

javax.swing.text 中 DropMode 的使用

返回 DropMode 的 javax.swing.text 中的方法
 DropMode JTextComponent.getDropMode()
返回此组件的放置模式。

参数类型为 DropMode 的 javax.swing.text 中的方法
 void JTextComponent.setDropMode(DropMode dropMode)
设置此组件的放置模式，为了向后兼容性，此属性的默认值为 DropMode.USE_SELECTION。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.FocusManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.FocusManager
的使用

使用 FocusManager 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 FocusManager 的使用

javax.swing 中 FocusManager 的子类
 class DefaultFocusManager
此类已被废弃，用 1.4 focus API 取代。

返回 FocusManager 的 javax.swing 中的方法
static FocusManager FocusManager.getCurrentManager()
返回调用线程上下文的当前 KeyboardFocusManager 实例。

参数类型为 FocusManager 的 javax.swing 中的方法
static void FocusManager.setCurrentManager(FocusManager aFocusManager)
设置调用线程上下文的当前 KeyboardFocusManager 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.GrayFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GrayFilter
的使用

没有 javax.swing.GrayFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.GroupLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GroupLayout
的使用

没有 javax.swing.GroupLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.GroupLayout.Alignment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GroupLayout.Alignment
的使用

使用 GroupLayout.Alignment 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 GroupLayout.Alignment 的使用

返回 GroupLayout.Alignment 的 javax.swing 中的方法
static GroupLayout.Alignment | GroupLayout.Alignment.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static GroupLayout.Alignment[] | GroupLayout.Alignment.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 GroupLayout.Alignment 的 javax.swing 中的方法
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment) 使用指定的对齐方式将 Component 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment, int min, int pref, int max) 使用指定的对齐方式和大小将 Component 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group) 使用指定的对齐方式将 Group 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.createParallelGroup(GroupLayout.Alignment alignment) 使用指定的对齐方式创建并返回一个 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.createParallelGroup(GroupLayout.Alignment alignment, boolean resizable) 使用指定的对齐方式和调整大小行为创建并返回一个 ParallelGroup。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.GroupLayout.Group 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GroupLayout.Group
的使用

使用 GroupLayout.Group 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 GroupLayout.Group 的使用

javax.swing 中 GroupLayout.Group 的子类
class | GroupLayout.ParallelGroup 一个 Group，它对齐其子元素并确定其大小。
class | GroupLayout.SequentialGroup 一个 Group，它按顺序一个接一个地确定其元素的位置和大小。

返回 GroupLayout.Group 的 javax.swing 中的方法
GroupLayout.Group | GroupLayout.Group.addComponent(Component component) 将 Component 添加到此 Group。
GroupLayout.Group | GroupLayout.Group.addComponent(Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.Group | GroupLayout.Group.addGap(int size) 将固定间隙添加到此 Group。
GroupLayout.Group | GroupLayout.Group.addGap(int min, int pref, int max) 将指定大小的间隙添加到此 Group。
GroupLayout.Group | GroupLayout.Group.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。

参数类型为 GroupLayout.Group 的 javax.swing 中的方法
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGroup(boolean useAsBaseline, GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group) 使用指定的对齐方式将 Group 添加到此 ParallelGroup。
GroupLayout.Group | GroupLayout.Group.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
void | GroupLayout.setHorizontalGroup(GroupLayout.Group group) 设置沿水平轴确定组件位置和大小的 Group。
void | GroupLayout.setVerticalGroup(GroupLayout.Group group) 设置沿垂直轴确定组件位置和大小的 Group。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.GroupLayout.ParallelGroup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GroupLayout.ParallelGroup
的使用

使用 GroupLayout.ParallelGroup 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 GroupLayout.ParallelGroup 的使用

返回 GroupLayout.ParallelGroup 的 javax.swing 中的方法
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component) 将 Component 添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment) 使用指定的对齐方式将 Component 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment, int min, int pref, int max) 使用指定的对齐方式和大小将 Component 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGap(int pref) 将固定间隙添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGap(int min, int pref, int max) 将指定大小的间隙添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group) 使用指定的对齐方式将 Group 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.createBaselineGroup(boolean resizable, boolean anchorBaselineToTop) 创建并返回一个沿基线对齐其元素的 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.createParallelGroup() 使用 Alignment.LEADING 的对齐方式创建并返回一个 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.createParallelGroup(GroupLayout.Alignment alignment) 使用指定的对齐方式创建并返回一个 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.createParallelGroup(GroupLayout.Alignment alignment, boolean resizable) 使用指定的对齐方式和调整大小行为创建并返回一个 ParallelGroup。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.GroupLayout.SequentialGroup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GroupLayout.SequentialGroup
的使用

使用 GroupLayout.SequentialGroup 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 GroupLayout.SequentialGroup 的使用

返回 GroupLayout.SequentialGroup 的 javax.swing 中的方法
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addComponent(boolean useAsBaseline, Component component) 将 Component 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addComponent(boolean useAsBaseline, Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addComponent(Component component) 将 Component 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addComponent(Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addContainerGap() 添加一个表示容器边缘和触到容器边框的组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addContainerGap(int pref, int max) 使用指定大小添加一个元素，它表示容器的一个边缘和下一个或前一个 Component 之间的首选间隙。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGap(int size) 将固定间隙添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGap(int min, int pref, int max) 将指定大小的间隙添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGroup(boolean useAsBaseline, GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type) 添加一个表示两个组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max) 添加一个表示两个组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type) 添加一个表示两个距离最近的组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type, int pref, int max) 添加一个表示两个距离最近的组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.createSequentialGroup() 创建并返回一个 SequentialGroup。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.Icon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.Icon
的使用

使用 Icon 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 Icon 的使用

实现 Icon 的 javax.swing 中的类
 class ImageIcon
一个 Icon 接口的实现，它根据 Image 绘制 Icon。

声明为 Icon 的 javax.swing 中的字段
protected Icon | JInternalFrame.frameIcon 此内部窗体左上角显示的图标。
protected Icon | JOptionPane.icon 在窗格中使用的图标。

返回 Icon 的 javax.swing 中的方法
Icon | AbstractButton.getDisabledIcon() 返回禁用按钮时按钮使用的图标。
Icon | JLabel.getDisabledIcon() 返回该标签被禁用时所使用的图标。
Icon | LookAndFeel.getDisabledIcon(JComponent component, Icon icon) 返回具有禁用外观的 Icon。
Icon | JTabbedPane.getDisabledIconAt(int index) 返回 index 位置的选项卡禁用图标。
Icon | AbstractButton.getDisabledSelectedIcon() 返回禁用并选择按钮时按钮使用的图标。
Icon | LookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon) 返回由选定的禁用组件使用的 Icon。
Icon | JInternalFrame.getFrameIcon() 返回要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。
Icon | JOptionPane.getIcon() 返回此窗格显示的图标。
Icon | AbstractButton.getIcon() 返回默认图标。
Icon | JLabel.getIcon() 返回该标签显示的图形图像（字形、图标）。
Icon | JFileChooser.getIcon(File f) 返回此文件或文件类型的图标，这取决于系统。
Icon | UIDefaults.getIcon(Object key) 如果 key 值为一个 Icon，则返回该 Icon，否则返回 null。
static Icon | UIManager.getIcon(Object key) 从默认值中返回一个 Icon。
Icon | UIDefaults.getIcon(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Icon，则返回该 Icon，否则返回 null。
static Icon | UIManager.getIcon(Object key, Locale l) 从适合给定语言环境的默认值中返回一个 Icon。
Icon | JTabbedPane.getIconAt(int index) 返回 index 位置的选项卡图标。
Icon | AbstractButton.getPressedIcon() 返回按钮的按下图标。
Icon | AbstractButton.getRolloverIcon() 返回按钮的翻转图标。
Icon | AbstractButton.getRolloverSelectedIcon() 返回按钮的翻转选定图标。
Icon | AbstractButton.getSelectedIcon() 返回按钮的选择图标。
Icon | TransferHandler.getVisualRepresentation(Transferable t) 返回一个建立传输外观的对象。

参数类型为 Icon 的 javax.swing 中的方法
 void JTabbedPane.addTab(String title, Icon icon, Component component)
添加一个由 title 和/或 icon 表示的 component，其任意一个都可以为 null。
 void JTabbedPane.addTab(String title, Icon icon, Component component, String tip)
添加由 title 和/或 icon 表示的 component 和 tip，其中任意一个都可以为 null。
static MatteBorder BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Icon tileIcon)
创建一个由多层指定图标组成的、类似衬边的边框。
 Icon LookAndFeel.getDisabledIcon(JComponent component, Icon icon)
返回具有禁用外观的 Icon。
 Icon LookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon)
返回由选定的禁用组件使用的 Icon。
 int JTabbedPane.indexOfTab(Icon icon)
返回具有给定的 icon 的第一个选项卡索引，如果没有具有此图标的选项卡，则返回 -1。
protected  void JMenuItem.init(String text, Icon icon)
利用指定文本和图标初始化菜单项。
protected  void AbstractButton.init(String text, Icon icon)
 void JTextPane.insertIcon(Icon g)
将一个图标插入文档中，以替换当前选择的内容。
 void JTabbedPane.insertTab(String title, Icon icon, Component component, String tip, int index)
在 index 位置插入一个 component，该组件通过 title 和/或 icon（任意一个都可以为 null）来表示。
static String SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
static String SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
 void AbstractButton.setDisabledIcon(Icon disabledIcon)
设置按钮的禁用图标。
 void JLabel.setDisabledIcon(Icon disabledIcon)
设置如果此 JLabel 是“禁用的”(JLabel.setEnabled(false))，则要显示的图标。
 void JTabbedPane.setDisabledIconAt(int index, Icon disabledIcon)
将 index 位置的禁用图标设置为 icon，它可以为 null。
 void AbstractButton.setDisabledSelectedIcon(Icon disabledSelectedIcon)
设置按钮的禁用选择图标。
 void JInternalFrame.setFrameIcon(Icon icon)
设置要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。
 void JOptionPane.setIcon(Icon newIcon)
设置要显示的图标。
 void AbstractButton.setIcon(Icon defaultIcon)
设置按钮的默认图标。
 void JLabel.setIcon(Icon icon)
定义此组件将要显示的图标。
 void JTabbedPane.setIconAt(int index, Icon icon)
将 index 位置的图标设置为 icon，它可以为 null。
 void AbstractButton.setPressedIcon(Icon pressedIcon)
设置按钮的按下图标。
 void AbstractButton.setRolloverIcon(Icon rolloverIcon)
设置按钮的翻转图标。
 void AbstractButton.setRolloverSelectedIcon(Icon rolloverSelectedIcon)
设置按钮的翻转选择图标。
 void AbstractButton.setSelectedIcon(Icon selectedIcon)
设置按钮的选择图标。
static int JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。
static Object JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。
static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。
static Object JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。
static void JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示消息的内部对话框面板，为其指定了所有参数。
static int JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
static void JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示信息的对话框，为其指定了所有参数。
static int JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

参数类型为 Icon 的 javax.swing 中的构造方法
AbstractAction(String name, Icon icon)
用指定描述字符串和指定图标定义一个 Action 对象。
JButton(Icon icon)
创建一个带图标的按钮。
JButton(String text, Icon icon)
创建一个带初始文本和图标的按钮。
JCheckBox(Icon icon)
创建有一个图标、最初未被选定的复选框。
JCheckBox(Icon icon, boolean selected)
创建一个带图标的复选框，并指定其最初是否处于选定状态。
JCheckBox(String text, Icon icon)
创建带有指定文本和图标的、最初未选定的复选框。
JCheckBox(String text, Icon icon, boolean selected)
创建一个带文本和图标的复选框，并指定其最初是否处于选定状态。
JCheckBoxMenuItem(Icon icon)
创建有一个带图标的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String text, Icon icon)
创建带有指定文本和图标的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String text, Icon icon, boolean b)
创建带有指定文本、图标和选择状态的复选框菜单项。
JLabel(Icon image)
创建具有指定图像的 JLabel 实例。
JLabel(Icon image, int horizontalAlignment)
创建具有指定图像和水平对齐方式的 JLabel 实例。
JLabel(String text, Icon icon, int horizontalAlignment)
创建具有指定文本、图像和水平对齐方式的 JLabel 实例。
JMenuItem(Icon icon)
创建带有指定图标的 JMenuItem。
JMenuItem(String text, Icon icon)
创建带有指定文本和图标的 JMenuItem。
JOptionPane(Object message, int messageType, int optionType, Icon icon)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、选项和图标。
JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。
JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options, Object initialValue)
在指定最初选择的选项的前提下，创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。
JRadioButton(Icon icon)
创建一个初始化为未选择的单选按钮，其具有指定的图像但无文本。
JRadioButton(Icon icon, boolean selected)
创建一个具有指定图像和选择状态的单选按钮，但无文本。
JRadioButton(String text, Icon icon)
创建一个具有指定的文本和图像并初始化为未选择的单选按钮。
JRadioButton(String text, Icon icon, boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮。
JRadioButtonMenuItem(Icon icon)
创建一个带图标的 JRadioButtonMenuItem。
JRadioButtonMenuItem(Icon icon, boolean selected)
创建一个具有指定图像和选择状态的单选按钮菜单项，但无文本。
JRadioButtonMenuItem(String text, Icon icon)
创建一个具有指定文本和 Icon 的单选按钮菜单项。
JRadioButtonMenuItem(String text, Icon icon, boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮菜单项。
JToggleButton(Icon icon)
创建一个最初未选定的切换按钮，该按钮具有指定的图像但是没有文本。
JToggleButton(Icon icon, boolean selected)
创建具有指定图像和选择状态但没有文本的切换按钮。
JToggleButton(String text, Icon icon)
创建一个最初未选定的切换按钮，该按钮具有指定的文本和图像。
JToggleButton(String text, Icon icon, boolean selected)
创建具有指定文本、图像和选择状态的切换按钮。

javax.swing.border 中 Icon 的使用

声明为 Icon 的 javax.swing.border 中的字段
protected  Icon MatteBorder.tileIcon

返回 Icon 的 javax.swing.border 中的方法
 Icon MatteBorder.getTileIcon()
返回平铺边框的图标，如果使用了纯色，则返回 null。

参数类型为 Icon 的 javax.swing.border 中的构造方法
MatteBorder(Icon tileIcon)
创建具有指定平铺图标的衬边边框。
MatteBorder(Insets borderInsets, Icon tileIcon)
创建具有指定 insets 和平铺图标的衬边边框。
MatteBorder(int top, int left, int bottom, int right, Icon tileIcon)
创建具有指定 insets 和平铺图标的衬边边框。

javax.swing.colorchooser 中 Icon 的使用

返回 Icon 的 javax.swing.colorchooser 中的方法
abstract Icon | AbstractColorChooserPanel.getLargeDisplayIcon() 返回此面板的大显示图标。
abstract Icon | AbstractColorChooserPanel.getSmallDisplayIcon() 返回此面板的小图标。

javax.swing.filechooser 中 Icon 的使用

返回 Icon 的 javax.swing.filechooser 中的方法
Icon | FileView.getIcon(File f) 表示 JFileChooser 中此文件的图标。
Icon | FileSystemView.getSystemIcon(File f) 在系统文件浏览器中显示的文件、目录或文件夹的图标。

javax.swing.plaf 中 Icon 的使用

实现 Icon 的 javax.swing.plaf 中的类
 class IconUIResource
实现 UIResource 的 Icon 包装类。

参数类型为 Icon 的 javax.swing.plaf 中的构造方法
BorderUIResource.MatteBorderUIResource(Icon tileIcon)
BorderUIResource.MatteBorderUIResource(int top, int left, int bottom, int right, Icon tileIcon)
IconUIResource(Icon delegate)
创建一个 UIResource 图标对象，该对象包装了一个现有 Icon 实例。

javax.swing.plaf.basic 中 Icon 的使用

声明为 Icon 的 javax.swing.plaf.basic 中的字段
protected Icon | BasicMenuItemUI.arrowIcon
protected Icon | BasicMenuItemUI.checkIcon
protected Icon | BasicInternalFrameTitlePane.closeIcon
protected Icon | BasicTreeUI.collapsedIcon
protected Icon | BasicFileChooserUI.computerIcon
protected Icon | BasicFileChooserUI.detailsViewIcon
protected Icon | BasicFileChooserUI.directoryIcon
protected Icon | BasicTreeUI.expandedIcon
protected Icon | BasicFileChooserUI.fileIcon
protected Icon | BasicFileChooserUI.floppyDriveIcon
protected Icon | BasicFileChooserUI.hardDriveIcon
protected Icon | BasicFileChooserUI.homeFolderIcon
protected Icon | BasicRadioButtonUI.icon
protected Icon | BasicInternalFrameTitlePane.iconIcon
protected Icon | BasicFileChooserUI.listViewIcon
protected Icon | BasicInternalFrameTitlePane.maxIcon
protected Icon | BasicInternalFrameTitlePane.minIcon
protected Icon | BasicFileChooserUI.newFolderIcon
protected Icon | BasicFileChooserUI.upFolderIcon

类型参数类型为 Icon 的 javax.swing.plaf.basic 中的字段
protected  Hashtable<File,Icon> BasicFileChooserUI.BasicFileView.iconCache

返回 Icon 的 javax.swing.plaf.basic 中的方法
static Icon | BasicIconFactory.createEmptyFrameIcon()
Icon | BasicFileChooserUI.BasicFileView.getCachedIcon(File f)
static Icon | BasicIconFactory.getCheckBoxIcon()
static Icon | BasicIconFactory.getCheckBoxMenuItemIcon()
Icon | BasicTreeUI.getCollapsedIcon()
Icon | BasicRadioButtonUI.getDefaultIcon()
Icon | BasicTreeUI.getExpandedIcon()
protected Icon | BasicOptionPaneUI.getIcon() 返回来自接收者为其提供外观的 JOptionPane 的图标，或者从 getDefaultIcon 返回的默认图标。
Icon | BasicFileChooserUI.BasicFileView.getIcon(File f)
protected Icon | BasicTabbedPaneUI.getIconForTab(int tabIndex)
protected Icon | BasicOptionPaneUI.getIconForType(int messageType) 返回用于传入类型的图标。
static Icon | BasicIconFactory.getMenuArrowIcon()
static Icon | BasicIconFactory.getMenuItemArrowIcon()
static Icon | BasicIconFactory.getMenuItemCheckIcon()
static Icon | BasicIconFactory.getRadioButtonIcon()
static Icon | BasicIconFactory.getRadioButtonMenuItemIcon()

参数类型为 Icon 的 javax.swing.plaf.basic 中的方法
 void BasicFileChooserUI.BasicFileView.cacheIcon(File f, Icon i)
protected  void BasicTreeUI.drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
protected  Dimension BasicMenuItemUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
protected  String BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。
protected  void BasicTabbedPaneUI.layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicTabbedPaneUI.paintIcon(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
protected  void BasicMenuItemUI.paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
 void BasicTreeUI.setCollapsedIcon(Icon newG)
 void BasicTreeUI.setExpandedIcon(Icon newG)

javax.swing.plaf.metal 中 Icon 的使用

实现 Icon 的 javax.swing.plaf.metal 中的类
class | MetalCheckBoxIcon OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxIcon 此实用工具类绘制指示 MetalComboBox 的水平条
static class | MetalIconFactory.FileIcon16 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.FolderIcon16 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.PaletteCloseIcon 定义一个用于 Palette 关闭的图标
static class | MetalIconFactory.TreeControlIcon 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.TreeFolderIcon 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.TreeLeafIcon

声明为 Icon 的 javax.swing.plaf.metal 中的字段
protected Icon | MetalComboBoxButton.comboIcon
protected static Icon | MetalSliderUI.horizThumbIcon 默认水平 thumb Icon。
protected Icon | MetalInternalFrameTitlePane.paletteCloseIcon
protected static Icon | MetalSliderUI.vertThumbIcon 默认垂直 thumb Icon。

返回 Icon 的 javax.swing.plaf.metal 中的方法
static Icon | MetalIconFactory.getCheckBoxIcon() 返回一个复选框图标。
static Icon | MetalIconFactory.getCheckBoxMenuItemIcon()
Icon | MetalComboBoxButton.getComboIcon()
Icon | MetalLookAndFeel.getDisabledIcon(JComponent component, Icon icon) 返回具有禁用外观的 Icon。
Icon | MetalLookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon) 返回由选定的禁用组件使用的 Icon。
static Icon | MetalIconFactory.getFileChooserDetailViewIcon()
static Icon | MetalIconFactory.getFileChooserHomeFolderIcon()
static Icon | MetalIconFactory.getFileChooserListViewIcon()
static Icon | MetalIconFactory.getFileChooserNewFolderIcon()
static Icon | MetalIconFactory.getFileChooserUpFolderIcon()
static Icon | MetalIconFactory.getHorizontalSliderThumbIcon()
static Icon | MetalIconFactory.getInternalFrameAltMaximizeIcon(int size)
static Icon | MetalIconFactory.getInternalFrameCloseIcon(int size)
static Icon | MetalIconFactory.getInternalFrameDefaultMenuIcon()
static Icon | MetalIconFactory.getInternalFrameMaximizeIcon(int size)
static Icon | MetalIconFactory.getInternalFrameMinimizeIcon(int size)
static Icon | MetalIconFactory.getMenuArrowIcon()
static Icon | MetalIconFactory.getMenuItemArrowIcon()
static Icon | MetalIconFactory.getMenuItemCheckIcon() 返回一个将由 JCheckBoxMenuItem 使用的图标。
static Icon | MetalIconFactory.getRadioButtonIcon()
static Icon | MetalIconFactory.getRadioButtonMenuItemIcon()
static Icon | MetalIconFactory.getTreeComputerIcon()
static Icon | MetalIconFactory.getTreeControlIcon(boolean isCollapsed)
static Icon | MetalIconFactory.getTreeFloppyDriveIcon()
static Icon | MetalIconFactory.getTreeFolderIcon()
static Icon | MetalIconFactory.getTreeHardDriveIcon()
static Icon | MetalIconFactory.getTreeLeafIcon()
static Icon | MetalIconFactory.getVerticalSliderThumbIcon()

参数类型为 Icon 的 javax.swing.plaf.metal 中的方法
Icon | MetalLookAndFeel.getDisabledIcon(JComponent component, Icon icon) 返回具有禁用外观的 Icon。
Icon | MetalLookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon) 返回由选定的禁用组件使用的 Icon。
void | MetalComboBoxButton.setComboIcon(Icon i)

参数类型为 Icon 的 javax.swing.plaf.metal 中的构造方法
MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)

javax.swing.plaf.synth 中 Icon 的使用

返回 Icon 的 javax.swing.plaf.synth 中的方法
 Icon SynthStyle.getIcon(SynthContext context, Object key)
获得其值是一个 Icon 的特定样式属性的便捷方法。

参数类型为 Icon 的 javax.swing.plaf.synth 中的方法
Dimension | SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最大大小。
Dimension | SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最小大小。
Dimension | SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的首选大小。
String | SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap) 根据通过引用返回的放置图标和文本的位置，布局文本和图标。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset) 绘制图标和文本。

javax.swing.text 中 Icon 的使用

返回 Icon 的 javax.swing.text 中的方法
static Icon StyleConstants.getIcon(AttributeSet a)
从属性列表中获取图标设置。

参数类型为 Icon 的 javax.swing.text 中的方法
static void StyleConstants.setIcon(MutableAttributeSet a, Icon c)
设置图标属性。

javax.swing.text.html 中 Icon 的使用

返回 Icon 的 javax.swing.text.html 中的方法
Icon | ImageView.getLoadingImageIcon() 返回加载图像过程中要使用的图标。
Icon | ImageView.getNoImageIcon() 如果不能找到图像，则返回要使用的图标。

javax.swing.tree 中 Icon 的使用

声明为 Icon 的 javax.swing.tree 中的字段
protected Icon | DefaultTreeCellRenderer.closedIcon 用于显示无扩展的非叶节点的图标。
protected Icon | DefaultTreeCellEditor.editingIcon 编辑时要使用的图标。
protected Icon | DefaultTreeCellRenderer.leafIcon 用于显示叶节点的图标。
protected Icon | DefaultTreeCellRenderer.openIcon 用于显示扩展的非叶节点的图标。

返回 Icon 的 javax.swing.tree 中的方法
Icon | DefaultTreeCellRenderer.getClosedIcon() 返回用于表示没有扩展的非叶节点的图标。
Icon | DefaultTreeCellRenderer.getDefaultClosedIcon() 返回默认图标，对于当前的 laf，它用于表示没有扩展的非叶节点。
Icon | DefaultTreeCellRenderer.getDefaultLeafIcon() 返回默认图标，对于当前的 laf，它用于表示叶节点。
Icon | DefaultTreeCellRenderer.getDefaultOpenIcon() 返回默认图标，对于当前的 laf，它用于表示扩展的非叶节点。
Icon | DefaultTreeCellRenderer.getLeafIcon() 返回用于表示叶节点的图标。
Icon | DefaultTreeCellRenderer.getOpenIcon() 返回用于表示扩展的非叶节点的图标。

参数类型为 Icon 的 javax.swing.tree 中的方法
void | DefaultTreeCellRenderer.setClosedIcon(Icon newIcon) 设置用于表示没有扩展的非叶节点的图标。
void | DefaultTreeCellRenderer.setLeafIcon(Icon newIcon) 设置用于表示叶节点的图标。
void | DefaultTreeCellRenderer.setOpenIcon(Icon newIcon) 设置用于表示扩展的非叶节点的图标。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ImageIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ImageIcon
的使用

没有 javax.swing.ImageIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ImageIcon.AccessibleImageIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ImageIcon.AccessibleImageIcon
的使用

没有 javax.swing.ImageIcon.AccessibleImageIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.InputMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.InputMap
的使用

使用 InputMap 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing 中 InputMap 的使用

javax.swing 中 InputMap 的子类
 class ComponentInputMap
ComponentInputMap 是与特定 JComponent 相关联的 InputMap。

返回 InputMap 的 javax.swing 中的方法
InputMap | JComponent.getInputMap() 返回组件具有焦点时所使用的 InputMap。
InputMap | JComponent.getInputMap(int condition) 返回 condition 中所使用的 InputMap。
InputMap | InputMap.getParent() 获得此 InputMap 的父级。
static InputMap | SwingUtilities.getUIInputMap(JComponent component, int condition) 返回由组件 component 中的条件 condition 的 UI 提供的 InputMap。
static InputMap | LookAndFeel.makeInputMap(Object[] keys) 根据 keys 创建一个 InputMapUIResource。

参数类型为 InputMap 的 javax.swing 中的方法
static void | LookAndFeel.loadKeyBindings(InputMap retMap, Object[] keys) 使用指定绑定填充 InputMap。
static void | SwingUtilities.replaceUIInputMap(JComponent component, int type, InputMap uiInputMap) 将 component 的 UI InputMap 更改为 uiInputMap 的便捷方法。
void | JComponent.setInputMap(int condition, InputMap map) 设置在 map 的 condition 条件下要使用的 InputMap。
void | ComponentInputMap.setParent(InputMap map) 设置父组件，该组件必须是一个和与此 ComponentInputMap 相同的组件相关联的 ComponentInputMap。
void | InputMap.setParent(InputMap map) 设置此 InputMap 的父级。

javax.swing.plaf 中 InputMap 的使用

javax.swing.plaf 中 InputMap 的子类
class | ComponentInputMapUIResource 实现 UIResource 的 javax.swing.ComponentInputMap 的子类。
class | InputMapUIResource 实现 UIResource 的 javax.swing.InputMap 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.InputVerifier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.InputVerifier
的使用

使用 InputVerifier 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 InputVerifier 的使用

返回 InputVerifier 的 javax.swing 中的方法
 InputVerifier JComponent.getInputVerifier()
返回此组件的输入校验器。

参数类型为 InputVerifier 的 javax.swing 中的方法
 void JComponent.setInputVerifier(InputVerifier inputVerifier)
设置此组件的输入校验器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.InternalFrameFocusTraversalPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.InternalFrameFocusTraversalPolicy
的使用

使用 InternalFrameFocusTraversalPolicy 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 InternalFrameFocusTraversalPolicy 的使用

javax.swing 中 InternalFrameFocusTraversalPolicy 的子类
class | LayoutFocusTraversalPolicy 根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。
class | SortingFocusTraversalPolicy 通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JApplet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JApplet
的使用

没有 javax.swing.JApplet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JApplet.AccessibleJApplet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JApplet.AccessibleJApplet
的使用

没有 javax.swing.JApplet.AccessibleJApplet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JButton
的使用

使用 JButton 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JButton 的使用

声明为 JButton 的 javax.swing 中的字段
protected  JButton JRootPane.defaultButton
当窗格成为焦点并有类似按下 Enter 键的特定于 UI 的操作发生时被激活的按钮。

返回 JButton 的 javax.swing 中的方法
JButton | JToolBar.add(Action a) 添加一个指派动作的新的 JButton。
protected JButton | JToolBar.createActionComponent(Action a) 将为 Action 创建 JButton 的工厂方法添加到 JToolBar 中。
JButton | JRootPane.getDefaultButton() 返回 defaultButton 属性的值。

参数类型为 JButton 的 javax.swing 中的方法
protected PropertyChangeListener | JToolBar.createActionChangeListener(JButton b) 返回正确配置的 PropertyChangeListener，它根据 Action 的更改对控件进行更新，如果需要使用默认的属性更改侦听器，则为 null。
void | JRootPane.setDefaultButton(JButton defaultButton) 设置 defaultButton 属性，它确定此 JRootPane 的当前默认按钮。

javax.swing.plaf.basic 中 JButton 的使用

javax.swing.plaf.basic 中 JButton 的子类
 class BasicArrowButton
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。

声明为 JButton 的 javax.swing.plaf.basic 中的字段
protected JButton | BasicComboBoxUI.arrowButton
protected JButton | BasicInternalFrameTitlePane.closeButton
protected JButton | BasicScrollBarUI.decrButton
protected JButton | BasicInternalFrameTitlePane.iconButton
protected JButton | BasicScrollBarUI.incrButton
protected JButton | BasicSplitPaneDivider.leftButton 用于快速切换左边组件的按钮。
protected JButton | BasicInternalFrameTitlePane.maxButton
protected JButton | BasicSplitPaneDivider.rightButton 用于快速切换右边组件的按钮。

返回 JButton 的 javax.swing.plaf.basic 中的方法
protected JButton | BasicComboBoxUI.createArrowButton() 创建一个按钮，将使用它来控制显示或隐藏组合框的弹出部分。
protected JButton | BasicScrollBarUI.createDecreaseButton(int orientation)
protected JButton | BasicScrollBarUI.createIncreaseButton(int orientation)
protected JButton | BasicSplitPaneDivider.createLeftOneTouchButton() 创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的左边组件。
protected JButton | BasicSplitPaneDivider.createRightOneTouchButton() 创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的右边组件。
protected JButton | BasicTabbedPaneUI.createScrollButton(int direction) 创建并返回一个 JButton，它将为用户提供朝某一特定方向滚动选项卡的方式。
protected JButton | BasicFileChooserUI.getApproveButton(JFileChooser fc)

javax.swing.plaf.metal 中 JButton 的使用

javax.swing.plaf.metal 中 JButton 的子类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

返回 JButton 的 javax.swing.plaf.metal 中的方法
protected JButton | MetalComboBoxUI.createArrowButton()
protected JButton | MetalScrollBarUI.createDecreaseButton(int orientation) 返回表示减少量视图的视图。
protected JButton | MetalScrollBarUI.createIncreaseButton(int orientation) 返回表示增加量视图的视图。
protected JButton | MetalFileChooserUI.getApproveButton(JFileChooser fc)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JButton.AccessibleJButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JButton.AccessibleJButton
的使用

没有 javax.swing.JButton.AccessibleJButton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JCheckBox 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JCheckBox
的使用

使用 JCheckBox 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JCheckBox 的使用

参数类型为 JCheckBox 的 javax.swing 中的构造方法
DefaultCellEditor(JCheckBox checkBox)
构造一个使用复选框的 DefaultCellEditor 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JCheckBox.AccessibleJCheckBox 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JCheckBox.AccessibleJCheckBox
的使用

没有 javax.swing.JCheckBox.AccessibleJCheckBox 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JCheckBoxMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JCheckBoxMenuItem
的使用

没有 javax.swing.JCheckBoxMenuItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
的使用

没有 javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JColorChooser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JColorChooser
的使用

使用 JColorChooser 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JColorChooser 的使用

参数类型为 JColorChooser 的 javax.swing 中的方法
static JDialog JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。

javax.swing.colorchooser 中 JColorChooser 的使用

参数类型为 JColorChooser 的 javax.swing.colorchooser 中的方法
void | AbstractColorChooserPanel.installChooserPanel(JColorChooser enclosingChooser) 将面板添加到选取器时被调用。
void | AbstractColorChooserPanel.uninstallChooserPanel(JColorChooser enclosingChooser) 从选取器中移除面板时被调用。

javax.swing.plaf.basic 中 JColorChooser 的使用

声明为 JColorChooser 的 javax.swing.plaf.basic 中的字段
protected  JColorChooser BasicColorChooserUI.chooser
在其上安装此 BasicColorChooserUI 的 JColorChooser。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JColorChooser.AccessibleJColorChooser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JColorChooser.AccessibleJColorChooser
的使用

没有 javax.swing.JColorChooser.AccessibleJColorChooser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JComboBox 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComboBox
的使用

使用 JComboBox 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 JComboBox 的使用

参数类型为 JComboBox 的 javax.swing 中的构造方法
DefaultCellEditor(JComboBox comboBox)
构造一个使用组合框的 DefaultCellEditor 对象。

javax.swing.plaf 中 JComboBox 的使用

参数类型为 JComboBox 的 javax.swing.plaf 中的方法
abstract boolean | ComboBoxUI.isFocusTraversable(JComboBox c) 确定组合框本身是否是可遍历的
abstract boolean | ComboBoxUI.isPopupVisible(JComboBox c) 确定弹出窗口的可见性
abstract void | ComboBoxUI.setPopupVisible(JComboBox c, boolean v) 设置弹出菜单的可见性

javax.swing.plaf.basic 中 JComboBox 的使用

声明为 JComboBox 的 javax.swing.plaf.basic 中的字段
protected JComboBox | BasicComboPopup.comboBox
protected JComboBox | BasicComboBoxUI.comboBox

参数类型为 JComboBox 的 javax.swing.plaf.basic 中的方法
boolean | BasicComboBoxUI.isFocusTraversable(JComboBox c) 确定 JComboBox 是否是可焦点遍历的。
boolean | BasicComboBoxUI.isPopupVisible(JComboBox c) 告知弹出控件是否可见。
void | BasicComboBoxUI.setPopupVisible(JComboBox c, boolean v) 隐藏弹出部分。

参数类型为 JComboBox 的 javax.swing.plaf.basic 中的构造方法
BasicComboPopup(JComboBox combo)

javax.swing.plaf.metal 中 JComboBox 的使用

声明为 JComboBox 的 javax.swing.plaf.metal 中的字段
protected  JComboBox MetalComboBoxButton.comboBox

返回 JComboBox 的 javax.swing.plaf.metal 中的方法
 JComboBox MetalComboBoxButton.getComboBox()

参数类型为 JComboBox 的 javax.swing.plaf.metal 中的方法
 void MetalComboBoxButton.setComboBox(JComboBox cb)

参数类型为 JComboBox 的 javax.swing.plaf.metal 中的构造方法
MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)
MetalComboBoxUI.MetalComboPopup(JComboBox cBox)
已过时。

javax.swing.plaf.multi 中 JComboBox 的使用

参数类型为 JComboBox 的 javax.swing.plaf.multi 中的方法
boolean | MultiComboBoxUI.isFocusTraversable(JComboBox a) 在由此对象处理的每个 UI 上调用 isFocusTraversable 方法。
boolean | MultiComboBoxUI.isPopupVisible(JComboBox a) 在由此对象处理的每个 UI 上调用 isPopupVisible 方法。
void | MultiComboBoxUI.setPopupVisible(JComboBox a, boolean b) 在由此对象处理的每个 UI 上调用 setPopupVisible 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JComboBox.AccessibleJComboBox 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComboBox.AccessibleJComboBox
的使用

没有 javax.swing.JComboBox.AccessibleJComboBox 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.JComboBox.KeySelectionManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.JComboBox.KeySelectionManager
的使用

使用 JComboBox.KeySelectionManager 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JComboBox.KeySelectionManager 的使用

声明为 JComboBox.KeySelectionManager 的 javax.swing 中的字段
protected  JComboBox.KeySelectionManager JComboBox.keySelectionManager
此受保护字段是特定于实现的。

返回 JComboBox.KeySelectionManager 的 javax.swing 中的方法
protected JComboBox.KeySelectionManager | JComboBox.createDefaultKeySelectionManager() 返回默认键选择管理器的实例。
JComboBox.KeySelectionManager | JComboBox.getKeySelectionManager() 返回列表的键选择管理器。

参数类型为 JComboBox.KeySelectionManager 的 javax.swing 中的方法
 void JComboBox.setKeySelectionManager(JComboBox.KeySelectionManager aManager)
设置将键盘字符转换为列表选择的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComponent
的使用

使用 JComponent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 JComponent 的使用

javax.swing 中 JComponent 的子类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。

声明为 JComponent 的 javax.swing 中的字段
protected  JComponent DefaultCellEditor.editorComponent
正被编辑的 Swing 组件。

返回 JComponent 的 javax.swing 中的方法
protected JComponent | JSpinner.createEditor(SpinnerModel model) 此方法由构造方法调用，以创建显示序列当前值的 JComponent。
JComponent | JFileChooser.getAccessory() 返回 accessory 组件。
JComponent | JToolTip.getComponent() 返回工具提示所描述的组件。
JComponent | ComponentInputMap.getComponent() 返回为其创建 InputMap 的组件。
JComponent | JSpinner.getEditor() 返回显示和潜在更改模型值的组件。
JComponent | JColorChooser.getPreviewPanel() 返回显示选取颜色的预览面板。

参数类型为 JComponent 的 javax.swing 中的方法
 void RepaintManager.addDirtyRegion(JComponent c, int x, int y, int w, int h)
在应刷新的组件列表中添加组件。
 void RepaintManager.addInvalidComponent(JComponent invalidComponent)
按照布局需要标记组件，并将事件指派线程的 runnable 排入队列，该线程将验证组件的第一个 isValidateRoot() 祖先。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type)
添加一个表示两个组件之间首选间隙的元素。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max)
添加一个表示两个组件之间首选间隙的元素。
 void DefaultDesktopManager.beginDraggingFrame(JComponent f)
 void DesktopManager.beginDraggingFrame(JComponent f)
通常在用户已经指示他们将开始拖动某个组件时调用此方法。
 void DefaultDesktopManager.beginResizingFrame(JComponent f, int direction)
 void DesktopManager.beginResizingFrame(JComponent f, int direction)
通常在用户已经指示他们将开始重新调整窗体的大小时调用此方法。
static Rectangle SwingUtilities.calculateInnerArea(JComponent c, Rectangle r)
将指定组件的内部绘制区域的位置和大小存储在 r 中，然后返回 r。
 boolean TransferHandler.canImport(JComponent comp, DataFlavor[] transferFlavors)
指示一个组件在实际尝试导入给定数据 flavor 的集合之前是否接受其导入。
protected  Transferable TransferHandler.createTransferable(JComponent c)
创建一个要用作数据传输源的 Transferable。
static RepaintManager RepaintManager.currentManager(JComponent c)
在给定 JComponent 的情况下，返回调用线程的 RepaintManager。
 void DefaultDesktopManager.dragFrame(JComponent f, int newX, int newY)
将正被拖动窗体的可见位置移动到指定位置。
 void DesktopManager.dragFrame(JComponent f, int newX, int newY)
用户已经移动窗体。
 void DefaultDesktopManager.endDraggingFrame(JComponent f)
 void DesktopManager.endDraggingFrame(JComponent f)
此方法在拖动会话结束时发出信号。
 void DefaultDesktopManager.endResizingFrame(JComponent f)
 void DesktopManager.endResizingFrame(JComponent f)
此方法在重新调整大小会话结束时发出信号。
 void TransferHandler.exportAsDrag(JComponent comp, InputEvent e, int action)
导致 Swing 拖动支持的启用。
protected  void TransferHandler.exportDone(JComponent source, Transferable data, int action)
在导出数据之后调用。
 void TransferHandler.exportToClipboard(JComponent comp, Clipboard clip, int action)
导致从给定组件到给定剪贴板的传输。
abstract  int LayoutStyle.getContainerGap(JComponent component, int position, Container parent)
返回组件与其父容器的指定边缘之间放置的空格数量。
 Rectangle RepaintManager.getDirtyRegion(JComponent aComponent)
返回组件的当前脏区。
 Icon LookAndFeel.getDisabledIcon(JComponent component, Icon icon)
返回具有禁用外观的 Icon。
 Icon LookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon)
返回由选定的禁用组件使用的 Icon。
static int JLayeredPane.getLayer(JComponent c)
获得 JComponent 的 layer 属性，此方法不会产生与 setLayer() 类似的副作用（绘制、添加/移除等）。
abstract  int LayoutStyle.getPreferredGap(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent)
返回两个组件之间使用的空格的数量。
 int TransferHandler.getSourceActions(JComponent c)
返回源支持的传输动作的类型；COPY、MOVE 和 LINK 的任意按位或组合。
 ComponentUI UIDefaults.getUI(JComponent target)
创建一个指定组件的 ComponentUI 实现。
static ComponentUI UIManager.getUI(JComponent target)
返回 target 的适当 ComponentUI 实现。
static ActionMap SwingUtilities.getUIActionMap(JComponent component)
返回该 UI 在组件 component 中提供的 ActionMap。
static InputMap SwingUtilities.getUIInputMap(JComponent component, int condition)
返回由组件 component 中的条件 condition 的 UI 提供的 InputMap。
 boolean TransferHandler.importData(JComponent comp, Transferable t)
导致从剪贴板或 DND 放置操作向组件的传输。
static void LookAndFeel.installBorder(JComponent c, String defaultBorderName)
使用默认的值设置组件边框属性的便捷方法。
static void LookAndFeel.installColors(JComponent c, String defaultBgName, String defaultFgName)
使用默认的值设置组件的前景和背景颜色属性的便捷方法。
static void LookAndFeel.installColorsAndFont(JComponent c, String defaultBgName, String defaultFgName, String defaultFontName)
使用默认的值设置组件的前景、背景和字体属性的便捷方法。
static void LookAndFeel.installProperty(JComponent c, String propertyName, Object propertyValue)
在组件上安装具有指定名称和值的属性的便捷方法，条件是该属性尚未由开发人员设置。
 boolean RepaintManager.isCompletelyDirty(JComponent aComponent)
在下一个 paintDirtyRegions() 中全部绘制 aComponent 时返回 true 的便捷方法。
static String SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
static ComponentInputMap LookAndFeel.makeComponentInputMap(JComponent c, Object[] keys)
根据 keys 创建一个 ComponentInputMapUIResource。
 void RepaintManager.markCompletelyClean(JComponent aComponent)
标记完全干净的组件。
 void RepaintManager.markCompletelyDirty(JComponent aComponent)
标记完全弄脏的组件。
static void JLayeredPane.putLayer(JComponent c, int layer)
设置 JComponent 上的 layer 属性。
 void ToolTipManager.registerComponent(JComponent component)
注册一个工具提示管理组件。
 void RepaintManager.removeInvalidComponent(JComponent component)
从无效组件的列表移除组件。
static void SwingUtilities.replaceUIActionMap(JComponent component, ActionMap uiActionMap)
将 component 的 UI ActionMap 更改为 uiActionMap 的便捷方法。
static void SwingUtilities.replaceUIInputMap(JComponent component, int type, InputMap uiInputMap)
将 component 的 UI InputMap 更改为 uiInputMap 的便捷方法。
 void DefaultDesktopManager.resizeFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
使用新值调用 setBoundsForFrame。
 void DesktopManager.resizeFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
用户已经重新调整组件的大小。
 void JFileChooser.setAccessory(JComponent newAccessory)
设置 accessory 组件。
 void DefaultDesktopManager.setBoundsForFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
此方法移动 JComponent 并重新绘制已毁坏的区域。
 void DesktopManager.setBoundsForFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
这是一个基本重塑方法。
 void JToolTip.setComponent(JComponent c)
指定工具提示所描述的组件。
 void JSpinner.setEditor(JComponent editor)
更改显示 SpinnerModel 当前值的 JComponent。
 void JColorChooser.setPreviewPanel(JComponent preview)
设置当前预览面板。
 boolean InputVerifier.shouldYieldFocus(JComponent input)
调用 verify(input) 来确保输入是有效的。
static void LookAndFeel.uninstallBorder(JComponent c)
卸载边框的便捷方法。
 void ToolTipManager.unregisterComponent(JComponent component)
从工具提示控件中移除一个组件。
abstract  boolean InputVerifier.verify(JComponent input)
检查 JComponent 的输入是否有效。

参数类型为 JComponent 的 javax.swing 中的构造方法
ComponentInputMap(JComponent component)
创建一个与给定组件相关联的 ComponentInputMap。
DebugGraphics(Graphics graphics, JComponent component)
根据现有图形上下文构造一个调试图形上下文，该上下文可以减慢指定组件的绘制。

javax.swing.colorchooser 中 JComponent 的使用

javax.swing.colorchooser 中 JComponent 的子类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

返回 JComponent 的 javax.swing.colorchooser 中的方法
static JComponent ColorChooserComponentFactory.getPreviewPanel()

javax.swing.event 中 JComponent 的使用

返回 JComponent 的 javax.swing.event 中的方法
 JComponent AncestorEvent.getComponent()
返回添加了侦听器的组件。

参数类型为 JComponent 的 javax.swing.event 中的构造方法
AncestorEvent(JComponent source, int id, Container ancestor, Container ancestorParent)
构造一个 AncestorEvent 对象，以标识祖先组件显示状态的更改。

javax.swing.plaf 中 JComponent 的使用

参数类型为 JComponent 的 javax.swing.plaf 中的方法
boolean | ComponentUI.contains(JComponent c, int x, int y) 如果指定 x,y 位置包含在指定组件外观的已定义形状中，则返回 true。
static ComponentUI | ComponentUI.createUI(JComponent c) 返回指定组件的一个 UI 委托实例。
Accessible | ComponentUI.getAccessibleChild(JComponent c, int i) 返回对象的第 i 个 Accessible 子对象。
int | ComponentUI.getAccessibleChildrenCount(JComponent c) 返回对象中的可访问子对象数。
int | ComponentUI.getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | ComponentUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，指示组件的基线如何随大小的改变而发生更改。
Dimension | ComponentUI.getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | ComponentUI.getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | ComponentUI.getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
void | ComponentUI.installUI(JComponent c) 配置指定组件，使其适合外观。
void | ComponentUI.paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
void | ComponentUI.uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
void | ComponentUI.update(Graphics g, JComponent c) 通知此 UI 委托开始绘制指定的组件。

参数类型为 JComponent 的 javax.swing.plaf 中的构造方法
ComponentInputMapUIResource(JComponent component)

javax.swing.plaf.basic 中 JComponent 的使用

javax.swing.plaf.basic 中 JComponent 的子类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。

声明为 JComponent 的 javax.swing.plaf.basic 中的字段
protected JComponent | BasicInternalFrameUI.eastPane
protected JComponent | BasicDesktopIconUI.iconPane 在桌面图标中使用的标题窗格组件。
protected JComponent | BasicOptionPaneUI.inputComponent 如果 optionPane.getWantsInput() 返回 true，则 JComponent 提供输入。
protected JComponent | BasicInternalFrameUI.northPane
protected JComponent | BasicInternalFrameUI.southPane
protected JComponent | BasicInternalFrameUI.westPane

返回 JComponent 的 javax.swing.plaf.basic 中的方法
protected JComponent | BasicInternalFrameUI.createEastPane(JInternalFrame w)
protected JComponent | BasicSpinnerUI.createEditor() installUI 通过调用此方法获取 JSpinner 的编辑器组件。
protected JComponent | BasicInternalFrameUI.createNorthPane(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createSouthPane(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createWestPane(JInternalFrame w)
JComponent | BasicInternalFrameUI.getEastPane()
JComponent | BasicInternalFrameUI.getNorthPane()
JComponent | BasicInternalFrameUI.getSouthPane()
JComponent | BasicInternalFrameUI.getWestPane()

参数类型为 JComponent 的 javax.swing.plaf.basic 中的方法
protected  ChangeListener BasicMenuUI.createChangeListener(JComponent c)
static View BasicHTML.createHTMLView(JComponent c, String html)
创建给定组件和 html 字符串的 html 渲染器。
protected  MenuDragMouseListener BasicMenuUI.createMenuDragMouseListener(JComponent c)
protected  MenuDragMouseListener BasicMenuItemUI.createMenuDragMouseListener(JComponent c)
protected  MenuKeyListener BasicMenuUI.createMenuKeyListener(JComponent c)
protected  MenuKeyListener BasicMenuItemUI.createMenuKeyListener(JComponent c)
protected  MenuListener BasicMenuUI.createMenuListener(JComponent c)
protected  MouseInputListener BasicMenuUI.createMouseInputListener(JComponent c)
protected  MouseInputListener BasicMenuItemUI.createMouseInputListener(JComponent c)
protected  PropertyChangeListener BasicMenuUI.createPropertyChangeListener(JComponent c)
protected  PropertyChangeListener BasicMenuItemUI.createPropertyChangeListener(JComponent c)
创建一个将被添加到菜单项的 PropertyChangeListener。
static ComponentUI BasicCheckBoxUI.createUI(JComponent b)
static ComponentUI BasicColorChooserUI.createUI(JComponent c)
static ComponentUI BasicDesktopIconUI.createUI(JComponent c)
static ComponentUI BasicDesktopPaneUI.createUI(JComponent c)
static ComponentUI BasicEditorPaneUI.createUI(JComponent c)
创建 JTextPane 的 UI。
static ComponentUI BasicFormattedTextFieldUI.createUI(JComponent c)
创建 JFormattedTextField 的 UI。
static ComponentUI BasicInternalFrameUI.createUI(JComponent b)
static ComponentUI BasicOptionPaneUI.createUI(JComponent x)
创建一个新的 BasicOptionPaneUI 实例。
static ComponentUI BasicPasswordFieldUI.createUI(JComponent c)
创建 JPasswordField 的 UI。
static ComponentUI BasicPopupMenuSeparatorUI.createUI(JComponent c)
static ComponentUI BasicSpinnerUI.createUI(JComponent c)
返回 BasicSpinnerUI 的新实例。
static ComponentUI BasicTextPaneUI.createUI(JComponent c)
创建 JTextPane 的 UI。
static ComponentUI BasicToolTipUI.createUI(JComponent c)
static ComponentUI BasicRadioButtonMenuItemUI.createUI(JComponent b)
static ComponentUI BasicCheckBoxMenuItemUI.createUI(JComponent c)
static ComponentUI BasicSliderUI.createUI(JComponent b)
static ComponentUI BasicTextAreaUI.createUI(JComponent ta)
创建 JTextArea 的 UI。
static ComponentUI BasicSplitPaneUI.createUI(JComponent x)
创建新的 BasicSplitPaneUI 实例
static ComponentUI BasicTreeUI.createUI(JComponent x)
static ComponentUI BasicTableUI.createUI(JComponent c)
static ComponentUI BasicTableHeaderUI.createUI(JComponent h)
static ComponentUI BasicProgressBarUI.createUI(JComponent x)
static ComponentUI BasicRadioButtonUI.createUI(JComponent b)
static ComponentUI BasicTabbedPaneUI.createUI(JComponent c)
static ComponentUI BasicToolBarSeparatorUI.createUI(JComponent c)
static ComponentUI BasicTextFieldUI.createUI(JComponent c)
创建 JTextField 的 UI。
static ComponentUI BasicScrollPaneUI.createUI(JComponent x)
static ComponentUI BasicViewportUI.createUI(JComponent c)
static ComponentUI BasicListUI.createUI(JComponent list)
返回 BasicListUI 的新实例。
static ComponentUI BasicComboBoxUI.createUI(JComponent c)
static ComponentUI BasicScrollBarUI.createUI(JComponent c)
static ComponentUI BasicSeparatorUI.createUI(JComponent c)
static ComponentUI BasicPopupMenuUI.createUI(JComponent x)
static ComponentUI BasicMenuUI.createUI(JComponent x)
static ComponentUI BasicMenuItemUI.createUI(JComponent c)
static ComponentUI BasicToolBarUI.createUI(JComponent c)
static ComponentUI BasicMenuBarUI.createUI(JComponent x)
static ComponentUI BasicToggleButtonUI.createUI(JComponent b)
static ComponentUI BasicButtonUI.createUI(JComponent c)
static ComponentUI BasicLabelUI.createUI(JComponent c)
static ComponentUI BasicRootPaneUI.createUI(JComponent c)
static ComponentUI BasicPanelUI.createUI(JComponent c)
protected  void BasicInternalFrameUI.deinstallMouseHandlers(JComponent c)
 Accessible BasicComboBoxUI.getAccessibleChild(JComponent c, int i)
 int BasicComboBoxUI.getAccessibleChildrenCount(JComponent c)
 int BasicSpinnerUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicSliderUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTextAreaUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTreeUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTableUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTableHeaderUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicProgressBarUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTabbedPaneUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTextFieldUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicScrollPaneUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicListUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicComboBoxUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicButtonUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicLabelUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicPanelUI.getBaseline(JComponent c, int width, int height)
返回基线。
 Component.BaselineResizeBehavior BasicSpinnerUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicSliderUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicTextAreaUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicTreeUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicTableUI.getBaselineResizeBehavior(JComponent c)
返回指示该组件的基线如何随大小的改变而发生更改的枚举。
 Component.BaselineResizeBehavior BasicProgressBarUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicTabbedPaneUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicTextFieldUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicScrollPaneUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicListUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicComboBoxUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicButtonUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicLabelUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicPanelUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Insets BasicDesktopIconUI.getInsets(JComponent c)
 Insets BasicSplitPaneUI.getInsets(JComponent jc)
返回 insets。
 Dimension BasicDesktopIconUI.getMaximumSize(JComponent c)
不能调整桌面图标的大小。
 Dimension BasicDesktopPaneUI.getMaximumSize(JComponent c)
 Dimension BasicInternalFrameUI.getMaximumSize(JComponent x)
 Dimension BasicToolTipUI.getMaximumSize(JComponent c)
 Dimension BasicSliderUI.getMaximumSize(JComponent c)
 Dimension BasicSplitPaneUI.getMaximumSize(JComponent jc)
返回传入组件的最大大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getMaximumSize(JComponent c)
返回此组件的最大大小，如果实例当前位于 JTree 中或 0, 0 处，则该大小将为首选大小。
 Dimension BasicTableUI.getMaximumSize(JComponent c)
返回表的最大大小。
 Dimension BasicTableHeaderUI.getMaximumSize(JComponent c)
返回标题的最大大小。
 Dimension BasicProgressBarUI.getMaximumSize(JComponent c)
 Dimension BasicTabbedPaneUI.getMaximumSize(JComponent c)
 Dimension BasicTextUI.getMaximumSize(JComponent c)
获取编辑器组件的最大大小。
 Dimension BasicScrollPaneUI.getMaximumSize(JComponent c)
 Dimension BasicComboBoxUI.getMaximumSize(JComponent c)
 Dimension BasicScrollBarUI.getMaximumSize(JComponent c)
 Dimension BasicSeparatorUI.getMaximumSize(JComponent c)
 Dimension BasicMenuUI.getMaximumSize(JComponent c)
 Dimension BasicMenuItemUI.getMaximumSize(JComponent c)
 Dimension BasicMenuBarUI.getMaximumSize(JComponent c)
 Dimension BasicButtonUI.getMaximumSize(JComponent c)
 Dimension BasicLabelUI.getMaximumSize(JComponent c)
 Dimension BasicDesktopIconUI.getMinimumSize(JComponent c)
 Dimension BasicDesktopPaneUI.getMinimumSize(JComponent c)
 Dimension BasicInternalFrameUI.getMinimumSize(JComponent x)
 Dimension BasicToolTipUI.getMinimumSize(JComponent c)
 Dimension BasicSliderUI.getMinimumSize(JComponent c)
 Dimension BasicTextAreaUI.getMinimumSize(JComponent c)
重写此方法以将插入符的宽度考虑在内。
 Dimension BasicSplitPaneUI.getMinimumSize(JComponent jc)
返回传入组件的最小大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getMinimumSize(JComponent c)
返回此组件的最小大小。
 Dimension BasicTableUI.getMinimumSize(JComponent c)
返回表的最小大小。
 Dimension BasicTableHeaderUI.getMinimumSize(JComponent c)
返回标题的最小大小。
 Dimension BasicProgressBarUI.getMinimumSize(JComponent c)
此组件的最小大小为 10。
 Dimension BasicTabbedPaneUI.getMinimumSize(JComponent c)
 Dimension BasicTextUI.getMinimumSize(JComponent c)
获取编辑器组件的最小大小。
 Dimension BasicComboBoxUI.getMinimumSize(JComponent c)
最小大小为显示区域加上 insets 再加上按钮的大小。
 Dimension BasicSeparatorUI.getMinimumSize(JComponent c)
 Dimension BasicMenuItemUI.getMinimumSize(JComponent c)
 Dimension BasicMenuBarUI.getMinimumSize(JComponent c)
 Dimension BasicButtonUI.getMinimumSize(JComponent c)
 Dimension BasicLabelUI.getMinimumSize(JComponent c)
protected  Dimension BasicMenuItemUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
 Dimension BasicDesktopIconUI.getPreferredSize(JComponent c)
 Dimension BasicDesktopPaneUI.getPreferredSize(JComponent c)
 Dimension BasicInternalFrameUI.getPreferredSize(JComponent x)
 Dimension BasicOptionPaneUI.getPreferredSize(JComponent c)
如果 c 为包含接收者的 JOptionPane，则返回的首选大小为 JOptionPane 的 LayoutManager 的最大首选大小和 getMinimumOptionPaneSize。
 Dimension BasicPopupMenuSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicToolTipUI.getPreferredSize(JComponent c)
 Dimension BasicSliderUI.getPreferredSize(JComponent c)
 Dimension BasicTextAreaUI.getPreferredSize(JComponent c)
重写此方法以将插入符的宽度考虑在内。
 Dimension BasicSplitPaneUI.getPreferredSize(JComponent jc)
返回传入组件的首选大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getPreferredSize(JComponent c)
返回首选大小以正确显示树，这是一种 getPreferredSize(c, false) 的替代方法。
 Dimension BasicTableUI.getPreferredSize(JComponent c)
返回表的首选大小。
 Dimension BasicTableHeaderUI.getPreferredSize(JComponent c)
返回标题的首选大小。
 Dimension BasicProgressBarUI.getPreferredSize(JComponent c)
 Dimension BasicRadioButtonUI.getPreferredSize(JComponent c)
单选按钮的首选大小。
 Dimension BasicToolBarSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicTextUI.getPreferredSize(JComponent c)
获取编辑器组件的首选大小。
 Dimension BasicListUI.getPreferredSize(JComponent c)
列表的 preferredSize 依赖于布局方向。
 Dimension BasicComboBoxUI.getPreferredSize(JComponent c)
 Dimension BasicScrollBarUI.getPreferredSize(JComponent c)
垂直滚动条的首选宽度是（非 null）递增/递减按钮的首选宽度的最大值，也是 thumb 的最小宽度。
 Dimension BasicSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicMenuItemUI.getPreferredSize(JComponent c)
 Dimension BasicButtonUI.getPreferredSize(JComponent c)
 Dimension BasicLabelUI.getPreferredSize(JComponent c)
 Dimension BasicTreeUI.getPreferredSize(JComponent c, boolean checkConsistancy)
返回首选大小以表示 c 中的树。
protected  void BasicToolTipUI.installDefaults(JComponent c)
protected  void BasicViewportUI.installDefaults(JComponent c)
 void BasicButtonListener.installKeyboardActions(JComponent c)
注册默认键动作：按下空格键以“单击”按钮并注册键盘助记符（如果有）。
protected  void BasicToolTipUI.installListeners(JComponent c)
protected  void BasicInternalFrameUI.installMouseHandlers(JComponent c)
protected  void BasicToolBarUI.installNonRolloverBorders(JComponent c)
在 JComponent 的所有子组件上安装非翻转边框。
protected  void BasicToolBarUI.installNormalBorders(JComponent c)
在 JComponent 的所有子组件上安装普通边框。
protected  void BasicToolBarUI.installRolloverBorders(JComponent c)
在 JComponent 的所有子组件上安装翻转边框。
 void BasicColorChooserUI.installUI(JComponent c)
 void BasicDesktopIconUI.installUI(JComponent c)
 void BasicDesktopPaneUI.installUI(JComponent c)
 void BasicEditorPaneUI.installUI(JComponent c)
安装组件的 UI。
 void BasicFileChooserUI.installUI(JComponent c)
 void BasicInternalFrameUI.installUI(JComponent c)
 void BasicOptionPaneUI.installUI(JComponent c)
安装作为传入 JOptionPane 的 L&F 的接收者。
 void BasicSpinnerUI.installUI(JComponent c)
调用 installDefaults、installListeners，然后添加由 createNextButton、createPreviousButton 和 createEditor 返回的组件。
 void BasicTextPaneUI.installUI(JComponent c)
 void BasicToolTipUI.installUI(JComponent c)
 void BasicSliderUI.installUI(JComponent c)
 void BasicSplitPaneUI.installUI(JComponent c)
安装 UI。
 void BasicTreeUI.installUI(JComponent c)
 void BasicTableUI.installUI(JComponent c)
 void BasicTableHeaderUI.installUI(JComponent c)
 void BasicProgressBarUI.installUI(JComponent c)
 void BasicTabbedPaneUI.installUI(JComponent c)
 void BasicTextUI.installUI(JComponent c)
安装组件的 UI。
 void BasicScrollPaneUI.installUI(JComponent x)
 void BasicViewportUI.installUI(JComponent c)
 void BasicListUI.installUI(JComponent c)
按顺序调用 installDefaults()、installListeners() 和 installKeyboardActions() 来初始化 this.list。
 void BasicComboBoxUI.installUI(JComponent c)
 void BasicScrollBarUI.installUI(JComponent c)
 void BasicSeparatorUI.installUI(JComponent c)
 void BasicPopupMenuUI.installUI(JComponent c)
 void BasicMenuItemUI.installUI(JComponent c)
 void BasicToolBarUI.installUI(JComponent c)
 void BasicMenuBarUI.installUI(JComponent c)
 void BasicButtonUI.installUI(JComponent c)
 void BasicLabelUI.installUI(JComponent c)
 void BasicRootPaneUI.installUI(JComponent c)
 void BasicPanelUI.installUI(JComponent c)
 void BasicDesktopIconUI.MouseInputHandler.moveAndRepaint(JComponent f, int newX, int newY, int newWidth, int newHeight)
 void BasicDesktopPaneUI.paint(Graphics g, JComponent c)
 void BasicPopupMenuSeparatorUI.paint(Graphics g, JComponent c)
 void BasicToolTipUI.paint(Graphics g, JComponent c)
 void BasicSliderUI.paint(Graphics g, JComponent c)
 void BasicSplitPaneUI.paint(Graphics g, JComponent jc)
传递消息以绘制外观。
 void BasicTreeUI.paint(Graphics g, JComponent c)
 void BasicTableUI.paint(Graphics g, JComponent c)
绘制用 installUI() 设置的 table 实例的表示形式。
 void BasicTableHeaderUI.paint(Graphics g, JComponent c)
 void BasicProgressBarUI.paint(Graphics g, JComponent c)
将绘制委托给两种方法之一：paintDeterminate 和 paintIndeterminate。
 void BasicRadioButtonUI.paint(Graphics g, JComponent c)
绘制单选按钮
 void BasicTabbedPaneUI.paint(Graphics g, JComponent c)
 void BasicToolBarSeparatorUI.paint(Graphics g, JComponent c)
 void BasicTextUI.paint(Graphics g, JComponent c)
绘制界面。
 void BasicScrollPaneUI.paint(Graphics g, JComponent c)
 void BasicListUI.paint(Graphics g, JComponent c)
绘制与 Graphics 对象 clipRect 相交的行。
 void BasicComboBoxUI.paint(Graphics g, JComponent c)
 void BasicScrollBarUI.paint(Graphics g, JComponent c)
 void BasicSeparatorUI.paint(Graphics g, JComponent c)
 void BasicMenuItemUI.paint(Graphics g, JComponent c)
 void BasicToggleButtonUI.paint(Graphics g, JComponent c)
 void BasicButtonUI.paint(Graphics g, JComponent c)
 void BasicLabelUI.paint(Graphics g, JComponent c)
使用前景色绘制标签文本，如果标签不透明，则利用背景色绘制整个背景。
protected  void BasicProgressBarUI.paintDeterminate(Graphics g, JComponent c)
对几乎所有线性、确定进度条都能正确执行操作的多用途绘制方法。
protected  void BasicTreeUI.paintHorizontalLine(Graphics g, JComponent c, int y, int left, int right)
绘制水平线。
protected  void BasicButtonUI.paintIcon(Graphics g, JComponent c, Rectangle iconRect)
protected  void BasicProgressBarUI.paintIndeterminate(Graphics g, JComponent c)
对所有线性跳动框进度条都能正确执行操作的多用途绘制方法。
protected  void BasicMenuItemUI.paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
protected  void BasicButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
protected  void BasicScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected  void BasicScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
protected  void BasicTreeUI.paintVerticalLine(Graphics g, JComponent c, int x, int top, int bottom)
绘制垂直线。
protected  void BasicSpinnerUI.replaceEditor(JComponent oldEditor, JComponent newEditor)
当 JSpinner 编辑器属性更改时，由 PropertyChangeListener 调用。
protected  void BasicInternalFrameUI.replacePane(JComponent currentPane, JComponent newPane)
将必需的鼠标处理程序安装在 newPane 上并将其添加到窗体。
 void BasicInternalFrameUI.setEastPane(JComponent c)
 void BasicInternalFrameUI.setNorthPane(JComponent c)
 void BasicInternalFrameUI.setSouthPane(JComponent c)
 void BasicInternalFrameUI.setWestPane(JComponent c)
protected  void BasicToolTipUI.uninstallDefaults(JComponent c)
protected  void BasicViewportUI.uninstallDefaults(JComponent c)
 void BasicButtonListener.uninstallKeyboardActions(JComponent c)
未注册的默认键动作
protected  void BasicToolTipUI.uninstallListeners(JComponent c)
protected  void BasicScrollPaneUI.uninstallListeners(JComponent c)
 void BasicColorChooserUI.uninstallUI(JComponent c)
 void BasicDesktopIconUI.uninstallUI(JComponent c)
 void BasicDesktopPaneUI.uninstallUI(JComponent c)
 void BasicEditorPaneUI.uninstallUI(JComponent c)
卸载组件的 UI。
 void BasicFileChooserUI.uninstallUI(JComponent c)
 void BasicInternalFrameUI.uninstallUI(JComponent c)
 void BasicOptionPaneUI.uninstallUI(JComponent c)
从传入拆分窗格的 L&F 控制器移除接收者。
 void BasicSpinnerUI.uninstallUI(JComponent c)
调用 uninstallDefaults、uninstallListeners，然后移除所有子 spinner。
 void BasicToolTipUI.uninstallUI(JComponent c)
 void BasicSliderUI.uninstallUI(JComponent c)
 void BasicSplitPaneUI.uninstallUI(JComponent c)
卸载 UI。
 void BasicTreeUI.uninstallUI(JComponent c)
 void BasicTableUI.uninstallUI(JComponent c)
 void BasicTableHeaderUI.uninstallUI(JComponent c)
 void BasicProgressBarUI.uninstallUI(JComponent c)
 void BasicTabbedPaneUI.uninstallUI(JComponent c)
 void BasicTextUI.uninstallUI(JComponent c)
卸载组件的 UI。
 void BasicScrollPaneUI.uninstallUI(JComponent c)
 void BasicViewportUI.uninstallUI(JComponent c)
 void BasicListUI.uninstallUI(JComponent c)
按顺序调用 uninstallListeners()、uninstallKeyboardActions() 和 uninstallDefaults() 来取消初始化 this.list。
 void BasicComboBoxUI.uninstallUI(JComponent c)
 void BasicScrollBarUI.uninstallUI(JComponent c)
 void BasicSeparatorUI.uninstallUI(JComponent c)
 void BasicPopupMenuUI.uninstallUI(JComponent c)
 void BasicMenuItemUI.uninstallUI(JComponent c)
 void BasicToolBarUI.uninstallUI(JComponent c)
 void BasicMenuBarUI.uninstallUI(JComponent c)
 void BasicButtonUI.uninstallUI(JComponent c)
 void BasicLabelUI.uninstallUI(JComponent c)
 void BasicRootPaneUI.uninstallUI(JComponent c)
 void BasicPanelUI.uninstallUI(JComponent c)
 void BasicTextUI.update(Graphics g, JComponent c)
超类以无法控制的方式绘制背景（即有人可能希望将图像平铺在背景中）。
 void BasicMenuItemUI.update(Graphics g, JComponent c)
使用 paintMenuItem() 绘制背景，从而重写 update（默认情况下填充不透明组件的背景）以调用 paint()。
static void BasicHTML.updateRenderer(JComponent c, String text)
将给定文本的 HTML 渲染器隐藏在给定 JComponent 的客户端属性中。

javax.swing.plaf.metal 中 JComponent 的使用

javax.swing.plaf.metal 中 JComponent 的子类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

返回 JComponent 的 javax.swing.plaf.metal 中的方法
protected  JComponent MetalInternalFrameUI.createNorthPane(JInternalFrame w)

参数类型为 JComponent 的 javax.swing.plaf.metal 中的方法
static ComponentUI | MetalDesktopIconUI.createUI(JComponent c)
static ComponentUI | MetalFileChooserUI.createUI(JComponent c)
static ComponentUI | MetalInternalFrameUI.createUI(JComponent c)
static ComponentUI | MetalToolTipUI.createUI(JComponent c)
static ComponentUI | MetalSliderUI.createUI(JComponent c)
static ComponentUI | MetalSplitPaneUI.createUI(JComponent x) 创建一个新的 MetalSplitPaneUI 实例
static ComponentUI | MetalTreeUI.createUI(JComponent x)
static ComponentUI | MetalProgressBarUI.createUI(JComponent c)
static ComponentUI | MetalCheckBoxUI.createUI(JComponent b)
static ComponentUI | MetalRadioButtonUI.createUI(JComponent c)
static ComponentUI | MetalTabbedPaneUI.createUI(JComponent x)
static ComponentUI | MetalTextFieldUI.createUI(JComponent c)
static ComponentUI | MetalScrollPaneUI.createUI(JComponent x)
static ComponentUI | MetalComboBoxUI.createUI(JComponent c)
static ComponentUI | MetalScrollBarUI.createUI(JComponent c)
static ComponentUI | MetalPopupMenuSeparatorUI.createUI(JComponent c)
static ComponentUI | MetalSeparatorUI.createUI(JComponent c)
static ComponentUI | MetalToolBarUI.createUI(JComponent c)
static ComponentUI | MetalMenuBarUI.createUI(JComponent x) 为传入的组件创建 ComponentUI 实现。
static ComponentUI | MetalToggleButtonUI.createUI(JComponent b)
static ComponentUI | MetalButtonUI.createUI(JComponent c)
static ComponentUI | MetalLabelUI.createUI(JComponent c)
static ComponentUI | MetalRootPaneUI.createUI(JComponent c) 为 JRootPane 创建一个 UI。
int | MetalComboBoxUI.getBaseline(JComponent c, int width, int height) 返回基线。
Icon | MetalLookAndFeel.getDisabledIcon(JComponent component, Icon icon) 返回具有禁用外观的 Icon。
Icon | MetalLookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon) 返回由选定的禁用组件使用的 Icon。
Dimension | MetalDesktopIconUI.getMaximumSize(JComponent c)
Dimension | MetalFileChooserUI.getMaximumSize(JComponent c) 返回 JFileChooser 的最大大小。
Dimension | MetalDesktopIconUI.getMinimumSize(JComponent c)
Dimension | MetalFileChooserUI.getMinimumSize(JComponent c) 返回 JFileChooser 的最小大小。
Dimension | MetalComboBoxUI.getMinimumSize(JComponent c)
Dimension | MetalDesktopIconUI.getPreferredSize(JComponent c)
Dimension | MetalFileChooserUI.getPreferredSize(JComponent c) 返回指定 JFileChooser 的首选大小。
Dimension | MetalToolTipUI.getPreferredSize(JComponent c)
Dimension | MetalScrollBarUI.getPreferredSize(JComponent c)
Dimension | MetalPopupMenuSeparatorUI.getPreferredSize(JComponent c)
Dimension | MetalSeparatorUI.getPreferredSize(JComponent c)
void | MetalFileChooserUI.installUI(JComponent c)
void | MetalInternalFrameUI.installUI(JComponent c)
void | MetalToolTipUI.installUI(JComponent c)
void | MetalSliderUI.installUI(JComponent c)
void | MetalTreeUI.installUI(JComponent c)
void | MetalScrollPaneUI.installUI(JComponent c)
void | MetalToolBarUI.installUI(JComponent c)
void | MetalMenuBarUI.installUI(JComponent c) 配置指定组件，使其适合 metal 外观。
void | MetalRootPaneUI.installUI(JComponent c) 调用 installUI 的超实现来在传入的 JRootPane 上安装必要的状态，以呈现 RootPaneUI 的 metal 外观实现。
void | MetalToolTipUI.paint(Graphics g, JComponent c)
void | MetalTreeUI.paint(Graphics g, JComponent c)
void | MetalRadioButtonUI.paint(Graphics g, JComponent c)
void | MetalTabbedPaneUI.paint(Graphics g, JComponent c)
void | MetalComboBoxUI.paint(Graphics g, JComponent c)
void | MetalPopupMenuSeparatorUI.paint(Graphics g, JComponent c)
void | MetalSeparatorUI.paint(Graphics g, JComponent c)
void | MetalProgressBarUI.paintDeterminate(Graphics g, JComponent c) 在进度条上绘制少量特殊的高亮显示。
protected void | MetalTreeUI.paintHorizontalSeparators(Graphics g, JComponent c)
void | MetalProgressBarUI.paintIndeterminate(Graphics g, JComponent c) 在进度条和跳动框上绘制少量特殊的高亮显示。
protected void | MetalToggleButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
protected void | MetalButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
protected void | MetalScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected void | MetalScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
void | MetalFileChooserUI.uninstallUI(JComponent c)
void | MetalInternalFrameUI.uninstallUI(JComponent c)
void | MetalToolTipUI.uninstallUI(JComponent c)
void | MetalTreeUI.uninstallUI(JComponent c)
void | MetalScrollPaneUI.uninstallUI(JComponent c)
void | MetalToolBarUI.uninstallUI(JComponent c)
void | MetalMenuBarUI.uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
void | MetalRootPaneUI.uninstallUI(JComponent c) 调用超实现来卸载所有状态。
void | MetalTabbedPaneUI.update(Graphics g, JComponent c)
void | MetalToolBarUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalMenuBarUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalToggleButtonUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalButtonUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。

javax.swing.plaf.multi 中 JComponent 的使用

参数类型为 JComponent 的 javax.swing.plaf.multi 中的方法
boolean | MultiButtonUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiColorChooserUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiComboBoxUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiDesktopIconUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiDesktopPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiFileChooserUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiInternalFrameUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiLabelUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiListUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiMenuBarUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiMenuItemUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiOptionPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiPanelUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiPopupMenuUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiProgressBarUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiRootPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiScrollBarUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiScrollPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiSeparatorUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiSliderUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiSpinnerUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiSplitPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiTabbedPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiTableHeaderUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiTableUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiTextUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiToolBarUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiToolTipUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiTreeUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiViewportUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | MultiButtonUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiColorChooserUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiComboBoxUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiDesktopIconUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiDesktopPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiFileChooserUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiInternalFrameUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiLabelUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiListUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiMenuBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiMenuItemUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiOptionPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiPanelUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiPopupMenuUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiProgressBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiRootPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiScrollBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiScrollPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSeparatorUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSliderUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSpinnerUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSplitPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTabbedPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTableHeaderUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTableUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTextUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiToolBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiToolTipUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTreeUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiViewportUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target) 创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。
Accessible | MultiButtonUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiColorChooserUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiComboBoxUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiDesktopIconUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiDesktopPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiFileChooserUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiInternalFrameUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiLabelUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiListUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiMenuBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiMenuItemUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiOptionPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiPanelUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiPopupMenuUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiProgressBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiRootPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiScrollBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiScrollPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSeparatorUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSliderUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSpinnerUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSplitPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTabbedPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTableHeaderUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTableUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTextUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiToolBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiToolTipUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTreeUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiViewportUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | MultiButtonUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiColorChooserUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiComboBoxUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiDesktopIconUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiDesktopPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiFileChooserUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiInternalFrameUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiLabelUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiListUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiMenuBarUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiMenuItemUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiOptionPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiPanelUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiPopupMenuUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiProgressBarUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiRootPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiScrollBarUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiScrollPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiSeparatorUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiSliderUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiSpinnerUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiSplitPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiTabbedPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiTableHeaderUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiTableUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiTextUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiToolBarUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiToolTipUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiTreeUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiViewportUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | MultiButtonUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiColorChooserUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiComboBoxUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiDesktopIconUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiDesktopPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiFileChooserUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法
Dimension | MultiInternalFrameUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiLabelUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiListUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiMenuBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiMenuItemUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiOptionPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiPanelUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiPopupMenuUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiProgressBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiRootPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiScrollBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiScrollPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSeparatorUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSliderUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSpinnerUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSplitPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTabbedPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTableHeaderUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTableUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTextUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiToolBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiToolTipUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTreeUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiViewportUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiButtonUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiColorChooserUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiComboBoxUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiDesktopIconUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiDesktopPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiFileChooserUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiInternalFrameUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiLabelUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiListUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiMenuBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiMenuItemUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiOptionPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiPanelUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiPopupMenuUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiProgressBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiRootPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiScrollBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiScrollPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSeparatorUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSliderUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSpinnerUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSplitPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTabbedPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTableHeaderUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTableUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTextUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiToolBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiToolTipUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTreeUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiViewportUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiButtonUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiColorChooserUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiComboBoxUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiDesktopIconUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiDesktopPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiFileChooserUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiInternalFrameUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiLabelUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiListUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiMenuBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiMenuItemUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiOptionPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiPanelUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiPopupMenuUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiProgressBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiRootPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiScrollBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiScrollPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSeparatorUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSliderUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSpinnerUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSplitPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTabbedPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTableHeaderUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTableUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTextUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiToolBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiToolTipUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTreeUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiViewportUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
void | MultiButtonUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiColorChooserUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiComboBoxUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiDesktopIconUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiDesktopPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiFileChooserUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiInternalFrameUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiLabelUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiListUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiMenuBarUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiMenuItemUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiOptionPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiPanelUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiPopupMenuUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiProgressBarUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiRootPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiScrollBarUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiScrollPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiSeparatorUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiSliderUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiSpinnerUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiSplitPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiTabbedPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiTableHeaderUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiTableUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiTextUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiToolBarUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiToolTipUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiTreeUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiViewportUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiButtonUI.paint(Graphics a, JComponent b) 在此对象处理的每个 UI 上调用 paint 方法。
void | MultiColorChooserUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法
void | MultiComboBoxUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiDesktopIconUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiDesktopPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiFileChooserUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiInternalFrameUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiLabelUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiListUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiMenuBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiMenuItemUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiOptionPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiPanelUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiPopupMenuUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiProgressBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiRootPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiScrollBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiScrollPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSeparatorUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSliderUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSpinnerUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSplitPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTabbedPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTableHeaderUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTableUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTextUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiToolBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiToolTipUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTreeUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiViewportUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiButtonUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiColorChooserUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiComboBoxUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiDesktopIconUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiDesktopPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiFileChooserUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiInternalFrameUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiLabelUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiListUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiMenuBarUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiMenuItemUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiOptionPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiPanelUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiPopupMenuUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiProgressBarUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiRootPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiScrollBarUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiScrollPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiSeparatorUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiSliderUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiSpinnerUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiSplitPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiTabbedPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiTableHeaderUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiTableUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiTextUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiToolBarUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiToolTipUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiTreeUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiViewportUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiButtonUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiColorChooserUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiComboBoxUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiDesktopIconUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiDesktopPaneUI.update(Graphics a, JComponent b) 在此对象处理的每个 UI 上调用 update 方法。
void | MultiFileChooserUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiInternalFrameUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiLabelUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiListUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiMenuBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiMenuItemUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiOptionPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiPanelUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiPopupMenuUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiProgressBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiRootPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiScrollBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiScrollPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSeparatorUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSliderUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSpinnerUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSplitPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTabbedPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTableHeaderUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTableUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTextUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiToolBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiToolTipUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTreeUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiViewportUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。

javax.swing.plaf.synth 中 JComponent 的使用

返回 JComponent 的 javax.swing.plaf.synth 中的方法
 JComponent SynthContext.getComponent()
返回包含 region 的承载组件。

参数类型为 JComponent 的 javax.swing.plaf.synth 中的方法
static ComponentUI | SynthLookAndFeel.createUI(JComponent c) 为传入的 JComponent 创建 Synth 外观 ComponentUI。
static Region | SynthLookAndFeel.getRegion(JComponent c) 返回 JComponent c 的 Region。
abstract SynthStyle | SynthStyleFactory.getStyle(JComponent c, Region id) 返回指定 Component 的样式。
static SynthStyle | SynthLookAndFeel.getStyle(JComponent c, Region region) 获取指定组件的指定 region 的 SynthStyle。

参数类型为 JComponent 的 javax.swing.plaf.synth 中的构造方法
SynthContext(JComponent component, Region region, SynthStyle style, int state)
创建一个具有指定值的 SynthContext。

javax.swing.table 中 JComponent 的使用

javax.swing.table 中 JComponent 的子类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。

javax.swing.text 中 JComponent 的使用

javax.swing.text 中 JComponent 的子类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

javax.swing.tree 中 JComponent 的使用

javax.swing.tree 中 JComponent 的子类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellRenderer 显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JComponent.AccessibleJComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComponent.AccessibleJComponent
的使用

使用 JComponent.AccessibleJComponent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JComponent.AccessibleJComponent 的使用

javax.swing 中 JComponent.AccessibleJComponent 的子类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。

javax.swing.table 中 JComponent.AccessibleJComponent 的使用

javax.swing.table 中 JComponent.AccessibleJComponent 的子类
protected  class JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。

javax.swing.text 中 JComponent.AccessibleJComponent 的使用

javax.swing.text 中 JComponent.AccessibleJComponent 的子类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
的使用

没有 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
的使用

没有 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JDesktopPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JDesktopPane
的使用

使用 JDesktopPane 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JDesktopPane 的使用

返回 JDesktopPane 的 javax.swing 中的方法
JDesktopPane | JInternalFrame.getDesktopPane() 在祖先层次结构中搜索 JDesktop 实例的便捷方法。
JDesktopPane | JInternalFrame.JDesktopIcon.getDesktopPane() 询问该图标所属的 Desktop 对象的便捷方法。
static JDesktopPane | JOptionPane.getDesktopPaneForComponent(Component parentComponent) 返回指定组件的桌面窗格。

javax.swing.plaf.basic 中 JDesktopPane 的使用

声明为 JDesktopPane 的 javax.swing.plaf.basic 中的字段
protected  JDesktopPane BasicDesktopPaneUI.desktop

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JDesktopPane.AccessibleJDesktopPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JDesktopPane.AccessibleJDesktopPane
的使用

没有 javax.swing.JDesktopPane.AccessibleJDesktopPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JDialog 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JDialog
的使用

使用 JDialog 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JDialog 的使用

返回 JDialog 的 javax.swing 中的方法
protected JDialog | JFileChooser.createDialog(Component parent) 创建并返回包含 this 的新 JDialog，在 parent 窗体中的 parent 上居中。
JDialog | JOptionPane.createDialog(Component parentComponent, String title) 创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。
static JDialog | JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener) 创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
JDialog | JOptionPane.createDialog(String title) 创建并返回一个新的带有指定标题的无父 JDialog。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JDialog.AccessibleJDialog 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JDialog.AccessibleJDialog
的使用

没有 javax.swing.JDialog.AccessibleJDialog 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JEditorPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JEditorPane
的使用

使用 JEditorPane 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JEditorPane 的使用

javax.swing 中 JEditorPane 的子类
 class JTextPane
可以用以图形方式表示的属性来标记的文本组件。

javax.swing.text 中 JEditorPane 的使用

返回 JEditorPane 的 javax.swing.text 中的方法
protected  JEditorPane StyledEditorKit.StyledTextAction.getEditor(ActionEvent e)
获得操作的目标编辑器。

参数类型为 JEditorPane 的 javax.swing.text 中的方法
void | StyledEditorKit.deinstall(JEditorPane c) 工具包从 JEditorPane 移除时调用。
void | EditorKit.deinstall(JEditorPane c) 从 JEditorPane 中移除工具包时调用。
protected StyledDocument | StyledEditorKit.StyledTextAction.getStyledDocument(JEditorPane e) 获取与编辑器窗格相关的文档。
protected StyledEditorKit | StyledEditorKit.StyledTextAction.getStyledEditorKit(JEditorPane e) 获取与编辑器窗格相关的编辑器工具包。
void | StyledEditorKit.install(JEditorPane c) 工具包安装到 JEditorPane 时调用。
void | EditorKit.install(JEditorPane c) 将工具包安装到 JEditorPane 中时调用。
protected void | StyledEditorKit.StyledTextAction.setCharacterAttributes(JEditorPane editor, AttributeSet attr, boolean replace) 对字符内容应用给定的属性。
protected void | StyledEditorKit.StyledTextAction.setParagraphAttributes(JEditorPane editor, AttributeSet attr, boolean replace) 对段落应用给定的属性。

javax.swing.text.html 中 JEditorPane 的使用

参数类型为 JEditorPane 的 javax.swing.text.html 中的方法
protected void | HTMLEditorKit.LinkController.activateLink(int pos, JEditorPane editor) 如果给定位置表示一个链接，则调用关联 JEditorPane 上的 linkActivated。
void | HTMLEditorKit.deinstall(JEditorPane c) 工具包从 JEditorPane 移除时调用。
protected HTMLDocument | HTMLEditorKit.HTMLTextAction.getHTMLDocument(JEditorPane e)
protected HTMLEditorKit | HTMLEditorKit.HTMLTextAction.getHTMLEditorKit(JEditorPane e)
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 当在边界上插入时调用。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
protected void | HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag) HTMLEditorKit.insertHTML 的一个覆盖。
void | HTMLEditorKit.install(JEditorPane c) 将工具包安装到 JEditorPane 中时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JEditorPane.AccessibleJEditorPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JEditorPane.AccessibleJEditorPane
的使用

使用 JEditorPane.AccessibleJEditorPane 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JEditorPane.AccessibleJEditorPane 的使用

javax.swing 中 JEditorPane.AccessibleJEditorPane 的子类
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML
的使用

没有 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport
的使用

没有 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
的使用

没有 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JFileChooser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFileChooser
的使用

使用 JFileChooser 的软件包
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf 中 JFileChooser 的使用

参数类型为 JFileChooser 的 javax.swing.plaf 中的方法
abstract void | FileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
abstract FileFilter | FileChooserUI.getAcceptAllFileFilter(JFileChooser fc)
abstract String | FileChooserUI.getApproveButtonText(JFileChooser fc)
abstract String | FileChooserUI.getDialogTitle(JFileChooser fc)
abstract FileView | FileChooserUI.getFileView(JFileChooser fc)
abstract void | FileChooserUI.rescanCurrentDirectory(JFileChooser fc)

javax.swing.plaf.basic 中 JFileChooser 的使用

返回 JFileChooser 的 javax.swing.plaf.basic 中的方法
 JFileChooser BasicFileChooserUI.getFileChooser()

参数类型为 JFileChooser 的 javax.swing.plaf.basic 中的方法
protected MouseListener | BasicFileChooserUI.createDoubleClickListener(JFileChooser fc, JList list)
ListSelectionListener | BasicFileChooserUI.createListSelectionListener(JFileChooser fc)
PropertyChangeListener | BasicFileChooserUI.createPropertyChangeListener(JFileChooser fc)
void | BasicFileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
FileFilter | BasicFileChooserUI.getAcceptAllFileFilter(JFileChooser fc) 返回默认接受所有文件过滤器
protected JButton | BasicFileChooserUI.getApproveButton(JFileChooser fc)
int | BasicFileChooserUI.getApproveButtonMnemonic(JFileChooser fc)
String | BasicFileChooserUI.getApproveButtonText(JFileChooser fc)
String | BasicFileChooserUI.getApproveButtonToolTipText(JFileChooser fc)
String | BasicFileChooserUI.getDialogTitle(JFileChooser fc) 返回此对话框的标题
FileView | BasicFileChooserUI.getFileView(JFileChooser fc)
void | BasicFileChooserUI.installComponents(JFileChooser fc)
protected void | BasicFileChooserUI.installDefaults(JFileChooser fc)
protected void | BasicFileChooserUI.installIcons(JFileChooser fc)
protected void | BasicFileChooserUI.installListeners(JFileChooser fc)
protected void | BasicFileChooserUI.installStrings(JFileChooser fc)
void | BasicFileChooserUI.rescanCurrentDirectory(JFileChooser fc)
void | BasicFileChooserUI.uninstallComponents(JFileChooser fc)
protected void | BasicFileChooserUI.uninstallDefaults(JFileChooser fc)
protected void | BasicFileChooserUI.uninstallIcons(JFileChooser fc)
protected void | BasicFileChooserUI.uninstallListeners(JFileChooser fc)
protected void | BasicFileChooserUI.uninstallStrings(JFileChooser fc)

参数类型为 JFileChooser 的 javax.swing.plaf.basic 中的构造方法
BasicDirectoryModel(JFileChooser filechooser)
BasicFileChooserUI(JFileChooser b)

javax.swing.plaf.metal 中 JFileChooser 的使用

参数类型为 JFileChooser 的 javax.swing.plaf.metal 中的方法
protected JPanel | MetalFileChooserUI.createDetailsView(JFileChooser fc)
protected MetalFileChooserUI.DirectoryComboBoxModel | MetalFileChooserUI.createDirectoryComboBoxModel(JFileChooser fc)
protected javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxRenderer | MetalFileChooserUI.createDirectoryComboBoxRenderer(JFileChooser fc)
protected JPanel | MetalFileChooserUI.createList(JFileChooser fc)
ListSelectionListener | MetalFileChooserUI.createListSelectionListener(JFileChooser fc) 创建一个用于文件和目录列表的选择侦听器。
PropertyChangeListener | MetalFileChooserUI.createPropertyChangeListener(JFileChooser fc)
void | MetalFileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
protected JButton | MetalFileChooserUI.getApproveButton(JFileChooser fc)
void | MetalFileChooserUI.installComponents(JFileChooser fc)
protected void | MetalFileChooserUI.installListeners(JFileChooser fc)
protected void | MetalFileChooserUI.installStrings(JFileChooser fc)
void | MetalFileChooserUI.rescanCurrentDirectory(JFileChooser fc)
void | MetalFileChooserUI.uninstallComponents(JFileChooser fc)

参数类型为 JFileChooser 的 javax.swing.plaf.metal 中的构造方法
MetalFileChooserUI(JFileChooser filechooser)

javax.swing.plaf.multi 中 JFileChooser 的使用

参数类型为 JFileChooser 的 javax.swing.plaf.multi 中的方法
void | MultiFileChooserUI.ensureFileIsVisible(JFileChooser a, File b) 在由此对象处理的每个 UI 上调用 ensureFileIsVisible 方法。
FileFilter | MultiFileChooserUI.getAcceptAllFileFilter(JFileChooser a) 在由此对象处理的每个 UI 上调用 getAcceptAllFileFilter 方法。
String | MultiFileChooserUI.getApproveButtonText(JFileChooser a) 在由此对象处理的每个 UI 上调用 getApproveButtonText 方法。
String | MultiFileChooserUI.getDialogTitle(JFileChooser a) 在由此对象处理的每个 UI 上调用 getDialogTitle 方法。
FileView | MultiFileChooserUI.getFileView(JFileChooser a) 在由此对象处理的每个 UI 上调用 getFileView 方法。
void | MultiFileChooserUI.rescanCurrentDirectory(JFileChooser a) 在由此对象处理的每个 UI 上调用 rescanCurrentDirectory 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JFileChooser.AccessibleJFileChooser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFileChooser.AccessibleJFileChooser
的使用

没有 javax.swing.JFileChooser.AccessibleJFileChooser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JFormattedTextField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFormattedTextField
的使用

使用 JFormattedTextField 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JFormattedTextField 的使用

返回 JFormattedTextField 的 javax.swing 中的方法
protected JFormattedTextField | JFormattedTextField.AbstractFormatter.getFormattedTextField() 返回 AbstractFormatter 所安装到的当前 JFormattedTextField。
JFormattedTextField | JSpinner.DefaultEditor.getTextField() 返回此编辑器的子 JFormattedTextField。

参数类型为 JFormattedTextField 的 javax.swing 中的方法
abstract JFormattedTextField.AbstractFormatter | JFormattedTextField.AbstractFormatterFactory.getFormatter(JFormattedTextField tf) 返回一个 AbstractFormatter，它对传入的 JFormattedTextField 进行格式化。
void | JFormattedTextField.AbstractFormatter.install(JFormattedTextField ftf) 将 AbstractFormatter 安装到特定的 JFormattedTextField。

javax.swing.text 中 JFormattedTextField 的使用

参数类型为 JFormattedTextField 的 javax.swing.text 中的方法
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getFormatter(JFormattedTextField source) 根据 JFormattedTextField 的状态返回默认的 formatter、显示 formatter、编辑器 formatter 或 null formatter。
void | DefaultFormatter.install(JFormattedTextField ftf) 将 DefaultFormatter 安装到特定的 JFormattedTextField。
void | InternationalFormatter.install(JFormattedTextField ftf) 将 DefaultFormatter 安装到特定的 JFormattedTextField 上。
void | MaskFormatter.install(JFormattedTextField ftf) 将 DefaultFormatter 安装在特定的 JFormattedTextField 上。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JFormattedTextField.AbstractFormatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFormattedTextField.AbstractFormatter
的使用

使用 JFormattedTextField.AbstractFormatter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JFormattedTextField.AbstractFormatter 的使用

返回 JFormattedTextField.AbstractFormatter 的 javax.swing 中的方法
JFormattedTextField.AbstractFormatter | JFormattedTextField.getFormatter() 返回用于格式化和分析当前值的 AbstractFormatter。
abstract JFormattedTextField.AbstractFormatter | JFormattedTextField.AbstractFormatterFactory.getFormatter(JFormattedTextField tf) 返回一个 AbstractFormatter，它对传入的 JFormattedTextField 进行格式化。

参数类型为 JFormattedTextField.AbstractFormatter 的 javax.swing 中的方法
protected  void JFormattedTextField.setFormatter(JFormattedTextField.AbstractFormatter format)
设置当前的 AbstractFormatter。

参数类型为 JFormattedTextField.AbstractFormatter 的 javax.swing 中的构造方法
JFormattedTextField(JFormattedTextField.AbstractFormatter formatter)
创建一个具有指定 AbstractFormatter 的 JFormattedTextField。

javax.swing.text 中 JFormattedTextField.AbstractFormatter 的使用

javax.swing.text 中 JFormattedTextField.AbstractFormatter 的子类
class | DateFormatter DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
class | DefaultFormatter DefaultFormatter 格式化任意对象。
class | InternationalFormatter InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
class | MaskFormatter MaskFormatter 用于格式化和编辑字符串。
class | NumberFormatter 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。

返回 JFormattedTextField.AbstractFormatter 的 javax.swing.text 中的方法
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getDefaultFormatter() 返回供最后选择使用的 JFormattedTextField.AbstractFormatter，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getDisplayFormatter() 返回在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getEditFormatter() 返回在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getFormatter(JFormattedTextField source) 根据 JFormattedTextField 的状态返回默认的 formatter、显示 formatter、编辑器 formatter 或 null formatter。
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getNullFormatter() 返回值为 null 时使用的 formatter。

参数类型为 JFormattedTextField.AbstractFormatter 的 javax.swing.text 中的方法
void | DefaultFormatterFactory.setDefaultFormatter(JFormattedTextField.AbstractFormatter atf) 设置 JFormattedTextField.AbstractFormatter 供最后选择使用，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。
void | DefaultFormatterFactory.setDisplayFormatter(JFormattedTextField.AbstractFormatter atf) 设置在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
void | DefaultFormatterFactory.setEditFormatter(JFormattedTextField.AbstractFormatter atf) 设置在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
void | DefaultFormatterFactory.setNullFormatter(JFormattedTextField.AbstractFormatter atf) 设置在 JFormattedTextField 值为 null 时使用的 formatter。

参数类型为 JFormattedTextField.AbstractFormatter 的 javax.swing.text 中的构造方法
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat, JFormattedTextField.AbstractFormatter editFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat, JFormattedTextField.AbstractFormatter editFormat, JFormattedTextField.AbstractFormatter nullFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JFormattedTextField.AbstractFormatterFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFormattedTextField.AbstractFormatterFactory
的使用

使用 JFormattedTextField.AbstractFormatterFactory 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JFormattedTextField.AbstractFormatterFactory 的使用

返回 JFormattedTextField.AbstractFormatterFactory 的 javax.swing 中的方法
 JFormattedTextField.AbstractFormatterFactory JFormattedTextField.getFormatterFactory()
返回当前的 AbstractFormatterFactory。

参数类型为 JFormattedTextField.AbstractFormatterFactory 的 javax.swing 中的方法
 void JFormattedTextField.setFormatterFactory(JFormattedTextField.AbstractFormatterFactory tf)
设置 AbstractFormatterFactory。

参数类型为 JFormattedTextField.AbstractFormatterFactory 的 javax.swing 中的构造方法
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory)
创建一个具有指定 AbstractFormatterFactory 的 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory, Object currentValue)
创建一个具有指定 AbstractFormatterFactory 和初始值的 JFormattedTextField。

javax.swing.text 中 JFormattedTextField.AbstractFormatterFactory 的使用

javax.swing.text 中 JFormattedTextField.AbstractFormatterFactory 的子类
 class DefaultFormatterFactory
JFormattedTextField.AbstractFormatterFactory 的一个实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JFrame 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFrame
的使用

使用 JFrame 的软件包
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt.im.spi 中 JFrame 的使用

返回 JFrame 的 java.awt.im.spi 中的方法
 JFrame InputMethodContext.createInputMethodJFrame(String title, boolean attachToInputContext)
创建输入方法使用的顶层 Swing JFrame。

javax.swing.plaf.basic 中 JFrame 的使用

返回 JFrame 的 javax.swing.plaf.basic 中的方法
protected  JFrame BasicToolBarUI.createFloatingFrame(JToolBar toolbar)
不再使用，使用 BasicToolBarUI.createFloatingWindow(JToolBar)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JFrame.AccessibleJFrame 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFrame.AccessibleJFrame
的使用

没有 javax.swing.JFrame.AccessibleJFrame 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JInternalFrame 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JInternalFrame
的使用

使用 JInternalFrame 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JInternalFrame 的使用

返回 JInternalFrame 的 javax.swing 中的方法
JInternalFrame | JOptionPane.createInternalFrame(Component parentComponent, String title) 创建并返回 JInternalFrame 的实例。
JInternalFrame[] | JDesktopPane.getAllFrames() 返回桌面中当前显示的所有 JInternalFrames。
JInternalFrame[] | JDesktopPane.getAllFramesInLayer(int layer) 返回桌面指定层中当前所显示的所有 JInternalFrames。
JInternalFrame | JInternalFrame.JDesktopIcon.getInternalFrame() 返回与此 DesktopIcon 关联的 JInternalFrame。
JInternalFrame | JDesktopPane.getSelectedFrame() 返回此 JDesktopPane 中当前活动的 JInternalFrame，如果当前没有活动的 JInternalFrame，则返回 null。
JInternalFrame | JDesktopPane.selectFrame(boolean forward) 选择此桌面窗格中的下一个 JInternalFrame。

参数类型为 JInternalFrame 的 javax.swing 中的方法
 void DefaultDesktopManager.activateFrame(JInternalFrame f)
此方法将激活 f，将它移动到前台。
 void DesktopManager.activateFrame(JInternalFrame f)
通常指示此窗体拥有焦点。
 void DefaultDesktopManager.closeFrame(JInternalFrame f)
从父窗体中移除窗体，如有必要，还要移除 desktopIcon。
 void DesktopManager.closeFrame(JInternalFrame f)
通常，此调用应该从其父窗体中移除窗体。
 void DefaultDesktopManager.deactivateFrame(JInternalFrame f)
 void DesktopManager.deactivateFrame(JInternalFrame f)
通常指示此窗体失去焦点。
 void DefaultDesktopManager.deiconifyFrame(JInternalFrame f)
从父窗体中移除 desktopIcon，并将其窗体添加到父窗体中。
 void DesktopManager.deiconifyFrame(JInternalFrame f)
通常移除现有的任何图标表示形式，并将窗体恢复到其原始大小和位置。
protected  Rectangle DefaultDesktopManager.getBoundsForIconOf(JInternalFrame f)
iconifyFrame() 代码调用此方法来确定 desktopIcon 的适当边界。
 Component InternalFrameFocusTraversalPolicy.getInitialComponent(JInternalFrame frame)
返回第一次选择 JInternalFrame 时应该接收焦点的 Component。
protected  Rectangle DefaultDesktopManager.getPreviousBounds(JInternalFrame f)
在将组件最大化之前，获得该组件的普通边界。
 void DefaultDesktopManager.iconifyFrame(JInternalFrame f)
从父窗体中移除窗体，并将其 desktopIcon 添加到父窗体中。
 void DesktopManager.iconifyFrame(JInternalFrame f)
通常从父窗体中移除此窗体，并添加一个图标表示形式。
 void DefaultDesktopManager.maximizeFrame(JInternalFrame f)
重新调整窗体的大小，使其满足其父窗体的限制。
 void DesktopManager.maximizeFrame(JInternalFrame f)
通常，应该重新调整窗体的大小，使其满足其父窗体的限制。
 void DefaultDesktopManager.minimizeFrame(JInternalFrame f)
使窗体恢复回调用 maximizeFrame 之前的大小和位置。
 void DesktopManager.minimizeFrame(JInternalFrame f)
通常，这指示应该将窗体恢复到调用 maximizeFrame() 前的大小和位置。
 void DefaultDesktopManager.openFrame(JInternalFrame f)
通常不调用此方法。
 void DesktopManager.openFrame(JInternalFrame f)
如有可能，在适当的位置显示此窗体。
protected  void DefaultDesktopManager.removeIconFor(JInternalFrame f)
在需要时移除 f 的 desktopIcon 的便捷方法。
 void JInternalFrame.JDesktopIcon.setInternalFrame(JInternalFrame f)
设置与此 DesktopIcon 关联的 JInternalFrame。
protected  void DefaultDesktopManager.setPreviousBounds(JInternalFrame f, Rectangle r)
在进行 maximize 调用之前存储组件的边界。
 void JDesktopPane.setSelectedFrame(JInternalFrame f)
设置此 JDesktopPane 中当前活动的 JInternalFrame。
protected  void DefaultDesktopManager.setWasIcon(JInternalFrame f, Boolean value)
设定组件已被图标化并且 desktopIcon 的边界是有效的。
protected  boolean DefaultDesktopManager.wasIcon(JInternalFrame f)
如果组件已被图标化并且 desktopIcon 的边界是有效的，则返回 true，否则返回 false。

参数类型为 JInternalFrame 的 javax.swing 中的构造方法
JInternalFrame.JDesktopIcon(JInternalFrame f)
为内部 frame 创建一个图标。

javax.swing.event 中 JInternalFrame 的使用

返回 JInternalFrame 的 javax.swing.event 中的方法
 JInternalFrame InternalFrameEvent.getInternalFrame()
返回事件的发起者。

参数类型为 JInternalFrame 的 javax.swing.event 中的构造方法
InternalFrameEvent(JInternalFrame source, int id)
构造一个 InternalFrameEvent 对象。

javax.swing.plaf.basic 中 JInternalFrame 的使用

声明为 JInternalFrame 的 javax.swing.plaf.basic 中的字段
protected JInternalFrame | BasicDesktopIconUI.frame
protected JInternalFrame | BasicInternalFrameTitlePane.frame
protected JInternalFrame | BasicInternalFrameUI.frame

参数类型为 JInternalFrame 的 javax.swing.plaf.basic 中的方法
protected void | BasicInternalFrameUI.activateFrame(JInternalFrame f) 窗体变为被选择状态时调用此方法。
protected void | BasicInternalFrameUI.closeFrame(JInternalFrame f) 当用户要关闭窗体时调用此方法。
protected MouseInputAdapter | BasicInternalFrameUI.createBorderListener(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createEastPane(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createNorthPane(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createSouthPane(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createWestPane(JInternalFrame w)
protected void | BasicInternalFrameUI.deactivateFrame(JInternalFrame f) 窗体不再是被选择状态时调用此方法。
protected void | BasicInternalFrameUI.deiconifyFrame(JInternalFrame f) 当用户要取消图标化窗体时调用此方法。
protected void | BasicInternalFrameUI.iconifyFrame(JInternalFrame f) 当用户要图标化窗体时调用此方法。
protected void | BasicInternalFrameUI.maximizeFrame(JInternalFrame f) 当用户要最大化窗体时调用此方法。
protected void | BasicInternalFrameUI.minimizeFrame(JInternalFrame f) 当用户要最小化窗体时调用此方法。
protected void | BasicInternalFrameTitlePane.postClosingEvent(JInternalFrame frame) 将类似于 WINDOW_CLOSING 的事件发送到窗体，以便将其当作规则的 Frame 来对待。

参数类型为 JInternalFrame 的 javax.swing.plaf.basic 中的构造方法
BasicInternalFrameTitlePane(JInternalFrame f)
BasicInternalFrameUI(JInternalFrame b)

javax.swing.plaf.metal 中 JInternalFrame 的使用

参数类型为 JInternalFrame 的 javax.swing.plaf.metal 中的方法
protected MouseInputAdapter | MetalInternalFrameUI.createBorderListener(JInternalFrame w) 返回将在 TitlePane 上安装的 MouseInputAdapter。
protected JComponent | MetalInternalFrameUI.createNorthPane(JInternalFrame w)

参数类型为 JInternalFrame 的 javax.swing.plaf.metal 中的构造方法
MetalInternalFrameTitlePane(JInternalFrame f)
MetalInternalFrameUI(JInternalFrame b)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JInternalFrame.AccessibleJInternalFrame 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JInternalFrame.AccessibleJInternalFrame
的使用

没有 javax.swing.JInternalFrame.AccessibleJInternalFrame 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JInternalFrame.JDesktopIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JInternalFrame.JDesktopIcon
的使用

使用 JInternalFrame.JDesktopIcon 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JInternalFrame.JDesktopIcon 的使用

声明为 JInternalFrame.JDesktopIcon 的 javax.swing 中的字段
protected  JInternalFrame.JDesktopIcon JInternalFrame.desktopIcon
此内部窗体图标化时所显示的图标。

返回 JInternalFrame.JDesktopIcon 的 javax.swing 中的方法
 JInternalFrame.JDesktopIcon JInternalFrame.getDesktopIcon()
返回图标化此 JInternalFrame 时使用的 JDesktopIcon。

参数类型为 JInternalFrame.JDesktopIcon 的 javax.swing 中的方法
 void JInternalFrame.setDesktopIcon(JInternalFrame.JDesktopIcon d)
设置与此 JInternalFrame 关联的 JDesktopIcon。

javax.swing.plaf.basic 中 JInternalFrame.JDesktopIcon 的使用

声明为 JInternalFrame.JDesktopIcon 的 javax.swing.plaf.basic 中的字段
protected  JInternalFrame.JDesktopIcon BasicDesktopIconUI.desktopIcon

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
的使用

没有 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JLabel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JLabel
的使用

使用 JLabel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 JLabel 的使用

javax.swing 中 JLabel 的子类
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。

javax.swing.plaf.basic 中 JLabel 的使用

javax.swing.plaf.basic 中 JLabel 的子类
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。

参数类型为 JLabel 的 javax.swing.plaf.basic 中的方法
protected  void BasicLabelUI.installComponents(JLabel c)
protected  void BasicLabelUI.installDefaults(JLabel c)
protected  void BasicLabelUI.installKeyboardActions(JLabel l)
protected  void BasicLabelUI.installListeners(JLabel c)
protected  String BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。
protected  void BasicLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用 background.lighter() 将 clippedText 绘制在 textX、textY 处，然后利用 background.darker() 向右下移动一个像素。
protected  void BasicLabelUI.paintEnabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用标签的前景色将 clippedText 绘制在 textX、textY 处。
protected  void BasicLabelUI.uninstallComponents(JLabel c)
protected  void BasicLabelUI.uninstallDefaults(JLabel c)
protected  void BasicLabelUI.uninstallKeyboardActions(JLabel c)
protected  void BasicLabelUI.uninstallListeners(JLabel c)

javax.swing.plaf.metal 中 JLabel 的使用

javax.swing.plaf.metal 中 JLabel 的子类
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。

参数类型为 JLabel 的 javax.swing.plaf.metal 中的方法
protected  void MetalLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
只绘制文本灰度 (Label.disabledForeground)，而不是使用标签前景色。

javax.swing.table 中 JLabel 的使用

javax.swing.table 中 JLabel 的子类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。

javax.swing.tree 中 JLabel 的使用

javax.swing.tree 中 JLabel 的子类
 class DefaultTreeCellRenderer
显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JLabel.AccessibleJLabel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JLabel.AccessibleJLabel
的使用

没有 javax.swing.JLabel.AccessibleJLabel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JLayeredPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JLayeredPane
的使用

使用 JLayeredPane 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JLayeredPane 的使用

javax.swing 中 JLayeredPane 的子类
 class JDesktopPane
用于创建多文档界面或虚拟桌面的容器。

声明为 JLayeredPane 的 javax.swing 中的字段
protected  JLayeredPane JRootPane.layeredPane
管理菜单栏和内容窗格的分层窗格。

返回 JLayeredPane 的 javax.swing 中的方法
protected JLayeredPane | JRootPane.createLayeredPane() 由构造方法调用以便创建默认的 layeredPane。
JLayeredPane | JApplet.getLayeredPane() 返回此 applet 的 layeredPane 对象。
JLayeredPane | JWindow.getLayeredPane() 返回此窗口的 layeredPane 对象。
JLayeredPane | JDialog.getLayeredPane() 返回此对话框的 layeredPane 对象。
JLayeredPane | JInternalFrame.getLayeredPane() 返回此内部窗体的分层窗格。
JLayeredPane | JRootPane.getLayeredPane() 获取供根窗格使用的分层窗格。
JLayeredPane | JFrame.getLayeredPane() 返回此窗体的 layeredPane 对象。
JLayeredPane | RootPaneContainer.getLayeredPane() 返回 layeredPane。
static JLayeredPane | JLayeredPane.getLayeredPaneAbove(Component c) 一个便捷方法，它返回包含指定组件的第一个 JLayeredPane。

参数类型为 JLayeredPane 的 javax.swing 中的方法
void | JApplet.setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | JWindow.setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | JDialog.setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | JInternalFrame.setLayeredPane(JLayeredPane layered) 设置此 JInternalFrame 的 layeredPane 属性。
void | JRootPane.setLayeredPane(JLayeredPane layered) 设置供根窗格使用的分层窗格。
void | JFrame.setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | RootPaneContainer.setLayeredPane(JLayeredPane layeredPane) 管理 contentPane 的 Container，在某些情况下为菜单栏。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JLayeredPane.AccessibleJLayeredPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JLayeredPane.AccessibleJLayeredPane
的使用

没有 javax.swing.JLayeredPane.AccessibleJLayeredPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JList
的使用

使用 JList 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 JList 的使用

参数类型为 JList 的 javax.swing 中的方法
Component | DefaultListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
Component | ListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus) 返回已配置用于显示指定值的组件。

参数类型为 JList 的 javax.swing 中的构造方法
JList.AccessibleJList.AccessibleJListChild(JList parent, int indexInParent)

javax.swing.plaf 中 JList 的使用

参数类型为 JList 的 javax.swing.plaf 中的方法
abstract Rectangle | ListUI.getCellBounds(JList list, int index1, int index2) 返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
abstract Point | ListUI.indexToLocation(JList list, int index) 返回列表坐标系统中给定 JList 中指定项的原点。
abstract int | ListUI.locationToIndex(JList list, Point location) 返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。

javax.swing.plaf.basic 中 JList 的使用

声明为 JList 的 javax.swing.plaf.basic 中的字段
protected JList | BasicListUI.list
protected JList | BasicComboPopup.list 此受保护字段是特定于实现的。
protected JList | BasicComboBoxUI.listBox

返回 JList 的 javax.swing.plaf.basic 中的方法
protected  JList BasicComboPopup.createList()
创建在显示组合框模型项的弹出控件中使用的 JList。
 JList BasicComboPopup.getList()
ComboPopup.getList() 的实现。
 JList ComboPopup.getList()
返回要用于在组合框中绘制项的列表。

参数类型为 JList 的 javax.swing.plaf.basic 中的方法
protected MouseListener | BasicFileChooserUI.createDoubleClickListener(JFileChooser fc, JList list)
Rectangle | BasicListUI.getCellBounds(JList list, int index1, int index2) 返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
Component | BasicComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
Point | BasicListUI.indexToLocation(JList list, int index) 返回列表坐标系统中给定 JList 中指定项的原点。
int | BasicListUI.locationToIndex(JList list, Point location) 返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。

参数类型为 JList 的 javax.swing.plaf.basic 中的构造方法
BasicFileChooserUI.DoubleClickListener(JList list)

javax.swing.plaf.metal 中 JList 的使用

声明为 JList 的 javax.swing.plaf.metal 中的字段
protected  JList MetalComboBoxButton.listBox

参数类型为 JList 的 javax.swing.plaf.metal 中的方法
 Component MetalFileChooserUI.FilterComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)

参数类型为 JList 的 javax.swing.plaf.metal 中的构造方法
MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)
MetalFileChooserUI.SingleClickListener(JList list)

javax.swing.plaf.multi 中 JList 的使用

参数类型为 JList 的 javax.swing.plaf.multi 中的方法
Rectangle | MultiListUI.getCellBounds(JList a, int b, int c) 在由此对象处理的每个 UI 上调用 getCellBounds 方法。
Point | MultiListUI.indexToLocation(JList a, int b) 在由此对象处理的每个 UI 上调用 indexToLocation 方法。
int | MultiListUI.locationToIndex(JList a, Point b) 在由此对象处理的每个 UI 上调用 locationToIndex 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JList.AccessibleJList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JList.AccessibleJList
的使用

没有 javax.swing.JList.AccessibleJList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JList.AccessibleJList.AccessibleJListChild 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JList.AccessibleJList.AccessibleJListChild
的使用

没有 javax.swing.JList.AccessibleJList.AccessibleJListChild 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JList.DropLocation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JList.DropLocation
的使用

使用 JList.DropLocation 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JList.DropLocation 的使用

返回 JList.DropLocation 的 javax.swing 中的方法
 JList.DropLocation JList.getDropLocation()
返回在该组件上执行 DnD 操作期间此组件应该视觉上指示为放置位置的位置；如果当前没有任何显示的位置，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JMenu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenu
的使用

使用 JMenu 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JMenu 的使用

返回 JMenu 的 javax.swing 中的方法
JMenu | JMenuBar.add(JMenu c) 将指定的菜单追加到菜单栏的末尾。
JMenu | JMenuBar.getHelpMenu() 获取菜单栏的帮助菜单。
JMenu | JMenuBar.getMenu(int index) 返回菜单栏中指定位置的菜单。

参数类型为 JMenu 的 javax.swing 中的方法
JMenu | JMenuBar.add(JMenu c) 将指定的菜单追加到菜单栏的末尾。
void | JMenuBar.setHelpMenu(JMenu menu) 设置用户选择菜单栏中的“帮助”选项时显示的帮助菜单。

javax.swing.plaf.basic 中 JMenu 的使用

声明为 JMenu 的 javax.swing.plaf.basic 中的字段
JMenu | BasicMenuUI.ChangeHandler.menu
protected JMenu | BasicInternalFrameTitlePane.windowMenu

返回 JMenu 的 javax.swing.plaf.basic 中的方法
protected  JMenu BasicInternalFrameTitlePane.createSystemMenu()

参数类型为 JMenu 的 javax.swing.plaf.basic 中的方法
protected void | BasicInternalFrameTitlePane.addSystemMenuItems(JMenu systemMenu)
protected void | BasicMenuUI.setupPostTimer(JMenu menu)

参数类型为 JMenu 的 javax.swing.plaf.basic 中的构造方法
BasicMenuUI.ChangeHandler(JMenu m, BasicMenuUI ui)

javax.swing.plaf.metal 中 JMenu 的使用

参数类型为 JMenu 的 javax.swing.plaf.metal 中的方法
protected  void MetalInternalFrameTitlePane.addSystemMenuItems(JMenu systemMenu)
重写父级的方法，使其不执行任何操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JMenu.AccessibleJMenu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenu.AccessibleJMenu
的使用

没有 javax.swing.JMenu.AccessibleJMenu 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JMenu.WinListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenu.WinListener
的使用

使用 JMenu.WinListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JMenu.WinListener 的使用

声明为 JMenu.WinListener 的 javax.swing 中的字段
protected  JMenu.WinListener JMenu.popupListener
弹出菜单的窗口关闭侦听器。

返回 JMenu.WinListener 的 javax.swing 中的方法
protected  JMenu.WinListener JMenu.createWinListener(JPopupMenu p)
创建弹出菜单的窗口关闭侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JMenuBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenuBar
的使用

使用 JMenuBar 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JMenuBar 的使用

声明为 JMenuBar 的 javax.swing 中的字段
protected  JMenuBar JRootPane.menuBar
菜单栏。

返回 JMenuBar 的 javax.swing 中的方法
 JMenuBar JApplet.getJMenuBar()
返回此 applet 上的菜单栏设置。
 JMenuBar JDialog.getJMenuBar()
返回此对话框上设置的菜单栏。
 JMenuBar JInternalFrame.getJMenuBar()
返回此 JInternalFrame 的当前 JMenuBar；如果尚未设置菜单栏，则返回 null。
 JMenuBar JRootPane.getJMenuBar()
返回窗格层的菜单栏。
 JMenuBar JFrame.getJMenuBar()
返回此窗体上设置的菜单栏。
 JMenuBar JInternalFrame.getMenuBar()
已过时。 从 Swing version 1.0.3 开始，由 getJMenuBar() 取代。
 JMenuBar JRootPane.getMenuBar()
已过时。 从 Swing 版本 1.0.3 开始，由 getJMenuBar() 取代。

参数类型为 JMenuBar 的 javax.swing 中的方法
void | JApplet.setJMenuBar(JMenuBar menuBar) 设置此 applet 的菜单栏。
void | JDialog.setJMenuBar(JMenuBar menu) 设置此对话框的菜单栏。
void | JInternalFrame.setJMenuBar(JMenuBar m) 设置此 JInternalFrame 的 menuBar 属性。
void | JRootPane.setJMenuBar(JMenuBar menu) 添加或更改在分层窗格中使用的菜单栏。
void | JFrame.setJMenuBar(JMenuBar menubar) 设置此窗体的菜单栏。
void | JInternalFrame.setMenuBar(JMenuBar m) 已过时。 从 Swing version 1.0.3 开始，由 setJMenuBar(JMenuBar m) 取代。
void | JRootPane.setMenuBar(JMenuBar menu) 已过时。 从 Swing 版本 1.0.3 开始，由 setJMenuBar(JMenuBar menu) 取代。

javax.swing.plaf.basic 中 JMenuBar 的使用

javax.swing.plaf.basic 中 JMenuBar 的子类
 class BasicInternalFrameTitlePane.SystemMenuBar
此类应视为“受保护”内部类。

声明为 JMenuBar 的 javax.swing.plaf.basic 中的字段
protected JMenuBar | BasicInternalFrameTitlePane.menuBar
protected JMenuBar | BasicMenuBarUI.menuBar

返回 JMenuBar 的 javax.swing.plaf.basic 中的方法
protected  JMenuBar BasicInternalFrameTitlePane.createSystemMenuBar()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JMenuBar.AccessibleJMenuBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenuBar.AccessibleJMenuBar
的使用

没有 javax.swing.JMenuBar.AccessibleJMenuBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenuItem
的使用

使用 JMenuItem 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JMenuItem 的使用

javax.swing 中 JMenuItem 的子类
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。

返回 JMenuItem 的 javax.swing 中的方法
JMenuItem | JPopupMenu.add(Action a) 将指派指定 Action 对象的新菜单项添加到菜单的末尾。
JMenuItem | JMenu.add(Action a) 创建连接到指定 Action 对象的新菜单项，并将其追加到此菜单的末尾。
JMenuItem | JPopupMenu.add(JMenuItem menuItem) 将指定菜单项添加到此菜单的末尾。
JMenuItem | JMenu.add(JMenuItem menuItem) 将某个菜单项追加到此菜单的末尾。
JMenuItem | JPopupMenu.add(String s) 创建具有指定文本的菜单项，并将其添加到此菜单的末尾。
JMenuItem | JMenu.add(String s) 创建具有指定文本的新菜单项，并将其追加到此菜单的末尾。
protected JMenuItem | JPopupMenu.createActionComponent(Action a) 该工厂方法为添加到 JPopupMenu 的 Action 创建对应的 JMenuItem。
protected JMenuItem | JMenu.createActionComponent(Action a) 该工厂方法创建添加到 JMenu 的 Action 的 JMenuItem。
JMenuItem | JMenu.getItem(int pos) 返回指定位置的 JMenuItem。
JMenuItem | JMenu.insert(Action a, int pos) 在给定位置插入连接到指定 Action 对象的新菜单项。
JMenuItem | JMenu.insert(JMenuItem mi, int pos) 在给定位置插入指定的 JMenuitem。

参数类型为 JMenuItem 的 javax.swing 中的方法
JMenuItem | JPopupMenu.add(JMenuItem menuItem) 将指定菜单项添加到此菜单的末尾。
JMenuItem | JMenu.add(JMenuItem menuItem) 将某个菜单项追加到此菜单的末尾。
protected PropertyChangeListener | JPopupMenu.createActionChangeListener(JMenuItem b) 返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
protected PropertyChangeListener | JMenu.createActionChangeListener(JMenuItem b) 返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
JMenuItem | JMenu.insert(JMenuItem mi, int pos) 在给定位置插入指定的 JMenuitem。
void | JMenu.remove(JMenuItem item) 从此菜单移除指定的菜单项。

javax.swing.plaf.basic 中 JMenuItem 的使用

声明为 JMenuItem 的 javax.swing.plaf.basic 中的字段
protected  JMenuItem BasicMenuItemUI.menuItem

参数类型为 JMenuItem 的 javax.swing.plaf.basic 中的方法
protected void | BasicMenuItemUI.installComponents(JMenuItem menuItem)
protected void | BasicMenuItemUI.paintBackground(Graphics g, JMenuItem menuItem, Color bgColor) 绘制菜单项的背景。
protected void | BasicMenuItemUI.paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text) 呈现当前菜单项的文本。
void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
protected void | BasicMenuItemUI.uninstallComponents(JMenuItem menuItem)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JMenuItem.AccessibleJMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenuItem.AccessibleJMenuItem
的使用

使用 JMenuItem.AccessibleJMenuItem 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JMenuItem.AccessibleJMenuItem 的使用

javax.swing 中 JMenuItem.AccessibleJMenuItem 的子类
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JOptionPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JOptionPane
的使用

使用 JOptionPane 的软件包
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf 中 JOptionPane 的使用

参数类型为 JOptionPane 的 javax.swing.plaf 中的方法
abstract boolean | OptionPaneUI.containsCustomComponents(JOptionPane op) 如果用户已经为选项或消息提供 Component 实例，则返回 true。
abstract void | OptionPaneUI.selectInitialValue(JOptionPane op) 请求表示默认值的组件拥有焦点。

javax.swing.plaf.basic 中 JOptionPane 的使用

声明为 JOptionPane 的 javax.swing.plaf.basic 中的字段
protected  JOptionPane BasicOptionPaneUI.optionPane
接收者为其提供外观的 JOptionPane。

参数类型为 JOptionPane 的 javax.swing.plaf.basic 中的方法
boolean | BasicOptionPaneUI.containsCustomComponents(JOptionPane op) 如果在上一次对 validateComponent 的调用中消息或按钮包含 Component 的子类，则返回 true。
void | BasicOptionPaneUI.selectInitialValue(JOptionPane op) 如果 inputComponent 为非 null，则请求焦点位于其上；否则请求焦点位于默认值上

javax.swing.plaf.multi 中 JOptionPane 的使用

参数类型为 JOptionPane 的 javax.swing.plaf.multi 中的方法
boolean | MultiOptionPaneUI.containsCustomComponents(JOptionPane a) 在由此对象处理的每个 UI 上调用 containsCustomComponents 方法。
void | MultiOptionPaneUI.selectInitialValue(JOptionPane a) 在由此对象处理的每个 UI 上调用 selectInitialValue 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JOptionPane.AccessibleJOptionPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JOptionPane.AccessibleJOptionPane
的使用

没有 javax.swing.JOptionPane.AccessibleJOptionPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JPanel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPanel
的使用

使用 JPanel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JPanel 的使用

javax.swing 中 JPanel 的子类
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。

javax.swing.colorchooser 中 JPanel 的使用

javax.swing.colorchooser 中 JPanel 的子类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.plaf.basic 中 JPanel 的使用

返回 JPanel 的 javax.swing.plaf.basic 中的方法
 JPanel BasicFileChooserUI.getAccessoryPanel()

参数类型为 JPanel 的 javax.swing.plaf.basic 中的方法
protected void | BasicPanelUI.installDefaults(JPanel p)
protected void | BasicPanelUI.uninstallDefaults(JPanel p)

javax.swing.plaf.metal 中 JPanel 的使用

返回 JPanel 的 javax.swing.plaf.metal 中的方法
protected JPanel | MetalFileChooserUI.createDetailsView(JFileChooser fc)
protected JPanel | MetalFileChooserUI.createList(JFileChooser fc)
protected JPanel | MetalFileChooserUI.getBottomPanel()
protected JPanel | MetalFileChooserUI.getButtonPanel()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JPanel.AccessibleJPanel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPanel.AccessibleJPanel
的使用

没有 javax.swing.JPanel.AccessibleJPanel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JPasswordField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPasswordField
的使用

没有 javax.swing.JPasswordField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JPasswordField.AccessibleJPasswordField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPasswordField.AccessibleJPasswordField
的使用

没有 javax.swing.JPasswordField.AccessibleJPasswordField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JPopupMenu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPopupMenu
的使用

使用 JPopupMenu 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 JPopupMenu 的使用

返回 JPopupMenu 的 javax.swing 中的方法
JPopupMenu | JComponent.getComponentPopupMenu() 返回为此组件分配的 JPopupMenu。
JPopupMenu | JMenu.getPopupMenu() 返回与此菜单关联的弹出菜单。

参数类型为 JPopupMenu 的 javax.swing 中的方法
protected JMenu.WinListener | JMenu.createWinListener(JPopupMenu p) 创建弹出菜单的窗口关闭侦听器。
void | JComponent.setComponentPopupMenu(JPopupMenu popup) 设置此 JComponent 的 JPopupMenu。

参数类型为 JPopupMenu 的 javax.swing 中的构造方法
JMenu.WinListener(JPopupMenu p)
创建指定弹出菜单的窗口侦听器。

javax.swing.plaf 中 JPopupMenu 的使用

参数类型为 JPopupMenu 的 javax.swing.plaf 中的方法
 Popup PopupMenuUI.getPopup(JPopupMenu popup, int x, int y)
返回将负责显示 JPopupMenu 的 Popup。

javax.swing.plaf.basic 中 JPopupMenu 的使用

javax.swing.plaf.basic 中 JPopupMenu 的子类
 class BasicComboPopup
此为 ComboPopup 接口的基本实现。

声明为 JPopupMenu 的 javax.swing.plaf.basic 中的字段
protected  JPopupMenu BasicPopupMenuUI.popupMenu

javax.swing.plaf.metal 中 JPopupMenu 的使用

javax.swing.plaf.metal 中 JPopupMenu 的子类
 class MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

javax.swing.plaf.multi 中 JPopupMenu 的使用

参数类型为 JPopupMenu 的 javax.swing.plaf.multi 中的方法
 Popup MultiPopupMenuUI.getPopup(JPopupMenu a, int b, int c)
在由此对象处理的每个 UI 上调用 getPopup 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JPopupMenu.AccessibleJPopupMenu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPopupMenu.AccessibleJPopupMenu
的使用

没有 javax.swing.JPopupMenu.AccessibleJPopupMenu 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JPopupMenu.Separator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPopupMenu.Separator
的使用

没有 javax.swing.JPopupMenu.Separator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JProgressBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JProgressBar
的使用

使用 JProgressBar 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 JProgressBar 的使用

声明为 JProgressBar 的 javax.swing.plaf.basic 中的字段
protected  JProgressBar BasicProgressBarUI.progressBar

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JProgressBar.AccessibleJProgressBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JProgressBar.AccessibleJProgressBar
的使用

没有 javax.swing.JProgressBar.AccessibleJProgressBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JRadioButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRadioButton
的使用

没有 javax.swing.JRadioButton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JRadioButton.AccessibleJRadioButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRadioButton.AccessibleJRadioButton
的使用

没有 javax.swing.JRadioButton.AccessibleJRadioButton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JRadioButtonMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRadioButtonMenuItem
的使用

没有 javax.swing.JRadioButtonMenuItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
的使用

没有 javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JRootPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRootPane
的使用

使用 JRootPane 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JRootPane 的使用

声明为 JRootPane 的 javax.swing 中的字段
protected JRootPane | JApplet.rootPane
protected JRootPane | JWindow.rootPane 管理此框架的 contentPane 和可选 menuBar 以及 glassPane 的 JRootPane 实例。
protected JRootPane | JDialog.rootPane
protected JRootPane | JInternalFrame.rootPane JRootPane 实例，它管理此内部窗体的内容窗格和可选菜单栏以及玻璃窗格（glass pane）。
protected JRootPane | JFrame.rootPane JRootPane 实例管理此窗体的 contentPane 和可选的 menuBar，以及 glassPane。

返回 JRootPane 的 javax.swing 中的方法
protected JRootPane | JApplet.createRootPane() 构造方法调用此方法创建默认 rootPane。
protected JRootPane | JWindow.createRootPane() 由该构造方法调用以创建默认的 rootPane。
protected JRootPane | JDialog.createRootPane() 构造方法调用此方法来创建默认的 rootPane。
protected JRootPane | JInternalFrame.createRootPane() 构造方法调用此方法来设置 JRootPane。
protected JRootPane | JFrame.createRootPane() 由构造方法调用，以创建默认的 rootPane。
JRootPane | JApplet.getRootPane() 返回此 applet 的 rootPane 对象。
JRootPane | JWindow.getRootPane() 返回此窗口的 rootPane 对象。
JRootPane | JDialog.getRootPane() 返回此对话框的 rootPane 对象。
JRootPane | JInternalFrame.getRootPane() 返回此内部窗体的 rootPane 对象。
JRootPane | JComponent.getRootPane() 返回此组件的 JRootPane 祖先。
JRootPane | JFrame.getRootPane() 返回此窗体的 rootPane 对象。
JRootPane | RootPaneContainer.getRootPane() 返回此组件的单个 JRootPane 子组件。
static JRootPane | SwingUtilities.getRootPane(Component c) 如果 c 是一个 JRootPane 后代，则返回其 JRootPane 祖先。

参数类型为 JRootPane 的 javax.swing 中的方法
protected void | JApplet.setRootPane(JRootPane root) 设置 rootPane 属性。
protected void | JWindow.setRootPane(JRootPane root) 设置此窗口的新 rootPane 对象。
protected void | JDialog.setRootPane(JRootPane root) 设置 rootPane 属性。
protected void | JInternalFrame.setRootPane(JRootPane root) 设置此 JInternalFrame 的 rootPane 属性。
protected void | JFrame.setRootPane(JRootPane root) 设置 rootPane 属性。

javax.swing.plaf.basic 中 JRootPane 的使用

参数类型为 JRootPane 的 javax.swing.plaf.basic 中的方法
protected void | BasicRootPaneUI.installComponents(JRootPane root)
protected void | BasicRootPaneUI.installDefaults(JRootPane c)
protected void | BasicRootPaneUI.installKeyboardActions(JRootPane root)
protected void | BasicRootPaneUI.installListeners(JRootPane root)
protected void | BasicRootPaneUI.uninstallComponents(JRootPane root)
protected void | BasicRootPaneUI.uninstallDefaults(JRootPane root)
protected void | BasicRootPaneUI.uninstallKeyboardActions(JRootPane root)
protected void | BasicRootPaneUI.uninstallListeners(JRootPane root)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JRootPane.AccessibleJRootPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRootPane.AccessibleJRootPane
的使用

没有 javax.swing.JRootPane.AccessibleJRootPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JRootPane.RootLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRootPane.RootLayout
的使用

没有 javax.swing.JRootPane.RootLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JScrollBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JScrollBar
的使用

使用 JScrollBar 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JScrollBar 的使用

javax.swing 中 JScrollBar 的子类
protected  class JScrollPane.ScrollBar
默认情况下，JScrollPane 创建的滚动条为此类的实例。

声明为 JScrollBar 的 javax.swing 中的字段
protected JScrollBar | JScrollPane.horizontalScrollBar 滚动窗格的水平滚动条子级。
protected JScrollBar | ScrollPaneLayout.hsb 滚动窗格的子级水平滚动条。
protected JScrollBar | JScrollPane.verticalScrollBar 滚动窗格的垂直滚动条子级。
protected JScrollBar | ScrollPaneLayout.vsb 滚动窗格的子级垂直滚动条。

返回 JScrollBar 的 javax.swing 中的方法
JScrollBar | JScrollPane.createHorizontalScrollBar() 默认返回 JScrollPane.ScrollBar。
JScrollBar | JScrollPane.createVerticalScrollBar() 默认返回 JScrollPane.ScrollBar。
JScrollBar | ScrollPaneLayout.getHorizontalScrollBar() 返回处理水平滚动的 JScrollBar 对象。
JScrollBar | JScrollPane.getHorizontalScrollBar() 返回控制视口的水平视图位置的水平滚动条。
JScrollBar | ScrollPaneLayout.getVerticalScrollBar() 返回处理垂直滚动的 JScrollBar 对象。
JScrollBar | JScrollPane.getVerticalScrollBar() 返回控制视口垂直视图位置的垂直滚动条。

参数类型为 JScrollBar 的 javax.swing 中的方法
void | JScrollPane.setHorizontalScrollBar(JScrollBar horizontalScrollBar) 将控制视口水平视图位置的水平滚动条添加到滚动窗格中。
void | JScrollPane.setVerticalScrollBar(JScrollBar verticalScrollBar) 将控制视口垂直视图位置的滚动条添加到滚动窗格中。

javax.swing.plaf.basic 中 JScrollBar 的使用

声明为 JScrollBar 的 javax.swing.plaf.basic 中的字段
protected JScrollBar | BasicScrollBarUI.scrollbar
protected JScrollBar | BasicTreeUI.ComponentHandler.scrollBar 正在调整的 scrollBar。

参数类型为 JScrollBar 的 javax.swing.plaf.basic 中的方法
protected void | BasicScrollBarUI.layoutHScrollbar(JScrollBar sb)
protected void | BasicScrollBarUI.layoutVScrollbar(JScrollBar sb)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JScrollBar.AccessibleJScrollBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JScrollBar.AccessibleJScrollBar
的使用

没有 javax.swing.JScrollBar.AccessibleJScrollBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JScrollPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JScrollPane
的使用

使用 JScrollPane 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JScrollPane 的使用

返回 JScrollPane 的 javax.swing 中的方法
static JScrollPane JTable.createScrollPaneForTable(JTable aTable)
已过时。 从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。

参数类型为 JScrollPane 的 javax.swing 中的方法
 Rectangle ScrollPaneLayout.getViewportBorderBounds(JScrollPane scrollpane)
已过时。 从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。
 void ScrollPaneLayout.syncWithScrollPane(JScrollPane sp)
在 ScrollPaneLayout 被设置为 JScrollPane 的 LayoutManager 后，此方法被调用。

javax.swing.plaf.basic 中 JScrollPane 的使用

声明为 JScrollPane 的 javax.swing.plaf.basic 中的字段
protected JScrollPane | BasicComboPopup.scroller 此受保护字段是特定于实现的。
protected JScrollPane | BasicScrollPaneUI.scrollpane

返回 JScrollPane 的 javax.swing.plaf.basic 中的方法
protected JScrollPane | BasicComboPopup.createScroller() 创建容纳可滚动列表的滚动窗格。
protected JScrollPane | BasicTreeUI.ComponentHandler.getScrollPane() 返回容纳 JTree 的 JScrollPane；如果一个也没有找到，则返回 null。

参数类型为 JScrollPane 的 javax.swing.plaf.basic 中的方法
protected void | BasicScrollPaneUI.installDefaults(JScrollPane scrollpane)
protected void | BasicScrollPaneUI.installKeyboardActions(JScrollPane c)
protected void | BasicScrollPaneUI.installListeners(JScrollPane c)
protected void | BasicScrollPaneUI.uninstallDefaults(JScrollPane c)
protected void | BasicScrollPaneUI.uninstallKeyboardActions(JScrollPane c)

javax.swing.plaf.metal 中 JScrollPane 的使用

参数类型为 JScrollPane 的 javax.swing.plaf.metal 中的方法
void | MetalScrollPaneUI.installListeners(JScrollPane scrollPane)
void | MetalScrollPaneUI.uninstallListeners(JScrollPane scrollPane)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JScrollPane.AccessibleJScrollPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JScrollPane.AccessibleJScrollPane
的使用

没有 javax.swing.JScrollPane.AccessibleJScrollPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JScrollPane.ScrollBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JScrollPane.ScrollBar
的使用

没有 javax.swing.JScrollPane.ScrollBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSeparator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSeparator
的使用

使用 JSeparator 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JSeparator 的使用

javax.swing 中 JSeparator 的子类
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。

javax.swing.plaf.basic 中 JSeparator 的使用

参数类型为 JSeparator 的 javax.swing.plaf.basic 中的方法
protected void | BasicToolBarSeparatorUI.installDefaults(JSeparator s)
protected void | BasicSeparatorUI.installDefaults(JSeparator s)
protected void | BasicSeparatorUI.installListeners(JSeparator s)
protected void | BasicSeparatorUI.uninstallDefaults(JSeparator s)
protected void | BasicSeparatorUI.uninstallListeners(JSeparator s)

javax.swing.plaf.metal 中 JSeparator 的使用

参数类型为 JSeparator 的 javax.swing.plaf.metal 中的方法
protected  void MetalSeparatorUI.installDefaults(JSeparator s)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSeparator.AccessibleJSeparator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSeparator.AccessibleJSeparator
的使用

没有 javax.swing.JSeparator.AccessibleJSeparator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSlider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSlider
的使用

使用 JSlider 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 JSlider 的使用

声明为 JSlider 的 javax.swing.plaf.basic 中的字段
protected  JSlider BasicSliderUI.slider

参数类型为 JSlider 的 javax.swing.plaf.basic 中的方法
protected ChangeListener | BasicSliderUI.createChangeListener(JSlider slider)
protected ComponentListener | BasicSliderUI.createComponentListener(JSlider slider)
protected FocusListener | BasicSliderUI.createFocusListener(JSlider slider)
protected PropertyChangeListener | BasicSliderUI.createPropertyChangeListener(JSlider slider)
protected BasicSliderUI.ScrollListener | BasicSliderUI.createScrollListener(JSlider slider)
protected BasicSliderUI.TrackListener | BasicSliderUI.createTrackListener(JSlider slider)
protected void | BasicSliderUI.installDefaults(JSlider slider)
protected void | BasicSliderUI.installKeyboardActions(JSlider slider)
protected void | BasicSliderUI.installListeners(JSlider slider)
protected void | BasicSliderUI.uninstallKeyboardActions(JSlider slider)
protected void | BasicSliderUI.uninstallListeners(JSlider slider)

参数类型为 JSlider 的 javax.swing.plaf.basic 中的构造方法
BasicSliderUI.ActionScroller(JSlider slider, int dir, boolean block)
BasicSliderUI(JSlider b)

javax.swing.plaf.metal 中 JSlider 的使用

参数类型为 JSlider 的 javax.swing.plaf.metal 中的方法
protected  PropertyChangeListener MetalSliderUI.createPropertyChangeListener(JSlider slider)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSlider.AccessibleJSlider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSlider.AccessibleJSlider
的使用

没有 javax.swing.JSlider.AccessibleJSlider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSpinner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner
的使用

使用 JSpinner 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JSpinner 的使用

返回 JSpinner 的 javax.swing 中的方法
 JSpinner JSpinner.DefaultEditor.getSpinner()
如果此编辑器的 JSpinner 祖先，如果祖先都不为 JSpinner，则返回 null。

参数类型为 JSpinner 的 javax.swing 中的方法
 void JSpinner.DefaultEditor.dismiss(JSpinner spinner)
将此编辑器从指定的 JSpinner 断开连接。

参数类型为 JSpinner 的 javax.swing 中的构造方法
JSpinner.DateEditor(JSpinner spinner)
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。
JSpinner.DateEditor(JSpinner spinner, String dateFormatPattern)
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。
JSpinner.DefaultEditor(JSpinner spinner)
构造一个针对指定 JSpinner 的编辑器组件。
JSpinner.ListEditor(JSpinner spinner)
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerListModel 的值的显示和编辑。
JSpinner.NumberEditor(JSpinner spinner)
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerNumberModel 值的显示和编辑。
JSpinner.NumberEditor(JSpinner spinner, String decimalFormatPattern)
构造一个 JSpinner，使其支持具有一个 JFormattedTextField 的 SpinnerNumberModel 的值。

javax.swing.plaf.basic 中 JSpinner 的使用

声明为 JSpinner 的 javax.swing.plaf.basic 中的字段
protected  JSpinner BasicSpinnerUI.spinner
作为 UI 委托的 spinner。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSpinner.AccessibleJSpinner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner.AccessibleJSpinner
的使用

没有 javax.swing.JSpinner.AccessibleJSpinner 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSpinner.DateEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner.DateEditor
的使用

没有 javax.swing.JSpinner.DateEditor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSpinner.DefaultEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner.DefaultEditor
的使用

使用 JSpinner.DefaultEditor 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JSpinner.DefaultEditor 的使用

javax.swing 中 JSpinner.DefaultEditor 的子类
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSpinner.ListEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner.ListEditor
的使用

没有 javax.swing.JSpinner.ListEditor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSpinner.NumberEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner.NumberEditor
的使用

没有 javax.swing.JSpinner.NumberEditor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSplitPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSplitPane
的使用

使用 JSplitPane 的软件包
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf 中 JSplitPane 的使用

参数类型为 JSplitPane 的 javax.swing.plaf 中的方法
abstract void | SplitPaneUI.finishedPaintingChildren(JSplitPane jc, Graphics g) 在 JSplitPane 接收方提供外观来绘制其子组件之后传递消息。
abstract int | SplitPaneUI.getDividerLocation(JSplitPane jc) 返回分隔符的位置。
abstract int | SplitPaneUI.getMaximumDividerLocation(JSplitPane jc) 返回分隔符的最大可能位置。
abstract int | SplitPaneUI.getMinimumDividerLocation(JSplitPane jc) 返回分隔符的最小可能位置。
abstract void | SplitPaneUI.resetToPreferredSizes(JSplitPane jc) 传递消息，以便基于子组件的首选大小重新布置 JSplitPane。
abstract void | SplitPaneUI.setDividerLocation(JSplitPane jc, int location) 将分隔符的位置设置到 location。

javax.swing.plaf.basic 中 JSplitPane 的使用

声明为 JSplitPane 的 javax.swing.plaf.basic 中的字段
protected JSplitPane | BasicSplitPaneDivider.splitPane 其中包含接收者的 JSplitPane。
protected JSplitPane | BasicSplitPaneUI.splitPane 此实例为其提供外观的 JSplitPane 实例。

返回 JSplitPane 的 javax.swing.plaf.basic 中的方法
 JSplitPane BasicSplitPaneUI.getSplitPane()
返回当前包含此实例的拆分窗格。

参数类型为 JSplitPane 的 javax.swing.plaf.basic 中的方法
void | BasicSplitPaneUI.finishedPaintingChildren(JSplitPane jc, Graphics g) 在 JSplitPane 接收者将为绘制其子级提供外观后传递消息。
int | BasicSplitPaneUI.getDividerLocation(JSplitPane jc) 返回分隔符的位置，该位置可能不同于拆分窗格认为分隔符所在的位置。
int | BasicSplitPaneUI.getMaximumDividerLocation(JSplitPane jc) 获取分隔符的最大位置。
int | BasicSplitPaneUI.getMinimumDividerLocation(JSplitPane jc) 获取分隔符的最小位置。
void | BasicSplitPaneUI.resetToPreferredSizes(JSplitPane jc) 传递消息以重置首选大小。
void | BasicSplitPaneUI.setDividerLocation(JSplitPane jc, int location) 将分隔符的位置设置到 location。

javax.swing.plaf.multi 中 JSplitPane 的使用

参数类型为 JSplitPane 的 javax.swing.plaf.multi 中的方法
void | MultiSplitPaneUI.finishedPaintingChildren(JSplitPane a, Graphics b) 在由此对象处理的每个 UI 上调用 finishedPaintingChildren 方法。
int | MultiSplitPaneUI.getDividerLocation(JSplitPane a) 在由此对象处理的每个 UI 上调用 getDividerLocation 方法。
int | MultiSplitPaneUI.getMaximumDividerLocation(JSplitPane a) 在由此对象处理的每个 UI 上调用 getMaximumDividerLocation 方法。
int | MultiSplitPaneUI.getMinimumDividerLocation(JSplitPane a) 在由此对象处理的每个 UI 上调用 getMinimumDividerLocation 方法。
void | MultiSplitPaneUI.resetToPreferredSizes(JSplitPane a) 在由此对象处理的每个 UI 上调用 resetToPreferredSizes 方法。
void | MultiSplitPaneUI.setDividerLocation(JSplitPane a, int b) 在由此对象处理的每个 UI 上调用 setDividerLocation 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JSplitPane.AccessibleJSplitPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSplitPane.AccessibleJSplitPane
的使用

没有 javax.swing.JSplitPane.AccessibleJSplitPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTabbedPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTabbedPane
的使用

使用 JTabbedPane 的软件包
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf 中 JTabbedPane 的使用

参数类型为 JTabbedPane 的 javax.swing.plaf 中的方法
abstract Rectangle | TabbedPaneUI.getTabBounds(JTabbedPane pane, int index)
abstract int | TabbedPaneUI.getTabRunCount(JTabbedPane pane)
abstract int | TabbedPaneUI.tabForCoordinate(JTabbedPane pane, int x, int y)

javax.swing.plaf.basic 中 JTabbedPane 的使用

声明为 JTabbedPane 的 javax.swing.plaf.basic 中的字段
protected  JTabbedPane BasicTabbedPaneUI.tabPane

参数类型为 JTabbedPane 的 javax.swing.plaf.basic 中的方法
Rectangle | BasicTabbedPaneUI.getTabBounds(JTabbedPane pane, int i) 返回指定选项卡索引的边界。
int | BasicTabbedPaneUI.getTabRunCount(JTabbedPane pane)
int | BasicTabbedPaneUI.tabForCoordinate(JTabbedPane pane, int x, int y) 返回与 JTabbedPane 的坐标空间中的指定点相交的选项卡索引。

javax.swing.plaf.multi 中 JTabbedPane 的使用

参数类型为 JTabbedPane 的 javax.swing.plaf.multi 中的方法
Rectangle | MultiTabbedPaneUI.getTabBounds(JTabbedPane a, int b) 在由此对象处理的每个 UI 上调用 getTabBounds 方法。
int | MultiTabbedPaneUI.getTabRunCount(JTabbedPane a) 在由此对象处理的每个 UI 上调用 getTabRunCount 方法。
int | MultiTabbedPaneUI.tabForCoordinate(JTabbedPane a, int b, int c) 在由此对象处理的每个 UI 上调用 tabForCoordinate 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTabbedPane.AccessibleJTabbedPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTabbedPane.AccessibleJTabbedPane
的使用

没有 javax.swing.JTabbedPane.AccessibleJTabbedPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTabbedPane.ModelListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTabbedPane.ModelListener
的使用

没有 javax.swing.JTabbedPane.ModelListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable
的使用

使用 JTable 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 JTable 的使用

参数类型为 JTable 的 javax.swing 中的方法
static JScrollPane | JTable.createScrollPaneForTable(JTable aTable) 已过时。 从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。
Component | DefaultCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column) 实现 TableCellEditor 接口。

参数类型为 JTable 的 javax.swing 中的构造方法
JTable.AccessibleJTable.AccessibleJTableCell(JTable t, int r, int c, int i)
构造一个 AccessibleJTableHeaderEntry。

javax.swing.plaf.basic 中 JTable 的使用

声明为 JTable 的 javax.swing.plaf.basic 中的字段
protected  JTable BasicTableUI.table

javax.swing.table 中 JTable 的使用

声明为 JTable 的 javax.swing.table 中的字段
protected  JTable JTableHeader.table
将此对象作为其头的表，默认值为 null。

返回 JTable 的 javax.swing.table 中的方法
 JTable JTableHeader.getTable()
返回与此头关联的表。

参数类型为 JTable 的 javax.swing.table 中的方法
Component | TableCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column) 为编辑器设置初始 value。
Component | DefaultTableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column) 返回默认的表单元格渲染器。
Component | TableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column) 返回用于绘制单元格的组件。
void | JTableHeader.setTable(JTable table) 设置与此头关联的表。

参数类型为 JTable 的 javax.swing.table 中的构造方法
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c, JTableHeader p, JTable t)
构造一个 AccessiblJTableHeaaderEntry

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTable.AccessibleJTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable.AccessibleJTable
的使用

没有 javax.swing.JTable.AccessibleJTable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
的使用

没有 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
的使用

没有 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTable.DropLocation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable.DropLocation
的使用

使用 JTable.DropLocation 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTable.DropLocation 的使用

返回 JTable.DropLocation 的 javax.swing 中的方法
 JTable.DropLocation JTable.getDropLocation()
返回对组件的 DnD 操作期间此组件应该可见地指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTable.PrintMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable.PrintMode
的使用

使用 JTable.PrintMode 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTable.PrintMode 的使用

返回 JTable.PrintMode 的 javax.swing 中的方法
static JTable.PrintMode | JTable.PrintMode.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static JTable.PrintMode[] | JTable.PrintMode.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 JTable.PrintMode 的 javax.swing 中的方法
Printable | JTable.getPrintable(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 返回打印此 JTable 中所使用的 Printable。
boolean | JTable.print(JTable.PrintMode printMode) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，不打印标题或脚注文本。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，打印指定的标题和脚注文本。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTextArea 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTextArea
的使用

没有 javax.swing.JTextArea 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTextArea.AccessibleJTextArea 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTextArea.AccessibleJTextArea
的使用

没有 javax.swing.JTextArea.AccessibleJTextArea 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTextField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTextField
的使用

使用 JTextField 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 JTextField 的使用

javax.swing 中 JTextField 的子类
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。

参数类型为 JTextField 的 javax.swing 中的构造方法
DefaultCellEditor(JTextField textField)
构造一个使用文本字段的 DefaultCellEditor。

javax.swing.plaf.basic 中 JTextField 的使用

声明为 JTextField 的 javax.swing.plaf.basic 中的字段
protected  JTextField BasicComboBoxEditor.editor

返回 JTextField 的 javax.swing.plaf.basic 中的方法
protected  JTextField BasicComboBoxEditor.createEditorComponent()
创建内部编辑器组件。

javax.swing.tree 中 JTextField 的使用

javax.swing.tree 中 JTextField 的子类
 class DefaultTreeCellEditor.DefaultTextField
不提供任何编辑器时所使用的 TextField。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTextField.AccessibleJTextField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTextField.AccessibleJTextField
的使用

使用 JTextField.AccessibleJTextField 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTextField.AccessibleJTextField 的使用

javax.swing 中 JTextField.AccessibleJTextField 的子类
protected  class JPasswordField.AccessibleJPasswordField
此类实现对 JPasswordField 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTextPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTextPane
的使用

没有 javax.swing.JTextPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JToggleButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToggleButton
的使用

使用 JToggleButton 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JToggleButton 的使用

javax.swing 中 JToggleButton 的子类
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JToggleButton.AccessibleJToggleButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToggleButton.AccessibleJToggleButton
的使用

使用 JToggleButton.AccessibleJToggleButton 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JToggleButton.AccessibleJToggleButton 的使用

javax.swing 中 JToggleButton.AccessibleJToggleButton 的子类
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JToggleButton.ToggleButtonModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToggleButton.ToggleButtonModel
的使用

没有 javax.swing.JToggleButton.ToggleButtonModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JToolBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToolBar
的使用

使用 JToolBar 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 JToolBar 的使用

声明为 JToolBar 的 javax.swing.plaf.basic 中的字段
protected JToolBar | BasicToolBarUI.toolBar
protected JToolBar | BasicToolBarUI.DockingListener.toolBar

参数类型为 JToolBar 的 javax.swing.plaf.basic 中的方法
protected  BasicToolBarUI.DragWindow BasicToolBarUI.createDragWindow(JToolBar toolbar)
protected  JFrame BasicToolBarUI.createFloatingFrame(JToolBar toolbar)
不再使用，使用 BasicToolBarUI.createFloatingWindow(JToolBar)
protected  RootPaneContainer BasicToolBarUI.createFloatingWindow(JToolBar toolbar)
创建将工具栏拖出其容器后包含该工具栏的窗口

参数类型为 JToolBar 的 javax.swing.plaf.basic 中的构造方法
BasicToolBarUI.DockingListener(JToolBar t)

javax.swing.plaf.metal 中 JToolBar 的使用

参数类型为 JToolBar 的 javax.swing.plaf.metal 中的构造方法
MetalToolBarUI.MetalDockingListener(JToolBar t)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JToolBar.AccessibleJToolBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToolBar.AccessibleJToolBar
的使用

没有 javax.swing.JToolBar.AccessibleJToolBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JToolBar.Separator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToolBar.Separator
的使用

没有 javax.swing.JToolBar.Separator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JToolTip 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToolTip
的使用

使用 JToolTip 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JToolTip 的使用

返回 JToolTip 的 javax.swing 中的方法
 JToolTip JComponent.createToolTip()
返回用于显示工具提示的 JToolTip 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JToolTip.AccessibleJToolTip 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToolTip.AccessibleJToolTip
的使用

没有 javax.swing.JToolTip.AccessibleJToolTip 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTree 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree
的使用

使用 JTree 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 JTree 的使用

参数类型为 JTree 的 javax.swing 中的方法
 Component DefaultCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
实现 TreeCellEditor 接口。

参数类型为 JTree 的 javax.swing 中的构造方法
JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
构造一个 AccessibleJTreeNode

javax.swing.plaf 中 JTree 的使用

参数类型为 JTree 的 javax.swing.plaf 中的方法
abstract void | TreeUI.cancelEditing(JTree tree) 取消当前编辑会话。
abstract TreePath | TreeUI.getClosestPathForLocation(JTree tree, int x, int y) 返回到达最接近于 x,y 的那个节点的路径。
abstract TreePath | TreeUI.getEditingPath(JTree tree) 返回到达正被编辑的元素的路径。
abstract Rectangle | TreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
abstract TreePath | TreeUI.getPathForRow(JTree tree, int row) 返回传入的 row 的路径。
abstract int | TreeUI.getRowCount(JTree tree) 返回将显示的行数。
abstract int | TreeUI.getRowForPath(JTree tree, TreePath path) 返回可在其中看见路径中标识的最后一个项的行。
abstract boolean | TreeUI.isEditing(JTree tree) 如果树正被编辑，则返回 true。
abstract void | TreeUI.startEditingAtPath(JTree tree, TreePath path) 选择路径中的最后一个项并试着编辑它。
abstract boolean | TreeUI.stopEditing(JTree tree) 停止当前编辑会话。

javax.swing.plaf.basic 中 JTree 的使用

声明为 JTree 的 javax.swing.plaf.basic 中的字段
protected  JTree BasicTreeUI.tree
要在其中进行绘制的组件。

参数类型为 JTree 的 javax.swing.plaf.basic 中的方法
void | BasicTreeUI.cancelEditing(JTree tree) 取消当前编辑会话。
TreePath | BasicTreeUI.getClosestPathForLocation(JTree tree, int x, int y) 返回到达最接近于 x,y 的那个节点的路径。
TreePath | BasicTreeUI.getEditingPath(JTree tree) 返回到达正被编辑的元素的路径。
Rectangle | BasicTreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
TreePath | BasicTreeUI.getPathForRow(JTree tree, int row) 返回传入的 row 的路径。
int | BasicTreeUI.getRowCount(JTree tree) 返回将显示的行数。
int | BasicTreeUI.getRowForPath(JTree tree, TreePath path) 返回可在其中看见路径中标识的最后一个项的行。
boolean | BasicTreeUI.isEditing(JTree tree) 如果树正被编辑，则返回 true。
void | BasicTreeUI.startEditingAtPath(JTree tree, TreePath path) 选择路径中的最后一个项并尝试对其进行编辑。
boolean | BasicTreeUI.stopEditing(JTree tree) 停止当前编辑会话。

javax.swing.plaf.multi 中 JTree 的使用

参数类型为 JTree 的 javax.swing.plaf.multi 中的方法
void | MultiTreeUI.cancelEditing(JTree a) 在由此对象处理的每个 UI 上调用 cancelEditing 方法。
TreePath | MultiTreeUI.getClosestPathForLocation(JTree a, int b, int c) 在由此对象处理的每个 UI 上调用 getClosestPathForLocation 方法。
TreePath | MultiTreeUI.getEditingPath(JTree a) 在由此对象处理的每个 UI 上调用 getEditingPath 方法。
Rectangle | MultiTreeUI.getPathBounds(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getPathBounds 方法。
TreePath | MultiTreeUI.getPathForRow(JTree a, int b) 在由此对象处理的每个 UI 上调用 getPathForRow 方法。
int | MultiTreeUI.getRowCount(JTree a) 在由此对象处理的每个 UI 上调用 getRowCount 方法。
int | MultiTreeUI.getRowForPath(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getRowForPath 方法。
boolean | MultiTreeUI.isEditing(JTree a) 在由此对象处理的每个 UI 上调用 isEditing 方法。
void | MultiTreeUI.startEditingAtPath(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 startEditingAtPath 方法。
boolean | MultiTreeUI.stopEditing(JTree a) 在由此对象处理的每个 UI 上调用 stopEditing 方法。

javax.swing.tree 中 JTree 的使用

声明为 JTree 的 javax.swing.tree 中的字段
protected  JTree DefaultTreeCellEditor.tree
JTree 实例侦听。

参数类型为 JTree 的 javax.swing.tree 中的方法
protected void | DefaultTreeCellEditor.determineOffset(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
Component | DefaultTreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row) 配置编辑器。
Component | TreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row) 设置编辑器的初始值。
Component | DefaultTreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus) 配置基于传入组件的渲染器。
Component | TreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus) 将当前树单元格的值设置为 value。
protected void | DefaultTreeCellEditor.setTree(JTree newTree) 设置当前正在为其编辑的树。

参数类型为 JTree 的 javax.swing.tree 中的构造方法
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer)
使用指定呈现器和默认编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
使用指定的呈现器和指定的编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTree.AccessibleJTree 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.AccessibleJTree
的使用

没有 javax.swing.JTree.AccessibleJTree 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
的使用

没有 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTree.DropLocation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.DropLocation
的使用

使用 JTree.DropLocation 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTree.DropLocation 的使用

返回 JTree.DropLocation 的 javax.swing 中的方法
 JTree.DropLocation JTree.getDropLocation()
返回该组件上 DnD 操作期间此组件应该视觉上指示为放置操作的位置；如果当前未显示任何位置，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTree.DynamicUtilTreeNode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.DynamicUtilTreeNode
的使用

没有 javax.swing.JTree.DynamicUtilTreeNode 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTree.EmptySelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.EmptySelectionModel
的使用

使用 JTree.EmptySelectionModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTree.EmptySelectionModel 的使用

声明为 JTree.EmptySelectionModel 的 javax.swing 中的字段
protected static JTree.EmptySelectionModel JTree.EmptySelectionModel.sharedInstance
独有的共享实例。

返回 JTree.EmptySelectionModel 的 javax.swing 中的方法
static JTree.EmptySelectionModel JTree.EmptySelectionModel.sharedInstance()
返回空选择模型的共享实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTree.TreeModelHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.TreeModelHandler
的使用

没有 javax.swing.JTree.TreeModelHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JTree.TreeSelectionRedirector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.TreeSelectionRedirector
的使用

使用 JTree.TreeSelectionRedirector 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTree.TreeSelectionRedirector 的使用

声明为 JTree.TreeSelectionRedirector 的 javax.swing 中的字段
protected  JTree.TreeSelectionRedirector JTree.selectionRedirector
创建一个新事件，并将它传递给 selectionListeners。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JViewport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JViewport
的使用

使用 JViewport 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JViewport 的使用

声明为 JViewport 的 javax.swing 中的字段
protected JViewport | ScrollPaneLayout.colHead 子级列标题。
protected JViewport | JScrollPane.columnHeader 列标题子级。
protected JViewport | ScrollPaneLayout.rowHead 子级行标题。
protected JViewport | JScrollPane.rowHeader 行标题子级。
protected JViewport | ScrollPaneLayout.viewport 滚动窗格的子级视口。
protected JViewport | JScrollPane.viewport 滚动窗格的视口子级。
protected JViewport | JScrollPane.AccessibleJScrollPane.viewPort

返回 JViewport 的 javax.swing 中的方法
protected JViewport | JScrollPane.createViewport() 默认返回新的 JViewport。
JViewport | ScrollPaneLayout.getColumnHeader() 返回列标题对应的 JViewport 对象。
JViewport | JScrollPane.getColumnHeader() 返回列标题。
JViewport | ScrollPaneLayout.getRowHeader() 返回行标题对应的 JViewport 对象。
JViewport | JScrollPane.getRowHeader() 返回行标题。
JViewport | ScrollPaneLayout.getViewport() 返回显示滚动组件内容的 JViewport 对象。
JViewport | JScrollPane.getViewport() 返回当前的 JViewport。

参数类型为 JViewport 的 javax.swing 中的方法
void | JScrollPane.setColumnHeader(JViewport columnHeader) 移除旧的 columnHeader，如果有的话；如果新的 columnHeader 不为 null，将其 viewPosition 的 x 坐标与视口（如果有）同步然后将其添加到滚动窗格。
void | JScrollPane.setRowHeader(JViewport rowHeader) 移除旧的 rowHeader，如果存在；如果新的 rowHeader 不为 null，将其 viewPosition 的 y 坐标与视口（如果有）同步然后将其添加到滚动窗格。
void | JScrollPane.setViewport(JViewport viewport) 移除旧视口（如果有）；强制新视口的 viewPosition 位于 +x,+y 象限中；将行和列标题（如果有）与新视口同步；最后将滚动条和标题与新视口同步。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JViewport.AccessibleJViewport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JViewport.AccessibleJViewport
的使用

没有 javax.swing.JViewport.AccessibleJViewport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JViewport.ViewListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JViewport.ViewListener
的使用

使用 JViewport.ViewListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JViewport.ViewListener 的使用

返回 JViewport.ViewListener 的 javax.swing 中的方法
protected  JViewport.ViewListener JViewport.createViewListener()
为该视图创建侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JWindow 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JWindow
的使用

没有 javax.swing.JWindow 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.JWindow.AccessibleJWindow 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JWindow.AccessibleJWindow
的使用

没有 javax.swing.JWindow.AccessibleJWindow 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.KeyStroke 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.KeyStroke
的使用

使用 KeyStroke 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 KeyStroke 的使用

返回 KeyStroke 的 javax.swing 中的方法
KeyStroke[] | InputMap.allKeys() 返回在此 InputMap 及其父级中定义的 KeyStroke 组成的数组。
KeyStroke | JMenuItem.getAccelerator() 返回作为菜单项的加速器的 KeyStroke。
static KeyStroke | KeyStroke.getKeyStroke(char keyChar) 返回 KeyStroke 的共享实例，前者表示指定字符的 KEY_TYPED 事件。
static KeyStroke | KeyStroke.getKeyStroke(Character keyChar, int modifiers) 返回 KeyStroke 的一个共享实例，它表示指定 Character 对象和一组修饰符的 KEY_TYPED 事件。
static KeyStroke | KeyStroke.getKeyStroke(char keyChar, boolean onKeyRelease) 已过时。 使用 getKeyStroke(char)
static KeyStroke | KeyStroke.getKeyStroke(int keyCode, int modifiers) 在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例。
static KeyStroke | KeyStroke.getKeyStroke(int keyCode, int modifiers, boolean onKeyRelease) 在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例，指定该键在按下或释放时是否为已激活。
static KeyStroke | KeyStroke.getKeyStroke(String s) 分析字符串并返回 KeyStroke。
static KeyStroke | KeyStroke.getKeyStrokeForEvent(KeyEvent anEvent) 返回一个 KeyStroke，它表示生成给定 KeyEvent 的快捷键事件。
KeyStroke[] | JComponent.getRegisteredKeyStrokes() 返回启动已注册动作的 KeyStrokes。
KeyStroke[] | InputMap.keys() 返回绑定在此 InputMap 中的 KeyStroke。

参数类型为 KeyStroke 的 javax.swing 中的方法
 Object InputMap.get(KeyStroke keyStroke)
返回 keyStroke 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 InputMap。
 ActionListener JComponent.getActionForKeyStroke(KeyStroke aKeyStroke)
返回执行针对给定键击而注册的操作的对象。
 int JComponent.getConditionForKeyStroke(KeyStroke aKeyStroke)
返回确定是否发生已注册动作以响应指定键击事件的条件。
static boolean SwingUtilities.notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers)
如果启用 action（且为非 null），则调用 action 上的 actionPerformed。
protected  boolean JTable.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
protected  boolean JMenuBar.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
子类化以检查所有子菜单。
protected  boolean JComponent.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
由于发生 KeyEvent e 而调用此方法处理 ks 的键绑定。
 void ComponentInputMap.put(KeyStroke keyStroke, Object actionMapKey)
将一个 keyStroke 的绑定添加到 actionMapKey。
 void InputMap.put(KeyStroke keyStroke, Object actionMapKey)
将 keyStroke 的一个绑定添加到 actionMapKey。
 void JComponent.registerKeyboardAction(ActionListener anAction, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
 void JComponent.registerKeyboardAction(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
 void ComponentInputMap.remove(KeyStroke key)
从此对象中移除 key 的绑定。
 void InputMap.remove(KeyStroke key)
从此 InputMap 中移除 key 的绑定。
 void JMenu.setAccelerator(KeyStroke keyStroke)
没有为 JMenu 定义 setAccelerator。
 void JMenuItem.setAccelerator(KeyStroke keyStroke)
设置修改键，它能直接调用菜单项的操作侦听器而不必显示菜单的层次结构。
 void JComponent.unregisterKeyboardAction(KeyStroke aKeyStroke)
此方法现在已过时。

javax.swing.plaf.basic 中 KeyStroke 的使用

声明为 KeyStroke 的 javax.swing.plaf.basic 中的字段
protected KeyStroke | BasicDesktopPaneUI.closeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicSplitPaneUI.dividerResizeToggleKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.downKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.downKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.downKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.endKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.homeKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.leftKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.leftKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.leftKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.maximizeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.minimizeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.navigateKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.navigateKey2 已过时。 从 1.3 开始。
protected KeyStroke | BasicInternalFrameUI.openMenuKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.rightKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.rightKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.rightKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.upKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.upKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.upKey 已过时。 从 Java 2 平台 v1.3 开始。

javax.swing.text 中 KeyStroke 的使用

声明为 KeyStroke 的 javax.swing.text 中的字段
 KeyStroke JTextComponent.KeyBinding.key
键。

返回 KeyStroke 的 javax.swing.text 中的方法
KeyStroke[] | Keymap.getBoundKeyStrokes() 获取在此映射中绑定到其他操作的所有击键。
KeyStroke[] | Keymap.getKeyStrokesForAction(Action a) 获取将导致给定操作的击键。

参数类型为 KeyStroke 的 javax.swing.text 中的方法
void | Keymap.addActionForKeyStroke(KeyStroke key, Action a) 向 keymap 添加绑定。
Action | Keymap.getAction(KeyStroke key) 获取适合于给定符号事件序列的操作。
boolean | Keymap.isLocallyDefined(KeyStroke key) 确定是否本地定义给定的键序列。
void | Keymap.removeKeyStrokeBinding(KeyStroke keys) 从 keymap 移除绑定。

参数类型为 KeyStroke 的 javax.swing.text 中的构造方法
JTextComponent.KeyBinding(KeyStroke key, String actionName)
创建新的键绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.LayoutFocusTraversalPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.LayoutFocusTraversalPolicy
的使用

没有 javax.swing.LayoutFocusTraversalPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.LayoutStyle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.LayoutStyle
的使用

使用 LayoutStyle 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 LayoutStyle 的使用

返回 LayoutStyle 的 javax.swing 中的方法
static LayoutStyle | LayoutStyle.getInstance() 返回 LayoutStyle 的共享实例。
LayoutStyle | GroupLayout.getLayoutStyle() 返回 LayoutStyle，用于计算组件之间的首选间隙。
LayoutStyle | LookAndFeel.getLayoutStyle() 返回此外观的 LayoutStyle。

参数类型为 LayoutStyle 的 javax.swing 中的方法
static void | LayoutStyle.setInstance(LayoutStyle style) 设置 LayoutStyle 的共享实例。
void | GroupLayout.setLayoutStyle(LayoutStyle layoutStyle) 设置用于计算组件之间首选间隙的 LayoutStyle。

javax.swing.plaf.metal 中 LayoutStyle 的使用

返回 LayoutStyle 的 javax.swing.plaf.metal 中的方法
 LayoutStyle MetalLookAndFeel.getLayoutStyle()
返回一个 LayoutStyle，它实现 http://java.sun.com/products/jlf/ed2/book/HIG.Visual2.html 中指定的 Java 外观设计原则。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.LayoutStyle.ComponentPlacement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.LayoutStyle.ComponentPlacement
的使用

使用 LayoutStyle.ComponentPlacement 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 LayoutStyle.ComponentPlacement 的使用

返回 LayoutStyle.ComponentPlacement 的 javax.swing 中的方法
static LayoutStyle.ComponentPlacement | LayoutStyle.ComponentPlacement.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static LayoutStyle.ComponentPlacement[] | LayoutStyle.ComponentPlacement.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 LayoutStyle.ComponentPlacement 的 javax.swing 中的方法
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type) 添加一个表示两个组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max) 添加一个表示两个组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type) 添加一个表示两个距离最近的组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type, int pref, int max) 添加一个表示两个距离最近的组件之间首选间隙的元素。
abstract int | LayoutStyle.getPreferredGap(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent) 返回两个组件之间使用的空格的数量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.ListCellRenderer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ListCellRenderer
的使用

使用 ListCellRenderer 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ListCellRenderer 的使用

实现 ListCellRenderer 的 javax.swing 中的类
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。

声明为 ListCellRenderer 的 javax.swing 中的字段
protected  ListCellRenderer JComboBox.renderer
此受保护字段是特定于实现的。

返回 ListCellRenderer 的 javax.swing 中的方法
ListCellRenderer | JList.getCellRenderer() 返回负责绘制列表项的对象。
ListCellRenderer | JComboBox.getRenderer() 返回用于显示 JComboBox 字段中所选项的渲染器。

参数类型为 ListCellRenderer 的 javax.swing 中的方法
void | JList.setCellRenderer(ListCellRenderer cellRenderer) 设置用于绘制列表中每个单元的委托。
void | JComboBox.setRenderer(ListCellRenderer aRenderer) 设置渲染器，该渲染器用于绘制列表项和从 JComboBox 字段的列表中选择的项。

javax.swing.plaf.basic 中 ListCellRenderer 的使用

实现 ListCellRenderer 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。

返回 ListCellRenderer 的 javax.swing.plaf.basic 中的方法
protected  ListCellRenderer BasicComboBoxUI.createRenderer()
创建将在不可编辑的组合框中使用的默认渲染器。

参数类型为 ListCellRenderer 的 javax.swing.plaf.basic 中的方法
protected  void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。

javax.swing.plaf.metal 中 ListCellRenderer 的使用

实现 ListCellRenderer 的 javax.swing.plaf.metal 中的类
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.ListModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ListModel
的使用

使用 ListModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ListModel 的使用

javax.swing 中 ListModel 的子接口
interface | ComboBoxModel 用于组合框的数据模型。
interface | MutableComboBoxModel ComboBoxModel 的可变版本。

实现 ListModel 的 javax.swing 中的类
class | AbstractListModel 该数据模型的抽象定义提供一个带内容的 List。
class | DefaultComboBoxModel 组合框的默认模型。
class | DefaultListModel 此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。

返回 ListModel 的 javax.swing 中的方法
 ListModel JList.getModel()
返回保存由 JList 组件显示的项列表的数据模型。

参数类型为 ListModel 的 javax.swing 中的方法
 void JList.setModel(ListModel model)
设置表示列表内容或列表“值”的模型，通知属性更改侦听器，然后清除列表选择。

参数类型为 ListModel 的 javax.swing 中的构造方法
JList(ListModel dataModel)
根据指定的非 null 模型构造一个显示元素的 JList。

javax.swing.plaf.basic 中 ListModel 的使用

实现 ListModel 的 javax.swing.plaf.basic 中的类
 class BasicDirectoryModel
文件列表的基本实现。

参数类型为 ListModel 的 javax.swing.plaf.basic 中的方法
protected  void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。

javax.swing.plaf.metal 中 ListModel 的使用

实现 ListModel 的 javax.swing.plaf.metal 中的类
protected class | MetalFileChooserUI.DirectoryComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.ListSelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ListSelectionModel
的使用

使用 ListSelectionModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 ListSelectionModel 的使用

实现 ListSelectionModel 的 javax.swing 中的类
 class DefaultListSelectionModel
列表选择的默认数据模型。

声明为 ListSelectionModel 的 javax.swing 中的字段
protected  ListSelectionModel JTable.selectionModel
表的 ListSelectionModel，用来追踪行选择。

返回 ListSelectionModel 的 javax.swing 中的方法
protected ListSelectionModel | JTable.createDefaultSelectionModel() 返回默认的选择模型对象，它是一个 DefaultListSelectionModel。
protected ListSelectionModel | JList.createSelectionModel() 返回一个 DefaultListSelectionModel 实例；在构造期间调用此方法初始化列表的选择模型属性。
ListSelectionModel | JTable.getSelectionModel() 返回用来维持行选择状态的 ListSelectionModel。
ListSelectionModel | JList.getSelectionModel() 返回当前选择模型。

参数类型为 ListSelectionModel 的 javax.swing 中的方法
void | JTable.setSelectionModel(ListSelectionModel newModel) 将此表的行选择模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
void | JList.setSelectionModel(ListSelectionModel selectionModel) 将列表的 selectionModel 设置为非 null 的 ListSelectionModel 实现。

参数类型为 ListSelectionModel 的 javax.swing 中的构造方法
JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和选择模型 sm 对其进行初始化。

javax.swing.plaf.basic 中 ListSelectionModel 的使用

参数类型为 ListSelectionModel 的 javax.swing.plaf.basic 中的方法
protected  void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。

javax.swing.table 中 ListSelectionModel 的使用

声明为 ListSelectionModel 的 javax.swing.table 中的字段
protected  ListSelectionModel DefaultTableColumnModel.selectionModel
跟踪列选择的模型

返回 ListSelectionModel 的 javax.swing.table 中的方法
protected ListSelectionModel | DefaultTableColumnModel.createSelectionModel() 创建新的默认列表选择模型。
ListSelectionModel | DefaultTableColumnModel.getSelectionModel() 返回用来维护列选择状态的 ListSelectionModel。
ListSelectionModel | TableColumnModel.getSelectionModel() 返回当前的选择模型。

参数类型为 ListSelectionModel 的 javax.swing.table 中的方法
void | DefaultTableColumnModel.setSelectionModel(ListSelectionModel newModel) 将此 TableColumnModel 的选择模型设置为 newModel，并为来自新选择模型的侦听器通知注册它。
void | TableColumnModel.setSelectionModel(ListSelectionModel newModel) 设置选择模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.LookAndFeel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.LookAndFeel
的使用

使用 LookAndFeel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing 中 LookAndFeel 的使用

返回 LookAndFeel 的 javax.swing 中的方法
static LookAndFeel[] | UIManager.getAuxiliaryLookAndFeels() 返回辅助外观的列表（可以为 null）。
static LookAndFeel | UIManager.getLookAndFeel() 返回当前外观或 null。

参数类型为 LookAndFeel 的 javax.swing 中的方法
static void | UIManager.addAuxiliaryLookAndFeel(LookAndFeel laf) 将 LookAndFeel 添加到辅助外观的列表中。
static boolean | UIManager.removeAuxiliaryLookAndFeel(LookAndFeel laf) 从辅助外观列表移除一个 LookAndFeel。
static void | UIManager.setLookAndFeel(LookAndFeel newLookAndFeel) 将当前外观设置为 newLookAndFeel。

javax.swing.plaf.basic 中 LookAndFeel 的使用

javax.swing.plaf.basic 中 LookAndFeel 的子类
 class BasicLookAndFeel
为 Swing 创建外观时要使用的基类。

javax.swing.plaf.metal 中 LookAndFeel 的使用

javax.swing.plaf.metal 中 LookAndFeel 的子类
 class MetalLookAndFeel
Java 外观，也称为 Metal。

javax.swing.plaf.multi 中 LookAndFeel 的使用

javax.swing.plaf.multi 中 LookAndFeel 的子类
 class MultiLookAndFeel
多路外观允许同时将多个 UI 与一个组件相关联。

javax.swing.plaf.synth 中 LookAndFeel 的使用

javax.swing.plaf.synth 中 LookAndFeel 的子类
 class SynthLookAndFeel
SynthLookAndFeel 提供创建定制外观的基础。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.MenuElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.MenuElement
的使用

使用 MenuElement 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 MenuElement 的使用

实现 MenuElement 的 javax.swing 中的类
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。

返回 MenuElement 的 javax.swing 中的方法
MenuElement[] | MenuSelectionManager.getSelectedPath() 返回当前选择菜单项的路径
MenuElement[] | JPopupMenu.getSubElements() 返回 MenuElement 组成的数组，包含此菜单组件的子菜单。
MenuElement[] | JMenuBar.getSubElements() 实现为 MenuElement（返回此菜单栏中的菜单）。
MenuElement[] | JMenu.getSubElements() 返回由 MenuElement 组成的数组，其中包含此菜单组件的子菜单。
MenuElement[] | JMenuItem.getSubElements() 此方法返回包含此菜单组件的子菜单组件的数组。
MenuElement[] | MenuElement.getSubElements() 此方法应返回一个包含接收菜单元素的子元素的数组

参数类型为 MenuElement 的 javax.swing 中的方法
void | JPopupMenu.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | JMenuBar.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | JMenuItem.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | MenuElement.processKeyEvent(KeyEvent event, MenuElement[] path, MenuSelectionManager manager) 处理键事件。
void | JPopupMenu.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 要求此方法遵守 MenuElement 接口，但它没有被实现。
void | JMenuBar.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | JMenuItem.processMouseEvent(MouseEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的鼠标事件并更改菜单选择。
void | MenuElement.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 处理鼠标事件。
void | MenuSelectionManager.setSelectedPath(MenuElement[] path) 更改菜单层次结构中的选项。

javax.swing.event 中 MenuElement 的使用

返回 MenuElement 的 javax.swing.event 中的方法
MenuElement[] | MenuDragMouseEvent.getPath() 返回选定菜单项所在的路径。
MenuElement[] | MenuKeyEvent.getPath() 返回到达此事件引用的菜单项的路径。

参数类型为 MenuElement 的 javax.swing.event 中的构造方法
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuKeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuKeyEvent 对象。

javax.swing.plaf.basic 中 MenuElement 的使用

实现 MenuElement 的 javax.swing.plaf.basic 中的类
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。

返回 MenuElement 的 javax.swing.plaf.basic 中的方法
 MenuElement[] BasicMenuItemUI.getPath()

参数类型为 MenuElement 的 javax.swing.plaf.basic 中的方法
void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)

javax.swing.plaf.metal 中 MenuElement 的使用

实现 MenuElement 的 javax.swing.plaf.metal 中的类
 class MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.MenuSelectionManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.MenuSelectionManager
的使用

使用 MenuSelectionManager 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 MenuSelectionManager 的使用

返回 MenuSelectionManager 的 javax.swing 中的方法
static MenuSelectionManager MenuSelectionManager.defaultManager()
返回默认菜单选项管理器。

参数类型为 MenuSelectionManager 的 javax.swing 中的方法
void | JPopupMenu.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | JMenuBar.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | JMenuItem.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | MenuElement.processKeyEvent(KeyEvent event, MenuElement[] path, MenuSelectionManager manager) 处理键事件。
void | JPopupMenu.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 要求此方法遵守 MenuElement 接口，但它没有被实现。
void | JMenuBar.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | JMenuItem.processMouseEvent(MouseEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的鼠标事件并更改菜单选择。
void | MenuElement.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 处理鼠标事件。

javax.swing.event 中 MenuSelectionManager 的使用

返回 MenuSelectionManager 的 javax.swing.event 中的方法
MenuSelectionManager | MenuDragMouseEvent.getMenuSelectionManager() 返回当前菜单选项管理器。
MenuSelectionManager | MenuKeyEvent.getMenuSelectionManager() 返回当前菜单选项管理器。

参数类型为 MenuSelectionManager 的 javax.swing.event 中的构造方法
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuKeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuKeyEvent 对象。

javax.swing.plaf.basic 中 MenuSelectionManager 的使用

参数类型为 MenuSelectionManager 的 javax.swing.plaf.basic 中的方法
protected void | BasicMenuItemUI.doClick(MenuSelectionManager msm) 要激活菜单项时调用此方法。
void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.MutableComboBoxModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.MutableComboBoxModel
的使用

使用 MutableComboBoxModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 MutableComboBoxModel 的使用

实现 MutableComboBoxModel 的 javax.swing 中的类
 class DefaultComboBoxModel
组合框的默认模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.OverlayLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.OverlayLayout
的使用

没有 javax.swing.OverlayLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.Popup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Popup
的使用

使用 Popup 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 Popup 的使用

返回 Popup 的 javax.swing 中的方法
 Popup PopupFactory.getPopup(Component owner, Component contents, int x, int y)
为包含 Component contents 的 Component owner 创建 Popup。

javax.swing.plaf 中 Popup 的使用

返回 Popup 的 javax.swing.plaf 中的方法
 Popup PopupMenuUI.getPopup(JPopupMenu popup, int x, int y)
返回将负责显示 JPopupMenu 的 Popup。

javax.swing.plaf.multi 中 Popup 的使用

返回 Popup 的 javax.swing.plaf.multi 中的方法
 Popup MultiPopupMenuUI.getPopup(JPopupMenu a, int b, int c)
在由此对象处理的每个 UI 上调用 getPopup 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.PopupFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.PopupFactory
的使用

使用 PopupFactory 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 PopupFactory 的使用

返回 PopupFactory 的 javax.swing 中的方法
static PopupFactory PopupFactory.getSharedInstance()
返回共享 PopupFactory，它可用于获取 Popup。

参数类型为 PopupFactory 的 javax.swing 中的方法
static void PopupFactory.setSharedInstance(PopupFactory factory)
设置用于获取 Popup 的 PopupFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ProgressMonitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ProgressMonitor
的使用

使用 ProgressMonitor 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 ProgressMonitor 的使用

返回 ProgressMonitor 的 javax.swing 中的方法
 ProgressMonitor ProgressMonitorInputStream.getProgressMonitor()
获取此流使用的 ProgressMonitor 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ProgressMonitor.AccessibleProgressMonitor
的使用

没有 javax.swing.ProgressMonitor.AccessibleProgressMonitor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ProgressMonitorInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ProgressMonitorInputStream
的使用

没有 javax.swing.ProgressMonitorInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.Renderer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.Renderer
的使用

没有 javax.swing.Renderer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.RepaintManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RepaintManager
的使用

使用 RepaintManager 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RepaintManager 的使用

返回 RepaintManager 的 javax.swing 中的方法
static RepaintManager | RepaintManager.currentManager(Component c) 在给定 Component 的情况下，返回调用线程的 RepaintManager。
static RepaintManager | RepaintManager.currentManager(JComponent c) 在给定 JComponent 的情况下，返回调用线程的 RepaintManager。

参数类型为 RepaintManager 的 javax.swing 中的方法
static void RepaintManager.setCurrentManager(RepaintManager aRepaintManager)
设置用于调用线程的 RepaintManager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.RootPaneContainer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.RootPaneContainer
的使用

使用 RootPaneContainer 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 RootPaneContainer 的使用

实现 RootPaneContainer 的 javax.swing 中的类
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JDialog 创建对话框窗口的主要类。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

javax.swing.plaf.basic 中 RootPaneContainer 的使用

返回 RootPaneContainer 的 javax.swing.plaf.basic 中的方法
protected  RootPaneContainer BasicToolBarUI.createFloatingWindow(JToolBar toolbar)
创建将工具栏拖出其容器后包含该工具栏的窗口

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.RowFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RowFilter
的使用

使用 RowFilter 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RowFilter 的使用

返回 RowFilter 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
static
<M,I> RowFilter<M,I>
RowFilter.dateFilter(RowFilter.ComparisonType type, Date date, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Date 值的条目。
 RowFilter<? super M,? super I> DefaultRowSorter.getRowFilter()
返回用于确定哪些行（如果有）应该在视图中隐藏的过滤器。
static
<M,I> RowFilter<M,I>
RowFilter.notFilter(RowFilter<M,I> filter)
返回一个 RowFilter，它包含提供的过滤器不包含的条目。
static
<M,I> RowFilter<M,I>
RowFilter.numberFilter(RowFilter.ComparisonType type, Number number, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Number 值的条目。
static
<M,I> RowFilter<M,I>
RowFilter.orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
static
<M,I> RowFilter<M,I>
RowFilter.regexFilter(String regex, int... indices)
返回一个 RowFilter，它使用正则表达式确定要包含哪些条目。

参数类型为 RowFilter 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.notFilter(RowFilter<M,I> filter)
返回一个 RowFilter，它包含提供的过滤器不包含的条目。
 void DefaultRowSorter.setRowFilter(RowFilter<? super M,? super I> filter)
设置用于确定哪些行（如果有）应该在视图中隐藏的过滤器。

类型变量类型为 RowFilter 的 javax.swing 中的方法参数
static
<M,I> RowFilter<M,I>
RowFilter.andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
static
<M,I> RowFilter<M,I>
RowFilter.orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.RowFilter.ComparisonType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RowFilter.ComparisonType
的使用

使用 RowFilter.ComparisonType 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RowFilter.ComparisonType 的使用

返回 RowFilter.ComparisonType 的 javax.swing 中的方法
static RowFilter.ComparisonType | RowFilter.ComparisonType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RowFilter.ComparisonType[] | RowFilter.ComparisonType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 RowFilter.ComparisonType 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.dateFilter(RowFilter.ComparisonType type, Date date, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Date 值的条目。
static
<M,I> RowFilter<M,I>
RowFilter.numberFilter(RowFilter.ComparisonType type, Number number, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Number 值的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.RowFilter.Entry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RowFilter.Entry
的使用

使用 RowFilter.Entry 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RowFilter.Entry 的使用

参数类型为 RowFilter.Entry 的 javax.swing 中的方法
abstract  boolean RowFilter.include(RowFilter.Entry<? extends M,? extends I> entry)
如果应该显示指定的条目，则返回 true；如果应该隐藏该条目，则返回 false。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.RowSorter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RowSorter
的使用

使用 RowSorter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 RowSorter 的使用

javax.swing 中 RowSorter 的子类
 class DefaultRowSorter<M,I>
RowSorter 的一个实现，它围绕基于网格的数据模型提供排序和过滤操作。

返回 RowSorter 的 javax.swing 中的方法
 RowSorter<? extends TableModel> JTable.getRowSorter()
返回负责排序的对象。

参数类型为 RowSorter 的 javax.swing 中的方法
 void JTable.setRowSorter(RowSorter<? extends TableModel> sorter)
设置 RowSorter。

javax.swing.event 中 RowSorter 的使用

返回 RowSorter 的 javax.swing.event 中的方法
 RowSorter RowSorterEvent.getSource()
返回以 RowSorter 形式表示的事件源。

参数类型为 RowSorter 的 javax.swing.event 中的构造方法
RowSorterEvent(RowSorter source)
创建类型为 SORT_ORDER_CHANGED 的 RowSorterEvent。
RowSorterEvent(RowSorter source, RowSorterEvent.Type type, int[] previousRowIndexToModel)
创建一个 RowSorterEvent。

javax.swing.table 中 RowSorter 的使用

javax.swing.table 中 RowSorter 的子类
 class TableRowSorter<M extends TableModel>
RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.RowSorter.SortKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RowSorter.SortKey
的使用

使用 RowSorter.SortKey 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RowSorter.SortKey 的使用

返回变量类型为 RowSorter.SortKey 的类型的 javax.swing 中的方法
List<? extends RowSorter.SortKey> | DefaultRowSorter.getSortKeys() 返回当前排序键。
abstract List<? extends RowSorter.SortKey> | RowSorter.getSortKeys() 返回当前排序键。

类型变量类型为 RowSorter.SortKey 的 javax.swing 中的方法参数
void | DefaultRowSorter.setSortKeys(List<? extends RowSorter.SortKey> sortKeys) 设置排序键。
abstract void | RowSorter.setSortKeys(List<? extends RowSorter.SortKey> keys) 设置当前排序键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.Scrollable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.Scrollable
的使用

使用 Scrollable 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 Scrollable 的使用

实现 Scrollable 的 javax.swing 中的类
class | JEditorPane 可编辑各种内容的文本组件。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JTree 将分层数据集显示为轮廓的控件。

javax.swing.text 中 Scrollable 的使用

实现 Scrollable 的 javax.swing.text 中的类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

javax.swing.tree 中 Scrollable 的使用

实现 Scrollable 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor.DefaultTextField
不提供任何编辑器时所使用的 TextField。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.ScrollPaneConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ScrollPaneConstants
的使用

使用 ScrollPaneConstants 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ScrollPaneConstants 的使用

实现 ScrollPaneConstants 的 javax.swing 中的类
class | JScrollPane 提供轻量级组件的 scrollable 视图。
class | ScrollPaneLayout JScrollPane 使用的布局管理器。
static class | ScrollPaneLayout.UIResource ScrollPaneLayout 的 UI 资源版本。

javax.swing.plaf.basic 中 ScrollPaneConstants 的使用

实现 ScrollPaneConstants 的 javax.swing.plaf.basic 中的类
 class BasicScrollPaneUI
ScrollPaneUI 的默认 L&F 实现。

javax.swing.plaf.metal 中 ScrollPaneConstants 的使用

实现 ScrollPaneConstants 的 javax.swing.plaf.metal 中的类
 class MetalScrollPaneUI
ScrollPaneUI 的 Metal L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ScrollPaneLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ScrollPaneLayout
的使用

使用 ScrollPaneLayout 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 ScrollPaneLayout 的使用

javax.swing 中 ScrollPaneLayout 的子类
static class ScrollPaneLayout.UIResource
ScrollPaneLayout 的 UI 资源版本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ScrollPaneLayout.UIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ScrollPaneLayout.UIResource
的使用

没有 javax.swing.ScrollPaneLayout.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.SingleSelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.SingleSelectionModel
的使用

使用 SingleSelectionModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SingleSelectionModel 的使用

实现 SingleSelectionModel 的 javax.swing 中的类
 class DefaultSingleSelectionModel
SingleSelectionModel 的一般实现。

声明为 SingleSelectionModel 的 javax.swing 中的字段
protected  SingleSelectionModel JTabbedPane.model
默认的选择模型。

返回 SingleSelectionModel 的 javax.swing 中的方法
SingleSelectionModel | JTabbedPane.getModel() 返回与此选项卡窗格关联的模型。
SingleSelectionModel | JPopupMenu.getSelectionModel() 返回处理单个选择的模型对象。
SingleSelectionModel | JMenuBar.getSelectionModel() 返回处理单个选择的模型对象。

参数类型为 SingleSelectionModel 的 javax.swing 中的方法
void | JTabbedPane.setModel(SingleSelectionModel model) 设置要用于此选项卡窗格的模型。
void | JPopupMenu.setSelectionModel(SingleSelectionModel model) 设置处理单个选择的模型对象。
void | JMenuBar.setSelectionModel(SingleSelectionModel model) 设置处理单个选择的模型对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SizeRequirements 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SizeRequirements
的使用

使用 SizeRequirements 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 SizeRequirements 的使用

返回 SizeRequirements 的 javax.swing 中的方法
static SizeRequirements | SizeRequirements.getAlignedSizeRequirements(SizeRequirements[] children) 确定对齐一组组件所需的总空间。
static SizeRequirements | SizeRequirements.getTiledSizeRequirements(SizeRequirements[] children) 确定端到端放置一组组件需要占用的总空间。

参数类型为 SizeRequirements 的 javax.swing 中的方法
static int[] | SizeRequirements.adjustSizes(int delta, SizeRequirements[] children) 按给定总量调整指定的大小数组。
static void | SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans) 创建一组偏移量/区域对，指定如何按照指定对齐方式对一组组件进行布局。
static void | SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans) 创建一组偏移量/区域对，指定如何按照指定对齐方式对一组组件进行布局。
static void | SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean normal) 创建一组偏移量/区域对，指定如何按指定对齐方式对一组组件进行布局。
static void | SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean normal) 创建一组偏移量/区域对，指定如何按指定对齐方式对一组组件进行布局。
static void | SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans) 创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
static void | SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans) 创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
static void | SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean forward) 创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
static void | SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean forward) 创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
static SizeRequirements | SizeRequirements.getAlignedSizeRequirements(SizeRequirements[] children) 确定对齐一组组件所需的总空间。
static SizeRequirements | SizeRequirements.getTiledSizeRequirements(SizeRequirements[] children) 确定端到端放置一组组件需要占用的总空间。

javax.swing.text 中 SizeRequirements 的使用

返回 SizeRequirements 的 javax.swing.text 中的方法
protected SizeRequirements | BoxView.baselineRequirements(int axis, SizeRequirements r) 通过检查每个子视图的大小计算此 BoxView 的大小要求。
protected SizeRequirements | BoxView.calculateMajorAxisRequirements(int axis, SizeRequirements r) 计算主轴 axis 的大小要求。
protected SizeRequirements | BoxView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算辅轴 axis 的大小要求。
protected SizeRequirements | FlowView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算沿辅轴的要求。
protected SizeRequirements | TableView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算辅轴的所需大小。

参数类型为 SizeRequirements 的 javax.swing.text 中的方法
protected SizeRequirements | BoxView.baselineRequirements(int axis, SizeRequirements r) 通过检查每个子视图的大小计算此 BoxView 的大小要求。
protected SizeRequirements | BoxView.calculateMajorAxisRequirements(int axis, SizeRequirements r) 计算主轴 axis 的大小要求。
protected SizeRequirements | BoxView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算辅轴 axis 的大小要求。
protected SizeRequirements | FlowView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算沿辅轴的要求。
protected SizeRequirements | TableView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算辅轴的所需大小。
protected void | TableView.layoutColumns(int targetSpan, int[] offsets, int[] spans, SizeRequirements[] reqs) 布局列，使其符合给定的目标跨距。

javax.swing.text.html 中 SizeRequirements 的使用

返回 SizeRequirements 的 javax.swing.text.html 中的方法
protected SizeRequirements | BlockView.calculateMajorAxisRequirements(int axis, SizeRequirements r) 计算块沿主轴的要求（即沿其平铺的轴）。
protected SizeRequirements | BlockView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算块沿辅轴的要求（即垂直沿其平铺的轴的轴）。
protected SizeRequirements | ParagraphView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算段落沿辅轴的要求。

参数类型为 SizeRequirements 的 javax.swing.text.html 中的方法
protected SizeRequirements | BlockView.calculateMajorAxisRequirements(int axis, SizeRequirements r) 计算块沿主轴的要求（即沿其平铺的轴）。
protected SizeRequirements | BlockView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算块沿辅轴的要求（即垂直沿其平铺的轴的轴）。
protected SizeRequirements | ParagraphView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算段落沿辅轴的要求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SizeSequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SizeSequence
的使用

没有 javax.swing.SizeSequence 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SortingFocusTraversalPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SortingFocusTraversalPolicy
的使用

使用 SortingFocusTraversalPolicy 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SortingFocusTraversalPolicy 的使用

javax.swing 中 SortingFocusTraversalPolicy 的子类
 class LayoutFocusTraversalPolicy
根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SortOrder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SortOrder
的使用

使用 SortOrder 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SortOrder 的使用

返回 SortOrder 的 javax.swing 中的方法
SortOrder | RowSorter.SortKey.getSortOrder() 返回列的排序顺序。
static SortOrder | SortOrder.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SortOrder[] | SortOrder.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 SortOrder 的 javax.swing 中的构造方法
RowSorter.SortKey(int column, SortOrder sortOrder)
使用指定的排序顺序创建指定列的 SortKey。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SpinnerDateModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SpinnerDateModel
的使用

使用 SpinnerDateModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SpinnerDateModel 的使用

返回 SpinnerDateModel 的 javax.swing 中的方法
 SpinnerDateModel JSpinner.DateEditor.getModel()
返回微调器祖先的 SpinnerDateModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SpinnerListModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SpinnerListModel
的使用

使用 SpinnerListModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SpinnerListModel 的使用

返回 SpinnerListModel 的 javax.swing 中的方法
 SpinnerListModel JSpinner.ListEditor.getModel()
返回 spinner 祖先的 SpinnerNumberModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.SpinnerModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.SpinnerModel
的使用

使用 SpinnerModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SpinnerModel 的使用

实现 SpinnerModel 的 javax.swing 中的类
class | AbstractSpinnerModel 此类提供 SpinnerModel 接口的 ChangeListener 部分，该接口应该适用于最具体的 SpinnerModel 实现。
class | SpinnerDateModel Date 序列的一个 SpinnerModel。
class | SpinnerListModel 其值由数组或 List 定义的 SpinnerModel 的简单实现。
class | SpinnerNumberModel 用于数字序列的 SpinnerModel。

返回 SpinnerModel 的 javax.swing 中的方法
 SpinnerModel JSpinner.getModel()
返回定义此 spinner 值序列的 SpinnerModel。

参数类型为 SpinnerModel 的 javax.swing 中的方法
protected JComponent | JSpinner.createEditor(SpinnerModel model) 此方法由构造方法调用，以创建显示序列当前值的 JComponent。
void | JSpinner.setModel(SpinnerModel model) 更改表示此 spinner 值的模型。

参数类型为 SpinnerModel 的 javax.swing 中的构造方法
JSpinner(SpinnerModel model)
构造具有一对 next/previous 按钮和 SpinnerModel 编辑器的完整 spinner。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SpinnerNumberModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SpinnerNumberModel
的使用

使用 SpinnerNumberModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SpinnerNumberModel 的使用

返回 SpinnerNumberModel 的 javax.swing 中的方法
 SpinnerNumberModel JSpinner.NumberEditor.getModel()
返回 spinner 祖先的 SpinnerNumberModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.Spring 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Spring
的使用

使用 Spring 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 Spring 的使用

返回 Spring 的 javax.swing 中的方法
static Spring Spring.constant(int pref)
返回一个 strut -- 一个其 minimum、preferred 和 maximum 值每个都有值 pref 的 spring。
static Spring Spring.constant(int min, int pref, int max)
返回一个其 minimum、preferred 和 maximum 值具有以下值的 spring：分别是 min、pref 和 max。
 Spring SpringLayout.Constraints.getConstraint(String edgeName)
返回指定边的值，它可以为一个派生值，甚至可以为 null。
 Spring SpringLayout.getConstraint(String edgeName, Component c)
返回控制该组件指定边及其父级的顶边或左边之间距离的 spring。
 Spring SpringLayout.Constraints.getHeight()
返回 height 属性的值。
 Spring SpringLayout.Constraints.getWidth()
返回 width 属性的值。
 Spring SpringLayout.Constraints.getX()
返回 x 属性的值。
 Spring SpringLayout.Constraints.getY()
返回 y 属性的值。
static Spring Spring.height(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的高度定义。
static Spring Spring.max(Spring s1, Spring s2)
返回 max(s1, s2)：一个其值始终大于（或等于）s1 加 s2 的值的 spring。
static Spring Spring.minus(Spring s)
返回 -s：一个以与 s 相反方向运行的 spring。
static Spring Spring.scale(Spring s, float factor)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性都是参数 spring s 的属性的倍数。
static Spring Spring.sum(Spring s1, Spring s2)
返回 s1+s2：一个连续表示 s1 和 s2 的 spring。
static Spring Spring.width(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的宽度定义。

参数类型为 Spring 的 javax.swing 中的方法
static Spring Spring.max(Spring s1, Spring s2)
返回 max(s1, s2)：一个其值始终大于（或等于）s1 加 s2 的值的 spring。
static Spring Spring.minus(Spring s)
返回 -s：一个以与 s 相反方向运行的 spring。
 void SpringLayout.putConstraint(String e1, Component c1, Spring s, String e2, Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2。
static Spring Spring.scale(Spring s, float factor)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性都是参数 spring s 的属性的倍数。
 void SpringLayout.Constraints.setConstraint(String edgeName, Spring s)
设置控制指定边的 spring。
 void SpringLayout.Constraints.setHeight(Spring height)
设置 height 属性，该属性控制组件的高度。
 void SpringLayout.Constraints.setWidth(Spring width)
设置 width 属性，该属性控制组件的宽度。
 void SpringLayout.Constraints.setX(Spring x)
设置 x 属性，该属性控制组件位置的 x 值。
 void SpringLayout.Constraints.setY(Spring y)
设置 y 属性，该属性控制组件位置的 y 值。
static Spring Spring.sum(Spring s1, Spring s2)
返回 s1+s2：一个连续表示 s1 和 s2 的 spring。

参数类型为 Spring 的 javax.swing 中的构造方法
SpringLayout.Constraints(Spring x, Spring y)
创建一个指定了 x 和 y 属性值的 Constraints 对象。
SpringLayout.Constraints(Spring x, Spring y, Spring width, Spring height)
创建一个指定了 x、y、width 和 height 属性值的 Constraints 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SpringLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SpringLayout
的使用

没有 javax.swing.SpringLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SpringLayout.Constraints 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SpringLayout.Constraints
的使用

使用 SpringLayout.Constraints 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SpringLayout.Constraints 的使用

返回 SpringLayout.Constraints 的 javax.swing 中的方法
 SpringLayout.Constraints SpringLayout.getConstraints(Component c)
返回指定组件的约束。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.SwingConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.SwingConstants
的使用

使用 SwingConstants 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing 中的类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuItem 菜单中的项的实现。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | SwingUtilities Swing 实用方法的集合。

javax.swing.plaf.basic 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.plaf.basic 中的类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
class | BasicScrollBarUI 基本外观的 ScrollBarUI 的实现
class | BasicTabbedPaneUI TabbedPaneUI 的基本 L&F 实现。
class | BasicToolBarUI ToolBarUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.plaf.metal 中的类
static class | MetalBorders.ToolBarBorder
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalScrollBarUI ScrollBarUI 的 Metal 外观实现
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。
class | MetalTabbedPaneUI BasicTabbedPaneUI 的 Metal 子类。
class | MetalToolBarUI ToolBarUI 的 Metal 外观实现。

javax.swing.table 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.table 中的类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。

javax.swing.text 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.text 中的类
class | AsyncBoxView 异步执行布局处理的框。
class | BoxView 一个视图，它通过沿某轴平铺将其子级排列到框形状中。
class | ComponentView 实现视图接口的组件装饰器。
class | CompositeView CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。
class | FieldView 扩展多行纯文本视图，使其适合单行编辑器视图。
class | FlowView 试图将其子级流入某个部分受约束的空间的视图。
class | GlyphView GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
class | IconView 实现视图接口的图标修饰符。
class | LabelView LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。
class | ParagraphView 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
class | PasswordView 实现适用于 JPasswordField UI 实现的视图。
class | PlainView 实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。
class | TableView 为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。
class | TableView.TableRow 以行为中心的表格中的行视图。
class | View View 类是 text 包极为重要的一部分。
class | WrappedPlainView 进行换行的纯文本（仅有一种字体和颜色的文本）视图。
class | ZoneView ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

javax.swing.text.html 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.text.html 中的类
class | BlockView 用来显示具有 CSS 规范的块（作为一个框）的视图实现。
class | FormView 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
class | ImageView 图像视图，用于支持 HTML <IMG> 标记。
class | InlineView 显示基于 css 属性的 inline element 样式。
class | ListView 用于显示 html 列表的视图实现。
class | ObjectView 实现 <object> 元素视图接口的组件装饰符。

javax.swing.tree 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.tree 中的类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellRenderer 显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SwingUtilities 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SwingUtilities
的使用

没有 javax.swing.SwingUtilities 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SwingWorker 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SwingWorker
的使用

没有 javax.swing.SwingWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.SwingWorker.StateValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SwingWorker.StateValue
的使用

使用 SwingWorker.StateValue 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SwingWorker.StateValue 的使用

返回 SwingWorker.StateValue 的 javax.swing 中的方法
SwingWorker.StateValue | SwingWorker.getState() 返回 SwingWorker 状态绑定属性。
static SwingWorker.StateValue | SwingWorker.StateValue.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SwingWorker.StateValue[] | SwingWorker.StateValue.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.Timer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Timer
的使用

使用 Timer 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing.plaf.basic 中 Timer 的使用

声明为 Timer 的 javax.swing.plaf.basic 中的字段
protected Timer | BasicComboPopup.autoscrollTimer 此受保护字段是特定于实现的。
protected Timer | BasicSliderUI.scrollTimer
protected Timer | BasicScrollBarUI.scrollTimer
protected Timer | BasicTreeUI.ComponentHandler.timer 在滚动窗格中调整滚动条时使用的 Timer。

javax.swing.tree 中 Timer 的使用

声明为 Timer 的 javax.swing.tree 中的字段
protected  Timer DefaultTreeCellEditor.timer
在启动编辑会话之前使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ToolTipManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ToolTipManager
的使用

使用 ToolTipManager 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 ToolTipManager 的使用

返回 ToolTipManager 的 javax.swing 中的方法
static ToolTipManager ToolTipManager.sharedInstance()
返回共享的 ToolTipManager 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ToolTipManager.insideTimerAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ToolTipManager.insideTimerAction
的使用

没有 javax.swing.ToolTipManager.insideTimerAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ToolTipManager.outsideTimerAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ToolTipManager.outsideTimerAction
的使用

没有 javax.swing.ToolTipManager.outsideTimerAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ToolTipManager.stillInsideTimerAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ToolTipManager.stillInsideTimerAction
的使用

没有 javax.swing.ToolTipManager.stillInsideTimerAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.TransferHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.TransferHandler
的使用

使用 TransferHandler 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 TransferHandler 的使用

返回 TransferHandler 的 javax.swing 中的方法
TransferHandler | JApplet.getTransferHandler() 获取 transferHandler 属性。
TransferHandler | JWindow.getTransferHandler() 获取 transferHandler 属性。
TransferHandler | JDialog.getTransferHandler() 获取 transferHandler 属性。
TransferHandler | JComponent.getTransferHandler() 获取 transferHandler 属性。
TransferHandler | JFrame.getTransferHandler() 获取 transferHandler 属性。

参数类型为 TransferHandler 的 javax.swing 中的方法
void | JApplet.setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。
void | JWindow.setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。
void | JDialog.setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。
void | JComponent.setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性；如果该组件不支持数据传输操作，则为 null。
void | JFrame.setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.TransferHandler.DropLocation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.TransferHandler.DropLocation
的使用

使用 TransferHandler.DropLocation 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 TransferHandler.DropLocation 的使用

javax.swing 中 TransferHandler.DropLocation 的子类
static class | JList.DropLocation TransferHandler.DropLocation 的一个子类，表示 JList 的放置位置 (drop location)。
static class | JTable.DropLocation TransferHandler.DropLocation 的一个子类，表示 JTable 的放置位置 (drop location)。
static class | JTree.DropLocation TransferHandler.DropLocation 的一个子类，表示 JTree 的放置位置 (drop location)。

返回 TransferHandler.DropLocation 的 javax.swing 中的方法
 TransferHandler.DropLocation TransferHandler.TransferSupport.getDropLocation()
此 TransferSupport 表示一个放置操作时，返回组件的当前放置位置（非 null）。

javax.swing.text 中 TransferHandler.DropLocation 的使用

javax.swing.text 中 TransferHandler.DropLocation 的子类
static class JTextComponent.DropLocation
表示 JTextComponent 的放置位置 (drop location)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.TransferHandler.TransferSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.TransferHandler.TransferSupport
的使用

使用 TransferHandler.TransferSupport 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 TransferHandler.TransferSupport 的使用

参数类型为 TransferHandler.TransferSupport 的 javax.swing 中的方法
boolean | TransferHandler.canImport(TransferHandler.TransferSupport support) 在拖放操作期间重复调用此方法，以允许开发人员配置传输的可接受性属性，并返回传输的可接受性；返回 true 值指示给定 TransferSupport（它包含该传输的所有细节）所表示的传输在当前是可以接受的，false 值指示拒绝该传输。
boolean | TransferHandler.importData(TransferHandler.TransferSupport support) 导致从剪贴板或拖放操作的传输。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.UIDefaults 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UIDefaults
的使用

使用 UIDefaults 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing 中 UIDefaults 的使用

返回 UIDefaults 的 javax.swing 中的方法
UIDefaults | LookAndFeel.getDefaults() 返回外观的默认值。
static UIDefaults | UIManager.getDefaults() 返回该默认值。
static UIDefaults | UIManager.getLookAndFeelDefaults() 从当前外观返回 UIDefaults，UIDefaults 在安装该外观时获得。

参数类型为 UIDefaults 的 javax.swing 中的方法
Object | UIDefaults.LazyValue.createValue(UIDefaults table) 创建从 UIDefaults 表中检索的实际值。
Object | UIDefaults.ActiveValue.createValue(UIDefaults table) 创建从 UIDefaults 表中检索的值。
Object | UIDefaults.ProxyLazyValue.createValue(UIDefaults table) 创建从 UIDefaults 表中检索的值。
Object | UIDefaults.LazyInputMap.createValue(UIDefaults table) 使用传入的绑定创建一个 InputMap。

javax.swing.plaf.basic 中 UIDefaults 的使用

返回 UIDefaults 的 javax.swing.plaf.basic 中的方法
 UIDefaults BasicLookAndFeel.getDefaults()
返回外观默认值。

参数类型为 UIDefaults 的 javax.swing.plaf.basic 中的方法
protected void | BasicLookAndFeel.initClassDefaults(UIDefaults table) 用从 uiClassID 到 ui 类的完全限定名称的映射关系填充 table。
protected void | BasicLookAndFeel.initComponentDefaults(UIDefaults table) 用基本外观的默认值填充 table。
protected void | BasicLookAndFeel.initSystemColorDefaults(UIDefaults table) 用系统颜色填充 table。
protected void | BasicLookAndFeel.loadSystemColors(UIDefaults table, String[] systemColors, boolean useNative) 用 systemColors 中的 name-color 对填充 table。

javax.swing.plaf.metal 中 UIDefaults 的使用

返回 UIDefaults 的 javax.swing.plaf.metal 中的方法
 UIDefaults MetalLookAndFeel.getDefaults()
返回外观的默认值。

参数类型为 UIDefaults 的 javax.swing.plaf.metal 中的方法
void | OceanTheme.addCustomEntriesToTable(UIDefaults table) 将此主题的自定义条目添加到默认表中。
void | MetalTheme.addCustomEntriesToTable(UIDefaults table) 将特定于此主题的值添加到默认表。
protected void | MetalLookAndFeel.initClassDefaults(UIDefaults table) 用从 uiClassID 到 ui 类完全限定名的映射关系填充 table。
protected void | MetalLookAndFeel.initComponentDefaults(UIDefaults table) 用 metal 的默认值填充 table。
protected void | MetalLookAndFeel.initSystemColorDefaults(UIDefaults table) 用系统颜色填充 table。

javax.swing.plaf.multi 中 UIDefaults 的使用

返回 UIDefaults 的 javax.swing.plaf.multi 中的方法
 UIDefaults MultiLookAndFeel.getDefaults()
创建、初始化并返回特定于外观的默认值。

javax.swing.plaf.synth 中 UIDefaults 的使用

返回 UIDefaults 的 javax.swing.plaf.synth 中的方法
 UIDefaults SynthLookAndFeel.getDefaults()
返回此 SynthLookAndFeel 的默认值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.UIDefaults.ActiveValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.UIDefaults.ActiveValue
的使用

没有 javax.swing.UIDefaults.ActiveValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.UIDefaults.LazyInputMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UIDefaults.LazyInputMap
的使用

没有 javax.swing.UIDefaults.LazyInputMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.UIDefaults.LazyValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.UIDefaults.LazyValue
的使用

使用 UIDefaults.LazyValue 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 UIDefaults.LazyValue 的使用

实现 UIDefaults.LazyValue 的 javax.swing 中的类
static class | UIDefaults.LazyInputMap LazyInputMap 将在其 createValue 方法中创建一个 InputMap。
static class | UIDefaults.ProxyLazyValue 此类提供一个可用于延迟加载要创建实例类的 LazyValue 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.UIDefaults.ProxyLazyValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UIDefaults.ProxyLazyValue
的使用

没有 javax.swing.UIDefaults.ProxyLazyValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.UIManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UIManager
的使用

没有 javax.swing.UIManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.UIManager.LookAndFeelInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UIManager.LookAndFeelInfo
的使用

使用 UIManager.LookAndFeelInfo 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 UIManager.LookAndFeelInfo 的使用

返回 UIManager.LookAndFeelInfo 的 javax.swing 中的方法
static UIManager.LookAndFeelInfo[] UIManager.getInstalledLookAndFeels()
返回表示当前可用的 LookAndFeel 实现的 LookAndFeelInfo 数组。

参数类型为 UIManager.LookAndFeelInfo 的 javax.swing 中的方法
static void | UIManager.installLookAndFeel(UIManager.LookAndFeelInfo info) 将指定的外观添加到可用外观的集合中。
static void | UIManager.setInstalledLookAndFeels(UIManager.LookAndFeelInfo[] infos) 设置可用外观的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.UnsupportedLookAndFeelException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UnsupportedLookAndFeelException
的使用

使用 UnsupportedLookAndFeelException 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 UnsupportedLookAndFeelException 的使用

抛出 UnsupportedLookAndFeelException 的 javax.swing 中的方法
static void | UIManager.setLookAndFeel(LookAndFeel newLookAndFeel) 将当前外观设置为 newLookAndFeel。
static void | UIManager.setLookAndFeel(String className) 使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.ViewportLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ViewportLayout
的使用

没有 javax.swing.ViewportLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.WindowConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.WindowConstants
的使用

使用 WindowConstants 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 WindowConstants 的使用

实现 WindowConstants 的 javax.swing 中的类
class | JDialog 创建对话框窗口的主要类。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.colorchooser (Java 2 Platform SE 6)

 javax.swing.colorchooser
接口
ColorSelectionModel
类
AbstractColorChooserPanel
ColorChooserComponentFactory
DefaultColorSelectionModel


类 javax.swing.colorchooser.AbstractColorChooserPanel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.colorchooser.AbstractColorChooserPanel
的使用

使用 AbstractColorChooserPanel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 AbstractColorChooserPanel 的使用

返回 AbstractColorChooserPanel 的 javax.swing 中的方法
AbstractColorChooserPanel[] | JColorChooser.getChooserPanels() 返回指定的颜色面板。
AbstractColorChooserPanel | JColorChooser.removeChooserPanel(AbstractColorChooserPanel panel) 移除指定的 Color Panel。

参数类型为 AbstractColorChooserPanel 的 javax.swing 中的方法
void | JColorChooser.addChooserPanel(AbstractColorChooserPanel panel) 将颜色选取器面板添加到颜色选取器。
AbstractColorChooserPanel | JColorChooser.removeChooserPanel(AbstractColorChooserPanel panel) 移除指定的 Color Panel。
void | JColorChooser.setChooserPanels(AbstractColorChooserPanel[] panels) 指定用于选取颜色值的 Color Panel。

javax.swing.colorchooser 中 AbstractColorChooserPanel 的使用

返回 AbstractColorChooserPanel 的 javax.swing.colorchooser 中的方法
static AbstractColorChooserPanel[] ColorChooserComponentFactory.getDefaultChooserPanels()

javax.swing.plaf.basic 中 AbstractColorChooserPanel 的使用

声明为 AbstractColorChooserPanel 的 javax.swing.plaf.basic 中的字段
protected  AbstractColorChooserPanel[] BasicColorChooserUI.defaultChoosers

返回 AbstractColorChooserPanel 的 javax.swing.plaf.basic 中的方法
protected  AbstractColorChooserPanel[] BasicColorChooserUI.createDefaultChoosers()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.colorchooser.ColorChooserComponentFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.colorchooser.ColorChooserComponentFactory
的使用

没有 javax.swing.colorchooser.ColorChooserComponentFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.colorchooser.ColorSelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.colorchooser.ColorSelectionModel
的使用

使用 ColorSelectionModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。

javax.swing 中 ColorSelectionModel 的使用

返回 ColorSelectionModel 的 javax.swing 中的方法
 ColorSelectionModel JColorChooser.getSelectionModel()
返回处理颜色选择的数据模型。

参数类型为 ColorSelectionModel 的 javax.swing 中的方法
 void JColorChooser.setSelectionModel(ColorSelectionModel newModel)
设置包含所选颜色的模型。

参数类型为 ColorSelectionModel 的 javax.swing 中的构造方法
JColorChooser(ColorSelectionModel model)
创建具有指定 ColorSelectionModel 颜色选取器窗格。

javax.swing.colorchooser 中 ColorSelectionModel 的使用

实现 ColorSelectionModel 的 javax.swing.colorchooser 中的类
 class DefaultColorSelectionModel
ColorSelectionModel 的一般实现。

返回 ColorSelectionModel 的 javax.swing.colorchooser 中的方法
 ColorSelectionModel AbstractColorChooserPanel.getColorSelectionModel()
返回选取器面板正在编辑的模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.colorchooser.DefaultColorSelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.colorchooser.DefaultColorSelectionModel
的使用

没有 javax.swing.colorchooser.DefaultColorSelectionModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.event (Java 2 Platform SE 6)

 javax.swing.event
接口
AncestorListener
CaretListener
CellEditorListener
ChangeListener
DocumentEvent
DocumentEvent.ElementChange
DocumentListener
HyperlinkListener
InternalFrameListener
ListDataListener
ListSelectionListener
MenuDragMouseListener
MenuKeyListener
MenuListener
MouseInputListener
PopupMenuListener
RowSorterListener
TableColumnModelListener
TableModelListener
TreeExpansionListener
TreeModelListener
TreeSelectionListener
TreeWillExpandListener
UndoableEditListener
类
AncestorEvent
CaretEvent
ChangeEvent
DocumentEvent.EventType
EventListenerList
HyperlinkEvent
HyperlinkEvent.EventType
InternalFrameAdapter
InternalFrameEvent
ListDataEvent
ListSelectionEvent
MenuDragMouseEvent
MenuEvent
MenuKeyEvent
MouseInputAdapter
PopupMenuEvent
RowSorterEvent
SwingPropertyChangeSupport
TableColumnModelEvent
TableModelEvent
TreeExpansionEvent
TreeModelEvent
TreeSelectionEvent
UndoableEditEvent
枚举
RowSorterEvent.Type


类 javax.swing.event.AncestorEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.AncestorEvent
的使用

使用 AncestorEvent 的软件包
javax.swing.event 供 Swing 组件触发的事件使用。

javax.swing.event 中 AncestorEvent 的使用

参数类型为 AncestorEvent 的 javax.swing.event 中的方法
void | AncestorListener.ancestorAdded(AncestorEvent event) 当通过调用 setVisible(true) 或将其添加到组件层次结构中而使源组件或其祖先之一变得可见时调用。
void | AncestorListener.ancestorMoved(AncestorEvent event) 在源组件或其祖先之一被移动时调用。
void | AncestorListener.ancestorRemoved(AncestorEvent event) 当通过调用 setVisible(false) 或将其从组件层次结构中移除而使源组件或其祖先之一变得不可见时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.AncestorListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.AncestorListener
的使用

使用 AncestorListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AncestorListener 的使用

返回 AncestorListener 的 javax.swing 中的方法
 AncestorListener[] JComponent.getAncestorListeners()
返回在此组件上注册的所有祖先侦听器所组成的数组。

参数类型为 AncestorListener 的 javax.swing 中的方法
void | JComponent.addAncestorListener(AncestorListener listener) 注册 listener，从而当组件或其任意祖先移动，或者变得可见或不可见时该侦听器将收到 AncestorEvent。
void | JComponent.removeAncestorListener(AncestorListener listener) 注销 listener，使其不再接收 AncestorEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.CaretEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.CaretEvent
的使用

使用 CaretEvent 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.event 中 CaretEvent 的使用

参数类型为 CaretEvent 的 javax.swing.event 中的方法
 void CaretListener.caretUpdate(CaretEvent e)
当插入符的位置被更新时调用。

javax.swing.text 中 CaretEvent 的使用

参数类型为 CaretEvent 的 javax.swing.text 中的方法
void | JTextComponent.AccessibleJTextComponent.caretUpdate(CaretEvent e) 处理插入符更新（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_CARET_PROPERTY 和 AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY）。
protected void | JTextComponent.fireCaretUpdate(CaretEvent e) 通知所有已注册需要此事件类型的通知的侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.CaretListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.CaretListener
的使用

使用 CaretListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 CaretListener 的使用

实现 CaretListener 的 javax.swing 中的类
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。

javax.swing.text 中 CaretListener 的使用

实现 CaretListener 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 CaretListener 的 javax.swing.text 中的方法
 CaretListener[] JTextComponent.getCaretListeners()
返回在此文本组件上已注册的所有插入符侦听器的数组。

参数类型为 CaretListener 的 javax.swing.text 中的方法
void | JTextComponent.addCaretListener(CaretListener listener) 添加插入符侦听器，以便侦听任何插入符的更改通知。
void | JTextComponent.removeCaretListener(CaretListener listener) 移除插入符侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.CellEditorListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.CellEditorListener
的使用

使用 CellEditorListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 CellEditorListener 的使用

实现 CellEditorListener 的 javax.swing 中的类
class | JTable JTable 用来显示和编辑常规二维单元表。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。

返回 CellEditorListener 的 javax.swing 中的方法
 CellEditorListener[] AbstractCellEditor.getCellEditorListeners()
返回使用 addCellEditorListener() 添加到此 AbstractCellEditor 中的所有 CellEditorListener 组成的数组。

参数类型为 CellEditorListener 的 javax.swing 中的方法
void | AbstractCellEditor.addCellEditorListener(CellEditorListener l) 将一个 CellEditorListener 添加到侦听器列表中。
void | CellEditor.addCellEditorListener(CellEditorListener l) 当编辑器停止运作或取消编辑时，向被通知的列表添加一个侦听器。
void | AbstractCellEditor.removeCellEditorListener(CellEditorListener l) 从侦听器列表中移除一个 CellEditorListener。
void | CellEditor.removeCellEditorListener(CellEditorListener l) 从被通知的列表中移除一个侦听器

javax.swing.plaf.basic 中 CellEditorListener 的使用

实现 CellEditorListener 的 javax.swing.plaf.basic 中的类
 class BasicTreeUI.CellEditorHandler
侦听器负责获取单元格编辑事件并相应地更新树。

返回 CellEditorListener 的 javax.swing.plaf.basic 中的方法
protected  CellEditorListener BasicTreeUI.createCellEditorListener()
创建在当前编辑器中处理事件的侦听器。

javax.swing.tree 中 CellEditorListener 的使用

返回 CellEditorListener 的 javax.swing.tree 中的方法
 CellEditorListener[] DefaultTreeCellEditor.getCellEditorListeners()
返回使用 addCellEditorListener() 添加到此 DefaultTreeCellEditor 中的所有 CellEditorListener 组成的数组。

参数类型为 CellEditorListener 的 javax.swing.tree 中的方法
void | DefaultTreeCellEditor.addCellEditorListener(CellEditorListener l) 添加 CellEditorListener。
void | DefaultTreeCellEditor.removeCellEditorListener(CellEditorListener l) 移除以前添加的 CellEditorListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.ChangeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.ChangeEvent
的使用

使用 ChangeEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 ChangeEvent 的使用

声明为 ChangeEvent 的 javax.swing 中的字段
protected ChangeEvent | JSlider.changeEvent 一个滑块实例仅需要一个 ChangeEvent，因为该事件唯一（只读）的状态是源属性。
protected ChangeEvent | AbstractCellEditor.changeEvent
protected ChangeEvent | JProgressBar.changeEvent 每个实例只需要一个 ChangeEvent，因为事件的唯一感兴趣属性是不可变源，即进度条。
protected ChangeEvent | JTabbedPane.changeEvent 由于事件仅有的（只读）状态是源属性，因此每个 TabPane 实例只需要一个 ChangeEvent。
protected ChangeEvent | DefaultBoundedRangeModel.changeEvent 由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。
protected ChangeEvent | MenuSelectionManager.changeEvent 每个按钮模型实例只需要一个 ChangeEvent，因为事件的惟一状态是 source 属性。
protected ChangeEvent | DefaultSingleSelectionModel.changeEvent
protected ChangeEvent | DefaultButtonModel.changeEvent 每个按钮模型实例只需要一个 ChangeEvent，因为事件的唯一状态是源属性。
protected ChangeEvent | AbstractButton.changeEvent 每个按钮实例都只需要一个 ChangeEvent，因为事件的唯一状态是源属性。

参数类型为 ChangeEvent 的 javax.swing 中的方法
void | JTable.columnMarginChanged(ChangeEvent e) 当列由于间距的更改而被移动时调用。
void | JTable.AccessibleJTable.columnMarginChanged(ChangeEvent e) 跟踪由于空白变更而引起的列移动的变更。
void | JTable.editingCanceled(ChangeEvent e) 编辑取消时调用。
void | JTable.AccessibleJTable.editingCanceled(ChangeEvent e) 编辑取消时调用。
void | JTable.editingStopped(ChangeEvent e) 编辑结束时调用。
void | JTable.AccessibleJTable.editingStopped(ChangeEvent e) 跟踪单元格内容的变更。
void | JSpinner.DefaultEditor.stateChanged(ChangeEvent e) 当 spinner 的模型状态更改时调用此方法。
void | JSpinner.AccessibleJSpinner.stateChanged(ChangeEvent e) 侦听器的目标已更改其状态时调用。
void | ProgressMonitor.AccessibleProgressMonitor.stateChanged(ChangeEvent e) 在侦听器的目标已更改其状态时调用。
void | JTabbedPane.ModelListener.stateChanged(ChangeEvent e)
void | JTabbedPane.AccessibleJTabbedPane.stateChanged(ChangeEvent e)
void | JScrollPane.AccessibleJScrollPane.stateChanged(ChangeEvent e) 当侦听器目标的状态改变时，此方法被调用。
void | JMenuItem.AccessibleJMenuItem.stateChanged(ChangeEvent e) 支持更改侦听器接口并激发属性更改。
void | AbstractButton.ButtonChangeListener.stateChanged(ChangeEvent e)

javax.swing.colorchooser 中 ChangeEvent 的使用

声明为 ChangeEvent 的 javax.swing.colorchooser 中的字段
protected  ChangeEvent DefaultColorSelectionModel.changeEvent
由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。

javax.swing.event 中 ChangeEvent 的使用

参数类型为 ChangeEvent 的 javax.swing.event 中的方法
void | TableColumnModelListener.columnMarginChanged(ChangeEvent e) 告知侦听器因为页边空白更改，有一列被移除。
void | CellEditorListener.editingCanceled(ChangeEvent e) 此方法告知侦听器编辑器已经取消编辑
void | CellEditorListener.editingStopped(ChangeEvent e) 此方法告知侦听器编辑器已经结束编辑
void | ChangeListener.stateChanged(ChangeEvent e) 当侦听器的目标已更改其状态时调用。

javax.swing.plaf.basic 中 ChangeEvent 的使用

参数类型为 ChangeEvent 的 javax.swing.plaf.basic 中的方法
void | BasicTreeUI.CellEditorHandler.editingCanceled(ChangeEvent e) 在树中取消编辑时传递消息。
void | BasicTreeUI.CellEditorHandler.editingStopped(ChangeEvent e) 在树中停止编辑时传递消息。
void | BasicSliderUI.ChangeHandler.stateChanged(ChangeEvent e)
void | BasicProgressBarUI.ChangeHandler.stateChanged(ChangeEvent e)
void | BasicTabbedPaneUI.TabSelectionHandler.stateChanged(ChangeEvent e)
void | BasicScrollPaneUI.ViewportChangeHandler.stateChanged(ChangeEvent e)
void | BasicScrollPaneUI.HSBChangeListener.stateChanged(ChangeEvent e)
void | BasicScrollPaneUI.VSBChangeListener.stateChanged(ChangeEvent e)
void | BasicScrollBarUI.ModelListener.stateChanged(ChangeEvent e)
void | BasicMenuUI.ChangeHandler.stateChanged(ChangeEvent e)
void | BasicButtonListener.stateChanged(ChangeEvent e)

javax.swing.table 中 ChangeEvent 的使用

声明为 ChangeEvent 的 javax.swing.table 中的字段
protected  ChangeEvent DefaultTableColumnModel.changeEvent
更改事件（只需要一个）

参数类型为 ChangeEvent 的 javax.swing.table 中的方法
 void JTableHeader.columnMarginChanged(ChangeEvent e)
当列由于间距改变而被移动时调用。

javax.swing.text 中 ChangeEvent 的使用

声明为 ChangeEvent 的 javax.swing.text 中的字段
protected ChangeEvent | DefaultCaret.changeEvent 此模型的更改事件。
protected ChangeEvent | StyleContext.NamedStyle.changeEvent 由于事件的惟一状态（只读）为源属性，因此每个模型实例只需要一个 ChangeEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.ChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.ChangeListener
的使用

使用 ChangeListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 ChangeListener 的使用

实现 ChangeListener 的 javax.swing 中的类
protected class | AbstractButton.ButtonChangeListener 将 ChangeListener 扩展为可序列化的。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTabbedPane.ModelListener 将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。
protected class | ProgressMonitor.AccessibleProgressMonitor AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

声明为 ChangeListener 的 javax.swing 中的字段
protected ChangeListener | JSlider.changeListener changeListener（无前缀）是添加到滑块模型的侦听器。
protected ChangeListener | JProgressBar.changeListener 侦听由进度条的模型发送的更改事件，并将其再次指派到在此进度条上注册的更改事件侦听器。
protected ChangeListener | JTabbedPane.changeListener changeListener 是添加到模型中的侦听器。
protected ChangeListener | AbstractButton.changeListener 按钮模型的 changeListener。

返回 ChangeListener 的 javax.swing 中的方法
protected  ChangeListener JSlider.createChangeListener()
想要以不同方式处理模型的 ChangeEvent 的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。
protected  ChangeListener JProgressBar.createChangeListener()
要以不同方式处理来自模型的更改事件的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。
protected  ChangeListener JTabbedPane.createChangeListener()
要对 ChangeEvents 进行不同处理的子类可以重写它，从而返回 ModelListener 的一个子类，或者返回另一个 ChangeListener 实现。
protected  ChangeListener AbstractButton.createChangeListener()
想以不同的方式处理 ChangeEvent 的子类可以重写此方法，以返回另一个 ChangeListener 实现。
 ChangeListener[] AbstractSpinnerModel.getChangeListeners()
返回使用 addChangeListener() 添加到此 AbstractSpinnerModel 中的所有 ChangeListener 组成的数组。
 ChangeListener[] JSpinner.getChangeListeners()
返回一个通过 addChangeListener() 方法添加到此 JSpinner 的所有 ChangeListener 的数组。
 ChangeListener[] JSlider.getChangeListeners()
返回一个通过 addChangeListener() 方法添加此 JSlider 的所有 ChangeListener 的数组。
 ChangeListener[] JProgressBar.getChangeListeners()
返回通过 addChangeListener 添加到此进度条的所有 ChangeListener 组成的数组。
 ChangeListener[] JTabbedPane.getChangeListeners()
返回通过 addChangeListener 方法添加到此 JTabbedPane 中的所有 ChangeListener 的数组。
 ChangeListener[] JViewport.getChangeListeners()
返回使用 addChangeListener() 添加到此 JViewport 的所有 ChangeListener 的数组。
 ChangeListener[] DefaultBoundedRangeModel.getChangeListeners()
返回此 DefaultBoundedRangeModel 上所有已注册的更改侦听器组成的数组。
 ChangeListener[] MenuSelectionManager.getChangeListeners()
返回使用 addChangeListener() 添加到此 MenuSelectionManager 的所有 ChangeListener 的数组。
 ChangeListener[] DefaultSingleSelectionModel.getChangeListeners()
返回此 DefaultSingleSelectionModel 上所有已注册的更改侦听器组成的数组。
 ChangeListener[] DefaultButtonModel.getChangeListeners()
返回此 DefaultButtonModel 上所有已注册的更改侦听器组成的数组。
 ChangeListener[] AbstractButton.getChangeListeners()
返回使用 addChangeListener() 添加到此 AbstractButton 中的所有 ChangeListener 组成的数组。

参数类型为 ChangeListener 的 javax.swing 中的方法
void | AbstractSpinnerModel.addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到模型的侦听器列表中。
void | JSpinner.addChangeListener(ChangeListener listener) 为每次发生模型更改时要通知的列表添加侦听器。
void | SpinnerModel.addChangeListener(ChangeListener l) 向该模型的侦听器列表添加一个 ChangeListener。
void | JSlider.addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到滑块。
void | JProgressBar.addChangeListener(ChangeListener l) 将指定的 ChangeListener 添加到进度条。
void | JTabbedPane.addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到此选项卡窗格中。
void | JViewport.addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表。
void | DefaultBoundedRangeModel.addChangeListener(ChangeListener l) 添加一个 ChangeListener。
void | BoundedRangeModel.addChangeListener(ChangeListener x) 将一个 ChangeListener 添加到模型的侦听器列表中。
void | MenuSelectionManager.addChangeListener(ChangeListener l) 向按钮添加 ChangeListener。
void | DefaultSingleSelectionModel.addChangeListener(ChangeListener l) 向按钮添加一个 ChangeListener。
void | SingleSelectionModel.addChangeListener(ChangeListener listener) 在模型中添加作为更改侦听侦听器的 listener。
void | DefaultButtonModel.addChangeListener(ChangeListener l) 向模型添加一个 ChangeListener。
void | ButtonModel.addChangeListener(ChangeListener l) 向模型添加一个 ChangeListener。
void | AbstractButton.addChangeListener(ChangeListener l) 向按钮添加一个 ChangeListener。
void | AbstractSpinnerModel.removeChangeListener(ChangeListener l) 从模型的侦听器列表中移除一个 ChangeListener。
void | JSpinner.removeChangeListener(ChangeListener listener) 从此 spinne 中移除 ChangeListener。
void | SpinnerModel.removeChangeListener(ChangeListener l) 从该模型的侦听器列表移除一个 ChangeListener。
void | JSlider.removeChangeListener(ChangeListener l) 从滑块中移除一个 ChangeListener。
void | JProgressBar.removeChangeListener(ChangeListener l) 从进度条移除 ChangeListener。
void | JTabbedPane.removeChangeListener(ChangeListener l) 从此选项卡窗格中移除一个 ChangeListener。
void | JViewport.removeChangeListener(ChangeListener l) 从每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表中移除 ChangeListener。
void | DefaultBoundedRangeModel.removeChangeListener(ChangeListener l) 移除一个 ChangeListener。
void | BoundedRangeModel.removeChangeListener(ChangeListener x) 从模型的侦听器列表中移除一个 ChangeListener。
void | MenuSelectionManager.removeChangeListener(ChangeListener l) 从按钮中移除 ChangeListener。
void | DefaultSingleSelectionModel.removeChangeListener(ChangeListener l) 从按钮中移除一个 ChangeListener。
void | SingleSelectionModel.removeChangeListener(ChangeListener listener) 从模型中移除作为更改侦听器的 listener。
void | DefaultButtonModel.removeChangeListener(ChangeListener l) 从模型中移除一个 ChangeListener。
void | ButtonModel.removeChangeListener(ChangeListener l) 从模型中移除一个 ChangeListener。
void | AbstractButton.removeChangeListener(ChangeListener l) 从按钮中移除一个 ChangeListener。

javax.swing.colorchooser 中 ChangeListener 的使用

返回 ChangeListener 的 javax.swing.colorchooser 中的方法
 ChangeListener[] DefaultColorSelectionModel.getChangeListeners()
返回一个使用 addChangeListener 添加到此 DefaultColorSelectionModel 中的所有 ChangeListener 的数组。

参数类型为 ChangeListener 的 javax.swing.colorchooser 中的方法
void | ColorSelectionModel.addChangeListener(ChangeListener listener) 在模型中添加作为更改侦听器的 listener。
void | DefaultColorSelectionModel.addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到模型中。
void | ColorSelectionModel.removeChangeListener(ChangeListener listener) 从模型中移除作为更改侦听器的 listener。
void | DefaultColorSelectionModel.removeChangeListener(ChangeListener l) 从模型中移除一个 ChangeListener。

javax.swing.plaf.basic 中 ChangeListener 的使用

实现 ChangeListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
class | BasicMenuUI.ChangeHandler 从 Java 2 平台 1.4 开始，已废弃这种以前没有记录的类。
class | BasicProgressBarUI.ChangeHandler 此内部类因编译器故障而被标记为“公开”。
protected class | BasicScrollBarUI.ModelListener 侦听模型更改的侦听器。
class | BasicScrollPaneUI.HSBChangeListener 水平滚动条侦听器。
class | BasicScrollPaneUI.ViewportChangeHandler 视口事件的侦听器。
class | BasicScrollPaneUI.VSBChangeListener 垂直滚动条侦听器。
class | BasicSliderUI.ChangeHandler 数据模型侦听器。
class | BasicTabbedPaneUI.TabSelectionHandler 此类应视为“受保护”内部类。

声明为 ChangeListener 的 javax.swing.plaf.basic 中的字段
protected ChangeListener | BasicSliderUI.changeListener
protected ChangeListener | BasicProgressBarUI.changeListener
protected ChangeListener | BasicMenuUI.changeListener
protected ChangeListener | BasicMenuBarUI.changeListener
protected ChangeListener | BasicScrollPaneUI.hsbChangeListener
protected ChangeListener | BasicColorChooserUI.previewListener
protected ChangeListener | BasicTabbedPaneUI.tabChangeListener
protected ChangeListener | BasicScrollPaneUI.viewportChangeListener
protected ChangeListener | BasicScrollPaneUI.vsbChangeListener

返回 ChangeListener 的 javax.swing.plaf.basic 中的方法
protected ChangeListener | BasicTabbedPaneUI.createChangeListener()
protected ChangeListener | BasicMenuBarUI.createChangeListener()
protected ChangeListener | BasicMenuUI.createChangeListener(JComponent c)
protected ChangeListener | BasicSliderUI.createChangeListener(JSlider slider)
protected ChangeListener | BasicScrollPaneUI.createHSBChangeListener()
protected ChangeListener | BasicScrollPaneUI.createViewportChangeListener()
protected ChangeListener | BasicScrollPaneUI.createVSBChangeListener()

javax.swing.text 中 ChangeListener 的使用

返回 ChangeListener 的 javax.swing.text 中的方法
 ChangeListener[] DefaultCaret.getChangeListeners()
返回此插入符上所有已注册的更改侦听器组成的数组。
 ChangeListener[] StyleContext.getChangeListeners()
返回使用 addChangeListener() 添加到此 StyleContext 中的所有 ChangeListener 组成的数组。
 ChangeListener[] StyleContext.NamedStyle.getChangeListeners()
返回使用 addChangeListener() 添加到此 NamedStyle 中的所有 ChangeListener 组成的数组。

参数类型为 ChangeListener 的 javax.swing.text 中的方法
void | DefaultCaret.addChangeListener(ChangeListener l) 添加一个侦听器，以便对插入符位置改变进行跟踪。
void | Caret.addChangeListener(ChangeListener l) 添加作为跟踪任何插入符位置更改的侦听器。
void | Style.addChangeListener(ChangeListener l) 添加一个侦听器，以便随时跟踪属性的更改。
void | StyleContext.addChangeListener(ChangeListener l) 添加一个侦听器，以跟踪何时添加或删除样式。
void | StyleContext.NamedStyle.addChangeListener(ChangeListener l) 添加更改侦听器。
void | DefaultCaret.removeChangeListener(ChangeListener l) 移除跟踪位置更改的侦听器。
void | Caret.removeChangeListener(ChangeListener l) 移除跟踪插入符位置更改的侦听器。
void | Style.removeChangeListener(ChangeListener l) 移除跟踪属性更改的侦听器。
void | StyleContext.removeChangeListener(ChangeListener l) 移除一个跟踪正被添加或移除样式的侦听器。
void | StyleContext.NamedStyle.removeChangeListener(ChangeListener l) 移除更改侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.DocumentEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.DocumentEvent
的使用

使用 DocumentEvent 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.event 中 DocumentEvent 的使用

参数类型为 DocumentEvent 的 javax.swing.event 中的方法
void | DocumentListener.changedUpdate(DocumentEvent e) 给出属性或属性集发生了更改的通知。
void | DocumentListener.insertUpdate(DocumentEvent e) 给出对文档执行了插入操作的通知。
void | DocumentListener.removeUpdate(DocumentEvent e) 给出移除了一部分文档的通知。

javax.swing.text 中 DocumentEvent 的使用

实现 DocumentEvent 的 javax.swing.text 中的类
 class AbstractDocument.DefaultDocumentEvent
存储修改文档时发生的文档更改。

参数类型为 DocumentEvent 的 javax.swing.text 中的方法
void | JTextComponent.AccessibleJTextComponent.changedUpdate(DocumentEvent e) 处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
void | FlowView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | GlyphView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | LabelView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | ParagraphView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | WrappedPlainView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出文档中此视图负责的位置上的属性已发生更改的通知。
void | PlainView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | View.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | FlowView.FlowStrategy.changedUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
protected void | AbstractDocument.fireChangedUpdate(DocumentEvent e) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected void | AbstractDocument.fireInsertUpdate(DocumentEvent e) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected void | AbstractDocument.fireRemoveUpdate(DocumentEvent e) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected void | BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
protected void | View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
protected void | View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f) 将 DocumentEvent 转发到给定的子视图。
void | JTextComponent.AccessibleJTextComponent.insertUpdate(DocumentEvent e) 处理文档插入（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
void | FlowView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | GlyphView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | WrappedPlainView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出在文档中此视图负责的位置插入了某些内容的通知。
void | ZoneView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出在文档中此视图负责的位置插入了某些内容的通知。
void | FieldView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | View.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | FlowView.FlowStrategy.insertUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | JTextComponent.AccessibleJTextComponent.removeUpdate(DocumentEvent e) 处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
void | FlowView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知从文档中此视图负责的某个位置已移除内容。
void | GlyphView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。
void | WrappedPlainView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出从文档中此视图负责的位置移除了某些内容的通知。
void | ZoneView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
void | FieldView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | View.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
void | FlowView.FlowStrategy.removeUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知已从文档中此给定流视图负责的某个位置移除某些内容。
protected boolean | ZoneView.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 超类行为将试图更新子视图，而在这种情况下并不需要这样做，因为子级是分区并且不受关联元素变化的直接影响。
protected boolean | View.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 更新子视图以响应接收模型变化的通知，并且有一条此视图负责的元素的变化记录。
protected void | PlainView.updateDamage(DocumentEvent changes, Shape a, ViewFactory f) 重新绘制给定文档事件覆盖的更改区域。
protected void | AsyncBoxView.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接收的更改通知。
protected void | View.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接受的更改通知。

javax.swing.text.html 中 DocumentEvent 的使用

参数类型为 DocumentEvent 的 javax.swing.text.html 中的方法
void | BlockView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
void | ImageView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 当 Elements 属性已更改时调用。
void | InlineView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
protected void | HTMLDocument.fireChangedUpdate(DocumentEvent e) 通知所有需要此事件类型的通知的已注册侦听器。
void | InlineView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | InlineView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.DocumentEvent.ElementChange 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.DocumentEvent.ElementChange
的使用

使用 DocumentEvent.ElementChange 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.event 中 DocumentEvent.ElementChange 的使用

返回 DocumentEvent.ElementChange 的 javax.swing.event 中的方法
 DocumentEvent.ElementChange DocumentEvent.getChange(Element elem)
获得给定元素的更改信息。

javax.swing.text 中 DocumentEvent.ElementChange 的使用

实现 DocumentEvent.ElementChange 的 javax.swing.text 中的类
static class AbstractDocument.ElementEdit
一个 ElementChange 实现，可将其添加到文档事件中。

返回 DocumentEvent.ElementChange 的 javax.swing.text 中的方法
 DocumentEvent.ElementChange AbstractDocument.DefaultDocumentEvent.getChange(Element elem)
获得元素的更改。

参数类型为 DocumentEvent.ElementChange 的 javax.swing.text 中的方法
protected void | BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
protected void | View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
protected boolean | ZoneView.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 超类行为将试图更新子视图，而在这种情况下并不需要这样做，因为子级是分区并且不受关联元素变化的直接影响。
protected boolean | View.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 更新子视图以响应接收模型变化的通知，并且有一条此视图负责的元素的变化记录。
protected void | AsyncBoxView.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接收的更改通知。
protected void | View.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接受的更改通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.DocumentEvent.EventType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.DocumentEvent.EventType
的使用

使用 DocumentEvent.EventType 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.event 中 DocumentEvent.EventType 的使用

声明为 DocumentEvent.EventType 的 javax.swing.event 中的字段
static DocumentEvent.EventType | DocumentEvent.EventType.CHANGE 更改类型。
static DocumentEvent.EventType | DocumentEvent.EventType.INSERT 插入类型。
static DocumentEvent.EventType | DocumentEvent.EventType.REMOVE 移除类型。

返回 DocumentEvent.EventType 的 javax.swing.event 中的方法
 DocumentEvent.EventType DocumentEvent.getType()
获得事件类型。

javax.swing.text 中 DocumentEvent.EventType 的使用

返回 DocumentEvent.EventType 的 javax.swing.text 中的方法
 DocumentEvent.EventType AbstractDocument.DefaultDocumentEvent.getType()
返回事件的类型。

参数类型为 DocumentEvent.EventType 的 javax.swing.text 中的构造方法
AbstractDocument.DefaultDocumentEvent(int offs, int len, DocumentEvent.EventType type)
构造更改记录。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.DocumentListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.DocumentListener
的使用

使用 DocumentListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 DocumentListener 的使用

实现 DocumentListener 的 javax.swing 中的类
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。

javax.swing.text 中 DocumentListener 的使用

实现 DocumentListener 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 DocumentListener 的 javax.swing.text 中的方法
 DocumentListener[] AbstractDocument.getDocumentListeners()
返回在此文档上注册的所有文档侦听器的数组。

参数类型为 DocumentListener 的 javax.swing.text 中的方法
void | DefaultStyledDocument.addDocumentListener(DocumentListener listener) 添加负责通知任何更改的文档侦听器。
void | AbstractDocument.addDocumentListener(DocumentListener listener) 添加负责通知任何更改的文档侦听器。
void | Document.addDocumentListener(DocumentListener listener) 注册给定的观察者以便开始接收文档发生更改的通知。
void | DefaultStyledDocument.removeDocumentListener(DocumentListener listener) 移除文档侦听器。
void | AbstractDocument.removeDocumentListener(DocumentListener listener) 移除文档侦听器。
void | Document.removeDocumentListener(DocumentListener listener) 将给定的观察者从通知列表中撤消注册，这样就不再接收改动更新。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.EventListenerList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.EventListenerList
的使用

使用 EventListenerList 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 EventListenerList 的使用

声明为 EventListenerList 的 javax.swing 中的字段
protected EventListenerList | AbstractSpinnerModel.listenerList 此模型的 ChangeListener 列表。
protected EventListenerList | AbstractCellEditor.listenerList
protected EventListenerList | DefaultListSelectionModel.listenerList
protected EventListenerList | AbstractListModel.listenerList
protected EventListenerList | DefaultBoundedRangeModel.listenerList 等待模型更改的侦听器。
protected EventListenerList | MenuSelectionManager.listenerList
protected EventListenerList | DefaultSingleSelectionModel.listenerList 已注册侦听器的集合
protected EventListenerList | DefaultButtonModel.listenerList 在此模型中存储侦听器。
protected EventListenerList | Timer.listenerList
protected EventListenerList | JComponent.listenerList 此组件的事件侦听器列表。

javax.swing.colorchooser 中 EventListenerList 的使用

声明为 EventListenerList 的 javax.swing.colorchooser 中的字段
protected  EventListenerList DefaultColorSelectionModel.listenerList

javax.swing.table 中 EventListenerList 的使用

声明为 EventListenerList 的 javax.swing.table 中的字段
protected EventListenerList | DefaultTableColumnModel.listenerList TableColumnModelListener 的列表
protected EventListenerList | AbstractTableModel.listenerList 侦听器的列表

javax.swing.text 中 EventListenerList 的使用

声明为 EventListenerList 的 javax.swing.text 中的字段
protected EventListenerList | DefaultCaret.listenerList 事件侦听器列表。
protected EventListenerList | StyleContext.NamedStyle.listenerList 模型的更改侦听器。
protected EventListenerList | AbstractDocument.listenerList 文档的事件侦听器列表。

javax.swing.tree 中 EventListenerList 的使用

声明为 EventListenerList 的 javax.swing.tree 中的字段
protected EventListenerList | DefaultTreeModel.listenerList 侦听器。
protected EventListenerList | DefaultTreeSelectionModel.listenerList 事件侦听器列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.HyperlinkEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.HyperlinkEvent
的使用

使用 HyperlinkEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 HyperlinkEvent 的使用

参数类型为 HyperlinkEvent 的 javax.swing 中的方法
 void JEditorPane.fireHyperlinkUpdate(HyperlinkEvent e)
通知因对此事件类型的通知感兴趣而已注册的所有侦听器。

javax.swing.event 中 HyperlinkEvent 的使用

参数类型为 HyperlinkEvent 的 javax.swing.event 中的方法
 void HyperlinkListener.hyperlinkUpdate(HyperlinkEvent e)
在更新超文本链接时调用。

javax.swing.text.html 中 HyperlinkEvent 的使用

javax.swing.text.html 中 HyperlinkEvent 的子类
class | FormSubmitEvent FormSubmitEvent 用于通知提交表单所需的参与者。
class | HTMLFrameHyperlinkEvent HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.HyperlinkEvent.EventType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.HyperlinkEvent.EventType
的使用

使用 HyperlinkEvent.EventType 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.event 中 HyperlinkEvent.EventType 的使用

声明为 HyperlinkEvent.EventType 的 javax.swing.event 中的字段
static HyperlinkEvent.EventType | HyperlinkEvent.EventType.ACTIVATED 激活类型。
static HyperlinkEvent.EventType | HyperlinkEvent.EventType.ENTERED 进入类型。
static HyperlinkEvent.EventType | HyperlinkEvent.EventType.EXITED 退出类型。

返回 HyperlinkEvent.EventType 的 javax.swing.event 中的方法
 HyperlinkEvent.EventType HyperlinkEvent.getEventType()
获得事件类型。

参数类型为 HyperlinkEvent.EventType 的 javax.swing.event 中的构造方法
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u)
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。

javax.swing.text.html 中 HyperlinkEvent.EventType 的使用

参数类型为 HyperlinkEvent.EventType 的 javax.swing.text.html 中的构造方法
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
创建一个表示 html 框架超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
创建一个表示超文本链接事件的新对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.HyperlinkListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.HyperlinkListener
的使用

使用 HyperlinkListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 HyperlinkListener 的使用

返回 HyperlinkListener 的 javax.swing 中的方法
 HyperlinkListener[] JEditorPane.getHyperlinkListeners()
返回使用 addHyperlinkListener() 添加到此 JEditorPane 的所有 HyperLinkListener 的数组。

参数类型为 HyperlinkListener 的 javax.swing 中的方法
void | JEditorPane.addHyperlinkListener(HyperlinkListener listener) 为了通知所有的更改（例如选中和进入某个链接）而添加一个超链接侦听器。
void | JEditorPane.removeHyperlinkListener(HyperlinkListener listener) 移除超链接侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.InternalFrameAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.InternalFrameAdapter
的使用

没有 javax.swing.event.InternalFrameAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.InternalFrameEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.InternalFrameEvent
的使用

使用 InternalFrameEvent 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing.event 中 InternalFrameEvent 的使用

参数类型为 InternalFrameEvent 的 javax.swing.event 中的方法
void | InternalFrameAdapter.internalFrameActivated(InternalFrameEvent e) 当内部窗体被激活时调用。
void | InternalFrameListener.internalFrameActivated(InternalFrameEvent e) 当内部窗体被激活时调用。
void | InternalFrameAdapter.internalFrameClosed(InternalFrameEvent e) 当内部窗体已关闭时调用。
void | InternalFrameListener.internalFrameClosed(InternalFrameEvent e) 当内部窗体已关闭时调用。
void | InternalFrameAdapter.internalFrameClosing(InternalFrameEvent e) 当内部窗体正被关闭时调用。
void | InternalFrameListener.internalFrameClosing(InternalFrameEvent e) 当内部窗体正被关闭时调用。
void | InternalFrameAdapter.internalFrameDeactivated(InternalFrameEvent e) 当内部窗体被取消激活时调用。
void | InternalFrameListener.internalFrameDeactivated(InternalFrameEvent e) 当内部窗体被取消激活时调用。
void | InternalFrameAdapter.internalFrameDeiconified(InternalFrameEvent e) 当内部窗体被取消图标化时调用。
void | InternalFrameListener.internalFrameDeiconified(InternalFrameEvent e) 当内部窗体被取消图标化时调用。
void | InternalFrameAdapter.internalFrameIconified(InternalFrameEvent e) 当内部窗体被图标化时调用。
void | InternalFrameListener.internalFrameIconified(InternalFrameEvent e) 当内部窗体被图标化时调用。
void | InternalFrameAdapter.internalFrameOpened(InternalFrameEvent e) 当内部窗体已打开时调用。
void | InternalFrameListener.internalFrameOpened(InternalFrameEvent e) 当内部窗体已打开时调用。

javax.swing.plaf.basic 中 InternalFrameEvent 的使用

参数类型为 InternalFrameEvent 的 javax.swing.plaf.basic 中的方法
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameActivated(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameClosed(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameClosing(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameDeactivated(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameDeiconified(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameIconified(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameOpened(InternalFrameEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.InternalFrameListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.InternalFrameListener
的使用

使用 InternalFrameListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 InternalFrameListener 的使用

返回 InternalFrameListener 的 javax.swing 中的方法
 InternalFrameListener[] JInternalFrame.getInternalFrameListeners()
返回使用 addInternalFrameListener 添加到此 JInternalFrame 的所有 InternalFrameListener 的数组。

参数类型为 InternalFrameListener 的 javax.swing 中的方法
void | JInternalFrame.addInternalFrameListener(InternalFrameListener l) 添加指定的侦听器，以从此内部窗体接收内部窗体事件。
void | JInternalFrame.removeInternalFrameListener(InternalFrameListener l) 移除指定的内部窗体侦听器，不再接收此内部窗体发出的内部窗体事件。

javax.swing.event 中 InternalFrameListener 的使用

实现 InternalFrameListener 的 javax.swing.event 中的类
 class InternalFrameAdapter
用于接收内部窗体事件的抽象适配器类。

javax.swing.plaf.basic 中 InternalFrameListener 的使用

实现 InternalFrameListener 的 javax.swing.plaf.basic 中的类
protected  class BasicInternalFrameUI.BasicInternalFrameListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.ListDataEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.ListDataEvent
的使用

使用 ListDataEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 ListDataEvent 的使用

参数类型为 ListDataEvent 的 javax.swing 中的方法
void | JList.AccessibleJList.contentsChanged(ListDataEvent e) List Data Listener 内容更改方法。
void | JComboBox.contentsChanged(ListDataEvent e) 此方法作为实现的副作用存在的公共方法。
void | JList.AccessibleJList.intervalAdded(ListDataEvent e) List Data Listener 间隔添加方法。
void | JComboBox.intervalAdded(ListDataEvent e) 此方法作为实现的副作用存在的公共方法。
void | JList.AccessibleJList.intervalRemoved(ListDataEvent e) List Data Listener 间隔移除方法。
void | JComboBox.intervalRemoved(ListDataEvent e) 此方法作为实现的副作用存在的公共方法。

javax.swing.event 中 ListDataEvent 的使用

参数类型为 ListDataEvent 的 javax.swing.event 中的方法
void | ListDataListener.contentsChanged(ListDataEvent e) 在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。
void | ListDataListener.intervalAdded(ListDataEvent e) 在已将 index0,index1 区间中的索引插入数据模型中之后发送。
void | ListDataListener.intervalRemoved(ListDataEvent e) 在已将 index0,index1 区间中的索引从数据模型中移除后发送。

javax.swing.plaf.basic 中 ListDataEvent 的使用

参数类型为 ListDataEvent 的 javax.swing.plaf.basic 中的方法
void | BasicListUI.ListDataHandler.contentsChanged(ListDataEvent e)
void | BasicComboPopup.ListDataHandler.contentsChanged(ListDataEvent e)
void | BasicComboBoxUI.ListDataHandler.contentsChanged(ListDataEvent e)
void | BasicDirectoryModel.intervalAdded(ListDataEvent e) 废弃，不使用。
void | BasicListUI.ListDataHandler.intervalAdded(ListDataEvent e)
void | BasicComboPopup.ListDataHandler.intervalAdded(ListDataEvent e)
void | BasicComboBoxUI.ListDataHandler.intervalAdded(ListDataEvent e)
void | BasicDirectoryModel.intervalRemoved(ListDataEvent e) 废弃，不使用。
void | BasicListUI.ListDataHandler.intervalRemoved(ListDataEvent e)
void | BasicComboPopup.ListDataHandler.intervalRemoved(ListDataEvent e)
void | BasicComboBoxUI.ListDataHandler.intervalRemoved(ListDataEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.ListDataListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.ListDataListener
的使用

使用 ListDataListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 ListDataListener 的使用

实现 ListDataListener 的 javax.swing 中的类
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。

返回 ListDataListener 的 javax.swing 中的方法
 ListDataListener[] AbstractListModel.getListDataListeners()
返回已在此 AbstractListModel 上注册的所有列表数据侦听器组成的数组。

参数类型为 ListDataListener 的 javax.swing 中的方法
void | AbstractListModel.addListDataListener(ListDataListener l) 将某个侦听器添加到每次更改数据模型都要通知的列表。
void | ListModel.addListDataListener(ListDataListener l) 将一个侦听器添加到每次在数据模型发生更改时都得到通知的列表。
void | AbstractListModel.removeListDataListener(ListDataListener l) 将某个侦听器从每次更改数据模型都要通知的列表中移除。
void | ListModel.removeListDataListener(ListDataListener l) 从每次在数据模型发生更改时都得到通知的列表中移除侦听器。

javax.swing.plaf.basic 中 ListDataListener 的使用

实现 ListDataListener 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxUI.ListDataHandler 此侦听器观察 ComboBoxModel 中的更改。
class | BasicComboPopup.ListDataHandler 从 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
class | BasicListUI.ListDataHandler 在 installUI 时和只要 JList.model 属性更改时就要添加到 JList 模型的 ListDataListener。

声明为 ListDataListener 的 javax.swing.plaf.basic 中的字段
protected ListDataListener | BasicListUI.listDataListener
protected ListDataListener | BasicComboPopup.listDataListener 此受保护字段是特定于实现的。
protected ListDataListener | BasicComboBoxUI.listDataListener 此受保护字段是特定于实现的。

返回 ListDataListener 的 javax.swing.plaf.basic 中的方法
protected ListDataListener | BasicListUI.createListDataListener() 创建在需要时由模型添加到 JList 的 ListDataListener 的实例。
protected ListDataListener | BasicComboPopup.createListDataListener() 创建将添加到 ComboBoxModel 的列表数据侦听器。
protected ListDataListener | BasicComboBoxUI.createListDataListener() 创建将添加到 ComboBoxModel 的列表数据侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.ListSelectionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.ListSelectionEvent
的使用

使用 ListSelectionEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 ListSelectionEvent 的使用

参数类型为 ListSelectionEvent 的 javax.swing 中的方法
void | JTable.columnSelectionChanged(ListSelectionEvent e) TableColumnModel 的选择模型更改时调用。
void | JTable.AccessibleJTable.columnSelectionChanged(ListSelectionEvent e) 对变更的 TableColumnModel 的选择模型进行跟踪。
void | JTable.valueChanged(ListSelectionEvent e) 行选择更改时调用，重新绘制来显示新的选择。
void | JTable.AccessibleJTable.valueChanged(ListSelectionEvent e) 跟踪表单元格选择的变更
void | JList.AccessibleJList.valueChanged(ListSelectionEvent e) List Selection Listener 值更改方法。

javax.swing.event 中 ListSelectionEvent 的使用

参数类型为 ListSelectionEvent 的 javax.swing.event 中的方法
void | TableColumnModelListener.columnSelectionChanged(ListSelectionEvent e) 告知侦听器 TableColumnModel 的选择模型发生更改。
void | ListSelectionListener.valueChanged(ListSelectionEvent e) 每当选择值发生更改时调用。

javax.swing.plaf.basic 中 ListSelectionEvent 的使用

参数类型为 ListSelectionEvent 的 javax.swing.plaf.basic 中的方法
void | BasicFileChooserUI.SelectionListener.valueChanged(ListSelectionEvent e)
void | BasicListUI.ListSelectionHandler.valueChanged(ListSelectionEvent e)
void | BasicComboPopup.ListSelectionHandler.valueChanged(ListSelectionEvent e)

javax.swing.plaf.metal 中 ListSelectionEvent 的使用

参数类型为 ListSelectionEvent 的 javax.swing.plaf.metal 中的方法
 void MetalFileChooserUI.valueChanged(ListSelectionEvent e)

javax.swing.table 中 ListSelectionEvent 的使用

参数类型为 ListSelectionEvent 的 javax.swing.table 中的方法
void | JTableHeader.columnSelectionChanged(ListSelectionEvent e) 当 TableColumnModel 的选择模型更改时调用。
protected void | DefaultTableColumnModel.fireColumnSelectionChanged(ListSelectionEvent e) 通知所有对此事件类型的通知感兴趣的已注册侦听器。
void | DefaultTableColumnModel.valueChanged(ListSelectionEvent e) 列选择更改时转发 ListSelectionEvents 的 ListSelectionListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.ListSelectionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.ListSelectionListener
的使用

使用 ListSelectionListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 ListSelectionListener 的使用

实现 ListSelectionListener 的 javax.swing 中的类
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
class | JTable JTable 用来显示和编辑常规二维单元表。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。

返回 ListSelectionListener 的 javax.swing 中的方法
ListSelectionListener[] | DefaultListSelectionModel.getListSelectionListeners() 返回已在此 DefaultListSelectionModel 上注册的所有列表选择侦听器组成的数组。
ListSelectionListener[] | JList.getListSelectionListeners() 返回通过 addListSelectionListener 添加到此 JList 中的所有 ListSelectionListener 所组成的数组。

参数类型为 ListSelectionListener 的 javax.swing 中的方法
void | DefaultListSelectionModel.addListSelectionListener(ListSelectionListener l) 将侦听器添加到每次在选择发生更改时都得到通知的列表。
void | ListSelectionModel.addListSelectionListener(ListSelectionListener x) 将侦听器添加到每次在选择发生更改时都得到通知的列表。
void | JList.addListSelectionListener(ListSelectionListener listener) 将侦听器添加到列表，每次选择发生更改时将获得通知；这是侦听选择状态更改的首选方式。
void | DefaultListSelectionModel.removeListSelectionListener(ListSelectionListener l) 将侦听器从每次在选择发生更改时都得到通知的列表中移除。
void | ListSelectionModel.removeListSelectionListener(ListSelectionListener x) 将侦听器从每次在选择发生更改时都得到通知的列表中移除。
void | JList.removeListSelectionListener(ListSelectionListener listener) 从列表中移除一个选择侦听器。

javax.swing.plaf.basic 中 ListSelectionListener 的使用

实现 ListSelectionListener 的 javax.swing.plaf.basic 中的类
protected class | BasicComboPopup.ListSelectionHandler 从 Java 2 平台 v 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
protected class | BasicFileChooserUI.SelectionListener
class | BasicListUI.ListSelectionHandler 在 installUI 时和只要 JList.selectionModel 属性更改时就要添加到 JList 模型的 ListSelectionListener。

声明为 ListSelectionListener 的 javax.swing.plaf.basic 中的字段
protected ListSelectionListener | BasicListUI.listSelectionListener
protected ListSelectionListener | BasicComboPopup.listSelectionListener 此受保护字段是特定于实现的。

返回 ListSelectionListener 的 javax.swing.plaf.basic 中的方法
protected ListSelectionListener | BasicListUI.createListSelectionListener() 创建在需要时由 selectionModel 添加到 JList 的 ListSelectionHandler 的实例。
protected ListSelectionListener | BasicComboPopup.createListSelectionListener() 创建观察弹出列表中的选择更改的列表选择侦听器。
ListSelectionListener | BasicFileChooserUI.createListSelectionListener(JFileChooser fc)

javax.swing.plaf.metal 中 ListSelectionListener 的使用

返回 ListSelectionListener 的 javax.swing.plaf.metal 中的方法
 ListSelectionListener MetalFileChooserUI.createListSelectionListener(JFileChooser fc)
创建一个用于文件和目录列表的选择侦听器。

javax.swing.table 中 ListSelectionListener 的使用

实现 ListSelectionListener 的 javax.swing.table 中的类
 class DefaultTableColumnModel
JTable 的标准列处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.MenuDragMouseEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.MenuDragMouseEvent
的使用

使用 MenuDragMouseEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

javax.swing 中 MenuDragMouseEvent 的使用

参数类型为 MenuDragMouseEvent 的 javax.swing 中的方法
protected void | JMenuItem.fireMenuDragMouseDragged(MenuDragMouseEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected void | JMenuItem.fireMenuDragMouseEntered(MenuDragMouseEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected void | JMenuItem.fireMenuDragMouseExited(MenuDragMouseEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected void | JMenuItem.fireMenuDragMouseReleased(MenuDragMouseEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
void | JMenuItem.processMenuDragMouseEvent(MenuDragMouseEvent e) 处理菜单中的鼠标拖动。

javax.swing.event 中 MenuDragMouseEvent 的使用

参数类型为 MenuDragMouseEvent 的 javax.swing.event 中的方法
void | MenuDragMouseListener.menuDragMouseDragged(MenuDragMouseEvent e) 当鼠标被拖动到某一菜单组件的显示区域中时调用。
void | MenuDragMouseListener.menuDragMouseEntered(MenuDragMouseEvent e) 当拖动的鼠标进入某一菜单组件的显示区域时调用。
void | MenuDragMouseListener.menuDragMouseExited(MenuDragMouseEvent e) 当拖动的鼠标离开某一菜单组件的显示区域时调用。
void | MenuDragMouseListener.menuDragMouseReleased(MenuDragMouseEvent e) 当在菜单组件的显示区域中释放拖动鼠标时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.MenuDragMouseListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.MenuDragMouseListener
的使用

使用 MenuDragMouseListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 MenuDragMouseListener 的使用

返回 MenuDragMouseListener 的 javax.swing 中的方法
 MenuDragMouseListener[] JMenuItem.getMenuDragMouseListeners()
返回利用 addMenuDragMouseListener() 添加到此 JMenuItem 的所有 MenuDragMouseListener 组成的数组。

参数类型为 MenuDragMouseListener 的 javax.swing 中的方法
void | JMenuItem.addMenuDragMouseListener(MenuDragMouseListener l) 将 MenuDragMouseListener 添加到菜单项。
void | JMenuItem.removeMenuDragMouseListener(MenuDragMouseListener l) 从菜单项中移除 MenuDragMouseListener。

javax.swing.plaf.basic 中 MenuDragMouseListener 的使用

声明为 MenuDragMouseListener 的 javax.swing.plaf.basic 中的字段
protected  MenuDragMouseListener BasicMenuItemUI.menuDragMouseListener

返回 MenuDragMouseListener 的 javax.swing.plaf.basic 中的方法
protected MenuDragMouseListener | BasicMenuUI.createMenuDragMouseListener(JComponent c)
protected MenuDragMouseListener | BasicMenuItemUI.createMenuDragMouseListener(JComponent c)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.MenuEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.MenuEvent
的使用

使用 MenuEvent 的软件包
javax.swing.event 供 Swing 组件触发的事件使用。

javax.swing.event 中 MenuEvent 的使用

参数类型为 MenuEvent 的 javax.swing.event 中的方法
void | MenuListener.menuCanceled(MenuEvent e) 取消菜单时调用。
void | MenuListener.menuDeselected(MenuEvent e) 取消选择某个菜单时调用。
void | MenuListener.menuSelected(MenuEvent e) 选择某个菜单时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.MenuKeyEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.MenuKeyEvent
的使用

使用 MenuKeyEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

javax.swing 中 MenuKeyEvent 的使用

参数类型为 MenuKeyEvent 的 javax.swing 中的方法
protected void | JMenuItem.fireMenuKeyPressed(MenuKeyEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected void | JMenuItem.fireMenuKeyReleased(MenuKeyEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected void | JMenuItem.fireMenuKeyTyped(MenuKeyEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
void | JMenuItem.processMenuKeyEvent(MenuKeyEvent e) 处理菜单中的快捷键。

javax.swing.event 中 MenuKeyEvent 的使用

参数类型为 MenuKeyEvent 的 javax.swing.event 中的方法
void | MenuKeyListener.menuKeyPressed(MenuKeyEvent e) 已按下某个键时调用。
void | MenuKeyListener.menuKeyReleased(MenuKeyEvent e) 已释放某个键时调用。
void | MenuKeyListener.menuKeyTyped(MenuKeyEvent e) 已键入某个键时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.MenuKeyListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.MenuKeyListener
的使用

使用 MenuKeyListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 MenuKeyListener 的使用

返回 MenuKeyListener 的 javax.swing 中的方法
 MenuKeyListener[] JPopupMenu.getMenuKeyListeners()
返回利用 addMenuKeyListener() 添加到此 JPopupMenu 的所有 MenuKeyListener 组成的数组。
 MenuKeyListener[] JMenuItem.getMenuKeyListeners()
返回利用 addMenuKeyListener() 添加到此 JMenuItem 的所有 MenuKeyListener 的数组。

参数类型为 MenuKeyListener 的 javax.swing 中的方法
void | JPopupMenu.addMenuKeyListener(MenuKeyListener l) 将 MenuKeyListener 添加到弹出菜单。
void | JMenuItem.addMenuKeyListener(MenuKeyListener l) 将 MenuKeyListener 添加到菜单项。
void | JPopupMenu.removeMenuKeyListener(MenuKeyListener l) 从弹出菜单移除 MenuKeyListener。
void | JMenuItem.removeMenuKeyListener(MenuKeyListener l) 从菜单项中移除 MenuKeyListener。

javax.swing.plaf.basic 中 MenuKeyListener 的使用

声明为 MenuKeyListener 的 javax.swing.plaf.basic 中的字段
protected  MenuKeyListener BasicMenuItemUI.menuKeyListener

返回 MenuKeyListener 的 javax.swing.plaf.basic 中的方法
protected MenuKeyListener | BasicMenuUI.createMenuKeyListener(JComponent c)
protected MenuKeyListener | BasicMenuItemUI.createMenuKeyListener(JComponent c)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.MenuListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.MenuListener
的使用

使用 MenuListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 MenuListener 的使用

返回 MenuListener 的 javax.swing 中的方法
 MenuListener[] JMenu.getMenuListeners()
返回利用 addMenuListener() 添加到此 JMenu 的所有 MenuListener 组成的数组。

参数类型为 MenuListener 的 javax.swing 中的方法
void | JMenu.addMenuListener(MenuListener l) 添加菜单事件的侦听器。
void | JMenu.removeMenuListener(MenuListener l) 移除菜单事件的侦听器。

javax.swing.plaf.basic 中 MenuListener 的使用

声明为 MenuListener 的 javax.swing.plaf.basic 中的字段
protected  MenuListener BasicMenuUI.menuListener

返回 MenuListener 的 javax.swing.plaf.basic 中的方法
protected  MenuListener BasicMenuUI.createMenuListener(JComponent c)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.MouseInputAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.MouseInputAdapter
的使用

使用 MouseInputAdapter 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 MouseInputAdapter 的使用

javax.swing.plaf.basic 中 MouseInputAdapter 的子类
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。

声明为 MouseInputAdapter 的 javax.swing.plaf.basic 中的字段
protected  MouseInputAdapter BasicInternalFrameUI.borderListener

返回 MouseInputAdapter 的 javax.swing.plaf.basic 中的方法
protected  MouseInputAdapter BasicInternalFrameUI.createBorderListener(JInternalFrame w)

javax.swing.plaf.metal 中 MouseInputAdapter 的使用

返回 MouseInputAdapter 的 javax.swing.plaf.metal 中的方法
protected  MouseInputAdapter MetalInternalFrameUI.createBorderListener(JInternalFrame w)
返回将在 TitlePane 上安装的 MouseInputAdapter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.MouseInputListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.MouseInputListener
的使用

使用 MouseInputListener 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.event 中 MouseInputListener 的使用

实现 MouseInputListener 的 javax.swing.event 中的类
 class MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

javax.swing.plaf.basic 中 MouseInputListener 的使用

实现 MouseInputListener 的 javax.swing.plaf.basic 中的类
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicInternalFrameUI.GlassPaneDispatcher
class | BasicListUI.MouseInputHandler 鼠标输入和 JList 的焦点处理。
protected class | BasicMenuItemUI.MouseInputHandler
protected class | BasicMenuUI.MouseInputHandler 实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
class | BasicTableHeaderUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicToolBarUI.DockingListener 此类应视为“受保护”内部类。
class | BasicTreeUI.MouseInputHandler 在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。

声明为 MouseInputListener 的 javax.swing.plaf.basic 中的字段
protected MouseInputListener | BasicToolBarUI.dockingListener
protected MouseInputListener | BasicInternalFrameUI.glassPaneDispatcher
protected MouseInputListener | BasicTableUI.mouseInputListener
protected MouseInputListener | BasicTableHeaderUI.mouseInputListener
protected MouseInputListener | BasicListUI.mouseInputListener
protected MouseInputListener | BasicMenuItemUI.mouseInputListener

返回 MouseInputListener 的 javax.swing.plaf.basic 中的方法
protected MouseInputListener | BasicToolBarUI.createDockingListener()
protected MouseInputListener | BasicInternalFrameUI.createGlassPaneDispatcher()
protected MouseInputListener | BasicDesktopIconUI.createMouseInputListener()
protected MouseInputListener | BasicTableUI.createMouseInputListener() 创建 JTable 的鼠标侦听器。
protected MouseInputListener | BasicTableHeaderUI.createMouseInputListener() 创建 JTableHeader 的鼠标侦听器。
protected MouseInputListener | BasicListUI.createMouseInputListener() 创建实现 MouseInputListener 的委托。
protected MouseInputListener | BasicMenuUI.createMouseInputListener(JComponent c)
protected MouseInputListener | BasicMenuItemUI.createMouseInputListener(JComponent c)

javax.swing.plaf.metal 中 MouseInputListener 的使用

实现 MouseInputListener 的 javax.swing.plaf.metal 中的类
protected  class MetalToolBarUI.MetalDockingListener

返回 MouseInputListener 的 javax.swing.plaf.metal 中的方法
protected  MouseInputListener MetalToolBarUI.createDockingListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.PopupMenuEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.PopupMenuEvent
的使用

使用 PopupMenuEvent 的软件包
javax.swing.event 供 Swing 组件触发的事件使用。

javax.swing.event 中 PopupMenuEvent 的使用

参数类型为 PopupMenuEvent 的 javax.swing.event 中的方法
void | PopupMenuListener.popupMenuCanceled(PopupMenuEvent e) 此方法在弹出菜单被取消时调用。
void | PopupMenuListener.popupMenuWillBecomeInvisible(PopupMenuEvent e) 此方法在弹出菜单变得不可见之前调用。
void | PopupMenuListener.popupMenuWillBecomeVisible(PopupMenuEvent e) 此方法在弹出菜单变得可见之前调用

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.PopupMenuListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.PopupMenuListener
的使用

使用 PopupMenuListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 PopupMenuListener 的使用

返回 PopupMenuListener 的 javax.swing 中的方法
 PopupMenuListener[] JComboBox.getPopupMenuListeners()
返回利用 addPopupMenuListener() 添加到此 JComboBox 的所有 PopupMenuListener 组成的数组。
 PopupMenuListener[] JPopupMenu.getPopupMenuListeners()
返回利用 addPopupMenuListener() 添加到此 JMenuItem 的所有 PopupMenuListener 组成的数组。

参数类型为 PopupMenuListener 的 javax.swing 中的方法
void | JComboBox.addPopupMenuListener(PopupMenuListener l) 添加 PopupMenu 侦听器，该侦听器将侦听取自组合框弹出部分的通知消息。
void | JPopupMenu.addPopupMenuListener(PopupMenuListener l) 添加 PopupMenu 侦听器。
void | JComboBox.removePopupMenuListener(PopupMenuListener l) 移除 PopupMenuListener。
void | JPopupMenu.removePopupMenuListener(PopupMenuListener l) 移除 PopupMenu 侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.RowSorterEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.RowSorterEvent
的使用

使用 RowSorterEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

javax.swing 中 RowSorterEvent 的使用

参数类型为 RowSorterEvent 的 javax.swing 中的方法
 void JTable.sorterChanged(RowSorterEvent e)
RowSorter 以某种方式发生了更改的 RowSorterListener 通知。

javax.swing.event 中 RowSorterEvent 的使用

参数类型为 RowSorterEvent 的 javax.swing.event 中的方法
 void RowSorterListener.sorterChanged(RowSorterEvent e)
RowSorter 发生了更改的通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.RowSorterEvent.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.RowSorterEvent.Type
的使用

使用 RowSorterEvent.Type 的软件包
javax.swing.event 供 Swing 组件触发的事件使用。

javax.swing.event 中 RowSorterEvent.Type 的使用

返回 RowSorterEvent.Type 的 javax.swing.event 中的方法
RowSorterEvent.Type | RowSorterEvent.getType() 返回事件的类型。
static RowSorterEvent.Type | RowSorterEvent.Type.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RowSorterEvent.Type[] | RowSorterEvent.Type.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 RowSorterEvent.Type 的 javax.swing.event 中的构造方法
RowSorterEvent(RowSorter source, RowSorterEvent.Type type, int[] previousRowIndexToModel)
创建一个 RowSorterEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.RowSorterListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.RowSorterListener
的使用

使用 RowSorterListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RowSorterListener 的使用

实现 RowSorterListener 的 javax.swing 中的类
 class JTable
JTable 用来显示和编辑常规二维单元表。

参数类型为 RowSorterListener 的 javax.swing 中的方法
void | RowSorter.addRowSorterListener(RowSorterListener l) 添加一个 RowSorterListener 来接收有关此 RowSorter 的通知。
void | RowSorter.removeRowSorterListener(RowSorterListener l) 移除一个 RowSorterListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.SwingPropertyChangeSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.SwingPropertyChangeSupport
的使用

使用 SwingPropertyChangeSupport 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 SwingPropertyChangeSupport 的使用

声明为 SwingPropertyChangeSupport 的 javax.swing 中的字段
protected  SwingPropertyChangeSupport AbstractAction.changeSupport
如果已经注册了任意 PropertyChangeListener，则 changeSupport 字段负责描述它们。

javax.swing.tree 中 SwingPropertyChangeSupport 的使用

声明为 SwingPropertyChangeSupport 的 javax.swing.tree 中的字段
protected  SwingPropertyChangeSupport DefaultTreeSelectionModel.changeSupport
用于接收通知的注册侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.TableColumnModelEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.TableColumnModelEvent
的使用

使用 TableColumnModelEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableColumnModelEvent 的使用

参数类型为 TableColumnModelEvent 的 javax.swing 中的方法
void | JTable.columnAdded(TableColumnModelEvent e) 将列添加到表的列模型时调用。
void | JTable.AccessibleJTable.columnAdded(TableColumnModelEvent e) 跟踪表内容的变更（列插入）
void | JTable.columnMoved(TableColumnModelEvent e) 重新定位列时调用。
void | JTable.AccessibleJTable.columnMoved(TableColumnModelEvent e) 跟踪列重新定位的变更。
void | JTable.columnRemoved(TableColumnModelEvent e) 从表的列模型中移除列时调用。
void | JTable.AccessibleJTable.columnRemoved(TableColumnModelEvent e) 跟踪表内容的变更（列删除）

javax.swing.event 中 TableColumnModelEvent 的使用

参数类型为 TableColumnModelEvent 的 javax.swing.event 中的方法
void | TableColumnModelListener.columnAdded(TableColumnModelEvent e) 告知侦听器有一列被添加到模型中。
void | TableColumnModelListener.columnMoved(TableColumnModelEvent e) 告知侦听器有一列被重新调整位置。
void | TableColumnModelListener.columnRemoved(TableColumnModelEvent e) 告知侦听器有一列从模型中移除。

javax.swing.table 中 TableColumnModelEvent 的使用

参数类型为 TableColumnModelEvent 的 javax.swing.table 中的方法
void | JTableHeader.columnAdded(TableColumnModelEvent e) 将列添加到表列模型时调用。
void | JTableHeader.columnMoved(TableColumnModelEvent e) 重新定位列时调用。
void | JTableHeader.columnRemoved(TableColumnModelEvent e) 从表列模型中移除列时调用。
protected void | DefaultTableColumnModel.fireColumnAdded(TableColumnModelEvent e) 通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected void | DefaultTableColumnModel.fireColumnMoved(TableColumnModelEvent e) 通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected void | DefaultTableColumnModel.fireColumnRemoved(TableColumnModelEvent e) 通知所有对此事件类型的通知感兴趣的已注册侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.TableColumnModelListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.TableColumnModelListener
的使用

使用 TableColumnModelListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableColumnModelListener 的使用

实现 TableColumnModelListener 的 javax.swing 中的类
class | JTable JTable 用来显示和编辑常规二维单元表。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。

javax.swing.table 中 TableColumnModelListener 的使用

实现 TableColumnModelListener 的 javax.swing.table 中的类
 class JTableHeader
这是管理 JTable 的头的对象。

返回 TableColumnModelListener 的 javax.swing.table 中的方法
 TableColumnModelListener[] DefaultTableColumnModel.getColumnModelListeners()
返回一个包含在此模型上注册的所有列模型侦听器的数组。

参数类型为 TableColumnModelListener 的 javax.swing.table 中的方法
void | DefaultTableColumnModel.addColumnModelListener(TableColumnModelListener x) 添加表列模型事件的侦听器。
void | TableColumnModel.addColumnModelListener(TableColumnModelListener x) 为表列模型事件添加侦听器。
void | DefaultTableColumnModel.removeColumnModelListener(TableColumnModelListener x) 移除表列模型事件的侦听器。
void | TableColumnModel.removeColumnModelListener(TableColumnModelListener x) 移除表列模型事件的侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.TableModelEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.TableModelEvent
的使用

使用 TableModelEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableModelEvent 的使用

参数类型为 TableModelEvent 的 javax.swing 中的方法
void | JTable.tableChanged(TableModelEvent e) 当此表的 TableModel 生成 TableModelEvent 时调用。
void | JTable.AccessibleJTable.tableChanged(TableModelEvent e) 跟踪表内容的变更
void | JTable.AccessibleJTable.tableRowsDeleted(TableModelEvent e) 跟踪表内容的变更（行删除）
void | JTable.AccessibleJTable.tableRowsInserted(TableModelEvent e) 跟踪表内容的变更（行插入）

javax.swing.event 中 TableModelEvent 的使用

参数类型为 TableModelEvent 的 javax.swing.event 中的方法
 void TableModelListener.tableChanged(TableModelEvent e)
此细粒度通知告知侦听器单元格、行或列的哪些具体范围发生了更改。

javax.swing.table 中 TableModelEvent 的使用

参数类型为 TableModelEvent 的 javax.swing.table 中的方法
void | AbstractTableModel.fireTableChanged(TableModelEvent e) 将给定的通知事件转发到所有将自身注册为此表模型的侦听器的 TableModelListeners。
void | DefaultTableModel.newDataAvailable(TableModelEvent event) 等效于 fireTableChanged。
void | DefaultTableModel.newRowsAdded(TableModelEvent e) 确保新行的列数正确。
void | DefaultTableModel.rowsRemoved(TableModelEvent event) 等效于 fireTableChanged。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.TableModelListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.TableModelListener
的使用

使用 TableModelListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableModelListener 的使用

实现 TableModelListener 的 javax.swing 中的类
class | JTable JTable 用来显示和编辑常规二维单元表。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。

javax.swing.table 中 TableModelListener 的使用

返回 TableModelListener 的 javax.swing.table 中的方法
 TableModelListener[] AbstractTableModel.getTableModelListeners()
返回一个包含在此模型上注册的所有表模型侦听器的数组。

参数类型为 TableModelListener 的 javax.swing.table 中的方法
void | AbstractTableModel.addTableModelListener(TableModelListener l) 每次数据模型发生更改时，就向被通知的列表添加一个侦听器。
void | TableModel.addTableModelListener(TableModelListener l) 每当数据模型发生更改时，就将一个侦听器添加到被通知的列表中。
void | AbstractTableModel.removeTableModelListener(TableModelListener l) 每次数据模型发生更改时，就从被通知的列表移除一个侦听器。
void | TableModel.removeTableModelListener(TableModelListener l) 每当数据模型发生更改时，就从被通知的列表中移除一个侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.TreeExpansionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.TreeExpansionEvent
的使用

使用 TreeExpansionEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeExpansionEvent 的使用

参数类型为 TreeExpansionEvent 的 javax.swing 中的方法
void | JTree.AccessibleJTree.treeCollapsed(TreeExpansionEvent e) 树折叠通知。
void | JTree.AccessibleJTree.treeExpanded(TreeExpansionEvent e) 树模型展开通知。

javax.swing.event 中 TreeExpansionEvent 的使用

参数类型为 TreeExpansionEvent 的 javax.swing.event 中的方法
void | TreeExpansionListener.treeCollapsed(TreeExpansionEvent event) 每当树中的一个项被折叠时调用。
void | TreeExpansionListener.treeExpanded(TreeExpansionEvent event) 每当树中的一个项被扩展时调用。
void | TreeWillExpandListener.treeWillCollapse(TreeExpansionEvent event) 每当树中的一个节点将被折叠时调用。
void | TreeWillExpandListener.treeWillExpand(TreeExpansionEvent event) 每当树中的一个节点将被扩展时调用。

javax.swing.plaf.basic 中 TreeExpansionEvent 的使用

参数类型为 TreeExpansionEvent 的 javax.swing.plaf.basic 中的方法
void | BasicTreeUI.TreeExpansionHandler.treeCollapsed(TreeExpansionEvent event) 每当树中的项被折叠时调用。
void | BasicTreeUI.TreeExpansionHandler.treeExpanded(TreeExpansionEvent event) 每当树中的项被展开时调用。

javax.swing.tree 中 TreeExpansionEvent 的使用

声明为 TreeExpansionEvent 的 javax.swing.tree 中的字段
protected  TreeExpansionEvent ExpandVetoException.event
为其创建异常的事件。

参数类型为 TreeExpansionEvent 的 javax.swing.tree 中的构造方法
ExpandVetoException(TreeExpansionEvent event)
构造不带任何消息的 ExpandVetoException 对象。
ExpandVetoException(TreeExpansionEvent event, String message)
构造带指定消息的 ExpandVetoException 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.TreeExpansionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.TreeExpansionListener
的使用

使用 TreeExpansionListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 TreeExpansionListener 的使用

实现 TreeExpansionListener 的 javax.swing 中的类
protected  class JTree.AccessibleJTree
此类实现 JTree 类的可访问性支持。

返回 TreeExpansionListener 的 javax.swing 中的方法
 TreeExpansionListener[] JTree.getTreeExpansionListeners()
返回使用 addTreeExpansionListener() 添加到此 JTree 的所有 TreeExpansionListener 的数组。

参数类型为 TreeExpansionListener 的 javax.swing 中的方法
void | JTree.addTreeExpansionListener(TreeExpansionListener tel) 为 TreeExpansion 事件添加侦听器。
void | JTree.removeTreeExpansionListener(TreeExpansionListener tel) 移除 TreeExpansion 事件的侦听器。

javax.swing.plaf.basic 中 TreeExpansionListener 的使用

实现 TreeExpansionListener 的 javax.swing.plaf.basic 中的类
 class BasicTreeUI.TreeExpansionHandler
更新 TreeState 以响应节点的展开/折叠。

返回 TreeExpansionListener 的 javax.swing.plaf.basic 中的方法
protected  TreeExpansionListener BasicTreeUI.createTreeExpansionListener()
创建并返回在节点展开状态更改时负责更新 treestate 的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.TreeModelEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.TreeModelEvent
的使用

使用 TreeModelEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeModelEvent 的使用

参数类型为 TreeModelEvent 的 javax.swing 中的方法
void | JTree.TreeModelHandler.treeNodesChanged(TreeModelEvent e)
void | JTree.AccessibleJTree.treeNodesChanged(TreeModelEvent e) 树模型节点更改通知。
void | JTree.TreeModelHandler.treeNodesInserted(TreeModelEvent e)
void | JTree.AccessibleJTree.treeNodesInserted(TreeModelEvent e) 树模型节点更改通知。
void | JTree.TreeModelHandler.treeNodesRemoved(TreeModelEvent e)
void | JTree.AccessibleJTree.treeNodesRemoved(TreeModelEvent e) 树模型节点更改通知。
void | JTree.TreeModelHandler.treeStructureChanged(TreeModelEvent e)
void | JTree.AccessibleJTree.treeStructureChanged(TreeModelEvent e) 树模型结构更改通知。

javax.swing.event 中 TreeModelEvent 的使用

参数类型为 TreeModelEvent 的 javax.swing.event 中的方法
void | TreeModelListener.treeNodesChanged(TreeModelEvent e) 在已经以某种方式更改节点（或同级节点集）后调用。
void | TreeModelListener.treeNodesInserted(TreeModelEvent e) 在已将节点插入树中以后调用。
void | TreeModelListener.treeNodesRemoved(TreeModelEvent e) 在已从树中移除节点后调用。
void | TreeModelListener.treeStructureChanged(TreeModelEvent e) 在树结构中从某个给定节点开始向下的地方发生彻底更改之后调用。

javax.swing.plaf.basic 中 TreeModelEvent 的使用

参数类型为 TreeModelEvent 的 javax.swing.plaf.basic 中的方法
void | BasicTreeUI.TreeModelHandler.treeNodesChanged(TreeModelEvent e)
void | BasicTreeUI.TreeModelHandler.treeNodesInserted(TreeModelEvent e)
void | BasicTreeUI.TreeModelHandler.treeNodesRemoved(TreeModelEvent e)
void | BasicTreeUI.TreeModelHandler.treeStructureChanged(TreeModelEvent e)

javax.swing.tree 中 TreeModelEvent 的使用

参数类型为 TreeModelEvent 的 javax.swing.tree 中的方法
void | FixedHeightLayoutCache.treeNodesChanged(TreeModelEvent e) 在已经以某种方式更改节点（或同级节点集）后调用。
void | VariableHeightLayoutCache.treeNodesChanged(TreeModelEvent e) 按某种方式更改节点（或兄弟节点集）后进行调用。
abstract void | AbstractLayoutCache.treeNodesChanged(TreeModelEvent e) 在某个节点（或一组兄弟节点）以某种方式更改后进行调用。
void | FixedHeightLayoutCache.treeNodesInserted(TreeModelEvent e) 将节点插入树之后进行调用。
void | VariableHeightLayoutCache.treeNodesInserted(TreeModelEvent e) 将节点插入树后进行调用。
abstract void | AbstractLayoutCache.treeNodesInserted(TreeModelEvent e) 将节点插入树之后进行调用。
void | FixedHeightLayoutCache.treeNodesRemoved(TreeModelEvent e) 将节点从树移除之后进行调用。
void | VariableHeightLayoutCache.treeNodesRemoved(TreeModelEvent e) 将节点从树删除后进行调用。
abstract void | AbstractLayoutCache.treeNodesRemoved(TreeModelEvent e) 将节点从树移除之后进行调用。
void | FixedHeightLayoutCache.treeStructureChanged(TreeModelEvent e) 树彻底更改给定节点以下的结构之后进行调用。
void | VariableHeightLayoutCache.treeStructureChanged(TreeModelEvent e) 树彻底更改给定节点以下的结构之后进行调用。
abstract void | AbstractLayoutCache.treeStructureChanged(TreeModelEvent e) 树彻底更改给定节点以下的结构之后进行调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.TreeModelListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.TreeModelListener
的使用

使用 TreeModelListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeModelListener 的使用

实现 TreeModelListener 的 javax.swing 中的类
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JTree.TreeModelHandler 在移除或更改节点时，监听模型并相应地更新 expandedState。

声明为 TreeModelListener 的 javax.swing 中的字段
protected  TreeModelListener JTree.treeModelListener
更新 expandedState。

返回 TreeModelListener 的 javax.swing 中的方法
protected  TreeModelListener JTree.createTreeModelListener()
创建并返回 TreeModelHandler 的一个实例。

javax.swing.plaf.basic 中 TreeModelListener 的使用

实现 TreeModelListener 的 javax.swing.plaf.basic 中的类
 class BasicTreeUI.TreeModelHandler
将所有 TreeModel 事件转发到 TreeState。

返回 TreeModelListener 的 javax.swing.plaf.basic 中的方法
protected  TreeModelListener BasicTreeUI.createTreeModelListener()
返回可以在模型更改时更新树的侦听器。

javax.swing.tree 中 TreeModelListener 的使用

返回 TreeModelListener 的 javax.swing.tree 中的方法
 TreeModelListener[] DefaultTreeModel.getTreeModelListeners()
返回在此模型上注册的所有树模型侦听器组成的数组。

参数类型为 TreeModelListener 的 javax.swing.tree 中的方法
 void DefaultTreeModel.addTreeModelListener(TreeModelListener l)
为树更改后发布的 TreeModelEvent 添加侦听器。
 void TreeModel.addTreeModelListener(TreeModelListener l)
为树更改后发布的 TreeModelEvent 添加侦听器。
 void DefaultTreeModel.removeTreeModelListener(TreeModelListener l)
移除以前使用 addTreeModelListener() 添加的侦听器。
 void TreeModel.removeTreeModelListener(TreeModelListener l)
移除以前通过 addTreeModelListener 添加的侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.TreeSelectionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.TreeSelectionEvent
的使用

使用 TreeSelectionEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeSelectionEvent 的使用

参数类型为 TreeSelectionEvent 的 javax.swing 中的方法
protected void | JTree.fireValueChanged(TreeSelectionEvent e) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
void | JTree.TreeSelectionRedirector.valueChanged(TreeSelectionEvent e) 在选择更改时由 TreeSelectionModel 调用。
void | JTree.AccessibleJTree.valueChanged(TreeSelectionEvent e) 树选择侦听器值更改方法。

javax.swing.event 中 TreeSelectionEvent 的使用

参数类型为 TreeSelectionEvent 的 javax.swing.event 中的方法
 void TreeSelectionListener.valueChanged(TreeSelectionEvent e)
每当选择值发生更改时调用。

javax.swing.plaf.basic 中 TreeSelectionEvent 的使用

参数类型为 TreeSelectionEvent 的 javax.swing.plaf.basic 中的方法
 void BasicTreeUI.TreeSelectionHandler.valueChanged(TreeSelectionEvent event)
当显示的树中发生选择更改时传递消息。

javax.swing.tree 中 TreeSelectionEvent 的使用

参数类型为 TreeSelectionEvent 的 javax.swing.tree 中的方法
protected void | DefaultTreeSelectionModel.fireValueChanged(TreeSelectionEvent e) 通知已注册此对象上的树选择事件的所有侦听器。
void | DefaultTreeCellEditor.valueChanged(TreeSelectionEvent e) 重置 lastPath。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.TreeSelectionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.TreeSelectionListener
的使用

使用 TreeSelectionListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeSelectionListener 的使用

实现 TreeSelectionListener 的 javax.swing 中的类
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JTree.TreeSelectionRedirector 使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。

返回 TreeSelectionListener 的 javax.swing 中的方法
 TreeSelectionListener[] JTree.getTreeSelectionListeners()
返回使用 addTreeSelectionListener() 添加到此 JTree 的所有 TreeSelectionListener 的数组。

参数类型为 TreeSelectionListener 的 javax.swing 中的方法
void | JTree.addTreeSelectionListener(TreeSelectionListener tsl) 为 TreeSelection 事件添加侦听器。
void | JTree.removeTreeSelectionListener(TreeSelectionListener tsl) 移除 TreeSelection 侦听器。

javax.swing.plaf.basic 中 TreeSelectionListener 的使用

实现 TreeSelectionListener 的 javax.swing.plaf.basic 中的类
 class BasicTreeUI.TreeSelectionHandler
侦听选择模型中的更改并相应地更新显示。

返回 TreeSelectionListener 的 javax.swing.plaf.basic 中的方法
protected  TreeSelectionListener BasicTreeUI.createTreeSelectionListener()
创建基于选择更改方法更新显示的侦听器。

javax.swing.tree 中 TreeSelectionListener 的使用

实现 TreeSelectionListener 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor
TreeCellEditor。

返回 TreeSelectionListener 的 javax.swing.tree 中的方法
 TreeSelectionListener[] DefaultTreeSelectionModel.getTreeSelectionListeners()
返回已在此模型上注册的所有树选择侦听器组成的数组。

参数类型为 TreeSelectionListener 的 javax.swing.tree 中的方法
void | DefaultTreeSelectionModel.addTreeSelectionListener(TreeSelectionListener x) 向每次已选的 TreePaths 集合发生更改时都会得到通知的侦听器列表添加 x。
void | TreeSelectionModel.addTreeSelectionListener(TreeSelectionListener x) 向侦听器列表添加 x，每次选定的 TreePath 集合发生更改时，这些侦听器都会得到通知。
void | DefaultTreeSelectionModel.removeTreeSelectionListener(TreeSelectionListener x) 从每次已选的 TreePaths 集合发生更改时都会得到通知的侦听器列表中移除 x。
void | TreeSelectionModel.removeTreeSelectionListener(TreeSelectionListener x) 从每次已选的 TreePath 集合发生更改时都会得到通知的侦听器列表中移除 x。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.TreeWillExpandListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.TreeWillExpandListener
的使用

使用 TreeWillExpandListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 TreeWillExpandListener 的使用

返回 TreeWillExpandListener 的 javax.swing 中的方法
 TreeWillExpandListener[] JTree.getTreeWillExpandListeners()
返回使用 addTreeWillExpandListener() 添加到此 JTree 的所有 TreeWillExpandListener 的数组。

参数类型为 TreeWillExpandListener 的 javax.swing 中的方法
void | JTree.addTreeWillExpandListener(TreeWillExpandListener tel) 为 TreeWillExpand 事件添加侦听器。
void | JTree.removeTreeWillExpandListener(TreeWillExpandListener tel) 移除 TreeWillExpand 事件的侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.event.UndoableEditEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.UndoableEditEvent
的使用

使用 UndoableEditEvent 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.event 中 UndoableEditEvent 的使用

参数类型为 UndoableEditEvent 的 javax.swing.event 中的方法
 void UndoableEditListener.undoableEditHappened(UndoableEditEvent e)
发生了可撤消的编辑操作

javax.swing.text 中 UndoableEditEvent 的使用

参数类型为 UndoableEditEvent 的 javax.swing.text 中的方法
protected  void AbstractDocument.fireUndoableEditUpdate(UndoableEditEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。

javax.swing.text.html 中 UndoableEditEvent 的使用

参数类型为 UndoableEditEvent 的 javax.swing.text.html 中的方法
protected  void HTMLDocument.fireUndoableEditUpdate(UndoableEditEvent e)
通知所有需要此事件类型的通知的已注册侦听器。

javax.swing.undo 中 UndoableEditEvent 的使用

参数类型为 UndoableEditEvent 的 javax.swing.undo 中的方法
 void UndoManager.undoableEditHappened(UndoableEditEvent e)
一个 UndoableEditListener 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.event.UndoableEditListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.UndoableEditListener
的使用

使用 UndoableEditListener 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.text 中 UndoableEditListener 的使用

返回 UndoableEditListener 的 javax.swing.text 中的方法
 UndoableEditListener[] AbstractDocument.getUndoableEditListeners()
返回在此文档上注册的所有可撤消编辑侦听器的数组。

参数类型为 UndoableEditListener 的 javax.swing.text 中的方法
void | AbstractDocument.addUndoableEditListener(UndoableEditListener listener) 添加负责通知任何更改的撤消侦听器。
void | Document.addUndoableEditListener(UndoableEditListener listener) 注册给定的观察者以便开始接收文档发生不可撤消的编辑的通知。
void | AbstractDocument.removeUndoableEditListener(UndoableEditListener listener) 移除撤消侦听器。
void | Document.removeUndoableEditListener(UndoableEditListener listener) 将给定的观察者从通知列表中撤消注册，这样就不再接收更新。

javax.swing.undo 中 UndoableEditListener 的使用

实现 UndoableEditListener 的 javax.swing.undo 中的类
 class UndoManager
UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

类型参数类型为 UndoableEditListener 的 javax.swing.undo 中的字段
protected  Vector<UndoableEditListener> UndoableEditSupport.listeners

返回 UndoableEditListener 的 javax.swing.undo 中的方法
 UndoableEditListener[] UndoableEditSupport.getUndoableEditListeners()
返回使用 addUndoableEditListener() 添加到此 UndoableEditSupport 中的所有 UndoableEditListener 组成的数组。

参数类型为 UndoableEditListener 的 javax.swing.undo 中的方法
void | UndoableEditSupport.addUndoableEditListener(UndoableEditListener l) 注册一个 UndoableEditListener。
void | UndoableEditSupport.removeUndoableEditListener(UndoableEditListener l) 移除一个 UndoableEditListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.filechooser (Java 2 Platform SE 6)

 javax.swing.filechooser
类
FileFilter
FileNameExtensionFilter
FileSystemView
FileView


类 javax.swing.filechooser.FileFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.filechooser.FileFilter
的使用

使用 FileFilter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 FileFilter 的使用

返回 FileFilter 的 javax.swing 中的方法
FileFilter | JFileChooser.getAcceptAllFileFilter() 返回 AcceptAll 文件过滤器。
FileFilter[] | JFileChooser.getChoosableFileFilters() 获得用户可选择的文件过滤器列表。
FileFilter | JFileChooser.getFileFilter() 返回当前选择的文件过滤器。

参数类型为 FileFilter 的 javax.swing 中的方法
void | JFileChooser.addChoosableFileFilter(FileFilter filter) 向用户可选择的文件过滤器列表添加一个过滤器。
boolean | JFileChooser.removeChoosableFileFilter(FileFilter f) 从用户可选择的文件过滤器列表中移除一个过滤器。
void | JFileChooser.setFileFilter(FileFilter filter) 设置当前文件过滤器。

javax.swing.filechooser 中 FileFilter 的使用

javax.swing.filechooser 中 FileFilter 的子类
 class FileNameExtensionFilter
FileFilter 的一个实现，它使用指定的扩展名集合进行过滤。

javax.swing.plaf 中 FileFilter 的使用

返回 FileFilter 的 javax.swing.plaf 中的方法
abstract  FileFilter FileChooserUI.getAcceptAllFileFilter(JFileChooser fc)

javax.swing.plaf.basic 中 FileFilter 的使用

javax.swing.plaf.basic 中 FileFilter 的子类
protected  class BasicFileChooserUI.AcceptAllFileFilter

返回 FileFilter 的 javax.swing.plaf.basic 中的方法
 FileFilter BasicFileChooserUI.getAcceptAllFileFilter(JFileChooser fc)
返回默认接受所有文件过滤器

javax.swing.plaf.metal 中 FileFilter 的使用

声明为 FileFilter 的 javax.swing.plaf.metal 中的字段
protected  FileFilter[] MetalFileChooserUI.FilterComboBoxModel.filters

javax.swing.plaf.multi 中 FileFilter 的使用

返回 FileFilter 的 javax.swing.plaf.multi 中的方法
 FileFilter MultiFileChooserUI.getAcceptAllFileFilter(JFileChooser a)
在由此对象处理的每个 UI 上调用 getAcceptAllFileFilter 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.filechooser.FileNameExtensionFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.filechooser.FileNameExtensionFilter
的使用

没有 javax.swing.filechooser.FileNameExtensionFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.filechooser.FileSystemView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.filechooser.FileSystemView
的使用

使用 FileSystemView 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。

javax.swing 中 FileSystemView 的使用

返回 FileSystemView 的 javax.swing 中的方法
 FileSystemView JFileChooser.getFileSystemView()
返回文件系统视图。

参数类型为 FileSystemView 的 javax.swing 中的方法
void | JFileChooser.setFileSystemView(FileSystemView fsv) 设置为访问和创建文件系统资源（如查找软驱和获得根驱动器列表），JFileChooser 所使用的文件系统视图。
protected void | JFileChooser.setup(FileSystemView view) 执行公共的构造方法初始化和设置。

参数类型为 FileSystemView 的 javax.swing 中的构造方法
JFileChooser(File currentDirectory, FileSystemView fsv)
使用给定的当前目录和 FileSystemView 构造一个 JFileChooser。
JFileChooser(FileSystemView fsv)
使用给定的 FileSystemView 构造一个 JFileChooser。
JFileChooser(String currentDirectoryPath, FileSystemView fsv)
使用给定的当前目录路径和 FileSystemView 构造一个 JFileChooser。

javax.swing.filechooser 中 FileSystemView 的使用

返回 FileSystemView 的 javax.swing.filechooser 中的方法
static FileSystemView FileSystemView.getFileSystemView()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.filechooser.FileView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.filechooser.FileView
的使用

使用 FileView 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 FileView 的使用

返回 FileView 的 javax.swing 中的方法
 FileView JFileChooser.getFileView()
返回当前的文件视图。

参数类型为 FileView 的 javax.swing 中的方法
 void JFileChooser.setFileView(FileView fileView)
设置用于检索 UI 信息的文件视图，如表示文件的图标或文件的类型描述。

javax.swing.plaf 中 FileView 的使用

返回 FileView 的 javax.swing.plaf 中的方法
abstract  FileView FileChooserUI.getFileView(JFileChooser fc)

javax.swing.plaf.basic 中 FileView 的使用

javax.swing.plaf.basic 中 FileView 的子类
protected  class BasicFileChooserUI.BasicFileView

返回 FileView 的 javax.swing.plaf.basic 中的方法
 FileView BasicFileChooserUI.getFileView(JFileChooser fc)

javax.swing.plaf.multi 中 FileView 的使用

返回 FileView 的 javax.swing.plaf.multi 中的方法
 FileView MultiFileChooserUI.getFileView(JFileChooser a)
在由此对象处理的每个 UI 上调用 getFileView 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.plaf (Java 2 Platform SE 6)

 javax.swing.plaf
接口
UIResource
类
ActionMapUIResource
BorderUIResource
BorderUIResource.BevelBorderUIResource
BorderUIResource.CompoundBorderUIResource
BorderUIResource.EmptyBorderUIResource
BorderUIResource.EtchedBorderUIResource
BorderUIResource.LineBorderUIResource
BorderUIResource.MatteBorderUIResource
BorderUIResource.TitledBorderUIResource
ButtonUI
ColorChooserUI
ColorUIResource
ComboBoxUI
ComponentInputMapUIResource
ComponentUI
DesktopIconUI
DesktopPaneUI
DimensionUIResource
FileChooserUI
FontUIResource
IconUIResource
InputMapUIResource
InsetsUIResource
InternalFrameUI
LabelUI
ListUI
MenuBarUI
MenuItemUI
OptionPaneUI
PanelUI
PopupMenuUI
ProgressBarUI
RootPaneUI
ScrollBarUI
ScrollPaneUI
SeparatorUI
SliderUI
SpinnerUI
SplitPaneUI
TabbedPaneUI
TableHeaderUI
TableUI
TextUI
ToolBarUI
ToolTipUI
TreeUI
ViewportUI


javax.swing.plaf.basic (Java 2 Platform SE 6)

 javax.swing.plaf.basic
接口
ComboPopup
类
BasicArrowButton
BasicBorders
BasicBorders.ButtonBorder
BasicBorders.FieldBorder
BasicBorders.MarginBorder
BasicBorders.MenuBarBorder
BasicBorders.RadioButtonBorder
BasicBorders.RolloverButtonBorder
BasicBorders.SplitPaneBorder
BasicBorders.ToggleButtonBorder
BasicButtonListener
BasicButtonUI
BasicCheckBoxMenuItemUI
BasicCheckBoxUI
BasicColorChooserUI
BasicComboBoxEditor
BasicComboBoxEditor.UIResource
BasicComboBoxRenderer
BasicComboBoxRenderer.UIResource
BasicComboBoxUI
BasicComboPopup
BasicDesktopIconUI
BasicDesktopPaneUI
BasicDirectoryModel
BasicEditorPaneUI
BasicFileChooserUI
BasicFormattedTextFieldUI
BasicGraphicsUtils
BasicHTML
BasicIconFactory
BasicInternalFrameTitlePane
BasicInternalFrameUI
BasicLabelUI
BasicListUI
BasicLookAndFeel
BasicMenuBarUI
BasicMenuItemUI
BasicMenuUI
BasicOptionPaneUI
BasicOptionPaneUI.ButtonAreaLayout
BasicPanelUI
BasicPasswordFieldUI
BasicPopupMenuSeparatorUI
BasicPopupMenuUI
BasicProgressBarUI
BasicRadioButtonMenuItemUI
BasicRadioButtonUI
BasicRootPaneUI
BasicScrollBarUI
BasicScrollPaneUI
BasicSeparatorUI
BasicSliderUI
BasicSpinnerUI
BasicSplitPaneDivider
BasicSplitPaneUI
BasicTabbedPaneUI
BasicTableHeaderUI
BasicTableUI
BasicTextAreaUI
BasicTextFieldUI
BasicTextPaneUI
BasicTextUI
BasicTextUI.BasicCaret
BasicTextUI.BasicHighlighter
BasicToggleButtonUI
BasicToolBarSeparatorUI
BasicToolBarUI
BasicToolTipUI
BasicTreeUI
BasicViewportUI
DefaultMenuLayout


类 javax.swing.plaf.basic.BasicArrowButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicArrowButton
的使用

使用 BasicArrowButton 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicArrowButton 的使用

javax.swing.plaf.metal 中 BasicArrowButton 的子类
 class MetalScrollButton
Metal 滚动条箭头的 JButton 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders
的使用

没有 javax.swing.plaf.basic.BasicBorders 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.ButtonBorder
的使用

使用 BasicBorders.ButtonBorder 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicBorders.ButtonBorder 的使用

javax.swing.plaf.basic 中 BasicBorders.ButtonBorder 的子类
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.ToggleButtonBorder

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.FieldBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.FieldBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.FieldBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.MarginBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.MarginBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.MarginBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicButtonListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicButtonListener
的使用

使用 BasicButtonListener 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicButtonListener 的使用

返回 BasicButtonListener 的 javax.swing.plaf.basic 中的方法
protected  BasicButtonListener BasicButtonUI.createButtonListener(AbstractButton b)

javax.swing.plaf.metal 中 BasicButtonListener 的使用

返回 BasicButtonListener 的 javax.swing.plaf.metal 中的方法
protected  BasicButtonListener MetalButtonUI.createButtonListener(AbstractButton b)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicButtonUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicButtonUI
的使用

使用 BasicButtonUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicButtonUI 的使用

javax.swing.plaf.basic 中 BasicButtonUI 的子类
class | BasicCheckBoxUI BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicRadioButtonUI BasicRadioButtonUI 的 RadioButtonUI 实现
class | BasicToggleButtonUI BasicToggleButton 实现

javax.swing.plaf.metal 中 BasicButtonUI 的使用

javax.swing.plaf.metal 中 BasicButtonUI 的子类
class | MetalButtonUI MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
class | MetalCheckBoxUI MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalRadioButtonUI MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalToggleButtonUI MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
的使用

没有 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicCheckBoxUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicCheckBoxUI
的使用

没有 javax.swing.plaf.basic.BasicCheckBoxUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicColorChooserUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicColorChooserUI
的使用

没有 javax.swing.plaf.basic.BasicColorChooserUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler
的使用

没有 javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxEditor
的使用

使用 BasicComboBoxEditor 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicComboBoxEditor 的使用

javax.swing.plaf.basic 中 BasicComboBoxEditor 的子类
static class BasicComboBoxEditor.UIResource
实现 UIResource 的 BasicComboBoxEditor 的子类。

javax.swing.plaf.metal 中 BasicComboBoxEditor 的使用

javax.swing.plaf.metal 中 BasicComboBoxEditor 的子类
class | MetalComboBoxEditor Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的一个子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxEditor.UIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxEditor.UIResource
的使用

没有 javax.swing.plaf.basic.BasicComboBoxEditor.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxRenderer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxRenderer
的使用

使用 BasicComboBoxRenderer 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicComboBoxRenderer 的使用

javax.swing.plaf.basic 中 BasicComboBoxRenderer 的子类
static class BasicComboBoxRenderer.UIResource
实现 UIResource 的 BasicComboBoxRenderer 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource
的使用

没有 javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI
的使用

使用 BasicComboBoxUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicComboBoxUI 的使用

javax.swing.plaf.metal 中 BasicComboBoxUI 的子类
 class MetalComboBoxUI
JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
的使用

使用 BasicComboBoxUI.ComboBoxLayoutManager 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicComboBoxUI.ComboBoxLayoutManager 的使用

javax.swing.plaf.metal 中 BasicComboBoxUI.ComboBoxLayoutManager 的子类
 class MetalComboBoxUI.MetalComboBoxLayoutManager
此内部类因编译器故障而被标记为 "public"。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler
的使用

没有 javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
的使用

没有 javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
的使用

没有 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler
的使用

使用 BasicComboBoxUI.PropertyChangeHandler 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicComboBoxUI.PropertyChangeHandler 的使用

javax.swing.plaf.metal 中 BasicComboBoxUI.PropertyChangeHandler 的子类
 class MetalComboBoxUI.MetalPropertyChangeListener
此内部类由于编译器故障而被标记为 "public"。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup
的使用

使用 BasicComboPopup 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicComboPopup 的使用

javax.swing.plaf.metal 中 BasicComboPopup 的子类
 class MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.ItemHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.ItemHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.ItemHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopIconUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopIconUI
的使用

使用 BasicDesktopIconUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicDesktopIconUI 的使用

javax.swing.plaf.metal 中 BasicDesktopIconUI 的子类
 class MetalDesktopIconUI
Metal 桌面图标。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDirectoryModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDirectoryModel
的使用

使用 BasicDirectoryModel 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicDirectoryModel 的使用

返回 BasicDirectoryModel 的 javax.swing.plaf.basic 中的方法
 BasicDirectoryModel BasicFileChooserUI.getModel()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicEditorPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicEditorPaneUI
的使用

使用 BasicEditorPaneUI 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicEditorPaneUI 的使用

javax.swing.plaf.basic 中 BasicEditorPaneUI 的子类
 class BasicTextPaneUI
为样式化文本编辑器提供外观。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI
的使用

使用 BasicFileChooserUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicFileChooserUI 的使用

javax.swing.plaf.metal 中 BasicFileChooserUI 的子类
 class MetalFileChooserUI
FileChooser 的 Metal L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFormattedTextFieldUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFormattedTextFieldUI
的使用

没有 javax.swing.plaf.basic.BasicFormattedTextFieldUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicGraphicsUtils 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicGraphicsUtils
的使用

没有 javax.swing.plaf.basic.BasicGraphicsUtils 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicHTML 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicHTML
的使用

没有 javax.swing.plaf.basic.BasicHTML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicIconFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicIconFactory
的使用

没有 javax.swing.plaf.basic.BasicIconFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane
的使用

使用 BasicInternalFrameTitlePane 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicInternalFrameTitlePane 的使用

声明为 BasicInternalFrameTitlePane 的 javax.swing.plaf.basic 中的字段
protected  BasicInternalFrameTitlePane BasicInternalFrameUI.titlePane

javax.swing.plaf.metal 中 BasicInternalFrameTitlePane 的使用

javax.swing.plaf.metal 中 BasicInternalFrameTitlePane 的子类
 class MetalInternalFrameTitlePane
管理 JLF 标题栏的类

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI
的使用

使用 BasicInternalFrameUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicInternalFrameUI 的使用

javax.swing.plaf.metal 中 BasicInternalFrameUI 的子类
 class MetalInternalFrameUI
JInternalFrame 的 Metal 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicLabelUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicLabelUI
的使用

使用 BasicLabelUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicLabelUI 的使用

声明为 BasicLabelUI 的 javax.swing.plaf.basic 中的字段
protected static BasicLabelUI BasicLabelUI.labelUI
默认 BasicLabelUI 实例。

javax.swing.plaf.metal 中 BasicLabelUI 的使用

javax.swing.plaf.metal 中 BasicLabelUI 的子类
 class MetalLabelUI
LabelUI 的 Windows L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI
的使用

没有 javax.swing.plaf.basic.BasicListUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI.FocusHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicListUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI.ListDataHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI.ListDataHandler
的使用

没有 javax.swing.plaf.basic.BasicListUI.ListDataHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI.ListSelectionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI.ListSelectionHandler
的使用

没有 javax.swing.plaf.basic.BasicListUI.ListSelectionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicLookAndFeel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicLookAndFeel
的使用

使用 BasicLookAndFeel 的软件包
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.metal 中 BasicLookAndFeel 的使用

javax.swing.plaf.metal 中 BasicLookAndFeel 的子类
 class MetalLookAndFeel
Java 外观，也称为 Metal。

javax.swing.plaf.synth 中 BasicLookAndFeel 的使用

javax.swing.plaf.synth 中 BasicLookAndFeel 的子类
 class SynthLookAndFeel
SynthLookAndFeel 提供创建定制外观的基础。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuBarUI
的使用

使用 BasicMenuBarUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicMenuBarUI 的使用

javax.swing.plaf.metal 中 BasicMenuBarUI 的子类
 class MetalMenuBarUI
MenuBarUI 的 Metal 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuItemUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuItemUI
的使用

使用 BasicMenuItemUI 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicMenuItemUI 的使用

javax.swing.plaf.basic 中 BasicMenuItemUI 的子类
class | BasicCheckBoxMenuItemUI BasicCheckboxMenuItem 实现
class | BasicMenuUI MenuUI 的默认 L&F 实现。
class | BasicRadioButtonMenuItemUI BasicRadioButtonMenuItem 实现

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuUI
的使用

使用 BasicMenuUI 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicMenuUI 的使用

声明为 BasicMenuUI 的 javax.swing.plaf.basic 中的字段
 BasicMenuUI BasicMenuUI.ChangeHandler.ui

参数类型为 BasicMenuUI 的 javax.swing.plaf.basic 中的构造方法
BasicMenuUI.ChangeHandler(JMenu m, BasicMenuUI ui)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicOptionPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicOptionPaneUI
的使用

没有 javax.swing.plaf.basic.BasicOptionPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
的使用

没有 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
的使用

没有 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicPanelUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicPanelUI
的使用

没有 javax.swing.plaf.basic.BasicPanelUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicPasswordFieldUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicPasswordFieldUI
的使用

没有 javax.swing.plaf.basic.BasicPasswordFieldUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
的使用

没有 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicPopupMenuUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicPopupMenuUI
的使用

没有 javax.swing.plaf.basic.BasicPopupMenuUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicProgressBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicProgressBarUI
的使用

使用 BasicProgressBarUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicProgressBarUI 的使用

javax.swing.plaf.metal 中 BasicProgressBarUI 的子类
 class MetalProgressBarUI
ProgressBarUI 的 Metal 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
的使用

没有 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicRadioButtonUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicRadioButtonUI
的使用

使用 BasicRadioButtonUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicRadioButtonUI 的使用

javax.swing.plaf.basic 中 BasicRadioButtonUI 的子类
 class BasicCheckBoxUI
BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。

javax.swing.plaf.metal 中 BasicRadioButtonUI 的使用

javax.swing.plaf.metal 中 BasicRadioButtonUI 的子类
class | MetalCheckBoxUI MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalRadioButtonUI MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicRootPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicRootPaneUI
的使用

使用 BasicRootPaneUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicRootPaneUI 的使用

javax.swing.plaf.metal 中 BasicRootPaneUI 的子类
 class MetalRootPaneUI
提供 RootPaneUI 的 metal 外观实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI
的使用

使用 BasicScrollBarUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicScrollBarUI 的使用

javax.swing.plaf.metal 中 BasicScrollBarUI 的子类
 class MetalScrollBarUI
ScrollBarUI 的 Metal 外观实现

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
的使用

使用 BasicScrollBarUI.ArrowButtonListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicScrollBarUI.ArrowButtonListener 的使用

声明为 BasicScrollBarUI.ArrowButtonListener 的 javax.swing.plaf.basic 中的字段
protected  BasicScrollBarUI.ArrowButtonListener BasicScrollBarUI.buttonListener

返回 BasicScrollBarUI.ArrowButtonListener 的 javax.swing.plaf.basic 中的方法
protected  BasicScrollBarUI.ArrowButtonListener BasicScrollBarUI.createArrowButtonListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI.ModelListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI.ModelListener
的使用

使用 BasicScrollBarUI.ModelListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicScrollBarUI.ModelListener 的使用

声明为 BasicScrollBarUI.ModelListener 的 javax.swing.plaf.basic 中的字段
protected  BasicScrollBarUI.ModelListener BasicScrollBarUI.modelListener

返回 BasicScrollBarUI.ModelListener 的 javax.swing.plaf.basic 中的方法
protected  BasicScrollBarUI.ModelListener BasicScrollBarUI.createModelListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener
的使用

使用 BasicScrollBarUI.ScrollListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicScrollBarUI.ScrollListener 的使用

声明为 BasicScrollBarUI.ScrollListener 的 javax.swing.plaf.basic 中的字段
protected  BasicScrollBarUI.ScrollListener BasicScrollBarUI.scrollListener

返回 BasicScrollBarUI.ScrollListener 的 javax.swing.plaf.basic 中的方法
protected  BasicScrollBarUI.ScrollListener BasicScrollBarUI.createScrollListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
的使用

使用 BasicScrollBarUI.TrackListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicScrollBarUI.TrackListener 的使用

声明为 BasicScrollBarUI.TrackListener 的 javax.swing.plaf.basic 中的字段
protected  BasicScrollBarUI.TrackListener BasicScrollBarUI.trackListener

返回 BasicScrollBarUI.TrackListener 的 javax.swing.plaf.basic 中的方法
protected  BasicScrollBarUI.TrackListener BasicScrollBarUI.createTrackListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI
的使用

使用 BasicScrollPaneUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicScrollPaneUI 的使用

javax.swing.plaf.metal 中 BasicScrollPaneUI 的子类
 class MetalScrollPaneUI
ScrollPaneUI 的 Metal L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener
的使用

没有 javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler
的使用

没有 javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener
的使用

没有 javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSeparatorUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSeparatorUI
的使用

使用 BasicSeparatorUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicSeparatorUI 的使用

javax.swing.plaf.basic 中 BasicSeparatorUI 的子类
class | BasicPopupMenuSeparatorUI PopupMenuSeparatorUI 的基本 L&F 实现。
class | BasicToolBarSeparatorUI ToolBarSeparatorUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 BasicSeparatorUI 的使用

javax.swing.plaf.metal 中 BasicSeparatorUI 的子类
class | MetalPopupMenuSeparatorUI PopupMenuSeparatorUI 的 Metal L&F 实现。
class | MetalSeparatorUI SeparatorUI 的 Metal L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI
的使用

使用 BasicSliderUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicSliderUI 的使用

javax.swing.plaf.metal 中 BasicSliderUI 的子类
 class MetalSliderUI
SliderUI 的 Java L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.ActionScroller 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.ActionScroller
的使用

没有 javax.swing.plaf.basic.BasicSliderUI.ActionScroller 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.ChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.ChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicSliderUI.ChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.ComponentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
的使用

没有 javax.swing.plaf.basic.BasicSliderUI.ComponentHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.FocusHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicSliderUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler
的使用

使用 BasicSliderUI.PropertyChangeHandler 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicSliderUI.PropertyChangeHandler 的使用

javax.swing.plaf.metal 中 BasicSliderUI.PropertyChangeHandler 的子类
protected  class MetalSliderUI.MetalPropertyListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener
的使用

使用 BasicSliderUI.ScrollListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicSliderUI.ScrollListener 的使用

声明为 BasicSliderUI.ScrollListener 的 javax.swing.plaf.basic 中的字段
protected  BasicSliderUI.ScrollListener BasicSliderUI.scrollListener

返回 BasicSliderUI.ScrollListener 的 javax.swing.plaf.basic 中的方法
protected  BasicSliderUI.ScrollListener BasicSliderUI.createScrollListener(JSlider slider)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.TrackListener
的使用

使用 BasicSliderUI.TrackListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicSliderUI.TrackListener 的使用

声明为 BasicSliderUI.TrackListener 的 javax.swing.plaf.basic 中的字段
protected  BasicSliderUI.TrackListener BasicSliderUI.trackListener

返回 BasicSliderUI.TrackListener 的 javax.swing.plaf.basic 中的方法
protected  BasicSliderUI.TrackListener BasicSliderUI.createTrackListener(JSlider slider)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSpinnerUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSpinnerUI
的使用

没有 javax.swing.plaf.basic.BasicSpinnerUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneDivider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneDivider
的使用

使用 BasicSplitPaneDivider 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicSplitPaneDivider 的使用

声明为 BasicSplitPaneDivider 的 javax.swing.plaf.basic 中的字段
protected  BasicSplitPaneDivider BasicSplitPaneUI.divider
此 JSplitPane 的分隔符的实例。

返回 BasicSplitPaneDivider 的 javax.swing.plaf.basic 中的方法
BasicSplitPaneDivider | BasicSplitPaneUI.createDefaultDivider() 创建默认的分隔符。
BasicSplitPaneDivider | BasicSplitPaneUI.getDivider() 返回顶层 Component 之间的分隔符。

javax.swing.plaf.metal 中 BasicSplitPaneDivider 的使用

返回 BasicSplitPaneDivider 的 javax.swing.plaf.metal 中的方法
 BasicSplitPaneDivider MetalSplitPaneUI.createDefaultDivider()
创建默认分隔符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
的使用

使用 BasicSplitPaneDivider.DragController 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicSplitPaneDivider.DragController 的使用

javax.swing.plaf.basic 中 BasicSplitPaneDivider.DragController 的子类
protected  class BasicSplitPaneDivider.VerticalDragController
在面向 VERTICAL_SPLIT 的拆分窗格的拖动会话期间处理事件。

声明为 BasicSplitPaneDivider.DragController 的 javax.swing.plaf.basic 中的字段
protected  BasicSplitPaneDivider.DragController BasicSplitPaneDivider.dragger
处理要进行实际拖动操作的鼠标拖动消息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
的使用

使用 BasicSplitPaneDivider.MouseHandler 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicSplitPaneDivider.MouseHandler 的使用

声明为 BasicSplitPaneDivider.MouseHandler 的 javax.swing.plaf.basic 中的字段
protected  BasicSplitPaneDivider.MouseHandler BasicSplitPaneDivider.mouseHandler
处理发自此类和拆分窗格的鼠标事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI
的使用

使用 BasicSplitPaneUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicSplitPaneUI 的使用

声明为 BasicSplitPaneUI 的 javax.swing.plaf.basic 中的字段
protected  BasicSplitPaneUI BasicSplitPaneDivider.splitPaneUI
从其创建此实例的 UI。

返回 BasicSplitPaneUI 的 javax.swing.plaf.basic 中的方法
 BasicSplitPaneUI BasicSplitPaneDivider.getBasicSplitPaneUI()
返回接收者当前位于其中的 SplitPaneUI。

参数类型为 BasicSplitPaneUI 的 javax.swing.plaf.basic 中的方法
 void BasicSplitPaneDivider.setBasicSplitPaneUI(BasicSplitPaneUI newUI)
设置要使用接收者的 SplitPaneUI。

参数类型为 BasicSplitPaneUI 的 javax.swing.plaf.basic 中的构造方法
BasicSplitPaneDivider(BasicSplitPaneUI ui)
创建 BasicSplitPaneDivider 的实例。

javax.swing.plaf.metal 中 BasicSplitPaneUI 的使用

javax.swing.plaf.metal 中 BasicSplitPaneUI 的子类
 class MetalSplitPaneUI
Metal 分隔窗格。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
的使用

使用 BasicSplitPaneUI.BasicHorizontalLayoutManager 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicSplitPaneUI.BasicHorizontalLayoutManager 的使用

javax.swing.plaf.basic 中 BasicSplitPaneUI.BasicHorizontalLayoutManager 的子类
 class BasicSplitPaneUI.BasicVerticalLayoutManager
用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。

声明为 BasicSplitPaneUI.BasicHorizontalLayoutManager 的 javax.swing.plaf.basic 中的字段
protected  BasicSplitPaneUI.BasicHorizontalLayoutManager BasicSplitPaneUI.layoutManager
创建并放到拆分窗格中的 LayoutManager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI
的使用

使用 BasicTabbedPaneUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicTabbedPaneUI 的使用

javax.swing.plaf.metal 中 BasicTabbedPaneUI 的子类
 class MetalTabbedPaneUI
BasicTabbedPaneUI 的 Metal 子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
的使用

没有 javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
的使用

使用 BasicTabbedPaneUI.TabbedPaneLayout 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicTabbedPaneUI.TabbedPaneLayout 的使用

javax.swing.plaf.metal 中 BasicTabbedPaneUI.TabbedPaneLayout 的子类
 class MetalTabbedPaneUI.TabbedPaneLayout
此内部类由于编译器故障而被标记为 "public"。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler
的使用

没有 javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableHeaderUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableHeaderUI
的使用

没有 javax.swing.plaf.basic.BasicTableHeaderUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableUI
的使用

没有 javax.swing.plaf.basic.BasicTableUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableUI.FocusHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicTableUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableUI.KeyHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableUI.KeyHandler
的使用

没有 javax.swing.plaf.basic.BasicTableUI.KeyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextAreaUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextAreaUI
的使用

没有 javax.swing.plaf.basic.BasicTextAreaUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextFieldUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextFieldUI
的使用

使用 BasicTextFieldUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicTextFieldUI 的使用

javax.swing.plaf.basic 中 BasicTextFieldUI 的子类
class | BasicFormattedTextFieldUI 提供 JFormattedTextField 的外观实现。
class | BasicPasswordFieldUI 为密码字段提供 Windows 外观。

javax.swing.plaf.metal 中 BasicTextFieldUI 的使用

javax.swing.plaf.metal 中 BasicTextFieldUI 的子类
 class MetalTextFieldUI
JTextField 外观的基础。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextPaneUI
的使用

没有 javax.swing.plaf.basic.BasicTextPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextUI
的使用

使用 BasicTextUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 BasicTextUI 的使用

javax.swing.plaf.basic 中 BasicTextUI 的子类
class | BasicEditorPaneUI 为 JEditorPane 提供外观。
class | BasicFormattedTextFieldUI 提供 JFormattedTextField 的外观实现。
class | BasicPasswordFieldUI 为密码字段提供 Windows 外观。
class | BasicTextAreaUI 为纯文本编辑器提供外观。
class | BasicTextFieldUI JTextField 的外观的基础。
class | BasicTextPaneUI 为样式化文本编辑器提供外观。

javax.swing.plaf.metal 中 BasicTextUI 的使用

javax.swing.plaf.metal 中 BasicTextUI 的子类
 class MetalTextFieldUI
JTextField 外观的基础。

javax.swing.text 中 BasicTextUI 的使用

javax.swing.text 中 BasicTextUI 的子类
 class DefaultTextUI
已过时。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextUI.BasicCaret 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextUI.BasicCaret
的使用

没有 javax.swing.plaf.basic.BasicTextUI.BasicCaret 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextUI.BasicHighlighter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextUI.BasicHighlighter
的使用

没有 javax.swing.plaf.basic.BasicTextUI.BasicHighlighter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToggleButtonUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToggleButtonUI
的使用

使用 BasicToggleButtonUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicToggleButtonUI 的使用

javax.swing.plaf.basic 中 BasicToggleButtonUI 的子类
class | BasicCheckBoxUI BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicRadioButtonUI BasicRadioButtonUI 的 RadioButtonUI 实现

javax.swing.plaf.metal 中 BasicToggleButtonUI 的使用

javax.swing.plaf.metal 中 BasicToggleButtonUI 的子类
class | MetalCheckBoxUI MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalRadioButtonUI MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalToggleButtonUI MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarSeparatorUI
的使用

没有 javax.swing.plaf.basic.BasicToolBarSeparatorUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI
的使用

使用 BasicToolBarUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicToolBarUI 的使用

javax.swing.plaf.metal 中 BasicToolBarUI 的子类
 class MetalToolBarUI
ToolBarUI 的 Metal 外观实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener
的使用

使用 BasicToolBarUI.DockingListener 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicToolBarUI.DockingListener 的使用

javax.swing.plaf.metal 中 BasicToolBarUI.DockingListener 的子类
protected  class MetalToolBarUI.MetalDockingListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow
的使用

使用 BasicToolBarUI.DragWindow 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicToolBarUI.DragWindow 的使用

声明为 BasicToolBarUI.DragWindow 的 javax.swing.plaf.basic 中的字段
protected  BasicToolBarUI.DragWindow BasicToolBarUI.dragWindow

返回 BasicToolBarUI.DragWindow 的 javax.swing.plaf.basic 中的方法
protected  BasicToolBarUI.DragWindow BasicToolBarUI.createDragWindow(JToolBar toolbar)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.FrameListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.FrameListener
的使用

没有 javax.swing.plaf.basic.BasicToolBarUI.FrameListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.PropertyListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.PropertyListener
的使用

使用 BasicToolBarUI.PropertyListener 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicToolBarUI.PropertyListener 的使用

javax.swing.plaf.metal 中 BasicToolBarUI.PropertyListener 的子类
protected  class MetalToolBarUI.MetalRolloverListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
的使用

使用 BasicToolBarUI.ToolBarContListener 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicToolBarUI.ToolBarContListener 的使用

javax.swing.plaf.metal 中 BasicToolBarUI.ToolBarContListener 的子类
protected  class MetalToolBarUI.MetalContainerListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
的使用

没有 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolTipUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolTipUI
的使用

使用 BasicToolTipUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicToolTipUI 的使用

javax.swing.plaf.metal 中 BasicToolTipUI 的子类
 class MetalToolTipUI
BasicToolTipUI 的 Metal L&F 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI
的使用

使用 BasicTreeUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicTreeUI 的使用

javax.swing.plaf.metal 中 BasicTreeUI 的子类
 class MetalTreeUI
TreeUI 的 metal 外观实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.FocusHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicViewportUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicViewportUI
的使用

没有 javax.swing.plaf.basic.BasicViewportUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.plaf.basic.ComboPopup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.plaf.basic.ComboPopup
的使用

使用 ComboPopup 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 ComboPopup 的使用

实现 ComboPopup 的 javax.swing.plaf.basic 中的类
 class BasicComboPopup
此为 ComboPopup 接口的基本实现。

声明为 ComboPopup 的 javax.swing.plaf.basic 中的字段
protected  ComboPopup BasicComboBoxUI.popup

返回 ComboPopup 的 javax.swing.plaf.basic 中的方法
protected  ComboPopup BasicComboBoxUI.createPopup()
创建组合框的弹出部分。

javax.swing.plaf.metal 中 ComboPopup 的使用

实现 ComboPopup 的 javax.swing.plaf.metal 中的类
 class MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

返回 ComboPopup 的 javax.swing.plaf.metal 中的方法
protected  ComboPopup MetalComboBoxUI.createPopup()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.basic.DefaultMenuLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.DefaultMenuLayout
的使用

没有 javax.swing.plaf.basic.DefaultMenuLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ActionMapUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ActionMapUIResource
的使用

没有 javax.swing.plaf.ActionMapUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.BevelBorderUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.BevelBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.BevelBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.CompoundBorderUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.CompoundBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.CompoundBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.EmptyBorderUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.EmptyBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.EmptyBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.LineBorderUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.LineBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.LineBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.MatteBorderUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.MatteBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.MatteBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ButtonUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ButtonUI
的使用

使用 ButtonUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ButtonUI 的使用

返回 ButtonUI 的 javax.swing 中的方法
 ButtonUI AbstractButton.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 ButtonUI 的 javax.swing 中的方法
 void AbstractButton.setUI(ButtonUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf 中 ButtonUI 的使用

javax.swing.plaf 中 ButtonUI 的子类
 class MenuItemUI
JMenuItem 的可插入外观界面。

javax.swing.plaf.basic 中 ButtonUI 的使用

javax.swing.plaf.basic 中 ButtonUI 的子类
class | BasicButtonUI BasicButton 实现
class | BasicCheckBoxMenuItemUI BasicCheckboxMenuItem 实现
class | BasicCheckBoxUI BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicMenuItemUI BasicMenuItem 实现
class | BasicMenuUI MenuUI 的默认 L&F 实现。
class | BasicRadioButtonMenuItemUI BasicRadioButtonMenuItem 实现
class | BasicRadioButtonUI BasicRadioButtonUI 的 RadioButtonUI 实现
class | BasicToggleButtonUI BasicToggleButton 实现

javax.swing.plaf.metal 中 ButtonUI 的使用

javax.swing.plaf.metal 中 ButtonUI 的子类
class | MetalButtonUI MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
class | MetalCheckBoxUI MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalRadioButtonUI MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalToggleButtonUI MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

javax.swing.plaf.multi 中 ButtonUI 的使用

javax.swing.plaf.multi 中 ButtonUI 的子类
class | MultiButtonUI 用于组合 ButtonUI 的多路 UI。
class | MultiMenuItemUI 用于组合 MenuItemUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ColorChooserUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ColorChooserUI
的使用

使用 ColorChooserUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ColorChooserUI 的使用

返回 ColorChooserUI 的 javax.swing 中的方法
 ColorChooserUI JColorChooser.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 ColorChooserUI 的 javax.swing 中的方法
 void JColorChooser.setUI(ColorChooserUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ColorChooserUI 的使用

javax.swing.plaf.basic 中 ColorChooserUI 的子类
 class BasicColorChooserUI
为 JColorChooser 提供基本外观。

javax.swing.plaf.multi 中 ColorChooserUI 的使用

javax.swing.plaf.multi 中 ColorChooserUI 的子类
 class MultiColorChooserUI
用于组合 ColorChooserUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ColorUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ColorUIResource
的使用

使用 ColorUIResource 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 ColorUIResource 的使用

返回 ColorUIResource 的 javax.swing.plaf.metal 中的方法
ColorUIResource | MetalTheme.getAcceleratorForeground() 返回加速器前景色。
static ColorUIResource | MetalLookAndFeel.getAcceleratorForeground() 返回当前主题的加速器前景颜色。
ColorUIResource | MetalTheme.getAcceleratorSelectedForeground() 返回加速器选中前景色。
static ColorUIResource | MetalLookAndFeel.getAcceleratorSelectedForeground() 返回当前主题的加速器选中前景颜色。
protected ColorUIResource | OceanTheme.getBlack() 返回黑色。
protected ColorUIResource | MetalTheme.getBlack() 返回黑色。
static ColorUIResource | MetalLookAndFeel.getBlack() 返回当前主题的黑色。
ColorUIResource | MetalTheme.getControl() 返回控件颜色。
static ColorUIResource | MetalLookAndFeel.getControl() 返回当前主题的控件颜色。
ColorUIResource | MetalTheme.getControlDarkShadow() 返回控件加黑阴影颜色。
static ColorUIResource | MetalLookAndFeel.getControlDarkShadow() 返回当前主题的控件加黑阴影颜色。
ColorUIResource | MetalTheme.getControlDisabled() 返回控件禁用的颜色。
static ColorUIResource | MetalLookAndFeel.getControlDisabled() 返回当前主题的控件禁用颜色。
ColorUIResource | MetalTheme.getControlHighlight() 返回控件高亮显示颜色。
static ColorUIResource | MetalLookAndFeel.getControlHighlight() 返回当前主题的控件高亮显示颜色。
ColorUIResource | MetalTheme.getControlInfo() 返回控件信息颜色。
static ColorUIResource | MetalLookAndFeel.getControlInfo() 返回当前主题的控件信息颜色。
ColorUIResource | MetalTheme.getControlShadow() 返回控件阴影颜色。
static ColorUIResource | MetalLookAndFeel.getControlShadow() 返回当前主题的控件阴影颜色。
ColorUIResource | OceanTheme.getControlTextColor() 返回控件文本颜色。
ColorUIResource | MetalTheme.getControlTextColor() 返回控件文本颜色。
static ColorUIResource | MetalLookAndFeel.getControlTextColor() 返回当前主题的控件文本颜色。
ColorUIResource | OceanTheme.getDesktopColor() 返回桌面颜色。
ColorUIResource | MetalTheme.getDesktopColor() 返回桌面颜色。
static ColorUIResource | MetalLookAndFeel.getDesktopColor() 返回当前主题的桌面颜色。
ColorUIResource | MetalTheme.getFocusColor() 返回焦点颜色。
static ColorUIResource | MetalLookAndFeel.getFocusColor() 返回当前主题的焦点颜色。
ColorUIResource | MetalTheme.getHighlightedTextColor() 返回高亮显示的文本颜色。
static ColorUIResource | MetalLookAndFeel.getHighlightedTextColor() 返回当前主题的加亮文本颜色。
ColorUIResource | OceanTheme.getInactiveControlTextColor() 返回非活动控件文本颜色。
ColorUIResource | MetalTheme.getInactiveControlTextColor() 返回非活动控件文本颜色。
static ColorUIResource | MetalLookAndFeel.getInactiveControlTextColor() 返回当前主题的非活动控件文本颜色。
ColorUIResource | MetalTheme.getInactiveSystemTextColor() 返回非活动系统文本颜色。
static ColorUIResource | MetalLookAndFeel.getInactiveSystemTextColor() 返回当前主题的非活动系统文本颜色。
ColorUIResource | MetalTheme.getMenuBackground() 返回菜单背景色。
static ColorUIResource | MetalLookAndFeel.getMenuBackground() 返回当前主题的菜单背景颜色。
ColorUIResource | OceanTheme.getMenuDisabledForeground() 返回菜单禁用前景色。
ColorUIResource | MetalTheme.getMenuDisabledForeground() 返回菜单禁用前景色。
static ColorUIResource | MetalLookAndFeel.getMenuDisabledForeground() 返回当前主题的菜单禁用前景颜色。
ColorUIResource | MetalTheme.getMenuForeground() 返回菜单前景色。
static ColorUIResource | MetalLookAndFeel.getMenuForeground() 返回当前主题的菜单前景颜色。
ColorUIResource | MetalTheme.getMenuSelectedBackground() 返回菜单选中背景色。
static ColorUIResource | MetalLookAndFeel.getMenuSelectedBackground() 返回当前主题的菜单选中背景颜色。
ColorUIResource | MetalTheme.getMenuSelectedForeground() 返回菜单选中前景色。
static ColorUIResource | MetalLookAndFeel.getMenuSelectedForeground() 返回当前主题的菜单选中前景颜色。
protected ColorUIResource | OceanTheme.getPrimary1() 返回 primary 1 颜色。
protected ColorUIResource | DefaultMetalTheme.getPrimary1() 返回 primary 1 颜色。
protected abstract ColorUIResource | MetalTheme.getPrimary1() 返回 primary 1 颜色。
protected ColorUIResource | OceanTheme.getPrimary2() 返回 primary 2 颜色。
protected ColorUIResource | DefaultMetalTheme.getPrimary2() 返回 primary 2 颜色。
protected abstract ColorUIResource | MetalTheme.getPrimary2() 返回 primary 2 颜色。
protected ColorUIResource | OceanTheme.getPrimary3() 返回 primary 3 颜色。
protected ColorUIResource | DefaultMetalTheme.getPrimary3() 返回 primary 3 颜色。
protected abstract ColorUIResource | MetalTheme.getPrimary3() 返回 primary 3 颜色。
ColorUIResource | MetalTheme.getPrimaryControl() 返回 primary 控件颜色。
static ColorUIResource | MetalLookAndFeel.getPrimaryControl() 返回当前主题的 primary 控件颜色。
ColorUIResource | MetalTheme.getPrimaryControlDarkShadow() 返回 primary 控件加黑阴影颜色。
static ColorUIResource | MetalLookAndFeel.getPrimaryControlDarkShadow() 返回当前主题的 primary 控件加黑阴影颜色。
ColorUIResource | MetalTheme.getPrimaryControlHighlight() 返回 primary 控件高亮显示颜色。
static ColorUIResource | MetalLookAndFeel.getPrimaryControlHighlight() 返回当前主题的 primary 控件高亮显示颜色。
ColorUIResource | MetalTheme.getPrimaryControlInfo() 返回 primary 控件信息颜色。
static ColorUIResource | MetalLookAndFeel.getPrimaryControlInfo() 返回当前主题的 primary 控件信息颜色。
ColorUIResource | MetalTheme.getPrimaryControlShadow() 返回 primary 控件阴影颜色。
static ColorUIResource | MetalLookAndFeel.getPrimaryControlShadow() 返回当前主题的 primary 控件阴影颜色。
protected ColorUIResource | OceanTheme.getSecondary1() 返回 secondary 1 颜色。
protected ColorUIResource | DefaultMetalTheme.getSecondary1() 返回 secondary 1 颜色。
protected abstract ColorUIResource | MetalTheme.getSecondary1() 返回 secondary 1 颜色。
protected ColorUIResource | OceanTheme.getSecondary2() 返回 secondary 2 颜色。
protected ColorUIResource | DefaultMetalTheme.getSecondary2() 返回 secondary 2 颜色。
protected abstract ColorUIResource | MetalTheme.getSecondary2() 返回 secondary 2 颜色。
protected ColorUIResource | OceanTheme.getSecondary3() 返回 secondary 3 颜色。
protected ColorUIResource | DefaultMetalTheme.getSecondary3() 返回 secondary 3 颜色。
protected abstract ColorUIResource | MetalTheme.getSecondary3() 返回 secondary 3 颜色。
ColorUIResource | MetalTheme.getSeparatorBackground() 返回分隔符背景色。
static ColorUIResource | MetalLookAndFeel.getSeparatorBackground() 返回当前主题的分隔符背景颜色。
ColorUIResource | MetalTheme.getSeparatorForeground() 返回分隔符前景色。
static ColorUIResource | MetalLookAndFeel.getSeparatorForeground() 返回当前主题的分隔符前景颜色。
ColorUIResource | MetalTheme.getSystemTextColor() 返回系统文本颜色。
static ColorUIResource | MetalLookAndFeel.getSystemTextColor() 返回当前主题的系统文本颜色。
ColorUIResource | MetalTheme.getTextHighlightColor() 返回文本高亮显示的颜色。
static ColorUIResource | MetalLookAndFeel.getTextHighlightColor() 返回当前主题的文本高亮显示颜色。
ColorUIResource | MetalTheme.getUserTextColor() 返回用户文本颜色。
static ColorUIResource | MetalLookAndFeel.getUserTextColor() 返回当前主题的用户文本颜色。
protected ColorUIResource | MetalTheme.getWhite() 返回白色。
static ColorUIResource | MetalLookAndFeel.getWhite() 返回当前主题的白色。
ColorUIResource | MetalTheme.getWindowBackground() 返回窗口背景色。
static ColorUIResource | MetalLookAndFeel.getWindowBackground() 返回当前主题的窗口背景颜色。
ColorUIResource | MetalTheme.getWindowTitleBackground() 返回窗口标题背景色。
static ColorUIResource | MetalLookAndFeel.getWindowTitleBackground() 返回当前主题的窗口标题背景颜色。
ColorUIResource | MetalTheme.getWindowTitleForeground() 返回窗口标题前景色。
static ColorUIResource | MetalLookAndFeel.getWindowTitleForeground() 返回当前主题的窗口标题前景色。
ColorUIResource | MetalTheme.getWindowTitleInactiveBackground() 返回窗口标题非活动背景色。
static ColorUIResource | MetalLookAndFeel.getWindowTitleInactiveBackground() 返回当前主题的窗口标题非活动背景颜色。
ColorUIResource | MetalTheme.getWindowTitleInactiveForeground() 返回窗口标题非活动前景色。
static ColorUIResource | MetalLookAndFeel.getWindowTitleInactiveForeground() 返回当前主题的窗口标题非活动前景颜色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ComboBoxUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ComboBoxUI
的使用

使用 ComboBoxUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ComboBoxUI 的使用

返回 ComboBoxUI 的 javax.swing 中的方法
 ComboBoxUI JComboBox.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 ComboBoxUI 的 javax.swing 中的方法
 void JComboBox.setUI(ComboBoxUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ComboBoxUI 的使用

javax.swing.plaf.basic 中 ComboBoxUI 的子类
 class BasicComboBoxUI
JComboBox 的基本 UI 实现。

javax.swing.plaf.metal 中 ComboBoxUI 的使用

javax.swing.plaf.metal 中 ComboBoxUI 的子类
 class MetalComboBoxUI
JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

javax.swing.plaf.multi 中 ComboBoxUI 的使用

javax.swing.plaf.multi 中 ComboBoxUI 的子类
 class MultiComboBoxUI
用于组合 ComboBoxUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ComponentInputMapUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ComponentInputMapUIResource
的使用

没有 javax.swing.plaf.ComponentInputMapUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ComponentUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ComponentUI
的使用

使用 ComponentUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 ComponentUI 的使用

声明为 ComponentUI 的 javax.swing 中的字段
protected  ComponentUI JComponent.ui
此组件的外观委托。

返回 ComponentUI 的 javax.swing 中的方法
ComponentUI | UIDefaults.getUI(JComponent target) 创建一个指定组件的 ComponentUI 实现。
static ComponentUI | UIManager.getUI(JComponent target) 返回 target 的适当 ComponentUI 实现。

返回变量类型为 ComponentUI 的类型的 javax.swing 中的方法
Class<? extends ComponentUI> | UIDefaults.getUIClass(String uiClassID) 返回呈现此组件的 L&F 类。
Class<? extends ComponentUI> | UIDefaults.getUIClass(String uiClassID, ClassLoader uiClassLoader) get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。

参数类型为 ComponentUI 的 javax.swing 中的方法
protected  void JComponent.setUI(ComponentUI newUI)
设置此组件的外观委托。

javax.swing.plaf 中 ComponentUI 的使用

javax.swing.plaf 中 ComponentUI 的子类
class | ButtonUI JButton 的可插入外观界面。
class | ColorChooserUI JColorChooser 的可插入外观界面。
class | ComboBoxUI JComboBox 的可插入外观界面。
class | DesktopIconUI JDesktopIcon 的可插入外观界面。
class | DesktopPaneUI JDesktopPane 的可插入外观界面。
class | FileChooserUI JFileChooser 的可插入外观界面。
class | InternalFrameUI JInternalFrame 的可插入外观界面。
class | LabelUI JLabel 的可插入外观界面。
class | ListUI JList 的可插入外观代理。
class | MenuBarUI JMenuBar 的可插入外观界面。
class | MenuItemUI JMenuItem 的可插入外观界面。
class | OptionPaneUI JOptionPane 的可插入外观界面。
class | PanelUI Panel 的可插入外观界面。
class | PopupMenuUI JPopupMenu 的可插入外观界面。
class | ProgressBarUI JProgressBar 的可插入外观界面。
class | RootPaneUI JRootPane 的可插入外观界面。
class | ScrollBarUI JScrollBar 的可插入外观界面。
class | ScrollPaneUI JScrollPane 的可插入外观界面。
class | SeparatorUI JSeparator 的可插入外观界面。
class | SliderUI JSlider 的可插入外观界面。
class | SpinnerUI JSpinner 的可插入外观界面
class | SplitPaneUI JSplitPane 的可插入外观界面。
class | TabbedPaneUI JTabbedPane 的可插入外观界面。
class | TableHeaderUI JTableHeader 的可插入外观界面。
class | TableUI JTable 的可插入外观界面。
class | TextUI 文本编辑器用户界面
class | ToolBarUI JToolBar 的可插入外观界面。
class | ToolTipUI JToolTip 的可插入外观界面。
class | TreeUI JTree 的可插入外观界面。
class | ViewportUI JViewport 的可插入外观界面。

返回 ComponentUI 的 javax.swing.plaf 中的方法
static ComponentUI ComponentUI.createUI(JComponent c)
返回指定组件的一个 UI 委托实例。

javax.swing.plaf.basic 中 ComponentUI 的使用

javax.swing.plaf.basic 中 ComponentUI 的子类
class | BasicButtonUI BasicButton 实现
class | BasicCheckBoxMenuItemUI BasicCheckboxMenuItem 实现
class | BasicCheckBoxUI BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicColorChooserUI 为 JColorChooser 提供基本外观。
class | BasicComboBoxUI JComboBox 的基本 UI 实现。
class | BasicDesktopIconUI 用于桌面最小化窗口的 L&F。
class | BasicDesktopPaneUI 桌面的基本 L&F。
class | BasicEditorPaneUI 为 JEditorPane 提供外观。
class | BasicFileChooserUI FileChooser 的基本 L&F 实现。
class | BasicFormattedTextFieldUI 提供 JFormattedTextField 的外观实现。
class | BasicInternalFrameUI JInternalFrame 的基本 L&F 实现。
class | BasicLabelUI LabelUI 的 Windows L&F 实现。
class | BasicListUI ListUI 的可扩展实现。
class | BasicMenuBarUI MenuBarUI 的默认 L&F 实现。
class | BasicMenuItemUI BasicMenuItem 实现
class | BasicMenuUI MenuUI 的默认 L&F 实现。
class | BasicOptionPaneUI 为 JOptionPane 提供基本外观。
class | BasicPanelUI BasicPanel 实现
class | BasicPasswordFieldUI 为密码字段提供 Windows 外观。
class | BasicPopupMenuSeparatorUI PopupMenuSeparatorUI 的基本 L&F 实现。
class | BasicPopupMenuUI PopupMenuUI 的 Windows L&F 实现。
class | BasicProgressBarUI ProgressBarUI 的基本 L&F 实现。
class | BasicRadioButtonMenuItemUI BasicRadioButtonMenuItem 实现
class | BasicRadioButtonUI BasicRadioButtonUI 的 RadioButtonUI 实现
class | BasicRootPaneUI RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。
class | BasicScrollBarUI 基本外观的 ScrollBarUI 的实现
class | BasicScrollPaneUI ScrollPaneUI 的默认 L&F 实现。
class | BasicSeparatorUI SeparatorUI 的基本 L&F 实现。
class | BasicSliderUI SliderUI 的基本 L&F 实现。
class | BasicSpinnerUI 默认 Spinner UI 委托。
class | BasicSplitPaneUI SplitPaneUI 的基本 L&F 实现。
class | BasicTabbedPaneUI TabbedPaneUI 的基本 L&F 实现。
class | BasicTableHeaderUI BasicTableHeaderUI 实现
class | BasicTableUI BasicTableUI 实现
class | BasicTextAreaUI 为纯文本编辑器提供外观。
class | BasicTextFieldUI JTextField 的外观的基础。
class | BasicTextPaneUI 为样式化文本编辑器提供外观。
class | BasicTextUI 此类是文本组件外观的基础。
class | BasicToggleButtonUI BasicToggleButton 实现
class | BasicToolBarSeparatorUI ToolBarSeparatorUI 的基本 L&F 实现。
class | BasicToolBarUI ToolBarUI 的基本 L&F 实现。
class | BasicToolTipUI 标准工具提示 L&F。
class | BasicTreeUI 层次数据结构的基本 L&F。
class | BasicViewportUI BasicViewport 实现

返回 ComponentUI 的 javax.swing.plaf.basic 中的方法
static ComponentUI | BasicCheckBoxUI.createUI(JComponent b)
static ComponentUI | BasicColorChooserUI.createUI(JComponent c)
static ComponentUI | BasicDesktopIconUI.createUI(JComponent c)
static ComponentUI | BasicDesktopPaneUI.createUI(JComponent c)
static ComponentUI | BasicEditorPaneUI.createUI(JComponent c) 创建 JTextPane 的 UI。
static ComponentUI | BasicFormattedTextFieldUI.createUI(JComponent c) 创建 JFormattedTextField 的 UI。
static ComponentUI | BasicInternalFrameUI.createUI(JComponent b)
static ComponentUI | BasicOptionPaneUI.createUI(JComponent x) 创建一个新的 BasicOptionPaneUI 实例。
static ComponentUI | BasicPasswordFieldUI.createUI(JComponent c) 创建 JPasswordField 的 UI。
static ComponentUI | BasicPopupMenuSeparatorUI.createUI(JComponent c)
static ComponentUI | BasicSpinnerUI.createUI(JComponent c) 返回 BasicSpinnerUI 的新实例。
static ComponentUI | BasicTextPaneUI.createUI(JComponent c) 创建 JTextPane 的 UI。
static ComponentUI | BasicToolTipUI.createUI(JComponent c)
static ComponentUI | BasicRadioButtonMenuItemUI.createUI(JComponent b)
static ComponentUI | BasicCheckBoxMenuItemUI.createUI(JComponent c)
static ComponentUI | BasicSliderUI.createUI(JComponent b)
static ComponentUI | BasicTextAreaUI.createUI(JComponent ta) 创建 JTextArea 的 UI。
static ComponentUI | BasicSplitPaneUI.createUI(JComponent x) 创建新的 BasicSplitPaneUI 实例
static ComponentUI | BasicTreeUI.createUI(JComponent x)
static ComponentUI | BasicTableUI.createUI(JComponent c)
static ComponentUI | BasicTableHeaderUI.createUI(JComponent h)
static ComponentUI | BasicProgressBarUI.createUI(JComponent x)
static ComponentUI | BasicRadioButtonUI.createUI(JComponent b)
static ComponentUI | BasicTabbedPaneUI.createUI(JComponent c)
static ComponentUI | BasicToolBarSeparatorUI.createUI(JComponent c)
static ComponentUI | BasicTextFieldUI.createUI(JComponent c) 创建 JTextField 的 UI。
static ComponentUI | BasicScrollPaneUI.createUI(JComponent x)
static ComponentUI | BasicViewportUI.createUI(JComponent c)
static ComponentUI | BasicListUI.createUI(JComponent list) 返回 BasicListUI 的新实例。
static ComponentUI | BasicComboBoxUI.createUI(JComponent c)
static ComponentUI | BasicScrollBarUI.createUI(JComponent c)
static ComponentUI | BasicSeparatorUI.createUI(JComponent c)
static ComponentUI | BasicPopupMenuUI.createUI(JComponent x)
static ComponentUI | BasicMenuUI.createUI(JComponent x)
static ComponentUI | BasicMenuItemUI.createUI(JComponent c)
static ComponentUI | BasicToolBarUI.createUI(JComponent c)
static ComponentUI | BasicMenuBarUI.createUI(JComponent x)
static ComponentUI | BasicToggleButtonUI.createUI(JComponent b)
static ComponentUI | BasicButtonUI.createUI(JComponent c)
static ComponentUI | BasicLabelUI.createUI(JComponent c)
static ComponentUI | BasicRootPaneUI.createUI(JComponent c)
static ComponentUI | BasicPanelUI.createUI(JComponent c)

javax.swing.plaf.metal 中 ComponentUI 的使用

javax.swing.plaf.metal 中 ComponentUI 的子类
class | MetalButtonUI MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
class | MetalCheckBoxUI MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalDesktopIconUI Metal 桌面图标。
class | MetalFileChooserUI FileChooser 的 Metal L&F 实现。
class | MetalInternalFrameUI JInternalFrame 的 Metal 实现。
class | MetalLabelUI LabelUI 的 Windows L&F 实现。
class | MetalMenuBarUI MenuBarUI 的 Metal 实现。
class | MetalPopupMenuSeparatorUI PopupMenuSeparatorUI 的 Metal L&F 实现。
class | MetalProgressBarUI ProgressBarUI 的 Metal 实现。
class | MetalRadioButtonUI MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalRootPaneUI 提供 RootPaneUI 的 metal 外观实现。
class | MetalScrollBarUI ScrollBarUI 的 Metal 外观实现
class | MetalScrollPaneUI ScrollPaneUI 的 Metal L&F 实现。
class | MetalSeparatorUI SeparatorUI 的 Metal L&F 实现。
class | MetalSliderUI SliderUI 的 Java L&F 实现。
class | MetalSplitPaneUI Metal 分隔窗格。
class | MetalTabbedPaneUI BasicTabbedPaneUI 的 Metal 子类。
class | MetalTextFieldUI JTextField 外观的基础。
class | MetalToggleButtonUI MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalToolBarUI ToolBarUI 的 Metal 外观实现。
class | MetalToolTipUI BasicToolTipUI 的 Metal L&F 扩展。
class | MetalTreeUI TreeUI 的 metal 外观实现。

返回 ComponentUI 的 javax.swing.plaf.metal 中的方法
static ComponentUI | MetalDesktopIconUI.createUI(JComponent c)
static ComponentUI | MetalFileChooserUI.createUI(JComponent c)
static ComponentUI | MetalInternalFrameUI.createUI(JComponent c)
static ComponentUI | MetalToolTipUI.createUI(JComponent c)
static ComponentUI | MetalSliderUI.createUI(JComponent c)
static ComponentUI | MetalSplitPaneUI.createUI(JComponent x) 创建一个新的 MetalSplitPaneUI 实例
static ComponentUI | MetalTreeUI.createUI(JComponent x)
static ComponentUI | MetalProgressBarUI.createUI(JComponent c)
static ComponentUI | MetalCheckBoxUI.createUI(JComponent b)
static ComponentUI | MetalRadioButtonUI.createUI(JComponent c)
static ComponentUI | MetalTabbedPaneUI.createUI(JComponent x)
static ComponentUI | MetalTextFieldUI.createUI(JComponent c)
static ComponentUI | MetalScrollPaneUI.createUI(JComponent x)
static ComponentUI | MetalComboBoxUI.createUI(JComponent c)
static ComponentUI | MetalScrollBarUI.createUI(JComponent c)
static ComponentUI | MetalPopupMenuSeparatorUI.createUI(JComponent c)
static ComponentUI | MetalSeparatorUI.createUI(JComponent c)
static ComponentUI | MetalToolBarUI.createUI(JComponent c)
static ComponentUI | MetalMenuBarUI.createUI(JComponent x) 为传入的组件创建 ComponentUI 实现。
static ComponentUI | MetalToggleButtonUI.createUI(JComponent b)
static ComponentUI | MetalButtonUI.createUI(JComponent c)
static ComponentUI | MetalLabelUI.createUI(JComponent c)
static ComponentUI | MetalRootPaneUI.createUI(JComponent c) 为 JRootPane 创建一个 UI。

javax.swing.plaf.multi 中 ComponentUI 的使用

javax.swing.plaf.multi 中 ComponentUI 的子类
class | MultiButtonUI 用于组合 ButtonUI 的多路 UI。
class | MultiColorChooserUI 用于组合 ColorChooserUI 的多路 UI。
class | MultiComboBoxUI 用于组合 ComboBoxUI 的多路 UI。
class | MultiDesktopIconUI 用于组合 DesktopIconUI 的多路 UI。
class | MultiDesktopPaneUI 用于组合 DesktopPaneUI 的多路 UI。
class | MultiFileChooserUI 用于组合 FileChooserUI 的多路 UI。
class | MultiInternalFrameUI 用于组合 InternalFrameUI 的多路 UI。
class | MultiLabelUI 用于组合 LabelUI 的多路 UI。
class | MultiListUI 用于组合 ListUI 的多路 UI。
class | MultiMenuBarUI 用于组合 MenuBarUI 的多路 UI。
class | MultiMenuItemUI 用于组合 MenuItemUI 的多路 UI。
class | MultiOptionPaneUI 用于组合 OptionPaneUI 的多路 UI。
class | MultiPanelUI 用于组合 PanelUI 的多路 UI。
class | MultiPopupMenuUI 用于组合 PopupMenuUI 的多路 UI。
class | MultiProgressBarUI 用于组合 ProgressBarUI 的多路 UI。
class | MultiRootPaneUI 用于组合 RootPaneUI 的多路 UI。
class | MultiScrollBarUI 用于组合 ScrollBarUI 的多路 UI。
class | MultiScrollPaneUI 用于组合 ScrollPaneUI 的多路 UI。
class | MultiSeparatorUI 用于组合 SeparatorUI 的多路 UI。
class | MultiSliderUI 用于组合 SliderUI 的多路 UI。
class | MultiSpinnerUI 用于组合 SpinnerUI 的多路 UI。
class | MultiSplitPaneUI 用于组合 SplitPaneUI 的多路 UI。
class | MultiTabbedPaneUI 用于组合 TabbedPaneUI 的多路 UI。
class | MultiTableHeaderUI 用于组合 TableHeaderUI 的多路 UI。
class | MultiTableUI 用于组合 TableUI 的多路 UI。
class | MultiTextUI 用于组合 TextUI 的多路 UI。
class | MultiToolBarUI 用于组合 ToolBarUI 的多路 UI。
class | MultiToolTipUI 用于组合 ToolTipUI 的多路 UI。
class | MultiTreeUI 用于组合 TreeUI 的多路 UI。
class | MultiViewportUI 用于组合 ViewportUI 的多路 UI。

返回 ComponentUI 的 javax.swing.plaf.multi 中的方法
static ComponentUI | MultiButtonUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiColorChooserUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiComboBoxUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiDesktopIconUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiDesktopPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiFileChooserUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiInternalFrameUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiLabelUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiListUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiMenuBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiMenuItemUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiOptionPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiPanelUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiPopupMenuUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiProgressBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiRootPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiScrollBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiScrollPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSeparatorUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSliderUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSpinnerUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSplitPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTabbedPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTableHeaderUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTableUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTextUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiToolBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiToolTipUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTreeUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiViewportUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target) 创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。
ComponentUI[] | MultiButtonUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiColorChooserUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiComboBoxUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiDesktopIconUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiDesktopPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiFileChooserUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiInternalFrameUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiLabelUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiListUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiMenuBarUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiMenuItemUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiOptionPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiPanelUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiPopupMenuUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiProgressBarUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiRootPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiScrollBarUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiScrollPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiSeparatorUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiSliderUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiSpinnerUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiSplitPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiTabbedPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiTableHeaderUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiTableUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiTextUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiToolBarUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiToolTipUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiTreeUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiViewportUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
protected static ComponentUI[] | MultiLookAndFeel.uisToArray(Vector uis) 创建一个数组，使用来自传入向量的 UI 对象填充它并返回该数组。

参数类型为 ComponentUI 的 javax.swing.plaf.multi 中的方法
static ComponentUI MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target)
创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。

javax.swing.plaf.synth 中 ComponentUI 的使用

返回 ComponentUI 的 javax.swing.plaf.synth 中的方法
static ComponentUI SynthLookAndFeel.createUI(JComponent c)
为传入的 JComponent 创建 Synth 外观 ComponentUI。

javax.swing.text 中 ComponentUI 的使用

javax.swing.text 中 ComponentUI 的子类
 class DefaultTextUI
已过时。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.DesktopIconUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.DesktopIconUI
的使用

使用 DesktopIconUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 DesktopIconUI 的使用

返回 DesktopIconUI 的 javax.swing 中的方法
 DesktopIconUI JInternalFrame.JDesktopIcon.getUI()
返回呈现此组件的外观对象。

参数类型为 DesktopIconUI 的 javax.swing 中的方法
 void JInternalFrame.JDesktopIcon.setUI(DesktopIconUI ui)
设置呈现此组件的外观对象。

javax.swing.plaf.basic 中 DesktopIconUI 的使用

javax.swing.plaf.basic 中 DesktopIconUI 的子类
 class BasicDesktopIconUI
用于桌面最小化窗口的 L&F。

javax.swing.plaf.metal 中 DesktopIconUI 的使用

javax.swing.plaf.metal 中 DesktopIconUI 的子类
 class MetalDesktopIconUI
Metal 桌面图标。

javax.swing.plaf.multi 中 DesktopIconUI 的使用

javax.swing.plaf.multi 中 DesktopIconUI 的子类
 class MultiDesktopIconUI
用于组合 DesktopIconUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.DesktopPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.DesktopPaneUI
的使用

使用 DesktopPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 DesktopPaneUI 的使用

返回 DesktopPaneUI 的 javax.swing 中的方法
 DesktopPaneUI JDesktopPane.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 DesktopPaneUI 的 javax.swing 中的方法
 void JDesktopPane.setUI(DesktopPaneUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 DesktopPaneUI 的使用

javax.swing.plaf.basic 中 DesktopPaneUI 的子类
 class BasicDesktopPaneUI
桌面的基本 L&F。

javax.swing.plaf.multi 中 DesktopPaneUI 的使用

javax.swing.plaf.multi 中 DesktopPaneUI 的子类
 class MultiDesktopPaneUI
用于组合 DesktopPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.DimensionUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.DimensionUIResource
的使用

没有 javax.swing.plaf.DimensionUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.FileChooserUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.FileChooserUI
的使用

使用 FileChooserUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 FileChooserUI 的使用

返回 FileChooserUI 的 javax.swing 中的方法
 FileChooserUI JFileChooser.getUI()
获得实现此组件 L&F 的 UI 对象。

javax.swing.plaf.basic 中 FileChooserUI 的使用

javax.swing.plaf.basic 中 FileChooserUI 的子类
 class BasicFileChooserUI
FileChooser 的基本 L&F 实现。

javax.swing.plaf.metal 中 FileChooserUI 的使用

javax.swing.plaf.metal 中 FileChooserUI 的子类
 class MetalFileChooserUI
FileChooser 的 Metal L&F 实现。

javax.swing.plaf.multi 中 FileChooserUI 的使用

javax.swing.plaf.multi 中 FileChooserUI 的子类
 class MultiFileChooserUI
用于组合 FileChooserUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.FontUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.FontUIResource
的使用

使用 FontUIResource 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 FontUIResource 的使用

返回 FontUIResource 的 javax.swing.plaf.metal 中的方法
FontUIResource | DefaultMetalTheme.getControlTextFont() 返回控件文本字体。
abstract FontUIResource | MetalTheme.getControlTextFont() 返回控件文本字体。
static FontUIResource | MetalLookAndFeel.getControlTextFont() 返回当前主题的控件文本字体。
FontUIResource | DefaultMetalTheme.getMenuTextFont() 返回菜单文本字体。
abstract FontUIResource | MetalTheme.getMenuTextFont() 返回菜单文本字体。
static FontUIResource | MetalLookAndFeel.getMenuTextFont() 返回当前主题的菜单文本字体。
FontUIResource | DefaultMetalTheme.getSubTextFont() 返回子文本字体。
abstract FontUIResource | MetalTheme.getSubTextFont() 返回子文本字体。
static FontUIResource | MetalLookAndFeel.getSubTextFont() 返回当前主题的子文本字体。
FontUIResource | DefaultMetalTheme.getSystemTextFont() 返回系统文本字体。
abstract FontUIResource | MetalTheme.getSystemTextFont() 返回系统文本字体。
static FontUIResource | MetalLookAndFeel.getSystemTextFont() 返回当前主题的系统文本字体。
FontUIResource | DefaultMetalTheme.getUserTextFont() 返回用户文本字体。
abstract FontUIResource | MetalTheme.getUserTextFont() 返回用户文本字体。
static FontUIResource | MetalLookAndFeel.getUserTextFont() 返回当前主题的用户文本字体。
FontUIResource | DefaultMetalTheme.getWindowTitleFont() 返回窗口标题字体。
abstract FontUIResource | MetalTheme.getWindowTitleFont() 返回窗口标题字体。
static FontUIResource | MetalLookAndFeel.getWindowTitleFont() 返回当前主题的窗口标题字体。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.IconUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.IconUIResource
的使用

没有 javax.swing.plaf.IconUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.InputMapUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.InputMapUIResource
的使用

没有 javax.swing.plaf.InputMapUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.InsetsUIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.InsetsUIResource
的使用

没有 javax.swing.plaf.InsetsUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.InternalFrameUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.InternalFrameUI
的使用

使用 InternalFrameUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 InternalFrameUI 的使用

返回 InternalFrameUI 的 javax.swing 中的方法
 InternalFrameUI JInternalFrame.getUI()
返回呈现此组件的外观对象。

参数类型为 InternalFrameUI 的 javax.swing 中的方法
 void JInternalFrame.setUI(InternalFrameUI ui)
设置此 JInternalFrame 的 UI 委托。

javax.swing.plaf.basic 中 InternalFrameUI 的使用

javax.swing.plaf.basic 中 InternalFrameUI 的子类
 class BasicInternalFrameUI
JInternalFrame 的基本 L&F 实现。

javax.swing.plaf.metal 中 InternalFrameUI 的使用

javax.swing.plaf.metal 中 InternalFrameUI 的子类
 class MetalInternalFrameUI
JInternalFrame 的 Metal 实现。

javax.swing.plaf.multi 中 InternalFrameUI 的使用

javax.swing.plaf.multi 中 InternalFrameUI 的子类
 class MultiInternalFrameUI
用于组合 InternalFrameUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.LabelUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.LabelUI
的使用

使用 LabelUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 LabelUI 的使用

返回 LabelUI 的 javax.swing 中的方法
 LabelUI JLabel.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 LabelUI 的 javax.swing 中的方法
 void JLabel.setUI(LabelUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 LabelUI 的使用

javax.swing.plaf.basic 中 LabelUI 的子类
 class BasicLabelUI
LabelUI 的 Windows L&F 实现。

javax.swing.plaf.metal 中 LabelUI 的使用

javax.swing.plaf.metal 中 LabelUI 的子类
 class MetalLabelUI
LabelUI 的 Windows L&F 实现。

javax.swing.plaf.multi 中 LabelUI 的使用

javax.swing.plaf.multi 中 LabelUI 的子类
 class MultiLabelUI
用于组合 LabelUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ListUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ListUI
的使用

使用 ListUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ListUI 的使用

返回 ListUI 的 javax.swing 中的方法
 ListUI JList.getUI()
返回呈现此组件的外观对象 ListUI。

参数类型为 ListUI 的 javax.swing 中的方法
 void JList.setUI(ListUI ui)
设置呈现此组件的外观对象 ListUI。

javax.swing.plaf.basic 中 ListUI 的使用

javax.swing.plaf.basic 中 ListUI 的子类
 class BasicListUI
ListUI 的可扩展实现。

javax.swing.plaf.multi 中 ListUI 的使用

javax.swing.plaf.multi 中 ListUI 的子类
 class MultiListUI
用于组合 ListUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.MenuBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.MenuBarUI
的使用

使用 MenuBarUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 MenuBarUI 的使用

返回 MenuBarUI 的 javax.swing 中的方法
 MenuBarUI JMenuBar.getUI()
返回菜单栏的当前 UI。

参数类型为 MenuBarUI 的 javax.swing 中的方法
 void JMenuBar.setUI(MenuBarUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 MenuBarUI 的使用

javax.swing.plaf.basic 中 MenuBarUI 的子类
 class BasicMenuBarUI
MenuBarUI 的默认 L&F 实现。

javax.swing.plaf.metal 中 MenuBarUI 的使用

javax.swing.plaf.metal 中 MenuBarUI 的子类
 class MetalMenuBarUI
MenuBarUI 的 Metal 实现。

javax.swing.plaf.multi 中 MenuBarUI 的使用

javax.swing.plaf.multi 中 MenuBarUI 的子类
 class MultiMenuBarUI
用于组合 MenuBarUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.MenuItemUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.MenuItemUI
的使用

使用 MenuItemUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 MenuItemUI 的使用

参数类型为 MenuItemUI 的 javax.swing 中的方法
 void JMenuItem.setUI(MenuItemUI ui)
设置呈现此组件的外观对象。

javax.swing.plaf.basic 中 MenuItemUI 的使用

javax.swing.plaf.basic 中 MenuItemUI 的子类
class | BasicCheckBoxMenuItemUI BasicCheckboxMenuItem 实现
class | BasicMenuItemUI BasicMenuItem 实现
class | BasicMenuUI MenuUI 的默认 L&F 实现。
class | BasicRadioButtonMenuItemUI BasicRadioButtonMenuItem 实现

javax.swing.plaf.multi 中 MenuItemUI 的使用

javax.swing.plaf.multi 中 MenuItemUI 的子类
 class MultiMenuItemUI
用于组合 MenuItemUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.OptionPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.OptionPaneUI
的使用

使用 OptionPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 OptionPaneUI 的使用

返回 OptionPaneUI 的 javax.swing 中的方法
 OptionPaneUI JOptionPane.getUI()
返回实现此组件 L&F 的 UI 对象。

参数类型为 OptionPaneUI 的 javax.swing 中的方法
 void JOptionPane.setUI(OptionPaneUI ui)
设置实现此组件 L&F 的 UI 对象。

javax.swing.plaf.basic 中 OptionPaneUI 的使用

javax.swing.plaf.basic 中 OptionPaneUI 的子类
 class BasicOptionPaneUI
为 JOptionPane 提供基本外观。

javax.swing.plaf.multi 中 OptionPaneUI 的使用

javax.swing.plaf.multi 中 OptionPaneUI 的子类
 class MultiOptionPaneUI
用于组合 OptionPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.PanelUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.PanelUI
的使用

使用 PanelUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 PanelUI 的使用

返回 PanelUI 的 javax.swing 中的方法
 PanelUI JPanel.getUI()
返回呈现此组件的外观 (L&F) 对象。

参数类型为 PanelUI 的 javax.swing 中的方法
 void JPanel.setUI(PanelUI ui)
设置呈现此组件的外观 (L&F) 对象。

javax.swing.plaf.basic 中 PanelUI 的使用

javax.swing.plaf.basic 中 PanelUI 的子类
 class BasicPanelUI
BasicPanel 实现

javax.swing.plaf.multi 中 PanelUI 的使用

javax.swing.plaf.multi 中 PanelUI 的子类
 class MultiPanelUI
用于组合 PanelUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.PopupMenuUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.PopupMenuUI
的使用

使用 PopupMenuUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 PopupMenuUI 的使用

返回 PopupMenuUI 的 javax.swing 中的方法
 PopupMenuUI JPopupMenu.getUI()
返回用于呈现此组件的外观 (L&F) 对象。

参数类型为 PopupMenuUI 的 javax.swing 中的方法
 void JPopupMenu.setUI(PopupMenuUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 PopupMenuUI 的使用

javax.swing.plaf.basic 中 PopupMenuUI 的子类
 class BasicPopupMenuUI
PopupMenuUI 的 Windows L&F 实现。

javax.swing.plaf.multi 中 PopupMenuUI 的使用

javax.swing.plaf.multi 中 PopupMenuUI 的子类
 class MultiPopupMenuUI
用于组合 PopupMenuUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ProgressBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ProgressBarUI
的使用

使用 ProgressBarUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ProgressBarUI 的使用

返回 ProgressBarUI 的 javax.swing 中的方法
 ProgressBarUI JProgressBar.getUI()
返回呈现此组件的外观对象。

参数类型为 ProgressBarUI 的 javax.swing 中的方法
 void JProgressBar.setUI(ProgressBarUI ui)
设置呈现此组件的外观对象。

javax.swing.plaf.basic 中 ProgressBarUI 的使用

javax.swing.plaf.basic 中 ProgressBarUI 的子类
 class BasicProgressBarUI
ProgressBarUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 ProgressBarUI 的使用

javax.swing.plaf.metal 中 ProgressBarUI 的子类
 class MetalProgressBarUI
ProgressBarUI 的 Metal 实现。

javax.swing.plaf.multi 中 ProgressBarUI 的使用

javax.swing.plaf.multi 中 ProgressBarUI 的子类
 class MultiProgressBarUI
用于组合 ProgressBarUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.RootPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.RootPaneUI
的使用

使用 RootPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 RootPaneUI 的使用

返回 RootPaneUI 的 javax.swing 中的方法
 RootPaneUI JRootPane.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 RootPaneUI 的 javax.swing 中的方法
 void JRootPane.setUI(RootPaneUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 RootPaneUI 的使用

javax.swing.plaf.basic 中 RootPaneUI 的子类
 class BasicRootPaneUI
RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。

javax.swing.plaf.metal 中 RootPaneUI 的使用

javax.swing.plaf.metal 中 RootPaneUI 的子类
 class MetalRootPaneUI
提供 RootPaneUI 的 metal 外观实现。

javax.swing.plaf.multi 中 RootPaneUI 的使用

javax.swing.plaf.multi 中 RootPaneUI 的子类
 class MultiRootPaneUI
用于组合 RootPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ScrollBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ScrollBarUI
的使用

使用 ScrollBarUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ScrollBarUI 的使用

返回 ScrollBarUI 的 javax.swing 中的方法
 ScrollBarUI JScrollBar.getUI()
返回实现此组件的外观的委托。

参数类型为 ScrollBarUI 的 javax.swing 中的方法
 void JScrollBar.setUI(ScrollBarUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ScrollBarUI 的使用

javax.swing.plaf.basic 中 ScrollBarUI 的子类
 class BasicScrollBarUI
基本外观的 ScrollBarUI 的实现

javax.swing.plaf.metal 中 ScrollBarUI 的使用

javax.swing.plaf.metal 中 ScrollBarUI 的子类
 class MetalScrollBarUI
ScrollBarUI 的 Metal 外观实现

javax.swing.plaf.multi 中 ScrollBarUI 的使用

javax.swing.plaf.multi 中 ScrollBarUI 的子类
 class MultiScrollBarUI
用于组合 ScrollBarUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ScrollPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ScrollPaneUI
的使用

使用 ScrollPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ScrollPaneUI 的使用

返回 ScrollPaneUI 的 javax.swing 中的方法
 ScrollPaneUI JScrollPane.getUI()
返回呈现此组件的外观 (L&F) 对象。

参数类型为 ScrollPaneUI 的 javax.swing 中的方法
 void JScrollPane.setUI(ScrollPaneUI ui)
设置 ScrollPaneUI 对象，它为此组件提供外观 (L&F)。

javax.swing.plaf.basic 中 ScrollPaneUI 的使用

javax.swing.plaf.basic 中 ScrollPaneUI 的子类
 class BasicScrollPaneUI
ScrollPaneUI 的默认 L&F 实现。

javax.swing.plaf.metal 中 ScrollPaneUI 的使用

javax.swing.plaf.metal 中 ScrollPaneUI 的子类
 class MetalScrollPaneUI
ScrollPaneUI 的 Metal L&F 实现。

javax.swing.plaf.multi 中 ScrollPaneUI 的使用

javax.swing.plaf.multi 中 ScrollPaneUI 的子类
 class MultiScrollPaneUI
用于组合 ScrollPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.SeparatorUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.SeparatorUI
的使用

使用 SeparatorUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 SeparatorUI 的使用

返回 SeparatorUI 的 javax.swing 中的方法
 SeparatorUI JSeparator.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 SeparatorUI 的 javax.swing 中的方法
 void JSeparator.setUI(SeparatorUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 SeparatorUI 的使用

javax.swing.plaf.basic 中 SeparatorUI 的子类
class | BasicPopupMenuSeparatorUI PopupMenuSeparatorUI 的基本 L&F 实现。
class | BasicSeparatorUI SeparatorUI 的基本 L&F 实现。
class | BasicToolBarSeparatorUI ToolBarSeparatorUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 SeparatorUI 的使用

javax.swing.plaf.metal 中 SeparatorUI 的子类
class | MetalPopupMenuSeparatorUI PopupMenuSeparatorUI 的 Metal L&F 实现。
class | MetalSeparatorUI SeparatorUI 的 Metal L&F 实现。

javax.swing.plaf.multi 中 SeparatorUI 的使用

javax.swing.plaf.multi 中 SeparatorUI 的子类
 class MultiSeparatorUI
用于组合 SeparatorUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.SliderUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.SliderUI
的使用

使用 SliderUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 SliderUI 的使用

返回 SliderUI 的 javax.swing 中的方法
 SliderUI JSlider.getUI()
获取实现此组件 L&F 的 UI 对象。

参数类型为 SliderUI 的 javax.swing 中的方法
 void JSlider.setUI(SliderUI ui)
设置实现此组件 L&F 的 UI 对象。

javax.swing.plaf.basic 中 SliderUI 的使用

javax.swing.plaf.basic 中 SliderUI 的子类
 class BasicSliderUI
SliderUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 SliderUI 的使用

javax.swing.plaf.metal 中 SliderUI 的子类
 class MetalSliderUI
SliderUI 的 Java L&F 实现。

javax.swing.plaf.multi 中 SliderUI 的使用

javax.swing.plaf.multi 中 SliderUI 的子类
 class MultiSliderUI
用于组合 SliderUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.SpinnerUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.SpinnerUI
的使用

使用 SpinnerUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 SpinnerUI 的使用

返回 SpinnerUI 的 javax.swing 中的方法
 SpinnerUI JSpinner.getUI()
返回呈现此组件的外观 (L&F) 对象。

参数类型为 SpinnerUI 的 javax.swing 中的方法
 void JSpinner.setUI(SpinnerUI ui)
设置呈现此组件的外观 (L&F) 对象。

javax.swing.plaf.basic 中 SpinnerUI 的使用

javax.swing.plaf.basic 中 SpinnerUI 的子类
 class BasicSpinnerUI
默认 Spinner UI 委托。

javax.swing.plaf.multi 中 SpinnerUI 的使用

javax.swing.plaf.multi 中 SpinnerUI 的子类
 class MultiSpinnerUI
用于组合 SpinnerUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.SplitPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.SplitPaneUI
的使用

使用 SplitPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 SplitPaneUI 的使用

返回 SplitPaneUI 的 javax.swing 中的方法
 SplitPaneUI JSplitPane.getUI()
返回提供当前外观的 SplitPaneUI。

参数类型为 SplitPaneUI 的 javax.swing 中的方法
 void JSplitPane.setUI(SplitPaneUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 SplitPaneUI 的使用

javax.swing.plaf.basic 中 SplitPaneUI 的子类
 class BasicSplitPaneUI
SplitPaneUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 SplitPaneUI 的使用

javax.swing.plaf.metal 中 SplitPaneUI 的子类
 class MetalSplitPaneUI
Metal 分隔窗格。

javax.swing.plaf.multi 中 SplitPaneUI 的使用

javax.swing.plaf.multi 中 SplitPaneUI 的子类
 class MultiSplitPaneUI
用于组合 SplitPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.TabbedPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.TabbedPaneUI
的使用

使用 TabbedPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 TabbedPaneUI 的使用

返回 TabbedPaneUI 的 javax.swing 中的方法
 TabbedPaneUI JTabbedPane.getUI()
返回实现此组件的 L&F 的 UI 对象。

参数类型为 TabbedPaneUI 的 javax.swing 中的方法
 void JTabbedPane.setUI(TabbedPaneUI ui)
设置实现此组件的 L&F 的 UI 对象。

javax.swing.plaf.basic 中 TabbedPaneUI 的使用

javax.swing.plaf.basic 中 TabbedPaneUI 的子类
 class BasicTabbedPaneUI
TabbedPaneUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 TabbedPaneUI 的使用

javax.swing.plaf.metal 中 TabbedPaneUI 的子类
 class MetalTabbedPaneUI
BasicTabbedPaneUI 的 Metal 子类。

javax.swing.plaf.multi 中 TabbedPaneUI 的使用

javax.swing.plaf.multi 中 TabbedPaneUI 的子类
 class MultiTabbedPaneUI
用于组合 TabbedPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.TableHeaderUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.TableHeaderUI
的使用

使用 TableHeaderUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.plaf.basic 中 TableHeaderUI 的使用

javax.swing.plaf.basic 中 TableHeaderUI 的子类
 class BasicTableHeaderUI
BasicTableHeaderUI 实现

javax.swing.plaf.multi 中 TableHeaderUI 的使用

javax.swing.plaf.multi 中 TableHeaderUI 的子类
 class MultiTableHeaderUI
用于组合 TableHeaderUI 的多路 UI。

javax.swing.table 中 TableHeaderUI 的使用

返回 TableHeaderUI 的 javax.swing.table 中的方法
 TableHeaderUI JTableHeader.getUI()
返回渲染此组件的外观 (L&F) 对象。

参数类型为 TableHeaderUI 的 javax.swing.table 中的方法
 void JTableHeader.setUI(TableHeaderUI ui)
设置渲染此组件的 (L&F) 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.TableUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.TableUI
的使用

使用 TableUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 TableUI 的使用

返回 TableUI 的 javax.swing 中的方法
 TableUI JTable.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 TableUI 的 javax.swing 中的方法
 void JTable.setUI(TableUI ui)
设置呈现此组件并进行重新绘制的 L&F 对象。

javax.swing.plaf.basic 中 TableUI 的使用

javax.swing.plaf.basic 中 TableUI 的子类
 class BasicTableUI
BasicTableUI 实现

javax.swing.plaf.multi 中 TableUI 的使用

javax.swing.plaf.multi 中 TableUI 的子类
 class MultiTableUI
用于组合 TableUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.TextUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.TextUI
的使用

使用 TextUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 TextUI 的使用

javax.swing.plaf.basic 中 TextUI 的子类
class | BasicEditorPaneUI 为 JEditorPane 提供外观。
class | BasicFormattedTextFieldUI 提供 JFormattedTextField 的外观实现。
class | BasicPasswordFieldUI 为密码字段提供 Windows 外观。
class | BasicTextAreaUI 为纯文本编辑器提供外观。
class | BasicTextFieldUI JTextField 的外观的基础。
class | BasicTextPaneUI 为样式化文本编辑器提供外观。
class | BasicTextUI 此类是文本组件外观的基础。

javax.swing.plaf.metal 中 TextUI 的使用

javax.swing.plaf.metal 中 TextUI 的子类
 class MetalTextFieldUI
JTextField 外观的基础。

javax.swing.plaf.multi 中 TextUI 的使用

javax.swing.plaf.multi 中 TextUI 的子类
 class MultiTextUI
用于组合 TextUI 的多路 UI。

javax.swing.text 中 TextUI 的使用

javax.swing.text 中 TextUI 的子类
 class DefaultTextUI
已过时。

返回 TextUI 的 javax.swing.text 中的方法
 TextUI JTextComponent.getUI()
获取此面向文本的编辑器的用户界面工厂。

参数类型为 TextUI 的 javax.swing.text 中的方法
 void JTextComponent.setUI(TextUI ui)
设置此面向文本的编辑器的用户界面工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ToolBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ToolBarUI
的使用

使用 ToolBarUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ToolBarUI 的使用

返回 ToolBarUI 的 javax.swing 中的方法
 ToolBarUI JToolBar.getUI()
返回工具栏的当前 UI。

参数类型为 ToolBarUI 的 javax.swing 中的方法
 void JToolBar.setUI(ToolBarUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ToolBarUI 的使用

javax.swing.plaf.basic 中 ToolBarUI 的子类
 class BasicToolBarUI
ToolBarUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 ToolBarUI 的使用

javax.swing.plaf.metal 中 ToolBarUI 的子类
 class MetalToolBarUI
ToolBarUI 的 Metal 外观实现。

javax.swing.plaf.multi 中 ToolBarUI 的使用

javax.swing.plaf.multi 中 ToolBarUI 的子类
 class MultiToolBarUI
用于组合 ToolBarUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ToolTipUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ToolTipUI
的使用

使用 ToolTipUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ToolTipUI 的使用

返回 ToolTipUI 的 javax.swing 中的方法
 ToolTipUI JToolTip.getUI()
返回呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ToolTipUI 的使用

javax.swing.plaf.basic 中 ToolTipUI 的子类
 class BasicToolTipUI
标准工具提示 L&F。

javax.swing.plaf.metal 中 ToolTipUI 的使用

javax.swing.plaf.metal 中 ToolTipUI 的子类
 class MetalToolTipUI
BasicToolTipUI 的 Metal L&F 扩展。

javax.swing.plaf.multi 中 ToolTipUI 的使用

javax.swing.plaf.multi 中 ToolTipUI 的子类
 class MultiToolTipUI
用于组合 ToolTipUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.TreeUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.TreeUI
的使用

使用 TreeUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 TreeUI 的使用

返回 TreeUI 的 javax.swing 中的方法
 TreeUI JTree.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 TreeUI 的 javax.swing 中的方法
 void JTree.setUI(TreeUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 TreeUI 的使用

javax.swing.plaf.basic 中 TreeUI 的子类
 class BasicTreeUI
层次数据结构的基本 L&F。

javax.swing.plaf.metal 中 TreeUI 的使用

javax.swing.plaf.metal 中 TreeUI 的子类
 class MetalTreeUI
TreeUI 的 metal 外观实现。

javax.swing.plaf.multi 中 TreeUI 的使用

javax.swing.plaf.multi 中 TreeUI 的子类
 class MultiTreeUI
用于组合 TreeUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.plaf.UIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.plaf.UIResource
的使用

使用 UIResource 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 UIResource 的使用

实现 UIResource 的 javax.swing 中的类
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
static class | ScrollPaneLayout.UIResource ScrollPaneLayout 的 UI 资源版本。

javax.swing.plaf 中 UIResource 的使用

实现 UIResource 的 javax.swing.plaf 中的类
class | ActionMapUIResource 实现 UIResource 的 javax.swing.ActionMap 的子类。
class | BorderUIResource
static class | BorderUIResource.BevelBorderUIResource
static class | BorderUIResource.CompoundBorderUIResource
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.EtchedBorderUIResource
static class | BorderUIResource.LineBorderUIResource
static class | BorderUIResource.MatteBorderUIResource
static class | BorderUIResource.TitledBorderUIResource
class | ColorUIResource
class | ComponentInputMapUIResource 实现 UIResource 的 javax.swing.ComponentInputMap 的子类。
class | DimensionUIResource
class | FontUIResource 实现 UIResource 的 java.awt.Font 的子类。
class | IconUIResource 实现 UIResource 的 Icon 包装类。
class | InputMapUIResource 实现 UIResource 的 javax.swing.InputMap 的子类。
class | InsetsUIResource

javax.swing.plaf.basic 中 UIResource 的使用

实现 UIResource 的 javax.swing.plaf.basic 中的类
static class | BasicBorders.ButtonBorder
static class | BasicBorders.FieldBorder
static class | BasicBorders.MarginBorder
static class | BasicBorders.MenuBarBorder
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.SplitPaneBorder 绘制围绕拆分窗格的边框。
static class | BasicBorders.ToggleButtonBorder
static class | BasicComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的子类。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
static class | BasicTextUI.BasicCaret
static class | BasicTextUI.BasicHighlighter
class | DefaultMenuLayout Popup 菜单和菜单栏的默认布局管理器。

javax.swing.plaf.metal 中 UIResource 的使用

实现 UIResource 的 javax.swing.plaf.metal 中的类
static class | MetalBorders.ButtonBorder
static class | MetalBorders.Flush3DBorder
static class | MetalBorders.InternalFrameBorder
static class | MetalBorders.MenuBarBorder
static class | MetalBorders.MenuItemBorder
static class | MetalBorders.OptionDialogBorder
static class | MetalBorders.PaletteBorder Palette 的边框。
static class | MetalBorders.PopupMenuBorder
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ScrollPaneBorder
static class | MetalBorders.TextFieldBorder
static class | MetalBorders.ToggleButtonBorder
static class | MetalBorders.ToolBarBorder
class | MetalCheckBoxIcon OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
static class | MetalComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的一个子类。
static class | MetalIconFactory.PaletteCloseIcon 定义一个用于 Palette 关闭的图标

javax.swing.table 中 UIResource 的使用

实现 UIResource 的 javax.swing.table 中的类
static class DefaultTableCellRenderer.UIResource
DefaultTableCellRenderer 的一个子类，它实现 UIResource。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.ViewportUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ViewportUI
的使用

使用 ViewportUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ViewportUI 的使用

返回 ViewportUI 的 javax.swing 中的方法
 ViewportUI JViewport.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 ViewportUI 的 javax.swing 中的方法
 void JViewport.setUI(ViewportUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ViewportUI 的使用

javax.swing.plaf.basic 中 ViewportUI 的子类
 class BasicViewportUI
BasicViewport 实现

javax.swing.plaf.multi 中 ViewportUI 的使用

javax.swing.plaf.multi 中 ViewportUI 的子类
 class MultiViewportUI
用于组合 ViewportUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.plaf.metal (Java 2 Platform SE 6)

 javax.swing.plaf.metal
类
DefaultMetalTheme
MetalBorders
MetalBorders.ButtonBorder
MetalBorders.Flush3DBorder
MetalBorders.InternalFrameBorder
MetalBorders.MenuBarBorder
MetalBorders.MenuItemBorder
MetalBorders.OptionDialogBorder
MetalBorders.PaletteBorder
MetalBorders.PopupMenuBorder
MetalBorders.RolloverButtonBorder
MetalBorders.ScrollPaneBorder
MetalBorders.TableHeaderBorder
MetalBorders.TextFieldBorder
MetalBorders.ToggleButtonBorder
MetalBorders.ToolBarBorder
MetalButtonUI
MetalCheckBoxIcon
MetalCheckBoxUI
MetalComboBoxButton
MetalComboBoxEditor
MetalComboBoxEditor.UIResource
MetalComboBoxIcon
MetalComboBoxUI
MetalDesktopIconUI
MetalFileChooserUI
MetalIconFactory
MetalIconFactory.FileIcon16
MetalIconFactory.FolderIcon16
MetalIconFactory.PaletteCloseIcon
MetalIconFactory.TreeControlIcon
MetalIconFactory.TreeFolderIcon
MetalIconFactory.TreeLeafIcon
MetalInternalFrameTitlePane
MetalInternalFrameUI
MetalLabelUI
MetalLookAndFeel
MetalMenuBarUI
MetalPopupMenuSeparatorUI
MetalProgressBarUI
MetalRadioButtonUI
MetalRootPaneUI
MetalScrollBarUI
MetalScrollButton
MetalScrollPaneUI
MetalSeparatorUI
MetalSliderUI
MetalSplitPaneUI
MetalTabbedPaneUI
MetalTextFieldUI
MetalTheme
MetalToggleButtonUI
MetalToolBarUI
MetalToolTipUI
MetalTreeUI
OceanTheme


类 javax.swing.plaf.metal.DefaultMetalTheme 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.DefaultMetalTheme
的使用

使用 DefaultMetalTheme 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 DefaultMetalTheme 的使用

javax.swing.plaf.metal 中 DefaultMetalTheme 的子类
 class OceanTheme
MetalLookAndFeel 的默认主题。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders
的使用

没有 javax.swing.plaf.metal.MetalBorders 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.ButtonBorder
的使用

使用 MetalBorders.ButtonBorder 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalBorders.ButtonBorder 的使用

javax.swing.plaf.metal 中 MetalBorders.ButtonBorder 的子类
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ToggleButtonBorder

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder
的使用

使用 MetalBorders.Flush3DBorder 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalBorders.Flush3DBorder 的使用

javax.swing.plaf.metal 中 MetalBorders.Flush3DBorder 的子类
static class MetalBorders.TextFieldBorder

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.PaletteBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.PaletteBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.PaletteBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.TextFieldBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.TextFieldBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.TextFieldBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalButtonUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalButtonUI
的使用

没有 javax.swing.plaf.metal.MetalButtonUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalCheckBoxIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalCheckBoxIcon
的使用

没有 javax.swing.plaf.metal.MetalCheckBoxIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalCheckBoxUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalCheckBoxUI
的使用

没有 javax.swing.plaf.metal.MetalCheckBoxUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxButton
的使用

没有 javax.swing.plaf.metal.MetalComboBoxButton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxEditor
的使用

使用 MetalComboBoxEditor 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalComboBoxEditor 的使用

javax.swing.plaf.metal 中 MetalComboBoxEditor 的子类
static class MetalComboBoxEditor.UIResource
实现 UIResource 的 BasicComboBoxEditor 的一个子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxEditor.UIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxEditor.UIResource
的使用

没有 javax.swing.plaf.metal.MetalComboBoxEditor.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxIcon
的使用

没有 javax.swing.plaf.metal.MetalComboBoxIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxUI
的使用

没有 javax.swing.plaf.metal.MetalComboBoxUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
的使用

使用 MetalComboBoxUI.MetalComboBoxLayoutManager 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalComboBoxUI.MetalComboBoxLayoutManager 的使用

参数类型为 MetalComboBoxUI.MetalComboBoxLayoutManager 的 javax.swing.plaf.metal 中的方法
 void MetalComboBoxUI.layoutComboBox(Container parent, MetalComboBoxUI.MetalComboBoxLayoutManager manager)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
的使用

没有 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
的使用

没有 javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalDesktopIconUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalDesktopIconUI
的使用

没有 javax.swing.plaf.metal.MetalDesktopIconUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI
的使用

没有 javax.swing.plaf.metal.MetalFileChooserUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
的使用

没有 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel
的使用

使用 MetalFileChooserUI.DirectoryComboBoxModel 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalFileChooserUI.DirectoryComboBoxModel 的使用

返回 MetalFileChooserUI.DirectoryComboBoxModel 的 javax.swing.plaf.metal 中的方法
protected  MetalFileChooserUI.DirectoryComboBoxModel MetalFileChooserUI.createDirectoryComboBoxModel(JFileChooser fc)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
的使用

没有 javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel
的使用

使用 MetalFileChooserUI.FilterComboBoxModel 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalFileChooserUI.FilterComboBoxModel 的使用

返回 MetalFileChooserUI.FilterComboBoxModel 的 javax.swing.plaf.metal 中的方法
protected  MetalFileChooserUI.FilterComboBoxModel MetalFileChooserUI.createFilterComboBoxModel()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer
的使用

使用 MetalFileChooserUI.FilterComboBoxRenderer 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalFileChooserUI.FilterComboBoxRenderer 的使用

返回 MetalFileChooserUI.FilterComboBoxRenderer 的 javax.swing.plaf.metal 中的方法
protected  MetalFileChooserUI.FilterComboBoxRenderer MetalFileChooserUI.createFilterComboBoxRenderer()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
的使用

没有 javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory
的使用

没有 javax.swing.plaf.metal.MetalIconFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16
的使用

使用 MetalIconFactory.FileIcon16 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalIconFactory.FileIcon16 的使用

javax.swing.plaf.metal 中 MetalIconFactory.FileIcon16 的子类
static class MetalIconFactory.TreeLeafIcon

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16
的使用

使用 MetalIconFactory.FolderIcon16 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalIconFactory.FolderIcon16 的使用

javax.swing.plaf.metal 中 MetalIconFactory.FolderIcon16 的子类
static class MetalIconFactory.TreeFolderIcon
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon
的使用

没有 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon
的使用

没有 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
的使用

没有 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
的使用

没有 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalInternalFrameTitlePane
的使用

没有 javax.swing.plaf.metal.MetalInternalFrameTitlePane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalInternalFrameUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalInternalFrameUI
的使用

没有 javax.swing.plaf.metal.MetalInternalFrameUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalLabelUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalLabelUI
的使用

使用 MetalLabelUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalLabelUI 的使用

声明为 MetalLabelUI 的 javax.swing.plaf.metal 中的字段
protected static MetalLabelUI MetalLabelUI.metalLabelUI
默认的 MetalLabelUI 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalLookAndFeel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalLookAndFeel
的使用

没有 javax.swing.plaf.metal.MetalLookAndFeel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalMenuBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalMenuBarUI
的使用

没有 javax.swing.plaf.metal.MetalMenuBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
的使用

没有 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalProgressBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalProgressBarUI
的使用

没有 javax.swing.plaf.metal.MetalProgressBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalRadioButtonUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalRadioButtonUI
的使用

使用 MetalRadioButtonUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalRadioButtonUI 的使用

javax.swing.plaf.metal 中 MetalRadioButtonUI 的子类
 class MetalCheckBoxUI
MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalRootPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalRootPaneUI
的使用

没有 javax.swing.plaf.metal.MetalRootPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalScrollBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalScrollBarUI
的使用

没有 javax.swing.plaf.metal.MetalScrollBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalScrollButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalScrollButton
的使用

使用 MetalScrollButton 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalScrollButton 的使用

声明为 MetalScrollButton 的 javax.swing.plaf.metal 中的字段
protected MetalScrollButton | MetalScrollBarUI.decreaseButton
protected MetalScrollButton | MetalScrollBarUI.increaseButton

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalScrollPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalScrollPaneUI
的使用

没有 javax.swing.plaf.metal.MetalScrollPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalSeparatorUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalSeparatorUI
的使用

使用 MetalSeparatorUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalSeparatorUI 的使用

javax.swing.plaf.metal 中 MetalSeparatorUI 的子类
 class MetalPopupMenuSeparatorUI
PopupMenuSeparatorUI 的 Metal L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalSliderUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalSliderUI
的使用

没有 javax.swing.plaf.metal.MetalSliderUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
的使用

没有 javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalSplitPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalSplitPaneUI
的使用

没有 javax.swing.plaf.metal.MetalSplitPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalTabbedPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalTabbedPaneUI
的使用

没有 javax.swing.plaf.metal.MetalTabbedPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
的使用

没有 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalTextFieldUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalTextFieldUI
的使用

没有 javax.swing.plaf.metal.MetalTextFieldUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalTheme 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalTheme
的使用

使用 MetalTheme 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalTheme 的使用

javax.swing.plaf.metal 中 MetalTheme 的子类
class | DefaultMetalTheme 提供 Java 外观原型的 MetalTheme 的一个具体实现，代码名称为“Steel”。
class | OceanTheme MetalLookAndFeel 的默认主题。

返回 MetalTheme 的 javax.swing.plaf.metal 中的方法
static MetalTheme MetalLookAndFeel.getCurrentTheme()
返回 MetalLookAndFeel 当前正在使用的主题。

参数类型为 MetalTheme 的 javax.swing.plaf.metal 中的方法
static void MetalLookAndFeel.setCurrentTheme(MetalTheme theme)
设置 MetalLookAndFeel 使用的主题。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToggleButtonUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToggleButtonUI
的使用

没有 javax.swing.plaf.metal.MetalToggleButtonUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToolBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToolBarUI
的使用

没有 javax.swing.plaf.metal.MetalToolBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
的使用

没有 javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
的使用

没有 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
的使用

没有 javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToolTipUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToolTipUI
的使用

没有 javax.swing.plaf.metal.MetalToolTipUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalTreeUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalTreeUI
的使用

没有 javax.swing.plaf.metal.MetalTreeUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.metal.OceanTheme 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.OceanTheme
的使用

没有 javax.swing.plaf.metal.OceanTheme 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.plaf.multi (Java 2 Platform SE 6)

 javax.swing.plaf.multi
类
MultiButtonUI
MultiColorChooserUI
MultiComboBoxUI
MultiDesktopIconUI
MultiDesktopPaneUI
MultiFileChooserUI
MultiInternalFrameUI
MultiLabelUI
MultiListUI
MultiLookAndFeel
MultiMenuBarUI
MultiMenuItemUI
MultiOptionPaneUI
MultiPanelUI
MultiPopupMenuUI
MultiProgressBarUI
MultiRootPaneUI
MultiScrollBarUI
MultiScrollPaneUI
MultiSeparatorUI
MultiSliderUI
MultiSpinnerUI
MultiSplitPaneUI
MultiTabbedPaneUI
MultiTableHeaderUI
MultiTableUI
MultiTextUI
MultiToolBarUI
MultiToolTipUI
MultiTreeUI
MultiViewportUI


类 javax.swing.plaf.multi.MultiButtonUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiButtonUI
的使用

没有 javax.swing.plaf.multi.MultiButtonUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiColorChooserUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiColorChooserUI
的使用

没有 javax.swing.plaf.multi.MultiColorChooserUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiComboBoxUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiComboBoxUI
的使用

没有 javax.swing.plaf.multi.MultiComboBoxUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiDesktopIconUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiDesktopIconUI
的使用

没有 javax.swing.plaf.multi.MultiDesktopIconUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiDesktopPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiDesktopPaneUI
的使用

没有 javax.swing.plaf.multi.MultiDesktopPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiFileChooserUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiFileChooserUI
的使用

没有 javax.swing.plaf.multi.MultiFileChooserUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiInternalFrameUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiInternalFrameUI
的使用

没有 javax.swing.plaf.multi.MultiInternalFrameUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiLabelUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiLabelUI
的使用

没有 javax.swing.plaf.multi.MultiLabelUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiListUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiListUI
的使用

没有 javax.swing.plaf.multi.MultiListUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiLookAndFeel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiLookAndFeel
的使用

没有 javax.swing.plaf.multi.MultiLookAndFeel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiMenuBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiMenuBarUI
的使用

没有 javax.swing.plaf.multi.MultiMenuBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiMenuItemUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiMenuItemUI
的使用

没有 javax.swing.plaf.multi.MultiMenuItemUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiOptionPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiOptionPaneUI
的使用

没有 javax.swing.plaf.multi.MultiOptionPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiPanelUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiPanelUI
的使用

没有 javax.swing.plaf.multi.MultiPanelUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiPopupMenuUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiPopupMenuUI
的使用

没有 javax.swing.plaf.multi.MultiPopupMenuUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiProgressBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiProgressBarUI
的使用

没有 javax.swing.plaf.multi.MultiProgressBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiRootPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiRootPaneUI
的使用

没有 javax.swing.plaf.multi.MultiRootPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiScrollBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiScrollBarUI
的使用

没有 javax.swing.plaf.multi.MultiScrollBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiScrollPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiScrollPaneUI
的使用

没有 javax.swing.plaf.multi.MultiScrollPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiSeparatorUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiSeparatorUI
的使用

没有 javax.swing.plaf.multi.MultiSeparatorUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiSliderUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiSliderUI
的使用

没有 javax.swing.plaf.multi.MultiSliderUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiSpinnerUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiSpinnerUI
的使用

没有 javax.swing.plaf.multi.MultiSpinnerUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiSplitPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiSplitPaneUI
的使用

没有 javax.swing.plaf.multi.MultiSplitPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiTabbedPaneUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiTabbedPaneUI
的使用

没有 javax.swing.plaf.multi.MultiTabbedPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiTableHeaderUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiTableHeaderUI
的使用

没有 javax.swing.plaf.multi.MultiTableHeaderUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiTableUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiTableUI
的使用

没有 javax.swing.plaf.multi.MultiTableUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiTextUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiTextUI
的使用

没有 javax.swing.plaf.multi.MultiTextUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiToolBarUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiToolBarUI
的使用

没有 javax.swing.plaf.multi.MultiToolBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiToolTipUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiToolTipUI
的使用

没有 javax.swing.plaf.multi.MultiToolTipUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiTreeUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiTreeUI
的使用

没有 javax.swing.plaf.multi.MultiTreeUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiViewportUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiViewportUI
的使用

没有 javax.swing.plaf.multi.MultiViewportUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


 Using the Multiplexing Look and Feel

This document is based on an article originally published in The Swing Connection.

The Multiplexing look and feel lets you supplement an ordinary look and feel (called the default look and feel) with one or more auxiliary look and feels. For example, you could simultaneously provide text-to-speech and Braille outputs, in addition to the ordinary visual output that a Swing-based application generates, by adding two auxiliary look and feels (one for text-to-speech, the other for Braille) to the default look and feel. The default look and feel can be any ordinary look and feel -- the Java or Windows look and feel, for example -- and requires no modifications to work with auxiliary look and feels.

This document has the following sections:

  • Overview
  • How to Use Auxiliary Look and Feels
  • Tips for Writing an Auxiliary Look and Feel
    • Dos and Don'ts
    • Extending UIDefaults
    • Examining Other UI Objects
  • How the Multiplexing Look and Feel is Implemented
  • How to Provide a Custom Multiplexing Look and Feel

Before reading further, you should be familiar with the concept of pluggable look and feels. For basic information, see Choosing the Look and Feel, a section in The Java Tutorial. For architectural details, you can read Pluggable look-and-feel architecture, a section within a Swing Connection article.

Overview

The classes in the javax.swing.plaf.multi package implement a multiplexing look and feel. A multiplexing look and feel transparently creates -- and simultaneously supports -- UI objects from several different look and feels in response to a component requesting its UI object (with the getUI method).

Without a multiplexing look and feel, a developer who wanted to enhance a particular look and feel would need to extend the classes supporting that look and feel. For example, to add text-to-speech support to the Java look and feel without using a multiplexing look and feel, the developer would need to create a group of classes that extend those of the Java look and feel, and add text-to-speech support to the new classes. If the developer also wanted to add text-to-speech support to other look and feels, such as Motif or Windows, the developers would need to create subclasses of those classes as well.

This approach has at least two shortcomings:

  • First, each subclass must use what is essentially a copy of the same code, potentially creating a difficult support situation for the developer.
  • Second, and more significantly for the end user, some application developers might force a particular look and feel to be used. When this approach is used, the end user can't even use the enhanced look and feel.

A multiplexing look and feel both these problems simultaneously because it allows multiple look and feels to be combined. The first problem (having to use what amounts to a second copy of the same code) is solved because the developer can create a specialized look and feel that can then be combined with other look and feels.

The second problem (having to force the use of a particular look and feel) is solved because a specialized look and feel can be used with whatever default look and feel the application may have locked in place.

The default multiplexing look and feel implementation, represented by the MultiLookAndFeel class in the javax.swing.plaf.multi package, is called (unsurprisingly) the Multiplexing look and feel.

How to Use Auxiliary Look and Feels

It's easy to use auxiliary look and feels with Swing. To instruct Swing to use the Multiplexing look and feel, all an application has to do is modify the $JDKHOME/lib/swing.properties file to include a definition of the swing.auxiliarylaf property. Swing treats the swing.auxiliarylaf property as a comma-separated list of LookAndFeel subclasses that specify what auxiliary look and feels should be used in addition to the default look and feel. If at least one valid LookAndFeel subclass is specified in the swing.auxiliarylaf property, Swing automatically uses the Multiplexing look and feel to load and support the default and auxiliary look and feels.

For example, let's assume that an application makes use of a look and feel that supports text-to-speech feedback, and also uses an look and feel that adds support for a device that emits perfume. Let's assume that the text-to-speech look and feel is named com.myco.TextTalkerLookAndFeel, and the look and feel that adds support for perfume is named com.smellco.OlfactoryLookAndFeel.

To tell Swing to use both these look and feels -- and to use a default look and feel at the same time -- your application could simply add the following line to the $JDKHOME/lib/swing.properties file:

    swing.auxiliarylaf=com.myco.TextTalkerLookAndFeel,
        com.smellco.OlfactoryLookAndFeel

This statement tells Swing to obtain a component's UI from the Multiplexing look and feel automatically, instead of obtaining it directly from the default look and feel. The resulting multiplexing UI is a small delegate that obtains and maintains UIs from the default and auxiliary look and feels. As a result, when a method is invoked in a multiplexing UI object, the multiplexing UI invokes the same method on each of the UIs obtained from the default and auxiliary look and feels.

Tips for Writing an Auxiliary Look and Feel

An auxiliary look and feel is like any other look and feel, except that it doesn't have to provide the complete support that a default look and feel must. For example, an auxiliary look and feel that supports just text-to-speech feedback doesn't need to provide any code for painting. Also, it might not need to support all components -- JSeparators, for example, might be ignored.

Auxiliary look and feels tend to be simple, so developing one can be easier than developing a visual look and feel. The developer can concentrate solely on providing the specialized functionality.

Because the primary purpose of an auxiliary look and feel is to enhance the default look and feel, auxiliary look and feels tend be nonvisual. Since an auxiliary look and feel is a genuine look and feel, however, there is nothing to prevent it from rendering information on the display.

Just like for any other look and feel, you implement an auxiliary look and feel by writing a subclass of javax.swing.LookAndFeel and creating subclasses of the FooUI classes defined in the javax.swing.plaf package.

Dos and Don'ts

The following paragraphs provide some general recommendations for developing auxiliary look and feels.

Use the installUI method to perform all initialization, and the uninstallUI method to perform all cleanup.

    The installUI and uninstallUI methods are invoked when a component's look and feel is set. The installUI method gives the new UI object a chance to add listeners on the component and its data model. Similarly, the uninstallUI method lets the previous UI object remove its listeners.

Don't extend visual look and feels.

    We recommended that you don't implement UI classes of an auxiliary look and feel as subclasses of the UI classes of a visual look and feel.�Why not? Because they might accidentally inherit code that installs listeners on a component object or renders the component on the display.�As a result, your auxiliary look and feel would compete with the default look and feel rather than cooperating with it.

    Instead, we recommend that the UI classes of an auxiliary look and feel directly extend the abstract UI classes in the javax.swing.plaf package.�By using this strategy, the developer of an auxiliary look and feel can avoid competing with the default look and feel.

Override all UI-specific methods your UI classes inherit.

    We recommend that each UI class of an auxiliary look and feel override the methods defined in the javax.swing.plaf UI classes it descends from The reasons for this recommendation are similar to those for not extending a visual look and feel. For example, the ComponentUI class, from which all UI classes descend, provides a default implementation for the update method. This default implementation paints on the display if the component is opaque. If a UI class from a non-visual auxiliary look and feel does not override this method, all opaque components appear as blank areas on the screen!

Extending UIDefaults

In many cases, you might want an auxiliary look and feel to be "incomplete."�That is, you might not need to support the complete set of components. For example, an auxiliary look and feel might choose to provide a ButtonUI subclass but no LabelUI subclass. This option is allowed, and the multiplexing look and feel gracefully handles such situations.

By default, however, Swing issues an error message when it asks a look and feel for a UI object and the look and feel does not support that UI. This message can be annoying, especially to auxiliary look-and-feel developers who don't want to support a particular component.

Fortunately, you can prevent this error message by creating a subclass of the UIDefaults class and returning an instance of it from the getDefaults method of your LookAndFeel class. For example:

public class MyAuxLookAndFeel
              extends LookAndFeel {
��� ...
��� public UIDefaults getDefaults() {
������� UIDefaults table =
new MyAuxUIDefaults();
������� Object[] uiDefaults = {
��������� "ButtonUI", "MyAuxButtonUI",
��������� ...
������� }
������� table.putDefaults(uiDefaults);
������� return table;
��� }
}

class MyAuxUIDefaults extends UIDefaults {
��� protected void getUIError(String msg) {
������� //System.err.println
//   ("An
              annoying message!");
��� }
}

In the preceding example, an auxiliary look and feel named MyAux creates a UIDefaults subclass that overrides the getUIError method.�The getUIError method is the method that is invoked when Swing cannot find a UI object in a look and feel.�By merely doing nothing in this method, you can avoid the error message.

Examining Other UI Objects

In rare instances, a UI object from an auxiliary look and feel may be interested in the default UI object used by the component.�In these cases, the UI object from auxiliary look and feel can obtain the UI from a component by calling its getUI method.�The returned UI is an instance of one of the multiplexing look and feel UI classes (for example, MultiButtonUI). The UI object from the auxiliary look and feel can call the getUIs method of the returned object to obtain an array containing a complete list of all UI objects handled by the multiplexing UI. The first element is guaranteed to be the UI created from the default look and feel.

How the Multiplexing Look and Feel Is Implemented

The Multiplexing look and feel (represented by javax.swing.plaf.multi.MultiLookAndFeel) is meant to be transparent to all developers and users.�It should "just work" -- and it is used only when the user tells Swing to use an auxiliary look and feel.

When the Multiplexing look and feel is in use, the type of the UI object associated with each component depends on whether any of the auxiliary look and feels currently in use support the component. If so, the component's UI object is an instance of a multiplexing UI. If only the default look and feel supports the component, then the component gets a UI object from the default look and feel, just as if no auxiliary look and feels were installed.

A multiplexing UI object obtains and maintains UI objects from the default and auxiliary look and feels, referring to these UIs in the following manner:

  • The UI object from the default look and feel is always the first to be created. After that, a UI object is created from each auxiliary look and feel in the order they are specified in the swing.auxiliarylaf property.

  • When a method that requests information from a UI object is invoked, the multiplexing UI object invokes the method on all the UI objects, but returns only the results from the UI for the default look and feel. For example, when the getPreferredSize method is invoked on a multiplexing UI, the UI returns only the results of invoking getPreferredSize on the UI obtained from the default look and feel. The getPreferredSize method is also invoked on the UI object for each auxiliary look and feel, but the return values are ignored.

  • When a method that does not request information from the UI object is invoked, the multiplexing UI object invokes that method on all UIs -- on the UI object obtained from the default look and feel and on all the UIs obtained from the auxiliary look and feels, as well. For example, invoking the installUI method on a multiplexing UI causes the multiplexing UI to invoke installUI on the UI obtained from the default look and feel and the UIs obtained from the auxiliary factories.

In all cases, the UI object obtained from the default look and feel is acted upon first, and then the auxiliary look and feels are acted upon in the order they are specified in the swing.auxiliarylaf property.

How to Provide a Custom Multiplexing Look and Feel

While we hope the behavior of the Multiplexing look and feel is flexible enough not to require an alternative multiplexing look and feel, Swing allows the user to specify another multiplexing look and feel to use.

To do that, all the user has to do is modify the $JDKHOME/lib/swing.properties file to include a definition of the swing.plaf.multiplexinglaf property.�Swing then treats the swing.plaf.multiplexinglaf property as a LookAndFeel subclass that supports multiplexing.

For example, if a user has a multiplexing look and feel represented by com.myco.SuperMultiLookAndFeel that is a better match for their needs than the Multiplexing look and feel (javax.swing.plaf.multi.MultiLookAndFeel), the user could include the following line in $JDKHOME/lib/swing.properties:

swing.plaf.multiplexinglaf = com.myco.SuperMultiLookAndFeel

This statement instructs Swing to use com.myco.SuperMultiLookAndFeel instead of javax.swing.plaf.multi.MultiLookAndFeel. But if you use this kind of statement, be careful, because the suppliers of auxiliary look and feels will most likely have developed and tested against our Multiplexing look and feel.


javax.swing.plaf.synth (Java 2 Platform SE 6)

 javax.swing.plaf.synth
接口
SynthConstants
类
ColorType
Region
SynthContext
SynthGraphicsUtils
SynthLookAndFeel
SynthPainter
SynthStyle
SynthStyleFactory


类 javax.swing.plaf.synth.ColorType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.ColorType
的使用

使用 ColorType 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 ColorType 的使用

声明为 ColorType 的 javax.swing.plaf.synth 中的字段
static ColorType | ColorType.BACKGROUND 某一 region 背景的 ColorType。
static ColorType | ColorType.FOCUS 焦点的 ColorType。
static ColorType | ColorType.FOREGROUND 某一 region 前景的 ColorType。
static ColorType | ColorType.TEXT_BACKGROUND 某一 region 背景的 ColorType。
static ColorType | ColorType.TEXT_FOREGROUND 某一 region 前景的 ColorType。

参数类型为 ColorType 的 javax.swing.plaf.synth 中的方法
Color | SynthStyle.getColor(SynthContext context, ColorType type) 返回指定状态的颜色。
protected abstract Color | SynthStyle.getColorForState(SynthContext context, ColorType type) 返回指定状态的颜色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.synth.Region 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.Region
的使用

使用 Region 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 Region 的使用

声明为 Region 的 javax.swing.plaf.synth 中的字段
static Region | Region.ARROW_BUTTON ArrowButton 是特殊类型的按钮，也呈现了一个方向指示器（通常是一个箭头）。
static Region | Region.BUTTON Button 的 region。
static Region | Region.CHECK_BOX CheckBox 的 region。
static Region | Region.CHECK_BOX_MENU_ITEM CheckBoxMenuItem 的 region。
static Region | Region.COLOR_CHOOSER ColorChooser 的 region。
static Region | Region.COMBO_BOX ComboBox 的 region。
static Region | Region.DESKTOP_ICON DesktopIcon 的 region。
static Region | Region.DESKTOP_PANE DesktopPane 的 region。
static Region | Region.EDITOR_PANE EditorPane 的 region。
static Region | Region.FILE_CHOOSER FileChooser 的 region。
static Region | Region.FORMATTED_TEXT_FIELD FormattedTextField 的 region。
static Region | Region.INTERNAL_FRAME InternalFrame 的 region。
static Region | Region.INTERNAL_FRAME_TITLE_PANE InternalFrame 的 TitlePane。
static Region | Region.LABEL Label 的 region。
static Region | Region.LIST List 的 region。
static Region | Region.MENU Menu 的 region。
static Region | Region.MENU_BAR MenuBar 的 region。
static Region | Region.MENU_ITEM MenuItem 的 region。
static Region | Region.MENU_ITEM_ACCELERATOR MenuItem 的加速器 region。
static Region | Region.OPTION_PANE OptionPane 的 region。
static Region | Region.PANEL Panel 的 region。
static Region | Region.PASSWORD_FIELD PasswordField 的 region。
static Region | Region.POPUP_MENU PopupMenu 的 region。
static Region | Region.POPUP_MENU_SEPARATOR PopupMenuSeparator 的 region。
static Region | Region.PROGRESS_BAR ProgressBar 的 region。
static Region | Region.RADIO_BUTTON RadioButton 的 region。
static Region | Region.RADIO_BUTTON_MENU_ITEM RegionButtonMenuItem 的 region。
static Region | Region.ROOT_PANE RootPane 的 region。
static Region | Region.SCROLL_BAR ScrollBar 的 region。
static Region | Region.SCROLL_BAR_THUMB ScrollBar 的 thumb。
static Region | Region.SCROLL_BAR_TRACK ScrollBar 的滑道。
static Region | Region.SCROLL_PANE ScrollPane 的 region。
static Region | Region.SEPARATOR Separator 的 region。
static Region | Region.SLIDER Slider 的 region。
static Region | Region.SLIDER_THUMB 滑块的 thumb。
static Region | Region.SLIDER_TRACK Slider 的滑道。
static Region | Region.SPINNER Spinner 的 region。
static Region | Region.SPLIT_PANE SplitPane 的 region。
static Region | Region.SPLIT_PANE_DIVIDER SplitPane 的分隔器。
static Region | Region.TABBED_PANE TabbedPane 的 region。
static Region | Region.TABBED_PANE_CONTENT 包含内容的 TabbedPane 的 region。
static Region | Region.TABBED_PANE_TAB 某一选项卡的 TabbedPane 的 region。
static Region | Region.TABBED_PANE_TAB_AREA 包含选项卡的 TabbedPane 的 region。
static Region | Region.TABLE Table 的 region。
static Region | Region.TABLE_HEADER TableHeader 的 region。
static Region | Region.TEXT_AREA TextArea 的 region。
static Region | Region.TEXT_FIELD TextField 的 region。
static Region | Region.TEXT_PANE TextPane 的 region。
static Region | Region.TOGGLE_BUTTON ToggleButton 的 region。
static Region | Region.TOOL_BAR ToolBar 的 region。
static Region | Region.TOOL_BAR_CONTENT 包含内容的 ToolBar 的 region。
static Region | Region.TOOL_BAR_DRAG_WINDOW 包含 ToolBar 的 Window 的 region。
static Region | Region.TOOL_BAR_SEPARATOR ToolBar 分隔器的 region。
static Region | Region.TOOL_TIP ToolTip 的 region。
static Region | Region.TREE Tree 的 region。
static Region | Region.TREE_CELL 用于某一单元格的 Tree 的 region。
static Region | Region.VIEWPORT Viewport 的 region。

返回 Region 的 javax.swing.plaf.synth 中的方法
Region | SynthContext.getRegion() 返回标识此状态的 Region。
static Region | SynthLookAndFeel.getRegion(JComponent c) 返回 JComponent c 的 Region。

参数类型为 Region 的 javax.swing.plaf.synth 中的方法
abstract SynthStyle | SynthStyleFactory.getStyle(JComponent c, Region id) 返回指定 Component 的样式。
static SynthStyle | SynthLookAndFeel.getStyle(JComponent c, Region region) 获取指定组件的指定 region 的 SynthStyle。

参数类型为 Region 的 javax.swing.plaf.synth 中的构造方法
SynthContext(JComponent component, Region region, SynthStyle style, int state)
创建一个具有指定值的 SynthContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.plaf.synth.SynthConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.plaf.synth.SynthConstants
的使用

没有 javax.swing.plaf.synth.SynthConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthContext
的使用

使用 SynthContext 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 SynthContext 的使用

参数类型为 SynthContext 的 javax.swing.plaf.synth 中的方法
int | SynthGraphicsUtils.computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text) 返回传入字符串的大小。
void | SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2) 在两个端点之间绘制一条线。
void | SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey) 在两个端点之间绘制一条线。
Object | SynthStyle.get(SynthContext context, Object key) 某个 region 特定样式属性的获取器。
boolean | SynthStyle.getBoolean(SynthContext context, Object key, boolean defaultValue) 获得其值是一个 Boolean 值的特定样式属性的便捷方法。
Color | SynthStyle.getColor(SynthContext context, ColorType type) 返回指定状态的颜色。
protected abstract Color | SynthStyle.getColorForState(SynthContext context, ColorType type) 返回指定状态的颜色。
Font | SynthStyle.getFont(SynthContext context) 返回指定状态的 Font。
protected abstract Font | SynthStyle.getFontForState(SynthContext context) 返回指定状态的字体。
SynthGraphicsUtils | SynthStyle.getGraphicsUtils(SynthContext context) 返回指定上下文的 SynthGraphicUtils。
Icon | SynthStyle.getIcon(SynthContext context, Object key) 获得其值是一个 Icon 的特定样式属性的便捷方法。
Insets | SynthStyle.getInsets(SynthContext context, Insets insets) 返回用来计算大小调整信息的 Insets。
int | SynthStyle.getInt(SynthContext context, Object key, int defaultValue) 获得值为 Number 的一个特定样式属性的便捷方法。
int | SynthGraphicsUtils.getMaximumCharHeight(SynthContext context) 根据传入的 SynthContext 返回 Font 的最大高度。
Dimension | SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最大大小。
Dimension | SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最小大小。
SynthPainter | SynthStyle.getPainter(SynthContext context) 返回将用于绘制的 SynthPainter。
Dimension | SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的首选大小。
String | SynthStyle.getString(SynthContext context, Object key, String defaultValue) 获得其值是一个 String 值的特定样式属性的便捷方法。
void | SynthStyle.installDefaults(SynthContext context) 在 context 的 JComponent 上根据此 Style 安装必要的状态。
boolean | SynthStyle.isOpaque(SynthContext context) 如果 region 是不透明的，则返回 true。
String | SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap) 根据通过引用返回的放置图标和文本的位置，布局文本和图标。
void | SynthPainter.paintArrowButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制箭头按钮的背景。
void | SynthPainter.paintArrowButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制箭头按钮的边框。
void | SynthPainter.paintArrowButtonForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int direction) 绘制箭头按钮的前景。
void | SynthPainter.paintButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制按钮的背景。
void | SynthPainter.paintButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制按钮的边框。
void | SynthPainter.paintCheckBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框的背景。
void | SynthPainter.paintCheckBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框的边框。
void | SynthPainter.paintCheckBoxMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框菜单项的背景。
void | SynthPainter.paintCheckBoxMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框菜单项的边框。
void | SynthPainter.paintColorChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制颜色选择器的背景。
void | SynthPainter.paintColorChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制颜色选择器的边框。
void | SynthPainter.paintComboBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制组合框的背景。
void | SynthPainter.paintComboBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制组合框的边框。
void | SynthPainter.paintDesktopIconBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面图标的背景。
void | SynthPainter.paintDesktopIconBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面图标的边框。
void | SynthPainter.paintDesktopPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面窗格的背景。
void | SynthPainter.paintDesktopPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面窗格的边框。
void | SynthPainter.paintEditorPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制编辑器窗格的背景。
void | SynthPainter.paintEditorPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制编辑器窗格的边框。
void | SynthPainter.paintFileChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文件选择器的背景。
void | SynthPainter.paintFileChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文件选择器的边框。
void | SynthPainter.paintFormattedTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制已格式化文本字段的背景。
void | SynthPainter.paintFormattedTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制已格式化文本字段的边框。
void | SynthPainter.paintInternalFrameBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体的背景。
void | SynthPainter.paintInternalFrameBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体的边框。
void | SynthPainter.paintInternalFrameTitlePaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体标题窗格的背景。
void | SynthPainter.paintInternalFrameTitlePaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体标题窗格的边框。
void | SynthPainter.paintLabelBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制标签的背景。
void | SynthPainter.paintLabelBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制标签的边框。
void | SynthPainter.paintListBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制列表的背景。
void | SynthPainter.paintListBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制列表的边框。
void | SynthPainter.paintMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单的背景。
void | SynthPainter.paintMenuBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单栏的背景。
void | SynthPainter.paintMenuBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单栏的边框。
void | SynthPainter.paintMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单的边框。
void | SynthPainter.paintMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单项的背景。
void | SynthPainter.paintMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单项的边框。
void | SynthPainter.paintOptionPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项窗格的背景。
void | SynthPainter.paintOptionPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项窗格的边框。
void | SynthPainter.paintPanelBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制面板的背景。
void | SynthPainter.paintPanelBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制面板的边框。
void | SynthPainter.paintPasswordFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制密码字段的背景。
void | SynthPainter.paintPasswordFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制密码字段的边框。
void | SynthPainter.paintPopupMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制弹出菜单的背景。
void | SynthPainter.paintPopupMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制弹出菜单的边框。
void | SynthPainter.paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制进度条的背景。
void | SynthPainter.paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的背景。
void | SynthPainter.paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制进度条的边框。
void | SynthPainter.paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的边框。
void | SynthPainter.paintProgressBarForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的前景。
void | SynthPainter.paintRadioButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮的背景。
void | SynthPainter.paintRadioButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮的边框。
void | SynthPainter.paintRadioButtonMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮菜单项的背景。
void | SynthPainter.paintRadioButtonMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮菜单项的边框。
void | SynthPainter.paintRootPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制根窗体的背景。
void | SynthPainter.paintRootPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制根窗体的边框。
void | SynthPainter.paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条的背景。
void | SynthPainter.paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的背景。
void | SynthPainter.paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条的边框。
void | SynthPainter.paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的边框。
void | SynthPainter.paintScrollBarThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的 thumb 的背景。
void | SynthPainter.paintScrollBarThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的 thumb 的边框。
void | SynthPainter.paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条滑道的背景。
void | SynthPainter.paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条滑道的背景。
void | SynthPainter.paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条滑道的边框。
void | SynthPainter.paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条滑道的边框。
void | SynthPainter.paintScrollPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动窗格的背景。
void | SynthPainter.paintScrollPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动窗格的边框。
void | SynthPainter.paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔符的背景。
void | SynthPainter.paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的背景。
void | SynthPainter.paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔符的边框。
void | SynthPainter.paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的边框。
void | SynthPainter.paintSeparatorForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的前景。
void | SynthPainter.paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的背景。
void | SynthPainter.paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的背景。
void | SynthPainter.paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的边框。
void | SynthPainter.paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的边框。
void | SynthPainter.paintSliderThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的 thumb 的背景。
void | SynthPainter.paintSliderThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的 thumb 的边框。
void | SynthPainter.paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的滑道的背景。
void | SynthPainter.paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的滑道的背景。
void | SynthPainter.paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的滑道的边框。
void | SynthPainter.paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的滑道的边框。
void | SynthPainter.paintSpinnerBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制 spinner 的背景。
void | SynthPainter.paintSpinnerBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制 spinner 的边框。
void | SynthPainter.paintSplitPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的背景。
void | SynthPainter.paintSplitPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的边框。
void | SynthPainter.paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的分隔栏的背景。
void | SynthPainter.paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔窗格的分隔栏的背景。
void | SynthPainter.paintSplitPaneDividerForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔窗格的分隔栏的前景。
void | SynthPainter.paintSplitPaneDragDivider(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 当用户拖动分隔符时，绘制分隔窗格的分隔栏。
void | SynthPainter.paintTabbedPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的背景。
void | SynthPainter.paintTabbedPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的边框。
void | SynthPainter.paintTabbedPaneContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含选项卡窗格中所选选项卡内容的区域的背景。
void | SynthPainter.paintTabbedPaneContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含选项卡窗格中所选选项卡内容的区域的边框。
void | SynthPainter.paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的选项卡背后区域的背景。
void | SynthPainter.paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制选项卡窗格的选项卡背后区域的背景。
void | SynthPainter.paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的选项卡背后区域的边框。
void | SynthPainter.paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制选项卡窗格的选项卡背后区域的边框。
void | SynthPainter.paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex) 绘制选项卡窗格的选项卡的背景。
void | SynthPainter.paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation) 绘制选项卡窗格的选项卡的背景。
void | SynthPainter.paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex) 绘制选项卡窗格的选项卡的边框。
void | SynthPainter.paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation) 绘制选项卡窗格的选项卡的边框。
void | SynthPainter.paintTableBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表的背景。
void | SynthPainter.paintTableBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表的边框。
void | SynthPainter.paintTableHeaderBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表标题的背景。
void | SynthPainter.paintTableHeaderBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表标题的边框。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset) 绘制图标和文本。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex) 在指定位置上绘制文本。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex) 在指定位置上绘制文本。
void | SynthPainter.paintTextAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本区域的背景。
void | SynthPainter.paintTextAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本区域的边框。
void | SynthPainter.paintTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本字段的背景。
void | SynthPainter.paintTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本字段的边框。
void | SynthPainter.paintTextPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本窗格的背景。
void | SynthPainter.paintTextPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本窗格的边框。
void | SynthPainter.paintToggleButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制切换按钮的背景。
void | SynthPainter.paintToggleButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制切换按钮的边框。
void | SynthPainter.paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏的背景。
void | SynthPainter.paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏的背景。
void | SynthPainter.paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏的边框。
void | SynthPainter.paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏的边框。
void | SynthPainter.paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏内容区的背景。
void | SynthPainter.paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏内容区的背景。
void | SynthPainter.paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏内容区的边框。
void | SynthPainter.paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏内容区的边框。
void | SynthPainter.paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
void | SynthPainter.paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
void | SynthPainter.paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
void | SynthPainter.paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
void | SynthPainter.paintToolTipBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具提示的背景。
void | SynthPainter.paintToolTipBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具提示的边框。
void | SynthPainter.paintTreeBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制树的背景。
void | SynthPainter.paintTreeBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制树的边框。
void | SynthPainter.paintTreeCellBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含树中某个单元格的行的背景。
void | SynthPainter.paintTreeCellBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含树中某个单元格的行的边框。
void | SynthPainter.paintTreeCellFocus(SynthContext context, Graphics g, int x, int y, int w, int h) 当树中某个单元格拥有焦点时，绘制该单元格的焦点指示器。
void | SynthPainter.paintViewportBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制视口的背景。
void | SynthPainter.paintViewportBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制视口的边框。
void | SynthStyle.uninstallDefaults(SynthContext context) 卸载此样式在 context 的 JComponent 上安装的任何状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthGraphicsUtils 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthGraphicsUtils
的使用

使用 SynthGraphicsUtils 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 SynthGraphicsUtils 的使用

返回 SynthGraphicsUtils 的 javax.swing.plaf.synth 中的方法
 SynthGraphicsUtils SynthStyle.getGraphicsUtils(SynthContext context)
返回指定上下文的 SynthGraphicUtils。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthLookAndFeel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthLookAndFeel
的使用

没有 javax.swing.plaf.synth.SynthLookAndFeel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthPainter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthPainter
的使用

使用 SynthPainter 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 SynthPainter 的使用

返回 SynthPainter 的 javax.swing.plaf.synth 中的方法
 SynthPainter SynthStyle.getPainter(SynthContext context)
返回将用于绘制的 SynthPainter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthStyle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthStyle
的使用

使用 SynthStyle 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 SynthStyle 的使用

返回 SynthStyle 的 javax.swing.plaf.synth 中的方法
SynthStyle | SynthContext.getStyle() 返回与此 Region 相关的样式。
abstract SynthStyle | SynthStyleFactory.getStyle(JComponent c, Region id) 返回指定 Component 的样式。
static SynthStyle | SynthLookAndFeel.getStyle(JComponent c, Region region) 获取指定组件的指定 region 的 SynthStyle。

参数类型为 SynthStyle 的 javax.swing.plaf.synth 中的构造方法
SynthContext(JComponent component, Region region, SynthStyle style, int state)
创建一个具有指定值的 SynthContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthStyleFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthStyleFactory
的使用

使用 SynthStyleFactory 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 SynthStyleFactory 的使用

返回 SynthStyleFactory 的 javax.swing.plaf.synth 中的方法
static SynthStyleFactory SynthLookAndFeel.getStyleFactory()
返回当前 SynthStyleFactory。

参数类型为 SynthStyleFactory 的 javax.swing.plaf.synth 中的方法
static void SynthLookAndFeel.setStyleFactory(SynthStyleFactory cache)
设置 SynthStyleFactory，由 synth 提供的 UI 类将使用它来获取 SynthStyle。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


Component Specific Properties

The look, and to some degree the feel of Synth can be customized by way of component specific properties. These properties are accessed from SynthStyle#get. Refer to synth file format for examples of how to specify these properties in a synth configuration file.

This file specifies the expected class type each of the values are to take. The behavior of supplying the wrong type is unspecified: typically a ClassCastException is thrown, but it is implementation specific.

ArrowButton

ArrowButton is a special type of JButton that renders an arrow. ArrowButton is typically not created directly, rather some of the Components will create it to render a button with an arrow. The components that make use of ArrowButton are: JComboBox, JScrollBar and JSplitPane (for the buttons on the divider). In addition to the Button properties, ArrowButton supports the following propeties:

ArrowButton Specific Properties
Property | Expected Type | Default Value | Description
ArrowButton.size | Integer | 16 | Preferred size of the arrow button.

JButton

JButton paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JButton supports the following property:

JButton Specific Properties
Property | Expected Type | Default Value | Description
Button.defaultButtonFollowsFocus | Boolean | true | Whether or not the default JButton should change to the button that is receiving focus.

JCheckBox

JCheckBox paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JCheckBox supports the following property:

JCheckBox Specific Properties
Property | Expected Type | Default Value | Description
CheckBox.icon | Icon | null | Icon used to render the check.

JComboBox

JComboBox is a composite component that consists of the following child Components:

Name | Type | Description
ComboBox.arrowButton | SynthArrowButton | Renders the drop down indicator.
ComboBox.list | JList | JList used to render the values.
ComboBox.listRenderer | Component | The renderer used for the JComboBox's JList.
ComboBox.popup | JPopupMenu | JPopupMenu used to show the ComboBox.list of the JComboBox.
ComboBox.renderer | Component | The renderer used for the JComboBox. This is ONLY set if the renderer is a UIResource.
ComboBox.scrollPane | JScrollPane | JScrollPane containing the JList.
ComboBox.textField | JTextField | The editor.

JComboBox Specific Properties
Property | Expected Type | Default Value | Description
ComboBox.showPopupOnNavigation | Boolean | false | Whether or not the JPopupMenu should appear when navigating with the keyboard.

JFileChooser

JFileChooser Specific Properties
Property | Expected Type | Default Value | Description
FileChooser.cancelIcon | Icon | null | Icon displayed on cancel button of the file chooser.
FileChooser.okIcon | Icon | null | Icon displayed on the ok button of the file chooser.
FileView.directoryIcon | Icon | null | Icon used for directories.
FileView.fileIcon | Icon | null | Icon used for files.
FileView.computerIcon | Icon | null | Icon used for directories that represent the computer. Not all platforms will make use of this icon.
FileView.hardDriveIcon | Icon | null | Icon used to represent the root of a hard drive. For example, on Windows this would be used when viewing the C drive.
FileView.floppyDriveIcon | Icon | null | Icon used to represent a floppy disk.
FileChooser.newFolderIcon | Icon | null | Icon used by the button that creates a new folder.
FileChooser.upFolderIcon | Icon | null | Icon used by the button that navigates to the parent folder.
FileChooser.homeFolderIcon | Icon | null | Icon used by the button that navigates to the current user's home directory.
FileChooser.detailsViewIcon | Icon | null | Icon used by the button that toggles the detailed files list view.
FileChooser.listViewIcon | Icon | null | Icon used by the button that toggles the regular files list view, showing only an icon and the name of each file and directory.

JInternalFrame

JInternalFrame Specific Properties
Property | Expected Type | DefaultValue | Description
InternalFrame.icon | Icon | null | Icon drawn representing the system icon of the internal frame. If pressed the system menu will be shown.

JInternalFrameTitlePane

JInternalFrameTitlePane is the control bar located at the top of the internal frame similar to that found in a frame.

JInternalFrameTitlePane Specific Properties
Property | Expected Type | Default Value | Description
InternalFrameTitlePane.maximizeIcon | Icon | null | Icon drawn to indicate the ability to maximize the internal frame.
InternalFrameTitlePane.minimizeIcon | Icon | null | Icon drawn to indicate the ability to restore the internal frame back to its previous state.
InternalFrameTitlePane.iconifyIcon | Icon | null | Icon drawn to indicate the ability to minimize the internal frame.
InternalFrameTitlePane.closeIcon | Icon | null | Icon drawn to indicate the abililty to close the internal frame.
InternalFrameTitlePane.titleSpacing | Integer | 2 | Space between the buttons on the title pane and the title.
InternalFrameTitlePane.buttonSpacing | Integer | 2 | Space between the buttons on the title pane.
InternalFrameTitlePane.maxFrameIconSize | Dimension | 16x16 | Maximum size of the frame icon that will be rendered on the title pane. If the icon is bigger than this size, it will be scaled down.
InternalFrameTitlePane.titleAlignment | leading|trailing|center | leading | Alignment for the title. With a left to right component orientation leading is left and trailing right. With a right to left component orientation leading is right and trailing left.

JList

JList's sets the name of the renderer to List.renderer. JList supports the following properties:

JList Specific Properties
Property | Expected Type | Default Value | Description
List.rendererUseListColors | Boolean | true | If true the renderers state is not updated, and the text colors come from JList's getSelectionBackground and getSelectionForeground methods. If false, the renderer's state is updated and the colors will instead come from the Style.
List.rendererUseUIBorder | Boolean | true | If true setBorder on the renderer will succeed regardless of the border passed in, otherwise setBorder on the renderer will only succeed if it is a Synth Border.
List.cellHeight | Integer | -1 | Cell height of the JList. Is this is -1, setFixedCellHeight is not invoked.

Menu Properties

The Menu classes (JCheckBoxMenuItem, JMenu, JMenuItem, and JRadioButtonMenuItem) all support the same set of properties and behave similarly. Each component consists of two Regions: the region specific to the component and Region.MENU_ITEM_ACCELERATOR. MENU_ITEM_ACCELERATOR is used for painting the accelerator. Both Regions paint text using the TEXT_FOREGROUND ColorType. The following set of properties are supported:

Property | Expected Type | Default Value | Description
prefix.acceleratorDelimiter | String | + | String separator between the description of the modifiers and the key, for example Ctrl <acceleratorDelimiter> X.
prefix.arrowIcon | Icon | null | Icon drawn to the right of the text (or left when the ComponentOrientation is right to left) of the text. This is typically only defined for JMenu.
prefix.checkIcon | Icon | null | Icon drawn to the left of the text (or right when the ComponentOrientation is right to left) of the text. This is typically only defined for JCheckBoxMenuItem and JRadioButtonMenuItem to provide the check or radio button.
prefix.margin | Insets | Empty Insets (0, 0, 0, 0) | Margin for the JMenuItem. Refer to the javadoc of javax.swing.AbstractButton#setMargin(java.awt.Insets) for details of how the margin is used.
prefix.textIconGap | Integer | 4 | Padding between the icon and text. Refer to the javadoc for javax.swing.AbstractButton#setIconTextGap(int) for details of how this is used.

Prefix is one of: CheckBoxMenuItem, Menu, MenuItem, or RadioButtonMenuItem.

JMenu also supports the following properties:

Property | Expected Type | Default Value | Description
Menu.delay | Integer | 200 | Sets the delay before the menu appears.
Menu.shortcutKeys | int[] | KeyEvent.ALT_MASK | Array of the KeyEvent modifiers to use for shortcut keys.

JOptionPane

JOptionPane is a composite component and may consist of numerous child components, they are: OptionPane.button, OptionPane.label, OptionPane.comboBox, OptionPane.scrollPane, OptionPane.list, OptionPane.textField, OptionPane.iconLabel.

JOptionPane Specific Properties
Property | Expected Type | Default Value | Description
OptionPane.buttonAreaBorder | Border | null | Border around the button area.
OptionPane.buttonClickThreshhold | Integer | 0 | Passed to the created buttons setMultiClickThreshhold.
OptionPane.buttonOrientation | Integer | SwingConstants.CENTER | How the buttons should be layed out, one of SwingConstants.LEFT, SwingConstants.RIGHT or SwingConstants.CENTER (this will be flipped when in a right to left locale).
OptionPane.buttonPadding | Integer | 6 | Amount of space between buttons.
OptionPane.cancelIcon | Icon | null | Icon for the cancel button.
OptionPane.errorIcon | Icon | null | Icon used for ERROR_MESSAGE.
OptionPane.informationIcon | Icon | null | Icon used for INFORMATION_MESSAGE.
OptionPane.isYesLast | Boolean | false | If true the 'yes' button leads other buttons, otherwise it follows the other buttons.
OptionPane.questionIcon | Icon | null | Icon used for error QUESTION_MESSAGE.
OptionPane.minimumSize | Dimension | 262x90 | Minimum size for the JOptionPane.
OptionPane.noIcon | Icon | null | Icon for the no button.
OptionPane.okIcon | Icon | null | Icon for the ok button.
OptionPane.sameSizeButtons | Boolean | true | Whether or not all the buttons should be the same size.
OptionPane.separatorPadding | Integer | 6 | Amount of padding between the message area and separator.
OptionPane.yesIcon | Icon | null | Icon for the yes button.
OptionPane.warningIcon | Icon | null | Icon used for error WARNING_MESSAGE

JProgressBar

JProgressBar Specific Properties
Property | Expected Type | Default Value | Description
ProgressBar.repaintInterval | Integer | 50 | Number of milliseconds between repaints for indeterminate progress bars.
ProgressBar.cycleTime | Integer | 3000 | Number of milliseconds used to determine how far to move the bouncing box per frame when the progress bar is indeterminate.

JRadioButton

JRadioButton paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JRadioButton supports the following property:

JRadioButton Specific Properties
Property | Expected Type | Default Value | Description
RadioButton.icon | Icon | null | Icon used to render the radio indicator.

JScrollBar

JScrollBar is a composite component that consists of the following child Components:

Name | Type | Description
ScrollBar.button | SynthArrowButton | Identifies the increment/decrement buttons.

JScrollBar Specific Properties
Property | Expected Type | Default Value | Description
ScrollBar.allowsAbsolutePositioning | Boolean | false | If true, middle mouse click in the track will set the position of the track to where the mouse is.
ScrollBar.maximumThumbSize | Dimension | 4096x4096 | Maximum thumb size.
ScrollBar.minimumThumbSize | Dimension | Derived from ScrollBar.thumbHeight | The minimum thumb size. If this is not specified the minimum thumb size is ScrollBar.thumbHeight plus the insets of the scrollbar along the opposite axis of the scrollbar and 7 along the other axis. For example, if you have not specified Insets for a scrollbar, and the orientation of the scrollbar is vertical, than the minimum thumb size width is ScrollBar.thumbHeight with a height of 7.
ScrollBar.squareButtons | Boolean | false | If true, the width and height of the scrollbar buttons will be made equal.
ScrollBar.thumbHeight | Integer | 14 | The preferred height, when the orientation of the scrollbar is horizontal, or preferred width when the orientation of the scrollbar is vertical.

Separators

All of the separator classes, JSeparator, JPopupMenu.Separator and JToolBar.Separator use the same property:

Property | Expected Type | Default Value | Description
Separator.thickness | Integer | 2 | Preferred width, for vertically aligned separators, or preferred height for horizontally aligned separators. The resulting preferred size will include the Insets.

JToolBar.Separator also supports the following property:

Property | Expected Type | Default Value | Description
ToolBar.separatorSize | Dimension | null | The value of this is passed to the javax.swing.JToolBar$Separator#setSeparatorSize(java.awt.Dimension) method. If unspecified setSeparatorSize is not invoked.

JScrollPane

JScrollPane is unique in that it provides a method for setting the Border around the JViewport with JViewport throwing an IllegalArgumentException from setBorder. To accomodate this a special border is installed on the JScrollPane that uses the insets from the key ScrollPane.viewportBorderInsets. The SynthPainter method paintViewportBorder is called to paint the Viewports border.

JScrollPane Specific Properties
Property | Expected Type | Default Value | Description
ScrollPane.viewportBorderInsets | Insets | null | Insets for the viewport Border.

JSplitPane

JSplitPane is a composite component that will contain a divider and potentially two buttons, if setOneTouchExpandable(true) has been invoked. The two buttons will be named: SplitPaneDivider.leftOneTouchButton and SplitPaneDivider.rightOneTouchButton.

JSplitPane Specific Properties
Property | Expected Type | Default Value | Description
SplitPane.centerOneTouchButtons | Boolean | true | If true, the one touch buttons are centered on the divider.
SplitPane.oneTouchButtonOffset | Integer | 2 | Distance between the one touch buttons.
SplitPane.oneTouchButtonSize | Integer | 6 | Size to make the one touch buttons.
SplitPane.oneTouchExpandable | Boolean | null | If non null, the value of this is passed to setOneTouchExpandable.
SplitPane.size | Integer | 6 | Size of the divider

JSlider

JSlider Specific Properties
Property | Expected Type | Default Value | Description
Slider.thumbWidth | Integer | 30 | Width of the slider thumb
Slider.thumbHeight | Integer | 14 | Height of the slider thumb
Slider.trackBorder | Integer | 1 | Width of the track border
Slider.paintValue | Boolean | true | Whether or not to paint the current value of the slider.

JTabbedPane

JTabbedPane Specific Properties
Property | Expected Type | Default Value | Description
TabbedPane.tabRunOverlay | Integer | 0 | Number of pixels to overlap tabs when there is more than one row.
TabbedPane.textIconGap | Integer | 0 | Padding added between the icon and text on a tab. If there is no text or icon this value is not used.
TabbedPane.selectedTabPadInsets | Insets | Empty Insets (0, 0, 0, 0) | Extra insets added to the selected tab.
TabbedPane.selectionFollowsFocus | Boolean | true | If true the selection of the tabbed pane changes as the user navigates the tabs with a mouse.

JTable

JTable sets the name of the renderer to Table.cellRenderer. JTable supports the following properties:

JTable Specific Properties
Property | Expected Type | Default Value | Description
Table.gridColor | Color | null | Color used for the grid. If null the foreground from the style is used.
Table.rendererUseTableColors | Boolean | true | If true the renderers state is not updated, and the text colors come from JTable's getSelectionBackground and getSelectionForeground methods. If false, the renderer's state is updated and the colors will instead come from the Style.
Table.rendererUseUIBorder | Boolean | true | If true setBorder on the renderer will succeed regardless of the border passed in, otherwise setBorder on the renderer will only succeed if it is a Synth Border.
Table.rowHeight | Integer | -1 | If not -1 setRowHeight is invoked on the JTable.

JTree

JTree sets the name of the renderer to Tree.renderer, the name of the editor is Tree.cellEditor.

JTree Specific Properties
Property | Expected Type | Default Value | Description
Tree.collapsedIcon | Icon | null | Icon to use when a node is collapsed.
Tree.drawHorizontalLines | Boolean | true | If true nodes have a horizontal connecting them to the leading edge of their parent.
Tree.drawVerticalLines | Boolean | true | If true a vertical line is drawn down from expanded nodes.
Tree.expandedIcon | Icon | null | Icon to use when a node has been expanded.
Tree.leftChildIndent | Integer | 0 | This plus Tree.rightChildIndent account for the total space, along the y axis, to offset nodes from their parent.
Tree.rightChildIndent | Integer | 0 | This plus Tree.leftChildIndent account for the total space, along the y axis, to offset nodes from their parent.
Tree.rowHeight | Integer | -1 | Row height for the Tree.
Tree.scrollsHorizontallyAndVertically | Boolean | false | If false and scrolling needs to happen to accomodate cells it will only happen along the vertical axis, if true, scrolling may happen along both the horizontal and vertical axis.
Tree.scrollsOnExpand | Boolean | true | Whether or not the JTree should scroll when a node is expanded.
Tree.linesStyle | String |  | The styles of the lines in the tree. Synth supports solid lines (empty value) and dashed lines ("dashed" value). It is possible to add new styles by creating a new SynthGraphicsUtils and binding it to the tree.

JToggleButton

JToggleButton paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JToggleButton supports the following property:

JToggleButton Specific Properties
Property | Expected Type | Default Value | Description
ToggleButton.icon | Icon | null | Icon used to render the radio indicator.

Button Properties

Each of the Button classes (JButton, JCheckBox, JRadioButton, JToggleButton and SynthArrowButton) support a similar set of properties. These properties are:

Property | Expected Type | Default Value | Description
prefix.contentAreaFilled | Integer | true | Refer to the javadoc of javax.swing.AbstractButton#contentAreaFilled(boolean) for details of how this is used. It is up to the Painter to properly honor this property.
prefix.iconTextGap | Integer | If unspecified, JButton.setIconTextGap is not invoked. | Padding between the icon and text. Refer to the javadoc of javax.swing.AbstractButton#setIconTextGap(int) for details of how this is used.
prefix.margin | Insets | Empty Insets (0, 0, 0, 0) | Margin for the JButton. Refer to the javadoc of javax.swing.AbstractButton#setMargin(java.awt.Insets) for details of how the margin is used.
prefix.textShiftOffset | Integer | 0 | Amount to shift the text and icon, along the x and y axis, from where it would normally be layed out. This is only used when the button is in a pressed state and does not have a pressed icon.

Prefix is one of: Button, CheckBox, RadioButton or JToggleButton.

Text Properties

Property | Expected Type | Default Value | Description
prefix.caretForeground | Color | #000000 | Color of the caret.
prefix.margin | Insets | Empty Insets (0, 0, 0, 0), EditorPane and TextPane (3, 3, 3, 3) | Margins of the text component.
prefix.caretBlinkRate | Integer | 500 | Number of milliseconds defining the blink rate fo the caret.

Prefix is one of: EditorPane, FormattedTextField, PasswordField, TextArea, TextField or TextPane.


Synth File Format

File Format

Synth's file format (dtd) allows for specifying all the pieces necessary to create your own look and feel. A synth file is loaded by way of the SynthLookAndFeel.load(InputStream, Class) or SynthLookAndFeel.load(URL) methods. The following example uses the load method to configure a SynthLookAndFeel and sets it as the current look and feel:

  SynthLookAndFeel laf = new SynthLookAndFeel();
  laf.load(MyClass.class.getResourceAsStream("laf.xml"), MyClass.class);
  UIManager.setLookAndFeel(laf);

This example loads the look and feel from an input stream, using the specified class as the resource base to resolve paths. It is also possible to load a look and feel from an arbitrary URL as in the following example.

  SynthLookAndFeel laf = new SynthLookAndFeel();
  laf.load(new URL("file:///C:/java/synth/laf/laf.xml"));
  UIManager.setLookAndFeel(laf);

The method SynthLookAndFeel.load(URL) can be used, for instance, to load a look and feel from any of the following:

  • File, e.g. file:///C:/java/synth/laf/laf.xml
  • Web server, e.g. http://host/laf.xml
  • JAR file, e.g. jar:file:///C:/synth-laf.jar!/laf.xml
  • Remote JAR file, e.g. jar:http://host/synth-laf.jar!/laf.xml

While the DTD for synth is specified, the parser is not validating. Parsing will fail only if a necessary attribute is not specified, or of the wrong type.

The synth element

<!ELEMENT synth ((%beansPersistance;) | style | bind | font | color |
                 imagePainter | imageIcon | defaultsProperty)*>
<!ATTLIST synth
          version              CDATA          #IMPLIED
>

Attribute definitions

version
File format version, should be 1

The synth element contains all the other elements that make up a SynthLookAndFeel definition.

The style element

<!ELEMENT style (property | defaultsProperty | state | font | graphicsUtils |
                 insets | painter | imagePainter | opaque | (%beansPersistance;) |
                 imageIcon)*>
<!ATTLIST style
          id              ID          #IMPLIED
          clone           IDREF       #IMPLIED
>

Attribute definitions

id
Unique identifier for the style.
clone
Identifier of a previously defined style that is copied and used for the new style. This provides a conveniant mechanism for overriding only a portion of an existing style.

A style element corresponds to a SynthStyle, with the child elements specifying properties that apply to all states or state elements which contain properties specific to a particular state. The following example creates an opaque style with the id button, insets of 4, 4, 4, 4 and a font of Dialog 12.

<style id="button">
  <opaque value="true"/>
  <insets top="4" left="4" right="4" bottom="4"/>
  <font name="Dialog" size="12"/>
</style>

The following example creates a new style with an id of clonedButton that is a copy of the style with id button and has a font of Dialog, 14. The resulting style will be opaque, have insets of 4, 4, 4, 4 and a font of Dialog 14.

<style id="clonedButton" clone="button">
  <font name="Dialog" size="14"/>
</style>

The state element

<!ELEMENT state (color | font | painter | imagePainter | (%beansPersistance;) |
                 property |  imageIcon)*>
<!ATTLIST state
          id              ID             #IMPLIED
          clone           IDREF          #IMPLIED
          value           CDATA          #IMPLIED
          idref           IDREF          #IMPLIED
>

Attribute definitions

id
Unique identifier for the state.
clone
Identifier of a previously defined state that is copied and used for the new state.
value
Identifies the state of the Component the properties are to apply to. This is a list of: ENABLED, MOUSE_OVER, PRESSED, DISABLED, FOCUSED, SELECTED or DEFAULT. Multiple states should be separated by 'and.' If you do not specify a value, the contents apply to all states.
idref
Indicates this state should be the same as a previously defined state. This is useful for multiple styles that wish to share the same visual properties for a particular state.

The state element specifies the visual properties that are to be used for a particular state of a component. For example, you could specify the background color when the Component is enabled should look different than the background color when the component is disabled. Not all Components support all states. For example, a Panel only supports the states ENABLED and DISABLED.

The following example creates a state with a red background that will be used when the component is in an a selected and pressed state:

<state value="SELECTED AND PRESSED">
  <color value="RED" type="BACKGROUND"/>
</state>

The state with the most individual matches will be chosen. For example, the following defines two states:

<state value="SELECTED and PRESSED" id="one">
  <color value="RED" type="BACKGROUND"/>
</state>
<state value="SELECTED" id="two">
  <color value="RED" type="BACKGROUND"/>
</state>

State one is used when the Component is SELECTED and PRESSED, and state two when the Component is SELECTED. If the state of the Component contains at least SELECTED and PRESSED, state one will be chosen, otherwise if the state is SELECTED, but not does not contain PRESSED, state two will be used.

The font element

<!ELEMENT font EMPTY>
<!ATTLIST font
          id              ID             #IMPLIED
          clone           IDREF          #IMPLIED
          name            CDATA          #IMPLIED
          style           CDATA          #IMPLIED
          size            CDATA          #IMPLIED
>

Attribute definitions

id
Unique identifier for the Font.
idref
Identifier of a previously defined font.
name
Name of the font.
style
Style of the font. This is a list of the styles defined by Font separated by spaces: PLAIN, BOLD or ITALIC. If unspecified PLAIN is used.
size
Size of the font, in pixels

Defines the font for the current state, or style. You must specify either an idref or a name and size.

The following example creates a style with a Font of Dialog 12 Bold.

<style id="test">
  <font name="DIALOG" size="12" style="BOLD"/>
</style>

The following example creates a style with a font of Dialog 12 Bold that will be used if the component is ENABLED, otherwise Dialog 12 Italic will be used.

<style id="test">
  <font name="DIALOG" size="12" style="ITALIC"/>
  <state value="ENABLED">
    <font name="DIALOG" size="12" style="BOLD"/>
  </state>
</style>

While you can supply a different font per state, in general widgets will NOT revalidate when the state changes, so that you may run into sizing problems if you try to use a font with a significantly different size for different states.

The color element

<!ELEMENT color EMPTY>
<!ATTLIST color
          id              ID             #IMPLIED
          idref           IDREF          #IMPLIED
          type            CDATA          #IMPLIED
          value           CDATA          #IMPLIED
>

Attribute definitions

id
Unique identifier for the color.
idref
Identifier of a previously defined color.
type
Describes where this color should be used. This is typically one of the constants defined by ColorType: FOREGROUND, BACKGROUND, TEXT_FOREGROUND, TEXT_BACKGROUND or FOCUS. Alternatively you can specify the complete path to a class and field, for example javax.swing.plaf.synth.ColorType.FOREGROUND, this is useful for subclasses of synth that define additional color types.
value
Value for the color. This accepts the following forms.
  • The name of a constant in the Color class, for example RED.
  • A hex value of the form #RRGGBB where RR gives the red component, GG the green component and BB the blue component. You need not specify all color components. For example, #123 is equivalent to #000123.
  • A hex value of the form #ARRGGBB or #AARRGGBB. This is useful for alpha values other than 0xFF. The form #ARRGGBB is equivalent to #0ARRGGBB.

Color defines a color and what portion of the Component it should be applied to. The following example will use a background color of RED when the component is enabled.

<state value="ENABLED">
  <color value="RED" type="BACKGROUND"/>
</state>

The following example will have a red background when the Component is enabled, otherwise blue.

<style id="test">
  <state value="ENABLED">
    <color value="RED" type="BACKGROUND"/>
  </state>
  <state>
    <color value="#00FF00" type="BACKGROUND"/>
  </state>
</style>

The property element

<!ELEMENT property EMPTY>
<!ATTLIST property
          key               CDATA                                             #REQUIRED
          type              (idref|boolean|dimension|insets|integer|string)          "idref"
          value             CDATA                                             #REQUIRED
>

Attribute definitions

key
Name of the property.
type
Indicates the type of the property.
value
Value for the property. For boolean properties this will be be true or false, for integer properties this will be a valid integer, for dimensions this will be the width and height separated by a space, for insets properties this will be the top, left, bottom and right separated by a space and for idref properties this will be the unique id of a previously defined object.

Property elements are used to add key value pairs to a SynthStyle that can be accessed by way of the get method. Many Components use the key value pairs for configuring their visual appearance. Refer to property table for a list of the properties each Component supports. The following creates the properties ScrollBar.allowsAbsolutePositioning, OptionPane.minimumSize, ScrollPane.viewportBorderInsets, Tree.rowHeight and foreground with the values false, a dimensions of 262x90, an insets of 5, 5, 5, 5, the integer 20 and an instance of the class ArrowButtonPainter.

<style id="test">
  <property key="ScrollBar.allowsAbsolutePositioning" type="boolean" value="false"/>
  <property key="OptionPane.minimumSize" type="dimension" value="262 90"/>
  <property key="ScrollPane.viewportBorderInsets" type="insets" value="5 5 5 5"/>
  <property key="Tree.rowHeight" type="integer" value="20"/>
  <object class="ArrowButtonPainter" id="ArrowButtonPainter"/>
  <property key="foreground" type="idref" value="ArrowButtonPainter"/>
</style>

You can also specify properties that are to apply to specific states. Whether or not the property is accessed for each state depends upon how the property is used. For example, the following specifies a default icon and an icon to use while the mouse is over the component.

<style id="test">
  <imageIcon id="defaultIcon" path="resources/myImage.png"/>
  <property key="RadioButton.icon" value="defaultIcon"/>
  <state value="MOUSE_OVER">
    <imageIcon id="mouseOverIcon" path="resources/myMouseOverImage.png"/>
    <property key="RadioButton.icon" value="mouseOverIcon"/>
  </state>
</style>

<!ELEMENT defaultsProperty EMPTY>
<!ATTLIST defaultsProperty
          key               CDATA                                             #REQUIRED
          type              (idref|boolean|dimension|insets|integer|string)   "idref"
          value             CDATA                                             #REQUIRED
>

Attribute definitions

key
Name of the property.
type
Indicates the type of the property.
value
Value for the property. For boolean properties this will be true or false, for integer properties this will be a valid integer, for dimensions this will be the width and height separated by a space, for insets properties this will be the top, left, bottom and right separated by a space and for idref properties this will be the unique id of a previously defined object.

DefaultsProperty elements are used to define properties that will be placed in the UIDefaults table that SynthLookAndFeel supplies to the UIManager. The following assigns the the Color red to the value Table.focusCellForeground.

<style id="test">
  <object class="javax.swing.plaf.ColorUIResource" id="color">
    <int>255</int>
    <int>0</int>
    <int>0</int>
  </object>
  <defaultsProperty key="Table.focusCellForeground" type="idref" value="color"/>
</style>

This value could then be asked by way of UIManager.get("Table.focusCellForeground").

The graphicsUtils element

<!ELEMENT graphicsUtils EMPTY>
<!ATTLIST graphicsUtils
          idref           IDREF             #REQUIRED
>

Attribute definitions

idref
Identifer of a previously defined SynthGraphicsUtils object that is to be used as the SynthGraphicsUtils for the current style.

GraphicsUtils elements are used to define the SynthGraphicsUtils that the current style will use. The following example creates a style with an instance of CustomGraphicsUtils for the SynthGraphicsUtils.

<style id="test">
  <object class="CustomGraphicsUtils" id="graphics"/>
  <graphicsUtils idref="graphics"/>
</style>

The insets element

<!ELEMENT insets EMPTY>
<!ATTLIST insets
          id           ID             #IMPLIED
          idref        IDREF          #IMPLIED
          top          CDATA          #IMPLIED
          bottom       CDATA          #IMPLIED
          left         CDATA          #IMPLIED
          right        CDATA          #IMPLIED
>

Attribute definitions

id
Unique identifier for the Insets.
idref
Identifier of a previously defined Insets.
top
Top component of the Insets.
bottom
Bottom component of the Insets.
left
Left component of the Insets.
right
Right component of the Insets.

Insets elements are used to define the Insets for the current style. The insets will be set on any Components the style is associated with. The following example creates a style with insets of 1, 2, 3, 0.

<style id="test">
  <insets top="1" bottom="2" left="3"/>
</style>

The bind element

<!ELEMENT bind EMPTY>
<!ATTLIST bind
          style        IDREF             #REQUIRED
          type         (name|region)     #REQUIRED
          key          CDATA             #REQUIRED
>

Attribute definitions

style
Unique identifier of a previously defined style.
type
One of name or region. For type name component.getName() is used, otherwise the name of the Region is used.
key
Regular expression applied to the name of the Component, or the name of the Region, depending upon the value of type.

Bind elements specify which Regions a style is to be used for. The following example applies the style test to any Component whose name starts with test.

<style id="test">
  <insets top="1" bottom="2" left="3"/>
</style>
<bind style="test" type="name" key="test.*"/>

Numerous styles may apply to a region, in which case each of the matching styles is merged into a resulting style that is used. Precedence is given to styles defined later in the file. For example, the following defines two styles, a and b. Style a is applied to any component with a name starting with test, and style b is used for button regions.

<style id="a">
  <font name="DIALOG" size="12" style="ITALIC"/>
  <insets top="1" bottom="2" left="3"/>
</style>
<bind style="a" type="name" key="test.*"/>
<style id="b">
  <font name="DIALOG" size="12" style="BOLD"/>
</style>
<bind style="b" type="region" key="button"/>

For a button with the name test this is equivalent to:

<style>
  <font name="DIALOG" size="12" style="BOLD"/>
  <insets top="1" bottom="2" left="3"/>
</style>

Merging happens for states of a style as well.

<style id="a">
  <font name="DIALOG" size="12" style="ITALIC"/>
  <insets top="1" bottom="2" left="3"/>
  <state value="ENABLED">
    <object id="customPainter" class="CustomPainter"/>
    <painter idref="customPainter"/>
  </state>
</style>
<bind style="a" type="name" key="test.*"/>
<style id="b">
  <font name="DIALOG" size="12" style="BOLD"/>
  <state value="ENABLED">
    <font name="Lucida" size="12" style="ITALIC"/>
  </state>
</style>
<bind style="b" type="region" key="button"/>

For a button with the name test this is equivalent to:

<style>
  <font name="DIALOG" size="12" style="BOLD"/>
  <insets top="1" bottom="2" left="3"/>
  <state value="ENABLED">
    <object id="customPainter" class="CustomPainter"/>
    <painter idref="customPainter"/>
    <font name="Lucida" size="12" style="ITALIC"/>
  </state>
</style>

The painter element

<!ELEMENT painter EMPTY>
<!ATTLIST painter
          idref                 IDREF          #IMPLIED
          method                CDATA          #IMPLIED
          direction             (north|south|east|west|top|left|bottom|right|horizontal|vertical|horizontal_split|vertical_split)          #IMPLIED
>

Attribute definitions

idref
Identifier of a previously defined SynthPainter.
method
Identifies the SynthPainter method this is to be used for. The name corresponds to the method name of a paint method in SynthPainter with the paint prefix dropped, the remainder is case insensitive (using the latin1 case folding rules). For example SynthPainter.paintButtonBackground is identified by 'buttonBackground' or 'buttonbackground'. If this is not specified the painter is used for all methods that don't have a a specific painter for them.
direction
Identifies the direction, or orientation, this painter is to be used for. This is only useful for the SynthPainter methods that take a direction or orientation. If this is not specified the painter is used for all directions.

Painter defines a SynthPainter for the current style or the state of the current style. The following example binds an instance of the class MyPainter which must be a SynthPainter to the style test.

<style id="test">
  <object class="MyPainter" id="MyPainter"/>
  <painter idref="MyPainter"/>
</style>

The painter that is used for a particular method and state is determined as follows:

  1. Painter specified for the current state, method and direction.
  2. Painter specified for the current state and method.
  3. Painter specified for the current state.
  4. Painter specified for the style, method and direction.
  5. Painter specified for the style and method.
  6. Painter specified for the style.

Consider the following:

<style id="test">
  <painter idref="fallbackPainter"/>
  <painter idref="styleButtonBackgroundPainter" method="buttonBackground"/>
  <state value="SELECTED">
    <painter idref="stateFallbackPainter"/>
    <painter idref="stateButtonBackgroundPainter" method="buttonBackground"/>
  </state>
</style>

The following outlines which painter will be used for what SynthPainter method:

State | Method | Painter
SELECTED | paintButtonBackground | stateButtonBackgroundPainter
SELECTED | Anything but paintButtonBackground | stateFallbackPainter
Anything but SELECTED | paintButtonBackground | styleButtonBackgroundPainter
Anything but SELECTED | Anything but paintButtonBackground | fallbackPainter

When several identical painters are declared, they are aggregated into a single one. Two painters are identical if their direction and method attributes values are equal. Consider the following:

<style id="panelStyle">
  <imagePainter method="panelBackground" path="red.png" />
  <imagePainter method="panelBackground" path="green.png" />
  <imagePainter method="panelBackground" path="blue.png" />
</style>

These three painters are identical for they use the same method and the same direction (all directions by default). Synth aggregates these painters to create a single one that will paint its children painters in the order of declaration. Hence, Synth will first paint the red picture, then the green one and finally the blue one. Each child painter can be seen as a layer of the aggregate painter.

Painter aggregation, or multi-layering, is very useful to reuse elements. Imagine you want to use an highlight effect on buttons and on selected menu items. With painter aggregation, you just need to create a separate highlighting painter instead of having buttons and menu items painters handle it.

The imagePainter element

<!ELEMENT imagePainter EMPTY>
<!ATTLIST imagePainter
          id                    ID             #IMPLIED
          method                CDATA          #IMPLIED
          direction             (north|south|east|west|top|left|bottom|right|horizontal|vertical|horizontal_split|vertical_split)          #IMPLIED
          path                  CDATA          #REQUIRED
          sourceInsets          CDATA          #IMPLIED
          destinationInsets     CDATA          #IMPLIED
          paintCenter           (true|false)   "true"
          stretch               (true|false)   "true"
          center                (true|false)   "false"
>

Attribute definitions

id
Unique identifier for the imagePainter.
method
Identifies the SynthPainter method this is to be used for. The name corresponds to the method name of a paint method in SynthPainter with the paint prefix dropped, the remainder is case insensitive (using the latin1 case folding rules). For example SynthPainter.paintButtonBackground is identified by 'buttonBackground' or 'buttonbackground'. If this is not specified the painter is used for all methods that don't have a a specific painter for them.
direction
Identifies the direction, or orientation, this image is to be used for. This is only useful for the SynthPainter methods that take a direction or orientation. If this is not specified the image is used for all directions.
path
Path to the image. Path to the image. If SynthLookAndFeel.load is passed a Class this will use the Class method getResource (with with the Class suplied to the load method). If load is passed a URL this will use the URL constructor URL(context, path) to resolve the path.
sourceInsets
Insets on the source image. This is top, left, bottom, right with each component separated by a space.
destinationInsets
Insets of the destination image. This is top, left, bottom, right with each component separated by a space. If not specified the sourceInsets are used.
paintCenter
Whether or not the center of the image should be drawn.
stretch
Whether or not the north, south, east and west components of the resulting image should be scaled or tiled.
center
Whether or not the image is centered.

The ImagePainter element defines a painter for the current style or state that will render using the specified image. ImagePainter offers two distinct rendering modes. The first mode is used to center an image in the space provided. This is commonly used in rendering decorations on top of a widget, for example, to specify an arrow for a scroll button use the center mode. The following example illustrates this:

<style id="test">
  <imagePainter path="resources/myImage.png" center="true"/>
</style>

The second mode is used in scaling an image to fit in the provided space. In this mode sourceInsets is used to specify a border around an image where the north, south, east and west edges of the border are either stretched or tiled (stretch attribute), the four corners of the border drawn in place, and the center is stretched. In this mode you must specify sourceInsets. The following example illustrates an ImagePainter that is using the image MyImage.png and insets of 2 all the way around:

<style id="test">
  <imagePainter path="resources/myImage.png"
                sourceInsets="2 2 2 2"/>
</style>

Refer to the description of the painter element for details as to the precedence in choosing a painter and to understand how identical painters are handled.

The imageIcon element

<!ELEMENT imageIcon EMPTY>
<!ATTLIST imageIcon
          id                    ID             #REQUIRED
          path                  CDATA          #REQUIRED
>

Attribute definitions

id
Unique identifier for the imageIcon.
path
Path to the image. This uses the Class method getResource to resolve the path, with the Class supplied to SynthLookAndFeel.load.

ImageIcon is used to assign an Icon implementation that is wrapping an Image to a unique identifier. This is typically used for properties that take an Icon. The following example binds an ImageIcon to the property RadioButton.icon.

<style id="test">
  <imageIcon id="icon" path="resources/myImage.png"/>
  <property key="RadioButton.icon" value="icon"/>
</style>

The opaque element

<!ELEMENT opaque EMPTY>
<!ATTLIST opaque
          value              (true|false)   "true"
>

Attribute definitions

id
Whether or not the style should be opaque, if unspecified the style is opaque.

The opaque element indicates whether or not any Components the style is associated with are to be made opaque. The painter will be asked to paint regardless of the opacity of the associated Component. The following example creates a style that is not opaque.

<style id="test">
  <opaque value="FALSE">
  <painter idref="painter"/>
</style>

The beansPersistance entity

Beans persistance can be used to embed any Object. This is typically used for embedding your own Painters, but can be used for other arbritrary objects as well. Refer to http://java.sun.com/products/jfc/tsc/articles/persistence3/ for details on beans persistance.

Backing Style

In creating a Synth file it's good practice to create a backing style that is used by all components. This will make sure that any components that do not match a specific style will have a default font, foreground, background and opacity. The following example illustrates this:

<synth>
  <style id="backingStyle">
    <opaque value="true"/>
    <font name="Dialog" size="12"/>
    <state>
      <color value="BLACK" type="BACKGROUND"/>
      <color value="WHITE" type="FOREGROUND"/>
    </state>
  </style>
  <bind style="backingStyle" type="region" key=".*"/>
</synth>


JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
所有已实现的接口：
Accessible, AccessibleComponent
正在封闭类：
JTableHeader.AccessibleJTableHeader
protected class JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
extends AccessibleContext
implements Accessible, AccessibleComponent

此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c, JTableHeader p, JTable t)
构造一个 AccessiblJTableHeaaderEntry
方法摘要
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
void | addPropertyChangeListener(PropertyChangeListener l) 将 PropertyChangeListener 添加到侦听器列表。
boolean | contains(Point p) 检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
AccessibleAction | getAccessibleAction() 获取与此对象关联的可支持一个或多个动作的 AccessibleAction。
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | getAccessibleChild(int i) 返回该对象的指定 Accessible 子级。
int | getAccessibleChildrenCount() 返回该对象的可访问子级数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent。
AccessibleContext | getAccessibleContext() 获取与此对象关联的 AccessibleContext。
String | getAccessibleDescription() 获取此对象的 accessibleDescription 属性。
int | getAccessibleIndexInParent() 获取此对象在其可访问父级中的基于零的索引。
String | getAccessibleName() 获取此对象的 accessibleName 属性。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态集合。
AccessibleText | getAccessibleText() 获取与在显示器上显示文本的此对象关联的 AccessibleText。
AccessibleValue | getAccessibleValue() 获取与此对象关联的支持 Numerical 值的 AccessibleValue。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 获取 Rectangle 对象形式的此对象的边界。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Locale | getLocale() 获取该组件的语言环境。
Point | getLocation() 获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isEnabled() 确定是否已启用该对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定是否正显示对象。
boolean | isVisible() 确定此对象是否可见。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
void | removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表移除 PropertyChangeListener。
void | requestFocus() 请求此对象的焦点。
void | setAccessibleDescription(String s) 设置此对象的可访问描述。
void | setAccessibleName(String s) 设置此对象的可访问的本地化名称。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 设置 Rectangle 对象形式的此对象的边界。
void | setCursor(Cursor c) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置对象相对于父级的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置对象的可见状态。
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleParent, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

public JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c,
                                                                       JTableHeader p,
                                                                       JTable t)
构造一个 AccessiblJTableHeaaderEntry

从以下版本开始：
1.4
方法详细信息

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此对象关联的 AccessibleContext。在此类的 Java Accessibility API 的实现中，返回的是此对象，它充当其本身的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
此对象

getAccessibleName

public String getAccessibleName()
从类 AccessibleContext 复制的描述
获取此对象的 accessibleName 属性。对象的 accessibleName 属性是指定该对象功能的本地化 String。例如，标签和按钮的 accessibleName 属性可以是标签或按钮本身的文本。对于不显示其名称的对象，仍应设置 accessibleName。例如，对于用于输入城市名称的文本字段，在 en_US 语言环境下，accessibleName 可以为 "city"。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
对象的本地化名称；如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

setAccessibleName

public void setAccessibleName(String s)
从类 AccessibleContext 复制的描述
设置此对象的可访问的本地化名称。更改名称将导致激发 ACCESSIBLE_NAME_PROPERTY 属性的 PropertyChangeEvent。

覆盖：
类 AccessibleContext 中的 setAccessibleName
参数：
s - 对象的新本地化名称。
另请参见：
AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleDescription

public String getAccessibleDescription()
从类 AccessibleContext 复制的描述
获取此对象的 accessibleDescription 属性。此对象的 accessibleDescription 属性是描述该对象功能的本地化短语。例如，对于 "Cancel" 按钮，accessibleDescription 可以是 "Ignore changes and close dialog box"（忽略更改并关闭对话框）。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
该对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

setAccessibleDescription

public void setAccessibleDescription(String s)
从类 AccessibleContext 复制的描述
设置此对象的可访问描述。更改名称将导致激发 ACCESSIBLE_DESCRIPTION_PROPERTY 属性的 PropertyChangeEvent。

覆盖：
类 AccessibleContext 中的 setAccessibleDescription
参数：
s - 此对象的新的本地化描述
另请参见：
AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public AccessibleRole getAccessibleRole()
从类 AccessibleContext 复制的描述
获取此对象的职责。对象的职责是此对象的类的一般功能或用途。例如，push 按钮的职责是 AccessibleRole.PUSH_BUTTON。AccessibleRole 中提供了一些职责，组件开发人员可以从一组预定义职责中进行选择。这就使辅助技术能为各种交互的组件子类（例如，对所有充当按钮的组件使用 AccessibleRole.PUSH_BUTTON）以及区分行为各异的子类（例如，复选框 AccessibleRole.CHECK_BOX 和单选框 AccessibleRole.RADIO_BUTTON）提供一致的接口。

注意，AccessibleRole 类也是可扩展的，因此如果预定义的职责集合不充分，则自定义组件的开发人员可以定义他们自己的 AccessibleRole。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
从类 AccessibleContext 复制的描述
获取此对象的状态集合。对象的 AccessibleStateSet 由一组唯一的 AccessibleState 组成。对象的 AccessibleStateSet 中的更改将导致激发 ACCESSIBLE_STATE_PROPERTY 属性的 PropertyChangeEvent。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含对象的当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleStateSet, AccessibleState, AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
从类 AccessibleContext 复制的描述
获取此对象在其可访问父级中的基于零的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
返回此对象在父级中从零开始的索引；如果此对象没有可访问父级，则返回 -1。
另请参见：
AccessibleContext.getAccessibleParent(),
AccessibleContext.getAccessibleChildrenCount(),
AccessibleContext.getAccessibleChild(int)

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
从类 AccessibleContext 复制的描述
返回该对象的可访问子级数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
该对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
从类 AccessibleContext 复制的描述
返回该对象的指定 Accessible 子级。Accessible 对象的 Accessible 子级是从零开始的，因此 Accessible 对象的第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 子级从零开始的索引
返回：
对象的 Accessible 子级
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
从类 AccessibleContext 复制的描述
获取该组件的语言环境。如果该组件没有语言环境，则返回其父级的语言环境。

指定者：
类 AccessibleContext 中的 getLocale
返回：
此组件的语言环境。如果此组件没有语言环境，则返回其父级的语言环境。

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener l)
从类 AccessibleContext 复制的描述
将 PropertyChangeListener 添加到侦听器列表。此侦听器为所有 Accessible 属性注册，并且将在这些属性发生更改时调用。

覆盖：
类 AccessibleContext 中的 addPropertyChangeListener
参数：
l - 要添加的 PropertyChangeListener
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener l)
从类 AccessibleContext 复制的描述
从侦听器列表移除 PropertyChangeListener。此方法移除一个为所有属性注册的 PropertyChangeListener。

覆盖：
类 AccessibleContext 中的 removePropertyChangeListener
参数：
l - 要移除的 PropertyChangeListener

getAccessibleAction

public AccessibleAction getAccessibleAction()
从类 AccessibleContext 复制的描述
获取与此对象关联的可支持一个或多个动作的 AccessibleAction。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
如果受对象支持，则返回 AccessibleAction；否则返回 null
另请参见：
AccessibleAction

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其自身实现 AccessibleComponent 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
此对象
另请参见：
AccessibleComponent

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
从类 AccessibleContext 复制的描述
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
如果受对象支持，则返回 AccessibleSelection；否则返回 null
另请参见：
AccessibleSelection

getAccessibleText

public AccessibleText getAccessibleText()
从类 AccessibleContext 复制的描述
获取与在显示器上显示文本的此对象关联的 AccessibleText。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
如果受对象支持，则返回 AccessibleText；否则返回 null
另请参见：
AccessibleText

getAccessibleValue

public AccessibleValue getAccessibleValue()
从类 AccessibleContext 复制的描述
获取与此对象关联的支持 Numerical 值的 AccessibleValue。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
如果受对象支持，则返回 AccessibleValue；否则返回 null
另请参见：
AccessibleValue

getBackground

public Color getBackground()
从接口 AccessibleComponent 复制的描述
获取此对象的背景色。

指定者：
接口 AccessibleComponent 中的 getBackground
返回：
如果支持的话，返回对象的背景色；否则返回 null
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
从接口 AccessibleComponent 复制的描述
设置此对象的背景色。

指定者：
接口 AccessibleComponent 中的 setBackground
参数：
c - 新的背景 Color
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

getForeground

public Color getForeground()
从接口 AccessibleComponent 复制的描述
获取此对象的前景色。

指定者：
接口 AccessibleComponent 中的 getForeground
返回：
如果支持的话，返回对象的前景色；否则返回 null
另请参见：
AccessibleComponent.setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
从接口 AccessibleComponent 复制的描述
设置此对象的前景色。

指定者：
接口 AccessibleComponent 中的 setForeground
参数：
c - 新的前景 Color
另请参见：
AccessibleComponent.getForeground()

getCursor

public Cursor getCursor()
从接口 AccessibleComponent 复制的描述
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
返回：
如果支持的话，返回对象的 Cursor；否则返回 null
另请参见：
AccessibleComponent.setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor c)
从接口 AccessibleComponent 复制的描述
设置此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 setCursor
参数：
c - 对象的新 Cursor
另请参见：
AccessibleComponent.getCursor()

getFont

public Font getFont()
从接口 AccessibleComponent 复制的描述
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
返回：
如果支持的话，返回对象的 Font；否则返回 null
另请参见：
AccessibleComponent.setFont(java.awt.Font)

setFont

public void setFont(Font f)
从接口 AccessibleComponent 复制的描述
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
参数：
f - 对象的新 Font
另请参见：
AccessibleComponent.getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
从接口 AccessibleComponent 复制的描述
获取此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
参数：
f - Font
返回：
如果支持的话，返回对象的 FontMetrics；否则返回 null
另请参见：
AccessibleComponent.getFont()

isEnabled

public boolean isEnabled()
从接口 AccessibleComponent 复制的描述
确定是否已启用该对象。启用的对象在其 AccessibleStateSet 中也将具有 AccessibleState.ENABLED 状态设置。

指定者：
接口 AccessibleComponent 中的 isEnabled
返回：
如果已启用对象，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则禁用它
另请参见：
AccessibleComponent.isEnabled()

isVisible

public boolean isVisible()
从接口 AccessibleComponent 复制的描述
确定此对象是否可见。注：这意味着该对象多半是可见的；但是因为包含此对象的对象之一目前不可见，所以可能在屏幕上不显示它。要确定对象是否在屏幕上显示，需要使用 isShowing()。

可见的对象在其 AccessibleStateSet 中也将具有 AccessibleState.VISIBLE 状态设置。

指定者：
接口 AccessibleComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则隐藏它
另请参见：
AccessibleComponent.isVisible()

isShowing

public boolean isShowing()
从接口 AccessibleComponent 复制的描述
确定是否正显示对象。通过检查该对象和祖先的可见性可确定这一点。注：即使该对象被另一对象屏蔽（例如，它是下拉菜单的下级），仍然返回 true。

指定者：
接口 AccessibleComponent 中的 isShowing
返回：
如果正在显示对象，则返回 true；否则，返回 false

contains

public boolean contains(Point p)
从接口 AccessibleComponent 复制的描述
检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。

指定者：
接口 AccessibleComponent 中的 contains
参数：
p - 相对于对象的坐标系统的 Point
返回：
如果对象包含 Point，则返回 true；否则返回 false
另请参见：
AccessibleComponent.getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
从接口 AccessibleComponent 复制的描述
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
返回：
返回对象在屏幕上的位置；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

getLocation

public Point getLocation()
从接口 AccessibleComponent 复制的描述
获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
返回：
Point 的实例，该点表示屏幕坐标空间中对象边界的左上角 ；如果此对象或其父级不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

setLocation

public void setLocation(Point p)
从接口 AccessibleComponent 复制的描述
设置对象相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
AccessibleComponent.getLocation()

getBounds

public Rectangle getBounds()
从接口 AccessibleComponent 复制的描述
获取 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
返回：
返回指示此组件的边界的矩形；如果此对象不在屏幕上，则返回 null。
另请参见：
AccessibleComponent.contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
从接口 AccessibleComponent 复制的描述
设置 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
参数：
r - 指示此组件边界的矩形
另请参见：
AccessibleComponent.getBounds()

getSize

public Dimension getSize()
从接口 AccessibleComponent 复制的描述
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的 height 字段包含此对象的高度，Dimension 对象的 width 字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
从接口 AccessibleComponent 复制的描述
调整此对象，使其具有高度和宽度。

指定者：
接口 AccessibleComponent 中的 setSize
参数：
d - 指定对象新大小的维数。
另请参见：
AccessibleComponent.getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
从接口 AccessibleComponent 复制的描述
返回本地坐标 Point 包含的可访问子级（如果存在）。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
参数：
p - 相对于此对象坐标系统的 point。
返回：
如果存在，则返回指定位置处的 Accessible；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
从接口 AccessibleComponent 复制的描述
返回此对象是否可以接受焦点。可以接受焦点的对象也将具有在其 AccessibleStateSet 中设置的 AccessibleState.FOCUSABLE 状态。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
从接口 AccessibleComponent 复制的描述
请求此对象的焦点。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
另请参见：
AccessibleComponent.isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
添加指定的焦点侦听器，以接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.addFocusListener(java.awt.event.FocusListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


javax.swing.table (Java 2 Platform SE 6)

 javax.swing.table
接口
TableCellEditor
TableCellRenderer
TableColumnModel
TableModel
类
AbstractTableModel
DefaultTableCellRenderer
DefaultTableCellRenderer.UIResource
DefaultTableColumnModel
DefaultTableModel
JTableHeader
TableColumn
TableRowSorter
TableStringConverter


类 javax.swing.table.AbstractTableModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.AbstractTableModel
的使用

使用 AbstractTableModel 的软件包
javax.swing.table 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.table 中 AbstractTableModel 的使用

javax.swing.table 中 AbstractTableModel 的子类
 class DefaultTableModel
这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.table.DefaultTableCellRenderer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.DefaultTableCellRenderer
的使用

使用 DefaultTableCellRenderer 的软件包
javax.swing.table 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.table 中 DefaultTableCellRenderer 的使用

javax.swing.table 中 DefaultTableCellRenderer 的子类
static class DefaultTableCellRenderer.UIResource
DefaultTableCellRenderer 的一个子类，它实现 UIResource。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.table.DefaultTableCellRenderer.UIResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.DefaultTableCellRenderer.UIResource
的使用

没有 javax.swing.table.DefaultTableCellRenderer.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.table.DefaultTableColumnModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.DefaultTableColumnModel
的使用

没有 javax.swing.table.DefaultTableColumnModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.table.DefaultTableModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.DefaultTableModel
的使用

没有 javax.swing.table.DefaultTableModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.table.JTableHeader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.JTableHeader
的使用

使用 JTableHeader 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 JTableHeader 的使用

声明为 JTableHeader 的 javax.swing 中的字段
protected  JTableHeader JTable.tableHeader
表所使用的 TableHeader。

返回 JTableHeader 的 javax.swing 中的方法
protected JTableHeader | JTable.createDefaultTableHeader() 返回默认的表标题对象，它是一个 JTableHeader。
JTableHeader | JTable.getTableHeader() 返回此 JTable 所使用的 tableHeader。

参数类型为 JTableHeader 的 javax.swing 中的方法
 void JTable.setTableHeader(JTableHeader tableHeader)
将此 JTable 所使用的 tableHeader 设置为 newHeader。

javax.swing.plaf.basic 中 JTableHeader 的使用

声明为 JTableHeader 的 javax.swing.plaf.basic 中的字段
protected  JTableHeader BasicTableHeaderUI.header
要将绘制委托给此 UI 的 JTableHeader。

javax.swing.table 中 JTableHeader 的使用

参数类型为 JTableHeader 的 javax.swing.table 中的构造方法
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c, JTableHeader p, JTable t)
构造一个 AccessiblJTableHeaaderEntry

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.table.JTableHeader.AccessibleJTableHeader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.JTableHeader.AccessibleJTableHeader
的使用

没有 javax.swing.table.JTableHeader.AccessibleJTableHeader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
的使用

没有 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.table.TableCellEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.table.TableCellEditor
的使用

使用 TableCellEditor 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableCellEditor 的使用

实现 TableCellEditor 的 javax.swing 中的类
 class DefaultCellEditor
表单元格和树单元格的默认编辑器。

声明为 TableCellEditor 的 javax.swing 中的字段
protected  TableCellEditor JTable.cellEditor
活动单元格编辑器对象，它重写当前单元格占用的屏幕空间，并允许用户更改其内容。

返回 TableCellEditor 的 javax.swing 中的方法
TableCellEditor | JTable.getCellEditor() 返回活动单元格编辑器；如果该表当前没有被编辑，则返回 null。
TableCellEditor | JTable.getCellEditor(int row, int column) 返回适用于由 row 和 column 所指定单元格的编辑器。
TableCellEditor | JTable.getDefaultEditor(Class<?> columnClass) 尚未在 TableColumn 中设置编辑器时，返回要使用的编辑器。

参数类型为 TableCellEditor 的 javax.swing 中的方法
Component | JTable.prepareEditor(TableCellEditor editor, int row, int column) 通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备编辑器。
void | JTable.setCellEditor(TableCellEditor anEditor) 设置活动单元格编辑器。
void | JTable.setDefaultEditor(Class<?> columnClass, TableCellEditor editor) 如果尚未在 TableColumn 中设置编辑器，则设置要使用的默认单元格编辑器。

javax.swing.table 中 TableCellEditor 的使用

声明为 TableCellEditor 的 javax.swing.table 中的字段
protected  TableCellEditor TableColumn.cellEditor
用于编辑列的数据单元格的编辑器。

返回 TableCellEditor 的 javax.swing.table 中的方法
 TableCellEditor TableColumn.getCellEditor()
返回 JTable 用于编辑此列各值的 TableCellEditor。

参数类型为 TableCellEditor 的 javax.swing.table 中的方法
 void TableColumn.setCellEditor(TableCellEditor cellEditor)
设置编辑此列中单元格时所用的编辑器。

参数类型为 TableCellEditor 的 javax.swing.table 中的构造方法
TableColumn(int modelIndex, int width, TableCellRenderer cellRenderer, TableCellEditor cellEditor)
使用指定的模型索引、宽度、单元格渲染器、单元格编辑器创建并初始化 TableColumn 实例；所有 TableColumn 构造方法都委托给此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.table.TableCellRenderer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.table.TableCellRenderer
的使用

使用 TableCellRenderer 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableCellRenderer 的使用

返回 TableCellRenderer 的 javax.swing 中的方法
TableCellRenderer | JTable.getCellRenderer(int row, int column) 返回适于由此行和列所指定单元格的渲染器。
TableCellRenderer | JTable.getDefaultRenderer(Class<?> columnClass) 尚未在 TableColumn 中设置渲染器时，返回要使用的单元格渲染器。

参数类型为 TableCellRenderer 的 javax.swing 中的方法
Component | JTable.prepareRenderer(TableCellRenderer renderer, int row, int column) 通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备渲染器。
void | JTable.setDefaultRenderer(Class<?> columnClass, TableCellRenderer renderer) 如果没有在 TableColumn 中设置渲染器，则设置要使用的默认单元格渲染器。

javax.swing.table 中 TableCellRenderer 的使用

实现 TableCellRenderer 的 javax.swing.table 中的类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。

声明为 TableCellRenderer 的 javax.swing.table 中的字段
protected TableCellRenderer | TableColumn.cellRenderer 用于绘制列的数据单元格的渲染器。
protected TableCellRenderer | TableColumn.headerRenderer 用于绘制列标题的渲染器。

返回 TableCellRenderer 的 javax.swing.table 中的方法
protected TableCellRenderer | TableColumn.createDefaultHeaderRenderer() 从 Java 2 platform v1.3 开始，TableColumn 构造方法不再调用此方法。
protected TableCellRenderer | JTableHeader.createDefaultRenderer() 返回 TableColumn 未定义头渲染器时所使用的默认渲染器。
TableCellRenderer | TableColumn.getCellRenderer() 返回 JTable 用于绘制此列各值的 TableCellRenderer。
TableCellRenderer | JTableHeader.getDefaultRenderer() 返回 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。
TableCellRenderer | TableColumn.getHeaderRenderer() 返回用于绘制 TableColumn 标题的 TableCellRenderer。

参数类型为 TableCellRenderer 的 javax.swing.table 中的方法
void | TableColumn.setCellRenderer(TableCellRenderer cellRenderer) 设置 JTable 用于绘制此列各值的 TableCellRenderer。
void | JTableHeader.setDefaultRenderer(TableCellRenderer defaultRenderer) 设置 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。
void | TableColumn.setHeaderRenderer(TableCellRenderer headerRenderer) 将用于绘制 TableColumn 的标题的 TableCellRenderer 设置为 headerRenderer。

参数类型为 TableCellRenderer 的 javax.swing.table 中的构造方法
TableColumn(int modelIndex, int width, TableCellRenderer cellRenderer, TableCellEditor cellEditor)
使用指定的模型索引、宽度、单元格渲染器、单元格编辑器创建并初始化 TableColumn 实例；所有 TableColumn 构造方法都委托给此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.table.TableColumn 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.TableColumn
的使用

使用 TableColumn 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableColumn 的使用

返回 TableColumn 的 javax.swing 中的方法
 TableColumn JTable.getColumn(Object identifier)
返回表中列的 TableColumn 对象，当使用 equals 进行比较时，表的标识符等于 identifier。

参数类型为 TableColumn 的 javax.swing 中的方法
void | JTable.addColumn(TableColumn aColumn) 将 aColumn 追加到此 JTable 的列模型所保持的列数组的尾部。
void | JTable.removeColumn(TableColumn aColumn) 从此 JTable 的列数组中移除 aColumn。

javax.swing.table 中 TableColumn 的使用

声明为 TableColumn 的 javax.swing.table 中的字段
protected TableColumn | JTableHeader.draggedColumn 被拖动列的索引。
protected TableColumn | JTableHeader.resizingColumn 进行大小调整的列的索引。

类型参数类型为 TableColumn 的 javax.swing.table 中的字段
protected  Vector<TableColumn> DefaultTableColumnModel.tableColumns
此模型中 TableColumn 对象组成的数组

返回 TableColumn 的 javax.swing.table 中的方法
TableColumn | DefaultTableColumnModel.getColumn(int columnIndex) 返回 columnIndex 处列的 TableColumn 对象。
TableColumn | TableColumnModel.getColumn(int columnIndex) 返回 columnIndex 位置列的 TableColumn 对象。
TableColumn | JTableHeader.getDraggedColumn() 当且仅当正在进行拖动时，返回被拖动的列，否则返回 null。
TableColumn | JTableHeader.getResizingColumn() 返回正在调整其大小的列。

返回变量类型为 TableColumn 的类型的 javax.swing.table 中的方法
Enumeration<TableColumn> | DefaultTableColumnModel.getColumns() 返回该模型中所有列的一个 Enumeration。
Enumeration<TableColumn> | TableColumnModel.getColumns() 返回该模型中所有列的 Enumeration。

参数类型为 TableColumn 的 javax.swing.table 中的方法
void | DefaultTableColumnModel.addColumn(TableColumn aColumn) 将 aColumn 追加到 tableColumns 数组的结尾。
void | TableColumnModel.addColumn(TableColumn aColumn) 将 aColumn 追加到 tableColumns 数组的结尾。
void | DefaultTableColumnModel.removeColumn(TableColumn column) 从 tableColumns 数组删除 column。
void | TableColumnModel.removeColumn(TableColumn column) 从 tableColumns 数组中删除 TableColumn column。
void | JTableHeader.setDraggedColumn(TableColumn aColumn) 将头的 draggedColumn 设置为 aColumn。
void | JTableHeader.setResizingColumn(TableColumn aColumn) 将头的 resizingColumn 设置为 aColumn。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.table.TableColumnModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.table.TableColumnModel
的使用

使用 TableColumnModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableColumnModel 的使用

声明为 TableColumnModel 的 javax.swing 中的字段
protected  TableColumnModel JTable.columnModel
表的 TableColumnModel。

返回 TableColumnModel 的 javax.swing 中的方法
protected TableColumnModel | JTable.createDefaultColumnModel() 返回默认的列模型对象，它是一个 DefaultTableColumnModel。
TableColumnModel | JTable.getColumnModel() 返回包含此表所有列信息的 TableColumnModel。

参数类型为 TableColumnModel 的 javax.swing 中的方法
 void JTable.setColumnModel(TableColumnModel columnModel)
将此表的列模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。

参数类型为 TableColumnModel 的 javax.swing 中的构造方法
JTable(TableModel dm, TableColumnModel cm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和默认的选择模型对其进行初始化。
JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和选择模型 sm 对其进行初始化。

javax.swing.event 中 TableColumnModel 的使用

参数类型为 TableColumnModel 的 javax.swing.event 中的构造方法
TableColumnModelEvent(TableColumnModel source, int from, int to)
构造一个 TableColumnModelEvent 对象。

javax.swing.table 中 TableColumnModel 的使用

实现 TableColumnModel 的 javax.swing.table 中的类
 class DefaultTableColumnModel
JTable 的标准列处理程序。

声明为 TableColumnModel 的 javax.swing.table 中的字段
protected  TableColumnModel JTableHeader.columnModel
表头的 TableColumnModel。

返回 TableColumnModel 的 javax.swing.table 中的方法
protected TableColumnModel | JTableHeader.createDefaultColumnModel() 返回默认的列模型对象，它是 DefaultTableColumnModel。
TableColumnModel | JTableHeader.getColumnModel() 返回包含此表头所有列信息的 TableColumnModel。

参数类型为 TableColumnModel 的 javax.swing.table 中的方法
 void JTableHeader.setColumnModel(TableColumnModel columnModel)
将此表的列模型设置为 newModel，并向侦听器注册来自新列模型的通知。

参数类型为 TableColumnModel 的 javax.swing.table 中的构造方法
JTableHeader(TableColumnModel cm)
构造 JTableHeader，使用 cm 作为列模型对其进行初始化。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.table.TableModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.table.TableModel
的使用

使用 TableModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableModel 的使用

声明为 TableModel 的 javax.swing 中的字段
protected  TableModel JTable.dataModel
表的 TableModel。

返回 TableModel 的 javax.swing 中的方法
protected TableModel | JTable.createDefaultDataModel() 返回默认的表模型对象，它是一个 DefaultTableModel。
TableModel | JTable.getModel() 返回提供此 JTable 所显示数据的 TableModel。

返回变量类型为 TableModel 的类型的 javax.swing 中的方法
 RowSorter<? extends TableModel> JTable.getRowSorter()
返回负责排序的对象。

参数类型为 TableModel 的 javax.swing 中的方法
 void JTable.setModel(TableModel dataModel)
将此表的数据模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。

类型变量类型为 TableModel 的 javax.swing 中的方法参数
 void JTable.setRowSorter(RowSorter<? extends TableModel> sorter)
设置 RowSorter。

参数类型为 TableModel 的 javax.swing 中的构造方法
JTable(TableModel dm)
构造一个 JTable，使用数据模型 dm、默认的列模型和默认的选择模型对其进行初始化。
JTable(TableModel dm, TableColumnModel cm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和默认的选择模型对其进行初始化。
JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和选择模型 sm 对其进行初始化。

javax.swing.event 中 TableModel 的使用

参数类型为 TableModel 的 javax.swing.event 中的构造方法
TableModelEvent(TableModel source)
如果表中的所有行数据都发生更改，那么侦听器应该丢弃基于这些行的所有状态，并重新查询 TableModel 来获得新的行计数和所有恰当值。
TableModelEvent(TableModel source, int row)
此数据行已被更新。
TableModelEvent(TableModel source, int firstRow, int lastRow)
行 [firstRow, lastRow] 中的数据已被更新。
TableModelEvent(TableModel source, int firstRow, int lastRow, int column)
列 column 的 [firstRow, lastRow] 范围内的单元格已被更新。
TableModelEvent(TableModel source, int firstRow, int lastRow, int column, int type)
从 (firstRow, column) 到 (lastRow, column) 的单元格已被更改。

javax.swing.table 中 TableModel 的使用

类型参数类型为 TableModel 的 javax.swing.table 中的类
 class TableRowSorter<M extends TableModel>
RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。

实现 TableModel 的 javax.swing.table 中的类
class | AbstractTableModel 此抽象类为 TableModel 接口中的大多数方法提供默认实现。
class | DefaultTableModel 这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。

参数类型为 TableModel 的 javax.swing.table 中的方法
abstract  String TableStringConverter.toString(TableModel model, int row, int column)
返回指定位置处值的字符串表示形式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.table.TableRowSorter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.TableRowSorter
的使用

没有 javax.swing.table.TableRowSorter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.table.TableStringConverter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.TableStringConverter
的使用

使用 TableStringConverter 的软件包
javax.swing.table 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.table 中 TableStringConverter 的使用

返回 TableStringConverter 的 javax.swing.table 中的方法
 TableStringConverter TableRowSorter.getStringConverter()
返回负责将值从模型转换为字符串的对象。

参数类型为 TableStringConverter 的 javax.swing.table 中的方法
 void TableRowSorter.setStringConverter(TableStringConverter stringConverter)
设置负责将值从模型转换为字符串的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.text (Java 2 Platform SE 6)

 javax.swing.text
接口
AbstractDocument.AttributeContext
AbstractDocument.Content
AttributeSet
AttributeSet.CharacterAttribute
AttributeSet.ColorAttribute
AttributeSet.FontAttribute
AttributeSet.ParagraphAttribute
Caret
Document
Element
Highlighter
Highlighter.Highlight
Highlighter.HighlightPainter
Keymap
MutableAttributeSet
Position
Style
StyledDocument
TabableView
TabExpander
ViewFactory
类
AbstractDocument
AbstractDocument.ElementEdit
AbstractWriter
AsyncBoxView
BoxView
ComponentView
CompositeView
DateFormatter
DefaultCaret
DefaultEditorKit
DefaultEditorKit.BeepAction
DefaultEditorKit.CopyAction
DefaultEditorKit.CutAction
DefaultEditorKit.DefaultKeyTypedAction
DefaultEditorKit.InsertBreakAction
DefaultEditorKit.InsertContentAction
DefaultEditorKit.InsertTabAction
DefaultEditorKit.PasteAction
DefaultFormatter
DefaultFormatterFactory
DefaultHighlighter
DefaultHighlighter.DefaultHighlightPainter
DefaultStyledDocument
DefaultStyledDocument.AttributeUndoableEdit
DefaultStyledDocument.ElementSpec
DefaultTextUI
DocumentFilter
DocumentFilter.FilterBypass
EditorKit
ElementIterator
FieldView
FlowView
FlowView.FlowStrategy
GapContent
GlyphView
GlyphView.GlyphPainter
IconView
InternationalFormatter
JTextComponent
JTextComponent.DropLocation
JTextComponent.KeyBinding
LabelView
LayeredHighlighter
LayeredHighlighter.LayerPainter
LayoutQueue
MaskFormatter
NavigationFilter
NavigationFilter.FilterBypass
NumberFormatter
ParagraphView
PasswordView
PlainDocument
PlainView
Position.Bias
Segment
SimpleAttributeSet
StringContent
StyleConstants
StyleConstants.CharacterConstants
StyleConstants.ColorConstants
StyleConstants.FontConstants
StyleConstants.ParagraphConstants
StyleContext
StyledEditorKit
StyledEditorKit.AlignmentAction
StyledEditorKit.BoldAction
StyledEditorKit.FontFamilyAction
StyledEditorKit.FontSizeAction
StyledEditorKit.ForegroundAction
StyledEditorKit.ItalicAction
StyledEditorKit.StyledTextAction
StyledEditorKit.UnderlineAction
TableView
TabSet
TabStop
TextAction
Utilities
View
WrappedPlainView
ZoneView
异常
BadLocationException
ChangedCharSetException


类 javax.swing.text.AbstractDocument 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument
的使用

使用 AbstractDocument 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument 的使用

javax.swing.text 中 AbstractDocument 的子类
class | DefaultStyledDocument 能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。
class | PlainDocument 维护无任何字符属性的普通文档。

javax.swing.text.html 中 AbstractDocument 的使用

javax.swing.text.html 中 AbstractDocument 的子类
 class HTMLDocument
对 HTML 进行建模的文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument.AbstractElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument.AbstractElement
的使用

使用 AbstractDocument.AbstractElement 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument.AbstractElement 的使用

javax.swing.text 中 AbstractDocument.AbstractElement 的子类
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。

返回 AbstractDocument.AbstractElement 的 javax.swing.text 中的方法
protected AbstractDocument.AbstractElement | DefaultStyledDocument.createDefaultRoot() 创建用于代表默认文档结构的根元素。
protected AbstractDocument.AbstractElement | PlainDocument.createDefaultRoot() 创建用于表示默认文档结构的根元素。

javax.swing.text.html 中 AbstractDocument.AbstractElement 的使用

javax.swing.text.html 中 AbstractDocument.AbstractElement 的子类
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

返回 AbstractDocument.AbstractElement 的 javax.swing.text.html 中的方法
protected  AbstractDocument.AbstractElement HTMLDocument.createDefaultRoot()
创建用于表示默认文档结构的根元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.AbstractDocument.AttributeContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AbstractDocument.AttributeContext
的使用

使用 AbstractDocument.AttributeContext 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument.AttributeContext 的使用

实现 AbstractDocument.AttributeContext 的 javax.swing.text 中的类
 class StyleContext
样式池及其关联的资源。

返回 AbstractDocument.AttributeContext 的 javax.swing.text 中的方法
protected  AbstractDocument.AttributeContext AbstractDocument.getAttributeContext()
获取管理属性的上下文。

参数类型为 AbstractDocument.AttributeContext 的 javax.swing.text 中的构造方法
AbstractDocument(AbstractDocument.Content data, AbstractDocument.AttributeContext context)
构造具有某种指定内容存储机制的新 AbstractDocument。

javax.swing.text.html 中 AbstractDocument.AttributeContext 的使用

实现 AbstractDocument.AttributeContext 的 javax.swing.text.html 中的类
 class StyleSheet
支持定义要呈现的 HTML 视图的可视化特征。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument.BranchElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument.BranchElement
的使用

使用 AbstractDocument.BranchElement 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument.BranchElement 的使用

javax.swing.text 中 AbstractDocument.BranchElement 的子类
protected  class DefaultStyledDocument.SectionElement
文档的默认根元素... 与所包含的段落/行对应。

javax.swing.text.html 中 AbstractDocument.BranchElement 的使用

javax.swing.text.html 中 AbstractDocument.BranchElement 的子类
 class HTMLDocument.BlockElement
表示结构性 HTML 块 的元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.AbstractDocument.Content 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AbstractDocument.Content
的使用

使用 AbstractDocument.Content 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument.Content 的使用

实现 AbstractDocument.Content 的 javax.swing.text 中的类
class | GapContent AbstractDocument.Content 接口的一个实现，使用类似于 emacs 使用的间隙缓冲区来实现。
class | StringContent AbstractDocument.Content 接口的一个实现，这是一个对相对于较小的文档和/或调试很有用的强制实现。

返回 AbstractDocument.Content 的 javax.swing.text 中的方法
protected  AbstractDocument.Content AbstractDocument.getContent()
获得文档的内容。

参数类型为 AbstractDocument.Content 的 javax.swing.text 中的构造方法
AbstractDocument(AbstractDocument.Content data)
构造具有某种指定内容存储机制的新 AbstractDocument。
AbstractDocument(AbstractDocument.Content data, AbstractDocument.AttributeContext context)
构造具有某种指定内容存储机制的新 AbstractDocument。
DefaultStyledDocument(AbstractDocument.Content c, StyleContext styles)
构造样式化文档。
PlainDocument(AbstractDocument.Content c)
构造一个纯文本文档。

javax.swing.text.html 中 AbstractDocument.Content 的使用

参数类型为 AbstractDocument.Content 的 javax.swing.text.html 中的构造方法
HTMLDocument(AbstractDocument.Content c, StyleSheet styles)
构造具有给定内容存储实现和给定样式/属性存储机制的 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument.DefaultDocumentEvent
的使用

使用 AbstractDocument.DefaultDocumentEvent 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument.DefaultDocumentEvent 的使用

参数类型为 AbstractDocument.DefaultDocumentEvent 的 javax.swing.text 中的方法
void | DefaultStyledDocument.ElementBuffer.change(int offset, int length, AbstractDocument.DefaultDocumentEvent de) 更改内容。
void | DefaultStyledDocument.ElementBuffer.insert(int offset, int length, DefaultStyledDocument.ElementSpec[] data, AbstractDocument.DefaultDocumentEvent de) 插入新内容。
protected void | DefaultStyledDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 在文本插入后更新文档结构。
protected void | PlainDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 随文本插入更新文档结构。
protected void | AbstractDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 在文本插入后更新文档结构。
protected void | AbstractDocument.postRemoveUpdate(AbstractDocument.DefaultDocumentEvent chng) 随文本的移除更新任何文档结构。
void | DefaultStyledDocument.ElementBuffer.remove(int offset, int length, AbstractDocument.DefaultDocumentEvent de) 移除内容。
protected void | DefaultStyledDocument.removeUpdate(AbstractDocument.DefaultDocumentEvent chng) 在文本移除后更新文档结构。
protected void | PlainDocument.removeUpdate(AbstractDocument.DefaultDocumentEvent chng) 随文本的移除更新任何文档结构。
protected void | AbstractDocument.removeUpdate(AbstractDocument.DefaultDocumentEvent chng) 随文本的移除更新任何文档结构。

javax.swing.text.html 中 AbstractDocument.DefaultDocumentEvent 的使用

参数类型为 AbstractDocument.DefaultDocumentEvent 的 javax.swing.text.html 中的方法
protected  void HTMLDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
由于插入文本而导致更新文档的结构。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument.ElementEdit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument.ElementEdit
的使用

没有 javax.swing.text.AbstractDocument.ElementEdit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument.LeafElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument.LeafElement
的使用

使用 AbstractDocument.LeafElement 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 AbstractDocument.LeafElement 的使用

javax.swing.text.html 中 AbstractDocument.LeafElement 的子类
 class HTMLDocument.RunElement
表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.AbstractWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractWriter
的使用

使用 AbstractWriter 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 AbstractWriter 的使用

javax.swing.text.html 中 AbstractWriter 的子类
class | HTMLWriter 这是用于 HTMLDocuments 的 writer。
class | MinimalHTMLWriter MinimalHTMLWriter 是一个回退 writer，HTMLEditorKit 使用它为非 EditorKit 生成的文档写出 HTML。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.AsyncBoxView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AsyncBoxView
的使用

没有 javax.swing.text.AsyncBoxView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.AsyncBoxView.ChildLocator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AsyncBoxView.ChildLocator
的使用

使用 AsyncBoxView.ChildLocator 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AsyncBoxView.ChildLocator 的使用

声明为 AsyncBoxView.ChildLocator 的 javax.swing.text 中的字段
protected  AsyncBoxView.ChildLocator AsyncBoxView.locator
这是管理子视图偏移量的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.AsyncBoxView.ChildState 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AsyncBoxView.ChildState
的使用

使用 AsyncBoxView.ChildState 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AsyncBoxView.ChildState 的使用

声明为 AsyncBoxView.ChildState 的 javax.swing.text 中的字段
protected  AsyncBoxView.ChildState AsyncBoxView.ChildLocator.lastValidOffset
最后一次有效偏移量计算的位置。

返回 AsyncBoxView.ChildState 的 javax.swing.text 中的方法
protected AsyncBoxView.ChildState | AsyncBoxView.createChildState(View v) 通过此方法创建新的 ChildState 记录，以允许扩展 ChildState 记录的子类执行/保存更多状态。
protected AsyncBoxView.ChildState | AsyncBoxView.getChildState(int index) 获取对象，该对象表示在给定索引位置的子视图的布局状态。

参数类型为 AsyncBoxView.ChildState 的 javax.swing.text 中的方法
void | AsyncBoxView.ChildLocator.childChanged(AsyncBoxView.ChildState cs) 子级已更改的通知。
protected void | AsyncBoxView.majorRequirementChange(AsyncBoxView.ChildState cs, float delta) 沿主轴上的要求更改。
protected void | AsyncBoxView.minorRequirementChange(AsyncBoxView.ChildState cs) 沿辅轴上的要求更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.AttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AttributeSet
的使用

使用 AttributeSet 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 AttributeSet 的使用

返回 AttributeSet 的 java.awt 中的方法
 AttributeSet TextComponent.AccessibleAWTTextComponent.getCharacterAttribute(int i)
返回给定字符（位于给定索引处）的 AttributeSet。

javax.accessibility 中 AttributeSet 的使用

声明为 AttributeSet 的 javax.accessibility 中的字段
 AttributeSet AccessibleAttributeSequence.attributes
文本属性

返回 AttributeSet 的 javax.accessibility 中的方法
 AttributeSet AccessibleText.getCharacterAttribute(int i)
返回给定索引处给定字符的 AttributeSet

参数类型为 AttributeSet 的 javax.accessibility 中的方法
 void AccessibleEditableText.setAttributes(int startIndex, int endIndex, AttributeSet as)
设置两个索引之间文本的属性。

参数类型为 AttributeSet 的 javax.accessibility 中的构造方法
AccessibleAttributeSequence(int start, int end, AttributeSet attr)
构造带有给定参数的 AccessibleAttributeSequence。

javax.swing 中 AttributeSet 的使用

返回 AttributeSet 的 javax.swing 中的方法
AttributeSet | JSpinner.AccessibleJSpinner.getCharacterAttribute(int i) 返回给定索引处给定字符的 AttributeSet
AttributeSet | ProgressMonitor.AccessibleProgressMonitor.getCharacterAttribute(int i) 返回位于给定索引处的给定字符的 AttributeSet
AttributeSet | AbstractButton.AccessibleAbstractButton.getCharacterAttribute(int i) 返回位于给定索引处的给定字符的 AttributeSet。
AttributeSet | JLabel.AccessibleJLabel.getCharacterAttribute(int i) 返回给定索引处给定字符的 AttributeSet
AttributeSet | JTextPane.getCharacterAttributes() 获取在当前插入符号位置的有效字符属性，或者 null。
AttributeSet | JTextPane.getParagraphAttributes() 获取插入符号位置的当前有效段落属性，如果没有，则返回 null。

参数类型为 AttributeSet 的 javax.swing 中的方法
void | JSpinner.AccessibleJSpinner.setAttributes(int startIndex, int endIndex, AttributeSet as) 设置两个索引之间文本的属性。
void | JTextPane.setCharacterAttributes(AttributeSet attr, boolean replace) 将给定属性应用于字符内容。
void | JTextPane.setParagraphAttributes(AttributeSet attr, boolean replace) 将给定属性应用于段落。

javax.swing.text 中 AttributeSet 的使用

javax.swing.text 中 AttributeSet 的子接口
interface | MutableAttributeSet 独特属性的可变集合的通用接口。
interface | Style 与文档中某个元素相关的属性集合。

实现 AttributeSet 的 javax.swing.text 中的类
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。
class | SimpleAttributeSet 使用哈希表的 MutableAttributeSet 的直接实现。
class | StyleContext.NamedStyle 通常用于表示字符和段落样式的属性集合。
class | StyleContext.SmallAttributeSet 此类可在数组中存储少量的属性。

声明为 AttributeSet 的 javax.swing.text 中的字段
protected AttributeSet | DefaultStyledDocument.AttributeUndoableEdit.copy
static AttributeSet | SimpleAttributeSet.EMPTY 空的属性集。
protected AttributeSet | DefaultStyledDocument.AttributeUndoableEdit.newAttributes

返回 AttributeSet 的 javax.swing.text 中的方法
AttributeSet | StyleContext.addAttribute(AttributeSet old, Object name, Object value) 向给定的集合中添加属性，并返回新的有代表性的集合。
AttributeSet | AbstractDocument.AttributeContext.addAttribute(AttributeSet old, Object name, Object value) 向给定属性集中添加一个属性，并返回新的有代表性的属性集。
AttributeSet | StyleContext.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加属性集。
AttributeSet | AbstractDocument.AttributeContext.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加一组属性。
AttributeSet | SimpleAttributeSet.copyAttributes() 创建属性的副本。
AttributeSet | AttributeSet.copyAttributes() 返回保证固定不变的属性集。
AttributeSet | StyleContext.SmallAttributeSet.copyAttributes() 复制属性集。
AttributeSet | StyleContext.NamedStyle.copyAttributes() 复制属性集。
AttributeSet | AbstractDocument.AbstractElement.copyAttributes() 复制属性集合。
AttributeSet | DefaultStyledDocument.ElementSpec.getAttributes() 获得元素属性。
AttributeSet | View.getAttributes() 获取呈现时要使用的属性。
AttributeSet | AbstractDocument.AbstractElement.getAttributes() 获取该元素的属性。
AttributeSet | Element.getAttributes() 获取此元素包含的属性集合。
AttributeSet | JTextComponent.AccessibleJTextComponent.getCharacterAttribute(int i) 返回给定字符（位于给定索引处）的 AttributeSet。
AttributeSet | StyleContext.getEmptySet() 获取空 AttributeSet。
AttributeSet | AbstractDocument.AttributeContext.getEmptySet() 获取一个空的 AttributeSet。
AttributeSet | SimpleAttributeSet.getResolveParent() 获取正解析的父级。
AttributeSet | AttributeSet.getResolveParent() 获取解析父集合。
AttributeSet | StyleContext.SmallAttributeSet.getResolveParent() 如果未重写，解析父级默认为是解析父元素。
AttributeSet | StyleContext.NamedStyle.getResolveParent() 从父级获取属性。
AttributeSet | AbstractDocument.AbstractElement.getResolveParent() 获取要解析的父级。
AttributeSet | StyleContext.removeAttribute(AttributeSet old, Object name) 从集合中移除一个属性。
AttributeSet | AbstractDocument.AttributeContext.removeAttribute(AttributeSet old, Object name) 从属性集中移除某个属性。
AttributeSet | StyleContext.removeAttributes(AttributeSet old, AttributeSet attrs) 移除元素的属性集。
AttributeSet | AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, AttributeSet attrs) 移除元素的一组属性。
AttributeSet | StyleContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一个属性集。
AttributeSet | AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一组属性。

参数类型为 AttributeSet 的 javax.swing.text 中的方法
AttributeSet | StyleContext.addAttribute(AttributeSet old, Object name, Object value) 向给定的集合中添加属性，并返回新的有代表性的集合。
AttributeSet | AbstractDocument.AttributeContext.addAttribute(AttributeSet old, Object name, Object value) 向给定属性集中添加一个属性，并返回新的有代表性的属性集。
void | SimpleAttributeSet.addAttributes(AttributeSet attributes) 向列表添加属性集。
void | MutableAttributeSet.addAttributes(AttributeSet attributes) 创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。
void | StyleContext.NamedStyle.addAttributes(AttributeSet attr) 将属性集添加到元素。
void | AbstractDocument.AbstractElement.addAttributes(AttributeSet attr) 向该元素添加一个属性集合。
AttributeSet | StyleContext.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加属性集。
AttributeSet | AbstractDocument.AttributeContext.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加一组属性。
boolean | SimpleAttributeSet.containsAttributes(AttributeSet attributes) 确定属性列表中是否包含所有指定的名称/值对。
boolean | AttributeSet.containsAttributes(AttributeSet attributes) 如果此集合用相等值定义给定集合中的所有属性，则返回 true。
boolean | StyleContext.SmallAttributeSet.containsAttributes(AttributeSet attrs) 检查属性集是否包含了所有给定的属性。
boolean | StyleContext.NamedStyle.containsAttributes(AttributeSet attrs) 检查元素是否包含了所有属性。
boolean | AbstractDocument.AbstractElement.containsAttributes(AttributeSet attrs) 检查该元素是否包含所有的属性。
protected Element | AbstractDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可包含其他元素。
protected MutableAttributeSet | StyleContext.createLargeAttributeSet(AttributeSet a) 创建一个以空间来换取时间的大属性集合。
protected Element | AbstractDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建文档叶元素。
protected StyleContext.SmallAttributeSet | StyleContext.createSmallAttributeSet(AttributeSet a) 创建一个可能用于共享的压缩属性集。
static int | StyleConstants.getAlignment(AttributeSet a) 获取对齐设置。
Color | DefaultStyledDocument.getBackground(AttributeSet attr) 从属性集获得背景颜色。
Color | StyledDocument.getBackground(AttributeSet attr) 使用一个属性集并将其转换为一个背景色规范。
static Color | StyleConstants.getBackground(AttributeSet a) 从属性列表中获取背景色设置。
Color | StyleContext.getBackground(AttributeSet attr) 使用一个属性集并将其转换成为一个背景色规范。
static int | StyleConstants.getBidiLevel(AttributeSet a) 获取 BidiLevel 设置。
static Component | StyleConstants.getComponent(AttributeSet a) 从属性列表中获取组件设置。
static float | StyleConstants.getFirstLineIndent(AttributeSet a) 获取首行缩进设置。
Font | DefaultStyledDocument.getFont(AttributeSet attr) 从属性集获得字体。
Font | StyledDocument.getFont(AttributeSet attr) 使用一个属性集并将其转换为字体规范。
Font | StyleContext.getFont(AttributeSet attr) 从属性集中获取字体。
static String | StyleConstants.getFontFamily(AttributeSet a) 从属性列表中获取字体系列设置。
static int | StyleConstants.getFontSize(AttributeSet a) 从属性列表中获取字体大小设置。
Color | DefaultStyledDocument.getForeground(AttributeSet attr) 从属性集获得前景色。
Color | StyledDocument.getForeground(AttributeSet attr) 使用一个属性集并将其转换成为一个前景色规范。
static Color | StyleConstants.getForeground(AttributeSet a) 从属性列表中获取前景色设置。
Color | StyleContext.getForeground(AttributeSet attr) 使用一个属性集并将其转换成为一个前景色规范。
static Icon | StyleConstants.getIcon(AttributeSet a) 从属性列表中获取图标设置。
static float | StyleConstants.getLeftIndent(AttributeSet a) 获取左边缩进设置。
static float | StyleConstants.getLineSpacing(AttributeSet a) 获取行间距设置。
static float | StyleConstants.getRightIndent(AttributeSet a) 获取右边缩进设置。
static float | StyleConstants.getSpaceAbove(AttributeSet a) 获取上部空间设置。
static float | StyleConstants.getSpaceBelow(AttributeSet a) 获取下部空间设置。
static TabSet | StyleConstants.getTabSet(AttributeSet a) 获取 TabSet。
void | DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr) 将文本插入指定的 Document 之前调用。
abstract void | DocumentFilter.FilterBypass.insertString(int offset, String string, AttributeSet attr) 插入指定的文本，绕过 DocumentFilter。
void | PlainDocument.insertString(int offs, String str, AttributeSet a) 向文档中插入某些内容。
void | AbstractDocument.insertString(int offs, String str, AttributeSet a) 将某些内容插入文档。
void | Document.insertString(int offset, String str, AttributeSet a) 插入内容字符串。
protected void | DefaultStyledDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 在文本插入后更新文档结构。
protected void | PlainDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 随文本插入更新文档结构。
protected void | AbstractDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 在文本插入后更新文档结构。
static boolean | StyleConstants.isBold(AttributeSet a) 确定是否设置了粗体属性。
boolean | SimpleAttributeSet.isEqual(AttributeSet attr) 比较两个属性集。
boolean | AttributeSet.isEqual(AttributeSet attr) 确定两个属性集是否相等。
boolean | StyleContext.SmallAttributeSet.isEqual(AttributeSet attr) 检查两个属性集是否相等。
boolean | StyleContext.NamedStyle.isEqual(AttributeSet attr) 检查两个属性集是否相等。
boolean | AbstractDocument.AbstractElement.isEqual(AttributeSet attr) 检查两个属性集合是否相等。
static boolean | StyleConstants.isItalic(AttributeSet a) 确定是否设置了斜体属性。
static boolean | StyleConstants.isStrikeThrough(AttributeSet a) 确定是否设置了删除线属性。
static boolean | StyleConstants.isSubscript(AttributeSet a) 确定是否设置了下标属性。
static boolean | StyleConstants.isSuperscript(AttributeSet a) 确定是否设置了上标属性。
static boolean | StyleConstants.isUnderline(AttributeSet a) 确定是否设置了下划线属性。
void | StyleContext.reclaim(AttributeSet a) 返回 MutableAttributeSet 实现不再需要的集合。
void | AbstractDocument.AttributeContext.reclaim(AttributeSet a) 回收某个属性集。
AttributeSet | StyleContext.removeAttribute(AttributeSet old, Object name) 从集合中移除一个属性。
AttributeSet | AbstractDocument.AttributeContext.removeAttribute(AttributeSet old, Object name) 从属性集中移除某个属性。
void | SimpleAttributeSet.removeAttributes(AttributeSet attributes) 从列表中移除属性集。
void | MutableAttributeSet.removeAttributes(AttributeSet attributes) 移除具有给定 name 的属性集。
void | StyleContext.NamedStyle.removeAttributes(AttributeSet attrs) 移除元素的属性集。
void | AbstractDocument.AbstractElement.removeAttributes(AttributeSet attrs) 移除该元素的属性集合。
AttributeSet | StyleContext.removeAttributes(AttributeSet old, AttributeSet attrs) 移除元素的属性集。
AttributeSet | AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, AttributeSet attrs) 移除元素的一组属性。
AttributeSet | StyleContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一个属性集。
AttributeSet | AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一组属性。
void | DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs) 在替换指定的 Document 中的文本区域之前调用。
abstract void | DocumentFilter.FilterBypass.replace(int offset, int length, String string, AttributeSet attrs) 删除从 offset 到 offset + length 的文本区域，并用 text 替换。
void | AbstractDocument.replace(int offset, int length, String text, AttributeSet attrs) 删除从 offset 到 offset + length 的文本区域，并用 text 替换它。
void | JTextComponent.AccessibleJTextComponent.setAttributes(int startIndex, int endIndex, AttributeSet as) 设置两个索引之间的文本的属性。
void | DefaultStyledDocument.setCharacterAttributes(int offset, int length, AttributeSet s, boolean replace) 为文档某些部分设置属性。
void | StyledDocument.setCharacterAttributes(int offset, int length, AttributeSet s, boolean replace) 更改内容元素属性，该属性是用来给定文档中现有内容范围的。
protected void | StyledEditorKit.StyledTextAction.setCharacterAttributes(JEditorPane editor, AttributeSet attr, boolean replace) 对字符内容应用给定的属性。
void | DefaultStyledDocument.setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace) 设置段落属性。
void | StyledDocument.setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace) 设置段落属性。
protected void | StyledEditorKit.StyledTextAction.setParagraphAttributes(JEditorPane editor, AttributeSet attr, boolean replace) 对段落应用给定的属性。
protected void | CompositeView.setParagraphInsets(AttributeSet attr) 按照给定属性中指定的段落属性设置 insets。
void | SimpleAttributeSet.setResolveParent(AttributeSet parent) 设置解析的父级。
void | MutableAttributeSet.setResolveParent(AttributeSet parent) 设置正解析的父级。
void | StyleContext.NamedStyle.setResolveParent(AttributeSet parent) 设置解析的父级。
void | AbstractDocument.AbstractElement.setResolveParent(AttributeSet parent) 设置要解析的父级。
protected void | AbstractWriter.writeAttributes(AttributeSet attr) 以 " =" 对的形式写出属性集。
void | StyleContext.writeAttributes(ObjectOutputStream out, AttributeSet a) 写出属性的特定于上下文的处理。
static void | StyleContext.writeAttributeSet(ObjectOutputStream out, AttributeSet a) 将属性集写入到给定的对象流以便序列化。

参数类型为 AttributeSet 的 javax.swing.text 中的构造方法
AbstractDocument.AbstractElement(Element parent, AttributeSet a)
创建新的 AbstractElement。
AbstractDocument.BranchElement(Element parent, AttributeSet a)
构造最初不包含任何子元素的复合元素。
AbstractDocument.LeafElement(Element parent, AttributeSet a, int offs0, int offs1)
构造一个表示文档中内容的元素（没有子元素）。
DefaultStyledDocument.AttributeUndoableEdit(Element element, AttributeSet newAttributes, boolean isReplacing)
DefaultStyledDocument.ElementSpec(AttributeSet a, short type)
当标记不在文档中存储时供标记使用的构造方法。
DefaultStyledDocument.ElementSpec(AttributeSet a, short type, char[] txt, int offs, int len)
用于外部创建规范的构造方法，供批量输入内容和标记到文档中。
DefaultStyledDocument.ElementSpec(AttributeSet a, short type, int len)
供文档内部解析使用的构造方法，在数据已添加但还需要 len 信息时使用。
SimpleAttributeSet(AttributeSet source)
根据提供的属性集创建新属性集。
StyleContext.SmallAttributeSet(AttributeSet attrs)

javax.swing.text.html 中 AttributeSet 的使用

实现 AttributeSet 的 javax.swing.text.html 中的类
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

返回 AttributeSet 的 javax.swing.text.html 中的方法
AttributeSet | StyleSheet.addAttribute(AttributeSet old, Object key, Object value) 向给定集合添加属性，并返回新的表示方式的集合。
AttributeSet | StyleSheet.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加属性集。
AttributeSet | BlockView.getAttributes() 获取呈现时要使用的属性。
abstract AttributeSet | HTMLDocument.Iterator.getAttributes() 返回此标记的属性。
AttributeSet | ImageView.getAttributes() 获取呈现时要使用的属性。
AttributeSet | InlineView.getAttributes() 获取呈现时要使用的属性。
AttributeSet | Option.getAttributes() 获取与此选项相关的属性。
AttributeSet | ParagraphView.getAttributes() 获取呈现时所使用的属性。
AttributeSet | StyleSheet.getDeclaration(String decl) 将 CSS 声明转换为表示 CSS 声明的 AttributeSet。
AttributeSet | HTMLDocument.RunElement.getResolveParent() 获得解析父级。
AttributeSet | HTMLDocument.BlockElement.getResolveParent() 获得解析父级。
AttributeSet | StyleSheet.getViewAttributes(View v) 获取用来显示视图的属性集。
AttributeSet | StyleSheet.removeAttribute(AttributeSet old, Object key) 从集合中移除属性。
AttributeSet | StyleSheet.removeAttributes(AttributeSet old, AttributeSet attrs) 移除属性集。
AttributeSet | StyleSheet.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的属性集。
AttributeSet | StyleSheet.translateHTMLToCSS(AttributeSet htmlAttrSet) 将 HTML 属性集合转换为对等的 CSS 属性集合。

参数类型为 AttributeSet 的 javax.swing.text.html 中的方法
AttributeSet | StyleSheet.addAttribute(AttributeSet old, Object key, Object value) 向给定集合添加属性，并返回新的表示方式的集合。
AttributeSet | StyleSheet.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加属性集。
protected void | HTMLWriter.closeOutUnwantedEmbeddedTags(AttributeSet attr) 搜索属性集和存储在标记向量中的每个标记。
protected Element | HTMLDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可以包含其他元素。
protected MutableAttributeSet | StyleSheet.createLargeAttributeSet(AttributeSet a) 创建一个以空间来换取时间的大属性集合。
protected Element | HTMLDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建直接表示文本的文档叶元素（没有任何子级）。
protected StyleContext.SmallAttributeSet | StyleSheet.createSmallAttributeSet(AttributeSet a) 创建可以共享的属性压缩集。
Color | StyleSheet.getBackground(AttributeSet a) 获取一个属性集并将其转换为背景色规范。
StyleSheet.BoxPainter | StyleSheet.getBoxPainter(AttributeSet a) 获取给定 CSS 属性集合使用的框 formatter。
Font | StyleSheet.getFont(AttributeSet a) 获取给定属性集使用的字体。
Color | StyleSheet.getForeground(AttributeSet a) 获取一个属性集并将其转换为前景色规范。
static int | HTML.getIntegerAttributeValue(AttributeSet attr, HTML.Attribute key, int def) 获取整数属性值。
StyleSheet.ListPainter | StyleSheet.getListPainter(AttributeSet a) 获取给定 CSS 属性集合使用的列表 formatter。
protected void | HTMLDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 由于插入文本而导致更新文档的结构。
protected boolean | HTMLWriter.isBlockTag(AttributeSet attr) 确定与该元素关联的 HTML.Tag 是否为块标记。
protected boolean | HTMLWriter.matchNameAttribute(AttributeSet attr, HTML.Tag tag) 如果 StyleConstants.NameAttribute 与作为参数传入的标记相同，则返回 true。
AttributeSet | StyleSheet.removeAttribute(AttributeSet old, Object key) 从集合中移除属性。
AttributeSet | StyleSheet.removeAttributes(AttributeSet old, AttributeSet attrs) 移除属性集。
AttributeSet | StyleSheet.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的属性集。
protected void | HTMLWriter.selectContent(AttributeSet attr) 写出 SELECT 表单元素的内容。
void | HTMLDocument.setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace) 设置段落属性。
protected void | HTMLWriter.textAreaContent(AttributeSet attr) 写出 TEXTAREA 表单元素中所包含的文本。
AttributeSet | StyleSheet.translateHTMLToCSS(AttributeSet htmlAttrSet) 将 HTML 属性集合转换为对等的 CSS 属性集合。
protected void | HTMLWriter.writeAttributes(AttributeSet attr) 写出属性集。
protected void | MinimalHTMLWriter.writeAttributes(AttributeSet attr) 写出以下类型的所有属性：StyleConstants.ParagraphConstants、StyleConstants.CharacterConstants、StyleConstants.FontConstants、StyleConstants.ColorConstants。
protected void | HTMLWriter.writeEmbeddedTags(AttributeSet attr) 搜索 AttributeSet 中的嵌入式标记并写出它们。
protected void | MinimalHTMLWriter.writeHTMLTags(AttributeSet attr) 基于文本的属性设置生成文本的 bold <b>、italic <i> 和 <u> 标记。
protected void | MinimalHTMLWriter.writeNonHTMLAttributes(AttributeSet attr) 以与 HTML 兼容的方式写出其余的字符级属性（bold、italic 和 underline 之外的属性）。

参数类型为 AttributeSet 的 javax.swing.text.html 中的构造方法
HTMLDocument.BlockElement(Element parent, AttributeSet a)
构造初始不包含子元素的复合元素。
HTMLDocument.RunElement(Element parent, AttributeSet a, int offs0, int offs1)
构造表示文档内部（没有子级）内容的元素。
Option(AttributeSet attr)
创建新的 Option 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.AttributeSet.CharacterAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AttributeSet.CharacterAttribute
的使用

使用 AttributeSet.CharacterAttribute 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AttributeSet.CharacterAttribute 的使用

实现 AttributeSet.CharacterAttribute 的 javax.swing.text 中的类
static class | StyleConstants.CharacterConstants 这是一个类型安全的已知 属性的枚举，它用于字符样式。
static class | StyleConstants.ColorConstants 这是一个类型安全的已知 属性的枚举，它用于颜色样式。
static class | StyleConstants.FontConstants 这是一个类型安全的已知 属性的枚举，它用于字体样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.AttributeSet.ColorAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AttributeSet.ColorAttribute
的使用

使用 AttributeSet.ColorAttribute 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AttributeSet.ColorAttribute 的使用

实现 AttributeSet.ColorAttribute 的 javax.swing.text 中的类
static class StyleConstants.ColorConstants
这是一个类型安全的已知 属性的枚举，它用于颜色样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.AttributeSet.FontAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AttributeSet.FontAttribute
的使用

使用 AttributeSet.FontAttribute 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AttributeSet.FontAttribute 的使用

实现 AttributeSet.FontAttribute 的 javax.swing.text 中的类
static class StyleConstants.FontConstants
这是一个类型安全的已知 属性的枚举，它用于字体样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.AttributeSet.ParagraphAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AttributeSet.ParagraphAttribute
的使用

使用 AttributeSet.ParagraphAttribute 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AttributeSet.ParagraphAttribute 的使用

实现 AttributeSet.ParagraphAttribute 的 javax.swing.text 中的类
static class StyleConstants.ParagraphConstants
这是一个类型安全的已知 属性的枚举，它用于段落样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.BadLocationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.BadLocationException
的使用

使用 BadLocationException 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing 中的方法
int | JTextArea.getLineEndOffset(int line) 确定给定行结尾处的偏移量。
int | JTextArea.getLineOfOffset(int offset) 将组件文本中的偏移量转换为行号。
int | JTextArea.getLineStartOffset(int line) 确定给定行起始处的偏移量。
String | JPasswordField.getText(int offs, int len) 已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。

javax.swing.plaf 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.plaf 中的方法
abstract int | TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。

javax.swing.plaf.basic 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.plaf.basic 中的方法
int | BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。

javax.swing.plaf.multi 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.plaf.multi 中的方法
int | MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e) 在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b) 在由此对象处理的每个 UI 上调用 modelToView 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c) 在由此对象处理的每个 UI 上调用 modelToView 方法。

javax.swing.text 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.text 中的方法
 Object DefaultHighlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
向视图添加高亮显示。
 Object Highlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
向视图添加高亮显示。
 void DefaultHighlighter.changeHighlight(Object tag, int p0, int p1)
更改高亮显示。
 void Highlighter.changeHighlight(Object tag, int p0, int p1)
更改给定的高亮显示，以使其横跨文档的不同部分。
 Position StringContent.createPosition(int offset)
在内容中创建一个位置，让其跟踪随内容的变化而进行的更改。
 Position GapContent.createPosition(int offset)
在内容中创建一个位置，使其在内容发生变化时能跟踪内容的更改。
 Position AbstractDocument.createPosition(int offs)
返回更改文档时，将跟踪更改的位置。
 Position AbstractDocument.Content.createPosition(int offset)
在内容中创建一个位置，该位置将在内容改变时跟踪更改。
 Position Document.createPosition(int offs)
此方法允许应用程序在字符内容序列中标记位置。
protected  int PasswordView.drawSelectedText(Graphics g, int x, int y, int p0, int p1)
将模型中给定的范围呈现为选定文本。
protected  int WrappedPlainView.drawSelectedText(Graphics g, int x, int y, int p0, int p1)
将模型中给定的范围呈现为所选文本。
protected  int PlainView.drawSelectedText(Graphics g, int x, int y, int p0, int p1)
将模型中给定的范围呈现为选定文本。
protected  int PasswordView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
将模型中给定的范围呈现为正常的未选定文本。
protected  int WrappedPlainView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
将模型中的给定范围呈现为普通未选择的文本。
protected  int PlainView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
将模型中给定的范围呈现为正常的未选定文本。
 void StringContent.getChars(int where, int len, Segment chars)
检索内容的某一部分，where ＋ len 必须 <= length()
 void GapContent.getChars(int where, int len, Segment chars)
检索部分内容。
 void AbstractDocument.Content.getChars(int where, int len, Segment txt)
获得字符序列并将其复制到 Segment 中。
protected  int ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x)
返回最接近 x 处的模型位置。
protected  int CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
返回光标的下一个可视位置，可以在东或在西。
protected  int CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
返回光标的下一个可视位置，可以在北也可以在南。
protected  int ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
在东或西方向返回光标的下一个可视位置。
 int GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
 int AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
 int CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
 int GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
 int View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
 int NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet)
返回从现在位置起的下一个放置插入符的可视位置。
static int Utilities.getNextWord(JTextComponent c, int offs)
确定针对给定位置的下一个单词开头。
static int Utilities.getPositionAbove(JTextComponent c, int offs, int x)
确定模型中离行上方给定的视图位置最近的位置。
static int Utilities.getPositionBelow(JTextComponent c, int offs, int x)
确定模型中离行下方给定的视图位置最近的位置。
static int Utilities.getPreviousWord(JTextComponent c, int offs)
确定针对给定位置的上一个单词开头。
static int Utilities.getRowEnd(JTextComponent c, int offs)
确定包含指定模型位置的行的结束行模型位置。
static int Utilities.getRowStart(JTextComponent c, int offs)
确定包含指定模型位置的行的起始行模型位置。
 String StringContent.getString(int where, int len)
检索内容的某一部分，where ＋ len 必须 <= length()。
 String GapContent.getString(int where, int len)
检索部分内容。
 String AbstractDocument.Content.getString(int where, int len)
获取序列中包含的字符串。
protected  String AbstractWriter.getText(Element elem)
返回与该元素关联的文本。
 String JTextComponent.getText(int offs, int len)
获取由组件表示的文本部分。
 String AbstractDocument.getText(int offset, int length)
从文档中获得文本序列。
 String Document.getText(int offset, int length)
获取文档中给定部分包含的文本。
 void AbstractDocument.getText(int offset, int length, Segment txt)
获取文档给定部分内包含的文本。
 void Document.getText(int offset, int length, Segment txt)
获取文档中给定部分包含的文本。
static int Utilities.getWordEnd(JTextComponent c, int offs)
确定针对给定位置的单词结尾。
static int Utilities.getWordStart(JTextComponent c, int offs)
确定针对给定模型位置的单词开头。
protected  void DefaultStyledDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data)
批量插入新元素。
 void DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr)
将文本插入指定的 Document 之前调用。
 UndoableEdit StringContent.insertString(int where, String str)
将字符串插入到内容中。
 UndoableEdit GapContent.insertString(int where, String str)
在内容中插入字符串。
 UndoableEdit AbstractDocument.Content.insertString(int where, String str)
向序列中插入一个字符串。
abstract  void DocumentFilter.FilterBypass.insertString(int offset, String string, AttributeSet attr)
插入指定的文本，绕过 DocumentFilter。
 void PlainDocument.insertString(int offs, String str, AttributeSet a)
向文档中插入某些内容。
 void AbstractDocument.insertString(int offs, String str, AttributeSet a)
将某些内容插入文档。
 void Document.insertString(int offset, String str, AttributeSet a)
插入内容字符串。
abstract  Shape GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Rectangle JTextComponent.modelToView(int pos)
将模型中给定位置转换为视图坐标系统中的位置。
 Shape CompositeView.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape View.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
 Shape View.modelToView(int pos, Shape a)
已过时。
 Shape AsyncBoxView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape BoxView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
 Shape ComponentView.modelToView(int pos, Shape a, Position.Bias b)
提供模型坐标空间到视图坐标空间的映射。
 Shape CompositeView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape GlyphView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape IconView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape PasswordView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape FieldView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape PlainView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract  Shape View.modelToView(int pos, Shape a, Position.Bias b)
为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
 void DefaultEditorKit.read(InputStream in, Document doc, int pos)
插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
abstract  void EditorKit.read(InputStream in, Document doc, int pos)
插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
 void DefaultEditorKit.read(Reader in, Document doc, int pos)
插入取自给定流的内容，它将被视为纯文本。
abstract  void EditorKit.read(Reader in, Document doc, int pos)
插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
 void DocumentFilter.remove(DocumentFilter.FilterBypass fb, int offset, int length)
移除指定 Document 中的指定区域之前调用。
abstract  void DocumentFilter.FilterBypass.remove(int offset, int length)
移除指定的文本区域，绕过 DocumentFilter。
 UndoableEdit StringContent.remove(int where, int nitems)
移除部分内容，其中 where ＋ nitems 必须 < length()。
 UndoableEdit GapContent.remove(int where, int nitems)
移除部分内容。
 void AbstractDocument.remove(int offs, int len)
从文档中移除某些内容。
 UndoableEdit AbstractDocument.Content.remove(int where, int nitems)
移除该序列的某一部分。
 void Document.remove(int offs, int len)
移除文档的部分内容。
 void DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs)
在替换指定的 Document 中的文本区域之前调用。
abstract  void DocumentFilter.FilterBypass.replace(int offset, int length, String string, AttributeSet attrs)
删除从 offset 到 offset + length 的文本区域，并用 text 替换。
 void AbstractDocument.replace(int offset, int length, String text, AttributeSet attrs)
删除从 offset 到 offset + length 的文本区域，并用 text 替换它。
protected  void AbstractWriter.text(Element elem)
写出文本。
protected abstract  void AbstractWriter.write()
需要由子类实现此抽象方法。
 void DefaultEditorKit.write(OutputStream out, Document doc, int pos, int len)
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
abstract  void EditorKit.write(OutputStream out, Document doc, int pos, int len)
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
 void DefaultEditorKit.write(Writer out, Document doc, int pos, int len)
将取自文档的内容以纯文本格式写入给定流。
abstract  void EditorKit.write(Writer out, Document doc, int pos, int len)
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

javax.swing.text.html 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.text.html 中的方法
protected void | HTMLWriter.comment(Element elem) 写出注释。
protected void | HTMLWriter.emptyTag(Element elem) 写出所有空元素（没有对应结束标记的所有标记）。
void | HTMLDocument.HTMLReader.flush() 在 reader 上调用的最后一个方法。
void | HTMLEditorKit.ParserCallback.flush()
protected void | HTMLDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data) 批量插入新元素。
void | HTMLDocument.insertAfterEnd(Element elem, String htmlText) 将指定为字符串的 HTML 插入给定元素的起始处之后。
void | HTMLDocument.insertAfterStart(Element elem, String htmlText) 将指定为字符串的 HTML 插入元素的起始处。
void | HTMLDocument.insertBeforeEnd(Element elem, String htmlText) 将指定为字符串的 HTML 插入元素的结尾处。
void | HTMLDocument.insertBeforeStart(Element elem, String htmlText) 将指定为字符串的 HTML 插入给定元素的起始处之前。
void | HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag) 将 HTML 插入现有文档。
Shape | ImageView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
void | HTMLEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容。
void | HTMLDocument.setInnerHTML(Element elem, String htmlText) 用指定为 HTML 字符串的内容替换给定元素的子元素。
void | HTMLDocument.setOuterHTML(Element elem, String htmlText) 用指定为 HTML 字符串的内容替换父元素中的给定元素。
protected void | HTMLWriter.startTag(Element elem) 写出元素的开始标记。
protected void | HTMLWriter.text(Element elem) 写出文本。
protected void | MinimalHTMLWriter.text(Element elem) 写出文本。
protected void | HTMLWriter.textAreaContent(AttributeSet attr) 写出 TEXTAREA 表单元素中所包含的文本。
void | HTMLWriter.write() 对 Element 树进行迭代并控制所有标记及其属性的写出。
void | MinimalHTMLWriter.write() 从 StyledDocument 生成 HTML 输出。
void | HTMLEditorKit.write(Writer out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。
protected void | MinimalHTMLWriter.writeBody() 对文档中的元素进行迭代，并基于元素是分支元素还是叶元素来处理它们。
protected void | MinimalHTMLWriter.writeContent(Element elem, boolean needsIndenting) 以与 HTML 兼容的方式写出属性集。

javax.swing.text.rtf 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.text.rtf 中的方法
void | RTFEditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。
void | RTFEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，该内容将被视为纯文本。
void | RTFEditorKit.write(OutputStream out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。
void | RTFEditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容作为纯文本写入给定的流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.BoxView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.BoxView
的使用

使用 BoxView 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 BoxView 的使用

javax.swing.text 中 BoxView 的子类
class | FlowView 试图将其子级流入某个部分受约束的空间的视图。
class | ParagraphView 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
class | TableView 为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。
class | TableView.TableRow 以行为中心的表格中的行视图。
class | WrappedPlainView 进行换行的纯文本（仅有一种字体和颜色的文本）视图。
class | ZoneView ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

javax.swing.text.html 中 BoxView 的使用

javax.swing.text.html 中 BoxView 的子类
class | BlockView 用来显示具有 CSS 规范的块（作为一个框）的视图实现。
class | ListView 用于显示 html 列表的视图实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.Caret 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Caret
的使用

使用 Caret 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 Caret 的使用

实现 Caret 的 javax.swing.plaf.basic 中的类
static class BasicTextUI.BasicCaret

返回 Caret 的 javax.swing.plaf.basic 中的方法
protected  Caret BasicTextUI.createCaret()
创建用于插入符的对象。

javax.swing.text 中 Caret 的使用

实现 Caret 的 javax.swing.text 中的类
 class DefaultCaret
插入符的默认实现。

返回 Caret 的 javax.swing.text 中的方法
Caret | DefaultEditorKit.createCaret() 获取能在由关联的 ViewFactory 生成的视图中导航的插入符。
abstract Caret | EditorKit.createCaret() 获取能在由关联的 ViewFactory 生成的视图中导航的插入符。
abstract Caret | NavigationFilter.FilterBypass.getCaret() 返回不断变化的 Caret。
Caret | JTextComponent.getCaret() 获取允许在视图上进行面向文本导航的插入符。

参数类型为 Caret 的 javax.swing.text 中的方法
 void JTextComponent.setCaret(Caret c)
设置要使用的插入符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.ChangedCharSetException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.ChangedCharSetException
的使用

使用 ChangedCharSetException 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 ChangedCharSetException 的使用

抛出 ChangedCharSetException 的 javax.swing.text.html.parser 中的方法
protected void | DocumentParser.handleEmptyTag(TagElement tag) 处理空标记。
protected void | Parser.handleEmptyTag(TagElement tag) 在遇到空标记时调用。
protected void | Parser.startTag(TagElement tag) 处理开始标记。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.ComponentView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.ComponentView
的使用

使用 ComponentView 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 ComponentView 的使用

javax.swing.text.html 中 ComponentView 的子类
class | FormView 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
class | ObjectView 实现 <object> 元素视图接口的组件装饰符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.CompositeView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.CompositeView
的使用

使用 CompositeView 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 CompositeView 的使用

javax.swing.text 中 CompositeView 的子类
class | BoxView 一个视图，它通过沿某轴平铺将其子级排列到框形状中。
class | FlowView 试图将其子级流入某个部分受约束的空间的视图。
class | ParagraphView 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
class | TableView 为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。
class | TableView.TableRow 以行为中心的表格中的行视图。
class | WrappedPlainView 进行换行的纯文本（仅有一种字体和颜色的文本）视图。
class | ZoneView ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

javax.swing.text.html 中 CompositeView 的使用

javax.swing.text.html 中 CompositeView 的子类
class | BlockView 用来显示具有 CSS 规范的块（作为一个框）的视图实现。
class | ListView 用于显示 html 列表的视图实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DateFormatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DateFormatter
的使用

没有 javax.swing.text.DateFormatter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultCaret 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultCaret
的使用

使用 DefaultCaret 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 DefaultCaret 的使用

javax.swing.plaf.basic 中 DefaultCaret 的子类
static class BasicTextUI.BasicCaret

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit
的使用

使用 DefaultEditorKit 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing.text 中 DefaultEditorKit 的使用

javax.swing.text 中 DefaultEditorKit 的子类
 class StyledEditorKit
这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。

javax.swing.text.html 中 DefaultEditorKit 的使用

javax.swing.text.html 中 DefaultEditorKit 的子类
 class HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。

javax.swing.text.rtf 中 DefaultEditorKit 的使用

javax.swing.text.rtf 中 DefaultEditorKit 的子类
 class RTFEditorKit
这是对 RTF 编辑功能的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.BeepAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.BeepAction
的使用

没有 javax.swing.text.DefaultEditorKit.BeepAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.CopyAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.CopyAction
的使用

没有 javax.swing.text.DefaultEditorKit.CopyAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.CutAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.CutAction
的使用

没有 javax.swing.text.DefaultEditorKit.CutAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
的使用

没有 javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.InsertBreakAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.InsertBreakAction
的使用

没有 javax.swing.text.DefaultEditorKit.InsertBreakAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.InsertContentAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.InsertContentAction
的使用

没有 javax.swing.text.DefaultEditorKit.InsertContentAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.InsertTabAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.InsertTabAction
的使用

没有 javax.swing.text.DefaultEditorKit.InsertTabAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.PasteAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.PasteAction
的使用

没有 javax.swing.text.DefaultEditorKit.PasteAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultFormatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultFormatter
的使用

使用 DefaultFormatter 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 DefaultFormatter 的使用

javax.swing.text 中 DefaultFormatter 的子类
class | DateFormatter DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
class | InternationalFormatter InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
class | MaskFormatter MaskFormatter 用于格式化和编辑字符串。
class | NumberFormatter 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultFormatterFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultFormatterFactory
的使用

没有 javax.swing.text.DefaultFormatterFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultHighlighter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultHighlighter
的使用

使用 DefaultHighlighter 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 DefaultHighlighter 的使用

javax.swing.plaf.basic 中 DefaultHighlighter 的子类
static class BasicTextUI.BasicHighlighter

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
的使用

没有 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultStyledDocument 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultStyledDocument
的使用

使用 DefaultStyledDocument 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 DefaultStyledDocument 的使用

javax.swing.text.html 中 DefaultStyledDocument 的子类
 class HTMLDocument
对 HTML 进行建模的文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
的使用

没有 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultStyledDocument.ElementBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultStyledDocument.ElementBuffer
的使用

使用 DefaultStyledDocument.ElementBuffer 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 DefaultStyledDocument.ElementBuffer 的使用

声明为 DefaultStyledDocument.ElementBuffer 的 javax.swing.text 中的字段
protected  DefaultStyledDocument.ElementBuffer DefaultStyledDocument.buffer

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultStyledDocument.ElementSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultStyledDocument.ElementSpec
的使用

使用 DefaultStyledDocument.ElementSpec 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 DefaultStyledDocument.ElementSpec 的使用

参数类型为 DefaultStyledDocument.ElementSpec 的 javax.swing.text 中的方法
protected void | DefaultStyledDocument.create(DefaultStyledDocument.ElementSpec[] data) 初始化文档，以反映给定元素结构（即由 getDefaultRootElement 方法报告的结构）。
protected void | DefaultStyledDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data) 批量插入新元素。
void | DefaultStyledDocument.ElementBuffer.insert(int offset, int length, DefaultStyledDocument.ElementSpec[] data, AbstractDocument.DefaultDocumentEvent de) 插入新内容。
protected void | DefaultStyledDocument.ElementBuffer.insertUpdate(DefaultStyledDocument.ElementSpec[] data) 向文档添加更新。

javax.swing.text.html 中 DefaultStyledDocument.ElementSpec 的使用

类型参数类型为 DefaultStyledDocument.ElementSpec 的 javax.swing.text.html 中的字段
protected  Vector<DefaultStyledDocument.ElementSpec> HTMLDocument.HTMLReader.parseBuffer

参数类型为 DefaultStyledDocument.ElementSpec 的 javax.swing.text.html 中的方法
protected void | HTMLDocument.create(DefaultStyledDocument.ElementSpec[] data) 替换具有给定元素规范的文档内容。
protected void | HTMLDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data) 批量插入新元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultStyledDocument.SectionElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultStyledDocument.SectionElement
的使用

没有 javax.swing.text.DefaultStyledDocument.SectionElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DefaultTextUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultTextUI
的使用

没有 javax.swing.text.DefaultTextUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.Document 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Document
的使用

使用 Document 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing 中 Document 的使用

返回 Document 的 javax.swing 中的方法
protected Document | JTextArea.createDefaultModel() 如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。
protected Document | JTextField.createDefaultModel() 如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。

参数类型为 Document 的 javax.swing 中的方法
void | JFormattedTextField.setDocument(Document doc) 将该编辑器与某个文本文档关联。
void | JTextPane.setDocument(Document doc) 将编辑器与一个文本文档关联。
void | JTextField.setDocument(Document doc) 将编辑器与一个文本文档关联。

参数类型为 Document 的 javax.swing 中的构造方法
JPasswordField(Document doc, String txt, int columns)
构造一个使用给定文本存储模型和给定列数的新 JPasswordField。
JTextArea(Document doc)
构造新的 JTextArea，使其具有给定的文档模型，所有其他参数均默认为 (null, 0, 0)。
JTextArea(Document doc, String text, int rows, int columns)
构造具有指定行数和列数以及给定模型的新的 JTextArea。
JTextField(Document doc, String text, int columns)
构造一个新的 JTextField，它使用给定文本存储模型和给定的列数。

javax.swing.event 中 Document 的使用

返回 Document 的 javax.swing.event 中的方法
 Document DocumentEvent.getDocument()
获得发起更改事件的文档。

javax.swing.text 中 Document 的使用

javax.swing.text 中 Document 的子接口
 interface StyledDocument
用作通用样式化文档的接口。

实现 Document 的 javax.swing.text 中的类
class | AbstractDocument 文档接口的实现，可作为实现各种文档的基础。
class | DefaultStyledDocument 能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。
class | PlainDocument 维护无任何字符属性的普通文档。

返回 Document 的 javax.swing.text 中的方法
Document | StyledEditorKit.createDefaultDocument() 创建一个适合此编辑器类型的未初始化文本存储模型。
Document | DefaultEditorKit.createDefaultDocument() 创建一个适合此编辑器类型的未初始化文本存储模型 (PlainDocument)。
abstract Document | EditorKit.createDefaultDocument() 创建一个适合此编辑器类型的未初始化的文本存储模型。
protected Document | AbstractWriter.getDocument() 获取文档。
abstract Document | DocumentFilter.FilterBypass.getDocument() 返回发生变化的 Document。
Document | View.getDocument() 获取与视图关联的模型。
Document | JTextComponent.getDocument() 获取与编辑器关联的模型。
Document | AbstractDocument.AbstractElement.getDocument() 获得基础模型。
Document | AbstractDocument.DefaultDocumentEvent.getDocument() 获得发起更改事件的文档。
Document | Element.getDocument() 获取与此元素关联的文档。

参数类型为 Document 的 javax.swing.text 中的方法
void | DefaultEditorKit.read(InputStream in, Document doc, int pos) 插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
abstract void | EditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
void | DefaultEditorKit.read(Reader in, Document doc, int pos) 插入取自给定流的内容，它将被视为纯文本。
abstract void | EditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
void | JTextComponent.setDocument(Document doc) 将编辑器与文本文档关联。
void | DefaultEditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
abstract void | EditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
void | DefaultEditorKit.write(Writer out, Document doc, int pos, int len) 将取自文档的内容以纯文本格式写入给定流。
abstract void | EditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

参数类型为 Document 的 javax.swing.text 中的构造方法
AbstractWriter(Writer w, Document doc)
创建新的 AbstractWriter。
AbstractWriter(Writer w, Document doc, int pos, int len)
创建新的 AbstractWriter。
ElementIterator(Document document)
创建新的 ElementIterator。

javax.swing.text.html 中 Document 的使用

实现 Document 的 javax.swing.text.html 中的类
 class HTMLDocument
对 HTML 进行建模的文档。

返回 Document 的 javax.swing.text.html 中的方法
 Document HTMLEditorKit.createDefaultDocument()
创建一个适合此编辑器类型的未初始化文本存储模型。

参数类型为 Document 的 javax.swing.text.html 中的方法
void | HTMLEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容。
void | HTMLEditorKit.write(Writer out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。

javax.swing.text.rtf 中 Document 的使用

参数类型为 Document 的 javax.swing.text.rtf 中的方法
void | RTFEditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。
void | RTFEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，该内容将被视为纯文本。
void | RTFEditorKit.write(OutputStream out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。
void | RTFEditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容作为纯文本写入给定的流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DocumentFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DocumentFilter
的使用

使用 DocumentFilter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 DocumentFilter 的使用

返回 DocumentFilter 的 javax.swing 中的方法
protected  DocumentFilter JFormattedTextField.AbstractFormatter.getDocumentFilter()
如果想要提供某个 DocumentFilter 以限制输入内容，则应进行子类化和重写。

javax.swing.text 中 DocumentFilter 的使用

返回 DocumentFilter 的 javax.swing.text 中的方法
protected DocumentFilter | DefaultFormatter.getDocumentFilter() 返回用于限制放置到 JFormattedTextField 中的字符的 DocumentFilter。
DocumentFilter | AbstractDocument.getDocumentFilter() 返回负责进行插入/移除过滤的 DocumentFilter。

参数类型为 DocumentFilter 的 javax.swing.text 中的方法
 void AbstractDocument.setDocumentFilter(DocumentFilter filter)
设置 DocumentFilter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.DocumentFilter.FilterBypass 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DocumentFilter.FilterBypass
的使用

使用 DocumentFilter.FilterBypass 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 DocumentFilter.FilterBypass 的使用

参数类型为 DocumentFilter.FilterBypass 的 javax.swing.text 中的方法
void | DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr) 将文本插入指定的 Document 之前调用。
void | DocumentFilter.remove(DocumentFilter.FilterBypass fb, int offset, int length) 移除指定 Document 中的指定区域之前调用。
void | DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs) 在替换指定的 Document 中的文本区域之前调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.EditorKit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.EditorKit
的使用

使用 EditorKit 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing 中 EditorKit 的使用

返回 EditorKit 的 javax.swing 中的方法
protected EditorKit | JEditorPane.createDefaultEditorKit() 首次创建组件时，创建默认的编辑器工具包 (PlainEditorKit)。
protected EditorKit | JTextPane.createDefaultEditorKit() 创建默认使用的 EditorKit。
static EditorKit | JEditorPane.createEditorKitForContentType(String type) 根据默认的编辑器工具包注册表为给定的类型创建处理程序。
EditorKit | JEditorPane.getEditorKit() 获取用于处理内容的、当前已安装的工具包。
EditorKit | JEditorPane.getEditorKitForContentType(String type) 获取用于给定内容类型的编辑器工具包。

参数类型为 EditorKit 的 javax.swing 中的方法
void | JEditorPane.setEditorKit(EditorKit kit) 设置当前为处理内容而安装的工具包。
void | JTextPane.setEditorKit(EditorKit kit) 设置当前安装的用于内容处理的工具包。
void | JEditorPane.setEditorKitForContentType(String type, EditorKit k) 直接设置用于给定类型的编辑器工具包。

javax.swing.plaf 中 EditorKit 的使用

返回 EditorKit 的 javax.swing.plaf 中的方法
abstract  EditorKit TextUI.getEditorKit(JTextComponent t)
获取为要编辑的文档类型设置策略的服务绑定。

javax.swing.plaf.basic 中 EditorKit 的使用

返回 EditorKit 的 javax.swing.plaf.basic 中的方法
EditorKit | BasicEditorPaneUI.getEditorKit(JTextComponent tc) 获取 UI 的 EditorKit。
EditorKit | BasicTextUI.getEditorKit(JTextComponent tc) 获取 UI 的 EditorKit。

javax.swing.plaf.multi 中 EditorKit 的使用

返回 EditorKit 的 javax.swing.plaf.multi 中的方法
 EditorKit MultiTextUI.getEditorKit(JTextComponent a)
在由此对象处理的每个 UI 上调用 getEditorKit 方法。

javax.swing.text 中 EditorKit 的使用

javax.swing.text 中 EditorKit 的子类
class | DefaultEditorKit 这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
class | StyledEditorKit 这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。

javax.swing.text.html 中 EditorKit 的使用

javax.swing.text.html 中 EditorKit 的子类
 class HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。

javax.swing.text.rtf 中 EditorKit 的使用

javax.swing.text.rtf 中 EditorKit 的子类
 class RTFEditorKit
这是对 RTF 编辑功能的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.Element 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Element
的使用

使用 Element 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 Element 的使用

参数类型为 Element 的 javax.swing 中的构造方法
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element e)

javax.swing.event 中 Element 的使用

返回 Element 的 javax.swing.event 中的方法
Element[] | DocumentEvent.ElementChange.getChildrenAdded() 获得添加到给定父元素中的子元素。
Element[] | DocumentEvent.ElementChange.getChildrenRemoved() 获得从给定父元素中移除的子元素。
Element | DocumentEvent.ElementChange.getElement() 返回所表示的元素。
Element | HyperlinkEvent.getSourceElement() 返回对应于事件源的 Element。

参数类型为 Element 的 javax.swing.event 中的方法
 DocumentEvent.ElementChange DocumentEvent.getChange(Element elem)
获得给定元素的更改信息。

参数类型为 Element 的 javax.swing.event 中的构造方法
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。

javax.swing.plaf.basic 中 Element 的使用

参数类型为 Element 的 javax.swing.plaf.basic 中的方法
View | BasicPasswordFieldUI.create(Element elem) 创建元素的视图 (PasswordView)。
View | BasicTextAreaUI.create(Element elem) 创建元素的视图。
View | BasicTextFieldUI.create(Element elem) 基于元素创建视图 (FieldView)。
View | BasicTextUI.create(Element elem) 创建元素的视图。
View | BasicTextUI.create(Element elem, int p0, int p1) 创建元素的视图。

javax.swing.text 中 Element 的使用

实现 Element 的 javax.swing.text 中的类
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。

声明为 Element 的 javax.swing.text 中的字段
protected  Element DefaultStyledDocument.AttributeUndoableEdit.element

返回 Element 的 javax.swing.text 中的方法
Element | DefaultStyledDocument.ElementBuffer.clone(Element parent, Element clonee) 创建此元素的一个副本，使其具有不同的父级。
protected Element | AbstractDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可包含其他元素。
protected Element | AbstractDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建文档叶元素。
Element | ElementIterator.current() 获取当前 Element。
Element | ElementIterator.first() 获取第一个元素。
Element | AbstractDocument.getBidiRootElement() 返回此文档双向结构的根元素。
Element | StyledEditorKit.getCharacterAttributeRun() 获取表示该插入符处当前运行的字符属性的元素。
Element | DefaultStyledDocument.getCharacterElement(int pos) 获得基于某个位置的字符元素。
Element | StyledDocument.getCharacterElement(int pos) 获取表示文档中给定偏移量处字符的元素。
Element[] | AbstractDocument.ElementEdit.getChildrenAdded() 获得已添加的子元素列表。
Element[] | AbstractDocument.ElementEdit.getChildrenRemoved() 获得已移除的子元素列表。
Element | DefaultStyledDocument.getDefaultRootElement() 获得默认的根元素。
Element | PlainDocument.getDefaultRootElement() 获取文档模型的默认根元素。
abstract Element | AbstractDocument.getDefaultRootElement() 返回视图赖依存在的根元素，除非提供了向元素结构指派视图的其他机制。
Element | Document.getDefaultRootElement() 返回视图赖以存在的根元素，除非提供了向元素结构指定视图的其他机制。
Element | View.getElement() 获取此视图所映射的主题的结构化部分。
Element | AbstractDocument.ElementEdit.getElement() 返回基础元素。
abstract Element | AbstractDocument.AbstractElement.getElement(int index) 获取子元素。
Element | AbstractDocument.BranchElement.getElement(int index) 获得一个子元素。
Element | AbstractDocument.LeafElement.getElement(int index) 获得一个子元素。
Element | Element.getElement(int index) 获取给定索引处的子元素。
Element | DefaultStyledDocument.getParagraphElement(int pos) 获得位于偏移量 pos 的段落元素。
Element | StyledDocument.getParagraphElement(int pos) 获取表示包含文档中给定偏移量的段落的元素。
Element | PlainDocument.getParagraphElement(int pos) 获取包含给定位置的段落元素。
abstract Element | AbstractDocument.getParagraphElement(int pos) 获得包含给定位置的段落元素。
static Element | Utilities.getParagraphElement(JTextComponent c, int offs) 确定某个段落/行要使用的元素。
Element | AbstractDocument.AbstractElement.getParentElement() 获取该元素的父级。
Element | Element.getParentElement() 获得父元素。
Element | DefaultStyledDocument.ElementBuffer.getRootElement() 获得根元素。
Element[] | AbstractDocument.getRootElements() 获得已定义的所有根元素。
Element[] | Document.getRootElements() 返回定义的所有根元素。
Element | ElementIterator.next() 获取下一个 Element。
Element | AbstractDocument.BranchElement.positionToElement(int pos) 获得包含给定模型位置的子元素。
Element | ElementIterator.previous() 获取前一个 Element。

参数类型为 Element 的 javax.swing.text 中的方法
Element | DefaultStyledDocument.ElementBuffer.clone(Element parent, Element clonee) 创建此元素的一个副本，使其具有不同的父级。
View | ViewFactory.create(Element elem) 根据给定的文档的结构化元素创建一个视图。
protected Element | AbstractDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可包含其他元素。
protected void | StyledEditorKit.createInputAttributes(Element element, MutableAttributeSet set) 将 element 的 AttributeSet 键/值复制到 set 中。
protected Element | AbstractDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建文档叶元素。
protected TableView.TableCell | TableView.createTableCell(Element elem) 已过时。 现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。
protected TableView.TableRow | TableView.createTableRow(Element elem) 创建新的表格行。
DocumentEvent.ElementChange | AbstractDocument.DefaultDocumentEvent.getChange(Element elem) 获得元素的更改。
protected String | AbstractWriter.getText(Element elem) 返回与该元素关联的文本。
protected boolean | AbstractWriter.inRange(Element next) 此方法确定当前元素是否位于指定的范围内。
void | AbstractDocument.BranchElement.replace(int offset, int length, Element[] elems) 使用新的元素集替换该内容。
protected void | AbstractWriter.text(Element elem) 写出文本。

参数类型为 Element 的 javax.swing.text 中的构造方法
AbstractDocument.AbstractElement(Element parent, AttributeSet a)
创建新的 AbstractElement。
AbstractDocument.BranchElement(Element parent, AttributeSet a)
构造最初不包含任何子元素的复合元素。
AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
构造一个编辑记录。
AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
构造一个编辑记录。
AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
构造一个编辑记录。
AbstractDocument.LeafElement(Element parent, AttributeSet a, int offs0, int offs1)
构造一个表示文档中内容的元素（没有子元素）。
AbstractWriter(Writer w, Element root)
创建新的 AbstractWriter。
AbstractWriter(Writer w, Element root, int pos, int len)
创建新的 AbstractWriter。
AsyncBoxView(Element elem, int axis)
构造执行异步布局处理的 BoxView。
BoxView(Element elem, int axis)
构造一个 BoxView。
ComponentView(Element elem)
创建新的 ComponentView 对象。
CompositeView(Element elem)
为给定元素构造一个 CompositeView。
DefaultStyledDocument.AttributeUndoableEdit(Element element, AttributeSet newAttributes, boolean isReplacing)
DefaultStyledDocument.ElementBuffer(Element root)
创建新的 ElementBuffer。
ElementIterator(Element root)
创建新的 ElementIterator。
FieldView(Element elem)
构造包装了元素的新 FieldView。
FlowView(Element elem, int axis)
构造给定元素的 FlowView。
GlyphView(Element elem)
构造在元素上包装的新视图。
IconView(Element elem)
创建表示元素的新图标视图。
LabelView(Element elem)
构造在元素上包装的新视图。
ParagraphView(Element elem)
创建给定元素的 ParagraphView。
PasswordView(Element elem)
构造在元素上包装的新视图。
PlainView(Element elem)
构造在元素上包装的新 PlainView。
TableView.TableCell(Element elem)
已过时。 构造给定元素的 TableCell。
TableView.TableRow(Element elem)
构造给定元素的 TableView。
TableView(Element elem)
针对给定的元素构造一个 TableView。
View(Element elem)
创建一个新的 View 对象。
WrappedPlainView(Element elem)
创建一个新的 WrappedPlainView。
WrappedPlainView(Element elem, boolean wordWrap)
创建一个新的 WrappedPlainView。
ZoneView(Element elem, int axis)
构造一个 ZoneView。

javax.swing.text.html 中 Element 的使用

实现 Element 的 javax.swing.text.html 中的类
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

返回 Element 的 javax.swing.text.html 中的方法
protected Element | HTMLDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可以包含其他元素。
protected Element | HTMLDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建直接表示文本的文档叶元素（没有任何子级）。
protected Element | HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回在 offset 处与 tag 匹配的最深的元素。
Element | HTMLDocument.getElement(Element e, Object attribute, Object value) 返回 e（它包含具有值 value 的属性 attribute）的子元素，如果未找到，则返回 null。
Element | HTMLDocument.getElement(String id) 返回具有给定 id Attribute 的元素。
protected Element[] | HTMLEditorKit.HTMLTextAction.getElementsAt(HTMLDocument doc, int offset) 返回包含 offset 的 Elements 数组。

参数类型为 Element 的 javax.swing.text.html 中的方法
protected void | HTMLWriter.comment(Element elem) 写出注释。
View | HTMLEditorKit.HTMLFactory.create(Element elem) 根据元素创建视图。
protected Element | HTMLDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可以包含其他元素。
protected void | HTMLEditorKit.createInputAttributes(Element element, MutableAttributeSet set) 将 element 的 AttributeSet 键/值复制到 set 中。
protected Element | HTMLDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建直接表示文本的文档叶元素（没有任何子级）。
protected void | HTMLWriter.emptyTag(Element elem) 写出所有空元素（没有对应结束标记的所有标记）。
protected void | HTMLWriter.endTag(Element elem) 写出元素的结束标记。
Element | HTMLDocument.getElement(Element e, Object attribute, Object value) 返回 e（它包含具有值 value 的属性 attribute）的子元素，如果未找到，则返回 null。
Style | StyleSheet.getRule(HTML.Tag t, Element e) 获取用来呈现给定类型的 HTML 标记的样式。
void | HTMLDocument.insertAfterEnd(Element elem, String htmlText) 将指定为字符串的 HTML 插入给定元素的起始处之后。
void | HTMLDocument.insertAfterStart(Element elem, String htmlText) 将指定为字符串的 HTML 插入元素的起始处。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 当在边界上插入时调用。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
void | HTMLDocument.insertBeforeEnd(Element elem, String htmlText) 将指定为字符串的 HTML 插入元素的结尾处。
void | HTMLDocument.insertBeforeStart(Element elem, String htmlText) 将指定为字符串的 HTML 插入给定元素的起始处之前。
protected boolean | MinimalHTMLWriter.isText(Element elem) 如果元素是文本元素，则返回 true。
void | HTMLDocument.setInnerHTML(Element elem, String htmlText) 用指定为 HTML 字符串的内容替换给定元素的子元素。
void | HTMLDocument.setOuterHTML(Element elem, String htmlText) 用指定为 HTML 字符串的内容替换父元素中的给定元素。
protected void | HTMLWriter.startTag(Element elem) 写出元素的开始标记。
protected boolean | HTMLWriter.synthesizedElement(Element elem) 如果元素是合成元素，则返回 true。
protected void | HTMLWriter.text(Element elem) 写出文本。
protected void | MinimalHTMLWriter.text(Element elem) 写出文本。
protected void | MinimalHTMLWriter.writeComponent(Element elem) 负责处理 Component Elements；有意不实现它。
protected void | MinimalHTMLWriter.writeContent(Element elem, boolean needsIndenting) 以与 HTML 兼容的方式写出属性集。
protected void | MinimalHTMLWriter.writeImage(Element elem) 负责处理 Icon Elements；有意不实现它。
protected void | MinimalHTMLWriter.writeLeaf(Element elem) 负责写出其他非文本叶元素。
protected void | MinimalHTMLWriter.writeStartParagraph(Element elem) 发出段落的开始标记。

参数类型为 Element 的 javax.swing.text.html 中的构造方法
BlockView(Element elem, int axis)
创建表示 html 框的新视图。
FormView(Element elem)
创建新的 FormView 对象。
HTMLDocument.BlockElement(Element parent, AttributeSet a)
构造初始不包含子元素的复合元素。
HTMLDocument.RunElement(Element parent, AttributeSet a, int offs0, int offs1)
构造表示文档内部（没有子级）内容的元素。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
ImageView(Element elem)
创建表示 IMG 元素的新视图。
InlineView(Element elem)
构造在元素上包装的新视图。
ListView(Element elem)
创建表示列表元素的新视图。
ObjectView(Element elem)
创建新的 ObjectView 对象。
ParagraphView(Element elem)
构造给定元素的 ParagraphView。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.ElementIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.ElementIterator
的使用

使用 ElementIterator 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 ElementIterator 的使用

返回 ElementIterator 的 javax.swing.text 中的方法
protected  ElementIterator AbstractWriter.getElementIterator()
获取 ElementIterator。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.FieldView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.FieldView
的使用

使用 FieldView 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 FieldView 的使用

javax.swing.text 中 FieldView 的子类
 class PasswordView
实现适用于 JPasswordField UI 实现的视图。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.FlowView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.FlowView
的使用

使用 FlowView 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 FlowView 的使用

javax.swing.text 中 FlowView 的子类
 class ParagraphView
存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。

参数类型为 FlowView 的 javax.swing.text 中的方法
protected void | FlowView.FlowStrategy.adjustRow(FlowView fv, int rowIndex, int desiredSpan, int x) 如有可能，调整给定行以使其适合布局区域。
void | FlowView.FlowStrategy.changedUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
protected View | FlowView.FlowStrategy.createView(FlowView fv, int startOffset, int spanLeft, int rowIndex) 创建一个可用于表示流的当前片段的视图。
protected View | FlowView.FlowStrategy.getLogicalView(FlowView fv) 此方法提供访问 FlowView 的逻辑视图的流策略。
void | FlowView.FlowStrategy.insertUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | FlowView.FlowStrategy.layout(FlowView fv) 更新给定 FlowView 的流。
protected int | FlowView.FlowStrategy.layoutRow(FlowView fv, int rowIndex, int pos) 创建一个符合该行布局区域的视图的行。
void | FlowView.FlowStrategy.removeUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知已从文档中此给定流视图负责的某个位置移除某些内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.FlowView.FlowStrategy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.FlowView.FlowStrategy
的使用

使用 FlowView.FlowStrategy 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 FlowView.FlowStrategy 的使用

声明为 FlowView.FlowStrategy 的 javax.swing.text 中的字段
protected  FlowView.FlowStrategy FlowView.strategy
保持流更新的行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.GapContent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.GapContent
的使用

没有 javax.swing.text.GapContent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.GlyphView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.GlyphView
的使用

使用 GlyphView 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 GlyphView 的使用

javax.swing.text 中 GlyphView 的子类
 class LabelView
LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。

参数类型为 GlyphView 的 javax.swing.text 中的方法
abstract float | GlyphView.GlyphPainter.getAscent(GlyphView v)
abstract int | GlyphView.GlyphPainter.getBoundedPosition(GlyphView v, int p0, float x, float len) 确定表示符合给定区域的最大 advance 的模型位置。
abstract float | GlyphView.GlyphPainter.getDescent(GlyphView v)
abstract float | GlyphView.GlyphPainter.getHeight(GlyphView v)
int | GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
GlyphView.GlyphPainter | GlyphView.GlyphPainter.getPainter(GlyphView v, int p0, int p1) 创建用于给定 GlyphView 的 painter。
abstract float | GlyphView.GlyphPainter.getSpan(GlyphView v, int p0, int p1, TabExpander e, float x) 确定给定开始位置（相对于选项卡扩展而言）的字形区域。
abstract Shape | GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract void | GlyphView.GlyphPainter.paint(GlyphView v, Graphics g, Shape a, int p0, int p1) 绘制表示给定范围的字形。
abstract int | GlyphView.GlyphPainter.viewToModel(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。

javax.swing.text.html 中 GlyphView 的使用

javax.swing.text.html 中 GlyphView 的子类
 class InlineView
显示基于 css 属性的 inline element 样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.GlyphView.GlyphPainter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.GlyphView.GlyphPainter
的使用

使用 GlyphView.GlyphPainter 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 GlyphView.GlyphPainter 的使用

返回 GlyphView.GlyphPainter 的 javax.swing.text 中的方法
GlyphView.GlyphPainter | GlyphView.getGlyphPainter() 获取当前安装的字形 painter。
GlyphView.GlyphPainter | GlyphView.GlyphPainter.getPainter(GlyphView v, int p0, int p1) 创建用于给定 GlyphView 的 painter。

参数类型为 GlyphView.GlyphPainter 的 javax.swing.text 中的方法
 void GlyphView.setGlyphPainter(GlyphView.GlyphPainter p)
设置用于呈现字形的 painter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.Highlighter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Highlighter
的使用

使用 Highlighter 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 Highlighter 的使用

实现 Highlighter 的 javax.swing.plaf.basic 中的类
static class BasicTextUI.BasicHighlighter

返回 Highlighter 的 javax.swing.plaf.basic 中的方法
protected  Highlighter BasicTextUI.createHighlighter()
创建用于添加高亮显示的对象。

javax.swing.text 中 Highlighter 的使用

实现 Highlighter 的 javax.swing.text 中的类
class | DefaultHighlighter 实现 Highlighter 接口。
class | LayeredHighlighter

返回 Highlighter 的 javax.swing.text 中的方法
 Highlighter JTextComponent.getHighlighter()
获取负责进行高亮显示的对象。

参数类型为 Highlighter 的 javax.swing.text 中的方法
 void JTextComponent.setHighlighter(Highlighter h)
设置要使用的 highlighter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.Highlighter.Highlight 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Highlighter.Highlight
的使用

使用 Highlighter.Highlight 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 Highlighter.Highlight 的使用

返回 Highlighter.Highlight 的 javax.swing.text 中的方法
Highlighter.Highlight[] | DefaultHighlighter.getHighlights() 制作高亮显示的副本。
Highlighter.Highlight[] | Highlighter.getHighlights() 获取高亮显示的当前列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.Highlighter.HighlightPainter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Highlighter.HighlightPainter
的使用

使用 Highlighter.HighlightPainter 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 Highlighter.HighlightPainter 的使用

实现 Highlighter.HighlightPainter 的 javax.swing.text 中的类
static class | DefaultHighlighter.DefaultHighlightPainter 只高亮显示用纯色填充高亮显示区域的 painter。
static class | LayeredHighlighter.LayerPainter 分层的高亮显示渲染器。

返回 Highlighter.HighlightPainter 的 javax.swing.text 中的方法
Highlighter.HighlightPainter | Highlighter.Highlight.getPainter() 获取 highlighter 的 painter。
protected Highlighter.HighlightPainter | DefaultCaret.getSelectionPainter() 获取此 Highlighter 的 painter。

参数类型为 Highlighter.HighlightPainter 的 javax.swing.text 中的方法
Object | DefaultHighlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p) 向视图添加高亮显示。
Object | Highlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p) 向视图添加高亮显示。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.IconView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.IconView
的使用

没有 javax.swing.text.IconView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.InternationalFormatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.InternationalFormatter
的使用

使用 InternationalFormatter 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 InternationalFormatter 的使用

javax.swing.text 中 InternationalFormatter 的子类
class | DateFormatter DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
class | NumberFormatter 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.JTextComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.JTextComponent
的使用

使用 JTextComponent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 JTextComponent 的使用

javax.swing 中 JTextComponent 的子类
class | JEditorPane 可编辑各种内容的文本组件。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。

javax.swing.plaf 中 JTextComponent 的使用

参数类型为 JTextComponent 的 javax.swing.plaf 中的方法
abstract void | TextUI.damageRange(JTextComponent t, int p0, int p1) 促使重新绘制负责模型给定部分的那部分视图。
abstract void | TextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias firstBias, Position.Bias secondBias) 促使重新绘制负责模型给定部分的那部分视图。
abstract EditorKit | TextUI.getEditorKit(JTextComponent t) 获取为要编辑的文档类型设置策略的服务绑定。
abstract int | TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
abstract View | TextUI.getRootView(JTextComponent t) 获取分配了相关文本组件（即层次结构的根）的 View，可遍历这些组件来确定在空间中表示模型的形式。
String | TextUI.getToolTipText(JTextComponent t, Point pt) 返回在传入位置上用作工具提示的字符串。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract int | TextUI.viewToModel(JTextComponent t, Point pt) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
abstract int | TextUI.viewToModel(JTextComponent t, Point pt, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射关系。

javax.swing.plaf.basic 中 JTextComponent 的使用

返回 JTextComponent 的 javax.swing.plaf.basic 中的方法
protected  JTextComponent BasicTextUI.getComponent()
获取与此 UI 实现关联的文本组件。

参数类型为 JTextComponent 的 javax.swing.plaf.basic 中的方法
void | BasicTextUI.damageRange(JTextComponent tc, int p0, int p1) 促使重新绘制负责模型给定部分的那部分视图。
void | BasicTextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias p0Bias, Position.Bias p1Bias) 促使重新绘制负责模型给定部分的那部分视图。
EditorKit | BasicEditorPaneUI.getEditorKit(JTextComponent tc) 获取 UI 的 EditorKit。
EditorKit | BasicTextUI.getEditorKit(JTextComponent tc) 获取 UI 的 EditorKit。
int | BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
View | BasicTextUI.getRootView(JTextComponent tc) 获取分配了相关文本组件（即层次结构的根）的 View，可通过遍历该视图确定模型在空间中的表示形式。
String | BasicTextUI.getToolTipText(JTextComponent t, Point pt) 返回在传入位置上用作工具提示的字符串。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
int | BasicTextUI.viewToModel(JTextComponent tc, Point pt) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
int | BasicTextUI.viewToModel(JTextComponent tc, Point pt, Position.Bias[] biasReturn) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。

javax.swing.plaf.multi 中 JTextComponent 的使用

参数类型为 JTextComponent 的 javax.swing.plaf.multi 中的方法
void | MultiTextUI.damageRange(JTextComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 damageRange 方法。
void | MultiTextUI.damageRange(JTextComponent a, int b, int c, Position.Bias d, Position.Bias e) 在由此对象处理的每个 UI 上调用 damageRange 方法。
EditorKit | MultiTextUI.getEditorKit(JTextComponent a) 在由此对象处理的每个 UI 上调用 getEditorKit 方法。
int | MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e) 在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
View | MultiTextUI.getRootView(JTextComponent a) 在由此对象处理的每个 UI 上调用 getRootView 方法。
String | MultiTextUI.getToolTipText(JTextComponent a, Point b) 在由此对象处理的每个 UI 上调用 getToolTipText 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b) 在由此对象处理的每个 UI 上调用 modelToView 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c) 在由此对象处理的每个 UI 上调用 modelToView 方法。
int | MultiTextUI.viewToModel(JTextComponent a, Point b) 在由此对象处理的每个 UI 上调用 viewToModel 方法。
int | MultiTextUI.viewToModel(JTextComponent a, Point b, Position.Bias[] c) 在由此对象处理的每个 UI 上调用 viewToModel 方法。

javax.swing.text 中 JTextComponent 的使用

返回 JTextComponent 的 javax.swing.text 中的方法
protected JTextComponent | DefaultCaret.getComponent() 获取此插入符所绑定的文本编辑器组件。
protected JTextComponent | TextAction.getFocusedComponent() 获取当前具有焦点的文本组件。
protected JTextComponent | TextAction.getTextComponent(ActionEvent e) 确定动作所使用的组件。

参数类型为 JTextComponent 的 javax.swing.text 中的方法
void | DefaultHighlighter.deinstall(JTextComponent c) 从 JTextComponent 的接口移除 UI 时调用。
void | Highlighter.deinstall(JTextComponent c) 将 UI 从 JTextComponent 的接口移除时调用。
void | DefaultCaret.deinstall(JTextComponent c) 当 UI 从一个 JTextComponent 的接口移除时调用。
void | Caret.deinstall(JTextComponent c) 在将 UI 从 JTextComponent 的接口中移除时调用。
int | NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet) 返回从现在位置起的下一个放置插入符的可视位置。
static int | Utilities.getNextWord(JTextComponent c, int offs) 确定针对给定位置的下一个单词开头。
static Element | Utilities.getParagraphElement(JTextComponent c, int offs) 确定某个段落/行要使用的元素。
static int | Utilities.getPositionAbove(JTextComponent c, int offs, int x) 确定模型中离行上方给定的视图位置最近的位置。
static int | Utilities.getPositionBelow(JTextComponent c, int offs, int x) 确定模型中离行下方给定的视图位置最近的位置。
static int | Utilities.getPreviousWord(JTextComponent c, int offs) 确定针对给定位置的上一个单词开头。
static int | Utilities.getRowEnd(JTextComponent c, int offs) 确定包含指定模型位置的行的结束行模型位置。
static int | Utilities.getRowStart(JTextComponent c, int offs) 确定包含指定模型位置的行的起始行模型位置。
static int | Utilities.getWordEnd(JTextComponent c, int offs) 确定针对给定位置的单词结尾。
static int | Utilities.getWordStart(JTextComponent c, int offs) 确定针对给定模型位置的单词开头。
void | DefaultHighlighter.install(JTextComponent c) 当 UI 安装到 JTextComponent 的接口时调用。
void | Highlighter.install(JTextComponent c) 将 UI 安装到 JTextComponent 的接口时调用。
void | DefaultCaret.install(JTextComponent c) 当 UI 装入一个 JTextComponent 的接口时调用。
void | Caret.install(JTextComponent c) 在将 UI 安装到 JTextComponent 的接口中时调用。
void | DefaultHighlighter.DefaultHighlightPainter.paint(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c) 绘制高亮显示区域。
void | Highlighter.HighlightPainter.paint(Graphics g, int p0, int p1, Shape bounds, JTextComponent c) 呈现高亮显示。
Shape | DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
void | DefaultHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当要呈现叶 View （例如，LabelView）时，要调用此方法。
abstract void | LayeredHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当叶 View（如 LabelView）呈现时，它们应调用此方法。

javax.swing.tree 中 JTextComponent 的使用

javax.swing.tree 中 JTextComponent 的子类
 class DefaultTreeCellEditor.DefaultTextField
不提供任何编辑器时所使用的 TextField。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.JTextComponent.AccessibleJTextComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.JTextComponent.AccessibleJTextComponent
的使用

使用 JTextComponent.AccessibleJTextComponent 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTextComponent.AccessibleJTextComponent 的使用

javax.swing 中 JTextComponent.AccessibleJTextComponent 的子类
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.JTextComponent.DropLocation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.JTextComponent.DropLocation
的使用

使用 JTextComponent.DropLocation 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 JTextComponent.DropLocation 的使用

返回 JTextComponent.DropLocation 的 javax.swing.text 中的方法
 JTextComponent.DropLocation JTextComponent.getDropLocation()
返回在组件上进行 DnD 操作过程中此组件在视觉上指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.JTextComponent.KeyBinding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.JTextComponent.KeyBinding
的使用

使用 JTextComponent.KeyBinding 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JTextComponent.KeyBinding 的使用

返回 JTextComponent.KeyBinding 的 javax.swing 中的方法
static JTextComponent.KeyBinding[] LookAndFeel.makeKeyBindings(Object[] keyBindingList)
构建一个 KeyBinding 数组的便捷方法。

javax.swing.text 中 JTextComponent.KeyBinding 的使用

参数类型为 JTextComponent.KeyBinding 的 javax.swing.text 中的方法
static void JTextComponent.loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions)
加载带有一组绑定的 keymap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.Keymap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Keymap
的使用

使用 Keymap 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 Keymap 的使用

返回 Keymap 的 javax.swing.plaf.basic 中的方法
protected  Keymap BasicTextUI.createKeymap()
创建用于文本组件的 keymap，并在其中安装必需的绑定。

javax.swing.text 中 Keymap 的使用

返回 Keymap 的 javax.swing.text 中的方法
static Keymap | JTextComponent.addKeymap(String nm, Keymap parent) 将一个新 keymap 添加到 keymap 层次结构。
Keymap | JTextComponent.getKeymap() 获取当前在此文本组件中活动的 keymap。
static Keymap | JTextComponent.getKeymap(String nm) 获取以前添加到文档中的已命名 keymap。
Keymap | Keymap.getResolveParent() 获取用于解析键绑定的父级 keymap。
static Keymap | JTextComponent.removeKeymap(String nm) 移除以前添加到文档中的已命名 keymap。

参数类型为 Keymap 的 javax.swing.text 中的方法
static Keymap | JTextComponent.addKeymap(String nm, Keymap parent) 将一个新 keymap 添加到 keymap 层次结构。
static void | JTextComponent.loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions) 加载带有一组绑定的 keymap。
void | JTextComponent.setKeymap(Keymap map) 设置用于将事件绑定到操作的 keymap。
void | Keymap.setResolveParent(Keymap parent) 设置将用于解析键绑定的父级 keymap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.LabelView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.LabelView
的使用

使用 LabelView 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 LabelView 的使用

javax.swing.text.html 中 LabelView 的子类
 class InlineView
显示基于 css 属性的 inline element 样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.LayeredHighlighter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.LayeredHighlighter
的使用

使用 LayeredHighlighter 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 LayeredHighlighter 的使用

javax.swing.plaf.basic 中 LayeredHighlighter 的子类
static class BasicTextUI.BasicHighlighter

javax.swing.text 中 LayeredHighlighter 的使用

javax.swing.text 中 LayeredHighlighter 的子类
 class DefaultHighlighter
实现 Highlighter 接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.LayeredHighlighter.LayerPainter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.LayeredHighlighter.LayerPainter
的使用

使用 LayeredHighlighter.LayerPainter 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 LayeredHighlighter.LayerPainter 的使用

javax.swing.text 中 LayeredHighlighter.LayerPainter 的子类
static class DefaultHighlighter.DefaultHighlightPainter
只高亮显示用纯色填充高亮显示区域的 painter。

声明为 LayeredHighlighter.LayerPainter 的 javax.swing.text 中的字段
static LayeredHighlighter.LayerPainter DefaultHighlighter.DefaultPainter
LayeredHighlighter.LayerPainter 的默认实现，可用于绘制高亮显示区域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.LayoutQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.LayoutQueue
的使用

使用 LayoutQueue 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 LayoutQueue 的使用

返回 LayoutQueue 的 javax.swing.text 中的方法
static LayoutQueue | LayoutQueue.getDefaultQueue() 返回默认的布局队列。
protected LayoutQueue | AsyncBoxView.getLayoutQueue() 获取用于布局处理的队列。

参数类型为 LayoutQueue 的 javax.swing.text 中的方法
static void LayoutQueue.setDefaultQueue(LayoutQueue q)
设置默认的布局队列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.MaskFormatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.MaskFormatter
的使用

没有 javax.swing.text.MaskFormatter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.MutableAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.MutableAttributeSet
的使用

使用 MutableAttributeSet 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 MutableAttributeSet 的使用

返回 MutableAttributeSet 的 javax.swing 中的方法
 MutableAttributeSet JTextPane.getInputAttributes()
获取窗格的输入属性。

javax.swing.text 中 MutableAttributeSet 的使用

javax.swing.text 中 MutableAttributeSet 的子接口
 interface Style
与文档中某个元素相关的属性集合。

实现 MutableAttributeSet 的 javax.swing.text 中的类
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。
class | SimpleAttributeSet 使用哈希表的 MutableAttributeSet 的直接实现。
class | StyleContext.NamedStyle 通常用于表示字符和段落样式的属性集合。

返回 MutableAttributeSet 的 javax.swing.text 中的方法
protected MutableAttributeSet | StyleContext.createLargeAttributeSet(AttributeSet a) 创建一个以空间来换取时间的大属性集合。
MutableAttributeSet | StyledEditorKit.getInputAttributes() 获取该窗格的输入属性。

参数类型为 MutableAttributeSet 的 javax.swing.text 中的方法
protected void | StyledEditorKit.createInputAttributes(Element element, MutableAttributeSet set) 将 element 的 AttributeSet 键/值复制到 set 中。
void | StyleContext.readAttributes(ObjectInputStream in, MutableAttributeSet a) 读入属性的特定于上下文的处理。
static void | StyleContext.readAttributeSet(ObjectInputStream in, MutableAttributeSet a) 从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。
static void | StyleConstants.setAlignment(MutableAttributeSet a, int align) 设置对齐方式。
static void | StyleConstants.setBackground(MutableAttributeSet a, Color fg) 设置背景色。
static void | StyleConstants.setBidiLevel(MutableAttributeSet a, int o) 设置 BidiLevel。
static void | StyleConstants.setBold(MutableAttributeSet a, boolean b) 设置粗体属性。
static void | StyleConstants.setComponent(MutableAttributeSet a, Component c) 设置组件属性。
static void | StyleConstants.setFirstLineIndent(MutableAttributeSet a, float i) 设置首行缩进。
static void | StyleConstants.setFontFamily(MutableAttributeSet a, String fam) 设置字体属性。
static void | StyleConstants.setFontSize(MutableAttributeSet a, int s) 设置字体大小属性。
static void | StyleConstants.setForeground(MutableAttributeSet a, Color fg) 设置前景色。
static void | StyleConstants.setIcon(MutableAttributeSet a, Icon c) 设置图标属性。
static void | StyleConstants.setItalic(MutableAttributeSet a, boolean b) 设置斜体属性。
static void | StyleConstants.setLeftIndent(MutableAttributeSet a, float i) 设置左边缩进。
static void | StyleConstants.setLineSpacing(MutableAttributeSet a, float i) 设置行间距。
static void | StyleConstants.setRightIndent(MutableAttributeSet a, float i) 设置右边缩进。
static void | StyleConstants.setSpaceAbove(MutableAttributeSet a, float i) 设置上部空间。
static void | StyleConstants.setSpaceBelow(MutableAttributeSet a, float i) 设置下部空间。
static void | StyleConstants.setStrikeThrough(MutableAttributeSet a, boolean b) 设置删除线属性。
static void | StyleConstants.setSubscript(MutableAttributeSet a, boolean b) 设置下标属性。
static void | StyleConstants.setSuperscript(MutableAttributeSet a, boolean b) 设置上标属性。
static void | StyleConstants.setTabSet(MutableAttributeSet a, TabSet tabs) 设置 TabSet。
static void | StyleConstants.setUnderline(MutableAttributeSet a, boolean b) 设置下标属性。

javax.swing.text.html 中 MutableAttributeSet 的使用

实现 MutableAttributeSet 的 javax.swing.text.html 中的类
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

声明为 MutableAttributeSet 的 javax.swing.text.html 中的字段
protected  MutableAttributeSet HTMLDocument.HTMLReader.charAttr

返回 MutableAttributeSet 的 javax.swing.text.html 中的方法
protected MutableAttributeSet | StyleSheet.createLargeAttributeSet(AttributeSet a) 创建一个以空间来换取时间的大属性集合。
MutableAttributeSet | HTMLEditorKit.getInputAttributes() 获取该样式编辑动作的输入属性。

参数类型为 MutableAttributeSet 的 javax.swing.text.html 中的方法
void | StyleSheet.addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value) 将 CSS 属性添加到给定的集合。
boolean | StyleSheet.addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value) 将 CSS 属性添加到给定的集合。
protected void | HTMLDocument.HTMLReader.addSpecialElement(HTML.Tag t, MutableAttributeSet a) 添加基本上完全是在属性集中指定的内容。
protected void | HTMLDocument.HTMLReader.blockOpen(HTML.Tag t, MutableAttributeSet attr) 向解析器缓冲区添加一条指令，以创建具有给定属性的块元素。
protected void | HTMLEditorKit.createInputAttributes(Element element, MutableAttributeSet set) 将 element 的 AttributeSet 键/值复制到 set 中。
void | HTMLDocument.HTMLReader.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos) 从解析器回调。
void | HTMLEditorKit.ParserCallback.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
void | HTMLDocument.HTMLReader.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos) 从解析器回调。
void | HTMLEditorKit.ParserCallback.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
void | HTMLDocument.HTMLReader.TagAction.start(HTML.Tag t, MutableAttributeSet a) 当发现此动作所注册的标记类型的开始标记时调用。
void | HTMLDocument.HTMLReader.BlockAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.ParagraphAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.SpecialAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.IsindexAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.HiddenAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.PreAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.CharacterAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.FormAction.start(HTML.Tag t, MutableAttributeSet attr)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.NavigationFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.NavigationFilter
的使用

使用 NavigationFilter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 NavigationFilter 的使用

返回 NavigationFilter 的 javax.swing 中的方法
protected  NavigationFilter JFormattedTextField.AbstractFormatter.getNavigationFilter()
如果想要提供过滤器以限制用户可导航的位置，则应进行子类化和重写。

javax.swing.text 中 NavigationFilter 的使用

返回 NavigationFilter 的 javax.swing.text 中的方法
protected NavigationFilter | DefaultFormatter.getNavigationFilter() 返回用于限制光标放置位置的 NavigationFilter。
NavigationFilter | JTextComponent.getNavigationFilter() 返回 NavigationFilter。

参数类型为 NavigationFilter 的 javax.swing.text 中的方法
 void JTextComponent.setNavigationFilter(NavigationFilter filter)
设置 NavigationFilter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.NavigationFilter.FilterBypass 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.NavigationFilter.FilterBypass
的使用

使用 NavigationFilter.FilterBypass 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 NavigationFilter.FilterBypass 的使用

参数类型为 NavigationFilter.FilterBypass 的 javax.swing.text 中的方法
void | NavigationFilter.moveDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias) 在 Caret 移动点之前调用。
void | NavigationFilter.setDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias) 在 Caret 设置点之前调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.NumberFormatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.NumberFormatter
的使用

没有 javax.swing.text.NumberFormatter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.ParagraphView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.ParagraphView
的使用

使用 ParagraphView 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 ParagraphView 的使用

javax.swing.text.html 中 ParagraphView 的子类
 class ParagraphView
显示段落，并使用 css 属性作为其配置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.PasswordView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.PasswordView
的使用

没有 javax.swing.text.PasswordView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.PlainDocument 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.PlainDocument
的使用

没有 javax.swing.text.PlainDocument 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.PlainView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.PlainView
的使用

使用 PlainView 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 PlainView 的使用

javax.swing.text 中 PlainView 的子类
class | FieldView 扩展多行纯文本视图，使其适合单行编辑器视图。
class | PasswordView 实现适用于 JPasswordField UI 实现的视图。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.Position 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Position
的使用

使用 Position 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 Position 的使用

返回 Position 的 javax.swing.text 中的方法
Position | StringContent.createPosition(int offset) 在内容中创建一个位置，让其跟踪随内容的变化而进行的更改。
Position | GapContent.createPosition(int offset) 在内容中创建一个位置，使其在内容发生变化时能跟踪内容的更改。
Position | AbstractDocument.createPosition(int offs) 返回更改文档时，将跟踪更改的位置。
Position | AbstractDocument.Content.createPosition(int offset) 在内容中创建一个位置，该位置将在内容改变时跟踪更改。
Position | Document.createPosition(int offs) 此方法允许应用程序在字符内容序列中标记位置。
Position | AbstractDocument.getEndPosition() 返回表示文档结尾的位置。
Position | Document.getEndPosition() 返回代表文档结束处的位置。
Position | AbstractDocument.getStartPosition() 返回表示文档开始的位置。
Position | Document.getStartPosition() 返回代表文档起始处的位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.Position.Bias 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.Position.Bias
的使用

使用 Position.Bias 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 Position.Bias 的使用

参数类型为 Position.Bias 的 javax.swing 中的方法
TreePath | JTree.getNextMatch(String prefix, int startingRow, Position.Bias bias) 将 TreePath 返回到以一个前缀开头的下一个树元素。
int | JList.getNextMatch(String prefix, int startIndex, Position.Bias bias) 返回其 toString 值以给定前缀开头的下一个列表元素。

javax.swing.plaf 中 Position.Bias 的使用

参数类型为 Position.Bias 的 javax.swing.plaf 中的方法
abstract void | TextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias firstBias, Position.Bias secondBias) 促使重新绘制负责模型给定部分的那部分视图。
abstract int | TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
abstract int | TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract int | TextUI.viewToModel(JTextComponent t, Point pt, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射关系。

javax.swing.plaf.basic 中 Position.Bias 的使用

参数类型为 Position.Bias 的 javax.swing.plaf.basic 中的方法
void | BasicTextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias p0Bias, Position.Bias p1Bias) 促使重新绘制负责模型给定部分的那部分视图。
int | BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
int | BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
int | BasicTextUI.viewToModel(JTextComponent tc, Point pt, Position.Bias[] biasReturn) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。

javax.swing.plaf.multi 中 Position.Bias 的使用

参数类型为 Position.Bias 的 javax.swing.plaf.multi 中的方法
void | MultiTextUI.damageRange(JTextComponent a, int b, int c, Position.Bias d, Position.Bias e) 在由此对象处理的每个 UI 上调用 damageRange 方法。
int | MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e) 在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
int | MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e) 在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c) 在由此对象处理的每个 UI 上调用 modelToView 方法。
int | MultiTextUI.viewToModel(JTextComponent a, Point b, Position.Bias[] c) 在由此对象处理的每个 UI 上调用 viewToModel 方法。

javax.swing.text 中 Position.Bias 的使用

声明为 Position.Bias 的 javax.swing.text 中的字段
static Position.Bias | Position.Bias.Backward 指示到模型中上一字符的偏差。
static Position.Bias | Position.Bias.Forward 指示到模型中下一字符的偏差。

返回 Position.Bias 的 javax.swing.text 中的方法
Position.Bias | JTextComponent.DropLocation.getBias() 返回放置索引的偏差。
Position.Bias | DefaultCaret.getDotBias() 返回插入符位置的偏差。
Position.Bias | DefaultCaret.getMarkBias() 返回标记的偏差。

参数类型为 Position.Bias 的 javax.swing.text 中的方法
protected boolean | BoxView.flipEastAndWestAtEnds(int position, Position.Bias bias) 确定下一个视图的放置方向。
protected boolean | CompositeView.flipEastAndWestAtEnds(int position, Position.Bias bias) 确定下一个视图放置的朝向。
protected boolean | ParagraphView.flipEastAndWestAtEnds(int position, Position.Bias bias) 确定下一个视图要布置的方向。
protected int | ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x) 返回最接近 x 处的模型位置。
protected int | ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x) 返回最接近 x 处的模型位置。
protected int | CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在东或在西。
protected int | CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在东或在西。
protected int | CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在北也可以在南。
protected int | CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在北也可以在南。
protected int | ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 在东或西方向返回光标的下一个可视位置。
protected int | ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 在东或西方向返回光标的下一个可视位置。
int | GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
int | View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
int | NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet) 返回从现在位置起的下一个放置插入符的可视位置。
int | NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet) 返回从现在位置起的下一个放置插入符的可视位置。
int | AsyncBoxView.getViewIndex(int pos, Position.Bias b) 返回该模型中表示给定位置的子视图索引。
int | CompositeView.getViewIndex(int pos, Position.Bias b) 返回表示模型中给定位置的子视图索引。
int | View.getViewIndex(int pos, Position.Bias b) 返回表示模型中给定位置的子视图索引。
protected int | AsyncBoxView.getViewIndexAtPosition(int pos, Position.Bias b) 获取此模型中表示给定位置的子视图索引。
abstract Shape | GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | CompositeView.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | View.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
Shape | AsyncBoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | BoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
Shape | ComponentView.modelToView(int pos, Shape a, Position.Bias b) 提供模型坐标空间到视图坐标空间的映射。
Shape | CompositeView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | GlyphView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | IconView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PasswordView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | FieldView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PlainView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract Shape | View.modelToView(int pos, Shape a, Position.Bias b) 为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
abstract void | NavigationFilter.FilterBypass.moveDot(int dot, Position.Bias bias) 移动插入符的位置，并跳过 NavigationFilter。
void | DefaultCaret.moveDot(int dot, Position.Bias dotBias) 将插入符位置移动到指定位置，存在指定偏差。
void | NavigationFilter.moveDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias) 在 Caret 移动点之前调用。
abstract void | NavigationFilter.FilterBypass.setDot(int dot, Position.Bias bias) 设置插入符的位置，并跳过 NavigationFilter。
void | DefaultCaret.setDot(int dot, Position.Bias dotBias) 将插入符位置和标记设置为指定位置，存在指定偏差。
void | NavigationFilter.setDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias) 在 Caret 设置点之前调用。
int | AsyncBoxView.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | BoxView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | ComponentView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | CompositeView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型的逻辑坐标空间的映射。
int | GlyphView.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | IconView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | PasswordView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | FieldView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | PlainView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
abstract int | View.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射。
abstract int | GlyphView.GlyphPainter.viewToModel(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。

javax.swing.text.html 中 Position.Bias 的使用

参数类型为 Position.Bias 的 javax.swing.text.html 中的方法
Shape | ImageView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
int | ImageView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.Segment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.Segment
的使用

使用 Segment 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 Segment 的使用

返回 Segment 的 javax.swing.text 中的方法
protected Segment | WrappedPlainView.getLineBuffer() 提供对能用于从关联文档获取文本的缓冲区的访问。
protected Segment | PlainView.getLineBuffer() 提供对可用于从相关文档获取文本的缓冲区的访问。
Segment | GlyphView.getText(int p0, int p1) 获取对占用给定范围的文本的引用。

参数类型为 Segment 的 javax.swing.text 中的方法
static int Utilities.drawTabbedText(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset)
使用给定的制表符扩展方式来扩展给定文本所包含的任何制表符，从而绘制给定的文本。
static int Utilities.getBreakLocation(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
确定对给定文本进行拆分的位置，以符合给定的跨距。
 void StringContent.getChars(int where, int len, Segment chars)
检索内容的某一部分，where ＋ len 必须 <= length()
 void GapContent.getChars(int where, int len, Segment chars)
检索部分内容。
 void AbstractDocument.Content.getChars(int where, int len, Segment txt)
获得字符序列并将其复制到 Segment 中。
static int Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
确定给定文本中的某个相对偏移量，使其能最好的表示视图坐标系统中的给定跨距。
static int Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
static int Utilities.getTabbedTextWidth(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset)
确定给定的考虑制表符的文本段的宽度。
 void AbstractDocument.getText(int offset, int length, Segment txt)
获取文档给定部分内包含的文本。
 void Document.getText(int offset, int length, Segment txt)
获取文档中给定部分包含的文本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.SimpleAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.SimpleAttributeSet
的使用

使用 SimpleAttributeSet 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 SimpleAttributeSet 的使用

返回 SimpleAttributeSet 的 javax.swing.text.html.parser 中的方法
protected  SimpleAttributeSet Parser.getAttributes()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StringContent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StringContent
的使用

没有 javax.swing.text.StringContent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.Style 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Style
的使用

使用 Style 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 Style 的使用

返回 Style 的 javax.swing 中的方法
Style | JTextPane.addStyle(String nm, Style parent) 将一个新样式添加到逻辑样式层次结构中。
Style | JTextPane.getLogicalStyle() 获取分配给由当前插入符号位置表示的段落的逻辑样式，或者 null。
Style | JTextPane.getStyle(String nm) 获取以前添加的已命名的非 null 样式。

参数类型为 Style 的 javax.swing 中的方法
Style | JTextPane.addStyle(String nm, Style parent) 将一个新样式添加到逻辑样式层次结构中。
void | JTextPane.setLogicalStyle(Style s) 设置在当前插入符号位置用于段落的逻辑样式。

javax.swing.text 中 Style 的使用

实现 Style 的 javax.swing.text 中的类
 class StyleContext.NamedStyle
通常用于表示字符和段落样式的属性集合。

返回 Style 的 javax.swing.text 中的方法
Style | DefaultStyledDocument.addStyle(String nm, Style parent) 向逻辑样式层次结构中添加新样式。
Style | StyledDocument.addStyle(String nm, Style parent) 向逻辑样式层次中添加新样式。
Style | StyleContext.addStyle(String nm, Style parent) 将新的样式添加到样式层次中。
Style | DefaultStyledDocument.getLogicalStyle(int p) 获取表示给定位置处分配给段落的逻辑样式。
Style | StyledDocument.getLogicalStyle(int p) 获取段落中给定位置的逻辑样式。
Style | DefaultStyledDocument.getStyle(String nm) 获取以前添加的已命名的样式。
Style | StyledDocument.getStyle(String nm) 获取以前添加的指定样式。
Style | StyleContext.getStyle(String nm) 获取以前添加到文档中的已命名样式

参数类型为 Style 的 javax.swing.text 中的方法
Style | DefaultStyledDocument.addStyle(String nm, Style parent) 向逻辑样式层次结构中添加新样式。
Style | StyledDocument.addStyle(String nm, Style parent) 向逻辑样式层次中添加新样式。
Style | StyleContext.addStyle(String nm, Style parent) 将新的样式添加到样式层次中。
void | DefaultStyledDocument.setLogicalStyle(int pos, Style s) 设置给定位置处用于段落的逻辑样式。
void | StyledDocument.setLogicalStyle(int pos, Style s) 设置给定位置的段落所用的逻辑样式。
protected void | DefaultStyledDocument.styleChanged(Style style) 此文档样式有任何改变时调用。

参数类型为 Style 的 javax.swing.text 中的构造方法
StyleContext.NamedStyle(String name, Style parent)
创建新的命名样式。
StyleContext.NamedStyle(Style parent)
创建新的命名样式。

javax.swing.text.html 中 Style 的使用

返回 Style 的 javax.swing.text.html 中的方法
Style | StyleSheet.getRule(HTML.Tag t, Element e) 获取用来呈现给定类型的 HTML 标记的样式。
Style | StyleSheet.getRule(String selector) 获取最能匹配以字符串形式表示的选择器的规则。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyleConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleConstants
的使用

使用 StyleConstants 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 StyleConstants 的使用

javax.swing.text 中 StyleConstants 的子类
static class | StyleConstants.CharacterConstants 这是一个类型安全的已知 属性的枚举，它用于字符样式。
static class | StyleConstants.ColorConstants 这是一个类型安全的已知 属性的枚举，它用于颜色样式。
static class | StyleConstants.FontConstants 这是一个类型安全的已知 属性的枚举，它用于字体样式。
static class | StyleConstants.ParagraphConstants 这是一个类型安全的已知 属性的枚举，它用于段落样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyleConstants.CharacterConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleConstants.CharacterConstants
的使用

没有 javax.swing.text.StyleConstants.CharacterConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyleConstants.ColorConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleConstants.ColorConstants
的使用

没有 javax.swing.text.StyleConstants.ColorConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyleConstants.FontConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleConstants.FontConstants
的使用

没有 javax.swing.text.StyleConstants.FontConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyleConstants.ParagraphConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleConstants.ParagraphConstants
的使用

没有 javax.swing.text.StyleConstants.ParagraphConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyleContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleContext
的使用

使用 StyleContext 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 StyleContext 的使用

返回 StyleContext 的 javax.swing.text 中的方法
static StyleContext StyleContext.getDefaultStyleContext()
返回由所有文档共享的默认 AttributeContext，这些文档不影响定义/提供其自己的上下文。

参数类型为 StyleContext 的 javax.swing.text 中的构造方法
DefaultStyledDocument(AbstractDocument.Content c, StyleContext styles)
构造样式化文档。
DefaultStyledDocument(StyleContext styles)
构造具有默认的内容存储实现和一组共享样式的样式化文档。

javax.swing.text.html 中 StyleContext 的使用

javax.swing.text.html 中 StyleContext 的子类
 class StyleSheet
支持定义要呈现的 HTML 视图的可视化特征。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyleContext.NamedStyle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleContext.NamedStyle
的使用

没有 javax.swing.text.StyleContext.NamedStyle 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyleContext.SmallAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleContext.SmallAttributeSet
的使用

使用 StyleContext.SmallAttributeSet 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 StyleContext.SmallAttributeSet 的使用

返回 StyleContext.SmallAttributeSet 的 javax.swing.text 中的方法
protected  StyleContext.SmallAttributeSet StyleContext.createSmallAttributeSet(AttributeSet a)
创建一个可能用于共享的压缩属性集。

javax.swing.text.html 中 StyleContext.SmallAttributeSet 的使用

返回 StyleContext.SmallAttributeSet 的 javax.swing.text.html 中的方法
protected  StyleContext.SmallAttributeSet StyleSheet.createSmallAttributeSet(AttributeSet a)
创建可以共享的属性压缩集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.StyledDocument 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.StyledDocument
的使用

使用 StyledDocument 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 StyledDocument 的使用

返回 StyledDocument 的 javax.swing 中的方法
 StyledDocument JTextPane.getStyledDocument()
获取与编辑器关联的模型。

参数类型为 StyledDocument 的 javax.swing 中的方法
 void JTextPane.setStyledDocument(StyledDocument doc)
将编辑器与一个文本文档关联。

参数类型为 StyledDocument 的 javax.swing 中的构造方法
JTextPane(StyledDocument doc)
创建具有指定文档模型的新 JTextPane。

javax.swing.text 中 StyledDocument 的使用

实现 StyledDocument 的 javax.swing.text 中的类
 class DefaultStyledDocument
能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。

返回 StyledDocument 的 javax.swing.text 中的方法
protected  StyledDocument StyledEditorKit.StyledTextAction.getStyledDocument(JEditorPane e)
获取与编辑器窗格相关的文档。

javax.swing.text.html 中 StyledDocument 的使用

实现 StyledDocument 的 javax.swing.text.html 中的类
 class HTMLDocument
对 HTML 进行建模的文档。

参数类型为 StyledDocument 的 javax.swing.text.html 中的构造方法
MinimalHTMLWriter(Writer w, StyledDocument doc)
创建一个新的 MinimalHTMLWriter。
MinimalHTMLWriter(Writer w, StyledDocument doc, int pos, int len)
创建一个新的 MinimalHTMLWriter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit
的使用

使用 StyledEditorKit 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing 中 StyledEditorKit 的使用

返回 StyledEditorKit 的 javax.swing 中的方法
protected  StyledEditorKit JTextPane.getStyledEditorKit()
获取编辑器工具包。

javax.swing.text 中 StyledEditorKit 的使用

返回 StyledEditorKit 的 javax.swing.text 中的方法
protected  StyledEditorKit StyledEditorKit.StyledTextAction.getStyledEditorKit(JEditorPane e)
获取与编辑器窗格相关的编辑器工具包。

javax.swing.text.html 中 StyledEditorKit 的使用

javax.swing.text.html 中 StyledEditorKit 的子类
 class HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。

javax.swing.text.rtf 中 StyledEditorKit 的使用

javax.swing.text.rtf 中 StyledEditorKit 的子类
 class RTFEditorKit
这是对 RTF 编辑功能的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.AlignmentAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.AlignmentAction
的使用

没有 javax.swing.text.StyledEditorKit.AlignmentAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.BoldAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.BoldAction
的使用

没有 javax.swing.text.StyledEditorKit.BoldAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.FontFamilyAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.FontFamilyAction
的使用

没有 javax.swing.text.StyledEditorKit.FontFamilyAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.FontSizeAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.FontSizeAction
的使用

没有 javax.swing.text.StyledEditorKit.FontSizeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.ForegroundAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.ForegroundAction
的使用

没有 javax.swing.text.StyledEditorKit.ForegroundAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.ItalicAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.ItalicAction
的使用

没有 javax.swing.text.StyledEditorKit.ItalicAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.StyledTextAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.StyledTextAction
的使用

使用 StyledEditorKit.StyledTextAction 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 StyledEditorKit.StyledTextAction 的使用

javax.swing.text 中 StyledEditorKit.StyledTextAction 的子类
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。

javax.swing.text.html 中 StyledEditorKit.StyledTextAction 的使用

javax.swing.text.html 中 StyledEditorKit.StyledTextAction 的子类
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.UnderlineAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.UnderlineAction
的使用

没有 javax.swing.text.StyledEditorKit.UnderlineAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.TabableView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.TabableView
的使用

使用 TabableView 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TabableView 的使用

实现 TabableView 的 javax.swing.text 中的类
class | GlyphView GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
class | LabelView LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。

javax.swing.text.html 中 TabableView 的使用

实现 TabableView 的 javax.swing.text.html 中的类
 class InlineView
显示基于 css 属性的 inline element 样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.TabExpander 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.TabExpander
的使用

使用 TabExpander 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TabExpander 的使用

实现 TabExpander 的 javax.swing.text 中的类
class | FieldView 扩展多行纯文本视图，使其适合单行编辑器视图。
class | ParagraphView 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
class | PasswordView 实现适用于 JPasswordField UI 实现的视图。
class | PlainView 实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。
class | WrappedPlainView 进行换行的纯文本（仅有一种字体和颜色的文本）视图。

返回 TabExpander 的 javax.swing.text 中的方法
 TabExpander GlyphView.getTabExpander()
如果此视图中存在选项卡，则获取要使用的 TabExpander。

参数类型为 TabExpander 的 javax.swing.text 中的方法
static int | Utilities.drawTabbedText(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset) 使用给定的制表符扩展方式来扩展给定文本所包含的任何制表符，从而绘制给定的文本。
static int | Utilities.getBreakLocation(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset) 确定对给定文本进行拆分的位置，以符合给定的跨距。
abstract float | GlyphView.GlyphPainter.getSpan(GlyphView v, int p0, int p1, TabExpander e, float x) 确定给定开始位置（相对于选项卡扩展而言）的字形区域。
float | GlyphView.getTabbedSpan(float x, TabExpander e) 确定使用给定选项卡扩展实现时所需的区域。
float | TabableView.getTabbedSpan(float x, TabExpander e) 确定当使用给定的制表符扩展实现时所需的跨距。
static int | Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset) 确定给定文本中的某个相对偏移量，使其能最好的表示视图坐标系统中的给定跨距。
static int | Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
static int | Utilities.getTabbedTextWidth(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset) 确定给定的考虑制表符的文本段的宽度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.TableView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TableView
的使用

没有 javax.swing.text.TableView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.TableView.TableCell 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TableView.TableCell
的使用

使用 TableView.TableCell 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TableView.TableCell 的使用

返回 TableView.TableCell 的 javax.swing.text 中的方法
protected  TableView.TableCell TableView.createTableCell(Element elem)
已过时。 现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.TableView.TableRow 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TableView.TableRow
的使用

使用 TableView.TableRow 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TableView.TableRow 的使用

返回 TableView.TableRow 的 javax.swing.text 中的方法
protected  TableView.TableRow TableView.createTableRow(Element elem)
创建新的表格行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.TabSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TabSet
的使用

使用 TabSet 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TabSet 的使用

返回 TabSet 的 javax.swing.text 中的方法
protected TabSet | ParagraphView.getTabSet() 获取计算制表符时使用的 Tabset。
static TabSet | StyleConstants.getTabSet(AttributeSet a) 获取 TabSet。

参数类型为 TabSet 的 javax.swing.text 中的方法
static void StyleConstants.setTabSet(MutableAttributeSet a, TabSet tabs)
设置 TabSet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.TabStop 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TabStop
的使用

使用 TabStop 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TabStop 的使用

返回 TabStop 的 javax.swing.text 中的方法
TabStop | TabSet.getTab(int index) 返回索引 index 处的 TabStop。
TabStop | TabSet.getTabAfter(float location) 返回 location 之后的 Tab 实例。

参数类型为 TabStop 的 javax.swing.text 中的方法
 int TabSet.getTabIndex(TabStop tab)

参数类型为 TabStop 的 javax.swing.text 中的构造方法
TabSet(TabStop[] tabs)
创建并且返回 TabSet 的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.TextAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TextAction
的使用

使用 TextAction 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TextAction 的使用

javax.swing.text 中 TextAction 的子类
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。

javax.swing.text.html 中 TextAction 的使用

javax.swing.text.html 中 TextAction 的子类
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.Utilities 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.Utilities
的使用

没有 javax.swing.text.Utilities 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.View 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.View
的使用

使用 View 的软件包
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf 中 View 的使用

返回 View 的 javax.swing.plaf 中的方法
abstract  View TextUI.getRootView(JTextComponent t)
获取分配了相关文本组件（即层次结构的根）的 View，可遍历这些组件来确定在空间中表示模型的形式。

javax.swing.plaf.basic 中 View 的使用

返回 View 的 javax.swing.plaf.basic 中的方法
View | BasicPasswordFieldUI.create(Element elem) 创建元素的视图 (PasswordView)。
View | BasicTextAreaUI.create(Element elem) 创建元素的视图。
View | BasicTextFieldUI.create(Element elem) 基于元素创建视图 (FieldView)。
View | BasicTextUI.create(Element elem) 创建元素的视图。
View | BasicTextUI.create(Element elem, int p0, int p1) 创建元素的视图。
static View | BasicHTML.createHTMLView(JComponent c, String html) 创建给定组件和 html 字符串的 html 渲染器。
View | BasicTextUI.getRootView(JTextComponent tc) 获取分配了相关文本组件（即层次结构的根）的 View，可通过遍历该视图确定模型在空间中的表示形式。
protected View | BasicTabbedPaneUI.getTextViewForTab(int tabIndex) 返回为指定选项卡呈现样式化文本 (HTML) 所需的文本 View 对象；如果此选项卡不需要任何特殊化的文本呈现，则返回 null。

参数类型为 View 的 javax.swing.plaf.basic 中的方法
static int BasicHTML.getHTMLBaseline(View view, int w, int h)
返回 html 渲染器的基线。
protected  void BasicTextUI.setView(View v)
设置视图层次结构的当前根并调用 invalidate()。

javax.swing.plaf.multi 中 View 的使用

返回 View 的 javax.swing.plaf.multi 中的方法
 View MultiTextUI.getRootView(JTextComponent a)
在由此对象处理的每个 UI 上调用 getRootView 方法。

javax.swing.text 中 View 的使用

javax.swing.text 中 View 的子类
class | AsyncBoxView 异步执行布局处理的框。
class | BoxView 一个视图，它通过沿某轴平铺将其子级排列到框形状中。
class | ComponentView 实现视图接口的组件装饰器。
class | CompositeView CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。
class | FieldView 扩展多行纯文本视图，使其适合单行编辑器视图。
class | FlowView 试图将其子级流入某个部分受约束的空间的视图。
class | GlyphView GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
class | IconView 实现视图接口的图标修饰符。
class | LabelView LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。
class | ParagraphView 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
class | PasswordView 实现适用于 JPasswordField UI 实现的视图。
class | PlainView 实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。
class | TableView 为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。
class | TableView.TableRow 以行为中心的表格中的行视图。
class | WrappedPlainView 进行换行的纯文本（仅有一种字体和颜色的文本）视图。
class | ZoneView ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

声明为 View 的 javax.swing.text 中的字段
protected  View FlowView.layoutPool
这些都是表示此视图表示的元素（要转换为物理视图的逻辑视图）的子元素的视图。

返回 View 的 javax.swing.text 中的方法
View | ParagraphView.breakView(int axis, float len, Shape a) 以给定的长度在给定的轴上拆分此视图。
View | GlyphView.breakView(int axis, int p0, float pos, float len) 在给定的轴上以给定的长度拆分此视图。
View | View.breakView(int axis, int offset, float pos, float len) 试图在给定的轴上拆分视图。
View | ViewFactory.create(Element elem) 根据给定的文档的结构化元素创建一个视图。
View | GlyphView.createFragment(int p0, int p1) 创建表示元素某部分的视图。
View | View.createFragment(int p0, int p1) 创建一个表示元素某部分的视图。
protected abstract View | FlowView.createRow() 创建应在保持流中子级行值时使用的视图。
protected View | ParagraphView.createRow() 创建用于在流中存储子级行值的 View。
protected View | FlowView.FlowStrategy.createView(FlowView fv, int startOffset, int spanLeft, int rowIndex) 创建一个可用于表示流的当前片段的视图。
protected View | ZoneView.createZone(int p0, int p1) 针对模型中的给定范围（应该在此对象的职责范围内），创建一个视图来表示分区。
View | AsyncBoxView.ChildState.getChildView() 获取此记录表示的子视图。
protected View | ParagraphView.getLayoutView(int index) 返回给定 index 处的视图。
protected View | FlowView.FlowStrategy.getLogicalView(FlowView fv) 此方法提供访问 FlowView 的逻辑视图的流策略。
View | View.getParent() 返回视图的父级。
View | AsyncBoxView.getView(int n) 获得第 n 个子视图。
View | CompositeView.getView(int n) 返回该容器中的第 n 个视图。
View | View.getView(int n) 获取第 n 个子视图。
protected View | BoxView.getViewAtPoint(int x, int y, Rectangle alloc) 获取给定坐标处的子视图。
protected abstract View | CompositeView.getViewAtPoint(int x, int y, Rectangle alloc) 获取位于给定坐标的子视图。
protected View | CompositeView.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
protected View | TableView.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
protected View | TableView.TableRow.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。

参数类型为 View 的 javax.swing.text 中的方法
void | View.append(View v) 追加单个子视图。
protected AsyncBoxView.ChildState | AsyncBoxView.createChildState(View v) 通过此方法创建新的 ChildState 记录，以允许扩展 ChildState 记录的子类执行/保存更多状态。
protected void | View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f) 将 DocumentEvent 转发到给定的子视图。
void | View.insert(int offs, View v) 插入单个子视图。
protected boolean | ZoneView.isZoneLoaded(View zone) 确定某个分区是否处于加载状态。
Shape | DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
void | DefaultHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当要呈现叶 View （例如，LabelView）时，要调用此方法。
abstract void | LayeredHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当叶 View（如 LabelView）呈现时，它们应调用此方法。
void | AsyncBoxView.preferenceChanged(View child, boolean width, boolean height) 子视图可以在父级上调用此方法，以指示首选项已更改并且应该重新考虑布局。
void | BoxView.preferenceChanged(View child, boolean width, boolean height) 这由子级来调用，以表明它的首选项区域已更改。
void | View.preferenceChanged(View child, boolean width, boolean height) 子视图能在父级上调用此方法来指示首选项已经更改，并且应该重新考虑布局。
void | AsyncBoxView.replace(int offset, int length, View[] views) 调用超类以更新子视图，并且更新子视图的状态记录。
void | BoxView.replace(int index, int length, View[] elems) 使布局变得无效并调整所需/分配的缓存大小。
void | CompositeView.replace(int offset, int length, View[] views) 替换子视图。
void | TableView.replace(int offset, int length, View[] views) 更改子视图。
void | TableView.TableRow.replace(int offset, int length, View[] views) 更改子视图。
void | View.replace(int offset, int length, View[] views) 替代子视图。
void | AsyncBoxView.setParent(View parent) 设置视图的父级。
void | ComponentView.setParent(View p) 为子视图设置父级。
void | CompositeView.setParent(View parent) 设置此视图的父级。
void | FlowView.setParent(View parent) 设置此视图的父级。
void | View.setParent(View parent) 为此视图建立父视图。
protected void | ZoneView.unloadZone(View zone) 卸载一个分区（将分区转换到其内存节省状态）。
protected void | ZoneView.zoneWasLoaded(View zone) 当加载某个分区后由该分区调用。

参数类型为 View 的 javax.swing.text 中的构造方法
AsyncBoxView.ChildState(View v)
构造子视图状态。

javax.swing.text.html 中 View 的使用

javax.swing.text.html 中 View 的子类
class | BlockView 用来显示具有 CSS 规范的块（作为一个框）的视图实现。
class | FormView 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
class | ImageView 图像视图，用于支持 HTML <IMG> 标记。
class | InlineView 显示基于 css 属性的 inline element 样式。
class | ListView 用于显示 html 列表的视图实现。
class | ObjectView 实现 <object> 元素视图接口的组件装饰符。

返回 View 的 javax.swing.text.html 中的方法
View | InlineView.breakView(int axis, int offset, float pos, float len) 尝试在给定轴上拆分此视图。
View | HTMLEditorKit.HTMLFactory.create(Element elem) 根据元素创建视图。

参数类型为 View 的 javax.swing.text.html 中的方法
float | StyleSheet.BoxPainter.getInset(int side, View v) 获取给定边上所需的 inset，以便计算空白、边框和填充数量。
AttributeSet | StyleSheet.getViewAttributes(View v) 获取用来显示视图的属性集。
void | StyleSheet.BoxPainter.paint(Graphics g, float x, float y, float w, float h, View v) 根据给定的属性绘制 CSS 框。
void | StyleSheet.ListPainter.paint(Graphics g, float x, float y, float w, float h, View v, int item) 根据给定的属性绘制 CSS 列表装饰。
void | BlockView.setParent(View parent) 建立此视图的父视图。
void | ImageView.setParent(View parent) 建立此视图的父视图。
void | ParagraphView.setParent(View parent) 建立此视图的父视图。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.ViewFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.ViewFactory
的使用

使用 ViewFactory 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 ViewFactory 的使用

实现 ViewFactory 的 javax.swing.plaf.basic 中的类
class | BasicEditorPaneUI 为 JEditorPane 提供外观。
class | BasicFormattedTextFieldUI 提供 JFormattedTextField 的外观实现。
class | BasicPasswordFieldUI 为密码字段提供 Windows 外观。
class | BasicTextAreaUI 为纯文本编辑器提供外观。
class | BasicTextFieldUI JTextField 的外观的基础。
class | BasicTextPaneUI 为样式化文本编辑器提供外观。
class | BasicTextUI 此类是文本组件外观的基础。

javax.swing.plaf.metal 中 ViewFactory 的使用

实现 ViewFactory 的 javax.swing.plaf.metal 中的类
 class MetalTextFieldUI
JTextField 外观的基础。

javax.swing.text 中 ViewFactory 的使用

实现 ViewFactory 的 javax.swing.text 中的类
 class DefaultTextUI
已过时。

返回 ViewFactory 的 javax.swing.text 中的方法
ViewFactory | StyledEditorKit.getViewFactory() 获取一个适合供由此包所产生的任何模型来产生视图的工厂。
ViewFactory | View.getViewFactory() 获取将提供给视图层次结构的 ViewFactory 实现。
ViewFactory | DefaultEditorKit.getViewFactory() 获取一个适合供由此包所产生的任何模型来产生视图的工厂。
abstract ViewFactory | EditorKit.getViewFactory() 获取适合生成此工具包生成的任何模型视图的工厂。

参数类型为 ViewFactory 的 javax.swing.text 中的方法
void | FlowView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | GlyphView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | LabelView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | ParagraphView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | WrappedPlainView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出文档中此视图负责的位置上的属性已发生更改的通知。
void | PlainView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | View.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
protected void | BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
protected void | View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
protected void | View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f) 将 DocumentEvent 转发到给定的子视图。
void | FlowView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | GlyphView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | WrappedPlainView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出在文档中此视图负责的位置插入了某些内容的通知。
void | ZoneView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出在文档中此视图负责的位置插入了某些内容的通知。
void | FieldView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | View.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
protected void | AsyncBoxView.loadChildren(ViewFactory f) 加载初始化该视图的所有子级。
protected void | CompositeView.loadChildren(ViewFactory f) 加载所有的子级以初始化该视图。
protected void | FlowView.loadChildren(ViewFactory f) 加载初始化该视图的所有子级。
protected void | WrappedPlainView.loadChildren(ViewFactory f) 加载所有子级来初始化视图。
protected void | ZoneView.loadChildren(ViewFactory f) 加载所有子级来初始化视图。
void | FlowView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知从文档中此视图负责的某个位置已移除内容。
void | GlyphView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。
void | WrappedPlainView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出从文档中此视图负责的位置移除了某些内容的通知。
void | ZoneView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
void | FieldView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | View.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
protected boolean | ZoneView.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 超类行为将试图更新子视图，而在这种情况下并不需要这样做，因为子级是分区并且不受关联元素变化的直接影响。
protected boolean | View.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 更新子视图以响应接收模型变化的通知，并且有一条此视图负责的元素的变化记录。
protected void | PlainView.updateDamage(DocumentEvent changes, Shape a, ViewFactory f) 重新绘制给定文档事件覆盖的更改区域。

javax.swing.text.html 中 ViewFactory 的使用

实现 ViewFactory 的 javax.swing.text.html 中的类
static class HTMLEditorKit.HTMLFactory
用于构建 HTML 视图的工厂。

返回 ViewFactory 的 javax.swing.text.html 中的方法
 ViewFactory HTMLEditorKit.getViewFactory()
获取一个适合供由此包所产生的任何模型来产生视图的工厂。

参数类型为 ViewFactory 的 javax.swing.text.html 中的方法
void | BlockView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
void | ImageView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 当 Elements 属性已更改时调用。
void | InlineView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | InlineView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | InlineView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.WrappedPlainView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.WrappedPlainView
的使用

没有 javax.swing.text.WrappedPlainView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.ZoneView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.ZoneView
的使用

没有 javax.swing.text.ZoneView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


HTMLDocument.HTMLReader.BlockAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.BlockAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
直接已知子类：
HTMLDocument.HTMLReader.ParagraphAction, HTMLDocument.HTMLReader.PreAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.BlockAction
extends HTMLDocument.HTMLReader.TagAction

构造方法摘要
HTMLDocument.HTMLReader.BlockAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet attr) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.BlockAction

public HTMLDocument.HTMLReader.BlockAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet attr)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.CharacterAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.CharacterAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.CharacterAction
extends HTMLDocument.HTMLReader.TagAction

构造方法摘要
HTMLDocument.HTMLReader.CharacterAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet attr) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.CharacterAction

public HTMLDocument.HTMLReader.CharacterAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet attr)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.FormAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.FormAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
            继承者  javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.FormAction
extends HTMLDocument.HTMLReader.SpecialAction

此动作通过构建所有用于表示表单控件的元素来支持表单。这将处理 <INPUT>、<TEXTAREA>、<SELECT> 和 <OPTION> 标记。此动作所创建的元素应该将属性 StyleConstants.ModelAttribute 设置为保存表单控件状态的模型。这就允许多个视图，并允许对文档进行迭代来获得表单数据。下面是各类表单元素的模型分配。

元素类型 | 模型类型
输入，类型为 button | DefaultButtonModel
输入，类型为 checkbox | JToggleButton.ToggleButtonModel
输入，类型为 image | DefaultButtonModel
输入，类型为 password | PlainDocument
输入，类型为 radio | JToggleButton.ToggleButtonModel
输入，类型为 reset | DefaultButtonModel
输入，类型为 submit | DefaultButtonModel
输入，类型为 text 或 null。 | PlainDocument
选择 | DefaultComboBoxModel 或 DefaultListModel，带有 Option 类型的项
textarea | PlainDocument

构造方法摘要
HTMLDocument.HTMLReader.FormAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet attr) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.FormAction

public HTMLDocument.HTMLReader.FormAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet attr)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.SpecialAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.HiddenAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.HiddenAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.HiddenAction
extends HTMLDocument.HTMLReader.TagAction

构造方法摘要
HTMLDocument.HTMLReader.HiddenAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet a) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.HiddenAction

public HTMLDocument.HTMLReader.HiddenAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet a)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.IsindexAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.IsindexAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.IsindexAction
extends HTMLDocument.HTMLReader.TagAction

构造方法摘要
HTMLDocument.HTMLReader.IsindexAction()
方法摘要
 void start(HTML.Tag t, MutableAttributeSet a)
当发现此动作所注册的标记类型的开始标记时调用。
从类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 继承的方法
end
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.IsindexAction

public HTMLDocument.HTMLReader.IsindexAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet a)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 start
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.ParagraphAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.ParagraphAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
            继承者  javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.ParagraphAction
extends HTMLDocument.HTMLReader.BlockAction

构造方法摘要
HTMLDocument.HTMLReader.ParagraphAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet a) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.ParagraphAction

public HTMLDocument.HTMLReader.ParagraphAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet a)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.BlockAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.BlockAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.PreAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.PreAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
            继承者  javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.PreAction
extends HTMLDocument.HTMLReader.BlockAction

构造方法摘要
HTMLDocument.HTMLReader.PreAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet attr) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.PreAction

public HTMLDocument.HTMLReader.PreAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet attr)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.BlockAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.BlockAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.SpecialAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.SpecialAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
直接已知子类：
HTMLDocument.HTMLReader.FormAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.SpecialAction
extends HTMLDocument.HTMLReader.TagAction

构造方法摘要
HTMLDocument.HTMLReader.SpecialAction()
方法摘要
 void start(HTML.Tag t, MutableAttributeSet a)
当发现此动作所注册的标记类型的开始标记时调用。
从类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 继承的方法
end
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.SpecialAction

public HTMLDocument.HTMLReader.SpecialAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet a)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 start
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.TagAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.TagAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
直接已知子类：
HTMLDocument.HTMLReader.BlockAction, HTMLDocument.HTMLReader.CharacterAction, HTMLDocument.HTMLReader.HiddenAction, HTMLDocument.HTMLReader.IsindexAction, HTMLDocument.HTMLReader.SpecialAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.TagAction
extends Object

为响应对标记的解析而执行的动作。这允许自定义每个标记的处理方式，并避免了大的 switch 语句。

构造方法摘要
HTMLDocument.HTMLReader.TagAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet a) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.TagAction

public HTMLDocument.HTMLReader.TagAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet a)
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

end

public void end(HTML.Tag t)
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


javax.swing.text.html (Java 2 Platform SE 6)

 javax.swing.text.html
类
BlockView
CSS
CSS.Attribute
FormSubmitEvent
FormView
HTML
HTML.Attribute
HTML.Tag
HTML.UnknownTag
HTMLDocument
HTMLDocument.Iterator
HTMLEditorKit
HTMLEditorKit.HTMLFactory
HTMLEditorKit.HTMLTextAction
HTMLEditorKit.InsertHTMLTextAction
HTMLEditorKit.LinkController
HTMLEditorKit.Parser
HTMLEditorKit.ParserCallback
HTMLFrameHyperlinkEvent
HTMLWriter
ImageView
InlineView
ListView
MinimalHTMLWriter
ObjectView
Option
ParagraphView
StyleSheet
StyleSheet.BoxPainter
StyleSheet.ListPainter
枚举
FormSubmitEvent.MethodType


类 javax.swing.text.html.BlockView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.BlockView
的使用

使用 BlockView 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 BlockView 的使用

javax.swing.text.html 中 BlockView 的子类
 class ListView
用于显示 html 列表的视图实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.CSS 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.CSS
的使用

没有 javax.swing.text.html.CSS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.CSS.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.CSS.Attribute
的使用

使用 CSS.Attribute 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 CSS.Attribute 的使用

声明为 CSS.Attribute 的 javax.swing.text.html 中的字段
static CSS.Attribute | CSS.Attribute.BACKGROUND
static CSS.Attribute | CSS.Attribute.BACKGROUND_ATTACHMENT
static CSS.Attribute | CSS.Attribute.BACKGROUND_COLOR
static CSS.Attribute | CSS.Attribute.BACKGROUND_IMAGE
static CSS.Attribute | CSS.Attribute.BACKGROUND_POSITION
static CSS.Attribute | CSS.Attribute.BACKGROUND_REPEAT
static CSS.Attribute | CSS.Attribute.BORDER
static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM
static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM_WIDTH
static CSS.Attribute | CSS.Attribute.BORDER_COLOR
static CSS.Attribute | CSS.Attribute.BORDER_LEFT
static CSS.Attribute | CSS.Attribute.BORDER_LEFT_WIDTH
static CSS.Attribute | CSS.Attribute.BORDER_RIGHT
static CSS.Attribute | CSS.Attribute.BORDER_RIGHT_WIDTH
static CSS.Attribute | CSS.Attribute.BORDER_STYLE
static CSS.Attribute | CSS.Attribute.BORDER_TOP
static CSS.Attribute | CSS.Attribute.BORDER_TOP_WIDTH
static CSS.Attribute | CSS.Attribute.BORDER_WIDTH
static CSS.Attribute | CSS.Attribute.CLEAR
static CSS.Attribute | CSS.Attribute.COLOR
static CSS.Attribute | CSS.Attribute.DISPLAY
static CSS.Attribute | CSS.Attribute.FLOAT
static CSS.Attribute | CSS.Attribute.FONT
static CSS.Attribute | CSS.Attribute.FONT_FAMILY
static CSS.Attribute | CSS.Attribute.FONT_SIZE
static CSS.Attribute | CSS.Attribute.FONT_STYLE
static CSS.Attribute | CSS.Attribute.FONT_VARIANT
static CSS.Attribute | CSS.Attribute.FONT_WEIGHT
static CSS.Attribute | CSS.Attribute.HEIGHT
static CSS.Attribute | CSS.Attribute.LETTER_SPACING
static CSS.Attribute | CSS.Attribute.LINE_HEIGHT
static CSS.Attribute | CSS.Attribute.LIST_STYLE
static CSS.Attribute | CSS.Attribute.LIST_STYLE_IMAGE
static CSS.Attribute | CSS.Attribute.LIST_STYLE_POSITION
static CSS.Attribute | CSS.Attribute.LIST_STYLE_TYPE
static CSS.Attribute | CSS.Attribute.MARGIN
static CSS.Attribute | CSS.Attribute.MARGIN_BOTTOM
static CSS.Attribute | CSS.Attribute.MARGIN_LEFT
static CSS.Attribute | CSS.Attribute.MARGIN_RIGHT
static CSS.Attribute | CSS.Attribute.MARGIN_TOP
static CSS.Attribute | CSS.Attribute.PADDING
static CSS.Attribute | CSS.Attribute.PADDING_BOTTOM
static CSS.Attribute | CSS.Attribute.PADDING_LEFT
static CSS.Attribute | CSS.Attribute.PADDING_RIGHT
static CSS.Attribute | CSS.Attribute.PADDING_TOP
static CSS.Attribute | CSS.Attribute.TEXT_ALIGN
static CSS.Attribute | CSS.Attribute.TEXT_DECORATION
static CSS.Attribute | CSS.Attribute.TEXT_INDENT
static CSS.Attribute | CSS.Attribute.TEXT_TRANSFORM
static CSS.Attribute | CSS.Attribute.VERTICAL_ALIGN
static CSS.Attribute | CSS.Attribute.WHITE_SPACE
static CSS.Attribute | CSS.Attribute.WIDTH
static CSS.Attribute | CSS.Attribute.WORD_SPACING

返回 CSS.Attribute 的 javax.swing.text.html 中的方法
static CSS.Attribute[] | CSS.getAllAttributeKeys() 返回所有可能的 CSS 属性键集合。
static CSS.Attribute | CSS.getAttribute(String name) 将字符串转换为 CSS.Attribute 对象。

参数类型为 CSS.Attribute 的 javax.swing.text.html 中的方法
void | StyleSheet.addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value) 将 CSS 属性添加到给定的集合。
boolean | StyleSheet.addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value) 将 CSS 属性添加到给定的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.FormSubmitEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.FormSubmitEvent
的使用

没有 javax.swing.text.html.FormSubmitEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.FormSubmitEvent.MethodType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.FormSubmitEvent.MethodType
的使用

使用 FormSubmitEvent.MethodType 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 FormSubmitEvent.MethodType 的使用

返回 FormSubmitEvent.MethodType 的 javax.swing.text.html 中的方法
FormSubmitEvent.MethodType | FormSubmitEvent.getMethod() 获取表单方法类型。
static FormSubmitEvent.MethodType | FormSubmitEvent.MethodType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static FormSubmitEvent.MethodType[] | FormSubmitEvent.MethodType.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.FormView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.FormView
的使用

没有 javax.swing.text.html.FormView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.FormView.MouseEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.FormView.MouseEventListener
的使用

没有 javax.swing.text.html.FormView.MouseEventListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTML 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTML
的使用

没有 javax.swing.text.html.HTML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTML.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTML.Attribute
的使用

使用 HTML.Attribute 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTML.Attribute 的使用

声明为 HTML.Attribute 的 javax.swing.text.html 中的字段
static HTML.Attribute | HTML.Attribute.ACTION
static HTML.Attribute | HTML.Attribute.ALIGN
static HTML.Attribute | HTML.Attribute.ALINK
static HTML.Attribute | HTML.Attribute.ALT
static HTML.Attribute | HTML.Attribute.ARCHIVE
static HTML.Attribute | HTML.Attribute.BACKGROUND
static HTML.Attribute | HTML.Attribute.BGCOLOR
static HTML.Attribute | HTML.Attribute.BORDER
static HTML.Attribute | HTML.Attribute.CELLPADDING
static HTML.Attribute | HTML.Attribute.CELLSPACING
static HTML.Attribute | HTML.Attribute.CHECKED
static HTML.Attribute | HTML.Attribute.CLASS
static HTML.Attribute | HTML.Attribute.CLASSID
static HTML.Attribute | HTML.Attribute.CLEAR
static HTML.Attribute | HTML.Attribute.CODE
static HTML.Attribute | HTML.Attribute.CODEBASE
static HTML.Attribute | HTML.Attribute.CODETYPE
static HTML.Attribute | HTML.Attribute.COLOR
static HTML.Attribute | HTML.Attribute.COLS
static HTML.Attribute | HTML.Attribute.COLSPAN
static HTML.Attribute | HTML.Attribute.COMMENT
static HTML.Attribute | HTML.Attribute.COMPACT
static HTML.Attribute | HTML.Attribute.CONTENT
static HTML.Attribute | HTML.Attribute.COORDS
static HTML.Attribute | HTML.Attribute.DATA
static HTML.Attribute | HTML.Attribute.DECLARE
static HTML.Attribute | HTML.Attribute.DIR
static HTML.Attribute | HTML.Attribute.DUMMY
static HTML.Attribute | HTML.Attribute.ENCTYPE
static HTML.Attribute | HTML.Attribute.ENDTAG
static HTML.Attribute | HTML.Attribute.FACE
static HTML.Attribute | HTML.Attribute.FRAMEBORDER
static HTML.Attribute | HTML.Attribute.HALIGN
static HTML.Attribute | HTML.Attribute.HEIGHT
static HTML.Attribute | HTML.Attribute.HREF
static HTML.Attribute | HTML.Attribute.HSPACE
static HTML.Attribute | HTML.Attribute.HTTPEQUIV
static HTML.Attribute | HTML.Attribute.ID
static HTML.Attribute | HTML.Attribute.ISMAP
static HTML.Attribute | HTML.Attribute.LANG
static HTML.Attribute | HTML.Attribute.LANGUAGE
static HTML.Attribute | HTML.Attribute.LINK
static HTML.Attribute | HTML.Attribute.LOWSRC
static HTML.Attribute | HTML.Attribute.MARGINHEIGHT
static HTML.Attribute | HTML.Attribute.MARGINWIDTH
static HTML.Attribute | HTML.Attribute.MAXLENGTH
static HTML.Attribute | HTML.Attribute.METHOD
static HTML.Attribute | HTML.Attribute.MULTIPLE
static HTML.Attribute | HTML.Attribute.N
static HTML.Attribute | HTML.Attribute.NAME
static HTML.Attribute | HTML.Attribute.NOHREF
static HTML.Attribute | HTML.Attribute.NORESIZE
static HTML.Attribute | HTML.Attribute.NOSHADE
static HTML.Attribute | HTML.Attribute.NOWRAP
static HTML.Attribute | HTML.Attribute.PROMPT
static HTML.Attribute | HTML.Attribute.REL
static HTML.Attribute | HTML.Attribute.REV
static HTML.Attribute | HTML.Attribute.ROWS
static HTML.Attribute | HTML.Attribute.ROWSPAN
static HTML.Attribute | HTML.Attribute.SCROLLING
static HTML.Attribute | HTML.Attribute.SELECTED
static HTML.Attribute | HTML.Attribute.SHAPE
static HTML.Attribute | HTML.Attribute.SHAPES
static HTML.Attribute | HTML.Attribute.SIZE
static HTML.Attribute | HTML.Attribute.SRC
static HTML.Attribute | HTML.Attribute.STANDBY
static HTML.Attribute | HTML.Attribute.START
static HTML.Attribute | HTML.Attribute.STYLE
static HTML.Attribute | HTML.Attribute.TARGET
static HTML.Attribute | HTML.Attribute.TEXT
static HTML.Attribute | HTML.Attribute.TITLE
static HTML.Attribute | HTML.Attribute.TYPE
static HTML.Attribute | HTML.Attribute.USEMAP
static HTML.Attribute | HTML.Attribute.VALIGN
static HTML.Attribute | HTML.Attribute.VALUE
static HTML.Attribute | HTML.Attribute.VALUETYPE
static HTML.Attribute | HTML.Attribute.VERSION
static HTML.Attribute | HTML.Attribute.VLINK
static HTML.Attribute | HTML.Attribute.VSPACE
static HTML.Attribute | HTML.Attribute.WIDTH

返回 HTML.Attribute 的 javax.swing.text.html 中的方法
static HTML.Attribute[] | HTML.getAllAttributeKeys() 返回所识别的 HTML 属性集。
static HTML.Attribute | HTML.getAttributeKey(String attName) 获取已知属性名称的属性常量（即集合 {FACE, COMMENT, SIZE, COLOR, CLEAR, BACKGROUND, BGCOLOR, TEXT, LINK, VLINK, ALINK, WIDTH, HEIGHT, ALIGN, NAME, HREF, REL, REV, TITLE, TARGET, SHAPE, COORDS, ISMAP, NOHREF, ALT, ID, SRC, HSPACE, VSPACE, USEMAP, LOWSRC, CODEBASE, CODE, ARCHIVE, VALUE, VALUETYPE, TYPE, CLASS, STYLE, LANG, DIR, DECLARE, CLASSID, DATA, CODETYPE, STANDBY, BORDER, SHAPES, NOSHADE, COMPACT, START, ACTION, METHOD, ENCTYPE, CHECKED, MAXLENGTH, MULTIPLE, SELECTED, ROWS, COLS, DUMMY, CELLSPACING, CELLPADDING, VALIGN, HALIGN, NOWRAP, ROWSPAN, COLSPAN, PROMPT, HTTPEQUIV, CONTENT, LANGUAGE, VERSION, N, FRAMEBORDER, MARGINWIDTH, MARGINHEIGHT, SCROLLING, NORESIZE, MEDIA, ENDTAG} 中的某个属性）。

参数类型为 HTML.Attribute 的 javax.swing.text.html 中的方法
static int HTML.getIntegerAttributeValue(AttributeSet attr, HTML.Attribute key, int def)
获取整数属性值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTML.Tag 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTML.Tag
的使用

使用 HTML.Tag 的软件包
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html 中 HTML.Tag 的使用

javax.swing.text.html 中 HTML.Tag 的子类
static class HTML.UnknownTag

声明为 HTML.Tag 的 javax.swing.text.html 中的字段
static HTML.Tag | HTML.Tag.A
static HTML.Tag | HTML.Tag.ADDRESS
protected HTML.Tag | HTMLEditorKit.InsertHTMLTextAction.addTag HTML 中的 Tag（从此 Tag 开始添加标记）。
protected HTML.Tag | HTMLEditorKit.InsertHTMLTextAction.alternateAddTag HTML 中的替换 Tag，如果未找到 parentTag 但找到了 alternateParentTag，则从此替换 Tag 开始添加标记。
protected HTML.Tag | HTMLEditorKit.InsertHTMLTextAction.alternateParentTag 如果未找到 parentTag，则要在文档中检查的替换 Tag。
static HTML.Tag | HTML.Tag.APPLET
static HTML.Tag | HTML.Tag.AREA
static HTML.Tag | HTML.Tag.B
static HTML.Tag | HTML.Tag.BASE
static HTML.Tag | HTML.Tag.BASEFONT
static HTML.Tag | HTML.Tag.BIG
static HTML.Tag | HTML.Tag.BLOCKQUOTE
static HTML.Tag | HTML.Tag.BODY
static HTML.Tag | HTML.Tag.BR
static HTML.Tag | HTML.Tag.CAPTION
static HTML.Tag | HTML.Tag.CENTER
static HTML.Tag | HTML.Tag.CITE
static HTML.Tag | HTML.Tag.CODE
static HTML.Tag | HTML.Tag.COMMENT 所有注释以此标记作为标签。
static HTML.Tag | HTML.Tag.CONTENT 所有文本内容以此标记作为标签。
static HTML.Tag | HTML.Tag.DD
static HTML.Tag | HTML.Tag.DFN
static HTML.Tag | HTML.Tag.DIR
static HTML.Tag | HTML.Tag.DIV
static HTML.Tag | HTML.Tag.DL
static HTML.Tag | HTML.Tag.DT
static HTML.Tag | HTML.Tag.EM
static HTML.Tag | HTML.Tag.FONT
static HTML.Tag | HTML.Tag.FORM
static HTML.Tag | HTML.Tag.FRAME
static HTML.Tag | HTML.Tag.FRAMESET
static HTML.Tag | HTML.Tag.H1
static HTML.Tag | HTML.Tag.H2
static HTML.Tag | HTML.Tag.H3
static HTML.Tag | HTML.Tag.H4
static HTML.Tag | HTML.Tag.H5
static HTML.Tag | HTML.Tag.H6
static HTML.Tag | HTML.Tag.HEAD
static HTML.Tag | HTML.Tag.HR
static HTML.Tag | HTML.Tag.HTML
static HTML.Tag | HTML.Tag.I
static HTML.Tag | HTML.Tag.IMG
static HTML.Tag | HTML.Tag.IMPLIED 所有文本内容必须包含在段落元素中。
static HTML.Tag | HTML.Tag.INPUT
static HTML.Tag | HTML.Tag.ISINDEX
static HTML.Tag | HTML.Tag.KBD
static HTML.Tag | HTML.Tag.LI
static HTML.Tag | HTML.Tag.LINK
static HTML.Tag | HTML.Tag.MAP
static HTML.Tag | HTML.Tag.MENU
static HTML.Tag | HTML.Tag.META
static HTML.Tag | HTML.Tag.NOFRAMES
static HTML.Tag | HTML.Tag.OBJECT
static HTML.Tag | HTML.Tag.OL
static HTML.Tag | HTML.Tag.OPTION
static HTML.Tag | HTML.Tag.P
static HTML.Tag | HTML.Tag.PARAM
protected HTML.Tag | HTMLEditorKit.InsertHTMLTextAction.parentTag 要在文档中检查的 Tag。
static HTML.Tag | HTML.Tag.PRE
static HTML.Tag | HTML.Tag.S
static HTML.Tag | HTML.Tag.SAMP
static HTML.Tag | HTML.Tag.SCRIPT
static HTML.Tag | HTML.Tag.SELECT
static HTML.Tag | HTML.Tag.SMALL
static HTML.Tag | HTML.Tag.SPAN
static HTML.Tag | HTML.Tag.STRIKE
static HTML.Tag | HTML.Tag.STRONG
static HTML.Tag | HTML.Tag.STYLE
static HTML.Tag | HTML.Tag.SUB
static HTML.Tag | HTML.Tag.SUP
static HTML.Tag | HTML.Tag.TABLE
static HTML.Tag | HTML.Tag.TD
static HTML.Tag | HTML.Tag.TEXTAREA
static HTML.Tag | HTML.Tag.TH
static HTML.Tag | HTML.Tag.TITLE
static HTML.Tag | HTML.Tag.TR
static HTML.Tag | HTML.Tag.TT
static HTML.Tag | HTML.Tag.U
static HTML.Tag | HTML.Tag.UL
static HTML.Tag | HTML.Tag.VAR

返回 HTML.Tag 的 javax.swing.text.html 中的方法
static HTML.Tag[] | HTML.getAllTags() 返回默认 HTML reader 所识别的实际 HTML 标记集。
abstract HTML.Tag | HTMLDocument.Iterator.getTag() 此迭代器所表示的标记类型。
static HTML.Tag | HTML.getTag(String tagName) 获取已知标记名称的标记常量（即集合 {A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOBR, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, S, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR} 中的某个标记）。

参数类型为 HTML.Tag 的 javax.swing.text.html 中的方法
protected void | HTMLDocument.HTMLReader.addSpecialElement(HTML.Tag t, MutableAttributeSet a) 添加基本上完全是在属性集中指定的内容。
protected void | HTMLDocument.HTMLReader.blockClose(HTML.Tag t) 向解析器缓冲区添加一条指令，以关闭给定类型的块元素。
protected void | HTMLDocument.HTMLReader.blockOpen(HTML.Tag t, MutableAttributeSet attr) 向解析器缓冲区添加一条指令，以创建具有给定属性的块元素。
protected int | HTMLEditorKit.HTMLTextAction.elementCountToTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回要获得表示 tag 的元素时，从最深的叶元素开始所需的元素数。
void | HTMLDocument.HTMLReader.TagAction.end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | HTMLDocument.HTMLReader.BlockAction.end(HTML.Tag t)
void | HTMLDocument.HTMLReader.ParagraphAction.end(HTML.Tag t)
void | HTMLDocument.HTMLReader.HiddenAction.end(HTML.Tag t)
void | HTMLDocument.HTMLReader.PreAction.end(HTML.Tag t)
void | HTMLDocument.HTMLReader.CharacterAction.end(HTML.Tag t)
void | HTMLDocument.HTMLReader.FormAction.end(HTML.Tag t)
protected Element | HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回在 offset 处与 tag 匹配的最深的元素。
HTMLDocument.Iterator | HTMLDocument.getIterator(HTML.Tag t) 获取指定 HTML 标记的迭代器。
HTMLEditorKit.ParserCallback | HTMLDocument.getReader(int pos, int popDepth, int pushDepth, HTML.Tag insertTag) 返回加载带有 HTML 的文档时所用解析器的 reader。
Style | StyleSheet.getRule(HTML.Tag t, Element e) 获取用来呈现给定类型的 HTML 标记的样式。
void | HTMLDocument.HTMLReader.handleEndTag(HTML.Tag t, int pos) 从解析器回调。
void | HTMLEditorKit.ParserCallback.handleEndTag(HTML.Tag t, int pos)
void | HTMLDocument.HTMLReader.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos) 从解析器回调。
void | HTMLEditorKit.ParserCallback.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
void | HTMLDocument.HTMLReader.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos) 从解析器回调。
void | HTMLEditorKit.ParserCallback.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 当在边界上插入时调用。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
void | HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag) 将 HTML 插入现有文档。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag) HTMLEditorKit.insertHTML 的一个覆盖。
protected boolean | HTMLWriter.matchNameAttribute(AttributeSet attr, HTML.Tag tag) 如果 StyleConstants.NameAttribute 与作为参数传入的标记相同，则返回 true。
protected void | HTMLDocument.HTMLReader.registerTag(HTML.Tag t, HTMLDocument.HTMLReader.TagAction a) 注册给定标记的处理程序。
void | HTMLDocument.HTMLReader.TagAction.start(HTML.Tag t, MutableAttributeSet a) 当发现此动作所注册的标记类型的开始标记时调用。
void | HTMLDocument.HTMLReader.BlockAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.ParagraphAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.SpecialAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.IsindexAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.HiddenAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.PreAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.CharacterAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.FormAction.start(HTML.Tag t, MutableAttributeSet attr)

参数类型为 HTML.Tag 的 javax.swing.text.html 中的构造方法
HTMLDocument.HTMLReader(int offset, int popDepth, int pushDepth, HTML.Tag insertTag)
HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag)
HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag, HTML.Tag alternateParentTag, HTML.Tag alternateAddTag)

javax.swing.text.html.parser 中 HTML.Tag 的使用

返回 HTML.Tag 的 javax.swing.text.html.parser 中的方法
 HTML.Tag TagElement.getHTMLTag()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTML.UnknownTag 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTML.UnknownTag
的使用

没有 javax.swing.text.html.HTML.UnknownTag 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument
的使用

使用 HTMLDocument 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLDocument 的使用

返回 HTMLDocument 的 javax.swing.text.html 中的方法
protected  HTMLDocument HTMLEditorKit.HTMLTextAction.getHTMLDocument(JEditorPane e)

参数类型为 HTMLDocument 的 javax.swing.text.html 中的方法
protected int | HTMLEditorKit.HTMLTextAction.elementCountToTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回要获得表示 tag 的元素时，从最深的叶元素开始所需的元素数。
protected Element | HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回在 offset 处与 tag 匹配的最深的元素。
protected Element[] | HTMLEditorKit.HTMLTextAction.getElementsAt(HTMLDocument doc, int offset) 返回包含 offset 的 Elements 数组。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 当在边界上插入时调用。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
void | HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag) 将 HTML 插入现有文档。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag) HTMLEditorKit.insertHTML 的一个覆盖。

参数类型为 HTMLDocument 的 javax.swing.text.html 中的构造方法
HTMLWriter(Writer w, HTMLDocument doc)
创建新的 HTMLWriter。
HTMLWriter(Writer w, HTMLDocument doc, int pos, int len)
创建新的 HTMLWriter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.BlockElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.BlockElement
的使用

没有 javax.swing.text.html.HTMLDocument.BlockElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
的使用

使用 HTMLDocument.HTMLReader.BlockAction 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLDocument.HTMLReader.BlockAction 的使用

javax.swing.text.html 中 HTMLDocument.HTMLReader.BlockAction 的子类
class | HTMLDocument.HTMLReader.ParagraphAction
class | HTMLDocument.HTMLReader.PreAction

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
的使用

使用 HTMLDocument.HTMLReader.SpecialAction 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLDocument.HTMLReader.SpecialAction 的使用

javax.swing.text.html 中 HTMLDocument.HTMLReader.SpecialAction 的子类
 class HTMLDocument.HTMLReader.FormAction
此动作通过构建所有用于表示表单控件的元素来支持表单。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
的使用

使用 HTMLDocument.HTMLReader.TagAction 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLDocument.HTMLReader.TagAction 的使用

javax.swing.text.html 中 HTMLDocument.HTMLReader.TagAction 的子类
class | HTMLDocument.HTMLReader.BlockAction
class | HTMLDocument.HTMLReader.CharacterAction
class | HTMLDocument.HTMLReader.FormAction 此动作通过构建所有用于表示表单控件的元素来支持表单。
class | HTMLDocument.HTMLReader.HiddenAction
class | HTMLDocument.HTMLReader.IsindexAction
class | HTMLDocument.HTMLReader.ParagraphAction
class | HTMLDocument.HTMLReader.PreAction
class | HTMLDocument.HTMLReader.SpecialAction

参数类型为 HTMLDocument.HTMLReader.TagAction 的 javax.swing.text.html 中的方法
protected  void HTMLDocument.HTMLReader.registerTag(HTML.Tag t, HTMLDocument.HTMLReader.TagAction a)
注册给定标记的处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.Iterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.Iterator
的使用

使用 HTMLDocument.Iterator 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLDocument.Iterator 的使用

返回 HTMLDocument.Iterator 的 javax.swing.text.html 中的方法
 HTMLDocument.Iterator HTMLDocument.getIterator(HTML.Tag t)
获取指定 HTML 标记的迭代器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.RunElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.RunElement
的使用

没有 javax.swing.text.html.HTMLDocument.RunElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit
的使用

使用 HTMLEditorKit 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLEditorKit 的使用

返回 HTMLEditorKit 的 javax.swing.text.html 中的方法
protected  HTMLEditorKit HTMLEditorKit.HTMLTextAction.getHTMLEditorKit(JEditorPane e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.HTMLFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.HTMLFactory
的使用

没有 javax.swing.text.html.HTMLEditorKit.HTMLFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction
的使用

使用 HTMLEditorKit.HTMLTextAction 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLEditorKit.HTMLTextAction 的使用

javax.swing.text.html 中 HTMLEditorKit.HTMLTextAction 的子类
static class HTMLEditorKit.InsertHTMLTextAction
InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
的使用

没有 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.LinkController 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.LinkController
的使用

没有 javax.swing.text.html.HTMLEditorKit.LinkController 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.Parser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.Parser
的使用

使用 HTMLEditorKit.Parser 的软件包
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html 中 HTMLEditorKit.Parser 的使用

返回 HTMLEditorKit.Parser 的 javax.swing.text.html 中的方法
HTMLEditorKit.Parser | HTMLDocument.getParser() 返回将 HTML 插入现有文档时所使用的解析器。
protected HTMLEditorKit.Parser | HTMLEditorKit.getParser() 获取要用于读取 HTML 流的解析器。

参数类型为 HTMLEditorKit.Parser 的 javax.swing.text.html 中的方法
 void HTMLDocument.setParser(HTMLEditorKit.Parser parser)
设置将 html 插入现有文档的方法所使用的解析器，例如 setInnerHTML 和 setOuterHTML。

javax.swing.text.html.parser 中 HTMLEditorKit.Parser 的使用

javax.swing.text.html.parser 中 HTMLEditorKit.Parser 的子类
 class ParserDelegator
负责每次在调用其 parse 方法时启动一个新的 DocumentParser。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.ParserCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.ParserCallback
的使用

使用 HTMLEditorKit.ParserCallback 的软件包
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html 中 HTMLEditorKit.ParserCallback 的使用

javax.swing.text.html 中 HTMLEditorKit.ParserCallback 的子类
 class HTMLDocument.HTMLReader
一个 HTML reader，用来加载具有 HTML 元素结构的 HTML 文档。

返回 HTMLEditorKit.ParserCallback 的 javax.swing.text.html 中的方法
HTMLEditorKit.ParserCallback | HTMLDocument.getReader(int pos) 获取加载带有 HTML 的文档时所用解析器的 reader。
HTMLEditorKit.ParserCallback | HTMLDocument.getReader(int pos, int popDepth, int pushDepth, HTML.Tag insertTag) 返回加载带有 HTML 的文档时所用解析器的 reader。

参数类型为 HTMLEditorKit.ParserCallback 的 javax.swing.text.html 中的方法
abstract  void HTMLEditorKit.Parser.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
解析给定的流并通过解析的结果驱动给定的回调。

javax.swing.text.html.parser 中 HTMLEditorKit.ParserCallback 的使用

参数类型为 HTMLEditorKit.ParserCallback 的 javax.swing.text.html.parser 中的方法
void | DocumentParser.parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
void | ParserDelegator.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLFrameHyperlinkEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLFrameHyperlinkEvent
的使用

使用 HTMLFrameHyperlinkEvent 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLFrameHyperlinkEvent 的使用

javax.swing.text.html 中 HTMLFrameHyperlinkEvent 的子类
 class FormSubmitEvent
FormSubmitEvent 用于通知提交表单所需的参与者。

参数类型为 HTMLFrameHyperlinkEvent 的 javax.swing.text.html 中的方法
 void HTMLDocument.processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent e)
处理 HTML 框架中的文档所生成的 HyperlinkEvents。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLWriter
的使用

没有 javax.swing.text.html.HTMLWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.ImageView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.ImageView
的使用

没有 javax.swing.text.html.ImageView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.InlineView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.InlineView
的使用

没有 javax.swing.text.html.InlineView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.ListView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.ListView
的使用

没有 javax.swing.text.html.ListView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.MinimalHTMLWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.MinimalHTMLWriter
的使用

没有 javax.swing.text.html.MinimalHTMLWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.ObjectView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.ObjectView
的使用

没有 javax.swing.text.html.ObjectView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.Option 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.Option
的使用

使用 Option 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 Option 的使用

参数类型为 Option 的 javax.swing.text.html 中的方法
protected  void HTMLWriter.writeOption(Option option)
写出 Option 表单元素的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.ParagraphView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.ParagraphView
的使用

没有 javax.swing.text.html.ParagraphView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.StyleSheet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.StyleSheet
的使用

使用 StyleSheet 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 StyleSheet 的使用

返回 StyleSheet 的 javax.swing.text.html 中的方法
protected StyleSheet | BlockView.getStyleSheet()
StyleSheet | HTMLDocument.getStyleSheet() 获取具有特定于文档的显示规则（CSS）的 StyleSheet，其中这些规则是在 HTML 文档本身中指定的。
StyleSheet | HTMLEditorKit.getStyleSheet() 获取当前正用于呈现 HTML 元素的样式集。
protected StyleSheet | ImageView.getStyleSheet() 获取 StyleSheet 的便捷方法。
protected StyleSheet | InlineView.getStyleSheet()
protected StyleSheet | ParagraphView.getStyleSheet()
StyleSheet[] | StyleSheet.getStyleSheets() 返回一个链接 StyleSheet 的数组。

参数类型为 StyleSheet 的 javax.swing.text.html 中的方法
void | StyleSheet.addStyleSheet(StyleSheet ss) 将 StyleSheet ss 中的规则添加到接收者的规则中。
void | StyleSheet.removeStyleSheet(StyleSheet ss) 从接收者的规则中移除 StyleSheet ss。
void | HTMLEditorKit.setStyleSheet(StyleSheet s) 设置要用于呈现各种 HTML 元素的样式集。

参数类型为 StyleSheet 的 javax.swing.text.html 中的构造方法
HTMLDocument(AbstractDocument.Content c, StyleSheet styles)
构造具有给定内容存储实现和给定样式/属性存储机制的 HTML 文档。
HTMLDocument(StyleSheet styles)
构造具有默认内容存储实现和指定样式/属性存储机制的 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.StyleSheet.BoxPainter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.StyleSheet.BoxPainter
的使用

使用 StyleSheet.BoxPainter 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 StyleSheet.BoxPainter 的使用

返回 StyleSheet.BoxPainter 的 javax.swing.text.html 中的方法
 StyleSheet.BoxPainter StyleSheet.getBoxPainter(AttributeSet a)
获取给定 CSS 属性集合使用的框 formatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.StyleSheet.ListPainter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.StyleSheet.ListPainter
的使用

使用 StyleSheet.ListPainter 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 StyleSheet.ListPainter 的使用

返回 StyleSheet.ListPainter 的 javax.swing.text.html 中的方法
 StyleSheet.ListPainter StyleSheet.getListPainter(AttributeSet a)
获取给定 CSS 属性集合使用的列表 formatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.text.html.parser (Java 2 Platform SE 6)

 javax.swing.text.html.parser
接口
DTDConstants
类
AttributeList
ContentModel
DocumentParser
DTD
Element
Entity
Parser
ParserDelegator
TagElement


类 javax.swing.text.html.parser.AttributeList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.AttributeList
的使用

使用 AttributeList 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 AttributeList 的使用

声明为 AttributeList 的 javax.swing.text.html.parser 中的字段
AttributeList | Element.atts
AttributeList | AttributeList.next

返回 AttributeList 的 javax.swing.text.html.parser 中的方法
protected AttributeList | DTD.defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts) 创建并返回一个 AttributeList。
AttributeList | Element.getAttribute(String name) 按名称获取一个元素。
AttributeList | Element.getAttributeByValue(String name) 按值获取一个属性。
AttributeList | Element.getAttributes() 获取属性。
AttributeList | AttributeList.getNext()

参数类型为 AttributeList 的 javax.swing.text.html.parser 中的方法
protected AttributeList | DTD.defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts) 创建并返回一个 AttributeList。
protected Element | DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts) 创建并返回一个 Element。
void | DTD.defineAttributes(String name, AttributeList atts) 定义 Element 的属性。
Element | DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts) 返回与指定参数匹配的 Element。

参数类型为 AttributeList 的 javax.swing.text.html.parser 中的构造方法
AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
创建一个属性列表元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.parser.ContentModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.ContentModel
的使用

使用 ContentModel 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 ContentModel 的使用

声明为 ContentModel 的 javax.swing.text.html.parser 中的字段
ContentModel | Element.content
ContentModel | ContentModel.next 下一个内容模式（使用 ','、'|' 或 '&' 表达式）。

返回 ContentModel 的 javax.swing.text.html.parser 中的方法
protected ContentModel | DTD.defContentModel(int type, Object obj, ContentModel next) 创建并返回一个新的内容模式。
ContentModel | Element.getContent() 获取内容模式

参数类型为 ContentModel 的 javax.swing.text.html.parser 中的方法
protected ContentModel | DTD.defContentModel(int type, Object obj, ContentModel next) 创建并返回一个新的内容模式。
protected Element | DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts) 创建并返回一个 Element。
Element | DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts) 返回与指定参数匹配的 Element。

参数类型为 ContentModel 的 javax.swing.text.html.parser 中的构造方法
ContentModel(int type, ContentModel content)
创建一个特定类型的内容模式。
ContentModel(int type, Object content, ContentModel next)
创建一个特定类型的内容模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.parser.DocumentParser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.DocumentParser
的使用

没有 javax.swing.text.html.parser.DocumentParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.parser.DTD 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.DTD
的使用

使用 DTD 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 DTD 的使用

声明为 DTD 的 javax.swing.text.html.parser 中的字段
protected  DTD Parser.dtd

返回 DTD 的 javax.swing.text.html.parser 中的方法
protected static DTD | ParserDelegator.createDTD(DTD dtd, String name)
static DTD | DTD.getDTD(String name) 返回具有指定 name 的 DTD。

参数类型为 DTD 的 javax.swing.text.html.parser 中的方法
protected static DTD | ParserDelegator.createDTD(DTD dtd, String name)
static void | DTD.putDTDHash(String name, DTD dtd)

参数类型为 DTD 的 javax.swing.text.html.parser 中的构造方法
DocumentParser(DTD dtd)
Parser(DTD dtd)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.text.html.parser.DTDConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.html.parser.DTDConstants
的使用

使用 DTDConstants 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 DTDConstants 的使用

实现 DTDConstants 的 javax.swing.text.html.parser 中的类
class | AttributeList 此类使用 ATTLIST 构造定义 DTD 中描述的 SGML 元素的属性。
class | DocumentParser HTML 文档的解析器 (Parser)（实际上，您可以指定一个 DTD，但实际上仅应将此类与 swing 中的 html dtd 一起使用）。
class | DTD SGML DTD 的表示形式。
class | Element 使用 ELEMENT 构造在 DTD 中描述的一个元素。
class | Entity 使用 ENTITY 构造在 DTD 中描述了一个实体。
class | Parser 一个简单的 DTD 驱动的 HTML 解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.parser.Element 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.Element
的使用

使用 Element 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 Element 的使用

声明为 Element 的 javax.swing.text.html.parser 中的字段
Element | DTD.applet
Element | DTD.base
Element | DTD.body
Element | DTD.head
Element | DTD.html
Element | DTD.isindex
Element | DTD.meta
Element | DTD.p
Element | DTD.param
Element | DTD.pcdata
Element | DTD.title

类型参数类型为 Element 的 javax.swing.text.html.parser 中的字段
Hashtable<String,Element> | DTD.elementHash
Vector<Element> | DTD.elements

返回 Element 的 javax.swing.text.html.parser 中的方法
protected Element | DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts) 创建并返回一个 Element。
Element | DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts) 返回与指定参数匹配的 Element。
Element | ContentModel.first() 返回必须具有下一个的元素。
Element | TagElement.getElement()
Element | DTD.getElement(int index) 按索引获取一个元素。
Element | DTD.getElement(String name) 按名称获取一个元素。

参数类型为 Element 的 javax.swing.text.html.parser 中的方法
protected TagElement | Parser.makeTag(Element elem)
protected TagElement | Parser.makeTag(Element elem, boolean fictional) 制作 TagElement。
protected void | Parser.markFirstTime(Element elem) 标记在文档中首次看到标记

类型变量类型为 Element 的 javax.swing.text.html.parser 中的方法参数
 void ContentModel.getElements(Vector<Element> elemVec)
使用作为此 contentModel 一部分的元素列表更新 elemVec。

参数类型为 Element 的 javax.swing.text.html.parser 中的构造方法
ContentModel(Element content)
为元素创建一个内容模式。
TagElement(Element elem)
TagElement(Element elem, boolean fictional)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.parser.Entity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.Entity
的使用

使用 Entity 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 Entity 的使用

类型参数类型为 Entity 的 javax.swing.text.html.parser 中的字段
 Hashtable<Object,Entity> DTD.entityHash

返回 Entity 的 javax.swing.text.html.parser 中的方法
Entity | DTD.defEntity(String name, int type, int ch) 创建并返回一个字符 Entity。
protected Entity | DTD.defEntity(String name, int type, String str) 创建并返回一个 Entity。
Entity | DTD.defineEntity(String name, int type, char[] data) 定义一个实体。
Entity | DTD.getEntity(int ch) 获取一个字符实体。
Entity | DTD.getEntity(String name) 按名称获取一个实体。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.parser.Parser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.Parser
的使用

使用 Parser 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 Parser 的使用

javax.swing.text.html.parser 中 Parser 的子类
 class DocumentParser
HTML 文档的解析器 (Parser)（实际上，您可以指定一个 DTD，但实际上仅应将此类与 swing 中的 html dtd 一起使用）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.parser.ParserDelegator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.ParserDelegator
的使用

没有 javax.swing.text.html.parser.ParserDelegator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.text.html.parser.TagElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.TagElement
的使用

使用 TagElement 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 TagElement 的使用

返回 TagElement 的 javax.swing.text.html.parser 中的方法
protected TagElement | Parser.makeTag(Element elem)
protected TagElement | Parser.makeTag(Element elem, boolean fictional) 制作 TagElement。

参数类型为 TagElement 的 javax.swing.text.html.parser 中的方法
protected void | DocumentParser.handleEmptyTag(TagElement tag) 处理空标记。
protected void | Parser.handleEmptyTag(TagElement tag) 在遇到空标记时调用。
protected void | DocumentParser.handleEndTag(TagElement tag) 处理结束标记。
protected void | Parser.handleEndTag(TagElement tag) 在遇到结束标记时调用。
protected void | DocumentParser.handleStartTag(TagElement tag) 处理开始标记。
protected void | Parser.handleStartTag(TagElement tag) 在遇到开始标记时调用。
protected void | Parser.startTag(TagElement tag) 处理开始标记。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.text.rtf (Java 2 Platform SE 6)

 javax.swing.text.rtf
类
RTFEditorKit


类 javax.swing.text.rtf.RTFEditorKit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.rtf.RTFEditorKit
的使用

没有 javax.swing.text.rtf.RTFEditorKit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.tree (Java 2 Platform SE 6)

 javax.swing.tree
接口
MutableTreeNode
RowMapper
TreeCellEditor
TreeCellRenderer
TreeModel
TreeNode
TreeSelectionModel
类
AbstractLayoutCache
AbstractLayoutCache.NodeDimensions
DefaultMutableTreeNode
DefaultTreeCellEditor
DefaultTreeCellRenderer
DefaultTreeModel
DefaultTreeSelectionModel
FixedHeightLayoutCache
TreePath
VariableHeightLayoutCache
异常
ExpandVetoException


类 javax.swing.tree.AbstractLayoutCache 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.AbstractLayoutCache
的使用

使用 AbstractLayoutCache 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing.plaf.basic 中 AbstractLayoutCache 的使用

声明为 AbstractLayoutCache 的 javax.swing.plaf.basic 中的字段
protected  AbstractLayoutCache BasicTreeUI.treeState
负责处理大小和展开问题的对象。

返回 AbstractLayoutCache 的 javax.swing.plaf.basic 中的方法
protected  AbstractLayoutCache BasicTreeUI.createLayoutCache()
创建负责管理展开内容及节点大小的对象。

javax.swing.tree 中 AbstractLayoutCache 的使用

javax.swing.tree 中 AbstractLayoutCache 的子类
class | FixedHeightLayoutCache 注：在以后的版本中，这将变得更加开放。
class | VariableHeightLayoutCache 注：在以后的版本中，此类将变得更加开放。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.AbstractLayoutCache.NodeDimensions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.AbstractLayoutCache.NodeDimensions
的使用

使用 AbstractLayoutCache.NodeDimensions 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing.plaf.basic 中 AbstractLayoutCache.NodeDimensions 的使用

javax.swing.plaf.basic 中 AbstractLayoutCache.NodeDimensions 的子类
 class BasicTreeUI.NodeDimensionsHandler
负责获取节点大小的类，其方法被转发到 BasicTreeUI 方法。

声明为 AbstractLayoutCache.NodeDimensions 的 javax.swing.plaf.basic 中的字段
protected  AbstractLayoutCache.NodeDimensions BasicTreeUI.nodeDimensions
负责告知 TreeState 节点所需的大小。

返回 AbstractLayoutCache.NodeDimensions 的 javax.swing.plaf.basic 中的方法
protected  AbstractLayoutCache.NodeDimensions BasicTreeUI.createNodeDimensions()
创建能够确定树中给定节点大小的 NodeDimensions 的实例。

javax.swing.tree 中 AbstractLayoutCache.NodeDimensions 的使用

声明为 AbstractLayoutCache.NodeDimensions 的 javax.swing.tree 中的字段
protected  AbstractLayoutCache.NodeDimensions AbstractLayoutCache.nodeDimensions
负责获取节点大小的对象。

返回 AbstractLayoutCache.NodeDimensions 的 javax.swing.tree 中的方法
 AbstractLayoutCache.NodeDimensions AbstractLayoutCache.getNodeDimensions()
返回呈现树中节点的对象，它负责计算各个节点的尺寸。

参数类型为 AbstractLayoutCache.NodeDimensions 的 javax.swing.tree 中的方法
void | VariableHeightLayoutCache.setNodeDimensions(AbstractLayoutCache.NodeDimensions nd) 设置负责绘制树中节点的渲染器。
void | AbstractLayoutCache.setNodeDimensions(AbstractLayoutCache.NodeDimensions nd) 设置负责绘制树中节点的 renderer，因此，它还负责计算各个节点的尺寸。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.DefaultMutableTreeNode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultMutableTreeNode
的使用

使用 DefaultMutableTreeNode 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 DefaultMutableTreeNode 的使用

javax.swing 中 DefaultMutableTreeNode 的子类
static class JTree.DynamicUtilTreeNode
DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。

参数类型为 DefaultMutableTreeNode 的 javax.swing 中的方法
static void JTree.DynamicUtilTreeNode.createChildren(DefaultMutableTreeNode parent, Object children)
将 children 中的所有子节点添加到父节点。

javax.swing.tree 中 DefaultMutableTreeNode 的使用

返回 DefaultMutableTreeNode 的 javax.swing.tree 中的方法
DefaultMutableTreeNode | DefaultMutableTreeNode.getFirstLeaf() 查找并返回为此节点后代的第一个叶节点，即此节点或其第一个子节点的第一个叶节点。
DefaultMutableTreeNode | DefaultMutableTreeNode.getLastLeaf() 查找并返回为此节点后代的最后一个叶节点，即此节点或其最后一个子节点的最后一个叶节点。
DefaultMutableTreeNode | DefaultMutableTreeNode.getNextLeaf() 返回此节点后面的叶节点，如果此节点是树中的最后一个叶节点，则返回 null。
DefaultMutableTreeNode | DefaultMutableTreeNode.getNextNode() 返回在此节点的树的前序遍历中此节点之后的节点。
DefaultMutableTreeNode | DefaultMutableTreeNode.getNextSibling() 返回父节点的子节点数组中此节点的下一个兄弟节点。
DefaultMutableTreeNode | DefaultMutableTreeNode.getPreviousLeaf() 返回此节点之前的叶节点，如果此节点是树中的第一个叶节点，则返回 null。
DefaultMutableTreeNode | DefaultMutableTreeNode.getPreviousNode() 返回在此节点树的前序遍历中此节点之前的节点。
DefaultMutableTreeNode | DefaultMutableTreeNode.getPreviousSibling() 返回父节点的子节点数组中此节点的前一个兄弟节点。

参数类型为 DefaultMutableTreeNode 的 javax.swing.tree 中的方法
TreeNode | DefaultMutableTreeNode.getSharedAncestor(DefaultMutableTreeNode aNode) 返回此节点和 aNode 最近的共同祖先。
boolean | DefaultMutableTreeNode.isNodeDescendant(DefaultMutableTreeNode anotherNode) 如果 anotherNode 是此节点的后代 -- 如果它是此节点、此节点的一个子节点或此节点的一个子节点的后代，则返回 true。
boolean | DefaultMutableTreeNode.isNodeRelated(DefaultMutableTreeNode aNode) 当且仅当 aNode 位于与此节点相同的树中时，返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeCellEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeCellEditor
的使用

没有 javax.swing.tree.DefaultTreeCellEditor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
的使用

没有 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer
的使用

没有 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeCellRenderer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeCellRenderer
的使用

使用 DefaultTreeCellRenderer 的软件包
javax.swing.tree 提供处理 javax.swing.JTree 的类和接口。

javax.swing.tree 中 DefaultTreeCellRenderer 的使用

声明为 DefaultTreeCellRenderer 的 javax.swing.tree 中的字段
protected  DefaultTreeCellRenderer DefaultTreeCellEditor.renderer
用于从中获取边框和偏移量的呈现器。

参数类型为 DefaultTreeCellRenderer 的 javax.swing.tree 中的构造方法
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer)
使用指定呈现器和默认编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
使用指定的呈现器和指定的编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeModel
的使用

没有 javax.swing.tree.DefaultTreeModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeSelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeSelectionModel
的使用

使用 DefaultTreeSelectionModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DefaultTreeSelectionModel 的使用

javax.swing 中 DefaultTreeSelectionModel 的子类
protected static class JTree.EmptySelectionModel
EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.ExpandVetoException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.ExpandVetoException
的使用

使用 ExpandVetoException 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

javax.swing 中 ExpandVetoException 的使用

抛出 ExpandVetoException 的 javax.swing 中的方法
void | JTree.fireTreeWillCollapse(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
void | JTree.fireTreeWillExpand(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。

javax.swing.event 中 ExpandVetoException 的使用

抛出 ExpandVetoException 的 javax.swing.event 中的方法
void | TreeWillExpandListener.treeWillCollapse(TreeExpansionEvent event) 每当树中的一个节点将被折叠时调用。
void | TreeWillExpandListener.treeWillExpand(TreeExpansionEvent event) 每当树中的一个节点将被扩展时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.FixedHeightLayoutCache 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.FixedHeightLayoutCache
的使用

没有 javax.swing.tree.FixedHeightLayoutCache 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.tree.MutableTreeNode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.MutableTreeNode
的使用

使用 MutableTreeNode 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 MutableTreeNode 的使用

实现 MutableTreeNode 的 javax.swing 中的类
static class JTree.DynamicUtilTreeNode
DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。

javax.swing.tree 中 MutableTreeNode 的使用

实现 MutableTreeNode 的 javax.swing.tree 中的类
 class DefaultMutableTreeNode
DefaultMutableTreeNode 是树数据结构中的通用节点。

声明为 MutableTreeNode 的 javax.swing.tree 中的字段
protected  MutableTreeNode DefaultMutableTreeNode.parent
此节点的父节点，如果此节点没有父节点，则为 null

参数类型为 MutableTreeNode 的 javax.swing.tree 中的方法
void | DefaultMutableTreeNode.add(MutableTreeNode newChild) 从其父节点移除 newChild，并通过将其添加到此节点的子数组的结尾，使其成为此节点的子节点。
void | DefaultMutableTreeNode.insert(MutableTreeNode newChild, int childIndex) 从其现有父节点移除 newChild（如果它有父节点），将子节点的父节点设置为此节点，然后，将该子节点添加到此节点位于索引 childIndex 处的子节点数组。
void | MutableTreeNode.insert(MutableTreeNode child, int index) 将 child 添加到 index 位置的接收者。
void | DefaultTreeModel.insertNodeInto(MutableTreeNode newChild, MutableTreeNode parent, int index) 对它进行调用，以便在父节点的子节点中的 index 位置插入 newChild。
void | DefaultMutableTreeNode.remove(MutableTreeNode aChild) 通过向其提供一个 null 父节点，从此节点的子节点数组移除 aChild。
void | MutableTreeNode.remove(MutableTreeNode node) 从接收者移除 node。
void | DefaultTreeModel.removeNodeFromParent(MutableTreeNode node) 通知它从其父节点中移除节点。
void | DefaultMutableTreeNode.setParent(MutableTreeNode newParent) 将此节点的父节点设置为 newParent，但不更改父节点的子节点数组。
void | MutableTreeNode.setParent(MutableTreeNode newParent) 将接收者的父对象设置为 newParent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.tree.RowMapper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.RowMapper
的使用

使用 RowMapper 的软件包
javax.swing.tree 提供处理 javax.swing.JTree 的类和接口。

javax.swing.tree 中 RowMapper 的使用

实现 RowMapper 的 javax.swing.tree 中的类
class | AbstractLayoutCache 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | FixedHeightLayoutCache 注：在以后的版本中，这将变得更加开放。
class | VariableHeightLayoutCache 注：在以后的版本中，此类将变得更加开放。

声明为 RowMapper 的 javax.swing.tree 中的字段
protected  RowMapper DefaultTreeSelectionModel.rowMapper
提供给定路径的行。

返回 RowMapper 的 javax.swing.tree 中的方法
RowMapper | DefaultTreeSelectionModel.getRowMapper() 返回能够将 TreePath 映射到行的 RowMapper 实例。
RowMapper | TreeSelectionModel.getRowMapper() 返回能够将 TreePath 映射到行的 RowMapper 实例。

参数类型为 RowMapper 的 javax.swing.tree 中的方法
void | DefaultTreeSelectionModel.setRowMapper(RowMapper newMapper) 设置 RowMapper 实例。
void | TreeSelectionModel.setRowMapper(RowMapper newMapper) 设置 RowMapper 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.tree.TreeCellEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.TreeCellEditor
的使用

使用 TreeCellEditor 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeCellEditor 的使用

实现 TreeCellEditor 的 javax.swing 中的类
 class DefaultCellEditor
表单元格和树单元格的默认编辑器。

声明为 TreeCellEditor 的 javax.swing 中的字段
protected  TreeCellEditor JTree.cellEditor
条目编辑器。

返回 TreeCellEditor 的 javax.swing 中的方法
 TreeCellEditor JTree.getCellEditor()
返回用于编辑树中条目的编辑器。

参数类型为 TreeCellEditor 的 javax.swing 中的方法
 void JTree.setCellEditor(TreeCellEditor cellEditor)
设置单元格编辑器。

javax.swing.plaf.basic 中 TreeCellEditor 的使用

声明为 TreeCellEditor 的 javax.swing.plaf.basic 中的字段
protected  TreeCellEditor BasicTreeUI.cellEditor
树的编辑器。

返回 TreeCellEditor 的 javax.swing.plaf.basic 中的方法
protected TreeCellEditor | BasicTreeUI.createDefaultCellEditor() 创建默认单元格编辑器。
protected TreeCellEditor | BasicTreeUI.getCellEditor()

参数类型为 TreeCellEditor 的 javax.swing.plaf.basic 中的方法
protected  void BasicTreeUI.setCellEditor(TreeCellEditor editor)
设置单元格编辑器。

javax.swing.tree 中 TreeCellEditor 的使用

实现 TreeCellEditor 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor
TreeCellEditor。

声明为 TreeCellEditor 的 javax.swing.tree 中的字段
protected  TreeCellEditor DefaultTreeCellEditor.realEditor
处理该编辑的编辑器。

返回 TreeCellEditor 的 javax.swing.tree 中的方法
protected  TreeCellEditor DefaultTreeCellEditor.createTreeCellEditor()
如果构造方法中没有提供 TreeCellEditor，则调用此方法。

参数类型为 TreeCellEditor 的 javax.swing.tree 中的构造方法
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
使用指定的呈现器和指定的编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.tree.TreeCellRenderer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.TreeCellRenderer
的使用

使用 TreeCellRenderer 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeCellRenderer 的使用

声明为 TreeCellRenderer 的 javax.swing 中的字段
protected  TreeCellRenderer JTree.cellRenderer
用于绘制节点的单元格。

返回 TreeCellRenderer 的 javax.swing 中的方法
 TreeCellRenderer JTree.getCellRenderer()
返回正在呈现每个单元格的当前 TreeCellRenderer。

参数类型为 TreeCellRenderer 的 javax.swing 中的方法
 void JTree.setCellRenderer(TreeCellRenderer x)
设置将用于绘制每个单元格的 TreeCellRenderer。

javax.swing.plaf.basic 中 TreeCellRenderer 的使用

声明为 TreeCellRenderer 的 javax.swing.plaf.basic 中的字段
protected  TreeCellRenderer BasicTreeUI.currentCellRenderer
要用于进行实际单元格绘制的渲染器。

返回 TreeCellRenderer 的 javax.swing.plaf.basic 中的方法
protected TreeCellRenderer | BasicTreeUI.createDefaultCellRenderer() 返回用于为每个节点添加标志的默认单元格渲染器。
protected TreeCellRenderer | BasicTreeUI.getCellRenderer() 返回 currentCellRenderer，可以为树渲染器，也可以为 defaultCellRenderer，无论哪个都不为 null。

参数类型为 TreeCellRenderer 的 javax.swing.plaf.basic 中的方法
protected  void BasicTreeUI.setCellRenderer(TreeCellRenderer tcr)
将 TreeCellRenderer 设置为 tcr。

javax.swing.tree 中 TreeCellRenderer 的使用

实现 TreeCellRenderer 的 javax.swing.tree 中的类
 class DefaultTreeCellRenderer
显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.tree.TreeModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.TreeModel
的使用

使用 TreeModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeModel 的使用

声明为 TreeModel 的 javax.swing 中的字段
protected  TreeModel JTree.treeModel
定义此对象显示的树的模型。

返回 TreeModel 的 javax.swing 中的方法
protected static TreeModel | JTree.createTreeModel(Object value) 返回一个 TreeModel，它包装指定的对象。
protected static TreeModel | JTree.getDefaultTreeModel() 创建并返回一个示例 TreeModel。
TreeModel | JTree.getModel() 返回正在提供数据的 TreeModel。

参数类型为 TreeModel 的 javax.swing 中的方法
 void JTree.setModel(TreeModel newModel)
设置将提供数据的 TreeModel。

参数类型为 TreeModel 的 javax.swing 中的构造方法
JTree(TreeModel newModel)
返回 JTree 的一个实例，它显示根节点 - 使用指定的数据模型创建树。

javax.swing.plaf.basic 中 TreeModel 的使用

声明为 TreeModel 的 javax.swing.plaf.basic 中的字段
protected  TreeModel BasicTreeUI.treeModel
用于确定要显示的内容。

返回 TreeModel 的 javax.swing.plaf.basic 中的方法
protected  TreeModel BasicTreeUI.getModel()

参数类型为 TreeModel 的 javax.swing.plaf.basic 中的方法
protected  void BasicTreeUI.setModel(TreeModel model)
设置 TreeModel。

javax.swing.tree 中 TreeModel 的使用

实现 TreeModel 的 javax.swing.tree 中的类
 class DefaultTreeModel
使用 TreeNodes 的简单树数据模型。

声明为 TreeModel 的 javax.swing.tree 中的字段
protected  TreeModel AbstractLayoutCache.treeModel
提供信息的模型。

返回 TreeModel 的 javax.swing.tree 中的方法
 TreeModel AbstractLayoutCache.getModel()
返回要提供数据的 TreeModel。

参数类型为 TreeModel 的 javax.swing.tree 中的方法
void | FixedHeightLayoutCache.setModel(TreeModel newModel) 设置将提供数据的 TreeModel。
void | VariableHeightLayoutCache.setModel(TreeModel newModel) 设置将提供数据的 TreeModel。
void | AbstractLayoutCache.setModel(TreeModel newModel) 设置将提供数据的 TreeModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.tree.TreeNode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.TreeNode
的使用

使用 TreeNode 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeNode 的使用

实现 TreeNode 的 javax.swing 中的类
static class JTree.DynamicUtilTreeNode
DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。

返回 TreeNode 的 javax.swing 中的方法
 TreeNode JTree.DynamicUtilTreeNode.getChildAt(int index)
必要时创建子类以加载此子节点。

参数类型为 TreeNode 的 javax.swing 中的构造方法
JTree(TreeNode root)
返回 JTree，指定的 TreeNode 作为其根，它显示根节点。
JTree(TreeNode root, boolean asksAllowsChildren)
返回 JTree，指定的 TreeNode 作为其根，它用指定的方式显示根节点，并确定节点是否为叶节点。

javax.swing.text 中 TreeNode 的使用

实现 TreeNode 的 javax.swing.text 中的类
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。

返回 TreeNode 的 javax.swing.text 中的方法
TreeNode | AbstractDocument.AbstractElement.getChildAt(int childIndex) 在索引 childIndex 处返回子级 TreeNode。
TreeNode | AbstractDocument.AbstractElement.getParent() 返回接收方的父级 TreeNode。

参数类型为 TreeNode 的 javax.swing.text 中的方法
 int AbstractDocument.AbstractElement.getIndex(TreeNode node)
返回接收方子级中 node 的索引。

javax.swing.text.html 中 TreeNode 的使用

实现 TreeNode 的 javax.swing.text.html 中的类
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

javax.swing.tree 中 TreeNode 的使用

javax.swing.tree 中 TreeNode 的子接口
 interface MutableTreeNode
定义针对树节点对象的要求，这些树节点可以通过以下操作更改：添加或移除子节点，或更改该节点中存储的用户对象的内容。

实现 TreeNode 的 javax.swing.tree 中的类
 class DefaultMutableTreeNode
DefaultMutableTreeNode 是树数据结构中的通用节点。

声明为 TreeNode 的 javax.swing.tree 中的字段
protected  TreeNode DefaultTreeModel.root
树的根。

类型参数类型为 TreeNode 的 javax.swing.tree 中的字段
static Enumeration<TreeNode> DefaultMutableTreeNode.EMPTY_ENUMERATION
始终为空的枚举。

返回 TreeNode 的 javax.swing.tree 中的方法
TreeNode | DefaultMutableTreeNode.getChildAfter(TreeNode aChild) 返回此节点的子节点数组中刚好跟在 aChild 之后的子节点，它必须是此节点的子节点。
TreeNode | DefaultMutableTreeNode.getChildAt(int index) 返回此节点的子节点数组中指定索引处的子节点。
TreeNode | TreeNode.getChildAt(int childIndex) 返回索引 childIndex 位置的子 TreeNode。
TreeNode | DefaultMutableTreeNode.getChildBefore(TreeNode aChild) 返回此节点的子节点数组中刚好在 aChild 之前的子节点，它必须是此节点的子节点。
TreeNode | DefaultMutableTreeNode.getFirstChild() 返回此节点的第一个子节点。
TreeNode | DefaultMutableTreeNode.getLastChild() 返回此节点的最后一个子节点。
TreeNode | DefaultMutableTreeNode.getParent() 返回此节点的父节点，如果此节点没有父节点，则返回 null。
TreeNode | TreeNode.getParent() 返回接收者的父 TreeNode。
TreeNode[] | DefaultMutableTreeNode.getPath() 返回从根到达此节点的路径。
TreeNode[] | DefaultTreeModel.getPathToRoot(TreeNode aNode) 向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
protected TreeNode[] | DefaultTreeModel.getPathToRoot(TreeNode aNode, int depth) 向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
protected TreeNode[] | DefaultMutableTreeNode.getPathToRoot(TreeNode aNode, int depth) 构建节点的父节点一直到根节点（包括根节点），其中源节点是返回数组中的最后一个元素。
TreeNode | DefaultMutableTreeNode.getRoot() 返回包含此节点的树的根。
TreeNode | DefaultMutableTreeNode.getSharedAncestor(DefaultMutableTreeNode aNode) 返回此节点和 aNode 最近的共同祖先。

参数类型为 TreeNode 的 javax.swing.tree 中的方法
TreeNode | DefaultMutableTreeNode.getChildAfter(TreeNode aChild) 返回此节点的子节点数组中刚好跟在 aChild 之后的子节点，它必须是此节点的子节点。
TreeNode | DefaultMutableTreeNode.getChildBefore(TreeNode aChild) 返回此节点的子节点数组中刚好在 aChild 之前的子节点，它必须是此节点的子节点。
int | DefaultMutableTreeNode.getIndex(TreeNode aChild) 返回此节点的子节点数组中指定子节点的索引。
int | TreeNode.getIndex(TreeNode node) 返回接收者子节点中的 node 的索引。
TreeNode[] | DefaultTreeModel.getPathToRoot(TreeNode aNode) 向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
protected TreeNode[] | DefaultTreeModel.getPathToRoot(TreeNode aNode, int depth) 向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
protected TreeNode[] | DefaultMutableTreeNode.getPathToRoot(TreeNode aNode, int depth) 构建节点的父节点一直到根节点（包括根节点），其中源节点是返回数组中的最后一个元素。
boolean | DefaultMutableTreeNode.isNodeAncestor(TreeNode anotherNode) 如果 anotherNode 是此节点的祖先 -- 如果它是此节点、此节点的父节点或此节点的父节点的祖先，则返回 true。
boolean | DefaultMutableTreeNode.isNodeChild(TreeNode aNode) 如果 aNode 是此节点的子节点，则返回 true。
boolean | DefaultMutableTreeNode.isNodeSibling(TreeNode anotherNode) 如果 anotherNode 是此节点的兄弟节点（与此节点共享同一父节点），则返回 true。
void | DefaultTreeModel.nodeChanged(TreeNode node) 更改节点在树中的表示方式之后，调用此方法。
void | DefaultTreeModel.nodesChanged(TreeNode node, int[] childIndices) 更改由 childIndicies 标识的子对象在树中的表示方式之后，调用此方法。
void | DefaultTreeModel.nodeStructureChanged(TreeNode node) 如果完全更改了节点的子节点、子节点的子节点、依此类推，则调用此方法。
void | DefaultTreeModel.nodesWereInserted(TreeNode node, int[] childIndices) 将某些 TreeNodes 插入节点之后，调用此方法。
void | DefaultTreeModel.nodesWereRemoved(TreeNode node, int[] childIndices, Object[] removedChildren) 从节点移除一些 TreeNodes 之后，调用此方法。
Enumeration | DefaultMutableTreeNode.pathFromAncestorEnumeration(TreeNode ancestor) 创建并返回沿着从 ancestor 到此节点的路径的一个枚举。
void | DefaultTreeModel.reload(TreeNode node) 如果已修改此模型依赖的 TreeNode，则调用此方法。
void | DefaultTreeModel.setRoot(TreeNode root) 将根设置为 root。

参数类型为 TreeNode 的 javax.swing.tree 中的构造方法
DefaultTreeModel(TreeNode root)
创建其中任何节点都可以有子节点的树。
DefaultTreeModel(TreeNode root, boolean asksAllowsChildren)
创建一棵树，指定某个节点是否可以有子节点，或者是否仅某些节点可以有子节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.TreePath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.TreePath
的使用

使用 TreePath 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreePath 的使用

返回 TreePath 的 javax.swing 中的方法
TreePath | JTree.getAnchorSelectionPath() 返回标识为定位的路径。
TreePath | JTree.getClosestPathForLocation(int x, int y) 返回离 x,y 最近的节点的路径。
TreePath | JTree.getEditingPath() 返回当前正在编辑的元素的路径。
TreePath | JTree.getLeadSelectionPath() 返回标识为前导的路径。
TreePath | JTree.getNextMatch(String prefix, int startingRow, Position.Bias bias) 将 TreePath 返回到以一个前缀开头的下一个树元素。
TreePath | JTree.DropLocation.getPath() 返回树中应该用来放入放置数据的路径。
protected TreePath[] | JTree.getPathBetweenRows(int index0, int index1) 返回 JTreePath 实例，它表示 index0 和 index1（包括 index1）之间的路径。
TreePath | JTree.getPathForLocation(int x, int y) 返回指定位置处的节点路径。
TreePath | JTree.getPathForRow(int row) 返回指定行的路径。
TreePath | JTree.getSelectionPath() 返回首选节点的路径。
TreePath[] | JTree.getSelectionPaths() 返回所有选择值的路径。

返回变量类型为 TreePath 的类型的 javax.swing 中的方法
protected Enumeration<TreePath> | JTree.getDescendantToggledPaths(TreePath parent) 返回已展开且为 parent 的子路径的 TreePath 的 Enumeration。
Enumeration<TreePath> | JTree.getExpandedDescendants(TreePath parent) 返回当前展开的 parent 路径的子路径的 Enumeration。

参数类型为 TreePath 的 javax.swing 中的方法
void | JTree.addSelectionPath(TreePath path) 将由指定的 TreePath 标识的节点添加到当前选择。
void | JTree.addSelectionPaths(TreePath[] paths) 将路径数组中的每个路径添加到当前选择。
void | JTree.EmptySelectionModel.addSelectionPaths(TreePath[] paths) 一个未添加任何内容的 null 实现。
void | JTree.collapsePath(TreePath path) 确保指定路径标识的节点是折叠的，并且可查看。
void | JTree.expandPath(TreePath path) 确保指定路径标识的节点展开，并且可查看。
void | JTree.fireTreeCollapsed(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
void | JTree.fireTreeExpanded(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
void | JTree.fireTreeWillCollapse(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
void | JTree.fireTreeWillExpand(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected Enumeration<TreePath> | JTree.getDescendantToggledPaths(TreePath parent) 返回已展开且为 parent 的子路径的 TreePath 的 Enumeration。
Enumeration<TreePath> | JTree.getExpandedDescendants(TreePath parent) 返回当前展开的 parent 路径的子路径的 Enumeration。
Rectangle | JTree.getPathBounds(TreePath path) 返回将指定节点绘入的 Rectangle。
int | JTree.getRowForPath(TreePath path) 返回显示由指定路径标识的节点的行。
boolean | JTree.hasBeenExpanded(TreePath path) 如果已经展开路径标识的节点，则返回 true。
boolean | JTree.isCollapsed(TreePath path) 如果当前折叠了路径标识的值，则返回 true，如果当前未显示路径中的任何值，则返回 false。
boolean | JTree.isExpanded(TreePath path) 如果当前展开了路径标识的节点，则返回 true。
boolean | JTree.isPathEditable(TreePath path) 返回 isEditable。
boolean | JTree.isPathSelected(TreePath path) 如果当前选择了路径标识的条目，则返回 true。
boolean | JTree.isVisible(TreePath path) 如果当前可查看路径标识的值，则返回 true，这意味着该路径或者是根路径，或者它的所有父路径均被展开。
void | JTree.makeVisible(TreePath path) 确保路径标识的节点当前可查看。
protected boolean | JTree.removeDescendantSelectedPaths(TreePath path, boolean includePath) 移除选择中的任何路径（path 的子路径）。
void | JTree.removeSelectionPath(TreePath path) 从当前选择中移除指定路径标识的节点。
void | JTree.removeSelectionPaths(TreePath[] paths) 从当前选择移除指定路径标识的节点。
void | JTree.EmptySelectionModel.removeSelectionPaths(TreePath[] paths) 一个未移除任何内容的 null 实现。
void | JTree.scrollPathToVisible(TreePath path) 确保路径中所有的路径组件均展开（最后一个路径组件除外）并滚动，以便显示该路径标识的节点。
void | JTree.setAnchorSelectionPath(TreePath newPath) 将标识的路径设置为定位路径。
protected void | JTree.setExpandedState(TreePath path, boolean state) 设置此 JTree 的展开状态。
void | JTree.setLeadSelectionPath(TreePath newPath) 将标识的路径设置为前导路径。
void | JTree.setSelectionPath(TreePath path) 选择指定路径标识的节点。
void | JTree.setSelectionPaths(TreePath[] paths) 选择由指定的路径数组标识的节点。
void | JTree.EmptySelectionModel.setSelectionPaths(TreePath[] pPaths) 一个未选择任何内容的 null 实现。
void | JTree.startEditingAtPath(TreePath path) 选择指定路径标识的节点，并开始编辑。

类型变量类型为 TreePath 的 javax.swing 中的方法参数
protected  void JTree.removeDescendantToggledPaths(Enumeration<TreePath> toRemove)
移除已展开的 toRemove 中 TreePath 的所有子路径。

参数类型为 TreePath 的 javax.swing 中的构造方法
JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
构造一个 AccessibleJTreeNode

javax.swing.event 中 TreePath 的使用

声明为 TreePath 的 javax.swing.event 中的字段
protected TreePath | TreeSelectionEvent.newLeadSelectionPath 在路径被更改之后的 leadSelectionPath，可能为 null。
protected TreePath | TreeSelectionEvent.oldLeadSelectionPath 在路径被更改之前的 leadSelectionPath，可能为 null。
protected TreePath | TreeExpansionEvent.path 到达此事件表示的值的路径。
protected TreePath | TreeModelEvent.path 到达已更改节点的父节点的路径。
protected TreePath[] | TreeSelectionEvent.paths 此事件表示的路径。

返回 TreePath 的 javax.swing.event 中的方法
TreePath | TreeSelectionEvent.getNewLeadSelectionPath() 返回当前前导路径。
TreePath | TreeSelectionEvent.getOldLeadSelectionPath() 返回以前是前导路径的路径。
TreePath | TreeExpansionEvent.getPath() 返回到达已被扩展/折叠的值的路径。
TreePath | TreeSelectionEvent.getPath() 返回第一个路径元素。
TreePath[] | TreeSelectionEvent.getPaths() 返回已经添加到该选择中或已从中移除的路径。
TreePath | TreeModelEvent.getTreePath() 对于除 treeStructureChanged 以外的所有事件，返回已更改节点的父节点。

参数类型为 TreePath 的 javax.swing.event 中的方法
 boolean TreeSelectionEvent.isAddedPath(TreePath path)
如果 path 标识的路径被添加到选择中，则返回 true。

参数类型为 TreePath 的 javax.swing.event 中的构造方法
TreeExpansionEvent(Object source, TreePath path)
构造一个 TreeExpansionEvent 对象。
TreeModelEvent(Object source, TreePath path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 TreePath 对象。
TreeModelEvent(Object source, TreePath path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 TreePath 对象。
TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。
TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。
TreeSelectionEvent(Object source, TreePath path, boolean isNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。

javax.swing.plaf 中 TreePath 的使用

返回 TreePath 的 javax.swing.plaf 中的方法
abstract TreePath | TreeUI.getClosestPathForLocation(JTree tree, int x, int y) 返回到达最接近于 x,y 的那个节点的路径。
abstract TreePath | TreeUI.getEditingPath(JTree tree) 返回到达正被编辑的元素的路径。
abstract TreePath | TreeUI.getPathForRow(JTree tree, int row) 返回传入的 row 的路径。

参数类型为 TreePath 的 javax.swing.plaf 中的方法
abstract Rectangle | TreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
abstract int | TreeUI.getRowForPath(JTree tree, TreePath path) 返回可在其中看见路径中标识的最后一个项的行。
abstract void | TreeUI.startEditingAtPath(JTree tree, TreePath path) 选择路径中的最后一个项并试着编辑它。

javax.swing.plaf.basic 中 TreePath 的使用

声明为 TreePath 的 javax.swing.plaf.basic 中的字段
protected  TreePath BasicTreeUI.editingPath
要编辑的路径。

类型参数类型为 TreePath 的 javax.swing.plaf.basic 中的字段
protected  Hashtable<TreePath,Boolean> BasicTreeUI.drawingCache
用于最小化垂直线的绘制。

返回 TreePath 的 javax.swing.plaf.basic 中的方法
TreePath | BasicTreeUI.getClosestPathForLocation(JTree tree, int x, int y) 返回到达最接近于 x,y 的那个节点的路径。
TreePath | BasicTreeUI.getEditingPath(JTree tree) 返回到达正被编辑的元素的路径。
protected TreePath | BasicTreeUI.getLastChildPath(TreePath parent) 返回到 parent 的最后一个子节点的路径。
TreePath | BasicTreeUI.getPathForRow(JTree tree, int row) 返回传入的 row 的路径。

参数类型为 TreePath 的 javax.swing.plaf.basic 中的方法
protected void | BasicTreeUI.checkForClickInExpandControl(TreePath path, int mouseX, int mouseY) 如果 mouseX 和 mouseY 位于 row 的展开/折叠区域内，则此方法将切换行。
protected TreePath | BasicTreeUI.getLastChildPath(TreePath parent) 返回到 parent 的最后一个子节点的路径。
Rectangle | BasicTreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
int | BasicTreeUI.getRowForPath(JTree tree, TreePath path) 返回可在其中看见路径中标识的最后一个项的行。
protected void | BasicTreeUI.handleExpandControlClick(TreePath path, int mouseX, int mouseY) 当用户单击特定行时传递消息，此方法调用 toggleExpandState。
protected boolean | BasicTreeUI.isLocationInExpandControl(TreePath path, int mouseX, int mouseY) 如果 mouseX 和 mouseY 落在用于展开/折叠节点的行的区域内，并且 row 的节点不表示叶节点，则返回 true。
protected void | BasicTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制 row 的展开（切换）部分。
protected void | BasicTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制支路 (leg) 的水平部分。
protected void | BasicTreeUI.paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制 row 的渲染器部分。
protected void | BasicTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path) 绘制支路的垂直部分。
protected void | BasicTreeUI.pathWasCollapsed(TreePath path) 在折叠 VisibleTreeNode 后，从其传递消息。
protected void | BasicTreeUI.pathWasExpanded(TreePath path) 在展开 VisibleTreeNode 后，从其传递消息。
protected void | BasicTreeUI.selectPathForEvent(TreePath path, MouseEvent event) 传递消息以基于特定行上的 MouseEvent 更新选择。
protected boolean | BasicTreeUI.shouldPaintExpandControl(TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 如果应该为指定行绘制展开（切换）控件，则返回 true。
protected boolean | BasicTreeUI.startEditing(TreePath path, MouseEvent event) 如果存在 cellEditor 并且 shouldSelectCell 返回 true，则启动节点的编辑操作。
void | BasicTreeUI.startEditingAtPath(JTree tree, TreePath path) 选择路径中的最后一个项并尝试对其进行编辑。
protected void | BasicTreeUI.toggleExpandState(TreePath path) 如果路径不是展开的，则展开它；如果它是展开的，则折叠它。
protected void | BasicTreeUI.updateExpandedDescendants(TreePath path) 通过从树获取展开的子代并将其转发到树状态来更新 path 的所有子代的展开状态。

javax.swing.plaf.metal 中 TreePath 的使用

参数类型为 TreePath 的 javax.swing.plaf.metal 中的方法
protected void | MetalTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
protected void | MetalTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

javax.swing.plaf.multi 中 TreePath 的使用

返回 TreePath 的 javax.swing.plaf.multi 中的方法
TreePath | MultiTreeUI.getClosestPathForLocation(JTree a, int b, int c) 在由此对象处理的每个 UI 上调用 getClosestPathForLocation 方法。
TreePath | MultiTreeUI.getEditingPath(JTree a) 在由此对象处理的每个 UI 上调用 getEditingPath 方法。
TreePath | MultiTreeUI.getPathForRow(JTree a, int b) 在由此对象处理的每个 UI 上调用 getPathForRow 方法。

参数类型为 TreePath 的 javax.swing.plaf.multi 中的方法
Rectangle | MultiTreeUI.getPathBounds(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getPathBounds 方法。
int | MultiTreeUI.getRowForPath(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getRowForPath 方法。
void | MultiTreeUI.startEditingAtPath(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 startEditingAtPath 方法。

javax.swing.tree 中 TreePath 的使用

声明为 TreePath 的 javax.swing.tree 中的字段
protected TreePath | DefaultTreeCellEditor.lastPath 选择的最后路径。
protected TreePath | DefaultTreeSelectionModel.leadPath 添加的最后一条路径。
protected TreePath[] | DefaultTreeSelectionModel.selection 当前选择的路径。

返回 TreePath 的 javax.swing.tree 中的方法
TreePath | DefaultTreeSelectionModel.getLeadSelectionPath() 返回添加的最后一条路径。
TreePath | TreeSelectionModel.getLeadSelectionPath() 返回添加的最后一个路径。
TreePath | TreePath.getParentPath() 返回包含除最后一个路径组件之外的此对象所有元素的路径。
TreePath | FixedHeightLayoutCache.getPathClosestTo(int x, int y) 返回最接近 x,y 的节点的路径。
TreePath | VariableHeightLayoutCache.getPathClosestTo(int x, int y) 返回最接近 x,y 的节点的路径。
abstract TreePath | AbstractLayoutCache.getPathClosestTo(int x, int y) 返回最接近 x,y 节点的路径。
TreePath | FixedHeightLayoutCache.getPathForRow(int row) 返回传入行的路径。
TreePath | VariableHeightLayoutCache.getPathForRow(int row) 返回 row 的路径。
abstract TreePath | AbstractLayoutCache.getPathForRow(int row) 返回传入行的路径。
TreePath | DefaultTreeSelectionModel.getSelectionPath() 返回 selection 中的第一个路径。
TreePath | TreeSelectionModel.getSelectionPath() 返回选择中的第一个路径。
TreePath[] | DefaultTreeSelectionModel.getSelectionPaths() 返回 selection 中的路径。
TreePath[] | TreeSelectionModel.getSelectionPaths() 返回选择中的路径。
TreePath | TreePath.pathByAddingChild(Object child) 返回包含此对象的所有元素加上 child 的新路径。

返回变量类型为 TreePath 的类型的 javax.swing.tree 中的方法
Enumeration<TreePath> | FixedHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回表示从传入位置开始的可见路径的增量的 Enumerator。
Enumeration<TreePath> | VariableHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回从传入位置开始的可见路径的增量的 Enumerator。
abstract Enumeration<TreePath> | AbstractLayoutCache.getVisiblePathsFrom(TreePath path) 返回一个 Enumerator，它列举从传入位置开始的可视路径的增量。

参数类型为 TreePath 的 javax.swing.tree 中的方法
void | DefaultTreeSelectionModel.addSelectionPath(TreePath path) 将路径添加到当前的 selection 中。
void | TreeSelectionModel.addSelectionPath(TreePath path) 将路径添加到当前的选择中。
void | DefaultTreeSelectionModel.addSelectionPaths(TreePath[] paths) 向当前的 selection 中添加路径。
void | TreeSelectionModel.addSelectionPaths(TreePath[] paths) 向当前的选择中添加路径。
protected boolean | DefaultTreeSelectionModel.arePathsContiguous(TreePath[] paths) 如果路径是连续的，或者此对象没有 RowMapper，则返回 true。
protected boolean | DefaultTreeSelectionModel.canPathsBeAdded(TreePath[] paths) 用于测试是否可以添加特定的 TreePath 集合。
protected boolean | DefaultTreeSelectionModel.canPathsBeRemoved(TreePath[] paths) 如果可以移除该路径而不中断该模型的连续性，则返回 true。
Rectangle | FixedHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回给出绘制路径所需边界的矩形。
Rectangle | VariableHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回 Rectangle，它包围在其中绘制 path 标识的项的标签部分。
abstract Rectangle | AbstractLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回一个矩形，该矩形给出了绘制路径所需的 bounds。
boolean | FixedHeightLayoutCache.getExpandedState(TreePath path) 如果该路径已扩展，并且可见，则返回 true。
boolean | VariableHeightLayoutCache.getExpandedState(TreePath path) 如果路径已扩展，并且可见，则返回 true。
abstract boolean | AbstractLayoutCache.getExpandedState(TreePath path) 如果路径已扩展并且可视，则返回 true。
int | FixedHeightLayoutCache.getRowForPath(TreePath path) 返回路径中标识的最后一项可见的行。
int | VariableHeightLayoutCache.getRowForPath(TreePath path) 返回路径中标识的最后一项在其中可见的行。
abstract int | AbstractLayoutCache.getRowForPath(TreePath path) 返回其路径中标识的最后一项可视的行。
int[] | AbstractLayoutCache.getRowsForPaths(TreePath[] paths) 返回在其中显示 path 中 TreePath 实例的行。
int[] | RowMapper.getRowsForPaths(TreePath[] path) 返回显示 path 中的 TreePath 实例的行。
int | FixedHeightLayoutCache.getVisibleChildCount(TreePath path) 返回行的可见子对象数。
int | VariableHeightLayoutCache.getVisibleChildCount(TreePath path) 返回 path 的可见子路径数。
abstract int | AbstractLayoutCache.getVisibleChildCount(TreePath path) 返回行的可视子节点数。
Enumeration<TreePath> | FixedHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回表示从传入位置开始的可见路径的增量的 Enumerator。
Enumeration<TreePath> | VariableHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回从传入位置开始的可见路径的增量的 Enumerator。
abstract Enumeration<TreePath> | AbstractLayoutCache.getVisiblePathsFrom(TreePath path) 返回一个 Enumerator，它列举从传入位置开始的可视路径的增量。
void | FixedHeightLayoutCache.invalidatePathBounds(TreePath path) 不执行任何操作，FixedHeightLayoutCache 不缓存宽度（即所有可以更改的宽度）。
void | VariableHeightLayoutCache.invalidatePathBounds(TreePath path) 指示 LayoutCache path 的边界无效，需要更新。
abstract void | AbstractLayoutCache.invalidatePathBounds(TreePath path) 指示 LayoutCache，path 的边界无效，需要进行更新。
boolean | TreePath.isDescendant(TreePath aTreePath) 如果 aTreePath 为此 TreePath 的后代，则返回 true。
boolean | FixedHeightLayoutCache.isExpanded(TreePath path) 如果当前扩展了由行标识的值，则返回 true。
boolean | VariableHeightLayoutCache.isExpanded(TreePath path) 如果当前扩展了 path 标识的值，则返回 true。
abstract boolean | AbstractLayoutCache.isExpanded(TreePath path) 如果当前扩展了由行标识的值，则返回 true。
boolean | DefaultTreeSelectionModel.isPathSelected(TreePath path) 如果当前选择了路径 path，则返回 true。
boolean | TreeSelectionModel.isPathSelected(TreePath path) 如果路径 path 在当前的选择中，则返回 true。
protected void | DefaultTreeSelectionModel.notifyPathChange(Vector<javax.swing.tree.PathPlaceHolder> changedPaths, TreePath oldLeadSelection) 通知侦听器路径中的更改。
void | DefaultTreeSelectionModel.removeSelectionPath(TreePath path) 从 selection 中移除路径。
void | TreeSelectionModel.removeSelectionPath(TreePath path) 从选择中移除路径。
void | DefaultTreeSelectionModel.removeSelectionPaths(TreePath[] paths) 从 selection 中移除路径。
void | TreeSelectionModel.removeSelectionPaths(TreePath[] paths) 从选择中移除路径。
void | FixedHeightLayoutCache.setExpandedState(TreePath path, boolean isExpanded) 将路径 path 的扩展状态标记为 isExpanded。
void | VariableHeightLayoutCache.setExpandedState(TreePath path, boolean isExpanded) 将路径 path 的扩展状态标记为 isExpanded。
abstract void | AbstractLayoutCache.setExpandedState(TreePath path, boolean isExpanded) 将路径 path 的已扩展状态标记为 isExpanded。
void | DefaultTreeSelectionModel.setSelectionPath(TreePath path) 为该选择设置路径。
void | TreeSelectionModel.setSelectionPath(TreePath path) 为该选择设置路径。
void | DefaultTreeSelectionModel.setSelectionPaths(TreePath[] pPaths) 为该选择设置路径中的路径。
void | TreeSelectionModel.setSelectionPaths(TreePath[] paths) 为该选择设置路径。
void | DefaultTreeModel.valueForPathChanged(TreePath path, Object newValue) 此方法设置由路径标识的 TreeNode 的用户对象，并发送更改的节点。
void | TreeModel.valueForPathChanged(TreePath path, Object newValue) 用户已将 path 标识的项的值更改为 newValue 时，进行通知。

参数类型为 TreePath 的 javax.swing.tree 中的构造方法
TreePath(TreePath parent, Object lastElement)
构造一个新的 TreePath，它是以 lastElement 结束的 parent 标识的路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.tree.TreeSelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.TreeSelectionModel
的使用

使用 TreeSelectionModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeSelectionModel 的使用

实现 TreeSelectionModel 的 javax.swing 中的类
protected static class JTree.EmptySelectionModel
EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。

声明为 TreeSelectionModel 的 javax.swing 中的字段
protected  TreeSelectionModel JTree.selectionModel
对此树中选择的节点集建模。

返回 TreeSelectionModel 的 javax.swing 中的方法
 TreeSelectionModel JTree.getSelectionModel()
返回选择的模型。

参数类型为 TreeSelectionModel 的 javax.swing 中的方法
 void JTree.setSelectionModel(TreeSelectionModel selectionModel)
设置树的选择模型。

javax.swing.plaf.basic 中 TreeSelectionModel 的使用

声明为 TreeSelectionModel 的 javax.swing.plaf.basic 中的字段
protected  TreeSelectionModel BasicTreeUI.treeSelectionModel
维护选择的模型。

返回 TreeSelectionModel 的 javax.swing.plaf.basic 中的方法
protected  TreeSelectionModel BasicTreeUI.getSelectionModel()

参数类型为 TreeSelectionModel 的 javax.swing.plaf.basic 中的方法
protected  void BasicTreeUI.setSelectionModel(TreeSelectionModel newLSM)
重置选择模型。

javax.swing.tree 中 TreeSelectionModel 的使用

实现 TreeSelectionModel 的 javax.swing.tree 中的类
 class DefaultTreeSelectionModel
TreeSelectionModel 的默认实现。

声明为 TreeSelectionModel 的 javax.swing.tree 中的字段
protected  TreeSelectionModel AbstractLayoutCache.treeSelectionModel
选择模型。

返回 TreeSelectionModel 的 javax.swing.tree 中的方法
 TreeSelectionModel AbstractLayoutCache.getSelectionModel()
返回用于维护该选择的模型。

参数类型为 TreeSelectionModel 的 javax.swing.tree 中的方法
 void AbstractLayoutCache.setSelectionModel(TreeSelectionModel newLSM)
将用于管理选择的 TreeSelectionModel 设置为新的 LSM。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.tree.VariableHeightLayoutCache 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.VariableHeightLayoutCache
的使用

没有 javax.swing.tree.VariableHeightLayoutCache 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.swing.undo (Java 2 Platform SE 6)

 javax.swing.undo
接口
StateEditable
UndoableEdit
类
AbstractUndoableEdit
CompoundEdit
StateEdit
UndoableEditSupport
UndoManager
异常
CannotRedoException
CannotUndoException


类 javax.swing.undo.AbstractUndoableEdit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.AbstractUndoableEdit
的使用

使用 AbstractUndoableEdit 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.text 中 AbstractUndoableEdit 的使用

javax.swing.text 中 AbstractUndoableEdit 的子类
class | AbstractDocument.DefaultDocumentEvent 存储修改文档时发生的文档更改。
static class | AbstractDocument.ElementEdit 一个 ElementChange 实现，可将其添加到文档事件中。
static class | DefaultStyledDocument.AttributeUndoableEdit 用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。

javax.swing.undo 中 AbstractUndoableEdit 的使用

javax.swing.undo 中 AbstractUndoableEdit 的子类
class | CompoundEdit AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
class | StateEdit StateEdit 是更改状态的对象的通用编辑。
class | UndoManager UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.undo.CannotRedoException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.CannotRedoException
的使用

使用 CannotRedoException 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.text 中 CannotRedoException 的使用

抛出 CannotRedoException 的 javax.swing.text 中的方法
void | DefaultStyledDocument.AttributeUndoableEdit.redo() 重复更改。
void | AbstractDocument.DefaultDocumentEvent.redo() 重复执行更改。
void | AbstractDocument.ElementEdit.redo() 重复执行更改。

javax.swing.undo 中 CannotRedoException 的使用

抛出 CannotRedoException 的 javax.swing.undo 中的方法
void | UndoManager.redo() 恢复适当的编辑。
void | CompoundEdit.redo() 按添加时的顺序将 redo 发送到所有包含的 UndoableEdit 中。
void | AbstractUndoableEdit.redo() 如果 canRedo 返回 false，则抛出 CannotRedoException。
void | UndoableEdit.redo() 重新应用编辑。
protected void | UndoManager.redoTo(UndoableEdit edit) 恢复从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。
void | UndoManager.undoOrRedo() 一个便捷方法，它调用 undo 或 redo。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.undo.CannotUndoException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.CannotUndoException
的使用

使用 CannotUndoException 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.text 中 CannotUndoException 的使用

抛出 CannotUndoException 的 javax.swing.text 中的方法
void | DefaultStyledDocument.AttributeUndoableEdit.undo() 撤消更改。
void | AbstractDocument.DefaultDocumentEvent.undo() 撤消更改。
void | AbstractDocument.ElementEdit.undo() 撤消更改。

javax.swing.undo 中 CannotUndoException 的使用

抛出 CannotUndoException 的 javax.swing.undo 中的方法
void | UndoManager.undo() 撤消适当的编辑。
void | CompoundEdit.undo() 按与添加时相反的顺序将 undo 发送到所有包含的 UndoableEdits 中。
void | AbstractUndoableEdit.undo() 如果 canUndo 返回 false，则抛出 CannotUndoException。
void | UndoableEdit.undo() 撤消编辑。
void | UndoManager.undoOrRedo() 一个便捷方法，它调用 undo 或 redo。
protected void | UndoManager.undoTo(UndoableEdit edit) 撤消从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.undo.CompoundEdit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.CompoundEdit
的使用

使用 CompoundEdit 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.text 中 CompoundEdit 的使用

javax.swing.text 中 CompoundEdit 的子类
 class AbstractDocument.DefaultDocumentEvent
存储修改文档时发生的文档更改。

javax.swing.undo 中 CompoundEdit 的使用

javax.swing.undo 中 CompoundEdit 的子类
 class UndoManager
UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

声明为 CompoundEdit 的 javax.swing.undo 中的字段
protected  CompoundEdit UndoableEditSupport.compoundEdit

返回 CompoundEdit 的 javax.swing.undo 中的方法
protected  CompoundEdit UndoableEditSupport.createCompoundEdit()
仅从 beginUpdate 调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.undo.StateEdit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.StateEdit
的使用

没有 javax.swing.undo.StateEdit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.undo.StateEditable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.undo.StateEditable
的使用

使用 StateEditable 的软件包
javax.swing.undo 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.undo 中 StateEditable 的使用

声明为 StateEditable 的 javax.swing.undo 中的字段
protected  StateEditable StateEdit.object
被编辑的对象

参数类型为 StateEditable 的 javax.swing.undo 中的方法
protected  void StateEdit.init(StateEditable anObject, String name)

参数类型为 StateEditable 的 javax.swing.undo 中的构造方法
StateEdit(StateEditable anObject)
创建并返回新的 StateEdit。
StateEdit(StateEditable anObject, String name)
创建并返回具有表示名称的新 StateEdit。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.swing.undo.UndoableEdit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.undo.UndoableEdit
的使用

使用 UndoableEdit 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.event 中 UndoableEdit 的使用

返回 UndoableEdit 的 javax.swing.event 中的方法
 UndoableEdit UndoableEditEvent.getEdit()
返回 edit 值。

参数类型为 UndoableEdit 的 javax.swing.event 中的构造方法
UndoableEditEvent(Object source, UndoableEdit edit)
构造一个 UndoableEditEvent 对象。

javax.swing.text 中 UndoableEdit 的使用

实现 UndoableEdit 的 javax.swing.text 中的类
class | AbstractDocument.DefaultDocumentEvent 存储修改文档时发生的文档更改。
static class | AbstractDocument.ElementEdit 一个 ElementChange 实现，可将其添加到文档事件中。
static class | DefaultStyledDocument.AttributeUndoableEdit 用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。

返回 UndoableEdit 的 javax.swing.text 中的方法
 UndoableEdit StringContent.insertString(int where, String str)
将字符串插入到内容中。
 UndoableEdit GapContent.insertString(int where, String str)
在内容中插入字符串。
 UndoableEdit AbstractDocument.Content.insertString(int where, String str)
向序列中插入一个字符串。
 UndoableEdit StringContent.remove(int where, int nitems)
移除部分内容，其中 where ＋ nitems 必须 < length()。
 UndoableEdit GapContent.remove(int where, int nitems)
移除部分内容。
 UndoableEdit AbstractDocument.Content.remove(int where, int nitems)
移除该序列的某一部分。

参数类型为 UndoableEdit 的 javax.swing.text 中的方法
 boolean AbstractDocument.DefaultDocumentEvent.addEdit(UndoableEdit anEdit)
添加文档编辑。

javax.swing.undo 中 UndoableEdit 的使用

实现 UndoableEdit 的 javax.swing.undo 中的类
class | AbstractUndoableEdit UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。
class | CompoundEdit AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
class | StateEdit StateEdit 是更改状态的对象的通用编辑。
class | UndoManager UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

类型参数类型为 UndoableEdit 的 javax.swing.undo 中的字段
protected  Vector<UndoableEdit> CompoundEdit.edits
由此 CompoundEdit 全部撤消/恢复的 UndoableEdit 的集合。

返回 UndoableEdit 的 javax.swing.undo 中的方法
protected UndoableEdit | UndoManager.editToBeRedone() 如果调用 redo，则返回下一个要恢复的有效编辑。
protected UndoableEdit | UndoManager.editToBeUndone() 如果调用 undo，则返回下一个要撤消的有效编辑。
protected UndoableEdit | CompoundEdit.lastEdit() 返回 edits 中最后一个 UndoableEdit，如果 edits 为空，则返回 null。

参数类型为 UndoableEdit 的 javax.swing.undo 中的方法
protected void | UndoableEditSupport._postEdit(UndoableEdit e) 仅从 postEdit 和 endUpdate 调用。
boolean | UndoManager.addEdit(UndoableEdit anEdit) 如果可能，将一个 UndoableEdit 添加到此 UndoManager。
boolean | CompoundEdit.addEdit(UndoableEdit anEdit) 如果此编辑为 inProgress，则接受 anEdit 并返回 true。
boolean | AbstractUndoableEdit.addEdit(UndoableEdit anEdit) 此默认实现返回 false。
boolean | UndoableEdit.addEdit(UndoableEdit anEdit) 将 UndoableEdit 添加到此 UndoableEdit。
void | UndoableEditSupport.postEdit(UndoableEdit e) 死锁警告：调用此方法可能调用所有侦听器中的 undoableEditHappened。
protected void | UndoManager.redoTo(UndoableEdit edit) 恢复从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。
boolean | AbstractUndoableEdit.replaceEdit(UndoableEdit anEdit) 此默认实现返回 false。
boolean | UndoableEdit.replaceEdit(UndoableEdit anEdit) 如果此 UndoableEdit 应替换 anEdit，则返回 true。
protected void | UndoManager.undoTo(UndoableEdit edit) 撤消从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.undo.UndoableEditSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.UndoableEditSupport
的使用

没有 javax.swing.undo.UndoableEditSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.swing.undo.UndoManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.UndoManager
的使用

没有 javax.swing.undo.UndoManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.tools (Java 2 Platform SE 6)

 javax.tools
接口
Diagnostic
DiagnosticListener
FileObject
JavaCompiler
JavaCompiler.CompilationTask
JavaFileManager
JavaFileManager.Location
JavaFileObject
OptionChecker
StandardJavaFileManager
Tool
类
DiagnosticCollector
ForwardingFileObject
ForwardingJavaFileManager
ForwardingJavaFileObject
SimpleJavaFileObject
ToolProvider
枚举
Diagnostic.Kind
JavaFileObject.Kind
StandardLocation


接口 javax.tools.Diagnostic 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.Diagnostic
的使用

使用 Diagnostic 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 Diagnostic 的使用

返回变量类型为 Diagnostic 的类型的 javax.tools 中的方法
 List<Diagnostic<? extends S>> DiagnosticCollector.getDiagnostics()
获取此对象收集的诊断所组成的列表视图。

参数类型为 Diagnostic 的 javax.tools 中的方法
void | DiagnosticCollector.report(Diagnostic<? extends S> diagnostic)
void | DiagnosticListener.report(Diagnostic<? extends S> diagnostic) 发现问题时调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.tools.Diagnostic.Kind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.Diagnostic.Kind
的使用

使用 Diagnostic.Kind 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 Diagnostic.Kind 的使用

参数类型为 Diagnostic.Kind 的 javax.annotation.processing 中的方法
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg) 打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e) 在元素的位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a) 在已注释元素的注释镜像位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v) 在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

javax.tools 中 Diagnostic.Kind 的使用

返回 Diagnostic.Kind 的 javax.tools 中的方法
Diagnostic.Kind | Diagnostic.getKind() 获取此诊断的类型，例如，错误或者警告。
static Diagnostic.Kind | Diagnostic.Kind.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Diagnostic.Kind[] | Diagnostic.Kind.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.tools.DiagnosticCollector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.DiagnosticCollector
的使用

没有 javax.tools.DiagnosticCollector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.tools.DiagnosticListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.DiagnosticListener
的使用

使用 DiagnosticListener 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 DiagnosticListener 的使用

实现 DiagnosticListener 的 javax.tools 中的类
 class DiagnosticCollector<S>
提供将诊断收集到一个列表中的简单方法。

参数类型为 DiagnosticListener 的 javax.tools 中的方法
StandardJavaFileManager | JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset) 为此工具获取一个标准文件管理器实现的新实例。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.tools.FileObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.FileObject
的使用

使用 FileObject 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 FileObject 的使用

返回 FileObject 的 javax.annotation.processing 中的方法
FileObject | Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
FileObject | Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName) 返回一个用于读取现有资源的对象。

javax.tools 中 FileObject 的使用

类型参数类型为 FileObject 的 javax.tools 中的类
 class ForwardingFileObject<F extends FileObject>
将调用转发到给定的文件对象。

javax.tools 中 FileObject 的子接口
 interface JavaFileObject
在 Java™ 编程语言源和类文件上进行操作的工具的文件抽象。

实现 FileObject 的 javax.tools 中的类
class | ForwardingFileObject<F extends FileObject> 将调用转发到给定的文件对象。
class | ForwardingJavaFileObject<F extends JavaFileObject> 将调用转发到给定的文件对象。
class | SimpleJavaFileObject 为 JavaFileObject 中的大多数方法提供简单实现。

声明为 FileObject 的 javax.tools 中的字段
protected  F ForwardingFileObject.fileObject
一个文件对象，所有方法都将委托给它。

返回 FileObject 的 javax.tools 中的方法
FileObject | ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
FileObject | JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName) 获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。
FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
FileObject | JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。

参数类型为 FileObject 的 javax.tools 中的方法
FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
FileObject | JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。
JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
JavaFileObject | JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定类型的指定类。
boolean | ForwardingJavaFileManager.isSameFile(FileObject a, FileObject b)
boolean | JavaFileManager.isSameFile(FileObject a, FileObject b) 比较两个文件对象，如果它们表示相同的底层对象，则返回 true。
boolean | StandardJavaFileManager.isSameFile(FileObject a, FileObject b) 比较两个文件对象，如果它们表示相同的规范文件、zip 文件条目或者基于任何文件系统的容器中的条目，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.tools.ForwardingFileObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.ForwardingFileObject
的使用

使用 ForwardingFileObject 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 ForwardingFileObject 的使用

javax.tools 中 ForwardingFileObject 的子类
 class ForwardingJavaFileObject<F extends JavaFileObject>
将调用转发到给定的文件对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.tools.ForwardingJavaFileManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.ForwardingJavaFileManager
的使用

没有 javax.tools.ForwardingJavaFileManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.tools.ForwardingJavaFileObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.ForwardingJavaFileObject
的使用

没有 javax.tools.ForwardingJavaFileObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.tools.JavaCompiler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.JavaCompiler
的使用

使用 JavaCompiler 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 JavaCompiler 的使用

返回 JavaCompiler 的 javax.tools 中的方法
static JavaCompiler ToolProvider.getSystemJavaCompiler()
获取此平台提供的 Java™ 编程语言编译器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.tools.JavaCompiler.CompilationTask 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.JavaCompiler.CompilationTask
的使用

使用 JavaCompiler.CompilationTask 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 JavaCompiler.CompilationTask 的使用

返回 JavaCompiler.CompilationTask 的 javax.tools 中的方法
 JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.tools.JavaFileManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.JavaFileManager
的使用

使用 JavaFileManager 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 JavaFileManager 的使用

类型参数类型为 JavaFileManager 的 javax.tools 中的类
 class ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

javax.tools 中 JavaFileManager 的子接口
 interface StandardJavaFileManager
基于 java.io.File 的文件管理器。

实现 JavaFileManager 的 javax.tools 中的类
 class ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

声明为 JavaFileManager 的 javax.tools 中的字段
protected  M ForwardingJavaFileManager.fileManager
一个文件管理器，所有方法都将委托给它。

参数类型为 JavaFileManager 的 javax.tools 中的方法
 JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.tools.JavaFileManager.Location 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.JavaFileManager.Location
的使用

使用 JavaFileManager.Location 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 JavaFileManager.Location 的使用

参数类型为 JavaFileManager.Location 的 javax.annotation.processing 中的方法
FileObject | Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
FileObject | Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName) 返回一个用于读取现有资源的对象。

javax.tools 中 JavaFileManager.Location 的使用

实现 JavaFileManager.Location 的 javax.tools 中的类
 class StandardLocation
文件对象的标准位置。

返回 JavaFileManager.Location 的 javax.tools 中的方法
static JavaFileManager.Location StandardLocation.locationFor(String name)
使用给定名称获取位置对象。

参数类型为 JavaFileManager.Location 的 javax.tools 中的方法
ClassLoader | ForwardingJavaFileManager.getClassLoader(JavaFileManager.Location location)
ClassLoader | JavaFileManager.getClassLoader(JavaFileManager.Location location) 获取可从给定位置加载插件的类加载器。
FileObject | ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
FileObject | JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName) 获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。
FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
FileObject | JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。
JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
JavaFileObject | JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind) 获取输入的文件对象，它表示给定位置处指定类型的指定类。
JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
JavaFileObject | JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定类型的指定类。
Iterable<? extends File> | StandardJavaFileManager.getLocation(JavaFileManager.Location location) 获取与给定位置关联的路径。
boolean | ForwardingJavaFileManager.hasLocation(JavaFileManager.Location location)
boolean | JavaFileManager.hasLocation(JavaFileManager.Location location) 确定此文件管理器是否已知某位置。
String | ForwardingJavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
String | JavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file) 根据位置推断文件对象的二进制名称。
Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
Iterable<JavaFileObject> | JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。
void | StandardJavaFileManager.setLocation(JavaFileManager.Location location, Iterable<? extends File> path) 将给定路径与给定位置关联。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.tools.JavaFileObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.JavaFileObject
的使用

使用 JavaFileObject 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 JavaFileObject 的使用

返回 JavaFileObject 的 javax.annotation.processing 中的方法
JavaFileObject | Filer.createClassFile(CharSequence name, Element... originatingElements) 创建一个新的类文件，并返回一个对象以允许写入它。
JavaFileObject | Filer.createSourceFile(CharSequence name, Element... originatingElements) 创建一个新的源文件，并返回一个对象以允许写入它。

javax.tools 中 JavaFileObject 的使用

类型参数类型为 JavaFileObject 的 javax.tools 中的类
 class ForwardingJavaFileObject<F extends JavaFileObject>
将调用转发到给定的文件对象。

实现 JavaFileObject 的 javax.tools 中的类
class | ForwardingJavaFileObject<F extends JavaFileObject> 将调用转发到给定的文件对象。
class | SimpleJavaFileObject 为 JavaFileObject 中的大多数方法提供简单实现。

返回 JavaFileObject 的 javax.tools 中的方法
JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
JavaFileObject | JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind) 获取输入的文件对象，它表示给定位置处指定类型的指定类。
JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
JavaFileObject | JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定类型的指定类。

返回变量类型为 JavaFileObject 的类型的 javax.tools 中的方法
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjects(File... files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjects(String... names) 获取表示给定文件名称的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File> files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String> names) 获取表示给定文件名称的文件对象。
Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
Iterable<JavaFileObject> | JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。

参数类型为 JavaFileObject 的 javax.tools 中的方法
String | ForwardingJavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
String | JavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file) 根据位置推断文件对象的二进制名称。

类型变量类型为 JavaFileObject 的 javax.tools 中的方法参数
StandardJavaFileManager | JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset) 为此工具获取一个标准文件管理器实现的新实例。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.tools.JavaFileObject.Kind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.JavaFileObject.Kind
的使用

使用 JavaFileObject.Kind 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 JavaFileObject.Kind 的使用

声明为 JavaFileObject.Kind 的 javax.tools 中的字段
protected  JavaFileObject.Kind SimpleJavaFileObject.kind
此文件对象的种类。

返回 JavaFileObject.Kind 的 javax.tools 中的方法
JavaFileObject.Kind | ForwardingJavaFileObject.getKind()
JavaFileObject.Kind | JavaFileObject.getKind() 获取此文件对象的种类。
JavaFileObject.Kind | SimpleJavaFileObject.getKind()
static JavaFileObject.Kind | JavaFileObject.Kind.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static JavaFileObject.Kind[] | JavaFileObject.Kind.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 JavaFileObject.Kind 的 javax.tools 中的方法
JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
JavaFileObject | JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind) 获取输入的文件对象，它表示给定位置处指定类型的指定类。
JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
JavaFileObject | JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定类型的指定类。
boolean | ForwardingJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
boolean | JavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind) 检查此文件对象是否与指定的简单名称和种类兼容。
boolean | SimpleJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind) 此实现对其 URI 路径和给定简单名称进行比较。

类型变量类型为 JavaFileObject.Kind 的 javax.tools 中的方法参数
Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
Iterable<JavaFileObject> | JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。

参数类型为 JavaFileObject.Kind 的 javax.tools 中的构造方法
SimpleJavaFileObject(URI uri, JavaFileObject.Kind kind)
使用给定 URI 构建给定种类的 SimpleJavaFileObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.tools.OptionChecker 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.OptionChecker
的使用

使用 OptionChecker 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 OptionChecker 的使用

javax.tools 中 OptionChecker 的子接口
interface | JavaCompiler 从程序中调用 Java™ 编程语言编译器的接口。
interface | JavaFileManager 在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。
interface | StandardJavaFileManager 基于 java.io.File 的文件管理器。

实现 OptionChecker 的 javax.tools 中的类
 class ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.tools.SimpleJavaFileObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.SimpleJavaFileObject
的使用

没有 javax.tools.SimpleJavaFileObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.tools.StandardJavaFileManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.StandardJavaFileManager
的使用

使用 StandardJavaFileManager 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 StandardJavaFileManager 的使用

返回 StandardJavaFileManager 的 javax.tools 中的方法
 StandardJavaFileManager JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
为此工具获取一个标准文件管理器实现的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.tools.StandardLocation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.StandardLocation
的使用

使用 StandardLocation 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 StandardLocation 的使用

返回 StandardLocation 的 javax.tools 中的方法
static StandardLocation | StandardLocation.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static StandardLocation[] | StandardLocation.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.tools.Tool 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.Tool
的使用

使用 Tool 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 Tool 的使用

javax.tools 中 Tool 的子接口
 interface JavaCompiler
从程序中调用 Java™ 编程语言编译器的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.tools.ToolProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.ToolProvider
的使用

没有 javax.tools.ToolProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.transaction (Java 2 Platform SE 6)

 javax.transaction
异常
InvalidTransactionException
TransactionRequiredException
TransactionRolledbackException


类 javax.transaction.InvalidTransactionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.transaction.InvalidTransactionException
的使用

没有 javax.transaction.InvalidTransactionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.transaction.TransactionRequiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.transaction.TransactionRequiredException
的使用

没有 javax.transaction.TransactionRequiredException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.transaction.TransactionRolledbackException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.transaction.TransactionRolledbackException
的使用

没有 javax.transaction.TransactionRolledbackException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.transaction.xa (Java 2 Platform SE 6)

 javax.transaction.xa
接口
XAResource
Xid
异常
XAException


类 javax.transaction.xa.XAException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.transaction.xa.XAException
的使用

使用 XAException 的软件包
javax.transaction.xa 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.transaction.xa 中 XAException 的使用

抛出 XAException 的 javax.transaction.xa 中的方法
void | XAResource.commit(Xid xid, boolean onePhase) 提交 xid 指定的全局事务。
void | XAResource.end(Xid xid, int flags) 终止代表事务分支所执行的工作。
void | XAResource.forget(Xid xid) 告知资源管理器忽略以启发式完成的事务分支。
int | XAResource.getTransactionTimeout() 获取为此 XAResource 实例设置的当前事务超时值。
boolean | XAResource.isSameRM(XAResource xares) 调用此方法，以确定目标对象表示的资源管理器实例是否与参数 xares 表示的资源管理器实例相同。
int | XAResource.prepare(Xid xid) 请求资源管理器准备好 xid 中指定的事务的事务提交工作。
Xid[] | XAResource.recover(int flag) 从资源管理器获取准备的事务分支的列表。
void | XAResource.rollback(Xid xid) 通知资源管理器回滚代表事务分支执行的工作。
boolean | XAResource.setTransactionTimeout(int seconds) 为此 XAResource 实例设置当前事务超时值。
void | XAResource.start(Xid xid, int flags) 代表 xid 中指定的事务分支开始工作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.transaction.xa.XAResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.transaction.xa.XAResource
的使用

使用 XAResource 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.sql 中 XAResource 的使用

返回 XAResource 的 javax.sql 中的方法
 XAResource XAConnection.getXAResource()
获取 XAResource 对象，事务管理器将使用该对象管理此 XAConnection 对象如何参与到分布式事务中。

javax.transaction.xa 中 XAResource 的使用

参数类型为 XAResource 的 javax.transaction.xa 中的方法
 boolean XAResource.isSameRM(XAResource xares)
调用此方法，以确定目标对象表示的资源管理器实例是否与参数 xares 表示的资源管理器实例相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.transaction.xa.Xid 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.transaction.xa.Xid
的使用

使用 Xid 的软件包
javax.transaction.xa 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.transaction.xa 中 Xid 的使用

返回 Xid 的 javax.transaction.xa 中的方法
 Xid[] XAResource.recover(int flag)
从资源管理器获取准备的事务分支的列表。

参数类型为 Xid 的 javax.transaction.xa 中的方法
void | XAResource.commit(Xid xid, boolean onePhase) 提交 xid 指定的全局事务。
void | XAResource.end(Xid xid, int flags) 终止代表事务分支所执行的工作。
void | XAResource.forget(Xid xid) 告知资源管理器忽略以启发式完成的事务分支。
int | XAResource.prepare(Xid xid) 请求资源管理器准备好 xid 中指定的事务的事务提交工作。
void | XAResource.rollback(Xid xid) 通知资源管理器回滚代表事务分支执行的工作。
void | XAResource.start(Xid xid, int flags) 代表 xid 中指定的事务分支开始工作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml (Java 2 Platform SE 6)

 javax.xml
类
XMLConstants


javax.xml.bind (Java 2 Platform SE 6)

 javax.xml.bind
接口
DatatypeConverterInterface
Element
Marshaller
NotIdentifiableEvent
ParseConversionEvent
PrintConversionEvent
Unmarshaller
UnmarshallerHandler
ValidationEvent
ValidationEventHandler
ValidationEventLocator
Validator
类
Binder
DatatypeConverter
JAXBContext
JAXBElement
JAXBElement.GlobalScope
JAXBIntrospector
Marshaller.Listener
SchemaOutputResolver
Unmarshaller.Listener
异常
JAXBException
MarshalException
PropertyException
TypeConstraintException
UnmarshalException
ValidationException


javax.xml.bind.annotation (Java 2 Platform SE 6)

 javax.xml.bind.annotation
接口
DomHandler
类
W3CDomHandler
XmlElement.DEFAULT
XmlElementDecl.GLOBAL
XmlElementRef.DEFAULT
XmlSchemaType.DEFAULT
XmlType.DEFAULT
枚举
XmlAccessOrder
XmlAccessType
XmlNsForm
注释类型
XmlAccessorOrder
XmlAccessorType
XmlAnyAttribute
XmlAnyElement
XmlAttachmentRef
XmlAttribute
XmlElement
XmlElementDecl
XmlElementRef
XmlElementRefs
XmlElements
XmlElementWrapper
XmlEnum
XmlEnumValue
XmlID
XmlIDREF
XmlInlineBinaryData
XmlList
XmlMimeType
XmlMixed
XmlNs
XmlRegistry
XmlRootElement
XmlSchema
XmlSchemaType
XmlSchemaTypes
XmlTransient
XmlType
XmlValue


XmlElement.DEFAULT (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 XmlElement.DEFAULT

java.lang.Object
    继承者  javax.xml.bind.annotation.XmlElement.DEFAULT
正在封闭类：
XmlElement
public static final class XmlElement.DEFAULT
extends Object

在 XmlElement.type() 中使用，用于表示根据属性签名推断出来的类型。

构造方法摘要
XmlElement.DEFAULT()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlElement.DEFAULT

public XmlElement.DEFAULT()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlElementDecl.GLOBAL (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 XmlElementDecl.GLOBAL

java.lang.Object
    继承者  javax.xml.bind.annotation.XmlElementDecl.GLOBAL
正在封闭类：
XmlElementDecl
public static final class XmlElementDecl.GLOBAL
extends Object

在 XmlElementDecl.scope() 中使用，指示声明是全局范围的。

构造方法摘要
XmlElementDecl.GLOBAL()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlElementDecl.GLOBAL

public XmlElementDecl.GLOBAL()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlElementRef.DEFAULT (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 XmlElementRef.DEFAULT

java.lang.Object
    继承者  javax.xml.bind.annotation.XmlElementRef.DEFAULT
正在封闭类：
XmlElementRef
public static final class XmlElementRef.DEFAULT
extends Object

在 XmlElementRef.type() 中使用，用于表示根据属性签名推断出来的类型。

构造方法摘要
XmlElementRef.DEFAULT()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlElementRef.DEFAULT

public XmlElementRef.DEFAULT()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlSchemaType.DEFAULT (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 XmlSchemaType.DEFAULT

java.lang.Object
    继承者  javax.xml.bind.annotation.XmlSchemaType.DEFAULT
正在封闭类：
XmlSchemaType
public static final class XmlSchemaType.DEFAULT
extends Object

在 XmlSchemaType.type() 中使用，用于表示根据属性签名推断出来的类型。

构造方法摘要
XmlSchemaType.DEFAULT()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlSchemaType.DEFAULT

public XmlSchemaType.DEFAULT()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlType.DEFAULT (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 XmlType.DEFAULT

java.lang.Object
    继承者  javax.xml.bind.annotation.XmlType.DEFAULT
正在封闭类：
XmlType
public static final class XmlType.DEFAULT
extends Object

在 XmlType.factoryClass() 中使用，指示工厂方法未被使用或者在具有此 XmlType 的类中。

构造方法摘要
XmlType.DEFAULT()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlType.DEFAULT

public XmlType.DEFAULT()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


javax.xml.bind.annotation.adapters (Java 2 Platform SE 6)

 javax.xml.bind.annotation.adapters
类
CollapsedStringAdapter
HexBinaryAdapter
NormalizedStringAdapter
XmlAdapter
XmlJavaTypeAdapter.DEFAULT
注释类型
XmlJavaTypeAdapter
XmlJavaTypeAdapters


XmlJavaTypeAdapter.DEFAULT (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation.adapters
类 XmlJavaTypeAdapter.DEFAULT

java.lang.Object
    继承者  javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
正在封闭类：
XmlJavaTypeAdapter
public static final class XmlJavaTypeAdapter.DEFAULT
extends Object

此类在 XmlJavaTypeAdapter.type() 中使用，用来表示从字段、属性、参数或类的签名推导出的类型。

构造方法摘要
XmlJavaTypeAdapter.DEFAULT()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlJavaTypeAdapter.DEFAULT

public XmlJavaTypeAdapter.DEFAULT()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter
的使用

没有 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.HexBinaryAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.HexBinaryAdapter
的使用

没有 javax.xml.bind.annotation.adapters.HexBinaryAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter
的使用

没有 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.XmlAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.XmlAdapter
的使用

使用 XmlAdapter 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 XmlAdapter 的使用

类型参数类型为 XmlAdapter 的 javax.xml.bind 中的方法
<A extends XmlAdapter>
A
Marshaller.getAdapter(Class<A> type)
获取与指定类型关联的适配器。
<A extends XmlAdapter>
A
Unmarshaller.getAdapter(Class<A> type)
获取与指定类型关联的适配器。
<A extends XmlAdapter>
void
Marshaller.setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 marshaller 关联。
<A extends XmlAdapter>
void
Unmarshaller.setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。

参数类型为 XmlAdapter 的 javax.xml.bind 中的方法
void | Marshaller.setAdapter(XmlAdapter adapter) 将已配置的 XmlAdapter 实例与此 marshaller 关联。
void | Unmarshaller.setAdapter(XmlAdapter adapter) 将已配置的 XmlAdapter 实例与此 unmarshaller 关联。

javax.xml.bind.annotation.adapters 中 XmlAdapter 的使用

javax.xml.bind.annotation.adapters 中 XmlAdapter 的子类
class | CollapsedStringAdapter 用来处理 xs:token 及其派生类型的内置 XmlAdapter。
class | HexBinaryAdapter xs:hexBinary 的 XmlAdapter。
class | NormalizedStringAdapter 处理 xs:normalizedString 的 XmlAdapter。

javax.xml.bind.helpers 中 XmlAdapter 的使用

类型参数类型为 XmlAdapter 的 javax.xml.bind.helpers 中的方法
<A extends XmlAdapter>
A
AbstractMarshallerImpl.getAdapter(Class<A> type)
<A extends XmlAdapter>
A
AbstractUnmarshallerImpl.getAdapter(Class<A> type)
<A extends XmlAdapter>
void
AbstractMarshallerImpl.setAdapter(Class<A> type, A adapter)
<A extends XmlAdapter>
void
AbstractUnmarshallerImpl.setAdapter(Class<A> type, A adapter)

参数类型为 XmlAdapter 的 javax.xml.bind.helpers 中的方法
void | AbstractMarshallerImpl.setAdapter(XmlAdapter adapter)
void | AbstractUnmarshallerImpl.setAdapter(XmlAdapter adapter)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter
的使用

没有 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
的使用

没有 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters
的使用

没有 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.annotation.DomHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.annotation.DomHandler
的使用

使用 DomHandler 的软件包
javax.xml.bind.annotation 定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation 中 DomHandler 的使用

实现 DomHandler 的 javax.xml.bind.annotation 中的类
 class W3CDomHandler
W3C DOM（org.w3c.dom 包）的 DomHandler 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.W3CDomHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.W3CDomHandler
的使用

没有 javax.xml.bind.annotation.W3CDomHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAccessOrder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAccessOrder
的使用

使用 XmlAccessOrder 的软件包
javax.xml.bind.annotation 定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation 中 XmlAccessOrder 的使用

返回 XmlAccessOrder 的 javax.xml.bind.annotation 中的方法
static XmlAccessOrder | XmlAccessOrder.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static XmlAccessOrder[] | XmlAccessOrder.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAccessorOrder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAccessorOrder
的使用

没有 javax.xml.bind.annotation.XmlAccessorOrder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAccessorType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAccessorType
的使用

没有 javax.xml.bind.annotation.XmlAccessorType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAccessType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAccessType
的使用

使用 XmlAccessType 的软件包
javax.xml.bind.annotation 定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation 中 XmlAccessType 的使用

返回 XmlAccessType 的 javax.xml.bind.annotation 中的方法
static XmlAccessType | XmlAccessType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static XmlAccessType[] | XmlAccessType.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAnyAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAnyAttribute
的使用

没有 javax.xml.bind.annotation.XmlAnyAttribute 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAnyElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAnyElement
的使用

没有 javax.xml.bind.annotation.XmlAnyElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAttachmentRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAttachmentRef
的使用

没有 javax.xml.bind.annotation.XmlAttachmentRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAttribute
的使用

没有 javax.xml.bind.annotation.XmlAttribute 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElement
的使用

没有 javax.xml.bind.annotation.XmlElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElement.DEFAULT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElement.DEFAULT
的使用

没有 javax.xml.bind.annotation.XmlElement.DEFAULT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementDecl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementDecl
的使用

没有 javax.xml.bind.annotation.XmlElementDecl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementDecl.GLOBAL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementDecl.GLOBAL
的使用

没有 javax.xml.bind.annotation.XmlElementDecl.GLOBAL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementRef
的使用

没有 javax.xml.bind.annotation.XmlElementRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementRef.DEFAULT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementRef.DEFAULT
的使用

没有 javax.xml.bind.annotation.XmlElementRef.DEFAULT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementRefs 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementRefs
的使用

没有 javax.xml.bind.annotation.XmlElementRefs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElements 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElements
的使用

没有 javax.xml.bind.annotation.XmlElements 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementWrapper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementWrapper
的使用

没有 javax.xml.bind.annotation.XmlElementWrapper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlEnum 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlEnum
的使用

没有 javax.xml.bind.annotation.XmlEnum 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlEnumValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlEnumValue
的使用

没有 javax.xml.bind.annotation.XmlEnumValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlID
的使用

没有 javax.xml.bind.annotation.XmlID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlIDREF 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlIDREF
的使用

没有 javax.xml.bind.annotation.XmlIDREF 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlInlineBinaryData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlInlineBinaryData
的使用

没有 javax.xml.bind.annotation.XmlInlineBinaryData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlList
的使用

没有 javax.xml.bind.annotation.XmlList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlMimeType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlMimeType
的使用

没有 javax.xml.bind.annotation.XmlMimeType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlMixed 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlMixed
的使用

没有 javax.xml.bind.annotation.XmlMixed 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlNs 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlNs
的使用

没有 javax.xml.bind.annotation.XmlNs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlNsForm 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlNsForm
的使用

使用 XmlNsForm 的软件包
javax.xml.bind.annotation 定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation 中 XmlNsForm 的使用

返回 XmlNsForm 的 javax.xml.bind.annotation 中的方法
static XmlNsForm | XmlNsForm.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static XmlNsForm[] | XmlNsForm.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlRegistry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlRegistry
的使用

没有 javax.xml.bind.annotation.XmlRegistry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlRootElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlRootElement
的使用

没有 javax.xml.bind.annotation.XmlRootElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlSchema 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlSchema
的使用

没有 javax.xml.bind.annotation.XmlSchema 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlSchemaType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlSchemaType
的使用

没有 javax.xml.bind.annotation.XmlSchemaType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlSchemaType.DEFAULT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlSchemaType.DEFAULT
的使用

没有 javax.xml.bind.annotation.XmlSchemaType.DEFAULT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlSchemaTypes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlSchemaTypes
的使用

没有 javax.xml.bind.annotation.XmlSchemaTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlTransient 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlTransient
的使用

没有 javax.xml.bind.annotation.XmlTransient 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlType
的使用

没有 javax.xml.bind.annotation.XmlType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlType.DEFAULT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlType.DEFAULT
的使用

没有 javax.xml.bind.annotation.XmlType.DEFAULT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlValue
的使用

没有 javax.xml.bind.annotation.XmlValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.bind.attachment (Java 2 Platform SE 6)

 javax.xml.bind.attachment
类
AttachmentMarshaller
AttachmentUnmarshaller


类 javax.xml.bind.attachment.AttachmentMarshaller 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.attachment.AttachmentMarshaller
的使用

使用 AttachmentMarshaller 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 AttachmentMarshaller 的使用

返回 AttachmentMarshaller 的 javax.xml.bind 中的方法
 AttachmentMarshaller Marshaller.getAttachmentMarshaller()

参数类型为 AttachmentMarshaller 的 javax.xml.bind 中的方法
 void Marshaller.setAttachmentMarshaller(AttachmentMarshaller am)
与上下文关联，使 XML 文档内的二进制数据能够以优化的 XML 二进制附件的形式传送。

javax.xml.bind.helpers 中 AttachmentMarshaller 的使用

返回 AttachmentMarshaller 的 javax.xml.bind.helpers 中的方法
 AttachmentMarshaller AbstractMarshallerImpl.getAttachmentMarshaller()

参数类型为 AttachmentMarshaller 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.setAttachmentMarshaller(AttachmentMarshaller am)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.attachment.AttachmentUnmarshaller 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.attachment.AttachmentUnmarshaller
的使用

使用 AttachmentUnmarshaller 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 AttachmentUnmarshaller 的使用

返回 AttachmentUnmarshaller 的 javax.xml.bind 中的方法
 AttachmentUnmarshaller Unmarshaller.getAttachmentUnmarshaller()

参数类型为 AttachmentUnmarshaller 的 javax.xml.bind 中的方法
 void Unmarshaller.setAttachmentUnmarshaller(AttachmentUnmarshaller au)
将解析 cid（内容 id URI）的上下文与作为附件传递的二进制数据关联。

javax.xml.bind.helpers 中 AttachmentUnmarshaller 的使用

返回 AttachmentUnmarshaller 的 javax.xml.bind.helpers 中的方法
 AttachmentUnmarshaller AbstractUnmarshallerImpl.getAttachmentUnmarshaller()

参数类型为 AttachmentUnmarshaller 的 javax.xml.bind.helpers 中的方法
 void AbstractUnmarshallerImpl.setAttachmentUnmarshaller(AttachmentUnmarshaller au)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.Binder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.Binder
的使用

使用 Binder 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 Binder 的使用

返回 Binder 的 javax.xml.bind 中的方法
 Binder<Node> JAXBContext.createBinder()
为 W3C DOM 创建一个 Binder。
<T> Binder<T>
JAXBContext.createBinder(Class<T> domType)
创建一个可用于关联/原地解组/编组操作的 Binder 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.DatatypeConverter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.DatatypeConverter
的使用

没有 javax.xml.bind.DatatypeConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.DatatypeConverterInterface 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.DatatypeConverterInterface
的使用

使用 DatatypeConverterInterface 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 DatatypeConverterInterface 的使用

参数类型为 DatatypeConverterInterface 的 javax.xml.bind 中的方法
static void DatatypeConverter.setDatatypeConverter(DatatypeConverterInterface converter)
此方法仅适用于 JAXB 提供者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.Element 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.Element
的使用

没有 javax.xml.bind.Element 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.JAXBContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.JAXBContext
的使用

使用 JAXBContext 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.bind 中 JAXBContext 的使用

返回 JAXBContext 的 javax.xml.bind 中的方法
static JAXBContext | JAXBContext.newInstance(Class... classesToBeBound) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(String contextPath) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(String contextPath, ClassLoader classLoader) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties) 获得 JAXBContext 类的新实例。

javax.xml.bind.util 中 JAXBContext 的使用

参数类型为 JAXBContext 的 javax.xml.bind.util 中的构造方法
JAXBResult(JAXBContext context)
创建一个使用指定 JAXBContext 来解组的新实例。
JAXBSource(JAXBContext context, Object contentObject)
针对给定的内容对象创建一个新 Source。

javax.xml.ws 中 JAXBContext 的使用

参数类型为 JAXBContext 的 javax.xml.ws 中的方法
Dispatch<Object> | Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode) 创建与生成的 JAXB 对象一起使用的 Dispatch 实例。
Object | LogicalMessage.getPayload(JAXBContext context) 以 JAXB 对象的形式获取消息负载。
void | LogicalMessage.setPayload(Object payload, JAXBContext context) 设置消息负载

javax.xml.ws.handler.soap 中 JAXBContext 的使用

参数类型为 JAXBContext 的 javax.xml.ws.handler.soap 中的方法
 Object[] SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
从消息上下文的消息中获得具有特定限定名的头。

javax.xml.ws.spi 中 JAXBContext 的使用

参数类型为 JAXBContext 的 javax.xml.ws.spi 中的方法
abstract  Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.JAXBElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.JAXBElement
的使用

使用 JAXBElement 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 JAXBElement 的使用

返回 JAXBElement 的 javax.xml.bind 中的方法
<T> JAXBElement<T>
Unmarshaller.unmarshal(Node node, Class<T> declaredType)
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Source source, Class<T> declaredType)
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
abstract
<T> JAXBElement<T>
Binder.unmarshal(XmlNode xmlNode, Class<T> declaredType)
根据提供的 declaredType 将 XML 根元素解组为 JAXB 对象树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

javax.xml.bind.helpers 中 JAXBElement 的使用

返回 JAXBElement 的 javax.xml.bind.helpers 中的方法
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.JAXBElement.GlobalScope 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.JAXBElement.GlobalScope
的使用

没有 javax.xml.bind.JAXBElement.GlobalScope 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.JAXBException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.JAXBException
的使用

使用 JAXBException 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。

javax.xml.bind 中 JAXBException 的使用

javax.xml.bind 中 JAXBException 的子类
class | MarshalException 此异常指示在执行提供者无法恢复的编组操作时发生错误。
class | PropertyException 此异常指示在获取或设置属性时遇到一个错误。
class | UnmarshalException 此异常指示在执行阻止 JAXB 提供者完成操作的解组操作时遇到一个错误。
class | ValidationException 此异常指示在执行验证操作时发生错误。

抛出 JAXBException 的 javax.xml.bind 中的方法
abstract  Marshaller JAXBContext.createMarshaller()
创建一个可以用来将 java 内容树转换为 XML 数据的 Marshaller 对象。
abstract  Unmarshaller JAXBContext.createUnmarshaller()
创建一个可以用来将 XML 数据转换为 java 内容树的 Unmarshaller 对象。
abstract  Validator JAXBContext.createValidator()
已过时。 从 JAXB 2.0 开始
abstract  ValidationEventHandler Binder.getEventHandler()
当前的事件处理程序；如果没有设置，则返回默认事件处理程序。
 ValidationEventHandler Marshaller.getEventHandler()
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
 ValidationEventHandler Unmarshaller.getEventHandler()
返回当前的事件处理程序，如果没有设置事件处理程序，则返回默认的事件处理程序。
 ValidationEventHandler Validator.getEventHandler()
已过时。 从 JAXB2.0 开始
 Node Marshaller.getNode(Object contentTree)
获取内容树的 DOM 树视图（可选）。
 Object UnmarshallerHandler.getResult()
获得解组的结果。
 boolean Unmarshaller.isValidating()
已过时。 从 JAXB 2.0 开始，请参阅 Unmarshaller.getSchema()
 void Marshaller.marshal(Object jaxbElement, ContentHandler handler)
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。
 void Marshaller.marshal(Object jaxbElement, Node node)
将以 jaxbElement 为根的内容树编组到 DOM 树中。
 void Marshaller.marshal(Object jaxbElement, OutputStream os)
将以 jaxbElement 为根的内容树编组到输出流中。
 void Marshaller.marshal(Object jaxbElement, Result result)
将以 jaxbElement 为根的内容树编组到指定的 javax.xml.transform.Result 中。
 void Marshaller.marshal(Object jaxbElement, Writer writer)
将以 jaxbElement 为根的内容树编组到 Writer 中。
 void Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。
abstract  void Binder.marshal(Object jaxbObject, XmlNode xmlNode)
将 JAXB 对象树编组为新的 XML 文档。
 void Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。
static JAXBContext JAXBContext.newInstance(Class... classesToBeBound)
获得 JAXBContext 类的新实例。
static JAXBContext JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties)
获得 JAXBContext 类的新实例。
static JAXBContext JAXBContext.newInstance(String contextPath)
获得 JAXBContext 类的新实例。
static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader)
获得 JAXBContext 类的新实例。
static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
获得 JAXBContext 类的新实例。
abstract  void Binder.setEventHandler(ValidationEventHandler handler)
允许应用程序注册 ValidationEventHandler。
 void Marshaller.setEventHandler(ValidationEventHandler handler)
允许应用程序注册一个验证事件处理程序。
 void Unmarshaller.setEventHandler(ValidationEventHandler handler)
允许应用程序注册 ValidationEventHandler。
 void Validator.setEventHandler(ValidationEventHandler handler)
已过时。 从 JAXB2.0 开始
 void Unmarshaller.setValidating(boolean validating)
已过时。 从 JAXB2.0 开始，请参阅 Unmarshaller.setSchema(javax.xml.validation.Schema)
 Object Unmarshaller.unmarshal(File f)
从指定的文件解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(InputSource source)
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(InputStream is)
从指定的 InputStream 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(Node node)
从指定的 DOM 树解组全局 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Node node, Class<T> declaredType)
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(Reader reader)
从指定的 Reader 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(Source source)
从指定的 XML Source 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Source source, Class<T> declaredType)
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(URL url)
从指定的 URL 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(XMLEventReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
abstract  Object Binder.unmarshal(XmlNode xmlNode)
将 XML 信息集视图解组为 JAXB 对象树。
abstract
<T> JAXBElement<T>
Binder.unmarshal(XmlNode xmlNode, Class<T> declaredType)
根据提供的 declaredType 将 XML 根元素解组为 JAXB 对象树。
 Object Unmarshaller.unmarshal(XMLStreamReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
abstract  Object Binder.updateJAXB(XmlNode xmlNode)
取一个 XML 节点，并更新与其关联的 JAXB 对象和该对象的子级。
abstract  XmlNode Binder.updateXML(Object jaxbObject)
取一个 JAXB 对象，并更新与其关联的 XML 节点和该节点的子级。
abstract  XmlNode Binder.updateXML(Object jaxbObject, XmlNode xmlNode)
JAXB 对象树中所做的更改在与其关联的 XML 解析树中得到更新。
 boolean Validator.validate(Object subrootObj)
已过时。 从 JAXB2.0 开始
 boolean Validator.validateRoot(Object rootObj)
已过时。 从 JAXB2.0 开始

javax.xml.bind.helpers 中 JAXBException 的使用

抛出 JAXBException 的 javax.xml.bind.helpers 中的方法
 ValidationEventHandler AbstractMarshallerImpl.getEventHandler()
 ValidationEventHandler AbstractUnmarshallerImpl.getEventHandler()
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
 Node AbstractMarshallerImpl.getNode(Object obj)
默认情况下，getNode 方法不受支持并抛出 UnsupportedOperationException。
protected  XMLReader AbstractUnmarshallerImpl.getXMLReader()
获取配置好的 XMLReader。
 boolean AbstractUnmarshallerImpl.isValidating()
指示 Unmarshaller 是否被配置为在执行解组操作期间进行验证。
 void AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)
 void AbstractMarshallerImpl.marshal(Object obj, Node node)
 void AbstractMarshallerImpl.marshal(Object obj, OutputStream os)
 void AbstractMarshallerImpl.marshal(Object obj, Writer w)
 void AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)
 void AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)
 void AbstractMarshallerImpl.setEventHandler(ValidationEventHandler handler)
 void AbstractUnmarshallerImpl.setEventHandler(ValidationEventHandler handler)
允许应用程序注册一个验证事件处理程序。
 void AbstractUnmarshallerImpl.setValidating(boolean validating)
指定 Unmarshaller 是否应该在执行解组操作期间进行验证。
 Object AbstractUnmarshallerImpl.unmarshal(File f)
 Object AbstractUnmarshallerImpl.unmarshal(InputSource source)
 Object AbstractUnmarshallerImpl.unmarshal(InputStream is)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
 Object AbstractUnmarshallerImpl.unmarshal(Reader reader)
 Object AbstractUnmarshallerImpl.unmarshal(Source source)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)
 Object AbstractUnmarshallerImpl.unmarshal(URL url)
 Object AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)
protected abstract  Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
使用指定的 XMLReader 和 InputSource 解组对象。
 Object AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

javax.xml.bind.util 中 JAXBException 的使用

抛出 JAXBException 的 javax.xml.bind.util 中的方法
 Object JAXBResult.getResult()
获取通过转换创建的已解组对象。

抛出 JAXBException 的 javax.xml.bind.util 中的构造方法
JAXBResult(JAXBContext context)
创建一个使用指定 JAXBContext 来解组的新实例。
JAXBResult(Unmarshaller _unmarshaller)
创建一个使用指定 Unmarshaller 来解组对象的新实例。
JAXBSource(JAXBContext context, Object contentObject)
针对给定的内容对象创建一个新 Source。
JAXBSource(Marshaller marshaller, Object contentObject)
针对给定的内容对象创建一个新 Source。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.JAXBIntrospector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.JAXBIntrospector
的使用

使用 JAXBIntrospector 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 JAXBIntrospector 的使用

返回 JAXBIntrospector 的 javax.xml.bind 中的方法
 JAXBIntrospector JAXBContext.createJAXBIntrospector()
创建一个可以用于内省 JAXB 对象的 JAXBIntrospector 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.MarshalException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.MarshalException
的使用

没有 javax.xml.bind.MarshalException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.Marshaller 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.Marshaller
的使用

使用 Marshaller 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。

javax.xml.bind 中 Marshaller 的使用

返回 Marshaller 的 javax.xml.bind 中的方法
abstract  Marshaller JAXBContext.createMarshaller()
创建一个可以用来将 java 内容树转换为 XML 数据的 Marshaller 对象。

javax.xml.bind.helpers 中 Marshaller 的使用

实现 Marshaller 的 javax.xml.bind.helpers 中的类
 class AbstractMarshallerImpl
部分默认 Marshaller 实现。

javax.xml.bind.util 中 Marshaller 的使用

参数类型为 Marshaller 的 javax.xml.bind.util 中的构造方法
JAXBSource(Marshaller marshaller, Object contentObject)
针对给定的内容对象创建一个新 Source。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.Marshaller.Listener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.Marshaller.Listener
的使用

使用 Marshaller.Listener 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 Marshaller.Listener 的使用

返回 Marshaller.Listener 的 javax.xml.bind 中的方法
 Marshaller.Listener Marshaller.getListener()
返回向此 Marshaller 注册的 Marshaller.Listener。

参数类型为 Marshaller.Listener 的 javax.xml.bind 中的方法
 void Marshaller.setListener(Marshaller.Listener listener)
向此 Marshaller 注册编组事件回调 Marshaller.Listener。

javax.xml.bind.helpers 中 Marshaller.Listener 的使用

返回 Marshaller.Listener 的 javax.xml.bind.helpers 中的方法
 Marshaller.Listener AbstractMarshallerImpl.getListener()

参数类型为 Marshaller.Listener 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.setListener(Marshaller.Listener listener)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.NotIdentifiableEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.NotIdentifiableEvent
的使用

使用 NotIdentifiableEvent 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 中 NotIdentifiableEvent 的使用

实现 NotIdentifiableEvent 的 javax.xml.bind.helpers 中的类
 class NotIdentifiableEventImpl
NotIdentifiableEvent 接口的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.ParseConversionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.ParseConversionEvent
的使用

使用 ParseConversionEvent 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 中 ParseConversionEvent 的使用

实现 ParseConversionEvent 的 javax.xml.bind.helpers 中的类
 class ParseConversionEventImpl
ParseConversionEvent 接口的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.PrintConversionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.PrintConversionEvent
的使用

使用 PrintConversionEvent 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 中 PrintConversionEvent 的使用

实现 PrintConversionEvent 的 javax.xml.bind.helpers 中的类
 class PrintConversionEventImpl
PrintConversionEvent 接口的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.PropertyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.PropertyException
的使用

使用 PropertyException 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 PropertyException 的使用

抛出 PropertyException 的 javax.xml.bind 中的方法
abstract Object | Binder.getProperty(String name) 获取 Binder 的基础实现中的特定属性。
Object | Marshaller.getProperty(String name) 获取 Marshaller 底层实现中的特定属性。
Object | Unmarshaller.getProperty(String name) 获取 Unmarshaller 底层实现中的特定属性。
Object | Validator.getProperty(String name) 已过时。 从 JAXB2.0 开始
abstract void | Binder.setProperty(String name, Object value) 设置 Binder 的基础实现中的特定属性。
void | Marshaller.setProperty(String name, Object value) 设置 Marshaller 底层实现中的特定属性。
void | Unmarshaller.setProperty(String name, Object value) 设置 Unmarshaller 底层实现中的特定属性。
void | Validator.setProperty(String name, Object value) 已过时。 从 JAXB2.0 开始

javax.xml.bind.helpers 中 PropertyException 的使用

抛出 PropertyException 的 javax.xml.bind.helpers 中的方法
Object | AbstractMarshallerImpl.getProperty(String name) getProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。
Object | AbstractUnmarshallerImpl.getProperty(String name) 由于没有必需的属性，getProperty 方法的默认实现总是抛出 PropertyException。
void | AbstractMarshallerImpl.setProperty(String name, Object value) setProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。
void | AbstractUnmarshallerImpl.setProperty(String name, Object value) 由于没有必需的属性，setProperty 方法的默认实现总是抛出 PropertyException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.SchemaOutputResolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.SchemaOutputResolver
的使用

使用 SchemaOutputResolver 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 SchemaOutputResolver 的使用

参数类型为 SchemaOutputResolver 的 javax.xml.bind 中的方法
 void JAXBContext.generateSchema(SchemaOutputResolver outputResolver)
生成此上下文的模式文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.TypeConstraintException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.TypeConstraintException
的使用

没有 javax.xml.bind.TypeConstraintException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.UnmarshalException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.UnmarshalException
的使用

使用 UnmarshalException 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 中 UnmarshalException 的使用

返回 UnmarshalException 的 javax.xml.bind.helpers 中的方法
protected  UnmarshalException AbstractUnmarshallerImpl.createUnmarshalException(SAXException e)
从 SAXException 创建 UnmarshalException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.Unmarshaller 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.Unmarshaller
的使用

使用 Unmarshaller 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。

javax.xml.bind 中 Unmarshaller 的使用

返回 Unmarshaller 的 javax.xml.bind 中的方法
abstract  Unmarshaller JAXBContext.createUnmarshaller()
创建一个可以用来将 XML 数据转换为 java 内容树的 Unmarshaller 对象。

javax.xml.bind.helpers 中 Unmarshaller 的使用

实现 Unmarshaller 的 javax.xml.bind.helpers 中的类
 class AbstractUnmarshallerImpl
部分默认 Unmarshaller 实现。

javax.xml.bind.util 中 Unmarshaller 的使用

参数类型为 Unmarshaller 的 javax.xml.bind.util 中的构造方法
JAXBResult(Unmarshaller _unmarshaller)
创建一个使用指定 Unmarshaller 来解组对象的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.Unmarshaller.Listener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.Unmarshaller.Listener
的使用

使用 Unmarshaller.Listener 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 Unmarshaller.Listener 的使用

返回 Unmarshaller.Listener 的 javax.xml.bind 中的方法
 Unmarshaller.Listener Unmarshaller.getListener()
返回向此 Unmarshaller 注册的 Unmarshaller.Listener。

参数类型为 Unmarshaller.Listener 的 javax.xml.bind 中的方法
 void Unmarshaller.setListener(Unmarshaller.Listener listener)
向此 Unmarshaller 注册解组事件回调 Unmarshaller.Listener。

javax.xml.bind.helpers 中 Unmarshaller.Listener 的使用

返回 Unmarshaller.Listener 的 javax.xml.bind.helpers 中的方法
 Unmarshaller.Listener AbstractUnmarshallerImpl.getListener()

参数类型为 Unmarshaller.Listener 的 javax.xml.bind.helpers 中的方法
 void AbstractUnmarshallerImpl.setListener(Unmarshaller.Listener listener)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.UnmarshallerHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.UnmarshallerHandler
的使用

使用 UnmarshallerHandler 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 UnmarshallerHandler 的使用

返回 UnmarshallerHandler 的 javax.xml.bind 中的方法
 UnmarshallerHandler Unmarshaller.getUnmarshallerHandler()
获取可用作 XML 管线中的组件的 unmarshaller 处理程序对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.ValidationEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.ValidationEvent
的使用

使用 ValidationEvent 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。

javax.xml.bind 中 ValidationEvent 的使用

javax.xml.bind 中 ValidationEvent 的子接口
interface | NotIdentifiableEvent 此事件指示解析 ID/IDREF 时遇到一个问题。
interface | ParseConversionEvent 此事件指示将 XML 数据中的字符串转换为目标 Java 数据类型的值时遇到一个问题。
interface | PrintConversionEvent 此事件指示将 Java 内容树中的数据转换为其词汇表示形式时遇到一个问题。

参数类型为 ValidationEvent 的 javax.xml.bind 中的方法
 boolean ValidationEventHandler.handleEvent(ValidationEvent event)
接收验证警告或错误的通知。

javax.xml.bind.helpers 中 ValidationEvent 的使用

实现 ValidationEvent 的 javax.xml.bind.helpers 中的类
class | NotIdentifiableEventImpl NotIdentifiableEvent 接口的默认实现。
class | ParseConversionEventImpl ParseConversionEvent 接口的默认实现。
class | PrintConversionEventImpl PrintConversionEvent 接口的默认实现。
class | ValidationEventImpl ValidationEvent 接口的默认实现。

参数类型为 ValidationEvent 的 javax.xml.bind.helpers 中的方法
 boolean DefaultValidationEventHandler.handleEvent(ValidationEvent event)

javax.xml.bind.util 中 ValidationEvent 的使用

返回 ValidationEvent 的 javax.xml.bind.util 中的方法
 ValidationEvent[] ValidationEventCollector.getEvents()
返回一个 ValidationEvent 对象数组，这些对象包含所有收集的错误和警告的副本。

参数类型为 ValidationEvent 的 javax.xml.bind.util 中的方法
 boolean ValidationEventCollector.handleEvent(ValidationEvent event)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.ValidationEventHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.ValidationEventHandler
的使用

使用 ValidationEventHandler 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。

javax.xml.bind 中 ValidationEventHandler 的使用

返回 ValidationEventHandler 的 javax.xml.bind 中的方法
abstract ValidationEventHandler | Binder.getEventHandler() 当前的事件处理程序；如果没有设置，则返回默认事件处理程序。
ValidationEventHandler | Marshaller.getEventHandler() 返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
ValidationEventHandler | Unmarshaller.getEventHandler() 返回当前的事件处理程序，如果没有设置事件处理程序，则返回默认的事件处理程序。
ValidationEventHandler | Validator.getEventHandler() 已过时。 从 JAXB2.0 开始

参数类型为 ValidationEventHandler 的 javax.xml.bind 中的方法
abstract void | Binder.setEventHandler(ValidationEventHandler handler) 允许应用程序注册 ValidationEventHandler。
void | Marshaller.setEventHandler(ValidationEventHandler handler) 允许应用程序注册一个验证事件处理程序。
void | Unmarshaller.setEventHandler(ValidationEventHandler handler) 允许应用程序注册 ValidationEventHandler。
void | Validator.setEventHandler(ValidationEventHandler handler) 已过时。 从 JAXB2.0 开始

javax.xml.bind.annotation 中 ValidationEventHandler 的使用

参数类型为 ValidationEventHandler 的 javax.xml.bind.annotation 中的方法
ResultT | DomHandler.createUnmarshaller(ValidationEventHandler errorHandler) 当 JAXB 提供者需要将文档的一部分解组为信息集表示形式时，首先要调用此方法创建一个 Result 对象。
DOMResult | W3CDomHandler.createUnmarshaller(ValidationEventHandler errorHandler)
Source | DomHandler.marshal(ElementT n, ValidationEventHandler errorHandler) 在 JAXB 提供者需要将元素编组为 XML 时调用此方法。
Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

javax.xml.bind.helpers 中 ValidationEventHandler 的使用

实现 ValidationEventHandler 的 javax.xml.bind.helpers 中的类
 class DefaultValidationEventHandler
唯一的 JAXB 1.0 默认验证事件处理程序。

返回 ValidationEventHandler 的 javax.xml.bind.helpers 中的方法
ValidationEventHandler | AbstractMarshallerImpl.getEventHandler()
ValidationEventHandler | AbstractUnmarshallerImpl.getEventHandler() 返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。

参数类型为 ValidationEventHandler 的 javax.xml.bind.helpers 中的方法
void | AbstractMarshallerImpl.setEventHandler(ValidationEventHandler handler)
void | AbstractUnmarshallerImpl.setEventHandler(ValidationEventHandler handler) 允许应用程序注册一个验证事件处理程序。

javax.xml.bind.util 中 ValidationEventHandler 的使用

实现 ValidationEventHandler 的 javax.xml.bind.util 中的类
 class ValidationEventCollector
收集所有事件的 ValidationEventHandler 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.ValidationEventLocator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.ValidationEventLocator
的使用

使用 ValidationEventLocator 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 ValidationEventLocator 的使用

返回 ValidationEventLocator 的 javax.xml.bind 中的方法
 ValidationEventLocator ValidationEvent.getLocator()
检索此警告/错误的定位符。

javax.xml.bind.helpers 中 ValidationEventLocator 的使用

实现 ValidationEventLocator 的 javax.xml.bind.helpers 中的类
 class ValidationEventLocatorImpl
ValidationEventLocator 接口的默认实现。

返回 ValidationEventLocator 的 javax.xml.bind.helpers 中的方法
 ValidationEventLocator ValidationEventImpl.getLocator()

参数类型为 ValidationEventLocator 的 javax.xml.bind.helpers 中的方法
 void ValidationEventImpl.setLocator(ValidationEventLocator _locator)
设置此事件的 Locator 对象。

参数类型为 ValidationEventLocator 的 javax.xml.bind.helpers 中的构造方法
NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 NotIdentifiableEventImpl。
NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 NotIdentifiableEventImpl。
ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 ParseConversionEventImpl。
ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ParseConversionEventImpl。
PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 PrintConversionEventImpl。
PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 PrintConversionEventImpl。
ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 ValidationEventImpl。
ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ValidationEventImpl。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.ValidationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.ValidationException
的使用

没有 javax.xml.bind.ValidationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.bind.Validator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.Validator
的使用

使用 Validator 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 Validator 的使用

返回 Validator 的 javax.xml.bind 中的方法
abstract  Validator JAXBContext.createValidator()
已过时。 从 JAXB 2.0 开始

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.bind.helpers (Java 2 Platform SE 6)

 javax.xml.bind.helpers
类
AbstractMarshallerImpl
AbstractUnmarshallerImpl
DefaultValidationEventHandler
NotIdentifiableEventImpl
ParseConversionEventImpl
PrintConversionEventImpl
ValidationEventImpl
ValidationEventLocatorImpl


类 javax.xml.bind.helpers.AbstractMarshallerImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.AbstractMarshallerImpl
的使用

没有 javax.xml.bind.helpers.AbstractMarshallerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.AbstractUnmarshallerImpl
的使用

没有 javax.xml.bind.helpers.AbstractUnmarshallerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.helpers.DefaultValidationEventHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.DefaultValidationEventHandler
的使用

没有 javax.xml.bind.helpers.DefaultValidationEventHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.helpers.NotIdentifiableEventImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.NotIdentifiableEventImpl
的使用

没有 javax.xml.bind.helpers.NotIdentifiableEventImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.helpers.ParseConversionEventImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.ParseConversionEventImpl
的使用

没有 javax.xml.bind.helpers.ParseConversionEventImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.helpers.PrintConversionEventImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.PrintConversionEventImpl
的使用

没有 javax.xml.bind.helpers.PrintConversionEventImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.helpers.ValidationEventImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.ValidationEventImpl
的使用

使用 ValidationEventImpl 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 中 ValidationEventImpl 的使用

javax.xml.bind.helpers 中 ValidationEventImpl 的子类
class | NotIdentifiableEventImpl NotIdentifiableEvent 接口的默认实现。
class | ParseConversionEventImpl ParseConversionEvent 接口的默认实现。
class | PrintConversionEventImpl PrintConversionEvent 接口的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.ValidationEventLocatorImpl
的使用

没有 javax.xml.bind.helpers.ValidationEventLocatorImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.bind.util (Java 2 Platform SE 6)

 javax.xml.bind.util
类
JAXBResult
JAXBSource
ValidationEventCollector


类 javax.xml.bind.util.JAXBResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.util.JAXBResult
的使用

没有 javax.xml.bind.util.JAXBResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.util.JAXBSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.util.JAXBSource
的使用

没有 javax.xml.bind.util.JAXBSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.bind.util.ValidationEventCollector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.util.ValidationEventCollector
的使用

没有 javax.xml.bind.util.ValidationEventCollector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.XMLConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.XMLConstants
的使用

没有 javax.xml.XMLConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.crypto (Java 2 Platform SE 6)

 javax.xml.crypto
接口
AlgorithmMethod
Data
KeySelectorResult
NodeSetData
URIDereferencer
URIReference
XMLCryptoContext
XMLStructure
类
KeySelector
KeySelector.Purpose
OctetStreamData
异常
KeySelectorException
MarshalException
NoSuchMechanismException
URIReferenceException


接口 javax.xml.crypto.AlgorithmMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.AlgorithmMethod
的使用

使用 AlgorithmMethod 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。

javax.xml.crypto 中 AlgorithmMethod 的使用

参数类型为 AlgorithmMethod 的 javax.xml.crypto 中的方法
abstract  KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
尝试查找满足指定约束的密钥。

javax.xml.crypto.dsig 中 AlgorithmMethod 的使用

javax.xml.crypto.dsig 中 AlgorithmMethod 的子接口
interface | CanonicalizationMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。
interface | DigestMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML DigestMethod 元素的表示形式。
interface | SignatureMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureMethod 元素的表示形式。
interface | Transform W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Transform 元素的表示形式。

实现 AlgorithmMethod 的 javax.xml.crypto.dsig 中的类
 class TransformService
转换算法和规范算法的服务提供者接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.Data 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.Data
的使用

使用 Data 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 Data 的使用

javax.xml.crypto 中 Data 的子接口
 interface NodeSetData
包含节点集的 Data 类型的抽象表示。

实现 Data 的 javax.xml.crypto 中的类
 class OctetStreamData
包含一个八位组流的 Data 类型的表示形式。

返回 Data 的 javax.xml.crypto 中的方法
 Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
取消引用指定 URIReference 并返回已取消引用的数据。

javax.xml.crypto.dsig 中 Data 的使用

返回 Data 的 javax.xml.crypto.dsig 中的方法
Data | Reference.getDereferencedData() 如果已启用引用缓存，则返回被取消引用的数据。
Data | Transform.transform(Data data, XMLCryptoContext context) 使用底层转换算法对指定数据进行转换。
Data | Transform.transform(Data data, XMLCryptoContext context, OutputStream os) 使用底层转换算法对指定数据进行转换。

参数类型为 Data 的 javax.xml.crypto.dsig 中的方法
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
Data | Transform.transform(Data data, XMLCryptoContext context) 使用底层转换算法对指定数据进行转换。
Data | Transform.transform(Data data, XMLCryptoContext context, OutputStream os) 使用底层转换算法对指定数据进行转换。

javax.xml.crypto.dsig.keyinfo 中 Data 的使用

返回 Data 的 javax.xml.crypto.dsig.keyinfo 中的方法
 Data RetrievalMethod.dereference(XMLCryptoContext context)
取消引用此 RetrievalMethod 引用的 KeyInfo 信息，并应用指定的 Transform。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.KeySelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.KeySelector
的使用

使用 KeySelector 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto 中 KeySelector 的使用

返回 KeySelector 的 javax.xml.crypto 中的方法
KeySelector | XMLCryptoContext.getKeySelector() 返回用于查找某个密钥的密钥选择器。
static KeySelector | KeySelector.singletonKeySelector(Key key) 返回一个总是选择指定密钥的 KeySelector，不管传递给它的 KeyInfo 是什么。

参数类型为 KeySelector 的 javax.xml.crypto 中的方法
 void XMLCryptoContext.setKeySelector(KeySelector ks)
设置用于查找某个密钥的密钥选择器。

javax.xml.crypto.dom 中 KeySelector 的使用

返回 KeySelector 的 javax.xml.crypto.dom 中的方法
 KeySelector DOMCryptoContext.getKeySelector()

参数类型为 KeySelector 的 javax.xml.crypto.dom 中的方法
 void DOMCryptoContext.setKeySelector(KeySelector ks)

javax.xml.crypto.dsig.dom 中 KeySelector 的使用

参数类型为 KeySelector 的 javax.xml.crypto.dsig.dom 中的构造方法
DOMSignContext(KeySelector ks, Node parent)
创建带有指定密钥选择器和父节点的 DOMSignContext。
DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
创建带有指定密钥选择器、父节点和下一个兄弟节点的 DOMSignContext。
DOMValidateContext(KeySelector ks, Node node)
创建包含指定密钥选择器和节点的 DOMValidateContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.KeySelector.Purpose 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.KeySelector.Purpose
的使用

使用 KeySelector.Purpose 的软件包
javax.xml.crypto 用于 XML 加密的通用类。

javax.xml.crypto 中 KeySelector.Purpose 的使用

声明为 KeySelector.Purpose 的 javax.xml.crypto 中的字段
static KeySelector.Purpose | KeySelector.Purpose.DECRYPT 用于解密的密钥。
static KeySelector.Purpose | KeySelector.Purpose.ENCRYPT 用于加密的密钥。
static KeySelector.Purpose | KeySelector.Purpose.SIGN 用于签名的密钥。
static KeySelector.Purpose | KeySelector.Purpose.VERIFY 用于验证的密钥。

参数类型为 KeySelector.Purpose 的 javax.xml.crypto 中的方法
abstract  KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
尝试查找满足指定约束的密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.KeySelectorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.KeySelectorException
的使用

使用 KeySelectorException 的软件包
javax.xml.crypto 用于 XML 加密的通用类。

javax.xml.crypto 中 KeySelectorException 的使用

抛出 KeySelectorException 的 javax.xml.crypto 中的方法
abstract  KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
尝试查找满足指定约束的密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.KeySelectorResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.KeySelectorResult
的使用

使用 KeySelectorResult 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。

javax.xml.crypto 中 KeySelectorResult 的使用

返回 KeySelectorResult 的 javax.xml.crypto 中的方法
abstract  KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
尝试查找满足指定约束的密钥。

javax.xml.crypto.dsig 中 KeySelectorResult 的使用

返回 KeySelectorResult 的 javax.xml.crypto.dsig 中的方法
 KeySelectorResult XMLSignature.getKeySelectorResult()
在对此 XMLSignature 进行签名或验证后，返回密钥选择器 KeySelector（如果已指定）的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.MarshalException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.MarshalException
的使用

使用 MarshalException 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig 中 MarshalException 的使用

抛出 MarshalException 的 javax.xml.crypto.dsig 中的方法
abstract void | TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context) 对特定于算法的参数进行编组。
void | XMLSignature.sign(XMLSignContext signContext) 为此 XMLSignature 签名。
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure) 从特定于机制的 XMLStructure 实例解组新的 XMLSignature 实例。
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context) 从特定于机制的 XMLValidateContext 实例解组新的 XMLSignature 实例。

javax.xml.crypto.dsig.keyinfo 中 MarshalException 的使用

抛出 MarshalException 的 javax.xml.crypto.dsig.keyinfo 中的方法
void | KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context) 将密钥信息编组为 XML。
abstract KeyInfo | KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure) 根据特定于机制的 XMLStructure（比如：DOMStructure）实例解组新的 KeyInfo 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.NodeSetData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.NodeSetData
的使用

没有 javax.xml.crypto.NodeSetData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.NoSuchMechanismException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.NoSuchMechanismException
的使用

没有 javax.xml.crypto.NoSuchMechanismException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.OctetStreamData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.OctetStreamData
的使用

没有 javax.xml.crypto.OctetStreamData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.URIDereferencer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.URIDereferencer
的使用

使用 URIDereferencer 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 URIDereferencer 的使用

返回 URIDereferencer 的 javax.xml.crypto 中的方法
 URIDereferencer XMLCryptoContext.getURIDereferencer()
返回用来取消引用 URIReference 的 URIDereferencer。

参数类型为 URIDereferencer 的 javax.xml.crypto 中的方法
 void XMLCryptoContext.setURIDereferencer(URIDereferencer dereferencer)
设置用来取消引用 URIReference 的 URIDereferencer。

javax.xml.crypto.dom 中 URIDereferencer 的使用

返回 URIDereferencer 的 javax.xml.crypto.dom 中的方法
 URIDereferencer DOMCryptoContext.getURIDereferencer()

参数类型为 URIDereferencer 的 javax.xml.crypto.dom 中的方法
 void DOMCryptoContext.setURIDereferencer(URIDereferencer dereferencer)

javax.xml.crypto.dsig 中 URIDereferencer 的使用

返回 URIDereferencer 的 javax.xml.crypto.dsig 中的方法
abstract  URIDereferencer XMLSignatureFactory.getURIDereferencer()
返回对 URIDereferencer 的引用，默认情况下该引用用于取消 Reference 对象中对 URI 的引用。

javax.xml.crypto.dsig.keyinfo 中 URIDereferencer 的使用

返回 URIDereferencer 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  URIDereferencer KeyInfoFactory.getURIDereferencer()
返回对 URIDereferencer 的引用，默认情况下用于取消引用 RetrievalMethod 对象中的 URI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.URIReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.URIReference
的使用

使用 URIReference 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 URIReference 的使用

返回 URIReference 的 javax.xml.crypto 中的方法
 URIReference URIReferenceException.getURIReference()
返回抛出异常时正被取消引用的 URIReference。

参数类型为 URIReference 的 javax.xml.crypto 中的方法
 Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
取消引用指定 URIReference 并返回已取消引用的数据。

参数类型为 URIReference 的 javax.xml.crypto 中的构造方法
URIReferenceException(String message, Throwable cause, URIReference uriReference)
构造带指定详细消息、cause 和 URIReference 的新 URIReferenceException。

javax.xml.crypto.dom 中 URIReference 的使用

javax.xml.crypto.dom 中 URIReference 的子接口
 interface DOMURIReference
特定于 DOM 的 URIReference。

javax.xml.crypto.dsig 中 URIReference 的使用

javax.xml.crypto.dsig 中 URIReference 的子接口
 interface Reference
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Reference 元素的表示形式。

javax.xml.crypto.dsig.keyinfo 中 URIReference 的使用

javax.xml.crypto.dsig.keyinfo 中 URIReference 的子接口
 interface RetrievalMethod
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML RetrievalMethod 元素的表示形式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.URIReferenceException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.URIReferenceException
的使用

使用 URIReferenceException 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 URIReferenceException 的使用

抛出 URIReferenceException 的 javax.xml.crypto 中的方法
 Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
取消引用指定 URIReference 并返回已取消引用的数据。

javax.xml.crypto.dsig.keyinfo 中 URIReferenceException 的使用

抛出 URIReferenceException 的 javax.xml.crypto.dsig.keyinfo 中的方法
 Data RetrievalMethod.dereference(XMLCryptoContext context)
取消引用此 RetrievalMethod 引用的 KeyInfo 信息，并应用指定的 Transform。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.XMLCryptoContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.XMLCryptoContext
的使用

使用 XMLCryptoContext 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 XMLCryptoContext 的使用

参数类型为 XMLCryptoContext 的 javax.xml.crypto 中的方法
Data | URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context) 取消引用指定 URIReference 并返回已取消引用的数据。
abstract KeySelectorResult | KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context) 尝试查找满足指定约束的密钥。

javax.xml.crypto.dom 中 XMLCryptoContext 的使用

实现 XMLCryptoContext 的 javax.xml.crypto.dom 中的类
 class DOMCryptoContext
此类提供 XMLCryptoContext 接口特定于 DOM 的实现。

javax.xml.crypto.dsig 中 XMLCryptoContext 的使用

javax.xml.crypto.dsig 中 XMLCryptoContext 的子接口
interface | XMLSignContext 包含用于生成 XML Signature 的上下文信息。
interface | XMLValidateContext 包含用于验证 XML Signature 的上下文信息。

参数类型为 XMLCryptoContext 的 javax.xml.crypto.dsig 中的方法
abstract void | TransformService.init(XMLStructure parent, XMLCryptoContext context) 使用指定的参数和文档上下文初始化此 TransformService。
abstract void | TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context) 对特定于算法的参数进行编组。
Data | Transform.transform(Data data, XMLCryptoContext context) 使用底层转换算法对指定数据进行转换。
Data | Transform.transform(Data data, XMLCryptoContext context, OutputStream os) 使用底层转换算法对指定数据进行转换。

javax.xml.crypto.dsig.dom 中 XMLCryptoContext 的使用

实现 XMLCryptoContext 的 javax.xml.crypto.dsig.dom 中的类
class | DOMSignContext 特定于 DOM 的 XMLSignContext。
class | DOMValidateContext 特定于 DOM 的 XMLValidateContext。

javax.xml.crypto.dsig.keyinfo 中 XMLCryptoContext 的使用

参数类型为 XMLCryptoContext 的 javax.xml.crypto.dsig.keyinfo 中的方法
Data | RetrievalMethod.dereference(XMLCryptoContext context) 取消引用此 RetrievalMethod 引用的 KeyInfo 信息，并应用指定的 Transform。
void | KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context) 将密钥信息编组为 XML。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.XMLStructure 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.XMLStructure
的使用

使用 XMLStructure 的软件包
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

javax.xml.crypto.dom 中 XMLStructure 的使用

实现 XMLStructure 的 javax.xml.crypto.dom 中的类
 class DOMStructure
特定于 DOM 的 XMLStructure。

javax.xml.crypto.dsig 中 XMLStructure 的使用

javax.xml.crypto.dsig 中 XMLStructure 的子接口
interface | CanonicalizationMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。
interface | DigestMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML DigestMethod 元素的表示形式。
interface | Manifest 在 W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Manifest 元素的表示形式。
interface | Reference W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Reference 元素的表示形式。
interface | SignatureMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureMethod 元素的表示形式。
interface | SignatureProperties W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperties 元素的表示形式。
interface | SignatureProperty W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperty 元素的表示形式。
interface | SignedInfo W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignedInfo 元素的表示形式。
interface | Transform W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Transform 元素的表示形式。
interface | XMLObject W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Object 元素的表示形式。
interface | XMLSignature W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Signature 元素的表示形式。
static interface | XMLSignature.SignatureValue W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureValue 元素的表示形式。

实现 XMLStructure 的 javax.xml.crypto.dsig 中的类
 class TransformService
转换算法和规范算法的服务提供者接口。

参数类型为 XMLStructure 的 javax.xml.crypto.dsig 中的方法
abstract void | TransformService.init(XMLStructure parent, XMLCryptoContext context) 使用指定的参数和文档上下文初始化此 TransformService。
abstract void | TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context) 对特定于算法的参数进行编组。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 Transform。
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure) 从特定于机制的 XMLStructure 实例解组新的 XMLSignature 实例。

javax.xml.crypto.dsig.keyinfo 中 XMLStructure 的使用

javax.xml.crypto.dsig.keyinfo 中 XMLStructure 的子接口
interface | KeyInfo W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyInfo 元素的表示形式。
interface | KeyName W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyName 元素的表示形式。
interface | KeyValue W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyValue 元素的表示形式。
interface | PGPData W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML PGPData 元素的表示形式。
interface | RetrievalMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML RetrievalMethod 元素的表示形式。
interface | X509Data W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509Data 元素的表示形式。
interface | X509IssuerSerial W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509IssuerSerial 元素的表示形式。

参数类型为 XMLStructure 的 javax.xml.crypto.dsig.keyinfo 中的方法
void | KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context) 将密钥信息编组为 XML。
abstract KeyInfo | KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure) 根据特定于机制的 XMLStructure（比如：DOMStructure）实例解组新的 KeyInfo 实例。

javax.xml.crypto.dsig.spec 中 XMLStructure 的使用

返回 XMLStructure 的 javax.xml.crypto.dsig.spec 中的方法
 XMLStructure XSLTTransformParameterSpec.getStylesheet()
返回样式表。

参数类型为 XMLStructure 的 javax.xml.crypto.dsig.spec 中的构造方法
XSLTTransformParameterSpec(XMLStructure stylesheet)
创建带有指定样式表的 XSLTTransformParameterSpec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.crypto.dom (Java 2 Platform SE 6)

 javax.xml.crypto.dom
接口
DOMURIReference
类
DOMCryptoContext
DOMStructure


类 javax.xml.crypto.dom.DOMCryptoContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dom.DOMCryptoContext
的使用

使用 DOMCryptoContext 的软件包
javax.xml.crypto.dsig.dom javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto.dsig.dom 中 DOMCryptoContext 的使用

javax.xml.crypto.dsig.dom 中 DOMCryptoContext 的子类
class | DOMSignContext 特定于 DOM 的 XMLSignContext。
class | DOMValidateContext 特定于 DOM 的 XMLValidateContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dom.DOMStructure 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dom.DOMStructure
的使用

没有 javax.xml.crypto.dom.DOMStructure 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dom.DOMURIReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dom.DOMURIReference
的使用

没有 javax.xml.crypto.dom.DOMURIReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.crypto.dsig (Java 2 Platform SE 6)

 javax.xml.crypto.dsig
接口
CanonicalizationMethod
DigestMethod
Manifest
Reference
SignatureMethod
SignatureProperties
SignatureProperty
SignedInfo
Transform
XMLObject
XMLSignature
XMLSignature.SignatureValue
XMLSignContext
XMLValidateContext
类
TransformService
XMLSignatureFactory
异常
TransformException
XMLSignatureException


接口 javax.xml.crypto.dsig.CanonicalizationMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.CanonicalizationMethod
的使用

使用 CanonicalizationMethod 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 CanonicalizationMethod 的使用

返回 CanonicalizationMethod 的 javax.xml.crypto.dsig 中的方法
CanonicalizationMethod | SignedInfo.getCanonicalizationMethod() 返回此 SignedInfo 的规范化方法。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。

参数类型为 CanonicalizationMethod 的 javax.xml.crypto.dsig 中的方法
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references) 创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id) 创建带指定参数的 SignedInfo。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.DigestMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.DigestMethod
的使用

使用 DigestMethod 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 DigestMethod 的使用

返回 DigestMethod 的 javax.xml.crypto.dsig 中的方法
DigestMethod | Reference.getDigestMethod() 返回此 Reference 的摘要方法。
abstract DigestMethod | XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params) 针对指定的算法 URI 和参数创建 DigestMethod。

参数类型为 DigestMethod 的 javax.xml.crypto.dsig 中的方法
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm) 创建带指定 URI 和摘要方法的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue) 创建带指定参数和预计算的摘要值的 Reference。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.Manifest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.Manifest
的使用

使用 Manifest 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 Manifest 的使用

返回 Manifest 的 javax.xml.crypto.dsig 中的方法
abstract Manifest | XMLSignatureFactory.newManifest(List references) 创建包含指定的 Reference 列表的 Manifest。
abstract Manifest | XMLSignatureFactory.newManifest(List references, String id) 创建包含指定的 Reference 列表和可选 id 的 Manifest。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.Reference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.Reference
的使用

使用 Reference 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 Reference 的使用

返回 Reference 的 javax.xml.crypto.dsig 中的方法
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm) 创建带指定 URI 和摘要方法的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue) 创建带指定参数和预计算的摘要值的 Reference。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.SignatureMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.SignatureMethod
的使用

使用 SignatureMethod 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 SignatureMethod 的使用

返回 SignatureMethod 的 javax.xml.crypto.dsig 中的方法
SignatureMethod | SignedInfo.getSignatureMethod() 返回此 SignedInfo 的签名方法。
abstract SignatureMethod | XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params) 针对指定的算法 URI 和参数创建 SignatureMethod。

参数类型为 SignatureMethod 的 javax.xml.crypto.dsig 中的方法
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references) 创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id) 创建带指定参数的 SignedInfo。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.SignatureProperties 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.SignatureProperties
的使用

使用 SignatureProperties 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 SignatureProperties 的使用

返回 SignatureProperties 的 javax.xml.crypto.dsig 中的方法
abstract  SignatureProperties XMLSignatureFactory.newSignatureProperties(List properties, String id)
创建包含指定的 SignatureProperty 列表和可选 id 的 SignatureProperties。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.SignatureProperty 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.SignatureProperty
的使用

使用 SignatureProperty 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 SignatureProperty 的使用

返回 SignatureProperty 的 javax.xml.crypto.dsig 中的方法
abstract  SignatureProperty XMLSignatureFactory.newSignatureProperty(List content, String target, String id)
创建包含指定的 XMLStructure 列表、目标 URI 和可选 id 的SignatureProperty。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.SignedInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.SignedInfo
的使用

使用 SignedInfo 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 SignedInfo 的使用

返回 SignedInfo 的 javax.xml.crypto.dsig 中的方法
SignedInfo | XMLSignature.getSignedInfo() 返回此 XMLSignature 的签名信息。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references) 创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id) 创建带指定参数的 SignedInfo。

参数类型为 SignedInfo 的 javax.xml.crypto.dsig 中的方法
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki) 创建一个 XMLSignature，并使用指定的 SignedInfo 和 KeyInfo 对象的内容对其进行初始化。
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId) 创建一个 XMLSignature，并使用指定的参数对其进行初始化。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.Transform 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.Transform
的使用

使用 Transform 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 Transform 的使用

javax.xml.crypto.dsig 中 Transform 的子接口
 interface CanonicalizationMethod
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。

实现 Transform 的 javax.xml.crypto.dsig 中的类
 class TransformService
转换算法和规范算法的服务提供者接口。

返回 Transform 的 javax.xml.crypto.dsig 中的方法
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params) 针对指定的算法 URI 和参数创建 Transform。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 Transform。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.TransformException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.TransformException
的使用

使用 TransformException 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 TransformException 的使用

抛出 TransformException 的 javax.xml.crypto.dsig 中的方法
Data | Transform.transform(Data data, XMLCryptoContext context) 使用底层转换算法对指定数据进行转换。
Data | Transform.transform(Data data, XMLCryptoContext context, OutputStream os) 使用底层转换算法对指定数据进行转换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.TransformService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.TransformService
的使用

使用 TransformService 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 TransformService 的使用

返回 TransformService 的 javax.xml.crypto.dsig 中的方法
static TransformService | TransformService.getInstance(String algorithm, String mechanismType) 返回支持指定算法 URI 的 TransformService（比如：Transform.XPATH2）和机制类型（比如：DOM）。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, Provider provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, String provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.XMLObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.XMLObject
的使用

使用 XMLObject 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 XMLObject 的使用

返回 XMLObject 的 javax.xml.crypto.dsig 中的方法
abstract  XMLObject XMLSignatureFactory.newXMLObject(List content, String id, String mimeType, String encoding)
根据指定参数创建 XMLObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.XMLSignature 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.XMLSignature
的使用

使用 XMLSignature 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 XMLSignature 的使用

返回 XMLSignature 的 javax.xml.crypto.dsig 中的方法
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki) 创建一个 XMLSignature，并使用指定的 SignedInfo 和 KeyInfo 对象的内容对其进行初始化。
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId) 创建一个 XMLSignature，并使用指定的参数对其进行初始化。
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure) 从特定于机制的 XMLStructure 实例解组新的 XMLSignature 实例。
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context) 从特定于机制的 XMLValidateContext 实例解组新的 XMLSignature 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.XMLSignature.SignatureValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.XMLSignature.SignatureValue
的使用

使用 XMLSignature.SignatureValue 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 XMLSignature.SignatureValue 的使用

返回 XMLSignature.SignatureValue 的 javax.xml.crypto.dsig 中的方法
 XMLSignature.SignatureValue XMLSignature.getSignatureValue()
返回此 XMLSignature 的签名值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.XMLSignatureException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.XMLSignatureException
的使用

使用 XMLSignatureException 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 XMLSignatureException 的使用

抛出 XMLSignatureException 的 javax.xml.crypto.dsig 中的方法
void | XMLSignature.sign(XMLSignContext signContext) 为此 XMLSignature 签名。
boolean | Reference.validate(XMLValidateContext validateContext) 验证此引用。
boolean | XMLSignature.validate(XMLValidateContext validateContext) 根据核心验证处理规则来验证签名。
boolean | XMLSignature.SignatureValue.validate(XMLValidateContext validateContext) 验证签名值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.XMLSignatureFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.XMLSignatureFactory
的使用

使用 XMLSignatureFactory 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 XMLSignatureFactory 的使用

返回 XMLSignatureFactory 的 javax.xml.crypto.dsig 中的方法
static XMLSignatureFactory | XMLSignatureFactory.getInstance() 返回支持默认的 XML 处理机制和表示形式类型（“DOM”） 的 XMLSignatureFactory。
static XMLSignatureFactory | XMLSignatureFactory.getInstance(String mechanismType) 返回 XMLSignatureFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。
static XMLSignatureFactory | XMLSignatureFactory.getInstance(String mechanismType, Provider provider) 返回支持请求的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
static XMLSignatureFactory | XMLSignatureFactory.getInstance(String mechanismType, String provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.XMLSignContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.XMLSignContext
的使用

使用 XMLSignContext 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto.dsig 中 XMLSignContext 的使用

参数类型为 XMLSignContext 的 javax.xml.crypto.dsig 中的方法
 void XMLSignature.sign(XMLSignContext signContext)
为此 XMLSignature 签名。

javax.xml.crypto.dsig.dom 中 XMLSignContext 的使用

实现 XMLSignContext 的 javax.xml.crypto.dsig.dom 中的类
 class DOMSignContext
特定于 DOM 的 XMLSignContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.XMLValidateContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.XMLValidateContext
的使用

使用 XMLValidateContext 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto.dsig 中 XMLValidateContext 的使用

参数类型为 XMLValidateContext 的 javax.xml.crypto.dsig 中的方法
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context) 从特定于机制的 XMLValidateContext 实例解组新的 XMLSignature 实例。
boolean | Reference.validate(XMLValidateContext validateContext) 验证此引用。
boolean | XMLSignature.validate(XMLValidateContext validateContext) 根据核心验证处理规则来验证签名。
boolean | XMLSignature.SignatureValue.validate(XMLValidateContext validateContext) 验证签名值。

javax.xml.crypto.dsig.dom 中 XMLValidateContext 的使用

实现 XMLValidateContext 的 javax.xml.crypto.dsig.dom 中的类
 class DOMValidateContext
特定于 DOM 的 XMLValidateContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.crypto.dsig.dom (Java 2 Platform SE 6)

 javax.xml.crypto.dsig.dom
类
DOMSignContext
DOMValidateContext


类 javax.xml.crypto.dsig.dom.DOMSignContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.dom.DOMSignContext
的使用

没有 javax.xml.crypto.dsig.dom.DOMSignContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.dom.DOMValidateContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.dom.DOMValidateContext
的使用

没有 javax.xml.crypto.dsig.dom.DOMValidateContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.crypto.dsig.keyinfo (Java 2 Platform SE 6)

 javax.xml.crypto.dsig.keyinfo
接口
KeyInfo
KeyName
KeyValue
PGPData
RetrievalMethod
X509Data
X509IssuerSerial
类
KeyInfoFactory


接口 javax.xml.crypto.dsig.keyinfo.KeyInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.KeyInfo
的使用

使用 KeyInfo 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 KeyInfo 的使用

参数类型为 KeyInfo 的 javax.xml.crypto 中的方法
abstract  KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
尝试查找满足指定约束的密钥。

javax.xml.crypto.dsig 中 KeyInfo 的使用

返回 KeyInfo 的 javax.xml.crypto.dsig 中的方法
 KeyInfo XMLSignature.getKeyInfo()
返回此 XMLSignature 的密钥信息。

参数类型为 KeyInfo 的 javax.xml.crypto.dsig 中的方法
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki) 创建一个 XMLSignature，并使用指定的 SignedInfo 和 KeyInfo 对象的内容对其进行初始化。
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId) 创建一个 XMLSignature，并使用指定的参数对其进行初始化。

javax.xml.crypto.dsig.keyinfo 中 KeyInfo 的使用

返回 KeyInfo 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract KeyInfo | KeyInfoFactory.newKeyInfo(List content) 创建包含指定的密钥信息类型列表的 KeyInfo。
abstract KeyInfo | KeyInfoFactory.newKeyInfo(List content, String id) 创建包含指定的密钥信息类型列表和可选 id 的 KeyInfo。
abstract KeyInfo | KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure) 根据特定于机制的 XMLStructure（比如：DOMStructure）实例解组新的 KeyInfo 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
的使用

使用 KeyInfoFactory 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig 中 KeyInfoFactory 的使用

返回 KeyInfoFactory 的 javax.xml.crypto.dsig 中的方法
 KeyInfoFactory XMLSignatureFactory.getKeyInfoFactory()
返回创建 KeyInfo 对象的 KeyInfoFactory。

javax.xml.crypto.dsig.keyinfo 中 KeyInfoFactory 的使用

返回 KeyInfoFactory 的 javax.xml.crypto.dsig.keyinfo 中的方法
static KeyInfoFactory | KeyInfoFactory.getInstance() 返回支持默认 XML 处理机制和表示形式类型（“DOM”） 的 KeyInfoFactory。
static KeyInfoFactory | KeyInfoFactory.getInstance(String mechanismType) 返回 KeyInfoFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。
static KeyInfoFactory | KeyInfoFactory.getInstance(String mechanismType, Provider provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。
static KeyInfoFactory | KeyInfoFactory.getInstance(String mechanismType, String provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.KeyName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.KeyName
的使用

使用 KeyName 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 KeyName 的使用

返回 KeyName 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  KeyName KeyInfoFactory.newKeyName(String name)
根据指定的名称创建 KeyName。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.KeyValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.KeyValue
的使用

使用 KeyValue 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 KeyValue 的使用

返回 KeyValue 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  KeyValue KeyInfoFactory.newKeyValue(PublicKey key)
根据指定的公钥创建 KeyValue。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.PGPData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.PGPData
的使用

使用 PGPData 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 PGPData 的使用

返回 PGPData 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract PGPData | KeyInfoFactory.newPGPData(byte[] keyId) 根据指定的 PGP 公钥标识符创建 PGPData。
abstract PGPData | KeyInfoFactory.newPGPData(byte[] keyId, byte[] keyPacket, List other) 根据指定的 PGP 公钥标识符、可选的密钥材料包和外部元素的列表，创建 PGPData。
abstract PGPData | KeyInfoFactory.newPGPData(byte[] keyPacket, List other) 根据指定的 PGP 密钥材料包和可选的外部元素列表创建 PGPData。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.RetrievalMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.RetrievalMethod
的使用

使用 RetrievalMethod 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 RetrievalMethod 的使用

返回 RetrievalMethod 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract RetrievalMethod | KeyInfoFactory.newRetrievalMethod(String uri) 根据指定的 URI 创建 RetrievalMethod。
abstract RetrievalMethod | KeyInfoFactory.newRetrievalMethod(String uri, String type, List transforms) 根据指定的参数创建 RetrievalMethod。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.X509Data 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.X509Data
的使用

使用 X509Data 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 X509Data 的使用

返回 X509Data 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  X509Data KeyInfoFactory.newX509Data(List content)
创建包含指定的 X.509 内容列表的 X509Data。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.X509IssuerSerial 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.X509IssuerSerial
的使用

使用 X509IssuerSerial 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 X509IssuerSerial 的使用

返回 X509IssuerSerial 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  X509IssuerSerial KeyInfoFactory.newX509IssuerSerial(String issuerName, BigInteger serialNumber)
根据指定的 X.500 发布方标识名和序列号创建 X509IssuerSerial。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.crypto.dsig.spec (Java 2 Platform SE 6)

 javax.xml.crypto.dsig.spec
接口
C14NMethodParameterSpec
DigestMethodParameterSpec
SignatureMethodParameterSpec
TransformParameterSpec
类
ExcC14NParameterSpec
HMACParameterSpec
XPathFilter2ParameterSpec
XPathFilterParameterSpec
XPathType
XPathType.Filter
XSLTTransformParameterSpec


接口 javax.xml.crypto.dsig.spec.C14NMethodParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
的使用

使用 C14NMethodParameterSpec 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

javax.xml.crypto.dsig 中 C14NMethodParameterSpec 的使用

参数类型为 C14NMethodParameterSpec 的 javax.xml.crypto.dsig 中的方法
abstract  CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params)
针对指定的算法 URI 和参数创建 CanonicalizationMethod。

javax.xml.crypto.dsig.spec 中 C14NMethodParameterSpec 的使用

实现 C14NMethodParameterSpec 的 javax.xml.crypto.dsig.spec 中的类
 class ExcC14NParameterSpec
W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.spec.DigestMethodParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.spec.DigestMethodParameterSpec
的使用

使用 DigestMethodParameterSpec 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 DigestMethodParameterSpec 的使用

参数类型为 DigestMethodParameterSpec 的 javax.xml.crypto.dsig 中的方法
abstract  DigestMethod XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params)
针对指定的算法 URI 和参数创建 DigestMethod。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
的使用

没有 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.HMACParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.HMACParameterSpec
的使用

没有 javax.xml.crypto.dsig.spec.HMACParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec
的使用

使用 SignatureMethodParameterSpec 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

javax.xml.crypto.dsig 中 SignatureMethodParameterSpec 的使用

参数类型为 SignatureMethodParameterSpec 的 javax.xml.crypto.dsig 中的方法
abstract  SignatureMethod XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params)
针对指定的算法 URI 和参数创建 SignatureMethod。

javax.xml.crypto.dsig.spec 中 SignatureMethodParameterSpec 的使用

实现 SignatureMethodParameterSpec 的 javax.xml.crypto.dsig.spec 中的类
 class HMACParameterSpec
XML Signature HMAC Algorithm 的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.spec.TransformParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.spec.TransformParameterSpec
的使用

使用 TransformParameterSpec 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

javax.xml.crypto.dsig 中 TransformParameterSpec 的使用

参数类型为 TransformParameterSpec 的 javax.xml.crypto.dsig 中的方法
abstract void | TransformService.init(TransformParameterSpec params) 使用指定的参数初始化此 TransformService。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params) 针对指定的算法 URI 和参数创建 Transform。

javax.xml.crypto.dsig.spec 中 TransformParameterSpec 的使用

javax.xml.crypto.dsig.spec 中 TransformParameterSpec 的子接口
 interface C14NMethodParameterSpec
CanonicalizationMethod 算法的算法参数规范。

实现 TransformParameterSpec 的 javax.xml.crypto.dsig.spec 中的类
class | ExcC14NParameterSpec W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。
class | XPathFilter2ParameterSpec W3C Recommendation XPath Filter 2.0 Transform Algorithm 的参数。
class | XPathFilterParameterSpec XPath Filtering Transform Algorithm 的参数。
class | XSLTTransformParameterSpec XSLT Transform Algorithm 的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec
的使用

没有 javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec
的使用

没有 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.XPathType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.XPathType
的使用

没有 javax.xml.crypto.dsig.spec.XPathType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.XPathType.Filter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.XPathType.Filter
的使用

使用 XPathType.Filter 的软件包
javax.xml.crypto.dsig.spec XML 数字签名的参数类。

javax.xml.crypto.dsig.spec 中 XPathType.Filter 的使用

声明为 XPathType.Filter 的 javax.xml.crypto.dsig.spec 中的字段
static XPathType.Filter | XPathType.Filter.INTERSECT 相交过滤操作。
static XPathType.Filter | XPathType.Filter.SUBTRACT 减少过滤操作。
static XPathType.Filter | XPathType.Filter.UNION 联合过滤操作。

返回 XPathType.Filter 的 javax.xml.crypto.dsig.spec 中的方法
 XPathType.Filter XPathType.getFilter()
返回过滤操作。

参数类型为 XPathType.Filter 的 javax.xml.crypto.dsig.spec 中的构造方法
XPathType(String expression, XPathType.Filter filter)
创建带有指定 XPath 表达式和过滤器的 XPathType 实例。
XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
创建带有指定 XPath 表达式、过滤器和名称空间映射表的 XPathType 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec
的使用

没有 javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.datatype (Java 2 Platform SE 6)

 javax.xml.datatype
类
DatatypeConstants
DatatypeConstants.Field
DatatypeFactory
Duration
XMLGregorianCalendar
异常
DatatypeConfigurationException


类 javax.xml.datatype.DatatypeConfigurationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.DatatypeConfigurationException
的使用

使用 DatatypeConfigurationException 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 DatatypeConfigurationException 的使用

抛出 DatatypeConfigurationException 的 javax.xml.datatype 中的方法
static DatatypeFactory | DatatypeFactory.newInstance() 获取新的 DatatypeFactory 实例。
static DatatypeFactory | DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 DatatypeFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.datatype.DatatypeConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.DatatypeConstants
的使用

没有 javax.xml.datatype.DatatypeConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.datatype.DatatypeConstants.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.DatatypeConstants.Field
的使用

使用 DatatypeConstants.Field 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 DatatypeConstants.Field 的使用

声明为 DatatypeConstants.Field 的 javax.xml.datatype 中的字段
static DatatypeConstants.Field | DatatypeConstants.DAYS 表示日字段的常量。
static DatatypeConstants.Field | DatatypeConstants.HOURS 表示小时字段的常量。
static DatatypeConstants.Field | DatatypeConstants.MINUTES 表示分钟字段的常量。
static DatatypeConstants.Field | DatatypeConstants.MONTHS 表示月字段的常量。
static DatatypeConstants.Field | DatatypeConstants.SECONDS 表示秒字段的常量。
static DatatypeConstants.Field | DatatypeConstants.YEARS 表示年字段的常量。

参数类型为 DatatypeConstants.Field 的 javax.xml.datatype 中的方法
abstract Number | Duration.getField(DatatypeConstants.Field field) 获取字段的值。
abstract boolean | Duration.isSet(DatatypeConstants.Field field) 检查是否设置了字段。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.datatype.DatatypeFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.DatatypeFactory
的使用

使用 DatatypeFactory 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 DatatypeFactory 的使用

返回 DatatypeFactory 的 javax.xml.datatype 中的方法
static DatatypeFactory | DatatypeFactory.newInstance() 获取新的 DatatypeFactory 实例。
static DatatypeFactory | DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 DatatypeFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.datatype.Duration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.Duration
的使用

使用 Duration 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 Duration 的使用

返回 Duration 的 javax.xml.datatype 中的方法
abstract Duration | Duration.add(Duration rhs) 计算值为 this+rhs 的新持续时间。
abstract Duration | Duration.multiply(BigDecimal factor) 计算新的持续时间，其值是此持续时间值的 factor 倍。
Duration | Duration.multiply(int factor) 计算新的持续时间，值为此持续时间值的 factor 倍。
abstract Duration | Duration.negate() 返回值为 -this 的新 Duration 对象。
abstract Duration | DatatypeFactory.newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds) 获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
Duration | DatatypeFactory.newDuration(boolean isPositive, int years, int months, int days, int hours, int minutes, int seconds) 获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
abstract Duration | DatatypeFactory.newDuration(long durationInMilliSeconds) 获取新的 Duration 实例，它将 Duration 指定为毫秒。
abstract Duration | DatatypeFactory.newDuration(String lexicalRepresentation) 获取新的 Duration 实例，它根据 XML 模式 1.0 第 3.2.6.1 节中的定义将 Duration 指定为其字符串表示形式 "PnYnMnDTnHnMnS"。
Duration | DatatypeFactory.newDurationDayTime(boolean isPositive, BigInteger day, BigInteger hour, BigInteger minute, BigInteger second) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | DatatypeFactory.newDurationDayTime(boolean isPositive, int day, int hour, int minute, int second) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | DatatypeFactory.newDurationDayTime(long durationInMilliseconds) 使用 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中定义的指定毫秒创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | DatatypeFactory.newDurationDayTime(String lexicalRepresentation) 通过解析其 String 表示形式 "PnDTnHnMnS"（XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration）创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | DatatypeFactory.newDurationYearMonth(boolean isPositive, BigInteger year, BigInteger month) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
Duration | DatatypeFactory.newDurationYearMonth(boolean isPositive, int year, int month) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
Duration | DatatypeFactory.newDurationYearMonth(long durationInMilliseconds) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定毫秒创建类型为 xdt:yearMonthDuration 的 Duration。
Duration | DatatypeFactory.newDurationYearMonth(String lexicalRepresentation) 通过解析其 String 表示形式 "PnYnM"（XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration）创建类型为 xdt:yearMonthDuration 的 Duration。
abstract Duration | Duration.normalizeWith(Calendar startTimeInstant) 通过使用特定的时间点作为参考点，将 years 和 months 字段转换为 days 字段。
Duration | Duration.subtract(Duration rhs) 计算值为 this-rhs 的新持续时间。

参数类型为 Duration 的 javax.xml.datatype 中的方法
abstract Duration | Duration.add(Duration rhs) 计算值为 this+rhs 的新持续时间。
abstract void | XMLGregorianCalendar.add(Duration duration) 将 duration 添加到此实例。
abstract int | Duration.compare(Duration duration) 与此 Duration 实例的部分顺序关系比较。
boolean | Duration.isLongerThan(Duration duration) 检查此持续时间对象是否严格长于另一个 Duration 对象。
boolean | Duration.isShorterThan(Duration duration) 检查此持续时间对象是否严格短于另一个 Duration 对象。
Duration | Duration.subtract(Duration rhs) 计算值为 this-rhs 的新持续时间。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.datatype.XMLGregorianCalendar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.XMLGregorianCalendar
的使用

使用 XMLGregorianCalendar 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 XMLGregorianCalendar 的使用

返回 XMLGregorianCalendar 的 javax.xml.datatype 中的方法
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar() 创建新的 XMLGregorianCalendar 实例。
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone) W3C XML 模式 1.0 推荐考虑完整值空间的构造方法，该方法用于 xsd:dateTime 和相关的内置数据类型。
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(GregorianCalendar cal) 根据 GregorianCalendar 创建 XMLGregorianCalendar。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(int year, int month, int day, int hour, int minute, int second, int millisecond, int timezone) java.util.GregorianCalendar 实例需要转换为 XMLGregorianCalendar 实例的值空间的构造方法。
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation) 通过将字符串解析为词汇表示形式，创建新的 XMLGregorianCalendar。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendarDate(int year, int month, int day, int timezone) 创建 XML 模式内置数据类型 date 或 g* 的 Java 表示形式。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int milliseconds, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
abstract XMLGregorianCalendar | XMLGregorianCalendar.normalize() 将此实例标准化为 UTC。

参数类型为 XMLGregorianCalendar 的 javax.xml.datatype 中的方法
abstract int | XMLGregorianCalendar.compare(XMLGregorianCalendar xmlGregorianCalendar) 根据 W3C XML 模式 1.0 第二部分 3.2.7.3 小节 Order relation on dateTime 中定义的部分顺序关系，比较 W3C XML 模式 1.0 日期/时间数据类型的两个实例。
abstract GregorianCalendar | XMLGregorianCalendar.toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults) 将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.namespace (Java 2 Platform SE 6)

 javax.xml.namespace
接口
NamespaceContext
类
QName


接口 javax.xml.namespace.NamespaceContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.namespace.NamespaceContext
的使用

使用 NamespaceContext 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.bind 中 NamespaceContext 的使用

参数类型为 NamespaceContext 的 javax.xml.bind 中的方法
static QName | DatatypeConverter.parseQName(String lexicalXSDQName, NamespaceContext nsc) 将字符串参数转换为一个 byte 值。
QName | DatatypeConverterInterface.parseQName(String lexicalXSDQName, NamespaceContext nsc) 将字符串参数转换为一个 QName 值。
static String | DatatypeConverter.printQName(QName val, NamespaceContext nsc) 将 QName 实例转换为一个字符串。
String | DatatypeConverterInterface.printQName(QName val, NamespaceContext nsc) 将 QName 实例转换为一个字符串。

javax.xml.stream 中 NamespaceContext 的使用

返回 NamespaceContext 的 javax.xml.stream 中的方法
NamespaceContext | XMLEventWriter.getNamespaceContext() 返回当前名称空间上下文。
NamespaceContext | XMLStreamReader.getNamespaceContext() 返回当前位置的只读名称空间上下文。
NamespaceContext | XMLStreamWriter.getNamespaceContext() 返回当前名称空间上下文。

参数类型为 NamespaceContext 的 javax.xml.stream 中的方法
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context) 创建一个新 StartElement。
void | XMLEventWriter.setNamespaceContext(NamespaceContext context) 设置前缀的当前名称空间上下文和 URI 绑定。
void | XMLStreamWriter.setNamespaceContext(NamespaceContext context) 设置前缀和 URI 绑定的当前名称空间上下文。

javax.xml.stream.events 中 NamespaceContext 的使用

返回 NamespaceContext 的 javax.xml.stream.events 中的方法
 NamespaceContext StartElement.getNamespaceContext()
获取只读名称空间上下文。

javax.xml.stream.util 中 NamespaceContext 的使用

返回 NamespaceContext 的 javax.xml.stream.util 中的方法
 NamespaceContext StreamReaderDelegate.getNamespaceContext()

javax.xml.xpath 中 NamespaceContext 的使用

返回 NamespaceContext 的 javax.xml.xpath 中的方法
 NamespaceContext XPath.getNamespaceContext()
返回当前的名称空间上下文。

参数类型为 NamespaceContext 的 javax.xml.xpath 中的方法
 void XPath.setNamespaceContext(NamespaceContext nsContext)
建立名称空间上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.namespace.QName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.namespace.QName
的使用

使用 QName 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.namespace | XML 名称空间处理。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.bind 中 QName 的使用

声明为 QName 的 javax.xml.bind 中的字段
protected  QName JAXBElement.name
xml 元素标记名称。

返回 QName 的 javax.xml.bind 中的方法
abstract QName | JAXBIntrospector.getElementName(Object jaxbElement) 获取 jaxbElement 的 xml 元素 qname。
QName | JAXBElement.getName() 返回 xml 元素标记名称。
static QName | DatatypeConverter.parseQName(String lexicalXSDQName, NamespaceContext nsc) 将字符串参数转换为一个 byte 值。
QName | DatatypeConverterInterface.parseQName(String lexicalXSDQName, NamespaceContext nsc) 将字符串参数转换为一个 QName 值。

参数类型为 QName 的 javax.xml.bind 中的方法
static String | DatatypeConverter.printQName(QName val, NamespaceContext nsc) 将 QName 实例转换为一个字符串。
String | DatatypeConverterInterface.printQName(QName val, NamespaceContext nsc) 将 QName 实例转换为一个字符串。

参数类型为 QName 的 javax.xml.bind 中的构造方法
JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
构造一个 xml 元素实例。
JAXBElement(QName name, Class<T> declaredType, T value)
构造一个 xml 元素实例。

javax.xml.datatype 中 QName 的使用

声明为 QName 的 javax.xml.datatype 中的字段
static QName | DatatypeConstants.DATE W3C XML 模式 1.0 数据类型 date 的完全限定名称。
static QName | DatatypeConstants.DATETIME W3C XML 模式 1.0 数据类型 dateTime 的完全限定名称。
static QName | DatatypeConstants.DURATION W3C XML 模式数据类型 duration 的完全限定名称。
static QName | DatatypeConstants.DURATION_DAYTIME XQuery 1.0 和 Path 2.0 数据类型 dayTimeDuration 的完全限定名称。
static QName | DatatypeConstants.DURATION_YEARMONTH XQuery 1.0 和 XPath 2.0 数据类型 yearMonthDuration 的完全限定名称。
static QName | DatatypeConstants.GDAY W3C XML 模式 1.0 数据类型 gDay 的完全限定名称。
static QName | DatatypeConstants.GMONTH W3C XML 模式 1.0 数据类型 gMonth 的完全限定名称。
static QName | DatatypeConstants.GMONTHDAY W3C XML 模式 1.0 数据类型 gMonthDay 的完全限定名称。
static QName | DatatypeConstants.GYEAR W3C XML 模式 1.0 数据类型 gYear 的完全限定名称。
static QName | DatatypeConstants.GYEARMONTH W3C XML 模式 1.0 数据类型 gYearMonth 的完全限定名称。
static QName | DatatypeConstants.TIME W3C XML 模式 1.0 数据类型 time 的完全限定名称。

返回 QName 的 javax.xml.datatype 中的方法
QName | Duration.getXMLSchemaType() 返回此实例映射到的 XML 模式日期/时间类型的名称。
abstract QName | XMLGregorianCalendar.getXMLSchemaType() 返回此实例映射到的 XML 模式日期/时间类型的名称。

javax.xml.namespace 中 QName 的使用

返回 QName 的 javax.xml.namespace 中的方法
static QName QName.valueOf(String qNameAsString)
从解析格式化 String 中派生的 QName。

javax.xml.soap 中 QName 的使用

声明为 QName 的 javax.xml.soap 中的字段
static QName | SOAPConstants.SOAP_DATAENCODINGUNKNOWN_FAULT SOAP 1.2 DataEncodingUnknown 错误。
static QName | SOAPConstants.SOAP_MUSTUNDERSTAND_FAULT SOAP 1.2 MustUnderstand 错误。
static QName | SOAPConstants.SOAP_RECEIVER_FAULT SOAP 1.2 Receiver 错误。
static QName | SOAPConstants.SOAP_SENDER_FAULT SOAP 1.2 Sender 错误。
static QName | SOAPConstants.SOAP_VERSIONMISMATCH_FAULT SOAP 1.2 VersionMismatch 错误。

返回 QName 的 javax.xml.soap 中的方法
QName | SOAPElement.createQName(String localName, String prefix) 创建一个 QName，其名称空间 URI 应与此 SOAPElement 上下文中的参数、prefix 相关联。
QName | SOAPElement.getElementQName() 返回此 SOAPElement 对象的 qname。
QName | SOAPFault.getFaultCodeAsQName() 以 QName 对象形式获取此 SOAPFault 对象的错误代码。

参数类型为 QName 的 javax.xml.soap 中的方法
SOAPElement | SOAPElement.addAttribute(QName qname, String value) 将带有指定名称和值的属性添加到此 SOAPElement 对象。
SOAPBodyElement | SOAPBody.addBodyElement(QName qname) 使用指定 QName 创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
SOAPElement | SOAPElement.addChildElement(QName qname) 创建使用给定 QName 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
DetailEntry | Detail.addDetailEntry(QName qname) 使用给定 QName 创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
SOAPFault | SOAPBody.addFault(QName faultCode, String faultString) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(QName faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPHeaderElement | SOAPHeader.addHeaderElement(QName qname) 创建使用指定 qname 初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addNotUnderstoodHeaderElement(QName name) 创建使用指定名称初始化的新的 NotUnderstood SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
void | SOAPFault.appendFaultSubcode(QName subcode) 将 Subcode 添加到此 SOAPFault 包含的 Subcode 序列的末尾。
SOAPElement | SOAPFactory.createElement(QName qname) 创建使用给定 QName 对象初始化的 SOAPElement 对象。
abstract SOAPFault | SOAPFactory.createFault(String reasonText, QName faultCode) 创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象
String | SOAPElement.getAttributeValue(QName qname) 返回带有指定 qname 的属性值。
Iterator | SOAPElement.getChildElements(QName qname) 返回可在带有指定 qname 的此元素所有直接子 Node 上进行迭代的 Iterator。
boolean | SOAPElement.removeAttribute(QName qname) 移除带有指定 qname 的属性。
SOAPElement | SOAPElement.setElementQName(QName newName) 如果可能，将此 Element 的名称更改为 newName。
void | SOAPFault.setFaultCode(QName faultCodeQName) 使用给定的错误代码设置此 SOAPFault 对象。

javax.xml.stream 中 QName 的使用

返回 QName 的 javax.xml.stream 中的方法
QName | XMLStreamReader.getAttributeName(int index) 返回所提供索引处的属性的 qname
QName | XMLStreamReader.getName() 返回当前 START_ELEMENT 或 END_ELEMENT 事件的 QName

参数类型为 QName 的 javax.xml.stream 中的方法
abstract Attribute | XMLEventFactory.createAttribute(QName name, String value) 创建一个新 Attribute。
abstract EndElement | XMLEventFactory.createEndElement(QName name, Iterator namespaces) 创建一个新 EndElement。
abstract StartElement | XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。

javax.xml.stream.events 中 QName 的使用

返回 QName 的 javax.xml.stream.events 中的方法
QName | Attribute.getName() 返回此属性的 QName。
QName | EndElement.getName() 获取此事件的名称
QName | StartElement.getName() 获取此事件的名称
QName | XMLEvent.getSchemaType() 提供此方法是为了提供有关关联事件的可选类型信息。

参数类型为 QName 的 javax.xml.stream.events 中的方法
 Attribute StartElement.getAttributeByName(QName name)
返回此名称引用的属性

javax.xml.stream.util 中 QName 的使用

返回 QName 的 javax.xml.stream.util 中的方法
QName | StreamReaderDelegate.getAttributeName(int index)
QName | StreamReaderDelegate.getName()

javax.xml.ws 中 QName 的使用

返回 QName 的 javax.xml.ws 中的方法
 QName Service.getServiceName()
获取此服务的名称。

返回变量类型为 QName 的类型的 javax.xml.ws 中的方法
 Iterator<QName> Service.getPorts()
返回一个 Iterator，它用于此服务所组合的服务端点的 QName 列表。

参数类型为 QName 的 javax.xml.ws 中的方法
 void Service.addPort(QName portName, String bindingId, String endpointAddress)
为服务创建新的端口。
static Service Service.create(QName serviceName)
创建 Service 实例。
static Service Service.create(URL wsdlDocumentLocation, QName serviceName)
创建 Service 实例。
<T> Dispatch<T>
Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
 Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与生成的 JAXB 对象一起使用的 Dispatch 实例。
<T> T
Service.getPort(QName portName, Class<T> serviceEndpointInterface)
getPort 方法返回 stub。

参数类型为 QName 的 javax.xml.ws 中的构造方法
Service(URL wsdlDocumentLocation, QName serviceName)

javax.xml.ws.handler 中 QName 的使用

返回 QName 的 javax.xml.ws.handler 中的方法
QName | PortInfo.getPortName() 获取正被访问的 WSDL 端口的限定名。
QName | PortInfo.getServiceName() 获取包含正被访问端口的 WSDL 服务名称的限定名。

javax.xml.ws.handler.soap 中 QName 的使用

返回变量类型为 QName 的类型的 javax.xml.ws.handler.soap 中的方法
 Set<QName> SOAPHandler.getHeaders()
获取可以由此处理程序实例处理的头块。

参数类型为 QName 的 javax.xml.ws.handler.soap 中的方法
 Object[] SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
从消息上下文的消息中获得具有特定限定名的头。

javax.xml.ws.spi 中 QName 的使用

返回 QName 的 javax.xml.ws.spi 中的方法
abstract  QName ServiceDelegate.getServiceName()
获取此服务的名称。

返回变量类型为 QName 的类型的 javax.xml.ws.spi 中的方法
abstract  Iterator<QName> ServiceDelegate.getPorts()
返回一个 Iterator，该迭代器用于根据此服务分组的服务端点的 QName 列表。

参数类型为 QName 的 javax.xml.ws.spi 中的方法
abstract  void ServiceDelegate.addPort(QName portName, String bindingId, String endpointAddress)
为服务创建新的端口。
abstract
<T> Dispatch<T>
ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
abstract  Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。
abstract  ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class serviceClass)
创建一个服务委托对象。
abstract
<T> T
ServiceDelegate.getPort(QName portName, Class<T> serviceEndpointInterface)
getPort 方法返回一个桩模块 (stub)。

javax.xml.xpath 中 QName 的使用

声明为 QName 的 javax.xml.xpath 中的字段
static QName | XPathConstants.BOOLEAN XPath 1.0 布尔值数据类型。
static QName | XPathConstants.NODE XPath 1.0 NodeSet 数据类型。
static QName | XPathConstants.NODESET XPath 1.0 NodeSet 数据类型。
static QName | XPathConstants.NUMBER XPath 1.0 数字数据类型。
static QName | XPathConstants.STRING XPath 1.0 字符串数据类型。

参数类型为 QName 的 javax.xml.xpath 中的方法
Object | XPathExpression.evaluate(InputSource source, QName returnType) 计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。
Object | XPathExpression.evaluate(Object item, QName returnType) 计算指定上下文中的 XPath 表达式并返回指定类型的结果。
Object | XPath.evaluate(String expression, InputSource source, QName returnType) 计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。
Object | XPath.evaluate(String expression, Object item, QName returnType) 计算指定上下文中的 XPath 表达式并返回指定类型的结果。
XPathFunction | XPathFunctionResolver.resolveFunction(QName functionName, int arity) 在可用的函数集中查找函数。
Object | XPathVariableResolver.resolveVariable(QName variableName) 在可用的变量集中查找变量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.parsers (Java 2 Platform SE 6)

 javax.xml.parsers
类
DocumentBuilder
DocumentBuilderFactory
SAXParser
SAXParserFactory
异常
ParserConfigurationException
错误
FactoryConfigurationError


类 javax.xml.parsers.DocumentBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.DocumentBuilder
的使用

使用 DocumentBuilder 的软件包
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.parsers | 提供允许处理 XML 文档的类。

javax.xml.bind.annotation 中 DocumentBuilder 的使用

返回 DocumentBuilder 的 javax.xml.bind.annotation 中的方法
 DocumentBuilder W3CDomHandler.getBuilder()

参数类型为 DocumentBuilder 的 javax.xml.bind.annotation 中的方法
 void W3CDomHandler.setBuilder(DocumentBuilder builder)

参数类型为 DocumentBuilder 的 javax.xml.bind.annotation 中的构造方法
W3CDomHandler(DocumentBuilder builder)
允许应用程序指定使用哪一个 DOM 实现的构造方法。

javax.xml.parsers 中 DocumentBuilder 的使用

返回 DocumentBuilder 的 javax.xml.parsers 中的方法
abstract  DocumentBuilder DocumentBuilderFactory.newDocumentBuilder()
使用当前配置的参数创建一个新的 DocumentBuilder 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.parsers.DocumentBuilderFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.DocumentBuilderFactory
的使用

使用 DocumentBuilderFactory 的软件包
javax.xml.parsers 提供允许处理 XML 文档的类。

javax.xml.parsers 中 DocumentBuilderFactory 的使用

返回 DocumentBuilderFactory 的 javax.xml.parsers 中的方法
static DocumentBuilderFactory | DocumentBuilderFactory.newInstance() 获取 DocumentBuilderFactory 的新实例。
static DocumentBuilderFactory | DocumentBuilderFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 DocumentBuilderFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.parsers.FactoryConfigurationError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.FactoryConfigurationError
的使用

没有 javax.xml.parsers.FactoryConfigurationError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.parsers.ParserConfigurationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.ParserConfigurationException
的使用

使用 ParserConfigurationException 的软件包
javax.xml.parsers 提供允许处理 XML 文档的类。

javax.xml.parsers 中 ParserConfigurationException 的使用

抛出 ParserConfigurationException 的 javax.xml.parsers 中的方法
abstract boolean | SAXParserFactory.getFeature(String name) 返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。
abstract boolean | DocumentBuilderFactory.getFeature(String name) 获取指定功能的状态。
abstract DocumentBuilder | DocumentBuilderFactory.newDocumentBuilder() 使用当前配置的参数创建一个新的 DocumentBuilder 实例。
abstract SAXParser | SAXParserFactory.newSAXParser() 使用当前配置的工厂参数创建 SAXParser 的一个新实例。
abstract void | SAXParserFactory.setFeature(String name, boolean value) 在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。
abstract void | DocumentBuilderFactory.setFeature(String name, boolean value) 设置由此工厂创建的此 DocumentBuilderFactory 和 DocumentBuilder 的功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.parsers.SAXParser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.SAXParser
的使用

使用 SAXParser 的软件包
javax.xml.parsers 提供允许处理 XML 文档的类。

javax.xml.parsers 中 SAXParser 的使用

返回 SAXParser 的 javax.xml.parsers 中的方法
abstract  SAXParser SAXParserFactory.newSAXParser()
使用当前配置的工厂参数创建 SAXParser 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.parsers.SAXParserFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.SAXParserFactory
的使用

使用 SAXParserFactory 的软件包
javax.xml.parsers 提供允许处理 XML 文档的类。

javax.xml.parsers 中 SAXParserFactory 的使用

返回 SAXParserFactory 的 javax.xml.parsers 中的方法
static SAXParserFactory | SAXParserFactory.newInstance() 获取 SAXParserFactory 的一个新实例。
static SAXParserFactory | SAXParserFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 SAXParserFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.soap (Java 2 Platform SE 6)

 javax.xml.soap
接口
Detail
DetailEntry
Name
Node
SOAPBody
SOAPBodyElement
SOAPConstants
SOAPElement
SOAPEnvelope
SOAPFault
SOAPFaultElement
SOAPHeader
SOAPHeaderElement
Text
类
AttachmentPart
MessageFactory
MimeHeader
MimeHeaders
SAAJMetaFactory
SAAJResult
SOAPConnection
SOAPConnectionFactory
SOAPElementFactory
SOAPFactory
SOAPMessage
SOAPPart
异常
SOAPException


类 javax.xml.soap.AttachmentPart 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.AttachmentPart
的使用

使用 AttachmentPart 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 AttachmentPart 的使用

返回 AttachmentPart 的 javax.xml.soap 中的方法
abstract AttachmentPart | SOAPMessage.createAttachmentPart() 创建一个新的空 AttachmentPart 对象。
AttachmentPart | SOAPMessage.createAttachmentPart(DataHandler dataHandler) 创建 AttachmentPart 对象并使用给定的 DataHandler 对象填充。
AttachmentPart | SOAPMessage.createAttachmentPart(Object content, String contentType) 创建 AttachmentPart 对象并使用指定内容类型的指定数据填充。
abstract AttachmentPart | SOAPMessage.getAttachment(SOAPElement element) 返回与此 SOAPElement 引用的附件关联的 AttachmentPart 对象，如果不存在此类附件，则返回 null。

参数类型为 AttachmentPart 的 javax.xml.soap 中的方法
abstract  void SOAPMessage.addAttachmentPart(AttachmentPart AttachmentPart)
将给定的 AttachmentPart 对象添加到此 SOAPMessage 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.Detail 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.Detail
的使用

使用 Detail 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 Detail 的使用

返回 Detail 的 javax.xml.soap 中的方法
Detail | SOAPFault.addDetail() 创建可选的 Detail 对象，并将其设置为此 SOAPFault 对象的 Detail 对象。
abstract Detail | SOAPFactory.createDetail() 创建充当 DetailEntry 对象容器的新 Detail 对象。
Detail | SOAPFault.getDetail() 返回此 SOAPFault 对象的可选 detail 元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.DetailEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.DetailEntry
的使用

使用 DetailEntry 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 DetailEntry 的使用

返回 DetailEntry 的 javax.xml.soap 中的方法
DetailEntry | Detail.addDetailEntry(Name name) 使用给定名称创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
DetailEntry | Detail.addDetailEntry(QName qname) 使用给定 QName 创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.MessageFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.MessageFactory
的使用

使用 MessageFactory 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.soap 中 MessageFactory 的使用

返回 MessageFactory 的 javax.xml.soap 中的方法
static MessageFactory | MessageFactory.newInstance() 创建新的 MessageFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
static MessageFactory | MessageFactory.newInstance(String protocol) 创建新的 MessageFactory 对象，该对象是指定实现的实例。
protected abstract MessageFactory | SAAJMetaFactory.newMessageFactory(String protocol) 创建给定 String 协议的 MessageFactory 对象。

javax.xml.ws.soap 中 MessageFactory 的使用

返回 MessageFactory 的 javax.xml.ws.soap 中的方法
 MessageFactory SOAPBinding.getMessageFactory()
获取此 SOAP 绑定使用的 SAAJ MessageFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.MimeHeader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.MimeHeader
的使用

没有 javax.xml.soap.MimeHeader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.MimeHeaders 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.MimeHeaders
的使用

使用 MimeHeaders 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 MimeHeaders 的使用

返回 MimeHeaders 的 javax.xml.soap 中的方法
abstract  MimeHeaders SOAPMessage.getMimeHeaders()
以与传输无关的方式返回此 SOAPMessage 对象所有特定于传输的 MIME 头。

参数类型为 MimeHeaders 的 javax.xml.soap 中的方法
abstract SOAPMessage | MessageFactory.createMessage(MimeHeaders headers, InputStream in) 将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
abstract Iterator | SOAPMessage.getAttachments(MimeHeaders headers) 检索所有头条目匹配指定头的 AttachmentPart 对象。
abstract void | SOAPMessage.removeAttachments(MimeHeaders headers) 移除所有头条目匹配指定头的 AttachmentPart 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.Name 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.Name
的使用

使用 Name 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 Name 的使用

返回 Name 的 javax.xml.soap 中的方法
Name | SOAPEnvelope.createName(String localName) 创建使用给定本地名称初始化的新 Name 对象。
abstract Name | SOAPFactory.createName(String localName) 创建使用给定本地名称初始化的新 Name 对象。
Name | SOAPEnvelope.createName(String localName, String prefix, String uri) 创建使用给定本地名称、名称空间前缀和名称空间 URL 初始化的新 Name 对象。
abstract Name | SOAPFactory.createName(String localName, String prefix, String uri) 创建使用给定本地名称、名称空间前缀和名称空间 URI 初始化的新 Name 对象。
Name | SOAPElement.getElementName() 返回此 SOAPElement 对象的名称。
Name | SOAPFault.getFaultCodeAsName() 以 SAAJ Name 对象形式获取此 SOAPFault 对象的强制性 SOAP 1.1 错误代码。

参数类型为 Name 的 javax.xml.soap 中的方法
 SOAPElement SOAPElement.addAttribute(Name name, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。
 SOAPBodyElement SOAPBody.addBodyElement(Name name)
使用指定名称创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
 SOAPElement SOAPElement.addChildElement(Name name)
创建使用给定 Name 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 DetailEntry Detail.addDetailEntry(Name name)
使用给定名称创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
 SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
创建使用指定名称初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPElement SOAPElementFactory.create(Name name)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换
abstract  SOAPElement SOAPFactory.createElement(Name name)
创建使用给定 Name 对象初始化的 SOAPElement 对象。
 String SOAPElement.getAttributeValue(Name name)
返回带有指定名称的属性值。
 Iterator SOAPElement.getChildElements(Name name)
返回可在带有指定名称的此元素所有直接子 Node 上进行迭代的 Iterator。
 boolean SOAPElement.removeAttribute(Name name)
移除带有指定名称的属性。
 void SOAPFault.setFaultCode(Name faultCodeQName)
使用给定的错误代码设置此 SOAPFault 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.Node 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.Node
的使用

使用 Node 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 Node 的使用

javax.xml.soap 中 Node 的子接口
interface | Detail DetailEntry 对象的容器。
interface | DetailEntry Detail 对象的内容，给出 SOAPFault 对象的详细信息。
interface | SOAPBody 表示 SOAP 消息中 SOAP 正文元素内容的对象。
interface | SOAPBodyElement 表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
interface | SOAPElement 表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。
interface | SOAPEnvelope SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
interface | SOAPFault SOAPBody 对象中的元素，包含错误和/或状态信息。
interface | SOAPFaultElement SOAPFault 对象内容的表示形式。
interface | SOAPHeader SOAP 头元素的表示形式。
interface | SOAPHeaderElement 表示 SOAP 信封 SOAP 头部分的内容的对象。
interface | Text 值为文本的节点的表示形式。

返回 Node 的 javax.xml.soap 中的方法
 Node SAAJResult.getResult()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.SAAJMetaFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SAAJMetaFactory
的使用

没有 javax.xml.soap.SAAJMetaFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.SAAJResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SAAJResult
的使用

没有 javax.xml.soap.SAAJResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPBody 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPBody
的使用

使用 SOAPBody 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPBody 的使用

返回 SOAPBody 的 javax.xml.soap 中的方法
SOAPBody | SOAPEnvelope.addBody() 创建一个 SOAPBody 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPBody 对象。
SOAPBody | SOAPEnvelope.getBody() 返回与此 SOAPEnvelope 对象关联的 SOAPBody 对象。
SOAPBody | SOAPMessage.getSOAPBody() 获取此 SOAPMessage 对象中包含的 SOAP Body。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPBodyElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPBodyElement
的使用

使用 SOAPBodyElement 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPBodyElement 的使用

javax.xml.soap 中 SOAPBodyElement 的子接口
 interface SOAPFault
SOAPBody 对象中的元素，包含错误和/或状态信息。

返回 SOAPBodyElement 的 javax.xml.soap 中的方法
SOAPBodyElement | SOAPBody.addBodyElement(Name name) 使用指定名称创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
SOAPBodyElement | SOAPBody.addBodyElement(QName qname) 使用指定 QName 创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
SOAPBodyElement | SOAPBody.addDocument(Document document) 将 DOM Document 的根节点添加到此 SOAPBody 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.SOAPConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPConnection
的使用

使用 SOAPConnection 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPConnection 的使用

返回 SOAPConnection 的 javax.xml.soap 中的方法
abstract  SOAPConnection SOAPConnectionFactory.createConnection()
创建新的 SOAPConnection。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.SOAPConnectionFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPConnectionFactory
的使用

使用 SOAPConnectionFactory 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPConnectionFactory 的使用

返回 SOAPConnectionFactory 的 javax.xml.soap 中的方法
static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
创建默认 SOAPConnectionFactory 对象的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPConstants
的使用

没有 javax.xml.soap.SOAPConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPElement
的使用

使用 SOAPElement 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPElement 的使用

javax.xml.soap 中 SOAPElement 的子接口
interface | Detail DetailEntry 对象的容器。
interface | DetailEntry Detail 对象的内容，给出 SOAPFault 对象的详细信息。
interface | SOAPBody 表示 SOAP 消息中 SOAP 正文元素内容的对象。
interface | SOAPBodyElement 表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
interface | SOAPEnvelope SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
interface | SOAPFault SOAPBody 对象中的元素，包含错误和/或状态信息。
interface | SOAPFaultElement SOAPFault 对象内容的表示形式。
interface | SOAPHeader SOAP 头元素的表示形式。
interface | SOAPHeaderElement 表示 SOAP 信封 SOAP 头部分的内容的对象。

返回 SOAPElement 的 javax.xml.soap 中的方法
 SOAPElement SOAPElement.addAttribute(Name name, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addAttribute(QName qname, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(Name name)
创建使用给定 Name 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(QName qname)
创建使用给定 QName 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(SOAPElement element)
将 SOAPElement 作为此 SOAPElement 实例的子级添加。
 SOAPElement SOAPElement.addChildElement(String localName)
创建使用指定本地名称初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(String localName, String prefix)
创建使用指定本地名称和前缀初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(String localName, String prefix, String uri)
创建使用指定本地名称、前缀和 URI 初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addNamespaceDeclaration(String prefix, String uri)
将带有指定前缀和 URI 的名称空间声明添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addTextNode(String text)
创建使用给定 String 初始化的新 Text 对象，并将其添加到此 SOAPElement 对象。
 SOAPElement SOAPElementFactory.create(Name name)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换
 SOAPElement SOAPElementFactory.create(String localName)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换
 SOAPElement SOAPElementFactory.create(String localName, String prefix, String uri)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换
 SOAPElement SOAPFactory.createElement(Element domElement)
根据现有的 DOM Element 创建 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(Name name)
创建使用给定 Name 对象初始化的 SOAPElement 对象。
 SOAPElement SOAPFactory.createElement(QName qname)
创建使用给定 QName 对象初始化的 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(String localName)
创建使用给定本地名称初始化的 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(String localName, String prefix, String uri)
使用本地名称、前缀和 URI 创建新的 SOAPElement 对象。
 SOAPElement Node.getParentElement()
返回此 Node 对象的父元素。
 SOAPElement SOAPElement.setElementQName(QName newName)
如果可能，将此 Element 的名称更改为 newName。

参数类型为 SOAPElement 的 javax.xml.soap 中的方法
SOAPElement | SOAPElement.addChildElement(SOAPElement element) 将 SOAPElement 作为此 SOAPElement 实例的子级添加。
abstract AttachmentPart | SOAPMessage.getAttachment(SOAPElement element) 返回与此 SOAPElement 引用的附件关联的 AttachmentPart 对象，如果不存在此类附件，则返回 null。
void | Node.setParentElement(SOAPElement parent) 将此 Node 对象的父节点设置为给定的 SOAPElement 对象。

参数类型为 SOAPElement 的 javax.xml.soap 中的构造方法
SAAJResult(SOAPElement rootNode)
创建一个 SAAJResult，它会将结果编写为指定 SOAPElement 的子节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.SOAPElementFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPElementFactory
的使用

使用 SOAPElementFactory 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPElementFactory 的使用

返回 SOAPElementFactory 的 javax.xml.soap 中的方法
static SOAPElementFactory SOAPElementFactory.newInstance()
已过时。 创建新的 SOAPElementFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPEnvelope 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPEnvelope
的使用

使用 SOAPEnvelope 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPEnvelope 的使用

返回 SOAPEnvelope 的 javax.xml.soap 中的方法
abstract  SOAPEnvelope SOAPPart.getEnvelope()
获取与此 SOAPPart 对象关联的 SOAPEnvelope 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.SOAPException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPException
的使用

使用 SOAPException 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPException 的使用

抛出 SOAPException 的 javax.xml.soap 中的方法
 SOAPElement SOAPElement.addAttribute(Name name, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addAttribute(QName qname, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。
 SOAPBody SOAPEnvelope.addBody()
创建一个 SOAPBody 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPBody 对象。
 SOAPBodyElement SOAPBody.addBodyElement(Name name)
使用指定名称创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
 SOAPBodyElement SOAPBody.addBodyElement(QName qname)
使用指定 QName 创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
 SOAPElement SOAPElement.addChildElement(Name name)
创建使用给定 Name 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(QName qname)
创建使用给定 QName 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(SOAPElement element)
将 SOAPElement 作为此 SOAPElement 实例的子级添加。
 SOAPElement SOAPElement.addChildElement(String localName)
创建使用指定本地名称初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(String localName, String prefix)
创建使用指定本地名称和前缀初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(String localName, String prefix, String uri)
创建使用指定本地名称、前缀和 URI 初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 Detail SOAPFault.addDetail()
创建可选的 Detail 对象，并将其设置为此 SOAPFault 对象的 Detail 对象。
 DetailEntry Detail.addDetailEntry(Name name)
使用给定名称创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
 DetailEntry Detail.addDetailEntry(QName qname)
使用给定 QName 创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
 SOAPBodyElement SOAPBody.addDocument(Document document)
将 DOM Document 的根节点添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault()
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault(QName faultCode, String faultString)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 void SOAPFault.addFaultReasonText(String text, Locale locale)
追加或替换包含指定文本消息的 Reason Text 项，以及从 locale 派生的 xml:lang。
 SOAPHeader SOAPEnvelope.addHeader()
创建一个 SOAPHeader 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPHeader 对象。
 SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
创建使用指定名称初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPHeaderElement SOAPHeader.addHeaderElement(QName qname)
创建使用指定 qname 初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPElement SOAPElement.addNamespaceDeclaration(String prefix, String uri)
将带有指定前缀和 URI 的名称空间声明添加到此 SOAPElement 对象。
 SOAPHeaderElement SOAPHeader.addNotUnderstoodHeaderElement(QName name)
创建使用指定名称初始化的新的 NotUnderstood SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPElement SOAPElement.addTextNode(String text)
创建使用给定 String 初始化的新 Text 对象，并将其添加到此 SOAPElement 对象。
 SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs)
创建使用指定的 SOAP URI 支持列表初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri)
创建使用指定受支持 SOAP URI 初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris)
创建使用指定 SOAP URI 支持数组初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 void SOAPFault.appendFaultSubcode(QName subcode)
将 Subcode 添加到此 SOAPFault 包含的 Subcode 序列的末尾。
abstract  SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
将给定消息发送到指定端点，在返回应答前将一直阻塞。
abstract  void SOAPConnection.close()
关闭此 SOAPConnection 对象。
 SOAPElement SOAPElementFactory.create(Name name)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换
 SOAPElement SOAPElementFactory.create(String localName)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换
 SOAPElement SOAPElementFactory.create(String localName, String prefix, String uri)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换
abstract  SOAPConnection SOAPConnectionFactory.createConnection()
创建新的 SOAPConnection。
abstract  Detail SOAPFactory.createDetail()
创建充当 DetailEntry 对象容器的新 Detail 对象。
 SOAPElement SOAPFactory.createElement(Element domElement)
根据现有的 DOM Element 创建 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(Name name)
创建使用给定 Name 对象初始化的 SOAPElement 对象。
 SOAPElement SOAPFactory.createElement(QName qname)
创建使用给定 QName 对象初始化的 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(String localName)
创建使用给定本地名称初始化的 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(String localName, String prefix, String uri)
使用本地名称、前缀和 URI 创建新的 SOAPElement 对象。
abstract  SOAPFault SOAPFactory.createFault()
创建一个新的默认 SOAPFault 对象
abstract  SOAPFault SOAPFactory.createFault(String reasonText, QName faultCode)
创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象
abstract  SOAPMessage MessageFactory.createMessage()
使用默认的 SOAPPart、SOAPEnvelope、SOAPBody 和 SOAPHeader 对象创建新的 SOAPMessage 对象。
abstract  SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
 Name SOAPEnvelope.createName(String localName)
创建使用给定本地名称初始化的新 Name 对象。
abstract  Name SOAPFactory.createName(String localName)
创建使用给定本地名称初始化的新 Name 对象。
 Name SOAPEnvelope.createName(String localName, String prefix, String uri)
创建使用给定本地名称、名称空间前缀和名称空间 URL 初始化的新 Name 对象。
abstract  Name SOAPFactory.createName(String localName, String prefix, String uri)
创建使用给定本地名称、名称空间前缀和名称空间 URI 初始化的新 Name 对象。
 QName SOAPElement.createQName(String localName, String prefix)
创建一个 QName，其名称空间 URI 应与此 SOAPElement 上下文中的参数、prefix 相关联。
 Document SOAPBody.extractContentAsDocument()
创建新的 DOM Document，并将此 SOAPBody 的第一个子元素设置为它的文档元素。
 SOAPMessage SOAPConnection.get(Object to)
从特定端点获取消息，在收到消息前将一直阻塞。
abstract  AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
返回与此 SOAPElement 引用的附件关联的 AttachmentPart 对象，如果不存在此类附件，则返回 null。
abstract  InputStream AttachmentPart.getBase64Content()
以 Base64 编码字符数据的形式返回可用于获取 AttachmentPart 内容的 InputStream，此方法将对附件的原始字节进行 Base64 编码，然后返回该内容。
 SOAPBody SOAPEnvelope.getBody()
返回与此 SOAPEnvelope 对象关联的 SOAPBody 对象。
abstract  Object AttachmentPart.getContent()
以 Java 对象的形式获取此 AttachmentPart 对象的内容。
abstract  Source SOAPPart.getContent()
以 JAXP Source 对象的形式返回 SOAPEnvelope 的内容。
abstract  DataHandler AttachmentPart.getDataHandler()
获取针对此 AttachmentPart 对象的 DataHandler 对象。
abstract  SOAPEnvelope SOAPPart.getEnvelope()
获取与此 SOAPPart 对象关联的 SOAPEnvelope 对象。
 Iterator SOAPFault.getFaultReasonLocales()
返回一个 Iterator，它可以在与 Reason Text 项关联的 Locale 独特序列上进行迭代。
 String SOAPFault.getFaultReasonText(Locale locale)
返回与给定 Locale 关联的 Reason Text。
 Iterator SOAPFault.getFaultReasonTexts()
返回一个 Iterator，它可以在包含此 SOAPFault 所有 Reason Text 项的 String 对象序列上进行迭代。
 SOAPHeader SOAPEnvelope.getHeader()
返回此 SOAPEnvelope 对象的 SOAPHeader 对象。
 Object SOAPMessage.getProperty(String property)
检索指定属性的值。
abstract  InputStream AttachmentPart.getRawContent()
以 InputStream 的形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。
abstract  byte[] AttachmentPart.getRawContentBytes()
以 byte[] 数组形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。
abstract  int AttachmentPart.getSize()
返回此 AttachmentPart 对象中的字节数。
 SOAPBody SOAPMessage.getSOAPBody()
获取此 SOAPMessage 对象中包含的 SOAP Body。
 SOAPHeader SOAPMessage.getSOAPHeader()
获取此 SOAPMessage 对象中包含的 SOAP Header。
static MessageFactory MessageFactory.newInstance()
创建新的 MessageFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
创建默认 SOAPConnectionFactory 对象的实例。
static SOAPElementFactory SOAPElementFactory.newInstance()
已过时。 创建新的 SOAPElementFactory 实例。
static SOAPFactory SOAPFactory.newInstance()
创建新的 SOAPFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
static MessageFactory MessageFactory.newInstance(String protocol)
创建新的 MessageFactory 对象，该对象是指定实现的实例。
static SOAPFactory SOAPFactory.newInstance(String protocol)
创建新的 SOAPFactory 对象，该对象是指定实现的实例，此方法使用 SAAJMetaFactory 来定位实现类并创建 SOAPFactory 实例。
protected abstract  MessageFactory SAAJMetaFactory.newMessageFactory(String protocol)
创建给定 String 协议的 MessageFactory 对象。
protected abstract  SOAPFactory SAAJMetaFactory.newSOAPFactory(String protocol)
创建给定 String 协议的 SOAPFactory 对象。
abstract  void SOAPMessage.saveChanges()
使用对其所作的所有更改更新此 SOAPMessage 对象。
abstract  void AttachmentPart.setBase64Content(InputStream content, String contentType)
根据 Base64 源 InputStream 设置此附件部分的内容，并将 Content-Type 头的值设置为 contentType 中包含的值，此方法将首先对 base64 输入流进行解码，然后将得到的原始字节写入附件。
abstract  void SOAPPart.setContent(Source source)
使用取自给定 Source 对象的数据设置 SOAPEnvelope 对象的内容。
 SOAPElement SOAPElement.setElementQName(QName newName)
如果可能，将此 Element 的名称更改为 newName。
 void SOAPElement.setEncodingStyle(String encodingStyle)
将此 SOAPElement 对象的编码样式设置为指定样式。
 void SOAPFault.setFaultActor(String faultActor)
使用给定的错误参与者 (actor) 设置此 SOAPFault 对象。
 void SOAPFault.setFaultCode(Name faultCodeQName)
使用给定的错误代码设置此 SOAPFault 对象。
 void SOAPFault.setFaultCode(QName faultCodeQName)
使用给定的错误代码设置此 SOAPFault 对象。
 void SOAPFault.setFaultCode(String faultCode)
使用给定的错误代码设置此 SOAPFault 对象。
 void SOAPFault.setFaultNode(String uri)
创建或替换此 SOAPFault 对象的任何现有 Node 元素。
 void SOAPFault.setFaultRole(String uri)
创建或替换此 SOAPFault 对象的任何现有 Role 元素。
 void SOAPFault.setFaultString(String faultString)
将此 SOAPFault 对象的错误字符串设定为给定字符串。
 void SOAPFault.setFaultString(String faultString, Locale locale)
将此 SOAPFault 对象的错误字符串设定为给定字符串，并本地化为给定语言环境。
 void Node.setParentElement(SOAPElement parent)
将此 Node 对象的父节点设置为给定的 SOAPElement 对象。
 void SOAPMessage.setProperty(String property, Object value)
将指定值与指定属性关联。
abstract  void AttachmentPart.setRawContent(InputStream content, String contentType)
将此附件部分的内容设置为 InputStream content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。
abstract  void AttachmentPart.setRawContentBytes(byte[] content, int offset, int len, String contentType)
将此附件部分的内容设置为 byte[] 数组 content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。
 void SOAPHeaderElement.setRelay(boolean relay)
将此 SOAPHeaderElement 的 relay 属性设置为 true 或 false。
 void SOAPHeaderElement.setRole(String uri)
将与此 SOAPHeaderElement 对象关联的 Role 设置为指定 Role。
abstract  void SOAPMessage.writeTo(OutputStream out)
将此 SOAPMessage 对象写入给定输出流。

抛出 SOAPException 的 javax.xml.soap 中的构造方法
SAAJResult()
创建一个 SAAJResult，此类将以支持默认 (SOAP 1.1) 协议的 SAAJ 树的形式显示结果。
SAAJResult(String protocol)
创建一个 SAAJResult，它将以支持指定协议的 SAAJ 树的形式显示结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.SOAPFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPFactory
的使用

使用 SOAPFactory 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.soap 中 SOAPFactory 的使用

返回 SOAPFactory 的 javax.xml.soap 中的方法
static SOAPFactory | SOAPFactory.newInstance() 创建新的 SOAPFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
static SOAPFactory | SOAPFactory.newInstance(String protocol) 创建新的 SOAPFactory 对象，该对象是指定实现的实例，此方法使用 SAAJMetaFactory 来定位实现类并创建 SOAPFactory 实例。
protected abstract SOAPFactory | SAAJMetaFactory.newSOAPFactory(String protocol) 创建给定 String 协议的 SOAPFactory 对象。

javax.xml.ws.soap 中 SOAPFactory 的使用

返回 SOAPFactory 的 javax.xml.ws.soap 中的方法
 SOAPFactory SOAPBinding.getSOAPFactory()
获取此 SOAP 绑定使用的 SAAJ SOAPFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPFault 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPFault
的使用

使用 SOAPFault 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.soap 中 SOAPFault 的使用

返回 SOAPFault 的 javax.xml.soap 中的方法
SOAPFault | SOAPBody.addFault() 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(Name faultCode, String faultString) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(Name faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(QName faultCode, String faultString) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(QName faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
abstract SOAPFault | SOAPFactory.createFault() 创建一个新的默认 SOAPFault 对象
abstract SOAPFault | SOAPFactory.createFault(String reasonText, QName faultCode) 创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象
SOAPFault | SOAPBody.getFault() 返回此 SOAPBody 对象中的 SOAPFault 对象。

javax.xml.ws.soap 中 SOAPFault 的使用

返回 SOAPFault 的 javax.xml.ws.soap 中的方法
 SOAPFault SOAPFaultException.getFault()
获取嵌入的 SOAPFault 实例。

参数类型为 SOAPFault 的 javax.xml.ws.soap 中的构造方法
SOAPFaultException(SOAPFault fault)
SOAPFaultException 的构造方法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPFaultElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPFaultElement
的使用

使用 SOAPFaultElement 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPFaultElement 的使用

javax.xml.soap 中 SOAPFaultElement 的子接口
 interface Detail
DetailEntry 对象的容器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPHeader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPHeader
的使用

使用 SOAPHeader 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPHeader 的使用

返回 SOAPHeader 的 javax.xml.soap 中的方法
SOAPHeader | SOAPEnvelope.addHeader() 创建一个 SOAPHeader 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPHeader 对象。
SOAPHeader | SOAPEnvelope.getHeader() 返回此 SOAPEnvelope 对象的 SOAPHeader 对象。
SOAPHeader | SOAPMessage.getSOAPHeader() 获取此 SOAPMessage 对象中包含的 SOAP Header。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPHeaderElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPHeaderElement
的使用

使用 SOAPHeaderElement 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPHeaderElement 的使用

返回 SOAPHeaderElement 的 javax.xml.soap 中的方法
SOAPHeaderElement | SOAPHeader.addHeaderElement(Name name) 创建使用指定名称初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addHeaderElement(QName qname) 创建使用指定 qname 初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addNotUnderstoodHeaderElement(QName name) 创建使用指定名称初始化的新的 NotUnderstood SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs) 创建使用指定的 SOAP URI 支持列表初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri) 创建使用指定受支持 SOAP URI 初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris) 创建使用指定 SOAP URI 支持数组初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.SOAPMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPMessage
的使用

使用 SOAPMessage 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。

javax.xml.soap 中 SOAPMessage 的使用

返回 SOAPMessage 的 javax.xml.soap 中的方法
abstract SOAPMessage | SOAPConnection.call(SOAPMessage request, Object to) 将给定消息发送到指定端点，在返回应答前将一直阻塞。
abstract SOAPMessage | MessageFactory.createMessage() 使用默认的 SOAPPart、SOAPEnvelope、SOAPBody 和 SOAPHeader 对象创建新的 SOAPMessage 对象。
abstract SOAPMessage | MessageFactory.createMessage(MimeHeaders headers, InputStream in) 将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
SOAPMessage | SOAPConnection.get(Object to) 从特定端点获取消息，在收到消息前将一直阻塞。

参数类型为 SOAPMessage 的 javax.xml.soap 中的方法
abstract  SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
将给定消息发送到指定端点，在返回应答前将一直阻塞。

参数类型为 SOAPMessage 的 javax.xml.soap 中的构造方法
SAAJResult(SOAPMessage message)
创建一个 SAAJResult，它会将结果写入提供的 SOAPMessage 的 SOAPPart 中。

javax.xml.ws.handler.soap 中 SOAPMessage 的使用

返回 SOAPMessage 的 javax.xml.ws.handler.soap 中的方法
 SOAPMessage SOAPMessageContext.getMessage()
从此消息上下文中获取 SOAPMessage。

参数类型为 SOAPMessage 的 javax.xml.ws.handler.soap 中的方法
 void SOAPMessageContext.setMessage(SOAPMessage message)
在此消息上下文中设置 SOAPMessage。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.soap.SOAPPart 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPPart
的使用

使用 SOAPPart 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPPart 的使用

返回 SOAPPart 的 javax.xml.soap 中的方法
abstract  SOAPPart SOAPMessage.getSOAPPart()
获取此 SOAPMessage 对象的 SOAP 部分。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.soap.Text 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.Text
的使用

没有 javax.xml.soap.Text 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.stream (Java 2 Platform SE 6)

 javax.xml.stream
接口
EventFilter
Location
StreamFilter
XMLEventReader
XMLEventWriter
XMLReporter
XMLResolver
XMLStreamConstants
XMLStreamReader
XMLStreamWriter
类
XMLEventFactory
XMLInputFactory
XMLOutputFactory
异常
XMLStreamException
错误
FactoryConfigurationError


接口 javax.xml.stream.EventFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.EventFilter
的使用

使用 EventFilter 的软件包
javax.xml.stream

javax.xml.stream 中 EventFilter 的使用

参数类型为 EventFilter 的 javax.xml.stream 中的方法
abstract  XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
创建过滤的事件 reader，它用过滤器包装事件 reader。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.stream.FactoryConfigurationError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.FactoryConfigurationError
的使用

使用 FactoryConfigurationError 的软件包
javax.xml.stream

javax.xml.stream 中 FactoryConfigurationError 的使用

抛出 FactoryConfigurationError 的 javax.xml.stream 中的方法
static XMLEventFactory | XMLEventFactory.newInstance() 创建一个新的工厂实例。
static XMLInputFactory | XMLInputFactory.newInstance() 创建一个新的工厂实例。
static XMLOutputFactory | XMLOutputFactory.newInstance() 创建一个新的工厂实例。
static XMLEventFactory | XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
static XMLInputFactory | XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
static XMLInputFactory | XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个的新工厂实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.Location 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.Location
的使用

使用 Location 的软件包
javax.xml.stream
javax.xml.stream.events
javax.xml.stream.util

javax.xml.stream 中 Location 的使用

声明为 Location 的 javax.xml.stream 中的字段
protected  Location XMLStreamException.location

返回 Location 的 javax.xml.stream 中的方法
Location | XMLStreamException.getLocation() 获取异常的位置
Location | XMLStreamReader.getLocation() 返回处理器的当前位置。

参数类型为 Location 的 javax.xml.stream 中的方法
void | XMLReporter.report(String message, String errorType, Object relatedInformation, Location location) 以特定于应用程序的格式报告所需消息。
abstract void | XMLEventFactory.setLocation(Location location) 此方法允许对此工厂创建的每个事件设置 Location。

参数类型为 Location 的 javax.xml.stream 中的构造方法
XMLStreamException(String msg, Location location)
构造具有关联消息、异常和位置的异常。
XMLStreamException(String msg, Location location, Throwable th)
构造具有关联消息、异常和位置的异常。

javax.xml.stream.events 中 Location 的使用

返回 Location 的 javax.xml.stream.events 中的方法
 Location XMLEvent.getLocation()
返回此事件的位置。

javax.xml.stream.util 中 Location 的使用

返回 Location 的 javax.xml.stream.util 中的方法
 Location StreamReaderDelegate.getLocation()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.StreamFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.StreamFilter
的使用

使用 StreamFilter 的软件包
javax.xml.stream

javax.xml.stream 中 StreamFilter 的使用

参数类型为 StreamFilter 的 javax.xml.stream 中的方法
abstract  XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
创建过滤的 reader，它用过滤器包装 reader。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.stream.XMLEventFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.XMLEventFactory
的使用

使用 XMLEventFactory 的软件包
javax.xml.stream

javax.xml.stream 中 XMLEventFactory 的使用

返回 XMLEventFactory 的 javax.xml.stream 中的方法
static XMLEventFactory | XMLEventFactory.newInstance() 创建一个新的工厂实例。
static XMLEventFactory | XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.XMLEventReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLEventReader
的使用

使用 XMLEventReader 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.stream.util |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.bind 中 XMLEventReader 的使用

参数类型为 XMLEventReader 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(XMLEventReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

javax.xml.bind.helpers 中 XMLEventReader 的使用

参数类型为 XMLEventReader 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)

javax.xml.stream 中 XMLEventReader 的使用

返回 XMLEventReader 的 javax.xml.stream 中的方法
abstract XMLEventReader | XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter) 创建过滤的事件 reader，它用过滤器包装事件 reader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(InputStream stream) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(InputStream stream, String encoding) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(Reader reader) 根据 reader 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(Source source) 根据 JAXP 源创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(String systemId, InputStream stream) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(String systemId, Reader reader) 根据 reader 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(XMLStreamReader reader) 根据 XMLStreamReader 创建一个新 XMLEventReader。

参数类型为 XMLEventReader 的 javax.xml.stream 中的方法
 void XMLEventWriter.add(XMLEventReader reader)
将整个流添加到输出流，在 hasNext() 返回 false 前对 inputStream 参数调用 next()。
abstract  XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
创建过滤的事件 reader，它用过滤器包装事件 reader。

javax.xml.stream.util 中 XMLEventReader 的使用

实现 XMLEventReader 的 javax.xml.stream.util 中的类
 class EventReaderDelegate
该类是用于派生 XMLEventReader 过滤器的基类。

返回 XMLEventReader 的 javax.xml.stream.util 中的方法
 XMLEventReader EventReaderDelegate.getParent()
获取此实例的父实例。

参数类型为 XMLEventReader 的 javax.xml.stream.util 中的方法
 void EventReaderDelegate.setParent(XMLEventReader reader)
设置此实例的父实例。

参数类型为 XMLEventReader 的 javax.xml.stream.util 中的构造方法
EventReaderDelegate(XMLEventReader reader)
用指定的父过滤器来构造一个过滤器。

javax.xml.transform.stax 中 XMLEventReader 的使用

返回 XMLEventReader 的 javax.xml.transform.stax 中的方法
 XMLEventReader StAXSource.getXMLEventReader()
获取此 StAXSource 使用的 XMLEventReader。

参数类型为 XMLEventReader 的 javax.xml.transform.stax 中的构造方法
StAXSource(XMLEventReader xmlEventReader)
通过提供 XMLEventReader 创建 StAXSource 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.XMLEventWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLEventWriter
的使用

使用 XMLEventWriter 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.bind 中 XMLEventWriter 的使用

参数类型为 XMLEventWriter 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。

javax.xml.bind.helpers 中 XMLEventWriter 的使用

参数类型为 XMLEventWriter 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)

javax.xml.stream 中 XMLEventWriter 的使用

返回 XMLEventWriter 的 javax.xml.stream 中的方法
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(OutputStream stream) 创建一个写入到流的新 XMLEventWriter。
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding) 创建一个写入到流的新 XMLEventWriter。
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(Result result) 创建一个写入到 JAXP 结果的新 XMLEventWriter。
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(Writer stream) 创建一个写入到 writer 的新 XMLEventWriter。

javax.xml.transform.stax 中 XMLEventWriter 的使用

返回 XMLEventWriter 的 javax.xml.transform.stax 中的方法
 XMLEventWriter StAXResult.getXMLEventWriter()
获取此 StAXResult 使用的 XMLEventWriter。

参数类型为 XMLEventWriter 的 javax.xml.transform.stax 中的构造方法
StAXResult(XMLEventWriter xmlEventWriter)
通过提供 XMLEventWriter 创建 StAXResult 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.stream.XMLInputFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.XMLInputFactory
的使用

使用 XMLInputFactory 的软件包
javax.xml.stream

javax.xml.stream 中 XMLInputFactory 的使用

返回 XMLInputFactory 的 javax.xml.stream 中的方法
static XMLInputFactory | XMLInputFactory.newInstance() 创建一个新的工厂实例。
static XMLInputFactory | XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
static XMLInputFactory | XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个的新工厂实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.stream.XMLOutputFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.XMLOutputFactory
的使用

使用 XMLOutputFactory 的软件包
javax.xml.stream

javax.xml.stream 中 XMLOutputFactory 的使用

返回 XMLOutputFactory 的 javax.xml.stream 中的方法
static XMLOutputFactory XMLOutputFactory.newInstance()
创建一个新的工厂实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.XMLReporter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLReporter
的使用

使用 XMLReporter 的软件包
javax.xml.stream

javax.xml.stream 中 XMLReporter 的使用

返回 XMLReporter 的 javax.xml.stream 中的方法
abstract  XMLReporter XMLInputFactory.getXMLReporter()
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。

参数类型为 XMLReporter 的 javax.xml.stream 中的方法
abstract  void XMLInputFactory.setXMLReporter(XMLReporter reporter)
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.XMLResolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLResolver
的使用

使用 XMLResolver 的软件包
javax.xml.stream

javax.xml.stream 中 XMLResolver 的使用

返回 XMLResolver 的 javax.xml.stream 中的方法
abstract  XMLResolver XMLInputFactory.getXMLResolver()
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。

参数类型为 XMLResolver 的 javax.xml.stream 中的方法
abstract  void XMLInputFactory.setXMLResolver(XMLResolver resolver)
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.XMLStreamConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLStreamConstants
的使用

使用 XMLStreamConstants 的软件包
javax.xml.stream
javax.xml.stream.events
javax.xml.stream.util

javax.xml.stream 中 XMLStreamConstants 的使用

javax.xml.stream 中 XMLStreamConstants 的子接口
 interface XMLStreamReader
XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。

javax.xml.stream.events 中 XMLStreamConstants 的使用

javax.xml.stream.events 中 XMLStreamConstants 的子接口
interface | Attribute 包含关于属性信息的接口。
interface | Characters 此方法将描述 Characters 事件的接口。
interface | Comment 注释事件的接口。
interface | DTD 它是处理 DTD 的事件的顶层接口。
interface | EndDocument 文档结尾的标记接口。
interface | EndElement 结束元素事件的接口。
interface | EntityDeclaration 处理实体声明的接口。
interface | EntityReference 处理实体事件的接口。
interface | Namespace 包含有关名称空间的信息的接口。
interface | NotationDeclaration 处理注释声明的接口。
interface | ProcessingInstruction 描述处理指令中的数据的接口。
interface | StartDocument 开始文档事件的接口。
interface | StartElement StartElement 接口提供对有关开始元素的信息的访问。
interface | XMLEvent 处理标记事件的基础事件接口。

javax.xml.stream.util 中 XMLStreamConstants 的使用

实现 XMLStreamConstants 的 javax.xml.stream.util 中的类
 class StreamReaderDelegate
该类是用于派生 XMLStreamReader 过滤器的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.stream.XMLStreamException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.XMLStreamException
的使用

使用 XMLStreamException 的软件包
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.stream 中 XMLStreamException 的使用

抛出 XMLStreamException 的 javax.xml.stream 中的方法
 void XMLEventWriter.add(XMLEvent event)
向输出流添加事件。
 void XMLEventWriter.add(XMLEventReader reader)
将整个流添加到输出流，在 hasNext() 返回 false 前对 inputStream 参数调用 next()。
 void XMLEventReader.close()
释放所有与此 Reader 关联的资源。
 void XMLEventWriter.close()
释放所有与此流关联的资源。
 void XMLStreamReader.close()
释放与此 Reader 关联的所有资源。
 void XMLStreamWriter.close()
关闭此 writer 并释放与 writer 关联的所有资源。
abstract  XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
创建过滤的事件 reader，它用过滤器包装事件 reader。
abstract  XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
创建过滤的 reader，它用过滤器包装 reader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream)
根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream, String encoding)
根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(Reader reader)
根据 reader 创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(Source source)
根据 JAXP 源创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, InputStream stream)
根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, Reader reader)
根据 reader 创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(XMLStreamReader reader)
根据 XMLStreamReader 创建一个新 XMLEventReader。
abstract  XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream)
创建一个写入到流的新 XMLEventWriter。
abstract  XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding)
创建一个写入到流的新 XMLEventWriter。
abstract  XMLEventWriter XMLOutputFactory.createXMLEventWriter(Result result)
创建一个写入到 JAXP 结果的新 XMLEventWriter。
abstract  XMLEventWriter XMLOutputFactory.createXMLEventWriter(Writer stream)
创建一个写入到 writer 的新 XMLEventWriter。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream)
根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding)
根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(Reader reader)
根据 reader 创建一个新 XMLStreamReader。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(Source source)
根据 JAXP 源创建一个新 XMLStreamReader。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream)
根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, Reader reader)
根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract  XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream)
创建一个写入到流的新 XMLStreamWriter。
abstract  XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding)
创建一个写入到流的新 XMLStreamWriter。
abstract  XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Result result)
创建一个写入到 JAXP 结果的新 XMLStreamWriter。
abstract  XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Writer stream)
创建一个写入到 writer 的新 XMLStreamWriter。
 void XMLEventWriter.flush()
将所有缓存事件写入到底层输出机制。
 void XMLStreamWriter.flush()
将所有缓存数据写入底层输出机制。
 String XMLEventReader.getElementText()
读取纯文本元素的内容。
 String XMLStreamReader.getElementText()
读取纯文本元素的内容，如果不是纯文本元素，则抛出异常。
 String XMLEventWriter.getPrefix(String uri)
获取绑定 URI 的前缀。
 String XMLStreamWriter.getPrefix(String uri)
获取绑定 URI 的前缀
 int XMLStreamReader.getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
获取与 CHARACTERS、SPACE 或 CDATA 事件关联的文本。
 boolean XMLStreamReader.hasNext()
如果有多个解析事件，则返回 true，如果不再有事件，则返回 false。
 int XMLStreamReader.next()
获取下一个解析事件??处理器可以用单个存储块返回所有连续的字符数据，它也可以将其分割成几个存储块。
 XMLEvent XMLEventReader.nextEvent()
获取下一个 XMLEvent。
 XMLEvent XMLEventReader.nextTag()
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有无意义的空格事件。
 int XMLStreamReader.nextTag()
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有空格（isWhiteSpace() 返回 true）、COMMENT 或 PROCESSING_INSTRUCTION。
 XMLEvent XMLEventReader.peek()
检查下一个 XMLEvent，但不从流中读取它。
 void XMLReporter.report(String message, String errorType, Object relatedInformation, Location location)
以特定于应用程序的格式报告所需消息。
 void XMLStreamReader.require(int type, String namespaceURI, String localName)
测试当前事件是否属于给定的类型，以及名称空间和名称是否与当前事件的当前名称空间和名称相匹配。
 Object XMLResolver.resolveEntity(String publicID, String systemID, String baseURI, String namespace)
检索资源。
 void XMLEventWriter.setDefaultNamespace(String uri)
将 URI 绑定到默认名称空间。
 void XMLStreamWriter.setDefaultNamespace(String uri)
将 URI 绑定到默认名称空间。
 void XMLEventWriter.setNamespaceContext(NamespaceContext context)
设置前缀的当前名称空间上下文和 URI 绑定。
 void XMLStreamWriter.setNamespaceContext(NamespaceContext context)
设置前缀和 URI 绑定的当前名称空间上下文。
 void XMLEventWriter.setPrefix(String prefix, String uri)
设置绑定 URI 的前缀。
 void XMLStreamWriter.setPrefix(String prefix, String uri)
设置绑定 URI 的前缀。
 void XMLStreamWriter.writeAttribute(String localName, String value)
向输出流写入一个不带前缀的属性。
 void XMLStreamWriter.writeAttribute(String namespaceURI, String localName, String value)
向输出流写入一个属性
 void XMLStreamWriter.writeAttribute(String prefix, String namespaceURI, String localName, String value)
向输出流写入一个属性
 void XMLStreamWriter.writeCData(String data)
编写 CData 节
 void XMLStreamWriter.writeCharacters(char[] text, int start, int len)
向输出写入文本
 void XMLStreamWriter.writeCharacters(String text)
向输出写入文本
 void XMLStreamWriter.writeComment(String data)
编写一个包含数据的 XML 注释
 void XMLStreamWriter.writeDefaultNamespace(String namespaceURI)
向流写入默认名称空间
 void XMLStreamWriter.writeDTD(String dtd)
编写 DTD 节。
 void XMLStreamWriter.writeEmptyElement(String localName)
向输出写入一个空元素标记
 void XMLStreamWriter.writeEmptyElement(String namespaceURI, String localName)
向输出写入一个空元素标记
 void XMLStreamWriter.writeEmptyElement(String prefix, String localName, String namespaceURI)
向输出写入一个空元素标记
 void XMLStreamWriter.writeEndDocument()
关闭所有开始标记并写入相应的结束标记。
 void XMLStreamWriter.writeEndElement()
向依赖于 writer 内部状态的输出写入一个结束标记，以此确定事件的前缀和本地名称。
 void XMLStreamWriter.writeEntityRef(String name)
编写一个实体引用
 void XMLStreamWriter.writeNamespace(String prefix, String namespaceURI)
向输出流写入一个名称空间。
 void XMLStreamWriter.writeProcessingInstruction(String target)
编写一条处理指令
 void XMLStreamWriter.writeProcessingInstruction(String target, String data)
编写一条处理指令
 void XMLStreamWriter.writeStartDocument()
编写 XML 声明。
 void XMLStreamWriter.writeStartDocument(String version)
编写 XML 声明。
 void XMLStreamWriter.writeStartDocument(String encoding, String version)
编写 XML 声明。
 void XMLStreamWriter.writeStartElement(String localName)
向输出写入一个开始标记。
 void XMLStreamWriter.writeStartElement(String namespaceURI, String localName)
向输出写入一个开始标记
 void XMLStreamWriter.writeStartElement(String prefix, String localName, String namespaceURI)
向输出写入一个开始标记

javax.xml.stream.events 中 XMLStreamException 的使用

抛出 XMLStreamException 的 javax.xml.stream.events 中的方法
 void XMLEvent.writeAsEncodedUnicode(Writer writer)
此方法根据 XML 1.0 规范将 XMLEvent 编写为 Unicode 字符。

javax.xml.stream.util 中 XMLStreamException 的使用

抛出 XMLStreamException 的 javax.xml.stream.util 中的方法
void | XMLEventConsumer.add(XMLEvent event) 此方法为使用者添加一个事件。
XMLEvent | XMLEventAllocator.allocate(XMLStreamReader reader) 此方法在给定 XMLStreamReader 当前状态的情况下分配事件。
void | XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer) 此方法在给定 XMLStreamReader 当前状态的情况下分配一个事件或一个事件组，并将该事件或事件组添加给传入的使用者。
void | EventReaderDelegate.close()
void | StreamReaderDelegate.close()
String | EventReaderDelegate.getElementText()
String | StreamReaderDelegate.getElementText()
int | StreamReaderDelegate.getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
boolean | StreamReaderDelegate.hasNext()
int | StreamReaderDelegate.next()
XMLEvent | EventReaderDelegate.nextEvent()
XMLEvent | EventReaderDelegate.nextTag()
int | StreamReaderDelegate.nextTag()
XMLEvent | EventReaderDelegate.peek()
void | StreamReaderDelegate.require(int type, String namespaceURI, String localName)

javax.xml.transform.stax 中 XMLStreamException 的使用

抛出 XMLStreamException 的 javax.xml.transform.stax 中的构造方法
StAXSource(XMLEventReader xmlEventReader)
通过提供 XMLEventReader 创建 StAXSource 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.XMLStreamReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLStreamReader
的使用

使用 XMLStreamReader 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.stream.util |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.bind 中 XMLStreamReader 的使用

参数类型为 XMLStreamReader 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(XMLStreamReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

javax.xml.bind.helpers 中 XMLStreamReader 的使用

参数类型为 XMLStreamReader 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

javax.xml.stream 中 XMLStreamReader 的使用

返回 XMLStreamReader 的 javax.xml.stream 中的方法
abstract XMLStreamReader | XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter) 创建过滤的 reader，它用过滤器包装 reader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(InputStream stream) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(Reader reader) 根据 reader 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(Source source) 根据 JAXP 源创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(String systemId, Reader reader) 根据 java.io.InputStream 创建一个新 XMLStreamReader。

参数类型为 XMLStreamReader 的 javax.xml.stream 中的方法
boolean | StreamFilter.accept(XMLStreamReader reader) 测试当前状态是否为此流的一部分。
abstract XMLStreamReader | XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter) 创建过滤的 reader，它用过滤器包装 reader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(XMLStreamReader reader) 根据 XMLStreamReader 创建一个新 XMLEventReader。

javax.xml.stream.util 中 XMLStreamReader 的使用

实现 XMLStreamReader 的 javax.xml.stream.util 中的类
 class StreamReaderDelegate
该类是用于派生 XMLStreamReader 过滤器的基类。

返回 XMLStreamReader 的 javax.xml.stream.util 中的方法
 XMLStreamReader StreamReaderDelegate.getParent()
获取此实例的父实例。

参数类型为 XMLStreamReader 的 javax.xml.stream.util 中的方法
XMLEvent | XMLEventAllocator.allocate(XMLStreamReader reader) 此方法在给定 XMLStreamReader 当前状态的情况下分配事件。
void | XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer) 此方法在给定 XMLStreamReader 当前状态的情况下分配一个事件或一个事件组，并将该事件或事件组添加给传入的使用者。
void | StreamReaderDelegate.setParent(XMLStreamReader reader) 设置此实例的父实例。

参数类型为 XMLStreamReader 的 javax.xml.stream.util 中的构造方法
StreamReaderDelegate(XMLStreamReader reader)
用指定的父过滤器来构造一个过滤器。

javax.xml.transform.stax 中 XMLStreamReader 的使用

返回 XMLStreamReader 的 javax.xml.transform.stax 中的方法
 XMLStreamReader StAXSource.getXMLStreamReader()
获取此 StAXSource 使用的 XMLStreamReader。

参数类型为 XMLStreamReader 的 javax.xml.transform.stax 中的构造方法
StAXSource(XMLStreamReader xmlStreamReader)
通过 XMLStreamReader 创建 StAXSource 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.XMLStreamWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLStreamWriter
的使用

使用 XMLStreamWriter 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.bind 中 XMLStreamWriter 的使用

参数类型为 XMLStreamWriter 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。

javax.xml.bind.helpers 中 XMLStreamWriter 的使用

参数类型为 XMLStreamWriter 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)

javax.xml.stream 中 XMLStreamWriter 的使用

返回 XMLStreamWriter 的 javax.xml.stream 中的方法
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(OutputStream stream) 创建一个写入到流的新 XMLStreamWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding) 创建一个写入到流的新 XMLStreamWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(Result result) 创建一个写入到 JAXP 结果的新 XMLStreamWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(Writer stream) 创建一个写入到 writer 的新 XMLStreamWriter。

javax.xml.transform.stax 中 XMLStreamWriter 的使用

返回 XMLStreamWriter 的 javax.xml.transform.stax 中的方法
 XMLStreamWriter StAXResult.getXMLStreamWriter()
获取此 StAXResult 使用的 XMLStreamWriter。

参数类型为 XMLStreamWriter 的 javax.xml.transform.stax 中的构造方法
StAXResult(XMLStreamWriter xmlStreamWriter)
通过提供 XMLStreamWriter 创建 StAXResult 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.stream.events (Java 2 Platform SE 6)

 javax.xml.stream.events
接口
Attribute
Characters
Comment
DTD
EndDocument
EndElement
EntityDeclaration
EntityReference
Namespace
NotationDeclaration
ProcessingInstruction
StartDocument
StartElement
XMLEvent


接口 javax.xml.stream.events.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.Attribute
的使用

使用 Attribute 的软件包
javax.xml.stream
javax.xml.stream.events

javax.xml.stream 中 Attribute 的使用

返回 Attribute 的 javax.xml.stream 中的方法
abstract Attribute | XMLEventFactory.createAttribute(QName name, String value) 创建一个新 Attribute。
abstract Attribute | XMLEventFactory.createAttribute(String localName, String value) 创建一个新 Attribute。
abstract Attribute | XMLEventFactory.createAttribute(String prefix, String namespaceURI, String localName, String value) 创建一个新 Attribute。

javax.xml.stream.events 中 Attribute 的使用

javax.xml.stream.events 中 Attribute 的子接口
 interface Namespace
包含有关名称空间的信息的接口。

返回 Attribute 的 javax.xml.stream.events 中的方法
 Attribute StartElement.getAttributeByName(QName name)
返回此名称引用的属性

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.Characters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.Characters
的使用

使用 Characters 的软件包
javax.xml.stream
javax.xml.stream.events

javax.xml.stream 中 Characters 的使用

返回 Characters 的 javax.xml.stream 中的方法
abstract Characters | XMLEventFactory.createCData(String content) 创建一个 CData 标记设置为 true 的 Character 事件。
abstract Characters | XMLEventFactory.createCharacters(String content) 创建一个 Character 事件，此方法不检查内容是否全部为空白。
abstract Characters | XMLEventFactory.createIgnorableSpace(String content) 创建一个可忽略的空间。
abstract Characters | XMLEventFactory.createSpace(String content) 创建一个 isSpace 标记设置为 true 的 Character 事件。

javax.xml.stream.events 中 Characters 的使用

返回 Characters 的 javax.xml.stream.events 中的方法
 Characters XMLEvent.asCharacters()
将此事件作为 Characters 返回，如果此事件不是字符，则可能导致类强制转化异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.Comment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.Comment
的使用

使用 Comment 的软件包
javax.xml.stream

javax.xml.stream 中 Comment 的使用

返回 Comment 的 javax.xml.stream 中的方法
abstract  Comment XMLEventFactory.createComment(String text)
创建一个注释。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.DTD 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.DTD
的使用

使用 DTD 的软件包
javax.xml.stream

javax.xml.stream 中 DTD 的使用

返回 DTD 的 javax.xml.stream 中的方法
abstract  DTD XMLEventFactory.createDTD(String dtd)
创建一个文档类型定义事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.EndDocument 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.EndDocument
的使用

使用 EndDocument 的软件包
javax.xml.stream

javax.xml.stream 中 EndDocument 的使用

返回 EndDocument 的 javax.xml.stream 中的方法
abstract  EndDocument XMLEventFactory.createEndDocument()
创建一个 EndDocument 事件的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.EndElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.EndElement
的使用

使用 EndElement 的软件包
javax.xml.stream
javax.xml.stream.events

javax.xml.stream 中 EndElement 的使用

返回 EndElement 的 javax.xml.stream 中的方法
abstract EndElement | XMLEventFactory.createEndElement(QName name, Iterator namespaces) 创建一个新 EndElement。
abstract EndElement | XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName) 创建一个新 EndElement。
abstract EndElement | XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces) 创建一个新 EndElement。

javax.xml.stream.events 中 EndElement 的使用

返回 EndElement 的 javax.xml.stream.events 中的方法
 EndElement XMLEvent.asEndElement()
将此事件作为结束元素事件返回，如果此事件不是结束元素，则可能导致类强制转换异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.EntityDeclaration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.EntityDeclaration
的使用

使用 EntityDeclaration 的软件包
javax.xml.stream
javax.xml.stream.events

javax.xml.stream 中 EntityDeclaration 的使用

参数类型为 EntityDeclaration 的 javax.xml.stream 中的方法
abstract  EntityReference XMLEventFactory.createEntityReference(String name, EntityDeclaration declaration)
创建一个 EntityReference 事件的新实例。

javax.xml.stream.events 中 EntityDeclaration 的使用

返回 EntityDeclaration 的 javax.xml.stream.events 中的方法
 EntityDeclaration EntityReference.getDeclaration()
返回此实体的声明。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.EntityReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.EntityReference
的使用

使用 EntityReference 的软件包
javax.xml.stream

javax.xml.stream 中 EntityReference 的使用

返回 EntityReference 的 javax.xml.stream 中的方法
abstract  EntityReference XMLEventFactory.createEntityReference(String name, EntityDeclaration declaration)
创建一个 EntityReference 事件的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.Namespace 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.Namespace
的使用

使用 Namespace 的软件包
javax.xml.stream

javax.xml.stream 中 Namespace 的使用

返回 Namespace 的 javax.xml.stream 中的方法
abstract Namespace | XMLEventFactory.createNamespace(String namespaceURI) 创建一个新的默认 Namespace。
abstract Namespace | XMLEventFactory.createNamespace(String prefix, String namespaceUri) 创建一个新的 Namespace。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.NotationDeclaration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.NotationDeclaration
的使用

没有 javax.xml.stream.events.NotationDeclaration 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.ProcessingInstruction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.ProcessingInstruction
的使用

使用 ProcessingInstruction 的软件包
javax.xml.stream

javax.xml.stream 中 ProcessingInstruction 的使用

返回 ProcessingInstruction 的 javax.xml.stream 中的方法
abstract  ProcessingInstruction XMLEventFactory.createProcessingInstruction(String target, String data)
创建一个处理指令。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.StartDocument 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.StartDocument
的使用

使用 StartDocument 的软件包
javax.xml.stream

javax.xml.stream 中 StartDocument 的使用

返回 StartDocument 的 javax.xml.stream 中的方法
abstract StartDocument | XMLEventFactory.createStartDocument() 创建一个 StartDocument 事件的新实例。
abstract StartDocument | XMLEventFactory.createStartDocument(String encoding) 创建一个 StartDocument 事件的新实例。
abstract StartDocument | XMLEventFactory.createStartDocument(String encoding, String version) 创建一个 StartDocument 事件的新实例。
abstract StartDocument | XMLEventFactory.createStartDocument(String encoding, String version, boolean standalone) 创建一个 StartDocument 事件的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.StartElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.StartElement
的使用

使用 StartElement 的软件包
javax.xml.stream
javax.xml.stream.events

javax.xml.stream 中 StartElement 的使用

返回 StartElement 的 javax.xml.stream 中的方法
abstract StartElement | XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context) 创建一个新 StartElement。

javax.xml.stream.events 中 StartElement 的使用

返回 StartElement 的 javax.xml.stream.events 中的方法
 StartElement XMLEvent.asStartElement()
将此事件作为开始元素事件返回，如果此事件不是开始元素，则可能导致类强制转换异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.events.XMLEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.XMLEvent
的使用

使用 XMLEvent 的软件包
javax.xml.stream
javax.xml.stream.events
javax.xml.stream.util

javax.xml.stream 中 XMLEvent 的使用

返回 XMLEvent 的 javax.xml.stream 中的方法
XMLEvent | XMLEventReader.nextEvent() 获取下一个 XMLEvent。
XMLEvent | XMLEventReader.nextTag() 在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有无意义的空格事件。
XMLEvent | XMLEventReader.peek() 检查下一个 XMLEvent，但不从流中读取它。

参数类型为 XMLEvent 的 javax.xml.stream 中的方法
boolean | EventFilter.accept(XMLEvent event) 测试此事件是否为此流的一部分。
void | XMLEventWriter.add(XMLEvent event) 向输出流添加事件。

javax.xml.stream.events 中 XMLEvent 的使用

javax.xml.stream.events 中 XMLEvent 的子接口
interface | Attribute 包含关于属性信息的接口。
interface | Characters 此方法将描述 Characters 事件的接口。
interface | Comment 注释事件的接口。
interface | DTD 它是处理 DTD 的事件的顶层接口。
interface | EndDocument 文档结尾的标记接口。
interface | EndElement 结束元素事件的接口。
interface | EntityDeclaration 处理实体声明的接口。
interface | EntityReference 处理实体事件的接口。
interface | Namespace 包含有关名称空间的信息的接口。
interface | NotationDeclaration 处理注释声明的接口。
interface | ProcessingInstruction 描述处理指令中的数据的接口。
interface | StartDocument 开始文档事件的接口。
interface | StartElement StartElement 接口提供对有关开始元素的信息的访问。

javax.xml.stream.util 中 XMLEvent 的使用

返回 XMLEvent 的 javax.xml.stream.util 中的方法
XMLEvent | XMLEventAllocator.allocate(XMLStreamReader reader) 此方法在给定 XMLStreamReader 当前状态的情况下分配事件。
XMLEvent | EventReaderDelegate.nextEvent()
XMLEvent | EventReaderDelegate.nextTag()
XMLEvent | EventReaderDelegate.peek()

参数类型为 XMLEvent 的 javax.xml.stream.util 中的方法
 void XMLEventConsumer.add(XMLEvent event)
此方法为使用者添加一个事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.stream.util (Java 2 Platform SE 6)

 javax.xml.stream.util
接口
XMLEventAllocator
XMLEventConsumer
类
EventReaderDelegate
StreamReaderDelegate


类 javax.xml.stream.util.EventReaderDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.util.EventReaderDelegate
的使用

没有 javax.xml.stream.util.EventReaderDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.stream.util.StreamReaderDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.util.StreamReaderDelegate
的使用

没有 javax.xml.stream.util.StreamReaderDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.util.XMLEventAllocator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.util.XMLEventAllocator
的使用

使用 XMLEventAllocator 的软件包
javax.xml.stream
javax.xml.stream.util

javax.xml.stream 中 XMLEventAllocator 的使用

返回 XMLEventAllocator 的 javax.xml.stream 中的方法
abstract  XMLEventAllocator XMLInputFactory.getEventAllocator()
获取用此工厂创建的流所使用的分配器。

参数类型为 XMLEventAllocator 的 javax.xml.stream 中的方法
abstract  void XMLInputFactory.setEventAllocator(XMLEventAllocator allocator)
为事件设置一个用户定义的事件分配器。

javax.xml.stream.util 中 XMLEventAllocator 的使用

返回 XMLEventAllocator 的 javax.xml.stream.util 中的方法
 XMLEventAllocator XMLEventAllocator.newInstance()
此方法创建一个 XMLEventAllocator 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.stream.util.XMLEventConsumer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.util.XMLEventConsumer
的使用

使用 XMLEventConsumer 的软件包
javax.xml.stream
javax.xml.stream.util

javax.xml.stream 中 XMLEventConsumer 的使用

javax.xml.stream 中 XMLEventConsumer 的子接口
 interface XMLEventWriter
此类是用于编写 XML 文档的顶层接口。

javax.xml.stream.util 中 XMLEventConsumer 的使用

参数类型为 XMLEventConsumer 的 javax.xml.stream.util 中的方法
 void XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer)
此方法在给定 XMLStreamReader 当前状态的情况下分配一个事件或一个事件组，并将该事件或事件组添加给传入的使用者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.transform (Java 2 Platform SE 6)

 javax.xml.transform
接口
ErrorListener
Result
Source
SourceLocator
Templates
URIResolver
类
OutputKeys
Transformer
TransformerFactory
异常
TransformerConfigurationException
TransformerException
错误
TransformerFactoryConfigurationError


接口 javax.xml.transform.ErrorListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.ErrorListener
的使用

使用 ErrorListener 的软件包
javax.xml.transform 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform 中 ErrorListener 的使用

返回 ErrorListener 的 javax.xml.transform 中的方法
abstract ErrorListener | Transformer.getErrorListener() 获取转换的实际错误事件处理程序。
abstract ErrorListener | TransformerFactory.getErrorListener() 获取 TransformerFactory 的错误事件处理程序。

参数类型为 ErrorListener 的 javax.xml.transform 中的方法
abstract void | Transformer.setErrorListener(ErrorListener listener) 设置转换的实际错误事件侦听器。
abstract void | TransformerFactory.setErrorListener(ErrorListener listener) 设置此 TransformerFactory 的错误事件侦听器，它将用于转换指令的处理，而不用于转换本身。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.OutputKeys 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.OutputKeys
的使用

没有 javax.xml.transform.OutputKeys 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.transform.Result 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.Result
的使用

使用 Result 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。

java.sql 中 Result 的使用

类型参数类型为 Result 的 java.sql 中的方法
<T extends Result>
T
SQLXML.setResult(Class<T> resultClass)
返回设置此 SQLXML 实例指定的 XML 值的 Result。

javax.xml.bind 中 Result 的使用

返回 Result 的 javax.xml.bind 中的方法
abstract  Result SchemaOutputResolver.createOutput(String namespaceUri, String suggestedFileName)
确定写入模式文件（由给定名称空间 URI 指定）的位置，并以 Result 对象的形式返回它。

参数类型为 Result 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, Result result)
将以 jaxbElement 为根的内容树编组到指定的 javax.xml.transform.Result 中。

javax.xml.bind.annotation 中 Result 的使用

类型参数类型为 Result 的 javax.xml.bind.annotation 中的类
 interface DomHandler<ElementT,ResultT extends Result>
在元素（及其子代）与 DOM（或类似对象）表示形式之间相互转换。

javax.xml.bind.util 中 Result 的使用

实现 Result 的 javax.xml.bind.util 中的类
 class JAXBResult
解组 JAXB 对象的 JAXP Result 实现。

javax.xml.soap 中 Result 的使用

实现 Result 的 javax.xml.soap 中的类
 class SAAJResult
以 SAAJ 树的形式，充当 JAXP 转换或 JAXB 编组结果的持有者。

javax.xml.stream 中 Result 的使用

参数类型为 Result 的 javax.xml.stream 中的方法
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(Result result) 创建一个写入到 JAXP 结果的新 XMLEventWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(Result result) 创建一个写入到 JAXP 结果的新 XMLStreamWriter。

javax.xml.transform 中 Result 的使用

参数类型为 Result 的 javax.xml.transform 中的方法
abstract  void Transformer.transform(Source xmlSource, Result outputTarget)
将 XML Source 转换为 Result。

javax.xml.transform.dom 中 Result 的使用

实现 Result 的 javax.xml.transform.dom 中的类
 class DOMResult
以 Document Object Model（DOM）树的形式充当转换结果树的持有者。

javax.xml.transform.sax 中 Result 的使用

实现 Result 的 javax.xml.transform.sax 中的类
 class SAXResult
充当转换 Result 的持有者。

参数类型为 Result 的 javax.xml.transform.sax 中的方法
 void TransformerHandler.setResult(Result result)
设置与用于转换的此 TransformerHandler 关联的 Result。

javax.xml.transform.stax 中 Result 的使用

实现 Result 的 javax.xml.transform.stax 中的类
 class StAXResult
以 StAX writer 的形式（即 XMLStreamWriter 或 XMLEventWriter）充当 XML Result 的持有者。

javax.xml.transform.stream 中 Result 的使用

实现 Result 的 javax.xml.transform.stream 中的类
 class StreamResult
充当转换结果的持有者，可以为 XML、纯文本、HTML 或某些其他格式的标记。

javax.xml.validation 中 Result 的使用

参数类型为 Result 的 javax.xml.validation 中的方法
abstract  void Validator.validate(Source source, Result result)
验证指定输入并将扩充的验证结果发送到指定输出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.transform.Source 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.Source
的使用

使用 Source 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.sql 中 Source 的使用

类型参数类型为 Source 的 java.sql 中的方法
<T extends Source>
T
SQLXML.getSource(Class<T> sourceClass)
返回读取此 SQLXML 实例指定的 XML 值的 Source。

javax.xml.bind 中 Source 的使用

参数类型为 Source 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(Source source)
从指定的 XML Source 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Source source, Class<T> declaredType)
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。

javax.xml.bind.annotation 中 Source 的使用

返回 Source 的 javax.xml.bind.annotation 中的方法
Source | DomHandler.marshal(ElementT n, ValidationEventHandler errorHandler) 在 JAXB 提供者需要将元素编组为 XML 时调用此方法。
Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

javax.xml.bind.helpers 中 Source 的使用

参数类型为 Source 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(Source source)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)

javax.xml.bind.util 中 Source 的使用

实现 Source 的 javax.xml.bind.util 中的类
 class JAXBSource
编组 JAXB 生成的对象的 JAXP Source 实现。

javax.xml.soap 中 Source 的使用

返回 Source 的 javax.xml.soap 中的方法
abstract  Source SOAPPart.getContent()
以 JAXP Source 对象的形式返回 SOAPEnvelope 的内容。

参数类型为 Source 的 javax.xml.soap 中的方法
abstract  void SOAPPart.setContent(Source source)
使用取自给定 Source 对象的数据设置 SOAPEnvelope 对象的内容。

javax.xml.stream 中 Source 的使用

参数类型为 Source 的 javax.xml.stream 中的方法
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(Source source) 根据 JAXP 源创建一个新 XMLEventReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(Source source) 根据 JAXP 源创建一个新 XMLStreamReader。

javax.xml.transform 中 Source 的使用

返回 Source 的 javax.xml.transform 中的方法
abstract  Source TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset)
通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。
 Source URIResolver.resolve(String href, String base)
当遇到 xsl:include、xsl:import 或 document() 函数时，由处理器调用此方法。

参数类型为 Source 的 javax.xml.transform 中的方法
abstract Source | TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset) 通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。
abstract Templates | TransformerFactory.newTemplates(Source source) 将 Source 处理为 Templates 对象，后者是源的编译后表示形式。
abstract Transformer | TransformerFactory.newTransformer(Source source) 将 Source 处理为 Transformer Object。
abstract void | Transformer.transform(Source xmlSource, Result outputTarget) 将 XML Source 转换为 Result。

javax.xml.transform.dom 中 Source 的使用

实现 Source 的 javax.xml.transform.dom 中的类
 class DOMSource
以 Document Object Model（DOM）树的形式充当转换 Source 树的持有者。

javax.xml.transform.sax 中 Source 的使用

实现 Source 的 javax.xml.transform.sax 中的类
 class SAXSource
充当 SAX 样式 Source 的持有者。

参数类型为 Source 的 javax.xml.transform.sax 中的方法
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Source src) 基于参数所指定的转换指令，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Source src) 创建使用给定 Source 作为转换指令的 XMLFilter。
static InputSource | SAXSource.sourceToInputSource(Source source) 尝试从 Source 对象获取 SAX InputSource 对象。

javax.xml.transform.stax 中 Source 的使用

实现 Source 的 javax.xml.transform.stax 中的类
 class StAXSource
以 StAX reader 的形式（即 XMLStreamReader 或 XMLEventReader）充当 XML Source 的持有者。

javax.xml.transform.stream 中 Source 的使用

实现 Source 的 javax.xml.transform.stream 中的类
 class StreamSource
以 XML 标记流的形式充当转换 Source 的持有者。

javax.xml.validation 中 Source 的使用

参数类型为 Source 的 javax.xml.validation 中的方法
Schema | SchemaFactory.newSchema(Source schema) 解析作为模式的指定源并以模式形式返回它。
abstract Schema | SchemaFactory.newSchema(Source[] schemas) 解析作为模式的指定源（或多个源），并以模式形式返回它。
void | Validator.validate(Source source) 验证指定的输入。
abstract void | Validator.validate(Source source, Result result) 验证指定输入并将扩充的验证结果发送到指定输出。

javax.xml.ws 中 Source 的使用

返回 Source 的 javax.xml.ws 中的方法
 Source LogicalMessage.getPayload()
以 XML 源的形式获取消息负载，可以在相同的 LogicalMessage 实例上多次调用，总是返回可以用来检索整个消息负载的新的 Source。

返回变量类型为 Source 的类型的 javax.xml.ws 中的方法
abstract  List<Source> Endpoint.getMetadata()
返回服务的元数据文档列表。

参数类型为 Source 的 javax.xml.ws 中的方法
 void LogicalMessage.setPayload(Source payload)
设置消息负载

类型变量类型为 Source 的 javax.xml.ws 中的方法参数
abstract  void Endpoint.setMetadata(List<Source> metadata)
设置此端点的元数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.transform.SourceLocator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.SourceLocator
的使用

使用 SourceLocator 的软件包
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。

javax.xml.transform 中 SourceLocator 的使用

返回 SourceLocator 的 javax.xml.transform 中的方法
 SourceLocator TransformerException.getLocator()
getLocator 方法检索 SourceLocator 对象的实例，此对象指定了错误发生的位置。

参数类型为 SourceLocator 的 javax.xml.transform 中的方法
 void TransformerException.setLocator(SourceLocator location)
setLocator 方法设置 SourceLocator 对象的实例，此对象指定了错误发生的位置。

参数类型为 SourceLocator 的 javax.xml.transform 中的构造方法
TransformerConfigurationException(String message, SourceLocator locator)
从消息和 Locator 创建新 TransformerConfigurationException。
TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
包装了 TransformerConfigurationException 中的现有异常。
TransformerException(String message, SourceLocator locator)
从消息和 Locator 创建一个新 TransformerException。
TransformerException(String message, SourceLocator locator, Throwable e)
包装了 TransformerException 中的现有异常。

javax.xml.transform.dom 中 SourceLocator 的使用

javax.xml.transform.dom 中 SourceLocator 的子接口
 interface DOMLocator
指示源 DOM 中节点的位置，主要用于错误报告。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.transform.Templates 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.Templates
的使用

使用 Templates 的软件包
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

javax.xml.transform 中 Templates 的使用

返回 Templates 的 javax.xml.transform 中的方法
abstract  Templates TransformerFactory.newTemplates(Source source)
将 Source 处理为 Templates 对象，后者是源的编译后表示形式。

javax.xml.transform.sax 中 Templates 的使用

返回 Templates 的 javax.xml.transform.sax 中的方法
 Templates TemplatesHandler.getTemplates()
当 TemplatesHandler 对象用作 ContentHandler（用于转换指令的解析）时，它创建 Templates 对象，调用者可以在 SAX 事件已完成后获取该对象。

参数类型为 Templates 的 javax.xml.transform.sax 中的方法
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Templates templates) 基于 Templates 参数，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Templates templates) 基于 Templates 参数，创建 XMLFilter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.Transformer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.Transformer
的使用

使用 Transformer 的软件包
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

javax.xml.transform 中 Transformer 的使用

返回 Transformer 的 javax.xml.transform 中的方法
Transformer | Templates.newTransformer() 创建此 Templates 对象的新转换上下文。
abstract Transformer | TransformerFactory.newTransformer() 创建执行从 Source 到 Result 的复制的新 Transformer。
abstract Transformer | TransformerFactory.newTransformer(Source source) 将 Source 处理为 Transformer Object。

javax.xml.transform.sax 中 Transformer 的使用

返回 Transformer 的 javax.xml.transform.sax 中的方法
 Transformer TransformerHandler.getTransformer()
获取与此处理程序关联的 Transformer，用于设置参数和输出属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.TransformerConfigurationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.TransformerConfigurationException
的使用

使用 TransformerConfigurationException 的软件包
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

javax.xml.transform 中 TransformerConfigurationException 的使用

抛出 TransformerConfigurationException 的 javax.xml.transform 中的方法
abstract Source | TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset) 通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。
abstract Templates | TransformerFactory.newTemplates(Source source) 将 Source 处理为 Templates 对象，后者是源的编译后表示形式。
Transformer | Templates.newTransformer() 创建此 Templates 对象的新转换上下文。
abstract Transformer | TransformerFactory.newTransformer() 创建执行从 Source 到 Result 的复制的新 Transformer。
abstract Transformer | TransformerFactory.newTransformer(Source source) 将 Source 处理为 Transformer Object。
abstract void | TransformerFactory.setFeature(String name, boolean value) 设置通过此工厂创建的此 TransformerFactory 和 Transformer 或 Template 的功能。

javax.xml.transform.sax 中 TransformerConfigurationException 的使用

抛出 TransformerConfigurationException 的 javax.xml.transform.sax 中的方法
abstract TemplatesHandler | SAXTransformerFactory.newTemplatesHandler() 获取能够将 SAX ContentHandler 事件处理为 Templates 对象的 TemplatesHandler 对象。
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler() 获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Source src) 基于参数所指定的转换指令，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Templates templates) 基于 Templates 参数，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Source src) 创建使用给定 Source 作为转换指令的 XMLFilter。
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Templates templates) 基于 Templates 参数，创建 XMLFilter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.TransformerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.TransformerException
的使用

使用 TransformerException 的软件包
javax.xml.transform 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform 中 TransformerException 的使用

javax.xml.transform 中 TransformerException 的子类
 class TransformerConfigurationException
指示严重的配置错误。

参数类型为 TransformerException 的 javax.xml.transform 中的方法
void | ErrorListener.error(TransformerException exception) 接收可恢复错误的通知。
void | ErrorListener.fatalError(TransformerException exception) 接收不可恢复错误的通知。
void | ErrorListener.warning(TransformerException exception) 接收警告通知。

抛出 TransformerException 的 javax.xml.transform 中的方法
 void ErrorListener.error(TransformerException exception)
接收可恢复错误的通知。
 void ErrorListener.fatalError(TransformerException exception)
接收不可恢复错误的通知。
 Source URIResolver.resolve(String href, String base)
当遇到 xsl:include、xsl:import 或 document() 函数时，由处理器调用此方法。
abstract  void Transformer.transform(Source xmlSource, Result outputTarget)
将 XML Source 转换为 Result。
 void ErrorListener.warning(TransformerException exception)
接收警告通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.TransformerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.TransformerFactory
的使用

使用 TransformerFactory 的软件包
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

javax.xml.transform 中 TransformerFactory 的使用

返回 TransformerFactory 的 javax.xml.transform 中的方法
static TransformerFactory | TransformerFactory.newInstance() 获取 TransformerFactory 的新实例。
static TransformerFactory | TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader) 根据类名称获得一个新 TransformerFactory 实例。

javax.xml.transform.sax 中 TransformerFactory 的使用

javax.xml.transform.sax 中 TransformerFactory 的子类
 class SAXTransformerFactory
此类扩展了 TransformerFactory 以提供特定于 SAX 的工厂方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.TransformerFactoryConfigurationError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.TransformerFactoryConfigurationError
的使用

使用 TransformerFactoryConfigurationError 的软件包
javax.xml.transform 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform 中 TransformerFactoryConfigurationError 的使用

抛出 TransformerFactoryConfigurationError 的 javax.xml.transform 中的方法
static TransformerFactory | TransformerFactory.newInstance() 获取 TransformerFactory 的新实例。
static TransformerFactory | TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader) 根据类名称获得一个新 TransformerFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.transform.URIResolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.URIResolver
的使用

使用 URIResolver 的软件包
javax.xml.transform 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform 中 URIResolver 的使用

返回 URIResolver 的 javax.xml.transform 中的方法
abstract  URIResolver Transformer.getURIResolver()
获取将用于解析在 document() 中使用的 URI 的对象。
abstract  URIResolver TransformerFactory.getURIResolver()
获取在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。

参数类型为 URIResolver 的 javax.xml.transform 中的方法
abstract  void Transformer.setURIResolver(URIResolver resolver)
设置将用于解析在 document() 中使用的 URI 的对象。
abstract  void TransformerFactory.setURIResolver(URIResolver resolver)
设置在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.transform.dom (Java 2 Platform SE 6)

 javax.xml.transform.dom
接口
DOMLocator
类
DOMResult
DOMSource


接口 javax.xml.transform.dom.DOMLocator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.dom.DOMLocator
的使用

没有 javax.xml.transform.dom.DOMLocator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.dom.DOMResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.dom.DOMResult
的使用

使用 DOMResult 的软件包
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。

javax.xml.bind.annotation 中 DOMResult 的使用

返回 DOMResult 的 javax.xml.bind.annotation 中的方法
 DOMResult W3CDomHandler.createUnmarshaller(ValidationEventHandler errorHandler)

参数类型为 DOMResult 的 javax.xml.bind.annotation 中的方法
 Element W3CDomHandler.getElement(DOMResult r)

javax.xml.soap 中 DOMResult 的使用

javax.xml.soap 中 DOMResult 的子类
 class SAAJResult
以 SAAJ 树的形式，充当 JAXP 转换或 JAXB 编组结果的持有者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.dom.DOMSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.dom.DOMSource
的使用

没有 javax.xml.transform.dom.DOMSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.transform.sax (Java 2 Platform SE 6)

 javax.xml.transform.sax
接口
TemplatesHandler
TransformerHandler
类
SAXResult
SAXSource
SAXTransformerFactory


类 javax.xml.transform.sax.SAXResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.sax.SAXResult
的使用

使用 SAXResult 的软件包
javax.xml.bind.util 有用的客户端实用工具类。

javax.xml.bind.util 中 SAXResult 的使用

javax.xml.bind.util 中 SAXResult 的子类
 class JAXBResult
解组 JAXB 对象的 JAXP Result 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.sax.SAXSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.sax.SAXSource
的使用

使用 SAXSource 的软件包
javax.xml.bind.util 有用的客户端实用工具类。

javax.xml.bind.util 中 SAXSource 的使用

javax.xml.bind.util 中 SAXSource 的子类
 class JAXBSource
编组 JAXB 生成的对象的 JAXP Source 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.sax.SAXTransformerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.sax.SAXTransformerFactory
的使用

没有 javax.xml.transform.sax.SAXTransformerFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.transform.sax.TemplatesHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.sax.TemplatesHandler
的使用

使用 TemplatesHandler 的软件包
javax.xml.transform.sax 此包实现特定于 SAX2 的转换 API。

javax.xml.transform.sax 中 TemplatesHandler 的使用

返回 TemplatesHandler 的 javax.xml.transform.sax 中的方法
abstract  TemplatesHandler SAXTransformerFactory.newTemplatesHandler()
获取能够将 SAX ContentHandler 事件处理为 Templates 对象的 TemplatesHandler 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.transform.sax.TransformerHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.sax.TransformerHandler
的使用

使用 TransformerHandler 的软件包
javax.xml.transform.sax 此包实现特定于 SAX2 的转换 API。

javax.xml.transform.sax 中 TransformerHandler 的使用

返回 TransformerHandler 的 javax.xml.transform.sax 中的方法
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler() 获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Source src) 基于参数所指定的转换指令，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Templates templates) 基于 Templates 参数，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.transform.stax (Java 2 Platform SE 6)

 javax.xml.transform.stax
类
StAXResult
StAXSource


类 javax.xml.transform.stax.StAXResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.stax.StAXResult
的使用

没有 javax.xml.transform.stax.StAXResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.stax.StAXSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.stax.StAXSource
的使用

没有 javax.xml.transform.stax.StAXSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.transform.stream (Java 2 Platform SE 6)

 javax.xml.transform.stream
类
StreamResult
StreamSource


类 javax.xml.transform.stream.StreamResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.stream.StreamResult
的使用

没有 javax.xml.transform.stream.StreamResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.transform.stream.StreamSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.stream.StreamSource
的使用

没有 javax.xml.transform.stream.StreamSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.validation (Java 2 Platform SE 6)

 javax.xml.validation
类
Schema
SchemaFactory
SchemaFactoryLoader
TypeInfoProvider
Validator
ValidatorHandler


类 javax.xml.validation.Schema 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.Schema
的使用

使用 Schema 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。

javax.xml.bind 中 Schema 的使用

返回 Schema 的 javax.xml.bind 中的方法
abstract  Schema Binder.getSchema()
获取 Binder.setSchema(Schema) 方法设置的最后一个 Schema 对象（包括 null）。
 Schema Marshaller.getSchema()
获取用于执行编组时验证的 JAXP 1.3 Schema 对象。
 Schema Unmarshaller.getSchema()
获取用于执行解组时验证的 JAXP 1.3 Schema 对象。

参数类型为 Schema 的 javax.xml.bind 中的方法
abstract void | Binder.setSchema(Schema schema) 指定 marshal、unmarshal 和 update 方法是否在其 XML 内容上执行验证。
void | Marshaller.setSchema(Schema schema) 指定应该用作验证后续编组操作依据的 JAXP 1.3 Schema 对象。
void | Unmarshaller.setSchema(Schema schema) 指定应用作验证后续解组操作依据的 JAXP 1.3 Schema 对象。

javax.xml.bind.helpers 中 Schema 的使用

返回 Schema 的 javax.xml.bind.helpers 中的方法
Schema | AbstractMarshallerImpl.getSchema()
Schema | AbstractUnmarshallerImpl.getSchema()

参数类型为 Schema 的 javax.xml.bind.helpers 中的方法
void | AbstractMarshallerImpl.setSchema(Schema schema)
void | AbstractUnmarshallerImpl.setSchema(Schema schema)

javax.xml.parsers 中 Schema 的使用

返回 Schema 的 javax.xml.parsers 中的方法
 Schema SAXParser.getSchema()
获取对 XML 处理器使用的 Schema 的引用。
 Schema SAXParserFactory.getSchema()
获取通过 SAXParserFactory.setSchema(Schema schema) 方法指定的 Schema 对象。
 Schema DocumentBuilder.getSchema()
获取由 XML 处理器使用的 Schema 的引用。
 Schema DocumentBuilderFactory.getSchema()
获取通过 DocumentBuilderFactory.setSchema(Schema schema) 方法指定的 Schema 对象。

参数类型为 Schema 的 javax.xml.parsers 中的方法
void | SAXParserFactory.setSchema(Schema schema) 设置将由解析器使用的 Schema，该解析器从此工厂创建。
void | DocumentBuilderFactory.setSchema(Schema schema) 设置将由解析器使用的 Schema，该解析器从此工厂创建。

javax.xml.validation 中 Schema 的使用

返回 Schema 的 javax.xml.validation 中的方法
abstract Schema | SchemaFactory.newSchema() 创建特殊的 Schema 对象。
Schema | SchemaFactory.newSchema(File schema) 解析作为模式的指定 File 并以 Schema 的形式返回它。
Schema | SchemaFactory.newSchema(Source schema) 解析作为模式的指定源并以模式形式返回它。
abstract Schema | SchemaFactory.newSchema(Source[] schemas) 解析作为模式的指定源（或多个源），并以模式形式返回它。
Schema | SchemaFactory.newSchema(URL schema) 解析作为模式的指定 URL 并以 Schema 形式返回它。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.validation.SchemaFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.SchemaFactory
的使用

使用 SchemaFactory 的软件包
javax.xml.validation 此包提供了用于 XML 文档验证的 API。

javax.xml.validation 中 SchemaFactory 的使用

返回 SchemaFactory 的 javax.xml.validation 中的方法
abstract SchemaFactory | SchemaFactoryLoader.newFactory(String schemaLanguage) 创建指定模式语言的新 SchemaFactory 对象。
static SchemaFactory | SchemaFactory.newInstance(String schemaLanguage) 查找支持指定模式语言的 SchemaFactory 的实现并返回它。
static SchemaFactory | SchemaFactory.newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader) 根据类名称获得一个新 SchemaFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.validation.SchemaFactoryLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.SchemaFactoryLoader
的使用

没有 javax.xml.validation.SchemaFactoryLoader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.validation.TypeInfoProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.TypeInfoProvider
的使用

使用 TypeInfoProvider 的软件包
javax.xml.validation 此包提供了用于 XML 文档验证的 API。

javax.xml.validation 中 TypeInfoProvider 的使用

返回 TypeInfoProvider 的 javax.xml.validation 中的方法
abstract  TypeInfoProvider ValidatorHandler.getTypeInfoProvider()
获取此 ValidatorHandler 的 TypeInfoProvider 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.validation.Validator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.Validator
的使用

使用 Validator 的软件包
javax.xml.validation 此包提供了用于 XML 文档验证的 API。

javax.xml.validation 中 Validator 的使用

返回 Validator 的 javax.xml.validation 中的方法
abstract  Validator Schema.newValidator()
创建此 Schema 的新 Validator。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.validation.ValidatorHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.ValidatorHandler
的使用

使用 ValidatorHandler 的软件包
javax.xml.validation 此包提供了用于 XML 文档验证的 API。

javax.xml.validation 中 ValidatorHandler 的使用

返回 ValidatorHandler 的 javax.xml.validation 中的方法
abstract  ValidatorHandler Schema.newValidatorHandler()
创建此 Schema 的新 ValidatorHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.ws (Java 2 Platform SE 6)

 javax.xml.ws
接口
AsyncHandler
Binding
BindingProvider
Dispatch
LogicalMessage
Provider
Response
WebServiceContext
类
Endpoint
Holder
Service
WebServicePermission
枚举
Service.Mode
异常
ProtocolException
WebServiceException
注释类型
BindingType
RequestWrapper
ResponseWrapper
ServiceMode
WebEndpoint
WebFault
WebServiceClient
WebServiceProvider
WebServiceRef
WebServiceRefs


接口 javax.xml.ws.AsyncHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.AsyncHandler
的使用

使用 AsyncHandler 的软件包
javax.xml.ws 此包包含核心 JAX-WS API。

javax.xml.ws 中 AsyncHandler 的使用

参数类型为 AsyncHandler 的 javax.xml.ws 中的方法
 Future<?> Dispatch.invokeAsync(T msg, AsyncHandler<T> handler)
异步调用服务操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.Binding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.Binding
的使用

使用 Binding 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.ws 中 Binding 的使用

返回 Binding 的 javax.xml.ws 中的方法
Binding | BindingProvider.getBinding() 获取此绑定提供者的 Binding。
abstract Binding | Endpoint.getBinding() 返回此端点的绑定。

javax.xml.ws.http 中 Binding 的使用

javax.xml.ws.http 中 Binding 的子接口
 interface HTTPBinding
HTTPBinding 接口是 XML/HTTP 绑定的抽象。

javax.xml.ws.soap 中 Binding 的使用

javax.xml.ws.soap 中 Binding 的子接口
 interface SOAPBinding
SOAPBinding 接口是 SOAP 绑定的抽象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.BindingProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.BindingProvider
的使用

使用 BindingProvider 的软件包
javax.xml.ws 此包包含核心 JAX-WS API。

javax.xml.ws 中 BindingProvider 的使用

javax.xml.ws 中 BindingProvider 的子接口
 interface Dispatch<T>
Dispatch 接口提供对动态调用服务端点操作的支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.BindingType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.BindingType
的使用

没有 javax.xml.ws.BindingType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.Dispatch 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.Dispatch
的使用

使用 Dispatch 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws 中 Dispatch 的使用

返回 Dispatch 的 javax.xml.ws 中的方法
<T> Dispatch<T>
Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
 Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与生成的 JAXB 对象一起使用的 Dispatch 实例。

javax.xml.ws.spi 中 Dispatch 的使用

返回 Dispatch 的 javax.xml.ws.spi 中的方法
abstract
<T> Dispatch<T>
ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
abstract  Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.Endpoint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.Endpoint
的使用

使用 Endpoint 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws 中 Endpoint 的使用

返回 Endpoint 的 javax.xml.ws 中的方法
static Endpoint | Endpoint.create(Object implementor) 创建具有指定实现者对象的端点。
static Endpoint | Endpoint.create(String bindingId, Object implementor) 创建具有指定绑定类型和实现者对象的端点。
static Endpoint | Endpoint.publish(String address, Object implementor) 在给定地址处针对指定的实现者对象创建并发布端点。

javax.xml.ws.spi 中 Endpoint 的使用

返回 Endpoint 的 javax.xml.ws.spi 中的方法
abstract Endpoint | Provider.createAndPublishEndpoint(String address, Object implementor) 创建和发布具有指定地址和实现对象的端点对象。
abstract Endpoint | Provider.createEndpoint(String bindingId, Object implementor) 创建具有提供的绑定和实现对象的端点对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.Holder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.Holder
的使用

没有 javax.xml.ws.Holder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.LogicalMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.LogicalMessage
的使用

使用 LogicalMessage 的软件包
javax.xml.ws.handler 该包定义用于消息处理程序的 API。

javax.xml.ws.handler 中 LogicalMessage 的使用

返回 LogicalMessage 的 javax.xml.ws.handler 中的方法
 LogicalMessage LogicalMessageContext.getMessage()
从此消息上下文中获得消息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.ProtocolException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.ProtocolException
的使用

使用 ProtocolException 的软件包
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.ws.http 中 ProtocolException 的使用

javax.xml.ws.http 中 ProtocolException 的子类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 ProtocolException 的使用

javax.xml.ws.soap 中 ProtocolException 的子类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.Provider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.Provider
的使用

没有 javax.xml.ws.Provider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.RequestWrapper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.RequestWrapper
的使用

没有 javax.xml.ws.RequestWrapper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.Response 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.Response
的使用

使用 Response 的软件包
javax.xml.ws 此包包含核心 JAX-WS API。

javax.xml.ws 中 Response 的使用

返回 Response 的 javax.xml.ws 中的方法
 Response<T> Dispatch.invokeAsync(T msg)
异步调用服务操作。

参数类型为 Response 的 javax.xml.ws 中的方法
 void AsyncHandler.handleResponse(Response<T> res)
当可以获得对异步操作的响应时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.ResponseWrapper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.ResponseWrapper
的使用

没有 javax.xml.ws.ResponseWrapper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.Service 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.Service
的使用

使用 Service 的软件包
javax.xml.ws 此包包含核心 JAX-WS API。

javax.xml.ws 中 Service 的使用

返回 Service 的 javax.xml.ws 中的方法
static Service | Service.create(QName serviceName) 创建 Service 实例。
static Service | Service.create(URL wsdlDocumentLocation, QName serviceName) 创建 Service 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.Service.Mode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.Service.Mode
的使用

使用 Service.Mode 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws 中 Service.Mode 的使用

返回 Service.Mode 的 javax.xml.ws 中的方法
static Service.Mode | Service.Mode.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Service.Mode[] | Service.Mode.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Service.Mode 的 javax.xml.ws 中的方法
<T> Dispatch<T>
Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
 Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与生成的 JAXB 对象一起使用的 Dispatch 实例。

javax.xml.ws.spi 中 Service.Mode 的使用

参数类型为 Service.Mode 的 javax.xml.ws.spi 中的方法
abstract
<T> Dispatch<T>
ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
abstract  Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.ServiceMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.ServiceMode
的使用

没有 javax.xml.ws.ServiceMode 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.WebEndpoint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebEndpoint
的使用

没有 javax.xml.ws.WebEndpoint 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.WebFault 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebFault
的使用

没有 javax.xml.ws.WebFault 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.WebServiceClient 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServiceClient
的使用

没有 javax.xml.ws.WebServiceClient 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.WebServiceContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.WebServiceContext
的使用

没有 javax.xml.ws.WebServiceContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.WebServiceException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServiceException
的使用

使用 WebServiceException 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.ws 中 WebServiceException 的使用

javax.xml.ws 中 WebServiceException 的子类
 class ProtocolException
ProtocolException 类是与特定协议绑定有关的异常的基类。

javax.xml.ws.http 中 WebServiceException 的使用

javax.xml.ws.http 中 WebServiceException 的子类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 WebServiceException 的使用

javax.xml.ws.soap 中 WebServiceException 的子类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.WebServicePermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServicePermission
的使用

没有 javax.xml.ws.WebServicePermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.WebServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServiceProvider
的使用

没有 javax.xml.ws.WebServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.WebServiceRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServiceRef
的使用

没有 javax.xml.ws.WebServiceRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.WebServiceRefs 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServiceRefs
的使用

没有 javax.xml.ws.WebServiceRefs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.ws.handler (Java 2 Platform SE 6)

 javax.xml.ws.handler
接口
Handler
HandlerResolver
LogicalHandler
LogicalMessageContext
MessageContext
PortInfo
枚举
MessageContext.Scope


接口 javax.xml.ws.handler.Handler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.Handler
的使用

使用 Handler 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws 中 Handler 的使用

返回变量类型为 Handler 的类型的 javax.xml.ws 中的方法
 List<Handler> Binding.getHandlerChain()
获取协议绑定实例处理程序链的副本。

类型变量类型为 Handler 的 javax.xml.ws 中的方法参数
 void Binding.setHandlerChain(List<Handler> chain)
设置协议绑定实例的处理程序链。

javax.xml.ws.handler 中 Handler 的使用

javax.xml.ws.handler 中 Handler 的子接口
 interface LogicalHandler<C extends LogicalMessageContext>
LogicalHandler 扩展了 Handler，以便为消息上下文参数提供输入安全性。

返回变量类型为 Handler 的类型的 javax.xml.ws.handler 中的方法
 List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
获取指定端口的处理程序链。

javax.xml.ws.handler.soap 中 Handler 的使用

javax.xml.ws.handler.soap 中 Handler 的子接口
 interface SOAPHandler<T extends SOAPMessageContext>
SOAPHandler 类扩展了 Handler，以便为消息上下文参数提供输入安全性，并添加了一个方法，以访问可能由该处理程序处理的头。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.handler.HandlerResolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.HandlerResolver
的使用

使用 HandlerResolver 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws 中 HandlerResolver 的使用

返回 HandlerResolver 的 javax.xml.ws 中的方法
 HandlerResolver Service.getHandlerResolver()
返回已配置的处理程序解析器。

参数类型为 HandlerResolver 的 javax.xml.ws 中的方法
 void Service.setHandlerResolver(HandlerResolver handlerResolver)
设置此 Service 实例的 HandlerResolver。

javax.xml.ws.spi 中 HandlerResolver 的使用

返回 HandlerResolver 的 javax.xml.ws.spi 中的方法
abstract  HandlerResolver ServiceDelegate.getHandlerResolver()
返回已配置的处理程序解析器。

参数类型为 HandlerResolver 的 javax.xml.ws.spi 中的方法
abstract  void ServiceDelegate.setHandlerResolver(HandlerResolver handlerResolver)
为此 Service 实例设置 HandlerResolver。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.handler.LogicalHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.LogicalHandler
的使用

没有 javax.xml.ws.handler.LogicalHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.handler.LogicalMessageContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.LogicalMessageContext
的使用

使用 LogicalMessageContext 的软件包
javax.xml.ws.handler 该包定义用于消息处理程序的 API。

javax.xml.ws.handler 中 LogicalMessageContext 的使用

类型参数类型为 LogicalMessageContext 的 javax.xml.ws.handler 中的类
 interface LogicalHandler<C extends LogicalMessageContext>
LogicalHandler 扩展了 Handler，以便为消息上下文参数提供输入安全性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.handler.MessageContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.MessageContext
的使用

使用 MessageContext 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws 中 MessageContext 的使用

返回 MessageContext 的 javax.xml.ws 中的方法
 MessageContext WebServiceContext.getMessageContext()
调用此方法时，返回正在服务的请求的 MessageContext。

javax.xml.ws.handler 中 MessageContext 的使用

类型参数类型为 MessageContext 的 javax.xml.ws.handler 中的类
 interface Handler<C extends MessageContext>
Handler 接口是 JAX-WS 处理程序的基本接口。

javax.xml.ws.handler 中 MessageContext 的子接口
 interface LogicalMessageContext
LogicalMessageContext 接口扩展了 MessageContext，以访问以与协议无关的 LogicalMessage 形式包含的消息。

参数类型为 MessageContext 的 javax.xml.ws.handler 中的方法
 void Handler.close(MessageContext context)
消息交换模式结束时调用，正好发生在 JAX-WS 运行时指派消息、错误或异常之前。

javax.xml.ws.handler.soap 中 MessageContext 的使用

javax.xml.ws.handler.soap 中 MessageContext 的子接口
 interface SOAPMessageContext
接口 SOAPMessageContext 提供对 RPC 请求或响应的 SOAP 消息的访问。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.handler.MessageContext.Scope 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.handler.MessageContext.Scope
的使用

使用 MessageContext.Scope 的软件包
javax.xml.ws.handler 该包定义用于消息处理程序的 API。

javax.xml.ws.handler 中 MessageContext.Scope 的使用

返回 MessageContext.Scope 的 javax.xml.ws.handler 中的方法
MessageContext.Scope | MessageContext.getScope(String name) 获得属性的作用域。
static MessageContext.Scope | MessageContext.Scope.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MessageContext.Scope[] | MessageContext.Scope.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 MessageContext.Scope 的 javax.xml.ws.handler 中的方法
 void MessageContext.setScope(String name, MessageContext.Scope scope)
设置属性的作用域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.handler.PortInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.PortInfo
的使用

使用 PortInfo 的软件包
javax.xml.ws.handler 该包定义用于消息处理程序的 API。

javax.xml.ws.handler 中 PortInfo 的使用

参数类型为 PortInfo 的 javax.xml.ws.handler 中的方法
 List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
获取指定端口的处理程序链。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.ws.handler.soap (Java 2 Platform SE 6)

 javax.xml.ws.handler.soap
接口
SOAPHandler
SOAPMessageContext


接口 javax.xml.ws.handler.soap.SOAPHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.soap.SOAPHandler
的使用

没有 javax.xml.ws.handler.soap.SOAPHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.ws.handler.soap.SOAPMessageContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.soap.SOAPMessageContext
的使用

使用 SOAPMessageContext 的软件包
javax.xml.ws.handler.soap 该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws.handler.soap 中 SOAPMessageContext 的使用

类型参数类型为 SOAPMessageContext 的 javax.xml.ws.handler.soap 中的类
 interface SOAPHandler<T extends SOAPMessageContext>
SOAPHandler 类扩展了 Handler，以便为消息上下文参数提供输入安全性，并添加了一个方法，以访问可能由该处理程序处理的头。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.ws.http (Java 2 Platform SE 6)

 javax.xml.ws.http
接口
HTTPBinding
异常
HTTPException


接口 javax.xml.ws.http.HTTPBinding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.http.HTTPBinding
的使用

没有 javax.xml.ws.http.HTTPBinding 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.http.HTTPException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.http.HTTPException
的使用

没有 javax.xml.ws.http.HTTPException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.ws.soap (Java 2 Platform SE 6)

 javax.xml.ws.soap
接口
SOAPBinding
异常
SOAPFaultException


接口 javax.xml.ws.soap.SOAPBinding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.soap.SOAPBinding
的使用

没有 javax.xml.ws.soap.SOAPBinding 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.soap.SOAPFaultException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.soap.SOAPFaultException
的使用

没有 javax.xml.ws.soap.SOAPFaultException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.ws.spi (Java 2 Platform SE 6)

 javax.xml.ws.spi
类
Provider
ServiceDelegate


类 javax.xml.ws.spi.Provider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.spi.Provider
的使用

使用 Provider 的软件包
javax.xml.ws.spi 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws.spi 中 Provider 的使用

返回 Provider 的 javax.xml.ws.spi 中的方法
static Provider Provider.provider()
创建一个新的提供者对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.ws.spi.ServiceDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.spi.ServiceDelegate
的使用

使用 ServiceDelegate 的软件包
javax.xml.ws.spi 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws.spi 中 ServiceDelegate 的使用

返回 ServiceDelegate 的 javax.xml.ws.spi 中的方法
abstract  ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class serviceClass)
创建一个服务委托对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


javax.xml.xpath (Java 2 Platform SE 6)

 javax.xml.xpath
接口
XPath
XPathExpression
XPathFunction
XPathFunctionResolver
XPathVariableResolver
类
XPathConstants
XPathFactory
异常
XPathException
XPathExpressionException
XPathFactoryConfigurationException
XPathFunctionException


接口 javax.xml.xpath.XPath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.xpath.XPath
的使用

使用 XPath 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPath 的使用

返回 XPath 的 javax.xml.xpath 中的方法
abstract  XPath XPathFactory.newXPath()
返回使用实例化 XPathFactory 时确定的底层对象模型的新 XPath。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.xpath.XPathConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathConstants
的使用

没有 javax.xml.xpath.XPathConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.xpath.XPathException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathException
的使用

使用 XPathException 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathException 的使用

javax.xml.xpath 中 XPathException 的子类
class | XPathExpressionException XPathExpressionException 表示 XPath 表达式中的错误。
class | XPathFactoryConfigurationException XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
class | XPathFunctionException XPathFunctionException 表示 XPath 函数的错误。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.xpath.XPathExpression 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.xpath.XPathExpression
的使用

使用 XPathExpression 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathExpression 的使用

返回 XPathExpression 的 javax.xml.xpath 中的方法
 XPathExpression XPath.compile(String expression)
编译 XPath 表达式供以后计算使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.xpath.XPathExpressionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathExpressionException
的使用

使用 XPathExpressionException 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathExpressionException 的使用

javax.xml.xpath 中 XPathExpressionException 的子类
 class XPathFunctionException
XPathFunctionException 表示 XPath 函数的错误。

抛出 XPathExpressionException 的 javax.xml.xpath 中的方法
XPathExpression | XPath.compile(String expression) 编译 XPath 表达式供以后计算使用。
String | XPathExpression.evaluate(InputSource source) 计算指定 InputSource 上下文中编译后的 XPath 表达式并以 String 形式返回结果。
Object | XPathExpression.evaluate(InputSource source, QName returnType) 计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。
String | XPathExpression.evaluate(Object item) 计算指定上下文中编译后的 XPath 表达式并以 String 形式返回结果。
Object | XPathExpression.evaluate(Object item, QName returnType) 计算指定上下文中的 XPath 表达式并返回指定类型的结果。
String | XPath.evaluate(String expression, InputSource source) 计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。
Object | XPath.evaluate(String expression, InputSource source, QName returnType) 计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。
String | XPath.evaluate(String expression, Object item) 计算指定上下文中的 XPath 表达式并返回 String 形式的结果。
Object | XPath.evaluate(String expression, Object item, QName returnType) 计算指定上下文中的 XPath 表达式并返回指定类型的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.xpath.XPathFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathFactory
的使用

使用 XPathFactory 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathFactory 的使用

返回 XPathFactory 的 javax.xml.xpath 中的方法
static XPathFactory | XPathFactory.newInstance() 获取使用默认对象模型 DEFAULT_OBJECT_MODEL_URI（即 W3C DOM）的新 XPathFactory 实例。
static XPathFactory | XPathFactory.newInstance(String uri) 获取使用指定对象模型的新 XPathFactory 实例。
static XPathFactory | XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader) 根据工厂类名称获取一个新 XPathFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.xpath.XPathFactoryConfigurationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathFactoryConfigurationException
的使用

使用 XPathFactoryConfigurationException 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathFactoryConfigurationException 的使用

抛出 XPathFactoryConfigurationException 的 javax.xml.xpath 中的方法
abstract boolean | XPathFactory.getFeature(String name) 获取指定功能的状态。
static XPathFactory | XPathFactory.newInstance(String uri) 获取使用指定对象模型的新 XPathFactory 实例。
static XPathFactory | XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader) 根据工厂类名称获取一个新 XPathFactory 实例。
abstract void | XPathFactory.setFeature(String name, boolean value) 设置此工厂所创建的此 XPathFactory 和 XPath 的功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.xpath.XPathFunction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.xpath.XPathFunction
的使用

使用 XPathFunction 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathFunction 的使用

返回 XPathFunction 的 javax.xml.xpath 中的方法
 XPathFunction XPathFunctionResolver.resolveFunction(QName functionName, int arity)
在可用的函数集中查找函数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 javax.xml.xpath.XPathFunctionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathFunctionException
的使用

使用 XPathFunctionException 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathFunctionException 的使用

抛出 XPathFunctionException 的 javax.xml.xpath 中的方法
 Object XPathFunction.evaluate(List args)
计算带指定参数的函数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.xpath.XPathFunctionResolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.xpath.XPathFunctionResolver
的使用

使用 XPathFunctionResolver 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathFunctionResolver 的使用

返回 XPathFunctionResolver 的 javax.xml.xpath 中的方法
 XPathFunctionResolver XPath.getXPathFunctionResolver()
返回当前的函数解析器。

参数类型为 XPathFunctionResolver 的 javax.xml.xpath 中的方法
void | XPath.setXPathFunctionResolver(XPathFunctionResolver resolver) 建立函数解析器。
abstract void | XPathFactory.setXPathFunctionResolver(XPathFunctionResolver resolver) 建立默认函数解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 javax.xml.xpath.XPathVariableResolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.xpath.XPathVariableResolver
的使用

使用 XPathVariableResolver 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathVariableResolver 的使用

返回 XPathVariableResolver 的 javax.xml.xpath 中的方法
 XPathVariableResolver XPath.getXPathVariableResolver()
返回当前的变量解析器。

参数类型为 XPathVariableResolver 的 javax.xml.xpath 中的方法
void | XPath.setXPathVariableResolver(XPathVariableResolver resolver) 建立变量解析器。
abstract void | XPathFactory.setXPathVariableResolver(XPathVariableResolver resolver) 建立默认变量解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.ietf.jgss (Java 2 Platform SE 6)

 org.ietf.jgss
接口
GSSContext
GSSCredential
GSSName
类
ChannelBinding
GSSManager
MessageProp
Oid
异常
GSSException


类 org.ietf.jgss.ChannelBinding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.ietf.jgss.ChannelBinding
的使用

使用 ChannelBinding 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 ChannelBinding 的使用

参数类型为 ChannelBinding 的 org.ietf.jgss 中的方法
 void GSSContext.setChannelBinding(ChannelBinding cb)
设置在上下文创建期间使用的通道绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.ietf.jgss.GSSContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.ietf.jgss.GSSContext
的使用

使用 GSSContext 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 GSSContext 的使用

返回 GSSContext 的 org.ietf.jgss 中的方法
abstract GSSContext | GSSManager.createContext(byte[] interProcessToken) 创建以前导出的上下文的 Factory 方法。
abstract GSSContext | GSSManager.createContext(GSSCredential myCred) 为接受端一方创建上下文的 Factory 方法。
abstract GSSContext | GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.ietf.jgss.GSSCredential 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.ietf.jgss.GSSCredential
的使用

使用 GSSCredential 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 GSSCredential 的使用

返回 GSSCredential 的 org.ietf.jgss 中的方法
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage) 通过一套机制获取凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage) 获取单个机制凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(int usage) 获取默认凭据的 Factory 方法。
GSSCredential | GSSContext.getDelegCred() 获取上下文初始端委托给上下文接受端的凭据。

参数类型为 GSSCredential 的 org.ietf.jgss 中的方法
abstract GSSContext | GSSManager.createContext(GSSCredential myCred) 为接受端一方创建上下文的 Factory 方法。
abstract GSSContext | GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.ietf.jgss.GSSException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.ietf.jgss.GSSException
的使用

使用 GSSException 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 GSSException 的使用

抛出 GSSException 的 org.ietf.jgss 中的方法
byte[] | GSSContext.acceptSecContext(byte[] inToken, int offset, int len) 由上下文接受端在收到同位体的标记后调用。
void | GSSContext.acceptSecContext(InputStream inStream, OutputStream outStream) 由上下文接受端调用，以处理来自使用流的同位体的标记。
void | GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage) 将特定于机制的凭据元素添加到现有的凭据中。
abstract void | GSSManager.addProviderAtEnd(Provider p, Oid mech) 此方法用于向 GSSManager 指示，如果没有其他的提供者支持指定的机制，则应用程序将使用特定的提供者。
abstract void | GSSManager.addProviderAtFront(Provider p, Oid mech) 此方法用来向 GSSManager 表示，当支持是指定的机制所需要的支持时，应用程序希望优先于其他所有提供者使用特定的提供者。
GSSName | GSSName.canonicalize(Oid mech) 创建一个针对某种机制而规范化的名称。
abstract GSSContext | GSSManager.createContext(byte[] interProcessToken) 创建以前导出的上下文的 Factory 方法。
abstract GSSContext | GSSManager.createContext(GSSCredential myCred) 为接受端一方创建上下文的 Factory 方法。
abstract GSSContext | GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage) 通过一套机制获取凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage) 获取单个机制凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(int usage) 获取默认凭据的 Factory 方法。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType) 将包含名称的字节数组从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType, Oid mech) 将包含名称的字符串数组从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType) 将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType, Oid mech) 将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
void | GSSContext.dispose() 释放存储在上下文对象中并且使上下文无效的系统资源和加密信息。
void | GSSCredential.dispose() 释放 GSSCredential 对象可能包含的任何敏感信息。
boolean | GSSName.equals(GSSName another) 比较两个 GSSName 对象，以确定它们是否指的是同一个实体。
byte[] | GSSContext.export() 导出此上下文，以便使其他进程能够导入它。
byte[] | GSSName.export() 返回机制名称 (MN) 的规范化连续字节表示形式，适合通过授权的功能进行直接的、逐字节比较。
GSSCredential | GSSContext.getDelegCred() 获取上下文初始端委托给上下文接受端的凭据。
byte[] | Oid.getDER() 返回此 oid 对象的全部 ASN.1 DER 编码，其中包括标记和长度。
Oid | GSSContext.getMech() 确定什么机制正用于此上下文。
Oid[] | GSSCredential.getMechs() 返回受此凭据支持的机制的列表。
byte[] | GSSContext.getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp) 返回包含所提供消息的加密消息完整性代码 (MIC) 的标记，以便传输到同位体应用程序。
void | GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
GSSName | GSSCredential.getName() 检索凭据所维护的实体的名称。
GSSName | GSSCredential.getName(Oid mech) 检索凭据所维护的实体的 Mechanism Name（机制名称）。
abstract Oid[] | GSSManager.getNamesForMech(Oid mech) 然后返回由指定的机制所支持的名称类型。
int | GSSCredential.getRemainingAcceptLifetime(Oid mech) 返回凭据以秒为单位的生存期，以便能够继续使用指定的机制接受安全上下文。
int | GSSCredential.getRemainingInitLifetime(Oid mech) 返回凭据以秒为单位的生存期，以便能够继续使用指定的机制初始化安全上下文。
int | GSSCredential.getRemainingLifetime() 返回凭据所剩余的以秒为单位的生存期。
GSSName | GSSContext.getSrcName() 返回上下文初始端的名称。
Oid | GSSName.getStringNameType() 返回此名称的可打印表示形式的名称类型，此名称可从 toString 方法中获取。
GSSName | GSSContext.getTargName() 返回上下文接受端的名称。
int | GSSCredential.getUsage() 返回凭据使用模式。
int | GSSCredential.getUsage(Oid mech) 返回特定机制的凭据使用模式。
int | GSSContext.getWrapSizeLimit(int qop, boolean confReq, int maxTokenSize) 用来确定可以传输给 wrap 的消息的大小限制。
byte[] | GSSContext.initSecContext(byte[] inputBuf, int offset, int len) 由上下文初始端调用，以启动上下文创建阶段，处理由同位体的 acceptSecContext 方法生成的任何标记。
int | GSSContext.initSecContext(InputStream inStream, OutputStream outStream) 由上下文初始端调用，以启动上下文的创建阶段，处理由使用流的同位体的 acceptSecContext 方法生成的任何标记。
boolean | GSSContext.isInitiator() 确定它是否为上下文初始端。
boolean | GSSContext.isTransferable() 确定通过使用 export 方法，该上下文是否可以传输给其他进程。
void | GSSContext.requestAnonymity(boolean state) 请求不要将初始端的身份泄露给接受端。
void | GSSContext.requestConf(boolean state) 请求针对 wrap 方法启用数据机密性。
void | GSSContext.requestCredDeleg(boolean state) 请求在上下文创建期间将初始端的凭据委托给接受端。
void | GSSContext.requestInteg(boolean state) 请求针对 wrap 和 getMIC 方法启用数据完整性。
void | GSSContext.requestLifetime(int lifetime) 请求上下文以秒为单位的生存期。
void | GSSContext.requestMutualAuth(boolean state) 要求相互验证在上下文创建期间完成。
void | GSSContext.requestReplayDet(boolean state) 请求在上下文创建之后针对 per-message 安全服务启用重放检测。
void | GSSContext.requestSequenceDet(boolean state) 请求在上下文创建之后针对 per-message 安全服务启用序列检查。
void | GSSContext.setChannelBinding(ChannelBinding cb) 设置在上下文创建期间使用的通道绑定。
byte[] | GSSContext.unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp) 用来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp) 通过提供的消息，检查包含在标记参数中的加密的 MIC。
void | GSSContext.verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp) 通过提供的消息，使用流来验证包含在标记参数中的加密的 MIC。
byte[] | GSSContext.wrap(byte[] inBuf, int offset, int len, MessageProp msgProp) 将 per-message 安全服务应用于已创建的安全上下文。
void | GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 将 per-message 安全服务应用于已创建的使用流的安全上下文。

抛出 GSSException 的 org.ietf.jgss 中的构造方法
Oid(byte[] data)
从其 ASN.1 DER 编码中创建 Oid 对象。
Oid(InputStream derOid)
从其 ASN.1 DER 编码中创建 Oid 对象。
Oid(String strOid)
从其整数组件的字符串表示形式中构建 Oid 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.ietf.jgss.GSSManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.ietf.jgss.GSSManager
的使用

使用 GSSManager 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 GSSManager 的使用

返回 GSSManager 的 org.ietf.jgss 中的方法
static GSSManager GSSManager.getInstance()
返回默认的 GSSManager 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.ietf.jgss.GSSName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.ietf.jgss.GSSName
的使用

使用 GSSName 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 GSSName 的使用

返回 GSSName 的 org.ietf.jgss 中的方法
GSSName | GSSName.canonicalize(Oid mech) 创建一个针对某种机制而规范化的名称。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType) 将包含名称的字节数组从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType, Oid mech) 将包含名称的字符串数组从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType) 将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType, Oid mech) 将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
GSSName | GSSCredential.getName() 检索凭据所维护的实体的名称。
GSSName | GSSCredential.getName(Oid mech) 检索凭据所维护的实体的 Mechanism Name（机制名称）。
GSSName | GSSContext.getSrcName() 返回上下文初始端的名称。
GSSName | GSSContext.getTargName() 返回上下文接受端的名称。

参数类型为 GSSName 的 org.ietf.jgss 中的方法
void | GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage) 将特定于机制的凭据元素添加到现有的凭据中。
abstract GSSContext | GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage) 通过一套机制获取凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage) 获取单个机制凭据的 Factory 方法。
boolean | GSSName.equals(GSSName another) 比较两个 GSSName 对象，以确定它们是否指的是同一个实体。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.ietf.jgss.MessageProp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.ietf.jgss.MessageProp
的使用

使用 MessageProp 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 MessageProp 的使用

参数类型为 MessageProp 的 org.ietf.jgss 中的方法
byte[] | GSSContext.getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp) 返回包含所提供消息的加密消息完整性代码 (MIC) 的标记，以便传输到同位体应用程序。
void | GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
byte[] | GSSContext.unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp) 用来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp) 通过提供的消息，检查包含在标记参数中的加密的 MIC。
void | GSSContext.verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp) 通过提供的消息，使用流来验证包含在标记参数中的加密的 MIC。
byte[] | GSSContext.wrap(byte[] inBuf, int offset, int len, MessageProp msgProp) 将 per-message 安全服务应用于已创建的安全上下文。
void | GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 将 per-message 安全服务应用于已创建的使用流的安全上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.ietf.jgss.Oid 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.ietf.jgss.Oid
的使用

使用 Oid 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 Oid 的使用

声明为 Oid 的 org.ietf.jgss 中的字段
static Oid | GSSName.NT_ANONYMOUS 表示匿名实体的名称类型。
static Oid | GSSName.NT_EXPORT_NAME 用来表示通过导出方法产生的导出名称的名称类型。
static Oid | GSSName.NT_HOSTBASED_SERVICE 表示基于主机的服务名称格式的 Oid。
static Oid | GSSName.NT_MACHINE_UID_NAME 名称类型，表示与本地系统上的用户对应的数值型用户标识符。
static Oid | GSSName.NT_STRING_UID_NAME 名称类型，指示一个由数字组成的字符串，表示本地系统上用户的数值型用户标识符。
static Oid | GSSName.NT_USER_NAME 名称类型，表示在本地系统上指定的用户。

返回 Oid 的 org.ietf.jgss 中的方法
Oid | GSSContext.getMech() 确定什么机制正用于此上下文。
Oid[] | GSSCredential.getMechs() 返回受此凭据支持的机制的列表。
abstract Oid[] | GSSManager.getMechs() 返回一个可通过此 GSSManager 提供给 GSS-API 调用者的机制列表。
abstract Oid[] | GSSManager.getMechsForName(Oid nameType) 返回支持指定的名称类型的机制的列表。
abstract Oid[] | GSSManager.getNamesForMech(Oid mech) 然后返回由指定的机制所支持的名称类型。
Oid | GSSName.getStringNameType() 返回此名称的可打印表示形式的名称类型，此名称可从 toString 方法中获取。

参数类型为 Oid 的 org.ietf.jgss 中的方法
void | GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage) 将特定于机制的凭据元素添加到现有的凭据中。
abstract void | GSSManager.addProviderAtEnd(Provider p, Oid mech) 此方法用于向 GSSManager 指示，如果没有其他的提供者支持指定的机制，则应用程序将使用特定的提供者。
abstract void | GSSManager.addProviderAtFront(Provider p, Oid mech) 此方法用来向 GSSManager 表示，当支持是指定的机制所需要的支持时，应用程序希望优先于其他所有提供者使用特定的提供者。
GSSName | GSSName.canonicalize(Oid mech) 创建一个针对某种机制而规范化的名称。
boolean | Oid.containedIn(Oid[] oids) 一种实用工具方法，可测试此 Oid 值是否包含在所提供的 Oid 数组中。
abstract GSSContext | GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage) 通过一套机制获取凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage) 获取单个机制凭据的 Factory 方法。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType) 将包含名称的字节数组从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType, Oid mech) 将包含名称的字符串数组从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType) 将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType, Oid mech) 将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
abstract Oid[] | GSSManager.getMechsForName(Oid nameType) 返回支持指定的名称类型的机制的列表。
GSSName | GSSCredential.getName(Oid mech) 检索凭据所维护的实体的 Mechanism Name（机制名称）。
abstract Oid[] | GSSManager.getNamesForMech(Oid mech) 然后返回由指定的机制所支持的名称类型。
int | GSSCredential.getRemainingAcceptLifetime(Oid mech) 返回凭据以秒为单位的生存期，以便能够继续使用指定的机制接受安全上下文。
int | GSSCredential.getRemainingInitLifetime(Oid mech) 返回凭据以秒为单位的生存期，以便能够继续使用指定的机制初始化安全上下文。
int | GSSCredential.getUsage(Oid mech) 返回特定机制的凭据使用模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.CORBA (Java 2 Platform SE 6)

 org.omg.CORBA
接口
ARG_IN
ARG_INOUT
ARG_OUT
BAD_POLICY
BAD_POLICY_TYPE
BAD_POLICY_VALUE
CTX_RESTRICT_SCOPE
Current
CurrentOperations
CustomMarshal
DataInputStream
DataOutputStream
DomainManager
DomainManagerOperations
DynAny
DynArray
DynEnum
DynFixed
DynSequence
DynStruct
DynUnion
DynValue
IDLType
IDLTypeOperations
IRObject
IRObjectOperations
Object
OMGVMCID
Policy
PolicyOperations
PRIVATE_MEMBER
PUBLIC_MEMBER
UNSUPPORTED_POLICY
UNSUPPORTED_POLICY_VALUE
VM_ABSTRACT
VM_CUSTOM
VM_NONE
VM_TRUNCATABLE
类
_IDLTypeStub
_PolicyStub
Any
AnyHolder
AnySeqHelper
AnySeqHolder
BooleanHolder
BooleanSeqHelper
BooleanSeqHolder
ByteHolder
CharHolder
CharSeqHelper
CharSeqHolder
CompletionStatus
CompletionStatusHelper
Context
ContextList
CurrentHelper
CurrentHolder
DefinitionKind
DefinitionKindHelper
DoubleHolder
DoubleSeqHelper
DoubleSeqHolder
DynamicImplementation
Environment
ExceptionList
FieldNameHelper
FixedHolder
FloatHolder
FloatSeqHelper
FloatSeqHolder
IdentifierHelper
IDLTypeHelper
IntHolder
LocalObject
LongHolder
LongLongSeqHelper
LongLongSeqHolder
LongSeqHelper
LongSeqHolder
NamedValue
NameValuePair
NameValuePairHelper
NVList
ObjectHelper
ObjectHolder
OctetSeqHelper
OctetSeqHolder
ORB
ParameterMode
ParameterModeHelper
ParameterModeHolder
PolicyErrorCodeHelper
PolicyErrorHelper
PolicyErrorHolder
PolicyHelper
PolicyHolder
PolicyListHelper
PolicyListHolder
PolicyTypeHelper
Principal
PrincipalHolder
RepositoryIdHelper
Request
ServerRequest
ServiceDetail
ServiceDetailHelper
ServiceInformation
ServiceInformationHelper
ServiceInformationHolder
SetOverrideType
SetOverrideTypeHelper
ShortHolder
ShortSeqHelper
ShortSeqHolder
StringHolder
StringSeqHelper
StringSeqHolder
StringValueHelper
StructMember
StructMemberHelper
TCKind
TypeCode
TypeCodeHolder
ULongLongSeqHelper
ULongLongSeqHolder
ULongSeqHelper
ULongSeqHolder
UnionMember
UnionMemberHelper
UnknownUserExceptionHelper
UnknownUserExceptionHolder
UShortSeqHelper
UShortSeqHolder
ValueBaseHelper
ValueBaseHolder
ValueMember
ValueMemberHelper
VersionSpecHelper
VisibilityHelper
WCharSeqHelper
WCharSeqHolder
WrongTransactionHelper
WrongTransactionHolder
WStringSeqHelper
WStringSeqHolder
WStringValueHelper
异常
ACTIVITY_COMPLETED
ACTIVITY_REQUIRED
BAD_CONTEXT
BAD_INV_ORDER
BAD_OPERATION
BAD_PARAM
BAD_QOS
BAD_TYPECODE
Bounds
CODESET_INCOMPATIBLE
COMM_FAILURE
DATA_CONVERSION
FREE_MEM
IMP_LIMIT
INITIALIZE
INTERNAL
INTF_REPOS
INV_FLAG
INV_IDENT
INV_OBJREF
INV_POLICY
INVALID_ACTIVITY
INVALID_TRANSACTION
MARSHAL
NO_IMPLEMENT
NO_MEMORY
NO_PERMISSION
NO_RESOURCES
NO_RESPONSE
OBJ_ADAPTER
OBJECT_NOT_EXIST
PERSIST_STORE
PolicyError
REBIND
SystemException
TIMEOUT
TRANSACTION_MODE
TRANSACTION_REQUIRED
TRANSACTION_ROLLEDBACK
TRANSACTION_UNAVAILABLE
TRANSIENT
UNKNOWN
UnknownUserException
UserException
WrongTransaction


类 org.omg.CORBA._IDLTypeStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA._IDLTypeStub
的使用

没有 org.omg.CORBA._IDLTypeStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA._PolicyStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA._PolicyStub
的使用

没有 org.omg.CORBA._PolicyStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ACTIVITY_COMPLETED 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ACTIVITY_COMPLETED
的使用

没有 org.omg.CORBA.ACTIVITY_COMPLETED 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ACTIVITY_REQUIRED 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ACTIVITY_REQUIRED
的使用

没有 org.omg.CORBA.ACTIVITY_REQUIRED 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.Any 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Any
的使用

使用 Any 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.CORBA 中 Any 的使用

声明为 Any 的 org.omg.CORBA 中的字段
Any | UnknownUserException.except 包含由服务器抛出的实际用户异常的 Any 实例。
Any | UnionMember.label 此 UnionMember 对象所描述的 union 成员的标签。
Any | AnyHolder.value 此 AnyHolder 对象保存的 Any 值。
Any[] | AnySeqHolder.value
Any | NameValuePair.value 将通过此 NameValuePair 对象与某一名称关联的值。

返回 Any 的 org.omg.CORBA 中的方法
abstract Any | Request.add_in_arg() 创建一个输入参数，并将它添加到此 Request 对象中。
abstract Any | Request.add_inout_arg() 将一个输入/输出参数添加到此 Request 对象中。
abstract Any | Request.add_named_in_arg(String name) 使用给定名称创建一个输入参数，并将它添加到此 Request 对象中。
abstract Any | Request.add_named_inout_arg(String name) 将具有给定名称的输入/输出参数添加到此 Request 对象中。
abstract Any | Request.add_named_out_arg(String name) 将具有给定名称的输出参数添加到此 Request 对象中。
abstract Any | Request.add_out_arg() 将输出参数添加到此 Request 对象中。
abstract Any | ORB.create_any() 创建一个 IDL Any 对象，初始化后该对象包含一个 kind 字段被设置为 TCKind.tc_null 的 Typecode 对象。
abstract Any | Any.extract_any() 提取此 Any 对象 value 字段中的 Any 对象。
static Any[] | AnySeqHelper.extract(Any a)
Any | DynAny.get_any() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Any。
Any[] | DynArray.get_elements() 已过时。 返回此数组所有元素的值。
Any[] | DynSequence.get_elements() 已过时。 返回此 sequence 中每个元素的值。
abstract Any | TypeCode.member_label(int index) 检索给定索引标识的 union 成员的标签。
Any | DataInputStream.read_any() 从输入流读取 IDL Any 值。
static Any[] | AnySeqHelper.read(InputStream istream)
abstract Any | Request.return_value() 返回包含方法结果值的 Any 对象。
Any | DynAny.to_any() 已过时。 将 DynAny 对象转换成 Any 对象。
abstract Any | NamedValue.value() 检索此 NamedValue 对象的值。

参数类型为 Any 的 org.omg.CORBA 中的方法
abstract  NamedValue NVList.add_value(String item_name, Any val, int flags)
创建一个新的 NamedValue 对象，使用给定名称、值和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
 DynAny ORB.create_dyn_any(Any value)
已过时。 使用新的 DynAnyFactory API 代替
abstract  NamedValue ORB.create_named_value(String s, Any any, int flags)
使用给定名称、值和参数模式标志创建一个 NamedValue 对象。
 Policy ORB.create_policy(int type, Any val)
可以调用此方法创建特定类型的新策略对象实例，并且其类型具有指定的初始状态。
abstract  boolean Any.equal(Any a)
检查此 Any 对象与给定 Any 对象是否相等。
 void ServerRequest.except(Any any)
已过时。 使用 set_exception()
static Any[] AnySeqHelper.extract(Any a)
static boolean[] BooleanSeqHelper.extract(Any a)
static char[] CharSeqHelper.extract(Any a)
static CompletionStatus CompletionStatusHelper.extract(Any a)
static Current CurrentHelper.extract(Any a)
static DefinitionKind DefinitionKindHelper.extract(Any a)
static double[] DoubleSeqHelper.extract(Any a)
static String FieldNameHelper.extract(Any a)
static float[] FloatSeqHelper.extract(Any a)
static IDLType IDLTypeHelper.extract(Any a)
static String IdentifierHelper.extract(Any a)
static long[] LongLongSeqHelper.extract(Any a)
static int[] LongSeqHelper.extract(Any a)
static NameValuePair NameValuePairHelper.extract(Any a)
static Object ObjectHelper.extract(Any a)
static byte[] OctetSeqHelper.extract(Any a)
static ParameterMode ParameterModeHelper.extract(Any a)
static short PolicyErrorCodeHelper.extract(Any a)
static PolicyError PolicyErrorHelper.extract(Any a)
static Policy PolicyHelper.extract(Any a)
static Policy[] PolicyListHelper.extract(Any a)
static int PolicyTypeHelper.extract(Any a)
static String RepositoryIdHelper.extract(Any a)
static ServiceDetail ServiceDetailHelper.extract(Any a)
static ServiceInformation ServiceInformationHelper.extract(Any a)
static SetOverrideType SetOverrideTypeHelper.extract(Any a)
static short[] ShortSeqHelper.extract(Any a)
static String[] StringSeqHelper.extract(Any a)
static String StringValueHelper.extract(Any a)
static StructMember StructMemberHelper.extract(Any a)
static long[] ULongLongSeqHelper.extract(Any a)
static int[] ULongSeqHelper.extract(Any a)
static short[] UShortSeqHelper.extract(Any a)
static UnionMember UnionMemberHelper.extract(Any a)
static UnknownUserException UnknownUserExceptionHelper.extract(Any a)
static Serializable ValueBaseHelper.extract(Any a)
static ValueMember ValueMemberHelper.extract(Any a)
static String VersionSpecHelper.extract(Any a)
static short VisibilityHelper.extract(Any a)
static char[] WCharSeqHelper.extract(Any a)
static String[] WStringSeqHelper.extract(Any a)
static String WStringValueHelper.extract(Any a)
static WrongTransaction WrongTransactionHelper.extract(Any a)
 void DynAny.from_any(Any value)
已过时。 根据 Any 对象生成一个 DynAny 对象。
abstract  void Any.insert_any(Any a)
将给定 Any 对象插入此 Any 对象的 value 字段。
 void DynAny.insert_any(Any value)
已过时。 插入给定 org.omg.CORBA.Any 对象作为此 DynAny 对象的值。
static void AnySeqHelper.insert(Any a, Any[] that)
static void AnySeqHelper.insert(Any a, Any[] that)
static void BooleanSeqHelper.insert(Any a, boolean[] that)
static void OctetSeqHelper.insert(Any a, byte[] that)
static void CharSeqHelper.insert(Any a, char[] that)
static void WCharSeqHelper.insert(Any a, char[] that)
static void CompletionStatusHelper.insert(Any a, CompletionStatus that)
static void CurrentHelper.insert(Any a, Current that)
static void DefinitionKindHelper.insert(Any a, DefinitionKind that)
static void DoubleSeqHelper.insert(Any a, double[] that)
static void FloatSeqHelper.insert(Any a, float[] that)
static void IDLTypeHelper.insert(Any a, IDLType that)
static void PolicyTypeHelper.insert(Any a, int that)
static void LongSeqHelper.insert(Any a, int[] that)
static void ULongSeqHelper.insert(Any a, int[] that)
static void LongLongSeqHelper.insert(Any a, long[] that)
static void ULongLongSeqHelper.insert(Any a, long[] that)
static void NameValuePairHelper.insert(Any a, NameValuePair that)
static void ObjectHelper.insert(Any a, Object that)
static void ParameterModeHelper.insert(Any a, ParameterMode that)
static void PolicyHelper.insert(Any a, Policy that)
static void PolicyListHelper.insert(Any a, Policy[] that)
static void PolicyErrorHelper.insert(Any a, PolicyError that)
static void ValueBaseHelper.insert(Any a, Serializable that)
static void ServiceDetailHelper.insert(Any a, ServiceDetail that)
static void ServiceInformationHelper.insert(Any a, ServiceInformation that)
static void SetOverrideTypeHelper.insert(Any a, SetOverrideType that)
static void PolicyErrorCodeHelper.insert(Any a, short that)
static void VisibilityHelper.insert(Any a, short that)
static void ShortSeqHelper.insert(Any a, short[] that)
static void UShortSeqHelper.insert(Any a, short[] that)
static void FieldNameHelper.insert(Any a, String that)
static void IdentifierHelper.insert(Any a, String that)
static void RepositoryIdHelper.insert(Any a, String that)
static void StringValueHelper.insert(Any a, String that)
static void VersionSpecHelper.insert(Any a, String that)
static void WStringValueHelper.insert(Any a, String that)
static void StringSeqHelper.insert(Any a, String[] that)
static void WStringSeqHelper.insert(Any a, String[] that)
static void StructMemberHelper.insert(Any a, StructMember that)
static void UnionMemberHelper.insert(Any a, UnionMember that)
static void UnknownUserExceptionHelper.insert(Any a, UnknownUserException that)
static void ValueMemberHelper.insert(Any a, ValueMember that)
static void WrongTransactionHelper.insert(Any a, WrongTransaction that)
 void ServerRequest.result(Any any)
已过时。 使用方法 set_result
 void DynArray.set_elements(Any[] value)
已过时。 将此 DynArray 对象的值设置为给定数组。
 void DynSequence.set_elements(Any[] value)
已过时。 使用给定数组设置此 sequence 中所有元素的值。
 void ServerRequest.set_exception(Any any)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
abstract  void Context.set_one_value(String propname, Any propvalue)
创建一个 NamedValue 对象，并将它添加到此 Context 对象中。
 void ServerRequest.set_result(Any any)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
 void DataOutputStream.write_any_array(Any[] seq, int offset, int length)
将 IDL Any 数组中从 offset 处开始的 length 个元素写入输出流。
 void DataOutputStream.write_any(Any value)
将 Any 值写入输出流。
static void AnySeqHelper.write(OutputStream ostream, Any[] value)

参数类型为 Any 的 org.omg.CORBA 中的构造方法
AnyHolder(Any initial)
为给定的 Any 对象构造一个新 AnyHolder 对象。
AnySeqHolder(Any[] initialValue)
NameValuePair(String __id, Any __value)
构造一个 NameValuePair 对象，该对象将给定名称与给定 org.omg.CORBA.Any 对象关联。
UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
构造一个新的 UnionMember 对象，将其字段初始化为给定值。
UnknownUserException(Any a)
构造一个包含给定 Any 对象的 UnknownUserException 对象。

org.omg.CORBA.portable 中 Any 的使用

返回 Any 的 org.omg.CORBA.portable 中的方法
abstract  Any InputStream.read_any()
从此输入流中读取一个 Any。

参数类型为 Any 的 org.omg.CORBA.portable 中的方法
abstract  void OutputStream.write_any(Any value)
在此输出流上写入一个 Any。

org.omg.CosNaming 中 Any 的使用

参数类型为 Any 的 org.omg.CosNaming 中的方法
static Binding | BindingHelper.extract(Any a)
static BindingIterator | BindingIteratorHelper.extract(Any a)
static Binding[] | BindingListHelper.extract(Any a)
static BindingType | BindingTypeHelper.extract(Any a)
static String | IstringHelper.extract(Any a)
static NameComponent | NameComponentHelper.extract(Any a)
static NameComponent[] | NameHelper.extract(Any a)
static NamingContextExt | NamingContextExtHelper.extract(Any a)
static NamingContext | NamingContextHelper.extract(Any a)
static void | BindingHelper.insert(Any a, Binding that)
static void | BindingListHelper.insert(Any a, Binding[] that)
static void | BindingIteratorHelper.insert(Any a, BindingIterator that)
static void | BindingTypeHelper.insert(Any a, BindingType that)
static void | NameComponentHelper.insert(Any a, NameComponent that)
static void | NameHelper.insert(Any a, NameComponent[] that)
static void | NamingContextHelper.insert(Any a, NamingContext that)
static void | NamingContextExtHelper.insert(Any a, NamingContextExt that)
static void | IstringHelper.insert(Any a, String that)

org.omg.CosNaming.NamingContextExtPackage 中 Any 的使用

参数类型为 Any 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
static String | AddressHelper.extract(Any a)
static InvalidAddress | InvalidAddressHelper.extract(Any a)
static String | StringNameHelper.extract(Any a)
static String | URLStringHelper.extract(Any a)
static void | InvalidAddressHelper.insert(Any a, InvalidAddress that)
static void | AddressHelper.insert(Any a, String that)
static void | StringNameHelper.insert(Any a, String that)
static void | URLStringHelper.insert(Any a, String that)

org.omg.CosNaming.NamingContextPackage 中 Any 的使用

参数类型为 Any 的 org.omg.CosNaming.NamingContextPackage 中的方法
static AlreadyBound | AlreadyBoundHelper.extract(Any a)
static CannotProceed | CannotProceedHelper.extract(Any a)
static InvalidName | InvalidNameHelper.extract(Any a)
static NotEmpty | NotEmptyHelper.extract(Any a)
static NotFound | NotFoundHelper.extract(Any a)
static NotFoundReason | NotFoundReasonHelper.extract(Any a)
static void | AlreadyBoundHelper.insert(Any a, AlreadyBound that)
static void | CannotProceedHelper.insert(Any a, CannotProceed that)
static void | InvalidNameHelper.insert(Any a, InvalidName that)
static void | NotEmptyHelper.insert(Any a, NotEmpty that)
static void | NotFoundHelper.insert(Any a, NotFound that)
static void | NotFoundReasonHelper.insert(Any a, NotFoundReason that)

org.omg.Dynamic 中 Any 的使用

声明为 Any 的 org.omg.Dynamic 中的字段
 Any Parameter.argument

参数类型为 Any 的 org.omg.Dynamic 中的构造方法
Parameter(Any _argument, ParameterMode _mode)

org.omg.DynamicAny 中 Any 的使用

声明为 Any 的 org.omg.DynamicAny 中的字段
 Any NameValuePair.value
与名称关联的 Any 值。

返回 Any 的 org.omg.DynamicAny 中的方法
static Any[] | AnySeqHelper.extract(Any a)
Any | DynAnyOperations.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynAnyStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynArrayStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynEnumStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynFixedStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
Any | _DynSequenceStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynStructStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynUnionStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynValueStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
Any | DynValueBoxOperations.get_boxed_value() 以 Any 的形式返回装箱值。
Any[] | DynArrayOperations.get_elements() 返回 DynArray 的元素。
Any[] | DynSequenceOperations.get_elements() 返回序列的元素。
Any[] | _DynArrayStub.get_elements() 返回 DynArray 的元素。
Any[] | _DynSequenceStub.get_elements() 返回序列的元素。
static Any[] | AnySeqHelper.read(InputStream istream)
Any | DynAnyOperations.to_any() 从 DynAny 对象创建 any 值。
Any | _DynAnyStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynArrayStub.to_any() 从 DynAny 对象中创建 any 值。
Any | _DynEnumStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynFixedStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynSequenceStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynStructStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynUnionStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynValueStub.to_any() 从 DynAny 对象创建 any 值。

参数类型为 Any 的 org.omg.DynamicAny 中的方法
DynAny | DynAnyFactoryOperations.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
DynAny | _DynAnyFactoryStub.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
static Any[] | AnySeqHelper.extract(Any a)
static DynAnyFactory | DynAnyFactoryHelper.extract(Any a)
static DynAny | DynAnyHelper.extract(Any a)
static DynAny[] | DynAnySeqHelper.extract(Any a)
static DynArray | DynArrayHelper.extract(Any a)
static DynEnum | DynEnumHelper.extract(Any a)
static DynFixed | DynFixedHelper.extract(Any a)
static DynSequence | DynSequenceHelper.extract(Any a)
static DynStruct | DynStructHelper.extract(Any a)
static DynUnion | DynUnionHelper.extract(Any a)
static DynValue | DynValueHelper.extract(Any a)
static String | FieldNameHelper.extract(Any a)
static NameDynAnyPair | NameDynAnyPairHelper.extract(Any a)
static NameDynAnyPair[] | NameDynAnyPairSeqHelper.extract(Any a)
static NameValuePair | NameValuePairHelper.extract(Any a)
static NameValuePair[] | NameValuePairSeqHelper.extract(Any a)
void | DynAnyOperations.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynAnyStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynArrayStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynEnumStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynFixedStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynSequenceStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynStructStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynUnionStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynValueStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | DynAnyOperations.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynFixedStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_any(Any value) 将 Any 值插入由此 DynAny 表示的 Any 中。
void | _DynStructStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
static void | AnySeqHelper.insert(Any a, Any[] that)
static void | AnySeqHelper.insert(Any a, Any[] that)
static void | DynAnyHelper.insert(Any a, DynAny that)
static void | DynAnySeqHelper.insert(Any a, DynAny[] that)
static void | DynAnyFactoryHelper.insert(Any a, DynAnyFactory that)
static void | DynArrayHelper.insert(Any a, DynArray that)
static void | DynEnumHelper.insert(Any a, DynEnum that)
static void | DynFixedHelper.insert(Any a, DynFixed that)
static void | DynSequenceHelper.insert(Any a, DynSequence that)
static void | DynStructHelper.insert(Any a, DynStruct that)
static void | DynUnionHelper.insert(Any a, DynUnion that)
static void | DynValueHelper.insert(Any a, DynValue that)
static void | NameDynAnyPairHelper.insert(Any a, NameDynAnyPair that)
static void | NameDynAnyPairSeqHelper.insert(Any a, NameDynAnyPair[] that)
static void | NameValuePairHelper.insert(Any a, NameValuePair that)
static void | NameValuePairSeqHelper.insert(Any a, NameValuePair[] that)
static void | FieldNameHelper.insert(Any a, String that)
void | DynValueBoxOperations.set_boxed_value(Any boxed) 使用指定值取代已装箱值。
void | DynArrayOperations.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements(Any[] value) 设置序列的元素。
void | _DynArrayStub.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements(Any[] value) 设置序列的元素。
static void | AnySeqHelper.write(OutputStream ostream, Any[] value)

参数类型为 Any 的 org.omg.DynamicAny 中的构造方法
NameValuePair(String _id, Any _value)

org.omg.DynamicAny.DynAnyFactoryPackage 中 Any 的使用

参数类型为 Any 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static InconsistentTypeCode | InconsistentTypeCodeHelper.extract(Any a)
static void | InconsistentTypeCodeHelper.insert(Any a, InconsistentTypeCode that)

org.omg.DynamicAny.DynAnyPackage 中 Any 的使用

参数类型为 Any 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static InvalidValue | InvalidValueHelper.extract(Any a)
static TypeMismatch | TypeMismatchHelper.extract(Any a)
static void | InvalidValueHelper.insert(Any a, InvalidValue that)
static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)

org.omg.IOP 中 Any 的使用

返回 Any 的 org.omg.IOP 中的方法
Any | CodecOperations.decode_value(byte[] data, TypeCode tc) 基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。
Any | CodecOperations.decode(byte[] data) 基于对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。

参数类型为 Any 的 org.omg.IOP 中的方法
byte[] | CodecOperations.encode_value(Any data) 基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
byte[] | CodecOperations.encode(Any data) 基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
static CodecFactory | CodecFactoryHelper.extract(Any a)
static int | ComponentIdHelper.extract(Any a)
static IOR | IORHelper.extract(Any a)
static TaggedComponent[] | MultipleComponentProfileHelper.extract(Any a)
static int | ProfileIdHelper.extract(Any a)
static ServiceContext | ServiceContextHelper.extract(Any a)
static ServiceContext[] | ServiceContextListHelper.extract(Any a)
static int | ServiceIdHelper.extract(Any a)
static TaggedComponent | TaggedComponentHelper.extract(Any a)
static TaggedProfile | TaggedProfileHelper.extract(Any a)
static void | CodecFactoryHelper.insert(Any a, CodecFactory that)
static void | ComponentIdHelper.insert(Any a, int that)
static void | ProfileIdHelper.insert(Any a, int that)
static void | ServiceIdHelper.insert(Any a, int that)
static void | IORHelper.insert(Any a, IOR that)
static void | ServiceContextHelper.insert(Any a, ServiceContext that)
static void | ServiceContextListHelper.insert(Any a, ServiceContext[] that)
static void | TaggedComponentHelper.insert(Any a, TaggedComponent that)
static void | MultipleComponentProfileHelper.insert(Any a, TaggedComponent[] that)
static void | TaggedProfileHelper.insert(Any a, TaggedProfile that)

org.omg.IOP.CodecFactoryPackage 中 Any 的使用

参数类型为 Any 的 org.omg.IOP.CodecFactoryPackage 中的方法
static UnknownEncoding | UnknownEncodingHelper.extract(Any a)
static void | UnknownEncodingHelper.insert(Any a, UnknownEncoding that)

org.omg.IOP.CodecPackage 中 Any 的使用

参数类型为 Any 的 org.omg.IOP.CodecPackage 中的方法
static FormatMismatch | FormatMismatchHelper.extract(Any a)
static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.extract(Any a)
static TypeMismatch | TypeMismatchHelper.extract(Any a)
static void | FormatMismatchHelper.insert(Any a, FormatMismatch that)
static void | InvalidTypeForEncodingHelper.insert(Any a, InvalidTypeForEncoding that)
static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)

org.omg.Messaging 中 Any 的使用

参数类型为 Any 的 org.omg.Messaging 中的方法
static short | SyncScopeHelper.extract(Any a)
static void | SyncScopeHelper.insert(Any a, short that)

org.omg.PortableInterceptor 中 Any 的使用

返回 Any 的 org.omg.PortableInterceptor 中的方法
Any | CurrentOperations.get_slot(int id) 检索应用程序通过 get_slot 在 PICurrent 中设置的槽数据。
Any | RequestInfoOperations.get_slot(int id) 返回请求域内 PortableInterceptor.Current 给定槽 (slot) 中的数据。
Any | ClientRequestInfoOperations.received_exception() 返回一个 any，它包含要向客户端返回的异常。
Any | RequestInfoOperations.result() 返回一个 any，它包含该操作调用的结果。
Any | ServerRequestInfoOperations.sending_exception() 返回一个 any，它包含将向客户端返回的异常。

参数类型为 Any 的 org.omg.PortableInterceptor 中的方法
Policy | PolicyFactoryOperations.create_policy(int type, Any value) 返回派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。
static int | AdapterManagerIdHelper.extract(Any a)
static String[] | AdapterNameHelper.extract(Any a)
static short | AdapterStateHelper.extract(Any a)
static Current | CurrentHelper.extract(Any a)
static ForwardRequest | ForwardRequestHelper.extract(Any a)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.extract(Any a)
static InvalidSlot | InvalidSlotHelper.extract(Any a)
static String | ORBIdHelper.extract(Any a)
static byte[] | ObjectIdHelper.extract(Any a)
static ObjectReferenceFactory | ObjectReferenceFactoryHelper.extract(Any a)
static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.extract(Any a)
static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.extract(Any a)
static String | ServerIdHelper.extract(Any a)
static void | ObjectIdHelper.insert(Any a, byte[] that)
static void | CurrentHelper.insert(Any a, Current that)
static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
static void | AdapterManagerIdHelper.insert(Any a, int that)
static void | InvalidSlotHelper.insert(Any a, InvalidSlot that)
static void | IORInterceptor_3_0Helper.insert(Any a, IORInterceptor_3_0 that)
static void | ObjectReferenceFactoryHelper.insert(Any a, ObjectReferenceFactory that)
static void | ObjectReferenceTemplateHelper.insert(Any a, ObjectReferenceTemplate that)
static void | ObjectReferenceTemplateSeqHelper.insert(Any a, ObjectReferenceTemplate[] that)
static void | AdapterStateHelper.insert(Any a, short that)
static void | ORBIdHelper.insert(Any a, String that)
static void | ServerIdHelper.insert(Any a, String that)
static void | AdapterNameHelper.insert(Any a, String[] that)
void | CurrentOperations.set_slot(int id, Any data) 在槽中设置数据。
void | ServerRequestInfoOperations.set_slot(int id, Any data) 允许 Interceptor 在请求域中的 PortableInterceptor.Current 内设置槽 (slot)。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Any 的使用

参数类型为 Any 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static DuplicateName | DuplicateNameHelper.extract(Any a)
static InvalidName | InvalidNameHelper.extract(Any a)
static String | ObjectIdHelper.extract(Any a)
static void | DuplicateNameHelper.insert(Any a, DuplicateName that)
static void | InvalidNameHelper.insert(Any a, InvalidName that)
static void | ObjectIdHelper.insert(Any a, String that)

org.omg.PortableServer 中 Any 的使用

参数类型为 Any 的 org.omg.PortableServer 中的方法
static Current | CurrentHelper.extract(Any a)
static ForwardRequest | ForwardRequestHelper.extract(Any a)
static POA | POAHelper.extract(Any a)
static ServantActivator | ServantActivatorHelper.extract(Any a)
static ServantLocator | ServantLocatorHelper.extract(Any a)
static void | CurrentHelper.insert(Any a, Current that)
static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
static void | POAHelper.insert(Any a, POA that)
static void | ServantActivatorHelper.insert(Any a, ServantActivator that)
static void | ServantLocatorHelper.insert(Any a, ServantLocator that)

org.omg.PortableServer.CurrentPackage 中 Any 的使用

参数类型为 Any 的 org.omg.PortableServer.CurrentPackage 中的方法
static NoContext | NoContextHelper.extract(Any a)
static void | NoContextHelper.insert(Any a, NoContext that)

org.omg.PortableServer.POAManagerPackage 中 Any 的使用

参数类型为 Any 的 org.omg.PortableServer.POAManagerPackage 中的方法
static AdapterInactive | AdapterInactiveHelper.extract(Any a)
static void | AdapterInactiveHelper.insert(Any a, AdapterInactive that)

org.omg.PortableServer.POAPackage 中 Any 的使用

参数类型为 Any 的 org.omg.PortableServer.POAPackage 中的方法
static AdapterAlreadyExists | AdapterAlreadyExistsHelper.extract(Any a)
static AdapterNonExistent | AdapterNonExistentHelper.extract(Any a)
static InvalidPolicy | InvalidPolicyHelper.extract(Any a)
static NoServant | NoServantHelper.extract(Any a)
static ObjectAlreadyActive | ObjectAlreadyActiveHelper.extract(Any a)
static ObjectNotActive | ObjectNotActiveHelper.extract(Any a)
static ServantAlreadyActive | ServantAlreadyActiveHelper.extract(Any a)
static ServantNotActive | ServantNotActiveHelper.extract(Any a)
static WrongAdapter | WrongAdapterHelper.extract(Any a)
static WrongPolicy | WrongPolicyHelper.extract(Any a)
static void | AdapterAlreadyExistsHelper.insert(Any a, AdapterAlreadyExists that)
static void | AdapterNonExistentHelper.insert(Any a, AdapterNonExistent that)
static void | InvalidPolicyHelper.insert(Any a, InvalidPolicy that)
static void | NoServantHelper.insert(Any a, NoServant that)
static void | ObjectAlreadyActiveHelper.insert(Any a, ObjectAlreadyActive that)
static void | ObjectNotActiveHelper.insert(Any a, ObjectNotActive that)
static void | ServantAlreadyActiveHelper.insert(Any a, ServantAlreadyActive that)
static void | ServantNotActiveHelper.insert(Any a, ServantNotActive that)
static void | WrongAdapterHelper.insert(Any a, WrongAdapter that)
static void | WrongPolicyHelper.insert(Any a, WrongPolicy that)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.AnyHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.AnyHolder
的使用

没有 org.omg.CORBA.AnyHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.AnySeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.AnySeqHelper
的使用

没有 org.omg.CORBA.AnySeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.AnySeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.AnySeqHolder
的使用

使用 AnySeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 AnySeqHolder 的使用

参数类型为 AnySeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_any_array(AnySeqHolder seq, int offset, int length)
从输入流读取 IDL Any 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.ARG_IN 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.ARG_IN
的使用

没有 org.omg.CORBA.ARG_IN 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.ARG_INOUT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.ARG_INOUT
的使用

没有 org.omg.CORBA.ARG_INOUT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.ARG_OUT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.ARG_OUT
的使用

没有 org.omg.CORBA.ARG_OUT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_CONTEXT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_CONTEXT
的使用

没有 org.omg.CORBA.BAD_CONTEXT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_INV_ORDER 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_INV_ORDER
的使用

使用 BAD_INV_ORDER 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 BAD_INV_ORDER 的使用

抛出 BAD_INV_ORDER 的 org.omg.CORBA 中的方法
Streamable | Any.extract_Streamable() 从此 Any 对象的 value 字段提取 Streamable。
void | Any.insert_fixed(BigDecimal value, TypeCode type) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_OPERATION 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_OPERATION
的使用

使用 BAD_OPERATION 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 BAD_OPERATION 的使用

抛出 BAD_OPERATION 的 org.omg.CORBA 中的方法
abstract Any | Any.extract_any() 提取此 Any 对象 value 字段中的 Any 对象。
abstract boolean | Any.extract_boolean() 提取此 Any 对象 value 字段中的 boolean 值。
abstract char | Any.extract_char() 提取此 Any 对象 value 字段中的 char 值。
abstract double | Any.extract_double() 提取此 Any 对象 value 字段中的 double 值。
abstract float | Any.extract_float() 提取此 Any 对象 value 字段中的 float 值。
abstract int | Any.extract_long() 提取此 Any 对象 value 字段中的 int 值。
abstract long | Any.extract_longlong() 提取此 Any 对象 value 字段中的 long 值。
abstract Object | Any.extract_Object() 提取此 Any 对象 value 字段中的 org.omg.CORBA.Object。
abstract byte | Any.extract_octet() 提取此 Any 对象 value 字段中的 byte 值。
Principal | Any.extract_Principal() 已过时。 由 CORBA 2.2 取代。
abstract short | Any.extract_short() 提取此 Any 对象 value 字段中的 short 值。
abstract String | Any.extract_string() 提取此 Any 对象 value 字段中的 String 对象。
abstract TypeCode | Any.extract_TypeCode() 提取此 Any 对象 value 字段中的 TypeCode 对象。
abstract int | Any.extract_ulong() 提取此 Any 对象 value 字段中的 int 值。
abstract long | Any.extract_ulonglong() 提取此 Any 对象 value 字段中的 long 值。
abstract short | Any.extract_ushort() 提取此 Any 对象 value 字段中的 short 值。
abstract Serializable | Any.extract_Value() 提取此 Any 对象 value 字段中的 java.io.Serializable 对象。
abstract char | Any.extract_wchar() 提取此 Any 对象 value 字段中的 char 值。
abstract String | Any.extract_wstring() 提取此 Any 对象 value 字段中的 String 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_PARAM 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_PARAM
的使用

使用 BAD_PARAM 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3 | CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。

org.omg.CORBA 中 BAD_PARAM 的使用

抛出 BAD_PARAM 的 org.omg.CORBA 中的方法
abstract  void Any.insert_Object(Object o, TypeCode t)
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。

org.omg.CORBA_2_3 中 BAD_PARAM 的使用

抛出 BAD_PARAM 的 org.omg.CORBA_2_3 中的方法
 Object ORB.get_value_def(String repid)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.BAD_POLICY 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.BAD_POLICY
的使用

没有 org.omg.CORBA.BAD_POLICY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.BAD_POLICY_TYPE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.BAD_POLICY_TYPE
的使用

没有 org.omg.CORBA.BAD_POLICY_TYPE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.BAD_POLICY_VALUE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.BAD_POLICY_VALUE
的使用

没有 org.omg.CORBA.BAD_POLICY_VALUE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_QOS 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_QOS
的使用

没有 org.omg.CORBA.BAD_QOS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_TYPECODE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_TYPECODE
的使用

没有 org.omg.CORBA.BAD_TYPECODE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.BooleanHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BooleanHolder
的使用

没有 org.omg.CORBA.BooleanHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.BooleanSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BooleanSeqHelper
的使用

没有 org.omg.CORBA.BooleanSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.BooleanSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BooleanSeqHolder
的使用

使用 BooleanSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 BooleanSeqHolder 的使用

参数类型为 BooleanSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_boolean_array(BooleanSeqHolder seq, int offset, int length)
从输入流读取 IDL boolean 数组中 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.Bounds 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Bounds
的使用

使用 Bounds 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 Bounds 的使用

抛出 Bounds 的 org.omg.CORBA 中的方法
abstract String | ContextList.item(int index) 返回位于给定索引的 String 对象。
abstract TypeCode | ExceptionList.item(int index) 返回给定索引处的 TypeCode 对象。
abstract NamedValue | NVList.item(int index) 检索给定索引处的 NamedValue 对象。
abstract void | ContextList.remove(int index) 移除给定索引处的 String 对象。
abstract void | ExceptionList.remove(int index) 移除给定索引处的 TypeCode 对象。
abstract void | NVList.remove(int index) 移除位于给定索引处的 NamedValue 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ByteHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ByteHolder
的使用

没有 org.omg.CORBA.ByteHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.CharHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CharHolder
的使用

没有 org.omg.CORBA.CharHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.CharSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CharSeqHelper
的使用

没有 org.omg.CORBA.CharSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.CharSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CharSeqHolder
的使用

使用 CharSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 CharSeqHolder 的使用

参数类型为 CharSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_char_array(CharSeqHolder seq, int offset, int length)
从输入流读取 IDL 字符数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.CODESET_INCOMPATIBLE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CODESET_INCOMPATIBLE
的使用

没有 org.omg.CORBA.CODESET_INCOMPATIBLE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.COMM_FAILURE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.COMM_FAILURE
的使用

没有 org.omg.CORBA.COMM_FAILURE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.CompletionStatus 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CompletionStatus
的使用

使用 CompletionStatus 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 CompletionStatus 的使用

声明为 CompletionStatus 的 org.omg.CORBA 中的字段
CompletionStatus | SystemException.completed 抛出此异常的操作的状态。
static CompletionStatus | CompletionStatus.COMPLETED_MAYBE 使用常量 _COMPLETED_MAYBE 初始化的 CompletionStatus 实例。
static CompletionStatus | CompletionStatus.COMPLETED_NO 使用常量 _COMPLETED_NO 初始化的 CompletionStatus 实例。
static CompletionStatus | CompletionStatus.COMPLETED_YES 使用常量 _COMPLETED_YES 初始化的 CompletionStatus 实例。

返回 CompletionStatus 的 org.omg.CORBA 中的方法
static CompletionStatus | CompletionStatusHelper.extract(Any a)
static CompletionStatus | CompletionStatus.from_int(int i) 根据给定的 int 创建一个 CompletionStatus 对象。
static CompletionStatus | CompletionStatusHelper.read(InputStream istream)

参数类型为 CompletionStatus 的 org.omg.CORBA 中的方法
static void | CompletionStatusHelper.insert(Any a, CompletionStatus that)
static void | CompletionStatusHelper.write(OutputStream ostream, CompletionStatus value)

参数类型为 CompletionStatus 的 org.omg.CORBA 中的构造方法
ACTIVITY_COMPLETED(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_COMPLETED(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_REQUIRED(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。
ACTIVITY_REQUIRED(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。
BAD_CONTEXT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_CONTEXT 异常。
BAD_INV_ORDER(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_INV_ORDER 异常。
BAD_OPERATION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_OPERATION 异常。
BAD_OPERATION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_OPERATION 异常。
BAD_PARAM(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_PARAM 异常。
BAD_PARAM(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_PARAM 异常。
BAD_QOS(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 BAD_QOS 异常。
BAD_QOS(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 BAD_QOS 异常。
BAD_TYPECODE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_TYPECODE 异常。
CODESET_INCOMPATIBLE(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。
CODESET_INCOMPATIBLE(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。
COMM_FAILURE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 COMM_FAILURE 异常。
COMM_FAILURE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 COMM_FAILURE 异常。
DATA_CONVERSION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 DATA_CONVERSION 异常。
FREE_MEM(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 FREE_MEM 异常。
FREE_MEM(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 FREE_MEM 异常。
IMP_LIMIT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 IMP_LIMIT 异常。
IMP_LIMIT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 IMP_LIMIT 异常。
INITIALIZE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INITIALIZE 异常。
INITIALIZE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INITIALIZE 异常。
INTERNAL(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INTERNAL 异常。
INTERNAL(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTERNAL 异常。
INTF_REPOS(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INTF_REPOS 异常。
INTF_REPOS(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTF_REPOS 异常。
INV_FLAG(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_FLAG 异常。
INV_FLAG(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_FLAG 异常。
INV_IDENT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_IDENT 异常。
INV_IDENT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_IDENT 异常。
INV_OBJREF(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_OBJREF 异常。
INV_OBJREF(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_OBJREF 异常。
INV_POLICY(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_POLICY 异常。
INV_POLICY(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 INV_POLICY 异常。
INVALID_ACTIVITY(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。
INVALID_TRANSACTION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。
MARSHAL(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 MARSHAL 异常。
MARSHAL(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 MARSHAL 异常。
NO_IMPLEMENT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_IMPLEMENT 异常。
NO_MEMORY(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_MEMORY 异常。
NO_MEMORY(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_MEMORY 异常。
NO_PERMISSION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_PERMISSION 异常。
NO_PERMISSION(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_PERMISSION 异常。
NO_RESOURCES(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_RESOURCES 异常。
NO_RESOURCES(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESOURCES 异常。
NO_RESPONSE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_RESPONSE 异常。
NO_RESPONSE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESPONSE 异常。
OBJ_ADAPTER(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJ_ADAPTER 异常。
OBJECT_NOT_EXIST(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。
PERSIST_STORE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 PERSIST_STORE 异常。
PERSIST_STORE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 PERSIST_STORE 异常。
REBIND(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态 (completion status) 构造一个 REBIND 异常。
REBIND(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 REBIND 异常。
SystemException(String reason, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 SystemException 异常。
TIMEOUT(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 TIMEOUT 异常。
TIMEOUT(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 TIMEOUT 异常。
TRANSACTION_MODE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_MODE 异常。
TRANSACTION_REQUIRED(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_ROLLEDBACK(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_UNAVAILABLE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSIENT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSIENT 异常。
TRANSIENT(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSIENT 异常。
UNKNOWN(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 UNKNOWN 异常。
UNKNOWN(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 UNKNOWN 异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.CompletionStatusHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CompletionStatusHelper
的使用

没有 org.omg.CORBA.CompletionStatusHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.Context 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Context
的使用

使用 Context 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 Context 的使用

返回 Context 的 org.omg.CORBA 中的方法
abstract Context | Context.create_child(String child_ctx_name) 创建一个 Context 对象，使用给定字符串作为其名称，并将此 Context 对象设置为其父对象。
abstract Context | Request.ctx() 检索用于此请求的 Context 对象。
abstract Context | ServerRequest.ctx() 当操作不是一个属性访问并且该操作的 IDL 定义中包含上下文表达式时，该操作返回用 IDL 指定的上下文信息；否则返回 nil Context 引用。
abstract Context | ORB.get_default_context() 获取默认 Context 对象。
abstract Context | Context.parent() 检索此 Context 对象的父对象。

参数类型为 Context 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。
abstract void | Request.ctx(Context c) 将此请求的 Context 对象设置为给定对象。

org.omg.CORBA.portable 中 Context 的使用

返回 Context 的 org.omg.CORBA.portable 中的方法
 Context InputStream.read_Context()
从流中读取一个 CORBA 上下文。

参数类型为 Context 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result) 创建在动态调用接口中使用的 Request 实例。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。
void | OutputStream.write_Context(Context ctx, ContextList contexts) 在此流上写入一个 CORBA 上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ContextList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ContextList
的使用

使用 ContextList 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 ContextList 的使用

返回 ContextList 的 org.omg.CORBA 中的方法
abstract ContextList | Request.contexts() 检索用于此请求的 ContextList 对象。
abstract ContextList | ORB.create_context_list() 创建一个空的 ContextList 对象。

参数类型为 ContextList 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。

org.omg.CORBA.portable 中 ContextList 的使用

参数类型为 ContextList 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。
void | OutputStream.write_Context(Context ctx, ContextList contexts) 在此流上写入一个 CORBA 上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.CTX_RESTRICT_SCOPE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.CTX_RESTRICT_SCOPE
的使用

没有 org.omg.CORBA.CTX_RESTRICT_SCOPE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.Current 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.Current
的使用

使用 Current 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA 中 Current 的使用

声明为 Current 的 org.omg.CORBA 中的字段
 Current CurrentHolder.value

返回 Current 的 org.omg.CORBA 中的方法
static Current | CurrentHelper.extract(Any a)
Current | ORB.get_current() 已过时。 使用 resolve_initial_references。
static Current | CurrentHelper.narrow(Object obj)
static Current | CurrentHelper.read(InputStream istream)

参数类型为 Current 的 org.omg.CORBA 中的方法
static void | CurrentHelper.insert(Any a, Current that)
static void | CurrentHelper.write(OutputStream ostream, Current value)

参数类型为 Current 的 org.omg.CORBA 中的构造方法
CurrentHolder(Current initialValue)

org.omg.PortableServer 中 Current 的使用

org.omg.PortableServer 中 Current 的子接口
 interface Current
从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.CurrentHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CurrentHelper
的使用

没有 org.omg.CORBA.CurrentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.CurrentHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CurrentHolder
的使用

没有 org.omg.CORBA.CurrentHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.CurrentOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.CurrentOperations
的使用

使用 CurrentOperations 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA 中 CurrentOperations 的使用

org.omg.CORBA 中 CurrentOperations 的子接口
 interface Current
从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。

org.omg.PortableServer 中 CurrentOperations 的使用

org.omg.PortableServer 中 CurrentOperations 的子接口
 interface CurrentOperations
从 CORBA::Current 中派生的 PortableServer::Current 接口，它提供一些能够访问调用方法的对象身份的方法实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.CustomMarshal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.CustomMarshal
的使用

使用 CustomMarshal 的软件包
org.omg.CORBA.portable 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA.portable 中 CustomMarshal 的使用

org.omg.CORBA.portable 中 CustomMarshal 的子接口
 interface CustomValue
通过自定义值类型实现的 ValueBase 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.DATA_CONVERSION 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DATA_CONVERSION
的使用

使用 DATA_CONVERSION 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DATA_CONVERSION 的使用

抛出 DATA_CONVERSION 的 org.omg.CORBA 中的方法
abstract void | Any.insert_char(char c) 将给定 char 值插入此 Any 对象的 value 字段。
abstract void | Any.insert_string(String s) 将给定 String 对象插入此 Any 对象的 value 字段。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DataInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DataInputStream
的使用

使用 DataInputStream 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DataInputStream 的使用

参数类型为 DataInputStream 的 org.omg.CORBA 中的方法
 void CustomMarshal.unmarshal(DataInputStream is)
必须通过自定义的 Marshal 类实现 unmarshal 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DataOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DataOutputStream
的使用

使用 DataOutputStream 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DataOutputStream 的使用

参数类型为 DataOutputStream 的 org.omg.CORBA 中的方法
 void CustomMarshal.marshal(DataOutputStream os)
必须通过自定义的 Marshal 类实现 marshal 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.DefinitionKind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DefinitionKind
的使用

使用 DefinitionKind 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DefinitionKind 的使用

声明为 DefinitionKind 的 org.omg.CORBA 中的字段
static DefinitionKind | DefinitionKind.dk_AbstractInterface 指示 Interface Repository 对象表示一个抽象接口的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Alias 指示 Interface Repository 对象是一个 Alias 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_all 通配符 DefinitionKind 常量，可用于 DefinitionKind 适合的所有情况。
static DefinitionKind | DefinitionKind.dk_Array 指示 Interface Repository 对象是一个 Array 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Attribute 指示 Interface Repository 对象是一个 Attribute 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Constant 指示 Interface Repository 对象是一个常量的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Enum 指示 Interface Repository 对象是一个 Enum 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Exception 指示 Interface Repository 对象是一个 Exception 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Fixed 指示 Interface Repository 对象是一个 Fixed value 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Interface 指示 Interface Repository 对象是一个 Interface 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Module 指示 Interface Repository 对象是一个 Module 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Native 指示 Interface Repository 对象是一个 Native value 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_none 指示 Interface Repository 对象不具有任何定义种类的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Operation 指示 Interface Repository 对象是一个 Operation 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Primitive 指示 Interface Repository 对象是一个 Primitive 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Repository 指示 Interface Repository 对象是一个 Repository 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Sequence 指示 Interface Repository 对象是一个 Sequence 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_String 指示 Interface Repository 对象是一个 String 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Struct 指示 Interface Repository 对象是一个 Struct 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Typedef 指示 Interface Repository 对象是一个 Typedef 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Union 指示 Interface Repository 对象是一个 Union 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Value 指示 Interface Repository 对象是一个 Value 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_ValueBox 指示 Interface Repository 对象是一个 ValueBox 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_ValueMember 指示 Interface Repository 对象是一个 ValueMember 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Wstring 指示 Interface Repository 对象是一个 Wstring 的静态 DefinitionKind 实例。

返回 DefinitionKind 的 org.omg.CORBA 中的方法
DefinitionKind | IRObjectOperations.def_kind() 返回对应于此接口存储库对象的 DefinitionKind。
DefinitionKind | _IDLTypeStub.def_kind()
static DefinitionKind | DefinitionKindHelper.extract(Any a)
static DefinitionKind | DefinitionKind.from_int(int i) 创建一个对应于给定代码的 DefinitionKind 实例。
static DefinitionKind | DefinitionKindHelper.read(InputStream istream)

参数类型为 DefinitionKind 的 org.omg.CORBA 中的方法
static void | DefinitionKindHelper.insert(Any a, DefinitionKind that)
static void | DefinitionKindHelper.write(OutputStream ostream, DefinitionKind value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.DefinitionKindHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DefinitionKindHelper
的使用

没有 org.omg.CORBA.DefinitionKindHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DomainManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DomainManager
的使用

使用 DomainManager 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 DomainManager 的使用

返回 DomainManager 的 org.omg.CORBA 中的方法
DomainManager[] | LocalObject._get_domain_managers() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
DomainManager[] | Object._get_domain_managers() 检索此对象的 DomainManager。

org.omg.CORBA.portable 中 DomainManager 的使用

返回 DomainManager 的 org.omg.CORBA.portable 中的方法
DomainManager[] | ObjectImpl._get_domain_managers() 获得此 ObjectImpl 对象的域管理程序所组成的列表。
DomainManager[] | Delegate.get_domain_managers(Object self) 检索此对象的 DomainManager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DomainManagerOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DomainManagerOperations
的使用

使用 DomainManagerOperations 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DomainManagerOperations 的使用

org.omg.CORBA 中 DomainManagerOperations 的子接口
 interface DomainManager
提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.DoubleHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DoubleHolder
的使用

没有 org.omg.CORBA.DoubleHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.DoubleSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DoubleSeqHelper
的使用

没有 org.omg.CORBA.DoubleSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.DoubleSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DoubleSeqHolder
的使用

使用 DoubleSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DoubleSeqHolder 的使用

参数类型为 DoubleSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_double_array(DoubleSeqHolder seq, int offset, int length)
从输入流读取 IDL double 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.DynamicImplementation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DynamicImplementation
的使用

使用 DynamicImplementation 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 DynamicImplementation 的使用

org.omg.CosNaming 中 DynamicImplementation 的子类
class | _BindingIteratorImplBase
class | _NamingContextImplBase

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DynAny 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynAny
的使用

使用 DynAny 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynAny 的使用

org.omg.CORBA 中 DynAny 的子接口
interface | DynArray 已过时。 使用新的 DynArray 替代
interface | DynEnum 已过时。 使用新的 DynEnum 替代
interface | DynFixed 已过时。 使用新的 DynFixed 替代
interface | DynSequence 已过时。 使用新的 DynSequence 替代
interface | DynStruct 已过时。 使用新的 DynStruct 替代
interface | DynUnion 已过时。 使用新的 DynUnion 替代
interface | DynValue 已过时。 使用新的 DynValue 替代

返回 DynAny 的 org.omg.CORBA 中的方法
DynAny | DynAny.copy() 已过时。 克隆此 DynAny 对象。
DynAny | ORB.create_basic_dyn_any(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynAny | ORB.create_dyn_any(Any value) 已过时。 使用新的 DynAnyFactory API 代替
DynAny | DynAny.current_component() 已过时。 返回一个 DynAny 对象引用，可用来获取/设置当前所访问组件的值。
DynAny | DynUnion.discriminator() 已过时。 返回一个 DynAny 对象引用，为了插入/获取鉴别符值，必须将该对象收缩为该鉴别符的类型。
DynAny | DynUnion.member() 已过时。 返回为了插入/获取此 union 成员而使用的 DynAny 对象引用。

参数类型为 DynAny 的 org.omg.CORBA 中的方法
 void DynAny.assign(DynAny dyn_any)
已过时。 将内容从一个 Dynamic Any 复制到另一个 Dynamic Any 中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DynArray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynArray
的使用

使用 DynArray 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynArray 的使用

返回 DynArray 的 org.omg.CORBA 中的方法
 DynArray ORB.create_dyn_array(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DynEnum 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynEnum
的使用

使用 DynEnum 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynEnum 的使用

返回 DynEnum 的 org.omg.CORBA 中的方法
 DynEnum ORB.create_dyn_enum(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DynFixed 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynFixed
的使用

没有 org.omg.CORBA.DynFixed 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DynSequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynSequence
的使用

使用 DynSequence 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynSequence 的使用

返回 DynSequence 的 org.omg.CORBA 中的方法
 DynSequence ORB.create_dyn_sequence(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DynStruct 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynStruct
的使用

使用 DynStruct 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynStruct 的使用

返回 DynStruct 的 org.omg.CORBA 中的方法
 DynStruct ORB.create_dyn_struct(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DynUnion 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynUnion
的使用

使用 DynUnion 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynUnion 的使用

返回 DynUnion 的 org.omg.CORBA 中的方法
 DynUnion ORB.create_dyn_union(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.DynValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynValue
的使用

没有 org.omg.CORBA.DynValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.Environment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Environment
的使用

使用 Environment 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 Environment 的使用

返回 Environment 的 org.omg.CORBA 中的方法
abstract Environment | ORB.create_environment() 创建一个 Environment 对象。
abstract Environment | Request.env() 检索用于此请求的 Environment 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ExceptionList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ExceptionList
的使用

使用 ExceptionList 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 ExceptionList 的使用

返回 ExceptionList 的 org.omg.CORBA 中的方法
abstract ExceptionList | ORB.create_exception_list() 创建一个空的 ExceptionList 对象。
abstract ExceptionList | Request.exceptions() 检索用于此请求的 ExceptionList 对象。

参数类型为 ExceptionList 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。

org.omg.CORBA.portable 中 ExceptionList 的使用

参数类型为 ExceptionList 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.FieldNameHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FieldNameHelper
的使用

没有 org.omg.CORBA.FieldNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.FixedHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FixedHolder
的使用

没有 org.omg.CORBA.FixedHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.FloatHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FloatHolder
的使用

没有 org.omg.CORBA.FloatHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.FloatSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FloatSeqHelper
的使用

没有 org.omg.CORBA.FloatSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.FloatSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FloatSeqHolder
的使用

使用 FloatSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 FloatSeqHolder 的使用

参数类型为 FloatSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_float_array(FloatSeqHolder seq, int offset, int length)
从输入流读取 IDL float 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.FREE_MEM 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FREE_MEM
的使用

没有 org.omg.CORBA.FREE_MEM 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.IdentifierHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.IdentifierHelper
的使用

没有 org.omg.CORBA.IdentifierHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.IDLType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.IDLType
的使用

使用 IDLType 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 IDLType 的使用

实现 IDLType 的 org.omg.CORBA 中的类
 class _IDLTypeStub
IDLType 的 Stub。

声明为 IDLType 的 org.omg.CORBA 中的字段
IDLType | StructMember.type_def typedef，它表示此 StructMember 对象所描述的 struct 成员的 IDL 类型。
IDLType | UnionMember.type_def typedef，它表示此 UnionMember 对象描述的 union 成员的 IDL 类型。
IDLType | ValueMember.type_def typedef，它表示此 ValueMember 对象描述的 value 成员的 IDL 类型。

返回 IDLType 的 org.omg.CORBA 中的方法
static IDLType | IDLTypeHelper.extract(Any a)
static IDLType | IDLTypeHelper.narrow(Object obj)
static IDLType | IDLTypeHelper.read(InputStream istream)

参数类型为 IDLType 的 org.omg.CORBA 中的方法
static void | IDLTypeHelper.insert(Any a, IDLType that)
static void | IDLTypeHelper.write(OutputStream ostream, IDLType value)

参数类型为 IDLType 的 org.omg.CORBA 中的构造方法
StructMember(String __name, TypeCode __type, IDLType __type_def)
构造一个 StructMember 对象，并使用给定值进行初始化。
UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
构造一个新的 UnionMember 对象，将其字段初始化为给定值。
ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
构造一个 ValueMember 对象，使用给定值进行初始化。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.IDLTypeHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.IDLTypeHelper
的使用

没有 org.omg.CORBA.IDLTypeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.IDLTypeOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.IDLTypeOperations
的使用

使用 IDLTypeOperations 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 IDLTypeOperations 的使用

org.omg.CORBA 中 IDLTypeOperations 的子接口
 interface IDLType
由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。

实现 IDLTypeOperations 的 org.omg.CORBA 中的类
 class _IDLTypeStub
IDLType 的 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.IMP_LIMIT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.IMP_LIMIT
的使用

没有 org.omg.CORBA.IMP_LIMIT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.INITIALIZE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INITIALIZE
的使用

没有 org.omg.CORBA.INITIALIZE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.INTERNAL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INTERNAL
的使用

没有 org.omg.CORBA.INTERNAL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.INTF_REPOS 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INTF_REPOS
的使用

没有 org.omg.CORBA.INTF_REPOS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.IntHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.IntHolder
的使用

没有 org.omg.CORBA.IntHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.INV_FLAG 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INV_FLAG
的使用

没有 org.omg.CORBA.INV_FLAG 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.INV_IDENT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INV_IDENT
的使用

没有 org.omg.CORBA.INV_IDENT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.INV_OBJREF 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INV_OBJREF
的使用

没有 org.omg.CORBA.INV_OBJREF 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.INV_POLICY 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INV_POLICY
的使用

没有 org.omg.CORBA.INV_POLICY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.INVALID_ACTIVITY 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INVALID_ACTIVITY
的使用

没有 org.omg.CORBA.INVALID_ACTIVITY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.INVALID_TRANSACTION 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INVALID_TRANSACTION
的使用

没有 org.omg.CORBA.INVALID_TRANSACTION 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.IRObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.IRObject
的使用

使用 IRObject 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 IRObject 的使用

org.omg.CORBA 中 IRObject 的子接口
 interface IDLType
由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。

实现 IRObject 的 org.omg.CORBA 中的类
 class _IDLTypeStub
IDLType 的 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.IRObjectOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.IRObjectOperations
的使用

使用 IRObjectOperations 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 IRObjectOperations 的使用

org.omg.CORBA 中 IRObjectOperations 的子接口
interface | IDLType 由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
interface | IDLTypeOperations 此接口必须由所有 IDLType 对象实现。
interface | IRObject IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。

实现 IRObjectOperations 的 org.omg.CORBA 中的类
 class _IDLTypeStub
IDLType 的 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.LocalObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LocalObject
的使用

没有 org.omg.CORBA.LocalObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.LongHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LongHolder
的使用

没有 org.omg.CORBA.LongHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.LongLongSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LongLongSeqHelper
的使用

没有 org.omg.CORBA.LongLongSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.LongLongSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LongLongSeqHolder
的使用

使用 LongLongSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 LongLongSeqHolder 的使用

参数类型为 LongLongSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_longlong_array(LongLongSeqHolder seq, int offset, int length)
从输入流读取 IDL long long 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.LongSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LongSeqHelper
的使用

没有 org.omg.CORBA.LongSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.LongSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LongSeqHolder
的使用

使用 LongSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 LongSeqHolder 的使用

参数类型为 LongSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_long_array(LongSeqHolder seq, int offset, int length)
从输入流读取 IDL long 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.MARSHAL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.MARSHAL
的使用

使用 MARSHAL 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 MARSHAL 的使用

抛出 MARSHAL 的 org.omg.CORBA 中的方法
abstract void | Any.insert_string(String s) 将给定 String 对象插入此 Any 对象的 value 字段。
abstract void | Any.insert_Value(Serializable v, TypeCode t) 将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
abstract void | Any.insert_wstring(String s) 将给定 String 对象插入此 Any 对象的 value 字段。
abstract void | Any.read_value(InputStream is, TypeCode t) 使用给定 typecode 读出（解组）给定输入流中某一 Any 对象的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.NamedValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NamedValue
的使用

使用 NamedValue 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 NamedValue 的使用

返回 NamedValue 的 org.omg.CORBA 中的方法
abstract NamedValue | NVList.add_item(String item_name, int flags) 创建一个新的 NamedValue 对象，使用给定名称和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
abstract NamedValue | NVList.add_value(String item_name, Any val, int flags) 创建一个新的 NamedValue 对象，使用给定名称、值和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
abstract NamedValue | NVList.add(int flags) 创建一个新的 NamedValue 对象，使用给定标志初始化该对象，并将它添加到此 NVList 对象的末尾。
abstract NamedValue | ORB.create_named_value(String s, Any any, int flags) 使用给定名称、值和参数模式标志创建一个 NamedValue 对象。
abstract NamedValue | NVList.item(int index) 检索给定索引处的 NamedValue 对象。
abstract NamedValue | Request.result() 检索包含该方法的返回值的 NamedValue 对象。

参数类型为 NamedValue 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。

org.omg.CORBA.portable 中 NamedValue 的使用

参数类型为 NamedValue 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result) 创建在动态调用接口中使用的 Request 实例。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.NameValuePair 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NameValuePair
的使用

使用 NameValuePair 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 NameValuePair 的使用

返回 NameValuePair 的 org.omg.CORBA 中的方法
static NameValuePair | NameValuePairHelper.extract(Any a)
NameValuePair[] | DynStruct.get_members() 已过时。 返回包含所有已存储 struct 成员的数组。
NameValuePair[] | DynValue.get_members() 已过时。 返回一个数组，它包含存储在此 DynValue 中 value 对象的所有成员。
static NameValuePair | NameValuePairHelper.read(InputStream istream)

参数类型为 NameValuePair 的 org.omg.CORBA 中的方法
static void | NameValuePairHelper.insert(Any a, NameValuePair that)
void | DynStruct.set_members(NameValuePair[] value) 已过时。 设置 struct 的成员。
void | DynValue.set_members(NameValuePair[] value) 已过时。 将此 DynValue 对象表示的 value 对象成员设置为给定的 NameValuePair 对象数组。
static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.NameValuePairHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NameValuePairHelper
的使用

没有 org.omg.CORBA.NameValuePairHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.NO_IMPLEMENT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NO_IMPLEMENT
的使用

没有 org.omg.CORBA.NO_IMPLEMENT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.NO_MEMORY 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NO_MEMORY
的使用

没有 org.omg.CORBA.NO_MEMORY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.NO_PERMISSION 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NO_PERMISSION
的使用

没有 org.omg.CORBA.NO_PERMISSION 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.NO_RESOURCES 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NO_RESOURCES
的使用

没有 org.omg.CORBA.NO_RESOURCES 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.NO_RESPONSE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NO_RESPONSE
的使用

没有 org.omg.CORBA.NO_RESPONSE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.NVList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NVList
的使用

使用 NVList 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 NVList 的使用

返回 NVList 的 org.omg.CORBA 中的方法
abstract NVList | Request.arguments() 检索包含将被调用方法的参数的 NVList 对象。
abstract NVList | ORB.create_list(int count) 为指定数量的 NamedValue 对象分配具有（可能）足够空间的 NVList。
NVList | ORB.create_operation_list(Object oper) 创建一个 NVList，并使用给定 OperationDef 对象中所述操作的参数描述进行初始化。
abstract NVList | Context.get_values(String start_scope, int op_flags, String pattern) 检索 name 字段与给定名称或名称模式匹配的 NamedValue 对象。

参数类型为 NVList 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。
void | ServerRequest.arguments(NVList args) 指定方法参数类型并检索 "in" 和 "inout" 参数值。
void | ServerRequest.params(NVList params) 已过时。 使用方法 arguments
abstract void | Context.set_values(NVList values) 在此 Context 对象中设置一个或多个属性值。

org.omg.CORBA.portable 中 NVList 的使用

参数类型为 NVList 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result) 创建在动态调用接口中使用的 Request 实例。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.OBJ_ADAPTER 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.OBJ_ADAPTER
的使用

没有 org.omg.CORBA.OBJ_ADAPTER 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.Object 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.Object
的使用

使用 Object 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3 | CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.portable | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.SendingContext | 为值类型的编组提供支持。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 中 Object 的使用

实现 Object 的 javax.rmi.CORBA 中的类
 class Stub
必须从其继承所有 RMI-IIOP stub 的基类。

返回 Object 的 javax.rmi.CORBA 中的方法
 Object Tie.thisObject()
返回此 tie 表示的目标对象的对象引用。

org.omg.CORBA 中 Object 的使用

org.omg.CORBA 中 Object 的子接口
interface | Current 从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
interface | DomainManager 提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
interface | DynAny 已过时。 使用新的 DynAny 替代
interface | DynArray 已过时。 使用新的 DynArray 替代
interface | DynEnum 已过时。 使用新的 DynEnum 替代
interface | DynFixed 已过时。 使用新的 DynFixed 替代
interface | DynSequence 已过时。 使用新的 DynSequence 替代
interface | DynStruct 已过时。 使用新的 DynStruct 替代
interface | DynUnion 已过时。 使用新的 DynUnion 替代
interface | DynValue 已过时。 使用新的 DynValue 替代
interface | IDLType 由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
interface | IRObject IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。
interface | Policy 派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。

实现 Object 的 org.omg.CORBA 中的类
class | _IDLTypeStub IDLType 的 Stub。
class | _PolicyStub Policy 的 Stub。
class | DynamicImplementation 已过时。 org.omg.CORBA.DynamicImplementation
class | LocalObject 用作 Java 语言映射中的本地 IDL 接口实现的基本类。

声明为 Object 的 org.omg.CORBA 中的字段
 Object ObjectHolder.value
此 ObjectHolder 对象保存的 Object 值。

返回 Object 的 org.omg.CORBA 中的方法
 Object LocalObject._duplicate()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
 Object Object._duplicate()
返回此 CORBA 对象引用的副本。
 Object LocalObject._get_interface_def()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
 Object Object._get_interface_def()
获取此对象引用所引用的对象实现的 InterfaceDef。
 Object LocalObject._get_interface()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
 Object LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
 Object Object._set_policy_override(Policy[] policies, SetOverrideType set_add)
返回一个新的 Object，使用给定策略替换此 Object 中的所有现有策略，或者根据给定 SetOverrideType 对象的值将给定策略添加到现有策略。
abstract  Object Any.extract_Object()
提取此 Any 对象 value 字段中的 org.omg.CORBA.Object。
static Object ObjectHelper.extract(Any a)
 Object DynAny.get_reference()
已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Other。
 Object DataInputStream.read_Object()
从输入流读取 IDL CORBA::Object。
static Object ObjectHelper.read(InputStream istream)
abstract  Object ORB.resolve_initial_references(String object_name)
根据可用初始服务名称集解析特定对象引用。
abstract  Object ORB.string_to_object(String str)
将方法 object_to_string 生成的字符串转换回 CORBA 对象引用。
abstract  Object Request.target()
检索目标对象引用。

参数类型为 Object 的 org.omg.CORBA 中的方法
 boolean LocalObject._is_equivalent(Object that)
在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。
 boolean Object._is_equivalent(Object other)
在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。
 void ORB.connect(Object obj)
将给定 servant 对象（作为服务器实现类的实例的 Java 对象）连接到 ORB。
 NVList ORB.create_operation_list(Object oper)
创建一个 NVList，并使用给定 OperationDef 对象中所述操作的参数描述进行初始化。
 void ORB.disconnect(Object obj)
断开给定 servant 对象与 ORB 的连接。
abstract  void Any.insert_Object(Object o)
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
abstract  void Any.insert_Object(Object o, TypeCode t)
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
 void DynAny.insert_reference(Object value)
已过时。 插入给定 org.omg.CORBA.Object 作为此 DynAny 对象的值。
static void ObjectHelper.insert(Any a, Object that)
static Current CurrentHelper.narrow(Object obj)
static IDLType IDLTypeHelper.narrow(Object obj)
static Policy PolicyHelper.narrow(Object obj)
abstract  String ORB.object_to_string(Object obj)
将给定 CORBA 对象引用转换为字符串。
 void DataOutputStream.write_Object(Object value)
将 IDL CORBA::Object 值写入输出流。
static void ObjectHelper.write(OutputStream ostream, Object value)

参数类型为 Object 的 org.omg.CORBA 中的构造方法
ObjectHolder(Object initial)
构造一个新的 ObjectHolder 对象，并使用给定 Object 初始化其 value 字段。

org.omg.CORBA_2_3 中 Object 的使用

返回 Object 的 org.omg.CORBA_2_3 中的方法
 Object ORB.get_value_def(String repid)

org.omg.CORBA_2_3.portable 中 Object 的使用

参数类型为 Object 的 org.omg.CORBA_2_3.portable 中的方法
 String Delegate.get_codebase(Object self)
返回提供的对象引用的代码基。

org.omg.CORBA.portable 中 Object 的使用

实现 Object 的 org.omg.CORBA.portable 中的类
 class ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。

返回 Object 的 org.omg.CORBA.portable 中的方法
Object | ObjectImpl._duplicate() 返回此 ObjectImpl 对象的一个副本。
Object | ObjectImpl._get_interface_def() 获得此 ObjectImpl 对象的接口定义。
Object | ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add) 将此 ObjectImpl 对象给定策略的重写类型设置为给定的 SetOverrideType 实例。
abstract Object | Delegate.duplicate(Object obj) 返回所提供对象引用的复本。
abstract Object | Delegate.get_interface_def(Object self) 返回一个所提供对象引用的 InterfaceDef。
abstract Object | InputStream.read_Object() 从此输入流中读取一个 CORBA 对象。
Object | InputStream.read_Object(Class clz) 取消对象的编组并返回一个 CORBA Object，该对象是作为参数传递的类的实例。
Object | Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add) 将传入的策略与它返回的新创建对象引用关联。

参数类型为 Object 的 org.omg.CORBA.portable 中的方法
 boolean ObjectImpl._is_equivalent(Object that)
检查给定的 ObjectImpl 对象是否等于此 ObjectImpl 对象。
abstract  Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
创建在动态调用接口中使用的 Request 实例。
abstract  Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
创建在动态调用接口中使用的 Request 实例。
abstract  Object Delegate.duplicate(Object obj)
返回所提供对象引用的复本。
 boolean Delegate.equals(Object self, Object obj)
提供重写委托 CORBA 对象方法 equals(java.lang.Object obj) 的实现。
 DomainManager[] Delegate.get_domain_managers(Object self)
检索此对象的 DomainManager。
abstract  Object Delegate.get_interface_def(Object self)
返回一个所提供对象引用的 InterfaceDef。
 Policy Delegate.get_policy(Object self, int policy_type)
返回应用于此对象的指定类型的 Policy 对象。
abstract  int Delegate.hash(Object obj, int max)
返回此对象引用的内部 ORB 标识符（哈希码）。
 int Delegate.hashCode(Object self)
提供重写委托 CORBA 对象的 hashCode() 方法的实现。
 InputStream Delegate.invoke(Object self, OutputStream output)
由 stub 调用，以调用一个操作。
abstract  boolean Delegate.is_a(Object obj, String repository_id)
检查对象引用是否是给定接口的实例。
abstract  boolean Delegate.is_equivalent(Object obj, Object other)
确定两个对象引用是否相等。
 boolean Delegate.is_local(Object self)
如果此对象由本地 servant 实现，则返回 true。
abstract  boolean Delegate.non_existent(Object obj)
确定对象引用的服务器对象是否已经被销毁。
 ORB Delegate.orb(Object obj)
提供对与其参数关联的 orb 的引用。
abstract  void Delegate.release(Object obj)
发布与所提供对象引用关联的资源。
 void Delegate.releaseReply(Object self, InputStream input)
releaseReply 可以由 stub 以可选方式调用，以在解组完成时将应答流释放回 ORB。
abstract  Request Delegate.request(Object obj, String operation)
创建在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。
 OutputStream Delegate.request(Object self, String operation, boolean responseExpected)
request 由 stub 调用，以获取用于编组参数的 OutputStream。
 void Delegate.servant_postinvoke(Object self, ServantObject servant)
servant_postinvoke() 由本地 stub 在已经对本地 servant 调用该操作之后调用。
 ServantObject Delegate.servant_preinvoke(Object self, String operation, Class expectedType)
返回对应该用作此请求的 servant 的 Java 引用。
 Object Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
将传入的策略与它返回的新创建对象引用关联。
 String Delegate.toString(Object self)
提供重写委托 CORBA 对象的 toString() 方法的实现。
abstract  void OutputStream.write_Object(Object value)
在此输入流上写入一个 CORBA Object。

org.omg.CosNaming 中 Object 的使用

org.omg.CosNaming 中 Object 的子接口
interface | BindingIterator BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
interface | NamingContext 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
interface | NamingContextExt NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 Object 的 org.omg.CosNaming 中的类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

返回 Object 的 org.omg.CosNaming 中的方法
Object | NamingContextExtOperations.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | _NamingContextExtStub.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | NamingContextOperations.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextExtStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。

参数类型为 Object 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
static BindingIterator | BindingIteratorHelper.narrow(Object obj)
static NamingContextExt | NamingContextExtHelper.narrow(Object obj)
static NamingContext | NamingContextHelper.narrow(Object obj)
void | NamingContextOperations.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
static BindingIterator | BindingIteratorHelper.unchecked_narrow(Object obj)
static NamingContextExt | NamingContextExtHelper.unchecked_narrow(Object obj)
static NamingContext | NamingContextHelper.unchecked_narrow(Object obj)

org.omg.DynamicAny 中 Object 的使用

org.omg.DynamicAny 中 Object 的子接口
interface | DynAnyFactory DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。

实现 Object 的 org.omg.DynamicAny 中的类
class | _DynAnyFactoryStub DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。

返回 Object 的 org.omg.DynamicAny 中的方法
Object | DynAnyOperations.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynAnyStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynArrayStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynEnumStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynFixedStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynSequenceStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynStructStub.get_reference() 从此 DynAny 析取对 CORBA 对象的引用。
Object | _DynUnionStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynValueStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。

参数类型为 Object 的 org.omg.DynamicAny 中的方法
void | DynAnyOperations.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynAnyStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynArrayStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynEnumStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynFixedStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynSequenceStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynStructStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynUnionStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynValueStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
static DynAnyFactory | DynAnyFactoryHelper.narrow(Object obj)
static DynAny | DynAnyHelper.narrow(Object obj)
static DynArray | DynArrayHelper.narrow(Object obj)
static DynEnum | DynEnumHelper.narrow(Object obj)
static DynFixed | DynFixedHelper.narrow(Object obj)
static DynSequence | DynSequenceHelper.narrow(Object obj)
static DynStruct | DynStructHelper.narrow(Object obj)
static DynUnion | DynUnionHelper.narrow(Object obj)
static DynValue | DynValueHelper.narrow(Object obj)
static DynAnyFactory | DynAnyFactoryHelper.unchecked_narrow(Object obj)
static DynAny | DynAnyHelper.unchecked_narrow(Object obj)
static DynArray | DynArrayHelper.unchecked_narrow(Object obj)
static DynEnum | DynEnumHelper.unchecked_narrow(Object obj)
static DynFixed | DynFixedHelper.unchecked_narrow(Object obj)
static DynSequence | DynSequenceHelper.unchecked_narrow(Object obj)
static DynStruct | DynStructHelper.unchecked_narrow(Object obj)
static DynUnion | DynUnionHelper.unchecked_narrow(Object obj)
static DynValue | DynValueHelper.unchecked_narrow(Object obj)

org.omg.IOP 中 Object 的使用

org.omg.IOP 中 Object 的子接口
interface | Codec IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。
interface | CodecFactory Codec 可从 CodecFactory 中获得。

参数类型为 Object 的 org.omg.IOP 中的方法
static CodecFactory | CodecFactoryHelper.narrow(Object obj)
static CodecFactory | CodecFactoryHelper.unchecked_narrow(Object obj)

org.omg.PortableInterceptor 中 Object 的使用

org.omg.PortableInterceptor 中 Object 的子接口
interface | ClientRequestInfo 客户端请求 interceptor 可访问的请求信息。
interface | ClientRequestInterceptor 客户端 interceptor。
interface | Interceptor 所有 Portable Interceptor 实现 Interceptor。
interface | IORInfo 提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | ORBInitializer 便于注册 interceptor 和初始化 ORB。
interface | ORBInitInfo 传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
interface | PolicyFactory 使得策略类型能够使用 CORBA.ORB.create_policy 来构建。
interface | RequestInfo Interceptor 可访问的请求信息。
interface | ServerRequestInfo 服务器端请求 interceptor 可访问的请求信息。
interface | ServerRequestInterceptor 服务器端的请求 interceptor。

声明为 Object 的 org.omg.PortableInterceptor 中的字段
 Object ForwardRequest.forward
将请求转发到的新对象。

返回 Object 的 org.omg.PortableInterceptor 中的方法
Object | ClientRequestInfoOperations.effective_target() 返回实际调用操作的对象。
Object | RequestInfoOperations.forward_reference() 如果 reply_status 属性为 LOCATION_FORWARD，则包含要将请求转发到的对象。
Object | ObjectReferenceFactory.make_object(String repositoryId, byte[] object_id) make_object 根据此模板中的数据，使用给定的存储库 ID 和对象 ID 创建 CORBA 对象引用。
Object | ORBInitInfoOperations.resolve_initial_references(String id) 等同于 ORB.resolve_initial_references。
Object | ClientRequestInfoOperations.target() 返回客户端调用以执行操作的对象。

参数类型为 Object 的 org.omg.PortableInterceptor 中的方法
static Current | CurrentHelper.narrow(Object obj)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.narrow(Object obj)
void | ORBInitInfoOperations.register_initial_reference(String id, Object obj) 等同于 ORB.register_initial_reference。
static Current | CurrentHelper.unchecked_narrow(Object obj)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.unchecked_narrow(Object obj)

参数类型为 Object 的 org.omg.PortableInterceptor 中的构造方法
ForwardRequest(Object _forward)
ForwardRequest(String $reason, Object _forward)

org.omg.PortableServer 中 Object 的使用

org.omg.PortableServer 中 Object 的子接口
interface | AdapterActivator 一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
interface | IdAssignmentPolicy IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdUniquenessPolicy IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | ImplicitActivationPolicy 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | LifespanPolicy LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | POA POA 对象管理对象集合的实现。
interface | POAManager 每个 POA 对象都有一个关联的 POAManager 对象。
interface | RequestProcessingPolicy 此策略指定已创建的 POA 处理请求的方式。
interface | ServantActivator POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantLocator 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
interface | ServantManager servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
interface | ServantRetentionPolicy 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ThreadPolicy ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。

实现 Object 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。

声明为 Object 的 org.omg.PortableServer 中的字段
 Object ForwardRequest.forward_reference

返回 Object 的 org.omg.PortableServer 中的方法
 Object Servant._get_interface_def()
以 CORBA::Object 的形式返回 InterfaceDef 对象，该对象定义由 Servant 实现的 CORBA::Object 的运行时类型。
 Object Servant._this_object()
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
 Object Servant._this_object(ORB orb)
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
 Object POAOperations.create_reference_with_id(byte[] oid, String intf)
此操作创建一个对象引用，该引用封装指定的 Object Id 和接口存储库 Id 值。
 Object POAOperations.create_reference(String intf)
此操作创建一个对象引用，该引用封装 POA 生成的 Object Id 值和指定的接口存储库 id。
 Object POAOperations.id_to_reference(byte[] oid)
如果具有指定 Object Id 值的对象当前不是激活状态，则返回一个封装激活该对象时所用信息的引用。
 Object POAOperations.servant_to_reference(Servant p_servant)
如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。

参数类型为 Object 的 org.omg.PortableServer 中的方法
static Current | CurrentHelper.narrow(Object obj)
static POA | POAHelper.narrow(Object obj)
static ServantActivator | ServantActivatorHelper.narrow(Object obj)
static ServantLocator | ServantLocatorHelper.narrow(Object obj)
byte[] | POAOperations.reference_to_id(Object reference) 此操作返回指定引用封装的 Object Id 值。
Servant | POAOperations.reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
static ServantActivator | ServantActivatorHelper.unchecked_narrow(Object obj)
static ServantLocator | ServantLocatorHelper.unchecked_narrow(Object obj)

参数类型为 Object 的 org.omg.PortableServer 中的构造方法
ForwardRequest(Object _forward_reference)
ForwardRequest(String $reason, Object _forward_reference)

org.omg.PortableServer.portable 中 Object 的使用

返回 Object 的 org.omg.PortableServer.portable 中的方法
Object | Delegate.get_interface_def(Servant self) 此操作返回接口 Repository 中的一个对象，该对象提供可能对编程有用的类型信息。
Object | Delegate.this_object(Servant Self) 此方法允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。

org.omg.SendingContext 中 Object 的使用

org.omg.SendingContext 中 Object 的子接口
 interface RunTime
定义表示请求的发送上下文的基类。

org.omg.stub.java.rmi 中 Object 的使用

实现 Object 的 org.omg.stub.java.rmi 中的类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.OBJECT_NOT_EXIST 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.OBJECT_NOT_EXIST
的使用

没有 org.omg.CORBA.OBJECT_NOT_EXIST 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ObjectHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ObjectHelper
的使用

没有 org.omg.CORBA.ObjectHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ObjectHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ObjectHolder
的使用

没有 org.omg.CORBA.ObjectHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.OctetSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.OctetSeqHelper
的使用

没有 org.omg.CORBA.OctetSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.OctetSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.OctetSeqHolder
的使用

使用 OctetSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 OctetSeqHolder 的使用

参数类型为 OctetSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_octet_array(OctetSeqHolder seq, int offset, int length)
从输入流读取 IDL octet 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.OMGVMCID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.OMGVMCID
的使用

没有 org.omg.CORBA.OMGVMCID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ORB 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ORB
的使用

使用 ORB 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3 | CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.portable | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

javax.rmi.CORBA 中 ORB 的使用

返回 ORB 的 javax.rmi.CORBA 中的方法
 ORB Tie.orb()
返回此 tie 的 ORB。

参数类型为 ORB 的 javax.rmi.CORBA 中的方法
 void Stub.connect(ORB orb)
将此 stub 连接到 ORB。
 void StubDelegate.connect(Stub self, ORB orb)
Stub.connect(org.omg.CORBA.ORB) 的委托调用。
static Object Util.copyObject(Object obj, ORB orb)
复制或连接一个对象。
 Object UtilDelegate.copyObject(Object obj, ORB orb)
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。
static Object[] Util.copyObjects(Object[] obj, ORB orb)
复制或连接一个对象数组。
 Object[] UtilDelegate.copyObjects(Object[] obj, ORB orb)
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。
 void Tie.orb(ORB orb)
设置此 tie 的 ORB。

org.omg.CORBA 中 ORB 的使用

返回 ORB 的 org.omg.CORBA 中的方法
ORB | LocalObject._orb() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
static ORB | ORB.init() 返回对象 ORB 单件。
static ORB | ORB.init(Applet app, Properties props) 为 applet 创建一个新的 ORB 实例。
static ORB | ORB.init(String[] args, Properties props) 为独立的应用程序创建一个新的 ORB 实例。

org.omg.CORBA_2_3 中 ORB 的使用

org.omg.CORBA_2_3 中 ORB 的子类
 class ORB
扩展了 org.omg.CORBA.ORB 的类，使 ORB 在 OMG CORBA 规范 2.3 版下可移植。

org.omg.CORBA.portable 中 ORB 的使用

返回 ORB 的 org.omg.CORBA.portable 中的方法
ORB | ObjectImpl._orb() 返回对与此对象及其委托相关的 ORB 的引用。
ORB | InputStream.orb() 返回创建此 InputStream 的 ORB。
ORB | OutputStream.orb() 返回创建此 OutputStream 的 ORB。
ORB | Delegate.orb(Object obj) 提供对与其参数关联的 orb 的引用。

org.omg.CosNaming 中 ORB 的使用

参数类型为 ORB 的 org.omg.CosNaming 中的方法
BindingIterator | BindingIteratorPOA._this(ORB orb)
NamingContextExt | NamingContextExtPOA._this(ORB orb)
NamingContext | NamingContextPOA._this(ORB orb)

org.omg.PortableServer 中 ORB 的使用

返回 ORB 的 org.omg.PortableServer 中的方法
 ORB Servant._orb()
返回当前与 Servant 关联的 ORB 实例（便捷方法）。

参数类型为 ORB 的 org.omg.PortableServer 中的方法
Object | Servant._this_object(ORB orb) 允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
ServantActivator | ServantActivatorPOA._this(ORB orb)
ServantLocator | ServantLocatorPOA._this(ORB orb)

org.omg.PortableServer.portable 中 ORB 的使用

返回 ORB 的 org.omg.PortableServer.portable 中的方法
 ORB Delegate.orb(Servant Self)
返回当前关联 Servant 的 ORB 实例的便捷方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ParameterMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ParameterMode
的使用

使用 ParameterMode 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。

org.omg.CORBA 中 ParameterMode 的使用

声明为 ParameterMode 的 org.omg.CORBA 中的字段
static ParameterMode | ParameterMode.PARAM_IN
static ParameterMode | ParameterMode.PARAM_INOUT
static ParameterMode | ParameterMode.PARAM_OUT
ParameterMode | ParameterModeHolder.value

返回 ParameterMode 的 org.omg.CORBA 中的方法
static ParameterMode | ParameterModeHelper.extract(Any a)
static ParameterMode | ParameterMode.from_int(int value)
static ParameterMode | ParameterModeHelper.read(InputStream istream)

参数类型为 ParameterMode 的 org.omg.CORBA 中的方法
static void | ParameterModeHelper.insert(Any a, ParameterMode that)
static void | ParameterModeHelper.write(OutputStream ostream, ParameterMode value)

参数类型为 ParameterMode 的 org.omg.CORBA 中的构造方法
ParameterModeHolder(ParameterMode initialValue)

org.omg.Dynamic 中 ParameterMode 的使用

声明为 ParameterMode 的 org.omg.Dynamic 中的字段
 ParameterMode Parameter.mode

参数类型为 ParameterMode 的 org.omg.Dynamic 中的构造方法
Parameter(Any _argument, ParameterMode _mode)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ParameterModeHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ParameterModeHelper
的使用

没有 org.omg.CORBA.ParameterModeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ParameterModeHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ParameterModeHolder
的使用

没有 org.omg.CORBA.ParameterModeHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PERSIST_STORE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PERSIST_STORE
的使用

没有 org.omg.CORBA.PERSIST_STORE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.Policy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.Policy
的使用

使用 Policy 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA 中 Policy 的使用

实现 Policy 的 org.omg.CORBA 中的类
 class _PolicyStub
Policy 的 Stub。

声明为 Policy 的 org.omg.CORBA 中的字段
Policy | PolicyHolder.value
Policy[] | PolicyListHolder.value

返回 Policy 的 org.omg.CORBA 中的方法
Policy | LocalObject._get_policy(int policy_type) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Policy | Object._get_policy(int policy_type) 返回应用于此对象的指定类型的 Policy 对象。
Policy | PolicyOperations.copy() 返回 Policy 对象的副本。
Policy | _PolicyStub.copy() 复制策略对象。
Policy | ORB.create_policy(int type, Any val) 可以调用此方法创建特定类型的新策略对象实例，并且其类型具有指定的初始状态。
static Policy | PolicyHelper.extract(Any a)
static Policy[] | PolicyListHelper.extract(Any a)
Policy | DomainManagerOperations.get_domain_policy(int policy_type) 此方法为此域中的对象返回指定类型的策略。
static Policy | PolicyHelper.narrow(Object obj)
static Policy | PolicyHelper.read(InputStream istream)
static Policy[] | PolicyListHelper.read(InputStream istream)

参数类型为 Policy 的 org.omg.CORBA 中的方法
Object | LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Object | Object._set_policy_override(Policy[] policies, SetOverrideType set_add) 返回一个新的 Object，使用给定策略替换此 Object 中的所有现有策略，或者根据给定 SetOverrideType 对象的值将给定策略添加到现有策略。
static void | PolicyHelper.insert(Any a, Policy that)
static void | PolicyListHelper.insert(Any a, Policy[] that)
static void | PolicyHelper.write(OutputStream ostream, Policy value)
static void | PolicyListHelper.write(OutputStream ostream, Policy[] value)

参数类型为 Policy 的 org.omg.CORBA 中的构造方法
PolicyHolder(Policy initialValue)
PolicyListHolder(Policy[] initialValue)

org.omg.CORBA.portable 中 Policy 的使用

返回 Policy 的 org.omg.CORBA.portable 中的方法
Policy | ObjectImpl._get_policy(int policy_type) 获得此 ObjectImpl 对象具有给定策略类型的 Policy 对象。
Policy | Delegate.get_policy(Object self, int policy_type) 返回应用于此对象的指定类型的 Policy 对象。

参数类型为 Policy 的 org.omg.CORBA.portable 中的方法
Object | ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add) 将此 ObjectImpl 对象给定策略的重写类型设置为给定的 SetOverrideType 实例。
Object | Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add) 将传入的策略与它返回的新创建对象引用关联。

org.omg.PortableInterceptor 中 Policy 的使用

返回 Policy 的 org.omg.PortableInterceptor 中的方法
Policy | PolicyFactoryOperations.create_policy(int type, Any value) 返回派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。
Policy | IORInfoOperations.get_effective_policy(int type) 允许 ORB 服务实现确定对将构造的 IOR 有效的特定类型服务器端策略。
Policy | ClientRequestInfoOperations.get_request_policy(int type) 返回此操作实行的给定策略。
Policy | ServerRequestInfoOperations.get_server_policy(int type) 返回此操作实行的具有给定策略类型的策略。

org.omg.PortableServer 中 Policy 的使用

org.omg.PortableServer 中 Policy 的子接口
interface | IdAssignmentPolicy IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdUniquenessPolicy IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | ImplicitActivationPolicy 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | LifespanPolicy LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | RequestProcessingPolicy 此策略指定已创建的 POA 处理请求的方式。
interface | ServantRetentionPolicy 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ThreadPolicy ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。

参数类型为 Policy 的 org.omg.PortableServer 中的方法
 POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyError
的使用

使用 PolicyError 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.CORBA 中 PolicyError 的使用

声明为 PolicyError 的 org.omg.CORBA 中的字段
 PolicyError PolicyErrorHolder.value

返回 PolicyError 的 org.omg.CORBA 中的方法
static PolicyError | PolicyErrorHelper.extract(Any a)
static PolicyError | PolicyErrorHelper.read(InputStream istream)

参数类型为 PolicyError 的 org.omg.CORBA 中的方法
static void | PolicyErrorHelper.insert(Any a, PolicyError that)
static void | PolicyErrorHelper.write(OutputStream ostream, PolicyError value)

抛出 PolicyError 的 org.omg.CORBA 中的方法
 Policy ORB.create_policy(int type, Any val)
可以调用此方法创建特定类型的新策略对象实例，并且其类型具有指定的初始状态。

参数类型为 PolicyError 的 org.omg.CORBA 中的构造方法
PolicyErrorHolder(PolicyError initialValue)

org.omg.PortableInterceptor 中 PolicyError 的使用

抛出 PolicyError 的 org.omg.PortableInterceptor 中的方法
 Policy PolicyFactoryOperations.create_policy(int type, Any value)
返回派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyErrorCodeHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyErrorCodeHelper
的使用

没有 org.omg.CORBA.PolicyErrorCodeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyErrorHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyErrorHelper
的使用

没有 org.omg.CORBA.PolicyErrorHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyErrorHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyErrorHolder
的使用

没有 org.omg.CORBA.PolicyErrorHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyHelper
的使用

没有 org.omg.CORBA.PolicyHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyHolder
的使用

没有 org.omg.CORBA.PolicyHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyListHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyListHelper
的使用

没有 org.omg.CORBA.PolicyListHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyListHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyListHolder
的使用

没有 org.omg.CORBA.PolicyListHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.PolicyOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.PolicyOperations
的使用

使用 PolicyOperations 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA 中 PolicyOperations 的使用

org.omg.CORBA 中 PolicyOperations 的子接口
 interface Policy
派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。

实现 PolicyOperations 的 org.omg.CORBA 中的类
 class _PolicyStub
Policy 的 Stub。

org.omg.PortableServer 中 PolicyOperations 的使用

org.omg.PortableServer 中 PolicyOperations 的子接口
interface | IdAssignmentPolicy IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdAssignmentPolicyOperations IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdUniquenessPolicy IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | IdUniquenessPolicyOperations IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | ImplicitActivationPolicy 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | ImplicitActivationPolicyOperations 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | LifespanPolicy LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | LifespanPolicyOperations LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | RequestProcessingPolicy 此策略指定已创建的 POA 处理请求的方式。
interface | RequestProcessingPolicyOperations 此策略指定已创建的 POA 处理请求的方式。
interface | ServantRetentionPolicy 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ServantRetentionPolicyOperations 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ThreadPolicy ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。
interface | ThreadPolicyOperations ThreadPolicy 指定与已创建的 POA 一起使用的线程模型 (threading model)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyTypeHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyTypeHelper
的使用

没有 org.omg.CORBA.PolicyTypeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.Principal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Principal
的使用

使用 Principal 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 Principal 的使用

声明为 Principal 的 org.omg.CORBA 中的字段
 Principal PrincipalHolder.value
已过时。 此 PrincipalHolder 对象保存的 Principal 值。

返回 Principal 的 org.omg.CORBA 中的方法
 Principal Any.extract_Principal()
已过时。 由 CORBA 2.2 取代。

参数类型为 Principal 的 org.omg.CORBA 中的方法
 void Any.insert_Principal(Principal p)
已过时。 由 CORBA 2.2 取代。

参数类型为 Principal 的 org.omg.CORBA 中的构造方法
PrincipalHolder(Principal initial)
已过时。 构造一个新的 PrincipalHolder 对象，并将其 value 字段初始化为给定的 Principal 对象。

org.omg.CORBA.portable 中 Principal 的使用

返回 Principal 的 org.omg.CORBA.portable 中的方法
 Principal InputStream.read_Principal()
已过时。 已由 CORBA 2.2 取代。

参数类型为 Principal 的 org.omg.CORBA.portable 中的方法
 void OutputStream.write_Principal(Principal value)
已过时。 已由 CORBA 2.2 取代。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.PrincipalHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PrincipalHolder
的使用

没有 org.omg.CORBA.PrincipalHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.PRIVATE_MEMBER 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.PRIVATE_MEMBER
的使用

没有 org.omg.CORBA.PRIVATE_MEMBER 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.PUBLIC_MEMBER 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.PUBLIC_MEMBER
的使用

没有 org.omg.CORBA.PUBLIC_MEMBER 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.REBIND 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.REBIND
的使用

没有 org.omg.CORBA.REBIND 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.RepositoryIdHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.RepositoryIdHelper
的使用

没有 org.omg.CORBA.RepositoryIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.Request 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Request
的使用

使用 Request 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 Request 的使用

返回 Request 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。
Request | LocalObject._request(String operation) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._request(String operation) 创建一个在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。
abstract Request | ORB.get_next_response() 获取已接收到响应的下一个 Request 实例。

参数类型为 Request 的 org.omg.CORBA 中的方法
abstract void | ORB.send_multiple_requests_deferred(Request[] req) 异步发送多个动态 (DII) 请求。
abstract void | ORB.send_multiple_requests_oneway(Request[] req) 异步发送多个动态 (DII) 请求，并且不期望任何响应。

org.omg.CORBA.portable 中 Request 的使用

返回 Request 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
Request | ObjectImpl._request(String operation) 创建一个 Request 对象，使其包含可用于动态调用接口 (Dynamic Invocation Interface) 的给定方法。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result) 创建在动态调用接口中使用的 Request 实例。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。
abstract Request | Delegate.request(Object obj, String operation) 创建在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ServerRequest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServerRequest
的使用

使用 ServerRequest 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA 中 ServerRequest 的使用

参数类型为 ServerRequest 的 org.omg.CORBA 中的方法
 void DynamicImplementation.invoke(ServerRequest request)
已过时。 由 Portable Object Adapter 取代

org.omg.CosNaming 中 ServerRequest 的使用

参数类型为 ServerRequest 的 org.omg.CosNaming 中的方法
void | _BindingIteratorImplBase.invoke(ServerRequest r)
void | _NamingContextImplBase.invoke(ServerRequest r)

org.omg.PortableServer 中 ServerRequest 的使用

参数类型为 ServerRequest 的 org.omg.PortableServer 中的方法
abstract  void DynamicImplementation.invoke(ServerRequest request)
接收发布到任何由 DSI servant 实现的 CORBA 对象的请求，并进行执行该请求所需的处理。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ServiceDetail 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServiceDetail
的使用

使用 ServiceDetail 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ServiceDetail 的使用

声明为 ServiceDetail 的 org.omg.CORBA 中的字段
 ServiceDetail[] ServiceInformation.service_details
提供有关服务更多详细信息的 ServiceDetail 所组成的数组。

返回 ServiceDetail 的 org.omg.CORBA 中的方法
static ServiceDetail | ServiceDetailHelper.extract(Any a)
static ServiceDetail | ServiceDetailHelper.read(InputStream in)

参数类型为 ServiceDetail 的 org.omg.CORBA 中的方法
static void | ServiceDetailHelper.insert(Any a, ServiceDetail that)
static void | ServiceDetailHelper.write(OutputStream out, ServiceDetail that)

参数类型为 ServiceDetail 的 org.omg.CORBA 中的构造方法
ServiceInformation(int[] __service_options, ServiceDetail[] __service_details)
使用给定 service_options 和 service_details 构造一个 ServiceInformation 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ServiceDetailHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServiceDetailHelper
的使用

没有 org.omg.CORBA.ServiceDetailHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ServiceInformation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServiceInformation
的使用

使用 ServiceInformation 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ServiceInformation 的使用

声明为 ServiceInformation 的 org.omg.CORBA 中的字段
 ServiceInformation ServiceInformationHolder.value
此 ServiceInformationHolder 对象保存在其 value 字段中的 ServiceInformation 值。

返回 ServiceInformation 的 org.omg.CORBA 中的方法
static ServiceInformation | ServiceInformationHelper.extract(Any a)
static ServiceInformation | ServiceInformationHelper.read(InputStream in)

参数类型为 ServiceInformation 的 org.omg.CORBA 中的方法
static void | ServiceInformationHelper.insert(Any a, ServiceInformation that)
static void | ServiceInformationHelper.write(OutputStream out, ServiceInformation that)

参数类型为 ServiceInformation 的 org.omg.CORBA 中的构造方法
ServiceInformationHolder(ServiceInformation arg)
构造一个新的 ServiceInformationHolder 对象，将其 value 字段初始化为给定的 ServiceInformation 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ServiceInformationHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServiceInformationHelper
的使用

没有 org.omg.CORBA.ServiceInformationHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ServiceInformationHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServiceInformationHolder
的使用

使用 ServiceInformationHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ServiceInformationHolder 的使用

参数类型为 ServiceInformationHolder 的 org.omg.CORBA 中的方法
 boolean ORB.get_service_information(short service_type, ServiceInformationHolder service_info)
用来获取有关受此 ORB 支持的 CORBA 资源和服务的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.SetOverrideType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.SetOverrideType
的使用

使用 SetOverrideType 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 SetOverrideType 的使用

声明为 SetOverrideType 的 org.omg.CORBA 中的字段
static SetOverrideType | SetOverrideType.ADD_OVERRIDE 用于枚举值 ADD_OVERRIDE 的 SetOverrideType 常量。
static SetOverrideType | SetOverrideType.SET_OVERRIDE 用于枚举值 SET_OVERRIDE 的 SetOverrideType 常量。

返回 SetOverrideType 的 org.omg.CORBA 中的方法
static SetOverrideType | SetOverrideTypeHelper.extract(Any a)
static SetOverrideType | SetOverrideType.from_int(int i) 将给定 int 值转换成相应的 SetOverrideType 实例。
static SetOverrideType | SetOverrideTypeHelper.read(InputStream istream)

参数类型为 SetOverrideType 的 org.omg.CORBA 中的方法
Object | LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Object | Object._set_policy_override(Policy[] policies, SetOverrideType set_add) 返回一个新的 Object，使用给定策略替换此 Object 中的所有现有策略，或者根据给定 SetOverrideType 对象的值将给定策略添加到现有策略。
static void | SetOverrideTypeHelper.insert(Any a, SetOverrideType that)
static void | SetOverrideTypeHelper.write(OutputStream ostream, SetOverrideType value)

org.omg.CORBA.portable 中 SetOverrideType 的使用

参数类型为 SetOverrideType 的 org.omg.CORBA.portable 中的方法
Object | ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add) 将此 ObjectImpl 对象给定策略的重写类型设置为给定的 SetOverrideType 实例。
Object | Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add) 将传入的策略与它返回的新创建对象引用关联。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.SetOverrideTypeHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.SetOverrideTypeHelper
的使用

没有 org.omg.CORBA.SetOverrideTypeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ShortHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ShortHolder
的使用

没有 org.omg.CORBA.ShortHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ShortSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ShortSeqHelper
的使用

没有 org.omg.CORBA.ShortSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ShortSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ShortSeqHolder
的使用

使用 ShortSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ShortSeqHolder 的使用

参数类型为 ShortSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_short_array(ShortSeqHolder seq, int offset, int length)
从输入流读取 IDL short 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.StringHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StringHolder
的使用

没有 org.omg.CORBA.StringHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.StringSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StringSeqHelper
的使用

没有 org.omg.CORBA.StringSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.StringSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StringSeqHolder
的使用

没有 org.omg.CORBA.StringSeqHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.StringValueHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StringValueHelper
的使用

没有 org.omg.CORBA.StringValueHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.StructMember 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StructMember
的使用

使用 StructMember 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 StructMember 的使用

返回 StructMember 的 org.omg.CORBA 中的方法
static StructMember | StructMemberHelper.extract(Any a)
static StructMember | StructMemberHelper.read(InputStream istream)

参数类型为 StructMember 的 org.omg.CORBA 中的方法
abstract TypeCode | ORB.create_exception_tc(String id, String name, StructMember[] members) 创建一个表示 IDL exception 的 TypeCode 对象。
abstract TypeCode | ORB.create_struct_tc(String id, String name, StructMember[] members) 创建一个表示 IDL struct 的 TypeCode 对象。
static void | StructMemberHelper.insert(Any a, StructMember that)
static void | StructMemberHelper.write(OutputStream ostream, StructMember value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.StructMemberHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StructMemberHelper
的使用

没有 org.omg.CORBA.StructMemberHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.SystemException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.SystemException
的使用

使用 SystemException 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

javax.rmi.CORBA 中 SystemException 的使用

参数类型为 SystemException 的 javax.rmi.CORBA 中的方法
static RemoteException Util.mapSystemException(SystemException ex)
将 SystemException 映射到 RemoteException。
 RemoteException UtilDelegate.mapSystemException(SystemException ex)
Util.mapSystemException(org.omg.CORBA.SystemException) 的委托调用。

org.omg.CORBA 中 SystemException 的使用

org.omg.CORBA 中 SystemException 的子类
class | ACTIVITY_COMPLETED ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
class | ACTIVITY_REQUIRED ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
class | BAD_CONTEXT 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
class | BAD_INV_ORDER 此异常指示调用者按错误顺序调用了操作。
class | BAD_OPERATION 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
class | BAD_PARAM 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
class | BAD_QOS 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
class | BAD_TYPECODE 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
class | CODESET_INCOMPATIBLE 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
class | COMM_FAILURE 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
class | DATA_CONVERSION 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
class | FREE_MEM 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
class | IMP_LIMIT 此异常指示在 OBR 运行时超过了某一项实现限制。
class | INITIALIZE ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
class | INTERNAL 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
class | INTF_REPOS 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
class | INV_FLAG 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
class | INV_IDENT 此异常指示 IDL 标识符在语法上是无效的。
class | INV_OBJREF 此异常指示对象引用存在内部错误。
class | INV_POLICY 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
class | INVALID_ACTIVITY 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
class | INVALID_TRANSACTION 当请求带有无效的事务上下文时，抛出此异常。
class | MARSHAL 表示网络中传来的请求或应答在结构上无效。
class | NO_IMPLEMENT 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
class | NO_MEMORY 如果 ORB 运行时出现内存不足，则抛出此异常。
class | NO_PERMISSION 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
class | NO_RESOURCES 当 ORB 遇到一些一般资源限制时，抛出此异常。
class | NO_RESPONSE 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
class | OBJ_ADAPTER 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
class | OBJECT_NOT_EXIST 只要在已删除的对象上执行调用，就会引发此异常。
class | PERSIST_STORE 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
class | REBIND 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
class | TIMEOUT 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
class | TRANSACTION_MODE 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
class | TRANSACTION_REQUIRED 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
class | TRANSACTION_ROLLEDBACK 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
class | TRANSACTION_UNAVAILABLE 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
class | TRANSIENT 当 ORB 试图到达某一对象但失败时，抛出此异常。
class | UNKNOWN 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。

org.omg.CORBA.portable 中 SystemException 的使用

org.omg.CORBA.portable 中 SystemException 的子类
class | IndirectionException Indirection 异常是一个特定于 Java 的系统异常。
class | UnknownException org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

抛出 SystemException 的 org.omg.CORBA.portable 中的方法
 OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
由 ORB 调用来调度对 servant 的请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.TCKind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TCKind
的使用

使用 TCKind 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.CORBA 中 TCKind 的使用

声明为 TCKind 的 org.omg.CORBA 中的字段
static TCKind | TCKind.tk_abstract_interface TCKind 常量，使用 TCKind._tk_abstract_interface 初始化其 value 字段。
static TCKind | TCKind.tk_alias TCKind 常量，使用 TCKind._tk_alias 初始化其 value 字段。
static TCKind | TCKind.tk_any TCKind 常量，使用 TCKind._tk_any 初始化其 value 字段。
static TCKind | TCKind.tk_array TCKind 常量，使用 TCKind._tk_array 初始化其 value 字段。
static TCKind | TCKind.tk_boolean TCKind 常量，使用 TCKind._tk_boolean 初始化其 value 字段。
static TCKind | TCKind.tk_char TCKind 常量，使用 TCKind._tk_char 初始化其 value 字段。
static TCKind | TCKind.tk_double TCKind 常量，使用 TCKind._tk_double 初始化其 value 字段。
static TCKind | TCKind.tk_enum TCKind 常量，使用 TCKind._tk_enum 初始化其 value 字段。
static TCKind | TCKind.tk_except TCKind 常量，使用 TCKind._tk_except 初始化其 value 字段。
static TCKind | TCKind.tk_fixed TCKind 常量，使用 TCKind._tk_fixed 初始化其 value 字段。
static TCKind | TCKind.tk_float TCKind 常量，使用 TCKind._tk_float 初始化其 value 字段。
static TCKind | TCKind.tk_long TCKind 常量，使用 TCKind._tk_long 初始化其 value 字段。
static TCKind | TCKind.tk_longdouble TCKind 常量，使用 TCKind._tk_longdouble 初始化其 value 字段。
static TCKind | TCKind.tk_longlong TCKind 常量，使用 TCKind._tk_longlong 初始化其 value 字段。
static TCKind | TCKind.tk_native TCKind 常量，使用 TCKind._tk_native 初始化其 value 字段。
static TCKind | TCKind.tk_null TCKind 常量，使用 TCKind._tk_null 初始化其 value 字段。
static TCKind | TCKind.tk_objref TCKind 常量，使用 TCKind._tk_objref 初始化其 value 字段。
static TCKind | TCKind.tk_octet TCKind 常量，使用 TCKind._tk_octet 初始化其 value 字段。
static TCKind | TCKind.tk_Principal TCKind 常量，使用 TCKind._tk_Principal 初始化其 value 字段。
static TCKind | TCKind.tk_sequence TCKind 常量，使用 TCKind._tk_sequence 初始化其 value 字段。
static TCKind | TCKind.tk_short TCKind 常量，使用 TCKind._tk_short 初始化其 value 字段。
static TCKind | TCKind.tk_string TCKind 常量，使用 TCKind._tk_string 初始化其 value 字段。
static TCKind | TCKind.tk_struct TCKind 常量，使用 TCKind._tk_struct 初始化其 value 字段。
static TCKind | TCKind.tk_TypeCode TCKind 常量，使用 TCKind._tk_TypeCode 初始化其 value 字段。
static TCKind | TCKind.tk_ulong TCKind 常量，使用 TCKind._tk_ulong 初始化其 value 字段。
static TCKind | TCKind.tk_ulonglong TCKind 常量，使用 TCKind._tk_ulonglong 初始化其 value 字段。
static TCKind | TCKind.tk_union TCKind 常量，使用 TCKind._tk_union 初始化其 value 字段。
static TCKind | TCKind.tk_ushort TCKind 常量，使用 TCKind._tk_ushort 初始化其 value 字段。
static TCKind | TCKind.tk_value TCKind 常量，使用 TCKind._tk_value 初始化其 value 字段。
static TCKind | TCKind.tk_value_box TCKind 常量，使用 TCKind._tk_value_box 初始化其 value 字段。
static TCKind | TCKind.tk_void TCKind 常量，使用 TCKind._tk_void 初始化其 value 字段。
static TCKind | TCKind.tk_wchar TCKind 常量，使用 TCKind._tk_wchar 初始化其 value 字段。
static TCKind | TCKind.tk_wstring TCKind 常量，使用 TCKind._tk_wstring 初始化其 value 字段。

返回 TCKind 的 org.omg.CORBA 中的方法
TCKind | DynStruct.current_member_kind() 已过时。 返回描述当前成员的种类的 TCKind 对象。
TCKind | DynValue.current_member_kind() 已过时。 返回描述当前成员的 TCKind 对象。
TCKind | DynUnion.discriminator_kind() 已过时。 返回与此 union 的鉴别符关联的 TCKind 对象。
static TCKind | TCKind.from_int(int i) 将给定 int 值转换成相应的 TCKind 实例。
abstract TCKind | TypeCode.kind() 检索此 TypeCode 对象的种类。
TCKind | DynUnion.member_kind() 已过时。 返回与此 union 成员关联的 TCKind。

参数类型为 TCKind 的 org.omg.CORBA 中的方法
abstract  TypeCode ORB.get_primitive_tc(TCKind tcKind)
检索表示给定基本 IDL 类型的 TypeCode 对象。

org.omg.DynamicAny 中 TCKind 的使用

返回 TCKind 的 org.omg.DynamicAny 中的方法
TCKind | DynStructOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | DynValueOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynStructStub.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynValueStub.current_member_kind() 返回与当前位置的成员有关联的 TCKind。
TCKind | DynUnionOperations.discriminator_kind() 返回鉴别符 TypeCode 的 TCKind 值。
TCKind | _DynUnionStub.discriminator_kind() 返回鉴别符 TypeCode 的 TCKind 值。
TCKind | DynUnionOperations.member_kind() 返回当前活动成员 TypeCode 的 TCKind 值。
TCKind | _DynUnionStub.member_kind() 返回当前活动成员 TypeCode 的 TCKind 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.TIMEOUT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TIMEOUT
的使用

没有 org.omg.CORBA.TIMEOUT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.TRANSACTION_MODE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TRANSACTION_MODE
的使用

没有 org.omg.CORBA.TRANSACTION_MODE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.TRANSACTION_REQUIRED 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TRANSACTION_REQUIRED
的使用

没有 org.omg.CORBA.TRANSACTION_REQUIRED 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TRANSACTION_ROLLEDBACK
的使用

没有 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TRANSACTION_UNAVAILABLE
的使用

没有 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.TRANSIENT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TRANSIENT
的使用

没有 org.omg.CORBA.TRANSIENT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.TypeCode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TypeCode
的使用

使用 TypeCode 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。

org.omg.CORBA 中 TypeCode 的使用

声明为 TypeCode 的 org.omg.CORBA 中的字段
TypeCode | StructMember.type 此 StructMember 对象所描述的 struct 成员的类型。
TypeCode | UnionMember.type 此 UnionMember 对象所描述的 union 成员的类型。
TypeCode | ValueMember.type 此 value 成员的类型。
TypeCode | TypeCodeHolder.value 此 TypeCodeHolder 对象保存的 TypeCode 值。

返回 TypeCode 的 org.omg.CORBA 中的方法
TypeCode | AnyHolder._type() 返回对应于此 AnyHolder 对象中保存值的 TypeCode 对象。
TypeCode | AnySeqHolder._type()
TypeCode | BooleanHolder._type() 检索对应于此 BooleanHolder 对象中所保存的值的 TypeCode 对象。
TypeCode | BooleanSeqHolder._type()
TypeCode | ByteHolder._type() 返回对应于此 ByteHolder 对象中所保存的值的 TypeCode。
TypeCode | CharHolder._type() 返回对应于此 CharHolder 对象中所保存的值的 TypeCode 对象。
TypeCode | CharSeqHolder._type()
TypeCode | CurrentHolder._type()
TypeCode | DoubleHolder._type() 返回此 holder 对象的 TypeCode。
TypeCode | DoubleSeqHolder._type()
TypeCode | FixedHolder._type() 返回此 holder 对象的 TypeCode。
TypeCode | FloatHolder._type() 返回此 Streamable 的 TypeCode。
TypeCode | FloatSeqHolder._type()
TypeCode | IntHolder._type() 检索对应于此 IntHolder 对象 value 字段的 TypeCode 对象。
TypeCode | LongHolder._type() 返回对应于此 Holder 中所保存的值的 TypeCode 对象。
TypeCode | LongLongSeqHolder._type()
TypeCode | LongSeqHolder._type()
TypeCode | ObjectHolder._type() 返回对应于此 ObjectHolder 对象中所保存的值的 TypeCode
TypeCode | OctetSeqHolder._type()
TypeCode | ParameterModeHolder._type()
TypeCode | PolicyErrorHolder._type()
TypeCode | PolicyHolder._type()
TypeCode | PolicyListHolder._type()
TypeCode | PrincipalHolder._type() 已过时。
TypeCode | ServiceInformationHolder._type() 检索对应于此 ServiceInformationHolder 对象的 value 字段中所保存的值的 TypeCode 对象。
TypeCode | ShortHolder._type() 返回对应于此 ShortHolder 对象中所保存的值的 TypeCode。
TypeCode | ShortSeqHolder._type()
TypeCode | StringHolder._type() 检索对应于此 StringHolder 对象中所保存的值的 TypeCode 对象。
TypeCode | StringSeqHolder._type()
TypeCode | TypeCodeHolder._type() 返回对应于此 TypeCodeHolder 对象中所保存的值的 TypeCode。
TypeCode | ULongLongSeqHolder._type()
TypeCode | ULongSeqHolder._type()
TypeCode | UShortSeqHolder._type()
TypeCode | UnknownUserExceptionHolder._type()
TypeCode | ValueBaseHolder._type() 返回对应于此 Holder 中保存的值的 TypeCode 对象。
TypeCode | WCharSeqHolder._type()
TypeCode | WStringSeqHolder._type()
TypeCode | WrongTransactionHolder._type()
abstract TypeCode | TypeCode.concrete_base_type() 返回一个 TypeCode 对象，它描述此 TypeCode 对象所描述 value 类型的具体基本类型。
abstract TypeCode | TypeCode.content_type() 返回表示此 TypeCode 对象所描述成员 IDL 类型的 TypeCode 对象。
TypeCode | ORB.create_abstract_interface_tc(String id, String name) 为 IDL 抽象接口创建一个 TypeCode 对象。
abstract TypeCode | ORB.create_alias_tc(String id, String name, TypeCode original_type) 创建一个表示 IDL alias 的 TypeCode 对象 (typedef)。
abstract TypeCode | ORB.create_array_tc(int length, TypeCode element_type) 创建一个表示 IDL array 的 TypeCode 对象。
abstract TypeCode | ORB.create_enum_tc(String id, String name, String[] members) 创建一个表示 IDL enum 的 TypeCode 对象。
abstract TypeCode | ORB.create_exception_tc(String id, String name, StructMember[] members) 创建一个表示 IDL exception 的 TypeCode 对象。
TypeCode | ORB.create_fixed_tc(short digits, short scale) 为 IDL fixed 类型创建一个 TypeCode 对象。
abstract TypeCode | ORB.create_interface_tc(String id, String name) 创建一个表示 IDL interface 的 TypeCode 对象。
TypeCode | ORB.create_native_tc(String id, String name) 为 IDL native 类型创建一个 TypeCode 对象。
abstract TypeCode | ORB.create_recursive_sequence_tc(int bound, int offset) 已过时。 使用 create_recursive_tc 和 create_sequence_tc 的组合替代它
TypeCode | ORB.create_recursive_tc(String id) 创建一个递归 TypeCode 对象，在创建包含递归的 TypeCodes 期间，该对象充当具体 TypeCode 的占位符。
abstract TypeCode | ORB.create_sequence_tc(int bound, TypeCode element_type) 创建一个表示 IDL sequence 的 TypeCode 对象。
abstract TypeCode | ORB.create_string_tc(int bound) 创建一个表示有界 IDL string 的 TypeCode 对象。
abstract TypeCode | ORB.create_struct_tc(String id, String name, StructMember[] members) 创建一个表示 IDL struct 的 TypeCode 对象。
abstract TypeCode | ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members) 创建一个表示 IDL union 的 TypeCode 对象。
TypeCode | ORB.create_value_box_tc(String id, String name, TypeCode boxed_type) 为 IDL value box 类型创建一个 TypeCode 对象。
TypeCode | ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members) 为 IDL value 类型创建一个 TypeCode 对象。
abstract TypeCode | ORB.create_wstring_tc(int bound) 创建一个表示有界 IDL wstring (wide string) 的 TypeCode 对象。
abstract TypeCode | TypeCode.discriminator_type() 返回描述所有非默认成员标签的 TypeCode 对象。
abstract TypeCode | Any.extract_TypeCode() 提取此 Any 对象 value 字段中的 TypeCode 对象。
abstract TypeCode | TypeCode.get_compact_typecode() 剔除所有可选名称和成员名称字段，但使所有别名 typecode 保留原样。
abstract TypeCode | ORB.get_primitive_tc(TCKind tcKind) 检索表示给定基本 IDL 类型的 TypeCode 对象。
TypeCode | DynAny.get_typecode() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.TypeCode。
abstract TypeCode | ExceptionList.item(int index) 返回给定索引处的 TypeCode 对象。
abstract TypeCode | TypeCode.member_type(int index) 检索一个 TypeCode 对象，它描述给定索引所标识成员的类型。
TypeCode | DataInputStream.read_TypeCode() 从输入流读取 IDL typecode 值。
abstract TypeCode | Any.type() 返回此 Any 对象中所包含元素的类型信息。
static TypeCode | AnySeqHelper.type()
static TypeCode | BooleanSeqHelper.type()
static TypeCode | CharSeqHelper.type()
static TypeCode | CompletionStatusHelper.type()
static TypeCode | CurrentHelper.type()
static TypeCode | DefinitionKindHelper.type()
static TypeCode | DoubleSeqHelper.type()
TypeCode | DynAny.type() 已过时。 返回插入此 DynAny 对象的 TypeCode。
static TypeCode | FieldNameHelper.type()
static TypeCode | FloatSeqHelper.type()
static TypeCode | IDLTypeHelper.type()
TypeCode | IDLTypeOperations.type() type 属性描述源自 IDLType 的对象定义的类型。
static TypeCode | IdentifierHelper.type()
static TypeCode | LongLongSeqHelper.type()
static TypeCode | LongSeqHelper.type()
static TypeCode | NameValuePairHelper.type()
static TypeCode | ObjectHelper.type()
static TypeCode | OctetSeqHelper.type()
static TypeCode | ParameterModeHelper.type()
static TypeCode | PolicyErrorCodeHelper.type()
static TypeCode | PolicyErrorHelper.type()
static TypeCode | PolicyHelper.type()
static TypeCode | PolicyListHelper.type()
static TypeCode | PolicyTypeHelper.type()
static TypeCode | RepositoryIdHelper.type()
static TypeCode | ServiceDetailHelper.type()
static TypeCode | ServiceInformationHelper.type()
static TypeCode | SetOverrideTypeHelper.type()
static TypeCode | ShortSeqHelper.type()
static TypeCode | StringSeqHelper.type()
static TypeCode | StringValueHelper.type()
static TypeCode | StructMemberHelper.type()
static TypeCode | ULongLongSeqHelper.type()
static TypeCode | ULongSeqHelper.type()
static TypeCode | UShortSeqHelper.type()
static TypeCode | UnionMemberHelper.type()
static TypeCode | UnknownUserExceptionHelper.type()
static TypeCode | ValueBaseHelper.type()
static TypeCode | ValueMemberHelper.type()
static TypeCode | VersionSpecHelper.type()
static TypeCode | VisibilityHelper.type()
static TypeCode | WCharSeqHelper.type()
static TypeCode | WStringSeqHelper.type()
static TypeCode | WStringValueHelper.type()
static TypeCode | WrongTransactionHelper.type()
TypeCode | _IDLTypeStub.type()

参数类型为 TypeCode 的 org.omg.CORBA 中的方法
abstract void | ExceptionList.add(TypeCode exc) 将描述异常的 TypeCode 对象添加到此 ExceptionList 对象中。
abstract TypeCode | ORB.create_alias_tc(String id, String name, TypeCode original_type) 创建一个表示 IDL alias 的 TypeCode 对象 (typedef)。
abstract TypeCode | ORB.create_array_tc(int length, TypeCode element_type) 创建一个表示 IDL array 的 TypeCode 对象。
DynAny | ORB.create_basic_dyn_any(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynArray | ORB.create_dyn_array(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynEnum | ORB.create_dyn_enum(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynSequence | ORB.create_dyn_sequence(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynStruct | ORB.create_dyn_struct(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynUnion | ORB.create_dyn_union(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
abstract TypeCode | ORB.create_sequence_tc(int bound, TypeCode element_type) 创建一个表示 IDL sequence 的 TypeCode 对象。
abstract TypeCode | ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members) 创建一个表示 IDL union 的 TypeCode 对象。
TypeCode | ORB.create_value_box_tc(String id, String name, TypeCode boxed_type) 为 IDL value box 类型创建一个 TypeCode 对象。
TypeCode | ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members) 为 IDL value 类型创建一个 TypeCode 对象。
abstract boolean | TypeCode.equal(TypeCode tc) 将此 TypeCode 对象与给定对象比较，测试它们是否相等。
abstract boolean | TypeCode.equivalent(TypeCode tc) 测试给定 TypeCode 对象是否等于此 TypeCode 对象。
void | Any.insert_fixed(BigDecimal value, TypeCode type) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
abstract void | Any.insert_Object(Object o, TypeCode t) 将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
void | DynAny.insert_typecode(TypeCode value) 已过时。 插入给定 org.omg.CORBA.TypeCode 值作为此 DynAny 对象的值。
abstract void | Any.insert_TypeCode(TypeCode t) 将给定 TypeCode 对象插入此 Any 对象的 value 字段。
abstract void | Any.insert_Value(Serializable v, TypeCode t) 将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
abstract void | Any.read_value(InputStream is, TypeCode t) 使用给定 typecode 读出（解组）给定输入流中某一 Any 对象的值。
abstract void | Request.set_return_type(TypeCode tc) 设置该方法返回值的 typecode。
abstract void | Any.type(TypeCode t) 将此 Any 对象的 type 字段设置为给定的 TypeCode 对象，并清除其值。
void | DataOutputStream.write_TypeCode(TypeCode value) 将 typecode 写入输出流。

参数类型为 TypeCode 的 org.omg.CORBA 中的构造方法
StructMember(String __name, TypeCode __type, IDLType __type_def)
构造一个 StructMember 对象，并使用给定值进行初始化。
TypeCodeHolder(TypeCode initial)
构造一个新的 TypeCodeHolder 对象，将其 value 字段初始化为给定的 TypeCode 对象。
UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
构造一个新的 UnionMember 对象，将其字段初始化为给定值。
ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
构造一个 ValueMember 对象，使用给定值进行初始化。

org.omg.CORBA.portable 中 TypeCode 的使用

返回 TypeCode 的 org.omg.CORBA.portable 中的方法
TypeCode | Streamable._type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
abstract TypeCode | InputStream.read_TypeCode() 从此输入流中读取一个 TypeCode。

参数类型为 TypeCode 的 org.omg.CORBA.portable 中的方法
abstract  void OutputStream.write_TypeCode(TypeCode value)
在此输出流上写入一个 TypeCode。

org.omg.CosNaming 中 TypeCode 的使用

返回 TypeCode 的 org.omg.CosNaming 中的方法
TypeCode | BindingHolder._type()
TypeCode | BindingIteratorHolder._type()
TypeCode | BindingListHolder._type()
TypeCode | BindingTypeHolder._type()
TypeCode | NameComponentHolder._type()
TypeCode | NameHolder._type()
TypeCode | NamingContextExtHolder._type()
TypeCode | NamingContextHolder._type()
static TypeCode | BindingHelper.type()
static TypeCode | BindingIteratorHelper.type()
static TypeCode | BindingListHelper.type()
static TypeCode | BindingTypeHelper.type()
static TypeCode | IstringHelper.type()
static TypeCode | NameComponentHelper.type()
static TypeCode | NameHelper.type()
static TypeCode | NamingContextExtHelper.type()
static TypeCode | NamingContextHelper.type()

org.omg.CosNaming.NamingContextExtPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
TypeCode | InvalidAddressHolder._type()
static TypeCode | AddressHelper.type()
static TypeCode | InvalidAddressHelper.type()
static TypeCode | StringNameHelper.type()
static TypeCode | URLStringHelper.type()

org.omg.CosNaming.NamingContextPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.CosNaming.NamingContextPackage 中的方法
TypeCode | AlreadyBoundHolder._type()
TypeCode | CannotProceedHolder._type()
TypeCode | InvalidNameHolder._type()
TypeCode | NotEmptyHolder._type()
TypeCode | NotFoundHolder._type()
TypeCode | NotFoundReasonHolder._type()
static TypeCode | AlreadyBoundHelper.type()
static TypeCode | CannotProceedHelper.type()
static TypeCode | InvalidNameHelper.type()
static TypeCode | NotEmptyHelper.type()
static TypeCode | NotFoundHelper.type()
static TypeCode | NotFoundReasonHelper.type()

org.omg.DynamicAny 中 TypeCode 的使用

返回 TypeCode 的 org.omg.DynamicAny 中的方法
TypeCode | DynAnyOperations.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynAnyStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynArrayStub.get_typecode() 从此 DynAny 析取 TypeCode 对象。
TypeCode | _DynEnumStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynFixedStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynSequenceStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynStructStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynUnionStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynValueStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
static TypeCode | AnySeqHelper.type()
static TypeCode | DynAnyFactoryHelper.type()
static TypeCode | DynAnyHelper.type()
TypeCode | DynAnyOperations.type() 返回与此 DynAny 对象有关联的 TypeCode。
static TypeCode | DynAnySeqHelper.type()
static TypeCode | DynArrayHelper.type()
static TypeCode | DynEnumHelper.type()
static TypeCode | DynFixedHelper.type()
static TypeCode | DynSequenceHelper.type()
static TypeCode | DynStructHelper.type()
static TypeCode | DynUnionHelper.type()
static TypeCode | DynValueHelper.type()
static TypeCode | FieldNameHelper.type()
static TypeCode | NameDynAnyPairHelper.type()
static TypeCode | NameDynAnyPairSeqHelper.type()
static TypeCode | NameValuePairHelper.type()
static TypeCode | NameValuePairSeqHelper.type()
TypeCode | _DynAnyStub.type() 返回与此 DynAny 对象有关联的 TypeCode。
TypeCode | _DynArrayStub.type() 返回与此 DynAny 对象有关联的 TypeCode。
TypeCode | _DynEnumStub.type() 返回与此 DynAny 对象关联的 TypeCode。
TypeCode | _DynFixedStub.type() 返回与此 DynAny 对象有关联的 TypeCode。
TypeCode | _DynSequenceStub.type() 返回与此 DynAny 对象关联的 TypeCode。
TypeCode | _DynStructStub.type() 返回与此 DynAny 对象有关联的 TypeCode。
TypeCode | _DynUnionStub.type() 返回与此 DynAny 对象有关联的 TypeCode。
TypeCode | _DynValueStub.type() 返回与此 DynAny 对象有关联的 TypeCode。

参数类型为 TypeCode 的 org.omg.DynamicAny 中的方法
DynAny | DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
void | DynAnyOperations.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynAnyStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynArrayStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynEnumStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynFixedStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynSequenceStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynStructStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynUnionStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynValueStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。

org.omg.DynamicAny.DynAnyFactoryPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static TypeCode InconsistentTypeCodeHelper.type()

org.omg.DynamicAny.DynAnyPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static TypeCode | InvalidValueHelper.type()
static TypeCode | TypeMismatchHelper.type()

org.omg.IOP 中 TypeCode 的使用

返回 TypeCode 的 org.omg.IOP 中的方法
TypeCode | IORHolder._type()
TypeCode | MultipleComponentProfileHolder._type()
TypeCode | ServiceContextHolder._type()
TypeCode | ServiceContextListHolder._type()
TypeCode | TaggedComponentHolder._type()
TypeCode | TaggedProfileHolder._type()
static TypeCode | CodecFactoryHelper.type()
static TypeCode | ComponentIdHelper.type()
static TypeCode | IORHelper.type()
static TypeCode | MultipleComponentProfileHelper.type()
static TypeCode | ProfileIdHelper.type()
static TypeCode | ServiceContextHelper.type()
static TypeCode | ServiceContextListHelper.type()
static TypeCode | ServiceIdHelper.type()
static TypeCode | TaggedComponentHelper.type()
static TypeCode | TaggedProfileHelper.type()

参数类型为 TypeCode 的 org.omg.IOP 中的方法
 Any CodecOperations.decode_value(byte[] data, TypeCode tc)
基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。

org.omg.IOP.CodecFactoryPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.IOP.CodecFactoryPackage 中的方法
static TypeCode UnknownEncodingHelper.type()

org.omg.IOP.CodecPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.IOP.CodecPackage 中的方法
static TypeCode | FormatMismatchHelper.type()
static TypeCode | InvalidTypeForEncodingHelper.type()
static TypeCode | TypeMismatchHelper.type()

org.omg.Messaging 中 TypeCode 的使用

返回 TypeCode 的 org.omg.Messaging 中的方法
static TypeCode SyncScopeHelper.type()

org.omg.PortableInterceptor 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableInterceptor 中的方法
TypeCode | IORInterceptor_3_0Holder._type()
TypeCode | ObjectReferenceFactoryHolder._type()
TypeCode | ObjectReferenceTemplateHolder._type()
TypeCode | ObjectReferenceTemplateSeqHolder._type()
TypeCode[] | RequestInfoOperations.exceptions() 返回一个 TypeCode 对象数组，这些对象描述此操作调用可能抛出的用户异常的 TypeCode。
static TypeCode | AdapterManagerIdHelper.type()
static TypeCode | AdapterNameHelper.type()
static TypeCode | AdapterStateHelper.type()
static TypeCode | CurrentHelper.type()
static TypeCode | ForwardRequestHelper.type()
static TypeCode | IORInterceptor_3_0Helper.type()
static TypeCode | InvalidSlotHelper.type()
static TypeCode | ORBIdHelper.type()
static TypeCode | ObjectIdHelper.type()
static TypeCode | ObjectReferenceFactoryHelper.type()
static TypeCode | ObjectReferenceTemplateHelper.type()
static TypeCode | ObjectReferenceTemplateSeqHelper.type()
static TypeCode | ServerIdHelper.type()

org.omg.PortableInterceptor.ORBInitInfoPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static TypeCode | DuplicateNameHelper.type()
static TypeCode | InvalidNameHelper.type()
static TypeCode | ObjectIdHelper.type()

org.omg.PortableServer 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableServer 中的方法
static TypeCode | CurrentHelper.type()
static TypeCode | ForwardRequestHelper.type()
static TypeCode | POAHelper.type()
static TypeCode | ServantActivatorHelper.type()
static TypeCode | ServantLocatorHelper.type()

org.omg.PortableServer.CurrentPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableServer.CurrentPackage 中的方法
static TypeCode NoContextHelper.type()

org.omg.PortableServer.POAManagerPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableServer.POAManagerPackage 中的方法
static TypeCode AdapterInactiveHelper.type()

org.omg.PortableServer.POAPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableServer.POAPackage 中的方法
static TypeCode | AdapterAlreadyExistsHelper.type()
static TypeCode | AdapterNonExistentHelper.type()
static TypeCode | InvalidPolicyHelper.type()
static TypeCode | NoServantHelper.type()
static TypeCode | ObjectAlreadyActiveHelper.type()
static TypeCode | ObjectNotActiveHelper.type()
static TypeCode | ServantAlreadyActiveHelper.type()
static TypeCode | ServantNotActiveHelper.type()
static TypeCode | WrongAdapterHelper.type()
static TypeCode | WrongPolicyHelper.type()

org.omg.PortableServer.ServantLocatorPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableServer.ServantLocatorPackage 中的方法
 TypeCode CookieHolder._type()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.TypeCodeHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TypeCodeHolder
的使用

没有 org.omg.CORBA.TypeCodeHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ULongLongSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ULongLongSeqHelper
的使用

没有 org.omg.CORBA.ULongLongSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ULongLongSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ULongLongSeqHolder
的使用

使用 ULongLongSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ULongLongSeqHolder 的使用

参数类型为 ULongLongSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_ulonglong_array(ULongLongSeqHolder seq, int offset, int length)
从输入流读取无符号 IDL long long 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ULongSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ULongSeqHelper
的使用

没有 org.omg.CORBA.ULongSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ULongSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ULongSeqHolder
的使用

使用 ULongSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ULongSeqHolder 的使用

参数类型为 ULongSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_ulong_array(ULongSeqHolder seq, int offset, int length)
从输入流读取无符号 IDL long 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.UnionMember 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UnionMember
的使用

使用 UnionMember 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 UnionMember 的使用

返回 UnionMember 的 org.omg.CORBA 中的方法
static UnionMember | UnionMemberHelper.extract(Any a)
static UnionMember | UnionMemberHelper.read(InputStream istream)

参数类型为 UnionMember 的 org.omg.CORBA 中的方法
abstract TypeCode | ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members) 创建一个表示 IDL union 的 TypeCode 对象。
static void | UnionMemberHelper.insert(Any a, UnionMember that)
static void | UnionMemberHelper.write(OutputStream ostream, UnionMember value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.UnionMemberHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UnionMemberHelper
的使用

没有 org.omg.CORBA.UnionMemberHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.UNKNOWN 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UNKNOWN
的使用

没有 org.omg.CORBA.UNKNOWN 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.UnknownUserException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UnknownUserException
的使用

使用 UnknownUserException 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 UnknownUserException 的使用

声明为 UnknownUserException 的 org.omg.CORBA 中的字段
 UnknownUserException UnknownUserExceptionHolder.value

返回 UnknownUserException 的 org.omg.CORBA 中的方法
static UnknownUserException | UnknownUserExceptionHelper.extract(Any a)
static UnknownUserException | UnknownUserExceptionHelper.read(InputStream istream)

参数类型为 UnknownUserException 的 org.omg.CORBA 中的方法
static void | UnknownUserExceptionHelper.insert(Any a, UnknownUserException that)
static void | UnknownUserExceptionHelper.write(OutputStream ostream, UnknownUserException value)

参数类型为 UnknownUserException 的 org.omg.CORBA 中的构造方法
UnknownUserExceptionHolder(UnknownUserException initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.UnknownUserExceptionHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UnknownUserExceptionHelper
的使用

没有 org.omg.CORBA.UnknownUserExceptionHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.UnknownUserExceptionHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UnknownUserExceptionHolder
的使用

没有 org.omg.CORBA.UnknownUserExceptionHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.UNSUPPORTED_POLICY 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.UNSUPPORTED_POLICY
的使用

没有 org.omg.CORBA.UNSUPPORTED_POLICY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.UNSUPPORTED_POLICY_VALUE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
的使用

没有 org.omg.CORBA.UNSUPPORTED_POLICY_VALUE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.UserException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UserException
的使用

使用 UserException 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.CORBA 中 UserException 的使用

org.omg.CORBA 中 UserException 的子类
class | Bounds 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
class | PolicyError 发生策略错误时抛出的用户异常。
class | UnknownUserException 包含由服务器返回的用户异常的类。
class | WrongTransaction CORBA WrongTransaction 用户定义异常。

org.omg.CORBA.DynAnyPackage 中 UserException 的使用

org.omg.CORBA.DynAnyPackage 中 UserException 的子类
class | Invalid 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
class | InvalidSeq 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
class | InvalidValue
class | TypeMismatch 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 UserException 的使用

org.omg.CORBA.ORBPackage 中 UserException 的子类
class | InconsistentTypeCode 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
class | InvalidName 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.TypeCodePackage 中 UserException 的使用

org.omg.CORBA.TypeCodePackage 中 UserException 的子类
 class BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming.NamingContextExtPackage 中 UserException 的使用

org.omg.CosNaming.NamingContextExtPackage 中 UserException 的子类
 class InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextPackage 中 UserException 的使用

org.omg.CosNaming.NamingContextPackage 中 UserException 的子类
class | AlreadyBound org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
class | CannotProceed org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
class | NotEmpty org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
class | NotFound org/omg/CosNaming/NamingContextPackage/NotFound.java。

org.omg.IOP.CodecFactoryPackage 中 UserException 的使用

org.omg.IOP.CodecFactoryPackage 中 UserException 的子类
 class UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecPackage 中 UserException 的使用

org.omg.IOP.CodecPackage 中 UserException 的子类
class | FormatMismatch org/omg/IOP/CodecPackage/FormatMismatch.java。
class | InvalidTypeForEncoding org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

org.omg.PortableInterceptor 中 UserException 的使用

org.omg.PortableInterceptor 中 UserException 的子类
 class InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 UserException 的使用

org.omg.PortableInterceptor.ORBInitInfoPackage 中 UserException 的子类
 class DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

org.omg.PortableServer 中 UserException 的使用

org.omg.PortableServer 中 UserException 的子类
 class ForwardRequest
org/omg/PortableServer/ForwardRequest.java。

org.omg.PortableServer.CurrentPackage 中 UserException 的使用

org.omg.PortableServer.CurrentPackage 中 UserException 的子类
 class NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.POAManagerPackage 中 UserException 的使用

org.omg.PortableServer.POAManagerPackage 中 UserException 的子类
 class AdapterInactive
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。

org.omg.PortableServer.POAPackage 中 UserException 的使用

org.omg.PortableServer.POAPackage 中 UserException 的子类
class | AdapterAlreadyExists org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
class | AdapterNonExistent org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
class | InvalidPolicy org/omg/PortableServer/POAPackage/InvalidPolicy.java。
class | NoServant org/omg/PortableServer/POAPackage/NoServant.java。
class | ObjectAlreadyActive org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
class | ObjectNotActive org/omg/PortableServer/POAPackage/ObjectNotActive.java。
class | ServantAlreadyActive org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
class | ServantNotActive org/omg/PortableServer/POAPackage/ServantNotActive.java。
class | WrongAdapter org/omg/PortableServer/POAPackage/WrongAdapter.java。
class | WrongPolicy org/omg/PortableServer/POAPackage/WrongPolicy.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.UShortSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UShortSeqHelper
的使用

没有 org.omg.CORBA.UShortSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.UShortSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UShortSeqHolder
的使用

使用 UShortSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 UShortSeqHolder 的使用

参数类型为 UShortSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_ushort_array(UShortSeqHolder seq, int offset, int length)
从输入流读取无符号 IDL short 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ValueBaseHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ValueBaseHelper
的使用

没有 org.omg.CORBA.ValueBaseHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ValueBaseHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ValueBaseHolder
的使用

没有 org.omg.CORBA.ValueBaseHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ValueMember 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ValueMember
的使用

使用 ValueMember 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ValueMember 的使用

返回 ValueMember 的 org.omg.CORBA 中的方法
static ValueMember | ValueMemberHelper.extract(Any a)
static ValueMember | ValueMemberHelper.read(InputStream istream)

参数类型为 ValueMember 的 org.omg.CORBA 中的方法
TypeCode | ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members) 为 IDL value 类型创建一个 TypeCode 对象。
static void | ValueMemberHelper.insert(Any a, ValueMember that)
static void | ValueMemberHelper.write(OutputStream ostream, ValueMember value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ValueMemberHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ValueMemberHelper
的使用

没有 org.omg.CORBA.ValueMemberHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.VersionSpecHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.VersionSpecHelper
的使用

没有 org.omg.CORBA.VersionSpecHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.VisibilityHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.VisibilityHelper
的使用

没有 org.omg.CORBA.VisibilityHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.VM_ABSTRACT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.VM_ABSTRACT
的使用

没有 org.omg.CORBA.VM_ABSTRACT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.VM_CUSTOM 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.VM_CUSTOM
的使用

没有 org.omg.CORBA.VM_CUSTOM 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.VM_NONE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.VM_NONE
的使用

没有 org.omg.CORBA.VM_NONE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.VM_TRUNCATABLE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.VM_TRUNCATABLE
的使用

没有 org.omg.CORBA.VM_TRUNCATABLE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.WCharSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WCharSeqHelper
的使用

没有 org.omg.CORBA.WCharSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.WCharSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WCharSeqHolder
的使用

使用 WCharSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 WCharSeqHolder 的使用

参数类型为 WCharSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_wchar_array(WCharSeqHolder seq, int offset, int length)
从输入流读取 IDL 宽字符数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.WrongTransaction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WrongTransaction
的使用

使用 WrongTransaction 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 WrongTransaction 的使用

声明为 WrongTransaction 的 org.omg.CORBA 中的字段
 WrongTransaction WrongTransactionHolder.value

返回 WrongTransaction 的 org.omg.CORBA 中的方法
static WrongTransaction | WrongTransactionHelper.extract(Any a)
static WrongTransaction | WrongTransactionHelper.read(InputStream istream)

参数类型为 WrongTransaction 的 org.omg.CORBA 中的方法
static void | WrongTransactionHelper.insert(Any a, WrongTransaction that)
static void | WrongTransactionHelper.write(OutputStream ostream, WrongTransaction value)

抛出 WrongTransaction 的 org.omg.CORBA 中的方法
abstract Request | ORB.get_next_response() 获取已接收到响应的下一个 Request 实例。
abstract void | Request.get_response() 允许用户访问之前使用 send_deferred 方法所触发调用的响应。

参数类型为 WrongTransaction 的 org.omg.CORBA 中的构造方法
WrongTransactionHolder(WrongTransaction initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.WrongTransactionHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WrongTransactionHelper
的使用

没有 org.omg.CORBA.WrongTransactionHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.WrongTransactionHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WrongTransactionHolder
的使用

没有 org.omg.CORBA.WrongTransactionHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.WStringSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WStringSeqHelper
的使用

没有 org.omg.CORBA.WStringSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.WStringSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WStringSeqHolder
的使用

没有 org.omg.CORBA.WStringSeqHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.WStringValueHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WStringValueHelper
的使用

没有 org.omg.CORBA.WStringValueHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


Official Specifications for CORBA support in Java[tm] SE 6

Specification References

The specifications with which the Java[tm] Platform, Standard Edition (Java SE) v.1.6.0 ORB complies are as follows. If these links do not take you to the referenced specification, the OMG may have changed the URL, and you can link to www.omg.org to search for the correct specification.
  • CORBA 2.3.1 (formal/99-10-07)
  • IDL to Java language mapping (ptc/00-01-08)
  • Revised IDL to Java language mapping (ptc/00-11-03)
  • Java to IDL language mapping (ptc/00-01-06)
  • Interoperable Naming Service (ptc/00-08-07)
  • Portable Interceptors (ptc/2001-03-04)
These are the only specifications referenced by this document.

Supported Specification Details

Not all of the above specifications are currently implemented in the ORB in Java[tm] SE 6. The precise list of supported sections is as follows:
  • CORBA 2.3.1 chapters 1-3 and 6-9
  • Revised IDL to Java language mapping, section 1.21.8.2, the orb.properties file.
  • CORBA 2.3.1 chapter 4 with the following replacements from the Portable Interceptors specification:
    • section 4.2.3.5 destroy
    • section 4.5.2 CodeFactory and PICurrent are required
    • Section 4.5.3.4 as updated for register_initial_reference
  • CORBA 2.3.1 chapter 5 with the following update from the Portable Interceptors specification:
    • 5.5.2 StringSeq and WStringSeq are required. This adds the following classes to org.omg.CORBA:
      • StringSeqHolder
      • StringSeqHelper
      • WStringSeqHolder
      • WStringSeqHelper
  • CORBA 2.3.1 sections 10.6.1 and 10.6.2 are supported for repository IDs.
  • CORBA 2.3.1 section 10.7 for TypeCode APIs.
  • CORBA 2.3.1 chapter 11, Portable Object Adapter (POA), with the following updates from the Portable Interceptors specification:
    • Section 11.3.7 POAs must preserve all policies
    • Section 11.3.8.2 again states that POAs must preserve all policies
    • Section 11.3.8.26 POA::id is required.
  • CORBA 2.3.1 chapters 13 and 15 define GIOP 1.0, 1.1, and 1.2. The Java SE 6 ORB fully supports all versions of GIOP, with the exception that the bi-directional GIOP feature defined in sections 15.8 and 15.9 is not supported.
  • All of the Interoperable Naming Service is supported.
  • Portable Interceptors section 13.8 (the new Coder/Decoder interfaces) and all of chapter 21 (the interceptor specification).
  • Section 1.21.8 of the Revised IDL to Java Language Mapping Specification (ptc/00-11-03) has been changed from the version in the IDL to Java Language Mapping Specification (ptc/00-01-08).

Tools

  • The IDL to Java compiler (idlj) complies with:
    • CORBA 2.3.1 chapter 3 (IDL definition)
    • CORBA 2.3.1 chapters 5 and 6 (semantics of Value types)
    • CORBA 2.3.1 section 10.6.5 (pragmas)
    • The IDL to Java mapping specification
    • The Revised IDL to Java language mapping specification section 1.12.1 "local interfaces"
  • The Java to IDL compiler (the IIOP backend for rmic) complies with:
    • CORBA 2.3.1 chapters 5 and 6 (value types)
    • The Java to IDL language mapping. Note that this implicitly references section 1.21 of the IDL to Java language mapping
    • IDL generated by the -idl flag complies with CORBA 2.3.1 chapter 3.


IDL-to-Java Generated Files

The files that are generated by the IDL-to-Java compiler, in accordance with the IDL-to-Java Language Mapping Specification, which is implemented in JavaTM SE 6 according the compliance document.

In general IDL names and identifiers are mapped to Java names and identifiers with no change. Because of the nature of the Java language, a single IDL construct may be mapped to several (differently named) Java constructs. The additional names are constructed by appending a descriptive suffix. For example, the IDL interface foo is mapped to the Java interfaces foo and fooOperations, and additional Java classes fooHelper, fooHolder, fooPOA, and optionally fooPOATie.

The mapping in effect reserves the use of several names for its own purposes. These are:

  • The Java class <type>Helper, where <type> is the name of an IDL defined type.
  • The Java class <type>Holder, where <type> is the name of an IDL defined type (with certain exceptions such as typedef aliases).
  • The Java classes <basicJavaType>Holder, where <basicJavaType> is one of the Java primitive datatypes that is used by one of the IDL basic datatypes.
  • The Java classes <interface>Operations, <interface>POA, and <interface>POATie, where <interface> is the name of an IDL interface type.
  • The nested scope Java package name <interface>Package, where <interface> is the name of an IDL interface.

    Helper Files

    Helper files supply several static methods needed to manipulate the type. These include Any insert and extract operations for the type, getting the repository id, getting the typecode, and reading and writing the type from and to a stream.

    The helper class for a mapped IDL interface or abstract interface also include narrow operation(s). The static narrow method allows an org.omg.CORBA.Object to be narrowed to the object reference of a more specific type. The IDL exception CORBA::BAD_PARAM is thrown if the narrow fails because the object reference does not support the requested type. A different system exception is raised to indicate other kinds of errors. Trying to narrow a null will always succeed with a return value of null.

    Holder Files

    Support for out and inout parameter passing modes requires the use of additional holder classes. These classes are available for all of the basic IDL datatypes in the org.omg.CORBA package and are generated for all named user defined IDL types except those defined by typedefs. (Note that in this context user defined includes types that are defined in OMG specifications such as those for the Interface Repository, and other OMG services.)

    Each holder class has a constructor from an instance, a default constructor, and has a public instance member, value which is the typed value. The default constructor sets the value field to the default value for the type as defined by the Java language: false for boolean, 0 for numeric and char types, null for strings, null for object references.

    To support portable stubs and skeletons, holder classes also implement the org.omg.CORBA.portable.Streamable interface.

    Operations Files

    A non abstract IDL interface is mapped to two public Java interfaces: a signature interface and an operations interface. The signature interface, which extends IDLEntity, has the same name as the IDL interface name and is used as the signature type in method declarations when interfaces of the specified type are used in other interfaces. The operations interface has the same name as the IDL interface with the suffix Operations appended to the end and is used in the server-side mapping and as a mechanism for providing optimized calls for collocated client and servers.

    The Java operations interface contains the mapped operation signatures. The Java signature interface extends the operations interface, the (mapped) base org.omg.CORBA.Object, as well as org.omg.portable.IDLEntity. Methods can be invoked on the signature interface. Interface inheritance expressed in IDL is reflected in both the Java signature interface and operations interface hierarchies.

    Stubs

    For the mapping of a non-object-oriented language, there will be a programming interface to the stubs for each interface type. Generally, the stubs will present access to the OMG IDL-defined operations on an object in a way that is easy for programmers to predict once they are familiar with OMG IDL and the language mapping for the particular programming language. The stubs make calls on the rest of the ORB using interfaces that are private to, and presumably optimized for, the particular ORB Core. If more than one ORB is available, there may be different stubs corresponding to the different ORBs. In this case, it is necessary for the ORB and language mapping to cooperate to associate the correct stubs with the particular object reference.

    Object-oriented programming languages, such as Java, C++, and Smalltalk, do not require stub interfaces.


org.omg.CORBA.DynAnyPackage (Java 2 Platform SE 6)

 org.omg.CORBA.DynAnyPackage
异常
Invalid
InvalidSeq
InvalidValue
TypeMismatch


类 org.omg.CORBA.DynAnyPackage.Invalid 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DynAnyPackage.Invalid
的使用

使用 Invalid 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 Invalid 的使用

抛出 Invalid 的 org.omg.CORBA 中的方法
void | DynAny.assign(DynAny dyn_any) 已过时。 将内容从一个 Dynamic Any 复制到另一个 Dynamic Any 中。
void | DynAny.from_any(Any value) 已过时。 根据 Any 对象生成一个 DynAny 对象。
Any | DynAny.to_any() 已过时。 将 DynAny 对象转换成 Any 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.DynAnyPackage.InvalidSeq 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DynAnyPackage.InvalidSeq
的使用

使用 InvalidSeq 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 InvalidSeq 的使用

抛出 InvalidSeq 的 org.omg.CORBA 中的方法
void | DynArray.set_elements(Any[] value) 已过时。 将此 DynArray 对象的值设置为给定数组。
void | DynSequence.set_elements(Any[] value) 已过时。 使用给定数组设置此 sequence 中所有元素的值。
void | DynStruct.set_members(NameValuePair[] value) 已过时。 设置 struct 的成员。
void | DynValue.set_members(NameValuePair[] value) 已过时。 将此 DynValue 对象表示的 value 对象成员设置为给定的 NameValuePair 对象数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.DynAnyPackage.InvalidValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DynAnyPackage.InvalidValue
的使用

使用 InvalidValue 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 InvalidValue 的使用

抛出 InvalidValue 的 org.omg.CORBA 中的方法
void | DynAny.insert_any(Any value) 已过时。 插入给定 org.omg.CORBA.Any 对象作为此 DynAny 对象的值。
void | DynAny.insert_boolean(boolean value) 已过时。 插入给定 boolean 值作为此 DynAny 对象的值。
void | DynAny.insert_char(char value) 已过时。 插入给定 char 值作为此 DynAny 对象的值。
void | DynAny.insert_double(double value) 已过时。 插入给定 double 值作为此 DynAny 对象的值。
void | DynAny.insert_float(float value) 已过时。 插入给定 float 值作为此 DynAny 对象的值。
void | DynAny.insert_long(int value) 已过时。 插入给定 int 值作为此 DynAny 对象的值。
void | DynAny.insert_longlong(long value) 已过时。 插入给定 long 值作为此 DynAny 对象的值。
void | DynAny.insert_octet(byte value) 已过时。 插入给定 byte 值作为此 DynAny 对象的值。
void | DynAny.insert_reference(Object value) 已过时。 插入给定 org.omg.CORBA.Object 作为此 DynAny 对象的值。
void | DynAny.insert_short(short value) 已过时。 插入给定 short 值作为此 DynAny 对象的值。
void | DynAny.insert_string(String value) 已过时。 插入给定 String 对象作为此 DynAny 对象的值。
void | DynAny.insert_typecode(TypeCode value) 已过时。 插入给定 org.omg.CORBA.TypeCode 值作为此 DynAny 对象的值。
void | DynAny.insert_ulong(int value) 已过时。 插入给定 int 值作为此 DynAny 对象的值。
void | DynAny.insert_ulonglong(long value) 已过时。 插入给定 long 值作为此 DynAny 对象的值。
void | DynAny.insert_ushort(short value) 已过时。 插入给定 short 值作为此 DynAny 对象的值。
void | DynAny.insert_val(Serializable value) 已过时。 插入给定 java.io.Serializable 对象作为此 DynAny 对象的值。
void | DynAny.insert_wchar(char value) 已过时。 插入给定 char 值作为此 DynAny 对象的值。
void | DynAny.insert_wstring(String value) 已过时。 插入给定 String 作为此 DynAny 对象的值。
void | DynFixed.set_value(byte[] val) 已过时。 将给定 fixed 类型的实例设置为此 DynFixed 对象的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.DynAnyPackage.TypeMismatch 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DynAnyPackage.TypeMismatch
的使用

使用 TypeMismatch 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 TypeMismatch 的使用

抛出 TypeMismatch 的 org.omg.CORBA 中的方法
Any | DynAny.get_any() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Any。
boolean | DynAny.get_boolean() 已过时。 检索此 DynAny 对象中包含的 boolean 值。
char | DynAny.get_char() 已过时。 检索此 DynAny 对象中包含的 char 值。
double | DynAny.get_double() 已过时。 检索此 DynAny 对象中包含的 double 值。
float | DynAny.get_float() 已过时。 检索此 DynAny 对象中包含的 float 值。
int | DynAny.get_long() 已过时。 检索此 DynAny 对象中包含的 int 值。
long | DynAny.get_longlong() 已过时。 检索此 DynAny 对象中包含的 long 值。
byte | DynAny.get_octet() 已过时。 检索此 DynAny 对象中包含的 byte 值。
Object | DynAny.get_reference() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Other。
short | DynAny.get_short() 已过时。 检索此 DynAny 对象中包含的 short 值。
String | DynAny.get_string() 已过时。 检索此 DynAny 对象中包含的 String。
TypeCode | DynAny.get_typecode() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.TypeCode。
int | DynAny.get_ulong() 已过时。 检索此 DynAny 对象中包含的 int 值。
long | DynAny.get_ulonglong() 已过时。 检索此 DynAny 对象中包含的 long 值。
short | DynAny.get_ushort() 已过时。 检索此 DynAny 对象中包含的 short 值。
Serializable | DynAny.get_val() 已过时。 检索此 DynAny 对象中包含的 java.io.Serializable 对象。
char | DynAny.get_wchar() 已过时。 检索此 DynAny 对象中包含的 char 值。
String | DynAny.get_wstring() 已过时。 检索此 DynAny 对象中包含的 String。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.CORBA.ORBPackage (Java 2 Platform SE 6)

 org.omg.CORBA.ORBPackage
异常
InconsistentTypeCode
InvalidName


类 org.omg.CORBA.ORBPackage.InconsistentTypeCode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ORBPackage.InconsistentTypeCode
的使用

使用 InconsistentTypeCode 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 InconsistentTypeCode 的使用

抛出 InconsistentTypeCode 的 org.omg.CORBA 中的方法
DynAny | ORB.create_basic_dyn_any(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynArray | ORB.create_dyn_array(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynEnum | ORB.create_dyn_enum(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynSequence | ORB.create_dyn_sequence(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynStruct | ORB.create_dyn_struct(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynUnion | ORB.create_dyn_union(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.ORBPackage.InvalidName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ORBPackage.InvalidName
的使用

使用 InvalidName 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 InvalidName 的使用

抛出 InvalidName 的 org.omg.CORBA 中的方法
abstract  Object ORB.resolve_initial_references(String object_name)
根据可用初始服务名称集解析特定对象引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.CORBA.portable (Java 2 Platform SE 6)

 org.omg.CORBA.portable
接口
BoxedValueHelper
CustomValue
IDLEntity
InvokeHandler
ResponseHandler
Streamable
StreamableValue
ValueBase
ValueFactory
ValueInputStream
ValueOutputStream
类
Delegate
InputStream
ObjectImpl
OutputStream
ServantObject
异常
ApplicationException
IndirectionException
RemarshalException
UnknownException


类 org.omg.CORBA.portable.ApplicationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.ApplicationException
的使用

使用 ApplicationException 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 ApplicationException 的使用

抛出 ApplicationException 的 org.omg.CORBA 中的方法
 InputStream LocalObject._invoke(OutputStream output)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

org.omg.CORBA.portable 中 ApplicationException 的使用

抛出 ApplicationException 的 org.omg.CORBA.portable 中的方法
InputStream | ObjectImpl._invoke(OutputStream output) 调用某个操作并返回用来读取响应的 InputStream 对象。
InputStream | Delegate.invoke(Object self, OutputStream output) 由 stub 调用，以调用一个操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.BoxedValueHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.BoxedValueHelper
的使用

使用 BoxedValueHelper 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。

org.omg.CORBA 中 BoxedValueHelper 的使用

实现 BoxedValueHelper 的 org.omg.CORBA 中的类
class | StringValueHelper StringValue 的 Helper。
class | WStringValueHelper org/omg/CORBA/WStringValueHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 orb.idl 中生成，生成时间为 1999 年 5 月 31 日 22:27:30 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范： 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07) ptc/00-01-08 中定义的 IDL/Java 语言映射

org.omg.CORBA_2_3.portable 中 BoxedValueHelper 的使用

参数类型为 BoxedValueHelper 的 org.omg.CORBA_2_3.portable 中的方法
Serializable | InputStream.read_value(BoxedValueHelper factory) 从输入流解组值类型。
void | OutputStream.write_value(Serializable value, BoxedValueHelper factory) 将值类型编组到输出流中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.CustomValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.CustomValue
的使用

没有 org.omg.CORBA.portable.CustomValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.portable.Delegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.Delegate
的使用

使用 Delegate 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 Delegate 的使用

参数类型为 Delegate 的 org.omg.CORBA 中的构造方法
_IDLTypeStub(Delegate delegate)
构造一个 _IDLTypeStub 对象，并使用给定 Delegate 对象初始化。
_PolicyStub(Delegate delegate)
构造一个 _PolicyStub 对象，并使用给定 Delegate 对象初始化。

org.omg.CORBA_2_3.portable 中 Delegate 的使用

org.omg.CORBA_2_3.portable 中 Delegate 的子类
 class Delegate
Delegate 类提供 CORBA 对象特定于 ORB 供应商的实现。

org.omg.CORBA.portable 中 Delegate 的使用

返回 Delegate 的 org.omg.CORBA.portable 中的方法
 Delegate ObjectImpl._get_delegate()
获得对特定于供应商的 Delegate 对象的引用，此 ObjectImpl 对象将对其调用的所有方法委托给该对象。

参数类型为 Delegate 的 org.omg.CORBA.portable 中的方法
 void ObjectImpl._set_delegate(Delegate delegate)
将此 ObjectImpl 实例的 Delegate 设置为给定的 Delegate 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.IDLEntity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.IDLEntity
的使用

使用 IDLEntity 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.SendingContext | 为值类型的编组提供支持。

org.omg.CORBA 中 IDLEntity 的使用

org.omg.CORBA 中 IDLEntity 的子接口
interface | Current 从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
interface | DataInputStream 定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。
interface | DataOutputStream 定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。
interface | DomainManager 提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
interface | IDLType 由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
interface | IRObject IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。
interface | Policy 派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。

实现 IDLEntity 的 org.omg.CORBA 中的类
class | _IDLTypeStub IDLType 的 Stub。
class | _PolicyStub Policy 的 Stub。
class | Any 充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
class | Bounds 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
class | CompletionStatus 指示某一方法抛出 SystemException 时是否已结束运行的对象。
class | DefinitionKind 该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。
class | NameValuePair 将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。
class | ParameterMode Parameter 参数模式的枚举。
class | PolicyError 发生策略错误时抛出的用户异常。
class | ServiceDetail 表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。
class | ServiceInformation CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。
class | SetOverrideType 标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。
class | StructMember 描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。
class | TypeCode 用于有关特定 CORBA 数据类型的信息的容器。
class | UnionMember 接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。
class | UnknownUserException 包含由服务器返回的用户异常的类。
class | UserException CORBA IDL 定义的用户异常的根类。
class | ValueMember 接口存储库 (Interface Repository) 中关于 value 对象成员的描述。
class | WrongTransaction CORBA WrongTransaction 用户定义异常。

org.omg.CORBA.DynAnyPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.CORBA.DynAnyPackage 中的类
class | Invalid 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
class | InvalidSeq 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
class | InvalidValue
class | TypeMismatch 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.CORBA.ORBPackage 中的类
class | InconsistentTypeCode 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
class | InvalidName 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.portable 中 IDLEntity 的使用

org.omg.CORBA.portable 中 IDLEntity 的子接口
interface | CustomValue 通过自定义值类型实现的 ValueBase 扩展。
interface | StreamableValue 为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。
interface | ValueBase 所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。

org.omg.CORBA.TypeCodePackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.CORBA.TypeCodePackage 中的类
 class BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming 中 IDLEntity 的使用

org.omg.CosNaming 中 IDLEntity 的子接口
interface | BindingIterator BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
interface | NamingContext 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
interface | NamingContextExt NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 IDLEntity 的 org.omg.CosNaming 中的类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
class | Binding org/omg/CosNaming/Binding.java。
class | BindingType 指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
class | NameComponent org/omg/CosNaming/NameComponent.java。

org.omg.CosNaming.NamingContextExtPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.CosNaming.NamingContextExtPackage 中的类
 class InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.CosNaming.NamingContextPackage 中的类
class | AlreadyBound org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
class | CannotProceed org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
class | NotEmpty org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
class | NotFound org/omg/CosNaming/NamingContextPackage/NotFound.java。
class | NotFoundReason 指示未能解析的原因。

org.omg.Dynamic 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.Dynamic 中的类
 class Parameter
org/omg/Dynamic/Parameter.java。

org.omg.DynamicAny 中 IDLEntity 的使用

org.omg.DynamicAny 中 IDLEntity 的子接口
interface | DynAny 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
interface | DynAnyFactory DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
interface | DynArray DynArray 对象支持对 IDL 数组的操作。
interface | DynEnum DynEnum 对象支持对 IDL 枚举值的操作。
interface | DynFixed DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
interface | DynSequence DynSequence 对象支持对 IDL 序列的操作。
interface | DynStruct DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
interface | DynUnion DynUnion 对象支持对 IDL 联合 (union) 的操作。
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。

实现 IDLEntity 的 org.omg.DynamicAny 中的类
class | _DynAnyFactoryStub DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。
class | NameDynAnyPair org/omg/DynamicAny/NameDynAnyPair.java。

org.omg.IOP 中 IDLEntity 的使用

org.omg.IOP 中 IDLEntity 的子接口
interface | Codec IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。
interface | CodecFactory Codec 可从 CodecFactory 中获得。

实现 IDLEntity 的 org.omg.IOP 中的类
class | Encoding org/omg/IOP/Encoding.java。
class | IOR org/omg/IOP/IOR.java。
class | ServiceContext org/omg/IOP/ServiceContext.java。
class | TaggedComponent org/omg/IOP/TaggedComponent.java。
class | TaggedProfile org/omg/IOP/TaggedProfile.java。

org.omg.IOP.CodecFactoryPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.IOP.CodecFactoryPackage 中的类
 class UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.IOP.CodecPackage 中的类
class | FormatMismatch org/omg/IOP/CodecPackage/FormatMismatch.java。
class | InvalidTypeForEncoding org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

org.omg.PortableInterceptor 中 IDLEntity 的使用

org.omg.PortableInterceptor 中 IDLEntity 的子接口
interface | ClientRequestInfo 客户端请求 interceptor 可访问的请求信息。
interface | ClientRequestInterceptor 客户端 interceptor。
interface | Interceptor 所有 Portable Interceptor 实现 Interceptor。
interface | IORInfo 提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | ObjectReferenceFactory 对象引用工厂。
interface | ObjectReferenceTemplate 对象引用模板。
interface | ORBInitializer 便于注册 interceptor 和初始化 ORB。
interface | ORBInitInfo 传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
interface | PolicyFactory 使得策略类型能够使用 CORBA.ORB.create_policy 来构建。
interface | RequestInfo Interceptor 可访问的请求信息。
interface | ServerRequestInfo 服务器端请求 interceptor 可访问的请求信息。
interface | ServerRequestInterceptor 服务器端的请求 interceptor。

实现 IDLEntity 的 org.omg.PortableInterceptor 中的类
 class InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的类
 class DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

org.omg.PortableServer 中 IDLEntity 的使用

org.omg.PortableServer 中 IDLEntity 的子接口
interface | AdapterActivator 一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
interface | IdAssignmentPolicy IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdUniquenessPolicy IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | ImplicitActivationPolicy 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | LifespanPolicy LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | POA POA 对象管理对象集合的实现。
interface | POAManager 每个 POA 对象都有一个关联的 POAManager 对象。
interface | RequestProcessingPolicy 此策略指定已创建的 POA 处理请求的方式。
interface | ServantActivator POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantLocator 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
interface | ServantManager servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
interface | ServantRetentionPolicy 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ThreadPolicy ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。

实现 IDLEntity 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
class | ForwardRequest org/omg/PortableServer/ForwardRequest.java。
class | IdAssignmentPolicyValue IdAssignmentPolicyValue 可以具有以下值。
class | IdUniquenessPolicyValue IdUniquenessPolicyValue 可以具有以下值。
class | ImplicitActivationPolicyValue ImplicitActivationPolicyValue 具有以下语义。
class | LifespanPolicyValue LifespanPolicyValue 可以具有以下值。
class | RequestProcessingPolicyValue RequestProcessingPolicyValue 可以具有以下值。
class | ServantRetentionPolicyValue ServantRetentionPolicyValue 可以具有以下值。
class | ThreadPolicyValue ThreadPolicyValue 可以具有以下值。

org.omg.PortableServer.CurrentPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.PortableServer.CurrentPackage 中的类
 class NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.POAManagerPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.PortableServer.POAManagerPackage 中的类
class | AdapterInactive org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。
class | State 指定 POAManager 的状态。

org.omg.PortableServer.POAPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.PortableServer.POAPackage 中的类
class | AdapterAlreadyExists org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
class | AdapterNonExistent org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
class | InvalidPolicy org/omg/PortableServer/POAPackage/InvalidPolicy.java。
class | NoServant org/omg/PortableServer/POAPackage/NoServant.java。
class | ObjectAlreadyActive org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
class | ObjectNotActive org/omg/PortableServer/POAPackage/ObjectNotActive.java。
class | ServantAlreadyActive org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
class | ServantNotActive org/omg/PortableServer/POAPackage/ServantNotActive.java。
class | WrongAdapter org/omg/PortableServer/POAPackage/WrongAdapter.java。
class | WrongPolicy org/omg/PortableServer/POAPackage/WrongPolicy.java。

org.omg.SendingContext 中 IDLEntity 的使用

org.omg.SendingContext 中 IDLEntity 的子接口
 interface RunTime
定义表示请求的发送上下文的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.portable.IndirectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.IndirectionException
的使用

没有 org.omg.CORBA.portable.IndirectionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.portable.InputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.InputStream
的使用

使用 InputStream 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。

javax.rmi.CORBA 中 InputStream 的使用

参数类型为 InputStream 的 javax.rmi.CORBA 中的方法
static Object Util.readAny(InputStream in)
将 java.lang.Object 作为 CORBA any 读取。
 Object UtilDelegate.readAny(InputStream in)
Util.readAny(org.omg.CORBA.portable.InputStream) 的委托调用。
 Serializable ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
使用 Java 语义从流中读取一个值。

org.omg.CORBA 中 InputStream 的使用

返回 InputStream 的 org.omg.CORBA 中的方法
InputStream | LocalObject._invoke(OutputStream output) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
abstract InputStream | Any.create_input_stream() 创建一个输入流，可以从中解组此 Any 对象的值。

参数类型为 InputStream 的 org.omg.CORBA 中的方法
void | AnyHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
void | AnySeqHolder._read(InputStream i)
void | BooleanHolder._read(InputStream input) 从 input 中读取已解组的数据，并将它们分配给此 BooleanHolder 对象的 value 字段。
void | BooleanSeqHolder._read(InputStream i)
void | ByteHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 ByteHolder 对象中的值。
void | CharHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 CharHolder 对象中的值。
void | CharSeqHolder._read(InputStream i)
void | CurrentHolder._read(InputStream i)
void | DoubleHolder._read(InputStream input) 从输入流读取一个 double 值，并将其存储在值成员中。
void | DoubleSeqHolder._read(InputStream i)
void | FixedHolder._read(InputStream input) 从输入流读取定点值，并将其存储在值成员中。
void | FloatHolder._read(InputStream input) 从输入流读取一个 float 值，并使用该 float 值初始化值成员。
void | FloatSeqHolder._read(InputStream i)
void | IntHolder._read(InputStream input) 从 input 中读取已解组数据，并将其分配给此 IntHolder 对象的 value 字段。
void | LongHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
void | LongLongSeqHolder._read(InputStream i)
void | LongSeqHolder._read(InputStream i)
void | ObjectHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 ObjectHolder 对象中的值。
void | OctetSeqHolder._read(InputStream i)
void | ParameterModeHolder._read(InputStream i)
void | PolicyErrorHolder._read(InputStream i)
void | PolicyHolder._read(InputStream i)
void | PolicyListHolder._read(InputStream i)
void | PrincipalHolder._read(InputStream input) 已过时。
void | ServiceInformationHolder._read(InputStream in) 从输入流 in 中读取已解组数据，并将它赋予此 ServiceInformationHolder 对象的 value 字段。
void | ShortHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 ShortHolder 对象中的值。
void | ShortSeqHolder._read(InputStream i)
void | StringHolder._read(InputStream input) 从 input 中读取已解组的数据，并将它赋予此 StringHolder 对象的 value 字段。
void | StringSeqHolder._read(InputStream i)
void | TypeCodeHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 TypeCodeHolder 对象中的值。
void | ULongLongSeqHolder._read(InputStream i)
void | ULongSeqHolder._read(InputStream i)
void | UShortSeqHolder._read(InputStream i)
void | UnknownUserExceptionHolder._read(InputStream i)
void | ValueBaseHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
void | WCharSeqHolder._read(InputStream i)
void | WStringSeqHolder._read(InputStream i)
void | WrongTransactionHolder._read(InputStream i)
void | LocalObject._releaseReply(InputStream input) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Serializable | StringValueHelper.read_value(InputStream istream)
Serializable | WStringValueHelper.read_value(InputStream istream)
abstract void | Any.read_value(InputStream is, TypeCode t) 使用给定 typecode 读出（解组）给定输入流中某一 Any 对象的值。
static Any[] | AnySeqHelper.read(InputStream istream)
static boolean[] | BooleanSeqHelper.read(InputStream istream)
static char[] | CharSeqHelper.read(InputStream istream)
static CompletionStatus | CompletionStatusHelper.read(InputStream istream)
static Current | CurrentHelper.read(InputStream istream)
static DefinitionKind | DefinitionKindHelper.read(InputStream istream)
static double[] | DoubleSeqHelper.read(InputStream istream)
static String | FieldNameHelper.read(InputStream istream)
static float[] | FloatSeqHelper.read(InputStream istream)
static IDLType | IDLTypeHelper.read(InputStream istream)
static String | IdentifierHelper.read(InputStream istream)
static long[] | LongLongSeqHelper.read(InputStream istream)
static int[] | LongSeqHelper.read(InputStream istream)
static NameValuePair | NameValuePairHelper.read(InputStream istream)
static Object | ObjectHelper.read(InputStream istream)
static byte[] | OctetSeqHelper.read(InputStream istream)
static ParameterMode | ParameterModeHelper.read(InputStream istream)
static short | PolicyErrorCodeHelper.read(InputStream istream)
static PolicyError | PolicyErrorHelper.read(InputStream istream)
static Policy | PolicyHelper.read(InputStream istream)
static Policy[] | PolicyListHelper.read(InputStream istream)
static int | PolicyTypeHelper.read(InputStream istream)
static String | RepositoryIdHelper.read(InputStream istream)
static ServiceDetail | ServiceDetailHelper.read(InputStream in)
static ServiceInformation | ServiceInformationHelper.read(InputStream in)
static SetOverrideType | SetOverrideTypeHelper.read(InputStream istream)
static short[] | ShortSeqHelper.read(InputStream istream)
static String[] | StringSeqHelper.read(InputStream istream)
static String | StringValueHelper.read(InputStream istream)
static StructMember | StructMemberHelper.read(InputStream istream)
static long[] | ULongLongSeqHelper.read(InputStream istream)
static int[] | ULongSeqHelper.read(InputStream istream)
static short[] | UShortSeqHelper.read(InputStream istream)
static UnionMember | UnionMemberHelper.read(InputStream istream)
static UnknownUserException | UnknownUserExceptionHelper.read(InputStream istream)
static Serializable | ValueBaseHelper.read(InputStream istream)
static ValueMember | ValueMemberHelper.read(InputStream istream)
static String | VersionSpecHelper.read(InputStream istream)
static short | VisibilityHelper.read(InputStream istream)
static char[] | WCharSeqHelper.read(InputStream istream)
static String[] | WStringSeqHelper.read(InputStream istream)
static String | WStringValueHelper.read(InputStream istream)
static WrongTransaction | WrongTransactionHelper.read(InputStream istream)

org.omg.CORBA_2_3.portable 中 InputStream 的使用

org.omg.CORBA_2_3.portable 中 InputStream 的子类
 class InputStream
InputStream 提供从流读取所有映射的 IDL 类型的接口。

org.omg.CORBA.portable 中 InputStream 的使用

返回 InputStream 的 org.omg.CORBA.portable 中的方法
InputStream | ObjectImpl._invoke(OutputStream output) 调用某个操作并返回用来读取响应的 InputStream 对象。
abstract InputStream | OutputStream.create_input_stream() 返回一个具有相同缓冲区的输入流。
InputStream | ApplicationException.getInputStream() 返回可从中读取异常数据作为其参数的输入流。
InputStream | Delegate.invoke(Object self, OutputStream output) 由 stub 调用，以调用一个操作。

参数类型为 InputStream 的 org.omg.CORBA.portable 中的方法
OutputStream | InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler) 由 ORB 调用来调度对 servant 的请求。
void | Streamable._read(InputStream istream) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
void | ObjectImpl._releaseReply(InputStream input) 调用 _invoke 方法并且解组完成后，将给定的应答流释放回 ORB。
Serializable | BoxedValueHelper.read_value(InputStream is)
void | Delegate.releaseReply(Object self, InputStream input) releaseReply 可以由 stub 以可选方式调用，以在解组完成时将应答流释放回 ORB。

参数类型为 InputStream 的 org.omg.CORBA.portable 中的构造方法
ApplicationException(String id, InputStream ins)
根据异常的 CORBA 存储库 ID 和一个输入流（可从中读取异常数据作为其参数）构造 ApplicationException。

org.omg.CosNaming 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.CosNaming 中的方法
OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
void | BindingHolder._read(InputStream i)
void | BindingIteratorHolder._read(InputStream i)
void | BindingListHolder._read(InputStream i)
void | BindingTypeHolder._read(InputStream i)
void | NameComponentHolder._read(InputStream i)
void | NameHolder._read(InputStream i)
void | NamingContextExtHolder._read(InputStream i)
void | NamingContextHolder._read(InputStream i)
static Binding | BindingHelper.read(InputStream istream)
static BindingIterator | BindingIteratorHelper.read(InputStream istream)
static Binding[] | BindingListHelper.read(InputStream istream)
static BindingType | BindingTypeHelper.read(InputStream istream)
static String | IstringHelper.read(InputStream istream)
static NameComponent | NameComponentHelper.read(InputStream istream)
static NameComponent[] | NameHelper.read(InputStream istream)
static NamingContextExt | NamingContextExtHelper.read(InputStream istream)
static NamingContext | NamingContextHelper.read(InputStream istream)

org.omg.CosNaming.NamingContextExtPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
void | InvalidAddressHolder._read(InputStream i)
static String | AddressHelper.read(InputStream istream)
static InvalidAddress | InvalidAddressHelper.read(InputStream istream)
static String | StringNameHelper.read(InputStream istream)
static String | URLStringHelper.read(InputStream istream)

org.omg.CosNaming.NamingContextPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.CosNaming.NamingContextPackage 中的方法
void | AlreadyBoundHolder._read(InputStream i)
void | CannotProceedHolder._read(InputStream i)
void | InvalidNameHolder._read(InputStream i)
void | NotEmptyHolder._read(InputStream i)
void | NotFoundHolder._read(InputStream i)
void | NotFoundReasonHolder._read(InputStream i)
static AlreadyBound | AlreadyBoundHelper.read(InputStream istream)
static CannotProceed | CannotProceedHelper.read(InputStream istream)
static InvalidName | InvalidNameHelper.read(InputStream istream)
static NotEmpty | NotEmptyHelper.read(InputStream istream)
static NotFound | NotFoundHelper.read(InputStream istream)
static NotFoundReason | NotFoundReasonHelper.read(InputStream istream)

org.omg.DynamicAny 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.DynamicAny 中的方法
static Any[] | AnySeqHelper.read(InputStream istream)
static DynAnyFactory | DynAnyFactoryHelper.read(InputStream istream)
static DynAny | DynAnyHelper.read(InputStream istream)
static DynAny[] | DynAnySeqHelper.read(InputStream istream)
static DynArray | DynArrayHelper.read(InputStream istream)
static DynEnum | DynEnumHelper.read(InputStream istream)
static DynFixed | DynFixedHelper.read(InputStream istream)
static DynSequence | DynSequenceHelper.read(InputStream istream)
static DynStruct | DynStructHelper.read(InputStream istream)
static DynUnion | DynUnionHelper.read(InputStream istream)
static DynValue | DynValueHelper.read(InputStream istream)
static String | FieldNameHelper.read(InputStream istream)
static NameDynAnyPair | NameDynAnyPairHelper.read(InputStream istream)
static NameDynAnyPair[] | NameDynAnyPairSeqHelper.read(InputStream istream)
static NameValuePair | NameValuePairHelper.read(InputStream istream)
static NameValuePair[] | NameValuePairSeqHelper.read(InputStream istream)

org.omg.DynamicAny.DynAnyFactoryPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static InconsistentTypeCode InconsistentTypeCodeHelper.read(InputStream istream)

org.omg.DynamicAny.DynAnyPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static InvalidValue | InvalidValueHelper.read(InputStream istream)
static TypeMismatch | TypeMismatchHelper.read(InputStream istream)

org.omg.IOP 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.IOP 中的方法
void | IORHolder._read(InputStream i)
void | MultipleComponentProfileHolder._read(InputStream i)
void | ServiceContextHolder._read(InputStream i)
void | ServiceContextListHolder._read(InputStream i)
void | TaggedComponentHolder._read(InputStream i)
void | TaggedProfileHolder._read(InputStream i)
static CodecFactory | CodecFactoryHelper.read(InputStream istream)
static int | ComponentIdHelper.read(InputStream istream)
static IOR | IORHelper.read(InputStream istream)
static TaggedComponent[] | MultipleComponentProfileHelper.read(InputStream istream)
static int | ProfileIdHelper.read(InputStream istream)
static ServiceContext | ServiceContextHelper.read(InputStream istream)
static ServiceContext[] | ServiceContextListHelper.read(InputStream istream)
static int | ServiceIdHelper.read(InputStream istream)
static TaggedComponent | TaggedComponentHelper.read(InputStream istream)
static TaggedProfile | TaggedProfileHelper.read(InputStream istream)

org.omg.IOP.CodecFactoryPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.IOP.CodecFactoryPackage 中的方法
static UnknownEncoding UnknownEncodingHelper.read(InputStream istream)

org.omg.IOP.CodecPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.IOP.CodecPackage 中的方法
static FormatMismatch | FormatMismatchHelper.read(InputStream istream)
static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.read(InputStream istream)
static TypeMismatch | TypeMismatchHelper.read(InputStream istream)

org.omg.Messaging 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.Messaging 中的方法
static short SyncScopeHelper.read(InputStream istream)

org.omg.PortableInterceptor 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableInterceptor 中的方法
void | IORInterceptor_3_0Holder._read(InputStream i)
void | ObjectReferenceFactoryHolder._read(InputStream i)
void | ObjectReferenceTemplateHolder._read(InputStream i)
void | ObjectReferenceTemplateSeqHolder._read(InputStream i)
static int | AdapterManagerIdHelper.read(InputStream istream)
static String[] | AdapterNameHelper.read(InputStream istream)
static short | AdapterStateHelper.read(InputStream istream)
static Current | CurrentHelper.read(InputStream istream)
static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.read(InputStream istream)
static InvalidSlot | InvalidSlotHelper.read(InputStream istream)
static String | ORBIdHelper.read(InputStream istream)
static byte[] | ObjectIdHelper.read(InputStream istream)
static ObjectReferenceFactory | ObjectReferenceFactoryHelper.read(InputStream istream)
static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.read(InputStream istream)
static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.read(InputStream istream)
static String | ServerIdHelper.read(InputStream istream)

org.omg.PortableInterceptor.ORBInitInfoPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static DuplicateName | DuplicateNameHelper.read(InputStream istream)
static InvalidName | InvalidNameHelper.read(InputStream istream)
static String | ObjectIdHelper.read(InputStream istream)

org.omg.PortableServer 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableServer 中的方法
OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
static Current | CurrentHelper.read(InputStream istream)
static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
static POA | POAHelper.read(InputStream istream)
static ServantActivator | ServantActivatorHelper.read(InputStream istream)
static ServantLocator | ServantLocatorHelper.read(InputStream istream)

org.omg.PortableServer.CurrentPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableServer.CurrentPackage 中的方法
static NoContext NoContextHelper.read(InputStream istream)

org.omg.PortableServer.POAManagerPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableServer.POAManagerPackage 中的方法
static AdapterInactive AdapterInactiveHelper.read(InputStream istream)

org.omg.PortableServer.POAPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableServer.POAPackage 中的方法
static AdapterAlreadyExists | AdapterAlreadyExistsHelper.read(InputStream istream)
static AdapterNonExistent | AdapterNonExistentHelper.read(InputStream istream)
static InvalidPolicy | InvalidPolicyHelper.read(InputStream istream)
static NoServant | NoServantHelper.read(InputStream istream)
static ObjectAlreadyActive | ObjectAlreadyActiveHelper.read(InputStream istream)
static ObjectNotActive | ObjectNotActiveHelper.read(InputStream istream)
static ServantAlreadyActive | ServantAlreadyActiveHelper.read(InputStream istream)
static ServantNotActive | ServantNotActiveHelper.read(InputStream istream)
static WrongAdapter | WrongAdapterHelper.read(InputStream istream)
static WrongPolicy | WrongPolicyHelper.read(InputStream istream)

org.omg.PortableServer.ServantLocatorPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableServer.ServantLocatorPackage 中的方法
 void CookieHolder._read(InputStream is)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.InvokeHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.InvokeHandler
的使用

使用 InvokeHandler 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

javax.rmi.CORBA 中 InvokeHandler 的使用

javax.rmi.CORBA 中 InvokeHandler 的子接口
 interface Tie
定义所有 RMI-IIOP 服务器端 tie 必须实现的方法。

org.omg.CosNaming 中 InvokeHandler 的使用

实现 InvokeHandler 的 org.omg.CosNaming 中的类
class | BindingIteratorPOA BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
class | NamingContextExtPOA NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | NamingContextPOA 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.PortableServer 中 InvokeHandler 的使用

实现 InvokeHandler 的 org.omg.PortableServer 中的类
class | ServantActivatorPOA POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
class | ServantLocatorPOA POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.portable.ObjectImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.ObjectImpl
的使用

使用 ObjectImpl 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 中 ObjectImpl 的使用

javax.rmi.CORBA 中 ObjectImpl 的子类
 class Stub
必须从其继承所有 RMI-IIOP stub 的基类。

org.omg.CORBA 中 ObjectImpl 的使用

org.omg.CORBA 中 ObjectImpl 的子类
class | _IDLTypeStub IDLType 的 Stub。
class | _PolicyStub Policy 的 Stub。
class | DynamicImplementation 已过时。 org.omg.CORBA.DynamicImplementation

org.omg.CORBA_2_3.portable 中 ObjectImpl 的使用

org.omg.CORBA_2_3.portable 中 ObjectImpl 的子类
 class ObjectImpl
ObjectImpl 类是所有 stub 的基类。

org.omg.CosNaming 中 ObjectImpl 的使用

org.omg.CosNaming 中 ObjectImpl 的子类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.DynamicAny 中 ObjectImpl 的使用

org.omg.DynamicAny 中 ObjectImpl 的子类
class | _DynAnyFactoryStub DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。

org.omg.PortableServer 中 ObjectImpl 的使用

org.omg.PortableServer 中 ObjectImpl 的子类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。

org.omg.stub.java.rmi 中 ObjectImpl 的使用

org.omg.stub.java.rmi 中 ObjectImpl 的子类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.portable.OutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.OutputStream
的使用

使用 OutputStream 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。

javax.rmi.CORBA 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.rmi.CORBA 中的方法
static void Util.writeAbstractObject(OutputStream out, Object obj)
将 java.lang.Object 作为一个值或 CORBA Object 写入。
 void UtilDelegate.writeAbstractObject(OutputStream out, Object obj)
Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
static void Util.writeAny(OutputStream out, Object obj)
将 any java.lang.Object 作为 CORBA any 写入。
 void UtilDelegate.writeAny(OutputStream out, Object obj)
Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
static void Util.writeRemoteObject(OutputStream out, Object obj)
将 java.lang.Object 作为 CORBA Object 写入。
 void UtilDelegate.writeRemoteObject(OutputStream out, Object obj)
Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
 void ValueHandler.writeValue(OutputStream out, Serializable value)
使用 Java 语义将一个值写入流。
 void ValueHandlerMultiFormat.writeValue(OutputStream out, Serializable value, byte streamFormatVersion)
允许 ORB 为 RMI/IDL 自定义值类型传递流格式版本。

org.omg.CORBA 中 OutputStream 的使用

返回 OutputStream 的 org.omg.CORBA 中的方法
OutputStream | LocalObject._request(String operation, boolean responseExpected) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
abstract OutputStream | Any.create_output_stream() 创建一个输出流，可以将此 Any 对象的值编组到其中。
abstract OutputStream | ORB.create_output_stream() 创建一个新的 org.omg.CORBA.portable.OutputStream，在执行方法调用期间，可在该输出流中对 IDL 方法参数进行编组。

参数类型为 OutputStream 的 org.omg.CORBA 中的方法
InputStream | LocalObject._invoke(OutputStream output) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
void | AnyHolder._write(OutputStream output) 将此 AnyHolder 对象中的值编组到 output。
void | AnySeqHolder._write(OutputStream o)
void | BooleanHolder._write(OutputStream output) 将此 BooleanHolder 对象 value 字段中的值编组到输出流 output。
void | BooleanSeqHolder._write(OutputStream o)
void | ByteHolder._write(OutputStream output) 将此 ByteHolder 对象中的值编组到 output。
void | CharHolder._write(OutputStream output) 将此 CharHolder 对象中的值编组到 output。
void | CharSeqHolder._write(OutputStream o)
void | CurrentHolder._write(OutputStream o)
void | DoubleHolder._write(OutputStream output) 将存储在此 holder 中的 double 值写入 OutputStream。
void | DoubleSeqHolder._write(OutputStream o)
void | FixedHolder._write(OutputStream output) 将存储在此 holder 中的定点值写入 OutputStream。
void | FloatHolder._write(OutputStream output) 将 float 值写入输出流。
void | FloatSeqHolder._write(OutputStream o)
void | IntHolder._write(OutputStream output) 将此 IntHolder 对象 value 字段中的值编组到输出流 output 中。
void | LongHolder._write(OutputStream output) 将此 Holder 中的值编组到 output。
void | LongLongSeqHolder._write(OutputStream o)
void | LongSeqHolder._write(OutputStream o)
void | ObjectHolder._write(OutputStream output) 将此 ObjectHolder 对象中的值编组到 output。
void | OctetSeqHolder._write(OutputStream o)
void | ParameterModeHolder._write(OutputStream o)
void | PolicyErrorHolder._write(OutputStream o)
void | PolicyHolder._write(OutputStream o)
void | PolicyListHolder._write(OutputStream o)
void | PrincipalHolder._write(OutputStream output) 已过时。
void | ServiceInformationHolder._write(OutputStream out) 将此 ServiceInformationHolder 对象的 value 字段中的值编组到输出流 out。
void | ShortHolder._write(OutputStream output) 将此 ShortHolder 对象中的值编组到 output。
void | ShortSeqHolder._write(OutputStream o)
void | StringHolder._write(OutputStream output) 将此 StringHolder 对象所保存的值编组到输出流 output。
void | StringSeqHolder._write(OutputStream o)
void | TypeCodeHolder._write(OutputStream output) 将此 TypeCodeHolder 对象中的值编组到 output。
void | ULongLongSeqHolder._write(OutputStream o)
void | ULongSeqHolder._write(OutputStream o)
void | UShortSeqHolder._write(OutputStream o)
void | UnknownUserExceptionHolder._write(OutputStream o)
void | ValueBaseHolder._write(OutputStream output) 将此 Holder 中的值编组到 output。
void | WCharSeqHolder._write(OutputStream o)
void | WStringSeqHolder._write(OutputStream o)
void | WrongTransactionHolder._write(OutputStream o)
abstract void | Any.write_value(OutputStream os) 将此 Any 对象的值写出到给定输出流。
void | StringValueHelper.write_value(OutputStream ostream, Serializable value)
void | WStringValueHelper.write_value(OutputStream ostream, Serializable value)
static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
static void | BooleanSeqHelper.write(OutputStream ostream, boolean[] value)
static void | OctetSeqHelper.write(OutputStream ostream, byte[] value)
static void | CharSeqHelper.write(OutputStream ostream, char[] value)
static void | WCharSeqHelper.write(OutputStream ostream, char[] value)
static void | CompletionStatusHelper.write(OutputStream ostream, CompletionStatus value)
static void | CurrentHelper.write(OutputStream ostream, Current value)
static void | DefinitionKindHelper.write(OutputStream ostream, DefinitionKind value)
static void | DoubleSeqHelper.write(OutputStream ostream, double[] value)
static void | FloatSeqHelper.write(OutputStream ostream, float[] value)
static void | IDLTypeHelper.write(OutputStream ostream, IDLType value)
static void | PolicyTypeHelper.write(OutputStream ostream, int value)
static void | LongSeqHelper.write(OutputStream ostream, int[] value)
static void | ULongSeqHelper.write(OutputStream ostream, int[] value)
static void | LongLongSeqHelper.write(OutputStream ostream, long[] value)
static void | ULongLongSeqHelper.write(OutputStream ostream, long[] value)
static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
static void | ObjectHelper.write(OutputStream ostream, Object value)
static void | ParameterModeHelper.write(OutputStream ostream, ParameterMode value)
static void | PolicyHelper.write(OutputStream ostream, Policy value)
static void | PolicyListHelper.write(OutputStream ostream, Policy[] value)
static void | PolicyErrorHelper.write(OutputStream ostream, PolicyError value)
static void | ValueBaseHelper.write(OutputStream ostream, Serializable value)
static void | ServiceDetailHelper.write(OutputStream out, ServiceDetail that)
static void | ServiceInformationHelper.write(OutputStream out, ServiceInformation that)
static void | SetOverrideTypeHelper.write(OutputStream ostream, SetOverrideType value)
static void | PolicyErrorCodeHelper.write(OutputStream ostream, short value)
static void | VisibilityHelper.write(OutputStream ostream, short value)
static void | ShortSeqHelper.write(OutputStream ostream, short[] value)
static void | UShortSeqHelper.write(OutputStream ostream, short[] value)
static void | FieldNameHelper.write(OutputStream ostream, String value)
static void | IdentifierHelper.write(OutputStream ostream, String value)
static void | RepositoryIdHelper.write(OutputStream ostream, String value)
static void | StringValueHelper.write(OutputStream ostream, String value)
static void | VersionSpecHelper.write(OutputStream ostream, String value)
static void | WStringValueHelper.write(OutputStream ostream, String value)
static void | StringSeqHelper.write(OutputStream ostream, String[] value)
static void | WStringSeqHelper.write(OutputStream ostream, String[] value)
static void | StructMemberHelper.write(OutputStream ostream, StructMember value)
static void | UnionMemberHelper.write(OutputStream ostream, UnionMember value)
static void | UnknownUserExceptionHelper.write(OutputStream ostream, UnknownUserException value)
static void | ValueMemberHelper.write(OutputStream ostream, ValueMember value)
static void | WrongTransactionHelper.write(OutputStream ostream, WrongTransaction value)

org.omg.CORBA_2_3.portable 中 OutputStream 的使用

org.omg.CORBA_2_3.portable 中 OutputStream 的子类
 class OutputStream
OutputStream 提供将所有映射的 IDL 类型写入流的接口。

org.omg.CORBA.portable 中 OutputStream 的使用

返回 OutputStream 的 org.omg.CORBA.portable 中的方法
OutputStream | InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler) 由 ORB 调用来调度对 servant 的请求。
OutputStream | ObjectImpl._request(String operation, boolean responseExpected) 返回一个 OutputStream 对象，该对象用于编组给定方法的参数。
OutputStream | ResponseHandler.createExceptionReply() 在方法调用期间由 servant 调用。
OutputStream | ResponseHandler.createReply() 在方法调用期间由 servant 调用。
OutputStream | Delegate.request(Object self, String operation, boolean responseExpected) request 由 stub 调用，以获取用于编组参数的 OutputStream。

参数类型为 OutputStream 的 org.omg.CORBA.portable 中的方法
InputStream | ObjectImpl._invoke(OutputStream output) 调用某个操作并返回用来读取响应的 InputStream 对象。
void | Streamable._write(OutputStream ostream) 将 Holder 中 value 字段的值编组到 ostream。
InputStream | Delegate.invoke(Object self, OutputStream output) 由 stub 调用，以调用一个操作。
void | BoxedValueHelper.write_value(OutputStream os, Serializable value)

org.omg.CosNaming 中 OutputStream 的使用

返回 OutputStream 的 org.omg.CosNaming 中的方法
OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

参数类型为 OutputStream 的 org.omg.CosNaming 中的方法
void | BindingHolder._write(OutputStream o)
void | BindingIteratorHolder._write(OutputStream o)
void | BindingListHolder._write(OutputStream o)
void | BindingTypeHolder._write(OutputStream o)
void | NameComponentHolder._write(OutputStream o)
void | NameHolder._write(OutputStream o)
void | NamingContextExtHolder._write(OutputStream o)
void | NamingContextHolder._write(OutputStream o)
static void | BindingHelper.write(OutputStream ostream, Binding value)
static void | BindingListHelper.write(OutputStream ostream, Binding[] value)
static void | BindingIteratorHelper.write(OutputStream ostream, BindingIterator value)
static void | BindingTypeHelper.write(OutputStream ostream, BindingType value)
static void | NameComponentHelper.write(OutputStream ostream, NameComponent value)
static void | NameHelper.write(OutputStream ostream, NameComponent[] value)
static void | NamingContextHelper.write(OutputStream ostream, NamingContext value)
static void | NamingContextExtHelper.write(OutputStream ostream, NamingContextExt value)
static void | IstringHelper.write(OutputStream ostream, String value)

org.omg.CosNaming.NamingContextExtPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
void | InvalidAddressHolder._write(OutputStream o)
static void | InvalidAddressHelper.write(OutputStream ostream, InvalidAddress value)
static void | AddressHelper.write(OutputStream ostream, String value)
static void | StringNameHelper.write(OutputStream ostream, String value)
static void | URLStringHelper.write(OutputStream ostream, String value)

org.omg.CosNaming.NamingContextPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.CosNaming.NamingContextPackage 中的方法
void | AlreadyBoundHolder._write(OutputStream o)
void | CannotProceedHolder._write(OutputStream o)
void | InvalidNameHolder._write(OutputStream o)
void | NotEmptyHolder._write(OutputStream o)
void | NotFoundHolder._write(OutputStream o)
void | NotFoundReasonHolder._write(OutputStream o)
static void | AlreadyBoundHelper.write(OutputStream ostream, AlreadyBound value)
static void | CannotProceedHelper.write(OutputStream ostream, CannotProceed value)
static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
static void | NotEmptyHelper.write(OutputStream ostream, NotEmpty value)
static void | NotFoundHelper.write(OutputStream ostream, NotFound value)
static void | NotFoundReasonHelper.write(OutputStream ostream, NotFoundReason value)

org.omg.DynamicAny 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.DynamicAny 中的方法
static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
static void | DynAnyHelper.write(OutputStream ostream, DynAny value)
static void | DynAnySeqHelper.write(OutputStream ostream, DynAny[] value)
static void | DynAnyFactoryHelper.write(OutputStream ostream, DynAnyFactory value)
static void | DynArrayHelper.write(OutputStream ostream, DynArray value)
static void | DynEnumHelper.write(OutputStream ostream, DynEnum value)
static void | DynFixedHelper.write(OutputStream ostream, DynFixed value)
static void | DynSequenceHelper.write(OutputStream ostream, DynSequence value)
static void | DynStructHelper.write(OutputStream ostream, DynStruct value)
static void | DynUnionHelper.write(OutputStream ostream, DynUnion value)
static void | DynValueHelper.write(OutputStream ostream, DynValue value)
static void | NameDynAnyPairHelper.write(OutputStream ostream, NameDynAnyPair value)
static void | NameDynAnyPairSeqHelper.write(OutputStream ostream, NameDynAnyPair[] value)
static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
static void | NameValuePairSeqHelper.write(OutputStream ostream, NameValuePair[] value)
static void | FieldNameHelper.write(OutputStream ostream, String value)

org.omg.DynamicAny.DynAnyFactoryPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static void InconsistentTypeCodeHelper.write(OutputStream ostream, InconsistentTypeCode value)

org.omg.DynamicAny.DynAnyPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static void | InvalidValueHelper.write(OutputStream ostream, InvalidValue value)
static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

org.omg.IOP 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.IOP 中的方法
void | IORHolder._write(OutputStream o)
void | MultipleComponentProfileHolder._write(OutputStream o)
void | ServiceContextHolder._write(OutputStream o)
void | ServiceContextListHolder._write(OutputStream o)
void | TaggedComponentHolder._write(OutputStream o)
void | TaggedProfileHolder._write(OutputStream o)
static void | CodecFactoryHelper.write(OutputStream ostream, CodecFactory value)
static void | ComponentIdHelper.write(OutputStream ostream, int value)
static void | ProfileIdHelper.write(OutputStream ostream, int value)
static void | ServiceIdHelper.write(OutputStream ostream, int value)
static void | IORHelper.write(OutputStream ostream, IOR value)
static void | ServiceContextHelper.write(OutputStream ostream, ServiceContext value)
static void | ServiceContextListHelper.write(OutputStream ostream, ServiceContext[] value)
static void | TaggedComponentHelper.write(OutputStream ostream, TaggedComponent value)
static void | MultipleComponentProfileHelper.write(OutputStream ostream, TaggedComponent[] value)
static void | TaggedProfileHelper.write(OutputStream ostream, TaggedProfile value)

org.omg.IOP.CodecFactoryPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.IOP.CodecFactoryPackage 中的方法
static void UnknownEncodingHelper.write(OutputStream ostream, UnknownEncoding value)

org.omg.IOP.CodecPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.IOP.CodecPackage 中的方法
static void | FormatMismatchHelper.write(OutputStream ostream, FormatMismatch value)
static void | InvalidTypeForEncodingHelper.write(OutputStream ostream, InvalidTypeForEncoding value)
static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

org.omg.Messaging 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.Messaging 中的方法
static void SyncScopeHelper.write(OutputStream ostream, short value)

org.omg.PortableInterceptor 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableInterceptor 中的方法
void | IORInterceptor_3_0Holder._write(OutputStream o)
void | ObjectReferenceFactoryHolder._write(OutputStream o)
void | ObjectReferenceTemplateHolder._write(OutputStream o)
void | ObjectReferenceTemplateSeqHolder._write(OutputStream o)
static void | ObjectIdHelper.write(OutputStream ostream, byte[] value)
static void | CurrentHelper.write(OutputStream ostream, Current value)
static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
static void | AdapterManagerIdHelper.write(OutputStream ostream, int value)
static void | InvalidSlotHelper.write(OutputStream ostream, InvalidSlot value)
static void | IORInterceptor_3_0Helper.write(OutputStream ostream, IORInterceptor_3_0 value)
static void | ObjectReferenceFactoryHelper.write(OutputStream ostream, ObjectReferenceFactory value)
static void | ObjectReferenceTemplateHelper.write(OutputStream ostream, ObjectReferenceTemplate value)
static void | ObjectReferenceTemplateSeqHelper.write(OutputStream ostream, ObjectReferenceTemplate[] value)
static void | AdapterStateHelper.write(OutputStream ostream, short value)
static void | ORBIdHelper.write(OutputStream ostream, String value)
static void | ServerIdHelper.write(OutputStream ostream, String value)
static void | AdapterNameHelper.write(OutputStream ostream, String[] value)

org.omg.PortableInterceptor.ORBInitInfoPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static void | DuplicateNameHelper.write(OutputStream ostream, DuplicateName value)
static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
static void | ObjectIdHelper.write(OutputStream ostream, String value)

org.omg.PortableServer 中 OutputStream 的使用

返回 OutputStream 的 org.omg.PortableServer 中的方法
OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

参数类型为 OutputStream 的 org.omg.PortableServer 中的方法
static void | CurrentHelper.write(OutputStream ostream, Current value)
static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
static void | POAHelper.write(OutputStream ostream, POA value)
static void | ServantActivatorHelper.write(OutputStream ostream, ServantActivator value)
static void | ServantLocatorHelper.write(OutputStream ostream, ServantLocator value)

org.omg.PortableServer.CurrentPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableServer.CurrentPackage 中的方法
static void NoContextHelper.write(OutputStream ostream, NoContext value)

org.omg.PortableServer.POAManagerPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableServer.POAManagerPackage 中的方法
static void AdapterInactiveHelper.write(OutputStream ostream, AdapterInactive value)

org.omg.PortableServer.POAPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableServer.POAPackage 中的方法
static void | AdapterAlreadyExistsHelper.write(OutputStream ostream, AdapterAlreadyExists value)
static void | AdapterNonExistentHelper.write(OutputStream ostream, AdapterNonExistent value)
static void | InvalidPolicyHelper.write(OutputStream ostream, InvalidPolicy value)
static void | NoServantHelper.write(OutputStream ostream, NoServant value)
static void | ObjectAlreadyActiveHelper.write(OutputStream ostream, ObjectAlreadyActive value)
static void | ObjectNotActiveHelper.write(OutputStream ostream, ObjectNotActive value)
static void | ServantAlreadyActiveHelper.write(OutputStream ostream, ServantAlreadyActive value)
static void | ServantNotActiveHelper.write(OutputStream ostream, ServantNotActive value)
static void | WrongAdapterHelper.write(OutputStream ostream, WrongAdapter value)
static void | WrongPolicyHelper.write(OutputStream ostream, WrongPolicy value)

org.omg.PortableServer.ServantLocatorPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableServer.ServantLocatorPackage 中的方法
 void CookieHolder._write(OutputStream os)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.portable.RemarshalException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.RemarshalException
的使用

使用 RemarshalException 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 RemarshalException 的使用

抛出 RemarshalException 的 org.omg.CORBA 中的方法
 InputStream LocalObject._invoke(OutputStream output)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

org.omg.CORBA.portable 中 RemarshalException 的使用

抛出 RemarshalException 的 org.omg.CORBA.portable 中的方法
InputStream | ObjectImpl._invoke(OutputStream output) 调用某个操作并返回用来读取响应的 InputStream 对象。
InputStream | Delegate.invoke(Object self, OutputStream output) 由 stub 调用，以调用一个操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.ResponseHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.ResponseHandler
的使用

使用 ResponseHandler 的软件包
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA.portable 中 ResponseHandler 的使用

参数类型为 ResponseHandler 的 org.omg.CORBA.portable 中的方法
 OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
由 ORB 调用来调度对 servant 的请求。

org.omg.CosNaming 中 ResponseHandler 的使用

参数类型为 ResponseHandler 的 org.omg.CosNaming 中的方法
OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

org.omg.PortableServer 中 ResponseHandler 的使用

参数类型为 ResponseHandler 的 org.omg.PortableServer 中的方法
OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.portable.ServantObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.ServantObject
的使用

使用 ServantObject 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 ServantObject 的使用

返回 ServantObject 的 org.omg.CORBA 中的方法
 ServantObject LocalObject._servant_preinvoke(String operation, Class expectedType)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

参数类型为 ServantObject 的 org.omg.CORBA 中的方法
 void LocalObject._servant_postinvoke(ServantObject servant)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

org.omg.CORBA.portable 中 ServantObject 的使用

返回 ServantObject 的 org.omg.CORBA.portable 中的方法
ServantObject | ObjectImpl._servant_preinvoke(String operation, Class expectedType) 返回对本地 servant 的 Java 引用，该引用应该被用来发送对指定方法的请求。
ServantObject | Delegate.servant_preinvoke(Object self, String operation, Class expectedType) 返回对应该用作此请求的 servant 的 Java 引用。

参数类型为 ServantObject 的 org.omg.CORBA.portable 中的方法
 void ObjectImpl._servant_postinvoke(ServantObject servant)
本地 stub 在发起了对本地 servant（通过对 _servant_preinvoke 方法的调用得到）的一次操作后，再调用此方法。
 void Delegate.servant_postinvoke(Object self, ServantObject servant)
servant_postinvoke() 由本地 stub 在已经对本地 servant 调用该操作之后调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.Streamable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.Streamable
的使用

使用 Streamable 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。

org.omg.CORBA 中 Streamable 的使用

实现 Streamable 的 org.omg.CORBA 中的类
class | AnyHolder Any 的 Holder。
class | AnySeqHolder AnySeq 的 Holder。
class | BooleanHolder Boolean 的 Holder。
class | BooleanSeqHolder BooleanSeq 的 Holder。
class | ByteHolder Byte 的 Holder。
class | CharHolder Char 的 Holder。
class | CharSeqHolder CharSeq 的 Holder。
class | CurrentHolder Current 的 Holder。
class | DoubleHolder Double 的 Holder。
class | DoubleSeqHolder DoubleSeq 的 Holder。
class | FixedHolder Fixed 的 Holder。
class | FloatHolder Float 的 Holder。
class | FloatSeqHolder FloatSeq 的 Holder。
class | IntHolder Int 的 Holder。
class | LongHolder Long 值的 Holder。
class | LongLongSeqHolder LongLongSeq 的 Holder。
class | LongSeqHolder LongSeq 的 Holder。
class | ObjectHolder Object 的 Holder。
class | OctetSeqHolder OctetSeq 的 Holder。
class | ParameterModeHolder Parameter 参数模式的枚举。
class | PolicyErrorHolder 抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。
class | PolicyHolder Policy 的 Holder。
class | PolicyListHolder PolicyList 的 Holder。
class | PrincipalHolder 已过时。 Deprecated by CORBA 2.2.
class | ServiceInformationHolder ServiceInformation 的 Holder。
class | ShortHolder Short 的 Holder。
class | ShortSeqHolder ShortSeq 的 Holder。
class | StringHolder String 的 Holder。
class | StringSeqHolder String 数组
class | TypeCodeHolder TypeCode 的 Holder。
class | ULongLongSeqHolder ULongLongSeq 的 Holder。
class | ULongSeqHolder ULongSeq 的 Holder。
class | UnknownUserExceptionHolder UnknownUserException 的 Holder。
class | UShortSeqHolder UShortSeq 的 Holder。
class | ValueBaseHolder ValueBase 的 Holder。
class | WCharSeqHolder WCharSeq 的 Holder。
class | WrongTransactionHolder WrongTransaction 的 Holder。
class | WStringSeqHolder WString 数组

返回 Streamable 的 org.omg.CORBA 中的方法
 Streamable Any.extract_Streamable()
从此 Any 对象的 value 字段提取 Streamable。

参数类型为 Streamable 的 org.omg.CORBA 中的方法
 void Any.insert_Streamable(Streamable s)
将给定 Streamable 对象插入此 Any 对象的 value 字段。

org.omg.CORBA.portable 中 Streamable 的使用

org.omg.CORBA.portable 中 Streamable 的子接口
 interface StreamableValue
为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。

org.omg.CosNaming 中 Streamable 的使用

实现 Streamable 的 org.omg.CosNaming 中的类
class | BindingHolder org/omg/CosNaming/BindingHolder.java。
class | BindingIteratorHolder BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
class | BindingListHolder 绑定列表。
class | BindingTypeHolder 指定给定的绑定是对象（非命名上下文的对象）的还是命名上下文的。
class | NameComponentHolder org/omg/CosNaming/NameComponentHolder.java。
class | NameHolder 名称是名称组件的序列。
class | NamingContextExtHolder NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | NamingContextHolder 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.CosNaming.NamingContextExtPackage 中 Streamable 的使用

实现 Streamable 的 org.omg.CosNaming.NamingContextExtPackage 中的类
 class InvalidAddressHolder
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java。

org.omg.CosNaming.NamingContextPackage 中 Streamable 的使用

实现 Streamable 的 org.omg.CosNaming.NamingContextPackage 中的类
class | AlreadyBoundHolder org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java。
class | CannotProceedHolder org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java。
class | InvalidNameHolder org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java。
class | NotEmptyHolder org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java。
class | NotFoundHolder org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java。
class | NotFoundReasonHolder 指示未能解析的原因。

org.omg.IOP 中 Streamable 的使用

实现 Streamable 的 org.omg.IOP 中的类
class | IORHolder org/omg/IOP/IORHolder.java。
class | MultipleComponentProfileHolder 形成多组件配置文件的一组加标记的组件。
class | ServiceContextHolder org/omg/IOP/ServiceContextHolder.java。
class | ServiceContextListHolder 形成服务上下文列表的一组服务上下文。
class | TaggedComponentHolder org/omg/IOP/TaggedComponentHolder.java。
class | TaggedProfileHolder org/omg/IOP/TaggedProfileHolder.java。

org.omg.PortableInterceptor 中 Streamable 的使用

实现 Streamable 的 org.omg.PortableInterceptor 中的类
class | IORInterceptor_3_0Holder org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java。
class | ObjectReferenceFactoryHolder 对象引用工厂。
class | ObjectReferenceTemplateHolder 对象引用模板。
class | ObjectReferenceTemplateSeqHolder 对象引用模板序列用来报告不发生在适配器管理器的状态更改。

org.omg.PortableServer.ServantLocatorPackage 中 Streamable 的使用

实现 Streamable 的 org.omg.PortableServer.ServantLocatorPackage 中的类
 class CookieHolder
native 类型 PortableServer::ServantLocator::Cookie 被映射到 java.lang.Object。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.StreamableValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.StreamableValue
的使用

没有 org.omg.CORBA.portable.StreamableValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.portable.UnknownException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.UnknownException
的使用

没有 org.omg.CORBA.portable.UnknownException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.ValueBase 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.ValueBase
的使用

使用 ValueBase 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.CORBA 中 ValueBase 的使用

org.omg.CORBA 中 ValueBase 的子接口
interface | DataInputStream 定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。
interface | DataOutputStream 定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。

org.omg.CORBA.portable 中 ValueBase 的使用

org.omg.CORBA.portable 中 ValueBase 的子接口
interface | CustomValue 通过自定义值类型实现的 ValueBase 扩展。
interface | StreamableValue 为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。

org.omg.PortableInterceptor 中 ValueBase 的使用

org.omg.PortableInterceptor 中 ValueBase 的子接口
interface | ObjectReferenceFactory 对象引用工厂。
interface | ObjectReferenceTemplate 对象引用模板。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.ValueFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.ValueFactory
的使用

使用 ValueFactory 的软件包
org.omg.CORBA_2_3 CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。

org.omg.CORBA_2_3 中 ValueFactory 的使用

返回 ValueFactory 的 org.omg.CORBA_2_3 中的方法
ValueFactory | ORB.lookup_value_factory(String id)
ValueFactory | ORB.register_value_factory(String id, ValueFactory factory)

参数类型为 ValueFactory 的 org.omg.CORBA_2_3 中的方法
 ValueFactory ORB.register_value_factory(String id, ValueFactory factory)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.ValueInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.ValueInputStream
的使用

没有 org.omg.CORBA.portable.ValueInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.ValueOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.ValueOutputStream
的使用

没有 org.omg.CORBA.portable.ValueOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.CORBA.TypeCodePackage (Java 2 Platform SE 6)

 org.omg.CORBA.TypeCodePackage
异常
BadKind
Bounds


类 org.omg.CORBA.TypeCodePackage.BadKind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TypeCodePackage.BadKind
的使用

使用 BadKind 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 BadKind 的使用

抛出 BadKind 的 org.omg.CORBA 中的方法
abstract TypeCode | TypeCode.concrete_base_type() 返回一个 TypeCode 对象，它描述此 TypeCode 对象所描述 value 类型的具体基本类型。
abstract TypeCode | TypeCode.content_type() 返回表示此 TypeCode 对象所描述成员 IDL 类型的 TypeCode 对象。
abstract int | TypeCode.default_index() 返回默认成员的索引，如果没有默认成员，则返回 -1。
abstract TypeCode | TypeCode.discriminator_type() 返回描述所有非默认成员标签的 TypeCode 对象。
abstract short | TypeCode.fixed_digits() 返回此 TypeCode 对象所描述的 fixed 类型中数字的数量。
abstract short | TypeCode.fixed_scale() 返回此 TypeCode 对象所描述的 fixed 类型的标度。
abstract String | TypeCode.id() 检索全局标识此 TypeCode 对象类型的 RepositoryId。
abstract int | TypeCode.length() 返回此 TypeCode 对象所描述类型中的成员数。
abstract int | TypeCode.member_count() 检索此 TypeCode 对象所描述类型中的成员数。
abstract Any | TypeCode.member_label(int index) 检索给定索引标识的 union 成员的标签。
abstract String | TypeCode.member_name(int index) 检索给定索引标识的成员的简单名称。
abstract TypeCode | TypeCode.member_type(int index) 检索一个 TypeCode 对象，它描述给定索引所标识成员的类型。
abstract short | TypeCode.member_visibility(int index) 返回一个常量，它指示位于给定索引处的成员的可见性。
abstract String | TypeCode.name() 在 TypeCode 对象的封闭作用域内检索标识此对象的简单名称。
abstract short | TypeCode.type_modifier() 返回一个常量，它指示此 TypeCode 对象所描述的 value 类型的修饰符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA.TypeCodePackage.Bounds 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TypeCodePackage.Bounds
的使用

使用 Bounds 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 Bounds 的使用

抛出 Bounds 的 org.omg.CORBA 中的方法
abstract Any | TypeCode.member_label(int index) 检索给定索引标识的 union 成员的标签。
abstract String | TypeCode.member_name(int index) 检索给定索引标识的成员的简单名称。
abstract TypeCode | TypeCode.member_type(int index) 检索一个 TypeCode 对象，它描述给定索引所标识成员的类型。
abstract short | TypeCode.member_visibility(int index) 返回一个常量，它指示位于给定索引处的成员的可见性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.CORBA_2_3 (Java 2 Platform SE 6)

 org.omg.CORBA_2_3
类
ORB


类 org.omg.CORBA_2_3.ORB 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA_2_3.ORB
的使用

没有 org.omg.CORBA_2_3.ORB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.CORBA_2_3.portable (Java 2 Platform SE 6)

 org.omg.CORBA_2_3.portable
类
Delegate
InputStream
ObjectImpl
OutputStream


类 org.omg.CORBA_2_3.portable.Delegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA_2_3.portable.Delegate
的使用

没有 org.omg.CORBA_2_3.portable.Delegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA_2_3.portable.InputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA_2_3.portable.InputStream
的使用

使用 InputStream 的软件包
org.omg.CORBA.portable 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA.portable 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.CORBA.portable 中的方法
 Serializable ValueFactory.read_value(InputStream is)
ORB 运行时在解组值类型的过程中调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA_2_3.portable.ObjectImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA_2_3.portable.ObjectImpl
的使用

使用 ObjectImpl 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 中 ObjectImpl 的使用

javax.rmi.CORBA 中 ObjectImpl 的子类
 class Stub
必须从其继承所有 RMI-IIOP stub 的基类。

org.omg.stub.java.rmi 中 ObjectImpl 的使用

org.omg.stub.java.rmi 中 ObjectImpl 的子类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CORBA_2_3.portable.OutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA_2_3.portable.OutputStream
的使用

没有 org.omg.CORBA_2_3.portable.OutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.CosNaming (Java 2 Platform SE 6)

 org.omg.CosNaming
接口
BindingIterator
BindingIteratorOperations
NamingContext
NamingContextExt
NamingContextExtOperations
NamingContextOperations
类
_BindingIteratorImplBase
_BindingIteratorStub
_NamingContextExtStub
_NamingContextImplBase
_NamingContextStub
Binding
BindingHelper
BindingHolder
BindingIteratorHelper
BindingIteratorHolder
BindingIteratorPOA
BindingListHelper
BindingListHolder
BindingType
BindingTypeHelper
BindingTypeHolder
IstringHelper
NameComponent
NameComponentHelper
NameComponentHolder
NameHelper
NameHolder
NamingContextExtHelper
NamingContextExtHolder
NamingContextExtPOA
NamingContextHelper
NamingContextHolder
NamingContextPOA


类 org.omg.CosNaming._BindingIteratorImplBase 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming._BindingIteratorImplBase
的使用

没有 org.omg.CosNaming._BindingIteratorImplBase 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming._BindingIteratorStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming._BindingIteratorStub
的使用

没有 org.omg.CosNaming._BindingIteratorStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming._NamingContextExtStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming._NamingContextExtStub
的使用

没有 org.omg.CosNaming._NamingContextExtStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming._NamingContextImplBase 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming._NamingContextImplBase
的使用

没有 org.omg.CosNaming._NamingContextImplBase 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming._NamingContextStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming._NamingContextStub
的使用

没有 org.omg.CosNaming._NamingContextStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.Binding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.Binding
的使用

使用 Binding 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 Binding 的使用

声明为 Binding 的 org.omg.CosNaming 中的字段
Binding | BindingHolder.value
Binding[] | BindingListHolder.value

返回 Binding 的 org.omg.CosNaming 中的方法
static Binding | BindingHelper.extract(Any a)
static Binding[] | BindingListHelper.extract(Any a)
static Binding | BindingHelper.read(InputStream istream)
static Binding[] | BindingListHelper.read(InputStream istream)

参数类型为 Binding 的 org.omg.CosNaming 中的方法
static void | BindingHelper.insert(Any a, Binding that)
static void | BindingListHelper.insert(Any a, Binding[] that)
static void | BindingHelper.write(OutputStream ostream, Binding value)
static void | BindingListHelper.write(OutputStream ostream, Binding[] value)

参数类型为 Binding 的 org.omg.CosNaming 中的构造方法
BindingHolder(Binding initialValue)
BindingListHolder(Binding[] initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingHelper
的使用

没有 org.omg.CosNaming.BindingHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingHolder
的使用

使用 BindingHolder 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingHolder 的使用

参数类型为 BindingHolder 的 org.omg.CosNaming 中的方法
boolean | BindingIteratorOperations.next_one(BindingHolder b) 此操作返回下一个绑定。
boolean | _BindingIteratorStub.next_one(BindingHolder b) 此操作返回下一个绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CosNaming.BindingIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.BindingIterator
的使用

使用 BindingIterator 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingIterator 的使用

实现 BindingIterator 的 org.omg.CosNaming 中的类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。

声明为 BindingIterator 的 org.omg.CosNaming 中的字段
 BindingIterator BindingIteratorHolder.value

返回 BindingIterator 的 org.omg.CosNaming 中的方法
BindingIterator | BindingIteratorPOA._this()
BindingIterator | BindingIteratorPOA._this(ORB orb)
static BindingIterator | BindingIteratorHelper.extract(Any a)
static BindingIterator | BindingIteratorHelper.narrow(Object obj)
static BindingIterator | BindingIteratorHelper.read(InputStream istream)
static BindingIterator | BindingIteratorHelper.unchecked_narrow(Object obj)

参数类型为 BindingIterator 的 org.omg.CosNaming 中的方法
static void | BindingIteratorHelper.insert(Any a, BindingIterator that)
static void | BindingIteratorHelper.write(OutputStream ostream, BindingIterator value)

参数类型为 BindingIterator 的 org.omg.CosNaming 中的构造方法
BindingIteratorHolder(BindingIterator initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingIteratorHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingIteratorHelper
的使用

没有 org.omg.CosNaming.BindingIteratorHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingIteratorHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingIteratorHolder
的使用

使用 BindingIteratorHolder 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingIteratorHolder 的使用

参数类型为 BindingIteratorHolder 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) list 操作允许客户端迭代命名上下文中的一组绑定。
void | _NamingContextExtStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) 列表操作允许客户端迭代命名上下文中的一组绑定。
void | _NamingContextStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) 列表操作允许客户端迭代命名上下文中的一组绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CosNaming.BindingIteratorOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.BindingIteratorOperations
的使用

使用 BindingIteratorOperations 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingIteratorOperations 的使用

org.omg.CosNaming 中 BindingIteratorOperations 的子接口
 interface BindingIterator
BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。

实现 BindingIteratorOperations 的 org.omg.CosNaming 中的类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
class | BindingIteratorPOA BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingIteratorPOA 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingIteratorPOA
的使用

没有 org.omg.CosNaming.BindingIteratorPOA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingListHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingListHelper
的使用

没有 org.omg.CosNaming.BindingListHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingListHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingListHolder
的使用

使用 BindingListHolder 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingListHolder 的使用

参数类型为 BindingListHolder 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) list 操作允许客户端迭代命名上下文中的一组绑定。
void | _NamingContextExtStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) 列表操作允许客户端迭代命名上下文中的一组绑定。
void | _NamingContextStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) 列表操作允许客户端迭代命名上下文中的一组绑定。
boolean | BindingIteratorOperations.next_n(int how_many, BindingListHolder bl) 此操作返回最多可以达到的请求绑定数。
boolean | _BindingIteratorStub.next_n(int how_many, BindingListHolder bl) 此操作返回最多可以达到的请求绑定数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingType
的使用

使用 BindingType 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingType 的使用

声明为 BindingType 的 org.omg.CosNaming 中的字段
BindingType | Binding.binding_type
static BindingType | BindingType.ncontext
static BindingType | BindingType.nobject
BindingType | BindingTypeHolder.value

返回 BindingType 的 org.omg.CosNaming 中的方法
static BindingType | BindingTypeHelper.extract(Any a)
static BindingType | BindingType.from_int(int value)
static BindingType | BindingTypeHelper.read(InputStream istream)

参数类型为 BindingType 的 org.omg.CosNaming 中的方法
static void | BindingTypeHelper.insert(Any a, BindingType that)
static void | BindingTypeHelper.write(OutputStream ostream, BindingType value)

参数类型为 BindingType 的 org.omg.CosNaming 中的构造方法
Binding(NameComponent[] _binding_name, BindingType _binding_type)
BindingTypeHolder(BindingType initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingTypeHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingTypeHelper
的使用

没有 org.omg.CosNaming.BindingTypeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingTypeHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingTypeHolder
的使用

没有 org.omg.CosNaming.BindingTypeHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.IstringHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.IstringHelper
的使用

没有 org.omg.CosNaming.IstringHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NameComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NameComponent
的使用

使用 NameComponent 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 NameComponent 的使用

声明为 NameComponent 的 org.omg.CosNaming 中的字段
NameComponent[] | Binding.binding_name
NameComponent | NameComponentHolder.value
NameComponent[] | NameHolder.value

返回 NameComponent 的 org.omg.CosNaming 中的方法
static NameComponent | NameComponentHelper.extract(Any a)
static NameComponent[] | NameHelper.extract(Any a)
static NameComponent | NameComponentHelper.read(InputStream istream)
static NameComponent[] | NameHelper.read(InputStream istream)
NameComponent[] | NamingContextExtOperations.to_name(String sn) 此操作将“字符串化的名称”转换为等效的“名称组件”数组。
NameComponent[] | _NamingContextExtStub.to_name(String sn) 此操作将“字符串化的名称”转换为等效的“名称组件”数组。

参数类型为 NameComponent 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
static void | NameComponentHelper.insert(Any a, NameComponent that)
static void | NameHelper.insert(Any a, NameComponent[] that)
void | NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | NamingContextOperations.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | NamingContextOperations.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextExtStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
String | NamingContextExtOperations.to_string(NameComponent[] n) 此操作根据 Name 组件数组创建字符串化的名称。
String | _NamingContextExtStub.to_string(NameComponent[] n) 此操作从 Name 组件数组创建字符串化的名称。
void | NamingContextOperations.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextExtStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
static void | NameComponentHelper.write(OutputStream ostream, NameComponent value)
static void | NameHelper.write(OutputStream ostream, NameComponent[] value)

参数类型为 NameComponent 的 org.omg.CosNaming 中的构造方法
Binding(NameComponent[] _binding_name, BindingType _binding_type)
NameComponentHolder(NameComponent initialValue)
NameHolder(NameComponent[] initialValue)

org.omg.CosNaming.NamingContextPackage 中 NameComponent 的使用

声明为 NameComponent 的 org.omg.CosNaming.NamingContextPackage 中的字段
NameComponent[] | CannotProceed.rest_of_name
NameComponent[] | NotFound.rest_of_name

参数类型为 NameComponent 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)
NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NameComponentHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NameComponentHelper
的使用

没有 org.omg.CosNaming.NameComponentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NameComponentHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NameComponentHolder
的使用

没有 org.omg.CosNaming.NameComponentHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NameHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NameHelper
的使用

没有 org.omg.CosNaming.NameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NameHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NameHolder
的使用

没有 org.omg.CosNaming.NameHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CosNaming.NamingContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.NamingContext
的使用

使用 NamingContext 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 NamingContext 的使用

org.omg.CosNaming 中 NamingContext 的子接口
 interface NamingContextExt
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 NamingContext 的 org.omg.CosNaming 中的类
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

声明为 NamingContext 的 org.omg.CosNaming 中的字段
 NamingContext NamingContextHolder.value

返回 NamingContext 的 org.omg.CosNaming 中的方法
NamingContext | NamingContextPOA._this()
NamingContext | NamingContextPOA._this(ORB orb)
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
static NamingContext | NamingContextHelper.extract(Any a)
static NamingContext | NamingContextHelper.narrow(Object obj)
NamingContext | NamingContextOperations.new_context() 此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
NamingContext | _NamingContextExtStub.new_context() 此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
NamingContext | _NamingContextStub.new_context() 此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
static NamingContext | NamingContextHelper.read(InputStream istream)
static NamingContext | NamingContextHelper.unchecked_narrow(Object obj)

参数类型为 NamingContext 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
static void | NamingContextHelper.insert(Any a, NamingContext that)
void | NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
static void | NamingContextHelper.write(OutputStream ostream, NamingContext value)

参数类型为 NamingContext 的 org.omg.CosNaming 中的构造方法
NamingContextHolder(NamingContext initialValue)

org.omg.CosNaming.NamingContextPackage 中 NamingContext 的使用

声明为 NamingContext 的 org.omg.CosNaming.NamingContextPackage 中的字段
 NamingContext CannotProceed.cxt

参数类型为 NamingContext 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CosNaming.NamingContextExt 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.NamingContextExt
的使用

使用 NamingContextExt 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 NamingContextExt 的使用

实现 NamingContextExt 的 org.omg.CosNaming 中的类
 class _NamingContextExtStub
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

声明为 NamingContextExt 的 org.omg.CosNaming 中的字段
 NamingContextExt NamingContextExtHolder.value

返回 NamingContextExt 的 org.omg.CosNaming 中的方法
NamingContextExt | NamingContextExtPOA._this()
NamingContextExt | NamingContextExtPOA._this(ORB orb)
static NamingContextExt | NamingContextExtHelper.extract(Any a)
static NamingContextExt | NamingContextExtHelper.narrow(Object obj)
static NamingContextExt | NamingContextExtHelper.read(InputStream istream)
static NamingContextExt | NamingContextExtHelper.unchecked_narrow(Object obj)

参数类型为 NamingContextExt 的 org.omg.CosNaming 中的方法
static void | NamingContextExtHelper.insert(Any a, NamingContextExt that)
static void | NamingContextExtHelper.write(OutputStream ostream, NamingContextExt value)

参数类型为 NamingContextExt 的 org.omg.CosNaming 中的构造方法
NamingContextExtHolder(NamingContextExt initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtHelper
的使用

没有 org.omg.CosNaming.NamingContextExtHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtHolder
的使用

没有 org.omg.CosNaming.NamingContextExtHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CosNaming.NamingContextExtOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.NamingContextExtOperations
的使用

使用 NamingContextExtOperations 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 NamingContextExtOperations 的使用

org.omg.CosNaming 中 NamingContextExtOperations 的子接口
 interface NamingContextExt
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 NamingContextExtOperations 的 org.omg.CosNaming 中的类
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | NamingContextExtPOA NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPOA 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPOA
的使用

没有 org.omg.CosNaming.NamingContextExtPOA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextHelper
的使用

没有 org.omg.CosNaming.NamingContextHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextHolder
的使用

没有 org.omg.CosNaming.NamingContextHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.CosNaming.NamingContextOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.NamingContextOperations
的使用

使用 NamingContextOperations 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 NamingContextOperations 的使用

org.omg.CosNaming 中 NamingContextOperations 的子接口
interface | NamingContext 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
interface | NamingContextExt NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
interface | NamingContextExtOperations NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 NamingContextOperations 的 org.omg.CosNaming 中的类
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
class | NamingContextExtPOA NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | NamingContextPOA 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPOA 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPOA
的使用

没有 org.omg.CosNaming.NamingContextPOA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.CosNaming.NamingContextExtPackage (Java 2 Platform SE 6)

 org.omg.CosNaming.NamingContextExtPackage
类
AddressHelper
InvalidAddressHelper
InvalidAddressHolder
StringNameHelper
URLStringHelper
异常
InvalidAddress


类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper
的使用

没有 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddress 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
的使用

使用 InvalidAddress 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

org.omg.CosNaming 中 InvalidAddress 的使用

抛出 InvalidAddress 的 org.omg.CosNaming 中的方法
String | NamingContextExtOperations.to_url(String addr, String sn) 此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
String | _NamingContextExtStub.to_url(String addr, String sn) 此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

org.omg.CosNaming.NamingContextExtPackage 中 InvalidAddress 的使用

声明为 InvalidAddress 的 org.omg.CosNaming.NamingContextExtPackage 中的字段
 InvalidAddress InvalidAddressHolder.value

返回 InvalidAddress 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
static InvalidAddress | InvalidAddressHelper.extract(Any a)
static InvalidAddress | InvalidAddressHelper.read(InputStream istream)

参数类型为 InvalidAddress 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
static void | InvalidAddressHelper.insert(Any a, InvalidAddress that)
static void | InvalidAddressHelper.write(OutputStream ostream, InvalidAddress value)

参数类型为 InvalidAddress 的 org.omg.CosNaming.NamingContextExtPackage 中的构造方法
InvalidAddressHolder(InvalidAddress initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
的使用

没有 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
的使用

没有 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
的使用

没有 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
的使用

没有 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.CosNaming.NamingContextPackage (Java 2 Platform SE 6)

 org.omg.CosNaming.NamingContextPackage
类
AlreadyBoundHelper
AlreadyBoundHolder
CannotProceedHelper
CannotProceedHolder
InvalidNameHelper
InvalidNameHolder
NotEmptyHelper
NotEmptyHolder
NotFoundHelper
NotFoundHolder
NotFoundReason
NotFoundReasonHelper
NotFoundReasonHolder
异常
AlreadyBound
CannotProceed
InvalidName
NotEmpty
NotFound


类 org.omg.CosNaming.NamingContextPackage.AlreadyBound 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.AlreadyBound
的使用

使用 AlreadyBound 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 AlreadyBound 的使用

抛出 AlreadyBound 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。

org.omg.CosNaming.NamingContextPackage 中 AlreadyBound 的使用

声明为 AlreadyBound 的 org.omg.CosNaming.NamingContextPackage 中的字段
 AlreadyBound AlreadyBoundHolder.value

返回 AlreadyBound 的 org.omg.CosNaming.NamingContextPackage 中的方法
static AlreadyBound | AlreadyBoundHelper.extract(Any a)
static AlreadyBound | AlreadyBoundHelper.read(InputStream istream)

参数类型为 AlreadyBound 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | AlreadyBoundHelper.insert(Any a, AlreadyBound that)
static void | AlreadyBoundHelper.write(OutputStream ostream, AlreadyBound value)

参数类型为 AlreadyBound 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
AlreadyBoundHolder(AlreadyBound initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.CannotProceed 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.CannotProceed
的使用

使用 CannotProceed 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 CannotProceed 的使用

抛出 CannotProceed 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | NamingContextOperations.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | NamingContextExtOperations.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | _NamingContextExtStub.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | NamingContextOperations.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextExtStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
void | NamingContextOperations.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextExtStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。

org.omg.CosNaming.NamingContextPackage 中 CannotProceed 的使用

声明为 CannotProceed 的 org.omg.CosNaming.NamingContextPackage 中的字段
 CannotProceed CannotProceedHolder.value

返回 CannotProceed 的 org.omg.CosNaming.NamingContextPackage 中的方法
static CannotProceed | CannotProceedHelper.extract(Any a)
static CannotProceed | CannotProceedHelper.read(InputStream istream)

参数类型为 CannotProceed 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | CannotProceedHelper.insert(Any a, CannotProceed that)
static void | CannotProceedHelper.write(OutputStream ostream, CannotProceed value)

参数类型为 CannotProceed 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
CannotProceedHolder(CannotProceed initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.InvalidName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.InvalidName
的使用

使用 InvalidName 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 InvalidName 的使用

抛出 InvalidName 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | NamingContextOperations.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | NamingContextExtOperations.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | _NamingContextExtStub.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | NamingContextOperations.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextExtStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
NameComponent[] | NamingContextExtOperations.to_name(String sn) 此操作将“字符串化的名称”转换为等效的“名称组件”数组。
NameComponent[] | _NamingContextExtStub.to_name(String sn) 此操作将“字符串化的名称”转换为等效的“名称组件”数组。
String | NamingContextExtOperations.to_string(NameComponent[] n) 此操作根据 Name 组件数组创建字符串化的名称。
String | _NamingContextExtStub.to_string(NameComponent[] n) 此操作从 Name 组件数组创建字符串化的名称。
String | NamingContextExtOperations.to_url(String addr, String sn) 此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
String | _NamingContextExtStub.to_url(String addr, String sn) 此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
void | NamingContextOperations.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextExtStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。

org.omg.CosNaming.NamingContextPackage 中 InvalidName 的使用

声明为 InvalidName 的 org.omg.CosNaming.NamingContextPackage 中的字段
 InvalidName InvalidNameHolder.value

返回 InvalidName 的 org.omg.CosNaming.NamingContextPackage 中的方法
static InvalidName | InvalidNameHelper.extract(Any a)
static InvalidName | InvalidNameHelper.read(InputStream istream)

参数类型为 InvalidName 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | InvalidNameHelper.insert(Any a, InvalidName that)
static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)

参数类型为 InvalidName 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
InvalidNameHolder(InvalidName initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotEmpty 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotEmpty
的使用

使用 NotEmpty 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 NotEmpty 的使用

抛出 NotEmpty 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.destroy() destroy 操作删除命名上下文。
void | _NamingContextExtStub.destroy() destroy 操作删除命名上下文。
void | _NamingContextStub.destroy() destroy 操作删除命名上下文。

org.omg.CosNaming.NamingContextPackage 中 NotEmpty 的使用

声明为 NotEmpty 的 org.omg.CosNaming.NamingContextPackage 中的字段
 NotEmpty NotEmptyHolder.value

返回 NotEmpty 的 org.omg.CosNaming.NamingContextPackage 中的方法
static NotEmpty | NotEmptyHelper.extract(Any a)
static NotEmpty | NotEmptyHelper.read(InputStream istream)

参数类型为 NotEmpty 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | NotEmptyHelper.insert(Any a, NotEmpty that)
static void | NotEmptyHelper.write(OutputStream ostream, NotEmpty value)

参数类型为 NotEmpty 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
NotEmptyHolder(NotEmpty initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFound 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFound
的使用

使用 NotFound 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 NotFound 的使用

抛出 NotFound 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | NamingContextOperations.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | NamingContextExtOperations.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | _NamingContextExtStub.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | NamingContextOperations.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextExtStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
void | NamingContextOperations.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextExtStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。

org.omg.CosNaming.NamingContextPackage 中 NotFound 的使用

声明为 NotFound 的 org.omg.CosNaming.NamingContextPackage 中的字段
 NotFound NotFoundHolder.value

返回 NotFound 的 org.omg.CosNaming.NamingContextPackage 中的方法
static NotFound | NotFoundHelper.extract(Any a)
static NotFound | NotFoundHelper.read(InputStream istream)

参数类型为 NotFound 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | NotFoundHelper.insert(Any a, NotFound that)
static void | NotFoundHelper.write(OutputStream ostream, NotFound value)

参数类型为 NotFound 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
NotFoundHolder(NotFound initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFoundReason
的使用

使用 NotFoundReason 的软件包
org.omg.CosNaming.NamingContextPackage 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming.NamingContextPackage 中 NotFoundReason 的使用

声明为 NotFoundReason 的 org.omg.CosNaming.NamingContextPackage 中的字段
static NotFoundReason | NotFoundReason.missing_node
static NotFoundReason | NotFoundReason.not_context
static NotFoundReason | NotFoundReason.not_object
NotFoundReason | NotFoundReasonHolder.value
NotFoundReason | NotFound.why

返回 NotFoundReason 的 org.omg.CosNaming.NamingContextPackage 中的方法
static NotFoundReason | NotFoundReasonHelper.extract(Any a)
static NotFoundReason | NotFoundReason.from_int(int value)
static NotFoundReason | NotFoundReasonHelper.read(InputStream istream)

参数类型为 NotFoundReason 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | NotFoundReasonHelper.insert(Any a, NotFoundReason that)
static void | NotFoundReasonHelper.write(OutputStream ostream, NotFoundReason value)

参数类型为 NotFoundReason 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)
NotFoundReasonHolder(NotFoundReason initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.Dynamic (Java 2 Platform SE 6)

 org.omg.Dynamic
类
Parameter


类 org.omg.Dynamic.Parameter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.Dynamic.Parameter
的使用

使用 Parameter 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 Parameter 的使用

返回 Parameter 的 org.omg.PortableInterceptor 中的方法
 Parameter[] RequestInfoOperations.arguments()
返回一个 Parameter 对象数组，包含将调用的操作上的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.DynamicAny (Java 2 Platform SE 6)

 org.omg.DynamicAny
接口
DynAny
DynAnyFactory
DynAnyFactoryOperations
DynAnyOperations
DynArray
DynArrayOperations
DynEnum
DynEnumOperations
DynFixed
DynFixedOperations
DynSequence
DynSequenceOperations
DynStruct
DynStructOperations
DynUnion
DynUnionOperations
DynValue
DynValueBox
DynValueBoxOperations
DynValueCommon
DynValueCommonOperations
DynValueOperations
类
_DynAnyFactoryStub
_DynAnyStub
_DynArrayStub
_DynEnumStub
_DynFixedStub
_DynSequenceStub
_DynStructStub
_DynUnionStub
_DynValueStub
AnySeqHelper
DynAnyFactoryHelper
DynAnyHelper
DynAnySeqHelper
DynArrayHelper
DynEnumHelper
DynFixedHelper
DynSequenceHelper
DynStructHelper
DynUnionHelper
DynValueHelper
FieldNameHelper
NameDynAnyPair
NameDynAnyPairHelper
NameDynAnyPairSeqHelper
NameValuePair
NameValuePairHelper
NameValuePairSeqHelper


类 org.omg.DynamicAny._DynAnyFactoryStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynAnyFactoryStub
的使用

没有 org.omg.DynamicAny._DynAnyFactoryStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynAnyStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynAnyStub
的使用

没有 org.omg.DynamicAny._DynAnyStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynArrayStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynArrayStub
的使用

没有 org.omg.DynamicAny._DynArrayStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynEnumStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynEnumStub
的使用

没有 org.omg.DynamicAny._DynEnumStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynFixedStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynFixedStub
的使用

没有 org.omg.DynamicAny._DynFixedStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynSequenceStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynSequenceStub
的使用

没有 org.omg.DynamicAny._DynSequenceStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynStructStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynStructStub
的使用

没有 org.omg.DynamicAny._DynStructStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynUnionStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynUnionStub
的使用

没有 org.omg.DynamicAny._DynUnionStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynValueStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynValueStub
的使用

没有 org.omg.DynamicAny._DynValueStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.AnySeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.AnySeqHelper
的使用

没有 org.omg.DynamicAny.AnySeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynAny 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynAny
的使用

使用 DynAny 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynAny 的使用

org.omg.DynamicAny 中 DynAny 的子接口
interface | DynArray DynArray 对象支持对 IDL 数组的操作。
interface | DynEnum DynEnum 对象支持对 IDL 枚举值的操作。
interface | DynFixed DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
interface | DynSequence DynSequence 对象支持对 IDL 序列的操作。
interface | DynStruct DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
interface | DynUnion DynUnion 对象支持对 IDL 联合 (union) 的操作。
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。

实现 DynAny 的 org.omg.DynamicAny 中的类
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。

声明为 DynAny 的 org.omg.DynamicAny 中的字段
 DynAny NameDynAnyPair.value
与名称关联的 DynAny 值。

返回 DynAny 的 org.omg.DynamicAny 中的方法
DynAny | DynAnyOperations.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynAnyStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynArrayStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynEnumStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynFixedStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynSequenceStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynStructStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynUnionStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynValueStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | DynAnyFactoryOperations.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
DynAny | _DynAnyFactoryStub.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
DynAny | DynAnyOperations.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynAnyStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynArrayStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynEnumStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynFixedStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynSequenceStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynStructStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynUnionStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynValueStub.current_component() 返回当前位置上的组件的 DynAny。
static DynAny | DynAnyHelper.extract(Any a)
static DynAny[] | DynAnySeqHelper.extract(Any a)
DynAny | DynValueBoxOperations.get_boxed_value_as_dyn_any() 以 DynAny 的形式返回已装箱值。
DynAny | DynUnionOperations.get_discriminator() 返回当前鉴别符值。
DynAny | _DynUnionStub.get_discriminator() 返回当前鉴别符值。
DynAny | DynAnyOperations.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynAnyStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynArrayStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynEnumStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynFixedStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynSequenceStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynStructStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynUnionStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynValueStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny[] | DynArrayOperations.get_elements_as_dyn_any() 以 DynAny 的形式返回 DynArray 的元素。
DynAny[] | DynSequenceOperations.get_elements_as_dyn_any() 返回表示序列元素的 DynAny。
DynAny[] | _DynArrayStub.get_elements_as_dyn_any() 以 DynAny 的形式返回 DynArray 的元素。
DynAny[] | _DynSequenceStub.get_elements_as_dyn_any() 返回表示序列的元素的 DynAny。
DynAny | DynUnionOperations.member() 返回当前活动成员。
DynAny | _DynUnionStub.member() 返回当前活动成员。
static DynAny | DynAnyHelper.narrow(Object obj)
static DynAny | DynAnyHelper.read(InputStream istream)
static DynAny[] | DynAnySeqHelper.read(InputStream istream)
static DynAny | DynAnyHelper.unchecked_narrow(Object obj)

参数类型为 DynAny 的 org.omg.DynamicAny 中的方法
void | DynAnyOperations.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
void | _DynAnyStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynArrayStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynEnumStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynFixedStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynSequenceStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynStructStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynUnionStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
void | _DynValueStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
boolean | DynAnyOperations.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynAnyStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynArrayStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynEnumStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynFixedStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynSequenceStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynStructStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynUnionStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynValueStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
void | DynAnyOperations.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynFixedStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynStructStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
static void | DynAnyHelper.insert(Any a, DynAny that)
static void | DynAnySeqHelper.insert(Any a, DynAny[] that)
void | DynValueBoxOperations.set_boxed_value_as_dyn_any(DynAny boxed) 使用参数中包含的值取代已装箱值。
void | DynUnionOperations.set_discriminator(DynAny d) 将 DynUnion 的鉴别符值设置为指定值。
void | _DynUnionStub.set_discriminator(DynAny d) 将 DynUnion 的鉴别符值设置为指定值。
void | DynArrayOperations.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | _DynArrayStub.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
static void | DynAnyHelper.write(OutputStream ostream, DynAny value)
static void | DynAnySeqHelper.write(OutputStream ostream, DynAny[] value)

参数类型为 DynAny 的 org.omg.DynamicAny 中的构造方法
NameDynAnyPair(String _id, DynAny _value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynAnyFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynAnyFactory
的使用

使用 DynAnyFactory 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynAnyFactory 的使用

实现 DynAnyFactory 的 org.omg.DynamicAny 中的类
 class _DynAnyFactoryStub
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。

返回 DynAnyFactory 的 org.omg.DynamicAny 中的方法
static DynAnyFactory | DynAnyFactoryHelper.extract(Any a)
static DynAnyFactory | DynAnyFactoryHelper.narrow(Object obj)
static DynAnyFactory | DynAnyFactoryHelper.read(InputStream istream)
static DynAnyFactory | DynAnyFactoryHelper.unchecked_narrow(Object obj)

参数类型为 DynAnyFactory 的 org.omg.DynamicAny 中的方法
static void | DynAnyFactoryHelper.insert(Any a, DynAnyFactory that)
static void | DynAnyFactoryHelper.write(OutputStream ostream, DynAnyFactory value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyFactoryHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyFactoryHelper
的使用

没有 org.omg.DynamicAny.DynAnyFactoryHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynAnyFactoryOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynAnyFactoryOperations
的使用

使用 DynAnyFactoryOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynAnyFactoryOperations 的使用

org.omg.DynamicAny 中 DynAnyFactoryOperations 的子接口
 interface DynAnyFactory
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。

实现 DynAnyFactoryOperations 的 org.omg.DynamicAny 中的类
 class _DynAnyFactoryStub
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyHelper
的使用

没有 org.omg.DynamicAny.DynAnyHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynAnyOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynAnyOperations
的使用

使用 DynAnyOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynAnyOperations 的使用

org.omg.DynamicAny 中 DynAnyOperations 的子接口
interface | DynAny 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
interface | DynArray DynArray 对象支持对 IDL 数组的操作。
interface | DynArrayOperations DynArray 对象支持对 IDL 数组的操作。
interface | DynEnum DynEnum 对象支持对 IDL 枚举值的操作。
interface | DynEnumOperations DynEnum 对象支持对 IDL enumerated value 的操作。
interface | DynFixed DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
interface | DynFixedOperations DynFixed 对象支持对 IDL 定值的操作。
interface | DynSequence DynSequence 对象支持对 IDL 序列的操作。
interface | DynSequenceOperations DynSequence 对象支持对 IDL 序列的操作。
interface | DynStruct DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
interface | DynStructOperations DynStruct 对象支持对 IDL 结构数据 (struct) 和异常 (exception) 值的操作。
interface | DynUnion DynUnion 对象支持对 IDL 联合 (union) 的操作。
interface | DynUnionOperations DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueBoxOperations DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
interface | DynValueCommonOperations DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
interface | DynValueOperations DynValue 对象支持对 IDL 非装箱 (boxed) 值类型的支持。

实现 DynAnyOperations 的 org.omg.DynamicAny 中的类
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnySeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnySeqHelper
的使用

没有 org.omg.DynamicAny.DynAnySeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynArray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynArray
的使用

使用 DynArray 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynArray 的使用

实现 DynArray 的 org.omg.DynamicAny 中的类
 class _DynArrayStub
DynArray 对象支持对 IDL 数组 (array) 的操作。

返回 DynArray 的 org.omg.DynamicAny 中的方法
static DynArray | DynArrayHelper.extract(Any a)
static DynArray | DynArrayHelper.narrow(Object obj)
static DynArray | DynArrayHelper.read(InputStream istream)
static DynArray | DynArrayHelper.unchecked_narrow(Object obj)

参数类型为 DynArray 的 org.omg.DynamicAny 中的方法
static void | DynArrayHelper.insert(Any a, DynArray that)
static void | DynArrayHelper.write(OutputStream ostream, DynArray value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynArrayHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynArrayHelper
的使用

没有 org.omg.DynamicAny.DynArrayHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynArrayOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynArrayOperations
的使用

使用 DynArrayOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynArrayOperations 的使用

org.omg.DynamicAny 中 DynArrayOperations 的子接口
 interface DynArray
DynArray 对象支持对 IDL 数组的操作。

实现 DynArrayOperations 的 org.omg.DynamicAny 中的类
 class _DynArrayStub
DynArray 对象支持对 IDL 数组 (array) 的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynEnum 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynEnum
的使用

使用 DynEnum 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynEnum 的使用

实现 DynEnum 的 org.omg.DynamicAny 中的类
 class _DynEnumStub
DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。

返回 DynEnum 的 org.omg.DynamicAny 中的方法
static DynEnum | DynEnumHelper.extract(Any a)
static DynEnum | DynEnumHelper.narrow(Object obj)
static DynEnum | DynEnumHelper.read(InputStream istream)
static DynEnum | DynEnumHelper.unchecked_narrow(Object obj)

参数类型为 DynEnum 的 org.omg.DynamicAny 中的方法
static void | DynEnumHelper.insert(Any a, DynEnum that)
static void | DynEnumHelper.write(OutputStream ostream, DynEnum value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynEnumHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynEnumHelper
的使用

没有 org.omg.DynamicAny.DynEnumHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynEnumOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynEnumOperations
的使用

使用 DynEnumOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynEnumOperations 的使用

org.omg.DynamicAny 中 DynEnumOperations 的子接口
 interface DynEnum
DynEnum 对象支持对 IDL 枚举值的操作。

实现 DynEnumOperations 的 org.omg.DynamicAny 中的类
 class _DynEnumStub
DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynFixed 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynFixed
的使用

使用 DynFixed 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynFixed 的使用

实现 DynFixed 的 org.omg.DynamicAny 中的类
 class _DynFixedStub
DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。

返回 DynFixed 的 org.omg.DynamicAny 中的方法
static DynFixed | DynFixedHelper.extract(Any a)
static DynFixed | DynFixedHelper.narrow(Object obj)
static DynFixed | DynFixedHelper.read(InputStream istream)
static DynFixed | DynFixedHelper.unchecked_narrow(Object obj)

参数类型为 DynFixed 的 org.omg.DynamicAny 中的方法
static void | DynFixedHelper.insert(Any a, DynFixed that)
static void | DynFixedHelper.write(OutputStream ostream, DynFixed value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynFixedHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynFixedHelper
的使用

没有 org.omg.DynamicAny.DynFixedHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynFixedOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynFixedOperations
的使用

使用 DynFixedOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynFixedOperations 的使用

org.omg.DynamicAny 中 DynFixedOperations 的子接口
 interface DynFixed
DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。

实现 DynFixedOperations 的 org.omg.DynamicAny 中的类
 class _DynFixedStub
DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynSequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynSequence
的使用

使用 DynSequence 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynSequence 的使用

实现 DynSequence 的 org.omg.DynamicAny 中的类
 class _DynSequenceStub
DynSequence 对象支持对 IDL 序列 (sequence) 的操作。

返回 DynSequence 的 org.omg.DynamicAny 中的方法
static DynSequence | DynSequenceHelper.extract(Any a)
static DynSequence | DynSequenceHelper.narrow(Object obj)
static DynSequence | DynSequenceHelper.read(InputStream istream)
static DynSequence | DynSequenceHelper.unchecked_narrow(Object obj)

参数类型为 DynSequence 的 org.omg.DynamicAny 中的方法
static void | DynSequenceHelper.insert(Any a, DynSequence that)
static void | DynSequenceHelper.write(OutputStream ostream, DynSequence value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynSequenceHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynSequenceHelper
的使用

没有 org.omg.DynamicAny.DynSequenceHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynSequenceOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynSequenceOperations
的使用

使用 DynSequenceOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynSequenceOperations 的使用

org.omg.DynamicAny 中 DynSequenceOperations 的子接口
 interface DynSequence
DynSequence 对象支持对 IDL 序列的操作。

实现 DynSequenceOperations 的 org.omg.DynamicAny 中的类
 class _DynSequenceStub
DynSequence 对象支持对 IDL 序列 (sequence) 的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynStruct 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynStruct
的使用

使用 DynStruct 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynStruct 的使用

实现 DynStruct 的 org.omg.DynamicAny 中的类
 class _DynStructStub
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。

返回 DynStruct 的 org.omg.DynamicAny 中的方法
static DynStruct | DynStructHelper.extract(Any a)
static DynStruct | DynStructHelper.narrow(Object obj)
static DynStruct | DynStructHelper.read(InputStream istream)
static DynStruct | DynStructHelper.unchecked_narrow(Object obj)

参数类型为 DynStruct 的 org.omg.DynamicAny 中的方法
static void | DynStructHelper.insert(Any a, DynStruct that)
static void | DynStructHelper.write(OutputStream ostream, DynStruct value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynStructHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynStructHelper
的使用

没有 org.omg.DynamicAny.DynStructHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynStructOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynStructOperations
的使用

使用 DynStructOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynStructOperations 的使用

org.omg.DynamicAny 中 DynStructOperations 的子接口
 interface DynStruct
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。

实现 DynStructOperations 的 org.omg.DynamicAny 中的类
 class _DynStructStub
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynUnion 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynUnion
的使用

使用 DynUnion 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynUnion 的使用

实现 DynUnion 的 org.omg.DynamicAny 中的类
 class _DynUnionStub
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。

返回 DynUnion 的 org.omg.DynamicAny 中的方法
static DynUnion | DynUnionHelper.extract(Any a)
static DynUnion | DynUnionHelper.narrow(Object obj)
static DynUnion | DynUnionHelper.read(InputStream istream)
static DynUnion | DynUnionHelper.unchecked_narrow(Object obj)

参数类型为 DynUnion 的 org.omg.DynamicAny 中的方法
static void | DynUnionHelper.insert(Any a, DynUnion that)
static void | DynUnionHelper.write(OutputStream ostream, DynUnion value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynUnionHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynUnionHelper
的使用

没有 org.omg.DynamicAny.DynUnionHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynUnionOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynUnionOperations
的使用

使用 DynUnionOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynUnionOperations 的使用

org.omg.DynamicAny 中 DynUnionOperations 的子接口
 interface DynUnion
DynUnion 对象支持对 IDL 联合 (union) 的操作。

实现 DynUnionOperations 的 org.omg.DynamicAny 中的类
 class _DynUnionStub
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValue
的使用

使用 DynValue 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynValue 的使用

实现 DynValue 的 org.omg.DynamicAny 中的类
 class _DynValueStub
DynValue 对象支持 IDL non-boxed value 类型的操作。

返回 DynValue 的 org.omg.DynamicAny 中的方法
static DynValue | DynValueHelper.extract(Any a)
static DynValue | DynValueHelper.narrow(Object obj)
static DynValue | DynValueHelper.read(InputStream istream)
static DynValue | DynValueHelper.unchecked_narrow(Object obj)

参数类型为 DynValue 的 org.omg.DynamicAny 中的方法
static void | DynValueHelper.insert(Any a, DynValue that)
static void | DynValueHelper.write(OutputStream ostream, DynValue value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValueBox 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValueBox
的使用

没有 org.omg.DynamicAny.DynValueBox 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValueBoxOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValueBoxOperations
的使用

使用 DynValueBoxOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynValueBoxOperations 的使用

org.omg.DynamicAny 中 DynValueBoxOperations 的子接口
 interface DynValueBox
DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValueCommon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValueCommon
的使用

使用 DynValueCommon 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynValueCommon 的使用

org.omg.DynamicAny 中 DynValueCommon 的子接口
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。

实现 DynValueCommon 的 org.omg.DynamicAny 中的类
 class _DynValueStub
DynValue 对象支持 IDL non-boxed value 类型的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValueCommonOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValueCommonOperations
的使用

使用 DynValueCommonOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynValueCommonOperations 的使用

org.omg.DynamicAny 中 DynValueCommonOperations 的子接口
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueBoxOperations DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
interface | DynValueOperations DynValue 对象支持对 IDL 非装箱 (boxed) 值类型的支持。

实现 DynValueCommonOperations 的 org.omg.DynamicAny 中的类
 class _DynValueStub
DynValue 对象支持 IDL non-boxed value 类型的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynValueHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynValueHelper
的使用

没有 org.omg.DynamicAny.DynValueHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValueOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValueOperations
的使用

使用 DynValueOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynValueOperations 的使用

org.omg.DynamicAny 中 DynValueOperations 的子接口
 interface DynValue
DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。

实现 DynValueOperations 的 org.omg.DynamicAny 中的类
 class _DynValueStub
DynValue 对象支持 IDL non-boxed value 类型的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.FieldNameHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.FieldNameHelper
的使用

没有 org.omg.DynamicAny.FieldNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameDynAnyPair 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameDynAnyPair
的使用

使用 NameDynAnyPair 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 NameDynAnyPair 的使用

返回 NameDynAnyPair 的 org.omg.DynamicAny 中的方法
static NameDynAnyPair | NameDynAnyPairHelper.extract(Any a)
static NameDynAnyPair[] | NameDynAnyPairSeqHelper.extract(Any a)
NameDynAnyPair[] | DynStructOperations.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
NameDynAnyPair[] | DynValueOperations.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
NameDynAnyPair[] | _DynStructStub.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
NameDynAnyPair[] | _DynValueStub.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
static NameDynAnyPair | NameDynAnyPairHelper.read(InputStream istream)
static NameDynAnyPair[] | NameDynAnyPairSeqHelper.read(InputStream istream)

参数类型为 NameDynAnyPair 的 org.omg.DynamicAny 中的方法
static void | NameDynAnyPairHelper.insert(Any a, NameDynAnyPair that)
static void | NameDynAnyPairSeqHelper.insert(Any a, NameDynAnyPair[] that)
void | DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
static void | NameDynAnyPairHelper.write(OutputStream ostream, NameDynAnyPair value)
static void | NameDynAnyPairSeqHelper.write(OutputStream ostream, NameDynAnyPair[] value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameDynAnyPairHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameDynAnyPairHelper
的使用

没有 org.omg.DynamicAny.NameDynAnyPairHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameDynAnyPairSeqHelper
的使用

没有 org.omg.DynamicAny.NameDynAnyPairSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameValuePair 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameValuePair
的使用

使用 NameValuePair 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 NameValuePair 的使用

返回 NameValuePair 的 org.omg.DynamicAny 中的方法
static NameValuePair | NameValuePairHelper.extract(Any a)
static NameValuePair[] | NameValuePairSeqHelper.extract(Any a)
NameValuePair[] | DynStructOperations.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
NameValuePair[] | DynValueOperations.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
NameValuePair[] | _DynStructStub.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
NameValuePair[] | _DynValueStub.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
static NameValuePair | NameValuePairHelper.read(InputStream istream)
static NameValuePair[] | NameValuePairSeqHelper.read(InputStream istream)

参数类型为 NameValuePair 的 org.omg.DynamicAny 中的方法
static void | NameValuePairHelper.insert(Any a, NameValuePair that)
static void | NameValuePairSeqHelper.insert(Any a, NameValuePair[] that)
void | DynStructOperations.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
void | _DynStructStub.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
static void | NameValuePairSeqHelper.write(OutputStream ostream, NameValuePair[] value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameValuePairHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameValuePairHelper
的使用

没有 org.omg.DynamicAny.NameValuePairHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameValuePairSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameValuePairSeqHelper
的使用

没有 org.omg.DynamicAny.NameValuePairSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.DynamicAny.DynAnyFactoryPackage (Java 2 Platform SE 6)

 org.omg.DynamicAny.DynAnyFactoryPackage
类
InconsistentTypeCodeHelper
异常
InconsistentTypeCode


类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
的使用

使用 InconsistentTypeCode 的软件包
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。

org.omg.DynamicAny 中 InconsistentTypeCode 的使用

抛出 InconsistentTypeCode 的 org.omg.DynamicAny 中的方法
DynAny | DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | DynAnyFactoryOperations.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
DynAny | _DynAnyFactoryStub.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。

org.omg.DynamicAny.DynAnyFactoryPackage 中 InconsistentTypeCode 的使用

返回 InconsistentTypeCode 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static InconsistentTypeCode | InconsistentTypeCodeHelper.extract(Any a)
static InconsistentTypeCode | InconsistentTypeCodeHelper.read(InputStream istream)

参数类型为 InconsistentTypeCode 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static void | InconsistentTypeCodeHelper.insert(Any a, InconsistentTypeCode that)
static void | InconsistentTypeCodeHelper.write(OutputStream ostream, InconsistentTypeCode value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
的使用

没有 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.DynamicAny.DynAnyPackage (Java 2 Platform SE 6)

 org.omg.DynamicAny.DynAnyPackage
类
InvalidValueHelper
TypeMismatchHelper
异常
InvalidValue
TypeMismatch


类 org.omg.DynamicAny.DynAnyPackage.InvalidValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyPackage.InvalidValue
的使用

使用 InvalidValue 的软件包
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。

org.omg.DynamicAny 中 InvalidValue 的使用

抛出 InvalidValue 的 org.omg.DynamicAny 中的方法
TCKind | DynStructOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | DynValueOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynStructStub.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynValueStub.current_member_kind() 返回与当前位置的成员有关联的 TCKind。
String | DynStructOperations.current_member_name() 返回当前位置的成员的名称。
String | DynValueOperations.current_member_name() 返回当前位置上的成员的名称。
String | _DynStructStub.current_member_name() 返回当前位置上的成员的名称。
String | _DynValueStub.current_member_name() 返回当前位置上成员的名称。
void | DynAnyOperations.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynAnyStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynArrayStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynEnumStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynFixedStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynSequenceStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynStructStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynUnionStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynValueStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
Any | DynAnyOperations.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynAnyStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynArrayStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynEnumStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynFixedStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
Any | _DynSequenceStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynStructStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynUnionStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynValueStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
boolean | DynAnyOperations.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynAnyStub.get_boolean() 从此 DynAny 析取 boolean 值。
boolean | _DynArrayStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynEnumStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynFixedStub.get_boolean() 从此 DynAny 提取 boolean 值。
boolean | _DynSequenceStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynStructStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynUnionStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynValueStub.get_boolean() 从此 DynAny 中提取 boolean 值。
DynAny | DynValueBoxOperations.get_boxed_value_as_dyn_any() 以 DynAny 的形式返回已装箱值。
Any | DynValueBoxOperations.get_boxed_value() 以 Any 的形式返回装箱值。
char | DynAnyOperations.get_char() 从此 DynAny 中提取 char 值。
char | _DynAnyStub.get_char() 从此 DynAny 析取 char 值。
char | _DynArrayStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynEnumStub.get_char() 从此 DynAny 析取 char 值。
char | _DynFixedStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynSequenceStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynStructStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynUnionStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynValueStub.get_char() 从此 DynAny 中提取 char 值。
double | DynAnyOperations.get_double() 从此 DynAny 中提取 double 值。
double | _DynAnyStub.get_double() 从此 DynAny 析取 double 值。
double | _DynArrayStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynEnumStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynFixedStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynSequenceStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynStructStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynUnionStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynValueStub.get_double() 从此 DynAny 中提取 double 值。
DynAny | DynAnyOperations.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynAnyStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynArrayStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynEnumStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynFixedStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynSequenceStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynStructStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynUnionStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynValueStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值，并将其包装在新 DynAny 中返回。
float | DynAnyOperations.get_float() 从此 DynAny 中提取 float 值。
float | _DynAnyStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynArrayStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynEnumStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynFixedStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynSequenceStub.get_float() 从此 DynAny 提取 float 值。
float | _DynStructStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynUnionStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynValueStub.get_float() 从此 DynAny 中提取 float 值。
int | DynAnyOperations.get_long() 从此 DynAny 中提取 integer 值。
int | _DynAnyStub.get_long() 从此 DynAny 析取 integer 值。
int | _DynArrayStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynEnumStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynFixedStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynSequenceStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynStructStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynUnionStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynValueStub.get_long() 从此 DynAny 中提取 integer 值。
long | DynAnyOperations.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynAnyStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynArrayStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynEnumStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynFixedStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynSequenceStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynStructStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynUnionStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynValueStub.get_longlong() 从此 DynAny 中提取 long 值。
NameDynAnyPair[] | DynValueOperations.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
NameDynAnyPair[] | _DynValueStub.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
NameValuePair[] | DynValueOperations.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
NameValuePair[] | _DynValueStub.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
byte | DynAnyOperations.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynAnyStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynArrayStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynEnumStub.get_octet() 从此 DynAny 析取 byte 值。
byte | _DynFixedStub.get_octet() 从此 DynAny 析取 byte 值。
byte | _DynSequenceStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynStructStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynUnionStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynValueStub.get_octet() 从此 DynAny 中提取 byte 值。
Object | DynAnyOperations.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynAnyStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynArrayStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynEnumStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynFixedStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynSequenceStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynStructStub.get_reference() 从此 DynAny 析取对 CORBA 对象的引用。
Object | _DynUnionStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynValueStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
short | DynAnyOperations.get_short() 从此 DynAny 中提取 short 值。
short | _DynAnyStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynArrayStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynEnumStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynFixedStub.get_short() 从此 DynAny 析取 short 值。
short | _DynSequenceStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynStructStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynUnionStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynValueStub.get_short() 从此 DynAny 中提取 short 值。
String | DynAnyOperations.get_string() 从此 DynAny 中提取 string 值。
String | _DynAnyStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynArrayStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynEnumStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynFixedStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynSequenceStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynStructStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynUnionStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynValueStub.get_string() 从此 DynAny 中提取 string 值。
TypeCode | DynAnyOperations.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynAnyStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynArrayStub.get_typecode() 从此 DynAny 析取 TypeCode 对象。
TypeCode | _DynEnumStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynFixedStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynSequenceStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynStructStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynUnionStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynValueStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
int | DynAnyOperations.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynAnyStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynArrayStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynEnumStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynFixedStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynSequenceStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynStructStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynUnionStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynValueStub.get_ulong() 从此 DynAny 中提取 integer 值。
long | DynAnyOperations.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynAnyStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynArrayStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynEnumStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynFixedStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynSequenceStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynStructStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynUnionStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynValueStub.get_ulonglong() 从此 DynAny 中提取 long 值。
short | DynAnyOperations.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynAnyStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynArrayStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynEnumStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynFixedStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynSequenceStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynStructStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynUnionStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynValueStub.get_ushort() 从此 DynAny 中提取 short 值。
Serializable | DynAnyOperations.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynAnyStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynArrayStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynEnumStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynFixedStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynSequenceStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynStructStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynUnionStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynValueStub.get_val() 从此 DynAny 中提取 Serializable 对象。
char | DynAnyOperations.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynAnyStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynArrayStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynEnumStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynFixedStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynSequenceStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynStructStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynUnionStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynValueStub.get_wchar() 从此 DynAny 中提取 long 值。
String | DynAnyOperations.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynAnyStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynArrayStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynEnumStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynFixedStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynSequenceStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynStructStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynUnionStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynValueStub.get_wstring() 从此 DynAny 中提取 string 值。
void | DynAnyOperations.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynFixedStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_any(Any value) 将 Any 值插入由此 DynAny 表示的 Any 中。
void | _DynStructStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | DynAnyOperations.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynAnyStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynArrayStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynEnumStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynFixedStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynSequenceStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynStructStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynUnionStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynValueStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | DynAnyOperations.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynAnyStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynArrayStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynEnumStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynFixedStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynSequenceStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynStructStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynUnionStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynValueStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | DynAnyOperations.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynAnyStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynArrayStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynEnumStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynFixedStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynSequenceStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynStructStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynUnionStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynValueStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | DynAnyOperations.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynFixedStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynStructStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | DynAnyOperations.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynAnyStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynArrayStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynEnumStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynFixedStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynSequenceStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynStructStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynUnionStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynValueStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | DynAnyOperations.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynAnyStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynArrayStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynEnumStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynFixedStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynSequenceStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynStructStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynUnionStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynValueStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | DynAnyOperations.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynAnyStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynArrayStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynEnumStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynFixedStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynSequenceStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynStructStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynUnionStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynValueStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | DynAnyOperations.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynAnyStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynArrayStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynEnumStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynFixedStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynSequenceStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynStructStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynUnionStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynValueStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | DynAnyOperations.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynAnyStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynArrayStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynEnumStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynFixedStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynSequenceStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynStructStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynUnionStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynValueStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | DynAnyOperations.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynAnyStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynArrayStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynEnumStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynFixedStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynSequenceStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynStructStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynUnionStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynValueStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | DynAnyOperations.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynAnyStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynArrayStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynEnumStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynFixedStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynSequenceStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynStructStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynUnionStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynValueStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | DynAnyOperations.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynAnyStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynArrayStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynEnumStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynFixedStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynSequenceStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynStructStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynUnionStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynValueStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | DynAnyOperations.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynAnyStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynArrayStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynEnumStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynFixedStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynSequenceStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynStructStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynUnionStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynValueStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | DynAnyOperations.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynAnyStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynArrayStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynEnumStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynFixedStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynSequenceStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynStructStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynUnionStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynValueStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | DynAnyOperations.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynAnyStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynArrayStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynEnumStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynFixedStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynSequenceStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynStructStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynUnionStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynValueStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | DynAnyOperations.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynAnyStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynArrayStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynEnumStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynFixedStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynSequenceStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynStructStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynUnionStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynValueStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | DynAnyOperations.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynAnyStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynArrayStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynEnumStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynFixedStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynSequenceStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynStructStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynUnionStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynValueStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | DynAnyOperations.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynAnyStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynArrayStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynEnumStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynFixedStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynSequenceStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynStructStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynUnionStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynValueStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
TCKind | DynUnionOperations.member_kind() 返回当前活动成员 TypeCode 的 TCKind 值。
TCKind | _DynUnionStub.member_kind() 返回当前活动成员 TypeCode 的 TCKind 值。
String | DynUnionOperations.member_name() 返回当前活动成员的名称。
String | _DynUnionStub.member_name() 返回当前活动成员的名称。
DynAny | DynUnionOperations.member() 返回当前活动成员。
DynAny | _DynUnionStub.member() 返回当前活动成员。
void | DynEnumOperations.set_as_string(String value) 将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。
void | _DynEnumStub.set_as_string(String value) 将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。
void | DynEnumOperations.set_as_ulong(int value) 将 DynEnum 的值设置为枚举值的序号。
void | _DynEnumStub.set_as_ulong(int value) 将 DynEnum 的值设置为枚举值的序号。
void | DynArrayOperations.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | _DynArrayStub.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | DynArrayOperations.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements(Any[] value) 设置序列的元素。
void | _DynArrayStub.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements(Any[] value) 设置序列的元素。
void | DynSequenceOperations.set_length(int len) 设置序列的长度。
void | _DynSequenceStub.set_length(int len) 设置序列的长度。
void | DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | DynStructOperations.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
void | _DynStructStub.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
boolean | DynFixedOperations.set_value(String val) 设置 DynFixed 的值。
boolean | _DynFixedStub.set_value(String val) 设置 DynFixed 的值。

org.omg.DynamicAny.DynAnyPackage 中 InvalidValue 的使用

返回 InvalidValue 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static InvalidValue | InvalidValueHelper.extract(Any a)
static InvalidValue | InvalidValueHelper.read(InputStream istream)

参数类型为 InvalidValue 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static void | InvalidValueHelper.insert(Any a, InvalidValue that)
static void | InvalidValueHelper.write(OutputStream ostream, InvalidValue value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
的使用

没有 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyPackage.TypeMismatch 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyPackage.TypeMismatch
的使用

使用 TypeMismatch 的软件包
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。

org.omg.DynamicAny 中 TypeMismatch 的使用

抛出 TypeMismatch 的 org.omg.DynamicAny 中的方法
void | DynAnyOperations.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
void | _DynAnyStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynArrayStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynEnumStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynFixedStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynSequenceStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynStructStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynUnionStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
void | _DynValueStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
DynAny | DynAnyOperations.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynAnyStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynArrayStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynEnumStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynFixedStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynSequenceStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynStructStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynUnionStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynValueStub.current_component() 返回当前位置上的组件的 DynAny。
TCKind | DynStructOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | DynValueOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynStructStub.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynValueStub.current_member_kind() 返回与当前位置的成员有关联的 TCKind。
String | DynStructOperations.current_member_name() 返回当前位置的成员的名称。
String | DynValueOperations.current_member_name() 返回当前位置上的成员的名称。
String | _DynStructStub.current_member_name() 返回当前位置上的成员的名称。
String | _DynValueStub.current_member_name() 返回当前位置上成员的名称。
void | DynAnyOperations.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynAnyStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynArrayStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynEnumStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynFixedStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynSequenceStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynStructStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynUnionStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynValueStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
Any | DynAnyOperations.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynAnyStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynArrayStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynEnumStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynFixedStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
Any | _DynSequenceStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynStructStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynUnionStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynValueStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
boolean | DynAnyOperations.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynAnyStub.get_boolean() 从此 DynAny 析取 boolean 值。
boolean | _DynArrayStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynEnumStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynFixedStub.get_boolean() 从此 DynAny 提取 boolean 值。
boolean | _DynSequenceStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynStructStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynUnionStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynValueStub.get_boolean() 从此 DynAny 中提取 boolean 值。
char | DynAnyOperations.get_char() 从此 DynAny 中提取 char 值。
char | _DynAnyStub.get_char() 从此 DynAny 析取 char 值。
char | _DynArrayStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynEnumStub.get_char() 从此 DynAny 析取 char 值。
char | _DynFixedStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynSequenceStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynStructStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynUnionStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynValueStub.get_char() 从此 DynAny 中提取 char 值。
double | DynAnyOperations.get_double() 从此 DynAny 中提取 double 值。
double | _DynAnyStub.get_double() 从此 DynAny 析取 double 值。
double | _DynArrayStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynEnumStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynFixedStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynSequenceStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynStructStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynUnionStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynValueStub.get_double() 从此 DynAny 中提取 double 值。
DynAny | DynAnyOperations.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynAnyStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynArrayStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynEnumStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynFixedStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynSequenceStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynStructStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynUnionStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynValueStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值，并将其包装在新 DynAny 中返回。
float | DynAnyOperations.get_float() 从此 DynAny 中提取 float 值。
float | _DynAnyStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynArrayStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynEnumStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynFixedStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynSequenceStub.get_float() 从此 DynAny 提取 float 值。
float | _DynStructStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynUnionStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynValueStub.get_float() 从此 DynAny 中提取 float 值。
int | DynAnyOperations.get_long() 从此 DynAny 中提取 integer 值。
int | _DynAnyStub.get_long() 从此 DynAny 析取 integer 值。
int | _DynArrayStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynEnumStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynFixedStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynSequenceStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynStructStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynUnionStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynValueStub.get_long() 从此 DynAny 中提取 integer 值。
long | DynAnyOperations.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynAnyStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynArrayStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynEnumStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynFixedStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynSequenceStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynStructStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynUnionStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynValueStub.get_longlong() 从此 DynAny 中提取 long 值。
byte | DynAnyOperations.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynAnyStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynArrayStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynEnumStub.get_octet() 从此 DynAny 析取 byte 值。
byte | _DynFixedStub.get_octet() 从此 DynAny 析取 byte 值。
byte | _DynSequenceStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynStructStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynUnionStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynValueStub.get_octet() 从此 DynAny 中提取 byte 值。
Object | DynAnyOperations.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynAnyStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynArrayStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynEnumStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynFixedStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynSequenceStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynStructStub.get_reference() 从此 DynAny 析取对 CORBA 对象的引用。
Object | _DynUnionStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynValueStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
short | DynAnyOperations.get_short() 从此 DynAny 中提取 short 值。
short | _DynAnyStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynArrayStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynEnumStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynFixedStub.get_short() 从此 DynAny 析取 short 值。
short | _DynSequenceStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynStructStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynUnionStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynValueStub.get_short() 从此 DynAny 中提取 short 值。
String | DynAnyOperations.get_string() 从此 DynAny 中提取 string 值。
String | _DynAnyStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynArrayStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynEnumStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynFixedStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynSequenceStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynStructStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynUnionStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynValueStub.get_string() 从此 DynAny 中提取 string 值。
TypeCode | DynAnyOperations.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynAnyStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynArrayStub.get_typecode() 从此 DynAny 析取 TypeCode 对象。
TypeCode | _DynEnumStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynFixedStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynSequenceStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynStructStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynUnionStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynValueStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
int | DynAnyOperations.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynAnyStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynArrayStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynEnumStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynFixedStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynSequenceStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynStructStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynUnionStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynValueStub.get_ulong() 从此 DynAny 中提取 integer 值。
long | DynAnyOperations.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynAnyStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynArrayStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynEnumStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynFixedStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynSequenceStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynStructStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynUnionStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynValueStub.get_ulonglong() 从此 DynAny 中提取 long 值。
short | DynAnyOperations.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynAnyStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynArrayStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynEnumStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynFixedStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynSequenceStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynStructStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynUnionStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynValueStub.get_ushort() 从此 DynAny 中提取 short 值。
Serializable | DynAnyOperations.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynAnyStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynArrayStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynEnumStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynFixedStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynSequenceStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynStructStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynUnionStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynValueStub.get_val() 从此 DynAny 中提取 Serializable 对象。
char | DynAnyOperations.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynAnyStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynArrayStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynEnumStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynFixedStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynSequenceStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynStructStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynUnionStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynValueStub.get_wchar() 从此 DynAny 中提取 long 值。
String | DynAnyOperations.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynAnyStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynArrayStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynEnumStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynFixedStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynSequenceStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynStructStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynUnionStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynValueStub.get_wstring() 从此 DynAny 中提取 string 值。
void | DynAnyOperations.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynFixedStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_any(Any value) 将 Any 值插入由此 DynAny 表示的 Any 中。
void | _DynStructStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | DynAnyOperations.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynAnyStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynArrayStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynEnumStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynFixedStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynSequenceStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynStructStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynUnionStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynValueStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | DynAnyOperations.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynAnyStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynArrayStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynEnumStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynFixedStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynSequenceStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynStructStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynUnionStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynValueStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | DynAnyOperations.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynAnyStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynArrayStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynEnumStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynFixedStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynSequenceStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynStructStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynUnionStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynValueStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | DynAnyOperations.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynFixedStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynStructStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | DynAnyOperations.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynAnyStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynArrayStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynEnumStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynFixedStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynSequenceStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynStructStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynUnionStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynValueStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | DynAnyOperations.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynAnyStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynArrayStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynEnumStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynFixedStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynSequenceStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynStructStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynUnionStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynValueStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | DynAnyOperations.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynAnyStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynArrayStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynEnumStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynFixedStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynSequenceStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynStructStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynUnionStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynValueStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | DynAnyOperations.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynAnyStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynArrayStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynEnumStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynFixedStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynSequenceStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynStructStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynUnionStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynValueStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | DynAnyOperations.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynAnyStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynArrayStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynEnumStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynFixedStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynSequenceStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynStructStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynUnionStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynValueStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | DynAnyOperations.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynAnyStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynArrayStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynEnumStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynFixedStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynSequenceStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynStructStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynUnionStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynValueStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | DynAnyOperations.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynAnyStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynArrayStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynEnumStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynFixedStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynSequenceStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynStructStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynUnionStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynValueStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | DynAnyOperations.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynAnyStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynArrayStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynEnumStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynFixedStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynSequenceStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynStructStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynUnionStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynValueStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | DynAnyOperations.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynAnyStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynArrayStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynEnumStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynFixedStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynSequenceStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynStructStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynUnionStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynValueStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | DynAnyOperations.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynAnyStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynArrayStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynEnumStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynFixedStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynSequenceStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynStructStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynUnionStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynValueStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | DynAnyOperations.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynAnyStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynArrayStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynEnumStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynFixedStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynSequenceStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynStructStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynUnionStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynValueStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | DynAnyOperations.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynAnyStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynArrayStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynEnumStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynFixedStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynSequenceStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynStructStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynUnionStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynValueStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | DynAnyOperations.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynAnyStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynArrayStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynEnumStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynFixedStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynSequenceStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynStructStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynUnionStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynValueStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | DynAnyOperations.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynAnyStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynArrayStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynEnumStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynFixedStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynSequenceStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynStructStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynUnionStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynValueStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | DynValueBoxOperations.set_boxed_value_as_dyn_any(DynAny boxed) 使用参数中包含的值取代已装箱值。
void | DynValueBoxOperations.set_boxed_value(Any boxed) 使用指定值取代已装箱值。
void | DynUnionOperations.set_discriminator(DynAny d) 将 DynUnion 的鉴别符值设置为指定值。
void | _DynUnionStub.set_discriminator(DynAny d) 将 DynUnion 的鉴别符值设置为指定值。
void | DynArrayOperations.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | _DynArrayStub.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | DynArrayOperations.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements(Any[] value) 设置序列的元素。
void | _DynArrayStub.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements(Any[] value) 设置序列的元素。
void | DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | DynStructOperations.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
void | _DynStructStub.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
void | DynUnionOperations.set_to_default_member() 将鉴别符设置为联合数据的默认 case 的值。
void | _DynUnionStub.set_to_default_member() 将鉴别符设置为联合数据的默认 case 的值。
void | DynUnionOperations.set_to_no_active_member() 将鉴别符设置为与任何联合数据 case 标签都不相应的值。
void | _DynUnionStub.set_to_no_active_member() 将鉴别符设置为与任何联合数据 case 标签都不相应的值。
boolean | DynFixedOperations.set_value(String val) 设置 DynFixed 的值。
boolean | _DynFixedStub.set_value(String val) 设置 DynFixed 的值。

org.omg.DynamicAny.DynAnyPackage 中 TypeMismatch 的使用

返回 TypeMismatch 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static TypeMismatch | TypeMismatchHelper.extract(Any a)
static TypeMismatch | TypeMismatchHelper.read(InputStream istream)

参数类型为 TypeMismatch 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)
static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
的使用

没有 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.IOP (Java 2 Platform SE 6)

 org.omg.IOP
接口
Codec
CodecFactory
CodecFactoryOperations
CodecOperations
CodeSets
ENCODING_CDR_ENCAPS
ExceptionDetailMessage
RMICustomMaxStreamFormat
TAG_ALTERNATE_IIOP_ADDRESS
TAG_CODE_SETS
TAG_INTERNET_IOP
TAG_JAVA_CODEBASE
TAG_MULTIPLE_COMPONENTS
TAG_ORB_TYPE
TAG_POLICIES
TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
TransactionService
类
CodecFactoryHelper
ComponentIdHelper
Encoding
IOR
IORHelper
IORHolder
MultipleComponentProfileHelper
MultipleComponentProfileHolder
ProfileIdHelper
ServiceContext
ServiceContextHelper
ServiceContextHolder
ServiceContextListHelper
ServiceContextListHolder
ServiceIdHelper
TaggedComponent
TaggedComponentHelper
TaggedComponentHolder
TaggedProfile
TaggedProfileHelper
TaggedProfileHolder


接口 org.omg.IOP.Codec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.Codec
的使用

使用 Codec 的软件包
org.omg.IOP 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP 中 Codec 的使用

返回 Codec 的 org.omg.IOP 中的方法
 Codec CodecFactoryOperations.create_codec(Encoding enc)
创建一个给定编码的 Codec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.CodecFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.CodecFactory
的使用

使用 CodecFactory 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.IOP 中 CodecFactory 的使用

返回 CodecFactory 的 org.omg.IOP 中的方法
static CodecFactory | CodecFactoryHelper.extract(Any a)
static CodecFactory | CodecFactoryHelper.narrow(Object obj)
static CodecFactory | CodecFactoryHelper.read(InputStream istream)
static CodecFactory | CodecFactoryHelper.unchecked_narrow(Object obj)

参数类型为 CodecFactory 的 org.omg.IOP 中的方法
static void | CodecFactoryHelper.insert(Any a, CodecFactory that)
static void | CodecFactoryHelper.write(OutputStream ostream, CodecFactory value)

org.omg.PortableInterceptor 中 CodecFactory 的使用

返回 CodecFactory 的 org.omg.PortableInterceptor 中的方法
 CodecFactory ORBInitInfoOperations.codec_factory()
返回 IOP.CodecFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.CodecFactoryHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecFactoryHelper
的使用

没有 org.omg.IOP.CodecFactoryHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.CodecFactoryOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.CodecFactoryOperations
的使用

使用 CodecFactoryOperations 的软件包
org.omg.IOP 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP 中 CodecFactoryOperations 的使用

org.omg.IOP 中 CodecFactoryOperations 的子接口
 interface CodecFactory
Codec 可从 CodecFactory 中获得。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.CodecOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.CodecOperations
的使用

使用 CodecOperations 的软件包
org.omg.IOP 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP 中 CodecOperations 的使用

org.omg.IOP 中 CodecOperations 的子接口
 interface Codec
IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.CodeSets 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.CodeSets
的使用

没有 org.omg.IOP.CodeSets 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.ComponentIdHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ComponentIdHelper
的使用

没有 org.omg.IOP.ComponentIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.Encoding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.Encoding
的使用

使用 Encoding 的软件包
org.omg.IOP 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP 中 Encoding 的使用

参数类型为 Encoding 的 org.omg.IOP 中的方法
 Codec CodecFactoryOperations.create_codec(Encoding enc)
创建一个给定编码的 Codec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.ENCODING_CDR_ENCAPS 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.ENCODING_CDR_ENCAPS
的使用

没有 org.omg.IOP.ENCODING_CDR_ENCAPS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.ExceptionDetailMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.ExceptionDetailMessage
的使用

没有 org.omg.IOP.ExceptionDetailMessage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.IOR 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.IOR
的使用

使用 IOR 的软件包
org.omg.IOP 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP 中 IOR 的使用

声明为 IOR 的 org.omg.IOP 中的字段
 IOR IORHolder.value

返回 IOR 的 org.omg.IOP 中的方法
static IOR | IORHelper.extract(Any a)
static IOR | IORHelper.read(InputStream istream)

参数类型为 IOR 的 org.omg.IOP 中的方法
static void | IORHelper.insert(Any a, IOR that)
static void | IORHelper.write(OutputStream ostream, IOR value)

参数类型为 IOR 的 org.omg.IOP 中的构造方法
IORHolder(IOR initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.IORHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.IORHelper
的使用

没有 org.omg.IOP.IORHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.IORHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.IORHolder
的使用

没有 org.omg.IOP.IORHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.MultipleComponentProfileHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.MultipleComponentProfileHelper
的使用

没有 org.omg.IOP.MultipleComponentProfileHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.MultipleComponentProfileHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.MultipleComponentProfileHolder
的使用

没有 org.omg.IOP.MultipleComponentProfileHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.ProfileIdHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ProfileIdHelper
的使用

没有 org.omg.IOP.ProfileIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.RMICustomMaxStreamFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.RMICustomMaxStreamFormat
的使用

没有 org.omg.IOP.RMICustomMaxStreamFormat 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.ServiceContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceContext
的使用

使用 ServiceContext 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.IOP 中 ServiceContext 的使用

声明为 ServiceContext 的 org.omg.IOP 中的字段
ServiceContext | ServiceContextHolder.value
ServiceContext[] | ServiceContextListHolder.value

返回 ServiceContext 的 org.omg.IOP 中的方法
static ServiceContext | ServiceContextHelper.extract(Any a)
static ServiceContext[] | ServiceContextListHelper.extract(Any a)
static ServiceContext | ServiceContextHelper.read(InputStream istream)
static ServiceContext[] | ServiceContextListHelper.read(InputStream istream)

参数类型为 ServiceContext 的 org.omg.IOP 中的方法
static void | ServiceContextHelper.insert(Any a, ServiceContext that)
static void | ServiceContextListHelper.insert(Any a, ServiceContext[] that)
static void | ServiceContextHelper.write(OutputStream ostream, ServiceContext value)
static void | ServiceContextListHelper.write(OutputStream ostream, ServiceContext[] value)

参数类型为 ServiceContext 的 org.omg.IOP 中的构造方法
ServiceContextHolder(ServiceContext initialValue)
ServiceContextListHolder(ServiceContext[] initialValue)

org.omg.PortableInterceptor 中 ServiceContext 的使用

返回 ServiceContext 的 org.omg.PortableInterceptor 中的方法
ServiceContext | RequestInfoOperations.get_reply_service_context(int id) 返回具有给定 ID 的与应答关联的服务上下文复本。
ServiceContext | RequestInfoOperations.get_request_service_context(int id) 返回具有给定 ID 的与请求关联的服务上下文复本。

参数类型为 ServiceContext 的 org.omg.PortableInterceptor 中的方法
void | ServerRequestInfoOperations.add_reply_service_context(ServiceContext service_context, boolean replace) 允许 Interceptor 将服务上下文添加到请求。
void | ClientRequestInfoOperations.add_request_service_context(ServiceContext service_context, boolean replace) 允许 Interceptor 将服务上下文添加到请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.ServiceContextHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceContextHelper
的使用

没有 org.omg.IOP.ServiceContextHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.ServiceContextHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceContextHolder
的使用

没有 org.omg.IOP.ServiceContextHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.ServiceContextListHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceContextListHelper
的使用

没有 org.omg.IOP.ServiceContextListHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.ServiceContextListHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceContextListHolder
的使用

没有 org.omg.IOP.ServiceContextListHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.ServiceIdHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceIdHelper
的使用

没有 org.omg.IOP.ServiceIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
的使用

没有 org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_CODE_SETS 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_CODE_SETS
的使用

没有 org.omg.IOP.TAG_CODE_SETS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_INTERNET_IOP 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_INTERNET_IOP
的使用

没有 org.omg.IOP.TAG_INTERNET_IOP 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_JAVA_CODEBASE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_JAVA_CODEBASE
的使用

没有 org.omg.IOP.TAG_JAVA_CODEBASE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_MULTIPLE_COMPONENTS 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_MULTIPLE_COMPONENTS
的使用

没有 org.omg.IOP.TAG_MULTIPLE_COMPONENTS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_ORB_TYPE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_ORB_TYPE
的使用

没有 org.omg.IOP.TAG_ORB_TYPE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_POLICIES 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_POLICIES
的使用

没有 org.omg.IOP.TAG_POLICIES 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
的使用

没有 org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.TaggedComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedComponent
的使用

使用 TaggedComponent 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.IOP 中 TaggedComponent 的使用

声明为 TaggedComponent 的 org.omg.IOP 中的字段
TaggedComponent[] | MultipleComponentProfileHolder.value
TaggedComponent | TaggedComponentHolder.value

返回 TaggedComponent 的 org.omg.IOP 中的方法
static TaggedComponent[] | MultipleComponentProfileHelper.extract(Any a)
static TaggedComponent | TaggedComponentHelper.extract(Any a)
static TaggedComponent[] | MultipleComponentProfileHelper.read(InputStream istream)
static TaggedComponent | TaggedComponentHelper.read(InputStream istream)

参数类型为 TaggedComponent 的 org.omg.IOP 中的方法
static void | TaggedComponentHelper.insert(Any a, TaggedComponent that)
static void | MultipleComponentProfileHelper.insert(Any a, TaggedComponent[] that)
static void | TaggedComponentHelper.write(OutputStream ostream, TaggedComponent value)
static void | MultipleComponentProfileHelper.write(OutputStream ostream, TaggedComponent[] value)

参数类型为 TaggedComponent 的 org.omg.IOP 中的构造方法
MultipleComponentProfileHolder(TaggedComponent[] initialValue)
TaggedComponentHolder(TaggedComponent initialValue)

org.omg.PortableInterceptor 中 TaggedComponent 的使用

返回 TaggedComponent 的 org.omg.PortableInterceptor 中的方法
TaggedComponent | ClientRequestInfoOperations.get_effective_component(int id) 返回为此请求选择的配置文件中带有给定 ID 的 IOP.TaggedComponent。
TaggedComponent[] | ClientRequestInfoOperations.get_effective_components(int id) 返回为此请求选择的配置文件中具有给定 ID 的带标记组件所组成的数组。

参数类型为 TaggedComponent 的 org.omg.PortableInterceptor 中的方法
void | IORInfoOperations.add_ior_component_to_profile(TaggedComponent tagged_component, int profile_id) 可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component_to_profile，以便向构造 IOR 时要包括的设置添加带标记的组件。
void | IORInfoOperations.add_ior_component(TaggedComponent tagged_component) 可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component，以便向构造 IOR 时要包括的设置添加带标记的组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.TaggedComponentHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedComponentHelper
的使用

没有 org.omg.IOP.TaggedComponentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.TaggedComponentHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedComponentHolder
的使用

没有 org.omg.IOP.TaggedComponentHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.TaggedProfile 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedProfile
的使用

使用 TaggedProfile 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.IOP 中 TaggedProfile 的使用

声明为 TaggedProfile 的 org.omg.IOP 中的字段
TaggedProfile[] | IOR.profiles 与此对象引用关联的一组有标记的配置文件。
TaggedProfile | TaggedProfileHolder.value

返回 TaggedProfile 的 org.omg.IOP 中的方法
static TaggedProfile | TaggedProfileHelper.extract(Any a)
static TaggedProfile | TaggedProfileHelper.read(InputStream istream)

参数类型为 TaggedProfile 的 org.omg.IOP 中的方法
static void | TaggedProfileHelper.insert(Any a, TaggedProfile that)
static void | TaggedProfileHelper.write(OutputStream ostream, TaggedProfile value)

参数类型为 TaggedProfile 的 org.omg.IOP 中的构造方法
IOR(String _type_id, TaggedProfile[] _profiles)
TaggedProfileHolder(TaggedProfile initialValue)

org.omg.PortableInterceptor 中 TaggedProfile 的使用

返回 TaggedProfile 的 org.omg.PortableInterceptor 中的方法
 TaggedProfile ClientRequestInfoOperations.effective_profile()
返回将用来发送请求的配置文件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.TaggedProfileHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedProfileHelper
的使用

没有 org.omg.IOP.TaggedProfileHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.TaggedProfileHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedProfileHolder
的使用

没有 org.omg.IOP.TaggedProfileHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.IOP.TransactionService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TransactionService
的使用

没有 org.omg.IOP.TransactionService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.IOP.CodecFactoryPackage (Java 2 Platform SE 6)

 org.omg.IOP.CodecFactoryPackage
类
UnknownEncodingHelper
异常
UnknownEncoding


类 org.omg.IOP.CodecFactoryPackage.UnknownEncoding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecFactoryPackage.UnknownEncoding
的使用

使用 UnknownEncoding 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。

org.omg.IOP 中 UnknownEncoding 的使用

抛出 UnknownEncoding 的 org.omg.IOP 中的方法
 Codec CodecFactoryOperations.create_codec(Encoding enc)
创建一个给定编码的 Codec。

org.omg.IOP.CodecFactoryPackage 中 UnknownEncoding 的使用

返回 UnknownEncoding 的 org.omg.IOP.CodecFactoryPackage 中的方法
static UnknownEncoding | UnknownEncodingHelper.extract(Any a)
static UnknownEncoding | UnknownEncodingHelper.read(InputStream istream)

参数类型为 UnknownEncoding 的 org.omg.IOP.CodecFactoryPackage 中的方法
static void | UnknownEncodingHelper.insert(Any a, UnknownEncoding that)
static void | UnknownEncodingHelper.write(OutputStream ostream, UnknownEncoding value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
的使用

没有 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.IOP.CodecPackage (Java 2 Platform SE 6)

 org.omg.IOP.CodecPackage
类
FormatMismatchHelper
InvalidTypeForEncodingHelper
TypeMismatchHelper
异常
FormatMismatch
InvalidTypeForEncoding
TypeMismatch


类 org.omg.IOP.CodecPackage.FormatMismatch 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.FormatMismatch
的使用

使用 FormatMismatch 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。

org.omg.IOP 中 FormatMismatch 的使用

抛出 FormatMismatch 的 org.omg.IOP 中的方法
Any | CodecOperations.decode_value(byte[] data, TypeCode tc) 基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。
Any | CodecOperations.decode(byte[] data) 基于对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。

org.omg.IOP.CodecPackage 中 FormatMismatch 的使用

返回 FormatMismatch 的 org.omg.IOP.CodecPackage 中的方法
static FormatMismatch | FormatMismatchHelper.extract(Any a)
static FormatMismatch | FormatMismatchHelper.read(InputStream istream)

参数类型为 FormatMismatch 的 org.omg.IOP.CodecPackage 中的方法
static void | FormatMismatchHelper.insert(Any a, FormatMismatch that)
static void | FormatMismatchHelper.write(OutputStream ostream, FormatMismatch value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.FormatMismatchHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.FormatMismatchHelper
的使用

没有 org.omg.IOP.CodecPackage.FormatMismatchHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.InvalidTypeForEncoding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.InvalidTypeForEncoding
的使用

使用 InvalidTypeForEncoding 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。

org.omg.IOP 中 InvalidTypeForEncoding 的使用

抛出 InvalidTypeForEncoding 的 org.omg.IOP 中的方法
byte[] | CodecOperations.encode_value(Any data) 基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
byte[] | CodecOperations.encode(Any data) 基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。

org.omg.IOP.CodecPackage 中 InvalidTypeForEncoding 的使用

返回 InvalidTypeForEncoding 的 org.omg.IOP.CodecPackage 中的方法
static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.extract(Any a)
static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.read(InputStream istream)

参数类型为 InvalidTypeForEncoding 的 org.omg.IOP.CodecPackage 中的方法
static void | InvalidTypeForEncodingHelper.insert(Any a, InvalidTypeForEncoding that)
static void | InvalidTypeForEncodingHelper.write(OutputStream ostream, InvalidTypeForEncoding value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
的使用

没有 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.TypeMismatch 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.TypeMismatch
的使用

使用 TypeMismatch 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。

org.omg.IOP 中 TypeMismatch 的使用

抛出 TypeMismatch 的 org.omg.IOP 中的方法
 Any CodecOperations.decode_value(byte[] data, TypeCode tc)
基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。

org.omg.IOP.CodecPackage 中 TypeMismatch 的使用

返回 TypeMismatch 的 org.omg.IOP.CodecPackage 中的方法
static TypeMismatch | TypeMismatchHelper.extract(Any a)
static TypeMismatch | TypeMismatchHelper.read(InputStream istream)

参数类型为 TypeMismatch 的 org.omg.IOP.CodecPackage 中的方法
static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)
static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.TypeMismatchHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.TypeMismatchHelper
的使用

没有 org.omg.IOP.CodecPackage.TypeMismatchHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.Messaging (Java 2 Platform SE 6)

 org.omg.Messaging
接口
SYNC_WITH_TRANSPORT
类
SyncScopeHelper


接口 org.omg.Messaging.SYNC_WITH_TRANSPORT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.Messaging.SYNC_WITH_TRANSPORT
的使用

没有 org.omg.Messaging.SYNC_WITH_TRANSPORT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.Messaging.SyncScopeHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.Messaging.SyncScopeHelper
的使用

没有 org.omg.Messaging.SyncScopeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.PortableInterceptor (Java 2 Platform SE 6)

 org.omg.PortableInterceptor
接口
ACTIVE
ClientRequestInfo
ClientRequestInfoOperations
ClientRequestInterceptor
ClientRequestInterceptorOperations
Current
CurrentOperations
DISCARDING
HOLDING
INACTIVE
Interceptor
InterceptorOperations
IORInfo
IORInfoOperations
IORInterceptor
IORInterceptor_3_0
IORInterceptor_3_0Operations
IORInterceptorOperations
LOCATION_FORWARD
NON_EXISTENT
ObjectReferenceFactory
ObjectReferenceTemplate
ORBInitializer
ORBInitializerOperations
ORBInitInfo
ORBInitInfoOperations
PolicyFactory
PolicyFactoryOperations
RequestInfo
RequestInfoOperations
ServerRequestInfo
ServerRequestInfoOperations
ServerRequestInterceptor
ServerRequestInterceptorOperations
SUCCESSFUL
SYSTEM_EXCEPTION
TRANSPORT_RETRY
UNKNOWN
USER_EXCEPTION
类
AdapterManagerIdHelper
AdapterNameHelper
AdapterStateHelper
CurrentHelper
ForwardRequestHelper
InvalidSlotHelper
IORInterceptor_3_0Helper
IORInterceptor_3_0Holder
ObjectIdHelper
ObjectReferenceFactoryHelper
ObjectReferenceFactoryHolder
ObjectReferenceTemplateHelper
ObjectReferenceTemplateHolder
ObjectReferenceTemplateSeqHelper
ObjectReferenceTemplateSeqHolder
ORBIdHelper
ServerIdHelper
异常
ForwardRequest
InvalidSlot


接口 org.omg.PortableInterceptor.ACTIVE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ACTIVE
的使用

没有 org.omg.PortableInterceptor.ACTIVE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.AdapterManagerIdHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.AdapterManagerIdHelper
的使用

没有 org.omg.PortableInterceptor.AdapterManagerIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.AdapterNameHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.AdapterNameHelper
的使用

没有 org.omg.PortableInterceptor.AdapterNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.AdapterStateHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.AdapterStateHelper
的使用

没有 org.omg.PortableInterceptor.AdapterStateHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ClientRequestInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ClientRequestInfo
的使用

使用 ClientRequestInfo 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ClientRequestInfo 的使用

参数类型为 ClientRequestInfo 的 org.omg.PortableInterceptor 中的方法
void | ClientRequestInterceptorOperations.receive_exception(ClientRequestInfo ri) 指示 interceptor 发生异常。
void | ClientRequestInterceptorOperations.receive_other(ClientRequestInfo ri) 允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
void | ClientRequestInterceptorOperations.receive_reply(ClientRequestInfo ri) 允许 Interceptor 在从服务器返回后但在向客户端返回控件前查询信息。
void | ClientRequestInterceptorOperations.send_poll(ClientRequestInfo ri) 允许 Interceptor 在轮询获取应答序列的与时间无关的调用（Time-Independent Invocation，TII）时查询信息。
void | ClientRequestInterceptorOperations.send_request(ClientRequestInfo ri) 允许 Interceptor 在请求被发送到服务器前查询请求信息并修改服务上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ClientRequestInfoOperations
的使用

使用 ClientRequestInfoOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ClientRequestInfoOperations 的使用

org.omg.PortableInterceptor 中 ClientRequestInfoOperations 的子接口
 interface ClientRequestInfo
客户端请求 interceptor 可访问的请求信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ClientRequestInterceptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ClientRequestInterceptor
的使用

使用 ClientRequestInterceptor 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ClientRequestInterceptor 的使用

参数类型为 ClientRequestInterceptor 的 org.omg.PortableInterceptor 中的方法
 void ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor interceptor)
此方法用来将客户端的请求 Interceptor 添加到客户端请求 Interceptor 列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations
的使用

使用 ClientRequestInterceptorOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ClientRequestInterceptorOperations 的使用

org.omg.PortableInterceptor 中 ClientRequestInterceptorOperations 的子接口
 interface ClientRequestInterceptor
客户端 interceptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.Current 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.Current
的使用

使用 Current 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 Current 的使用

返回 Current 的 org.omg.PortableInterceptor 中的方法
static Current | CurrentHelper.extract(Any a)
static Current | CurrentHelper.narrow(Object obj)
static Current | CurrentHelper.read(InputStream istream)
static Current | CurrentHelper.unchecked_narrow(Object obj)

参数类型为 Current 的 org.omg.PortableInterceptor 中的方法
static void | CurrentHelper.insert(Any a, Current that)
static void | CurrentHelper.write(OutputStream ostream, Current value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.CurrentHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.CurrentHelper
的使用

没有 org.omg.PortableInterceptor.CurrentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.CurrentOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.CurrentOperations
的使用

使用 CurrentOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 CurrentOperations 的使用

org.omg.PortableInterceptor 中 CurrentOperations 的子接口
 interface Current
Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.DISCARDING 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.DISCARDING
的使用

没有 org.omg.PortableInterceptor.DISCARDING 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ForwardRequest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ForwardRequest
的使用

使用 ForwardRequest 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ForwardRequest 的使用

返回 ForwardRequest 的 org.omg.PortableInterceptor 中的方法
static ForwardRequest | ForwardRequestHelper.extract(Any a)
static ForwardRequest | ForwardRequestHelper.read(InputStream istream)

参数类型为 ForwardRequest 的 org.omg.PortableInterceptor 中的方法
static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)

抛出 ForwardRequest 的 org.omg.PortableInterceptor 中的方法
void | ClientRequestInterceptorOperations.receive_exception(ClientRequestInfo ri) 指示 interceptor 发生异常。
void | ClientRequestInterceptorOperations.receive_other(ClientRequestInfo ri) 允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
void | ServerRequestInterceptorOperations.receive_request_service_contexts(ServerRequestInfo ri) 允许 interceptor 处理服务上下文信息。
void | ServerRequestInterceptorOperations.receive_request(ServerRequestInfo ri) 允许 Interceptor 在所有信息（包括操作参数）可用后查询信息。
void | ServerRequestInterceptorOperations.send_exception(ServerRequestInfo ri) 允许 Interceptor 在向客户端抛出异常前查询异常信息并修改应答服务上下文。
void | ServerRequestInterceptorOperations.send_other(ServerRequestInfo ri) 允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
void | ClientRequestInterceptorOperations.send_request(ClientRequestInfo ri) 允许 Interceptor 在请求被发送到服务器前查询请求信息并修改服务上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ForwardRequestHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ForwardRequestHelper
的使用

没有 org.omg.PortableInterceptor.ForwardRequestHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.HOLDING 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.HOLDING
的使用

没有 org.omg.PortableInterceptor.HOLDING 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.INACTIVE 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.INACTIVE
的使用

没有 org.omg.PortableInterceptor.INACTIVE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.Interceptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.Interceptor
的使用

使用 Interceptor 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 Interceptor 的使用

org.omg.PortableInterceptor 中 Interceptor 的子接口
interface | ClientRequestInterceptor 客户端 interceptor。
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | ServerRequestInterceptor 服务器端的请求 interceptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.InterceptorOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.InterceptorOperations
的使用

使用 InterceptorOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 InterceptorOperations 的使用

org.omg.PortableInterceptor 中 InterceptorOperations 的子接口
interface | ClientRequestInterceptor 客户端 interceptor。
interface | ClientRequestInterceptorOperations 客户端的请求 interceptor。
interface | Interceptor 所有 Portable Interceptor 实现 Interceptor。
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | IORInterceptor_3_0Operations org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java。
interface | IORInterceptorOperations Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | ServerRequestInterceptor 服务器端的请求 interceptor。
interface | ServerRequestInterceptorOperations 服务器端的请求 interceptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.InvalidSlot 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.InvalidSlot
的使用

使用 InvalidSlot 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 InvalidSlot 的使用

返回 InvalidSlot 的 org.omg.PortableInterceptor 中的方法
static InvalidSlot | InvalidSlotHelper.extract(Any a)
static InvalidSlot | InvalidSlotHelper.read(InputStream istream)

参数类型为 InvalidSlot 的 org.omg.PortableInterceptor 中的方法
static void | InvalidSlotHelper.insert(Any a, InvalidSlot that)
static void | InvalidSlotHelper.write(OutputStream ostream, InvalidSlot value)

抛出 InvalidSlot 的 org.omg.PortableInterceptor 中的方法
Any | CurrentOperations.get_slot(int id) 检索应用程序通过 get_slot 在 PICurrent 中设置的槽数据。
Any | RequestInfoOperations.get_slot(int id) 返回请求域内 PortableInterceptor.Current 给定槽 (slot) 中的数据。
void | CurrentOperations.set_slot(int id, Any data) 在槽中设置数据。
void | ServerRequestInfoOperations.set_slot(int id, Any data) 允许 Interceptor 在请求域中的 PortableInterceptor.Current 内设置槽 (slot)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.InvalidSlotHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.InvalidSlotHelper
的使用

没有 org.omg.PortableInterceptor.InvalidSlotHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInfo
的使用

使用 IORInfo 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInfo 的使用

参数类型为 IORInfo 的 org.omg.PortableInterceptor 中的方法
void | IORInterceptor_3_0Operations.components_established(IORInfo info) 在已经对所有已注册 IORInterceptor 实例调用 establish_components 方法后，对所有已注册 IORInterceptor_3_0 实例调用 components_established 方法。
void | IORInterceptorOperations.establish_components(IORInfo info) 在汇编将包括在对象引用配置文件中的组件列表时，服务器端 ORB 对所有已注册 IORInterceptor 实例调用 establish_components 操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInfoOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInfoOperations
的使用

使用 IORInfoOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInfoOperations 的使用

org.omg.PortableInterceptor 中 IORInfoOperations 的子接口
 interface IORInfo
提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInterceptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInterceptor
的使用

使用 IORInterceptor 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInterceptor 的使用

org.omg.PortableInterceptor 中 IORInterceptor 的子接口
 interface IORInterceptor_3_0
org/omg/PortableInterceptor/IORInterceptor_3_0.java。

参数类型为 IORInterceptor 的 org.omg.PortableInterceptor 中的方法
 void ORBInitInfoOperations.add_ior_interceptor(IORInterceptor interceptor)
此方法用来将 IOR Interceptor 添加到 IOR Interceptor 列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInterceptor_3_0 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInterceptor_3_0
的使用

使用 IORInterceptor_3_0 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInterceptor_3_0 的使用

声明为 IORInterceptor_3_0 的 org.omg.PortableInterceptor 中的字段
 IORInterceptor_3_0 IORInterceptor_3_0Holder.value

返回 IORInterceptor_3_0 的 org.omg.PortableInterceptor 中的方法
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.extract(Any a)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.narrow(Object obj)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.read(InputStream istream)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.unchecked_narrow(Object obj)

参数类型为 IORInterceptor_3_0 的 org.omg.PortableInterceptor 中的方法
static void | IORInterceptor_3_0Helper.insert(Any a, IORInterceptor_3_0 that)
static void | IORInterceptor_3_0Helper.write(OutputStream ostream, IORInterceptor_3_0 value)

参数类型为 IORInterceptor_3_0 的 org.omg.PortableInterceptor 中的构造方法
IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper
的使用

没有 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder
的使用

没有 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations
的使用

使用 IORInterceptor_3_0Operations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInterceptor_3_0Operations 的使用

org.omg.PortableInterceptor 中 IORInterceptor_3_0Operations 的子接口
 interface IORInterceptor_3_0
org/omg/PortableInterceptor/IORInterceptor_3_0.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInterceptorOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInterceptorOperations
的使用

使用 IORInterceptorOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInterceptorOperations 的使用

org.omg.PortableInterceptor 中 IORInterceptorOperations 的子接口
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | IORInterceptor_3_0Operations org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.LOCATION_FORWARD 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.LOCATION_FORWARD
的使用

没有 org.omg.PortableInterceptor.LOCATION_FORWARD 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.NON_EXISTENT 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.NON_EXISTENT
的使用

没有 org.omg.PortableInterceptor.NON_EXISTENT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectIdHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectIdHelper
的使用

没有 org.omg.PortableInterceptor.ObjectIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ObjectReferenceFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ObjectReferenceFactory
的使用

使用 ObjectReferenceFactory 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ObjectReferenceFactory 的使用

org.omg.PortableInterceptor 中 ObjectReferenceFactory 的子接口
 interface ObjectReferenceTemplate
对象引用模板。

声明为 ObjectReferenceFactory 的 org.omg.PortableInterceptor 中的字段
 ObjectReferenceFactory ObjectReferenceFactoryHolder.value

返回 ObjectReferenceFactory 的 org.omg.PortableInterceptor 中的方法
ObjectReferenceFactory | IORInfoOperations.current_factory() 读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。
static ObjectReferenceFactory | ObjectReferenceFactoryHelper.extract(Any a)
static ObjectReferenceFactory | ObjectReferenceFactoryHelper.read(InputStream istream)

参数类型为 ObjectReferenceFactory 的 org.omg.PortableInterceptor 中的方法
void | IORInfoOperations.current_factory(ObjectReferenceFactory newCurrent_factory) 读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。
static void | ObjectReferenceFactoryHelper.insert(Any a, ObjectReferenceFactory that)
static void | ObjectReferenceFactoryHelper.write(OutputStream ostream, ObjectReferenceFactory value)

参数类型为 ObjectReferenceFactory 的 org.omg.PortableInterceptor 中的构造方法
ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ObjectReferenceTemplate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ObjectReferenceTemplate
的使用

使用 ObjectReferenceTemplate 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ObjectReferenceTemplate 的使用

声明为 ObjectReferenceTemplate 的 org.omg.PortableInterceptor 中的字段
ObjectReferenceTemplate | ObjectReferenceTemplateHolder.value
ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHolder.value

返回 ObjectReferenceTemplate 的 org.omg.PortableInterceptor 中的方法
ObjectReferenceTemplate | IORInfoOperations.adapter_template() 返回刚创建并在 IOR interceptor 上运行的对象适配器的对象引用模板。
static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.extract(Any a)
static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.extract(Any a)
static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.read(InputStream istream)
static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.read(InputStream istream)

参数类型为 ObjectReferenceTemplate 的 org.omg.PortableInterceptor 中的方法
void | IORInterceptor_3_0Operations.adapter_state_changed(ObjectReferenceTemplate[] templates, short state) 只要对象适配器的状态发生更改，并且该状态更改不是由适配器管理器引起的，便调用此方法。
static void | ObjectReferenceTemplateHelper.insert(Any a, ObjectReferenceTemplate that)
static void | ObjectReferenceTemplateSeqHelper.insert(Any a, ObjectReferenceTemplate[] that)
static void | ObjectReferenceTemplateHelper.write(OutputStream ostream, ObjectReferenceTemplate value)
static void | ObjectReferenceTemplateSeqHelper.write(OutputStream ostream, ObjectReferenceTemplate[] value)

参数类型为 ObjectReferenceTemplate 的 org.omg.PortableInterceptor 中的构造方法
ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)
ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBIdHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBIdHelper
的使用

没有 org.omg.PortableInterceptor.ORBIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ORBInitializer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ORBInitializer
的使用

没有 org.omg.PortableInterceptor.ORBInitializer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ORBInitializerOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ORBInitializerOperations
的使用

使用 ORBInitializerOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ORBInitializerOperations 的使用

org.omg.PortableInterceptor 中 ORBInitializerOperations 的子接口
 interface ORBInitializer
便于注册 interceptor 和初始化 ORB。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ORBInitInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ORBInitInfo
的使用

使用 ORBInitInfo 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ORBInitInfo 的使用

参数类型为 ORBInitInfo 的 org.omg.PortableInterceptor 中的方法
void | ORBInitializerOperations.post_init(ORBInitInfo info) 初始化 ORB 期间调用此方法。
void | ORBInitializerOperations.pre_init(ORBInitInfo info) 初始化 ORB 期间调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ORBInitInfoOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ORBInitInfoOperations
的使用

使用 ORBInitInfoOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ORBInitInfoOperations 的使用

org.omg.PortableInterceptor 中 ORBInitInfoOperations 的子接口
 interface ORBInitInfo
传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.PolicyFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.PolicyFactory
的使用

使用 PolicyFactory 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 PolicyFactory 的使用

参数类型为 PolicyFactory 的 org.omg.PortableInterceptor 中的方法
 void ORBInitInfoOperations.register_policy_factory(int type, PolicyFactory policy_factory)
注册给定 PolicyType 的 PolicyFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.PolicyFactoryOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.PolicyFactoryOperations
的使用

使用 PolicyFactoryOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 PolicyFactoryOperations 的使用

org.omg.PortableInterceptor 中 PolicyFactoryOperations 的子接口
 interface PolicyFactory
使得策略类型能够使用 CORBA.ORB.create_policy 来构建。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.RequestInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.RequestInfo
的使用

使用 RequestInfo 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 RequestInfo 的使用

org.omg.PortableInterceptor 中 RequestInfo 的子接口
interface | ClientRequestInfo 客户端请求 interceptor 可访问的请求信息。
interface | ServerRequestInfo 服务器端请求 interceptor 可访问的请求信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.RequestInfoOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.RequestInfoOperations
的使用

使用 RequestInfoOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 RequestInfoOperations 的使用

org.omg.PortableInterceptor 中 RequestInfoOperations 的子接口
interface | ClientRequestInfo 客户端请求 interceptor 可访问的请求信息。
interface | ClientRequestInfoOperations 客户端请求 interceptor 可访问的请求信息。
interface | RequestInfo Interceptor 可访问的请求信息。
interface | ServerRequestInfo 服务器端请求 interceptor 可访问的请求信息。
interface | ServerRequestInfoOperations 服务器端请求 interceptor 可访问的请求信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ServerIdHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ServerIdHelper
的使用

没有 org.omg.PortableInterceptor.ServerIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ServerRequestInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ServerRequestInfo
的使用

使用 ServerRequestInfo 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ServerRequestInfo 的使用

参数类型为 ServerRequestInfo 的 org.omg.PortableInterceptor 中的方法
void | ServerRequestInterceptorOperations.receive_request_service_contexts(ServerRequestInfo ri) 允许 interceptor 处理服务上下文信息。
void | ServerRequestInterceptorOperations.receive_request(ServerRequestInfo ri) 允许 Interceptor 在所有信息（包括操作参数）可用后查询信息。
void | ServerRequestInterceptorOperations.send_exception(ServerRequestInfo ri) 允许 Interceptor 在向客户端抛出异常前查询异常信息并修改应答服务上下文。
void | ServerRequestInterceptorOperations.send_other(ServerRequestInfo ri) 允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
void | ServerRequestInterceptorOperations.send_reply(ServerRequestInfo ri) 允许 Interceptor 在已调用目标操作后、向客户端返回应答前查询应答信息并修改应答服务上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ServerRequestInfoOperations
的使用

使用 ServerRequestInfoOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ServerRequestInfoOperations 的使用

org.omg.PortableInterceptor 中 ServerRequestInfoOperations 的子接口
 interface ServerRequestInfo
服务器端请求 interceptor 可访问的请求信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ServerRequestInterceptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ServerRequestInterceptor
的使用

使用 ServerRequestInterceptor 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ServerRequestInterceptor 的使用

参数类型为 ServerRequestInterceptor 的 org.omg.PortableInterceptor 中的方法
 void ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor interceptor)
此方法用来将服务器端的请求 Interceptor 添加到服务器端请求 Interceptor 列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations
的使用

使用 ServerRequestInterceptorOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ServerRequestInterceptorOperations 的使用

org.omg.PortableInterceptor 中 ServerRequestInterceptorOperations 的子接口
 interface ServerRequestInterceptor
服务器端的请求 interceptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.SUCCESSFUL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.SUCCESSFUL
的使用

没有 org.omg.PortableInterceptor.SUCCESSFUL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.SYSTEM_EXCEPTION 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.SYSTEM_EXCEPTION
的使用

没有 org.omg.PortableInterceptor.SYSTEM_EXCEPTION 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.TRANSPORT_RETRY 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.TRANSPORT_RETRY
的使用

没有 org.omg.PortableInterceptor.TRANSPORT_RETRY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.UNKNOWN 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.UNKNOWN
的使用

没有 org.omg.PortableInterceptor.UNKNOWN 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.USER_EXCEPTION 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.USER_EXCEPTION
的使用

没有 org.omg.PortableInterceptor.USER_EXCEPTION 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.PortableInterceptor.ORBInitInfoPackage (Java 2 Platform SE 6)

 org.omg.PortableInterceptor.ORBInitInfoPackage
类
DuplicateNameHelper
InvalidNameHelper
ObjectIdHelper
异常
DuplicateName
InvalidName


类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
的使用

使用 DuplicateName 的软件包
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。

org.omg.PortableInterceptor 中 DuplicateName 的使用

抛出 DuplicateName 的 org.omg.PortableInterceptor 中的方法
void | ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor interceptor) 此方法用来将客户端的请求 Interceptor 添加到客户端请求 Interceptor 列表。
void | ORBInitInfoOperations.add_ior_interceptor(IORInterceptor interceptor) 此方法用来将 IOR Interceptor 添加到 IOR Interceptor 列表。
void | ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor interceptor) 此方法用来将服务器端的请求 Interceptor 添加到服务器端请求 Interceptor 列表。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 DuplicateName 的使用

返回 DuplicateName 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static DuplicateName | DuplicateNameHelper.extract(Any a)
static DuplicateName | DuplicateNameHelper.read(InputStream istream)

参数类型为 DuplicateName 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static void | DuplicateNameHelper.insert(Any a, DuplicateName that)
static void | DuplicateNameHelper.write(OutputStream ostream, DuplicateName value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
的使用

没有 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
的使用

使用 InvalidName 的软件包
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。

org.omg.PortableInterceptor 中 InvalidName 的使用

抛出 InvalidName 的 org.omg.PortableInterceptor 中的方法
void | ORBInitInfoOperations.register_initial_reference(String id, Object obj) 等同于 ORB.register_initial_reference。
Object | ORBInitInfoOperations.resolve_initial_references(String id) 等同于 ORB.resolve_initial_references。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 InvalidName 的使用

返回 InvalidName 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static InvalidName | InvalidNameHelper.extract(Any a)
static InvalidName | InvalidNameHelper.read(InputStream istream)

参数类型为 InvalidName 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static void | InvalidNameHelper.insert(Any a, InvalidName that)
static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
的使用

没有 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
的使用

没有 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.PortableServer (Java 2 Platform SE 6)

 org.omg.PortableServer
接口
AdapterActivator
AdapterActivatorOperations
Current
CurrentOperations
ID_ASSIGNMENT_POLICY_ID
ID_UNIQUENESS_POLICY_ID
IdAssignmentPolicy
IdAssignmentPolicyOperations
IdUniquenessPolicy
IdUniquenessPolicyOperations
IMPLICIT_ACTIVATION_POLICY_ID
ImplicitActivationPolicy
ImplicitActivationPolicyOperations
LIFESPAN_POLICY_ID
LifespanPolicy
LifespanPolicyOperations
POA
POAManager
POAManagerOperations
POAOperations
REQUEST_PROCESSING_POLICY_ID
RequestProcessingPolicy
RequestProcessingPolicyOperations
SERVANT_RETENTION_POLICY_ID
ServantActivator
ServantActivatorOperations
ServantLocator
ServantLocatorOperations
ServantManager
ServantManagerOperations
ServantRetentionPolicy
ServantRetentionPolicyOperations
THREAD_POLICY_ID
ThreadPolicy
ThreadPolicyOperations
类
_ServantActivatorStub
_ServantLocatorStub
CurrentHelper
DynamicImplementation
ForwardRequestHelper
IdAssignmentPolicyValue
IdUniquenessPolicyValue
ImplicitActivationPolicyValue
LifespanPolicyValue
POAHelper
RequestProcessingPolicyValue
Servant
ServantActivatorHelper
ServantActivatorPOA
ServantLocatorHelper
ServantLocatorPOA
ServantRetentionPolicyValue
ThreadPolicyValue
异常
ForwardRequest


类 org.omg.PortableServer._ServantActivatorStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer._ServantActivatorStub
的使用

没有 org.omg.PortableServer._ServantActivatorStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer._ServantLocatorStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer._ServantLocatorStub
的使用

没有 org.omg.PortableServer._ServantLocatorStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.AdapterActivator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.AdapterActivator
的使用

使用 AdapterActivator 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 AdapterActivator 的使用

返回 AdapterActivator 的 org.omg.PortableServer 中的方法
 AdapterActivator POAOperations.the_activator()
此属性标识与 POA 关联的适配器激活器。

参数类型为 AdapterActivator 的 org.omg.PortableServer 中的方法
 void POAOperations.the_activator(AdapterActivator newThe_activator)
此属性标识与 POA 关联的适配器激活器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.AdapterActivatorOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.AdapterActivatorOperations
的使用

使用 AdapterActivatorOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 AdapterActivatorOperations 的使用

org.omg.PortableServer 中 AdapterActivatorOperations 的子接口
 interface AdapterActivator
一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.Current 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.Current
的使用

使用 Current 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 Current 的使用

返回 Current 的 org.omg.PortableServer 中的方法
static Current | CurrentHelper.extract(Any a)
static Current | CurrentHelper.narrow(Object obj)
static Current | CurrentHelper.read(InputStream istream)

参数类型为 Current 的 org.omg.PortableServer 中的方法
static void | CurrentHelper.insert(Any a, Current that)
static void | CurrentHelper.write(OutputStream ostream, Current value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.CurrentHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.CurrentHelper
的使用

没有 org.omg.PortableServer.CurrentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.CurrentOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.CurrentOperations
的使用

使用 CurrentOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 CurrentOperations 的使用

org.omg.PortableServer 中 CurrentOperations 的子接口
 interface Current
从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.DynamicImplementation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.DynamicImplementation
的使用

没有 org.omg.PortableServer.DynamicImplementation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.ForwardRequest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ForwardRequest
的使用

使用 ForwardRequest 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ForwardRequest 的使用

返回 ForwardRequest 的 org.omg.PortableServer 中的方法
static ForwardRequest | ForwardRequestHelper.extract(Any a)
static ForwardRequest | ForwardRequestHelper.read(InputStream istream)

参数类型为 ForwardRequest 的 org.omg.PortableServer 中的方法
static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)

抛出 ForwardRequest 的 org.omg.PortableServer 中的方法
Servant | ServantActivatorOperations.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到针对当前未激活对象的请求，它就会调用此操作。
Servant | _ServantActivatorStub.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到对当前未激活对象的请求，它就会调用此操作。
Servant | ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。
Servant | _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.ForwardRequestHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ForwardRequestHelper
的使用

没有 org.omg.PortableServer.ForwardRequestHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
的使用

没有 org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
的使用

没有 org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.IdAssignmentPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.IdAssignmentPolicy
的使用

使用 IdAssignmentPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdAssignmentPolicy 的使用

返回 IdAssignmentPolicy 的 org.omg.PortableServer 中的方法
 IdAssignmentPolicy POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.IdAssignmentPolicyOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.IdAssignmentPolicyOperations
的使用

使用 IdAssignmentPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdAssignmentPolicyOperations 的使用

org.omg.PortableServer 中 IdAssignmentPolicyOperations 的子接口
 interface IdAssignmentPolicy
IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.IdAssignmentPolicyValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.IdAssignmentPolicyValue
的使用

使用 IdAssignmentPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdAssignmentPolicyValue 的使用

声明为 IdAssignmentPolicyValue 的 org.omg.PortableServer 中的字段
static IdAssignmentPolicyValue | IdAssignmentPolicyValue.SYSTEM_ID
static IdAssignmentPolicyValue | IdAssignmentPolicyValue.USER_ID

返回 IdAssignmentPolicyValue 的 org.omg.PortableServer 中的方法
static IdAssignmentPolicyValue | IdAssignmentPolicyValue.from_int(int value)
IdAssignmentPolicyValue | IdAssignmentPolicyOperations.value() 指定策略值。

参数类型为 IdAssignmentPolicyValue 的 org.omg.PortableServer 中的方法
 IdAssignmentPolicy POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.IdUniquenessPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.IdUniquenessPolicy
的使用

使用 IdUniquenessPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdUniquenessPolicy 的使用

返回 IdUniquenessPolicy 的 org.omg.PortableServer 中的方法
 IdUniquenessPolicy POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.IdUniquenessPolicyOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.IdUniquenessPolicyOperations
的使用

使用 IdUniquenessPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdUniquenessPolicyOperations 的使用

org.omg.PortableServer 中 IdUniquenessPolicyOperations 的子接口
 interface IdUniquenessPolicy
IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.IdUniquenessPolicyValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.IdUniquenessPolicyValue
的使用

使用 IdUniquenessPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdUniquenessPolicyValue 的使用

声明为 IdUniquenessPolicyValue 的 org.omg.PortableServer 中的字段
static IdUniquenessPolicyValue | IdUniquenessPolicyValue.MULTIPLE_ID
static IdUniquenessPolicyValue | IdUniquenessPolicyValue.UNIQUE_ID

返回 IdUniquenessPolicyValue 的 org.omg.PortableServer 中的方法
static IdUniquenessPolicyValue | IdUniquenessPolicyValue.from_int(int value)
IdUniquenessPolicyValue | IdUniquenessPolicyOperations.value() 指定策略值

参数类型为 IdUniquenessPolicyValue 的 org.omg.PortableServer 中的方法
 IdUniquenessPolicy POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
的使用

没有 org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ImplicitActivationPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ImplicitActivationPolicy
的使用

使用 ImplicitActivationPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ImplicitActivationPolicy 的使用

返回 ImplicitActivationPolicy 的 org.omg.PortableServer 中的方法
 ImplicitActivationPolicy POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ImplicitActivationPolicyOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ImplicitActivationPolicyOperations
的使用

使用 ImplicitActivationPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ImplicitActivationPolicyOperations 的使用

org.omg.PortableServer 中 ImplicitActivationPolicyOperations 的子接口
 interface ImplicitActivationPolicy
此策略指定已创建的 POA 中是否支持隐式激活 servant。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.ImplicitActivationPolicyValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ImplicitActivationPolicyValue
的使用

使用 ImplicitActivationPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ImplicitActivationPolicyValue 的使用

声明为 ImplicitActivationPolicyValue 的 org.omg.PortableServer 中的字段
static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.IMPLICIT_ACTIVATION
static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.NO_IMPLICIT_ACTIVATION

返回 ImplicitActivationPolicyValue 的 org.omg.PortableServer 中的方法
static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.from_int(int value)
ImplicitActivationPolicyValue | ImplicitActivationPolicyOperations.value() 指定策略值

参数类型为 ImplicitActivationPolicyValue 的 org.omg.PortableServer 中的方法
 ImplicitActivationPolicy POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.LIFESPAN_POLICY_ID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.LIFESPAN_POLICY_ID
的使用

没有 org.omg.PortableServer.LIFESPAN_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.LifespanPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.LifespanPolicy
的使用

使用 LifespanPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 LifespanPolicy 的使用

返回 LifespanPolicy 的 org.omg.PortableServer 中的方法
 LifespanPolicy POAOperations.create_lifespan_policy(LifespanPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.LifespanPolicyOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.LifespanPolicyOperations
的使用

使用 LifespanPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 LifespanPolicyOperations 的使用

org.omg.PortableServer 中 LifespanPolicyOperations 的子接口
 interface LifespanPolicy
LifespanPolicy 指定已创建 POA 中实现的对象的生存期。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.LifespanPolicyValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.LifespanPolicyValue
的使用

使用 LifespanPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 LifespanPolicyValue 的使用

声明为 LifespanPolicyValue 的 org.omg.PortableServer 中的字段
static LifespanPolicyValue | LifespanPolicyValue.PERSISTENT
static LifespanPolicyValue | LifespanPolicyValue.TRANSIENT

返回 LifespanPolicyValue 的 org.omg.PortableServer 中的方法
static LifespanPolicyValue | LifespanPolicyValue.from_int(int value)
LifespanPolicyValue | LifespanPolicyOperations.value() 指定策略值

参数类型为 LifespanPolicyValue 的 org.omg.PortableServer 中的方法
 LifespanPolicy POAOperations.create_lifespan_policy(LifespanPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.POA 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.POA
的使用

使用 POA 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.portable | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CosNaming 中 POA 的使用

参数类型为 POA 的 org.omg.CosNaming 中的方法
String[] | BindingIteratorPOA._all_interfaces(POA poa, byte[] objectId)
String[] | NamingContextExtPOA._all_interfaces(POA poa, byte[] objectId)
String[] | NamingContextPOA._all_interfaces(POA poa, byte[] objectId)

org.omg.PortableServer 中 POA 的使用

返回 POA 的 org.omg.PortableServer 中的方法
 POA Servant._default_POA()
从与 servant 关联的 ORB 实例返回根 POA。
 POA Servant._poa()
允许便捷地执行共用方法，等效于 PortableServer::Current:get_POA。
 POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。
static POA POAHelper.extract(Any a)
 POA POAOperations.find_POA(String adapter_name, boolean activate_it)
如果目标 POA 是具有指定名称的子 POA（相对于目标 POA）的父 POA，则返回该子 POA。
 POA CurrentOperations.get_POA()
返回对 POA 的引用，该 POA 实现此方法在其上下文中调用的对象。
static POA POAHelper.narrow(Object obj)
static POA POAHelper.read(InputStream istream)
 POA[] POAOperations.the_children()
此属性标识 POA 的所有子 POA 的当前设置。
 POA POAOperations.the_parent()
此属性标识 POA 的父 POA。

参数类型为 POA 的 org.omg.PortableServer 中的方法
abstract String[] | Servant._all_interfaces(POA poa, byte[] objectId) ORB 使用此操作从 servant 获取完整的类型信息。
String[] | ServantActivatorPOA._all_interfaces(POA poa, byte[] objectId)
String[] | ServantLocatorPOA._all_interfaces(POA poa, byte[] objectId)
void | ServantActivatorOperations.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要取消激活对象的 servant 就会调用此操作。
void | _ServantActivatorStub.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要停用对象的 servant 就会调用此操作。
Servant | ServantActivatorOperations.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到针对当前未激活对象的请求，它就会调用此操作。
Servant | _ServantActivatorStub.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到对当前未激活对象的请求，它就会调用此操作。
static void | POAHelper.insert(Any a, POA that)
void | ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) servant 完成请求时都将调用此操作。
void | _ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) servant 完成请求时都将调用此操作。
Servant | ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。
Servant | _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。
boolean | AdapterActivatorOperations.unknown_adapter(POA parent, String name) 在 ORB 接收对象引用的请求时，如果该对象引用定义不存在的目标 POA，则将调用此操作。
static void | POAHelper.write(OutputStream ostream, POA value)

org.omg.PortableServer.portable 中 POA 的使用

返回 POA 的 org.omg.PortableServer.portable 中的方法
 POA Delegate.default_POA(Servant Self)
此方法的默认行为是从关联 servant 的 ORB 实例返回根 POA。
 POA Delegate.poa(Servant Self)
method _poa() 等效于调用 PortableServer::Current:get_POA。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAHelper
的使用

没有 org.omg.PortableServer.POAHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.POAManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.POAManager
的使用

使用 POAManager 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 POAManager 的使用

返回 POAManager 的 org.omg.PortableServer 中的方法
 POAManager POAOperations.the_POAManager()
此属性标识与 POA 关联的 POA 管理器。

参数类型为 POAManager 的 org.omg.PortableServer 中的方法
 POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.POAManagerOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.POAManagerOperations
的使用

使用 POAManagerOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 POAManagerOperations 的使用

org.omg.PortableServer 中 POAManagerOperations 的子接口
 interface POAManager
每个 POA 对象都有一个关联的 POAManager 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.POAOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.POAOperations
的使用

使用 POAOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 POAOperations 的使用

org.omg.PortableServer 中 POAOperations 的子接口
 interface POA
POA 对象管理对象集合的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
的使用

没有 org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.RequestProcessingPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.RequestProcessingPolicy
的使用

使用 RequestProcessingPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 RequestProcessingPolicy 的使用

返回 RequestProcessingPolicy 的 org.omg.PortableServer 中的方法
 RequestProcessingPolicy POAOperations.create_request_processing_policy(RequestProcessingPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.RequestProcessingPolicyOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.RequestProcessingPolicyOperations
的使用

使用 RequestProcessingPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 RequestProcessingPolicyOperations 的使用

org.omg.PortableServer 中 RequestProcessingPolicyOperations 的子接口
 interface RequestProcessingPolicy
此策略指定已创建的 POA 处理请求的方式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.RequestProcessingPolicyValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.RequestProcessingPolicyValue
的使用

使用 RequestProcessingPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 RequestProcessingPolicyValue 的使用

声明为 RequestProcessingPolicyValue 的 org.omg.PortableServer 中的字段
static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_ACTIVE_OBJECT_MAP_ONLY
static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_DEFAULT_SERVANT
static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_SERVANT_MANAGER

返回 RequestProcessingPolicyValue 的 org.omg.PortableServer 中的方法
static RequestProcessingPolicyValue | RequestProcessingPolicyValue.from_int(int value)
RequestProcessingPolicyValue | RequestProcessingPolicyOperations.value() 指定策略值

参数类型为 RequestProcessingPolicyValue 的 org.omg.PortableServer 中的方法
 RequestProcessingPolicy POAOperations.create_request_processing_policy(RequestProcessingPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.Servant 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.Servant
的使用

使用 Servant 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.portable | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CosNaming 中 Servant 的使用

org.omg.CosNaming 中 Servant 的子类
class | BindingIteratorPOA BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
class | NamingContextExtPOA NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | NamingContextPOA 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.PortableServer 中 Servant 的使用

org.omg.PortableServer 中 Servant 的子类
class | DynamicImplementation 允许动态处理对象调用。
class | ServantActivatorPOA POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
class | ServantLocatorPOA POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

返回 Servant 的 org.omg.PortableServer 中的方法
Servant | POAOperations.get_servant() 此操作返回与 POA 关联的默认 servant。
Servant | POAOperations.id_to_servant(byte[] oid) 如果 POA 具有 RETAIN 策略并且指定的 ObjectId 存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
Servant | ServantActivatorOperations.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到针对当前未激活对象的请求，它就会调用此操作。
Servant | _ServantActivatorStub.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到对当前未激活对象的请求，它就会调用此操作。
Servant | ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。
Servant | _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。
Servant | POAOperations.reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。

参数类型为 Servant 的 org.omg.PortableServer 中的方法
void | POAOperations.activate_object_with_id(byte[] id, Servant p_servant) 此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。
byte[] | POAOperations.activate_object(Servant p_servant) 此操作生成一个 Object Id，并将该 Object Id 和指定的 servant 输入 Active Object Map。
void | ServantActivatorOperations.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要取消激活对象的 servant 就会调用此操作。
void | _ServantActivatorStub.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要停用对象的 servant 就会调用此操作。
void | ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) servant 完成请求时都将调用此操作。
void | _ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) servant 完成请求时都将调用此操作。
byte[] | POAOperations.servant_to_id(Servant p_servant) 此操作有四种可能的行为。
Object | POAOperations.servant_to_reference(Servant p_servant) 如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。
void | POAOperations.set_servant(Servant p_servant) 此操作在 POA 中将指定的 servant 注册为默认 servant。

org.omg.PortableServer.portable 中 Servant 的使用

参数类型为 Servant 的 org.omg.PortableServer.portable 中的方法
 POA Delegate.default_POA(Servant Self)
此方法的默认行为是从关联 servant 的 ORB 实例返回根 POA。
 Object Delegate.get_interface_def(Servant self)
此操作返回接口 Repository 中的一个对象，该对象提供可能对编程有用的类型信息。
 boolean Delegate.is_a(Servant Self, String Repository_Id)
此方法查看指定的 repid 是否存在于 _all_interfaces() 返回的列表上，或者该 repid 是否是通用 CORBA 对象的存储库 id。
 boolean Delegate.non_existent(Servant Self)
此操作用来检查 Object 是否存在。
 byte[] Delegate.object_id(Servant Self)
方法 _object_id() 等效于调用 PortableServer::Current::get_object_id。
 ORB Delegate.orb(Servant Self)
返回当前关联 Servant 的 ORB 实例的便捷方法。
 POA Delegate.poa(Servant Self)
method _poa() 等效于调用 PortableServer::Current:get_POA。
 Object Delegate.this_object(Servant Self)
此方法允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
的使用

没有 org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantActivator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantActivator
的使用

使用 ServantActivator 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantActivator 的使用

实现 ServantActivator 的 org.omg.PortableServer 中的类
 class _ServantActivatorStub
当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。

返回 ServantActivator 的 org.omg.PortableServer 中的方法
ServantActivator | ServantActivatorPOA._this()
ServantActivator | ServantActivatorPOA._this(ORB orb)
static ServantActivator | ServantActivatorHelper.extract(Any a)
static ServantActivator | ServantActivatorHelper.narrow(Object obj)
static ServantActivator | ServantActivatorHelper.read(InputStream istream)
static ServantActivator | ServantActivatorHelper.unchecked_narrow(Object obj)

参数类型为 ServantActivator 的 org.omg.PortableServer 中的方法
static void | ServantActivatorHelper.insert(Any a, ServantActivator that)
static void | ServantActivatorHelper.write(OutputStream ostream, ServantActivator value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantActivatorHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantActivatorHelper
的使用

没有 org.omg.PortableServer.ServantActivatorHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantActivatorOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantActivatorOperations
的使用

使用 ServantActivatorOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantActivatorOperations 的使用

org.omg.PortableServer 中 ServantActivatorOperations 的子接口
 interface ServantActivator
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

实现 ServantActivatorOperations 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | ServantActivatorPOA POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantActivatorPOA 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantActivatorPOA
的使用

没有 org.omg.PortableServer.ServantActivatorPOA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantLocator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantLocator
的使用

使用 ServantLocator 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantLocator 的使用

实现 ServantLocator 的 org.omg.PortableServer 中的类
 class _ServantLocatorStub
POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。

返回 ServantLocator 的 org.omg.PortableServer 中的方法
ServantLocator | ServantLocatorPOA._this()
ServantLocator | ServantLocatorPOA._this(ORB orb)
static ServantLocator | ServantLocatorHelper.extract(Any a)
static ServantLocator | ServantLocatorHelper.narrow(Object obj)
static ServantLocator | ServantLocatorHelper.read(InputStream istream)
static ServantLocator | ServantLocatorHelper.unchecked_narrow(Object obj)

参数类型为 ServantLocator 的 org.omg.PortableServer 中的方法
static void | ServantLocatorHelper.insert(Any a, ServantLocator that)
static void | ServantLocatorHelper.write(OutputStream ostream, ServantLocator value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantLocatorHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantLocatorHelper
的使用

没有 org.omg.PortableServer.ServantLocatorHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantLocatorOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantLocatorOperations
的使用

使用 ServantLocatorOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantLocatorOperations 的使用

org.omg.PortableServer 中 ServantLocatorOperations 的子接口
 interface ServantLocator
当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。

实现 ServantLocatorOperations 的 org.omg.PortableServer 中的类
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
class | ServantLocatorPOA POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantLocatorPOA 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantLocatorPOA
的使用

没有 org.omg.PortableServer.ServantLocatorPOA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantManager
的使用

使用 ServantManager 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantManager 的使用

org.omg.PortableServer 中 ServantManager 的子接口
interface | ServantActivator POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantLocator 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。

实现 ServantManager 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。

返回 ServantManager 的 org.omg.PortableServer 中的方法
 ServantManager POAOperations.get_servant_manager()
如果 POA 的 ServantRetentionPolicy 为 RETAIN，则 ServantManager 参数 (imgr) 应该支持 ServantActivator 接口。

参数类型为 ServantManager 的 org.omg.PortableServer 中的方法
 void POAOperations.set_servant_manager(ServantManager imgr)
此操作设置与 POA 关联的默认 servant 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantManagerOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantManagerOperations
的使用

使用 ServantManagerOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantManagerOperations 的使用

org.omg.PortableServer 中 ServantManagerOperations 的子接口
interface | ServantActivator POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantActivatorOperations POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantLocator 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
interface | ServantLocatorOperations 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
interface | ServantManager servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。

实现 ServantManagerOperations 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
class | ServantActivatorPOA POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
class | ServantLocatorPOA POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantRetentionPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantRetentionPolicy
的使用

使用 ServantRetentionPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantRetentionPolicy 的使用

返回 ServantRetentionPolicy 的 org.omg.PortableServer 中的方法
 ServantRetentionPolicy POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantRetentionPolicyOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantRetentionPolicyOperations
的使用

使用 ServantRetentionPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantRetentionPolicyOperations 的使用

org.omg.PortableServer 中 ServantRetentionPolicyOperations 的子接口
 interface ServantRetentionPolicy
此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantRetentionPolicyValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantRetentionPolicyValue
的使用

使用 ServantRetentionPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantRetentionPolicyValue 的使用

声明为 ServantRetentionPolicyValue 的 org.omg.PortableServer 中的字段
static ServantRetentionPolicyValue | ServantRetentionPolicyValue.NON_RETAIN
static ServantRetentionPolicyValue | ServantRetentionPolicyValue.RETAIN

返回 ServantRetentionPolicyValue 的 org.omg.PortableServer 中的方法
static ServantRetentionPolicyValue | ServantRetentionPolicyValue.from_int(int value)
ServantRetentionPolicyValue | ServantRetentionPolicyOperations.value() 指示策略值

参数类型为 ServantRetentionPolicyValue 的 org.omg.PortableServer 中的方法
 ServantRetentionPolicy POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.THREAD_POLICY_ID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.THREAD_POLICY_ID
的使用

没有 org.omg.PortableServer.THREAD_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ThreadPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ThreadPolicy
的使用

使用 ThreadPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ThreadPolicy 的使用

返回 ThreadPolicy 的 org.omg.PortableServer 中的方法
 ThreadPolicy POAOperations.create_thread_policy(ThreadPolicyValue value)
每个这种操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.PortableServer.ThreadPolicyOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ThreadPolicyOperations
的使用

使用 ThreadPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ThreadPolicyOperations 的使用

org.omg.PortableServer 中 ThreadPolicyOperations 的子接口
 interface ThreadPolicy
ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.ThreadPolicyValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ThreadPolicyValue
的使用

使用 ThreadPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ThreadPolicyValue 的使用

声明为 ThreadPolicyValue 的 org.omg.PortableServer 中的字段
static ThreadPolicyValue | ThreadPolicyValue.ORB_CTRL_MODEL
static ThreadPolicyValue | ThreadPolicyValue.SINGLE_THREAD_MODEL

返回 ThreadPolicyValue 的 org.omg.PortableServer 中的方法
static ThreadPolicyValue | ThreadPolicyValue.from_int(int value)
ThreadPolicyValue | ThreadPolicyOperations.value() 指定策略值

参数类型为 ThreadPolicyValue 的 org.omg.PortableServer 中的方法
 ThreadPolicy POAOperations.create_thread_policy(ThreadPolicyValue value)
每个这种操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.PortableServer.CurrentPackage (Java 2 Platform SE 6)

 org.omg.PortableServer.CurrentPackage
类
NoContextHelper
异常
NoContext


类 org.omg.PortableServer.CurrentPackage.NoContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.CurrentPackage.NoContext
的使用

使用 NoContext 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。

org.omg.PortableServer 中 NoContext 的使用

抛出 NoContext 的 org.omg.PortableServer 中的方法
byte[] | CurrentOperations.get_object_id() 返回一个 ObjectId，标识此方法在其上下文中调用的对象。
POA | CurrentOperations.get_POA() 返回对 POA 的引用，该 POA 实现此方法在其上下文中调用的对象。

org.omg.PortableServer.CurrentPackage 中 NoContext 的使用

返回 NoContext 的 org.omg.PortableServer.CurrentPackage 中的方法
static NoContext | NoContextHelper.extract(Any a)
static NoContext | NoContextHelper.read(InputStream istream)

参数类型为 NoContext 的 org.omg.PortableServer.CurrentPackage 中的方法
static void | NoContextHelper.insert(Any a, NoContext that)
static void | NoContextHelper.write(OutputStream ostream, NoContext value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.CurrentPackage.NoContextHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.CurrentPackage.NoContextHelper
的使用

没有 org.omg.PortableServer.CurrentPackage.NoContextHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.PortableServer.POAManagerPackage (Java 2 Platform SE 6)

 org.omg.PortableServer.POAManagerPackage
类
AdapterInactiveHelper
State
异常
AdapterInactive


类 org.omg.PortableServer.POAManagerPackage.AdapterInactive 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAManagerPackage.AdapterInactive
的使用

使用 AdapterInactive 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。

org.omg.PortableServer 中 AdapterInactive 的使用

抛出 AdapterInactive 的 org.omg.PortableServer 中的方法
void | POAManagerOperations.activate() 此操作将 POA 管理器更改为激活状态，促使关联的 POA 开始处理请求。
void | POAManagerOperations.deactivate(boolean etherealize_objects, boolean wait_for_completion) 此操作将 POA 管理器的状态更改为非激活 (inactive)，促使关联的 POA 拒绝尚未开始执行的请求以及任何新的请求。
void | POAManagerOperations.discard_requests(boolean wait_for_completion) 此操作将 POA 管理器的状态更改为丢弃 (discarding)。
void | POAManagerOperations.hold_requests(boolean wait_for_completion) 此操作将 POA 管理器更改为保持 (holding) 状态，促使关联的 POA 将传入请求排队。

org.omg.PortableServer.POAManagerPackage 中 AdapterInactive 的使用

返回 AdapterInactive 的 org.omg.PortableServer.POAManagerPackage 中的方法
static AdapterInactive | AdapterInactiveHelper.extract(Any a)
static AdapterInactive | AdapterInactiveHelper.read(InputStream istream)

参数类型为 AdapterInactive 的 org.omg.PortableServer.POAManagerPackage 中的方法
static void | AdapterInactiveHelper.insert(Any a, AdapterInactive that)
static void | AdapterInactiveHelper.write(OutputStream ostream, AdapterInactive value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
的使用

没有 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAManagerPackage.State 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAManagerPackage.State
的使用

使用 State 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。

org.omg.PortableServer 中 State 的使用

返回 State 的 org.omg.PortableServer 中的方法
 State POAManagerOperations.get_state()
此操作返回 POA 管理器的状态。

org.omg.PortableServer.POAManagerPackage 中 State 的使用

声明为 State 的 org.omg.PortableServer.POAManagerPackage 中的字段
static State | State.ACTIVE
static State | State.DISCARDING
static State | State.HOLDING
static State | State.INACTIVE

返回 State 的 org.omg.PortableServer.POAManagerPackage 中的方法
static State State.from_int(int value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.PortableServer.POAPackage (Java 2 Platform SE 6)

 org.omg.PortableServer.POAPackage
类
AdapterAlreadyExistsHelper
AdapterNonExistentHelper
InvalidPolicyHelper
NoServantHelper
ObjectAlreadyActiveHelper
ObjectNotActiveHelper
ServantAlreadyActiveHelper
ServantNotActiveHelper
WrongAdapterHelper
WrongPolicyHelper
异常
AdapterAlreadyExists
AdapterNonExistent
InvalidPolicy
NoServant
ObjectAlreadyActive
ObjectNotActive
ServantAlreadyActive
ServantNotActive
WrongAdapter
WrongPolicy


类 org.omg.PortableServer.POAPackage.AdapterAlreadyExists 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.AdapterAlreadyExists
的使用

使用 AdapterAlreadyExists 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 AdapterAlreadyExists 的使用

抛出 AdapterAlreadyExists 的 org.omg.PortableServer 中的方法
 POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。

org.omg.PortableServer.POAPackage 中 AdapterAlreadyExists 的使用

返回 AdapterAlreadyExists 的 org.omg.PortableServer.POAPackage 中的方法
static AdapterAlreadyExists | AdapterAlreadyExistsHelper.extract(Any a)
static AdapterAlreadyExists | AdapterAlreadyExistsHelper.read(InputStream istream)

参数类型为 AdapterAlreadyExists 的 org.omg.PortableServer.POAPackage 中的方法
static void | AdapterAlreadyExistsHelper.insert(Any a, AdapterAlreadyExists that)
static void | AdapterAlreadyExistsHelper.write(OutputStream ostream, AdapterAlreadyExists value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
的使用

没有 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.AdapterNonExistent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.AdapterNonExistent
的使用

使用 AdapterNonExistent 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 AdapterNonExistent 的使用

抛出 AdapterNonExistent 的 org.omg.PortableServer 中的方法
 POA POAOperations.find_POA(String adapter_name, boolean activate_it)
如果目标 POA 是具有指定名称的子 POA（相对于目标 POA）的父 POA，则返回该子 POA。

org.omg.PortableServer.POAPackage 中 AdapterNonExistent 的使用

返回 AdapterNonExistent 的 org.omg.PortableServer.POAPackage 中的方法
static AdapterNonExistent | AdapterNonExistentHelper.extract(Any a)
static AdapterNonExistent | AdapterNonExistentHelper.read(InputStream istream)

参数类型为 AdapterNonExistent 的 org.omg.PortableServer.POAPackage 中的方法
static void | AdapterNonExistentHelper.insert(Any a, AdapterNonExistent that)
static void | AdapterNonExistentHelper.write(OutputStream ostream, AdapterNonExistent value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
的使用

没有 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.InvalidPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.InvalidPolicy
的使用

使用 InvalidPolicy 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 InvalidPolicy 的使用

抛出 InvalidPolicy 的 org.omg.PortableServer 中的方法
 POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。

org.omg.PortableServer.POAPackage 中 InvalidPolicy 的使用

返回 InvalidPolicy 的 org.omg.PortableServer.POAPackage 中的方法
static InvalidPolicy | InvalidPolicyHelper.extract(Any a)
static InvalidPolicy | InvalidPolicyHelper.read(InputStream istream)

参数类型为 InvalidPolicy 的 org.omg.PortableServer.POAPackage 中的方法
static void | InvalidPolicyHelper.insert(Any a, InvalidPolicy that)
static void | InvalidPolicyHelper.write(OutputStream ostream, InvalidPolicy value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper
的使用

没有 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.NoServant 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.NoServant
的使用

使用 NoServant 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 NoServant 的使用

抛出 NoServant 的 org.omg.PortableServer 中的方法
 Servant POAOperations.get_servant()
此操作返回与 POA 关联的默认 servant。

org.omg.PortableServer.POAPackage 中 NoServant 的使用

返回 NoServant 的 org.omg.PortableServer.POAPackage 中的方法
static NoServant | NoServantHelper.extract(Any a)
static NoServant | NoServantHelper.read(InputStream istream)

参数类型为 NoServant 的 org.omg.PortableServer.POAPackage 中的方法
static void | NoServantHelper.insert(Any a, NoServant that)
static void | NoServantHelper.write(OutputStream ostream, NoServant value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.NoServantHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.NoServantHelper
的使用

没有 org.omg.PortableServer.POAPackage.NoServantHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ObjectAlreadyActive 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ObjectAlreadyActive
的使用

使用 ObjectAlreadyActive 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 ObjectAlreadyActive 的使用

抛出 ObjectAlreadyActive 的 org.omg.PortableServer 中的方法
 void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。

org.omg.PortableServer.POAPackage 中 ObjectAlreadyActive 的使用

返回 ObjectAlreadyActive 的 org.omg.PortableServer.POAPackage 中的方法
static ObjectAlreadyActive | ObjectAlreadyActiveHelper.extract(Any a)
static ObjectAlreadyActive | ObjectAlreadyActiveHelper.read(InputStream istream)

参数类型为 ObjectAlreadyActive 的 org.omg.PortableServer.POAPackage 中的方法
static void | ObjectAlreadyActiveHelper.insert(Any a, ObjectAlreadyActive that)
static void | ObjectAlreadyActiveHelper.write(OutputStream ostream, ObjectAlreadyActive value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
的使用

没有 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ObjectNotActive 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ObjectNotActive
的使用

使用 ObjectNotActive 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 ObjectNotActive 的使用

抛出 ObjectNotActive 的 org.omg.PortableServer 中的方法
void | POAOperations.deactivate_object(byte[] oid) 此操作促使在 oid 参数中指定的 ObjectId 被取消激活。
Object | POAOperations.id_to_reference(byte[] oid) 如果具有指定 Object Id 值的对象当前不是激活状态，则返回一个封装激活该对象时所用信息的引用。
Servant | POAOperations.id_to_servant(byte[] oid) 如果 POA 具有 RETAIN 策略并且指定的 ObjectId 存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
Servant | POAOperations.reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。

org.omg.PortableServer.POAPackage 中 ObjectNotActive 的使用

返回 ObjectNotActive 的 org.omg.PortableServer.POAPackage 中的方法
static ObjectNotActive | ObjectNotActiveHelper.extract(Any a)
static ObjectNotActive | ObjectNotActiveHelper.read(InputStream istream)

参数类型为 ObjectNotActive 的 org.omg.PortableServer.POAPackage 中的方法
static void | ObjectNotActiveHelper.insert(Any a, ObjectNotActive that)
static void | ObjectNotActiveHelper.write(OutputStream ostream, ObjectNotActive value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
的使用

没有 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ServantAlreadyActive 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ServantAlreadyActive
的使用

使用 ServantAlreadyActive 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 ServantAlreadyActive 的使用

抛出 ServantAlreadyActive 的 org.omg.PortableServer 中的方法
void | POAOperations.activate_object_with_id(byte[] id, Servant p_servant) 此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。
byte[] | POAOperations.activate_object(Servant p_servant) 此操作生成一个 Object Id，并将该 Object Id 和指定的 servant 输入 Active Object Map。

org.omg.PortableServer.POAPackage 中 ServantAlreadyActive 的使用

返回 ServantAlreadyActive 的 org.omg.PortableServer.POAPackage 中的方法
static ServantAlreadyActive | ServantAlreadyActiveHelper.extract(Any a)
static ServantAlreadyActive | ServantAlreadyActiveHelper.read(InputStream istream)

参数类型为 ServantAlreadyActive 的 org.omg.PortableServer.POAPackage 中的方法
static void | ServantAlreadyActiveHelper.insert(Any a, ServantAlreadyActive that)
static void | ServantAlreadyActiveHelper.write(OutputStream ostream, ServantAlreadyActive value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
的使用

没有 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ServantNotActive 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ServantNotActive
的使用

使用 ServantNotActive 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 ServantNotActive 的使用

抛出 ServantNotActive 的 org.omg.PortableServer 中的方法
byte[] | POAOperations.servant_to_id(Servant p_servant) 此操作有四种可能的行为。
Object | POAOperations.servant_to_reference(Servant p_servant) 如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。

org.omg.PortableServer.POAPackage 中 ServantNotActive 的使用

返回 ServantNotActive 的 org.omg.PortableServer.POAPackage 中的方法
static ServantNotActive | ServantNotActiveHelper.extract(Any a)
static ServantNotActive | ServantNotActiveHelper.read(InputStream istream)

参数类型为 ServantNotActive 的 org.omg.PortableServer.POAPackage 中的方法
static void | ServantNotActiveHelper.insert(Any a, ServantNotActive that)
static void | ServantNotActiveHelper.write(OutputStream ostream, ServantNotActive value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper
的使用

没有 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.WrongAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.WrongAdapter
的使用

使用 WrongAdapter 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 WrongAdapter 的使用

抛出 WrongAdapter 的 org.omg.PortableServer 中的方法
byte[] | POAOperations.reference_to_id(Object reference) 此操作返回指定引用封装的 Object Id 值。
Servant | POAOperations.reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。

org.omg.PortableServer.POAPackage 中 WrongAdapter 的使用

返回 WrongAdapter 的 org.omg.PortableServer.POAPackage 中的方法
static WrongAdapter | WrongAdapterHelper.extract(Any a)
static WrongAdapter | WrongAdapterHelper.read(InputStream istream)

参数类型为 WrongAdapter 的 org.omg.PortableServer.POAPackage 中的方法
static void | WrongAdapterHelper.insert(Any a, WrongAdapter that)
static void | WrongAdapterHelper.write(OutputStream ostream, WrongAdapter value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.WrongAdapterHelper
的使用

没有 org.omg.PortableServer.POAPackage.WrongAdapterHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.WrongPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.WrongPolicy
的使用

使用 WrongPolicy 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 WrongPolicy 的使用

抛出 WrongPolicy 的 org.omg.PortableServer 中的方法
void | POAOperations.activate_object_with_id(byte[] id, Servant p_servant) 此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。
byte[] | POAOperations.activate_object(Servant p_servant) 此操作生成一个 Object Id，并将该 Object Id 和指定的 servant 输入 Active Object Map。
Object | POAOperations.create_reference(String intf) 此操作创建一个对象引用，该引用封装 POA 生成的 Object Id 值和指定的接口存储库 id。
void | POAOperations.deactivate_object(byte[] oid) 此操作促使在 oid 参数中指定的 ObjectId 被取消激活。
ServantManager | POAOperations.get_servant_manager() 如果 POA 的 ServantRetentionPolicy 为 RETAIN，则 ServantManager 参数 (imgr) 应该支持 ServantActivator 接口。
Servant | POAOperations.get_servant() 此操作返回与 POA 关联的默认 servant。
Object | POAOperations.id_to_reference(byte[] oid) 如果具有指定 Object Id 值的对象当前不是激活状态，则返回一个封装激活该对象时所用信息的引用。
Servant | POAOperations.id_to_servant(byte[] oid) 如果 POA 具有 RETAIN 策略并且指定的 ObjectId 存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
byte[] | POAOperations.reference_to_id(Object reference) 此操作返回指定引用封装的 Object Id 值。
Servant | POAOperations.reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
byte[] | POAOperations.servant_to_id(Servant p_servant) 此操作有四种可能的行为。
Object | POAOperations.servant_to_reference(Servant p_servant) 如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。
void | POAOperations.set_servant_manager(ServantManager imgr) 此操作设置与 POA 关联的默认 servant 管理器。
void | POAOperations.set_servant(Servant p_servant) 此操作在 POA 中将指定的 servant 注册为默认 servant。

org.omg.PortableServer.POAPackage 中 WrongPolicy 的使用

返回 WrongPolicy 的 org.omg.PortableServer.POAPackage 中的方法
static WrongPolicy | WrongPolicyHelper.extract(Any a)
static WrongPolicy | WrongPolicyHelper.read(InputStream istream)

参数类型为 WrongPolicy 的 org.omg.PortableServer.POAPackage 中的方法
static void | WrongPolicyHelper.insert(Any a, WrongPolicy that)
static void | WrongPolicyHelper.write(OutputStream ostream, WrongPolicy value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.WrongPolicyHelper
的使用

没有 org.omg.PortableServer.POAPackage.WrongPolicyHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.PortableServer.portable (Java 2 Platform SE 6)

 org.omg.PortableServer.portable
接口
Delegate


接口 org.omg.PortableServer.portable.Delegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.portable.Delegate
的使用

使用 Delegate 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 Delegate 的使用

返回 Delegate 的 org.omg.PortableServer 中的方法
 Delegate Servant._get_delegate()
获取 PortableServer::Servant 特定于供应商的 ORB 实现。

参数类型为 Delegate 的 org.omg.PortableServer 中的方法
 void Servant._set_delegate(Delegate delegate)
此操作支持 Java ORB 可移植性接口，它向通过代理支持 ORB 可移植性的类提供一个设置其委托的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.PortableServer.ServantLocatorPackage (Java 2 Platform SE 6)

 org.omg.PortableServer.ServantLocatorPackage
类
CookieHolder


类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder
的使用

使用 CookieHolder 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 CookieHolder 的使用

参数类型为 CookieHolder 的 org.omg.PortableServer 中的方法
Servant | ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。
Servant | _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.SendingContext (Java 2 Platform SE 6)

 org.omg.SendingContext
接口
RunTime
RunTimeOperations


接口 org.omg.SendingContext.RunTime 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.SendingContext.RunTime
的使用

使用 RunTime 的软件包
javax.rmi.CORBA 包含用于 RMI-IIOP 的可移植性 API。

javax.rmi.CORBA 中 RunTime 的使用

返回 RunTime 的 javax.rmi.CORBA 中的方法
 RunTime ValueHandler.getRunTimeCodeBase()
返回此 ValueHandler 的 CodeBase。

参数类型为 RunTime 的 javax.rmi.CORBA 中的方法
 Serializable ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
使用 Java 语义从流中读取一个值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.omg.SendingContext.RunTimeOperations 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.SendingContext.RunTimeOperations
的使用

使用 RunTimeOperations 的软件包
org.omg.SendingContext 为值类型的编组提供支持。

org.omg.SendingContext 中 RunTimeOperations 的使用

org.omg.SendingContext 中 RunTimeOperations 的子接口
 interface RunTime
定义表示请求的发送上下文的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.omg.stub.java.rmi (Java 2 Platform SE 6)

 org.omg.stub.java.rmi
类
_Remote_Stub


类 org.omg.stub.java.rmi._Remote_Stub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.stub.java.rmi._Remote_Stub
的使用

没有 org.omg.stub.java.rmi._Remote_Stub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.w3c.dom (Java 2 Platform SE 6)

 org.w3c.dom
接口
Attr
CDATASection
CharacterData
Comment
Document
DocumentFragment
DocumentType
DOMConfiguration
DOMError
DOMErrorHandler
DOMImplementation
DOMImplementationList
DOMImplementationSource
DOMLocator
DOMStringList
Element
Entity
EntityReference
NamedNodeMap
NameList
Node
NodeList
Notation
ProcessingInstruction
Text
TypeInfo
UserDataHandler
异常
DOMException


org.w3c.dom.bootstrap (Java 2 Platform SE 6)

 org.w3c.dom.bootstrap
类
DOMImplementationRegistry


类 org.w3c.dom.bootstrap.DOMImplementationRegistry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.w3c.dom.bootstrap.DOMImplementationRegistry
的使用

使用 DOMImplementationRegistry 的软件包
org.w3c.dom.bootstrap

org.w3c.dom.bootstrap 中 DOMImplementationRegistry 的使用

返回 DOMImplementationRegistry 的 org.w3c.dom.bootstrap 中的方法
static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
获得 DOMImplementationRegistry 的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.Attr 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Attr
的使用

使用 Attr 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.imageio.metadata 中 Attr 的使用

返回 Attr 的 javax.imageio.metadata 中的方法
Attr | IIOMetadataNode.getAttributeNode(String name)
Attr | IIOMetadataNode.getAttributeNodeNS(String namespaceURI, String localName) 等效于 getAttributeNode(localName)。
Attr | IIOMetadataNode.removeAttributeNode(Attr oldAttr)
Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
Attr | IIOMetadataNode.setAttributeNodeNS(Attr newAttr) 等效于 setAttributeNode(newAttr)。

参数类型为 Attr 的 javax.imageio.metadata 中的方法
Attr | IIOMetadataNode.removeAttributeNode(Attr oldAttr)
Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
Attr | IIOMetadataNode.setAttributeNodeNS(Attr newAttr) 等效于 setAttributeNode(newAttr)。
void | IIOMetadataNode.setIdAttributeNode(Attr idAttr, boolean isId)

org.w3c.dom 中 Attr 的使用

返回 Attr 的 org.w3c.dom 中的方法
Attr | Document.createAttribute(String name) 创建给定名称的 Attr。
Attr | Document.createAttributeNS(String namespaceURI, String qualifiedName) 创建给定的限定名称和名称空间 URI 的属性。
Attr | Element.getAttributeNode(String name) 通过名称获得属性节点。
Attr | Element.getAttributeNodeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 获得 Attr 节点。
Attr | Element.removeAttributeNode(Attr oldAttr) 移除指定的属性节点。
Attr | Element.setAttributeNode(Attr newAttr) 添加新的属性节点。
Attr | Element.setAttributeNodeNS(Attr newAttr) 添加新属性。

参数类型为 Attr 的 org.w3c.dom 中的方法
Attr | Element.removeAttributeNode(Attr oldAttr) 移除指定的属性节点。
Attr | Element.setAttributeNode(Attr newAttr) 添加新的属性节点。
Attr | Element.setAttributeNodeNS(Attr newAttr) 添加新属性。
void | Element.setIdAttributeNode(Attr idAttr, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.CDATASection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.CDATASection
的使用

使用 CDATASection 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 CDATASection 的使用

返回 CDATASection 的 org.w3c.dom 中的方法
 CDATASection Document.createCDATASection(String data)
创建其值为指定字符串的 CDATASection 节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.CharacterData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.CharacterData
的使用

使用 CharacterData 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 CharacterData 的使用

org.w3c.dom 中 CharacterData 的子接口
interface | CDATASection CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。
interface | Comment 此接口继承自 CharacterData 表示注释的内容，即起始 '<!--' 和结束 '-->' 之间的所有字符。
interface | Text 该 Text 接口继承自 CharacterData，并且表示 Element 或 Attr 的文本内容（在 XML 中称为字符数据）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.Comment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Comment
的使用

使用 Comment 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 Comment 的使用

返回 Comment 的 org.w3c.dom 中的方法
 Comment Document.createComment(String data)
创建给定指定字符串的 Comment 节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.Document 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Document
的使用

使用 Document 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.ls |

javax.imageio.metadata 中 Document 的使用

返回 Document 的 javax.imageio.metadata 中的方法
 Document IIOMetadataNode.getOwnerDocument()
返回 null，因为 IIOMetadataNode 不属于任何 Document。

javax.xml.parsers 中 Document 的使用

返回 Document 的 javax.xml.parsers 中的方法
abstract Document | DocumentBuilder.newDocument() 获取 DOM Document 对象的一个新实例来生成一个 DOM 树。
Document | DocumentBuilder.parse(File f) 将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
abstract Document | DocumentBuilder.parse(InputSource is) 将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | DocumentBuilder.parse(InputStream is) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | DocumentBuilder.parse(InputStream is, String systemId) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | DocumentBuilder.parse(String uri) 将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。

javax.xml.soap 中 Document 的使用

实现 Document 的 javax.xml.soap 中的类
 class SOAPPart
SOAPMessage 对象中特定于 SOAP 部分的容器。

返回 Document 的 javax.xml.soap 中的方法
 Document SOAPBody.extractContentAsDocument()
创建新的 DOM Document，并将此 SOAPBody 的第一个子元素设置为它的文档元素。

参数类型为 Document 的 javax.xml.soap 中的方法
 SOAPBodyElement SOAPBody.addDocument(Document document)
将 DOM Document 的根节点添加到此 SOAPBody 对象。

org.w3c.dom 中 Document 的使用

返回 Document 的 org.w3c.dom 中的方法
Document | DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype) 创建具有文档元素的指定类型的 DOM Document 对象。
Document | Node.getOwnerDocument() 与此节点相关的 Document 对象。

org.w3c.dom.ls 中 Document 的使用

返回 Document 的 org.w3c.dom.ls 中的方法
Document | LSLoadEvent.getNewDocument() 完成加载的文档。
Document | LSParser.parse(LSInput input) 从通过 LSInput 标识的资源中解析 XML 文档。
Document | LSParser.parseURI(String uri) 从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.DocumentFragment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DocumentFragment
的使用

使用 DocumentFragment 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 DocumentFragment 的使用

返回 DocumentFragment 的 org.w3c.dom 中的方法
 DocumentFragment Document.createDocumentFragment()
创建空 DocumentFragment 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.DocumentType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DocumentType
的使用

使用 DocumentType 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 DocumentType 的使用

返回 DocumentType 的 org.w3c.dom 中的方法
DocumentType | DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId) 创建空 DocumentType 节点。
DocumentType | Document.getDoctype() 与此文档相关的文档类型声明（参见 DocumentType）。

参数类型为 DocumentType 的 org.w3c.dom 中的方法
 Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
创建具有文档元素的指定类型的 DOM Document 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.DOMConfiguration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMConfiguration
的使用

使用 DOMConfiguration 的软件包
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.ls |

org.w3c.dom 中 DOMConfiguration 的使用

返回 DOMConfiguration 的 org.w3c.dom 中的方法
 DOMConfiguration Document.getDomConfig()
调用 Document.normalizeDocument() 时使用的配置。

org.w3c.dom.ls 中 DOMConfiguration 的使用

返回 DOMConfiguration 的 org.w3c.dom.ls 中的方法
DOMConfiguration | LSParser.getDomConfig() 解析输入源时使用的 DOMConfiguration 对象。
DOMConfiguration | LSSerializer.getDomConfig() 在序列化 DOM 节点时由 LSSerializer 使用的 DOMConfiguration 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.DOMError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMError
的使用

使用 DOMError 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 DOMError 的使用

参数类型为 DOMError 的 org.w3c.dom 中的方法
 boolean DOMErrorHandler.handleError(DOMError error)
发生错误时在错误处理程序上调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.DOMErrorHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMErrorHandler
的使用

没有 org.w3c.dom.DOMErrorHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.w3c.dom.DOMException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.w3c.dom.DOMException
的使用

使用 DOMException 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |

javax.imageio.metadata 中 DOMException 的使用

抛出 DOMException 的 javax.imageio.metadata 中的方法
short | IIOMetadataNode.compareDocumentPosition(Node other)
String | IIOMetadataNode.getNamespaceURI() 返回 null，因为不支持名称空间。
String | IIOMetadataNode.getNodeValue()
String | IIOMetadataNode.getTextContent()
Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
void | IIOMetadataNode.setIdAttribute(String name, boolean isId)
void | IIOMetadataNode.setIdAttributeNode(Attr idAttr, boolean isId)
void | IIOMetadataNode.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
void | IIOMetadataNode.setNodeValue(String nodeValue)
void | IIOMetadataNode.setTextContent(String textContent)

org.w3c.dom 中 DOMException 的使用

抛出 DOMException 的 org.w3c.dom 中的方法
Node | Document.adoptNode(Node source) 试图把另一文档中的节点采用到此文档。
Node | Node.appendChild(Node newChild) 将节点 newChild 添加到此节点的子节点列表的末尾。
void | CharacterData.appendData(String arg) 将字符串追加到节点的字符数据的结尾。
short | Node.compareDocumentPosition(Node other) 就节点在文档中的位置并按照文档的顺序，比较引用节点（即在其上调用此方法的节点）与作为参数传递的节点。
Attr | Document.createAttribute(String name) 创建给定名称的 Attr。
Attr | Document.createAttributeNS(String namespaceURI, String qualifiedName) 创建给定的限定名称和名称空间 URI 的属性。
CDATASection | Document.createCDATASection(String data) 创建其值为指定字符串的 CDATASection 节点。
Document | DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype) 创建具有文档元素的指定类型的 DOM Document 对象。
DocumentType | DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId) 创建空 DocumentType 节点。
Element | Document.createElement(String tagName) 创建指定类型的元素。
Element | Document.createElementNS(String namespaceURI, String qualifiedName) 创建给定的限定名称和名称空间 URI 的元素。
EntityReference | Document.createEntityReference(String name) 创建 EntityReference 对象。
ProcessingInstruction | Document.createProcessingInstruction(String target, String data) 创建给定指定名称和数据字符串的 ProcessingInstruction 节点。
void | CharacterData.deleteData(int offset, int count) 从该节点移除某个范围的 16 位单元。
Attr | Element.getAttributeNodeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 获得 Attr 节点。
String | Element.getAttributeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 获得属性值。
String | CharacterData.getData() 实现此接口的节点的字符数据。
NodeList | Element.getElementsByTagNameNS(String namespaceURI, String localName) 以文档顺序返回具有给定本地名称和名称空间 URI 的所有后代 Elements 的 NodeList。
Node | NamedNodeMap.getNamedItemNS(String namespaceURI, String localName) 检索通过本地名称和名称空间 URI 指定的节点。
String | Node.getNodeValue() 此节点的值，取决于其类型；参见上表。
Object | DOMConfiguration.getParameter(String name) 如果已知，则返回参数的值。
String | Node.getTextContent() 此属性返回此节点及其后代的文本内容。
boolean | Element.hasAttributeNS(String namespaceURI, String localName) 当具有给定本地名称和名称空间 URI 的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。
Node | Document.importNode(Node importedNode, boolean deep) 从另一文档向此文档导入节点，而不改变或移除原始文档中的源节点；此方法创建源节点的一个新副本。
Node | Node.insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
void | CharacterData.insertData(int offset, String arg) 在指定的 16 位单元偏移量位置插入一个字符串。
void | Element.removeAttribute(String name) 通过名称移除一个属性。
Attr | Element.removeAttributeNode(Attr oldAttr) 移除指定的属性节点。
void | Element.removeAttributeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 移除属性值。
Node | Node.removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | NamedNodeMap.removeNamedItem(String name) 移除通过名称指定的节点。
Node | NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName) 移除通过本地名称和名称空间 URI 指定的节点。
Node | Document.renameNode(Node n, String namespaceURI, String qualifiedName) 重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。
Node | Node.replaceChild(Node newChild, Node oldChild) 将子节点列表中的子节点 oldChild 替换为 newChild，并返回 oldChild 节点。
void | CharacterData.replaceData(int offset, int count, String arg) 用指定的字符串替换从指定 16 位单元偏移量起始的字符。
Text | Text.replaceWholeText(String content) 将当前节点和所有逻辑上相邻的文本节点的文本替换为指定的文本。
void | Element.setAttribute(String name, String value) 添加一个新属性。
Attr | Element.setAttributeNode(Attr newAttr) 添加新的属性节点。
Attr | Element.setAttributeNodeNS(Attr newAttr) 添加新属性。
void | Element.setAttributeNS(String namespaceURI, String qualifiedName, String value) 添加新属性。
void | ProcessingInstruction.setData(String data) 此处理指令的内容。
void | CharacterData.setData(String data) 实现此接口的节点的字符数据。
void | Element.setIdAttribute(String name, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用于确定用户的 ID 属性。
void | Element.setIdAttributeNode(Attr idAttr, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
void | Element.setIdAttributeNS(String namespaceURI, String localName, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
Node | NamedNodeMap.setNamedItem(Node arg) 使用 nodeName 属性添加节点。
Node | NamedNodeMap.setNamedItemNS(Node arg) 使用其 namespaceURI 和 localName 添加节点。
void | Node.setNodeValue(String nodeValue) 此节点的值，取决于其类型；参见上表。
void | DOMConfiguration.setParameter(String name, Object value) 设置参数的值。
void | Node.setPrefix(String prefix) 此节点的名称空间前缀；如果未指定，则为 null。
void | Node.setTextContent(String textContent) 此属性返回此节点及其后代的文本内容。
void | Attr.setValue(String value) 检索时，该属性值以字符串形式返回。
void | Document.setXmlStandalone(boolean xmlStandalone) 作为 XML 声明 的一部分指定此文档是否是单独的的属性。
void | Document.setXmlVersion(String xmlVersion) 作为 XML 声明 的一部分指定此文档版本号的属性。
Text | Text.splitText(int offset) 在指定的 offset 处将此节点拆分为两个节点，并将二者作为兄弟节点保持在树中。
String | CharacterData.substringData(int offset, int count) 从该节点提取某个范围的数据。

org.w3c.dom.events 中 DOMException 的使用

抛出 DOMException 的 org.w3c.dom.events 中的方法
 Event DocumentEvent.createEvent(String eventType)

org.w3c.dom.ls 中 DOMException 的使用

抛出 DOMException 的 org.w3c.dom.ls 中的方法
LSParser | DOMImplementationLS.createLSParser(short mode, String schemaType) 创建一个新的 LSParser。
Document | LSParser.parse(LSInput input) 从通过 LSInput 标识的资源中解析 XML 文档。
Document | LSParser.parseURI(String uri) 从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。
Node | LSParser.parseWithContext(LSInput input, Node contextArg, short action) 从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。
String | LSSerializer.writeToString(Node nodeArg) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.DOMImplementation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMImplementation
的使用

使用 DOMImplementation 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.bootstrap |

javax.xml.parsers 中 DOMImplementation 的使用

返回 DOMImplementation 的 javax.xml.parsers 中的方法
abstract  DOMImplementation DocumentBuilder.getDOMImplementation()
获取 DOMImplementation 对象的一个实例。

org.w3c.dom 中 DOMImplementation 的使用

返回 DOMImplementation 的 org.w3c.dom 中的方法
DOMImplementation | DOMImplementationSource.getDOMImplementation(String features) 请求支持指定的功能的第一个 DOM 实现的方法。
DOMImplementation | Document.getImplementation() 处理此文档的 DOMImplementation 对象。
DOMImplementation | DOMImplementationList.item(int index) 返回集合中的第 index 个项。

org.w3c.dom.bootstrap 中 DOMImplementation 的使用

返回 DOMImplementation 的 org.w3c.dom.bootstrap 中的方法
 DOMImplementation DOMImplementationRegistry.getDOMImplementation(String features)
返回第一个具有所需功能的实现；如果找不到具有所需功能的任何实现，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.DOMImplementationList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMImplementationList
的使用

使用 DOMImplementationList 的软件包
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.bootstrap |

org.w3c.dom 中 DOMImplementationList 的使用

返回 DOMImplementationList 的 org.w3c.dom 中的方法
 DOMImplementationList DOMImplementationSource.getDOMImplementationList(String features)
请求支持指定功能和版本的 DOM 实现的列表的方法，如下所述。

org.w3c.dom.bootstrap 中 DOMImplementationList 的使用

返回 DOMImplementationList 的 org.w3c.dom.bootstrap 中的方法
 DOMImplementationList DOMImplementationRegistry.getDOMImplementationList(String features)
返回支持所需功能的实现列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.DOMImplementationSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMImplementationSource
的使用

使用 DOMImplementationSource 的软件包
org.w3c.dom.bootstrap

org.w3c.dom.bootstrap 中 DOMImplementationSource 的使用

参数类型为 DOMImplementationSource 的 org.w3c.dom.bootstrap 中的方法
 void DOMImplementationRegistry.addSource(DOMImplementationSource s)
注册实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.DOMLocator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMLocator
的使用

使用 DOMLocator 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 DOMLocator 的使用

返回 DOMLocator 的 org.w3c.dom 中的方法
 DOMLocator DOMError.getLocation()
错误的位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.DOMStringList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMStringList
的使用

使用 DOMStringList 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 DOMStringList 的使用

返回 DOMStringList 的 org.w3c.dom 中的方法
 DOMStringList DOMConfiguration.getParameterNames()
此 DOMConfiguration 对象支持的参数列表，并且应用程序至少可以为其设置一个值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.Element 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Element
的使用

使用 Element 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.ls |

javax.imageio.metadata 中 Element 的使用

实现 Element 的 javax.imageio.metadata 中的类
 class IIOMetadataNode
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

javax.xml.bind.annotation 中 Element 的使用

返回 Element 的 javax.xml.bind.annotation 中的方法
 Element W3CDomHandler.getElement(DOMResult r)

参数类型为 Element 的 javax.xml.bind.annotation 中的方法
 Source W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

javax.xml.crypto.dom 中 Element 的使用

返回 Element 的 javax.xml.crypto.dom 中的方法
 Element DOMCryptoContext.getElementById(String idValue)
返回具有指定 ID 属性值的 Element。

参数类型为 Element 的 javax.xml.crypto.dom 中的方法
 void DOMCryptoContext.setIdAttributeNS(Element element, String namespaceURI, String localName)
将名称空间 URI 和本地名称指定的元素属性注册为类型 ID。

javax.xml.soap 中 Element 的使用

javax.xml.soap 中 Element 的子接口
interface | Detail DetailEntry 对象的容器。
interface | DetailEntry Detail 对象的内容，给出 SOAPFault 对象的详细信息。
interface | SOAPBody 表示 SOAP 消息中 SOAP 正文元素内容的对象。
interface | SOAPBodyElement 表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
interface | SOAPElement 表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。
interface | SOAPEnvelope SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
interface | SOAPFault SOAPBody 对象中的元素，包含错误和/或状态信息。
interface | SOAPFaultElement SOAPFault 对象内容的表示形式。
interface | SOAPHeader SOAP 头元素的表示形式。
interface | SOAPHeaderElement 表示 SOAP 信封 SOAP 头部分的内容的对象。

参数类型为 Element 的 javax.xml.soap 中的方法
 SOAPElement SOAPFactory.createElement(Element domElement)
根据现有的 DOM Element 创建 SOAPElement 对象。

org.w3c.dom 中 Element 的使用

返回 Element 的 org.w3c.dom 中的方法
Element | Document.createElement(String tagName) 创建指定类型的元素。
Element | Document.createElementNS(String namespaceURI, String qualifiedName) 创建给定的限定名称和名称空间 URI 的元素。
Element | Document.getDocumentElement() 这是一种便捷属性，该属性允许直接访问文档的文档元素的子节点。
Element | Document.getElementById(String elementId) 返回具有带给定值的 ID 属性的 Element。
Element | Attr.getOwnerElement() 此属性连接到的 Element 节点；如果未使用此属性，则为 null。

org.w3c.dom.ls 中 Element 的使用

参数类型为 Element 的 org.w3c.dom.ls 中的方法
 short LSParserFilter.startElement(Element elementArg)
解析器将在扫描完每个 Element 启动标记后，处理其余的 Element 之前调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.Entity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Entity
的使用

没有 org.w3c.dom.Entity 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.EntityReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.EntityReference
的使用

使用 EntityReference 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 EntityReference 的使用

返回 EntityReference 的 org.w3c.dom 中的方法
 EntityReference Document.createEntityReference(String name)
创建 EntityReference 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.NamedNodeMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.NamedNodeMap
的使用

使用 NamedNodeMap 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.imageio.metadata 中 NamedNodeMap 的使用

返回 NamedNodeMap 的 javax.imageio.metadata 中的方法
 NamedNodeMap IIOMetadataNode.getAttributes()

org.w3c.dom 中 NamedNodeMap 的使用

返回 NamedNodeMap 的 org.w3c.dom 中的方法
NamedNodeMap | Node.getAttributes() 包含此节点的属性的 NamedNodeMap（如果它是 Element）；否则为 null。
NamedNodeMap | DocumentType.getEntities() 包含在 DTD 中声明的内部和外部常规实体的 NamedNodeMap。
NamedNodeMap | DocumentType.getNotations() 包含在 DTD 中声明的表示法的 NamedNodeMap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.NameList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.NameList
的使用

没有 org.w3c.dom.NameList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.Node 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Node
的使用

使用 Node 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |

javax.imageio.metadata 中 Node 的使用

实现 Node 的 javax.imageio.metadata 中的类
 class IIOMetadataNode
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

声明为 Node 的 javax.imageio.metadata 中的字段
protected  Node IIOInvalidTreeException.offendingNode
导致解析错误的 Node，或 null。

返回 Node 的 javax.imageio.metadata 中的方法
Node | IIOMetadataNode.appendChild(Node newChild) 将节点 newChild 添加到此节点子节点列表的末尾。
Node | IIOMetadataNode.cloneNode(boolean deep) 返回此节点的副本。
abstract Node | IIOMetadata.getAsTree(String formatName) 返回 XML DOM Node 对象，该对象表示此对象所包含的元数据树的根（根据给定元数据格式定义的约定）。
Node | IIOMetadataNode.getFirstChild() 此节点的第一个子节点；如果该节点没有子节点，则返回 null。
Node | IIOMetadataNode.getLastChild() 返回此节点的最后一个子节点；如果该节点没有子节点，则返回 null。
Node | IIOMetadataNode.getNextSibling() 返回此节点的下一个兄弟节点；如果该节点没有下一个兄弟节点，则返回 null。
Node | IIOInvalidTreeException.getOffendingNode() 返回导致解析错误的 Node。
Node | IIOMetadataNode.getParentNode() 返回此节点的父节点。
Node | IIOMetadataNode.getPreviousSibling() 返回此节点的上一个兄弟节点；如果该节点没有上一个兄弟节点，则返回 null。
Node | IIOMetadataNode.insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
Node | IIOMetadataNode.item(int index)
Node | IIOMetadataNode.removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | IIOMetadataNode.replaceChild(Node newChild, Node oldChild) 将子节点 oldChild 替换为子节点列表中的 newChild，并返回 oldChild 节点。

参数类型为 Node 的 javax.imageio.metadata 中的方法
Node | IIOMetadataNode.appendChild(Node newChild) 将节点 newChild 添加到此节点子节点列表的末尾。
short | IIOMetadataNode.compareDocumentPosition(Node other)
Node | IIOMetadataNode.insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
boolean | IIOMetadataNode.isEqualNode(Node node)
boolean | IIOMetadataNode.isSameNode(Node node)
abstract void | IIOMetadata.mergeTree(String formatName, Node root) 根据 XML DOM Node 树（其语法由给定元数据格式定义）改变此 IIOMetadata 对象的内部状态。
Node | IIOMetadataNode.removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | IIOMetadataNode.replaceChild(Node newChild, Node oldChild) 将子节点 oldChild 替换为子节点列表中的 newChild，并返回 oldChild 节点。
void | IIOMetadata.setFromTree(String formatName, Node root) 根据 XML DOM Node 的树（其语法由给定元数据格式定义）设置此 IIOMetadata 对象的内部状态。

参数类型为 Node 的 javax.imageio.metadata 中的构造方法
IIOInvalidTreeException(String message, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串和对导致解析错误的 Node 的引用。
IIOInvalidTreeException(String message, Throwable cause, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串、对导致此异常的异常的引用和导致解析错误的 Node 的引用。

javax.xml.bind 中 Node 的使用

返回 Node 的 javax.xml.bind 中的方法
Node | ValidationEventLocator.getNode() 返回对 DOM Node 的引用（如果可用）。
Node | Marshaller.getNode(Object contentTree) 获取内容树的 DOM 树视图（可选）。

返回变量类型为 Node 的类型的 javax.xml.bind 中的方法
 Binder<Node> JAXBContext.createBinder()
为 W3C DOM 创建一个 Binder。

参数类型为 Node 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, Node node)
将以 jaxbElement 为根的内容树编组到 DOM 树中。
 Object Unmarshaller.unmarshal(Node node)
从指定的 DOM 树解组全局 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Node node, Class<T> declaredType)
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 Node 的使用

返回 Node 的 javax.xml.bind.helpers 中的方法
Node | ValidationEventLocatorImpl.getNode()
Node | AbstractMarshallerImpl.getNode(Object obj) 默认情况下，getNode 方法不受支持并抛出 UnsupportedOperationException。

参数类型为 Node 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, Node node)
 void ValidationEventLocatorImpl.setNode(Node _node)
在此事件定位符上设置 Node 字段。
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)

参数类型为 Node 的 javax.xml.bind.helpers 中的构造方法
ValidationEventLocatorImpl(Node _node)
构造一个指向 DOM Node 的对象。

javax.xml.crypto.dom 中 Node 的使用

返回 Node 的 javax.xml.crypto.dom 中的方法
Node | DOMURIReference.getHere() 返回当前位置的节点。
Node | DOMStructure.getNode() 返回包含在此 DOMStructure 中的节点。

参数类型为 Node 的 javax.xml.crypto.dom 中的构造方法
DOMStructure(Node node)
创建包含指定节点的 DOMStructure。

javax.xml.crypto.dsig.dom 中 Node 的使用

返回 Node 的 javax.xml.crypto.dsig.dom 中的方法
Node | DOMSignContext.getNextSibling() 返回 nextSibling 节点。
Node | DOMValidateContext.getNode() 返回节点。
Node | DOMSignContext.getParent() 返回父节点。

参数类型为 Node 的 javax.xml.crypto.dsig.dom 中的方法
void | DOMSignContext.setNextSibling(Node nextSibling) 设置下一个兄弟节点。
void | DOMValidateContext.setNode(Node node) 设置节点。
void | DOMSignContext.setParent(Node parent) 设置父节点。

参数类型为 Node 的 javax.xml.crypto.dsig.dom 中的构造方法
DOMSignContext(Key signingKey, Node parent)
创建带有指定签名密钥和父节点的 DOMSignContext。
DOMSignContext(Key signingKey, Node parent, Node nextSibling)
创建带有指定的签名密钥、父节点和下一个兄弟节点的 DOMSignContext。
DOMSignContext(KeySelector ks, Node parent)
创建带有指定密钥选择器和父节点的 DOMSignContext。
DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
创建带有指定密钥选择器、父节点和下一个兄弟节点的 DOMSignContext。
DOMValidateContext(Key validatingKey, Node node)
创建包含指定密钥和节点的 DOMValidateContext。
DOMValidateContext(KeySelector ks, Node node)
创建包含指定密钥选择器和节点的 DOMValidateContext。

javax.xml.soap 中 Node 的使用

javax.xml.soap 中 Node 的子接口
interface | Detail DetailEntry 对象的容器。
interface | DetailEntry Detail 对象的内容，给出 SOAPFault 对象的详细信息。
interface | Node XML 文档中节点（元素）的表示形式。
interface | SOAPBody 表示 SOAP 消息中 SOAP 正文元素内容的对象。
interface | SOAPBodyElement 表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
interface | SOAPElement 表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。
interface | SOAPEnvelope SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
interface | SOAPFault SOAPBody 对象中的元素，包含错误和/或状态信息。
interface | SOAPFaultElement SOAPFault 对象内容的表示形式。
interface | SOAPHeader SOAP 头元素的表示形式。
interface | SOAPHeaderElement 表示 SOAP 信封 SOAP 头部分的内容的对象。

实现 Node 的 javax.xml.soap 中的类
 class SOAPPart
SOAPMessage 对象中特定于 SOAP 部分的容器。

javax.xml.transform.dom 中 Node 的使用

返回 Node 的 javax.xml.transform.dom 中的方法
Node | DOMResult.getNextSibling() 获取将要插入的结果节点之后的子节点。
Node | DOMResult.getNode() 获取将包含结果 DOM 树的节点。
Node | DOMSource.getNode() 获取表示 Source DOM 树的节点。
Node | DOMLocator.getOriginatingNode() 返回事件发生的节点位置。

参数类型为 Node 的 javax.xml.transform.dom 中的方法
void | DOMResult.setNextSibling(Node nextSibling) 设置将要插入的结果节点之后的子节点。
void | DOMResult.setNode(Node node) 设置将包含结果 DOM 树的节点。
void | DOMSource.setNode(Node node) 设置将表示 Source DOM 树的节点。

参数类型为 Node 的 javax.xml.transform.dom 中的构造方法
DOMResult(Node node)
使用 DOM 节点创建新输出目标。
DOMResult(Node node, Node nextSibling)
使用 DOM 节点创建新输出目标，此目标指定了应该插入的结果节点之后的子节点。
DOMResult(Node node, Node nextSibling, String systemId)
使用 DOM 节点创建新输出目标，此目标指定了子节点，其中结果节点为指定 System ID 且应该插入到该子节点之前。
DOMResult(Node node, String systemId)
使用 DOM 节点创建带有指定 System ID 的新输出目标。
DOMSource(Node n)
创建带有 DOM 节点的新输入源。
DOMSource(Node node, String systemID)
创建带有 DOM 节点的新输入源，系统 ID 也作为基本 URI 被传入。

org.w3c.dom 中 Node 的使用

org.w3c.dom 中 Node 的子接口
interface | Attr Attr 接口表示 Element 对象中的属性。
interface | CDATASection CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。
interface | CharacterData CharacterData 接口使用属性集合和用于访问 DOM 中字符数据的方法扩展节点。
interface | Comment 此接口继承自 CharacterData 表示注释的内容，即起始 '<!--' 和结束 '-->' 之间的所有字符。
interface | Document Document 接口表示整个 HTML 或 XML 文档。
interface | DocumentFragment DocumentFragment 是“轻量级”或“最小”Document 对象。
interface | DocumentType 每个 Document 都有 doctype 属性，该属性的值可以为 null，也可以为 DocumentType 对象。
interface | Element Element 接口表示 HTML 或 XML 文档中的一个元素。
interface | Entity 此接口表示在 XML 文档中解析和未解析的已知实体。
interface | EntityReference EntityReference 节点可以用来在树中表示实体引用。
interface | Notation 此接口表示在 DTD 中声明的表示法。
interface | ProcessingInstruction ProcessingInstruction 接口表示“处理指令”，该指令作为一种在文档的文本中保持特定于处理器的信息的方法在 XML 中使用。
interface | Text 该 Text 接口继承自 CharacterData，并且表示 Element 或 Attr 的文本内容（在 XML 中称为字符数据）。

返回 Node 的 org.w3c.dom 中的方法
Node | Document.adoptNode(Node source) 试图把另一文档中的节点采用到此文档。
Node | Node.appendChild(Node newChild) 将节点 newChild 添加到此节点的子节点列表的末尾。
Node | Node.cloneNode(boolean deep) 返回此节点的副本，即允当节点的一般复制构造方法。
Node | Node.getFirstChild() 此节点的第一个子节点。
Node | Node.getLastChild() 此节点的最后一个节点。
Node | NamedNodeMap.getNamedItem(String name) 检索通过名称指定的节点。
Node | NamedNodeMap.getNamedItemNS(String namespaceURI, String localName) 检索通过本地名称和名称空间 URI 指定的节点。
Node | Node.getNextSibling() 直接在此节点之后的节点。
Node | Node.getParentNode() 此节点的父节点。
Node | Node.getPreviousSibling() 直接在此节点之前的节点。
Node | DOMLocator.getRelatedNode() 此定位器指向的节点；如果没有可用的节点，则为 null。
Node | Document.importNode(Node importedNode, boolean deep) 从另一文档向此文档导入节点，而不改变或移除原始文档中的源节点；此方法创建源节点的一个新副本。
Node | Node.insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
Node | NamedNodeMap.item(int index) 返回映射中第 index 个项。
Node | NodeList.item(int index) 返回集合中的第 index 个项。
Node | Node.removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | NamedNodeMap.removeNamedItem(String name) 移除通过名称指定的节点。
Node | NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName) 移除通过本地名称和名称空间 URI 指定的节点。
Node | Document.renameNode(Node n, String namespaceURI, String qualifiedName) 重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。
Node | Node.replaceChild(Node newChild, Node oldChild) 将子节点列表中的子节点 oldChild 替换为 newChild，并返回 oldChild 节点。
Node | NamedNodeMap.setNamedItem(Node arg) 使用 nodeName 属性添加节点。
Node | NamedNodeMap.setNamedItemNS(Node arg) 使用其 namespaceURI 和 localName 添加节点。

参数类型为 Node 的 org.w3c.dom 中的方法
Node | Document.adoptNode(Node source) 试图把另一文档中的节点采用到此文档。
Node | Node.appendChild(Node newChild) 将节点 newChild 添加到此节点的子节点列表的末尾。
short | Node.compareDocumentPosition(Node other) 就节点在文档中的位置并按照文档的顺序，比较引用节点（即在其上调用此方法的节点）与作为参数传递的节点。
void | UserDataHandler.handle(short operation, String key, Object data, Node src, Node dst) 每当导入或克隆为其注册此处理程序的节点时，调用此方法。
Node | Document.importNode(Node importedNode, boolean deep) 从另一文档向此文档导入节点，而不改变或移除原始文档中的源节点；此方法创建源节点的一个新副本。
Node | Node.insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
boolean | Node.isEqualNode(Node arg) 测试两个节点是否相等。
boolean | Node.isSameNode(Node other) 返回此节点是否是与给定节点相同的节点。
Node | Node.removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | Document.renameNode(Node n, String namespaceURI, String qualifiedName) 重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。
Node | Node.replaceChild(Node newChild, Node oldChild) 将子节点列表中的子节点 oldChild 替换为 newChild，并返回 oldChild 节点。
Node | NamedNodeMap.setNamedItem(Node arg) 使用 nodeName 属性添加节点。
Node | NamedNodeMap.setNamedItemNS(Node arg) 使用其 namespaceURI 和 localName 添加节点。

org.w3c.dom.events 中 Node 的使用

返回 Node 的 org.w3c.dom.events 中的方法
 Node MutationEvent.getRelatedNode()
relatedNode 用于识别与 mutation 事件相关联的辅助节点。

参数类型为 Node 的 org.w3c.dom.events 中的方法
 void MutationEvent.initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)
该 initMutationEvent 方法用于初始化通过 DocumentEvent 接口创建的 MutationEvent 的值。

org.w3c.dom.ls 中 Node 的使用

返回 Node 的 org.w3c.dom.ls 中的方法
 Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。

参数类型为 Node 的 org.w3c.dom.ls 中的方法
short | LSParserFilter.acceptNode(Node nodeArg) 此方法将由解析器在完成对每个节点的解析后调用。
Node | LSParser.parseWithContext(LSInput input, Node contextArg, short action) 从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。
boolean | LSSerializer.write(Node nodeArg, LSOutput destination) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
String | LSSerializer.writeToString(Node nodeArg) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
boolean | LSSerializer.writeToURI(Node nodeArg, String uri) 这是一种简便方法，其作用就像使用没有指定编码的 LSOutput 调用 LSSerializer.write，并且 LSOutput.systemId 被设置为 uri 参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.NodeList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.NodeList
的使用

使用 NodeList 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.imageio.metadata 中 NodeList 的使用

实现 NodeList 的 javax.imageio.metadata 中的类
 class IIOMetadataNode
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

返回 NodeList 的 javax.imageio.metadata 中的方法
NodeList | IIOMetadataNode.getChildNodes()
NodeList | IIOMetadataNode.getElementsByTagName(String name)
NodeList | IIOMetadataNode.getElementsByTagNameNS(String namespaceURI, String localName) 等效于 getElementsByTagName(localName)。

org.w3c.dom 中 NodeList 的使用

返回 NodeList 的 org.w3c.dom 中的方法
NodeList | Node.getChildNodes() 包含此节点的所有子节点的 NodeList。
NodeList | Element.getElementsByTagName(String name) 以文档顺序返回具有给定标记名称的所有后代 Elements 的 NodeList。
NodeList | Document.getElementsByTagName(String tagname) 按文档顺序返回包含在文档中且具有给定标记名称的所有 Element 的 NodeList。
NodeList | Element.getElementsByTagNameNS(String namespaceURI, String localName) 以文档顺序返回具有给定本地名称和名称空间 URI 的所有后代 Elements 的 NodeList。
NodeList | Document.getElementsByTagNameNS(String namespaceURI, String localName) 以文档顺序返回具有给定本地名称和名称空间 URI 的所有 Elements 的 NodeList。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.Notation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Notation
的使用

没有 org.w3c.dom.Notation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.ProcessingInstruction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ProcessingInstruction
的使用

使用 ProcessingInstruction 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 ProcessingInstruction 的使用

返回 ProcessingInstruction 的 org.w3c.dom 中的方法
 ProcessingInstruction Document.createProcessingInstruction(String target, String data)
创建给定指定名称和数据字符串的 ProcessingInstruction 节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.Text 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Text
的使用

使用 Text 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.xml.soap 中 Text 的使用

javax.xml.soap 中 Text 的子接口
 interface Text
值为文本的节点的表示形式。

org.w3c.dom 中 Text 的使用

org.w3c.dom 中 Text 的子接口
 interface CDATASection
CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。

返回 Text 的 org.w3c.dom 中的方法
Text | Document.createTextNode(String data) 创建给定指定字符串的 Text 节点。
Text | Text.replaceWholeText(String content) 将当前节点和所有逻辑上相邻的文本节点的文本替换为指定的文本。
Text | Text.splitText(int offset) 在指定的 offset 处将此节点拆分为两个节点，并将二者作为兄弟节点保持在树中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.TypeInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.TypeInfo
的使用

使用 TypeInfo 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.imageio.metadata 中 TypeInfo 的使用

返回 TypeInfo 的 javax.imageio.metadata 中的方法
 TypeInfo IIOMetadataNode.getSchemaTypeInfo()

javax.xml.validation 中 TypeInfo 的使用

返回 TypeInfo 的 javax.xml.validation 中的方法
abstract TypeInfo | TypeInfoProvider.getAttributeTypeInfo(int index) 返回指定的当前元素属性的不可变的 TypeInfo 对象。
abstract TypeInfo | TypeInfoProvider.getElementTypeInfo() 返回当前元素的不可变的 TypeInfo 对象。

org.w3c.dom 中 TypeInfo 的使用

返回 TypeInfo 的 org.w3c.dom 中的方法
TypeInfo | Attr.getSchemaTypeInfo() 与此属性相关联的类型信息。
TypeInfo | Element.getSchemaTypeInfo() 与此元素相关的类型信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.UserDataHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.UserDataHandler
的使用

使用 UserDataHandler 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.imageio.metadata 中 UserDataHandler 的使用

参数类型为 UserDataHandler 的 javax.imageio.metadata 中的方法
 Object IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)

org.w3c.dom 中 UserDataHandler 的使用

参数类型为 UserDataHandler 的 org.w3c.dom 中的方法
 Object Node.setUserData(String key, Object data, UserDataHandler handler)
将对象与此节点上的键相关联。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.w3c.dom.events (Java 2 Platform SE 6)

 org.w3c.dom.events
接口
DocumentEvent
Event
EventListener
EventTarget
MouseEvent
MutationEvent
UIEvent
异常
EventException


接口 org.w3c.dom.events.DocumentEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.DocumentEvent
的使用

没有 org.w3c.dom.events.DocumentEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.events.Event 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.Event
的使用

使用 Event 的软件包
org.w3c.dom.events
org.w3c.dom.ls

org.w3c.dom.events 中 Event 的使用

org.w3c.dom.events 中 Event 的子接口
interface | MouseEvent MouseEvent 接口提供与鼠标事件相关联的特定上下文信息。
interface | MutationEvent MutationEvent 接口提供与 Mutation 事件相关的特定上下文信息。
interface | UIEvent UIEvent 接口提供与用户界面事件相关联的特定上下文信息。

返回 Event 的 org.w3c.dom.events 中的方法
 Event DocumentEvent.createEvent(String eventType)

参数类型为 Event 的 org.w3c.dom.events 中的方法
boolean | EventTarget.dispatchEvent(Event evt) 此方法允许将事件指派到实现事件模型。
void | EventListener.handleEvent(Event evt) 每当发生 EventListener 接口为其注册的类型的事件时，即可调用此方法。

org.w3c.dom.ls 中 Event 的使用

org.w3c.dom.ls 中 Event 的子接口
interface | LSLoadEvent 此接口表示通知文档加载完成的加载事件对象。
interface | LSProgressEvent 此接口表示进度事件对象，该对象在解析文档时通知应用程序有关进度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.w3c.dom.events.EventException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.w3c.dom.events.EventException
的使用

使用 EventException 的软件包
org.w3c.dom.events

org.w3c.dom.events 中 EventException 的使用

抛出 EventException 的 org.w3c.dom.events 中的方法
 boolean EventTarget.dispatchEvent(Event evt)
此方法允许将事件指派到实现事件模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.events.EventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.EventListener
的使用

使用 EventListener 的软件包
org.w3c.dom.events

org.w3c.dom.events 中 EventListener 的使用

参数类型为 EventListener 的 org.w3c.dom.events 中的方法
void | EventTarget.addEventListener(String type, EventListener listener, boolean useCapture) 此方法允许在事件目标上注册事件侦听器。
void | EventTarget.removeEventListener(String type, EventListener listener, boolean useCapture) 此方法允许从事件目标移除事件侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.events.EventTarget 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.EventTarget
的使用

使用 EventTarget 的软件包
org.w3c.dom.events

org.w3c.dom.events 中 EventTarget 的使用

返回 EventTarget 的 org.w3c.dom.events 中的方法
EventTarget | Event.getCurrentTarget() 用于指示当前正在处理其 EventListeners 的 EventTarget。
EventTarget | MouseEvent.getRelatedTarget() 用于识别与 UI 事件相关的辅助 EventTarget。
EventTarget | Event.getTarget() 用于指示 EventTarget，最初将事件指派给它。

参数类型为 EventTarget 的 org.w3c.dom.events 中的方法
 void MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
initMouseEvent 方法用于初始化通过 DocumentEvent 接口创建的 MouseEvent 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.events.MouseEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.MouseEvent
的使用

没有 org.w3c.dom.events.MouseEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.events.MutationEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.MutationEvent
的使用

没有 org.w3c.dom.events.MutationEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.events.UIEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.UIEvent
的使用

使用 UIEvent 的软件包
org.w3c.dom.events

org.w3c.dom.events 中 UIEvent 的使用

org.w3c.dom.events 中 UIEvent 的子接口
 interface MouseEvent
MouseEvent 接口提供与鼠标事件相关联的特定上下文信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.w3c.dom.ls (Java 2 Platform SE 6)

 org.w3c.dom.ls
接口
DOMImplementationLS
LSInput
LSLoadEvent
LSOutput
LSParser
LSParserFilter
LSProgressEvent
LSResourceResolver
LSSerializer
LSSerializerFilter
异常
LSException


接口 org.w3c.dom.ls.DOMImplementationLS 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.DOMImplementationLS
的使用

没有 org.w3c.dom.ls.DOMImplementationLS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.w3c.dom.ls.LSException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.w3c.dom.ls.LSException
的使用

使用 LSException 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSException 的使用

抛出 LSException 的 org.w3c.dom.ls 中的方法
Document | LSParser.parse(LSInput input) 从通过 LSInput 标识的资源中解析 XML 文档。
Document | LSParser.parseURI(String uri) 从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。
Node | LSParser.parseWithContext(LSInput input, Node contextArg, short action) 从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。
boolean | LSSerializer.write(Node nodeArg, LSOutput destination) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
String | LSSerializer.writeToString(Node nodeArg) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
boolean | LSSerializer.writeToURI(Node nodeArg, String uri) 这是一种简便方法，其作用就像使用没有指定编码的 LSOutput 调用 LSSerializer.write，并且 LSOutput.systemId 被设置为 uri 参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSInput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSInput
的使用

使用 LSInput 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSInput 的使用

返回 LSInput 的 org.w3c.dom.ls 中的方法
LSInput | DOMImplementationLS.createLSInput() 创建一个新的空输入源对象，其中，LSInput.characterStream、LSInput.byteStream、LSInput.stringData LSInput.systemId、LSInput.publicId、LSInput.baseURI 和 LSInput.encoding 为 null，LSInput.certifiedText 为 false。
LSInput | LSLoadEvent.getInput() 被解析的输入源。
LSInput | LSProgressEvent.getInput() 被解析的输入源。
LSInput | LSResourceResolver.resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI) 允许应用程序解析外部资源。

参数类型为 LSInput 的 org.w3c.dom.ls 中的方法
Document | LSParser.parse(LSInput input) 从通过 LSInput 标识的资源中解析 XML 文档。
Node | LSParser.parseWithContext(LSInput input, Node contextArg, short action) 从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSLoadEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSLoadEvent
的使用

没有 org.w3c.dom.ls.LSLoadEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSOutput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSOutput
的使用

使用 LSOutput 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSOutput 的使用

返回 LSOutput 的 org.w3c.dom.ls 中的方法
 LSOutput DOMImplementationLS.createLSOutput()
创建新的空输出目标对象，其中，LSOutput.characterStream、LSOutput.byteStream、LSOutput.systemId 和 LSOutput.encoding 为 null。

参数类型为 LSOutput 的 org.w3c.dom.ls 中的方法
 boolean LSSerializer.write(Node nodeArg, LSOutput destination)
像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSParser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSParser
的使用

使用 LSParser 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSParser 的使用

返回 LSParser 的 org.w3c.dom.ls 中的方法
 LSParser DOMImplementationLS.createLSParser(short mode, String schemaType)
创建一个新的 LSParser。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSParserFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSParserFilter
的使用

使用 LSParserFilter 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSParserFilter 的使用

返回 LSParserFilter 的 org.w3c.dom.ls 中的方法
 LSParserFilter LSParser.getFilter()
当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。

参数类型为 LSParserFilter 的 org.w3c.dom.ls 中的方法
 void LSParser.setFilter(LSParserFilter filter)
当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSProgressEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSProgressEvent
的使用

没有 org.w3c.dom.ls.LSProgressEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSResourceResolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSResourceResolver
的使用

使用 LSResourceResolver 的软件包
javax.xml.validation 此包提供了用于 XML 文档验证的 API。

javax.xml.validation 中 LSResourceResolver 的使用

返回 LSResourceResolver 的 javax.xml.validation 中的方法
abstract LSResourceResolver | SchemaFactory.getResourceResolver() 获取设置为此 SchemaFactory 的当前 LSResourceResolver。
abstract LSResourceResolver | Validator.getResourceResolver() 获取设置为此 Validator 的当前 LSResourceResolver。
abstract LSResourceResolver | ValidatorHandler.getResourceResolver() 获取设置到此 ValidatorHandler 的当前 LSResourceResolver。

参数类型为 LSResourceResolver 的 javax.xml.validation 中的方法
abstract void | SchemaFactory.setResourceResolver(LSResourceResolver resourceResolver) 设置 LSResourceResolver 以自定义解析模式时的资源解析。
abstract void | Validator.setResourceResolver(LSResourceResolver resourceResolver) 设置 LSResourceResolver 以自定义验证期间的资源解析。
abstract void | ValidatorHandler.setResourceResolver(LSResourceResolver resourceResolver) 设置 LSResourceResolver 以自定义验证期间的资源解析。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSSerializer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSSerializer
的使用

使用 LSSerializer 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSSerializer 的使用

返回 LSSerializer 的 org.w3c.dom.ls 中的方法
 LSSerializer DOMImplementationLS.createLSSerializer()
创建新的 LSSerializer 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSSerializerFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSSerializerFilter
的使用

使用 LSSerializerFilter 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSSerializerFilter 的使用

返回 LSSerializerFilter 的 org.w3c.dom.ls 中的方法
 LSSerializerFilter LSSerializer.getFilter()
当应用程序提供过滤器时，在序列化每个节点前串行器先调出过滤器。

参数类型为 LSSerializerFilter 的 org.w3c.dom.ls 中的方法
 void LSSerializer.setFilter(LSSerializerFilter filter)
当应用程序提供过滤器时，在序列化每个节点前串行器将先调出过滤器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.xml.sax (Java 2 Platform SE 6)

 org.xml.sax
接口
AttributeList
Attributes
ContentHandler
DocumentHandler
DTDHandler
EntityResolver
ErrorHandler
Locator
Parser
XMLFilter
XMLReader
类
HandlerBase
InputSource
异常
SAXException
SAXNotRecognizedException
SAXNotSupportedException
SAXParseException


接口 org.xml.sax.AttributeList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.AttributeList
的使用

使用 AttributeList 的软件包
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

org.xml.sax 中 AttributeList 的使用

参数类型为 AttributeList 的 org.xml.sax 中的方法
void | DocumentHandler.startElement(String name, AttributeList atts) 已过时。 接收元素开始的通知。
void | HandlerBase.startElement(String name, AttributeList attributes) 已过时。 接收元素开始的通知。

org.xml.sax.helpers 中 AttributeList 的使用

实现 AttributeList 的 org.xml.sax.helpers 中的类
 class AttributeListImpl
已过时。 此类实现不推荐使用的接口 AttributeList；该接口已被 AttributesImpl 帮助器类中实现的 Attributes 取代。

参数类型为 AttributeList 的 org.xml.sax.helpers 中的方法
void | AttributeListImpl.setAttributeList(AttributeList atts) 已过时。 设置属性列表，丢弃以前的内容。
void | ParserAdapter.startElement(String qName, AttributeList qAtts) 适配器实现方法；不调用。

参数类型为 AttributeList 的 org.xml.sax.helpers 中的构造方法
AttributeListImpl(AttributeList atts)
已过时。 构造现有属性列表的持久副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.Attributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.Attributes
的使用

使用 Attributes 的软件包
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

org.xml.sax 中 Attributes 的使用

参数类型为 Attributes 的 org.xml.sax 中的方法
 void ContentHandler.startElement(String uri, String localName, String qName, Attributes atts)
接收元素开始的通知。

org.xml.sax.ext 中 Attributes 的使用

org.xml.sax.ext 中 Attributes 的子接口
 interface Attributes2
SAX2 扩展，用于扩充通过 Attributes 提供的每个属性信息。

实现 Attributes 的 org.xml.sax.ext 中的类
 class Attributes2Impl
用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。

参数类型为 Attributes 的 org.xml.sax.ext 中的方法
 void Attributes2Impl.setAttributes(Attributes atts)
复制整个属性对象。

参数类型为 Attributes 的 org.xml.sax.ext 中的构造方法
Attributes2Impl(Attributes atts)
复制现有属性或 Attributes2 对象。

org.xml.sax.helpers 中 Attributes 的使用

实现 Attributes 的 org.xml.sax.helpers 中的类
 class AttributesImpl
Attributes 接口的默认实现。

参数类型为 Attributes 的 org.xml.sax.helpers 中的方法
void | AttributesImpl.setAttributes(Attributes atts) 复制整个 Attributes 对象。
void | DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes) 接收元素开始的通知。
void | XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts) 过滤一个开始元素事件。
void | XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts) 适配 SAX2 开始元素事件。

参数类型为 Attributes 的 org.xml.sax.helpers 中的构造方法
AttributesImpl(Attributes atts)
复制现有 Attributes 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.ContentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ContentHandler
的使用

使用 ContentHandler 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind 中 ContentHandler 的使用

javax.xml.bind 中 ContentHandler 的子接口
 interface UnmarshallerHandler
作为 SAX ContentHandler 实现的 Unmarshaller。

参数类型为 ContentHandler 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, ContentHandler handler)
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。

javax.xml.bind.helpers 中 ContentHandler 的使用

参数类型为 ContentHandler 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)

javax.xml.transform.sax 中 ContentHandler 的使用

javax.xml.transform.sax 中 ContentHandler 的子接口
interface | TemplatesHandler 可用于将 SAX 解析事件（解析转换指令）处理为 Templates 对象的 SAX ContentHandler。
interface | TransformerHandler 侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。

返回 ContentHandler 的 javax.xml.transform.sax 中的方法
 ContentHandler SAXResult.getHandler()
获取作为 Result 的 ContentHandler。

参数类型为 ContentHandler 的 javax.xml.transform.sax 中的方法
 void SAXResult.setHandler(ContentHandler handler)
设置要作为 SAX2 ContentHandler 的目标。

参数类型为 ContentHandler 的 javax.xml.transform.sax 中的构造方法
SAXResult(ContentHandler handler)
创建以 SAX2 ContentHandler 为目标的 SAXResult。

javax.xml.validation 中 ContentHandler 的使用

实现 ContentHandler 的 javax.xml.validation 中的类
 class ValidatorHandler
处理 SAX 流的流验证器。

返回 ContentHandler 的 javax.xml.validation 中的方法
abstract  ContentHandler ValidatorHandler.getContentHandler()
获取接收扩充的验证结果的 ContentHandler。

参数类型为 ContentHandler 的 javax.xml.validation 中的方法
abstract  void ValidatorHandler.setContentHandler(ContentHandler receiver)
设置 ContentHandler，它接收扩充的验证结果。

org.xml.sax 中 ContentHandler 的使用

返回 ContentHandler 的 org.xml.sax 中的方法
 ContentHandler XMLReader.getContentHandler()
返回当前的内容处理程序。

参数类型为 ContentHandler 的 org.xml.sax 中的方法
 void XMLReader.setContentHandler(ContentHandler handler)
允许应用程序注册内容事件处理程序。

org.xml.sax.ext 中 ContentHandler 的使用

实现 ContentHandler 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

org.xml.sax.helpers 中 ContentHandler 的使用

实现 ContentHandler 的 org.xml.sax.helpers 中的类
class | DefaultHandler SAX2 事件处理程序的默认基类。
class | XMLFilterImpl 派生 XML 过滤器的基类。
class | XMLReaderAdapter 将 SAX2 XMLReader 适配为 SAX1 解析器。

返回 ContentHandler 的 org.xml.sax.helpers 中的方法
ContentHandler | ParserAdapter.getContentHandler() 返回当前内容处理程序。
ContentHandler | XMLFilterImpl.getContentHandler() 获取内容事件处理程序。

参数类型为 ContentHandler 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.setContentHandler(ContentHandler handler) 设置内容处理程序。
void | XMLFilterImpl.setContentHandler(ContentHandler handler) 设置内容事件处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.DocumentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.DocumentHandler
的使用

使用 DocumentHandler 的软件包
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

org.xml.sax 中 DocumentHandler 的使用

实现 DocumentHandler 的 org.xml.sax 中的类
 class HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

参数类型为 DocumentHandler 的 org.xml.sax 中的方法
 void Parser.setDocumentHandler(DocumentHandler handler)
已过时。 允许应用程序注册文档事件处理程序。

org.xml.sax.helpers 中 DocumentHandler 的使用

实现 DocumentHandler 的 org.xml.sax.helpers 中的类
 class ParserAdapter
将 SAX1 Parser 适配为 SAX2 XMLReader。

参数类型为 DocumentHandler 的 org.xml.sax.helpers 中的方法
 void XMLReaderAdapter.setDocumentHandler(DocumentHandler handler)
注册 SAX1 文档事件处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.DTDHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.DTDHandler
的使用

使用 DTDHandler 的软件包
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.transform.sax 中 DTDHandler 的使用

javax.xml.transform.sax 中 DTDHandler 的子接口
 interface TransformerHandler
侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。

org.xml.sax 中 DTDHandler 的使用

实现 DTDHandler 的 org.xml.sax 中的类
 class HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

返回 DTDHandler 的 org.xml.sax 中的方法
 DTDHandler XMLReader.getDTDHandler()
返回当前的 DTD 处理程序。

参数类型为 DTDHandler 的 org.xml.sax 中的方法
void | Parser.setDTDHandler(DTDHandler handler) 已过时。 允许应用程序注册 DTD 事件处理程序。
void | XMLReader.setDTDHandler(DTDHandler handler) 允许应用程序注册 DTD 事件处理程序。

org.xml.sax.ext 中 DTDHandler 的使用

实现 DTDHandler 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

org.xml.sax.helpers 中 DTDHandler 的使用

实现 DTDHandler 的 org.xml.sax.helpers 中的类
class | DefaultHandler SAX2 事件处理程序的默认基类。
class | XMLFilterImpl 派生 XML 过滤器的基类。

返回 DTDHandler 的 org.xml.sax.helpers 中的方法
DTDHandler | ParserAdapter.getDTDHandler() 返回当前 DTD 处理程序。
DTDHandler | XMLFilterImpl.getDTDHandler() 获取当前 DTD 事件处理程序。

参数类型为 DTDHandler 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.setDTDHandler(DTDHandler handler) 设置 DTD 处理程序。
void | XMLFilterImpl.setDTDHandler(DTDHandler handler) 设置 DTD 事件处理程序。
void | XMLReaderAdapter.setDTDHandler(DTDHandler handler) 注册 DTD 事件处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.EntityResolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.EntityResolver
的使用

使用 EntityResolver 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.parsers 中 EntityResolver 的使用

参数类型为 EntityResolver 的 javax.xml.parsers 中的方法
abstract  void DocumentBuilder.setEntityResolver(EntityResolver er)
指定使用 EntityResolver 解析要解析的 XML 文档中存在的实体。

org.xml.sax 中 EntityResolver 的使用

实现 EntityResolver 的 org.xml.sax 中的类
 class HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

返回 EntityResolver 的 org.xml.sax 中的方法
 EntityResolver XMLReader.getEntityResolver()
返回当前的实体解析器。

参数类型为 EntityResolver 的 org.xml.sax 中的方法
void | Parser.setEntityResolver(EntityResolver resolver) 已过时。 允许应用程序注册自定义的实体解析器。
void | XMLReader.setEntityResolver(EntityResolver resolver) 允许应用程序注册实体解析器。

org.xml.sax.ext 中 EntityResolver 的使用

org.xml.sax.ext 中 EntityResolver 的子接口
 interface EntityResolver2
扩展的接口，用于将外部实体引用映射到输入源，或用于提供缺少的外部子集。

实现 EntityResolver 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

org.xml.sax.helpers 中 EntityResolver 的使用

实现 EntityResolver 的 org.xml.sax.helpers 中的类
class | DefaultHandler SAX2 事件处理程序的默认基类。
class | XMLFilterImpl 派生 XML 过滤器的基类。

返回 EntityResolver 的 org.xml.sax.helpers 中的方法
EntityResolver | ParserAdapter.getEntityResolver() 返回当前实体解析器。
EntityResolver | XMLFilterImpl.getEntityResolver() 获取当前实体解析器。

参数类型为 EntityResolver 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.setEntityResolver(EntityResolver resolver) 设置实体解析器。
void | XMLFilterImpl.setEntityResolver(EntityResolver resolver) 设置实体解析器。
void | XMLReaderAdapter.setEntityResolver(EntityResolver resolver) 注册实体解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.ErrorHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ErrorHandler
的使用

使用 ErrorHandler 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.parsers 中 ErrorHandler 的使用

参数类型为 ErrorHandler 的 javax.xml.parsers 中的方法
abstract  void DocumentBuilder.setErrorHandler(ErrorHandler eh)
指定解析器要使用的 ErrorHandler。

javax.xml.validation 中 ErrorHandler 的使用

返回 ErrorHandler 的 javax.xml.validation 中的方法
abstract ErrorHandler | SchemaFactory.getErrorHandler() 获取设置为此 SchemaFactory 的当前 ErrorHandler。
abstract ErrorHandler | Validator.getErrorHandler() 获取设置为此 Validator 的当前 ErrorHandler。
abstract ErrorHandler | ValidatorHandler.getErrorHandler() 获取设置为此 ValidatorHandler 的当前 ErrorHandler。

参数类型为 ErrorHandler 的 javax.xml.validation 中的方法
abstract void | SchemaFactory.setErrorHandler(ErrorHandler errorHandler) 设置 ErrorHandler 以接收在 newSchema 方法调用期间遇到的错误。
abstract void | Validator.setErrorHandler(ErrorHandler errorHandler) 设置 ErrorHandler 以接收在 validate 方法调用期间遇到的错误。
abstract void | ValidatorHandler.setErrorHandler(ErrorHandler errorHandler) 设置 ErrorHandler 以接收验证期间遇到的错误。

org.xml.sax 中 ErrorHandler 的使用

实现 ErrorHandler 的 org.xml.sax 中的类
 class HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

返回 ErrorHandler 的 org.xml.sax 中的方法
 ErrorHandler XMLReader.getErrorHandler()
返回当前的错误处理程序。

参数类型为 ErrorHandler 的 org.xml.sax 中的方法
void | Parser.setErrorHandler(ErrorHandler handler) 已过时。 允许应用程序注册错误事件处理程序。
void | XMLReader.setErrorHandler(ErrorHandler handler) 允许应用程序注册错误事件处理程序。

org.xml.sax.ext 中 ErrorHandler 的使用

实现 ErrorHandler 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

org.xml.sax.helpers 中 ErrorHandler 的使用

实现 ErrorHandler 的 org.xml.sax.helpers 中的类
class | DefaultHandler SAX2 事件处理程序的默认基类。
class | XMLFilterImpl 派生 XML 过滤器的基类。

返回 ErrorHandler 的 org.xml.sax.helpers 中的方法
ErrorHandler | ParserAdapter.getErrorHandler() 返回当前错误处理程序。
ErrorHandler | XMLFilterImpl.getErrorHandler() 获取当前错误事件处理程序。

参数类型为 ErrorHandler 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.setErrorHandler(ErrorHandler handler) 设置错误处理程序。
void | XMLFilterImpl.setErrorHandler(ErrorHandler handler) 设置错误事件处理程序。
void | XMLReaderAdapter.setErrorHandler(ErrorHandler handler) 注册错误事件处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.HandlerBase 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.HandlerBase
的使用

使用 HandlerBase 的软件包
javax.xml.parsers 提供允许处理 XML 文档的类。

javax.xml.parsers 中 HandlerBase 的使用

参数类型为 HandlerBase 的 javax.xml.parsers 中的方法
void | SAXParser.parse(File f, HandlerBase hb) 使用指定的 HandlerBase 将指定文件的内容解析为 XML。
void | SAXParser.parse(InputSource is, HandlerBase hb) 使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb, String systemId) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(String uri, HandlerBase hb) 使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.InputSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.InputSource
的使用

使用 InputSource 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind 中 InputSource 的使用

参数类型为 InputSource 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(InputSource source)
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 InputSource 的使用

参数类型为 InputSource 的 javax.xml.bind.helpers 中的方法
Object | AbstractUnmarshallerImpl.unmarshal(InputSource source)
protected abstract Object | AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source) 使用指定的 XMLReader 和 InputSource 解组对象。

javax.xml.parsers 中 InputSource 的使用

参数类型为 InputSource 的 javax.xml.parsers 中的方法
abstract Document | DocumentBuilder.parse(InputSource is) 将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputSource is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
void | SAXParser.parse(InputSource is, HandlerBase hb) 使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。

javax.xml.transform.sax 中 InputSource 的使用

返回 InputSource 的 javax.xml.transform.sax 中的方法
InputSource | SAXSource.getInputSource() 获取要用于 Source 的 SAX InputSource。
static InputSource | SAXSource.sourceToInputSource(Source source) 尝试从 Source 对象获取 SAX InputSource 对象。

参数类型为 InputSource 的 javax.xml.transform.sax 中的方法
 void SAXSource.setInputSource(InputSource inputSource)
设置要用于 Source 的 SAX InputSource。

参数类型为 InputSource 的 javax.xml.transform.sax 中的构造方法
SAXSource(InputSource inputSource)
使用 SAX InputSource，创建 SAXSource。
SAXSource(XMLReader reader, InputSource inputSource)
使用 XMLReader 和 SAX InputSource 创建 SAXSource。

javax.xml.xpath 中 InputSource 的使用

参数类型为 InputSource 的 javax.xml.xpath 中的方法
String | XPathExpression.evaluate(InputSource source) 计算指定 InputSource 上下文中编译后的 XPath 表达式并以 String 形式返回结果。
Object | XPathExpression.evaluate(InputSource source, QName returnType) 计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。
String | XPath.evaluate(String expression, InputSource source) 计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。
Object | XPath.evaluate(String expression, InputSource source, QName returnType) 计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。

org.xml.sax 中 InputSource 的使用

返回 InputSource 的 org.xml.sax 中的方法
InputSource | HandlerBase.resolveEntity(String publicId, String systemId) 已过时。 解析外部实体。
InputSource | EntityResolver.resolveEntity(String publicId, String systemId) 允许应用程序解析外部实体。

参数类型为 InputSource 的 org.xml.sax 中的方法
void | Parser.parse(InputSource source) 已过时。 解析 XML 文档。
void | XMLReader.parse(InputSource input) 解析 XML 文档。

org.xml.sax.ext 中 InputSource 的使用

返回 InputSource 的 org.xml.sax.ext 中的方法
 InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。
 InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
允许应用程序为不能显式定义外部子集的文档提供外部子集。
 InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。
 InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。
 InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。

org.xml.sax.helpers 中 InputSource 的使用

返回 InputSource 的 org.xml.sax.helpers 中的方法
InputSource | DefaultHandler.resolveEntity(String publicId, String systemId) 解析外部实体。
InputSource | XMLFilterImpl.resolveEntity(String publicId, String systemId) 过滤一个外部实体解析。

参数类型为 InputSource 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.parse(InputSource input) 解析 XML 文档。
void | XMLFilterImpl.parse(InputSource input) 解析一个文档。
void | XMLReaderAdapter.parse(InputSource input) 解析文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.Locator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.Locator
的使用

使用 Locator 的软件包
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind.helpers 中 Locator 的使用

参数类型为 Locator 的 javax.xml.bind.helpers 中的构造方法
ValidationEventLocatorImpl(Locator loc)
根据 org.xml.sax.Locator 构造一个对象。

org.xml.sax 中 Locator 的使用

参数类型为 Locator 的 org.xml.sax 中的方法
void | ContentHandler.setDocumentLocator(Locator locator) 接收用来查找 SAX 文档事件起源的对象。
void | DocumentHandler.setDocumentLocator(Locator locator) 已过时。 接收用来查找 SAX 文档事件起源的对象。
void | HandlerBase.setDocumentLocator(Locator locator) 已过时。 接收文档事件的 Locator 对象。

参数类型为 Locator 的 org.xml.sax 中的构造方法
SAXParseException(String message, Locator locator)
从消息和 Locator 创建新的 SAXParseException。
SAXParseException(String message, Locator locator, Exception e)
将现有的异常包装在 SAXParseException 中。

org.xml.sax.ext 中 Locator 的使用

org.xml.sax.ext 中 Locator 的子接口
 interface Locator2
SAX2 扩展，用于扩充通过 Locator 提供的实体信息。

实现 Locator 的 org.xml.sax.ext 中的类
 class Locator2Impl
用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。

参数类型为 Locator 的 org.xml.sax.ext 中的构造方法
Locator2Impl(Locator locator)
复制现有 Locator 或 Locator2 对象。

org.xml.sax.helpers 中 Locator 的使用

实现 Locator 的 org.xml.sax.helpers 中的类
 class LocatorImpl
提供 Locator 的可选的有用实现。

参数类型为 Locator 的 org.xml.sax.helpers 中的方法
void | DefaultHandler.setDocumentLocator(Locator locator) 接收文档事件的 Locator 对象。
void | ParserAdapter.setDocumentLocator(Locator locator) 适配器实现方法；不调用。
void | XMLFilterImpl.setDocumentLocator(Locator locator) 过滤一个新的文档定位器事件。
void | XMLReaderAdapter.setDocumentLocator(Locator locator) 设置文档定位器。

参数类型为 Locator 的 org.xml.sax.helpers 中的构造方法
LocatorImpl(Locator locator)
复制构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.Parser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.Parser
的使用

使用 Parser 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.parsers 中 Parser 的使用

返回 Parser 的 javax.xml.parsers 中的方法
abstract  Parser SAXParser.getParser()
返回由此类的实现封装的 SAX 解析器。

org.xml.sax.helpers 中 Parser 的使用

实现 Parser 的 org.xml.sax.helpers 中的类
 class XMLReaderAdapter
将 SAX2 XMLReader 适配为 SAX1 解析器。

返回 Parser 的 org.xml.sax.helpers 中的方法
static Parser | ParserFactory.makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | ParserFactory.makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

参数类型为 Parser 的 org.xml.sax.helpers 中的构造方法
ParserAdapter(Parser parser)
构造一个新的解析器适配器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.SAXException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.SAXException
的使用

使用 SAXException 的软件包
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind.helpers 中 SAXException 的使用

参数类型为 SAXException 的 javax.xml.bind.helpers 中的方法
protected  UnmarshalException AbstractUnmarshallerImpl.createUnmarshalException(SAXException e)
从 SAXException 创建 UnmarshalException。

javax.xml.parsers 中 SAXException 的使用

抛出 SAXException 的 javax.xml.parsers 中的方法
abstract Parser | SAXParser.getParser() 返回由此类的实现封装的 SAX 解析器。
abstract XMLReader | SAXParser.getXMLReader() 返回由此类的实现封装的 XMLReader。
abstract SAXParser | SAXParserFactory.newSAXParser() 使用当前配置的工厂参数创建 SAXParser 的一个新实例。
Document | DocumentBuilder.parse(File f) 将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(File f, DefaultHandler dh) 使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
void | SAXParser.parse(File f, HandlerBase hb) 使用指定的 HandlerBase 将指定文件的内容解析为 XML。
abstract Document | DocumentBuilder.parse(InputSource is) 将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputSource is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
void | SAXParser.parse(InputSource is, HandlerBase hb) 使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。
Document | DocumentBuilder.parse(InputStream is) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputStream is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, DefaultHandler dh, String systemId) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb, String systemId) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
Document | DocumentBuilder.parse(InputStream is, String systemId) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | DocumentBuilder.parse(String uri) 将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(String uri, DefaultHandler dh) 使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。
void | SAXParser.parse(String uri, HandlerBase hb) 使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

javax.xml.validation 中 SAXException 的使用

抛出 SAXException 的 javax.xml.validation 中的方法
abstract Schema | SchemaFactory.newSchema() 创建特殊的 Schema 对象。
Schema | SchemaFactory.newSchema(File schema) 解析作为模式的指定 File 并以 Schema 的形式返回它。
Schema | SchemaFactory.newSchema(Source schema) 解析作为模式的指定源并以模式形式返回它。
abstract Schema | SchemaFactory.newSchema(Source[] schemas) 解析作为模式的指定源（或多个源），并以模式形式返回它。
Schema | SchemaFactory.newSchema(URL schema) 解析作为模式的指定 URL 并以 Schema 形式返回它。
void | Validator.validate(Source source) 验证指定的输入。
abstract void | Validator.validate(Source source, Result result) 验证指定输入并将扩充的验证结果发送到指定输出。

org.xml.sax 中 SAXException 的使用

org.xml.sax 中 SAXException 的子类
class | SAXNotRecognizedException 用于未识别的标识符的 Exception 类。
class | SAXNotSupportedException 用于不被支持的操作的 Exception 类。
class | SAXParseException 封装 XML 解析错误或警告。

抛出 SAXException 的 org.xml.sax 中的方法
void | ContentHandler.characters(char[] ch, int start, int length) 接收字符数据的通知。
void | DocumentHandler.characters(char[] ch, int start, int length) 已过时。 接收字符数据的通知。
void | HandlerBase.characters(char[] ch, int start, int length) 已过时。 接收元素内字符数据的通知。
void | ContentHandler.endDocument() 接收文档的结尾的通知。
void | DocumentHandler.endDocument() 已过时。 接收文档结束的通知。
void | HandlerBase.endDocument() 已过时。 接收文档结束的通知。
void | DocumentHandler.endElement(String name) 已过时。 接收元素结束的通知。
void | HandlerBase.endElement(String name) 已过时。 接收元素结束的通知。
void | ContentHandler.endElement(String uri, String localName, String qName) 接收元素结束的通知。
void | ContentHandler.endPrefixMapping(String prefix) 结束前缀 URI 范围的映射。
void | HandlerBase.error(SAXParseException e) 已过时。 接收可恢复的解析器错误的通知。
void | ErrorHandler.error(SAXParseException exception) 接收可恢复的错误的通知。
void | HandlerBase.fatalError(SAXParseException e) 已过时。 报告严重的 XML 解析错误。
void | ErrorHandler.fatalError(SAXParseException exception) 接收不可恢复的错误的通知。
void | ContentHandler.ignorableWhitespace(char[] ch, int start, int length) 接收元素内容中可忽略的空白的通知。
void | DocumentHandler.ignorableWhitespace(char[] ch, int start, int length) 已过时。 接收元素内容中可忽略的空白的通知。
void | HandlerBase.ignorableWhitespace(char[] ch, int start, int length) 已过时。 接收元素内容中可忽略的空白的通知。
void | DTDHandler.notationDecl(String name, String publicId, String systemId) 接收注释声明事件的通知。
void | Parser.parse(InputSource source) 已过时。 解析 XML 文档。
void | XMLReader.parse(InputSource input) 解析 XML 文档。
void | Parser.parse(String systemId) 已过时。 从系统标识符 (URI) 解析 XML 文档。
void | XMLReader.parse(String systemId) 从系统标识符 (URI) 解析 XML 文档。
void | ContentHandler.processingInstruction(String target, String data) 接收处理指令的通知。
void | DocumentHandler.processingInstruction(String target, String data) 已过时。 接收处理指令的通知。
void | HandlerBase.processingInstruction(String target, String data) 已过时。 接收处理指令的通知。
InputSource | HandlerBase.resolveEntity(String publicId, String systemId) 已过时。 解析外部实体。
InputSource | EntityResolver.resolveEntity(String publicId, String systemId) 允许应用程序解析外部实体。
void | Parser.setLocale(Locale locale) 已过时。 允许应用程序请求错误和警告的环境。
void | ContentHandler.skippedEntity(String name) 接收跳过的实体的通知。
void | ContentHandler.startDocument() 接收文档的开始的通知。
void | DocumentHandler.startDocument() 已过时。 接收文档的开始的通知。
void | HandlerBase.startDocument() 已过时。 接收文档开始的通知。
void | DocumentHandler.startElement(String name, AttributeList atts) 已过时。 接收元素开始的通知。
void | HandlerBase.startElement(String name, AttributeList attributes) 已过时。 接收元素开始的通知。
void | ContentHandler.startElement(String uri, String localName, String qName, Attributes atts) 接收元素开始的通知。
void | ContentHandler.startPrefixMapping(String prefix, String uri) 开始前缀 URI 名称空间范围映射。
void | DTDHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName) 接收未解析的实体声明事件的通知。
void | HandlerBase.warning(SAXParseException e) 已过时。 接收解析器警告的通知。
void | ErrorHandler.warning(SAXParseException exception) 接收警告的通知。

org.xml.sax.ext 中 SAXException 的使用

抛出 SAXException 的 org.xml.sax.ext 中的方法
 void DeclHandler.attributeDecl(String eName, String aName, String type, String mode, String value)
报告属性类型声明。
 void DefaultHandler2.attributeDecl(String eName, String aName, String type, String mode, String value)
 void DefaultHandler2.comment(char[] ch, int start, int length)
 void LexicalHandler.comment(char[] ch, int start, int length)
报告文档的任何位置的 XML 注释。
 void DeclHandler.elementDecl(String name, String model)
报告元素类型声明。
 void DefaultHandler2.elementDecl(String name, String model)
 void DefaultHandler2.endCDATA()
 void LexicalHandler.endCDATA()
报告 CDATA 节的结束。
 void DefaultHandler2.endDTD()
 void LexicalHandler.endDTD()
报告 DTD 声明的结束。
 void DefaultHandler2.endEntity(String name)
 void LexicalHandler.endEntity(String name)
报告实体的结束。
 void DeclHandler.externalEntityDecl(String name, String publicId, String systemId)
报告解析的外部实体声明。
 void DefaultHandler2.externalEntityDecl(String name, String publicId, String systemId)
 InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。
 InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
允许应用程序为不能显式定义外部子集的文档提供外部子集。
 void DeclHandler.internalEntityDecl(String name, String value)
报告内部实体声明。
 void DefaultHandler2.internalEntityDecl(String name, String value)
 InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。
 InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。
 InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。
 void DefaultHandler2.startCDATA()
 void LexicalHandler.startCDATA()
报告 CDATA 节的开始。
 void DefaultHandler2.startDTD(String name, String publicId, String systemId)
 void LexicalHandler.startDTD(String name, String publicId, String systemId)
报告 DTD 声明的开始（如果存在）。
 void DefaultHandler2.startEntity(String name)
 void LexicalHandler.startEntity(String name)
报告一些内部和外部 XML 实体的开始。

org.xml.sax.helpers 中 SAXException 的使用

抛出 SAXException 的 org.xml.sax.helpers 中的方法
void | DefaultHandler.characters(char[] ch, int start, int length) 接收元素中字符数据的通知。
void | ParserAdapter.characters(char[] ch, int start, int length) 适配器实现方法；不调用。
void | XMLFilterImpl.characters(char[] ch, int start, int length) 过滤一个字符数据事件。
void | XMLReaderAdapter.characters(char[] ch, int start, int length) 适配 SAX2 字符事件。
static XMLReader | XMLReaderFactory.createXMLReader() 尝试从系统默认值创建一个 XMLReader。
static XMLReader | XMLReaderFactory.createXMLReader(String className) 尝试从类名称创建一个 XML 阅读器。
void | DefaultHandler.endDocument() 接收文档结束的通知。
void | ParserAdapter.endDocument() 适配器实现方法；不调用。
void | XMLFilterImpl.endDocument() 过滤一个结束文档事件。
void | XMLReaderAdapter.endDocument() 结束文档事件。
void | ParserAdapter.endElement(String qName) 适配器实现方法；不调用。
void | DefaultHandler.endElement(String uri, String localName, String qName) 接收元素结束的通知。
void | XMLFilterImpl.endElement(String uri, String localName, String qName) 过滤一个结束元素事件。
void | XMLReaderAdapter.endElement(String uri, String localName, String qName) 适配 SAX2 结束元素事件。
void | DefaultHandler.endPrefixMapping(String prefix) 接收名称空间映射结束的通知。
void | XMLFilterImpl.endPrefixMapping(String prefix) 过滤一个结束名称空间前缀映射事件。
void | DefaultHandler.error(SAXParseException e) 接收可恢复的解析器错误的通知。
void | XMLFilterImpl.error(SAXParseException e) 过滤一个错误事件。
void | DefaultHandler.fatalError(SAXParseException e) 报告严重的 XML 解析错误。
void | XMLFilterImpl.fatalError(SAXParseException e) 过滤一个严重的错误事件。
void | DefaultHandler.ignorableWhitespace(char[] ch, int start, int length) 接收元素内容中可忽略空白的通知。
void | ParserAdapter.ignorableWhitespace(char[] ch, int start, int length) 适配器实现方法；不调用。
void | XMLFilterImpl.ignorableWhitespace(char[] ch, int start, int length) 过滤一个可忽略空格的事件。
void | XMLReaderAdapter.ignorableWhitespace(char[] ch, int start, int length) 适配 SAX2 忽略空白事件。
void | DefaultHandler.notationDecl(String name, String publicId, String systemId) 接收注释声明的通知。
void | XMLFilterImpl.notationDecl(String name, String publicId, String systemId) 过滤一个注释声明事件。
void | ParserAdapter.parse(InputSource input) 解析 XML 文档。
void | XMLFilterImpl.parse(InputSource input) 解析一个文档。
void | XMLReaderAdapter.parse(InputSource input) 解析文档。
void | ParserAdapter.parse(String systemId) 解析 XML 文档。
void | XMLFilterImpl.parse(String systemId) 解析一个文档。
void | XMLReaderAdapter.parse(String systemId) 解析文档。
void | DefaultHandler.processingInstruction(String target, String data) 接收处理指令的通知。
void | ParserAdapter.processingInstruction(String target, String data) 适配器实现方法；不调用。
void | XMLFilterImpl.processingInstruction(String target, String data) 过滤一个处理指令事件。
void | XMLReaderAdapter.processingInstruction(String target, String data) 适配 SAX2 处理指令事件。
InputSource | DefaultHandler.resolveEntity(String publicId, String systemId) 解析外部实体。
InputSource | XMLFilterImpl.resolveEntity(String publicId, String systemId) 过滤一个外部实体解析。
void | XMLReaderAdapter.setLocale(Locale locale) 设置错误报告的语言环境。
void | DefaultHandler.skippedEntity(String name) 接收跳过的实体的通知。
void | XMLFilterImpl.skippedEntity(String name) 过滤一个跳过的实体事件。
void | XMLReaderAdapter.skippedEntity(String name) 适配 SAX2 跳过的实体事件。
void | DefaultHandler.startDocument() 接收文档开始的通知。
void | ParserAdapter.startDocument() 适配器实现方法；不调用。
void | XMLFilterImpl.startDocument() 过滤一个开始文档事件。
void | XMLReaderAdapter.startDocument() 开始文档事件。
void | ParserAdapter.startElement(String qName, AttributeList qAtts) 适配器实现方法；不调用。
void | DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes) 接收元素开始的通知。
void | XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts) 过滤一个开始元素事件。
void | XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts) 适配 SAX2 开始元素事件。
void | DefaultHandler.startPrefixMapping(String prefix, String uri) 接收名称空间映射开始的通知。
void | XMLFilterImpl.startPrefixMapping(String prefix, String uri) 过滤一个开始名称空间前缀映射事件。
void | DefaultHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName) 接收未解析实体声明的通知。
void | XMLFilterImpl.unparsedEntityDecl(String name, String publicId, String systemId, String notationName) 过滤一个未解析实体声明事件。
void | DefaultHandler.warning(SAXParseException e) 接收解析器警告的通知。
void | XMLFilterImpl.warning(SAXParseException e) 过滤一个警告事件。

抛出 SAXException 的 org.xml.sax.helpers 中的构造方法
ParserAdapter()
构造一个新解析器适配器。
XMLReaderAdapter()
创建一个新的适配器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.SAXNotRecognizedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.SAXNotRecognizedException
的使用

使用 SAXNotRecognizedException 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.parsers 中 SAXNotRecognizedException 的使用

抛出 SAXNotRecognizedException 的 javax.xml.parsers 中的方法
abstract boolean | SAXParserFactory.getFeature(String name) 返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。
abstract Object | SAXParser.getProperty(String name) 返回 XMLReader 的底层实现中请求的特定属性。
abstract void | SAXParserFactory.setFeature(String name, boolean value) 在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。
abstract void | SAXParser.setProperty(String name, Object value) 设置 XMLReader 的底层实现中的特定属性。

javax.xml.validation 中 SAXNotRecognizedException 的使用

抛出 SAXNotRecognizedException 的 javax.xml.validation 中的方法
boolean | SchemaFactory.getFeature(String name) 查找功能标志的值。
boolean | Validator.getFeature(String name) 查找功能标志的值。
boolean | ValidatorHandler.getFeature(String name) 查找特性标志的值。
Object | SchemaFactory.getProperty(String name) 查找属性值。
Object | Validator.getProperty(String name) 查找属性值。
Object | ValidatorHandler.getProperty(String name) 查找属性值。
void | SchemaFactory.setFeature(String name, boolean value) 设置此 SchemaFactory 的特性，Schema 由此工厂创建，更进一步说，Validator 和 ValidatorHandler 由这些 Schema 创建。
void | Validator.setFeature(String name, boolean value) 设置功能标志的值。
void | ValidatorHandler.setFeature(String name, boolean value) 设置此 ValidatorHandler 的特性。
void | SchemaFactory.setProperty(String name, Object object) 设置属性值。
void | Validator.setProperty(String name, Object object) 设置属性值。
void | ValidatorHandler.setProperty(String name, Object object) 设置属性值。

org.xml.sax 中 SAXNotRecognizedException 的使用

抛出 SAXNotRecognizedException 的 org.xml.sax 中的方法
boolean | XMLReader.getFeature(String name) 查找功能标志的值。
Object | XMLReader.getProperty(String name) 查找属性的值。
void | XMLReader.setFeature(String name, boolean value) 设置功能标志的值。
void | XMLReader.setProperty(String name, Object value) 设置属性的值。

org.xml.sax.helpers 中 SAXNotRecognizedException 的使用

抛出 SAXNotRecognizedException 的 org.xml.sax.helpers 中的方法
boolean | ParserAdapter.getFeature(String name) 检查解析器功能标志。
boolean | XMLFilterImpl.getFeature(String name) 查找功能值。
Object | ParserAdapter.getProperty(String name) 获取解析器属性。
Object | XMLFilterImpl.getProperty(String name) 查找属性值。
void | ParserAdapter.setFeature(String name, boolean value) 为解析器设置功能标志。
void | XMLFilterImpl.setFeature(String name, boolean value) 设置功能的值。
void | ParserAdapter.setProperty(String name, Object value) 设置解析器属性。
void | XMLFilterImpl.setProperty(String name, Object value) 设置属性值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.SAXNotSupportedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.SAXNotSupportedException
的使用

使用 SAXNotSupportedException 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.parsers 中 SAXNotSupportedException 的使用

抛出 SAXNotSupportedException 的 javax.xml.parsers 中的方法
abstract boolean | SAXParserFactory.getFeature(String name) 返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。
abstract Object | SAXParser.getProperty(String name) 返回 XMLReader 的底层实现中请求的特定属性。
abstract void | SAXParserFactory.setFeature(String name, boolean value) 在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。
abstract void | SAXParser.setProperty(String name, Object value) 设置 XMLReader 的底层实现中的特定属性。

javax.xml.validation 中 SAXNotSupportedException 的使用

抛出 SAXNotSupportedException 的 javax.xml.validation 中的方法
boolean | SchemaFactory.getFeature(String name) 查找功能标志的值。
boolean | Validator.getFeature(String name) 查找功能标志的值。
boolean | ValidatorHandler.getFeature(String name) 查找特性标志的值。
Object | SchemaFactory.getProperty(String name) 查找属性值。
Object | Validator.getProperty(String name) 查找属性值。
Object | ValidatorHandler.getProperty(String name) 查找属性值。
void | SchemaFactory.setFeature(String name, boolean value) 设置此 SchemaFactory 的特性，Schema 由此工厂创建，更进一步说，Validator 和 ValidatorHandler 由这些 Schema 创建。
void | Validator.setFeature(String name, boolean value) 设置功能标志的值。
void | ValidatorHandler.setFeature(String name, boolean value) 设置此 ValidatorHandler 的特性。
void | SchemaFactory.setProperty(String name, Object object) 设置属性值。
void | Validator.setProperty(String name, Object object) 设置属性值。
void | ValidatorHandler.setProperty(String name, Object object) 设置属性值。

org.xml.sax 中 SAXNotSupportedException 的使用

抛出 SAXNotSupportedException 的 org.xml.sax 中的方法
boolean | XMLReader.getFeature(String name) 查找功能标志的值。
Object | XMLReader.getProperty(String name) 查找属性的值。
void | XMLReader.setFeature(String name, boolean value) 设置功能标志的值。
void | XMLReader.setProperty(String name, Object value) 设置属性的值。

org.xml.sax.helpers 中 SAXNotSupportedException 的使用

抛出 SAXNotSupportedException 的 org.xml.sax.helpers 中的方法
boolean | ParserAdapter.getFeature(String name) 检查解析器功能标志。
boolean | XMLFilterImpl.getFeature(String name) 查找功能值。
Object | ParserAdapter.getProperty(String name) 获取解析器属性。
Object | XMLFilterImpl.getProperty(String name) 查找属性值。
void | ParserAdapter.setFeature(String name, boolean value) 为解析器设置功能标志。
void | XMLFilterImpl.setFeature(String name, boolean value) 设置功能的值。
void | ParserAdapter.setProperty(String name, Object value) 设置解析器属性。
void | XMLFilterImpl.setProperty(String name, Object value) 设置属性值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.SAXParseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.SAXParseException
的使用

使用 SAXParseException 的软件包
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind.helpers 中 SAXParseException 的使用

参数类型为 SAXParseException 的 javax.xml.bind.helpers 中的构造方法
ValidationEventLocatorImpl(SAXParseException e)
根据 SAXParseException 的位置信息构造一个对象。

org.xml.sax 中 SAXParseException 的使用

参数类型为 SAXParseException 的 org.xml.sax 中的方法
void | HandlerBase.error(SAXParseException e) 已过时。 接收可恢复的解析器错误的通知。
void | ErrorHandler.error(SAXParseException exception) 接收可恢复的错误的通知。
void | HandlerBase.fatalError(SAXParseException e) 已过时。 报告严重的 XML 解析错误。
void | ErrorHandler.fatalError(SAXParseException exception) 接收不可恢复的错误的通知。
void | HandlerBase.warning(SAXParseException e) 已过时。 接收解析器警告的通知。
void | ErrorHandler.warning(SAXParseException exception) 接收警告的通知。

org.xml.sax.helpers 中 SAXParseException 的使用

参数类型为 SAXParseException 的 org.xml.sax.helpers 中的方法
void | DefaultHandler.error(SAXParseException e) 接收可恢复的解析器错误的通知。
void | XMLFilterImpl.error(SAXParseException e) 过滤一个错误事件。
void | DefaultHandler.fatalError(SAXParseException e) 报告严重的 XML 解析错误。
void | XMLFilterImpl.fatalError(SAXParseException e) 过滤一个严重的错误事件。
void | DefaultHandler.warning(SAXParseException e) 接收解析器警告的通知。
void | XMLFilterImpl.warning(SAXParseException e) 过滤一个警告事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.XMLFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.XMLFilter
的使用

使用 XMLFilter 的软件包
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.transform.sax 中 XMLFilter 的使用

返回 XMLFilter 的 javax.xml.transform.sax 中的方法
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Source src) 创建使用给定 Source 作为转换指令的 XMLFilter。
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Templates templates) 基于 Templates 参数，创建 XMLFilter。

org.xml.sax.helpers 中 XMLFilter 的使用

实现 XMLFilter 的 org.xml.sax.helpers 中的类
 class XMLFilterImpl
派生 XML 过滤器的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.XMLReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.XMLReader
的使用

使用 XMLReader 的软件包
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind.helpers 中 XMLReader 的使用

返回 XMLReader 的 javax.xml.bind.helpers 中的方法
protected  XMLReader AbstractUnmarshallerImpl.getXMLReader()
获取配置好的 XMLReader。

参数类型为 XMLReader 的 javax.xml.bind.helpers 中的方法
protected abstract  Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
使用指定的 XMLReader 和 InputSource 解组对象。

javax.xml.parsers 中 XMLReader 的使用

返回 XMLReader 的 javax.xml.parsers 中的方法
abstract  XMLReader SAXParser.getXMLReader()
返回由此类的实现封装的 XMLReader。

javax.xml.transform.sax 中 XMLReader 的使用

返回 XMLReader 的 javax.xml.transform.sax 中的方法
 XMLReader SAXSource.getXMLReader()
获取要用于 Source 的 XMLReader。

参数类型为 XMLReader 的 javax.xml.transform.sax 中的方法
 void SAXSource.setXMLReader(XMLReader reader)
设置要用于 Source 的 XMLReader。

参数类型为 XMLReader 的 javax.xml.transform.sax 中的构造方法
SAXSource(XMLReader reader, InputSource inputSource)
使用 XMLReader 和 SAX InputSource 创建 SAXSource。

org.xml.sax 中 XMLReader 的使用

org.xml.sax 中 XMLReader 的子接口
 interface XMLFilter
用于 XML 过滤器的接口。

返回 XMLReader 的 org.xml.sax 中的方法
 XMLReader XMLFilter.getParent()
获取父阅读器。

参数类型为 XMLReader 的 org.xml.sax 中的方法
 void XMLFilter.setParent(XMLReader parent)
设置父阅读器。

org.xml.sax.helpers 中 XMLReader 的使用

实现 XMLReader 的 org.xml.sax.helpers 中的类
class | ParserAdapter 将 SAX1 Parser 适配为 SAX2 XMLReader。
class | XMLFilterImpl 派生 XML 过滤器的基类。

返回 XMLReader 的 org.xml.sax.helpers 中的方法
static XMLReader | XMLReaderFactory.createXMLReader() 尝试从系统默认值创建一个 XMLReader。
static XMLReader | XMLReaderFactory.createXMLReader(String className) 尝试从类名称创建一个 XML 阅读器。
XMLReader | XMLFilterImpl.getParent() 获取父读取器。

参数类型为 XMLReader 的 org.xml.sax.helpers 中的方法
 void XMLFilterImpl.setParent(XMLReader parent)
设置父读取器。

参数类型为 XMLReader 的 org.xml.sax.helpers 中的构造方法
XMLFilterImpl(XMLReader parent)
构造一个带有特定父过滤器的 XML 过滤器。
XMLReaderAdapter(XMLReader xmlReader)
创建一个新的适配器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.xml.sax.ext (Java 2 Platform SE 6)

 org.xml.sax.ext
接口
Attributes2
DeclHandler
EntityResolver2
LexicalHandler
Locator2
类
Attributes2Impl
DefaultHandler2
Locator2Impl


接口 org.xml.sax.ext.Attributes2 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ext.Attributes2
的使用

使用 Attributes2 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 Attributes2 的使用

实现 Attributes2 的 org.xml.sax.ext 中的类
 class Attributes2Impl
用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.ext.Attributes2Impl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.ext.Attributes2Impl
的使用

没有 org.xml.sax.ext.Attributes2Impl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.ext.DeclHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ext.DeclHandler
的使用

使用 DeclHandler 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 DeclHandler 的使用

实现 DeclHandler 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.ext.DefaultHandler2 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.ext.DefaultHandler2
的使用

没有 org.xml.sax.ext.DefaultHandler2 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.ext.EntityResolver2 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ext.EntityResolver2
的使用

使用 EntityResolver2 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 EntityResolver2 的使用

实现 EntityResolver2 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.ext.LexicalHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ext.LexicalHandler
的使用

使用 LexicalHandler 的软件包
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

javax.xml.transform.sax 中 LexicalHandler 的使用

javax.xml.transform.sax 中 LexicalHandler 的子接口
 interface TransformerHandler
侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。

返回 LexicalHandler 的 javax.xml.transform.sax 中的方法
 LexicalHandler SAXResult.getLexicalHandler()
获取输出的 SAX2 LexicalHandler。

参数类型为 LexicalHandler 的 javax.xml.transform.sax 中的方法
 void SAXResult.setLexicalHandler(LexicalHandler handler)
设置输出的 SAX2 LexicalHandler。

org.xml.sax.ext 中 LexicalHandler 的使用

实现 LexicalHandler 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


接口 org.xml.sax.ext.Locator2 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ext.Locator2
的使用

使用 Locator2 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 Locator2 的使用

实现 Locator2 的 org.xml.sax.ext 中的类
 class Locator2Impl
用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.ext.Locator2Impl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.ext.Locator2Impl
的使用

没有 org.xml.sax.ext.Locator2Impl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


org.xml.sax.helpers (Java 2 Platform SE 6)

 org.xml.sax.helpers
类
AttributeListImpl
AttributesImpl
DefaultHandler
LocatorImpl
NamespaceSupport
ParserAdapter
ParserFactory
XMLFilterImpl
XMLReaderAdapter
XMLReaderFactory


类 org.xml.sax.helpers.AttributeListImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.AttributeListImpl
的使用

没有 org.xml.sax.helpers.AttributeListImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.helpers.AttributesImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.AttributesImpl
的使用

使用 AttributesImpl 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 AttributesImpl 的使用

org.xml.sax.ext 中 AttributesImpl 的子类
 class Attributes2Impl
用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.helpers.DefaultHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.DefaultHandler
的使用

使用 DefaultHandler 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

javax.xml.parsers 中 DefaultHandler 的使用

参数类型为 DefaultHandler 的 javax.xml.parsers 中的方法
void | SAXParser.parse(File f, DefaultHandler dh) 使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
void | SAXParser.parse(InputSource is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
void | SAXParser.parse(InputStream is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, DefaultHandler dh, String systemId) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(String uri, DefaultHandler dh) 使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

org.xml.sax.ext 中 DefaultHandler 的使用

org.xml.sax.ext 中 DefaultHandler 的子类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.helpers.LocatorImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.LocatorImpl
的使用

使用 LocatorImpl 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 LocatorImpl 的使用

org.xml.sax.ext 中 LocatorImpl 的子类
 class Locator2Impl
用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.helpers.NamespaceSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.NamespaceSupport
的使用

没有 org.xml.sax.helpers.NamespaceSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.helpers.ParserAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.ParserAdapter
的使用

没有 org.xml.sax.helpers.ParserAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.helpers.ParserFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.ParserFactory
的使用

没有 org.xml.sax.helpers.ParserFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.helpers.XMLFilterImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.XMLFilterImpl
的使用

没有 org.xml.sax.helpers.XMLFilterImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.helpers.XMLReaderAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.XMLReaderAdapter
的使用

没有 org.xml.sax.helpers.XMLReaderAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6


类 org.xml.sax.helpers.XMLReaderFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.XMLReaderFactory
的使用

没有 org.xml.sax.helpers.XMLReaderFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6